Development for Microsoft Dynamics CRM Online and on-premises (CRM SDK)

Welcome to the developer documentation for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update! You can read all the documentation online in the MSDN library or in the CHM file found in the download package. The download package also includes assemblies, developer tools, and a wide range of sample code and other resources. The download package is available here: Microsoft Dynamics CRM SDK.

In This Section

Software Development Kit for Microsoft Dynamics CRM

Find information for developers writing server side code, custom business logic, integration modules, workflow assemblies, and plug-ins. You'll see an architectural overview of Microsoft Dynamics CRM, the entity model, security model, and Web services. You'll find walkthroughs that help guide you through the new features. There are also many samples that demonstrate the features described in the SDK, and more are being added every month!

SDK extensions for Microsoft Dynamics CRM

Learn about extensions to the core SDK that offer additional capabilities and a different developer experience. Currently there are two: Developer Extensions and the Portal Development Toolkit. Developer Extensions are essentially a wrapper around the existing SDK assemblies, providing you with extra functionality on top of existing functionality. The Portal Development Toolkit allows you to create portal web pages that interact with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online
Send comments about this topic to Microsoft.
© 2015 Microsoft. All rights reserved.


Software Development Kit for Microsoft Dynamics CRM

Welcome to the Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update Software Development Kit (SDK). If you want to jump right in with writing .NET code, see Run a simple program using Microsoft Dynamics CRM web services and then read Write applications and server extensions. We welcome your feedback; use the feedback link at the bottom of this page.

This SDK contains a wealth of resources, including code samples, which are designed to help you build powerful vertical applications using the Microsoft Dynamics CRM platform. It is a guide for developers writing solutions, server-side code, client applications and extensions, custom business logic, plug-ins, integration modules, custom workflow modules and more. The SDK contains an architectural overview of Microsoft Dynamics CRM, the entity model, security model, web services, and sample code.

The code samples, tools, and other supporting files are located in the download package, available here: Microsoft Dynamics CRM SDK.

Before you use the Microsoft Dynamics CRM SDK, you should review Microsoft Dynamics CRM Online 2015 Update and Microsoft Dynamics CRM 2015 Readme.

You should also read Deploying and administering Microsoft Dynamics CRM , which is located on Microsoft TechNet, or is available for download. Detailed instructions for installing Microsoft Dynamics CRM 2015 for Microsoft Office Outlook, Microsoft Dynamics CRM Server 2015, and other related software are provided in this guide.

Please also review the following information: What's changing in the next release

Tip
You can print portions of the SDK documentation from the compiled help file (CHM). However, you should probably not include the Programming reference in your print job due to its size.

The search tab in the CHM file supports the use of wildcards. For example, searching for IOrg* will return all topics that refer to the IOrganizationService Web service.

Release date | Release information
SDK Version 7.0.1, March 2015 | Release history

In This Section

What's new for developers

Developer overview

Model your business data

Developer tools

Write mobile and modern apps

Write applications and server extensions

Write client application extensions

Write plug-ins to extend business processes

Write workflows to automate business processes

Developers guide to reports for Microsoft Dynamics CRM

Manage your data

Package and distribute extensions using solutions

Developers guide to customization for Microsoft Dynamics CRM

Extend Microsoft Dynamics CRM for Outlook

Integrate SharePoint with Microsoft Dynamics CRM

Advanced development

Sample code directory

Programming reference

Send Us Your Feedback

We appreciate hearing from you. To send your feedback, click the following link and type your comments in the message body. The subject-line information is used to route your feedback. If you remove or modify the subject line we may be unable to process your feedback. Send Feedback

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Release history
See Also

This is the release history page for the Software Development Kit (SDK) for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Current Version: 7.0.1, March 2015

In this topic

Release history for SDK Version 7.0.1, March 2015

Release history for SDK Version 7.0.0, December 2014

Note
Developer Toolkit for Microsoft Dynamics CRM is not included in this release of the SDK - Please refer to the CRM 2013 SDK for information about the Developer Toolkit for Microsoft Dynamics CRM 2013 and Microsoft Dynamics CRM Online. The CRM 2013 SDK is available for download: Microsoft Dynamics CRM Software Development Kit (SDK) for CRM Online and CRM 2013 (on-premises).

Release history for SDK Version 7.0.1, March 2015

The following table lists the significant changes made to this version of the SDK.

New and updated topics | Description of changes
SDK\Bin | Updated the assemblies for Microsoft Dynamics CRM 2015 Update Rollup 1. These assemblies are also compatible with Microsoft Dynamics CRM Online 2015 Update 0.1.
SDK\Solutions\PortalBase\MicrosoftXrmPortals_managed.zip | Added updated portal base solution that is compatible with Microsoft Dynamics CRM 2015.
<Url> (RibbonDiffXml) | Added to note in remarks saying that this element should not be used to open web resources.
ActivityParty entity | Removed invalid option for ActivityParty.ParticipationTypeMask. There is no option for Partner with a value of 12.
Browse the metadata for your organization SDK\Tools\MetadataBrowser\MetadataBrowser_2_0_1_2_managed.zip | Updated the Metadata Browser solution to address an issue when used with Google Chrome.
Introduction to solutions Maintain managed solutions | Updated the Version Compatibility sections in both topics to correctly describe compatibility of solutions between different versions of CRM.
Portal authentication | Updated the website registration URL.
Understand dashboards: Dashboard components and FormXML | Added content to specify that the maximum number of controls that may be displayed in a dashboard is 20.
Walkthrough: Build a console application that connects to Microsoft Dynamics CRM using developer extensions | Updated code and screenshots. Added information on NuGet packages.
Walkthrough: Build a web application that connects to Microsoft Dynamics CRM using developer extensions | Updated code and screenshots. Added information on NuGet packages.
Sample: Windows 8 desktop modern OData app Sample: Windows 8 desktop modern SOAP app | Updated to a Windows 8.1 app. Changed from an IFD specific sample to a CRM Online or IFD sample. Added authority discovery.
What's new for developers | Added content to highlight that the minimum .NET Framework version for building managed code applications, plug-ins, and custom workflow activities is now .NET 4.5.2

Release history for SDK Version 7.0.0, December 2014

The following table lists the significant changes made to this version of the SDK.

New and updated topics | Description of changes
Initial version | Start with What's new for developers.

See Also

Concepts

What's new for developers

Other Resources

Software Development Kit for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


What's new for developers

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update provide a single development environment for on-premises and cloud-based deployments. Partners, including independent software vendors, global system integrators, and value-added resellers, can quickly create, package, and distribute Microsoft Dynamics CRM extensions and custom solutions.

What’s new for CRM 2015 and CRM Online 2015 Update

Developers will be able to leverage the following enhancements and new capabilities in this release:

  • Product catalog enhancements
  • Use hierarchical data
  • Apply hierarchical security models
  • Use calculated and rollup attributes created in Dynamics CRM
  • Write form scripts that interact with business process flows
  • Use field-level security with system entities
  • Create business rules instead of writing code
  • Add custom help content
  • New service proxy classes for the web endpoint
  • New messages in the Organization web service
  • New messages in the Deployment web service
  • New entities
  • New privileges
  • New NuGet packages
  • Deprecated form script methods removed
  • Preview feature: IFrame and web resources for CRM for tablets
  • New .NET framework requirement

Product catalog enhancements

The enhanced product catalog feature enables you to:

  • Create a rich product classification system (taxonomy) for your organization by defining hierarchies of product families and products with configurable properties that reduce the number of product stock keeping units (SKUs) needed to maintain your product catalog.
  • Group products and services into a bundle to create attractive packages for your customers.
  • Define new relationships, such as cross-sell, up-sell, and accessory, in addition to the substitute relationships for your products that surface as product suggestions to your sales agents during opportunity and order management, which can help to boost sales of the related products.
  • Use custom pricing instead of the CRM system pricing to calculate prices when you associate a product or bundle to opportunity, quote, order, or invoice.
  • Define per unit discount for products at line level when you add them to opportunity, quote, order, or invoice.
  • Automatically set the default price level (price list) for an opportunity, quote, order, or invoice based on the current user and the user’s territory relationship with the price level.
  • Specify localized values for certain product properties (attributes) to allow for product names and descriptions to be available in the user’s preferred language.

More information: Product catalog entities

Use hierarchical data

Users can gain valuable insight about their data because they can visualize hierarchically related data and navigate between related records.

Identify and edit hierarchical entity relationships

Hierarchical relationships aren’t new to Microsoft Dynamics CRM. However, these visualizations and new query operators for hierarchical data depend on explicit declarations that certain entity relationships are hierarchical. There are limitations that are enforced using this declaration, for example, each entity can have just one self-referential one-to-many entity relationship that is considered hierarchical. This declaration is included in the metadata of the relationship. The OneToManyRelationshipMetadata class has a new IsHierarchical property that specifies whether the entity relationship should be considered hierarchical. There is also a new EntityMetadata.CanChangeHierarchicalRelationship managed property that you can use to control whether the hierarchical state of entity relationships included in your managed solutions can be changed. The following system entities have hierarchical relationships that can’t be changed: account, systemuser, product, and position.

All of these settings can be configured using the customization tools in the web application without writing code, but developers can also define hierarchies programmatically using metadata APIs or query the metadata to understand which entity relationships are considered hierarchical.

More information: Hierarchical one-to-many entity relationships

Query hierarchical data

Developers can take advantage of new query condition operators to query entities with explicit hierarchical relationships. These operators only apply for the entity relationship specifically defined as a hierarchical relationship. These condition operators allow for queries that are above or under other records in the hierarchy.

More information: Query hierarchical data

Apply commands to hierarchy visualizations

New hierarchy visualizations allow people to navigate through records in a hierarchy and apply commands on selected records using the command bar. Custom commands for these visualizations support the same contextual information available to commands for views so that you can determine whether to enable or disable your command based on the record currently selected and perform actions on the selected record.

More information: Customize commands and the ribbon

Apply hierarchical security models

While Microsoft Dynamics CRM provides a rich set of structures in which to model security (business units, security roles, sharing, teams), some organizations may need special exceptions defined in code so that people who need to see data can view it. Today, when the existing security configuration doesn’t support business requirements in the organization, organizations might need to define a large number of business units and developers write code in plug-ins to programmatically share records.

Hierarchical security models is an optional feature to provide another dimension to the current matrix of security structures that can reduce the need to create a large number of business units or to write code that deals with exceptions. Developers and implementers need to understand how this new additional layer of security can be applied so that programmatically modifying the security access to records in code becomes something that is done less frequently for those organizations with complex security requirements.

More information: How hierarchical security can be used to control access to entities in Microsoft Dynamics CRM

Use calculated and rollup attributes created in Dynamics CRM

Calculated and rollup attributes are essential because they free the user from having to manually perform calculations and focus on their work. System administrators can now easily define a field to contain the value of many common calculations without having to work with a developer. Developers can also leverage the platform capabilities to perform these calculations rather than within their own code.

More information: Calculated and rollup attributes

Write form scripts that interact with business process flows

In this release, business process flows have been enhanced to support branches based on conditions. These conditions take advantage of the newly introduced support for If-Else structures as well as support for combining multiple conditional expressions entirely using OR or AND. With these new capabilities, developers should evaluate whether existing processes that use form scripts could instead use business process flows so that organizations can maintain the logic they need without writing code.

This release also makes it easier for developers to interact with the business process flows in their scripts. Form script developers have asked for a supported way to interact with the business process form user interface (UI) in form scripts. This release provides a client-side object model developers can use to interact with business process flows in their form scripts. The Xrm.Page object model is extended to include new events, methods, and objects.

More information: Write scripts for business process flows

Use field-level security with system entities

Previous versions of Microsoft Dynamics CRM only allowed definition of field-level security for custom attributes. Because of feedback from our customers, this release now provides for defining field-level security for system attributes. Not all system attributes can be secured because all system users have to be able to access certain attributes.

You can query the metadata to determine which system attributes you can apply field-level security to. The AttributeMetadata properties CanBeSecuredForCreate, CanBeSecuredForRead, and CanBeSecuredForUpdate values have been modified for those system attributes that you can apply field-level security to. You can detect which fields have been secured using the IsSecured property.

More information: How field security can be used to control access to field values in Microsoft Dynamics CRM

Create business rules instead of writing code

Business rules allow customizers to move common form logic away from form scripts so that they do not need to rely on developers. Business rules don’t replace form scripts or plug-ins. They provide a way for a person who isn’t a developer to apply common logic. The logic applied in the business rule can be quickly changed without editing code.

With new business rules enhancements, customizers can now also define common logic that can be evaluated on the server, eliminating the need to apply this logic in a plug-in or a workflow. Business rules are also more useful because they allow for branching logic using OR and If-else conditions that weren’t previously available. Business rules also now allow for setting default values. People who aren’t developers will find defining processes using business rules easier and therefore may not require form scripts as often.

Developers need to be familiar with the capabilities of business rules so they can evaluate if a business requirement can be met without writing code.

Developers must also be aware that business rules evaluated on the server apply to all clients, including custom clients and integration solutions that perform operations on records. When code from any client violates a rule, the business rule will return the error message specified by the rule. This means that it’s important that code include appropriate error handling to adapt to changes that may be applied using business rules.

More information: Custom errors from business rules and the Customization Guide topic Create and edit business rules

Add custom help content

Organizations have a highly customized system, especially those that use custom entities, will find that the application help content may not address the needs of their users. Administrators can configure the system to override the default help content by specifying a URL to open instead. The page to open might be a static page on a Microsoft SharePoint site, a web page on the Internet, or a custom help application created using web resources and included with a solution. Developers need to understand the options available and what contextual information can be passed with the URL so that they can create pages to display appropriate content. More information: Add custom help content and Customize the Help experience

New service proxy classes for the web endpoint

A new namespace called Microsoft.Xrm.Sdk.WebServiceClient provides OrganizationWebProxyClient and DiscoveryWebProxyClient classes for web service access. These classes support executing message requests through the /web endpoint of the Discovery.svc or Organization.svc when authenticated with OAuth. In addition, a new message named RetrieveCurrentOrganizationRequest has been added.

New messages in the Organization web service

The following messages are new in this release:

Request class name | Description | More information
CalculatePriceRequest | Defines custom pricing for your products in opportunities, quotes, orders, and invoices. | Use custom pricing for products
CalculateRollupFieldRequest | Calculates a rollup attribute value on demand. | Rollup attributes
CloneProductRequest | Clones a product family, product, or bundle record, and creates a copy of the record under the same parent node. | Clone a product family, product, or bundle
ExportFieldTranslationRequest | Exports localizable attributes for translation. | Translate localizable attributes
GetDefaultPriceLevelRequest | Used internally by CRM to determine the default price level (price list) for an opportunity, quote, order, and invoice based on the current user and the territory relationship with the price level. | Set default price level for opportunity, quote, order, invoice
ImportFieldTranslationRequest | Imports localizable attributes for translation. | Translate localizable attributes
PublishProductHierarchyRequest | Publishes a product family hierarchy including the child products and bundles. | Publish a product family, product, or bundle
RetrieveCurrentOrganizationRequest | Retrieves organization information from the organization service rather than the discovery service. | Retrieve organization information from the organization service instead of using the discovery service.
RetrievePrincipalSyncAttributeMappingsRequest | Retrieves the synchronization attribute mapping information, which defines the flow of data from the server to the client application. | This message doesn’t have any extensibility scenarios in this release.
RetrieveProductPropertiesRequest | Retrieves all the property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice. | DynamicPropertyInstance (property instance) methods and messages
RevertProductRequest | Reverts a product family, product, or bundle record to its last Active state. All the product property (attribute) changes done to the record since it was last published (Active state) will be lost. | Revert a product family, product, or bundle
UpdateProductPropertiesRequest | Updates the value of property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice. | DynamicPropertyInstance (property instance) methods and messages

New messages in the Deployment web service

The following new messages are introduced to support tasks you can do using the Deployment web service:

Request class name | Description
AddCrmDatabaseRequest | Adds a CRM database to your deployment from a database backup or from a detached database.
DeleteOrganizationRequest | Deletes a CRM organization.
RetrieveMonitoringResultsRequest | Retrieves results from the monitoring service operation tests for your CRM deployment.
RetrieveUserMappingRequest | Retrieves the mapping information of existing users in a CRM organization.

For information about using these new classes, see Administer the deployment using the deployment web service. You can also use the Windows PowerShell cmdlets to manage your CRM deployment. More information: Microsoft Dynamics CRM PowerShell Reference

New entities

New entities can be found by querying on the entity metadata IntroducedVersion property. Entities added in this release have the property value “7.0.0.0”. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following entities are new in this release.

Schema name | Description | More information
BusinessDataLocalizedLabel | For internal use only. | For internal use only.
DynamicProperty | For internal use only. | Define product properties (not supported through SDK)
DynamicPropertyAssociation | For internal use only. | Define product properties (not supported through SDK)
DynamicPropertyInstance | A property instance (DynamicPropertyInstance) stores the instance of a product property along with its values. | DynamicPropertyInstance (property instance) methods and messages
DynamicPropertyOptionSetItem | For internal use only. | Define product properties (not supported through SDK)
HierarchyRule | For internal use only. | For internal use only.
HierarchySecurityConfiguration | For internal use only. | Hierarchical security (position) entity
Position | Contains the position of a user in the security hierarchy. | How hierarchical security can be used to control access to entities in Microsoft Dynamics CRM
PrincipalSyncAttributeMap | Maps security principals (users and teams) to synchronization attribute mappings. | This entity doesn’t have any extensibility scenarios in this release.
RollupJob | For internal use only. | For internal use only.
RollupProperties | For internal use only. | For internal use only.
SLAKPIInstance | Service level agreement (SLA) key performance indicator (KPI) instance that is tracked for an individual case. | SLAKPIInstance (SLA KPI instance) entity messages and methods
SyncAttributeMapping | Synchronization attribute mappings used to provide attribute mappings during synchronization for a particular user or team. | This entity doesn’t have any extensibility scenarios in this release.
SyncAttributeMappingProfile | Stores profile information used to map synchronization attribute mapping data to users or teams. | This entity doesn’t have any extensibility scenarios in this release.
SystemUserManagerMap | For internal use only. | For internal use only.
SystemUserSyncMappingProfiles | Mapping between the synchronization attribute mapping and system users. | This entity doesn’t have any extensibility scenarios in this release.
TeamSyncAttributeMappingProfiles | Mapping between the synchronization attribute mapping and teams. | This entity doesn’t have any extensibility scenarios in this release.

New privileges

The following privileges are new or changed. For an overall view of how the security role editor maps to privilege names in this SDK, see Security role UI to privilege mapping.

Tab name in the security role dialog | Name displayed in the dialog | Privilege name | More information
Sales | Property | prv*DynamicProperty | Define product properties (not supported through SDK)
Sales | Property Association | prv*DynamicPropertyAssociation | Define product properties (not supported through SDK)
Sales | Property Instance | prv*DynamicPropertyInstance | DynamicPropertyInstance (property instance) methods and messages
Sales | Property Option Set item | prv*DynamicPropertyOptionSetItem | Define product properties (not supported through SDK)
Business Management | Change Hierarchy Security Settings | prvWriteHierarchicalSecurityConfiguration | How hierarchical security can be used to control access to entities in Microsoft Dynamics CRM
Customization | Hierarchy Rule | prv*HierarchyRule | Hierarchical security (position) entity
Business Management | Position | prv*Position | Hierarchical security (position) entity
Business Management | Principal Sync Attribute Map | prvWritePrincipalSynAttributeMap | This entity doesn’t have any extensibility scenarios in this release.
Service Managment | SLA KPI Instance | prv*SLAKPIInstance | SLAKPIInstance (SLA KPI instance) entity messages and methods
Business Management | Sync Attribute Mapping Profile | prv*SyncAttributeMappingProfile | This entity doesn’t have any extensibility scenarios in this release.
Business Management | Assign position for a user | prvAssignPosition | Hierarchical security (position) entity
Business Management | Change Hierarchy Security Settings | prvWriteHierarchicalSecurityConfiguration | Hierarchical security (position) entity

* This privilege is one of the following: Create, Read, Write, Delete, Append, AppendTo, Assign, or Share.

NuGet packages

For detailed information about how to obtain the NuGet packages containing SDK assemblies and tools for this release, see Subscribe to SDK assembly updates using NuGet.

Deprecated form script methods removed

Some previously deprecated form script methods have been removed in this release. More information: Removed methods

Note
If you’re upgrading from Microsoft Dynamics CRM 2011 to this release, make sure you review the guidance in Upgrade your code from Microsoft Dynamics CRM 2011 to Microsoft Dynamics CRM 2013. An important resource that can help you get ready for changes to form script methods is the Custom Code Validation tool. An updated version of the custom code validation tool is available to include the latest changes in Microsoft Dynamics CRM 2015. Download the custom code validation tool from http://go.microsoft.com/fwlink/p/?LinkId=518207.

Preview feature: IFrame and web resources for CRM for tablets

If you want to start developing solutions that will use IFrames and web resources with Microsoft Dynamics CRM for tablets you can enable them with this preview feature. While IFrames and web resources aren’t yet supported for forms and dashboards in CRM for tablets, you can enable them for your development organization and get an early start for a future release where they will be supported. More information: Create web resources and IFRAME content for use with the CRM for tablets client

New .NET framework requirement

The minimum .NET Framework version for building managed code applications, plug-ins, and custom workflow activities is now .NET 4.5.2. More information: Visual Studio and the .NET Framework

See Also

Concepts

Tutorials for learning about development for Microsoft Dynamics CRM

Other Resources

Developer overview
What is Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online?
Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Developer overview

This section contains overview and ramp-up information to learn about Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

In This Section

What is Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online?

The extensibility model of Microsoft Dynamics CRM

The security model of Microsoft Dynamics CRM

The metadata and data models in Microsoft Dynamics CRM

The programming models for Microsoft Dynamics CRM

Supported extensions for Microsoft Dynamics CRM

Choose your development style for managed code

Subscribe to SDK assembly updates using NuGet

Tutorials for learning about development for Microsoft Dynamics CRM

Related Sections

Model your business data

Developer tools

Write mobile and modern apps

Write applications and server extensions

Write client application extensions

Write plug-ins to extend business processes

Write workflows to automate business processes

Developers guide to reports for Microsoft Dynamics CRM

Manage your data

Package and distribute extensions using solutions

Developers guide to customization for Microsoft Dynamics CRM

Extend Microsoft Dynamics CRM for Outlook

Integrate SharePoint with Microsoft Dynamics CRM

Advanced development

Sample code directory

Programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


What is Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online?

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online provide a powerful business application platform that delivers to customers, Microsoft Partners, and Independent Software Vendors (ISVs) an opportunity to extend and provide value added solutions. These solutions build on top of the robust core platform capabilities included with Microsoft Dynamics CRM. By using these capabilities, you can build customized solutions without having to custom build the foundation. To learn more about Microsoft Dynamics CRM or to start a free trial, visit http://crm.dynamics.com/.

Microsoft Dynamics CRM continues the evolution of platform features with the addition of the xRM initiative. Platform backward compatibility helps make sure that investments made with earlier versions migrate forward to the Microsoft Dynamics CRM upgrade.

Microsoft Dynamics CRM supports three types of deployments:

  • Microsoft Dynamics CRM 2015 on-premises deployment
  • Microsoft Dynamics CRM 2015 Internet-facing deployment (IFD)
  • Microsoft Dynamics CRM Online

For each of these types of deployments, you have the choice of client application you use to access Microsoft Dynamics CRM. Alternatively, you can create your own client application on top of the Microsoft Dynamics CRM platform. The following clients are provided:

  • Microsoft Dynamics CRM Web client
  • Microsoft Dynamics CRM for Microsoft Office Outlook
  • Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access
  • Microsoft Dynamics CRM for phones

Microsoft Dynamics CRM Online is kept up to date for you. For on-premises and IFD deployments, keep Microsoft Dynamics CRM current by installing the latest updates and hotfixes automatically from Microsoft Update. You can also search for updates on the Microsoft Download Center.

In This Section

The extensibility model of Microsoft Dynamics CRM

The security model of Microsoft Dynamics CRM

The metadata and data models in Microsoft Dynamics CRM

Related Sections

Developer overview

The extensibility model of Microsoft Dynamics CRM

Write client application extensions

Programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


The extensibility model of Microsoft Dynamics CRM

The extensibility platform is the heart of Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online. When you use the Microsoft Dynamics CRM SDK, you are building on top of this system. The Microsoft Dynamics CRM platform supports several types of deployments with the power of choice: Microsoft Dynamics CRM Online, Microsoft Dynamics CRM installed on your own server (on-premises), or a hosted deployment of Microsoft Dynamics CRM. The security model protects the platform from unauthorized access across the Web.

When you develop an application that uses the Microsoft Dynamics CRM server, you use Web services to communicate with the underlying xRM platform layer. Microsoft Dynamics CRM uses a metadata driven architecture to provide the flexibility to create custom entities and additional system entity attributes and also to make upgrades and enable transportation of solutions easier. This allows for changes in the data structure without requiring any change to code in Microsoft Dynamics CRM.

The xRM platform does not impose business-specific logic. This layer imposes only generic constraints such as security. It contains the building blocks for an application, but by itself is nothing more than a collection of related objects. However, the interaction between those objects is used to implement more extensible logic such as the quote-to-order-to-invoice processing and pricing logic.

The xRM platform also controls access to data through security, controls access to the database, and raises events for workflow processes and custom business logic implementations (plug-ins). The platform layer provides for both incoming and outgoing email processing through Microsoft Exchange Server.

In this topic

Microsoft Dynamics CRM Extensibility Architecture

WCF Web Services

Processes (formerly Workflows)

Plug-ins

Client Application Extensions

Reporting

Microsoft Dynamics CRM Extensibility Architecture

Microsoft Dynamics CRM SDK architecture

WCF Web Services

Microsoft Dynamics CRM provides a dynamic Web service interface for applications to use to access and manipulate platform data, metadata, and to interact with platform services, implemented using the Windows Communication Foundation (WCF). These services allow you to write .NET applications using Microsoft Visual Studio or non-.NET applications using other developer tools by simply referencing the Web services. The Web services exposed by the platform are WSI BP 1.1 compliant. This compliance support makes the Web services interoperable with non-Microsoft platforms. For more information about using the Microsoft Dynamics CRM Web services, see Write applications and server extensions. For more information about Web services, see the .NET Framework Developer Center. You can also read the article XML Web Services Basics.

Processes (formerly Workflows)

The process feature supports extending the functionality of the Microsoft Dynamics CRM system by enabling the user to create and execute custom business processes. A Microsoft Dynamics CRM process is built on top of Windows Workflow Foundation, which provides the programming model, run-time engine, and tools for quickly building processes. This includes XAML processes and custom process activities (.NET assemblies). There are two categories of processes in Microsoft Dynamics CRM: workflows and dialogs. For more information about processes, see Write workflows to automate business processes.

Plug-ins

Microsoft Dynamics CRM provides an extension mechanism for implementing validation and custom platform-based business logic. You are not limited to creating custom business logic through workflow processes alone. You can also construct business logic that is integrated with Microsoft Dynamics CRM and executes in response to a particular system event for a specific entity.

Plug-ins support an event handler interface that is based on a pipeline execution model. The pipeline model allows for event handlers, also known as plug-ins, to be executed before or after the core operation of the system. When an action occurs caused by user interaction with the Web application or a Web service call, the platform checks for registered event handlers. If a handler is registered for notification, the platform executes a well-defined event handler method, passing it run-time information. For more information, see Write plug-ins to extend business processes.

Client Application Extensions

Client application extension features allow you to build a solution and add it seamlessly into the Microsoft Dynamics CRM user interface. Client extension features can also be used to create implementation specific customizations or modify the user experience. All client programming code is stored in the Microsoft Dynamics CRM database. This enables the solutions to be transported easily from one deployment to another, and also for the code to function in CRM for Outlook. For more information, see Developers guide to customization for Microsoft Dynamics CRM.

Reporting

Microsoft Dynamics CRM includes reports that provide useful business information to the user. You can use these reports as templates for creating your own custom reports using Microsoft SQL Server Reporting Services Report Builder. You can also use filtered views to create custom reports within Microsoft Dynamics CRM and directly in Microsoft Office Excel and Microsoft Access. There are two types of reports in Microsoft Dynamics CRM: SQL-based reports and FetchXML-based reports. For more information, see Developers guide to reports for Microsoft Dynamics CRM.

Note
You cannot access filtered views in Microsoft Dynamics CRM Online because access to the SQL database is not supported in Microsoft Dynamics CRM Online.

See Also

Other Resources

Developer overview
The security model of Microsoft Dynamics CRM
Microsoft Platform Ready

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


The security model of Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online provide a security model that protects data integrity and privacy, and supports efficient data access and collaboration. The goals of the model are as follows:

  • Provide users with the access only to the appropriate levels of information that is required to do their jobs.
  • Categorize users by role and restrict access based on those roles.
  • Support data sharing so that users and teams can be granted access to records that they do not own for a specified collaborative effort.
  • Prevent a user's access to records the user does not own or share.

Role-based security in Microsoft Dynamics CRM focuses on grouping a set of privileges together that describe the responsibilities (or tasks that can be performed) for a user. Microsoft Dynamics CRM includes a set of predefined security roles. Each aggregates a set of user rights to make user security management easier. Also, each application deployment can define its own roles to meet the needs of different users.

Record-based security in Microsoft Dynamics CRM focuses on access rights to specific records.

Field-level security in Microsoft Dynamics CRM restricts access to specific high business impact fields in an entity only to specified users or teams.

Combine role-based security, record-level security, and field-level security to define the overall security rights that users have within your custom Microsoft Dynamics CRM application.

More overview information about security can be found in this white paper: Microsoft Dynamics CRM Online security and compliance planning guide.

In This Section

How role-based security can be used to control access to entities in Microsoft Dynamics CRM

How record-based security can be used to control access to records in Microsoft Dynamics CRM

How field security can be used to control access to field values in Microsoft Dynamics CRM

How hierarchical security can be used to control access to entities in Microsoft Dynamics CRM

Related Sections

TechNet: Security concepts for Microsoft Dynamics CRM The metadata and data models in Microsoft Dynamics CRM

The programming models for Microsoft Dynamics CRM

Supported extensions for Microsoft Dynamics CRM

Choose your development style for managed code

Tutorials for learning about development for Microsoft Dynamics CRM

Write applications and server extensions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


How role-based security can be used to control access to entities in Microsoft Dynamics CRM

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online the fundamental concept in role-based security is that a role contains privileges that define a set of actions that can be performed within the organization. For example, the salesperson role is assigned a set of privileges that are relevant to the performance of the tasks defined for that role. All users must be assigned to one or more predefined or custom roles. In Microsoft Dynamics CRM 2015, roles can also be assigned to teams. When a user or team is assigned to one of these roles, the person or team members are assigned the set of privileges associated with that role. A user must be assigned to at least one role.

A privilege authorizes the user to perform a specific action on a specific entity type. Privileges apply to an entire class of objects, rather than individual instances of objects. For example, if a user does not have the privilege to read accounts, any attempt by that user to read an account will fail. A privilege contains an access level that determines the levels within the organization to which a privilege applies. Each privilege can have up to four access levels: Basic, Local, Deep, and Global.

In This Topic

Roles

Privileges

Access levels

Putting it all together

List of predefined security roles

Roles

Microsoft Dynamics CRM includes fourteen predefined roles that reflect common user roles with access levels defined to match the security best-practice goal of providing access to the minimum amount of business data required for the job. With these roles you can quickly deploy a Microsoft Dynamics CRM system without having to define your own roles. However, you can create custom roles using the predefined roles as a template, or you can define a new set of roles. For a list, see List of Predefined Security Roles.

Each role is associated with a set of privileges that determines the user or team’s access to information within the company.

You can create roles within Microsoft Dynamics CRM and modify or remove these custom roles to fit your business needs. The roles you create for your business unit are inherited by all the business units in the hierarchy.

You can assign one or more roles to a user or to a team. For example, a user can have the Sales Manager role in addition to being a Customer Service Representative, in which case that user has all the privileges of both roles.

You cannot modify privileges at the user level, but you can create a new role with the desired privileges. For example, John is given a Salesperson role, which requires him to accept all leads assigned to him. However, the administrator wants John to be able to reassign leads assigned to him. As a result, the administrator either has to modify the Salesperson role to allow this or create a new role that incorporates this specific privilege and add John to this role. Creating a new role is the recommended option unless you think it necessary that all users who are assigned the Salesperson role now have this additional privilege.

Privileges

In Microsoft Dynamics CRM, there are over 580 privileges that are predefined system-wide during setup. A privilege is a permission to perform an action in Microsoft Dynamics CRM. Some privileges apply in general and some to a specific entity type. For a complete list of the privileges available in Microsoft Dynamics CRM, see Security role and privilege reference.

Microsoft Dynamics CRM uses privileges as the core of the underlying security check. Privileges are "built in" to the product and are used throughout the application and platform layers. You cannot add or remove privileges, or change how privileges are used to grant access to certain functionality, but you can construct new roles from the existing privilege set.

Each role defines a set of privileges that determines the user or team's access to information within the company. The platform checks for the privilege and rejects the operation if the user does not have the necessary privilege. A privilege is combined with a depth or access level.

For example, the Salesperson role could contain the privileges Read Account with Basic access and Write Account with Basic access, whereas the Sales Manager role might contain privileges like Read Account with Local access and Assign Contact with Local access.

Most entities have a set of possible privileges that can be added to a role that correspond to the various actions you can take on the records of that entity time. For more information, see Privileges by entity.

Each action in the system, and each message described in the SDK documentation, requires one or more privileges to be performed. For more information, see Privileges by message.

Access levels

The access level or privilege depth for a privilege determines, for a given entity type, at which levels within the organization hierarchy a user can act on that type of entity.

The following table lists the levels of access in Microsoft Dynamics CRM, starting with the most access. The icon is shown in the security role editor in the Web application.

Access level global

Global. This access level gives a user access to all records within the organization, regardless of the business unit hierarchical level to which the instance or the user belongs. Users who have Global access automatically have Deep, Local, and Basic access, also.

Because this access level gives access to information throughout the organization, it should be restricted to match the organization's data security plan. This level of access is usually reserved for managers with authority over the organization.

The application refers to this access level as Organization.

Access level deep

Deep. This access level gives a user access to records in the user's business unit and all business units subordinate to the user's business unit.

Users who have Deep access automatically have Local and Basic access, also.

Because this access level gives access to information throughout the business unit and subordinate business units, it should be restricted to match the organization's data security plan. This level of access is usually reserved for managers with authority over the business units.

The application refers to this access level as Parent: Child Business Units.

Access level local

Local. This access level gives a user access to records in the user's business unit.

Users who have Local access automatically have Basic access, also.

Because this access level gives access to information throughout the business unit, it should be restricted to match the organization's data security plan. This level of access is usually reserved for managers with authority over the business unit.

The application refers to this access level as Business Unit.

Access level basic

Basic.

This access level gives a user access to records he or she owns, objects that are shared with the user, and objects that are shared with a team of which the user is a member.

This is the typical level of access for sales and service representatives.

The application refers to this access level as User.

Access level none

None. No access is allowed.

Putting it all together

  • If a user has the Deep Read Account privilege, this user can read all accounts in his or her business unit, and all accounts in any child business unit of that business unit.
  • If a user has Local Read Account privileges, this user can read all accounts in the local business unit.
  • If a user is assigned the Basic Read Account privilege, this user can read only the accounts that he or she owns or the accounts that are shared with him or her.
  • A customer service representative with the Basic Read Account privilege can view accounts that he or she owns and any accounts another user has shared with this user. This makes it possible for the representative to read the account data that is relevant to a service request, but not to change the data.
  • A data analyst with the Local Read Account privilege can view account data and run account-related reports for all accounts in his or her business unit.
  • A finance officer for the company with the Deep Read Account privilege can view account data and run account-related reports for all accounts in his or her business unit and accounts in any child business unit.

List of predefined security roles

The following table lists the predefined set of roles that are included in the Microsoft Dynamics CRM SDK.

Role | Description
CEO-Business Manager | A user who manages the organization at the corporate business level.
CSR Manager | A user who manages customer service activities at the local or team level.
Customer Service Representative (CSR) | A customer service representative (CSR) at any level.
Delegate | A user who is allowed to act on behalf of another user.
Marketing Manager | A user who manages marketing activities at the local or team level.
Marketing Professional | A user engaged in marketing activities at any level.
Sales Manager | A user who manages sales activities at the local or team level.
Salesperson | A salesperson at any level.
Schedule Manager | A user who schedules appointments for services.
Scheduler | A user who manages services, required resources, and working hours.
Support User | A user who is a customer support engineer.
System Administrator | A user who defines and implements the process at any level.
System Customizer | A user who customizes Microsoft Dynamics CRM entities, attributes, relationships, and forms.
Vice President of Marketing | A user who manages marketing activities at the business unit level.
Vice President of Sales | A user who manages the sales organization at the business unit level.

See Also

Concepts

Privilege and role entities
How record-based security can be used to control access to records in Microsoft Dynamics CRM
How field security can be used to control access to field values in Microsoft Dynamics CRM

Other Resources

The security model of Microsoft Dynamics CRM
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


How record-based security can be used to control access to records in Microsoft Dynamics CRM

Record-based security in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online applies to individual records. It is provided by using access rights.

The relationship between an access right and a privilege is that access rights apply only after privileges have taken effect. For example, if a user does not have the privilege to read accounts, that user is unable to read any account, regardless of the access rights another user might grant to a specific account through sharing.

In This Topic

Access rights

Sharing records

Assigning records

Retrieving the access rights for a record

Dependencies between access rights

Access rights

An access right is granted to a user for a particular record. The following table lists the descriptions for these access rights.

Access right | AccessRights enumeration value | Description
Read | ReadAccess | Controls whether the user can read a record.
Write | WriteAccess | Controls whether the user can update a record.
Assign | AssignAccess | Controls whether the user can assign a record to another user.
Append | AppendAccess | Controls whether the user can attach another record to the specified record. The Append and Append To access rights work in combination. Every time that a user attaches one record to another, the user must have both rights. For example, when you attach a note to a case, you must have the Append access right on the note and the Append To access right on the case for the operation to work.
Append To | AppendToAccess | Controls whether the user can append the record in question to another record. The Append and Append To access rights work in combination. For more information, see the description for Append.
Share | ShareAccess | Controls whether the user can share a record with another user or team. Sharing gives another user access to a record. For more information, see Sharing Records.
Delete | DeleteAccess | Controls whether the user can delete a record.

Create access

The right to create a record for an entity type is not included in the previous table because this right does not apply to an individual record, but instead to a class of entities. Create is handled as a privilege instead of as an access right. The user who creates a record has all rights on that record, unless his or her other privileges forbid a specific right.

The Create privilege controls whether you can create a record. If you have the Create privilege with Local, Deep, or Global access, you can create records for other users. If you have Create and Read privileges with Basic access, you can create records for yourself.

For more information about dependencies that relate to create privileges, see Dependencies between access rights.

Sharing records

Sharing lets users give other users or teams access to specific customer information. This is useful for sharing information with users in roles that have only the Basic access level. For example, in an organization that gives salespeople Basic read and write access to accounts, a salesperson can share an opportunity with another salesperson so that they can both track the progress of an important sale.

For security reasons, develop the practice of sharing only the necessary records with the smallest set of users possible. Only grant the minimum access required for users to do their jobs.

Microsoft Dynamics CRM provides the following sharing capabilities:

  • Share. Any user who has share privileges on a given entity type can share records of that type with any other user or team in Microsoft Dynamics CRM. To share a record, use GrantAccessRequest.
    When you share a record with another user, indicate what access rights (Read, Write, Delete, Append, Assign, and Share) you want to grant to the other user. Access rights on a shared record can be different for each user with whom the record is shared. However, you cannot give a user any rights that he or she would not have for that type of entity, based on the role assigned to that user. For example, if a user does not have Read privileges on accounts and you share an account with that user, the user will be unable to see that account.
  • Modify share. You can modify the rights granted to a shared record after it has been shared. To modify sharing for a record, use the ModifyAccessRequest.
  • Remove share. If you share a record with another user or team, you can stop sharing the record. After you remove sharing for a record, the other user or team loses access rights to the record. To remove sharing for a record, use the RevokeAccessRequest.
Tip
Use GrantAccessRequest, ModifyAccessRequest, and RevokeAccessRequest for sharing.

A user might have access to the same record in more than one context. For example, a user might share a record directly with specific access rights, and he or she might also be on a team in which the same record is shared with different access rights. In this case, the access rights that this user has on the record are the union of all the rights.

For a list of entities that support sharing, see the GrantAccessRequest.

Sharing and inheritance

If a record is created and the parent record has certain sharing properties, the new record inherits those properties. For example, Joe and Mike are working on a high priority lead. Joe creates a new lead and two activities, shares the lead with Mike, and selects cascade sharing. Mike makes a telephone call and sends an email regarding the new lead. Joe sees that Mike has contacted the company two times, so he does not make another call.

Sharing is maintained on individual records. A record inherits the sharing properties from its parent and also maintains its own sharing properties. Therefore, a record can have two sets of sharing properties—one that it has on its own and one that it inherits from its parent.

Removing the share of a parent record removes the sharing properties of objects (records) that it inherited from the parent. That is, all users who previously had visibility into this record no longer have visibility. Child objects still could be shared to some of these users if they were shared individually, not from the parent record.

Assigning records

Anyone with Assign privileges on a record can assign that record to another user. When a record is assigned, the new user or team becomes the owner of the record and its related records. The original user or team loses ownership of the record, but automatically shares it with the new owner.

In Microsoft Dynamics CRM, the system administrator can decide for an organization whether records should be shared with previous owners or not after the assign operation. If Share with previous owner is selected, then the previous owner shares the record with all access rights after the assign operation. Otherwise, the previous owner does not share the record and may not have access to the record, depending on his or her privileges. The Organization.ShareRoPreviousOwnerOnAssign attribute controls this setting.

For a list of entities that support Assign, see the AssignRequest.

Retrieving the access rights for a record

Use the RetrievePrincipalAccessRequest message to retrieve the access rights the specified security principal (user or team) has to a record.

Use the RetrieveSharedPrincipalsAndAccessRequest message to retrieves all the security principals (users or teams) that have access to a record, together with their access rights to that record.

Dependencies between access rights

Sometimes, security dependencies exist because it is necessary to have more than one access right to perform a given action. For example, if you have the create access right for accounts, you can create a record of the account entity type. However, unless you also have read access for accounts, you cannot create an account record and be the owner of that new record.

The following table lists the access right dependencies for the actions specified.

Action | Access rights required
To Create a record and be the record owner | CREATE READ
To Share a record | SHARE. This right is required by the person doing the share operation. READ. This right is required by the person doing the share operation and also by the person with whom the record is being shared.
To Assign a record | ASSIGN WRITE READ
To Append To a record | READ APPENDTO
To Append a record | READ APPEND

Another type of dependency exists when objects are subordinate to another object. For example, the opportunity object cannot exist on its own. Each opportunity is always attached to an account or contact. To create an opportunity, you must have the access right appendto on accounts and the access right append on opportunities.

See Also

Concepts

How role-based security can be used to control access to entities in Microsoft Dynamics CRM
How field security can be used to control access to field values in Microsoft Dynamics CRM
Introduction to entities in Microsoft Dynamics CRM
Entity relationship behavior

Other Resources

The security model of Microsoft Dynamics CRM
AccessRights
RetrievePrincipalAccessRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


How field security can be used to control access to field values in Microsoft Dynamics CRM

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online, you use field-level security to restrict access to high business impact fields to specific users and teams. For example, you use this to enable only certain users to read or update the credit score for a customer. For this release, field-level security can be applied to both custom fields and many out-of-box (OOB) fields.

The following steps describe how to restrict access to a field:

  1. Enable field-level security for an attribute
  2. Create a field-level security profile
  3. Associate users or teams with the profile
  4. Add specific field permissions, such as Create, Update or Read for a specific attribute to the profile

The following diagram shows the interaction between role-based security, record-based security, and field-level security.

Role-based compared to field-level security

Role-based security lets you see a specific entity type, record-based security lets you see individual records, and field-level security lets you see specific fields.

Video: Field Level Security in Microsoft Dynamics CRM 2015

Frequently asked questions

  • Which attributes can be secured?
  • Which security roles allow you to see secured fields?
  • How do secured fields behave for Retrieve and RetrieveMultiple?
  • How do secured fields behave for create or update?
  • How do secured fields behave when records are shared?
  • How do secured fields behave for filtered views?
  • How do secured fields behave for offline synchronization?

Which attributes can be secured?

To see which attributes can be secured, you can query the entity metadata for the following properties:

  • CanBeSecuredForCreate
  • CanBeSecuredForRead
  • CanBeSecuredForUpdate

There are thousands of attributes that can be secured, so there are two easier ways to look for this information. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

There are a few additional rules that apply to certain attribute data types:

  • Boolean attributes can be secured for create and update operations but not for read.
  • Option set attributes can be secured for create, update, and read when a default value is unspecified.

Which security roles allow you to see secured fields?

The System Administrator field security profile gives full access to all secured fields in Microsoft Dynamics CRM. By default, all users who have the System Administrator security role have this profile. This profile is system managed and can’t be updated or deleted.

How do secured fields behave for Retrieve and RetrieveMultiple?

When you call the Retrieve or RetrieveMultiple methods or messages, Microsoft Dynamics CRM evaluates if the caller and the impersonated user have access to each retrieved record (this is the regular security process) and each secured field. The call does not throw an exception if the criteria contain secured fields for which the caller does not have access. Instead, null values are returned for secured fields if they are part of the output column set.

The following describes more about the retrieve multiple behaviors for secured fields.

When a secured attribute is in the column set

If the caller (or impersonated user) does not have read access to the secured fields that are included in a column set, the value returns as null. You cannot tell the difference between a returned null value caused by no data or caused by insufficient access.

When a secured attribute is in the filter condition

If the caller (or impersonated user) does not have access to the secured fields that are included in the filter criteria, the field value is substituted with null during the evaluation of the filter.

In the following table, the caller has access to all attributes except those indicated with an asterisk (*).

Record Number | Value of the Name attribute | Value of the Description attribute | Value of the Can Be Contacted attribute
1 | A | AAA | True
2 | B | BBB | False
3 | C | CCC | True*
4 | D | DDD | Null
5* | E* | EEE* | Null*

When the filter is CanbeContacted == True, only record one is returned.

When the filter is IsNULL (CanbeContacted), records 3 and 4 are returned. Since record 3 is hidden from the user, it is treated as null during condition evaluation and will be evaluated as True for ISNull.

When aggregating on secured attributes

Secured values are substituted with a null value, so normal SQL aggregation behavior applies.

When grouping on secured attributes

If the caller (or impersonated user) does not have access to the attribute used for grouping, the value is treated as null and the results are grouped together with all null values.

In the following example, the caller has access to some attributes. Bold indicates no access to attributes, also indicated with *. Italics indicate a record for which the caller does not have read access, also indicated with **.

Name | Description | Number of orders | State
A | AAA | 1 | WA
B | BBB | 4 | WA
C | CCC | 4 | CA
D** | DDD** | 3** | MA**
E | EEE | 0 | CA
F | FFF | 0 | WA*
G | GGG | 2 | CA*

Select State, Total(orders) Group by (STATE) results in the following:

WA–5

CA–4

null–2

When ordering on secured attributes

If the caller (or impersonated user) does not have access to secured fields that are included in an order by condition, the values will be treated as if they are null.

In the following example, the caller has access to attributes that are in plain text. Bold indicates no access to attributes, also indicated with an asterisk (*). Italics indicate a record for which the caller does not have read access, also indicated with **.

Name | Description | CanbeContacted
A | AAA | True
B | BBB | False
C | CCC* | True*
D | DDD | Null
E | EEE* | Null*
F** | FFF** | True**
G | Null | True

Select Name order by Description ascending results in the following:

{G,E,C},A, B, D, will be returned.

How do secured fields behave for create or update?

A programmer may build a client that uses Create and Update methods that interact with secured fields. When you call the Create or Update method, passing data for secured fields and the caller does not have sufficient permissions, an exception is thrown.

How do secured fields behave when records are shared?

A user with access to a secured field in a record can choose to share it with another user or team. The user can only give the access that they have on the record. For example, to share the record and grant Update privileges, the user must have update privileges.

You can share a secured field on a particular record with Read and/or Update with a security principal (user or team). The user or team members with whom the record was shared now have that type of secured field access only on the shared secured fields on only that particular record, even if the user or team member to whom it was shared does not have a field security profile that gives them access.

How do secured fields behave for filtered views?

An administrator secures a number of fields for access in the application and wants the fields not to be available in reports. This allows for maintaining the same set of reports for all users. Filtered views will not return data for the secured fields if the calling user does not have authorization for the fields. When no field security is applied for any of the view’s attributes, the filtered views return complete data.

How do secured fields behave for offline synchronization?

If you are using Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access, only the secured field values that you have access to replicate into the offline database. If you don’t have access to the data, it is not saved offline.

See Also

Concepts

How role-based security can be used to control access to entities in Microsoft Dynamics CRM
How record-based security can be used to control access to records in Microsoft Dynamics CRM

Other Resources

The security model of Microsoft Dynamics CRM
Video: Field Level Security in Microsoft Dynamics CRM 2015

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


How hierarchical security can be used to control access to entities in Microsoft Dynamics CRM

Hierarchy security offers a more granular access to records for an organization and helps to bring the maintenance costs down. For example, in complex scenarios, you can start with creating several business units and then add the hierarchy security. This will achieve a more granular access to data with far less maintenance costs that a large number of business units may require. The hierarchy security model is an extension to the existing Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update security models that use business units, security roles, sharing, and teams. It can be used in conjunction with all other existing security models.

Previously, implementing this kind of security often required developers to mimic this behavior using custom plug-ins. Now, with the hierarchy security model, that type of security is built into the CRM 2015 product. This removes the need to create and update custom plug-ins.

For a detailed description of the hierarchy security model, see TechNet: Security concepts for Microsoft Dynamics CRM in the Deploying and administering Microsoft Dynamics CRM documentation.

Video: Hierarchical Security Modelling in Microsoft Dynamics CRM 2015

Position hierarchy

Administrators can define various job positions in the organization and arrange them in the position hierarchy. You can add users to any given position or “tag” a user with a particular position. A user can be tagged only with one position in a given hierarchy; however, a position can be used for multiple users. Users at the higher positions in the hierarchy have access to the data of the users at the lower positions, in the direct ancestor path. The direct higher positions have Read, Write, Update, Append, and AppendTo access to the lower positions’ data in the direct ancestor path. The non-direct higher positions have read-only access to the lower positions’ data in the direct ancestor path.

With the position hierarchy security, a user at a higher position has access to the records owned by a lower position user or by the team that a user is a member of, and to the records that are directly shared to the user or the team that a user is a member of. In addition to the position hierarchy security model, the users at a higher level must have at least the user level Read privilege on an entity to see the records that the users at the lower positions have access to. For example, if a user at a higher level doesn’t have the Read access to the Case entity, that user won’t be able to see the cases that the users at a lower positions have access to.

As a developer, you can implement a position hierarchy by using the Position entity.

Two new privileges have been added that are related to the position hierarchy feature as shown in the table below.

Privilege | Description
prvAssignPosition | Assign a position to a system user.
prvWriteHierarchicalSecurityConfiguration | Change hierarchy security settings.

For more information about the Position entity and its messages, see Position entity messages and methods.

See Also

Concepts

Hierarchical security (position) entity
Position entity messages and methods

Other Resources

The security model of Microsoft Dynamics CRM
Video: Hierarchical Security Modelling in Microsoft Dynamics CRM 2015
TechNet: Security concepts for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


The metadata and data models in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online uses a metadata driven architecture to provide the flexibility to create custom entities and additional system entity attributes. This structure also makes upgrades and the transportation of customizations easier. The data structure can change without requiring any change to code in the Microsoft Dynamics CRM server or client applications.

All the information necessary for Microsoft Dynamics CRM server to operate is stored in the Microsoft Dynamics CRM metadata. This includes information about entities, attributes, relationships, and option sets.

The Microsoft Dynamics CRM Web services contain the messages that you use to read or write the definitions for all the entities each organization. It can also be used to build a client-side metadata cache, which is useful for applications that access the metadata frequently. For example, you may want to create a custom search solution that supports all entities, even those created after the solution has been installed.

A very important role of the metadata is to provide the framework to deliver a fully metadata driven user interface. The entity metadata controls the grid and form layout, and how navigation options are presented.

When you create a custom entity, the information in the attributes and relationships are used to create the appropriate user interface for that entity. In addition, this supports multiple languages in the user interface so that one user may see labels and other text in a different language from another user. These languages and the associated labels are stored in the metadata. The language edition of Microsoft Dynamics CRM server that is installed for an organization is considered its base language. You then install Multilingual User Interface (MUI) language packs for additional languages as they are needed.

To read more about metadata and how to find metadata reports, see Entity Metadata.

The following table lists the objects described by the metadata.

Metadata object | Description
Entity | An entity is a container for data, similar to a table in a traditional database. Each entity contains a set of attributes. For Microsoft Dynamics CRM, there are a set of entities that exist when you first install. Some of these are customizable. In addition, you can create custom entities to contain business data.
Attribute | An attribute is a container for a piece of data in an entity. Microsoft Dynamics CRM supports a wide variety of attribute types.
Relationship | A relationship defines an association between two entities: one-to-many, many-to-one, many-to-many, and self-referential.
Option Set | An option set defines a set of options provided for a picklist. Several picklist attributes may use a global option set so that the options they provide are always the same and can be maintained in one location.
Option | An option is one of the values available in an option set. Each option in an option set has a unique integer value and an associated set of localized labels.

See Also

Concepts

The programming models for Microsoft Dynamics CRM
Customize entity metadata

Other Resources

Developer overview
What is Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online?
Extend the metadata model

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


The programming models for Microsoft Dynamics CRM

Microsoft Dynamics CRM offers several programming paradigms designed to give you the flexibility to decide what works best for your needs. An early-bound entity data model has been added that includes an "object services" layer that integrates with the stack and exposes entity values as .NET Framework objects. You can also use the late-bound scenario.

Programmability scenarios

The following diagram illustrates the key programmability scenarios for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Use these Microsoft Dynamics CRM programming paradigms for the following:

  • Early-bound – Microsoft Dynamics CRM uses an entity data model and Windows Communication Foundation (WCF) Data Services technologies to provide a new set of tools that simplify the development of Internet-enabled applications that interact with Microsoft Dynamics CRM. This also enables an additional programming paradigm: an organization service context that tracks changes to objects and supports .NET Language-Integrated Query (LINQ) queries to retrieve data from Microsoft Dynamics CRM. For more information, see Use the early bound entity classes in code.
  • Late-bound – This programming paradigm lets you write code that accesses entities that are not yet defined. For example, you may use this to write a custom search utility that will work for any installation of Microsoft Dynamics CRM, regardless of the customizations that you made. For more information, see Use the late bound entity class in code. This paradigm also allows code to be written in a generic manner in such a way that it doesn't require a certain type of entity.
  • REST – The REST endpoint for AJAX and Microsoft Silverlight clients provides an alternative interface that you can use to work with Microsoft Dynamics CRM data. Rather than directly invoking the SOAP-based web service, you can execute requests using a service that is based on a URI. For more information, see Use the OData endpoint with web resources.
  • WSDL – This programming paradigm lets you develop code from non-.NET clients, and does not depend on the use of Microsoft Dynamics CRM assemblies. For example, you can use this programming model to write code for Microsoft Dynamics CRM in Java. For more information, see Write Java and other non-.NET client applications.

Program using early and late binding

In Microsoft Dynamics CRM, you can choose from several programming scenarios to find the model that best suits your needs.

The main development scenario for Microsoft Dynamics CRM for the Microsoft .NET Framework references two assemblies that allow you to connect to any Microsoft Dynamics CRM system for both early and late bound types. This scenario can be described as late binding or loosely typed. To use late bound types, use the Entity class. This class defines a collection of attributes that can be used to get and set the values of attributes. To use this model, the exact logical name must be known (and specified) as a string.

Alternatively, you can use early bound classes generated directly from the metadata, which include all customizations. The generated classes provide early binding and IntelliSense to aid you as you write custom code. For more information, see Create early bound entity classes with the code generation tool (CrmSvcUtil.exe).

The entity class structure is the following:

Entity class hierarchy for CRM 2011

The DynamicEntity class has been replaced by the base class Entity. This means that all types are discoverable at both build time and runtime, making all strongly-typed entities now loosely-typed entities. You can use both programming scenarios in the same code as shown in the following example:

C# Copy Code
Account entity = new Account();
entity["name"] = "My Account"; //loosely typed, late binding
entity.AccountNumber = "1234"; //strongly typed, early binding

The Microsoft Dynamics CRM SDK documentation includes samples that use both programming scenarios. The early bound samples use a file of strongly-typed classes that are generated with the code generation utility from a new, uncustomized installation of Microsoft Dynamics CRM. To run the samples, you must generate a file of strongly-typed classes from your installation. You can decide whether to create a proxy assembly from the generated code file or to include the file in your project directly, as we have done for the samples. For more information about your development style choices, see Choose your development style for managed code.

See Also

Concepts

Supported extensions for Microsoft Dynamics CRM
Assemblies included in the Microsoft Dynamics CRM SDK
Entity and attribute naming conventions
Introduction to entities in Microsoft Dynamics CRM
Introduction to entity attributes in Microsoft Dynamics CRM

Other Resources

Developer overview

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Supported extensions for Microsoft Dynamics CRM

You can customize Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update by using tools that are available in the Microsoft Dynamics CRM web application or that are described in the Microsoft Dynamics CRM SDK. These customizations are supported and can be upgraded.

Customizations made using methods other than those described here are unsupported and could cause problems during updates and upgrades to Microsoft Dynamics CRM. For more information, see Unsupported Customizations.

Topics covered in technical articles published on MSDN in the CRM Developer Center on MSDN are supported, but might not be upgraded.

In This Topic

Customizations using Microsoft Dynamics web application

Customizations using the Microsoft Dynamics CRM SDK

Support for .NET Framework versions

Unsupported customizations

Customizations using Microsoft Dynamics web application

There are a variety of tools included with Microsoft Dynamics CRM that you can use to customize it. Customizations made using the Microsoft Dynamics CRM tools and web application are fully supported and fully upgradeable.

The following customization methods can be used to produce fully supported customizations:

  • Customization in the web application. For more information, see the Customization Guide for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online.
  • Settings in the web application. For more information, see the Administrator’s Guide in Microsoft Dynamics CRM online Help.
  • Reporting Services. For more information, see Developers guide to reports for Microsoft Dynamics CRM and the Report Writers Guide for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online.
  • Using Filtered Views with external applications such as those in Microsoft Office.
Note
Fully supported means that developer support can provide assistance for customizations and that application support can help customers running those modifications.

For more information about using the customization tools in the web application, see the Customization Guide for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online.

Customizations using the Microsoft Dynamics CRM SDK

The Microsoft Dynamics CRM SDK, technical articles, and sample code published on the Microsoft Dynamics CRM Developer Center, and information released by the Microsoft Dynamics CRM Developer Support Team are included in the area of customizations using the Microsoft Dynamics CRM SDK. The specific actions and levels of supportability and upgradeability are described later in this topic.

Microsoft Dynamics CRM SDK

Use of the web services is fully supported. This includes: DiscoveryService, OrganizationService, Organization Data Service, the OData endpoint, the modern app SOAP endpoint, and the DeploymentService. We strive to keep the APIs backward compatible but reserve the right to change APIs for additional features. Entity attributes may also change in future versions. For more information, see Write applications and server extensions and Administer the deployment using the deployment web service.

Client-side JavaScript

You can use JavaScript within Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update in three areas:

  • Form Script event handlers: You can configure form event handlers to call functions defined in JavaScript web resources.
  • Command bar (ribbon) commands: You can use the <CustomRule> (RibbonDiffXml) or <JavaScriptFunction> (RibbonDiffXml) elements to define actions that call functions defined within JavaScript web resources.
  • Web resources and IFRAMEs: You can use JavaScript web resources within HTML web resources. IFRAMES configured to allow cross-site scripting, or scripts within HTML web resources included in a form may interact with the documented Xrm.Page or Xrm.Utility methods within the form via the parent reference.

All interaction with Microsoft Dynamics CRM application pages must only be performed through the methods with the Xrm.Page or Xrm.Utility namespaces documented in the Client-side programming reference. Directly accessing the Document Object Model (DOM) of any Microsoft Dynamics CRM application pages is not supported. The use of jQuery in form scripts and commands is not recommended. More information: Use of jQuery

You can open Microsoft Dynamics CRM forms, views, dialogs, and reports using the methods documented in Open forms, views, dialogs and reports with a URL.

Ribbon customization

Use of RibbonDiffXml to add, remove, or hide ribbon elements is supported. Reuse of Ribbon commands defined by Microsoft Dynamics CRM is supported; however, we reserve the right to change or deprecate the available commands. Reuse of JavaScript functions defined within ribbon commands is not supported.

Solution file

Modification of an unmanaged solution file is supported as described in the Microsoft Dynamics CRM SDK. Certain customization tasks are performed using these steps:

  • Export a solution component as an unmanaged solution.
  • Extract the contents of the solution package.
  • Edit the Customizations.xml file.
  • Repackage the solutions file.
  • Import the modified solution.

Changes to the Customizations.xml file must conform to the CustomizationsSolution.xsd schema. For more information, see Schemas used in Microsoft Dynamics CRM.

The following supported tasks require this procedure:

  • Ribbon customization.
  • Application navigation customization using SiteMap.
  • Form and dashboard customization using FormXml.
  • Saved query customization.

Plug-ins

The ability to create custom business logic using the plug-in mechanism described in the Microsoft Dynamics CRM SDK is fully supported and upgradeable. This feature is available for all Microsoft Dynamics CRM deployments, including on-premises, IFD, and Online. However, plug-ins can only be registered and executed in the sandbox (isolation) of Microsoft Dynamics CRM Online. More information: Write plug-ins to extend business processes

Adding your plug-in and custom workflow activity assemblies to the %installdir%\server\bin\ folder is supported on Microsoft Dynamics CRM on-premises and IFD server installations only.

Workflow

The ability to create custom workflow activities (assemblies) to be called from workflow rules is fully supported and upgradeable. This feature is available for Microsoft Dynamics CRM on-premises, IFD, and Online. However, custom workflow activities can only be registered and executed in the sandbox (isolation) of Microsoft Dynamics CRM Online. More information: Write workflows to automate business processes

The ability to edit XAML workflows is fully supported and upgradeable. However, this feature is available for Microsoft Dynamics CRM on-premises and IFD only. More information: Write workflows to automate business processes

Support for .NET Framework Versions

The following describes the support considerations for custom code written with Microsoft Visual Studio 2012 or 2013 and the Microsoft .NET Framework 4.5.2.

Any web service client created by using Visual Studio and the Microsoft .NET Framework 4.5.2 that calls the Microsoft Dynamics CRM web services is fully supported in Microsoft Dynamics CRM. The use of ASP.NET AJAX is supported.

Any .NET assembly that is created with Visual Studio and the Microsoft .NET Framework 4.5.2 for use in Microsoft Dynamics CRM as a Microsoft Dynamics CRM plug-in assembly or as a Microsoft Dynamics CRM custom workflow activity is supported.

Any visualization (chart) that is created with .NET Framework 4.5.2 .

For backwards compatibility, these endpoints can be used with earlier versions of the .NET Framework as follows:

  • The 2011 endpoint supports .NET Framework 4.

Unsupported customizations

Modifications to Microsoft Dynamics CRM that are made without using either the Microsoft Dynamics CRM SDK or Microsoft Dynamics CRM tools are not supported and are not preserved during updates or upgrades of Microsoft Dynamics CRM. Anything that is not documented in the Microsoft Dynamics CRM SDK and supporting documents is not supported. Additionally, unsupported modifications could cause problems when you update through the addition of hotfixes or service packs or upgrade Microsoft Dynamics CRM. To minimize update and upgrade issues, do not modify any Microsoft Dynamics CRM file that you did not create yourself.

The following is a list of unsupported action types that are frequently asked about:

  • Modifications to any .aspx, .css, .htm, .js, .xml, .jpg, or .gif files or the addition of files in the wwwroot directories of the Microsoft Dynamics CRM application, Microsoft Dynamics CRM tools, or Microsoft Dynamics CRM files located at Program Files\Microsoft Dynamics CRM. However, if you have made changes to these files, these files are checked for modifications and will not be overwritten.
  • Modifications to the Microsoft Dynamics CRM website (file and website settings). Custom solutions should be installed in a different website. This includes modifications to the file system access control lists (ACLs) of any files on the Microsoft Dynamics CRM server.
  • Use of client certificates is not supported by the Microsoft Dynamics CRM SDK. If you configure the Microsoft Dynamics CRM website to require IIS client certificates, you will get authentication failures for any applications that were built using the SDK.
  • Modifications to the physical schema of the database, other than adding or updating indexes. This includes any actions performed against the database without using the System Customization capabilities in the web application or using the metadata APIs that are described in this SDK documentation. Modifying tables, stored procedures, or views in the database is not supported. Adding tables, stored procedures, or views to the database is also not supported because of referential integrity or upgrade issues. For Microsoft Dynamics CRM 2015 on-premises deployments, adding indexes is supported per the guidelines in the Deploying and administering Microsoft Dynamics CRM documentation. This applies to all Microsoft Dynamics CRM databases and the Microsoft Dynamics CRM for Microsoft Office Outlook local database.
    When you change the database without using the support methods for system customization, you run the risk of problems occurring during updates and upgrades.
  • Data (record) changes in the Microsoft Dynamics CRM database using SQL commands or any technology other than those described in the Microsoft Dynamics CRM SDK.
  • Referencing any Microsoft Dynamics CRM dynamic-link libraries (DLLs) other than the following:
    • Microsoft.Xrm.Sdk.dll
    • Microsoft.Crm.Sdk.Proxy.dll
    • Microsoft.Xrm.Sdk.Workflow.dll
    • Microsoft.Xrm.Sdk.Deployment.dll
    • Microsoft.Crm.Outlook.Sdk.dll
    • Microsoft.Crm.Tools.EmailProviders.dll
  • The use of application programming interfaces (APIs) other than the documented APIs in the web services DeploymentService, DiscoveryService, Organization Data Service, SOAP endpoint for web resources and OrganizationService.
    To achieve the appearance and behavior of Microsoft Dynamics CRM, the reuse of any Microsoft Dynamics CRM user interface controls, including the grid controls. These controls may change or be overwritten during an upgrade. We do not recommend that you use or change the Default.css file in the Microsoft Dynamics CRM root installation folder.
  • The reuse of any Microsoft Dynamics CRM JavaScript code, including ribbon commands. This code may change or be overwritten during an upgrade.
  • Modifications to any one of the Microsoft Dynamics CRM forms or adding new forms, such as custom .aspx pages, directly to Microsoft Office Outlook or making changes to .pst files. These changes will not be upgraded.
  • Making customizations except when you use the Microsoft Dynamics CRM supported tools available offline in the CRM for Outlook.
  • The use of custom HttpModules to inject HTML/DHTML into the Microsoft Dynamics CRM Forms.
  • Creating a plug-in assembly for a standard Microsoft Dynamics CRM assembly (Microsoft.Crm.*.dll) or performing an update or delete of a platform created pluginassembly is not supported.
  • Microsoft Dynamics CRM 4.0 plug-ins and custom workflow activities are not supported.
  • Microsoft Dynamics CRM 4.0 Service Endpoint (2007 endpoint) is not supported.
  • Creating an Internet Information Services (IIS) application inside the Microsoft Dynamics CRM website for any VDir and specifically within the ISV folder is not supported. The <crmwebroot>\ISV folder is no longer supported.
  • Editing a solutions file to edit any solution components other than ribbons, forms, SiteMap, or saved queries is not supported. For more information, see When to edit the customizations file. Defining new solution components by editing the solutions file is not supported. Editing web resource files exported with a solution is not supported. Except for the steps documented in Maintain managed solutions, editing the contents of a managed solution is not supported.
  • Silverlight Application Library Caching is not supported.
  • Displaying an entity form within an IFrame embedded in another entity form is not supported.

See Also

Concepts

Choose your development style for managed code
Write code for Microsoft Dynamics CRM forms

Other Resources

Developer overview
Write applications and server extensions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Choose your development style for managed code

The Microsoft Dynamics CRM SDK offers a variety of methods and technologies to use when you write code to access the Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update web services or to extend the application. This guide highlights some tools and methods that you can use to accomplish different coding tasks, and offers some guidance on when to use them.

In This Topic

Authenticate using code

Create and deploy plug-ins or custom workflow activities

Create and deploy XAML workflows

Entity programming (early bound vs. late bound vs. developer extensions)

Query (Fetch vs. QueryExpressions vs. LINQ vs. Developer Extensions)

Authenticate using code

The following table lists the choices you have for writing code that authenticates the caller with an installation of Microsoft Dynamics CRM for on-premises, Internet-facing deployment (IFD), or online deployments.

Classes Description and usage More information

Helper code

The classes in the sample code demonstrate how to connect to the web services and authenticate the user. You can use the helper code as a basis of your own custom authentication code.

This code is easy to use and supports all Microsoft Dynamics CRM deployment types. It also supports storing users’ passwords in the Windows Credential Manager for later reuse.

Full source code is provided so you can copy and customize it for your needs. This is a recommended practice to isolate your programs from changes to this helper code in future releases.

Sample: Quick start for Microsoft Dynamics CRM

Use the sample and helper code

Helper code: ServerConnection class

This code can be found in the SampleCode\CS\HelperCode\CrmServiceHelpers.cs and SampleCode\VB\HelperCode\CrmServiceHelpers.vb files in the SDK. Download the Microsoft Dynamics CRM SDK package.

Developer Extensions

These assemblies are provided to simplify and accelerate the development of applications that interact with Microsoft Dynamics CRM. The extensions extend the functionality of the core Microsoft Dynamics CRM SDK specifically around the use of the OrganizationServiceContext class.

For an easy method that does the hard work for you in a few lines of code, use the CrmConnection class.

This code is easy to use and supports all Microsoft Dynamics CRM deployment types.

Developer extensions for Microsoft Dynamics CRM

Simplified connection to Microsoft Dynamics CRM

Xrm client

For advanced developers who need to customize the Windows Communication Foundation (WCF) service channel management and the authentication process, use the IServiceManagement`1 and OrganizationServiceProxy classes in the Microsoft.Xrm.Sdk.Client namespace.

Using these classes directly can provide better connection and authentication performance, and more flexibility. However, they require more advanced knowledge of the WCF service channel and server authentication. In addition, you must write more code to handle all Microsoft Dynamics CRM deployment types.

Active Directory and claims-based authentication

Sample: Authenticate users with Microsoft Dynamics CRM web services

Improve Service Channel Allocation Performance

XRM tooling

These assemblies leverage the CRM APIs to provide easy authentication support with fewer lines of code and through Windows PowerShell cmdlets. All the function calls in these classes provide thread-safety for actions performed in CRM in a multithreaded environment. It provides a common sign-in control with integrated authentication logic and an ability to securely store and reuse the authentication information to provide a consistent and seamless sign-in experience to CRM from your Windows client applications.

These classes also provide built-in diagnostic tracing to aid troubleshooting and performance reporting of the action calls from your Windows client applications.

These classes support all Microsoft Dynamics CRM deployment types and authentication types, except OAuth.

Build Windows client applications using the XRM tools

Use XRM tooling to connect to CRM

Use PowerShell cmdlets for XRM tooling to connect to CRM

Sample: Quick start for XRM Tooling API

Create and deploy plug-ins or custom workflow activities

The following table lists the choices you have for writing and deploying plug-ins and custom workflow activities.

Tool Description and usage More information

Plug-in and Custom Workflow Activity classes

Plug-in Registration Tool

The plug-in and custom workflow activity classes allow you to create event handlers to perform custom business logic that you can integrate with Microsoft Dynamics CRM to modify or augment the standard behavior of the platform.

By using these classes directly, your code will not contain any helper code provided in the Developer Toolkit.

If you write plug-ins and custom workflow activities from scratch, you must use the Plug-in Registration Tool to register them. This tool provides a graphical user interface and supports registering plug-ins and custom workflow activities with Microsoft Dynamics CRM.

Use this method if you:

Understand how to use the plug-in and custom activity classes.

Don't want extra library code auto-generated and placed in your code files.

Don't mind using an external tool and the web application to register and package custom code assemblies.

Plug-in development

Custom workflow activities (workflow assemblies)

Register and Deploy Plug-Ins

Walkthrough: Register a plug-in using the plug-in registration tool

Create and deploy XAML workflows

The following table lists the choices you have for writing and deploying XAML workflows.

Tool | Description and usage | More information
Microsoft Visual Studio Workflow Designer | Microsoft Dynamics CRM on-premises and IFD supports the ability to create custom XAML workflows. Using the Microsoft Visual Studio Workflow Designer, you can create custom XAML workflows, also called declarative workflows, by dragging workflow activities from the toolbox onto the design surface, creating variables, and setting properties of these activities to implement the workflow’s functionality. You can use built-in Windows Workflow Foundation activities or the process activities that are specific to Microsoft Dynamics CRM. Use this method when you just want to write custom XAML workflows. | Custom XAML workflows Write workflows to automate business processes

Entity programming (early bound vs. late bound vs. developer extensions)

The following table lists the choices you have for writing code that uses entities in Microsoft Dynamics CRM.

Class Description and usage More information

Early Bound

<optional namespace>.Account, <optional namespace>.Contact, and so on

The code generation tool (CrmSvcUtil) creates early-bound entity classes, derived from the Entity class, that you can use to access business data in Microsoft Dynamics CRM. These classes include one class for each entity in your installation, including custom entities.

Use this method when you want to have the compiler check type references at compile time. Also, attributes and relationships are included in the generated class, so they have IntelliSense support for entity, attribute, and relationship names. Using strong types is generally the preferred method and is used in the majority of samples in this SDK documentation.

There are some downsides to this approach:

Classes must be regenerated each time entities are customized to take advantage of schema changes.

Serialization costs increase as the entities are converted to late bound types during transmission over the network.

Use the early bound entity classes in code

Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)

Late Bound

Microsoft.Xrm. Entity

The Entity class contains the logical name of an entity and a property-bag array of the entity’s attributes. This lets you use late binding so that you can work with types such as custom entities and custom attributes that were not present when your application was compiled.

Another benefit of this is that less serialization occurs as entity data is transmitted over a network, which means higher performance.

There are some downsides to this approach:

Types must be explicitly specified to prevent implicit casts.

It is harder to isolate the impact of changes to the schema because the names for resources, such as entities and attributes, are hardcoded.

Spelling mistakes while coding are easier to make because the attribute names are hardcoded strings.

Use the late bound entity class in code

Developer Extensions

Microsoft.Xrm.Client. CrmEntity

The CrmEntity class derives from the Entity class. In addition to providing all the same functionality of the Entity class, CrmEntity adds new get and set extension methods to simplify common coding tasks, and two new property change events.

Developer extensions for Microsoft Dynamics CRM

Early Bound using Code Generation Tool Extensions

<optional namespace>.Account, <optional namespace>.Account, and so on

By using the Developer Extensions version of the CrmSvcUtil tool, you can generate early-bound types that are derived from the CrmEntity class. Use this when you want to take advantage of other features available in the Developer Extensions.

Generate code with the code generation tool extensions

Attach entities to the context

Developer extensions for Microsoft Dynamics CRM

Query (Fetch vs. QueryExpressions vs. LINQ vs. Developer Extensions)

The following table lists the choices you have for creating queries you can use to retrieve records from the Microsoft Dynamics CRM database.

Query style Description and usage More information

FetchXML

This is a custom XML-based query language that supports all the features of QueryExpression plus aggregates and grouping. Fetch queries can return records for multiple entities. In addition, queries can be serialized and saved in the database. This is used to save a query as a user-owned saved view in the UserQuery entity and as an organization-owned saved view in the SavedQuery entity.

Use this query language when you need support for aggregates and grouping or you need to save the query.

Build queries with FetchXML

QueryExpression

A query expression is used to search for records for a single entity type. Queries are built as an object model. This class supports all the features in FetchXML except for aggregates and grouping. It also supports both early and late bound entity programming styles.

Build queries with QueryExpression

LINQ

Queries are built using standard language, but internally .NET Language-Integrated Query (LINQ) uses QueryExpression, so it is limited to the features of QueryExpression. LINQ supports both early and late bound entity programming styles.

Build queries with LINQ (.NET language-integrated query)

See Also

Concepts

Tutorials for learning about development for Microsoft Dynamics CRM
The programming models for Microsoft Dynamics CRM

Other Resources

Developer overview
Write applications and server extensions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Subscribe to SDK assembly updates using NuGet

Microsoft Dynamics CRM SDK assemblies and some command-line tools are available through a software distribution website called nuget.org. Use of NuGet packages in your application project enables you to keep your project up-to-date with the latest releases of the SDK assemblies and tools. Microsoft Visual Studio has supported this capability since version 2010 and there is even a standalone NuGet client for those developers that don’t develop in Visual Studio. Another advantage of using NuGet packages in your projects is that assembly references and dependencies are automatically taken care of for you. NuGet packages are available for the Microsoft Dynamics CRM 2015 SDK as well as for the previous versions – 2011 and 2013.

Where to find the NuGet SDK packages

The CRM SDK packages can be found by searching the NuGet website for Microsoft.CrmSdk. The search results in a list of available CRM SDK packages. Select any package in the list to navigate to the package details page.

CRM 2015

On the package details page, select any package with a version number starting with 7.x. The package title indicates that the version of the package is for the CRM 2015 SDK. The package targets .NET Framework 4.5.2.

CRM 2013

On the package details page, select any package with a version number starting with 6.x. The package title indicates that the version of the package is for the CRM 2013 SDK. The package targets .NET Framework 4. Beginning with package version 6.1.1, the package also targets .NET Framework 4.5.

CRM 2011

On the package details page, select any package with a version number starting with 5.x. The package title indicates that the version of the package is for the CRM 2011 SDK. The package targets .NET Framework 4.

How to install a package in your project

For information about installing NuGet packages into your project, see Managing NuGet Packages Using the Dialog.

See Also

Other Resources

Developer overview
nuget DOCS
Installing NuGet
Manage Project Libraries with NuGet

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Tutorials for learning about development for Microsoft Dynamics CRM

This topic lists the walkthroughs that are included in the SDK, and tells you where to find videos, training, and sample code to get you started with development for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online. For the fastest way to get some code running, see Run a simple program using Microsoft Dynamics CRM web services.

Questions? Get help in the Microsoft Dynamics CRM Development Forum.

Need Support? Search the knowledge base or contact technical support.

In This Topic

Walkthroughs

Videos

Sample code

Other resources

Walkthroughs

The following table lists the walkthroughs that are available in this SDK documentation. The CRM Developer Center on MSDN shows these walkthroughs organized by topic area. Check it out!

Category | Link
Quick Start | Run a simple program using Microsoft Dynamics CRM web services
App Development | Walkthrough: Register a CRM app with Active Directory
Client Applications | Walkthrough: Use the Modern app SOAP endpoint with JavaScript
Developer Extensions | Walkthrough: Build a console application that connects to Microsoft Dynamics CRM using developer extensions
Developer Extensions | Walkthrough: Build a web application that connects to Microsoft Dynamics CRM using developer extensions
Plugins | Walkthrough: Configure assembly security for an offline plug-in
Plugins | Walkthrough: Register a plug-in using the plug-in registration tool
Plugins | Walkthrough: Register an Azure-aware plug-in with the CRM plug-in registration tool
Microsoft Azure | Walkthrough: Configure CRM for integration with Microsoft Azure
Microsoft Azure | Walkthrough: Configure Microsoft Azure ACS for integration with Microsoft Dynamics CRM 2015

Videos

Here is a series of feature overview videos to get you started: YouTube Videos.

Sample code

There are hundreds of samples found throughout this SDK documentation. For an alphabetical list, see Sample code directory.

Other resources

Looking for more developer resources? Here are some other sources of information:

  • Microsoft Dynamics CRM Developer Center on MSDN
  • Microsoft Dynamics CRM: Development Forum
  • Microsoft Dynamics CRM Team Blog
  • Community provided sample code on MSDN Code Gallery
  • Community provided open source projects on CodePlex

Looking for more than just developer information? Here are other sites and pointers to social media you can use:

  • Microsoft Dynamics CRM IT Pro Center on TechNet
  • Microsoft Dynamics CRM Customer Center
  • Microsoft Dynamics CRM pre-sales information
  • Microsoft Dynamics CRM: Deployment Forum
  • Certification Training
  • Contact CRM Customer Support
  • Microsoft Dynamics CRM YouTube Videos
  • Microsoft Dynamics CRM on Facebook
  • Microsoft Dynamics CRM group on Linkedin
  • Microsoft Dynamics CRM on Twitter

See Also

Tasks

Run a simple program using Microsoft Dynamics CRM web services

Other Resources

Developer overview
Write applications and server extensions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Run a simple program using Microsoft Dynamics CRM web services

This topic shows you how to compile and run a program that creates an account record, retrieves the record, updates the record, and then prompts to see if you would like the record deleted.

Prerequisites

  • Download the Microsoft Dynamics CRM SDK.
  • You must be able to sign in to Microsoft Dynamics CRM 2015 or Microsoft Dynamics CRM Online.
  • Microsoft Visual Studio 2012, or 2013
  • Microsoft .NET Framework 4.5.2

Compile and run the Quick Start sample

  1. Locate and open the SDK\SampleCode\CS\QuickStart folder.

  2. Open the QuickStart.csproj file in Visual Studio.

  3. Press F5 to compile and run the program.

  4. Enter the following information at the prompts:

    Prompt Description

    Enter a CRM server name and port [crm.dynamics.com]

    Type the name of your Microsoft Dynamics CRM server. The default is Microsoft Dynamics CRM Online (crm.dynamics.com) in North America.

    Example: myservername

    Example: myprefix.myservername:5500

    Example: crm5.dynamics.com

    Do not include the name of your organization or Internet protocol (http or https). You will be prompted for that later.

    Is this server configured for Secure Sockets Layer (https) (y/n) [n]

    Type y if the URL you use to access CRM 2015 begins with https://, otherwise type n. Microsoft Dynamics CRM Online users do not see this prompt.

    Is this organization provisioned in Microsoft Online Services (y/n) [n]

    Type y if this is a Microsoft Online Services provisioned organization. Otherwise, type n.

    Only Microsoft Dynamics CRM Online users see this prompt.

    Enter domain\username

    For Microsoft Dynamics CRM 2015, type your network domain and user name separated by a backslash (\). For Microsoft Dynamics CRM Online, enter your Microsoft account.

    On-premises/IFD Example: mydomain\tadams

    Online Example: terryadams@somedomain.onmicrosoft.com

    If you just press <Enter> for the user name, the program will look for and use saved credentials. If there are no saved credentials, the program will fail.

    Enter password

    Type your password. The characters will show as “*” in the window. Your password is securely saved in the Microsoft Credential Manager for later reuse.

    Specify an organization number (1-n) [1]

    From the list of organizations shown that you belong to, type the corresponding number. The default is 1, indicating the first organization in the list.

    Do you want these entity records deleted? (y/n) [y]

    Type y for yes and n for no. After the program runs, demonstrating create, retrieve and update of an account record, you can choose to delete the record that was created, or you can leave it so that you can view it in the Web application or Microsoft Dynamics CRM for Microsoft Office Outlook.

    Press Enter to exit

    Press Enter to exit the program.

Next Steps

After running the QuickStart program or most other SDK console-based samples, the server, organization, and user name information you entered when prompted is saved in an XML configuration file for re-use the next time you run a sample. This removes the need to enter that information again as you run additional samples. After the first time, the console prompts are as follows.

Prompt | Description
Specify the saved server configuration number (1-x) [x]: | Enter zero (0) to create a new server configuration and follow the prompts as shown in the table above. Otherwise, enter the number of a saved configuration as shown in the displayed list.
Enter Password: | Type your password. The characters will show as “*” in the window. If your password has been saved from a previous sample run, you will not see this prompt.
Do you want these entity records deleted? (y/n) [y] | Type y for yes and n for no. After the program runs, demonstrating create, retrieve and update of an account record, you can choose to delete the record that was created, or you can leave it so that you can view it in the Web application or Microsoft Dynamics CRM for Microsoft Office Outlook.
Press Enter to exit | Press Enter to exit the program.

If you would like to add or modify the functionality of this QuickStart program, you can modify the code in the CRUDOperations.cs file.

For more information about the helper code files that the QuickStart and many other SDK samples use, or to learn about how to set up a new project with the required assembly references, refer to Use the sample and helper code. For more information about the source code that handles saving and re-using the server configuration information, see Helper code: ServerConnection class.

A second sample project, named QuickStart with Simplified Connection, is included in the Microsoft Visual Studio solution. This second sample shows a simplified method to connect to the Microsoft Dynamics CRM Organization web service but is otherwise similar to the first QuickStart sample. This sample does not use any helper code to establish a web service connection.

See Also

Concepts

Tutorials for learning about development for Microsoft Dynamics CRM
Sample code directory

Other Resources

Sample: Quick start for Microsoft Dynamics CRM
Sample: Simplified connection quick start using Microsoft Dynamics CRM
Write applications and server extensions
Build a .NET Business Application in 60 Minutes with xRM and SharePoint

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Quick start for Microsoft Dynamics CRM
See Also Example

The QuickStart sample is a Microsoft .NET Framework managed code sample that shows how to connect to the Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online web services by using the ServerConnection helper class and perform basic create, update, retrieve, and delete operations on an entity.

Requirements

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK\SampleCode\CS\QuickStart

Demonstrates

This sample authenticates the user with the Microsoft Dynamics CRM web services by using the ServerConnection helper class and methods. After obtaining a reference to the Organization web service, the sample performs basic create, update, retrieve, and delete operations on an account entity. The sample also handles common exceptions that can be thrown.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.IdentityModel.Tokens;
using System.ServiceModel.Security;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll and
// Microsoft.Crm.Sdk.Proxy.dll assemblies.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to perform create, retrieve, update, and delete entity
    /// record operations.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// entity records created by this program.</remarks>
    public class CRUDOperations
    {
        static public void Main(string[] args)
        {
            // The connection to the Organization web service.
            OrganizationServiceProxy serviceProxy = null;

            try
            {
                // Obtain the target organization's web address and client logon credentials
                // from the user by using a helper class.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                // Establish an authenticated connection to the Organization web service.
                serviceProxy = new OrganizationServiceProxy(config.OrganizationUri, config.HomeRealmUri,
                                                            config.Credentials, config.DeviceCredentials);

                CRUDOperations app = new CRUDOperations();

                // Create any records that must exist in the database. These record references are
                // stored in a collection so the records can be deleted later.
                EntityReferenceCollection records =
                    app.CreateRequiredEntityRecords(serviceProxy);

                // Perform the primary operation of this sample.
                app.Run(serviceProxy, records);

                // Delete all remaining records that were created by this sample.
                app.DeleteEntityRecords(serviceProxy, records, true);
            }

            // Some exceptions to consider catching.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> e) { HandleException(e); }
            catch (TimeoutException e)                 { HandleException(e); }
            catch (SecurityTokenValidationException e) { HandleException(e); }
            catch (ExpiredSecurityTokenException e)    { HandleException(e); }
            catch (MessageSecurityException e)         { HandleException(e); }
            catch (SecurityNegotiationException e)     { HandleException(e); }
            catch (SecurityAccessDeniedException e)    { HandleException(e); }
            catch (Exception e)                        { HandleException(e); }

            finally
            {
                // Always dispose the service object to close the service connection and free resources.
                if (serviceProxy != null) serviceProxy.Dispose();

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        /// <summary>
        /// This method performs entity create, retrieve, and update operations.
        /// The delete operation is handled in the DeleteRequiredrecords() method.
        /// </summary>
        /// <param name="serviceProxy">An established connection to the Organization web service.</param>
        /// <param name="records">A collection of entity records created by this sample.</param>
        public void Run(OrganizationServiceProxy serviceProxy, EntityReferenceCollection records)
        {
            // Enable early-bound entity types. This enables use of IntelliSense in Visual Studio
            // and avoids spelling errors in attribute names when using the Entity property bag.
            serviceProxy.EnableProxyTypes();

            // Here we will use the interface instead of the proxy object.
            IOrganizationService service = (IOrganizationService)serviceProxy;

            // Display information about the logged on user.
            Guid userid = ((WhoAmIResponse)service.Execute(new WhoAmIRequest())).UserId;
            SystemUser systemUser = (SystemUser)service.Retrieve("systemuser", userid,
                new ColumnSet(new string[] {"firstname", "lastname"}));
            Console.WriteLine("Logged on user is {0} {1}.", systemUser.FirstName, systemUser.LastName);

            // Retrieve the version of Microsoft Dynamics CRM.
            RetrieveVersionRequest versionRequest = new RetrieveVersionRequest();
            RetrieveVersionResponse versionResponse =
                (RetrieveVersionResponse)service.Execute(versionRequest);
            Console.WriteLine("Microsoft Dynamics CRM version {0}.", versionResponse.Version);

            // Instantiate an account object. Note the use of the option set enumerations defined
            // in OptionSets.cs.
            Account account = new Account { Name = "Fourth Coffee" };
            account.AccountCategoryCode = new OptionSetValue((int)AccountAccountCategoryCode.PreferredCustomer);
            account.CustomerTypeCode = new OptionSetValue((int)AccountCustomerTypeCode.Investor);

            // Create an account record named Fourth Coffee.
            // Save the record reference so we can delete it during cleanup later.
            Guid accountId = service.Create(account);
            records.Add(new EntityReference(Account.EntityLogicalName, accountId));
            Console.Write("{0} {1} created, ", account.LogicalName, account.Name);

            // Retrieve the account containing several of its attributes. This results in
            // better performance compared to retrieving all attributes.
            ColumnSet cols = new ColumnSet(
                new String[] { "name", "address1_postalcode", "lastusedincampaign" });

            Account retrievedAccount = (Account)service.Retrieve("account", accountId, cols);
            Console.Write("retrieved, ");

            // Update the postal code attribute.
            retrievedAccount.Address1_PostalCode = "98052";

            // There is no address 2 postal code needed.
            retrievedAccount.Address2_PostalCode = null;

            // Shows use of a Money value.
            retrievedAccount.Revenue = new Money(5000000);

            // Shows use of a Boolean value.
            retrievedAccount.CreditOnHold = false;

            // Update the account record.
            service.Update(retrievedAccount);
            Console.WriteLine("and updated.");
        }

        /// <summary>
        /// Create any entity records that the Run() method requires.
        /// </summary>
        public EntityReferenceCollection CreateRequiredEntityRecords(OrganizationServiceProxy service)
        {
            // For this sample, all required entity records are created in the Run() method.
            return new EntityReferenceCollection();
        }

        /// <summary>
        /// Delete all remaining entity records that were created by this sample.
        /// <param name="prompt">When true, the user is prompted whether
        /// the records created in this sample should be deleted; otherwise, false.</param>
        /// </summary>
        public void DeleteEntityRecords(OrganizationServiceProxy  service,
                                        EntityReferenceCollection records, bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                while (records.Count > 0)
                {
                    EntityReference entityRef = records[records.Count-1];
                    service.Delete(entityRef.LogicalName, entityRef.Id);
                    records.Remove(entityRef);
                }

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        /// Handle a thrown exception.
        /// </summary>
        /// <param name="ex">An exception.</param>
        private static void HandleException(Exception e)
        {
            // Display the details of the exception.
            Console.WriteLine("\n" + e.Message);
            Console.WriteLine(e.StackTrace);

            if (e.InnerException != null) HandleException(e.InnerException);
        }
    }
}

See Also

Concepts

Tutorials for learning about development for Microsoft Dynamics CRM

Other Resources

Sample: Simplified connection quick start using Microsoft Dynamics CRM
Helper code: ServerConnection class

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Simplified connection quick start using Microsoft Dynamics CRM
See Also Example

This sample shows you how to connect to the Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update web services using the CrmConnection class and perform basic create, update, retrieve, and delete operations on an entity. For more information about the CrmConnection class, see Simplified connection to Microsoft Dynamics CRM in Developer extensions for Microsoft Dynamics CRM.

Requirements

The complete sample code can be found in the following location in the download package:

SDK\SampleCode\CS\QuickStart\SimplifiedConnection.cs

Download the Microsoft Dynamics CRM SDK package.

You must modify the supplied app.config file with connection information for your Microsoft Dynamics CRM server before running the sample. For more information, see Simplified connection to Microsoft Dynamics CRM and the commented out example connection strings in the app.config file.

Demonstrates

This sample authenticates the user with the Microsoft Dynamics CRM web services by using the CrmConnection class and methods. After obtaining a reference to the Organization web service, the sample performs basic create, update, retrieve, and delete operations on an account entity. The sample also handles common exceptions. No helper code is used to establish a connection to the Organization web service.

Example

The following shows a sample app.config file. To use this, remove the comment characters “<!- -” at the beginning of the <add … /> line and the “- ->” at the end on the line for the line that is relevant to your server and organization. Next, modify the attribute values as appropriate for your configuration.

Xml Copy Code
<?xml version="1.0"?>
<configuration>
  <connectionStrings>
    <!-- Online using Office 365 -->
    <!-- <add name="Server=CRM Online, organization=contoso, user=someone" connectionString="Url=https://contoso.crm.dynamics.com; Username=someone@contoso.onmicrosoft.com; Password=password;"/> -->
    <!-- Online using Microsoft account (formerly Windows Live ID) -->
    <!-- <add name="Server=CRM Online, organization=contoso, user=someone@example.com" connectionString="Url=https://contoso.crm.dynamics.com; Username=someone@example.com; Password=password; DeviceID=11hfn41bbqrg580vyvoea05abc; DevicePassword=fuqNIlx%e$.l*+ax_#8O4abc;"/>-->
    <!-- On-premises with provided user credentials -->
    <!-- <add name="Server=myserver, organization=AdventureWorksCycle, user=administrator" connectionString="Url=http://myserver/AdventureWorksCycle; Domain=mydomain; Username=administrator; Password=password;"/> -->
    <!-- On-premises using Windows integrated security -->
    <!--<add name="Server=myserver, organization=AdventureWorksCycle" connectionString="Url=http://myserver/AdventureWorksCycle;"/>-->
    <!-- On-premises (IFD) with claims -->
    <!--<add name="Server=litware.com, organization=contoso, user=someone@litware.com" connectionString="Url=https://contoso.litware.com; Username=someone@litware.com; Password=password;"/>-->
  </connectionStrings>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
  </startup>
</configuration>
C# Copy Code
using System;
using System.Configuration;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;

// These namespaces are found in the Microsoft.Xrm.Client.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Client;
using Microsoft.Xrm.Client.Services;
using System.Collections.Generic;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample uses the CrmConnection class found in the Microsoft.Xrm.Client
    /// namespace to connect to and authenticate with the organization web service.
    ///
    /// Next, the sample demonstrates how to do basic entity operations like create,
    /// retrieve, update, and delete.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the database
    /// records created by this program.
    ///
    /// No helper code from CrmServiceHelpers.cs is used in this sample.</remarks>
    /// <see cref="http://msdn.microsoft.com/en-us/library/gg695810.aspx"/>
    public class SimplifiedConnection
    {
        #region Class Level Members

        private Guid _accountId;
        private OrganizationService _orgService;

        #endregion Class Level Members

         /// <summary>
        /// The Run() method first connects to the Organization service. Afterwards,
        /// basic create, retrieve, update, and delete entity operations are performed.
        /// </summary>
        /// <param name="connectionString">Provides service connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(String connectionString, bool promptforDelete)
        {
            try
            {
                // Establish a connection to the organization web service using CrmConnection.
                Microsoft.Xrm.Client.CrmConnection connection = CrmConnection.Parse (connectionString);

                // Obtain an organization service proxy.
                // The using statement assures that the service proxy will be properly disposed.
                using (_orgService = new OrganizationService(connection) )
                {
                    //Create any entity records this sample requires.
                    CreateRequiredRecords();

                    // Obtain information about the logged on user from the web service.
                    Guid userid = ((WhoAmIResponse)_orgService.Execute(new WhoAmIRequest())).UserId;
                    SystemUser systemUser = (SystemUser)_orgService.Retrieve("systemuser", userid,
                        new ColumnSet(new string[] { "firstname", "lastname" }));
                    Console.WriteLine("Logged on user is {0} {1}.", systemUser.FirstName, systemUser.LastName);

                    // Retrieve the version of Microsoft Dynamics CRM.
                    RetrieveVersionRequest versionRequest = new RetrieveVersionRequest();
                    RetrieveVersionResponse versionResponse =
                        (RetrieveVersionResponse)_orgService.Execute(versionRequest);
                    Console.WriteLine("Microsoft Dynamics CRM version {0}.", versionResponse.Version);

                    // Instantiate an account object. Note the use of option set enumerations defined in OptionSets.cs.
                    // Refer to the Entity Metadata topic in the SDK documentation to determine which attributes must
                    // be set for each entity.
                    Account account = new Account { Name = "Fourth Coffee" };
                    account.AccountCategoryCode = new OptionSetValue((int)AccountAccountCategoryCode.PreferredCustomer);
                    account.CustomerTypeCode = new OptionSetValue((int)AccountCustomerTypeCode.Investor);

                    // Create an account record named Fourth Coffee.
                    _accountId = _orgService.Create(account);

                    Console.Write("{0} {1} created, ", account.LogicalName, account.Name);

                    // Retrieve the several attributes from the new account.
                    ColumnSet cols = new ColumnSet(
                        new String[] { "name", "address1_postalcode", "lastusedincampaign" });

                    Account retrievedAccount = (Account)_orgService.Retrieve("account", _accountId, cols);
                    Console.Write("retrieved, ");

                    // Update the postal code attribute.
                    retrievedAccount.Address1_PostalCode = "98052";

                    // The address 2 postal code was set accidentally, so set it to null.
                    retrievedAccount.Address2_PostalCode = null;

                    // Shows use of a Money value.
                    retrievedAccount.Revenue = new Money(5000000);

                    // Shows use of a Boolean value.
                    retrievedAccount.CreditOnHold = false;

                    // Update the account record.
                    _orgService.Update(retrievedAccount);
                    Console.WriteLine("and updated.");

                    // Delete any entity records this sample created.
                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #region Public Methods
        /// <summary>
        /// Creates any entity records this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // For this sample, all required entities are created in the Run() method.
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _orgService.Delete(Account.EntityLogicalName, _accountId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion Public Methods

        #region Private Methods

        /// <summary>
        /// Gets web service connection information from the app.config file.
        /// If there is more than one available, the user is prompted to select
        /// the desired connection configuration by name.
        /// </summary>
        /// <returns>A string containing web service connection configuration information.</returns>
        private static String GetServiceConfiguration()
        {
            // Get available connection strings from app.config.
            int count = ConfigurationManager.ConnectionStrings.Count;

            // Create a filter list of connection strings so that we have a list of valid
            // connection strings for Microsoft Dynamics CRM only.
            List<KeyValuePair<String, String>> filteredConnectionStrings =
                new List<KeyValuePair<String, String>>();

            for (int a = 0; a < count; a++)
            {
                if (isValidConnectionString(ConfigurationManager.ConnectionStrings[a].ConnectionString))
                    filteredConnectionStrings.Add
                        (new KeyValuePair<string, string>
                            (ConfigurationManager.ConnectionStrings[a].Name,
                            ConfigurationManager.ConnectionStrings[a].ConnectionString));
            }

            // No valid connections strings found. Write out and error message.
            if (filteredConnectionStrings.Count == 0)
            {
                Console.WriteLine("An app.config file containing at least one valid Microsoft Dynamics CRM " +
                    "connection string configuration must exist in the run-time folder.");
                Console.WriteLine("\nThere are several commented out example connection strings in " +
                    "the provided app.config file. Uncomment one of them and modify the string according " +
                    "to your Microsoft Dynamics CRM installation. Then re-run the sample.");
                return null;
            }

            // If one valid connection string is found, use that.
            if (filteredConnectionStrings.Count == 1)
            {
                return filteredConnectionStrings[0].Value;
            }

            // If more than one valid connection string is found, let the user decide which to use.
            if (filteredConnectionStrings.Count > 1)
            {
                Console.WriteLine("The following connections are available:");
                Console.WriteLine("------------------------------------------------");

                for (int i = 0; i < filteredConnectionStrings.Count; i++)
                {
                    Console.Write("\n({0}) {1}\t",
                    i + 1, filteredConnectionStrings[i].Key);
                }

                Console.WriteLine();

                Console.Write("\nType the number of the connection to use (1-{0}) [{0}] : ",
                    filteredConnectionStrings.Count);
                String input = Console.ReadLine();
                int configNumber;
                if (input == String.Empty) input = filteredConnectionStrings.Count.ToString();
                if (!Int32.TryParse(input, out configNumber) || configNumber > count ||
                    configNumber == 0)
                {
                    Console.WriteLine("Option not valid.");
                    return null;
                }

                return filteredConnectionStrings[configNumber - 1].Value;

            }
            return null;

        }

        /// <summary>
        /// Verifies if a connection string is valid for Microsoft Dynamics CRM.
        /// </summary>
        /// <returns>True for a valid string, otherwise False.</returns>
        private static Boolean isValidConnectionString(String connectionString)
        {
            // At a minimum, a connection string must contain one of these arguments.
            if (connectionString.Contains("Url=") ||
                connectionString.Contains("Server=") ||
                connectionString.Contains("ServiceUri="))
                return true;

            return false;
        }

        #endregion Private Methods

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain connection configuration information for the Microsoft Dynamics
                // CRM organization web service.
                String connectionString = GetServiceConfiguration();

                if (connectionString != null)
                {
                    SimplifiedConnection app = new SimplifiedConnection();
                    app.Run(connectionString, true);
                }
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }

            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Tutorials for learning about development for Microsoft Dynamics CRM
Simplified connection to Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Quick start for XRM Tooling API
See Also Example

The QuickStart sample is a Microsoft .NET Framework managed code sample that shows how to connect to a Microsoft Dynamics CRM instance by using the XRM Tooling APIs, and perform basic create, update, retrieve, and delete operations on an entity. For more information about XRM Tooling, see Build Windows client applications using the XRM tools.

Requirements

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK\SampleCode\CS\XRMTooling

Demonstrates

  • The sample code is built using the WPF Application for CRM SDK template that provides a common login control with built-in support for authentication and credential caching and reuse. For more information about the common login control and how to use the SDK template in Microsoft Visual Studio, see Use the XRM tooling common login control in your client applications.
  • No helper code is used to establish a connection to CRM.
  • After connecting to CRM, the sample performs basic create, update, retrieve, and delete operations on an account entity.
  • Stores user credentials in a configuration file (Default_QuickStartXRMToolingWPFClient.exe.config) in the c:\Users\<username>\AppData\Roaming\Microsoft\QuickStartXRMToolingWPFClient folder when the sample is run for the first time, and thereafter prompts the user to either use the stored or specify new credentials at runtime to sign in to CRM.
  • Generates the following log files, if any issue occurs, to aid troubleshooting:
    • Login_ErrorLog.log: To report sign-in errors. This file is available at C:\Users\<username>\AppData\Roaming\Microsoft\QuickStartXRMToolingWPFClient.
    • QuickStartXRMToolingWPFClient.log: To report operational errors. This file is available at the same location as the executable, that is in the debug folder of your Microsoft Visual Studio project.

To run the sample

  1. Locate and open the SDK\SampleCode\CS\XRMTooling folder.
  2. Open the QuickStartXRMToolingWPFClient.sln file in Visual Studio.
  3. Press F5 to compile and run the program.

Example

Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Windows;
using System.Windows.Controls;
using System.Windows.Data;
using System.Windows.Documents;
using System.Windows.Input;
using System.Windows.Media;
using System.Windows.Media.Imaging;
using System.Windows.Navigation;
using System.Windows.Shapes;

// This namespace is automatically added for using
// components in LoginWindow\CrmLogin.xaml (common login control).
using QuickStartXRMToolingWPFClient.LoginWindow;

// Add this namespace for performing
// various operations in CRM.
using Microsoft.Xrm.Tooling.Connector;

namespace QuickStartXRMToolingWPFClient
{
    /// <summary>
    /// Demonstrates how to do basic entity operations like create, retrieve,
    /// update, and delete using the XRM Tooling APIs and the common login
    /// control.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public partial class MainWindow : Window
    {
        public MainWindow()
        {
            InitializeComponent();
            btnDelete.Visibility = Visibility.Hidden;
        }

        #region Class Level Members

        private CrmLogin _ctrl = null;
        private Guid _accountId;

        #endregion Class Level Members

        #region How To Sample Code

        /// <summary>
        /// Connect to Microsoft Dynamics CRM, and get an instance of CRMServiceClient
        /// </summary>

        private void LoginButton_Click(object sender, RoutedEventArgs e)
        {
            // Create an instance of the XRM Tooling common login control
            _ctrl = new CrmLogin();

            /// Wire event to the CRM sign-in response.
            _ctrl.ConnectionToCrmCompleted += ctrl_ConnectionToCrmCompleted;
            UpdateStatus("Initiating connection to CRM...");

            /// Show the XRM Tooling common login control.
            _ctrl.ShowDialog();

            /// Validate if you are connected to CRM
            if (_ctrl.CrmConnectionMgr != null && _ctrl.CrmConnectionMgr.CrmSvc != null && _ctrl.CrmConnectionMgr.CrmSvc.IsReady)
            {
                UpdateStatus("Connected to CRM! (Version: " + _ctrl.CrmConnectionMgr.CrmSvc.ConnectedOrgVersion.ToString() +
                    "; Org: " + _ctrl.CrmConnectionMgr.CrmSvc.ConnectedOrgUniqueName.ToString() + ")");
                UpdateStatus("***************************************");
                UpdateStatus("Click Start to create, retrieve, update, and delete (optional) an account record.");
                btnSignIn.IsEnabled = false;
                btnCRUD.IsEnabled = true;
            }
            // If you are not connected to CRM; display the last error and last CRM excption
            else
            {
                UpdateStatus("The connection to CRM failed or was cancelled by the user.");
            }
        }

        private void btnCRUD_Click(object sender, RoutedEventArgs e)
        {
            // Create an account record
            Dictionary<string, CrmDataTypeWrapper> inData = new Dictionary<string, CrmDataTypeWrapper>();
            inData.Add("name", new CrmDataTypeWrapper("Sample Account Name", CrmFieldType.String));
            inData.Add("address1_city", new CrmDataTypeWrapper("Redmond", CrmFieldType.String));
            inData.Add("telephone1", new CrmDataTypeWrapper("555-0160", CrmFieldType.String));
            _accountId = _ctrl.CrmConnectionMgr.CrmSvc.CreateNewRecord("account", inData);

            // Validate if the account is created, and then retrieve it
            if (_accountId != Guid.Empty)
            {
                UpdateStatus("***************************************");
                UpdateStatus(DateTime.Now.ToString() + ": Created an account with the following" + "\n" + "details, and retrieved it:");
                Dictionary<string, object> data = _ctrl.CrmConnectionMgr.CrmSvc.GetEntityDataById("account", _accountId, null);
                foreach (var pair in data)
                {
                    if ((pair.Key == "name") || (pair.Key == "address1_city") || (pair.Key == "telephone1"))
                    {
                        UpdateStatus(pair.Key.ToUpper() + ": " + pair.Value);
                    }
                }
                btnCRUD.IsEnabled = false;
            }
            else
            {
                UpdateStatus("***************************************");
                UpdateStatus("Could not create the account.");
            }

            // Update the account record
            Dictionary<string, CrmDataTypeWrapper> updateData = new Dictionary<string, CrmDataTypeWrapper>();
            updateData.Add("name", new CrmDataTypeWrapper("Updated Sample Account Name", CrmFieldType.String));
            updateData.Add("address1_city", new CrmDataTypeWrapper("Boston", CrmFieldType.String));
            updateData.Add("telephone1", new CrmDataTypeWrapper("555-0161", CrmFieldType.String));
            bool updateAccountStatus = _ctrl.CrmConnectionMgr.CrmSvc.UpdateEntity("account","accountid",_accountId,updateData);

            // Validate if the the account record was updated successfully, and then display the updated information
            if (updateAccountStatus == true)
            {
                UpdateStatus("***************************************");
                UpdateStatus(DateTime.Now.ToString() + ": Updated the account details as follows:");
                Dictionary<string, object> data = _ctrl.CrmConnectionMgr.CrmSvc.GetEntityDataById("account", _accountId, null);
                foreach (var pair in data)
                {
                    if ((pair.Key == "name") || (pair.Key == "address1_city") || (pair.Key == "telephone1"))
                    {
                        UpdateStatus(pair.Key.ToUpper() + ": " + pair.Value);
                    }
                }
            }
            else
            {
                UpdateStatus("***************************************");
                UpdateStatus("Could not update the account.");
            }

            // Prompt the user to delete the account record created in the sample
            UpdateStatus("***************************************");
            UpdateStatus("To delete the account record created by the sample, click Delete Record.");
            UpdateStatus("Otherwise, click Exit to close the sample application.");
            btnDelete.Visibility = Visibility.Visible;
        }

        // Delete the account record created in this sample.
        private void btnDelete_Click(object sender, RoutedEventArgs e)
        {
            btnDelete.IsEnabled = false;
            _ctrl.CrmConnectionMgr.CrmSvc.DeleteEntity("account", _accountId);
            UpdateStatus("***************************************");
            UpdateStatus(DateTime.Now.ToString() + ": Deleted the account record.");
            UpdateStatus("Click Exit to close the sample application.");
        }

        // Exit the sample application
        private void btnExit_Click(object sender, RoutedEventArgs e)
        {
            this.Close();
        }

        /// <summary>
        /// Progressively displays the status messages about the actions
        /// performed during the running of the sample.
        /// <param name="updateText">Indicates the status string that needs to be
        /// displayed to the user.</param>
        /// </summary>
        public void UpdateStatus(string updateText)
        {
            if (lblStatus.Content.ToString() != String.Empty)
            {
                lblStatus.Content = lblStatus.Content + "\n" + updateText;
            }
            else
            {
                lblStatus.Content = updateText;
            }
        }

        /// <summary>
        /// Raised when the login process is completed.
        /// </summary>
        private void ctrl_ConnectionToCrmCompleted(object sender, EventArgs e)
        {
            if (sender is CrmLogin)
            {
                this.Dispatcher.Invoke(() =>
                {
                    ((CrmLogin)sender).Close();
                });
            }
        }
    }
    #endregion How To Sample Code

}

See Also

Concepts

Use the XRM tooling common login control in your client applications
Build Windows client applications using the XRM tools
Tutorials for learning about development for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Model your business data

Microsoft Dynamics CRM provides a robust and customizable data model that uses entities to define the data tracked in the system. This section describes the out-of-the-box entities that correspond to the areas shown in the web application. These entities are defined by metadata. For more information about how to customize entities, see Extend the metadata model.

In This Section

Introduction to entities in Microsoft Dynamics CRM

Introduction to entity attributes in Microsoft Dynamics CRM

Administration and security entities

Activity feeds entities

Customer entities (account, contact)

Business management entities

Sales entities (lead, opportunity, competitor, quote, order, invoice)

Marketing entities (campaign, list)

Service entities (contract, incident, knowledge base, queue, calendar, entitlement, slakpiinstance)

Activity entities

Server-side synchronization entities

Goal management entities

Product catalog entities

Sales literature entities

Schedule and appointment entities

Social entities

Template entities

Annotation (note) entity

UserQuery (saved view) entity

See Also

Other Resources

Software Development Kit for Microsoft Dynamics CRM
Developer tools

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Introduction to entities in Microsoft Dynamics CRM

The entities are used to model and manage business data in Microsoft Dynamics CRM. For example, entities such as account, campaign, and incident (case) can be used to track and support sales, marketing, and service activities. An entity has a set of attributes and each attribute represents a data item of a particular type. For example, the account entity has Name, Address, and OwnerId attributes. Conceptually, an entity is like a database table, and the entity attributes correspond to the table columns. Creating an entity record (or, simply a record) in Microsoft Dynamics CRM is like adding a record in a database table. The entities are divided into three categories: system, business, and custom. As a developer working with business data, you will use business and custom entities. System entities are used by Microsoft Dynamics CRM to handle all internal processes, such as workflows and asynchronous jobs. You cannot delete or customize system entities.

Business entities are part of the Microsoft Dynamics CRM default installation and they appear in the customization user interface. An account, contact, and letter are examples of business entities. After installation, you can add custom entities to Microsoft Dynamics CRM to address specific business needs of the organization. In a Microsoft Dynamics CRM Solution, you can set business and custom entities and attributes to be either customizable or non-customizable. You can modify a customizable entity by renaming it, adding new attributes, or changing various settings, such as duplicate detection or queue support settings. You cannot modify a non-customizable entity. For more information about customization, unmanaged and managed solutions, and managed properties, see Package and distribute extensions using solutions.

If you are using the early-bound programming model, an entity is represented by a class, such as the Account class that represents the account entity. Entity attributes are represented by class properties. This class is generated by the CrmSvcUtil tool. For more information, see Use the early bound entity classes in code. Alternatively, you can write programs that work with entity data by using a dynamic approach. For more information, see Use the late bound entity class in code.

Note
In the Microsoft Dynamics CRM SDK documentation, the term “entity attribute” is used interchangeably with the term “attribute” and the term “property” (class property).

In This Topic

Entity metadata

Actions on entity records

Entity ownership

Record state and status

Entity images

Entity metadata

The metadata for a Microsoft Dynamics CRM organization contains the definitions for the entities, attributes, and the relationships between the entities. For more information, see The metadata and data models in Microsoft Dynamics CRM. As a developer there are many cases where it is useful to be able to find all the metadata for an organization. There are a number of ways you can find and reference the metadata:

  • You can use the Entity Metadata Browser to view entities and their properties in Microsoft Dynamics CRM. For details, see Browse the metadata for your organization.
  • The SDK package contains this same information in an Microsoft Office Excel spreadsheet. You can find this in the file SDK\Tools\EntityMetadata.xlsx.
  • You can generate the metadata for your organization using these samples:
    • Sample: Dump entity metadata to a file
    • Sample: Dump entity privilege information to a file
    • Sample: Dump attribute metadata to a file
    • Sample: Dump entity relationship information to a file
    • Sample: Dump global option set information to a file

You can create the following types of the relationships between entities: one-to-many, many-to-one, and many-to-many. The records for a many-to-many relationships are stored in an intersect entity. After a relationship is defined, use the AssociateRequest message or the Associate method to create a link between the specified records, and use the DisassociateRequest message or the Disassociate method to remove a link between the specified records.

In the one-to-many and many-to-one relationships, some actions on the parent entity record affect the child entity records. The actions that have cascading behavior include: Assign, Delete, Merge, Share, Unshare and Reparent. For more information, see Entity relationship behavior.

Names used in entity metadata

Entities, attributes, and relationships have several different names. The following table lists the various names that are used in the metadata.

Name | Description
Display Name | The name that is displayed to the user.
Display Collection Name | A plural version of the display name. This only applies to entities.
Logical Name | The unique name of the entity or attribute. This name is all lowercase.
Schema Name | The schema name is specified upon creation. It must be unique. It is used to create the logical name. This name should be in Pascal case. The schema name is used to create the class for the entity when using early bound programming.
Note
For a custom entity, attribute, and relationship created in the context of a solution, the customization prefix in the logical and schema names is defined in the Publisher.CustomizationPrefix attribute. For a custom entity created programmatically, set the customization prefix to a string that is between two and eight characters in length, all alphanumeric characters starting with a letter. It cannot start with “mscrm”. For more information about entity metadata customization and naming conventions, see Customize entity metadata.

Actions on entity records

Each entity supports several different actions, for example create or delete a record, or assign a record to another user or team. Not all actions are allowed on all entity types or attributes. For each attribute, the metadata defines whether a given action is supported. For example, an attribute’s properties, such as IsValidForCreate, IsValidForRead and IsValidForUpdate tell you if you can create, retrieve or update the attribute. More information: Valid operations on attributes.

To perform an action, you call one of the methods in IOrganizationService. For example, to create a record in Microsoft Dynamics CRM, you can use the IOrganizationService.Create method or the IOrganizationService.Execute method with the corresponding CreateRequest message. You must have the necessary privileges and access rights to perform these actions. For more information, see The security model of Microsoft Dynamics CRM.

The following table lists the actions that are allowed on business and custom entity records and the methods and messages that you can use to perform these actions.

Action | Description | Method and/or Message
Create | Creates a record of a specific entity type, including custom entities. | IOrganizationService.Create CreateRequest
Update | Modifies the contents of a record. | IOrganizationService.Update UpdateRequest
Delete | Deletes a record. | IOrganizationService.Delete DeleteRequest
Retrieve | Retrieves a record. | IOrganizationService.Retrieve RetrieveRequest
Retrieve Multiple | Retrieves a collection of records. | IOrganizationService.RetrieveMultiple RetrieveMultipleRequest
Assign | Changes ownership of a record. Valid for user-owned or team-owned entities. | AssignRequest
Share | Grants, modifies or revokes access to a record to another user or team. Valid for user-owned or team-owned entities. | GrantAccessRequest ModifyAccessRequest RevokeAccessRequest
Associate | Creates links between a record and a collection of records where there is a relationship between the entities. | AssociateRequest
Disassociate | Removes links between a record and a collection of records where there is a relationship between the entities. | DisassociateRequest
Set State | Set the state of a record. | SetStateRequest

Create

To perform this action, the caller must have Create message privileges. Access rights do not apply to the Create action, but they do apply to the record after it has been created.

To own a record or to retrieve the newly created record, a user or team must also have read privileges and access rights on the new record. For example, if you have create privileges for accounts, you can create an account record and assign it to another user or team. However, unless you also have read privilege for accounts, and access rights on the new record, you cannot create an account and be the owner of that new account.

Update

To perform this action, the caller must have Update message privileges and access rights on the entity records that are being updated.

When you update a record, only the attributes for which you specify data or for which you specify null are updated. All other values remain the same. Also, if you specify data for attributes that are not valid for update, they are ignored.

Delete

To perform this action, the caller must have Delete message privileges and access rights on the entity records being deleted.

The cascading rules determine whether related records are deleted at the same time. For more information, see Entity relationship behavior.

Typically, you should only delete records that you entered by mistake. For some record types, you can deactivate or close the record instead of deleting it. Not all record types can be deleted.

Retrieve

To perform this action, the caller must have Retrieve message privileges and access rights on the entity records retrieved.

Retrieve multiple

To perform this action, the caller must have Retrieve message privileges and access rights on the entity records retrieved.

To retrieve a collection of records based on the query parameters, you can either use a query expression or FetchXML query language. Query expressions let you build a query tree by using a class hierarchy. The methods that use a query expression return a collection of strongly typed records. FetchXML lets you build a query by using an XML language. FetchXML returns an XML string. Therefore, you must do more data manipulation to use the query results. For more information, see Retrieve data with queries.

Assign

For user-owned or team-owned entities, you assign a record to a new owner. For more information, see Entity Ownership. To perform this action, the caller must have Assign message privileges and access rights on the entity records.

The cascading rules determine whether related records are assigned to another user at the same time. For more information, see Entity relationship behavior.

When a record is assigned to another user or team, the previous owner still has access to this record if the ShareToPreviousOwnerOnAssign attribute is set to true. However, the previous owner will no longer have ownership of the record.

Share

For user-owned or team-owned entities, you can share a record with other users or teams. To perform this action, the caller must have GrantAccess message privileges, ModifyAccess message privileges, and RevokeAccess message privileges and access rights on the entity records.

The cascading rules determine whether related records are shared at the same time. For more information, see Entity relationship behavior

Sharing is the way Microsoft Dynamics CRM users can give other users access to customer information as needed. For example, a salesperson might decide to share an opportunity with another salesperson so that they can both track the progress of an important sale.

Use the GrantAccessRequest to share a record. Use the ModifyAccessRequest to change how a record is shared. Use the RevokeAccessRequest to remove all sharing for the record.

A user must have share rights to share customer-related records, such as contacts, accounts, opportunities, cases, and orders, with any other user in Microsoft Dynamics CRM. When a record is shared, you can specify the rights to grant for the shared record.

The following list describes the rules for sharing records:

  • Anyone with share privileges on a record can share it with additional users or teams.
  • Anyone with share privileges on a record can set access rights for that record. These access rights control how a user who shares a record can access that record.
  • Access on a shared record can be set to any access right, for example, read or write.
  • Access rights on a shared record can be different for each user that the record is shared with.
  • A record can be shared with the same security principal only one time. A user can share a record if they have share privileges on that record.
  • Anyone with share privileges on a business record can modify the access rights for users who have the record shared.
  • Anyone with share privileges on a business record can remove sharing for a specified user who has the record shared.
  • Anyone with share privileges on a business record can remove sharing for all users with whom the record was previously shared.

Associate

To perform this action, the caller must have Associate message privileges and access rights on the records that are being updated.

Associate creates multiple associations in one transaction between the specified record and each record in the specified collection for the relationship specified.

For a one-to-many relationship, this method sets the ReferencingAttribute in the related record to the ID of the specified record.

For a many-to-many relationship, this method creates a record in the intersect table for the relationship, which contains the ID of both the referenced and referencing records. The intersect table name is defined in the IntersectEntityName property for the relationship.

Disassociate

To perform this action, the caller must have Disassociate message privileges and access rights on the records that are being updated.

Disassociate reverses the associate operation, by updating the referenced and referencing records and deleting the intersect record where appropriate. For more information, see Associate.

Set State

To perform this action, the caller must have SetState message privileges and access rights on the records that are being updated. The SetStateRequest message updates the StateCode and StatusCode attributes of the entity record.

Entity ownership

There are several types of entity ownership. Most entities, including custom entities, are owned by the organization, by a user, or a team. There are some business entities that do not have an owner, such as discount type (discount list), where the ownership is defined by its parent entity discount. The type of ownership defines some of the operations that can be performed on a record. Ownership for an entity is defined in the metadata property OwnershipType. The following table lists the ownership properties.

Ownership Type | Description
Organization Owned | Contains data involving something that belongs to or that can be viewed by the whole organization. Organization-owned entities cannot be assigned or shared. For example, products are owned by the organization. These entities have an attribute named organizationid.
Business Owned | Entities that belong to a business unit. These entities have an attribute named owningbusinessunit.
User or Team Owned | Assigned to a user or to a team. These entities contain data that relates to customers, such as accounts or contacts. Security can be defined according to the business unit for the user or team. These entities have attributes named owningteam and owninguser.
None | These entities are not owned by another entity.

Additional Information about User or Team Ownership

You can use the AssignRequest message to change the ownership of a record. For more information, see Assign. You can use the ReassignObjectsOwnerRequest or ReassignObjectsSystemUserRequest message to do bulk reassignment of all records for an owner.

Note
By limiting ownership to users or teams, you restrict access to data to authorized users in the organization. However, you can expand data access to additional users and teams by sharing an entity record with them. You can also assign a record to another user or team. Configuring security for user-owned or team-owned entities gives you more access levels for the security roles than for organization-owned entities. The security roles for organization-owned entities have two access levels: None and Global. The user-owned or team-owned entities have five access levels: Global, Deep, Local, Basic, and None.

Record state and status

Most business entities have two properties to track the state of a record. These are StateCode, which is called Status in the Web application and StatusCode, which is called Status Reason in the Web application. The StateCode and StatusCode attribute values are linked. The StateCode attribute is used internally to represent the status of the entity. The StatusCode attribute is used to display this value to the end user. The set of valid state codes for an entity is not customizable, but the status codes are customizable. For the case entity and custom entities, you can define additional criteria for valid transitions between statuses. For more information, see Customize entity attribute metadata and Define custom state model transitions.

Entity images

Certain system entities have image attributes. You can add image attributes to custom entities. When an entity has an image attribute, you can set the PrimaryImageAttribute property to control whether the image will be shown in the application. When the image is shown in the application users of the web application can upload pictures for the entity record. The following system entities have image attributes. Those marked with an asterisk are enabled by default to show them in the application.

Account * | KbArticle | Campaign
Incident | Competitor * | Connection
Contact * | Contract | TransactionCurrency
EmailServerProfile | Goal | Invoice
Lead * | Mailbox | OpportunityProduct
SalesOrder | Organization | Product *
Publisher * | Queue | Resource *
SalesLiterature | Territory | SystemUser *

More information: Image data attributes.

See Also

Concepts

Use metadata to generate entity diagrams
Define custom state model transitions
Key to entity diagrams
Customize entity relationship metadata
Entity relationship behavior
The metadata and data models in Microsoft Dynamics CRM
IOrganizationService entities

Other Resources

Administration and security entities
Model your business data
Extend the metadata model
Package and distribute extensions using solutions
The security model of Microsoft Dynamics CRM
Sample: Set and retrieve entity images
Sample: Assign a record to a team
Sample: Share records using GrantAccess, ModifyAccess and RevokeAccess messages
Sample: Merge two records
Sample: Validate record state and set the state of the record
Sample: Rollup records related to a specific record

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use metadata to generate entity diagrams

Visual representation of metadata can be very useful, especially when you are trying to describe the relationship between entities in the system. You can use the Metadata Diagram sample code provided for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update to generate the entity relationship diagrams. You can create a simple diagram that shows a relationship for just one entity, or a complex diagram that includes dozens of related entities, including custom and system entities.

In This Topic

Relationships in entity diagrams

About the diagrams

Generate entity diagrams with the metadata diagram Tool

Relationships in entity diagrams

The following example shows two new custom entities created in Microsoft Dynamics CRM. The first entity represents a bank account and the second entity represents a safe deposit box. The following entity diagram was generated by using the Metadata Diagram tool. It shows the relationship between the new_bankaccount entity, the new_safedepositbox entity, and other entities in the system. The names shown are the logical entity names. Note that if there are multiple relationships between the same two entities, only one line is drawn in the diagram for simplicity.

Entity relationship diagram for custom entities

The following table shows the one-to-many relationships where the primary entity is either bank account or safe deposit box.

Relationship schema name | Referencing entity
new_bankaccount_ActivityPointers | activitypointer
new_bankaccount_Appointments | appointment
new_bankaccount_Emails | email
new_bankaccount_Faxes | fax
new_bankaccount_Letters | letter
new_bankaccount_PhoneCalls | phonecall
new_bankaccount_ServiceAppointments | serviceappointment
new_bankaccount_Tasks | task
new_bankaccount_RecurringAppointmentMasters | recurringappointmentmaster
new_bankaccount_DuplicateMatchingRecord | duplicaterecord
new_bankaccount_DuplicateBaseRecord | duplicaterecord
new_bankaccount_Annotations | annotation
new_bankaccount_AsyncOperations | asyncoperation
new_bankaccount_UserEntityInstanceDatas | userentityinstancedata
new_bankaccount_ProcessSession | processsession
new_bankaccount_BulkDeleteFailures | bulkdeletefailure
new_bankaccount_PrincipalObjectAttributeAccesses | principalobjectattributeaccess
new_new_bankaccount_new_safedepositbox | new_safedepositbox
new_safedepositbox_ActivityPointers | activitypointer
new_safedepositbox_Appointments | appointment
new_safedepositbox_Emails | email
new_safedepositbox_Faxes | fax
new_safedepositbox_Letters | letter
new_safedepositbox_PhoneCalls | phonecall
new_safedepositbox_ServiceAppointments | serviceappointment
new_safedepositbox_Tasks | task
new_safedepositbox_RecurringAppointmentMasters | recurringappointmentmaster
new_safedepositbox_DuplicateMatchingRecord | duplicaterecord
new_safedepositbox_DuplicateBaseRecord | duplicaterecord
new_safedepositbox_Annotations | annotation
new_safedepositbox_AsyncOperations | asyncoperation
new_safedepositbox_UserEntityInstanceDatas | userentityinstancedata
new_safedepositbox_ProcessSession | processsession
new_safedepositbox_BulkDeleteFailures | bulkdeletefailure
new_safedepositbox_PrincipalObjectAttributeAccesses | principalobjectattributeaccess

The following table shows the many-to-one relationships where the primary entity is either bank account or safe deposit box.

Relationship schema name | Referenced entity
lk_new_bankaccount_createdby | systemuser
lk_new_bankaccount_createdonbehalfby | systemuser
lk_new_bankaccount_modifiedby | systemuser
lk_new_bankaccount_modifiedonbehalfby | systemuser
user_new_bankaccount | systemuser
team_new_bankaccount | team
owner_new_bankaccount | owner
business_unit_new_bankaccount | businessunit
new_account_new_bankaccount | account
lk_new_safedepositbox_createdby | systemuser
lk_new_safedepositbox_createdonbehalfby | systemuser
lk_new_safedepositbox_modifiedby | systemuser
lk_new_safedepositbox_modifiedonbehalfby | systemuser
user_new_safedepositbox | systemuser
team_new_safedepositbox | team
owner_new_safedepositbox | owner
business_unit_new_safedepositbox | businessunit
new_new_bankaccount_new_safedepositbox | new_bankaccount

The account entity that is shown on the diagram represents a bank customer. As a bank customer, you can open several bank accounts, such as checking and savings accounts, and also several safe deposit boxes. This is an example of a many-to-one relationship type between a bank account and a customer, and a safe deposit box and a customer. You can associate multiple activities, such as tasks, emails, and appointments with a bank account. To provide additional information about a bank account or a safe deposit box, you can use notes and attachments.

About the diagrams

You can find the diagrams for many system entities in the SDK documentation, in the topics that describe the entity capabilities. In each box in the diagram, the first line in bold text is the name of the entity. Subsequent lines contain the names of the attributes used to define the relationships for that entity. The tool does not generate lines showing the relationships to the following entities: organization, business unit, and user (systemuser). This is done to simplify the diagram. Color coding is used to indicate the owner relationship for each entity. The following diagram describes the color coding:

Diagram key for CRM entity relationship diagrams

Generate entity diagrams with the metadata diagram tool

To use the sample code that will programmatically generate Microsoft Office Visio metadata diagrams, build and execute the one of these solutions found in the SDK package: SDK\SampleCode\CS\Metadata\Diagram. The folder contains a Readme file with instructions for its use. The code sample is a stand-alone console application that creates an entity relationship diagram. The program requiresMicrosoft Office Visio.

You can run the program at the command prompt. Simply list the entities you wish to include in the diagram as command-line arguments. Other entities may be included in your diagram as needed to show all the relationships for each entity you have requested. To generate a diagram that shows the relationships for the new_bankaccount and new_safedepositbox entities, use the following command:

Copy Code
MetadataDiagramConsole.exe new_bankaccount new_safedepositbox

The name of the generated Visio file is new_bankaccount.vsd.

Note
The tool uses the name of the first entity on the command line as the name of the Visio file. If you execute the following two commands, the second command overwrites the diagram generated by the first. This is because the Visio files have the same name –”new_bankaccount.vsd”:

MetadataDiagramConsole.exe new_bankaccount

MetadataDiagramConsole.exe new_bankaccount new_safedepositbox

To avoid overwriting a generated diagram file, you have to rename the first file before you run the second command.

See Also

Concepts

Introduction to entities in Microsoft Dynamics CRM
Key to entity diagrams

Other Resources

Extend the metadata model

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Key to entity diagrams

The following is the key to the entity model diagrams shown in the Microsoft Dynamics CRM SDK documentation for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. The relationships to the organization, business unit, and system user (user) entities have been filtered out to simplify the diagrams. The color coding shows if the entity is owned by one of these entities.

Diagram key for CRM entity relationship diagrams

All entity diagrams in the SDK were generated using the metadata diagram sample code that reads the metadata and uses Microsoft Office Visio to draw an entity relationship diagram. You can find this sample in the SDK Download the Microsoft Dynamics CRM SDK package. package in the folder SDK\SampleCode\CS\Metadata\Diagram. The folder contains a readme file with instructions for its use.

See Also

Concepts

Introduction to entities in Microsoft Dynamics CRM

Other Resources

Sample: Assign a record to a team

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Assign a record to a team
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\AssignRecordToTeam.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to assign a record to a team by using the AssignRequest message.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

using Microsoft.Xrm.Sdk.Client;
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{

    /// <summary>
    /// Demonstrates how to assign a record to a team.
    /// If you want to run this sample repeatedly, you have the option to
    /// delete all the records created at the end of execution.
    /// </summary>
    public class AssignRecordToTeam
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service interface.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        // Define the IDs needed for this sample.
        public Guid _accountId;
        public Guid _teamId;
        public Guid _roleId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create a team, an account and a role.
        /// Add read account privileges to the role.
        /// Assign the role to the team so that they can read the account.
        /// Assign the account to the team.
        /// Optionally delete the account, team and role records.
        /// <para name="organizationFriendlyName">The friendly name of
        /// the target organization.</para>
        /// <para name="discoveryServer">The name of the discovery server.</para>
        /// <param name="promptForDelete">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    _service = (IOrganizationService)_serviceProxy;

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Assign the account to a team.
                    AssignRequest assignRequest = new AssignRequest()
                    {
                        Assignee = new EntityReference
                        {
                            LogicalName = Team.EntityLogicalName,
                            Id = _teamId
                        },

                        Target = new EntityReference(Account.EntityLogicalName, _accountId)
                    };

                    _service.Execute(assignRequest);

                    Console.WriteLine("The account is owned by the team.");

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a team, an account and a role.
        /// Add read account privileges to the role.
        /// Assign the role to the team so that they can read the account.
        /// Assign the account to the team.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Instantiate an account entity record and set its property values.
            // See the Entity Metadata topic in the SDK documentation to determine
            // which attributes must be set for each entity.
            Account setupAccount = new Account
            {
                Name = "Example Account"
            };

            // Create the account record.
            _accountId = _service.Create(setupAccount);
            Console.WriteLine("Created {0}", setupAccount.Name);

            // Retrieve the default business unit needed to create the team and role.
            QueryExpression queryDefaultBusinessUnit = new QueryExpression
            {
                EntityName = BusinessUnit.EntityLogicalName,
                ColumnSet = new ColumnSet("businessunitid" ),
                Criteria = new FilterExpression()
            };

            queryDefaultBusinessUnit.Criteria.AddCondition("parentbusinessunitid",
                ConditionOperator.Null);

            BusinessUnit defaultBusinessUnit = (BusinessUnit)_service.RetrieveMultiple(
                queryDefaultBusinessUnit).Entities[0];

            // Instantiate a team entity record and set its property values.
            // See the Entity Metadata topic in the SDK documentation to determine
            // which attributes must be set for each entity.
            Team setupTeam = new Team
            {
                Name = "Example Team",
                BusinessUnitId = new EntityReference(BusinessUnit.EntityLogicalName,
                    defaultBusinessUnit.Id)
            };

            // Create a team record.
            _teamId = _service.Create(setupTeam);
            Console.WriteLine("Created {0}", setupTeam.Name);

            // Instantiate a role entity record and set its property values.
            // See the Entity Metadata topic in the SDK documentation to determine
            // which attributes must be set for each entity.
            Role setupRole = new Role
            {
                Name = "Example Role",
                BusinessUnitId = new EntityReference(BusinessUnit.EntityLogicalName,
                    defaultBusinessUnit.Id)
            };

            // Create a role record. Typically you would use an existing role that has the
            // the correct privileges. For this sample we need to be sure the role has
            // at least the privilege to read account records.
            _roleId = _service.Create(setupRole);
            Console.WriteLine("Created {0}", setupRole.Name);

            // Create a query expression to find the prvReadAccountPrivilege.
            QueryExpression queryReadAccountPrivilege = new QueryExpression
            {
                EntityName = Privilege.EntityLogicalName,
                ColumnSet = new ColumnSet("privilegeid", "name"),
                Criteria = new FilterExpression()
            };
            queryReadAccountPrivilege.Criteria.AddCondition("name",
                ConditionOperator.Equal, "prvReadAccount");

            // Retrieve the prvReadAccount privilege.
            Entity readAccountPrivilege = _service.RetrieveMultiple(
                queryReadAccountPrivilege)[0];
            Console.WriteLine("Retrieved {0}", readAccountPrivilege.Attributes["name"]);

            // Add the prvReadAccount privilege to the example roles to assure the
            // team can read accounts.
            AddPrivilegesRoleRequest addPrivilegesRequest = new AddPrivilegesRoleRequest
            {
                RoleId = _roleId,
                Privileges = new[]
                {
                    // Grant prvReadAccount privilege.
                    new RolePrivilege
                    {
                        PrivilegeId = readAccountPrivilege.Id
                    }
                }
            };
            _service.Execute(addPrivilegesRequest);

            Console.WriteLine("Added privilege to role");

            // Add the role to the team.
            _service.Associate(
                       Team.EntityLogicalName,
                       _teamId,
                       new Relationship("teamroles_association"),
                       new EntityReferenceCollection() { new EntityReference(Role.EntityLogicalName, _roleId) });

            Console.WriteLine("Assigned team to role");

            // It takes some time for the privileges to propagate to the team. Delay the
            // application until the privilege has been assigned.
            bool teamLacksPrivilege = true;
            while (teamLacksPrivilege)
            {
                RetrieveTeamPrivilegesRequest retrieveTeamPrivilegesRequest =
                    new RetrieveTeamPrivilegesRequest
                {
                    TeamId = _teamId
                };

                RetrieveTeamPrivilegesResponse retrieveTeamPrivilegesResponse =
                    (RetrieveTeamPrivilegesResponse)_service.Execute(
                    retrieveTeamPrivilegesRequest);

                foreach (RolePrivilege rp in
                    retrieveTeamPrivilegesResponse.RolePrivileges)
                {
                    if (rp.PrivilegeId == readAccountPrivilege.Id)
                    {
                        teamLacksPrivilege = false;
                        break;
                    }
                    else
                    {
                        System.Threading.Thread.CurrentThread.Join(500);
                    }
                }
            }

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _service.Delete("account", _accountId);
                _service.Delete("team", _teamId);
                _service.Delete("role", _roleId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {

            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                AssignRecordToTeam app = new AssignRecordToTeam();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Reference

Entity Ownership
Assign

Concepts

User and team entities
Introduction to entities in Microsoft Dynamics CRM

Other Resources

Sample: Share records using GrantAccess, ModifyAccess and RevokeAccess messages
AssignRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Share records using GrantAccess, ModifyAccess and RevokeAccess messages
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\UserAccess.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to share a record using the following messages:

  • GrantAccessRequest
  • ModifyAccessRequest
  • RevokeAccessRequest

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    public class UserAccess
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private Guid _currentUserId;
        private List<Guid> _systemUserIds;
        private Guid _teamId;
        private Guid _leadId;
        private Guid _taskId;
        #endregion

        #region How To Sample Code
        public void Run(ServerConnection.Configuration serverConfig,
            bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early bound type support.
                _serviceProxy.EnableProxyTypes();
                CreateRequiredRecords();

                // Retrieve and display the access that the calling user has to the
                // created lead.
                var leadReference = new EntityReference(Lead.EntityLogicalName, _leadId);
                var currentUserReference = new EntityReference(
                    SystemUser.EntityLogicalName, _currentUserId);
                RetrieveAndDisplayPrincipalAccess(leadReference, currentUserReference,
                    "Current User");

                // Retrieve and display the access that the first user has to the
                // created lead.
                var systemUser1Ref = new EntityReference(SystemUser.EntityLogicalName,
                    _systemUserIds[0]);
                RetrieveAndDisplayPrincipalAccess(leadReference, systemUser1Ref,
                    "System User 1");

                // Grant the first user read access to the created lead.
                var grantAccessRequest1 = new GrantAccessRequest
                {
                    PrincipalAccess = new PrincipalAccess
                    {
                        AccessMask = AccessRights.ReadAccess,
                        Principal = systemUser1Ref
                    },
                    Target = leadReference
                };

                Console.WriteLine("Granting {0} to {1} ({2}) on the lead...\r\n",
                    AccessRights.ReadAccess, GetEntityReferenceString(systemUser1Ref), "System User 1");
                _serviceProxy.Execute(grantAccessRequest1);

                // Retrieve and display access information for the lead.
                RetrieveAndDisplayPrincipalAccess(leadReference, systemUser1Ref,
                    "System User 1");
                RetrieveAndDisplayLeadAccess(leadReference);

                // Grant the team read/write access to the lead.
                var teamReference = new EntityReference(Team.EntityLogicalName, _teamId);
                var grantAccessRequest = new GrantAccessRequest
                {
                    PrincipalAccess = new PrincipalAccess
                    {
                        AccessMask = AccessRights.ReadAccess | AccessRights.WriteAccess,
                        Principal = teamReference
                    },
                    Target = leadReference
                };

                Console.WriteLine("Granting {0} to {1} ({2}) on the lead...\r\n",
                    AccessRights.ReadAccess | AccessRights.WriteAccess, GetEntityReferenceString(teamReference), "Team");
                _serviceProxy.Execute(grantAccessRequest);

                var systemUser2Ref = new EntityReference(SystemUser.EntityLogicalName,
                    _systemUserIds[1]);

                // Retrieve and display access information for the lead and system user 2.
                RetrieveAndDisplayPrincipalAccess(leadReference, systemUser2Ref,
                    "System User 2");
                RetrieveAndDisplayLeadAccess(leadReference);

                // Grant the first user delete access to the lead.
                var modifyUser1AccessReq = new ModifyAccessRequest
                {
                    PrincipalAccess = new PrincipalAccess
                    {
                        AccessMask = AccessRights.DeleteAccess,
                        Principal = systemUser1Ref
                    },
                    Target = leadReference
                };

                Console.WriteLine("Granting delete access to {0} on the lead...\r\n",
                    GetEntityReferenceString(systemUser1Ref));
                _serviceProxy.Execute(modifyUser1AccessReq);

                // Retrieve and display access information for the lead.
                RetrieveAndDisplayLeadAccess(leadReference);

                // Revoke access to the lead for the second user.
                var revokeUser2AccessReq = new RevokeAccessRequest
                {
                    Revokee = systemUser2Ref,
                    Target = leadReference
                };

                Console.WriteLine("Revoking access to the lead for {0}...\r\n",
                    GetEntityReferenceString(systemUser2Ref));
                _serviceProxy.Execute(revokeUser2AccessReq);

                // Retrieve and display access information for the lead.
                RetrieveAndDisplayPrincipalAccess(leadReference, systemUser2Ref,
                    "System User 2");

                RetrieveAndDisplayLeadAccess(leadReference);

                DeleteRequiredRecords(promptforDelete);
            }
        }

        private void RetrieveAndDisplayPrincipalAccess(EntityReference leadReference,
            EntityReference principal, String additionalIdentifier)
        {
            var principalAccessReq = new RetrievePrincipalAccessRequest
            {
                Principal = principal,
                Target = leadReference
            };
            var principalAccessRes = (RetrievePrincipalAccessResponse)
                _serviceProxy.Execute(principalAccessReq);
            Console.WriteLine("Access rights of {0} ({1}) on the lead: {2}\r\n",
                GetEntityReferenceString(principal),
                additionalIdentifier,
                principalAccessRes.AccessRights);
        }

        private void RetrieveAndDisplayLeadAccess(EntityReference leadReference)
        {
            var accessRequest = new RetrieveSharedPrincipalsAndAccessRequest
            {
                Target = leadReference
            };

            // The RetrieveSharedPrincipalsAndAccessResponse returns an entity reference
            // that has a LogicalName of "user" when returning access information for a
            // "team."
            var accessResponse = (RetrieveSharedPrincipalsAndAccessResponse)
                _serviceProxy.Execute(accessRequest);
            Console.WriteLine("The following have the specified granted access to the lead.");
            foreach (var principalAccess in accessResponse.PrincipalAccesses)
            {
                Console.WriteLine("\t{0}:\r\n\t\t{1}",
                    GetEntityReferenceString(principalAccess.Principal),
                    principalAccess.AccessMask);
            }
            Console.WriteLine();

        }

        private String GetEntityReferenceString(EntityReference entityReference)
        {
            return String.Format("{0} with GUID {1}", entityReference.LogicalName,
                entityReference.Id);
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a unique identifier for this sample for preventing name conflicts.
            var sampleIdentifier = Guid.NewGuid();

            // Retrieve/create the system users to use for the sample.
            var ldapPath = String.Empty;
            _systemUserIds = SystemUserProvider.RetrieveDelegates(
                _serviceProxy, ref ldapPath);

            // Retrieve the root business unit to use for creating the team for the
            // sample.
            var businessUnitQuery = new QueryExpression
            {
                EntityName = BusinessUnit.EntityLogicalName,
                ColumnSet = new ColumnSet("businessunitid"),
                Criteria = new FilterExpression()
            };

            businessUnitQuery.Criteria.AddCondition("parentbusinessunitid",
                ConditionOperator.Null);
            var businessUnitResult = _serviceProxy.RetrieveMultiple(businessUnitQuery);
            var businessUnit = businessUnitResult.Entities[0].ToEntity<BusinessUnit>();

            // Get the GUID of the current user.
            var who = new WhoAmIRequest();
            var whoResponse = (WhoAmIResponse)_serviceProxy.Execute(who);
            _currentUserId = whoResponse.UserId;

            // Create a team for use in the sample.
            var team = new Team
            {
                AdministratorId = new EntityReference(
                    "systemuser", _currentUserId),
                Name = String.Format("User Access Sample Team {0}", sampleIdentifier),
                BusinessUnitId = businessUnit.ToEntityReference()
            };
            _teamId = _serviceProxy.Create(team);

            // Add the second user to the newly created team.
            var addToTeamRequest = new AddMembersTeamRequest
            {
                TeamId = _teamId,
                MemberIds = new[] { _systemUserIds[1] }
            };
            _serviceProxy.Execute(addToTeamRequest);

            // Create a lead for use in the sample.
            var lead = new Lead
            {
                CompanyName = "User Access Sample Company",
                FirstName = "Sample",
                LastName = "Lead",
                Subject = "User Access Sample Lead",
            };
            _leadId = _serviceProxy.Create(lead);

            // Create a task to associate to the lead.
            var leadReference = new EntityReference(Lead.EntityLogicalName, _leadId);
            var task = new Task
            {
                Subject = "User Access Sample Task",
                RegardingObjectId = leadReference
            };
            _taskId = _serviceProxy.Create(task);

            // Create a letter to associate to the lead.
            var letter = new Letter
            {
                Subject = "User Access Sample Letter",
                RegardingObjectId = leadReference
            };
            _serviceProxy.Create(letter);
        }

        private void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete records created in this sample.
                _serviceProxy.Delete(Team.EntityLogicalName, _teamId);
                // Deleting the lead will delete its associated activities.
                _serviceProxy.Delete(Lead.EntityLogicalName, _leadId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }
        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new UserAccess();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Reference

Introduction to Entities in Microsoft Dynamics CRM

Concepts

User and team entities
Introduction to entities in Microsoft Dynamics CRM

Other Resources

Sample: Create an on-premises user
GrantAccessRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Merge two records
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\Merge.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to merge two records.

Example

C# Copy Code

using System;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to merge two entity records.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.
    /// </remarks>
    public class Merge
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private Guid _account1Id;
        private Guid _account2Id;
        #endregion

        #region How To Sample Code
        /// <summary>
        /// This method shows how to merge two entity records with the Merge message.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete
        /// all created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig,bool promptForDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();

                //Create the Contact and Incident required for this sample.
                CreateRequiredRecords();

                // Create the target for the request.
                EntityReference target = new EntityReference();

                // Id is the GUID of the account that is being merged into.
                // LogicalName is the type of the entity being merged to, as a string
                target.Id = _account1Id;
                target.LogicalName = Account.EntityLogicalName;

                // Create the request.
                MergeRequest merge = new MergeRequest();
                // SubordinateId is the GUID of the account merging.
                merge.SubordinateId = _account2Id;
                merge.Target = target;
                merge.PerformParentingChecks = false;

                Console.WriteLine("\nMerging account2 into account1 and adding " +
                    "\"test\" as Address 1 Line 1");

                // Create another account to hold new data to merge into the entity.
                // If you use the subordinate account object, its data will be merged.
                Account updateContent = new Account();
                updateContent.Address1_Line1 = "test";

                // Set the content you want updated on the merged account
                merge.UpdateContent = updateContent;

                // Execute the request.
                MergeResponse merged = (MergeResponse)_serviceProxy.Execute(merge);

                Account mergeeAccount =
                    (Account)_serviceProxy.Retrieve(Account.EntityLogicalName,
                    _account2Id, new ColumnSet(allColumns:true));

                if(mergeeAccount.Merged == true)
                {
                    Account mergedAccount =
                        (Account)_serviceProxy.Retrieve(Account.EntityLogicalName,
                        _account1Id, new ColumnSet(allColumns: true));

                    Console.WriteLine("\nAccounts merged successfully into account1");
                    Console.WriteLine("  Name: {0}", mergedAccount.Name);
                    Console.WriteLine("  Description: {0}", mergedAccount.Description);
                    Console.WriteLine("  Number of Employees: {0}",
                        mergedAccount.NumberOfEmployees);
                    Console.WriteLine("  Address 1 Line 1: {0}",
                        mergedAccount.Address1_Line1);
                }

                DeleteRequiredRecords(promptForDelete);
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create the first account, which will be merged into
            Account account1 = new Account();
            account1.Name = "Fourth Coffee";
            account1.Description = "Coffee House";

            _account1Id = _serviceProxy.Create(account1);
            Console.WriteLine("Account 1 created with GUID {{{0}}}", _account1Id);
            Console.WriteLine("  Name: {0}", account1.Name);
            Console.WriteLine("  Description: {0}", account1.Description);

            // Create the second account, which will be merged from
            Account account2 = new Account();

            account2.Name = "Fourth Coffee";
            account2.NumberOfEmployees = 55;

            _account2Id = _serviceProxy.Create(account2);
            Console.WriteLine("Account 2 created with GUID {{{0}}}", _account2Id);
            Console.WriteLine("  Name: {0}", account2.Name);
            Console.WriteLine("  Number of Employees: {0}", account2.NumberOfEmployees);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                Console.WriteLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") ||
                    answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Account.EntityLogicalName, _account1Id);
                _serviceProxy.Delete(Account.EntityLogicalName, _account2Id);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config =
                    serverConnect.GetServerConfiguration();

                var app = new Merge();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException,
            // ExpiredSecurityTokenException, SecurityAccessDeniedException,
            // MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Introduction to entities in Microsoft Dynamics CRM

Other Resources

Sample: Validate record state and set the state of the record
MergeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Validate record state and set the state of the record
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\ValidateAndSetState.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to validate a change of state of an entity and set a state of an entity.

Example

C# Copy Code

using System;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    ///  This sample shows how to validate an intended state change on an entity record.
    ///  This sample will also show how to set the state on the entity record.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.
    /// </remarks>
    public class ValidateAndSetState
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private Guid _caseCustomerId;
        private Guid _caseIncidentId;
        #endregion

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards, a
        /// case is created. The IsValidStateTransition is used to test if a state change
        /// is valid. The case is closed, re-opened and then closed with SetState.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig,
            bool promptForDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();

                //Create the Contact and Incident required for this sample.
                CreateRequiredRecords();

                // Create an EntityReference to represent an open case
                EntityReference caseReference = new EntityReference()
                {
                    LogicalName = Incident.EntityLogicalName,
                    Id = _caseIncidentId
                };

                IsValidStateTransitionRequest checkState =
                    new IsValidStateTransitionRequest();

                // Set the transition request to an open case
                checkState.Entity = caseReference;

                // Check to see if a new state of "resolved" and
                // a new status of "problem solved" are valid
                checkState.NewState = IncidentState.Resolved.ToString();
                checkState.NewStatus = (int)incident_statuscode.ProblemSolved;

                // Execute the request
                IsValidStateTransitionResponse checkStateResponse =
                    (IsValidStateTransitionResponse)_serviceProxy.Execute(checkState);

                // Handle the response
                if (checkStateResponse.IsValid)
                {
                    String changeAnswer = "y"; // default to "y" unless prompting for delete
                    if (promptForDelete)
                    {
                        // The case can be closed
                        Console.WriteLine("Validate State Request returned that the case " +
                                          "can be closed.");
                        Console.Write("\nDo you want to change the record state? " +
                                          "(y/n) [y]: ");
                        changeAnswer = Console.ReadLine();
                        Console.WriteLine();
                    }

                    if (changeAnswer.StartsWith("y") || changeAnswer.StartsWith("Y")
                        || changeAnswer == String.Empty)
                    {
                        // Call function to change the incident to the closed state
                        CloseIncident(caseReference);
                        // Re-open the incident and change its state
                        SetState(caseReference);
                    }
                }
                else
                {
                    // The case cannot be closed
                    Console.WriteLine("Validate State Request returned that the " +
                                      "change is not valid.");
                }

                DeleteRequiredRecords(promptForDelete);
            }
        }

        private void CloseIncident(EntityReference caseReference)
        {
            // First close the Incident

            // Create resolution for the closing incident
            IncidentResolution resolution = new IncidentResolution
            {
                Subject = "Case Closed",
            };

            resolution.IncidentId = caseReference;

            // Create the request to close the incident, and set its resolution to the
            // resolution created above
            CloseIncidentRequest closeRequest = new CloseIncidentRequest();
            closeRequest.IncidentResolution = resolution;

            // Set the requested new status for the closed Incident
            closeRequest.Status =
                new OptionSetValue((int)incident_statuscode.ProblemSolved);

            // Execute the close request
            CloseIncidentResponse closeResponse =
                (CloseIncidentResponse)_serviceProxy.Execute(closeRequest);

            //Check if the incident was successfully closed
            Incident incident = _serviceProxy.Retrieve(Incident.EntityLogicalName,
                _caseIncidentId, new ColumnSet(allColumns: true)).ToEntity<Incident>();

            if (incident.StateCode.HasValue &&
                incident.StateCode == IncidentState.Resolved)
            {
                Console.WriteLine("The incident was closed out as Resolved.");
            }
            else
            {
                Console.WriteLine("The incident's state was not changed.");
            }
        }

        private void SetState(EntityReference caseReference)
        {
            // Create the Request Object
            SetStateRequest state = new SetStateRequest();

            // Set the Request Object's Properties
            state.State = new OptionSetValue((int)IncidentState.Active);
            state.Status =
                new OptionSetValue((int)incident_statuscode.WaitingforDetails);

            // Point the Request to the case whose state is being changed
            state.EntityMoniker = caseReference;

            // Execute the Request
            SetStateResponse stateSet = (SetStateResponse)_serviceProxy.Execute(state);

            // Check if the state was successfully set
            Incident incident = _serviceProxy.Retrieve(Incident.EntityLogicalName,
                _caseIncidentId, new ColumnSet(allColumns: true)).ToEntity<Incident>();

            if (incident.StatusCode.Value == (int)incident_statuscode.WaitingforDetails)
            {
                Console.WriteLine("Record state set successfully.");
            }
            else
            {
                Console.WriteLine("The request to set the record state failed.");
            }

        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a customer for a new incident
            Contact caseCustomer = new Contact();

            // Set the contact properties
            caseCustomer.FirstName = "Christen";
            caseCustomer.LastName = "Anderson";

            // Create the contact in CRM
            _caseCustomerId = _serviceProxy.Create(caseCustomer);
            NotifyEntityCreated(Contact.EntityLogicalName, _caseCustomerId);

            // Retrieve the default subject for a new incident\case
            var query = new QueryExpression()
            {
                EntityName = Subject.EntityLogicalName,
                ColumnSet = new ColumnSet(allColumns: true),
                Criteria = new FilterExpression()
            };
            query.Criteria.AddCondition("title", ConditionOperator.Equal,
                "Default Subject");

            var subjectRecords = _serviceProxy.RetrieveMultiple(query);
            Entity defaultSubject = subjectRecords[0];
            NotifyEntityRetrieved(Subject.EntityLogicalName, defaultSubject.Id);

            // Create a new incident
            Incident newCase = new Incident();

            // Set the incident properties
            newCase.SubjectId = new EntityReference();
            newCase.SubjectId.LogicalName = Subject.EntityLogicalName;
            newCase.SubjectId.Id = defaultSubject.Id;
            newCase.CustomerId = new EntityReference();
            newCase.CustomerId.LogicalName = Contact.EntityLogicalName;
            newCase.CustomerId.Id = _caseCustomerId;
            newCase.Title = "New Case from SDK";

            _caseIncidentId = _serviceProxy.Create(newCase);
            NotifyEntityCreated(Incident.EntityLogicalName, _caseIncidentId);

        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                Console.WriteLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y")
                    || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Incident.EntityLogicalName, _caseIncidentId);
                _serviceProxy.Delete(Contact.EntityLogicalName, _caseCustomerId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        private void NotifyEntityCreated(String entityName, Guid entityId)
        {
            Console.WriteLine("  {0} created with GUID {{{1}}}",
                entityName, entityId);
        }

        private void NotifyEntityRetrieved(String entityName, Guid entityId)
        {
            Console.WriteLine("  Retrieved {0} with GUID {{{1}}}",
                entityName, entityId);
        }
        #endregion

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config =
                    serverConnect.GetServerConfiguration();

                var app = new ValidateAndSetState();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException,
            // ExpiredSecurityTokenException, SecurityAccessDeniedException,
            // MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Introduction to entities in Microsoft Dynamics CRM

Other Resources

Sample: Rollup records related to a specific record
IsValidStateTransitionRequest
SetStateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Rollup records related to a specific record
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\RollupByObject.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to roll up opportunities by the parent account.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to roll up opportunities by their parent account.</summary>
    /// </summary>
    public class RollupByObject
    {
        #region Class Level Members

        private Guid _accountId;
        private Guid _opportunityId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This sample demonstrates how to roll up opportunities by their parent account.
        /// The sample first creates the Rollup Request. Next, it executes that request.
        /// Finally, the sample displays the results of the Rollup Response.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Create QueryExpression
                    // Create QueryExpression
                    QueryExpression query = new QueryExpression()
                    {
                        EntityName = Opportunity.EntityLogicalName,
                        ColumnSet = new ColumnSet("name", "accountid"),
                        Criteria =
                        {
                            Filters =
                            {
                                new FilterExpression
                                {
                                    FilterOperator = LogicalOperator.And,
                                    Conditions =
                                    {
                                        new ConditionExpression("name", ConditionOperator.Equal, "Opportunity 1")
                                    },
                                }
                            }
                        },
                    };
                    Console.WriteLine("Created QueryExpression.");
                    #endregion Create QueryExpression

                    #region Create RollupRequest
                    // Create RollupRequest
                    RollupRequest rollupRequest = new RollupRequest();
                    rollupRequest.Query = query;
                    rollupRequest.Target = new EntityReference("account", _accountId);
                    rollupRequest.RollupType = RollupType.Extended;
                    Console.WriteLine("Created RollupRequest.");
                    #endregion Create RollupRequest

                    #region Execute RollupRequest
                    // Execute RollupRequest
                    RollupResponse rollupResponse = (RollupResponse)_serviceProxy.Execute(rollupRequest);
                    Console.WriteLine("Executed RollupRequest.");
                    #endregion Execute RollupRequest

                    #region Show RollupResponse results
                    // Show RollupResponse results
                    Console.WriteLine("RollupResponse Results:");
                    Console.WriteLine("--------------------------------------------------");
                    Console.WriteLine("Count: " + rollupResponse.Results.Count);
                    for (int i = 0; i < rollupResponse.Results.Count; i++ )
                    {
                        Console.WriteLine();
                        Console.WriteLine("LogicalName: " + rollupResponse.EntityCollection.Entities[i].LogicalName);
                        Console.WriteLine("Id: " + rollupResponse.EntityCollection.Entities[i].Id);
                    }
                    #endregion Show RollupResponse results

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        public void CreateRequiredRecords()
        {
            // Create an account
            Account account = new Account
            {
                Name = "Fourth Coffee"
            };
            _accountId = _serviceProxy.Create(account);

            // Create an opportunity
            Opportunity newOpportunity = new Opportunity
            {
                Name = "Opportunity 1",
                CustomerId = new EntityReference
                {
                    Id = _accountId,
                    LogicalName = account.LogicalName
                }
            };
            _opportunityId = _serviceProxy.Create(newOpportunity);
        }

        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }

        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                RollupByObject app = new RollupByObject();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        #endregion Main method
    }
}

See Also

Concepts

Introduction to entities in Microsoft Dynamics CRM

Other Resources

Sample: Set and retrieve entity images
RollupRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Introduction to entity attributes in Microsoft Dynamics CRM

Entities include a set of attributes that represent the data that can be included within each record. Developers need to understand the different types of attributes and how to work with them. The metadata for attributes describes the valid operations and behaviors of different types of attributes. Several types of attributes can be grouped by common behaviors.

The specific experience developers will have depends on the style of development they choose. More information: Entity programming (early bound vs. late bound vs. developer extensions).

Note
This topic includes references to many metadata properties. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

In this topic

Valid operations on attributes

Types of attributes

Categorization data attributes

Collection data attributes

Date and time data attribute

Image data attributes

Quantity data attributes

Reference data attributes

String data attributes

Unique identifier data attributes

Virtual attributes

Logical attributes

Valid operations on attributes

Each attribute has metadata that describes the operations it supports. You need to be aware of the operations that are valid for the attributes you work with.

AttributeMetadata property | Description
IsValidForCreate | True if this attribute value is valid to be set when a record is created, otherwise false.
IsValidForRead | True if this attribute value can be retrieved, otherwise false.
IsValidForUpdate | True if this attribute value is valid to be set when a record is updated, otherwise false.

Types of attributes

Attributes are defined in metadata and the AttributeMetadata.AttributeTypeName property contains the value describing the type. The static AttributeTypeDisplayName members provide the list of possible types.

Note
The older AttributeType property contains data that is mostly aligned with AttributeTypeName, except that it shows ImageType attributes as Virtual. You should use the AttributeTypeName property rather than the AttributeType property.

The following section groups the types of attributes into the following categories so that you can more easily compare them:

  • Categorization data attributes
  • Collection data attributes
  • Date and time data attribute
  • Image data attributes
  • Quantity data attributes
  • Reference data attributes
  • String data attributes
  • Unique Identifier data attributes
  • Virtual attributes

Categorization data attributes

Each of the five attributes in this group inherit from a common EnumAttributeMetadata base class and use a pre-defined set of valid values to group records into categories.

Set Picklist, Status, and State attributes using an OptionSetValue with a Value property set to an integer that represents a valid option within the metadata.

Set Boolean attributes using a Boolean value, but recognize that this is a categorization limited to just two options.

EntityName attributes use a string value that is constrained to be a valid entity logical name in the organization.

Custom Picklist and Boolean attributes can be defined as calculated attributes. More information: Calculated attributes.

Metadata Type AttributeTypeName Value Description

PicklistAttributeMetadata

PicklistType

Valid values are set in the OptionMetadata.Value for that attribute defined within the OptionSetMetadata.Options.

Within the customization tools in the application these attributes are called Option Set fields.

StatusAttributeMetadata

StatusType

These system attributes are generally named StatusCode. Valid values are set in the StatusOptionMetadata.Value for that attribute defined within the OptionSetMetadata.Options.

The StatusOptionMetadata.State property for each option describes the valid value for the corresponding StateCode value. Before you set the StatusCode you should verify that it is valid for the current StateCode value. Use the SetStateRequest message to set the StatusCode and StateCode attribute values when you need to change the state of the record.

These attributes may have further restrictions on which values can be set. The StatusOptionMetadata.TransitionData property may contain information on which options are allowed when the EntityMetadata.EnforceTransitions value is true. More information: Define custom state model transitions.

StateAttributeMetadata

StateType

These system attributes are generally named StatusCode. Valid values are set in the StateOptionMetadata.Value for that attribute defined within the OptionSetMetadata.Options.

StateCode is not valid for update. After the record is created, the StateCode can only be set using the SetStateRequest message.

The StateOptionMetadata.DefaultStatus property for each option describes the default StatusCode that will be used if not set as a parameter in the SetStateRequest.

BooleanAttributeMetadata

BooleanType

Boolean attributes can be set directly using a Boolean value, but like the others they also have an OptionSet property with FalseOption and TrueOption properties that correspond to the Boolean options. Each of these properties define a set of localized labels that represent what true and false mean for the attribute. Within the customization tools in the application these attributes are called Two Options fields because the meaning for each option can be any mutually exclusive pair of options, not just true and false. For example, the options might be big and small.

EntityNameAttributeMetadata

EntityNameType

These system attributes are generally paired with a unique identifier or reference attribute that is valid for multiple types. The value of this attribute is a string value representing the logical name of an entity. If the corresponding reference attribute is an EntityReference, the value of this attribute is the same as the EntityReference.Name property value.

Collection data attributes

These system attributes return collections of values.

AttributeTypeName Value Description

CalendarRulesType

There are no actual attributes that use the CalendarRulesType. When using the early binding style, the code generation tool will create the following two simulated attributes that are not present in the metadata. These attributes actually represent a view of the calendar rules records associated in a one-to-many relationship to the entity instance.

  • Calendar.CalendarRules relationship: calendar_calendar_rules
  • Service.CalendarRules relationship: service_calendar_rules

PartyListType

The following attributes allow for multiple EntityReference to be set for various types of activities.

ActivityPointer.allparties
Appointment.OptionalAttendees
Appointment.Organizer
Appointment.requiredattendees
CampaignActivity.from
CampaignActivity.Partners
CampaignResponse.Customer
CampaignResponse.from
CampaignResponse.Partner
Email.bcc
Email.cc
Email.from
Email.to
Fax.from
Fax.to
Letter.bcc
Letter.cc
Letter.from
Letter.to
PhoneCall.from
PhoneCall.to
RecurringAppointmentMaster.OptionalAttendees
RecurringAppointmentMaster.Organizer
RecurringAppointmentMaster.RequiredAttendees
ServiceAppointment.Customers
ServiceAppointment.Resources
SocialActivity.From
SocialActivity.Resources
SocialActivity.To

Date and time data attribute

Attributes with the metadata AttributeTypeName value of DateTimeType. Set these attributes using System.DateTime.

The DateTimeAttributeMetadata.Format property can be one of the following DateTimeFormat values:

  • DateAndTime: Display the date and time.
  • DateOnly: Display the date only

Custom Date and time attributes can be defined as calculated or rollup attributes. More information: Calculated and rollup attributes.

Image data attributes

For those entities which support image attributes, the SchemaName of the entity image attribute is always EntityImage.

More information: Image attributes, Entity images and Sample: Set and retrieve entity images.

Quantity data attributes

Attributes in this category use numerical data. Each of these attributes has a MaxValue and MinValue metadata property to set a range of valid values.

Custom Decimal, Integer, and Money attributes can be defined as calculated or rollup attributes. More information: Calculated and rollup attributes.

Metadata Type AttributeTypeName Value Description

BigIntAttributeMetadata

BigIntType

BigInt attributes are for internal use only.

DecimalAttributeMetadata

DecimalType

Use decimal values.

The Precision metadata property sets the precision to be used for the attribute.

DoubleAttributeMetadata

DoubleType

Use double values.

The Precision metadata property sets the precision to be used for the attribute.

IntegerAttributeMetadata

IntegerType

Use int values.

MoneyAttributeMetadata

MoneyType

Use Money which has a decimalValue property.

Each Money attribute has a corresponding system calculated base currency money attribute that is used to calculate the value in the organization’s base currency when multiple currencies have been enabled for the organization. The IsBaseCurrency property identifies whether a money attribute represents the base currency. More information: Transaction Currency (currency) entity.

Money attributes also have a PrecisionSource metadata property that can specify the level of precision that should be used. The integer value in this property determines whether:

  • 0: The precision is determined by the Precision metadata property.
  • 1: The Organization.PricingDecimalPrecision value.
  • 2: The TransactionCurrency.CurrencyPrecision that is associated with the current record.

Reference data attributes

These attributes are commonly referred to as lookup attributes and each of them contain an EntityReference value. The difference between these attributes is the kinds of entities they can associate to. The Targets metadata property contains a String[] of the valid entity logical names that represent valid targets for the lookup. Custom lookup attributes can only have a single type in the Targets property.

The PartyListType also represent a kind of reference data attribute, but since they contain a collection of references, they are included in the Collection data attributes.

Metadata Type AttributeTypeName Value Description

LookupAttributeMetadata

CustomerType

These system lookup attributes can link to Account or Contact entity records.

Contact.ParentCustomerId
Contract.BillingCustomerId
Contract.CustomerId
ContractDetail.CustomerId
CustomerOpportunityRole.CustomerId
CustomerRelationship.CustomerId
CustomerRelationship.PartnerId
Entitlement.CustomerId
Incident.CustomerId
Invoice.CustomerId
Lead.CustomerId
Opportunity.CustomerId
Quote.CustomerId
SalesOrder.CustomerId
SocialActivity.PostAuthor
SocialActivity.PostAuthorAccount
SocialProfile.CustomerId

LookupType

These lookup attributes can be used to set references to a record of the type indicated by the Targets metadata property.

Some system lookups do not have a value set for the Targets property, but the intended entity should be apparent based on the entity relationship that is associated to the lookup.

OwnerType

These system lookups are always named OwnerId and each user-owned entity will have one. They can reference either SystemUser or Team records.

String data attributes

There are two types of attributes that use string data.

Metadata Type AttributeTypeName Value Description

StringAttributeMetadata

StringType

An attribute for a string value to which a format can be applied. More information:StringAttributeMetadata formats.

Custom String attributes can be defined as calculated attributes. More information: Calculated attributes.

MemoAttributeMetadata

MemoType

An attribute for a string value intended for notes. This attributes is equivalent to String attributes with the FormatName property value set to TextArea.

Unique identifier data attributes

Attributes with the metadata AttributeTypeName value of UniqueidentifierType contain nullable System.Guid values.

Each entity instance includes one attribute that represents the unique identifier for the record. This attribute has a schema name that follows the naming convention <entity schema name>+Id. For example, the Account entity the schema name for the attribute representing the unique identifier is named AccountId. This value is also available directly using the Entity.Id property. This attribute is always returned when you retrieve an entity, even if you do not include it in the ColumnSet of a query. This value is null for a newly instantiated entity. While it is valid to set a Guid value to define the unique identifier when you create a new record, for best performance we recommend that you leave it null and allow the system to assign a value when the record is created. After a record is saved this value becomes read-only.

Entities may include other unique identifier attributes depending on the capabilities of the entity. For example, entities that are enabled for business processes will contain unique identifier attributes for ProcessId and StageId to track the current business process associated with the record. Certain system relationships that might normally use an EntityReference value will use a unique identifier instead. For example the Account and Contact entities each have two unique identifier attributes (Address1_AddressId and Address2_AddressId) that correspond to CustomerAddress records created when an Account or Contact is created.

Virtual attributes

The metadata for an entity will include some attributes with the metadata AttributeTypeName value of VirtualType. These attributes cannot be used in code.

Logical attributes

Logical attributes contain values which are stored in different database tables than other attributes in the entity. In most cases this internal implementation is not relevant to working with Microsoft Dynamics CRM. When you use logical attributes as sources for a calculated field the values in the calculated field cannot be sorted. Use the AttributeMetadata.IsLogical property to detect if an attribute is a logical attribute.

The most common logical attributes are those which store address information in several special entities: CompetitorAddress, CustomerAddress, InternalAddress, LeadAddress, and PublisherAddress. There are 8 system entities that include a complete set of attributes for two addresses using logical attributes. Each of these attributes begin with “Address*”, such as Address1_City or Address2_Latitude.

See Also

Concepts

Introduction to entities in Microsoft Dynamics CRM
Image attributes
Calculated and rollup attributes

Other Resources

Sample: Retrieve valid status transitions
Sample: Set and retrieve entity images

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Image attributes

Entity records that include image data provide a unique experience within the application. As a developer you need to understand how you work with image data.

Only certain system entities and custom entities support images. For information about which system entities support images, see Entity images.

In this topic

Supporting attributes

Retrieving image data

Uploading image data

Supporting attributes

For those entities which support image attributes, the SchemaName of the entity image attribute is always EntityImage. When an image attribute is added to an entity some additional attributes are created to support it as shown in the following table.

Schema Name Attribute Type Name Description

EntityImage_Timestamp

BigIntType

The value represents when the image was last updated and is used to help make sure that the latest version of the image is downloaded and cached on the client.

EntityImage_URL

StringType

An absolute URL to display the entity image in a client.

The URL is composed this way:

Copy Code
{0}/image/download.aspx?entity={1}&attribute={2}&id={3}&timestamp={4}
  • 0 : The organization URL
  • 1 : The entity logical name
  • 2 : The attribute logical name
  • 3 : The EntityImageId value.
  • 4 : The EntityImage_Timestamp value

For example:
https://myorg.crm.dynamics.com/image/download.aspx?attribute=entityimage&entity=contact&id={ECB6D3DF-4A04-E311-AFE0-00155D9C3020}&timestamp=635120312218444444

EntityImageId

UniqueIdentifierType

The unique identifier of the image

Note
Clients that do not use the current .NET assemblies need to include SdkClientVersion with a value of ‘6.0.0.0’ or higher in order to receive ImageAttributeMetadata attributes. More information: SdkClientVersion.

Retrieving image data

When you use RetrieveMultiple or Retrieve the EntityImage is not included when the ColumnSet.AllColumns property is set to true. Because of the potential size of data in this attribute, to return this attribute you must explicitly request it.

The binary data representing the image isn’t returned using the deprecated ExecuteFetchRequest class. You should use RetrieveMultipleRequest instead.

More information: Sample: Set and retrieve entity images.

Uploading image data

To update images set the value of the EntityImage to a byte[] that contains the content of the file. All images are displayed in a 144x144 pixel square. Images will be cropped and resized to reduce the size of the data before being saved.

  • Images with at least one side larger than 144 pixels are cropped on center to 144x144.
  • Images with both sides smaller than 144 are cropped square to their smallest side.

The following table shows two examples.

Before | After
Image before resize 300x428 | image after resize 144x144
Second image resize example 91x130 | second resize example 91x91

More information: Sample: Set and retrieve entity images.

See Also

Concepts

Introduction to entities in Microsoft Dynamics CRM
Introduction to entity attributes in Microsoft Dynamics CRM

Other Resources

Sample: Set and retrieve entity images

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Calculated and rollup attributes

Calculated and rollup attributes free the user from having to manually perform calculations and focus on their work. System administrators can now easily define a field to contain the value of many common calculations without having to work with a developer. Developers can also leverage the platform capabilities to perform these calculations rather than within their own code.

Video: Rollup and Calculated Fields in Microsoft Dynamics CRM 2015

In this topic

Common elements and characteristics

Calculated attributes

Rollup attributes

SourceTypeMasks enumeration

Common elements and characteristics

Calculated and rollup attributes share some common elements and characteristics, for example:

  • They’re read-only.
  • They’re not specific to the user. The calculation is performed using a system user account, so the values may be based on records that the user doesn’t otherwise have privileges to view, such as attributes that have field-level security enabled.

All attributes that inherit from AttributeMetadata have a SourceType property that can contain the values shown in the following table.

Value | Description
null | Not a valid type of attribute to be a calculated or rollup attribute.
0 | Simple attribute. The attribute isn’t defined as a calculated or rollup attribute.
1 | Calculated attribute
2 | Rollup attribute

Calculated and rollup attributes are based on existing attribute types that inherit from AttributeMetadata. The following types of attributes have new properties:

  • BooleanAttributeMetadata
  • DateTimeAttributeMetadata
  • DecimalAttributeMetadata
  • IntegerAttributeMetadata
  • MoneyAttributeMetadata
  • PicklistAttributeMetadata
  • StringAttributeMetadata

Each of these types of attributes have the following properties to support calculations and rollups.

Property Definition

FormulaDefinition

Contains the XAML definition of the formula used to perform the calculation or rollup. The only supported way to change this value is through the application formula editor.

For information about configuring the formulas for these attributes see the following topics in the Customization Guide: Define rollup fields and Define calculated fields.

SourceTypeMask

The bitmask value of this read-only property describes the types of sources used in the formula of the calculated attribute or if the formula of a calculated or rollup attribute is not valid.

  • 0: Undefined. The default value for simple and rollup attributes.
  • 1: Simple. The calculated attribute refers to an attribute in the same record.
  • 2: Related. The calculated attribute refers to an attribute in a related record.
  • 4: Logical. The calculated attribute refers to an attribute in the same record which is actually stored in a different database table. More information: Logical attributes
  • 8: Calculated. The calculated attribute refers to another calculated attribute.
  • 16: Rollup. The calculated attribute refers a rollup attribute.
  • 32: Invalid. The calculated or rollup field is invalid.
    Typically this would be where a field refers to an attribute that no longer exists.
Note
One or more of these conditions may be true for any calculated or rollup field. Because this is a bitmask value, you may find it useful to use the SourceTypeMasks enumeration when performing bitwise operations.

Calculated attributes

Calculated attributes are calculated in real-time when they are retrieved. Calculated attributes can be composed using different data types. For example, an Integer calculated attribute may reference values from Decimal or Currency attributes. More information: Customization Guide topic: Define calculated fields.

Calculated attribute values are available in the retrieve plug-in pipeline. Post image of entity record update or create contains the calculated attribute value in stage 40. More information: Event execution pipeline

Limitations

You can’t use values in calculated attributes that reference a related entity, another calculated attribute, or a logical value in the same entity to sort data returned by a query. Although your query can specify that the results should be ordered using a calculated attribute, the sort direction will be ignored and will not throw an error. If the calculated attribute references only simple values in the same record, sorting works normally. You can determine the sources used in a calculated field using the SourceTypeMask property on the attribute metadata. More information:Logical attributes

Only attributes from an immediate parent entity can be used in a calculated attribute.

Saved queries, charts, and visualizations can have a maximum of 10 unique calculated attributes.

Calculated attributes can reference other calculated attributes in their formula, but they can’t reference themselves.

Calculated attributes don’t have values when a user with Microsoft Dynamics CRM for Microsoft Office Outlook is offline.

MaxValue and MinValue metadata properties can’t be set on calculated attributes

Rollup attributes

Because rollup attributes persist in the database, they can be used for filtering or sorting just like regular attributes. Any kind of process or plug-in will use the most recently calculated value of the attribute. Rollup attribute values are calculated asynchronously by scheduled system jobs. Administrators set when a job is run or pause the job. By default, each attribute is updated hourly. More information: Customization Guide topic : Define rollup fields.

When a rollup attribute is created or updated a Mass Calculated Rollup Fields job is scheduled to run in 12 hours. The 12-hour delay is intended to perform this resource intensive operation during a time that will affect users the least. After the job completes, the next time it is scheduled to run will be 10 years in the future. If there is a problem with the calculation, this will be reported with the system job. Locate the system job in Settings > System Jobs to find any errors with rollup fields.

Tip
As a developer testing a solution in a development environment you may not want to wait for 12 hours. You can make it happen faster. In the System Jobs list, use the Recurring System Jobs view to filter the list and locate the Mass Calculate Rollup Fields job. With the job selected, use More Actions > Postpone and set the time to something that occurs sooner.

If you want to trigger the creation of a new Mass Calculated Rollup Fields job programmatically, retrieve the AttributeMetadata for the rollup attribute using RetrieveAttributeRequest and use UpdateAttributeRequest to update the attribute without making any actual changes.

The Mass Calculated Rollup Fields job will occur immediately when a solution containing a rollup attribute is imported. This assumes that you are installing a solution during a time that won’t adversely impact users.

Each rollup attribute for an entity will also include two supporting attributes for the rollup attribute:

  • <attribute SchemaName>_Date: DateTime – When the rollup was last calculated.
  • <attribute SchemaName>_State: Integer – The state of the rollup calculation. More information:Rollup state values

Rollup state values

The state of a rollup field calculation is available in the corresponding <attribute SchemaName>_State attribute and in the CalculateRollupFieldResponse.FieldState property. Values that indicate the state are shown in the following table.

State Value | Description
0 | NotCalculated: Attribute value is yet to be calculated.
1 | Calculated: Attribute value has been calculated per the last update time in <attribute SchemaName>_Date attribute.
2 | OverflowError: Attribute value calculation lead to overflow error.
3 | OtherError: Attribute value calculation failed due to an internal error, next run of calculation job will likely fix it.
4 | RetryLimitExceeded: Attribute value calculation failed because the maximum number of retry attempts to calculate the value were exceeded likely due to high number of concurrency and locking conflicts.
5 | HierarchicalRecursionLimitReached: Attribute value calculation failed because maximum hierarchy depth limit for calculation was reached.
6 | LoopDetected: Attribute value calculation failed because a recursive loop was detected in the hierarchy of the record.

Retrieve a calculated rollup field value immediately

Rollup attributes support a CalculateRollupField message that developers can use to calculate a rollup attribute value on demand. The request and response, along with the members, are shown in the following table.

Request/Response | Members
CalculateRollupFieldRequest | Target: EntityReference for the record. FieldName: String representing the logical name of the attribute.
CalculateRollupFieldResponse | Entity: Entity containing the rollup attribute and the supporting <attribute SchemaName>_Date and <attribute SchemaName>_State attributes.

This message is a synchronous operation for just the attribute identified in the request. If the value of that record is included as part of other rollup fields, the values of those fields won’t take the possible value change caused by calling this method into consideration until the regularly scheduled asynchronous jobs that perform those calculations occur.

Limitations

Rollup attributes can’t be used as a workflow event or wait condition. These attributes don’t raise the event to trigger workflows.

The ModifiedBy and ModifiedOn attributes for the entity aren’t updated when the rollup attribute is updated.

A maximum of 100 rollup attributes can be defined within an organization. Each entity can have no more than 10 rollup attributes.

A rollup attribute formula can’t reference another rollup attribute.

A rollup attribute formula can’t reference complex calculated attributes. Only calculated attributes that reference simple attributes in the same record can be used with rollups.

A rollup attribute formula can’t include records in many-to-many (N:N) relationships. It can only include records in one-to-many (1:N) relationships.

Rollup attribute formulas can’t use one-to-many (1:N) relationships with the ActivityPointer or ActivityParty entity.

SourceTypeMasks enumeration

The SourceTypeMask property for those attributes that support calculated and rollup fields contains a bitmask value. To extract the relevant information from the value, it helps to have an enumeration when performing bitwise operations. Use the following SourceTypeMasks enumeration when comparing the SourceTypeMask property value.

C# Copy Code
 public enum SourceTypeMasks
{
    /// <summary>
    /// Undefined: 0 - The default value for simple and rollup attributes.
    /// </summary>
    Undefined = 0,
    /// <summary>
    /// Simple: 1 - The calculated attribute refers to an attribute in the same record.
    /// </summary>
    Simple = 1,
    /// <summary>
    /// Related: 2 - The calculated attribute refers to an attribute in a related record.
    /// </summary>
    Related = 2,
    /// <summary>
    /// Logical: 4 - The calculated attribute refers to a logical attribute.
    /// </summary>
    Logical = 4,
    /// <summary>
    /// Calculated: 8 - The calculated attribute refers to another calculated attribute.
    /// </summary>
    Calculated = 8,
    /// <summary>
    /// Rollup: 16 - The calculated attribute refers a rollup attribute.
    /// </summary>
    Rollup = 16,
    /// <summary>
    /// Invalid: 32 - The calculated or rollup attribute is invalid.
    /// Typically this would be where a field refers to an attribute that no longer exists.
    /// </summary>
    Invalid = 32
}

See Also

Concepts

Introduction to entity attributes in Microsoft Dynamics CRM

Other Resources

Video: Rollup and Calculated Fields in Microsoft Dynamics CRM 2015
Customization Guide: Define calculated fields
Customization Guide: Define rollup fields

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Define custom state model transitions

You can specify custom state transitions for the Incident (Case) entity or custom entities. The EntityMetadata.IsStateModelAware property is true for entities that support state model transitions.

Custom state transitions are an optional level of filtering to define which state transitions are valid for a record in a given state. Particularly when you have a large number of combinations for valid states and status values, defining a limited list of valid options can make it easier for people to choose the correct status for a record.

In this topic

What is the state model?

Detect valid status transitions

What is the state model?

Entities that support the concept of state have a pair of attributes that capture this data, as shown in this table.

Logical Name | Display Name | Description
statecode | Status | Represents the state of the record. For custom entities this is Active or Inactive. The Incident (case) entity uses Active, Resolved, and Canceled. You can’t add more state options but you can change the option labels.
statuscode | Status Reason | Represents a status that is linked to a specific state. Each state must have at least one possible status. You can add additional status options and change the labels of existing options.

The metadata for the attributes defines what status values are valid for a given state. For example, for the Incident (Case) entity, the default state and status options are shown in the following table.

State | Status
Label: Active Value: 0 | Label: In Progress Value: 1 State: 0
 | Label: On Hold Value: 2 State: 0
 | Label: Waiting for Details Value: 3 State: 0
 | Label: Researching Value: 4 State: 0
Label: Resolved Value: 1 | Label: Problem Solved Value: 5 State: 1
 | Label: Information Provided Value: 1000 State: 1
Label: Canceled Value: 2 | Label: Canceled Value: 6 State: 2
 | Label: Merged Value: 2000 State: 2

This data is stored in the StatusOptionMetadata class, which represents the options in the StatusAttributeMetadata class.

To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Detect valid status transitions

You can modify the statuscode attribute to define which other status options represent valid transitions from the current status. For instructions, see the Customization Guide topic: Define status reason transitions

When custom state transitions are applied to an entity, the EntityMetadata.EnforceStateTransitions property will be true. Also, each StatusOptionMetadata within the StatusAttributeMetadata.Options collection will have a new TransitionData property. This property will contain a String value that represents an XML document. This document contains the definition of the allowed transitions. For example, the default Incident (Case) StatusCode attribute option may have the following TransitionData value.

Copy Code
<allowedtransitions xmlns="http://schemas.microsoft.com/crm/2009/WebServices">
<allowedtransition sourcestatusid="1" tostatusid="6" />
<allowedtransition sourcestatusid="1" tostatusid="1000" />
<allowedtransition sourcestatusid="1" tostatusid="2000" />
<allowedtransition sourcestatusid="1" tostatusid="5" />
</allowedtransitions>
Note
When this data is retrieved in unmanaged code from the web service, for example when using JavaScript, it will be escaped and appear like the following example.

Copy Code
&lt;allowedtransitions xmlns="http://schemas.microsoft.com/crm/2009/WebServices"&gt;
&lt;allowedtransition sourcestatusid="1" tostatusid="6" /&gt;
&lt;allowedtransition sourcestatusid="1" tostatusid="1000" /&gt;
&lt;allowedtransition sourcestatusid="1" tostatusid="2000" /&gt;
&lt;allowedtransition sourcestatusid="1" tostatusid="5" /&gt;
&lt;/allowedtransitions&gt;

When this data is present and the Entity EnforceStateTransitions property is true, any incident instance can only be changed to one of the allowed statuscode values. You can use IOrganizationService.Update to set the statuscode OptionSetValue to any of the allowed values that don’t represent a change in state. To change the state, use SetStateRequest setting the allowed State and Status property values or the CloseIncidentRequest setting Status property to one of the values allowed for the current statuscode value. Attempting to set an invalid value throws an error.

See Also

Reference

Record state and status

Concepts

Retrieve and detect changes to metadata

Other Resources

Sample: Retrieve valid status transitions
Define status reason transitions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve valid status transitions
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Attributes\StateModelTransitions.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve valid state transitions regardless of whether custom state transitions have been defined for the entity.

The sample does the following tasks:

  1. Retrieves status options for the Incident entity
  2. Uses a GetValidStatusOptions method in the sample to get valid status transitions for each status option
  3. Displays the valid transition options in the console

When status reason transitions for the incident entity are configured in the following way:

Example of status reason transitions for case

The valid state transitions are filtered and you will see the following representing all the valid transitions for each status option.

Copy Code
[In Progress] incident records can transition to:
2  Canceled  1    Canceled
2  Canceled  1    Merged
0  Active    1    On Hold

[On Hold] incident records can transition to:
2  Canceled  2    Canceled
2  Canceled  2    Merged
0  Active    2    Waiting for Details

[Waiting for Details] incident records can transition to:
2  Canceled  3    Canceled
2  Canceled  3    Merged
0  Active    3    Researching

[Researching] incident records can transition to:
2  Canceled  4    Canceled
1  Resolved  4    Information Provided
1  Resolved  4    Problem Solved
2  Canceled  4    Merged

[Problem Solved] incident records can transition to:
2  Canceled  5    Merged

[Information Provided] incident records can transition to:
2  Canceled  1000 Merged

[Canceled] incident records can transition to:
2  Canceled  6    Merged

[Merged] incident records can transition to:

When this sample is run without status reason transitions applied on the incident entity you will see the following representing all the possible transitions for each status.

Copy Code
[Problem Solved] incident records can transition to:
1  Resolved  1000 Information Provided
2  Canceled  6    Canceled
2  Canceled  2000 Merged
0  Active    1    In Progress
0  Active    2    On Hold
0  Active    3    Waiting for Details
0  Active    4    Researching

[Information Provided] incident records can transition to:
1  Resolved  5    Problem Solved
2  Canceled  6    Canceled
2  Canceled  2000 Merged
0  Active    1    In Progress
0  Active    2    On Hold
0  Active    3    Waiting for Details
0  Active    4    Researching

[Canceled] incident records can transition to:
1  Resolved  5    Problem Solved
1  Resolved  1000 Information Provided
2  Canceled  2000 Merged
0  Active    1    In Progress
0  Active    2    On Hold
0  Active    3    Waiting for Details
0  Active    4    Researching

[Merged] incident records can transition to:
1  Resolved  5    Problem Solved
1  Resolved  1000 Information Provided
2  Canceled  6    Canceled
0  Active    1    In Progress
0  Active    2    On Hold
0  Active    3    Waiting for Details
0  Active    4    Researching

[In Progress] incident records can transition to:
1  Resolved  5    Problem Solved
1  Resolved  1000 Information Provided
2  Canceled  6    Canceled
2  Canceled  2000 Merged
0  Active    2    On Hold
0  Active    3    Waiting for Details
0  Active    4    Researching

[On Hold] incident records can transition to:
1  Resolved  5    Problem Solved
1  Resolved  1000 Information Provided
2  Canceled  6    Canceled
2  Canceled  2000 Merged
0  Active    1    In Progress
0  Active    3    Waiting for Details
0  Active    4    Researching

[Waiting for Details] incident records can transition to:
1  Resolved  5    Problem Solved
1  Resolved  1000 Information Provided
2  Canceled  6    Canceled
2  Canceled  2000 Merged
0  Active    1    In Progress
0  Active    2    On Hold
0  Active    4    Researching

[Researching] incident records can transition to:
1  Resolved  5    Problem Solved
1  Resolved  1000 Information Provided
2  Canceled  6    Canceled
2  Canceled  2000 Merged
0  Active    1    In Progress
0  Active    2    On Hold
0  Active    3    Waiting for Details

Example

The following is the GetValidStatusOptions method used in the sample:

C# Copy Code
/// <summary>
/// Returns valid status option transitions regardless of whether state transitions are enabled for the entity
/// </summary>
/// <param name="entityLogicalName">The logical name of the entity</param>
/// <param name="currentStatusValue">The current status of the entity instance</param>
/// <returns>A list of StatusOptions that represent the valid transitions</returns>
public List<StatusOption> GetValidStatusOptions(String entityLogicalName, int currentStatusValue)
{

 List<StatusOption> validStatusOptions = new List<StatusOption>();

 //Check entity Metadata

 //Retrieve just one entity definition
 MetadataFilterExpression entityFilter = new MetadataFilterExpression(LogicalOperator.And);
 entityFilter.Conditions.Add(new MetadataConditionExpression("LogicalName", MetadataConditionOperator.Equals, entityLogicalName));
 //Return the attributes and the EnforceStateTransitions property
 MetadataPropertiesExpression entityProperties = new MetadataPropertiesExpression(new string[] { "Attributes", "EnforceStateTransitions" });

 //Retrieve only State or Status attributes
 MetadataFilterExpression attributeFilter = new MetadataFilterExpression(LogicalOperator.Or);
 attributeFilter.Conditions.Add(new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Status));
 attributeFilter.Conditions.Add(new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.State));

 //Retrieve only the OptionSet property of the attributes
 MetadataPropertiesExpression attributeProperties = new MetadataPropertiesExpression(new string[] { "OptionSet" });

 //Set the query
 EntityQueryExpression query = new EntityQueryExpression()
 {
  Criteria = entityFilter,
  Properties = entityProperties,
  AttributeQuery = new AttributeQueryExpression() { Criteria = attributeFilter, Properties = attributeProperties }
 };

 //Retrieve the metadata
 RetrieveMetadataChangesRequest request = new RetrieveMetadataChangesRequest() { Query = query };
 RetrieveMetadataChangesResponse response = (RetrieveMetadataChangesResponse)_serviceProxy.Execute(request);

 //Check the value of EnforceStateTransitions
 Boolean? EnforceStateTransitions = response.EntityMetadata[0].EnforceStateTransitions;

 //Capture the state and status attributes
 StatusAttributeMetadata statusAttribute = new StatusAttributeMetadata();
 StateAttributeMetadata stateAttribute = new StateAttributeMetadata();

 foreach (AttributeMetadata attributeMetadata in response.EntityMetadata[0].Attributes)
 {
  switch (attributeMetadata.AttributeType)
  {
   case AttributeTypeCode.Status:
    statusAttribute = (StatusAttributeMetadata)attributeMetadata;
    break;
   case AttributeTypeCode.State:
    stateAttribute = (StateAttributeMetadata)attributeMetadata;
    break;
  }
 }

 if (EnforceStateTransitions.HasValue && EnforceStateTransitions.Value == true)
 {
  //When EnforceStateTransitions is true use the TransitionData to filter the valid options
  foreach (StatusOptionMetadata option in statusAttribute.OptionSet.Options)
  {
   if (option.Value == currentStatusValue)
   {
    if (option.TransitionData != String.Empty)
    {
     XDocument transitionData = XDocument.Parse(option.TransitionData);

     IEnumerable<XElement> elements = (((XElement)transitionData.FirstNode)).Descendants();

     foreach (XElement e in elements)
     {
      int statusOptionValue = Convert.ToInt32(e.Attribute("tostatusid").Value);
      String statusLabel = GetOptionSetLabel(statusAttribute, statusOptionValue);

      string stateLabel = String.Empty;
      int? stateValue = null;
      foreach (StatusOptionMetadata statusOption in statusAttribute.OptionSet.Options)
      {
       if (statusOption.Value.Value == statusOptionValue)
       {
        stateValue = statusOption.State.Value;
        stateLabel = GetOptionSetLabel(stateAttribute, stateValue.Value);
       }

      }

      validStatusOptions.Add(new StatusOption()
      {
       StateLabel = stateLabel,
       StateValue = stateValue.Value,
       StatusLabel = statusLabel,
       StatusValue = option.Value.Value
      });
     }
    }
   }
  }

 }
 else
 {
  ////When EnforceStateTransitions is false do not filter the available options

  foreach (StatusOptionMetadata option in statusAttribute.OptionSet.Options)
  {
   if (option.Value != currentStatusValue)
   {

    String statusLabel = "";
    try
    {
     statusLabel = option.Label.UserLocalizedLabel.Label;
    }
    catch (Exception)
    {
     statusLabel = option.Label.LocalizedLabels[0].Label;
    };

    String stateLabel = GetOptionSetLabel(stateAttribute, option.State.Value);

    validStatusOptions.Add(new StatusOption()
    {
     StateLabel = stateLabel,
     StateValue = option.State.Value,
     StatusLabel = statusLabel,
     StatusValue = option.Value.Value

    });
   }
  }
 }
 return validStatusOptions;

}

The following is the full code for the sample.

C# Copy Code

using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;
using System.Xml.Serialization;
using System.Xml;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Metadata.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
 class StateModelTransitions
 {
  #region Class Level Members
  /// <summary>
  /// Stores the organization service proxy.
  /// </summary>
  OrganizationServiceProxy _serviceProxy;
  #endregion Class Level Members

  #region How To Sample Code
  /// <summary>
  /// Create and configure the organization service proxy.
  /// Retrieve status options for the Incident entity
  /// Use GetValidStatusOptions to get valid status transitions for each status option
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>
  /// <param name="promptForDelete">When True, the user will be prompted to delete all
  /// created entities.</param>
  public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
  {
   try
   {

    // Connect to the Organization service.
    // The using statement assures that the service proxy will be properly disposed.
    using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();
     String entityLogicalName = "incident";
     // Retrieve status options for the Incident entity

     //Retrieve just the incident entity and its attributes
     MetadataFilterExpression entityFilter = new MetadataFilterExpression(LogicalOperator.And);
     entityFilter.Conditions.Add(new MetadataConditionExpression("LogicalName", MetadataConditionOperator.Equals, entityLogicalName));
     MetadataPropertiesExpression entityProperties = new MetadataPropertiesExpression(new string[] { "Attributes" });

     //Retrieve just the status attribute and the OptionSet property
     MetadataFilterExpression attributeFilter = new MetadataFilterExpression(LogicalOperator.And);
     attributeFilter.Conditions.Add(new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Status));
     MetadataPropertiesExpression attributeProperties = new MetadataPropertiesExpression(new string[] { "OptionSet" });

     //Instantiate the entity query
     EntityQueryExpression query = new EntityQueryExpression()
     {
      Criteria = entityFilter,
      Properties = entityProperties,
      AttributeQuery = new AttributeQueryExpression() { Criteria = attributeFilter, Properties = attributeProperties }
     };

     //Retrieve the metadata
     RetrieveMetadataChangesRequest request = new RetrieveMetadataChangesRequest() { Query = query };
     RetrieveMetadataChangesResponse response = (RetrieveMetadataChangesResponse)_serviceProxy.Execute(request);

     StatusAttributeMetadata statusAttribute = (StatusAttributeMetadata)response.EntityMetadata[0].Attributes[0];
     OptionMetadataCollection statusOptions = statusAttribute.OptionSet.Options;
     //Loop through each of the status options
     foreach (StatusOptionMetadata option in statusOptions)
     {
      String StatusOptionLabel = GetOptionSetLabel(statusAttribute, option.Value.Value);
      Console.WriteLine("[{0}] {1} records can transition to:", StatusOptionLabel, entityLogicalName);
      List<StatusOption> validStatusOptions = GetValidStatusOptions(entityLogicalName, option.Value.Value);
      //Loop through each valid transition for the option
      foreach (StatusOption opt in validStatusOptions)
      {
       Console.WriteLine("{0,-3}{1,-10}{2,-5}{3,-10}", opt.StateValue, opt.StateLabel, opt.StatusValue, opt.StatusLabel);
      }
      Console.WriteLine("");
     }
    }
   }

   // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  #endregion How To Sample Code

  #region Main
  /// <summary>
  /// Standard Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    StateModelTransitions app = new StateModelTransitions();
    app.Run(config, true);
   }
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
         = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
     }
    }
   }
   // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {

    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }

  }
  #endregion Main

  #region Methods used in Sample
  /// <summary>
  /// Returns valid status option transitions regardless of whether state transitions are enabled for the entity
  /// </summary>
  /// <param name="entityLogicalName">The logical name of the entity</param>
  /// <param name="currentStatusValue">The current status of the entity instance</param>
  /// <returns>A list of StatusOptions that represent the valid transitions</returns>
  public List<StatusOption> GetValidStatusOptions(String entityLogicalName, int currentStatusValue)
  {

   List<StatusOption> validStatusOptions = new List<StatusOption>();

   //Check entity Metadata

   //Retrieve just one entity definition
   MetadataFilterExpression entityFilter = new MetadataFilterExpression(LogicalOperator.And);
   entityFilter.Conditions.Add(new MetadataConditionExpression("LogicalName", MetadataConditionOperator.Equals, entityLogicalName));
   //Return the attributes and the EnforceStateTransitions property
   MetadataPropertiesExpression entityProperties = new MetadataPropertiesExpression(new string[] { "Attributes", "EnforceStateTransitions" });

   //Retrieve only State or Status attributes
   MetadataFilterExpression attributeFilter = new MetadataFilterExpression(LogicalOperator.Or);
   attributeFilter.Conditions.Add(new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Status));
   attributeFilter.Conditions.Add(new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.State));

   //Retrieve only the OptionSet property of the attributes
   MetadataPropertiesExpression attributeProperties = new MetadataPropertiesExpression(new string[] { "OptionSet" });

   //Set the query
   EntityQueryExpression query = new EntityQueryExpression()
   {
    Criteria = entityFilter,
    Properties = entityProperties,
    AttributeQuery = new AttributeQueryExpression() { Criteria = attributeFilter, Properties = attributeProperties }
   };

   //Retrieve the metadata
   RetrieveMetadataChangesRequest request = new RetrieveMetadataChangesRequest() { Query = query };
   RetrieveMetadataChangesResponse response = (RetrieveMetadataChangesResponse)_serviceProxy.Execute(request);

   //Check the value of EnforceStateTransitions
   Boolean? EnforceStateTransitions = response.EntityMetadata[0].EnforceStateTransitions;

   //Capture the state and status attributes
   StatusAttributeMetadata statusAttribute = new StatusAttributeMetadata();
   StateAttributeMetadata stateAttribute = new StateAttributeMetadata();

   foreach (AttributeMetadata attributeMetadata in response.EntityMetadata[0].Attributes)
   {
    switch (attributeMetadata.AttributeType)
    {
     case AttributeTypeCode.Status:
      statusAttribute = (StatusAttributeMetadata)attributeMetadata;
      break;
     case AttributeTypeCode.State:
      stateAttribute = (StateAttributeMetadata)attributeMetadata;
      break;
    }
   }

   if (EnforceStateTransitions.HasValue && EnforceStateTransitions.Value == true)
   {
    //When EnforceStateTransitions is true use the TransitionData to filter the valid options
    foreach (StatusOptionMetadata option in statusAttribute.OptionSet.Options)
    {
     if (option.Value == currentStatusValue)
     {
      if (option.TransitionData != String.Empty)
      {
       XDocument transitionData = XDocument.Parse(option.TransitionData);

       IEnumerable<XElement> elements = (((XElement)transitionData.FirstNode)).Descendants();

       foreach (XElement e in elements)
       {
        int statusOptionValue = Convert.ToInt32(e.Attribute("tostatusid").Value);
        String statusLabel = GetOptionSetLabel(statusAttribute, statusOptionValue);

        string stateLabel = String.Empty;
        int? stateValue = null;
        foreach (StatusOptionMetadata statusOption in statusAttribute.OptionSet.Options)
        {
         if (statusOption.Value.Value == statusOptionValue)
         {
          stateValue = statusOption.State.Value;
          stateLabel = GetOptionSetLabel(stateAttribute, stateValue.Value);
         }

        }

        validStatusOptions.Add(new StatusOption()
        {
         StateLabel = stateLabel,
         StateValue = stateValue.Value,
         StatusLabel = statusLabel,
         StatusValue = option.Value.Value
        });
       }
      }
     }
    }

   }
   else
   {
    ////When EnforceStateTransitions is false do not filter the available options

    foreach (StatusOptionMetadata option in statusAttribute.OptionSet.Options)
    {
     if (option.Value != currentStatusValue)
     {

      String statusLabel = "";
      try
      {
       statusLabel = option.Label.UserLocalizedLabel.Label;
      }
      catch (Exception)
      {
       statusLabel = option.Label.LocalizedLabels[0].Label;
      };

      String stateLabel = GetOptionSetLabel(stateAttribute, option.State.Value);

      validStatusOptions.Add(new StatusOption()
      {
       StateLabel = stateLabel,
       StateValue = option.State.Value,
       StatusLabel = statusLabel,
       StatusValue = option.Value.Value

      });
     }
    }
   }
   return validStatusOptions;

  }

  /// <summary>
  /// Returns a string representing the label of an option in an optionset
  /// </summary>
  /// <param name="attribute">The metadata for an an attribute with options</param>
  /// <param name="value">The value of the option</param>
  /// <returns>The label for the option</returns>
  public String GetOptionSetLabel(EnumAttributeMetadata attribute, int value)
   {
    String label = "";
    foreach (OptionMetadata option in attribute.OptionSet.Options)
    {
     if (option.Value.Value == value)
     {
      try
      {
       label = option.Label.UserLocalizedLabel.Label;
      }
      catch (Exception)
      {
       label = option.Label.LocalizedLabels[0].Label;
      };
     }
    }
    return label;
   }
  #endregion Methods used in Sample
 }
 public class StatusOption
 {
  public int StatusValue { get; set; }
  public String StatusLabel { get; set; }
  public int StateValue { get; set; }
  public String StateLabel { get; set; }
 }
}

See Also

Concepts

Define custom state model transitions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Set and retrieve entity images
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\LateBound\EntityImages.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to set and retrieve data for entity images.

The sample does the following tasks:

  1. Uses the CreateImageAttributeDemoEntity method to:
    1. Create a custom entity with the schema name sample_ImageAttributeDemo and a primary attribute with the schema name sample_Name.
    2. Create an image attribute with the schema name EntityImage. All image attributes use this name.
    3. Retrieve and update the main form for the sample_ImageAttributeDemo entity to set the <form> (FormXml) showImage attribute to true so that the image is displayed in the form.
    4. Publish the sample_ImageAttributeDemo entity.
  2. Creates five new records for the sample_ImageAttributeDemo entity using five different sized images located in the Images folder as shown here.
    The relative size of source images
    The sample_Name primary attribute field value is the name of the file.
    After each record is created you have the opportunity to view the record in the web browser application using the ShowEntityFormInBrowser method so that you can see how the source images are resized to fit the space available in the form.

    C# Copy Code
    //Use a 144x144 pixel image
Entity imageEntity1 = new Entity(_customEntityName.ToLower());
imageEntity1["sample_name"] = "144x144.png";
imageEntity1["entityimage"] = File.ReadAllBytes("Images\\144x144.png");
Guid imageEntity1Id = _serviceProxy.Create(imageEntity1);
ShowEntityFormInBrowser(promptforDelete, "144x144.png", imageEntity1Id);

//Use a 144x400 pixel image
Entity imageEntity2 = new Entity(_customEntityName.ToLower());
imageEntity2["sample_name"] = "144x400.png";
imageEntity2["entityimage"] = File.ReadAllBytes("Images\\144x400.png");
Guid imageEntity2Id = _serviceProxy.Create(imageEntity2);
ShowEntityFormInBrowser(promptforDelete, "144x400.png", imageEntity2Id);

//Use a 400x144 pixel image
Entity imageEntity3 = new Entity(_customEntityName.ToLower());
imageEntity3["sample_name"] = "400x144.png";
imageEntity3["entityimage"] = File.ReadAllBytes("Images\\400x144.png");
Guid imageEntity3Id = _serviceProxy.Create(imageEntity3);
ShowEntityFormInBrowser(promptforDelete, "400x144.png", imageEntity3Id);

//Use a 400x500 pixel image
Entity imageEntity4 = new Entity(_customEntityName.ToLower());
imageEntity4["sample_name"] = "400x500.png";
imageEntity4["entityimage"] = File.ReadAllBytes("Images\\400x500.png");
Guid imageEntity4Id = _serviceProxy.Create(imageEntity4);
ShowEntityFormInBrowser(promptforDelete, "400x500.png", imageEntity4Id);

//Use a 60x80 pixel image
Entity imageEntity5 = new Entity(_customEntityName.ToLower());
imageEntity5["sample_name"] = "60x80.png";
imageEntity5["entityimage"] = File.ReadAllBytes("Images\\60x80.png");
Guid imageEntity5Id = _serviceProxy.Create(imageEntity5);
ShowEntityFormInBrowser(promptforDelete, "60x80.png", imageEntity5Id);

    Note
    This code uses late bound entities because the entity is created in the sample and is not available as a strongly typed class. However, after early bound classes are generated, the strongly typed classes could be used. More information: Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)

  3. Retrieves the records with the entityimage attribute and saves the resized files. After you run the sample you can find the files saved in the \bin\Debug folder.

    C# Copy Code
         //Retrieve and download the binary images
     string binaryImageQuery =
String.Format(@"<fetch mapping='logical'>
  <entity name='{0}'>
    <attribute name='sample_name' />
    <attribute name='entityimage' />
  </entity>
</fetch>",_customEntityName.ToLower());

     EntityCollection binaryImageResults = _serviceProxy.RetrieveMultiple(new FetchExpression(binaryImageQuery));

     Console.WriteLine("Records retrieved and image files saved to: {0}", Directory.GetCurrentDirectory());
     foreach (Entity record in binaryImageResults.Entities)
     {
      String recordName = record["sample_name"] as String;
      String downloadedFileName = String.Format("Downloaded_{0}", recordName);
      byte[] imageBytes = record["entityimage"] as byte[];
      var fs = new BinaryWriter(new FileStream(downloadedFileName, FileMode.Append, FileAccess.Write));
      fs.Write(imageBytes);
      fs.Close();
      Console.WriteLine(downloadedFileName);
     }
    The image files are resized as shown here.
    The relative size of downloaded images
  4. Retrieves the records with the entityimage_url attribute and displays the relative URL values you can include in your application to access the images. This query should be more responsive because the amount of data transferred is smaller.

    C# Copy Code
         //Retrieve and the records with just the url
     string imageUrlQuery =
String.Format(@"<fetch mapping='logical'>
  <entity name='{0}'>
    <attribute name='sample_name' />
    <attribute name='entityimage_url' />
  </entity>
</fetch>", _customEntityName.ToLower());

     EntityCollection imageUrlResults = _serviceProxy.RetrieveMultiple(new FetchExpression(imageUrlQuery));

     Console.WriteLine("These are the relative URLs for the images retrieved:");
     foreach (Entity record in imageUrlResults.Entities)
     {
      String imageUrl = record["entityimage_url"] as String;
      Console.WriteLine(imageUrl);
     }
    The relative URLs will look something like the following examples:
    • /Image/download.aspx?Entity=sample_imageattributedemo&Attribute=entityimage&Id=2ed5a666-7b51-e311-9088-00155d9c5607&Timestamp=635205044273046819
    • /Image/download.aspx?Entity=sample_imageattributedemo&Attribute=entityimage&Id=22f17c6d-7b51-e311-9088-00155d9c5607&Timestamp=635205044320978850
    • /Image/download.aspx?Entity=sample_imageattributedemo&Attribute=entityimage&Id=24f17c6d-7b51-e311-9088-00155d9c5607&Timestamp=635205044333049824
    • /Image/download.aspx?Entity=sample_imageattributedemo&Attribute=entityimage&Id=26f17c6d-7b51-e311-9088-00155d9c5607&Timestamp=635205044343080227
    • /Image/download.aspx?Entity=sample_imageattributedemo&Attribute=entityimage&Id=28f17c6d-7b51-e311-9088-00155d9c5607&Timestamp=635205044353421800

The DeleteImageAttributeDemoEntity method gives you the option to delete the sample_ImageAttributeDemo entity and return your organization to state it was before running the sample. You can’t run the sample again until you delete this entity.

Example

The following is the full code for the sample.

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Diagnostics;
using System.Xml.Linq;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
 /// <summary>
 /// Demonstrates how to do create and retrieve records with image data
 /// </summary>
 /// <remarks>
 /// At run-time, you will be given the option to delete all the
 /// database records created by this program.</remarks>
 public class EntityImages
 {
  #region Class Level Members
  private OrganizationServiceProxy _serviceProxy;
  private const String _customEntityName = "sample_ImageAttributeDemo";
  #endregion Class Level Members

  #region How To Sample Code
  /// <summary>
  /// This method first connects to the Organization service. Afterwards,
  /// a custom entity is created and configured to support entity images.
  /// Then records are created using this custom entity with image data.
  /// The records are then retrieved and the resized images are saved.
  /// Finally, the custom entity can be deleted.
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>
  /// <param name="promptforDelete">When True, the user will be prompted to delete all
  /// created entities.</param>
  public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
  {
   try
   {
    // Connect to the Organization service.
    // The using statement assures that the service proxy will be properly disposed.
    using (_serviceProxy = ServerConnection.GetOrganizationProxy(serverConfig))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();

     Console.WriteLine("Please wait while the custom Image Attribute Demo entity used by this sample is created.");
     //Creates the Image Attribute Demo entity used in this sample
     CreateImageAttributeDemoEntity();

     //Create 5 records using different sized images.
     /*

      This sample uses late-binding because the entity was just created and is
      not included in the 'MyOrganizationsCrmSdkTypes.cs' file created by the
      code generation tool (CrmSvcUtil.exe)

     */
     //Use a 144x144 pixel image
     Entity imageEntity1 = new Entity(_customEntityName.ToLower());
     imageEntity1["sample_name"] = "144x144.png";
     imageEntity1["entityimage"] = File.ReadAllBytes("Images\\144x144.png");
     Guid imageEntity1Id = _serviceProxy.Create(imageEntity1);
     ShowEntityFormInBrowser(promptforDelete, "144x144.png", imageEntity1Id);

     //Use a 144x400 pixel image
     Entity imageEntity2 = new Entity(_customEntityName.ToLower());
     imageEntity2["sample_name"] = "144x400.png";
     imageEntity2["entityimage"] = File.ReadAllBytes("Images\\144x400.png");
     Guid imageEntity2Id = _serviceProxy.Create(imageEntity2);
     ShowEntityFormInBrowser(promptforDelete, "144x400.png", imageEntity2Id);

     //Use a 400x144 pixel image
     Entity imageEntity3 = new Entity(_customEntityName.ToLower());
     imageEntity3["sample_name"] = "400x144.png";
     imageEntity3["entityimage"] = File.ReadAllBytes("Images\\400x144.png");
     Guid imageEntity3Id = _serviceProxy.Create(imageEntity3);
     ShowEntityFormInBrowser(promptforDelete, "400x144.png", imageEntity3Id);

     //Use a 400x500 pixel image
     Entity imageEntity4 = new Entity(_customEntityName.ToLower());
     imageEntity4["sample_name"] = "400x500.png";
     imageEntity4["entityimage"] = File.ReadAllBytes("Images\\400x500.png");
     Guid imageEntity4Id = _serviceProxy.Create(imageEntity4);
     ShowEntityFormInBrowser(promptforDelete, "400x500.png", imageEntity4Id);

     //Use a 60x80 pixel image
     Entity imageEntity5 = new Entity(_customEntityName.ToLower());
     imageEntity5["sample_name"] = "60x80.png";
     imageEntity5["entityimage"] = File.ReadAllBytes("Images\\60x80.png");
     Guid imageEntity5Id = _serviceProxy.Create(imageEntity5);
     ShowEntityFormInBrowser(promptforDelete, "60x80.png", imageEntity5Id);
     Console.WriteLine();
     //Retrieve and download the binary images
     string binaryImageQuery =
String.Format(@"<fetch mapping='logical'>
  <entity name='{0}'>
    <attribute name='sample_name' />
    <attribute name='entityimage' />
  </entity>
</fetch>",_customEntityName.ToLower());

     EntityCollection binaryImageResults = _serviceProxy.RetrieveMultiple(new FetchExpression(binaryImageQuery));

     Console.WriteLine("Records retrieved and image files saved to: {0}", Directory.GetCurrentDirectory());
     foreach (Entity record in binaryImageResults.Entities)
     {
      String recordName = record["sample_name"] as String;
      String downloadedFileName = String.Format("Downloaded_{0}", recordName);
      byte[] imageBytes = record["entityimage"] as byte[];
      var fs = new BinaryWriter(new FileStream(downloadedFileName, FileMode.Append, FileAccess.Write));
      fs.Write(imageBytes);
      fs.Close();
      Console.WriteLine(downloadedFileName);
     }
     Console.WriteLine();
     //Retrieve and the records with just the url
     string imageUrlQuery =
String.Format(@"<fetch mapping='logical'>
  <entity name='{0}'>
    <attribute name='sample_name' />
    <attribute name='entityimage_url' />
  </entity>
</fetch>", _customEntityName.ToLower());

     EntityCollection imageUrlResults = _serviceProxy.RetrieveMultiple(new FetchExpression(imageUrlQuery));

     Console.WriteLine("These are the relative URLs for the images retrieved:");
     foreach (Entity record in imageUrlResults.Entities)
     {
      String imageUrl = record["entityimage_url"] as String;
      Console.WriteLine(imageUrl);
     }

     DeleteImageAttributeDemoEntity(promptforDelete);
    }
   }

   // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  /// <summary>
  /// Creates any entity records that this sample requires.
  /// </summary>
  public void CreateImageAttributeDemoEntity()
  {
   //Create a Custom entity
   CreateEntityRequest createrequest = new CreateEntityRequest
   {

    //Define the entity
    Entity = new EntityMetadata
    {
     SchemaName = _customEntityName,
     DisplayName = new Label("Image Attribute Demo", 1033),
     DisplayCollectionName = new Label("Image Attribute Demos", 1033),
     Description = new Label("An entity created by an SDK sample to demonstrate how to upload and retrieve entity images.", 1033),
     OwnershipType = OwnershipTypes.UserOwned,
     IsActivity = false,

    },

    // Define the primary attribute for the entity
    PrimaryAttribute = new StringAttributeMetadata
    {
     SchemaName = "sample_Name",
     RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
     MaxLength = 100,
     FormatName = StringFormatName.Text,
     DisplayName = new Label("Name", 1033),
     Description = new Label("The primary attribute for the Image Attribute Demo entity.", 1033)
    }

   };
   _serviceProxy.Execute(createrequest);
   Console.WriteLine("The Image Attribute Demo entity has been created.");

   //Create an Image attribute for the custom entity
   // Only one Image attribute can be added to an entity that doesn't already have one.
   CreateAttributeRequest createEntityImageRequest = new CreateAttributeRequest
   {
    EntityName = _customEntityName.ToLower(),
    Attribute = new ImageAttributeMetadata
    {
     SchemaName = "EntityImage", //The name is always EntityImage
     //Required level must be AttributeRequiredLevel.None
     RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
     DisplayName = new Label("Image", 1033),
     Description = new Label("An image to show with this demonstration.", 1033)

    }
   };
   _serviceProxy.Execute(createEntityImageRequest);
   Console.WriteLine("The Image attribute has been created.");

   QueryExpression qe = new QueryExpression("systemform");
   qe.Criteria.AddCondition("type", ConditionOperator.Equal, 2); //main form
   qe.Criteria.AddCondition("objecttypecode", ConditionOperator.Equal, _customEntityName.ToLower());
   qe.ColumnSet.AddColumn("formxml");

   SystemForm ImageAttributeDemoMainForm = (SystemForm)_serviceProxy.RetrieveMultiple(qe).Entities[0];

   XDocument ImageAttributeDemoMainFormXml = XDocument.Parse(ImageAttributeDemoMainForm.FormXml);
   //Set the showImage attribute so the entity image will be displayed
   ImageAttributeDemoMainFormXml.Root.SetAttributeValue("showImage", true);

   //Updating the entity form definition
   ImageAttributeDemoMainForm.FormXml = ImageAttributeDemoMainFormXml.ToString();

   _serviceProxy.Update(ImageAttributeDemoMainForm);
   Console.WriteLine("The Image Attribute Demo main form has been updated to show images.");

   PublishXmlRequest pxReq1 = new PublishXmlRequest { ParameterXml = String.Format(@"
   <importexportxml>
    <entities>
     <entity>{0}</entity>
    </entities>
   </importexportxml>", _customEntityName.ToLower()) };
   _serviceProxy.Execute(pxReq1);

   Console.WriteLine("The Image Attribute Demo entity was published");
  }

  public void ShowEntityFormInBrowser(bool prompt, String name, Guid id)
  {
   if (prompt)
   {
    Console.WriteLine("\nDo you want to view record '{0}' form? (y/n)", name);
    String viewFormAnswer = Console.ReadLine();
    if (viewFormAnswer.StartsWith("y") || viewFormAnswer.StartsWith("Y"))
    {
     try
     {
      String webServiceURL = _serviceProxy.EndpointSwitch.PrimaryEndpoint.AbsoluteUri;
      String entityInDefaultSolutionUrl = webServiceURL.Replace("XRMServices/2011/Organization.svc",
       String.Format("main.aspx?etn={0}&pagetype=entityrecord&id=%7B{1}%7D", _customEntityName.ToLower(),id.ToString()));

      ProcessStartInfo browserProcess = new ProcessStartInfo("iexplore.exe");
      browserProcess.Arguments = entityInDefaultSolutionUrl;
      Process.Start(browserProcess);

     }
     catch (SystemException)
     {
      Console.WriteLine("\nThere was a problem opening Internet Explorer.");
     }
    }
   }
  }

  /// <summary>
  /// Deletes any entity records that were created for this sample.
  /// <param name="prompt">Indicates whether to prompt the user
  /// to delete the records created in this sample.</param>
  /// </summary>
  public void DeleteImageAttributeDemoEntity(bool prompt)
  {
   bool deleteRecords = true;

   if (prompt)
   {
    Console.WriteLine("\nDo you want to delete the entity created for this sample? (y/n) [y]: ");
    String answer = Console.ReadLine();

    deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
   }

   if (deleteRecords)
   {
    DeleteEntityRequest der = new DeleteEntityRequest() { LogicalName = _customEntityName.ToLower() };
    _serviceProxy.Execute(der);
    Console.WriteLine("The Image Attribute Demo entity has been deleted.");
   }
  }

  #endregion How To Sample Code

  #region Main method

  /// <summary>
  /// Standard Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    EntityImages app = new EntityImages();
    app.Run(config, true);
   }

   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
     }
    }
   }

   // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {
    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }
  }
  #endregion Main method
 }
}

See Also

Concepts

Image attributes
Introduction to entity attributes in Microsoft Dynamics CRM
Introduction to entities in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Administration and security entities

The entities described in this section are used to set up the Microsoft Dynamics CRM system. This includes setting up the businesses, users, and teams that define your organization.

In This Section

Organization entities

BusinessUnit entity

User and team entities

Privilege and role entities

Field security entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Organization entities

An organization entity is internal to the customer relationship management process. The organization is the top level of the Microsoft Dynamics CRM business hierarchy. The organization can be a specific business, a holding company, a corporation, and so on. An organization is divided into business units. Schema customization is done at this level.

A deployment is a single installation of Microsoft Dynamics CRM. For more information about writing code for a deployment, see Administer the deployment using the deployment web service.

An announcement is a message that appears to all users on the home page of the web application. Announcements are owned by the organization and are represented by the BusinessUnitNewsArticle entity.

You can call the WhoAmIRequest message to find out the organization for the currently logged on or impersonated user.

Actions on the organization entity

An organization record is created when an organization is created in a deployment of Microsoft Dynamics CRM. To create, import, or delete an organization programmatically, you must use the deployment web service. This advanced operation is described in Administer the deployment using the deployment web service. After an organization is created, you can use the organization web service to retrieve or update the organization. The methods to do this programmatically are described in Organization entity messages and methods.

An organization can own records as defined in the ownership type in the metadata definition for an entity. More information: Entity Ownership

See Also

Reference

BusinessUnitNewsArticle (announcement) entity privileges

Concepts

Organization entity messages and methods
BusinessUnitNewsArticle (announcement) entity messages and methods
Organization entity privileges

Other Resources

Administration and security entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Organization entity messages and methods

An organization represents the top level of the Microsoft Dynamics CRM business hierarchy. The organization can be a specific business, holding company, or corporation. The schema name for this entity is Organization. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves an organization. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of organizations. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveOrganizationResourcesRequest | Retrieves the resources used by an organization.
UpdateRequest | Updates an organization. You can also call the IOrganizationService.Update method.

See Also

Concepts

Organization entities
Organization entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BusinessUnitNewsArticle (announcement) entity messages and methods

This entity represents an announcement associated with an organization. The schema name for this entity is BusinessUnitNewsArticle. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a news article. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a news article. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a news article. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of news articles. You can also call the RetrieveMultiple method.
UpdateRequest | Updates a news article. You can also call the IOrganizationService.Update method.

See Also

Reference

BusinessUnitNewsArticle (announcement) entity privileges

Concepts

Organization entities
Organization entity messages and methods
Organization entity attributes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Organization entity attributes

The following information is for the organization entity in a default, uncustomized installation of Microsoft Dynamics CRM. The schema name and early bound class for this entity is Organization.

In This Topic

Editable organization attributes

Attributes for internal use only

Editable organization attributes

The following table shows the attribute metadata for the organization entity. For a list of attributes that are for internal use only, see Internal Attributes.

Attribute Schema Name | Display Name | Type | Description
AcknowledgementTemplateId | Acknowledgement Template | Lookup | ID of the template to be used for acknowledgement when a user unsubscribes.
AllowAddressBookSyncs | Allow Address Book Synchronization | Boolean | Indicates whether background address book synchronization in Microsoft Office Outlook is allowed.
AllowAutoResponseCreation | Allow Automatic Response Creation | Boolean | Indicates whether automatic response creation is allowed.
AllowAutoUnsubscribe | Allow Automatic Unsubscribe | Boolean | Indicates whether automatic unsubscribe is allowed.
AllowAutoUnsubscribeAcknowledgement | Allow Automatic Unsubscribe Acknowledgement | Boolean | Indicates whether automatic unsubscribe acknowledgement email is allowed to be sent.
AllowClientMessageBarAd | Allow Outlook Client Message Bar Advertisement | Boolean | Indicates whether the Microsoft Dynamics CRM for Outlook message bar advertisement is allowed.
AllowEntityOnlyAudit | Allow Entity Level Auditing | Boolean | Indicates whether auditing of changes to an entity is allowed when no attributes have changed.
AllowMarketingEmailExecution | Allow Marketing Email Execution | Boolean | Indicates whether marketing emails execution is allowed.
AllowOfflineScheduledSyncs | Allow Offline Scheduled Synchronization | Boolean | Indicates whether background offline synchronization in Microsoft Office Outlook is allowed.
AllowOutlookScheduledSyncs | Allow Scheduled Synchronization | Boolean | Indicates whether scheduled synchronizations to Outlook are allowed.
AllowUnresolvedPartiesOnEmailSend | Allow Unresolved Address Email Send | Boolean | Indicates whether users are allowed to send email to unresolved parties (parties must still have an email address).
AllowUserFormModePreference | Allow User Form Mode Preference | Boolean | Indicates whether individuals can select their form mode preference in their personal options.
AllowUsersSeeAppdownloadMessage | Allow the showing tablet application notification bars in a browser. | Boolean | Indicates whether showing tablet application notification bars in a browser is allowed.
AllowWebExcelExport | Allow Export to Excel | Boolean | Indicates whether web-based export of grids to Microsoft Office Excel is allowed.
AMDesignator | AM Designator | String | AM designator to use throughout Microsoft Dynamics CRM.
BaseCurrencyId | Currency | Lookup | ID of the base currency of the organization.
BaseCurrencyPrecision | Base Currency Precision | Integer | Number of decimal places that can be used for the base currency.
BaseCurrencySymbol | Base Currency Symbol | String | Symbol used for the base currency.
BaseISOCurrencyCode | Base ISO Currency Code | String | Base ISO currency code.
BingMapsApiKey | Bing Maps API Key | String | API key to be used in requests to Bing Maps services.
BlockedAttachments | Block Attachments | String | Prevent upload or download of certain attachment types that are considered dangerous.
BulkOperationPrefix | Bulk Operation Prefix | String | Prefix used for bulk operation numbering.
BusinessClosureCalendarId | Business Closure Calendar | Unique identifier | ID of the business closure calendar of organization.
CalendarType | Calendar Type | Integer | Calendar type for the system. Set to Gregorian US by default.
CampaignPrefix | Campaign Prefix | String | Prefix used for campaign numbering.
CascadeStatusUpdate | Cascade Status Update | Boolean | Flag to cascade update on incident (case).
CasePrefix | Case Prefix | String | Prefix to use for all cases throughout Microsoft Dynamics CRM.
ContractPrefix | Contract Prefix | String | Prefix to use for all contracts throughout Microsoft Dynamics CRM.
CreatedBy | Created By | Lookup | ID of the user who created the organization.
CreatedOn | Created On | DateTime | Date and time when the organization was created.
CreatedOnBehalfBy | Created By (Delegate) | Lookup | ID of the delegate user who created the organization.
CreateProductsWithoutParentInActiveState | Enable Active Initial Product State | Boolean | Enable Initial state of newly created products to be Active instead of Draft.
CurrencyDecimalPrecision | Currency Decimal Precision | Integer | Number of decimal places that can be used for currency.
CurrencyDisplayOption | Display Currencies Using | Picklist | Indicates whether to display money fields with currency code or currency symbol.
CurrencyFormatCode | Currency Format Code | Picklist | Information about how currency symbols are placed throughout Microsoft Dynamics CRM.
CurrencySymbol | Currency Symbol | String | Symbol used for currency throughout Microsoft Dynamics CRM.
CurrentBulkOperationNumber | Current Bulk Operation Number | Integer | Current bulk operation number.
CurrentCampaignNumber | Current Campaign Number | Integer | Current campaign number.
CurrentCaseNumber | Current Case Number | Integer | First case number to use.
CurrentContractNumber | Current Contract Number | Integer | First contract number to use.
CurrentImportSequenceNumber | Current Import Sequence Number | Integer | Import sequence to use.
CurrentInvoiceNumber | Current Invoice Number | Integer | First invoice number to use.
CurrentKbNumber | Current Article Number | Integer | First article number to use.
CurrentOrderNumber | Current Order Number | Integer | First order number to use.
CurrentParsedTableNumber | Current Parsed Table Number | Integer | First parsed table number to use.
CurrentQuoteNumber | Current Quote Number | Integer | First quote number to use.
DateFormatCode | Date Format Code | Picklist | Information about how the date is displayed throughout Microsoft Dynamics CRM.
DateFormatString | Date Format String | String | String showing how the date is displayed throughout Microsoft Dynamics CRM.
DateSeparator | Date Separator | String | Character used to separate the month, the day, and the year in dates throughout Microsoft Dynamics CRM.
DecimalSymbol | Decimal Symbol | String | Symbol used for decimal in Microsoft Dynamics CRM.
DefaultCountryCode | Default Country/Region Code | String | Text area to enter the default country/region code.
DefaultEmailServerProfileId | Email Server Profile | Lookup | ID of the default email server profile.
DefaultEmailSettings | Default Email Settings | String | XML string containing the default email settings that are applied when a user or queue is created.
DefaultRecurrenceEndRangeType | Default Recurrence End Range Type | Picklist | Type of default recurrence end range date.
DisableSocialCare | Is Social Care disabled | Boolean | Indicates whether Social Care is disabled.
DisabledReason | Disabled Reason | String | Reason for disabling the organization.
DiscountCalculationMethod | Discount calculation method | Picklist | Discount calculation method for the QOOI product.
DisplayNavigationTour | Display Navigation Tour | Boolean | Indicates whether the navigation tour is displayed.
EmailConnectionChannel | Email Connection Channel | Picklist | Select if you want to use the Email Router or server-side synchronization for email processing.
EmailCorrelationEnabled | Use Email Correlation | Boolean | Flag to turn email correlation on or off.
EmailSendPollingPeriod | Email Send Polling Frequency | Integer | Normal polling frequency used for sending email in Microsoft Office Outlook.
EnableBingMapsIntegration | Enable Integration with Bing Maps | Boolean | Enable integration with Bing Maps.
EnablePricingOnCreate | Enable Pricing On Create | Boolean | Enable pricing calculations on a Create call.
EnableSmartMatching | Enable Smart Matching | Boolean | Use Smart Matching.
ExpireSubscriptionsInDays | Days to Expire Subscriptions | Integer | Maximum number of days before deleting inactive subscriptions.
FeatureSet | Feature Set | String | Features to be enabled as an XML BLOB.
FiscalCalendarStart | Fiscal Calendar Start | DateTime | Start date for the fiscal period that is to be used throughout Microsoft Dynamics CRM.
FiscalPeriodFormat | Fiscal Period Format | String | Information that specifies how the name of the fiscal period is displayed throughout Microsoft Dynamics CRM.
FiscalPeriodFormatPeriod | Format for Fiscal Period | Picklist | Format in which the fiscal period will be displayed.
FiscalPeriodType | Fiscal Period Type | Integer | Type of fiscal period used throughout Microsoft Dynamics CRM.
FiscalSettingsUpdated | Is Fiscal Settings Updated | Boolean | Information that specifies whether the fiscal settings have been updated.
FiscalYearDisplayCode | Fiscal Year Display | Integer | Information that specifies whether the fiscal year should be displayed based on the start date or the end date of the fiscal year.
FiscalYearFormat | Fiscal Year Format | String | Information that specifies how the name of the fiscal year is displayed throughout Microsoft Dynamics CRM.
FiscalYearFormatPrefix | Prefix for Fiscal Year | Picklist | Prefix for the display of the fiscal year.
FiscalYearFormatSuffix | Suffix for Fiscal Year | Picklist | Suffix for the display of the fiscal year.
FiscalYearFormatYear | Fiscal Year Format Year | Picklist | Format for the year.
FiscalYearPeriodConnect | Fiscal Year Period Connector | String | Information that specifies how the names of the fiscal year and the fiscal period should be connected when displayed together.
FullNameConventionCode | Full Name Display Order | Picklist | Order in which names are to be displayed throughout Microsoft Dynamics CRM.
FutureExpansionWindow | Future Expansion Window | Integer | Specifies the maximum number of months in future for which the recurring activities can be created.
GenerateAlertsForErrors | Generate Alerts For Errors | Boolean | Indicates whether alerts will be generated for errors.
GenerateAlertsForInformation | Generate Alerts For Information | Boolean | Indicates whether alerts will be generated for information.
GenerateAlertsForWarnings | Generate Alerts For Warnings | Boolean | Indicates whether alerts will be generated for warnings.
GetStartedPaneContentEnabled | Is Get Started Pane Content Enabled | Boolean | Indicates whether Get Started content is enabled for this organization.
GlobalAppendUrlParametersEnabled | Is AppendUrl Parameters enabled | Boolean | Indicates whether append help URL parameters is enabled.
GlobalHelpUrl | Global Help URL. | Boolean | URL for the global help web page.
GlobalHelpUrlEnabled | Is Customizable Global Help enabled | Boolean | Indicates whether the customizable global help is enabled.
GoalRollupExpiryTime | Rollup Expiration Time for Goal | Integer | Number of days after the goal's end date after which the rollup of the goal stops automatically.
GoalRollupFrequency | Automatic Rollup Frequency for Goal | Integer | Number of hours between automatic rollup jobs .
HashDeltaSubjectCount | Hash Delta Subject Count | Integer | Maximum difference allowed between subject keywords count of the email messaged to be correlated.
HashFilterKeywords | Hash Filter Keywords | String | Filter subject keywords.
HashMaxCount | Hash Max Count | Integer | Maximum number of subject keywords or recipients used for correlation.
HashMinAddressCount | Hash Min Address Count | Integer | Minimum number of recipients required to match for email messaged to be correlated
IgnoreInternalEmail | Ignore Internal Email | Boolean | Indicates whether incoming email sent by internal Microsoft Dynamics CRM users or queues should be tracked.
IncomingEmailExchangeEmailRetrievalBatchSize | Exchange Email Retrieval Batch Size | Integer | Setting for the Async Service Mailbox Queue. Defines the retrieval batch size of exchange server.
InitialVersion | Initial Version | String | Initial version of the organization.
IntegrationUserId | Integration User | Unique identifier | ID of the integration user for the organization.
InvoicePrefix | Invoice Prefix | String | Prefix to use for all invoice numbers throughout Microsoft Dynamics CRM.
IsAppMode | Is Application Mode Enabled | Boolean | Indicates whether loading of Microsoft Dynamics CRM in a browser window that does not have address, tool, and menu bars is enabled.
IsAppointmentAttachmentSyncEnabled | Is Attachment Sync Enabled |  | Indicates whether attachments sync for Microsoft Outlook and Exchange is enabled.
IsAssignedTasksSyncEnabled | Is Assigned Tasks Sync Enabled | Boolean | Indicates whether assigned tasks sync for Microsoft Outlook and Exchange is enabled.
IsAuditEnabled | Is Auditing Enabled | Boolean | Indicates whether auditing of changes is enabled.
IsAutoSaveEnabled | Auto Save Enabled | Boolean | Information on whether auto save is enabled.
IsContactMailingAddressSyncEnabled | Is Mailing Address Sync Enabled | Boolean | Indicates whether mailing address sync for Microsoft Outlook and Exchange is enabled.
IsDefaultCountryCodeCheckEnabled | Enable or disable country/region code selection | Boolean | Indicates whether country/region code selection is enabled.
IsDisabled | Is Organization Disabled | Boolean | Information that specifies whether the organization is disabled.
IsDuplicateDetectionEnabled | Is Duplicate Detection Enabled | Boolean | Indicates whether duplicate detection of records is enabled.
IsDuplicateDetectionEnabledForImport | Is Duplicate Detection Enabled For Import | Boolean | Indicates whether duplicate detection of records during import is enabled.
IsDuplicateDetectionEnabledForOfflineSync | Is Duplicate Detection Enabled For Offline Synchronization | Boolean | Indicates whether duplicate detection of records during offline synchronization is enabled.
IsDuplicateDetectionEnabledForOnlineCreateUpdate | Is Duplicate Detection Enabled for Online Create/Update | Boolean | Indicates whether duplicate detection during online create or update is enabled.
IsFiscalPeriodMonthBased | Is Fiscal Period Monthly | Boolean | Indicates whether the fiscal period is displayed as the month number.
IsHierarchicalSecurityModelEnabled | Enable Hierarchical Security Model | Boolean | Indicates whether the hierarchical security model is enabled.
IsMailboxInactiveBackoffEnabled | Is Mailbox Keep Alive Enabled | Boolean | Indicates whether mailbox keep alive for server side sync is enabled.
IsPresenceEnabled | Presence Enabled | Boolean | Information on whether IM presence is enabled.
IsSOPIntegrationEnabled | Is Sales Order Integration Enabled | Boolean | Enable sales order processing integration.
IsUserAccessAuditEnabled | Is User Access Auditing Enabled | Boolean | Enable or disable auditing of user access.
ISVIntegrationCode | ISV Integration Mode | Picklist | Indicates whether loading of Microsoft Dynamics CRM in a browser window that does not have address, tool, and menu bars is enabled.
KbPrefix | Article Prefix | String | Prefix to use for all articles in Microsoft Dynamics CRM.
LanguageCode | Language | Integer | Preferred language for the organization.
LocaleId | Locale | Integer | ID of the locale of the organization.
LongDateFormatCode | Long Date Format | Integer | Information that specifies how the Long Date format is displayed in Microsoft Dynamics CRM.
MaxAppointmentDurationDays | Max Appointment Duration | Integer | Maximum number of days an appointment can last.
MaximumActiveBusinessProcessFlowsAllowedPerEntity | Maximum active business process flows per entity | Integer | Maximum number of active business process flows allowed per entity
MaxDepthForHierarchicalSecurityModel | Maximum depth for hierarchy security propagation. | Integer | Maximum depth for hierarchy security propagation.
MaximumDynamicPropertiesAllowed | Product Properties Item Limit | Integer | Maximum number of product properties for a product family or bundle.
MaximumTrackingNumber | Max Tracking Number | Integer | Maximum tracking number before recycling takes place.
MaxProductsInBundle | Bundle Item Limit | Integer | Maximum number of items in a bundle.
MaxRecordsForExportToExcel | Max Records For Excel Export | Integer | Maximum number of records that will be exported to a static Microsoft Office Excel worksheet when exporting from the grid.
MaxRecordsForLookupFilters | Max Records Filter Selection | Integer | Maximum number of lookup and picklist records that can be selected by user for filtering.
MaxSupportedInternetExplorerVersion | Max supported IE version | Integer | The maximum version of Internet Explorer to run browser emulation for in CRM for Outlook.
MaxUploadFileSize | Max Upload File Size | Integer | Maximum allowed size of an attachment.
MetadataSyncLastTimeOfNeverExpiredDeletedObjects | The last date/time for never expired metadata tracking deleted objects | DateTime | What is the last date/time where there are metadata tracking deleted objects that have never been outside of the expiration period.
MetadataSyncTimestamp | Metadata sync version | BigInt | Contains the maximum version number for attributes used by metadata synchronization that have changed.
MinAddressBookSyncInterval | Min Address Synchronization Frequency | Integer | Normal polling frequency used for address book synchronization in Microsoft Office Outlook.
MinOfflineSyncInterval | Min Offline Synchronization Frequency | Integer | Normal polling frequency used for background offline synchronization in Microsoft Office Outlook.
MinOutlookSyncInterval | Min Synchronization Frequency | Integer | Minimum allowed time between scheduled Outlook synchronizations.
MobileClientMashupEnabled | Is Mobile Client Mashup enabled | Boolean | Indicates whether the mobile client mashup is enabled.
ModifiedBy | Modified By | Lookup | ID of the user who last modified the organization.
ModifiedOn | Modified On | DateTime | Date and time when the organization was last modified.
ModifiedOnBehalfBy | Modified By (Delegate) | Lookup | ID of the delegate user who last modified the organization.
Name | Organization Name | String | Name of the organization. The name is set when Microsoft Dynamics CRM is installed and should not be changed.
NegativeCurrencyFormatCode | Negative Currency Format | Integer | Information that specifies how negative currency numbers are displayed throughout Microsoft Dynamics CRM.
NegativeFormatCode | Negative Format | Picklist | Information that specifies how negative numbers are displayed throughout Microsoft Dynamics CRM.
NextCustomObjectTypeCode | Next Entity Type Code | Integer | Next entity type code to use for custom entities.
NextTrackingNumber | Next Tracking Number | Integer | Next token to be placed on the subject line of an email message.
NotifyMailboxOwnerOfEmailServerLevelAlerts | Notify Mailbox Owner Of Email Server Level Alerts | Boolean | Indicates whether mailbox owners will be notified of email server profile level alerts.
NumberFormat | Number Format | String | Specification of how numbers are displayed throughout Microsoft Dynamics CRM.
NumberGroupFormat | Number Grouping Format | String | Specifies how numbers are grouped in Microsoft Dynamics CRM.
NumberSeparator | Number Separator | String | Symbol used for number separation in Microsoft Dynamics CRM.
OOBPriceCalculationEnabled | Enable OOB Price calculation | Boolean | Enable out-of-the-box pricing calculation logic for the opportunity, quote, order and invoice entities.
OrderPrefix | Order Prefix | String | Prefix to use for all orders throughout Microsoft Dynamics CRM.
OrganizationId | Organization | Unique identifier | ID of the organization.
OrgDbOrgSettings | Organization Database Organization Settings | String | Organization settings stored in Organization Database.
ParsedTableColumnPrefix | Parsed Table Column Prefix | String | Prefix used for parsed table columns.
ParsedTablePrefix | Parsed Table Prefix | String | Prefix used for parsed tables.
PastExpansionWindow | Past Expansion Window | Integer | Specifies the maximum number of months in past for which the recurring activities can be created.
PinpointLanguageCode | Pinpoint Language Code | Integer | Language code to use for Pinpoint.
PMDesignator | PM Designator | String | PM designator to use throughout Microsoft Dynamics CRM.
PricingDecimalPrecision | Pricing Decimal Precision | Integer | Number of decimal places that can be used for prices.
PrivilegeUserGroupId | Privilege User Group | Unique identifier | ID of the default privilege for users in the organization.
QuickFindRecordLimitEnabled | Quick Find Record Limit Enabled | Boolean | Indicates whether a quick find record limit should be enabled for this organization (allows for faster Quick Find queries but prevents overly broad searches).
QuotePrefix | Quote Prefix | String | Prefix to use for all quotes throughout Microsoft Dynamics CRM.
RecurrenceDefaultNumberOfOccurrences | Recurrence Default Number of Occurrences | Integer | Specifies the default value for number of occurrences field in the recurrence dialog.
RecurrenceExpansionJobBatchInterval | Recurrence Expansion Job Batch Interval | Integer | Specifies the interval (in seconds) for pausing expansion job.
RecurrenceExpansionJobBatchSize | Recurrence Expansion On Demand Job Batch Size | Integer | Specifies the value for number of instances created in on demand job in one shot.
RecurrenceExpansionSynchCreateMax | Recurrence Expansion Synchronization Create Maximum | Integer | Specifies the maximum number of instances to be created synchronously after creating a recurring appointment.
ReferenceSiteMapXml | Reference SiteMap XML | String | XML string that defines the navigation structure for the application. This is the site map from the previously upgraded build and is used in a 3-way merge during upgrade.
RenderSecureIFrameForEmail | Render Secure Frame For Email | Boolean | Flag to render the body of email in the Web form in an IFRAME with the security='restricted' attribute set. This is additional security but can cause a credentials prompt.
ReportScriptErrors | Report Script Errors | Picklist | Picklist for selecting the organization preference for reporting scripting errors.
RequireApprovalForQueueEmail | Is Approval For Queue Email Required | Boolean | Indicates whether Send As Other User privilege is enabled.
RequireApprovalForUserEmail | Is Approval For User Email Required | Boolean | Indicates whether Send As Other User privilege is enabled.
RestrictStatusUpdate | Restrict Status Update | Boolean | Indicates whether to restrict update on incident.
SampleDataImportId | Sample Data Import | Unique identifier | ID of the sample data import job.
SchemaNamePrefix | Customization Name Prefix | String | Prefix used for custom entities and attributes.
ShareToPreviousOwnerOnAssign | Share To Previous Owner On Assign | Boolean | Information that specifies whether to share to previous owner on assign.
ShowWeekNumber | Show Week Number | Boolean | Information that specifies whether to display the week number in calendar displays throughout Microsoft Dynamics CRM.
SignupOutlookDownloadFWLink | CRMForOutlookDownloadURL | String | Specifies the Microsoft Dynamics CRM for Outlook download URL.
SiteMapXml | SiteMap XML | Memo | XML string that defines the navigation structure for the application.
SlaPauseStates | SLA pause states | String | Contains the on hold case status values.
SocialInsightsEnabled | Social Insights Enabled | Boolean | Indicates whether the organization is using social insights.
SocialInsightsInstance | Social Insights instance identifier | String | Identifier for the Social Insights instance for the organization.
SocialInsightsTermsAccepted | Social Insights Terms of Use | Boolean | Indicates whether the organization has accepted the Social Insights terms of use.
SQMEnabled | Is SQM Enabled | Boolean | Setting for SQM data collection, 0 no, 1 yes enabled
SupportUserId | Support User | Unique identifier | ID of the support user for the organization.
SuppressSLA | Is SLA suppressed | Boolean | Indicates whether SLA is suppressed.
SystemUserId | System User | Unique identifier | ID of the system user for the organization.
TagMaxAggressiveCycles | Auto-Tag Max Cycles | Integer | Maximum number of aggressive polling cycles executed for email auto-tagging when a new email is received.
TagPollingPeriod | Auto-Tag Interval | Integer | Normal polling frequency used for email receive auto-tagging in Outlook.
TimeFormatCode | Time Format Code | Picklist | Information that specifies how the time is displayed throughout Microsoft Dynamics CRM.
TimeFormatString | Time Format String | String | Text for how time is displayed in Microsoft Dynamics CRM.
TimeSeparator | Time Separator | String | Text for how the time separator is displayed throughout Microsoft Dynamics CRM.
TokenExpiry | Token Expiration Duration | Integer | Duration used for token expiration.
TokenKey | Token Key | String | Token key.
TrackingPrefix | Tracking Prefix | String | History list of tracking token prefixes.
TrackingTokenIdBase | Tracking Token Base | Integer | Base number used to provide separate tracking token identifiers to users belonging to different deployments.
TrackingTokenIdDigits | Tracking Token Digits | Integer | Number of digits used to represent a tracking token identifier.
UniqueSpecifierLength | Unique String Length | Integer | Number of characters appended to invoice, quote, and order numbers.
UserAccessAuditingInterval | User Authentication Auditing Interval | Integer | The interval at which user access is checked for auditing.
UseReadForm | Use Read-Optimized Form | Boolean | Indicates whether the read-optimized form should be enabled for this organization.
UserGroupId | User Group | Unique identifier | ID of the default group of users in the organization.
UseInbuiltRuleForDefaultPricelistSelection | Use Inbuilt Rule For Default Pricelist Selection | Boolean | Indicates whether to use the inbuilt rule for the default pricelist.
UsePositionHierarchy | Use position hierarchy | Boolean | Indicates whether to use position hierarchy.
UseSkypeProtocol | User Skype Protocol | Boolean | Indicates default protocol selected for organization.
UTCConversionTimeZoneCode | UTC Conversion Time Zone Code | Integer | Time zone code that was in use when the record was created.
V3CalloutConfigHash | V3 Callout Hash | String | Hash of the Microsoft Dynamics CRM 3.0 callout configuration file.
VersionNumber | Version Number | BigInt | Version number of the organization.
WeekStartDayCode | Week Start Day Code | Picklist | Designated first day of the week throughout Microsoft Dynamics CRM.
YammerGroupId | Yammer Group Id | Integer | Denotes the Yammer group ID.
YammerNetworkPermalink | Yammer Network Permalink | String | Denotes the Yammer network permalink
YammerOAuthAccessTokenExpired | Yammer OAuth Access Token Expired | Boolean | Denotes whether the OAuth access token for Yammer network has expired
YammerPostMethod | Internal Use Only | Picklist | For internal use only.
YearStartWeekCode | Year Start Week Code | Integer | Information that specifies how the first week of the year is specified in Microsoft Dynamics CRM.

Attributes for internal use only

The following table contains the attributes that are intended for internal use only.

Attribute logical name

EntityImageId

GrantAccessToNetworkService

Picture

PrivReportingGroupId

PrivReportingGroupName

ReportingGroupId

ReportingGroupName

SortId

SqlAccessGroupId

SqlAccessGroupName

TimeZoneRuleVersionNumber

YammerPostMethod

yammergroupid

yammernetworkpermalink

yammeroauthaccesstokenexpired

yammerpostmethod

See Also

Concepts

Organization entities
Organization entity messages and methods
Organization entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BusinessUnit entity

An organization in Microsoft Dynamics CRM, such as a holding company or a corporation, is made up of business units. A business unit is a unit of the top-level organization. Business units can be parents of other business units (child business units). The first business unit created for an organization is called the root business unit. Business units can be deleted, however, the root business unit can’t be deleted.

A parent business unit is any business unit with one or more business units that report to it in the hierarchy.

A child business unit is a business unit that is immediately under another business unit in the business hierarchy of an organization.

A business unit can own records as defined in the ownership type in the metadata definition for an entity. More information: Entity Ownership

You can call the WhoAmIRequest message to find out the business unit for the currently logged on or impersonated user.

See Also

Reference

BusinessUnit entity privileges

Concepts

BusinessUnit entity messages and methods
User and team entities

Other Resources

Administration and security entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BusinessUnit entity messages and methods

This entity represents a business, division, or department in the Microsoft Dynamics CRM database. The schema name for this entity is BusinessUnit. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to BusinessUnit entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a business unit. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a business unit. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the BusinessUnit entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieve a business unit. You can also call the IOrganizationService.Retrieve method.
RetrieveBusinessHierarchyBusinessUnitRequest | Retrieves all the business units in the business unit hierarchy.
RetrieveMultipleRequest | Retrieves a collection of business units. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveSubsidiaryTeamsBusinessUnitRequest | Deprecated. Use the RetrieveMultipleRequest class. Retrieves all the team information for child business units of the specified business unit.
RetrieveSubsidiaryUsersBusinessUnitRequest | Deprecated. Use the RetrieveMultipleRequest class. Retrieves all system users for the child business units of the specified business unit.
SetParentBusinessUnitRequest | Sets the parent business unit.
SetStateRequest | Sets the state of a business unit.
UpdateRequest | Updates a business unit. You can also call the IOrganizationService.Update method.

See Also

Reference

BusinessUnit entity privileges

Concepts

BusinessUnit entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


User and team entities

User and team management is the area of Microsoft Dynamics CRM where you can create and maintain user accounts and profiles.

A user is any person who works for a business unit who uses Microsoft Dynamics CRM. Each user has a user account. All users must be associated with only one business unit. This association controls which customer data the user will have access to. Included in the user's account is information such as the user's telephone numbers, email address, and a link to the user's manager. Each user has privileges and rights to manage their own personal settings. Each user corresponds to a user in the Active Directory for that organization. When you create a user, you must assign the user to at least one security role. Even if the user is part of a team that has assigned roles, the user should be assigned to a role. For more information about access levels and roles, see How role-based security can be used to control access to entities in Microsoft Dynamics CRM.

A team is a group of users. Teams let users across an organization collaborate and share information. For more information about teams, see Use access teams and owner teams to collaborate and share information.

Records can be owned by users or teams. Set the OwnershipType to OwnershipTypes.UserOwned or OwnershipTypes.TeamOwned to enable ownership. You can use the ReassignObjectsOwnerRequest message or the ReassignObjectsSystemUserRequest message to do bulk reassignment of all records for an owner.

The following illustration shows the entity relationships for users and teams.

User and team entity relationship diagram

Users

In Microsoft Dynamics CRM, users can be disabled but they cannot be deleted. To find the user who is currently logged on or who is impersonated, call the WhoAmIRequest message.

The following table provides details about the significant attributes for the system user entity.

Attribute name Description

AccessMode

Specifies the type of access that this user has to Microsoft Dynamics CRM. This is sometimes referred to as the type of user.

  • Administrative – The user has access to the Settings area but does not have access to the Sales, Marketing, and Service areas.
  • Non-Interactive – The user can access the system but only through the Web service.
  • Read – The user has read-only access.
  • Read-Write – The user has both read and write access.
  • Support User – The user was created by the Microsoft Dynamics support team.

CalType

Specifies the user’s license type.

  • Administrative – The user has administrative user rights.
  • Device Full – The user who is using the device running Microsoft Dynamics CRM has both read and write access.
  • Device Limited – The user who is using the device running Microsoft Dynamics CRM has only read access.
  • Full – The user has both read and write access.
  • Limited – The user has only read access.

IsDisabled

Specifies whether the user is disabled. Only licensed users or users who have an access mode of support or non-interactive can be enabled. Support users cannot be disabled.

IsLicensed

Specifies whether the user is licensed. This applies to customers who access Microsoft Dynamics CRM Online through the Microsoft Online Services environment. This attribute is read-only, and is updated by the system.

IsSyncWithDirectory

Specifies whether the user is synchronized with the Office 365 directory. This applies to customers who access Microsoft Dynamics CRM Online through the Microsoft Online Services environment. This attribute can only be set on create and is otherwise read-only.

QueueId

Specifies the default queue for the user.

Access checks are additive. You can access entities based on the roles assigned to the user plus the roles assigned to the team that a user is a member of. This allows a user to have privileges outside their business unit.

Note
A user's set of privileges is a union of privileges from the user's roles and privileges from all teams’ roles in which the user is a member.

For more information about how users are provisioned in and synchronized with Microsoft Office 365, see Synchronized users in Microsoft Dynamics CRM Online and Office 365.

Non-interactive users are often used when writing service-to-service code because they do not use up a license. Microsoft Dynamics CRM Online allows for five free non-interactive users. To disable a non-interactive user, update the user record changing the accessmode value to any other value. The user will be disabled automatically.

See Also

Concepts

Synchronized users in Microsoft Dynamics CRM Online and Office 365
Use access teams and owner teams to collaborate and share information
Team entity messages and methods
TeamTemplate entity messages and methods
SystemUser (user) entity messages and methods
UserSettings entity messages and methods
Privilege and role entities

Other Resources

Administration and security entities
Sample: Assign a record to a team
Sample: Create an on-premises user
Sample: Disable a user
Sample: Share records using GrantAccess, ModifyAccess and RevokeAccess messages
Blog: Service Accounts – Non-Interactive Users

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use access teams and owner teams to collaborate and share information

With owner teams or access teams, you can easily share business objects and collaborate with the users across business units in Microsoft Dynamics CRM. A team belongs to one business unit, but it can include users from other business units. A user can be associated with more than one team.

An owner team owns records and has security roles assigned to the team. The team’s privileges are defined by these security roles. In addition to privileges provided by the team, team members have the privileges defined by their individual security roles and by the roles from other teams in which they are members. A team has full access rights on the records that the team owns.

An access team doesn’t own records and doesn’t have security roles assigned to the team. The team members have privileges defined by their individual security roles and by roles from the teams in which they are members. The records are shared with an access team and the team is granted access rights on the records, such as Read, Write or Append.

The team functionality is supported by the Team entity and the TeamTemplate entity. The Team entity is used to create owner teams and user-created access teams. For auto-created access teams, the Team entity and the TeamTemplate entity are used.

In This Topic

Owner team or access team?

Setting up teams

Quick reference to teams

Owner team or access team?

Choosing the type of the team may depend on the goals, nature of the project, and even the size of your organization. There are a few guidelines that you can use when choosing the team type.

When to use owner teams

  • Owning records by entities other than users is required by your company’s business policies.
  • The number of teams is known at the design time of your Microsoft Dynamics CRM system.
  • Daily reporting on progress by owning teams is required.

When to use access teams

  • The teams are dynamically formed and dissolved. This typically happens if the clear criteria for defining the teams, such as established territory, product, or volume aren’t provided.
  • The number of teams isn’t known at the design time of your Microsoft Dynamics CRM system.
  • The team members require different access rights on the records. You can share a record with several access teams, each team providing different access rights on the record. For example, one team is granted the Read access right on the account and another team, the Read, Write and Share access rights on the same account.
  • A unique set of users requires access to a single record without having an ownership of the record.

Setting up teams

In addition to owner and access team types, the access teams are further subdivided into user-created and auto-created (system-managed) teams. The setup information is specific to each team type.

Owner team

An owner team can own multiple records. To create an owner team, use the Team entity and set the Team.TeamType attribute to Owner. For a list of the TeamType values, refer to the Team entity metadata.

Note
To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

To make a team an owner of the record, you have to assign a record to the team. To assign, use the AssignRequest message. To assign records to an owner team in bulk, use the ReassignObjectsOwnerRequest message or the ReassignObjectsSystemUserRequest message.

A record owned by the team must have the OwnershipType property set to OwnershipTypes.TeamOwned.

If an owner team doesn’t own records and doesn’t have security roles assigned to the team, it can be converted to an access team, by using the ConvertOwnerTeamToAccessTeamRequest message. It is a one way conversion. You can’t convert the access team back to the owner team. During conversion, all queues and mailboxes associated with the team are deleted.

To add or remove team members, use the AddMembersTeamRequest message and the RemoveMembersTeamRequest message.

User-created access team

You can share multiple records with a user-created access team. To create an access team, use the team entity and set the Team.TeamType attribute to Access. For a list of the TeamType values, refer to the Team entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

To share a record with the user-created access team, use the GrantAccessRequest message. For user-created teams, the Team.SystemManaged attribute is false. For a list of the Team.SystemManaged values, refer to the Team entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

To add or remove team members, use the AddMembersTeamRequest message and the RemoveMembersTeamRequest message.

To provide the team members with different access rights on the records, create several teams and grant each team a different set of access rights on the records.

Auto-created (system-managed) access team

An auto-created (system-managed) team is created for a specific record and can’t be shared with other records. For system-managed teams, you have to provide a team template. To create a template, use the team template entity. In the template, you have to specify the entity type and the access rights on the entity record, such as Read or Write that are granted to the team users when the team is created. The entity that you specify in the template must be enabled for auto created access teams. To provide the team members with different access rights on the record, create several team templates. For example, for the account entity, provide one template with the Read access right for team that only needs to view the record. Provide a second template with the Read, Write and Share access rights, for team that require more access to the same record.

To enable an entity for the auto-created access teams, set the AutoCreateAccessTeams attribute to true.

A maximum number of team templates that you can create for an entity is specified in the MaxAutoCreatedAccessTeamsPerEntity deployment setting. The default value is 2. A maximum number of entities that you can enable for auto created access teams is specified in the MaxEntitiesEnabledForAutoCreatedAccessTeams deployment setting. The default value is 5. More information: Deployment entities and deployment configuration settings and Administer the deployment using Windows PowerShell

The users are automatically added and removed in the system-managed team, when you add or remove the users in a particular record by using the AddUserToRecordTeamRequest message and the RemoveUserFromRecordTeamRequest message. The actual team is created when you add the first user to the record and the team ID is returned in AccessTeamId. The Team.SystemManaged attribute for this team is set to true. For a list of the Team.SystemManaged values, refer to the Team entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information. The caller of the message must have the Share privilege on the entity and the access rights on the record that match the access rights provided in the template. For example, if the template specifies the Read access rights, the calling user must have the Read access rights on the record. To be added to the team, a minimum access level a user must have on the entity specified in the template is Basic (User) Read.

Because of the parental relation between the team template and system-managed access teams, when you delete a template, all teams associated with the template are deleted according to the cascading rules.

If you change access rights for the team template, the changes are only applied to the new auto-created access teams. The existing teams aren’t affected.

Quick reference to teams

Use the following information as a quick reference to the available teams.

Team | When to use? | What entity to use? | Use team template? | What messages to use to add or remove team members? | Owns records? | How many records owns or has access to? | Has security roles assigned?
Owner | Record ownership by the team is required. The number of teams is known at the design time. | Team | No | AddMembersTeamRequest RemoveMembersTeamRequest. | Yes | Can own multiple records. | Yes
Access, user-created | Multiple records have to be shared with the team. The number of teams isn’t known at design time. Team members require different access rights on the records. | Team | No | AddMembersTeamRequest RemoveMembersTeamRequest | No | Can access multiple records. | No. Provides access rights on the record.
Access, auto-created (system-managed) | Unique set of users works on a single record. Team members require different access rights on the records. Creating teams automatically per record is desirable. | TeamTemplate Team | Yes | AddUserToRecordTeamRequest RemoveUserFromRecordTeamRequest | No | Can access only one record. | No. Provides access rights on the record.

Note
Owner teams and access teams provide access rights to the record and related records, such as to an account and all opportunities related to this account. In case of parental relationship between the records, cascading rules are applied. For the owner teams, you can access entities based on the roles assigned to the user plus the roles assigned to the team that a user is a member of. This allows a user to have privileges outside their business unit. More information: Entity relationship behavior

Note
A user must have sufficient privileges to join an access team. For example, if the access team has the Delete access right on an account, the user must have the Delete privilege on the Account entity to join the team. If you’re trying to add a user with insufficient privileges, you’ll see this error message: “You can’t add the user to the access team because the user doesn’t have sufficient privileges on the entity.”

See Also

Reference

Cascading Behavior

Concepts

User and team entities
Team entity messages and methods
TeamTemplate entity messages and methods
How record-based security can be used to control access to records in Microsoft Dynamics CRM
How role-based security can be used to control access to entities in Microsoft Dynamics CRM

Other Resources

Whitepaper: Access Teams with Microsoft Dynamics CRM 2013
Whitepaper: Scalable security modeling with Microsoft Dynamics CRM 2013
TechNet: Administer the deployment using Windows PowerShell

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Team entity messages and methods

A team is a group of users. Individual users are called team members. A team reports to a business unit and team members may be from different business units. Creating a team gives greater flexibility for sharing business objects and collaboration. A team can own records or the records can be shared with the team. The schema name for this entity is Team. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddMembersTeamRequest | Adds members to a team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Team entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
ConvertOwnerTeamToAccessTeamRequest | Converts a team of an owner type to a team of an access type.
CreateRequest | Creates a team. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a team. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Team entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RemoveMembersTeamRequest | Removes members from a team.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a team. You can also call the IOrganizationService.Retrieve method.
RetrieveMembersTeamRequest | Deprecated. Use the RetrieveMultipleRequest class and its members. Retrieves the members of a team.
RetrieveMultipleRequest | Retrieves a collection of teams. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAttributePrivilegesRequest | Retrieves all the secured attribute privileges that a user or team has through direct or indirect team membership associations with the FieldSecurityProfile entity.
RetrieveTeamPrivilegesRequest | Retrieves the privileges for a team.
SetParentTeamRequest | Sets the parent business unit for a team.
UpdateRequest | Updates a team. You can also call the IOrganizationService.Update method.

See Also

Concepts

User and team entities
Use access teams and owner teams to collaborate and share information
Team entity privileges
TeamTemplate entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TeamTemplate entity messages and methods

A team template is used for auto-created (system-managed) access teams. The schema name for this entity is TeamTemplate. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddUserToRecordTeamRequest | Adds a user to the automatically created access team.
CreateRequest | Creates a team template. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a team template. You can also call the IOrganizationService.Delete method. Because of a parental relationship between the team template and system-managed access teams, when you delete a template, all teams associated with the template are deleted according to the cascading rules.
RemoveUserFromRecordTeamRequest | Removes a user from the automatically created access team.
RetrieveRequest | Retrieves a team template. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of team templates. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a team template. You can also call the IOrganizationService.Update method.

See Also

Reference

TeamTemplate entity privileges
Cascading Behavior

Concepts

User and team entities
Use access teams and owner teams to collaborate and share information
SystemUser (user) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SystemUser (user) entity messages and methods

A system user is a person who has access to sign in to on-premises Microsoft Dynamics CRM or Microsoft Dynamics CRM Online. Managing system users involves many different activities. That includes adding system users, setting security roles, and placing system users into a reporting hierarchy. Access to each of these features is protected by what security privileges that the system user has. These privileges are based on the system user's security role. A system user profile must be created and saved before the system user can be assigned security roles or associated with teams. The schema name for this entity is SystemUser. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

A Dynamics CRM system user account can be either enabled or disabled. Dynamics CRM allows only enabled system users with a paid license to sign in to the application.

An enabled system user's account can be set to disabled to keep historical information, such as the account of a salesperson that has left the company. Set a system user account to disabled to remove that user from workflow processes, such as during vacations. Disabling a system user adds to the available license count, as disabled system users do not count against paid licenses.

Note
To create an instance of a system user entity in an on-premises instance of Microsoft Dynamics CRM, the system user must first exist in Active Directory.

To create an instance of a system user entity in Microsoft Dynamics CRM Online, the user’s Microsoft account must already exist. In addition, there is no programmatic way to send an invitation to a user for Microsoft Dynamics CRM Online. You must send user invitations through the web application.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see SystemUser entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a system user. You can also call the IOrganizationService.Create method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see SystemUser entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
ReassignObjectsSystemUserRequest | Reassigns all entities owned by the specified system user to another system user or team.
RetrieveRequest | Retrieves a system user. You can also call the IOrganizationService.Retrieve method.
RemoveParentRequest | Removes the parent for a record.
RetrieveAllChildUsersSystemUserRequest | Retrieves the collection of system users who report to the specified system user.
RetrieveMultipleRequest | Retrieves a collection of system users. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAttributePrivilegesRequest | Retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity.
RetrieveTeamsSystemUserRequest | Deprecated. Use the RetrieveMultipleRequest class. Retrieves the collection of teams of which the specified system user is a member.
RetrieveUserPrivilegesRequest | Retrieves all the privileges a system user (user) has through his or her roles in the specified business unit.
RetrieveUserSettingsSystemUserRequest | Deprecated. Use the RetrieveMultipleRequest class. Retrieves the system user settings for the specified system user.
SetBusinessSystemUserRequest | Sets the business unit for the specified system user.
SetParentSystemUserRequest | Sets the parent (manager) for the specified system user.
SetStateRequest | Sets the state of a system user. The possible states are defined in the SystemUser.Statecode attribute. If you are using early bound types, use the SystemUserState enumeration. For a list of the state values, see SystemUser entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a system user. You can also call the IOrganizationService.Update method.
UpdateUserSettingsSystemUserRequest | Deprecated. Use the UpdateRequest class. Updates the system user settings for a system user.

See Also

Concepts

User and team entities
SystemUser (user) entity privileges
UserSettings entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserSettings entity messages and methods

This entity represents the application settings for a user. The schema name for this entity is UserSettings. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see UserSettings entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see UserSettings entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a user settings record. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of user settings. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveUserSettingsSystemUserRequest | Deprecated. Retrieves the user settings for the specified user. Use RetrieveRequest.
UpdateRequest | Updates a user settings record. You can also call the IOrganizationService.Update method.
UpdateUserSettingsSystemUserRequest | Deprecated. Updates the user settings for a system user. Use UpdateRequest.

See Also

Concepts

User and team entities
UserSettings entity privileges

Other Resources

Sample: Assign a record to a team

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create an on-premises user
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\UsersAndRoles\CreateAUser.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a user in an Active Directory environment using the IOrganizationService.Create method. A snippet showing just the key sections of the sample is shown first, followed by the Complete Sample Code.

Example

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy is properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Retrieve the default business unit needed to create the user.
    QueryExpression businessUnitQuery = new QueryExpression
    {
        EntityName = BusinessUnit.EntityLogicalName,
        ColumnSet = new ColumnSet("businessunitid"),
        Criteria =
        {
            Conditions =
    {
        new ConditionExpression("parentbusinessunitid",
            ConditionOperator.Null)
    }
        }
    };

    BusinessUnit defaultBusinessUnit = _serviceProxy.RetrieveMultiple(
        businessUnitQuery).Entities[0].ToEntity<BusinessUnit>();

    //Create a new system user.
    SystemUser user = new SystemUser
    {
        DomainName = _domain + _userName,
        FirstName = _firstName,
        LastName = _lastName,
        BusinessUnitId = new EntityReference
        {
            LogicalName = BusinessUnit.EntityLogicalName,
            Name = BusinessUnit.EntityLogicalName,
            Id = defaultBusinessUnit.Id
        }
    };

    Guid userId = _serviceProxy.Create(user);

    Console.WriteLine("Created a system user {0} for '{1}, {2}'", userId, _lastName, _firstName);
}

Complete Sample Code

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do basic entity operations like create
    /// a system user account.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class CreateAUser
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private String _domain = String.Empty;
        private String _userName = "dparker";
        private String _firstName = "Darren";
        private String _lastName = "Parker";
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// it creates a system user account with a given active directory account.
        /// Note: Creating a user is only supported in an on-premises/active directory environment.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy is properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Retrieve the default business unit needed to create the user.
                    QueryExpression businessUnitQuery = new QueryExpression
                    {
                        EntityName = BusinessUnit.EntityLogicalName,
                        ColumnSet = new ColumnSet("businessunitid"),
                        Criteria =
                        {
                            Conditions =
                    {
                        new ConditionExpression("parentbusinessunitid",
                            ConditionOperator.Null)
                    }
                        }
                    };

                    BusinessUnit defaultBusinessUnit = _serviceProxy.RetrieveMultiple(
                        businessUnitQuery).Entities[0].ToEntity<BusinessUnit>();

                    //Create a new system user.
                    SystemUser user = new SystemUser
                    {
                        DomainName = _domain + _userName,
                        FirstName = _firstName,
                        LastName = _lastName,
                        BusinessUnitId = new EntityReference
                        {
                            LogicalName = BusinessUnit.EntityLogicalName,
                            Name = BusinessUnit.EntityLogicalName,
                            Id = defaultBusinessUnit.Id
                        }
                    };

                    Guid userId = _serviceProxy.Create(user);

                    Console.WriteLine("Created a system user {0} for '{1}, {2}'", userId, _lastName, _firstName);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // For this sample, all required entities are created in the Run() method.
            // Obtain the current user's information.
            WhoAmIRequest who = new WhoAmIRequest();
            WhoAmIResponse whoResp = (WhoAmIResponse)_serviceProxy.Execute(who);
            Guid currentUserId = whoResp.UserId;

            SystemUser currentUser =
                _serviceProxy.Retrieve(SystemUser.EntityLogicalName,
                currentUserId,
                new ColumnSet("domainname")).ToEntity<SystemUser>();

            // Extract the domain and create the LDAP object.
            String[] userPath = currentUser.DomainName.Split(new char[] { '\\' });
            if (userPath.Length > 1)
                _domain = userPath[0] + "\\";
            else
                _domain = String.Empty;

            SystemUser existingUser = SystemUserProvider.GetUserIdIfExist(_serviceProxy,
                _domain, _userName, _firstName, _lastName);

            if(existingUser != null)
                throw new Exception("User already exist!");

            // Set up an Active Directory account in the current domain for this sample.
            String ldapPath = String.Empty;
            Boolean accountSetup = SystemUserProvider.CreateADAccount(_userName,
                _firstName, _lastName, _serviceProxy, ref ldapPath);
            if (accountSetup)
                Console.WriteLine("An AD account created for '{0}, {1}'", _lastName, _firstName);
            else
                Console.WriteLine("AD account already exist for '{0}, {1}'", _lastName, _firstName);
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateAUser app = new CreateAUser();
                app.Run( config, true );
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

User and team entities
Synchronized users in Microsoft Dynamics CRM Online and Office 365

Other Resources

Helper code: ServerConnection class
Sample: Disable a user

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Disable a user
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\UsersAndRoles\DisableOREnableUser.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a user in an Active Directory environment using the SetStateRequest message. A snippet showing just the key sections of the sample is shown first, followed by the complete sample code. Note that this sample can only be run in an on-premises environment because it creates a user. However, the portion of the sample that demonstrates disabling the user will work for all environments.

Example

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy is properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Retrieve a user.
    SystemUser user = _serviceProxy.Retrieve(SystemUser.EntityLogicalName,
        _userId, new ColumnSet(new String [] {"systemuserid", "firstname", "lastname"})).ToEntity<SystemUser>();

    if (user != null)
    {
        Console.WriteLine("{1} {0} user account is retrieved.", user.LastName, user.FirstName);
        SetStateRequest request = new SetStateRequest() {
            EntityMoniker = user.ToEntityReference(),
            // Sets the user to disabled.
            State = new OptionSetValue(1),
            // Required by request but always valued at -1 in this context.
            Status = new OptionSetValue(-1)
            /*
            //Sets the user to enabled.
            State = new OptionSetValue(0),
            // Required by request but always valued at -1 in this context.
            Status = new OptionSetValue(-1)
            */
        };

        _serviceProxy.Execute(request);

        Console.WriteLine("User account is disabled.");
    }
    DeleteRequiredRecords(promptforDelete);
}

Complete sample code

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do disable/enable a system user account.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to revert the role
    /// association created by this program.</remarks>
    public class DisableOrEnableUser
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _userId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards, it
        /// creates/retrieves a system user, and
        /// updates the system user to disable/enable the user account.
        /// Note: Creating a user is only supported
        /// in an on-premises/active directory environment.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy is properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Retrieve a user.
                    SystemUser user = _serviceProxy.Retrieve(SystemUser.EntityLogicalName,
                        _userId, new ColumnSet(new String [] {"systemuserid", "firstname", "lastname"})).ToEntity<SystemUser>();

                    if (user != null)
                    {
                        Console.WriteLine("{1} {0} user account is retrieved.", user.LastName, user.FirstName);
                        SetStateRequest request = new SetStateRequest() {
                            EntityMoniker = user.ToEntityReference(),
                            // Sets the user to disabled.
                            State = new OptionSetValue(1),
                            // Required by request but always valued at -1 in this context.
                            Status = new OptionSetValue(-1)
                            /*
                            //Sets the user to enabled.
                            State = new OptionSetValue(0),
                            // Required by request but always valued at -1 in this context.
                            Status = new OptionSetValue(-1)
                            */
                        };

                        _serviceProxy.Execute(request);

                        Console.WriteLine("User account is disabled.");
                    }
                    DeleteRequiredRecords(promptforDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // For this sample, all required entities are created in the Run() method.
            // Retrieve a user.
            _userId = SystemUserProvider.RetrieveAUserWithoutAnyRoleAssigned(_serviceProxy);
        }

        /// <summary>
        /// Deletes/reverts any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete/revert the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.Write("\nDo you want these entity records deleted/reverted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                SetStateRequest request = new SetStateRequest()
                {
                    EntityMoniker = new EntityReference(SystemUser.EntityLogicalName,
                        _userId),
                    //sets the user to enabled
                    State = new OptionSetValue(0),
                    // required by request but always valued at -1 in this context
                    Status = new OptionSetValue(-1)
                };
                _serviceProxy.Execute(request);
                Console.WriteLine("User account is enabled back again.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DisableOrEnableUser app = new DisableOrEnableUser();
                app.Run( config, true );
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

User and team entities
Synchronized users in Microsoft Dynamics CRM Online and Office 365

Other Resources

Helper code: ServerConnection class
SetStateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Privilege and role entities

A privilege is a permission to perform an action on a specific entity type in Microsoft Dynamics CRM. The platform checks for the privilege and fails if the user does not hold the privilege. A privilege has an associated access level that determines the depth within the organization to which the privilege applies.

A role, or security role, is a grouping of security privileges. Users are assigned roles that authorize their access to CRM. A user must be assigned to at least one role. It isn’t sufficient to be a member of a team that has an assigned role.

For more information about access levels and roles, see How role-based security can be used to control access to entities in Microsoft Dynamics CRM.

The following illustration shows the entity relationships for this area. More information: Key to entity diagrams

Privilege and role entity relationship diagram

See Also

Concepts

Role (security role) entity messages and methods
Privilege entity messages and methods

Other Resources

Sample: Associate a security role to a team
Sample: Associate a Security Role to a User
Sample: Determine whether a user has a role
Sample: Remove a role for a user
Sample: Retrieve the roles for an organization
Administration and security entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Role (security role) entity messages and methods

A role represents a grouping of security privileges. Users are assigned roles that authorize their access to Microsoft Dynamics CRM. The schema name for this entity is Role. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddPrivilegesRoleRequest | Adds a set of existing privileges to an existing role.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Role entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a role. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a role. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService. Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Role entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RemovePrivilegeRoleRequest | Removes a privilege from a role.
ReplacePrivilegesRoleRequest | Replaces the privilege set of an existing role. This effectively deletes all existing privileges from the role and adds the new specified privileges.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a role. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of roles. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveRolePrivilegesRoleRequest | Retrieves the privileges that are assigned to the specified role.
UpdateRequest | Updates a role. You can also call the IOrganizationService.Update method.

See Also

Concepts

How role-based security can be used to control access to entities in Microsoft Dynamics CRM
Privilege and role entities
Privilege entity messages and methods
Role (security role) entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Privilege entity messages and methods

A privilege is a permission to perform an action in Microsoft Dynamics CRM. The platform checks for the privilege. It fails if the user does not hold the privilege.

Microsoft Dynamics CRM contains a complete set of privileges for all entities, including custom entities. Privileges cannot be added to the system except that when a custom entity is added, generated custom entity privileges are added for that entity. When a custom entity is deleted, the corresponding privileges are deleted also.

For more information, see Security role and privilege reference. The schema name for this entity is Privilege. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a privilege. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of privileges. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrivilegeSetRequest | Retrieves the set of privileges defined in the system.
RetrieveUserPrivilegesRequest | Retrieves the set of privileges for a user. Use the RetrieveMultipleRequest method instead.

See Also

Concepts

How role-based security can be used to control access to entities in Microsoft Dynamics CRM
Privilege and role entities
Role (security role) entity messages and methods
Privilege entity privileges

Other Resources

Sample: Associate a security role to a team

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Associate a security role to a team
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\AssignSecurityRoleToTeam.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to assign a security role to a team by using the AssignRequest message. Note that this example does not take into consideration that a team or user can only be assigned a role from its business unit. The role to be assigned is the first from the collection that is returned by the RetrieveMultiple method. If that record is from a business unit that is different from the requesting team, the assignment fails.

Example

C# Copy Code

// Retrieve a role from CRM.
QueryExpression query = new QueryExpression
{
    EntityName = Role.EntityLogicalName,
    ColumnSet = new ColumnSet("roleid"),
    Criteria = new FilterExpression
    {
        Conditions =
    {
        // You would replace the condition below with an actual role
        // name, or skip this query if you had a role id.
        new ConditionExpression
        {
            AttributeName = "name",
            Operator = ConditionOperator.Equal,
            Values = {_roleName}
        }
    }
    }
};

Role role = _service.RetrieveMultiple(query).Entities.
    Cast<Role>().First();

// Add the role to the team.
_service.Associate(
       Team.EntityLogicalName,
       _teamId,
       new Relationship("teamroles_association"),
       new EntityReferenceCollection() { new EntityReference(Role.EntityLogicalName, _roleId) });

Console.WriteLine("Assigned role to team");

See Also

Reference

Assign

Concepts

Privilege and role entities
User and team entities

Other Resources

Sample: Associate a Security Role to a User
AssignRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Associate a Security Role to a User
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\UsersAndRoles\AddRoleToUser.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to associate a role with a user by using the IOrganizationService.Associate method. A snippet showing just the key portions of the sample is shown first, followed by the Complete Sample Code. Note that this sample can only be run in an on-premises environment because it creates a user. However, the section of the sample that demonstrates associating a role with a user will work for all environments.

Example

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy is properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Find the role.
    QueryExpression query = new QueryExpression
    {
        EntityName = Role.EntityLogicalName,
        ColumnSet = new ColumnSet("roleid"),
        Criteria = new FilterExpression
        {
            Conditions =
                {

                    new ConditionExpression
                    {
                        AttributeName = "name",
                        Operator = ConditionOperator.Equal,
                        Values = {_givenRole}
                    }
                }
        }
    };

    // Get the role.
    EntityCollection roles = _serviceProxy.RetrieveMultiple(query);
    if (roles.Entities.Count > 0)
    {
        Role salesRole = _serviceProxy.RetrieveMultiple(query).Entities[0].ToEntity<Role>();

        Console.WriteLine("Role {0} is retrieved for the role assignment.", _givenRole);

        _roleId = salesRole.Id;

        // Associate the user with the role.
        if (_roleId != Guid.Empty && _userId != Guid.Empty)
        {
            _serviceProxy.Associate(
                        "systemuser",
                        _userId,
                        new Relationship("systemuserroles_association"),
                        new EntityReferenceCollection() { new EntityReference(Role.EntityLogicalName, _roleId) });

            Console.WriteLine("Role is associated with the user.");
        }
    }

    DeleteRequiredRecords(promptforDelete);
}

Complete Sample Code

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do basic role association with the system user.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to revert the role
    /// association created by this program.</remarks>
    public class AddRoleToUser
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _userId;
        private Guid _roleId;
        private String _givenRole = "salesperson";
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// creates/retrieves a system user,
        /// updates the system user to associate with the salesperson role.
        /// Note: Creating a user is only supported
        /// in an on-premises/active directory environment.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user is prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy is properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Find the role.
                    QueryExpression query = new QueryExpression
                    {
                        EntityName = Role.EntityLogicalName,
                        ColumnSet = new ColumnSet("roleid"),
                        Criteria = new FilterExpression
                        {
                            Conditions =
                                {

                                    new ConditionExpression
                                    {
                                        AttributeName = "name",
                                        Operator = ConditionOperator.Equal,
                                        Values = {_givenRole}
                                    }
                                }
                        }
                    };

                    // Get the role.
                    EntityCollection roles = _serviceProxy.RetrieveMultiple(query);
                    if (roles.Entities.Count > 0)
                    {
                        Role salesRole = _serviceProxy.RetrieveMultiple(query).Entities[0].ToEntity<Role>();

                        Console.WriteLine("Role {0} is retrieved for the role assignment.", _givenRole);

                        _roleId = salesRole.Id;

                        // Associate the user with the role.
                        if (_roleId != Guid.Empty && _userId != Guid.Empty)
                        {
                            _serviceProxy.Associate(
                                        "systemuser",
                                        _userId,
                                        new Relationship("systemuserroles_association"),
                                        new EntityReferenceCollection() { new EntityReference(Role.EntityLogicalName, _roleId) });

                            Console.WriteLine("Role is associated with the user.");
                        }
                    }

                    DeleteRequiredRecords(promptforDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // For this sample, all required entities are created in the Run() method.
            // Create/retrieve a user for role assignment.
            _userId = SystemUserProvider.RetrieveAUserWithoutAnyRoleAssigned(_serviceProxy);

            if (_userId != Guid.Empty)
                Console.WriteLine("{0} user retrieved.", _userId);
        }

        /// <summary>
        /// Deletes/reverts any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete/revert the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.Write("\nDo you want these entity records deleted/reverted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Disassociate("systemuser",
                    _userId,
                    new Relationship("systemuserroles_association"),
                    new EntityReferenceCollection() { new EntityReference("role", _roleId) });
                Console.WriteLine("Entity records have been deleted/reverted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                AddRoleToUser app = new AddRoleToUser();
                app.Run( config, true );
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Privilege and role entities
User and team entities
Synchronized users in Microsoft Dynamics CRM Online and Office 365

Other Resources

Sample: Determine whether a user has a role
Helper code: ServerConnection class
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Determine whether a user has a role
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package::

SampleCode\CS\BusinessDataModel\UsersAndRoles\DoesUserBelongToRole.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to determine whether a user in Microsoft Dynamics CRM has been associated with a specific role. This is performed by using a query with the IOrganizationService.RetrieveMultiple method. A snippet that shows the key sections of the sample is shown first, followed by the complete sample code. Note that this sample can only be run in an on-premises environment because it creates a user. However, the section of the sample that demonstrates retrieving the roles for a user will work for all environments.

Example

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Retrieve a user.
    SystemUser user = _serviceProxy.Retrieve(SystemUser.EntityLogicalName,
        _userId, new ColumnSet(new String [] {"systemuserid", "firstname", "lastname"})).ToEntity<SystemUser>();

    if (user != null)
    {
        Console.WriteLine("{1} {0} user account is retrieved.", user.LastName, user.FirstName);
        // Find a role.
        QueryExpression query = new QueryExpression
        {
            EntityName = Role.EntityLogicalName,
            ColumnSet = new ColumnSet("roleid"),
            Criteria = new FilterExpression
            {
                Conditions =
                {

                    new ConditionExpression
                    {
                        AttributeName = "name",
                        Operator = ConditionOperator.Equal,
                        Values = {_givenRole}
                    }
                }
            }
        };

        // Get the role.
        EntityCollection givenRoles = _serviceProxy.RetrieveMultiple(query);

        if (givenRoles.Entities.Count > 0)
        {
            Role givenRole = givenRoles.Entities[0].ToEntity<Role>();

            Console.WriteLine("Role {0} is retrieved.", _givenRole);

            Console.WriteLine("Checking association between user and role.");
            // Establish a SystemUser link for a query.
            LinkEntity systemUserLink = new LinkEntity()
            {
                LinkFromEntityName = SystemUserRoles.EntityLogicalName,
                LinkFromAttributeName = "systemuserid",
                LinkToEntityName = SystemUser.EntityLogicalName,
                LinkToAttributeName = "systemuserid",
                LinkCriteria =
                {
                    Conditions =
                    {
                        new ConditionExpression(
                            "systemuserid", ConditionOperator.Equal, user.Id)
                    }
                }
            };

            // Build the query.
            QueryExpression linkQuery = new QueryExpression()
            {
                EntityName = Role.EntityLogicalName,
                ColumnSet = new ColumnSet("roleid"),
                LinkEntities =
                {
                    new LinkEntity()
                    {
                        LinkFromEntityName = Role.EntityLogicalName,
                        LinkFromAttributeName = "roleid",
                        LinkToEntityName = SystemUserRoles.EntityLogicalName,
                        LinkToAttributeName = "roleid",
                        LinkEntities = {systemUserLink}
                    }
                },
                Criteria =
                {
                    Conditions =
                    {
                        new ConditionExpression("roleid", ConditionOperator.Equal, givenRole.Id)
                    }
                }
            };

            // Retrieve matching roles.
            EntityCollection matchEntities = _serviceProxy.RetrieveMultiple(linkQuery);

            // if an entity is returned then the user is a member
            // of the role
            Boolean isUserInRole = (matchEntities.Entities.Count > 0);

            if(isUserInRole)
                Console.WriteLine("User do not belong to the role.");
            else
                Console.WriteLine("User belong to this role.");

        }
    }
}

Complete Sample Code

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to check a role association with the system user.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to revert the role
    /// association created by this program.</remarks>
    public class DoesUserBelongToRole
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _userId;
        private OrganizationServiceProxy _serviceProxy;
        private String _givenRole = "salesperson";
        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// creates/retrieve a system user,
        /// retrieve a system user to check if it is associate with the salesperson role.
        /// Note: Creating a user is only supported
        /// in on-premises/active directory environment.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Retrieve a user.
                    SystemUser user = _serviceProxy.Retrieve(SystemUser.EntityLogicalName,
                        _userId, new ColumnSet(new String [] {"systemuserid", "firstname", "lastname"})).ToEntity<SystemUser>();

                    if (user != null)
                    {
                        Console.WriteLine("{1} {0} user account is retrieved.", user.LastName, user.FirstName);
                        // Find a role.
                        QueryExpression query = new QueryExpression
                        {
                            EntityName = Role.EntityLogicalName,
                            ColumnSet = new ColumnSet("roleid"),
                            Criteria = new FilterExpression
                            {
                                Conditions =
                                {

                                    new ConditionExpression
                                    {
                                        AttributeName = "name",
                                        Operator = ConditionOperator.Equal,
                                        Values = {_givenRole}
                                    }
                                }
                            }
                        };

                        // Get the role.
                        EntityCollection givenRoles = _serviceProxy.RetrieveMultiple(query);

                        if (givenRoles.Entities.Count > 0)
                        {
                            Role givenRole = givenRoles.Entities[0].ToEntity<Role>();

                            Console.WriteLine("Role {0} is retrieved.", _givenRole);

                            Console.WriteLine("Checking association between user and role.");
                            // Establish a SystemUser link for a query.
                            LinkEntity systemUserLink = new LinkEntity()
                            {
                                LinkFromEntityName = SystemUserRoles.EntityLogicalName,
                                LinkFromAttributeName = "systemuserid",
                                LinkToEntityName = SystemUser.EntityLogicalName,
                                LinkToAttributeName = "systemuserid",
                                LinkCriteria =
                                {
                                    Conditions =
                                    {
                                        new ConditionExpression(
                                            "systemuserid", ConditionOperator.Equal, user.Id)
                                    }
                                }
                            };

                            // Build the query.
                            QueryExpression linkQuery = new QueryExpression()
                            {
                                EntityName = Role.EntityLogicalName,
                                ColumnSet = new ColumnSet("roleid"),
                                LinkEntities =
                                {
                                    new LinkEntity()
                                    {
                                        LinkFromEntityName = Role.EntityLogicalName,
                                        LinkFromAttributeName = "roleid",
                                        LinkToEntityName = SystemUserRoles.EntityLogicalName,
                                        LinkToAttributeName = "roleid",
                                        LinkEntities = {systemUserLink}
                                    }
                                },
                                Criteria =
                                {
                                    Conditions =
                                    {
                                        new ConditionExpression("roleid", ConditionOperator.Equal, givenRole.Id)
                                    }
                                }
                            };

                            // Retrieve matching roles.
                            EntityCollection matchEntities = _serviceProxy.RetrieveMultiple(linkQuery);

                            // if an entity is returned then the user is a member
                            // of the role
                            Boolean isUserInRole = (matchEntities.Entities.Count > 0);

                            if(isUserInRole)
                                Console.WriteLine("User do not belong to the role.");
                            else
                                Console.WriteLine("User belong to this role.");

                        }
                    }
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // For this sample, all required entities are created in the Run() method.
            // Create/Retrieve a user.
            _userId = SystemUserProvider.RetrieveAUserWithoutAnyRoleAssigned(_serviceProxy);

            if (_userId != Guid.Empty)
                Console.WriteLine("{0} user retrieved.", _userId);
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DoesUserBelongToRole app = new DoesUserBelongToRole();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Privilege and role entities
User and team entities
Synchronized users in Microsoft Dynamics CRM Online and Office 365

Other Resources

Sample: Remove a role for a user
Helper code: ServerConnection class

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Remove a role for a user
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\UsersAndRoles\RemoveRoleFromUser.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to disassociate a role from a user by using the IOrganizationService.Disassociate method. A snippet showing just the key sections of the sample is shown first, followed by the complete sample code. Note that this sample can only be run in an on-premises environment because it creates a user. However, the section of the sample that demonstrates disassociating a role from a user will work for all environments.

Example

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy is properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Retrieve a user.
    SystemUser user = _serviceProxy.Retrieve(SystemUser.EntityLogicalName,
        _userId, new ColumnSet(new String[] { "systemuserid", "firstname", "lastname" })).ToEntity<SystemUser>();

    if (user != null)
    {
        Console.WriteLine("{1} {0} user account is retrieved.", user.FirstName, user.LastName);
        // Find the role.
        QueryExpression query = new QueryExpression
        {
            EntityName = "role",
            ColumnSet = new ColumnSet("roleid"),
            Criteria = new FilterExpression
            {
                Conditions =
                {

                    new ConditionExpression
                    {
                        AttributeName = "name",
                        Operator = ConditionOperator.Equal,
                        Values = {_givenRole}
                    }
                }
            }
        };

        // Get the role.
        EntityCollection roles = _serviceProxy.RetrieveMultiple(query);

        // Disassociate the role.
        if (roles.Entities.Count > 0)
        {
            Role salesRole = _serviceProxy.RetrieveMultiple(query).Entities[0].ToEntity<Role>();

            Console.WriteLine("Role {0} is retrieved.", _givenRole);

            _serviceProxy.Disassociate(
                        "systemuser",
                        user.Id,
                        new Relationship("systemuserroles_association"),
                        new EntityReferenceCollection() { new EntityReference("role", salesRole.Id) });
            Console.WriteLine("Role {0} is disassociated from user {1} {2}.", _givenRole, user.FirstName, user.LastName);
        }
    }

}

Complete sample code

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do basic role association with the system user.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to revert the role
    /// association created by this program.</remarks>
    public class RemoveRoleFromUser
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _userId;
        private String _givenRole = "salesperson";
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards, it
        /// creates/retrieves a system user, and
        /// updates the system user to associate with the salesperson role.
        /// Note: Creating a user is only supported
        /// in an on-premises/active directory environment.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy is properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Retrieve a user.
                    SystemUser user = _serviceProxy.Retrieve(SystemUser.EntityLogicalName,
                        _userId, new ColumnSet(new String[] { "systemuserid", "firstname", "lastname" })).ToEntity<SystemUser>();

                    if (user != null)
                    {
                        Console.WriteLine("{1} {0} user account is retrieved.", user.FirstName, user.LastName);
                        // Find the role.
                        QueryExpression query = new QueryExpression
                        {
                            EntityName = "role",
                            ColumnSet = new ColumnSet("roleid"),
                            Criteria = new FilterExpression
                            {
                                Conditions =
                                {

                                    new ConditionExpression
                                    {
                                        AttributeName = "name",
                                        Operator = ConditionOperator.Equal,
                                        Values = {_givenRole}
                                    }
                                }
                            }
                        };

                        // Get the role.
                        EntityCollection roles = _serviceProxy.RetrieveMultiple(query);

                        // Disassociate the role.
                        if (roles.Entities.Count > 0)
                        {
                            Role salesRole = _serviceProxy.RetrieveMultiple(query).Entities[0].ToEntity<Role>();

                            Console.WriteLine("Role {0} is retrieved.", _givenRole);

                            _serviceProxy.Disassociate(
                                        "systemuser",
                                        user.Id,
                                        new Relationship("systemuserroles_association"),
                                        new EntityReferenceCollection() { new EntityReference("role", salesRole.Id) });
                            Console.WriteLine("Role {0} is disassociated from user {1} {2}.", _givenRole, user.FirstName, user.LastName);
                        }
                    }

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // For this sample, all required entities are created in the Run() method.
            // Create/retrieve a user and associate a role.

            _userId = SystemUserProvider.RetrieveAUserWithoutAnyRoleAssigned(_serviceProxy);
            // Find the role.
            QueryExpression query = new QueryExpression
            {
                EntityName = Role.EntityLogicalName,
                ColumnSet = new ColumnSet("roleid"),
                Criteria = new FilterExpression
                {
                    Conditions =
                                {

                                    new ConditionExpression
                                    {
                                        AttributeName = "name",
                                        Operator = ConditionOperator.Equal,
                                        Values = {_givenRole}
                                    }
                                }
                }
            };

            // Get the role.
            EntityCollection roles = _serviceProxy.RetrieveMultiple(query);
            if (roles.Entities.Count > 0)
            {
                Role salesRole = _serviceProxy.RetrieveMultiple(query).Entities[0].ToEntity<Role>();

                // Associate the user with the role for this sample.
                if (salesRole != null && _userId != Guid.Empty)
                {
                    _serviceProxy.Associate(
                                "systemuser",
                                _userId,
                                new Relationship("systemuserroles_association"),
                                new EntityReferenceCollection() { new EntityReference(Role.EntityLogicalName, salesRole.Id) });
                }
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                RemoveRoleFromUser app = new RemoveRoleFromUser();
                app.Run( config, true );
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Privilege and role entities
User and team entities
Synchronized users in Microsoft Dynamics CRM Online and Office 365

Other Resources

Sample: Retrieve the roles for an organization
Helper code: ServerConnection class
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve the roles for an organization
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\UsersAndRoles\RetrieveRolesForOrg.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve the roles for an organization by using the IOrganizationService.RetrieveMultiple method. A snippet that shows just the key sections of the sample is shown first, followed by the complete sample code.

Example

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy is properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    QueryExpression query = new QueryExpression
    {
        EntityName = Role.EntityLogicalName,
        ColumnSet = new ColumnSet("name", "roleid")

    };

    EntityCollection entities = _serviceProxy.RetrieveMultiple(query);
    // Write the name and ID of each role to the console.
    foreach (Entity item in entities.Entities)
    {
        Role role = item.ToEntity<Role>();
        Console.WriteLine("Name: {0}. Id: {1}", role.Name, role.Id);
    }

}

Complete sample code

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to retrieve roles from an organization.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to revert the role
    /// association created by this program.</remarks>
    public class RetrieveRolesForOrg
    {
        #region Class Level Members

        // Define the IDs needed for this sample.

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards, it
        /// retrieves roles.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user is prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy is properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    QueryExpression query = new QueryExpression
                    {
                        EntityName = Role.EntityLogicalName,
                        ColumnSet = new ColumnSet("name", "roleid")

                    };

                    EntityCollection entities = _serviceProxy.RetrieveMultiple(query);
                    // Write the name and ID of each role to the console.
                    foreach (Entity item in entities.Entities)
                    {
                        Role role = item.ToEntity<Role>();
                        Console.WriteLine("Name: {0}. Id: {1}", role.Name, role.Id);
                    }

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                RetrieveRolesForOrg app = new RetrieveRolesForOrg();
                app.Run( config, true );
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Privilege and role entities

Other Resources

Helper code: ServerConnection class
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Field security entities

You use field security entities to apply field-level security, which restricts field access to specified users and teams. The scope of field-level security is global, which means that it applies to all records within the organization, regardless of the business unit hierarchical level to which the record or the user belongs. Field security works in all Microsoft Dynamics CRM clients, including the Web client, Microsoft Dynamics CRM for Outlook, and Microsoft Dynamics CRM for phones. It applies to all components, such as the Microsoft Dynamics CRM SDK, reports, search, offline, filtered views, auditing, and duplicate detection. For this release, field security can be applied to both custom fields and many out-of-box (OOB) fields.

For more information about how secured fields change the behavior of methods, see How field security can be used to control access to field values in Microsoft Dynamics CRM.

Security Note
Field-level security profiles prevent unintended users from getting access to Microsoft Dynamics CRM data based on the profile definitions. If the Microsoft SQL Server ACLs are misconfigured, or if there is a SQL injection issue, adversaries can get direct access to data in Microsoft SQL Server thereby bypassing field level security restrictions. For more information, see Overview of Web Application Security Threats.

In This Topic

Set up and use field security

Which attributes can be secured?

Share secured fields

Set up and use field security

To use field security you must do the following:

  1. Create a field security profile record
  2. Add users or teams to the profile
  3. Find an attribute that can be secured at the field level
  4. Secure the attribute, either when you create the attribute or by updating the attribute metadata
  5. Publish the attribute customizations
  6. Create a field permission record that defines what access (create, update, read) the profile will have for the custom attribute

For sample code about how to perform these steps, see Sample: Enable field security for an entity.

Use the following field permission attributes to set whether the specified field security profile can create, read, or update an attribute. You can set or compare the value for these attributes by using the A Yes or No Boolean global option set:

  • FieldPermission.CanCreate
  • FieldPermission.CanRead
  • FieldPermission.CanUpdate

Security Note
If low privilege users are given Read access to the field security profile entity, they can see what profiles other users have and find other users with access to secured attributes they are interested in. They can then use social engineering techniques to get assigned a profile with access to those secured attributes.

Which attributes can be secured?

To see which attributes can be secured, you can query the entity metadata for the following properties:

  • CanBeSecuredForCreate
  • CanBeSecuredForRead
  • CanBeSecuredForUpdate

There are a few additional rules that apply to certain attribute data types:

  • Boolean attributes can be secured for create and update operations but not for read.
  • Option set attributes can be secured for create, update, and read when a default value is unspecified.

There are thousands of attributes that can be secured, so there are two easier ways to look for this information. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Share secured fields

You can share secured fields much as you can share records. To do this, you create, update, or delete a PrincipalObjectAttributeAccess (field sharing) record, where you specify the user or team, the entity, and the permissions.

The following table lists the corresponding methods for securing a field compared to securing a record.

Record sharing | Field access sharing
Use the GrantAccessRequest message to grant record access for a user or team. | Use the CreateRequest message or the IOrganizationService.Create method to grant secured field access for a user or team.
Use the ModifyAccessRequest message to update record access for a user or team. | Use the UpdateRequest message or the IOrganizationService.Update method to update secured field access for a user or team.
Use the RevokeAccessRequest message to remove record access for a user or team. | Use the DeleteRequest message or the IOrganizationService.Delete method to remove secured field access for a user or team.

See Also

Concepts

FieldSecurityProfile entity messages and methods
FieldPermission entity messages and methods
PrincipalObjectAttributeAccess (field sharing) entity messages and methods
Field-level data encryption

Other Resources

The security model of Microsoft Dynamics CRM
Administration and security entities
Sample: Retrieve field permissions
Sample: Enable field security for an entity
Sample: Retrieve field sharing records

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FieldSecurityProfile entity messages and methods

A field security profile defines the access level for secured attributes. The schema name for this entity is FieldSecurityProfile. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a field security profile. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a field security profile. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a field security profile. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of field security profiles. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAttributePrivilegesRequest | Retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity.
UpdateRequest | Updates a field security profile. You can also call the IOrganizationService.Update method.

See Also

Concepts

Field security entities
FieldPermission entity messages and methods
FieldSecurityProfile entity privileges
PrincipalObjectAttributeAccess (field sharing) entity messages and methods
Field-level data encryption

Other Resources

Sample: Retrieve field permissions
Sample: Enable field security for an entity
Sample: Retrieve field sharing records

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FieldPermission entity messages and methods

A field permission is a group of field privileges (Create, Read or Update) used to provide appropriate access to secured fields. The schema name for this entity is FieldPermission. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a field permission. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a field permission. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a field permission. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of field permissions. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a field permission. You can also call the IOrganizationService.Update method.

See Also

Concepts

Field security entities
FieldPermission entity privileges
FieldSecurityProfile entity messages and methods
PrincipalObjectAttributeAccess (field sharing) entity messages and methods
Field-level data encryption

Other Resources

Sample: Retrieve field permissions
Sample: Enable field security for an entity
Sample: Retrieve field sharing records

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PrincipalObjectAttributeAccess (field sharing) entity messages and methods

A principal object attribute access (field sharing) keeps data about sharing of secured attribute instance (SAI) access for a user or team. Only read or update access to SAI can be shared. The schema name for this entity is PrincipalObjectAttributeAccess. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a principal object attribute access (field sharing). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a principal object attribute access (field sharing). You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a principal object attribute access (field sharing). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of principal object attribute access (field sharing) records. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a principal object attribute access (field sharing). You can also call the IOrganizationService.Update method.

See Also

Concepts

Field security entities
FieldSecurityProfile entity messages and methods
FieldPermission entity messages and methods
Field-level data encryption
PrincipalObjectAttributeAccess (field sharing) entity privileges

Other Resources

Sample: Retrieve field permissions
Sample: Enable field security for an entity
Sample: Retrieve field sharing records

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Field-level data encryption

Microsoft Dynamics CRM 2015 uses standard Microsoft SQL Server cell level encryption for a set of default entity attributes that contain sensitive information, such as user names and email passwords. This feature can help organizations meet the compliance requirements associated with FIPS 140-2. Field-level data encryption is especially important in scenarios that leverage the Microsoft Dynamics CRM Email Router, which must store user names and passwords to enable integration between a CRM instance and an email service such as Microsoft Exchange.

While data encryption is not active in Microsoft Dynamics CRM 2015 on-premises by default for new or upgraded organizations, data encryption may be activated at any time. Microsoft Dynamics CRM users who have the system administrator security role can activate data encryption (or change the encryption key after data encryption is enabled) in the Settings > Data Management > Data Encryption area. After data encryption is activated, it cannot be turn off.

Important
For Microsoft Dynamics CRM Online, all new and upgraded organizations have data encryption activated.

When considering the use of data encryption, be sure to keep in mind the following key points:

  • To help ensure the highest level of security, we recommend that you change the encryption key once a year.
  • Changing the encryption key requires that SSL be configured on the Microsoft Dynamics CRM website.
  • Auditing cannot be enabled on encrypted fields.
  • Encrypted fields cannot be customized.
  • Encrypted fields cannot be indexed.
  • Encrypted fields can be set and updated by using standard Create, Update, and Delete methods.
  • When doing a retrieve of an encrypted field’s value, a null is returned.

The encryption key is required to activate data encryption when you import an organization database into a new deployment or into a deployment that has had the configuration database (MSCRM_CONFIG) recreated after the organization was encrypted. You can copy the original encryption key to Notepad and then paste it into the Settings > Data Management > Data Encryption dialog box after the organization import is completed. When activating data encryption after redeployment, we recommend that you use Internet Explorer to paste the encryption key into the Data Encryption dialog box.

Encrypted attributes

The entity attributes that are configured for field-level data encryption are listed in the following table.

Entity | Attribute
EmailServerProfile | IncomingPassword
EmailServerProfile | OutgoingPassword
Mailbox | Password
Queue | EmailPassword
UserSettings | EmailPassword

Messages

The messages that can be used for field-level data encryption are listed in the following table.

Request class name | More information
IsDataEncryptionActiveRequest | Checks if data encryption is currently running (active or inactive).
RetrieveDataEncryptionKeyRequest | Retrieves the data encryption key value.
SetDataEncryptionKeyRequest | Sets or restores the data encryption key. To prevent accidentally running multiple change requests in parallel, this SDK message will be throttled so that only one request can run at a time.

Note
You must use SSL when you use these messages. When you execute these messages, a check will ensure that the user’s client/server connectivity is using the HTTPS protocol. If not, an exception is returned if the requests are submitted without using HTTPS.

See Also

Other Resources

Administration Guide: Data encryption

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve field permissions
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\FieldSecurity\RetrieveSecuredFieldsForAUser.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve secured fields for a user according to the steps outlined in Field security entities.

Example

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Create Field Security Profile.
    FieldSecurityProfile managersProfile = new FieldSecurityProfile();
    managersProfile.Name = "Managers";
    _profileId = _serviceProxy.Create(managersProfile);
    Console.Write("Created Profile, ");

    // Add team to profile.
    AssociateRequest teamToProfile = new AssociateRequest()
    {
        Target = new EntityReference(FieldSecurityProfile.EntityLogicalName,
            _profileId),
        RelatedEntities = new EntityReferenceCollection()
        {
            new EntityReference(Team.EntityLogicalName, _teamId)
        },
        Relationship = new Relationship("teamprofiles_association")
    };
    _serviceProxy.Execute(teamToProfile);

    // Add user to the profile.
    AssociateRequest userToProfile = new AssociateRequest()
    {
        Target = new EntityReference(FieldSecurityProfile.EntityLogicalName,
            _profileId),
        RelatedEntities = new EntityReferenceCollection()
        {
            new EntityReference(SystemUser.EntityLogicalName, _userId)
        },
        Relationship = new Relationship("systemuserprofiles_association")
    };
    _serviceProxy.Execute(userToProfile);

    // Create custom activity entity.
    CreateEntityRequest req = new CreateEntityRequest()
    {
        Entity = new EntityMetadata
        {
            LogicalName = "new_tweet",
            DisplayName = new Label("Tweet", 1033),
            DisplayCollectionName = new Label("Tweet", 1033),
            OwnershipType = OwnershipTypes.UserOwned,
            SchemaName = "New_Tweet",
            IsActivity = true,
            IsAvailableOffline = true,
            IsAuditEnabled = new BooleanManagedProperty(true),
            IsMailMergeEnabled = new BooleanManagedProperty(false),
        },
        HasActivities = false,
        HasNotes = true,
        PrimaryAttribute = new StringAttributeMetadata()
        {
            SchemaName = "Subject",
            LogicalName = "subject",
            RequiredLevel = new AttributeRequiredLevelManagedProperty(
                AttributeRequiredLevel.None),
            MaxLength = 100,
            DisplayName = new Label("Subject", 1033)
        }
    };
    _serviceProxy.Execute(req);
    Console.Write("Entity Created, ");

    // Add privileges for the Tweet entity to the Marketing Role.
    RolePrivilege[] privileges = new RolePrivilege[3];

    // SDK: prvCreateActivity
    privileges[0] = new RolePrivilege();
    privileges[0].PrivilegeId = new Guid("{091DF793-FE5E-44D4-B4CA-7E3F580C4664}");
    privileges[0].Depth = PrivilegeDepth.Global;

    // SDK: prvReadActivity
    privileges[1] = new RolePrivilege();
    privileges[1].PrivilegeId = new Guid("{650C14FE-3521-45FE-A000-84138688E45D}");
    privileges[1].Depth = PrivilegeDepth.Global;

    // SDK: prvWriteActivity
    privileges[2] = new RolePrivilege();
    privileges[2].PrivilegeId = new Guid("{0DC8F72C-57D5-4B4D-8892-FE6AAC0E4B81}");
    privileges[2].Depth = PrivilegeDepth.Global;

    // Create and execute the request.
    AddPrivilegesRoleRequest request = new AddPrivilegesRoleRequest()
    {
        RoleId = _roleId,
        Privileges = privileges
    };
    AddPrivilegesRoleResponse response =
        (AddPrivilegesRoleResponse)_serviceProxy.Execute(request);

    // Create custom identity attribute.
    CreateAttributeRequest attrReq = new CreateAttributeRequest()
    {
        Attribute = new StringAttributeMetadata()
        {
            LogicalName = "new_identity",
            DisplayName = new Label("Identity", 1033),
            SchemaName = "New_Identity",
            MaxLength = 500,
            RequiredLevel = new AttributeRequiredLevelManagedProperty(
                AttributeRequiredLevel.Recommended),
            IsSecured = true
        },
        EntityName = "new_tweet"
    };
    CreateAttributeResponse identityAttributeResponse =
        (CreateAttributeResponse)_serviceProxy.Execute(attrReq);
    _identityId = identityAttributeResponse.AttributeId;
    Console.Write("Identity Created, ");

    // Create custom message attribute.
    attrReq = new CreateAttributeRequest()
    {
        Attribute = new StringAttributeMetadata()
        {
            LogicalName = "new_message",
            DisplayName = new Label("Message", 1033),
            SchemaName = "New_Message",
            MaxLength = 140,
            RequiredLevel = new AttributeRequiredLevelManagedProperty(
                AttributeRequiredLevel.Recommended),
            IsSecured = true
        },
        EntityName = "new_tweet"
    };
    CreateAttributeResponse messageAttributeResponse =
        (CreateAttributeResponse)_serviceProxy.Execute(attrReq);
    _messageId = messageAttributeResponse.AttributeId;
    Console.Write("Message Created, ");

    // Create field permission object for Identity.
    FieldPermission identityPermission = new FieldPermission();
    identityPermission.AttributeLogicalName = "new_identity";
    identityPermission.EntityName = "new_tweet";
    identityPermission.CanRead = new OptionSetValue(FieldPermissionType.Allowed);
    identityPermission.FieldSecurityProfileId = new EntityReference(
        FieldSecurityProfile.EntityLogicalName, _profileId);
    _identityPermissionId = _serviceProxy.Create(identityPermission);
    Console.Write("Permission Created, ");

    // Create list for storing retrieved profiles.
    List<Guid> profileIds = new List<Guid>();

    // Build query to obtain the field security profiles.
    QueryExpression qe = new QueryExpression()
    {
        EntityName = FieldSecurityProfile.EntityLogicalName,
        ColumnSet = new ColumnSet("fieldsecurityprofileid"),
        LinkEntities =
        {
            new LinkEntity
            {
                LinkFromEntityName = FieldSecurityProfile.EntityLogicalName,
                LinkToEntityName = SystemUser.EntityLogicalName,
                LinkCriteria =
                {
                    Conditions =
                    {
                        new ConditionExpression("systemuserid", ConditionOperator.Equal, _userId)
                    }
                }
            }
        }
    };

    // Execute the query and obtain the results.
    RetrieveMultipleRequest rmRequest = new RetrieveMultipleRequest()
    {
        Query = qe
    };

    EntityCollection bec = ((RetrieveMultipleResponse)_serviceProxy.Execute(
        rmRequest)).EntityCollection;

    // Extract profiles from query result.
    foreach (FieldSecurityProfile profileEnt in bec.Entities)
    {
        profileIds.Add(profileEnt.FieldSecurityProfileId.Value);
    }
    Console.Write("Profiles Retrieved, ");

    // Retrieve attribute permissions of a FieldSecurityProfile.
    DataCollection<Entity> dc;

    // Retrieve the attributes.
    QueryByAttribute qba = new QueryByAttribute(FieldPermission.EntityLogicalName);
    qba.AddAttributeValue("fieldsecurityprofileid", _profileId);
    qba.ColumnSet = new ColumnSet("attributelogicalname");

    dc = _serviceProxy.RetrieveMultiple(qba).Entities;
    Console.Write("Attributes Retrieved. ");

    DeleteRequiredRecords(promptforDelete);
}

See Also

Concepts

How field security can be used to control access to field values in Microsoft Dynamics CRM
Field security entities

Other Resources

IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Enable field security for an entity
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\FieldSecurity\EnableFieldSecurityForAnEntity.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Example

This sample shows how to enable field security for an entity.

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Create Field Security Profile.
    FieldSecurityProfile managersProfile = new FieldSecurityProfile();
    managersProfile.Name = "Managers";
    _profileId = _serviceProxy.Create(managersProfile);
    Console.Write("Created Profile, ");

    // Create the request object and set the monikers with the
    // teamprofiles_association relationship.
    AssociateRequest teamToProfile = new AssociateRequest
    {
        Target = new EntityReference(FieldSecurityProfile.EntityLogicalName, _profileId),
        RelatedEntities = new EntityReferenceCollection
        {
            new EntityReference(Team.EntityLogicalName, _teamId)
        },
        Relationship = new Relationship("teamprofiles_association")
    };

    // Execute the request.
    _serviceProxy.Execute(teamToProfile);

    // Create custom activity entity.
    CreateEntityRequest req = new CreateEntityRequest()
    {
        Entity = new EntityMetadata
        {
            LogicalName = "new_tweet",
            DisplayName = new Label("Tweet", 1033),
            DisplayCollectionName = new Label("Tweet", 1033),
            OwnershipType = OwnershipTypes.UserOwned,
            SchemaName = "New_Tweet",
            IsActivity = true,
            IsAvailableOffline = true,
            IsAuditEnabled = new BooleanManagedProperty(true),
            IsMailMergeEnabled = new BooleanManagedProperty(false)
        },
        HasActivities = false,
        HasNotes = true,
        PrimaryAttribute = new StringAttributeMetadata()
        {
            SchemaName = "Subject",
            LogicalName = "subject",
            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
            MaxLength = 100,
            DisplayName = new Label("Subject", 1033)
        }
    };

    // Execute the request.
    _serviceProxy.Execute(req);
    Console.Write("Entity Created, ");

    // Create custom attributes.
    CreateAttributeRequest attrReq = new CreateAttributeRequest()
    {
        Attribute = new StringAttributeMetadata()
        {
            LogicalName = "new_identity",
            DisplayName = new Label("Identity", 1033),
            SchemaName = "New_Identity",
            MaxLength = 500,
            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.Recommended),
            IsSecured = true
        },
        EntityName = "new_tweet"
    };

    // Execute the request.
    CreateAttributeResponse identityAttributeResponse = (CreateAttributeResponse)_serviceProxy.Execute(attrReq);
    _identityId = identityAttributeResponse.AttributeId;
    Console.Write("Identity Created, ");

    attrReq = new CreateAttributeRequest()
    {
        Attribute = new StringAttributeMetadata()
        {
            LogicalName = "new_message",
            DisplayName = new Label("Message", 1033),
            SchemaName = "New_Message",
            MaxLength = 140,
            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.Recommended),
            IsSecured = true
        },
        EntityName = "new_tweet"
    };

    // Execute the request.
    CreateAttributeResponse messageAttributeResponse = (CreateAttributeResponse)_serviceProxy.Execute(attrReq);
    _messageId = messageAttributeResponse.AttributeId;
    Console.Write("Message Created, ");

    // Create the field permission for the Identity attribute.
    FieldPermission identityPermission = new FieldPermission()
    {
        AttributeLogicalName = "new_identity",
        EntityName = "new_tweet",
        CanRead = new OptionSetValue(FieldPermissionType.Allowed),
        FieldSecurityProfileId = new EntityReference(FieldSecurityProfile.EntityLogicalName, _profileId)
    };

    // Execute the request
    _identityPermissionId = _serviceProxy.Create(identityPermission);
    Console.Write("Permission Created. ");

    DeleteRequiredRecords(promptforDelete);
}

See Also

Concepts

How field security can be used to control access to field values in Microsoft Dynamics CRM
Field security entities

Other Resources

Sample: Retrieve field sharing records
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve field sharing records
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\FieldSecurity\RetrieveUserSharedAttributePermissions.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Example

This sample shows how to retrieve the PrincipalObjectAttributeAccess (field sharing) records for an entity.

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    #region Check if this user has prvReadPOAA
    // Get the GUID of the current user.
    WhoAmIRequest whoAmI = new WhoAmIRequest();
    Guid userLoggedId =
        ((WhoAmIResponse)_serviceProxy.Execute(whoAmI)).UserId;
    Console.WriteLine("User logged: " + userLoggedId);

    // Check if this user has prvReadPOAA.
    RetrieveUserPrivilegesRequest userPrivilegesRequest =
        new RetrieveUserPrivilegesRequest();
    userPrivilegesRequest.UserId = userLoggedId;
    RetrieveUserPrivilegesResponse userPrivilegesResponse =
        (RetrieveUserPrivilegesResponse)_serviceProxy.Execute(userPrivilegesRequest);

    // Fixed the GUID for prvReadPOAA.
    Guid prvReadPOAA = new Guid("{68564CD5-2B2E-11DF-80A6-00137299E1C2}");

    if (userPrivilegesResponse.RolePrivileges.Any(r => r.PrivilegeId.Equals(prvReadPOAA)))
    {
        Console.WriteLine("This user DOES have prvReadPOAA");
    }
    else
    {
        Console.WriteLine("This user DOESN'T have prvReadPOAA");
    }
    Console.WriteLine();
    #endregion Check if this user has prvReadPOAA
    #region Create an account record

    // Create an account record
    Account accountRecord = new Account();
    accountRecord.Name = "Ane";
    accountRecord["secret_phone"] = "123456";
    _accountRecordId = _serviceProxy.Create(accountRecord);
    Console.WriteLine("Account record created.");

    #endregion Create an account record

    #region Create POAA entity for field #1

    // Create POAA entity for field #1
    PrincipalObjectAttributeAccess poaa = new PrincipalObjectAttributeAccess
    {
        AttributeId = _secretHomeId,
        ObjectId = new EntityReference
            (Account.EntityLogicalName, _accountRecordId),
        PrincipalId = new EntityReference
            (SystemUser.EntityLogicalName, userLoggedId),
        ReadAccess = true,
        UpdateAccess = true
    };

    _serviceProxy.Create(poaa);
    Console.WriteLine("POAA record for custom field Secret_Home created.");

    #endregion Create POAA entity for field #1

    #region Create POAA entity for field #2

    // Create POAA entity for field #2
    poaa = new PrincipalObjectAttributeAccess
    {
        AttributeId = _secretPhoneId,
        ObjectId = new EntityReference
            (Account.EntityLogicalName, _accountRecordId),
        PrincipalId = new EntityReference
            (SystemUser.EntityLogicalName, userLoggedId),
        ReadAccess = true,
        UpdateAccess = true
    };

    _serviceProxy.Create(poaa);
    Console.WriteLine("POAA record for custom field Secret_Phone created.");

    #endregion Create POAA entity for field #2

    #region Retrieve User Shared Attribute Permissions
    // Create the query for retrieve User Shared Attribute permissions.
    QueryExpression queryPOAA =
        new QueryExpression("principalobjectattributeaccess");
    queryPOAA.ColumnSet = new ColumnSet
        (new string[] { "attributeid", "readaccess", "updateaccess", "principalid" });
    queryPOAA.Criteria.FilterOperator = LogicalOperator.And;
    queryPOAA.Criteria.Conditions.Add
        (new ConditionExpression("objectid", ConditionOperator.Equal, _accountRecordId));
    queryPOAA.Criteria.Conditions.Add
        (new ConditionExpression("principalid", ConditionOperator.EqualUserId));

    Console.WriteLine();
    Console.WriteLine("POAA for user: " + userLoggedId.ToString());
    Console.WriteLine();

    try
    {
        // Execute the query.
        EntityCollection responsePOAA = _serviceProxy.RetrieveMultiple(queryPOAA);

        foreach (var entity in responsePOAA.Entities)
        {
            Console.WriteLine("  principalid: " + ((EntityReference)entity["principalid"]).Id);
            Console.WriteLine("  attributeid: " + entity["attributeid"].ToString());
            Console.WriteLine("  readaccess: " + entity["readaccess"].ToString());
            Console.WriteLine("  updateaccess: " + entity["updateaccess"].ToString());
            Console.WriteLine();
        }
    }
    catch (Exception exc)
    {
        Console.WriteLine("Error: " + exc.Message);
    }

    #endregion Retrieve User Shared Attribute Permissions

    DeleteRequiredRecords(promptforDelete);

}

See Also

Concepts

How field security can be used to control access to field values in Microsoft Dynamics CRM
Field security entities

Other Resources

IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Hierarchical security (position) entity

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, hierarchy security enables you to model the manager/direct report structure that is often used in businesses. The Position entity provides the capability to model this type of relationship. A system user in a higher level position can access the business data being accessed by another user in a lower level position.

See Also

Concepts

Position entity messages and methods
How hierarchical security can be used to control access to entities in Microsoft Dynamics CRM

Other Resources

Administration and security entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Position entity messages and methods

A Position represents a location in a business hierarchy structure of system users that models a relationship between a manager and direct reports. This structure enables a higher level manager to access business data that is accessible to direct reports. The schema name for this entity is Position. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a position. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a position. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a position. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of positions. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a position. For a list of the state values, see the options available in the metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a position. You can also call the IOrganizationService.Update method.

See Also

Reference

Apply hierarchical security models
Position entity privileges

Concepts

Hierarchical security (position) entity
Position entity messages and methods
How hierarchical security can be used to control access to entities in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Activity feeds entities

The activity feeds help promote internal collaboration through quick and short updates in Microsoft Dynamics CRM. The activity feeds do not replace emails or in-person communications. Instead, they augment these traditional methods with non-intrusive and non-urgent ways of communication.

The activity feeds enable a salesperson to stay on top of situations that involve people, accounts, leads, contacts, or opportunities. They provide easy and convenient ways of monitoring important information that can be critical for closing a deal.

With activity feeds you can easily accomplish important tasks, such as:

  • Share information about users, accounts, leads, and other entity records.
  • Receive important updates regarding opportunities, users, or other records.
  • Follow users, accounts, and other records.
  • Learn, in a timely manner, about updates regarding users, accounts, or opportunities and items that are related to them.
  • Take quick actions on specific updates to move your work towards successful completion.

As a developer you can consume and create activity feeds data programmatically. You can integrate activity feeds with other applications, and extend activity feeds to meet the needs of the organization. The following are examples of custom applications that you can build around activity feeds:

  • Build full-featured activity feeds clients to complement Microsoft Dynamics CRM out-of-the-box client experiences that include Web, Outlook, and Mobile clients. For example, you can develop a desktop client.
  • Build surfaces to expose activity feeds data inside other applications, such as SharePoint or enterprise resource planning (ERP).
  • Build custom business logic to create activity feed posts when internal Microsoft Dynamics CRM or external events occur. An example of an external event is an invoice creation in an external ERP system.
  • Perform specific actions when posts are created or deleted. For example, use a workflow to send an email when a post is created.
Note
In addition to activity feeds, from Microsoft Dynamics CRM you can directly connect to Yammer, a powerful tool for collaborating in your organization. For more information, see Connect to Yammer.

In This Section

Introduction to activity feeds

Configure activity feeds

Connect to Yammer

Post entity messages and methods

PostComment (comment) entity messages and methods

PostFollow (follow) entity messages and methods

PostLike (like) entity messages and methods

msdyn_PostAlbum (profile album) entity messages and methods

msdyn_PostConfig (post configuration) entity messages and methods

msdyn_PostRuleConfig (post rule configuration) entity messages and methods

Sample: Collaborate with activity feeds

Related Sections

Model your business data

Customer entities (account, contact)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Introduction to activity feeds

As a developer implementing collaboration scenarios with activity feeds, you should become familiar with the activity feeds terminology, definitions and entity model.

In This Topic

Activity feeds concepts

Activity feeds entities

Mentions

Displaying data on the record wall or personal wall

Activity feeds concepts

The following table contains activity feeds definitions.

Term Description

Wall

A place in Microsoft Dynamics CRM where activity feeds are displayed as short updates.

Record Wall

A place in Microsoft Dynamics CRM where activity feeds for a record, such as an account or lead, are displayed. In the Microsoft Dynamics CRM web application, the record wall is shown as What’s New for the record. The record wall contains posts that are regarding the record or that mention the record. If a record is the system user (user), the wall also contains the posts that are created by the user.

Personal Wall

A wall that is personal to a user. In the Microsoft Dynamics CRM web application, it is user’s What’s New wall. This wall contains the posts about the records that the user is following, posts that are regarding the user or that mention the user.

Auto Post

A post generated by Microsoft Dynamics CRM by applying an auto post rule in case of an event, such as creation of an account or closure of a won opportunity. An auto post can be shown on a record wall or personal wall. The auto post text is localized.

Note
When creating a new opportunity, an auto post is generated, if one of the following attributes is specified: CustomerId, ParentAccountId or ParentContactId.

Manual Post (User Post)

A post created by a Microsoft Dynamics CRM user. A manual post can be shown on a record wall or personal wall.

Auto Post Rule

A rule that is used by Microsoft Dynamics CRM to generate an auto post when an event occurs. For example, a rule may specify to generate an auto post when a new opportunity is created for an account.

Mention

A part of a post that refers to a Microsoft Dynamics CRM record. One post can have multiple mentions.

Comment

A remark that is added on a post. A comment is related to a parent post. It cannot exist without a parent post. If a parent post is deleted, the post’s comments are deleted also.

Follow

An action taken by a user on a Microsoft Dynamics CRM record that enables that user to see the posts about the record on their personal wall.

Note
The maximum allowed number of records to follow is 5000. The default number of records that the user can follow is 1000. The default value is configurable and can be changed by an Administrator or a user with the permissions to modify the deployment settings.

Unfollow

An action taken by a user on a Microsoft Dynamics CRM record that stops posts about that record from being displayed on the user's personal wall.

Like

An action taken by a user on a post that expresses that the user liked the post.

Note

Unlike

An action taken by a user to remove the Like from the post.

Note

Thread or Conversation

A collection of posts and all related comments.

View

A view of entity records based on a query.

Note
Manual and auto posts that are created programmatically can have up to 2000 characters. Posts created in the Microsoft Dynamics CRM web application can have up to 1000 characters. Comments that are created programmatically can have up to 1000 characters, but comments created in the web application are limited to 500 characters.

Activity feeds entities

The following table contains information about the activity feeds entities.

Entity | Description
Post | Represents an auto post or a manual (user) post.
PostComment | Represents a comment on an activity feed post.
PostFollow | Represents a post follow that indicates that a user follows a record. Deleting the PostFollow record is an action of “unfollow”.
PostLike | Represents that the user liked the post. Deleting the PostLike record is an action of “unlike”.
msdyn_PostConfig | Contains activity feed configuration for an entity and is used to enable or disable an entity for activity feeds.
msdyn_PostRuleConfig | Contains activity feed rule configuration for an entity and is used to enable or disable an auto post rule for an entity.
msdyn_PostAlbum | Contains user profile images that are stored as attachments and displayed in posts.

Like/Unlike

With Like/Unlike, you can express an immediate opinion about a post. This makes your communication more personable and interactive. Use Like/Unlike to exchange kudos with your co-workers, praise the work of your subordinates and measure the popularity of the posts. An action taken by the Microsoft Dynamics CRM users showing that they like a particular post is called Like. An action taken by a Microsoft Dynamics CRM user to undo the “Like” on a post is called the Unlike. You can add one “Like” to the post; however, a post maybe “liked” by multiple users. To add a “Like” to a post, create the PostLike record and associate it with the parent Post record. To remove the “Like” from the post, delete the PostLike record.

Mentions

During discussions within a group, you often need to reference a specific person (a Microsoft Dynamics CRM user), or a record, such as an account, and share this information with others. In Microsoft Dynamics CRM Activity Feeds, this action is called a “mention.” The posts that mention a user can be displayed on the user’s record wall and user’s personal wall (“What’s New” in Microsoft Dynamics CRM). The posts that mention a record are displayed on the record’s wall.

To add a mention to a post, use an expression in the following format in the Post.Text attribute:

@[Entity,ID,"Display String"].

Note
There are no spaces following commas in this expression.

The following table describes the parameters in the expression:

Parameter | Description
Entity | An entity logical name or an entity type code for the record that is mentioned in the post.
ID | The ID of the record that is mentioned in the post.
Display String | The text that you want to be displayed in the mention, such as a record’s name.

The entity type codes for all default (non-custom) entities are predefined. For more information, see IOrganizationService entities. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

You can specify multiple mentions in this attribute. To retrieve data contained in the mention, parse the string in the Text attribute to search for the “@[“ characters that separate mentions from other mentions or text.

For additional information about post mentions, see Blog Post: How to do Mentions with Activity Feeds.

Displaying data on the record wall or personal wall

To retrieve posts for displaying on a record wall or a personal wall, you can use the RetrieveRequest message or RetrieveMultipleRequest message. However, to retrieve pages of posts with associated comments and likes in one single call, you can use special activity feeds messages.

To retrieve pages of posts with associated comments and likes for a record wall, use the RetrieveRecordWallRequest message. To retrieve pages of posts with associated comments and likes for a personal wall, use the RetrievePersonalWallRequest message.

The following posts with comments are displayed on the Record Wall:

  • Posts that are regarding a record. The record ID is specified in the Post.RegardingObjectId attribute.
  • Posts that mention a record. The record ID is specified within the Post.Text attribute.
  • For a system user (user) record, the wall also includes the posts that the user created. The Post.RegardingObjectId attribute contains the current user ID.

The following posts with comments are displayed on the Your (User) Personal Wall (What’s New in Microsoft Dynamics CRM):

  • Posts that are regarding you. The Post.RegardingObjectId attribute contains your user ID.
  • Posts that mention you. Your user ID is specified within the Post.Text attribute.
  • Posts that are regarding a record or that mention a record that you follow.

Note
You can only follow the records on which you have read privileges and access rights. If you lose read permissions, a follow is automatically removed. All Microsoft Dynamics CRM users automatically follow themselves. You can only see the posts that are regarding the records or mention the records on which you have read privileges and access rights.

If you create the PostFollow record for the account A and set the OwnerId on the PostFollow to the user B, then the user B follows the account A.

For more information about the role-based and record-based security, see, The security model of Microsoft Dynamics CRM.

See Also

Concepts

Configure activity feeds
Connect to Yammer

Other Resources

Activity feeds entities
Sample: Collaborate with activity feeds
RetrieveRecordWallRequest
RetrievePersonalWallRequest
Blog Post: Working with Activity Feed using Microsoft CRM SDK
Blog Post: How to do Mentions with Activity Feeds
Blog Post: Displaying a Contact’s Facebook Picture in Microsoft Dynamics CRM 2011
Blog Post: Data management for Activity Feeds entities
Blog Post: How to Add a Record Wall to a Form
Blog Post: Activity Feeds Solution & Development Environment

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Configure activity feeds

The following sections contain information about how to configure your system for activity feeds.

In This Topic

Configuration entities

Auto post rules

Plug-ins and workflows

Wall controls

Lookup information for the post entity and post follow entity

Configuration entities

The activity feeds configuration entities are used to enable entities for activity feeds, enable post rules for entities, and configure the user’s profile pictures.

To enable an entity for activity feeds, use the msdyn_PostConfig entity. Set the msdyn_PostConfig.StateCode attribute to Active (value 0) and the msdyn_PostConfig.StatusCode attribute to Active (value 1) by using the SetStateRequest message. Specify the logical name of the entity you want to enable in the msdyn_PostConfig.EntityName attribute. Set the msdyn_PostConfig.msdyn_ConfigureWall attribute to true to enable the wall on the entity form.

Important
If you are developing custom solutions in the activity feeds enabled environment, deactivate the activity feeds for all entities before you create, develop, and export the solution. After the solution is exported, reactivate the activity feeds.

To enable a post rule for an entity, use the msdyn_PostRuleConfig entity. Use the SetStateRequest message to activate a post rule for an entity.

To configure a user’s profile picture, use the msdyn_PostAlbum entity that contains user profile images as attachments. The msdyn_Name attribute contains the name of the profile album.

For activity feeds, you can enable customizable business entities and custom entities that are user-owned, team-owned or organization-owned.

For a list of entities that you can enable for activity feeds, see Microsoft Dynamics CRM web application. On the nav bar, choose Microsoft Dynamics CRM > Settings. Click or tap Post Configurations. The Post Configurations area contains a list of entities that are configurable for activity feeds. You don’t need system administrator privileges to access the grid for viewing, but you do need administrator permissions to make modifications to items in the list, such as activating or deactivating post configurations for an entity or refreshing the list.

Auto post rules

You can programmatically enable or disable the post rules for an entity. These rules create localized, parameterized auto posts when events occur. For example, a post is created when an opportunity is added to an account, or a task is added to an opportunity.

For a list of the auto post rules available out-of-the-box, see Microsoft Dynamics CRM web application. On the nav bar, choose Microsoft Dynamics CRM > Settings. Click or tap Post Rule Configurations. For more information about how to activate and use auto post rules, see Sample: Collaborate with activity feeds.

Tip
To make data import run faster, deactivate auto post rules for entities that are being imported.

Plug-ins and workflows

The custom auto post rules in different user’s locales can’t be created programmatically. However, you can create auto posts (posts with the Source attribute set to “Auto Post”) by using plug-ins and workflows when events occur in Microsoft Dynamics CRM. With plug-ins and workflows you can create or delete posts, comments, and follows, or perform a specific action when posts, comments, or follows are created. For example, an email can be sent to the user when another user starts following him.

To mention a record in a post created by a workflow, use the dynamic values. For example, to mention a user who modified a post, use the following expression in the post entity Text field:
{Post URL(Dynamic)(Modified By (User))}
To add dynamic values, use the workflow designer Form Assistant in Microsoft Dynamics CRM Web workflow designer.

For more information about plug-ins and workflows, see Write plug-ins to extend business processes and Write workflows to automate business processes

Wall controls

The activity feeds walls are web resources that can be embedded in dashboards in context with relevant grids and visualizations. For example, you can embed the msdyn_/PersonalWall.htm web resource into a dashboard with specifying the HideUserProfile parameter. The default is value 1 (or, true), to hide the user profile, to unhide, use the value 0 (or, false). For more information about how to use web resources in dashboards, see Analyze Data with Dashboards. For more information about web resources, see Web Resources for Microsoft Dynamics CRM.

To learn more about available out-of-the-box wall controls, see Microsoft Dynamics CRM Help.

Lookup information for the post entity and post follow entity

You can add a post to a record or follow a record for the entities that are enabled for activity feeds. Normally, you can find a list of entities available for the lookup, such as the list of entities enabled for activity feeds, in the RegardingObjectId.Target property of the referencing entity. However, for the Post entity and the PostFollow entity, the RegardingObjectId.Target property isn’t supported. For these entities, to obtain a list of entity types for the lookup, retrieve the msdyn_PostConfig records that are in the active state (msdyn_PostConfig.StateCode = Active (value 0) and msdyn_PostConfig.StatusCode = Active ( value 1). For retrieval, use the RetrieveMultipleRequest message. The msdyn_PostConfig.EntityName attribute contains the logical name of the entity enabled for activity feeds that you can use for the lookup.

See Also

Concepts

msdyn_PostConfig (post configuration) entity messages and methods
msdyn_PostRuleConfig (post rule configuration) entity messages and methods
Introduction to activity feeds
Connect to Yammer

Other Resources

Activity feeds entities
Sample: Collaborate with activity feeds
Write plug-ins to extend business processes
Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Connect to Yammer

To enhance your organization’s collaboration, use Microsoft Dynamics CRM to connect directly to Yammer, a powerful tool for social networking in your company. Before you set up a connection to Yammer in Microsoft Dynamics CRM, you must purchase Yammer enterprise licenses for your organization, such as an Enterprise Network or SharePoint Online + Yammer account.

Note
Connecting to Yammer is a one-way process. After the connection is established, it can’t be removed.

Several attributes are available that support connection to Yammer. The msdyn_PostRuleConfig.msdyn_PostToYammer attribute determines whether certain auto posts are posted in CRM and Yammer, or only in CRM. Other attributes, intended for internal use only, are added to the Post, PostFollow, Organization, and SystemUser entities. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The description of the msdyn_PostRuleConfig.msdyn_PostToYammer attribute appears as “For internal use only” until you enable the Yammer connection. After the connection is enabled, the attribute’s description is updated in the metadata. The attributes exist in the databases of all deployments.

You’ll notice that, if you enable the Yammer connection, Activity Feeds behavior changes, as shown here:

  • User posts (manual posts) added through the CRM user interface are created and stored directly in Yammer. Existing user posts, created before the Yammer connection was enabled, aren’t migrated from CRM to Yammer.
  • Auto posts are created and stored in CRM.
    Note
    Selective auto posts are stored in Yammer in addition to CRM, if you set the msdyn_PostRuleConfig.msdyn_PostToYammer attribute to true. Some of the auto post rules for Yammer are enabled out-of-the-box. Other rules can be enabled by the administrator. To see the auto post rules that are available for Yammer in the CRM web application, on the nav bar, click or tap Microsoft Dynamics CRM > Settings > Post Rule Configurations. Click or tap the All Activity Feeds Rules drop-down list, and then click or tap All Yammer Rules.

  • Objects, except users, are followed in CRM and Yammer. You must enable the Yammer connection before you can follow an object in Yammer.
  • Users are only followed in Yammer. A user must have a valid Yammer account to be followed.
  • You can stop following an object in Microsoft Dynamics CRM programmatically or through the user interface. However, this doesn’t unfollow the object in Yammer. To stop following an object in Yammer, you have to use the Yammer user interface. You can’t unfollow an object in Yammer programmatically.

If you’re connected to Yammer, the RetrieveRecordWallRequest message and the RetrievePersonalWallRequest message return the following posts:

  • All auto posts.
  • User posts created by using the Yammer web application, before you enabled the connection to Yammer.
  • User posts created programmatically in Yammer before or after you enabled the connection to Yammer.

See Also

Concepts

Post entity messages and methods

Other Resources

Activity feeds entities
Collaborate and communicate with Yammer
Connect Microsoft Dynamics CRM to Yammer

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Post entity messages and methods

A post represents an activity feed post. The posts are divided into auto-posts and manual (user) posts.

An auto-post is created as a result of an event, such as a creation of an opportunity or an invoice. An example of a manual post is a user adding or updating information on the account’s record wall.

Information about whether the post was created by a user (manual post) or generated by the system (auto post) is contained in the Source attribute. If not specified, it is set to manual post. To specify a regarding record, use the Post.RegardingObjectId attribute.

The early bound class for this entity is Post. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message Description

CreateRequest

Creates a post. You can also call the IOrganizationService.Create method.

DeleteRequest

Deletes a post. You can also call the IOrganizationService.Delete method.

Note
When you delete a parent post, all child comments and likes for this post are also deleted.

RetrieveRequest

Retrieves a post. You can also call the IOrganizationService.Retrieve method.

RetrieveMultipleRequest

Retrieves a collection of posts. You can also call the IOrganizationService.RetrieveMultiple method.

Important
To retrieve a collection of posts with associated comments and likes, use the RetrieveRecordWallRequest message or the RetrievePersonalWallRequest message.

Note
The post entity is enabled for the bulk delete operation by default. You can schedule a bulk delete job to delete old or unnecessary manual and auto posts.

See Also

Reference

Post entity privileges

Concepts

PostComment (comment) entity messages and methods

Other Resources

Activity feeds entities
RetrieveRecordWallRequest
RetrievePersonalWallRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PostComment (comment) entity messages and methods

A post comment (comment) represents a comment on an activity feed post.

The early bound class for this entity is PostComment. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a post comment. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a post comment. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a post comment. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of post comments. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Reference

PostComment (comment) entity privileges

Concepts

PostFollow (follow) entity messages and methods

Other Resources

Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PostFollow (follow) entity messages and methods

A post follow (follow) represents that a user followed an object.

Note
The maximum number of records you can follow is 500.

If you create the PostFollow record for the account A and set the OwnerId on the PostFollow to the user B, then the user B follows the account A.

The early bound class for this entity is PostFollow. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a post follow. You can also call the IOrganizationService.Create method. A caller with the prvCreatePostFollow privilege and Basic access level (privilege depth) can create the PostFollow records to follow themselves. You must have the prvCreatePostFollow privilege and the prvAppendPostFollow privilege with the Local or Deep access level to follow other records.
DeleteRequest | Deletes a post follow. When you delete the PostFollow record, you perform an action of “unfollow” the record. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a post follow. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of post follows. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Reference

PostFollow (follow) entity privileges

Concepts

PostLike (like) entity messages and methods

Other Resources

Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PostLike (like) entity messages and methods

A post like (like) represents that a user liked an activity feed post.

The early bound class for this entity is PostLike. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a post like. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a post like. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a post like. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of post likes. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Reference

PostLike (like) entity privileges

Concepts

msdyn_PostAlbum (profile album) entity messages and methods

Other Resources

Activity feeds entities
Sample: Collaborate with activity feeds

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


msdyn_PostAlbum (profile album) entity messages and methods

A msdyn_PostAlbum (Profile Album) contains user profile images that are stored as attachments and displayed in posts.

The early bound class for this entity is msdyn_PostAlbum. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
DeleteRequest | Deletes an msdyn_PostAlbum record. You can also call the IOrganizationService.Delete method.
IsValidStateTransitionRequest | Checks if the state transition is valid.
RetrieveRequest | Retrieves an msdyn_PostAlbum record. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of msdyn_PostAlbum records. You can also call the IOrganizationService.RetrieveMultiple method.
Note
To upload or update a profile image, use Microsoft Dynamics CRM web application.

See Also

Reference

msdyn_PostAlbum (profile album) entity privileges

Concepts

msdyn_PostConfig (post configuration) entity messages and methods

Other Resources

Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


msdyn_PostConfig (post configuration) entity messages and methods

A msdyn_PostConfig (Post Configuration) contains activity feed configuration for an entity and is used to enable or disable an entity for activity feeds.

The early bound class for this entity is msdyn_PostConfig. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a msdyn_PostConfig record. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an msdyn_PostConfig record. You can also call the IOrganizationService.Delete method.
IsValidStateTransitionRequest | Checks if the state transition is valid.
RetrieveRequest | Retrieves an msdyn_PostConfig record. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of msdyn_PostConfig records. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of an msdyn_PostConfig record. The possible states are defined in the msdyn_PostConfig.State attribute. If you’re using early bound types, use the msdyn_PostConfigState enumeration. For a list of the state values, refer to the msdyn_PostConfig entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

See Also

Reference

msdyn_PostConfig (post configuration) entity privileges

Concepts

msdyn_PostRuleConfig (post rule configuration) entity messages and methods

Other Resources

Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


msdyn_PostRuleConfig (post rule configuration) entity messages and methods

An msdyn_PostRuleConfig (Post Rule Configuration) contains activity feed rule configuration for an entity and is used to enable or disable an auto post rule for an entity. The early bound class for this entity is msdyn_PostRuleConfig. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
DeleteRequest | Deletes an msdyn_PostRuleConfig record. You can also call the IOrganizationService.Delete method.
IsValidStateTransitionRequest | Checks if the state transition is valid.
RetrieveRequest | Retrieves an msdyn_PostRuleConfig record. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of msdyn_PostRuleConfig records. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of an msdyn_PostRuleConfig record. The possible states are defined in the msdyn_PostRuleConfig.State attribute. If you are using early bound types, use the msdyn_PostRuleConfigState enumeration. For a list of the state values, refer to the msdyn_PostRuleConfig entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

See Also

Reference

msdyn_PostRuleConfig (post rule configuration) entity privileges

Other Resources

Activity feeds entities
Sample: Collaborate with activity feeds

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Collaborate with activity feeds
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ActivityFeeds\WorkingWithActivityFeeds.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create posts with comments and mentions and how to follow Microsoft Dynamics CRM records. It also demonstrates how to retrieve information for the personal and record walls.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.ServiceModel;
using System.Threading;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to work with the new Activity Feeds entities, including Post,
    /// PostFollow, and PostComment.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class WorkingWithActivityFeeds
    {
        #region Local Sample Types
        private class InvalidSampleExecutionException : Exception
        {
            public InvalidSampleExecutionException(String message)
                : base(message)
            {
            }
        }
        #endregion Local Sample Types

        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private ServiceContext _serviceContext;
        private msdyn_PostConfig _originalLeadConfig;
        private msdyn_PostConfig _originalSystemUserConfig;
        private msdyn_PostConfig _systemuserConfig;
        private msdyn_PostConfig _leadConfig;
        private List<msdyn_PostRuleConfig> _postRuleConfigs =
            new List<msdyn_PostRuleConfig>();
        private Lead _lead1;
        private Lead _lead2;
        private Lead _lead3;
        private PostFollow _follow1;
        private PostFollow _follow2;
        private PostFollow _follow3;
        private List<EntityReference> _generatedEntities = new List<EntityReference>();
        private Post _post1;
        private Post _post2;
        private Post _post3;
        private Post _post4;
        private Post _leadPost1;
        #endregion Class Level Members

        #region How To Sample Code

        /// <summary>
        /// This method first connects to the Organization service. Afterwards, activity
        /// feeds are enabled, posts and comments are made to entity records and user
        /// walls and auto post rules are demonstrated.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();
                _serviceContext = new ServiceContext(_serviceProxy);

                try
                {
                    ConfigureActivityFeeds();
                    PostToRecordWalls();
                    PostToPersonalWalls();
                    ShowRecordWalls();
                    DeleteRequiredRecords(promptForDelete);
                }
                catch (InvalidSampleExecutionException e)
                {
                    Console.WriteLine(e.Message);
                    DeleteRequiredRecords(promptForDelete);
                }
            }
        }

        private void ConfigureActivityFeeds()
        {
            Console.WriteLine("== Configuring Activity Feeds ==");

            // Get the original systemuser config in order to keep a copy for reverting
            // after the sample has completed.
            _originalSystemUserConfig =
                (from c in _serviceContext.msdyn_PostConfigSet
                 where c.msdyn_EntityName == SystemUser.EntityLogicalName
                 select new msdyn_PostConfig
                 {
                     msdyn_PostConfigId = c.msdyn_PostConfigId,
                     msdyn_ConfigureWall = c.msdyn_ConfigureWall,
                     msdyn_EntityName = c.msdyn_EntityName
                 }).FirstOrDefault();

            // Retrieve or Create an instance of msdyn_PostConfig to enable activity
            // feeds for leads (or make sure they are already enabled).
            // If a new msdyn_PostConfig record gets created, activity feeds for
            // systemusers will be enabled automatically.
            _leadConfig =
                (from c in _serviceContext.msdyn_PostConfigSet
                 where c.msdyn_EntityName == Lead.EntityLogicalName
                 select new msdyn_PostConfig
                 {
                     msdyn_PostConfigId = c.msdyn_PostConfigId,
                     msdyn_EntityName = c.msdyn_EntityName,
                     msdyn_ConfigureWall = c.msdyn_ConfigureWall
                 }).FirstOrDefault();

            if (_leadConfig == null)
            {
                // Create the configuration record for leads.
                _leadConfig = new msdyn_PostConfig
                {
                    msdyn_EntityName = Lead.EntityLogicalName,
                    msdyn_ConfigureWall = true
                };

                _serviceContext.AddObject(_leadConfig);
                _serviceContext.SaveChanges();
                Console.WriteLine(
                    "  The lead activity feed wall configuration was created.");
            }
            else
            {
                // Store the original Lead Config so that we can revert changes later.
                _originalLeadConfig = CloneRelevantConfiguration(_leadConfig);

                if (!_leadConfig.msdyn_ConfigureWall.HasValue
                    || !_leadConfig.msdyn_ConfigureWall.Value)
                {
                    _leadConfig.msdyn_ConfigureWall = true;

                    _serviceContext.UpdateObject(_leadConfig);
                    _serviceContext.SaveChanges();
                    Console.WriteLine(
                        "  The lead activity feed wall was enabled.");
                }
            }

            // Get the original systemuser config in order to keep a copy for reverting
            // after the sample has completed.
            _systemuserConfig =
                (from c in _serviceContext.msdyn_PostConfigSet
                 where c.msdyn_EntityName == SystemUser.EntityLogicalName
                 select new msdyn_PostConfig
                 {
                     msdyn_PostConfigId = c.msdyn_PostConfigId,
                     msdyn_ConfigureWall = c.msdyn_ConfigureWall,
                     msdyn_EntityName = c.msdyn_EntityName
                 }).FirstOrDefault();

            // Ensure that the wall for systemuser is enabled if there is already a
            // systemuser configuration defined.
            if (_systemuserConfig != null &&
                (!_systemuserConfig.msdyn_ConfigureWall.HasValue
                || !_systemuserConfig.msdyn_ConfigureWall.Value))
            {
                _systemuserConfig.msdyn_ConfigureWall = true;

                _serviceContext.UpdateObject(_systemuserConfig);
                _serviceContext.SaveChanges();
                Console.WriteLine("  The systemuser activity feed wall was enabled.");
            }

            // Publish the lead and systemuser entities so that they will have record
            // walls on their forms.
            PublishSystemUserAndLead();

            // Activate the auto post rule configurations. New Lead qualified should be
            // activated automatically when the rule is generated by CRM.
            var leadRules =
                (from r in _serviceContext.msdyn_PostRuleConfigSet
                 where r.msdyn_RuleId == "LeadQualify.Yes.Rule"
                    || r.msdyn_RuleId == "LeadCreate.Rule"
                 select r).ToList();
            if (leadRules.Count() != 2)
            {
                throw new InvalidSampleExecutionException(
                "  One or both of the lead config rules do not exist. This can be fixed by deleting the lead post config.");
            }
            foreach (var configRule in leadRules)
            {
                _postRuleConfigs.Add(configRule);
                ActivateRuleConfig(configRule);
            }
        }

        private void PostToRecordWalls()
        {
            Console.WriteLine("\r\n== Working with Record Walls ==");
            // Create the leads.
            CreateRequiredRecords();

            // Follow each of the leads.
            _follow1 = new PostFollow
            {
                RegardingObjectId = _lead1.ToEntityReference()
            };
            _serviceContext.AddObject(_follow1);

            _follow2 = new PostFollow
            {
                RegardingObjectId = _lead2.ToEntityReference()
            };
            _serviceContext.AddObject(_follow2);

            _follow3 = new PostFollow
            {
                RegardingObjectId = _lead3.ToEntityReference()
            };
            _serviceContext.AddObject(_follow3);

            _serviceContext.SaveChanges();
            Console.WriteLine("  The 3 leads are now followed.");

            // Create posts, mentions, and comments related to the leads.
            // Create a post related to lead 1 with a mention and a comment.
            _leadPost1 = new Post
            {
                RegardingObjectId = _lead1.ToEntityReference(),
                Source = new OptionSetValue((int)PostSource.AutoPost),
                // Include a mention in the post text.
                Text = String.Format("This lead is similar to @[{0},{1},\"{2}\"]",
                    Lead.EntityTypeCode, _lead2.Id, _lead2.FullName)
            };

            _serviceContext.AddObject(_leadPost1);
            _serviceContext.SaveChanges();
            Console.WriteLine("  Post 1 has been created.");

            // It isn't necessary to keep track of the comment because the comment will
            // be deleted when its parent post is deleted.
            var comment1 = new PostComment
            {
                PostId = _leadPost1.ToEntityReference(),
                Text = "Sample comment 1"
            };
            _serviceContext.AddObject(comment1);
            _serviceContext.SaveChanges();
            Console.WriteLine("  Comment 1 has been created.");

            // Create a post related to lead 2 with three comments.
            var post2 = new Post
            {
                RegardingObjectId = _lead2.ToEntityReference(),
                Source = new OptionSetValue((int)PostSource.ManualPost),
                Text = "This lead was created for a sample."
            };

            _serviceContext.AddObject(post2);
            _serviceContext.SaveChanges();
            Console.WriteLine("  Post 2 has been created.");

            var comment2 = new PostComment
            {
                PostId = post2.ToEntityReference(),
                Text = "Sample comment 2"
            };

            var comment3 = new PostComment
            {
                PostId = post2.ToEntityReference(),
                Text = "Sample comment 3"
            };

            var comment4 = new PostComment
            {
                PostId = post2.ToEntityReference(),
                Text = "Sample comment 4"
            };

            _serviceContext.AddObject(comment2);
            _serviceContext.AddObject(comment3);
            _serviceContext.AddObject(comment4);
            _serviceContext.SaveChanges();
            Console.WriteLine("  Comments 2, 3, and 4 have been created.");

            // Qualify some leads.  Since there is an active post rule config for
            // qualification of a lead, this should generate an auto post to the record
            // wall of each lead that is qualified.

            // Qualify lead 2.
            var qualifyLead2Request = new QualifyLeadRequest
            {
                CreateAccount = true,
                LeadId = _lead2.ToEntityReference(),
                Status = new OptionSetValue((int)lead_statuscode.Qualified)
            };

            var qualifyLead2Response = (QualifyLeadResponse)_serviceProxy.Execute(
                qualifyLead2Request);

            // Store the generated Account to delete it later.
            foreach (var entityRef in qualifyLead2Response.CreatedEntities)
            {
                _generatedEntities.Add(entityRef);
            }

            Console.WriteLine("  Lead 2 was qualified.");

            // Qualify lead 3.
            var qualifyLead3Request = new QualifyLeadRequest
            {
                CreateAccount = true,
                LeadId = _lead3.ToEntityReference(),
                Status = new OptionSetValue((int)lead_statuscode.Qualified)
            };

            var qualifyLead3Response = (QualifyLeadResponse)_serviceProxy.Execute(
                qualifyLead3Request);

            foreach (var entityRef in qualifyLead3Response.CreatedEntities)
            {
                _generatedEntities.Add(entityRef);
            }

            Console.WriteLine("  Lead 3 was qualified.");
        }

        private void PostToPersonalWalls()
        {
            Console.WriteLine("\r\n== Working with Personal Walls ==");
            // Create manual (user) posts on a user's Personal wall.
            var whoAmIRequest = new WhoAmIRequest();
            var whoAmIResponse = (WhoAmIResponse)_serviceProxy.Execute(whoAmIRequest);
            var currentUserRef = new EntityReference(
                SystemUser.EntityLogicalName, whoAmIResponse.UserId);

            // Create a post that mentions lead 1.
            // The Regarding object should be set to the user whose wall the post should
            // be posted to (we'll just use the current user).
            _post1 = new Post
            {
                RegardingObjectId = currentUserRef,
                Source = new OptionSetValue((int)PostSource.ManualPost),
                Text = String.Format("I'd rather not pursue @[{0},{1},\"{2}\"]",
                    Lead.EntityTypeCode, _lead1.Id, _lead1.FullName)
            };

            _serviceContext.AddObject(_post1);
            _serviceContext.SaveChanges();
            Console.WriteLine("  Personal wall post 1 was created.");

            // Create a related comment.
            var comment1 = new PostComment
            {
                PostId = _post1.ToEntityReference(),
                Text = "Personal wall comment 1."
            };

            _serviceContext.AddObject(comment1);
            _serviceContext.SaveChanges();
            Console.WriteLine("  Personal wall comment 1 was created.");

            _post2 = new Post
            {
                RegardingObjectId = currentUserRef,
                Source = new OptionSetValue((int)PostSource.AutoPost),
                Text = "Personal wall post 2."
            };

            _serviceContext.AddObject(_post2);
            _serviceContext.SaveChanges();
            Console.WriteLine("  Personal wall post 2 was created.");

            // Create a few related comments.
            var comment2 = new PostComment
            {
                PostId = _post2.ToEntityReference(),
                Text = "Personal wall comment 2."
            };

            var comment3 = new PostComment
            {
                PostId = _post2.ToEntityReference(),
                Text = "Personal wall comment 3."
            };

            var comment4 = new PostComment
            {
                PostId = _post2.ToEntityReference(),
                Text = "Personal wall comment 4."
            };

            var comment5 = new PostComment
            {
                PostId = _post2.ToEntityReference(),
                Text = "Personal wall comment 5."
            };

            _serviceContext.AddObject(comment2);
            _serviceContext.AddObject(comment3);
            _serviceContext.AddObject(comment4);
            _serviceContext.AddObject(comment5);
            _serviceContext.SaveChanges();
            Console.WriteLine("  Personal wall comments 2, 3, 4, and 5 were created.");

            // Create a couple more posts just to show how paging works.
            _post3 = new Post
            {
                RegardingObjectId = currentUserRef,
                Source = new OptionSetValue((int)PostSource.ManualPost),
                Text = "Personal wall post 3."
            };

            _post4 = new Post
            {
                RegardingObjectId = currentUserRef,
                Source = new OptionSetValue((int)PostSource.AutoPost),
                Text = "Personal wall post 4."
            };

            _serviceContext.AddObject(_post3);
            _serviceContext.AddObject(_post4);
            _serviceContext.SaveChanges();
            Console.WriteLine("  Personal wall posts 3 and 4 were created.");

            // Retrieve this user's personal wall.
            // Retrieve the first page of posts.
            DisplayPersonalWallPage(1);

            // Retrieve the second page of posts.
            DisplayPersonalWallPage(2);

            // Sleep for a second so that the time of the newly created comment will
            // clearly be later than the previously created posts/comments (otherwise
            // Post 3 will not be escalated to the top of the wall).
            Thread.Sleep(1000);

            // Create a new comment on the last post, which will bring the post to the
            // top.
            var newPostComment = new PostComment
            {
                PostId = _post3.ToEntityReference(),
                Text = "New comment to show that new comments affect post ordering."
            };

            _serviceContext.AddObject(newPostComment);
            _serviceContext.SaveChanges();
            Console.WriteLine("\r\n  A new comment was created to show effects on post ordering.");

            // Display the first page of the personal wall to showcase the change in
            // ordering.  Post 3 should be at the top.
            DisplayPersonalWallPage(1);

            // Show paging of comments.
            // Retrieve comments 2 at a time, starting with page 1.
            var commentsQuery = new QueryExpression(PostComment.EntityLogicalName)
            {
                ColumnSet = new ColumnSet(true),
                Criteria = new FilterExpression(LogicalOperator.And),
                PageInfo = new PagingInfo
                {
                    Count = 2,
                    PageNumber = 1,
                    ReturnTotalRecordCount = true
                }
            };

            commentsQuery.Criteria.AddCondition(
                "postid", ConditionOperator.Equal, _post2.Id);

            // Continue querying for comments until there are no further comments to
            // be retrieved.
            EntityCollection commentsResult;
            do
            {
                commentsResult = _serviceProxy.RetrieveMultiple(commentsQuery);

                // Display the comments that we retrieved.
                Console.WriteLine("\r\n  Comments for lead 2 page {0}",
                    commentsQuery.PageInfo.PageNumber);
                foreach (PostComment comment in commentsResult.Entities)
                {
                    DisplayComment(comment);
                }

                commentsQuery.PageInfo.PageNumber += 1;
            }
            while (commentsResult.MoreRecords);
        }

        private void ShowRecordWalls()
        {
            Console.WriteLine("\r\n== Showing Record Walls ==");

            // Create a new post on one of the leads.
            var newLeadPost = new Post
            {
                Source = new OptionSetValue((int)PostSource.AutoPost),
                Text = "New lead post.",
                RegardingObjectId = _lead2.ToEntityReference(),
            };

            _serviceContext.AddObject(newLeadPost);
            _serviceContext.SaveChanges();
            Console.WriteLine("  The new lead 2 post has been created.");

            DisplayRecordWall(_lead1);
            DisplayRecordWall(_lead2);
            DisplayRecordWall(_lead3);
        }
        private void DisplayRecordWall(Lead lead)
        {
            // Display the first page of the record wall.
            var retrieveRecordWallReq = new RetrieveRecordWallRequest
            {
                Entity = lead.ToEntityReference(),
                CommentsPerPost = 2,
                PageSize = 10,
                PageNumber = 1
            };

            var retrieveRecordWallRes =
                (RetrieveRecordWallResponse)_serviceProxy.Execute(retrieveRecordWallReq);

            Console.WriteLine("\r\n  Posts for lead {0}:", lead.FullName);
            foreach (Post post in retrieveRecordWallRes.EntityCollection.Entities)
            {
                DisplayPost(post);
            }
        }

        private void DisplayPersonalWallPage(int pageNumber)
        {
            // Retrieve the page of posts.  We'll only retrieve 5 at a time so that
            // we will have more than one page.
            var pageSize = 5;

            var personalWallPageReq = new RetrievePersonalWallRequest
            {
                CommentsPerPost = 2,
                PageNumber = pageNumber,
                PageSize = pageSize
            };
            var personalWallPageRes =
                (RetrievePersonalWallResponse)_serviceProxy.Execute(personalWallPageReq);

            Console.WriteLine("\r\n  Personal Wall Page {0} Posts:", pageNumber);
            foreach (Post post in personalWallPageRes.EntityCollection.Entities)
            {
                DisplayPost(post);
            }
        }

        private void DisplayPost(Post post)
        {
            Console.WriteLine("    Post, {0}, {1}, {2}: {3}",
                post.CreatedBy.Name,
                (PostType)post.Type.Value,
                (PostSource)post.Source.Value,
                Shorten(post.Text));

            if (post.Post_Comments != null)
            {
                foreach (var comment in post.Post_Comments)
                {
                    DisplayComment(comment);
                }
            }
        }

        private void DisplayComment(PostComment comment)
        {
            Console.WriteLine("      Comment, {0}: {1}",
                        comment.CreatedBy.Name, Shorten(comment.Text));
        }

        private String Shorten(String x)
        {
            return x.Length > 33 ? x.Substring(0, 30) + "..." : x;
        }

        private void CreateRequiredRecords()
        {
            // Create leads for relating activity feed records to. Since there is an
            // active post rule config for creation of a new lead, creating the leads
            // should add an auto post to the record wall for each of the leads.
            _lead1 = new Lead
            {
                CompanyName = "A. Datum Corporation",
                FirstName = "Henriette",
                MiddleName = "Thaulow",
                LastName = "Andersen",
                Subject = "Activity Feeds Sample 1"
            };
            _serviceContext.AddObject(_lead1);

            _lead2 = new Lead
            {
                CompanyName = "Adventure Works",
                FirstName = "Mary",
                MiddleName = "Kay",
                LastName = "Andersen",
                Subject = "Activity Feeds Sample 2"
            };
            _serviceContext.AddObject(_lead2);

            _lead3 = new Lead
            {
                CompanyName = "Fabrikam, Inc.",
                FirstName = "Andrew",
                LastName = "Sullivan",
                Subject = "Activity Feeds Sample 3"
            };
            _serviceContext.AddObject(_lead3);

            _serviceContext.SaveChanges();

            var columnSet = new ColumnSet(true);
            _lead1 = (Lead)_serviceProxy.Retrieve(
                Lead.EntityLogicalName, _lead1.Id, columnSet);
            _lead2 = (Lead)_serviceProxy.Retrieve(
                Lead.EntityLogicalName, _lead2.Id, columnSet);
            _lead3 = (Lead)_serviceProxy.Retrieve(
                Lead.EntityLogicalName, _lead3.Id, columnSet);

            Console.WriteLine("  The leads have been created.");
        }

        private void ActivateRuleConfig(msdyn_PostRuleConfig qualifyLeadRule)
        {
            _serviceProxy.Execute(new SetStateRequest
            {
                EntityMoniker = qualifyLeadRule.ToEntityReference(),
                State = new OptionSetValue((int)msdyn_PostRuleConfigState.Active),
                Status = new OptionSetValue((int)msdyn_postruleconfig_statuscode.Active)
            });
        }

        private msdyn_PostConfig CloneRelevantConfiguration(msdyn_PostConfig config)
        {
            return new msdyn_PostConfig
            {
                msdyn_ConfigureWall = config.msdyn_ConfigureWall,
                msdyn_EntityName = config.msdyn_EntityName,
                msdyn_PostConfigId = config.msdyn_PostConfigId
            };
        }

        private void PublishSystemUserAndLead()
        {
            // The systemuser and lead entities must be published because otherwise the
            // record walls on the respective forms will not update.
            _serviceProxy.Execute(new PublishXmlRequest
            {
                ParameterXml = @"
                    <importexportxml>
                        <entities>
                            <entity>systemuser</entity>
                            <entity>lead</entity>
                        </entities>
                    </importexportxml>"
            });
            Console.WriteLine("  The systemuser and lead entities were published.");
        }

        private void DeleteRequiredRecords(bool prompt)
        {
            var toBeDeleted = true;
            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Handle reverting the configurations appropriately - delete them
                // if they did not exist before.  Otherwise update them to their
                // original values.  Lead must be reverted first since it must be deleted
                // first if systemuser is to be deleted.
                RevertPostConfig(_originalLeadConfig, _leadConfig);
                RevertPostConfig(_originalSystemUserConfig, _systemuserConfig);

                // Revert the form changes.
                PublishSystemUserAndLead();

                // Delete the leads.
                DeleteFromContext(_lead1);
                DeleteFromContext(_lead2);
                DeleteFromContext(_lead3);
                var saveResult = _serviceContext.SaveChanges();
                Console.WriteLine("  The leads have been deleted.");

                Console.WriteLine("  The post follow records were deleted with the leads.");
                Console.WriteLine("  Posts that were related to leads were deleted with the leads.");

                // Delete posts that aren't regarding entities that were deleted.
                DeleteFromContext(_post1);
                DeleteFromContext(_post2);
                DeleteFromContext(_post3);
                DeleteFromContext(_post4);
                _serviceContext.SaveChanges();
                Console.WriteLine("  Posts that weren't regarding deleted entities were deleted.");

                // Delete the generated entities.
                foreach (var entityRef in _generatedEntities)
                {
                    _serviceProxy.Delete(entityRef.LogicalName, entityRef.Id);
                }
                Console.WriteLine("  All generated entities have been deleted.");
            }
        }

        private void DeleteFromContext(Entity entity)
        {
            if (!_serviceContext.IsAttached(entity))
            {
                _serviceContext.Attach(entity);
            }
            _serviceContext.DeleteObject(entity);
            _serviceContext.SaveChanges();
        }

        private void RevertPostConfig(msdyn_PostConfig originalConfig,
            msdyn_PostConfig newConfig)
        {
            if (originalConfig != null)
            {
                // Revert the rule configs.
                foreach (var rule in _postRuleConfigs.Where(
                    x => x.msdyn_PostConfigId.Id == newConfig.msdyn_PostConfigId))
                {
                    // Set the state to the original value.
                    _serviceProxy.Execute(new SetStateRequest
                    {
                        EntityMoniker = rule.ToEntityReference(),
                        State = new OptionSetValue((int)rule.statecode),
                        Status = rule.statuscode
                    });
                }

                // Update the config to the values from the original config.
                // Make sure the context is not tracking the new config and is tracking
                // the original config.
                if (!_serviceContext.IsAttached(originalConfig))
                {
                    if (_serviceContext.IsAttached(newConfig))
                    {
                        _serviceContext.Detach(newConfig);
                    }
                    _serviceContext.Attach(originalConfig);
                }
                _serviceContext.UpdateObject(originalConfig);
                _serviceContext.SaveChanges();
                Console.WriteLine(
                    "  The {0} activity feed configuration was reverted.",
                    originalConfig.msdyn_EntityName);
            }
            else
            {
                _serviceProxy.Delete(newConfig.LogicalName,
                    newConfig.Id);
                Console.WriteLine(
                    "  The {0} activity feed configuration was deleted.",
                    newConfig.msdyn_EntityName);
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new WorkingWithActivityFeeds();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Introduction to activity feeds
Configure activity feeds
Post entity messages and methods
PostComment (comment) entity messages and methods
PostFollow (follow) entity messages and methods

Other Resources

Activity feeds entities
RetrievePersonalWallRequest
RetrieveRecordWallRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customer entities (account, contact)

The account and contact entities in Microsoft Dynamics CRM are essential for identifying and managing customers, selling products and services, and providing superior service to the customers. A customer address entity is used to store address and shipping information for a customer.

The account entity is one of the entities in Microsoft Dynamics CRM to which most other entities are attached or parented. In Microsoft Dynamics CRM, an account represents a company with which the business unit has a relationship. Information that is included in an account is all relevant contact information, company information, category, relationship type, and address information. Other information that applies includes the following items:

  • An account can be a parent to almost any other entity. This includes another account.
  • An account can be a standalone entity.
  • An account can have only one account as its parent.
  • Accounts can have multiple child accounts and child contacts.

Account management is one of the important concepts of business-to-business customer relationship management (CRM) because an organization wants to see all the activities they have with another company All these activities come together at the account level.

In Microsoft Dynamics CRM, a contact represents a person, usually an individual, with whom a business unit has a relationship, such as a customer, a supplier, or a colleague. The contact entity is one of the entities that most other entities are linked to. A contact can be a stand-alone entity. Included in this entity are professional, personal, and family information, and multiple addresses.

Both accounts and contacts are part of managing customers and are related to one another in the following ways:

  • A contact can be a parent to every other entity except accounts and contacts.
  • A contact can have only one account as its parent.
  • A contact can be marked as the primary contact person for an account by using the Update method.

The contact entity stores all information about a person such as an email address, street address, telephone numbers, and other related information, such as the birthday or anniversary date. Depending on the type of customers a business unit has, it needs either only contacts, or contacts and accounts, to give a full view of its customers.

The basic operations that you can perform on a contact include Create, Read, Update, and Delete.

Linking entities such as activities and notes to the contact entity lets user see all the communication the user has had with a customer, any actions the user has taken on behalf of the customer, and all information the user needs about the customer.

In This Section

Account entity messages and methods

Contact entity messages and methods

CustomerAddress (address) entity messages and methods

Related Sections

Model your business data

Business management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Account entity messages and methods

An account represents a person or business to which the salesperson sells a product or service. The schema name for this entity is Account. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an account to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Account entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates an account. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an account. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Account entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares an account with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
MergeRequest | Merges two accounts.
ModifyAccessRequest | Changes the access rights for an account previously shared with another security principal (user or team).
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves an account. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of accounts. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to an account.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to an account, and their access rights to the account.
RevokeAccessRequest | Removes all access to an account for the specified security principal (user or team).
SetStateRequest | Sets the state of an account. The possible states are defined in the Account.State attribute. If you are using early bound types, use the AccountState enumeration. For a list of the state values, refer to the Account entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an account. You can also call the IOrganizationService.Update method.

See Also

Reference

Account entity privileges

Concepts

Contact entity messages and methods

Other Resources

Customer entities (account, contact)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Contact entity messages and methods

A contact represents a person with whom a business unit has a relationship. For example, this could be a customer, a supplier, or a colleague. The schema name for this entity is Contact. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a contact to another user or team.
CreateRequest | Creates a contact. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a contact. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a contact with another security principal (user or team).
MergeRequest | Merges two contacts.
ModifyAccessRequest | Changes the access rights for a contact previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a contact. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of contacts. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a contact.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a contact, and their access rights to the contact.
RevokeAccessRequest | Removes all access to a contact for the specified security principal (user or team).
SetStateRequest | Sets the state of a contact. Sets the state of an account. The possible states are defined in the Contact.State attribute. If you are using early bound types, use the ContactState enumeration. For a list of the state values, refer to the contact entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a contact. You can also call the IOrganizationService.Update method.

See Also

Concepts

Contact entity privileges

Other Resources

Customer entities (account, contact)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CustomerAddress (address) entity messages and methods

A customer address represents address and shipping information. It is also used to store additional addresses for an account or contact. The schema name for this entity is CustomerAddress. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a customer address (address). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a customer address (address). You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a customer address (address). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of customer addresses. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a customer address (address). You can also call the IOrganizationService.Update method.

See Also

Concepts

CustomerAddress (address) entity privileges

Other Resources

Customer entities (account, contact)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Business management entities

The entities described in this section help you effectively manage the Microsoft Dynamics CRM application. This includes creating the relationships between entity records, setting up queues, and defining the fiscal periods for the organization.

In This Section

Connection entities

Customer relationship entities

Fiscal calendar and territory entities

Queue entities

Site entity

Subject entity

Time zone entities

Transaction Currency (currency) entity

Related Sections

Model your business data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Connection entities

The connections provide a flexible way to connect and describe the relationships between any two entity records Microsoft Dynamics CRM. It helps you to promote teamwork, collaboration, and effective management of business and sales processes. Connections enable you to easily associate users, contacts, quotes, sales orders, and many other entity records with each other. The records in the association can be assigned particular roles that help define the purpose of the relationship.

Connections provide the following capabilities:

  • An easy and flexible way to make a connection between two records of most Microsoft Dynamics CRM entity types. All customizable business and custom entities can be enabled for connections.
  • An option to add useful information, such as a description of the connection and the duration.
  • The ability to create connection roles that describe the relationship between two records, such as a relationship between a doctor and a patient, or a manager and an employee.
  • A quick way to create multiple connections and roles for a particular record. For example, a contact may have many relationships with other contacts, accounts, or contracts. In each relationship a contact may play a different role.
  • Information for building queries and creating graphs. You can search for all connections and connection roles for a particular record and create graphs and charts for visual representation of the connections.
  • Support for workflows and auditing for automating and improving business processes.

Enabling and creating connections

You can enable any custom or customizable entity for connection by updating the entity metadata. Use the UpdateEntityRequest message to set the IsConnectionsEnabled property to true.

To create a connection between two records, use the Connection entity. You must specify a record from which you create a connection (source) and a record to which you connect (target). Use the Connection.Record1Id attribute to specify the source entity record and the Connection.Record2Id attribute to specify the target entity record. Optionally, you can specify the duration of the connection and the description. To describe the relationship between the participants in the connection, use the connection roles. To specify the connection roles, use the Connection.Record1RoleId attribute and the Connection.Record2RoleId attribute.

Querying connections

Querying connections gives you valuable data that you can use to create reports, graphs, or charts. You can query connections by an entity record, by an entity type (Entity Type Code), by a particular role, or other criteria. The following are examples of how you can query connections:

By an entity record:

  • Show all connections for account A.
  • Show all roles for account A.

By an entity type (using Entity Type Codes):

  • Show all roles for the competitor entity.
  • Find the total number of roles for the account entity.

By a role:

  • Find all connections where account A is a “Vendor”.
  • Find all open opportunities over $20,000, where contact B is a “Salesperson”.
  • Find all matching roles for a “Doctor” role, such as “Patient”, “Nurse”, or “Medical Assistant”.
  • Find all contacts that have the role “Friend”.
Important
When you create a connection entity record, two records are created in the database. The first record represents a source to target connection and the second record represents a target to source connection. This guarantees that a query will find all connections that the record participates in, regardless whether the record is a source record or a target record in the connection.

See Also

Concepts

Describe a relationship between entities with connection roles
Connection entity messages and methods
ConnectionRole entity messages and methods
ConnectionRoleObjectTypeCode entity messages and methods
Fiscal calendar and territory entities

Other Resources

Sample code for connection entities
Business management entities
Customize visualizations and dashboards

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Describe a relationship between entities with connection roles

You can describe the relationship between records through the roles that you assign to them.

There are several ways you can use the connection roles in a connection:

  • Apply the same role to the source record and to the target record. A “friend”, a “team member”, or a “colleague” are examples of roles that could be applied to both records in the connection.
  • Apply a role to the source record or to the target record, but not to both. A “salesperson” role in a contact to opportunity connection is an example of such role. The records, such as opportunity, invoice, or sales order usually contain sufficient information about what they represent and do not require a role assigned to them.
  • Apply two matching roles (sometimes referred to as reciprocal roles). One role applies to a source record and the other role applies to a target record. A “doctor” and a “patient”, a “parent” and a “child” are examples of matching roles.

Connection Role Categories

When you create connection roles, you can specify what category they belong to. For example, you can use the following categories:

  • Business (supplier, buyer, competitor)
  • Family (father, sister, cousin)
  • Social (tennis partner, club member, friend)

The category list is customizable. You can add the categories that best fit your business model.

Create Connection Roles

To create a connection role you must specify the following information:

  • Use the ConnectionRole.Name attribute to specify a role name.
  • Use the ConnectionRole.Description attribute to add a role description.
  • Use the ConnectionRole.Category attribute to specify a role category. The possible values for this attribute are defined in the Category global option set.
  • When you create a connection role, you can specify an entity type that the role will be applied to, such as lead, account, or competitor. If you do not specify a particular entity type, then you can apply a connection role to all Microsoft Dynamics CRM entities. To specify the entity type, use the ConnectionRoleObjectTypeCode.AssociatedObjectTypeCode attribute. To link the connection role to a particular entity type, use the ConnectionRoleObjectTypeCode.ConnectionRoleId attribute. A connection role record can be referenced by multiple connection role object type code records. If you remove all references to the connection role record, you can apply this connection role to all Microsoft Dynamics CRM entities.

    Tip
    To find the connection roles for an account entity, in the query, specify all roles that are linked to the account entity (Entity Type Code = 1) or to all entities (Entity Type Code = 0).

Associate and Disassociate Connection Roles

To associate the roles in the connection, use the Associate method. To disassociate the roles, use the Disassociate method. For more information about the Associate message and the Disassociate message, see Introduction to entities in Microsoft Dynamics CRM.

See Also

Concepts

Connection entities
Connection entity messages and methods

Other Resources

Sample code for connection entities
Sample: Create a reciprocal connection role (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Connection entity messages and methods

A connection represents a relationship between two entities. The schema name for this entity is Connection. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a connection to another user or team.
CreateRequest | Creates a connection. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a connection. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a connection with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a connection previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a connection. You can also call the IOrganizationService.Delete method.
RetrieveMultipleRequest | Retrieves a collection of connections. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to a connection.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a connection, together with their access rights to the campaign.
RevokeAccessRequest | Removes all access rights to a connection for the specified security principal (user or team).
SetStateRequest | Sets the state of a connection. If you are using early bound types, use the ConnectionState enumeration to set the possible states. If you are using early bound types, use the ConnectionState enumeration. For a list of the state values, refer to the connection entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a connection. You can also call the IOrganizationService.Update method.

See Also

Concepts

Connection entities
Connection entity privileges
ConnectionRole entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConnectionRole entity messages and methods

A connection role describes a relationship between a two records. The schema name for this entity is ConnectionRole. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a connection role. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a connection role. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a connection role. You can also call the IOrganizationService.Delete method.
RetrieveMultipleRequest | Retrieves a collection of connection roles. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a connection role. If you are using early bound types, use the ConnectionRoleState enumeration. For a list of the state values, refer to the ConnectionRole entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a connection role. You can also call the IOrganizationService.Update method.

See Also

Concepts

Connection entities
ConnectionRole entity privileges
ConnectionRoleObjectTypeCode entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConnectionRoleObjectTypeCode entity messages and methods

A connection role object type code specifies the entity type to which a connection role can be applied. The schema name for this entity is ConnectionRoleObjectTypeCode. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a connection role object type code. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a connection role object type code. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a connection role object type code. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of connection role object type codes. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

Connection entities
ConnectionRoleObjectTypeCode entity privileges

Other Resources

Sample code for connection entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample code for connection entities

This section contains the code examples that show how to use the connection entities.

In This Section

Sample: Create a connection role (early bound)

Sample: Create a reciprocal connection role (early bound)

Sample: Update a connection role (early bound)

Sample: Create a connection (early bound)

Sample: Query connections by a record (early bound)

Sample: Query connection roles by entity type code (early bound)

Sample: Query connections by reciprocal roles (early bound)

Related Sections

Connection entities

Customer relationship entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a connection role (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. The sample code can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\CreateConnectionRole.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a connection role that can be used for accounts and contacts.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to set the connection role object type.
    /// </summary>
    public class CreateConnectionRole
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy  _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _connectionRoleId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create a new connectionrole instance and set the object type.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Define some anonymous types to define the range
                    // of possible connection property values.
                    var Categories = new
                    {
                        Business = 1,
                        Family = 2,
                        Social = 3,
                        Sales = 4,
                        Other = 5
                    };

                    // Create a Connection Role for account and contact
                    ConnectionRole newConnectionRole = new ConnectionRole
                    {
                        Name = "Example Connection Role",
                        Category = new OptionSetValue(Categories.Business)
                    };

                    _connectionRoleId = _serviceProxy.Create(newConnectionRole);
                    Console.WriteLine("Created {0}.", newConnectionRole.Name);

                    // Create a related Connection Role Object Type Code record for Account
                    ConnectionRoleObjectTypeCode newAccountConnectionRoleTypeCode
                        = new ConnectionRoleObjectTypeCode
                        {
                            ConnectionRoleId = new EntityReference(
                                ConnectionRole.EntityLogicalName, _connectionRoleId),
                            AssociatedObjectTypeCode = Account.EntityLogicalName
                        };

                    _serviceProxy.Create(newAccountConnectionRoleTypeCode);
                    Console.WriteLine(
                        "Created a related Connection Role Object Type Code record for Account.");

                    // Create a related Connection Role Object Type Code record for Contact
                    ConnectionRoleObjectTypeCode newContactConnectionRoleTypeCode
                        = new ConnectionRoleObjectTypeCode
                        {
                            ConnectionRoleId = new EntityReference(
                                ConnectionRole.EntityLogicalName, _connectionRoleId),
                            AssociatedObjectTypeCode = Contact.EntityLogicalName
                        };

                    _serviceProxy.Create(newContactConnectionRoleTypeCode);
                    Console.WriteLine(
                        "Created a related Connection Role Object Type Code record for Contact.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(ConnectionRole.EntityLogicalName, _connectionRoleId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateConnectionRole app = new CreateConnectionRole();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Connection entities

Other Resources

Sample code for connection entities
Sample: Create a reciprocal connection role (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a reciprocal connection role (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. This sample code can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\CreateReciprocalConnectionRole.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create the reciprocal connection roles. It creates a connection role for an account and a connection role for a contact, and then makes them reciprocal by associating them with each other.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This Sample shows how to create a reciprocal connection role.
    /// </summary>
    public class CreateReciprocalConnectionRole
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _connectionRole1Id;
        public Guid _connectionRole2Id;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create the connection role instances.
        /// Associate the connection roles.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Create the Connection Role 1
                    ConnectionRole newConnectionRole1 = new ConnectionRole
                    {
                        Name = "Example Connection Role 1",
                        Category = new OptionSetValue((int)connectionrole_category.Business),
                    };

                    _connectionRole1Id = _serviceProxy.Create(newConnectionRole1);
                    Console.WriteLine("Created {0}.", newConnectionRole1.Name);

                    // Create a related Connection Role Object Type Code record for Account
                    ConnectionRoleObjectTypeCode newAccountConnectionRole1TypeCode
                        = new ConnectionRoleObjectTypeCode
                        {
                            ConnectionRoleId = new EntityReference(
                                ConnectionRole.EntityLogicalName, _connectionRole1Id),
                            AssociatedObjectTypeCode = Account.EntityLogicalName
                        };

                    _serviceProxy.Create(newAccountConnectionRole1TypeCode);
                    Console.WriteLine(
                        "Created a related Connection Role 1 Object Type Code record for Account."
                        );

                    // Create a related Connection Role Object Type Code record for Contact
                    ConnectionRoleObjectTypeCode newContactConnectionRole1TypeCode
                        = new ConnectionRoleObjectTypeCode
                        {
                            ConnectionRoleId = new EntityReference(
                                ConnectionRole.EntityLogicalName, _connectionRole1Id),
                            AssociatedObjectTypeCode = Contact.EntityLogicalName
                        };

                    _serviceProxy.Create(newContactConnectionRole1TypeCode);
                    Console.WriteLine(
                        "Created a related Connection Role 1 Object Type Code record for Contact."
                        );

                    // Create the Connection Role 2
                    ConnectionRole newConnectionRole2 = new ConnectionRole
                    {
                        Name = "Example Connection Role 2",
                        Category = new OptionSetValue((int)connectionrole_category.Business),
                    };

                    _connectionRole2Id = _serviceProxy.Create(newConnectionRole2);
                    Console.WriteLine("Created {0}.", newConnectionRole2.Name);

                    // Create a related Connection Role 2 Object Type Code record for Account
                    ConnectionRoleObjectTypeCode newAccountConnectionRole2TypeCode
                        = new ConnectionRoleObjectTypeCode
                        {
                            ConnectionRoleId = new EntityReference(
                                ConnectionRole.EntityLogicalName, _connectionRole2Id),
                            AssociatedObjectTypeCode = Account.EntityLogicalName
                        };

                    _serviceProxy.Create(newAccountConnectionRole2TypeCode);
                    Console.WriteLine(
                        "Created a related Connection Role 2 Object Type Code record for Account."
                        );

                    // Create a related Connection Role 2 Object Type Code record for Contact
                    ConnectionRoleObjectTypeCode newContactConnectionRole2TypeCode
                        = new ConnectionRoleObjectTypeCode
                        {
                            ConnectionRoleId = new EntityReference(
                                ConnectionRole.EntityLogicalName, _connectionRole2Id),
                            AssociatedObjectTypeCode = Contact.EntityLogicalName
                        };

                    _serviceProxy.Create(newContactConnectionRole2TypeCode);
                    Console.WriteLine(
                        "Created a related Connection Role 2 Object Type Code record for Contact."
                        );
                    // Associate the connection roles
                     AssociateRequest associateConnectionRoles = new AssociateRequest
                    {
                        Target = new EntityReference(ConnectionRole.EntityLogicalName,
                            _connectionRole1Id),
                        RelatedEntities = new EntityReferenceCollection()
                        {
                            new EntityReference(ConnectionRole.EntityLogicalName,
                                _connectionRole2Id)
                        },
                        // The name of the relationship connection role association
                        // relationship in MS CRM
                        Relationship = new Relationship()
                        {
                            PrimaryEntityRole = EntityRole.Referencing, // Referencing or Referenced based on N:1 or 1:N reflexive relationship.
                            SchemaName = "connectionroleassociation_association"
                        }
                    };

                    _serviceProxy.Execute(associateConnectionRoles);
                    Console.WriteLine("Associated the connection roles.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
         public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(ConnectionRole.EntityLogicalName, _connectionRole1Id);
                _serviceProxy.Delete(ConnectionRole.EntityLogicalName, _connectionRole2Id);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateReciprocalConnectionRole app = new CreateReciprocalConnectionRole();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Connection entities

Other Resources

Sample code for connection entities
Sample: Update a connection role (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Update a connection role (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\UpdateConnectionRole.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to modify the properties of the connection role, such as a role name, description, and category.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This Sample shows how to update a connection role.
    /// </summary>
    public class UpdateConnectionRole
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy  _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _connectionRoleId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Call the method to create any data that this sample requires.
        /// Update the connectionrole instance.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Define some anonymous types to define the range
                    // of possible connection property values.
                    var Categories = new
                    {
                        Business = 1,
                        Family = 2,
                        Social = 3,
                        Sales = 4,
                        Other = 5
                    };

                    // Update the connectionrole instance.
                    ConnectionRole connectionRole = new ConnectionRole
                    {
                        ConnectionRoleId = _connectionRoleId,
                        Name = "Updated Connection Role",
                        Description = "This is an updated connection role.",
                        Category = new OptionSetValue(Categories.Other)
                    };

                    _serviceProxy.Update(connectionRole);

                    Console.WriteLine("Updated the connectionrole instance.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a new connectionrole instance.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Define some anonymous types to define the range
            // of possible connection property values.
            var Categories = new
            {
                Business = 1,
                Family = 2,
                Social = 3,
                Sales = 4,
                Other = 5
            };

            // Create a Connection Role
            ConnectionRole setupConnectionRole = new ConnectionRole
            {
                Name = "Example Connection Role",
                Description = "This is an example one sided connection role.",
                Category = new OptionSetValue(Categories.Business),
            };

            _connectionRoleId = _serviceProxy.Create(setupConnectionRole);
            Console.WriteLine("Created {0}.", setupConnectionRole.Name);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(ConnectionRole.EntityLogicalName, _connectionRoleId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                UpdateConnectionRole app = new UpdateConnectionRole();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Connection entities

Other Resources

Sample code for connection entities
Sample: Create a connection (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a connection (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\CreateConnection.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a connection between an account and a contact that have matching connection roles.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to create a connection between two entities.
    /// </summary>
    public class CreateConnection
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _connectionRoleId;
        public Guid _connectionId;
        public Guid _accountId;
        public Guid _contactId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Call the method to create any data that this sample requires.
        /// Create a new connection between the account and the contact.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
                /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Create a connection between the account and the contact.
                    // Assign a connection role to a record.
                    Connection newConnection = new Connection
                    {
                        Record1Id = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        Record1RoleId = new EntityReference(ConnectionRole.EntityLogicalName,
                            _connectionRoleId),
                        Record2RoleId = new EntityReference(ConnectionRole.EntityLogicalName,
                            _connectionRoleId),
                        Record2Id = new EntityReference(Contact.EntityLogicalName,
                            _contactId)
                    };

                    _connectionId = _serviceProxy.Create(newConnection);

                    Console.WriteLine(
                        "Created a connection between the account and the contact.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a new connectionrole instance.
        /// Create related Connection Role Object Type Code records
        /// for the account and the contact entities.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a Connection Role for account and contact
            ConnectionRole newConnectionRole = new ConnectionRole
            {
                Name = "Example Connection Role",
                Category = new OptionSetValue((int)connectionrole_category.Business)
            };

            _connectionRoleId = _serviceProxy.Create(newConnectionRole);
            Console.WriteLine("Created {0}.", newConnectionRole.Name);

            // Create a related Connection Role Object Type Code record for Account
            ConnectionRoleObjectTypeCode newAccountConnectionRoleTypeCode
                = new ConnectionRoleObjectTypeCode
                {
                    ConnectionRoleId = new EntityReference(
                        ConnectionRole.EntityLogicalName, _connectionRoleId),
                    AssociatedObjectTypeCode = Account.EntityLogicalName
                };

            _serviceProxy.Create(newAccountConnectionRoleTypeCode);
            Console.WriteLine(
                "Created a related Connection Role Object Type Code record for Account."
                );

            // Create a related Connection Role Object Type Code record for Contact
            ConnectionRoleObjectTypeCode newContactConnectionRoleTypeCode
                = new ConnectionRoleObjectTypeCode
                {
                    ConnectionRoleId = new EntityReference(
                        ConnectionRole.EntityLogicalName, _connectionRoleId),
                    AssociatedObjectTypeCode = Contact.EntityLogicalName
                };

            _serviceProxy.Create(newContactConnectionRoleTypeCode);
            Console.WriteLine(
                "Created a related Connection Role Object Type Code record for Contact."
                );

            // Associate the connection role with itself.
            AssociateRequest associateConnectionRoles = new AssociateRequest
            {
                Target = new EntityReference(ConnectionRole.EntityLogicalName,
                    _connectionRoleId),
                RelatedEntities = new EntityReferenceCollection()
                        {
                            new EntityReference(ConnectionRole.EntityLogicalName,
                                _connectionRoleId)
                        },
                // The name of the relationship connection role association
                // relationship in MS CRM.
                Relationship = new Relationship()
                {
                    PrimaryEntityRole = EntityRole.Referencing, // Referencing or Referenced based on N:1 or 1:N reflexive relationship.
                    SchemaName = "connectionroleassociation_association"
                }
            };

            _serviceProxy.Execute(associateConnectionRoles);
            Console.WriteLine("Associated the connection role with itself.");

            // Create an Account
            Account setupAccount = new Account { Name = "Example Account" };
            _accountId = _serviceProxy.Create(setupAccount);
            Console.WriteLine("Created {0}.", setupAccount.Name);

            // Create a Contact
            Contact setupContact = new Contact { LastName = "Example Contact" };
            _contactId = _serviceProxy.Create(setupContact);
            Console.WriteLine("Created {0}.", setupContact.LastName);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(Connection.EntityLogicalName, _connectionId);
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
                _serviceProxy.Delete(Contact.EntityLogicalName, _contactId);
                _serviceProxy.Delete(ConnectionRole.EntityLogicalName, _connectionRoleId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateConnection app = new CreateConnection();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Connection entities

Other Resources

Sample code for connection entities
Sample: Query connection roles by entity type code (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Query connections by a record (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. You can find it in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\QueryConnections.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to query connections for a particular record. It creates connections between a contact and two accounts, and then searches for the contact’s connections.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This Sample shows how to query connections.
    /// </summary>
    public class QueryConnections
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _connectionRoleId;
        public Guid _account1Id;
        public Guid _account2Id;
        public Guid _contactId;
        public Guid _connection1Id;
        public Guid _connection2Id;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Call the method to create any data that this sample requires.
        /// Query the connections.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
                /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // This query retrieves all connections this contact is part of.
                    QueryExpression query = new QueryExpression
                    {
                        EntityName = Connection.EntityLogicalName,
                        ColumnSet = new ColumnSet("connectionid"),
                        Criteria = new FilterExpression
                        {
                            FilterOperator = LogicalOperator.And,
                            Conditions =
                        {
                            // You can safely query against only record1id or
                            // record2id - CRM will find all connections this
                            // entity is a part of either way.
                            new ConditionExpression
                            {
                                AttributeName = "record1id",
                                Operator = ConditionOperator.Equal,
                                Values = { _contactId }
                            }
                        }
                        }
                    };

                    EntityCollection results = _serviceProxy.RetrieveMultiple(query);

                    // TODO: Here you could do a variety of tasks with the
                    // connections retrieved, such as listing the connected entities,
                    // finding reciprocal connections, etc.

                    Console.WriteLine("Retrieved {0} connectionrole instances.", results.Entities.Count);

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a new connectionrole instance.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Define some anonymous types to define the range
            // of possible connection property values.
            var Categories = new
            {
                Business = 1,
                Family = 2,
                Social = 3,
                Sales = 4,
                Other = 5
            };

            // Create a Connection Role
            ConnectionRole setupConnectionRole = new ConnectionRole
            {
                Name = "Example Connection Role",
                Description = "This is an example one sided connection role.",
                Category = new OptionSetValue(Categories.Business),
            };

            _connectionRoleId = _serviceProxy.Create(setupConnectionRole);
            Console.WriteLine("Created {0}.", setupConnectionRole.Name);

            // Create a related Connection Role Object Type Code record for Account
            ConnectionRoleObjectTypeCode newAccountConnectionRoleTypeCode
                = new ConnectionRoleObjectTypeCode
                {
                    ConnectionRoleId = new EntityReference(
                        ConnectionRole.EntityLogicalName, _connectionRoleId),
                    AssociatedObjectTypeCode = Account.EntityLogicalName
                };

            _serviceProxy.Create(newAccountConnectionRoleTypeCode);
            Console.WriteLine(
                "Created a related Connection Role Object Type Code record for Account."
                );

            // Create a related Connection Role Object Type Code record for Contact
            ConnectionRoleObjectTypeCode newContactConnectionRoleTypeCode
                = new ConnectionRoleObjectTypeCode
                {
                    ConnectionRoleId = new EntityReference(
                        ConnectionRole.EntityLogicalName, _connectionRoleId),
                    AssociatedObjectTypeCode = Contact.EntityLogicalName
                };

            _serviceProxy.Create(newContactConnectionRoleTypeCode);
            Console.WriteLine(
                "Created a related Connection Role Object Type Code record for Contact."
                );

            //Create a few account records for use in the connections.
            Account setupAccount1 = new Account { Name = "Example Account 1" };
            _account1Id = _serviceProxy.Create(setupAccount1);
            Console.WriteLine("Created {0}.", setupAccount1.Name);

            Account setupAccount2 = new Account { Name = "Example Account 2" };
            _account2Id = _serviceProxy.Create(setupAccount2);
            Console.WriteLine("Created {0}.", setupAccount2.Name);

            //Creates a contact used in the connection.
            Contact setupContact = new Contact { LastName = "Example Contact" };
            _contactId = _serviceProxy.Create(setupContact);
            Console.WriteLine("Created {0}.", setupContact.LastName);

            // Create a new connection between Account 1 and the contact record.
            Connection newConnection1 = new Connection
            {
                Record1Id = new EntityReference(Account.EntityLogicalName,
                    _account1Id),
                Record1RoleId = new EntityReference(ConnectionRole.EntityLogicalName,
                    _connectionRoleId),
                Record2Id = new EntityReference(Contact.EntityLogicalName,
                    _contactId)
            };

            _connection1Id = _serviceProxy.Create(newConnection1);

            Console.WriteLine(
                    "Created a connection between the account 1 and the contact.");

            // Create a new connection between the contact and Account 2 record
            Connection newConnection2 = new Connection
            {
                Record1Id = new EntityReference(Contact.EntityLogicalName,
                    _contactId),
                Record1RoleId = new EntityReference(ConnectionRole.EntityLogicalName,
                    _connectionRoleId),
                Record2Id = new EntityReference(Account.EntityLogicalName,
                    _account2Id)
            };

            _connection2Id = _serviceProxy.Create(newConnection2);

            Console.WriteLine(
                    "Created a connection between the contact and the account 2.");

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Connection.EntityLogicalName, _connection1Id);
                _serviceProxy.Delete(Connection.EntityLogicalName, _connection2Id);
                _serviceProxy.Delete(Account.EntityLogicalName, _account1Id);
                _serviceProxy.Delete(Account.EntityLogicalName, _account2Id);
                _serviceProxy.Delete(Contact.EntityLogicalName, _contactId);
                _serviceProxy.Delete(ConnectionRole.EntityLogicalName, _connectionRoleId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                QueryConnections app = new QueryConnections();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Connection entities

Other Resources

Sample code for connection entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Query connection roles by entity type code (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\QueryConnectionRolesByEntityTypeCode.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to use a query to find a connection role for an account entity by specifying an entity type code.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to find connection roles by object type code.
    /// </summary>
    public class QueryConnectionRolesByEntityTypeCode
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _connectionRoleId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This sample creates a role that is not linked to any entity type. All
        /// connection roles that apply to all are found and shown. Then the role is
        /// linked to the account entity and it is demonstrated that the role only works
        /// for accounts at this point, not for all. Subsequently the link to the account
        /// entity is removed and it is shown that the role is now applicable to all
        /// entities again.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Define some anonymous types to define the range
                    // of possible connection property values.
                    var Categories = new
                    {
                        Business = 1,
                        Family = 2,
                        Social = 3,
                        Sales = 4,
                        Other = 5
                    };

                    // Create a Connection Role.
                    ConnectionRole setupConnectionRole = new ConnectionRole
                    {
                        Name = "Example Connection Role",
                        Category = new OptionSetValue(Categories.Business),
                    };

                    _connectionRoleId = _serviceProxy.Create(setupConnectionRole);
                    setupConnectionRole.Id = _connectionRoleId;

                    Console.WriteLine("Created {0}.", setupConnectionRole.Name);

                    // Query for all Connection Roles.
                    QueryExpression allQuery = new QueryExpression
                    {
                        EntityName = ConnectionRole.EntityLogicalName,
                        ColumnSet = new ColumnSet("connectionroleid", "name"),
                        Distinct = true,
                        LinkEntities =
                        {
                            new LinkEntity
                            {
                                LinkToEntityName =
                                ConnectionRoleObjectTypeCode.EntityLogicalName,
                                LinkToAttributeName = "connectionroleid",
                                LinkFromEntityName = ConnectionRole.EntityLogicalName,
                                LinkFromAttributeName = "connectionroleid",
                                LinkCriteria = new FilterExpression
                                {
                                    FilterOperator = LogicalOperator.And,
                                    // Set a condition to only get connection roles
                                    // related to all entities (object type code = 0).
                                    Conditions =
                                    {
                                        new ConditionExpression
                                        {
                                             AttributeName = "associatedobjecttypecode",
                                             Operator = ConditionOperator.Equal,
                                             Values = { 0 }
                                        }
                                    }
                                }
                            }
                        }
                    };

                    EntityCollection results = _serviceProxy.RetrieveMultiple(allQuery);

                    // Here you could perform operations on all of
                    // the connectionroles found by the query.

                    Console.WriteLine("Retrieved {0} unassociated connectionrole instance(s).",
                        results.Entities.Count);

                    // Query to find roles which apply only to accounts.
                    QueryExpression accountQuery = new QueryExpression
                    {
                        EntityName = ConnectionRole.EntityLogicalName,
                        ColumnSet = new ColumnSet("connectionroleid", "name"),
                        Distinct = true,
                        LinkEntities =
                        {
                            new LinkEntity
                            {
                                LinkToEntityName =
                                ConnectionRoleObjectTypeCode.EntityLogicalName,
                                LinkToAttributeName = "connectionroleid",
                                LinkFromEntityName = ConnectionRole.EntityLogicalName,
                                LinkFromAttributeName = "connectionroleid",
                                LinkCriteria = new FilterExpression
                                {
                                    FilterOperator = LogicalOperator.And,
                                    // Set a condition to only get connection roles
                                    // related to accounts (object type code = 1).
                                    Conditions =
                                    {
                                        new ConditionExpression
                                        {
                                             AttributeName = "associatedobjecttypecode",
                                             Operator = ConditionOperator.In,
                                             Values = { Account.EntityLogicalName }
                                        }
                                    }
                                }
                            }
                        }
                    };

                    results = _serviceProxy.RetrieveMultiple(accountQuery);

                    Console.WriteLine("Retrieved {0} account-only connectionrole instance(s).",
                        results.Entities.Count);

                    // Create a related Connection Role Object Type Code record for
                    // Account.
                    ConnectionRoleObjectTypeCode setupAccountConnectionRoleTypeCode
                        = new ConnectionRoleObjectTypeCode
                        {
                            ConnectionRoleId = new EntityReference(
                                ConnectionRole.EntityLogicalName, _connectionRoleId),
                            AssociatedObjectTypeCode = Account.EntityLogicalName
                        };

                    setupAccountConnectionRoleTypeCode.Id =
                        _serviceProxy.Create(setupAccountConnectionRoleTypeCode);

                    Console.Write("Created a related Connection Role Object Type Code");
                    Console.Write(" record for Account.");

                    // Run the query to find unassociated connectionroles again.
                    results = _serviceProxy.RetrieveMultiple(allQuery);

                    Console.WriteLine(@"Retrieved {0} unassociated connectionrole instance(s).",
                        results.Entities.Count);

                    // Run the account-only query again.
                    results = _serviceProxy.RetrieveMultiple(accountQuery);

                    Console.WriteLine("Retrieved {0} account-only connectionrole instance(s).",
                        results.Entities.Count);

                    // Remove the link from account entity.
                    _serviceProxy.Delete(ConnectionRoleObjectTypeCode.EntityLogicalName,
                        setupAccountConnectionRoleTypeCode.Id);

                    Console.WriteLine("Removed link from connectionrole to account entity.");

                    // Run the query to find unassociated connectionroles again.
                    results = _serviceProxy.RetrieveMultiple(allQuery);

                    Console.WriteLine("Retrieved {0} unassociated connectionrole instance(s).",
                        results.Entities.Count);

                    // Run the account-only query again.
                    results = _serviceProxy.RetrieveMultiple(accountQuery);

                    Console.WriteLine("Retrieved {0} account-only connectionrole instance(s).",
                        results.Entities.Count);

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete(ConnectionRole.EntityLogicalName, _connectionRoleId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                QueryConnectionRolesByEntityTypeCode app = new QueryConnectionRolesByEntityTypeCode();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                           null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Connection entities

Other Resources

Sample code for connection entities
Sample: Query connections by reciprocal roles (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Query connections by reciprocal roles (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. The sample can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\QueryConnectionRolesByReciprocalRole.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create matching roles and then find a matching role for a particular role.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to find connection roles by a reciprocal connectionrole.
    /// </summary>
    public class QueryConnectionRolesByReciprocalRole
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _primaryConnectionRoleId;
        public Guid _reciprocalConnectionRoleId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Call the method to create any data that this sample requires.
        /// Query all connection roles that have this role listed as a reciprocal role.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // This query retrieves all connection roles that have this role
                    // listed as a reciprocal role.
                    QueryExpression query = new QueryExpression
                    {
                        EntityName = ConnectionRole.EntityLogicalName,
                        ColumnSet = new ColumnSet("connectionroleid"),
                        LinkEntities =
                    {
                        new LinkEntity
                        {
                            JoinOperator = JoinOperator.Inner,
                            LinkFromEntityName =  ConnectionRole.EntityLogicalName,
                            LinkFromAttributeName = "connectionroleid",
                            LinkToEntityName = "connectionroleassociation",
                            LinkToAttributeName = "connectionroleid",
                            LinkCriteria = new FilterExpression
                            {
                                FilterOperator = LogicalOperator.And,
                                Conditions =
                                {
                                    new ConditionExpression
                                    {
                                        AttributeName = "associatedconnectionroleid",
                                        Operator = ConditionOperator.Equal,
                                        Values = { _reciprocalConnectionRoleId }
                                    }
                                }
                            }
                        }
                    }
                    };

                    EntityCollection results = _serviceProxy.RetrieveMultiple(query);

                    // TODO: Here you would perform some operation on the retrieved
                    // roles.

                    Console.WriteLine("Retrieved {0} connectionrole instance.", results.Entities.Count);

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a primary connection role instance.
        /// Create a reciprocal connection role instance.
        /// Associate the connection roles.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Define some anonymous types to define the range
            // of possible connection property values.
            var Categories = new
            {
                Business = 1,
                Family = 2,
                Social = 3,
                Sales = 4,
                Other = 5
            };

            // Create the Connection Roles.
            // Create the primary connection Role instance.
            ConnectionRole setupPrimaryConnectionRole = new ConnectionRole
            {
                Name = "Example Primary Connection Role",
                Category = new OptionSetValue(Categories.Business),
            };

            _primaryConnectionRoleId = _serviceProxy.Create(setupPrimaryConnectionRole);
            Console.WriteLine("Created {0}.", setupPrimaryConnectionRole.Name);

            // Create a related Connection Role Object Type Code record for Account
            // on the primary role.
            ConnectionRoleObjectTypeCode accountPrimaryConnectionRoleTypeCode
                = new ConnectionRoleObjectTypeCode
                {
                    ConnectionRoleId = new EntityReference(
                        ConnectionRole.EntityLogicalName, _primaryConnectionRoleId),
                    AssociatedObjectTypeCode = Account.EntityLogicalName
                };

            _serviceProxy.Create(accountPrimaryConnectionRoleTypeCode);
            Console.WriteLine(@"Created a related Connection Role Object Type Code
                                record for Account on the primary role.");

            // Create another Connection Role.
            ConnectionRole setupReciprocalConnectionRole = new ConnectionRole
            {
                Name = "Example Reciprocal Connection Role",
                Category = new OptionSetValue(Categories.Business),
            };

            _reciprocalConnectionRoleId = _serviceProxy.Create(setupReciprocalConnectionRole);
            Console.WriteLine("Created {0}.", setupReciprocalConnectionRole.Name);

            // Create a related Connection Role Object Type Code record for Account
            // on the related role.
            ConnectionRoleObjectTypeCode accountReciprocalConnectionRoleTypeCode
                = new ConnectionRoleObjectTypeCode
                {
                    ConnectionRoleId = new EntityReference(
                        ConnectionRole.EntityLogicalName, _reciprocalConnectionRoleId),
                    AssociatedObjectTypeCode = Account.EntityLogicalName
                };

            _serviceProxy.Create(accountReciprocalConnectionRoleTypeCode);
            Console.WriteLine(@"Created a related Connection Role Object Type Code
                                record for Account on the related role.");

            // Associate the connection roles.
            AssociateRequest associateConnectionRoles =
                new AssociateRequest
                {
                    Target = new EntityReference(ConnectionRole.EntityLogicalName,
                        _primaryConnectionRoleId),
                    RelatedEntities = new EntityReferenceCollection()
                    {
                        new EntityReference(ConnectionRole.EntityLogicalName,
                        _reciprocalConnectionRoleId)
                    },
                    // The name of the relationship connection role association
                    // relationship in MS CRM
                    Relationship = new Relationship()
                    {
                        PrimaryEntityRole = EntityRole.Referencing, // Referencing or Referenced based on N:1 or 1:N reflexive relationship.
                        SchemaName = "connectionroleassociation_association"
                    }
                };

            _serviceProxy.Execute(associateConnectionRoles);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(ConnectionRole.EntityLogicalName, _primaryConnectionRoleId);
                _serviceProxy.Delete(ConnectionRole.EntityLogicalName, _reciprocalConnectionRoleId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                QueryConnectionRolesByReciprocalRole app = new QueryConnectionRolesByReciprocalRole();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Connection entities

Other Resources

Sample code for connection entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customer relationship entities

The customer relationship entities are not supported in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update or future versions of Microsoft Dynamics CRM. To create relationships between the entities in Microsoft Dynamics CRM, use Connection entities.

See Also

Other Resources

Business management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Fiscal calendar and territory entities

You can use the fiscal calendar entities and the territory entity to track sales information for a salesperson. A salesperson is a user in Microsoft Dynamics CRM who has to meet sales objectives, such as sales quotas. A territory is a geographical area that is assigned to a salesperson. The fiscal calendar entities define sales quotas for a salesperson. A quota is a revenue objective for a salesperson. A quota is defined as a specific currency amount for a particular fiscal period. A fiscal calendar is a span of time during which the financial activities of an organization are calculated. A fiscal year is divided into fiscal periods, typically defined as semesters, quarters, or months. Depending on the fiscal year settings that are defined by the Organization entity, you can use one of the following fiscal calendar entities to set the sales quotas: AnnualFiscalCalendar, FixedMonthlyFiscalCalendar, MonthlyFiscalCalendar, QuarterlyFiscalCalendar, and SemiAnnualFiscalCalendar. Each of these entities has one or more money type attributes that you can use to specify a quota for a particular time period. For example, to set a quota for a full fiscal year period, use the AnnualFiscalCalendar.Period1 attribute. To set monthly quotas, use the MonthlyFiscalCalendar entity that contains twelve periods.

Important
The create action (IOrganizationService.Create method and CreateRequest message) for fiscal calendar entities is deprecated in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. We encourage you to use new goal management entities for setting sales quotas. The goal management entities are much more versatile and offer many more capabilities than the fiscal calendar entities.

See Also

Concepts

Territory entity messages and methods
AnnualFiscalCalendar entity messages and methods
FixedMonthlyFiscalCalendar entity messages and methods
MonthlyFiscalCalendar entity messages and methods
QuarterlyFiscalCalendar entity messages and methods
SemiAnnualFiscalCalendar entity messages and methods
Organization entities
Queue entities

Other Resources

Business management entities
Goal management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Territory entity messages and methods

A territory represents a sales region. The schema name for this entity is Territory. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a territory. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a territory. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a territory. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of territories. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a territory. You can also call the IOrganizationService.Update method.

See Also

Concepts

Territory entity privileges
Fiscal calendar and territory entities
AnnualFiscalCalendar entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AnnualFiscalCalendar entity messages and methods

An annual fiscal calendar represents a year-long fiscal calendar of an organization. This is a span of time during which the financial activities of an organization are calculated. The schema name for this entity is AnnualFiscalCalendar. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
DeleteRequest | Deletes a fiscal calendar. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a fiscal calendar. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of fiscal calendars. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a fiscal calendar. You can also call the IOrganizationService.Update method.

See Also

Reference

AnnualFiscalCalendar entity privileges

Concepts

Fiscal calendar and territory entities
FixedMonthlyFiscalCalendar entity messages and methods

Other Resources

Goal management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FixedMonthlyFiscalCalendar entity messages and methods

A fixed monthly fiscal calendar represents a span of time during which the financial activities of an organization are calculated. The schema name for this entity is FixedMonthlyFiscalCalendar. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
DeleteRequest | Deletes a fiscal calendar. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a fiscal calendar. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of fiscal calendars. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a fiscal calendar. You can also call the IOrganizationService.Update method.

See Also

Concepts

Fiscal calendar and territory entities
FixedMonthlyFiscalCalendar entity privileges
MonthlyFiscalCalendar entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


MonthlyFiscalCalendar entity messages and methods

A monthly fiscal calendar represents a monthly fiscal calendar of an organization. This is a span of time during which the financial activities of an organization are calculated. The schema name for this entity is MonthlyFiscalCalendar. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
DeleteRequest | Deletes a fiscal calendar. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a fiscal calendar. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of fiscal calendars. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a fiscal calendar. You can also call the IOrganizationService.Update method.

See Also

Concepts

Fiscal calendar and territory entities
MonthlyFiscalCalendar entity privileges
QuarterlyFiscalCalendar entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QuarterlyFiscalCalendar entity messages and methods

A quarterly fiscal calendar represents a span of time during which the financial activities of an organization are calculated. The schema name for this entity is QuarterlyFiscalCalendar. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
DeleteRequest | Deletes a fiscal calendar. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a fiscal calendar. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of fiscal calendars. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a fiscal calendar. You can also call the IOrganizationService.Update method.

See Also

Concepts

Fiscal calendar and territory entities
QuarterlyFiscalCalendar entity privileges
SemiAnnualFiscalCalendar entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SemiAnnualFiscalCalendar entity messages and methods

An semiannual fiscal calendar represents a half yearly fiscal calendar of an organization. This is a span of time during which the financial activities of an organization are calculated. The schema name for this entity is SemiAnnualFiscalCalendar. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
DeleteRequest | Deletes a fiscal calendar. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a fiscal calendar. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of fiscal calendars. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a fiscal calendar. You can also call the IOrganizationService.Update method.

See Also

Concepts

Fiscal calendar and territory entities
SemiAnnualFiscalCalendar entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Queue entities

Queues are instrumental in organizing, prioritizing, and monitoring the progress of your work while you are using Microsoft Dynamics CRM. As a central location for work management, queues assist you in processing cases, responding to service calls, or sending out product information to prospective customers. Programmatically, a queue is a collection of queue items. A queue item serves as a container for an entity record, such as a task, an email, or a case that needs processing.

Note
The capabilities of queues was enhanced in Microsoft Dynamics CRM 2013 Service Pack 1 (SP1) (on-premises) and CRM Online Spring ‘14. For details about what was added from earlier versions, see the Dynamics CRM 2013 version of this topic.

The following information pertains to queues:

  • All customizable entities can be enabled for queues.
  • Queues may be public or private. Private queue items are only visible to the members of the queue.
  • A private queue is automatically created for each new user or team.
  • A queue can contain multiple entity types, such as tasks, emails, or cases.
  • A queue contains information about the user who is working on a particular queue item. This helps you manage your resources more efficiently and helps to prevent duplication of work.
  • Queues can be enabled for workflows and audit. This helps improve productivity and track the entity and attribute data changes for future analysis and reporting.

In This Topic

Members capabilities

Public and private queues

Attributes used to manage queues

Restrictions on deleting queues

Enable entities for queues

Inherit privileges and provide limited access to a queue

Actions on queues and queue items

Members capabilities

Queues are categorized into public or private queues. Private queues have individual users as members to make controlling access to queues easier. If you add a team to a private queue, all the members of that team become members of the private queue.

Public and private queues

The QueueViewType attribute is a picklist that defines whether a queue is public or private.

  • All user queues are private queues for the user: Only the user will be able to see queue items in their private queue.
  • Team queues are marked as private with members: the team owner and all team members will be able to see the queue in the application.
  • All other queues are public. Everyone with read privileges for the queue entity will be able to see these queues.

Attributes used to manage queues

Use the following attributes to manage queues.

SchemaName | DisplayName | Type | Description
NumberOfItems | Queue Items | Integer | Number of Queue items associated with the queue.
NumberOfMembers | No. of Members | Integer | Number of Members associated with the queue.
QueueViewType | Type | Picklist | Select whether the queue is public or private. A public queue can be viewed by all. A private queue can be viewed only by the members added to the queue.

Restrictions on deleting queues

A queue cannot be deleted if the following are true:

  • When the queue has queue items.
  • When any routing rule uses the queue.

Enable entities for queues

To enable a customizable entity, business or custom, for queues, use the UpdateEntityRequest message to set the IsValidForQueue attribute to true. For a list of customizable entities, see Which entities are customizable?. The queue entity and the queue item entity are customizable entities, but they cannot be enabled for queues.

The following list contains default queue-enabled entities in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update:

  • Appointment
  • Campaignactivity
  • CampaignResponse
  • Email
  • Fax
  • Incident
  • Letter
  • PhoneCall
  • RecurringAppointmentMaster
  • ServiceAppointment
  • SocialActivity
  • Task

Inherit privileges and provide limited access to a queue

A queue and a queue item have a parental relationship in which operations on the parent queue record are propagated to the child queue item records. For more information about parental relationships and cascading rules, see Entity relationship behavior.

Note
In this particular parental relationship, only the Delete action is cascaded from the parent queue entity to the child queue item entity. Other actions, such as Assign, Merge or Share are not cascaded.

The privileges on a queue item are inherited from the privileges on a queue.

  • If you have prvReadQueue privilege, you also have read privilege on a queue item entity.
  • If you have prvAppendToQueue privilege, you also have create, update, and delete privileges on a queue item entity.

Often, you must limit access to the queue when permitting access to the queue items. As a queue owner with full access to the queue, you might want to share a queue with a team that will have only limited access to the queue. For example, if the support team is given read and append to privileges on a queue, team members cannot make any changes to the queue, such as changing queue name or queue owner. However, they can create, retrieve, update, and delete queue items.

For more information, see Queue entity privileges.

Actions on queues and queue items

You can perform a variety of actions on queues and queue items, if you have appropriate privileges on the queue entity and the queue item entity.

Actions on queues

Perform the following actions on the queues:

  • Customize queues and queue items by adding custom attributes.
  • Add an entity record to a queue.

    Note
    An entity record cannot be added in multiple queues. An exception is an email entity record with the status “Received”.

  • Add entity records of different entity types in the same queue.
  • Change an ownership of a queue by assigning it to another user or team.
  • Add principals to a private queue using the AddPrincipalToQueueRequest.
  • Clean up the history for a queue by deleting inactive queue items in the queue, such as completed or canceled phone calls.
  • Retrieve all the queues that a user has access to using the RetrieveUserQueuesRequest
  • Make a queue the default queue for a user by setting the SystemUser.QueueId attribute to the ID of the queue. The same queue can be specified as a default queue for different users.
  • Create a workflow that operates on all private queues. For example, whenever a user creates a task, the workflow adds the task to the default queue of the user. You can also create a workflow that operates only on a particular queue.
  • Configure an email for incoming messages, if you want incoming email messages to be delivered to a queue.

Actions on queue items

Perform the following actions on the queue items:

  • Assign a queue item to a user using the PickFromQueueRequest.
  • Move a queue item from a source queue to a destination queue by using the AddToQueueRequest message. A queue item can be moved from one queue to another until it is deactivated by using the SetStateRequest message.

    Note
    A queue item is automatically deactivated if the state of the record in the queue item changed from Active to Inactive. This applies to queue-enabled entities that have Active and Inactive states. To determine if an entity is queue-enabled and if an entity record can be in an Active or Inactive state, see entity metadata information. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

  • Release a queue item back to the queue using the ReleaseToQueueRequest.
  • Delete a queue item from a queue by using the DeleteRequest message. When you delete a queue item, a referenced entity record is not deleted. However, when you delete an entity record, all queue items that reference this entity record are deleted.

See Also

Concepts

Configure email for incoming messages
Queue entity messages and methods
QueueItem entity messages and methods
Queue entity privileges

Other Resources

Sample code for queue entities
Business management entities
AddToQueueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Configure email for incoming messages

If you want incoming email messages to be delivered directly to a queue, specify the following information in the queue:

  • An email address by using the Queue.EmailAddress attribute. It must be a valid email address where emails that are sent to the queue are directed.
  • An incoming email delivery method by using the Queue.IncomingEmailDeliveryMethod attribute. You can specify email to be sent and received with the Microsoft Dynamics CRM Email Router or forwarded from another email address. If you specify the email router, you have an option to include the user’s email server credentials to give the user access to the server for retrieving emails.
  • An outgoing email delivery method, such as email router, by using the Queue.OutgoingEmailDeliveryMethod attribute.
  • An incoming email filtering method by using the Queue.IncomingEmailFilteringMethod attribute. You can specify to convert all incoming email messages to email activities or only email messages that relate to existing Microsoft Dynamics CRM records.
Important
The primary email address of the queue must be approved to ensure that the incoming and outgoing email messages are not blocked. The Queue.EmailRouterAccessApproval attribute contains the status of the primary email address of the queue. The status must be set to 1 (Approved). You can update the queue record to change the attribute value to 1 (Approved), if it is not already in the approved state. To update the attribute value, you must have the prvApproveRejectEmailAddress privilege. You also must set the Organization.RequireApprovalForQueueEmail attribute to 1 (True). If not set to 1 (True), the value provided in the Queue.EmailRouterAccessApproval attribute is ignored.

Beginning with the Microsoft Dynamics CRM 2015 and CRM Online Fall ‘13 releases, it’s no longer possible to configure Email Router credentials by setting the Queue.AllowEmailCredentials attribute to true followed by specifying the user name and password in Queue.EmailUserName and Queue.EmailPassword. These attributes have been deprecated and made read-only. The same restriction applies to the UserSettings.EmailPassword and UserSettings.EmailUserName attributes. However, these attributes can be set in the Email Router configuration. More information: Configure the Email Router.

See Also

Reference

Privileges not associated with an entity

Concepts

Queue entities
Queue entity privileges
Queue entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Queue entity messages and methods

A queue is a list of records requiring action, such as accounts, cases, and activities. The schema name for this entity is Queue. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddPrincipalToQueueRequest | This message was added with CRM 2015 Service Pack 1 (on-premises) and CRM Online Spring ‘14. Adds the specified principal to the list of queue members. If the passed-in Principal is a team, add each team member to the queue.
AssignRequest | Assigns a queue to another user or team.
CreateRequest | Creates a queue. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a queue. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a queue with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a queue previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a queue. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of queues. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights the specified security principal (user or team) has to a queue.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a contract, together with their access rights to the queue.
RetrieveUserQueuesRequest | This message was added with CRM 2015 Service Pack 1 (on-premises) and CRM Online Spring ‘14. Retrieves all private queues of a specified user and optionally all public queues.
RevokeAccessRequest | Removes all access to a queue for the specified security principal (user or team).
SetStateRequest | Sets the state of a queue. For a list of the state values, see the options available in the metadata.You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a queue. You can also call the IOrganizationService.Update method.
Note
The Queue.QueueTypeCode attribute exists for legacy purpose only. This attribute should not be used and any value stored in this attribute should be ignored.

See Also

Concepts

Queue entities
Queue entity privileges
QueueItem entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QueueItem entity messages and methods

A queue item is a specific item in a queue, such as a case record or an activity record. The schema name for this entity is QueueItem. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddToQueueRequest | Moves an entity record from a source queue to a destination queue.
CreateRequest | Creates a queue item. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a queue item. You can also call the IOrganizationService.Delete method.
PickFromQueueRequest | This message was added with CRM 2015 Service Pack 1 (on-premises) and CRM Online Spring ‘14. Assign a queue item to a user and optionally remove the queue item from the queue.
ReleaseToQueueRequest | This message was added with CRM 2015 Service Pack 1 (on-premises) and CRM Online Spring ‘14. Assign a queue item back to the queue owner so others can pick it.
RemoveFromQueueRequest | This message was added with CRM 2015 Service Pack 1 (on-premises) and CRM Online Spring ‘14. Remove a queue item from a queue.
RetrieveRequest | Retrieves a queue item. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of queue items. You can also call the IOrganizationService.RetrieveMultiple method.
RouteToRequest | This message was added with CRM 2015 Service Pack 1 (on-premises) and CRM Online Spring ‘14. Route a queue item to a different user or queue.
SetStateRequest | Sets the state of a queue item. For a list of the state values, see the options available in the metadata.You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a queue item. You can also call the IOrganizationService.Update method.

See Also

Concepts

Queue entities
QueueItem entity privileges

Other Resources

Sample code for queue entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample code for queue entities

This section contains the code examples that demonstrate how to use the queue entities.

In This Section

Sample: Create a queue (early bound)

Sample: Add a principal to a queue (early bound)

Sample: Delete a queue (early bound)

Sample: Add a record to a queue (early bound)

Sample: Clean up history for a queue (early bound)

Sample: Specify a queue item to work on (early bound)

Sample: Release a queue item to the queue (early bound)

Related Sections

Queue entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a queue (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\CreateQueue.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a simple queue and set required attributes.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to create a simple queue instance.
    /// </summary>
    public class CreateQueue
    {
        #region Class Level Members
        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs as well as strings needed for this sample.
        public Guid _queueId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create a new queue instance.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Define some anonymous types to define the range of possible
                    // queue property values.
                    var IncomingEmailDeliveryMethods = new
                    {
                        None = 0,
                        EmailRouter = 2,
                        ForwardMailbox = 3
                    };

                    var IncomingEmailFilteringMethods = new
                    {
                        AllEmailMessages = 0,
                        EmailMessagesInResponseToCrmEmail = 1,
                        EmailMessagesFromCrmLeadsContactsAndAccounts = 2
                    };

                    var OutgoingEmailDeliveryMethods = new
                    {
                        None = 0,
                        EmailRouter = 2
                    };

                    var QueueViewType = new
                    {
                        Public = 0,
                        Private = 1
                    };
                    // Create a queue instance and set its property values.
                    Queue newQueue = new Queue()
                    {
                        Name = "Example Queue.",
                        Description = "This is an example queue.",
                        IncomingEmailDeliveryMethod = new OptionSetValue(
                            IncomingEmailDeliveryMethods.None),
                        IncomingEmailFilteringMethod = new OptionSetValue(
                            IncomingEmailFilteringMethods.AllEmailMessages),
                        OutgoingEmailDeliveryMethod = new OptionSetValue(
                            OutgoingEmailDeliveryMethods.None),
                        QueueViewType = new OptionSetValue(
                            QueueViewType.Private)
                    };

                    // Create a new queue instance.
                    _queueId = _serviceProxy.Create(newQueue);

                    Console.WriteLine("Created {0}", newQueue.Name);

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Queue.EntityLogicalName,
                    _queueId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateQueue app = new CreateQueue();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Queue entities

Other Resources

Sample code for queue entities
Sample: Add a principal to a queue (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Add a principal to a queue (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\AddPrincipalToQueue.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to give a team access to a queue. The AddPrincipalToQueueRequest adds the specified principal to the list of queue members. If the passed-in Principal is a team each member of the team is added to the queue.

Example

C# Copy Code
using System;
using System.Linq;
using System.Threading;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This Sample shows how to share a queue to the team.
    /// </summary>
    public class AddPrincipalToQueue
    {

        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _queueId;
        private Guid _teamId;
        private Guid _roleId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Share a queue to the team.
        /// Optionally delete any entity records that were created for this sample.
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        /// </summary>

        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri, serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    ColumnSet columnSet = new ColumnSet("name");
                    Entity team = _serviceProxy.Retrieve(Team.EntityLogicalName, _teamId, columnSet);
                    AddPrincipalToQueueRequest addPrincipalToQueueRequest = new AddPrincipalToQueueRequest
                    {
                        Principal = team,
                        QueueId = _queueId
                    };

                    _serviceProxy.Execute(addPrincipalToQueueRequest);

                    Console.WriteLine("The team has been added to the queue.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a queue record.
        /// Create a team record.
        /// Create a role and add queue privileges.
        /// Assign role to team.
        /// </summary>
        public void CreateRequiredRecords()
        {
            var QueueViewType = new
            {
                Public = 0,
                Private = 1
            };
            // Create a queue instance and set its property values.
            Queue newQueue = new Queue
            {
                Name = "Example Queue",
                Description = "This is an example queue.",
                QueueViewType = new OptionSetValue(QueueViewType.Private)
            };

            // Create a new queue and store its returned GUID in a variable for later use.
            _queueId = _serviceProxy.Create(newQueue);
            Console.WriteLine("Created {0}", newQueue.Name);

            // Retrieve the default business unit for the creation of the team and role.
            QueryExpression queryDefaultBusinessUnit = new QueryExpression
            {
                EntityName = BusinessUnit.EntityLogicalName,
                ColumnSet = new ColumnSet("businessunitid"),
                Criteria = new FilterExpression
                {
                    Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "parentbusinessunitid",
                                Operator = ConditionOperator.Null
                            }
                        }
                }
            };

            BusinessUnit defaultBusinessUnit =
                (BusinessUnit)_serviceProxy.RetrieveMultiple(
                queryDefaultBusinessUnit).Entities[0];

            // Create a new example team.
            Team setupTeam = new Team
            {
                Name = "Example Team",
                BusinessUnitId = new EntityReference(BusinessUnit.EntityLogicalName,
                    defaultBusinessUnit.BusinessUnitId.Value)
            };

            _teamId = _serviceProxy.Create(setupTeam);
            Console.WriteLine("Created {0}", setupTeam.Name);

            // Create a new example role.
            Role setupRole = new Role
            {
                Name = "Example Role",
                BusinessUnitId = new EntityReference(BusinessUnit.EntityLogicalName,
                    defaultBusinessUnit.BusinessUnitId.Value)
            };

            _roleId = _serviceProxy.Create(setupRole);
            Console.WriteLine("Created {0}", setupRole.Name);

            // Retrieve the prvReadQueue and prvAppendToQueue privileges.
            QueryExpression queryQueuePrivileges = new QueryExpression
            {
                EntityName = Privilege.EntityLogicalName,
                ColumnSet = new ColumnSet("privilegeid", "name"),
                Criteria = new FilterExpression
                {
                    Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "name",
                                Operator = ConditionOperator.In,
                                Values = { "prvReadQueue", "prvAppendToQueue" }
                            }
                        }
                }
            };

            DataCollection<Entity> retrievedQueuePrivileges =
                _serviceProxy.RetrieveMultiple(queryQueuePrivileges).Entities;

            Console.WriteLine("Retrieved prvReadQueue and prvAppendToQueue privileges.");

            // Define a list to hold the RolePrivileges we'll need to add
            List<RolePrivilege> rolePrivileges = new List<RolePrivilege>();

            foreach (Privilege privilege in retrievedQueuePrivileges)
            {
                RolePrivilege rolePrivilege = new RolePrivilege(
                    (int)PrivilegeDepth.Local, privilege.PrivilegeId.Value);
                rolePrivileges.Add(rolePrivilege);
            }

            // Add the prvReadQueue and prvAppendToQueue privileges to the example role.
            AddPrivilegesRoleRequest addPrivilegesRequest = new AddPrivilegesRoleRequest
            {
                RoleId = _roleId,
                Privileges = rolePrivileges.ToArray()
            };
            _serviceProxy.Execute(addPrivilegesRequest);
            Console.WriteLine("Retrieved privileges are added to {0}.", setupRole.Name);

            // Add the example role to the example team.
            _serviceProxy.Associate(
                       Team.EntityLogicalName,
                       _teamId,
                       new Relationship("teamroles_association"),
                       new EntityReferenceCollection() { new EntityReference(Role.EntityLogicalName, _roleId) });

            // It takes some time for the privileges to propogate to the team.
            // Verify this is complete before continuing.

            bool teamLacksPrivilege = true;
            while (teamLacksPrivilege)
            {
                RetrieveTeamPrivilegesRequest retrieveTeamPrivilegesRequest =
                    new RetrieveTeamPrivilegesRequest
                {
                    TeamId = _teamId
                };

                RetrieveTeamPrivilegesResponse retrieveTeamPrivilegesResponse =
                    (RetrieveTeamPrivilegesResponse)_serviceProxy.Execute(
                    retrieveTeamPrivilegesRequest);

                if (retrieveTeamPrivilegesResponse.RolePrivileges.Any(
                    rp => rp.PrivilegeId == rolePrivileges[0].PrivilegeId) &&
                    retrieveTeamPrivilegesResponse.RolePrivileges.Any(
                    rp => rp.PrivilegeId == rolePrivileges[1].PrivilegeId))
                {
                    teamLacksPrivilege = false;
                }
                else
                {
                    Thread.Sleep(1000);
                }
            }

            Console.WriteLine("{0} has been added to {1}",
               setupRole.Name, setupTeam.Name);
            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to
        /// delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Queue.EntityLogicalName, _queueId);
                _serviceProxy.Delete(Team.EntityLogicalName, _teamId);
                _serviceProxy.Delete(Role.EntityLogicalName, _roleId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                AddPrincipalToQueue app = new AddPrincipalToQueue();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Queue entities

Other Resources

Helper code: ServerConnection class
Sample code for queue entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Delete a queue (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\DeleteQueue.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to delete a queue.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to delete a simple queue instance.
    /// </summary>
    public class DeleteQueue
    {
        #region Class Level Members

        // Define the IDs as well as strings needed for this sample.
        private Guid _queueId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Delete a new queue instance.
        /// Optionally delete any entity records that were created for this sample.
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Delete the queue instance.
                    _serviceProxy.Delete(Queue.EntityLogicalName, _queueId);

                    Console.WriteLine("Deleted a queue instance.");
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a new queue instance.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a queue instance and set its property values.
            Queue newQueue = new Queue()
            {
                Name = "Example Queue.",
                Description = "This is an example queue."
            };

            // Create a new queue instance.
            _queueId = _serviceProxy.Create(newQueue);

            Console.WriteLine("Created {0}.", newQueue.Name);

            return;
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DeleteQueue app = new DeleteQueue();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Queue entities

Other Resources

Sample code for queue entities
Sample: Add a record to a queue (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Add a record to a queue (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\AddToQueue.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to add a record to a queue. It creates source and destination queues. It adds a letter activity to the source queue and then moves it to the destination queue.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;
using System.Collections;
using System.Collections.Generic;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This Sample shows how to move a record from one queue to another.
    /// </summary>
    public class AddToQueue
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _sourceQueueId;
        private Guid _destinationQueueId;
        private Guid _letterId;
        private Guid _userId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Move a record from a source queue to a destination queue.
        /// Optionally delete any entity records that were created for this sample.
        /// <para name="organizationFriendlyName">The friendly name of the target
        /// organization.</para>
        /// <para name="discoveryServer">The name of the discovery server.</para>
        /// <param name="promptForDelete">Indicates whether to prompt the user to
        /// delete the records created in this sample.</param>
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri, serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    Guid CurrentUserId = ((WhoAmIResponse)_serviceProxy.Execute(new WhoAmIRequest())).UserId;

                    // Get known private queues for the user
                    // by using RetrieveUserQueuesRequest message.
                    RetrieveUserQueuesRequest retrieveUserQueuesRequest = new RetrieveUserQueuesRequest
                    {
                        UserId = CurrentUserId,
                        IncludePublic = true
                    };
                    RetrieveUserQueuesResponse retrieveUserQueuesResponse =
                        (RetrieveUserQueuesResponse)_serviceProxy.Execute(retrieveUserQueuesRequest);
                    EntityCollection queues = (EntityCollection)retrieveUserQueuesResponse.EntityCollection;

                    Guid sourceQueueId = new Guid();
                    Guid destinationQueueId = new Guid();

                    foreach (Entity entity in queues.Entities)
                    {
                        Queue queue = (Queue)entity;
                        switch (queue.Name)
                        {
                            case "Source Queue":
                                sourceQueueId = queue.Id;
                                break;
                            case "Destination Queue":
                                destinationQueueId = queue.Id;
                                break;
                        }
                    }

                    // Move a record from a source queue to a destination queue
                    // by using the AddToQueue request message.
                    AddToQueueRequest routeRequest = new AddToQueueRequest
                    {
                        SourceQueueId = sourceQueueId,
                        Target = new EntityReference(Letter.EntityLogicalName, _letterId),
                        DestinationQueueId = destinationQueueId
                    };

                    // Execute the Request
                    _serviceProxy.Execute(routeRequest);

                    Console.WriteLine(@"The letter record has been moved to a new queue.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create source queue and destination queue.
        /// Create a letter  entity.
        /// Add letter  entity to source queue.
        /// </summary>
        public void CreateRequiredRecords()
        {
            var QueueViewType = new
            {
                Public = 0,
                Private = 1
            };
            //Create new queues and store their returned GUIDs in variables for later use.
            Queue sourceQueue = new Queue
                {
                    Name = "Source Queue",
                    Description = "This is an example queue.",
                    QueueViewType = new OptionSetValue(QueueViewType.Private)
                };

            _sourceQueueId = _serviceProxy.Create(sourceQueue);
            Console.WriteLine("Created {0}", sourceQueue.Name);

            Queue destinationQueue = new Queue
                {
                    Name = "Destination Queue",
                    Description = "This is an example queue.",
                    QueueViewType = new OptionSetValue(QueueViewType.Private)
                };

            _destinationQueueId = _serviceProxy.Create(destinationQueue);
            Console.WriteLine("Created {0}", destinationQueue.Name);

            // Create a letter  entity.
            Letter newLetter = new Letter
            {
                Description = "Example Letter"
            };

            _letterId = _serviceProxy.Create(newLetter);
            Console.WriteLine("Created {0}", newLetter.Description);

            // Use AddToQueue message to add an  entity into a queue, which will associate
            // the letter with the first queue.
            AddToQueueRequest addToSourceQueue = new AddToQueueRequest
            {
                DestinationQueueId = _sourceQueueId,
                Target = new EntityReference(Letter.EntityLogicalName, _letterId)
            };

            _serviceProxy.Execute(addToSourceQueue);
            Console.WriteLine("Added letter record to {0}", sourceQueue.Name);

            // Retrieve/create a user record for assigning the queue item to the user's
            // queue.
            _userId = SystemUserProvider.RetrieveSalesManager(_serviceProxy);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(Letter.EntityLogicalName, _letterId);
                _serviceProxy.Delete(Queue.EntityLogicalName, _sourceQueueId);
                _serviceProxy.Delete(Queue.EntityLogicalName, _destinationQueueId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                AddToQueue app = new AddToQueue();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Queue entities

Other Resources

Sample code for queue entities
Sample: Clean up history for a queue (early bound)
AddToQueueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Clean up history for a queue (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\CleanUpQueueItems.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to clean up the history for the queue by using RemoveFromQueueRequest with inactive items. It finds completed phone calls in the queue and removes the associated queue items.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This Sample shows how to delete inactive items in a queue.
    /// </summary>
    public class CleanUpQueueItems
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _queueId;
        private Guid _phoneCallId;
        private Guid _queueItemId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Retrieve all queueitems with inactive phone calls from a queue.
        /// Delete all inactive phone call entity instances.
        /// Optionally delete any entity records that were created for this sample.
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Retrieve the queueitem with inactive phone calls from a queue
                    RemoveFromQueueRequest removeFromQueueRequest = new RemoveFromQueueRequest
                    {
                        QueueItemId = _queueItemId
                    };
                    _serviceProxy.Execute(removeFromQueueRequest);

                    Console.WriteLine("Inactive phonecalls have been deleted from the queue.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a queue instance.
        /// Create a phone call activity instance.
        /// Add phone call entity instance in to queue.
        /// Mark phone call entity instance status as completed.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a queue instance and set its property values.
            Queue newQueue = new Queue()
            {
                Name = "Example Queue",
                Description = "This is an example queue.",
                QueueViewType = new OptionSetValue((int)QueueQueueViewType.Private)
            };

            _queueId = _serviceProxy.Create(newQueue);
            Console.WriteLine("Created {0}.", newQueue.Name);

            // Create a phone call activity instance.
            PhoneCall newPhoneCall = new PhoneCall
            {
                Description = "Example Phone Call"
            };

            _phoneCallId = _serviceProxy.Create(newPhoneCall);
            Console.WriteLine("Created {0}.", newPhoneCall.Description);

            // Create a new instance of a queueitem and initialize its
            // properties.
            QueueItem item = new QueueItem
            {
                QueueId = new EntityReference(Queue.EntityLogicalName, _queueId),
                ObjectId = new EntityReference(PhoneCall.EntityLogicalName, _phoneCallId)
            };

            // Create the queueitem on the server, which will associate
            // the phone call activity with the queue.
            _queueItemId = _serviceProxy.Create(item);

            Console.WriteLine("Added phone call entity instance to {0}", newQueue.Name);

            // Mark the phone call as completed.
            SetStateRequest setStatePhoneCall = new SetStateRequest
            {
                EntityMoniker = new EntityReference(PhoneCall.EntityLogicalName,
                    _phoneCallId),
                State = new OptionSetValue((int)PhoneCallState.Completed),
                Status = new OptionSetValue(-1)
            };

            _serviceProxy.Execute(setStatePhoneCall);
            Console.WriteLine("PhoneCall entity instance has been marked as completed.");

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(PhoneCall.EntityLogicalName, _phoneCallId);
                _serviceProxy.Delete(Queue.EntityLogicalName, _queueId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CleanUpQueueItems app = new CleanUpQueueItems();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Queue entities

Other Resources

Sample code for queue entities
Sample: Specify a queue item to work on (early bound)
AddToQueueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Specify a queue item to work on (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\AssignQueueItemWorker.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to use PickFromQueueRequest to specify a user who will work on a queue item.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to assign queue item work to some user.
    /// </summary>
    public class AssignQueueItemWorker
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _queueItemId;
        private Guid _letterId;
        private Guid _queueId;
        private Guid _userId;
        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service.
        /// Initiate method to create any entity records that this sample requires.
        /// Retrieves new owner's details.
        /// Update the queue item record to assign it to new owner.
        /// Optionally delete any entity records that were created for this sample.
        /// <para name="organizationFriendlyName">The friendly name of the
        /// target organization.</para>
        /// <para name="discoveryServer">The name of the discovery server.</para>
        /// <param name="promptForDelete">Indicates whether to prompt the user to
        /// delete the records created in this sample.</param>
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Retrieve the current user information.
                    WhoAmIRequest whoAmIRequest = new WhoAmIRequest();
                    WhoAmIResponse whoAmIResponse = (WhoAmIResponse)_serviceProxy.Execute(
                        whoAmIRequest);

                    ColumnSet columnSet = new ColumnSet("fullname");
                    SystemUser currentUser = (SystemUser)_serviceProxy.Retrieve(
                        SystemUser.EntityLogicalName,
                        whoAmIResponse.UserId, columnSet);
                    String currentUserName = currentUser.FullName;
                    _userId = currentUser.Id;

                    // Create an instance of an existing queueitem in order to specify
                    // the user that will be working on it using PickFromQueueRequest.

                    PickFromQueueRequest pickFromQueueRequest = new PickFromQueueRequest
                    {
                        QueueItemId = _queueItemId,
                        WorkerId = _userId
                    };

                    _serviceProxy.Execute(pickFromQueueRequest);

                    Console.WriteLine("The letter queue item is queued for new owner {0}.",
                        currentUserName);

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a queue record.
        /// Create a letter record.
        /// Create a queue item for queue record.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a private queue instance and set its property values.
            Queue newQueue = new Queue
            {
                Name = "Example Queue.",
                Description = "This is an example queue.",
                QueueViewType=new OptionSetValue((int)QueueQueueViewType.Private)
            };

            // Create a new queue and store its returned GUID in a variable
            // for later use.
            _queueId = _serviceProxy.Create(newQueue);

            Console.WriteLine("Created {0}.", newQueue.Name);

            Letter newLetter = new Letter
            {
                Description = "Example Letter"
            };

            _letterId = _serviceProxy.Create(newLetter);

            Console.WriteLine("Created {0}.", newLetter.Description);

            // Create a new instance of a queueitem and initialize its
            // properties.
            QueueItem item = new QueueItem
            {
                QueueId = new EntityReference(Queue.EntityLogicalName, _queueId),
                ObjectId = new EntityReference(Letter.EntityLogicalName, _letterId)
            };

            // Create the queueitem on the server, which will associate
            // the letter with the queue.
            _queueItemId = _serviceProxy.Create(item);

            Console.WriteLine("Created the letter queue item for the queue.");

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to
        /// delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(QueueItem.EntityLogicalName, _queueItemId);
                _serviceProxy.Delete(Letter.EntityLogicalName, _letterId);
                _serviceProxy.Delete(Queue.EntityLogicalName, _queueId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                AssignQueueItemWorker app = new AssignQueueItemWorker();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Queue entities

Other Resources

Sample code for queue entities
Sample: Release a queue item to the queue (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Release a queue item to the queue (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\RemoveQueueItemWorker.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to use ReleaseToQueueRequest to dissociate a user from a queue item that he or she worked on and release a queue item back to the queue.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to release queued object from worker's queue.
    /// </summary>
    public class RemoveQueueItemWorker
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _queueItemId;
        private Guid _letterId;
        private Guid _queueId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate method to create any entity records that this sample requires.
        /// Remove worker from queue item to release queued object
        /// which user is working on.
        /// Optionally delete any entity records that were created for this sample.
        /// <para name="organizationFriendlyName">The friendly name of the
        /// target organization.</para>
        /// <para name="discoveryServer">The name of the discovery server.</para>
        /// <param name="promptForDelete">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri, serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Remove worker from queue item to release queued object
                    // from worker's queue using ReleaseToQueueRequest

                    ReleaseToQueueRequest releaseToQueueRequest = new ReleaseToQueueRequest
                    {
                        QueueItemId = _queueItemId
                    };
                    _serviceProxy.Execute(releaseToQueueRequest);

                    Console.WriteLine("Released the queued object from worker queue.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a queue record.
        /// Create a letter record.
        /// Create a queue item for queue record.
        /// Retrieves new owner's details.
        /// Update the queue item record to assign it to new owner.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a private queue instance and set its property values.
            Queue newQueue = new Queue
            {
                Name = "Example Queue.",
                Description = "This is an example queue.",
                QueueViewType = new OptionSetValue((int)QueueQueueViewType.Private)
            };

            // Create a new queue and store its returned GUID in a variable
            // for later use.
            _queueId = _serviceProxy.Create(newQueue);

            Console.WriteLine("Created {0}.", newQueue.Name);

            Letter newLetter = new Letter
            {
                Description = "Example Letter"
            };

            _letterId = _serviceProxy.Create(newLetter);

            Console.WriteLine("Created {0}.", newLetter.Description);

            // Create a new instance of a queueitem and initialize its
            // properties.
            QueueItem item = new QueueItem
            {
                QueueId = new EntityReference(Queue.EntityLogicalName, _queueId),
                ObjectId = new EntityReference(Letter.EntityLogicalName, _letterId)
            };

            // Create the queueitem on the server, which will associate
            // the letter with the queue.
            _queueItemId = _serviceProxy.Create(item);

            Console.WriteLine("Created the letter queue item for the queue.");

            // Retrieve the user information.
            WhoAmIRequest whoAmIRequest = new WhoAmIRequest();
            WhoAmIResponse whoAmIResponse = (WhoAmIResponse)_serviceProxy.Execute(
                whoAmIRequest);

            ColumnSet columnSet = new ColumnSet("fullname");
            SystemUser currentUser = (SystemUser)_serviceProxy.Retrieve(
                SystemUser.EntityLogicalName,
                whoAmIResponse.UserId, columnSet);
            String currentUserName = currentUser.FullName;

            // Create an instance of an existing queueitem in order to specify
            // the user that will be working on it.
            QueueItem queueItem = new QueueItem
            {
                QueueItemId = _queueItemId,
                WorkerId = new EntityReference(SystemUser.EntityLogicalName,
                    whoAmIResponse.UserId)
            };

            _serviceProxy.Update(queueItem);

            Console.WriteLine("The letter queue item is queued for new owner {0}.",
                currentUserName);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to
        /// delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(QueueItem.EntityLogicalName, _queueItemId);
                _serviceProxy.Delete(Letter.EntityLogicalName, _letterId);
                _serviceProxy.Delete(Queue.EntityLogicalName, _queueId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                RemoveQueueItemWorker app = new RemoveQueueItemWorker();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Queue entities

Other Resources

Sample code for queue entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Site entity

The site entity represents a location or branch office where an organization does business. Many Microsoft Dynamics CRM customers have multiple sites. Sites enable resources, services, and appointments to be defined at a particular location with an associated time zone. Location, correct selection of resources, and time zone are important elements in the scheduling of service appointments when multiple locations of doing business are involved. You can use sites to limit what resources, such as users and equipment, can be scheduled for a specific service activity.

When you search for an available service activity resource calendar time slot, to avoid making an appointment in the wrong location, the scheduler must be able to select the site or delivery location as a constraint to the search. For example, a customer may ask for an appointment at the Seattle office. To support this, there must be a site named Seattle and there must be required resources assigned to the service type to be performed. When generating appointment proposals, Microsoft Dynamics CRM must be able to avoid proposing appointments with resources that can’t physically be together to provide the service. The site entity serves this purpose. Sites provide for the grouping of resources, such as users and facility/equipment, services, and appointments, according to a location with an associated time zone and locale.

See Also

Concepts

Site entity messages and methods

Other Resources

Business management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Site entity messages and methods

A site represents a location or branch office where an organization does business. An organization can have multiple sites. The schema name for this entity is Site. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a site. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a site. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a site. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of sites. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a site. You can also call the IOrganizationService.Update method.

See Also

Concepts

Site entity
Site entity privileges

Other Resources

Business management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Subject entity

A subject categorizes entity records, such as articles and sales literature. By using subjects, you can create a hierarchy of topics to organize and maintain information in Microsoft Dynamics CRM. The information organized in the subject tree can be used by any entity in Microsoft Dynamics CRM. The Subject entity categorizes the following:

  • Knowledge base articles
  • Incidents (cases)
  • Product catalog items
  • Sales literature

The content organization of the knowledge base is displayed in the subject tree. The subject tree provides organizational consistency across entities. It makes the system easier for customer service, sales, and marketing to use. Frequently, the products for an organization determine the subject tree. However, you can use subject entity records to create nodes at the root level that are not shared.

See Also

Concepts

Subject entity messages and methods

Other Resources

Business management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Subject entity messages and methods

The subject entity represents a category used to organize information. The schema name for this entity is Subject. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a subject. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a subject. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a subject. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of subjects. You can also call theIOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a subject. You can also call the IOrganizationService.Update method.

See Also

Concepts

Subject entity
Subject entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Time zone entities

The time zone entities can be used when you write code that works in multiple time zones. The following three read-only entities in Microsoft Dynamics CRM contain time zone information:

  • The time zone definition entity stores basic information about each supported time zone, including the time zone code and the standard time zone name.
  • The time zone localized name entity stores the localized time zone names.
  • The time zone rule entity stores information about how times are calculated.

The following table lists the messages that are related to time zones, but don’t refer to a specific entity.

Message | Description
GetTimeZoneCodeByLocalizedNameRequest | Retrieves all the time zone definitions for the specified locale, returning only the display name attribute.
LocalTimeFromUtcTimeRequest | Retrieves the local time for the specified UTC time.
UtcTimeFromLocalTimeRequest | Retrieves the UTC time for the specified local time.

See Also

Concepts

TimeZoneDefinition entity messages and methods
TimeZoneLocalizedName entity messages and methods
TimeZoneRule entity messages and methods
Transaction Currency (currency) entity

Other Resources

Business management entities
Sample: Retrieve time zone information
Sample: Retrieve time zone information

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TimeZoneDefinition entity messages and methods

The Time Zone entity stores basic information about each supported time zone, including the time zone code and the standard time zone name. This information is read-only. The schema name for this entity is TimeZoneDefinition. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
GetAllTimeZonesWithDisplayNameRequest | Retrieves all the time-zone definitions for the specified locale, returning only the display name attribute.
GetTimeZoneCodeByLocalizedNameRequest | Retrieves the time-zone code for the specified localized time-zone name.
LocalTimeFromUtcTimeRequest | Retrieves the local time for the specified Universal Time Coordinate (UTC) time.
RetrieveLocLabelsRequest | Retrieves localized labels for the TimeZoneDefinition.UserInterfaceName and TimeZoneDefinition.StandardName attributes.
RetrieveRequest | Retrieves a time zone definition. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of time zone definitions. You can also call the IOrganizationService.RetrieveMultiple method.
SetLocLabelsRequest | Sets localized labels for the TimeZoneDefinition.UserInterfaceName and TimeZoneDefinition.StandardName attributes.
UtcTimeFromLocalTimeRequest | Retrieves the UTC time for the specified local time.

See Also

Concepts

Time zone entities
TimeZoneDefinition entity privileges
TimeZoneLocalizedName entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TimeZoneLocalizedName entity messages and methods

The Time Zone Localized Name entity stores the localized time zone names.

The schema name for this entity is TimeZoneLocalizedName. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveLocLabelsRequest | Retrieves localized labels for the TimeZoneLocalizedLabelName.UserInterfaceName attribute.
RetrieveRequest | Retrieves a time zone localized name. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of time zone localized names. You can also call the IOrganizationService.RetrieveMultiple method.
SetLocLabelsRequest | Sets localized labels for the TimeZoneLocalizedLabelName.UserInterfaceName attribute.

See Also

Concepts

Time zone entities
TimeZoneLocalizedName entity privileges
TimeZoneRule entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TimeZoneRule entity messages and methods

A time zone rule stores information about how times are calculated. The schema name for this entity is TimeZoneRule. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves a time zone rule. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of time zone rules. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

Time zone entities
TimeZoneRule entity privileges

Other Resources

Sample: Retrieve time zone information

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve time zone information
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\WorkingWithTimeZones.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve time zone information.

Example

C# Copy Code
using System;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to use various SDK messages with time zones.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.
    /// </remarks>
    public class WorkingWithTimeZones
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private string _timeZoneName;
        private Guid? _timeZoneId;
        private int? _localeId;
        private int? _timeZoneCode;
        #endregion

        #region How To Sample Code

        /// <summary>
        /// This method shows how to retrieve the user's time zone, retrieve time zones
        /// on the system and convert time between UTC and local time for a user.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete
        /// all created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig,
            bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();

                _timeZoneId = new Guid("42B2880D-BED5-4AA3-BD69-418052D38B7E");
                _timeZoneName = "Central Standard Time";
                RetrieveCurrentUsersSettings();

                RetrieveAllTimeZonesForLocale();
                GetTimeZoneCodeByLocaleAndName();
                RetrieveTimeZoneById();
                RetrieveTimeZonesLessThan50();
                RetrieveLocalTimeFromUTCTime(new DateTime(1981, 6, 6, 9, 5, 0));
                RetrieveUTCTimeFromLocalTime(new DateTime(2012, 1, 1, 0, 0, 0));
            }
        }

        /// <summary>
        /// Retrieves the current users timezone code and locale id
        /// </summary>
        private void RetrieveCurrentUsersSettings()
        {
            var currentUserSettings = _serviceProxy.RetrieveMultiple(
                new QueryExpression(UserSettings.EntityLogicalName)
                {
                    ColumnSet = new ColumnSet("localeid", "timezonecode"),
                    Criteria = new FilterExpression
                    {
                        Conditions =
                        {
                            new ConditionExpression("systemuserid", ConditionOperator.EqualUserId)
                        }
                    }
                }).Entities[0].ToEntity<UserSettings>();

            _localeId = currentUserSettings.LocaleId;
            _timeZoneCode = currentUserSettings.TimeZoneCode;
        }

        /// <summary>
        /// Uses the current locale id to retrieve all the timezones
        /// </summary>
        private void RetrieveAllTimeZonesForLocale()
        {
            if (!_localeId.HasValue)
                return;

            Console.WriteLine(String.Concat("Retrieving time zones for locale id: ",
                _localeId.Value));

            var response = (GetAllTimeZonesWithDisplayNameResponse) _serviceProxy.Execute(
                new GetAllTimeZonesWithDisplayNameRequest
                {
                    LocaleId = _localeId.Value,
                });

            for (int i = 0; i < response.EntityCollection.Entities.Count; i++)
            {
                var timeZoneDefinition = response.EntityCollection
                    .Entities[i].ToEntity<TimeZoneDefinition>();

                Console.WriteLine(String.Concat(timeZoneDefinition.UserInterfaceName,
                    " found for ", _localeId.Value));
            }
        }

        /// <summary>
        /// Retrieves a timezone by the name and the locale ID
        /// </summary>
        private void GetTimeZoneCodeByLocaleAndName()
        {
            if (string.IsNullOrWhiteSpace(_timeZoneName) || !_localeId.HasValue)
                return;

            var request = new GetTimeZoneCodeByLocalizedNameRequest
            {
                LocaleId = _localeId.Value,
                LocalizedStandardName = _timeZoneName
            };

            var response = (GetTimeZoneCodeByLocalizedNameResponse)
                _serviceProxy.Execute(request);

            Console.WriteLine(String.Concat("Time zone code: ", response.TimeZoneCode,
                " retrieved for locale id: ", _localeId.Value, ", and time zone name: ",
                _timeZoneName));
        }

        /// <summary>
        /// Retieve time zone by id
        /// </summary>
        private void RetrieveTimeZoneById()
        {
            if (!_timeZoneId.HasValue)
                return;

            // In addition to the RetrieveRequest message,
            // you may use the IOrganizationService.Retrieve method
            var request = new RetrieveRequest
            {
                Target = new EntityReference(
                    TimeZoneDefinition.EntityLogicalName, _timeZoneId.Value),
                ColumnSet = new ColumnSet("standardname")
            };

            var response = (RetrieveResponse)_serviceProxy.Execute(request);

            Console.WriteLine(String.Concat("Retrieve request on time zone ",
                _timeZoneId.Value, ".  Name: ", response.Entity.
                ToEntity<TimeZoneDefinition>().StandardName));
        }

        /// <summary>
        /// Retrieve time zones less than 50.
        /// </summary>
        private void RetrieveTimeZonesLessThan50()
        {
            // In addition to the RetrieveMultipleRequest message,
            // you may use the IOrganizationService.RetrieveMultiple method.
            var request = new RetrieveMultipleRequest
            {
                Query = new QueryExpression(TimeZoneDefinition.EntityLogicalName)
                {
                    ColumnSet = new ColumnSet("timezonecode", "standardname"),
                    Criteria = new FilterExpression
                    {
                        Conditions =
                        {
                            new ConditionExpression("timezonecode",
                                ConditionOperator.LessThan, 50)
                        }
                    }
                }
            };

            Console.WriteLine("Retrieving all timezones with a timezonecode less than 50");
            var response = (RetrieveMultipleResponse)_serviceProxy.Execute(request);

            foreach (var item in response.EntityCollection.Entities)
            {
                var timeZone = item.ToEntity<TimeZoneDefinition>();

                Console.WriteLine(String.Concat("Time zone name: ",
                    timeZone.StandardName, ", time zone code: ",
                    !timeZone.TimeZoneCode.HasValue ? "null" :
                    timeZone.TimeZoneCode.Value.ToString()));
            }

        }

        /// <summary>
        /// Retrive the local time from the UTC time.
        /// </summary>
        /// <param name="utcTime"></param>
        private void RetrieveLocalTimeFromUTCTime(DateTime utcTime)
        {
            if (!_timeZoneCode.HasValue)
                return;

            var request = new LocalTimeFromUtcTimeRequest
            {
                TimeZoneCode = _timeZoneCode.Value,
                UtcTime = utcTime.ToUniversalTime()
            };

            var response = (LocalTimeFromUtcTimeResponse)_serviceProxy.Execute(request);

            Console.WriteLine(String.Concat("Calling LocalTimeFromUtcTimeRequest.  UTC time: ",
                utcTime.ToString("MM/dd/yyyy HH:mm:ss"), ". Local time: ",
                response.LocalTime.ToString("MM/dd/yyyy HH:mm:ss")));
        }

        /// <summary>
        /// Retrieves the utc time from the local time
        /// </summary>
        /// <param name="localTime"></param>
        private void RetrieveUTCTimeFromLocalTime(DateTime localTime)
        {
            if (!_timeZoneCode.HasValue)
                return;

            var request = new UtcTimeFromLocalTimeRequest
            {
                TimeZoneCode = _timeZoneCode.Value,
                LocalTime = localTime
            };

            var response = (UtcTimeFromLocalTimeResponse)_serviceProxy.Execute(request);

            Console.WriteLine(String.Concat("Calling UtcTimeFromLocalTimeRequest.  Local time: ",
                localTime.ToString("MM/dd/yyyy HH:mm:ss"), ". UTC time: ",
                response.UtcTime.ToString("MM/dd/yyyy HH:mm:ss")));
        }
        #endregion

        #region Main method
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new WorkingWithTimeZones();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion
    }
}

See Also

Concepts

Time zone entities

Other Resources

GetAllTimeZonesWithDisplayNameRequest
GetTimeZoneCodeByLocalizedNameRequest
UtcTimeFromLocalTimeRequest
LocalTimeFromUtcTimeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Transaction Currency (currency) entity

Microsoft Dynamics CRM is a multicurrency system, in which each record can be associated with its own currency. This currency is called the transaction currency. The multicurrency features enable users to perform financial transactions like opportunities, quotes, orders, and invoices in multiple currencies. This feature also provides a currency choice to the end user when a financial transaction occurs.

Multiple records in different transaction currencies can be aggregated, compared, or analyzed with regard to a single currency, by using an exchange rate. This is known as the base currency. You first define a base currency for the organization and then define exchange rates to associate the base currency with transaction currencies. The base currency is the currency in which other currencies are quoted. The exchange rate is the value of a transaction currency equal to one base currency.

By using the transaction currency properties you can do the following:

  • Select the currency in which you want to define and transact opportunities, quotes, orders, and invoices.
  • Define currency exchange rates relative to the base currency.
  • Define transaction currencies and define an exchange rate to associate the base currency with the transaction currency.
  • Capture the value of the transaction in the base currency and the transaction currency in all financial transactions.
  • Define product pricelists for each currency.

To use multiple currencies, the base currency must be defined for an organization during server installation and organization setup. After the base currency is set for an organization, it cannot be changed. This value is stored in the Organization.BaseCurrencyID attribute.

Transaction currencies are defined as a part of the system settings. An unlimited number of transaction currencies can be defined. Transaction currencies are related to the base currency with the definition of a currency exchange rate.

After the definition of base and transaction currencies, pricelists must be defined. An organization can have multiple pricelists, which are also typically defined for a target geographical market in the local currency.

All entities that are involved in financial transactions support transaction currency. The currency is typically inherited from the account, opportunity, and so on, but can be changed as needed.

You can specify the decimal precision for the transaction currency by using the TransactionCurrency.CurrencyPrecision attribute. To specify the source of the precision for the attributes of type Money, use the MoneyAttributeMetadata.PrecisionSource attribute.

All money properties in a record share the same transaction currency, for example, see the Account.CreditLimit attribute. For each money attribute in an entity, Microsoft Dynamics CRM automatically creates a corresponding read-only, system calculated, money attribute that is called the "base". This is a money attribute that stores the value of the corresponding attribute in a base currency equivalent, for example, see the Account.CreditLimit_Base attribute.

The following formula is used to calculate the base value:

C# Copy Code
creditlimit_base = creditlimit / exchangerate

The following are the entities for which the transaction currency can be defined.

  • Account
  • AnnualFiscalCalendar
  • Campaign
  • CampaignActivity
  • Competitor
  • Contact
  • Contract
  • ContractDetail
  • Discount
  • DiscountType
  • FixedMonthlyFiscalCalendar
  • Invoice
  • InvoiceDetail
  • Lead
  • List
  • MonthlyFiscalCalendar
  • Opportunity
  • OpportunityClose
  • OpportunityProduct
  • PriceLevel
  • Product
  • ProductPriceLevel
  • QuarterlyFiscalCalendar
  • Quote
  • QuoteDetail
  • SalesOrder
  • SalesOrderDetail
  • SemiAnnualFiscalCalendar
  • UserSettings

See Also

Concepts

TransactionCurrency (currency) entity messages and methods

Other Resources

Sample: Retrieve currency exchange rate
Business management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TransactionCurrency (currency) entity messages and methods

This entity represents a transaction currency and an exchange rate in relation to the base transaction currency. The schema name for this entity is TransactionCurrency. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a transaction currency. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a transaction currency. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a transaction currency. You can also call the IOrganizationService.Retrieve method.
RetrieveExchangeRateRequest | Retrieves the exchange rate.
RetrieveMultipleRequest | Retrieves a collection of transaction currencies. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a transaction currency. If you are using early bound types, use the TransactionCurrencyState enumeration to set the possible states. For a list of the state values, refer to the TransactionCurrency entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a transaction currency. You can also call the IOrganizationService.Update method.

See Also

Concepts

Transaction Currency (currency) entity
TransactionCurrency (currency) entity privileges

Other Resources

Sample: Retrieve currency exchange rate

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve currency exchange rate
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\TransactionCurrencyExchangeRate.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a new currency, and how to retrieve and display the currency exchange rate relative to the organization’s base currency.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to retrieve a currency's exchange rates.
    /// </summary>
    /// <param name="serverConfig">Contains server connection information.</param>
    /// <param name="promptforDelete">When True, the user will be prompted to delete all
    /// created entities.</param>
    public class TransactionCurrencyExchangeRate
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;
        private ServiceContext _context;

        private TransactionCurrency _currency;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first creates a new currency within the system, setting its
        /// exchange rate to a pre-defined value. It then issues a
        /// RetrieveExchangeRateRequest to get the exchange rate from the created
        /// currency to the organization's base currency. Finally, it retrieves the
        /// organization's base currency and displays the conversion rate.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                // using the service context makes retrieving entities easier
                using (_context = new ServiceContext(_serviceProxy))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    String currentOrganizatoinUniqueName = GetCurrentOrganizationName(serverConfig);

                    CreateRequiredRecords();

                    RetrieveExchangeRateRequest request = new RetrieveExchangeRateRequest()
                    {
                        TransactionCurrencyId = _currency.Id
                    };
                    RetrieveExchangeRateResponse response =
                        (RetrieveExchangeRateResponse)_serviceProxy.Execute(request);
                    Console.WriteLine("  Retrieved exchange rate for created currency");

                    // get the base currency for the current org
                    var baseCurrencyName =
                        (from currency in _context.TransactionCurrencySet
                         join org in _context.OrganizationSet
                         on currency.Id equals org.BaseCurrencyId.Id
                         where org.Name == currentOrganizatoinUniqueName
                         select currency.CurrencyName).FirstOrDefault();
                    Console.WriteLine("  This organization's base currency is {0}",
                        baseCurrencyName);

                    Console.WriteLine(
                        "  The conversion from {0} -> {1} is {2}",
                        _currency.CurrencyName,
                        baseCurrencyName,
                        response.ExchangeRate);

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        private string GetCurrentOrganizationName(ServerConnection.Configuration serverConfig)
        {
            using (DiscoveryServiceProxy _discoveryProxy = new DiscoveryServiceProxy(serverConfig.DiscoveryUri,
                        serverConfig.HomeRealmUri, serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                RetrieveOrganizationsRequest orgsRequest =
                new RetrieveOrganizationsRequest()
                {
                    AccessType = EndpointAccessType.Default,
                    Release = OrganizationRelease.Current
                };
                RetrieveOrganizationsResponse organizations =
                    (RetrieveOrganizationsResponse)_discoveryProxy.Execute(orgsRequest);

                foreach (OrganizationDetail organization in organizations.Details)
                {
                    foreach (var endpoint in organization.Endpoints)
                    {
                        if (endpoint.Value.ToLowerInvariant() == serverConfig.OrganizationUri.ToString().ToLowerInvariant())
                            return organization.FriendlyName;
                    }
                }
            }
            return String.Empty;
        }

        #region Public Methods

        public void CreateRequiredRecords()
        {
            Console.WriteLine("  Creating currency 'Canadian Dollar'");
            // Create another currency
            _currency = new TransactionCurrency()
            {
                CurrencyName = "Canadian Dollar",
                CurrencyPrecision = 2,
                ExchangeRate = (decimal)0.9755,
                ISOCurrencyCode = "CAD", // Canadian Dollar currency code
                CurrencySymbol = "$"
            };
            _currency.Id = _serviceProxy.Create(_currency);
        }

        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(TransactionCurrency.EntityLogicalName,
                    _currency.Id);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                TransactionCurrencyExchangeRate app = new TransactionCurrencyExchangeRate();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        #endregion Main method
    }
}

See Also

Concepts

Transaction Currency (currency) entity

Other Resources

RetrieveExchangeRateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sales entities (lead, opportunity, competitor, quote, order, invoice)

You use the entities described in this section to manage various phases of a sales process. They include tracking leads, opportunities, competitors, and managing quotes, orders, products, and sales goals.

In This Section

Competitor entity

Lead entity

Opportunity entities

Quote, order, and invoice entities

Related Sections

Model your business data

Marketing entities (campaign, list)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Competitor entity

A competitor is another company that offers competing products and services. Each competitor record in Microsoft Dynamics CRM can contain detailed information about the competitor that includes a company profile, a SWOT analysis (Strengths, Weaknesses, Opportunities, and Threats), and any relevant sales materials and presentations. In addition, competitor articles can contain links to relevant information in the marketing encyclopedia.

With competitor tracking, you can find competitors and analyze their sales strategies, their products, and what contracts they win. This functionality includes adding and maintaining competitor records, and storing competitor documents. Competitor tracking lets you disperse competition information to everyone who deals with an opportunity so that they can compete in the most effective way possible to close the sale and maintain the relationship. Competitor tracking helps you compare your business unit to the competition, including opportunities lost to and won against competitors.

One or many competitors can be associated with any opportunity. By using this association, salespeople give management the ability to track their overall win/loss record versus specific competitors, and to do further analysis regarding the cause of losses and other outcomes.

See Also

Concepts

Competitor entity messages and methods
Opportunity entities
Lead entity

Other Resources

Sales entities (lead, opportunity, competitor, quote, order, invoice)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Competitor entity messages and methods

A competitor is another company that offers competing products and services. Each competitor record can contain detailed information about the competitor that includes a company profile, a SWOT analysis (Strengths, Weaknesses, Opportunities, and Threats), and any relevant sales materials and presentations. In addition, competitor articles can contain links to relevant information in the marketing encyclopedia.

One or many competitors can be associated with any opportunity. By using this association, salespeople give management the ability to track their overall win/loss record versus specific competitors, and to do further analysis regarding the cause of losses and other outcomes.

The schema name for this entity is Competitor. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a competitor. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a competitor. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a competitor. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of competitors. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a competitor. You can also call the IOrganizationService.Update method.

See Also

Concepts

Competitor entity
Competitor entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Lead entity

A lead entity represents an individual that is identified as someone who is interested in receiving specific information about the products or services offered by the company. The information is provided to a lead by a salesperson through email or other communication activities available in Microsoft Dynamics CRM. A lead is used to track contacts or accounts that are potential customers, but who have not yet been qualified.

Lead management is largely the same as opportunity management. However, a lead is kept separate from customer and opportunity data until the lead is qualified. The possible states for a lead are Open, Qualified, and Disqualified. A qualified lead may be converted to an account, contact or opportunity. To convert, use the QualifyLeadRequest message.

The following items can be associated with a lead:

  • Contact and account information
  • Customer requests
  • Activities
  • Notes
  • Attachments

A link is maintained between the lead and any accounts and contacts. You can create this link by using the IOrganizationService.Execute method with the AssociateRequest or the DisassociateRequest messages. This makes it possible to generate reports that indicate the value of different lead sources.

When you enter a lead into Microsoft Dynamics CRM, you can use the process (workflow) engine to automatically route it to a specific user or team based on rules that are defined by the business unit or channel partner. Upon qualification, the lead is either converted to an opportunity or is inactivated, but retained to allow for accurate business reporting, for example, analysis of the effectiveness of different lead sources. For more information, seeWrite workflows to automate business processes.

See Also

Concepts

Lead entity messages and methods
Opportunity entities

Other Resources

Sample: Qualify a lead
Sales entities (lead, opportunity, competitor, quote, order, invoice)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Lead entity messages and methods

A lead is used to track contacts or accounts that are potential customers but who have not yet been qualified. The schema name for this entity is Lead. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a lead to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the lead entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a lead. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a lead. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the lead entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares a lead with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
MergeRequest | Merges two leads.
ModifyAccessRequest | Changes the access rights for a lead previously shared with another security principal (user or team).
QualifyLeadRequest | Qualifies a lead and creates an account, contact, or opportunity records that are linked to the originating lead.
RemoveRelatedRequest | Deprecated. Use the DisassociateRequest or Disassociate class. Removes the link between a lead and an account or contact.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a lead. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of leads. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights the specified security principal (user or team) has to a lead.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a lead, and also retrieves their access rights to the lead.
RevokeAccessRequest | Removes all access rights to a lead for the specified security principal (user or team).
SetRelatedRequest | Deprecated. Use the AssociateRequest or Associate class. Creates a link between a lead and an account or contact.
SetStateRequest | Sets the state of a lead. If you are using early bound types, use the LeadState enumeration to set the possible states. For a list of the state values, refer to the LeadState entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a lead. You can also call the IOrganizationService.Update method.

See Also

Concepts

Lead entity privileges
Lead entity

Other Resources

Sales entities (lead, opportunity, competitor, quote, order, invoice)
Sample: Qualify a lead

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Qualify a lead
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagementSampleCode\WorkingWithLeads.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to qualify a lead and create an account, contact, or opportunity based on the lead.

Example

C# Copy Code
using System;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    public class WorkingWithLeads
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private Guid _lead1Id;
        private Guid _lead2Id;
        private Guid _accountId;
        private Guid _leadAccountId;
        private Guid _contactId;
        private Guid _opportunityId;
        #endregion

        #region How To Sample Code

        public void Run(ServerConnection.Configuration serverConfig,
            bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early bound type support.
                _serviceProxy.EnableProxyTypes();
                CreateRequiredRecords();

                Console.WriteLine("=== Creating and Qualifying Leads ===");

                // Create two leads.
                var lead1 = new Lead
                {
                    CompanyName = "A. Datum Corporation",
                    FirstName = "Henriette",
                    LastName = "Andersen",
                    Subject = "Sample Lead 1"
                };

                _lead1Id = _serviceProxy.Create(lead1);
                NotifyEntityCreated(Lead.EntityLogicalName, _lead1Id);

                var lead2 = new Lead
                {
                    CompanyName = "Adventure Works",
                    FirstName = "Michael",
                    LastName = "Sullivan",
                    Subject = "Sample Lead 2"
                };

                _lead2Id = _serviceProxy.Create(lead2);
                NotifyEntityCreated(Lead.EntityLogicalName, _lead2Id);

                // Qualify the first lead, creating an account and a contact from it, but
                // not creating an opportunity.
                var qualifyIntoAccountContactReq = new QualifyLeadRequest
                {
                    CreateAccount = true,
                    CreateContact = true,
                    LeadId = new EntityReference(Lead.EntityLogicalName, _lead1Id),
                    Status = new OptionSetValue((int)lead_statuscode.Qualified)
                };

                var qualifyIntoAccountContactRes =
                    (QualifyLeadResponse)_serviceProxy.Execute(qualifyIntoAccountContactReq);
                Console.WriteLine("  The first lead was qualified.");
                foreach (var entity in qualifyIntoAccountContactRes.CreatedEntities)
                {
                    NotifyEntityCreated(entity.LogicalName, entity.Id);
                    if (entity.LogicalName == Account.EntityLogicalName)
                    {
                        _leadAccountId = entity.Id;
                    }
                    else if (entity.LogicalName == Contact.EntityLogicalName)
                    {
                        _contactId = entity.Id;
                    }
                }

                // Retrieve the organization's base currency ID for setting the
                // transaction currency of the opportunity.
                var query = new QueryExpression("organization");
                query.ColumnSet = new ColumnSet("basecurrencyid");
                var result = _serviceProxy.RetrieveMultiple(query);
                var currencyId = (EntityReference)result.Entities[0]["basecurrencyid"];

                // Qualify the second lead, creating an opportunity from it, and not
                // creating an account or a contact.  We use an existing account for the
                // opportunity customer instead.
                var qualifyIntoOpportunityReq = new QualifyLeadRequest
                {
                    CreateOpportunity = true,
                    OpportunityCurrencyId = currencyId,
                    OpportunityCustomerId = new EntityReference(
                        Account.EntityLogicalName,
                        _accountId),
                    Status = new OptionSetValue((int)lead_statuscode.Qualified),
                    LeadId = new EntityReference(Lead.EntityLogicalName, _lead2Id)
                };

                var qualifyIntoOpportunityRes =
                    (QualifyLeadResponse)_serviceProxy.Execute(qualifyIntoOpportunityReq);
                Console.WriteLine("  The second lead was qualified.");

                foreach (var entity in qualifyIntoOpportunityRes.CreatedEntities)
                {
                    NotifyEntityCreated(entity.LogicalName, entity.Id);
                    if (entity.LogicalName == Opportunity.EntityLogicalName)
                    {
                        _opportunityId = entity.Id;
                    }
                }

                DeleteRecords(promptforDelete);
            }
        }

        private void NotifyEntityCreated(String entityName, Guid entityId)
        {
            Console.WriteLine("  {0} created with GUID {{{1}}}",
                entityName, entityId);
        }

        private void CreateRequiredRecords()
        {
            // Create an account to relate the opportunity to.
            var account = new Account
            {
                Name = "Litware, Inc.",
                Address1_StateOrProvince = "Colorado"
            };
            _accountId = (_serviceProxy.Create(account));
        }

        private void DeleteRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Deleting the accounts will delete all of their related records, and then
                // only the leads will be left.
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
                _serviceProxy.Delete(Account.EntityLogicalName, _leadAccountId);

                _serviceProxy.Delete(Lead.EntityLogicalName, _lead1Id);
                _serviceProxy.Delete(Lead.EntityLogicalName, _lead2Id);
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new WorkingWithLeads();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Lead entity

Other Resources

Sales entities (lead, opportunity, competitor, quote, order, invoice)
QualifyLeadRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Opportunity entities

The opportunity entity represents a potential sale to new or established customers. It helps you to forecast future business demands and sales revenues. You can create a new opportunity in Microsoft Dynamics CRM to monitor an inquiry from your existing customer, or convert a qualified lead into an opportunity. Salespeople often use opportunities to keep track of the sales engagements that they are currently working on.

You can track the estimated revenue, estimated close date, and rating of the opportunity as well as what stage the opportunity is in. You can track the potential customer’s name and salesperson’s name. You can monitor activities related to the potential sale, such as telephone calls, email messages, and tasks.

An opportunity must be associated with one account or contact. An account and a contact may have links to multiple opportunities. Opportunities contain competitor information that helps you to analyze and find effective selling strategies.

Each opportunity may have multiple products associated with it. An association between an opportunity and a product is represented by the opportunity product entity.

After you determine whether the prospective customer or an existing customer wants to purchase your product or service, you may close an opportunity. By closing an opportunity, you deactivate it, but you do not delete it. This gives you an option to reopen it later. When you close an opportunity, an opportunity close activity is created. It is represented by the opportunity close entity. You can use this entity to store information about the revenue, why you closed the opportunity, close date, and the competitor. It also contains the information about the user that created the opportunity.

The entities that can be associated with an opportunity to provide a complete set of information about the sales engagement include: activities, notes and attachments, competitors, quotes, orders, and sales literature.

See Also

Concepts

Create an opportunity
Convert an opportunity to a quote, sales order or invoice
Opportunity entity messages and methods
OpportunityProduct entity messages and methods
OpportunityClose activity entity messages and methods
Quote, order, and invoice entities
Set default price level for opportunity, quote, order, invoice

Other Resources

Sample: Create an opportunity (early bound)
Sample: Retrieve an opportunity (early bound)
Sample: Convert an opportunity to a quote (early bound)
Sales entities (lead, opportunity, competitor, quote, order, invoice)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create an opportunity

You can create an opportunity from a qualified lead or you can create a new opportunity for one of your existing customers. You can track the information about each opportunity, such as state and status of the opportunity, the probability of the sale, and the estimated closing date. An opportunity contains important sales information that can be used later in quotes, sales orders, and invoices. The sales information includes:

  • Products and services from the product catalog and write-in products that you plan to sell
  • Overridden prices of the products and services from the product catalog
  • Discounted prices of the products and services from the product catalog and the write-in products
  • Calculated or estimated revenues
  • Freight rates
  • Calculated tax and cost totals

In This Topic

Prepare Data for an Opportunity

Add Existing Products and Write-in Products

Price Overriding

Apply Discounts

Calculate Tax and Totals

Close an Opportunity

Prepare Data for an Opportunity

Before you create an opportunity, ensure that Microsoft Dynamics CRM contains necessary data:

  • Create accounts, contacts, and leads before you create an opportunity. You can create an opportunity for an existing account or contact, or convert a qualified lead into an opportunity.
  • Each opportunity must be associated with one account or a contact.
  • Qualify a lead for an opportunity by using your company’s lead qualification criteria. The possible states for a lead are Open, Qualified, and Disqualified.

If you add products to an opportunity, the system must contain a product catalog, products, price lists, and units of measure.

Add Existing Products and Write-in Products

A single opportunity may be associated with multiple products that include existing products and write-in products. Existing products are a part of the product catalog and are associated with the price lists in the product catalog. Write-in products are products that your company sells, but does not include in the product catalog. The prices of write-in products are not associated with the price lists in the product catalog. An existing product or a write-in product is a line item in the opportunity record. The existing products and the write-in products are represented by the opportunity product entity. To associate the products with a specific opportunity, use the OpportunityProduct.OpportunityId attribute.

To set up a product catalog, products, price lists, and discount lists you must have system administrator privileges.

Add Existing Products from the Product Catalog

To specify an existing product from the catalog, set the OpportunityProduct.IsProductOverridden attribute to false. Specify the following information: product ID (OpportunityProduct.ProductId), price per unit (OpportunityProduct.PricePerUnit), quantity (OpportunityProduct.Quantity) and units of measure (OpportunityProduct.UomId). To associate a price list with the opportunity, use the Opportunity.PriceLevelId attribute. You can add other product-related data, such as tax amount (OpportunityProduct.Tax), volume discount (OpportunityProduct.VolumeDiscountAmount), or manual discount (OpportunityProduct.ManualDiscountAmount).

Add Write-in Products

Although, a write-in product is not in the product catalog, you can add it to an opportunity. To specify a write-in product, set the OpportunityProduct.IsProductOverridden attribute to true. Specify the following information: product description (OpportunityProduct.ProductDescription), price per unit (OpportunityProduct.PricePerUnit), and quantity (OpportunityProduct.Quantity). You can add other product-related data, such as tax amount (OpportunityProduct.Tax), volume discount (OpportunityProduct.VolumeDiscountAmount), or manual discount (OpportunityProduct.ManualDiscountAmount).

Price Overriding

For a write-in product, you can use any price that you want and the quantities that you plan to sell. However, if you add an existing product from the catalog, you have an option to override the list price. To override the list price of the existing product, set the OpportunityProduct.IsPriceOverridden attribute to true. Specify a desired price by using the OpportunityProduct.PricePerUnit attribute.

Apply Discounts

In addition to price overriding, you can apply volume discounts and manual discounts. The discounts can be applied to line items and to a whole opportunity.

For example, if the average order from your customers is for five units of your product, you could create an incentive for your customers to order more than five units by giving them a discount when they order six or more units. A discount can be specified as a percentage or an amount. To specify a volume discount for the opportunity product, use the OpportunityProduct.VolumeDiscountAmount attribute. To specify a manual discount for the opportunity product, use the OpportunityProduct.ManualDiscountAmount attribute. To specify an overall discount for the opportunity, use the Opportunity.DiscountAmount attribute.

Calculate Tax and Totals

The estimated tax and the estimated total value of the opportunity are automatically calculated. The estimated value is based on the combined cost of all products added to the opportunity and the associated price lists. Instead of using the system calculated value, you can specify the estimated revenue for the opportunity. To do this, set the Opportunity.IsRevenueSystemCalculated attribute to false and specify the estimated value in the Opportunity.EstimatedValue attribute.

The breakdown of the opportunity total costs is a follows:

  • Total amount
  • Total amount less freight
  • Total discount amount
  • Total line item amount
  • Total line item discount amount
  • Total discount
  • Total tax

Having information about individual costs helps you analyze your overall cost. You can make necessary adjustments to pricing, discounts, and freight cost to help with closing a deal.

Close an Opportunity

If a customer decides to purchase products or services from your company, you can close an opportunity as a won opportunity. The opportunity states are specified in the Opportunity.StateCode attribute. If you are using early bound types, you can use the OpportunityState enumeration. For a list of the state values, see see the picklist values for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

When you close an opportunity, an activity is created automatically by creating a record of the entity type opportunity close. The states of the opportunity close activity are specified in the OpportunityClose.StateCode attribute. If you are using early bound types, you can use the OpportunityCloseState enumeration. For a list of the state values, see the picklist values for this entity.

The opportunity close activity contains information about the user that created the activity, and the date and time when it was created. It also contains the information about the estimated revenue, close date, and competitor. You can add notes that explain the reasons why you closed the opportunity.

See Also

Concepts

Opportunity entities
Convert an opportunity to a quote, sales order or invoice
Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)

Other Resources

Product catalog entities
Sales entities (lead, opportunity, competitor, quote, order, invoice)
Customer entities (account, contact)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Convert an opportunity to a quote, sales order or invoice

Opportunities, quotes, sales orders, and invoices are all part of the sales process. An opportunity is a possibility to sell products and services to a qualified customer. If an opportunity is won, you may convert it to a quote, or to a sales order or an invoice. The catalog products and write-in products that are included in an opportunity are added to a quote, a sales order, or an invoice during conversion. An opportunity, a quote, a sales order, and an invoice share common data that can be reused in the flow of the sales process. The shared data includes user information, product price and discounts, freight amount, total costs, and tax.

Converting an Opportunity to a Quote, a Sales Order, or an Invoice

The following table lists the messages that you can use to convert an opportunity to a quote, a sales order, or an invoice.

Message | Description
GenerateQuoteFromOpportunityRequest | Generates a quote from an opportunity.
GenerateSalesOrderFromOpportunityRequest | Generates a sales order from an opportunity.
GenerateInvoiceFromOpportunityRequest | Generates an invoice from an opportunity.

Copying Products from an Opportunity to a Quote, a Sales Order, or on Invoice

The following table lists the messages that you can use to add products from a new opportunity to existing quotes, invoices, or sales orders.

Message | Description
GetQuoteProductsFromOpportunityRequest | Retrieves the products from an opportunity and copies them to the specified quote.
GetSalesOrderProductsFromOpportunityRequest | Retrieves the products from an opportunity and copies them to the specified sales order.
GetInvoiceProductsFromOpportunityRequest | Retrieves the products from an opportunity and copies them to the specified invoice.

See Also

Concepts

Opportunity entities
Create an opportunity
Quote, order, and invoice entities
Opportunity entity messages and methods

Other Resources

Sales entities (lead, opportunity, competitor, quote, order, invoice)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Opportunity entity messages and methods

An opportunity represents a potential revenue-generating event, or sale to an account, that must be tracked through a sales process to completion. The schema name for this entity is Opportunity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an opportunity to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Opportunity entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CalculateActualValueOpportunityRequest | Calculates the value of an opportunity.
CreateRequest | Creates an opportunity. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an opportunity. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Opportunity entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GetQuantityDecimalRequest | Gets the quantity decimal value of a product for the entity specified in the target.
GrantAccessRequest | Shares an opportunity with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
IsValidStateTransitionRequest | Checks if the state transition is valid.
LoseOpportunityRequest | Sets the state of an opportunity. The possible states are defined in the Opportunity.Statecode attribute. If you are using early bound types, use the OpportunityState enumeration..
ModifyAccessRequest | Changes the access rights for an opportunity previously shared with another security principal (user or team).
RemoveRelatedRequest | Deprecated. Removes the relationship between an opportunity and an account, contact, or competitor. Use DisassociateRequest or IOrganizationService.Disassociate instead.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves an opportunity. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of opportunities. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights the specified security principal (user or team) has to an opportunity.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to an opportunity, together with their access rights to the opportunity.
RevokeAccessRequest | Removes all access rights to an opportunity for the specified security principal (user or team).
RollupRequest | Retrieves all the opportunities related to the specified record (account or contact).
SetRelatedRequest | Deprecated. Creates a relationship between an opportunity and an account, contact, or competitor. Use AssociateRequest or IOrganizationService.Associate instead.
SetStateRequest | Sets the state of an opportunity. If you are using early bound types, use the OpportunityState enumeration to set the possible states. For a list of the state values, refer to the Opportunity entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an opportunity. You can also call the IOrganizationService.Update method.
WinOpportunityRequest | Changes the state of an opportunity to Won.

See Also

Concepts

Opportunity entities
Opportunity entity privileges
OpportunityProduct entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OpportunityProduct entity messages and methods

An opportunity product represents an association between an opportunity and a product.

The schema name for this entity is OpportunityProduct. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an opportunity product. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an opportunity product. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an opportunity product. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of opportunity products. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates an opportunity product. You can also call the IOrganizationService.Update method.

See Also

Concepts

Opportunity entities
OpportunityProduct entity privileges
OpportunityClose activity entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OpportunityClose activity entity messages and methods

An opportunity close represents an activity that is created automatically when an opportunity is closed.

The schema name for this entity is OpportunityClose. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an opportunity close activity to another user or team.
CreateRequest | Creates an opportunity close activity. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an opportunity close activity. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares an opportunity close activity with another security principal (user or team).
MergeRequest | Merges two opportunity close activities.
RetrieveRequest | Retrieves an opportunity close activity. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of opportunity close activities. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights the specified security principal (user or team) has to an opportunity close activity.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to an opportunity close activity, and their access rights to the opportunity close activity.
RevokeAccessRequest | Removes all access rights to an opportunity close activity for the specified security principal (user or team).
SetStateRequest | Sets the state of an opportunity close activity. If you are using early bound types, use the OpportunityCloseState enumeration to set the possible states. For a list of the state values, refer to the OpportunityClose entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an opportunity close activity. You can also call the IOrganizationService.Update method.

See Also

Concepts

Opportunity entities
OpportunityClose entity privileges

Other Resources

Sample: Create an opportunity (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create an opportunity (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\CreateOpportunity.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create an opportunity that contains a product from the product catalog and from a write-in product.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This Sample shows how to create an opportunity with
    /// one catalog and one write-in product.
    /// </summary>
    public class CreateOpportunity
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _unitGroupId;
        public Guid _defaultUnitId;
        public Guid _product1Id;
        public Guid _product2Id;
        public Guid _discountTypeId;
        public Guid _discountId;
        public Guid _priceListId;
        public Guid _priceListItem1Id;
        public Guid _priceListItem2Id;
        public Guid _accountId;
        public Guid _opportunityId;
        public Guid _catalogProductId;
        public Guid _catalogProductPriceOverrideId;
        public Guid _writeInProductId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate method to create any data that this sample requires.
        /// Create a new opportunity and few opportunity product
        /// including write-in product.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Create a new opportunity with user specified estimated revenue
                    Opportunity newOpportunity = new Opportunity
                    {
                        Name = "Example Opportunity",
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName,
                            _priceListId),
                        IsRevenueSystemCalculated = false,
                        EstimatedValue = new Money(400.00m),
                        FreightAmount = new Money(10.00m),
                        DiscountAmount = new Money(0.10m),
                        DiscountPercentage = 0.20m
                    };

                    _opportunityId = _serviceProxy.Create(newOpportunity);
                    Console.WriteLine("Created {0} with user specified estimated revenue.",
                        newOpportunity.Name);

                    // Create a new opportunity product from the catalog

                    // Create a catalog product
                    OpportunityProduct catalogProduct = new OpportunityProduct
                    {
                        OpportunityId = new EntityReference(Opportunity.EntityLogicalName,
                            _opportunityId),
                        ProductId = new EntityReference(Product.EntityLogicalName,
                            _product1Id),
                        UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                        Quantity = 8,
                        Tax = new Money(12.42m)
                    };

                    _catalogProductId = _serviceProxy.Create(catalogProduct);
                    Console.WriteLine("Created the catalog product.");

                    // Create anothter catalog product and override the list price
                    OpportunityProduct catalogProductPriceOverride = new OpportunityProduct
                    {
                        OpportunityId = new EntityReference(Opportunity.EntityLogicalName,
                            _opportunityId),
                        ProductId = new EntityReference(Product.EntityLogicalName,
                            _product2Id),
                        UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                        Quantity = 3,
                        Tax = new Money(2.88m),
                        IsPriceOverridden = true,
                        PricePerUnit = new Money(12)
                    };

                    _catalogProductPriceOverrideId = _serviceProxy.Create(
                        catalogProductPriceOverride);
                    Console.WriteLine(@"Created another catalog product and
                    overriden the list price.");

                    // create a new write-in opportunity product with a manual discount applied
                    OpportunityProduct writeInProduct = new OpportunityProduct
                    {
                        OpportunityId = new EntityReference(Opportunity.EntityLogicalName,
                            _opportunityId),
                        IsProductOverridden = true,
                        ProductDescription = "Example Write-in Product",
                        PricePerUnit = new Money(20.00m),
                        Quantity = 5,
                        ManualDiscountAmount = new Money(10.50m),
                        Tax = new Money(7.16m)
                    };

                    _writeInProductId = _serviceProxy.Create(writeInProduct);
                    Console.WriteLine("Created {0}.", writeInProduct.ProductDescription);

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a unit group.
        /// Retrieve the default unit.
        /// Create few products.
        /// Create new discount list and discount.
        /// Create new price list and few price list items.
        /// Create an account record.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a unit group
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };

            _unitGroupId = _serviceProxy.Create(newUnitGroup);
            Console.WriteLine("Created {0}", newUnitGroup.Name);

            // Retrieve the default unit id that was automatically created
            // when we created the Unit Group
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression
                {
                    Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "uomscheduleid",
                                Operator = ConditionOperator.Equal,
                                Values = { _unitGroupId }
                            }
                        }
                },
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };

            // Retrieve the unit.
            UoM unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];

            _defaultUnitId = unit.UoMId.Value;

            Console.WriteLine("Retrieved {0}", unit.Name);

            // Create a few products
            Product newProduct1 = new Product
            {
                ProductNumber = "1",
                Name = "Example Product 1",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName,
                    _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };

            _product1Id = _serviceProxy.Create(newProduct1);
            Console.WriteLine("Created {0}", newProduct1.Name);

            Product newProduct2 = new Product
            {
               ProductNumber = "2",
               Name = "Example Product 2",
               ProductStructure = new OptionSetValue(1),
               QuantityDecimal = 3,
               DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName,
                   _unitGroupId),
               DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };

            _product2Id = _serviceProxy.Create(newProduct2);
            Console.WriteLine("Created {0}", newProduct2.Name);

            // Create a new discount list
            DiscountType newDiscountType = new DiscountType
            {
                Name = "Example Discount List",
                IsAmountType = false
            };

            _discountTypeId = _serviceProxy.Create(newDiscountType);
            Console.WriteLine("Created {0}", newDiscountType.Name);

            // Create a new discount
            Discount newDiscount = new Discount
            {
                DiscountTypeId = new EntityReference(DiscountType.EntityLogicalName,
                    _discountTypeId),
                LowQuantity = 5,
                HighQuantity = 10,
                Percentage = 3
            };

            _discountId = _serviceProxy.Create(newDiscount);

            Console.WriteLine("Created new discount for the {0}.", newDiscountType.Name);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };

            _priceListId = _serviceProxy.Create(newPriceList);
            Console.WriteLine("Created {0}", newPriceList.Name);

            // Create a price list item for the first product and apply volume discount
            ProductPriceLevel newPriceListItem1 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(20),
                DiscountTypeId = new EntityReference(DiscountType.EntityLogicalName,
                    _discountTypeId)
            };

            _priceListItem1Id = _serviceProxy.Create(newPriceListItem1);
            Console.WriteLine(@"Created price list item for the {0} and applied
                volume discount.", newProduct1.Name);

            // Create a price list item for the second product
            ProductPriceLevel newPriceListItem2 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product2Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(15)
            };

            _priceListItem2Id = _serviceProxy.Create(newPriceListItem2);
            Console.WriteLine("Created price list item for the {0}.", newProduct1.Name);

            //Publish Product1
            SetStateRequest publishRequest1 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product1Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest1);

            //Publish Product2
            SetStateRequest publishRequest2 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product2Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest2);
            Console.WriteLine("Published both the products");

            // Create an account record for the opporutnity's potential customerid
            Account newAccount = new Account
            {
                Name = "Example Account"
            };
            _accountId = _serviceProxy.Create(newAccount);

            Console.WriteLine("Created {0}", newAccount.Name);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete("opportunityproduct", _writeInProductId);
                _serviceProxy.Delete("opportunityproduct", _catalogProductPriceOverrideId);
                _serviceProxy.Delete("opportunityproduct", _catalogProductId);
                _serviceProxy.Delete("opportunity", _opportunityId);
                _serviceProxy.Delete("account", _accountId);
                _serviceProxy.Delete("productpricelevel", _priceListItem1Id);
                _serviceProxy.Delete("productpricelevel", _priceListItem2Id);
                _serviceProxy.Delete("pricelevel", _priceListId);
                _serviceProxy.Delete("product", _product1Id);
                _serviceProxy.Delete("product", _product2Id);
                _serviceProxy.Delete("discount", _discountId);
                _serviceProxy.Delete("discounttype", _discountTypeId);
                _serviceProxy.Delete("uomschedule", _unitGroupId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateOpportunity app = new CreateOpportunity();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main
    }
}

See Also

Concepts

Opportunity entities

Other Resources

Helper code: ServerConnection class
Sample: Retrieve an opportunity (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve an opportunity (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\RetrieveOpportunity.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve an opportunity and products related to the opportunity.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This Sample shows how to retrieve an opportunity with
    /// related opportunity products.
    /// </summary>
    public class RetrieveOpportunity
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _unitGroupId;
        public Guid _defaultUnitId;
        public Guid _product1Id;
        public Guid _product2Id;
        public Guid _discountTypeId;
        public Guid _discountId;
        public Guid _priceListId;
        public Guid _priceListItem1Id;
        public Guid _priceListItem2Id;
        public Guid _accountId;
        public Guid _opportunityId;
        public Guid _opportunityProduct1Id;
        public Guid _opportunityProduct2Id;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate method to create any data that this sample requires.
        /// Retrieve opportunity and opportunity products.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Retrieve Opportunity record.
                    Opportunity checkOpportunity = (Opportunity)_serviceProxy.Retrieve(
                        Opportunity.EntityLogicalName,
                        _opportunityId,
                        new ColumnSet("name"));

                    Console.WriteLine("Retrieved {0}", checkOpportunity.Name);

                    // Retrieve the related opportunity products
                    QueryExpression opportunityProductsQuery = new QueryExpression
                    {
                        EntityName = OpportunityProduct.EntityLogicalName,
                        ColumnSet = new ColumnSet("opportunityproductid", "volumediscountamount"),
                        Criteria = new FilterExpression
                        {
                            Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "opportunityid",
                                Operator = ConditionOperator.Equal,
                                Values = { _opportunityId }
                            }
                        }
                        }
                    };

                    DataCollection<Entity> opportunityProducts = _serviceProxy.RetrieveMultiple(
                        opportunityProductsQuery).Entities;

                    foreach (Entity entity in opportunityProducts)
                    {
                        OpportunityProduct opportunityProduct = (OpportunityProduct)entity;
                        Console.WriteLine("Retrieved Opportunity Product {0}",
                            opportunityProduct.OpportunityProductId.Value);
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a unit group.
        /// Retrieve the default unit.
        /// Create few products.
        /// Create new discount list and discount.
        /// Create new price list and few price list items.
        /// Create an account record.
        /// Create a new opportunity and few opportunity products.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a unit group
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };

            _unitGroupId = _serviceProxy.Create(newUnitGroup);
            Console.WriteLine("Created {0}", newUnitGroup.Name);

            // Retrieve the default unit id that was automatically created
            // when we created the Unit Group
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression
                {
                    Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "uomscheduleid",
                                Operator = ConditionOperator.Equal,
                                Values = { _unitGroupId }
                            }
                        }
                },
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };

            // Retrieve the unit.
            UoM unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];

            _defaultUnitId = unit.UoMId.Value;

            Console.WriteLine("Retrieved {0}", unit.Name);

            // Create a few products
            Product newProduct1 = new Product
            {
                ProductNumber = "1",
                Name = "Example Product 1",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName,
                    _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };

            _product1Id = _serviceProxy.Create(newProduct1);
            Console.WriteLine("Created {0}", newProduct1.Name);

            Product newProduct2 = new Product
            {
               ProductNumber = "2",
               Name = "Example Product 2",
               ProductStructure = new OptionSetValue(1),
               QuantityDecimal = 3,
               DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName,
                   _unitGroupId),
               DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };

            _product2Id = _serviceProxy.Create(newProduct2);
            Console.WriteLine("Created {0}", newProduct2.Name);

            // Create a new discount list
            DiscountType newDiscountType = new DiscountType
            {
                Name = "Example Discount List",
                IsAmountType = false
            };

            _discountTypeId = _serviceProxy.Create(newDiscountType);
            Console.WriteLine("Created {0}", newDiscountType.Name);

            // Create a new discount
            Discount newDiscount = new Discount
            {
                DiscountTypeId = new EntityReference(DiscountType.EntityLogicalName,
                    _discountTypeId),
                LowQuantity = 5,
                HighQuantity = 10,
                Percentage = 3
            };

            _discountId = _serviceProxy.Create(newDiscount);

            Console.WriteLine("Created new discount for the {0}.", newDiscountType.Name);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };

            _priceListId = _serviceProxy.Create(newPriceList);
            Console.WriteLine("Created {0}", newPriceList.Name);

            // Create a price list item for the first product and apply volume discount
            ProductPriceLevel newPriceListItem1 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(20),
                DiscountTypeId = new EntityReference(DiscountType.EntityLogicalName,
                    _discountTypeId)
            };

            _priceListItem1Id = _serviceProxy.Create(newPriceListItem1);
            Console.WriteLine(@"Created price list item for the {0} and applied
                volume discount.", newProduct1.Name);

            // Create a price list item for the second product
            ProductPriceLevel newPriceListItem2 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product2Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(20)
            };

            _priceListItem2Id = _serviceProxy.Create(newPriceListItem2);
            Console.WriteLine("Created price list item for the {0}.", newProduct1.Name);

            //Publish Product1
            SetStateRequest publishRequest1 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product1Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest1);

            //Publish Product2
            SetStateRequest publishRequest2 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product2Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest2);
            Console.WriteLine("Published both the products");

            // Create an account record for the opporutnity's potential customerid
            Account newAccount = new Account
            {
                Name = "Example Account"
            };
            _accountId = _serviceProxy.Create(newAccount);

            Console.WriteLine("Created {0}", newAccount.Name);

            // Create a new opportunity
            Opportunity newOpportunity = new Opportunity
            {
                Name = "Example Opportunity",
                CustomerId = new EntityReference(Account.EntityLogicalName,
                    _accountId),
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName,
                    _priceListId)
            };

            _opportunityId = _serviceProxy.Create(newOpportunity);
            Console.WriteLine("Created {0}.", newOpportunity.Name);

            // Create some opportunity products
            OpportunityProduct newOpportunityProduct1 = new OpportunityProduct
            {
                OpportunityId = new EntityReference(Opportunity.EntityLogicalName,
                    _opportunityId),
                ProductId = new EntityReference(Product.EntityLogicalName,
                    _product1Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Quantity = 8
            };

            _opportunityProduct1Id = _serviceProxy.Create(newOpportunityProduct1);

            OpportunityProduct newOpportunityProduct2 = new OpportunityProduct
            {
                OpportunityId = new EntityReference(Opportunity.EntityLogicalName,
                    _opportunityId),
                ProductId = new EntityReference(Product.EntityLogicalName,
                    _product2Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Quantity = 1
            };

            _opportunityProduct2Id = _serviceProxy.Create(
                newOpportunityProduct2);

            Console.WriteLine("Created few opportunity products.");

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete("opportunityproduct", _opportunityProduct1Id);
                _serviceProxy.Delete("opportunityproduct", _opportunityProduct2Id);
                _serviceProxy.Delete("opportunity", _opportunityId);
                _serviceProxy.Delete("account", _accountId);
                _serviceProxy.Delete("productpricelevel", _priceListItem1Id);
                _serviceProxy.Delete("productpricelevel", _priceListItem2Id);
                _serviceProxy.Delete("pricelevel", _priceListId);
                _serviceProxy.Delete("product", _product1Id);
                _serviceProxy.Delete("product", _product2Id);
                _serviceProxy.Delete("discount", _discountId);
                _serviceProxy.Delete("discounttype", _discountTypeId);
                _serviceProxy.Delete("uomschedule", _unitGroupId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                RetrieveOpportunity app = new RetrieveOpportunity();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main
    }
}

See Also

Concepts

Opportunity entities

Other Resources

Helper code: ServerConnection class
Sample: Convert an opportunity to a quote (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Convert an opportunity to a quote (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\ConvertOpportunityToQuote.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to convert an opportunity that contains products from the product catalog and a write-in product to a quote. It also illustrates how to overwrite a price of a product from the product catalog.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to convert an opporutnity to a quote.
    /// </summary>
    public class ConvertOpportunityToQuote
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _unitGroupId;
        public Guid _product1Id;
        public Guid _product2Id;
        public Guid _priceListId;
        public Guid _priceListItem1Id;
        public Guid _priceListItem2Id;
        public Guid _accountId;
        public Guid _opportunityId;
        public Guid _opportunityProduct1Id;
        public Guid _opportunityProduct2Id;
        public Guid _writeInProductId;
        public Guid _quoteId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate creating all entity records that this sample requires.
        /// Convert an opportunity to quote
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
                /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Convert an opportunity to quote.
                    GenerateQuoteFromOpportunityRequest quoteRequest = new GenerateQuoteFromOpportunityRequest()
                    {
                        // Columns that will be transferred
                        ColumnSet = new ColumnSet("name", "customerid"),
                        OpportunityId = _opportunityId
                    };

                    GenerateQuoteFromOpportunityResponse quoteResponse =
                        (GenerateQuoteFromOpportunityResponse)_serviceProxy.Execute(quoteRequest);

                    _quoteId = quoteResponse.Entity.Id;
                    Console.WriteLine("Created the quote from an opportunity.");

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            catch
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a unit group, few products, price list and price list items.
        /// Create an account record.
        /// Create few opportunities, opportunity products and a write-in product.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a unit group.
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };

            _unitGroupId = _serviceProxy.Create(newUnitGroup);

            Console.WriteLine("Created {0}", newUnitGroup.Name);

            // retrieve the unit id.
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression(),
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };
            unitQuery.Criteria.AddCondition("uomscheduleid", ConditionOperator.Equal, _unitGroupId);

            // Retrieve the unit.
            UoM unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];

            Console.WriteLine("Retrieved {0}", unit.Name);

            // Create a few products
            Product newProduct1 = new Product
            {
                ProductNumber = "1",
                Name = "Example Product 1",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, unit.Id)
            };
           _product1Id = _serviceProxy.Create(newProduct1);

           Console.WriteLine("Created {0}", newProduct1.Name);

            Product newProduct2 = new Product
            {
                ProductNumber = "2",
                Name = "Example Product 2",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, unit.Id)
            };
            _product2Id = _serviceProxy.Create(newProduct2);

            Console.WriteLine("Created {0}", newProduct2.Name);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };
            _priceListId = _serviceProxy.Create(newPriceList);

            Console.WriteLine("Created {0}", newPriceList.Name);

            // Create a price list items for the products
            ProductPriceLevel newPriceListItem1 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
                Amount = new Money(20)
            };
            _priceListItem1Id = _serviceProxy.Create(newPriceListItem1);

            Console.WriteLine("Created price list for {0}", newProduct1.Name);

            ProductPriceLevel newPriceListItem2 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product2Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
                Amount = new Money(20)
            };
            _priceListItem2Id = _serviceProxy.Create(newPriceListItem2);

            Console.WriteLine("Created price list for {0}", newProduct2.Name);

            //Publish Product1
            SetStateRequest publishRequest1 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product1Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest1);

            //Publish Product2
            SetStateRequest publishRequest2 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product2Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest2);
            Console.WriteLine("Published both the products");

            // Create an account record for the opportunity's potential customerid
            Account newAccount = new Account
            {
                Name = "Example Account"
            };
            _accountId = _serviceProxy.Create(newAccount);

            Console.WriteLine("Created {0}", newAccount.Name);

            // Create a new opportunity
            Opportunity newOpportunity = new Opportunity
            {
                Name = "Example Opportunity",
                CustomerId = new EntityReference(Account.EntityLogicalName, _accountId),
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                FreightAmount = new Money(10.00m)
            };
            _opportunityId = _serviceProxy.Create(newOpportunity);

            Console.WriteLine("Created {0}", newOpportunity.Name);

            // Create an opportunity product
            OpportunityProduct newOpportunityProduct1 = new OpportunityProduct
            {
                OpportunityId = new EntityReference(Opportunity.EntityLogicalName, _opportunityId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
                Quantity = 3,
                Tax = new Money(4.80m)
            };
            _opportunityProduct1Id = _serviceProxy.Create(newOpportunityProduct1);

            Console.WriteLine("Created opportunity product for {0} and {1}", newOpportunity.Name, newProduct1.Name);

            // Create a catalog product and override the price per unit
            OpportunityProduct newOpportunityProduct2 = new OpportunityProduct
            {
               OpportunityId = new EntityReference(Opportunity.EntityLogicalName, _opportunityId),
               ProductId = new EntityReference(Product.EntityLogicalName, _product2Id),
               UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
               Quantity = 1,
               IsPriceOverridden = true,
               PricePerUnit = new Money(12),
               Tax = new Money(0.96m)
            };
            _opportunityProduct2Id = _serviceProxy.Create(newOpportunityProduct2);

            Console.WriteLine("Created opportunity product for {0} and {1}", newOpportunity.Name, newProduct2.Name);

            // Create a write-in product with a manual discount
            OpportunityProduct newWriteInProduct = new OpportunityProduct
            {
                OpportunityId = new EntityReference(Opportunity.EntityLogicalName, _opportunityId),
                // set this attribute to make it a write-in product
                IsProductOverridden = true,
                ProductDescription = "Example Write-in Product",
                PricePerUnit = new Money(20.00m),
                Quantity = 5,
                ManualDiscountAmount = new Money(10.50m),
                Tax = new Money(7.16m)
            };
            _writeInProductId = _serviceProxy.Create(newWriteInProduct);

            Console.WriteLine("Created {0}", newWriteInProduct.ProductDescription);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Quote.EntityLogicalName, _quoteId);
                _serviceProxy.Delete(OpportunityProduct.EntityLogicalName, _writeInProductId);
                _serviceProxy.Delete(OpportunityProduct.EntityLogicalName, _opportunityProduct1Id);
                _serviceProxy.Delete(OpportunityProduct.EntityLogicalName, _opportunityProduct2Id);
                _serviceProxy.Delete(Opportunity.EntityLogicalName, _opportunityId);
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItem1Id);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItem2Id);
                _serviceProxy.Delete(Product.EntityLogicalName, _product1Id);
                _serviceProxy.Delete(Product.EntityLogicalName, _product2Id);
                _serviceProxy.Delete(PriceLevel.EntityLogicalName, _priceListId);
                _serviceProxy.Delete(UoMSchedule.EntityLogicalName, _unitGroupId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                ConvertOpportunityToQuote  app = new ConvertOpportunityToQuote();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Opportunity entities

Other Resources

Helper code: ServerConnection class
GenerateQuoteFromOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Quote, order, and invoice entities

Microsoft Dynamics CRM supports robust quote, sales order (order), and invoice building. You can build a quote by selecting products directly from the product catalog, specifying the price list (such as wholesale or retail), and entering the requested number of units. If you have permission, you can also apply discounts. Multiple pricing models are supported, such as wholesale versus retail, and discounting can be done by line item based on volume or manual override. In addition, overall discounts can be applied to the whole quote.

A quote is a formal offer for products or services proposed at specific prices and related payment terms that is sent to a prospective customer. You can create a quote, save it as a draft, and specify whether it is active (presented to the customer) or closed (completed, either as an order or not). A quote can have a due date (when it was promised to the customer), effective dates (when it must be accepted or rejected by), and the requested delivery dates. In addition, a quote can contain many "ship to" addresses (by line item) or a "will call" setting for items to be picked up by the customer.

If a quote is created from an opportunity, CRM will use the products associated with the opportunity as the basis for the draft. When a quote is converted to an order, the user can keep the opportunity open or close it. If the user chooses to close it, the final revenue amount is recorded.

A quote can be associated with the following entities:

  • One or more products and one price list
  • One or more competitors
  • An opportunity
  • A customer
  • One or more notes and attachments
  • One or more customer addresses

The quote detail (quote product) entity represents a line item in a quote. Each quote can have multiple quote detail (quote product) records.

The quote close activity entity represents an activity that is generated when a quote is closed.

A sales order (order) is a quote that has been accepted. This entity is called an order in CRM.

An invoice is an order that has been billed.

See Also

Concepts

Quote entity messages and methods
QuoteDetail (quote product) entity messages and methods
QuoteClose activity entity messages and methods
SalesOrder (order) entity messages and methods
SalesOrderDetail (order product) entity messages and methods
OrderClose activity entity messages and methods
Invoice entity messages and methods
InvoiceDetail (invoice product) entity messages and methods
Opportunity entities
Set default price level for opportunity, quote, order, invoice

Other Resources

Sample: Set negative prices in opportunities, quotes, and sales orders
Sample: Process quotes, sales orders and invoices
Sample: Fulfill a sales order
Sales entities (lead, opportunity, competitor, quote, order, invoice)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Quote entity messages and methods

A quote is a formal offer for products and/or services, proposed at specific prices and related payment terms that is sent to a prospective customer. The schema name for this entity is entity is Quote. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a quote to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Quote entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CloseQuoteRequest | Specifies the parameters needed to close a quote.
CompoundCreateRequest | Creates a quote and its related quote details.
CompoundUpdateRequest | Updates a quote and its related quote details.
ConvertQuoteToSalesOrderRequest | Converts a quote to a sales order.
CreateRequest | Creates a quote. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a quote. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Quote entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GenerateQuoteFromOpportunityRequest | Creates a quote from an opportunity.
GetQuantityDecimalRequest | Gets the quantity decimal value of a product for the entity specified in the target.
GetQuoteProductsFromOpportunityRequest | Retrieves the products from an opportunity and copies them to the quote.
GrantAccessRequest | Shares a quote with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for a quote previously shared with another security principal (user or team).
RemoveRelatedRequest | Deprecated. Removes the relationship between a quote and a contact. Use DisassociateRequest or Disassociate instead.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a quote. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of quotes. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to a quote.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a quote, together with their access rights to the quote.
ReviseQuoteRequest | Sets the state of a quote to Draft.
RevokeAccessRequest | Removes all access rights to a quote for the specified security principal (user or team).
RollupRequest | Rolls up or retrieves all the quotes related to the specified record (account or contact).
SetRelatedRequest | Deprecated. Creates a relationship between a quote and a contact. Use DisassociateRequest or Disassociate instead.
SetStateRequest | Sets the state of a quote. If you are using early bound types, use the QuoteState enumeration to set the possible states. For a list of the state values, refer to the Quote entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a quote. You can also call the IOrganizationService.Update method.

See Also

Concepts

Quote, order, and invoice entities
Quote entity privileges
QuoteDetail (quote product) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QuoteDetail (quote product) entity messages and methods

The quote detail (quote product) entity stores a line item in a quote. Each quote can have multiple quote detail (quote product) records. The schema name for this entity is QuoteDetail. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Note
The pricing error code is specified in the QuoteDetail.PricingErrorCode attribute. The possible values for this attribute are defined in the Pricing Error global option set.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a quote detail (quote product). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a quote detail (quote product). You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a quote detail (quote product). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of quote details (quote products). You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a quote detail (quote product). You can also call the IOrganizationService.Update method.

See Also

Concepts

Quote, order, and invoice entities
QuoteDetail (quote product) entity privileges
QuoteClose activity entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QuoteClose activity entity messages and methods

A quote close records the activity generated when a quote is closed. The schema name for this entity is QuoteClose. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a quote close activity to another user or team.
CreateRequest | Creates a quote close activity. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a quote close activity. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a quote close activity with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a quote close activity previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a quote close activity. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of quote close activities. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to a quote close activity.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a quote close, and their access rights to the quote close activity.
RevokeAccessRequest | Removes all access rights to a quote close activity for the specified security principal (user or team).
SetStateRequest | Sets the state of a quote close activity. If you are using early bound types, use the QuoteCloseState enumeration to set the possible states. For a list of the state values, refer to the QuoteClose entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a quote close activity. You can also call the IOrganizationService.Update method.

See Also

Concepts

Quote, order, and invoice entities
QuoteClose entity privileges
SalesOrder (order) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SalesOrder (order) entity messages and methods

A sales order (order) is a quote that has been accepted. This entity is called order in the Microsoft Dynamics CRM application. The schema name for this entity is SalesOrder. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a sales order to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the SalesOrder entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CancelSalesOrderRequest | Cancels a sales order.
CompoundCreateRequest | Deprecated. Creates a sales order and related sales order details. Use CreateRequest.
CompoundUpdateRequest | Deprecated. Updates a sales order and related sales order details. Use UpdateRequest.
ConvertSalesOrderToInvoiceRequest | Converts a sales order to an invoice.
CreateRequest | Creates a sales order. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a sales order. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the SalesOrder entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
FulfillSalesOrderRequest | Fulfills the sales order.
GenerateSalesOrderFromOpportunityRequest | Generates a sales order from the specified opportunity.
GetQuantityDecimalRequest | Gets the quantity decimal value of a product for the entity specified in the target.
GetSalesOrderProductsFromOpportunityRequest | Retrieves the set of products for a sales order from the specified opportunity.
GrantAccessRequest | Shares a sales order with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
LockSalesOrderPricingRequest | Locks the sales order pricing.
ModifyAccessRequest | Changes the access rights for a sales order previously shared with another security principal (user or team).
RemoveRelatedRequest | Deprecated. Removes the relationship between a sales order and a contact. Use DisassociateRequest or Disassociate instead.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a sales order. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of sales orders.You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to a sales order.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a sales order, together with their access rights to the sales order.
RevokeAccessRequest | Removes all access rights to a sales order for the specified security principal (user or team).
RollupRequest | Rolls up or retrieves all the sales orders related to the specified record (account or contact).
SetRelatedRequest | Deprecated. Creates a relationship between a sales order and a contact. Use DisassociateRequest or Disassociate instead.
SetStateRequest | Sets the state of a sales order. If you are using early bound types, use the SalesOrderState enumeration to set the possible states. For a list of the state values, refer to the SalesOrder entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UnlockSalesOrderPricingRequest | Unlocks the price per unit for the products in the specified sales order (order).
UpdateRequest | Updates a sales order. You can also call the IOrganizationService.Update method.

See Also

Concepts

Quote, order, and invoice entities
SalesOrder (order) entity privileges
SalesOrderDetail (order product) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SalesOrderDetail (order product) entity messages and methods

A sales order detail (order product) entity stores a line item in an order. Each order can have multiple sales order detail instances. The schema name for this entity is SalesOrderDetail. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Note
The pricing error code is specified in the SalesOrderDetail.PricingErrorCode attribute. The possible values for this attribute are defined in the Pricing Error global option set.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a sales order detail. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a sales order detail. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a sales order detail. You can also call the IOrganizationService.Retrieve method
RetrieveMultipleRequest | Retrieves a collection of sales order details. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a sales order detail. You can also call the IOrganizationService.Update method.

See Also

Concepts

Quote, order, and invoice entities
SalesOrderDetail (order product) entity privileges
OrderClose activity entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OrderClose activity entity messages and methods

The order close entity records the activity that is automatically generated when an order is closed.

The schema name for this entity is OrderClose. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an order close activity to another user or team.
CreateRequest | Creates an order close activity. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an order close activity. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares an order close activity with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for an order close activity that was previously shared with another security principal (user or team).
RetrieveRequest | Retrieves an order close activity. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of order close activities. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to an order close activity.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to an order close activity, and their access rights to the order close activity.
RevokeAccessRequest | Removes all access rights to an order close activity for the specified security principal (user or team).
SetStateRequest | Sets the state of an order close activity. If you are using early bound types, use the OrderCloseState enumeration to set the possible states. For a list of the state values, refer to the OrderClose entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an order close activity. You can also call the IOrganizationService.Update method.

See Also

Concepts

Quote, order, and invoice entities
OrderClose entity privileges
Invoice entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Invoice entity messages and methods

An invoice is an order that has been billed. The schema name for this entity is Invoice. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an invoice to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the invoice entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CompoundCreateRequest | Deprecated. Creates an invoice and its related invoice detail. Use CreateRequest.
CompoundUpdateRequest | Deprecated. Updates an invoice and its related invoice detail. Use UpdateRequest.
CreateRequest | Creates an invoice. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an invoice. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the invoice entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GenerateInvoiceFromOpportunityRequest | Generates an invoice from an opportunity.
GetQuantityDecimalRequest | Gets the quantity decimal value of a product for the entity specified in the target.
GrantAccessRequest | Shares an invoice with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
LockInvoicePricingRequest | Locks the price per unit for the products in the specified invoice.
ModifyAccessRequest | Changes the access rights for an invoice previously shared with another security principal (user or team).
RemoveRelatedRequest | Deprecated. Removes the relationship between an invoice and a contact. Use DisassociateRequest or Disassociate instead.
RetrieveRequest | Retrieves an invoice. You can also call the IOrganizationService.Retrieve method.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveMultipleRequest | Retrieves a collection of invoices. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to an invoice
RetrieveSharedPrincipalsAndAccessRequest | Retrieves all the security principals (users or teams) that have access to an invoice, together with their access rights to the invoice.
RevokeAccessRequest | Removes all access rights to an invoice for the specified security principal (user or team).
RollupRequest | Retrieves all the invoices related to the specified record (account or contact).
SetRelatedRequest | Deprecated. Creates a relationship between an invoice and a contact. Use AssociateRequest or Associate instead.
SetStateRequest | Sets the state of an invoice. If you are using early bound types, use the InvoiceState enumeration. For a list of the state values, refer to the Invoice entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UnlockInvoicePricingRequest | Unlocks the price per unit for the products in the specified invoice.
UpdateRequest | Use this message to update an invoice. You can also call the IOrganizationService.Update method.

See Also

Concepts

Quote, order, and invoice entities
Invoice entity privileges
InvoiceDetail (invoice product) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InvoiceDetail (invoice product) entity messages and methods

An invoice product (invoice detail) stores a line item in an invoice. Each invoice can have multiple invoice detail records.

Note
The pricing error code is specified in the InvoiceDetail.PricingErrorCode attribute. The possible values for this attribute are defined in the Pricing Error global option set.

The schema name for this entity is InvoiceDetail. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an invoice detail. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an invoice detail. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an invoice detail. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of invoice details. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates an invoice detail. You can also call the IOrganizationService.Update method.

See Also

Concepts

Quote, order, and invoice entities
InvoiceDetail entity privileges

Other Resources

Sample: Set negative prices in opportunities, quotes, and sales orders

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Set negative prices in opportunities, quotes, and sales orders
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\WorkingWithNegativePrices.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to set negative prices in opportunities, quotes, and sales orders.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    ///  Show how to set negative values for amount and number attributes in
    ///  opportunities, quotes, sales orders.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class WorkingWithNegativePrices
    {
        #region Class Level Members

        private Guid _salesManagerId;
        private Guid _unitGroupId;
        private Guid _defaultUnitId;
        private Guid _product1Id;
        private Guid _product2Id;
        private Guid _priceListId;
        private Guid _priceListItem1Id;
        private Guid _priceListItem2Id;
        private Guid _catalogProductId;
        private Guid _quoteId;
        private Guid _quoteDetailId;
        private Guid _orderId;
        private Guid _orderDetailId;
        private Guid _opportunityId;
        private Guid _accountId;
        private List<Guid> _salesRepresentativeIds = new List<Guid>();
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards, an
        /// opportunity is created to demonstrate a negative estimated value. This is
        /// followed by the creation of a quote with a negative product quantity.
        /// Finally, a sales order with a negative product price is shown.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Opportunity with negative estimated value

                    // Create a new opportunity with user-specified negative
                    // estimated value.
                    Opportunity opportunity = new Opportunity
                    {
                        Name = "Example Opportunity",
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName,
                            _priceListId),
                        IsRevenueSystemCalculated = false,
                        EstimatedValue = new Money(-400.00m),
                        FreightAmount = new Money(10.00m),
                        ActualValue = new Money(-390.00m),
                        OwnerId = new EntityReference
                        {
                            Id = _salesRepresentativeIds[0],
                            LogicalName = SystemUser.EntityLogicalName
                        }
                    };
                    _opportunityId = _serviceProxy.Create(opportunity);
                    opportunity.Id = _opportunityId;

                    // Create a catalog product for the opportunity.
                    OpportunityProduct catalogProduct = new OpportunityProduct
                    {
                        OpportunityId = opportunity.ToEntityReference(),
                        ProductId = new EntityReference(Product.EntityLogicalName,
                            _product1Id),
                        UoMId = new EntityReference(UoM.EntityLogicalName,
                            _defaultUnitId),
                        Quantity = 8,
                        Tax = new Money(12.42m),
                    };
                    _catalogProductId = _serviceProxy.Create(catalogProduct);

                    Console.WriteLine("Created opportunity with negative estimated value.");

                    #endregion

                    #region Quote with negative quantity

                    // Create the quote.
                    Quote quote = new Quote()
                    {
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        Name = "Sample Quote",
                        PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName,
                            _priceListId)
                    };
                    _quoteId = _serviceProxy.Create(quote);
                    quote.Id = _quoteId;

                    // Set the quote's product quantity to a negative value.
                    QuoteDetail quoteDetail = new QuoteDetail()
                    {
                        ProductId = new EntityReference(Product.EntityLogicalName,
                            _product1Id),
                        Quantity = -4,
                        QuoteId = quote.ToEntityReference(),
                        UoMId = new EntityReference(UoM.EntityLogicalName,
                            _defaultUnitId)
                    };
                    _quoteDetailId = _serviceProxy.Create(quoteDetail);

                    Console.WriteLine("Created quote with negative quantity.");

                    #endregion

                    #region Sales Order with negative price

                    // Create the sales order.
                    SalesOrder order = new SalesOrder()
                    {
                        Name = "Faux Order",
                        DateFulfilled = new DateTime(2010, 8, 1),
                        PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName,
                            _priceListId),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        FreightAmount = new Money(20.0M)
                    };
                    _orderId = _serviceProxy.Create(order);
                    order.Id = _orderId;

                    // Add the product to the order with the price overriden with a
                    // negative value.
                    SalesOrderDetail orderDetail = new SalesOrderDetail()
                    {
                        ProductId = new EntityReference(Product.EntityLogicalName,
                            _product1Id),
                        Quantity = 4,
                        SalesOrderId = order.ToEntityReference(),
                        IsPriceOverridden = true,
                        PricePerUnit = new Money(-40.0M),
                        UoMId = new EntityReference(UoM.EntityLogicalName,
                            _defaultUnitId)
                    };
                    _orderDetailId = _serviceProxy.Create(orderDetail);

                    Console.WriteLine("Created order with negative price per unit.");

                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
           #region Create or Retrieve the necessary system users

            // Retrieve the ldapPath
            String ldapPath = String.Empty;
            // Retrieve the sales team - 1 sales manager and 2 sales representatives.
            _salesManagerId =
                SystemUserProvider.RetrieveSalesManager(_serviceProxy, ref ldapPath);
            _salesRepresentativeIds =
                SystemUserProvider.RetrieveSalespersons(_serviceProxy, ref ldapPath);

            #endregion

            #region Create records to support Opportunity records
            // Create a unit group
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };
            _unitGroupId = _serviceProxy.Create(newUnitGroup);

            // Retrieve the default unit id that was automatically created
            // when we created the Unit Group
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression
                {
                    Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "uomscheduleid",
                                Operator = ConditionOperator.Equal,
                                Values = { _unitGroupId }
                            }
                        }
                },
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };

            // Retrieve the unit.
            UoM unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];
            _defaultUnitId = unit.UoMId.Value;

            // Create a few products
            Product newProduct1 = new Product
            {
                ProductNumber = "1",
                Name = "Example Product 1",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName,
                    _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };
            _product1Id = _serviceProxy.Create(newProduct1);
            Console.WriteLine("Created {0}", newProduct1.Name);

            Product newProduct2 = new Product
            {
                ProductNumber = "2",
                Name = "Example Product 2",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 3,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName,
                    _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };
            _product2Id = _serviceProxy.Create(newProduct2);
            Console.WriteLine("Created {0}", newProduct2.Name);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };
            _priceListId = _serviceProxy.Create(newPriceList);

            // Create a price list item for the first product and apply volume discount
            ProductPriceLevel newPriceListItem1 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(20)
            };
            _priceListItem1Id = _serviceProxy.Create(newPriceListItem1);

            // Create a price list item for the second product
            ProductPriceLevel newPriceListItem2 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product2Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(15)
            };
            _priceListItem2Id = _serviceProxy.Create(newPriceListItem2);

            //Publish Product1
            SetStateRequest publishRequest1 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product1Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest1);

            //Publish Product2
            SetStateRequest publishRequest2 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product2Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest2);
            Console.WriteLine("Published both the products");

            // Create an account record for the opportunity's potential customerid
            Account newAccount = new Account
            {
                Name = "Margie's Travel",
                Address1_PostalCode = "99999"
            };
            _accountId = (_serviceProxy.Create(newAccount));

            #endregion Create records to support Opportunity records

        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            // Two of the contracts, their associated account and the contract template
            // records that were created and used in this sample will continue to exist
            // on your system because contracts that have been invoiced cannot be deleted
            // in Microsoft Dynamics CRM. They can only be put on hold or canceled.

            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(SalesOrderDetail.EntityLogicalName, _orderDetailId);
                _serviceProxy.Delete(SalesOrder.EntityLogicalName, _orderId);
                _serviceProxy.Delete(QuoteDetail.EntityLogicalName, _quoteDetailId);
                _serviceProxy.Delete(Quote.EntityLogicalName, _quoteId);
                _serviceProxy.Delete(Opportunity.EntityLogicalName, _opportunityId);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItem1Id);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItem2Id);
                _serviceProxy.Delete(PriceLevel.EntityLogicalName, _priceListId);
                _serviceProxy.Delete(Product.EntityLogicalName, _product1Id);
                _serviceProxy.Delete(Product.EntityLogicalName, _product2Id);
                _serviceProxy.Delete(UoMSchedule.EntityLogicalName, _unitGroupId);
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                WorkingWithNegativePrices app = new WorkingWithNegativePrices();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Quote, order, and invoice entities
PriceLevel (price list) entity messages and methods
Opportunity entity messages and methods

Other Resources

Sales entities (lead, opportunity, competitor, quote, order, invoice)
Sample: Set negative prices in opportunities, quotes, and sales orders

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Process quotes, sales orders and invoices
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\ProcessingQuotesAndSalesOrders.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to convert an opportunity that is won to a quote, then convert a quote to a sales order, and then convert a sales order to an invoice. It also shows how to lock and unlock the sales order and the invoice prices.

Example

C# Copy Code
using System;
using System.ServiceModel;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to convert a "won" opportunity to a quote and then convert a quote
    /// to a sales order, and a sales order to an invoice. Also demonstrates
    /// locking/unlocking prices on both sales orders and invoices.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class ProcessingQuotesAndSalesOrders
    {
        #region Class Level Members

        private Guid _opportunityId;
        private Guid _loseOpportunityId;
        private Guid _unitGroupId;
        private Guid _defaultUnitId;
        private Guid _productId;
        private Guid _priceListId;
        private Guid _priceListItemId;
        private Guid _accountId;
        private Guid _quoteId;
        private Guid _closeQuoteId;
        private Guid _quoteDetailId;
        private Guid _salesOrderId;
        private Guid _closeSalesOrderId;
        private Guid _invoiceId;

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards, a
        /// quote is created. This quote is then converted to an order, and the pricing
        /// is unlocked and relocked. This is followed by the order being converted
        /// to an invoice, and the pricing is locked then unlocked.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Create Opportunities

                    // Create an opportunity
                    var crmOpportunity = new Opportunity
                    {
                        CustomerId = new EntityReference(Account.EntityLogicalName, _accountId),
                        Name = "Sample",
                        PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName,
                            _priceListId)
                    };
                    _opportunityId = _serviceProxy.Create(crmOpportunity);

                    crmOpportunity = new Opportunity
                    {
                        CustomerId = new EntityReference(Account.EntityLogicalName, _accountId),
                        Name = "Another Sample",
                        PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName,
                            _priceListId)
                    };
                    _loseOpportunityId = _serviceProxy.Create(crmOpportunity);

                    Console.WriteLine("Opportunities created.");

                    #endregion

                    #region Win Opportunity

                    // Close the opportunity as won
                    var winOppRequest = new WinOpportunityRequest
                    {
                        OpportunityClose = new OpportunityClose
                        {
                            OpportunityId = new EntityReference
                                (Opportunity.EntityLogicalName, _opportunityId)
                        },
                        Status = new OptionSetValue((int)opportunity_statuscode.Won),
                    };

                    _serviceProxy.Execute(winOppRequest);

                    Console.WriteLine("Opportunity closed as Won.");

                    #endregion

                    #region Lose Opportunity
                    var loseOppRequest = new LoseOpportunityRequest
                    {
                        OpportunityClose = new OpportunityClose
                        {
                            OpportunityId = new EntityReference
                                (Opportunity.EntityLogicalName, _loseOpportunityId)
                        },
                        Status = new OptionSetValue((int)opportunity_statuscode.Canceled)
                    };

                    _serviceProxy.Execute(loseOppRequest);

                    Console.WriteLine("Opportunity closed as Lost.");

                    #endregion

                    #region Convert Opportunity to a Quote

                    // Convert the opportunity to a quote
                    var genQuoteFromOppRequest = new GenerateQuoteFromOpportunityRequest
                    {
                        OpportunityId = _opportunityId,
                        ColumnSet = new ColumnSet("quoteid", "name")
                    };

                    var genQuoteFromOppResponse = (GenerateQuoteFromOpportunityResponse)
                        _serviceProxy.Execute(genQuoteFromOppRequest);

                    Quote quote = genQuoteFromOppResponse.Entity.ToEntity<Quote>();
                    _quoteId = quote.Id;

                    Console.WriteLine("Quote generated from the Opportunity.");

                    #endregion

                    #region Close Quote

                    // convert the opportunity to a quote
                    genQuoteFromOppRequest = new GenerateQuoteFromOpportunityRequest
                    {
                        OpportunityId = _opportunityId,
                        ColumnSet = new ColumnSet("quoteid", "name")
                    };
                    genQuoteFromOppResponse = (GenerateQuoteFromOpportunityResponse)
                        _serviceProxy.Execute(genQuoteFromOppRequest);

                    Quote closeQuote = genQuoteFromOppResponse.Entity.ToEntity<Quote>();
                    _closeQuoteId = closeQuote.Id;

                    // Activate the quote
                    SetStateRequest activateQuote = new SetStateRequest()
                    {
                        EntityMoniker = closeQuote.ToEntityReference(),
                        State = new OptionSetValue((int)QuoteState.Active),
                        Status = new OptionSetValue((int)quote_statuscode.InProgress)
                    };
                    _serviceProxy.Execute(activateQuote);

                    // Close the quote
                    CloseQuoteRequest closeQuoteRequest = new CloseQuoteRequest()
                    {
                        QuoteClose = new QuoteClose()
                        {
                            QuoteId = closeQuote.ToEntityReference(),
                            Subject = "Quote Close " + DateTime.Now.ToString()
                        },
                        Status = new OptionSetValue(-1)
                    };
                    _serviceProxy.Execute(closeQuoteRequest);

                    Console.WriteLine("Quote Closed");

                    #endregion

                    #region Create Quote's Product

                    // Set the quote's product
                    QuoteDetail quoteDetail = new QuoteDetail()
                    {
                        ProductId = new EntityReference(Product.EntityLogicalName,
                            _productId),
                        Quantity = 1,
                        QuoteId = quote.ToEntityReference(),
                        UoMId = new EntityReference(UoM.EntityLogicalName,
                            _defaultUnitId)
                    };
                    _quoteDetailId = _serviceProxy.Create(quoteDetail);

                    Console.WriteLine("Quote Product created.");

                    // Activate the quote
                    activateQuote = new SetStateRequest()
                    {
                        EntityMoniker = quote.ToEntityReference(),
                        State = new OptionSetValue((int)QuoteState.Active),
                        Status = new OptionSetValue((int)quote_statuscode.InProgress)
                    };
                    _serviceProxy.Execute(activateQuote);

                    Console.WriteLine("Quote activated.");

                    // Mark the quote as won
                    // Note: this is necessary in order to convert a quote into a
                    // SalesOrder.
                    WinQuoteRequest winQuoteRequest = new WinQuoteRequest()
                    {
                        QuoteClose = new QuoteClose()
                        {
                            Subject = "Quote Close" + DateTime.Now.ToString(),
                            QuoteId = quote.ToEntityReference()
                        },
                        Status = new OptionSetValue(-1)
                    };
                    _serviceProxy.Execute(winQuoteRequest);

                    Console.WriteLine("Quote won.");

                    #endregion

                    #region Convert Quote to SalesOrder

                    // Define columns to be retrieved after creating the order
                    ColumnSet salesOrderColumns =
                        new ColumnSet("salesorderid", "totalamount");

                    // Convert the quote to a sales order
                    ConvertQuoteToSalesOrderRequest convertQuoteRequest =
                        new ConvertQuoteToSalesOrderRequest()
                        {
                            QuoteId = _quoteId,
                            ColumnSet = salesOrderColumns
                        };
                    ConvertQuoteToSalesOrderResponse convertQuoteResponse =
                        (ConvertQuoteToSalesOrderResponse)_serviceProxy.Execute(convertQuoteRequest);
                    SalesOrder salesOrder = (SalesOrder)convertQuoteResponse.Entity;
                    _salesOrderId = salesOrder.Id;

                    Console.WriteLine("Converted Quote to SalesOrder.");

                    #endregion

                    #region Cancel Sales Order

                    // Define columns to be retrieved after creating the order
                    salesOrderColumns = new ColumnSet("salesorderid", "totalamount");

                    // Convert the quote to a sales order
                    convertQuoteRequest =
                        new ConvertQuoteToSalesOrderRequest()
                        {
                            QuoteId = _quoteId,
                            ColumnSet = salesOrderColumns
                        };
                    convertQuoteResponse =
                        (ConvertQuoteToSalesOrderResponse)_serviceProxy.Execute(convertQuoteRequest);
                    SalesOrder closeSalesOrder = (SalesOrder)convertQuoteResponse.Entity;
                    _closeSalesOrderId = closeSalesOrder.Id;

                    CancelSalesOrderRequest cancelRequest = new CancelSalesOrderRequest()
                    {
                        OrderClose = new OrderClose()
                        {
                            SalesOrderId = closeSalesOrder.ToEntityReference(),
                            Subject = "Close Sales Order " + DateTime.Now
                        },
                        Status = new OptionSetValue(-1)
                    };
                    _serviceProxy.Execute(cancelRequest);

                    Console.WriteLine("Canceled sales order");

                    #endregion

                    #region Lock pricing on SalesOrder

                    // Note: after converting a won quote to an order, the pricing of
                    // the order is locked by default.

                    // Retrieve current price list
                    ProductPriceLevel priceListItem =
                        (ProductPriceLevel)_serviceProxy.Retrieve(
                            ProductPriceLevel.EntityLogicalName,
                            _priceListItemId,
                            new ColumnSet("productpricelevelid", "amount")
                        );

                    Console.WriteLine("Current price list retrieved.");
                    Console.WriteLine();

                    Console.WriteLine("Details before update:");
                    Console.WriteLine("----------------");
                    Console.WriteLine("Current order total: {0}",
                        salesOrder.TotalAmount.Value);
                    Console.WriteLine("Current price per item: {0}",
                        priceListItem.Amount.Value);
                    Console.WriteLine("</End of Listing>");
                    Console.WriteLine();

                    // Update the price list
                    priceListItem.Amount = new Money(30.0M);

                    UpdateRequest updatePriceListItem = new UpdateRequest()
                    {
                        Target = priceListItem,
                    };
                    _serviceProxy.Execute(updatePriceListItem);

                    Console.WriteLine("Price list updated.");

                    // Retrieve the order
                    SalesOrder updatedSalesOrder = (SalesOrder)_serviceProxy.Retrieve(
                            SalesOrder.EntityLogicalName,
                            _salesOrderId,
                            new ColumnSet("salesorderid", "totalamount")
                        );

                    Console.WriteLine("Updated order retrieved.");
                    Console.WriteLine();

                    Console.WriteLine("Details after update:");
                    Console.WriteLine("----------------");
                    Console.WriteLine("Current order total: {0}",
                        updatedSalesOrder.TotalAmount.Value);
                    Console.WriteLine("Current price per item: {0}",
                        priceListItem.Amount.Value);
                    Console.WriteLine("</End of Listing>");
                    Console.WriteLine();

                    // Unlock the order pricing
                    UnlockSalesOrderPricingRequest unlockOrderRequest =
                        new UnlockSalesOrderPricingRequest()
                        {
                            SalesOrderId = _salesOrderId
                        };
                    _serviceProxy.Execute(unlockOrderRequest);

                    Console.WriteLine("Order pricing unlocked.");

                    // Retrieve the order
                    updatedSalesOrder = (SalesOrder)_serviceProxy.Retrieve(
                            SalesOrder.EntityLogicalName,
                            _salesOrderId,
                            new ColumnSet("salesorderid", "totalamount")
                        );

                    Console.WriteLine("Updated order retrieved.");
                    Console.WriteLine();

                    Console.WriteLine("Details after update and unlock:");
                    Console.WriteLine("----------------");
                    Console.WriteLine("Current order total: {0}",
                        updatedSalesOrder.TotalAmount.Value);
                    Console.WriteLine("Current price per item: {0}",
                        priceListItem.Amount.Value);
                    Console.WriteLine("</End of Listing>");
                    Console.WriteLine();

                    // Relock the order pricing
                    LockSalesOrderPricingRequest lockOrderRequest =
                        new LockSalesOrderPricingRequest()
                        {
                            SalesOrderId = _salesOrderId
                        };
                    _serviceProxy.Execute(lockOrderRequest);

                    Console.WriteLine("Order pricing relocked.");

                    #endregion

                    #region Convert SalesOrder to Invoice

                    // Define columns to be retrieved after creating the invoice
                    ColumnSet invoiceColumns =
                        new ColumnSet("invoiceid", "totalamount");

                    // Convert the order to an invoice
                    ConvertSalesOrderToInvoiceRequest convertOrderRequest =
                        new ConvertSalesOrderToInvoiceRequest()
                        {
                            SalesOrderId = _salesOrderId,
                            ColumnSet = invoiceColumns
                        };
                    ConvertSalesOrderToInvoiceResponse convertOrderResponse =
                        (ConvertSalesOrderToInvoiceResponse)_serviceProxy.Execute(convertOrderRequest);
                    Invoice invoice = (Invoice)convertOrderResponse.Entity;
                    _invoiceId = invoice.Id;

                    Console.WriteLine("Converted SalesOrder to Invoice.");

                    #endregion

                    #region Lock pricing on Invoice

                    // Note: after converting a SalesOrder to Invoice, the pricing of
                    // the Invoice is locked by default.

                    // Retrieve current price list
                    priceListItem = (ProductPriceLevel)_serviceProxy.Retrieve(
                            ProductPriceLevel.EntityLogicalName,
                            _priceListItemId,
                            new ColumnSet("productpricelevelid", "amount")
                        );

                    Console.WriteLine("Current price list retrieved.");
                    Console.WriteLine();

                    Console.WriteLine("Details before lock and update:");
                    Console.WriteLine("----------------");
                    Console.WriteLine("Current invoice total: {0}",
                        invoice.TotalAmount.Value);
                    Console.WriteLine("Current price per item: {0}",
                        priceListItem.Amount.Value);
                    Console.WriteLine("</End of Listing>");
                    Console.WriteLine();

                    // Update the price list
                    priceListItem.Amount = new Money(40.0M);

                    updatePriceListItem = new UpdateRequest()
                    {
                        Target = priceListItem
                    };
                    _serviceProxy.Execute(updatePriceListItem);

                    Console.WriteLine("Price list updated.");

                    // Retrieve the invoice
                    Invoice updatedInvoice = (Invoice)_serviceProxy.Retrieve(
                            Invoice.EntityLogicalName,
                            _invoiceId,
                            new ColumnSet("invoiceid", "totalamount")
                        );

                    Console.WriteLine("Updated invoice retrieved.");
                    Console.WriteLine();

                    Console.WriteLine("Details after lock and update:");
                    Console.WriteLine("----------------");
                    Console.WriteLine("Current invoice total: {0}",
                        updatedInvoice.TotalAmount.Value);
                    Console.WriteLine("Current price per item: {0}",
                        priceListItem.Amount.Value);
                    Console.WriteLine("</End of Listing>");
                    Console.WriteLine();

                    // Unlock the invoice pricing
                    UnlockInvoicePricingRequest unlockInvoiceRequest =
                        new UnlockInvoicePricingRequest()
                        {
                            InvoiceId = _invoiceId
                        };
                    _serviceProxy.Execute(unlockInvoiceRequest);

                    Console.WriteLine("Invoice pricing unlocked.");

                    // Retrieve the invoice
                    updatedInvoice = (Invoice)_serviceProxy.Retrieve(
                            Invoice.EntityLogicalName,
                            _invoiceId,
                            new ColumnSet("invoiceid", "totalamount")
                        );

                    Console.WriteLine("Updated invoice retrieved.");
                    Console.WriteLine();

                    Console.WriteLine("Details after update and unlock:");
                    Console.WriteLine("----------------");
                    Console.WriteLine("Current invoice total: {0}",
                        updatedInvoice.TotalAmount.Value);
                    Console.WriteLine("Current price per item: {0}",
                        priceListItem.Amount.Value);
                    Console.WriteLine("</End of Listing>");
                    Console.WriteLine();

                    // Relock the invoice pricing
                    LockInvoicePricingRequest lockInvoiceRequest =
                        new LockInvoicePricingRequest()
                        {
                            InvoiceId = _invoiceId
                        };
                    _serviceProxy.Execute(lockInvoiceRequest);

                    Console.WriteLine("Invoice pricing relocked.");

                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a unit group
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };
            _unitGroupId = _serviceProxy.Create(newUnitGroup);
            Console.WriteLine("Create {0}", newUnitGroup.Name);

            // Retrieve the default unit id that was automatically created
            // when we created the Unit Group
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression
                {
                    Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "uomscheduleid",
                                Operator = ConditionOperator.Equal,
                                Values = { _unitGroupId }
                            }
                        }
                },
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };

            // Retrieve the unit.
            UoM unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];
            _defaultUnitId = unit.UoMId.Value;

            // Create a few products
            Product newProduct = new Product
            {
                ProductNumber = "1",
                Name = "Example Product",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 1,
                DefaultUoMScheduleId =
                    new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                DefaultUoMId =
                    new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };
            _productId = _serviceProxy.Create(newProduct);
            newProduct.Id = _productId;
            Console.WriteLine("Create {0}", newProduct.Name);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };
            _priceListId = _serviceProxy.Create(newPriceList);

            // Create a price list item for the product and apply volume discount
            ProductPriceLevel newPriceListItem = new ProductPriceLevel
            {
                PriceLevelId =
                    new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId =
                    new EntityReference(Product.EntityLogicalName, _productId),
                UoMId =
                    new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(20.0M),
            };
            _priceListItemId = _serviceProxy.Create(newPriceListItem);

            // Publish the product
            SetStateRequest publishRequest = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _productId),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest);
            Console.WriteLine("Published {0}", newProduct.Name);

            // Create an account record for the opportunity's potential customerid
            Account newAccount = new Account
            {
                Name = "Litware, Inc.",
                Address1_PostalCode = "60661"
            };
            _accountId = _serviceProxy.Create(newAccount);
            newAccount.Id = _accountId;

        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            // The three system users that were created by this sample will continue to
            // exist on your system because system users cannot be deleted in Microsoft
            // Dynamics CRM.  They can only be enabled or disabled.

            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete("invoice", _invoiceId);
                _serviceProxy.Delete("salesorder", _salesOrderId);
                _serviceProxy.Delete("salesorder", _closeSalesOrderId);
                _serviceProxy.Delete("quotedetail", _quoteDetailId);
                _serviceProxy.Delete("quote", _quoteId);
                _serviceProxy.Delete("quote", _closeQuoteId);
                _serviceProxy.Delete("opportunity", _opportunityId);
                _serviceProxy.Delete("opportunity", _loseOpportunityId);
                _serviceProxy.Delete("account", _accountId);
                _serviceProxy.Delete("productpricelevel", _priceListItemId);
                _serviceProxy.Delete("pricelevel", _priceListId);
                _serviceProxy.Delete("product", _productId);
                _serviceProxy.Delete("uomschedule", _unitGroupId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                ProcessingQuotesAndSalesOrders app = new ProcessingQuotesAndSalesOrders();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Quote, order, and invoice entities

Other Resources

Sales entities (lead, opportunity, competitor, quote, order, invoice)
Sample: Fulfill a sales order
WinQuoteRequest
ConvertQuoteToSalesOrderRequest
UnlockSalesOrderPricingRequest
LockSalesOrderPricingRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Fulfill a sales order
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagementSampleCode\FulfillSalesOrder.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a sales order and then close it by fulfilling it.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample creates a SalesOrder record and demonstrates how to use the
    /// FulfillSalesOrderRequest to deactivate the record.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.
    /// </remarks>
    public class FulfillSalesOrder
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private Guid? _salesOrderId;
        private Guid? _accountId;
        #endregion

        #region How To Sample Code

        /// <summary>
        /// Creates a sales order and shows how to close using the FulfillSalesOrderRequest
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig,
           bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();

                CreateCustomer();
                CreateSalesOrder();
                CloseSalesOrder();
                DeleteRequiredRecords(promptforDelete);
            }
        }

        /// <summary>
        /// Creates a customer for the sales order
        /// </summary>
        private void CreateCustomer()
        {
            // Create an account to be used with the sales account.
            _accountId = _serviceProxy.Create(new Account
            {
                Name = "Microsoft"
            });

            Console.WriteLine(String.Concat("Created account for sales order: ",
                _accountId.Value));
        }

        /// <summary>
        /// Creates the sales order to close
        /// </summary>
        private void CreateSalesOrder()
        {
            // Create a sales order with an account
            _salesOrderId = _serviceProxy.Create(new SalesOrder
            {
                CustomerId = new EntityReference
                {
                    LogicalName = Account.EntityLogicalName,
                    Id = _accountId.Value
                },
                Description = "Sales Order Description",
            });

            Console.WriteLine(String.Concat("Created sales order: ",
                _salesOrderId.Value));
        }

        /// <summary>
        /// Calls the FulfillSalesOrderRequest and closes it as completed
        /// </summary>
        private void CloseSalesOrder()
        {
            if (!_salesOrderId.HasValue)
                return;

            // Close the sales order with a status of Complete
            int newStatus = (int)salesorder_statuscode.Complete;
            var request = new FulfillSalesOrderRequest
            {
                OrderClose = new OrderClose
                {
                    SalesOrderId = new EntityReference
                        { LogicalName = SalesOrder.EntityLogicalName, Id = _salesOrderId.Value }

                },
                Status = new OptionSetValue(newStatus)
            };

            Console.WriteLine(String.Concat("Executing FullfillSalesOrderRequest on sales order: ",
                _salesOrderId.Value, ",\n\t new status: ",
                GetLabelForStatus(SalesOrder.EntityLogicalName, "statuscode", newStatus)));

            _serviceProxy.Execute(request);

            // Validate that the sales order is complete
            var salesOrder = _serviceProxy.Retrieve(SalesOrder.EntityLogicalName, _salesOrderId.Value,
                new ColumnSet("statuscode")).ToEntity<SalesOrder>();

            Console.WriteLine(String.Concat("Validation of closed sales order: ", _salesOrderId.Value,
                ",\n\t status: ", salesOrder.FormattedValues["statuscode"]));
        }

        /// <summary>
        /// Returns the label for a status option
        /// </summary>
        /// <param name="entity">entity logical name</param>
        /// <param name="attribute">statuscode </param>
        /// <param name="value">numeric value</param>
        /// <returns>user label</returns>
        private string GetLabelForStatus(string entity, string attribute, int value)
        {
            // Retrieve the attribute metadata
            var attributeMD = ((RetrieveAttributeResponse) _serviceProxy.Execute(
                new RetrieveAttributeRequest
                {
                    EntityLogicalName = entity,
                    LogicalName = attribute,
                    RetrieveAsIfPublished = true,
                })).AttributeMetadata;

            // find the option based on the numeric value and return the label
            if (attributeMD.AttributeType == AttributeTypeCode.Status)
            {
                var options = ((StatusAttributeMetadata)attributeMD).OptionSet.Options;

                var crmOption = options.FirstOrDefault(x => x.Value == value);
                if (crmOption != null)
                    return crmOption.Label.UserLocalizedLabel.Label;
            }

            return string.Empty;
        }

        /// <summary>
        ///
        /// </summary>
        /// <param name="prompt"></param>
        private void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete records created in this sample.  Delete the sales order first
                // or there will be an error due to restrict delete.
                if (_salesOrderId.HasValue)
                {
                    Console.WriteLine(String.Concat("Deleting sales order: ", _salesOrderId.Value));
                    _serviceProxy.Delete(SalesOrder.EntityLogicalName, _salesOrderId.Value);
                }
                if (_accountId.HasValue)
                {
                    Console.WriteLine(String.Concat("Deleting account: ", _accountId.Value));
                    _serviceProxy.Delete(Account.EntityLogicalName, _accountId.Value);
                }

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion

        #region Main method
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new FulfillSalesOrder();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion
    }
}

See Also

Concepts

Quote, order, and invoice entities

Other Resources

Sales entities (lead, opportunity, competitor, quote, order, invoice)
FulfillSalesOrderRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Marketing entities (campaign, list)

The marketing entities let you perform detailed campaign planning, manage the creation and execution of a campaign, and assess a campaign's performance.

In This Section

Campaign entities

List (marketing list) entity

Sample: Distribute a quick campaign

Sample: Distribute a quick campaign

Sample: Distribute campaign activities to qualified marketing list

Related Sections

Model your business data

Service entities (contract, incident, knowledge base, queue, calendar, entitlement, slakpiinstance)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Campaign entities

A campaign in Microsoft Dynamics CRM is designed to accomplish a specific result, such as introducing a new product or increasing market share. The main way to accomplish this result is through communicating the benefits of a product or service to people and businesses. Campaigns often include more than one communication method, such as print advertisements, promotional discounts, and direct mail. A campaign can be thought of as a container in which a business keeps planning tasks, campaign activities, and campaign responses. It has a list of related products, sales literature, and a set of marketing lists of existing or potential customers. This information is used to plan and track the results of a marketing campaign throughout its life.

Marketing automation supports campaign execution through campaign activities that are used to distribute emails, phone calls, and other activities to qualified customers. Each campaign activity may include a set of marketing lists of existing or potential customers. Bulk email may result in the responses from the customers that are captured in a campaign response record.

If you plan to distribute only one type of the activity, such as an email, use a quick campaign. The results of a quick campaign are captured in the quick campaign log.

Campaigns and Quick Campaigns

A campaign or a quick campaign can be used to accomplish the following:

  • Create campaign activities to communicate with a customer, such as sending an email, a letter, or making a telephone call.
  • Use marketing lists to distribute the campaign activities. Marketing lists are usually assembled based on certain criteria, such as customers that previously bought a particular product or used a particular service.
  • Analyze campaign responses to the campaign activities.

The following table compares campaigns and quick campaigns:

Feature Campaign Quick Campaign

Campaign activities

A campaign may include different marketing activities. Some activities, such as tasks, are assigned to team members to perform specific tasks, for example, preparing a marketing list or printing sales literature. Other activities, such as emails, faxes, or letters are distributed through multiple campaign activities represented by the campaign activity entity (CampaignActivity). Each campaign activity is used to distribute one type of activity that specifies a recipient: phone call, appointment, letter, letter vial mail merge, fax, fax via mail merge, email, email via mail merge. The activities can be distributed over a period of time and at different times.

A quick campaign distributes one type of activity that specifies a recipient: phone call, appointment, letter, letter vial mail merge, fax, fax via mail merge, email, email via mail merge. The activities are distributed to recipients at one point in time.

Marketing lists

You can distribute a campaign to the members of different marketing lists. Each campaign activity (CampaignActivity) may contain multiple lists. A marketing list contains the records of one type, such as accounts or leads. To distribute a campaign to accounts and leads, you must create two separate marketing lists.

A quick campaign can be distributed to the members of one marketing list, or to the accounts, contacts, or leads selected by a query.

Campaign response

A reply to a campaign activity can be captured in the campaign response (CampaignResponse) and converted to an opportunity, lead, order, or quote.

The results of a quick campaign are captured in the quick campaign log (BulkOperationLog).

Entities

Use the campaign (Campaign) entity, the campaign activity (CampaignActivity) entity and the campaign response (CampaignResponse) entity to distribute a campaign.

Use the bulk operation (quick campaign) (BulkOperation) entity and the bulk operation log (quick campaign log) (BulkOperationLog) entity to distribute a quick campaign.

Distribute Activities

Use the DistributeCampaignActivityRequest message to distribute a campaign activity (CampaignActivity) to the members of a marketing list.

Use the PropagateByExpressionRequest message to distribute an activity, such as email or fax, to the accounts, contacts, or leads selected by the query.

Use the CreateActivitiesListRequest message to distribute an activity, such as email or fax, to the members of a marketing list.

See Also

Concepts

BulkOperation (quick campaign) entity messages and methods
BulkOperationLog (quick campaign log) entity messages and methods
Campaign entity messages and methods
CampaignActivity entity messages and methods
CampaignResponse entity messages and methods
List (marketing list) entity

Other Resources

Sample: Distribute a quick campaign
Marketing entities (campaign, list)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkOperation (quick campaign) entity messages and methods

The bulk operation entity represents a system operation used to perform lengthy and asynchronous operations, such as distributing a campaign activity or quick campaign, on large datasets.

The schema name for this entity is BulkOperation. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
BulkOperationStatusCloseRequest | For internal use only.
CleanUpBulkOperationRequest | For internal use only.
DeleteRequest | Deletes a bulk operation. You can also call the IOrganizationService.Delete method.
LogFailureBulkOperationRequest | For internal use only.
LogSuccessBulkOperationRequest | For internal use only.
ProcessOneMemberBulkOperationRequest | For internal use only.
PropagateByExpressionRequest | Creates a quick campaign to distribute an activity to accounts, contacts or leads selected by a query.
RetrieveMultipleRequest | Retrieves a collection of bulk operations. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveRequest | Retrieves a bulk operation. You can also call the IOrganizationService.Retrieve method.
RetrieveMembersBulkOperationRequest | Retrieves the members of a bulk operation.
RetrievePrincipalAccessRequest | Retrieves the access that the security principal (user) has for the bulk operation.
StatusUpdateBulkOperationRequest | For internal use only.

See Also

Reference

BulkOperation (quick campaign) entity privileges

Concepts

Campaign entities
BulkOperationLog (quick campaign log) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkOperationLog (quick campaign log) entity messages and methods

This entity represents the log used to track bulk operation execution, successes, and failures. The schema name for this entity is BulkOperationLog. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the BulkOperationLog entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the BulkOperationLog entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a bulk operation log. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of bulk operation logs. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Reference

BulkOperation (quick campaign) entity privileges

Concepts

Campaign entities
Campaign entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Campaign entity messages and methods

A campaign represents a container for campaign activities and responses, sales literature, products, and lists to create, plan, execute, and track the results of a specific marketing campaign through its life. The schema name for this entity is Campaign. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddItemCampaignRequest | Adds an item to a campaign.
AssignRequest | Assigns a campaign to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Campaign entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CopyCampaignRequest | Copies the information from one campaign to another, and optionally, creates a campaign template.
CreateRequest | Creates a campaign. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a campaign. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Campaign entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares a campaign with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for a campaign previously shared with another security principal (user or team).
RemoveItemCampaignRequest | Removes an item from a campaign.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a campaign. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of campaigns. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a campaign.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a campaign, together with their access rights to the campaign.
RevokeAccessRequest | Removes all access to a campaign for the specified security principal (user or team).
SetStateRequest | Sets the state of a campaign. If you are using early bound types, use the CampaignState enumeration to set the possible states. For a list of the state values, refer to the campaign entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a campaign. You can also call the IOrganizationService.Update method.

See Also

Concepts

Campaign entities
Campaign entity privileges
CampaignActivity entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CampaignActivity entity messages and methods

A campaign activity represents a step in a campaign with owner, partner, budget, timelines, and other information. Campaign activities can be created for planning and running a campaign. The schema name for this entity is CampaignActivity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddItemCampaignActivityRequest | Adds an item to a campaign activity.
AssignRequest | Assigns a campaign activity to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the CampaignActivity entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a campaign activity. The campaign activity entity must have a valid parent campaign set as the CampaignActivity.RegardingObjectId. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a campaign activity. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the CampaignActivity entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
DistributeCampaignActivityRequest | Creates the appropriate activity for each member in the list for the specified campaign activity.
GrantAccessRequest | Shares a campaign activity with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for a campaign activity previously shared with another security principal (user or team).
RemoveItemCampaignActivityRequest | Removes an item from a campaign activity.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a campaign activity. You can also call the IOrganizationService.Delete method.
RetrieveMultipleRequest | Retrieves a collection of campaign activities. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a campaign activity.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to an account, and their access rights to a campaign activity.
RevokeAccessRequest | Removes all access to a campaign activity for the specified security principal (user or team).
SetStateRequest | Sets the state of a campaign activity. If you are using early bound types, use the CampaignActivityState enumeration to set the possible states. For a list of the state values, refer to the CampaignActivity entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a campaign activity. You can also call the IOrganizationService.Update method.

See Also

Concepts

Campaign entities
CampaignActivity entity privileges
CampaignResponse entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CampaignResponse entity messages and methods

A campaign response is received by the marketing team following a campaign. The response may become an opportunity, lead, order, or quote for the sales team.

The schema name for this entity is CampaignResponse. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message Description

AssignRequest

Assigns a campaign response to another user or team.

CopyCampaignResponseRequest

Copies the information from one campaign response to another.

CreateRequest

Creates a campaign response. You can also call the IOrganizationService.Create method.

Note
The campaign response entity must have a valid parent campaign set as the CampaignResponse.RegardingObjectId.

DeleteRequest

Deletes a campaign response. You can also call the IOrganizationService.Delete method.

GrantAccessRequest

Shares a campaign response with another security principal (user or team).

ModifyAccessRequest

Changes the access rights for a campaign response previously shared with another security principal (user or team).

RetrieveRequest

Retrieves a campaign response. You can also call the IOrganizationService.Delete method.

RetrieveMultipleRequest

Retrieves a collection of campaign responses. You can also call the IOrganizationService.RetrieveMultiple method.

RetrievePrincipalAccessRequest

Retrieves the access that the specified security principal (user or team) has to a campaign response.

RetrieveSharedPrincipalsAndAccessRequest

Retrieves the security principals (users or teams) that have access to a campaign, together with their access rights to the campaign response.

RevokeAccessRequest

Removes all access to a campaign response for the specified security principal (user or team).

SetStateRequest

Sets the state of a campaign response. If you are using early bound types, use the CampaignResponseState enumeration to set the possible states. For a list of the state values, refer to the CampaignResponse entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

UpdateRequest

Updates a campaign response. You can also call the IOrganizationService.Update method.

See Also

Concepts

Campaign entities
CampaignResponse entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


List (marketing list) entity

In Microsoft Dynamics CRM, list management and the list (marketing list) entity help you create lists of potential customers or existing customers for marketing purposes. Typically, a list is a potential target for a campaign. However, you can also use it for other marketing reasons. You can generate subsets of a list by using different parameters for a campaign or to run an activity in bulk mode.

There are two types of lists: static and dynamic. To specify whether the list is static or dynamic, use the List.Type attribute. All list members must be of the same entity type, such as accounts, contacts, or leads. To add the members to a static list, use the Microsoft.Crm.Sdk.Messages.AddListMembersListRequest message. The members for a dynamic list are selected dynamically based on the FetchXML query criteria during distribution of a campaign activity or a quick campaign. To specify the FetchXML criteria, use the List.Query attribute. Initially, the member count for the dynamic list is set to null. To determine how many records in the system satisfy the FetchXML query criteria, use the aggregate function on the query. You can create a new static list based on the existing dynamic list by using the Microsoft.Crm.Sdk.Messages.CopyDynamicListToStaticRequest message. The newly created static list is locked.

See Also

Concepts

List (marketing list) entity messages and methods
Use FetchXML to construct a query
Use FetchXML aggregation

Other Resources

Marketing entities (campaign, list)
Sample: Distribute a quick campaign
Microsoft.Crm.Sdk.Messages.CopyDynamicListToStaticRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


List (marketing list) entity messages and methods

A list for a sales or marketing campaign contains records of one specified entity type such as contacts, leads, or accounts. A list member is a contact, lead, or account that is added to a list.

The schema name for this entity is List. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddListMembersListRequest | Adds a list of members to a list.
AddMemberListRequest | Adds a member to a list.
AssignRequest | Assigns a list to another user or team.
CopyDynamicListToStaticRequest | Creates a static list from the specified dynamic list and adds the members that satisfy the dynamic list query criteria to the static list.
CopyMembersListRequest | Copies the members from the source list to the target list without creating duplicates.
CreateRequest | Creates a list. You can also call the IOrganizationService.Create method.
CreateActivitiesListRequest | Creates a quick campaign for a specified marketing list.
DeleteRequest | Deletes a list. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a list with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a list previously shared with another security principal (user or team).
QualifyMemberListRequest | Qualifies the specified member list and either overrides the list members or removes them.
RemoveMemberListRequest | Removes a member from a list.
RetrieveRequest | Retrieves a list. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of lists. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to a list.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a list, together with their access rights to the list.
RevokeAccessRequest | Removes all access rights to a list for the specified security principal (user or team).
SetStateRequest | Sets the state of a list. If you are using early bound types, use the ListState enumeration to set the possible states. For a list of the state values, refer to the list entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a list. You can also call the IOrganizationService.Update method.

See Also

Concepts

List (marketing list) entity
List (marketing list) entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Distribute a quick campaign
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Marketing\QuickCampaign.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create and distribute a quick campaign.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to distribute a quick campaign to the marketing list members or to the accounts selected by a query.
    /// </summary>
    public class QuickCampaign
    {
        #region Class Level Members

        // Define the IDs as well as strings needed for this sample.
        //private static string _uniqStringForThisRun;
        private Guid[] _accountIdArray;
        Email _templateEmailActivity;
        Letter _templateLetterActivity;
        private Guid _newListId;
        private Guid _currentUser;
        private Guid _qcBOId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Delete a new queue instance.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    #region Run a QC with marketing list as input

                    List newList = new List()
                    {
                        ListName = "TestList",
                        CreatedFromCode = new OptionSetValue((int)ListCreatedFromCode.Account)
                    };

                    _newListId = _serviceProxy.Create(newList);

                    for (int j = 0; j < 5; j++)
                    {
                        AddMemberListRequest addMemberListRequest = new AddMemberListRequest();
                        addMemberListRequest.EntityId = _accountIdArray[j];
                        addMemberListRequest.ListId = _newListId;
                        AddMemberListResponse addMemberListResponse =
                            _serviceProxy.Execute(addMemberListRequest) as AddMemberListResponse;
                    }

                    Guid BOId = CreateAndRetrieveQuickCampaignForMarketingList(
                        _templateLetterActivity,
                        _newListId,
                        PropagationOwnershipOptions.ListMemberOwner,
                        true);

                    #endregion

                    #region Run a QC with a list of accounts as input

                    // Construct a Query Expression(QE) which specifies which records QC should include
                    QueryExpression query = new QueryExpression("account");
                    query.ColumnSet = new ColumnSet("accountid");
                    query.Criteria = new FilterExpression();
                    FilterExpression filter = query.Criteria.AddFilter(LogicalOperator.Or);
                    for (int j = 0; j < 5; j++)
                    {
                        filter.AddCondition("accountid", ConditionOperator.Equal, _accountIdArray[j]);
                    }
                    _qcBOId = CreateAndRetrieveQuickCampaignForQueryExpression(
                        _templateEmailActivity,
                        query,
                        PropagationOwnershipOptions.ListMemberOwner,
                        true);

                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates a Quick Campaign for a set of accounts selected by a query
        /// </summary>
        /// <param name="activityEntity">
        /// An object that indicates activity type for the quick campaign and
        /// contains values for each of activity that will be created
        /// </param>
        /// <param name="query">
        /// A query that provides a list of accounts for which
        /// the quick campaign is distributed.
        /// </param>
        /// <param name="ownershipOption">
        /// Specifies who will own the activities created by the Quick Campaign
        ///	The PropagationOwnershipOptions enum is used to specify value for this parameter
        ///	</param>
        /// <param name="isPropagate">
        /// Specifies whether the operation is to be executed.
        /// This input is often 'true' for Quick Campaign
        /// </param>
        /// <returns></returns>
        public Guid CreateAndRetrieveQuickCampaignForQueryExpression(Entity emailActivityEntity,
            QueryExpression query, PropagationOwnershipOptions ownershipOption, bool isPropagate)
        {

            // create the bulkoperation
            PropagateByExpressionRequest request = new PropagateByExpressionRequest() {
                Activity = emailActivityEntity,
                ExecuteImmediately = false, // Default value.
                FriendlyName = "Query Based Quick Campaign",
                OwnershipOptions = ownershipOption,
                QueryExpression = query,
                Owner = new EntityReference("systemuser", _currentUser),
                PostWorkflowEvent = true,
                SendEmail = false,
                TemplateId = Guid.Empty
            };

            PropagateByExpressionResponse response =
                (PropagateByExpressionResponse)_serviceProxy.Execute(request);

            Guid bulkOpId = response.BulkOperationId;
            System.Console.WriteLine(
                "Quick Campaign with following name has been created. "
                + "Please verify in Web app manually: \n"
                + request.FriendlyName + "\nPress enter to continue....");
            System.Console.ReadLine();
            return bulkOpId;

        }

        /// <summary>
        /// This method creates Quick Campaign for a given Marketing List and retruns the
        /// Guid of the Quich Campaign which is modelled as bulk operation in CRM
        /// </summary>
        /// <param name="activityEntity">
        /// An object that indicates activity type for the quick campaign and
        /// contains values for each activity that will be created
        /// </param>
        /// <param name="marketingListId">
        /// The ID of the marketing list to which quick campaign is distributed
        /// </param>
        /// <param name="ownershipOption">
        /// Specifies who will own the activities created by the Quick Campaign
        ///	The PropagationOwnershipOptions enum is used to specify value for this parameter
        ///	</param>
        /// <param name="isPropagate">
        /// Specifies whether the operation is to be executed.
        /// This input is often 'true' for Quick Campaign
        /// </param>
        public Guid CreateAndRetrieveQuickCampaignForMarketingList(
            Entity letterActivityEntity,
            Guid marketingListId,
            PropagationOwnershipOptions ownershipOption,
            bool isPropagate)
        {
            //Create the request object from input parameters
            CreateActivitiesListRequest request = new CreateActivitiesListRequest() {
                Activity = letterActivityEntity,
                ListId = marketingListId,
                OwnershipOptions = ownershipOption,
                Propagate = isPropagate,
                TemplateId = Guid.Empty,
                FriendlyName = "Quick Campaign for My List",
                Owner = new EntityReference("systemuser", _currentUser),
                PostWorkflowEvent = true
            };

            //Execute the request
            CreateActivitiesListResponse response =
                (CreateActivitiesListResponse)_serviceProxy.Execute(request);

            //On executing the request a BulkOperation record would be created in CRM.
            //If isPropagate is true, a corresponding Async job is also created which runs and creates the required activities
            //The response has BulkOperationId. This is the Id of the bulkoperation that mimics QuickCampaign in CRM
            Guid BOId = response.BulkOperationId;
            System.Console.WriteLine(
                "Quick Campaign with following name has been created. "
                + "Please verify in Web app manually: \n"
                + request.FriendlyName
                + "\nPress enter to continue....");
            System.Console.ReadLine();

            return BOId;

        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a new queue instance.
        /// </summary>
        public void CreateRequiredRecords()
        {
            WhoAmIRequest whoRequest = new WhoAmIRequest();
            _currentUser = ((WhoAmIResponse)_serviceProxy.Execute(whoRequest)).UserId;

            //Create an activity objects which will act like a template during QC distrbution.
            //The activities created by QC will create activities with content that this activity has
            _templateEmailActivity = new Email()
            {
                Subject = "qcCreatedEmailActivity"
            };

            _templateLetterActivity = new Letter()
            {
                Subject = "qcCreatedLetterActivity"
            };

            // Create accounts on which we want to run QC
            _accountIdArray = new Guid[5];
            for (int i = 0; i < 5; i++)
            {
                Account acct = new Account() {
                    Name = "Account For Quick Campaign " + i.ToString()
                };
                _accountIdArray[i] = _serviceProxy.Create(acct);
                Console.WriteLine("Created {0}.", acct.Name);
            }
        }

        /// <summary>
        /// Deletes/Reverts the record that was created/changed for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                for (int i = 0; i<_accountIdArray.Length; i++)
                    _serviceProxy.Delete(Account.EntityLogicalName, _accountIdArray[i]);
                _serviceProxy.Delete(List.EntityLogicalName, _newListId);
                _serviceProxy.Delete(BulkOperation.EntityLogicalName, _qcBOId);
                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                QuickCampaign app = new QuickCampaign();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additonal exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main method
    }
}

See Also

Concepts

Campaign entities
BulkOperation (quick campaign) entity messages and methods
List (marketing list) entity

Other Resources

Sample: Distribute campaign activities to dynamic and static lists
Marketing entities (campaign, list)
AddMemberListRequest
PropagateByExpressionRequest
CreateActivitiesListRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Distribute campaign activities to dynamic and static lists
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Marketing\MarketingAutomation.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a dynamic marketing list, copy it to the static marketing list, and distribute campaign activities to the members of the marketing lists.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Linq;
// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;
// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrate how to create a dynamic list and distribute campaign activities to
    /// the members on the list.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class MarketingAutomation
    {
        #region Class Level Members

        private Guid _salesManagerId;
        private Guid _accountId;
        private Guid _campaignId;
        private Guid _campaignActivityId;
        private Guid _dynamicListId;
        private Guid _staticListId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards a dynamic
        /// list is created and associated to the campaign and the campaign's activity.
        /// Then the dynamic list is copied to a static list and associated with the same
        /// campaign and campaign activity. Finally the sample distributes the campaign
        /// to both the dynamic and static lists.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Create Dynamic List

                    // Create FetchXml for marketing list's query which locates accounts
                    // in Seattle.
                    String fetchXml = @"<fetch version='1.0' output-format='xml-platform' mapping='logical' distinct='false'>
                                        <entity name='account'>
                                        <attribute name='name' />
                                        <attribute name='address1_city' />
                                        <attribute name='primarycontactid' />
                                        <attribute name='telephone1' />
                                        <attribute name='accountid' />
                                        <order attribute='name' descending='false' />
                                        <filter type='and'>
                                        <condition attribute='address1_city' operator='eq' value='seattle' />
                                        </filter>
                                        </entity>
                                        </fetch>";
                    // Create dynamic list. Set the type to true to declare a dynamic
                    // list.
                    List dynamicList = new List()
                    {
                        Type = true,
                        ListName = "Dynamic List",
                        CreatedFromCode = new OptionSetValue((int)ListCreatedFromCode.Account),
                        Query = fetchXml
                    };
                    _dynamicListId = _serviceProxy.Create(dynamicList);
                    dynamicList.Id = _dynamicListId;

                    Console.WriteLine("Created dynamic list.");

                    #endregion

                    #region Associate dynamic list to campaign

                    // Create a campaign.
                    Campaign campaign = new Campaign()
                    {
                        Name = "Sample Campaign"
                    };
                    _campaignId = _serviceProxy.Create(campaign);
                    campaign.Id = _campaignId;

                    // Add the dynamic list to the campaign.
                    AddItemCampaignRequest addListToCampaignRequest =
                        new AddItemCampaignRequest()
                        {
                            CampaignId = _campaignId,
                            EntityId = _dynamicListId,
                            EntityName = List.EntityLogicalName,
                        };
                    _serviceProxy.Execute(addListToCampaignRequest);

                    Console.WriteLine("Added dynamic list to the campaign.");

                    // Create a campaign activity to distribute fax to the list members.
                    CampaignActivity campaignActivity = new CampaignActivity()
                    {
                        Subject = "Sample Campaign Activity",
                        ChannelTypeCode = new OptionSetValue((int)CampaignActivityChannelTypeCode.Fax),
                        RegardingObjectId = campaign.ToEntityReference()
                    };
                    _campaignActivityId = _serviceProxy.Create(campaignActivity);

                    // Add dynamic list to campaign activity.
                    AddItemCampaignActivityRequest addListToCampaignActivityRequest =
                        new AddItemCampaignActivityRequest()
                    {
                        CampaignActivityId = _campaignActivityId,
                        ItemId = _dynamicListId,
                        EntityName = List.EntityLogicalName
                    };
                    _serviceProxy.Execute(addListToCampaignActivityRequest);

                    Console.WriteLine("Added dynamic list to the campaign activity.");

                    #endregion

                    #region Associate static list to campaign

                    // Copy the dynamic list to a static list.
                    CopyDynamicListToStaticRequest copyRequest =
                        new CopyDynamicListToStaticRequest()
                        {
                            ListId = _dynamicListId
                        };
                    CopyDynamicListToStaticResponse copyResponse =
                        (CopyDynamicListToStaticResponse)_serviceProxy.Execute(copyRequest);
                    _staticListId = copyResponse.StaticListId;

                    Console.WriteLine("Copied dynamic list to a static list.");

                    // Add the static list to the campaign.
                    AddItemCampaignRequest addStaticListToCampaignRequest =
                        new AddItemCampaignRequest()
                        {
                            CampaignId = _campaignId,
                            EntityId = _staticListId,
                            EntityName = List.EntityLogicalName
                        };
                    _serviceProxy.Execute(addStaticListToCampaignRequest);

                    Console.WriteLine("Added static list to the campaign.");

                    // Add the static list to the campaign activity.
                    AddItemCampaignActivityRequest addStaticListToCampaignActivityRequest =
                        new AddItemCampaignActivityRequest()
                    {
                        CampaignActivityId = _campaignActivityId,
                        ItemId = _staticListId,
                        EntityName = List.EntityLogicalName
                    };
                    _serviceProxy.Execute(addStaticListToCampaignActivityRequest);

                    Console.WriteLine("Added static list to the campaign's activity.");

                    #endregion

                    #region Create fax for campaign's activity
                    // Create a fax.
                    Fax fax = new Fax()
                    {
                        Subject = "Example Fax"
                    };

                    Console.WriteLine("Created fax for campaign's activity.");
                    #endregion Create fax for campaign's activity

                    #region Distribute fax to the marketing list
                    // Distribute the campaign activity to the marketing lists.
                    DistributeCampaignActivityRequest distributeRequest =
                        new DistributeCampaignActivityRequest()
                        {
                            CampaignActivityId = _campaignActivityId,
                            Activity = fax,
                            Owner = new EntityReference("systemuser", _salesManagerId),
                            Propagate = true,
                            SendEmail = false,
                            PostWorkflowEvent = true
                        };
                    _serviceProxy.Execute(distributeRequest);

                    Console.WriteLine("Distributed fax to the marketing lists.");
                    #endregion Distribute fax to the marketing list

                    #region Retrieve collection of entities from marketing list
                    // Retrieve a collection of entities that correspond
                    // to all of the members in a marketing list
                    // This approach of retrieving list members allows you to dynamically
                    // retrieve the members of a list programmatically without requiring
                    // knowledge of the member entity type.
                    OrganizationServiceContext orgContext =
                        new OrganizationServiceContext(_serviceProxy);

                    var member = (from mb in orgContext.CreateQuery<List>()
                                  where mb.Id == _dynamicListId
                                  select mb).FirstOrDefault();

                    string fetchQuery = member.Query;

                    RetrieveMultipleRequest memberRequest = new RetrieveMultipleRequest();
                    FetchExpression fetch = new FetchExpression(fetchQuery);
                    memberRequest.Query = fetch;
                    RetrieveMultipleResponse memberResponse =
                        (RetrieveMultipleResponse)_serviceProxy.Execute(memberRequest);

                    Console.WriteLine("Retrieved collection of entities from a marketing list.");
                    #endregion Retrieve collection of entities from marketing list

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Retrieve a sales manager.
            _salesManagerId =
                SystemUserProvider.RetrieveMarketingManager(_serviceProxy);

            // Create an account.
            Account account = new Account()
            {
                Name = "Fourth Coffee",
                Address1_City = "Seattle"
            };
            _accountId = _serviceProxy.Create(account);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete(List.EntityLogicalName, _staticListId);
                _serviceProxy.Delete(List.EntityLogicalName, _dynamicListId);
                _serviceProxy.Delete("campaignactivity", _campaignActivityId);
                _serviceProxy.Delete("campaign", _campaignId);
                _serviceProxy.Delete("account", _accountId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                MarketingAutomation app = new MarketingAutomation();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Campaign entities
List (marketing list) entity

Other Resources

Sample: Distribute a quick campaign
Marketing entities (campaign, list)
Sample: Distribute campaign activities to qualified marketing list
AddMemberListRequest
AddItemCampaignRequest
AddItemCampaignActivityRequest
CopyDynamicListToStaticRequest
DistributeCampaignActivityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Distribute campaign activities to qualified marketing list
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Marketing\DistributeCampaignFromMarketingList.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to distribute campaign activities to the qualified members of a marketing list.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    public class DistributeCampaignFromMarketingList
    {
        #region Class Level Members

        private Guid _accountId;
        private OrganizationServiceProxy _serviceProxy;
        private readonly List<Guid> _contactIdList = new List<Guid>();
        private Guid _marketingListId;
        private Guid _copiedMarketingListId;
        private Guid _campaignId;
        private  Guid _campaignActivityId;
        private Guid _originalCampaignId;

        #endregion Class Level Members

        #region Nested Classes

        // This static class contains the possible values for marketing list types.
        private static class MarketingListType
        {
            internal static bool Static = false;
            internal static bool Dynamic = true;
        }

        // This static class contains values for overriding or removing when making a qualify
        // member list request.  (Overriding means replacing all members of the list with
        // the specified members in the request.)
        private static class OverrideOrRemove
        {
            internal static bool Override = true;
            internal static bool Remove = false;
        }

        #endregion Nested Classes

        #region How To Sample Code

        public void Run(ServerConnection.Configuration serverConfig,
        bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early bound type support.
                _serviceProxy.EnableProxyTypes();
                CreateRequiredRecords();
                CreateMarketingList();
                DistributeCampaign();
                DeleteRecords(promptforDelete);
            }
        }

        private void DistributeCampaign()
        {
            Console.WriteLine("=== Creating and Distributing the Campaign ===");
            // Create the campaign.
            var campaign = new Campaign
            {
                Name = "Sample Campaign"
            };

            _originalCampaignId = _serviceProxy.Create(campaign);

            NotifyEntityCreated(Campaign.EntityLogicalName, _originalCampaignId);

            // Copy the campaign.
            var campaignCopyRequest = new CopyCampaignRequest
            {
                BaseCampaign = _originalCampaignId
            };

            var copyCampaignResponse =
                (CopyCampaignResponse)_serviceProxy.Execute(campaignCopyRequest);
            _campaignId = copyCampaignResponse.CampaignCopyId;

            Console.WriteLine("  Copied the campaign to new campaign with GUID \r\n\t{{{0}}}",
                _campaignId);

            var activity = new CampaignActivity
            {
                Subject = "Sample phone call",
                ChannelTypeCode = new OptionSetValue((int)CampaignActivityChannelTypeCode.Phone),
                RegardingObjectId = new EntityReference(
                    Campaign.EntityLogicalName, _campaignId)
            };

            _campaignActivityId = _serviceProxy.Create(activity);

            NotifyEntityCreated(CampaignActivity.EntityLogicalName, _campaignActivityId);

            // Find the current user to determine who the owner of the activity should be.
            var whoAmI = new WhoAmIRequest();
            var currentUser = (WhoAmIResponse)_serviceProxy.Execute(whoAmI);

            // Add the marketing list created earlier to the campaign.
            var addListToCampaignRequest = new AddItemCampaignRequest
            {
                CampaignId = _campaignId,
                EntityId = _copiedMarketingListId,
                EntityName = List.EntityLogicalName,
            };

            _serviceProxy.Execute(addListToCampaignRequest);

            Console.WriteLine("  Added the marketing list to the campaign.");

            // Add the marketing list created earlier to the campaign activity.
            var addListToActivityRequest = new AddItemCampaignActivityRequest
            {
                CampaignActivityId = _campaignActivityId,
                ItemId = _copiedMarketingListId,
                EntityName = List.EntityLogicalName
            };

            _serviceProxy.Execute(addListToActivityRequest);

            Console.WriteLine("  Added the marketing list to the campaign activity.");

            // Create the phone call to use for distribution.
            var phonecall = new PhoneCall
            {
                Subject = "Sample Phone Call"
            };

            // Distribute and execute the campaign activity.
            // PostWorkflowEvent signals Microsoft Dynamics CRM to actually create the phone call activities.
            // Propagate also signals to Microsoft Dynamics CRM to create the phone call activities.
            // OwnershipOptions indicates whom the created activities should be assigned
            // to.
            var distributeRequest = new DistributeCampaignActivityRequest
            {
                Activity = phonecall,
                CampaignActivityId = _campaignActivityId,
                Owner = new EntityReference(
                    SystemUser.EntityLogicalName, currentUser.UserId),
                OwnershipOptions = PropagationOwnershipOptions.Caller,
                PostWorkflowEvent = true,
                Propagate = true,
                SendEmail = false,
            };

            var distributeResponse =
                (DistributeCampaignActivityResponse)_serviceProxy.Execute(distributeRequest);

            Console.WriteLine("  Distributed and executed the campaign activity to the marketing list.");

            // Retrieve the members that were distributed to.
            var retrieveMembersRequest = new RetrieveMembersBulkOperationRequest
            {
                BulkOperationId = distributeResponse.BulkOperationId,
                BulkOperationSource = (int)BulkOperationSource.CampaignActivity,
                EntitySource = (int)EntitySource.Contact,
                Query = new QueryExpression(Contact.EntityLogicalName)
            };

            var retrieveMembersResponse = (RetrieveMembersBulkOperationResponse)
                _serviceProxy.Execute(retrieveMembersRequest);

            Console.WriteLine("  Contacts with the following GUIDs were distributed to:");
            foreach (var member in retrieveMembersResponse.EntityCollection.Entities)
            {
                Console.WriteLine("\t{{{0}}}", member.Id);
            }
        }

        private void CreateMarketingList()
        {
            Console.WriteLine("=== Creating the Marketing List ===");
            // Create the marketing list.  Make it static because members are going to be
            // added to the list.
            var list = new List
            {
                CreatedFromCode = new OptionSetValue((int)ListCreatedFromCode.Contact),
                ListName = "Sample Contact Marketing List",
                Type = MarketingListType.Static
            };

            _marketingListId = _serviceProxy.Create(list);

            NotifyEntityCreated(List.EntityLogicalName, _marketingListId);

            // Add a list of contacts to the marketing list.
            var addMemberListReq = new AddListMembersListRequest
            {
                MemberIds = new[] { _contactIdList[0], _contactIdList[2] },
                ListId = _marketingListId
            };

            _serviceProxy.Execute(addMemberListReq);

            Console.WriteLine("  Contacts with GUIDs \r\n\t{{{0}}}\r\n\tand {{{1}}}\r\n  were added to the list.",
                _contactIdList[0], _contactIdList[1]);

            // Copy the marketing list.  First create a new one, and then copy over the
            // members.
            list.ListName = list.ListName + " Copy";
            _copiedMarketingListId = _serviceProxy.Create(list);
            var copyRequest = new CopyMembersListRequest
            {
                SourceListId = _marketingListId,
                TargetListId = _copiedMarketingListId
            };

            _serviceProxy.Execute(copyRequest);

            // Add a single contact to the copied marketing list.
            var addMemberReq = new AddMemberListRequest
            {
                EntityId = _contactIdList[1],
                ListId = _copiedMarketingListId
            };

            _serviceProxy.Execute(addMemberReq);

            Console.WriteLine("  Contact with GUID\r\n\t{{{0}}}\r\n  was added to the list.",
                _contactIdList[1]);

            // Qualify the marketing list.
            var qualifyRequest = new QualifyMemberListRequest
            {
                OverrideorRemove = OverrideOrRemove.Override,
                MembersId = new[] { _contactIdList[0], _contactIdList[1] },
                ListId = _copiedMarketingListId
            };

            _serviceProxy.Execute(qualifyRequest);

            Console.WriteLine("  Qualified the copied marketing list so that it only\r\n    includes the first two members.");
        }

        private void NotifyEntityCreated(string entityName, Guid entityId)
        {
            Console.WriteLine("  {0} created with GUID {{{1}}}",
                entityName, entityId);
        }

        private void CreateRequiredRecords()
        {
            // Create an account.
            var account = new Account
            {
                Name = "Litware, Inc.",
                Address1_StateOrProvince = "Colorado"
            };
            _accountId = _serviceProxy.Create(account);

            // Create the contacts.
            var contact = new Contact
            {
                FirstName = "Ben",
                LastName = "Andrews",
                EMailAddress1 = "sample@example.com",
                Address1_City = "Redmond",
                Address1_StateOrProvince = "WA",
                Address1_Telephone1 = "(206)555-5555",
                ParentCustomerId = new EntityReference
                {
                    Id = _accountId,
                    LogicalName = account.LogicalName
                }
            };
            _contactIdList.Add(_serviceProxy.Create(contact));

            contact = new Contact
            {
                FirstName = "Colin",
                LastName = "Wilcox",
                EMailAddress1 = "sample@example.com",
                Address1_City = "Bellevue",
                Address1_StateOrProvince = "WA",
                Address1_Telephone1 = "(425)555-5555",
                ParentCustomerId = new EntityReference
                {
                    Id = _accountId,
                    LogicalName = account.LogicalName
                }
            };
            _contactIdList.Add(_serviceProxy.Create(contact));

            contact = new Contact
            {
                FirstName = "Lisa",
                LastName = "Andrews",
                EMailAddress1 = "sample@example.com",
                Address1_City = "Redmond",
                Address1_StateOrProvince = "WA",
                Address1_Telephone1 = "(206)555-5556",
                ParentCustomerId = new EntityReference
                {
                    Id = _accountId,
                    LogicalName = account.LogicalName
                }
            };
            _contactIdList.Add(_serviceProxy.Create(contact));

        }

        private void RemoveRelationships()
        {
            // Remove the marketing list from the campaign activity.
            var removeFromCampaignActivity = new RemoveItemCampaignActivityRequest
            {
                CampaignActivityId = _campaignActivityId,
                ItemId = _copiedMarketingListId
            };

            _serviceProxy.Execute(removeFromCampaignActivity);
            Console.WriteLine("  Removed the marketing list from the campaign activity.");

            // Remove the marketing list from the campaign.
            var removeFromCampaign = new RemoveItemCampaignRequest
            {
                CampaignId = _campaignId,
                EntityId = _copiedMarketingListId
            };

            _serviceProxy.Execute(removeFromCampaign);
            Console.WriteLine("  Removed the marketing list from the campaign.");
        }

        private void DeleteRecords(bool prompt)
        {
            var toBeDeleted = true;
            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                RemoveRelationships();

                // Delete the marketing lists.
                _serviceProxy.Delete(List.EntityLogicalName, _marketingListId);
                _serviceProxy.Delete(List.EntityLogicalName, _copiedMarketingListId);

                // Delete the contacts.
                foreach (var contactId in _contactIdList)
                {
                    _serviceProxy.Delete(Contact.EntityLogicalName, contactId);
                }

                // Delete the account.
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);

                // Just delete the campaign, no need to delete the campaign activity.
                _serviceProxy.Delete(Campaign.EntityLogicalName, _campaignId);
                _serviceProxy.Delete(Campaign.EntityLogicalName, _originalCampaignId);
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new DistributeCampaignFromMarketingList();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Campaign entities
List (marketing list) entity

Other Resources

Sample: Distribute a quick campaign
Sample: Distribute campaign activities to dynamic and static lists
Marketing entities (campaign, list)
AddMemberListRequest
AddItemCampaignRequest
AddItemCampaignActivityRequest
QualifyMemberListRequest
DistributeCampaignActivityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Service entities (contract, incident, knowledge base, queue, calendar, entitlement, slakpiinstance)

The entities described in this section are targeted at the customer service department of an organization.

Note
In addition to the entities linked to later in this topic, there are several entities that will appear to support a set of messages or could be used with the IOrganizationService methods. However, the following entities are for internal use only:

  • ConvertRule (Case Creation Rule): Defines the settings for automatic case creation.
  • ConvertRuleItem (Case Creation Rule Item): Defines the individual conditions required for creating case automatically.
  • RoutingRule (Routing Rule Set): Defines a set of rules to route cases automatically to queues, users, or teams.
  • RoutingRuleItem (Rule Item): Defines the individual conditions required for routing the cases.
  • SLA: Contains information about the service level agreements for cases that belong to different customers.
  • SLAItem (SLA Item) : Contains information about a tracked service level agreement (SLA) key performance indicator and the condition when it is applicable for case records.
While these entities appear to support common messages and methods, they also have a dependency on the web application so that certain messages will not work as expected when called directly from the web services. You should not use these entities in your code.

In This Section

Contract entities

Incident (case) entities

Knowledge base entities

Queue entities

Calendar entities

Entitlement entities

SLAKPIInstance (SLA KPI instance) entity messages and methods

Related Sections

Model your business data

Activity entities

Server-side synchronization entities

Goal management entities

Product catalog entities

Sales literature entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Contract entities

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, a contract is an agreement to provide support during specified coverage dates or for a specified number of cases or length of time. When customers contact customer service, the level of support they receive is determined by their contract.

The contract entity is used to track customer service agreements. You can create contracts for existing customers that specify the type of service and terms that apply to each customer. New contracts are created based on the contract template. You can create contracts only for existing accounts and contacts.

A contract has the status of “Draft” until it is invoiced. You can change the contract template until the contract status changes. Each new contract is assigned a unique ID that can’t be used for another contract unless it is being renewed. When you renew a contract, it is saved as a draft with an ID that corresponds to the original contract. If a contract with a status of “Invoiced” or “Active” is modified, the amended contract remains associated with the original account.

In This Section

Contract entity messages and methods

ContractDetail (contract line) entity messages and methods

Sample: Manage contracts

Related Sections

Service entities (contract, incident, knowledge base, queue, calendar, entitlement, slakpiinstance)

Incident (case) entities

Knowledge base entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Contract entity messages and methods

A contract is an agreement to provide customer service support during specified coverage dates or for a specified number of cases or length of time. When customers contact customer service, the level of support they receive is determined by their contract.

The schema name for this entity is Contract. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a contract to another user or team.
CancelContractRequest | Cancels a contract.
CloneContractRequest | Copies a contract.
CreateRequest | Creates a contract. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a contract. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a contract with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a contract previously shared with another security principal (user or team).
RenewContractRequest | Renews a contract.
RetrieveRequest | Retrieves a contract. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of contracts. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a contract.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a contract, together with their access rights to the contract.
RevokeAccessRequest | Removes all access to a contract for the specified security principal (user or team).
RollupRequest | Rolls up or retrieves all the contracts related to the specified account or contact.
SetStateRequest | Sets the state of a contract. If you are using early bound types, use the ContractState enumeration to set the possible states. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.
UpdateRequest | Updates a contract. You can also call the IOrganizationService.Update method.

See Also

Concepts

ContractDetail (contract line) entity messages and methods
Contract entity privileges

Other Resources

Contract entities
Sample: Manage contracts

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ContractDetail (contract line) entity messages and methods

A contract detail contains a detailed description of the type of service to which a customer is entitled. The application display name for this entity is contract line. The schema name for this entity is ContractDetail. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a contract detail. You can also call theIOrganizationService.Create method.
DeleteRequest | Deletes a contract detail. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a contract detail. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of contract details. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a contract detail. If you are using early bound types, use the ContractDetailState enumeration to set the possible states. For a list of the state values, see the ContractDetail entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a contract detail. You can also call the IOrganizationService.Update method.

See Also

Concepts

Contract entity messages and methods
ContractDetail (contract line) entity privileges

Other Resources

Contract entities
Sample: Manage contracts

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Manage contracts
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Service\WorkingWithContracts.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create and manage contracts.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do manage contract records programmatically.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class WorkingWithContracts
    {
        #region Class Level Members

        private Guid _accountId;
        private Guid _contractId;
        private Guid _contractTemplateId;
        private Guid _firstCloneId;
        private Guid _secondCloneId;
        private Guid _renewedId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// a Contract Template and several Contracts are created, demonstrating how to
        /// create and work with the Contract entity.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Create Contract Template

                    // First, attempt to retrieve the Contract Template. Otherwise,
                    // create the template.
                    QueryExpression templateQuery = new QueryExpression()
                    {
                        EntityName = ContractTemplate.EntityLogicalName,
                        ColumnSet = new ColumnSet("contracttemplateid"),
                        Criteria =
                        {
                            Conditions =
                            {
                                new ConditionExpression("abbreviation", ConditionOperator.Equal, "SCT")
                            }
                        }
                    };
                    EntityCollection ec = _serviceProxy.RetrieveMultiple(templateQuery);

                    if (ec.Entities.Count > 0)
                    {
                        _contractTemplateId = ec.Entities[0].Id;
                        Console.Write("Template retrieved, ");
                    }
                    else
                    {
                        ContractTemplate contractTemplate = new ContractTemplate()
                        {
                            Name = "Sample Contract Template",
                            BillingFrequencyCode = new OptionSetValue((int)ContractTemplateBillingFrequencyCode.Monthly),
                            Abbreviation = "SCT",
                            AllotmentTypeCode = new OptionSetValue((int)ContractTemplateAllotmentTypeCode.NumberofCases),
                            EffectivityCalendar =
                                "--------+++++++++---------------+++++++++---------------+++++++++---------------+++++++++---------------+++++++++-------------------------------------------------------"
                        };
                        _contractTemplateId = _serviceProxy.Create(contractTemplate);
                        Console.Write("Template created, ");
                    }

                    #endregion

                    #region Create Contract

                    // Create a Contract from the Contract Template.
                    Contract contract = new Contract()
                    {
                        Title = "Sample Contract",
                        ContractTemplateId = new EntityReference
                        {
                            Id = _contractTemplateId,
                            LogicalName = ContractTemplate.EntityLogicalName
                        },
                        CustomerId = new EntityReference
                        {
                            Id = _accountId,
                            LogicalName = Account.EntityLogicalName
                        },
                        BillingCustomerId = new EntityReference
                        {
                            Id = _accountId,
                            LogicalName = Account.EntityLogicalName
                        },
                        ActiveOn = new DateTime(2015, 1, 1),
                        ExpiresOn = new DateTime(2020, 1, 1),
                        BillingStartOn = new DateTime(2015, 1, 1),
                        BillingEndOn = new DateTime(2020, 1, 1)
                    };
                    _contractId = _serviceProxy.Create(contract);

                    Console.Write("parent contract created, ");

                    // Create a contract line item.
                    ContractDetail contractLineItem = new ContractDetail()
                    {
                        Title = "Sample Contract Line Item",
                        ContractId = new EntityReference
                        {
                            Id = _contractId,
                            LogicalName = Contract.EntityLogicalName
                        },
                        CustomerId = new EntityReference
                        {
                            Id = _accountId,
                            LogicalName = Account.EntityLogicalName
                        },
                        ActiveOn = new DateTime(2015, 1, 1),
                        ExpiresOn = new DateTime(2020, 1, 1),
                        Price = new Money(20.0M),
                        TotalAllotments = 20
                    };
                    _serviceProxy.Create(contractLineItem);

                    Console.Write("contract line attached, ");

                    #endregion

                    #region Clone contract twice

                    // Create the first clone of the contract.
                    CloneContractRequest cloneRequest = new CloneContractRequest()
                    {
                        ContractId = _contractId,
                        IncludeCanceledLines = false
                    };
                    CloneContractResponse cloneResponse =
                        (CloneContractResponse)_serviceProxy.Execute(cloneRequest);
                    _firstCloneId = ((Contract)cloneResponse.Entity).ContractId.Value;

                    Console.Write("first clone created, ");

                    // Create the second clone of the contract.
                    cloneRequest = new CloneContractRequest()
                    {
                        ContractId = _contractId,
                        IncludeCanceledLines = true
                    };
                    cloneResponse =
                        (CloneContractResponse)_serviceProxy.Execute(cloneRequest);
                    _secondCloneId = ((Contract)cloneResponse.Entity).ContractId.Value;

                    Console.Write("second clone created. \n");

                    // Retrieve all Contracts.
                    QueryExpression contractQuery = new QueryExpression()
                    {
                        EntityName = Contract.EntityLogicalName,
                        ColumnSet = new ColumnSet("contractid"),
                        Criteria =
                        {
                            Conditions =
                            {
                                new ConditionExpression("customerid", ConditionOperator.Equal, _accountId)
                            }
                        }
                    };
                    EntityCollection contracts = _serviceProxy.RetrieveMultiple(contractQuery);

                    // Display the retrieved Contract Ids.
                    for (int i = 0; i < contracts.Entities.Count; i++)
                    {
                        Console.WriteLine("Retrieved contract with Id: {0}",
                            ((Contract)contracts.Entities[i]).ContractId);
                    }

                    #endregion

                    #region Deactivate a cloned contract

                    // In order to deactivate a contract (put it on hold), it is first
                    // necessary to invoice the contract.
                    SetStateRequest setStateRequest = new SetStateRequest()
                    {
                        EntityMoniker = new EntityReference
                        {
                            Id = _firstCloneId,
                            LogicalName = Contract.EntityLogicalName
                        },
                        State = new OptionSetValue((int)ContractState.Invoiced),
                        Status = new OptionSetValue(2)
                    };
                    _serviceProxy.Execute(setStateRequest);

                    Console.Write("Contract invoiced, ");

                    // Now that the contract has been invoiced, it is possible to put
                    // the contract on hold.
                    setStateRequest = new SetStateRequest()
                    {
                        EntityMoniker = new EntityReference
                        {
                            Id = _firstCloneId,
                            LogicalName = Contract.EntityLogicalName
                        },
                        State = new OptionSetValue((int)ContractState.OnHold),
                        Status = new OptionSetValue(4)
                    };
                    _serviceProxy.Execute(setStateRequest);

                    Console.Write("and put on hold.\n");

                    #endregion

                    #region Renew an invoiced contract

                    // In order to renew a contract, it must be invoiced first, and
                    // then canceled.

                    // Invoice the contract.
                    setStateRequest = new SetStateRequest()
                    {
                        EntityMoniker = new EntityReference
                        {
                            Id = _contractId,
                            LogicalName = Contract.EntityLogicalName
                        },
                        State = new OptionSetValue((int)ContractState.Invoiced),
                        Status = new OptionSetValue(3)
                    };
                    _serviceProxy.Execute(setStateRequest);

                    Console.Write("Contract invoiced, ");

                    // Cancel the contract.
                    setStateRequest = new SetStateRequest()
                    {
                        EntityMoniker = new EntityReference
                        {
                            Id = _contractId,
                            LogicalName = Contract.EntityLogicalName
                        },
                        State = new OptionSetValue((int)ContractState.Canceled),
                        Status = new OptionSetValue(5)
                    };
                    _serviceProxy.Execute(setStateRequest);

                    Console.Write("canceled, ");

                    // Renew the canceled contract.
                    RenewContractRequest renewRequest = new RenewContractRequest()
                    {
                        ContractId = _contractId,
                        IncludeCanceledLines = true,
                        Status = 1
                    };
                    RenewContractResponse renewResponse =
                        (RenewContractResponse)_serviceProxy.Execute(renewRequest);

                    // Retrieve Id of renewed contract.
                    _renewedId = ((Contract)renewResponse.Entity).ContractId.Value;

                    // Display the Id of the renewed contract.
                    Console.WriteLine("and renewed.");

                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Instantiate an Account object.
            // See the Entity Metadata topic in the SDK documentation to determine
            // which attributes must be set for each entity.
            Account setupAccount = new Account()
            {
                Name = "Litware, Inc."
            };
            _accountId = _serviceProxy.Create(setupAccount);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            // Two of the contracts, their associated account and the contract template
            // records that were created and used in this sample will continue to exist
            // on your system because contracts that have been invoiced cannot be deleted
            // in Microsoft Dynamics CRM. They can only be put on hold or canceled.

            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(Contract.EntityLogicalName, _secondCloneId);
                _serviceProxy.Delete(Contract.EntityLogicalName, _renewedId);
                _serviceProxy.Delete(Contract.EntityLogicalName, _contractId);
                SetStateRequest setStateRequest = new SetStateRequest()
                {
                    EntityMoniker = new EntityReference
                    {
                        Id = _firstCloneId,
                        LogicalName = Contract.EntityLogicalName
                    },
                    State = new OptionSetValue((int)ContractState.Invoiced),
                    Status = new OptionSetValue(3)
                };
                _serviceProxy.Execute(setStateRequest);
                setStateRequest = new SetStateRequest()
                {
                    EntityMoniker = new EntityReference
                    {
                        Id = _firstCloneId,
                        LogicalName = Contract.EntityLogicalName
                    },
                    State = new OptionSetValue((int)ContractState.Canceled),
                    Status = new OptionSetValue(5)
                };
                _serviceProxy.Execute(setStateRequest);
                _serviceProxy.Delete(Contract.EntityLogicalName, _firstCloneId);
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                WorkingWithContracts app = new WorkingWithContracts();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Contract entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Incident (case) entities

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, incident management is the primary aspect of the customer service part of the Microsoft Dynamics CRM SDK. The other features, such as the knowledge base, are used to help manage cases. In Microsoft Dynamics CRM, an incident is referred to as a case.

A customer service representative creates an incident (case) to track a customer request, question, or a problem. All actions and communications can be tracked in the incident entity. An incident can be in one of three states: Active, Resolved, or Canceled.

By using the incident management APIs, you can create reports to measure statistics, such as individual customer service representative statistics (call lengths, resolutions, and so on) and the average length of time that incidents remain active.

Microsoft Dynamics CRM supports the ability to track many incidents and activities. Many of these tasks overlap with activities in sales force automation. Routing and queuing is the process of moving activities and cases from the customer to the correct customer service representative for service request completion.

In This Section

Incident (case) entity messages and methods

Incident (case) hierarchies

IncidentResolution (case resolution) entity messages and methods

Sample: Close an incident

Related Sections

Contract entities

Knowledge base entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Incident (case) entity messages and methods

An incident (case) is a customer service issue, which is a problem that is defined by a customer and the collection of activities that occur in the case to resolve the problem.

The schema name for this entity is Incident. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Note
The incident entity ResponsibleContactId lookup attribute should be considered deprecated and the PrimaryContactId lookup attribute introduced with the Microsoft Dynamics CRM 2013 Service Pack 1 (SP1) release should be considered the primary system lookup attribute to associate incidents with a contact record.

There are no plans to remove the ResponsibleContactId lookup attribute, but if you plan to create new customizations you should use PrimaryContactId rather than ResponsibleContactId. If you have existing customizations that currently use ResponsibleContactId, you should consider migrating them to use PrimaryContactId instead.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message Description

ApplyRoutingRuleRequest

This message was added in the CRM Online Spring ‘14 and Microsoft Dynamics CRM 2013 Service Pack 1 (SP1) release.

Applies the active routing rule to the case.

AssignRequest

Assigns an incident to another user or team.

AssociateRequest

Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on entity records. For a list of default relationships for this entity, refer to the Incident entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

CalculateTotalTimeIncidentRequest

Calculates the total time that was spent on the incident.

CloseIncidentRequest

Sets the state of the incident to Closed.

CreateRequest

Creates an incident. You can also call the IOrganizationService.Create method.

DisassociateRequest

Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on entity records. For a list of default relationships for this entity, refer to the Incident entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

DeleteRequest

Deletes an incident. You can also call the IOrganizationService.Delete method.

GrantAccessRequest

Shares an incident with another security principal (user or team).

IsValidStateTransitionRequest

Validates if the incident is ready to be closed.

MergeRequest

Merging Incidents was added with the CRM Online Spring ‘14 and CRM 2013 Service Pack 1 (on-premises) release.

Note
The behavior of a merge operation for incidents is different from merging accounts, contacts, or leads. More information: MergeRequest

ModifyAccessRequest

Changes the access rights for an incident previously shared with another security principal (user or team).

RetrieveRequest

Retrieves an incident. You can also call the IOrganizationService.Retrieve method.

RetrieveMultipleRequest

Retrieves a collection of incidents. You can also call the IOrganizationService.RetrieveMultiple method.

RetrievePrincipalAccessRequest

Retrieves the access rights that the specified security principal (user or team) has to an incident.

RetrieveSharedPrincipalsAndAccessRequest

Retrieves all the security principals (users or teams) that have access to an incident, together with their access rights to the incident.

RevokeAccessRequest

Removes all access rights to an incident for the specified security principal (user or team).

RollupRequest

Rolls up or retrieves all the incidents related to the specified incident or contact.

SetStateRequest

Sets the state of an incident. If you are using early bound types, use the IncidentState enumeration to set the possible states. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

UpdateRequest

Updates an incident. You can also call the IOrganizationService.Update method.

See Also

Concepts

IncidentResolution (case resolution) entity messages and methods
Incident (Case) entity privileges

Other Resources

Incident (case) entities
Sample: Close an incident

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Incident (case) hierarchies

Incident entities can be related hierarchically. An administrator can use the Parent and Child case settings to configure specific behaviors for these relationships.

Within the application, people can create a new child incident or associate an existing incident to a parent incident. This association uses the incident_parent_incident relationship. When you create a new incident to be associated using this relationship, use the InitializeFromRequest message to initialize the new incident with the default values defined in the attribute mapping for this relationship. The Parent and Child case settings allow easy access to specify the attribute mappings to this relationship, but they may also be set by editing the relationship in the application or programmatically. More information: Customization Guide : Mapping entity fields and Customize entity and attribute mappings.

The following behaviors are enforced for incident hierarchies:

  • Only one level of hierarchy is supported. You can’t set an incident as a parent while it is a child of another incident.
    • If you try to associate a child incident for an incident that is already the child of another incident you will get error -2147224493 with the message: “You can't create child cases for child cases.”
    • If you try to associate an incident that is a parent incident as a child of another incident you will get error -2147224491 with the message: “You can't add a parent case as a child case.”
  • Each incident can have up to 100 child incidents. If you try to create too many child incidents you will get error -2147224492 with the message: “A Parent Case cannot have more than 100 child cases. Contact your administrator for more details.”
  • Incidents associated with different parent incidents cannot be merged. The error message is “You can’t merge cases that have different parent cases.”

Rules for deactivating cases

The Parent and Child case settings in the application also allow you to configure additional cascade closure preferences. Depending on how the hierarchies are configured for the organization, specific rules around deactivating incidents should be followed to align with the preferences of the organization. When an incident is deactivated, its state is set to either resolved or canceled.

When Parent and Child case settings are configured in the application, data is stored in the following Boolean attributes of the organization entity.

Attribute | UI Label
CascadeStatusUpdate | Close all child cases when parent case is closed
RestrictStatusUpdate | Don’t allow parent case closure until all child cases are closed

Based on the values of these attributes the following rules are applied by the platform.

CascadeStatusUpdate value | RestrictStatusUpdate value | Behavior
false | false | When the Specify closure preference option in the Parent and Child case settings is not selected, incidents can be deactivated regardless of the status of parent or child incidents.
false | true | Parent incidents can’t be deactivated if any active child incidents exist. If you attempt to do this, you get error -2147224495 with the message: “You can't resolve the parent case because it has {0} active child cases.”
true | false | When parent incidents are deactivated, any active child incidents are also deactivated.
true | true | The application won’t allow both of these values to be set. You shouldn’t set both of these organization attribute values to true.

See Also

Concepts

Incident (case) entity messages and methods
IncidentResolution (case resolution) entity messages and methods

Other Resources

Service entities (contract, incident, knowledge base, queue, calendar, entitlement, slakpiinstance)
Incident (case) entities
Sample: Close an incident

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


IncidentResolution (case resolution) entity messages and methods

An incident resolution (case resolution) is a special type of activity that is created when an incident is closed. It includes the description of the resolution, billing status, and the duration of the case. The schema name for this entity is IncidentResolution. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the CaseResolution entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates an incident resolution. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an incident resolution. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the IncidentResolution entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares an incident resolution with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for an incident resolution previously shared with another security principal (user or team).
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves an incident resolution. You can also call the IOrganizationService.Delete method.
RetrieveMultipleRequest | Retrieves a collection of incident resolutions. You can also call the IOrganizationService.Retrieve method.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to an incident resolution.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to an incident resolution, and also retrieves their access rights to the campaign.
RevokeAccessRequest | Removes all access rights to an incident resolution for the specified security principal (user or team).
SetStateRequest | Sets the state of an incident resolution. If you are using early bound types, use the IncidentResolutionState enumeration to set the possible states. For a list of the state values, refer to the IncidentResolution entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an incident resolution. You can also call the IOrganizationService.Update method.

See Also

Concepts

Incident (case) entity messages and methods
IncidentResolution (case resolution) entity privileges

Other Resources

Incident (case) entities
Sample: Close an incident

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Close an incident
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Service\CloseAnIncident.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to process and close an incident (case) with a case resolution.

Example

C# Copy Code
using System;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    public class CloseAnIncident
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private Guid _incidentId;
        private Guid _appointmentId;
        private Guid _accountId;
        #endregion

        #region How To Sample Code

        public void Run(ServerConnection.Configuration serverConfig,
            bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early bound type support.
                _serviceProxy.EnableProxyTypes();
                CreateRequiredRecords();
                RunIncidentManipulation();
                DeleteRecords(promptforDelete);
            }
        }

        private void RunIncidentManipulation()
        {
            Console.WriteLine("=== Creating and Closing an Incident (Case) ===");

            // Create an incident.
            var incident = new Incident
            {
                CustomerId = new EntityReference(Account.EntityLogicalName, _accountId),
                Title = "Sample Incident"
            };

            _incidentId = _serviceProxy.Create(incident);
            NotifyEntityCreated(Incident.EntityLogicalName, _incidentId);

            // Create a 30-minute appointment regarding the incident.
            var appointment = new Appointment
            {
                ScheduledStart = DateTime.Now,
                ScheduledEnd = DateTime.Now.Add(new TimeSpan(0, 30, 0)),
                Subject = "Sample 30-minute Appointment",
                RegardingObjectId = new EntityReference(Incident.EntityLogicalName,
                    _incidentId)
            };

            _appointmentId = _serviceProxy.Create(appointment);
            NotifyEntityCreated(Appointment.EntityLogicalName, _appointmentId);

            // Show the time spent on the incident before closing the appointment.
            NotifyTimeSpentOnIncident();
            // Check the validity of the state transition to closed on the incident.
            NotifyValidityOfIncidentSolvedStateChange();
            // Close the appointment.
            var setAppointmentStateReq = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Appointment.EntityLogicalName,
                    _appointmentId),
                State = new OptionSetValue((int)AppointmentState.Completed),
                Status = new OptionSetValue((int)appointment_statuscode.Completed)
            };

            _serviceProxy.Execute(setAppointmentStateReq);

            Console.WriteLine("  Appointment state set to completed.");

            // Show the time spent on the incident after closing the appointment.
            NotifyTimeSpentOnIncident();
            // Check the validity of the state transition to closed again.
            NotifyValidityOfIncidentSolvedStateChange();

            // Create the incident's resolution.
            var incidentResolution = new IncidentResolution
            {
                Subject = "Resolved Sample Incident",
                IncidentId = new EntityReference(Incident.EntityLogicalName, _incidentId)
            };

            // Close the incident with the resolution.
            var closeIncidentRequest = new CloseIncidentRequest
            {
                IncidentResolution = incidentResolution,
                Status = new OptionSetValue((int)incident_statuscode.ProblemSolved)
            };

            _serviceProxy.Execute(closeIncidentRequest);

            Console.WriteLine("  Incident closed.");
        }

        private void NotifyValidityOfIncidentSolvedStateChange()
        {
            // Validate the state transition.
            var isValidRequest = new IsValidStateTransitionRequest
            {
                Entity = new EntityReference(Incident.EntityLogicalName, _incidentId),
                NewState = IncidentState.Resolved.ToString(),
                NewStatus = (int)incident_statuscode.ProblemSolved
            };

            var response =
                (IsValidStateTransitionResponse)_serviceProxy.Execute(isValidRequest);
            var isValidString = response.IsValid ? "is valid" : "is not valid";
            Console.WriteLine("  The transition to a completed status reason {0}.",
                isValidString);
        }

        private void NotifyTimeSpentOnIncident()
        {
            // Calculate the total number of minutes spent on an incident.
            var calculateRequestTime = new CalculateTotalTimeIncidentRequest
            {
                IncidentId = _incidentId
            };
            var response =
                (CalculateTotalTimeIncidentResponse)_serviceProxy.Execute(calculateRequestTime);

            Console.WriteLine("  {0} minutes have been spent on the incident.",
                response.TotalTime);
        }

        private void NotifyEntityCreated(String entityName, Guid entityId)
        {
            Console.WriteLine("  {0} created with GUID {{{1}}}",
                entityName, entityId);
        }

        private void CreateRequiredRecords()
        {
            // Create an account to act as a customer for the incident.
            var account = new Account
            {
                Name = "Litware, Inc.",
                Address1_StateOrProvince = "Colorado"
            };
            _accountId = (_serviceProxy.Create(account));
        }

        private void DeleteRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // The account is all that needs to be deleted.  Everything else will be
                // deleted with it.
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new CloseAnIncident();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Incident (case) entities
CloseIncidentRequest
IsValidStateTransitionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Knowledge base entities

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, a knowledge base is a collection of articles with one or more headers. It is searchable by keyword, header text, title, and subject. It also supports full-text search.

With the knowledge base, you can manage the distribution of product and service information for a business unit. Answers to users' questions can be stored in the knowledge base. The underlying content organization is displayed in the subject tree.

The knowledge base architecture consists of a metadata-driven repository that makes it possible to link questions to various types of content (such as documents, articles, graphics, and webpages) as document indexes. Also supported is a structured knowledge base article and template system.

In This Section

Create, publish and search for an article

KbArticle (article) entity messages and methods

KbArticleComment (article comment) entity messages and methods

Sample: Search and retrieve articles

Related Sections

Contract entities

Incident (case) entities

Service entities (contract, incident, knowledge base, queue, calendar, entitlement, slakpiinstance)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create, publish and search for an article

During its lifecycle, an article can be in the following states:

  • Draft (after an article is created)
  • Unapproved (during editing)
  • Published (after an article is published)

To change the state of the article, use the SetStateRequest message. For early bound types, use the KbArticleState enumeration to set the possible states.

Associate an article with a template

When you create an article, you have to associate it with a template and a subject. An article template describes the sections and formatting for the article. Subjects are used to organize the articles by business categories that are also used to group cases (incidents), sales literature, and products. A best practice is to create a subject tree hierarchy and all necessary article templates before you create an article.

Note
Microsoft Dynamics CRM provides several article templates. They include a standard article, a solution to a problem, a procedure, and other templates. The recommended method of creating article templates is by using the Microsoft Dynamics CRM web application. If you want to create an article template programmatically, use existing article templates as examples of what information to include and how to format the data.

To associate an article with a template, use the KbArticle. KbArticleTemplateId attribute. To place an article in a specific category by specifying a subject, use the KbArticle.SubjectId attribute.

Specify the title of the article and the keywords that you want to use in the search. To describe an article you can use the KbArticle.Description attribute. To add the content for the article, use the KbArticle.Content attribute. Use the Kbarticle.ArticleXml attribute to add the XML data for article. The KbArticle.LanguageCode value is obtained from the template to help you write the queries that sort the articles by the language.

When an article is created it is saved as a draft. After that, you can change the state of the article from “Draft” to “Unapproved.” You can modify the content of an unapproved article and make it ready for publishing. When the article is ready to be published, change the state from “Unapproved” to “Published.”

An unpublished article obtains the format settings from a template. If you change a template format, the changes are automatically propagated to articles in the “Draft” and “Unapproved” states.

After you publish an article, you can add comments (KbArticleComment), but you can’t edit it, regardless of your privileges. The comments can be added to the article that is in any of the states.

Note
The comments can be added to the article in any state: Draft, Unapproved or Published.

To revise or update the article, you have to unpublish it. To unpublish an article, change the state of the article from Published to Unapproved. To delete an article from the Microsoft Dynamics CRM database, change the state of the article from Published to Unapproved or Draft.

Note
A knowledge base article cannot be deleted, if it is in the Published state.

For more information on creating, updating, editing, and locating an article in the knowledge base, see Use articles in knowledge base.

See Also

Concepts

KbArticle (article) entity messages and methods

Other Resources

Knowledge base entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


KbArticle (article) entity messages and methods

A knowledge base article is a type of structured content that is managed internally as part of a knowledge base. The schema name for this entity is KbArticle. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a knowledge base article. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a knowledge base article. You can also call the IOrganizationService.Delete method.
RetrieveByTopIncidentProductKbArticleRequest | Retrieves the top ten knowledge base articles for the product specified.
RetrieveByTopIncidentSubjectKbArticleRequest | Retrieves the top ten knowledge base articles for the subject specified.
RetrieveRequest | Retrieves a knowledge base article. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of knowledge base articles. You can also call the IOrganizationService.RetrieveMultiple method.
SearchByBodyKbArticleRequest | Finds all the document indexes that contain the specified text in the body.
SearchByKeywordsKbArticleRequest | Finds all the document indexes that contain the specified keywords.
SearchByTitleKbArticleRequest | Finds all the document indexes that contain the specified text in the title.
SetStateRequest | Sets the state of a knowledge base article. If you are using early bound types, use the KbArticleState enumeration to set the possible states. For a list of the state values, see the KbArticle entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a knowledge base article. You can also call the IOrganizationService.Update method.

See Also

Concepts

Create, publish and search for an article
KbArticleComment (article comment) entity messages and methods
KbArticle (article) entity privileges

Other Resources

Knowledge base entities
Sample: Search and retrieve articles

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


KbArticleComment (article comment) entity messages and methods

A knowledge base comment is used to capture comments on a knowledge base article.

The schema name for this entity is KbArticleComment. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

message | Description
CreateRequest | Creates a knowledge base article comment. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a knowledge base article comment. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a knowledge base article comment. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of a knowledge base article comments. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a knowledge base article comment. You can also call the IOrganizationService.Update method.

See Also

Concepts

Create, publish and search for an article
KbArticle (article) entity messages and methods
KbArticle (article) entity privileges

Other Resources

Knowledge base entities
Sample: Search and retrieve articles

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Search and retrieve articles
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Service\SearchAndRetrieveArticles.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to search by body, keyword, and title, and retrieve articles by topic incident subject and topic incident product.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to search by body, keyword and title, and retrieve articles by
    /// topic incident subject and topic incident product.
    /// </summary>
    /// <param name="serverConfig">Contains server connection information.</param>
    /// <param name="promptforDelete">When True, the user will be prompted to delete all
    /// created entities.</param>
    public class SearchAndRetrieveArticles
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;
        private ServiceContext _context;

        private KbArticle[] _articles = new KbArticle[3];
        private Guid _subjectId;
        private Incident _incident;
        private Account _account;
        private Product _product;
        private UoM _uom;
        private UoMSchedule _uomSchedule;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first creates sample articles and publishes them, then searches
        /// for the articles by body, keyword and title. Finally, it retrieves the
        /// articles by top incident subject and top incident product.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                // Using the ServiceContext class makes the queries easier
                using (_context = new ServiceContext(_serviceProxy))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Search Knowledge base by Body

                    // Create the request
                    SearchByBodyKbArticleRequest searchByBodyRequest =
                        new SearchByBodyKbArticleRequest()
                    {
                        SubjectId = _subjectId,
                        UseInflection = true, // allows for a different tense or
                        // inflection to be substituted for the search text
                        SearchText = "contained", // will also match on 'contains'
                        QueryExpression = new QueryExpression()
                        {
                            ColumnSet = new ColumnSet("articlexml"),
                            EntityName = KbArticle.EntityLogicalName
                        }
                    };

                    // Execute the request
                    Console.WriteLine("  Searching for published article with 'contained' in the body");

                    SearchByBodyKbArticleResponse seachByBodyResponse =
                        (SearchByBodyKbArticleResponse)_context.Execute(searchByBodyRequest);

                    // Check success
                    var retrievedArticleBodies = seachByBodyResponse.EntityCollection.Entities
                        .Select((entity) => ((KbArticle)entity).ArticleXml);

                    if (retrievedArticleBodies.Count() == 0)
                        throw new Exception("No articles found");

                    Console.WriteLine("  Results of search (article bodies found):");
                    foreach (var body in retrievedArticleBodies)
                        Console.WriteLine(body);

                    #endregion

                    #region Search knowledge base by Keyword

                    // Create the request
                    SearchByKeywordsKbArticleRequest searchByKeywordRequest =
                        new SearchByKeywordsKbArticleRequest()
                    {
                        SubjectId = _subjectId,
                        UseInflection = true,
                        SearchText = "Search",
                        QueryExpression = new QueryExpression()
                        {
                            ColumnSet = new ColumnSet("keywords"),
                            EntityName = KbArticle.EntityLogicalName
                        }
                    };

                    // Execute the request
                    Console.WriteLine();
                    Console.WriteLine("  Searching for published article with 'search' as a keyword");
                    var searchByKeywordResponse =
                        (SearchByKeywordsKbArticleResponse)_context.Execute(searchByKeywordRequest);

                    // Check success
                    var retrievedArticleKeywords = searchByKeywordResponse.EntityCollection.Entities
                        .Select((entity) => (KbArticle)entity);

                    if (retrievedArticleKeywords.Count() == 0)
                        throw new Exception("No articles found");

                    Console.WriteLine("  Results of search (keywords found):");
                    foreach (var article in retrievedArticleKeywords)
                        Console.WriteLine(article.KeyWords);

                    #endregion

                    #region Search knowledge base by Title

                    // create the request
                    SearchByTitleKbArticleRequest searchByTitleRequest =
                        new SearchByTitleKbArticleRequest()
                    {
                        SubjectId = _subjectId,
                        UseInflection = false,
                        SearchText = "code",
                        QueryExpression = new QueryExpression()
                        {
                            ColumnSet = new ColumnSet("title"),
                            EntityName = KbArticle.EntityLogicalName
                        }
                    };

                    // execute the request
                    Console.WriteLine();
                    Console.WriteLine("  Searching for published articles with 'code' in the title");
                    var searchByTitleResponse = (SearchByTitleKbArticleResponse)
                        _context.Execute(searchByTitleRequest);

                    // check success
                    var retrievedArticles = searchByTitleResponse.EntityCollection.Entities
                        .Select((entity) => (KbArticle)entity);
                    Console.WriteLine("  Results of search (titles found):");
                    foreach (var article in retrievedArticles)
                        Console.WriteLine(article.Title);

                    #endregion

                    #region Retrieve by top incident subject

                    // create the request
                    var retrieveByTopIncidentSubjectRequest =
                        new RetrieveByTopIncidentSubjectKbArticleRequest()
                    {
                        SubjectId = _subjectId
                    };

                    // execute request
                    Console.WriteLine();
                    Console.WriteLine("  Searching for the top articles in subject 'Default Subject'");
                    var retrieveByTopIncidentSubjectResponse = (RetrieveByTopIncidentSubjectKbArticleResponse)
                        _context.Execute(retrieveByTopIncidentSubjectRequest);

                    // check success
                    var articles = retrieveByTopIncidentSubjectResponse.EntityCollection.Entities.Select(
                        (entity) => (KbArticle)entity);
                    Console.WriteLine("  Top articles in subject 'Default Subject':");
                    foreach (var article in articles)
                        Console.WriteLine(article.Title);

                    #endregion

                    #region Retrieve by top incident product

                    // create the request
                    var retrieveByTopIncidentProductRequest =
                        new RetrieveByTopIncidentProductKbArticleRequest()
                    {
                        ProductId = _product.Id
                    };

                    // execute request
                    Console.WriteLine();
                    Console.WriteLine("  Searching for the top articles for product 'Sample Product'");
                    var retrieveByTopIncidentProductResponse = (RetrieveByTopIncidentProductKbArticleResponse)
                        _context.Execute(retrieveByTopIncidentProductRequest);

                    // check success
                    articles = retrieveByTopIncidentProductResponse.EntityCollection.Entities.Select(
                        (entity) => (KbArticle)entity);
                    Console.WriteLine("  Top articles for product 'Sample Product':");
                    foreach (var article in articles)
                        Console.WriteLine(article.Title);

                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #region Public methods

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            #region create kb articles

            Console.WriteLine("  Creating KB Articles");

            _subjectId = (
                          from subject in _context.SubjectSet
                          where subject.Title == "Default Subject"
                          select subject.Id
                         ).First();

            var kbArticleTemplateId = (
                                       from articleTemplate in _context.KbArticleTemplateSet
                                       where articleTemplate.Title == "Standard KB Article"
                                       select articleTemplate.Id
                                      ).FirstOrDefault();

            if (kbArticleTemplateId != Guid.Empty)
            {
                // create a KB article
                _articles[0] = new KbArticle()
                {
                    // set the article properties
                    Title = "Searching the knowledge base",
                    ArticleXml = @"
                <articledata>
                    <section id='0'>
                        <content><![CDATA[This is a sample article about searching the knowledge base.]]></content>
                    </section>
                    <section id='1'>
                        <content><![CDATA[Knowledge bases contain information useful for various people.]]></content>
                    </section>
                </articledata>",
                    // use the built-in "Standard KB Article" template
                    KbArticleTemplateId = new EntityReference(KbArticleTemplate.EntityLogicalName,
                        kbArticleTemplateId),
                    // use the default subject
                    SubjectId = new EntityReference(Subject.EntityLogicalName, _subjectId),
                    KeyWords = "Searching Knowledge base"
                };
                _context.AddObject(_articles[0]);

                _articles[1] = new KbArticle()
                {
                    Title = "What's in a knowledge base",
                    ArticleXml = @"
                            <articledata>
                                <section id='0'>
                                    <content><![CDATA[This is a sample article about what would be in a knowledge base.]]></content>
                                </section>
                                <section id='1'>
                                    <content><![CDATA[This section contains more information.]]></content>
                                </section>
                            </articledata>",
                    KbArticleTemplateId = new EntityReference(KbArticleTemplate.EntityLogicalName,
                       kbArticleTemplateId),
                    SubjectId = new EntityReference(Subject.EntityLogicalName, _subjectId),
                    KeyWords = "Knowledge base"
                };
                _context.AddObject(_articles[1]);

                _articles[2] = new KbArticle()
                {
                    Title = "Searching the knowledge base from code",
                    ArticleXml = @"
                            <articledata>
                                <section id='0'>
                                    <content><![CDATA[This article covers searching the knowledge base from code.]]></content>
                                </section>
                                <section id='1'>
                                    <content><![CDATA[This section contains more information.]]></content>
                                </section>
                            </articledata>",
                    KbArticleTemplateId = new EntityReference(KbArticleTemplate.EntityLogicalName,
                       kbArticleTemplateId),
                    SubjectId = new EntityReference(Subject.EntityLogicalName, _subjectId),
                    KeyWords = "Knowledge base code"
                };
                _context.AddObject(_articles[2]);
                _context.SaveChanges();
            }
            else
            {
                throw new ArgumentException("Standard Article Templates are missing");
            }
            #endregion

            #region Submit the articles

            Console.WriteLine("  Submitting the articles");

            foreach (var article in _articles)
            {
                _context.Execute(new SetStateRequest
                {
                    EntityMoniker = article.ToEntityReference(),
                    State = new OptionSetValue((int)KbArticleState.Unapproved),
                    Status = new OptionSetValue((int)kbarticle_statuscode.Unapproved)
                });
            }

            #endregion

            #region Approve and Publish the article

            Console.WriteLine("  Publishing articles");

            foreach (var article in _articles)
            {
                _context.Execute(new SetStateRequest
                {
                    EntityMoniker = article.ToEntityReference(),
                    State = new OptionSetValue((int)KbArticleState.Published),
                    Status = new OptionSetValue((int)kbarticle_statuscode.Published)
                });
            }

            #endregion

            #region Waiting for publishing to finish

            // Wait 20 seconds to ensure that data will be available
            // Full-text indexing
            Console.WriteLine("  Waiting 20 seconds to ensure indexing has completed on the new records.");
            System.Threading.Thread.Sleep(20000);
            Console.WriteLine();

            #endregion

            #region Add cases to KbArticles

            // Create UoM
            _uomSchedule = new UoMSchedule()
            {
                Name = "Sample unit group",
                BaseUoMName = "Sample base unit"
            };
            _context.AddObject(_uomSchedule);
            _context.SaveChanges();

            _uom = (from uom in _context.UoMSet
                    where uom.Name == _uomSchedule.BaseUoMName
                    select uom).First();

            Console.WriteLine("  Creating an account and incidents for the KB articles");
            var whoami = (WhoAmIResponse)_context.Execute(new WhoAmIRequest());

            _account = new Account()
            {
                Name = "Coho Winery",
            };
            _context.AddObject(_account);
            _context.SaveChanges();

            _product = new Product()
            {
                Name = "Sample Product",
                ProductNumber = "0",
                ProductStructure = new OptionSetValue(1),
                DefaultUoMScheduleId = _uomSchedule.ToEntityReference(),
                DefaultUoMId = _uom.ToEntityReference()
            };

            _context.AddObject(_product);
            _context.SaveChanges();

            // Publish Product
            SetStateRequest publishRequest = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product.Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _context.Execute(publishRequest);

            _incident = new Incident()
            {
                Title = "A sample incident",
                OwnerId = new EntityReference(SystemUser.EntityLogicalName, whoami.UserId),
                KbArticleId = _articles[0].ToEntityReference(),
                CustomerId = _account.ToEntityReference(),
                SubjectId = new EntityReference(Subject.EntityLogicalName, _subjectId),
                ProductId = _product.ToEntityReference()
            };
            _context.AddObject(_incident);
            _context.SaveChanges();

            #endregion
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                #region Delete incidents, accounts and units of measure

                _serviceProxy.Delete(Incident.EntityLogicalName, _incident.Id);

                _serviceProxy.Delete(Product.EntityLogicalName, _product.Id);

                _serviceProxy.Delete(Account.EntityLogicalName, _account.Id);

                _serviceProxy.Delete(UoMSchedule.EntityLogicalName, _uomSchedule.Id);

                #endregion

                #region Unpublish articles

                foreach (var article in _articles)
                {
                    _serviceProxy.Execute(new SetStateRequest
                    {
                        EntityMoniker = article.ToEntityReference(),
                        Status = new OptionSetValue((int)kbarticle_statuscode.Unapproved),
                        State = new OptionSetValue((int)KbArticleState.Unapproved)
                    });
                }

                #endregion

                #region Delete articles

                foreach (var article in _articles)
                    _serviceProxy.Delete(KbArticle.EntityLogicalName, article.Id);

                #endregion

                Console.WriteLine("Entity records have been deleted.");
            }
        }
        #endregion Public Methods

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                SearchAndRetrieveArticles app = new SearchAndRetrieveArticles();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        #endregion Main method
    }
}

See Also

Other Resources

Service entities (contract, incident, knowledge base, queue, calendar, entitlement, slakpiinstance)
Knowledge base entities
SearchByBodyKbArticleRequest
SearchByKeywordsKbArticleRequest
SearchByTitleKbArticleRequest
RetrieveByTopIncidentSubjectKbArticleRequest
RetrieveByTopIncidentProductKbArticleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Calendar entities

The calendar entity stores data for customer service calendars and holiday schedules in addition to business. Each calendar is set for a specific time zone.

A calendar describes the availability of a service or a resource. Calendars are related to calendarrule records, which include details about the duration, start and end times, and recurring patterns of events included in the calendar.

There are two types of calendar rules in Microsoft Dynamics CRM:

  • Root: A calendar rule that contains an inner calendar or that has nested (leaf) rules. You can specify an inner calendar for a root calendar rule by using the CalendarRule.InnerCalendarId attribute. The attribute value of CalendarRule.InnerCalendarId of a root rule is the same as the attribute value of CalendarRule.CalendarId of its leaf rules.
  • Leaf: A calendar rule that doesn’t contain an inner calendar, and therefore, is the end of the "branch."

Calendar rules are ordered, or ranked, to describe their precedence, and rules can overlap. The nested rules expansion defines the time span, or extent, of a rule. You can use the CalendarRule.ExtentCode attribute to define how rule expansion overlap is handled, for example, whether both time span or extent of a rule are shown or if only one is included. These features provide for recurrence patterns, for example, different shift schedules for winter and summer months in a single service calendar.

A calendar can be a complex tree of rules and nested calendars that represent a high-level abstraction of the work schedule. The calendar entity supports the ExpandCalendarRequest message to convert to a simple view, which is an array of time blocks that determine availability over specific ranges.

In This Section

Types of calendars

Calendar entity messages and methods

CalendarRule entity messages and methods

Related Sections

Appointment entities

Recurring appointment entities

Resource entities

Service entity

Sample code for schedule and appointment Entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Types of calendars

The calendar entity has been modified to support additional types of calendars in CRM Online Spring ‘14 and CRM 2015 Service Pack 1 (on-premises).

Calendar type

The Type Picklist attribute contains the following options:

Value | Label | Description
0 | Default | All calendars that are not customer service, holiday schedule, or inner calendars.
1 | Customer Service | Service calendars for customer service.
2 | Holiday Schedule | Holiday schedule calendars for customer service.
-1 | Inner Calendar type | Inner Calendars are used by other calendars to build a graph of time slots available for customer service or service scheduling to be performed.

Customer service calendars

Customer service calendars exist to calculate performance against service level agreements (SLAs). SLAs are frequently based on key performance indicators (KPIs) based on time, such as duration for first response or a time limit before escalation. When these time limits are restricted to periods when customer service operations are open, calculations to enforce these agreements must include data from the customer service calendar.

Customer service calendars define regular weekly schedules. Events that don’t fall into those regular schedules are usually holidays. A customer service calendar can be associated with a holiday schedule to provide a complete description of the times when customer services are available.

Service scheduling calendars

Service scheduling uses the default calendar type. Business closure calendars can be defined and shared on service and resource entities. The scheduling engine makes sure that all appropriate calendar rules are considered for an appointment request.

In addition to free/busy times, you can define effort (required/available) constraints on the CalendarRule entity. These constraints are defined as the effort that is available from a resource to perform, deliver, or repeat a particular service at a given time. Similarly, each service defines the effort that is required from the required pool of resources to complete one unit of service for its specified duration. The scheduling engine automatically computes the appropriate time blocks for an appointment when the total effort that is required for a given service is less than or equal to the total available effort for all the required resources.

See Also

Concepts

Calendar entity messages and methods
CalendarRule entity messages and methods

Other Resources

Calendar entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Calendar entity messages and methods

A calendar consists of a set of ordered rules that define time blocks of free/busy times for users, business units, and services, and for resources or resource groups. Examples of rules are working and nonworking hours, vacations, appointments, and weekly meetings. Calendars support recurring events and can be nested. In addition to time blocks, a calendar also specifies the capacity rules, as measured by the effort that is required for a specific resource and appointment type, and by the effort that is available per duration by a resource in the calendar for the resource. The schema name for this entity is Calendar. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Calendar entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a calendar. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a calendar. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Calendar entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
ExpandCalendarRequest | Converts the calendar rules to an array of available time blocks for the specified period.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a calendar. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of calendars. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a calendar. You can also call the IOrganizationService.Update method.

See Also

Concepts

CalendarRule entity messages and methods
Calendar entity privileges

Other Resources

Calendar entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CalendarRule entity messages and methods

The schema name for this entity is CalendarRule. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

There are no messages that directly operate on CalendarRule, and you can access this entity by using the messages on the Calendar entity. For more information about messages for the Calendar entity, see Calendar entity messages and methods.

See Also

Concepts

Calendar entity messages and methods
Calendar entity privileges

Other Resources

Calendar entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Entitlement entities

Entitlements specify the support term based on number of hours or number of cases. The customer’s support level can vary based on the product or service that the customer has purchased. Customers who’ve purchased different products can be entitled to different support levels. This information helps the customer support agents verify what the customers are eligible for and create cases for them accordingly.

Entitlement channel records contain the total terms and remaining terms for each channel in an entitlement. Default channels include Phone, Email, Web, Facebook, and Twitter. You can add custom channels by editing the Case Origin (incident_caseorigincode) global option set.

Use entitlement templates and entitlement template channels to create entitlements prefilled with the basic information like the start and end date, service level agreement (SLA), allocation type, and total term. You can also relate entitlement channels and products to entitlement templates. For example, create a template for a standard entitlement, and then apply this template for every standard customer in your organization.

In This Section

Entitlement entity messages and methods

EntitlementChannel entity messages and methods

EntitlementTemplate entity messages and methods

EntitlementTemplateChannel entity messages and methods

Related Sections

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Entitlement entity messages and methods

The schema name for this entity is Entitlement. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an entitlement to another user or team.
CreateRequest | Creates an entitlement. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an entitlement. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares an entitlement with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for an entitlement previously shared with another security principal (user or team).
RenewEntitlementRequest | Renews an entitlement.
RetrieveRequest | Retrieves an entitlement. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of entitlements. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to an entitlement.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a contract, together with their access rights to the entitlement.
RevokeAccessRequest | Removes all access to an entitlement for the specified security principal (user or team).
SetStateRequest | Sets the state of an entitlement. For a list of the state values, see the options available in the metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an entitlement. You can also call the IOrganizationService.Update method.

See Also

Reference

Entitlement entity privileges

Concepts

EntitlementChannel entity messages and methods
EntitlementTemplate entity messages and methods
EntitlementTemplateChannel entity messages and methods

Other Resources

Entitlement entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


EntitlementChannel entity messages and methods

The schema name for this entity is EntitlementChannel. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an entitlement channel. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an entitlement channel. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an entitlement channel. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of entitlement channels. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates an entitlement channel. You can also call the IOrganizationService.Update method.

See Also

Concepts

EntitlementTemplate entity messages and methods
EntitlementTemplateChannel entity messages and methods

Other Resources

Entitlement entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


EntitlementTemplate entity messages and methods

The schema name for this entity is EntitlementTemplate. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an entitlement template. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an entitlement template. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an entitlement template. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of entitlement templates. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates an entitlement template. You can also call the IOrganizationService.Update method.

See Also

Reference

EntitlementTemplate entity privileges

Concepts

EntitlementChannel entity messages and methods
EntitlementTemplateChannel entity messages and methods

Other Resources

Entitlement entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


EntitlementTemplateChannel entity messages and methods

The schema name for this entity is EntitlementTemplateChannel. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an entitlement template channel. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an entitlement template channel. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an entitlement template channel. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of entitlement template channels. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates an entitlement template channel. You can also call the IOrganizationService.Update method.

See Also

Concepts

EntitlementChannel entity messages and methods
EntitlementTemplate entity messages and methods

Other Resources

Entitlement entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SLAKPIInstance (SLA KPI instance) entity messages and methods

The schema name for this entity is SLAKPIInstance. This entity represents the data of a service level agreement (SLA) key performance indicator (KPI) instance that is tracked for an individual case. Instances of this entity will be generated automatically and updated by the system for cases using enhanced SLAs. The messages supported for this entity are intended to enable scenarios for reporting and integration with other systems.

To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an SLAKPIInstance to another user or team.
CreateRequest | Creates an SLAKPIInstance. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an SLAKPIInstance. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a SLAKPIInstance with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a SLAKPIInstance previously shared with another security principal (user or team).
RetrieveRequest | Retrieves an SLAKPIInstance. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of SLAKPIInstances. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights the specified security principal (user or team) has to an SLAKPIInstance.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a contract, together with their access rights to the SLAKPIInstance.
RevokeAccessRequest | Removes all access to an SLAKPIInstance for the specified security principal (user or team).
UpdateRequest | Updates an SLAKPIInstance. You can also call the IOrganizationService.Update method.

See Also

Reference

SLAKPIInstance (SLA KPI instance) entity privileges

Other Resources

Service entities (contract, incident, knowledge base, queue, calendar, entitlement, slakpiinstance)
Customer Center Topic: Define service level agreements (SLAs)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Activity entities

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, activities are tasks that you or your teams perform when they contact customers, for example, sending letters or making telephone calls. You can create activities for yourselves, can assign them to someone else, or can share them with other users or teams. An activity is any action which can be entered on a calendar and has time dimensions (start time, stop time, due date, and duration) that help determine when the action occurred or is to occur. Activities has some basic properties that help determine what action the activity represents, for example, subject and description. An activity state can be opened, canceled, or completed. The completed status of an activity will have several substatus values associated with it to clarify the way that the activity was completed.

Activities involve one or more participants, called activity parties in Microsoft Dynamics CRM. For a meeting activity, the participants are those contacts or users attending the meeting. For a telephone call or fax activity, the parties are the caller and the person who is called. The following diagram shows the entity relationships for activities.

To support the communication needs of the modern-day business, such as instant messaging (IM) and SMS, you can create custom activities in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Other activity entities

  • The scheduling activities enables you to schedule your services and resources, and thus define work schedules. The scheduling activity entities are Appointment, ServiceAppointment, and RecurringAppointmentMaster. For more information, see Schedule and appointment entities.
  • The marketing activity, CampaignResponse, enables you to capture responses from the customers for a marketing campaign, while the CampaignActivity entity represents a step in a campaign. For more information, see Campaign entities.
  • The sales force automation entities OpportunityClose, OrderClose, and QuoteClose activities capture information about each of these events. For more information, see Sales entities (lead, opportunity, competitor, quote, order, invoice).
  • The customer service entity IncidentResolution activity captures information about the resolution of a case. For more information, see Incident (case) entities.

In This Section

Custom activities

ActivityPointer (activity) entity

ActivityParty entity

Task, fax, phone call, and letter activity entities

Email activity entities

Sample code for activity entities

Related Sections

Model your business data

Server-side synchronization entities

Customize entity metadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Custom activities

In Microsoft Dynamics CRM, you can create custom activities to support the communication needs of a business such as instant messaging (IM) and Short Message Service (SMS). To create a custom activity in CRM, create a custom entity, and specify it as an activity entity using the EntityMetadata.IsActivity property.

However, unlike other custom entities, you can’t specify a primary attribute for a custom activity because, by default, each custom activity must have a primary attribute named ”Subject”.

When you create a custom activity entity, all the properties and privileges of the activitypointer entity are inherited for the custom activity. Further, all the activity party types become available for the custom activity, and as a result the corresponding properties are also inherited.

You can create 1-to-Many (1:N) relationships for a custom activity just like any other activity, and also update the existing relationships.

Privileges and access rights

You require the same set of CRM privileges and access rights to work with custom activities as those required to work with custom entities. For more information about custom entities, see Customize entity metadata.

Creating a custom activity

To create a custom activity entity, set the values of the properties listed in the following table.

Property name Value Notes

EntityMetadata.IsActivity

true

Specify the custom entity as an activity entity.

EntityMetadata.IsAvailableOffline

true

A custom activity entity must have offline availability.

EntityMetadata.IsMailMergeEnabled

false

A custom activity entity cannot have mail merge enabled.

EntityMetadata.OwnershipType

OwnershipTypes. TeamOwned
or
OwnershipTypes. UserOwned

A custom activity entity can be either team-owned or user-owned.

EntityMetadata.ActivityTypeMask

0 - None
or
1 – Communication Activity

(Optional) Specify whether a custom activity should appear in the activity menus in the web application.

  • Specify 0 (None) to hide it from appearing in the activity menus. The custom activity will appear in the associated grids of only those entities with which it is associated (has relationship).
  • Specify 1 (Communication Activity) to make it appear in the activity menus.

If you do not specify this property, the custom activity is created with the default property value: 1. That is, the custom activity is available in the activity menus. Moreover, ActivityTypeMask can be set at the activity creation time only, and once set, cannot be modified.

CreateEntityRequest.HasActivities

false

A custom activity entity must not have a relationship with activities.

CreateEntityRequest.HasNotes

true

A custom activity entity must have a relationship to notes.

CreateEntityRequest. PrimaryAttribute

SchemaName is “Subject”.

The schema name of the PrimaryAttribute for all activities must be “Subject”.

Example

The following sample shows how you can create a custom activity by using the Microsoft Dynamics CRM SDK.

C# Copy Code
String prefix = "new_";

String customEntityName = prefix + "instantmessage";

// Create the custom activity entity.
CreateEntityRequest request = new CreateEntityRequest
{
    HasNotes = true,
    HasActivities = false,
    PrimaryAttribute = new StringAttributeMetadata
    {
        SchemaName = "Subject",
        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
        MaxLength = 100,
        DisplayName = new Label("Subject", 1033)
    },
    Entity = new EntityMetadata
    {
        IsActivity = true,
        SchemaName = customEntityName,
        DisplayName = new Label("Instant Message", 1033),
        DisplayCollectionName = new Label("Instant Messages", 1033),
        OwnershipType = OwnershipTypes.UserOwned,
        IsAvailableOffline = true,

    }
};

_serviceProxy.Execute(request);

//Entity must be published

See Also

Concepts

ActivityPointer (activity) entity

Other Resources

Activity entities
Sample: Create a custom activity
Sample: Create and update entity metadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ActivityPointer (activity) entity

The activity pointer (activity) entity represents any activity or task that is performed, or to be performed by a user. An activity is any action for which an entry can be made on a calendar.

Whenever you create an activity record in Microsoft Dynamics CRM, a corresponding activity pointer record is created. This implies that the activity record and the corresponding activity pointer record have the same value for the ActivityId attribute. For example, if you create an Email record, the attribute values of Email.ActivityId and the corresponding ActivityPointer.ActivityId will be the same.

The ActivityPointer.ActivityTypeCode attribute defines the type of the activity. The possible values for this attribute are defined in the Activity Type (activitypointer_activitytypecode) option set.

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

ActivityPointer (activity) entity messages and methods

Other Resources

Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ActivityPointer (activity) entity messages and methods

An activity pointer represents any activity in Microsoft Dynamics CRM. The schema name for this entity is ActivityPointer. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveMultipleRequest | Retrieves a collection of activities. You can also call the IOrganizationService.RetrieveMultiple method.
RollupRequest | Retrieves all activities related to the specified record (account or contact).

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

ActivityPointer (activity) entity

Other Resources

Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ActivityParty entity

An activity party represents a person or group associated with an activity. An activity can have multiple activity parties.

In This Topic

Activity Party Types

Activity Party Types Available for Each Activity

Activity Party Types

There are 11 types of activity party in Microsoft Dynamics CRM. The activity party type is stored as an integer value in the ActivityParty.ParticipationTypeMask attribute. The following table lists the different activity party types, the corresponding integer value for the ActivityParty.ParticipationTypeMask attribute, and the description.

Activity party type | Value | Description
Sender | 1 | Specifies the sender.
ToRecipient | 2 | Specifies the recipient in the To field.
CCRecipient | 3 | Specifies the recipient in the Cc field.
BccRecipient | 4 | Specifies the recipient in the Bcc field.
RequiredAttendee | 5 | Specifies a required attendee.
OptionalAttendee | 6 | Specifies an optional attendee.
Organizer | 7 | Specifies the activity organizer.
Regarding | 8 | Specifies the regarding item.
Owner | 9 | Specifies the activity owner.
Resource | 10 | Specifies a resource.
Customer | 11 | Specifies a customer.

Activity Party Types available for each activity

Not all activity party types are available for each activity in Microsoft Dynamics CRM, except for a custom activity. A custom activity supports all activity party types. You can associate an activity party type for an activity by using the respective attribute of an activity. For example, to associate an Organizer activity party type with an appointment activity, you must specify a value or an array of values of the ActivityParty type in the Appointment.Organizer attribute.

To control which email address should be used for sending emails to the activity party, or for replying to emails from the activity party, set the ActivityParty.AddressUsed attribute.

The following table lists the activity party types that are supported for each activity, and the corresponding activity properties to specify those activity party types.

Activity entity name | Supported activity party type | Activity attribute
Appointment | OptionalAttendee Organizer RequiredAttendee | Appointment.OptionalAttendees Appointment.Organizer Appointment.RequiredAttendees
CampaignActivity | Partner Sender | CampaignActivity.Partners CampaignActivity.From
CampaignResponse | Customer Partner From | CampaignResponse.Customer CampaignResponse.Partner CampaignResponse.From
Email | BccRecipient CcRecipient Sender ToRecipient | Email.Bcc Email.Cc Email.From Email.To
Fax | Sender ToRecipient | Fax.From Fax.To
Letter | BccRecipient Sender ToRecipient | Letter.Bcc Letter.From Letter.To
PhoneCall | Sender ToRecipient | PhoneCall.From PhoneCall.To
RecurringAppointmentMaster | OptionalAttendee Organizer RequiredAttendee | RecurringAppointmentMaster.OptionalAttendees RecurringAppointmentMaster.Organizer RecurringAppointmentMaster.RequiredAttendees
ServiceAppointment | Customer Resource | ServiceAppointment.Customers ServiceAppointment.Resources

See Also

Concepts

Task, fax, phone call, and letter activity entities
ActivityParty entity messages and methods

Other Resources

Activity entities
Sample: Book an appointment
Sample: Convert a fax to a task
Sample: Override goal total count and close the goal
Sample: Rollup goal data for a fiscal period against the stretch target count
Sample: Send an email using a template
Sample: Validate an appointment

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ActivityParty entity messages and methods

An activity party represents another record (person or resource) that is to be included in the activity. For example, it could be a contact, account, lead, opportunity or queue.

The schema name for this entity is ActivityParty. There are no messages that operate directly on this class.

See Also

Reference

ActivityParty entity privileges

Concepts

ActivityParty entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Task, fax, phone call, and letter activity entities

These entities enable you to manage core activities that are performed in a relationship management solution.

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

Fax entity messages and methods
Letter entity messages and methods
PhoneCall entity messages and methods
Task entity messages and methods

Other Resources

Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Fax entity messages and methods

This entity represents an activity that tracks call outcome and number of pages for a fax and optionally stores a copy of the document. The schema name for this entity is Fax. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a fax to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Fax entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a fax. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a fax. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. For a list of default relationships for this entity, see the Fax entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares a fax with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for a fax previously shared with another security principal (user or team).
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a fax. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of faxes. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a fax.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a fax, and their access rights to the fax.
RevokeAccessRequest | Removes all access to a fax for the specified security principal (user or team).
SendFaxRequest | Sends a fax.
SetStateRequest | Sets the state of a fax. The possible values for this attribute are defined in the Fax.State attribute. If you are using early bound types, you can use the FaxState enumeration. For a list of possible states, see the Fax entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a fax. You can also call the IOrganizationService.Update method.

See Also

Concepts

Task, fax, phone call, and letter activity entities
Letter entity messages and methods
Fax entity privileges

Other Resources

Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Letter entity messages and methods

This entity represents an activity that tracks the delivery of a letter. The activity can contain a copy of the letter. The schema name for this entity is Letter. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a letter to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Letter entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a letter. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a letter. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService. Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Letter entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares a letter with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for a letter previously shared with another security principal (user or team).
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a letter. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of letters. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a letter.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a letter, and their access rights to the letter.
RevokeAccessRequest | Removes all access to a letter for the specified security principal (user or team).
SetStateRequest | Sets the state of a letter. The possible values for this attribute are defined in the LetterState attribute. If you are using early bound types, you can use the Letter.State enumeration. For a list of possible state values, see Letter entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a letter. You can also call the IOrganizationService.Update method.

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

Task, fax, phone call, and letter activity entities
PhoneCall entity messages and methods

Other Resources

Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PhoneCall entity messages and methods

This entity represents an activity to track a telephone call. The schema name for this entity is PhoneCall. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a phone call to another user or team.
CreateRequest | Creates a phone call. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a phone call. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a phone call with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a phone call previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a phone call. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of phone calls. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a phone call.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a phone call, and their access rights to the phone call.
RevokeAccessRequest | Removes all access to a phone call for the specified security principal (user or team).
SetStateRequest | Sets the state of a phone call. The possible values for this attribute are defined in the PhoneCall.State attribute. If you are using early bound types, you can use the PhoneCallState enumeration. For a list of possible states, see PhoneCall entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a phone call. You can also call the IOrganizationService.Update method.

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

Task, fax, phone call, and letter activity entities
Task entity messages and methods

Other Resources

Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Task entity messages and methods

This entity represents a generic activity representing work needed to be done. The schema name for this entity is Task. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a task to another user or team.
CreateRequest | Creates a task. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a task. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a task with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a task previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a task. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of tasks. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a task.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a task, and their access rights to the task.
RevokeAccessRequest | Removes all access to a task for the specified security principal (user or team).
SetStateRequest | Sets the state of a task. The possible states are defined in the Task.State attribute. If you are using early bound types, use the TaskState enumeration. You can see the valid states in the Task entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a task. You can also call the IOrganizationService.Update method.

See Also

Concepts

Task, fax, phone call, and letter activity entities
Task entity privileges

Other Resources

Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Email activity entities

The email activity lets you track and manage email communications with customers. Microsoft Dynamics CRM includes the Email Router software that manages the routing of email to or from Microsoft Dynamics CRM. The email activity is delivered using email protocols. Email Router supports the following email protocols: Exchange Web services, POP3, and SMTP. In addition to the Email Router software, the email activity can also be delivered by using Microsoft Dynamics CRM for Microsoft Office Outlook.

In This Topic

Actions on an Email Activity

Bulk Email

Email Attachments

Actions on an Email Activity

Using Microsoft Dynamics CRM SDK, you can perform the following actions on an email activity:

  • Create, retrieve, update, and delete the email activity.
  • Send email messages, or send email messages by using email templates (Template). For more information about email templates, see Template (email template) entity messages and methods.
  • Attach files as attachments by using the (ActivityMimeAttachment) attribute in the email message.
  • Send mass or bulk email messages.
  • Configure incoming email messages to be delivered from Microsoft Exchange Server to any user or queue, or outgoing messages to be sent from any user or queue to Microsoft Exchange Server. For information about how to configure incoming email messages for queues, see Configure email for incoming messages.

    If the Organization.RequireApprovalForuserEmail and Organization.RequireApprovalForQueueEmail (process emails only for approved users/queues) organization attributes are set to true (1), the following occurs: email messages are delivered or sent from a user or queue only if the primary email address of the user or queue is approved. The SystemUser.EmailRouterAccessApproval and the Queue.EmailRouterAccessApproval attributes indicate the status of the primary email address of the user and queue respectively, and the value must be set to 1. Otherwise, the incoming and outgoing messages will be blocked. You can update the user or queue record to change the attribute value, if it is not already in the approved state, provided your user account has the prvApproveRejectEmailAddress privilege assigned. For more information, see Privileges not associated with an entity.
Note
In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, the Email.StatusCode attribute cannot be null.

Bulk Email

Microsoft Dynamics CRM supports sending email to a large list of recipients through a bulk email request. When a bulk email request is sent to Microsoft Dynamics CRM, an asynchronous operation is created in the asynchronous service queue that sends the email messages by using a background process. This gives you improved system performance.

The SendBulkMailRequest and BackgroundSendEmailRequest messages are used for sending bulk email messages. The following lists the sequence used to send bulk email:

  1. Execute the SendBulkMail request. This request contains a query that selects the target email recipients and an email template for composing each email.
  2. The asynchronous service creates the email activities for each recipient.
  3. The asynchronous service sends each email message. The email messages have a "pending" send status.
  4. The email router, Microsoft Dynamics CRM for Microsoft Office Outlook, or a third-party email send component polls Microsoft Dynamics CRM for pending email messages, and if one is found, downloads it by using the BackgroundSendEmail request.
  5. The BackgroundSendEmail request performs the following operations: checks if pending email messages are present, downloads the email to the caller of the BackgroundSendEmailRequest message, and synchronizes the downloads if there are multiple callers.
  6. The caller of the BackgroundSendEmailRequest message receives the downloaded email message, and sends it out.

Email Attachments

Email attachments are files that can be attached to email messages or email templates. An attached file can be in any standard computer file format such as Microsoft Office Word documents, Microsoft Office Excel spreadsheets, CAD files, and PDF files. You can attach multiple files as email attachments to an email or email template. The maximum size of files that can be uploaded is determined by the Organization.MaxUploadFileSize property. This property is set in the Email tab of the System Settings in the CRM application. This setting limits the size of files that can be attached to email messages, notes, and web resources. The default setting is 5 MB.

To attach an email attachment with an email message or template, you use the ActivityMimeAttachment.ObjectId and ActivityMimeAttachment.ObjectTypeCode attributes while you are creating or updating an activity mime attachment record.

The following code sample shows how to attach an email attachment to an email:

C# Copy Code
ActivityMimeAttachment _sampleAttachment = new ActivityMimeAttachment{    ObjectId = new EntityReference(Email.EntityLogicalName, _emailId),    ObjectTypeCode = Email.EntityLogicalName,    Subject = "Sample Attachment”,    Body = System.Convert.ToBase64String(new ASCIIEncoding().GetBytes("Example Attachment")),    FileName = "ExampleAttachment.txt"};

Similarly, to attach the email attachment to a template instead of an email, you will replace the values of the ActivityMimeAttachment.ObjectId and ActivityMimeAttachment.ObjectTypeCode attributes as follows in the above code:

C# Copy Code
ObjectId = new EntityReference(Template.EntityLogicalName, _templateId),ObjectTypeCode = Template.EntityLogicalName,

For complete code sample about how to create email attachments, see Sample: Create, retrieve, update, and delete an email attachment.

Reusing Email Attachments

When you create an email attachment record, the attached file is saved as a file BLOB. The ActivityMimeAttachment.AttachmentId attribute of the email attachment record uniquely identifies the file BLOB. This is done to facilitate the reuse of the file attachments with other email and email template records, without creating and storing multiple copies of the same file in the database.

To reuse an existing file attachment:

  1. Retrieve the ActivityMimeAttachment record that contains the attachment file that you want to re-use, as shown in the following code example:
    C# Copy Code
    ActivityMimeAttachment retrievedAttachment = (ActivityMimeAttachment)_serviceProxy.Retrieve(ActivityMimeAttachment.EntityLogicalName, _emailAttachmentId, new ColumnSet(true));
  2. Create a new email attachment record, associate it with the required email or email template record, and point it to the attached file of the retrieved ActivityMimeAttachment record, as shown in the following code example:
    C# Copy Code
    ActivityMimeAttachment _reuseAttachment = new ActivityMimeAttachment{    ObjectId = new EntityReference(Email.EntityLogicalName, _emailId),    ObjectTypeCode = Email.EntityLogicalName,    Subject = "Sample Attachment”,    AttachmentId = retrievedAttachment.AttachmentId};
    Because you are reusing an existing attachment file, you do not have to specify the ActivityMimeAttachment.Body and ActivityMimeAttachment.FileName attribute values while you are creating and associating email attachment records to emails or email templates.

See Also

Concepts

Email entity messages and methods
ActivityMimeAttachment (email attachment) entity messages and methods

Other Resources

Activity entities
Sample code for activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Email entity messages and methods

This entity represents an activity that is delivered using email protocols. The schema name for this entity is Email. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an email message to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Email entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
BackgroundSendEmailRequest | Sends an email message asynchronously.
CheckIncomingEmailRequest | Checks whether the incoming email message should be tracked in Microsoft Dynamics CRM.
CheckPromoteEmailRequest | Checks whether the incoming email message should be promoted to Microsoft Dynamics CRM system.
CreateRequest | Creates an email. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an email. You can also call the IOrganizationService.Delete method.
DeliverIncomingEmailRequest | Routes the email message to the appropriate system users or contacts.
DeliverPromoteEmailRequest | Creates an email activity instance from the specified email message.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Email entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GetDecryptionKeyRequest | Obtains the key used for encrypting or decrypting a user's or queue's email credentials stored in the Microsoft Dynamics CRM database.
GetTrackingTokenEmailRequest | Gets a tracking token that can be passed in as a parameter to the SendEmailRequest message.
GrantAccessRequest | Shares an email with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ProcessInboundEmailRequest | Processes marketing campaign email responses.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves an email message. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of emails. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to an email message.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves all the security principals (users or teams) that have access to an email message, and their access rights to the message.
RevokeAccessRequest | Removes all access to an email message for the specified security principal (user or team).
SendBulkMailRequest | Sends bulk email messages.
SendEmailRequest | Sends an email message.
SendEmailFromTemplateRequest | Sends an email message using a template.
SetStateRequest | Sets the state of an email message. The possible states are defined in the Email.Statecode attribute. If you are using early bound types, use the EmailState enumeration. For a list of possible states, see the Email entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an email message. You can also call the IOrganizationService.Update method.

See Also

Concepts

Email activity entities
ActivityMimeAttachment (email attachment) entity messages and methods
Email entity privileges

Other Resources

Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ActivityMimeAttachment (email attachment) entity messages and methods

An activity mime attachment represents an attachment to an email message or an email template. The schema name for this entity is ActivityMimeAttachment. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the ActivityMimeAttachment entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates an email attachment. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an email attachment. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the ActivityMimeAttachment entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves an email attachment. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of email attachments. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates an email attachment. You can also call the IOrganizationService.Update method.

See Also

Reference

ActivityMimeAttachment (email attachment) entity privileges

Concepts

Email activity entities
Email entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample code for activity entities

This section contains the code examples that demonstrate how to use the activity entities.

In This Section

Sample: Create a custom activity

Sample: Create, retrieve, update, and delete an email attachment

Sample: Retrieve email attachments for an email template

Sample: Convert a fax to a task

Sample: Promote an email message to Microsoft Dynamics CRM

Sample: Send an email using a template

Sample: Send an email

Sample: Create an email using a template

Sample: Work with activity party records

Sample: Send bulk email and monitor results

Related Sections

Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a custom activity
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\metadata\Entities\CreateCustomActivityEntity.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following code example demonstrates how to create a custom activity using the CreateEntityRequest and CreateAttributeRequest messages.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to create a custom activity.
    /// </summary>
    public class CreateCustomActivityEntity
    {
        #region Class Level Members
        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create the custom entity.
        /// Optionally delete the custom entity.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // The custom prefix would typically be passed in as an argument or
                    // determined by the publisher of the custom solution.
                    String prefix = "new_";

                    String customEntityName = prefix + "instantmessage";

                    // Create the custom activity entity.
                    CreateEntityRequest request = new CreateEntityRequest
                    {
                        HasNotes = true,
                        HasActivities = false,
                        PrimaryAttribute = new StringAttributeMetadata
                        {
                            SchemaName = "Subject",
                            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                            MaxLength = 100,
                            DisplayName = new Label("Subject", 1033)
                        },
                        Entity = new EntityMetadata
                        {
                            IsActivity = true,
                            SchemaName = customEntityName,
                            DisplayName = new Label("Instant Message", 1033),
                            DisplayCollectionName = new Label("Instant Messages", 1033),
                            OwnershipType = OwnershipTypes.UserOwned,
                            IsAvailableOffline = true,

                        }
                    };

                    _serviceProxy.Execute(request);

                    //Entity must be published

                    // Add few attributes to the custom activity entity.
                    CreateAttributeRequest fontFamilyAttributeRequest =
                        new CreateAttributeRequest
                   {
                       EntityName = customEntityName,
                       Attribute = new StringAttributeMetadata
                       {
                           SchemaName = prefix + "fontfamily",
                           DisplayName = new Label("Font Family", 1033),
                           MaxLength = 100
                       }
                   };
                    CreateAttributeResponse fontFamilyAttributeResponse =
                        (CreateAttributeResponse)_serviceProxy.Execute(
                        fontFamilyAttributeRequest);

                    CreateAttributeRequest fontColorAttributeRequest =
                        new CreateAttributeRequest
                    {
                        EntityName = customEntityName,
                        Attribute = new StringAttributeMetadata
                        {
                            SchemaName = prefix + "fontcolor",
                            DisplayName = new Label("Font Color", 1033),
                            MaxLength = 50
                        }
                    };
                    CreateAttributeResponse fontColorAttributeResponse =
                        (CreateAttributeResponse)_serviceProxy.Execute(
                        fontColorAttributeRequest);

                    CreateAttributeRequest fontSizeAttributeRequest =
                        new CreateAttributeRequest
                    {
                        EntityName = customEntityName,
                        Attribute = new IntegerAttributeMetadata
                        {
                            SchemaName = prefix + "fontSize",
                            DisplayName = new Label("Font Size", 1033)
                        }
                    };
                    CreateAttributeResponse fontSizeAttributeResponse =
                        (CreateAttributeResponse)_serviceProxy.Execute(
                        fontSizeAttributeRequest);

                    Console.WriteLine("The custom activity has been created.");

                    DeleteCustomEntity(prefix, promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes the custom entity that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the entity created in this sample.</param>
        /// </summary>
        public void DeleteCustomEntity(String prefix, bool prompt)
        {
            bool deleteEntity = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want this custom entity deleted? (y/n)");
                char answer = Convert.ToChar(Console.ReadLine().Substring(0, 1));

                deleteEntity = (answer == 'y' || answer == 'Y');
            }

            if (deleteEntity)
            {
                DeleteEntityRequest request = new DeleteEntityRequest()
                {
                    LogicalName = prefix + "instantmessage",
                };
                _serviceProxy.Execute(request);

                Console.WriteLine("Entity has been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateCustomActivityEntity app = new CreateCustomActivityEntity();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Custom activities

Other Resources

Sample code for activity entities
Helper code: ServerConnection class
Sample: Create, retrieve, update, and delete an email attachment
CreateEntityRequest
CreateAttributeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete an email attachment
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Activities\CRUDEmailAttachments.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create, retrieve, update, and delete email attachments using the following methods:

  • IOrganizationService.Create
  • IOrganizationService.Retrieve
  • IOrganizationService.Update
  • IOrganizationService.Delete

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Text;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    public class CRUDEmailAttachments
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _emailId;
        private Guid[] _emailAttachmentId = new Guid[3];

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create, Retrieve, Update and Delete an e-mail attachment.
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Create three e-mail attachments
                    for (int i = 0; i < 3; i++)
                    {
                        ActivityMimeAttachment _sampleAttachment = new ActivityMimeAttachment
                        {
                            ObjectId = new EntityReference(Email.EntityLogicalName, _emailId),
                            ObjectTypeCode = Email.EntityLogicalName,
                            Subject = String.Format("Sample Attachment {0}", i),
                            Body = System.Convert.ToBase64String(
                                    new ASCIIEncoding().GetBytes("Example Attachment")),
                            FileName = String.Format("ExampleAttachment{0}.txt", i)
                        };

                        _emailAttachmentId[i] = _serviceProxy.Create(_sampleAttachment);
                    }

                    Console.WriteLine("Created three e-mail attachments for the e-mail activity.");

                    // Retrieve an attachment including its id, subject, filename and body.
                    ActivityMimeAttachment _singleAttachment =
                        (ActivityMimeAttachment)_serviceProxy.Retrieve(
                                                    ActivityMimeAttachment.EntityLogicalName,
                                                    _emailAttachmentId[0],
                                                    new ColumnSet("activitymimeattachmentid",
                                                        "subject",
                                                        "filename",
                                                        "body"));

                    Console.WriteLine("Retrieved an email attachment, {0}.", _singleAttachment.FileName);

                    // Update attachment
                    _singleAttachment.FileName = "ExampleAttachmentUpdated.txt";
                    _serviceProxy.Update(_singleAttachment);

                    Console.WriteLine("Updated the retrieved e-mail attachment to {0}.", _singleAttachment.FileName);

                    // Retrieve all attachments associated with the email activity.
                    QueryExpression _attachmentQuery = new QueryExpression
                    {
                        EntityName = ActivityMimeAttachment.EntityLogicalName,
                        ColumnSet = new ColumnSet("activitymimeattachmentid"),
                        Criteria = new FilterExpression
                        {
                            Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "objectid",
                                Operator = ConditionOperator.Equal,
                                Values = {_emailId}
                            },
                            new ConditionExpression
                            {
                                AttributeName = "objecttypecode",
                                Operator = ConditionOperator.Equal,
                                Values = {Email.EntityLogicalName}
                            }
                        }
                        }
                    };

                    EntityCollection results = _serviceProxy.RetrieveMultiple(
                        _attachmentQuery);

                    Console.WriteLine("Retrieved all the e-mail attachments.");

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Creates the email activity.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create Email Activity
            Email email = new Email
            {
                Subject = "This is an example email",
                ActivityId = Guid.NewGuid()
            };

            _emailId = _serviceProxy.Create(email);

            Console.WriteLine("An e-mail activity is created.");
        }

        /// <summary>
        /// Deletes the custom entity record that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the entity created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                for (int j = 0; j < 3; j++)
                {
                    _serviceProxy.Delete(ActivityMimeAttachment.EntityLogicalName, _emailAttachmentId[j]);
                }
                _serviceProxy.Delete(Email.EntityLogicalName, _emailId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CRUDEmailAttachments app = new CRUDEmailAttachments();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Email activity entities
ActivityMimeAttachment (email attachment) entity messages and methods

Other Resources

Sample code for activity entities
Sample: Retrieve email attachments for an email template
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve email attachments for an email template
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Templates\GetEmailTemplateAttachments.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve email attachments associated with an email template by using the IOrganizationService.RetrieveMultiple method.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;
using System.Collections.Generic;

namespace Microsoft.Crm.Sdk.Samples
{

    /// <summary>
    /// Demonstrates how to retrieve email attachments associated with an email template.
    /// If you want to run this sample repeatedly, you have the option to
    /// delete all the records created at the end of execution.
    /// </summary>
    public class GetEmailTemplateAttachments
    {
        #region Class Level Members
        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _emailTemplateId;
        public List<Guid> _templateAttachmentIds = new List<Guid>();

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create an email template and several attachments.
        /// Retrieve the email attachments
        /// Optionally delete template and attachments.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    //Create a query to retrieve attachments.
                    QueryExpression query = new QueryExpression
                    {
                        EntityName = ActivityMimeAttachment.EntityLogicalName,
                        ColumnSet = new ColumnSet("filename"),

                        //Define the conditions for each attachment.
                        Criteria =
                        {
                            FilterOperator = LogicalOperator.And,
                            Conditions =
                        {
                            //The ObjectTypeCode must be specified, or else the query
                            //defaults to "email" instead of "template".
                            new ConditionExpression
                            {
                                AttributeName = "objecttypecode",
                                Operator = ConditionOperator.Equal,
                                Values = {Template.EntityTypeCode}
                            },
                            //Specify which template we need.
                            new ConditionExpression
                            {
                                AttributeName = "objectid",
                                Operator = ConditionOperator.Equal,
                                Values = {_emailTemplateId}
                            }
                        }
                        }
                    };

                    //Write out the filename of each attachment retrieved.
                    foreach (ActivityMimeAttachment attachment in _serviceProxy.RetrieveMultiple(query).Entities)
                    {
                        Console.WriteLine("Retrieved attachment {0}", attachment.FileName);
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            //Define the email template to create.
            Template emailTemplate = new Template
            {
                Title = "An example email template",
                Subject = "This is an example email.",
                IsPersonal = false,
                TemplateTypeCode = "lead",

                //1033 is the code for US English - you may need to change this value
                //depending on your locale.
                LanguageCode = 1033

            };

            _emailTemplateId = _serviceProxy.Create(emailTemplate);

            for (int i = 0; i < 3; i++ )
            {
                ActivityMimeAttachment attachment = new ActivityMimeAttachment
                {
                    Subject = String.Format("Attachment {0}",i),
                    FileName = String.Format("ExampleAttachment{0}.txt", i),
                    Body = "Some Text",
                    ObjectId = new EntityReference(Template.EntityLogicalName, _emailTemplateId),
                    ObjectTypeCode = Template.EntityLogicalName
                };

                _templateAttachmentIds.Add(_serviceProxy.Create(attachment));
            }

            Console.WriteLine("An email template and {0} attachments were created.", _templateAttachmentIds.Count);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                foreach(Guid attachmentId in _templateAttachmentIds)
                {
                    _serviceProxy.Delete(ActivityMimeAttachment.EntityLogicalName, attachmentId);
                }

                _serviceProxy.Delete(Template.EntityLogicalName, _emailTemplateId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                GetEmailTemplateAttachments app = new GetEmailTemplateAttachments();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }

            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Reference

E-Mail Attachments

Concepts

Template (email template) entity messages and methods

Other Resources

Helper code: ServerConnection class
Sample code for schedule and appointment Entities
Sample: Convert a fax to a task
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Convert a fax to a task
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Activities\ConvertFaxToTask.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a task for a fax by using the IOrganizationService.Create method.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Text;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    public class ConvertFaxToTask
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _faxId;
        private Guid _taskId;
        private Guid _userId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Convert a fax to a task.
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Retrieve the fax.
                    Fax retrievedFax = (Fax)_serviceProxy.Retrieve(Fax.EntityLogicalName, _faxId, new ColumnSet(true));

                    // Create a task.
                    Task task = new Task()
                    {
                        Subject = "Follow Up: " + retrievedFax.Subject,
                        ScheduledEnd = retrievedFax.CreatedOn.Value.AddDays(7),
                    };
                    _taskId = _serviceProxy.Create(task);

                    // Verify that the task has been created
                    if (_taskId != Guid.Empty)
                    {
                        Console.WriteLine("Created a task for the fax: '{0}'.", task.Subject);
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Get the current user.
            WhoAmIRequest userRequest = new WhoAmIRequest();
            WhoAmIResponse userResponse = (WhoAmIResponse)_serviceProxy.Execute(userRequest);
            _userId = userResponse.UserId;

            // Create the activity party for sending and receiving the fax.
            ActivityParty party = new ActivityParty
            {
                PartyId = new EntityReference(SystemUser.EntityLogicalName, _userId)
            };

            // Create the fax object.
            Fax fax = new Fax
            {
                Subject = "Sample Fax",
                From = new ActivityParty[] { party },
                To = new ActivityParty[] { party }
            };
            _faxId = _serviceProxy.Create(fax);
            Console.WriteLine("Created a fax: '{0}'.", fax.Subject);
        }

        /// <summary>
        /// Deletes the custom entity record that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the entity created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {

                _serviceProxy.Delete(Fax.EntityLogicalName, _faxId);
                _serviceProxy.Delete(Task.EntityLogicalName, _taskId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                ConvertFaxToTask app = new ConvertFaxToTask();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Fax entity messages and methods

Other Resources

Sample code for activity entities
Helper code: ServerConnection class
Sample: Promote an email message to Microsoft Dynamics CRM
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Promote an email message to Microsoft Dynamics CRM
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Activities\DeliverPromoteEmail.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create an email activity instance from the specified email message in Microsoft Dynamics CRM by using the DeliverPromoteEmailRequest message.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Text;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Create an e-mail activity instance from the specified e-mail message.
    /// </summary>
    /// <remarks>This sample requires that the user account running the program have
    /// a primary e-mail address defined in Microsoft Dynamics CRM.</remarks>
    public class DeliverPromoteEmail
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _contactId;
        private Guid _emailId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create an e-mail activity instance from the specified e-mail message.
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Create a contact to send an email to (To: field)
                    Contact emailContact = new Contact()
                    {
                        FirstName = "Lisa",
                        LastName = "Andrews",
                        EMailAddress1 = "lisa@contoso.com"
                    };
                    _contactId = _serviceProxy.Create(emailContact);
                    Console.WriteLine("Created a sample contact.");

                    // Get a system user to send the email (From: field)
                    WhoAmIRequest systemUserRequest = new WhoAmIRequest();
                    WhoAmIResponse systemUserResponse = (WhoAmIResponse)_serviceProxy.Execute(systemUserRequest);

                    ColumnSet cols = new ColumnSet("internalemailaddress");
                    SystemUser emailSender = (SystemUser)_serviceProxy.Retrieve(SystemUser.EntityLogicalName, systemUserResponse.UserId, cols);

                    // Create the request.
                    DeliverPromoteEmailRequest deliverEmailRequest = new DeliverPromoteEmailRequest
                    {
                        Subject = "SDK Sample Email",
                        To = emailContact.EMailAddress1,
                        From = emailSender.InternalEMailAddress,
                        Bcc = String.Empty,
                        Cc = String.Empty,
                        Importance = "high",
                        Body = "This message will create an email activity.",
                        MessageId = Guid.NewGuid().ToString(),
                        SubmittedBy = "",
                        ReceivedOn = DateTime.Now
                    };

                    // We won't attach a file to the email, but the Attachments property is required.
                    deliverEmailRequest.Attachments = new EntityCollection(new ActivityMimeAttachment[0]);
                    deliverEmailRequest.Attachments.EntityName = ActivityMimeAttachment.EntityLogicalName;

                    // Execute the request.
                    DeliverPromoteEmailResponse deliverEmailResponse = (DeliverPromoteEmailResponse)_serviceProxy.Execute(deliverEmailRequest);

                    // Verify the success.

                    // Define an anonymous type to define the possible values for
                    // email status
                    var EmailStatus = new
                    {
                        Draft = 1,
                        Completed = 2,
                        Sent = 3,
                        Received = 3,
                        Canceled = 5,
                        PendingSend = 6,
                        Sending = 7,
                        Failed = 8,
                    };

                    // Query for the delivered email, and verify the status code is "Sent".
                    ColumnSet deliveredMailColumns = new ColumnSet("statuscode");
                    Email deliveredEmail = (Email)_serviceProxy.Retrieve(Email.EntityLogicalName, deliverEmailResponse.EmailId, deliveredMailColumns);

                    _emailId = deliveredEmail.ActivityId.Value;

                    if (deliveredEmail.StatusCode.Value == EmailStatus.Sent)
                    {
                        Console.WriteLine("Successfully created and delivered the e-mail message.");
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes the custom entity record that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the entity created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                /// Delete the sent emails
                _serviceProxy.Delete(Email.EntityLogicalName, _emailId);

                // Delete the contacts created for emails
                _serviceProxy.Delete(Contact.EntityLogicalName, _contactId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DeliverPromoteEmail app = new DeliverPromoteEmail();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Email activity entities

Other Resources

Sample code for activity entities
Helper code: ServerConnection class
Sample: Send an email using a template
IOrganizationService
DeliverPromoteEmailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Send an email using a template
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Activities\SendEmailUsingTemplate.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to send an email message by using a template using the SendEmailFromTemplateRequest message.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Text;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Send an e-mail using a template.
    /// </summary>
    /// <remarks>This sample requires that the user account running the program have
    /// a primary e-mail address defined in Microsoft Dynamics CRM.</remarks>
    public class SendEmailUsingTemplate
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _emailId;
        private Guid _contactId;
        private Guid _userId;
        private Guid _templateId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Send an e-mail using a template.
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        /// </summary>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Create the 'From:' activity party for the email
                    ActivityParty fromParty = new ActivityParty
                    {
                        PartyId = new EntityReference(SystemUser.EntityLogicalName, _userId)
                    };

                    // Create the 'To:' activity party for the email
                    ActivityParty toParty = new ActivityParty
                    {
                        PartyId = new EntityReference(Contact.EntityLogicalName, _contactId)
                    };

                    Console.WriteLine("Created activity parties.");

                    // Create an e-mail message.
                    Email email = new Email
                    {
                        To = new ActivityParty[] { toParty },
                        From = new ActivityParty[] { fromParty },
                        Subject = "SDK Sample e-mail",
                        Description = "SDK Sample for SendEmailFromTemplate Message.",
                        DirectionCode = true
                    };

                    //Create a query expression to get one of Email Template of type "contact"

                    QueryExpression queryBuildInTemplates = new QueryExpression{
                        EntityName = "template",
                        ColumnSet = new ColumnSet("templateid", "templatetypecode"),
                        Criteria = new FilterExpression()
                    };
                    queryBuildInTemplates.Criteria.AddCondition("templatetypecode",
                        ConditionOperator.Equal, "contact");
                    EntityCollection templateEntityCollection = _serviceProxy.RetrieveMultiple(queryBuildInTemplates);

                    if (templateEntityCollection.Entities.Count > 0)
                    {
                        _templateId = (Guid)templateEntityCollection.Entities[0].Attributes["templateid"];
                    }
                    else
                    {
                        throw new ArgumentException("Standard Email Templates are missing");
                    }

                    // Create the request
                    SendEmailFromTemplateRequest emailUsingTemplateReq = new SendEmailFromTemplateRequest
                    {
                        Target = email,

                        // Use a built-in Email Template of type "contact".
                        TemplateId = _templateId,

                        // The regarding Id is required, and must be of the same type as the Email Template.
                        RegardingId = _contactId,
                        RegardingType = Contact.EntityLogicalName
                    };

                    SendEmailFromTemplateResponse emailUsingTemplateResp = (SendEmailFromTemplateResponse)_serviceProxy.Execute(emailUsingTemplateReq);

                    // Verify that the e-mail has been created
                    _emailId = emailUsingTemplateResp.Id;
                    if (!_emailId.Equals(Guid.Empty))
                    {
                        Console.WriteLine("Successfully sent an e-mail message using the template.");
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a contact to send an email to (To: field)
            Contact emailContact = new Contact
            {
                FirstName = "David",
                LastName = "Pelton",
                EMailAddress1 = "david@contoso.com",
                DoNotEMail = false
            };
            _contactId = _serviceProxy.Create(emailContact);
            Console.WriteLine("Created a sample contact.");

            // Get a system user to send the email (From: field)
            WhoAmIRequest systemUserRequest = new WhoAmIRequest();
            WhoAmIResponse systemUserResponse = (WhoAmIResponse)_serviceProxy.Execute(systemUserRequest);
            _userId = systemUserResponse.UserId;
        }

        /// <summary>
        /// Deletes the custom entity record that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the entity created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Email.EntityLogicalName, _emailId);
                _serviceProxy.Delete(Contact.EntityLogicalName, _contactId); ;

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                SendEmailUsingTemplate app = new SendEmailUsingTemplate();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Email activity entities
Template (email template) entity messages and methods

Other Resources

Sample code for activity entities
Sample: Send an email
Helper code: ServerConnection class
IOrganizationService
SendEmailFromTemplateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Send an email
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Activities\SendEmail.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to send an email SendEmailRequest message.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Text;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    public class SendEmail
    {
        #region Class Level Members
        // Define the IDs needed for this sample.
        private Guid _emailId;
        private Guid _contactId;
        private Guid _userId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Send an e-mail message.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Use the SendEmail message to send an e-mail message.
                    SendEmailRequest sendEmailreq = new SendEmailRequest
                    {
                        EmailId = _emailId,
                        TrackingToken = "",
                        IssueSend = true
                    };

                    SendEmailResponse sendEmailresp = (SendEmailResponse)_serviceProxy.Execute(sendEmailreq);
                    Console.WriteLine("Sent the e-mail message.");

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a contact to send an email to (To: field)
            Contact emailContact = new Contact
            {
                FirstName = "Nancy",
                LastName = "Anderson",
                EMailAddress1 = "nancy@contoso.com"
            };
            _contactId = _serviceProxy.Create(emailContact);
            Console.WriteLine("Created a contact: {0}.", emailContact.FirstName + " " + emailContact.LastName);

            // Get a system user to send the email (From: field)
            WhoAmIRequest systemUserRequest = new WhoAmIRequest();
            WhoAmIResponse systemUserResponse = (WhoAmIResponse)_serviceProxy.Execute(systemUserRequest);
            _userId = systemUserResponse.UserId;

            // Create the 'From:' activity party for the email
            ActivityParty fromParty = new ActivityParty
            {
                PartyId = new EntityReference(SystemUser.EntityLogicalName, _userId)
            };

            // Create the 'To:' activity party for the email
            ActivityParty toParty = new ActivityParty
            {
                PartyId = new EntityReference(Contact.EntityLogicalName, _contactId)
            };
            Console.WriteLine("Created activity parties.");

            // Create an e-mail message.
            Email email = new Email
            {
                To = new ActivityParty[] { toParty },
                From = new ActivityParty[] { fromParty },
                Subject = "SDK Sample e-mail",
                Description = "SDK Sample for SendEmail Message.",
                DirectionCode = true
            };
            _emailId = _serviceProxy.Create(email);
            Console.WriteLine("Create {0}.", email.Subject);
        }

        /// <summary>
        /// Deletes the custom entity record that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the entity created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(Email.EntityLogicalName, _emailId);
                _serviceProxy.Delete(Contact.EntityLogicalName, _contactId); ;

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                SendEmail app = new SendEmail();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additonal exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main method

    }
}

See Also

Concepts

Email activity entities
Email entity messages and methods

Other Resources

Sample code for activity entities
Sample: Create an email using a template
Helper code: ServerConnection class
IOrganizationService
SendEmailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create an email using a template
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Templates\CreateEmailUsingTemplate.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to instantiate an email record by using the InstantiateTemplateRequest message.

Example

C# Copy Code
using System;
using System.IO;
using System.Text;
using System.ServiceModel;
using System.Xml.Serialization;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    public class CreateEmailUsingTemplate
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _accountId;
        private Guid _templateId;

        private OrganizationServiceProxy _serviceProxy;
        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create an e-mail using a template.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Use the InstantiateTemplate message to create an e-mail message using a template.
                    InstantiateTemplateRequest instTemplateReq = new InstantiateTemplateRequest
                    {
                        TemplateId = _templateId,
                        ObjectId = _accountId,
                        ObjectType = Account.EntityLogicalName
                    };
                    InstantiateTemplateResponse instTemplateResp = (InstantiateTemplateResponse)_serviceProxy.Execute(instTemplateReq);

                    // Serialize the email message to XML, and save to a file.
                    XmlSerializer serializer = new XmlSerializer(typeof(InstantiateTemplateResponse));
                    string filename = "email-message.xml";
                    using (StreamWriter writer = new StreamWriter(filename))
                    {
                        serializer.Serialize(writer, instTemplateResp);
                    }
                    Console.WriteLine("Created e-mail using the template.");

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create an account.
            Account account = new Account
            {
                Name = "Fourth Coffee",
            };
            _accountId = _serviceProxy.Create(account);
            Console.WriteLine("Created a sample account: {0}.", account.Name);

            // Define the body and subject of the email template in XML format.
            string bodyXml =
               "<?xml version=\"1.0\" ?>"
               + "<xsl:stylesheet xmlns:xsl=\"http://www.w3.org/1999/XSL/Transform\" version=\"1.0\">"
               + "<xsl:output method=\"text\" indent=\"no\"/><xsl:template match=\"/data\">"
               + "<![CDATA["
               + "This message is to notify you that a new account has been created."
               + "]]></xsl:template></xsl:stylesheet>";

            string subjectXml =
               "<?xml version=\"1.0\" ?>"
               + "<xsl:stylesheet xmlns:xsl=\"http://www.w3.org/1999/XSL/Transform\" version=\"1.0\">"
               + "<xsl:output method=\"text\" indent=\"no\"/><xsl:template match=\"/data\">"
               + "<![CDATA[New account notification]]></xsl:template></xsl:stylesheet>";

            string presentationXml =
               "<template><text><![CDATA["
               + "This message is to notify you that a new account has been created."
               + "]]></text></template>";

            string subjectPresentationXml =
               "<template><text><![CDATA[New account notification]]></text></template>";

            // Create an e-mail template.
            Template template = new Template
            {
                Title = "Sample E-mail Template for Account",
                Body = bodyXml,
                Subject = subjectXml,
                PresentationXml = presentationXml,
                SubjectPresentationXml = subjectPresentationXml,
                TemplateTypeCode = Account.EntityLogicalName,
                LanguageCode = 1033, // For US English.
                IsPersonal = false
            };

            _templateId = _serviceProxy.Create(template);
            Console.WriteLine("Created {0}.", template.Title);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete(Template.EntityLogicalName, _templateId);
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId); ;

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateEmailUsingTemplate app = new CreateEmailUsingTemplate();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additonal exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main method

    }
}

See Also

Concepts

Email activity entities
Email entity messages and methods
Template (email template) entity messages and methods

Other Resources

Sample code for activity entities
Sample: Work with activity party records
Helper code: ServerConnection class
IOrganizationService
InstantiateTemplateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Work with activity party records
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Activities\WorkingWithActivityParties.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to work with activity party records.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to programmatically work with Activity Party records.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class WorkingWithActivityParties
    {
        #region Class Level Members

        private Guid[] _contactIds = new Guid[3];
        private Dictionary<Guid, String> _recordIds = new Dictionary<Guid, String>();
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// activity party records are created and associated with an activity.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete
        /// all created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    OrganizationServiceContext orgContext =
                        new OrganizationServiceContext(_serviceProxy);

                    // Retrieve the Contact records that we created previously.
                    List<Contact> contacts = (from c in orgContext.CreateQuery<Contact>()
                                              where c.Address1_City == "Sammamish"
                                              select new Contact
                                              {
                                                  ContactId = c.ContactId,
                                                  FirstName = c.FirstName,
                                                  LastName = c.LastName
                                              }).ToList<Contact>();
                    Console.Write("Contacts retrieved, ");

                    // Create an Activity Party record for each Contact.
                    var activityParty1 = new ActivityParty
                    {
                        PartyId = new EntityReference(Contact.EntityLogicalName,
                            contacts[0].ContactId.Value),
                    };

                    var activityParty2 = new ActivityParty
                    {
                        PartyId = new EntityReference(Contact.EntityLogicalName,
                            contacts[1].ContactId.Value),
                    };

                    var activityParty3 = new ActivityParty
                    {
                        PartyId = new EntityReference(Contact.EntityLogicalName,
                            contacts[2].ContactId.Value),
                    };

                    Console.Write("ActivityParty instances created, ");

                    // Create Letter Activity and set From and To fields to the
                    // respective Activity Party entities.
                    var letter = new Letter
                    {
                        RegardingObjectId = new EntityReference(Contact.EntityLogicalName,
                            contacts[2].ContactId.Value),
                        Subject = "Sample Letter Activity",
                        ScheduledEnd = DateTime.Now + TimeSpan.FromDays(5),
                        Description = @"Greetings, Mr. Andreshak,

This is a sample letter activity as part of the Microsoft Dynamics CRM SDK.

Sincerely,
Mary Kay Andersen

cc: Denise Smith",
                        From = new ActivityParty[] { activityParty1 },
                        To = new ActivityParty[] { activityParty3, activityParty2 }
                    };
                    orgContext.AddObject(letter);
                    orgContext.SaveChanges();

                    Console.WriteLine("and Letter Activity created.");

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create 3 Contact records to use in the Run() method.
            Contact contact1 = new Contact()
            {
                FirstName = "Mary Kay",
                LastName = "Andersen",
                Address1_Line1 = "23 Market St.",
                Address1_City = "Sammamish",
                Address1_StateOrProvince = "MT",
                Address1_PostalCode = "99999",
                Telephone1 = "12345678",
                EMailAddress1 = "marykay@contoso.com"
            };
            _contactIds[0] = _serviceProxy.Create(contact1);

            Contact contact2 = new Contact()
            {
                FirstName = "Joe",
                LastName = "Andreshak",
                Address1_Line1 = "23 Market St.",
                Address1_City = "Sammamish",
                Address1_StateOrProvince = "MT",
                Address1_PostalCode = "99999",
                Telephone1 = "12345678",
                EMailAddress1 = "joe@contoso.com"
            };
            _contactIds[1] = _serviceProxy.Create(contact2);

            Contact contact3 = new Contact()
            {
                FirstName = "Denise",
                LastName = "Smith",
                Address1_Line1 = "23 Market St.",
                Address1_City = "Sammamish",
                Address1_StateOrProvince = "MT",
                Address1_PostalCode = "99999",
                Telephone1 = "12345678",
                EMailAddress1 = "denise@contoso.com"
            };
            _contactIds[2] = _serviceProxy.Create(contact3);

        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                foreach (Guid contactId in _contactIds)
                {
                    _serviceProxy.Delete(Contact.EntityLogicalName, contactId);
                }
                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                WorkingWithActivityParties app = new WorkingWithActivityParties();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

ActivityParty entity

Other Resources

Sample code for activity entities
Sample: Send bulk email and monitor results
Helper code: ServerConnection class

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Send bulk email and monitor results
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Activities\SendBulkEmailAndMonitor.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to send bulk email using the SendBulkMailRequest and monitor the results by retrieving records from the AsyncOperation entity.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Collections.Generic;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// These namespaces are found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    public class SendBulkEmailAndMonitor
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;
        private List<Guid> _contactsIds = new List<Guid>();
        private const int ARBITRARY_MAX_POLLING_TIME = 60;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This sample shows how to send a bulk email and monitor its progress.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user is prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy is properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Create and send SendBulkEmail

                    Console.WriteLine();
                    Console.WriteLine("Creating and sending SendBulkEmail.");

                    // Get a system user to use as the sender.
                    WhoAmIRequest emailSenderRequest = new WhoAmIRequest();
                    WhoAmIResponse emailSenderResponse =
                        _serviceProxy.Execute(emailSenderRequest) as WhoAmIResponse;

                    // Set trackingId for bulk mail request.
                    Guid trackingId = Guid.NewGuid();

                    SendBulkMailRequest bulkMailRequest = new SendBulkMailRequest()
                    {
                        // Create a query expression for the bulk operation to use to retrieve
                        // the contacts in the email list.
                        Query = new QueryExpression()
                        {
                            EntityName = Contact.EntityLogicalName,
                            ColumnSet = new ColumnSet(new String[] { "contactid" }),
                            Criteria = new FilterExpression()
                            {
                                Conditions =
                            {
                                new ConditionExpression("contactid",ConditionOperator.In, _contactsIds)
                            }
                            }
                        },
                        // Set the Sender.
                        Sender = new EntityReference(SystemUser.EntityLogicalName, emailSenderResponse.UserId),
                        // Set the RegardingId - this field is required.
                        RegardingId = Guid.Empty,
                        RegardingType = SystemUser.EntityLogicalName,
                        // Use a built-in Microsoft Dynamics CRM email template.
                        // NOTE: The email template's "template type" must match the type of
                        // customers in the email list.  Our list contains contacts, so our
                        // template must be for contacts.
                        TemplateId = new Guid("07B94C1D-C85F-492F-B120-F0A743C540E6"),
                        RequestId = trackingId
                    };

                    // Execute the async bulk email request
                    SendBulkMailResponse resp = (SendBulkMailResponse)
                        _serviceProxy.Execute(bulkMailRequest);

                    Console.WriteLine("  Sent Bulk Email.");
                    #endregion

                    #region Monitoring SendBulkEmail

                    Console.WriteLine();
                    Console.WriteLine("Starting monitoring process..");

                    // Now that we've executed the bulk operation, we need to retrieve it
                    // using our tracking Id.

                    QueryByAttribute bulkQuery = new QueryByAttribute()
                    {
                        EntityName = AsyncOperation.EntityLogicalName,
                        ColumnSet = new ColumnSet(new string[] { "requestid", "statecode" }),
                        Attributes = { "requestid" },
                        Values = { trackingId }
                    };

                    // Retrieve the bulk email async operation.
                    EntityCollection aResponse = _serviceProxy.RetrieveMultiple(bulkQuery);

                    Console.WriteLine("  Retrieved Bulk Email Async Operation.");

                    // Monitor the async operation via polling.
                    int secondsTicker = ARBITRARY_MAX_POLLING_TIME;

                    AsyncOperation createdBulkMailOperation = null;

                    Console.WriteLine("  Checking operation's state for " + ARBITRARY_MAX_POLLING_TIME + " seconds.");
                    Console.WriteLine();

                    while (secondsTicker > 0)
                    {
                        // Make sure the async operation was retrieved.
                        if (aResponse.Entities.Count > 0)
                        {
                            // Grab the one bulk operation that has been created.
                            createdBulkMailOperation = (AsyncOperation)aResponse.Entities[0];

                            // Check the operation's state.
                            if (createdBulkMailOperation.StateCode.Value !=
                                AsyncOperationState.Completed)
                            {
                                // The operation has not yet completed.
                                // Wait a second for the status to change.
                                System.Threading.Thread.Sleep(1000);
                                secondsTicker--;

                                // Retrieve a fresh version the bulk delete operation.
                                aResponse = _serviceProxy.RetrieveMultiple(bulkQuery);
                            }
                            else
                            {
                                // Stop polling because the operation's state is now complete.
                                secondsTicker = 0;
                            }
                        }
                        else
                        {
                            // Wait a second for the async operation to activate.
                            System.Threading.Thread.Sleep(1000);
                            secondsTicker--;

                            // Retrieve the entity again
                            aResponse = _serviceProxy.RetrieveMultiple(bulkQuery);
                        }
                    }

                    // When the bulk email operation has completed, all sent emails will
                    // have a status of "Pending Send" and will be picked up by your email
                    // router.  Alternatively, you can then use BackgroundSendEmail to download
                    // all the emails created with the SendBulkEmail message.
                    // See the BackgroundSendEmail sample for an example.
                    #endregion

                    #region Check success

                    // Validate async operation succeeded
                    if (createdBulkMailOperation.StateCode.Value == AsyncOperationState.Completed)
                    {
                        Console.WriteLine("Operation Completed.");
                    }
                    else
                    {
                        Console.WriteLine("Operation not completed yet.");
                    }

                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            Console.WriteLine("Creating contacts records...");

            Contact emailContact1 = new Contact()
            {
                FirstName = "Adam",
                LastName = "Carter",
                EMailAddress1 = "someone@example.com"
            };

            // Create the contact1.
            _contactsIds.Add(_serviceProxy.Create(emailContact1));
            Console.WriteLine("Contact1 created.");

            Contact emailContact2 = new Contact()
            {
                FirstName = "Adina",
                LastName = "Hagege",
                EMailAddress1 = "someone@example.com"
            };

            // Create the contact2.
            _contactsIds.Add(_serviceProxy.Create(emailContact2));
            Console.WriteLine("Contact2 created.");

        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete the contacts.
                foreach (var contactId in _contactsIds)
                {
                    _serviceProxy.Delete(Contact.EntityLogicalName, contactId);
                }
                Console.WriteLine("Contacts have been deleted.");
            }
        }
        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                SendBulkEmailAndMonitor app = new SendBulkEmailAndMonitor();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Email activity entities

Other Resources

Sample code for activity entities
SendBulkMailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Social entities

Use Microsoft Dynamics CRM social care generic framework to route the social data that you obtain from various social channels into your CRM system. Social care framework provides the general interface, data model, and necessary APIs for integrating social listening applications like Facebook and Twitter with Microsoft Dynamics CRM to track social messages and profile data. Using social care framework, third party systems can push social data feed containing posts from the social channels to Microsoft Dynamics CRM and can associate a social post with an existing CRM record.

Social care framework offers following capabilities:

  • Social Activity to track Social posts in CRM
  • Social Profile to track a contact’s presence in social media
  • Rule driven manual and automated Case creation and attribute values in CRM. More information: Automatically create cases from email or social monitoring.

You can use this framework to automatically convert social posts to case, create social profiles and contact records for the author of the posts in Microsoft Dynamics CRM, search existing records, and associate social posts and profiles to them. You can configure watch lists with keywords, #tags, @mentions to identify the social buzz around your brand, product or service on social channels like Twitter or Facebook. Then, associate the watch list with a Microsoft Dynamics CRM queue, which is set up to automatically create cases from social posts. More information: Automatically create cases from email or social monitoring.

Social care concept diagram

Social care framework enhances the existing email to case settings to enable the automated case creation when a social activity is delivered to a queue. The external system or user can recognize the scope of the social care feed (for example, Post ID, corresponding CRM record, attributes corresponding to the CRM record), and target the update on the CRM record and its attributes using the CRM Create, Retrieve, Update, and Delete operations on an entity API method delivered through the OData endpoint of Microsoft Dynamics CRM.

Microsoft Dynamics CRM allows external services to connect to it, but won’t call into any external service and connect to it. The primary recipients of social data are SocialActivity entity messages and methods and SocialProfile entity messages and methods, which are compliant with the changes in the social data.

The data model and API used in social care framework provides the developers an opportunity to extend and customize the sample app to meet their business scenario. You can download the sample app based on CRM APIs to get visibility into Microsoft Dynamics CRM. More information: Sample Application Using Microsoft Dynamics CRM Social Care Framework.

In This Section

SocialActivity entity messages and methods

SocialProfile entity messages and methods

Related Sections

Model your business data

Sample Application Using Microsoft Dynamics CRM Social Care Framework

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SocialActivity entity messages and methods

A social activity represents an activity that is delivered using social protocols.

The schema name for this entity is Social Activity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a social activity to another user or team.
CreateRequest | Creates a social activity. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a social activity. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a social activity with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a social activity previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a social activity. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of social activities. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a socialactivity.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a contract, together with their access rights to the socialactivity.
RevokeAccessRequest | Removes all access to a social activity for the specified security principal (user or team).
SetStateRequest | Sets the state of a social activity. For a list of the state values, see the options available in the metadata.You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a social activity. You can also call the IOrganizationService.Update method.

See Also

Other Resources

Social entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SocialProfile entity messages and methods

A social profile represents social information about an account and contacts on different social channels. Social profile is always associated with a contact when it’s created. By default it represents the social info for a contact. If the contact is later associated with an account, it doesn’t necessarily represent the account, as account can have multiple contacts

The schema name for this entity is Social Profile. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a social profile to another user or team.
CreateRequest | Creates a social profile. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a social profile. You can also call the IOrganizationService.Delete method.
GenerateSocialProfileRequest | Returns an existing social profile record if one exists, otherwise generates a new one and returns it.
GrantAccessRequest | Shares a social profile with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a social profile previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a social profile. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of social profiles. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a social profile.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a contract, together with their access rights to the social profile.
RevokeAccessRequest | Removes all access to a social profile for the specified security principal (user or team).
SetStateRequest | Sets the state of a social profile. For a list of the state values, see the options available in the metadata.You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a social profile. You can also call the IOrganizationService.Update method.

See Also

Other Resources

Social entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Server-side synchronization entities

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, Server-side synchronization provides an interface between Microsoft Dynamics CRM and one or more Exchange servers or POP3 servers for incoming email, and one or more SMTP or Exchange servers for outgoing email. It retrieves and evaluates emails for relevance to CRM and accordingly creates corresponding email activities in CRM. It also picks emails from CRM and sends them through the configured email server for CRM users and queues. It also allows synchronization of appointments, contacts, and tasks with Exchange Server 2010 and Exchange Server 2013.

With the centralized email configuration, the CRM entity model allows having common UI settings (like user name, password, email address, and synchronization methods) for users, queues, and forward mailboxes. Each CRM user or a queue can have mailboxes, which can be monitored through either server-side synchronization or Microsoft Dynamics CRM for Outlook. The EmailServerProfile entity represents the email server profile for an organization. The Mailbox entity represents the appointments, contacts, and tasks delivery method of the mailbox. Currently, the user entity is restricted to have only one mailbox record per user and the queues entity to have only one mailbox record per queue, as shown in the following illustration.

Email connector entity model

Server-side synchronization offers the following capabilities:

  • Process emails of a user and a queue using the email address, email delivery method, and credentials from the related mailbox record.
  • Process appointments, contacts, and tasks.
  • Use mailbox records to process emails for users and queues having the incoming delivery method set as Forward Mailbox.
  • Use information from a related email profile record to process emails for all mailboxes.
  • Prevent email processing for inactive mailboxes or for mailboxes that don’t have an associated email profile.
  • Automatically relate an associated mailbox to the default email profile when a user or a queue is created with the email delivery method set as server-side synchronization.

In This Section

EmailServerProfile entity messages and methods

ExchangeSyncIdMapping messages and methods

Mailbox entity messages and methods

Related Sections

Model your business data

Goal management entities

Product catalog entities

Sales literature entities

Schedule and appointment entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


EmailServerProfile entity messages and methods

This entity represents the email server profile for an organization. The schema name for this entity is EmailServerProfile. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService method.

Message | Description
AssignRequest | Assigns an email server profile to another organization.
CreateRequest | Creates an email server profile.
DeleteRequest | Deletes an email server profile.
GrantAccessRequest | Shares an email server profile with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for an email server profile previously shared with another security principal (user or team).
RetrieveMultipleRequest | Retrieves a collection of email server profiles.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to an email server profile.
RetrieveRequest | Retrieves an email server profile.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to an email server profile, and their access rights to the email server profile.
RevokeAccessRequest | Removes all access to an email server profile for the specified security principal (user or team).
SetStateRequest | Sets the state of an email server profile. The possible states are defined in the EmailServerProfile.Statecode attribute. If you are using early bound types, use the EmailServerProfileState enumeration. For a list of possible states, see the EmailServerProfile entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an email server profile.

See Also

Reference

EmailServerProfile entity privileges

Concepts

ExchangeSyncIdMapping messages and methods

Other Resources

Server-side synchronization entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExchangeSyncIdMapping messages and methods

This entity represents the mapping used to keep track of the IDs for items synced between CRM and Exchange. The schema name for this entity is ExchangeSyncIdMapping. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService method.

Message | Description
CreateRequest | Creates an email synchronization ID mapping record.
DeleteRequest | Deletes an email synchronization ID mapping record.
RetrieveMultipleRequest | Retrieves a collection of email synchronization ID mapping records.
RetrieveRequest | Retrieves an email synchronization ID mapping record.
UpdateRequest | Updates an email synchronization ID mapping record.

See Also

Reference

ExchangeSyncIdMapping entity privileges

Concepts

Mailbox entity messages and methods

Other Resources

Server-side synchronization entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Mailbox entity messages and methods

This entity represents the mailbox synchronization settings for user, queue, or forward mailbox. It is used for synchronization of incoming or outgoing email as well as appointment, contacts, tasks. The schema name for this entity is Mailbox. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService method.

Message | Description
AssignRequest | Assigns a mailbox to another user or team.
CreateRequest | Creates a mailbox.
DeleteRequest | Deletes a mailbox.
GrantAccessRequest | Shares a mailbox with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a mailbox previously shared with another security principal (user or team).
RetrieveMultipleRequest | Retrieves a collection of mailboxes.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a mailbox.
RetrieveRequest | Retrieves a mailbox.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a mailbox, and their access rights to the mailbox.
RevokeAccessRequest | Removes all access to a mailbox for the specified security principal (user or team).
SetStateRequest | Sets the state of a mailbox.
UpdateRequest | Updates a mailbox.

See Also

Reference

Mailbox entity privileges

Concepts

EmailServerProfile entity messages and methods
ExchangeSyncIdMapping messages and methods

Other Resources

Server-side synchronization entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Goal management entities

The goal management in Microsoft Dynamics CRM lets you set sales, marketing, and other business goals for your organization and measure the results against the targets. The goal management will help you motivate your work force, identify successful programs, do better planning, and grow your business.

Goal management offers the following capabilities:

  • Create a complex goal hierarchy where each goal is assigned to an individual goal contributor or a team.
  • Use the goals in the hierarchy to track important business data, such as revenues, customer services cases, or phone calls. You can also track data represented by custom entities.
  • Roll up the totals for each goal, such as total revenues or units shipped, in the hierarchy tree.
  • Measure the results of the rollup against the targets or stretch targets.
  • Track the goal results for a fiscal period or a custom period.
  • Align the goal period with the current fiscal year settings.
  • Support different goal types, such as Amount or Count.
  • Track actual, in-progress, and custom data.
  • Add complex queries to refine the results of the rollup.
  • Override the results of the rollup to include new or additional data.
  • Incorporate goal results in reports, charts, and dashboards.
  • Support workflows and customizations.

In This Section

Create goal hierarchy, goals, and targets

Define goal metric and rollup fields

Add complex goal criteria

Roll up goal totals

Goal entity messages and methods

Metric (goal metric) entity messages and methods

RollupField entity messages and methods

GoalRollupQuery entity messages and methods

Sample: Rollup goal data for a custom period against the target revenue

Sample: Rollup goal data for a fiscal period against the stretch target count

Sample: Use rollup queries to track goals

Sample: Override goal total count and close the goal

Related Sections

Model your business data

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create goal hierarchy, goals, and targets

In preparation for goal management, you should specify a metric for a goal (amount or count), create a goal hierarchy, and set the targets. All goals in the hierarchy must be based on the same goal metric. A metric defines the type of the goal, and the rollup fields specify other important settings for the goal. For more information, see Define goal metric and rollup fields.

In this topic

Create Goal Hierarchy

Who Manages and Owns a Goal

Set and Monitor the Targets

Specify the Time Period

Other Important Settings

Create Goal Hierarchy

Typically, the manager’s goal is an aggregate of the goals assigned to the team members. A manager decides on the overall goal for the organization and then divides the goal into individual goals for each person. In a large organization, a goal for the company could be a combination of regional goals. In a simple goal hierarchy that is shown here, the manager’s goal is composed of two salesperson goals.

The manager’s goal can be referred to as a parent goal, and the salesperson goals as child goals. A goal can have multiple child goals (one-to-many relationship) and be a child goal of another goal. The relationship between a parent goal record and a child goal record can also be described as a referential relationship, in which a child goal references the parent goal. If you delete a parent goal, the child goal is not deleted, only a reference to the parent goal is removed. For more information, see Entity relationship behavior.

The goal rollup is done from the bottom of the hierarchy to the top of the hierarchy. During rollup, the child goal totals are rolled into the parent goal totals. The ending total for the root goal at the top of hierarchy is a cumulative sum of all goal totals in the hierarchy.

Who Manages and Owns a Goal

A goal manager sets or modifies goal targets, adjusts the goal time period, and assigns a goal owner. A goal manager is the goal record owner (Goal.OwnerID) with full access rights to the goal. A goal owner (Goal.GoalOwnerId) is someone who has to meet the goal targets. A goal owner has Read and AppendTo access to the goal.

When a goal is created in Microsoft Dynamics CRM, it is automatically shared with a goal owner and a parent goal’s manager. A parent goal’s manager is the record owner (Goal.OwnerId) of the parent goal, and has Read access to the newly created goal. When a parent goal’s manager or a goal owner is replaced, their access to the goal is revoked and the access is granted to the new parent goal’s manager or goal owner. If a goal was explicitly shared with a previous parent goal’s manager and goal owner, who were given specific access rights, these Microsoft Dynamics CRM users may not lose all access to the goal.

Set and Monitor the Targets

For each goal you can specify a target value against which the results of the goal rollup are measured. In addition, you can specify a stretch target. For example, your target revenue could be $100,000, and the stretch target revenue is $120,000.

Logically, the target values should increase towards the top of the goal hierarchy to reflect an upward increase of cumulative totals in the hierarchy.

Depending on the type of the rollup data, you can use one of the following goal entity attributes to set the targets: Goal.TargetInteger, Goal.TargetDecimal or Goal.TargetMoney. To set the stretch targets, use: Goal.StretchTargetInteger, Goal.StretchTargetDecimal, or Goal.StretchTargetMoney.

The following table lists the system-generated values that you can use to measure your progress against the target.

Goal entity attribute | Description | Formula
Goal.Percentage | Percentage achieved against the target goal. | (Actual/Target) * 100
Goal.ComputedTargetAsOfTodayPercentageAchieved | Expected value for percentage achieved against the target goal. | 100 * (Today’s date – Start date)/(End date – Start date)
Goal.ComputedTargetAsOfTodayInteger | Expected amount for Actual (integer) against the target goal. | Target (integer) * (Today’s date – Start date)/(End date – Start date)
Goal.ComputedTargetAsOfTodayDecimal | Expected amount for Actual (decimal) against the target goal. | Target (decimal) * (Today’s date – Start date)/(End date – Start date)
Goal.ComputedTargetAsOfTodayMoney | Expected amount for Actual (money) against the target goal. | Target (money) * (Today’s date – Start date)/(End date – Start date)
Note
The system-generated values are calculated against the target value. They are not calculated against the stretch target value.

Specify the Time Period

For each goal you must specify a particular fiscal period or a custom time period. To select the fiscal period or custom period, use the Goal.IsFiscalPeriodGoal attribute. If you select a fiscal period, you must specify a fiscal year by using the Goal.FiscalYear attribute. The possible values for this attribute are defined in the Fiscal Year global option set. A fiscal period, such as quarter or semi-annual, is specified in the Goal.FiscalPeriod attribute. The possible values for this attribute are defined in the Fiscal Period global option set.

The goal’s fiscal year and fiscal period are tied to the organization’s fiscal year settings that are defined in the Organization entity. The fiscal year settings for the organization can be redefined at any time. If the settings change, you can continue to use the existing goals with the old fiscal settings or you can realign them with the new fiscal settings.

Important
To realign, you must update the hierarchy’s root goal with the new fiscal year and fiscal period values by using the UpdateRequest message.

The fiscal year and fiscal period values are defined in the Fiscal Period global option set. All new goals can only be created by using the current fiscal year settings for the organization.

If you select a custom period for the goal, you have to specify the goal start and end dates by using the Goal.GoalStartDate attribute and the Goal.GoalEndDate attribute.

If you use a custom period, the Goal.FiscalYear and Goal.FiscalPeriod values are ignored. If you use a fiscal period, the start and end dates for the custom period are ignored.

All goals in the goal hierarchy must be based on the same fiscal period or custom period. If you specify a different time period for a child goal, a time period for a parent goal will be used.

Other Important Settings

Other important goal settings include the following:

  • Specify a parent goal for the goal by using the Goal.ParentGoalId attribute. If you delete a parent goal, the child goal is not deleted, but a parent goal GUID value is replaced with a null value by the system.
  • Specify to roll up data only from the child goals by setting Goal.RollupOnlyFromChildGoals to true. If set to false, data is rolled up from the child goals, and from the goal’s participating records specified in the goal’s metric and rollup query. For more information about the goal metric and the rollup query, see Define goal metric and rollup fields and Add complex goal criteria.
  • Specify whether you want to roll up data from all available records or only from goal owner’s records by using the Goal.ConsiderOnlyGoalOwnersRecords attribute. For example, you can specify to roll up data only from the closed opportunities owned by the goal’s owner, instead of rolling up data from all closed opportunities.

See Also

Concepts

Define goal metric and rollup fields

Other Resources

Goal management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Define goal metric and rollup fields

To specify the goal metric type, participating entities, and whether you track actuals, custom or in-progress data, use the goal metric entity (Metric) and the rollup field (RollupField) entity. The goal metric and the rollup fields have a parental relationship in which all operations on the parent record are propagated to the child records. For more information about parental relationship and cascading rules, see Entity relationship behavior.

Important
All goals in the hierarchy must be based on the same goal metric and time period. If you create a child goal that is based on a different goal metric, an exception is thrown. If you specify a different time period for a child goal, the system will ignore the specified time period and use the parent goal time period. You can associate a goal with a new metric, if the goal does not have a parent goal or a child goal. Otherwise, an exception is thrown when you update the goal record.

In this topic

Create Goal Metric

Specify Rollup Fields

Create Goal Metric

There are two goal metric types: Amount and Count. The Amount metric type is expressed as a money value, an integer, or a decimal number. The Count metric type is an integer. For example, you can use the Amount (money) goal metric to track the revenues from all active opportunities or sales orders. An integer type can be used to track sales calls made by a salesperson. A decimal number can represent a product sold by weight, such as grain or sugar.

To specify the goal metric type and whether you are tracking data against target or stretch target, use the goal metric entity (Metric). To select Amount or Count, use the Metric.IsAmount attribute. Use the Metric.AmountDataType attribute to specify the Amount data type. The possible values for this attribute are defined in the Goal Type global option set. To specify whether the goal tracks data against target or stretch target, use the Metric.IsStretchTracked attribute. To associate a goal with a metric, use the Goal.MetricId attribute.

Each goal can track actual, in-progress, and custom data as shown in the following diagram.

To track actual, in-progress, and custom data, you use the goal entity attributes, referred to as rollup fields. For example, if an opportunity is closed as “Won”, an amount of revenue generated from this opportunity can be rolled into the actual money amount rollup field. Or, if an opportunity is “Open”, the opportunity’s estimated revenue can be added to the in-progress money amount rollup field. The following table lists the relationship between the goal metric type and the rollup fields available for each type.

Goal metric type | Available rollup fields
Amount (money) | Goal.ActualMoney Goal.InProgressMoney Goal.CustomRollupFieldMoney
Amount (integer) or Count | Goal.ActualInteger Goal.InProgressInteger Goal.CustomRollupFieldInteger
Amount (decimal) | Goal.ActualDecimal Goal.InProgressDecimal Goal.CustomRollupFieldDecimal

Other examples of rollup data are Lead.EstimatedAmount and OpportunityClose.ActualRevenue that can be rolled into the Goal.InProgressMoney and the Goal.ActualMoney rollup fields. The custom rollup fields are extra fields that you can use for integer, decimal, and money values.

Specify Rollup Fields

To specify other important rollup information, use the rollup field entity.

Attribute | Rollup information
RollupField.GoalAttribute | A goal rollup field, such as Goal.ActualMoney, Goal.CustomRollupFieldMoney or Goal.InProgressMoney.
RollupField.SourceEntity | A source entity from where data is being rolled up, such as lead, opportunity, or sales order.
RollupField.SourceAttribute | An entity attribute from where data is being rolled up, such as Opportunity.ActualValue or Lead.EstimatedValue. A source attribute and a goal rollup field must be of the same type, such as money or integer; otherwise, an exception is thrown when you create a rollup field record.
RollupField.DateAttribute | The date that is validated against the goal time period, such as Opportunity.ActualCloseDate or Lead.EstimatedCloseDate. A record participates in the goal rollup, if the specified date falls between the start date and the end date for the goal. For example, if an opportunity is closed between the start and end dates for the goal, revenue generated from this opportunity is added to the goal’s total revenue; otherwise, it is not included.
RollupField.SourceState | The state of the source record such as “Won” or” Lost” opportunity.
RollupField.SourceStatus | The status reason for the state of the source record, such as “Won” for won opportunities, or “Canceled” or “Out-sold” for the lost opportunities.
RollupField.IsStateParentEntityAttribute | Indicates whether state or status belong to the parent entity. For example, for the opportunity product that does not have its own state, you can use state and status of the parent opportunity record.

For each goal metric, you can create up to three rollup field records. Each record can specify actual, in-progress, or custom amount or count. You can use the same source entity or difference source entities for all rollup field records. For example, in a goal metric that specifies the Money type, you can use an opportunity entity as a source entity and Opportunity.ActualValue as a source attribute. This lets you track the actual money amounts in all opportunities that are closed as “Won”. The Opportunity.EstimatedValue can be used to track the revenue that is expected after the opportunity is closed.

See Also

Concepts

Add complex goal criteria

Other Resources

Goal management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Add complex goal criteria

If you want to add complex rollup criteria for a goal, you can use a rollup query (GoalRollupQuery) entity. For example, you can specify revenue for a particular product line or revenue generated in a specific territory.

A rollup query can be used by different goals. However, a rollup query associated with a particular goal, applies only to that goal. A rollup query specified for a parent goal does not propagate to the child goal. A child goal can use the same query or a different query. A rollup query should use the same entity types that are specified in the rollup field records associated with the goal. If the goal tracks the sales order revenues, but the associated query uses the opportunity entity, an exception is thrown when you create or update the goal record.

To specify query criteria, use the GoalRollupQuery.FetchXml attribute. To specify the entity type for the query, use the GoalRollupQuery.QueryEntityType attribute.

Note
The entities that can be specified in the GoalRollupQuery.QueryEntityType attribute must have the following EntityMetadata attributes set to true: IsValidForAdvancedFind, IsUserOwned, IsCustomizable and CanCreateAttributes. The following entities cannot be specified in this attribute: SharePointDocumentLocation, SharePointSite and MailMergeTemplate.

Depending on the goal metric type, you can use the queries to filter actual, in-progress, and custom amount or count data. The following table shows the goal metric types and the goal entity attributes that you can use to specify the queries for each type.

Goal metric type | Rollup query attributes
Amount (money) | Goal.RollUpQueryActualMoneyId Goal.RollUpQueryCustomMoneyId Goal.RollUpQueryInprogressMoneyId
Amount (integer) or Count | Goal.RollupQueryActualIntegerId Goal.RollUpQueryCustomIntegerId Goal.RollUpQueryInprogressIntegerId
Amount (decimal) | Goal.RollUpQueryActualDecimalId Goal.RollUpQueryCustomDecimalId Goal.RollUpQueryInprogressDecimalId

The query for the goal's participating records for a given rollup attribute should include the following clauses:

  • A Goal.ConsiderOnlyGoalOwnersRecords value.
  • A FetchXML expression specified in GoalRollupQuery.FetchXml.
  • Date range (RollupField.DateAttribute), state and status specified in the respective rollup field for the referenced goal metric.

Preventing Double Counting and Other Erroneous Results

Queries are very effective in filtering the results of a rollup. However, if not used carefully, they can introduce the “double counting” or other erroneous results. The following examples demonstrate how queries may contribute in unwanted results:

  • You are tracking the sales orders for a particular salesperson. However, the rollup did not return any sales orders. This can happen if the query that you used filtered out the territories where the salesperson has customers.
  • You set two goals for a salesperson. One goal tracks the opportunities for a particular product and another goal tracks the opportunities in a particular territory. If the opportunity includes selling the specified product in the specified territory, the revenue from this opportunity is included in both goals. If the goals have the same parent goal, their totals are added to the parent goal, resulting in double counting.

You can prevent double counting and other incorrect results by following these guidelines:

  • Set the Goal.ConsiderOnlyGoalOwnersRecords attribute to true to use only the records owned by the goal owner.
  • Do not assign multiple goals to a sales person for the same time period.
  • Do not use a query if you are not sure it will provide the results that you expect.

See Also

Concepts

Roll up goal totals

Other Resources

Goal management entities
Sample: Use rollup queries to track goals

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Roll up goal totals

To roll up data in the goal hierarchy, use the RecalculateRequest message. It recalculates the goal rollup field values, such as Goal.ActualMoney or Goal.ActualInteger, for all goals in the hierarchy. A rollup for each goal is performed in the context of the goal manager. This means that only the records that a manager of a goal has Read access to participate in the rollup. The system automatically switches the manager’s context for each goal during rollup, as every goal may have a different goal manager.

The totals are rolled up from the child goals to the parent goals, from the bottom of the hierarchy to the top. The ending total for the root goal at the top of the hierarchy is an aggregate sum of all totals in the hierarchy. For example, if revenue metric is used, the total is an aggregate sum of the money amounts. If a count metric is used, the total is an aggregate count of the actual records in the system, such as telephone calls. Regardless of which particular goal is a target of the recalculate operation, all totals in a given hierarchy are updated.

If you set Goal.RollupOnlyFromChildGoals to true, only child goal records are used in the rollup. If you set it to false, the rollup includes the child records and other goal’s participating records. A participating record must satisfy the following conditions:

  • The source date of the record must be between the start date and the end date of the goal time period, or fall on the start date or the end date of the goal period.
  • The state and status of the record must match the values defined in the goal metric.
  • If a rollup query is specified for the goal, all query conditions must be met.
  • The goal manager must have Read access to the record.
Note
The goal rollup fields that do not participate in the rollup are not updated, their values are null.

To specify the rollup expiration time, use the Organization.GoalRollupExpiryTime attribute. For example, if the rollup expiration time is set to six months, the goals older than six months will not be rolled up automatically. To specify the frequency of goal rollup, use the Organization.GoalRollupFrequency attribute. The frequency can be set on an hourly basis. By default, the goal actual values are recalculated every 24 hours.

Override Calculated Values

To override the system calculated actual, in-progress, or custom goal rollup field values, use the UpdateRequest message to update the goal record. You must set the Goal.IsOverride attribute to true to notify the system that the rollup field values can be updated. To signal the system that the goal’s rollup field values were overridden and must not be updated during next recalculate operation, set the Goal.IsOverridden attribute to true. If Goal.IsOverride is false, an exception is thrown during the update operation. If Goal.IsOverridden is false, the goal rollup field values will be overwritten during next recalculate operation with system calculated values.

See Also

Concepts

Goal entity messages and methods

Other Resources

Goal management entities
Sample: Rollup goal data for a custom period against the target revenue
Sample: Rollup goal data for a fiscal period against the stretch target count

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Goal entity messages and methods

A goal represents a target objective for a user or a team for a specified time period.

The early bound class for this entity is Goal. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message Description

AssignRequest

Assigns a goal to another user.

CreateRequest

Creates a goal. You can also call the IOrganizationService.Create method.

DeleteRequest

Deletes a goal. You can also call the IOrganizationService.Delete method.

GrantAccessRequest

Shares a goal with another security principal (user or team).

ModifyAccessRequest

Changes the access rights for a goal previously shared with another security principal (user or team).

RecalculateRequest

Recalculates the rollup attribute values for all goals in the goal hierarchy that contain a specified goal.

RetrieveRequest

Retrieves a goal. You can also call the IOrganizationService.Retrieve method.

RetrieveMultipleRequest

Retrieves a collection of goals. You can also call the IOrganizationService.RetrieveMultiple method.

RetrievePrincipalAccessRequest

Retrieves the access the specified security principal (user or team) has to a goal.

RetrieveSharedPrincipalsAndAccessRequest

Retrieves all the security principals (users or teams) that have access to a goal, and their access rights to the goal.

RevokeAccessRequest

Removes all access to a goal for the specified security principal (user or team).

SetStateRequest

Sets the state of a goal. If you are using early bound types, use the GoalState enumeration. For a list of the state values, refer to the goal entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

Note
Not available in the offline mode.

UpdateRequest

Updates a goal. You can also call the IOrganizationService.Update method.

See Also

Concepts

Goal entity privileges
Metric (goal metric) entity messages and methods

Other Resources

Goal management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Metric (goal metric) entity messages and methods

A goal metric represents a type of measurement for a goal, such as money amount or count.

The early bound class for this entity is Metric. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a goal metric. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a goal metric. You can also call theIOrganizationService.Delete method.
RetrieveRequest | Retrieves a goal metric. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of goal metrics. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a goal metric. The possible states are defined in the MetricState enumeration. For a list of the state values, refer to the metric entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a goal metric. You can also call the IOrganizationService.Update method.

See Also

Concepts

Metric (goal metric) entity privileges
RollupField entity messages and methods

Other Resources

Goal management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RollupField entity messages and methods

A rollup field represents a field to be rolled up to calculate the actual and in-progress values against a goal.

The early bound class for this entity is RollupField. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a rollup field. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a rollup field. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a rollup field. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of rollup fields. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a rollup field. You can also call the IOrganizationService.Update method.

See Also

Concepts

RollupField entity privileges
GoalRollupQuery entity messages and methods

Other Resources

Goal management entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GoalRollupQuery entity messages and methods

A goal rollup query represents a query that is used to filter the results of the goal rollup.

The early bound class for this entity is GoalRollupQuery. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message Description

AssignRequest

Assigns a goal rollup query to another user or team.

CreateRequest

Creates a goal rollup query. You can also call the IOrganizationService.Create method.

DeleteRequest

Deletes a goal rollup query. You can also call the IOrganizationService.Delete method.

GrantAccessRequest

Shares a goal rollup query with another security principal (user or team).

ModifyAccessRequest

Changes the access rights for a goal rollup query previously shared with another security principal (user or team).

RetrieveRequest

Retrieves a goal rollup query. You can also call the IOrganizationService.Retrieve method.

RetrieveMultipleRequest

Retrieves a collection of goal rollup queries. You can also call the IOrganizationService.RetrieveMultiple method.

RetrievePrincipalAccessRequest

Retrieves the access the specified security principal (user or team) has to a goal rollup query.

RetrieveSharedPrincipalsAndAccessRequest

Retrieves the security principals (users or teams) that have access to a goal rollup query, and their access rights to the goal rollup query.

RevokeAccessRequest

Removes all access to a goal rollup query for the specified security principal (user or team).

SetStateRequest

Sets the state of a goal rollup query. If you are using early bound types, use the GoalRollupQueryState enumeration. For a list of the state values, refer to the GoalRollupQuery entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

Note
Not available in the offline mode.

UpdateRequest

Updates a goal rollup query. You can also call the IOrganizationService.Update method.

See Also

Concepts

GoalRollupQuery (rollup query) entity privileges

Other Resources

Goal management entities
Sample: Rollup goal data for a custom period against the target revenue

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Rollup goal data for a custom period against the target revenue
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Goals\RollupAllGoalsForCustomPeriodAgainstTargetRevenue.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to roll up goal data for a custom period against the target revenue.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Collections.Generic;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to work with Goals and related entities.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class RollupAllGoalsForCustomPeriodAgainstTargetRevenue
    {
        #region Class Level Members

        private Guid _salesManagerId;
        private Guid _unitGroupId;
        private Guid _defaultUnitId;
        private Guid _product1Id;
        private Guid _product2Id;
        private Guid _discountTypeId;
        private Guid _discountId;
        private Guid _priceListId;
        private Guid _priceListItem1Id;
        private Guid _priceListItem2Id;
        private Guid _catalogProductId;
        private Guid _catalogProductPriceOverrideId;
        private Guid _writeInProductId;
        private Guid _metricId;
        private Guid _inProgressId;
        private Guid _actualId;
        private Guid _parentGoalId;
        private Guid _firstChildGoalId;
        private Guid _secondChildGoalId;
        private List<Guid> _accountIds = new List<Guid>();
        private List<Guid> _rollupQueryIds = new List<Guid>();
        private List<Guid> _salesRepresentativeIds = new List<Guid>();
        private List<Guid> _opportunityIds = new List<Guid>();

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// several actions on Goal records are executed.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Create the revenue metric, setting the Amount Data Type to 'Money'
                    // and the Metric Type to 'Amount'.
                    Metric sampleMetric = new Metric()
                    {
                        Name = "Sample Revenue Metric",
                        AmountDataType = new OptionSetValue(0),
                        IsAmount = true,
                    };
                    _metricId = _serviceProxy.Create(sampleMetric);

                    Console.Write("Created revenue metric, ");

                    // Create first RollupField which targets the estimated values.
                    RollupField inProgress = new RollupField()
                    {
                        SourceEntity = Opportunity.EntityLogicalName,
                        SourceAttribute = "estimatedvalue",
                        GoalAttribute = "inprogressmoney",
                        SourceState = 0,
                        EntityForDateAttribute = Opportunity.EntityLogicalName,
                        DateAttribute = "estimatedclosedate",
                        MetricId = new EntityReference(Metric.EntityLogicalName, _metricId),
                    };
                    _inProgressId = _serviceProxy.Create(inProgress);

                    Console.Write("created in-progress RollupField, ");

                    // Create second RollupField which targets the actual values.
                    RollupField actual = new RollupField()
                    {
                        SourceEntity = Opportunity.EntityLogicalName,
                        SourceAttribute = "actualvalue",
                        GoalAttribute = "actualmoney",
                        SourceState = 1,
                        EntityForDateAttribute = Opportunity.EntityLogicalName,
                        DateAttribute = "actualclosedate",
                        MetricId = new EntityReference(Metric.EntityLogicalName, _metricId)
                    };
                    _actualId = _serviceProxy.Create(actual);

                    Console.Write("created actual revenue RollupField, ");

                    // Create the goal rollup queries.
                    // Note: Formatting the FetchXml onto multiple lines in the following
                    // rollup queries causes the lenth property to be greater than 1,000
                    // chars and will cause an exception.

                    // The first query locates opportunities in the first sales
                    // representative's area (zip code: 60661).
                    GoalRollupQuery goalRollupQuery = new GoalRollupQuery()
                    {
                        Name = "First Example Goal Rollup Query",
                        QueryEntityType = Opportunity.EntityLogicalName,
                        FetchXml = @"<fetch version=""1.0"" output-format=""xml-platform"" mapping=""logical"" distinct=""false""><entity name=""opportunity""><attribute name=""totalamount""/><attribute name=""name""/><attribute name=""customerid""/><attribute name=""estimatedvalue""/><attribute name=""statuscode""/><attribute name=""opportunityid""/><order attribute=""name"" descending=""false""/><link-entity name=""account"" from=""accountid"" to=""customerid"" alias=""aa""><filter type=""and""><condition attribute=""address1_postalcode"" operator=""eq"" value=""60661""/></filter></link-entity></entity></fetch>"
                    };
                    _rollupQueryIds.Add(_serviceProxy.Create(goalRollupQuery));

                    Console.Write("created first rollup query for zip code 60661, ");

                    // The second query locates opportunities in the second sales
                    // representative's area (zip code: 99999).
                    goalRollupQuery = new GoalRollupQuery()
                    {
                        Name = "Second Example Goal Rollup Query",
                        QueryEntityType = Opportunity.EntityLogicalName,
                        FetchXml = @"<fetch version=""1.0"" output-format=""xml-platform"" mapping=""logical"" distinct=""false""><entity name=""opportunity""><attribute name=""totalamount""/><attribute name=""customerid""/><attribute name=""estimatedvalue""/><attribute name=""statuscode""/><attribute name=""opportunityid""/><order attribute=""name"" descending=""false""/><link-entity name=""account"" from=""accountid"" to=""customerid"" alias=""aa""><filter type=""and""><condition attribute=""address1_postalcode"" operator=""eq"" value=""99999""/></filter></link-entity></entity></fetch>"
                    };
                    _rollupQueryIds.Add(_serviceProxy.Create(goalRollupQuery));

                    Console.WriteLine("created second rollup query for zip code 99999.");
                    Console.WriteLine();

                    // Create three goals: one parent goal and two child goals.
                    Goal parentGoal = new Goal()
                    {
                        Title = "Parent Goal Example",
                        RollupOnlyFromChildGoals = true,
                        ConsiderOnlyGoalOwnersRecords = true,
                        TargetMoney = new Money(300.0M),
                        IsFiscalPeriodGoal = false,
                        MetricId = new EntityReference
                        {
                            Id = _metricId,
                            LogicalName = Metric.EntityLogicalName
                        },
                        GoalOwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        OwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        GoalStartDate = DateTime.Today.AddDays(-1),
                        GoalEndDate = DateTime.Today.AddDays(30)
                    };
                    _parentGoalId = _serviceProxy.Create(parentGoal);

                    Console.WriteLine("Created parent goal");
                    Console.WriteLine("-------------------");
                    Console.WriteLine("Target: {0}", parentGoal.TargetMoney.Value);
                    Console.WriteLine("Goal owner: {0}", parentGoal.GoalOwnerId.Id);
                    Console.WriteLine("Goal Start Date: {0}", parentGoal.GoalStartDate);
                    Console.WriteLine("Goal End Date: {0}", parentGoal.GoalEndDate);
                    Console.WriteLine("<End of Listing>");
                    Console.WriteLine();

                    Goal firstChildGoal = new Goal()
                    {
                        Title = "First Child Goal Example",
                        ConsiderOnlyGoalOwnersRecords = true,
                        TargetMoney = new Money(100.0M),
                        IsFiscalPeriodGoal = false,
                        MetricId = new EntityReference
                        {
                            Id = _metricId,
                            LogicalName = Metric.EntityLogicalName
                        },
                        ParentGoalId = new EntityReference
                        {
                            Id = _parentGoalId,
                            LogicalName = Goal.EntityLogicalName
                        },
                        GoalOwnerId = new EntityReference
                        {
                            Id = _salesRepresentativeIds[0],
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        OwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        RollUpQueryActualMoneyId = new EntityReference
                        {
                            Id = _rollupQueryIds[0],
                            LogicalName = GoalRollupQuery.EntityLogicalName
                        },
                        GoalStartDate = DateTime.Today.AddDays(-1),
                        GoalEndDate = DateTime.Today.AddDays(30)
                    };
                    _firstChildGoalId = _serviceProxy.Create(firstChildGoal);

                    Console.WriteLine("First child goal");
                    Console.WriteLine("----------------");
                    Console.WriteLine("Target: {0}", firstChildGoal.TargetMoney.Value);
                    Console.WriteLine("Goal owner: {0}", firstChildGoal.GoalOwnerId.Id);
                    Console.WriteLine("Goal Start Date: {0}", firstChildGoal.GoalStartDate);
                    Console.WriteLine("Goal End Date: {0}", firstChildGoal.GoalEndDate);
                    Console.WriteLine();

                    Goal secondChildGoal = new Goal()
                    {
                        Title = "Second Child Goal Example",
                        ConsiderOnlyGoalOwnersRecords = true,
                        TargetMoney = new Money(200.0M),
                        IsFiscalPeriodGoal = false,
                        MetricId = new EntityReference
                        {
                            Id = _metricId,
                            LogicalName = Metric.EntityLogicalName
                        },
                        ParentGoalId = new EntityReference
                        {
                            Id = _parentGoalId,
                            LogicalName = Goal.EntityLogicalName
                        },
                        GoalOwnerId = new EntityReference
                        {
                            Id = _salesRepresentativeIds[1],
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        OwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        RollUpQueryActualMoneyId = new EntityReference
                        {
                            Id = _rollupQueryIds[1],
                            LogicalName = GoalRollupQuery.EntityLogicalName
                        },
                        GoalStartDate = DateTime.Today.AddDays(-1),
                        GoalEndDate = DateTime.Today.AddDays(30)
                    };
                    _secondChildGoalId = _serviceProxy.Create(secondChildGoal);

                    Console.WriteLine("Second child goal");
                    Console.WriteLine("-----------------");
                    Console.WriteLine("Target: {0}", secondChildGoal.TargetMoney.Value);
                    Console.WriteLine("Goal owner: {0}", secondChildGoal.GoalOwnerId.Id);
                    Console.WriteLine("Goal Start Date: {0}", secondChildGoal.GoalStartDate);
                    Console.WriteLine("Goal End Date: {0}", secondChildGoal.GoalEndDate);
                    Console.WriteLine();

                    // Calculate roll-up of goals.
                    RecalculateRequest recalculateRequest = new RecalculateRequest()
                    {
                        Target = new EntityReference(Goal.EntityLogicalName, _parentGoalId)
                    };
                    _serviceProxy.Execute(recalculateRequest);

                    Console.WriteLine("Calculated roll-up of goals.");

                    // Retrieve and report 3 different computed values for the goals
                    // - Percentage
                    // - ComputedTargetAsOfTodayPercentageAchieved
                    // - ComputedTargetAsOfTodayMoney
                    QueryExpression retrieveValues = new QueryExpression()
                    {
                        EntityName = Goal.EntityLogicalName,
                        ColumnSet = new ColumnSet(
                            "title",
                            "percentage",
                            "computedtargetasoftodaypercentageachieved",
                            "computedtargetasoftodaymoney")
                    };
                    EntityCollection ec = _serviceProxy.RetrieveMultiple(retrieveValues);

                    // Compute and display the results
                    for (int i = 0; i < ec.Entities.Count; i++)
                    {
                        Goal temp = (Goal)ec.Entities[i];
                        Console.WriteLine("Roll-up details for goal: {0}", temp.Title);
                        Console.WriteLine("---------------");
                        Console.WriteLine("Percentage: {0}", temp.Percentage);
                        Console.WriteLine("ComputedTargetAsOfTodayPercentageAchieved: {0}",
                            temp.ComputedTargetAsOfTodayPercentageAchieved);
                        Console.WriteLine("ComputedTargetAsOfTodayMoney: {0}",
                            temp.ComputedTargetAsOfTodayMoney.Value);
                        Console.WriteLine("<End of Listing>");
                    }

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {

            #region Create or Retrieve the necessary system users

            // Retrieve the ldapPath
            String ldapPath = String.Empty;
            // Retrieve the sales team - 1 sales manager and 2 sales representatives.
            _salesManagerId = SystemUserProvider.RetrieveSalesManager(_serviceProxy, ref ldapPath);
            _salesRepresentativeIds = SystemUserProvider.RetrieveSalespersons(_serviceProxy, ref ldapPath);

            #endregion

            #region Create records to support Opportunity records
            // Create a unit group
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };
            _unitGroupId = _serviceProxy.Create(newUnitGroup);

            // Retrieve the default unit id that was automatically created
            // when we created the Unit Group
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression
                {
                    Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "uomscheduleid",
                                Operator = ConditionOperator.Equal,
                                Values = { _unitGroupId }
                            }
                        }
                },
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };

            // Retrieve the unit.
            UoM unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];
            _defaultUnitId = unit.UoMId.Value;

            // Create a few products
            Product newProduct1 = new Product
            {
                ProductNumber = "1",
                Name = "Example Product 1",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName,
                    _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };
            _product1Id = _serviceProxy.Create(newProduct1);
            Console.WriteLine("Created {0}", newProduct1.Name);

            Product newProduct2 = new Product
            {
                ProductNumber = "2",
                Name = "Example Product 2",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 3,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName,
                    _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };
            _product2Id = _serviceProxy.Create(newProduct2);
            Console.WriteLine("Created {0}", newProduct2.Name);

            // Create a new discount list
            DiscountType newDiscountType = new DiscountType
            {
                Name = "Example Discount List",
                IsAmountType = false
            };
            _discountTypeId = _serviceProxy.Create(newDiscountType);

            // Create a new discount
            Discount newDiscount = new Discount
            {
                DiscountTypeId = new EntityReference(DiscountType.EntityLogicalName,
                    _discountTypeId),
                LowQuantity = 5,
                HighQuantity = 10,
                Percentage = 3
            };
            _discountId = _serviceProxy.Create(newDiscount);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };
            _priceListId = _serviceProxy.Create(newPriceList);

            // Create a price list item for the first product and apply volume discount
            ProductPriceLevel newPriceListItem1 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(20),
                DiscountTypeId = new EntityReference(DiscountType.EntityLogicalName,
                    _discountTypeId)
            };
            _priceListItem1Id = _serviceProxy.Create(newPriceListItem1);

            // Create a price list item for the second product
            ProductPriceLevel newPriceListItem2 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product2Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(15)
            };
            _priceListItem2Id = _serviceProxy.Create(newPriceListItem2);

            // Publish Product 1
            SetStateRequest publishRequest1 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product1Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest1);

            // Publish Product 2
            SetStateRequest publishRequest2 = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _product2Id),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest2);
            Console.WriteLine("Published {0} and {1}", newProduct1.Name, newProduct2.Name);

            // Create an account record for the opportunity's potential customerid
            Account newAccount = new Account
            {
                Name = "Litware, Inc.",
                Address1_PostalCode = "60661"
            };
            _accountIds.Add(_serviceProxy.Create(newAccount));

            newAccount = new Account
            {
                Name = "Margie's Travel",
                Address1_PostalCode = "99999"
            };
            _accountIds.Add(_serviceProxy.Create(newAccount));

            #endregion Create records to support Opportunity records

            #region Create Opportunity records
            // Create a new opportunity with user specified estimated revenue
            Opportunity newOpportunity = new Opportunity
            {
                Name = "Example Opportunity",
                CustomerId = new EntityReference(Account.EntityLogicalName,
                    _accountIds[0]),
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName,
                    _priceListId),
                IsRevenueSystemCalculated = false,
                EstimatedValue = new Money(400.00m),
                FreightAmount = new Money(10.00m),
                DiscountAmount = new Money(0.10m),
                DiscountPercentage = 0.20m,
                ActualValue = new Money(400.00m),
                OwnerId = new EntityReference
                {
                    Id = _salesRepresentativeIds[0],
                    LogicalName = SystemUser.EntityLogicalName
                }
            };
            _opportunityIds.Add(_serviceProxy.Create(newOpportunity));

            Opportunity secondOpportunity = new Opportunity
            {
                Name = "Example Opportunity 2",
                CustomerId = new EntityReference(Account.EntityLogicalName,
                    _accountIds[1]),
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName,
                    _priceListId),
                IsRevenueSystemCalculated = false,
                EstimatedValue = new Money(400.00m),
                FreightAmount = new Money(10.00m),
                DiscountAmount = new Money(0.10m),
                DiscountPercentage = 0.20m,
                ActualValue = new Money(400.00m),
                OwnerId = new EntityReference
                {
                    Id = _salesRepresentativeIds[1],
                    LogicalName = SystemUser.EntityLogicalName
                }
            };
            _opportunityIds.Add(_serviceProxy.Create(secondOpportunity));

            // Create a catalog product
            OpportunityProduct catalogProduct = new OpportunityProduct
            {
                OpportunityId = new EntityReference(Opportunity.EntityLogicalName,
                    _opportunityIds[0]),
                ProductId = new EntityReference(Product.EntityLogicalName,
                    _product1Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Quantity = 8,
                Tax = new Money(12.42m),
            };
            _catalogProductId = _serviceProxy.Create(catalogProduct);

            // Create another catalog product and override the list price
            OpportunityProduct catalogProductPriceOverride = new OpportunityProduct
            {
                OpportunityId = new EntityReference(Opportunity.EntityLogicalName,
                    _opportunityIds[1]),
                ProductId = new EntityReference(Product.EntityLogicalName,
                    _product2Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Quantity = 3,
                Tax = new Money(2.88m),
                IsPriceOverridden = true,
                PricePerUnit = new Money(12)
            };
            _catalogProductPriceOverrideId = _serviceProxy.Create(
                catalogProductPriceOverride);

            // create a new write-in opportunity product with a manual discount applied
            OpportunityProduct writeInProduct = new OpportunityProduct
            {
                OpportunityId = new EntityReference(Opportunity.EntityLogicalName,
                    _opportunityIds[1]),
                IsProductOverridden = true,
                ProductDescription = "Example Write-in Product",
                PricePerUnit = new Money(20.00m),
                Quantity = 5,
                ManualDiscountAmount = new Money(10.50m),
                Tax = new Money(7.16m)
            };
            _writeInProductId = _serviceProxy.Create(writeInProduct);

            // Close the opportunities as 'Won'
            WinOpportunityRequest winRequest = new WinOpportunityRequest()
            {
                OpportunityClose = new OpportunityClose()
                {
                    OpportunityId = new EntityReference
                    {
                        Id = _opportunityIds[0],
                        LogicalName = Opportunity.EntityLogicalName
                    },
                    ActualRevenue = new Money(400.00M),
                    ActualEnd = DateTime.Today
                },
                Status = new OptionSetValue(3)
            };
            _serviceProxy.Execute(winRequest);

            winRequest = new WinOpportunityRequest()
            {
                OpportunityClose = new OpportunityClose()
                {
                    OpportunityId = new EntityReference
                    {
                        Id = _opportunityIds[1],
                        LogicalName = Opportunity.EntityLogicalName
                    },
                    ActualRevenue = new Money(400.00M),
                    ActualEnd = DateTime.Today
                },
                Status = new OptionSetValue(3)
            };
            _serviceProxy.Execute(winRequest);

            #endregion Create Opportunity records
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            // The three system users that were created by this sample will continue to
            // exist on your system because system users cannot be deleted in Microsoft
            // Dynamics CRM.  They can only be enabled or disabled.

            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete("goal", _firstChildGoalId);
                _serviceProxy.Delete("goal", _secondChildGoalId);
                _serviceProxy.Delete("goal", _parentGoalId);
                _serviceProxy.Delete("goalrollupquery", _rollupQueryIds[0]);
                _serviceProxy.Delete("goalrollupquery", _rollupQueryIds[1]);
                _serviceProxy.Delete("opportunityproduct", _writeInProductId);
                _serviceProxy.Delete("opportunityproduct", _catalogProductPriceOverrideId);
                _serviceProxy.Delete("opportunityproduct", _catalogProductId);
                _serviceProxy.Delete("opportunity", _opportunityIds[0]);
                _serviceProxy.Delete("opportunity", _opportunityIds[1]);
                _serviceProxy.Delete("account", _accountIds[0]);
                _serviceProxy.Delete("account", _accountIds[1]);
                _serviceProxy.Delete("productpricelevel", _priceListItem1Id);
                _serviceProxy.Delete("productpricelevel", _priceListItem2Id);
                _serviceProxy.Delete("pricelevel", _priceListId);
                _serviceProxy.Delete("product", _product1Id);
                _serviceProxy.Delete("product", _product2Id);
                _serviceProxy.Delete("discount", _discountId);
                _serviceProxy.Delete("discounttype", _discountTypeId);
                _serviceProxy.Delete("uomschedule", _unitGroupId);
                _serviceProxy.Delete("rollupfield", _inProgressId);
                _serviceProxy.Delete("rollupfield", _actualId);
                _serviceProxy.Delete("metric", _metricId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                RollupAllGoalsForCustomPeriodAgainstTargetRevenue app = new RollupAllGoalsForCustomPeriodAgainstTargetRevenue();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Goal management entities
Sample: Rollup goal data for a fiscal period against the stretch target count
RecalculateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Rollup goal data for a fiscal period against the stretch target count
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Goals\RollupAllGoalsForFiscalPeriodAndStretchedTargetRevenue.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to roll up goal data for a fiscal period against stretch target count representing a number of completed telephone calls.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Collections.Generic;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to work with fiscal period goals that utilize stretched
    /// targets.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class RollupAllGoalsForFiscalPeriodAndStretchedTargetRevenue
    {
        #region Class Level Members

        private Guid _salesManagerId;
        private Guid _accountId;
        private Guid _phoneCallId;
        private Guid _phoneCall2Id;
        private Guid _metricId;
        private Guid _actualId;
        private Guid _parentGoalId;
        private Guid _firstChildGoalId;
        private Guid _secondChildGoalId;
        private List<Guid> _rollupQueryIds = new List<Guid>();
        private List<Guid> _salesRepresentativeIds = new List<Guid>();

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards, the
        /// sample creates a goal and child goals for a particular fiscal period.
        /// Stretched targets are tracked as well.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Create goal metric

                    // Create the metric, setting the Metric Type to 'Count' and enabling
                    // stretch tracking.
                    Metric metric = new Metric()
                    {
                        Name = "Sample Count Metric",
                        IsAmount = false,
                        IsStretchTracked = true
                    };
                    _metricId = _serviceProxy.Create(metric);
                    metric.Id = _metricId;

                    Console.Write("Created count metric, ");

                    #endregion

                    #region Create RollupFields

                    // Create RollupField which targets completed (received) phone calls.
                    RollupField actual = new RollupField()
                    {
                        SourceEntity = PhoneCall.EntityLogicalName,
                        GoalAttribute = "actualinteger",
                        SourceState = 1,
                        SourceStatus = 4,
                        EntityForDateAttribute = PhoneCall.EntityLogicalName,
                        DateAttribute = "actualend",
                        MetricId = metric.ToEntityReference()
                    };
                    _actualId = _serviceProxy.Create(actual);

                    Console.Write("created completed phone call RollupField, ");

                    #endregion

                    #region Create the goal rollup queries

                    // Note: Formatting the FetchXml onto multiple lines in the following
                    // rollup queries causes the length property to be greater than 1,000
                    // chars and will cause an exception.

                    // The following query locates closed incoming phone calls.
                    GoalRollupQuery goalRollupQuery = new GoalRollupQuery()
                    {
                        Name = "Example Goal Rollup Query",
                        QueryEntityType = PhoneCall.EntityLogicalName,
                        FetchXml = @"<fetch version='1.0' output-format='xml-platform' mapping='logical' distinct='false'><entity name='phonecall'><attribute name='subject'/><attribute name='statecode'/><attribute name='prioritycode'/><attribute name='scheduledend'/><attribute name='createdby'/><attribute name='regardingobjectid'/><attribute name='activityid'/><order attribute='subject' descending='false'/><filter type='and'><condition attribute='directioncode' operator='eq' value='0'/><condition attribute='statecode' operator='eq' value='1' /></filter></entity></fetch>"
                    };
                    _rollupQueryIds.Add(_serviceProxy.Create(goalRollupQuery));
                    goalRollupQuery.Id = _rollupQueryIds[0];

                    // The following query locates closed outgoing phone calls.
                    GoalRollupQuery goalRollupQuery2 = new GoalRollupQuery()
                    {
                        Name = "Example Goal Rollup Query",
                        QueryEntityType = PhoneCall.EntityLogicalName,
                        FetchXml = @"<fetch version='1.0' output-format='xml-platform' mapping='logical' distinct='false'><entity name='phonecall'><attribute name='subject'/><attribute name='statecode'/><attribute name='prioritycode'/><attribute name='scheduledend'/><attribute name='createdby'/><attribute name='regardingobjectid'/><attribute name='activityid'/><order attribute='subject' descending='false'/><filter type='and'><condition attribute='directioncode' operator='eq' value='1'/><condition attribute='statecode' operator='eq' value='1' /></filter></entity></fetch>"
                    };
                    _rollupQueryIds.Add(_serviceProxy.Create(goalRollupQuery2));
                    goalRollupQuery2.Id = _rollupQueryIds[1];

                    Console.Write("created rollup queries for phone calls.\n");
                    Console.WriteLine();

                    #endregion

                    #region Create goals

                    // Determine current fiscal period and year.
                    // Note: This sample assumes quarterly fiscal periods.
                    DateTime date = DateTime.Now;
                    int quarterNumber = (date.Month - 1) / 3 + 1;
                    int yearNumber = date.Year;

                    // Create three goals: one parent goal and two child goals.
                    Goal parentGoal = new Goal()
                    {
                        Title = "Parent Goal Example",
                        RollupOnlyFromChildGoals = true,
                        ConsiderOnlyGoalOwnersRecords = true,
                        TargetInteger = 8,
                        StretchTargetInteger = 10,
                        IsFiscalPeriodGoal = true,
                        FiscalPeriod = new OptionSetValue(quarterNumber),
                        FiscalYear = new OptionSetValue(yearNumber),
                        MetricId = metric.ToEntityReference(),
                        GoalOwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        OwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        }
                    };
                    _parentGoalId = _serviceProxy.Create(parentGoal);
                    parentGoal.Id = _parentGoalId;

                    Console.WriteLine("Created parent goal");
                    Console.WriteLine("-------------------");
                    Console.WriteLine("Target: {0}", parentGoal.TargetInteger.Value);
                    Console.WriteLine("Stretch Target: {0}",
                        parentGoal.StretchTargetInteger.Value);
                    Console.WriteLine("Goal owner: {0}", parentGoal.GoalOwnerId.Id);
                    Console.WriteLine("Goal Fiscal Period: {0}",
                        parentGoal.FiscalPeriod.Value);
                    Console.WriteLine("Goal Fiscal Year: {0}",
                        parentGoal.FiscalYear.Value);
                    Console.WriteLine("<End of Listing>");
                    Console.WriteLine();

                    Goal firstChildGoal = new Goal()
                    {
                        Title = "First Child Goal Example",
                        ConsiderOnlyGoalOwnersRecords = true,
                        TargetInteger = 5,
                        StretchTargetInteger = 6,
                        IsFiscalPeriodGoal = true,
                        FiscalPeriod = new OptionSetValue(quarterNumber),
                        FiscalYear = new OptionSetValue(yearNumber),
                        MetricId = metric.ToEntityReference(),
                        ParentGoalId = parentGoal.ToEntityReference(),
                        GoalOwnerId = new EntityReference
                        {
                            Id = _salesRepresentativeIds[0],
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        OwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        RollupQueryActualIntegerId = goalRollupQuery.ToEntityReference()
                    };
                    _firstChildGoalId = _serviceProxy.Create(firstChildGoal);

                    Console.WriteLine("First child goal");
                    Console.WriteLine("----------------");
                    Console.WriteLine("Target: {0}", firstChildGoal.TargetInteger.Value);
                    Console.WriteLine("Stretch Target: {0}",
                        firstChildGoal.StretchTargetInteger.Value);
                    Console.WriteLine("Goal owner: {0}", firstChildGoal.GoalOwnerId.Id);
                    Console.WriteLine("Goal Fiscal Period: {0}",
                        firstChildGoal.FiscalPeriod.Value);
                    Console.WriteLine("Goal Fiscal Year: {0}",
                        firstChildGoal.FiscalYear.Value);
                    Console.WriteLine();

                    Goal secondChildGoal = new Goal()
                    {
                        Title = "Second Child Goal Example",
                        ConsiderOnlyGoalOwnersRecords = true,
                        TargetInteger = 3,
                        StretchTargetInteger = 4,
                        IsFiscalPeriodGoal = true,
                        FiscalPeriod = new OptionSetValue(quarterNumber),
                        FiscalYear = new OptionSetValue(yearNumber),
                        MetricId = metric.ToEntityReference(),
                        ParentGoalId = parentGoal.ToEntityReference(),
                        GoalOwnerId = new EntityReference
                        {
                            Id = _salesRepresentativeIds[1],
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        OwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        RollupQueryActualIntegerId = goalRollupQuery2.ToEntityReference()
                    };
                    _secondChildGoalId = _serviceProxy.Create(secondChildGoal);

                    Console.WriteLine("Second child goal");
                    Console.WriteLine("-----------------");
                    Console.WriteLine("Target: {0}",
                        secondChildGoal.TargetInteger.Value);
                    Console.WriteLine("Stretch Target: {0}",
                        secondChildGoal.StretchTargetInteger.Value);
                    Console.WriteLine("Goal owner: {0}", secondChildGoal.GoalOwnerId.Id);
                    Console.WriteLine("Goal Fiscal Period: {0}",
                        secondChildGoal.FiscalPeriod.Value);
                    Console.WriteLine("Goal Fiscal Year: {0}",
                        secondChildGoal.FiscalYear.Value);
                    Console.WriteLine();

                    #endregion

                    #region Calculate rollup and display result

                    // Calculate roll-up of goals.
                    RecalculateRequest recalculateRequest = new RecalculateRequest()
                    {
                        Target = new EntityReference(Goal.EntityLogicalName, _parentGoalId)
                    };
                    _serviceProxy.Execute(recalculateRequest);

                    Console.WriteLine("Calculated roll-up of goals.");

                    // Retrieve and report 3 different computed values for the goals
                    // - Percentage
                    // - ComputedTargetAsOfTodayPercentageAchieved
                    // - ComputedTargetAsOfTodayInteger
                    QueryExpression retrieveValues = new QueryExpression()
                    {
                        EntityName = Goal.EntityLogicalName,
                        ColumnSet = new ColumnSet(
                            "title",
                            "percentage",
                            "computedtargetasoftodaypercentageachieved",
                            "computedtargetasoftodayinteger")
                    };
                    EntityCollection ec = _serviceProxy.RetrieveMultiple(retrieveValues);

                    // Compute and display the results
                    for (int i = 0; i < ec.Entities.Count; i++)
                    {
                        Goal temp = (Goal)ec.Entities[i];
                        Console.WriteLine("Roll-up details for goal: {0}", temp.Title);
                        Console.WriteLine("---------------");
                        Console.WriteLine("Percentage: {0}", temp.Percentage);
                        Console.WriteLine("ComputedTargetAsOfTodayPercentageAchieved: {0}",
                            temp.ComputedTargetAsOfTodayPercentageAchieved);
                        Console.WriteLine("ComputedTargetAsOfTodayInteger: {0}",
                            temp.ComputedTargetAsOfTodayInteger.Value);
                        Console.WriteLine("<End of Listing>");
                    }

                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {

            #region Create or Retrieve the necessary system users

            // Retrieve the ldapPath
            String ldapPath = String.Empty;
            // Retrieve the sales team - 1 sales manager and 2 sales representatives.
            _salesManagerId =
                SystemUserProvider.RetrieveSalesManager(_serviceProxy, ref ldapPath);
            _salesRepresentativeIds =
                SystemUserProvider.RetrieveSalespersons(_serviceProxy, ref ldapPath);

            #endregion

            #region Create PhoneCall record and supporting account

            Account account = new Account
            {
                Name = "Margie's Travel",
                Address1_PostalCode = "99999"
            };
            _accountId = (_serviceProxy.Create(account));
            account.Id = _accountId;

            // Create Guids for PhoneCalls
            _phoneCallId = Guid.NewGuid();
            _phoneCall2Id = Guid.NewGuid();

            // Create ActivityPartys for the phone calls' "From" field.
            ActivityParty activityParty = new ActivityParty()
            {
                PartyId = account.ToEntityReference(),
                ActivityId = new EntityReference
                {
                    Id = _phoneCallId,
                    LogicalName = PhoneCall.EntityLogicalName,
                },
                ParticipationTypeMask = new OptionSetValue(9),
            };

            ActivityParty activityPartyClosed = new ActivityParty()
            {
                PartyId = account.ToEntityReference(),
                ActivityId = new EntityReference
                {
                    Id = _phoneCall2Id,
                    LogicalName = PhoneCall.EntityLogicalName,
                },
                ParticipationTypeMask = new OptionSetValue(9)
            };

            // Create an open phone call.
            PhoneCall phoneCall = new PhoneCall()
            {
                Id = _phoneCallId,
                Subject = "Sample Phone Call",
                DirectionCode = false,
                To = new ActivityParty[] { activityParty },
                OwnerId = new EntityReference("systemuser", _salesRepresentativeIds[0]),
                ActualEnd = DateTime.Now
            };
            _serviceProxy.Create(phoneCall);

            // Close the first phone call.
            SetStateRequest closePhoneCall = new SetStateRequest()
            {
                EntityMoniker = phoneCall.ToEntityReference(),
                State = new OptionSetValue(1),
                Status = new OptionSetValue(4)
            };
            _serviceProxy.Execute(closePhoneCall);

            // Create a second phone call.
            phoneCall = new PhoneCall()
            {
                Id = _phoneCall2Id,
                Subject = "Sample Phone Call 2",
                DirectionCode = true,
                To = new ActivityParty[] { activityParty },
                OwnerId = new EntityReference("systemuser", _salesRepresentativeIds[1]),
                ActualEnd = DateTime.Now
            };
            _serviceProxy.Create(phoneCall);

            // Close the second phone call.
            closePhoneCall = new SetStateRequest()
            {
                EntityMoniker = phoneCall.ToEntityReference(),
                State = new OptionSetValue(1),
                Status = new OptionSetValue(4)
            };
            _serviceProxy.Execute(closePhoneCall);

            #endregion

        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            // The three system users that were created by this sample will continue to
            // exist on your system because system users cannot be deleted in Microsoft
            // Dynamics CRM.  They can only be enabled or disabled.

            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete("goal", _firstChildGoalId);
                _serviceProxy.Delete("goal", _secondChildGoalId);
                _serviceProxy.Delete("goal", _parentGoalId);
                _serviceProxy.Delete("goalrollupquery", _rollupQueryIds[0]);
                _serviceProxy.Delete("goalrollupquery", _rollupQueryIds[1]);
                _serviceProxy.Delete("account", _accountId);
                _serviceProxy.Delete("phonecall", _phoneCallId);
                _serviceProxy.Delete("phonecall", _phoneCall2Id);
                _serviceProxy.Delete("rollupfield", _actualId);
                _serviceProxy.Delete("metric", _metricId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                RollupAllGoalsForFiscalPeriodAndStretchedTargetRevenue app =
                    new RollupAllGoalsForFiscalPeriodAndStretchedTargetRevenue();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Goal management entities
Sample: Use rollup queries to track goals
RecalculateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Use rollup queries to track goals
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Goals\UsingQueriesToTrackGoals.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to use rollup queries to track goals.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to use queries to track goals.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class UsingQueriesToTrackGoals
    {
        #region Class Level Members

        private Guid _salesManagerId;
        private Guid _unitGroupId;
        private Guid _defaultUnitId;
        private Guid _productId;
        private Guid _priceListId;
        private Guid _priceListItemId;
        private Guid _orderDetailId;
        private Guid _metricId;
        private Guid _actualId;
        private Guid _parentGoalId;
        private Guid _firstChildGoalId;
        private Guid _accountId;
        private Guid _rollupQueryId;
        private Guid _salesRepresentativeId;
        private Guid _orderId;

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards, a
        /// rollup field and rollup query are created. The rollup query is only
        /// associated with the child goal. Then a parent goal and child goal
        /// are created. The goals are both rolled up and their results are displayed.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Create the revenue metric, setting the Amount Data Type to 'Money'
                    // and the Metric Type to 'Amount'.
                    Metric sampleMetric = new Metric()
                    {
                        Name = "Sample Revenue Metric",
                        AmountDataType = new OptionSetValue(0),
                        IsAmount = true,
                    };
                    _metricId = _serviceProxy.Create(sampleMetric);
                    sampleMetric.Id = _metricId;

                    Console.Write("Created revenue metric, ");

                    #region Create RollupFields

                    // Create RollupField which targets the actual totals.
                    RollupField actual = new RollupField()
                    {
                        SourceEntity = SalesOrder.EntityLogicalName,
                        SourceAttribute = "totalamount",
                        GoalAttribute = "actualmoney",
                        SourceState = 1,
                        EntityForDateAttribute = SalesOrder.EntityLogicalName,
                        DateAttribute = "datefulfilled",
                        MetricId = sampleMetric.ToEntityReference()
                    };
                    _actualId = _serviceProxy.Create(actual);

                    Console.Write("created actual revenue RollupField, ");

                    #endregion

                    #region Create the goal rollup query

                    // The query locates sales orders in the first sales
                    // representative's area (zip code: 60661) and with a value
                    // greater than $1,000.
                    GoalRollupQuery goalRollupQuery = new GoalRollupQuery()
                    {
                        Name = "First Example Goal Rollup Query",
                        QueryEntityType = SalesOrder.EntityLogicalName,
                        FetchXml = @"<fetch mapping=""logical"" version=""1.0""><entity name=""salesorder""><attribute name=""customerid"" /><attribute name=""name"" /><attribute name=""salesorderid"" /><attribute name=""statuscode"" /><attribute name=""totalamount"" /><order attribute=""name"" /><filter><condition attribute=""totalamount"" operator=""gt"" value=""1000"" /><condition attribute=""billto_postalcode"" operator=""eq"" value=""60661"" /></filter></entity></fetch>"
                    };
                    _rollupQueryId = _serviceProxy.Create(goalRollupQuery);
                    goalRollupQuery.Id = _rollupQueryId;

                    Console.Write("created rollup query.");
                    Console.WriteLine();

                    #endregion

                    #region Create two goals: one parent and one child goal

                    // Create the parent goal.
                    Goal parentGoal = new Goal()
                    {
                        Title = "Parent Goal Example",
                        RollupOnlyFromChildGoals = true,
                        TargetMoney = new Money(1000.0M),
                        IsFiscalPeriodGoal = false,
                        MetricId = sampleMetric.ToEntityReference(),
                        GoalOwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        OwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        GoalStartDate = DateTime.Today.AddDays(-1),
                        GoalEndDate = DateTime.Today.AddDays(30)
                    };
                    _parentGoalId = _serviceProxy.Create(parentGoal);
                    parentGoal.Id = _parentGoalId;

                    Console.WriteLine("Created parent goal");
                    Console.WriteLine("-------------------");
                    Console.WriteLine("Target: {0}", parentGoal.TargetMoney.Value);
                    Console.WriteLine("Goal owner: {0}", parentGoal.GoalOwnerId.Id);
                    Console.WriteLine("Goal Start Date: {0}", parentGoal.GoalStartDate);
                    Console.WriteLine("Goal End Date: {0}", parentGoal.GoalEndDate);
                    Console.WriteLine("<End of Listing>");
                    Console.WriteLine();

                    // Create the child goal.
                    Goal firstChildGoal = new Goal()
                    {
                        Title = "First Child Goal Example",
                        ConsiderOnlyGoalOwnersRecords = true,
                        TargetMoney = new Money(1000.0M),
                        IsFiscalPeriodGoal = false,
                        MetricId = sampleMetric.ToEntityReference(),
                        ParentGoalId = parentGoal.ToEntityReference(),
                        GoalOwnerId = new EntityReference
                        {
                            Id = _salesRepresentativeId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        OwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        RollUpQueryActualMoneyId = goalRollupQuery.ToEntityReference(),
                        GoalStartDate = DateTime.Today.AddDays(-1),
                        GoalEndDate = DateTime.Today.AddDays(30)
                    };
                    _firstChildGoalId = _serviceProxy.Create(firstChildGoal);

                    Console.WriteLine("First child goal");
                    Console.WriteLine("----------------");
                    Console.WriteLine("Target: {0}", firstChildGoal.TargetMoney.Value);
                    Console.WriteLine("Goal owner: {0}", firstChildGoal.GoalOwnerId.Id);
                    Console.WriteLine("Goal Start Date: {0}", firstChildGoal.GoalStartDate);
                    Console.WriteLine("Goal End Date: {0}", firstChildGoal.GoalEndDate);
                    Console.WriteLine("<End of Listing>");
                    Console.WriteLine();

                    #endregion

                    // Calculate roll-up of goals.
                    // Note: Recalculate can be run against any goal in the tree to cause
                    // a rollup of the whole tree.
                    RecalculateRequest recalculateRequest = new RecalculateRequest()
                    {
                        Target = parentGoal.ToEntityReference()
                    };
                    _serviceProxy.Execute(recalculateRequest);

                    Console.WriteLine("Calculated roll-up of goals.");
                    Console.WriteLine();

                    // Retrieve and report 3 different computed values for the goals
                    // - Percentage
                    // - ComputedTargetAsOfTodayPercentageAchieved
                    // - ComputedTargetAsOfTodayMoney
                    QueryExpression retrieveValues = new QueryExpression()
                    {
                        EntityName = Goal.EntityLogicalName,
                        ColumnSet = new ColumnSet(
                            "title",
                            "computedtargetasoftodaypercentageachieved",
                            "computedtargetasoftodaymoney")
                    };
                    EntityCollection ec = _serviceProxy.RetrieveMultiple(retrieveValues);

                    // Compute and display the results
                    for (int i = 0; i < ec.Entities.Count; i++)
                    {
                        Goal temp = (Goal)ec.Entities[i];
                        Console.WriteLine("Roll-up details for goal: {0}", temp.Title);
                        Console.WriteLine("---------------");
                        Console.WriteLine("ComputedTargetAsOfTodayPercentageAchieved: {0}",
                            temp.ComputedTargetAsOfTodayPercentageAchieved);
                        Console.WriteLine("ComputedTargetAsOfTodayMoney: {0}",
                            temp.ComputedTargetAsOfTodayMoney.Value);
                        Console.WriteLine("<End of Listing>");
                    }

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {

            #region Create or Retrieve the necessary system users

            // Retrieve the ldapPath
            String ldapPath = String.Empty;
            // Retrieve the sales team - 1 sales manager and 2 sales representatives.
            _salesManagerId =
                SystemUserProvider.RetrieveSalesManager(_serviceProxy, ref ldapPath);
            _salesRepresentativeId =
                SystemUserProvider.RetrieveSalespersons(_serviceProxy, ref ldapPath)[0];

            #endregion

            #region Create records to support SalesOrder records
            // Create a unit group
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };
            _unitGroupId = _serviceProxy.Create(newUnitGroup);

            // Retrieve the default unit id that was automatically created
            // when we created the Unit Group
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression
                {
                    Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "uomscheduleid",
                                Operator = ConditionOperator.Equal,
                                Values = { _unitGroupId }
                            }
                        }
                },
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };

            // Retrieve the unit.
            UoM unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];
            _defaultUnitId = unit.UoMId.Value;

            // Create a few products
            Product newProduct = new Product
            {
                ProductNumber = "1",
                Name = "Example Product",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId =
                    new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };
            _productId = _serviceProxy.Create(newProduct);
            newProduct.Id = _productId;
            Console.WriteLine("Created {0}", newProduct.Name);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };
            _priceListId = _serviceProxy.Create(newPriceList);

            // Create a price list item for the first product and apply volume discount
            ProductPriceLevel newPriceListItem = new ProductPriceLevel
            {
                PriceLevelId =
                    new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId =
                    new EntityReference(Product.EntityLogicalName, _productId),
                UoMId =
                    new EntityReference(UoM.EntityLogicalName, _defaultUnitId),
                Amount = new Money(20),
            };
            _priceListItemId = _serviceProxy.Create(newPriceListItem);

            // Publish the product
            SetStateRequest publishRequest = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Product.EntityLogicalName, _productId),
                State = new OptionSetValue((int)ProductState.Active),
                Status = new OptionSetValue(1)
            };
            _serviceProxy.Execute(publishRequest);
            Console.WriteLine("Published {0}", newProduct.Name);

            // Create an account record for the sales order's potential customerid
            Account newAccount = new Account
            {
                Name = "Litware, Inc.",
                Address1_PostalCode = "60661"
            };
            _accountId = _serviceProxy.Create(newAccount);
            newAccount.Id = _accountId;

            #endregion Create records to support SalesOrder

            #region Create SalesOrder record

            // Create the sales order.
            SalesOrder order = new SalesOrder()
            {
                Name = "Faux Order",
                DateFulfilled = new DateTime(2010, 8, 1),
                PriceLevelId =
                    new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                CustomerId =
                    new EntityReference(Account.EntityLogicalName, _accountId),
                FreightAmount = new Money(20.0M)
            };
            _orderId = _serviceProxy.Create(order);
            order.Id = _orderId;

            // Add the product to the order with the price overriden with a
            // negative value.
            SalesOrderDetail orderDetail = new SalesOrderDetail()
            {
                ProductId = newProduct.ToEntityReference(),
                Quantity = 4,
                SalesOrderId = order.ToEntityReference(),
                IsPriceOverridden = true,
                PricePerUnit = new Money(1000.0M),
                UoMId = new EntityReference(UoM.EntityLogicalName, _defaultUnitId)
            };
            _orderDetailId = _serviceProxy.Create(orderDetail);

            #endregion Create SalesOrder record
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            // The three system users that were created by this sample will continue to
            // exist on your system because system users cannot be deleted in Microsoft
            // Dynamics CRM.  They can only be enabled or disabled.

            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete("goal", _firstChildGoalId);
                _serviceProxy.Delete("goal", _parentGoalId);
                _serviceProxy.Delete("goalrollupquery", _rollupQueryId);
                _serviceProxy.Delete("salesorderdetail", _orderDetailId);
                _serviceProxy.Delete("salesorder", _orderId);
                _serviceProxy.Delete("account", _accountId);
                _serviceProxy.Delete("productpricelevel", _priceListItemId);
                _serviceProxy.Delete("pricelevel", _priceListId);
                _serviceProxy.Delete("product", _productId);
                _serviceProxy.Delete("uomschedule", _unitGroupId);
                _serviceProxy.Delete("rollupfield", _actualId);
                _serviceProxy.Delete("metric", _metricId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                UsingQueriesToTrackGoals app = new UsingQueriesToTrackGoals();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Goal management entities
Sample: Override goal total count and close the goal
RecalculateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Override goal total count and close the goal
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Goals\OverrideGoalTotalCount.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to override the goal total count and close the goal.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Collections.Generic;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to override the goal total count and close a goal.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class OverrideGoalTotalCount
    {
        #region Class Level Members

        private Guid _metricId;
        private Guid _actualId;
        private Guid _inprogressId;
        private Guid _goalId;
        private Guid _accountId;
        private Guid _salesManagerId;
        private Guid _phoneCallId;
        private Guid _phoneCall2Id;
        private List<Guid> _rollupQueryIds = new List<Guid>();

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// a goal is created specifying the target count. The goal is then
        /// rolled up, the actual and in-progress values are overridden and finally the
        /// goal is closed.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Create the count metric, setting the Metric Type to 'Count' by
                    // setting IsAmount to false.
                    Metric sampleMetric = new Metric()
                    {
                        Name = "Sample Count Metric",
                        IsAmount = false,
                    };
                    _metricId = _serviceProxy.Create(sampleMetric);
                    sampleMetric.Id = _metricId;

                    Console.Write("Created phone call metric, ");

                    #region Create RollupFields

                    // Create RollupField which targets completed (received) phone calls.
                    RollupField actual = new RollupField()
                    {
                        SourceEntity = PhoneCall.EntityLogicalName,
                        GoalAttribute = "actualinteger",
                        SourceState = 1,
                        SourceStatus = 4,
                        EntityForDateAttribute = PhoneCall.EntityLogicalName,
                        DateAttribute = "actualend",
                        MetricId = sampleMetric.ToEntityReference()
                    };
                    _actualId = _serviceProxy.Create(actual);

                    Console.Write("created actual revenue RollupField, ");

                    // Create RollupField which targets open (in-progress) phone calls.
                    RollupField inprogress = new RollupField()
                    {
                        SourceEntity = PhoneCall.EntityLogicalName,
                        GoalAttribute = "inprogressinteger",
                        SourceState = 0,
                        EntityForDateAttribute = PhoneCall.EntityLogicalName,
                        DateAttribute = "createdon",
                        MetricId = sampleMetric.ToEntityReference()
                    };
                    _inprogressId = _serviceProxy.Create(inprogress);

                    Console.Write("created in-progress revenue RollupField, ");

                    #endregion

                    #region Create the goal rollup queries

                    // Note: Formatting the FetchXml onto multiple lines in the following
                    // rollup queries causes the length property to be greater than 1,000
                    // chars and will cause an exception.

                    // The following query locates closed incoming phone calls.
                    GoalRollupQuery goalRollupQuery = new GoalRollupQuery()
                    {
                        Name = "Example Goal Rollup Query - Actual",
                        QueryEntityType = PhoneCall.EntityLogicalName,
                        FetchXml = @"<fetch version='1.0' output-format='xml-platform' mapping='logical' distinct='false'><entity name='phonecall'><attribute name='subject'/><attribute name='statecode'/><attribute name='prioritycode'/><attribute name='scheduledend'/><attribute name='createdby'/><attribute name='regardingobjectid'/><attribute name='activityid'/><order attribute='subject' descending='false'/><filter type='and'><condition attribute='directioncode' operator='eq' value='0'/><condition attribute='statecode' operator='eq' value='1' /></filter></entity></fetch>"
                    };
                    _rollupQueryIds.Add(_serviceProxy.Create(goalRollupQuery));
                    goalRollupQuery.Id = _rollupQueryIds[0];

                    // The following query locates open incoming phone calls.
                    GoalRollupQuery inProgressGoalRollupQuery = new GoalRollupQuery()
                    {
                        Name = "Example Goal Rollup Query - InProgress",
                        QueryEntityType = PhoneCall.EntityLogicalName,
                        FetchXml = @"<fetch version='1.0' output-format='xml-platform' mapping='logical' distinct='false'><entity name='phonecall'><attribute name='subject'/><attribute name='statecode'/><attribute name='prioritycode'/><attribute name='scheduledend'/><attribute name='createdby'/><attribute name='regardingobjectid'/><attribute name='activityid'/><order attribute='subject' descending='false'/><filter type='and'><condition attribute='directioncode' operator='eq' value='0'/><condition attribute='statecode' operator='eq' value='0' /></filter></entity></fetch>"
                    };
                    _rollupQueryIds.Add(_serviceProxy.Create(inProgressGoalRollupQuery));
                    inProgressGoalRollupQuery.Id = _rollupQueryIds[1];

                    Console.Write("created rollup queries for incoming phone calls.\n");
                    Console.WriteLine();

                    #endregion

                    #region Create a goal to track the open incoming phone calls.

                    // Create the goal.
                    Goal goal = new Goal()
                    {
                        Title = "Sample Goal",
                        RollupOnlyFromChildGoals = false,
                        ConsiderOnlyGoalOwnersRecords = false,
                        TargetInteger = 5,
                        RollupQueryActualIntegerId = goalRollupQuery.ToEntityReference(),
                        RollUpQueryInprogressIntegerId =
                            inProgressGoalRollupQuery.ToEntityReference(),
                        IsFiscalPeriodGoal = false,
                        MetricId = sampleMetric.ToEntityReference(),
                        GoalOwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        OwnerId = new EntityReference
                        {
                            Id = _salesManagerId,
                            LogicalName = SystemUser.EntityLogicalName
                        },
                        GoalStartDate = DateTime.Today.AddDays(-1),
                        GoalEndDate = DateTime.Today.AddDays(30)
                    };
                    _goalId = _serviceProxy.Create(goal);
                    goal.Id = _goalId;

                    Console.WriteLine("Created goal");
                    Console.WriteLine("-------------------");
                    Console.WriteLine("Target: {0}", goal.TargetInteger.Value);
                    Console.WriteLine("Goal owner: {0}", goal.GoalOwnerId.Id);
                    Console.WriteLine("Goal Start Date: {0}", goal.GoalStartDate);
                    Console.WriteLine("Goal End Date: {0}", goal.GoalEndDate);
                    Console.WriteLine("<End of Listing>");
                    Console.WriteLine();

                    #endregion

                    #region Calculate rollup and display result

                    // Calculate roll-up of the goal.
                    RecalculateRequest recalculateRequest = new RecalculateRequest()
                    {
                        Target = goal.ToEntityReference()
                    };
                    _serviceProxy.Execute(recalculateRequest);

                    Console.WriteLine("Calculated roll-up of goal.");
                    Console.WriteLine();

                    // Retrieve and report 3 different computed values for the goal
                    // - Percentage
                    // - Actual (Integer)
                    // - In-Progress (Integer)
                    QueryExpression retrieveValues = new QueryExpression()
                    {
                        EntityName = Goal.EntityLogicalName,
                        ColumnSet = new ColumnSet(
                            "title",
                            "percentage",
                            "actualinteger",
                            "inprogressinteger")
                    };
                    EntityCollection ec = _serviceProxy.RetrieveMultiple(retrieveValues);

                    // Compute and display the results.
                    for (int i = 0; i < ec.Entities.Count; i++)
                    {
                        Goal temp = (Goal)ec.Entities[i];
                        Console.WriteLine("Roll-up details for goal: {0}", temp.Title);
                        Console.WriteLine("---------------");
                        Console.WriteLine("Percentage Achieved: {0}",
                            temp.Percentage);
                        Console.WriteLine("Actual (Integer): {0}",
                            temp.ActualInteger.Value);
                        Console.WriteLine("In-Progress (Integer): {0}",
                            temp.InProgressInteger.Value);
                        Console.WriteLine("<End of Listing>");
                    }

                    Console.WriteLine();

                    #endregion

                    #region Update goal to override the actual rollup value

                    // Override the actual and in-progress values of the goal.
                    // To prevent rollup values to be overwritten during next Recalculate operation,
                    // set: goal.IsOverridden = true;

                    goal.IsOverride = true;
                    goal.ActualInteger = 10;
                    goal.InProgressInteger = 5;

                    // Update the goal.
                    UpdateRequest update = new UpdateRequest()
                    {
                        Target = goal
                    };
                    _serviceProxy.Execute(update);

                    Console.WriteLine("Goal actual and in-progress values overridden.");
                    Console.WriteLine();

                    #endregion

                    #region Retrieve result of manual override

                    // Retrieve and report 3 different computed values for the goal
                    // - Percentage
                    // - Actual (Integer)
                    // - In-Progress (Integer)
                    retrieveValues = new QueryExpression()
                    {
                        EntityName = Goal.EntityLogicalName,
                        ColumnSet = new ColumnSet(
                            "title",
                            "percentage",
                            "actualinteger",
                            "inprogressinteger")
                    };
                    ec = _serviceProxy.RetrieveMultiple(retrieveValues);

                    // Compute and display the results.
                    for (int i = 0; i < ec.Entities.Count; i++)
                    {
                        Goal temp = (Goal)ec.Entities[i];
                        Console.WriteLine("Roll-up details for goal: {0}", temp.Title);
                        Console.WriteLine("---------------");
                        Console.WriteLine("Percentage Achieved: {0}",
                            temp.Percentage);
                        Console.WriteLine("Actual (Integer): {0}",
                            temp.ActualInteger.Value);
                        Console.WriteLine("In-Progress (Integer): {0}",
                            temp.InProgressInteger.Value);
                        Console.WriteLine("<End of Listing>");
                    }

                    Console.WriteLine();

                    #endregion

                    #region Close the goal

                    // Close the goal.
                    SetStateRequest closeGoal = new SetStateRequest()
                    {
                        EntityMoniker = goal.ToEntityReference(),
                        State = new OptionSetValue(1),
                        Status = new OptionSetValue(1)
                    };

                    Console.WriteLine("Goal closed.");

                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {

            #region Create or Retrieve the necessary system users

            // Retrieve a sales manager.
            _salesManagerId =
                SystemUserProvider.RetrieveMarketingManager(_serviceProxy);

            #endregion

            #region Create PhoneCall record and supporting account

            Account newAccount = new Account
            {
                Name = "Margie's Travel",
                Address1_PostalCode = "99999"
            };
            _accountId = (_serviceProxy.Create(newAccount));
            newAccount.Id = _accountId;

            // Create Guids for PhoneCalls
            _phoneCallId = Guid.NewGuid();
            _phoneCall2Id = Guid.NewGuid();

            // Create ActivityPartys for the phone calls' "From" field.
            ActivityParty activityParty = new ActivityParty()
            {
                PartyId = newAccount.ToEntityReference(),
                ActivityId = new EntityReference
                {
                    Id = _phoneCallId,
                    LogicalName = PhoneCall.EntityLogicalName,
                },
                ParticipationTypeMask = new OptionSetValue(9)
            };

            ActivityParty activityPartyClosed = new ActivityParty()
            {
                PartyId = newAccount.ToEntityReference(),
                ActivityId = new EntityReference
                {
                    Id = _phoneCall2Id,
                    LogicalName = PhoneCall.EntityLogicalName,
                },
                ParticipationTypeMask = new OptionSetValue(9)
            };

            // Create an open phone call.
            PhoneCall phoneCall = new PhoneCall()
            {
                Id = _phoneCallId,
                Subject = "Sample Phone Call",
                DirectionCode = false,
                To = new ActivityParty[] { activityParty }
            };
            _serviceProxy.Create(phoneCall);

            // Create a second phone call to close
            phoneCall = new PhoneCall()
            {
                Id = _phoneCall2Id,
                Subject = "Sample Phone Call 2",
                DirectionCode = false,
                To = new ActivityParty[] { activityParty },
                ActualEnd = DateTime.Now
            };
            _serviceProxy.Create(phoneCall);

            // Close the second phone call.
            SetStateRequest closePhoneCall = new SetStateRequest()
            {
                EntityMoniker = phoneCall.ToEntityReference(),
                State = new OptionSetValue(1),
                Status = new OptionSetValue(4)
            };
            _serviceProxy.Execute(closePhoneCall);

            #endregion
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            // The three system users that were created by this sample will continue to
            // exist on your system because system users cannot be deleted in Microsoft
            // Dynamics CRM.  They can only be enabled or disabled.

            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete("phonecall", _phoneCallId);
                _serviceProxy.Delete("phonecall", _phoneCall2Id);
                _serviceProxy.Delete("goal", _goalId);
                _serviceProxy.Delete("goalrollupquery", _rollupQueryIds[1]);
                _serviceProxy.Delete("goalrollupquery", _rollupQueryIds[0]);
                _serviceProxy.Delete("account", _accountId);
                _serviceProxy.Delete("rollupfield", _actualId);
                _serviceProxy.Delete("rollupfield", _inprogressId);
                _serviceProxy.Delete("metric", _metricId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                OverrideGoalTotalCount app = new OverrideGoalTotalCount();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Goal management entities
RecalculateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Product catalog entities

A product catalog is a collection of products with their pricing information. The product catalog entities let you create a rich product classification system in Microsoft Dynamics CRM that provides support for:

  • Defining hierarchical structure of product families and products with configurable properties (attributes) that help you reduce the number of product stock keeping units (SKUs) needed to maintain your product catalog.
  • Selling individual products or grouping them into bundles and kits. A bundle or a kit is a collection of products that is sold as single unit. Product bundling is useful in grouping products in a way that customers get more benefit from the full line of products or to offer discounts on bundled products.
    Note
    Kits are deprecated in the current release of CRM. You should use bundles instead.

  • Defining related products in the system (substitute, cross-sell, up-sell, or accessory). The related products for a product are displayed as suggestions to the sales agents when they add the product to an opportunity, quote, order, or invoice.
  • Defining multiple pricing and discounting models. You can also use custom pricing instead of the CRM system pricing to calculate prices when you associate a product or bundle to an opportunity, quote, order, or invoice. Further, you can choose whether to apply discounts for products at the per-unit or line level.
  • Specify whether you want the price level (price list) to be automatically set for an opportunity, quote, order, or invoice based on the sales territory relationship of the user.
  • Specifying localized values for certain product properties (attributes) to make the product names and descriptions available in the user-preferred languages.

Use the following entities in CRM to manage your product catalog.

Entity | Description
Product | A product is either a physical inventory item (such as lumber or a nail), or a service (such as a haircut or tree pruning) that a company sells. Products from the product catalog can be used to build quotes and orders, and can be associated with opportunities or service cases. In addition, each product can contain links to sales literature and links to information about competitors and their products. More information: Product entity messages and methods
ProductSubstitute (Product Relationship) | A product relationship contains information about the selling relationship between two products, including the relationship type, such as up-sell, cross-sell, substitute, or accessory. More information: ProductSubstitute (product relationship) entity methods and messages
DynamicPropertyInstance (Property Instance) | A property instance stores the instance of a product property along with its values. More information: DynamicPropertyInstance (property instance) methods and messages
PriceLevel (Price List) | A price list contains one to many individual product and bundle prices, aggregated together into a list for categorization purposes. This enables easier maintenance and usability of the list. More information: PriceLevel (price list) entity messages and methods
ProductPriceLevel (Price List Item) | A price list item represents configurations that enable a business unit to control how prices are calculated in Microsoft Dynamics CRM such as quantity selling options, pricing method, rounding policy, and the rounding option. More information: ProductPriceLevel (price list item) entity messages and methods
Discount | Discounts enable a product to have different sales prices, depending on the quantity purchased. More information: Discount entity messages and methods
DiscountType (Discount List) | A discount list is an aggregation of different discounts, specifying how much of a discount the user can receive when the purchasing amount falls between certain ranges. Discount lists can exist at each quantity level, together with detail lines that contain the quantity breakpoints, and the reduction in the price. More information: DiscountType (discount list) entity messages and methods
UoM (Unit) | A unit is a measurement that specifies in what quantity a product will be sold. More information: UoM (unit) entity messages and methods
UoMSchedule (Unit Group) | A unit group contains one to many types of unit of measurement, as calculated from a base unit. A product is tied to a unit group in which it is sold. More information: UoMSchedule (unit group) entity messages and methods

These videos describe how products are administered and used in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update:

  • Video: Product Taxonomy Administration in Microsoft Dynamic CRM 2015
  • Video: Salesperson Experience with Product Taxonomy in Microsoft Dynamics CRM 2015

In This Section

Create and manage product families, products, and bundles

Publish, revise, revert, retire, and activate products (product lifecycle)

Product pricing methods

Use custom pricing for products

Set default price level for opportunity, quote, order, invoice

Product discounting methods

Localize product property values

Product entity messages and methods

ProductSubstitute (product relationship) entity methods and messages

ProductAssociation entity methods and messages

DynamicPropertyInstance (property instance) methods and messages

PriceLevel (price list) entity messages and methods

ProductPriceLevel (price list item) entity messages and methods

Discount entity messages and methods

DiscountType (discount list) entity messages and methods

UoM (unit) entity messages and methods

UoMSchedule (unit group) entity messages and methods

Sample: Create and publish products

Sample: Clone product records

Sample: Add products to a bundle

Sample: Calculate Price plug-in

Related Sections

Model your business data

Opportunity entities

Quote, order, and invoice entities

See Also

Other Resources

Video: Product Taxonomy Administration in Microsoft Dynamic CRM 2015
Video: Salesperson Experience with Product Taxonomy in Microsoft Dynamics CRM 2015

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create and manage product families, products, and bundles

Define your product catalog by organizing your products in a hierarchical structure by creating products and bundles under a product family, defining related products, and adding properties (attributes) to the parent product family so that all the child products and bundles under a product family automatically inherit the properties.

By default, when you create a product family, product, or bundle record, they are in the Draft state. After you have created a product, defined related products, and configured attributes for the parent product family record, you must publish the product family, product, or bundle record for them to become available in the system to your sales agents for selling. More information: Publish a product family, product, or bundle

Note
For products not associated with a product family, that is, products that don’t have a parent product family record assigned to them, you can choose to create them directly in an Active state by setting the Organization.CreateProductsWithoutParentInActiveState attribute to 1 (true). By default, this attribute is set to 0 (false) for a fresh installation of Microsoft Dynamics CRM and to 1 (true) if you’re upgrading from a previous version of CRM to ensure compatibility for your applications working with the previous version of CRM where the product records were created in an Active state.

You can also use the Sales tab in the system settings area in Microsoft Dynamics CRM or Microsoft Dynamics CRM for Outlook to specify whether products are created in an Active state. More information: Configure product catalog

In This Topic

Define product families, products, and bundles

Bundles and kits

Define product relationships for enhanced suggestions during product sale

Define product properties (not supported through SDK)

Clone a product family, product, or bundle

Define products, product families, and bundles

Use the Product.ProductStructure attribute to define whether an item is a product family, product, or bundle. Set the value of this attribute to:

  • 1 to create a product
  • 2 to create a product family
  • 3 to create a bundle
Note
Bundles are new in CRM. For more information, see Bundles and kits later in this topic.

To create a kit type of product, continue to use the Product.IsKit attribute.

Here are some important points to consider while defining product families, products, and bundles:

  • A product family record can contain multiple child product family, product, and bundle instances in a hierarchical structure. For a child product family, child product, or child bundle instance, you define the parent product family instance using the Product.ParentProductId attribute. You can’t change the parent record once you’ve set it.
  • A product or bundle can’t be set as a parent, which implies that a product or bundle record can’t have child records.
  • A product family, product, or bundle instance can be part of only one product family instance.
  • There is no limit on the nesting level for a product family.
  • The Product.ValidFromDate and Product.ValidToDate attributes don’t have any out-of-box business logic associated with them, except that there is a check to ensure that the date in Product.ValidToDate should be later than or equal to the date in Product.ValidFromDate. If required, you can implement your own business logic based on these attributes. For example, you could run a scheduled job to automatically retire last season’s products by using the date value in the Product.ValidToDate attribute.

The following code sample demonstrates how you can create a product family and a child product record.

Copy Code
// Create a product family
Product newProductFamily = new Product
{
   Name = "Example Product Family",
   ProductNumber = "PF001",
   ProductStructure = new OptionSetValue(2)
};
_productFamilyId = _serviceProxy.Create(newProductFamily);
Console.WriteLine("\nCreated {0}", newProductFamily.Name);

// Create a product record under the product family
Product newProduct1 = new Product
{
   Name = "Example Product 1",
   ProductNumber = "P001",
   ProductStructure = new OptionSetValue(1),
   ParentProductId = new EntityReference(Product.EntityLogicalName, _productFamilyId),
   QuantityDecimal = 2,
   DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
   DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _unit.Id)
};
_product1Id = _serviceProxy.Create(newProduct1);
Console.WriteLine("Created {0} under the product family", newProduct1.Name);

Bundles and kits

A bundle is a feature introduced in CRM to replace the older kit functionality. Similar to a kit, a bundle is a collection of products that is sold as single unit. Product bundling is useful in grouping products in a way that customers get more benefit from the full line of products or to offer discounts on bundled products that enables you to group products and sell as a single unit.

Only products can be added to a bundle; you can’t add a product family, a bundle, or a kit record to a bundle. You can add products to a bundle or a kit by creating a product association record using the ProductAssociation entity. The ProductAssociation.ProductId record specifies the bundle or kit that you want to add a product to and the ProductAssociation.AssociatedProduct specifies the product to be added. The maximum number of products that can be added to a bundle is determined by the following organization setting: Organization.MaxProductsinBundle.

You can also use the Sales tab in the system settings area in Dynamics CRM or CRM for Outlook to specify the maximum number of products that can be added to a bundle. More information: Configure product catalog information

The following code sample demonstrates how you can add products to a bundle.

Copy Code
// Add a product to a bundle
ProductAssociation newAssociation1 = new ProductAssociation
{
   AssociatedProduct = new EntityReference(Product.EntityLogicalName, _product1Id),
   ProductId = new EntityReference(Product.EntityLogicalName, _bundleId),
   Quantity = new decimal(15),
   ProductIsRequired = new OptionSetValue(0),
   UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id)
};
_product1AssociationId = _serviceProxy.Create(newAssociation1);

// Add another product to the bundle
ProductAssociation newAssociation2 = new ProductAssociation
{
   AssociatedProduct = new EntityReference(Product.EntityLogicalName, _product2Id),
   ProductId = new EntityReference(Product.EntityLogicalName, _bundleId),
   Quantity = new decimal(20),
   ProductIsRequired = new OptionSetValue(1),
   UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
};
_product2AssociationId = _serviceProxy.Create(newAssociation2);

if ((_product1AssociationId != null) && (_product1AssociationId != null))
Console.WriteLine("\nAdded both the products to the bundle");

For the complete sample, see Sample: Add products to a bundle.

Differences between kits and bundles

Both kits and bundles enable you to group products into a single unit, but here are some differences between the two.

Kits | Bundles
All the products in a kit are mandatory. | Some products in a bundle can be optional.
Kits support nesting; you can add a kit to another kit. | You can’t add a bundle to another bundle. You can only add products to a bundle.
While adding a kit to an opportunity, quote, order, or invoice, you can only see the kit level details; you can’t see individual products in the kit. | While adding a bundle to opportunity, quote, order, or invoice, you can see the bundle level details as well as individual products in the bundle.

Note
Kits are deprecated in the current release of Dynamics CRM; you should use bundles instead.

Define product relationships for enhanced suggestions during product sale

You can define related products for a product that are displayed as suggestions to your sales agents during opportunity or order management. The product suggestions for a product enables your sales agents to recommend related products and bundles/kits to the customers, and increase product sales. You can define the following relationships for a product: accessory, cross-sell, substitute, and up-sell. For example, Surface Pro can be added as an up-sell product for Surface RT so that when your sales agent is adding Surface RT to any opportunity, quote, order, or invoice, Surface Pro will be suggested as the up-sell option.

Use the ProductSubstitute.SalesRelationshipType attribute to define product relationships. Set the value of this attribute to:

  • 0 for up-sell
  • 1 for cross-sell
  • 2 for accessory
  • 3 for substitute

While defining product relationships, it’s important to define the direction of the relationship to prevent duplication of data. The supported directions the product relationships are:

Product relationship | Direction
Accessory | Uni-directional
Cross-sell | Uni-directional or Bi-directional
Substitute | Uni-directional or Bi-directional
Up-Sell | Uni-directional

Use the ProductSubstitute.Direction attribute to specify direction for a product relationship. Set the value of this attribute to:

  • 0 for uni-directional
  • 1 for bi-directional

The following code sample demonstrates how you can define relationships for products.

Copy Code
// Set product relationship
// Set product1 and product2 as substitute of each other (bi-directional)
ProductSubstitute newProductRelation = new ProductSubstitute
{
   SalesRelationshipType = new OptionSetValue(3),
   Direction = new OptionSetValue(1),
   ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
   SubstitutedProductId = new EntityReference(Product.EntityLogicalName, _product2Id)
};
_productRelationId = _serviceProxy.Create(newProductRelation);

Define product properties (not supported through SDK)

You can create and manage product properties (attributes) using Dynamics CRM or CRM for Outlook only; this isn’t supported programmatically. This section just provides an overview of the product properties, which is critical to understanding the new product catalog feature. For information about creating and managing product properties, see Use properties to describe a product.

Product properties can only be associated to a product family instance, and not to a product or bundle record. All the child product family, product, and bundle instances under a parent product family inherit the properties associated to the parent product family. The child product family, product, and bundle records can override or overwrite the inherited properties using Dynamics CRM or CRM for Outlook only.

The way you define a product property determines how it can be used by the sales agent at run time, that is, while adding an associated product to an opportunity, quote, order, or invoice.

  • An updatable product property’s value can be changed at run time, whereas the value of a read-only product property can’t be.
  • For a product property set as required, a value for the property must be specified at the run time. Otherwise, the property is displayed as unresolved.
  • A hidden property won’t be displayed to sales agents at the run time.
Note
Product properties don’t affect the pricing of a product. This implies that the Dynamics CRM pricing engine doesn’t support changing the price of a product based on a change in the product property values.

When you revise a product and change the properties, Dynamics CRM internally creates a new version of the product and copies the product details from the existing product to the newer version. The new product version has all the details including price lists, product relationships, and properties. The already-created opportunities with the older version of product can continue to refer to the older version of the product. The opportunities that are created after the product is revised or retired will refer to the current (newer) product version. For more information about product state transitions, see Publish, revise, revert, retire, and activate products (product lifecycle).

The following new entities are introduced for storing product properties configuration; programmatic access and management of these entities isn’t supported:

  • DynamicProperty entity stores information about the product properties.
  • DynamicPropertyAssociation entity stores information about the product family that a product property is associated to.
  • DynamicPropertyOptionSet entity stores information about the option set values for a product property of option set data type.
Note
The maximum number of product properties that can be attached to a product family is determined by the following organization setting: Organization.MaximumDynamicPropertiesAllowed. The number comes into effect when you publish a child product record or bundle under a product family that the properties are attached to, and not at the time when you attach the properties to a draft product family record.

You can also use the Sales tab in the system settings area in Dynamics CRM or CRM for Outlook to configure the maximum number of product properties. More information: Configure product catalog information

Clone a product family, product, or bundle

Use the CloneProductRequest message to clone a product family, product, or bundle record, and create a copy of the record under the same parent node. You must provide the ID of the record to clone. Cloning a product record also copies the properties of the product. The cloned record is created with the date and time stamp appended to the original values in the Product.Name and Product.ProductNumber attributes; the date time stamp denotes the time when the record was cloned. The following code sample demonstrates how to clone a product.

Copy Code
CloneProductRequest cloneReq = new CloneProductRequest
{
   Source = new EntityReference(Product.EntityLogicalName, _productId)
};

CloneProductResponse cloned = (CloneProductResponse)_serviceProxy.Execute(cloneReq);
_productCloneId = cloned.ClonedProduct.Id;

// Retrieve the cloned product record
Product retrievedProduct = (Product)_serviceProxy.Retrieve(Product.EntityLogicalName, _productCloneId, new ColumnSet(true));
Console.WriteLine("\nCreated clone product: {0}", retrievedProduct.Name);

Next step

Publish your product records to make products available for selling by your sales agents. More information: Publish a product family, product, or bundle

See Also

Concepts

Publish, revise, revert, retire, and activate products (product lifecycle)

Other Resources

Sample: Create and publish products
Sample: Clone product records
Sample: Add products to a bundle
Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Publish, revise, revert, retire, and activate products (product lifecycle)

By default, a product record is in the Draft state when you create it, and isn’t available for your sales agents. The record becomes available to your sales agents only when you publish it, which changes the state of the record to Active. For products that aren’t associated with a product family, that is, products that don’t have a parent product family record, you can choose to create them directly in an Active state by setting the Organization.CreateProductsWithoutParentInActiveState attribute to 1 (true). By default, this attribute is set to 0 (false) for a fresh installation of Microsoft Dynamics CRM and to 1 (true) if you’re upgrading from a previous version of CRM to ensure compatibility for your applications working with the previous version of CRM where the product records were created in an Active state.

You can also use the Sales tab in the system settings area in Microsoft Dynamics CRM or Microsoft Dynamics CRM for Outlook to specify whether products are created in an active state. More information: Configure product catalog information

Furthermore, you can revise, revert, retire, and activate your product records to maintain your product catalog as per your business requirements. The following illustration shows the state transitions of a product when you perform various operations on a product record in CRM.

Product lifecycle and state transitions

Activate*: The activate operation is applicable for certain type of product records only. More information: Activate a product or kit record

In This Topic

Publish a product family, product, or bundle

Revise a product family, product, or bundle

Revert a product family, product, or bundle

Retire a product family, product, or bundle

Activate a product or kit record

Publish a product family, product, or bundle

Use the SetStateRequest message to publish an individual product family, product, or bundle record. In this case, the state of the target record changes from Draft to Active. A child product or bundle record under a product family record can be published only if the parent product family record is published (in the Active state). You cannot publish multiple product family, product, or bundle records at once.

Use the PublishProductHierarchyRequest message to publish a product family hierarchy including the child products and bundles. You can use this message only with a product family record. The state of the target product family record and all the child product or bundle records changes from Draft to Active.

The following code sample demonstrates how you can publish an individual product family, product, or bundle record.

Copy Code
SetStateRequest publishRequest = new SetStateRequest
{
   EntityMoniker = new EntityReference(Product.EntityLogicalName, _productId),
   State = new OptionSetValue((int)ProductState.Active),
   Status = new OptionSetValue(1)
};
_serviceProxy.Execute(publishRequest);

The following code sample demonstrates how you can publish a product family, including its child records.

Copy Code
PublishProductHierarchyRequest publishRequest = new PublishProductHierarchyRequest
{
   Target = new EntityReference(Product.EntityLogicalName, _productFamilyId)
};
_serviceProxy.Execute(publishRequest);

For the complete sample code, see Sample: Create and publish products.

Important
For the product or bundle records that aren’t associated with a product family, you must publish them individually after creating or editing them to make them available to your sales agents. For product or bundle records associated with a product family, use the PublishProductHierarchyRequest message on the parent product family record to publish multiple child product or bundle records, along with the parent product family record, at once.

Also, for products that aren’t associated with a product family, you can choose to create them directly in an Active state by setting the Organization.CreateProductsWithoutParentInActiveState attribute to 1 (true). Alternately, use the Sales tab in the system settings area in Microsoft Dynamics CRM or Microsoft Dynamics CRM for Outlook to specify whether products not associated with product families are created in an active state. More information: Configure product catalog information

Revise a product family, product, or bundle

Use the SetStateRequest message to revise a product family, product, or bundle record.

  • When invoked for a product family record, it revises the product family and its child records.
  • When invoked for a product or a bundle record, it revises the individual record only.

The state of the target record changes from Active to Under Revision.

After the product properties (attributes) are updated, the target record must to be published for the changes to reflect. On publishing, the state of the target record changes from Under Revision to Active.

Note
When you revise a product and change the properties, CRM internally creates a new version of the product and copies the product details from the existing product to the newer version. The new product version has all the details including price lists, product relationships, and properties. The opportunities created with the older version of the product can continue to refer to the older version of the product. The opportunities that are created after the product is revised or retired will refer to the current (newer) product version.

You can add or change product properties using Microsoft Dynamics CRM or Microsoft Dynamics CRM for Outlook only; this isn’t supported programmatically. For more information about creating and managing product properties, see Use properties to describe a product.

Revert a product family, product, or bundle

Use the RevertProductRequest message to revert a product family, product, or bundle record to its last Active state. All the product property (attribute) changes done to the record since it was last published (Active state) will be lost.

  • When invoked for a product family record, it reverts the product family and its child records to their last Active state, and all the changes done to the product properties of the records since they were last published will be lost.
  • When invoked for a product or a bundle record, it reverts the individual product or bundle record to its last Active state, and all the changes done to the product properties of the record since it was last published will be lost.

The state of the target record changes from Under Revision to Active.

The following code sample demonstrates how to revert a product record.

Copy Code
RevertProductRequest revertReq = new RevertProductRequest
{
   Target = new EntityReference(Product.EntityLogicalName, _productId)
};
RevertProductResponse reverted = (RevertProductResponse)_serviceProxy.Execute(revertReq);

Retire a product family, product, or bundle

Use the SetStateRequest message to retire a product family, product, or bundle record.

  • When invoked for a product family record, it retires the entire product family hierarchy.
  • When invoked for a product or a bundle record, it retires the individual record only.

The state of the target record changes to Retired.

Note
You can’t retire a product that is part of a published (Active) bundle. Also, you can’t add a retired product to a bundle or can’t add a product to a retired bundle.

Activate a product or kit record

Use the SetStateRequest message to activate only the following types of record:

  • A retired product record that does not have a parent record.
  • A retired kit record.

The state of the target record changes from Retired to Active.

Note
You can’t activate a retired product family or a retired bundle record.

See Also

Concepts

Product pricing methods
Create and manage product families, products, and bundles

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Product pricing methods

Microsoft Dynamics CRM uses the ProductPriceLevel.PricingMethodCode attribute to determine prices. The value of this attribute affects:

  • How the price for the product is determined for each unit of measure that is defined for that product.
  • What attributes are required when you create or update a product price level and its associated product.

You can also use custom pricing for products instead of using the CRM system pricing. More information: Use custom pricing for products

The following table lists the formulas that are used for each value and the attributes that are required by each value.

Drop-down list value and equivalent pricing method value Description and required attributes

Currency Amount
CurrencyAmount = 1

The price is specified for each unit of measure for each product.
price = amount

For each unit of measure for each product, use the ProductPriceLevel.Amount attribute.

Note
The ProductPriceLevel.Amount attribute isn’t platform required if you’re not using the pricing methods provided by Microsoft Dynamics CRM. However, if you use the Currency Amount pricing method to determine a price, this attribute is platform required and you must specify a value for this attribute.

Percent of List
PercentListPrice = 2

The price is calculated based on the manufacturer's or distributor's list price.
calculated price = list price x percentage

For each unit of measure for each product, you must enter data for the following attributes:

  • Product.Price attribute. This is the List Price in the Product form.
  • ProductPriceLevel.Percentage attribute. This is the desired percentage of the list price.
  • ProductPriceLevel.RoundingPolicyCode attribute. This is the policy for rounding the price list.

Percent Markup - Current Cost
MarkupCurrentCost = 3

The price is calculated as a percentage of your current cost for the item.
calculated price = current cost x 100% + percentage

For each unit of measure for each product, you must enter data for the following attributes:

  • Product.CurrentCost attribute. You must update this cost every time that you receive a shipment of the item.
  • ProductPriceLevel.Percentage attribute. This is the percent markup.
  • ProductPriceLevel.RoundingPolicyCode attribute.

Percent Margin - Current Cost
MarginCurrentCost =4

The price is based on the profit percentage you want to achieve and your current cost for the item.
calculated price = current cost + [(current cost x percentage)/ (100% - percentage)]

For each unit of measure for each product, you must enter data for the following attributes:

  • Product.StandardCost attribute. You must update this cost every time when you receive a shipment of the item.
  • ProductPriceLevel.Percentage attribute. This is the profit percentage you want to achieve.
  • ProductPriceLevel.RoundingPolicyCode attribute.

Percent Markup - Standard Cost
MarkupStandardCost = 5

The price is calculated as a percentage of the standard cost of the item.
calculated price = standard cost x 100% + percentage
Because the standard cost is updated periodically, the standard cost amount in this equation is an average and will not always be the same as the amount you paid most recently for the item.

For each unit of measure for each product, you must enter data for the following attributes:

  • Product.StandardCost attribute. Every time that you update the standard cost, the price changes.
  • ProductPriceLevel.Percentage attribute. This is the percent markup.
  • ProductPriceLevel.RoundingPolicyCode attribute.

Percent Margin - Standard Cost
MarginStandardCost = 6

The price is based on the profit percentage you want to achieve and the standard cost of the item.
calculated price = standard cost + [(standard cost x percentage)/(100% - percentage)]
Because the standard cost is updated periodically, the standard cost amount in this equation is an average and will not always be the same as the amount you paid most recently for the item.

For each unit of measure for each product, you must enter data for the following attributes:

  • Product.StandardCost attribute. Every time that you update the standard cost, the price changes.
  • ProductPriceLevel.Percentage attribute. This is the profit percentage you want to achieve.
  • ProductPriceLevel.RoundingPolicyCode attribute.

To set the values for the ProductPriceLevel.PricingMethodCode attribute and the other product price level entity attributes, use the IOrganizationService.Update method, passing an instance of the ProductPriceLevel class. To set the values for the product attributes, use the methods in the Product class.

See Also

Concepts

ProductPriceLevel (price list item) entity messages and methods
Product entity messages and methods

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use custom pricing for products

The pricing engine in Microsoft Dynamics CRM supports a standard set of pricing and discounting methods, which might be limiting to your business depending on your specific requirements for applying taxation, discounts, and other pricing rules for your products. If you want to define custom pricing for your products in opportunities, quotes, orders and invoices, you can use the CalculatePrice message.

To use the custom pricing for your opportunities, quotes, orders, and invoices:

  1. Set the value of the Organization.OOBPriceCalculationEnabled attribute to 0 (false). You can also use the Sales tab in the system settings area in Microsoft Dynamics CRM or Microsoft Dynamics CRM for Outlook to disable system pricing. More information: Configure product catalog information
  2. Create a plug-in that contains your custom pricing code for calculating the price for your opportunity, quote, order, or invoice.
  3. Register the plug-in on the CalculatePrice message.

When the Organization.OOBPriceCalculationEnabled attribute is set to 0, every time an opportunity, quote, order, or invoice is created or changes, the plug-in registered on the CalculatePrice executes to calculate prices as specified in your custom code in the plug-in. The CalculatePriceRequest message doesn’t have any usage scenario of its own. It’s exposed so that you can plug in your own custom pricing calculation logic if you don’t want to use the out-of-box pricing provided by CRM.

For a sample plug-in that calculates custom pricing for opportunities, quotes, orders, and invoices, see Sample: Calculate Price plug-in.

If you want to revert to using the out-of-box pricing for your opportunities, quotes, orders, and invoices, set the value of the Organization.OOBPriceCalculationEnabled attribute to 1 (true). You can also use the Sales tab in the system settings area in CRM or CRM for Outlook to enable system pricing. More information: Configure product catalog information

See Also

Concepts

Product pricing methods

Other Resources

Sample: Calculate Price plug-in
Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Set default price level for opportunity, quote, order, invoice

You can choose whether to automatically set a default price level (price list) for an opportunity, quote, order, or invoice based on the sales territory of the user who creates or updates the opportunity, quote, order, or invoice record.

Enable automatic selection of default price level

To enable selection of default price level for opportunities, quotes, orders, or invoices based on the sales territory relationship, the following conditions must be true:

  • The value of the Organization.UseInbuiltRuleForDefaultPriceSelectionRule attribute is set to 1 (true). By default, the value is set to 1 (true).
    You can also use the Sales tab in the system settings area in Microsoft Dynamics CRM or Microsoft Dynamics CRM for Outlook to specify whether the default price level should be automatically selected for opportunities. More information: Configure product catalog information
  • A price level is associated with a territory using the Territory Default Pricelist connection role, and the territory is assigned to the user who creates or updates the opportunity, quote, order, or invoice record.
  • The user has permission on the price level that is associated with the territory by using the Territory Default Pricelist connection role.

CRM internally uses the GetDefaultPriceLevelRequest message to determine the default price level for an opportunity, quote, order, or invoice based on the current user and the territory relationship with the price level. This is how the price level is set:

  • If a single price level is returned, the price level is automatically set for the opportunity, quote, order, or invoice record that the user is creating or updating.
  • If multiple price levels are returned, the price level field isn’t populated and the user must specify a price level for the opportunity, quote, order, or invoice record.

Disable automatic selection of default price level

You can turn off the automatic selection of a default price level for your opportunity, quote, order, or invoice by setting the value of the Organization.UseInbuiltRuleForDefaultPriceSelectionRule attribute to 0 (false), or by using the Sales tab in the system settings area in Microsoft Dynamics CRM or Microsoft Dynamics CRM for Outlook. More information: Configure product catalog information

See Also

Concepts

PriceLevel (price list) entity messages and methods
Territory entity messages and methods
Opportunity entities
Quote, order, and invoice entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Product discounting methods

Discounts can be applied either at the line item level or at per unit level. Use the Organization.DiscountCalculationMethod attribute to specify the discount method. Set the value of the attribute to:

  • 0 for discounting at line item level
  • 1 for discounting at per unit level

You can also use the Sales tab in the system settings area in the Microsoft Dynamics CRM or Microsoft Dynamics CRM for Outlook to specify the discount calculation method. More information: Configure product catalog information

To illustrate the discounting model with an example, consider the following product line item entry in an opportunity:

Product Name | Price Per Unit | Quantity | Discount | Extended Amount
Example Product | 100 | 200 | 10 | ?

Extended Amount for the product line item entry is calculated depending on your selected discounting model:

  • Line item: The discount applied is 10, and the Extended Amount is 19990 ((Price Per Unit * Quantity) – discount applied).
  • Per unit: The discount applied is 2000 (Quantity * Discount), and the Extended Amount is 18000 ((Price Per Unit * Quantity) – discount applied).
Note
If you upgrade from a previous version of CRM to the current version, by default the value of the Organization.DiscountCalculationMethod attribute is set to 0 (line item) to support the old discounting behavior where discounts could only be applied at the line level.

See Also

Concepts

Discount entity messages and methods
DiscountType (discount list) entity messages and methods

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Localize product property values

Product names may be localized for different regions. With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update you can provide localized labels for certain product attributes so that people will see the localized names that match their language preferences. This topic is about how developers can interact with this feature. For step-by-step instructions to use this feature in the application, see Customer Center: Translate product names and properties into multiple languages.

In this topic

Attributes that support localized property values

Retrieve localized property values

Query using localized values

Create or update records with localizable attributes

Translate localizable attributes

Uninstall a language

Attributes that support localized property values

The following list contains the attributes that support localizable values:

  • Product.Name
  • DynamicProperty.Name
  • DynamicPropertyOptionSetItem.DynamicPropertyOptionName
  • DynamicPropertyOptionSetItem.DynamicPropertyOptionDescription

The StringAttributeMetadata and MemoAttributeMetadata classes have a read-only IsLocalizable Boolean property that is false for all attributes except the four in the preceding table.

Retrieve localized property values

You don’t need to do anything differently to retrieve the localized value that matches the user’s language preference. If a localized value exists for the user’s preferred language, it will be returned. If a localized value doesn’t exist, the value for the organization’s base language will be returned. This behavior maintains backwards compatibility; any code you currently have using the product name attribute will continue to work using any localized values. If the localization of property values is incomplete, people may see mixed language values.

To retrieve all the localized labels for a specific localizable attribute, use the RetrieveLocLabelsRequest message.

Query using localized values

When you query entities with conditions using values for localized attributes, the conditions will be evaluated using your preferred language first and will revert to the base language if there is no localized value for that attribute. Query results for localized attribute values will be those for your preferred language if they exist. Otherwise, the results will use the base language values.

Create or update records with localizable attributes

Records with localized attributes are read-only unless your preferred language is the organization’s base language. You can only create records with localized property values using the organization’s base language. If you update the base language value for a localizable attribute any localized values for that attribute are not changed except if you clear the value for the base language. If you set the base language value to null or an empty string, all localized values for that property will also be cleared.

To add or update localized labels for any specific localized attribute, use the SetLocLabelsRequest message or import translated values. Any changes to the localizable attributes will appear in the audit history for the record. The language code identifier (LCID) for the localized value will appear in the audit history.

Translate localizable attributes

The process of localizing localizable attributes programmatically is similar to the process used to translate localized solution labels. More information: Translate customized entity and attribute text

Unlike translating metadata values, the user exporting and importing localized attributes values does not have to have the system administrator security role. The sales manager security role has the privileges necessary to translate localizable attributes. The person translating localized property values can only export those records they have access to view and update those records they have privileges to update.

To translate localizable attributes programmatically you must first export the current localized label definitions using ExportFieldTranslationRequest. The ExportFieldTranslationResponse.ExportTranslationFile property contains a byte[] for a compressed crmFieldTranslations.zip file containing a [Content_types].xml file and a crmFieldTranslations.xml file that can be opened using Microsoft Office Excel. The Localized Labels worksheet contains a column with an LCID value for each provisioned language for the organization. The column with the base language values will be populated and the columns for each provisioned language will contain any previously localized values. This file can be edited by a translator to provide localized labels for the localizable properties.

Tip
If you want to perform a bulk update of just the base language names, you can also edit the base language values.

After the crmFieldTranslations.xml file is edited to provide localized labels, compress it together with the [Content_types].xml file and set that file as the TranslationFile property of the ImportFieldTranslationRequest.

Modify the values included when exporting translated property values

The values that are included in the exported translations are controlled by customizable views associated with the entities that support localizable property values. Only the product entity displays this view in the customization user interface. These views are named Export Field Translations. The following table provides the SavedQueryId for these views.

Entity SavedQueryId Default FetchXml

product

9cfe2a9f-13c4-e311-8f2e-00155d9d2505

<fetch version="1.0"
output-format="xml-platform"
mapping="logical"
distinct="false">
<entity name="product">
<attribute name="name" />
</entity>
</fetch>

dynamicproperty

4833cf48-1ac4-e311-8f2e-00155d9d2505

<fetch version="1.0"
output-format="xml-platform"
mapping="logical">
<entity name="dynamicproperty">
<attribute name="name" />
</entity>
</fetch>

dynamicpropertyoptionsetitem

d64cce30-1fc4-e311-8f2e-00155d9d2505

<fetch version="1.0"
output-format="xml-platform"
mapping="logical">
<entity name="dynamicpropertyoptionsetitem">
<attribute name="dynamicpropertyoptionname" />
<attribute name="dynamicpropertyoptiondescription" />
</entity>
</fetch>

You can edit the FetchXml property of these views to filter out any attribute property values you do not want to include. For example, you may want to exclude archived records or only include those updated after a certain date.

Monitor the progress of field translation import jobs

The system job entity contains the following views to monitor the progress of field translation import jobs:

  • All Field Translation Import Jobs
  • Completed Field Translation Import Jobs
  • In Progress Field Translation Import Jobs
  • My Field Translation Import Jobs
  • Not Started Field Translation Import Jobs

The following conditions will cause errors when importing translation jobs:

Message | Description
Warning: You don’t have write permissions to one or more of the rows specified in the import file for worksheet {0}, Line {1}. | The person running the import may not have write permissions to a row included in the imported file. Processing of other rows will continue.
Warning: The base language translation string present in worksheet {0}, row {1}, column {2} is null. | A base language value cannot be cleared by importing translations. Processing of other rows will continue
Warning: The number of cells in row {0} don’t match the number of cells in row 1 in worksheet {1}. | All rows in the spreadsheet must have the same number of cells. Processing of other rows will continue.
Warning: An invalid Entity name was found in worksheet {0}, Line {1}, Column A. | There is no valid entity in the system using a name in the worksheet. Processing of other rows will continue.
Warning: An invalid Object Column Name was found in worksheet {0}, Line {1}, Column C. | There is no valid localizable attribute in the system using a name in the worksheet. Processing of other rows will continue.
Warning: An invalid Object Id was found in worksheet {0}, Line {1}, Column B. | There is no matching record in the organization for item in this row. Processing of other rows will continue.
Error: No rows were found in worksheet {0}. | The worksheet to import is empty.
Error: The Organization ID present in worksheet {0} does not match the current Organization ID. | You can only import translations into the same organization they were exported from.
Warning: An invalid language code was found in worksheet {0}, Column {1}. | Details: {2} | The LCID in the column isn’t a valid integer or the Language pack for the language is not installed. The translations in the column are ignored. Valid locale ID values can be found at Locale ID (LCID) Chart.
Error: A duplicate language code was found in worksheet {0}, Column {1}. | Each column must have a different language code.
Error: The translation file is invalid. The compressed file must contain the following files at its root: CrmFieldTranslations.xml, [Content_Types].xml | The compressed (zip) file to be imported must contain only the files described in the error.
Error: The translations file is invalid or doesn’t conform to the required schema. | The CrmFieldTranslations.xml file included in the compressed (zip) file must be a file that was exported from the system and only edited to provide localized values. Other changes may invalidate the file.

Uninstall a language

Any localized labels provided for a language that is uninstalled will remain in the system so that they’ll be in place if the language is reinstalled.

See Also

Reference

Translate customized entity and attribute text

Other Resources

Product catalog entities
Customer Center: Translate product names and properties into multiple languages

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Product entity messages and methods

A product represents information about products and their pricing information. The schema name for this entity is Product. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddProductToKitRequest | Deprecated. Use the ProductAssociation entity. Adds a product to a kit. A kit is a product catalog item that consists of one or more products.
AddSubstituteProductRequest | Deprecated. Use the ProductSubstitute entity. Establishes an association between a product and a substitute product.
CloneProductRequest | Clones a product family, product, or bundle record to create a copy of the record under the same parent record.
ConvertKitToProductRequest | Deprecated. Converts a kit to a product.
ConvertProductToKitRequest | Deprecated. Converts a product to a kit.
CreateRequest | Creates a product family, product, or bundle. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a product family, product, or bundle. You can also call the IOrganizationService.Delete method.
PublishProductHierarchyRequest | Publishes a product family along with its child records.
RemoveProductFromKitRequest | Deprecated. Use the ProductAssociation entity. Removes a product from a kit.
RemoveRelatedRequest | Deprecated. Use the DisassociateRequest or Disassociate class. Removes the relationship between a product and the specified entity (lead or competitor).
RemoveSubstituteProductRequest | Deprecated. Use the ProductSubstitute entity. Removes the association of a substitute product from a product.
RetrieveRequest | Retrieves a product family, product, or bundle. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of products. You can also call the IOrganizationService.RetrieveMultiple method.
SetRelatedRequest | Deprecated. Use the AssociateRequest or Associate class. Creates a relationship between a product and the specified entity (lead or competitor).
SetStateRequest | Sets the state of a product family, product, or bundle. If you’re using early bound types, use the ProductState enumeration to set the possible states. For a list of the state values, refer to the Product entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a product family, product, or bundle. You can also call the IOrganizationService.Update method.

See Also

Reference

Bundles and kits

Concepts

Create and manage product families, products, and bundles
Publish, revise, revert, retire, and activate products (product lifecycle)
Product entity privileges

Other Resources

Product catalog entities
Sample: Create and publish products
Sample: Clone product records
Sample: Add products to a bundle

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProductSubstitute (product relationship) entity methods and messages

A product relationship represents a selling relationship between two products, including the relationship type, such as upsell, cross-sell, substitute, or accessory. The schema name for this entity is ProductSubstitute. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a product relationship (product substitute). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a product relationship (product substitute). You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a product relationship (product substitute). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of product relationships (product substitute). You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a product relationship (product substitute). You can also call the IOrganizationService.Update method.

See Also

Reference

Define product relationships for enhanced suggestions during product sale

Other Resources

Sample: Create and publish products
Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProductAssociation entity methods and messages

A product association represents an instance of a product added to a bundle or kit. The schema name for this entity is ProductAssociation. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a product association. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a product association. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a product association. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of product associations. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a product association. If you’re using early bound types, use the ProductAssociationState enumeration to set the possible states. For a list of the state values, refer to the ProductAssociation entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a product association. You can also call the IOrganizationService.Update method.

See Also

Reference

Bundles and kits

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DynamicPropertyInstance (property instance) methods and messages

A property instance stores the instance of a product property along with its values. The schema name for this entity is DynamicPropertyInstance. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Note
A property instance (dynamic property instance) record gets automatically created for a product or bundle when you add the product or bundle to an opportunity, quote, order, or invoice, and is automatically deleted when the product or bundle is removed from an opportunity, quote, order, or invoice. Therefore, it’s not recommended to manually create or delete property instance (dynamic property instance) records for a product or bundle.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a property instance (dynamic property instance). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a property instance (dynamic property instance). You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a property instance (dynamic property instance). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of property instances (dynamic property instances). You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveProductPropertiesRequest | Retrieves all the property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.
UpdateRequest | Updates a property instance (dynamic property instance). You can also call the IOrganizationService.Update method.
UpdateProductPropertiesRequest | Updates the value of property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.

See Also

Reference

Define product properties (not supported through SDK)
DynamicPropertyInstance entity privileges

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PriceLevel (price list) entity messages and methods

A price level (price list) represents pricing levels. The schema name for this entity is PriceLevel. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a price level (price list). You can also call the Create method.
DeleteRequest | Deletes a price level (price list). You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a price level (price list). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of price levels (price list). You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a price level (price list). If you are using early bound types, use the PriceLevelState enumeration to set the possible states. For a list of the state values, refer to the PriceLevel entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a price level (price list). You can also call the IOrganizationService.Update method.

See Also

Concepts

Set default price level for opportunity, quote, order, invoice
PriceLevel (price list) entity privileges
Product entity messages and methods

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProductPriceLevel (price list item) entity messages and methods

A product price level (price list item) represents information about how to price a product in the specified price level. This includes pricing method, rounding option, and discount type based on a specified product unit. The schema name for this entity is ProductPriceLevel. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a product price level (price list item). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a product price level (price list item). You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a product price level (price list item). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of product price levels (price list items). You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a product price level (price list item). You can also call the IOrganizationService.Update method.

See Also

Concepts

ProductPriceLevel (price list item) entity privileges
UoM (unit) entity messages and methods

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Discount entity messages and methods

A discount entity represents a price reduction made from the list price of a product or service, depending on the quantity purchased.

The schema name for this entity is Discount. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a discount. You can also call the IOrganizationService.Retrieve method.
DeleteRequest | Deletes a discount. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a discount. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of discounts. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a discount. You can also call the IOrganizationService.Update method.

See Also

Concepts

Discount entity privileges
DiscountType (discount list) entity messages and methods

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DiscountType (discount list) entity messages and methods

The discount list represents the type of discount specified as either a percentage or an amount.

The schema name for this entity is DiscountType. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a discount type (discount list). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a discount type (discount list). You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a discount type (discount list). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of discount types (discount lists). You can also use the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a discount type (discount list). If you are using early bound types, use the DiscountTypeState enumeration. For a list of the state values, refer to the DiscountType entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a discount type (discount list). You can also call the IOrganizationService.Update method.

See Also

Concepts

DiscountType entity (discount list) privileges
PriceLevel (price list) entity messages and methods

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UoM (unit) entity messages and methods

The unit of measure (unit) entity represents a unit of measure. The schema name for this entity is UoM. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a unit of measure. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a unit of measure. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a unit of measure. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of unit of measures. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a unit of measure. You can also call the IOrganizationService.UpdateRequest method.

See Also

Concepts

UoM (unit) entity privileges
UoMSchedule (unit group) entity messages and methods

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UoMSchedule (unit group) entity messages and methods

A unit of measure schedule (unit group) entity represents a grouping of units. The schema name for this entity is UoMSchedule. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a unit of measure schedule (unit group). You can also call theIOrganizationService.Create method.
DeleteRequest | Deletes a unit of measure schedule (unit group). You can also call theIOrganizationService.Delete method.
RetrieveRequest | Retrieves a unit of measure schedule (unit group). You can also call theIOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of unit of measure schedules (unit groups). You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a unit of measure schedule (unit group). If you are using early bound types, use the UoMScheduleState enumeration to set the possible states. For a list of the state values, refer to the UoMSchedule entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a unit of measure schedule (unit group). You can also call the IOrganizationService.UpdateRequest method.

See Also

Concepts

UoMSchedule (unit group) entity privileges

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create and publish products
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ProductCatalog\CreateAndPublishProducts.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create product family and child products, set product relationships, and publish product records.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to create and publish a product family
    /// and child products.
    /// </summary>
    public class CreateAndPublishProducts
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _unitGroupId;
        public Guid _product1Id;
        public Guid _product2Id;
        public Guid _productFamilyId;
        public Guid _priceListId;
        public Guid _priceListItem1Id;
        public Guid _priceListItem2Id;
        public Guid _productRelationId;
        public UoM _unit;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate creating all entity records that this sample requires.
        /// Create a product family with two child product records.
        /// Create a substitute relation between the two products.
        /// Publish the product family hierarchy, including the child records.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = ServerConnection.GetOrganizationProxy(serverConfig))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Create a product family
                    Product newProductFamily = new Product
                    {
                        Name = "Example Product Family",
                        ProductNumber = "PF001",
                        ProductStructure = new OptionSetValue(2)
                    };
                    _productFamilyId = _serviceProxy.Create(newProductFamily);
                    Console.WriteLine("\nCreated {0}", newProductFamily.Name);

                    // Create couple of product records under the product family
                    Product newProduct1 = new Product
                    {
                        Name = "Example Product 1",
                        ProductNumber = "P001",
                        ProductStructure = new OptionSetValue(1),
                        ParentProductId = new EntityReference(Product.EntityLogicalName, _productFamilyId),
                        QuantityDecimal = 2,
                        DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                        DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _unit.Id)
                    };
                    _product1Id = _serviceProxy.Create(newProduct1);

                    Console.WriteLine("Created {0} under the product family", newProduct1.Name);

                    Product newProduct2 = new Product
                    {
                        Name = "Example Product 2",
                        ProductNumber = "P002",
                        ProductStructure = new OptionSetValue(1),
                        ParentProductId = new EntityReference(Product.EntityLogicalName, _productFamilyId),
                        QuantityDecimal = 2,
                        DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                        DefaultUoMId = new EntityReference(UoM.EntityLogicalName, _unit.Id)
                    };
                    _product2Id = _serviceProxy.Create(newProduct2);

                    Console.WriteLine("Created {0} under the product family", newProduct2.Name);

                    // Create a price list items for the products
                    ProductPriceLevel newPriceListItem1 = new ProductPriceLevel
                    {
                        PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                        ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
                        UoMId = new EntityReference(UoM.EntityLogicalName, _unit.Id),
                        Amount = new Money(20)
                    };
                    _priceListItem1Id = _serviceProxy.Create(newPriceListItem1);

                    Console.WriteLine("Created price list for {0}", newProduct1.Name);

                    ProductPriceLevel newPriceListItem2 = new ProductPriceLevel
                    {
                        PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                        ProductId = new EntityReference(Product.EntityLogicalName, _product2Id),
                        UoMId = new EntityReference(UoM.EntityLogicalName, _unit.Id),
                        Amount = new Money(20)
                    };
                    _priceListItem2Id = _serviceProxy.Create(newPriceListItem2);

                    Console.WriteLine("Created price list for {0}", newProduct2.Name);

                    // Set the product relationship
                    // Set Example Product 1 and Example Product 2 as substitute of each other (bi-directional)
                    ProductSubstitute newProductRelation = new ProductSubstitute
                    {
                        SalesRelationshipType = new OptionSetValue(3),
                        Direction = new OptionSetValue(1),
                        ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
                        SubstitutedProductId = new EntityReference(Product.EntityLogicalName, _product2Id)
                    };
                    _productRelationId = _serviceProxy.Create(newProductRelation);

                    Console.WriteLine("Created a substitute relation between the two products.");

                    // Prompt the user whether to publish the product family and products
                    bool publishRecords = true;
                    Console.WriteLine("\nDo you want the product records published? (y/n)");
                    String answer = Console.ReadLine();
                    publishRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));

                    if (publishRecords)
                    {
                        PublishProductHierarchyRequest publishReq = new PublishProductHierarchyRequest
                        {
                            Target = new EntityReference(Product.EntityLogicalName, _productFamilyId)
                        };
                        PublishProductHierarchyResponse published = (PublishProductHierarchyResponse)_serviceProxy.Execute(publishReq);
                        if (published.Results != null)
                        {
                            Console.WriteLine("Published the product records");
                        }
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            catch
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a unit group and price list.
        /// </summary>
        public void CreateRequiredRecords()
        {
            Console.WriteLine("Creating required records for the sample:");
            // Create a unit group.
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };

            _unitGroupId = _serviceProxy.Create(newUnitGroup);

            Console.WriteLine("Created {0}", newUnitGroup.Name);

            // retrieve the unit id.
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression(),
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };
            unitQuery.Criteria.AddCondition("uomscheduleid", ConditionOperator.Equal, _unitGroupId);

            // Retrieve the unit.
            _unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];

            Console.WriteLine("Retrieved {0}", _unit.Name);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };
            _priceListId = _serviceProxy.Create(newPriceList);

            Console.WriteLine("Created {0}", newPriceList.Name);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();
                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                Console.WriteLine("Deleting entity records... please wait!");

                _serviceProxy.Delete(ProductSubstitute.EntityLogicalName, _productRelationId);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItem1Id);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItem2Id);
                _serviceProxy.Delete(Product.EntityLogicalName, _productFamilyId);
                _serviceProxy.Delete(PriceLevel.EntityLogicalName, _priceListId);
                _serviceProxy.Delete(UoMSchedule.EntityLogicalName, _unitGroupId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateAndPublishProducts app = new CreateAndPublishProducts();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main
    }
}

See Also

Concepts

Create and manage product families, products, and bundles
Publish, revise, revert, retire, and activate products (product lifecycle)

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Clone product records
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ProductCatalog\CloneProducts.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to clone a product record. More information: Clone a product family, product, or bundle

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to clone a product record.
    /// </summary>
    public class CloneProducts
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _unitGroupId;
        public Guid _productId;
        public Guid _productCloneId;
        public Guid _priceListId;
        public Guid _priceListItemId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate creating all entity records that this sample requires.
        /// Create a product record.
        /// Clone the product record.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = ServerConnection.GetOrganizationProxy(serverConfig))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    CloneProductRequest cloneReq = new CloneProductRequest
                    {
                        Source = new EntityReference(Product.EntityLogicalName, _productId)
                    };

                    CloneProductResponse cloned = (CloneProductResponse)_serviceProxy.Execute(cloneReq);
                    _productCloneId = cloned.ClonedProduct.Id;

                    // Retrieve the cloned product record
                    Product retrievedProduct = (Product)_serviceProxy.Retrieve(Product.EntityLogicalName, _productCloneId, new ColumnSet(true));
                    Console.WriteLine("\nCreated clone product: {0}", retrievedProduct.Name);

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            catch
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a unit group and price list.
        /// </summary>
        public void CreateRequiredRecords()
        {
            Console.WriteLine("Creating required records for the sample:");
            // Create a unit group.
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };

            _unitGroupId = _serviceProxy.Create(newUnitGroup);

            Console.WriteLine("Created {0}", newUnitGroup.Name);

            // retrieve the unit id.
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression(),
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };
            unitQuery.Criteria.AddCondition("uomscheduleid", ConditionOperator.Equal, _unitGroupId);

            // Retrieve the unit.
            UoM unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];

            Console.WriteLine("Retrieved {0}", unit.Name);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };
            _priceListId = _serviceProxy.Create(newPriceList);

            Console.WriteLine("Created {0}", newPriceList.Name);

            // Create a product record to be cloned.
            Product newProduct = new Product
            {
                Name = "Example Product",
                ProductNumber = "P001",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, unit.Id)
            };
            _productId = _serviceProxy.Create(newProduct);

            Console.WriteLine("\nCreated {0}", newProduct.Name);

            // Create a price list item for the product
            ProductPriceLevel newPriceListItem = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _productId),
                UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
                Amount = new Money(20)
            };
            _priceListItemId = _serviceProxy.Create(newPriceListItem);

            Console.WriteLine("Created price list for {0}", newProduct.Name);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();
                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                Console.WriteLine("Deleting entity records... please wait!");

                _serviceProxy.Delete(Product.EntityLogicalName, _productCloneId);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItemId);
                _serviceProxy.Delete(Product.EntityLogicalName, _productId);
                _serviceProxy.Delete(PriceLevel.EntityLogicalName, _priceListId);
                _serviceProxy.Delete(UoMSchedule.EntityLogicalName, _unitGroupId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CloneProducts app = new CloneProducts();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main
    }
}

See Also

Concepts

Create and manage product families, products, and bundles

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Add products to a bundle
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ProductCatalog\AddProductstoBundle.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to add products to a bundle. More information: Bundles and kits.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to add products to a bundle.
    /// </summary>
    public class AddProductstoBundle
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _unitGroupId;
        public Guid _product1Id;
        public Guid _product2Id;
        public Guid _bundleId;
        public Guid _priceListId;
        public Guid _priceListItem1Id;
        public Guid _priceListItem2Id;
        public Guid _priceListItem3Id;
        public Guid _product1AssociationId;
        public Guid _product2AssociationId;

        public UoM unit;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate creating all entity records that this sample requires.
        /// Create a bundle record.
        /// Add products to a bundle.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = ServerConnection.GetOrganizationProxy(serverConfig))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Add products to a bundle
                    ProductAssociation newAssociation1 = new ProductAssociation
                    {
                        AssociatedProduct = new EntityReference(Product.EntityLogicalName, _product1Id),
                        ProductId = new EntityReference(Product.EntityLogicalName, _bundleId),
                        Quantity = new decimal(15),
                        ProductIsRequired = new OptionSetValue(0), // Adding this as an optional product
                        UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id)
                    };
                    _product1AssociationId = _serviceProxy.Create(newAssociation1);

                    ProductAssociation newAssociation2 = new ProductAssociation
                    {
                        AssociatedProduct = new EntityReference(Product.EntityLogicalName, _product2Id),
                        ProductId = new EntityReference(Product.EntityLogicalName, _bundleId),
                        Quantity = new decimal(20),
                        ProductIsRequired = new OptionSetValue(1), // Adding this as a mandatory product
                        UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
                    };
                    _product2AssociationId = _serviceProxy.Create(newAssociation2);

                    // Verify if the product association is created
                    if ((_product1AssociationId != null) && (_product1AssociationId != null))
                    {
                        Console.WriteLine("\nAdded both the products to the bundle");
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            catch
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a unit group and price list.
        /// </summary>
        public void CreateRequiredRecords()
        {
            Console.WriteLine("Creating required records for the sample:");
            // Create a unit group.
            UoMSchedule newUnitGroup = new UoMSchedule
            {
                Name = "Example Unit Group",
                BaseUoMName = "Example Primary Unit"
            };

            _unitGroupId = _serviceProxy.Create(newUnitGroup);

            Console.WriteLine("Created {0}", newUnitGroup.Name);

            // retrieve the unit id.
            QueryExpression unitQuery = new QueryExpression
            {
                EntityName = UoM.EntityLogicalName,
                ColumnSet = new ColumnSet("uomid", "name"),
                Criteria = new FilterExpression(),
                PageInfo = new PagingInfo
                {
                    PageNumber = 1,
                    Count = 1
                }
            };
            unitQuery.Criteria.AddCondition("uomscheduleid", ConditionOperator.Equal, _unitGroupId);

            // Retrieve the unit.
             unit = (UoM)_serviceProxy.RetrieveMultiple(unitQuery).Entities[0];

            Console.WriteLine("Retrieved {0}", unit.Name);

            // Create a price list
            PriceLevel newPriceList = new PriceLevel
            {
                Name = "Example Price List"
            };
            _priceListId = _serviceProxy.Create(newPriceList);

            Console.WriteLine("Created {0}", newPriceList.Name);

            // Create couple of product records
            Product newProduct1 = new Product
            {
                Name = "Example Product 1",
                ProductNumber = "P001",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, unit.Id)
            };
            _product1Id = _serviceProxy.Create(newProduct1);

            Console.WriteLine("\nCreated {0}", newProduct1.Name);

            Product newProduct2 = new Product
            {
                Name = "Example Product 2",
                ProductNumber = "P002",
                ProductStructure = new OptionSetValue(1),
                QuantityDecimal = 2,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, unit.Id)
            };
            _product2Id = _serviceProxy.Create(newProduct2);

            Console.WriteLine("Created {0}", newProduct2.Name);

            // Create price list items for the products
            ProductPriceLevel newPriceListItem1 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product1Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
                Amount = new Money(20)
            };
            _priceListItem1Id = _serviceProxy.Create(newPriceListItem1);
            Console.WriteLine("Created price list for {0}", newProduct1.Name);

            ProductPriceLevel newPriceListItem2 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _product2Id),
                UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
                Amount = new Money(20)
            };
            _priceListItem2Id = _serviceProxy.Create(newPriceListItem2);
            Console.WriteLine("Created price list for {0}", newProduct2.Name);

            Product newBundle = new Product
            {
                Name = "Example Bundle",
                ProductNumber = "B001",
                ProductStructure = new OptionSetValue(3),
                QuantityDecimal = 0,
                DefaultUoMScheduleId = new EntityReference(UoMSchedule.EntityLogicalName, _unitGroupId),
                DefaultUoMId = new EntityReference(UoM.EntityLogicalName, unit.Id)
            };
            _bundleId = _serviceProxy.Create(newBundle);
            Console.WriteLine("\nCreated {0}", newBundle.Name);

            // Create price list item for the bundle
            ProductPriceLevel newPriceListItem3 = new ProductPriceLevel
            {
                PriceLevelId = new EntityReference(PriceLevel.EntityLogicalName, _priceListId),
                ProductId = new EntityReference(Product.EntityLogicalName, _bundleId),
                UoMId = new EntityReference(UoM.EntityLogicalName, unit.Id),
                Amount = new Money(200)
            };
            _priceListItem3Id = _serviceProxy.Create(newPriceListItem3);
            Console.WriteLine("Created price list for {0}", newBundle.Name);
            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();
                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                Console.WriteLine("Deleting entity records... please wait!");

                _serviceProxy.Delete(ProductAssociation.EntityLogicalName, _product1AssociationId);
                _serviceProxy.Delete(ProductAssociation.EntityLogicalName, _product2AssociationId);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItem1Id);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItem2Id);
                _serviceProxy.Delete(ProductPriceLevel.EntityLogicalName, _priceListItem3Id);
                _serviceProxy.Delete(Product.EntityLogicalName, _bundleId);
                _serviceProxy.Delete(Product.EntityLogicalName, _product1Id);
                _serviceProxy.Delete(Product.EntityLogicalName, _product2Id);
                _serviceProxy.Delete(PriceLevel.EntityLogicalName, _priceListId);
                _serviceProxy.Delete(UoMSchedule.EntityLogicalName, _unitGroupId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                AddProductstoBundle app = new AddProductstoBundle();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main
    }
}

See Also

Concepts

Create and manage product families, products, and bundles

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Calculate Price plug-in
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ProductCatalog\CustomPricePlug-in\CalculatePricePlugin.cs

Requirements

Ensure the following:

  • Set the value of the Organization.OOBPriceCalculationEnabled attribute to 0 (false).
  • Register the plug-in on the CalculatePrice message, Post-operation event stage, and Synchronous execution mode. For more information, see Register and Deploy Plug-Ins.

Demonstrates

This sample shows how to write a plug-in that calculates the pricing of the opportunities, quotes, orders, and invoices based on your custom code. The discounts and taxes are calculated based on the total amount of all the product line items in an opportunity, quote, order, or invoice:

  • Discount: If the total amount is greater than 1000 and less than 5000, discount is 5%; if the total amount is 5000 or greater, discount is 10%.
  • Tax: Tax is applied on the amount that is effective after the discount is applied (total amount minus discount). If the effective amount is less than 5000, tax is 10%; otherwise, tax is 8%.

For more information, see Use custom pricing for products.

Example

C# Copy Code
using System;
using System.ServiceModel;

// Microsoft Dynamics CRM namespace(s)
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    public class CalculatePricePlugin : IPlugin
    {
        /// <summary>
        /// A plugin that calculates custom pricing for
        /// opportunities, quotes, orders, and invoices.
        /// </summary>
        /// <remarks>Register this plug-in on the CalculatePrice message,
        /// Post Operation execution stage, and Synchronous execution mode.
        /// </remarks>
        public void Execute(IServiceProvider serviceProvider)
        {
            //Extract the tracing service for use in debugging sandboxed plug-ins.
            ITracingService tracingService =
                (ITracingService)serviceProvider.GetService(typeof(ITracingService));

            // Obtain the execution context from the service provider.
            IPluginExecutionContext context = (IPluginExecutionContext)
                serviceProvider.GetService(typeof(IPluginExecutionContext));

            if (context.ParentContext != null
                && context.ParentContext.ParentContext != null
                && context.ParentContext.ParentContext != null
                && context.ParentContext.ParentContext.ParentContext.SharedVariables.ContainsKey("CustomPrice")
                && (bool)context.ParentContext.ParentContext.ParentContext.SharedVariables["CustomPrice"])
                return;

            // The InputParameters collection contains all the data passed in the message request.
            if (context.InputParameters.Contains("Target") &&
                context.InputParameters["Target"] is EntityReference)
            {
                // Obtain the target entity from the input parmameters.
                EntityReference entity = (EntityReference)context.InputParameters["Target"];

                // Verify that the target entity represents an appropriate entity.
                if (CheckIfNotValidEntity(entity))
                    return;

                try
                {
                    context.SharedVariables.Add("CustomPrice", true);
                    context.ParentContext.SharedVariables.Add("CustomPrice", true);
                    IOrganizationServiceFactory serviceFactory = (IOrganizationServiceFactory)serviceProvider.GetService(typeof(IOrganizationServiceFactory));
                    IOrganizationService service = serviceFactory.CreateOrganizationService(context.UserId);

                    // Calculate pricing depending on the target entity
                    switch (entity.LogicalName)
                    {
                        case "opportunity":
                            CalculateOpportunity(entity, service);
                            return;

                        case "quote":
                            CalculateQuote(entity, service);
                            return;

                        case "salesorder":
                            CalculateOrder(entity, service);
                            return;

                        case "invoice":
                            CalculateInvoice(entity, service);
                            return;

                        case "opportunityproduct":
                            CalculateOpportunityProduct(entity, service);
                            return;

                        case "quotedetail":
                            CalculateQuoteProduct(entity, service);
                            return;

                        case "salesorderdetail":
                            CalculateOrderProduct(entity, service);
                            return;

                        case "invoicedetail":
                            CalculateInvoiceProduct(entity, service);
                            return;

                        default:
                            return;
                    }
                }

                catch (FaultException<OrganizationServiceFault> ex)
                {
                    tracingService.Trace("CalculatePrice: {0}", ex.ToString());
                    throw new InvalidPluginExecutionException("An error occurred in the Calculate Price plug-in.", ex);
                }

                catch (Exception ex)
                {
                    tracingService.Trace("CalculatePrice: {0}", ex.ToString());
                    throw;
                }
            }
        }

        private static bool CheckIfNotValidEntity(EntityReference entity)
        {
            switch (entity.LogicalName)
            {
                case "opportunity":
                case "quote":
                case "salesorder":
                case "invoice":
                case "opportunityproduct":
                case "invoicedetail":
                case "quotedetail":
                case "salesorderdetail":
                    return false;

                default:
                    return true;
            }
        }

        #region Calculate Opportunity Price
        // Method to calculate price in an opportunity
        private static void CalculateOpportunity(EntityReference entity, IOrganizationService service)
        {
            Entity e = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("statecode"));
            OptionSetValue statecode = (OptionSetValue)e["statecode"];
            if (statecode.Value == 0)
            {
                ColumnSet columns = new ColumnSet();
                columns.AddColumns("totaltax", "totallineitemamount", "totalamountlessfreight", "discountamount");
                Entity opp = service.Retrieve(entity.LogicalName, entity.Id, columns);

                QueryExpression query = new QueryExpression("opportunityproduct");
                query.ColumnSet.AddColumns("quantity", "priceperunit");
                query.Criteria.AddCondition("opportunityid", ConditionOperator.Equal, entity.Id);
                EntityCollection ec = service.RetrieveMultiple(query);
                opp["totallineitemamount"] = 0;

                decimal total = 0;
                decimal discount = 0;
                decimal tax = 0;

                for (int i = 0; i < ec.Entities.Count; i++)
                {
                    total = total + ((decimal)ec.Entities[i]["quantity"] * ((Money)ec.Entities[i]["priceperunit"]).Value);
                    (ec.Entities[i])["extendedamount"] = new Money(((decimal)ec.Entities[i]["quantity"] * ((Money)ec.Entities[i]["priceperunit"]).Value));
                    service.Update(ec.Entities[i]);
                }

                opp["totallineitemamount"] = new Money(total);

                // Calculate discount based on the total amount
                discount = CalculateDiscount(total);
                total = total - discount;
                opp["discountamount"] = new Money(discount);
                opp["totalamountlessfreight"] = new Money(total);
                service.Update(opp);

                // Calculate tax after the discount is applied
                tax = CalculateTax(total);
                total = total + tax;
                opp["totaltax"] = new Money(tax);
                opp["totalamount"] = new Money(total);
                opp["estimatedvalue"] = new Money(total);
                service.Update(opp);
            }
            return;
        }

        // Method to calculate extended amount in the product line items in an opportunity
        private static void CalculateOpportunityProduct(EntityReference entity, IOrganizationService service)
        {
            try
            {
                ColumnSet columns = new ColumnSet();
                Entity e = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("quantity", "priceperunit"));
                decimal total = 0;
                total = total + ((decimal)e["quantity"] * ((Money)e["priceperunit"]).Value);
                e["extendedamount"] = new Money(total);
                service.Update(e);
            }
            catch (FaultException<OrganizationServiceFault> ex)
            {
                System.Diagnostics.Debug.Write(ex.Message);
            }
        }

        #endregion

        #region Calculate Quote Price
        // Method to calculate price in a quote
        private static void CalculateQuote(EntityReference entity, IOrganizationService service)
        {
            Entity e = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("statecode"));
            OptionSetValue statecode = (OptionSetValue)e["statecode"];
            if (statecode.Value == 0)
            {
                ColumnSet columns = new ColumnSet();
                columns.AddColumns("totaltax", "totallineitemamount", "totalamountlessfreight", "discountamount");
                Entity quote = service.Retrieve(entity.LogicalName, entity.Id, columns);

                QueryExpression query = new QueryExpression("quotedetail");
                query.ColumnSet.AddColumns("quantity", "priceperunit");
                query.Criteria.AddCondition("quoteid", ConditionOperator.Equal, entity.Id);
                EntityCollection ec = service.RetrieveMultiple(query);
                quote["totallineitemamount"] = 0;

                decimal total = 0;
                decimal discount = 0;
                decimal tax = 0;

                for (int i = 0; i < ec.Entities.Count; i++)
                {
                    total = total + ((decimal)ec.Entities[i]["quantity"] * ((Money)ec.Entities[i]["priceperunit"]).Value);
                    (ec.Entities[i])["extendedamount"] = new Money(((decimal)ec.Entities[i]["quantity"] * ((Money)ec.Entities[i]["priceperunit"]).Value));
                    service.Update(ec.Entities[i]);
                }

                quote["totallineitemamount"] = new Money(total);

                // Calculate discount based on the total amount
                discount = CalculateDiscount(total);
                total = total - discount;
                quote["discountamount"] = new Money(discount);
                quote["totalamountlessfreight"] = new Money(total);
                service.Update(quote);

                // Calculate tax after the discount is applied
                tax = CalculateTax(total);
                total = total + tax;
                quote["totaltax"] = new Money(tax);
                quote["totalamount"] = new Money(total);
                service.Update(quote);
            }
            return;
        }

        // Method to calculate extended amount in the product line items in a quote
        private static void CalculateQuoteProduct(EntityReference entity, IOrganizationService service)
        {
            try
            {
                ColumnSet columns = new ColumnSet();
                Entity e = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("quantity", "priceperunit"));
                decimal total = 0;
                total = total + ((decimal)e["quantity"] * ((Money)e["priceperunit"]).Value);
                e["extendedamount"] = new Money(total);
                service.Update(e);
            }
            catch (FaultException<OrganizationServiceFault> ex)
            {
                System.Diagnostics.Debug.Write(ex.Message);
            }
        }

        #endregion

        #region Calculate Order Price
        // Method to calculate price in an order
        private static void CalculateOrder(EntityReference entity, IOrganizationService service)
        {
            Entity e = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("statecode"));
            OptionSetValue statecode = (OptionSetValue)e["statecode"];
            if (statecode.Value == 0)
            {
                ColumnSet columns = new ColumnSet();
                columns.AddColumns("totaltax", "totallineitemamount", "totalamountlessfreight", "discountamount");
                Entity order = service.Retrieve(entity.LogicalName, entity.Id, columns);

                QueryExpression query = new QueryExpression("salesorderdetail");
                query.ColumnSet.AddColumns("quantity", "salesorderispricelocked", "priceperunit");
                query.Criteria.AddCondition("salesorderid", ConditionOperator.Equal, entity.Id);

                QueryExpression query1 = new QueryExpression("salesorderdetail");
                query1.ColumnSet.AddColumns("salesorderispricelocked");
                query1.Criteria.AddCondition("salesorderid", ConditionOperator.Equal, entity.Id);

                EntityCollection ec = service.RetrieveMultiple(query);
                EntityCollection ec1 = service.RetrieveMultiple(query1);
                order["totallineitemamount"] = 0;

                decimal total = 0;
                decimal discount = 0;
                decimal tax = 0;

                for (int i = 0; i < ec.Entities.Count; i++)
                {
                    total = total + ((decimal)ec.Entities[i]["quantity"] * ((Money)ec.Entities[i]["priceperunit"]).Value);
                    (ec1.Entities[i])["extendedamount"] = new Money(((decimal)ec.Entities[i]["quantity"] * ((Money)ec.Entities[i]["priceperunit"]).Value));
                    service.Update(ec1.Entities[i]);
                }

                order["totallineitemamount"] = new Money(total);

                // Calculate discount based on the total amount
                discount = CalculateDiscount(total);
                total = total - discount;
                order["discountamount"] = new Money(discount);
                order["totalamountlessfreight"] = new Money(total);
                service.Update(order);

                // Calculate tax after the discount is applied
                tax = CalculateTax(total);
                total = total + tax;
                order["totaltax"] = new Money(tax);
                order["totalamount"] = new Money(total);
                service.Update(order);
            }
            return;
        }

        // Method to calculate extended amount in the product line items in a order
        private static void CalculateOrderProduct(EntityReference entity, IOrganizationService service)
        {
            try
            {
                ColumnSet columns = new ColumnSet();
                Entity e = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("quantity", "priceperunit", "salesorderispricelocked"));
                Entity e1 = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("quantity", "salesorderispricelocked"));
                decimal total = 0;
                total = total + ((decimal)e["quantity"] * ((Money)e["priceperunit"]).Value);
                e1["extendedamount"] = new Money(total);
                service.Update(e1);
            }
            catch (FaultException<OrganizationServiceFault> ex)
            {
                System.Diagnostics.Debug.Write(ex.Message);
            }
        }

        #endregion

        #region Calculate Invoice Price
        // Method to calculate price in an invoice
        private static void CalculateInvoice(EntityReference entity, IOrganizationService service)
        {
            Entity e = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("statecode"));
            OptionSetValue statecode = (OptionSetValue)e["statecode"];
            if (statecode.Value == 0)
            {
                ColumnSet columns = new ColumnSet();
                columns.AddColumns("totaltax", "totallineitemamount", "totalamountlessfreight", "discountamount");

                Entity invoice = service.Retrieve(entity.LogicalName, entity.Id, columns);

                QueryExpression query = new QueryExpression("invoicedetail");
                query.ColumnSet.AddColumns("quantity", "invoiceispricelocked", "priceperunit");
                query.Criteria.AddCondition("invoiceid", ConditionOperator.Equal, entity.Id);

                QueryExpression query1 = new QueryExpression("invoicedetail");
                query1.ColumnSet.AddColumns("quantity", "invoiceispricelocked");
                query1.Criteria.AddCondition("invoiceid", ConditionOperator.Equal, entity.Id);

                EntityCollection ec = service.RetrieveMultiple(query);
                EntityCollection ec1 = service.RetrieveMultiple(query1);

                invoice["totallineitemamount"] = 0;

                decimal total = 0;
                decimal discount = 0;
                decimal tax = 0;

                for (int i = 0; i < ec.Entities.Count; i++)
                {
                    total = total + ((decimal)ec.Entities[i]["quantity"] * ((Money)ec.Entities[i]["priceperunit"]).Value);
                    (ec1.Entities[i])["extendedamount"] = new Money(((decimal)ec.Entities[i]["quantity"] * ((Money)ec.Entities[i]["priceperunit"]).Value));
                    service.Update(ec1.Entities[i]);
                }

                invoice["totallineitemamount"] = new Money(total);

                // Calculate discount based on the total amount
                discount = CalculateDiscount(total);
                total = total - discount;
                invoice["discountamount"] = new Money(discount);
                invoice["totalamountlessfreight"] = new Money(total);
                service.Update(invoice);

                // Calculate tax after the discount is applied
                tax = CalculateTax(total);
                total = total + tax;
                invoice["totaltax"] = new Money(tax);
                invoice["totalamount"] = new Money(total);
                service.Update(invoice);
            }
            return;
        }

        // Method to calculate extended amount in the product line items in an invoice
        private static void CalculateInvoiceProduct(EntityReference entity, IOrganizationService service)
        {
            try
            {
                ColumnSet columns = new ColumnSet();
                Entity e = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("quantity", "priceperunit", "invoiceispricelocked"));
                Entity e1 = service.Retrieve(entity.LogicalName, entity.Id, new ColumnSet("quantity", "invoiceispricelocked"));
                decimal total = 0;
                total = total + ((decimal)e["quantity"] * ((Money)e["priceperunit"]).Value);
                e1["extendedamount"] = new Money(total);
                service.Update(e1);
            }
            catch (FaultException<OrganizationServiceFault> ex)
            {
                System.Diagnostics.Debug.Write(ex.Message);
            }
        }

        #endregion

        // Method to calculate discount.
        private static decimal CalculateDiscount(decimal amount)
        {
            decimal discount = 0;

            if (amount > (decimal)1000.00 && amount < (decimal)5000.00)
            {
                discount = amount * (decimal)0.05;
            }
            else if (amount >= (decimal)5000.00)
            {
                discount = amount * (decimal)0.10;
            }
            return discount;
        }

        // Method to calculate tax.
        private static decimal CalculateTax(decimal amount)
        {
            decimal tax = 0;
            if (amount < (decimal)5000.00)
            {
                tax = amount * (decimal)0.10;
            }
            else
            {
                tax = amount * (decimal)0.08;
            }
            return tax;
        }
    }
}

See Also

Concepts

Use custom pricing for products
Create and manage product families, products, and bundles

Other Resources

Product catalog entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sales literature entities

A sales literature item is the basic unit of the marketing encyclopedia in Microsoft Dynamics CRM. For example, a business unit might decide to create an article about a specific product. The article can contain multiple sales literature items (sales attachments) such as a brochure, detailed specifications, and a CAD file, together with appropriate search terms, for example, "bolt" or "stainless steel." Any PC-compatible file format can be uploaded and attached to an article in the marketing encyclopedia. Specific search terms can be specified for each item.

You can use the sales literature management entities to create a central repository for your organization’s sales information (in the form of sales literature items (sales attachments)) that provides an easy way to distribute information to users, both online and offline. Sales literature can be organized into categories and types to provide easier management and searching. Microsoft Dynamics CRM also supports a subject manager and knowledge base.

A sales literature record can have one or more sales literature items (sales attachments) attached to it in various formats, such as .doc, .pub, and .pdf. An item cannot be shared between sales literature records.

Sales literature records can also be attached to competitors and products (both yours and your competitors').

The basic operations supported in the marketing encyclopedia include the following:

  • Create a sales literature item
  • View a sales literature item
  • Edit a sales literature item
  • Delete a sales literature item
  • Search for a sales literature item
  • Upload an attachment and attach it to a sales literature item

You can create a searchable marketing encyclopedia for storing various sales and marketing literature. As an example, a sales literature library might include the following:

  • Product information
  • Presentations and brochures
  • Policies and procedures
  • Sales literature
  • White papers
  • Competitive information
  • Price lists
  • Annual reports
  • Manuals

In This Section

SalesLiterature entity messages and methods

SalesLiteratureItem (sales attachment) entity messages and methods

Related Sections

Model your business data

Schedule and appointment entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SalesLiterature entity messages and methods

The sales literature entity represents a collection of sales literature, which may contain one or more sales literature items (sales attachments). The schema name for this entity is SalesLiterature. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the SalesLiterature entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a sales literature record. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a sales literature record. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the SalesLiterature entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RemoveRelatedRequest | Deprecated. Removes the link between a sales literature record and a product or competitor. Use DisassociateRequest or IOrganizationService.Disassociate instead.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a sales literature record. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of sales literature records. You can also call the IOrganizationService.RetrieveMultiple method.
SetRelatedRequest | Deprecated. Creates a link between a sales literature record and a product or competitor. Use AssociateRequest or IOrganizationService.Associate instead.
UpdateRequest | Updates a sales literature record. You can also call the IOrganizationService.Update method.

See Also

Concepts

SalesLiterature entity privileges
SalesLiteratureItem (sales attachment) entity messages and methods

Other Resources

Sales literature entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SalesLiteratureItem (sales attachment) entity messages and methods

The sales literature item (sales attachment) entity contains the attachment for an item in the sales literature collection. The schema name for this entity is SalesLiteratureItem. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a sales literature item (sales attachment). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a sales literature item (sales attachment). You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a sales literature item (sales attachment). You can also call the IOrganizationService.Retrieve method
RetrieveMultipleRequest | Retrieves a collection of sales literature items (sales attachments). You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a sales literature item (sales attachment). You can also call the IOrganizationService.Update method.

See Also

Concepts

SalesLiteratureItem (sales attachment) entity privileges

Other Resources

Sales literature entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Schedule and appointment entities

Microsoft Dynamics CRM provides capabilities to address appointment-based service scheduling. You can define services, resources and work schedules, and service locations. A scheduling engine manages booked appointments and service availability, and can be tuned to optimize scheduling to reduce costs and required resources.

The entity model for the scheduling engine includes a core set of entities: Service, Resource, Calendar and Site. Other entities describe resource requirements, constraints, calendar rules, and a schedule.

The following messages can be used for scheduling appointments, recurring appointments, and service appointments (service activity).

Message | Description
BookRequest | Creates an appointment, recurring appointment, or service appointment (service activity), and calls the scheduling engine to make sure that it is valid for all constraints without any scheduling conflicts.
RescheduleRequest | Reschedules an appointment, recurring appointment, or service appointment (service activity), and calls the scheduling engine to make sure that it is valid for all constraints without any scheduling conflicts.

In This Section

Appointment entities

Recurring appointment entities

Calendar entities

Resource entities

Service entity

Sample code for schedule and appointment Entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Appointment entities

An appointment is a commitment that represents a time interval with start and end times and duration. The schema name for this entity is Appointment. A service appointment represents an appointment for service. The schema name for this entity is ServiceAppointment. A service appointment can be customized independently from other activities to accommodate the customer's business requirements for service delivery. Service appointments can block the availability of required resources and participate in resource availability searches and scheduling. A service appointment must have a corresponding service. It can be already bound with a set of resources specified by an activity party (ActivityParty) list.

To create an appointment by making sure that the constraints are met, use the BookRequest message or the RescheduleRequest message. The scheduling engine stores the booked appointment and adjusts the free/busy information for the resource. You can create an appointment at a specific time for a specific service that uses a specific set of resources, ignoring all constraints, by using the IOrganizationService.Create method or CreateRequest message.

Appointments can block the availability of the required resources. Appointments can be blocking, specified as part of the service definition or per appointment instance, for other appointments at the same interval.

In This Section

Schedule and appointment entities

Schedules in Microsoft Dynamics CRM

Appointment entity messages and methods

ServiceAppointment entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Schedules in Microsoft Dynamics CRM

A schedule is a logical collection of appointments that contains the availability and assignments of a given resource. It is a logical collection of appointments with a scheduling interface. There is no schedule entity in the Microsoft Dynamics CRM SDK. Instead, the service, resource specification, user, and equipment entities support the scheduling engine when booking appointments and service appointments. By using schedule messages, you can look for free or busy information, search for appointments, and book a specific appointment for a service and a set of resources.

Appointments stored in schedules are related to the owner of the schedule. It is only possible to ask the schedule for free or busy times within a given time period. The result of the operation is a collection of time blocks (appointments) that correspond to available or reserved time. You can create a schedule that represents the availability of a set of resources or even a set of activities or some arbitrary subset of service availability. To retrieve a schedule collection, use the retrieve messages listed in the following table.

The scheduling engine must know when changes are made to several different entities in Microsoft Dynamics CRM. When changes are made, Microsoft Dynamics CRM automatically schedules an asynchronous system job to publish the changes. This occurs five minutes after the change, whether the change occurs through the user interface or through Web service methods.

Supported messages

The following messages can be used with the IOrganizationService.Execute method to query a schedule.

Message | Description
QueryScheduleRequest | Retrieves the content (existing commitments) of the schedule for a given entity. Use this message to search the specified resources for an available time slot that matches the specified parameters. The message is available on all schedulable entities.
QueryMultipleSchedulesRequest | Searches multiple resources for an available time slot that matches the specified parameters.
SearchRequest | Searches for available time slots and returns a set of available Appointment instances (as time blocks). The message is available on the Resource entity or the Service entity.

See Also

Concepts

Appointment entity messages and methods

Other Resources

Schedule and appointment entities
Sample: Search for openings to schedule a resource
Appointment entities
Sample: Query the working hours of a user
Sample: Query the working hours of multiple users

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Appointment entity messages and methods

The appointment entity represents a block of time on a calendar. This includes blocking of the availability for included resources. The schema name for this entity is Appointment. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddRecurrenceRequest | Adds recurrence information to an existing appointment to make it a recurring appointment master.
AssignRequest | Assigns an appointment to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Appointment entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
BookRequest | Schedules or books an appointment.
CreateRequest | Creates an appointment. You can also call the IOrganizationService.Create method.
CreateExceptionRequest | Creates an exception for the recurring appointment instance Appointment.InstanceTypeCode. For more information, see Create a Recurring Appointment Exception.
DeleteRequest | Deletes an appointment. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the Appointment entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares an appointment with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for an appointment previously shared with another security principal (user or team).
RescheduleRequest | Reschedules an appointment.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves an appointment. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of appointments. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to an appointment.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to an appointment, and also retrieves their access rights to the appointment.
RevokeAccessRequest | Removes all access to an appointment for the specified security principal (user or team).
SetStateRequest | Sets the state of an appointment. The possible values for this attribute are defined in the Appointment.State attribute. If you are using early bound types, you can use the AppointmentState enumeration. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an appointment. You can also call the Update method.
ValidateRequest | Validates that all the constraints of an appointment are met.

See Also

Reference

Appointment entity privileges

Concepts

ServiceAppointment entity messages and methods

Other Resources

Appointment entities
Recurring appointment entities
Schedule and appointment entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ServiceAppointment entity messages and methods

The service appointment entity represents a block of time on a calendar. This entity stores the availability blocks for resources and can be used to determine resource availability and scheduling. The schema name for this entity is ServiceAppointment. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a service appointment to another user or team.
BookRequest | Schedules or books a service appointment.
CreateRequest | Creates a service appointment. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a service appointment. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a service appointment with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a service appointment previously shared with another security principal (user or team).
RescheduleRequest | Reschedules a service appointment.
RetrieveRequest | Retrieves a service appointment. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of service appointments. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a service appointment.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a service appointment, together with their access rights to the service appointment.
RevokeAccessRequest | Removes all access to a service appointment for the specified security principal (user or team).
SearchRequest | Searches for available time slots that fulfill the specified appointment request.
SetStateRequest | Sets the state of a service appointment. The possible values for this attribute are defined in the ServiceAppointment.State attribute.If you are using early bound types, you can use the ServiceAppointmentState enumeration. For a list of states, ServiceAppointment entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a service appointment. You can also call the IOrganizationService.Update method.
ValidateRequest | Validates that all the constraints of a service appointment are met.

See Also

Concepts

ServiceAppointment (service activity) entity privileges

Other Resources

Appointment entities
Schedule and appointment entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Recurring appointment entities

Recurring appointments occur more than once, and follow an occurrence pattern. For example, you can set up an appointment to discuss a project status that occurs every week on Friday. Recurring appointments provide the ability to add recurrence information (occurrence pattern) to a new or an existing appointment in Microsoft Dynamics CRM.

In This Section

Recurring appointment partial expansion model

Create a recurring appointment series, instance, or exception

Update a recurring appointment

Delete or end a recurring appointment series or instance

Link custom attributes of the recurring appointment master (series) and appointment entities

RecurringAppointmentMaster entity messages and methods

RecurrenceRule entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Recurring appointment partial expansion model

Microsoft Dynamics CRM implements a partial expansion model to create recurring appointment instances in the database. The recurrence information, specified when you create a RecurringAppointmentMaster record, is used to create or synchronize individual instances in a phased manner. This controls the creation of a large number of appointment records in Microsoft Dynamics CRM due to the creation or synchronization of recurring appointments that have a large or infinite (no end date) recurrence range.

The partial expansion model is an asynchronous job in Microsoft Dynamics CRM that runs at pre-specified intervals, and is defined at the organization level using the Organization.RecurrenceExpansionJobBatchInterval attribute. Moreover, the instance expansion model depends on an organization-level parameter, for example, “N,” where “N” stands for the maximum number of instances that can be created synchronously. You can specify an appropriate value for this variable using the Organization.RecurrenceExpansionSynchCreateMax attribute. These properties are covered in detail in the Parameters for the partial expansion job section later.

In This Topic

When the recurring appointment instances are less than or equal to “N”

When the recurring appointment instances are more than “N”

Parameters for the partial expansion job

When the recurring appointment instances are less than or equal to “N”

If the number of instances to be generated because of the recurrence information is less than or equal to “N”, the actual number of instances are created synchronously from the effective start date of the appointment. Each instance is stored as an appointment record in Microsoft Dynamics CRM.

When the recurring appointment instances are more than “N”

For each recurring appointment created in Microsoft Dynamics CRM, an asynchronous expansion job is created. The instances of the recurring appointment are expanded in the following phases:

  1. Synchronous expansion: The first “N” instances of the recurring appointment are created synchronously from the effective start date. Each instance is stored as an appointment record with the Appointment.InstanceTypeCode attribute set to “2” (Recurring Instance). The expansion of the rest of the instances is passed on to an asynchronous job. The effective start date is the date from which the recurring appointment series has to be expanded.
  2. Asynchronous expansion: Asynchronous jobs handle the rest of the expansion job and periodically expand the instances according to the recurrence information. The asynchronous expansion occurs only until the future expansion window (Organization.FutureExpansionWindow). After that, a new asynchronous job is created that handles expansion until the next future expansion window. The asynchronous service periodically expands the instances and stores them as appointment records in the system.

Parameters for the partial expansion job

You must set appropriate values for these organization-level attributes in the Organization record for the expansion model to work as per your requirements. You must have the System Administrator role or appropriate privilege to do this. The following table provides information about these properties.

Attribute Description

Organization.RecurrenceExpansionSynchCreateMax

This is the maximum number of appointment instances that is created at the time of creation or synchronization of a recurring appointment. You must specify an integer value that corresponds to the number of instances. This value corresponds to “N”.

Organization.PastExpansionWindow

This is the maximum valid time period in the past up to which the recurring appointments can be expanded or synchronized with Microsoft Dynamics CRM for Microsoft Office Outlook. You must specify an integer value that corresponds to the number of months.

The value of this attribute determines the past instance cutoff date for expanding or synchronizing the recurring appointment instances.

Organization.FutureExpansionWindow

This is the maximum valid time period in the future up to which the recurring appointments can be expanded or synchronized with CRM for Outlook. You must specify an integer value that corresponds to the number of months.

The value of this attribute determines the future instance cutoff date for expanding or synchronizing the recurring appointment instances.

Organization.RecurrenceExpansionJobBatchInterval

This is the frequency in seconds after which the partial expansion job is triggered.

Organization.RecurrenceExpansionJobBatchSize

This is the number of instances expanded every time the asynchronous job runs.

See Also

Concepts

Create a recurring appointment series, instance, or exception
Delete or end a recurring appointment series or instance
Update a recurring appointment

Other Resources

Recurring appointment entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create a recurring appointment series, instance, or exception

When you create a recurring appointment master (series), Microsoft Dynamics CRM creates individual appointment instances based on the specified recurrence information. You can also create individual recurring appointment instances and exceptions to those instances, and you can convert an appointment to a recurring appointment.

In This Topic

Create a recurring appointment series

Create a recurring appointment instance

Create a recurring appointment exception

Convert an appointment to a recurring appointment

Create a recurring appointment series

To create a recurring appointment series (a RecurringAppointmentMaster record), you can use the BookRequest message, the CreateRequest message, or the IOrganizationService.Create method.

When you create a recurring appointment series, the following things occur:

  1. A RecurringAppointmentMaster record (recurring appointment series) is created that contains the basic and recurrence information about the recurring appointment series. Each record can be uniquely identified using the RecurringAppointmentMaster.ActivityId property. Further, this recurring appointment series is also created and stored as an activity (ActivityPointer) record. The activity record can be uniquely identified using the ActivityPointer.ActivityId property.
  2. Individual recurring appointment instances are created based on the recurrence information and stored as Appointment records. These appointment objects are associated with the parent recurring appointment series using the Appointment.SeriesId property and have the same value as the parent recurring appointment series ID (ActivityPointer.SeriesId).
    The value of the Appointment.InstanceTypeCode property is set to Recurring Instance (picklist value 2) for these appointment objects.

    Note
    Recurring appointment instances are created based on the expansion model and the parameters that define it. More information: Recurring appointment partial expansion model.

For sample code that demonstrates how to create a recurring appointment series, see Sample: Create, retrieve, update, and delete a recurring appointment.

Create a recurring appointment instance

To create a recurring appointment instance (a RecurringAppointmentMaster record), you can use the CreateInstanceRequest. This message takes two parameters: the number of instances to be created and the recurring appointment series for which the instances have to be created.

The instances are created after the last instance in the recurring appointment series. Also, the instances are only created up until the future instance cutoff date, regardless of the number of instances you have specified for creation.

Create a recurring appointment exception

An exception is created when you either update or delete an instance of the recurring appointment. Recurring appointment instances are stored as an appointment record along like other appointments, and you can identify a recurring appointment instance using the Appointment.InstanceTypeCode attribute of an appointment record, which will have a value of Recurring Instance (picklist value 2).

You can create exceptions in the following ways:

  • Use the UpdateRequest class on the Appointment entity to update a recurring appointment instance, and set the value of the Appointment.InstanceTypeCode attribute to Recurring Exception (picklist value 3).
  • Use the DeleteRequest class on the Appointment entity to delete a recurring appointment instance. Deleting an appointment instance marks it an exception by creating an entry for the instance in the RecurringAppointmentMaster.DeletedExceptionsList attribute for the parent appointment series object.
  • Use the CreateExceptionRequest class on the Appointment entity.

Convert an appointment to a recurring appointment

A recurring appointment is an appointment with recurrence information. You can convert an existing appointment in Microsoft Dynamics CRM to a recurring appointment by using AddRecurrenceRequest. When you convert an existing appointment to a recurring appointment, the data from the existing appointment is copied to a new recurring appointment master instance and the existing appointment is deleted.

See Also

Concepts

Update a recurring appointment

Other Resources

Recurring appointment entities
Sample: Create, retrieve, update, and delete a recurring appointment
Sample: Convert an appointment to a recurring appointment

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Update a recurring appointment

You can either update the whole series or update an instance of a recurring appointment.

Update a recurring appointment series

You can update a recurring appointment series by using the IOrganizationService.Update method or the UpdateRequest message on the RecurringAppointmentMaster entity. You can update the basic or recurrence information.

Update basic information

When you update the basic information of a recurring appointment series, such as subject, location, or attendees, all instances in the recurring appointment series are updated except those that have exceptions on the same attribute.

Update recurrence information

When you update the recurring information of a recurring appointment series, such as pattern and range, the following things occur:

  1. A new series with a new RecurringAppointmentMaster.ActivityId is created that has the same information as the original series, and the date in the RecurringAppointmentMaster.EffectiveEndDate attribute of the new series is set to the last occurring past instance of the original series. All the future instances of the original series are deleted. In this manner, the original series is ended, and the history of the past instances is preserved in the system by storing it in a new series.
  2. The new information is used to create the future instances of the new series from the effective start date (RecurringAppointmentMaster.EffectiveStartDate).

Also, the RecurringAppointmentMaster.GroupId attribute for both the original and the new series is populated with the same value. This implies that whenever you update the recurrence information in a recurring appointment series, all the new series’ that are created have the same value for the RecurringAppointmentMaster.GroupId attribute as the recurring appointment series that is updated, although each series has a unique series ID.

Note
When you update the recurrence information of a recurring appointment series that has all the instances slated to occur in future, all instances are deleted and new recurrence information is used to create or expand new instances.

To see the sample code for updating a recurring appointment series, see Sample: Reschedule and cancel a recurring appointment.

Update a recurring appointment instance

Because the recurring appointment records are stored as appointment objects, you can use the IOrganizationService.Update method on the Appointment entity to update a recurring appointment instance. When you update a recurring appointment instance, the instance is marked as an exception to the recurring appointment series. More information: Create a Recurring Appointment Exception

You can also use the CreateExceptionRequest class on the Appointment entity to update a recurring appointment instance.

Tip
Recurring appointment instances can be identified using the Appointment.InstanceTypeCode attribute, which will have a value of “2” (Recurring Instance). More information: Appointment entity messages and methods

See Also

Concepts

Delete or end a recurring appointment series or instance

Other Resources

Recurring appointment entities
Sample: Create, retrieve, update, and delete a recurring appointment
Sample: Reschedule and cancel a recurring appointment

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Delete or end a recurring appointment series or instance

You can delete a recurring appointment series, delete an instance in the series, or end a recurring appointment series after a specified date and time.

In This Topic

Delete a recurring appointment instance

Delete a recurring appointment series

End a recurring appointment series

Delete a recurring appointment instance

Because recurring appointment instances are stored as appointment objects, you can use the IOrganizationService.DeleteRequest on an appointment record to delete a recurring appointment instance. Deleting an appointment instance marks it as an exception by creating an entry for the instance in the RecurringAppointmentMaster.DeletedExceptionsList attribute for the parent appointment series object. This is done to track the deleted instance for later synchronization with Microsoft Dynamics CRM for Microsoft Office Outlook.

Delete a recurring appointment series

You can use the IOrganizationService.Delete method or the DeleteRequest on a RecurringAppointmentMaster record to delete a recurring appointment series. Deleting a series deletes the record and all of the associated recurring appointment instances.

End a recurring appointment series

If you want to end a series before the original end date specified during the creation of the series, you can use the DeleteOpenInstancesRequest class. Using this message does the following:

  • Deletes all the “open” and “scheduled” future instances of the specified series from the date specified in the SeriesEndDate property. However, if the state of the future instances is changed to “completed” or “canceled”, they are not deleted.
  • Sets the status of the past instances to the specified value in the StateOfPastInstances property. However, the past instances are not deleted.
  • Terminates the series to the last occurring past instance date with respect to the date specified in the SeriesEndDate property, and sets the state of the series to “canceled”.

This allows you to preserve the instances of a recurring appointment series even if you have decided to end it prematurely. This is useful if you have attached notes or attachments to past instances of a recurring appointment series that contain important information about the customer or business.

See Also

Concepts

Link custom attributes of the recurring appointment master (series) and appointment entities

Other Resources

Recurring appointment entities
Sample: Create, retrieve, update, and delete a recurring appointment
Sample: End a recurring appointment series

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Link custom attributes of the recurring appointment master (series) and appointment entities

You can link the custom attributes created for the RecurringAppointmentMaster entity with the custom attributes created for the Appointment entity to automatically copy the data from the recurring appointment master custom attribute to the linked recurring appointment instances custom attribute, every time it is expanded.

There is a 1:1 mapping between the custom attributes, which implies that a custom attribute of the recurring appointment master entity can be linked to only one custom attribute of the appointment entity. Moreover, the custom attributes that are to be linked together must be of the same type. For example, you cannot link a custom attribute of type string with a decimal custom attribute. For information about different types of attributes, see Customize entity attribute metadata.

Note
You cannot link the custom attributes that have field-level security enabled. Similarly, you cannot enable field-level security for linked custom attributes.

Link custom attributes

  1. Create a custom attribute for the appointment entity using the CreateAttributeRequest class.

  2. Create a custom attribute for the recurring appointment series (recurring appointment master) entity. While specifying the attribute metadata for the custom attribute, use the AttributeMetadata.LinkedAttributeId property to link to the custom attribute that you created in step 1.

  3. Publish the changes to the solution.

For sample code, see Sample: Link custom attributes between series and instances.

See Also

Concepts

RecurringAppointmentMaster entity messages and methods
Customize entity attribute metadata

Other Resources

Recurring appointment entities
Sample: Link custom attributes between series and instances

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RecurringAppointmentMaster entity messages and methods

A recurring appointment master contains the master appointment of a recurring appointment series.

The schema name for this entity is RecurringAppointmentMaster. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddRecurrenceRequest | Adds recurrence information to an existing appointment to make it a recurring appointment master.
AssignRequest | Assigns a recurring appointment master to another user or team.
BookRequest | Schedules or books a recurring appointment master.
CreateExceptionRequest | Creates an exception for the recurring appointment instance.
CreateRequest | Creates a recurring appointment master. You can also call the IOrganizationService.Create method.
CreateInstanceRequest | Creates an instance of a recurring appointment master.
DeleteRequest | Deletes a recurring appointment master. You can also call the IOrganizationService.Delete method.
DeleteOpenInstancesRequest | Use this message to delete instances of a recurring appointment master that have an Open state.
GrantAccessRequest | Shares a recurring appointment master with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a recurring appointment master previously shared with another security principal (user or team).
RescheduleRequest | Reschedules a recurring appointment master.
RetrieveRequest | Retrieves a recurring appointment master. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of recurring appointment masters. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a recurring appointment master.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a recurring appointment master, and their access rights to the recurring appointment master.
RevokeAccessRequest | Removes all access to a recurring appointment master for the specified security principal (user or team).
SetStateRequest | Sets the state of a recurring appointment master. The possible values for this attribute are defined in the RecurringAppointmentMaster.State attribute. If you are using early bound types, you can use the RecurringAppointmentMasterState enumeration. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a recurring appointment master. You can also call the IOrganizationService.Update method.

See Also

Concepts

RecurringAppointmentMaster entity privileges
RecurrenceRule entity messages and methods

Other Resources

Recurring appointment entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RecurrenceRule entity messages and methods

A recurrence rule represents the pattern of incidence for a recurring appointment. The schema name for this entity is RecurrenceRule. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The recurrence rule entity offers limited functionality in terms of create, retrieve, update, and delete operations on this entity. You cannot directly update or delete recurrence rule records that were created as a result of creating recurring appointment master records. When you update the recurrence information of a recurring appointment or delete a recurring appointment master record, the associated recurrence rule record is automatically updated or deleted. To work with recurring appointments, use the recurring appointment master entity. More information: Recurring appointment entities.

The RecurrenceRule.MonthOfYear attribute specifies the month of the year valid for the recurrence pattern. The possible values for this attribute are defined in the MonthOfYear option set.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a recurrence rule. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a recurrence rule. You can also call the IOrganizationService.Delete method.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a recurrence rule. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of recurrence rules. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a recurrence rule. You can also call the IOrganizationService.Update method.
ValidateRecurrenceRuleRequest | Validates a rule for a recurring appointment.

See Also

Concepts

RecurrenceRule entity privileges

Other Resources

Recurring appointment entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Resource entities

Resources represent the people, tools, rooms, or pieces of equipment that are used to deliver a service. Resources are collected into resource groups with similar attributes to make them easier to work with by adding the resources to a constraint based group (resource group).In Microsoft Dynamics CRM, resources are categorized as Users or Facilities/Equipment.

A resource is an entity that can be scheduled. Examples of resources include employees, contacts, customers, knowledge workers, or physical assets like equipment. In the Microsoft Dynamics CRM SDK, resources are represented by the system user (user) and equipment (facility/equipment) entities. As resources, these entities also have a site property that can affect scheduling.

A resource also has its own calendar that defines working hours and constraints. Upon creation, if a calendar is not specified for a resource, a calendar with 24 hours a day, seven days a week availability is created by default. Resources support multiple concurrent appointments. This is supported by using the capacity set in the calendar rule for a calendar. A resource calendar describes not only when a resource is not available but also describes the resource effort available (capacity) and, optionally, the effort required (service cost). This is defined on a resource specification for services it supports. The resource specification is a required component of the service. It cannot be scheduled without specifying schedulable resources. These are evaluated by the scheduling engine when it is searching for resource availability for a particular appointment request. The resource is responsible for keeping its appointment book and responding to the scheduling engine only for existing commitments, calendar restrictions, and constraints.

A resource specification is an entity that chooses members within a group or team. It is also the link between a service and its resources and can be contained within a resource group to allow for nesting. For more information, see the diagram in Schedule and appointment entities. A resource specification defines the number and method for selecting resources within a group in addition to the effort required for a given service. Each service has exactly one resource specification but many services may share the same resource specification.

Resources can be grouped together to form a pool of available resource groups. Resource groups can contain user resources, equipment resources, teams and other resource groups, and enable the scheduling engine to select an available resource from a pool of resources. For example, one group could include all resources that have the skill of "Doctor." Another resource group could include all resources that have the skill of "Nurse." You can then define a resource specification that specifies one from the Doctors group and another that specifies two from the Nurses group. You can now define a new resource group called a "Surgery Crew," which includes these two resource specifications, one from Doctors and two from Nurses. A "Surgery" service can now refer to a resource specification that refers to this resource group. This is one example of how to quickly build a well-defined set of resource rules to participate in a service. A service may define requirements on the resource group as a whole, for example, any from the group, all from the group, or a subset.

In This Section

Resource entity messages and methods

Equipment (facility/equipment) entity messages and methods

ResourceSpec (resource specification) entity messages and methods

ResourceGroup (scheduling group) entity messages and methods

ConstraintBasedGroup (resource group) entity messages and methods

Related Sections

Sample code for schedule and appointment Entities

Service entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Resource entity messages and methods

A resource is a user or facility/equipment that has a calendar and can be scheduled for a service. The schema name for this entity is Resource. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Resource entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Resource entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a resource. You can also call the IOrganizationService.Retrieve method.
RetrieveByGroupResourceRequest | Retrieves all the resource groups to which the specified resource belongs.
RetrieveMultipleRequest | Retrieves a collection of resources. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

Resource entity privileges
Equipment (facility/equipment) entity messages and methods

Other Resources

Resource entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Equipment (facility/equipment) entity messages and methods

An equipment resource can represent a piece of equipment, such as a tool, or it can represent a facility, such as a room. The schema name for this entity is Equipment. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Equipment entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates an equipment record. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an equipment record. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Equipment entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves an equipment record. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of equipment records. You can also call the RetrieveMultiple method.
SetBusinessEquipmentRequest | Sets the business that owns the equipment.
UpdateRequest | Updates an equipment record. You can also call the IOrganizationService.Update method.

See Also

Concepts

ResourceSpec (resource specification) entity messages and methods
Equipment (facility/equipment) entity privileges

Other Resources

Resource entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ResourceSpec (resource specification) entity messages and methods

A resource specification contains the resource requirements for a service. Typically the resource specification includes a count of resources and exactly one reference to a resource group from which resources are selected. The required count attribute may be one (any of), more than one (n of), or all (all of) to indicate the number of group members required to perform this service. A resource specification also includes a binding objective described as an arithmetic expression (see Search Expressions in this topic) based on properties of group members or custom common language runtime (CLR) functions. This entity also specifies the effort required on each resource or the service cost that can vary over time. This is expressed as a calendar function. The schema name for this entity is ResourceSpec. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see ResourceSpec entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a resource specification. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a resource specification. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService. Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see ResourceSpec entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a resource specification. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of resource specifications. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a resource specification. You can also call the IOrganizationService.Update method.

Search Expressions

The scheduling engine supports the following three search strategies specified in the ResourceSpec.ObjectiveExpression attribute:

  • Least Busy. From the list of resources that can perform that specific service, select the resource that is the least busy and is also available at the requested time.
  • Most Busy. From the list of resources that can perform that specific service, select the resource that is the busiest and is also available at the requested time.
  • Random. From the list of resources that can perform that specific service, select any resource that is available at the requested time.

See Also

Concepts

ResourceSpec (resource specification) entity privileges
ResourceGroup (scheduling group) entity messages and methods

Other Resources

Resource entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ResourceGroup (scheduling group) entity messages and methods

A resource group (scheduling group) is a group or team whose members can be scheduled for a service. The schema name for this entity is ResourceGroup. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see ResourceGroup entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see ResourceGroup entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
FindParentResourceGroupRequest | Finds a parent resource group (scheduling group) for the specified resource groups (scheduling groups).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a resource group. You can also call the IOrganizationService.Retrieve method.
RetrieveByResourceResourceGroupRequest | Retrieves the resource groups that contain the specified resource.
RetrieveMultipleRequest | Retrieves a collection of resource groups. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveParentGroupsResourceGroupRequest | Retrieves a collection of the parent resource groups of the specified resource group (scheduling group).
RetrieveSubGroupsResourceGroupRequest | Retrieves a collection of the child resource groups of the specified resource group (scheduling group).

See Also

Concepts

ConstraintBasedGroup (resource group) entity privileges

Other Resources

Resource entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConstraintBasedGroup (resource group) entity messages and methods

A constraint-based group (resource group) is a group in which the resource members are specified by a logical expression constraint. Constraint-based group membership is described by a logical expression that is evaluated against the collection of all resources. The schema name for this entity is ConstraintBasedGroup. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship.You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the ConstraintBasedGroup entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a constraint-based group (resource group). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a constraint-based group (resource group). You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship.You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the ConstraintBasedGroup entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information..
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a constraint-based group (resource group). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of constraint-based groups (resource groups). You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a constraint-based group (resource group). You can also call the IOrganizationService.Update method.

See Also

Concepts

Resource entity messages and methods
Equipment (facility/equipment) entity messages and methods
ResourceSpec (resource specification) entity messages and methods
ResourceGroup (scheduling group) entity messages and methods
ConstraintBasedGroup (resource group) entity privileges

Other Resources

Resource entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Service entity

A service is work that is performed for a customer. The definition typically includes service attributes such as name, duration, granularity, calendar restrictions, and resource requirements. A Service entity represents a service made available to a customer, with attributes that include the standard duration of the service, when the service can be offered, and required resources, which is described by the ResourceSpec class.

For example, a dental cleaning service definition may include resource requirements for a hygienist, a dental cleaning chair, a patient, and a duration limit of 90 minutes. The definition may also include additional parameterized constraints that are evaluated during availability search. In this service definition, a constraint may be defined that the "patient" resource must have a valid insurance provider identification number. This constraint example uses a custom attribute added to the resource for the insurance provider identification number.

For each resource specification, there is an objective that ranks available resources from most suitable to least. For example, the busiest nurse, least busy doctor, or the cheapest resource.

To start using Microsoft Dynamics CRM service scheduling to manage your service delivery process, you must first create a model of your service business. To do this, you create a Resource record or an Equipment record for the people and equipment that you want to schedule and you create Service records for the services you offer. When you define the service, you can describe which resources are required for each service by using a series of resource specifications (ResourceSpec). Then, you can model the business rules that govern service availability into the system. These rules include things such as the working hours of the service delivery personnel, and any special restrictions on services. After this information is defined, the scheduling engine has what it must have to manage the service delivery schedule.

Service booking granularity determines the time interval on which availability is displayed to users. Typically, this is something like "every 15 minutes" or "every hour on the hour". Duration is the time that is required to perform the service.

In This Section

Service entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Service entity messages and methods

A service is an activity that represents work done to satisfy a customer's need. The schema name for this entity is Service. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Service entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a service. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a service. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Service entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a service. You can also call the IOrganizationService.Retrieve method.
RetrieveByResourcesServiceRequest | Retrieves a collection of services related to the specified set of services.
RetrieveMultipleRequest | Retrieves a collection of services. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a service. You can also call the IOrganizationService.Update method.

See Also

Concepts

Service entity privileges

Other Resources

Service entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample code for schedule and appointment Entities

This section contains the code examples that show how to use the schedule and appointment entities.

In This Section

Sample: Search for openings to schedule a resource

Sample: Query the working hours of a user

Sample: Query the working hours of multiple users

Sample: Book an appointment

Sample: Validate an appointment

Sample: Create, retrieve, update, and delete a recurring appointment

Sample: Reschedule and cancel a recurring appointment

Sample: End a recurring appointment series

Sample: Convert an appointment to a recurring appointment

Sample: Link custom attributes between series and instances

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Search for openings to schedule a resource
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\ScheduleResource.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following code example shows how to find openings to schedule a resource by using the SearchRequest message.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to schedule a resource.
    /// </summary>
    public class ScheduleResource
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _vanId;
        public Guid _groupId;
        public Guid _specId;
        public Guid _plumberServiceId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Schedule a resource.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Create the van required resource object.
                    RequiredResource vanReq = new RequiredResource
                    {
                        ResourceId = _vanId,
                        ResourceSpecId = _specId
                    };

                    // Create the appointment request.
                    AppointmentRequest appointmentReq = new AppointmentRequest
                    {
                        RequiredResources = new RequiredResource[] { vanReq },
                        Direction = SearchDirection.Backward,
                        Duration = 60,
                        NumberOfResults = 10,
                        ServiceId = _plumberServiceId,
                        // The search window describes the time when the resouce can be scheduled.
                        // It must be set.
                        SearchWindowStart = DateTime.Now.ToUniversalTime(),
                        SearchWindowEnd = DateTime.Now.AddDays(7).ToUniversalTime(),
                        UserTimeZoneCode = 1
                    };

                    // Verify whether there are openings available to schedule the appointment using this resource
                    SearchRequest search = new SearchRequest
                    {
                        AppointmentRequest = appointmentReq
                    };
                    SearchResponse searched = (SearchResponse)_serviceProxy.Execute(search);

                    if (searched.SearchResults.Proposals.Length > 0)
                    {
                        Console.WriteLine("Openings are available to schedule the resource.");
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Get the current user's information.
            WhoAmIRequest userRequest = new WhoAmIRequest();
            WhoAmIResponse userResponse = (WhoAmIResponse)_serviceProxy.Execute(userRequest);

            // Create the van resource.
            Equipment van = new Equipment
            {
                Name = "Van 1",
                TimeZoneCode = 1,
                BusinessUnitId = new EntityReference(BusinessUnit.EntityLogicalName, userResponse.BusinessUnitId)
            };

            _vanId = _serviceProxy.Create(van);

            Console.WriteLine("Created a sample equipment: {0}.", van.Name);

            // Create the contraints for creating the plumber resource group
            System.Text.StringBuilder builder = new System.Text.StringBuilder("<Constraints>");
            builder.Append("<Constraint>");
            builder.Append("<Expression>");
            builder.Append("<Body>resource[\"Id\"] == ");
            builder.Append(userResponse.UserId.ToString("B"));
            builder.Append(" || resource[\"Id\"] == ");
            builder.Append(_vanId.ToString("B"));
            builder.Append("</Body>");
            builder.Append("<Parameters>");
            builder.Append("<Parameter name=\"resource\" />");
            builder.Append("</Parameters>");
            builder.Append("</Expression>");
            builder.Append("</Constraint>");
            builder.Append("</Constraints>");

            // Define an anonymous type to define the possible constraint based group type code values.
            var ConstraintBasedGroupTypeCode = new
            {
                Static = 0,
                Dynamic = 1,
                Implicit = 2
            };
            // Create the plumber resource group.
            ConstraintBasedGroup group = new ConstraintBasedGroup
            {
                BusinessUnitId = new EntityReference(BusinessUnit.EntityLogicalName, userResponse.BusinessUnitId),
                Name = "Plumber with Van 1",
                Constraints = builder.ToString(),
                GroupTypeCode = new OptionSetValue(ConstraintBasedGroupTypeCode.Static),
            };

            _groupId = _serviceProxy.Create(group);

            Console.WriteLine("Created a sample resource group: {0}.", group.Name);

            // Create the resource specification.
            ResourceSpec spec = new ResourceSpec
            {
                BusinessUnitId = new EntityReference(BusinessUnit.EntityLogicalName, userResponse.BusinessUnitId),
                ObjectiveExpression = @"
                    <Expression>
                        <Body>udf ""Random""(factory,resource,appointment,request,leftoffset,rightoffset)</Body>
                        <Parameters>
                            <Parameter name=""factory"" />
                            <Parameter name=""resource"" />
                            <Parameter name=""appointment"" />
                            <Parameter name=""request"" />
                            <Parameter name=""leftoffset"" />
                            <Parameter name=""rightoffset"" />
                        </Parameters>
                        <Properties EvaluationInterval=""P0D"" evaluationcost=""0"" />
                    </Expression>",
                RequiredCount = 1,
                Name = "Test Spec",
                GroupObjectId = _groupId
            };
            _specId = _serviceProxy.Create(spec);

            // Create the plumber required resource object.
            RequiredResource plumberReq = new RequiredResource
            {
                ResourceId = userResponse.UserId,   // assume current user is the plumber
                ResourceSpecId = _specId
            };

            // Create the service for the equipment.
            Service plumberService = new Service
            {
                Name = "Plumber 1",
                Duration = 60,
                InitialStatusCode = new OptionSetValue(1),
                Granularity = "FREQ=MINUTELY;INTERVAL=15;",
                ResourceSpecId = new EntityReference(ResourceSpec.EntityLogicalName, _specId)
            };

            _plumberServiceId = _serviceProxy.Create(plumberService);

            Console.WriteLine("Created a sample service for the equipment: {0}.", plumberService.Name);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Service.EntityLogicalName, _plumberServiceId);
                _serviceProxy.Delete(Equipment.EntityLogicalName, _vanId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                ScheduleResource app = new ScheduleResource();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Other Resources

Sample code for schedule and appointment Entities
Sample: Query the working hours of a user
Resource entities
Helper code: ServerConnection class
IOrganizationService
SearchRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Query the working hours of a user
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\QueryWorkingHoursOfUser.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve the working hours of a user by using the QueryScheduleRequest message.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve the working hours of a user.
    /// </summary>
    public class QueryWorkingHoursOfUser
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Retrieve the working hours of the current user.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Get the current user's information.
                    WhoAmIRequest userRequest = new WhoAmIRequest();
                    WhoAmIResponse userResponse = (WhoAmIResponse)_serviceProxy.Execute(userRequest);

                    // Retrieve the working hours of the current user.
                    QueryScheduleRequest scheduleRequest = new QueryScheduleRequest
                    {
                        ResourceId = userResponse.UserId,
                        Start = DateTime.Now,
                        End = DateTime.Today.AddDays(7),
                        TimeCodes = new TimeCode[] { TimeCode.Available }
                    };
                    QueryScheduleResponse scheduleResponse = (QueryScheduleResponse)_serviceProxy.Execute(scheduleRequest);

                    // Verify if some data is returned for the availability of the current user
                    if (scheduleResponse.TimeInfos.Length > 0)
                    {
                        Console.WriteLine("Successfully queried the working hours of the current user.");
                    }
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // No entity records are created for this sample.
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                QueryWorkingHoursOfUser app = new QueryWorkingHoursOfUser();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Schedules in Microsoft Dynamics CRM

Other Resources

Sample code for schedule and appointment Entities
Sample: Query the working hours of multiple users
Resource entities
Helper code: ServerConnection class
IOrganizationService
QueryScheduleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Query the working hours of multiple users
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\QueryWorkingHoursOfMultipleUsers.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve the working hours of multiple users by using the QueryMultipleSchedulesRequest message.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve the working hours of multiple users.
    /// </summary>
    public class QueryWorkingHoursOfMultipleUsers
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _currentUserId;
        private Guid _otherUserId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Retrieve the working hours of multiple users.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Retrieve the working hours of the current and the other user.
                    QueryMultipleSchedulesRequest scheduleRequest = new QueryMultipleSchedulesRequest();
                    scheduleRequest.ResourceIds = new Guid[2];
                    scheduleRequest.ResourceIds[0] = _currentUserId;
                    scheduleRequest.ResourceIds[1] = _otherUserId;
                    scheduleRequest.Start = DateTime.Now;
                    scheduleRequest.End = DateTime.Today.AddDays(7);
                    scheduleRequest.TimeCodes = new TimeCode[] { TimeCode.Available };

                    QueryMultipleSchedulesResponse scheduleResponse = (QueryMultipleSchedulesResponse)_serviceProxy.Execute(scheduleRequest);

                    // Verify if some data is returned for the availability of the users
                    if (scheduleResponse.TimeInfos.Length > 0)
                    {
                        Console.WriteLine("Successfully queried the working hours of multiple users.");
                    }
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Get the current user's information.
            WhoAmIRequest userRequest = new WhoAmIRequest();
            WhoAmIResponse userResponse = (WhoAmIResponse)_serviceProxy.Execute(userRequest);
            _currentUserId = userResponse.UserId;

            // Create another user, Kevin Cook.
            _otherUserId = SystemUserProvider.RetrieveSalesManager(_serviceProxy);
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                QueryWorkingHoursOfMultipleUsers app = new QueryWorkingHoursOfMultipleUsers();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Schedules in Microsoft Dynamics CRM

Other Resources

Sample code for schedule and appointment Entities
Sample: Book an appointment
Resource entities
Helper code: ServerConnection class
IOrganizationService
QueryMultipleSchedulesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Book an appointment
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\BookAppointment.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to book or schedule an appointment by using the BookRequest message.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to book or schedule an appointment.
    /// </summary>
    public class BookAppointment
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _appointmentId = Guid.Empty;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Book an appointment.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Get the current user information
                    WhoAmIRequest userRequest = new WhoAmIRequest();
                    WhoAmIResponse userResponse = (WhoAmIResponse)_serviceProxy.Execute(userRequest);

                    // Create the ActivityParty instance.
                    ActivityParty party = new ActivityParty
                    {
                        PartyId = new EntityReference(SystemUser.EntityLogicalName, userResponse.UserId)
                    };

                    // Create the appointment instance.
                    Appointment appointment = new Appointment
                    {
                        Subject = "Test Appointment",
                        Description = "Test Appointment created using the BookRequest Message.",
                        ScheduledStart = DateTime.Now.AddHours(1),
                        ScheduledEnd = DateTime.Now.AddHours(2),
                        Location = "Office",
                        RequiredAttendees = new ActivityParty[] { party },
                        Organizer = new ActivityParty[] { party }
                    };

                    // Use the Book request message.
                    BookRequest book = new BookRequest
                    {
                        Target = appointment
                    };
                    BookResponse booked = (BookResponse)_serviceProxy.Execute(book);
                    _appointmentId = booked.ValidationResult.ActivityId;

                    // Verify that the appointment has been scheduled.
                    if (_appointmentId != Guid.Empty)
                    {
                        Console.WriteLine("Succesfully booked {0}.", appointment.Subject) ;
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // All the entity records in this sample are created in the Run() method.
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Appointment.EntityLogicalName, _appointmentId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                BookAppointment app = new BookAppointment();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Other Resources

Sample code for schedule and appointment Entities
Appointment entities
Helper code: ServerConnection class
Sample: Validate an appointment
BookRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Validate an appointment
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\Validate.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to validate an appointment using the ValidateRequest message.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    public class Validate
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _contactId;
        private Guid _appointmentId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Verify whether an appointment has valid resources for the appointment activity.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Retrieve the appointment to be validated
                    ColumnSet cols = new ColumnSet("scheduledstart", "scheduledend", "statecode", "statuscode");
                    Appointment retrievedAppointment = (Appointment)_serviceProxy.Retrieve(Appointment.EntityLogicalName,
                                                               _appointmentId, cols);

                    // Use the Validate message
                    ValidateRequest validatedReq = new ValidateRequest();
                    validatedReq.Activities = new EntityCollection();
                    validatedReq.Activities.Entities.Add(retrievedAppointment);
                    validatedReq.Activities.MoreRecords = false;
                    validatedReq.Activities.PagingCookie = "";
                    validatedReq.Activities.EntityName = Appointment.EntityLogicalName;

                    ValidateResponse validateResp = (ValidateResponse)_serviceProxy.Execute(validatedReq);

                    // Verify success
                    if ((validateResp.Result != null) && (validateResp.Result.Length > 0))
                    {
                        Console.WriteLine("Validated the appointment.");
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a new recurring appointment.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a contact
            Contact newContact = new Contact
            {
                FirstName = "Lisa",
                LastName = "Andrews",
                EMailAddress1 = "lisa@contoso.com"
            };
            _contactId = _serviceProxy.Create(newContact);
            Console.WriteLine("Created contact: {0}.", newContact.FirstName + " " + newContact.LastName);

            // Create ab activity party
            ActivityParty requiredAttendee = new ActivityParty
            {
                PartyId = new EntityReference(Contact.EntityLogicalName, _contactId)
            };

            // Create an appointment
            Appointment newAppointment = new Appointment
            {
                Subject = "Test Appointment",
                Description = "Test Appointment",
                ScheduledStart = DateTime.Now.AddHours(1),
                ScheduledEnd = DateTime.Now.AddHours(2),
                Location = "Office",
                RequiredAttendees = new ActivityParty[] {requiredAttendee}
            };
            _appointmentId = _serviceProxy.Create(newAppointment);
            Console.WriteLine("Created {0}.", newAppointment.Subject);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Appointment.EntityLogicalName, _appointmentId);
                _serviceProxy.Delete(Contact.EntityLogicalName, _contactId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                Validate app = new Validate();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Other Resources

Sample code for schedule and appointment Entities
Sample: Create, retrieve, update, and delete a recurring appointment
Appointment entities
Helper code: ServerConnection class
ValidateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete a recurring appointment
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\CRUDRecurringAppointment.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create, retrieve, update, and delete a recurring appointment series. This sample uses the following common methods:

  • IOrganizationService.Create
  • IOrganizationService.Retrieve
  • IOrganizationService.Update
  • IOrganizationService.Delete

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to create, retrieve, update, and delete a
    /// recurring appointment series.
    /// </summary>
    public class CRUDRecurringAppointment
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs as well as strings needed for this sample.
        public Guid _recurringAppointmentMasterId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create a recurring appointment.
        /// Retrieve the recurring appointment.
        /// Update the retrieved recurring appointment.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Define an anonymous type to define the possible recurrence pattern values.
                    var RecurrencePatternTypes = new
                    {
                        Daily = 0,
                        Weekly = 1,
                        Monthly = 2,
                        Yearly = 3
                    };

                    // Define an anonymous type to define the possible values for days
                    // of the week
                    var DayOfWeek = new
                    {
                        Sunday = 0x01,
                        Monday = 0x02,
                        Tuesday = 0x04,
                        Wednesday = 0x08,
                        Thursday = 0x10,
                        Friday = 0x20,
                        Saturday = 0x40
                    };

                    // Define an anonymous type to define the possible values
                    // for the recurrence rule pattern end type.
                    var RecurrenceRulePatternEndType = new
                    {
                        NoEndDate = 1,
                        Occurrences = 2,
                        PatternEndDate = 3
                    };

                    // Create a recurring appointment
                    RecurringAppointmentMaster newRecurringAppointment = new RecurringAppointmentMaster
                        {
                            Subject = "Sample Recurring Appointment",
                            StartTime = DateTime.Now.AddHours(1),
                            EndTime = DateTime.Now.AddHours(2),
                            RecurrencePatternType = new OptionSetValue(RecurrencePatternTypes.Weekly),
                            Interval = 1,
                            DaysOfWeekMask = DayOfWeek.Thursday,
                            PatternStartDate = DateTime.Today,
                            Occurrences = 10,
                            PatternEndType = new OptionSetValue(RecurrenceRulePatternEndType.Occurrences)
                        };

                    _recurringAppointmentMasterId = _serviceProxy.Create(newRecurringAppointment);
                    Console.WriteLine("Created {0}.", newRecurringAppointment.Subject);

                    // Retrieve the newly created recurring appointment
                    QueryExpression recurringAppointmentQuery = new QueryExpression
                    {
                        EntityName = RecurringAppointmentMaster.EntityLogicalName,
                        ColumnSet = new ColumnSet("subject"),
                        Criteria = new FilterExpression
                        {
                            Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "subject",
                                Operator = ConditionOperator.Equal,
                                Values = { "Sample Recurring Appointment" }
                            },
                            new ConditionExpression
                            {
                                AttributeName = "interval",
                                Operator = ConditionOperator.Equal,
                                Values = { 1 }
                            }
                        }
                        },
                        PageInfo = new PagingInfo
                        {
                            Count = 1,
                            PageNumber = 1
                        }
                    };

                    RecurringAppointmentMaster retrievedRecurringAppointment =
                        _serviceProxy.RetrieveMultiple(recurringAppointmentQuery).
                        Entities.Select(x => (RecurringAppointmentMaster)x).FirstOrDefault();

                    Console.WriteLine("Retrieved the recurring appointment.");

                    // Update the recurring appointment.
                    // Update the following for the retrieved recurring appointment series:
                    // 1. Update the subject.
                    // 2. Update the number of occurences to 5.
                    // 3. Update the appointment interval to 2.

                    retrievedRecurringAppointment.Subject = "Updated Recurring Appointment";
                    retrievedRecurringAppointment.Occurrences = 5;
                    retrievedRecurringAppointment.Interval = 2;
                    _serviceProxy.Update(retrievedRecurringAppointment);

                    Console.WriteLine("Updated the subject, occurrences, and interval of the recurring appointment.");

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(RecurringAppointmentMaster.EntityLogicalName,
                    _recurringAppointmentMasterId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CRUDRecurringAppointment app = new CRUDRecurringAppointment();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Reference

Create
Retrieve
Update
Delete

Concepts

Create a recurring appointment series, instance, or exception
Update a recurring appointment
Delete or end a recurring appointment series or instance

Other Resources

Helper code: ServerConnection class
Sample code for schedule and appointment Entities
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Reschedule and cancel a recurring appointment
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\RescheduleandCancelRecurringAppointmentInstance.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following code example demonstrates how to reschedule and cancel appointment instances in a recurring appointment series using the RescheduleRequest message.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to reschedule an instance and cancel
    /// the last instance of a recurring appointment series.
    /// </summary>
    public class RescheduleandCancelRecurringAppointmentInstance
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs as well as strings needed for this sample.
        public Guid _recurringAppointmentMasterId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Reschedule an instance of the recurring appointment series.
        /// Cancel another instance of the recurring appointment series.
        /// Optionally delete any entity records that were created for this sample.
         /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Retrieve the individual appointment instance that falls on or after
                    // 10 days from today. Basically this will be the second instance in the
                    // recurring appointment series.

                    QueryExpression instanceQuery = new QueryExpression
                    {
                        EntityName = Appointment.EntityLogicalName,
                        ColumnSet = new ColumnSet
                        {
                            Columns = { "activityid", "scheduledstart", "scheduledend" }
                        },
                        Criteria = new FilterExpression
                        {
                            Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "seriesid",
                                Operator = ConditionOperator.Equal,
                                Values = { _recurringAppointmentMasterId }
                            },
                            new ConditionExpression
                            {
                                 AttributeName = "scheduledstart",
                                 Operator = ConditionOperator.OnOrAfter,
                                 Values = { DateTime.Today.AddDays(10) }
                            }
                        }
                        }
                    };

                    EntityCollection individualAppointments = _serviceProxy.RetrieveMultiple(instanceQuery);

                    #region Reschedule an instance of recurring appointment

                    // Update the scheduled start and end dates of the appointment
                    // to reschedule it.
                    Appointment updateAppointment = new Appointment
                    {
                        ActivityId = individualAppointments.Entities.Select(x => (Appointment)x).First().ActivityId,
                        ScheduledStart = individualAppointments.Entities.Select(x => (Appointment)x).First().ScheduledStart.Value.AddHours(1),
                        ScheduledEnd = individualAppointments.Entities.Select(x => (Appointment)x).First().ScheduledEnd.Value.AddHours(2)
                    };

                    RescheduleRequest reschedule = new RescheduleRequest
                    {
                        Target = updateAppointment
                    };

                    RescheduleResponse rescheduled = (RescheduleResponse)_serviceProxy.Execute(reschedule);
                    Console.WriteLine("Rescheduled the second instance of the recurring appointment.");

                    #endregion Reschedule an instance of recurring appointment

                    #region Cancel an instance of recurring appointment

                    // Cancel the last instance of the appointment. The status of this appointment
                    // instance is set to 'Canceled'. You can view this appoinyment instance under
                    // the 'All Activities' view.
                    SetStateRequest appointmentRequest = new SetStateRequest
                    {
                        State = new OptionSetValue((int)AppointmentState.Canceled),
                        Status = new OptionSetValue(4),
                        EntityMoniker = new EntityReference(Appointment.EntityLogicalName,
                            new Guid(individualAppointments.Entities.Select(x => (Appointment)x).Last().ActivityId.ToString()))
                    };

                    _serviceProxy.Execute(appointmentRequest);
                    Console.WriteLine("Canceled the last instance of the recurring appointment.");

                    #endregion Cancel an instance of recurring appointment

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a new recurring appointment.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Define an anonymous type to define the possible recurrence pattern values.
            var RecurrencePatternTypes = new
            {
                Daily = 0,
                Weekly = 1,
                Monthly = 2,
                Yearly = 3
            };

            // Define an anonymous type to define the possible values for days
            // of the week
            var DayOfWeek = new
            {
                Sunday = 0x01,
                Monday = 0x02,
                Tuesday = 0x04,
                Wednesday = 0x08,
                Thursday = 0x10,
                Friday = 0x20,
                Saturday = 0x40
            };

            // Define an anonymous type to define the possible values
            // for the recurrence rule pattern end type.
            var RecurrenceRulePatternEndType = new
            {
                NoEndDate = 1,
                Occurrences = 2,
                PatternEndDate = 3,
            };

            // Create a new recurring appointment
            RecurringAppointmentMaster newRecurringAppointment =
                new RecurringAppointmentMaster
                {
                    Subject = "Sample Recurring Appointment",
                    StartTime = DateTime.Now.AddHours(1),
                    EndTime = DateTime.Now.AddHours(2),
                    RecurrencePatternType = new OptionSetValue(
                        RecurrencePatternTypes.Weekly),
                    Interval = 1,
                    DaysOfWeekMask = DayOfWeek.Thursday,
                    PatternStartDate = DateTime.Today,
                    Occurrences = 5,
                    PatternEndType = new OptionSetValue(
                        RecurrenceRulePatternEndType.Occurrences)

                };

            _recurringAppointmentMasterId = _serviceProxy.Create(newRecurringAppointment);
            Console.WriteLine("Created {0}", newRecurringAppointment.Subject);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(RecurringAppointmentMaster.EntityLogicalName,
                    _recurringAppointmentMasterId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                ConvertAnAppointmenttoRecurringAppointment app = new ConvertAnAppointmenttoRecurringAppointment();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Other Resources

Recurring appointment entities
Helper code: ServerConnection class
Sample code for schedule and appointment Entities
Sample: End a recurring appointment series
IOrganizationService
RescheduleRequest
SetStateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: End a recurring appointment series
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\EndRecurringAppointmentSeries.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following sample shows how to end a recurring appointment series by using the DeleteOpenInstancesRequest message.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to end a recurring appointment series.
    /// </summary>
    public class EndRecurringAppointmentSeries
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Define the IDs as well as strings needed for this sample.
        public Guid _recurringAppointmentMasterId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// End the recurring appointment series.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Retrieve a recurring appointment series
                    RecurringAppointmentMaster retrievedRecurringAppointmentSeries = (RecurringAppointmentMaster)_serviceProxy.Retrieve(RecurringAppointmentMaster.EntityLogicalName, _recurringAppointmentMasterId, new ColumnSet(true));

                    // Use the DeleteOpenInstances message to end the series to the
                    // last occurring past instance date w.r.t. the series end date
                    // (i.e., 20 days from today). Effectively, that means that the
                    // series will end after the third instance (day 14) as this
                    // instance is the last occuring past instance w.r.t the specified
                    // series end date (20 days from today).
                    // Also specify that the state of past instances (w.r.t. the series
                    // end date) be set to 'completed'.
                    DeleteOpenInstancesRequest endAppointmentSeries = new DeleteOpenInstancesRequest
                    {
                        Target = retrievedRecurringAppointmentSeries,
                        SeriesEndDate = DateTime.Today.AddDays(20),
                        StateOfPastInstances = (int)AppointmentState.Completed
                    };
                    _serviceProxy.Execute(endAppointmentSeries);

                    Console.WriteLine("The recurring appointment series has been ended after the third occurrence.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a new recurring appointment.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Define an anonymous type to define the possible recurrence pattern values.
            var RecurrencePatternTypes = new
            {
                Daily = 0,
                Weekly = 1,
                Monthly = 2,
                Yearly = 3
            };

            // Define an anonymous type to define the possible values for days
            // of the week
            var DayOfWeek = new
            {
                Sunday = 0x01,
                Monday = 0x02,
                Tuesday = 0x04,
                Wednesday = 0x08,
                Thursday = 0x10,
                Friday = 0x20,
                Saturday = 0x40
            };

            // Define an anonymous type to define the possible values
            // for the recurrence rule pattern end type.
            var RecurrenceRulePatternEndType = new
            {
                NoEndDate = 1,
                Occurrences = 2,
                PatternEndDate = 3,
            };

            // Create a new recurring appointment
            RecurringAppointmentMaster newRecurringAppointment =
                new RecurringAppointmentMaster
                {
                    Subject = "Sample Recurring Appointment",
                    StartTime = DateTime.Now.AddHours(1),
                    EndTime = DateTime.Now.AddHours(2),
                    RecurrencePatternType = new OptionSetValue(
                        RecurrencePatternTypes.Weekly),
                    Interval = 1,
                    DaysOfWeekMask = DayOfWeek.Thursday,
                    PatternStartDate = DateTime.Today,
                    Occurrences = 5,
                    PatternEndType = new OptionSetValue(
                        RecurrenceRulePatternEndType.Occurrences)

                };

            _recurringAppointmentMasterId = _serviceProxy.Create(newRecurringAppointment);
            Console.WriteLine("Created {0} with {1} occurrences.", newRecurringAppointment.Subject, newRecurringAppointment.Occurrences);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(RecurringAppointmentMaster.EntityLogicalName,
                    _recurringAppointmentMasterId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                EndRecurringAppointmentSeries app = new EndRecurringAppointmentSeries();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Delete or end a recurring appointment series or instance

Other Resources

Helper code: ServerConnection class
Sample code for schedule and appointment Entities
Sample: Convert an appointment to a recurring appointment
DeleteOpenInstancesRequest
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Convert an appointment to a recurring appointment
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\ConvertAnAppointmenttoRecurringAppointment.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to convert an appointment to a recurring appointment series by using the AddRecurrenceRequest message.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to convert an appointment to a
    /// recurring appointment.
    /// </summary>
    public class ConvertAnAppointmenttoRecurringAppointment
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs as well as strings needed for this sample.
        public Guid _appointmentId;
        public Guid __recurringAppointmentMasterId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Convert an appointment to a recurring appointment.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Specify the recurrence information that needs to be added to the
                    // existing appointment.
                    // 1.  Define an anonymous type to define the possible recurrence pattern values.
                    var RecurrencePatternTypes = new
                    {
                        Daily = 0,
                        Weekly = 1,
                        Monthly = 2,
                        Yearly = 3
                    };

                    // 2.  Define an anonymous type to define the possible values for days
                    // of the week
                    var DayOfWeek = new
                    {
                        Sunday = 0x01,
                        Monday = 0x02,
                        Tuesday = 0x04,
                        Wednesday = 0x08,
                        Thursday = 0x10,
                        Friday = 0x20,
                        Saturday = 0x40
                    };

                    // 3.  Define an anonymous type to define the possible values
                    // for the recurrence rule pattern end type.
                    var RecurrenceRulePatternEndType = new
                    {
                        NoEndDate = 1,
                        Occurrences = 2,
                        PatternEndDate = 3
                    };

                    // 4.  Finally, use a recurring appointment master object to specify
                    //     the recurrence information. Other appointment details such as
                    //     'subject' and 'location' are copied from the existing appointment
                    //     to the recurring appointment master object.

                    RecurringAppointmentMaster newRecurringAppointmentInfo = new RecurringAppointmentMaster
                        {
                            StartTime = DateTime.Now.AddHours(2),
                            EndTime = DateTime.Now.AddHours(3),
                            RecurrencePatternType = new OptionSetValue(RecurrencePatternTypes.Weekly),
                            Interval = 1,
                            DaysOfWeekMask = DayOfWeek.Thursday,
                            PatternStartDate = DateTime.Today,
                            PatternEndType = new OptionSetValue(RecurrenceRulePatternEndType.Occurrences),
                            Occurrences = 5
                        };

                    // Use the AddRecurrence message to convert the existing appointment
                    // object to a recurring appointment master object. The existing
                    // appointment object is deleted thereafter.

                    AddRecurrenceRequest recurringInfoRequest = new AddRecurrenceRequest
                    {
                        Target = newRecurringAppointmentInfo,
                        AppointmentId = _appointmentId
                    };

                    AddRecurrenceResponse recurringInfoResponse = (AddRecurrenceResponse)_serviceProxy.Execute(recurringInfoRequest);
                    __recurringAppointmentMasterId = recurringInfoResponse.id;

                    // Verify that the newly created recurring appointment master has same 'subject'
                    // as the existing appointment.

                    RecurringAppointmentMaster retrievedMasterAppointment = (RecurringAppointmentMaster)_serviceProxy.Retrieve(RecurringAppointmentMaster.EntityLogicalName, __recurringAppointmentMasterId, new ColumnSet(true));
                    if (retrievedMasterAppointment.Subject == "Sample Appointment")
                    {
                        Console.WriteLine("Sample Appointment is converted to a recurring appointment.");
                    }

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a new recurring appointment.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create an appointment
            Appointment newAppointment = new Appointment
                {
                    Subject = "Sample Appointment",
                    Location = "Office",
                    ScheduledStart = DateTime.Now.AddHours(1),
                    ScheduledEnd = DateTime.Now.AddHours(2),
                };

            _appointmentId = _serviceProxy.Create(newAppointment);
            Console.WriteLine("Created {0}", newAppointment.Subject);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(RecurringAppointmentMaster.EntityLogicalName,
                    __recurringAppointmentMasterId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                ConvertAnAppointmenttoRecurringAppointment app = new ConvertAnAppointmenttoRecurringAppointment();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Reference

Convert an Appointment to a Recurring Appointment

Other Resources

Helper code: ServerConnection class
Sample code for schedule and appointment Entities
Sample: Link custom attributes between series and instances
AddRecurrenceRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Link custom attributes between series and instances
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\ScheduleAndAppointment\LinkCustomAttributesBetweenSeriesandInstances.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to link a custom attribute that is created for a recurring appointment series (RecurringAppointmentMaster) with a custom attribute that is created for the appointment instances (Appointment).

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to custom attribute created for
    /// recurring appointment series with a custom attribute
    /// created for the appointment instances.
    /// </summary>
    public class LinkCustomAttributesBetweenSeriesandInstances
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs as well as strings needed for this sample.
        public Guid _instanceAttributeID;
        public Guid _seriesAttributeID;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Link the custom attributes.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Create a custom string attribute for the appointment instance
                    StringAttributeMetadata customAppointmentInstanceAttribute = new StringAttributeMetadata
                    {
                        LogicalName = "new_customAppInstanceAttribute",
                        DisplayName = new Label("CustomAppInstanceAttribute", 1033),
                        Description = new Label("Sample Custom Appointment Instance Attribute", 1033),
                        MaxLength = 500,
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        SchemaName = "new_customAppInstanceAttribute"
                    };

                    CreateAttributeRequest instanceAttributeRequest = new CreateAttributeRequest
                    {
                        Attribute = customAppointmentInstanceAttribute,
                        EntityName = "appointment"
                    };

                    CreateAttributeResponse instanceAttributeResponse = (CreateAttributeResponse)_serviceProxy.Execute(instanceAttributeRequest);
                    _instanceAttributeID = instanceAttributeResponse.AttributeId;

                    // Create a custom string attribute for the recurring appointment master (series)
                    StringAttributeMetadata customAppointmentSeriesAttribute = new StringAttributeMetadata
                    {
                        LogicalName = "new_customAppSeriesAttribute",
                        DisplayName = new Label("CustomAppSeriesAttribute", 1033),
                        Description = new Label("Sample Custom Appointment Series Attribute", 1033),
                        MaxLength = 500,
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        SchemaName = "new_customAppSeriesAttribute",
                        LinkedAttributeId = _instanceAttributeID // Link the custom attribute to the appointment’s custom attribute.
                    };

                    CreateAttributeRequest seriesAttributeRequest = new CreateAttributeRequest
                    {
                        Attribute = customAppointmentSeriesAttribute,
                        EntityName = "recurringappointmentmaster"
                    };

                    CreateAttributeResponse seriesAttributeResponse = (CreateAttributeResponse)_serviceProxy.Execute(seriesAttributeRequest);
                    _seriesAttributeID = seriesAttributeResponse.AttributeId;

                    // Publish all the changes to the solution.
                    PublishAllXmlRequest createRequest = new PublishAllXmlRequest();
                    _serviceProxy.Execute(createRequest);

                    Console.WriteLine("Created a custom string attribute, {0}, for the appointment.", customAppointmentInstanceAttribute.LogicalName);
                    Console.WriteLine("Created a custom string attribute, {0}, for the recurring appointment, and linked it with {1}.", customAppointmentSeriesAttribute.LogicalName, customAppointmentInstanceAttribute.LogicalName);

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                DeleteAttributeRequest delSeriesAttribute = new DeleteAttributeRequest
                {
                    LogicalName = "new_customappseriesattribute",
                    EntityLogicalName = RecurringAppointmentMaster.EntityLogicalName
                };
                _serviceProxy.Execute(delSeriesAttribute);

                DeleteAttributeRequest delInstanceAttribute = new DeleteAttributeRequest
                {
                    LogicalName = "new_customappinstanceattribute",
                    EntityLogicalName = Appointment.EntityLogicalName
                };
                _serviceProxy.Execute(delInstanceAttribute);

                // Publish all the changes to the solution.
                PublishAllXmlRequest delRequest = new PublishAllXmlRequest();
                _serviceProxy.Execute(delRequest);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                LinkCustomAttributesBetweenSeriesandInstances app = new LinkCustomAttributesBetweenSeriesandInstances();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Link custom attributes of the recurring appointment master (series) and appointment entities

Other Resources

Helper code: ServerConnection class
Sample code for schedule and appointment Entities
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Template entities

In Microsoft Dynamics CRM 2015, the template entities help you create consistent layout and content in e-mail messages, articles, contracts, and mail merge documents.

In This Section

ContractTemplate entity messages and methods

KbArticleTemplate entity messages and methods

MailMergeTemplate entity messages and methods

Template (email template) entity messages and methods

Related Sections

Model your business data

Annotation (note) entity

UserQuery (saved view) entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ContractTemplate entity messages and methods

You use a contract template to simplify the creation of standard contracts by eliminating the time-consuming tasks associated with building a contract. A template contains most of the standard content for a contract. You can add specific details to that template to create a complete contract for each contact or account. The schema name for this entity is ContractTemplate. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a contract template. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a contract template. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a contract template. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of contract templates. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a contract template. You can also call the IOrganizationService.Update method.

See Also

Concepts

KbArticleTemplate entity messages and methods
MailMergeTemplate entity messages and methods
Template (email template) entity messages and methods
ContractTemplate entity privileges

Other Resources

Template entities
Contract entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


KbArticleTemplate entity messages and methods

A knowledge base article template is a template that is used to create a knowledge base article. It describes the sections and formatting required for the knowledge base article. The schema name for this entity is KbArticleTemplate. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a knowledge base article template. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a knowledge base article template. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a knowledge base article template. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of knowledge base article templates. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a knowledge base article template. You can also call the IOrganizationService.Update method.

See Also

Concepts

ContractTemplate entity messages and methods
MailMergeTemplate entity messages and methods
Template (email template) entity messages and methods

Other Resources

Template entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


MailMergeTemplate entity messages and methods

This entity represents a template for a mail merge document. The schema name for this entity is MailMergeTemplate. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a mail merge template to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see MailMergeTemplate entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a mail merge template. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a mail merge template. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService. Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see MailMergeTemplate entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares a mail merge template with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for a mail merge template previously shared with another security principal (user or team).
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a mail merge template.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a mail merge template, along with their access rights to the mail merge template.
RevokeAccessRequest | Removes all access to a mail merge template for the specified security principal (user or team).
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a mail merge template. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of mail merge templates. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of a mail merge template. The possible states are defined in the MailMergeTemplate.Statecode attribute. If you are using early bound types, use the MailMergeTemplateState enumeration. For a list of possible states, see MailMergeTemplate entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a mail merge template. You can also call the IOrganizationService.Update method.

See Also

Concepts

ContractTemplate entity messages and methods
KbArticleTemplate entity messages and methods
Template (email template) entity messages and methods
MailMergeTemplate entity privileges

Other Resources

Activity entities
Template entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Template (email template) entity messages and methods

The template entity represents a template for an email activity. It provides boilerplate text and Microsoft Dynamics CRM data for email messages. You can attach an email attachment (ActivityMimeAttachment) to a template. Templates cannot be used with Microsoft Office Word mail merges. The schema name for this entity is Template. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a template to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Template entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a template. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a template. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Template entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares a template with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
InstantiateTemplateRequest | Creates an email from a template.
MakeAvailableToOrganizationTemplateRequest | Deprecated. Use the AssociateRequest class. Makes the specified email template available to the organization.
MakeUnavailableToOrganizationTemplateRequest | Deprecated. Use the DisassociateRequest class. Makes the specified email template unavailable to the organization.
ModifyAccessRequest | Changes the access rights for a template previously shared with another security principal (user or team).
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a template. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of templates. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to a template.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a template, and also retrieves their access rights to the template.
RevokeAccessRequest | Removes all access rights to a template for the specified security principal (user or team).
SendTemplateRequest | Sends a bulk email message that is created from a template.
UpdateRequest | Updates a template. You can also call the IOrganizationService.Update method.

See Also

Concepts

Template (email template) entity privileges

Other Resources

Template entities
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Annotation (note) entity

The annotations (notes) provide easy ways to append additional information to any record in the Microsoft Dynamics CRM database. An annotation (note) is a text entry that can be associated with any entity in CRM. However, you can associate annotations with only those custom entities that are created with the HasNotes property set to true. You can update a custom entity, which is not enabled for notes, to have notes by setting the HasNotes property to true.

The Annotation entity represents an annotation (note), and contains the following information:

  • Annotation (note) text
  • Who created and modified the annotation (note)
  • Whether a file is attached to the annotation (note)

An attached file can be any standard computer file format that includes Microsoft Office Word documents, Microsoft Office Excel spreadsheets, CAD files, and PDF files. An attachment can be associated with any object, other than an annotation (note), in CRM.

To upload or remove an attachment, use the IOrganizationService. Update method or UpdateRequest message, setting the Annotation.Filename and Annotation.MimeType properties. This uploads an attachment that has been decoded into a base64 string format. The System.Convert.ToBase64String method can be used to convert the contents of a data file into a base64-formatted string. The maximum size of files that can be uploaded is determined by the Organization.MaxUploadFileSize property. This property is set in the Email tab of the System Settings in the CRM application. This setting limits the size of files that can be attached to email messages, notes, and web resources. The default setting is 5 MB.

In This Section

Annotation (note) entity messages and methods

Sample: Upload, retrieve, and download an attachment

See Also

Concepts

UserQuery (saved view) entity

Other Resources

Model your business data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Annotation (note) entity messages and methods

An annotation is a note that is attached to one or more objects, including other notes. The schema name for this entity is Annotation. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an annotation (note) to another user.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Annotation entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates an annotation (note). You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an annotation (note). You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Annotation entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares an annotation (note) with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for an annotation (note) previously shared with another security principal (user or team).
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves an annotation (note). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of accounts. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to an annotation (note).
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to an annotation (note), and also retrieves their access rights to the account.
RevokeAccessRequest | Removes all access to an annotation (note) for the specified security principal (user or team).
RollupRequest | Retrieves the annotations (notes) related to the specified record (account, contact, or opportunity).
UpdateRequest | Updates an annotation (note). You can also call the IOrganizationService.Update method.

See Also

Reference

Annotation (note) entity privileges

Other Resources

Annotation (note) entity
Sample: Upload, retrieve, and download an attachment

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Upload, retrieve, and download an attachment
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\Annotation\UploadAndDownloadAttachment.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to upload, retrieve, and download an attachment for an annotation using the IOrganizationService.Create and IOrganizationService.Retrieve methods.

Example

C# Copy Code
using System;
using System.IO;
using System.Text;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to upload attachments to an annotation and how to download attachments.
    /// </summary>
    public class UploadAndDownloadAttachment
    {

        #region Class Level Members

        private Guid _annotationId;
        private OrganizationServiceProxy _serviceProxy;
        private String _fileName;

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// an annotation is created, uploaded, then finally downloaded.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    #region Create and Upload annotation attachment

                    // Instantiate an Annotation object.
                    // See the Entity Metadata topic in the SDK documentation to determine
                    // which attributes must be set for each entity.
                    Annotation setupAnnotation = new Annotation()
                    {
                        Subject = "Example Annotation",
                        FileName = "ExampleAnnotationAttachment.txt",
                        DocumentBody = Convert.ToBase64String(
                            new UnicodeEncoding().GetBytes("Sample Annotation Text")),
                        MimeType = "text/plain"
                    };

                    // Create the Annotation object.
                    _annotationId = _serviceProxy.Create(setupAnnotation);

                    Console.Write("{0} created with an attachment", setupAnnotation.Subject);

                    #endregion Create and Upload annotation attachment

                    #region Download attachment from annotation record

                    // Define columns to retrieve from the annotation record.
                    ColumnSet cols = new ColumnSet("filename", "documentbody");

                    // Retrieve the annotation record.
                    Annotation retrievedAnnotation =
                        (Annotation)_serviceProxy.Retrieve("annotation", _annotationId, cols);
                    Console.WriteLine(", and retrieved.");
                    _fileName = retrievedAnnotation.FileName;

                    // Download the attachment in the current execution folder.
                    using (FileStream fileStream = new FileStream(retrievedAnnotation.FileName, FileMode.OpenOrCreate))
                    {
                        byte[] fileContent = Convert.FromBase64String(retrievedAnnotation.DocumentBody);
                        fileStream.Write(fileContent, 0, fileContent.Length);
                    }

                    Console.WriteLine("Attachment downloaded.");

                    #endregion Download attachment from annotation record

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records and files that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Annotation.EntityLogicalName, _annotationId);
                File.Delete(_fileName);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                UploadAndDownloadAttachment app = new UploadAndDownloadAttachment();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Reference

Create
Retrieve

Other Resources

Helper code: ServerConnection class
Annotation (note) entity
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserQuery (saved view) entity

Saved queries are business entities that define the parameters and criteria of a Microsoft Dynamics CRM database search. Saved queries support cross-entity searches. In Microsoft Dynamics CRM there are two entities available for queries against the CRM database.

A user query, called a saved view in the application, is owned by an individual user, can be assigned and shared with other users, and can be viewed by other users depending on the query's access privileges. This is appropriate for frequently used queries that span entity types and queries that perform aggregation. A saved query, called a view in the application, is owned by an organization making it visible to all users in the organization. Saved queries (views) are used for both views defined for an entity and for filters and templates for Microsoft Dynamics CRM for Microsoft Office Outlook. For more information about saved views, see Customize entity views and Offline and Outlook filters and templates.

A query in the form of a FetchXML statement is constructed and then assigned to the UserQuery.FetchXml attribute. This query can be executed by using the ExecuteByIdUserQueryRequest message.

You can see the user query (saved view) in the Advanced Find section of the Microsoft Dynamics CRM application and also in the View drop-down list for an entity. You can export the value of the UserQuery.FetchXml attribute by using the Download Fetch XML button in the Advanced Find dialog box.

See Also

Reference

FetchXML schema

Concepts

UserQuery (saved view) entity messages and methods

Other Resources

Model your business data
Build queries with QueryExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserQuery (saved view) entity messages and methods

A user query (saved view) represents a saved database query that a user or team owns. The schema name for this entity is UserQuery. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a user query to another user or team.
CreateRequest | Creates a user query. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a user query. You can also call the IOrganizationService.Delete method.
ExecuteByIdUserQueryRequest | Executes a previously saved query specified by an ID.
GrantAccessRequest | Shares a user query with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a user query previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a user query. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of user queries. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a user query.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves a collection of a user query, along their access rights to the user query.
RevokeAccessRequest | Removes all access to a user query for the specified security principal (user or team).
SetStateRequest | Sets the state of a user query. The possible states are defined in the UserQueryState enumeration. You can see the states in the UserQuery entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a user query. You can also call the IOrganizationService.Update method.

See Also

Concepts

UserQuery (saved view) entity
UserQuery (saved view) entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Developer tools

This new section in the Microsoft Dynamics CRM SDK provides a single location for you to learn about the developer tools provided for use with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

In This Section

Visual Studio and the .NET Framework

Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)

Browse the metadata for your organization

Analyze plug-in performance

Solution tools for team development

Related Sections

Software Development Kit for Microsoft Dynamics CRM

Write applications and server extensions

Programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Visual Studio and the .NET Framework

This release of the Microsoft Dynamics CRM SDK for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update is built on .NET Framework 4.5.2. You can use Microsoft Visual Studio 2012 or 2013 to build your managed code applications using .NET Framework 4.5.2 or later. You can choose to use a Microsoft Visual Studio Express edition for development, however, use of extensions isn’t supported in the Express edition so you won’t be able to install the Developer Toolkit in that version of Microsoft Visual Studio. Use of the Developer Toolkit is recommended, but not required. More information: Support for .NET Framework versions

Tip
When installing .NET Framework 4.5.2 on your development computer, be sure to install the developer pack and not just the run-time. This will enable the 4.5.2 framework to be chosen in the New Project dialog box of Visual Studio and in the target framework drop-down menu of the project’s properties.

There is a known breaking change in the Windows Identity Framework (WIF) namespace used by Microsoft Dynamics CRM SDK based applications. Existing applications built using the CRM 2013 SDK may need code changes to build against the CRM 2015 SDK. More information: Guidelines for Migrating an Application Built Using WIF 3.5 to WIF 4.5

For a complete statement of supported and unsupported development, see Supported extensions for Microsoft Dynamics CRM.

See Also

Other Resources

Developer tools

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)

CrmSvcUtil.exe is a command-line code generation tool for use with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. This tool generates early-bound .NET Framework classes that represent the entity data model used by Microsoft Dynamics CRM. This tool is in the SDK package in the SDK\Bin folder. Download the Microsoft Dynamics CRM SDK package.

In This Topic

About the code generation tool

Run the code generation tool

Parameters

Usage examples

Use the configuration file

Enable tracing

About the code generation tool

The CrmSvcUtil.exe tool creates a Microsoft Visual C# or Microsoft Visual Basic .NET output file that contains strongly-typed classes for entities in your organization. This includes custom entities and attributes. This output file contains one class for each entity, providing early binding and IntelliSense support in Microsoft Visual Studio to aid you as you write custom code. The generated classes are partial classes that can be extended with custom business logic in separate files. You can also create extensions to this tool. For more information, see Create extensions for the code generation tool.

The tool can also be used to generate a class derived from the OrganizationServiceContext class that acts as an entity container in the entity data model. This service context provides the facilities for tracking changes and managing identities, concurrency, and relationships. This class also exposes a SaveChanges method that writes inserts, updates, and deletes records in Microsoft Dynamics CRM. For more information, see Use the OrganizationServiceContext class.

The code generation tool takes several parameters that determine the contents of the file that is created. The parameters can be passed in from the command line when you run the tool or in a .NET-connected application configuration file.

The classes created by the code generation tool are designed to be built into a class library that can be referenced by projects that use Microsoft Dynamics CRM. After you have generated the class file using the tool, you should add the file to your Visual Studio project. You must also add references to several assemblies that the generated classes are dependent upon.

The following lists assemblies that must be referenced in your project when you use the generated code file.

  • Microsoft.Crm.Sdk.Proxy.dll
  • Microsoft.Xrm.Sdk.dll

These assemblies can be found in the The SDK\Bin folder of the SDK. Download the Microsoft Dynamics CRM SDK package.

Run the code generation tool

Run the CrmSvcUtil.exe tool from the SDK\Bin folder. If you run the tool from another folder location, make sure that a copy of the Microsoft.Xrm.Sdk.dll assembly is in that same folder.

The following sample shows the format for running the tool from the command line for an on-premises installation of Microsoft Dynamics CRM. You supply the parameter values for your installation.

Copy Code
CrmSvcUtil.exe /url:http://<serverName>/<organizationName>/XRMServices/2011/Organization.svc    /out:<outputFilename>.cs /username:<username> /password:<password> /domain:<domainName>    /namespace:<outputNamespace> /serviceContextName:<serviceContextName>

The following sample shows the format for running the tool from the command line with Microsoft Dynamics CRM Online. You supply the parameter values appropriate for your account and server.

Copy Code
CrmSvcUtil.exe /url:https://<organizationUrlName>.api.crm.dynamics.com/XRMServices/2011/Organization.svc    /out:<outputFilename>.cs /username:<username> /password:<password>     /namespace:<outputNamespace> /serviceContextName:<serviceContextName>

For the username parameter, type the user name that is used to sign in to Microsoft account or Microsoft Office 365. You can look up the correct URL in the web application by selecting Settings, navigating to Customizations, and then choosing Developer Resources. The URL is shown under Organization Service.

To list the supported command-line parameters, use the following command.

Copy Code
CrmSvcUtil.exe /?

When you run the tool against Microsoft Dynamics CRM Online using the Microsoft account identity provider, you no longer have to supply the deviceid and devicepassword parameters from the command line. The tool registers your device automatically. However, you can manually register your device and obtain values for these parameters by first compiling and running the DeviceRegistration code sample as described here.

Generate your individual device ID and password

  1. Open and build the DeviceRegistration project: SDK\Tools\DeviceRegistration\DeviceRegistration.csproj.

  2. Run the executable file from the command line. To register your device, set the /operation parameter to Register.

    Copy Code
    C:\deviceregistration.exe /operation:Register

  3. Copy the displayed device ID and password values and use them as the deviceid and devicepassword parameter values when you run the CrmSvcUtil tool.

Parameters

The following table lists the code generation tool parameters and a gives a brief description of their use.

Parameter | Shortcut | Description | Required
deviceid | di | Device ID used when you connect to the Online server for authentication. Only required if the device ID has not been stored on disk in the %USERPROFILE%\LiveDeviceID folder. Only used with the Microsoft account identity provider. | False
devicepassword | dp | Device password that is used when you connect to the Online server for authentication. Only required if the device password has not been stored on disk in the %USERPROFILE%\LiveDeviceID folder. Only used with the Microsoft account identity provider. | False
domain | d | The domain to authenticate against when you connect to the server. | False
url |  | The URL for the Organization service. | True
out | o | The file name for the generated code. | True
language | l | The language to generate the code in. This can be either “CS” or “VB”. The default value is “CS”. | False
namespace | n | The namespace for the generated code. The default is the global namespace. | False
username | u | The user name to use when you connect to the server for authentication. | False
password | p | The password to use when you connect to the server for authentication. | False
servicecontextname |  | The name of the generated organization service context class. If no value is supplied, no service context is created. | False
help | ? | Show usage information. | False
nologo |  | Suppress the banner at runtime. | False
generateActions |  | Generate request and response classes for actions. |

Usage examples

The following examples show how to use of the code generation tool from the command line for each deployment type. Note that user name and password are optional parameters. If your credentials for the target Microsoft Dynamics CRM server are stored in the Windows credential vault, you do not have to provide them to run the code generation tool.

Claims authentication – Active Directory

The following sample shows how to run the code generation tool by using claims authentication in Active Directory. Note the use of https because this sample server is using Secure Sockets Layer (SSL).

Copy Code
CrmSvcUtil.exe /url:https://myport:555/MyOrg/XRMServices/2011/Organization.svc /out:GeneratedCode.cs
   /username:administrator /password:password

Microsoft Dynamics CRM Online

The following sample shows how to run the code generation tool for Microsoft Dynamics CRM Online. The first example is for the Microsoft account identity provider and the second is for the Office 365 identity provider.

Copy Code
CrmSvcUtil.exe /url:https://myorg.api.crm.dynamics.com/XRMServices/2011/Organization.svc    /out:GeneratedCode.cs /username:"myname@live.com" /password:"myp@ssword!"
Copy Code
CrmSvcUtil.exe /url:https://myorg.api.crm.dynamics.com/XRMServices/2011/Organization.svc    /out:GeneratedCode.cs /username:"myname@myorg.onmicrosoft.com" /password:"myp@ssword!"

Claims authentication - IFD

The following sample shows how to run the code generation tool using claims authentication.

Copy Code
CrmSvcUtil.exe /url:https://myorg.crm.com:555/XRMServices/2011/Organization.svc     /out:GeneratedCode.cs /username:administrator /password:p@ssword!

Use the configuration File

The CrmSvcUtil.exe.config configuration file must be in the same folder as the CrmSvcUtil.exe tool. The configuration file uses the standard key/value pairs in the appSettings section. However, if you enter a value at the command line, that value will be used instead of the one in the configuration file. Any key/value pairs found in the application configuration file that do not match any of the expected parameters are ignored.

Do not include the url and namespace parameters in the configuration file. These must be entered from the command line when the CrmSvcUtil.exe tool is being run.

The following sample shows how to configure the output file and the domain name parameters in the application configuration file using shortcut keys.

Xml Copy Code
<appSettings>    <add key="o" value="CrmProxy.cs"/>    <add key="d" value="mydomain"/></appSettings>

Enable tracing

To enable tracing when you run the tool, add the following lines to the configuration file:

Xml Copy Code
<system.diagnostics>
   <trace autoflush="false" indentsize="4">
      <listeners>
         <add name="configConsoleListener" type="System.Diagnostics.ConsoleTraceListener">
            <filter type="System.Diagnostics.EventTypeFilter" initializeData="Error" />
         </add>
      </listeners>
   </trace>
</system.diagnostics>

See Also

Tasks

Run a simple program using Microsoft Dynamics CRM web services

Concepts

Browse the metadata for your organization
Create extensions for the code generation tool
Use the early-bound entity classes for create, update, and delete
Troubleshooting tips

Other Resources

Developer tools

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create extensions for the code generation tool

You can extend the functionality of the code generation tool by specifying additional command-line parameters and parameter values. To specify a parameter, add the following to the command line: /<parametername>:<class name>,<assembly name>. Note that assembly name does not include the .dll extension. As an alternative, you can add the equivalent value to the config file in the format “<add key=”<parametername>” value=”<class name>,<assembly name>” />”.

The following table lists the parameters that you can use.

Parameter name | Interface Name | Description
/codecustomization | ICustomizeCodeDomService | Called after the CodeDOM generation has been completed, assuming the default instance of ICodeGenerationService. It is useful for generating additional classes, such as the constants in picklists.
/codewriterfilter | ICodeWriterFilterService | Called during the process of CodeDOM generation, assuming the default instance of ICodeGenerationService, to determine whether a specific object or property should be generated.
/codewritermessagefilter | ICodeWriterMessageFilterService | Called during the process of CodeDOM generation, assuming the default instance of ICodeGenerationService, to determine whether a specific message should be generated. This should not be used for requests/responses as these are already generated in Microsoft.Crm.Sdk.Proxy.dll and Microsoft.Xrm.Sdk.dll.
/metadataproviderservice | IMetadataProviderService | Called to retrieve the metadata from the server. This may be called multiple times during the generation process, so the data should be cached.
/codegenerationservice | ICodeGenerationService | Core implementation of the CodeDOM generation. If this is changed, the other extensions may not behave in the manner described.
/namingservice | INamingService | Called during the CodeDOM generation to determine the name for objects, assuming the default implementation.

The implementation of these interfaces must have one of the following constructors:

MyNamingService()
MyNamingService(INamingService defaultService)
MyNamingService(IDictionary<string, string> parameters)
MyNamingService(INamingService defaultService, IDictionary<string, string> parameters)

The Microsoft.Crm.Services.Utility namespace is defined in CrmSvcUtil.exe. Add a reference to CrmSvcUtil.exe in your Microsoft Visual Studio code generation tool extension projects.

Sample extension to generate enumerations for option sets

The following sample code demonstrates how to write an extension.

C# Copy Code
using System;

using Microsoft.Crm.Services.Utility;
using Microsoft.Xrm.Sdk.Metadata;

/// <summary>
/// Sample extension for the CrmSvcUtil.exe tool that generates early-bound
/// classes for custom entities.
/// </summary>
public sealed class BasicFilteringService : ICodeWriterFilterService
{
    public BasicFilteringService(ICodeWriterFilterService defaultService)
    {
        this.DefaultService = defaultService;
    }

    private ICodeWriterFilterService DefaultService { get; set; }

    bool ICodeWriterFilterService.GenerateAttribute(AttributeMetadata attributeMetadata, IServiceProvider services)
    {
        return this.DefaultService.GenerateAttribute(attributeMetadata, services);
    }

    bool ICodeWriterFilterService.GenerateEntity(EntityMetadata entityMetadata, IServiceProvider services)
    {
        if (!entityMetadata.IsCustomEntity.GetValueOrDefault()) { return false; }
        return this.DefaultService.GenerateEntity(entityMetadata, services);
    }

    bool ICodeWriterFilterService.GenerateOption(OptionMetadata optionMetadata, IServiceProvider services)
    {
        return this.DefaultService.GenerateOption(optionMetadata, services);
    }

    bool ICodeWriterFilterService.GenerateOptionSet(OptionSetMetadataBase optionSetMetadata, IServiceProvider services)
    {
        return this.DefaultService.GenerateOptionSet(optionSetMetadata, services);
    }

    bool ICodeWriterFilterService.GenerateRelationship(RelationshipMetadataBase relationshipMetadata, EntityMetadata otherEntityMetadata,
    IServiceProvider services)
    {
        return this.DefaultService.GenerateRelationship(relationshipMetadata, otherEntityMetadata, services);
    }

    bool ICodeWriterFilterService.GenerateServiceContext(IServiceProvider services)
    {
        return this.DefaultService.GenerateServiceContext(services);
    }
}

You can find this sample code and the GeneratePicklistEnums sample extension in the following folder SampleCode\CS\CrmSvcUtilExtensions of the SDK. Download the Microsoft Dynamics CRM SDK package. The GeneratePicklistEnums sample extension outputs a source code file that contains enumerations for all option sets, state codes, and status codes. For an example of how to use these enumerations, see the SampleCode\CS\QuickStart sample.

See Also

Tasks

Run a simple program using Microsoft Dynamics CRM web services

Concepts

Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)
Use the early-bound entity classes for create, update, and delete
Troubleshooting tips

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Browse the metadata for your organization

You can use the Entity Metadata Browser to view entities and their properties in Microsoft Dynamics CRM. The Entity Metadata Browser is a managed solution available in the downloadable files available in the Microsoft Dynamics CRM SDK at SDK\Tools\MetadataBrowser\MetadataBrowser_2_0_1_2_managed.zip.

The metadata browser supports Mozilla Firefox, Google Chrome, and Internet Explorer 9, Internet Explorer 10, or Internet Explorer 11.

After you install the Entity Metadata Browser solution, open the managed solution by double-clicking the row in the solutions list and view the Configuration page to view information about the Entity Metadata Browser and buttons to launch two different views.

Tip
After you launch one of the views, add the view to you favorites using the Internet Explorer Ctrl+D keyboard shortcut. Other browsers provide alternative ways to save bookmarks.

On the configuration page, you can open the Metadata Browser where you can perform the following actions:

  • Select an entity to view using the Entity Metadata Browser.
  • Open the selected entity form in the default organization, if the entity supports this.
  • Perform a text search to filter displayed entities using the following entity properties: SchemaName, LogicalName, DisplayName, ObjectTypeCode, or MetadataId.
  • Filter entities by any entity property values.
  • Filter the properties displayed for the selected entity.

You can also open the Entity Metadata Browser where you can perform the following actions for a single entity:

  • View all the properties for the entity and filter the properties displayed.
  • Open the selected entity edit form in the default organization, if the entity supports this.
  • Change the entity that you want to view.
  • View the entity attributes in a master/detail view. With this view you can:
    • Open the selected attribute form in the default organization, if the attribute supports this.
    • Perform a text search to filter displayed attributes using the following attribute properties: SchemaName, LogicalName, DisplayName, or MetadataId.
    • Filter attributes by any attribute property values.
    • Filter the properties displayed for the selected attribute.
  • View entity relationships. With these views you can:
    • Open the selected relationship form in the default organization, if the relationship supports this.
    • Perform a text search to filter displayed relationships using values relevant to the type of relationship.
    • Filter the relationship by any relationship property value.
  • View entity privileges. With this view you can:
    • Filter the displayed privilege using the PrivilegeId.

When viewing the entity detail properties, you’ll see that many complex properties are expandable. The most useful value is displayed with a link that allows toggling to a more detailed view. The detailed view reflects the structure of the data if you were to retrieve it programmatically. The detailed view also reveals other relevant data that can be retrieved in the same area, for example, if any localized labels are present for Display Name properties.

To copy text from the page, simply select the text and use the Ctrl+C keyboard shortcut or the context menu Copy command.

See Also

Concepts

Customize entity metadata
Visual Studio and the .NET Framework
Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)
Analyze plug-in performance

Other Resources

Developer tools
Extend the metadata model
Solution tools for team development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Analyze plug-in performance

The Plug-in Profiler is a tool that profiles the execution of plug-ins and custom workflow activities for an enhanced debugging experience in Microsoft Visual Studio. This tool, which can be run from the Command Prompt window or from within the Plug-in Registration tool, makes developing custom code against Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update quicker and easier. In addition, users can profile the execution of failing code and send the results to the developer of the code or independent software vendor (ISV) for analysis. The developer can replay the plug-in or custom workflow activity execution and debug the code remotely even when disconnected from the Microsoft Dynamics CRM server.

The tool can be used in either the debug or replay mode. Each of these modes is described in the following sections.

In This Topic

Debug a plug-in using the plug-in profiler

Replay plug-in execution

Run the plug-in profiler standalone

Debug a plug-in using the plug-in profiler

  1. Run the Plug-in Registration tool. You can find the tool’s executable file in the Tools\PluginRegistration folder of the SDK. Download the Microsoft Dynamics CRM SDK package.

  2. Click or tap CREATE NEW CONNECTION to connect to a Microsoft Dynamics CRM server and organization. For more information on connecting to a server and organization, refer to the SDK topic: Walkthrough: Register a plug-in using the plug-in registration tool.

  3. Register a plug-in and step on the Microsoft Dynamics CRM server. Keep a copy of the debug compiled plug-in assembly on the computer where you are running the tool.

  4. In the toolbar for the target organization, select Install Profiler. You will now see a Plug-in Profiler node in the list.

  5. Select a plug-in step and click Start Profiling in the toolbar to begin profiling. You can choose how the profiler executes in the displayed Profiler Settings dialog.

  6. Perform the operation in Microsoft Dynamics CRM that causes the plug-in to run. For example, if the step is configured for an update to an account, then update an account.

  7. If you have selected the Exception option in the Profiler Settings dialog, after the plug-in throws an exception and the Business Process Error dialog is displayed, click Download Log File and save this file. Alternately, if the plug-in does not throw an exception, click Stop Profiling.

  8. In the Plug-in Registration tool, click Debug.

  9. In the Debug an Existing Plug-in dialog box, provide the requested information in the Setup tab. Enter the location of the previously saved log file in the Profile field. Enter or choose the location of the plug-in assembly and the class name of the plug-in that was executed.

  10. Launch Microsoft Visual Studio and attach the debugger to the PluginRegistration.exe process.

  11. Set a breakpoint in the plug-in code.

  12. Click Start Execution in the Debug an Existing Plug-in dialog box.

  13. After a slight delay, the plug-in will execute using the same execution context that was passed to it by the Microsoft Dynamics CRM server and the debugger will stop execution on the breakpoint that you previously set.

  14. Continue debugging the plug-in as you would normally do. Any traces that the plug-in outputs are shown in the Debug an Existing Plug-in dialog box.

At this point you can alter the plug-in code, build it, re-attach the debugger to the PluginRegistration.exe process, and click Start Execution to continue with your debugging session. While performing these operations, you do not need to close the Debug an Existing Plug-in form.

You do not need to re-deploy the plug-in to the Microsoft Dynamics CRM server until after you have fixed the code problem. This debugging scenario works even if you have an optimized version of the plug-in on the server and a debug version of the plug-in on the computer where you are debugging.

Replay plug-in execution

Replaying plug-in execution does not require a connection to a Microsoft Dynamics CRM server and organization. The advantage of this method is that you can obtain the plug-in execution profile from a customer and debug the plug-in remotely. A restriction of the replay feature is that you cannot change the sequence of calls your plug-in code makes in the debugger while you are debugging.

The replay feature provides the plug-in with a snapshot of the call data and event execution context from the Microsoft Dynamics CRM server. You are getting the same events, GUIDs, and so on from calls to the Organization service but no data is being modified on the server as you debug the plug-in. During the debugging procedure in the previous section, the plug-in actually connects to the server and makes calls in real time.

Replay plug-in execution

  1. Launch Microsoft Visual Studio and attach the debugger to the PluginRegistration.exe process.

  2. Click REPLAY PLUG-IN EXECUTION.

  3. Enter the log and plug-in assembly locations in the dialog box.

  4. Click Start Execution.

  5. Debug the plug-in as you would normally.

Run the plug-in profiler standalone

The profiler can be executed from a Command Prompt window independent of the Plug-in Registration tool. This is useful to obtain the plug-in profile log from a customer's Microsoft Dynamics CRM server to debug a failed plug-in. A developer can then use that log to replay the plug-in's execution in the Plug-in Registration tool and debug the plug-in usingMicrosoft Visual Studio.

Run the plug-in profiler from a command prompt

  1. Open a Command Prompt window and set the working directory to the Tools\PluginRegistration folder in the SDK download.

  2. Type the command: PluginProfiler.Debugger.exe /?.

  3. Review the supported parameter list and re-run the PluginProfiler.Debugger.exe program with the appropriate parameters.

See Also

Concepts

Register and Deploy Plug-Ins
Debug a plug-In

Other Resources

Developer tools
Solution tools for team development
Plug-in development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Solution tools for team development

A Microsoft Dynamics CRM solution is a compressed (.zip) file that contains multiple customized components that have been exported from a Microsoft Dynamics CRM server so that they may be transported and imported into another server. However, a solution file is a single binary file that does not lend itself to source code control or team development. There is no way for multiple developers to work on the custom components in the solution.

The SolutionPackager tool, available in the Microsoft Dynamics CRM SDK download, resolves the problem of source code control and team development of solution files. The tool identifies individual components in the compressed solution file and extracts them out to individual files. The tool can also re-create a solution file by packing the files that had been previously extracted. This enables multiple people to work independently on a single solution and extract their changes into a common location. Because each component in the solution file is broken into multiple files, it becomes possible to merge customizations without overwriting prior changes. A secondary use of the SolutionPackager tool is that it can be invoked from an automated build process to generate a compressed solution file from previously extracted component files without needing an active Microsoft Dynamics CRM server. Download the Microsoft Dynamics CRM SDK package.

In This Section

Use the SolutionPackager tool to compress and extract a solution file

Use source control with solution files

Solution component file reference (SolutionPackager)

Related Sections

Developer tools

Package and distribute extensions using solutions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the SolutionPackager tool to compress and extract a solution file

SolutionPackager is a tool that can reversibly decompose a Microsoft Dynamics CRM compressed solution file into multiple XML files and other files so that these files can be easily managed by a source control system. The following sections show you how to run the tool and how to use the tool with managed and unmanaged solutions.

In This Topic

Where to Find the SolutionPackager tool

SolutionPackager command line arguments

Use the /map command argument

  • Folder mapping
  • File to file mapping
  • File to path mapping
  • Example mapping

Managed and unmanaged solutions

Where to find the SolutionPackager tool

The SolutionPackager.exe tool can be found in the Bin folder of the Microsoft Dynamics CRM SDK download. Download the Microsoft Dynamics CRM SDK package.

SolutionPackager command-line arguments

SolutionPackager is a command-line tool that can be invoked with the parameters identified in the following table.

Argument | Description
/action: {Extract|Pack} | Required. The action to perform. The action can be either to extract a solution .zip file to a folder, or to pack a folder into a .zip file.
/zipfile: <file path> | Required. The path and name of a solution .zip file. When extracting, the file must exist and will be read from. When packing, the file is replaced.
/folder: <folder path> | Required. The path to a folder. When extracting, this folder is created and populated with component files. When packing, this folder must already exist and contain previously extracted component files.
/packagetype: {Unmanaged|Managed|Both} | Optional. The type of package to process. The default value is Unmanaged. This argument may be omitted in most occasions because the package type can be read from inside the .zip file or component files. When extracting and Both is specified, managed and unmanaged solution .zip files must be present and are processed into a single folder. When packing and Both is specified, managed and unmanaged solution .zip files will be produced from one folder. For more information, see the section on working with managed and unmanaged solutions later in this topic.
/allowWrite:{Yes|No} | Optional. The default value is Yes. This argument is used only during an extraction. When /allowWrite:No is specified, the tool performs all operations but is prevented from writing or deleting any files. The extract operation can be safely assessed without overwriting or deleting any existing files.
/allowDelete:{Yes|No|Prompt} | Optional. The default value is Prompt. This argument is used only during an extraction. When /allowDelete:Yes is specified, any files present in the folder specified by the /folder parameter that are not expected are automatically deleted. When /allowDelete:No is specified, no deletes will occur. When /allowDelete:Prompt is specified, the user is prompted through the console to allow or deny all delete operations. Note that if /allowWrite:No is specified, no deletes will occur even if /allowDelete:Yes is also specified.
/clobber | Optional. This argument is used only during an extraction. When /clobber is specified, files that have the read-only attribute set are overwritten or deleted. When not specified, files with the read-only attribute aren’t overwritten or deleted.
/errorlevel: {Off|Error|Warning|Info|Verbose} | Optional. The default value is Info. This argument indicates the level of logging information to output.
/map: <file path> | Optional. The path and name of an .xml file containing file mapping directives. When used during an extraction, files typically read from inside the folder specified by the /folder parameter are read from alternate locations as specified in the mapping file. During a pack operation, files that match the directives aren’t written.
/nologo | Optional. Suppress the banner at runtime.
/log: <file path> | Optional. A path and name to a log file. If the file already exists, new logging information is appended to the file.
@ <file path> | Optional. A path and name to a file that contains command-line arguments for the tool.
/sourceLoc: <string> | Optional. This argument generates a template resource file, and is valid only on extract. Possible values are auto or an LCID/ISO code for the language you want to export. When this argument is used, the string resources from the given locale are extracted as a neutral .resx file. If auto or just the long or short form of the switch is specified, the base locale or the solution is used. You can use the short form of the command: /src.
/localize | Optional. Extract or merge all string resources into .resx files. You can use the short form of the command: /loc.

Use the /map command argument

The following discussion details the use of the /map argument to the SolutionPackager tool.

Files that are built in an automated build system, such as .xap Silverlight files and plug-in assemblies, are typically not checked into source control. Web resources may already be present in source control in locations that are not directly compatible with the SolutionPackager tool. By including the /map parameter, the SolutionPackager tool can be directed to read and package such files from alternate locations and not from inside the Extract folder as it would typically be done. The /map parameter must specify the name and path to an XML file containing mapping directives that instruct the SolutionPackager to match files by their name and path, and indicate the alternate location to find the matched file. The following information applies to all directives equally.

  • Multiple directives may be listed including those that will match identical files. Directives listed early in the file take precedence over those listed later.
  • If a file is matched to any directive, it must be found in at least one alternative location. If no matching alternatives are found, the SolutionPackager will issue an error.
  • Folder and file paths may be absolute or relative. Relative paths are always evaluated from the folder specified by the /folder parameter.
  • Environment variables may be specified by using a %variable% syntax.
  • A folder wildcard “**” may be used to mean “in any sub-folder”. It can only be used as the final part of a path, for example: “c:\folderA\**”.
  • File name wildcards may be used only in the forms “*.ext” or “*.*”. No other pattern is supported.

The three types of directives mappings are described here, along with an example that shows you how to use them.

Folder mapping

The following table provides detailed information on folder mapping.

Xml Format

<Folder map="folderA" to="folderB" />

Description

File paths that match “folderA” will be switched to “folderB”.

  • The hierarchy of subfolders under each must exactly match.
  • Folder wildcards are not supported.
  • No file names may be specified.

Examples

Xml Copy Code
<Folder map="folderA" to="folderB" />
<Folder map="folderA\folderB" to="..\..\folderC\" />
<Folder map="WebResources\subFolder" to="%base%\WebResources" />

File To file mapping

The following table provides detailed information on file-to-file mapping.

Xml Format

<FileToFile map="path\filename.ext" to="path\filename.ext" />

Description

Any file matching the map parameter will be read from the name and path specified in the to parameter.

For the map parameter:

  • A file name must be specified. The path is optional. If no path is specified, files from any folder may be matched.
  • File name wildcards are not supported.
  • The folder wildcard is supported.

For the to parameter:

  • A file name and path must be specified.
  • The file name may differ from the name in the map parameter.
  • File name wildcards are not supported.
  • The folder wildcard is supported.

Examples

Xml Copy Code
<FileToFile map="assembly.dll" to="c:\path\folder\assembly.dll" />
<FileToFile map="PluginAssemblies\**\this.dll" to="..\..\Plugins\**\that.dll" />
<FileToFile map="Webresrouces\ardvark.jpg" to="%SRCBASE%\CrmPackage\WebResources\JPG format\aardvark.jpg" />

File to path mapping

The following table provides detailed information on file-to-path mapping.

Xml Format

<FileToPath map="path\filename.ext" to="path" />

Description

Any file matching the map parameter is read from the path specified in the to parameter.

For the map parameter:

  • A file name must be specified. The path is optional. If no path is specified, files from any folder may be matched.
  • File name wildcards are supported.
  • The folder wildcard is supported.

For the to parameter:

  • A path must be specified.
  • The folder wildcard is supported.
  • A file name must not be specified.

Examples

Xml Copy Code
<FileToPath map="assembly.dll" to="c:\path\folder" />
<FileToPath map="PluginAssemblies\**\this.dll" to="..\..\Plugins\bin\**" />
<FileToPath map="*.jpg" to="%SRCBASE%\CrmPackage\WebResources\JPG format\" />
<FileToPath map="*.*" to="..\..\%ARCH%\%TYPE%\drop" />

Example mapping

The following XML code sample shows a complete mapping file that enables the SolutionPackager tool to read any web resource and the two default generated assemblies from a Developer Toolkit project named CRMDevTookitSample.

Xml Copy Code
<?xml version="1.0" encoding="utf-8"?>
<Mapping>
       <!-- Match specific named files to an alternate folder -->
       <FileToFile map="CRMDevTookitSamplePlugins.dll" to="..\..\Plugins\bin\**\CRMDevTookitSample.plugins.dll" />
       <FileToFile map="CRMDevTookitSampleWorkflow.dll" to="..\..\Workflow\bin\**\CRMDevTookitSample.Workflow.dll" />
       <!-- Match any file in and under WebResources to an alternate set of sub-folders -->
       <FileToPath map="WebResources\*.*" to="..\..\CrmPackage\WebResources\**" />
       <FileToPath map="WebResources\**\*.*" to="..\..\CrmPackage\WebResources\**" />
</Mapping>

Managed and unmanaged solutions

A Microsoft Dynamics CRM compressed solution (.zip) file can be exported in one of two types as shown here.

Managed solution

A completed solution ready to be imported into an organization. Once imported, components can’t be added or removed, although they can optionally allow further customization. This is recommended when development of the solution is complete.

Unmanaged solution

An open solution with no restrictions on what can be added, removed, or modified. This is recommended during development of a solution.

The format of a compressed solution file will be different based on its type, either managed or unmanaged. The SolutionPackager can process compressed solution files of either type. However, the tool can’t convert one type to another. The only way to convert solution files to a different type, for example from unmanaged to managed, is by importing the unmanaged solution .zip file into a Microsoft Dynamics CRM server and then exporting the solution as a managed solution.

The SolutionPackager can process unmanaged and managed solution .zip files as a combined set via the /PackageType:Both parameter. To perform this operation, it is necessary to export your solution twice as each type, naming the .zip files as follows.

Unmanaged .zip file: AnyName.zip

Managed .zip file: AnyName_managed.zip

The tool will assume the presence of the managed zip file in the same folder as the unmanaged file and extract both files into a single folder preserving the differences where managed and unmanaged components exist.

After a solution has been extracted as both unmanaged and managed, it is possible from that single folder to pack both, or each type individually, using the /PackageType parameter to specify which type to create. When specifying both, two .zip files will be produced using the naming convention as above. If the /PackageType parameter is missing when packing from a dual managed and unmanaged folder, the default is to produce a single unmanaged .zip file.

Troubleshooting

If you use Microsoft Visual Studio 2012 to edit resource files created by the solution packager, you may receive a message when you repack similar to this: “Failed to determine version id of the resource file <filename>.resx the resource file must be exported from the solutionpackager.exe tool in order to be used as part of the pack process.” This happens because Visual Studio replaces the resource file’s metadata tags with data tags.

Workaround

  1. Open the resource file in your favorite text editor and locate and update the following tags:

    Xml Copy Code
    <data name="Source LCID" xml:space="preserve">
<data name="Source file" xml:space="preserve">
<data name="Source package type" xml:space="preserve">
<data name="SolutionPackager Version" mimetype="application/x-microsoft.net.object.binary.base64">

  2. Change the node name from <data> to <metadata>.

    For example, this string:

    Xml Copy Code
      <data name="Source LCID" xml:space="preserve">
    <value>1033</value>
  </data>

    Changes to:

    Xml Copy Code
      <metadata name="Source LCID" xml:space="preserve">
    <value>1033</value>
  </metadata>

This allows the solution packager to read and import the resource file. This problem has only been observed when using the Visual Studio Resource editor.

See Also

Reference

Solution component file reference (SolutionPackager)

Concepts

Use source control with solution files
Introduction to solutions

Other Resources

Solution tools for team development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use source control with solution files

The SolutionPackager tool can be used with any source control system. After a solution .zip file has been extracted to a folder, simply add and submit the files to your source control system. These files can then be synchronized on another computer where they can be packed into a new identical solution .zip file.

An important aspect when using extracted component files in source control is that adding all the files into source control may cause unnecessary duplication. See the Solution component file reference (SolutionPackager) to see which files are generated for each component type and which files are recommended for use in source control.

As further customizations and changes are necessary for the solution, developers should edit or customize components through existing means, export again to create a .zip file, and extract the compressed solution file into the same folder.

Important
Manual editing of extracted component files and .zip files is not supported.

When the SolutionPackager tool extracts the component files it will not overwrite existing component files of the same name if the file contents are identical. In addition, the tool honors the read-only attribute on component files producing a warning in the console window that particular files were not written. This enables the user to check out, from source control, the minimal set of files that are changing. The /clobber parameter can be used to override and cause read-only files to be written or deleted. The /allowWrite parameter can be used to assess what impact an extract operation has without actually causing any files to be written or deleted. Use of the /allowWrite parameter with verbose logging is effective.

After the extract operation is completed with the minimal set of files checked out from source control, a developer may submit the changed files back into source control, as is done with any other type of source file.

In This Topic

Team development

Create a solution

Modify a solution

Team development

When there are multiple developers working on the same solution component a conflict might arise where changes from two developers result in changes to a single file. This occurrence is minimized by decomposing each individually editable component or subcomponent into a distinct file. Consider the following example.

  1. Developer A and B are both working on the same solution.
  2. On independent computers, they both get the latest sources of the solution from source control, pack, and import an unmanaged solution .zip file into independent Microsoft Dynamics CRM organizations.
  3. Developer A customizes the “Active Contacts” system view and the main form for the Contact entity.
  4. Developer B customizes the main form for the Account entity and changes the “Contact Lookup View”.
  5. Both developers export an unmanaged solution .zip file and extract.
    1. Developer A will need to check out one file for the Contact main form, and one file for the “Active Contacts” view.
    2. Developer B will need to check out one file for the Account main form, and one file for the “Contact Lookup View”.
  6. Both developers may submit, in any order, as their respective changes touched separate files.
  7. After both submissions are complete, they can repeat step #2 and then continue to make further changes in their independent organizations. They each have both sets of changes, with no overwrites of their own work.

The previous example works only when there are changes to separate files. It is inevitable that independent customizations require changes within a single file. Based on the example shown above, consider that developer B customized the “Active Contacts” view while developer A was also customizing it. In this new example, the order of events becomes important. The correct process to reconcile this predicament, written out in full, is as follows.

  1. Developer A and B are both working on the same solution.
  2. On independent computers, they both get the latest sources of the solution from source control, pack, and import an unmanaged solution .zip file into independent organizations.
  3. Developer A customizes the “Active Contacts” system view and the main form for the Contact entity.
  4. Developer B customizes the main form for the Account entity and changes the “Active Contacts”.
  5. Both developers export an unmanaged solution . zip file and extract.
    1. Developer A will need to check out one file for the Contact main form, and one file for the “Active Contacts” view.
    2. Developer B will need to check out one file for the Account main form, and one file for the “Active Contacts” view.
  6. Developer A is ready first.
    1. Before he submits to source control he must get latest sources to ensure no prior check-ins conflict with his changes.
    2. There are no conflicts so he is able to submit.
  7. Developer B is ready next following developer A.
    1. Before he submits he must get the latest sources to ensure no prior check-ins conflict with his changes.
    2. There is a conflict because the file for “Active Contacts” has been modified since he last retrieved the latest sources.
    3. Developer B must reconcile the conflict. It is possible the capabilities of the source control system in use may aide this process; otherwise the following choices are all viable.
      1. Developer B, through source control history, if available, can see that the developer A made the prior change. Through direct communication they can discuss each change. Then developer B only has to update his organization with the agreed resolution. He then exports, extracts, and overwrites the conflicting file and submits.
      2. Allow source control to overwrite his local file. Developer B packs the solution and imports it into his organization, then assesses the state of the view and re-customizes it as necessary. Next, he may export, extract, and overwrite the conflicting file.
      3. If the prior change can be deemed unnecessary, developer B allows his copy of the file to overwrite the version in source control and submits.

Whether working on a shared organization or independent organizations, team development of Microsoft Dynamics CRM solutions requires those actively working on a common solution to be aware of the work of others. The SolutionPackager tool does not fully remove this need but it does enable easy merging of non-conflicting changes at the source control level, and it proactively highlights the concise components where conflicts have arisen.

The next sections are the generic processes to effectively use the SolutionPackager tool in source control when developing with teams. These work equally with independent organizations or shared development organizations, though with shared organizations the export and extract will naturally include all changes present within the solution, not just those made by the developer performing the export. Similarly, when importing a solution .zip file the natural behavior to overwrite all components will occur.

Create a solution

The following procedure identifies the typical steps used when first creating a solution.

  1. In a clean organization, create a solution on Microsoft Dynamics CRM server, and then add or create components as necessary.
  2. When you are ready to check in, do the following.
    1. Export the unmanaged solution.
    2. Using the SolutionPackager tool, extract the solution into component files.
    3. From those extracted component files, add the necessary files to source control.
    4. Submit these changes to source control.

Modify a solution

The following procedure identifies the typical steps used when modifying an existing solution.

  1. Synchronize or get the latest solution component file sources.
  2. Using the SolutionPackager tool, pack component files into an unmanaged solution .zip file.
  3. Import the unmanaged solution file into an organization.
  4. Customize and edit the solution as necessary.
  5. When you are ready to check the changes into source control, do the following.
    1. Export the unmanaged solution.
    2. Using the SolutionPackager tool, extract the exported solution into component files.
    3. Synchronize or get the latest sources from source control.
    4. Reconcile if any conflicts exist.
    5. Submit the changes to source control.

Steps 2 and 3 must be done before further customizations occur in the development organization. Within step 5, step b must be completed before step c.

See Also

Reference

Solution component file reference (SolutionPackager)

Concepts

Use the SolutionPackager tool to compress and extract a solution file

Other Resources

Solution tools for team development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Solution component file reference (SolutionPackager)

This topic describes the folder structure and file naming scheme used by the SolutionPackager tool. The tool is used to decompose (unpack) Microsoft Dynamics CRM solution files into XML files that can be managed by a source code control system. The tool can also compile (pack) these individual XML files into a solution file that can be imported into Microsoft Dynamics CRM. For more information about the SolutionPackager tool, see Solution tools for team development.

The following tables describe the files that will be created for each solution component type, and which of these files are less suited to inclusion in source control. The folders indicated in the tables are all relative to the folder specified in the /folder parameter of the SolutionPackager command.

In This Topic

Component: Entity

Component: Option set

Component: Entity Relationship

Component: Ribbon customization

Component: Site map

Component: Web resources

Component: Role

Component: Connection role

Component: Dashboard

Component: Workflow

Component: Email template

Component: Contract template

Component: Kb article template

Component: Mail merge template

Component: PluginAssembly

Component: SdkMessageProcessingStep

Component: ServiceEndpoint

Component: Reports

Component: EntityMap

Component: Entity

Differs in managed solutions: Yes

Notes:

  1. Each entity has a distinct folder.
  2. Each Form, View & Visualization gets their own file in the respective sub-folder.
  3. The Form file names will vary by Managed or Unmanaged Solution types.
  4. Direct editing of RibbonDiff.xml to customize entity specific ribbons is supported.
  5. Manual editing of the XML files under the FormXml and SavedQueries folders is supported but optional.

Files:

\Entities\<Entity Schema Name>\

Entity.xml
RibbonDiff.xml

FormXml\Main\

{guid 1}.xml
{guid 1_managed}.xml
{guid n}.xml
{guid n_managed}.xml

FormXml\Mobile\

{guid 1}.xml
{guid 1_managed}.xml
{guid n}.xml
{guid n_managed}.xml

SavedQueries\

{guid 1}.xml
{guid n}.xml

Visualizations\

{guid 1}.xml
{guid n}.xml

Component: Option set

Differs in managed solutions: No

Notes:

  1. Each option set is stored in a distinct file.

Files:

\OptionSets\

<schema name 1>.xml
<schema name n>.xml

Component: Entity relationship

Differs in managed solutions: Yes

Notes:

  1. Each entity has a distinct file that contains all relationships where for:
    1. N:N it is the first listed entity
    2. 1:N it is the referenced entity

Files:

\Other\Relationships\

<Entity schema name 1>.xml
<Entity schema name n>.xml

Component: Ribbon customization

Differs in managed solutions: No

Notes:

  1. All entity specific ribbon XML can be found in the respective folder for that entity. All other ribbon XML will be in this file.
  2. Direct editing of RibbonCustomizations.xml to customize the global ribbon is supported.

Files:

\Other\RibbonCustomizations.xml

Component: Site map

Differs in managed solutions: Yes

Notes:

  1. Sitemap XML format is different for unmanaged & managed solutions. Expect the file to be named as shown here. When extracting both package types, both files are present.

Files:

\Other\

SiteMap.xml
SiteMap_managed.xml

Component: Web resources

Differs in managed solutions: No

Notes:

  1. The raw web resource is stored as a distinct file. The forward slash (/) characters are used to create folders.
  2. The web resource metadata is stored with a similar file name ending in .data.xml.
  3. It is recommended that the name of a web resource contain the natural file name extension.
  4. Adding the raw files to source control may cause duplication.

Files:

\WebResources\

<name 1>
<name 1>.data.xml
<name n>
<name n>.data.xml

Component: Role

Differs in managed solutions: No

Notes:

  1. Each role is stored in a distinct file.

Files:

\Roles\

<schema name>.xml

Component: Connection role

Differs in managed solutions: No

Notes:

  1. All Connection Roles are stored jointly in one file.

Files:

\Other\ConnectionRoles.xml

Component: Dashboard

Differs in managed solutions: No

Notes:

  1. Each dashboard is stored in a distinct file.

Files:

\Dashboards\

{guid 1}.xml
{guid n}.xml

Component: Workflow

Differs in managed solutions: No

Notes:

  1. The XAML for each workflow is stored in a distinct file.
  2. Metadata for each workflow resides in a similarly named file ending in .data.xml.

Files:

\Workflows\

<XamlFileName 1>.xaml
<XamlFileName 1>.xaml.data.xml
<XamlFileName n>.xaml
<XamlFileName n>.xaml.data.xml

Component: Email template

Differs in managed solutions: No

Notes:

  1. All email template metadata is stored in a single file.
  2. Each email template uses four distinct files per language.

Files:

\Templates\

EmailTemplates.xml

EmailDocuments\

<LCID 1>\{guid 1}\

Body.xsl
Presentation.xml
Subject.xsl
Subjectpresentation.xml

<LCID 1>\{guid n}\

Body.xsl
Presentation.xml
Subject.xsl
Subjectpresentation.xml

<LCID n>\{guid 1}\

Body.xsl
Presentation.xml
Subject.xsl
Subjectpresentation.xml

<LCID n>\{guid n}\

Body.xsl
Presentation.xml
Subject.xsl
Subjectpresentation.xml

Component: Contract template

Differs in managed solutions: No

Notes:

  1. All Contract template metadata is stored in a single file.

Files:

\Templates\ContractTemplates.xml

Component: Kb article template

Differs in managed solutions: No

Notes:

  1. All contract template metadata is stored in a single file.
  2. Each contract template uses two distinct files per language.

Files:

\Templates\

KBArticleTemplates.xml

KBArticleTemplates\

<LCID 1>\{guid 1}\

formatxml.xsl
Structurexml.xml

<LCID 1>\{guid n}\

formatxml.xsl
Structurexml.xml

<LCID n>\{guid 1}\

formatxml.xsl
Structurexml.xml

<LCID n>\{guid n}\

formatxml.xsl
Structurexml.xml

Component: Mail merge template

Differs in managed solutions: No

Notes:

  1. All mail merge template metadata is stored in a single file.
  2. Each mail merge template uses two distinct files per language.
  3. Documents that are shared across multiple templates will be stored in a single distinct file.

Files:

\Templates\

MailMergeTemplates.xml

MailMergeDocuments\

<LCID 1>\{guid 1}\<document name 1>.xml
<LCID 1>\{guid n}\<document name n>.xml
<LCID n>\{guid 1}\<document name 1>.xml
<LCID n>\{guid n}\<document name n>.xml

Component: PluginAssembly

Differs in managed solutions: No

Notes:

  1. Each plug-in assembly will have a distinct file for the raw assembly bytes.
  2. Plug-in assembly metadata is stored in a similar named file ending in .data.xml.
  3. Including the raw assembly in source control is not recommended.

Files:

\PluginAssemblies\

<Assembly Name 1>-{guid 1}\

<Assembly Name 1>.dll
<Assembly Name 1>.dll.data.xml

<Assembly Name n>-{guid n}\

<Assembly Name n>.dll
<Assembly Name n>.dll.data.xml

Component: SdkMessageProcessingStep

Differs in managed solutions: No

Notes:

  1. Each SDK message processing step is stored in a distinct file.

Files:

\SdkMessageProcessingSteps\

{guid 1}.xml
{guid n}.xml

Component: ServiceEndpoint

Differs in managed solutions: No

Notes:

  1. All service end point metadata is jointly stored in one file.

Files:

\PluginAssemblies\ServiceEndpoints.xml

Component: Reports

Differs in managed solutions: No

Notes:

  1. Reports are stored in a distinct sub-folder per language.
  2. Each report has a distinct file within that folder.
  3. Metadata for each report is stored within a similar named file ending in .data.xml.

Files:

\Reports\

ReportSignatureIdMappings.xml

ReportLinks.xml

<LCID 1>\{guid 1}\

<Report Name 1>.rdl
<Report Name 1>.rdl.data.xml

<LCID 1>\{guid n}\

<Report Name n>.rdl
<Report Name n>.rdl.data.xml

<LCID n>\{guid 1}\

<Report Name 1>.rdl
<Report Name 1>.rdl.data.xml

<LCID n>\{guid n}\

<Report Name n>.rdl
<Report Name n>.rdl.data.xml

Component: EntityMap

Differs in managed solutions: No

Notes:

  1. All entity maps are stored in a single file.

Files:

\Other\EntityMaps.xml

See Also

Concepts

Use the SolutionPackager tool to compress and extract a solution file

Other Resources

Solution tools for team development
Programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write mobile and modern apps

Mobile apps are very popular these days. By using industry standard protocols like SOAP and OData in your app code, your modern or mobile apps can connect to the Microsoft Dynamics CRM web services, execute custom business logic, and access organization data. In the following sections, learn how you can develop apps that can access the Microsoft Dynamics CRM web services.

Make sure to check out some of our latest samples for mobile development at code.msdn.microsoft.com.

Mobile Development Helper Code for Dynamics CRM

The Microsoft.Crm.Sdk.Mobile source code sample is a partial re-implementation of the Microsoft Dynamics CRM SDK classes written as a Portable Class Library to facilitate development of store apps for Windows 8.1 desktop, tablets, and phones. The code makes use of the SOAP and OData protocols to issue web service method calls. An organization web service proxy and most of the message response/request classes in the CRM SDK have been implemented. When writing apps that use this code, you don’t have to link to the CRM SDK assemblies to access the organization web service.

CRM Service Utility for Mobile Development

This sample is a custom extension to the CrmSvcUtil.exe program that ships in the Microsoft Dynamics CRM 2013 SDK. The purpose of this program is to generate C# or VB source code containing early-bound entity types and option set types from the metadata of your CRM server. This code can then be included in your mobile app projects. This enables you to make use of both out-of-box and any custom or customized entities in your code.

In This Section

Authenticate the user with the web services

Walkthrough: Register a CRM app with Active Directory

Sample: Windows 8 desktop modern SOAP app

Sample: Windows 8 desktop modern OData app

Related Sections

Software Development Kit for Microsoft Dynamics CRM

Mobile Development Helper Code for Dynamics CRM

CRM Service Utility for Mobile Development

Understanding SOAP

odata.org

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Authenticate the user with the web services

You can use the external client authentication capability of Microsoft Dynamics CRM to develop your own client apps for mobile devices, such as tablets and phones, as well as for the Windows 8 desktop. This capability is also available to non-.NET applications.

In This Topic

Overview of authentication

Technology dependencies

Security

User sign-in and application registration

The client application

OAuth authorization endpoints

OAuth discovery

Specify an OAuth resource

Overview of authentication

Developers who create modern and mobile apps, including apps not built on the .NET Framework, can access Microsoft Dynamics CRM business data through the SOAP and OData endpoints of the organization web service. This web service supports certain authentication capabilities found in the OAuth 2.0 protocol.

The following list describes what is supported for modern and mobile app authentication:

  • Use of JSON web tokens in the HTTP authorization header
  • Authentication for the OData service by external apps (outside the browser)
  • Authentication for the Organization.svc/web (SOAP) service by external applications (outside the browser)

Technology dependencies

The following technology is required to develop and execute external client applications that authenticate with the Microsoft Dynamics CRM OData and SOAP web service endpoints:

  • Claims configuration is required for on-premises deployment.
  • AD FS on Windows Server 2012 R2.

The following technology is optional to develop and execute external client applications that authenticate with the Microsoft Dynamics CRM OData and SOAP web service endpoints:

  • Microsoft Azure Active Directory Authentication Library (ADAL)
    • Microsoft Azure AD Authentication Library for .NET
    • Microsoft Azure AD Authentication Library for iOS
    • Microsoft Azure AD Authentication Library for Android
  • Visual Studio 2012 or 2013

Security

The following security information applies to this authentication feature:

  • The authentication token is stored on the device in protected storage. For the Windows operating system, the Windows Credential Manager is used.
  • The feature makes use of Secure Sockets Layer (SSL) for HTTP requests.

User sign-in and application registration

The following information is related to user sign-in and application registration.

  • User sign-in for the Microsoft Azure Active Directory Authentication Library (ADAL) is handled by a web browser context.
  • Application registration is managed through Azure Active Directory for a CRM Online deployment, and Active Directory Federation Services (AD FS) for on-premises or Internet-facing deployment (IFD). You can use the Microsoft Azure management portal or API to register your app with CRM Online.

The client application

The range of operations that an external client application can perform is summarized in the following list:

  • When using the OData endpoint, Create, Retrieve, Update, and Delete operations are supported. There is no support for message execution or metadata retrieval.
  • When using the SOAP endpoint (Organization.svc/web) for modern and mobile applications, access to the full web service feature set is available.

When writing client code that makes calls to the web service, it’s recommended to request a token through ADAL before every service call. That way ADAL can determine whether it can re-use a cached instance of the access token, make a request for a new one using the refresh token, or prompt the user to sign in.

Discover the OAuth endpoint URL

The ability to discovery the authority for web service authentication at run-time is provided as an alternate method to obtain the authority as compared to hardcoding OAuth provider URLs in applications or configuration files.

The discovery process is started by sending an unauthorized HTTP request with the word “Bearer” in the Authorization header and the tenant organization’s SOAP endpoint URL as the request message.

Copy Code
GET /XRMServices/2011/Organization.svc HTTP/1.1Host: <org>.crm.dynamics.comAuthorization: Bearer

A 401 error is returned with a response containing an authorization_uri parameter. That value of that parameter is an authority URL.

Copy Code
HTTP/1.1 401 UnauthorizedWWW-Authenticate: Bearer authorization_uri=URI

The authority discovery feature is made available to clients only when an SdkClientVersion property is present in the tenant organization’s SOAP endpoint URL. An example URL is shown below.

https://contoso.crm.dynamics.com/XRMServices/2011/Organization.svc/web?SdkClientVersion=6.1.0.533;

The SdkClientVersion value can be any version number than has at least one decimal point and is greater than 6.0.0002.0000. It’s recommended that the SdkClientVersion property value be set to the product build version of the SDK assemblies that were linked to the client application.

The following code sample demonstrates how to obtain the authority URL. Note that the sample code makes use of the Microsoft Azure Active Directory Authentication Library (ADAL), which can be obtained from NuGet.org. There are also open sourced versions of this library for Android and iOS.

C# Copy Code
/// <summary>
/// Discover the authority for authentication.
/// </summary>
/// <param name="serviceUrl">The SOAP endpoint for a tenant organization.</param>
/// <returns>The decoded authority URL.</returns>
/// <remarks>The passed service URL string must contain the SdkClientVersion property.
/// Otherwise, the discovery feature will not be available.</remarks>
public String DiscoveryAuthority(Uri serviceUrl)
{
    // Use AuthenticationParameters to send a request to the organization's endpoint and
    // receive tenant information in the 401 challenge.
    AuthenticationParameters parameters = null;

    HttpWebResponse response = null;
    try
    {
        // Create a web request where the authorization header contains the word "Bearer".
        HttpWebRequest httpWebRequest = (HttpWebRequest) WebRequest.Create(serviceUrl);
        httpWebRequest.Headers.Add(HttpRequestHeader.Authorization.ToString(), "Bearer");

        // The response is to be encoded.
        httpWebRequest.ContentType = "application/x-www-form-urlencoded";
        response = (HttpWebResponse) httpWebRequest.GetResponse();

        // If the expected response is returned, this code should not execute.
        throw new ActiveDirectoryAuthenticationException("unauthorized_response_expected",
            "Unauthorized http response (status code 401) was expected");
    }
    catch (WebException ex)
    {
        response = (HttpWebResponse) ex.Response;
        if (response == null)
        {
            throw new ActiveDirectoryAuthenticationException(
                "Unauthorized Http Status Code (401) was expected in the response",
                (Exception) ex);
        }
        else
        {

            // A good response was returned. Extract any parameters from the response.
            // The response should contain an authorization_uri parameter.
            parameters = AuthenticationParameters.CreateFromUnauthorizedResponse(response);
        }
    }
    finally
    {
        if (response != null)
            response.Close();
    }

    // Return the authority URL.
    return parameters.Authority;
}

OAuth authorization endpoints

An alternative method to using OAuth discovery is to use well known OAuth authorization endpoints. When writing an app that authenticates with the Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update web services, you need to use the OAuth provider URLs in your authentication code, as shown in the following table.

Deployment | URL
Microsoft Dynamics CRM Online | https://login.windows.net/common/oauth2/authorize https://login.windows.net/<tenant ID>/oauth2/authorize
Microsoft Dynamics CRM 2015 (on-premises/IFD) | https://<serverFQDNaddress>/adfs/ls/XRMServices/2011/Organization.svc/web

Substitute the address of your IFD server, for example contoso.com, in the security token service (STS) URL. The STS URL shown is for the default installation of AD FS. A non-default installation may use a different URL. Similarly, substitute your tenant ID where indicated.

It’s recommended that you always use OAuth discovery with CRM Online since the authorization endpoints can change at some future time.

Specify an OAuth resource

When authenticating with Microsoft Azure Active Directory using the OAuth authorization code flow, you must provide a value for the target resource. The root organization web address, for example: https://contoso.crm.dynamics.com, needs to be used as the “resource” query string parameter in the call to the OAuth authorization endpoint.

Copy Code
// Obtain an authentication token to access the web service.
String resource = “https://contoso.crm.dynamics.com”;
_authenticationContext = new AuthenticationContext(_oauthUrl, false );
AuthenticationResult result = await _authenticationContext.AcquireTokenAsync( resource, clientID );

More information: Sample: Windows 8 desktop modern OData app

See Also

Tasks

Walkthrough: Register a CRM app with Active Directory

Other Resources

Write mobile and modern apps
Authenticate users with Microsoft Dynamics CRM web services
Blog: Introducing a New Capability in the Azure AD Developer Preview: the Azure Authentication Library
Server-side CRM authentication using Azure Active Directory

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Walkthrough: Register a CRM app with Active Directory

This walkthrough describes how to register an external rich desktop client or mobile application so that it can connect to and authenticate with the Microsoft Dynamics CRM server and access the web services. Once registered, an application can access the web services using HTTP requests through the server’s SOAP or OData endpoints. This walkthrough applies to both Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Prerequisites

For a Microsoft Dynamics CRM 2015 on-premises or Internet-facing deployment (IFD):

  • Windows Server 2012 R2 with AD FS.
  • You must have administrator access to the server hosting the Microsoft Dynamics CRM 2015 deployment services role and the AD FS server.
  • The on-premises server must be configured to use claims authentication.

For a Microsoft Dynamics CRM Online deployment:

  • The user must have a Microsoft Dynamics CRM Online system user account with administrator role for the Microsoft Office 365 subscription.

For either deployment type, you must know the redirect URI for your application. Instructions for finding that URI are provided in the section at the end of this topic named How to obtain the redirect URI.

In This Topic

App registration for CRM on-premises (IFD)

App registration for CRM Online

Obtain the redirect URI

App registration for CRM on-premises (IFD)

Scenario: A customer or other person registers a custom application to access organization data on a CRM server provided by an ISV or Partner.

The ISV or Partner performs the following tasks:

  1. Configures the CRM on-premises (IFD) server and AD FS server using Windows PowerShell commands that are provided later in this section.

  2. Provides the client ID and server address URL information to the customer.

The customer or other person performs the following tasks:

  1. Configures the external application by entering the client ID and server address URL in the app as instructed.

CRM server setup

To configure the CRM server to enable federated claims, follow these steps.

Configure claims settings

  1. Log on as administrator on the CRM server that hosts the deployment service role and open a Windows PowerShell command window.

  2. Add the CRM Windows PowerShell snap-in (Microsoft.Crm.PowerShell.dll). More information: Use PowerShell to Call the Deployment Web Service

    Windows PowerShell Copy Code
    Add-PSSnapin Microsoft.Crm.PowerShell

  3. Enter the following Windows PowerShell commands.

    Windows PowerShell Copy Code
    $ClaimsSettings = Get-CrmSetting -SettingType OAuthClaimsSettings
$ClaimsSettings.Enabled = $true
Set-CrmSetting -Setting $ClaimsSettings

AD FS server setup

To register the external application with AD FS, follow these steps.

Register the application in Active Directory

  1. Log on to the AD FS server as administrator and open a Windows PowerShell command window.

  2. Enter the following command.

    Windows PowerShell Copy Code
    Add-AdfsClient -ClientId <CLIENT_ID> -Name <APP_NAME> -RedirectUri <REDIRECT_URI>

    Where <CLIENT_ID> is a unique number, <APP_NAME> is a name for the application, and <REDIRECT_URI> is any valid URI that AD FS is to redirect to after authentication has completed. It is recommended that the client ID be a GUID. You can generate a GUID in Microsoft Visual Studio by opening the Tools menu and clicking Create GUID.

App registration for CRM Online

Scenario: A person with a CRM Online system user account accesses organization data through a rich desktop client or mobile app.

The end user performs the following tasks:

  1. Registers the external application in Microsoft Azure and provides a redirect URI during the registration process. The URI can be any valid and appropriate URI. The Microsoft Azure app registration process results in the generation of a client ID string.

  2. Configures the application by entering the client ID and redirect URI in the app’s authentication code or configuration file when instructed on the Microsoft Azure app registration page.

Scenario: An ISV creates and registers an app that later published in the app store. The ISV’s customers download the app from the store and use it to connect to their Microsoft Dynamics CRM Online organization.

The ISV performs the following tasks:

  1. Registers the app in the ISV’s tenant using the steps provided in the previous scenario (above).

Each customer that downloads the app performs the following tasks:

  1. When accessing a CRM organization in the customer’s tenant, the customer will be presented with a consent form.

  2. The customer reads the information on the form and clicks OK to consent.

  3. (Optional) The customer register’s the app in the customer’s tenant.

For native apps, the customer has to consent each time he or she is prompted to authenticate again. For web apps, the customer is only asked to consent one time. The workaround to bypass the consent form is for the customer to register the app in the customer’s tenant.

Register an application with Microsoft Azure

  1. Sign in to the Microsoft Azure management portal by using an account with administrator permission. Use an account in the same subscription (tenant) as you intend to register the app with.

    If you don’t have an account, you must sign up for one by using a credit card. However, the account is free and your credit card will not be charged if you only follow the procedures called out in this topic to register one or more apps. More information: Active Directory Pricing Details

  2. Choose Active Directory in the left column of the page. You may need to scroll the left column to see the Active Directory icon and label.

  3. Choose the desired tenant directory in the directory list.

    List of available Active Directory entries

    If your CRM tenant directory is not shown in the directory list, choose Add, and then select Use existing directory in the dialog box. Follow the prompts and instructions provided, and then go back to step 1.

  4. With the target directory selected, choose Applications, and then choose Add.

  5. In the dialog box, choose Add an application my organization is developing.

  6. When prompted, enter a name for your application, choose a type: Web Application or Native Client Application, and then choose the right arrow to continue.

  7. Continue providing the requested information and complete the app registration process.

  8. With the tab of the newly registered app selected, choose Update Your Code. Insert the provided redirect URI and client ID in the authentication code of your app.

    Generated client ID in Dynamics CRM

  9. With the tab of the newly registered app selected, choose Configure.

  10. Set the app permissions as shown in the figure below.

    Add application permission in Dynamics CRM

Register an application with AD FS

  • If you’re federating users between an IFD server and Microsoft Dynamics CRM Online, and you want to use the app with either server, you must register the application with both Microsoft Dynamics CRM Online and Active Directory Federation Services (AD FS) on the IFD server. Follow the steps provided in this topic. Your IFD server must be running Windows Server 2012 R2.

Obtain the redirect URI

One method to obtain the redirect URI is to execute the following line of code in a debug session. In a WinJS debug session, select the RawUri property.

C# Copy Code
string redirectUri = WebAuthenticationBroker.GetCurrentApplicationCallbackUri().ToString();
Visual Basic Copy Code
Dim redirectUri As String = WebAuthenticationBroker.GetCurrentApplicationCallbackUri().ToString()
JavaScript Copy Code
Windows.Security.Authentication.Web.WebAuthenticationBroker.getCurrentApplicationCallbackUri()

You can then use the string value returned from the method call when you register the app. The C# line of code is shown in the topic Sample: Windows 8 desktop modern OData app.

See Also

Concepts

Authenticate the user with the web services

Other Resources

Authenticate users with Microsoft Dynamics CRM web services

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Windows 8 desktop modern SOAP app
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. It can be found in the following location in the download package:

SampleCode\CS\ModernAndMobileApps\ModernSoapApp

Download the Microsoft Dynamics CRM SDK package.

Requirements

This sample requires the Microsoft.Preview.WindowsAzure.ActiveDirectory.Authentication and Microsoft.IdentityModel.Clients.ActiveDirectory NuGet packages. If you have a working internet connection, the packages are automatically downloaded and installed when you load the project’s solution.

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write a Windows 8.1 desktop modern application that can send requests to the organization web service without linking to the SDK assemblies. This sample uses the Microsoft Azure Active Directory Authentication Library (ADAL) and the SOAP protocol. The sample also demonstrates obtaining the OAuth endpoint URL at run time.

While there are seven tiles displayed on the main app page, only the Accounts and Tasks tiles are connected to event handler code. The other tiles are just placeholders.

The example code is configured for the Microsoft Dynamics CRM Online server and a fictitious organization, but will work with an IFD server also.

Code snippets showing just the key sections of the full sample are shown later in this topic.

 Windows 8 sample app main screen

Example

The following code snippet shows how to authenticate the user with the organization web service.

C# Copy Code
using Microsoft.Preview.WindowsAzure.ActiveDirectory.Authentication;
using System;
using System.Threading.Tasks;
using Windows.UI.Popups;
using Windows.Security.Authentication.Web;
using System.Net;
using System.Threading;
using System.IO;
using System.Text;

namespace ModernSoapApp
{
    /// <summary>
    /// Manages authentication with the organization web service.
    /// </summary>
   public static class CurrentEnvironment
   {
       # region Class Level Members

       private static AuthenticationContext _authenticationContext;

       // TODO Set these string values as approppriate for your app registration and organization.
       // For more information, see the SDK topic "Walkthrough: Register an app with Active Directory".
       private const string _clientID = "893262be-fbdc-4556-9325-9f863b69495b";
       public const string CrmServiceUrl = "https://my-domain.crm.dynamics.com/";

       # endregion

       // <summary>
       /// Perform any required app initialization.
       /// This is where authentication with Active Directory is performed.
       public static async Task<string> Initialize()
       {
           Uri serviceUrl = new System.Uri(CrmServiceUrl + "/XRMServices/2011/Organization.svc/web?SdkClientVersion=6.1.0000.0000");

           // Dyamics CRM Online OAuth URL.
           string _oauthUrl = DiscoveryAuthority(serviceUrl);

           // Obtain the redirect URL for the app. This is only needed for app registration.
           string redirectUrl = WebAuthenticationBroker.GetCurrentApplicationCallbackUri().ToString();

           // Obtain an authentication token to access the web service.
           _authenticationContext = new AuthenticationContext(_oauthUrl, false);
           AuthenticationResult result = await _authenticationContext.AcquireTokenAsync(CrmServiceUrl, _clientID);

           // Verify that an access token was successfully acquired.
           if (AuthenticationStatus.Succeeded != result.Status)
           {
               if (result.Error == "authentication_failed")
               {
                   // Clear the token cache and try again.
                   (AuthenticationContext.TokenCache as DefaultTokenCache).Clear();
                   _authenticationContext = new AuthenticationContext(_oauthUrl, false);
                   result = await _authenticationContext.AcquireTokenAsync(CrmServiceUrl, _clientID);
               }
               else
               {
                   DisplayErrorWhenAcquireTokenFails(result);
               }
           }
           return result.AccessToken;
       }

       /// <summary>
       /// Method to get authority URL from organization’s SOAP endpoint URL using Microsoft Azure Active Directory Authentication Library (ADAL),
       /// </summary>
       /// <param name="result">The Authority Url returned from HttpWebResponse.</param>
       public static string DiscoveryAuthority(Uri serviceUrl)
       {
           // Use AuthenticationParameters to send a request to the organization's endpoint and
           // receive tenant information in the 401 challenge.
           Microsoft.IdentityModel.Clients.ActiveDirectory.AuthenticationParameters parameters = null;
           HttpWebResponse response = null;
           try
           {
               // Create a web request where the authorization header contains the word "Bearer".
               HttpWebRequest httpWebRequest = (HttpWebRequest)WebRequest.Create(serviceUrl);
               httpWebRequest.Headers[HttpRequestHeader.Authorization.ToString()] = "Bearer";

               // The response is to be encoded.
               httpWebRequest.ContentType = "application/x-www-form-urlencoded";
               response = (HttpWebResponse)httpWebRequest.GetResponse();
           }

           catch (WebException ex)
           {
               response = (HttpWebResponse)ex.Response;

               // A good response was returned. Extract any parameters from the response.
               // The response should contain an authorization_uri parameter.
               parameters = Microsoft.IdentityModel.Clients.ActiveDirectory.AuthenticationParameters.
                   CreateFromResponseAuthenticateHeader((response.Headers)["WWW-Authenticate"]);
           }
           finally
           {
               if (response != null)
                   response.Dispose();
           }
           // Return the authority URL.
           return parameters.Authority;
       }

       /// <summary>
       /// Returns a response from an Internet resource.
       /// </summary>
       public static WebResponse GetResponse(this WebRequest request)
       {
           AutoResetEvent autoResetEvent = new AutoResetEvent(false);
           IAsyncResult asyncResult = request.BeginGetResponse(r => autoResetEvent.Set(), null);

           // Wait until the call is finished
           autoResetEvent.WaitOne(DefaultRequestTimeout);
           return request.EndGetResponse(asyncResult);
       }

       /// <summary>
       /// Get the DefaultRequestTimeout from the server.
       /// </summary>
       public static TimeSpan DefaultRequestTimeout { get; set; }

        /// <summary>
        /// Display an error message to the user.
        /// </summary>
        /// <param name="result">The authentication result returned from AcquireTokenAsync().</param>
        private static async void DisplayErrorWhenAcquireTokenFails(AuthenticationResult result)
        {
            MessageDialog dialog;

            switch (result.Error)
            {
                case "authentication_canceled":
                    // User cancelled, so no need to display a message.
                    break;
                case "temporarily_unavailable":
                case "server_error":
                    dialog = new MessageDialog("Please retry the operation. If the error continues, please contact your administrator.",
                        "Sorry, an error has occurred.");
                    await dialog.ShowAsync();
                    break;
                default:
                    // An error occurred when acquiring a token so show the error description in a MessageDialog.
                    dialog = new MessageDialog(string.Format(
                        "If the error continues, please contact your administrator.\n\nError: {0}\n\nError Description:\n\n{1}",
                        result.Error, result.ErrorDescription), "Sorry, an error has occurred.");
                    await dialog.ShowAsync();
                    break;
            }
        }
    }
}

For this code to work, you must first register your app with a supported identity provider (AD FS or Microsoft Azure Active Directory). Next, you must set the variable values for _clientID, and CrmServiceUrl in the code. The value for client ID was defined during app registration. For more information about app registration, see Walkthrough: Register a CRM app with Active Directory.

The following code snippet shows how to retrieve entity records from the organization web service using SOAP code in an HTTP request. The authentication access token is placed in the authorization header.

C# Copy Code
using System.Net.Http;
using System.Net.Http.Headers;
using System.Threading.Tasks;

namespace ModernSoapApp
{
    public static class HttpRequestBuilder
    {
        /// <summary>
        /// Retrieve entity record data from the organization web service.
        /// </summary>
        /// <param name="accessToken">The web service authentication access token.</param>
        /// <param name="Columns">The entity attributes to retrieve.</param>
        /// <param name="entity">The target entity for which the data should be retreived.</param>
        /// <returns>Response from the web service.</returns>
        /// <remarks>Builds a SOAP HTTP request using passed parameters and sends the request to the server.</remarks>
        public static async Task<string> RetrieveMultiple(string accessToken, string[] Columns, string entity)
        {
            // Build a list of entity attributes to retrieve as a string.
            string columnsSet = string.Empty;
            foreach (string Column in Columns)
            {
                columnsSet += "<b:string>" + Column + "</b:string>";
            }

            // Default SOAP envelope string. This XML code was obtained using the SOAPLogger tool.
            string xmlSOAP =
             @"<s:Envelope xmlns:s='http://schemas.xmlsoap.org/soap/envelope/'>
                <s:Body>
                  <RetrieveMultiple xmlns='http://schemas.microsoft.com/xrm/2011/Contracts/Services' xmlns:i='http://www.w3.org/2001/XMLSchema-instance'>
                    <query i:type='a:QueryExpression' xmlns:a='http://schemas.microsoft.com/xrm/2011/Contracts'><a:ColumnSet>
                    <a:AllColumns>false</a:AllColumns><a:Columns xmlns:b='http://schemas.microsoft.com/2003/10/Serialization/Arrays'>" + columnsSet +
                   @"</a:Columns></a:ColumnSet><a:Criteria><a:Conditions /><a:FilterOperator>And</a:FilterOperator><a:Filters /></a:Criteria>
                    <a:Distinct>false</a:Distinct><a:EntityName>" + entity + @"</a:EntityName><a:LinkEntities /><a:Orders />
                    <a:PageInfo><a:Count>0</a:Count><a:PageNumber>0</a:PageNumber><a:PagingCookie i:nil='true' />
                    <a:ReturnTotalRecordCount>false</a:ReturnTotalRecordCount>
                    </a:PageInfo><a:NoLock>false</a:NoLock></query>
                  </RetrieveMultiple>
                </s:Body>
              </s:Envelope>";

            // The URL for the SOAP endpoint of the organization web service.
            string url = CurrentEnvironment.CrmServiceUrl + "/XRMServices/2011/Organization.svc/web";

            // Use the RetrieveMultiple CRM message as the SOAP action.
            string SOAPAction = "http://schemas.microsoft.com/xrm/2011/Contracts/Services/IOrganizationService/RetrieveMultiple";

            // Create a new HTTP request.
            HttpClient httpClient = new HttpClient();

            // Set the HTTP authorization header using the access token.
            httpClient.DefaultRequestHeaders.Authorization = new AuthenticationHeaderValue("Bearer", accessToken);

            // Finish setting up the HTTP request.
            HttpRequestMessage req = new HttpRequestMessage(HttpMethod.Post, url);
            req.Headers.Add("SOAPAction", SOAPAction);
            req.Method = HttpMethod.Post;
            req.Content = new StringContent(xmlSOAP);
            req.Content.Headers.ContentType = MediaTypeHeaderValue.Parse("text/xml; charset=utf-8");

            // Send the request asychronously and wait for the response.
            HttpResponseMessage response;
            response = await httpClient.SendAsync(req);
            var responseBodyAsText = await response.Content.ReadAsStringAsync();

            return responseBodyAsText;
        }
    }
}

You can use the SOAPLogger tool provider in the SDK download to obtain the SOAP code for an organization request. For information about using the SOAPLogger tool, see Walkthrough: Use the Modern app SOAP endpoint with JavaScript.

See Also

Concepts

Authenticate the user with the web services

Other Resources

Write mobile and modern apps
Sample: Windows 8 desktop modern OData app
Azure Authentication Library (AAL) for Windows Store: a Deep Dive
Securing a Windows Store Application and REST Web Service Using Azure AD (Preview)
Understanding SOAP

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Windows 8 desktop modern OData app
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. This code can be found in the following location in the download package:

SampleCode\CS\ModernAndMobileApps\ModernOdataApp

Download the Microsoft Dynamics CRM SDK package.

Requirements

This sample requires the Microsoft.Preview.WindowsAzure.ActiveDirectory.Authentication and Microsoft.IdentityModel.Clients.ActiveDirectory NuGet packages. These packages are automatically downloaded and installed when you load the project’s solution.

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write a Windows 8.1 desktop modern application that can send requests to the organization web service without linking to the SDK assemblies. This sample uses the Microsoft Azure Active Directory Authentication Library (ADAL) and the OData protocol.

While there are seven tiles displayed on the main app page, only the Accounts and Tasks tiles are connected to event handler code. The other tiles are just placeholders.

The example code is configured for use with the Microsoft Dynamics CRM Online server and a fictitious organization, but can be used with an IFD server also.

Code snippets showing just the key sections of the full sample are shown later in this topic.

 Windows 8 sample app main screen

Example

The following code snippet shows how to authenticate the user with the organization web service.

C# Copy Code
using Microsoft.Preview.WindowsAzure.ActiveDirectory.Authentication;
using System;
using System.Threading.Tasks;
using Windows.UI.Popups;
using Windows.Security.Authentication.Web;
using System.Net;
using System.Threading;
using System.IO;
using System.Text;

namespace ModernOdataApp
{
    /// <summary>
    /// Manages authentication with the organization web service.
    /// </summary>
    public static class CurrentEnvironment
    {
        # region Class Level Members

        private static AuthenticationContext _authenticationContext;

        // TODO Set these string values as approppriate for your app registration and organization.
        // For more information, see the SDK topic "Walkthrough: Register an app with Active Directory".
        private const string _clientID = "893262be-fbdc-4556-9325-9f863b69495b";
        public const string CrmServiceUrl = "https://my-domain.crm.dynamics.com/";

        # endregion

        // <summary>
        /// Perform any required app initialization.
        /// This is where authentication with Active Directory is performed.
        public static async Task<string> Initialize()
        {
            Uri serviceUrl = new System.Uri(CrmServiceUrl + "/XRMServices/2011/Organization.svc/web?SdkClientVersion=6.1.0000.0000");

            // Dyamics CRM Online OAuth URL.
            string _oauthUrl = DiscoveryAuthority(serviceUrl);

            // Obtain the redirect URL for the app. This is only needed for app registration.
            string redirectUrl = WebAuthenticationBroker.GetCurrentApplicationCallbackUri().ToString();

            // Obtain an authentication token to access the web service.
            _authenticationContext = new AuthenticationContext(_oauthUrl, false);
            AuthenticationResult result = await _authenticationContext.AcquireTokenAsync(CrmServiceUrl, _clientID);

            // Verify that an access token was successfully acquired.
            if (AuthenticationStatus.Succeeded != result.Status)
            {
                if (result.Error == "authentication_failed")
                {
                    // Clear the token cache and try again.
                    (AuthenticationContext.TokenCache as DefaultTokenCache).Clear();
                    _authenticationContext = new AuthenticationContext(_oauthUrl, false);
                    result = await _authenticationContext.AcquireTokenAsync(CrmServiceUrl, _clientID);
                }
                else
                {
                    DisplayErrorWhenAcquireTokenFails(result);
                }
            }
            return result.AccessToken;
        }

        /// <summary>
        /// Method to get authority URL from organization’s SOAP endpoint URL using Microsoft Azure Active Directory Authentication Library (ADAL),
        /// </summary>
        /// <param name="result">The Authority Url returned from HttpWebResponse.</param>
        public static string DiscoveryAuthority(Uri serviceUrl)
        {
            // Use AuthenticationParameters to send a request to the organization's endpoint and
            // receive tenant information in the 401 challenge.
            Microsoft.IdentityModel.Clients.ActiveDirectory.AuthenticationParameters parameters = null;
            HttpWebResponse response = null;
            try
            {
                // Create a web request where the authorization header contains the word "Bearer".
                HttpWebRequest httpWebRequest = (HttpWebRequest)WebRequest.Create(serviceUrl);
                httpWebRequest.Headers[HttpRequestHeader.Authorization.ToString()] = "Bearer";

                // The response is to be encoded.
                httpWebRequest.ContentType = "application/x-www-form-urlencoded";
                response = (HttpWebResponse)httpWebRequest.GetResponse();
            }

            catch (WebException ex)
            {
                response = (HttpWebResponse)ex.Response;

                // A good response was returned. Extract any parameters from the response.
                // The response should contain an authorization_uri parameter.
                parameters = Microsoft.IdentityModel.Clients.ActiveDirectory.AuthenticationParameters.
                    CreateFromResponseAuthenticateHeader((response.Headers)["WWW-Authenticate"]);
            }
            finally
            {
                if (response != null)
                    response.Dispose();
            }
            // Return the authority URL.
            return parameters.Authority;
        }

        /// <summary>
        /// Returns a response from an Internet resource.
        /// </summary>
        public static WebResponse GetResponse(this WebRequest request)
        {
            AutoResetEvent autoResetEvent = new AutoResetEvent(false);
            IAsyncResult asyncResult = request.BeginGetResponse(r => autoResetEvent.Set(), null);

            // Wait until the call is finished
            autoResetEvent.WaitOne(DefaultRequestTimeout);
            return request.EndGetResponse(asyncResult);
        }

        /// <summary>
        /// Get the DefaultRequestTimeout from the server.
        /// </summary>
        public static TimeSpan DefaultRequestTimeout { get; set; }

        /// <summary>
        /// Display an error message to the user.
        /// </summary>
        /// <param name="result">The authentication result returned from AcquireTokenAsync().</param>
        private static async void DisplayErrorWhenAcquireTokenFails(AuthenticationResult result)
        {
            MessageDialog dialog;

            switch (result.Error)
            {
                case "authentication_canceled":
                    // User cancelled, so no need to display a message.
                    break;
                case "temporarily_unavailable":
                case "server_error":
                    dialog = new MessageDialog("Please retry the operation. If the error continues, please contact your administrator.",
                        "Sorry, an error has occurred.");
                    await dialog.ShowAsync();
                    break;
                default:
                    // An error occurred when acquiring a token so show the error description in a MessageDialog.
                    dialog = new MessageDialog(string.Format(
                        "If the error continues, please contact your administrator.\n\nError: {0}\n\nError Description:\n\n{1}",
                        result.Error, result.ErrorDescription), "Sorry, an error has occurred.");
                    await dialog.ShowAsync();
                    break;
            }
        }
    }
}

For this code to work, you must first register your app with a supported identity provider (AD FS or Microsoft Azure Active Directory). Next, you must set the variable values for _clientID and CrmServiceUrl in the code. The value for client ID was defined during app registration. More information: Walkthrough: Register a CRM app with Active Directory

The following code snippet shows how to retrieve entity records from the organization web service using OData protocol code in an HTTP request. The authentication access token is placed in the authorization header.

C# Copy Code
using System.Net.Http;
using System.Net.Http.Headers;
using System.Threading.Tasks;

namespace ModernOdataApp
{
    public static class HttpRequestBuilder
    {
        /// <summary>
        /// Retrieve entity record data from the organization web service.
        /// </summary>
        /// <param name="accessToken">The web service authentication access token.</param>
        /// <param name="Columns">The entity attributes to retrieve.</param>
        /// <param name="entity">The target entity for which the data should be retreived.</param>
        /// <returns>Response from the web service.</returns>
        /// <remarks>Builds an OData HTTP request using passed parameters and sends the request to the server.</remarks>
        public static async Task<string> Retrieve(string accessToken, string[] Columns, string entity)
        {
            // Build a list of entity attributes to retrieve as a string.
            string columnsSet = "";
            foreach (string Column in Columns)
            {
                columnsSet += "," + Column;
            }

            // The URL for the OData organization web service.
            string url = CurrentEnvironment.CrmServiceUrl + "/XRMServices/2011/OrganizationData.svc/" + entity + "?$select=" + columnsSet.Remove(0, 1) + "";

            // Build and send the HTTP request.
            HttpClient httpClient = new HttpClient();
            httpClient.DefaultRequestHeaders.Authorization = new AuthenticationHeaderValue("Bearer", accessToken);
            HttpRequestMessage req = new HttpRequestMessage(HttpMethod.Get, url);
            req.Method = HttpMethod.Get;

            // Wait for the web service response.
            HttpResponseMessage response;
            response = await httpClient.SendAsync(req);
            var responseBodyAsText = await response.Content.ReadAsStringAsync();

            return responseBodyAsText;
        }
    }
}

See Also

Other Resources

Write mobile and modern apps
Azure Authentication Library (AAL) for Windows Store: a Deep Dive
Securing a Windows Store Application and REST Web Service Using Azure AD
OData.org

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write applications and server extensions

This section describes how to program by using the Microsoft Dynamics CRM SDK. Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update provide a rapid development application with out-of-the-box Microsoft Dynamics CRM functionality, capable of instantly leveraging the .NET Framework, and a vast array of Microsoft applications. This release separates the core platform functionality (xRM) from the CRM-specific functionality.

In This Section

Getting started with managed code application development

Use Microsoft Dynamics CRM services in code

Discover the URL for your organization with IDiscoveryService web service

Download the endpoints using the Microsoft Dynamics CRM Developer resources page

Use the IOrganizationService web service to read and write data or metadata

Authenticate users with Microsoft Dynamics CRM web services

Use the early bound entity classes in code

Use the late bound entity class in code

Retrieve data with queries

Retrieve and detect changes to metadata

Offline use of the Microsoft Dynamics CRM services

Troubleshooting and error handling

Use the sample and helper code

Best practices for developing with Microsoft Dynamics CRM

Build Windows client applications using the XRM tools

Related Sections

Developer overview

Model your business data

Getting started with managed code application development

Developer tools

Write client application extensions

Write plug-ins to extend business processes

Write workflows to automate business processes

Developers guide to reports for Microsoft Dynamics CRM

Manage your data

Package and distribute extensions using solutions

Developers guide to customization for Microsoft Dynamics CRM

Extend Microsoft Dynamics CRM for Outlook

Integrate SharePoint with Microsoft Dynamics CRM

Advanced development

Programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Getting started with managed code application development

This guide shows you how to write application code that connects to the Microsoft Dynamics CRM web services and invoke web methods to perform common business data operations like create, delete, update, and find. You will also be shown how to set up a project in Microsoft Visual Studio with the required namespaces, and how to handle exceptions returned from the web services. After completing this guide, you will have learned enough information to explore the many other business operations that are supported by the web services.

In This Section

Start a managed code project in Visual Studio

See Also

Other Resources

Developer overview

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Start a managed code project in Visual Studio

This topic shows you how to create a new project in Microsoft Visual Studio that’s properly configured to build a console application that uses the Microsoft Dynamics CRM SDK.

Prerequisites

  • Microsoft Visual Studio installed on your development computer.
    Any edition, including Visual Studio Express, should work. For more information about what versions of Microsoft Visual Studio are supported, see Visual Studio and the .NET Framework.
  • The Microsoft Dynamics CRM SDK installed on your development computer.
    Download the Microsoft Dynamics CRM SDK package. Run the downloaded executable file to unpack the package to any folder on your development system.

Create a project

The following procedure demonstrates how to create a console application project in the C# or VB language that uses Microsoft .NET Framework 4.5.2. For more information on supported versions of the .NET Framework, see Supported extensions for Microsoft Dynamics CRM.

New project

  1. In Microsoft Visual Studio, select New Project.

  2. In the left navigation pane under Templates, select Visual C# or Visual Basic.

  3. Above the list of available templates, select .NET Framework 4.5.2.

  4. In the list of templates, select Console Application.

    A new console app project dialog in Dynamics CRM

  5. In the fields near the bottom of the form give the project a name and location, and then select OK.

  6. Under the Project menu, open the project’s properties form and verify the target framework is set to .NET Framework 4.5.2. Do not use .NET Framework 4.5.2 Client Profile.

    Choose the target framework for the CRM project

Add all required references to your project

The following procedures instruct you how to add all required assembly references to your project. Consider this a base set of references that most managed code applications will need for calling web service methods.

An alternate and easy method to add the required references to you project is to use the available NuGet SDK package. Using the NuGet package manager in Visual Studio, find and add the Microsoft.CrmSdk.CoreAssemblies package to your project. You can then skip the remaining instructions in this topic.

However, if you are writing an application that accesses the OData web service endpoint, you may not have to add SDK assembly references to your project. For more information about writing apps that access the OData endpoint, see Write mobile and modern apps.

Add the required system references

  1. In Solution Explorer, right-click the project References node, select Add References, and then add the following references to your project.

    • System.Data.Linq
    • System.DirectoryServices.AccountManagement
    • System.Runtime.Serialization
    • System.Security
    • System.ServiceModel

Add the required SDK assembly references

  1. In Solution Explorer, right-click the project References node, and then select Add References.

  2. In the Reference Manager dialog box, select the Browse button, and then navigate to the folder where you extracted the Microsoft Dynamics CRM SDK.

  3. In the Bin folder of the SDK download, select the Microsoft.Crm.Sdk.Proxy.dll and Microsoft.Xrm.Sdk.dll assemblies, and then click Add.

  4. Select OK.

There are other Microsoft Dynamics CRM SDK assembly references that you may need at some time depending on the nature of the project you’re building. However, for writing application code that accesses the organization web service, the previously mentioned references are all you need. More information: Assemblies included in the Microsoft Dynamics CRM SDK.

Add the required Identity references

  1. Download and install the Windows Identity Framework (WIF) version 3.5 library, named WindowsIdentityFoundation-SDK-3.5.msi.

  2. In Solution Explorer, right-click the project References node, and then select Add References.

  3. In the search box, enter System.IdentityModel.

  4. Select System.IdentityModel in the search results list and click OK.

  5. Similar to what was done in steps 2 to 4, add a reference for Microsoft.IdentityModel.

The following diagram shows all the required references added to a project.

Add the project references for the CRM project

Next Steps

Tip
Before you leave this topic, consider saving your project as a project template. You can then reuse that template for future learning projects and save yourself some time and effort in setting up new projects. To do this, while your project is open in Microsoft Visual Studio, in the File menu select Export template. Follow the wizard instructions to create the template.

See Also

Other Resources

Getting started with managed code application development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use Microsoft Dynamics CRM services in code

Microsoft Dynamics CRM provides two web services that can be used to identify your organization and to access CRM data. This section describes how to use these services when you are developing applications or customizations for CRM.

IDiscoveryService web service

A single Microsoft Dynamics CRM installation can host multiple organizations on multiple servers. Therefore, it is important to specify which organization you want to access. The IDiscoveryService web service returns a list of organizations that the specified user belongs to and the URL endpoint address for each organization. More information: Discover the URL for your organization with IDiscoveryService web service and IDiscoveryService

IOrganizationService web service

The primary web service for accessing data and metadata in CRM is the IOrganizationService web service. More information: Use the IOrganizationService web service to read and write data or metadata and IOrganizationService

Add the Microsoft Dynamics CRM assemblies to your project

Most of the time you will choose to use the SDK assemblies in your development projects. Using the assemblies is the recommended developer scenario forMicrosoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. These assemblies are in the SDK\Bin folder, along with the corresponding Visual Studio IntelliSense XML files. More information: Assemblies included in the Microsoft Dynamics CRM SDK

Add the service reference to your project

You may have a development scenario where you want to include the service reference in your project rather than using the assemblies. To find the correct service references for your organization, see Download the endpoints using the Microsoft Dynamics CRM Developer resources page.

See Also

Concepts

Use the early bound entity classes in code
Assemblies included in the Microsoft Dynamics CRM SDK

Other Resources

Discover the URL for your organization with IDiscoveryService web service
Use the IOrganizationService web service to read and write data or metadata
Authenticate users with Microsoft Dynamics CRM web services
Write applications and server extensions
IDiscoveryService
IOrganizationService
Microsoft Dynamics CRM Developer Center

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Assemblies included in the Microsoft Dynamics CRM SDK

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update have several programming assemblies that you can use when writing custom code.

The following table lists the assemblies that are included in the Microsoft Dynamics CRM SDK.

Assembly name | Namespace name | Description
Microsoft.Crm.Sdk.Proxy.dll |  | Defines requests and responses for messages business data model specific (non-core) messages as well as enumerations required for working with organization data.
 | Microsoft.Crm.Sdk | Contains enumerations of possible picklists and integer values for some attributes. The naming convention of the classes is <EntityName><AttributeName> to make it easier to locate the specific attribute.
 | Microsoft.Crm.Sdk.Messages | Contains request and responses for business data model specific (non-core) messages.
Microsoft.Xrm.Sdk.dll |  | Defines the core xRM methods and types, including proxy classes to make the connection to Microsoft Dynamics CRM simpler, authentication methods, and the service contracts.
 | Microsoft.Xrm.Sdk | Defines the data contracts for attribute types, interfaces for authoring plug-ins, and other general purpose xRM types and methods.
 | Microsoft.Xrm.Sdk.Client | Defines classes for use by client-code, including a data context, proxy classes to ease the connection to Microsoft Dynamics CRM, and the LINQ provider.
 | Microsoft.Xrm.Sdk.Discovery | Defines all classes required to communicate with the Discovery Service, including the service contract, all request/responses and supporting classes.
 | Microsoft.Xrm.Sdk.Messages | Defines request/response classes for Create, Retrieve, Update, Delete, Associate , Disassociate, and the metadata classes.
 | Microsoft.Xrm.Sdk.Metadata | Defines the data contracts for Microsoft Dynamics CRM metadata.
 | Microsoft.Xrm.Sdk.Query | Defines query classes required to connect to Microsoft Dynamics CRM.
Microsoft.Xrm.Sdk.Workflow.dll |  | Defines types and methods required to author a custom workflow activity.
 | Microsoft.Xrm.Sdk.Workflow | Defines the attribute and dependency property classes required to author a custom workflow activity.
 | Microsoft.Xrm.Sdk.Workflow.Activities | Defines the workflow activities that are used by the Microsoft Dynamics CRM workflow designer.
 | Microsoft.Xrm.Sdk.Workflow.Designers | Defines a Microsoft Visual Studio designer for displaying a Microsoft Dynamics CRM workflow in Visual Studio.
Microsoft.Crm.Tools.EmailProviders.dll |  | Defines methods and types needed for developing a custom email provider component for the Microsoft Dynamics CRM Email Router.
 | Microsoft.Crm.Tools.Email.Management | Defines the email provider management types.
 | Microsoft.Crm.Tools.Email.Providers | Defines the base class for a custom email provider and supporting types.
Microsoft.Xrm.Sdk.Deployment.dll |  | Defines types and methods for interacting with the Deployment Web Service.
 | Microsoft.Xrm.Sdk.Deployment | Defines the data contracts necessary to communicate with the Deployment Web Service.
 | Microsoft.Xrm.Sdk.Deployment.Proxy | Defines a helper class to generate a proxy for the Deployment Web Service.

See Also

Concepts

The programming models for Microsoft Dynamics CRM
Use the early bound entity classes in code
Use the late bound entity class in code
Use Microsoft Dynamics CRM services in code
Entity and attribute naming conventions
Introduction to entity attributes in Microsoft Dynamics CRM

Other Resources

Administer the deployment using the deployment web service

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Entity and attribute naming conventions

In Microsoft Dynamics CRM, the programming method you use to access data determines the naming convention you use.

When you use the strongly typed classes generated by the code generation tool (CrmSvcUtil.exe) or when you use the OrganizationServiceContext class, you’re programming with early binding. With early-binding programming, you use the schema name of an entity or attribute. Schema names are defined in the Microsoft.Xrm.Sdk.Metadata.EntityMetadata.SchemaName and Microsoft.Xrm.Sdk.Metadata.AttributeMetadata.SchemaName properties.

The following code example shows early binding and uses schema names.

C# Copy Code
// Create new account using early binding and a context object.
AWCServiceContext context = new AWCServiceContext(_serviceProxy);
Account account = new Account()
{
  Name = "Contoso Services Extensions",
         EMailAddress1 = "contoso-Ext@contoso.com"
};

// Create an account record.context.AddToAccountSet(account);
context.SaveChanges();

When you use the Entity class, you are programming with late binding. With late-binding programming, you use the logical name of an entity or attribute. Logical names are defined in the Microsoft.Xrm.Sdk.Metadata.EntityMetadata.LogicalName and Microsoft.Xrm.Sdk.Metadata.AttributeMetadata.LogicalName properties.

The following code example shows late binding and uses logical names.

C# Copy Code
//Create new account using late binding and the Entity class.
Entity accountentity = new Entity("account");
accountentity["name"] = "Contoso Services Extensions";
accountentity["emailaddress1"] = "contoso-Ext@contoso.com";

// Create an account record.
_accountId =_serviceProxy.Create(accountentity);

To find the logical and schema names for each entity, see the metadata for each entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The generated strongly-typed classes file also shows the logical and schema names for each entity and attribute.

See Also

Concepts

Use Microsoft Dynamics CRM services in code
Assemblies included in the Microsoft Dynamics CRM SDK
Use the early bound entity classes in code
Use the late bound entity class in code
Introduction to entity attributes in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Discover the URL for your organization with IDiscoveryService web service

The IDiscoveryService Web service is used to determine the organizations that a user is a member of, and the endpoint address URL to access the IOrganizationService Web service for each of those organizations. This discovery service is necessary because Microsoft Dynamics CRM is a multi-tenant environment—a single Microsoft Dynamics CRM server can host multiple business organizations. By using the discovery Web service, your application can determine the endpoint address URL to access the target organization’s business data.

For Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update installations, server and organization allocation may change as part of datacenter management and load balancing. Therefore, the IDiscoveryService Web service provides a way to discover which Microsoft Dynamics CRM server is serving your organization at a given time.

The following table lists the Web service URLs for the worldwide Microsoft Dynamics CRM Online data centers.

Location | Discovery Web service URL | Identity Provider
North America | https://dev.crm.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft account
 | https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft Office 365
EMEA | https://dev.crm4.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft account
 | https://disco.crm4.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft Office 365
APAC | https://dev.crm5.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft account
 | https://disco.crm5.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft Office 365
South America | https://disco.crm2.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft Office 365

For an Internet-facing deployment (IFD) installation, the Web service URL has the following form:

Copy Code
https://dev.< hostname[:port]>/XRMServices/2011/Discovery.svc

For an on-premises installation, the web service URL has the following form:

Copy Code
http[s]://< hostname[:port]>/XRMServices/2011/Discovery.svc

Consult the Developer Resources page in the Microsoft Dynamics CRM Web application for the correct URL of your installation.

To use the IDiscoveryService Web service, add a reference to the Microsoft.Xrm.Sdk.dll assembly to your Microsoft Visual Studio project, and then add a using or imports statement to access the Microsoft.Xrm.Sdk.Discovery namespace. Alternatively, you can add the service references for the URLs described previously to your project.

In This Section

IDiscoveryService methods

Discovery service messages (request and response classes)

Messages in the discovery service

Sample: Access the Discovery service

Related Sections

Write applications and server extensions

Use Microsoft Dynamics CRM services in code

Download the endpoints using the Microsoft Dynamics CRM Developer resources page

Authenticate users with Microsoft Dynamics CRM web services

Run a simple program using Microsoft Dynamics CRM web services

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


IDiscoveryService methods

The IDiscoveryService Web service provides a single method you can use to determine the correct organization and URL to use to interact with the Microsoft Dynamics CRM Server.

To access the IDiscoveryService Web service, you add a reference to Microsoft.Xrm.Sdk.dll assembly to your Microsoft Visual Studio project, and then add a using or imports statement for the Microsoft.Xrm.Sdk.Discovery namespace.

Execute

Use the Execute method to execute a discovery service message. For a list of the messages you can use with this method, see Messages in the discovery service.

See Also

Concepts

Discovery service messages (request and response classes)

Other Resources

Discover the URL for your organization with IDiscoveryService web service
Authenticate users with Microsoft Dynamics CRM web services

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Discovery service messages (request and response classes)

The IDiscoveryService provides an Execute method to perform supported operations. This method takes a message request class as a parameter and returns a message response class. Request message class names end with "Request" and response message class names end with "Response”.

Execute message flow

DiscoveryRequest is the base class for all discovery message requests and DiscoveryResponse is the base class for all discovery message responses. Typically, you use one of the derived request and response class pairs in your application, for example: RetrieveOrganizationRequest and RetrieveOrganizationResponse.

For a list of the messages supported by the Execute method, see Messages in the discovery service.

See Also

Concepts

Messages in the discovery service

Other Resources

Discover the URL for your organization with IDiscoveryService web service
Sample: Access the Discovery service

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Messages in the discovery service

Messages are used with the discovery service Execute method. All messages available in the discovery web service for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update apply to all deployment types.

The following table lists the messages that are supported with Execute method. Each message derives from the abstract base class DiscoveryRequest.

Message | Description
RetrieveUserIdByExternalIdRequest | Retrieves the logged-on user's ID in Microsoft Dynamics CRM Online. This message is available in Microsoft Dynamics CRM Online only.
RetrieveOrganizationRequest | Retrieves information about a single organization.
RetrieveOrganizationsRequest | Retrieves information about all organizations to which the user belongs.

See Also

Concepts

Discovery service messages (request and response classes)

Other Resources

Discover the URL for your organization with IDiscoveryService web service
Sample: Access the Discovery service

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Access the Discovery service
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\DiscoveryService\DiscoveryService.cs

Demonstrates

How to obtain organization information, including the organization’s URL, from the DiscoveryService Web service.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Discovery;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates useful messages of the Discovery service.
    /// </summary>
    public class DiscoveryService
    {

        #region Class Level Members

        private DiscoveryServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// Demonstrates the RetrieveOrganization and RetrieveOrganizations messages
        /// of the Discovery service.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Discovery service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new DiscoveryServiceProxy(serverConfig.DiscoveryUri,
                                                                    serverConfig.HomeRealmUri,
                                                                    serverConfig.Credentials,
                                                                    serverConfig.DeviceCredentials))
                {
                    // You can choose to use the interface instead of the proxy.
                    IDiscoveryService service = _serviceProxy;

                    #region RetrieveOrganizations Message

                    // Retrieve details about all organizations discoverable via the
                    // Discovery service.
                    RetrieveOrganizationsRequest orgsRequest =
                        new RetrieveOrganizationsRequest()
                        {
                            AccessType = EndpointAccessType.Default,
                            Release = OrganizationRelease.Current
                        };
                    RetrieveOrganizationsResponse organizations =
                        (RetrieveOrganizationsResponse)service.Execute(orgsRequest);

                    // Print each organization's friendly name, unique name and URLs
                    // for each of its endpoints.
                    Console.WriteLine();
                    Console.WriteLine("Retrieving details of each organization:");
                    foreach (OrganizationDetail organization in organizations.Details)
                    {
                        Console.WriteLine("Organization Name: {0}", organization.FriendlyName);
                        Console.WriteLine("Unique Name: {0}", organization.UniqueName);
                        Console.WriteLine("Endpoints:");
                        foreach (var endpoint in organization.Endpoints)
                        {
                            Console.WriteLine("  Name: {0}", endpoint.Key);
                            Console.WriteLine("  URL: {0}", endpoint.Value);
                        }
                    }
                    Console.WriteLine("End of listing");
                    Console.WriteLine();

                    #endregion RetrieveOrganizations Message

                    #region RetrieveOrganization Message

                    // Retrieve details about a single organization discoverable via the Discovery service.
                    //
                    RetrieveOrganizationRequest orgRequest =
                        new RetrieveOrganizationRequest()
                        {
                            UniqueName = organizations.Details[organizations.Details.Count -1].UniqueName,
                            AccessType = EndpointAccessType.Default,
                            Release = OrganizationRelease.Current
                        };
                    RetrieveOrganizationResponse org =
                        (RetrieveOrganizationResponse)service.Execute(orgRequest);

                    // Print the organization's friendly name, unique name and URLs
                    // for each of its endpoints.
                    Console.WriteLine();
                    Console.WriteLine("Retrieving details of specific organization:");
                    Console.WriteLine("Organization Name: {0}", org.Detail.FriendlyName);
                    Console.WriteLine("Unique Name: {0}", org.Detail.UniqueName);
                    Console.WriteLine("Endpoints:");
                    foreach (KeyValuePair<EndpointType, string> endpoint in org.Detail.Endpoints)
                    {
                        Console.WriteLine("  Name: {0}", endpoint.Key);
                        Console.WriteLine("  URL: {0}", endpoint.Value);
                    }
                    Console.WriteLine("End of listing");
                    Console.WriteLine();

                    #endregion RetrieveOrganization Message

                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.DiscoveryServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DiscoveryService app = new DiscoveryService();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.DiscoveryServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.DiscoveryServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.DiscoveryServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Discover the URL for your organization with IDiscoveryService web service
DiscoveryServiceProxy
RetrieveOrganizationsRequest
OrganizationDetail

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Download the endpoints using the Microsoft Dynamics CRM Developer resources page

The Developer Resources page in the Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update web application provides important resources. Included on this page are the web service endpoint URLs, a certificate for accessing Microsoft Azure, and other organization information that you'll need during development. To access the page in the web application, choose Settings > Customizations, and then choose Developer Resources.

For the “Organization service” and “Organization data service” sections in this topic, the example URLs include an OrganizationName. This refers to the organization that you specify in the URL when you access the web application. For example, for Contoso.crm.dynamics.com, the OrganizationName is Contoso. ServerName refers to the name of the server, including the port number, for example, myserver or myserver:5555.

In This Topic

Organization unique name

Microsoft Azure Service Bus issuer certificate

Developer center

Discovery service

Organization service

Organization data service

Using the WSDL

Organization unique name

Shows the unique name for your organization, which is needed when interacting with the discovery service. Note that this may not be the same as the name that is specified in the URL. This name can be found in the following properties:

  • Deployment web service: UniqueName
  • Discovery web service: UniqueName
  • Organization web service using early bound classes: Organization.UniqueName

You can also retrieve this from the discovery service by using the RetrieveOrganizationsRequest message.

Microsoft Azure Service Bus issuer certificate

Provides a download link to the public certificate that is required to configure Microsoft Azure for Microsoft Dynamics CRM integration. For an on-premises or Internet-facing deployment, this information is only visible after CRM has been configured for Azure integration.

For more information, see Azure extensions for Microsoft Dynamics CRM.

Developer center

The Microsoft Dynamics CRM Developer Center or crmdevelopercenter.com contains a wealth of information to help developers. Here you’ll find the Microsoft Dynamics CRM SDK, which includes documentation, samples, and tools, as well as technical articles, ramp up kits, videos, blogs, forums, and more.

Discovery service

The IDiscoveryService web service provides information about the organizations available on the Microsoft Dynamics CRM server using the SOAP protocol. This information includes the web address (URL) for each organization. For more information, see Discover the URL for your organization with IDiscoveryService web service.

For Microsoft Dynamics CRM Online

Use the following URLs to access the discovery service (use the appropriate URL for your location).

Location | Discovery web service URL | Identity provider
North America | https://dev.crm.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft account
 | https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft Office 365
EMEA | https://dev.crm4.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft account
 | https://disco.crm4.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft Office 365
APAC | https://dev.crm5.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft account
 | https://disco.crm5.dynamics.com/XRMServices/2011/Discovery.svc | Microsoft Office 365

For on-premises Microsoft Dynamics CRM

Use the following URL to access the discovery service:

http://ServerName/XRMServices/2011/Discovery.svc

Organization service

The IOrganizationService web service provides access to the business data and metadata of your organization by using the SOAP protocol. More information: Use the IOrganizationService web service to read and write data or metadata.

For Microsoft Dynamics CRM Online

Use the following URLs to access the organization service (SOAP endpoint):

https://OrganizationName.api.crm.dynamics.com/XrmServices/2011/Organization.svc (North America)

https://OrganizationName.api.crm4.dynamics.com/XrmServices/2011/Organization.svc (EMEA)

https://OrganizationName.api.crm5.dynamics.com/XrmServices/2011/Organization.svc (APAC)

For on-premises Microsoft Dynamics CRM

Use the following URLs to access the organization service (SOAP endpoint):

http://ServerName/OrganizationName/XRMServices/2011/Organization.svc

Organization data service

This Open Data (OData) Web service provides access to the business data of your organization by exposing a REST API. This link opens the Conceptual Schema Definition Language (CSDL) document that describes how to access your data by using this API. For more information, see Use the OData endpoint with Ajax and JScript web resources, and Use the OData endpoint with Ajax and JScript web resources.

For Microsoft Dynamics CRM Online

Use the following URLs to access the organization data service (OData REST endpoint):

https://OrganizationName.api.crm.dynamics.com/XrmServices/2011/OrganizationData.svc (North America)

https://OrganizationName.api.crm4.dynamics.com/XrmServices/2011/OrganizationData.svc (EMEA)

https://OrganizationName.api.crm5.dynamics.com/XrmServices/2011/OrganizationData.svc (APAC)

For on-premises Microsoft Dynamics CRM

Use the following URL to access the organization data service (OData REST endpoint):

http://ServerName/OrganizationName/XRMServices/2011/OrganizationData.svc

Using the WSDL

To add a service reference for these services to a Microsoft Visual Studio project, you must append ?WSDL to the service URL when specifying the address in the Add Service Reference dialog box. For example, the discovery service Web Services Description Language (WSDL) address is http:// servername/xrmservices/2011/discovery.svc?wsdl.

See Also

Other Resources

Write applications and server extensions
Use the IOrganizationService web service to read and write data or metadata
Microsoft Dynamics CRM Developer Center

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the IOrganizationService web service to read and write data or metadata

In Microsoft Dynamics CRM 2015, the primary web service that accesses data and metadata for your organization is IOrganizationService. This web service contains the methods that you use to write code that uses all the data and metadata in Microsoft Dynamics CRM.

To use the IOrganizationService web service, add a reference to the Microsoft.Xrm.Sdk.dll assembly to your Microsoft Visual Studio project. To access the non-core xRM messages, add a reference to the Microsoft.Crm.Sdk.Proxy.dll assembly to your project also. Alternatively, add the service reference to your project. More information: Download the endpoints using the Microsoft Dynamics CRM Developer resources page

In This Section

Organization service methods

Use messages (request and response classes) with the Execute method

Use ExecuteMultiple to improve performance for bulk data load

xRM messages in the Organization service

CRM messages in the organization service

IOrganizationService entities

Sample: Execute multiple requests

Related Sections

Use the early bound entity classes in code

Use the late bound entity class in code

Retrieve data with queries

Write applications and server extensions

Authenticate users with Microsoft Dynamics CRM web services

Discover the URL for your organization with IDiscoveryService web service

Run a simple program using Microsoft Dynamics CRM web services

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Organization service methods

Important
Some links to methods in this SDK aren’t working. You can get to the documentation for the web service methods from this page: IOrganizationService.

The IOrganizationService web service provides a set of methods used to perform the most common operations on system and custom entities and on the metadata for your organization. These operations can also be performed by using the IOrganizationService.Execute method and the corresponding message.

Create

Use the IOrganizationService.Create method to create an instance (record) of any entity that supports the Create message, including custom entities.

Retrieve

Use the IOrganizationService.Retrieve method to retrieve an instance (record) of an entity.

RetrieveMultiple

Use the IOrganizationService.RetrieveMultiple method to retrieve a collection records. The query can be specified using a query expression or Fetch XML query.

Update

Use the IOrganizationService.Update method to update an existing record.

Delete

Use the IOrganizationService.Delete method to delete an existing record.

Associate

Use the IOrganizationService.Associate method to create a link between two records that participate in a relationship.

Disassociate

Use the IOrganizationService.Disassociate method to delete the link between two records.

Execute

Use the IOrganizationService.Execute method to execute a message. This includes common processing like create and delete of data records and metadata, or it can be specialized processing such as import or detect duplicates.

Example

The following code shows how to use the Create, Retrieve, and Update methods using the strong types.

C# Copy Code
//Define the account for which we will add letters
Account accountToCreate = new Account
{
    Name = "Example Account"
};

//Define the IDs of the related letters we will create
_letterIds = new[] { Guid.NewGuid(), Guid.NewGuid(), Guid.NewGuid() };

//This acts as a container for each letter we create. Note that we haven't
//define the relationship between the letter and account yet.
EntityCollection relatedLettersToCreate = new EntityCollection
{
    EntityName = Letter.EntityLogicalName,
    Entities =
    {
        new Letter{Subject = "Letter 1", ActivityId = _letterIds[0]},
        new Letter{Subject = "Letter 2", ActivityId = _letterIds[1]},
        new Letter{Subject = "Letter 3", ActivityId = _letterIds[2]}
    }
};

//Creates the reference between which relationship between Letter and
//Account we would like to use.
Relationship letterRelationship = new Relationship("Account_Letters");

//Adds the letters to the account under the specified relationship
accountToCreate.RelatedEntities.Add(letterRelationship, relatedLettersToCreate);

//Passes the Account (which contains the letters)
_accountId = _service.Create(accountToCreate);

Console.WriteLine("An account and {0} letters were created.", _letterIds.Length);

//Now we run through many of the same steps as the above "Create" example
Account accountToUpdate = new Account
{
    Name = "Example Account - Updated",
    AccountId = _accountId
};

EntityCollection relatedLettersToUpdate = new EntityCollection
{
    EntityName = Letter.EntityLogicalName,
    Entities =
    {
        new Letter{Subject = "Letter 1 - Updated", ActivityId = _letterIds[0]},
        new Letter{Subject = "Letter 2 - Updated", ActivityId = _letterIds[1]},
        new Letter{Subject = "Letter 3 - Updated", ActivityId = _letterIds[2]}
    }
};

accountToUpdate.RelatedEntities.Add(letterRelationship, relatedLettersToUpdate);

//This will update the account as well as all of the related letters
_service.Update(accountToUpdate);
Console.WriteLine("An account and {0} letters were updated.", _letterIds.Length);

See Also

Concepts

Use messages (request and response classes) with the Execute method
Use ExecuteMultiple to improve performance for bulk data load
xRM messages in the Organization service
CRM messages in the organization service

Other Resources

Use the IOrganizationService web service to read and write data or metadata
Authenticate users with Microsoft Dynamics CRM web services
Sample: Create, retrieve, update, and delete records (early bound)
Sample: Create, retrieve, update, and delete (late bound)
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use messages (request and response classes) with the Execute method

You can use the methods in the IOrganizationService to perform common operations. In addition to the common methods, methods, you can use the IOrganizationService.Execute method to execute messages that are not exposed as methods.The Execute method takes a message request class as a parameter and returns a message response class. Request message class names end with "Request" and response message class names end with "Response". For more information about all messages supported by the Execute method, see xRM messages in the Organization service, CRM messages in the organization service. The IDiscoveryServiceand the IDeploymentService web services use a similar execute request and response pattern.

Execute message flow

OrganizationRequest is the base class for all messages requests. You can use this base class to execute any messages, specifying the message name and the parameter collection for the request. However, when you use a derived class, such as AssociateRequest, the parameter collection is populated when you use the properties on the request class.

The Execute method returns the corresponding response class for the request, a derived class of the OrganizationResponse class. As with the request class, the derived class contains a property for each value in the results parameter collection. All messages have a response, but many do not have any properties on the response. .

Messages are pre-defined in metadata and stored as records in the SDK message entities. For each message you can determine whether it works while connected to the server or from Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access. This information can be found in the SdkMessage.Availability attribute. For more information, see Plug-in registration entities.

In This Topic

Pass Optional Parameters in Messages

Execute messages in the background (asynchronously)

Pass optional parameters in messages

You can pass optional parameters to any message request by adding a value to the Parameters property. Some parameters are not exposed properties on request classes. In order to set these parameters, they must be set in the Parameters collection on the Request class.

The following table lists these parameters.

Parameter | Description | Messages
SolutionUniqueName | A String that specifies the unique name of the solution to which the operation applies. For more information, see Dependency tracking for solution components. | AddPrivilegesRoleRequest CreateRequest DeleteRequest MakeAvailableToOrganizationTemplateRequest UpdateRequest
CalculateMatchCodeSynchronously | Specifying this parameter is no longer required. The match codes used to detect duplicates are calculated synchronously regardless of the value passed in this parameter. For more information, see Run duplicate detection. | CreateRequest UpdateRequest
SuppressDuplicateDetection | A Boolean used to disable duplicate detection on a create or update operation. For more information, see Run duplicate detection. | CreateRequest UpdateRequest

The following sample shows how to pass an optional parameter:

C# Copy Code
Account target = new Account();
target.Name = "Fabrikam";
CreateRequest req = new CreateRequest();
req.Target = target;
req["SuppressDuplicateDetection"] = true;
req["CalculateMatchCodeSynchronously"] = true;
req["SolutionUniqueName"] = "MySolutionName";
CreateResponse response = (CreateResponse)_service.Execute(req);

Execute messages in the background (asynchronously)

In addition to executing message requests immediately, as is the case with calling Execute and passing a message request, you can also choose to execute a message request in the background (asynchronously). This improves system performance by postponing message execution until some later time when the server load may be less. Interactive users do not have to wait for the target message to execute before they can continue. This is especially useful when processing messages that take a few minutes or more to execute.

Note
Currently, only the ImportSolutionRequest message can be used with the ExecuteAsync message.

Use the ExecuteAsyncRequest message to execute a message asynchronously. You configure the request and pass the request instance as an argument to Execute. ExecuteAsyncResponse returns with the ID of the asynchronous job. You can (optionally) query the job using the ID to find out its current state.

You can also execute multiple messages at a time using the ExecuteMultipleRequest message. To do this, add one or more ExecuteAsync message requests to an ExecuteMultiple message request. Due to throttling restrictions that improve overall system performance, only one message running asynchronously is allowed to execute at a time for each organization. You cannot execute an ExecuteMultiple message request from an ExecuteAsync message request. For more information about the ExecuteMultiple message request, see Use ExecuteMultiple to improve performance for bulk data load.

See Also

Reference

ExecuteAsync message privileges
Execute

Concepts

Use ExecuteMultiple to improve performance for bulk data load
Use messages (request and response classes) with the ExecuteCrmOrganizationRequest method
Messages in the discovery service
xRM messages in the Organization service
CRM messages in the organization service

Other Resources

Use the IOrganizationService web service to read and write data or metadata
OrganizationRequest
OrganizationResponse
ExecuteAsyncMaxConnectionsPerServer
ExecuteAsyncPerOrgMaxConnectionsPerServer

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use ExecuteMultiple to improve performance for bulk data load

You can use the ExecuteMultipleRequest message to support higher throughput bulk message passing scenarios in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, particularly in the case of Microsoft Dynamics CRM Online where Internet latency can be the largest limiting factor. ExecuteMultipleRequest accepts an input collection of message Requests, executes each of the message requests in the order they appear in the input collection, and optionally returns a collection of Responses containing each message’s response or the error that occurred. Each message request in the input collection is processed in a separate database transaction. ExecuteMultipleRequest is executed by using the IOrganizationService.Execute method.

In general, ExecuteMultipleRequest behaves the same as if you executed each message request in the input request collection separately, except with better performance. Use of the CallerId parameter of the service proxy is honored and will apply to the execution of every message in the input request collection. Plug-ins and workflow activities are executed as you would expect for each message processed.

Custom code in the form of plug-ins and custom workflow activities can even execute ExecuteMultipleRequest. However, there are a few key points to keep in mind. An exception thrown by a synchronous registered plug-in is returned in the response collection item Fault parameter. If a plug-in executes within a database transaction, the plug-in executes ExecuteMultipleRequest, and a transaction rollback is initiated, the rollback includes any data changes resulting from requests executed by ExecuteMultipleRequest.

In This Topic

Example

Specify run-time execution options

Run-time limitations

Handle a batch size fault

Example

The following sample code demonstrates a single ExecuteMultipleRequest that performs multiple create operations. Run-time execution options called Settings are used to control the request processing and returned results. These run-time options are discussed in the next section.

C# Copy Code
// Get a reference to the organization service.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // Enable early-bound type support to add/update entity records required for this sample.
    _serviceProxy.EnableProxyTypes();

    #region Execute Multiple with Results
    // Create an ExecuteMultipleRequest object.
    requestWithResults = new ExecuteMultipleRequest()
    {
        // Assign settings that define execution behavior: continue on error, return responses.
        Settings = new ExecuteMultipleSettings()
        {
            ContinueOnError = false,
            ReturnResponses = true
        },
        // Create an empty organization request collection.
        Requests = new OrganizationRequestCollection()
    };

    // Create several (local, in memory) entities in a collection.
    EntityCollection input = GetCollectionOfEntitiesToCreate();

    // Add a CreateRequest for each entity to the request collection.
    foreach (var entity in input.Entities)
    {
        CreateRequest createRequest = new CreateRequest { Target = entity };
        requestWithResults.Requests.Add(createRequest);
    }

    // Execute all the requests in the request collection using a single web method call.
    ExecuteMultipleResponse responseWithResults =
        (ExecuteMultipleResponse)_serviceProxy.Execute(requestWithResults);

    // Display the results returned in the responses.
    foreach (var responseItem in responseWithResults.Responses)
    {
        // A valid response.
        if (responseItem.Response != null)
            DisplayResponse(requestWithResults.Requests[responseItem.RequestIndex], responseItem.Response);

        // An error has occurred.
        else if (responseItem.Fault != null)
            DisplayFault(requestWithResults.Requests[responseItem.RequestIndex],
                responseItem.RequestIndex, responseItem.Fault);
    }

To view the complete sample, see Sample: Execute multiple requests.

Specify run-time execution options

The Settings parameter of ExecuteMultipleRequest applies to all of the requests in the request collection controlling execution behavior and results returned. Let’s take a look at these options in more detail.

ExecuteMultipleSettings Member Description

ContinueOnError

When true, continue processing the next request in the collection even if a fault has been returned from processing the current request in the collection. When false, do not continue processing the next request.

ReturnResponses

When true, return responses from each message request processed. When false, do not return responses.

If set to true and a request does not return a response, because that is its design, the ExecuteMultipleResponseItem for that request is set to null.

However, even when false, the Responses collection will not be empty if errors are returned. If errors are returned, there will be one response item in the collection for each processed request that returned a fault and Fault will be set to the actual fault that occurred.

For example, in a request collection that contains six requests where the third and fifth request return faults, the following table indicates what the Responses collection would contain.

Settings | Responses Collection Contents
ContinueOnError=true, ReturnResponses=true | 6 response items: 2 have Fault set to a value.
ContinueOnError=false, ReturnResponses=true | 3 response items: 1 has Fault set to a value.
ContinueOnError=true, ReturnResponses=false | 2 response items: 2 have Fault set to a value.
ContinueOnError=false, ReturnResponses=false | 1 response item: 1 has Fault set to a value.

An RequestIndex parameter in the response item indicates the sequence number, starting at zero, of the request that the response is associated with. In the previous example, the third request has a request index of 2.

Run-time limitations

There are several constraints related to the use of the ExecuteMultipleRequest as described in the following list.

  • No recursion is allowed - ExecuteMultipleRequest cannot invoke ExecuteMultipleRequest. An ExecuteMultipleRequest found in the request collection will generate a fault for that request item.
  • Maximum batch size – there is a limit to how many requests can be added to a request collection. If that limit is exceeded, a fault is thrown before the first request is ever executed. A limit of 1000 requests is typical though this maximum amount can be set for the Microsoft Dynamics CRM deployment. The deployment setting for this limit is BatchSize.
  • Throttling of concurrent calls – for Microsoft Dynamics CRM Online there is a limit of 2 concurrent ExecuteMultipleRequest executions per organization. If that limit is exceeded, a “Server Busy” fault is thrown before the first request is ever executed. For an on-premises deployment, throttling is not enabled by default. The deployment setting for this limit is ExecuteAsyncPerOrgMaxConnectionsPerServer.

Handle a batch size fault

What should you do when your input request collection exceeds the maximum batch size? Your code can’t directly query the maximum batch size through the deployment web service unless it is run under an account that has the deployment administrator role.

Fortunately, there is another method that you can use. When the number of requests in the input Requests collection exceeds the maximum batch size allowed for an organization, a fault is returned from the ExecuteMultipleRequest call. The maximum batch size is returned in the fault. Your code can check for that value, resize the input request collection to be within the indicated limit, and re-submit the ExecuteMultipleRequest. The following code snippet demonstrates some of this logic.

C# Copy Code
catch (FaultException<OrganizationServiceFault> fault)
{
    // Check if the maximum batch size has been exceeded. The maximum batch size is only included in the fault if it
    // the input request collection count exceeds the maximum batch size.
    if (fault.Detail.ErrorDetails.Contains("MaxBatchSize"))
    {
        int maxBatchSize = Convert.ToInt32(fault.Detail.ErrorDetails["MaxBatchSize"]);
        if (maxBatchSize < requestWithResults.Requests.Count)
        {
            // Here you could reduce the size of your request collection and re-submit the ExecuteMultiple request.
            // For this sample, that only issues a few requests per batch, we will just print out some info. However,
            // this code will never be executed because the default max batch size is 1000.
            Console.WriteLine("The input request collection contains %0 requests, which exceeds the maximum allowed (%1)",
                requestWithResults.Requests.Count, maxBatchSize);
        }
    }
    // Re-throw so Main() can process the fault.
    throw;
}

See Also

Reference

Execute

Concepts

xRM messages in the Organization service
Messages in the discovery service
CRM messages in the organization service

Other Resources

Use the IOrganizationService web service to read and write data or metadata
Import data
OrganizationRequest
OrganizationResponse

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


xRM messages in the Organization service

The Microsoft.Xrm.Sdk.Messages namespace supports the core messages used to work with the data stored in any entity. This namespace also contains the messages you can use to retrieve and customize the metadata for entities, attributes, and relationships.

Messages are used with the IOrganizationService.Execute method. All messages available in the Microsoft.Xrm.Sdk.Messages namespace apply to all three deployment types.

The request page indicates whether the message works while online (connected to the server) or offline (disconnected from the server).

Data messages

The following table lists the data messages available in the xRM namespace.

Message | Description
AssociateRequest | Creates a link between records that participate in a relationship.
CreateRequest | Creates a record of any type that supports the Create message, including custom entities.
DeleteRequest | Deletes an existing record.
DisassociateRequest | Removes the link between records.
ExecuteAsyncRequest | Executes a message asynchronously. Currently this only supports the ImportSolutionRequest message.
RetrieveRequest | Retrieves a record.
RetrieveMultipleRequest | Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query.
UpdateRequest | Updates an existing record.

Metadata messages

The following table lists the metadata messages available in the XRM namespace.

Message | Description
CanBeReferencedRequest | Checks to see if the specified entity can be the primary entity (one) in a one-to-many relationship.
CanBeReferencingRequest | Checks to see if the specified entity can be the referencing entity (many) in a one-to-many relationship.
CanManyToManyRequest | Checks to see if the entity can participate in a many-to-many relationship.
CreateAttributeRequest | Creates a custom attribute for an entity.
CreateEntityRequest | Creates a custom entity.
CreateManyToManyRequest | Creates a many-to-many relationship between two entities.
CreateOneToManyRequest | Creates a one-to-many relationship between two entities.
CreateOptionSetRequest | Creates a custom global option set.
DeleteAttributeRequest | Deletes an attribute from an entity.
DeleteEntityRequest | Deletes an entity.
DeleteOptionSetRequest | Deletes an option set.
DeleteOptionValueRequest | Deletes an option value from a list of options.
DeleteRelationshipRequest | Deletes a relationship.
GetValidManyToManyRequest | Returns the set of entities that can participate in a many-to-many relationship.
GetValidReferencedEntitiesRequest | Returns the set of entities that are valid as the primary entity (one) from the specified entity in a one-to-many relationship. If no entity is specified, this message returns all entities that can be the primary entity in a one-to-many relationship.
GetValidReferencingEntitiesRequest | Returns the set of entities that are valid as the related entity (many) to the specified entity in a one-to-many relationship. If no entity is specified, this message returns all entities that can be the related entity in a one-to-many relationship.
InsertOptionValueRequest | Inserts an option value into a list of options.
InsertStatusValueRequest | Inserts a status value into a list of status values.
OrderOptionRequest | Sets the order of a list of options.
RetrieveAllEntitiesRequest | Retrieves the metadata for all entities.
RetrieveAttributeRequest | Retrieves the metadata for the specified attribute.
RetrieveEntityRequest | Retrieves the metadata for the specified entity.
RetrieveMetadataChangesRequest | Retrieves a collection of metadata records that satisfy the specified criteria.
RetrieveOptionSetRequest | Retrieves a specified option set.
RetrieveRelationshipRequest | Retrieve the metadata for the specified relationship.
RetrieveTimestampRequest | Retrieves a time stamp indicating the last time that the metadata was changed.
UpdateAttributeRequest | Updates the metadata for an attribute.
UpdateEntityRequest | Updates the metadata for an entity.
UpdateOptionSetRequest | Updates an option set.
UpdateOptionValueRequest | Updates the metadata for an option value.
UpdateRelationshipRequest | Updates the metadata for a relationship.
UpdateStateValueRequest | Updates the metadata for a state value.

See Also

Concepts

CRM messages in the organization service

Other Resources

Use the IOrganizationService web service to read and write data or metadata
IOrganizationService
Microsoft.Xrm.Sdk.Messages

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CRM messages in the organization service

The Microsoft.Crm.Sdk.Messages namespace contains all the messages you need to work with the data stored in any entity. The solution messages are also in this namespace.

Messages are used with the IOrganizationService.Execute method. Most messages available in this namespace apply to all three deployment types. The request page for each message indicates which deployment types support the message. The deployment types are:

  • Microsoft Dynamics CRM 2015 - On-premises deployment
  • Microsoft Dynamics CRM 2015 – Internet-facing deployment (IFD)
  • Microsoft Dynamics CRM Online

The request page also indicates whether the message works while online (connected to the server) or offline (disconnected from the server).

Messages

The following table shows the messages available in the CRM namespace.

Message request class | Description
AddItemCampaignActivityRequest | Adds an item to a campaign activity.
AddItemCampaignRequest | Adds an item to a campaign. The item added must be one of the following entity types: campaign, list, product, or salesliterature.
AddListMembersListRequest | Adds a list of members to a list.
AddMemberListRequest | Adds a member to a list. The member added must be one of the following entity types: account, contact, or lead.
AddMembersTeamRequest | Adds members to a team.
AddToQueueRequest | Moves an entity record from a source queue to a destination queue.
AddPrivilegesRoleRequest | Adds a set of existing privileges to an existing role.
AddProductToKitRequest | Adds a product to a kit.
AddRecurrenceRequest | Adds recurrence information to an existing appointment to make it a recurring appointment master.
AddSolutionComponentRequest | Adds a solution component to an unmanaged solution.
AddSubstituteProductRequest | Deprecated. Establishes an association between a product and a substitute product.
AddToQueueRequest | Moves a record from a source queue to a destination queue.
AddUserToRecordTeamRequest | Adds a user to the auto created access team for the specified record.
ApplyRoutingRuleRequest | Applies the active routing rule to the incident (case).
AssignRequest | Assigns the specified record to a new security principal (user). This changes the ownerid attribute of the instance.
AssociateEntitiesRequest | Deprecated. Adds a link between two records in a many-to-many relationship.
AutoMapEntityRequest | Creates the attribute mappings between two entities.
BackgroundSendEmailRequest | Sends an email asynchronously.
BookRequest | Schedules or "books" an appointment.
BulkDeleteRequest | Submits an asynchronous bulk delete job.
BulkDetectDuplicatesRequest | Submits an asynchronous duplicates detection job.
BulkOperationStatusCloseRequest | For internal use only.
CalculateActualValueOpportunityRequest | Calculates the value of an opportunity that is in the "Won" state.
CalculateTotalTimeIncidentRequest | Calculates the total number of minutes spent on an incident (case).
CalculatePriceRequest | Defines custom pricing for your products in opportunities, quotes, orders, and invoices.
CalculateRollupFieldRequest | Calculates a rollup attribute value on demand.
CancelContractRequest | Cancels a contract.
CancelSalesOrderRequest | Cancels a sales order.
CheckIncomingEmailRequest | Checks whether the incoming email message is relevant to the Microsoft Dynamics CRM system.
CheckPromoteEmailRequest | Checks whether the incoming email message should be promoted to the Microsoft Dynamics CRM system.
CleanUpBulkOperationRequest | For internal use only.
CloneContractRequest | Copies an existing contract and its line items.
CloneProductRequest | Clones a product family, product, or bundle record, and creates a copy of the record under the same parent node.
CloseIncidentRequest | Closes an incident (case).
CloseQuoteRequest | Closes a quote.
CompoundCreateRequest | Deprecated. Creates a compound entity (salesorder, invoice, quote, or duplicaterule) and its related entity (salesorderdetail, invoicedetail, quotedetail, or duplicaterulecondition).
CompoundUpdateDuplicateDetectionRuleRequest | Updates a duplicate detection rule and its conditions.
CompoundUpdateRequest | Deprecated. Updates a compound record (salesorder, invoice, quote or duplicaterule) and its related detail record (salesorderdetail, invoicedetail, quotedetail or duplicaterulecondition).
ConvertKitToProductRequest | Converts a kit to a product.
ConvertOwnerTeamToAccessTeamRequest | Converts a team of type owner to a team of type access.
ConvertProductToKitRequest | Converts a product to a kit.
ConvertQuoteToSalesOrderRequest | Converts a quote to a sales order.
ConvertSalesOrderToInvoiceRequest | Converts a sales order to an invoice.
CopyCampaignRequest | Copies a campaign.
CopyCampaignResponseRequest | Copies the information from one campaign response to another, and optionally creates a campaign response template.
CopyDynamicListToStaticRequest | Creates a static list from the specified dynamic list and adds the members that satisfy the dynamic list query criteria to the static list.
CopyMembersListRequest | Copies the members from the source list to the target list without creating duplicates.
CopySystemFormRequest | Creates a new entity form that is based on an existing entity form.
CreateActivitiesListRequest | Creates the activities for a list.
CreateExceptionRequest | Creates an exception for the recurring appointment instance.
CreateInstanceRequest | Creates future unexpanded instances of a recurring appointment master.
CreateWorkflowFromTemplateRequest | Creates a workflow from a workflow template.
DeleteAuditDataRequest | Deletes all partitions containing audit data created before a given end date.
DeleteOpenInstancesRequest | Deletes instances of a recurring appointment master that have an Open state.
DeliverIncomingEmailRequest | Creates an email activity instance from an incoming email message.
DeliverPromoteEmailRequest | Creates an email activity instance from the specified email message.
DeprovisionLanguageRequest | Deprovisions a language.
DisassociateEntitiesRequest | Deprecated. Removes a link between two records in a many to many relationship.
DistributeCampaignActivityRequest | Creates a bulk operation to distribute the activity, creating the appropriate activity for each member in the list for the specified campaign activity.
DownloadReportDefinitionRequest | Downloads a report definition.
ExecuteByIdSavedQueryRequest | Executes a saved query (view) that has the specified ID.
ExecuteByIdUserQueryRequest | Executes the user query (saved view) that has the specified ID.
ExecuteFetchRequest | Deprecated. Executes the specified Fetch XML query.
ExecuteWorkflowRequest | Executes a workflow.
ExpandCalendarRequest | Converts the calendar rules to an array of available time blocks for the specified period.
ExportMappingsImportMapRequest | Exports an import data map to an XML file.
ExportFieldTranslationRequest | Exports localizable attributes for translation.
ExportSolutionRequest | Exports a managed or unmanaged solution.
ExportTranslationRequest | Exports all translations for a specific solution to a compressed file.
FetchXmlToQueryExpressionRequest | Converts a query in Fetch XML to a QueryExpression.
FindParentResourceGroupRequest | Finds a parent resource group (scheduling group) for the specified resource groups (scheduling groups).
FulfillSalesOrderRequest | Fulfills a sales order (order).
GenerateInvoiceFromOpportunityRequest | Generates an invoice from an opportunity.
GenerateQuoteFromOpportunityRequest | Generates a quote from an opportunity.
GenerateSalesOrderFromOpportunityRequest | Generates a sales order from an opportunity.
GenerateSocialProfileRequest | Returns an existing social profile record if one exists, otherwise generates a new one and returns it.
GetAllTimeZonesWithDisplayNameRequest | Retrieves all the time-zone definitions for the specified locale returning only the display name attribute.
GetDecryptionKeyRequest | Gets a decryption key.
GetDefaultPriceLevelRequest | Contains the data that is needed to retrieve the default price level (price list) for the current user based on the user’s territory relationship with the price list.
GetDistinctValuesImportFileRequest | Returns distinct values for a column in the source file that contains list values.
GetHeaderColumnsImportFileRequest | Retrieves the source-file column headings, or system-generated column headings, if the source file does not contain column headings.
GetInvoiceProductsFromOpportunityRequest | Retrieves the products from an opportunity and copies them to the specified invoice.
GetQuantityDecimalRequest | Gets the quantity decimal value for a product.
GetQuoteProductsFromOpportunityRequest | Retrieves the products from an opportunity and copies them to the quote.
GetReportHistoryLimitRequest | Gets the history limit for a report.
GetSalesOrderProductsFromOpportunityRequest | Retrieves the products from an opportunity and copies them to the sales order.
GetTimeZoneCodeByLocalizedNameRequest | Retrieves the time-zone code for the specified localized time-zone name.
GetTrackingTokenEmailRequest | Returns a tracking token that can be then passed in as a parameter to the SendEmailRequest message.
GrantAccessRequest | Grants a security principal (user or team) access to the specified record.
ImportFieldTranslationRequest | Imports localizable attributes for translation.
ImportMappingsImportMapRequest | Imports XML mappings and creates an import data map.
ImportRecordsImportRequest | Submits an asynchronous job that uploads the transformed data into Microsoft Dynamics CRM.
ImportSolutionRequest | Imports a managed or unmanaged solution.
ImportTranslationRequest | Imports all translations from a compressed file.
InitializeFromRequest | Initializes a new record from an existing record.
InstallSampleDataRequest | Installs sample data for an organization.
InstantiateFiltersRequest | Instantiates a filter.
InstantiateTemplateRequest | Creates an email message from a template.
IsBackOfficeInstalledRequest | Deprecated. Checks if Microsoft Great Plains is installed.
IsComponentCustomizableRequest | Determines whether a solution component is customizable.
IsValidStateTransitionRequest | Checks to see if the state transition is valid.
LocalTimeFromUtcTimeRequest | Retrieves the local time for the specified Universal Time Coordinate (UTC) time.
LockInvoicePricingRequest | Locks the total price of products and services specified in the invoice. When the invoice pricing is locked, changes to underlying price lists (price levels) do not affect the prices for an invoice.
LockSalesOrderPricingRequest | Locks the total price of products and services specified in the sales order (order). When the sales order pricing is locked, changes to underlying price lists (price levels) do not affect the prices for a sales order (order).
LogFailureBulkOperationRequest | For internal use only.
LogSuccessBulkOperationRequest | For internal use only.
LoseOpportunityRequest | Sets the state of an opportunity to Lost.
MakeAvailableToOrganizationReportRequest | Deprecated. Makes the report available to all users in the organization.
MakeAvailableToOrganizationTemplateRequest | Deprecated. Makes the specified email template available to the entire organization.
MakeUnavailableToOrganizationReportRequest | Deprecated. Makes the report unavailable to all users in the organization.
MakeUnavailableToOrganizationTemplateRequest | Deprecated. Makes the specified email template no longer available to the entire organization.
MergeRequest | Merges the information from two records of the same type.
ModifyAccessRequest | Replaces the access rights on the target record for the specified security principal (user or team).
ParseImportRequest | Submits an asynchronous job that parses all import files associated with the specified data import (import).
PickFromQueueRequest | Assigns a queue item to a user and optionally remove the queue item from the queue.
ProcessInboundEmailRequest | Processes marketing campaign email responses.
ProcessOneMemberBulkOperationRequest | For internal use only.
PropagateByExpressionRequest | Distributes an activity to a quick campaign.
ProvisionLanguageRequest | Provisions a language.
PublishAllXmlRequest | Publishes all customizations.
PublishDuplicateRuleRequest | Submits an asynchronous job to publish a duplicate rule.
PublishProductHierarchyRequest | Publishes a product family hierarchy including the child products and bundles.
PublishXmlRequest | Publishes the customizations for the specified entities.
QualifyLeadRequest | Qualifies a lead and creates an account, contact, or opportunity records that are linked to the originating lead.
QualifyMemberListRequest | Qualifies the specified member list and either overrides the list members or removes them according to the specified option.
QueryExpressionToFetchXmlRequest | Converts a query represented as a QueryExpression class to the equivalent query represented as FetchXML.
QueryMultipleSchedulesRequest | Searches multiple resources for an available time slot matching the specified parameters. This is similar to the QuerySchedule message but it works for multiple resources at one time.
QueryScheduleRequest | Searches the specified resource for an available time slot matching the specified parameters.
ReassignObjectsOwnerRequest | Reassigns all records that are owned by the security principal (user or team) to another security principal (user or team).
ReassignObjectsSystemUserRequest | Reassigns all records that are owned by the user to another security principal (user or team).
RecalculateRequest | Recalculates the rollup attribute values for all goals in the goal hierarchy that contain a specified goal.
ReleaseToQueueRequest | Assigns a queue item back to the queue owner so others can pick it.
RemoveFromQueueRequest | Removes a queue item from a queue.
RemoveItemCampaignActivityRequest | Removes an item from a campaign activity.
RemoveItemCampaignRequest | Removes an item from a campaign.
RemoveMemberListRequest | Removes a member from a list.
RemoveMembersTeamRequest | Removes members from a team.
RemoveParentRequest | Removes the parent for a record.
RemovePrivilegeRoleRequest | Removes a privilege from an existing role.
RemoveProductFromKitRequest | Removes a product from a kit.
RemoveRelatedRequest | Deprecated. Removes the relationship between two records as defined by the target classes listed below. For example, remove the relationship between an invoice and a contact.
RemoveSolutionComponentRequest | Removes a solution component to an unmanaged solution.
RemoveSubstituteProductRequest | Deprecated. Removes the association between a product and a substitute product.
RemoveUserFromRecordTeamRequest | Removes a user from the auto created access team for the specified record.
RenewContractRequest | Renews a contract.
RenewEntitlementRequest | Renews an entitlement.
ReplacePrivilegesRoleRequest | Replaces the privilege set of an existing role. This effectively deletes all existing privileges from the role and adds the new specified privileges.
RescheduleRequest | Reschedules an appointment, service appointment or recurring appointment.
ResetUserFiltersRequest | Resets the offline data filters for the calling user to the default filters for the organization.
RetrieveAbsoluteAndSiteCollectionUrlRequest | Retrieves the absolute (complete) URL and the site collection URL of a SharePoint document location or SharePoint site.
RetrieveAllChildUsersSystemUserRequest | Retrieves a collection of system users who report to the specified system user.
RetrieveApplicationRibbonRequest | Retrieves the core application ribbons including the entity template.
RetrieveAttributeChangeHistoryRequest | Retrieves all changes to a specific attribute.
RetrieveAuditDetailsRequest | Retrieves the full audit details of a particular audit record.
RetrieveAuditPartitionListRequest | Retrieves the list of auditing partitions.
RetrieveAvailableLanguagesRequest | Retrieves the list of available languages.
RetrieveBusinessHierarchyBusinessUnitRequest | Retrieves all the business units in the business unit hierarchy.
RetrieveByGroupResourceRequest | Retrieves all the resource groups to which the specified resource belongs.
RetrieveByResourceResourceGroupRequest | Retrieves the resource groups that contain the specified resource.
RetrieveByResourcesServiceRequest | Retrieves a collection of services related to the specified set of services.
RetrieveByTopIncidentProductKbArticleRequest | Retrieves the top ten knowledge base articles for the product specified.
RetrieveByTopIncidentSubjectKbArticleRequest | Retrieves the top ten knowledge base articles for the subject specified.
RetrieveCurrentOrganizationRequest | Retrieves organization information from the organization service rather than the discovery service.
RetrieveDependenciesForDeleteRequest | Retrieves the dependencies for solution components that will prevent a solution component from being deleted.
RetrieveDependenciesForUninstallRequest | Retrieves the dependencies for solution components that could prevent uninstalling a managed solution.
RetrieveDependentComponentsRequest | Retrieves all components that depend on the specified component.
RetrieveDeploymentLicenseTypeRequest | Retrieves the type of license for a deployment of Microsoft Dynamics CRM.
RetrieveDeprovisionedLanguagesRequest | Retrieves the list of language packs installed on the server that have been disabled.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record, provided duplicate detection is enabled and there are published duplicate detection rules for the entity.
RetrieveEntityRibbonRequest | Retrieves the ribbon definition used for a specific entity.
RetrieveExchangeRateRequest | Retrieves the exchange rate.
RetrieveFilteredFormsRequest | Retrieves the system forms for the specified user.
RetrieveFormattedImportJobResultsRequest | Retrieves the formatted results from an import job.
RetrieveFormXmlRequest | For internal use only.
RetrieveInstalledLanguagePacksRequest | Retrieves the list of language packs installed on the server.
RetrieveInstalledLanguagePackVersionRequest | Retrieves the version of an installed language pack.
RetrieveLicenseInfoRequest | Retrieves the number of licenses for a deployment of Microsoft Dynamics CRM.
RetrieveLocLabelsRequest | Retrieves the localized labels for the specified attribute.
RetrieveMembersBulkOperationRequest | Retrieves the members of a bulk operation.
RetrieveMembersTeamRequest | Deprecated. Retrieves the members of a team.
RetrieveMissingComponentsRequest | Retrieves a list of missing components for the target organization.
RetrieveMissingDependenciesRequest | Verifies whether any solution components are not included in the solution but possibly should be for a complete solution to be exported.
RetrieveOrganizationResourcesRequest | Retrieves the resources used by an organization.
RetrieveParentGroupsResourceGroupRequest | Retrieves a collection of the parent resource groups of the specified resource group (scheduling group).
RetrieveParsedDataImportFileRequest | Retrieves the data from the parse table.
RetrievePersonalWallRequest | Retrieves pages of posts, with comments for each post, for all records that the calling user follows.
RetrievePrincipalAccessRequest | Retrieves the access rights the specified security principal (user or team) has to a record.
RetrievePrincipalAttributePrivilegesRequest | Retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity.
RetrievePrincipalSyncAttributeMappingsRequest | Retrieves the synchronization attribute mapping information that defines the flow of data from the server to client application.
RetrievePrivilegeSetRequest | Retrieves the set of privileges defined in the system.
RetrieveProductPropertiesRequest | Retrieves all the property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.
RetrieveProvisionedLanguagePackVersionRequest | Retrieves the version of the language packs installed on the server.
RetrieveProvisionedLanguagesRequest | Retrieves the list of language packs installed on the server that are enabled.
RetrieveRecordChangeHistoryRequest | Retrieves all changes to a specific entity.
RetrieveRecordWallRequest | Retrieves pages of posts, with comments for each post, for a specific record.
RetrieveRequiredComponentsRequest | Retrieves all components that this component requires.
RetrieveRolePrivilegesRoleRequest | Retrieves the privileges that are assigned to the specified role.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves all the security principals (users or teams) that have access to a record, together with their access rights to the record.
RetrieveSubGroupsResourceGroupRequest | Retrieves a collection of the child resource groups of the specified resource group (scheduling group).
RetrieveSubsidiaryTeamsBusinessUnitRequest | Deprecated. Retrieves all the team information for child business units of the specified business unit.
RetrieveSubsidiaryUsersBusinessUnitRequest | Deprecated. Retrieves all system users for the child business units of the specified business unit.
RetrieveTeamPrivilegesRequest | Retrieves the privileges for a team.
RetrieveTeamsSystemUserRequest | Deprecated. Retrieves a collection of teams of which the specified system user is a member.
RetrieveUnpublishedMultipleRequest | Retrieves the current saved definitions of Web resources, organization-owned charts, or organization-owned dashboards, whether they have been published or not.
RetrieveUnpublishedRequest | Retrieves the current saved definition of a Web resource, organization-owned chart, or organization-owned dashboard, whether is has been published or not.
RetrieveUserPrivilegesRequest | Retrieves all the privileges a system user (user) has through his or her roles in the specified business unit.
RetrieveUserSettingsSystemUserRequest | Deprecated. Retrieves the system user settings for the specified system user.
RetrieveVersionRequest | Retrieves the version number of the Microsoft Dynamics CRM server.
RevertProductRequest | Reverts a product family, product, or bundle record to its last Active state. All the product property (attribute) changes done to the record since it was last published (Active state) will be lost.
ReviseQuoteRequest | Sets the state of a quote to Draft.
RevokeAccessRequest | Removes all access to a record for the specified security principal (user or team).
RollupRequest | Retrieves all the records related to the specified record (account or contact). This applies to all activity entities, annotation (note), contract, incident (case), invoice, opportunity, quote and sales order (order) entities.
RouteToRequest | Routes a queue item to a different user or queue.
SearchByBodyKbArticleRequest | Finds all the document indexes that contain the specified text in the body.
SearchByKeywordsKbArticleRequest | Finds all the document indexes that contain the specified keywords.
SearchByTitleKbArticleRequest | Finds all the document indexes that contain the specified text in the title.
SearchRequest | Searches for available time slots that fulfill the specified appointment request.
SendBulkMailRequest | Sends bulk email messages.
SendEmailFromTemplateRequest | Sends an email message using a template.
SendEmailRequest | Sends an email message.
SendFaxRequest | Sends a fax.
SendTemplateRequest | Sends a bulk email message that is created from a template.
SetBusinessEquipmentRequest | Sets the business that owns the equipment.
SetBusinessSystemUserRequest | Sets the business unit for the specified system user.
SetLocLabelsRequest | Sets the localized labels for the specified attribute.
SetParentBusinessUnitRequest | Sets the parent (manager) for the specified business unit.
SetParentSystemUserRequest | Sets the parent (manager) for the specified system user.
SetParentTeamRequest | Sets the parent (manager) for the specified team.
SetRelatedRequest | Deprecated. Creates a link between an opportunity and an account, contact, or competitor.
SetReportRelatedRequest | Specifies in which areas of Microsoft Dynamics CRM the report can be run and viewed.
SetStateRequest | Sets the state of a record.
StatusUpdateBulkOperationRequest | For internal use only.
TransformImportRequest | Submits an asynchronous job to transform the parsed data.
TriggerServiceEndpointCheckRequest | Validates the configuration of a Microsoft Azure solution’s service endpoint.
UnInstallSampleDataRequest | Uninstalls sample data for an organization.
UnlockInvoicePricingRequest | Unlocks the price per unit for the products in the specified invoice.
UnlockSalesOrderPricingRequest | Unlocks the price per unit for the products in the specified sales order (order).
UnpublishDuplicateRuleRequest | Unpublishes a duplicate rule.
UpdateProductPropertiesRequest | Updates all the retrieved property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.
UpdateUserSettingsSystemUserRequest | Deprecated. Updates the user settings for a system user.
UtcTimeFromLocalTimeRequest | Retrieves the UTC time for the specified local time.
ValidateRecurrenceRuleRequest | Validates a recurrence rule for a recurring appointment.
ValidateRequest | Validates that all the constraints of an appointment or service appointment are met.
ValidateSavedQueryRequest | Validates a saved query.
VerifyProcessStateDataRequest | For internal use only.
WhoAmIRequest | Retrieves the user information for the logged on user.
WinOpportunityRequest | Changes the state of an opportunity to Won.
WinQuoteRequest | Changes the state of a quote to Won.

See Also

Concepts

IOrganizationService entities

Other Resources

Use the IOrganizationService web service to read and write data or metadata
IOrganizationService
Microsoft.Crm.Sdk.Messages

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


IOrganizationService entities

The following table lists the entities available in default deployments of Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. It may be easier for you to see this using the metadata browser. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The table below shows the default display name, whether the entity can be customized, the ownership type, and whether the entity is available offline. For the most part, customizable entities appear in customizations UI in the web application, while the others do not. The display name of a customizable entity may be changed through system customization.

The schema name is also the class name used for early-bound programming, however, not all entities support an early-bound class. More information: Create early bound entity classes with the code generation tool (CrmSvcUtil.exe).

For a list of intersect entities (used for creating queries), see Retrieve records for many-to-many relationships using intersect entities.

In This Topic

Entities for developer use

Internal entities

Entities for developer use

The following entities are visible in the system and can be used by developers.

Entity type code | Entity logical name | Early bound class name (schema name) | Display name | Is customizable | Ownership type | Description | Is available offline
1 | account | Account | Account | True | User owned | Business that represents a customer or potential customer. The company that is billed in business transactions. | True
1001 | activitymimeattachment | ActivityMimeAttachment | E-Mail Attachment | True | None | Multipurpose Internet Mail Extensions (MIME) attachment for an email activity. | True
135 | activityparty | ActivityParty | Activity Party | False | None | Person or group associated with an activity. An activity can have multiple activity parties. | True
4200 | activitypointer | ActivityPointer | Activity | True | User owned | Task performed, or to be performed, by a user. An activity is any action for which an entry can be made on a calendar. | True
5 | annotation | Annotation | Note | True | User owned | Annotation (note) that is attached to one or more objects, including other annotations (notes). | True
2000 | annualfiscalcalendar | AnnualFiscalCalendar | Annual Fiscal Calendar | False | None | Year long fiscal calendar of an organization. A span of time during which the financial activities of an organization are calculated. | False
4201 | appointment | Appointment | Appointment | True | User owned | Commitment representing a time interval with start/end times and duration. | True
4700 | asyncoperation | AsyncOperation | System Job | False | User owned | Process whose execution can proceed independently or in the background. | False
4601 | attributemap | AttributeMap | Attribute Map | False | Organization owned | Represents a mapping between attributes where the attribute values should be copied from a record into the form of a new, related record. | True
4567 | audit | Audit | Auditing | False | None | Track changes to records for analysis, record keeping, and compliance. | False
4425 | bulkdeletefailure | BulkDeleteFailure | Bulk Delete Failure | False | None | Record that was not deleted during a bulk deletion job. | False
4424 | bulkdeleteoperation | BulkDeleteOperation | Bulk Delete Operation | False | None | User-submitted bulk deletion job. | False
4406 | bulkoperation | BulkOperation | Quick Campaign | True | User owned | System operation used to perform lengthy and asynchronous operations on large data sets, such as distributing a campaign activity or quick campaign. | True
4405 | bulkoperationlog | BulkOperationLog | Bulk Operation Log | False | None | Log used to track bulk operation execution successes and failures. | False
10 | businessunit | BusinessUnit | Business Unit | True | Business owned | Business, division, or department in the Microsoft Dynamics CRM database. | True
132 | businessunitnewsarticle | BusinessUnitNewsArticle | Announcement | False | Organization owned | Announcement associated with an organization. | True
4003 | calendar | Calendar | Calendar | False | Business owned | Calendar used by the scheduling system to define when an appointment or activity is to occur. | True
4004 | calendarrule | CalendarRule | Calendar Rule | False | None | Defines free/busy times for a service and for resources or resource groups, such as working, non-working, vacation, and blocked. | True
4400 | campaign | Campaign | Campaign | True | User owned | Container for campaign activities and responses, sales literature, products, and lists to create, plan, execute, and track the results of a specific marketing campaign through its life. | True
4402 | campaignactivity | CampaignActivity | Campaign Activity | True | User owned | Task performed, or to be performed, by a user for planning or running a campaign. | True
4401 | campaignresponse | CampaignResponse | Campaign Response | True | User owned | Response from an existing or a potential new customer for a campaign. | True
4417 | columnmapping | ColumnMapping | Column Mapping | False | None | Mapping for columns in a data map. | False
123 | competitor | Competitor | Competitor | True | Organization owned | Business competing for the sale represented by a lead or opportunity. | True
3234 | connection | Connection | Connection | True | User owned | Relationship between two entities. | True
3231 | connectionrole | ConnectionRole | Connection Role | True | Organization owned | Role describing a relationship between two records. | True
3233 | connectionroleobjecttypecode | ConnectionRoleObjectTypeCode | Connection Role Object Type Code | False | None | Specifies the entity type that can play a specific role in a connection. | True
4007 | constraintbasedgroup | ResourceGroup | Resource Group | False | Business owned | Group or collection of people, equipment, and/or facilities that can be scheduled. | True
2 | contact | Contact | Contact | True | User owned | Person with whom a business unit has a relationship, such as customer, supplier, or colleague. | True
1010 | contract | Contract | Contract | True | User owned | Agreement to provide customer service during a specified amount of time or number of cases. | True
1011 | contractdetail | ContractDetail | Contract Line | True | None | Line item in a contract that specifies the type of service a customer is entitled to. | True
2011 | contracttemplate | ContractTemplate | Contract Template | True | Organization owned | Template for a contract containing the standard attributes of a contract. | True
1071 | customeraddress | CustomerAddress | Address | True | None | Address and shipping information. Used to store additional addresses for an account or contact. | True
4503 | customeropportunityrole | CustomerOpportunityRole | Opportunity Relationship | True | User owned | Deprecated. Relationship between an account or contact and an opportunity. | True
4502 | customerrelationship | CustomerRelationship | Customer Relationship | False | User owned | Deprecated. Relationship between a customer and a partner in which either can be an account or contact. | True
7105 | dependency | Dependency | Dependency | False | None | A component dependency. | False
1013 | discount | Discount | Discount | True | None | Price reduction made from the list price of a product or service based on the quantity purchased. | True
1080 | discounttype | DiscountType | Discount List | True | Organization owned | Type of discount specified as either a percentage or an amount. | True
4102 | displaystring | DisplayString | Display String | False | Organization owned | Customized messages for an entity that has been renamed. | True
4101 | displaystringmap | DisplayString | Display String Map | False | None | Customized messages for an entity that has been renamed. | False
4415 | duplicaterecord | DuplicateRecord | Duplicate Record | False | None | Potential duplicate record. | False
4414 | duplicaterule | DuplicateRule | Duplicate Detection Rule | True | User owned | Rule used to identify potential duplicates. | False
4416 | duplicaterulecondition | DuplicateRuleCondition | Duplicate Rule Condition | True | None | Condition of a duplicate detection rule. | False
1333 | dynamicpropertyinstance | DynamicPropertyInstance | Property Instance | False | User owned | Stores the instance of a product property along with its values | True
4202 | email | Email | E-mail | True | User owned | Activity that is delivered by using email protocols. | True
9605 | emailserverprofile | EmailServerProfile | Email Server Profile | True | User owned | Holds the Email Server Profiles of an organization. | False
9700 | entitlement | Entitlement | Entitlement | True | User owned | Defines the amount and type of support a customer should receive. | False
9701 | entitlementchannel | EntitlementChannel | Entitlement Channel | False | None | Defines the amount and type of support for a channel. | True
9702 | entitlementtemplate | EntitlementTemplate | Entitlement Template | True | Organization owned | Contains predefined customer support terms that can be used to created entitlements for customers. | False
9703 | entitlementtemplatechannel | EntitlementTemplateChannel | Entitlement Template Channel | False | None | Contains predefined support terms for a channel to create entitlements for customers. | True
4600 | entitymap | EntityMap | Entity Map | False | Organization owned | Represents a mapping between two related entities so that data from one record can be copied into the form of a new, related record. | True
4000 | equipment | Equipment | Facility/Equipment | True | Business owned | Resource that can be scheduled. | True
4120 | exchangesyncidmapping | ExchangeSyncIdMapping | Exchange Sync Id Mapping | False | User owned | The mapping used to keep track of the IDs for items synced between CRM and Exchange. | False
4204 | fax | Fax | Fax | True | User owned | Activity that tracks call outcome and number of pages for a fax and optionally stores an electronic copy of the document. | True
1201 | fieldpermission | FieldPermission | Field Permission | False | None | Group of privileges used to categorize users to provide appropriate access to secured columns. | False
1200 | fieldsecurityprofile | FieldSecurityProfile | Field Security Profile | False | Organization owned | Profile that defines the access level for secured attributes. | False
2004 | fixedmonthlyfiscalcalendar | FixedMonthlyFiscalCalendar | Fixed Monthly Fiscal Calendar | False | None | Fixed monthly fiscal calendar of an organization. A span of time during which the financial activities of an organization are calculated. | False
9600 | goal | Goal | Goal | True | User owned | Target objective for a user or a team for a specified time period. | True
9602 | goalrollupquery | GoalRollupQuery | Rollup Query | True | User owned | Query that is used to filter the results of the goal rollup. | True
4410 | import | Import | Data Import | False | User owned | Status and ownership information for an import job. | False
4428 | importentitymapping | ImportEntityMapping | Import Entity Mapping | False | None | Mapping for entities in a data map. | False
4412 | importfile | ImportFile | Import Source File | False | User owned | File name of file used for import. | False
9107 | importjob | ImportJob | Import Job | False | Organization owned | Contains status and the progress information for an import operation that imports entity customizations or translations. | False
4423 | importlog | ImportLog | Import Log | False | User owned | Failure reason and other detailed information for a record that failed to import. | False
4411 | importmap | ImportMap | Data Map | True | User owned | Data map used in an import. | False
112 | incident | Incident | Case | True | User owned | Service request case associated with a contract. | True
4206 | incidentresolution | IncidentResolution | Case Resolution | True | User owned | Special type of activity that includes a description of the resolution, billing status, and the duration of the case. | True
7107 | invaliddependency | InvalidDependency | Invalid Dependency | False | None | An invalid dependency in the system. | False
1090 | invoice | Invoice | Invoice | True | User owned | Order that has been billed. | True
1091 | invoicedetail | InvoiceDetail | Invoice Product | True | None | Line item in an invoice containing detailed billing information for a product. | True
4705 | isvconfig | IsvConfig | ISV Config | False | Organization owned | XML document used to configure client extension controls. | True
127 | kbarticle | KbArticle | Article | True | Organization owned | Structured content that is part of the knowledge base. | True
1082 | kbarticlecomment | KbArticleComment | Article Comment | False | None | Comment on a knowledge base article. | True
1016 | kbarticletemplate | KbArticleTemplate | Article Template | False | Organization owned | Template for a knowledge base article that contains the standard attributes of an article. | True
4 | lead | Lead | Lead | True | User owned | Prospect or potential sales opportunity. Leads are converted into accounts, contacts, or opportunities when they are qualified. Otherwise, they are deleted or archived. | True
1017 | leadaddress | LeadAddress | Lead Address | True | None | Address information for a lead. | True
4207 | letter | Letter | Letter | True | User owned | Activity that tracks the delivery of a letter. The activity can contain the electronic copy of the letter. | True
2027 | license | License | License | False | None | Stores information about a Microsoft Dynamics CRM license. | False
4300 | list | List | Marketing List | True | User owned | Group of existing or potential customers created for a marketing campaign or other sales purposes. | True
4419 | lookupmapping | LookUpMapping | Lookup Mapping | False | None | In a data map, maps a lookup attribute in a source file to Microsoft Dynamics CRM. | False
9606 | mailbox | Mailbox | Mailbox | True | User owned | Tasks, Contacts, and Appointments delivery method of the mailbox. | False
9106 | mailmergetemplate | MailMergeTemplate | Mail Merge Template | True | User owned | Template for a mail merge document that contains the standard attributes of that document. | True
9603 | metric | Metric | Goal Metric | True | Organization owned | Type of measurement for a goal, such as money amount or count. | True
2003 | monthlyfiscalcalendar | MonthlyFiscalCalendar | Monthly Fiscal Calendar | False | None | Monthly fiscal calendar of an organization. A span of time during which the financial activities of an organization are calculated. | False
 | msdyn_postalbum | msdyn_PostAlbum | Profile Album | False | User owned | Contains user profile images used for identifying posts, stored as attachments. | False
 | msdyn_postconfig | msdyn_PostConfig | Post Configuration | False | Organization owned | Contains information about the activity feed configuration of an entity. | False
 | msdyn_postruleconfig | msdyn_PostRuleConfig | Post Rule Configuration | False | Organization owned | Contains information about the configuration of an activity feed rule for an entity. | False
3 | opportunity | Opportunity | Opportunity | True | User owned | Potential revenue-generating event or sale to an account that must be tracked through a sales process to completion. | True
4208 | opportunityclose | OpportunityClose | Opportunity Close | True | User owned | Activity that is created automatically when an opportunity is closed, containing information such as the description of the closing and actual revenue. | True
1083 | opportunityproduct | OpportunityProduct | Opportunity Product | True | None | Association between an opportunity and a product. | True
4209 | orderclose | OrderClose | Order Close | True | User owned | Activity generated automatically when an order is closed. | True
1019 | organization | Organization | Organization | True | Organization owned | Top level of the Microsoft Dynamics CRM business hierarchy. The organization can be a specific business, holding company, or corporation. | True
4420 | ownermapping | OwnerMapping | Owner Mapping | False | None | In a data map, maps ownership data from the source file to Microsoft Dynamics CRM. | False
4210 | phonecall | PhoneCall | Phone Call | True | User owned | Activity to track a telephone call. | True
4418 | picklistmapping | PickListMapping | List Value Mapping | False | None | In a data map, maps list values from the source file to Microsoft Dynamics CRM. | False
4605 | pluginassembly | PluginAssembly | Plug-in Assembly | False | Organization owned | Assembly that contains one or more plug-in types. | True
4602 | plugintype | PluginType | Plug-in Type | False | Organization owned | Type that inherits from the IPlugin interface and is contained within a plug-in assembly. | True
4603 | plugintypestatistic | PluginTypeStatistic | Plug-in Type Statistic | False | Organization owned | Plug-in type statistic. | False
50 | position | Position | Position | True | Organization owned | Contains the position of a user in the hierarchy. | False
 | post | Post | Posts | False | Organization owned | Activity feed post. | False
 | postcomment | PostComment | Comments | False | Organization owned | Comment on an activity feed post. | False
 | postfollow | PostFollow | Follows | False | Organization owned | User following the activity feed of an object. | False
1022 | pricelevel | PriceLevel | Price List | True | Organization owned | Entity that defines pricing levels. | True
44 | principalobjectattributeaccess | PrincipalObjectAttributeAccess | Field Sharing | False | Organization owned | Defines Microsoft Dynamics CRM security principals (users and teams) access rights to secured field for a record. | True
1404 | principalsyncattributemap | PrincipalSyncAttributeMap | Principal Sync Attribute Map | False | Organization owned | Maps security principals (users and teams) to synchronization attribute mappings. | True
1023 | privilege | Privilege | Privilege | False | None | Permission to perform an action in Microsoft Dynamics CRM. Microsoft Dynamics CRM checks for the privilege and rejects the attempt if the user does not hold the privilege. | True
4710 | processsession | ProcessSession | Process Session | True | User owned | Information that is generated when a dialog is run. Every time that you run a dialog, a process session is created. | False
4712 | processtrigger | ProcessTrigger | Process Trigger | True | None | The condition that triggers a rule. | True
1024 | product | Product | Product | True | Organization owned | Information about products and their pricing information. | True
1025 | productassociation | ProductAssociation | Product Association |  | Organization owned | Instance of a product added to a bundle or kit. |
1026 | productpricelevel | ProductPriceLevel | Price List Item | True | None | Information about how to price a product in the specified price level, including pricing method, rounding option, and discount type based on a specified product unit. | True
1028 | productsubstitute | ProductSubstitute | Product Relationship | True | Organization owned | Information about the selling relationship between two products, including the relationship type, such as up-sell, cross-sell, substitute or accessory. | True
7101 | publisher | Publisher | Publisher | True | Organization owned | A publisher of a Microsoft Dynamics CRM solution. | True
7102 | publisheraddress | PublisherAddress | Publisher Address | False | None | Address and shipping information. Used to store additional addresses for a publisher. | True
2002 | quarterlyfiscalcalendar | QuarterlyFiscalCalendar | Quarterly Fiscal Calendar | False | None | Quarterly fiscal calendar of an organization. A span of time during which the financial activities of an organization are calculated. | False
2020 | queue | Queue | Queue | True | User owned | A list of records requiring action, such as accounts, cases, and activities. | True
2029 | queueitem | QueueItem | Queue Item | True | None | A specific item in a queue, such as a case record or an activity record. | True
1084 | quote | Quote | Quote | True | User owned | Formal offer for products and/or services, proposed at specific prices and related payment terms that is sent to a prospective customer. | True
4211 | quoteclose | QuoteClose | Quote Close | True | User owned | Activity generated when a quote is closed. | True
1085 | quotedetail | QuoteDetail | Quote Product | True | None | Product line item in a quote. The details include such information as product ID, description, quantity, and cost. | True
4250 | recurrencerule | RecurrenceRule | Recurrence Rule | False | User owned | Represents the pattern of incidence of recurring entities. |
4251 | recurringappointmentmaster | RecurringAppointmentMaster | Recurring Appointment | True | User owned | The master appointment of a recurring appointment series. | True
4500 | relationshiprole | RelationshipRole | Relationship Role | False | Organization owned | Deprecated. Relationship between an account or contact and an opportunity. | True
4501 | relationshiprolemap | RelationshipRoleMap | Relationship Role Map | False | None | Deprecated. Mapping of the primary associated objects between which the relationship role is valid. | True
9100 | report | Report | Report | True | User owned | Data summary in an easy-to-read layout. | True
9102 | reportcategory | ReportCategory | Report Related Category | True | None | Categories related to a report. A report can be related to multiple categories. | True
9101 | reportentity | ReportEntity | Report Related Entity | False | None | Entities related to a report. A report can be related to multiple entities. | True
9104 | reportlink | ReportLink | Report Link | False | None | Links and dependencies between reports. A report may drill through to another report, or it may have another report as a sub-report. | True
9103 | reportvisibility | ReportVisibility | Report Visibility | False | None | Area in which to show a report. A report can be shown in multiple areas. | True
4002 | resource | Resource | Resource | True | Business owned | User or facility/equipment that can be scheduled for a service. | True
4005 | resourcegroup | ResourceGroup | Scheduling Group | True | Business owned | Resource group or team whose members can be scheduled for a service. | True
4006 | resourcespec | ResourceSpec | Resource Specification | False | Business owned | Selection rule that lets the scheduling engine select a number of resources from a pool of resources. The rules can be associated with a service. | True
1120 | ribboncustomization | RibbonCustomization | Application Ribbons | False | Organization owned | Ribbon customizations for the application ribbon and entity ribbon templates. | True
1036 | role | Role | Security Role | True | Business owned | Grouping of security privileges. Users are assigned roles that authorize their access to Microsoft Dynamics CRM. | True
9604 | rollupfield | RollupField | Rollup Field | True | None | Field to be rolled up to calculate the actual and in-progress values against the goal. | True
1038 | salesliterature | SalesLiterature | Sales Literature | True | Organization owned | Storage of sales literature, which may contain one or more documents. | True
1070 | salesliteratureitem | SalesLiteratureItem | Sales Attachment | False | None | Item in the sales literature collection. | True
1088 | salesorder | SalesOrder | Order | True | User owned | Quote that has been accepted. | True
1089 | salesorderdetail | SalesOrderDetail | Order Product | True | None | Line item in a sales order. | True
1039 | savedquery | SavedQuery | View | True | Organization owned | Saved query against the database. | True
1111 | savedqueryvisualization | SavedQueryVisualization | System Chart | True | Organization owned | Entity to store a visualization attached with a view. | True
4606 | sdkmessage | SdkMessage | Sdk Message | False | Organization owned | Message that is supported by the Microsoft Dynamics CRM SDK. | True
4607 | sdkmessagefilter | SdkMessageFilter | Sdk Message Filter | False | Organization owned | Filter that defines which Microsoft Dynamics CRM SDK messages are valid for each type of entity. | True
4608 | sdkmessageprocessingstep | SdkMessageProcessingStep | Sdk Message Processing Step | False | Organization owned | Stage in the execution pipeline that a plug-in is to execute. | True
4615 | sdkmessageprocessingstepimage | SdkMessageProcessingStepImage | Sdk Message Processing Step Image | False | Organization owned | A copy of an entity's attributes before or after the core system operation. | True
4616 | sdkmessageprocessingstepsecureconfig | SdkMessageProcessingStepSecureConfig | Sdk Message Processing Step Secure Configuration | False | Organization owned | Non-public custom configuration that is passed to a plug-in's constructor. | False
2001 | semiannualfiscalcalendar | SemiAnnualFiscalCalendar | Semi-annual Fiscal Calendar | False | None | Calendar representing the semi-annual span of time during which the financial activities of an organization are calculated. | False
4001 | service | Service | Service | True | Organization owned | Activity that represents work done to satisfy a customer's need. | True
4214 | serviceappointment | ServiceAppointment | Service Activity | True | User owned | Activity offered by the organization to satisfy its customer's needs. Each service activity includes date, time, duration, and required resources. | True
4618 | serviceendpoint | ServiceEndpoint | Service Endpoint | False | Organization owned | Service endpoint that can be contacted. | False
9508 | sharepointdocumentlocation | SharePointDocumentLocation | Document Location | True | User owned | Document libraries or folders on a SharePoint Server from where documents can be managed in Microsoft Dynamics CRM. | False
9502 | sharepointsite | SharePointSite | SharePoint Site | True | User owned | SharePoint Server site from where documents can be managed in Microsoft Dynamics CRM. | False
4009 | site | Site | Site | True | Organization owned | Location or branch office where an organization does business. An organization can have multiple sites. | True
4709 | sitemap | SiteMap | Site Map | False | Organization owned | XML data used to control the application navigation pane. | True
9752 | slakpiinstance | SLAKPIInstance | SLA KPI Instance | True | User or team owned | Service level agreement (SLA) key performance indicator (KPI) instance that is tracked for an individual case. | True
4216 | socialactivity | SocialActivity | Social Activity | True | User owned | Activity that is delivered using social protocols. | False
99 | socialprofile | SocialProfile | Social Profile | True | User owned | This entity is used to store social profile information of its associated account and contacts on different social channels. | False
7100 | solution | Solution | Solution | True | Organization owned | A solution that contains customizations. | True
7103 | solutioncomponent | SolutionComponent | Solution Component | False | None | A component of a solution. | True
129 | subject | Subject | Subject | True | Organization owned | Information regarding subjects available in Microsoft Dynamics CRM. | True
1401 | syncattributemapping | SyncAttributeMapping | Sync Attribute Mapping | False | None | Synchronization attribute mappings used to provide attribute mappings during synchronization for a particular user or team. | False
1400 | syncattributemappingprofile | SyncAttributeMappingProfile | Sync Attribute Mapping Profile | False | Organization owned | Stores profile information used to map synchronization attribute mapping data to users or teams. | False
1030 | systemform | SystemForm | System Form | False | Organization owned | Organization-owned entity customizations, including form layout and dashboards. | True
8 | systemuser | SystemUser | User | True | Business owned | Person with access to Microsoft Dynamics CRM and who can own records. | True
4212 | task | Task | Task | True | User owned | Generic activity representing work needed to be done. | True
9 | team | Team | Team | True | Business owned | Collection of system users that routinely collaborate. Teams can be used to simplify record sharing and provide team members with common access to organization data when team members belong to different business units. | True
1403 | teamsyncattributemappingprofiles | TeamSyncAttributeMappingProfiles | Team Sync-Attribute Mapping Profiles | False | None | Mapping between the synchronization attribute mapping and teams. | False
92 | teamtemplate | TeamTemplate | Team Template | True | None | Team template for an entity enabled for automatically created access teams. | False
2010 | template | Template | E-mail Template | True | User owned | Template for an email message that contains the standard attributes of an email message. | True
2013 | territory | Territory | Territory | True | Organization owned | Represents sales regions. | True
4810 | timezonedefinition | TimeZoneDefinition | Time Zone Definition | False | None | Definition of a time zone, including name and time zone code. | True
4812 | timezonelocalizedname | TimeZoneLocalizedName | Time Zone Localized Name | False | None | Localized name of the time zone. | True
4811 | timezonerule | TimeZoneRule | Time Zone Rule | False | None | Definition for time conversion between local time and Coordinated Universal Time (UTC) for a particular time zone at a particular time period. | True
9105 | transactioncurrency | TransactionCurrency | Currency | True | Organization owned | Currency in which a financial transaction is carried out. | True
4426 | transformationmapping | TransformationMapping | Transformation Mapping | False | None | In a data map, maps the transformation of source attributes to Microsoft Dynamics CRM attributes. | False
4427 | transformationparametermapping | TransformationParameterMapping | Transformation Parameter Mapping | False | None | In a data map, defines parameters for a transformation. | False
1055 | uom | UoM | Unit | True | None | Unit of measure. | True
1056 | uomschedule | UoMSchedule | Unit Group | True | Organization owned | Grouping of units. | True
2501 | userentityinstancedata | UserEntityInstanceData | UserEntityInstanceData | False | User owned | Per user item instance data. | True
2500 | userentityuisettings | UserEntityUISettings | User Entity UI Settings | False | User owned | Stores user settings for entity views. | True
1031 | userform | UserForm | User Dashboard | False | User owned | User-owned dashboards. | True
4230 | userquery | UserQuery | Saved View | True | User owned | Saved database query that is owned by a user. | True
1112 | userqueryvisualization | UserQueryVisualization | User Chart | True | User owned | Visualization attached to a saved view. | True
150 | usersettings | UserSettings | User Settings | False | Business owned | User's preferred settings. | True
9333 | webresource | WebResource | Web Resource | False | Organization owned | Data equivalent to files used in Web development. Web resources provide client-side components that are used to provide custom user interface elements. | True
4703 | workflow | Workflow | Process | True | User owned | Set of logical rules that define the steps necessary to automate a specific business process, task, or set of actions to be performed. | False
4704 | workflowdependency | WorkflowDependency | Workflow Dependency | False | None | Deprecated. Dependencies for a workflow. | False
4706 | workflowlog | WorkflowLog | Process Log | False | User owned | Log used to track process execution. | False

Internal entities

The following entities are visible in the system but have no supported developer scenarios.

Entity type code | Entity logical name | Display name | Ownership type
4707 | applicationfile | Application File | Organization owned
1002 | attachment | Attachment | None
1094 | authorizationserver | Authorization Server | Organization owned
4232 | businessdatalocalizedlabel | Business Data Localized Label | None
4725 | businessprocessflowinstance | Business Process Flow Instance | None
6 | businessunitmap | Business Unit Map | None
113 | childincidentcount | ChildIncidentCount | None
36 | clientupdate | Client update | None
4215 | commitment | Commitment | None
1004 | competitoraddress | Competitor Address | None
9650 | complexcontrol | Process Configuration | Organization owned
9300 | convertrule | Case Creation Rule | User owned
9301 | convertruleitem | Case Creation Rule Item | None
7108 | dependencyfeature | Dependency Feature | None
7106 | dependencynode | Dependency Node | None
126 | documentindex | Indexed Article | None
1048 | dynamicproperty | Property | Organization owned
1235 | dynamicpropertyassociation | Property Association | Organization owned
1049 | dynamicpropertyoptionsetitem | Property Option Set Item | Organization owned
4023 | emailhash | E-Mail Hash | None
4299 | emailsearch | E-Mail Search | None
30 | filtertemplate | Filter Template | None
8840 | hierarchyrule |  |
9919 | hierarchysecurityconfiguration |  |
1007 | imagedescriptor | Image Descriptor | None
4413 | importdata | Import Data | User owned
3000 | integrationstatus | Integration Status | Organization owned
1003 | internaladdress | Internal Address | None
4011 | interprocesslock | Inter Process Lock | None
9607 | mailboxstatistics | Mailbox Statistics | Organization owned
4231 | metadatadifference | Metadata Difference | None
 | msdyn_wallsavedquery | Wall View | Organization owned
 | msdyn_wallsavedqueryusersettings | Filter | User owned
9910 | multientitysearch | Multi Entity Search | None
9911 | multientitysearchentities | Multi Entity Search Entities | None
4110 | notification | Notification | None
4708 | organizationstatistic | Organization Statistic | None
1021 | organizationui | Organization UI | Organization owned
7 | owner | Owner | None
1095 | partnerapplication | Partner Application | Organization owned
 | postlike | Like | Organization owned
 | postregarding | Post Regarding | None
 | postrole | Post Role | Organization owned
43 | principalattributeaccessmap |  | None
11 | principalobjectaccess |  | None
90 | principalobjectaccessreadsnapshot |  | None
31 | privilegeobjecttypecodes | Privilege Object Type Code | None
4724 | processstage | Process Stage | None
2023 | queueitemcount | QueueItemCount | None
2024 | queuemembercount | QueueMemberCount | None
91 | recordcountsnapshot |  | None
1140 | replicationbacklog | Replication Backlog | None
4010 | resourcegroupexpansion | Resource Expansion | None
1116 | ribboncommand | Ribbon Command | Organization owned
1115 | ribboncontextgroup | Ribbon Context Group | Organization owned
1130 | ribbondiff | Ribbon Difference | Organization owned
1117 | ribbonrule | Ribbon Rule | Organization owned
1113 | ribbontabtocommandmap | Ribbon Tab To Command Mapping | Organization owned
1037 | roletemplate | Role Template | None
9511 | rollupjob | Rollup Job | None
9510 | rollupproperties | Rollup Properties | None
8181 | routingrule | Routing Rule Set | User owned
8199 | routingruleitem | Rule Item | None
32 | salesprocessinstance | Sales Process Instance | Business owned
4613 | sdkmessagepair | Sdk Message Pair | Organization owned
4609 | sdkmessagerequest | Sdk Message Request | Organization owned
4614 | sdkmessagerequestfield | Sdk Message Request Field | Organization owned
4610 | sdkmessageresponse | Sdk Message Response | Organization owned
4611 | sdkmessageresponsefield | Sdk Message Response Field | Organization owned
9509 | sharepointdata | SharePoint Data | Organization owned
9507 | sharepointdocument | SharePoint Document | User owned
9750 | sla | SLA | User owned
9751 | slaitem | SLA Item | None
9752 | slakpiinstance | SLA KPI Instance | User owned
1300 | socialinsightsconfiguration | SocialInsightsConfiguration | None
9613 | sqlencryptionaudit | SQL Encryption Audit | None
1075 | statusmap | Status Map | Organization owned
1043 | stringmap | String Map | Organization owned
29 | subscription | Subscription | None
1072 | subscriptionclients | Subscription Clients | None
33 | subscriptionsyncinfo | Subscription Synchronization Information | None
35 | subscriptiontrackingdeletedobject | Tracking information for deleted entities | None
7000 | systemapplicationmetadata | System Application Metadata | None
42 | systemuserbusinessunitentitymap | SystemUser BusinessUnit Entity Map | None
51 | systemusermanagermap | System User Manager Map | None
14 | systemuserprincipals | System User Principal | None
8051 | traceassociation | Trace Association | None
8050 | tracelog | TraceLog | Organization owned
8052 | traceregarding | Trace Regarding | None
2012 | unresolvedaddress | Unresolved Address | None
7001 | userapplicationmetadata | User Application Metadata | User owned
1086 | userfiscalcalendar | User Fiscal Calendar | None
4800 | webwizard | Web Wizard | Organization owned
4803 | wizardaccessprivilege | Web Wizard Access Privilege | Organization owned
4802 | wizardpage | Wizard Page | Organization owned
4702 | workflowwaitsubscription | Workflow Wait Subscription | None

See Also

Reference

Entity Ownership

Other Resources

Use the IOrganizationService web service to read and write data or metadata
Sample: Execute multiple requests
Model your business data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Execute multiple requests
See Also Example

Sending a large number of individual organization message requests over a network, as you would do in a bulk data import operation, is affected by network performance. For improved performance, Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update support batching of requests into a single web service method call.

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DataManagement\ExecuteMultiple\ExecuteMultiple.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to execute multiple organization message requests by using a single web service method call, passing ExecuteMultipleRequest as a parameter. Reducing the number of message requests that must be transmitted over the network results in increased message processing performance. A snippet showing just the key sections of the sample is shown first, followed by the Complete Sample Code.

Example

This sample uses a single web method call to execute all message requests in a collection. Settings to alter the execution behavior are also shown.

C# Copy Code
// Get a reference to the organization service.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // Enable early-bound type support to add/update entity records required for this sample.
    _serviceProxy.EnableProxyTypes();

    #region Execute Multiple with Results
    // Create an ExecuteMultipleRequest object.
    requestWithResults = new ExecuteMultipleRequest()
    {
        // Assign settings that define execution behavior: continue on error, return responses.
        Settings = new ExecuteMultipleSettings()
        {
            ContinueOnError = false,
            ReturnResponses = true
        },
        // Create an empty organization request collection.
        Requests = new OrganizationRequestCollection()
    };

    // Create several (local, in memory) entities in a collection.
    EntityCollection input = GetCollectionOfEntitiesToCreate();

    // Add a CreateRequest for each entity to the request collection.
    foreach (var entity in input.Entities)
    {
        CreateRequest createRequest = new CreateRequest { Target = entity };
        requestWithResults.Requests.Add(createRequest);
    }

    // Execute all the requests in the request collection using a single web method call.
    ExecuteMultipleResponse responseWithResults =
        (ExecuteMultipleResponse)_serviceProxy.Execute(requestWithResults);

    // Display the results returned in the responses.
    foreach (var responseItem in responseWithResults.Responses)
    {
        // A valid response.
        if (responseItem.Response != null)
            DisplayResponse(requestWithResults.Requests[responseItem.RequestIndex], responseItem.Response);

        // An error has occurred.
        else if (responseItem.Fault != null)
            DisplayFault(requestWithResults.Requests[responseItem.RequestIndex],
                responseItem.RequestIndex, responseItem.Fault);
    }

Complete sample code

C# Copy Code
using System;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Query;
using System.Collections.Generic;

namespace Microsoft.Crm.Sdk.Samples
{
    public class ExecuteMultiple
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;
        private readonly List<Guid> _newAccountIds = new List<Guid>();

        ExecuteMultipleRequest requestWithResults;

        #endregion

        #region How To Sample Code

        /// <summary>
        /// This sample demonstrates how to execute a collection of message requests using a single web service
        /// call and optionally return the results.
        /// </summary>
        /// <seealso cref="http://msdn.microsoft.com/en-us/library/gg328075.aspx"/>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Get a reference to the organization service.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // Enable early-bound type support to add/update entity records required for this sample.
                    _serviceProxy.EnableProxyTypes();

                    #region Execute Multiple with Results
                    // Create an ExecuteMultipleRequest object.
                    requestWithResults = new ExecuteMultipleRequest()
                    {
                        // Assign settings that define execution behavior: continue on error, return responses.
                        Settings = new ExecuteMultipleSettings()
                        {
                            ContinueOnError = false,
                            ReturnResponses = true
                        },
                        // Create an empty organization request collection.
                        Requests = new OrganizationRequestCollection()
                    };

                    // Create several (local, in memory) entities in a collection.
                    EntityCollection input = GetCollectionOfEntitiesToCreate();

                    // Add a CreateRequest for each entity to the request collection.
                    foreach (var entity in input.Entities)
                    {
                        CreateRequest createRequest = new CreateRequest { Target = entity };
                        requestWithResults.Requests.Add(createRequest);
                    }

                    // Execute all the requests in the request collection using a single web method call.
                    ExecuteMultipleResponse responseWithResults =
                        (ExecuteMultipleResponse)_serviceProxy.Execute(requestWithResults);

                    // Display the results returned in the responses.
                    foreach (var responseItem in responseWithResults.Responses)
                    {
                        // A valid response.
                        if (responseItem.Response != null)
                            DisplayResponse(requestWithResults.Requests[responseItem.RequestIndex], responseItem.Response);

                        // An error has occurred.
                        else if (responseItem.Fault != null)
                            DisplayFault(requestWithResults.Requests[responseItem.RequestIndex],
                                responseItem.RequestIndex, responseItem.Fault);
                    }
                    #endregion Execute Multiple with Results

                    #region Execute Multiple with No Results

                    ExecuteMultipleRequest requestWithNoResults = new ExecuteMultipleRequest()
                    {
                        // Set the execution behavior to not continue after the first error is received
                        // and to not return responses.
                        Settings = new ExecuteMultipleSettings()
                        {
                            ContinueOnError = false,
                            ReturnResponses = false
                        },
                        Requests = new OrganizationRequestCollection()
                    };

                    // Update the entities that were previously created.
                    EntityCollection update = GetCollectionOfEntitiesToUpdate();

                    foreach (var entity in update.Entities)
                    {
                        UpdateRequest updateRequest = new UpdateRequest { Target = entity };
                        requestWithNoResults.Requests.Add(updateRequest);
                    }

                    ExecuteMultipleResponse responseWithNoResults =
                        (ExecuteMultipleResponse)_serviceProxy.Execute(requestWithNoResults);

                    // There should be no responses unless there was an error. Only the first error
                    // should be returned. That is the behavior defined in the settings.
                    if (responseWithNoResults.Responses.Count > 0)
                    {
                        foreach (var responseItem in responseWithNoResults.Responses)
                        {
                            if (responseItem.Fault != null)
                                DisplayFault(requestWithNoResults.Requests[responseItem.RequestIndex],
                                    responseItem.RequestIndex, responseItem.Fault);
                        }
                    }
                    else
                    {
                        Console.WriteLine("All account records have been updated successfully.");
                    }

                    #endregion Execute Multiple with No Results

                    #region Execute Multiple with Continue On Error

                    ExecuteMultipleRequest requestWithContinueOnError = new ExecuteMultipleRequest()
                    {
                        // Set the execution behavior to continue on an error and not return responses.
                        Settings = new ExecuteMultipleSettings()
                        {
                            ContinueOnError = true,
                            ReturnResponses = false
                        },
                        Requests = new OrganizationRequestCollection()
                    };

                    // Update the entities but introduce some bad attribute values so we get errors.
                    EntityCollection updateWithErrors = GetCollectionOfEntitiesToUpdateWithErrors();

                    foreach (var entity in updateWithErrors.Entities)
                    {
                        UpdateRequest updateRequest = new UpdateRequest { Target = entity };
                        requestWithContinueOnError.Requests.Add(updateRequest);
                    }

                    ExecuteMultipleResponse responseWithContinueOnError =
                        (ExecuteMultipleResponse)_serviceProxy.Execute(requestWithContinueOnError);

                    // There should be no responses except for those that contain an error.
                    if (responseWithContinueOnError.Responses.Count > 0)
                    {
                        if (responseWithContinueOnError.Responses.Count < requestWithContinueOnError.Requests.Count)
                        {
                            Console.WriteLine("Response collection contain a mix of successful response objects and errors.");
                        }
                        foreach (var responseItem in responseWithContinueOnError.Responses)
                        {
                            if (responseItem.Fault != null)
                                DisplayFault(requestWithContinueOnError.Requests[responseItem.RequestIndex],
                                    responseItem.RequestIndex, responseItem.Fault);
                        }
                    }
                    else
                    {
                        // No errors means all transactions are successful.
                        Console.WriteLine("All account records have been updated successfully.");
                    }

                    #endregion Execute Multiple with Continue On Error

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            catch (FaultException<OrganizationServiceFault> fault)
            {
                // Check if the maximum batch size has been exceeded. The maximum batch size is only included in the fault if it
                // the input request collection count exceeds the maximum batch size.
                if (fault.Detail.ErrorDetails.Contains("MaxBatchSize"))
                {
                    int maxBatchSize = Convert.ToInt32(fault.Detail.ErrorDetails["MaxBatchSize"]);
                    if (maxBatchSize < requestWithResults.Requests.Count)
                    {
                        // Here you could reduce the size of your request collection and re-submit the ExecuteMultiple request.
                        // For this sample, that only issues a few requests per batch, we will just print out some info. However,
                        // this code will never be executed because the default max batch size is 1000.
                        Console.WriteLine("The input request collection contains %0 requests, which exceeds the maximum allowed (%1)",
                            requestWithResults.Requests.Count, maxBatchSize);
                    }
                }
                // Re-throw so Main() can process the fault.
                throw;
            }
        }

        #region Public Methods

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want to delete the account record? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (!deleteRecords)
                return;

            ExecuteMultipleRequest requestWithNoResults = new ExecuteMultipleRequest()
                            {
                                // Set the execution behavior to not continue after the first error is received
                                // and to not return responses.
                                Settings = new ExecuteMultipleSettings()
                                {
                                    ContinueOnError = false,
                                    ReturnResponses = false
                                },
                                Requests = new OrganizationRequestCollection()
                            };

            // Update the entities that were previously created.
            EntityCollection delete = GetCollectionOfEntitiesToDelete();

            foreach (var entity in delete.Entities)
            {
                DeleteRequest deleteRequest = new DeleteRequest { Target = entity.ToEntityReference() };
                requestWithNoResults.Requests.Add(deleteRequest);
            }

            ExecuteMultipleResponse responseWithNoResults =
                (ExecuteMultipleResponse)_serviceProxy.Execute(requestWithNoResults);

            // There should be no responses unless there was an error. Only the first error
            // should be returned. That is the behavior defined in the settings.
            if (responseWithNoResults.Responses.Count > 0)
            {
                foreach (var responseItem in responseWithNoResults.Responses)
                {
                    if (responseItem.Fault != null)
                        DisplayFault(requestWithNoResults.Requests[responseItem.RequestIndex],
                            responseItem.RequestIndex, responseItem.Fault);
                }
            }
            else
            {
                Console.WriteLine("All account records have been deleted successfully.");
            }
        }

        #endregion

        #region Private Methods

        /// <summary>
        /// Create a collection of entity objects for updating. Give these entities a new
        /// name for the update. However, use a bad (empty) GUID in some entities to demonstrate
        /// returning errors in ExecuteMultipleResponse.
        /// </summary>
        /// <returns>An entity collection.</returns>
        private EntityCollection GetCollectionOfEntitiesToUpdateWithErrors()
        {
            EntityCollection collection = new EntityCollection()
            {
                EntityName = Account.EntityLogicalName
            };

            for (int i = 1; i <= _newAccountIds.Count; i++)
            {
                if (i % 2 > 0)
                {
                    collection.Entities.Add(
                    new Account
                    {
                        Name = "Again Updated Example Account " + i.ToString(),
                        Id = new Guid()
                    });
                }
                else
                {

                    collection.Entities.Add(
                        new Account
                        {
                            Name = "Again Updated Example Account " + i.ToString(),
                            Id = _newAccountIds[i - 1]
                        });
                }
            }

            return collection;
        }

        /// <summary>
        /// Create a collection of entity objects for updating. Give these entities a new
        /// name for the update.
        /// </summary>
        /// <returns>An entity collection.</returns>
        private EntityCollection GetCollectionOfEntitiesToUpdate()
        {
            EntityCollection collection = new EntityCollection()
            {
                EntityName = Account.EntityLogicalName
            };

            for (int i = 1; i <= _newAccountIds.Count; i++)
            {
                collection.Entities.Add(
                    new Account
                    {
                        Name = "Updated Example Account " + i.ToString(),
                        Id = _newAccountIds[i - 1]
                    });
            }

            return collection;
        }

        /// <summary>
        /// Create a collection of new entity objects.
        /// </summary>
        /// <returns>A collection of entity objects.</returns>
        private EntityCollection GetCollectionOfEntitiesToCreate()
        {
            return new EntityCollection()
            {
                EntityName = Account.EntityLogicalName,
                Entities = {
                    new Account { Name = "Example Account 1" },
                    new Account { Name = "Example Account 2" },
                    new Account { Name = "Example Account 3" },
                    new Account { Name = "Example Account 4" },
                    new Account { Name = "Example Account 5" }
                }
            };
        }

        /// <summary>
        /// Delete a collection of entity objects.
        /// </summary>
        /// <returns>A collection of entity objects</returns>
        private EntityCollection GetCollectionOfEntitiesToDelete()
        {
            EntityCollection collection = new EntityCollection()
            {
                EntityName = Account.EntityLogicalName
            };

            for (int i = 1; i <= _newAccountIds.Count; i++)
            {
                collection.Entities.Add(
                    new Account
                    {
                        Id = _newAccountIds[i - 1]
                    });
            }

            return collection;
        }

        /// <summary>
        /// Display the response of an organization message request.
        /// </summary>
        /// <param name="organizationRequest">The organization message request.</param>
        /// <param name="organizationResponse">The organization message response.</param>
        private void DisplayResponse(OrganizationRequest organizationRequest, OrganizationResponse organizationResponse)
        {
            Console.WriteLine("Created " + ((Account)organizationRequest.Parameters["Target"]).Name
                + " with account id as " + organizationResponse.Results["id"].ToString());
            _newAccountIds.Add(new Guid(organizationResponse.Results["id"].ToString()));
        }

        /// <summary>
        /// Display the fault that resulted from processing an organization message request.
        /// </summary>
        /// <param name="organizationRequest">The organization message request.</param>
        /// <param name="count">nth request number from ExecuteMultiple request</param>
        /// <param name="organizationServiceFault">A WCF fault.</param>
        private void DisplayFault(OrganizationRequest organizationRequest, int count,
            OrganizationServiceFault organizationServiceFault)
        {
            Console.WriteLine("A fault occurred when processing {1} request, at index {0} in the request collection with a fault message: {2}", count + 1,
                organizationRequest.RequestName,
                organizationServiceFault.Message);
        }

        #endregion

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new ExecuteMultiple();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Use ExecuteMultiple to improve performance for bulk data load

Other Resources

Use the IOrganizationService web service to read and write data or metadata
ExecuteMultipleRequest
ExecuteMultipleSettings

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Authenticate users with Microsoft Dynamics CRM web services

Microsoft Dynamics CRM supports two security models for authentication: claims-based authentication and Active Directory authentication. The type of authentication used depends on the type of deployment your application is accessing: Microsoft Dynamics CRM Online orMicrosoft Dynamics CRM 2015.

In addition to using the correct security model, applications must establish a communication channel with the Microsoft Dynamics CRM web services on the target deployment. The Microsoft Dynamics CRM SDK run-time assemblies use Windows Communication Foundation (WCF) technology to establish this communication channel.

The Microsoft Dynamics CRM SDK simplifies use of WCF technology and claims-based authentication by providing helper proxy classes that make it easy to write applications that connect to and authenticate with the Microsoft Dynamics CRM web services. By using these helper classes in your application, you can access any Microsoft Dynamics CRM deployment using the same code and you don’t have to become an expert in claims-based security or WCF programming.

In This Section

Active Directory and claims-based authentication

Connect with Microsoft Office 365 and Microsoft Dynamics CRM Online

Impersonate another user

Implement single sign-on from an ASPX webpage or IFRAME

Sample: Impersonate using the ActOnBehalfOf privilege

Sample: Authenticate users with Microsoft Dynamics CRM web services

Related Sections

Write applications and server extensions

Discover the URL for your organization with IDiscoveryService web service

Use the IOrganizationService web service to read and write data or metadata

Use the sample and helper code

Best practices for developing with Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Active Directory and claims-based authentication

Claims-based authentication provides an industry standard security protocol to authenticate a user on a host computer. Claims-based authentication is a set of WS-* standards describing the use of a Security Assertion Markup Language (SAML) token in either passive mode (when WS-Federation is used with the Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update web application) or active mode (where WS-Trust in used with Windows Communication Foundation (WCF) clients). This authentication works together with WCF to provide secure user authentication and a communication channel with a Microsoft Dynamics CRM server. All Microsoft Dynamics CRM editions support claims-based authentication.

Claims-based authentication requires the availability of a security token service (STS) running on a server. An STS server can be based on Active Directory Federation Services (AD FS) V2, or any platform that provides the official STS protocol. For more information, see the following topic in the Deploying and administering Microsoft Dynamics CRM documentation: Configure IFD for Microsoft Dynamics CRM 2015.

In This Topic

Supported authentication scenarios

Unsupported authentication scenarios

Authentication classes

Authentication by using the client proxy classes

Handling channel exceptions and faults

Additional information about the security (SAML) token

Supported authentication scenarios

Microsoft Dynamics CRM supports the following authentication scenarios for each deployment type.

Deployment | Authentication model
Microsoft Dynamics CRM Online | Claims-based or Active Directory (through federation) authentication
Microsoft Dynamics CRM 2015 on-premises | Claims-based or Active Directory authentication
Microsoft Dynamics CRM 2015 Internet-facing deployment (IFD) | Claims-based or Active Directory authentication

How claims-based authentication works

A request to authenticate a user is sent from Microsoft Dynamics CRM 2015 or Microsoft Dynamics CRM Online or a custom application to the STS server. The STS server determines whether the user should be authenticated, and if so, issues a signed and encrypted SAML token that contains user authentication information. The token has a finite life span and may have to be periodically refreshed depending on how long your application is using the token. This is discussed in more detail later in this topic.

How Active Directory authentication works

A request to authenticate a user is sent from Microsoft Dynamics CRM or a custom application to Active Directory. The WCF stack manages the authentication process for Microsoft Dynamics CRM SDK API calls from an application, whereas Internet Information Services (IIS) manages authentication for a web application.

Unsupported authentication scenarios

Use of client certificates is not supported by the Microsoft Dynamics CRM SDK. If you configure the Microsoft Dynamics CRM website to require IIS client certificates, you will get authentication failures for any applications that were built using the SDK.

For more information about additional unsupported programming methods see Unsupported Customizations.

Authentication classes

The following table lists the primary authentication classes available in the SDK, describes when to use them, and provides links to additional relevant documentation.

Classes | Usage | Related Documentation
IServiceConfiguration`1, IServiceManagement`1 | All deployment types: on-premises/IFD, online (Microsoft account and Office 365/MOS*) Best choice for multi-threaded applications | Authenticate Office 365 users with Microsoft Dynamics CRM Online web services Sample: Authenticate users with Microsoft Dynamics CRM web services Improve service channel allocation performance
DiscoveryServiceProxy, OrganizationServiceProxy | All deployment types: on-premises/IFD, online (Microsoft account and Office 365/MOS*) | Authentication by Using the Client Proxy Classes Sample: Access the Discovery service Improve service channel allocation performance
CrmConnection | All deployment types: on-premises/IFD, online (Microsoft account and Office 365/MOS*) | Simplified connection to Microsoft Dynamics CRM Sample: Simplified connection quick start using Microsoft Dynamics CRM
ServerConnection | All deployment types: on-premises/IFD, online (Microsoft account and Office 365/MOS*) Use for console test applications and sample code. Designed to improve usability when running SDK sample code and to demonstrate use of the authentication classes. Contains console output code. | Helper code: ServerConnection class Sample: Quick start for Microsoft Dynamics CRM

* Microsoft Online Services environment

Authentication by using the client proxy classes

One way to authenticate with the Microsoft Dynamics CRM web services is by using the OrganizationServiceProxy and DiscoveryServiceProxy classes in the applications that you write. The four-parameter constructor of these classes supports Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update deployments. These proxy classes automatically handle claims or Active Directory authentication and also manage resource limits on the WCF channel endpoint.

The following code shows how to instantiate the organization service proxy:

C# Copy Code
using (OrganizationServiceProxy _serviceProxy =    new OrganizationServiceProxy(organizationUri, homeRealmUri, userCredentials, deviceCredentials))

The following code shows how to instantiate the discovery service proxy:

C# Copy Code
using (DiscoveryServiceProxy _discProxy =    new DiscoveryServiceProxy(organizationUri, homeRealmUri, userCredentials, deviceCredentials))

It is important to properly dispose of the service proxy instance in your application before the application terminates. The using statement makes sure that the service proxy is correctly disposed by automatically calling Dispose on the service proxy when it goes out of scope. However, for improved application performance, it is a best practice to keep the service proxy instance available in your application for the entire application session instead of disposing it and allocating it again somewhere else in the application code when needed. The reason being that creating and authenticating a service channel is an expensive operation (in time). In this case, when you are done with the service proxy instance, you must directly call the Dispose method on the proxy before the application terminates.

The device credentials of the registered computing device are only used when authenticating with Microsoft Dynamics CRM Online through the Microsoft account identity provider. For sample code that shows how to populate the proxy constructor parameters, see Sample: Access the Discovery service.

Important
For an on-premises or an Internet-facing deployment (IFD) installation of Microsoft Dynamics CRM 2015, the client proxy classes use claims-based authentication if an STS server is available. Otherwise, Active Directory authentication is used.

If you want to use Microsoft Dynamics CRM early-bound entity types in your code, you must add the following line of code after the organization service proxy is instantiated, but before you make web service method calls:

C# Copy Code
_serviceProxy.EnableProxyTypes()

Security Note
WCF supports a feature where it can interactively prompt the user for logon credentials when it is necessary. This feature is enabled by setting the SupportInteractive property of the ClientCredentials class. These credentials are used in the userCredentials parameter shown in the previous code snippet.

When making SDK calls to the Microsoft Dynamics CRM web services, the ownership of the operation and entity data changes performed by the SDK call can be changed by this WCF feature independent of your code.

Microsoft Dynamics CRM handles supplied credentials in web service calls as follows:

  • If credentials are not supplied in the web service call, the WCF stack determines which credentials to use. In that case, the SupportInteractive property value is automatically set to false.
  • If credentials are explicitly supplied by your code, the current SupportInteractive value is passed to the WCF channel factory. SupportInteractive is set to true by default unless you explicitly change it.
  • If SupportInteractive is set to true and the provided credentials fail, a WCF dialog box may be displayed. Any credentials entered by the user into the dialog box will be used instead of those supplied in the web service calls that your application invokes.

Handling channel exceptions and faults

Your code should catch the following exceptions and faults. See the C# samples in the Microsoft Dynamics CRM SDK for a list of additional exceptions to catch:

  • System.TimeoutException
  • FaultException <OrganizationServiceFault>
  • FaultException <DiscoveryServiceFault>

For more information, see the .NET Framework WCF documentation about how to handle WCF faults and exceptions. See Use the sample and helper code for additional sample code.

Additional information about the security (SAML) token

The SAML token used during user authentication is described below.

Contents of the SAML token

The XML-based SAML 2.0 token contains an identity that defines one or more claims about a user. This token is passed between an identity provider (STS) server and Microsoft Dynamics CRM for claims-based authentication. The claims in the identity have been defined as follows.

Claim | Use
Universal Principal Name (UPN) | Contains the user’s ID in domain\alias format on the target Microsoft Dynamics CRM server.
Name | If the authenticated user is also a Deployment Administrator in Microsoft Dynamics CRM, this claim contains the deployment administrator’s ID in domain\alias format on the target Microsoft Dynamics CRM server. Windows Identity Foundation maps the Name claim to the Identity.name property.
Any other claims | Not used by Microsoft Dynamics CRM.

Supported security token types

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update support two types of SAML tokens:

  • Web application - The Microsoft Dynamics CRM web application receives a bearer token from STS. This token is missing some required information so a Secure Sockets Layer (SSL)-based URL (https://) is used for security protection when you access the WCF endpoint.
  • SDK - A custom application receives an active token with a proof key that contains the required information.

Lifecycle of the security token

A SecurityToken has a life span identified by its ValidFrom and ValidTo properties. Your application design should consider the possibility that the token could expire, resulting in an ExpiredSecurityTokenException being thrown by the Microsoft Dynamics CRM web services when the next message request from your application is processed.

See Also

Concepts

Simplified connection to Microsoft Dynamics CRM
Use the early bound entity classes in code

Other Resources

Authenticate users with Microsoft Dynamics CRM web services
Connect with Microsoft Office 365 and Microsoft Dynamics CRM Online
Discover the URL for your organization with IDiscoveryService web service
Use the IOrganizationService web service to read and write data or metadata
Sample: Create, retrieve, update, and delete records (early bound)
Helper code: ServerConnection class
Helper code: DeviceIdManager class
Blog: Building clients for Windows Phone and Windows 8 RT

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Connect with Microsoft Office 365 and Microsoft Dynamics CRM Online

Microsoft Dynamics CRM Online is part of the Microsoft Office 365 collaboration and productivity tools delivered in the cloud. The Microsoft Office 365 portal provides a single sign-on experience for Office 365 customers where they can sign in once and access any Office 365 application, including Microsoft Dynamics CRM Online. In addition, system user accounts in Microsoft Dynamics CRM Online can be provisioned in the Microsoft Online Services admin portal.

Using federation, applications can connect to Microsoft Dynamics CRM Online in the cloud using the same system user identities and credentials available in an Active Directory based network. For more information, see the Office 365 single sign-on roadmap.

In This Section

Microsoft Dynamics CRM Online Integration with Office 365

Authenticate Office 365 users with Microsoft Dynamics CRM Online web services

Synchronized users in Microsoft Dynamics CRM Online and Office 365

Sample: Authenticate users with Microsoft Dynamics CRM web services

Related Sections

Authenticate users with Microsoft Dynamics CRM web services

Authenticate Office 365 users with Microsoft Dynamics CRM Online web services

Authenticate users with Microsoft Dynamics CRM web services

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Microsoft Dynamics CRM Online Integration with Office 365

This documentation applies to customers who access Microsoft Dynamics CRM Online through the Microsoft Online Services environment. Through integration of Microsoft Dynamics CRM Online with Microsoft Office 365, Microsoft Dynamics CRM Online customers that are subscribed to Office 365 have single sign-on access, through identity federation, to any Office 365 supported application, such as Microsoft Exchange Online. Similarly, when provisioned, Office 365 customers have access to Microsoft Dynamics CRM Online. In addition, by federating Active Directory domain accounts in Microsoft cloud services, businesses can manage a single set of user identities in both their Active Directory domain and Microsoft Dynamics CRM Online.

This topic provides information about where users’ identities are created and managed, and how they relate to Microsoft Dynamics CRM Online.

Identity management with Microsoft Online Services

When accessing the Microsoft Dynamics CRM Online web services, your applications should know the identity provider associated with the logged on user’s Microsoft Dynamics CRM account. Configuration of the user’s authentication credentials for accessing the web services through SDK calls is slightly different for each provider. The details on how to configure user credentials for each identity provider and access the Microsoft Dynamics CRM Online web services is discussed in the topic Authenticate Office 365 users with Microsoft Dynamics CRM Online web services.

There are two identity providers supported by Microsoft Dynamics CRM Online and provisioned through Microsoft Online Services: User ID, and Active Directory (through cloud federation). The following discussion provides an overview of these identity services and how they relate to Microsoft Dynamics CRM Online.

User ID

User ID represents user identities provisioned by customers in Microsoft cloud services and is the identity provider for all customers who have subscribed to the Office 365 collaboration environment. User ID enables you to have access to all Microsoft online services such as Microsoft Exchange Online and Microsoft Dynamics CRM Online. Customers with a User ID have their account credentials and policies managed through Microsoft Online Services.

For the sake of this discussion, User ID users are referred to in this documentation as “managed” or “non-federated” users.

Active Directory

Federation allows customers to use Active Directory-based domain user accounts to access Microsoft Online Services such as Office 365 or Microsoft Dynamics CRM Online. After federation is configured by an administrator, Active Directory-based system user accounts can be locally managed, made available to Microsoft Online Services, and kept in sync with changes made to the on-premises Active Directory identities. The benefit of federation is a single sign-on experience across Microsoft Dynamics CRM 2015 (on-premises) and Microsoft Dynamics CRM Online systems. This type of identity management is useful for large corporations that have hundreds or thousands of established users.

For more information about how to configure identity federation, see Single sign-on: Roadmap.

Identity management with Microsoft account

Microsoft account continues to be a supported identity provider for Microsoft Dynamics CRM Online. However, Microsoft account is not supported for Microsoft Dynamics CRM Online organizations when provisioned through Microsoft Online Services. Microsoft Dynamics CRM Online customers that are not subscribed through Office 365 can access Microsoft Dynamics CRM Online through their Microsoft account.

Microsoft account subscription transition to Office 365

All Microsoft Dynamics CRM Online customers with Microsoft account subscriptions are being transitioned to a Microsoft Office 365/Microsoft Online Services subscription. In this release of the SDK, several authentication-related classes have been updated to ease this transition by supporting Microsoft account logon credentials when you authenticate with the Microsoft Online Services identity provider of Microsoft Dynamics CRM Online. Depending on the SDK classes used by your application to authenticate, you may or may not need to update your application code to support transitioned users.

For more information on required coding changes, see the topic Authenticate Office 365 users with Microsoft Dynamics CRM Online web services. The Microsoft Dynamics CRM Transition Center has additional customer-related information.

See Also

Concepts

Authenticate Office 365 users with Microsoft Dynamics CRM Online web services
Active Directory and claims-based authentication

Other Resources

Connect with Microsoft Office 365 and Microsoft Dynamics CRM Online
AuthenticationCredentials
Active Directory Federation Services
Access Control Service 2.0

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Authenticate Office 365 users with Microsoft Dynamics CRM Online web services

This topic applies to customers who access Microsoft Dynamics CRM Online through the Microsoft Online Services environment. There are multiple Microsoft Dynamics CRM Online identity providers that must be accounted for when you develop an application that connects to the Organization or Discovery web services. These providers can be identified as managed domain, federated, and Microsoft account. This topic focuses on Microsoft Dynamics CRM Online web service authentication with managed domain and federated identity providers, although the same classes and code shown here also work with all supported identity providers and Microsoft Dynamics CRM deployment types.

In This Topic

Use the simplified authentication classes

Authenticate Microsoft account users with Office 365

Authentication deep dive

Use the simplified authentication classes

You can use the OrganizationServiceProxy and DiscoveryServiceProxy classes when authenticating with the web services. For more information about using these proxy classes see Authentication by using the client proxy classes.

Another authentication approach uses the CrmConnection class. With just a few lines of code, your application can authenticate with the web services and start calling web methods. For more information about the CrmConnection class, see Simplified connection to Microsoft Dynamics CRM. Sample code is available in the Sample: Simplified connection quick start using Microsoft Dynamics CRM topic.

C# Copy Code
CrmConnection connection = CrmConnection.Parse (connectionString);
using ( OrganizationService orgService = new OrganizationService(connection)) { }

Another authentication approach is to use the helper source code provided in the SDK. The ServerConnection helper class, shown in the Helper code: ServerConnection class topic, provides GetOrganizationProxy and GetProxy methods for authentication. If you look at the source code for ServerConnection, you will see that GetOrganizationProxy actually calls GetProxy.

C# Copy Code
using ( OrganizationServiceProxy orgServiceProxy = ServerConnection.GetOrganizationProxy(serverConfig) ) { }

You must create these organization or discovery service proxy objects in a using statement to correctly dispose of the service proxy, or call Dispose directly. For sample code that uses the GetOrganizationProxy helper code method, see Sample: Quick start for Microsoft Dynamics CRM.

The complete list of authentication classes available in the Microsoft Dynamics CRM SDK is shown in the Authentication Classes section.

Authenticate Microsoft account users with Office 365

Your application needs to support those Microsoft Dynamics CRM Online users whose organization is transitioned from the Microsoft account identity provider to the Microsoft Online Services identity provider. In this scenario, users may provide their Microsoft account logon credentials when they authenticate with the Microsoft Online Services identity provider of Microsoft Dynamics CRM Online.

To do this, pass the populated logon credentials in the OrganizationServiceProxy constructor or the Authenticate method of the IServiceManagement class. The credential values are populated as follows:

C# Copy Code
AuthenticationCredentials.ClientCredentials = <Microsoft account logon credentials>
AuthenticationCredentials.SupportingCredentials.ClientCredentials = <device credentials>

You can obtain the device credentials by using one of the public methods, for example LoadOrRegister, in the DeviceIdManager helper code. For more information see Helper code: DeviceIdManager class.

If your code checks the identity provider type to determine how to authenticate, then additional code is required. See the GetCredentials method in the next section for sample code that supports transitioned Microsoft account users.

For more information about this transition, see Microsoft Dynamics CRM Online Integration with Office 365.

Authentication deep dive

The previous discussion introduced two simple approaches that can be used to authenticate a user with the Microsoft Dynamics CRM web services. The following information shows how to authenticate a user by using the IServiceManagement`1 class and includes the source code to the GetProxy method. To see the complete sample that contains the following examples, see Sample: Authenticate users with Microsoft Dynamics CRM web services. You will notice that authentication at this level takes a lot more code.

The following sample code demonstrates the classes and methods that you can use in your application to authenticate an Office 365/MOS user using the Microsoft Dynamics CRM Online web services.

C# Copy Code
IServiceManagement<IOrganizationService> orgServiceManagement =
    ServiceConfigurationFactory.CreateManagement<IOrganizationService>(
    new Uri(organizationUri));

// Set the credentials.
AuthenticationCredentials credentials = GetCredentials(orgServiceManagement, endpointType);

// Get the organization service proxy.
using (OrganizationServiceProxy organizationProxy =
    GetProxy<IOrganizationService, OrganizationServiceProxy>(orgServiceManagement, credentials))
{
    // This statement is required to enable early-bound type support.
    organizationProxy.EnableProxyTypes();

    // Now make an SDK call with the organization service proxy.
    // Display information about the logged on user.
    Guid userid = ((WhoAmIResponse)organizationProxy.Execute(
        new WhoAmIRequest())).UserId;
    SystemUser systemUser = organizationProxy.Retrieve("systemuser", userid,
        new ColumnSet(new string[] { "firstname", "lastname" })).ToEntity<SystemUser>();
    Console.WriteLine("Logged on user is {0} {1}.",
        systemUser.FirstName, systemUser.LastName);
}

The code creates an IServiceManagement`1 object for the Organization service. An object of type AuthenticationCredentials is used to contain the user’s logon credentials. The IServiceManagement object and user credentials are then passed to GetProxy to obtain the web service proxy reference.

C# Copy Code
/// <summary>
/// Obtain the AuthenticationCredentials based on AuthenticationProviderType.
/// </summary>
/// <param name="service">A service management object.</param>
/// <param name="endpointType">An AuthenticationProviderType of the CRM environment.</param>
/// <returns>Get filled credentials.</returns>
private AuthenticationCredentials GetCredentials<TService>(IServiceManagement<TService> service, AuthenticationProviderType endpointType)
{
    AuthenticationCredentials authCredentials = new AuthenticationCredentials();

    switch (endpointType)
    {
        case AuthenticationProviderType.ActiveDirectory:
            authCredentials.ClientCredentials.Windows.ClientCredential =
                new System.Net.NetworkCredential(_userName,
                    _password,
                    _domain);
            break;
        case AuthenticationProviderType.LiveId:
            authCredentials.ClientCredentials.UserName.UserName = _userName;
            authCredentials.ClientCredentials.UserName.Password = _password;
            authCredentials.SupportingCredentials = new AuthenticationCredentials();
            authCredentials.SupportingCredentials.ClientCredentials =
                Microsoft.Crm.Services.Utility.DeviceIdManager.LoadOrRegisterDevice();
            break;
        default: // For Federated and OnlineFederated environments.
            authCredentials.ClientCredentials.UserName.UserName = _userName;
            authCredentials.ClientCredentials.UserName.Password = _password;
            // For OnlineFederated single-sign on, you could just use current UserPrincipalName instead of passing user name and password.
            // authCredentials.UserPrincipalName = UserPrincipal.Current.UserPrincipalName;  // Windows Kerberos

            // The service is configured for User Id authentication, but the user might provide Microsoft
            // account credentials. If so, the supporting credentials must contain the device credentials.
            if (endpointType == AuthenticationProviderType.OnlineFederation)
            {
                IdentityProvider provider = service.GetIdentityProvider(authCredentials.ClientCredentials.UserName.UserName);
                if (provider != null && provider.IdentityProviderType == IdentityProviderType.LiveId)
                {
                    authCredentials.SupportingCredentials = new AuthenticationCredentials();
                    authCredentials.SupportingCredentials.ClientCredentials =
                        Microsoft.Crm.Services.Utility.DeviceIdManager.LoadOrRegisterDevice();
                }
            }

            break;
    }

    return authCredentials;
}

The AuthenticationCredentials object is configured according to the subscribed identity for the logged on user. Notice that user credentials for all types of identity providers are shown. The default case handles Microsoft Office 365/MOS managed domain, online users whose identities are federated in the cloud, and transitioned Microsoft account users. Now let’s take a look at what GetProxy actually does.

C# Copy Code
private TProxy GetProxy<TService, TProxy>(
    IServiceManagement<TService> serviceManagement,
    AuthenticationCredentials authCredentials)
    where TService : class
    where TProxy : ServiceProxy<TService>
{
    Type classType = typeof(TProxy);

    if (serviceManagement.AuthenticationType !=
        AuthenticationProviderType.ActiveDirectory)
    {
        AuthenticationCredentials tokenCredentials =
            serviceManagement.Authenticate(authCredentials);
        // Obtain discovery/organization service proxy for Federated, LiveId and OnlineFederated environments.
        // Instantiate a new class of type using the 2 parameter constructor of type IServiceManagement and SecurityTokenResponse.
        return (TProxy)classType
            .GetConstructor(new Type[] { typeof(IServiceManagement<TService>), typeof(SecurityTokenResponse) })
            .Invoke(new object[] { serviceManagement, tokenCredentials.SecurityTokenResponse });
    }

    // Obtain discovery/organization service proxy for ActiveDirectory environment.
    // Instantiate a new class of type using the 2 parameter constructor of type IServiceManagement and ClientCredentials.
    return (TProxy)classType
        .GetConstructor(new Type[] { typeof(IServiceManagement<TService>), typeof(ClientCredentials) })
        .Invoke(new object[] { serviceManagement, authCredentials.ClientCredentials });
}

For all deployments other than on-premises (Active Directory, without claims), the Authenticate method is invoked and then the service proxy is instantiated. Notice that the authentication credentials returned from Authenticate contain the security token response that is used in the service proxy constructor. The generic GetProxy method shown previously can be used to obtain an object reference to either OrganizationServiceProxy or DiscoveryServiceProxy.

See Also

Concepts

Synchronized users in Microsoft Dynamics CRM Online and Office 365
Active Directory and claims-based authentication
Simplified connection to Microsoft Dynamics CRM

Other Resources

Connect with Microsoft Office 365 and Microsoft Dynamics CRM Online
Sample: Authenticate users with Microsoft Dynamics CRM web services
Helper code: ServerConnection class

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Synchronized users in Microsoft Dynamics CRM Online and Office 365

Microsoft Dynamics CRM integration with Microsoft Office 365 adds a new dimension to the concept of a user. User records are stored in both systems’ databases, and are synchronized. In addition, different types of users may exist to handle the situation where a user exists in one system but not the other. This topic describes these types of users, the data that is synchronized, and how to create, update, and delete a synchronized user. This applies to customers who access Microsoft Dynamics CRM Online through the Microsoft Online Services environment.

If you have set up directory synchronization between your local on-premises Active Directory and Microsoft Azure Active Directory, see this KB article: List of attributes that are synchronized to Office 365 and attributes that are written back to the on-premises Active Directory Domain Services.

In This Topic

User records for Office 365 and Microsoft Dynamics CRM Online

Data synchronization with Microsoft Office 365

Create a user for Microsoft Dynamics CRM Online that can be synchronized with Office 365

Update a user for Office 365 and Microsoft Dynamics CRM Online

Disable a user for Office 365 and Microsoft Dynamics CRM Online

User records for Office 365 and Microsoft Dynamics CRM Online

The system user (user) entity stores user records for both Microsoft Dynamics CRM and Office 365. For more information about this entity, see User and team entities.

The following definitions describe the user types that are available through Microsoft Online Services.

Full user

A user who is licensed for full use of Microsoft Dynamics CRM Online, and is synchronized with Office 365. For more information, see Data Synchronization with Microsoft Office 365.

Non-interactive user

A user who is synchronized with Office 365 but can only access Microsoft Dynamics CRM Online using the web services.

Synchronized user

A user who is not licensed to use Microsoft Dynamics CRM Online but who exists in, and is synchronized with, Office 365. For more information, see Data Synchronization with Microsoft Office 365. This user appears as a regular user to other users of Microsoft Dynamics CRM Online, and can own and share records and is similar to a disabled user. This type of user can be created through the Office 365 admin portal or by assigning the user a license through the Admin page. If desired, the license can be removed after the user is synchronized to Microsoft Dynamics CRM Online.

Stub user

A user record that has been created as a placeholder. For example, records have been imported that refer to this user but the user does not exist in Microsoft Dynamics CRM Online. This user cannot log in, cannot be enabled, and cannot be synchronized to Office 365. This type of user can only be created using the Create method or the CreateRequest message, or through data import. Data import always creates stub users.

The following table describes the different types of users for Microsoft Dynamics CRM Online and how they interact with the Microsoft Dynamics CRM application, web services, and with the Office 365 admin portal.

User type | Attribute values | Visible in Office 365 admin portal | Has Org ID | Has CRM License | Enabled in CRM | Can Access CRM UI | Can Access CRM Web Services | Can be Created using UI | Can be created through bulk import | Can be created using web service (Create)
Full | SystemUser.accessmode = Full SystemUser.IsLicensed = true SystemUser.IsSyncWithDirectory = true | Yes | Yes | Yes | Yes | Yes | Yes | No (only in MOP) | Yes | Yes
Non-Interactive | SystemUser.accessmode = Non-interactive SystemUser.IsLicensed = true or false SystemUser.IsSyncWithDirectory = true | Yes | Yes | Yes or No | Yes | No | Yes | Yes (using MOP & CRM UI) | No | Yes
Synchronized | SystemUser.accessmode = Full SystemUser.IsLicensed = false SystemUser.IsSyncWithDirectory = true | Yes | Yes | No | No | No | No | No | No | Yes
Stub user record | SystemUser.accessmode = any value SystemUser.IsLicensed = false SystemUser.IsSyncWithDirectory = false | No | No | No | No | No | No | No | Yes | Yes

Data synchronization with Microsoft Office 365

For full users and synchronized users, data is synchronized with the Office 365 directory. When a synchronized user is created or updated, the values in these attributes are ignored if there is existing data in the Office 365 database. For synchronized users, any Microsoft Dynamics CRM web service call that modifies the synchronized data returns the following warning: “Some data for this record is controlled by the directory and will not be processed.”

If you have set up directory synchronization between your local on-premises Active Directory and Azure Active Directory, see the following knowledge base article to understand which attributes are synchronized from the local Active Directory to the Azure Active Directory. For more information, see List of attributes that are synchronized to Office 365.

The following table lists the attributes that are synchronized with the Office 365 directory.

Display name (Office) | CRM attribute name
First name | FirstName
Last name | LastName
Display name | Not synchronized
User name | WindowsLiveID1 InternalEmailAddress2 Domain
Job Title | Title
User name | Primary email address
Office Phone | Address1_Telephone1
Mobile Phone | MobilePhone
Fax Phone | Address1_Fax
Street Address | Address1_Line1
City | Address1_City
State or province | Address1_StateOrProvince
ZIP or postal code | Address1_PostalCode
Country or region | Address1_Country

1 The User Name property is synchronized to all three Microsoft Dynamics CRM Online attributes.

2 If the InternalEmailAddress attribute value is updated in Microsoft Dynamics CRM Online, it will no longer be synchronized.

Create a user for Microsoft Dynamics CRM Online that can be synchronized with Office 365

You can use the Create method or CreateRequest message to create all types of users. You can also create some types of users through the web application or through a data import operation.

To create a synchronized user, set the attribute value for SystemUser.IsSyncWithDirectory to true. To create a stub user, set the value to false. After this user is created, this attribute value cannot be updated.

When you create a synchronized user, the email address specified in the systemuser entity instance is verified in the Office 365 directory. If a user with that email address does not exist in the directory, an error is thrown.

When you create a sync user, if a Microsoft Dynamics CRM user exists with the same WindowsLiveID, the existing user’s WindowsliveID attribute is updated as follows: _crm<#>_<WindowsLiveID>@<Domain>, where # is replaced with a number to make the value unique. To find users with conflicting IDs in the web application, you can add WindowsLiveID to the view and sort by this attribute to group all the conflicts together.

If you attempt to create a stub user with the same WindowsLiveID as an existing synchronized user, an error is thrown.

Update a user for Office 365 and Microsoft Dynamics CRM Online

You can use the Update method or UpdateRequest message to update all types of users. However, all fields that are synchronized with Office 365 cannot be updated. If you provide values for these attributes they will be ignored. For more information, see Data Synchronization with Microsoft Office 365.

Disable a user for Office 365 and Microsoft Dynamics CRM Online

To disable a user, set the SystemUser.IsDisabled attribute value to true, and set the SystemUser.DisabledReason value to one of the option set values and call the Update method or UpdateRequest message.

You cannot disable a synchronized user, a non-interactive user, or a support user.

See Also

Concepts

User and team entities

Other Resources

Connect with Microsoft Office 365 and Microsoft Dynamics CRM Online
Sample: Authenticate users with Microsoft Dynamics CRM web services

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Authenticate users with Microsoft Dynamics CRM web services
See Also Example

This sample shows how to authenticate a user with any Microsoft Dynamics CRM deployment and obtain a reference to the web services. This sample includes support for Microsoft Office 365 users provisioned in Microsoft Dynamics CRM Online.

Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK\SampleCode\CS\GeneralProgramming\Authentication\AuthenticateWithNoHelp\AuthenticateWithNoHelp.cs

Demonstrates

This sample demonstrates how to authenticate a user with any Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update deployment and make web service calls. This sample doesn’t rely on the CrmServiceHelpers.cs helper code. For a sample that does use helper code, see Sample: Quick start for Microsoft Dynamics CRM.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Reflection;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrate how to do basic authentication using IServiceManagement and SecurityTokenResponse.
    /// </summary>
    class AuthenticateWithNoHelp
    {
        #region Class Level Members
        // To get discovery service address and organization unique name,
        // Sign in to your CRM org and click Settings, Customization, Developer Resources.
        // On Developer Resource page, find the discovery service address under Service Endpoints and organization unique name under Your Organization Information.
        private String _discoveryServiceAddress = "https://dev.crm.dynamics.com/XRMServices/2011/Discovery.svc";
        private String _organizationUniqueName = "OrganizationUniqueName";
        // Provide your user name and password.
        private String _userName = "username@mydomain.com";
        private String _password = "password";

        // Provide domain name for the On-Premises org.
        private String _domain = "mydomain";

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        ///
        /// </summary>
        public void Run()
        {
            IServiceManagement<IDiscoveryService> serviceManagement =
                        ServiceConfigurationFactory.CreateManagement<IDiscoveryService>(
                        new Uri(_discoveryServiceAddress));
            AuthenticationProviderType endpointType = serviceManagement.AuthenticationType;

            // Set the credentials.
            AuthenticationCredentials authCredentials = GetCredentials(serviceManagement, endpointType);

            String organizationUri = String.Empty;
            // Get the discovery service proxy.
            using (DiscoveryServiceProxy discoveryProxy =
                GetProxy<IDiscoveryService, DiscoveryServiceProxy>(serviceManagement, authCredentials))
            {
                // Obtain organization information from the Discovery service.
                if (discoveryProxy != null)
                {
                    // Obtain information about the organizations that the system user belongs to.
                    OrganizationDetailCollection orgs = DiscoverOrganizations(discoveryProxy);
                    // Obtains the Web address (Uri) of the target organization.
                    organizationUri = FindOrganization(_organizationUniqueName,
                        orgs.ToArray()).Endpoints[EndpointType.OrganizationService];

                }
            }

            if (!String.IsNullOrWhiteSpace(organizationUri))
            {
                IServiceManagement<IOrganizationService> orgServiceManagement =
                    ServiceConfigurationFactory.CreateManagement<IOrganizationService>(
                    new Uri(organizationUri));

                // Set the credentials.
                AuthenticationCredentials credentials = GetCredentials(orgServiceManagement, endpointType);

                // Get the organization service proxy.
                using (OrganizationServiceProxy organizationProxy =
                    GetProxy<IOrganizationService, OrganizationServiceProxy>(orgServiceManagement, credentials))
                {
                    // This statement is required to enable early-bound type support.
                    organizationProxy.EnableProxyTypes();

                    // Now make an SDK call with the organization service proxy.
                    // Display information about the logged on user.
                    Guid userid = ((WhoAmIResponse)organizationProxy.Execute(
                        new WhoAmIRequest())).UserId;
                    SystemUser systemUser = organizationProxy.Retrieve("systemuser", userid,
                        new ColumnSet(new string[] { "firstname", "lastname" })).ToEntity<SystemUser>();
                    Console.WriteLine("Logged on user is {0} {1}.",
                        systemUser.FirstName, systemUser.LastName);
                }
            }

        }

        /// <summary>
        /// Obtain the AuthenticationCredentials based on AuthenticationProviderType.
        /// </summary>
        /// <param name="service">A service management object.</param>
        /// <param name="endpointType">An AuthenticationProviderType of the CRM environment.</param>
        /// <returns>Get filled credentials.</returns>
        private AuthenticationCredentials GetCredentials<TService>(IServiceManagement<TService> service, AuthenticationProviderType endpointType)
        {
            AuthenticationCredentials authCredentials = new AuthenticationCredentials();

            switch (endpointType)
            {
                case AuthenticationProviderType.ActiveDirectory:
                    authCredentials.ClientCredentials.Windows.ClientCredential =
                        new System.Net.NetworkCredential(_userName,
                            _password,
                            _domain);
                    break;
                case AuthenticationProviderType.LiveId:
                    authCredentials.ClientCredentials.UserName.UserName = _userName;
                    authCredentials.ClientCredentials.UserName.Password = _password;
                    authCredentials.SupportingCredentials = new AuthenticationCredentials();
                    authCredentials.SupportingCredentials.ClientCredentials =
                        Microsoft.Crm.Services.Utility.DeviceIdManager.LoadOrRegisterDevice();
                    break;
                default: // For Federated and OnlineFederated environments.
                    authCredentials.ClientCredentials.UserName.UserName = _userName;
                    authCredentials.ClientCredentials.UserName.Password = _password;
                    // For OnlineFederated single-sign on, you could just use current UserPrincipalName instead of passing user name and password.
                    // authCredentials.UserPrincipalName = UserPrincipal.Current.UserPrincipalName;  // Windows Kerberos

                    // The service is configured for User Id authentication, but the user might provide Microsoft
                    // account credentials. If so, the supporting credentials must contain the device credentials.
                    if (endpointType == AuthenticationProviderType.OnlineFederation)
                    {
                        IdentityProvider provider = service.GetIdentityProvider(authCredentials.ClientCredentials.UserName.UserName);
                        if (provider != null && provider.IdentityProviderType == IdentityProviderType.LiveId)
                        {
                            authCredentials.SupportingCredentials = new AuthenticationCredentials();
                            authCredentials.SupportingCredentials.ClientCredentials =
                                Microsoft.Crm.Services.Utility.DeviceIdManager.LoadOrRegisterDevice();
                        }
                    }

                    break;
            }

            return authCredentials;
        }

        /// <summary>
        /// Discovers the organizations that the calling user belongs to.
        /// </summary>
        /// <param name="service">A Discovery service proxy instance.</param>
        /// <returns>Array containing detailed information on each organization that
        /// the user belongs to.</returns>
        public OrganizationDetailCollection DiscoverOrganizations(
            IDiscoveryService service)
        {
            if (service == null) throw new ArgumentNullException("service");
            RetrieveOrganizationsRequest orgRequest = new RetrieveOrganizationsRequest();
            RetrieveOrganizationsResponse orgResponse =
                (RetrieveOrganizationsResponse)service.Execute(orgRequest);

            return orgResponse.Details;
        }

        /// <summary>
        /// Finds a specific organization detail in the array of organization details
        /// returned from the Discovery service.
        /// </summary>
        /// <param name="orgUniqueName">The unique name of the organization to find.</param>
        /// <param name="orgDetails">Array of organization detail object returned from the discovery service.</param>
        /// <returns>Organization details or null if the organization was not found.</returns>
        /// <seealso cref="DiscoveryOrganizations"/>
        public OrganizationDetail FindOrganization(string orgUniqueName,
            OrganizationDetail[] orgDetails)
        {
            if (String.IsNullOrWhiteSpace(orgUniqueName))
                throw new ArgumentNullException("orgUniqueName");
            if (orgDetails == null)
                throw new ArgumentNullException("orgDetails");
            OrganizationDetail orgDetail = null;

            foreach (OrganizationDetail detail in orgDetails)
            {
                if (String.Compare(detail.UniqueName, orgUniqueName,
                    StringComparison.InvariantCultureIgnoreCase) == 0)
                {
                    orgDetail = detail;
                    break;
                }
            }
            return orgDetail;
        }

        /// <summary>
        /// Generic method to obtain discovery/organization service proxy instance.
        /// </summary>
        /// <typeparam name="TService">
        /// Set IDiscoveryService or IOrganizationService type to request respective service proxy instance.
        /// </typeparam>
        /// <typeparam name="TProxy">
        /// Set the return type to either DiscoveryServiceProxy or OrganizationServiceProxy type based on TService type.
        /// </typeparam>
        /// <param name="serviceManagement">An instance of IServiceManagement</param>
        /// <param name="authCredentials">The user's Microsoft Dynamics CRM logon credentials.</param>
        /// <returns></returns>
        private TProxy GetProxy<TService, TProxy>(
            IServiceManagement<TService> serviceManagement,
            AuthenticationCredentials authCredentials)
            where TService : class
            where TProxy : ServiceProxy<TService>
        {
            Type classType = typeof(TProxy);

            if (serviceManagement.AuthenticationType !=
                AuthenticationProviderType.ActiveDirectory)
            {
                AuthenticationCredentials tokenCredentials =
                    serviceManagement.Authenticate(authCredentials);
                // Obtain discovery/organization service proxy for Federated, LiveId and OnlineFederated environments.
                // Instantiate a new class of type using the 2 parameter constructor of type IServiceManagement and SecurityTokenResponse.
                return (TProxy)classType
                    .GetConstructor(new Type[] { typeof(IServiceManagement<TService>), typeof(SecurityTokenResponse) })
                    .Invoke(new object[] { serviceManagement, tokenCredentials.SecurityTokenResponse });
            }

            // Obtain discovery/organization service proxy for ActiveDirectory environment.
            // Instantiate a new class of type using the 2 parameter constructor of type IServiceManagement and ClientCredentials.
            return (TProxy)classType
                .GetConstructor(new Type[] { typeof(IServiceManagement<TService>), typeof(ClientCredentials) })
                .Invoke(new object[] { serviceManagement, authCredentials.ClientCredentials });
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                AuthenticateWithNoHelp app = new AuthenticateWithNoHelp();
                app.Run();
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Authenticate Office 365 users with Microsoft Dynamics CRM Online web services

Other Resources

Authenticate users with Microsoft Dynamics CRM web services
Helper code: ServerConnection class
Connect with Microsoft Office 365 and Microsoft Dynamics CRM Online

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Impersonate another user

Impersonation is used to execute business logic (code) on behalf of another Microsoft Dynamics CRM user to provide a desired feature or service using the appropriate role and object-based security of that impersonated user. This is necessary because the Microsoft Dynamics CRM Web services can be called by various clients and services on behalf of a Microsoft Dynamics CRM user, for example, in a workflow or custom ISV solution. Impersonation involves two different user accounts: one user account (A) is used when executing code to perform some task on behalf of another user (B).

Required privileges

User account (A) needs the privilege prvActOnBehalfOfAnotherUser, which is included in the Delegate role.

Alternately, for Active Directory directory service deployments only, user account (A) under which the impersonation code is to run can be added to the PrivUserGroup group in Active Directory. This group is created by Microsoft Dynamics CRM during installation and setup. User account (A) does not have to be associated with a licensed Microsoft Dynamics CRM user. However, the user who is being impersonated (B) must be a licensed Microsoft Dynamics CRM user.

The actual set of privileges that is used to modify data is the intersection of the privileges that the Delegate role user possesses with that of the user that is being impersonated. In other words, user A is allowed to do something if and only if user A and the impersonated user (B) have the privilege necessary for the action.

Impersonate a user

To impersonate a user, set the CallerId property on an instance of OrganizationServiceProxy before calling the service’s Web methods.

See Also

Reference

Privileges not associated with an entity

Concepts

Implement single sign-on from an ASPX webpage or IFRAME
How role-based security can be used to control access to entities in Microsoft Dynamics CRM

Other Resources

Authenticate users with Microsoft Dynamics CRM web services
Security role and privilege reference
Sample: Impersonate using the ActOnBehalfOf privilege

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Implement single sign-on from an ASPX webpage or IFRAME

This topic describes how to develop a custom webpage that can make SDK calls to Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update on behalf of the Microsoft Dynamics CRM user who is signed in. The typical use of this capability is to write a webpage that is displayed in an inline frame in the Microsoft Dynamics CRM web application user interface. That webpage performs its intended operation, for example, providing a store front, while being hosted on a website independent of the site that’s hosting CRM. However, the webpage can perform its operations on behalf of the CRM user who is signed in. The result is seamless integration between a webpage and Microsoft Dynamics CRM.

Microsoft Dynamics CRM 2015 with a separate website

This scenario is for a Microsoft Dynamics CRM 2015 Internet-facing deployment (IFD) where a separate website hosts a custom ASPX webpage that is optionally displayed in an inline frame of the Microsoft Dynamics CRM web application. This scenario uses federated claims. Therefore, you’ll have to set up a security token service (STS) server for identity management. You’ll also need a certificate to be used when making Microsoft Dynamics CRM and the website relying parties, which established cross-domain trust between these parties.

Background information

For more information about how to configure claims and a relying party, see the following topics in Deploying and administering Microsoft Dynamics CRM:

  • Post-Installation and Configuration Guidelines - Configure a Microsoft Dynamics CRM Internet-facing deployment (IFD)
  • System requirements and required technologies - Accessing Microsoft Dynamics CRM from the Internet - Claims-based authentication and IFD requirements

For more information about identity management, see the identity training course.

More information: Walkthrough: Single Sign-on from a Custom Web Page in the Microsoft Dynamics CRM 2011 SDK.

CRM Online with an Azure-hosted webpage

This scenario is for use with Microsoft Dynamics CRM Online where Microsoft Azure hosts a custom webpage that’s optionally displayed in an inline frame of the Microsoft Dynamics CRM web application. This scenario uses federated claims, provided by the Windows Live security token service (STS) server for identity management. You must provide a certificate to be used when making Microsoft Dynamics CRM Online and the Microsoft Azure website relying parties, which established cross-domain trust between these parties.

Background information

For more information about how to configure a relying party, see the following topic: Secure Azure Web Role ASP.NET Web Application Using Access Control Service v2.0

For more information about identity management, see http://channel9.msdn.com/Learn/Courses/IdentityTrainingCourse

For more information about implementing this scenario including problems you may run into and the workarounds, see these blogs: CRM Online & Azure: Improving the SSO experience, and CRM Online & Azure Series.

Enable IFRAME communication across domains

If you want to enable communication for an inline frame that contains content from a different domain, you can use the Window.postMessage method. This browser method can be used for Internet Explorer 8. Google Chrome, Mozilla Firefox, and Apple Safari also support this method. For more information about using postMessage, see the following blog posts:

  • Cross domain calls to the parent CRM 2011 form
  • Cross-Document Messaging and RPC

See Also

Concepts

Impersonate another user
Web resources for Microsoft Dynamics CRM

Other Resources

Authenticate users with Microsoft Dynamics CRM web services
Sample: Impersonate using the ActOnBehalfOf privilege

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Impersonate using the ActOnBehalfOf privilege

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK\SampleCode\CS\GeneralProgramming\Authentication\ImpersonateWithOnBehalfOfPrivilege.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

The user (impersonator) must have the ActOnBehalfOf privilege or be a member of the PrivUserGroup group in Active Directory.

Demonstrates

This sample shows how to impersonate another user by setting the CallerId property of the organization web service proxy.

Examples

Code snippets that highlight the important code are shown first, followed by the complete example code.

Code snippet

C# Copy Code
// Connect to the Organization service.
// The using statement ensures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Retrieve the system user ID of the user to impersonate.
    OrganizationServiceContext orgContext = new OrganizationServiceContext(_serviceProxy);
    _userId = (from user in orgContext.CreateQuery<SystemUser>()
              where user.FullName == "Kevin Cook"
              select user.SystemUserId.Value).FirstOrDefault();

    // To impersonate another user, set the OrganizationServiceProxy.CallerId
    // property to the ID of the other user.
    _serviceProxy.CallerId = _userId;

    // Instantiate an account object.
    // See the Entity Metadata topic in the SDK documentation to determine
    // which attributes must be set for each entity.
    Account account = new Account { Name = "Fourth Coffee" };

    // Create an account record named Fourth Coffee.
    _accountId = _serviceProxy.Create(account);
    Console.Write("{0} {1} created, ", account.LogicalName, account.Name);

Complete example

C# Copy Code
using System;
using System.ServiceModel;
using System.Linq;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to impersonate another user with the on-behalf-of privilege and
    /// do basic entity operations like create, retrieve, update, and delete.</summary>
    /// <remarks>
    /// The system user account under which you run the sample must be part of the
    /// Administrators group on your computer system so that this sample can create
    /// and use a second user account. You must also have the
    /// “Act on Behalf of Another User” privilege in Microsoft Dynamics CRM.
    ///
    /// Note that the effective set of privileges for the operations performed will be the
    /// intersection of the privileges that the logged on (privileged) user possesses with
    /// that of the user that is being impersonated.
    ///
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class ImpersonateWithOnBehalfOfPrivilege
    {
        #region Class Level Members

        private Guid _userId;
        private Guid _accountId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method connects to the Organization service using an impersonated user
        /// credential. Afterwards, basic create, retrieve, update, and delete entity
        /// operations are performed as the impersonated user.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete
        /// all created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement ensures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Retrieve the system user ID of the user to impersonate.
                    OrganizationServiceContext orgContext = new OrganizationServiceContext(_serviceProxy);
                    _userId = (from user in orgContext.CreateQuery<SystemUser>()
                              where user.FullName == "Kevin Cook"
                              select user.SystemUserId.Value).FirstOrDefault();

                    // To impersonate another user, set the OrganizationServiceProxy.CallerId
                    // property to the ID of the other user.
                    _serviceProxy.CallerId = _userId;

                    // Instantiate an account object.
                    // See the Entity Metadata topic in the SDK documentation to determine
                    // which attributes must be set for each entity.
                    Account account = new Account { Name = "Fourth Coffee" };

                    // Create an account record named Fourth Coffee.
                    _accountId = _serviceProxy.Create(account);
                    Console.Write("{0} {1} created, ", account.LogicalName, account.Name);

                    // Retrieve the account containing several of its attributes.
                    // CreatedBy should reference the impersonated SystemUser.
                    // CreatedOnBehalfBy should reference the running SystemUser.
                    ColumnSet cols = new ColumnSet(
                        "name",
                        "createdby",
                        "createdonbehalfby",
                        "address1_postalcode",
                        "lastusedincampaign");

                    Account retrievedAccount =
                        (Account)_serviceProxy.Retrieve(Account.EntityLogicalName,
                            _accountId, cols);
                    Console.Write("retrieved, ");

                    // Update the postal code attribute.
                    retrievedAccount.Address1_PostalCode = "98052";

                    // The address 2 postal code was set accidentally, so set it to null.
                    retrievedAccount.Address2_PostalCode = null;

                    // Shows use of a Money value.
                    retrievedAccount.Revenue = new Money(5000000);

                    // Shows use of a boolean value.
                    retrievedAccount.CreditOnHold = false;

                    // Update the account record.
                    _serviceProxy.Update(retrievedAccount);
                    Console.Write("updated, ");

                    // Delete the account record.
                    _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
                    Console.WriteLine("and deleted.");

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a second user that we will impersonate in our sample code.
            SystemUserProvider.RetrieveSalesManager(_serviceProxy);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            // For this sample, all created records are deleted in the Run() method.
            // The system user named "Kevin Cook" that was created by this sample will
            // continue to exist on your system because system users cannot be deleted
            // in Microsoft Dynamics CRM.  They can only be enabled or disabled.
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                ImpersonateWithOnBehalfOfPrivilege app = new ImpersonateWithOnBehalfOfPrivilege();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Impersonate another user
How role-based security can be used to control access to entities in Microsoft Dynamics CRM

Other Resources

Authenticate users with Microsoft Dynamics CRM web services
Sample: Authenticate users with Microsoft Dynamics CRM web services
CallerId

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the early bound entity classes in code

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, the code generation tool (CrmSvcUtil) creates early-bound entity classes that you can use to access business data in Microsoft Dynamics CRM. These classes include one class for each entity in your installation, including custom entities. Each time you make customizations to your system, you must regenerate these classes. The classes can be used in any project type or built into a class library. You can use early-bound entity classes when creating applications that use Microsoft Dynamics CRM as well as plug-ins and custom workflow activities. For more information about using the code generation tool, see Create early bound entity classes with the code generation tool (CrmSvcUtil.exe).

The advantages to using early-bound entity classes is that all type references are checked at compile time. The compiled executable contains the code necessary to invoke the types’ properties, methods, and events. For more information, see Use the early-bound entity classes for create, update, and delete.

The class created by the code generation tool includes all the entity’s attributes and relationships. By using the class in your code, you can access these attributes and be type safe. A class with attributes and relationships is created for all entities in your organization. There is no difference between the generated types for system and custom entities.

Tip
You may experience a situation where there are two sets of early-bound entity classes, perhaps each in its own namespace, compiled into your application. For example, you include one set in your application directly and another set exists in a class library your application is linked to. In this case, you may receive an ArgumentException exception and the following error message:

“A proxy type with the name <entity name> has been defined by another assembly.”

In a situation like this, you can use the EnableProxyTypes method, which takes an Assembly object parameter. This method specifies an assembly that contains the early-bound entity proxy types to use with the organization service proxy. This allows you to use different assemblies for different sets of entity proxy instances.

The following sample shows how to set the email address of a contact entity. For this example, assume that a query has found the record to be changed and the logical name is Contact:

C# Copy Code
Contact contact = New Contact();contact.EMailAddress1 = "marykay@contoso.com";

The following sample shows how to use custom entities and attributes:

C# Copy Code
new_bankaccount bankaccount = New new_bankaccount();bankaccount.new_accountnumber = "12345";

For more information about using early bound entity classes, see the following topics:

Use the OrganizationServiceContext class

Use the early-bound entity classes for create, update, and delete

Use the early bound entity classes to add or update associations between related records

Mix early and late bound entities

Sample: Create, retrieve, update, and delete records (early bound)

Sample: Associate records (early bound)

Sample: Create and update records with related records (early bound)

Sample: Assign a record to a new owner

Sample: Use the organization service context

Sample: Serialize and deserialize an entity Instance

Code generation example

The code generation tool creates classes based on the entities in Microsoft Dynamics CRM. For example, the code generation tool creates the following class for the Team entity.

C# Copy Code
/// <summary>
/// Collection of system users that routinely collaborate.
/// Teams can be used to simplify record sharing and provide team members with common access
/// to organization data when team members belong to different Business Units.
/// </summary>
[System.Runtime.Serialization.DataContractAttribute()]
[Microsoft.Xrm.Sdk.Client.EntityLogicalNameAttribute("team")]
[System.CodeDom.Compiler.GeneratedCodeAttribute("CrmSvcUtil", "5.0.9688.32")]
public partial class Team : Microsoft.Xrm.Sdk.Entity, System.ComponentModel.INotifyPropertyChanging, System.ComponentModel.INotifyPropertyChanged
{

/// <summary>
/// Default Constructor.
/// </summary>
public Team() :
base(EntityLogicalName)
{
}

public const string EntityLogicalName = "team";

public const int EntityTypeCode = 9;

public event System.ComponentModel.PropertyChangedEventHandler PropertyChanged;

public event System.ComponentModel.PropertyChangingEventHandler PropertyChanging;

private void OnPropertyChanged(string propertyName)
{
if ((this.PropertyChanged != null))
{
this.PropertyChanged(this, new System.ComponentModel.PropertyChangedEventArgs(propertyName));
}
}

private void OnPropertyChanging(string propertyName)
{
if ((this.PropertyChanging != null))
{
this.PropertyChanging(this, new System.ComponentModel.PropertyChangingEventArgs(propertyName));
}
}

/// <summary>
/// Unique identifier of the user primary responsible for the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("administratorid")]
public Microsoft.Xrm.Sdk.EntityReference AdministratorId
{
get
{
return this.GetAttributeValue<Microsoft.Xrm.Sdk.EntityReference>("administratorid");
}
set
{
this.OnPropertyChanging("AdministratorId");
this.SetAttributeValue("administratorid", value);
this.OnPropertyChanged("AdministratorId");
}
}

/// <summary>
/// Unique identifier of the business unit with which the team is associated.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("businessunitid")]
public Microsoft.Xrm.Sdk.EntityReference BusinessUnitId
{
get
{
return this.GetAttributeValue<Microsoft.Xrm.Sdk.EntityReference>("businessunitid");
}
set
{
this.OnPropertyChanging("BusinessUnitId");
this.SetAttributeValue("businessunitid", value);
this.OnPropertyChanged("BusinessUnitId");
}
}

/// <summary>
/// Unique identifier of the user who created the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("createdby")]
public Microsoft.Xrm.Sdk.EntityReference CreatedBy
{
get
{
return this.GetAttributeValue<Microsoft.Xrm.Sdk.EntityReference>("createdby");
}
}

/// <summary>
/// Date and time when the team was created.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("createdon")]
public System.Nullable<System.DateTime> CreatedOn
{
get
{
return this.GetAttributeValue<System.Nullable<System.DateTime>>("createdon");
}
}

/// <summary>
/// Unique identifier of the delegate user who created the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("createdonbehalfby")]
public Microsoft.Xrm.Sdk.EntityReference CreatedOnBehalfBy
{
get
{
return this.GetAttributeValue<Microsoft.Xrm.Sdk.EntityReference>("createdonbehalfby");
}
}

/// <summary>
/// Description of the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("description")]
public string Description
{
get
{
return this.GetAttributeValue<string>("description");
}
set
{
this.OnPropertyChanging("Description");
this.SetAttributeValue("description", value);
this.OnPropertyChanged("Description");
}
}

/// <summary>
/// E-mail address for the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("emailaddress")]
public string EMailAddress
{
get
{
return this.GetAttributeValue<string>("emailaddress");
}
set
{
this.OnPropertyChanging("EMailAddress");
this.SetAttributeValue("emailaddress", value);
this.OnPropertyChanged("EMailAddress");
}
}

/// <summary>
/// Exchange rate for the currency associated with the team with respect to the base currency.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("exchangerate")]
public System.Nullable<decimal> ExchangeRate
{
get
{
return this.GetAttributeValue<System.Nullable<decimal>>("exchangerate");
}
}

/// <summary>
/// Unique identifier of the data import or data migration that created this record.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("importsequencenumber")]
public System.Nullable<int> ImportSequenceNumber
{
get
{
return this.GetAttributeValue<System.Nullable<int>>("importsequencenumber");
}
set
{
this.OnPropertyChanging("ImportSequenceNumber");
this.SetAttributeValue("importsequencenumber", value);
this.OnPropertyChanged("ImportSequenceNumber");
}
}

/// <summary>
/// Information about whether the team is a default business unit team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("isdefault")]
public System.Nullable<bool> IsDefault
{
get
{
return this.GetAttributeValue<System.Nullable<bool>>("isdefault");
}
}

/// <summary>
/// Unique identifier of the user who last modified the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("modifiedby")]
public Microsoft.Xrm.Sdk.EntityReference ModifiedBy
{
get
{
return this.GetAttributeValue<Microsoft.Xrm.Sdk.EntityReference>("modifiedby");
}
}

/// <summary>
/// Date and time when the team was last modified.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("modifiedon")]
public System.Nullable<System.DateTime> ModifiedOn
{
get
{
return this.GetAttributeValue<System.Nullable<System.DateTime>>("modifiedon");
}
}

/// <summary>
/// Unique identifier of the delegate user who last modified the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("modifiedonbehalfby")]
public Microsoft.Xrm.Sdk.EntityReference ModifiedOnBehalfBy
{
get
{
return this.GetAttributeValue<Microsoft.Xrm.Sdk.EntityReference>("modifiedonbehalfby");
}
}

/// <summary>
/// Name of the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("name")]
public string Name
{
get
{
return this.GetAttributeValue<string>("name");
}
set
{
this.OnPropertyChanging("Name");
this.SetAttributeValue("name", value);
this.OnPropertyChanged("Name");
}
}

/// <summary>
/// Unique identifier of the organization associated with the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("organizationid")]
public System.Nullable<System.Guid> OrganizationId
{
get
{
return this.GetAttributeValue<System.Nullable<System.Guid>>("organizationid");
}
}

/// <summary>
/// Date and time that the record was migrated.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("overriddencreatedon")]
public System.Nullable<System.DateTime> OverriddenCreatedOn
{
get
{
return this.GetAttributeValue<System.Nullable<System.DateTime>>("overriddencreatedon");
}
set
{
this.OnPropertyChanging("OverriddenCreatedOn");
this.SetAttributeValue("overriddencreatedon", value);
this.OnPropertyChanged("OverriddenCreatedOn");
}
}

/// <summary>
/// Unique identifier of the default queue for the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("queueid")]
public Microsoft.Xrm.Sdk.EntityReference QueueId
{
get
{
return this.GetAttributeValue<Microsoft.Xrm.Sdk.EntityReference>("queueid");
}
set
{
this.OnPropertyChanging("QueueId");
this.SetAttributeValue("queueid", value);
this.OnPropertyChanged("QueueId");
}
}

/// <summary>
/// Unique identifier for the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("teamid")]
public System.Nullable<System.Guid> TeamId
{
get
{
return this.GetAttributeValue<System.Nullable<System.Guid>>("teamid");
}
set
{
this.OnPropertyChanging("TeamId");
this.SetAttributeValue("teamid", value);
if (value.HasValue)
{
base.Id = value.Value;
}
else
{
base.Id = System.Guid.Empty;
}
this.OnPropertyChanged("TeamId");
}
}

[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("teamid")]
public override System.Guid Id
{
get
{
return base.Id;
}
set
{
this.TeamId = value;
}
}

/// <summary>
/// Unique identifier of the currency associated with the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("transactioncurrencyid")]
public Microsoft.Xrm.Sdk.EntityReference TransactionCurrencyId
{
get
{
return this.GetAttributeValue<Microsoft.Xrm.Sdk.EntityReference>("transactioncurrencyid");
}
set
{
this.OnPropertyChanging("TransactionCurrencyId");
this.SetAttributeValue("transactioncurrencyid", value);
this.OnPropertyChanged("TransactionCurrencyId");
}
}

/// <summary>
/// Version number of the team.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("versionnumber")]
public System.Nullable<long> VersionNumber
{
get
{
return this.GetAttributeValue<System.Nullable<long>>("versionnumber");
}
}

/// <summary>
/// Pronunciation of the full name of the team, written in phonetic hiragana or katakana characters.
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("yominame")]
public string YomiName
{
get
{
return this.GetAttributeValue<string>("yominame");
}
set
{
this.OnPropertyChanging("YomiName");
this.SetAttributeValue("yominame", value);
this.OnPropertyChanged("YomiName");
}
}

/// <summary>
/// 1:N ImportFile_Team
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("ImportFile_Team")]
public System.Collections.Generic.IEnumerable<ImportFile> ImportFile_Team
{
get
{
return this.GetRelatedEntities<ImportFile>("ImportFile_Team", null);
}
set
{
this.OnPropertyChanging("ImportFile_Team");
this.SetRelatedEntities<ImportFile>("ImportFile_Team", null, value);
this.OnPropertyChanged("ImportFile_Team");
}
}

/// <summary>
/// 1:N lead_owning_team
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("lead_owning_team")]
public System.Collections.Generic.IEnumerable<Lead> lead_owning_team
{
get
{
return this.GetRelatedEntities<Lead>("lead_owning_team", null);
}
set
{
this.OnPropertyChanging("lead_owning_team");
this.SetRelatedEntities<Lead>("lead_owning_team", null, value);
this.OnPropertyChanged("lead_owning_team");
}
}

/// <summary>
/// 1:N team_accounts
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_accounts")]
public System.Collections.Generic.IEnumerable<Account> team_accounts
{
get
{
return this.GetRelatedEntities<Account>("team_accounts", null);
}
set
{
this.OnPropertyChanging("team_accounts");
this.SetRelatedEntities<Account>("team_accounts", null, value);
this.OnPropertyChanged("team_accounts");
}
}

/// <summary>
/// 1:N team_activity
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_activity")]
public System.Collections.Generic.IEnumerable<ActivityPointer> team_activity
{
get
{
return this.GetRelatedEntities<ActivityPointer>("team_activity", null);
}
set
{
this.OnPropertyChanging("team_activity");
this.SetRelatedEntities<ActivityPointer>("team_activity", null, value);
this.OnPropertyChanged("team_activity");
}
}

/// <summary>
/// 1:N team_annotations
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_annotations")]
public System.Collections.Generic.IEnumerable<Annotation> team_annotations
{
get
{
return this.GetRelatedEntities<Annotation>("team_annotations", null);
}
set
{
this.OnPropertyChanging("team_annotations");
this.SetRelatedEntities<Annotation>("team_annotations", null, value);
this.OnPropertyChanged("team_annotations");
}
}

/// <summary>
/// 1:N team_appointment
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_appointment")]
public System.Collections.Generic.IEnumerable<Appointment> team_appointment
{
get
{
return this.GetRelatedEntities<Appointment>("team_appointment", null);
}
set
{
this.OnPropertyChanging("team_appointment");
this.SetRelatedEntities<Appointment>("team_appointment", null, value);
this.OnPropertyChanged("team_appointment");
}
}

/// <summary>
/// 1:N team_asyncoperation
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_asyncoperation")]
public System.Collections.Generic.IEnumerable<AsyncOperation> team_asyncoperation
{
get
{
return this.GetRelatedEntities<AsyncOperation>("team_asyncoperation", null);
}
set
{
this.OnPropertyChanging("team_asyncoperation");
this.SetRelatedEntities<AsyncOperation>("team_asyncoperation", null, value);
this.OnPropertyChanged("team_asyncoperation");
}
}

/// <summary>
/// 1:N Team_AsyncOperations
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("Team_AsyncOperations")]
public System.Collections.Generic.IEnumerable<AsyncOperation> Team_AsyncOperations
{
get
{
return this.GetRelatedEntities<AsyncOperation>("Team_AsyncOperations", null);
}
set
{
this.OnPropertyChanging("Team_AsyncOperations");
this.SetRelatedEntities<AsyncOperation>("Team_AsyncOperations", null, value);
this.OnPropertyChanged("Team_AsyncOperations");
}
}

/// <summary>
/// 1:N Team_BulkDeleteFailures
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("Team_BulkDeleteFailures")]
public System.Collections.Generic.IEnumerable<BulkDeleteFailure> Team_BulkDeleteFailures
{
get
{
return this.GetRelatedEntities<BulkDeleteFailure>("Team_BulkDeleteFailures", null);
}
set
{
this.OnPropertyChanging("Team_BulkDeleteFailures");
this.SetRelatedEntities<BulkDeleteFailure>("Team_BulkDeleteFailures", null, value);
this.OnPropertyChanged("Team_BulkDeleteFailures");
}
}

/// <summary>
/// 1:N team_BulkOperation
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_BulkOperation")]
public System.Collections.Generic.IEnumerable<BulkOperation> team_BulkOperation
{
get
{
return this.GetRelatedEntities<BulkOperation>("team_BulkOperation", null);
}
set
{
this.OnPropertyChanging("team_BulkOperation");
this.SetRelatedEntities<BulkOperation>("team_BulkOperation", null, value);
this.OnPropertyChanged("team_BulkOperation");
}
}

/// <summary>
/// 1:N team_campaignactivity
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_campaignactivity")]
public System.Collections.Generic.IEnumerable<CampaignActivity> team_campaignactivity
{
get
{
return this.GetRelatedEntities<CampaignActivity>("team_campaignactivity", null);
}
set
{
this.OnPropertyChanging("team_campaignactivity");
this.SetRelatedEntities<CampaignActivity>("team_campaignactivity", null, value);
this.OnPropertyChanged("team_campaignactivity");
}
}

/// <summary>
/// 1:N team_campaignresponse
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_campaignresponse")]
public System.Collections.Generic.IEnumerable<CampaignResponse> team_campaignresponse
{
get
{
return this.GetRelatedEntities<CampaignResponse>("team_campaignresponse", null);
}
set
{
this.OnPropertyChanging("team_campaignresponse");
this.SetRelatedEntities<CampaignResponse>("team_campaignresponse", null, value);
this.OnPropertyChanged("team_campaignresponse");
}
}

/// <summary>
/// 1:N team_Campaigns
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_Campaigns")]
public System.Collections.Generic.IEnumerable<Campaign> team_Campaigns
{
get
{
return this.GetRelatedEntities<Campaign>("team_Campaigns", null);
}
set
{
this.OnPropertyChanging("team_Campaigns");
this.SetRelatedEntities<Campaign>("team_Campaigns", null, value);
this.OnPropertyChanged("team_Campaigns");
}
}

/// <summary>
/// 1:N team_connections1
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_connections1")]
public System.Collections.Generic.IEnumerable<Connection> team_connections1
{
get
{
return this.GetRelatedEntities<Connection>("team_connections1", null);
}
set
{
this.OnPropertyChanging("team_connections1");
this.SetRelatedEntities<Connection>("team_connections1", null, value);
this.OnPropertyChanged("team_connections1");
}
}

/// <summary>
/// 1:N team_connections2
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_connections2")]
public System.Collections.Generic.IEnumerable<Connection> team_connections2
{
get
{
return this.GetRelatedEntities<Connection>("team_connections2", null);
}
set
{
this.OnPropertyChanging("team_connections2");
this.SetRelatedEntities<Connection>("team_connections2", null, value);
this.OnPropertyChanged("team_connections2");
}
}

/// <summary>
/// 1:N team_contacts
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_contacts")]
public System.Collections.Generic.IEnumerable<Contact> team_contacts
{
get
{
return this.GetRelatedEntities<Contact>("team_contacts", null);
}
set
{
this.OnPropertyChanging("team_contacts");
this.SetRelatedEntities<Contact>("team_contacts", null, value);
this.OnPropertyChanged("team_contacts");
}
}

/// <summary>
/// 1:N team_customer_opportunity_roles
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_customer_opportunity_roles")]
public System.Collections.Generic.IEnumerable<CustomerOpportunityRole> team_customer_opportunity_roles
{
get
{
return this.GetRelatedEntities<CustomerOpportunityRole>("team_customer_opportunity_roles", null);
}
set
{
this.OnPropertyChanging("team_customer_opportunity_roles");
this.SetRelatedEntities<CustomerOpportunityRole>("team_customer_opportunity_roles", null, value);
this.OnPropertyChanged("team_customer_opportunity_roles");
}
}

/// <summary>
/// 1:N team_customer_relationship
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_customer_relationship")]
public System.Collections.Generic.IEnumerable<CustomerRelationship> team_customer_relationship
{
get
{
return this.GetRelatedEntities<CustomerRelationship>("team_customer_relationship", null);
}
set
{
this.OnPropertyChanging("team_customer_relationship");
this.SetRelatedEntities<CustomerRelationship>("team_customer_relationship", null, value);
this.OnPropertyChanged("team_customer_relationship");
}
}

/// <summary>
/// 1:N Team_DuplicateBaseRecord
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("Team_DuplicateBaseRecord")]
public System.Collections.Generic.IEnumerable<DuplicateRecord> Team_DuplicateBaseRecord
{
get
{
return this.GetRelatedEntities<DuplicateRecord>("Team_DuplicateBaseRecord", null);
}
set
{
this.OnPropertyChanging("Team_DuplicateBaseRecord");
this.SetRelatedEntities<DuplicateRecord>("Team_DuplicateBaseRecord", null, value);
this.OnPropertyChanged("Team_DuplicateBaseRecord");
}
}

/// <summary>
/// 1:N Team_DuplicateMatchingRecord
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("Team_DuplicateMatchingRecord")]
public System.Collections.Generic.IEnumerable<DuplicateRecord> Team_DuplicateMatchingRecord
{
get
{
return this.GetRelatedEntities<DuplicateRecord>("Team_DuplicateMatchingRecord", null);
}
set
{
this.OnPropertyChanging("Team_DuplicateMatchingRecord");
this.SetRelatedEntities<DuplicateRecord>("Team_DuplicateMatchingRecord", null, value);
this.OnPropertyChanged("Team_DuplicateMatchingRecord");
}
}

/// <summary>
/// 1:N team_DuplicateRules
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_DuplicateRules")]
public System.Collections.Generic.IEnumerable<DuplicateRule> team_DuplicateRules
{
get
{
return this.GetRelatedEntities<DuplicateRule>("team_DuplicateRules", null);
}
set
{
this.OnPropertyChanging("team_DuplicateRules");
this.SetRelatedEntities<DuplicateRule>("team_DuplicateRules", null, value);
this.OnPropertyChanged("team_DuplicateRules");
}
}

/// <summary>
/// 1:N team_email
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_email")]
public System.Collections.Generic.IEnumerable<Email> team_email
{
get
{
return this.GetRelatedEntities<Email>("team_email", null);
}
set
{
this.OnPropertyChanging("team_email");
this.SetRelatedEntities<Email>("team_email", null, value);
this.OnPropertyChanged("team_email");
}
}

/// <summary>
/// 1:N team_email_templates
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_email_templates")]
public System.Collections.Generic.IEnumerable<Template> team_email_templates
{
get
{
return this.GetRelatedEntities<Template>("team_email_templates", null);
}
set
{
this.OnPropertyChanging("team_email_templates");
this.SetRelatedEntities<Template>("team_email_templates", null, value);
this.OnPropertyChanged("team_email_templates");
}
}

/// <summary>
/// 1:N team_fax
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_fax")]
public System.Collections.Generic.IEnumerable<Fax> team_fax
{
get
{
return this.GetRelatedEntities<Fax>("team_fax", null);
}
set
{
this.OnPropertyChanging("team_fax");
this.SetRelatedEntities<Fax>("team_fax", null, value);
this.OnPropertyChanged("team_fax");
}
}

/// <summary>
/// 1:N team_goal
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_goal")]
public System.Collections.Generic.IEnumerable<Goal> team_goal
{
get
{
return this.GetRelatedEntities<Goal>("team_goal", null);
}
set
{
this.OnPropertyChanging("team_goal");
this.SetRelatedEntities<Goal>("team_goal", null, value);
this.OnPropertyChanged("team_goal");
}
}

/// <summary>
/// 1:N team_goal_goalowner
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_goal_goalowner")]
public System.Collections.Generic.IEnumerable<Goal> team_goal_goalowner
{
get
{
return this.GetRelatedEntities<Goal>("team_goal_goalowner", null);
}
set
{
this.OnPropertyChanging("team_goal_goalowner");
this.SetRelatedEntities<Goal>("team_goal_goalowner", null, value);
this.OnPropertyChanged("team_goal_goalowner");
}
}

/// <summary>
/// 1:N team_goalrollupquery
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_goalrollupquery")]
public System.Collections.Generic.IEnumerable<GoalRollupQuery> team_goalrollupquery
{
get
{
return this.GetRelatedEntities<GoalRollupQuery>("team_goalrollupquery", null);
}
set
{
this.OnPropertyChanging("team_goalrollupquery");
this.SetRelatedEntities<GoalRollupQuery>("team_goalrollupquery", null, value);
this.OnPropertyChanged("team_goalrollupquery");
}
}

/// <summary>
/// 1:N team_ImportFiles
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_ImportFiles")]
public System.Collections.Generic.IEnumerable<ImportFile> team_ImportFiles
{
get
{
return this.GetRelatedEntities<ImportFile>("team_ImportFiles", null);
}
set
{
this.OnPropertyChanging("team_ImportFiles");
this.SetRelatedEntities<ImportFile>("team_ImportFiles", null, value);
this.OnPropertyChanged("team_ImportFiles");
}
}

/// <summary>
/// 1:N team_ImportLogs
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_ImportLogs")]
public System.Collections.Generic.IEnumerable<ImportLog> team_ImportLogs
{
get
{
return this.GetRelatedEntities<ImportLog>("team_ImportLogs", null);
}
set
{
this.OnPropertyChanging("team_ImportLogs");
this.SetRelatedEntities<ImportLog>("team_ImportLogs", null, value);
this.OnPropertyChanged("team_ImportLogs");
}
}

/// <summary>
/// 1:N team_ImportMaps
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_ImportMaps")]
public System.Collections.Generic.IEnumerable<ImportMap> team_ImportMaps
{
get
{
return this.GetRelatedEntities<ImportMap>("team_ImportMaps", null);
}
set
{
this.OnPropertyChanging("team_ImportMaps");
this.SetRelatedEntities<ImportMap>("team_ImportMaps", null, value);
this.OnPropertyChanged("team_ImportMaps");
}
}

/// <summary>
/// 1:N team_Imports
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_Imports")]
public System.Collections.Generic.IEnumerable<Import> team_Imports
{
get
{
return this.GetRelatedEntities<Import>("team_Imports", null);
}
set
{
this.OnPropertyChanging("team_Imports");
this.SetRelatedEntities<Import>("team_Imports", null, value);
this.OnPropertyChanged("team_Imports");
}
}

/// <summary>
/// 1:N team_incidentresolution
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_incidentresolution")]
public System.Collections.Generic.IEnumerable<IncidentResolution> team_incidentresolution
{
get
{
return this.GetRelatedEntities<IncidentResolution>("team_incidentresolution", null);
}
set
{
this.OnPropertyChanging("team_incidentresolution");
this.SetRelatedEntities<IncidentResolution>("team_incidentresolution", null, value);
this.OnPropertyChanged("team_incidentresolution");
}
}

/// <summary>
/// 1:N team_incidents
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_incidents")]
public System.Collections.Generic.IEnumerable<Incident> team_incidents
{
get
{
return this.GetRelatedEntities<Incident>("team_incidents", null);
}
set
{
this.OnPropertyChanging("team_incidents");
this.SetRelatedEntities<Incident>("team_incidents", null, value);
this.OnPropertyChanged("team_incidents");
}
}

/// <summary>
/// 1:N team_invoices
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_invoices")]
public System.Collections.Generic.IEnumerable<Invoice> team_invoices
{
get
{
return this.GetRelatedEntities<Invoice>("team_invoices", null);
}
set
{
this.OnPropertyChanging("team_invoices");
this.SetRelatedEntities<Invoice>("team_invoices", null, value);
this.OnPropertyChanged("team_invoices");
}
}

/// <summary>
/// 1:N team_letter
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_letter")]
public System.Collections.Generic.IEnumerable<Letter> team_letter
{
get
{
return this.GetRelatedEntities<Letter>("team_letter", null);
}
set
{
this.OnPropertyChanging("team_letter");
this.SetRelatedEntities<Letter>("team_letter", null, value);
this.OnPropertyChanged("team_letter");
}
}

/// <summary>
/// 1:N team_list
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_list")]
public System.Collections.Generic.IEnumerable<List> team_list
{
get
{
return this.GetRelatedEntities<List>("team_list", null);
}
set
{
this.OnPropertyChanging("team_list");
this.SetRelatedEntities<List>("team_list", null, value);
this.OnPropertyChanged("team_list");
}
}

/// <summary>
/// 1:N team_opportunities
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_opportunities")]
public System.Collections.Generic.IEnumerable<Opportunity> team_opportunities
{
get
{
return this.GetRelatedEntities<Opportunity>("team_opportunities", null);
}
set
{
this.OnPropertyChanging("team_opportunities");
this.SetRelatedEntities<Opportunity>("team_opportunities", null, value);
this.OnPropertyChanged("team_opportunities");
}
}

/// <summary>
/// 1:N team_opportunityclose
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_opportunityclose")]
public System.Collections.Generic.IEnumerable<OpportunityClose> team_opportunityclose
{
get
{
return this.GetRelatedEntities<OpportunityClose>("team_opportunityclose", null);
}
set
{
this.OnPropertyChanging("team_opportunityclose");
this.SetRelatedEntities<OpportunityClose>("team_opportunityclose", null, value);
this.OnPropertyChanged("team_opportunityclose");
}
}

/// <summary>
/// 1:N team_orderclose
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_orderclose")]
public System.Collections.Generic.IEnumerable<OrderClose> team_orderclose
{
get
{
return this.GetRelatedEntities<OrderClose>("team_orderclose", null);
}
set
{
this.OnPropertyChanging("team_orderclose");
this.SetRelatedEntities<OrderClose>("team_orderclose", null, value);
this.OnPropertyChanged("team_orderclose");
}
}

/// <summary>
/// 1:N team_orders
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_orders")]
public System.Collections.Generic.IEnumerable<SalesOrder> team_orders
{
get
{
return this.GetRelatedEntities<SalesOrder>("team_orders", null);
}
set
{
this.OnPropertyChanging("team_orders");
this.SetRelatedEntities<SalesOrder>("team_orders", null, value);
this.OnPropertyChanged("team_orders");
}
}

/// <summary>
/// 1:N team_phonecall
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_phonecall")]
public System.Collections.Generic.IEnumerable<PhoneCall> team_phonecall
{
get
{
return this.GetRelatedEntities<PhoneCall>("team_phonecall", null);
}
set
{
this.OnPropertyChanging("team_phonecall");
this.SetRelatedEntities<PhoneCall>("team_phonecall", null, value);
this.OnPropertyChanged("team_phonecall");
}
}

/// <summary>
/// 1:N team_principalobjectattributeaccess
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_principalobjectattributeaccess")]
public System.Collections.Generic.IEnumerable<PrincipalObjectAttributeAccess> team_principalobjectattributeaccess
{
get
{
return this.GetRelatedEntities<PrincipalObjectAttributeAccess>("team_principalobjectattributeaccess", null);
}
set
{
this.OnPropertyChanging("team_principalobjectattributeaccess");
this.SetRelatedEntities<PrincipalObjectAttributeAccess>("team_principalobjectattributeaccess", null, value);
this.OnPropertyChanged("team_principalobjectattributeaccess");
}
}

/// <summary>
/// 1:N team_principalobjectattributeaccess_principalid
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_principalobjectattributeaccess_principalid")]
public System.Collections.Generic.IEnumerable<PrincipalObjectAttributeAccess> team_principalobjectattributeaccess_principalid
{
get
{
return this.GetRelatedEntities<PrincipalObjectAttributeAccess>("team_principalobjectattributeaccess_principalid", null);
}
set
{
this.OnPropertyChanging("team_principalobjectattributeaccess_principalid");
this.SetRelatedEntities<PrincipalObjectAttributeAccess>("team_principalobjectattributeaccess_principalid", null, value);
this.OnPropertyChanged("team_principalobjectattributeaccess_principalid");
}
}

/// <summary>
/// 1:N team_processsession
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_processsession")]
public System.Collections.Generic.IEnumerable<ProcessSession> team_processsession
{
get
{
return this.GetRelatedEntities<ProcessSession>("team_processsession", null);
}
set
{
this.OnPropertyChanging("team_processsession");
this.SetRelatedEntities<ProcessSession>("team_processsession", null, value);
this.OnPropertyChanged("team_processsession");
}
}

/// <summary>
/// 1:N Team_ProcessSessions
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("Team_ProcessSessions")]
public System.Collections.Generic.IEnumerable<ProcessSession> Team_ProcessSessions
{
get
{
return this.GetRelatedEntities<ProcessSession>("Team_ProcessSessions", null);
}
set
{
this.OnPropertyChanging("Team_ProcessSessions");
this.SetRelatedEntities<ProcessSession>("Team_ProcessSessions", null, value);
this.OnPropertyChanged("Team_ProcessSessions");
}
}

/// <summary>
/// 1:N team_queueitembase_workerid
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_queueitembase_workerid")]
public System.Collections.Generic.IEnumerable<QueueItem> team_queueitembase_workerid
{
get
{
return this.GetRelatedEntities<QueueItem>("team_queueitembase_workerid", null);
}
set
{
this.OnPropertyChanging("team_queueitembase_workerid");
this.SetRelatedEntities<QueueItem>("team_queueitembase_workerid", null, value);
this.OnPropertyChanged("team_queueitembase_workerid");
}
}

/// <summary>
/// 1:N team_quoteclose
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_quoteclose")]
public System.Collections.Generic.IEnumerable<QuoteClose> team_quoteclose
{
get
{
return this.GetRelatedEntities<QuoteClose>("team_quoteclose", null);
}
set
{
this.OnPropertyChanging("team_quoteclose");
this.SetRelatedEntities<QuoteClose>("team_quoteclose", null, value);
this.OnPropertyChanged("team_quoteclose");
}
}

/// <summary>
/// 1:N team_quotes
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_quotes")]
public System.Collections.Generic.IEnumerable<Quote> team_quotes
{
get
{
return this.GetRelatedEntities<Quote>("team_quotes", null);
}
set
{
this.OnPropertyChanging("team_quotes");
this.SetRelatedEntities<Quote>("team_quotes", null, value);
this.OnPropertyChanged("team_quotes");
}
}

/// <summary>
/// 1:N team_recurringappointmentmaster
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_recurringappointmentmaster")]
public System.Collections.Generic.IEnumerable<RecurringAppointmentMaster> team_recurringappointmentmaster
{
get
{
return this.GetRelatedEntities<RecurringAppointmentMaster>("team_recurringappointmentmaster", null);
}
set
{
this.OnPropertyChanging("team_recurringappointmentmaster");
this.SetRelatedEntities<RecurringAppointmentMaster>("team_recurringappointmentmaster", null, value);
this.OnPropertyChanged("team_recurringappointmentmaster");
}
}

/// <summary>
/// 1:N team_resource_groups
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_resource_groups")]
public System.Collections.Generic.IEnumerable<ResourceGroup> team_resource_groups
{
get
{
return this.GetRelatedEntities<ResourceGroup>("team_resource_groups", null);
}
set
{
this.OnPropertyChanging("team_resource_groups");
this.SetRelatedEntities<ResourceGroup>("team_resource_groups", null, value);
this.OnPropertyChanged("team_resource_groups");
}
}

/// <summary>
/// 1:N team_resource_specs
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_resource_specs")]
public System.Collections.Generic.IEnumerable<ResourceSpec> team_resource_specs
{
get
{
return this.GetRelatedEntities<ResourceSpec>("team_resource_specs", null);
}
set
{
this.OnPropertyChanging("team_resource_specs");
this.SetRelatedEntities<ResourceSpec>("team_resource_specs", null, value);
this.OnPropertyChanged("team_resource_specs");
}
}

/// <summary>
/// 1:N team_service_appointments
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_service_appointments")]
public System.Collections.Generic.IEnumerable<ServiceAppointment> team_service_appointments
{
get
{
return this.GetRelatedEntities<ServiceAppointment>("team_service_appointments", null);
}
set
{
this.OnPropertyChanging("team_service_appointments");
this.SetRelatedEntities<ServiceAppointment>("team_service_appointments", null, value);
this.OnPropertyChanged("team_service_appointments");
}
}

/// <summary>
/// 1:N team_service_contracts
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_service_contracts")]
public System.Collections.Generic.IEnumerable<Contract> team_service_contracts
{
get
{
return this.GetRelatedEntities<Contract>("team_service_contracts", null);
}
set
{
this.OnPropertyChanging("team_service_contracts");
this.SetRelatedEntities<Contract>("team_service_contracts", null, value);
this.OnPropertyChanged("team_service_contracts");
}
}

/// <summary>
/// 1:N team_sharepointdocumentlocation
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_sharepointdocumentlocation")]
public System.Collections.Generic.IEnumerable<SharePointDocumentLocation> team_sharepointdocumentlocation
{
get
{
return this.GetRelatedEntities<SharePointDocumentLocation>("team_sharepointdocumentlocation", null);
}
set
{
this.OnPropertyChanging("team_sharepointdocumentlocation");
this.SetRelatedEntities<SharePointDocumentLocation>("team_sharepointdocumentlocation", null, value);
this.OnPropertyChanged("team_sharepointdocumentlocation");
}
}

/// <summary>
/// 1:N team_sharepointsite
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_sharepointsite")]
public System.Collections.Generic.IEnumerable<SharePointSite> team_sharepointsite
{
get
{
return this.GetRelatedEntities<SharePointSite>("team_sharepointsite", null);
}
set
{
this.OnPropertyChanging("team_sharepointsite");
this.SetRelatedEntities<SharePointSite>("team_sharepointsite", null, value);
this.OnPropertyChanged("team_sharepointsite");
}
}

/// <summary>
/// 1:N team_task
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_task")]
public System.Collections.Generic.IEnumerable<Task> team_task
{
get
{
return this.GetRelatedEntities<Task>("team_task", null);
}
set
{
this.OnPropertyChanging("team_task");
this.SetRelatedEntities<Task>("team_task", null, value);
this.OnPropertyChanged("team_task");
}
}

/// <summary>
/// 1:N team_userentityinstancedata
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_userentityinstancedata")]
public System.Collections.Generic.IEnumerable<UserEntityInstanceData> team_userentityinstancedata
{
get
{
return this.GetRelatedEntities<UserEntityInstanceData>("team_userentityinstancedata", null);
}
set
{
this.OnPropertyChanging("team_userentityinstancedata");
this.SetRelatedEntities<UserEntityInstanceData>("team_userentityinstancedata", null, value);
this.OnPropertyChanged("team_userentityinstancedata");
}
}

/// <summary>
/// 1:N team_userentityuisettings
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_userentityuisettings")]
public System.Collections.Generic.IEnumerable<UserEntityUISettings> team_userentityuisettings
{
get
{
return this.GetRelatedEntities<UserEntityUISettings>("team_userentityuisettings", null);
}
set
{
this.OnPropertyChanging("team_userentityuisettings");
this.SetRelatedEntities<UserEntityUISettings>("team_userentityuisettings", null, value);
this.OnPropertyChanged("team_userentityuisettings");
}
}

/// <summary>
/// 1:N team_userform
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_userform")]
public System.Collections.Generic.IEnumerable<UserForm> team_userform
{
get
{
return this.GetRelatedEntities<UserForm>("team_userform", null);
}
set
{
this.OnPropertyChanging("team_userform");
this.SetRelatedEntities<UserForm>("team_userform", null, value);
this.OnPropertyChanged("team_userform");
}
}

/// <summary>
/// 1:N team_userquery
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_userquery")]
public System.Collections.Generic.IEnumerable<UserQuery> team_userquery
{
get
{
return this.GetRelatedEntities<UserQuery>("team_userquery", null);
}
set
{
this.OnPropertyChanging("team_userquery");
this.SetRelatedEntities<UserQuery>("team_userquery", null, value);
this.OnPropertyChanged("team_userquery");
}
}

/// <summary>
/// 1:N team_userqueryvisualizations
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_userqueryvisualizations")]
public System.Collections.Generic.IEnumerable<UserQueryVisualization> team_userqueryvisualizations
{
get
{
return this.GetRelatedEntities<UserQueryVisualization>("team_userqueryvisualizations", null);
}
set
{
this.OnPropertyChanging("team_userqueryvisualizations");
this.SetRelatedEntities<UserQueryVisualization>("team_userqueryvisualizations", null, value);
this.OnPropertyChanged("team_userqueryvisualizations");
}
}

/// <summary>
/// 1:N team_workflow
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_workflow")]
public System.Collections.Generic.IEnumerable<Workflow> team_workflow
{
get
{
return this.GetRelatedEntities<Workflow>("team_workflow", null);
}
set
{
this.OnPropertyChanging("team_workflow");
this.SetRelatedEntities<Workflow>("team_workflow", null, value);
this.OnPropertyChanged("team_workflow");
}
}

/// <summary>
/// 1:N team_workflowlog
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("team_workflowlog")]
public System.Collections.Generic.IEnumerable<WorkflowLog> team_workflowlog
{
get
{
return this.GetRelatedEntities<WorkflowLog>("team_workflowlog", null);
}
set
{
this.OnPropertyChanging("team_workflowlog");
this.SetRelatedEntities<WorkflowLog>("team_workflowlog", null, value);
this.OnPropertyChanged("team_workflowlog");
}
}

/// <summary>
/// 1:N userentityinstancedata_team
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("userentityinstancedata_team")]
public System.Collections.Generic.IEnumerable<UserEntityInstanceData> userentityinstancedata_team
{
get
{
return this.GetRelatedEntities<UserEntityInstanceData>("userentityinstancedata_team", null);
}
set
{
this.OnPropertyChanging("userentityinstancedata_team");
this.SetRelatedEntities<UserEntityInstanceData>("userentityinstancedata_team", null, value);
this.OnPropertyChanged("userentityinstancedata_team");
}
}

/// <summary>
/// N:N teammembership_association
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("teammembership_association")]
public System.Collections.Generic.IEnumerable<SystemUser> teammembership_association
{
get
{
return this.GetRelatedEntities<SystemUser>("teammembership_association", null);
}
set
{
this.OnPropertyChanging("teammembership_association");
this.SetRelatedEntities<SystemUser>("teammembership_association", null, value);
this.OnPropertyChanged("teammembership_association");
}
}

/// <summary>
/// N:N teamprofiles_association
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("teamprofiles_association")]
public System.Collections.Generic.IEnumerable<FieldSecurityProfile> teamprofiles_association
{
get
{
return this.GetRelatedEntities<FieldSecurityProfile>("teamprofiles_association", null);
}
set
{
this.OnPropertyChanging("teamprofiles_association");
this.SetRelatedEntities<FieldSecurityProfile>("teamprofiles_association", null, value);
this.OnPropertyChanged("teamprofiles_association");
}
}

/// <summary>
/// N:N teamroles_association
/// </summary>
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("teamroles_association")]
public System.Collections.Generic.IEnumerable<Role> teamroles_association
{
get
{
return this.GetRelatedEntities<Role>("teamroles_association", null);
}
set
{
this.OnPropertyChanging("teamroles_association");
this.SetRelatedEntities<Role>("teamroles_association", null, value);
this.OnPropertyChanged("teamroles_association");
}
}

/// <summary>
/// N:1 business_unit_teams
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("businessunitid")]
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("business_unit_teams")]
public BusinessUnit business_unit_teams
{
get
{
return this.GetRelatedEntity<BusinessUnit>("business_unit_teams", null);
}
set
{
this.OnPropertyChanging("business_unit_teams");
this.SetRelatedEntity<BusinessUnit>("business_unit_teams", null, value);
this.OnPropertyChanged("business_unit_teams");
}
}

/// <summary>
/// N:1 lk_team_createdonbehalfby
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("createdonbehalfby")]
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("lk_team_createdonbehalfby")]
public SystemUser lk_team_createdonbehalfby
{
get
{
return this.GetRelatedEntity<SystemUser>("lk_team_createdonbehalfby", null);
}
}

/// <summary>
/// N:1 lk_team_modifiedonbehalfby
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("modifiedonbehalfby")]
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("lk_team_modifiedonbehalfby")]
public SystemUser lk_team_modifiedonbehalfby
{
get
{
return this.GetRelatedEntity<SystemUser>("lk_team_modifiedonbehalfby", null);
}
}

/// <summary>
/// N:1 lk_teambase_administratorid
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("administratorid")]
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("lk_teambase_administratorid")]
public SystemUser lk_teambase_administratorid
{
get
{
return this.GetRelatedEntity<SystemUser>("lk_teambase_administratorid", null);
}
set
{
this.OnPropertyChanging("lk_teambase_administratorid");
this.SetRelatedEntity<SystemUser>("lk_teambase_administratorid", null, value);
this.OnPropertyChanged("lk_teambase_administratorid");
}
}

/// <summary>
/// N:1 lk_teambase_createdby
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("createdby")]
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("lk_teambase_createdby")]
public SystemUser lk_teambase_createdby
{
get
{
return this.GetRelatedEntity<SystemUser>("lk_teambase_createdby", null);
}
}

/// <summary>
/// N:1 lk_teambase_modifiedby
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("modifiedby")]
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("lk_teambase_modifiedby")]
public SystemUser lk_teambase_modifiedby
{
get
{
return this.GetRelatedEntity<SystemUser>("lk_teambase_modifiedby", null);
}
}

/// <summary>
/// N:1 organization_teams
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("organizationid")]
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("organization_teams")]
public Organization organization_teams
{
get
{
return this.GetRelatedEntity<Organization>("organization_teams", null);
}
}

/// <summary>
/// N:1 queue_team
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("queueid")]
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("queue_team")]
public Queue queue_team
{
get
{
return this.GetRelatedEntity<Queue>("queue_team", null);
}
set
{
this.OnPropertyChanging("queue_team");
this.SetRelatedEntity<Queue>("queue_team", null, value);
this.OnPropertyChanged("queue_team");
}
}

/// <summary>
/// N:1 TransactionCurrency_Team
/// </summary>
[Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute("transactioncurrencyid")]
[Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute("TransactionCurrency_Team")]
public TransactionCurrency TransactionCurrency_Team
{
get
{
return this.GetRelatedEntity<TransactionCurrency>("TransactionCurrency_Team", null);
}
set
{
this.OnPropertyChanging("TransactionCurrency_Team");
this.SetRelatedEntity<TransactionCurrency>("TransactionCurrency_Team", null, value);
this.OnPropertyChanged("TransactionCurrency_Team");
}
}
}

See Also

Concepts

Use the OrganizationServiceContext class
Use the early-bound entity classes for create, update, and delete
Use the early bound entity classes to add or update associations between related records
Mix early and late bound entities

Other Resources

Write applications and server extensions
Sample: Use the organization service context
Sample: Create, retrieve, update, and delete records (early bound)
Sample: Associate records (early bound)
Sample: Create and update records with related records (early bound)
Sample: Assign a record to a new owner
Sample: Serialize and deserialize an entity Instance
Sample: Initialize a record from an existing record
Sample: Retrieve license information

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the OrganizationServiceContext class

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the OrganizationServiceProxy class to access the Web services. Alternatively, you can use the OrganizationServiceContext generated by the code generation tool to gain access to additional functionality. The OrganizationServiceContext class lets you track changes, manage identities and relationships, and gives you access to the Microsoft Dynamics CRM LINQ provider. This class also contains a OrganizationServiceContext.SaveChanges method that you use to submit the changes to data that the context is tracking. This class is based on the same concept as the DataServiceContext class in Windows Communication Foundation (WCF) Data Services.

To generate this class, provide a value for the /serviceContextName parameter when you generate early bound types. The code generation tool uses this name as the name of the generated class. For more information about how to use the code generation tool, see Create early bound entity classes with the code generation tool (CrmSvcUtil.exe). You can use the organization service context when you develop applications, plug-ins, and workflow activities.

In This Topic

How to use the OrganizationServiceContext class

Track changes with the OrganizationServiceContext class

Track related objects with the OrganizationServiceContext class

Save changes with the OrganizationServiceContext class

Use virtual methods when the context is changed

How to use the OrganizationServiceContext class

To instantiate the context class, you must pass the class constructor an object that implements the IOrganizationService interface. One option is to pass an instance of the OrganizationServiceProxy class. For more information about the IOrganizationService interface, see Use the IOrganizationService web service to read and write data or metadata.

The following code example shows how to create a new instance of the context class. In this example, the context class was named AdventureWorksCycleServiceContext by specifying the name using the /serviceContextName parameter on the code generation tool:

C# Copy Code
//For early bound types to work correctly, they have to be enabled on the proxy.
_serviceProxy.EnableProxyTypes();
AdventureWorksCycleServiceContext context = new AdventureWorksCycleServiceContext(_serviceProxy);

After you create the organization service context object, you can begin to track create, modify, or delete entities. For example, the following code example shows how to instantiate a new contact, and then save it to a Microsoft Dynamics CRM server by using the service context object.

C# Copy Code
//  Create a new contact record;
AdventureWorksCycleServiceContext context = new AdventureWorksCycleServiceContext (_serviceProxy);
Contact contact = new Contact()
 {
   FirstName = "Pamela",
   LastName = "Brown",
   Address1_Line1 = "123 Easy St.",
   Address1_City = "Atlanta",
   Address1_StateOrProvince = "GA",
   Address1_PostalCode = "32254",
   Telephone1 = "425-555-5678"   };
context.AddObject(contact);
context.SaveChanges();

There are several points to note in the previous code example. First, after a new contact is instantiated, you pass that contact object to the OrganizationServiceContext.AddObject method so the context can begin tracking the object. The second point to note is that the new object is saved to the server by using the OrganizationServiceContext.SaveChanges method.

The organization service context must track any entity or relationship that you want to submit to Microsoft Dynamics CRM. For example, you could retrieve a record with a LINQ query and the context would track that entity or you could use the OrganizationServiceContext.Attach method to cause the context to begin tracking the entity. You can work with data in a client application and create new entities, create related entities, and modify existing entities, but you must call the SaveChanges method on tracked entities to commit changes to the Microsoft Dynamics CRM server.

Track changes with the OrganizationServiceContext class

To determine how an entity is tracked by the context, you can check the EntityState property on the entity instance. You must notify the organization service context to track an entity from Microsoft Dynamics CRM by calling various methods or by using a LINQ query. All entities returned from a .NET Language-Integrated Query (LINQ) query are tracked by the service context.

You can add objects to the service context by calling one of the following methods in OrganizationServiceContext.

Method | Use
AddObject | Adds an entity to the set of entities the organization service context is tracking. The status of the entity in the context is set to Created. If the SaveChanges method is called, this record will be created or added to the server.
Attach | Adds an entity to the set of entities the organization service context is tracking. The status of the entity in the context is set to Unchanged. If the SaveChanges method is called, this entity will not be sent to the server unless its status changes.
CreateQuery | Adds the results of a query to the set of entities the organization service context is tracking.

Track related objects with the OrganizationServiceContext class

In CRM and CRM Online, the organization service context lets you create and update relationships between entities. The navigation properties generated by the CrmSvcUtil tool and located in the early-bound classes let you access and change related entity properties and relationships. The organization service context must be tracking the related entity for the related entity to be available to be updated on the server.

Use the following methods in OrganizationServiceContext to work with related entities and to add the entity to the service context:

Method | Use
AddRelatedObject | Adds the target to the context. Calls the Attach method on the target entity and then calls the AddLink method between the source entity and the target (related) entity.
AttachLink | Adds the related entity to the context for tracking. The status of the entity in the context is set to Unchanged.
AddLink | Creates a relationship between the source and target entities. Adds the target to the context. The status of the target entity in the context is set to Created.
LoadProperty | Loads the related entity set for the specified relationship. Gives access to related entities by using the navigation property. Call the AddObject method on the related entity after you have accessed the entity by using a navigation property on the parent entity.
UpdateObject | Changes the state of the specified entity in the OrganizationServiceContext to Modified.
DeleteObject | Changes the state of the specified entity to be deleted in the OrganizationServiceContext.

Load related entities using navigation properties

Related entities for entities you have retrieved using LINQ will be null until you use LoadProperty to retrieve them. The following code sample shows how to access Task records associated with a specific Contact record.

C# Copy Code
Contact pam = context.ContactSet.Where(c => c.FirstName == "Pamela").FirstOrDefault();
if (pam != null)
{
// pam.Contact_Tasks is null until you use LoadProperty
    context.LoadProperty(pam, "Contact_Tasks");
    Task firstTask = pam.Contact_Tasks.FirstOrDefault();
}

Save changes with the OrganizationServiceContext class

The organization service context holds a graph of the entities it is tracking. The order in which the organization service context processes entity changes and submits them to the server is important. Updates to primary entity are processed, and then related entities are processed. If a value is set on the primary entity by the related entity, that value is used when updating data on the server.

If an error occurs when entity information is being saved, a new exception type that contains the SaveChangesResult is thrown by the OrganizationServiceContext.SaveChanges method, regardless of the value of the SaveChangesOptions parameter that is passed into the method.

Use virtual methods when the context is changed

Sometimes it may be necessary to take actions based on changes in the OrganizationServiceContext. To facilitate this, virtual methods are provided to allow you to intercept or be notified of an operation. To take advantage of these methods, you either have to derive from OrganizationServiceContext or change the generated organization service context.The following table lists the virtual methods.

Method | Description
OnBeginEntityTracking | Called after an entity is attached to the OrganizationServiceContext.
OnBeginLinkTracking | Called after a link is attached to the OrganizationServiceContext.
OnEndEntityTracking | Called after an entity is detached from the OrganizationServiceContext.
OnEndLinkTracking | Called after a link is detached from the OrganizationServiceContext.
OnExecuting | Called immediately before a request is submitted to the Microsoft Dynamics CRM Server.
OnExecute | Called immediately after a request is submitted to the Microsoft Dynamics CRM Server, regardless of whether an exception occurred or not.
OnSavingChanges | Called before any operations occur after a call to SaveChanges.
OnSaveChanges | Called when all of the operations for a call to SaveChanges have completed, or when there is a failure.

See Also

Concepts

Use the early bound entity classes in code
Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)
Use the early-bound entity classes for create, update, and delete

Other Resources

Sample: Complex LINQ queries
IOrganizationService
OrganizationServiceContext

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the early-bound entity classes for create, update, and delete

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the entity data model and the early-bound entity classes, created by the code generation tool (CrmSvcUtil), to work with business data. You can use these early-bound classes with or without the organization service context, but a best practice is to use the generated organization service context class. The context attempts to manage relationships efficiently, but handwritten code can typically be even more efficient.

Note
Updates to records are made in a specific order. First, primary entities are processed, and then related entities are processed. If a change is made by the primary entity for a lookup or related entity attribute, and then a related entity updates the same attribute, the related entity value is retained. In general, a lookup attribute value and its equivalent in the RelatedEntities (or navigation properties) for the same relationship should not be used at the same time.

In This Topic

Use the OrganizationServiceContext class

Create a new entity record using the early-bound entity classes and the OrganizationServiceContext class

Update an entity record using early-bound entity classes and the OrganizationServiceContext class

Delete an entity record using early-bound entity classes and the OrganizationServiceContext class

Use early-bound entity classes without a Context object

Use the OrganizationServiceContext class

The organization service context class that the code generation tool creates and that inherits from OrganizationServiceContext is used to track data changes. The context tracks objects that are instances of entity types that represent data in Microsoft Dynamics CRM. You can modify, create, and delete objects in the organization service context, and Microsoft Dynamics CRM tracks the changes that you made to these objects. When the OrganizationServiceContext.SaveChanges method is called, Microsoft Dynamics CRM generates and executes commands that perform the equivalent insert, update, or delete statements against data in Microsoft Dynamics CRM.

When working with early-bound entity classes, you use the entity name and attribute schema name to specify an entity or attribute to work with. Attribute schema names are defined in EntityMetadata.SchemaName and AttributeMetadata.SchemaName, or you can use the class and property names shown in the code-generated file.The following sample shows how to assign a value to the email attribute of a new contact instance.

C# Copy Code
Contact contact = new Contact();contact.EMailAddress1 = “sonny@contoso.com”;

For a complete code sample that shows how to use early-bound entity classes to perform basic database actions, see Sample: Create, retrieve, update, and delete records (early bound).

Create a new entity record using the early-bound entity classes and the OrganizationServiceContext class

When you want to insert data into Microsoft Dynamics CRM by using the entity data model, you must create an instance of an entity type and add the object to an organization service context. The organization service context must be tracking the object before it can save the object to Microsoft Dynamics CRM.

When creating a new entity record, you add the object to the organization service context by using the OrganizationServiceContext.AddObject method.

The following sample shows how to instantiate and save a new contact record by using the entity data model. It also demonstrates how tp access a custom attribute.

C# Copy Code
OrganizationServiceContext orgContext =new OrganizationServiceContext(_serviceProxy);
Contact contact = new Contact()
 {
   FirstName = "Charles",
   LastName = "Brown",
   Address1_Line1 = "123 Main St.",
   Address1_City = "Des Moines",
   Address1_StateOrProvince = "IA",
   Address1_PostalCode = "21254",
   new_twittername = "Chuck",
   Telephone1 = "123-234-5678"
 };
orgContext.AddObject(contact);orgContext.SaveChanges();

After you add an object to the context and before the OrganizationServiceContext.SaveChanges method is called, the context generates an ID for the new object. An exception that contains the SaveChangesResults is thrown from the SaveChanges method if any updates to the Microsoft Dynamics CRM data fail.

Update an entity record using early-bound entity classes and the OrganizationServiceContext class

Microsoft Dynamics CRM tracks changes to objects that are attached to the organization service context. To modify an existing entity record, you must first add the object to the context. To add an object to the context, you must first retrieve the entity record from Microsoft Dynamics CRM and then add the object to the context by using the OrganizationServiceContext.Attach method. Once the object is being tracked by the context, you can update the record by setting the entity’s attributes.

The following sample shows how to update an account attribute by using early bound classes.

C# Copy Code
Account.EMailAddress1 = “Contoso-WebMaster@contoso.com”;

The following sample shows how to delete an attribute value.

C# Copy Code
Account.EMailAddress1 = null;

There are two partial methods named OnPropertyChanging and OnPropertyChanged for each entity. These methods are called in the property setter. You can extend these methods by using partial classes to insert custom business logic.

Delete an entity record using early-bound entity classes and the OrganizationServiceContext class

To delete an entity record, the organization service context must be tracking the object. Once the object is on the context, you can use the OrganizationServiceContext.DeleteObject method to mark the object on the context for deletion. Note that the entity record in Microsoft Dynamics CRM is not deleted until the OrganizationServiceContext.SaveChanges method is called.

Use early-bound entity classes without a Context object

You can use the early-bound entity classes without creating an organization service context object if you do not want to create the context object. The OrganizationServiceProxy class includes a OrganizationServiceProxy. Create method that can be used to save entity record changes to Microsoft Dynamics CRM.

The following sample shows how to use an early-bound entity class without creating an organization service context object. The OrganizationServiceProxy. Create method returns the GUID id assigned to the newly created entity record.

C# Copy Code
Contact contact = new Contact()
 {
   FirstName = "Charles",
   LastName = "Brown",
   Address1_Line1 = "123 Main St.",
   Address1_City = "Des Moines",
   Address1_StateOrProvince = "IA",
   Address1_PostalCode = "21254",
   Telephone1 = "123-234-5678"
  };
 _contactId = _serviceProxy.Create(contact);

To update an entity record in Microsoft Dynamics CRM, you retrieve the data to be updated, make the necessary changes, and then use the OrganizationServiceProxy. Update method to commit those changes to Microsoft Dynamics CRM. To retrieve entity records, you use the OrganizationServiceProxy. Retrieve method for single-object retrieval or the OrganizationServiceProxy. RetrieveMultiple method for retrieving multiple objects. To delete an entity record, you use the OrganizationServiceProxy. Delete method.

See Also

Concepts

Use the early bound entity classes in code
Use the early bound entity classes to add or update associations between related records
Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)

Other Resources

Sample: Create, retrieve, update, and delete records (early bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the early bound entity classes to add or update associations between related records

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can create an association by using early binding in several ways. To create a one-to-many relationship, you can use the AddLink method in the OrganizationServiceContext class. To create a many-to-many relationship, you can use the Associate method in the IOrganizationService class to create an association. You can also create the association by updating the foreign key of the target entity to match the primary key of the new source entity.

To remove an association, you can use the DeleteLink method in the OrganizationServiceContext class or the Disassociate method. You can also set the foreign key to null.

For a complete sample showing how to add and remove associations, see Sample: Associate records (early bound).

Use the AddLink method

You can use the AddLink method to create associations. You must call the SaveChanges method before the server is updated with the new link information.

The following code example shows how to create an association between a contact and an account.

C# Copy Code
Relationship relationship = new Relationship("account_primary_contact");
context.AddLink(contact, relationship, account);
context.SaveChanges();

Use the Associate method

You use the Associate method to create both one-to-many and many-to-many associations. The following code example shows how to create a one-to-many association between an account and a contact.

C# Copy Code
Relationship relationship2 = new Relationship("account_primary_contact");
EntityReferenceCollection relatedEntities = new EntityReferenceCollection();
relatedEntities.Add(new EntityReference(Account.EntityLogicalName, firstaccount.Id));
_serviceProxy.Associate(Contact.EntityLogicalName, firstcontact.Id, relationship2, relatedEntities);

See Also

Concepts

Use the early bound entity classes in code
Mix early and late bound entities
Use the early-bound entity classes for create, update, and delete

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Mix early and late bound entities

In Microsoft Dynamics CRM, you can mix early binding and late binding methods to work with both strong types and the Entity class. This approach uses both static metadata from a code-generated file of strong types with the flexibility of the Entity class and its helper methods.

The following example shows one way to mix early and late binding methods.

C# Copy Code
// Create an organization service context object
AWCServiceContext context = new AWCServiceContext(_serviceProxy);

// Instantiate an account object using the Entity class.
Entity testaccount = new Entity("account");

// Set several attributes. For account, only the name is required.
testaccount["name"] = "Fourth Coffee";
testaccount["emailaddress1"] = "marshd@contoso.com";

// Save the entity using the organization service context object.
context.AddToAccountSet(testaccount);
context.SaveChanges();

Assign an early bound instance to a late bound instance

The following sample shows how to assign an early bound instance to a late bound instance.

Copy Code
Entity incident = ((Entity)context.InputParameters[ParameterName.Target]).ToEntity<Incident>();
Task relatedEntity = new Task() { Id = this.TaskId };

incident.RelatedEntities[new Relationship("Incident_Tasks")] =
new EntityCollection(new Entity[] { relatedEntity.ToEntity<Entity>() });

See Also

Concepts

Use the early bound entity classes in code
Use the late bound entity class in code

Other Resources

Sample: Use the organization service context

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Use the organization service context
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\BasicContextExamples.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to use the OrganizationServiceContext to perform basic operations such as create, retrieve, update and delete.

Example

C# Copy Code
using System;
using System.IO;
using System.Linq;
using System.ServiceModel;
using System.Text;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

// These namespaces are found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do use the OrganizationServiceContext to work with multiple
    /// records simultaneously.</summary>
    /// <remarks>
    /// NOTE: To execute file attachment step, you must have a text file named
    /// "sample.txt" in the folder in which this code is executed.
    ///
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class BasicContextExamples
    {
        #region Class Level Members

        private Guid _accountId;
        private Guid _contactId;
        private Guid _annotationId;
        private Guid _priceLevelId;
        private Guid _quoteId;
        private Guid _productId;
        private Guid _productPriceLevelId;
        private Guid _quoteDetailId;
        private Guid _opportunityId;
        private Guid _incidentId;
        private OrganizationServiceProxy _serviceProxy;
        private OrganizationServiceContext _orgContext;
        private IOrganizationService _service;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service and creates the
        /// OrganizationServiceContext. Then, several entity creation and relationship
        /// operations are performed.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    _service = (IOrganizationService)_serviceProxy;

                    CreateRequiredRecords();

                    // The OrganizationServiceContext is an object that wraps the service
                    // proxy and allows creating/updating multiple records simultaneously.
                    _orgContext = new OrganizationServiceContext(_service);

                    // Create a new contact called Mary Kay Andersen.
                    var contact = new Contact()
                    {
                        FirstName = "Mary Kay",
                        LastName = "Andersen",
                        Address1_Line1 = "23 Market St.",
                        Address1_City = "Sammamish",
                        Address1_StateOrProvince = "MT",
                        Address1_PostalCode = "99999",
                        Telephone1 = "12345678",
                        EMailAddress1 = "marykay@contoso.com",
                        Id = Guid.NewGuid()
                    };
                    _contactId = contact.Id;
                    _orgContext.AddObject(contact);
                    Console.Write("Instantiating contact, ");

                    // Create an account called Contoso.
                    var account = new Account()
                    {
                        Name = "Contoso",
                        Address1_City = "Redmond",
                        // set the account category to 'Preferred Customer'
                        AccountCategoryCode = new OptionSetValue(1),
                        LastUsedInCampaign = DateTime.Now,
                        MarketCap = new Money(120000),
                        DoNotEMail = true,
                        Description = "Contoso is a fictional company!",
                        Id = Guid.NewGuid(),
                    };
                    _accountId = account.Id;
                    Console.Write("instantiating account, ");

                    // Set Mary Kay Andersen as the primary contact
                    _orgContext.AddRelatedObject(
                        contact,
                        new Relationship("account_primary_contact"),
                        account);
                    SaveChangesHelper(contact, account);
                    Console.WriteLine("and creating both records in CRM.");

                    // Remove the primary contact value from Mary Kay Andersen
                    _orgContext.Attach(contact);
                    _orgContext.DeleteLink(
                        contact,
                        new Relationship("account_primary_contact"),
                        account);
                    SaveChangesHelper(contact, account);
                    Console.Write("Removing primary contact status, ");

                    // Add Mary Kay Andersen to the contact list for the account Contoso.
                    _orgContext.Attach(account);
                    _orgContext.Attach(contact);
                    _orgContext.AddLink(
                        account,
                        new Relationship("contact_customer_accounts"),
                        contact);
                    SaveChangesHelper(contact, account);
                    Console.WriteLine("and adding contact to account's contact list.");

                    // Add a note with a document attachment to the contact's record.
                    var attachment = File.OpenRead("sample.txt");
                    var data = new byte[attachment.Length];
                    attachment.Read(data, 0, (int)attachment.Length);

                    var note = new Annotation()
                    {
                        Subject = "Note subject...",
                        NoteText = "Note Details....",
                        DocumentBody = Convert.ToBase64String(data),
                        FileName = Path.GetFileName(attachment.Name),
                        MimeType = "text/plain",
                        Id = Guid.NewGuid(),
                        // Associate the note to the contact.
                        ObjectId = contact.ToEntityReference(),
                        ObjectTypeCode = Contact.EntityLogicalName
                    };
                    _annotationId = note.Id;
                    Console.Write("Instantiating a note, ");
                    _orgContext.AddObject(note);
                    _orgContext.Attach(contact);
                    // Set the contact as the Regarding attribute of the note.
                    _orgContext.AddLink(
                        contact,
                        new Relationship("Contact_Annotation"),
                        note);
                    SaveChangesHelper(note, contact);
                    Console.WriteLine("creating the note in CRM and linking to contact.");

                    // Change the owning user of the contact Mary Kay Andersen
                    // Find a user with an email address of "someone@example.com"
                    var newOwner = (from u in _orgContext.CreateQuery<SystemUser>()
                                    where u.InternalEMailAddress == "someone@example.com"
                                    select u).Single();
                    AssignRequest assignRequest = new AssignRequest()
                    {
                        Target = contact.ToEntityReference(),
                        Assignee = newOwner.ToEntityReference()
                    };
                    _orgContext.Execute(assignRequest);
                    Console.WriteLine("Changing ownership of contact record.");

                    // Create a new price list called Retail Price List.
                    var priceList = new PriceLevel()
                    {
                        Name = "Retail Price List",
                        BeginDate = DateTime.Now,
                        EndDate = DateTime.Now,
                        Description = "Contoso's primary pricelist.",
                        Id = Guid.NewGuid()
                    };
                    _priceLevelId = priceList.Id;
                    _orgContext.AddObject(priceList);
                    Console.Write("Instantiating price list ");

                    // Create a new product called Widget A.
                    var newProduct = new Product()
                    {
                        Name = "Widget A",
                        Description = "Industrial widget for hi-tech industries",
                        ProductStructure = new OptionSetValue(1), // 1 = Product
                        QuantityOnHand = 2,
                        ProductNumber = "WIDG-A",
                        Price = new Money(decimal.Parse("12.50")),
                        QuantityDecimal = 2, // Sets the Decimals Supported value
                        Id = Guid.NewGuid(),
                        DefaultUoMScheduleId = new EntityReference(
                                UoMSchedule.EntityLogicalName,
                                _orgContext.CreateQuery<UoMSchedule>().First().Id),
                        DefaultUoMId = new EntityReference(
                                UoM.EntityLogicalName,
                                _orgContext.CreateQuery<UoM>().First().Id)
                    };
                    _productId = newProduct.Id;
                    _orgContext.AddObject(newProduct);
                    Console.WriteLine("and product.");
                    SaveChangesHelper(priceList, newProduct);

                    // Add Widget A to the Retail Price List.
                    var priceLevelProduct = new ProductPriceLevel()
                    {
                        ProductId = newProduct.ToEntityReference(),
                        UoMId = newProduct.DefaultUoMId,
                        Amount = new Money(decimal.Parse("12.50")),
                        PriceLevelId = priceList.ToEntityReference(),
                        Id = Guid.NewGuid()
                    };
                    _productPriceLevelId = priceLevelProduct.Id;
                    _orgContext.AddObject(priceLevelProduct);
                    Console.Write("Associating product to price list, ");

                    // Publish the product
                    SetStateRequest publishRequest = new SetStateRequest
                    {
                        EntityMoniker = newProduct.ToEntityReference(),
                        State = new OptionSetValue((int)ProductState.Active),
                        Status = new OptionSetValue(1)
                    };
                    _serviceProxy.Execute(publishRequest);
                    Console.WriteLine("and publishing the product.");

                    // Create a new quote for Contoso.
                    var newQuote = new Quote()
                    {
                        Name = "Quotation for Contoso",
                        // Sets the pricelist to the one we've just created
                        PriceLevelId = priceList.ToEntityReference(),
                        Id = Guid.NewGuid(),
                        CustomerId = account.ToEntityReference()
                    };
                    _quoteId = newQuote.Id;
                    _orgContext.AddObject(newQuote);
                    _orgContext.Attach(account);
                    _orgContext.AddLink(
                        newQuote,
                        new Relationship("quote_customer_accounts"),
                        account);
                    Console.Write("Instantiating a quote, ");

                    // Add a quote product to this quote.
                    var quoteProduct = new QuoteDetail()
                    {
                        ProductId = newProduct.ToEntityReference(),
                        Quantity = 1,
                        QuoteId = newQuote.ToEntityReference(),
                        UoMId = newProduct.DefaultUoMId,
                        Id = Guid.NewGuid()
                    };
                    _quoteDetailId = quoteProduct.Id;
                    _orgContext.AddObject(quoteProduct);
                    Console.WriteLine("and adding product to quote.");

                    // Create a sales opportunity with Contoso.
                    var oppty = new Opportunity()
                    {
                        Name = "Interested in Widget A",
                        EstimatedCloseDate = DateTime.Now.AddDays(30.0),
                        EstimatedValue = new Money(decimal.Parse("300000.00")),
                        CloseProbability = 25, // 25% probability of closing this deal
                        IsRevenueSystemCalculated = false, // user-calculated revenue
                        OpportunityRatingCode = new OptionSetValue(2), // warm
                        CustomerId = account.ToEntityReference(),
                        Id = Guid.NewGuid()
                    };
                    _opportunityId = oppty.Id;
                    _orgContext.AddObject(oppty);
                    Console.Write("Instantiating opportunity, ");
                    //_orgContext.AddLink(
                    //    oppty,
                    //    new Relationship("opportunity_customer_accounts"),
                    //    account);
                    SaveChangesHelper(priceList, newQuote, newProduct, priceLevelProduct,
                        quoteProduct, oppty, account);
                    Console.WriteLine("and creating all records in CRM.");

                    // Associate quote to contact, which adds the Contact record in the
                    // "Other Contacts" section of a Quote record.
                    _orgContext.Attach(contact);
                    _orgContext.Attach(newQuote);
                    _orgContext.AddLink(
                        contact,
                        new Relationship("contactquotes_association"),
                        newQuote);
                    SaveChangesHelper(contact, newQuote);
                    Console.WriteLine("Associating contact and quote.");

                    // Create a case for Mary Kay Andersen.
                    var serviceRequest = new Incident()
                    {
                        Title = "Problem with Widget B",
                        PriorityCode = new OptionSetValue(1), // 1 = High
                        CaseOriginCode = new OptionSetValue(1), // 1 = Phone
                        CaseTypeCode = new OptionSetValue(2), // 2 = Problem
                        SubjectId =
                            new EntityReference(
                                Subject.EntityLogicalName,
                                _orgContext.CreateQuery<Subject>()
                                    .First().Id),  // use the default subject
                        Description = "Customer can't switch the product on.",
                        FollowupBy = DateTime.Now.AddHours(3.0), // follow-up in 3 hours
                        CustomerId = contact.ToEntityReference(),
                        Id = Guid.NewGuid()
                    };
                    _incidentId = serviceRequest.Id;
                    _orgContext.AddObject(serviceRequest);
                    _orgContext.Attach(contact);
                    _orgContext.AddLink(
                        serviceRequest,
                        new Relationship("incident_customer_contacts"),
                        contact);
                    SaveChangesHelper(serviceRequest, contact);
                    Console.WriteLine("Creating service case for contact.");

                    // Deactivate the Mary Kay Andersen contact record.
                    SetStateRequest setInactiveRequest = new SetStateRequest
                    {
                        EntityMoniker = contact.ToEntityReference(),
                        State = new OptionSetValue((int)ContactState.Inactive),
                        Status = new OptionSetValue(2)
                    };
                    _orgContext.Execute(setInactiveRequest);
                    Console.WriteLine("Deactivating the contact record.");

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        private void SaveChangesHelper(params Entity[] entities)
        {
            SaveChangesResultCollection results = _orgContext.SaveChanges();
            if (results.HasError)
            {
                DeleteRequiredRecords(false);
                StringBuilder sb = new StringBuilder();
                foreach (var result in results)
                {
                    if (result.Error != null)
                    {
                        sb.AppendFormat("Error: {0}\n", result.Error.Message);
                    }
                }
                throw new InvalidOperationException("Failure occurred while " +
                    "calling OrganizationServiceContext.SaveChanges()\n" +
                    sb.ToString());
            }
            else
            {
                foreach (Entity e in entities)
                {
                    e.EntityState = null;
                }
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a second user that we will reference in our sample code.
            Guid userId = SystemUserProvider.RetrieveSalesManager(_serviceProxy);

            // Modify email address of user for sample.
            SystemUser systemUser = new SystemUser
            {
                Id = userId,
                InternalEMailAddress = "someone@example.com"
            };

            _service.Update(systemUser);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            // The system user named "Kevin Cook" that was created by this sample will
            // continue to exist on your system because system users cannot be deleted
            // in Microsoft Dynamics CRM.  They can only be enabled or disabled.

            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _service.Delete(Incident.EntityLogicalName, _incidentId);
                _service.Delete(Opportunity.EntityLogicalName, _opportunityId);
                _service.Delete(QuoteDetail.EntityLogicalName, _quoteDetailId);
                _service.Delete(ProductPriceLevel.EntityLogicalName, _productPriceLevelId);
                _service.Delete(Product.EntityLogicalName, _productId);
                _service.Delete(Quote.EntityLogicalName, _quoteId);
                _service.Delete(PriceLevel.EntityLogicalName, _priceLevelId);
                _service.Delete(Annotation.EntityLogicalName, _annotationId);
                _service.Delete(Contact.EntityLogicalName, _contactId);
                _service.Delete(Account.EntityLogicalName, _accountId);
                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                BasicContextExamples app = new BasicContextExamples();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Reference

AddObject
AddRelatedObject
DeleteLink

Concepts

Use the early bound entity classes in code

Other Resources

Sample: Create, retrieve, update, and delete records (early bound)
OrganizationServiceContext

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete records (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\CRUDOperations.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create, retrieve, update, and delete operations on an account using the early bound class. This sample uses the following common methods:

  • IOrganizationService.Create
  • IOrganizationService.Retrieve
  • IOrganizationService.Update
  • IOrganizationService.Delete

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do basic entity operations like create, retrieve,
    /// update, and delete.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class CRUDOperations
    {
        #region Class Level Members

        private Guid _accountId;
        private Guid _parentAccountId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// basic create, retrieve, update, and delete entity operations are performed.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Instantiate an account object.
                    // See the Entity Metadata topic in the SDK documentation to determine
                    // which attributes must be set for each entity.
                    Account account = new Account { Name = "Fourth Coffee" };

                    // Create an account record named Fourth Coffee.
                    _accountId = _serviceProxy.Create(account);
                    Console.Write("{0} {1} created, ", account.LogicalName, account.Name);

                    // Retrieve the account containing several of its attributes.
                    ColumnSet cols = new ColumnSet(
                        new String[] { "name", "address1_postalcode", "lastusedincampaign", "versionnumber" });

                    Account retrievedAccount = (Account)_serviceProxy.Retrieve("account", _accountId, cols);
                    Console.Write("retrieved ");

                    // Retrieve version number of the account. Shows BigInt attribute usage.
                    long? versionNumber = retrievedAccount.VersionNumber;

                    if (versionNumber != null)
                        Console.WriteLine("version # {0}, ", versionNumber);

                    // Update the postal code attribute.
                    retrievedAccount.Address1_PostalCode = "98052";

                    // The address 2 postal code was set accidentally, so set it to null.
                    retrievedAccount.Address2_PostalCode = null;

                    // Shows usage of option set (picklist) enumerations defined in OptionSets.cs.
                    retrievedAccount.Address1_AddressTypeCode = new OptionSetValue((int)AccountAddress1_AddressTypeCode.Primary);
                    retrievedAccount.Address1_ShippingMethodCode = new OptionSetValue((int)AccountAddress1_ShippingMethodCode.DHL);
                    retrievedAccount.IndustryCode = new OptionSetValue((int)AccountIndustryCode.AgricultureandNonpetrolNaturalResourceExtraction);

                    // Shows use of a Money value.
                    retrievedAccount.Revenue = new Money(5000000);

                    // Shows use of a Boolean value.
                    retrievedAccount.CreditOnHold = false;

                    // Shows use of EntityReference.
                    retrievedAccount.ParentAccountId = new EntityReference(Account.EntityLogicalName, _parentAccountId);

                    // Shows use of Memo attribute.
                    retrievedAccount.Description = "Account for Fourth Coffee.";

                    // Update the account record.
                    _serviceProxy.Update(retrievedAccount);
                    Console.WriteLine("and updated.");

                    _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
                    _serviceProxy.Delete(Account.EntityLogicalName, _parentAccountId);
                    Console.WriteLine("Entity records have been deleted.");
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // For this sample, all required entities are created in the Run() method.
            Account account = new Account { Name = "Sample Parent Account" };
            _parentAccountId = _serviceProxy.Create(account);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
                _serviceProxy.Delete(Account.EntityLogicalName, _parentAccountId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CRUDOperations app = new CRUDOperations();
                app.Run( config, true );
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Use the early bound entity classes in code

Other Resources

Sample: Associate records (early bound)
Sample: Create, retrieve, update, and delete (late bound)
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Associate records (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\AssociateDisassociate.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Full Sample – C#

Demonstrates

This sample shows how to associate a contact with three account records using the IOrganizationService.Associate method. It also shows how to use the IOrganizationService.Disassociate method.

Example

C# Copy Code
// Associate the accounts to the contact record.

// Create a collection of the entities that will be
// associated to the contact.
EntityReferenceCollection relatedEntities = new EntityReferenceCollection();
relatedEntities.Add(new EntityReference(Account.EntityLogicalName, _account1Id));
relatedEntities.Add(new EntityReference(Account.EntityLogicalName, _account2Id));
relatedEntities.Add(new EntityReference(Account.EntityLogicalName, _account3Id));

// Create an object that defines the relationship between the contact and account.
Relationship relationship = new Relationship("account_primary_contact");

//Associate the contact with the 3 accounts.
_service.Associate(Contact.EntityLogicalName, _contactId, relationship,
    relatedEntities);

Console.WriteLine("The entities have been associated.");

//Disassociate the records.
_service.Disassociate(Contact.EntityLogicalName, _contactId, relationship,
    relatedEntities);

Full Sample – C#

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to assign a queue to a team.
    /// If you want to run this sample repeatedly, you have the option to
    /// delete all the records created at the end of execution.
    /// </summary>
    public class AssociateDisassociate
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        // Define the IDs needed for this sample.
        public Guid _contactId;
        public Guid _account1Id;
        public Guid _account2Id;
        public Guid _account3Id;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create a team, a queue and a role.
        /// Add read queue privileges to the role.
        /// Assign the role to the team so that they can read the queue.
        /// Assign the queue to the team.
        /// Optionally delete any entity records that were created for this sample.
        // </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    _service = (IOrganizationService)_serviceProxy;

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Associate the accounts to the contact record.

                    // Create a collection of the entities that will be
                    // associated to the contact.
                    EntityReferenceCollection relatedEntities = new EntityReferenceCollection();
                    relatedEntities.Add(new EntityReference(Account.EntityLogicalName, _account1Id));
                    relatedEntities.Add(new EntityReference(Account.EntityLogicalName, _account2Id));
                    relatedEntities.Add(new EntityReference(Account.EntityLogicalName, _account3Id));

                    // Create an object that defines the relationship between the contact and account.
                    Relationship relationship = new Relationship("account_primary_contact");

                    //Associate the contact with the 3 accounts.
                    _service.Associate(Contact.EntityLogicalName, _contactId, relationship,
                        relatedEntities);

                    Console.WriteLine("The entities have been associated.");

                    //Disassociate the records.
                    _service.Disassociate(Contact.EntityLogicalName, _contactId, relationship,
                        relatedEntities);

                    Console.WriteLine("The entities have been disassociated.");

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a team, a queue and a role.
        /// Add read queue privileges to the role.
        /// Assign the role to the team so that they can read the queue.
        /// Assign the queue to the team.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Instantiate a contact entity record and set its property values.
            // See the Entity Metadata topic in the SDK documentatio to determine
            // which attributes must be set for each entity.
            Contact setupContact = new Contact
            {
                 FirstName = "John",
                 LastName = "Doe"
            };
            _contactId = _service.Create(setupContact);
            Console.WriteLine("Created {0} {1}", setupContact.FirstName,
                setupContact.LastName);

            // Instantiate an account entity record and set its property values.
            Account setupAccount1 = new Account
            {
                Name = "Example Account 1"
            };
            _account1Id = _service.Create(setupAccount1);
            Console.WriteLine("Created {0}", setupAccount1.Name);

            Account setupAccount2 = new Account
            {
                Name = "Example Account 2"
            };
            _account2Id = _service.Create(setupAccount2);
            Console.WriteLine("Created {0}", setupAccount2.Name);

            Account setupAccount3 = new Account
            {
                Name = "Example Account 3"
            };
            _account3Id = _service.Create(setupAccount3);
            Console.WriteLine("Created {0}", setupAccount3.Name);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _service.Delete("account", _account1Id);
                _service.Delete("account", _account2Id);
                _service.Delete("account", _account3Id);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                AssociateDisassociate app = new AssociateDisassociate();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Reference

Associate

Concepts

Use the early bound entity classes in code

Other Resources

Sample: Create and update records with related records (early bound)
IOrganizationService
AssociateRequest
DisassociateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create and update records with related records (early bound)
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\CompoundCreateUpdate.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create and update a record and related records in one call by using the IOrganizationService.Create and IOrganizationService. Update methods.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{

    /// <summary>
    /// Shows how to create and use compound Create and Update statements.
    /// If you want to run this sample repeatedly, you have the option to
    /// delete all the records created at the end of execution.
    /// </summary>
    public class CompoundCreateUpdate
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        // Define the IDs needed for this sample.
        public Guid _accountId;
        public Guid[] _letterIds;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Creates an account and some associated letters with a nested operation.
        /// Updates those records with a nested operation.
        // </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    _service = (IOrganizationService)_serviceProxy;

                    //Define the account for which we will add letters
                    Account accountToCreate = new Account
                    {
                        Name = "Example Account"
                    };

                    //Define the IDs of the related letters we will create
                    _letterIds = new[] { Guid.NewGuid(), Guid.NewGuid(), Guid.NewGuid() };

                    //This acts as a container for each letter we create. Note that we haven't
                    //define the relationship between the letter and account yet.
                    EntityCollection relatedLettersToCreate = new EntityCollection
                    {
                        EntityName = Letter.EntityLogicalName,
                        Entities =
                        {
                            new Letter{Subject = "Letter 1", ActivityId = _letterIds[0]},
                            new Letter{Subject = "Letter 2", ActivityId = _letterIds[1]},
                            new Letter{Subject = "Letter 3", ActivityId = _letterIds[2]}
                        }
                    };

                    //Creates the reference between which relationship between Letter and
                    //Account we would like to use.
                    Relationship letterRelationship = new Relationship("Account_Letters");

                    //Adds the letters to the account under the specified relationship
                    accountToCreate.RelatedEntities.Add(letterRelationship, relatedLettersToCreate);

                    //Passes the Account (which contains the letters)
                    _accountId = _service.Create(accountToCreate);

                    Console.WriteLine("An account and {0} letters were created.", _letterIds.Length);

                    //Now we run through many of the same steps as the above "Create" example
                    Account accountToUpdate = new Account
                    {
                        Name = "Example Account - Updated",
                        AccountId = _accountId
                    };

                    EntityCollection relatedLettersToUpdate = new EntityCollection
                    {
                        EntityName = Letter.EntityLogicalName,
                        Entities =
                        {
                            new Letter{Subject = "Letter 1 - Updated", ActivityId = _letterIds[0]},
                            new Letter{Subject = "Letter 2 - Updated", ActivityId = _letterIds[1]},
                            new Letter{Subject = "Letter 3 - Updated", ActivityId = _letterIds[2]}
                        }
                    };

                    accountToUpdate.RelatedEntities.Add(letterRelationship, relatedLettersToUpdate);

                    //This will update the account as well as all of the related letters
                    _service.Update(accountToUpdate);
                    Console.WriteLine("An account and {0} letters were updated.", _letterIds.Length);

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                foreach (Guid letterId in _letterIds)
                {
                    _service.Delete(Letter.EntityLogicalName, letterId);
                }
                _service.Delete(Account.EntityLogicalName, _accountId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CompoundCreateUpdate app = new CompoundCreateUpdate();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Use the early bound entity classes in code

Other Resources

Sample: Assign a record to a new owner
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Assign a record to a new owner
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\Assign.cs

Requirements

This sample code requires that you have administrator rights to create a new user. For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Example

This sample shows how to assign an account to another user by using the AssignRequest message.

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This Sample shows how to assign an account to another user.
    /// </summary>
    /// <remarks>
    /// Note: This sample expects another user to be present in
    /// the current business unit other than the current credentials.
    /// </remarks>

    public class Assign
    {
        #region Class Level Members

        // Define the IDs needed for this sample.
        private Guid _accountId;
        private Guid _myUserId;
        private Guid _otherUserId;

        // Declare the service proxy referring the CRUD
        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Retrieves new owner's details and creates an account record.
        /// Assign the account to new owner.
        /// Optionally delete any entity records that were created for this sample.
        // </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    _service = (IOrganizationService)_serviceProxy;

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Create the Request Object and Set the Request Object's Properties
                    AssignRequest assign = new AssignRequest
                        {
                            Assignee = new EntityReference(SystemUser.EntityLogicalName,
                                _otherUserId),
                            Target = new EntityReference(Account.EntityLogicalName,
                                _accountId)
                        };

                    // Execute the Request
                    _service.Execute(assign);

                    Console.WriteLine("The account is owned by new owner.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Retrieves the user details.
        /// Create an account record.
        /// </summary>
        public void CreateRequiredRecords()
        {
            WhoAmIRequest userRequest = new WhoAmIRequest();
            WhoAmIResponse user = (WhoAmIResponse)_service.Execute(userRequest);

            // Current user.
            _myUserId = user.UserId;

            // Query to retrieve other users.
            QueryExpression querySystemUser = new QueryExpression
            {
                EntityName = SystemUser.EntityLogicalName,
                ColumnSet = new ColumnSet(new String[] { "systemuserid", "fullname" }),
                Criteria = new FilterExpression()
            };

            querySystemUser.Criteria.AddCondition("businessunitid",
                ConditionOperator.Equal, user.BusinessUnitId);
            querySystemUser.Criteria.AddCondition("systemuserid",
                ConditionOperator.NotEqual, _myUserId);
            // Excluding SYSTEM user.
            querySystemUser.Criteria.AddCondition("lastname",
                ConditionOperator.NotEqual, "SYSTEM");
            // Excluding INTEGRATION user.
            querySystemUser.Criteria.AddCondition("lastname",
                ConditionOperator.NotEqual, "INTEGRATION");

            DataCollection<Entity> otherUsers = _service.RetrieveMultiple(
                querySystemUser).Entities;

            int count = _service.RetrieveMultiple(querySystemUser).Entities.Count;
            if ( count > 0)
            {
                _otherUserId = (Guid)otherUsers[count-1].Attributes["systemuserid"];

                Console.WriteLine("Retrieved new owner {0} for assignment.",
                    otherUsers[count - 1].Attributes["fullname"]);
            }
            else
            {
                throw new FaultException(
                    "No other user found in the current business unit for assignment.");
            }

            // Create an Account record
            Account newAccount = new Account
            {
                Name = "Example Account"
            };

            _accountId = _service.Create(newAccount);
            Console.WriteLine("Created {0}", newAccount.Name);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _service.Delete(Account.EntityLogicalName, _accountId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                Assign app = new Assign();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Reference

Assign
Entity Ownership

Concepts

Use the early bound entity classes in code

Other Resources

Sample: Serialize and deserialize an entity Instance
Helper code: ServerConnection class
AssignRequest
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Serialize and deserialize an entity Instance
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\BusinessDataModel\BusinessManagement\SerializeAndDeserialize.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to serialize early-bound and late-bound entity instances into an XML format, and how to de-serialize from an XML format to an early-bound entity instance.

Example

C# Copy Code
using System;
using System.IO;
using System.Runtime.Serialization;
using System.ServiceModel;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to serialize both early-bound and late-bound entity instances (records).  In
    /// addition, it shows how to de-serialize from XML to an early-bound entity instance.
    /// </summary>
    public class SerializeAndDeserialize
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;
        private Guid _contactId;

        #endregion Class Level Members

        #region How To Sample Code

        /// <summary>
        /// Run this sample, which shows both how to serialize late-bound and
        /// early-bound entity instances to XML and how to de-serialize them back from
        /// XML into entity instances.
        /// </summary>
        /// <param name="serverConfig"> Contains server connection information.</param>
        /// <param name="promptToDelete"> When True, the user will be prompted to delete all
        /// created entities.
        public void Run(ServerConnection.Configuration serverConfig, bool promptToDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();

                CreateRequiredRecords();

                #region Retrieve the contact from Microsoft CRM

                // Create the column set object that indicates the fields to be retrieved.
                var columns = new ColumnSet(
                    "contactid",
                    "firstname",
                    "lastname",
                    "jobtitle");

                // Retrieve the contact from Microsoft CRM using the ID of the record that was just created.
                // The EntityLogicalName indicates the EntityType of the object being retrieved.
                var contact = (Contact)_serviceProxy.Retrieve(
                    Contact.EntityLogicalName, _contactId, columns);

                Console.WriteLine("The contact for the sample has been retrieved.");

                #endregion

                #region Serialize the contact into XML and save it

                // Serialize the contact into XML and write it to the hard drive.
                var earlyBoundSerializer = new DataContractSerializer(typeof(Contact));

                // Create a unique file name for the XML.
                String earlyboundFile = "Contact_early_" + contact.ContactId.Value.ToString("B") + ".xml";

                // Write the serialized object to a file.  The using statement will
                // ensure that the FileStream is disposed of correctly.  The FileMode
                // will ensure that the file is overwritten if it already exists.
                using (var file = new FileStream(earlyboundFile, FileMode.Create))
                {
                    // Write the XML to disk.
                    earlyBoundSerializer.WriteObject(file, contact);
                }

                Console.WriteLine(
                    "The early-bound contact instance has been serialized to a file, {0}.",
                    earlyboundFile);

                // Convert the contact to a late-bound entity instance and serialize it to disk.
                var lateboundContact = contact.ToEntity<Entity>();
                String lateboundFile = "Contact_late_" + lateboundContact.Id.ToString("B") + ".xml";

                var lateBoundSerializer = new DataContractSerializer(typeof(Entity));
                // Write the serialized object to a file.
                using (var file = new FileStream(lateboundFile, FileMode.Create))
                {
                    lateBoundSerializer.WriteObject(file, lateboundContact);
                }

                Console.WriteLine(
                    "The late-bound contact instance has been serialized to a file, {0}.",
                    lateboundFile);

                #endregion

                #region De-serialize the Microsoft CRM contact from XML

                Contact deserializedContact = null;
                using (var file = new FileStream(earlyboundFile, FileMode.Open))
                {
                    deserializedContact = (Contact)earlyBoundSerializer.ReadObject(file);
                    Console.WriteLine("The contact has been de-serialized: {0} {1}",
                        deserializedContact.FirstName, deserializedContact.LastName);
                }

                #endregion

                #region Update contact in Microsoft CRM

                // Update the contact in Microsoft CRM to prove that the de-serialization worked.
                deserializedContact.JobTitle = "Plumber";
                _serviceProxy.Update(deserializedContact);

                Console.WriteLine("The contact was updated in Microsoft CRM.");

                #endregion

                DeleteRequiredRecords(promptToDelete);
            }
        }

        /// <summary>
        /// Creates a contact which is required for running this sample.
        /// </summary>
        private void CreateRequiredRecords()
        {
            // Create a contact entity record that will be serialized into XML.
            var contactCreate = new Contact();
            contactCreate.FirstName = "Thomas";
            contactCreate.LastName = "Andersen";

            // Create the entity in Microsoft CRM and get its ID.
            _contactId = _serviceProxy.Create(contactCreate);

            Console.WriteLine("The contact for the sample has been created.");
        }

        /// <summary>
        /// Deletes the contact record that was used in the sample if the user responds in the
        /// affirmative.
        /// </summary>
        /// <param name="promptToDelete">whether or not to delete the contact</param>
        private void DeleteRequiredRecords(bool promptToDelete)
        {
            var toBeDeleted = true;
            if (promptToDelete)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(Contact.EntityLogicalName, _contactId);
                Console.WriteLine("The contact has been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new SerializeAndDeserialize();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        #endregion Main method
    }
}

See Also

Concepts

Use the early bound entity classes in code
Mix early and late bound entities

Other Resources

Sample: Initialize a record from an existing record
DataContractSerializer Class

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Initialize a record from an existing record
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\InitializeFrom.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

  • Full Sample – C#

Demonstrates

This sample shows how to use the IOrganizationService.InitializeFromRequest message to create new records from an existing record.

Example

C# Copy Code

#region Initialize Account from Account
Console.WriteLine();
Console.WriteLine("  Initializing new Account from the initial Account");

// Create the request object
InitializeFromRequest initialize = new InitializeFromRequest();

// Set the properties of the request object
initialize.TargetEntityName = Account.EntityLogicalName.ToString();

// Create the EntityMoniker
initialize.EntityMoniker = _initialAccount.ToEntityReference();

// Execute the request
InitializeFromResponse initialized =
    (InitializeFromResponse)_serviceProxy.Execute(initialize);

if (initialized.Entity != null)
    Console.WriteLine("  New Account initialized successfully");

Console.WriteLine();
#endregion

#region Initialize Opportunity from Lead
Console.WriteLine("  Initializing an Opportunity from the initial Lead");

// Create the request object
initialize.TargetEntityName = Opportunity.EntityLogicalName.ToString();

// Create the EntityMoniker
initialize.EntityMoniker = _initialLead.ToEntityReference();

// Execute the request
initialized =
    (InitializeFromResponse)_serviceProxy.Execute(initialize);

if (initialized.Entity != null &&
    initialized.Entity.LogicalName == Opportunity.EntityLogicalName)
{
    var opportunity = (Opportunity)initialized.Entity;
    Console.WriteLine("  New Opportunity initialized successfully (Name={0})",
        opportunity.Name);
}
#endregion

Full Sample – C#

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to use the InitializeFrom message to create new records
    /// from existing records
    /// </summary>
    /// <param name="serverConfig">Contains server connection information.</param>
    /// <param name="promptforDelete">When True, the user will be prompted to delete all
    /// created entities.</param>
    public class InitializeFrom
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;

        private Account _initialAccount;
        private Lead _initialLead;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first creates an account and a lead, then initializes a new
        /// account from the already existing account and a new opportunity from the
        /// already existing lead.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly
                // disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Initialize Account from Account
                    Console.WriteLine();
                    Console.WriteLine("  Initializing new Account from the initial Account");

                    // Create the request object
                    InitializeFromRequest initialize = new InitializeFromRequest();

                    // Set the properties of the request object
                    initialize.TargetEntityName = Account.EntityLogicalName.ToString();

                    // Create the EntityMoniker
                    initialize.EntityMoniker = _initialAccount.ToEntityReference();

                    // Execute the request
                    InitializeFromResponse initialized =
                        (InitializeFromResponse)_serviceProxy.Execute(initialize);

                    if (initialized.Entity != null)
                        Console.WriteLine("  New Account initialized successfully");

                    Console.WriteLine();
                    #endregion

                    #region Initialize Opportunity from Lead
                    Console.WriteLine("  Initializing an Opportunity from the initial Lead");

                    // Create the request object
                    initialize.TargetEntityName = Opportunity.EntityLogicalName.ToString();

                    // Create the EntityMoniker
                    initialize.EntityMoniker = _initialLead.ToEntityReference();

                    // Execute the request
                    initialized =
                        (InitializeFromResponse)_serviceProxy.Execute(initialize);

                    if (initialized.Entity != null &&
                        initialized.Entity.LogicalName == Opportunity.EntityLogicalName)
                    {
                        var opportunity = (Opportunity)initialized.Entity;
                        Console.WriteLine("  New Opportunity initialized successfully (Name={0})",
                            opportunity.Name);
                    }
                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #region Public methods

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            _initialAccount = new Account()
            {
                Name = "Contoso, Ltd"
            };
            _initialAccount.Id = _serviceProxy.Create(_initialAccount);
            Console.WriteLine("  Created initial Account (Name={0})",
                _initialAccount.Name);

            _initialLead = new Lead()
            {
                Subject = "A Sample Lead",
                LastName = "Wilcox",
                FirstName = "Colin",
            };
            _initialLead.Id = _serviceProxy.Create(_initialLead);
            Console.WriteLine("  Created initial Lead (Subject={0}, Name={1} {2})",
                _initialLead.Subject,
                _initialLead.FirstName,
                _initialLead.LastName);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(Account.EntityLogicalName, _initialAccount.Id);
                _serviceProxy.Delete(Lead.EntityLogicalName, _initialLead.Id);
                Console.WriteLine("Entity records have been deleted.");
            }
        }
        #endregion Public Methods

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                InitializeFrom app = new InitializeFrom();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        #endregion Main method
    }
}

See Also

Reference

Associate

Concepts

Use the early bound entity classes in code

Other Resources

Sample: Retrieve license information
IOrganizationService
InitializeFromRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve license information
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\EarlyBound\License.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Full Sample – C#

Demonstrates

This sample shows how to use the IDeploymentService.RetrieveDeploymentLicenseTypeRequest message and the IOrganizationService.RetrieveLicenseInfoRequest message to retrieve information about licenses.

Example

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    #region RetrieveDeploymentLicenseTypeRequest

    // Create the request
    var deploymentTypeRequest = new RetrieveDeploymentLicenseTypeRequest();

    // Execute the request
    Console.WriteLine("  Fetching the license type for this deployment");
    var deploymentTypeResponse =
        (RetrieveDeploymentLicenseTypeResponse)_serviceProxy.Execute(deploymentTypeRequest);

    // Validate results
    if (String.IsNullOrEmpty(deploymentTypeResponse.licenseType))
        throw new Exception("The request did not return any results");

    string licenseId =
        new Guid(deploymentTypeResponse.licenseType).ToString().ToUpper();
    switch (licenseId)
    {
        case "9436EA66-8262-4168-9B6C-21DF47D1D121":
            Console.WriteLine("  License type: SmallBusiness");
            break;
        case "5BEEA2E8-8F82-40E8-AE0F-6D8C135E1397":
            Console.WriteLine("  License type: Professional");
            break;
        case "CB96BDD5-5F74-4EA5-8323-9D7E20079002":
            Console.WriteLine("  License type: Enterprise");
            break;
        case "66AE2919-DD58-40CA-A980-AEF7330B2745":
            Console.WriteLine("  License type: Live");
            break;
        case "722E9E15-62DC-48A7-95CF-93131BE27273":
            Console.WriteLine("  License type: SPLA (Service Provider)");
            break;
        default:
            Console.WriteLine("  Unknown license type with id {0}", licenseId);
            break;
    }

    #endregion

    #region RetrieveLicenseInfoRequest

    // create the request
    var licenseInfoRequest = new RetrieveLicenseInfoRequest();

    // execute the request
    Console.WriteLine("  Fetching license info");
    var licenseInfoResponse =
        (RetrieveLicenseInfoResponse)_serviceProxy.Execute(licenseInfoRequest);

    // output the results
    Console.WriteLine("  Number of licenses available: {0}",
        licenseInfoResponse.AvailableCount);
    Console.WriteLine("  Number of licenses used: {0}",
        licenseInfoResponse.GrantedLicenseCount);

    #endregion
}

Full Sample – C#

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to issue the RetrieveDeploymentLicenseTypeRequest and
    /// RetrieveLicenseInfoRequest.
    /// </summary>
    /// <param name="serverConfig">Contains server connection information.</param>
    /// <param name="promptforDelete">When True, the user will be prompted to delete all
    /// created entities.</param>
    public class License
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first executes a RetrieveDeploymentLicenseTypeRequest and
        /// displays the type of license for this deployment to the console, then
        /// executes a RetrieveLicenseInfoRequest and displays the number of used
        /// and available Read-Write licenses there are.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    #region RetrieveDeploymentLicenseTypeRequest

                    // Create the request
                    var deploymentTypeRequest = new RetrieveDeploymentLicenseTypeRequest();

                    // Execute the request
                    Console.WriteLine("  Fetching the license type for this deployment");
                    var deploymentTypeResponse =
                        (RetrieveDeploymentLicenseTypeResponse)_serviceProxy.Execute(deploymentTypeRequest);

                    // Validate results
                    if (String.IsNullOrEmpty(deploymentTypeResponse.licenseType))
                        throw new Exception("The request did not return any results");

                    string licenseId =
                        new Guid(deploymentTypeResponse.licenseType).ToString().ToUpper();
                    switch (licenseId)
                    {
                        case "9436EA66-8262-4168-9B6C-21DF47D1D121":
                            Console.WriteLine("  License type: SmallBusiness");
                            break;
                        case "5BEEA2E8-8F82-40E8-AE0F-6D8C135E1397":
                            Console.WriteLine("  License type: Professional");
                            break;
                        case "CB96BDD5-5F74-4EA5-8323-9D7E20079002":
                            Console.WriteLine("  License type: Enterprise");
                            break;
                        case "66AE2919-DD58-40CA-A980-AEF7330B2745":
                            Console.WriteLine("  License type: Live");
                            break;
                        case "722E9E15-62DC-48A7-95CF-93131BE27273":
                            Console.WriteLine("  License type: SPLA (Service Provider)");
                            break;
                        default:
                            Console.WriteLine("  Unknown license type with id {0}", licenseId);
                            break;
                    }

                    #endregion

                    #region RetrieveLicenseInfoRequest

                    // create the request
                    var licenseInfoRequest = new RetrieveLicenseInfoRequest();

                    // execute the request
                    Console.WriteLine("  Fetching license info");
                    var licenseInfoResponse =
                        (RetrieveLicenseInfoResponse)_serviceProxy.Execute(licenseInfoRequest);

                    // output the results
                    Console.WriteLine("  Number of licenses available: {0}",
                        licenseInfoResponse.AvailableCount);
                    Console.WriteLine("  Number of licenses used: {0}",
                        licenseInfoResponse.GrantedLicenseCount);

                    #endregion
                }

            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                License app = new License();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        #endregion Main method
    }
}

See Also

Concepts

Use the early bound entity classes in code

Other Resources

IDeploymentService
IOrganizationService
RetrieveDeploymentLicenseTypeRequest
RetrieveLicenseInfoRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the late bound entity class in code

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the Entity class when you work with entities. When initialized, the Entity class contains the logical name of an entity and a property-bag array of the entity’s attributes. This lets you use late binding so that you can work with types such as custom entities and custom attributes that weren’t available when your application was compiled.

The key difference between early and late binding involves type conversion. While early binding provides compile-time checking of all types so that no implicit casts occur, late binding checks types only when the object is created or an action is performed on the type. The Entity class requires types to be explicitly specified to prevent implicit casts.

See Also

Concepts

Retrieve data with queries
Use the Entity class for create, update and delete
Use the Entity class to add or update associations between related records

Other Resources

Write applications and server extensions
Sample: Create, retrieve, update, and delete (late bound)
Sample: Serialize and deserialize an entity Instance

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the Entity class for create, update and delete

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the Entity class to create, update, and delete entities and entity attributes.

Create, update, and delete using the Entity class

When you work with the Entity class and use late binding, you work with the entity and logical attribute name. This contrasts with early binding where you work with the entity and attribute schema name. The logical attribute name is all lowercase whereas the schema attribute name uses Pascal casing.

To create a new entity, you first create a new instance of the Entity class and pass it an entity name. The following code example shows how to create a new account record.

C# Copy Code
// Instantiate an account object.
Entity account = new Entity("account");

// Set the required attributes. For account, only the name is required.
// See the metadata to determine
// which attributes must be set for each entity.
account["name"] = "Fourth Coffee";

// Create an account record named Fourth Coffee.
_accountId = _orgService.Create(account);

In the example, a new entity object is created of type “account,” attributes are set, and then the IOrganizationService.Create method is called to create the new record.

To update an entity, you set a value for the attribute to be updated, and then call the IOrganizationService.Update method. The following code example shows how to update an attribute in an account.

C# Copy Code
Entity account = new Entity("account");
// Create a column set to define which attributes should be retrieved.
ColumnSet attributes = new ColumnSet(new string[] { "name", "ownerid" });

// Retrieve the account and its name and ownerid attributes.
account = _orgService.Retrieve(account.LogicalName, _accountId, attributes);

// Update the postal code attribute.
account["address1_postalcode"] = "98052";

// Update the account.
_orgService.Update(account);

To delete an entity, you can pass the key attribute information to the IOrganizationService.Delete method. The following code example shows how to use the Delete method.

Copy Code
_orgService.Delete("account", _accountId);

See Also

Concepts

Use the Entity class to add or update associations between related records
Use the late bound entity class in code

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the Entity class to add or update associations between related records

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the IOrganizationService. Associate and IOrganizationService.Disassociate methods to create and remove associations between related records.

To create an association, you first determine the unique ID of the target entity to be associated. You then create a collection of entities to be associated with the target entity. Next, you define a relationship between the entities in the collection and the target entity. Finally, you pass this information to the Associate method. The same information is passed to the Disassociate method when you remove an association.

The following code example shows how to create associations between related records and how to disassociate them.

C# Copy Code
// The account ID would typically be passed in as an argument or determined by a query.
// The contact ID would typically be passed in as an argument or determined by a query.
// Associate the accounts to the contact record.
//Create a collection of the entity ids that will be associated to the contact.
EntityReferenceCollection relatedEntities = new EntityReferenceCollection();
relatedEntities.Add(new EntityReference("account", _account1Id));
relatedEntities.Add(new EntityReference("account", _account2Id));
relatedEntities.Add(new EntityReference("account", _account3Id));
// Create an object that defines the relationship between the contact and account.
Relationship relationship = new Relationship("account_primary_contact");
  //Associate the contact with the 3 accounts.
_orgService.Associate("contact", _contactId, relationship, relatedEntities);
Console.WriteLine("The entities have been associated.");
//Disassociate the records.
_orgService.Disassociate("contact", _contactId, relationship, relatedEntities);
Console.WriteLine("The entities have been disassociated.");

See Also

Concepts

Use the late bound entity class in code
Use the Entity class for create, update and delete
Entity relationship behavior

Other Resources

Sample: Create, retrieve, update, and delete (late bound)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete (late bound)
See Also Example

This sample is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\LateBound\CRUDOperationsDE.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Example

This sample demonstrates the create, retrieve, update, and delete operations on an account using the late bound Entity class.

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do basic entity operations like create, retrieve,
    /// update, and delete.
    /// If you want to run this sample repeatedly, you have the option to
    /// delete all the records created at the end of execution.
    /// </summary>
    public class CRUDOperationsDE
    {
        #region Class Level Members
        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        // Define the IDs needed for this sample.
        private Guid _accountId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create an account record
        /// Retrieve the account record
        /// Update the account record
        /// Optionally delete any entity records that were created for this sample.
       /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete
        /// all created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    _service = (IOrganizationService)_serviceProxy;

                    // Instaniate an account object.
                    Entity account = new Entity("account");

                    // Set the required attributes. For account, only the name is required.
                    // See the Entity Metadata topic in the SDK documentatio to determine
                    // which attributes must be set for each entity.
                    account["name"] = "Fourth Coffee";

                    // Create an account record named Fourth Coffee.
                    _accountId = _service.Create(account);

                    Console.Write("{0} {1} created, ", account.LogicalName, account.Attributes["name"]);

                    // Create a column set to define which attributes should be retrieved.
                    ColumnSet attributes = new ColumnSet(new string[] { "name", "ownerid" });

                    // Retrieve the account and its name and ownerid attributes.
                    account = _service.Retrieve(account.LogicalName, _accountId, attributes);
                    Console.Write("retrieved, ");

                    // Update the postal code attribute.
                    account["address1_postalcode"] = "98052";

                    // The address 2 postal code was set accidentally, so set it to null.
                    account["address2_postalcode"] = null;

                    // Shows use of Money.
                    account["revenue"] = new Money(5000000);

                    // Shows use of boolean.
                    account["creditonhold"] = false;

                    // Update the account.
                    _service.Update(account);
                    Console.WriteLine("and updated.");

                    // Delete the account.
                    bool deleteRecords = true;

                    if (promptForDelete)
                    {
                        Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                        String answer = Console.ReadLine();

                        deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
                    }

                    if (deleteRecords)
                    {
                        _service.Delete("account", _accountId);

                        Console.WriteLine("Entity record(s) have been deleted.");
                    }

                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CRUDOperationsDE app = new CRUDOperationsDE();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Reference

Create
Retrieve
Update
Delete

Concepts

Use the late bound entity class in code

Other Resources

Helper code: ServerConnection class
Sample: Create, retrieve, update, and delete records (early bound)
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Retrieve data with queries

There are several ways to create queries in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. You can use .NET Language-Integrated Query (LINQ) in early and late binding scenarios, you can write queries by using FetchXML, the proprietary Microsoft Dynamics CRM query language, or you can build a query by using QueryExpression and the QueryExpression class.

The following table lists the basic capabilities of each query style.

Query style | Capabilities
FetchXML | Supports all the features of QueryExpression plus aggregates and grouping. Queries are built as XML statements.
QueryExpression | Queries are built as an object model. Supports all the features in FetchXML except for aggregates and grouping.
LINQ | Queries are built using standard language, but internally uses QueryExpression so is limited to the features of QueryExpression.

Use FetchXML to create queries that return aggregates such as the sum of a value for all returned records. You can also perform “group by” operations with FetchXML.

.NET Language-Integrated Query (LINQ) uses standard query patterns. The OrganizationServiceContext class contains the LINQ query provider and is efficient at creating multiple associations.

The following messages are useful for working with queries when you want to convert between FetchXml and QueryExpression: FetchXmlToQueryExpressionRequest and QueryExpressionToFetchXmlRequest.

In this section

Build queries with LINQ (.NET language-integrated query)

Build queries with FetchXML

Build queries with QueryExpression

Query hierarchical data

Retrieve records for many-to-many relationships using intersect entities

FetchXML schema

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Build queries with LINQ (.NET language-integrated query)

You can use .NET Language-Integrated Query (LINQ) to write queries in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. You can use the OrganizationServiceContext class or a deriving class created by the CrmSvcUtil tool to write LINQ queries that access the SOAP endpoint (Organization.svc). The OrganizationServiceContext class contains an underlying LINQ query provider that translates LINQ queries from Microsoft Visual C# or Microsoft Visual Basic .NET syntax into the query API used by Microsoft Dynamics CRM.

When you use early-bound programming classes you can generate a class derived from the OrganizationServiceContext class if you specify the name of the class using the servicecontextname parameter when using the Code Generation Tool (CrmSvcUtil.exe). Use of this class allows for referencing an IQueryable entity set using the pattern <entity schema name>+Set, for example AccountSet to reference the collection of Account entity records. All samples in the Microsoft Dynamics CRM SDK use ServiceContext as the name for this class but your code may use a different name. More information: Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)

In This Section

Use LINQ to construct a query

Use late-bound entity class with a LINQ query

Order results using entity attributes with LINQ

Order results using entity attributes with LINQ

Page large result sets with LINQ

LINQ query examples

Sample: Create a LINQ query

Sample: Complex LINQ queries

Sample: RetrieveMultiple with condition operators using LINQ

Sample: More LINQ query examples

Sample: Use LINQ with late binding

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use LINQ to construct a query

The .NET Language-Integrated Query (LINQ) query provider in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update uses standard LINQ syntax. The first step in creating a LINQ query is to identify the relevant entity types and the relationships between them. You can then specify the data source and the other query parameters.

The from clause is used to return a single “root” entity. The query provider can only return entities of a single entity type. The orderby and select clauses must reference this root entity. You can use join clauses to add entities with a relationship to the “root” entity.

In This Topic

LINQ operators

LINQ limitations

Filter multiple entities

LINQ operators

All LINQ query expressions have a similar format. The following table shows the most common clauses in a LINQ query expression when using the Microsoft Dynamics CRM LINQ query provider.

LINQ Operator Description Example

Obtain a data source (the from clause)

When using the generated service context and early binding, use the IQueryable entity set, such as AccountSet, in the generated context.

When not using the generated context, the CreateQuery method on the organization service context object gives you access to Microsoft Dynamics CRM entities.

Using the generated service context:

C# Copy Code
var query1 = from c in context.ContactSetselect c;

Using the CreateQuery method:

C# Copy Code
var query1 = from c in context.CreateQuery<Contact>()select c;

join clause

The join clause represents an inner join. You use the clause to work with two or more entities that can be joined with a common attribute value.

C# Copy Code
from c in context.ContactSetjoin a in context.AccountSet on c.ContactId equals a.PrimaryContactId.Id

Filtering (the where clause)

The where clause applies a filter to the results, often using a Boolean expression. The filter specifies which elements to exclude from the source sequence. Each where clause can only contain conditions against a single entity type. A composite condition involving multiple entities is not valid. Instead, each entity should be filtered in separate where clauses.

C# Copy Code
from a in context.AccountSetwhere (a.Name.StartsWith("Contoso") && a.Address1_StateOrProvince == "WA")

orderby

The orderby operator puts the returned query attributes in a specified order.

C# Copy Code
var query1 = from c in context.CreateQuery<Contact>()   orderby c.FullName ascending   select c;foreach ( var q in query1)   {   Console.WriteLine(q.FirstName + " " + q.LastName);   }

select clause

The select clause defines the form of the data returned. The clause creates a column set based on the query expression results. You can also define an instance of a new object to work with. The newly created object using the select clause is not created on the server, but is a local instance.

C# Copy Code
select new Contact   {   ContactId = c.ContactId,   FirstName = c.FirstName,   LastName = c.LastName,   Address1_Telephone1 = c.Address1_Telephone1   };

LINQ limitations

The LINQ query provider supports a subset of the LINQ operators. Not all conditions that can be expressed in LINQ are supported. The following table shows some of the limitations of the basic LINQ operators.

LINQ Operator | Limitations
join | Represents an inner join. You cannot perform outer joins.
from | Supports one from clause per query.
where | The left side of the clause must be an attribute name and the right side of the clause must be a value. You cannot set the left side to a constant. Both the sides of the clause cannot be constants. Supports the String functions Contains, StartsWith, EndsWith, and Equals.
groupBy | Not supported. FetchXML supports grouping options that are not available with the LINQ query provider. More information: Use FetchXML aggregation
orderBy | Supports ordering by entity attributes, such as Contact.FullName.
select | Supports anonymous types, constructors, and initializers.
last | The last operator is not supported.
skip and take | Supports skip and take using server-side paging. The skip value must be greater than or equal to the take value.
aggregate | Not supported. FetchXML supports aggregation options that are not available with the LINQ query provider. More information: Use FetchXML aggregation

Filter multiple entities

You can create complex .NET Language-Integrated Query (LINQ) queries in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online. You use multiple Join clauses with filter clauses to create a result that is filtered on attributes from several entities.

The following sample shows how to create a LINQ query that works with two entities and filters the result based on values from each of the entities.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_where3 = from c in svcContext.ContactSet
                    join a in svcContext.AccountSet
                    on c.ContactId equals a.PrimaryContactId.Id
                    where a.Name.Contains("Contoso")
                    where c.LastName.Contains("Smith")
                    select new
                    {
                     account_name = a.Name,
                     contact_name = c.LastName
                    };

 foreach (var c in query_where3)
 {
  System.Console.WriteLine("acct: " +
   c.account_name +
   "\t\t\t" +
   "contact: " +
   c.contact_name);
 }
}

See Also

Concepts

Use late-bound entity class with a LINQ query

Other Resources

Sample: Create a LINQ query
Sample: Complex LINQ queries
Build queries with LINQ (.NET language-integrated query)
Blog: LINQPad plugin for MS Dynamics CRM 2011

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use late-bound entity class with a LINQ query

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online, you can use late binding with .NET Language-Integrated Query (LINQ) queries. Late binding uses the attribute logical name, and is resolved at runtime.

In This Topic

Using late binding in a join clause

Using late binding in a left join

Using late binding and the Contains method

Using late binding and not equals operator

Using the GetAttributeValue method

Using late binding in a join clause

The following examples show how to use late binding in the join clause of a LINQ query.

Retrieve the full name of the contact that represents the primary contact for an account and the account name.

C# Copy Code
using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
{
 var query_join2 = from c in orgSvcContext.CreateQuery("contact")
                   join a in orgSvcContext.CreateQuery("account")
                   on c["contactid"] equals a["primarycontactid"]
                   select new
                   {
                    contact_name = c["fullname"],
                    account_name = a["name"]
                   };
 foreach (var c in query_join2)
 {
  System.Console.WriteLine(c.contact_name + "  " + c.account_name);
 }
}

Retrieve Contact, Account and Lead data where the Lead was the originating Lead and the Contact’s last name is not “Parker”

C# Copy Code
using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
{
 var query_dejoin = from c in orgSvcContext.CreateQuery("contact")
                    join a in orgSvcContext.CreateQuery("account")
                    on c["contactid"] equals a["primarycontactid"]
                    join l in orgSvcContext.CreateQuery("lead")
                    on a["originatingleadid"] equals l["leadid"]
                    where (string)c["lastname"] != "Parker"
                    select new { Contact = c, Account = a, Lead = l };
 foreach (var c in query_dejoin)
 {
  System.Console.WriteLine(c.Account.Attributes["name"] + " " +
   c.Contact.Attributes["fullname"] + " " + c.Lead.Attributes["leadid"]);
 }
}

Using late binding in a left join

The following example shows how to retrieve a list of Contact and Account information using a left join. A left join is designed to return parents with and without children from two sources. There is a correlation between parent and child, but no child may actually exist.

C# Copy Code
using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
{
 var query_join9 = from a in orgSvcContext.CreateQuery("account")
                   join c in orgSvcContext.CreateQuery("contact")
                   on a["primarycontactid"] equals c["contactid"] into gr
                   from c_joined in gr.DefaultIfEmpty()
                   select new
                   {
                    account_name = a.Attributes["name"]
                   };
 foreach (var c in query_join9)
 {
  System.Console.WriteLine(c.account_name);
 }
}

Using late binding and the Contains method

The following example shows how to use late binding with the Contains method in a LINQ query.

C# Copy Code
using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
{
 var query_contains3 = from c in orgSvcContext.CreateQuery("contact")
                       where ((string)c["description"]).Contains("Coho")
                       select new
                       {
                        firstname = c.Attributes["firstname"],
                        lastname = c.Attributes["lastname"]
                       };
 foreach (var c in query_contains3)
 {
  System.Console.WriteLine(c.firstname + " " + c.lastname);
 }
}

Using late binding and not equals operator

The following example shows use of the not equals operator.

C# Copy Code
using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
{
 var query_ne3 = from c in orgSvcContext.CreateQuery("contact")
                 where !c["address1_city"].Equals(null)
                 select new
                 {
                  FirstName = c["firstname"],
                  LastName = c["lastname"],
                  Address1_City = c["address1_city"]
                 };
 foreach (var c in query_ne3)
 {
  System.Console.WriteLine(c.FirstName + " " +
   c.LastName + " " + c.Address1_City);
 }
}

Using the GetAttributeValue method

The following example shows how to retrieve Contact information using the GetAttributeValue method.

C# Copy Code
using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
{

 var list_getattrib1 = (from c in orgSvcContext.CreateQuery("contact")
                        where c.GetAttributeValue<Guid?>("contactid") != _contactId1
                        select new {
                         FirstName = c.GetAttributeValue<string>("firstname"),
                         LastName = c.GetAttributeValue<string>("lastname")
                        }).ToList();
 foreach (var c in list_getattrib1)
 {
  System.Console.WriteLine(c.FirstName + " " + c.LastName);
 }
}

See Also

Concepts

Order results using entity attributes with LINQ

Other Resources

Build queries with LINQ (.NET language-integrated query)
CreateQuery``1

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Order results using entity attributes with LINQ

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online, you can use lookup or OptionSet (Picklist) attributes to order results within a LINQ query. This topic shows several examples of this type of query.

Using a Lookup Value to Order By

The following sample shows use the lookup attribute PrimaryContactId in an Order By clause.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_orderbylookup = from a in svcContext.AccountSet
                           where a.Address1_Name == "Contoso Pharmaceuticals"
                           orderby a.PrimaryContactId
                           select new
                           {
                            a.Name,
                            a.Address1_City
                           };
 foreach (var a in query_orderbylookup)
 {
  System.Console.WriteLine(a.Name + " " + a.Address1_City);
 }
}

Using a Picklist to Order By

The following sample shows use of a lookup value to order by.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_orderbypicklist = from c in svcContext.ContactSet
                             where c.LastName != "Parker" &&
                             c.AccountRoleCode != null
                             orderby c.AccountRoleCode, c.FirstName
                             select new
                             {
                              AccountRole = c.FormattedValues["accountrolecode"],
                              c.FirstName,
                              c.LastName
                             };
 foreach (var c in query_orderbypicklist)
 {
  System.Console.WriteLine(c.AccountRole + " " +
   c.FirstName + " " + c.LastName);
 }
}

See Also

Concepts

Page large result sets with LINQ

Other Resources

Build queries with LINQ (.NET language-integrated query)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Page large result sets with LINQ

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update you can page the results of a large .NET Language-Integrated Query (LINQ) query by using the Take and Skip operators. The Take operator retrieves a specified number of results and the Skip operator skips over a specified number of results.

LINQ paging example

The following example shows how to page the results of a LINQ query by using the Take and Skip operators:

C# Copy Code
int pageSize = 5;

var accountsByPage = (from a in svcContext.AccountSet
                      select new Account
                      {
                       Name = a.Name,
                      });
System.Console.WriteLine("Skip 10 accounts, then Take 5 accounts");
System.Console.WriteLine("======================================");
foreach (var a in accountsByPage.Skip(2 * pageSize).Take(pageSize))
{
 System.Console.WriteLine(a.Name);
}

See Also

Concepts

LINQ query examples

Other Resources

Build queries with LINQ (.NET language-integrated query)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


LINQ query examples

This topic contains many samples of LINQ queries. For the full sample, see Sample: Complex LINQ queries.

In This Topic

Simple Where clause

Join and simple Where clause

Use the Distinct operator

Simple inner join

Self-join

Double and multiple joins

Join using entity fields

Late-binding left join

Use the Equals Operator

Use the Not Equals operator

Use a method-based LINQ query with a Where clause

Use the Greater Than operator

Use the Greater Than or Equals and Less Than or Equals operators

Use the Contains operator

Use the Does Not Contain operator

Use the StartsWith and EndsWith operators

Use the And and Or operators

Use the OrderBy operator

Use the First and Single operators

Retrieve formatted values

Use the Skip and Take operators without paging

Use the FirstOrDefault and SingleOrDefault operators

Use a self-join with a condition on the linked entity

Use a transformation in the Where clause

Use a paging sort

Retrieve related entity columns for 1 to N relationships

Use .value to retrieve the value of an attribute

Multiple projections, new data type casting to different types

Use the GetAttributeValue method

Use Math methods

Use multiple Select and Where clauses

Use SelectMany

Use string operations

Use two Where clauses

Use LoadProperty to retrieve related records

Simple Where clause

The following sample shows how to retrieve a list of accounts where the Name contains “Contoso”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_where1 = from a in svcContext.AccountSet
                    where a.Name.Contains("Contoso")
                    select a;
 foreach (var a in query_where1)
 {
  System.Console.WriteLine(a.Name + " " + a.Address1_City);
 }
}

The following sample shows how to retrieve a list of accounts where the Name contains “Contoso” and Address1_City is “Redmond”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_where2 = from a in svcContext.AccountSet
                    where a.Name.Contains("Contoso")
                    where a.Address1_City == "Redmond"
                    select a;

 foreach (var a in query_where2)
 {
  System.Console.WriteLine(a.Name + " " + a.Address1_City);
 }
}

Join and simple Where clause

The following sample shows how to retrieve the account Name and the contact LastName where the account Name contains “Contoso” and the contact LastName contains “Smith” and the contact is the Primary Contact for the account.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_where3 = from c in svcContext.ContactSet
                    join a in svcContext.AccountSet
                    on c.ContactId equals a.PrimaryContactId.Id
                    where a.Name.Contains("Contoso")
                    where c.LastName.Contains("Smith")
                    select new
                    {
                     account_name = a.Name,
                     contact_name = c.LastName
                    };

 foreach (var c in query_where3)
 {
  System.Console.WriteLine("acct: " +
   c.account_name +
   "\t\t\t" +
   "contact: " +
   c.contact_name);
 }
}

Use the Distinct Operator

The following sample shows how to retrieve a distinct list of contact last names. Although there may be duplicates, each name will be listed only once.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_distinct = (from c in svcContext.ContactSet
                       select c.LastName).Distinct();
 foreach (var c in query_distinct)
 {
  System.Console.WriteLine(c);
 }
}

Simple inner join

The following sample shows how to retrieve information about an account and the contact listed as the primary contact for the account.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_join1 = from c in svcContext.ContactSet
                   join a in svcContext.AccountSet
                  on c.ContactId equals a.PrimaryContactId.Id
                   select new
                   {
                    c.FullName,
                    c.Address1_City,
                    a.Name,
                    a.Address1_Name
                   };
 foreach (var c in query_join1)
 {
  System.Console.WriteLine("acct: " +
   c.Name +
   "\t\t\t" +
   "contact: " +
   c.FullName);
 }
}

Self-join

The following sample shows how to retrieve information about accounts where an account is the parent account for an account.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_join5 = from a in svcContext.AccountSet
                   join a2 in svcContext.AccountSet
                   on a.ParentAccountId.Id equals a2.AccountId

                   select new
                   {
                    account_name = a.Name,
                    account_city = a.Address1_City
                   };
 foreach (var c in query_join5)
 {
  System.Console.WriteLine(c.account_name + "  " + c.account_city);
 }
}

Double and multiple joins

The following sample shows how to retrieve information from account, contact and lead where the contact is the primary contact for the account and the lead was the originating lead for the account.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_join4 = from a in svcContext.AccountSet
                   join c in svcContext.ContactSet
                   on a.PrimaryContactId.Id equals c.ContactId
                   join l in svcContext.LeadSet
                   on a.OriginatingLeadId.Id equals l.LeadId
                   select new
                   {
                    contact_name = c.FullName,
                    account_name = a.Name,
                    lead_name = l.FullName
                   };
 foreach (var c in query_join4)
 {
  System.Console.WriteLine(c.contact_name +
   "  " +
   c.account_name +
   "  " +
   c.lead_name);
 }
}

The following sample shows how to retrieve account and contact information where an account is the parent account for an account and the contact is the primary contact for the account.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_join6 = from c in svcContext.ContactSet
                   join a in svcContext.AccountSet
                   on c.ContactId equals a.PrimaryContactId.Id
                   join a2 in svcContext.AccountSet
                   on a.ParentAccountId.Id equals a2.AccountId
                   select new
                   {
                    contact_name = c.FullName,
                    account_name = a.Name
                   };
 foreach (var c in query_join6)
 {
  System.Console.WriteLine(c.contact_name + "  " + c.account_name);
 }
}

Join using entity fields

The following sample shows how to retrieve information about accounts from a list

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var list_join = (from a in svcContext.AccountSet
                  join c in svcContext.ContactSet
                  on a.PrimaryContactId.Id equals c.ContactId
                  where a.Name == "Contoso Ltd" &&
                  a.Address1_Name == "Contoso Pharmaceuticals"
                  select a).ToList();
 foreach (var c in list_join)
 {
  System.Console.WriteLine("Account " + list_join[0].Name
      + " and it's primary contact "
      + list_join[0].PrimaryContactId.Id);
 }
}

Late-binding left join

The following sample shows a left join. A left join is designed to return parents with and without children from two sources. There is a correlation between parent and child, but no child may actually exist.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_join8 = from a in svcContext.AccountSet
                   join c in svcContext.ContactSet
                   on a.PrimaryContactId.Id equals c.ContactId
                   into gr
                   from c_joined in gr.DefaultIfEmpty()
                   select new
                   {
                    contact_name = c_joined.FullName,
                    account_name = a.Name
                   };
 foreach (var c in query_join8)
 {
  System.Console.WriteLine(c.contact_name + "  " + c.account_name);
 }
}

Use the Equals operator

The following sample shows how to retrieve a list of contacts where the FirstName is “Colin”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_equals1 = from c in svcContext.ContactSet
                     where c.FirstName.Equals("Colin")
                     select new
                     {
                      c.FirstName,
                      c.LastName,
                      c.Address1_City
                     };
 foreach (var c in query_equals1)
 {
  System.Console.WriteLine(c.FirstName +
   " " + c.LastName +
   " " + c.Address1_City);
 }
}

The following sample shows how to retrieve a list of contacts where the FamilyStatusCode is 3. This corresponds to the Marital Status option of Divorced.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_equals2 = from c in svcContext.ContactSet
                     where c.FamilyStatusCode.Equals(3)
                     select new
                     {
                      c.FirstName,
                      c.LastName,
                      c.Address1_City
                     };
 foreach (var c in query_equals2)
 {
  System.Console.WriteLine(c.FirstName +
   " " + c.LastName +
   " " + c.Address1_City);
 }
}

Use the Not Equals operator

The following sample shows how to retrieve a list of contacts where the Address1_City is not “Redmond”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_ne1 = from c in svcContext.ContactSet
                 where c.Address1_City != "Redmond"
                 select new
                 {
                  c.FirstName,
                  c.LastName,
                  c.Address1_City
                 };
 foreach (var c in query_ne1)
 {
  System.Console.WriteLine(c.FirstName + " " +
   c.LastName + " " + c.Address1_City);
 }
}

The following sample shows how to retrieve a list of contacts where the FirstName is not “Colin”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_ne2 = from c in svcContext.ContactSet
                 where !c.FirstName.Equals("Colin")
                 select new
                 {
                  c.FirstName,
                  c.LastName,
                  c.Address1_City
                 };

 foreach (var c in query_ne2)
 {
  System.Console.WriteLine(c.FirstName + " " +
   c.LastName + " " + c.Address1_City);
 }
}

Use a method-based LINQ query with a Where clause

The following sample shows how to retrieve a list of contacts where the LastName is “Smith” or contains “Smi”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var methodResults = svcContext.ContactSet
  .Where(a => a.LastName == "Smith");
 var methodResults2 = svcContext.ContactSet
  .Where(a => a.LastName.StartsWith("Smi"));
 Console.WriteLine();
 Console.WriteLine("Method query using Lambda expression");
 Console.WriteLine("---------------------------------------");
 foreach (var a in methodResults)
 {
  Console.WriteLine("Name: " + a.FirstName + " " + a.LastName);
 }
 Console.WriteLine("---------------------------------------");
 Console.WriteLine("Method query 2 using Lambda expression");
 Console.WriteLine("---------------------------------------");
 foreach (var a in methodResults2)
 {
  Console.WriteLine("Name: " + a.Attributes["firstname"] +
   " " + a.Attributes["lastname"]);
 }
}

Use the Greater Than operator

The following sample shows how to retrieve a list of contacts with an Anniversary date later than February 5, 2010.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_gt1 = from c in svcContext.ContactSet
                 where c.Anniversary > new DateTime(2010, 2, 5)
                 select new
                 {
                  c.FirstName,
                  c.LastName,
                  c.Address1_City
                 };

 foreach (var c in query_gt1)
 {
  System.Console.WriteLine(c.FirstName + " " +
   c.LastName + " " + c.Address1_City);
 }
}

The following sample shows how to retrieve contacts with a CreditLimit greater than $20,000.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_gt2 = from c in svcContext.ContactSet
                 where c.CreditLimit.Value > 20000
                 select new
                 {
                  c.FirstName,
                  c.LastName,
                  c.Address1_City
                 };
 foreach (var c in query_gt2)
 {
  System.Console.WriteLine(c.FirstName + " " +
   c.LastName + " " + c.Address1_City);
 }
}

Use the Greater Than or Equals and Less Than or Equals operators

The following sample shows how to retrieve contacts with a CreditLimit greater than $200 and less than $400.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_gele1 = from c in svcContext.ContactSet
                   where c.CreditLimit.Value >= 200 &&
                   c.CreditLimit.Value <= 400
                   select new
                   {
                    c.FirstName,
                    c.LastName
                   };
 foreach (var c in query_gele1)
 {
  System.Console.WriteLine(c.FirstName + " " + c.LastName);
 }
}

Use the Contains operator

The following sample shows how to retrieve contacts where the Description contains “Alpine”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_contains1 = from c in svcContext.ContactSet
                       where c.Description.Contains("Alpine")
                       select new
                       {
                        c.FirstName,
                        c.LastName
                       };
 foreach (var c in query_contains1)
 {
  System.Console.WriteLine(c.FirstName + " " + c.LastName);
 }
}

Use the Does Not Contain operator

The following sample shows how to retrieve contacts where the Description does not contain “Coho”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_contains2 = from c in svcContext.ContactSet
                       where !c.Description.Contains("Coho")
                       select new
                       {
                        c.FirstName,
                        c.LastName
                       };
 foreach (var c in query_contains2)
 {
  System.Console.WriteLine(c.FirstName + " " + c.LastName);
 }
}

Use the StartsWith and EndsWith operators

The following sample shows how to retrieve contacts where FirstName starts with “Bri”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_startswith1 = from c in svcContext.ContactSet
                         where c.FirstName.StartsWith("Bri")
                         select new
                         {
                          c.FirstName,
                          c.LastName
                         };
 foreach (var c in query_startswith1)
 {
  System.Console.WriteLine(c.FirstName + " " + c.LastName);
 }
}

The following sample shows how to retrieve contacts where LastName ends with “cox”.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_endswith1 = from c in svcContext.ContactSet
                       where c.LastName.EndsWith("cox")
                       select new
                       {
                        c.FirstName,
                        c.LastName
                       };
 foreach (var c in query_endswith1)
 {
  System.Console.WriteLine(c.FirstName + " " + c.LastName);
 }
}

Use the And and Or operators

The following sample shows how to retrieve contacts where Address1_City is “Redmond” or “Bellevue” and a CreditLimit that is greater than $200.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_andor1 = from c in svcContext.ContactSet
                    where ((c.Address1_City == "Redmond" ||
                    c.Address1_City == "Bellevue") &&
                    (c.CreditLimit.Value != null &&
                    c.CreditLimit.Value >= 200))
                    select c;

 foreach (var c in query_andor1)
 {
  System.Console.WriteLine(c.LastName + ", " + c.FirstName + " " +
   c.Address1_City + " " + c.CreditLimit.Value);
 }
}

Use the OrderBy operator

The following sample shows how to retrieve contacts ordered by CreditLimit in descending order.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_orderby1 = from c in svcContext.ContactSet
                      where !c.CreditLimit.Equals(null)
                      orderby c.CreditLimit descending
                      select new
                      {
                       limit = c.CreditLimit,
                       first = c.FirstName,
                       last = c.LastName
                      };
 foreach (var c in query_orderby1)
 {
  System.Console.WriteLine(c.limit.Value + " " +
   c.last + ", " + c.first);
 }
}

The following sample shows how to retrieve contacts ordered by LastName in descending order and FirstName in ascending order.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_orderby2 = from c in svcContext.ContactSet
                      orderby c.LastName descending,
                      c.FirstName ascending
                      select new
                      {
                       first = c.FirstName,
                       last = c.LastName
                      };

 foreach (var c in query_orderby2)
 {
  System.Console.WriteLine(c.last + ", " + c.first);
 }
}

Use the First and Single operators

The following sample shows how to retrieve only the first contact record returned and retrieve only one contact record that matches the criterion.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 Contact firstcontact = svcContext.ContactSet.First();

 Contact singlecontact = svcContext.ContactSet.Single(c => c.ContactId == _contactId1);
 System.Console.WriteLine(firstcontact.LastName + ", " +
  firstcontact.FirstName + " is the first contact");
 System.Console.WriteLine("==========================");
 System.Console.WriteLine(singlecontact.LastName + ", " +
  singlecontact.FirstName + " is the single contact");
}

Retrieving formatted values

The following sample shows how to retrieve the label for an optionset option, in this case the value for the current record status.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var list_retrieve1 = from c in svcContext.ContactSet
                      where c.ContactId == _contactId1
                      select new { StatusReason = c.FormattedValues["statuscode"] };
 foreach (var c in list_retrieve1)
 {
  System.Console.WriteLine("Status: " + c.StatusReason);
 }
}

Use the Skip and Take operators without paging

The following sample shows how to retrieve just two records after skipping two records where the LastName is not “Parker” using the Skip and Takeoperators.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{

 var query_skip = (from c in svcContext.ContactSet
                   where c.LastName != "Parker"
                   orderby c.FirstName
                   select new
                       {
                        last = c.LastName,
                        first = c.FirstName
                       }).Skip(2).Take(2);
 foreach (var c in query_skip)
 {
  System.Console.WriteLine(c.first + " " + c.last);
 }
}

Use the FirstOrDefault and SingleOrDefault operators

The FirstOrDefault operator returns the first element of a sequence, or a default value if no element is found. The SingleOrDefault operator returns a single, specific element of a sequence, or a default value if that element is not found. The following sample shows how to use these operators.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{

 Contact firstorcontact = svcContext.ContactSet.FirstOrDefault();

 Contact singleorcontact = svcContext.ContactSet
  .SingleOrDefault(c => c.ContactId == _contactId1);

 System.Console.WriteLine(firstorcontact.FullName +
  " is the first contact");
 System.Console.WriteLine("==========================");
 System.Console.WriteLine(singleorcontact.FullName +
  " is the single contact");
}

Use a self-join with a condition on the linked entity

The following sample shows how to retrieve the names of two accounts where one account is the parent account of the other.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_joincond = from a1 in svcContext.AccountSet
                      join a2 in svcContext.AccountSet
                      on a1.ParentAccountId.Id equals a2.AccountId
                      where a2.AccountId == _accountId1
                      select new { Account = a1, Parent = a2 };
 foreach (var a in query_joincond)
 {
  System.Console.WriteLine(a.Account.Name + " " + a.Parent.Name);
 }
}

Use a transformation in the Where Clause

The following sample shows how to retrieve a specific contact where the anniversary date is later than January 1, 2010.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_wheretrans = from c in svcContext.ContactSet
                        where c.ContactId == _contactId1 &&
                        c.Anniversary > DateTime.Parse("1/1/2010")
                        select new
                        {
                         c.FirstName,
                         c.LastName
                        };
 foreach (var c in query_wheretrans)
 {
  System.Console.WriteLine(c.FirstName + " " + c.LastName);
 }
}

Use a paging sort

The following sample shows a multi-column sort with an extra condition.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_pagingsort1 = (from c in svcContext.ContactSet
                          where c.LastName != "Parker"
                          orderby c.LastName ascending,
                          c.FirstName descending
                          select new { c.FirstName, c.LastName })
                          .Skip(2).Take(2);
 foreach (var c in query_pagingsort1)
 {
  System.Console.WriteLine(c.FirstName + " " + c.LastName);
 }
}

The following sample shows a paging sort where the column being sorted is different from the column being retrieved.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_pagingsort2 = (from c in svcContext.ContactSet
                          where c.LastName != "Parker"
                          orderby c.FirstName descending
                          select new { c.FirstName }).Skip(2).Take(2);
 foreach (var c in query_pagingsort2)
 {
  System.Console.WriteLine(c.FirstName);
 }
}

The following sample shows how to retrieve just the first 10 records.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_pagingsort3 = (from c in svcContext.ContactSet
                          where c.LastName.StartsWith("W")
                          orderby c.MiddleName ascending,
                          c.FirstName descending
                          select new
                          {
                           c.FirstName,
                           c.MiddleName,
                           c.LastName
                          }).Take(10);
 foreach (var c in query_pagingsort3)
 {
  System.Console.WriteLine(c.FirstName + " " +
   c.MiddleName + " " + c.LastName);
 }
}

Retrieve related entity columns for 1 to N relationships

The following sample shows how to retrieve columns from related account and contact records.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_retrieve1 = from c in svcContext.ContactSet
                       join a in svcContext.AccountSet
                       on c.ContactId equals a.PrimaryContactId.Id
                       where c.ContactId != _contactId1
                       select new { Contact = c, Account = a };
 foreach (var c in query_retrieve1)
 {
  System.Console.WriteLine("Acct: " + c.Account.Name +
   "\t\t" + "Contact: " + c.Contact.FullName);
 }
}

Use .value to retrieve the value of an attribute

The following sample shows usage of Value to access the value of an attribute.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{

 var query_value = from c in svcContext.ContactSet
                   where c.ContactId != _contactId2
                   select new
                   {
                    ContactId = c.ContactId != null ?
                     c.ContactId.Value : Guid.Empty,
                    NumberOfChildren = c.NumberOfChildren != null ?
                     c.NumberOfChildren.Value : default(int),
                    CreditOnHold = c.CreditOnHold != null ?
                     c.CreditOnHold.Value : default(bool),
                    Anniversary = c.Anniversary != null ?
                     c.Anniversary.Value : default(DateTime)
                   };

 foreach (var c in query_value)
 {
  System.Console.WriteLine(c.ContactId + " " + c.NumberOfChildren +
   " " + c.CreditOnHold + " " + c.Anniversary);
 }
}

Multiple projections, new data type casting to different types

The following sample shows multiple projections and how to cast values to a different type.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_projections = from c in svcContext.ContactSet
                         where c.ContactId == _contactId1
                         && c.NumberOfChildren != null &&
                         c.Anniversary.Value != null
                         select new
                         {
                          Contact = new Contact {
                           LastName = c.LastName,
                           NumberOfChildren = c.NumberOfChildren
                          },
                          NumberOfChildren = (double)c.NumberOfChildren,
                          Anniversary = c.Anniversary.Value.AddYears(1),
                         };
 foreach (var c in query_projections)
 {
  System.Console.WriteLine(c.Contact.LastName + " " +
   c.NumberOfChildren + " " + c.Anniversary);
 }
}

Use the GetAttributeValue method

The following sample shows how to use the GetAttributeValue method.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_getattrib = from c in svcContext.ContactSet
                       where c.GetAttributeValue<Guid>("contactid") != _contactId1
                       select new
                       {
                        ContactId = c.GetAttributeValue<Guid?>("contactid"),
                        NumberOfChildren = c.GetAttributeValue<int?>("numberofchildren"),
                        CreditOnHold = c.GetAttributeValue<bool?>("creditonhold"),
                        Anniversary = c.GetAttributeValue<DateTime?>("anniversary"),
                       };

 foreach (var c in query_getattrib)
 {
  System.Console.WriteLine(c.ContactId + " " + c.NumberOfChildren +
   " " + c.CreditOnHold + " " + c.Anniversary);
 }
}

Use Math methods

The following sample shows how to use various Math methods.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_math = from c in svcContext.ContactSet
                  where c.ContactId != _contactId2
                  && c.Address1_Latitude != null &&
                  c.Address1_Longitude != null
                  select new
                  {
                   Round = Math.Round(c.Address1_Latitude.Value),
                   Floor = Math.Floor(c.Address1_Latitude.Value),
                   Ceiling = Math.Ceiling(c.Address1_Latitude.Value),
                   Abs = Math.Abs(c.Address1_Latitude.Value),
                  };
 foreach (var c in query_math)
 {
  System.Console.WriteLine(c.Round + " " + c.Floor +
   " " + c.Ceiling + " " + c.Abs);
 }
}

Use Multiple Select and Where clauses

The following sample shows multiple select and where clauses using a method-based query syntax.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_multiselect = svcContext.IncidentSet
                        .Where(i => i.IncidentId != _incidentId1)
                        .Select(i => i.incident_customer_accounts)
                        .Where(a => a.AccountId != _accountId2)
                        .Select(a => a.account_primary_contact)
                        .OrderBy(c => c.FirstName)
                        .Select(c => c.ContactId);
 foreach (var c in query_multiselect)
 {
  System.Console.WriteLine(c.GetValueOrDefault());
 }
}

Use SelectMany

The following sample shows how to use the SelectMany Method.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_selectmany = svcContext.ContactSet
                        .Where(c => c.ContactId != _contactId2)
                        .SelectMany(c => c.account_primary_contact)
                        .OrderBy(a => a.Name);
 foreach (var c in query_selectmany)
 {
  System.Console.WriteLine(c.AccountId + " " + c.Name);
 }
}

Use string operations

The following sample shows how to use various String methods.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_string = from c in svcContext.ContactSet
                    where c.ContactId == _contactId2
                    select new
                    {
                     IndexOf = c.FirstName.IndexOf("contact"),
                     Insert = c.FirstName.Insert(1, "Insert"),
                     Remove = c.FirstName.Remove(1, 1),
                     Substring = c.FirstName.Substring(1, 1),
                     ToUpper = c.FirstName.ToUpper(),
                     ToLower = c.FirstName.ToLower(),
                     TrimStart = c.FirstName.TrimStart(),
                     TrimEnd = c.FirstName.TrimEnd(),
                    };

 foreach (var c in query_string)
 {
  System.Console.WriteLine(c.IndexOf + "\n" + c.Insert + "\n" +
   c.Remove + "\n" + c.Substring + "\n"
                           + c.ToUpper + "\n" + c.ToLower +
                           "\n" + c.TrimStart + " " + c.TrimEnd);
 }
}

Use two Where clauses

The following sample shows how to use two Where clauses.

C# Copy Code
using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
{
 var query_twowhere = from a in svcContext.AccountSet
                      join c in svcContext.ContactSet
                      on a.PrimaryContactId.Id equals c.ContactId
                      where c.LastName == "Smith" && c.CreditOnHold != null
                      where a.Name == "Contoso Ltd"
                      orderby a.Name
                      select a;
 foreach (var c in query_twowhere)
 {
  System.Console.WriteLine(c.AccountId + " " + c.Name);
 }
}

Use LoadProperty to retrieve related records

The following sample shows how to LoadProperty to access related records.

C# Copy Code
Contact benAndrews = svcContext.ContactSet.Where(c => c.FullName == "Ben Andrews").FirstOrDefault();
if (benAndrews != null)
{
 //benAndrews.Contact_Tasks is null until LoadProperty is used.
 svcContext.LoadProperty(benAndrews, "Contact_Tasks");
 Task benAndrewsFirstTask = benAndrews.Contact_Tasks.FirstOrDefault();
 if (benAndrewsFirstTask != null)
 {
  Console.WriteLine("Ben Andrews first task with Subject: '{0}' retrieved.", benAndrewsFirstTask.Subject);
 }
}

See Also

Other Resources

Build queries with LINQ (.NET language-integrated query)
Sample: Create a LINQ query

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a LINQ query
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\CreateALinqQuery.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create simple .NET Language-Integrated Query (LINQ) queries. The following queries are demonstrated:

  • Retrieve all accounts that the calling user has access to.
  • Retrieve all accounts owned by the user who has read access rights to the accounts and where the last name of the user is not “Cannon.”
  • Return a count of all accounts that have a county specified in their addresses.
  • Return a count of states in which we have an account. This uses the distinct keyword that counts a state only once.
  • Return contacts where the city equals “Redmond” AND the first name is “Joe” OR “John.”

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Linq;
using System.Collections.Generic;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
 /// <summary>
 /// Demonstrates how to do create basic LINQ queries against Microsoft Dynamics CRM
 /// records.</summary>
 /// <remarks>
 /// At run-time, you will be given the option to delete all the
 /// database records created by this program.</remarks>
 public class CreateALinqQuery
 {
  #region Class Level Members

  private Dictionary<Guid, String> _recordIds = new Dictionary<Guid, String>();
  private OrganizationServiceProxy _serviceProxy;
  private IOrganizationService _service;

  #endregion Class Level Members

  #region How To Sample Code
  /// <summary>
  /// This method first connects to the Organization service. Afterwards,
  /// basic LINQ queries are performed.
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>
  /// <param name="promptforDelete">When True, the user will be prompted to delete all
  /// created entities.</param>
  public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
  {
   try
   {

    // Connect to the Organization service.
    // The using statement assures that the service proxy will be properly disposed.
       using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                        serverConfig.Credentials, serverConfig.DeviceCredentials))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();
     _service = (IOrganizationService)_serviceProxy;

     CreateRequiredRecords();

     // Create the ServiceContext object that will generate
     // the IQueryable collections for LINQ calls.

     ServiceContext svcContext = new ServiceContext(_service);
     // Loop through all CRM account using the IQueryable interface
     // on the ServiceContext object
     var accounts = from a in svcContext.AccountSet
                    select new Account
                    {
                     Name = a.Name,
                     Address1_County = a.Address1_County
                    };
     System.Console.WriteLine("List all accounts in CRM");
     System.Console.WriteLine("========================");
     foreach (var a in accounts)
     {
      System.Console.WriteLine(a.Name + " " + a.Address1_County);
     }
     System.Console.WriteLine();
     System.Console.WriteLine("<End of Listing>");
     System.Console.WriteLine();
     //OUTPUT:
     //List all accounts in CRM
     //========================
     //Fourth Coffee
     //School of Fine Art Lake County
     //Tailspin Toys King County
     //Woodgrove Bank
     //Contoso, Ltd. Saint Louis County

     //<End of Listing>
     System.Console.WriteLine();

     // Retrieve all accounts owned by the user who has read access rights
     // to the accounts and where the last name of the user is not Cannon.
     var queryAccounts = from a in svcContext.AccountSet
                         join owner in svcContext.SystemUserSet
                           on a.OwnerId.Id equals owner.SystemUserId
                         where owner.LastName != "Cannon"
                         select new Account
                         {
                          Name = a.Name,
                          Address1_City = a.Address1_City
                         };
     System.Console.WriteLine("Accounts not owned by user w/ last name 'Cannon'");
     System.Console.WriteLine("================================================");
     foreach (var a in queryAccounts)
     {
      System.Console.WriteLine(a.Name + " " + a.Address1_County);
     }
     System.Console.WriteLine();
     System.Console.WriteLine("<End of Listing>");
     System.Console.WriteLine();
     //OUTPUT:
     //Accounts not owned by user w/ last name 'Cannon'
     //================================================
     //Fourth Coffee
     //School of Fine Art
     //Tailspin Toys
     //Woodgrove Bank
     //Contoso, Ltd.

     //<End of Listing>
     System.Console.WriteLine();

     // Return a count of all accounts which have a county specified
     // in their address.
     int accountsWithCounty = (from a in svcContext.AccountSet
                               where (a.Address1_County != null)
                               select new Account
                               {
                                Name = a.Name,
                                Address1_City = a.Address1_City
                               }).ToArray().Count();
     System.Console.Write("Number of accounts with a county specified: ");
     System.Console.WriteLine(accountsWithCounty);
     System.Console.WriteLine();
     //OUTPUT:
     //Number of accounts with a county specified: 3
     System.Console.WriteLine();

     // Return a count of states in which we have an account. This
     // uses the 'distinct' keyword which counts a state only one time.
     int statesWithAccounts = (from a in svcContext.AccountSet
                               where (a.Address1_StateOrProvince != null)
                               select a.Address1_StateOrProvince)
                               .Distinct().ToArray().Count();
     System.Console.Write("Number of unique states that contain accounts: ");
     System.Console.WriteLine(statesWithAccounts);
     System.Console.WriteLine();
     //OUTPUT:
     //Number of unique states that contain accounts: 3
     System.Console.WriteLine();

     // Return contacts where the city equals Redmond AND the first
     // name is Joe OR John.
     var queryContacts = from c in svcContext.ContactSet
                         where (c.Address1_City == "Redmond") &&
                               (c.FirstName.Equals("Joe") ||
                                c.FirstName.Equals("John"))
                         select new Contact
                         {
                          FirstName = c.FirstName,
                          LastName = c.LastName,
                          Address1_City = c.Address1_City
                         };
     System.Console.WriteLine("Contacts in Redmond named Joe OR John");
     System.Console.WriteLine("=====================================");
     foreach (var c in queryContacts)
     {
      System.Console.WriteLine(c.FirstName + " " +
          c.LastName + " " + c.Address1_City);
     }
     System.Console.WriteLine();
     System.Console.WriteLine("<End of Listing>");
     System.Console.WriteLine();
     //OUTPUT:
     //Contacts in Redmond named Joe OR John
     //=====================================
     //Joe  Redmond
     //John  Redmond
     //Joe  Redmond

     //<End of Listing>

     System.Console.WriteLine();

     DeleteRequiredRecords(promptforDelete);
    }

   }

   // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  /// <summary>
  /// Creates any entity records that this sample requires.
  /// </summary>
  public void CreateRequiredRecords()
  {
   // Create 5 Accounts and 5 Contacts for the LINQ samples.
   Account account = new Account
   {
    Name = "Fourth Coffee",
    Address1_StateOrProvince = "Colorado",
   };
   _recordIds.Add(_service.Create(account), Account.EntityLogicalName);
   account = new Account
   {
    Name = "School of Fine Art",
    Address1_StateOrProvince = "Illinois",
    Address1_County = "Lake County"
   };
   _recordIds.Add(_service.Create(account), Account.EntityLogicalName);
   account = new Account
   {
    Name = "Tailspin Toys",
    Address1_StateOrProvince = "Washington",
    Address1_County = "King County",
   };
   _recordIds.Add(_service.Create(account), Account.EntityLogicalName);
   account = new Account
   {
    Name = "Woodgrove Bank",
    Address1_StateOrProvince = "Washington"
   };
   _recordIds.Add(_service.Create(account), Account.EntityLogicalName);
   account = new Account
   {
    Name = "Contoso, Ltd.",
    Address1_County = "Saint Louis County"
   };
   _recordIds.Add(_service.Create(account), Account.EntityLogicalName);

   Contact contact = new Contact
   {
    FirstName = "Joe",
    Address1_City = "Redmond",
   };
   _recordIds.Add(_service.Create(contact), Contact.EntityLogicalName);
   contact = new Contact
   {
    FirstName = "John",
    Address1_City = "Redmond",
   };
   _recordIds.Add(_service.Create(contact), Contact.EntityLogicalName);
   contact = new Contact
   {
    FirstName = "John",
    Address1_City = "Cleveland",
   };
   _recordIds.Add(_service.Create(contact), Contact.EntityLogicalName);
   contact = new Contact
   {
    FirstName = "Joe",
    Address1_City = "Redmond",
   };
   _recordIds.Add(_service.Create(contact), Contact.EntityLogicalName);
   contact = new Contact
   {
    FirstName = "Jim",
    Address1_City = "Redmond",
   };
   _recordIds.Add(_service.Create(contact), Contact.EntityLogicalName);
  }

  /// <summary>
  /// Deletes any entity records that were created for this sample.
  /// <param name="prompt">Indicates whether to prompt the user
  /// to delete the records created in this sample.</param>
  /// </summary>
  public void DeleteRequiredRecords(bool prompt)
  {
   bool toBeDeleted = true;

   if (prompt)
   {
    // Ask the user if the created entities should be deleted.
    Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
    String answer = Console.ReadLine();
    if (answer.StartsWith("y") ||
        answer.StartsWith("Y") ||
        answer == String.Empty)
    {
     toBeDeleted = true;
    }
    else
    {
     toBeDeleted = false;
    }
   }

   if (toBeDeleted)
   {
    // Delete all records created in this sample.
    foreach (var record in _recordIds)
    {
     _service.Delete(record.Value, record.Key);
    }
    Console.WriteLine("Entity record(s) have been deleted.");
   }
  }

  #endregion How To Sample Code

  #region Main method

  /// <summary>
  /// Standard Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    CreateALinqQuery app = new CreateALinqQuery();
    app.Run(config, true);
   }
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
     }
    }
   }
   // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {
    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }
  }
  #endregion Main method
 }
}

See Also

Other Resources

Build queries with LINQ (.NET language-integrated query)
Sample: Complex LINQ queries
OrganizationServiceContext

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Complex LINQ queries
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. The sample can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\LINQExamples.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to use .NET Language-Integrated Query (LINQ) with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

using System.Linq;     //namespace for LINQ queries
namespace Microsoft.Crm.Sdk.Samples
{
 /// <summary>
 /// Demonstrates basic and complex LINQ queries used with Microsoft Dynamics CRM
 /// </summary>
 /// <remarks>
 /// At run-time, you will be given the option to delete all the
 /// database records created by this program.</remarks>
 public class LINQ101
 {
  #region Class Level Members
  private Guid _contactId1;
  private Guid _contactId2;
  private Guid _contactId3;
  private Guid _contactId4;
  private Guid _accountId1;
  private Guid _accountId2;
  private Guid _incidentId1;
  private Guid _incidentId2;
  private Guid _leadId;

  private OrganizationServiceProxy _serviceProxy;

  #endregion Class Level Members

  #region How To Sample Code
  /// <summary>
  /// This method first connects to the Organization service. Afterwards,
  /// a series of LINQ queries are performed.
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>
  /// <param name="promptforDelete">When True, the user will be prompted to delete all
  /// created entities.</param>
  public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
  {
   try
   {
    // Connect to the Organization service.
    // The using statement assures that the service proxy will be properly disposed.
    using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();

     CreateRequiredRecords();

     #region EarlyBoundExamples

     // *****************************************************************************************************************
     //    LNQ    Simple where clause 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Accounts using one where clause");
     System.Console.WriteLine("======================================");

     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_where1 = from a in svcContext.AccountSet
                         where a.Name.Contains("Contoso")
                         select a;
      foreach (var a in query_where1)
      {
       System.Console.WriteLine(a.Name + " " + a.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     // List of Accounts using where clause 1
     //======================================
     //Contoso Ltd Redmond
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ    Simple where clause 2
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Accounts using two where clauses");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_where2 = from a in svcContext.AccountSet
                         where a.Name.Contains("Contoso")
                         where a.Address1_City == "Redmond"
                         select a;

      foreach (var a in query_where2)
      {
       System.Console.WriteLine(a.Name + " " + a.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //     List of Accounts using where clause 2
     //======================================
     //Contoso Ltd Redmond
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ    Join and simple where clause query
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Account and Contact Info using where clause");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_where3 = from c in svcContext.ContactSet
                         join a in svcContext.AccountSet
                         on c.ContactId equals a.PrimaryContactId.Id
                         where a.Name.Contains("Contoso")
                         where c.LastName.Contains("Smith")
                         select new
                         {
                          account_name = a.Name,
                          contact_name = c.LastName
                         };

      foreach (var c in query_where3)
      {
       System.Console.WriteLine("acct: " +
        c.account_name +
        "\t\t\t" +
        "contact: " +
        c.contact_name);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Account and Contact Info using where clause
     //======================================
     //acct: Contoso Ltd                       contact: Smith
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the Distinct operator (returns only one of duplicate elements)
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using Distinct operator");
     System.Console.WriteLine("======================================");

     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_distinct = (from c in svcContext.ContactSet
                            select c.LastName).Distinct();
      foreach (var c in query_distinct)
      {
       System.Console.WriteLine(c);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //     List of Contact Info using Distinct operator
     //======================================
     //Parker
     //Smith
     //Wilcox
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ    Simple inner join 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact and Account Info Using join 1 ");
     System.Console.WriteLine("==================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_join1 = from c in svcContext.ContactSet
                        join a in svcContext.AccountSet
                       on c.ContactId equals a.PrimaryContactId.Id
                        select new
                        {
                         c.FullName,
                         c.Address1_City,
                         a.Name,
                         a.Address1_Name
                        };
      foreach (var c in query_join1)
      {
       System.Console.WriteLine("acct: " +
        c.Name +
        "\t\t\t" +
        "contact: " +
        c.FullName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact and Account Info Using join 1
     //==================================
     //acct: Contoso Ltd                       contact: Brian Smith
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ                  Multiple join 4
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact, Account, Lead Info using multiple join 4");
     System.Console.WriteLine("==================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_join4 = from a in svcContext.AccountSet
                        join c in svcContext.ContactSet
                        on a.PrimaryContactId.Id equals c.ContactId
                        join l in svcContext.LeadSet
                        on a.OriginatingLeadId.Id equals l.LeadId
                        select new
                        {
                         contact_name = c.FullName,
                         account_name = a.Name,
                         lead_name = l.FullName
                        };
      foreach (var c in query_join4)
      {
       System.Console.WriteLine(c.contact_name +
        "  " +
        c.account_name +
        "  " +
        c.lead_name);
      }
     }
     System.Console.WriteLine("==================================");
     // OUTPUT:
     //List of Contact, Account, Lead Info using multiple join 4
     //==================================
     //Brian Smith  Contoso Ltd  Diogo Andrade
     //==================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ                  Self join 5
     // *****************************************************************************************************************
     System.Console.WriteLine();
     System.Console.WriteLine("List of Account Info using self join 5");
     System.Console.WriteLine("==================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_join5 = from a in svcContext.AccountSet
                        join a2 in svcContext.AccountSet
                        on a.ParentAccountId.Id equals a2.AccountId

                        select new
                        {
                         account_name = a.Name,
                         account_city = a.Address1_City
                        };
      foreach (var c in query_join5)
      {
       System.Console.WriteLine(c.account_name + "  " + c.account_city);
      }
     }
     System.Console.WriteLine("==================================");
     // OUTPUT:
     //List of Account Info using self join 5
     //==================================
     //Contoso Ltd  Redmond
     //==================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ                  Double join 6
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using double join 6");
     System.Console.WriteLine("==================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_join6 = from c in svcContext.ContactSet
                        join a in svcContext.AccountSet
                        on c.ContactId equals a.PrimaryContactId.Id
                        join a2 in svcContext.AccountSet
                        on a.ParentAccountId.Id equals a2.AccountId
                        select new
                        {
                         contact_name = c.FullName,
                         account_name = a.Name
                        };
      foreach (var c in query_join6)
      {
       System.Console.WriteLine(c.contact_name + "  " + c.account_name);
      }
     }
     System.Console.WriteLine("==================================");
     // OUTPUT:
     //List of Contact Info using double join 6
     //==================================
     //Brian Smith  Contoso Ltd
     //==================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ                  Entity Fields join 7
     // *****************************************************************************************************************
     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using entity field join 7");
     System.Console.WriteLine("==================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var list_join = (from a in svcContext.AccountSet
                       join c in svcContext.ContactSet
                       on a.PrimaryContactId.Id equals c.ContactId
                       where a.Name == "Contoso Ltd" &&
                       a.Address1_Name == "Contoso Pharmaceuticals"
                       select a).ToList();
      foreach (var c in list_join)
      {
       System.Console.WriteLine("Account " + list_join[0].Name
           + " and it's primary contact "
           + list_join[0].PrimaryContactId.Id);
      }
     }
     System.Console.WriteLine("==================================");
     // OUTPUT:
     // Account Contoso Ltd and it's primary contact 918228af-04a1-e011-b1b7-00155dba3818
     //==================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ                  Left join 8
     //  A left join is designed to return parents with and without children from two sources.
     //   There is a correlation between parent and child, but no child may actually exist.
     // *****************************************************************************************************************
     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using left join 8");
     System.Console.WriteLine("==================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_join8 = from a in svcContext.AccountSet
                        join c in svcContext.ContactSet
                        on a.PrimaryContactId.Id equals c.ContactId
                        into gr
                        from c_joined in gr.DefaultIfEmpty()
                        select new
                        {
                         contact_name = c_joined.FullName,
                         account_name = a.Name
                        };
      foreach (var c in query_join8)
      {
       System.Console.WriteLine(c.contact_name + "  " + c.account_name);
      }
     }
     System.Console.WriteLine("==================================");
     // OUTPUT:
     //List of Contact Info using left join 8
     //==================================
     //  Coho Winery
     //Brian Smith  Contoso Ltd
     //==================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the Equals operator 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using Equals operator 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_equals1 = from c in svcContext.ContactSet
                          where c.FirstName.Equals("Colin")
                          select new
                          {
                           c.FirstName,
                           c.LastName,
                           c.Address1_City
                          };
      foreach (var c in query_equals1)
      {
       System.Console.WriteLine(c.FirstName +
        " " + c.LastName +
        " " + c.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     // List of Contact Info using Equals operator 1
     //======================================
     //Colin Wilcox Redmond
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the Equals operator 2
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using Equals operator 2");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_equals2 = from c in svcContext.ContactSet
                          where c.FamilyStatusCode.Equals(3)
                          select new
                          {
                           c.FirstName,
                           c.LastName,
                           c.Address1_City
                          };
      foreach (var c in query_equals2)
      {
       System.Console.WriteLine(c.FirstName +
        " " + c.LastName +
        " " + c.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     // List of Contact Info using Equals operator 2
     //======================================
     //Brian Smith Bellevue
     //Darren Parker Kirkland
     //Ben Smith Kirkland
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the not equals operator 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using not equals operator 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_ne1 = from c in svcContext.ContactSet
                      where c.Address1_City != "Redmond"
                      select new
                      {
                       c.FirstName,
                       c.LastName,
                       c.Address1_City
                      };
      foreach (var c in query_ne1)
      {
       System.Console.WriteLine(c.FirstName + " " +
        c.LastName + " " + c.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     // List of Contact Info using not equals operator 1
     //======================================
     //Brian Smith Bellevue
     //Darren Parker Kirkland
     //Ben Smith Kirkland
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the not equals operator 2
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using not equals operator 2");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_ne2 = from c in svcContext.ContactSet
                      where !c.FirstName.Equals("Colin")
                      select new
                      {
                       c.FirstName,
                       c.LastName,
                       c.Address1_City
                      };

      foreach (var c in query_ne2)
      {
       System.Console.WriteLine(c.FirstName + " " +
        c.LastName + " " + c.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //     List of Contact Info using not equals operator 2
     //======================================
     //Brian Smith Bellevue
     //Darren Parker Kirkland
     //Ben Smith Kirkland
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //              LINQ      Method-based LINQ query with where clause
     // *****************************************************************************************************************
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var methodResults = svcContext.ContactSet
       .Where(a => a.LastName == "Smith");
      var methodResults2 = svcContext.ContactSet
       .Where(a => a.LastName.StartsWith("Smi"));
      Console.WriteLine();
      Console.WriteLine("Method query using Lambda expression");
      Console.WriteLine("---------------------------------------");
      foreach (var a in methodResults)
      {
       Console.WriteLine("Name: " + a.FirstName + " " + a.LastName);
      }
      Console.WriteLine("---------------------------------------");
      Console.WriteLine("Method query 2 using Lambda expression");
      Console.WriteLine("---------------------------------------");
      foreach (var a in methodResults2)
      {
       Console.WriteLine("Name: " + a.Attributes["firstname"] +
        " " + a.Attributes["lastname"]);
      }
     }
     Console.WriteLine("---------------------------------------");
     // OUTPUT:
     //Method query using Lambda expression
     //---------------------------------------
     //Name: Brian Smith
     //Name: Ben Smith
     //---------------------------------------
     //Method query 2 using Lambda expression
     //---------------------------------------
     //Name: Brian Smith
     //Name: Ben Smith
     //---------------------------------------

     // *****************************************************************************************************************
     //    LNQ        Using the greater than operator 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using greater than operator 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_gt1 = from c in svcContext.ContactSet
                      where c.Anniversary > new DateTime(2010, 2, 5)
                      select new
                      {
                       c.FirstName,
                       c.LastName,
                       c.Address1_City
                      };

      foreach (var c in query_gt1)
      {
       System.Console.WriteLine(c.FirstName + " " +
        c.LastName + " " + c.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using greater than operator 1
     //======================================
     //Colin Wilcox Redmond
     //Brian Smith Bellevue
     //Darren Parker Kirkland
     //Ben Smith Kirkland
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the greater than operator 2
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using greater than operator 2");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_gt2 = from c in svcContext.ContactSet
                      where c.CreditLimit.Value > 20000
                      select new
                      {
                       c.FirstName,
                       c.LastName,
                       c.Address1_City
                      };
      foreach (var c in query_gt2)
      {
       System.Console.WriteLine(c.FirstName + " " +
        c.LastName + " " + c.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //     List of Contact Info using greater than operator 2
     //======================================
     //Brian Smith Bellevue
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the ge and le operators 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the ge and le operators 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_gele1 = from c in svcContext.ContactSet
                        where c.CreditLimit.Value >= 200 &&
                        c.CreditLimit.Value <= 400
                        select new
                        {
                         c.FirstName,
                         c.LastName
                        };
      foreach (var c in query_gele1)
      {
       System.Console.WriteLine(c.FirstName + " " + c.LastName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //     List of Contact Info using the ge and le operators 1
     //======================================
     //Colin Wilcox
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the contains operator 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the contains operator 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_contains1 = from c in svcContext.ContactSet
                            where c.Description.Contains("Alpine")
                            select new
                            {
                             c.FirstName,
                             c.LastName
                            };
      foreach (var c in query_contains1)
      {
       System.Console.WriteLine(c.FirstName + " " + c.LastName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using the contains operator 1
     //======================================
     //Colin Wilcox
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the negated contains operator 2
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the negated contains operator 2");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_contains2 = from c in svcContext.ContactSet
                            where !c.Description.Contains("Coho")
                            select new
                            {
                             c.FirstName,
                             c.LastName
                            };
      foreach (var c in query_contains2)
      {
       System.Console.WriteLine(c.FirstName + " " + c.LastName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using the negated contains operator 2
     //======================================
     //Colin Wilcox
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the StartsWith operator 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the StartsWith operator 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_startswith1 = from c in svcContext.ContactSet
                              where c.FirstName.StartsWith("Bri")
                              select new
                              {
                               c.FirstName,
                               c.LastName
                              };
      foreach (var c in query_startswith1)
      {
       System.Console.WriteLine(c.FirstName + " " + c.LastName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using the StartsWith operator 1
     //======================================
     //Brian Smith
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the endswith operator 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the EndsWith operator 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_endswith1 = from c in svcContext.ContactSet
                            where c.LastName.EndsWith("cox")
                            select new
                            {
                             c.FirstName,
                             c.LastName
                            };
      foreach (var c in query_endswith1)
      {
       System.Console.WriteLine(c.FirstName + " " + c.LastName);
      }
     }

     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using the EndsWith operator 1
     //======================================
     //Colin Wilcox
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the && and || operators 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the && and || operators 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_andor1 = from c in svcContext.ContactSet
                         where ((c.Address1_City == "Redmond" ||
                         c.Address1_City == "Bellevue") &&
                         (c.CreditLimit.Value != null &&
                         c.CreditLimit.Value >= 200))
                         select c;

      foreach (var c in query_andor1)
      {
       System.Console.WriteLine(c.LastName + ", " + c.FirstName + " " +
        c.Address1_City + " " + c.CreditLimit.Value);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     // List of Contact Info using the && and || operators 1
     //======================================
     //Wilcox, Colin Redmond 300.0000
     //Smith, Brian Bellevue 30000.0000
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the orderby operator 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the orderby operator 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_orderby1 = from c in svcContext.ContactSet
                           where !c.CreditLimit.Equals(null)
                           orderby c.CreditLimit descending
                           select new
                           {
                            limit = c.CreditLimit,
                            first = c.FirstName,
                            last = c.LastName
                           };
      foreach (var c in query_orderby1)
      {
       System.Console.WriteLine(c.limit.Value + " " +
        c.last + ", " + c.first);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using the orderby operator 1
     //======================================
     //30000.0000 Smith, Brian
     //12000.0000 Smith, Ben
     //10000.0000 Parker, Darren
     //300.0000 Wilcox, Colin
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the orderby operator 2
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the orderby operator 2");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_orderby2 = from c in svcContext.ContactSet
                           orderby c.LastName descending,
                           c.FirstName ascending
                           select new
                           {
                            first = c.FirstName,
                            last = c.LastName
                           };

      foreach (var c in query_orderby2)
      {
       System.Console.WriteLine(c.last + ", " + c.first);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using the orderby operator 2
     //======================================
     //Wilcox, Colin
     //Smith, Ben
     //Smith, Brian
     //Parker, Darren
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the First and Single operators
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("==========================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      Contact firstcontact = svcContext.ContactSet.First();

      Contact singlecontact = svcContext.ContactSet.Single(c => c.ContactId == _contactId1);
      System.Console.WriteLine(firstcontact.LastName + ", " +
       firstcontact.FirstName + " is the first contact");
      System.Console.WriteLine("==========================");
      System.Console.WriteLine(singlecontact.LastName + ", " +
       singlecontact.FirstName + " is the single contact");
     }
     System.Console.WriteLine("======================================");
     // OUTPUT:
     //==========================
     //Wilcox, Colin is the first contact
     //==========================
     //Wilcox, Colin is the single contact
     //======================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Retrieving formatted values 1
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("Retrieving formatted values 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var list_retrieve1 = from c in svcContext.ContactSet
                           where c.ContactId == _contactId1
                           select new { StatusReason = c.FormattedValues["statuscode"] };
      foreach (var c in list_retrieve1)
      {
       System.Console.WriteLine("Status: " + c.StatusReason);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //Retrieving formatted values 1
     //======================================
     //Status: Active
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the Skip and Take operators (non-paging)
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the Skip and Take operators");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {

      var query_skip = (from c in svcContext.ContactSet
                        where c.LastName != "Parker"
                        orderby c.FirstName
                        select new
                            {
                             last = c.LastName,
                             first = c.FirstName
                            }).Skip(2).Take(2);
      foreach (var c in query_skip)
      {
       System.Console.WriteLine(c.first + " " + c.last);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using the Skip and Take operators
     //======================================
     //Colin Wilcox
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the FirstOrDefault and SingleOrDefault operators
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("==========================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {

      Contact firstorcontact = svcContext.ContactSet.FirstOrDefault();

      Contact singleorcontact = svcContext.ContactSet
       .SingleOrDefault(c => c.ContactId == _contactId1);

      System.Console.WriteLine(firstorcontact.FullName +
       " is the first contact");
      System.Console.WriteLine("==========================");
      System.Console.WriteLine(singleorcontact.FullName +
       " is the single contact");
     }
     System.Console.WriteLine("======================================");
     // OUTPUT:
     //==========================
     //Colin Wilcox is the first contact
     //==========================
     //Colin Wilcox is the single contact
     //======================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using a self join with a condition on the linked entity
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using a self join with a condition on the linked entity");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_joincond = from a1 in svcContext.AccountSet
                           join a2 in svcContext.AccountSet
                           on a1.ParentAccountId.Id equals a2.AccountId
                           where a2.AccountId == _accountId1
                           select new { Account = a1, Parent = a2 };
      foreach (var a in query_joincond)
      {
       System.Console.WriteLine(a.Account.Name + " " + a.Parent.Name);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using a self join with a condition on the linked entity
     //======================================
     //Contoso Ltd Coho Winery
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using a transformation in the where clause
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using a transformation in the where clause");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_wheretrans = from c in svcContext.ContactSet
                             where c.ContactId == _contactId1 &&
                             c.Anniversary > DateTime.Parse("1/1/2010")
                             select new
                             {
                              c.FirstName,
                              c.LastName
                             };
      foreach (var c in query_wheretrans)
      {
       System.Console.WriteLine(c.FirstName + " " + c.LastName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     // List of Contact Info using a transformation in the where clause
     //======================================
     //Colin Wilcox
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using a lookup value to order by
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Account Info using a lookup value to order by");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_orderbylookup = from a in svcContext.AccountSet
                                where a.Address1_Name == "Contoso Pharmaceuticals"
                                orderby a.PrimaryContactId
                                select new
                                {
                                 a.Name,
                                 a.Address1_City
                                };
      foreach (var a in query_orderbylookup)
      {
       System.Console.WriteLine(a.Name + " " + a.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     // List of Account Info using a lookup value to order by
     //======================================
     //Contoso Ltd Redmond
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using a a picklist to order by
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using a picklist to order by");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_orderbypicklist = from c in svcContext.ContactSet
                                  where c.LastName != "Parker" &&
                                  c.AccountRoleCode != null
                                  orderby c.AccountRoleCode, c.FirstName
                                  select new
                                  {
                                   AccountRole = c.FormattedValues["accountrolecode"],
                                   c.FirstName,
                                   c.LastName
                                  };
      foreach (var c in query_orderbypicklist)
      {
       System.Console.WriteLine(c.AccountRole + " " +
        c.FirstName + " " + c.LastName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using a picklist to order by
     //======================================
     //Decision Maker Colin Wilcox
     //Employee Ben Smith
     //Employee Brian Smith
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using a paging sort 1
     //            (Multi-column sort with extra condition)
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using a paging sort 1");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_pagingsort1 = (from c in svcContext.ContactSet
                               where c.LastName != "Parker"
                               orderby c.LastName ascending,
                               c.FirstName descending
                               select new { c.FirstName, c.LastName })
                               .Skip(2).Take(2);
      foreach (var c in query_pagingsort1)
      {
       System.Console.WriteLine(c.FirstName + " " + c.LastName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //     List of Contact Info using a paging sort 1
     //======================================
     //Colin Wilcox
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using a paging sort 2
     //    (Page and sort where the column being sorted is different from the column being retrieved
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using a paging sort 2");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_pagingsort2 = (from c in svcContext.ContactSet
                               where c.LastName != "Parker"
                               orderby c.FirstName descending
                               select new { c.FirstName }).Skip(2).Take(2);
      foreach (var c in query_pagingsort2)
      {
       System.Console.WriteLine(c.FirstName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //     List of Contact Info using a paging sort 2
     //======================================
     //Ben
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using a paging sort 3
     //          (Creates only the first page)
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using a paging sort 3");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_pagingsort3 = (from c in svcContext.ContactSet
                               where c.LastName.StartsWith("W")
                               orderby c.MiddleName ascending,
                               c.FirstName descending
                               select new
                               {
                                c.FirstName,
                                c.MiddleName,
                                c.LastName
                               }).Take(10);
      foreach (var c in query_pagingsort3)
      {
       System.Console.WriteLine(c.FirstName + " " +
        c.MiddleName + " " + c.LastName);
      }
     }
     System.Console.WriteLine("=====================================");

     // OUTPUT:
     //List of Contact Info using a paging sort 3
     //======================================
     //Colin  Wilcox
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Retrieving related entity columns (for 1 to N relationships)
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact and Account Info by retrieving related entity columns");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_retrieve1 = from c in svcContext.ContactSet
                            join a in svcContext.AccountSet
                            on c.ContactId equals a.PrimaryContactId.Id
                            where c.ContactId != _contactId1
                            select new { Contact = c, Account = a };
      foreach (var c in query_retrieve1)
      {
       System.Console.WriteLine("Acct: " + c.Account.Name +
        "\t\t" + "Contact: " + c.Contact.FullName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //     List of Contact and Account Info by retrieving related entity columns
     //======================================
     //Acct: Contoso Ltd               Contact: Brian Smith
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using .Value to retrieve the value of an attribute
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using .Value to retrieve the value of an attribute");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {

      var query_value = from c in svcContext.ContactSet
                        where c.ContactId != _contactId2
                        select new
                        {
                         ContactId = c.ContactId != null ?
                          c.ContactId.Value : Guid.Empty,
                         NumberOfChildren = c.NumberOfChildren != null ?
                          c.NumberOfChildren.Value : default(int),
                         CreditOnHold = c.CreditOnHold != null ?
                          c.CreditOnHold.Value : default(bool),
                         Anniversary = c.Anniversary != null ?
                          c.Anniversary.Value : default(DateTime)
                        };

      foreach (var c in query_value)
      {
       System.Console.WriteLine(c.ContactId + " " + c.NumberOfChildren +
        " " + c.CreditOnHold + " " + c.Anniversary);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using .Value to retrieve the value of an attribute
     //======================================
     //8f8228af-04a1-e011-b1b7-00155dba3818 1 False 3/5/2010 8:00:00 AM
     //938228af-04a1-e011-b1b7-00155dba3818 2 False 10/5/2010 7:00:00 AM
     //958228af-04a1-e011-b1b7-00155dba3818 2 True 7/5/2010 7:00:00 AM
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Multiple projections, new data type casting to different types
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using multiple projections");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_projections = from c in svcContext.ContactSet
                              where c.ContactId == _contactId1
                              && c.NumberOfChildren != null &&
                              c.Anniversary.Value != null
                              select new
                              {
                               Contact = new Contact {
                                LastName = c.LastName,
                                NumberOfChildren = c.NumberOfChildren
                               },
                               NumberOfChildren = (double)c.NumberOfChildren,
                               Anniversary = c.Anniversary.Value.AddYears(1),
                              };
      foreach (var c in query_projections)
      {
       System.Console.WriteLine(c.Contact.LastName + " " +
        c.NumberOfChildren + " " + c.Anniversary);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using multiple projections
     //======================================
     //Wilcox 1 3/5/2011 8:00:00 AM
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the GetAttributeValue method
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using the GetAttributeValue method");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_getattrib = from c in svcContext.ContactSet
                            where c.GetAttributeValue<Guid>("contactid") != _contactId1
                            select new
                            {
                             ContactId = c.GetAttributeValue<Guid?>("contactid"),
                             NumberOfChildren = c.GetAttributeValue<int?>("numberofchildren"),
                             CreditOnHold = c.GetAttributeValue<bool?>("creditonhold"),
                             Anniversary = c.GetAttributeValue<DateTime?>("anniversary"),
                            };

      foreach (var c in query_getattrib)
      {
       System.Console.WriteLine(c.ContactId + " " + c.NumberOfChildren +
        " " + c.CreditOnHold + " " + c.Anniversary);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using the GetAttributeValue method
     //======================================
     //918228af-04a1-e011-b1b7-00155dba3818 2 False 4/5/2010 7:00:00 AM
     //938228af-04a1-e011-b1b7-00155dba3818 2 False 10/5/2010 7:00:00 AM
     //958228af-04a1-e011-b1b7-00155dba3818 2 True 7/5/2010 7:00:00 AM
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using math operations
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using math operations");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_math = from c in svcContext.ContactSet
                       where c.ContactId != _contactId2
                       && c.Address1_Latitude != null &&
                       c.Address1_Longitude != null
                       select new
                       {
                        Round = Math.Round(c.Address1_Latitude.Value),
                        Floor = Math.Floor(c.Address1_Latitude.Value),
                        Ceiling = Math.Ceiling(c.Address1_Latitude.Value),
                        Abs = Math.Abs(c.Address1_Latitude.Value),
                       };
      foreach (var c in query_math)
      {
       System.Console.WriteLine(c.Round + " " + c.Floor +
        " " + c.Ceiling + " " + c.Abs);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //     List of Contact Info using math operations
     //======================================
     //48 47 48 47.67417
     //48 47 48 47.61056
     //48 47 48 47.61056
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using multiple select and where clauses
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Incidents using multiple select and where clauses");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_multiselect = svcContext.IncidentSet
                             .Where(i => i.IncidentId != _incidentId1)
                             .Select(i => i.incident_customer_accounts)
                             .Where(a => a.AccountId != _accountId2)
                             .Select(a => a.account_primary_contact)
                             .OrderBy(c => c.FirstName)
                             .Select(c => c.ContactId);
      foreach (var c in query_multiselect)
      {
       System.Console.WriteLine(c.GetValueOrDefault());
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Incidents using multiple select and where clauses
     //======================================
     //918228af-04a1-e011-b1b7-00155dba3818
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using SelectMany
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Account Info using SelectMany");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_selectmany = svcContext.ContactSet
                             .Where(c => c.ContactId != _contactId2)
                             .SelectMany(c => c.account_primary_contact)
                             .OrderBy(a => a.Name);
      foreach (var c in query_selectmany)
      {
       System.Console.WriteLine(c.AccountId + " " + c.Name);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Account Info using SelectMany
     //======================================
     //9b8228af-04a1-e011-b1b7-00155dba3818 Contoso Ltd
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using String operations
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using String operations");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_string = from c in svcContext.ContactSet
                         where c.ContactId == _contactId2
                         select new
                         {
                          IndexOf = c.FirstName.IndexOf("contact"),
                          Insert = c.FirstName.Insert(1, "Insert"),
                          Remove = c.FirstName.Remove(1, 1),
                          Substring = c.FirstName.Substring(1, 1),
                          ToUpper = c.FirstName.ToUpper(),
                          ToLower = c.FirstName.ToLower(),
                          TrimStart = c.FirstName.TrimStart(),
                          TrimEnd = c.FirstName.TrimEnd(),
                         };

      foreach (var c in query_string)
      {
       System.Console.WriteLine(c.IndexOf + "\n" + c.Insert + "\n" +
        c.Remove + "\n" + c.Substring + "\n"
                                + c.ToUpper + "\n" + c.ToLower +
                                "\n" + c.TrimStart + " " + c.TrimEnd);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using String operations
     //======================================
     //-1
     //BInsertrian
     //Bian
     //r
     //BRIAN
     //brian
     //Brian Brian
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using Two Where Clauses
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Account and Contact Info using two where clauses");
     System.Console.WriteLine("======================================");
     using (ServiceContext svcContext = new ServiceContext(_serviceProxy))
     {
      var query_twowhere = from a in svcContext.AccountSet
                           join c in svcContext.ContactSet
                           on a.PrimaryContactId.Id equals c.ContactId
                           where c.LastName == "Smith" && c.CreditOnHold != null
                           where a.Name == "Contoso Ltd"
                           orderby a.Name
                           select a;
      foreach (var c in query_twowhere)
      {
       System.Console.WriteLine(c.AccountId + " " + c.Name);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Account and Contact Info using two where clauses
     //======================================
     //9b8228af-04a1-e011-b1b7-00155dba3818 Contoso Ltd
     //=====================================
     System.Console.WriteLine();

     #endregion EarlyBoundExamples

     #region LateBoundExamples

     // *****************************************************************************************************************
     //    LNQ    Using late-bound entities, simple inner join 2
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact and Account Info using late-bound entities with join 2");
     System.Console.WriteLine("==================================");
     using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
     {
      var query_join2 = from c in orgSvcContext.CreateQuery("contact")
                        join a in orgSvcContext.CreateQuery("account")
                        on c["contactid"] equals a["primarycontactid"]
                        select new
                        {
                         contact_name = c["fullname"],
                         account_name = a["name"]
                        };
      foreach (var c in query_join2)
      {
       System.Console.WriteLine(c.contact_name + "  " + c.account_name);
      }
     }
     System.Console.WriteLine("==================================");
     // OUTPUT:
     //List of Contact and Account Info using late-bound entities with join 2
     //==================================
     //Brian Smith  Contoso Ltd
     //==================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ    Alternative syntax simple inner join 3
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact and Account Info with alternative syntax join 3");
     System.Console.WriteLine("==================================");

     using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
     {
      var query_join3 = from c in orgSvcContext.CreateQuery("contact")
                        join a in orgSvcContext.CreateQuery("account")
                        on c["contactid"] equals (Guid)((EntityReference)a["primarycontactid"]).Id
                        select new
                        {
                         contact_name = c["fullname"],
                         account_name = a["name"]
                        };

      foreach (var c in query_join3)
      {
       System.Console.WriteLine(c.contact_name + "  " + c.account_name);
      }
     }
     System.Console.WriteLine("==================================");
     // OUTPUT:
     //List of Contact and Account Info with alternative syntax join 3
     //==================================
     //Brian Smith  Contoso Ltd
     //==================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ                  Late binding left join 9
     //  A left join is designed to return parents with and without children from two sources.
     //   There is a correlation between parent and child, but no child may actually exist.
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using late binding left join 9");
     System.Console.WriteLine("==================================");
     using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
     {
      var query_join9 = from a in orgSvcContext.CreateQuery("account")
                        join c in orgSvcContext.CreateQuery("contact")
                        on a["primarycontactid"] equals c["contactid"] into gr
                        from c_joined in gr.DefaultIfEmpty()
                        select new
                        {
                         account_name = a.Attributes["name"]
                        };
      foreach (var c in query_join9)
      {
       System.Console.WriteLine(c.account_name);
      }
     }
     System.Console.WriteLine("==================================");
     // OUTPUT:
     //List of Contact Info using late binding left join 9
     //==================================
     //Coho Winery
     //Contoso Ltd
     //==================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using late binding and not equals operator 3
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using late binding and not equals operator 3");
     System.Console.WriteLine("======================================");

     using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
     {
      var query_ne3 = from c in orgSvcContext.CreateQuery("contact")
                      where !c["address1_city"].Equals(null)
                      select new
                      {
                       FirstName = c["firstname"],
                       LastName = c["lastname"],
                       Address1_City = c["address1_city"]
                      };
      foreach (var c in query_ne3)
      {
       System.Console.WriteLine(c.FirstName + " " +
        c.LastName + " " + c.Address1_City);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     // List of Contact Info using late binding and not equals operator 3
     //======================================
     //Colin Wilcox Redmond
     //Brian Smith Bellevue
     //Darren Parker Kirkland
     //Ben Smith Kirkland
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using late binding with Contains operator 3
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using late binding with Contains operator 3");
     System.Console.WriteLine("======================================");
     using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
     {
      var query_contains3 = from c in orgSvcContext.CreateQuery("contact")
                            where ((string)c["description"]).Contains("Coho")
                            select new
                            {
                             firstname = c.Attributes["firstname"],
                             lastname = c.Attributes["lastname"]
                            };
      foreach (var c in query_contains3)
      {
       System.Console.WriteLine(c.firstname + " " + c.lastname);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using late binding with Contains operator 3
     //======================================
     //Brian Smith
     //Darren Parker
     //Ben Smith
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using the GetAttributeValue (late binding) method 1
     // *****************************************************************************************************************
     System.Console.WriteLine();
     System.Console.WriteLine("List of Contact Info using late binding and the GetAttributeValue method 2");
     System.Console.WriteLine("======================================");
     using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
     {

      var list_getattrib1 = (from c in orgSvcContext.CreateQuery("contact")
                             where c.GetAttributeValue<Guid?>("contactid") != _contactId1
                             select new {
                              FirstName = c.GetAttributeValue<string>("firstname"),
                              LastName = c.GetAttributeValue<string>("lastname")
                             }).ToList();
      foreach (var c in list_getattrib1)
      {
       System.Console.WriteLine(c.FirstName + " " + c.LastName);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Contact Info using late binding and the GetAttributeValue method 2
     //======================================
     //Brian Smith
     //Darren Parker
     //Ben Smith
     //=====================================
     System.Console.WriteLine();

     // *****************************************************************************************************************
     //    LNQ        Using a late binding join
     // *****************************************************************************************************************

     System.Console.WriteLine();
     System.Console.WriteLine("List of Info using a late binding join");
     System.Console.WriteLine("======================================");
     using (OrganizationServiceContext orgSvcContext = new OrganizationServiceContext(_serviceProxy))
     {
      var query_dejoin = from c in orgSvcContext.CreateQuery("contact")
                         join a in orgSvcContext.CreateQuery("account")
                         on c["contactid"] equals a["primarycontactid"]
                         join l in orgSvcContext.CreateQuery("lead")
                         on a["originatingleadid"] equals l["leadid"]
                         where (string)c["lastname"] != "Parker"
                         select new { Contact = c, Account = a, Lead = l };
      foreach (var c in query_dejoin)
      {
       System.Console.WriteLine(c.Account.Attributes["name"] + " " +
        c.Contact.Attributes["fullname"] + " " + c.Lead.Attributes["leadid"]);
      }
     }
     System.Console.WriteLine("=====================================");
     // OUTPUT:
     //List of Info using a late binding join
     //======================================
     //Contoso Ltd Brian Smith 9a8228af-04a1-e011-b1b7-00155dba3818
     //=====================================
     System.Console.WriteLine();

     #endregion LateBoundExamples
     DeleteRequiredRecords(promptforDelete);
    }
   }

   // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  /// <summary>
  /// Creates any entity records that this sample requires.
  /// </summary>
  public void CreateRequiredRecords()
  {
   Contact contact1 = new Contact
   {
    FirstName = "Colin",
    LastName = "Wilcox",
    Address1_City = "Redmond",
    Address1_StateOrProvince = "WA",
    Address1_PostalCode = "98052",
    Anniversary = new DateTime(2010, 3, 5),
    CreditLimit = new Money(300),
    Description = "Alpine Ski House",
    StatusCode = new OptionSetValue(1),
    AccountRoleCode = new OptionSetValue(1),
    NumberOfChildren = 1,
    Address1_Latitude = 47.6741667,
    Address1_Longitude = -122.1202778,
    CreditOnHold = false
   };
   _contactId1 = _serviceProxy.Create(contact1);

   Console.Write("Created a sample contact 1: {0}, ", contact1.FirstName + " " + contact1.LastName);

   Contact contact2 = new Contact
   {
    FirstName = "Brian",
    LastName = "Smith",
    Address1_City = "Bellevue",
    FamilyStatusCode = new OptionSetValue(3),
    Address1_StateOrProvince = "WA",
    Address1_PostalCode = "98008",
    Anniversary = new DateTime(2010, 4, 5),
    CreditLimit = new Money(30000),
    Description = "Coho Winery",
    StatusCode = new OptionSetValue(1),
    AccountRoleCode = new OptionSetValue(2),
    NumberOfChildren = 2,
    Address1_Latitude = 47.6105556,
    Address1_Longitude = -122.1994444,
    CreditOnHold = false
   };
   _contactId2 = _serviceProxy.Create(contact2);

   Console.Write("Created a sample contact 2: {0}, ", contact2.FirstName + " " + contact2.LastName);

   Contact contact3 = new Contact
   {
    FirstName = "Darren",
    LastName = "Parker",
    Address1_City = "Kirkland",
    FamilyStatusCode = new OptionSetValue(3),
    Address1_StateOrProvince = "WA",
    Address1_PostalCode = "98033",
    Anniversary = new DateTime(2010, 10, 5),
    CreditLimit = new Money(10000),
    Description = "Coho Winery",
    StatusCode = new OptionSetValue(1),
    AccountRoleCode = new OptionSetValue(2),
    NumberOfChildren = 2,
    Address1_Latitude = 47.6105556,
    Address1_Longitude = -122.1994444,
    CreditOnHold = false
   };
   _contactId3 = _serviceProxy.Create(contact3);

   Console.Write("Created a sample contact 3: {0}, ", contact3.FirstName + " " + contact3.LastName);

   Contact contact4 = new Contact
   {
    FirstName = "Ben",
    LastName = "Smith",
    Address1_City = "Kirkland",
    FamilyStatusCode = new OptionSetValue(3),
    Address1_StateOrProvince = "WA",
    Address1_PostalCode = "98033",
    Anniversary = new DateTime(2010, 7, 5),
    CreditLimit = new Money(12000),
    Description = "Coho Winery",
    StatusCode = new OptionSetValue(1),
    AccountRoleCode = new OptionSetValue(2),
    NumberOfChildren = 2,
    Address1_Latitude = 47.6105556,
    Address1_Longitude = -122.1994444,
    CreditOnHold = true
   };
   _contactId4 = _serviceProxy.Create(contact4);

   Console.Write("Created a sample contact 4: {0}, ", contact4.FirstName + " " + contact4.LastName);

   Incident incident1 = new Incident
   {
    Title = "Test Case 1",
    PriorityCode = new OptionSetValue(1), // 1 = High
    CaseOriginCode = new OptionSetValue(1), // 1 = Phone
    CaseTypeCode = new OptionSetValue(2), // 2 = Problem
    Description = "Description for Test Case 1.",
    FollowupBy = DateTime.Now.AddHours(3.0), // follow-up in 3 hours
    CustomerId = new EntityReference(Contact.EntityLogicalName, _contactId2)
   };

   _incidentId1 = _serviceProxy.Create(incident1);

   Console.Write("Created a sample incident 1: {0}, ", incident1.Title);

   Relationship relationship1 = new Relationship("incident_customer_contacts");
   EntityReferenceCollection relatedEntities1 = new EntityReferenceCollection();
   relatedEntities1.Add(new EntityReference(Contact.EntityLogicalName, _contactId1));
   _serviceProxy.Associate(Incident.EntityLogicalName, _incidentId1, relationship1, relatedEntities1);

   Console.Write("Added relationship between incident 1 and contact 1, ");

   Account account1 = new Account
   {
    Name = "Coho Winery",
    Address1_Name = "Coho Vineyard & Winery",
    Address1_City = "Redmond"
   };
   _accountId1 = _serviceProxy.Create(account1);

   Console.Write("Created a sample account 1: {0}, ", account1.Name);

   Incident incident2 = new Incident
   {
    Title = "Test Case 2",
    PriorityCode = new OptionSetValue(1), // 1 = High
    CaseOriginCode = new OptionSetValue(1), // 1 = Phone
    CaseTypeCode = new OptionSetValue(2), // 2 = Problem
    Description = "Description for Sample Case 2.",
    FollowupBy = DateTime.Now.AddHours(3.0), // follow-up in 3 hours
    CustomerId = new EntityReference(Contact.EntityLogicalName, _contactId1)
   };

   _incidentId2 = _serviceProxy.Create(incident2);

   Console.Write("Created a sample incident 2: {0}, ", incident2.Title);

   Relationship relationship2 = new Relationship("incident_customer_accounts");
   EntityReferenceCollection relatedEntities2 = new EntityReferenceCollection();
   relatedEntities2.Add(new EntityReference(Account.EntityLogicalName, _accountId1));
   _serviceProxy.Associate(Incident.EntityLogicalName, _incidentId2, relationship2, relatedEntities2);

   Console.Write("Added relationship between incident 2 and account 1, ");

   Lead lead = new Lead()
   {
    FirstName = "Diogo",
    LastName = "Andrade"
   };
   _leadId = _serviceProxy.Create(lead);
   Console.Write("Created a sample Lead: {0} ", lead.FirstName + " " + lead.LastName);

   Account account2 = new Account
   {
    Name = "Contoso Ltd",
    ParentAccountId = new EntityReference(Account.EntityLogicalName, _accountId1),
    Address1_Name = "Contoso Pharmaceuticals",
    Address1_City = "Redmond",
    OriginatingLeadId = new EntityReference(Lead.EntityLogicalName, _leadId)
   };
   _accountId2 = _serviceProxy.Create(account2);

   Console.Write("Created a sample account 2: {0}, ", account2.Name);

   Relationship relationship3 = new Relationship("account_primary_contact");
   EntityReferenceCollection relatedEntities3 = new EntityReferenceCollection();
   relatedEntities3.Add(new EntityReference(Account.EntityLogicalName, _accountId2));
   _serviceProxy.Associate(Contact.EntityLogicalName, _contactId2, relationship3, relatedEntities3);

   Console.WriteLine("Added relationship between account 2 and contact 2.");
  }
  /// <summary>
  /// Deletes any entity records that were created for this sample.
  /// <param name="prompt">Indicates whether to prompt the user
  /// to delete the records created in this sample.</param>
  /// </summary>
  public void DeleteRequiredRecords(bool prompt)
  {
   // The three system users that were created by this sample will continue to
   // exist on your system because system users cannot be deleted in Microsoft
   // Dynamics CRM.  They can only be enabled or disabled.

   bool toBeDeleted = true;

   if (prompt)
   {
    // Ask the user if the created entities should be deleted.
    Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
    String answer = Console.ReadLine();
    if (answer.StartsWith("y") ||
        answer.StartsWith("Y") ||
        answer == String.Empty)
    {
     toBeDeleted = true;
    }
    else
    {
     toBeDeleted = false;
    }
   }

   if (toBeDeleted)
   {
    // Delete all records created in this sample.
    _serviceProxy.Delete(Account.EntityLogicalName, _accountId2);
    _serviceProxy.Delete(Incident.EntityLogicalName, _incidentId2);
    _serviceProxy.Delete(Account.EntityLogicalName, _accountId1);
    _serviceProxy.Delete(Lead.EntityLogicalName, _leadId);
    _serviceProxy.Delete(Incident.EntityLogicalName, _incidentId1);
    _serviceProxy.Delete(Contact.EntityLogicalName, _contactId4);
    _serviceProxy.Delete(Contact.EntityLogicalName, _contactId3);
    _serviceProxy.Delete(Contact.EntityLogicalName, _contactId2);
    _serviceProxy.Delete(Contact.EntityLogicalName, _contactId1);

    Console.WriteLine("Entity record(s) have been deleted.");
   }
  }

  #endregion How To Sample Code

  #region Main method

  /// <summary>
  /// Standard Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    LINQ101 app = new LINQ101();
    app.Run(config, true);
   }
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
     }
    }
   }
   // Additonal exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {
    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }
  }
  #endregion Main method
 }
}

See Also

Other Resources

Build queries with LINQ (.NET language-integrated query)
Sample: RetrieveMultiple with condition operators using LINQ
OrganizationServiceContext

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: RetrieveMultiple with condition operators using LINQ
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\RetrieveMultipleConditionOperatorsLinq.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve multiple condition operators with .NET Language-Integrated Query (LINQ).

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Collections.Generic;
using System.Linq;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
 /// <summary>
 /// Demonstrates how to do use retrieve multiple condition operators for all
 /// query types.</summary>
 /// <remarks>
 /// At run-time, you will be given the option to delete all the
 /// database records created by this program.</remarks>
 public class RetrieveMultipleConditionOperatorsLinq
 {
  #region Class Level Members

  private Guid _accountId;
  private List<Guid> _contactIdList = new List<Guid>();
  private OrganizationServiceProxy _serviceProxy;
  private IOrganizationService _service;

  #endregion Class Level Members

  #region How To Sample Code
  /// <summary>
  /// This method first connects to the Organization service. Afterwards,
  /// basic LINQ queries are performed.
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>
  /// <param name="promptforDelete">When True, the user will be prompted to delete all
  /// created entities.</param>
  public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
  {
   try
   {

    // Connect to the Organization service.
    // The using statement assures that the service proxy will be properly disposed.
    using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();

     _service = (IOrganizationService)_serviceProxy;

     CreateRequiredRecords();

     // Create the ServiceContext object that will generate
     // the IQueryable collections for LINQ calls.
     ServiceContext svcContext =
         new ServiceContext(_service);

     #region SQL Query Translated to LINQ
     // Build the following SQL query using QueryExpression:
     //
     //		SELECT contact.fullname, contact.address1_telephone1
     //		FROM contact
     //			LEFT OUTER JOIN account
     //				ON contact.parentcustomerid = account.accountid
     //				AND
     //				account.name = 'Litware, Inc.'
     //		WHERE (contact.address1_stateorprovince = 'WA'
     //		AND
     //			contact.address1_city in ('Redmond', 'Bellevue', 'Kirkland', 'Seattle')
     //		AND
     //			contact.address1_telephone1 like '(206)%'
     //			OR
     //			contact.address1_telephone1 like '(425)%'
     //		AND
     //			contact.emailaddress1 Not NULL
     //			   )
     var contacts = (from c in svcContext.ContactSet
                     join a in svcContext.AccountSet on c.ParentCustomerId.Id equals a.AccountId
                     where (a.Name == "Litware, Inc.")
                     where (c.Address1_StateOrProvince == "WA"
                     && (c.Address1_Telephone1.StartsWith("(206)") ||
                         c.Address1_Telephone1.StartsWith("(425)"))
                     && (c.Address1_City == "Redmond" ||
                         c.Address1_City == "Bellevue" ||
                         c.Address1_City == "Kirkland" ||
                         c.Address1_City == "Seattle")
                     && (c.EMailAddress1 != null && c.EMailAddress1 != ""))
                     select new Contact
                     {
                      ContactId = c.ContactId,
                      FirstName = c.FirstName,
                      LastName = c.LastName,
                      Address1_Telephone1 = c.Address1_Telephone1
                     });

     // Display the results.
     Console.WriteLine("List all contacts matching specified parameters");
     Console.WriteLine("===============================================");
     foreach (Contact contact in contacts)
     {
      Console.WriteLine("Contact ID: {0}", contact.Id);
      Console.WriteLine("Contact Name: {0}", contact.FullName);
      Console.WriteLine("Contact Phone: {0}", contact.Address1_Telephone1);
     }
     Console.WriteLine("<End of Listing>");
     Console.WriteLine();
     #endregion

     //OUTPUT:
     //List all contacts matching specified parameters
     //===============================================
     //Contact ID: a263e139-63a3-e011-aea3-00155dba3818
     //Contact Name:
     //Contact Phone: (206)555-5555
     //Contact ID: a463e139-63a3-e011-aea3-00155dba3818
     //Contact Name:
     //Contact Phone: (425)555-5555
     //<End of Listing>

     DeleteRequiredRecords(promptforDelete);
    }

   }

   // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  /// <summary>
  /// Creates any entity records that this sample requires.
  /// </summary>
  public void CreateRequiredRecords()
  {
   // Create an account.
   Account account = new Account
   {
    Name = "Litware, Inc."
   };
   _accountId = _service.Create(account);

   // Create the 2 contacts.
   Contact contact = new Contact()
   {
    FirstName = "Ben",
    LastName = "Andrews",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Redmond",
    Address1_StateOrProvince = "WA",
    Address1_Telephone1 = "(206)555-5555",
    ParentCustomerId = new EntityReference
    {
     Id = _accountId,
     LogicalName = account.LogicalName
    }
   };
   _contactIdList.Add(_service.Create(contact));

   contact = new Contact()
   {
    FirstName = "Colin",
    LastName = "Wilcox",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Bellevue",
    Address1_StateOrProvince = "WA",
    Address1_Telephone1 = "(425)555-5555",
    ParentCustomerId = new EntityReference
    {
     Id = _accountId,
     LogicalName = account.LogicalName
    }
   };
   _contactIdList.Add(_service.Create(contact));
  }

  /// <summary>
  /// Deletes any entity records that were created for this sample.
  /// <param name="prompt">Indicates whether to prompt the user
  /// to delete the records created in this sample.</param>
  /// </summary>
  public void DeleteRequiredRecords(bool prompt)
  {
   bool toBeDeleted = true;

   if (prompt)
   {
    // Ask the user if the created entities should be deleted.
    Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
    String answer = Console.ReadLine();
    if (answer.StartsWith("y") ||
        answer.StartsWith("Y") ||
        answer == String.Empty)
    {
     toBeDeleted = true;
    }
    else
    {
     toBeDeleted = false;
    }
   }

   if (toBeDeleted)
   {
    // Delete all records created in this sample.
    foreach (Guid contactId in _contactIdList)
    {
     _service.Delete(Contact.EntityLogicalName, contactId);
    }

    _service.Delete(Account.EntityLogicalName, _accountId);

    Console.WriteLine("Entity record(s) have been deleted.");
   }
  }

  #endregion How To Sample Code

  #region Main method

  /// <summary>
  /// Standard Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    RetrieveMultipleConditionOperatorsLinq app = new RetrieveMultipleConditionOperatorsLinq();
    app.Run(config, true);
   }
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
     }
    }
   }
   // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {
    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }
  }
  #endregion Main method
 }
}

See Also

Other Resources

Build queries with LINQ (.NET language-integrated query)
Sample: More LINQ query examples
OrganizationServiceContext

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: More LINQ query examples
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. The sample can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\UseLinqQuery.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create .NET Language-Integrated Query (LINQ) queries. The following queries are demonstrated:

  • Retrieve records with Skip/Take record paging.
  • Use orderBy to order items retrieved.
  • Filter multiple entities using LINQ.
  • Build a complex query with LINQ.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
 /// <summary>
 /// Demonstrates how to make LINQ queries with the OrganizationServiceContext
 /// object and strongly-typed entities.</summary>
 /// <remarks>
 /// At run-time, you will be given the option to delete all the
 /// database records created by this program.</remarks>
 public class UseLinqQuery
 {
  #region Class Level Members

  private List<Guid> _accountIds = new List<Guid>();
  private List<Guid> _contactIds = new List<Guid>();
  private List<Guid> _leadIds = new List<Guid>();
  private List<Guid> _taskIds = new List<Guid>();
  private OrganizationServiceProxy _serviceProxy;
  private IOrganizationService _service;

  #endregion Class Level Members

  #region How To Sample Code
  /// <summary>
  /// This method first connects to the Organization service and service context.
  /// Afterwards, several LINQ query techniques are demonstrated.
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>
  /// <param name="promptForDelete">When True, the user will be prompted to delete
  /// all created entities.</param>
  public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
  {
   try
   {

    // Connect to the Organization service.
    // The using statement assures that the service proxy will be properly disposed.
    using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();

     _service = (IOrganizationService)_serviceProxy;

     CreateRequiredRecords();

     ServiceContext svcContext =
         new ServiceContext(_service);

     // Retrieve records with Skip/Take record paging. Setting a page size
     // can help you manage your Skip and Take calls, since Skip must be
     // passed a multiple of Take's parameter value.
     int pageSize = 5;

     var accountsByPage = (from a in svcContext.AccountSet
                           select new Account
                           {
                            Name = a.Name,
                           });
     System.Console.WriteLine("Skip 10 accounts, then Take 5 accounts");
     System.Console.WriteLine("======================================");
     foreach (var a in accountsByPage.Skip(2 * pageSize).Take(pageSize))
     {
      System.Console.WriteLine(a.Name);
     }
     System.Console.WriteLine();
     System.Console.WriteLine("<End of Listing>");
     System.Console.WriteLine();
     //OUTPUT:
     //Skip 10 accounts, then Take 5 accounts
     //======================================
     //Fourth Coffee 6
     //Fourth Coffee 7
     //Fourth Coffee 8
     //Fourth Coffee 9
     //Fourth Coffee 10

     //<End of Listing>

     // Use orderBy to order items retrieved.
     var orderedAccounts = from a in svcContext.AccountSet
                           orderby a.Name
                           select new Account
                           {
                            Name = a.Name,
                           };
     System.Console.WriteLine("Display accounts ordered by name");
     System.Console.WriteLine("================================");
     foreach (var a in orderedAccounts)
     {
      System.Console.WriteLine(a.Name);
     }
     System.Console.WriteLine();
     System.Console.WriteLine("<End of Listing>");
     System.Console.WriteLine();
     //OUTPUT:
     //Display accounts ordered by name
     //================================
     //A. Datum Corporation
     //Adventure Works
     //Coho Vineyard
     //Fabrikam
     //Fourth Coffee 1
     //Fourth Coffee 10
     //Fourth Coffee 2
     //Fourth Coffee 3
     //Fourth Coffee 4
     //Fourth Coffee 5
     //Fourth Coffee 6
     //Fourth Coffee 7
     //Fourth Coffee 8
     //Fourth Coffee 9
     //Humongous Insurance

     //<End of Listing>

     // Filter multiple entities using LINQ.
     var query = from c in svcContext.ContactSet
                 join a in svcContext.AccountSet
                               on c.ContactId equals a.PrimaryContactId.Id
                 where c.LastName == "Wilcox" || c.LastName == "Andrews"
                 where a.Address1_Telephone1.Contains("(206)")
                     || a.Address1_Telephone1.Contains("(425)")
                 select new
                 {
                  Contact = new Contact
                  {
                   FirstName = c.FirstName,
                   LastName = c.LastName,
                  },
                  Account = new Account
                  {
                   Address1_Telephone1 = a.Address1_Telephone1
                  }
                 };

     Console.WriteLine("Join account and contact");
     Console.WriteLine("List all records matching specified parameters");
     Console.WriteLine("Contact name: Wilcox or Andrews");
     Console.WriteLine("Account area code: 206 or 425");
     Console.WriteLine("==============================================");
     foreach (var record in query)
     {
      Console.WriteLine("Contact Name: {0} {1}",
          record.Contact.FirstName, record.Contact.LastName);
      Console.WriteLine("Account Phone: {0}",
          record.Account.Address1_Telephone1);
     }
     Console.WriteLine("<End of Listing>");
     Console.WriteLine();
     //OUTPUT:
     //Join account and contact
     //List all records matching specified parameters
     //Contact name: Wilcox or Andrews
     //Account area code: 206 or 425
     //==============================================
     //Contact Name: Ben Andrews
     //Account Phone: (206)555-5555
     //Contact Name: Ben Andrews
     //Account Phone: (425)555-5555
     //Contact Name: Colin Wilcox
     //Account Phone: (425)555-5555
     //<End of Listing>

     // Build a complex query with LINQ. This query includes multiple
     // JOINs and a complex WHERE statement.
     var complexQuery = from c in svcContext.ContactSet
                        join a in svcContext.AccountSet
                               on c.ContactId equals a.PrimaryContactId.Id
                        join l in svcContext.CreateQuery<Lead>()
                               on a.OriginatingLeadId.Id equals l.LeadId
                        where c.LastName == "Wilcox" || c.LastName == "Andrews"
                        where a.Address1_Telephone1.Contains("(206)")
                            || a.Address1_Telephone1.Contains("(425)")
                        select new
                        {
                         Contact = new Contact
                         {
                          FirstName = c.FirstName,
                          LastName = c.LastName,
                         },
                         Account = new Account
                         {
                          Address1_Telephone1 = a.Address1_Telephone1
                         },
                         Lead = new Lead
                         {
                          LeadId = l.LeadId
                         }
                        };

     Console.WriteLine("Join account, contact and lead");
     Console.WriteLine("List all records matching specified parameters");
     Console.WriteLine("Contact name: Wilcox or Andrews");
     Console.WriteLine("Account area code: 206 or 425");
     Console.WriteLine("==============================================");
     foreach (var record in complexQuery)
     {
      Console.WriteLine("Lead ID: {0}",
          record.Lead.LeadId);
      Console.WriteLine("Contact Name: {0} {1}",
          record.Contact.FirstName, record.Contact.LastName);
      Console.WriteLine("Account Phone: {0}",
          record.Account.Address1_Telephone1);
     }
     Console.WriteLine("<End of Listing>");
     Console.WriteLine();
     //OUTPUT:
     //Join account, contact and lead
     //List all records matching specified parameters
     //Contact name: Wilcox or Andrews
     //Account area code: 206 or 425
     //==============================================
     //Lead ID: 78d5df14-64a3-e011-aea3-00155dba3818
     //Contact Name: Colin Wilcox
     //Account Phone: (425)555-5555
     //<End of Listing>

     //Retrieve a related Task for a Contact
     //Shows requirement that LoadProperty must be used to access the related record.
     Contact benAndrews = svcContext.ContactSet.Where(c => c.FullName == "Ben Andrews").FirstOrDefault();
     if (benAndrews != null)
     {
      //benAndrews.Contact_Tasks is null until LoadProperty is used.
      svcContext.LoadProperty(benAndrews, "Contact_Tasks");
      Task benAndrewsFirstTask = benAndrews.Contact_Tasks.FirstOrDefault();
      if (benAndrewsFirstTask != null)
      {
       Console.WriteLine("Ben Andrews first task with Subject: '{0}' retrieved.", benAndrewsFirstTask.Subject);
      }
     }

     DeleteRequiredRecords(promptForDelete);
    }
   }

   // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  /// <summary>
  /// Creates any entity records that this sample requires.
  /// </summary>
  public void CreateRequiredRecords()
  {
   // Create 3 contacts.
   Contact contact = new Contact()
   {
    FirstName = "Ben",
    LastName = "Andrews",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Redmond",
    Address1_StateOrProvince = "WA"
   };
   Guid benAndrewsContactId = _service.Create(contact);
   _contactIds.Add(benAndrewsContactId);

   //Create a task associated with Ben Andrews
   Task task = new Task() {
    Subject = "Sample Task",
    RegardingObjectId = new EntityReference() {
     LogicalName = Contact.EntityLogicalName,
     Id = benAndrewsContactId,
     Name = contact.FullName
    }
   };
   _taskIds.Add(_service.Create(task));

   contact = new Contact()
   {
    FirstName = "Colin",
    LastName = "Wilcox",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Bellevue",
    Address1_StateOrProvince = "WA"
   };
   _contactIds.Add(_service.Create(contact));

   contact = new Contact()
   {
    FirstName = "Ben",
    LastName = "Smith",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Bellevue",
    Address1_StateOrProvince = "WA"
   };
   _contactIds.Add(_service.Create(contact));

   // Create 3 leads.
   Lead lead = new Lead()
   {
    FirstName = "Dan",
    LastName = "Wilson",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Redmond",
    Address1_StateOrProvince = "WA"
   };
   _leadIds.Add(_service.Create(lead));

   lead = new Lead()
   {
    FirstName = "Jim",
    LastName = "Wilson",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Bellevue",
    Address1_StateOrProvince = "WA"
   };
   _leadIds.Add(_service.Create(lead));

   lead = new Lead()
   {
    FirstName = "Denise",
    LastName = "Smith",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Bellevue",
    Address1_StateOrProvince = "WA"
   };
   _leadIds.Add(_service.Create(lead));

   // Create 5 customized Accounts for the LINQ samples.
   Account account = new Account
   {
    Name = "A. Datum Corporation",
    Address1_StateOrProvince = "Colorado",
    Address1_Telephone1 = "(206)555-5555",
    PrimaryContactId =
        new EntityReference(Contact.EntityLogicalName, _contactIds[0])
   };
   _accountIds.Add(_service.Create(account));

   account = new Account
   {
    Name = "Adventure Works",
    Address1_StateOrProvince = "Illinois",
    Address1_County = "Lake County",
    Address1_Telephone1 = "(206)555-5555",
    OriginatingLeadId =
        new EntityReference(Lead.EntityLogicalName, _leadIds[0])
   };
   _accountIds.Add(_service.Create(account));

   account = new Account
   {
    Name = "Coho Vineyard",
    Address1_StateOrProvince = "Washington",
    Address1_County = "King County",
    Address1_Telephone1 = "(425)555-5555",
    PrimaryContactId =
        new EntityReference(Contact.EntityLogicalName, _contactIds[1]),
    OriginatingLeadId =
        new EntityReference(Lead.EntityLogicalName, _leadIds[0])
   };
   _accountIds.Add(_service.Create(account));

   account = new Account
   {
    Name = "Fabrikam",
    Address1_StateOrProvince = "Washington",
    Address1_Telephone1 = "(425)555-5555",
    PrimaryContactId =
        new EntityReference(Contact.EntityLogicalName, _contactIds[0])
   };
   _accountIds.Add(_service.Create(account));

   account = new Account
   {
    Name = "Humongous Insurance",
    Address1_StateOrProvince = "Missouri",
    Address1_County = "Saint Louis County",
    Address1_Telephone1 = "(314)555-5555",
    PrimaryContactId =
        new EntityReference(Contact.EntityLogicalName, _contactIds[1])
   };
   _accountIds.Add(_service.Create(account));

   // Create 10 basic Account records.
   for (int i = 1; i <= 10; i++)
   {
    account = new Account
    {
     Name = "Fourth Coffee " + i,
     Address1_StateOrProvince = "California"
    };
    _accountIds.Add(_service.Create(account));
   }
  }

  /// <summary>
  /// Deletes any entity records that were created for this sample.
  /// <param name="prompt">Indicates whether to prompt the user
  /// to delete the records created in this sample.</param>
  /// </summary>
  public void DeleteRequiredRecords(bool prompt)
  {
   bool toBeDeleted = true;

   if (prompt)
   {
    // Ask the user if the created entities should be deleted.
    Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
    String answer = Console.ReadLine();
    if (answer.StartsWith("y") ||
        answer.StartsWith("Y") ||
        answer == String.Empty)
    {
     toBeDeleted = true;
    }
    else
    {
     toBeDeleted = false;
    }
   }

   if (toBeDeleted)
   {
    // Delete all records created in this sample.

    foreach (Guid taskId in _taskIds)
    {
     _service.Delete(Task.EntityLogicalName, taskId);
    }
    foreach (Guid accountId in _accountIds)
    {
     _service.Delete(Account.EntityLogicalName, accountId);
    }
    foreach (Guid contactId in _contactIds)
    {
     _service.Delete(Contact.EntityLogicalName, contactId);
    }
    foreach (Guid leadId in _leadIds)
    {
     _service.Delete(Lead.EntityLogicalName, leadId);
    }
    Console.WriteLine("Entity record(s) have been deleted.");
   }
  }

  #endregion How To Sample Code

  #region Main method

  /// <summary>
  /// Standard Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    UseLinqQuery app = new UseLinqQuery();
    app.Run(config, true);
   }
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
     }
    }
   }
   // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {
    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }
  }
  #endregion Main method
 }
}

See Also

Other Resources

Build queries with LINQ (.NET language-integrated query)
Sample: Use LINQ with late binding
OrganizationServiceContext

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Use LINQ with late binding
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. The sample can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\UseLinqWithLateBinding.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create .NET Language-Integrated Query (LINQ) queries using late-bound entities.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
 /// <summary>
 /// Demonstrates how to make LINQ queries with the OrganizationServiceContext
 /// object and the dynamic entity type.</summary>
 /// <remarks>
 /// At run-time, you will be given the option to delete all the
 /// database records created by this program.</remarks>
 public class UseLinqWithDotNetDataServicesDE
 {
  #region Class Level Members
  /// <summary>
  /// Stores the organization service proxy.
  /// </summary>
  private OrganizationServiceProxy _serviceProxy;
  // Define the IDs needed for this sample.
  private List<Guid> _accountIds = new List<Guid>();
  private List<Guid> _contactIds = new List<Guid>();
  private List<Guid> _leadIds = new List<Guid>();

  #endregion Class Level Members

  #region How To Sample Code
  /// <summary>
  /// This method first connects to the Organization service and service context.
  /// Afterwards, several LINQ query techniques are demonstrated.
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>
  /// <param name="promptforDelete">When True, the user will be prompted to delete all
  /// created entities.</param>
  public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
  {
   try
   {
    // Connect to the Organization service.
    // The using statement assures that the service proxy will be properly disposed.
    using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();

     CreateRequiredRecords();

     OrganizationServiceContext orgContext =
         new OrganizationServiceContext(_serviceProxy);

     // Retrieve records with Skip/Take record paging. Setting a page size
     // can help you manage your Skip and Take calls, since Skip must be
     // passed a multiple of Take's parameter value.
     int pageSize = 5;

     var accountsByPage = from a in orgContext.CreateQuery("account")
                          select a["name"];
     System.Console.WriteLine("Skip 10 accounts, then Take 5 accounts");
     System.Console.WriteLine("======================================");
     foreach (var name in accountsByPage.Skip(2 * pageSize).Take(pageSize))
     {
      System.Console.WriteLine(name);
     }
     System.Console.WriteLine();
     System.Console.WriteLine("<End of Listing>");
     System.Console.WriteLine();
     //OUTPUT:
     //Skip 10 accounts, then Take 5 accounts
     //======================================
     //Fourth Coffee 6
     //Fourth Coffee 7
     //Fourth Coffee 8
     //Fourth Coffee 9
     //Fourth Coffee 10

     //<End of Listing>

     // Use orderBy to order items retrieved.
     var orderedAccounts = from a in orgContext.CreateQuery("account")
                           orderby a["name"]
                           select a["name"];
     System.Console.WriteLine("Display accounts ordered by name");
     System.Console.WriteLine("================================");
     foreach (var name in orderedAccounts)
     {
      System.Console.WriteLine(name);
     }
     System.Console.WriteLine();
     System.Console.WriteLine("<End of Listing>");
     System.Console.WriteLine();
     //OUTPUT:
     //Display accounts ordered by name
     //================================
     //A. Datum Corporation
     //Adventure Works
     //Coho Vineyard
     //Fabrikam
     //Fourth Coffee 1
     //Fourth Coffee 10
     //Fourth Coffee 2
     //Fourth Coffee 3
     //Fourth Coffee 4
     //Fourth Coffee 5
     //Fourth Coffee 6
     //Fourth Coffee 7
     //Fourth Coffee 8
     //Fourth Coffee 9
     //Humongous Insurance

     //<End of Listing>

     // Filter multiple entities using LINQ.
     var query = from c in orgContext.CreateQuery("contact")
                 join a in orgContext.CreateQuery("account")
                     on c["contactid"] equals a["primarycontactid"]
                 where (String)c["lastname"] == "Wilcox" ||
                     (String)c["lastname"] == "Andrews"
                 where ((String)a["address1_telephone1"]).Contains("(206)")
                     || ((String)a["address1_telephone1"]).Contains("(425)")
                 select new
                 {
                  Contact = new
                  {
                   FirstName = c["firstname"],
                   LastName = c["lastname"]
                  },
                  Account = new
                  {
                   Address1_Telephone1 = a["address1_telephone1"]
                  }
                 };

     Console.WriteLine("Join account and contact");
     Console.WriteLine("List all records matching specified parameters");
     Console.WriteLine("Contact name: Wilcox or Andrews");
     Console.WriteLine("Account area code: 206 or 425");
     Console.WriteLine("==============================================");
     foreach (var record in query)
     {
      Console.WriteLine("Contact Name: {0} {1}",
          record.Contact.FirstName, record.Contact.LastName);
      Console.WriteLine("Account Phone: {0}",
          record.Account.Address1_Telephone1);
     }
     Console.WriteLine("<End of Listing>");
     Console.WriteLine();
     //OUTPUT:
     //Join account and contact
     //List all records matching specified parameters
     //Contact name: Wilcox or Andrews
     //Account area code: 206 or 425
     //==============================================
     //Contact Name: Ben Andrews
     //Account Phone: (206)555-5555
     //Contact Name: Ben Andrews
     //Account Phone: (425)555-5555
     //Contact Name: Colin Wilcox
     //Account Phone: (425)555-5555
     //<End of Listing>

     // Build a complex query with LINQ. This query includes multiple
     // JOINs and a complex WHERE statement.
     var complexQuery = from c in orgContext.CreateQuery("contact")
                        join a in orgContext.CreateQuery("account")
                             on c["contactid"] equals a["primarycontactid"]
                        join l in orgContext.CreateQuery("lead")
                             on a["originatingleadid"] equals l["leadid"]
                        where (String)c["lastname"] == "Wilcox" ||
                             (String)c["lastname"] == "Andrews"
                        where ((String)a["address1_telephone1"]).Contains("(206)")
                            || ((String)a["address1_telephone1"]).Contains("(425)")
                        select new
                        {
                         Contact = new
                         {
                          FirstName = c["firstname"],
                          LastName = c["lastname"]
                         },
                         Account = new
                         {
                          Address1_Telephone1 = a["address1_telephone1"]
                         },
                         Lead = new
                         {
                          LeadId = l["leadid"]
                         }
                        };

     Console.WriteLine("Join account, contact and lead");
     Console.WriteLine("List all records matching specified parameters");
     Console.WriteLine("Contact name: Wilcox or Andrews");
     Console.WriteLine("Account area code: 206 or 425");
     Console.WriteLine("==============================================");
     foreach (var record in complexQuery)
     {
      Console.WriteLine("Lead ID: {0}",
          record.Lead.LeadId);
      Console.WriteLine("Contact Name: {0} {1}",
          record.Contact.FirstName, record.Contact.LastName);
      Console.WriteLine("Account Phone: {0}",
          record.Account.Address1_Telephone1);
     }
     Console.WriteLine("<End of Listing>");
     Console.WriteLine();
     //OUTPUT:
     //Join account, contact and lead
     //List all records matching specified parameters
     //Contact name: Wilcox or Andrews
     //Account area code: 206 or 425
     //==============================================
     //Lead ID: 78d5df14-64a3-e011-aea3-00155dba3818
     //Contact Name: Colin Wilcox
     //Account Phone: (425)555-5555
     //<End of Listing>

     DeleteRequiredRecords(promptforDelete);
    }
   }

   // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  /// <summary>
  /// Creates any entity records that this sample requires.
  /// </summary>
  public void CreateRequiredRecords()
  {
   // Create 3 contacts.
   Contact contact = new Contact()
   {
    FirstName = "Ben",
    LastName = "Andrews",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Redmond",
    Address1_StateOrProvince = "WA"
   };
   _contactIds.Add(_serviceProxy.Create(contact));

   contact = new Contact()
   {
    FirstName = "Colin",
    LastName = "Wilcox",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Bellevue",
    Address1_StateOrProvince = "WA"
   };
   _contactIds.Add(_serviceProxy.Create(contact));

   contact = new Contact()
   {
    FirstName = "Ben",
    LastName = "Smith",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Bellevue",
    Address1_StateOrProvince = "WA"
   };
   _contactIds.Add(_serviceProxy.Create(contact));

   // Create 3 leads.
   Lead lead = new Lead()
   {
    FirstName = "Dan",
    LastName = "Wilson",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Redmond",
    Address1_StateOrProvince = "WA"
   };
   _leadIds.Add(_serviceProxy.Create(lead));

   lead = new Lead()
   {
    FirstName = "Jim",
    LastName = "Wilson",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Bellevue",
    Address1_StateOrProvince = "WA"
   };
   _leadIds.Add(_serviceProxy.Create(lead));

   lead = new Lead()
   {
    FirstName = "Denise",
    LastName = "Smith",
    EMailAddress1 = "sample@example.com",
    Address1_City = "Bellevue",
    Address1_StateOrProvince = "WA"
   };
   _leadIds.Add(_serviceProxy.Create(lead));

   // Create 5 customized Accounts for the LINQ samples.
   Account account = new Account
   {
    Name = "A. Datum Corporation",
    Address1_StateOrProvince = "Colorado",
    Address1_Telephone1 = "(206)555-5555",
    PrimaryContactId =
        new EntityReference(Contact.EntityLogicalName, _contactIds[0])
   };
   _accountIds.Add(_serviceProxy.Create(account));

   account = new Account
   {
    Name = "Adventure Works",
    Address1_StateOrProvince = "Illinois",
    Address1_County = "Lake County",
    Address1_Telephone1 = "(206)555-5555",
    OriginatingLeadId =
        new EntityReference(Lead.EntityLogicalName, _leadIds[0])
   };
   _accountIds.Add(_serviceProxy.Create(account));

   account = new Account
   {
    Name = "Coho Vineyard",
    Address1_StateOrProvince = "Washington",
    Address1_County = "King County",
    Address1_Telephone1 = "(425)555-5555",
    PrimaryContactId =
        new EntityReference(Contact.EntityLogicalName, _contactIds[1]),
    OriginatingLeadId =
        new EntityReference(Lead.EntityLogicalName, _leadIds[0])
   };
   _accountIds.Add(_serviceProxy.Create(account));

   account = new Account
   {
    Name = "Fabrikam",
    Address1_StateOrProvince = "Washington",
    Address1_Telephone1 = "(425)555-5555",
    PrimaryContactId =
        new EntityReference(Contact.EntityLogicalName, _contactIds[0])
   };
   _accountIds.Add(_serviceProxy.Create(account));

   account = new Account
   {
    Name = "Humongous Insurance",
    Address1_StateOrProvince = "Missouri",
    Address1_County = "Saint Louis County",
    Address1_Telephone1 = "(314)555-5555",
    PrimaryContactId =
        new EntityReference(Contact.EntityLogicalName, _contactIds[1])
   };
   _accountIds.Add(_serviceProxy.Create(account));

   // Create 10 basic Account records.
   for (int i = 1; i <= 10; i++)
   {
    account = new Account
    {
     Name = "Fourth Coffee " + i,
     Address1_StateOrProvince = "California"
    };
    _accountIds.Add(_serviceProxy.Create(account));
   }
  }

  /// <summary>
  /// Deletes any entity records that were created for this sample.
  /// <param name="prompt">Indicates whether to prompt the user
  /// to delete the records created in this sample.</param>
  /// </summary>
  public void DeleteRequiredRecords(bool prompt)
  {
   bool toBeDeleted = true;

   if (prompt)
   {
    // Ask the user if the created entities should be deleted.
    Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
    String answer = Console.ReadLine();
    if (answer.StartsWith("y") ||
        answer.StartsWith("Y") ||
        answer == String.Empty)
    {
     toBeDeleted = true;
    }
    else
    {
     toBeDeleted = false;
    }
   }

   if (toBeDeleted)
   {
    // Delete all records created in this sample.
    foreach (Guid accountId in _accountIds)
    {
     _serviceProxy.Delete(Account.EntityLogicalName, accountId);
    }
    foreach (Guid contactId in _contactIds)
    {
     _serviceProxy.Delete(Contact.EntityLogicalName, contactId);
    }
    foreach (Guid leadId in _leadIds)
    {
     _serviceProxy.Delete(Lead.EntityLogicalName, leadId);
    }
    Console.WriteLine("Entity record(s) have been deleted.");
   }
  }

  #endregion How To Sample Code

  #region Main method

  /// <summary>
  /// Standard Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    UseLinqWithDotNetDataServicesDE app = new UseLinqWithDotNetDataServicesDE();
    app.Run(config, true);
   }
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
     }
    }
   }
   // Additonal exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {
    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }
  }
  #endregion Main method
 }
}

See Also

Reference

CreateQuery

Other Resources

Build queries with LINQ (.NET language-integrated query)
OrganizationServiceContext
CreateQuery``1

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Build queries with FetchXML

FetchXML is a proprietary query language that is used in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. It’s based on a schema that describes the capabilities of the language. The FetchXML language supports similar query capabilities as query expressions. In addition, it’s used as a serialized form of query, used to save a query as a user-owned saved view in the userquery entity and as an organization-owned saved view in the savedquery entity.

A FetchXML query can be executed by using the IOrganizationService.RetrieveMultiple method. You can convert a FetchXML query to a query expression with the FetchXmlToQueryExpressionRequest message.

For information about how to use LINQPad to work with FetchXML, see this blog post: Getting FetchXML from LINQPad.

For information about a utility that you can use to convert SQL scripts to FetchXML, see SQL2FetchXML Help.

In This Section

Use FetchXML to construct a query

Use FetchXML aggregation

Page large result sets with FetchXML

Fiscal date query operators in FetchXML

Use a left outer join in FetchXML to query for records "not in"

Sample: Use aggregation in FetchXML

Sample: Use FetchXML with a paging cookie

Sample: Convert queries between Fetch and QueryExpression

Sample: Validate and execute a saved query

Related Sections

Build queries with LINQ (.NET language-integrated query)

Build queries with QueryExpression

Retrieve records for many-to-many relationships using intersect entities

FetchXML schema

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use FetchXML to construct a query

To execute a FetchXML query in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online, you must first build the XML query string. After you create the query string, use the IOrganizationService.RetrieveMultiple method to execute the query string. The privileges of the logged on user affects the set of records returned. Only records for which the logged on user has read access will be returned.

The FetchXML query string must conform to the schema definition for the FetchXML language. For more information, see FetchXML schema.

You can save a query by creating a SavedQuery record, as demonstrated in Sample: Validate and execute a saved query. Set visible on the link-entity node to false to hide the linked entity in the Advanced Find user interface. It will still participate in the execution of the query and will return the appropriate results.

Warning
Don’t retrieve all attributes in a query because of the negative effect on performance. This is particularly true if the query is used as a parameter to an update request. In an update, if all attributes are included this sets all field values, even if they are unchanged, and often triggers cascaded updates to child records.

Create the Query String

In the following example, the FetchXML statement retrieves all accounts:

Xml Copy Code
<fetch mapping='logical'>
   <entity name='account'>
      <attribute name='accountid'/>
      <attribute name='name'/>
</entity>
</fetch>

In the following example, the FetchXML statement retrieves all accounts where the last name of the owning user is not equal to Cannon:

Xml Copy Code
<fetch mapping='logical'>
   <entity name='account'>
      <attribute name='accountid'/>
      <attribute name='name'/>
      <link-entity name='systemuser' to='owninguser'>
         <filter type='and'>
            <condition attribute='lastname' operator='ne' value='Cannon' />
          </filter>
      </link-entity>
   </entity>
</fetch>

In the following example, the FetchXML statement uses count to set the maximum number of records returned from the query. In this case first 3 accounts are returned from the query,

Copy Code
<fetch mapping='logical' count='3'>  <entity name='account'>   <attribute name='name' alias='name'/>  </entity></fetch>

Execute the Query

The following code shows how to execute a FetchXML query:

C# Copy Code
// Retrieve all accounts owned by the user with read access rights to the accounts and
// where the last name of the user is not Cannon.
string fetch2 = @"
   <fetch mapping='logical'>
     <entity name='account'>
        <attribute name='accountid'/>
        <attribute name='name'/>
        <link-entity name='systemuser' to='owninguser'>
           <filter type='and'>
              <condition attribute='lastname' operator='ne' value='Cannon' />
           </filter>
        </link-entity>
     </entity>
   </fetch> ";

EntityCollection result = _serviceProxy.RetrieveMultiple(new FetchExpression(fetch2));foreach (var c in result.Entities)   {   System.Console.WriteLine(c.Attributes["name"]);   }

Query Results

When you execute a FetchXML query by using the RetrieveMultiple method, the return value is an EntityCollection that contains the results of the query. You can then iterate through the entity collection. The previous example uses the foreach loop to iterate through the result collection of the FetchXML query.

See Also

Reference

FetchXML schema

Concepts

Use FetchXML aggregation

Other Resources

Build queries with FetchXML

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use FetchXML aggregation

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online, FetchXML includes grouping and aggregation features that let you calculate sum, average min, max and count.

The following aggregate functions are supported:

  • sum
  • avg
  • min
  • max
  • count(*)
  • count(attribute name)

In This Topic

About aggregation

Avg

Count

Max

Min

Sum

Multiple aggregates

Group by

Order by

About aggregation

Only one aggregate attribute can be specified in a query and you cannot use the distinct keyword. To create an aggregate attribute, set the keyword aggregate to true, then specify a valid entity name, attribute name, and alias (variable name). You must also specify the type of aggregation you want to perform.

The following example shows a simple aggregate attribute in FetchXML.

Xml Copy Code
<fetch distinct='false' mapping='logical' aggregate='true'>
   <entity name='entity name'>
      <attribute name='attribute name' aggregate='count' alias='alias name'/>
   </entity>
</fetch>"

The result of a query with an aggregate attribute is different from the results of a standard query. The alias value is used as the tag identifier for the aggregate result.

The following example shows the format of the result of an aggregate query.

Xml Copy Code
<resultset morerecords="0"'>
   <result>
      <alias>aggregate value</alias>
   </result>
</resultset>"

The following example shows the results of a query when the alias variable is set to account_count.

Copy Code
<resultset morerecords="0"'>
   <result>
      <account_count>20</account_count>
   </result>
</resultset>"

Avg

The following example shows how to use the avgaggregate attribute.

C# Copy Code
// Fetch the average of estimatedvalue for all opportunities.  This is the equivalent of
// SELECT AVG(estimatedvalue) AS estimatedvalue_avg ... in SQL.
System.Console.WriteLine("===============================");
string estimatedvalue_avg = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg' />
    </entity>
</fetch>";

EntityCollection estimatedvalue_avg_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_avg));

foreach (var c in estimatedvalue_avg_result.Entities)
{
    decimal aggregate1 = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
    System.Console.WriteLine("Average estimated value: " + aggregate1);

}
System.Console.WriteLine("===============================");

Limitation with null values while computing average

Null values are not considered when Microsoft Dynamics CRM computes the average of data. However, zero (0) is used.

In the following example, with the following data, the average for Account 1 (two entries) is shown as 250 whereas the average for Account 2 (two entries) is shown as 125.

Topic | Potential Customer | Estimated value
Opportunity 1 | Account 1 | null
Opportunity 2 | Account 1 | 250
Opportunity 3 | Account 2 | 0
Opportunity 4 | Account 2 | 250

Count

The following example shows how to use the countaggregate attribute.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      opportunity_count   Aggregate 2
// *****************************************************************************************************************
// Fetch the count of all opportunities.  This is the equivalent of
// SELECT COUNT(*) AS opportunity_count ... in SQL.
string opportunity_count = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='name' alias='opportunity_count' aggregate='count'/>
    </entity>
</fetch>";

EntityCollection opportunity_count_result = _serviceProxy.RetrieveMultiple(new FetchExpression(opportunity_count));

foreach (var c in opportunity_count_result.Entities)
{
    Int32 aggregate2 = (Int32)((AliasedValue)c["opportunity_count"]).Value;
    System.Console.WriteLine("Count of all opportunities: " + aggregate2);

}
System.Console.WriteLine("===============================");

CountColumn

The following example shows how to use the countcolumnaggregate attribute.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      opportunity_colcount   Aggregate 3
// *****************************************************************************************************************
// Fetch the count of all opportunities.  This is the equivalent of
// SELECT COUNT(name) AS opportunity_count ... in SQL.
string opportunity_colcount = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='name' alias='opportunity_colcount' aggregate='countcolumn'/>
    </entity>
</fetch>";

EntityCollection opportunity_colcount_result = _serviceProxy.RetrieveMultiple(new FetchExpression(opportunity_colcount));

foreach (var c in opportunity_colcount_result.Entities)
{
    Int32 aggregate3 = (Int32)((AliasedValue)c["opportunity_colcount"]).Value;
    System.Console.WriteLine("Column count of all opportunities: " + aggregate3);

}
System.Console.WriteLine("===============================");

Count distinct columns

The following example shows how to use the countcolumnaggregate attribute to count distinct columns.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      opportunity_distcount   Aggregate 4
// *****************************************************************************************************************
// Fetch the count of distinct names for opportunities.  This is the equivalent of
// SELECT COUNT(DISTINCT name) AS opportunity_count ... in SQL.
string opportunity_distcount = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='name' alias='opportunity_distcount' aggregate='countcolumn' distinct='true'/>
    </entity>
</fetch>";

EntityCollection opportunity_distcount_result = _serviceProxy.RetrieveMultiple(new FetchExpression(opportunity_distcount));

foreach (var c in opportunity_distcount_result.Entities)
{
    Int32 aggregate4 = (Int32)((AliasedValue)c["opportunity_distcount"]).Value;
    System.Console.WriteLine("Distinct name count of all opportunities: " + aggregate4);

}
System.Console.WriteLine("===============================");

Max

Null values are not considered when Microsoft Dynamics CRM computes the maximum of data. However, zero (0) is used.

The following example shows how to use the maxaggregate attribute.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      estimatedvalue_max   Aggregate 5
// *****************************************************************************************************************
// Fetch the maximum estimatedvalue of all opportunities.  This is the equivalent of
// SELECT MAX(estimatedvalue) AS estimatedvalue_max ... in SQL.
string estimatedvalue_max = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='estimatedvalue' alias='estimatedvalue_max' aggregate='max' />
    </entity>
</fetch>";

EntityCollection estimatedvalue_max_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_max));

foreach (var c in estimatedvalue_max_result.Entities)
{
    decimal aggregate5 = ((Money)((AliasedValue)c["estimatedvalue_max"]).Value).Value;
    System.Console.WriteLine("Max estimated value of all opportunities: " + aggregate5);

}
System.Console.WriteLine("===============================");

Min

Null values are not considered when Microsoft Dynamics CRM computes the minimum of data. However, zero (0) is used.

The following example shows how to use the minaggregate attribute.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      estimatedvalue_min   Aggregate 6
// *****************************************************************************************************************
// Fetch the minimum estimatedvalue of all opportunities.  This is the equivalent of
// SELECT MIN(estimatedvalue) AS estimatedvalue_min ... in SQL.
string estimatedvalue_min = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='estimatedvalue' alias='estimatedvalue_min' aggregate='min' />
    </entity>
</fetch>";

EntityCollection estimatedvalue_min_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_min));

foreach (var c in estimatedvalue_min_result.Entities)
{
    decimal aggregate6 = ((Money)((AliasedValue)c["estimatedvalue_min"]).Value).Value;
    System.Console.WriteLine("Minimum estimated value of all opportunities: " + aggregate6);

}
System.Console.WriteLine("===============================");

Sum

The following example shows how to use the sumaggregate attribute.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      estimatedvalue_sum   Aggregate 7
// *****************************************************************************************************************
// Fetch the sum of estimatedvalue for all opportunities.  This is the equivalent of
// SELECT SUM(estimatedvalue) AS estimatedvalue_sum ... in SQL.
string estimatedvalue_sum = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum' />
    </entity>
</fetch>";

EntityCollection estimatedvalue_sum_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_sum));

foreach (var c in estimatedvalue_sum_result.Entities)
{
    decimal aggregate7 = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
    System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate7);

}
System.Console.WriteLine("===============================");

Multiple aggregates

The following example shows how to use multiple aggregate attributes to set a minimum and maximum.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      estimatedvalue_avg, estimatedvalue_sum   Aggregate 8
// *****************************************************************************************************************
// Fetch multiple aggregate values within a single query.
string estimatedvalue_avg2 = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
    </entity>
</fetch>";

EntityCollection estimatedvalue_avg2_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_avg2));

foreach (var c in estimatedvalue_avg2_result.Entities)
{
    Int32 aggregate8a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
    System.Console.WriteLine("Count of all opportunities: " + aggregate8a);
    decimal aggregate8b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
    System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate8b);
    decimal aggregate8c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
    System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate8c);

}
System.Console.WriteLine("===============================");

Group by

The following example shows how to use multiple aggregate attributes and a linked groupby attribute.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      groupby1   Aggregate 9
// *****************************************************************************************************************
// Fetch a list of users with a count of all the opportunities they own using groupby.
string groupby1 = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='name' alias='opportunity_count' aggregate='countcolumn' />
       <attribute name='ownerid' alias='ownerid' groupby='true' />
    </entity>
</fetch>";

EntityCollection groupby1_result = _serviceProxy.RetrieveMultiple(new FetchExpression(groupby1));

foreach (var c in groupby1_result.Entities)
{
    Int32 aggregate9a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
    System.Console.WriteLine("Count of all opportunities: " + aggregate9a + "\n");
    string aggregate9b = ((EntityReference)((AliasedValue)c["ownerid"]).Value).Name;
    System.Console.WriteLine("Owner: " + aggregate9b);
    string aggregate9c = (string)((AliasedValue)c["ownerid_owneridyominame"]).Value;
    System.Console.WriteLine("Owner: " + aggregate9c);
    string aggregate9d = (string)((AliasedValue)c["ownerid_owneridyominame"]).Value;
    System.Console.WriteLine("Owner: " + aggregate9d);
}
System.Console.WriteLine("===============================");

The samples below show the following group by examples:

Group by with linked entity

Group by year

Group by quarter

Group by month

Group by week

Group by day

Multiple group by

Group by with linked entity

The following example shows how to use the sumaggregate attribute to sum linked entity values.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      groupby2   Aggregate 10
// *****************************************************************************************************************
// Fetch the number of opportunities each manager's direct reports
// own using a groupby within a link-entity.
string groupby2 = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='name' alias='opportunity_count' aggregate='countcolumn' />
       <link-entity name='systemuser' from='systemuserid' to='ownerid'>
           <attribute name='parentsystemuserid' alias='managerid' groupby='true' />
       </link-entity>
    </entity>
</fetch>";

EntityCollection groupby2_result = _serviceProxy.RetrieveMultiple(new FetchExpression(groupby2));

foreach (var c in groupby2_result.Entities)
{

      int? aggregate10a = (int?)((AliasedValue)c["opportunity_count"]).Value;
      System.Console.WriteLine("Count of all opportunities: " + aggregate10a + "\n");
}
System.Console.WriteLine("===============================");

Group by year

Group By for dates uses the day, week, month, quarter, or year value. The following example shows how to use the aggregate attribute and the groupby attribute to group the results by year.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      byyear   Aggregate 11
// *****************************************************************************************************************
// Fetch aggregate information about the opportunities that have
// been won by year.
string byyear = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
       <attribute name='actualclosedate' groupby='true' dategrouping='year' alias='year' />
       <filter type='and'>
           <condition attribute='statecode' operator='eq' value='Won' />
       </filter>
    </entity>
</fetch>";

EntityCollection byyear_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byyear));

foreach (var c in byyear_result.Entities)
{
    Int32 aggregate11 = (Int32)((AliasedValue)c["year"]).Value;
    System.Console.WriteLine("Year: " + aggregate11);
    Int32 aggregate11a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
    System.Console.WriteLine("Count of all opportunities: " + aggregate11a);
    decimal aggregate11b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
    System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate11b);
    decimal aggregate11c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
    System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate11c);
    System.Console.WriteLine("----------------------------------------------");
}
System.Console.WriteLine("===============================");

Group by quarter

The following example shows how to use the aggregate attribute and the groupby attribute to group the results by quarter.

C# Copy Code
 // *****************************************************************************************************************
 //                FetchXML      byquarter   Aggregate 12
 // *****************************************************************************************************************
// Fetch aggregate information about the opportunities that have
 // been won by quarter.(returns 1-4)
 string byquarter = @"
 <fetch distinct='false' mapping='logical' aggregate='true'>
     <entity name='opportunity'>
        <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
        <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
        <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
        <attribute name='actualclosedate' groupby='true' dategrouping='quarter' alias='quarter' />
        <filter type='and'>
            <condition attribute='statecode' operator='eq' value='Won' />
        </filter>
     </entity>
 </fetch>";

 EntityCollection byquarter_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byquarter));

 foreach (var c in byquarter_result.Entities)
 {
     Int32 aggregate12 = (Int32)((AliasedValue)c["quarter"]).Value;
     System.Console.WriteLine("Quarter: " + aggregate12);
     Int32 aggregate12a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
     System.Console.WriteLine("Count of all opportunities: " + aggregate12a);
     decimal aggregate12b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
     System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate12b);
     decimal aggregate12c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
     System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate12c);
     System.Console.WriteLine("----------------------------------------------");
 }
 System.Console.WriteLine("===============================");

Group by month

The following example shows how to use the aggregate attribute and the groupby attribute to group the results by month.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      bymonth   Aggregate 13
// *****************************************************************************************************************
// Fetch aggregate information about the opportunities that have
// been won by month. (returns 1-12)
string bymonth = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
       <attribute name='actualclosedate' groupby='true' dategrouping='month' alias='month' />
       <filter type='and'>
           <condition attribute='statecode' operator='eq' value='Won' />
       </filter>
    </entity>
</fetch>";

EntityCollection bymonth_result = _serviceProxy.RetrieveMultiple(new FetchExpression(bymonth));

foreach (var c in bymonth_result.Entities)
{
    Int32 aggregate13 = (Int32)((AliasedValue)c["month"]).Value;
    System.Console.WriteLine("Month: " + aggregate13);
    Int32 aggregate13a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
    System.Console.WriteLine("Count of all opportunities: " + aggregate13a);
    decimal aggregate13b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
    System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate13b);
    decimal aggregate13c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
    System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate13c);
    System.Console.WriteLine("----------------------------------------------");
}
System.Console.WriteLine("===============================");

Group by week

The following example shows how to use the aggregate attribute and the groupby attribute to group the results by week.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      byweek   Aggregate 14
// *****************************************************************************************************************
// Fetch aggregate information about the opportunities that have
// been won by week. (Returns 1-52)
string byweek = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
       <attribute name='actualclosedate' groupby='true' dategrouping='week' alias='week' />
       <filter type='and'>
           <condition attribute='statecode' operator='eq' value='Won' />
       </filter>
    </entity>
</fetch>";

EntityCollection byweek_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byweek));

foreach (var c in byweek_result.Entities)
{
    Int32 aggregate14 = (Int32)((AliasedValue)c["week"]).Value;
    System.Console.WriteLine("Week: " + aggregate14);
    Int32 aggregate14a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
    System.Console.WriteLine("Count of all opportunities: " + aggregate14a);
    decimal aggregate14b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
    System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate14b);
    decimal aggregate14c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
    System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate14c);
    System.Console.WriteLine("----------------------------------------------");
}
System.Console.WriteLine("===============================");

Group by day

The following example shows how to use the aggregate attribute and the groupby attribute to group the results by day.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      byday   Aggregate 15
// *****************************************************************************************************************
// Fetch aggregate information about the opportunities that have
// been won by day. (Returns 1-31)
string byday = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
       <attribute name='actualclosedate' groupby='true' dategrouping='day' alias='day' />
       <filter type='and'>
           <condition attribute='statecode' operator='eq' value='Won' />
       </filter>
    </entity>
</fetch>";

EntityCollection byday_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byday));

foreach (var c in byday_result.Entities)
{
    Int32 aggregate15 = (Int32)((AliasedValue)c["day"]).Value;
    System.Console.WriteLine("Day: " + aggregate15);
    Int32 aggregate15a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
    System.Console.WriteLine("Count of all opportunities: " + aggregate15a);
    decimal aggregate15b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
    System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate15b);
    decimal aggregate15c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
    System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate15c);
    System.Console.WriteLine("----------------------------------------------");
}
System.Console.WriteLine("===============================");

Multiple group by

The following example shows how to use the aggregate attribute and multiple groupby clauses.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      byyrqtr   Aggregate 16
// *****************************************************************************************************************
// Fetch aggregate information about the opportunities that have
// been won by year and quarter.
string byyrqtr = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
       <attribute name='actualclosedate' groupby='true' dategrouping='quarter' alias='quarter' />
       <attribute name='actualclosedate' groupby='true' dategrouping='year' alias='year' />
       <filter type='and'>
           <condition attribute='statecode' operator='eq' value='Won' />
       </filter>
    </entity>
</fetch>";

EntityCollection byyrqtr_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byyrqtr));

foreach (var c in byyrqtr_result.Entities)
{
    Int32 aggregate16d = (Int32)((AliasedValue)c["year"]).Value;
    System.Console.WriteLine("Year: " + aggregate16d);
    Int32 aggregate16 = (Int32)((AliasedValue)c["quarter"]).Value;
    System.Console.WriteLine("Quarter: " + aggregate16);
    Int32 aggregate16a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
    System.Console.WriteLine("Count of all opportunities: " + aggregate16a);
    decimal aggregate16b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
    System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate16b);
    decimal aggregate16c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
    System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate16c);
    System.Console.WriteLine("----------------------------------------------");
}
System.Console.WriteLine("===============================");

Order by

The following example shows how to use the aggregate attribute and multiple orderby clauses.

C# Copy Code
// *****************************************************************************************************************
//                FetchXML      byyrqtr2   Aggregate 17
// *****************************************************************************************************************
// Specify the result order for the previous sample.  Order by year, then quarter.
string byyrqtr2 = @"
<fetch distinct='false' mapping='logical' aggregate='true'>
    <entity name='opportunity'>
       <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
       <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
       <attribute name='actualclosedate' groupby='true' dategrouping='quarter' alias='quarter' />
       <attribute name='actualclosedate' groupby='true' dategrouping='year' alias='year' />
       <order alias='year' descending='false' />
       <order alias='quarter' descending='false' />
       <filter type='and'>
           <condition attribute='statecode' operator='eq' value='Won' />
       </filter>
    </entity>
</fetch>";

EntityCollection byyrqtr2_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byyrqtr2));

foreach (var c in byyrqtr2_result.Entities)
{
    Int32 aggregate17 = (Int32)((AliasedValue)c["quarter"]).Value;
    System.Console.WriteLine("Quarter: " + aggregate17);
    Int32 aggregate17d = (Int32)((AliasedValue)c["year"]).Value;
    System.Console.WriteLine("Year: " + aggregate17d);
    Int32 aggregate17a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
    System.Console.WriteLine("Count of all opportunities: " + aggregate17a);
    decimal aggregate17b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
    System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate17b);
    decimal aggregate17c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
    System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate17c);
    System.Console.WriteLine("----------------------------------------------");
}
System.Console.WriteLine("===============================");

See Also

Reference

FetchXML schema
RetrieveMultiple

Concepts

Page large result sets with FetchXML

Other Resources

Build queries with FetchXML
RetrieveMultipleRequest
FetchExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Page large result sets with FetchXML

You can page the results of a FetchXML query by using the paging cookie. The paging cookie is a performance feature that makes paging in the application faster for very large datasets. When you query for a set of records, the result will contain a value for the paging cookie. For better performance, you can pass that value when you retrieve the next set of records. If you request nonconsecutive pages, the paging cookie value is ignored.

When you use the paging cookie with FetchXML, make sure that you use the correct encoding. The following example shows the correct encoding when using the paging cookie with FetchXML:

C# Copy Code
strQueryXML = @"
<fetch mapping='logical' paging-cookie='&lt;cookie page=&quot;1&quot;&gt;&lt;accountid last=&quot;{E062B974-7F8D-DC11-9048-0003FF27AC3B}&quot; first=&quot;{60B934EF-798D-DC11-9048-0003FF27AC3B}&quot;/&gt;&lt;/cookie&gt;' page='2' count='2'>
 <entity name='account'>
  <all-attributes/>
 </entity>
</fetch>";

FetchXML and the Paging Cookie Example

This sample shows how to use the paging cookie with a FetchXML query:

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;
using System.Text;
using System.Xml;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to use the Fetch XML method with a paging
    /// cookie to retrieve a batch of records.
    /// If you want to run this sample repeatedly, you have the option to
    /// delete all the records created at the end of execution.
    /// </summary>
    class FetchPagingWithCookie
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        // Define the IDs needed for this sample.
        public Guid _parentAccountId;
        public Guid[] _childAccountIds;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create a parent account record and subsequent 10 child account records.
        /// Retrieve batch of records using RetrieveMultiple message with paging cookie.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    _service = (IOrganizationService)_serviceProxy;

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Define the fetch attributes.
                    // Set the number of records per page to retrieve.
                    int fetchCount = 3;
                    // Initialize the page number.
                    int pageNumber = 1;
                    // Initialize the number of records.
                    int recordCount = 0;
                    // Specify the current paging cookie. For retrieving the first page,
                    // pagingCookie should be null.
                    string pagingCookie = null;

                    // Create the FetchXml string for retrieving all child accounts to a parent account.
                    // This fetch query is using 1 placeholder to specify the parent account id
                    // for filtering out required accounts. Filter query is optional.
                    // Fetch query also includes optional order criteria that, in this case, is used
                    // to order the results in ascending order on the name data column.
                    string fetchXml = string.Format(@"<fetch version='1.0'
                                                    mapping='logical'
                                                    output-format='xml-platform'>
                                                    <entity name='account'>
                                                        <attribute name='name' />
                                                        <attribute name='emailaddress1' />
                                                        <order attribute='name' descending='false'/>
                                                        <filter type='and'>
                                                            <condition attribute='parentaccountid'
                                                                operator='eq' value='{0}' uiname='' uitype='' />
                                                        </filter>
                                                    </entity>
                                                </fetch>",
                                                    _parentAccountId);

                    Console.WriteLine("#\tAccount Name\t\t\tEmail Address");

                    while (true)
                    {
                        // Build fetchXml string with the placeholders.
                        string xml = CreateXml(fetchXml, pagingCookie, pageNumber, fetchCount);

                        // Excute the fetch query and get the xml result.
                        RetrieveMultipleRequest fetchRequest1 = new RetrieveMultipleRequest
                        {
                            Query = new FetchExpression(xml)
                        };

                        EntityCollection returnCollection = ((RetrieveMultipleResponse)_service.Execute(fetchRequest1)).EntityCollection;

                        foreach (var c in returnCollection.Entities)
                        {

                            System.Console.WriteLine("{0}.\t{1}\t\t{2}", ++recordCount, c.Attributes["name"], c.Attributes["emailaddress1"] );

                        }

                        // Check for morerecords, if it returns 1.
                        if (returnCollection.MoreRecords)
                        {
                            // Increment the page number to retrieve the next page.
                            pageNumber++;
                        }
                        else
                        {
                            // If no more records in the result nodes, exit the loop.
                            break;
                        }
                    }

                    Console.WriteLine("Retrieved record data.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
            return;
        }

        public string ExtractNodeValue(XmlNode parentNode, string name)
        {
            XmlNode childNode = parentNode.SelectSingleNode(name);

            if (null == childNode)
            {
                return null;
            }
            return childNode.InnerText;
        }

        public string ExtractAttribute(XmlDocument doc, string name)
        {
            XmlAttributeCollection attrs = doc.DocumentElement.Attributes;
            XmlAttribute attr = (XmlAttribute)attrs.GetNamedItem(name);
            if (null == attr)
            {
                return null;
            }
            return attr.Value;
        }

        public string CreateXml(string xml, string cookie, int page, int count)
        {
            StringReader stringReader = new StringReader(xml);
            XmlTextReader reader = new XmlTextReader(stringReader);

            // Load document
            XmlDocument doc = new XmlDocument();
            doc.Load(reader);

            return CreateXml(doc, cookie, page, count);
        }

        public string CreateXml(XmlDocument doc, string cookie, int page, int count)
        {
            XmlAttributeCollection attrs = doc.DocumentElement.Attributes;

            if (cookie != null)
            {
                XmlAttribute pagingAttr = doc.CreateAttribute("paging-cookie");
                pagingAttr.Value = cookie;
                attrs.Append(pagingAttr);
            }

            XmlAttribute pageAttr = doc.CreateAttribute("page");
            pageAttr.Value = System.Convert.ToString(page);
            attrs.Append(pageAttr);

            XmlAttribute countAttr = doc.CreateAttribute("count");
            countAttr.Value = System.Convert.ToString(count);
            attrs.Append(countAttr);

            StringBuilder sb = new StringBuilder(1024);
            StringWriter stringWriter = new StringWriter(sb);

            XmlTextWriter writer = new XmlTextWriter(stringWriter);
            doc.WriteTo(writer);
            writer.Close();

            return sb.ToString();
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a parent account record.
        /// Create 10 child accounts to the parent account record.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Instantiate a account entity record and set its property values.
            // See the Entity Metadata topic in the SDK documentation
            // to determine which attributes must be set for each entity.
            // Create the parent account.
            Account parentAccount = new Account
            {
                Name = "Root Test Account",
                EMailAddress1 = "root@root.com"
            };

            _parentAccountId = _service.Create(parentAccount);

            // Create 10 child accounts.
            _childAccountIds = new Guid[10];
            int count = 1;
            while (true)
            {
                Account childAccount = new Account
                {
                    Name = "Child Test Account " + count.ToString(),
                    EMailAddress1 = "child" + count.ToString() + "@root.com",
                    EMailAddress2 = "same@root.com",
                    ParentAccountId = new EntityReference(Account.EntityLogicalName, _parentAccountId)
                };

                _childAccountIds[count - 1] = _service.Create(childAccount);

                // Jump out of the loop after creating 10 child accounts.
                if (count == 10)
                    break;
                // Increment the count.
                count++;
            }

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                // Remove the test parent account.
                _service.Delete(Account.EntityLogicalName, _parentAccountId);

                // Remove 10 test child accounts.
                int deleteCount = 0;
                while (deleteCount < 10)
                {
                    _service.Delete(Account.EntityLogicalName, _childAccountIds[deleteCount]);
                    ++deleteCount;
                }

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                FetchPagingWithCookie app = new FetchPagingWithCookie();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Fiscal date query operators in FetchXML
Use FetchXML to construct a query

Other Resources

Build queries with FetchXML

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Fiscal date query operators in FetchXML

A FetchXML query in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update can use special fiscal date values in queries. For example, a FetchXML query can find all orders fulfilled in the last fiscal month.

Note
The FetchXML query uses the organization’s fiscal year settings for all fiscal date queries.

Using FetchXML fiscal date conditional operators

The following example shows a FetchXML expression that finds all orders fulfilled in the last fiscal period, according to the organization’s fiscal year settings. For example, if the organization uses fiscal months, the query returns orders fulfilled in the last fiscal month. If the organization uses fiscal quarters, the query returns orders fulfilled in the last fiscal quarter. If the organization uses fiscal semesters, orders fulfilled in the last fiscal semester are returned.

Xml Copy Code
<fetch> <entity name="order">  <attribute name="name"/>  <filter type="and">   <condition attribute="datefulfilled"              operator="last-fiscal-period"/>  </filter> </entity></fetch>

The following example shows a FetchXML expression that finds all accounts created in fiscal year 2013.

Xml Copy Code
<fetch> <entity name="account">  <attribute name="name"/>  <filter type="and">   <condition attribute="createdon"              operator="in-fiscal-year"              value="2013"/>  </filter> </entity></fetch>

The following example shows a FetchXML expression that finds all opportunities with an estimated close date in the next three fiscal years, based on the organization’s fiscal year settings. The value for x is specified in the value attribute of the condition tag.

Xml Copy Code
<fetch> <entity name="opportunity">  <attribute name="name"/>  <filter type="and">   <condition attribute="estimatedclosedate"              operator="next-x-fiscal-years"              value="3"/>  </filter> </entity></fetch>

The following example shows a FetchXML expression that finds all orders fulfilled in period three of any fiscal year, according to the organization’s fiscal year settings. The fiscal period value is specified in the value attribute of the condition tag. If the organization uses fiscal months, the query returns results from month three. If the organization uses fiscal quarters, the query returns results from quarter three. If the organization uses fiscal semesters, no results are returned; there are only two semesters, and the value supplied is therefore out-of-range.

Xml Copy Code
<fetch> <entity name="order">  <attribute name="name"/>  <filter type="and">   <condition attribute="datefulfilled"              operator="in-fiscal-period"              value="3"/>  </filter> </entity></fetch>

The following example shows a FetchXML expression that finds all orders fulfilled in period three of fiscal year 2013, according to the organization’s fiscal year settings. If the organization uses fiscal months, the query returns results from month three. If the organization uses fiscal quarters, the query returns results from quarter three. If the organization uses fiscal semesters, no results are returned; there are only two semesters, and the value supplied is therefore out-of-range.

Xml Copy Code
<fetch> <entity name="order">  <attribute name="name"/>  <filter type="and">   <condition attribute="datefulfilled"              operator="in-fiscal-period-and-year">    <value>3</value>    <value>2013</value>   </condition>  </filter> </entity></fetch>

The following example shows a FetchXML aggregation expression that sums the total amount of orders fulfilled and groups the result by fiscal semester and fiscal year.

Xml Copy Code
<fetch aggregate="true"> <entity name="order">  <attribute name="totalamount"             aggregate="sum"             alias="total"/>  <attribute name="datefulfilled"             groupby="true"             dategrouping="fiscal-period"/> </entity></fetch>

See Also

Concepts

Retrieve data with queries
Use a left outer join in FetchXML to query for records "not in"

Other Resources

Build queries with FetchXML

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use a left outer join in FetchXML to query for records "not in"

You can use a left outer join in FetchXML to perform a query that filters on the join table, such as to find all contacts who did not have any campaign activities in the past two months. Another common use for this type of a query is to find records “not in” a set, such as in these cases:

  • Find all leads that have no tasks
  • Find all accounts that have no contacts
  • Find all leads that have one or more tasks

A left outer join returns each row that satisfies the join of the first input with the second input. It also returns any rows from the first input that had no matching rows in the second input. The nonmatching rows in the second input are returned as null values.

You can perform a left outer join in FetchXML by using the entityname attribute as a condition operator. The entityname attribute is valid in conditions, filters, and nested filters.

You can create a query using a left outer join programmatically and execute the query using the RetrieveMultipleRequest, and you can save the query by creating a SavedQuery record. You can open a saved query that contains a left outer join in the Advanced Find or Saved Query editors in the web application and execute and view results, but some editor functionality is disabled. Those editors will allow modifications to the query, such as to change the columns returned, but the editor does not support changing the left outer join.

Example: Find all accounts that have no leads

The following shows how to construct the query in FetchXML:

Xml Copy Code
<fetch mapping='logical'>
  <entity name='account'>
    <attribute name='name'/>
    <link-entity name='lead' from='leadid' to='originatingleadid' link-type='outer'/>
    <filter operator='and'>
      <condition entityname='lead' attribute='leadid' operator='null'/>
    </filter>
  </entity>
</fetch>

Example: Find all leads that have no tasks, using an alias

The following shows how to construct the query in FetchXML:

Xml Copy Code
<fetch version="1.0" output-format="xml-platform" mapping="logical" distinct="true">
  <entity name="lead">
    <attribute name="fullname" />
    <link-entity name="task" from="regardingobjectid" to="leadid" alias="ab" link-type="outer">
       <attribute name="regardingobjectid" />
    </link-entity>
    <filter type="and">
        <condition entityname="ab" attribute="regardingobjectid" operator="null" />
    </filter>
  </entity>
<fetch/>

This is equivalent to the following SQL:

SQL Copy Code
SELECT lead.FullName
FROM Leads as lead
LEFT OUTER JOIN Tasks as ab
ON (lead.leadId  =  ab.RegardingObjectId)
WHERE ab.RegardingObjectId is null

See Also

Concepts

Use FetchXML to construct a query

Other Resources

Build queries with FetchXML
Sample: Use aggregation in FetchXML
Sample: Validate and execute a saved query

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Use aggregation in FetchXML
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\FetchAggregationAndGroupBy.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve aggregate record data using FetchXML.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Linq;
using System.Threading;
using System.Xml.Linq;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to fetch aggregate record data grouped by attributes.
    /// If you want to run this sample repeatedly, you have the option to
    /// Optionally delete all the records created at the end of execution.
    /// </summary>
    public class FetchAggregationAndGroupBy
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        // Define the IDs needed for this sample.
        public Guid _accountId;
        public Guid[] _setupOpportunitiyIds;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create an account record.
        /// Create 3 opportunity records associate to the account record.
        /// Mark all 3 opportunity records as won.
        /// Fetch aggregate record data grouped by attributes.
        /// Optionally delete all the records created at the end of execution.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();
                    _service = (IOrganizationService)_serviceProxy;

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // *****************************************************************************************************************
                    //                FetchXML      estimatedvalue_avg    Aggregate 1
                    // *****************************************************************************************************************
                    // Fetch the average of estimatedvalue for all opportunities.  This is the equivalent of
                    // SELECT AVG(estimatedvalue) AS estimatedvalue_avg ... in SQL.
                    System.Console.WriteLine("===============================");
                    string estimatedvalue_avg = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg' />
                        </entity>
                    </fetch>";

                    EntityCollection estimatedvalue_avg_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_avg));

                    foreach (var c in estimatedvalue_avg_result.Entities)
                    {
                        decimal aggregate1 = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
                        System.Console.WriteLine("Average estimated value: " + aggregate1);

                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      opportunity_count   Aggregate 2
                    // *****************************************************************************************************************
                    // Fetch the count of all opportunities.  This is the equivalent of
                    // SELECT COUNT(*) AS opportunity_count ... in SQL.
                    string opportunity_count = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='name' alias='opportunity_count' aggregate='count'/>
                        </entity>
                    </fetch>";

                    EntityCollection opportunity_count_result = _serviceProxy.RetrieveMultiple(new FetchExpression(opportunity_count));

                    foreach (var c in opportunity_count_result.Entities)
                    {
                        Int32 aggregate2 = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate2);

                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      opportunity_colcount   Aggregate 3
                    // *****************************************************************************************************************
                    // Fetch the count of all opportunities.  This is the equivalent of
                    // SELECT COUNT(name) AS opportunity_count ... in SQL.
                    string opportunity_colcount = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='name' alias='opportunity_colcount' aggregate='countcolumn'/>
                        </entity>
                    </fetch>";

                    EntityCollection opportunity_colcount_result = _serviceProxy.RetrieveMultiple(new FetchExpression(opportunity_colcount));

                    foreach (var c in opportunity_colcount_result.Entities)
                    {
                        Int32 aggregate3 = (Int32)((AliasedValue)c["opportunity_colcount"]).Value;
                        System.Console.WriteLine("Column count of all opportunities: " + aggregate3);

                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      opportunity_distcount   Aggregate 4
                    // *****************************************************************************************************************
                    // Fetch the count of distinct names for opportunities.  This is the equivalent of
                    // SELECT COUNT(DISTINCT name) AS opportunity_count ... in SQL.
                    string opportunity_distcount = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='name' alias='opportunity_distcount' aggregate='countcolumn' distinct='true'/>
                        </entity>
                    </fetch>";

                    EntityCollection opportunity_distcount_result = _serviceProxy.RetrieveMultiple(new FetchExpression(opportunity_distcount));

                    foreach (var c in opportunity_distcount_result.Entities)
                    {
                        Int32 aggregate4 = (Int32)((AliasedValue)c["opportunity_distcount"]).Value;
                        System.Console.WriteLine("Distinct name count of all opportunities: " + aggregate4);

                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      estimatedvalue_max   Aggregate 5
                    // *****************************************************************************************************************
                    // Fetch the maximum estimatedvalue of all opportunities.  This is the equivalent of
                    // SELECT MAX(estimatedvalue) AS estimatedvalue_max ... in SQL.
                    string estimatedvalue_max = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='estimatedvalue' alias='estimatedvalue_max' aggregate='max' />
                        </entity>
                    </fetch>";

                    EntityCollection estimatedvalue_max_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_max));

                    foreach (var c in estimatedvalue_max_result.Entities)
                    {
                        decimal aggregate5 = ((Money)((AliasedValue)c["estimatedvalue_max"]).Value).Value;
                        System.Console.WriteLine("Max estimated value of all opportunities: " + aggregate5);

                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      estimatedvalue_min   Aggregate 6
                    // *****************************************************************************************************************
                    // Fetch the minimum estimatedvalue of all opportunities.  This is the equivalent of
                    // SELECT MIN(estimatedvalue) AS estimatedvalue_min ... in SQL.
                    string estimatedvalue_min = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='estimatedvalue' alias='estimatedvalue_min' aggregate='min' />
                        </entity>
                    </fetch>";

                    EntityCollection estimatedvalue_min_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_min));

                    foreach (var c in estimatedvalue_min_result.Entities)
                    {
                        decimal aggregate6 = ((Money)((AliasedValue)c["estimatedvalue_min"]).Value).Value;
                        System.Console.WriteLine("Minimum estimated value of all opportunities: " + aggregate6);

                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      estimatedvalue_sum   Aggregate 7
                    // *****************************************************************************************************************
                    // Fetch the sum of estimatedvalue for all opportunities.  This is the equivalent of
                    // SELECT SUM(estimatedvalue) AS estimatedvalue_sum ... in SQL.
                    string estimatedvalue_sum = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum' />
                        </entity>
                    </fetch>";

                    EntityCollection estimatedvalue_sum_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_sum));

                    foreach (var c in estimatedvalue_sum_result.Entities)
                    {
                        decimal aggregate7 = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
                        System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate7);

                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      estimatedvalue_avg, estimatedvalue_sum   Aggregate 8
                    // *****************************************************************************************************************
                    // Fetch multiple aggregate values within a single query.
                    string estimatedvalue_avg2 = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
                        </entity>
                    </fetch>";

                    EntityCollection estimatedvalue_avg2_result = _serviceProxy.RetrieveMultiple(new FetchExpression(estimatedvalue_avg2));

                    foreach (var c in estimatedvalue_avg2_result.Entities)
                    {
                        Int32 aggregate8a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate8a);
                        decimal aggregate8b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
                        System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate8b);
                        decimal aggregate8c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
                        System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate8c);

                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      groupby1   Aggregate 9
                    // *****************************************************************************************************************
                    // Fetch a list of users with a count of all the opportunities they own using groupby.
                    string groupby1 = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='name' alias='opportunity_count' aggregate='countcolumn' />
                           <attribute name='ownerid' alias='ownerid' groupby='true' />
                        </entity>
                    </fetch>";

                    EntityCollection groupby1_result = _serviceProxy.RetrieveMultiple(new FetchExpression(groupby1));

                    foreach (var c in groupby1_result.Entities)
                    {
                        Int32 aggregate9a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate9a + "\n");
                        string aggregate9b = ((EntityReference)((AliasedValue)c["ownerid"]).Value).Name;
                        System.Console.WriteLine("Owner: " + aggregate9b);
                        string aggregate9c = (string)((AliasedValue)c["ownerid_owneridyominame"]).Value;
                        System.Console.WriteLine("Owner: " + aggregate9c);
                        string aggregate9d = (string)((AliasedValue)c["ownerid_owneridyominame"]).Value;
                        System.Console.WriteLine("Owner: " + aggregate9d);
                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      groupby2   Aggregate 10
                    // *****************************************************************************************************************
                    // Fetch the number of opportunities each manager's direct reports
                    // own using a groupby within a link-entity.
                    string groupby2 = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='name' alias='opportunity_count' aggregate='countcolumn' />
                           <link-entity name='systemuser' from='systemuserid' to='ownerid'>
                               <attribute name='parentsystemuserid' alias='managerid' groupby='true' />
                           </link-entity>
                        </entity>
                    </fetch>";

                    EntityCollection groupby2_result = _serviceProxy.RetrieveMultiple(new FetchExpression(groupby2));

                    foreach (var c in groupby2_result.Entities)
                    {

                          int? aggregate10a = (int?)((AliasedValue)c["opportunity_count"]).Value;
                          System.Console.WriteLine("Count of all opportunities: " + aggregate10a + "\n");
                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      byyear   Aggregate 11
                    // *****************************************************************************************************************
                    // Fetch aggregate information about the opportunities that have
                    // been won by year.
                    string byyear = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
                           <attribute name='actualclosedate' groupby='true' dategrouping='year' alias='year' />
                           <filter type='and'>
                               <condition attribute='statecode' operator='eq' value='Won' />
                           </filter>
                        </entity>
                    </fetch>";

                    EntityCollection byyear_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byyear));

                    foreach (var c in byyear_result.Entities)
                    {
                        Int32 aggregate11 = (Int32)((AliasedValue)c["year"]).Value;
                        System.Console.WriteLine("Year: " + aggregate11);
                        Int32 aggregate11a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate11a);
                        decimal aggregate11b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
                        System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate11b);
                        decimal aggregate11c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
                        System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate11c);
                        System.Console.WriteLine("----------------------------------------------");
                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      byquarter   Aggregate 12
                    // *****************************************************************************************************************
                   // Fetch aggregate information about the opportunities that have
                    // been won by quarter.(returns 1-4)
                    string byquarter = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
                           <attribute name='actualclosedate' groupby='true' dategrouping='quarter' alias='quarter' />
                           <filter type='and'>
                               <condition attribute='statecode' operator='eq' value='Won' />
                           </filter>
                        </entity>
                    </fetch>";

                    EntityCollection byquarter_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byquarter));

                    foreach (var c in byquarter_result.Entities)
                    {
                        Int32 aggregate12 = (Int32)((AliasedValue)c["quarter"]).Value;
                        System.Console.WriteLine("Quarter: " + aggregate12);
                        Int32 aggregate12a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate12a);
                        decimal aggregate12b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
                        System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate12b);
                        decimal aggregate12c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
                        System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate12c);
                        System.Console.WriteLine("----------------------------------------------");
                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      bymonth   Aggregate 13
                    // *****************************************************************************************************************
                    // Fetch aggregate information about the opportunities that have
                    // been won by month. (returns 1-12)
                    string bymonth = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
                           <attribute name='actualclosedate' groupby='true' dategrouping='month' alias='month' />
                           <filter type='and'>
                               <condition attribute='statecode' operator='eq' value='Won' />
                           </filter>
                        </entity>
                    </fetch>";

                    EntityCollection bymonth_result = _serviceProxy.RetrieveMultiple(new FetchExpression(bymonth));

                    foreach (var c in bymonth_result.Entities)
                    {
                        Int32 aggregate13 = (Int32)((AliasedValue)c["month"]).Value;
                        System.Console.WriteLine("Month: " + aggregate13);
                        Int32 aggregate13a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate13a);
                        decimal aggregate13b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
                        System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate13b);
                        decimal aggregate13c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
                        System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate13c);
                        System.Console.WriteLine("----------------------------------------------");
                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      byweek   Aggregate 14
                    // *****************************************************************************************************************
                    // Fetch aggregate information about the opportunities that have
                    // been won by week. (Returns 1-52)
                    string byweek = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
                           <attribute name='actualclosedate' groupby='true' dategrouping='week' alias='week' />
                           <filter type='and'>
                               <condition attribute='statecode' operator='eq' value='Won' />
                           </filter>
                        </entity>
                    </fetch>";

                    EntityCollection byweek_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byweek));

                    foreach (var c in byweek_result.Entities)
                    {
                        Int32 aggregate14 = (Int32)((AliasedValue)c["week"]).Value;
                        System.Console.WriteLine("Week: " + aggregate14);
                        Int32 aggregate14a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate14a);
                        decimal aggregate14b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
                        System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate14b);
                        decimal aggregate14c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
                        System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate14c);
                        System.Console.WriteLine("----------------------------------------------");
                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      byday   Aggregate 15
                    // *****************************************************************************************************************
                    // Fetch aggregate information about the opportunities that have
                    // been won by day. (Returns 1-31)
                    string byday = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
                           <attribute name='actualclosedate' groupby='true' dategrouping='day' alias='day' />
                           <filter type='and'>
                               <condition attribute='statecode' operator='eq' value='Won' />
                           </filter>
                        </entity>
                    </fetch>";

                    EntityCollection byday_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byday));

                    foreach (var c in byday_result.Entities)
                    {
                        Int32 aggregate15 = (Int32)((AliasedValue)c["day"]).Value;
                        System.Console.WriteLine("Day: " + aggregate15);
                        Int32 aggregate15a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate15a);
                        decimal aggregate15b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
                        System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate15b);
                        decimal aggregate15c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
                        System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate15c);
                        System.Console.WriteLine("----------------------------------------------");
                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      byyrqtr   Aggregate 16
                    // *****************************************************************************************************************
                    // Fetch aggregate information about the opportunities that have
                    // been won by year and quarter.
                    string byyrqtr = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
                           <attribute name='actualclosedate' groupby='true' dategrouping='quarter' alias='quarter' />
                           <attribute name='actualclosedate' groupby='true' dategrouping='year' alias='year' />
                           <filter type='and'>
                               <condition attribute='statecode' operator='eq' value='Won' />
                           </filter>
                        </entity>
                    </fetch>";

                    EntityCollection byyrqtr_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byyrqtr));

                    foreach (var c in byyrqtr_result.Entities)
                    {
                        Int32 aggregate16d = (Int32)((AliasedValue)c["year"]).Value;
                        System.Console.WriteLine("Year: " + aggregate16d);
                        Int32 aggregate16 = (Int32)((AliasedValue)c["quarter"]).Value;
                        System.Console.WriteLine("Quarter: " + aggregate16);
                        Int32 aggregate16a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate16a);
                        decimal aggregate16b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
                        System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate16b);
                        decimal aggregate16c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
                        System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate16c);
                        System.Console.WriteLine("----------------------------------------------");
                    }
                    System.Console.WriteLine("===============================");
                    // *****************************************************************************************************************
                    //                FetchXML      byyrqtr2   Aggregate 17
                    // *****************************************************************************************************************
                    // Specify the result order for the previous sample.  Order by year, then quarter.
                    string byyrqtr2 = @"
                    <fetch distinct='false' mapping='logical' aggregate='true'>
                        <entity name='opportunity'>
                           <attribute name='opportunityid' alias='opportunity_count' aggregate='count'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_sum' aggregate='sum'/>
                           <attribute name='estimatedvalue' alias='estimatedvalue_avg' aggregate='avg'/>
                           <attribute name='actualclosedate' groupby='true' dategrouping='quarter' alias='quarter' />
                           <attribute name='actualclosedate' groupby='true' dategrouping='year' alias='year' />
                           <order alias='year' descending='false' />
                           <order alias='quarter' descending='false' />
                           <filter type='and'>
                               <condition attribute='statecode' operator='eq' value='Won' />
                           </filter>
                        </entity>
                    </fetch>";

                    EntityCollection byyrqtr2_result = _serviceProxy.RetrieveMultiple(new FetchExpression(byyrqtr2));

                    foreach (var c in byyrqtr2_result.Entities)
                    {
                        Int32 aggregate17 = (Int32)((AliasedValue)c["quarter"]).Value;
                        System.Console.WriteLine("Quarter: " + aggregate17);
                        Int32 aggregate17d = (Int32)((AliasedValue)c["year"]).Value;
                        System.Console.WriteLine("Year: " + aggregate17d);
                        Int32 aggregate17a = (Int32)((AliasedValue)c["opportunity_count"]).Value;
                        System.Console.WriteLine("Count of all opportunities: " + aggregate17a);
                        decimal aggregate17b = ((Money)((AliasedValue)c["estimatedvalue_sum"]).Value).Value;
                        System.Console.WriteLine("Sum of estimated value of all opportunities: " + aggregate17b);
                        decimal aggregate17c = ((Money)((AliasedValue)c["estimatedvalue_avg"]).Value).Value;
                        System.Console.WriteLine("Average of estimated value of all opportunities: " + aggregate17c);
                        System.Console.WriteLine("----------------------------------------------");
                    }
                    System.Console.WriteLine("===============================");

                    Console.WriteLine("Retrieved aggregate record data.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
            return;
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a sample account record.
        /// Create 3 opportunity records associate to the account record.
        /// Mark all 3 opportunity records as won.
        /// </summary>
        public void CreateRequiredRecords()
        {

            var OpportunityStatusCodes = new
            {
                Won = 3
            };

            // Instantiate a account entity record and set its property values.
            // See the Entity Metadata topic in the SDK documentation
            // to determine which attributes must be set for each entity.
            Account setupAccount = new Account
            {
                Name = "Example Account"
            };

            _accountId = _service.Create(setupAccount);

            Console.WriteLine("Created {0}.", setupAccount.Name);

            EntityReference setupCustomer = new EntityReference
            {
                LogicalName = Account.EntityLogicalName,
                Id = _accountId
            };

            // Create 3 sample opportunities.
            // Instantiate opportunity entity records and set there property values.
            // See the Entity Metadata topic in the SDK documentation
            // to determine which attributes must be set for each entity.
            Opportunity[] setupOpportunities = new[]
                {
                    new Opportunity
                    {
                        Name = "Sample Opp 1",
                        EstimatedValue = new Money {Value = 120000.00m},
                        CustomerId = setupCustomer,
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp With Duplicate Name",
                        EstimatedValue = new Money { Value = 240000.00m},
                        CustomerId = setupCustomer,
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp With Duplicate Name",
                        EstimatedValue = new Money{ Value = 360000.00m},
                        CustomerId = setupCustomer,
                    },
                };

            _setupOpportunitiyIds = (from opp in setupOpportunities
                                           select _service.Create(opp)).ToArray();

            // "Win" each of the opportunities
            foreach (Guid oppId in _setupOpportunitiyIds)
            {
                WinOpportunityRequest winRequest = new WinOpportunityRequest
                {
                    OpportunityClose = new OpportunityClose
                    {
                        OpportunityId = new EntityReference
                        {
                            LogicalName = "opportunity",
                            Id = oppId
                        },

                        // Mark these entities as won in the year 2008 to
                        // have some testable results.
                        ActualEnd = new DateTime(2009, 11, 1, 12, 0, 0)
                    },
                    Status = new OptionSetValue(OpportunityStatusCodes.Won)
                };
                _service.Execute(winRequest);
            }

            Console.WriteLine("Created {0} sample opportunity records and updated as won for this sample.", _setupOpportunitiyIds.Length);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                foreach (Guid oppId in _setupOpportunitiyIds)
                {
                    _service.Delete("opportunity", oppId);
                }

                _service.Delete("account", _accountId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                FetchAggregationAndGroupBy app = new FetchAggregationAndGroupBy();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Reference

RetrieveMultiple

Concepts

Use FetchXML aggregation

Other Resources

Helper code: ServerConnection class
Build queries with FetchXML
Sample: Use FetchXML with a paging cookie
IOrganizationService
FetchExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Use FetchXML with a paging cookie
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\FetchPagingWithCookie.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Example

This sample shows how to use the paging cookie in a FetchXML query to retrieve successive pages of query results. It uses the IOrganizationService. RetrieveMultiple method.

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;
using System.Text;
using System.Xml;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to use the Fetch XML method with a paging
    /// cookie to retrieve a batch of records.
    /// If you want to run this sample repeatedly, you have the option to
    /// delete all the records created at the end of execution.
    /// </summary>
    class FetchPagingWithCookie
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        // Define the IDs needed for this sample.
        public Guid _parentAccountId;
        public Guid[] _childAccountIds;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create a parent account record and subsequent 10 child account records.
        /// Retrieve batch of records using RetrieveMultiple message with paging cookie.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    _service = (IOrganizationService)_serviceProxy;

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Define the fetch attributes.
                    // Set the number of records per page to retrieve.
                    int fetchCount = 3;
                    // Initialize the page number.
                    int pageNumber = 1;
                    // Initialize the number of records.
                    int recordCount = 0;
                    // Specify the current paging cookie. For retrieving the first page,
                    // pagingCookie should be null.
                    string pagingCookie = null;

                    // Create the FetchXml string for retrieving all child accounts to a parent account.
                    // This fetch query is using 1 placeholder to specify the parent account id
                    // for filtering out required accounts. Filter query is optional.
                    // Fetch query also includes optional order criteria that, in this case, is used
                    // to order the results in ascending order on the name data column.
                    string fetchXml = string.Format(@"<fetch version='1.0'
                                                    mapping='logical'
                                                    output-format='xml-platform'>
                                                    <entity name='account'>
                                                        <attribute name='name' />
                                                        <attribute name='emailaddress1' />
                                                        <order attribute='name' descending='false'/>
                                                        <filter type='and'>
                                                            <condition attribute='parentaccountid'
                                                                operator='eq' value='{0}' uiname='' uitype='' />
                                                        </filter>
                                                    </entity>
                                                </fetch>",
                                                    _parentAccountId);

                    Console.WriteLine("#\tAccount Name\t\t\tEmail Address");

                    while (true)
                    {
                        // Build fetchXml string with the placeholders.
                        string xml = CreateXml(fetchXml, pagingCookie, pageNumber, fetchCount);

                        // Excute the fetch query and get the xml result.
                        RetrieveMultipleRequest fetchRequest1 = new RetrieveMultipleRequest
                        {
                            Query = new FetchExpression(xml)
                        };

                        EntityCollection returnCollection = ((RetrieveMultipleResponse)_service.Execute(fetchRequest1)).EntityCollection;

                        foreach (var c in returnCollection.Entities)
                        {

                            System.Console.WriteLine("{0}.\t{1}\t\t{2}", ++recordCount, c.Attributes["name"], c.Attributes["emailaddress1"] );

                        }

                        // Check for morerecords, if it returns 1.
                        if (returnCollection.MoreRecords)
                        {
                            // Increment the page number to retrieve the next page.
                            pageNumber++;
                        }
                        else
                        {
                            // If no more records in the result nodes, exit the loop.
                            break;
                        }
                    }

                    Console.WriteLine("Retrieved record data.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
            return;
        }

        public string ExtractNodeValue(XmlNode parentNode, string name)
        {
            XmlNode childNode = parentNode.SelectSingleNode(name);

            if (null == childNode)
            {
                return null;
            }
            return childNode.InnerText;
        }

        public string ExtractAttribute(XmlDocument doc, string name)
        {
            XmlAttributeCollection attrs = doc.DocumentElement.Attributes;
            XmlAttribute attr = (XmlAttribute)attrs.GetNamedItem(name);
            if (null == attr)
            {
                return null;
            }
            return attr.Value;
        }

        public string CreateXml(string xml, string cookie, int page, int count)
        {
            StringReader stringReader = new StringReader(xml);
            XmlTextReader reader = new XmlTextReader(stringReader);

            // Load document
            XmlDocument doc = new XmlDocument();
            doc.Load(reader);

            return CreateXml(doc, cookie, page, count);
        }

        public string CreateXml(XmlDocument doc, string cookie, int page, int count)
        {
            XmlAttributeCollection attrs = doc.DocumentElement.Attributes;

            if (cookie != null)
            {
                XmlAttribute pagingAttr = doc.CreateAttribute("paging-cookie");
                pagingAttr.Value = cookie;
                attrs.Append(pagingAttr);
            }

            XmlAttribute pageAttr = doc.CreateAttribute("page");
            pageAttr.Value = System.Convert.ToString(page);
            attrs.Append(pageAttr);

            XmlAttribute countAttr = doc.CreateAttribute("count");
            countAttr.Value = System.Convert.ToString(count);
            attrs.Append(countAttr);

            StringBuilder sb = new StringBuilder(1024);
            StringWriter stringWriter = new StringWriter(sb);

            XmlTextWriter writer = new XmlTextWriter(stringWriter);
            doc.WriteTo(writer);
            writer.Close();

            return sb.ToString();
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a parent account record.
        /// Create 10 child accounts to the parent account record.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Instantiate a account entity record and set its property values.
            // See the Entity Metadata topic in the SDK documentation
            // to determine which attributes must be set for each entity.
            // Create the parent account.
            Account parentAccount = new Account
            {
                Name = "Root Test Account",
                EMailAddress1 = "root@root.com"
            };

            _parentAccountId = _service.Create(parentAccount);

            // Create 10 child accounts.
            _childAccountIds = new Guid[10];
            int count = 1;
            while (true)
            {
                Account childAccount = new Account
                {
                    Name = "Child Test Account " + count.ToString(),
                    EMailAddress1 = "child" + count.ToString() + "@root.com",
                    EMailAddress2 = "same@root.com",
                    ParentAccountId = new EntityReference(Account.EntityLogicalName, _parentAccountId)
                };

                _childAccountIds[count - 1] = _service.Create(childAccount);

                // Jump out of the loop after creating 10 child accounts.
                if (count == 10)
                    break;
                // Increment the count.
                count++;
            }

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                // Remove the test parent account.
                _service.Delete(Account.EntityLogicalName, _parentAccountId);

                // Remove 10 test child accounts.
                int deleteCount = 0;
                while (deleteCount < 10)
                {
                    _service.Delete(Account.EntityLogicalName, _childAccountIds[deleteCount]);
                    ++deleteCount;
                }

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                FetchPagingWithCookie app = new FetchPagingWithCookie();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Reference

RetrieveMultiple

Concepts

Use FetchXML aggregation
Use FetchXML to construct a query

Other Resources

Build queries with FetchXML
Sample: Convert queries between Fetch and QueryExpression
Helper code: ServerConnection class
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Convert queries between Fetch and QueryExpression
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\FetchXmlAndQueryExpressionQueryConversion.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to convert queries between FetchXML and Query Expression.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    public class FetchXmlAndQueryExpressionQueryConversion
    {

        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private Guid _accountId;
        private readonly List<Guid> _contactIdList = new List<Guid>();
        private readonly List<Guid> _opportunityIdList = new List<Guid>();
        #endregion

        #region How To Sample Code
        public void Run(ServerConnection.Configuration serverConfig,
            bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();
                CreateRequiredRecords();
                DoQueryExpressionToFetchXmlConversion();
                DoFetchXmlToQueryExpressionConversion();
                DeleteRequiredRecords(promptforDelete);
            }
        }

        private void DoQueryExpressionToFetchXmlConversion()
        {
            // Build a query expression that we will turn into FetchXML.
            var queryExpression = new QueryExpression()
            {
                Distinct = false,
                EntityName = Contact.EntityLogicalName,
                ColumnSet = new ColumnSet("fullname", "address1_telephone1"),
                LinkEntities =
                    {
                        new LinkEntity
                        {
                            JoinOperator = JoinOperator.LeftOuter,
                            LinkFromAttributeName = "parentcustomerid",
                            LinkFromEntityName = Contact.EntityLogicalName,
                            LinkToAttributeName = "accountid",
                            LinkToEntityName = Account.EntityLogicalName,
                            LinkCriteria =
                            {
                                Conditions =
                                {
                                    new ConditionExpression("name", ConditionOperator.Equal, "Litware, Inc.")
                                }
                            }
                        }
                    },
                Criteria =
                {
                    Filters =
                        {
                            new FilterExpression
                            {
                                FilterOperator = LogicalOperator.And,
                                Conditions =
                                {
                                    new ConditionExpression("address1_stateorprovince", ConditionOperator.Equal, "WA"),
                                    new ConditionExpression("address1_city", ConditionOperator.In, new String[] {"Redmond", "Bellevue" , "Kirkland", "Seattle"}),
                                    new ConditionExpression("createdon", ConditionOperator.LastXDays, 30),
                                    new ConditionExpression("emailaddress1", ConditionOperator.NotNull)
                                },
                            },
                            new FilterExpression
                            {
                                FilterOperator = LogicalOperator.Or,
                                Conditions =
                                {
                                    new ConditionExpression("address1_telephone1", ConditionOperator.Like, "(206)%"),
                                    new ConditionExpression("address1_telephone1", ConditionOperator.Like, "(425)%")
                                }
                            }
                        }
                }
            };

            // Run the query as a query expression.
            EntityCollection queryExpressionResult =
                _serviceProxy.RetrieveMultiple(queryExpression);
            Console.WriteLine("Output for query as QueryExpression:");
            DisplayContactQueryResults(queryExpressionResult);

            // Convert the query expression to FetchXML.
            var conversionRequest = new QueryExpressionToFetchXmlRequest
            {
                Query = queryExpression
            };
            var conversionResponse =
                (QueryExpressionToFetchXmlResponse)_serviceProxy.Execute(conversionRequest);

            // Use the converted query to make a retrieve multiple request to Microsoft Dynamics CRM.
            String fetchXml = conversionResponse.FetchXml;
            var fetchQuery = new FetchExpression(fetchXml);
            EntityCollection result = _serviceProxy.RetrieveMultiple(fetchQuery);

            // Display the results.
            Console.WriteLine("\nOutput for query after conversion to FetchXML:");
            DisplayContactQueryResults(result);

        }

        private static void DisplayContactQueryResults(EntityCollection result)
        {
            Console.WriteLine("List all contacts matching specified parameters");
            Console.WriteLine("===============================================");
            foreach (Entity entity in result.Entities)
            {
                var contact = entity.ToEntity<Contact>();
                Console.WriteLine("Contact ID: {0}", contact.Id);
                Console.WriteLine("Contact Name: {0}", contact.FullName);
                Console.WriteLine("Contact Phone: {0}", contact.Address1_Telephone1);
            }
            Console.WriteLine("<End of Listing>");
            Console.WriteLine();
        }

        private void DoFetchXmlToQueryExpressionConversion()
        {
            // Create a Fetch query that we will convert into a query expression.
            var fetchXml =
                @"<fetch mapping='logical' version='1.0'>
                    <entity name='opportunity'>
                        <attribute name='name' />
                        <filter>
                            <condition attribute='estimatedclosedate' operator='next-x-fiscal-years' value='3' />
                        </filter>
                        <link-entity name='account' from='accountid' to='customerid'>
                            <link-entity name='contact' from='parentcustomerid' to='accountid'>
                                <attribute name='fullname' />
                                <filter>
                                    <condition attribute='address1_city' operator='eq' value='Bellevue' />
                                    <condition attribute='address1_stateorprovince' operator='eq' value='WA' />
                                </filter>
                            </link-entity>
                        </link-entity>
                    </entity>
                </fetch>";

            // Run the query with the FetchXML.
            var fetchExpression = new FetchExpression(fetchXml);
            EntityCollection fetchResult =
                _serviceProxy.RetrieveMultiple(fetchExpression);
            Console.WriteLine("\nOutput for query as FetchXML:");
            DisplayOpportunityQueryResults(fetchResult);

            // Convert the FetchXML into a query expression.
            var conversionRequest = new FetchXmlToQueryExpressionRequest
            {
                FetchXml = fetchXml
            };

            var conversionResponse =
                (FetchXmlToQueryExpressionResponse)_serviceProxy.Execute(conversionRequest);

            // Use the newly converted query expression to make a retrieve multiple
            // request to Microsoft Dynamics CRM.
            QueryExpression queryExpression = conversionResponse.Query;

            EntityCollection result = _serviceProxy.RetrieveMultiple(queryExpression);

            // Display the results.
            Console.WriteLine("\nOutput for query after conversion to QueryExpression:");
            DisplayOpportunityQueryResults(result);

        }

        private static void DisplayOpportunityQueryResults(EntityCollection result)
        {
            Console.WriteLine("List all opportunities matching specified parameters.");
            Console.WriteLine("===========================================================================");
            foreach (Entity entity in result.Entities)
            {
                var opportunity = entity.ToEntity<Opportunity>();
                Console.WriteLine("Opportunity ID: {0}", opportunity.Id);
                Console.WriteLine("Opportunity: {0}", opportunity.Name);
                var aliased = (AliasedValue)opportunity["contact2.fullname"];
                var contactName = (String)aliased.Value;
                Console.WriteLine("Associated contact: {0}", contactName);
            }
            Console.WriteLine("<End of Listing>");
            Console.WriteLine();
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {

            // Create an account.
            var account = new Account
            {
                Name = "Litware, Inc.",
                Address1_StateOrProvince = "Colorado"
            };
            _accountId = (_serviceProxy.Create(account));

            // Create the two contacts.
            var contact = new Contact()
            {
                FirstName = "Ben",
                LastName = "Andrews",
                EMailAddress1 = "sample@example.com",
                Address1_City = "Redmond",
                Address1_StateOrProvince = "WA",
                Address1_Telephone1 = "(206)555-5555",
                ParentCustomerId = new EntityReference
                {
                    Id = _accountId,
                    LogicalName = account.LogicalName
                }
            };
            _contactIdList.Add(_serviceProxy.Create(contact));

            contact = new Contact()
            {
                FirstName = "Colin",
                LastName = "Wilcox",
                EMailAddress1 = "sample@example.com",
                Address1_City = "Bellevue",
                Address1_StateOrProvince = "WA",
                Address1_Telephone1 = "(425)555-5555",
                ParentCustomerId = new EntityReference
                {
                    Id = _accountId,
                    LogicalName = account.LogicalName
                }
            };
            _contactIdList.Add(_serviceProxy.Create(contact));

            // Create two opportunities.
            var opportunity = new Opportunity()
            {
                Name = "Litware, Inc. Opportunity 1",
                EstimatedCloseDate = DateTime.Now.AddMonths(6),
                CustomerId = new EntityReference
                {
                    Id = _accountId,
                    LogicalName = account.LogicalName
                }
            };
            _opportunityIdList.Add(_serviceProxy.Create(opportunity));

            opportunity = new Opportunity()
            {
                Name = "Litware, Inc. Opportunity 2",
                EstimatedCloseDate = DateTime.Now.AddYears(4),
                CustomerId = new EntityReference
                {
                    Id = _accountId,
                    LogicalName = account.LogicalName
                }
            };
            _opportunityIdList.Add(_serviceProxy.Create(opportunity));
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                foreach (Guid contactId in _contactIdList)
                {
                    _serviceProxy.Delete(Contact.EntityLogicalName, contactId);
                }

                foreach (Guid opportunityId in _opportunityIdList)
                {
                    _serviceProxy.Delete(Opportunity.EntityLogicalName, opportunityId);
                }

                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new FetchXmlAndQueryExpressionQueryConversion();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Reference

RetrieveMultiple

Other Resources

Helper code: ServerConnection class
Build queries with FetchXML
Sample: Validate and execute a saved query
Build queries with QueryExpression
IOrganizationService
FetchExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Validate and execute a saved query
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\UserQueryAndSavedQuery.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Full Sample – C#

Demonstrates

This sample shows how to use the IOrganizationService.ValidateSavedQueryRequest message to validate a FetchXML query, and then use the IOrganizationService.ExecuteByIdSavedQueryRequest message to execute the query.

Example

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    #region Validate saved query

    // Create the request
    ValidateSavedQueryRequest validateRequest = new ValidateSavedQueryRequest()
    {
        FetchXml = _savedQuery.FetchXml,
        QueryType = _savedQuery.QueryType.Value
    };

    // Send the request
    Console.WriteLine("  Validating Saved Query");
    try
    {
        // executing the request will throw an exception if the fetch xml is invalid
        var validateResponse = (ValidateSavedQueryResponse)_serviceProxy.Execute(validateRequest);
        Console.WriteLine("  Saved Query validated successfully");
    }
    catch (Exception)
    {
        Console.WriteLine("  Invalid Saved Query");
        throw;
    }

    #endregion

    #region Execute saved query

    // Create the request
    ExecuteByIdSavedQueryRequest executeSavedQueryRequest = new ExecuteByIdSavedQueryRequest()
    {
        EntityId = _savedQuery.Id
    };

    // Execute the request
    Console.WriteLine("  Executing Saved Query");
    ExecuteByIdSavedQueryResponse executeSavedQueryResponse =
        (ExecuteByIdSavedQueryResponse)_serviceProxy.Execute(executeSavedQueryRequest);

    // Check results
    if (String.IsNullOrEmpty(executeSavedQueryResponse.String))
        throw new Exception("Saved Query did not return any results");

    PrintResults(executeSavedQueryResponse.String);
    #endregion

    #region Execute user query

    // Create the request
    ExecuteByIdUserQueryRequest executeUserQuery = new ExecuteByIdUserQueryRequest()
    {
        EntityId = _userQuery.ToEntityReference()
    };

    // Send the request
    Console.WriteLine("  Executing User Query");
    ExecuteByIdUserQueryResponse executeUserQueryResponse =
        (ExecuteByIdUserQueryResponse)_serviceProxy.Execute(executeUserQuery);
    if (String.IsNullOrEmpty(executeUserQueryResponse.String))
        throw new Exception("User Query did not return any results");

    // validate results
    PrintResults(executeUserQueryResponse.String);

    #endregion

    DeleteRequiredRecords(promptforDelete);
}

Full Sample – C#

C# Copy Code
using System;
using System.Collections.Generic;
using System.IO;
using System.ServiceModel;
using System.Text;
using System.Xml;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to execute saved and user queries by id, and how to validate
    /// a saved query.
    /// </summary>
    /// <param name="serverConfig">Contains server connection information.</param>
    /// <param name="promptforDelete">When True, the user will be prompted to delete all
    /// created entities.</param>
    public class UserQueryAndSavedQuery
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;
        private List<Account> _accounts = new List<Account>();
        private SavedQuery _savedQuery;
        private UserQuery _userQuery;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first creates a series of Accounts to query over, a user query
        /// that retrieves the names of all Accounts with a name of 'Coho Winery' and
        /// a system query that retrieves all Account names. Then it validates the system
        /// query, executes the system query and displays the results, and finally
        /// executes the user query and displays the results.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Validate saved query

                    // Create the request
                    ValidateSavedQueryRequest validateRequest = new ValidateSavedQueryRequest()
                    {
                        FetchXml = _savedQuery.FetchXml,
                        QueryType = _savedQuery.QueryType.Value
                    };

                    // Send the request
                    Console.WriteLine("  Validating Saved Query");
                    try
                    {
                        // executing the request will throw an exception if the fetch xml is invalid
                        var validateResponse = (ValidateSavedQueryResponse)_serviceProxy.Execute(validateRequest);
                        Console.WriteLine("  Saved Query validated successfully");
                    }
                    catch (Exception)
                    {
                        Console.WriteLine("  Invalid Saved Query");
                        throw;
                    }

                    #endregion

                    #region Execute saved query

                    // Create the request
                    ExecuteByIdSavedQueryRequest executeSavedQueryRequest = new ExecuteByIdSavedQueryRequest()
                    {
                        EntityId = _savedQuery.Id
                    };

                    // Execute the request
                    Console.WriteLine("  Executing Saved Query");
                    ExecuteByIdSavedQueryResponse executeSavedQueryResponse =
                        (ExecuteByIdSavedQueryResponse)_serviceProxy.Execute(executeSavedQueryRequest);

                    // Check results
                    if (String.IsNullOrEmpty(executeSavedQueryResponse.String))
                        throw new Exception("Saved Query did not return any results");

                    PrintResults(executeSavedQueryResponse.String);
                    #endregion

                    #region Execute user query

                    // Create the request
                    ExecuteByIdUserQueryRequest executeUserQuery = new ExecuteByIdUserQueryRequest()
                    {
                        EntityId = _userQuery.ToEntityReference()
                    };

                    // Send the request
                    Console.WriteLine("  Executing User Query");
                    ExecuteByIdUserQueryResponse executeUserQueryResponse =
                        (ExecuteByIdUserQueryResponse)_serviceProxy.Execute(executeUserQuery);
                    if (String.IsNullOrEmpty(executeUserQueryResponse.String))
                        throw new Exception("User Query did not return any results");

                    // validate results
                    PrintResults(executeUserQueryResponse.String);

                    #endregion

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #region Public methods

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            #region Create Accounts to query over

            Console.WriteLine("  Creating some sample accounts");

            Account account = new Account()
            {
                Name = "Coho Vineyard"
            };
            account.Id = _serviceProxy.Create(account);
            _accounts.Add(account);
            Console.WriteLine("    Created Account {0}", account.Name);

            account = new Account()
            {
                Name = "Coho Winery"
            };
            account.Id = _serviceProxy.Create(account);
            _accounts.Add(account);
            Console.WriteLine("    Created Account {0}", account.Name);

            account = new Account()
            {
                Name = "Coho Vineyard & Winery"
            };
            account.Id = _serviceProxy.Create(account);
            _accounts.Add(account);
            Console.WriteLine("    Created Account {0}", account.Name);

            #endregion

            #region Create a Saved Query

            Console.WriteLine("  Creating a Saved Query that retrieves all Account ids");

            _savedQuery = new SavedQuery()
            {
                Name = "Fetch all Account ids",
                ReturnedTypeCode = Account.EntityLogicalName,
                FetchXml = @"
                    <fetch mapping='logical'>
                        <entity name='account'>
                            <attribute name='name' />
                        </entity>
                    </fetch>",
                QueryType = 0,

            };
            _savedQuery.Id = _serviceProxy.Create(_savedQuery);

            #endregion

            #region Create a User Query

            Console.WriteLine(
                "  Creating a User Query that retrieves all Account ids for Accounts with name 'Coho Winery'");

            _userQuery = new UserQuery()
            {
                Name = "Fetch Coho Winery",
                ReturnedTypeCode = Account.EntityLogicalName,
                FetchXml = @"
                    <fetch mapping='logical'>
                        <entity name='account'>
                            <attribute name='name' />
                            <filter>
                                <condition attribute='name' operator='eq' value='Coho Winery' />
                            </filter>
                        </entity>
                    </fetch>",
                QueryType = 0
            };
            _userQuery.Id = _serviceProxy.Create(_userQuery);

            #endregion
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                _serviceProxy.Delete(SavedQuery.EntityLogicalName,
                    _savedQuery.Id);

                _serviceProxy.Delete(UserQuery.EntityLogicalName,
                    _userQuery.Id);

                foreach (Account a in _accounts)
                    _serviceProxy.Delete(Account.EntityLogicalName, a.Id);

                Console.WriteLine("Entity records have been deleted.");
            }
        }
        #endregion Public Methods

        #region Helper methods

        private void PrintResults(String response)
        {
            // Using XmlReader to format output
            StringBuilder output = new StringBuilder();
            using (XmlReader reader = XmlReader.Create(new StringReader(response)))
            {
                XmlWriterSettings settings = new XmlWriterSettings
                {
                    Indent = true,
                    OmitXmlDeclaration = true
                };
                using (XmlWriter writer = XmlWriter.Create(output, settings))
                {
                    // Parse the file and display each of the nodes.
                    while (reader.Read())
                    {
                        switch (reader.NodeType)
                        {
                            case XmlNodeType.Element:
                                writer.WriteStartElement(reader.Name);
                                break;
                            case XmlNodeType.Text:
                                writer.WriteString(reader.Value);
                                break;
                            case XmlNodeType.XmlDeclaration:
                            case XmlNodeType.ProcessingInstruction:
                                writer.WriteProcessingInstruction(reader.Name, reader.Value);
                                break;
                            case XmlNodeType.Comment:
                                writer.WriteComment(reader.Value);
                                break;
                            case XmlNodeType.EndElement:
                                writer.WriteFullEndElement();
                                break;
                        }
                    }
                }
            }

            Console.WriteLine("  Result of query:\r\n {0}", output.ToString());
            Console.WriteLine();
        }

        #endregion

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                UserQueryAndSavedQuery app = new UserQueryAndSavedQuery();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        #endregion Main method
    }
}

See Also

Concepts

Use the early bound entity classes in code

Other Resources

Build queries with FetchXML
IOrganizationService
ValidateSavedQueryRequest
ExecuteByIdSavedQueryRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Build queries with QueryExpression

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the QueryExpression class to programmatically build a query containing data filters and search conditions that define the scope of a database search. A query expression is used for single-object searches. For example, you can create a search to return all accounts that match certain search criteria. The QueryBase class is the base class for query expressions. There are two derived classes: QueryExpression and QueryByAttribute. The QueryExpression class supports complex queries. The QueryByAttribute class is a simple means to search for entities where attributes match specified values.

Query expressions are used in methods that retrieve more than one record, such as the IOrganizationService.RetrieveMultiple method, in messages that perform an operation on a result set specified by a query expression, such as BulkDeleteRequest and when the ID for a specific record is not known.

In addition, there is a new attribute on the organization entity, Organization.QuickFindRecordLimitEnabled. When this Boolean attribute is true, a limit is imposed on quick find queries. If a user provides search criteria in quick find that is not selective enough, the system detects this and stops the search. This supports a faster form of quick find and can make a big performance difference.

Warning
Don’t retrieve all attributes in a query because of the negative effect on performance. This is particularly true if the query is used as a parameter to an update request. In an update, if all attributes are included this sets all field values, even if they are unchanged, and often triggers cascaded updates to child records.

There are two additional ways to create queries to retrieve records from Microsoft Dynamics CRM. FetchXML, the proprietary Microsoft Dynamics CRM query language, can be used to perform some queries by using XML-based queries. For more information, see Build queries with FetchXML. You can also use .NET Language-Integrated Query (LINQ) to write queries. More information: Build queries with LINQ (.NET language-integrated query).

To save a query, you can convert it to FetchXML by using the QueryExpressionToFetchXmlRequest and save it as a saved view by using the userquery entity.

In This Section

Use the QueryByAttribute class

Use the QueryExpression class

Use the ColumnSet class

Use the ConditionExpression class

Use the FilterExpression class

Use a left outer join in QueryExpression to query for records "not in"

Test for a null value

Page large result sets with QueryExpression

Sample: Retrieve with one-to-many relationship

Sample: Retrieve multiple with the QueryByAttribute class

Sample: Retrieve multiple with the QueryExpression class

Sample: Convert queries between Fetch and QueryExpression

Reference

QueryBase

QueryExpression

QueryByAttribute

RetrieveMultiple

ColumnSet

ConditionExpression

FilterExpression

PagingCookie

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the QueryByAttribute class

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the QueryByAttribute class to build queries that test a set of attributes against a set of values. Use this class with the RetrieveMultiple method or the IOrganizationService.RetrieveMultipleRequest method.

The following table lists the properties that you can set to create a query expression using the QueryByAttribute class.

Property | Description
EntityName | Specifies which type of entity is retrieved. A query expression can only retrieve a collection of one entity type. You can also pass this value by using the QueryExpression constructor.
ColumnSet | Specifies the set of attributes (columns) to retrieve.
Attributes | Specifies the set of attributes selected in the query.
Values | Specifies the attribute values to look for when the query is executed.
Orders | Specifies the order in which the records are returned from the query.
PageInfo | Specifies the number of pages and the number of records per page returned from the query.

The following code example shows how to use the QueryByAttribute class.

C# Copy Code
//  Create query using querybyattribute    QueryByAttribute querybyexpression = new QueryByAttribute("account");    querybyexpression.ColumnSet = new ColumnSet("name", "address1_city", "emailaddress1");//  Attribute to query    querybyexpression.Attributes.AddRange("address1_city");//  Value of queried attribute to return    querybyexpression.Values.AddRange("Detroit");    //  Query passed to the service proxy    EntityCollection retrieved = _serviceProxy.RetrieveMultiple(querybyexpression);   //  Iterate through returned collection    foreach (var c in retrieved.Entities)    {      System.Console.WriteLine("Name: " + c.Attributes["name"]);             System.Console.WriteLine("Address: " + c.Attributes["address1_city"]);      System.Console.WriteLine("E-mail: " + c.Attributes["emailaddress1"]);    }

See Also

Concepts

Use the QueryExpression class

Other Resources

Build queries with QueryExpression
QueryByAttribute

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the QueryExpression class

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online, you can use the QueryExpression class to build complex queries for use with the IOrganizationService.RetrieveMultiple method or the RetrieveMultipleRequest message. You can set query parameters to the QueryExpression by using the ConditionExpression, ColumnSet, and FilterExpression classes.

The QueryExpression class lets you create complex queries. The QueryByAttribute class is designed to be a simple way to search for entities where attributes match specified values.

The following table lists the properties that you set to create a query expression.

Property | Description
EntityName | Specifies which type of entity will be retrieved. A query expression can only retrieve a collection of one entity type.
ColumnSet | Specifies the set of attributes (columns) to retrieve.
Criteria | Specifies complex conditional and logical filter expressions that filter the results of the query.
Distinct | Specifies whether the results of the query contain duplicate records.
LinkEntities | Specifies the links between multiple entity types.
Orders | Specifies the order in which the records are returned from the query.
PageInfo | Specifies the number of pages and the number of records per page returned from the query.

Record count

To find out how many records the query returned, set the ReturnTotalRecordCount property to true before executing the query. When you do this, the TotalRecordCount will be set. Otherwise, this value will be -1.

Example

The following sample shows how to use the QueryExpression class.

Copy Code
//  Query using ConditionExpression and FilterExpressionConditionExpression condition1 = new ConditionExpression();condition1.AttributeName = "lastname";condition1.Operator = ConditionOperator.Equal;condition1.Values.Add("Brown");            FilterExpression filter1 = new FilterExpression();filter1.Conditions.Add(condition1);QueryExpression query = new QueryExpression("contact");query.ColumnSet.AddColumns("firstname", "lastname");query.Criteria.AddFilter(filter1);EntityCollection result1 = _serviceProxy.RetrieveMultiple(query);Console.WriteLine();Console.WriteLine("Query using Query Expression with ConditionExpression and FilterExpression");Console.WriteLine("---------------------------------------");foreach (var a in result1.Entities){    Console.WriteLine("Name: " + a.Attributes["firstname"] + " " + a.Attributes["lastname"]);}Console.WriteLine("---------------------------------------");

See Also

Concepts

Use the ColumnSet class
Use the ConditionExpression class
Use the FilterExpression class

Other Resources

Build queries with QueryExpression
QueryExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the ColumnSet class

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the ColumnSet class to specify what attributes to return from a query expression. The query returns only non-null values.

You can also use the ColumnSet class to reduce the size of a query result by defining only those attributes to be returned. To improve server performance, it is recommended that you don’t execute a query that returns all columns.

The following code example shows how to use the ColumnSet class to specify what attributes to return from a query expression.

C# Copy Code
QueryExpression contactquery = new QueryExpression {  EntityName="contact",  ColumnSet = new ColumnSet("firstname", "lastname", "contactid") };

See Also

Concepts

Use the QueryExpression class
Use the ConditionExpression class

Other Resources

Build queries with QueryExpression
QueryExpression
ColumnSet

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the ConditionExpression class

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the ConditionExpression class to compare an attribute to a value or set of values by using an operator, such as “equal to” or “greater than”. The ConditionExpression class lets you pass condition expressions as parameters to other classes, such as QueryExpression and FilterExpression.

The following table lists the properties you can set to create a condition using the ConditionExpression class.

Property | Description
AttributeName | Specifies the logical name of the attribute in the condition expression.
Operator | Specifies the condition operator. This is set by using the ConditionOperator enumeration.
Values | Specifies the values of the attribute.

When using the AddCondition method (or the constructor for ConditionExpression), it’s important to understand whether the array is being added as multiple values or as an array.

The following code example shows two different outcomes depending on how the array is used.

C# Copy Code
string[] values = new string[] { "Value1", "Value2" };
ConditionExpression c = new ConditionExpression("name", ConditionOperator.In, values);
Console.WriteLine(c.Values.Count); //This will output 2
string[] values = new string[] { "Value1", "Value2" }object value = values;
ConditionExpression c = new ConditionExpression("name", ConditionOperator.In, value);
Console.WriteLine(c.Values.Count); //This will output 1

In some cases, it is necessary to cast to either object[] or object, depending on the desired behavior.

When you create a condition that compares an attribute value to an enumeration, such as a state code, you must use the ToString method to convert the value to a string.

Example

The following code example shows how to use the ConditionExpression class.

C# Copy Code
//  Query using ConditionExpression
ConditionExpression condition1 = new ConditionExpression();
condition1.AttributeName = "lastname";
condition1.Operator = ConditionOperator.Equal;
condition1.Values.Add("Brown");
FilterExpression filter1 = new FilterExpression();
filter1.Conditions.Add(condition1);
QueryExpression query = new QueryExpression("contact");
query.ColumnSet.AddColumns("firstname", "lastname");
query.Criteria.AddFilter(filter1);
EntityCollection result1 = _serviceProxy.RetrieveMultiple(query);
Console.WriteLine();
Console.WriteLine("Query using Query Expression with ConditionExpression and FilterExpression");
Console.WriteLine("---------------------------------------");
foreach (var a in result1.Entities)
{
      Console.WriteLine("Name: " + a.Attributes["firstname"] + " " + a.Attributes["lastname"]);
}
Console.WriteLine("---------------------------------------");

Example

The following code example shows how to use the ConditionExpression class to test for the inactive state.

C# Copy Code
ConditionExpression condition3 = new ConditionExpression();
condition3.AttributeName = "statecode";
condition3.Operator = ConditionOperator.Equal;
condition3.Values.Add(AccountState.Active);

See Also

Concepts

Use the FilterExpression class

Other Resources

Build queries with QueryExpression
Build queries with QueryExpression
ConditionExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the FilterExpression class

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online, you can use the FilterExpression class to build a query that expresses multiple conditions. For example, you can create a query expression that is the equivalent of a SQL statement such as ([FirstName] = 'Joe' OR [FirstName] = 'John') AND [City] = 'Redmond'.

The following table lists the properties for the FilterExpression class.

Property | Description
Conditions | Gets or sets condition expressions that include attributes, condition operators, and attribute values.
FilterOperator | Gets or sets logical AND/OR filter operators. This is set by using the LogicalOperator enumeration.
Filters | Gets or sets a hierarchy of condition and logical filter expressions that filter the results of the query.
IsQuickFindFilter | Gets or sets a value that indicates whether the expression is part of a quick find query.

The FilterExpression class also includes several helper methods that make it easier to create queries. The AddCondition method adds a ConditionExpression to the Conditions property for the FilterExpression, reducing the amount of code needed to construct the condition expression. The AddFilter method adds a new filter to the Filters property of the FilterExpression class.

In This Topic

Filter expression example

About the IsQuickFindFilter property

Filter expression example

The following code example shows how to use the FilterExpression class.

C# Copy Code
QueryExpression query = new QueryExpression("contact");
query.ColumnSet.AddColumns("firstname", "lastname", "address1_city");

query.Criteria = new FilterExpression();
query.Criteria.AddCondition("address1_city", ConditionOperator.Equal, "Redmond");

FilterExpression childFilter = query.Criteria.AddFilter(LogicalOperator.Or);
childFilter.AddCondition("lastname", ConditionOperator.Equal, "Tharpe");
childFilter.AddCondition("lastname", ConditionOperator.Equal, "Brown");

// Pass query to service proxy
EntityCollection results = _serviceProxy.RetrieveMultiple(query);
Console.WriteLine();
Console.WriteLine("Query using QE with multiple conditions and filters");
Console.WriteLine("---------------------------------------");

// Print results
foreach (var a in results.Entities)
{
Console.WriteLine("Name: {0} {1}", a.GetAttributeValue<string>("firstname"), a.GetAttributeValue<string>("lastname"));
Console.WriteLine("City: {0}", a.GetAttributeValue<string>("address1_city"));
}
Console.WriteLine("---------------------------------------");

About the IsQuickFindFilter property

You can use the FilterExpression.IsQuickFindFilter property, that is analogous to the isquickfindfields attribute that exists on the filter node in Fetch XML. When a Fetch query is saved, this is stored in the SavedQuery and UserQuery entities IsQuickFind properties. The IsQuickFindFilter property was added to provide consistency between Query Expression and Fetch XML queries.

The following rules apply to the IsQuickFindFilter property:

  • This field can only be set to true for filter expressions with a logical operator of type LogicalOperator.Or. If it is set for expressions with a logical operator of type LogicalOperator.And, the IsQuickFindFilter property is ignored.
  • Only one filter expression in a filter expression hierarchy can be set with IsQuickFindFilter = true. If more than one is found, an exception is thrown.
  • If a filter expression has IsQuickFindFilter set to true, it cannot have any child filter expression properties, it can only have ConditionExpression properties. If you add a child filter expression, an exception is thrown.
  • All condition expressions related to a filter expression with IsQuickFindFilter set to true must be single non-null value conditions. In other words, given that a condition is made up of attribute, operator, and value, only conditions where the value property is a single value that is not null are supported. In addition, the only condition operators supported on these condition expressions are ones that work with a single value that is not null. If a null value or multiple values are detected, an exception is thrown.

See Also

Concepts

Use a left outer join in QueryExpression to query for records "not in"
Use the ConditionExpression class

Other Resources

Build queries with QueryExpression
FilterExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use a left outer join in QueryExpression to query for records "not in"

You can use a left outer join by using the QueryExpression class to perform a query that filters on the join table, such as to find all contacts who did not have any campaign activities in the past two months. Another common use for this type of a query is to find records “not in” a set, such as in these cases:

  • Find all leads that have no tasks
  • Find all accounts that have no contacts
  • Find all leads that have one or more tasks

A left outer join returns each row that satisfies the join of the first input with the second input. It also returns any rows from the first input that had no matching rows in the second input. The nonmatching rows in the second input are returned as null values.

You can perform a left outer join in QueryExpression by using the entityname attribute as a condition operator. The entityname attribute is valid in conditions, filters, and nested filters.

Find all leads that have no tasks, using an alias

The following example shows how to construct this query:

Copy Code
QueryExpression qx = new QueryExpression("lead");
qx.ColumnSet.AddColumn("subject");

LinkEntity link = qx.AddLink("task", "leadid", "regardingobjectid", JoinOperator.LeftOuter);
link.Columns.AddColumn("subject");
link.EntityAlias = "tsk";

qx.Criteria = new FilterExpression();
qx.Criteria.AddCondition("tsk", "activityid", ConditionOperator.Null);

This is equivalent to the following SQL:

Copy Code
SELECT lead.FullName
FROM Leads as lead
LEFT OUTER JOIN Tasks as ab
ON (lead.leadId  =  ab.RegardingObjectId)
WHERE ab.RegardingObjectId is null

See Also

Concepts

Test for a null value
Use the QueryExpression class
Use the QueryByAttribute class

Other Resources

Build queries with QueryExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Test for a null value

The following code example shows how to test for a null value by using the FilterExpression and QueryByAttribute classes.

Example

Use this code to test for equality by using the FilterExpression class.

C# Copy Code
FilterExpression null_filter = new FilterExpression(LogicalOperator.And);
null_filter.FilterOperator = LogicalOperator.And;
null_filter.AddCondition("leadid", ConditionOperator.Null);

Example

Use this code to test for inequality by using the FilterExpression class.

C# Copy Code
FilterExpression filter = new FilterExpression(LogicalOperator.And);
filter.FilterOperator = LogicalOperator.And;
filter.AddCondition("leadid", ConditionOperator.NotNull);

Example

Use this code to test for equality by using the QueryByAttribute class.

C# Copy Code
QueryByAttribute qba = new QueryByAttribute("account");
qba.ColumnSet = new ColumnSet("name","address1_stateorprovince");
qba.AddAttributeValue("donotfax", null);

See Also

Concepts

Page large result sets with QueryExpression

Other Resources

Build queries with QueryExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Page large result sets with QueryExpression

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can use the paging cookie feature to make paging in an application faster for large datasets. The feature is available in both FetchXML and QueryExpression queries. When you use the paging cookie feature when querying a set of records, the result contains a value for the paging cookie. To improve system performance, you can then pass that value when you retrieve the next set of records.

FetchXML and QueryExpression use different formats for their paging cookies. If you convert from one query format to the other by using the FetchXmlToQueryExpressionRequest message or the QueryExpressionToFetchXmlRequest message, the paging cookie value is ignored.In addition, if you request nonconsecutive pages, the paging cookie value is ignored.

Using a paging cookie with QueryExpression

The following example shows how to use the paging cookie with a query expression.

C# Copy Code
//  Query using the paging cookie.
// Define the paging attributes.
// The number of records per page to retrieve.
int fetchCount = 3;
// Initialize the page number.
int pageNumber = 1;
// Initialize the number of records.
int recordCount = 0;
// Define the condition expression for retrieving records.
ConditionExpression pagecondition = new ConditionExpression();

pagecondition.AttributeName = "address1_stateorprovince";

pagecondition.Operator = ConditionOperator.Equal;
pagecondition.Values.Add("WA");

// Define the order expression to retrieve the records.
OrderExpression order = new OrderExpression();
order.AttributeName = "name";
order.OrderType = OrderType.Ascending;

// Create the query expression and add condition.
QueryExpression pagequery = new QueryExpression();
pagequery.EntityName = "account";
pagequery.Criteria.AddCondition(pagecondition);
pagequery.Orders.Add(order);
pagequery.ColumnSet.AddColumns("name", "address1_stateorprovince", "emailaddress1", "accountid");

// Assign the pageinfo properties to the query expression.
pagequery.PageInfo = new PagingInfo();
pagequery.PageInfo.Count = fetchCount;
pagequery.PageInfo.PageNumber = pageNumber;

// The current paging cookie. When retrieving the first page,
// pagingCookie should be null.
pagequery.PageInfo.PagingCookie = null;
Console.WriteLine("#\tAccount Name\t\t\tEmail Address");while (true)
{
    // Retrieve the page.
    EntityCollection results = _serviceProxy.RetrieveMultiple(pagequery);
    if (results.Entities != null)
    {
        // Retrieve all records from the result set.
        foreach (Account acct in results.Entities)
        {
            Console.WriteLine("{0}.\t{1}\t\t{2}",
                               ++recordCount,
                               acct.EMailAddress1,
                              acct.Name);
        }
    }
    // Check for more records, if it returns true.
    if (results.MoreRecords)
    {
        // Increment the page number to retrieve the next page.
        pagequery.PageInfo.PageNumber++;
        // Set the paging cookie to the paging cookie returned from current results.
        pagequery.PageInfo.PagingCookie = results.PagingCookie;
    }
    else
    {
        // If no more records are in the result nodes, exit the loop.
        break;
    }
}

See Also

Concepts

Use the QueryExpression class

Other Resources

Build queries with QueryExpression
Sample: Retrieve with one-to-many relationship

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve with one-to-many relationship
See Also Example

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Example

The following sample shows how to use the RetrieveMultiple method to return the 1:N related entities of an entity along with the primary entity. In this example, we retrieve an account and its related tasks.

C# Copy Code
Console.WriteLine("One-to-many Query using RetrieveMultiple");
    Console.WriteLine();
//Create an account and three related tasks
    Account account = new Account();
    account.Name = "SDK Test Account";
    Guid acctId = _serviceProxy.Create(account);
    Console.WriteLine("New account created.");
    Console.WriteLine();

    Task task1 = new Task();
    task1.Subject = "Test Task1";
    task1.RegardingObjectId = new EntityReference("account", acctId);
    Guid task1Id = _serviceProxy.Create(task1);

    Task task2 = new Task();
    task2.Subject = "Test Task2";
    task2.RegardingObjectId = new EntityReference("account", acctId);
    Guid task2Id = _serviceProxy.Create(task2);

    Task task3 = new Task();
    task3.Subject = "Test Task3";
    task3.RegardingObjectId = new EntityReference("account", acctId);
    Guid task3Id = _serviceProxy.Create(task2);

    Console.WriteLine("Three tasks created.");
    Console.WriteLine();

// Construct query
    // Condition where task attribute equals account id.
    ConditionExpression condition = new ConditionExpression();
    condition.AttributeName = "regardingobjectid";
    condition.Operator = ConditionOperator.Equal;
    condition.Values.Add(acctId.ToString());

    //Create a column set.
    ColumnSet columns = new ColumnSet("subject");

    // Create query expression.
    QueryExpression query1 = new QueryExpression();
    query1.ColumnSet = columns;
    query1.EntityName = "task";
    query1.Criteria.AddCondition(condition);

    EntityCollection result1 = _serviceProxy.RetrieveMultiple(query1);

    foreach (var r in result1.Entities)
    {
        Console.WriteLine(r.Attributes["subject"]);
    };
    Console.WriteLine("-------------------------------");
    Console.WriteLine();

See Also

Reference

RetrieveMultiple

Other Resources

Build queries with QueryExpression
Sample: Retrieve multiple with the QueryByAttribute class
IOrganizationService
QueryExpression
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve multiple with the QueryByAttribute class
See Also Example

This sample is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\QueryByAttribute.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Example

This sample shows how to use QueryByAttribute in the RetrieveMultiple method.

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do basic entity operations like create, retrieve,
    /// update, and delete.</summary>

    public class QueryByAttributeSample
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;
        private List<Guid> _accountIds = new List<Guid>();

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// basic create, retrieve, update, and delete entity operations are performed.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    _service = (IOrganizationService)_serviceProxy;

                    CreateRequiredRecords();

                    //  Create query using QueryByAttribute.
                    QueryByAttribute querybyattribute = new QueryByAttribute("account");
                    querybyattribute.ColumnSet = new ColumnSet("name", "address1_city", "emailaddress1");

                    //  Attribute to query.
                    querybyattribute.Attributes.AddRange("address1_city");

                    //  Value of queried attribute to return.
                    querybyattribute.Values.AddRange("Redmond");

                    //  Query passed to service proxy.
                    EntityCollection retrieved = _service.RetrieveMultiple(querybyattribute);

                    System.Console.WriteLine("Query Using QueryByAttribute");
                    System.Console.WriteLine("===============================");

                    //  Iterate through returned collection.
                    foreach (var c in retrieved.Entities)
                    {
                        System.Console.WriteLine("Name: " + c.Attributes["name"]);

                        if( c.Attributes.Contains("address1_city") )
                            System.Console.WriteLine("Address: " + c.Attributes["address1_city"]);

                        if( c.Attributes.Contains("emailaddress1") )
                            System.Console.WriteLine("E-mail: " + c.Attributes["emailaddress1"]);
                    }
                    System.Console.WriteLine("===============================");

                    DeleteRequiredRecords(promptforDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create two accounts.
            Account account = new Account
            {
                Name = "A. Datum Corporation",
                Address1_StateOrProvince = "Colorado",
                Address1_Telephone1 = "(206)555-5555",
                EMailAddress1 = "info@datum.com"
            };
            _accountIds.Add(_service.Create(account));

            account = new Account
            {
                Name = "Adventure Works Cycle",
                Address1_StateOrProvince = "Washington",
                Address1_City = "Redmond",
                Address1_Telephone1 = "(206)555-5555",
                EMailAddress1 = "contactus@adventureworkscycle.com"
            };
            _accountIds.Add(_service.Create(account));
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") || answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                foreach (Guid accountId in _accountIds)
                {
                    _service.Delete(Account.EntityLogicalName, accountId);
                }
                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                QueryByAttributeSample app = new QueryByAttributeSample();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Reference

RetrieveMultiple

Concepts

Use the QueryByAttribute class

Other Resources

Build queries with QueryExpression
Sample: Retrieve multiple with the QueryExpression class
IOrganizationService
QueryByAttribute

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve multiple with the QueryExpression class
See Also Example

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Example

This sample shows how to retrieve multiple entities using the RetrieveMultiple method with QueryExpression along with their related entity columns. The code returns columns from the primary account record as well as the firstname and lastname of the primary contacts associated with the account.

C# Copy Code
static void RetrieveMultipleWithRelatedEntityColumns()
{
    Console.WriteLine("Entering:RetrieveMultipleWithRelatedEntityColumns");
    //Create multiple accounts with primary contacts
    Entity contact = new Entity("contact");
    contact.Attributes["firstname"] = "ContactFirstName";
    contact.Attributes["lastname"] = "ContactLastName";
    Guid contactId = _orgService.Create(contact, null);

    Entity account = new Entity("account");
    account["name"] = "Test Account1";
    EntityReference primaryContactId = new EntityReference("contact", contactId);
    account["primarycontactid"] = primaryContactId;

    Guid accountId1 = _orgService.Create(account, null);
    account["name"] = "Test Account2";
    Guid accountId2 = _orgService.Create(account, null);
    account["name"] = "Test Account3";
    Guid accountId3 = _orgService.Create(account, null);

    //Create a query expression specifying the link entity alias and the columns of the link entity that you want to return
    QueryExpression qe = new QueryExpression();
    qe.EntityName = "account";
    qe.ColumnSet = new ColumnSet();
    qe.ColumnSet.Columns.Add("name");

    qe.LinkEntities.Add(new LinkEntity("account", "contact", "primarycontactid", "contactid", JoinOperator.Inner));
    qe.LinkEntities[0].Columns.AddColumns("firstname", "lastname");
    qe.LinkEntities[0].EntityAlias = "primarycontact";

    EntityCollection ec = _orgService.RetrieveMultiple(qe);

    Console.WriteLine("Retrieved {0} entities", ec.Entities.Count);
    foreach (Entity act in ec.Entities)
    {
       Console.WriteLine("account name:" + act["name"]);
       Console.WriteLine("primary contact first name:" + act["primarycontact.firstname"]);
       Console.WriteLine("primary contact last name:" + act["primarycontact.lastname"]);
    }
}

See Also

Reference

RetrieveMultiple

Concepts

Use the QueryExpression class

Other Resources

Build queries with QueryExpression
Sample: Convert queries between Fetch and QueryExpression
IOrganizationService
QueryExpression
QueryExpression

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Query hierarchical data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update introduces the capability to define specific self-referencing one-to-many entity relationships as hierarchical. You can write queries that return related data in these hierarchies.

You can take advantage of new query condition operators to query entities with explicit hierarchical relationships. These operators only apply for the entity relationship specifically defined as a hierarchical relationship. You can use new condition operators to retrieve this hierarchical data when you query using QueryExpression or FetchExpression.

Note
The OData endpoint hasn’t been changed to support querying hierarchical data.

Condition operators for hierarchical data

Use the following operators to set conditions when querying hierarchical data.

FetchXML | ConditionOperator | Description
above | Above | Returns all records in referenced record's hierarchical ancestry line.
eq-or-above | AboveOrEqual | Returns the referenced record and all records above it in the hierarchy.
under | Under | Returns all child records below the referenced record in the hierarchy
eq-or-under | UnderOrEqual | Returns the referenced record and all child records below it in the hierarchy
not-under | NotUnder | Returns all records not below the referenced record in the hierarchy
eq-owneduseroruserhierarchy | OwnedByMeOrMyReports | When hierarchical security models are used, Equals current user or his reporting hierarchy
eq-useroruserhierarchyandteams | OwnedByMeOrMyReportsAndTeams | When hierarchical security models are used, Equals current user and his teams or his reporting hierarchy and their teams

Recursion limits when querying hierarchical data

Because querying hierarchical data can be resource intensive, there is a default limit of 100 recursions allowed conditions for hierarchical queries using the Above, AboveOrEqual, Under, UnderOrEqual, and NotUnder condition operators.

These limits can be adjusted using Windows PowerShell commands through the deployment web service. More information: Administer the deployment using Windows PowerShell.

OwnedByMeOrMyReports and OwnedByMeOrMyReportsAndTeams are hierarchical security condition operators that depend on the Hierarchy Depth setting that can be found in Settings > Security > Hierarchy Security. The value of this setting is stored in the Organization.MaxDepthForHierarchicalSecurityModel attribute.

Retrieve the number of hierarchically related child records

Use the rowaggregate attribute in a FetchXML based query to retrieve the number of hierarchically related child records. When this value is set to CountChildren a value that includes the total number of child records for the record is included in the EntityCollection. For example, the following query will include an AccountChildren aggregate value representing the number of child account records in the hierarchical relationship where the {0} parameter represents the AccountId of the parent record.

Xml Copy Code
<fetch distinct='false' no-lock='false' mapping='logical'>
  <entity name='account'>
    <attribute name='name' />
    <attribute name='accountid' />
    <attribute name='accountid' rowaggregate='CountChildren' alias='AccountChildren'/>
    <filter type='and'>
      <condition attribute='accountid' operator='under' value='{0}' />
    </filter>
  </entity>
</fetch>
Note
The aggregate value returned represents all the child records, including any that the user may not have access to read.

See Also

Reference

FetchXML schema

Concepts

Customize entity relationship metadata

Other Resources

Build queries with FetchXML
Build queries with QueryExpression
ConditionOperator
Video: Hierarchy Visualization in Microsoft Dynamics CRM 2015

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Retrieve records for many-to-many relationships using intersect entities

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online, when there is a many-to-many (N:N) relationship between two entities, an intersect entity is automatically created. This is true for both system relationships built into the product as well as custom many-to-many relationships. The name of the entity is specified in the IntersectEntityName property in the relationship metadata. The name of the relationship is specified in the SchemaName property in the relationship metadata.

You can use the intersect entities to refine the result set in any query by using the IOrganizationService.RetrieveMultiple method or the RetrieveMultipleRequest message. However, you cannot retrieve the intersect entity records directly by using the QueryExpression class. To retrieve the records in an intersect entity, you must use the FetchExpression class.

In this topic

Intersect entities

Intersect entity metadata

Intersect entities

The following table lists the intersect entities that are used in N:N relationships between default entities.

IntersectEntity | MtoM_SchemaName | MtoM_Entity1 | MtoM_Entity2
accountleads | accountleads_association | account | lead
campaignactivityitem | campaignactivitylist_association | campaignactivity | list
campaignactivityitem | campaignactivitysalesliterature_association | campaignactivity | salesliterature
campaignitem | campaigncampaign_association | campaign | campaign
campaignitem | campaignlist_association | campaign | list
campaignitem | campaignproduct_association | campaign | product
campaignitem | campaignsalesliterature_association | campaign | salesliterature
competitorproduct | competitorproduct_association | competitor | product
competitorsalesliterature | competitorsalesliterature_association | salesliterature | competitor
connectionroleassociation | connectionroleassociation_association | connectionrole | connectionrole
contactinvoices | contactinvoices_association | invoice | contact
contactleads | contactleads_association | contact | lead
contactorders | contactorders_association | salesorder | contact
contactquotes | contactquotes_association | quote | contact
entitlementcontacts | entitlementcontacts_association | contact | entitlement
entitlementproducts | product_entitlement_association | product | entitlement
entitlementtemplateproducts | product_entitlementtemplate_association | product | entitlementtemplate
leadcompetitors | leadcompetitors_association | lead | competitor
leadproduct | leadproduct_association | lead | product
listmember | listaccount_association | list | account
listmember | listcontact_association | list | contact
listmember | listlead_association | list | lead
opportunitycompetitors | opportunitycompetitors_association | opportunity | competitor
productassociation | productassociation_association | product | product
productsalesliterature | productsalesliterature_association | product | salesliterature
productsubstitute | productsubstitute_association | product | product
queuemembership | queuemembership_association | queue | systemuser
roleprivileges | roleprivileges_association | privilege | role
roletemplateprivileges | roletemplateprivileges_association | roletemplate | privilege
servicecontractcontacts | servicecontractcontacts_association | contact | contract
subscriptionmanuallytrackedobject | contact_subscription_association | subscription | contact
subscriptionmanuallytrackedobject | task_subscription_association | subscription | task
systemuserprofiles | systemuserprofiles_association | systemuser | fieldsecurityprofile
systemuserroles | systemuserroles_association | systemuser | role
teammembership | teammembership_association | team | systemuser
teamprofiles | teamprofiles_association | team | fieldsecurityprofile
teamroles | teamroles_association | team | role

Intersect entity metadata

Most intersect entities are simple, containing just the few properties that are needed to provide a link between to two entities in the N:N relationship. If you are using early bound types, you can see an example, in the ContactInvoices intersect entity. This is the case for all custom many-to-many relationships. However, there are several intersect entities that have additional properties that are used for specific functionality for the relationship. To make it easier to write queries by using the special intersect entities, the attribute metadata is provided in the following topics:

  • CampaignActivityItem intersect entity metadata
  • CampaignItem intersect entity metadata
  • ListMember intersect entity metadata
  • Role Privileges intersect entity metadata

See Also

Concepts

Customize entity relationship metadata
Retrieve data with queries
CampaignActivityItem intersect entity metadata
CampaignItem intersect entity metadata
ListMember intersect entity metadata
Role Privileges intersect entity metadata

Other Resources

Build queries with QueryExpression
Sample: Retrieve records from an intersect table

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CampaignActivityItem intersect entity metadata

The CampaignActivityItem intersect entity is the intersect table for the following many-to-many relationships for the CampaignActivity entity.

Relationship schema name | Entity 1 | Entity 2
campaignactivitysalesliterature_association | campaignactivity | salesliterature
campaignactivitylist_association | campaignactivity | list

If you are not using early bound types, you might need to know the names of the attributes in this entity to effectively build a query. This information is provided in the following table. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

See Also

Concepts

Retrieve records for many-to-many relationships using intersect entities
CampaignItem intersect entity metadata
ListMember intersect entity metadata
Role Privileges intersect entity metadata
Campaign entities

Other Resources

Sample: Retrieve records from an intersect table

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CampaignItem intersect entity metadata

The CampaignItem intersect entity is the intersect table for the following many-to-many relationships for the Campaign entity.

Relationship schema name | Entity 1 | Entity 2
campaignproduct_association | campaign | Product
campaigncampaign_association | campaign | Campaign
campaignsalesliterature_association | campaign | SalesLiterature
campaignlist_association | campaign | List

If you are not using early bound types, you might need to know the names of the attributes in this entity to effectively build a query. This information is provided in the following table. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

See Also

Concepts

Retrieve records for many-to-many relationships using intersect entities
CampaignActivityItem intersect entity metadata
ListMember intersect entity metadata
Role Privileges intersect entity metadata
Campaign entities

Other Resources

Sample: Retrieve records from an intersect table

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ListMember intersect entity metadata

The ListMember intersect entity is the intersect table for the following many-to-many relationships for the List entity.

Relationship schema name | Entity 1 | Entity 2
listaccount_association | list | account
listcontact_association | list | contact
listlead_association | list | lead

If you are not using early bound types, you might need to know the names of the attributes in this entity to effectively build a query. This information is provided in the following table. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

See Also

Concepts

Retrieve records for many-to-many relationships using intersect entities
CampaignActivityItem intersect entity metadata
CampaignItem intersect entity metadata
Role Privileges intersect entity metadata
Campaign entities

Other Resources

Sample: Retrieve records from an intersect table

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Role Privileges intersect entity metadata

The RolePrivileges intersect entity is the intersect table for the following many-to-many relationships for the Role entity.

Relationship schema name | Entity 1 | Entity 2
roleprivileges_association | Privilege | Role

If you are not using early bound types, you might need to know the names of the attributes in this entity to effectively build a query. This information is provided in the following table. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

See Also

Concepts

Retrieve records for many-to-many relationships using intersect entities
CampaignActivityItem intersect entity metadata
CampaignItem intersect entity metadata
ListMember intersect entity metadata
Privilege and role entities

Other Resources

Sample: Retrieve records from an intersect table

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve records from an intersect table
See Also Example

This sample code is Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Queries\RetrieveRecordsFromAnIntersectTable.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Example

This sample shows how to retrieve records from an intersect table:

C# Copy Code
using System;
using System.Text;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to retrieve records from an intersect table.
    /// </summary>
    public class RetrieveRecordsFromAnIntersectTable
    {

        #region Class Level Members

        private Guid _userId;
        private Guid _roleId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// records are retrieved from the systemuserroles intersect table via three
        /// methods: Query Expression, Fetch, and LINQ.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();
                    #region Retrieve records from an intersect table via QueryExpression

                    //Create Query Expression.
                    QueryExpression query = new QueryExpression()
                    {
                        EntityName = "role",
                        ColumnSet = new ColumnSet("name"),
                        LinkEntities =
                        {
                            new LinkEntity
                            {
                                LinkFromEntityName = Role.EntityLogicalName,
                                LinkFromAttributeName = "roleid",
                                LinkToEntityName = SystemUserRoles.EntityLogicalName,
                                LinkToAttributeName = "roleid",
                                LinkCriteria = new FilterExpression
                                {
                                    FilterOperator = LogicalOperator.And,
                                    Conditions =
                                    {
                                        new ConditionExpression
                                        {
                                            AttributeName = "systemuserid",
                                            Operator = ConditionOperator.Equal,
                                            Values = { _userId }
                                        }
                                    }
                                }
                            }
                        }
                    };

                    // Obtain results from the query expression.
                    EntityCollection ec = _serviceProxy.RetrieveMultiple(query);

                    // Display results.
                    for (int i = 0; i < ec.Entities.Count; i++)
                    {
                        Console.WriteLine("Query Expression Retrieved: {0}", ((Role)ec.Entities[i]).Name);
                    }

                    #endregion
                    #region Retrieve records from an intersect table via Fetch

                    // Setup Fetch XML.
                    StringBuilder linkFetch = new StringBuilder();
                    linkFetch.Append("<fetch version=\"1.0\" output-format=\"xml-platform\" mapping=\"logical\" distinct=\"true\">");
                    linkFetch.Append("<entity name=\"role\">");
                    linkFetch.Append("<attribute name=\"name\"/>");
                    linkFetch.Append("<link-entity name=\"systemuserroles\" from=\"roleid\" to=\"roleid\" visible=\"false\" intersect=\"true\">");
                    linkFetch.Append("<filter type=\"and\">");
                    linkFetch.Append("<condition attribute=\"systemuserid\" operator=\"eq\" value=\"" + _userId + "\"/>");
                    linkFetch.Append("</filter>");
                    linkFetch.Append("</link-entity>");
                    linkFetch.Append("</entity>");
                    linkFetch.Append("</fetch>");

                    // Build fetch request and obtain results.
                    RetrieveMultipleRequest efr = new RetrieveMultipleRequest()
                    {
                        Query = new FetchExpression(linkFetch.ToString())
                    };
                    EntityCollection entityResults = ((RetrieveMultipleResponse)_serviceProxy.Execute(efr)).EntityCollection;

                    // Display results.
                    foreach (var e in entityResults.Entities)
                    {
                        Console.WriteLine("Fetch Retrieved: {0}", e.Attributes["name"]);
                    }

                    #endregion
                    #region Retrieve records from an intersect table via LINQ

                    // Obtain the Organization Context.
                    OrganizationServiceContext context = new OrganizationServiceContext(_serviceProxy);

                    // Create Linq Query.
                    var roles = (from r in context.CreateQuery<Role>()
                                 join s in context.CreateQuery<SystemUserRoles>() on r.RoleId equals s.RoleId
                                 where s.SystemUserId == _userId
                                 orderby r.RoleId
                                 select r.Name);

                    // Display results.
                    foreach (var role in roles)
                    {
                        Console.WriteLine("Linq Retrieved: {0}", role);
                    }

                    #endregion
                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Retrieve the default business unit needed to create the team.
            QueryExpression queryDefaultBusinessUnit = new QueryExpression
            {
                EntityName = BusinessUnit.EntityLogicalName,
                ColumnSet = new ColumnSet("businessunitid"),
                Criteria = new FilterExpression()
            };

            // Execute the request.
            queryDefaultBusinessUnit.Criteria.AddCondition("parentbusinessunitid",
                ConditionOperator.Null);

            BusinessUnit defaultBusinessUnit = (BusinessUnit)_serviceProxy.RetrieveMultiple(
                queryDefaultBusinessUnit).Entities[0];

            // Get the GUID of the current user.
            WhoAmIRequest who = new WhoAmIRequest();
            WhoAmIResponse whoResp = (WhoAmIResponse)_serviceProxy.Execute(who);
            _userId = whoResp.UserId;

            // Instantiate a role entity record and set its property values.
            // See the Entity Metadata topic in the SDK documentation to determine
            // which attributes must be set for each entity.
            Role setupRole = new Role
            {
                Name = "ABC Management Role",
                BusinessUnitId = new EntityReference(BusinessUnit.EntityLogicalName,
                    defaultBusinessUnit.Id)
            };

            //Create a role record.
            _roleId = _serviceProxy.Create(setupRole);
            Console.WriteLine("Created Role.");

            // Assign User to Managers role.
            AssociateRequest associate = new AssociateRequest()
            {
                Target = new EntityReference(SystemUser.EntityLogicalName, _userId),
                RelatedEntities = new EntityReferenceCollection()
                {
                    new EntityReference(Role.EntityLogicalName, _roleId),
                },
                Relationship = new Relationship("systemuserroles_association")
            };

            // Execute the request.
            _serviceProxy.Execute(associate);
        }

        /// <summary>
        /// Deletes any entity records and files that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Role.EntityLogicalName, _roleId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                RetrieveRecordsFromAnIntersectTable app = new RetrieveRecordsFromAnIntersectTable();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Reference

RetrieveMultiple
RetrieveMultiple

Concepts

Retrieve records for many-to-many relationships using intersect entities

Other Resources

Build queries with FetchXML
Helper code: ServerConnection class
IOrganizationService
FetchExpression
RetrieveMultipleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FetchXML schema

The FetchXML query language is used to create queries against the Microsoft Dynamics CRM database. The following is the schema for the FetchXML query language. For more information, see Use FetchXML to construct a query. You can find this schema in the SDK\Schemas\fetch.xsd file in the SDK package. Download the Microsoft Dynamics CRM SDK package.

FetchXML Schema

Xml Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<xs:schema id="fetch" elementFormDefault="qualified" xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:mstns="http://tempuri.org/fetch/unique">
<xs:annotation>
<xs:documentation>Schema name: fetch-schema</xs:documentation>
</xs:annotation>
<!--

condition element - used for capturing entity and link-entity
"where" clause criteria

-->
<!-- [XDR-XSD] "value" element  -->
<xs:element name="value" type="xs:string"></xs:element>
<!-- [XDR-XSD] "condition" element  -->
<xs:element name="condition">
<xs:complexType>
<xs:choice minOccurs="0" maxOccurs="unbounded">
<!-- -->
<!--
The attribute "value" is used for all operators that compare to a single value (for example, eq).
The element "value" is used for operators that compare to multiple values (for example, in).
Some operators require neither the attribute "value" or the element "value" (for example, null).
-->
<xs:element name="value" minOccurs="0" maxOccurs="unbounded">
<xs:complexType>
<xs:simpleContent>
<xs:extension base="xs:string">
<xs:attribute name="uiname" type="xs:string" />
<xs:attribute name="uitype" type="xs:string" />
</xs:extension>
</xs:simpleContent>
</xs:complexType>
</xs:element>
</xs:choice>
<!-- -->
<xs:attribute name="column" type="xs:string" />
<xs:attribute name="attribute" type="xs:string"></xs:attribute>
<xs:attribute name="entityname" type="xs:string"></xs:attribute>
<xs:attribute name="operator" use="required" type="operator"></xs:attribute>
<!--
The attribute "value" is used for all operators that compare to a single value (for example, eq).
The element "value" is used for operators that compare to multiple values (for example, in).
Some operators require neither the attribute "value" or the element "value" (for example, null).
-->
<xs:attribute name="value" type="xs:string"></xs:attribute>
<xs:attribute name="aggregate" type="AggregateType"></xs:attribute>
<xs:attribute name="rowaggregate" type="RowAggregateType"></xs:attribute>
<xs:attribute name="alias" type="xs:string"></xs:attribute>
<xs:attribute name="uiname" />
<xs:attribute name="uitype" />
<xs:attribute name="uihidden" type="TrueFalse01Type" />
</xs:complexType>
</xs:element>
<!--

filter element - used for constructing complex conditionals
 legal on entity and link-entity

-->
<!-- [XDR-XSD] "filter" element  -->
<xs:element name="filter">
<xs:complexType>
<xs:choice minOccurs="0" maxOccurs="unbounded">
<!-- -->
<xs:element ref="condition" minOccurs="0" maxOccurs="500" />
<xs:element ref="filter" minOccurs="0" maxOccurs="unbounded" />
</xs:choice>
<!-- -->
<xs:attribute name="type" default="and">
<xs:simpleType>
<xs:restriction base="xs:NMTOKEN">
<xs:enumeration value="and" />
<xs:enumeration value="or" />
</xs:restriction>
</xs:simpleType>
</xs:attribute>
<xs:attribute name="isquickfindfields" type="xs:boolean" />
</xs:complexType>
</xs:element>
<!--

attribute elements - used for selecting attributes from the
 surrounding entity / link-entity, these
 values are returned as part of the fetch

-->
<!-- [XDR-XSD] "all-attributes" element  -->
<xs:element name="all-attributes">
<xs:complexType></xs:complexType>
</xs:element>
<!-- [XDR-XSD] "attribute" element  -->
<xs:complexType name="FetchAttributeType">
<xs:attribute name="name" use="required" type="xs:string"></xs:attribute>
<xs:attribute name="build" type="build"></xs:attribute>
<xs:attribute name="addedby" type="xs:string" />
<xs:attribute name="alias" type="xs:string"></xs:attribute>
<xs:attribute name="aggregate" type="AggregateType"></xs:attribute>
<xs:attribute name="groupby" type="FetchBoolType"></xs:attribute>
<xs:attribute name="dategrouping" type="DateGroupingType"></xs:attribute>
<xs:attribute name="usertimezone" type="FetchBoolType"></xs:attribute>
</xs:complexType>
<!--

order element - used to specify a sort order

-->
<!-- [XDR-XSD] "order" element  -->
<xs:complexType name="FetchOrderType">
<xs:choice minOccurs="0" maxOccurs="unbounded">
<!-- -->
</xs:choice>
<!-- -->
<xs:attribute name="attribute" type="xs:string"></xs:attribute>
<xs:attribute name="alias" type="xs:string"></xs:attribute>
<xs:attribute name="descending" default="false" type="xs:boolean"></xs:attribute>
</xs:complexType>
<!--

link-entity element - used for joining one entity to its "parent"

-->
<!-- [XDR-XSD] "link-entity" element  -->
<xs:complexType name="FetchLinkEntityType">
<xs:choice minOccurs="0" maxOccurs="unbounded">
<!-- -->
<xs:element ref="all-attributes" minOccurs="0" />
<xs:element name="attribute" type="FetchAttributeType" minOccurs="0" maxOccurs="unbounded" />
<xs:element name="order" type="FetchOrderType" minOccurs="0" maxOccurs="1" />
<xs:element ref="filter" minOccurs="0" />
<xs:element name="link-entity" type="FetchLinkEntityType" />
</xs:choice>
<!-- -->
<xs:attribute name="name" use="required" type="xs:string"></xs:attribute>
<xs:attribute name="to" type="xs:string"></xs:attribute>
<xs:attribute name="from" type="xs:string"></xs:attribute>
<xs:attribute name="alias" type="xs:string"></xs:attribute>
<xs:attribute name="link-type" type="xs:string"></xs:attribute>
<xs:attribute name="visible" type="xs:boolean"></xs:attribute>
<xs:attribute name="intersect" type="xs:boolean"></xs:attribute>
</xs:complexType>
<!--

entity element - used for specifying the root element for a fetch, only
 one root entity is allowed in a given fetch, all others
 are dependent on this entity and are marked as
 link-entity

-->
<!-- [XDR-XSD] "entity" element  -->
<xs:complexType name="FetchEntityType">
<xs:choice minOccurs="0" maxOccurs="unbounded">
<!-- -->
<xs:element ref="all-attributes" minOccurs="0" />
<xs:element name="attribute" type="FetchAttributeType" minOccurs="0" maxOccurs="unbounded" />
<xs:element name="order" type="FetchOrderType" minOccurs="0" maxOccurs="unbounded" />
<xs:element name="link-entity" type="FetchLinkEntityType" />
<xs:element ref="filter" minOccurs="0" />
</xs:choice>
<!-- -->
<xs:attribute name="name" use="required" type="xs:string"></xs:attribute>
</xs:complexType>
<!--

fetch element - root element for the query

-->
<!-- [XDR-XSD] "fetch" element  -->
<xs:element name="fetch" type="FetchType"/>
<xs:complexType name="FetchType">
<xs:choice minOccurs="0" maxOccurs="unbounded">
<!-- -->
<xs:element name="entity" type="FetchEntityType" />
<!-- This is for the Reports view only -->
<xs:element name="order" type="FetchOrderType" minOccurs="1" maxOccurs="1" />
</xs:choice>
<!-- -->
<xs:attribute name="version"/>
<xs:attribute name="count" type="xs:integer"/>
<xs:attribute name="page" type="xs:integer"/>
<xs:attribute name="paging-cookie" type="xs:string"/>
<xs:attribute name="utc-offset" type="IntOrEmpty"/>
<xs:attribute name="aggregate" type="xs:boolean"/>
<xs:attribute name="distinct" type="xs:boolean"/>
<xs:attribute name="top" type="xs:integer"/>
<xs:attribute name="mapping">
<xs:simpleType>
<xs:restriction base="xs:NMTOKEN">
<xs:enumeration value="internal" />
<xs:enumeration value="logical" />
</xs:restriction>
</xs:simpleType>
</xs:attribute>
<xs:attribute name="min-active-row-version" type="xs:boolean" use="optional" default="false"/>
<xs:attribute name="output-format">
<xs:simpleType>
<xs:restriction base="xs:NMTOKEN">
<xs:enumeration value="xml-ado" />
<xs:enumeration value="xml-auto" />
<xs:enumeration value="xml-elements" />
<xs:enumeration value="xml-raw" />
<xs:enumeration value="xml-platform" />
</xs:restriction>
</xs:simpleType>
</xs:attribute>
<xs:attribute name="returntotalrecordcount" type="xs:boolean" use="optional" default="false" />
<xs:attribute name="no-lock" type="xs:boolean" use="optional" default="false" />
</xs:complexType>
<!-- [XDR-XSD] XDR datatype derivations -->
<xs:element name="savedquery">
<xs:complexType>
<xs:all>
<xs:element name="name" type="xs:string" minOccurs="1" maxOccurs="1" />
<xs:element name="savedqueryid" type="guid" minOccurs="1" maxOccurs="1" />
<xs:element name="returnedtypecode" type="SerializedInteger" minOccurs="1" maxOccurs="1" />
<xs:element name="description" type="xs:string" minOccurs="0" maxOccurs="1" />
<xs:element name="querytype" type="SerializedInteger" minOccurs="1" maxOccurs="1" />
<xs:element name="IsCustomizable" type="SerializedTrueFalse01Type" minOccurs="0" maxOccurs="1" />
<xs:element name="CanBeDeleted" type="SerializedTrueFalse01Type" minOccurs="0" maxOccurs="1" />
<xs:element name="IntroducedVersion" type="VersionType" minOccurs="0" maxOccurs="1" />
<xs:element name="isquickfindquery" type="SerializedTrueFalse01Type" minOccurs="0" maxOccurs="1" />
<xs:element name="isuserdefined" type="SerializedTrueFalse01Type" minOccurs="0" maxOccurs="1" />
<xs:element name="isdefault" type="SerializedTrueFalse01Type" minOccurs="0" maxOccurs="1" />
<xs:element name="isprivate" type="xs:boolean" minOccurs="0" maxOccurs="1" />
<xs:element name="queryapi" type="xs:string" minOccurs="0" maxOccurs="1" />
<xs:element name="fetchxml" minOccurs="0" maxOccurs="1">
<xs:complexType>
<xs:sequence>
<xs:element ref="fetch" minOccurs="0" maxOccurs="1" />
</xs:sequence>
</xs:complexType>
</xs:element>
<xs:element name="columnsetxml" minOccurs="1" maxOccurs="1">
<xs:complexType>
<xs:sequence>
<xs:element name="columnset" minOccurs="0" maxOccurs="1">
<xs:complexType>
<xs:choice minOccurs="0" maxOccurs="unbounded">
<!-- Because <column> contains text and one attribute we cannot specify its type. We have to define it as a complexType with a simple content. -->
<xs:element name="column" minOccurs="0" maxOccurs="1">
<xs:complexType>
<xs:simpleContent>
<xs:extension base="xs:string">
<xs:attribute name="build" type="build" />
<xs:attribute name="addedby" type="xs:string" />
</xs:extension>
</xs:simpleContent>
</xs:complexType>
</xs:element>
<xs:choice>
<xs:element name="ascend" minOccurs="0" maxOccurs="1" />
<xs:element name="descend" minOccurs="0" maxOccurs="1" />
</xs:choice>
<xs:element name="filter" minOccurs="0" maxOccurs="1">
<!-- Allow support for v1.5 format -->
<xs:complexType>
<xs:sequence>
<xs:element name="condition" minOccurs="1" maxOccurs="500">
<xs:complexType>
<xs:attribute name="column" type="xs:string" use="required" />
<xs:attribute name="operator" type="operator" use="optional" />
<xs:attribute name="value" type="xs:string" use="optional"/>
</xs:complexType>
</xs:element>
</xs:sequence>

<xs:attribute name="column" type="xs:string" use="optional" />
<xs:attribute name="operator" type="operator" use="optional" />
<xs:attribute name="value" type="xs:string" use="optional"/>
<xs:attribute name="type" type="xs:string" use="optional"/>

</xs:complexType>
</xs:element>
</xs:choice>
<xs:attribute name="version"></xs:attribute>
<xs:attribute name="distinct" type="xs:boolean"/>
</xs:complexType>
</xs:element>
</xs:sequence>
</xs:complexType>
</xs:element>
<xs:element name="layoutxml" minOccurs="0" maxOccurs="1">
<xs:complexType>
<xs:sequence>
<xs:element name="grid" minOccurs="0" maxOccurs="1">
<xs:complexType>
<xs:sequence>
<xs:element name="row" minOccurs="1" maxOccurs="1">
<xs:complexType>
<xs:sequence>
<xs:element name="cell" minOccurs="1" maxOccurs="unbounded">
<xs:complexType>
<xs:sequence></xs:sequence>
<xs:attribute name="name" type="xs:string" use="required" />
<xs:attribute name="width" type="xs:integer" use="optional" />
<xs:attribute name="LabelId" type="xs:string" use="optional" />
<xs:attribute name="label" type="xs:string" use="optional" />
<xs:attribute name="desc" type="xs:string" use="optional" />
<xs:attribute name="ishidden" type="xs:integer" use="optional" />
<xs:attribute name="disableSorting" type="xs:integer" use="optional" />
<xs:attribute name="disableMetaDataBinding" type="xs:integer" use="optional" />
<xs:attribute name="cellType" type ="xs:string" />
</xs:complexType>
</xs:element>
</xs:sequence>
<xs:attribute name="name" type="xs:string" use="required" />
<xs:attribute name="id" type="xs:string" use="required" />
<xs:attribute name="multiobjectidfield" type="xs:string" />
<xs:attribute name="layoutstyle" type="xs:string" />
</xs:complexType>
</xs:element>
</xs:sequence>
<xs:attribute name="name" type="xs:string" use="required" />
<xs:attribute name="select" type="xs:boolean" use="required" />
<xs:attribute name="preview" type="BoolOrEmpty" use="required" />
<xs:attribute name="icon" type="BoolOrEmpty" use="required" />
<xs:attribute name="jump" type="xs:string" use="optional" />
<xs:attribute name="object" type="xs:integer" use="required" />
<xs:attribute name="disableInlineEditing" type="xs:integer" use="optional" />
<xs:attribute name="iconrenderer" type="xs:string" />
<xs:attribute name="multilinerows" type="BoolOrEmpty" use="optional" />
</xs:complexType>
</xs:element>
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:all>
<xs:attribute name="donotuseinLCID" type="xs:string" use="optional" />
<xs:attribute name="useinLCID" type="xs:string" use="optional" />
</xs:complexType>
</xs:element>
<xs:complexType name="SerializedInteger">
<xs:simpleContent>
<xs:extension base="xs:nonNegativeInteger">
<xs:attribute name="formattedvalue" type="xs:string" />
</xs:extension>
</xs:simpleContent>
</xs:complexType>
<xs:simpleType name="build">
<xs:restriction base="xs:string">
<xs:enumeration value="1.504021" />
<xs:enumeration value="1.003017" />
</xs:restriction>
</xs:simpleType>
<xs:simpleType name="operator">
<xs:restriction base="xs:NMTOKEN">
<xs:enumeration value="eq" />
<xs:enumeration value="neq" />
<xs:enumeration value="ne" />
<xs:enumeration value="gt" />
<xs:enumeration value="ge" />
<xs:enumeration value="le" />
<xs:enumeration value="lt" />
<xs:enumeration value="like" />
<xs:enumeration value="not-like" />
<xs:enumeration value="in" />
<xs:enumeration value="not-in" />
<xs:enumeration value="between" />
<xs:enumeration value="not-between" />
<xs:enumeration value="null" />
<xs:enumeration value="not-null" />
<xs:enumeration value="yesterday" />
<xs:enumeration value="today" />
<xs:enumeration value="tomorrow" />
<xs:enumeration value="last-seven-days" />
<xs:enumeration value="next-seven-days" />
<xs:enumeration value="last-week" />
<xs:enumeration value="this-week" />
<xs:enumeration value="next-week" />
<xs:enumeration value="last-month" />
<xs:enumeration value="this-month" />
<xs:enumeration value="next-month" />
<xs:enumeration value="on" />
<xs:enumeration value="on-or-before" />
<xs:enumeration value="on-or-after" />
<xs:enumeration value="last-year" />
<xs:enumeration value="this-year" />
<xs:enumeration value="next-year" />
<xs:enumeration value="last-x-hours" />
<xs:enumeration value="next-x-hours" />
<xs:enumeration value="last-x-days" />
<xs:enumeration value="next-x-days" />
<xs:enumeration value="last-x-weeks" />
<xs:enumeration value="next-x-weeks" />
<xs:enumeration value="last-x-months" />
<xs:enumeration value="next-x-months" />
<xs:enumeration value="olderthan-x-months" />
<xs:enumeration value="last-x-years" />
<xs:enumeration value="next-x-years" />
<xs:enumeration value="eq-userid" />
<xs:enumeration value="ne-userid" />
<xs:enumeration value="eq-userteams" />
<xs:enumeration value="eq-useroruserteams" />
<xs:enumeration value="eq-useroruserhierarchy" />
<xs:enumeration value="eq-useroruserhierarchyandteams" />
<xs:enumeration value="eq-businessid" />
<xs:enumeration value="ne-businessid" />
<xs:enumeration value="eq-userlanguage" />
<xs:enumeration value="this-fiscal-year" />
<xs:enumeration value="this-fiscal-period" />
<xs:enumeration value="next-fiscal-year" />
<xs:enumeration value="next-fiscal-period" />
<xs:enumeration value="last-fiscal-year" />
<xs:enumeration value="last-fiscal-period" />
<xs:enumeration value="last-x-fiscal-years" />
<xs:enumeration value="last-x-fiscal-periods" />
<xs:enumeration value="next-x-fiscal-years" />
<xs:enumeration value="next-x-fiscal-periods" />
<xs:enumeration value="in-fiscal-year" />
<xs:enumeration value="in-fiscal-period" />
<xs:enumeration value="in-fiscal-period-and-year" />
<xs:enumeration value="in-or-before-fiscal-period-and-year" />
<xs:enumeration value="in-or-after-fiscal-period-and-year" />
<xs:enumeration value="begins-with" />
<xs:enumeration value="not-begin-with" />
<xs:enumeration value="ends-with" />
<xs:enumeration value="not-end-with" />
<xs:enumeration value="under"/>
<xs:enumeration value="eq-or-under" />
<xs:enumeration value="not-under"/>
<xs:enumeration value="above" />
<xs:enumeration value="eq-or-above" />
</xs:restriction>
</xs:simpleType>
<xs:simpleType name="VersionType">
<xs:annotation>
<xs:documentation xml:lang="en">
The representation of a Version number.
</xs:documentation>
</xs:annotation>
<xs:restriction base="xs:string">
<xs:pattern value="^[0-9]+(\.[0-9]+){1,3}$" />
</xs:restriction>
</xs:simpleType>
<xs:simpleType name="guid">
<xs:restriction base="xs:string">
<xs:pattern value="\{?[0-9a-fA-F]{8}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{12}\}?" />
</xs:restriction>
</xs:simpleType>
<xs:simpleType name="BoolOrEmpty">
<xs:union memberTypes="xs:boolean">
<xs:simpleType>
<xs:restriction base="xs:string">
<xs:enumeration value="" />
</xs:restriction>
</xs:simpleType>
</xs:union>
</xs:simpleType>
<xs:simpleType name="IntOrEmpty">
<xs:union memberTypes="xs:integer">
<xs:simpleType>
<xs:restriction base="xs:string">
<xs:enumeration value="" />
</xs:restriction>
</xs:simpleType>
</xs:union>
</xs:simpleType>
<xs:simpleType name="TrueFalse01Type">
<xs:restriction base="xs:string">
<xs:enumeration value="0" />
<xs:enumeration value="1" />
</xs:restriction>
</xs:simpleType>
<xs:simpleType name="AggregateType">
<xs:restriction base="xs:NMTOKEN">
<xs:enumeration value="count" />
<xs:enumeration value="countcolumn" />
<xs:enumeration value="sum" />
<xs:enumeration value="avg" />
<xs:enumeration value="min" />
<xs:enumeration value="max" />
</xs:restriction>
</xs:simpleType>
<xs:simpleType name="RowAggregateType">
<xs:restriction base="xs:NMTOKEN">
<xs:enumeration value="countchildren" />
</xs:restriction>
</xs:simpleType>
<xs:simpleType name="DateGroupingType">
<xs:restriction base="xs:NMTOKEN">
<xs:enumeration value="day" />
<xs:enumeration value="week" />
<xs:enumeration value="month" />
<xs:enumeration value="quarter" />
<xs:enumeration value="year" />
<xs:enumeration value="fiscal-period" />
<xs:enumeration value="fiscal-year" />
</xs:restriction>
</xs:simpleType>
<xs:simpleType name="FetchBoolType">
<xs:restriction base="xs:NMTOKEN">
<xs:enumeration value="true" />
<xs:enumeration value="false" />
<xs:enumeration value="1" />
<xs:enumeration value="0" />
</xs:restriction>
</xs:simpleType>
<xs:complexType name="SerializedTrueFalse01Type">
<xs:simpleContent>
<xs:extension base="TrueFalse01Type">
<xs:attribute name="name" type="xs:string" />
</xs:extension>
</xs:simpleContent>
</xs:complexType>
<xs:complexType name="LocalizedNamesType">
<xs:sequence>
<xs:element name="LocalizedName" type="FieldXmlFieldUIType" minOccurs="0" maxOccurs="unbounded" />
</xs:sequence>
</xs:complexType>
<xs:complexType name="DescriptionsType">
<xs:sequence>
<xs:element name="Description" type="FieldXmlFieldUIType" minOccurs="0" maxOccurs="unbounded" />
</xs:sequence>
</xs:complexType>
<xs:complexType name="FieldXmlFieldUIType">
<xs:attribute name="id" type="guid" />
<xs:attribute name="description" use="required" type="xs:string" />
<xs:attribute name="languagecode" use="required" type="xs:positiveInteger" />
</xs:complexType>
</xs:schema>

See Also

Concepts

Retrieve data with queries

Other Resources

Schemas used in Microsoft Dynamics CRM
Build queries with FetchXML

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Retrieve and detect changes to metadata

The classes in the Microsoft.Xrm.Sdk.Metadata.Query namespace and the RetrieveMetadataChangesRequest and RetrieveMetadataChangesResponse classes let you build efficient metadata queries and capture changes to metadata as they occur over time.

All code examples referenced in this document are found in Sample: Query metadata and detect changes.

The technical article Query Metadata Using JavaScript provides a JavaScript library to use the objects and messages in client-sided code.

In This Topic

Strategies for using metadata

Retrieve only the metadata you need

Retrieve new or changed metadata

Retrieve information about deleted metadata

Strategies for using metadata

Metadata lets you create applications that adapt as the Microsoft Dynamics CRM data model changes. Metadata is important for the following types of application:

  • UI for client applications
  • Integration tools that have to map CRM data to external systems
  • Development tools

Using the classes in the Microsoft.Xrm.Sdk.Metadata.Query namespace you can implement designs that will exist somewhere between a lightweight query and a persistent metadata cache.

Lightweight query

An example of a lightweight query is when you have a custom web resource UI that provides a select control to display the current options in a Microsoft CRM Option Set (Picklist) attribute. You do not want to hard-code these options because you would have to update that code if the available options are ever changed. Instead you can construct a query to just retrieve those options values and labels from the metadata.

You do not have to cache this data because you can use the Microsoft.Xrm.Sdk.Metadata.Query classes to retrieve this data directly from the Microsoft CRM application cache.

Persistent metadata cache

When you have an application that must be able to work while disconnected from the Microsoft CRM Server, or that is sensitive to limited network bandwidth between the client and the server, such as a mobile application, you will want to implement a persistent metadata cache.

With a persistent metadata cache your application will have to query all the necessary metadata the first time it connects. Then you will save that data in the application. The next time the application connects to the server you can retrieve just the difference since your last query, which should be much less data to transmit, and then merge the changes into your metadata cache when your application is loading.

How frequently you should poll for metadata changes depends on the expected volatility of metadata for your application and how long your application will remaining running. There is no event available that you can use to detect when metadata changes occur. There is a limit to the number of days that deleted metadata changes are saved and a request for changes that occurs beyond that limit will require a full re-initialization of the metadata cache. For more information see Deleted metadata expiration.

When there are no changes the query should respond quickly and there will be no data to transmit back. However, if there are changes, especially if there are deleted metadata items that have to be removed from your cache, you can expect that the request may take some additional time to finish. More information: Performance When Retrieving Deleted Metadata

Retrieve only the metadata you need

Metadata is frequently retrieved or synchronized when an application starts and can affect the time the application takes to load. This is particularly true for mobile applications retrieving metadata for the first time. Retrieving only the metadata you need is very important to create an application that performs well.

The EntityQueryExpression class provides a structure consistent with the QueryExpression class you use to create complex queries to retrieve entity data. Unlike the RetrieveAllEntitiesRequest, RetrieveEntityRequest, RetrieveAttributeRequest, or RetrieveRelationshipRequest classes, the RetrieveMetadataChangesRequest contains a Query parameter that accepts an EntityQueryExpression instance that you can use to specify specific criteria for the data to return in addition to which properties you want. You can use RetrieveMetadataChangesRequest to return the full set of metadata that you get using the RetrieveAllEntitiesRequest, or just a label for a specific attribute.

Specify your filter criteria

The EntityQueryExpression.Criteria property accepts a MetadataFilterExpression that contains a collection of MetadataConditionExpression objects that allow for defining conditions for filtering entity properties based on their value. These conditions use a MetadataConditionOperator that allows for the following operators:

  • MetadataConditionOperator.Equals
  • MetadataConditionOperator.NotEquals
  • MetadataConditionOperator.In
  • MetadataConditionOperator.NotIn
  • MetadataConditionOperator.GreaterThan
  • MetadataConditionOperator.LessThan

The MetadataFilterExpression also includes a LogicalOperator to represent whether to apply And or Or logic when you evaluate the conditions.

Not all properties can be used as filter criteria. Only properties that represent simple data types, enumerations, BooleanManagedProperty or AttributeRequiredLevelManagedProperty types can be used in a MetadataFilterExpression. When a BooleanManagedProperty or AttributeRequiredLevelManagedProperty is specified, only the Value property is evaluated.

The following table lists EntityMetadata properties that cannot be used in a MetadataFilterExpression:

Attributes | Description | DisplayCollectionName | DisplayName
ManyToManyRelationships | ManyToOneRelationships | OneToManyRelationships | Privileges

The following example shows a MetadataFilterExpression that will return a set of non-intersect, user-owned entities not included in a list of entities to exclude:

C# Copy Code

     // An array SchemaName values for non-intersect, user-owned entities that should not be returned.
     String[] excludedEntities = {
"WorkflowLog",
"Template",
"CustomerOpportunityRole",
"Import",
"UserQueryVisualization",
"UserEntityInstanceData",
"ImportLog",
"RecurrenceRule",
"QuoteClose",
"UserForm",
"SharePointDocumentLocation",
"Queue",
"DuplicateRule",
"OpportunityClose",
"Workflow",
"RecurringAppointmentMaster",
"CustomerRelationship",
"Annotation",
"SharePointSite",
"ImportData",
"ImportFile",
"OrderClose",
"Contract",
"BulkOperation",
"CampaignResponse",
"Connection",
"Report",
"CampaignActivity",
"UserEntityUISettings",
"IncidentResolution",
"GoalRollupQuery",
"MailMergeTemplate",
"Campaign",
"PostFollow",
"ImportMap",
"Goal",
"AsyncOperation",
"ProcessSession",
"UserQuery",
"ActivityPointer",
"List",
"ServiceAppointment"};

     //A filter expression to limit entities returned to non-intersect, user-owned entities not found in the list of excluded entities.
     MetadataFilterExpression EntityFilter = new MetadataFilterExpression(LogicalOperator.And);
     EntityFilter.Conditions.Add(new MetadataConditionExpression("IsIntersect", MetadataConditionOperator.Equals, false));
     EntityFilter.Conditions.Add(new MetadataConditionExpression("OwnershipType", MetadataConditionOperator.Equals, OwnershipTypes.UserOwned));
     EntityFilter.Conditions.Add(new MetadataConditionExpression("SchemaName", MetadataConditionOperator.NotIn, excludedEntities));
     MetadataConditionExpression isVisibileInMobileTrue = new MetadataConditionExpression("IsVisibleInMobile", MetadataConditionOperator.Equals, true);
     EntityFilter.Conditions.Add(isVisibileInMobileTrue);

Specify the properties you want

The Properties property accepts a MetadataPropertiesExpression. You can set MetadataPropertiesExpression.AllProperties to true if you want to return all the properties or you can provide a collection of strings to the MetadataPropertiesExpression.PropertyNames to define which properties you want to include in the results.

The strongly typed objects returned will include all properties, but only those that you request will have data. All other properties will be null, with the following few exceptions: every item of metadata will include the MetadataId ,LogicalName and HasChanged values if they exist for that item. You do not have to specify them in the Properties you request.

If you are not using managed code and are actually parsing the responseXML returned from the XMLHttpRequest you will get elements for each property but only those you request will contain data. The following XML shows the contact entity metadata xml that will be returned when IsVisibleInMobile is the only property requested.

Xml Copy Code
<a:EntityMetadata>
 <c:MetadataId>608861bc-50a4-4c5f-a02c-21fe1943e2cf</c:MetadataId>
 <c:HasChanged i:nil="true"/>
 <c:ActivityTypeMask i:nil="true"/>
 <c:Attributes i:nil="true"/>
 <c:AutoRouteToOwnerQueue i:nil="true"/>
 <c:CanBeInManyToMany i:nil="true"/>
 <c:CanBePrimaryEntityInRelationship i:nil="true"/>
 <c:CanBeRelatedEntityInRelationship i:nil="true"/>
 <c:CanCreateAttributes i:nil="true"/>
 <c:CanCreateCharts i:nil="true"/>
 <c:CanCreateForms i:nil="true"/>
 <c:CanCreateViews i:nil="true"/>
 <c:CanModifyAdditionalSettings i:nil="true"/>
 <c:CanTriggerWorkflow i:nil="true"/>
 <c:Description i:nil="true"/>
 <c:DisplayCollectionName i:nil="true"/>
 <c:DisplayName i:nil="true"/>
 <c:IconLargeName i:nil="true"/>
 <c:IconMediumName i:nil="true"/>
 <c:IconSmallName i:nil="true"/>
 <c:IsActivity i:nil="true"/>
 <c:IsActivityParty i:nil="true"/>
 <c:IsAuditEnabled i:nil="true"/>
 <c:IsAvailableOffline i:nil="true"/>
 <c:IsChildEntity i:nil="true"/>
 <c:IsConnectionsEnabled i:nil="true"/>
 <c:IsCustomEntity i:nil="true"/>
 <c:IsCustomizable i:nil="true"/>
 <c:IsDocumentManagementEnabled i:nil="true"/>
 <c:IsDuplicateDetectionEnabled i:nil="true"/>
 <c:IsEnabledForCharts i:nil="true"/>
 <c:IsImportable i:nil="true"/>
 <c:IsIntersect i:nil="true"/>
 <c:IsMailMergeEnabled i:nil="true"/>
 <c:IsManaged i:nil="true"/>
 <c:IsMappable i:nil="true"/>
 <c:IsReadingPaneEnabled i:nil="true"/>
 <c:IsRenameable i:nil="true"/>
 <c:IsValidForAdvancedFind i:nil="true"/>
 <c:IsValidForQueue i:nil="true"/>
 <c:IsVisibleInMobile>
  <a:CanBeChanged>false</a:CanBeChanged>
  <a:ManagedPropertyLogicalName>canmodifymobilevisibility</a:ManagedPropertyLogicalName>
  <a:Value>false</a:Value>
 </c:IsVisibleInMobile>
 <c:LogicalName>contact</c:LogicalName>
 <c:ManyToManyRelationships i:nil="true"/>
 <c:ManyToOneRelationships i:nil="true"/>
 <c:ObjectTypeCode i:nil="true"/>
 <c:OneToManyRelationships i:nil="true"/>
 <c:OwnershipType i:nil="true"/>
 <c:PrimaryIdAttribute i:nil="true"/>
 <c:PrimaryNameAttribute i:nil="true"/>
 <c:Privileges i:nil="true"/>
 <c:RecurrenceBaseEntityLogicalName i:nil="true"/>
 <c:ReportViewName i:nil="true"/>
 <c:SchemaName i:nil="true"/>
</a:EntityMetadata>

In a future release further efficiencies may be achieved by not returning elements with null values for properties that were not requested. If you write code to parse this XML you should expect that the XML returned for the same query could be reduced to only the following XML.

Xml Copy Code
<a:EntityMetadata>
 <c:MetadataId>608861bc-50a4-4c5f-a02c-21fe1943e2cf</c:MetadataId>
 <c:IsVisibleInMobile>
  <a:CanBeChanged>false</a:CanBeChanged>
  <a:ManagedPropertyLogicalName>canmodifymobilevisibility</a:ManagedPropertyLogicalName>
  <a:Value>false</a:Value>
 </c:IsVisibleInMobile>
 <c:LogicalName>contact</c:LogicalName>
</a:EntityMetadata>

Metadata is returned in a hierarchical structure just as it is using the RetrieveAllEntitiesRequest. To access a specific attribute or relationship you must create a query that returns the entity they are part of. If you want to retrieve data about a specific attribute, you must include the EntityMetadata.Attributes property in your EntityQueryExpression.Properties. For the entity relationships to be returned, you must include one or more of the following EntityMetadata properties: ManyToManyRelationships, ManyToOneRelationships, or OneToManyRelationships.

The following example will return the Attributes property for requested entities:

C# Copy Code
//A properties expression to limit the properties to be included with entities
MetadataPropertiesExpression EntityProperties = new MetadataPropertiesExpression()
{
 AllProperties = false
};
EntityProperties.PropertyNames.AddRange(new string[] { "Attributes" });

Retrieve attribute metadata

The EntityQueryExpression.AttributeQuery property accepts an AttributeQueryExpression that defines Criteria and Properties for attributes to be returned for the entities that match the EntityQueryExpression Criteria and Properties.

The following table lists AttributeMetadata properties that cannot be used in a MetadataFilterExpression

Description | DisplayName
OptionSet | Targets

The following example will limit Attributes returned to only those that have an OptionSet and will only return the OptionSet and AttributeType properties for those attributes:

C# Copy Code
//A condition expresson to return optionset attributes
MetadataConditionExpression[] optionsetAttributeTypes = new MetadataConditionExpression[] {
new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Picklist),
new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.State),
new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Status),
new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Boolean)
};

//A filter expression to apply the optionsetAttributeTypes condition expression
MetadataFilterExpression AttributeFilter = new MetadataFilterExpression(LogicalOperator.Or);
AttributeFilter.Conditions.AddRange(optionsetAttributeTypes);

//A Properties expression to limit the properties to be included with attributes
MetadataPropertiesExpression AttributeProperties = new MetadataPropertiesExpression() { AllProperties = false };
AttributeProperties.PropertyNames.Add("OptionSet");
AttributeProperties.PropertyNames.Add("AttributeType");

Retrieve relationship metadata

The EntityQueryExpression.RelationshipQuery property accepts a RelationshipQueryExpression to specify the entity relationship Criteria and Properties you want for the entities that match the EntityQueryExpression Criteria and Properties.

Use the RelationshipType property in your criteria to specify whether you want to return ManyToMany Relationships or OneToMany Relationships.

The following table lists Relationship metadata properties that cannot be used in a MetadataFilterExpression:

OneToManyRelationshipMetadata.AssociatedMenuConfiguration

OneToManyRelationshipMetadata.CascadeConfiguration

ManyToManyRelationshipMetadata.Entity1AssociatedMenuConfiguration

ManyToManyRelationshipMetadata.Entity2AssociatedMenuConfiguration

Retrieve labels

Finally, the EntityQueryExpression.LabelQuery property accepts a LabelQueryExpression that lets you specify one or more integer LCID values for to determine which localized labels to return. Valid locale ID values can be found at Locale ID (LCID) Chart. If an organization has many language packs installed the labels for all languages will be returned unless you specify a LabelQuery.

The following example defines a LabelQueryExpression that will limit labels to only those representing the users preferred language.

C# Copy Code
private Guid _userId;
private int _languageCode;

Retrieve new or changed metadata

The RetrieveMetadataChangesResponse class returns a strongly typed EntityMetadataCollection that contains the requested data. The RetrieveMetadataChangesResponse class also provides a ServerVersionStamp value that you can pass to the RetrieveMetadataChangesRequest.ClientVersionStamp property in later requests. When a value is included for the ClientVersionStamp property, only data that matches the EntityQueryExpression and has changed since the ClientVersionStamp was retrieved will be returned. The only exception to this is when your EntityQueryExpression.Properties includes EntityMetadata.Privileges. Privileges will always be returned regardless of the ClientVersionStamp. This way your application can determine whether any important changes have occurred that you care about since you last queried the metadata. You can then merge any new or changed metadata into your persistent metadata cache so that your application will be able to avoid the performance issues with downloading metadata you may not need.

The HasChanged property provides a way to detect which child elements in a metadata item have changed. Because all the metadata is returned as part of the containing metadata item, when the label of a OptionMetadata has changed, the containing EntityMetadata, AttributeMetadata, and OptionSetMetadata properties are returned. However, the HasChanged property will be false for those containing metadata items. Only the OptionMetadata HasChanged property will be true.

The following example makes an initial request by defining an EntityQueryExpression and executing a request with a ClientVersionStamp set to null.

C# Copy Code
//An entity query expression to combine the filter expressions and property expressions for the query.
EntityQueryExpression entityQueryExpression = new EntityQueryExpression()
{

 Criteria = EntityFilter,
 Properties = EntityProperties,
 AttributeQuery = new AttributeQueryExpression()
 {
  Criteria = AttributeFilter,
  Properties = AttributeProperties
 },
 LabelQuery = labelQuery

};

//Retrieve the metadata for the query without a ClientVersionStamp
RetrieveMetadataChangesResponse initialRequest = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);

   ...

protected RetrieveMetadataChangesResponse getMetadataChanges(
 EntityQueryExpression entityQueryExpression,
 String clientVersionStamp,
 DeletedMetadataFilters deletedMetadataFilter)
{
 RetrieveMetadataChangesRequest retrieveMetadataChangesRequest = new RetrieveMetadataChangesRequest()
 {
  Query = entityQueryExpression,
  ClientVersionStamp = clientVersionStamp,
  DeletedMetadataFilters = deletedMetadataFilter
 };

 return (RetrieveMetadataChangesResponse)_service.Execute(retrieveMetadataChangesRequest);

}

Retrieve information about deleted metadata

The RetrieveMetadataChangesResponse.DeletedMetadata property will return a DeletedMetadataCollection when the ClientVersionStamp and DeletedMetadataFilters properties are set on the RetrieveMetadataChangesRequest. The DeletedMetadataCollection contains the MetadataId values of any EntityMetadata, AttributeMetadata or RelationshipMetadataBase objects that have been deleted from the system in a time limit. For more information, see Deleted metadata expiration.

Use the DeletedMetadataFilters enumeration with the RetrieveMetadataChangesRequest.DeletedMetadataFilters to limit the information to only those types of metadata you are interested in. The DeletedMetadataFilters enumeration provides the following options:

  • DeletedMetadataFilters.Entity (Default)
  • DeletedMetadataFilters.Attribute
  • DeletedMetadataFilters.Relationship
  • DeletedMetadataFilters.Label
  • DeletedMetadataFilters.OptionSet

You will also use DeletedMetadataFilters enumeration as a key to the RetrieveMetadataChangesResponse.DeletedMetadata to filter the GUID values found in the RetrieveMetadataChangesResponse.DeletedMetadata property.

When you design a metadata cache you will want to use the MetadataId for each item so that you can identify deleted metadata items and remove them.

Deleted metadata expiration

Any metadata items that are deleted are tracked for a limited period of time specified by the Organization.ExpireSubscriptionsInDays value. By default this value is 90 days. If the RetrieveMetadataChangesRequest.ClientVersionStamp value indicates that the last metadata query was from before the expiration date, the service will throw an ExpiredVersionStamp error (0x80044352), When you are retrieving data to refresh and existing metadata cache you should always try to catch this error and be prepared to re-initialize your metadata cache with the results from a second request passed without a ClientVersionStamp. The ExpiredVersionStamp error is also thrown when changes on the server, such as changes to the ExpireSubscriptionsInDays value, affect accurately tracking the deleted metadata.

The following example passes a ClientVersionStamp and catches the ExpiredVersionStamp. If the error is caught the cache is reinitialized by passing in a new request with the ClientVersionStamp set to null.

C# Copy Code
protected String updateOptionLabelList(EntityQueryExpression entityQueryExpression, String clientVersionStamp)
{
 //Retrieve metadata changes and add them to the cache
 RetrieveMetadataChangesResponse updateResponse;
 try
 {
  updateResponse = getMetadataChanges(entityQueryExpression, clientVersionStamp, DeletedMetadataFilters.OptionSet);
  addOptionLabelsToCache(updateResponse.EntityMetadata, true);
  removeOptionLabelsFromCache(updateResponse.DeletedMetadata, true);

 }
 catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
 {
  // Check for ErrorCodes.ExpiredVersionStamp (0x80044352)
  // Will occur when the timestamp exceeds the Organization.ExpireSubscriptionsInDays value, which is 90 by default.
  if (ex.Detail.ErrorCode == unchecked((int)0x80044352))
  {
   //reinitialize cache
   _optionLabelList.Clear();

   updateResponse = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);
   //Add them to the cache and display the changes
   addOptionLabelsToCache(updateResponse.EntityMetadata, true);

  }
  else
  {
   throw ex;
  }

 }
 return updateResponse.ServerVersionStamp;
}

Performance when retrieving deleted metadata

When a metadata item is deleted it is saved in the database and not in the Microsoft CRM metadata cache. Although the deleted metadata is limited to just the MetadataId and the type of metadata item, accessing the database is an operation that will require more server resources than just querying for changes.

See Also

Concepts

Offline use of the Microsoft Dynamics CRM services
Customize entity metadata
Customize entity attribute metadata
Customize entity relationship metadata

Other Resources

Write applications and server extensions
Sample: Query metadata and detect changes
Extend the metadata model
Query Metadata Using JavaScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Query metadata and detect changes
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package.

The sample code can be found in the following locations in the download package:

SampleCode\CS\Metadata\MetadataQuery\MetadataQuerySample.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to use the classes and methods in the Microsoft.Xrm.Sdk.Metadata.Query and Microsoft.Xrm.Sdk.Metadata namespaces to query for specific items of metadata and then track changes to the organization metadata.

Example

This sample creates an in-memory cache of all option-set option labels for certain entities. Then, a custom entity that contains OptionSet attributes is added and the cache of option-set option labels is updated. Then a single option is added to one of the custom OptionSet attributes and the cache is updated to add it. Finally, the custom entity is deleted and the cache of option-set option labels is again updated to reflect this change.

The sample will display output similar to the following when it is complete.

  • 463 option labels for 5 entities added to the cache.
  • ClientVersionStamp: 296297!10/22/2012 21:41:57
  • Adding a custom entity named sample_SampleEntityForMetadataQuery with a custom optionset attribute named : sample_ExampleOptionSet
  • 8 option labels for 1 entities were added to the cache.
  • 471 Option Labels cached
  • No Option Labels removed.
  • ClientVersionStamp: 296646!10/22/2012 21:42:06
  • Adding an additional option to the sample_ExampleOptionSet attribute options.
  • 1 option labels for 1 entities were added to the cache.
  • 472 Option Labels cached
  • No Option Labels removed.
  • ClientVersionStamp: 296649!10/22/2012 21:42:16
  • Current Options: 472
  • Deleting the sample_SampleEntityForMetadataQuery custom entity
  • No option labels were added to the cache.
  • 9 Option Labels removed
  • 463 Total Option Labels currently cached
  • ClientVersionStamp: 297079!10/22/2012 21:42:34
C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.IO;
using System.Collections.Generic;
// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Metadata.Query;

namespace Microsoft.Crm.Sdk.Samples
{
 public class MetadataQuerySample
 {
  #region Class Level Members

  private OrganizationServiceProxy _serviceProxy;
  private IOrganizationService _service;
  private List<OptionSetOption> _optionLabelList = new List<OptionSetOption>();
  private String _customEntitySchemaName = "sample_SampleEntityForMetadataQuery";
  private String _customAttributeSchemaName = "sample_ExampleOptionSet";
  private Guid _userId;
  private int _languageCode;

  #endregion Class Level Members

  /// <summary>
  /// This method connects to the Organization _service.
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>

  public void Run(ServerConnection.Configuration serverConfig)
  {
   try
   {

    // Connect to the Organization _service.
    // The using statement assures that the _service proxy will be properly disposed.
       using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri, serverConfig.Credentials, serverConfig.DeviceCredentials))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();

     _service = (IOrganizationService)_serviceProxy;
     _userId = ((WhoAmIResponse)_service.Execute(new WhoAmIRequest())).UserId;
     _languageCode = RetrieveUserUILanguageCode(_userId);

     // An array SchemaName values for non-intersect, user-owned entities that should not be returned.
     String[] excludedEntities = {
"WorkflowLog",
"Template",
"CustomerOpportunityRole",
"Import",
"UserQueryVisualization",
"UserEntityInstanceData",
"ImportLog",
"RecurrenceRule",
"QuoteClose",
"UserForm",
"SharePointDocumentLocation",
"Queue",
"DuplicateRule",
"OpportunityClose",
"Workflow",
"RecurringAppointmentMaster",
"CustomerRelationship",
"Annotation",
"SharePointSite",
"ImportData",
"ImportFile",
"OrderClose",
"Contract",
"BulkOperation",
"CampaignResponse",
"Connection",
"Report",
"CampaignActivity",
"UserEntityUISettings",
"IncidentResolution",
"GoalRollupQuery",
"MailMergeTemplate",
"Campaign",
"PostFollow",
"ImportMap",
"Goal",
"AsyncOperation",
"ProcessSession",
"UserQuery",
"ActivityPointer",
"List",
"ServiceAppointment"};

     //A filter expression to limit entities returned to non-intersect, user-owned entities not found in the list of excluded entities.
     MetadataFilterExpression EntityFilter = new MetadataFilterExpression(LogicalOperator.And);
     EntityFilter.Conditions.Add(new MetadataConditionExpression("IsIntersect", MetadataConditionOperator.Equals, false));
     EntityFilter.Conditions.Add(new MetadataConditionExpression("OwnershipType", MetadataConditionOperator.Equals, OwnershipTypes.UserOwned));
     EntityFilter.Conditions.Add(new MetadataConditionExpression("SchemaName", MetadataConditionOperator.NotIn, excludedEntities));
     MetadataConditionExpression isVisibileInMobileTrue = new MetadataConditionExpression("IsVisibleInMobile", MetadataConditionOperator.Equals, true);
     EntityFilter.Conditions.Add(isVisibileInMobileTrue);

     //A properties expression to limit the properties to be included with entities
     MetadataPropertiesExpression EntityProperties = new MetadataPropertiesExpression()
     {
      AllProperties = false
     };
     EntityProperties.PropertyNames.AddRange(new string[] { "Attributes" });

     //A condition expresson to return optionset attributes
     MetadataConditionExpression[] optionsetAttributeTypes = new MetadataConditionExpression[] {
     new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Picklist),
     new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.State),
     new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Status),
     new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Boolean)
     };

     //A filter expression to apply the optionsetAttributeTypes condition expression
     MetadataFilterExpression AttributeFilter = new MetadataFilterExpression(LogicalOperator.Or);
     AttributeFilter.Conditions.AddRange(optionsetAttributeTypes);

     //A Properties expression to limit the properties to be included with attributes
     MetadataPropertiesExpression AttributeProperties = new MetadataPropertiesExpression() { AllProperties = false };
     AttributeProperties.PropertyNames.Add("OptionSet");
     AttributeProperties.PropertyNames.Add("AttributeType");

     //A label query expression to limit the labels returned to only those for the user's preferred language
     LabelQueryExpression labelQuery = new LabelQueryExpression();
     labelQuery.FilterLanguages.Add(_languageCode);

     //An entity query expression to combine the filter expressions and property expressions for the query.
     EntityQueryExpression entityQueryExpression = new EntityQueryExpression()
     {

      Criteria = EntityFilter,
      Properties = EntityProperties,
      AttributeQuery = new AttributeQueryExpression()
      {
       Criteria = AttributeFilter,
       Properties = AttributeProperties
      },
      LabelQuery = labelQuery

     };

     //Retrieve the metadata for the query without a ClientVersionStamp
     RetrieveMetadataChangesResponse initialRequest = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);

     //Add option labels to the cache and display the changes
     addOptionLabelsToCache(initialRequest.EntityMetadata, false);
     String ClientVersionStamp = initialRequest.ServerVersionStamp;
     Console.WriteLine("{0} option labels for {1} entities added to the cache.",
      _optionLabelList.Count,
      initialRequest.EntityMetadata.Count);
     Console.WriteLine("");
     Console.WriteLine("ClientVersionStamp: {0}", ClientVersionStamp);
     Console.WriteLine("");

     //Add new custom entity with optionset
     Console.WriteLine("Adding a custom entity named {0} with a custom optionset attribute named : {1}",
      _customEntitySchemaName, _customAttributeSchemaName);
     Console.WriteLine("");
     addCustomEntityWithOptionSet();
     //Publishing isn't necessary when adding a custom entity

     //Add new option labels to the cache and display the results
     ClientVersionStamp = updateOptionLabelList(entityQueryExpression, ClientVersionStamp);

     Console.WriteLine("ClientVersionStamp: {0}", ClientVersionStamp);
     Console.WriteLine("");

     //Add a new option to the custom optionset in the custom entity and publish the custom entity
     Console.WriteLine("Adding an additional option to the {0} attribute options.",
      _customAttributeSchemaName);
     Console.WriteLine("");
     addOptionToCustomEntityOptionSet();
     //It is necessary to publish updates to metadata. Create and Delete operations are published automatically.
     publishUpdatedEntity();

     //Add the new option label to the cache and display the results
     ClientVersionStamp = updateOptionLabelList(entityQueryExpression, ClientVersionStamp);

     Console.WriteLine("ClientVersionStamp: {0}", ClientVersionStamp);
     Console.WriteLine("");

     Console.WriteLine("");
     Console.WriteLine("Current Options: {0}", _optionLabelList.Count.ToString());
     Console.WriteLine("");

     //Delete the custom entity
     Console.WriteLine("");
     Console.WriteLine("Deleting the {0} custom entity",
      _customEntitySchemaName);
     Console.WriteLine("");
     deleteCustomEntityWithOptionSet();
     //Publishing isn't necessary when deleting a custom entity

     //Retrieve metadata changes to remove option labels from deleted attributes and display the results
     ClientVersionStamp = updateOptionLabelList(entityQueryExpression, ClientVersionStamp);

     Console.WriteLine("ClientVersionStamp: {0}", ClientVersionStamp);
     Console.WriteLine("");

    }

   }

   // Catch any _service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  protected RetrieveMetadataChangesResponse getMetadataChanges(
   EntityQueryExpression entityQueryExpression,
   String clientVersionStamp,
   DeletedMetadataFilters deletedMetadataFilter)
  {
   RetrieveMetadataChangesRequest retrieveMetadataChangesRequest = new RetrieveMetadataChangesRequest()
   {
    Query = entityQueryExpression,
    ClientVersionStamp = clientVersionStamp,
    DeletedMetadataFilters = deletedMetadataFilter
   };

   return (RetrieveMetadataChangesResponse)_service.Execute(retrieveMetadataChangesRequest);

  }

  protected String updateOptionLabelList(EntityQueryExpression entityQueryExpression, String clientVersionStamp)
  {
   //Retrieve metadata changes and add them to the cache
   RetrieveMetadataChangesResponse updateResponse;
   try
   {
    updateResponse = getMetadataChanges(entityQueryExpression, clientVersionStamp, DeletedMetadataFilters.OptionSet);
    addOptionLabelsToCache(updateResponse.EntityMetadata, true);
    removeOptionLabelsFromCache(updateResponse.DeletedMetadata, true);

   }
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    // Check for ErrorCodes.ExpiredVersionStamp (0x80044352)
    // Will occur when the timestamp exceeds the Organization.ExpireSubscriptionsInDays value, which is 90 by default.
    if (ex.Detail.ErrorCode == unchecked((int)0x80044352))
    {
     //reinitialize cache
     _optionLabelList.Clear();

     updateResponse = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);
     //Add them to the cache and display the changes
     addOptionLabelsToCache(updateResponse.EntityMetadata, true);

    }
    else
    {
     throw ex;
    }

   }
   return updateResponse.ServerVersionStamp;
  }
  protected void addOptionLabelsToCache(EntityMetadataCollection entityMetadataCollection, Boolean showChanges)
  {

   List<OptionSetOption> changes = new List<OptionSetOption>();

   foreach (EntityMetadata em in entityMetadataCollection)
   {
    foreach (AttributeMetadata am in em.Attributes)
    {
     switch (am.AttributeType)
     {
      case AttributeTypeCode.Boolean:
       BooleanAttributeMetadata booleanAttribute = (BooleanAttributeMetadata)am;
       //Labels will not be included if they aren't new
       if (booleanAttribute.OptionSet.FalseOption.Label.UserLocalizedLabel != null)
       {
        changes.Add(new OptionSetOption(
        (Guid)booleanAttribute.OptionSet.MetadataId,
        0,
        booleanAttribute.OptionSet.FalseOption.Label.UserLocalizedLabel.Label)
        );
       }
       //Labels will not be included if they aren't new
       if (booleanAttribute.OptionSet.TrueOption.Label.UserLocalizedLabel != null)
       {
        changes.Add(new OptionSetOption(
        (Guid)booleanAttribute.OptionSet.MetadataId,
        1,
        booleanAttribute.OptionSet.TrueOption.Label.UserLocalizedLabel.Label));
       }
       break;
      default:
       EnumAttributeMetadata optionsetAttribute = (EnumAttributeMetadata)am;
       foreach (OptionMetadata option in optionsetAttribute.OptionSet.Options)
       {
        //Labels will not be included if they aren't new
        if (option.Label.UserLocalizedLabel != null)
        {
         changes.Add(new OptionSetOption(
          (Guid)optionsetAttribute.OptionSet.MetadataId,
         (int)option.Value,
         option.Label.UserLocalizedLabel.Label));
        }
       }
       break;
     }
    }
   }

   _optionLabelList.AddRange(changes);

   if (showChanges)
   {

    if (changes.Count > 0)
    {
     Console.WriteLine("{0} option labels for {1} entities were added to the cache.", changes.Count, entityMetadataCollection.Count);
     Console.WriteLine("{0} Option Labels cached", _optionLabelList.Count);
    }
    else
    { Console.WriteLine("No option labels were added to the cache."); }

   }
  }
  protected void removeOptionLabelsFromCache(DeletedMetadataCollection DeletedMetadata, Boolean showChanges)
  {
   List<OptionSetOption> optionSetOptionsToRemove = new List<OptionSetOption>();

   if (DeletedMetadata.Keys.Contains(DeletedMetadataFilters.OptionSet))
   {
    DataCollection<Guid> optionsetmetadataids = (DataCollection<Guid>)DeletedMetadata[DeletedMetadataFilters.OptionSet];
    foreach (Guid metadataid in optionsetmetadataids)
    {
     foreach (OptionSetOption oso in _optionLabelList)
     {
      if (metadataid == oso.optionsetId)
      {
       optionSetOptionsToRemove.Add(oso);
      }
     }
    }
   }
   foreach (OptionSetOption option in optionSetOptionsToRemove)
   {
    _optionLabelList.Remove(option);
   }
   if (showChanges)
   {
    if (optionSetOptionsToRemove.Count > 0)
    {
     Console.WriteLine("{0} Option Labels removed", optionSetOptionsToRemove.Count);
     Console.WriteLine("{0} Total Option Labels currently cached", _optionLabelList.Count);
     Console.WriteLine("");
    }
    else
    {
     Console.WriteLine("No Option Labels removed.");
     Console.WriteLine("");
    }

   }
  }

  protected void addCustomEntityWithOptionSet()
  {
   String primaryAttributeSchemaName = "sample_SampleEntityForMetadataQueryName";

   CreateEntityRequest createEntityRequest = new CreateEntityRequest
   {

    //Define the entity
    Entity = new EntityMetadata
    {
     SchemaName = _customEntitySchemaName,
     LogicalName = _customEntitySchemaName.ToLower(),
     DisplayName = new Label("Entity for MetadataQuery Sample", _languageCode),
     DisplayCollectionName = new Label("Entity for MetadataQuery Sample", _languageCode),
     Description = new Label("An entity created for the MetadataQuery Sample", _languageCode),
     OwnershipType = OwnershipTypes.UserOwned,
     IsVisibleInMobile = new BooleanManagedProperty(true),
     IsActivity = false,

    },

    // Define the primary attribute for the entity

    PrimaryAttribute = new StringAttributeMetadata
    {
     SchemaName = primaryAttributeSchemaName,
     LogicalName = primaryAttributeSchemaName.ToLower(),
     RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
     MaxLength = 100,
     Format = StringFormat.Text,
     DisplayName = new Label("Entity for MetadataQuery Sample Name", _languageCode),
     Description = new Label("The primary attribute for the Bank Account entity.", _languageCode)
    }

   };
_service.Execute(createEntityRequest);

   //PublishXmlRequest publishXmlRequest = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><entities><entity>{0}</entity></entities></importexportxml>", _customEntitySchemaName.ToLower()) };
   //_service.Execute(publishXmlRequest);

   //Add an optionset attribute

   CreateAttributeRequest createAttributeRequest = new CreateAttributeRequest
   {
    EntityName = _customEntitySchemaName.ToLower(),
    Attribute = new PicklistAttributeMetadata
    {
     SchemaName = _customAttributeSchemaName,
     DisplayName = new Label("Example OptionSet for MetadataQuery Sample", _languageCode),
     RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),

     OptionSet = new OptionSetMetadata
     {
      IsGlobal = false,
      OptionSetType = OptionSetType.Picklist,
      Options =  {
       new OptionMetadata(new Label("First Option",_languageCode),null),
       new OptionMetadata(new Label("Second Option",_languageCode),null),
       new OptionMetadata(new Label("Third Option",_languageCode),null),
       new OptionMetadata(new Label("Fourth Option",_languageCode),null)
      }
     }
    }
   };

   _service.Execute(createAttributeRequest);

  }

  protected void addOptionToCustomEntityOptionSet()
  {

   InsertOptionValueRequest insertOptionValueRequest =
    new InsertOptionValueRequest
    {
     AttributeLogicalName = _customAttributeSchemaName.ToLower(),
     EntityLogicalName = _customEntitySchemaName.ToLower(),
     Label = new Label("Fifth Option", _languageCode)
    };

   _service.Execute(insertOptionValueRequest);

  }

  protected void deleteCustomEntityWithOptionSet()
  {

   DeleteEntityRequest request = new DeleteEntityRequest()
   {
    LogicalName = _customEntitySchemaName.ToLower(),
   };
   _service.Execute(request);

  }
  protected int RetrieveUserUILanguageCode(Guid userId)
  {
   QueryExpression userSettingsQuery = new QueryExpression("usersettings");
   userSettingsQuery.ColumnSet.AddColumns("uilanguageid", "systemuserid");
   userSettingsQuery.Criteria.AddCondition("systemuserid", ConditionOperator.Equal, userId);
   EntityCollection userSettings = _service.RetrieveMultiple(userSettingsQuery);
   if (userSettings.Entities.Count > 0)
   {
    return (int)userSettings.Entities[0]["uilanguageid"];
   }
   return 0;
  }

  protected void publishUpdatedEntity()
  {
   PublishXmlRequest publishXmlRequest = new PublishXmlRequest
   {
    ParameterXml = "<importexportxml><entities><entity>" + _customEntitySchemaName.ToLower() + "</entity></entities></importexportxml>"
   };
   _service.Execute(publishXmlRequest);
  }

  #region Main method

  /// <summary>
  /// Based on the Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    MetadataQuerySample app = new MetadataQuerySample();
    app.Run(config);
   }

   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "Has Inner Fault" : "No Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "Has Inner Fault" : "No Inner Fault");
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "Has Inner Fault" : "No Inner Fault");
     }
    }
   }

    //Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   //SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {
    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }
  }
  #endregion Main method

 }

 public class OptionSetOption {
  public OptionSetOption(Guid OptionsetId, int OptionValue, String Label)
 {
  this._optionsetId = OptionsetId;
  this._optionValue = OptionValue;
  this._label = Label;
 }

  private Guid _optionsetId;
  private int _optionValue;
  private String _label;

  public Guid optionsetId { get { return this._optionsetId; } }
  public int optionValue { get { return this._optionValue; } }
  public String lable { get { return this._label; } }
 }

}

See Also

Concepts

Retrieve and detect changes to metadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Offline use of the Microsoft Dynamics CRM services

Both Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access enables you to continue your work when you are disconnected from the server.

In addition, the event and plug-in infrastructure lets you leverage development investments across solutions by using the same APIs and programming model. The IOrganizationService methods and the Microsoft Dynamics CRM OData service methods function both online and offline. When using a method such as Create or Update offline, the data is written locally and then when the user connects to the server, the actions are played back to the server.

For more information about whether a message is supported offline, see Microsoft.Crm.Sdk.Messages. You can also determine whether a IOrganizationService message works offline by checking the SdkMessage.Availability attribute for the desired message. If the message works for multiple entity types, you must also check the SdkMessageFilter.Availability attribute to see whether the message is available offline for the entity you want to work with. For example, the Create message is available offline, but not for the queue, user, or site entities.

Tracing can be enabled on the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access for debugging. For more information about the event viewer and platform tracing, see Monitoring and troubleshooting Microsoft Dynamics CRM.

See Also

Reference

Create
Update

Concepts

Organization service methods

Other Resources

Write applications and server extensions
Troubleshooting and error handling
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Troubleshooting and error handling

This section includes information about how to handle exceptions received from the Microsoft Dynamics CRM web services, how to troubleshoot your application, and other related topics.

In This Section

Handle exceptions in your code

Troubleshooting tips

Web service error codes

Related Sections

Write applications and server extensions

Handle exceptions in plug-ins

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Handle exceptions in your code

There are a number of exceptions that can be returned from a Microsoft Dynamics CRM web service method call. Your application design must catch and appropriately handle these exceptions. In the Microsoft Dynamics CRM SDK, all web service method calls use a communication channel to the server based on the Windows Communication Foundation (WCF) technology. In WCF terms, exceptions returned from the channel are called faults.

In this topic

Common exceptions and faults

Custom errors from business rules

Additional information about exceptions

Common exceptions and faults

The following code is used in most Microsoft Dynamics CRM SDK samples. It highlights the common faults and exceptions that your application design should handle.

C# Copy Code
catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
{
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
}
catch (System.TimeoutException ex)
{
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
}
catch (System.Exception ex)
{
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
        Console.WriteLine(ex.InnerException.Message);

        FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
            as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
        if (fe != null)
        {
            Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
            Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
            Console.WriteLine("Message: {0}", fe.Detail.Message);
            Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
            Console.WriteLine("Inner Fault: {0}",
                null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
        }
    }
}

Note
If you’re accessing the Discovery web service, your code should catch DiscoveryServiceFault instead of the OrganizationServiceFault fault shown previously.

In addition to these exceptions and faults, your code must handle the following exceptions:

  • SecurityTokenValidationException
  • ExpiredSecurityTokenException
  • SecurityAccessDeniedException
  • MessageSecurityException
  • SecurityNegotiationException

When connecting to Microsoft Dynamics CRM Online, a SecurityAccessDeniedException exception can be thrown if you use a valid Microsoft account and your account is not associated with any Microsoft Dynamics CRM Online organization. A MessageSecurityException can be thrown if your Microsoft account isn’t valid or there was an authentication failure.

Custom errors from business rules

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online, customizers can create business rules that are evaluated on the server. Customizers can throw error messages based on conditions set in the business rule. Developers should be sure to include robust error handling in their code to catch and handle these exceptions.

The following is an example of the trace log produced when one of these errors is returned from a business rule named “Name of Entity Scope Business Rule returning Error” and the error message is “custom error message”.

Copy Code
Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=7.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: custom error messageDetail:
<OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
  <ErrorCode>-2147220891</ErrorCode>
  <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic">
    <KeyValuePairOfstringanyType>
      <d2p1:key>OperationStatus</d2p1:key>
      <d2p1:value xmlns:d4p1="http://www.w3.org/2001/XMLSchema" i:type="d4p1:string">0</d2p1:value>
    </KeyValuePairOfstringanyType>
    <KeyValuePairOfstringanyType>
      <d2p1:key>SubErrorCode</d2p1:key>
      <d2p1:value xmlns:d4p1="http://www.w3.org/2001/XMLSchema" i:type="d4p1:string">-2146233088</d2p1:value>
    </KeyValuePairOfstringanyType>
  </ErrorDetails>
  <Message>custom error message</Message>
  <Timestamp>2014-09-04T17:43:16.8197965Z</Timestamp>
  <InnerFault i:nil="true" />
  <TraceText>

[Microsoft.Crm.ObjectModel: Microsoft.Crm.ObjectModel.SyncWorkflowExecutionPlugin]
[cf6a25a9-5a34-e411-80b9-00155dd8c20f: ]
Starting sync workflow 'Name of Entity Scope Business Rule returning Error', Id: c76a25a9-5a34-e411-80b9-00155dd8c20f
Entering ConditionStep1_step:
Entering SetMessage_step:
Sync workflow 'Name of Entity Scope Business Rule returning Error' terminated with error 'custom error message'

</TraceText>
</OrganizationServiceFault>

More information: Customization Guide topic Create and edit Business Rules.

Additional information about exceptions

When an uncaught exception is thrown that contains sensitive information that the user doesn’t have permission to see, the sensitive information in the exception is hidden from the user and a reference number is provided. This reference number refers to the related server event log entry and server trace entry. A system administrator can look up those entries and find more information about the exception.

See Also

Reference

Web service error codes

Concepts

Troubleshooting tips
Handle exceptions in plug-ins

Other Resources

Troubleshooting and error handling
.NET Framework Developer Center

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Troubleshooting tips

The following information is provided as an aid in diagnosing certain common issues that may arise when developing Microsoft Dynamics CRM SDK based applications. More content will be added to this topic as time goes on.

For more information about enabling tracing in an on-premises Microsoft Dynamics CRM 2015 server, see Monitor and troubleshooting Microsoft Dynamics CRM.

Handle the MessageSecurityException exception when you use the CRM web services

When you use the CRM APIs to connect to the Microsoft Dynamics CRM Online organization or discovery services you could receive the following exception:

Unhandled Exception: System.ServiceModel.Security.MessageSecurityException: An unsecured or incorrectly secured fault was received from the other party. See the inner FaultException for the fault code and detail.

To fix this, you can try deleting the device registration folder named LiveDeviceID in your profile folder C:\Users\<username>. Then, try to connect again.

Exceptions that can occur when running CrmSvcUtil

When you run the CrmSvcUtil.exe tool to generate early-bound entity types, you might receive an exception with the following message.

The type initializer for Microsoft.Xrm.Client.CodeGeneration.CodeCustomization threw an exception.

This error can be caused if the build version of the CrmSvcUtil tool and Microsoft.Xrm.Client.CodeGeneration.dll assembly aren’t the same. When you develop applications using the Microsoft Dynamics CRM SDK, always use the CrmSvcUtil tool and assemblies that are provided in the Bin folder of the SDK. Download the Microsoft Dynamics CRM SDK package. Don’t use the tool or assemblies from the Tools folder of a Microsoft Dynamics CRM server installation.

See Also

Reference

Web service error codes

Other Resources

Troubleshooting and error handling

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Web service error codes

This topic lists the error codes you might encounter when you debug your code. You can find helper code for using error codes in the SDK package in the folder SDK\SampleCode\CS\HelperCode\ErrorCodes.cs. In the same folder, you’ll also find CrmErrors.xml, which is provided so you have an easy way to look up error information. Download the Microsoft Dynamics CRM SDK package.

The following list shows the error codes used in Microsoft Dynamics CRM. For more information, see Handle exceptions in your code.

Xml Copy Code
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<crmerrors xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<crmerror>
<ErrorId>80048531</ErrorId>
<ManagedErrorName>CustomImageAttributeOnlyAllowedOnCustomEntity</ManagedErrorName>
<ErrorMessage>A custom image attribute can only be added to a custom entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048530</ErrorId>
<ManagedErrorName>SqlEncryptionSymmetricKeyCannotOpenBecauseWrongPassword</ManagedErrorName>
<ErrorMessage>Cannot open encryption Symmetric Key because the password is wrong.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004852F</ErrorId>
<ManagedErrorName>SqlEncryptionSymmetricKeyDoesNotExistOrNoPermission</ManagedErrorName>
<ErrorMessage>Cannot open encryption Symmetric Key because it does not exist in the database or user does not have permission.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004852E</ErrorId>
<ManagedErrorName>SqlEncryptionSymmetricKeyPasswordDoesNotExistInConfigDB</ManagedErrorName>
<ErrorMessage>Encryption Symmetric Key password does not exist in Config DB.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004852D</ErrorId>
<ManagedErrorName>SqlEncryptionSymmetricKeySourceDoesNotExistInConfigDB</ManagedErrorName>
<ErrorMessage>Encryption Symmetric Key Source does not exist in Config DB.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004852C</ErrorId>
<ManagedErrorName>CannotExecuteRequestBecauseHttpsIsRequired</ManagedErrorName>
<ErrorMessage>HTTPS protocol is required for this type of request, please enable HTTPS protocol and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004852B</ErrorId>
<ManagedErrorName>SqlEncryptionRestoreEncryptionKeyCannotDecryptExistingData</ManagedErrorName>
<ErrorMessage>Cannot perform 'activate' because the encryption key doesn’t match the original encryption key that was used to encrypt the data.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004852A</ErrorId>
<ManagedErrorName>SqlEncryptionSetEncryptionKeyIsAlreadyRunningCannotRunItInParallel</ManagedErrorName>
<ErrorMessage>The system is currently running a request to 'change' or 'activate' the encryption key. Please wait before making another request.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048529</ErrorId>
<ManagedErrorName>SqlEncryptionChangeEncryptionKeyExceededQuotaForTheInterval</ManagedErrorName>
<ErrorMessage>'Change' encryption key has already been executed {0} times in the last {1} minutes. Please wait a couple of minutes and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048528</ErrorId>
<ManagedErrorName>SqlEncryptionEncryptionKeyValidationError</ManagedErrorName>
<ErrorMessage>The new encryption key does not meet the strong encryption key requirements. The key must be between 10 and 100 characters in length, and must have at least one numeral, at least one letter, and one symbol or special character. {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048527</ErrorId>
<ManagedErrorName>SqlEncryptionIsInactiveCannotChangeEncryptionKey</ManagedErrorName>
<ErrorMessage>Cannot perform 'change' encryption key because the encryption key is not already set or is not working. First use 'activate' encryption key instead to set the correct current encryption key and then use 'change' encryption if you want to re-encrypt data using a new encryption key.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048526</ErrorId>
<ManagedErrorName>SqlEncryptionDeleteEncryptionKeyError</ManagedErrorName>
<ErrorMessage>Cannot delete the encryption key.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048525</ErrorId>
<ManagedErrorName>SqlEncryptionIsActiveCannotRestoreEncryptionKey</ManagedErrorName>
<ErrorMessage>Cannot perform 'activate' encryption key because the encryption key is already set and is working. Use 'change' encryption key instead.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048524</ErrorId>
<ManagedErrorName>SqlEncryptionKeyCannotDecryptExistingData</ManagedErrorName>
<ErrorMessage>Cannot decrypt existing encrypted data (Entity='{0}', Attribute='{1}') using the current encryption key. Use 'activate' encryption key to set the correct encryption key.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048523</ErrorId>
<ManagedErrorName>SqlEncryptionEncryptionDecryptionTestError</ManagedErrorName>
<ErrorMessage>Error while testing data encryption and decryption.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048522</ErrorId>
<ManagedErrorName>SqlEncryptionDeleteSymmetricKeyError</ManagedErrorName>
<ErrorMessage>Cannot delete Symmetric Key with Name='{0}' because it does not exist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048521</ErrorId>
<ManagedErrorName>SqlEncryptionCreateSymmetricKeyError</ManagedErrorName>
<ErrorMessage>Cannot create Symmetric Key with Name='{0}' because it already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048520</ErrorId>
<ManagedErrorName>SqlEncryptionSymmetricKeyDoesNotExist</ManagedErrorName>
<ErrorMessage>Symmetric Key with Name='{0}' does not exist in the database.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004851F</ErrorId>
<ManagedErrorName>SqlEncryptionDeleteCertificateError</ManagedErrorName>
<ErrorMessage>Cannot delete Certificate with Name='{0}' because it does not exist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004851E</ErrorId>
<ManagedErrorName>SqlEncryptionCreateCertificateError</ManagedErrorName>
<ErrorMessage>Cannot create Certificate with Name='{0}' because it already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004851D</ErrorId>
<ManagedErrorName>SqlEncryptionCertificateDoesNotExist</ManagedErrorName>
<ErrorMessage>Certificate with Name='{0}' does not exist in the database.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004851C</ErrorId>
<ManagedErrorName>SqlEncryptionDeleteDatabaseMasterKeyError</ManagedErrorName>
<ErrorMessage>Cannot delete Database Master Key because it does not exist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004851B</ErrorId>
<ManagedErrorName>SqlEncryptionCreateDatabaseMasterKeyError</ManagedErrorName>
<ErrorMessage>Cannot create Database Master Key because already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004851A</ErrorId>
<ManagedErrorName>SqlEncryptionCannotOpenSymmetricKeyBecauseDatabaseMasterKeyDoesNotExistOrIsNotOpened</ManagedErrorName>
<ErrorMessage>Cannot open Symmetric Key because Database Master Key does not exist in the database or is not opened.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048519</ErrorId>
<ManagedErrorName>SqlEncryptionDatabaseMasterKeyDoesNotExist</ManagedErrorName>
<ErrorMessage>Database Master Key does not exist in the database.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048518</ErrorId>
<ManagedErrorName>SqlEncryption</ManagedErrorName>
<ErrorMessage>There was an error in Data Encryption.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048535</ErrorId>
<ManagedErrorName>ErrorsInSlaWorkflowActivation</ManagedErrorName>
<ErrorMessage>You can't activate this service level agreement (SLA). You don't have the required permissions on the record types that are referenced by this SLA.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048534</ErrorId>
<ManagedErrorName>ManifestParsingFailure</ManagedErrorName>
<ErrorMessage>Failed to parse the specified manifest file to retrieve OrganizationId</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048533</ErrorId>
<ManagedErrorName>InvalidManifestFilePath</ManagedErrorName>
<ErrorMessage>Failed to locate the manifest file in the specified location</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048532</ErrorId>
<ManagedErrorName>OnPremiseRestoreOrganizationManifestFailed</ManagedErrorName>
<ErrorMessage>Failed to restore Organization's configdb state from manifest</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048516</ErrorId>
<ManagedErrorName>InvalidAuth</ManagedErrorName>
<ErrorMessage>Organization Authentication does not match the current discovery service Role.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048515</ErrorId>
<ManagedErrorName>CannotUpdateOrgDBOrgSettingWhenOffline</ManagedErrorName>
<ErrorMessage>Organization Settings stored in Organization Database cannot be set when offline.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048514</ErrorId>
<ManagedErrorName>InvalidOrgDBOrgSetting</ManagedErrorName>
<ErrorMessage>Invalid Organization Setting passed in. Please check the datatype and pass in an appropriate value.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048513</ErrorId>
<ManagedErrorName>UnknownInvalidTransformationParameterGeneric</ManagedErrorName>
<ErrorMessage>One or more input transformation parameter values are invalid: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048512</ErrorId>
<ManagedErrorName>InvalidTransformationParameterOutsideRangeGeneric</ManagedErrorName>
<ErrorMessage>One or more input transformation parameter values are outside the permissible range: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048511</ErrorId>
<ManagedErrorName>InvalidTransformationParameterEmptyCollection</ManagedErrorName>
<ErrorMessage>The transformation parameter: {0} has an invalid input value length: {1}. The parameter length cannot be an empty collection.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048510</ErrorId>
<ManagedErrorName>InvalidTransformationParameterOutsideRange</ManagedErrorName>
<ErrorMessage>The transformation parameter: {0} has an invalid input value: {1}. The parameter is out of the permissible range: {2}. </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048509</ErrorId>
<ManagedErrorName>InvalidTransformationParameterZeroToRange</ManagedErrorName>
<ErrorMessage>The transformation parameter: {0} has an invalid input value: {1}. The parameter value must be greater than 0 and less than the length of the parameter 1.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048508</ErrorId>
<ManagedErrorName>InvalidTransformationParameterString</ManagedErrorName>
<ErrorMessage>The transformation parameter: {0} has an invalid input value: {1}. The parameter must be a string that is not empty.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048507</ErrorId>
<ManagedErrorName>InvalidTransformationParametersGeneric</ManagedErrorName>
<ErrorMessage>The transformation parameter: {0} has an invalid input value: {1}. The parameter must be of type: {2}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048506</ErrorId>
<ManagedErrorName>InsufficientTransformationParameters</ManagedErrorName>
<ErrorMessage>Insufficient parameters to execute transformation mapping.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048505</ErrorId>
<ManagedErrorName>MaximumNumberHandlersExceeded</ManagedErrorName>
<ErrorMessage>This solution adds form event handlers so the number of event handlers for a form event exceeds the maximum number.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048503</ErrorId>
<ManagedErrorName>ErrorInUnzipAlternate</ManagedErrorName>
<ErrorMessage>An error occurred while the uploaded .zip file was being extracted. Try to upload the file again. If the problem persists, contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048502</ErrorId>
<ManagedErrorName>IncorrectSingleFileMultipleEntityMap</ManagedErrorName>
<ErrorMessage>There should be two or more Entity Mappings defined when EntitiesPerFile in ImportMap is set to Multiple</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048501</ErrorId>
<ManagedErrorName>ActivityEntityCannotBeActivityParty</ManagedErrorName>
<ErrorMessage>An activity entity cannot be also an activity party</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048500</ErrorId>
<ManagedErrorName>TargetAttributeInvalidForIgnore</ManagedErrorName>
<ErrorMessage>Target attribute name should be empty when the processcode is ignore.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048499</ErrorId>
<ManagedErrorName>MaxUnzipFolderSizeExceeded</ManagedErrorName>
<ErrorMessage>File cannot be unzipped because it exceeded the maximum server storage size limit. Please try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048498</ErrorId>
<ManagedErrorName>InvalidMultipleMapping</ManagedErrorName>
<ErrorMessage>A source field is mapped to more than one CRM fields of lookup/picklist type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048497</ErrorId>
<ManagedErrorName>ErrorInStoringImportFile</ManagedErrorName>
<ErrorMessage>An error occurred while storing the import file in database.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048496</ErrorId>
<ManagedErrorName>UnzipTimeout</ManagedErrorName>
<ErrorMessage>Timeout happened in unzipping the zip file uploaded for import.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048495</ErrorId>
<ManagedErrorName>UnsupportedZipFileForImport</ManagedErrorName>
<ErrorMessage>The structure of the zip file is not support for import.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048494</ErrorId>
<ManagedErrorName>UnzipProcessCountLimitReached</ManagedErrorName>
<ErrorMessage>Cannot start a new process to unzip.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048493</ErrorId>
<ManagedErrorName>AttachmentNotFound</ManagedErrorName>
<ErrorMessage>The reference to the attachment could not be found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048492</ErrorId>
<ManagedErrorName>TooManyPicklistValues</ManagedErrorName>
<ErrorMessage>Number of distinct picklist values exceed the limit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048491</ErrorId>
<ManagedErrorName>VeryLargeFileInZipImport</ManagedErrorName>
<ErrorMessage>One of the files in the .zip file that you are trying to import exceeds the size limit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048490</ErrorId>
<ManagedErrorName>InvalidAttachmentsFolder</ManagedErrorName>
<ErrorMessage>The .zip file cannot be uploaded because the folder "Attachments" contains one or more subfolders. Remove the subfolders and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048489</ErrorId>
<ManagedErrorName>ZipInsideZip</ManagedErrorName>
<ErrorMessage>The zip file that you are trying to upload contains another zip file within it.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048488</ErrorId>
<ManagedErrorName>InvalidZipFileFormat</ManagedErrorName>
<ErrorMessage>The file that you are trying to upload is not a valid file. Check the file and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048487</ErrorId>
<ManagedErrorName>EmptyFileForImport</ManagedErrorName>
<ErrorMessage>The selected file contains no data.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048486</ErrorId>
<ManagedErrorName>EmptyFilesInZip</ManagedErrorName>
<ErrorMessage>One or more files in the .zip file do not contain data. Check the files and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048485</ErrorId>
<ManagedErrorName>ZipFileHasMixOfCsvAndXmlFiles</ManagedErrorName>
<ErrorMessage>The zip file that you are trying to upload contains both CSV and XML Spreadsheet 2003 format. The zip file can contain either CSV files or XML Spreadsheet 2003 files, but not both.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048484</ErrorId>
<ManagedErrorName>DuplicateFileNamesInZip</ManagedErrorName>
<ErrorMessage>Two or more files have the same name. File names must be unique.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048483</ErrorId>
<ManagedErrorName>ErrorInUnzip</ManagedErrorName>
<ErrorMessage>An error occurred while unzipping the selected file.Try importing file again.If this problem persists, contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048482</ErrorId>
<ManagedErrorName>InvalidZipFileForImport</ManagedErrorName>
<ErrorMessage>Unzip file has invalid files for import.Zip file should contain either csv or xml files.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048481</ErrorId>
<ManagedErrorName>InvalidLookupMapNode</ManagedErrorName>
<ErrorMessage>The lookup entity provided is not valid for the given target attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048480</ErrorId>
<ManagedErrorName>ImportMailMergeTemplateEntityMissingError</ManagedErrorName>
<ErrorMessage>The {0} mail merge template was not imported because the {1} entity associated with this template is not in the target system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048479</ErrorId>
<ManagedErrorName>CannotUpdateOpportunityCurrency</ManagedErrorName>
<ErrorMessage>The currency cannot be changed because this opportunity has Products Quotes, and/ or Orders associated with it.  If you want to change the currency please delete all of the Products/quotes/orders and then change the currency or create a new opportunity with the appropriate currency.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048478</ErrorId>
<ManagedErrorName>ParentRecordAlreadyExists</ManagedErrorName>
<ErrorMessage>This record cannot be added because it already has a parent record.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048477</ErrorId>
<ManagedErrorName>MissingWebToLeadRedirect</ManagedErrorName>
<ErrorMessage>The redirectto is missing for web2lead redirect.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048476</ErrorId>
<ManagedErrorName>InvalidWebToLeadRedirect</ManagedErrorName>
<ErrorMessage>The redirectto is invalid for web2lead redirect.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048475</ErrorId>
<ManagedErrorName>TemplateNotAllowedForInternetMarketing</ManagedErrorName>
<ErrorMessage>Creating Templates with Internet Marketing Campaign Activities is not allowed</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048474</ErrorId>
<ManagedErrorName>CopyNotAllowedForInternetMarketing</ManagedErrorName>
<ErrorMessage>Duplicating campaigns that have Internet Marketing Campaign Activities is not allowed</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048473</ErrorId>
<ManagedErrorName>MissingOrInvalidRedirectId</ManagedErrorName>
<ErrorMessage>The RedirId parameter is missing for the partner redirect.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048472</ErrorId>
<ManagedErrorName>ImportNotComplete</ManagedErrorName>
<ErrorMessage>One or more imports are not in completed state. Imported records can only be deleted from completed jobs. Wait until job completes, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048471</ErrorId>
<ManagedErrorName>UIDataMissingInWorkflow</ManagedErrorName>
<ErrorMessage>The workflow does not contain UIData.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048470</ErrorId>
<ManagedErrorName>RefEntityRelationshipRoleRequired</ManagedErrorName>
<ErrorMessage>The entity relationship role of the referencing entity is required when creating a new one-to-many entity relationship.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004847a</ErrorId>
<ManagedErrorName>ImportTemplateLanguageIgnored</ManagedErrorName>
<ErrorMessage>You cannot import this template because its language is not enabled in your Microsoft Dynamics CRM organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004847b</ErrorId>
<ManagedErrorName>ImportTemplatePersonalIgnored</ManagedErrorName>
<ErrorMessage>You cannot import this template because it is set as "personal" in your Microsoft Dynamics CRM organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004847c</ErrorId>
<ManagedErrorName>ImportComponentDeletedIgnored</ManagedErrorName>
<ErrorMessage>You cannot update this component because it does not exist in this Microsoft Dynamics CRM organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048469</ErrorId>
<ManagedErrorName>RelationshipRoleNodeNumberInvalid</ManagedErrorName>
<ErrorMessage>There must be two entity relationship role nodes when creating a new many-to-many entity relationship.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048468</ErrorId>
<ManagedErrorName>AssociationRoleOrdinalInvalid</ManagedErrorName>
<ErrorMessage>The association role ordinal is not valid - it must be 1 or 2.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048467</ErrorId>
<ManagedErrorName>RelationshipRoleMismatch</ManagedErrorName>
<ErrorMessage>The relationship role name {0} does not match either expected entity name of {1} or {2}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048465</ErrorId>
<ManagedErrorName>ImportMapInUse</ManagedErrorName>
<ErrorMessage>One or more of the selected data maps cannot be deleted because it is currently used in a data import.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048464</ErrorId>
<ManagedErrorName>PreviousOperationNotComplete</ManagedErrorName>
<ErrorMessage>An operation on which this operation depends did not complete successfully.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048463</ErrorId>
<ManagedErrorName>TransformationResumeNotSupported</ManagedErrorName>
<ErrorMessage>The resume/retry of Transformation job of Import is not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048462</ErrorId>
<ManagedErrorName>CannotDisableDuplicateDetection</ManagedErrorName>
<ErrorMessage>Duplicate detection cannot be disabled because a duplicate detection job is currently in progress. Try again later.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048460</ErrorId>
<ManagedErrorName>TargetEntityNotMapped</ManagedErrorName>
<ErrorMessage>Target Entity Name not defined for source:{0} file.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048459</ErrorId>
<ManagedErrorName>BulkDeleteChildFailure</ManagedErrorName>
<ErrorMessage>One of the Bulk Delete Child Jobs Failed</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048458</ErrorId>
<ManagedErrorName>CannotRemoveNonListMember</ManagedErrorName>
<ErrorMessage>Specified Item not a member of the specified List.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048457</ErrorId>
<ManagedErrorName>JobNameIsEmptyOrNull</ManagedErrorName>
<ErrorMessage>Job Name can not be null or empty.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048456</ErrorId>
<ManagedErrorName>ImportMailMergeTemplateError</ManagedErrorName>
<ErrorMessage>There was an error in parsing the mail merge templates in Import Xml</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048455</ErrorId>
<ManagedErrorName>ErrorsInWorkflowDefinition</ManagedErrorName>
<ErrorMessage>The selected workflow has errors and cannot be published. Please open the workflow, remove the errors and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048454</ErrorId>
<ManagedErrorName>DistributeNoListAssociated</ManagedErrorName>
<ErrorMessage>This campaign activity cannot be distributed. No marketing lists are associated with it. Add at least one marketing list and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048453</ErrorId>
<ManagedErrorName>DistributeListAssociatedVary</ManagedErrorName>
<ErrorMessage>This campaign activity cannot be distributed. Mail merge activities can be done only on marketing lists that are all the same record type. For this campaign activity, remove marketing lists so that the remaining ones are the same record type, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048451</ErrorId>
<ManagedErrorName>OfflineFilterParentDownloaded</ManagedErrorName>
<ErrorMessage>You cannot use the Parent Downloaded condition in a local data group.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048450</ErrorId>
<ManagedErrorName>OfflineFilterNestedDateTimeOR</ManagedErrorName>
<ErrorMessage>You cannot use nested date time conditions within an OR clause in a local data group.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048449</ErrorId>
<ManagedErrorName>DuplicateOfflineFilter</ManagedErrorName>
<ErrorMessage>You can create only one local data group for each record type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048448</ErrorId>
<ManagedErrorName>CannotAssignAddressBookFilters</ManagedErrorName>
<ErrorMessage>Cannot assign address book filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048447</ErrorId>
<ManagedErrorName>CannotCreateAddressBookFilters</ManagedErrorName>
<ErrorMessage>Cannot create address book filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048446</ErrorId>
<ManagedErrorName>CannotGrantAccessToAddressBookFilters</ManagedErrorName>
<ErrorMessage>Cannot grant access to address book filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048445</ErrorId>
<ManagedErrorName>CannotModifyAccessToAddressBookFilters</ManagedErrorName>
<ErrorMessage>Cannot modify access for address book filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048444</ErrorId>
<ManagedErrorName>CannotRevokeAccessToAddressBookFilters</ManagedErrorName>
<ErrorMessage>Cannot revoke access for address book filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048443</ErrorId>
<ManagedErrorName>DuplicateMapName</ManagedErrorName>
<ErrorMessage>A data map with the specified name already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048441</ErrorId>
<ManagedErrorName>InvalidWordXmlFile</ManagedErrorName>
<ErrorMessage>Only Microsoft Word xml format files can be uploaded.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048440</ErrorId>
<ManagedErrorName>FileNotFound</ManagedErrorName>
<ErrorMessage>The attachment file was not found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048439</ErrorId>
<ManagedErrorName>MultipleFilesFound</ManagedErrorName>
<ErrorMessage>The attachment file name is not unique.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048438</ErrorId>
<ManagedErrorName>InvalidAttributeMapping</ManagedErrorName>
<ErrorMessage>One or more attribute mappings is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048437</ErrorId>
<ManagedErrorName>FileReadError</ManagedErrorName>
<ErrorMessage>There was an error reading the file from the file system. Make sure you have read permission for this file, and then try migrating the file again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048838</ErrorId>
<ManagedErrorName>ViewForDuplicateDetectionNotDefined</ManagedErrorName>
<ErrorMessage>Required view for viewing duplicates of an entity not defined.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048837</ErrorId>
<ManagedErrorName>FileInUse</ManagedErrorName>
<ErrorMessage>Could not read the file because another application is using the file.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048436</ErrorId>
<ManagedErrorName>NoPublishedDuplicateDetectionRules</ManagedErrorName>
<ErrorMessage>There are no published duplicate detection rules in the system. To run duplicate detection, you must create and publish one or more rules.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048442</ErrorId>
<ManagedErrorName>NoEntitiesForBulkDelete</ManagedErrorName>
<ErrorMessage>The Bulk Delete Wizard cannot be opened because there are no valid entities for deletion.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048435</ErrorId>
<ManagedErrorName>BulkDeleteRecordDeletionFailure</ManagedErrorName>
<ErrorMessage>The record cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048434</ErrorId>
<ManagedErrorName>RuleAlreadyPublishing</ManagedErrorName>
<ErrorMessage>The selected duplicate detection rule is already being published.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048433</ErrorId>
<ManagedErrorName>RuleNotFound</ManagedErrorName>
<ErrorMessage>No rules were found that match the criteria.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048432</ErrorId>
<ManagedErrorName>CannotDeleteSystemEmailTemplate</ManagedErrorName>
<ErrorMessage>System e-mail templates cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048431</ErrorId>
<ManagedErrorName>EntityDupCheckNotSupportedSystemWide</ManagedErrorName>
<ErrorMessage>Duplicate detection is not enabled for one or more of the selected entities. The duplicate detection job cannot be started.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048430</ErrorId>
<ManagedErrorName>DuplicateDetectionNotSupportedOnAttributeType</ManagedErrorName>
<ErrorMessage>The rule condition cannot be created or updated because duplicate detection is not supported on the data type of the selected attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048429</ErrorId>
<ManagedErrorName>MaxMatchCodeLengthExceeded</ManagedErrorName>
<ErrorMessage>The rule condition cannot be created or updated because it would cause the matchcode length to exceed the maximum limit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048428</ErrorId>
<ManagedErrorName>CannotDeleteUpdateInUseRule</ManagedErrorName>
<ErrorMessage>The duplicate detection rule is currently in use and cannot be updated or deleted. Please try again later.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048427</ErrorId>
<ManagedErrorName>ImportMappingsInvalidIdSpecified</ManagedErrorName>
<ErrorMessage>The XML file has one or more invalid IDs. The specified ID cannot be used as a unique identifier.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048426</ErrorId>
<ManagedErrorName>NotAWellFormedXml</ManagedErrorName>
<ErrorMessage>The input XML is not well-formed XML.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048425</ErrorId>
<ManagedErrorName>NoncompliantXml</ManagedErrorName>
<ErrorMessage>The input XML does not comply with the XML schema.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048424</ErrorId>
<ManagedErrorName>DuplicateDetectionTemplateNotFound</ManagedErrorName>
<ErrorMessage>Microsoft Dynamics CRM could not retrieve the e-mail notification template.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048423</ErrorId>
<ManagedErrorName>RulesInInconsistentStateFound</ManagedErrorName>
<ErrorMessage>One or more rules cannot be unpublished, either because they are in the process of being published, or are in a state where they cannot be unpublished.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048422</ErrorId>
<ManagedErrorName>BulkDetectInvalidEmailRecipient</ManagedErrorName>
<ErrorMessage>The e-mail recipient either does not exist or the e-mail address for the e-mail recipient is not valid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048421</ErrorId>
<ManagedErrorName>CannotEnableDuplicateDetection</ManagedErrorName>
<ErrorMessage>Duplicate detection cannot be enabled because one or more rules are being published.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048420</ErrorId>
<ManagedErrorName>CannotDeleteInUseEntity</ManagedErrorName>
<ErrorMessage>The selected entity cannot be deleted because it is referenced by one or more duplicate detection rules that are in process of being published.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D292</ErrorId>
<ManagedErrorName>StringAttributeIndexError</ManagedErrorName>
<ErrorMessage>One of the attributes of the selected entity is a part of database index and so it cannot be greater than 900 bytes.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D293</ErrorId>
<ManagedErrorName>CannotChangeAttributeRequiredLevel</ManagedErrorName>
<ErrorMessage>An attribute's required level cannot be changed from SystemRequired</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004841A</ErrorId>
<ManagedErrorName>MaximumNumberOfAttributesForEntityReached</ManagedErrorName>
<ErrorMessage>The maximum number of attributes allowed for an entity has already been reached. The attribute cannot be created.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048419</ErrorId>
<ManagedErrorName>CannotPublishMoreRules</ManagedErrorName>
<ErrorMessage>The selected record type already has the maximum number of published rules. Unpublish or delete existing rules for this record type, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048418</ErrorId>
<ManagedErrorName>CannotDeleteInUseAttribute</ManagedErrorName>
<ErrorMessage>The selected attribute cannot be deleted because it is referenced by one or more duplicate detection rules that are being published.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048417</ErrorId>
<ManagedErrorName>CannotDeleteInUseOptionSet</ManagedErrorName>
<ErrorMessage>This option set cannot be deleted. The current set of entities that reference this option set are: {0}. These references must be removed before this option set can be deleted</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048416</ErrorId>
<ManagedErrorName>InvalidEntityName</ManagedErrorName>
<ErrorMessage>The record type does not match the base record type and the matching record type of the duplicate detection rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048415</ErrorId>
<ManagedErrorName>InvalidOperatorCode</ManagedErrorName>
<ErrorMessage>The operator is not valid or it is not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048414</ErrorId>
<ManagedErrorName>CannotPublishEmptyRule</ManagedErrorName>
<ErrorMessage>No criteria have been specified. Add criteria, and then publish the duplicate detection rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048413</ErrorId>
<ManagedErrorName>CannotPublishInactiveRule</ManagedErrorName>
<ErrorMessage>The selected duplicate detection rule is marked as Inactive. Before publishing, you must activate the rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048412</ErrorId>
<ManagedErrorName>DuplicateCheckNotEnabled</ManagedErrorName>
<ErrorMessage>Duplicate detection is not enabled. To enable duplicate detection, click Settings, click Data Management, and then click Duplicate Detection Settings.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048410</ErrorId>
<ManagedErrorName>DuplicateCheckNotSupportedOnEntity</ManagedErrorName>
<ErrorMessage>Duplicate detection is not supported on this record type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048408</ErrorId>
<ManagedErrorName>InvalidStateCodeStatusCode</ManagedErrorName>
<ErrorMessage>State code is invalid or state code is valid but status code is invalid for a specified state code.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048407</ErrorId>
<ManagedErrorName>SyncToMsdeFailure</ManagedErrorName>
<ErrorMessage>Failed to start or connect to the offline mode MSDE database.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048406</ErrorId>
<ManagedErrorName>FormDoesNotExist</ManagedErrorName>
<ErrorMessage>Form doesn't exist</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048405</ErrorId>
<ManagedErrorName>AccessDenied</ManagedErrorName>
<ErrorMessage>Access is denied.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048404</ErrorId>
<ManagedErrorName>CannotDeleteOptionSet</ManagedErrorName>
<ErrorMessage>The selected OptionSet cannot be deleted</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048403</ErrorId>
<ManagedErrorName>InvalidOptionSetOperation</ManagedErrorName>
<ErrorMessage>Invalid OptionSet</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048402</ErrorId>
<ManagedErrorName>OptionValuePrefixOutOfRange</ManagedErrorName>
<ErrorMessage>CustomizationOptionValuePrefix must be a number between {0} and {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048401</ErrorId>
<ManagedErrorName>CheckPrivilegeGroupForUserOnPremiseError</ManagedErrorName>
<ErrorMessage>Please select an account that is a member of the PrivUserGroup security group and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048400</ErrorId>
<ManagedErrorName>CheckPrivilegeGroupForUserOnSplaError</ManagedErrorName>
<ErrorMessage>Please select a CRM System Administrator account that belongs to the root business unit and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048306</ErrorId>
<ManagedErrorName>unManagedIdsAccessDenied</ManagedErrorName>
<ErrorMessage>Not enough privilege to access the Microsoft Dynamics CRM object or perform the requested operation.</ErrorMessage>
<UnManagedErrorName>IDS_ACCESSDENIED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004830F</ErrorId>
<ManagedErrorName>EntityIsIntersect</ManagedErrorName>
<ErrorMessage>The specified entity is intersect entity</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004830E</ErrorId>
<ManagedErrorName>CannotDeleteTeamOwningRecords</ManagedErrorName>
<ErrorMessage>Can't delete a team which owns records. Reassign the records and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004830C</ErrorId>
<ManagedErrorName>CannotRemoveMembersFromDefaultTeam</ManagedErrorName>
<ErrorMessage>Can't remove members from the default business unit team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004830B</ErrorId>
<ManagedErrorName>CannotAddMembersToDefaultTeam</ManagedErrorName>
<ErrorMessage>Can't add members to the default business unit team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004830A</ErrorId>
<ManagedErrorName>CannotUpdateNameDefaultTeam</ManagedErrorName>
<ErrorMessage>The default business unit team name can't be updated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048308</ErrorId>
<ManagedErrorName>CannotSetParentDefaultTeam</ManagedErrorName>
<ErrorMessage>The default business unit team parent can't be set.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048307</ErrorId>
<ManagedErrorName>CannotDeleteDefaultTeam</ManagedErrorName>
<ErrorMessage>The default business unit team can't be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048305</ErrorId>
<ManagedErrorName>TeamNameTooLong</ManagedErrorName>
<ErrorMessage>The specified name for the team is too long.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_TEAM_NAME_TOO_LONG</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048331</ErrorId>
<ManagedErrorName>CannotAssignRolesOrProfilesToAccessTeam</ManagedErrorName>
<ErrorMessage>Cannot assign roles or profiles to an access team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048332</ErrorId>
<ManagedErrorName>TooManyEntitiesEnabledForAutoCreatedAccessTeams</ManagedErrorName>
<ErrorMessage>Too many entities enabled for auto created access teams.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048333</ErrorId>
<ManagedErrorName>TooManyTeamTemplatesForEntityAccessTeams</ManagedErrorName>
<ErrorMessage>Too many team templates for auto created access teams for this entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048334</ErrorId>
<ManagedErrorName>EntityNotEnabledForAutoCreatedAccessTeams</ManagedErrorName>
<ErrorMessage>This entity is not enabled for auto created access teams.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048335</ErrorId>
<ManagedErrorName>InvalidAccessMaskForTeamTemplate</ManagedErrorName>
<ErrorMessage>Invalid access mask is specified for team template.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048336</ErrorId>
<ManagedErrorName>CannotChangeTeamTypeDueToRoleOrProfile</ManagedErrorName>
<ErrorMessage>You cannot modify the type of the team because there are security roles or field security profiles assigned to the team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048337</ErrorId>
<ManagedErrorName>CannotChangeTeamTypeDueToOwnership</ManagedErrorName>
<ErrorMessage>You cannot modify the type of the team because there are records owned by the team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048338</ErrorId>
<ManagedErrorName>CannotDisableAutoCreateAccessTeams</ManagedErrorName>
<ErrorMessage>You cannot disable the auto create access team setting while there are associated team templates.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048339</ErrorId>
<ManagedErrorName>CannotShareSystemManagedTeam</ManagedErrorName>
<ErrorMessage>You can't share or unshare a record with a system-generated access team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048340</ErrorId>
<ManagedErrorName>CannotAssignToAccessTeam</ManagedErrorName>
<ErrorMessage>You cannot assign a record to the access team. You can assign a record to the owner team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048341</ErrorId>
<ManagedErrorName>DuplicateSalesTeamMember</ManagedErrorName>
<ErrorMessage>The user you're trying to add is already a member of the sales team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048342</ErrorId>
<ManagedErrorName>TargetUserInsufficientPrivileges</ManagedErrorName>
<ErrorMessage>"The user can’t be added to the team because the user has insufficient privileges on the entity. The minimum access level the user must have is User.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048343</ErrorId>
<ManagedErrorName>CannotDisableOrDeletePositionDueToAssociatedUsers</ManagedErrorName>
<ErrorMessage>This position can’t be deleted until all associated users are removed from this position.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048344</ErrorId>
<ManagedErrorName>CannotCreateOrEnablePositionDueToParentPositionIsDisabled</ManagedErrorName>
<ErrorMessage>A child position cannot be created/enabled under a disabled parent position.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048015</ErrorId>
<ManagedErrorName>InvalidDomainName</ManagedErrorName>
<ErrorMessage>The domain logon for this user is invalid. Select another domain logon and try again.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_INVALID_DOMAINNAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048095</ErrorId>
<ManagedErrorName>InvalidUserName</ManagedErrorName>
<ErrorMessage>You must enter the user name in the format &lt;name&gt;@&lt;domain&gt;. Correct the format and try again.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_INVALID_USERNAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048304</ErrorId>
<ManagedErrorName>BulkMailServiceNotAccessible</ManagedErrorName>
<ErrorMessage>The Microsoft Dynamics CRM Bulk E-Mail Service is not running.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048330</ErrorId>
<ManagedErrorName>RSMoveItemError</ManagedErrorName>
<ErrorMessage>Cannot move report item {0} to {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004832f</ErrorId>
<ManagedErrorName>ReportParentChildNotCustomizable</ManagedErrorName>
<ErrorMessage>The report could not be updated because either the parent report or the child report is not customizable.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004832e</ErrorId>
<ManagedErrorName>ConvertFetchDataSetError</ManagedErrorName>
<ErrorMessage>An unexpected error occurred while processing the Fetch data set.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004832d</ErrorId>
<ManagedErrorName>ConvertReportToCrmError</ManagedErrorName>
<ErrorMessage>An unexpected error occurred while converting supplied report to CRM format.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004832c</ErrorId>
<ManagedErrorName>ReportViewerError</ManagedErrorName>
<ErrorMessage>An error occurred during report rendering. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004832b</ErrorId>
<ManagedErrorName>RSGetItemTypeError</ManagedErrorName>
<ErrorMessage>Error occurred while fetching the report.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004832a</ErrorId>
<ManagedErrorName>RSSetPropertiesError</ManagedErrorName>
<ErrorMessage>Error occurred while setting property values for the report.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048329</ErrorId>
<ManagedErrorName>RSReportParameterTypeMismatchError</ManagedErrorName>
<ErrorMessage>The parameter type of the report is not valid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048328</ErrorId>
<ManagedErrorName>RSUpdateReportExecutionSnapshotError</ManagedErrorName>
<ErrorMessage>Error occurred while taking snapshot of a report.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048327</ErrorId>
<ManagedErrorName>RSSetReportHistoryLimitError</ManagedErrorName>
<ErrorMessage>Error occurred while setting report history snapshot limit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048326</ErrorId>
<ManagedErrorName>RSSetReportHistoryOptionsError</ManagedErrorName>
<ErrorMessage>Error occurred while setting report history snapshot options.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048325</ErrorId>
<ManagedErrorName>RSSetExecutionOptionsError</ManagedErrorName>
<ErrorMessage>Error occurred while setting execution options.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048324</ErrorId>
<ManagedErrorName>RSSetReportParametersError</ManagedErrorName>
<ErrorMessage>Error occurred while setting report parameters.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048323</ErrorId>
<ManagedErrorName>RSGetReportParametersError</ManagedErrorName>
<ErrorMessage>Error occurred while getting report parameters.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048322</ErrorId>
<ManagedErrorName>RSSetItemDataSourcesError</ManagedErrorName>
<ErrorMessage>Error occurred while setting the data source.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048321</ErrorId>
<ManagedErrorName>RSGetItemDataSourcesError</ManagedErrorName>
<ErrorMessage>Error occurred while fetching current data sources.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048320</ErrorId>
<ManagedErrorName>RSCreateBatchError</ManagedErrorName>
<ErrorMessage>Error occurred while creating a batch operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004831f</ErrorId>
<ManagedErrorName>RSListReportHistoryError</ManagedErrorName>
<ErrorMessage>Error occurred while fetching the report history snapshots.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004831e</ErrorId>
<ManagedErrorName>RSGetReportHistoryLimitError</ManagedErrorName>
<ErrorMessage>Error occurred while fetching the number of snapshots stored for the report.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004831d</ErrorId>
<ManagedErrorName>RSExecuteBatchError</ManagedErrorName>
<ErrorMessage>Error occurred while performing the batch operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004831c</ErrorId>
<ManagedErrorName>RSCancelBatchError</ManagedErrorName>
<ErrorMessage>Error occurred while canceling the batch operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004831b</ErrorId>
<ManagedErrorName>RSListExtensionsError</ManagedErrorName>
<ErrorMessage>Error occurred while fetching the list of data extensions installed on the report server.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004831a</ErrorId>
<ManagedErrorName>RSGetDataSourceContentsError</ManagedErrorName>
<ErrorMessage>Error occurred while getting the data source contents.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048319</ErrorId>
<ManagedErrorName>RSSetDataSourceContentsError</ManagedErrorName>
<ErrorMessage>Error occurred while setting the data source contents.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048318</ErrorId>
<ManagedErrorName>RSFindItemsError</ManagedErrorName>
<ErrorMessage>Error occurred while finding an item on the report server.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048317</ErrorId>
<ManagedErrorName>RSDeleteItemError</ManagedErrorName>
<ErrorMessage>Error occurred while deleting an item from the report server.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048316</ErrorId>
<ManagedErrorName>ReportSecurityError</ManagedErrorName>
<ErrorMessage>The report contains a security violation. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048315</ErrorId>
<ManagedErrorName>ReportMissingReportSourceError</ManagedErrorName>
<ErrorMessage>No source has been specified for the report. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048314</ErrorId>
<ManagedErrorName>ReportMissingParameterError</ManagedErrorName>
<ErrorMessage>A parameter expected by the report has not been supplied. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048313</ErrorId>
<ManagedErrorName>ReportMissingEndpointError</ManagedErrorName>
<ErrorMessage>The SOAP endpoint used by the ReportViewer control could not be accessed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048312</ErrorId>
<ManagedErrorName>ReportMissingDataSourceError</ManagedErrorName>
<ErrorMessage>A data source expected by the report has not been supplied. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048311</ErrorId>
<ManagedErrorName>ReportMissingDataSourceCredentialsError</ManagedErrorName>
<ErrorMessage>Credentials have not been supplied for a data source used by the report. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048310</ErrorId>
<ManagedErrorName>ReportLocalProcessingError</ManagedErrorName>
<ErrorMessage>Error occurred while viewing locally processed report. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048309</ErrorId>
<ManagedErrorName>ReportServerSP2HotFixNotApplied</ManagedErrorName>
<ErrorMessage>Report server SP2 Workgroup does not have the hotfix for role creation</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004830D</ErrorId>
<ManagedErrorName>DataSourceProhibited</ManagedErrorName>
<ErrorMessage>A non fetch based data source is not permitted on this report</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048303</ErrorId>
<ManagedErrorName>ReportServerVersionLow</ManagedErrorName>
<ErrorMessage>Report server does not meet the minimal version requirement</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048302</ErrorId>
<ManagedErrorName>ReportServerNoPrivilege</ManagedErrorName>
<ErrorMessage>Not enough privilege to configure report server</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048301</ErrorId>
<ManagedErrorName>ReportServerInvalidUrl</ManagedErrorName>
<ErrorMessage>Cannot contact report server from given URL</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048300</ErrorId>
<ManagedErrorName>ReportServerUnknownException</ManagedErrorName>
<ErrorMessage>Unknown exception thrown by report server</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048299</ErrorId>
<ManagedErrorName>ReportNotAvailable</ManagedErrorName>
<ErrorMessage>Report not available</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048298</ErrorId>
<ManagedErrorName>ErrorUploadingReport</ManagedErrorName>
<ErrorMessage>An error occurred while trying to add the report to Microsoft Dynamics CRM. Try adding the report again. If this problem persists, contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048297</ErrorId>
<ManagedErrorName>ReportFileTooBig</ManagedErrorName>
<ErrorMessage>The file is too large and cannot be uploaded. Please reduce the size of the file and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048296</ErrorId>
<ManagedErrorName>ReportFileZeroLength</ManagedErrorName>
<ErrorMessage>You have uploaded an empty file.  Please select a new file and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048295</ErrorId>
<ManagedErrorName>ReportTypeBlocked</ManagedErrorName>
<ErrorMessage>The report is not a valid type.  It cannot be uploaded or downloaded.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048294</ErrorId>
<ManagedErrorName>ReportUploadDisabled</ManagedErrorName>
<ErrorMessage>Reporting Services reports cannot be uploaded. If you want to create a new report, please use the Report Wizard.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048218</ErrorId>
<ManagedErrorName>BothConnectionSidesAreNeeded</ManagedErrorName>
<ErrorMessage>You must provide a name or select a role for both sides of this connection.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048217</ErrorId>
<ManagedErrorName>CannotConnectToSelf</ManagedErrorName>
<ErrorMessage>Cannot connect a record to itself.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048216</ErrorId>
<ManagedErrorName>UnrelatedConnectionRoles</ManagedErrorName>
<ErrorMessage>The connection roles are not related.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048215</ErrorId>
<ManagedErrorName>ConnectionRoleNotValidForObjectType</ManagedErrorName>
<ErrorMessage>The record type {0} is not defined for use with the connection role {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048214</ErrorId>
<ManagedErrorName>ConnectionCannotBeEnabledOnThisEntity</ManagedErrorName>
<ErrorMessage>Connections cannot be enabled on this entity</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048213</ErrorId>
<ManagedErrorName>ConnectionNotSupported</ManagedErrorName>
<ErrorMessage>The selected record does not support connections. You cannot add the connection.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048210</ErrorId>
<ManagedErrorName>ConnectionObjectsMissing</ManagedErrorName>
<ErrorMessage>Both objects being connected are missing.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048209</ErrorId>
<ManagedErrorName>ConnectionInvalidStartEndDate</ManagedErrorName>
<ErrorMessage>Start date / end date is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048208</ErrorId>
<ManagedErrorName>ConnectionExists</ManagedErrorName>
<ErrorMessage>Connection already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048207</ErrorId>
<ManagedErrorName>DecoupleUserOwnedEntity</ManagedErrorName>
<ErrorMessage>Can only decouple user owned entities.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048206</ErrorId>
<ManagedErrorName>DecoupleChildEntity</ManagedErrorName>
<ErrorMessage>Cannot decouple a child entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048205</ErrorId>
<ManagedErrorName>ExistingParentalRelationship</ManagedErrorName>
<ErrorMessage>A parental relationship already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048204</ErrorId>
<ManagedErrorName>InvalidCascadeLinkType</ManagedErrorName>
<ErrorMessage>The cascade link type is not valid for the cascade action.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048203</ErrorId>
<ManagedErrorName>InvalidDeleteModification</ManagedErrorName>
<ErrorMessage>A system relationship's delete cascading action cannot be modified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048202</ErrorId>
<ManagedErrorName>CustomerOpportunityRoleExists</ManagedErrorName>
<ErrorMessage>Customer opportunity role exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048201</ErrorId>
<ManagedErrorName>CustomerRelationshipExists</ManagedErrorName>
<ErrorMessage>Customer relationship already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048200</ErrorId>
<ManagedErrorName>MultipleRelationshipsNotSupported</ManagedErrorName>
<ErrorMessage>Multiple relationships are not supported</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004810c</ErrorId>
<ManagedErrorName>ImportDuplicateEntity</ManagedErrorName>
<ErrorMessage>This import has failed because a different entity with the identical name, {0}, already exists in the target organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004810b</ErrorId>
<ManagedErrorName>CascadeProxyEmptyCallerId</ManagedErrorName>
<ErrorMessage>Empty Caller Id</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004810a</ErrorId>
<ManagedErrorName>CascadeProxyInvalidPrincipalType</ManagedErrorName>
<ErrorMessage>Invalid security principal type</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048109</ErrorId>
<ManagedErrorName>CascadeProxyInvalidNativeDAPtr</ManagedErrorName>
<ErrorMessage>Invalid pointer of unmanaged data access object</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048108</ErrorId>
<ManagedErrorName>CascadeFailToCreateNativeDAWrapper</ManagedErrorName>
<ErrorMessage>Failed to create unmanaged data access wrapper</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048107</ErrorId>
<ManagedErrorName>CascadeReparentOnNonUserOwned</ManagedErrorName>
<ErrorMessage>Cannot perform Cascade Reparent on Non-UserOwned entities</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048106</ErrorId>
<ManagedErrorName>CascadeMergeInvalidSpecialColumn</ManagedErrorName>
<ErrorMessage>Invalid Column Name for Merge Special Casing</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048104</ErrorId>
<ManagedErrorName>CascadeRemoveLinkOnNonNullable</ManagedErrorName>
<ErrorMessage>CascadeDelete is defined as RemoveLink while the foreign key is not nullable</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048103</ErrorId>
<ManagedErrorName>CascadeDeleteNotAllowDelete</ManagedErrorName>
<ErrorMessage>Object is not allowed to be deleted</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048102</ErrorId>
<ManagedErrorName>CascadeInvalidLinkType</ManagedErrorName>
<ErrorMessage>Invalid CascadeLink Type</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048029</ErrorId>
<ManagedErrorName>IsvExtensionsPrivilegeNotPresent</ManagedErrorName>
<ErrorMessage>To import ISV.Config, your user account must be associated with a security role that includes the ISV Extensions privilege.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004802A</ErrorId>
<ManagedErrorName>RelationshipNameLengthExceedsLimit</ManagedErrorName>
<ErrorMessage>Relationship name cannot be more than 50 characters long.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004802B</ErrorId>
<ManagedErrorName>ImportEmailTemplateErrorMissingFile</ManagedErrorName>
<ErrorMessage>E-mail Template '{0}' import: The attachment '{1}' was not found in the import zip file.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048101</ErrorId>
<ManagedErrorName>CascadeInvalidExtraConditionValue</ManagedErrorName>
<ErrorMessage>Invalid Extra-condition value</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048027</ErrorId>
<ManagedErrorName>ImportWorkflowNameConflictError</ManagedErrorName>
<ErrorMessage>Workflow {0} cannot be imported because a workflow with same name and different unique identifier exists in the target system. Change the name of this workflow, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048028</ErrorId>
<ManagedErrorName>ImportWorkflowPublishedError</ManagedErrorName>
<ErrorMessage>Workflow {0}({1}) cannot be imported because a workflow with same unique identifier is published on the target system. Unpublish the workflow on the target system before attempting to import this workflow again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048023</ErrorId>
<ManagedErrorName>ImportWorkflowEntityDependencyError</ManagedErrorName>
<ErrorMessage>Cannot import workflow definition. Required entity dependency is missing.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048022</ErrorId>
<ManagedErrorName>ImportWorkflowAttributeDependencyError</ManagedErrorName>
<ErrorMessage>Cannot import workflow definition. Required attribute dependency is missing.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048021</ErrorId>
<ManagedErrorName>ImportWorkflowError</ManagedErrorName>
<ErrorMessage>Cannot import workflow definition. The workflow with specified workflow id is not updatable or workflow name is not unique.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048020</ErrorId>
<ManagedErrorName>ImportGenericEntitiesError</ManagedErrorName>
<ErrorMessage>An error occurred while importing generic entities.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048018</ErrorId>
<ManagedErrorName>ImportRolePermissionError</ManagedErrorName>
<ErrorMessage>You do not have the necessary privileges to import security roles.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048017</ErrorId>
<ManagedErrorName>ImportRoleError</ManagedErrorName>
<ErrorMessage>Cannot import security role. The role with specified role id is not updatable or role name is not unique.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048019</ErrorId>
<ManagedErrorName>ImportOrgSettingsError</ManagedErrorName>
<ErrorMessage>There was an error parsing the Organization Settings during Import.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048052</ErrorId>
<ManagedErrorName>InvalidSharePointSiteCollectionUrl</ManagedErrorName>
<ErrorMessage>The URL must conform to the http or https schema.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048053</ErrorId>
<ManagedErrorName>InvalidSiteRelativeUrlFormat</ManagedErrorName>
<ErrorMessage>The relative url contains invalid characters. Please use a different name. Valid relative url names cannot end with the following strings: .aspx, .ashx, .asmx, .svc , cannot begin or end with a dot or /, cannot contain consecutive dots or / and cannot contain any of the following characters: ~ &quot; # % &amp; * : &lt; &gt; ? \ { | }.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048054</ErrorId>
<ManagedErrorName>InvalidRelativeUrlFormat</ManagedErrorName>
<ErrorMessage>The relative url contains invalid characters. Please use a different name. Valid relative url names cannot ends with the following strings: .aspx, .ashx, .asmx, .svc , cannot begin or end with a dot, cannot contain consecutive dots and cannot contain any of the following characters: ~ &quot; # % &amp; * : &lt; &gt; ? / \ { | }.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048055</ErrorId>
<ManagedErrorName>InvalidAbsoluteUrlFormat</ManagedErrorName>
<ErrorMessage>The absolute url contains invalid characters. Please use a different name. Valid absolute url cannot ends with the following strings: .aspx, .ashx, .asmx, .svc</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048056</ErrorId>
<ManagedErrorName>InvalidUrlConsecutiveSlashes</ManagedErrorName>
<ErrorMessage>The Url contains consecutive slashes which is not allowed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048057</ErrorId>
<ManagedErrorName>SharePointRecordWithDuplicateUrl</ManagedErrorName>
<ErrorMessage>There is already a record with the same Url.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048149</ErrorId>
<ManagedErrorName>SharePointAbsoluteAndRelativeUrlEmpty</ManagedErrorName>
<ErrorMessage>Both absolute URL and relative URL cannot be null.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048030</ErrorId>
<ManagedErrorName>ImportOptionSetsError</ManagedErrorName>
<ErrorMessage>An error occurred while importing OptionSets.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048031</ErrorId>
<ManagedErrorName>ImportRibbonsError</ManagedErrorName>
<ErrorMessage>An error occurred while importing Ribbons.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048032</ErrorId>
<ManagedErrorName>ImportReportsError</ManagedErrorName>
<ErrorMessage>An error occurred while importing Reports.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048033</ErrorId>
<ManagedErrorName>ImportSolutionError</ManagedErrorName>
<ErrorMessage>An error occurred while importing a Solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048034</ErrorId>
<ManagedErrorName>ImportDependencySolutionError</ManagedErrorName>
<ErrorMessage>{0} requires solutions that are not currently installed. Import the following solutions before Importing this one. {1} </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048035</ErrorId>
<ManagedErrorName>ExportSolutionError</ManagedErrorName>
<ErrorMessage>An error occurred while exporting a Solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048036</ErrorId>
<ManagedErrorName>ExportManagedSolutionError</ManagedErrorName>
<ErrorMessage>An error occurred while exporting a solution. Managed solutions cannot be exported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048037</ErrorId>
<ManagedErrorName>ExportMissingSolutionError</ManagedErrorName>
<ErrorMessage>An error occurred while exporting a solution. The solution does not exist in this system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048038</ErrorId>
<ManagedErrorName>ImportSolutionManagedError</ManagedErrorName>
<ErrorMessage>Solution '{0}' already exists in this system as managed and cannot be upgraded.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048039</ErrorId>
<ManagedErrorName>ImportOptionSetAttributeError</ManagedErrorName>
<ErrorMessage>Attribute '{0}' was not imported as it references a non-existing global Option Set ('{1}').</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048040</ErrorId>
<ManagedErrorName>ImportSolutionManagedToUnmanagedMismatch</ManagedErrorName>
<ErrorMessage>The solution is already installed on this system as an unmanaged solution and the package supplied is attempting to install it in managed mode. Import can only update solutions when the modes match. Uninstall the current solution and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048041</ErrorId>
<ManagedErrorName>ImportSolutionUnmanagedToManagedMismatch</ManagedErrorName>
<ErrorMessage>The solution is already installed on this system as a managed solution and the package supplied is attempting to install it in unmanaged mode. Import can only update solutions when the modes match. Uninstall the current solution and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048042</ErrorId>
<ManagedErrorName>ImportSolutionIsvConfigWarning</ManagedErrorName>
<ErrorMessage>ISV Config was overwritten.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048043</ErrorId>
<ManagedErrorName>ImportSolutionSiteMapWarning</ManagedErrorName>
<ErrorMessage>SiteMap was overwritten.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048044</ErrorId>
<ManagedErrorName>ImportSolutionOrganizationSettingsWarning</ManagedErrorName>
<ErrorMessage>Organization settings were overwritten.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048045</ErrorId>
<ManagedErrorName>ImportExportDeprecatedError</ManagedErrorName>
<ErrorMessage>This message is no longer available. Please consult the SDK for alternative messages.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048046</ErrorId>
<ManagedErrorName>ImportSystemSolutionError</ManagedErrorName>
<ErrorMessage>System solution cannot be imported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048047</ErrorId>
<ManagedErrorName>ImportTranslationMissingSolutionError</ManagedErrorName>
<ErrorMessage>An error occurred while importing the translations. The solution associated with the translations does not exist in this system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048048</ErrorId>
<ManagedErrorName>ExportDefaultAsPackagedError</ManagedErrorName>
<ErrorMessage>The default solution cannot be exported as a package.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048049</ErrorId>
<ManagedErrorName>ImportDefaultAsPackageError</ManagedErrorName>
<ErrorMessage>The package supplied for the default solution is trying to install it in managed mode. The default solution cannot be managed. In the XML for the default solution, set the Managed value back to "false" and try to import the solution again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048060</ErrorId>
<ManagedErrorName>ImportCustomizationsBadZipFileError</ManagedErrorName>
<ErrorMessage>The solution file is invalid. The compressed file must contain the following files at its root: solution.xml, customizations.xml, and [Content_Types].xml. Customization files exported from previous versions of Microsoft Dynamics CRM are not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048061</ErrorId>
<ManagedErrorName>ImportTranslationsBadZipFileError</ManagedErrorName>
<ErrorMessage>The translation file is invalid. The compressed file must contain the following files at its root: {0}, [Content_Types].xml.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048062</ErrorId>
<ManagedErrorName>ImportAttributeNameError</ManagedErrorName>
<ErrorMessage>Invalid name for attribute {0}.  Custom attribute names must start with a valid customization prefix. The prefix for a solution component should match the prefix that is specified for the publisher of the solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048063</ErrorId>
<ManagedErrorName>ImportFieldSecurityProfileIsSecuredMissingError</ManagedErrorName>
<ErrorMessage>Some field security permissions could not be imported because the following fields are not securable: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048064</ErrorId>
<ManagedErrorName>ImportFieldSecurityProfileAttributesMissingError</ManagedErrorName>
<ErrorMessage>Some field security permissions could not be imported because the following fields are not in the system: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048065</ErrorId>
<ManagedErrorName>ImportFileSignatureInvalid</ManagedErrorName>
<ErrorMessage>The import file has an invalid digital signature.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048066</ErrorId>
<ManagedErrorName>ImportSolutionPackageNotValid</ManagedErrorName>
<ErrorMessage>The solution package you are importing was generated on a version of Microsoft Dynamics CRM that cannot be imported into this system. Package Version: {0} {1}, System Version: {2} {3}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048067</ErrorId>
<ManagedErrorName>ImportSolutionPackageNeedsUpgrade</ManagedErrorName>
<ErrorMessage>The solution package you are importing was generated on a different version of Microsoft Dynamics CRM. The system will attempt to transform the package prior to import. Package Version: {0} {1}, System Version: {2} {3}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048068</ErrorId>
<ManagedErrorName>ImportSolutionPackageInvalidSolutionPackageVersion</ManagedErrorName>
<ErrorMessage>You can only import solutions with a package version of {0} or earlier into this organization. Also, you can't import any solutions into this organization that were exported from Microsoft Dynamics CRM 2011 or earlier.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>00000001</ErrorId>
<ManagedErrorName>ImportSolutionPackageMinimumVersionNeeded</ManagedErrorName>
<ErrorMessage>Deprecated, not removing now as it might cause issues during integrations.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048069</ErrorId>
<ManagedErrorName>ImportSolutionPackageRequiresOptInAvailable</ManagedErrorName>
<ErrorMessage>Some components in the solution package you are importing require opt in. Opt in is available, please consult your administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004806A</ErrorId>
<ManagedErrorName>ImportSolutionPackageRequiresOptInNotAvailable</ManagedErrorName>
<ErrorMessage>The solution package you are importing was generated on a SKU of Microsoft Dynamics CRM that supports opt in. It cannot be imported in your system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048016</ErrorId>
<ManagedErrorName>ImportSdkMessagesError</ManagedErrorName>
<ErrorMessage>An error occurred while importing Sdk Messages.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048014</ErrorId>
<ManagedErrorName>ImportEmailTemplatePersonalError</ManagedErrorName>
<ErrorMessage>E-mail Template was not imported. The Template is a personal template on the target system; import cannot overwrite personal templates.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048013</ErrorId>
<ManagedErrorName>ImportNonWellFormedFileError</ManagedErrorName>
<ErrorMessage>Invalid customization file. This file is not well formed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048012</ErrorId>
<ManagedErrorName>ImportPluginTypesError</ManagedErrorName>
<ErrorMessage>An error occurred while importing plug-in types.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048011</ErrorId>
<ManagedErrorName>ImportSiteMapError</ManagedErrorName>
<ErrorMessage>An error occurred while importing the Site Map.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048010</ErrorId>
<ManagedErrorName>ImportMappingsMissingEntityMapError</ManagedErrorName>
<ErrorMessage>This customization file contains a reference to an entity map that does not exist on the target system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004800F</ErrorId>
<ManagedErrorName>ImportMappingsSystemMapError</ManagedErrorName>
<ErrorMessage>Import cannot create system attribute mappings</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004800E</ErrorId>
<ManagedErrorName>ImportIsvConfigError</ManagedErrorName>
<ErrorMessage>There was an error parsing the IsvConfig during Import</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004800D</ErrorId>
<ManagedErrorName>ImportArticleTemplateError</ManagedErrorName>
<ErrorMessage>There was an error in parsing the article templates in Import Xml</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004800C</ErrorId>
<ManagedErrorName>ImportEmailTemplateError</ManagedErrorName>
<ErrorMessage>There was an error in parsing the email templates in Import Xml</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004800B</ErrorId>
<ManagedErrorName>ImportContractTemplateError</ManagedErrorName>
<ErrorMessage>There was an error in parsing the contract templates in Import Xml</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004800A</ErrorId>
<ManagedErrorName>ImportRelationshipRoleMapsError</ManagedErrorName>
<ErrorMessage>The number of format parameters passed into the input string is incorrect</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048009</ErrorId>
<ManagedErrorName>ImportRelationshipRolesError</ManagedErrorName>
<ErrorMessage>The number of format parameters passed into the input string is incorrect</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004802F</ErrorId>
<ManagedErrorName>ImportRelationshipRolesPrivilegeError</ManagedErrorName>
<ErrorMessage>{0} cannot be imported. The {1} privilege is required to import this component.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048008</ErrorId>
<ManagedErrorName>ImportEntityNameMismatchError</ManagedErrorName>
<ErrorMessage>The number of format parameters passed into the input string is incorrect</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048007</ErrorId>
<ManagedErrorName>ImportFormXmlError</ManagedErrorName>
<ErrorMessage>The number of format parameters passed into the input string is incorrect</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048006</ErrorId>
<ManagedErrorName>ImportFieldXmlError</ManagedErrorName>
<ErrorMessage>The number of format parameters passed into the input string is incorrect</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048005</ErrorId>
<ManagedErrorName>ImportSavedQueryExistingError</ManagedErrorName>
<ErrorMessage>The number of format parameters passed into the input string is incorrect</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048004</ErrorId>
<ManagedErrorName>ImportSavedQueryOtcMismatchError</ManagedErrorName>
<ErrorMessage>There was an error processing saved queries of the same object type code (unresolvable system collision)</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048003</ErrorId>
<ManagedErrorName>ImportEntityCustomResourcesNewStringError</ManagedErrorName>
<ErrorMessage>Invalid Entity new string in the Custom Resources</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048002</ErrorId>
<ManagedErrorName>ImportEntityCustomResourcesError</ManagedErrorName>
<ErrorMessage>Invalid Custom Resources in the Import File</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048001</ErrorId>
<ManagedErrorName>ImportEntityIconError</ManagedErrorName>
<ErrorMessage>Invalid Icon in the Import File</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004801B</ErrorId>
<ManagedErrorName>ImportSavedQueryDeletedError</ManagedErrorName>
<ErrorMessage>A saved query with the same id is marked as deleted in the system. Please first publish the customized entity and import again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048024</ErrorId>
<ManagedErrorName>ImportEntitySystemUserOnPremiseMismatchError</ManagedErrorName>
<ErrorMessage>The systemuser entity was imported, but customized forms for the entity were not imported. Systemuser entity forms from Microsoft Dynamics CRM Online cannot be imported into on-premises or hosted versions of Microsoft Dynamics CRM.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048025</ErrorId>
<ManagedErrorName>ImportEntitySystemUserLiveMismatchError</ManagedErrorName>
<ErrorMessage>The systemuser entity was imported but customized forms for the entity were not imported. Systemuser entity forms from on-premises or hosted versions of Microsoft Dynamics CRM cannot be imported into Microsoft Dynamics CRM Online.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048026</ErrorId>
<ManagedErrorName>ImportLanguagesIgnoredError</ManagedErrorName>
<ErrorMessage>Translated labels for the following languages could not be imported because they have not been enabled for this organization: {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048000</ErrorId>
<ManagedErrorName>ImportInvalidFileError</ManagedErrorName>
<ErrorMessage>Invalid Import File</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004801A</ErrorId>
<ManagedErrorName>ImportXsdValidationError</ManagedErrorName>
<ErrorMessage>The import file is invalid. XSD validation failed with the following error: '{0}'. The validation failed at: '...{1} &lt;&lt;&lt;&lt;&lt;ERROR LOCATION&gt;&gt;&gt;&gt;&gt; {2}...'."</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004802C</ErrorId>
<ManagedErrorName>ImportInvalidXmlError</ManagedErrorName>
<ErrorMessage>This solution package cannot be imported because it contains invalid XML. You can attempt to repair the file by manually editing the XML contents using the information found in the schema validation errors, or you can contact your solution provider.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004801C</ErrorId>
<ManagedErrorName>ImportWrongPublisherError</ManagedErrorName>
<ErrorMessage>The following managed solution cannot be imported: {0}. The publisher name cannot be changed from {1} to {2}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004801D</ErrorId>
<ManagedErrorName>ImportMissingDependenciesError</ManagedErrorName>
<ErrorMessage>The following solution cannot be imported: {0}. Some dependencies are missing.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004801E</ErrorId>
<ManagedErrorName>ImportGenericError</ManagedErrorName>
<ErrorMessage>The import failed. For more information, see the related error messages.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004801F</ErrorId>
<ManagedErrorName>ImportMissingComponent</ManagedErrorName>
<ErrorMessage>Cannot add a Root Component {0} of type {1} because it is not in the target system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004803A</ErrorId>
<ManagedErrorName>ImportMissingRootComponentEntry</ManagedErrorName>
<ErrorMessage>The import has failed because component {0} of type {1} is not declared in the solution file as a root component. To fix this, import again using the XML file that was generated when you exported the solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004803B</ErrorId>
<ManagedErrorName>UnmanagedComponentParentsManagedComponent</ManagedErrorName>
<ErrorMessage>Found {0} dependency records where unmanaged component is the parent of a managed component. First record (dependentcomponentobjectid = {1}, type = {2}, requiredcomponentobjectid = {3}, type= {4}, solution = {5}).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047103</ErrorId>
<ManagedErrorName>FailedToGetNetworkServiceName</ManagedErrorName>
<ErrorMessage>Failed to obtain the localized name for NetworkService account</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047102</ErrorId>
<ManagedErrorName>CustomParentingSystemNotSupported</ManagedErrorName>
<ErrorMessage>A custom entity can not have a parental relationship to a system entity</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047101</ErrorId>
<ManagedErrorName>InvalidFormatParameters</ManagedErrorName>
<ErrorMessage>The number of format parameters passed into the input string is incorrect</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004701F</ErrorId>
<ManagedErrorName>InvalidHierarchicalRelationship</ManagedErrorName>
<ErrorMessage>This relationship is not self-referential and therefore cannot be made hierarchical.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004701E</ErrorId>
<ManagedErrorName>DuplicatePrimaryNameAttribute</ManagedErrorName>
<ErrorMessage>The new {2} attribute is set as the primary name attribute for the {1} entity. The {1} entity already has the {0} attribute set as the primary name attribute. An entity can only have one primary name attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004701D</ErrorId>
<ManagedErrorName>ConfigurationPageNotValidForSolution</ManagedErrorName>
<ErrorMessage>The solution configuration page must exist within the solution it represents.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004701C</ErrorId>
<ManagedErrorName>SolutionConfigurationPageMustBeHtmlWebResource</ManagedErrorName>
<ErrorMessage>The solution configuration page must exist within the solution it represents.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004701B</ErrorId>
<ManagedErrorName>InvalidSolutionConfigurationPage</ManagedErrorName>
<ErrorMessage>The specified configuration page for this solution is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004701a</ErrorId>
<ManagedErrorName>InvalidHierarchicalRelationshipChange</ManagedErrorName>
<ErrorMessage>You can’t change this entity’s hierarchy because the {0} hierarchical relationship can’t be customized.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047019</ErrorId>
<ManagedErrorName>InvalidLanguageForSolution</ManagedErrorName>
<ErrorMessage>Solution and Publisher Options are not available since your language does not match system base language.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047018</ErrorId>
<ManagedErrorName>CannotHaveDuplicateYomi</ManagedErrorName>
<ErrorMessage>One attribute can be tied to only one yomi at a time</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047017</ErrorId>
<ManagedErrorName>SavedQueryIsNotCustomizable</ManagedErrorName>
<ErrorMessage>The specified view is not customizable</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047016</ErrorId>
<ManagedErrorName>CannotDeleteChildAttribute</ManagedErrorName>
<ErrorMessage>The Child Attribute is not valid for deletion</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047015</ErrorId>
<ManagedErrorName>EntityHasNoStateCode</ManagedErrorName>
<ErrorMessage>Specified entity does not have a statecode.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047014</ErrorId>
<ManagedErrorName>NoAttributesForEntityCreate</ManagedErrorName>
<ErrorMessage>No attributes for Create Entity action.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047013</ErrorId>
<ManagedErrorName>DuplicateAttributeSchemaName</ManagedErrorName>
<ErrorMessage>An attribute with the specified name already exists</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047012</ErrorId>
<ManagedErrorName>DuplicateDisplayCollectionName</ManagedErrorName>
<ErrorMessage>An object with the specified display collection name already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047011</ErrorId>
<ManagedErrorName>DuplicateDisplayName</ManagedErrorName>
<ErrorMessage>An object with the specified display name already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047010</ErrorId>
<ManagedErrorName>DuplicateName</ManagedErrorName>
<ErrorMessage>An object with the specified name already exists</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004700f</ErrorId>
<ManagedErrorName>InvalidRelationshipType</ManagedErrorName>
<ErrorMessage>The specified relationship type is not valid for this operation</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004700e</ErrorId>
<ManagedErrorName>InvalidPrimaryFieldType</ManagedErrorName>
<ErrorMessage>Primary UI Attribute has to be of type String</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004700d</ErrorId>
<ManagedErrorName>InvalidOwnershipTypeMask</ManagedErrorName>
<ErrorMessage>The specified ownership type mask is not valid for this operation</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_OWNERSHIPTYPEMASK</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004700c</ErrorId>
<ManagedErrorName>InvalidDisplayName</ManagedErrorName>
<ErrorMessage>The specified display name is not valid</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004700b</ErrorId>
<ManagedErrorName>InvalidSchemaName</ManagedErrorName>
<ErrorMessage>An entity with the specified name already exists. Please specify a unique name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004700a</ErrorId>
<ManagedErrorName>RelationshipIsNotCustomRelationship</ManagedErrorName>
<ErrorMessage>The specified relationship is not a custom relationship</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047009</ErrorId>
<ManagedErrorName>AttributeIsNotCustomAttribute</ManagedErrorName>
<ErrorMessage>The specified attribute is not a custom attribute</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047008</ErrorId>
<ManagedErrorName>EntityIsNotCustomizable</ManagedErrorName>
<ErrorMessage>The specified entity is not customizable</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047007</ErrorId>
<ManagedErrorName>MultipleParentsNotSupported</ManagedErrorName>
<ErrorMessage>An entity can have only one parental relationship</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047006</ErrorId>
<ManagedErrorName>CannotCreateActivityRelationship</ManagedErrorName>
<ErrorMessage>Relationship with activities cannot be created through this operation</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047004</ErrorId>
<ManagedErrorName>CyclicalRelationship</ManagedErrorName>
<ErrorMessage>The specified relationship will result in a cycle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047003</ErrorId>
<ManagedErrorName>InvalidRelationshipDescription</ManagedErrorName>
<ErrorMessage>The specified relationship cannot be created</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047002</ErrorId>
<ManagedErrorName>CannotDeletePrimaryUIAttribute</ManagedErrorName>
<ErrorMessage>The Primary UI Attribute is not valid for deletion</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047001</ErrorId>
<ManagedErrorName>RowGuidIsNotValidName</ManagedErrorName>
<ErrorMessage>rowguid is a reserved name and cannot be used as an identifier</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80047000</ErrorId>
<ManagedErrorName>FailedToScheduleActivity</ManagedErrorName>
<ErrorMessage>Failed to schedule activity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80046FFF</ErrorId>
<ManagedErrorName>CannotDeleteLastEmailAttribute</ManagedErrorName>
<ErrorMessage>You cannot delete this field because the record type has been enabled for e-mail.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80046205</ErrorId>
<ManagedErrorName>SystemAttributeMap</ManagedErrorName>
<ErrorMessage>SystemAttributeMap Error Occurred</ErrorMessage>
<UnManagedErrorName>IDS_ENTITYMAPPER_CANT_DELETE_SYSTEM_ATTRIBUTEMAP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80046204</ErrorId>
<ManagedErrorName>UpdateAttributeMap</ManagedErrorName>
<ErrorMessage>UpdateAttributeMap Error Occurred</ErrorMessage>
<UnManagedErrorName>IDS_ENTITYMAPPER_CANT_UPDATE_ATTRIBUTEMAP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80046203</ErrorId>
<ManagedErrorName>InvalidAttributeMap</ManagedErrorName>
<ErrorMessage>InvalidAttributeMap Error Occurred</ErrorMessage>
<UnManagedErrorName>IDS_ENTITYMAPPER_INVALID_ATTRIBUTEMAP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80046202</ErrorId>
<ManagedErrorName>SystemEntityMap</ManagedErrorName>
<ErrorMessage>SystemEntityMap Error Occurred</ErrorMessage>
<UnManagedErrorName>IDS_ENTITYMAPPER_CANT_DELETE_SYSTEM_ENTITYMAP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80046201</ErrorId>
<ManagedErrorName>UpdateEntityMap</ManagedErrorName>
<ErrorMessage>UpdateEntityMap Error Occurred</ErrorMessage>
<UnManagedErrorName>IDS_ENTITYMAPPER_CANT_UPDATE_ENTITYMAP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80046200</ErrorId>
<ManagedErrorName>NonMappableEntity</ManagedErrorName>
<ErrorMessage>NonMappableEntity Error Occurred</ErrorMessage>
<UnManagedErrorName>IDS_ENTITYMAPPER_NON_MAPPABLE_ENTITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045f05</ErrorId>
<ManagedErrorName>unManagedidsCalloutException</ManagedErrorName>
<ErrorMessage>Callout code throws exception</ErrorMessage>
<UnManagedErrorName>IDS_CALLOUT_EXCEPTION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045f04</ErrorId>
<ManagedErrorName>unManagedidscalloutinvalidevent</ManagedErrorName>
<ErrorMessage>Invalid callout event</ErrorMessage>
<UnManagedErrorName>IDS_CALLOUT_INVALID_EVENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045f03</ErrorId>
<ManagedErrorName>unManagedidscalloutinvalidconfig</ManagedErrorName>
<ErrorMessage>Invalid callout configuration</ErrorMessage>
<UnManagedErrorName>IDS_CALLOUT_INVALID_CONFIG</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045f02</ErrorId>
<ManagedErrorName>unManagedidscalloutisvstop</ManagedErrorName>
<ErrorMessage>Callout ISV code stopped the operation</ErrorMessage>
<UnManagedErrorName>IDS_CALLOUT_ISV_STOP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045f01</ErrorId>
<ManagedErrorName>unManagedidscalloutisvabort</ManagedErrorName>
<ErrorMessage>Callout ISV code aborted the operation</ErrorMessage>
<UnManagedErrorName>IDS_CALLOUT_ISV_ABORT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045f00</ErrorId>
<ManagedErrorName>unManagedidscalloutisvexception</ManagedErrorName>
<ErrorMessage>Callout ISV code throws exception</ErrorMessage>
<UnManagedErrorName>IDS_CALLOUT_ISV_EXCEPTION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004590d</ErrorId>
<ManagedErrorName>unManagedidscustomentityambiguousrelationship</ManagedErrorName>
<ErrorMessage>More than one relationship between the requested entities exists.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_AMBIGUOUS_RELATIONSHIP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004590c</ErrorId>
<ManagedErrorName>unManagedidscustomentitynorelationship</ManagedErrorName>
<ErrorMessage>No relationship exists between the requested entities.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_NO_RELATIONSHIP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004590b</ErrorId>
<ManagedErrorName>unManagedidscustomentityparentchildidentical</ManagedErrorName>
<ErrorMessage>The supplied parent and child entities are identical.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_PARENTCHILD_IDENTICAL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004590a</ErrorId>
<ManagedErrorName>unManagedidscustomentityinvalidparent</ManagedErrorName>
<ErrorMessage>The supplied parent passed in is not a valid entity.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_INVALID_PARENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045909</ErrorId>
<ManagedErrorName>unManagedidscustomentityinvalidchild</ManagedErrorName>
<ErrorMessage>The supplied child passed in is not a valid entity.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_INVALID_CHILD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045908</ErrorId>
<ManagedErrorName>unManagedidscustomentitywouldcreateloop</ManagedErrorName>
<ErrorMessage>This association would create a loop in the database.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_WOULD_CREATE_LOOP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045907</ErrorId>
<ManagedErrorName>unManagedidscustomentityexistingloop</ManagedErrorName>
<ErrorMessage>There is an existing loop in the database.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_EXISTING_LOOP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045906</ErrorId>
<ManagedErrorName>unManagedidscustomentitystackunderflow</ManagedErrorName>
<ErrorMessage>Custom entity MD stack underflow.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_STACK_UNDERFLOW</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045905</ErrorId>
<ManagedErrorName>unManagedidscustomentitystackoverflow</ManagedErrorName>
<ErrorMessage>Custom entity MD stack overflow.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_STACK_OVERFLOW</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045904</ErrorId>
<ManagedErrorName>unManagedidscustomentitytlsfailure</ManagedErrorName>
<ErrorMessage>Custom entity MD TLS not initialized.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_TLS_FAILURE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045903</ErrorId>
<ManagedErrorName>unManagedidscustomentityinvalidownership</ManagedErrorName>
<ErrorMessage>Custom entity ownership type mask is improperly set.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_INVALID_OWNERSHIP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045902</ErrorId>
<ManagedErrorName>unManagedidscustomentitynotinitialized</ManagedErrorName>
<ErrorMessage>Custom entity interface was not properly initialized.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_NOT_INITIALIZED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045901</ErrorId>
<ManagedErrorName>unManagedidscustomentityalreadyinitialized</ManagedErrorName>
<ErrorMessage>Custom entity interface already initialized on this thread.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_ALREADY_INITIALIZED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045900</ErrorId>
<ManagedErrorName>unManagedidscustomentitynameviolation</ManagedErrorName>
<ErrorMessage>Supplied entity found, but it is not a custom entity.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMENTITY_NAME_VIOLATION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045603</ErrorId>
<ManagedErrorName>unManagedidscascadeunexpectederror</ManagedErrorName>
<ErrorMessage>Unexpected error occurred in cascading operation</ErrorMessage>
<UnManagedErrorName>IDS_CASCADE_UNEXPECTED_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045602</ErrorId>
<ManagedErrorName>unManagedidscascadeemptylinkerror</ManagedErrorName>
<ErrorMessage>The relationship link is empty</ErrorMessage>
<UnManagedErrorName>IDS_CASCADE_EMPTY_LINK_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045601</ErrorId>
<ManagedErrorName>unManagedidscascadeundefinedrelationerror</ManagedErrorName>
<ErrorMessage>Relationship type is not supported</ErrorMessage>
<UnManagedErrorName>IDS_CASCADE_UNDEFINED_RELATION_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045600</ErrorId>
<ManagedErrorName>unManagedidscascadeinconsistencyerror</ManagedErrorName>
<ErrorMessage>Cascade map information is inconsistent.</ErrorMessage>
<UnManagedErrorName>IDS_CASCADE_INCONSISTENCY_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045317</ErrorId>
<ManagedErrorName>MergeLossOfParentingWarning</ManagedErrorName>
<ErrorMessage>Merge warning: sub-entity might lose parenting</ErrorMessage>
<UnManagedErrorName>IDS_MERGE_LOSS_OF_PARENTING_WARNING</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045316</ErrorId>
<ManagedErrorName>MergeDifferentlyParentedWarning</ManagedErrorName>
<ErrorMessage>Merge warning: sub-entity will be differently parented.</ErrorMessage>
<UnManagedErrorName>IDS_MERGE_DIFFERENTLY_PARENTED_WARNING</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045305</ErrorId>
<ManagedErrorName>MergeEntitiesIdenticalError</ManagedErrorName>
<ErrorMessage>Merge cannot be performed on master and sub-entities that are identical.</ErrorMessage>
<UnManagedErrorName>IDS_MERGE_ENTITIES_IDENTICAL_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045304</ErrorId>
<ManagedErrorName>MergeEntityNotActiveError</ManagedErrorName>
<ErrorMessage>Merge cannot be performed on entity that is inactive.</ErrorMessage>
<UnManagedErrorName>IDS_MERGE_ENTITY_NOT_ACTIVE_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045303</ErrorId>
<ManagedErrorName>unManagedidsmergedifferentbizorgerror</ManagedErrorName>
<ErrorMessage>Merge cannot be performed on entities from different business entity.</ErrorMessage>
<UnManagedErrorName>IDS_MERGE_DIFFERENT_BIZORG_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045302</ErrorId>
<ManagedErrorName>MergeActiveQuoteError</ManagedErrorName>
<ErrorMessage>Merge cannot be performed on sub-entity that has active quote.</ErrorMessage>
<UnManagedErrorName>IDS_MERGE_ACTIVE_QUOTE_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045301</ErrorId>
<ManagedErrorName>MergeSecurityError</ManagedErrorName>
<ErrorMessage>Merge is not allowed: caller does not have the privilege or access.</ErrorMessage>
<UnManagedErrorName>IDS_MERGE_SECURITY_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045300</ErrorId>
<ManagedErrorName>MergeCyclicalParentingError</ManagedErrorName>
<ErrorMessage>Merge could create cyclical parenting.</ErrorMessage>
<UnManagedErrorName>IDS_MERGE_CYCLICAL_PARENTING_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045100</ErrorId>
<ManagedErrorName>unManagedidscalendarruledoesnotexist</ManagedErrorName>
<ErrorMessage>The calendar rule does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_CALENDAR_RULE_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044d00</ErrorId>
<ManagedErrorName>unManagedidscalendarinvalidcalendar</ManagedErrorName>
<ErrorMessage>The calendar is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CALENDAR_INVALID_CALENDAR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044a08</ErrorId>
<ManagedErrorName>AttachmentInvalidFileName</ManagedErrorName>
<ErrorMessage>Attachment file name contains invalid characters.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044a07</ErrorId>
<ManagedErrorName>unManagedidsattachmentcannottruncatetempfile</ManagedErrorName>
<ErrorMessage>Cannot truncate temporary attachment file.</ErrorMessage>
<UnManagedErrorName>IDS_ATTACHMENT_CANNOT_TRUNCATE_TEMPFILE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044a06</ErrorId>
<ManagedErrorName>unManagedidsattachmentcannotunmaptempfile</ManagedErrorName>
<ErrorMessage>Cannot unmap temporary attachment file.</ErrorMessage>
<UnManagedErrorName>IDS_ATTACHMENT_CANNOT_UNMAP_TEMPFILE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044a05</ErrorId>
<ManagedErrorName>unManagedidsattachmentcannotcreatetempfile</ManagedErrorName>
<ErrorMessage>Cannot create temporary attachment file.</ErrorMessage>
<UnManagedErrorName>IDS_ATTACHMENT_CANNOT_CREATE_TEMPFILE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044a04</ErrorId>
<ManagedErrorName>unManagedidsattachmentisempty</ManagedErrorName>
<ErrorMessage>Attachment is empty.</ErrorMessage>
<UnManagedErrorName>IDS_ATTACHMENT_IS_EMPTY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044a03</ErrorId>
<ManagedErrorName>unManagedidsattachmentcannotreadtempfile</ManagedErrorName>
<ErrorMessage>Cannot read temporary attachment file.</ErrorMessage>
<UnManagedErrorName>IDS_ATTACHMENT_CANNOT_READ_TEMPFILE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044a02</ErrorId>
<ManagedErrorName>unManagedidsattachmentinvalidfilesize</ManagedErrorName>
<ErrorMessage>Attachment file size is too big.</ErrorMessage>
<UnManagedErrorName>IDS_ATTACHMENT_INVALID_FILESIZE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044a01</ErrorId>
<ManagedErrorName>unManagedidsattachmentcannotgetfilesize</ManagedErrorName>
<ErrorMessage>Cannot get temporary attachment file size.</ErrorMessage>
<UnManagedErrorName>IDS_ATTACHMENT_CANNOT_GET_FILESIZE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044a00</ErrorId>
<ManagedErrorName>unManagedidsattachmentcannotopentempfile</ManagedErrorName>
<ErrorMessage>Cannot open temporary attachment file.</ErrorMessage>
<UnManagedErrorName>IDS_ATTACHMENT_CANNOT_OPEN_TEMPFILE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044700</ErrorId>
<ManagedErrorName>unManagedidscustomizationtransformationnotsupported</ManagedErrorName>
<ErrorMessage>Transformation is not supported for this object.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMIZATION_TRANSFORMATION_NOTSUPPORTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044414</ErrorId>
<ManagedErrorName>ContractDetailDiscountAmountAndPercent</ManagedErrorName>
<ErrorMessage>Both 'amount' and 'percentage' cannot be set.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044413</ErrorId>
<ManagedErrorName>ContractDetailDiscountAmount</ManagedErrorName>
<ErrorMessage>The contract's discount type does not support 'percentage' discounts.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044412</ErrorId>
<ManagedErrorName>ContractDetailDiscountPercent</ManagedErrorName>
<ErrorMessage>The contract's discount type does not support 'amount' discounts.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044411</ErrorId>
<ManagedErrorName>IncidentIsAlreadyClosedOrCancelled</ManagedErrorName>
<ErrorMessage>Already Closed or Canceled</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_IS_ALREADY_CLOSED_OR_CANCELLED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044410</ErrorId>
<ManagedErrorName>unManagedidsincidentparentaccountandparentcontactnotpresent</ManagedErrorName>
<ErrorMessage>You should specify a parent contact or account.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_PARENTACCOUNT_AND_PARENTCONTACT_NOT_PRESENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004440f</ErrorId>
<ManagedErrorName>unManagedidsincidentparentaccountandparentcontactpresent</ManagedErrorName>
<ErrorMessage>You can either specify a parent contact or account, but not both.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_PARENTACCOUNT_AND_PARENTCONTACT_PRESENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004440e</ErrorId>
<ManagedErrorName>IncidentCannotCancel</ManagedErrorName>
<ErrorMessage>The incident can not be cancelled because there are open activities for this incident.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_CANNOT_CANCEL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004440d</ErrorId>
<ManagedErrorName>IncidentInvalidContractLineStateForCreate</ManagedErrorName>
<ErrorMessage>The case can not be created against this contract line item because the contract line item is cancelled or expired.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_INVALID_CONTRACT_LINE_STATE_FOR_CREATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004440c</ErrorId>
<ManagedErrorName>IncidentNullSpentTimeOrBilled</ManagedErrorName>
<ErrorMessage>The timespent on the Incident is NULL or IncidentResolution Activity's IsBilled is NULL.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_NULL_SPENT_TIME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004440b</ErrorId>
<ManagedErrorName>IncidentInvalidAllotmentType</ManagedErrorName>
<ErrorMessage>The allotment type for the contract is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_INVALID_ALLOTMENT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004440a</ErrorId>
<ManagedErrorName>unManagedidsincidentcannotclose</ManagedErrorName>
<ErrorMessage>The incident can not be closed because there are open activities for this incident.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_CANNOT_CLOSE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044409</ErrorId>
<ManagedErrorName>IncidentMissingActivityRegardingObject</ManagedErrorName>
<ErrorMessage>The incident id is missing.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_MISSING_ACTIVITY_REGARDING_OBJECT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044408</ErrorId>
<ManagedErrorName>unManagedidsincidentmissingactivityobjecttype</ManagedErrorName>
<ErrorMessage>Missing object type code.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_MISSING_ACTIVITY_OBJECTTYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044407</ErrorId>
<ManagedErrorName>unManagedidsincidentnullactivitytypecode</ManagedErrorName>
<ErrorMessage>The activitytypecode can't be NULL.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_NULL_ACTIVITYTYPECODE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044406</ErrorId>
<ManagedErrorName>unManagedidsincidentinvalidactivitytypecode</ManagedErrorName>
<ErrorMessage>The activitytypecode is wrong.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_INVALID_ACTIVITYTYPECODE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044405</ErrorId>
<ManagedErrorName>unManagedidsincidentassociatedactivitycorrupted</ManagedErrorName>
<ErrorMessage>The activity associated with this case is corrupted.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_ASSOCIATED_ACTIVITY_CORRUPTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044404</ErrorId>
<ManagedErrorName>unManagedidsincidentinvalidstate</ManagedErrorName>
<ErrorMessage>Incident state is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_INVALID_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044403</ErrorId>
<ManagedErrorName>IncidentContractDoesNotHaveAllotments</ManagedErrorName>
<ErrorMessage>The contract does not have enough allotments. The case can not be created against this contract.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_CONTRACT_DOES_NOT_HAVE_ALLOTMENTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044402</ErrorId>
<ManagedErrorName>unManagedidsincidentcontractdetaildoesnotmatchcontract</ManagedErrorName>
<ErrorMessage>The contract line item is not in the specified contract.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_CONTRACT_DETAIL_DOES_NOT_MATCH_CONTRACT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044401</ErrorId>
<ManagedErrorName>IncidentMissingContractDetail</ManagedErrorName>
<ErrorMessage>The contract detail id is missing.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_MISSING_CONTRACT_DETAIL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044400</ErrorId>
<ManagedErrorName>IncidentInvalidContractStateForCreate</ManagedErrorName>
<ErrorMessage>The case can not be created against this contract because of the contract state.</ErrorMessage>
<UnManagedErrorName>IDS_INCIDENT_INVALID_CONTRACT_STATE_FOR_CREATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004F864</ErrorId>
<ManagedErrorName>InvalidPrimaryContactBasedOnAccount</ManagedErrorName>
<ErrorMessage>The specified contact doesn't belong to the account selected as the customer. Specify a contact that belongs to the selected account, and then try again.</ErrorMessage>
<UnManagedErrorName>INVALID_PRIMARY_CONTACT_BASED_ON_ACCOUNT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004F865</ErrorId>
<ManagedErrorName>InvalidPrimaryContactBasedOnContact</ManagedErrorName>
<ErrorMessage>The specified contact doesn't belong to the contact that was specified in the customer field. Remove the value from the contact field, or select a contact associated to the selected customer, and then try again.</ErrorMessage>
<UnManagedErrorName>INVALID_PRIMARY_CONTACT_BASED_ON_CONTACT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004F866</ErrorId>
<ManagedErrorName>InvalidEntitlementForSelectedCustomerOrProduct</ManagedErrorName>
<ErrorMessage>Select an active entitlement that belongs to the specified customer, contact, or product, and then try again.</ErrorMessage>
<UnManagedErrorName>INVALID_ENTITLEMENT_FOR_SELECTED_CUSTOMER_OR_PRODUCT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044207</ErrorId>
<ManagedErrorName>InvalidEntitlementContacts</ManagedErrorName>
<ErrorMessage>The specified contact isn’t associated with the selected customer.</ErrorMessage>
<UnManagedErrorName>INVALID_ENTITLEMENT_CONTACTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044208</ErrorId>
<ManagedErrorName>EntitlementAlreadyInCanceledState</ManagedErrorName>
<ErrorMessage>You can't cancel an entitlement when it's in the Canceled state.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_ENTITLEMENTALREADYINCANCELEDTSTATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044200</ErrorId>
<ManagedErrorName>DisabledCRMGoingOffline</ManagedErrorName>
<ErrorMessage>Microsoft Dynamics CRM functionality is not available while Offline Synchronization is occuring</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044201</ErrorId>
<ManagedErrorName>DisabledCRMGoingOnline</ManagedErrorName>
<ErrorMessage>Microsoft Dynamics CRM functionality is not available while Online Synchronization is occuring</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044202</ErrorId>
<ManagedErrorName>DisabledCRMAddinLoadFailure</ManagedErrorName>
<ErrorMessage>An error occurred loading Microsoft Dynamics CRM functionality. Try restarting Outlook. Contact your system administrator if errors persist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044203</ErrorId>
<ManagedErrorName>DisabledCRMClientVersionLower</ManagedErrorName>
<ErrorMessage>Offline functionality is not supported in this earlier version of Microsoft Dynamics CRM for Outlook and this Microsoft Dynamics CRM organization {0}. Download a compatible Outlook Client version.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044204</ErrorId>
<ManagedErrorName>DisabledCRMClientVersionHigher</ManagedErrorName>
<ErrorMessage>The Microsoft Dynamics CRM server needs to be upgraded before Microsoft Dynamics CRM client can be used. Contact your system administrator for assistance.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044205</ErrorId>
<ManagedErrorName>DisabledCRMPostOfflineUpgrade</ManagedErrorName>
<ErrorMessage>Microsoft Dynamics CRM functionality is not available until the Microsoft Dynamics CRM client is taken back online</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044206</ErrorId>
<ManagedErrorName>DisabledCRMOnlineCrmNotAvailable</ManagedErrorName>
<ErrorMessage>Microsoft Dynamics CRM server is not available</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044220</ErrorId>
<ManagedErrorName>GoOfflineMetadataVersionsMismatch</ManagedErrorName>
<ErrorMessage>Client and Server metadata versions are different due to new customization on the server. Please try going offline again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044221</ErrorId>
<ManagedErrorName>GoOfflineGetBCPFileException</ManagedErrorName>
<ErrorMessage>CRM server was not able to process your request. Contact your system administrator for assistance and try going offline again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044222</ErrorId>
<ManagedErrorName>GoOfflineDbSizeLimit</ManagedErrorName>
<ErrorMessage>You have exceeded the storage limit for your offline database. You must reduce the amount of data to be taken offline by changing your Local Data Groups.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044223</ErrorId>
<ManagedErrorName>GoOfflineServerFailedGenerateBCPFile</ManagedErrorName>
<ErrorMessage>CRM server was not able to generate BCP file. Contact your system administrator for assistance and try going offline again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044224</ErrorId>
<ManagedErrorName>GoOfflineBCPFileSize</ManagedErrorName>
<ErrorMessage>Client was not able to download BCP file. Contact your system administrator for assistance and try going offline again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044225</ErrorId>
<ManagedErrorName>GoOfflineFailedMoveData</ManagedErrorName>
<ErrorMessage>Client was not able to download data. Contact your system administrator for assistance and try going offline again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044226</ErrorId>
<ManagedErrorName>GoOfflineFailedPrepareMsde</ManagedErrorName>
<ErrorMessage>Prepare MSDE failed. Contact your system administrator for assistance and try going offline again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044227</ErrorId>
<ManagedErrorName>GoOfflineFailedReloadMetadataCache</ManagedErrorName>
<ErrorMessage>The Microsoft Dynamics CRM for Outlook was unable to go offline. Please try going offline again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044228</ErrorId>
<ManagedErrorName>DoNotTrackItem</ManagedErrorName>
<ErrorMessage>Selected item will not be tracked.</ErrorMessage>
<UnManagedErrorName>IDS_DO_NOT_TRACK</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044229</ErrorId>
<ManagedErrorName>GoOfflineFileWasDeleted</ManagedErrorName>
<ErrorMessage>Data file was deleted on server before it was sent to client.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044230</ErrorId>
<ManagedErrorName>GoOfflineEmptyFileForDelete</ManagedErrorName>
<ErrorMessage>Data file for delete is empty.</ErrorMessage>
</crmerror>
<!-- Outlook Client Configuration Wizard errors: 80044500 - 80044530 -->
<crmerror>
<ErrorId>80044500</ErrorId>
<ManagedErrorName>ClientVersionTooLow</ManagedErrorName>
<ErrorMessage>This version of Outlook client isn't compatible with your CRM organization (current version {0} is too low).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044501</ErrorId>
<ManagedErrorName>ClientVersionTooHigh</ManagedErrorName>
<ErrorMessage>This version of Outlook client isn't compatible with your CRM organization (current version {0} is too high).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044502</ErrorId>
<ManagedErrorName>InsufficientAccessMode</ManagedErrorName>
<ErrorMessage>User does not have read-write access to the CRM organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044503</ErrorId>
<ManagedErrorName>ClientServerDateTimeMismatch</ManagedErrorName>
<ErrorMessage>Your computer's date/time is out of sync with the server by more than 5 minutes.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044504</ErrorId>
<ManagedErrorName>ClientServerEmailAddressMismatch</ManagedErrorName>
<ErrorMessage>The Outlook email address and CRM user email address do not match.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044505</ErrorId>
<ManagedErrorName>FederatedEndpointError</ManagedErrorName>
<ErrorMessage>The username ADFS endpoint is enabled, which is blocking the intended authentication endpoint from being reached.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044506</ErrorId>
<ManagedErrorName>CommunicationBlocked</ManagedErrorName>
<ErrorMessage>Communication is blocked due to a socket exception.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044507</ErrorId>
<ManagedErrorName>UserDoesNotHaveAccessToTheTenant</ManagedErrorName>
<ErrorMessage>User does not have access to the tenant.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044508</ErrorId>
<ManagedErrorName>ConfiguredUserIsDifferentThanSuppliedUser</ManagedErrorName>
<ErrorMessage>Configured user is different than supplied user.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044509</ErrorId>
<ManagedErrorName>OutlookClientConfigActionFailed</ManagedErrorName>
<ErrorMessage>CRM Outlook client configuration action failed.</ErrorMessage>
</crmerror>
<!-- End Outlook Client Configuration Wizard error codes-->
<crmerror>
<ErrorId>80044159</ErrorId>
<ManagedErrorName>OrganizationUIDeprecated</ManagedErrorName>
<ErrorMessage>The OrganizationUI entity is deprecated. It has been replaced by the SystemForm entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044157</ErrorId>
<ManagedErrorName>SqlMaxRecursionExceeded</ManagedErrorName>
<ErrorMessage>The maximum recursion has reached before statement completion.</ErrorMessage>
<UnManagedErrorName>IDS_MAXRECURSION_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044151</ErrorId>
<ManagedErrorName>unManagedidssqltimeouterror</ManagedErrorName>
<ErrorMessage>SQL timeout expired.</ErrorMessage>
<UnManagedErrorName>IDS_SQL_TIMEOUT_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044150</ErrorId>
<ManagedErrorName>unManagedidssqlerror</ManagedErrorName>
<ErrorMessage>Generic SQL error.</ErrorMessage>
<UnManagedErrorName>IDS_SQL_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004410d</ErrorId>
<ManagedErrorName>unManagedidsrcsyncinvalidfiltererror</ManagedErrorName>
<ErrorMessage>Invalid filter specified.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_INVALID_FILTER_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044111</ErrorId>
<ManagedErrorName>unManagedidsrcsyncnotprimary</ManagedErrorName>
<ErrorMessage>Cannot sync: not the primary OutlookSync client.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_OUTLOOKSYNC_NOTPRIMARY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044112</ErrorId>
<ManagedErrorName>unManagedidsrcsyncnoprimary</ManagedErrorName>
<ErrorMessage>No primary client exists.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_OUTLOOKSYNC_NOPRIMARY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044113</ErrorId>
<ManagedErrorName>unManagedidsrcsyncnoclient</ManagedErrorName>
<ErrorMessage>Client does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_OUTLOOKSYNC_INVALID_CLIENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044114</ErrorId>
<ManagedErrorName>unManagedidsrcsyncmethodnone</ManagedErrorName>
<ErrorMessage>Synchronization tasks can’t be performed on this computer since the synchronization method is set to None.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_OUTLOOKSYNC_NONE_DELIVERYMETHOD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004410f</ErrorId>
<ManagedErrorName>unManagedidsrcsyncfilternoaccess</ManagedErrorName>
<ErrorMessage>Cannot go offline: missing access rights on required entity.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_FILTER_NO_ACCESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004410e</ErrorId>
<ManagedErrorName>InvalidOfflineOperation</ManagedErrorName>
<ErrorMessage>Operation not valid when offline.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_INVALID_OFFLINE_OPERATION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044110</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsqlgenericerror</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsqlgenericerror</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SQL_GENERIC_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004410c</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsqlpausederror</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsqlpausederror</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SQL_PAUSED_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004410b</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsqlstoppederror</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsqlstoppederror</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SQL_STOPPED_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004410a</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsubscriptionowner</ManagedErrorName>
<ErrorMessage>The caller id does not match the subscription owner id.  Only subscription owners may perform subscription operations.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SUBSCRIPTION_OWNER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044109</ErrorId>
<ManagedErrorName>unManagedidsrcsyncinvalidsubscription</ManagedErrorName>
<ErrorMessage>The specified subscription does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_INVALID_SUBSCRIPTION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044108</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsoapparseerror</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsoapparseerror</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SOAP_PARSE_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044107</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsoapreaderror</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsoapreaderror</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SOAP_READ_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044106</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsoapfaulterror</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsoapfaulterror</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SOAP_FAULT_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044105</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsoapservererror</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsoapservererror</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SOAP_SERVER_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044104</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsoapsendfailed</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsoapsendfailed</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SOAP_SEND_FAILED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044103</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsoapconnfailed</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsoapconnfailed</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SOAP_CONN_FAILED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044102</ErrorId>
<ManagedErrorName>unManagedidsrcsyncsoapgenfailed</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncsoapgenfailed</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_SOAP_GEN_FAILED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044101</ErrorId>
<ManagedErrorName>unManagedidsrcsyncmsxmlfailed</ManagedErrorName>
<ErrorMessage>unManagedidsrcsyncmsxmlfailed</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_MSXML_FAILED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044100</ErrorId>
<ManagedErrorName>unManagedidsrcsyncinvalidsynctime</ManagedErrorName>
<ErrorMessage>The specified sync time is invalid.  Sync times must not be earlier than those returned by the previous sync.  Please reinitialize your subscription.</ErrorMessage>
<UnManagedErrorName>IDS_RCSYNC_INVALID_SYNCTIME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043e09</ErrorId>
<ManagedErrorName>AttachmentBlocked</ManagedErrorName>
<ErrorMessage>The attachment is either not a valid type or is too large. It cannot be uploaded or downloaded.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043e07</ErrorId>
<ManagedErrorName>unManagedidsarticletemplateisnotactive</ManagedErrorName>
<ErrorMessage>KB article template is inactive.</ErrorMessage>
<UnManagedErrorName>IDS_ARTICLE_TEMPLATE_IS_NOT_ACTIVE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043e06</ErrorId>
<ManagedErrorName>unManagedidsfulltextoperationfailed</ManagedErrorName>
<ErrorMessage>Full text operation failed.</ErrorMessage>
<UnManagedErrorName>IDS_FULLTEXT_OPERATION_FAILED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043e05</ErrorId>
<ManagedErrorName>unManagedidsarticletemplatecontainsarticles</ManagedErrorName>
<ErrorMessage>Cannot change article template because there are knowledge base articles using it.</ErrorMessage>
<UnManagedErrorName>IDS_ARTICLE_TEMPLATE_CONTAINS_ARTICLES</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043e04</ErrorId>
<ManagedErrorName>unManagedidsqueueorganizationidnotmatch</ManagedErrorName>
<ErrorMessage>Callers' organization Id does not match businessunit's organization Id.</ErrorMessage>
<UnManagedErrorName>IDS_QUEUE_ORGANIZATIONID_NOT_MATCH</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043e03</ErrorId>
<ManagedErrorName>unManagedidsqueuemissingbusinessunitid</ManagedErrorName>
<ErrorMessage>Missing businessunitid.</ErrorMessage>
<UnManagedErrorName>IDS_QUEUE_MISSING_BUSINESSUNITID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043e02</ErrorId>
<ManagedErrorName>SubjectDoesNotExist</ManagedErrorName>
<ErrorMessage>Subject does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_SUBJECT_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043e01</ErrorId>
<ManagedErrorName>SubjectLoopBeingCreated</ManagedErrorName>
<ErrorMessage>Creating this parental association would create a loop in Subjects hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_SUBJECT_LOOP_BEING_CREATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043e00</ErrorId>
<ManagedErrorName>SubjectLoopExists</ManagedErrorName>
<ErrorMessage>Loop exists in the subjects hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_SUBJECT_LOOP_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048dff</ErrorId>
<ManagedErrorName>InvalidSubmitFromUnapprovedArticle</ManagedErrorName>
<ErrorMessage>You are trying to submit an article that has a status of unapproved. You can only submit an article with the status of draft.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_SUBMIT_UNAPPROVED_ARTICLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048dfe</ErrorId>
<ManagedErrorName>InvalidUnpublishFromUnapprovedArticle</ManagedErrorName>
<ErrorMessage>You are trying to unpublish an article that has a status of unapproved. You can only unpublish an article with the status of publish.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_UNPUBLISH_UNAPPROVED_ARTICLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048dfd</ErrorId>
<ManagedErrorName>InvalidApproveFromDraftArticle</ManagedErrorName>
<ErrorMessage>You are trying to approve an article that has a status of draft. You can only approve an article with the status of unapproved.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_APPROVE_DRAFT_ARTICLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048dfc</ErrorId>
<ManagedErrorName>InvalidUnpublishFromDraftArticle</ManagedErrorName>
<ErrorMessage>You are trying to unpublish an article that has a status of draft. You can only unpublish an article with the status of published.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_UNPUBLISH_DRAFT_ARTICLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048dfb</ErrorId>
<ManagedErrorName>InvalidApproveFromPublishedArticle</ManagedErrorName>
<ErrorMessage>You are trying to approve an article that has a status of published. You can only approve an article with the status of unapproved.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_APPROVE_PUBLISHED_ARTICLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048dfa</ErrorId>
<ManagedErrorName>InvalidSubmitFromPublishedArticle</ManagedErrorName>
<ErrorMessage>You are trying to submit an article that has a status of published. You can only submit an article with the status of draft.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_SUBMIT_PUBLISHED_ARTICLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80048d00</ErrorId>
<ManagedErrorName>QuoteReviseExistingActiveQuote</ManagedErrorName>
<ErrorMessage>Quote cannot be revised as there already exists another quote in Draft/Active state and with same quote number.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cff</ErrorId>
<ManagedErrorName>BaseCurrencyNotDeletable</ManagedErrorName>
<ErrorMessage>The base currency of an organization cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cfe</ErrorId>
<ManagedErrorName>CannotDeleteBaseMoneyCalculationAttribute</ManagedErrorName>
<ErrorMessage>The base money calculation Attribute is not valid for deletion</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cfd</ErrorId>
<ManagedErrorName>InvalidExchangeRate</ManagedErrorName>
<ErrorMessage>The exchange rate is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cfc</ErrorId>
<ManagedErrorName>InvalidCurrency</ManagedErrorName>
<ErrorMessage>The currency is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cfb</ErrorId>
<ManagedErrorName>CurrencyCannotBeNullDueToNonNullMoneyFields</ManagedErrorName>
<ErrorMessage>The currency cannot be null.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cfa</ErrorId>
<ManagedErrorName>CannotUpdateProductCurrency</ManagedErrorName>
<ErrorMessage>The currency of the product cannot be updated because there are associated price list items with pricing method percentage.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cf9</ErrorId>
<ManagedErrorName>InvalidPriceLevelCurrencyForPricingMethod</ManagedErrorName>
<ErrorMessage>The currency of the price list needs to match the currency of the product for pricing method percentage.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cf8</ErrorId>
<ManagedErrorName>DiscountTypeAndPriceLevelCurrencyNotEqual</ManagedErrorName>
<ErrorMessage>The currency of the discount needs to match the currency of the price list for discount type amount.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cf7</ErrorId>
<ManagedErrorName>CurrencyRequiredForDiscountTypeAmount</ManagedErrorName>
<ErrorMessage>The currency cannot be null for discount type amount.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cf6</ErrorId>
<ManagedErrorName>RecordAndPricelistCurrencyNotEqual</ManagedErrorName>
<ErrorMessage>The currency of the record does not match the currency of the price list.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cf5</ErrorId>
<ManagedErrorName>ExchangeRateOfBaseCurrencyNotUpdatable</ManagedErrorName>
<ErrorMessage>The exchange rate of the base currency cannot be modified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cf4</ErrorId>
<ManagedErrorName>BaseCurrencyCannotBeDeactivated</ManagedErrorName>
<ErrorMessage>The base currency cannot be deactivated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cf3</ErrorId>
<ManagedErrorName>DuplicateIsoCurrencyCode</ManagedErrorName>
<ErrorMessage>Cannot insert duplicate currency record. Currency with the same currency code already exist in the system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cf2</ErrorId>
<ManagedErrorName>InvalidIsoCurrencyCode</ManagedErrorName>
<ErrorMessage>Invalid ISO currency code.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cf1</ErrorId>
<ManagedErrorName>PercentageDiscountCannotHaveCurrency</ManagedErrorName>
<ErrorMessage>Currency cannot be set when discount type is percentage.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cef</ErrorId>
<ManagedErrorName>RecordAndOpportunityCurrencyNotEqual</ManagedErrorName>
<ErrorMessage>The currency of the record does not match the currency of the price list.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cee</ErrorId>
<ManagedErrorName>QuoteAndSalesOrderCurrencyNotEqual</ManagedErrorName>
<ErrorMessage>The currency of the record does not match the currency of the price list.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048ced</ErrorId>
<ManagedErrorName>SalesOrderAndInvoiceCurrencyNotEqual</ManagedErrorName>
<ErrorMessage>The currency of the record does not match the currency of the price list.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cec</ErrorId>
<ManagedErrorName>BaseCurrencyOverflow</ManagedErrorName>
<ErrorMessage>The exchange rate set for the currency specified in this record has generated a value for {0} that is larger than the maximum allowed for the base currency ({1}).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048ceb</ErrorId>
<ManagedErrorName>BaseCurrencyUnderflow</ManagedErrorName>
<ErrorMessage>The exchange rate set for the currency specified in this record has generated a value for {0} that is smaller than the minimum allowed for the base currency ({1}).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80048cea</ErrorId>
<ManagedErrorName>CurrencyNotEqual</ManagedErrorName>
<ErrorMessage>The currency of the {0} does not match the currency of the {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043b26</ErrorId>
<ManagedErrorName>UnitNoName</ManagedErrorName>
<ErrorMessage>The unit name cannot be null.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043b25</ErrorId>
<ManagedErrorName>unManagedidsinvoicecloseapideprecated</ManagedErrorName>
<ErrorMessage>The Invoice Close API is deprecated. It has been replaced by the Pay and Cancel APIs.</ErrorMessage>
<UnManagedErrorName>IDS_INVOICE_CLOSE_API_DEPRECATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b24</ErrorId>
<ManagedErrorName>ProductDoesNotExist</ManagedErrorName>
<ErrorMessage>The product does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_PRODUCT_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b23</ErrorId>
<ManagedErrorName>ProductKitLoopBeingCreated</ManagedErrorName>
<ErrorMessage>You can’t add a kit to itself.</ErrorMessage>
<UnManagedErrorName>IDS_PRODUCT_KIT_LOOP_BEING_CREATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b22</ErrorId>
<ManagedErrorName>ProductKitLoopExists</ManagedErrorName>
<ErrorMessage>Loop exists in the kit hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_PRODUCT_KIT_LOOP_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b21</ErrorId>
<ManagedErrorName>DiscountPercent</ManagedErrorName>
<ErrorMessage>The discount type does not support 'amount' discounts.</ErrorMessage>
<UnManagedErrorName>IDS_DISCOUNT_PERCENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b20</ErrorId>
<ManagedErrorName>DiscountAmount</ManagedErrorName>
<ErrorMessage>The discount type does not support 'percentage' discounts.</ErrorMessage>
<UnManagedErrorName>IDS_DISCOUNT_AMOUNT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b1f</ErrorId>
<ManagedErrorName>DiscountAmountAndPercent</ManagedErrorName>
<ErrorMessage>Both 'amount' and 'percentage' cannot be set.</ErrorMessage>
<UnManagedErrorName>IDS_DISCOUNT_AMOUNT_AND_PERCENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b1e</ErrorId>
<ManagedErrorName>EntityIsUnlocked</ManagedErrorName>
<ErrorMessage>This entity is already unlocked.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITY_IS_UNLOCKED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b1d</ErrorId>
<ManagedErrorName>EntityIsLocked</ManagedErrorName>
<ErrorMessage>This entity is already locked.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITY_IS_LOCKED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b1c</ErrorId>
<ManagedErrorName>BaseUnitDoesNotExist</ManagedErrorName>
<ErrorMessage>The base unit does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_BASEUNIT_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b1b</ErrorId>
<ManagedErrorName>UnitDoesNotExist</ManagedErrorName>
<ErrorMessage>The unit does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_UNIT_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b1a</ErrorId>
<ManagedErrorName>UnitLoopBeingCreated</ManagedErrorName>
<ErrorMessage>Using this base unit would create a loop in the unit hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_UNIT_LOOP_BEING_CREATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b19</ErrorId>
<ManagedErrorName>UnitLoopExists</ManagedErrorName>
<ErrorMessage>Loop exists in the unit hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_UNIT_LOOP_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b18</ErrorId>
<ManagedErrorName>QuantityReadonly</ManagedErrorName>
<ErrorMessage>Do not modify the Quantity field when you update the primary unit.</ErrorMessage>
<UnManagedErrorName>IDS_QUANTITY_READONLY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b17</ErrorId>
<ManagedErrorName>BaseUnitNotNull</ManagedErrorName>
<ErrorMessage>Do not use a base unit as the value for a primary unit. This value should always be null.</ErrorMessage>
<UnManagedErrorName>IDS_BASE_UNIT_NOT_NULL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b16</ErrorId>
<ManagedErrorName>UnitNotInSchedule</ManagedErrorName>
<ErrorMessage>The unit does not exist in the specified unit schedule.</ErrorMessage>
<UnManagedErrorName>IDS_UNIT_NOT_IN_SCHEDULE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b15</ErrorId>
<ManagedErrorName>MissingOpportunityId</ManagedErrorName>
<ErrorMessage>The opportunity id is missing or invalid.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_OPPORTUNITYID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b14</ErrorId>
<ManagedErrorName>ProductInvalidUnit</ManagedErrorName>
<ErrorMessage>The specified unit is not valid for this product.</ErrorMessage>
<UnManagedErrorName>IDS_PRODUCT_INVALID_UNIT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b13</ErrorId>
<ManagedErrorName>ProductMissingUomSheduleId</ManagedErrorName>
<ErrorMessage>The unit schedule id of the product is missing.</ErrorMessage>
<UnManagedErrorName>IDS_PRODUCT_MISSING_UOMSCHEDULEID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b12</ErrorId>
<ManagedErrorName>MissingPriceLevelId</ManagedErrorName>
<ErrorMessage>The price level id is missing.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_PRICELEVELID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b11</ErrorId>
<ManagedErrorName>MissingProductId</ManagedErrorName>
<ErrorMessage>The product id is missing.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_PRODUCTID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b10</ErrorId>
<ManagedErrorName>InvalidPricePerUnit</ManagedErrorName>
<ErrorMessage>The price per unit is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PRICEPERUNIT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b0f</ErrorId>
<ManagedErrorName>PriceLevelNameExists</ManagedErrorName>
<ErrorMessage>The name already exists.</ErrorMessage>
<UnManagedErrorName>IDS_PRICELEVEL_NAMEEXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b0e</ErrorId>
<ManagedErrorName>PriceLevelNoName</ManagedErrorName>
<ErrorMessage>The name can not be null.</ErrorMessage>
<UnManagedErrorName>IDS_PRICELEVEL_NONAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b0d</ErrorId>
<ManagedErrorName>MissingUomId</ManagedErrorName>
<ErrorMessage>The unit id is missing.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_UOMID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b0c</ErrorId>
<ManagedErrorName>ProductInvalidPriceLevelPercentage</ManagedErrorName>
<ErrorMessage>The pricing percentage must be greater than or equal to zero and less than 100000.</ErrorMessage>
<UnManagedErrorName>IDS_PRODUCT_INVALID_PRICE_LEVEL_PERCENTAGE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b0b</ErrorId>
<ManagedErrorName>InvalidBaseUnit</ManagedErrorName>
<ErrorMessage>The base unit does not belong to the schedule.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_BASE_UNIT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b0a</ErrorId>
<ManagedErrorName>MissingUomScheduleId</ManagedErrorName>
<ErrorMessage>The unit schedule id is missing.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_UOMSCHEDULEID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b09</ErrorId>
<ManagedErrorName>ParentReadOnly</ManagedErrorName>
<ErrorMessage>The parent is read only and cannot be edited.</ErrorMessage>
<UnManagedErrorName>IDS_PARENT_READ_ONLY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b08</ErrorId>
<ManagedErrorName>DuplicateProductPriceLevel</ManagedErrorName>
<ErrorMessage>This product and unit combination has a price for this price list.</ErrorMessage>
<UnManagedErrorName>IDS_DUPLICATE_PRODUCT_PRICE_LEVEL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b07</ErrorId>
<ManagedErrorName>ProductInvalidQuantityDecimal</ManagedErrorName>
<ErrorMessage>The number of decimal places on the quantity is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_PRODUCT_INVALID_QUANTITY_DECIMAL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b06</ErrorId>
<ManagedErrorName>ProductProductNumberExists</ManagedErrorName>
<ErrorMessage>The specified product ID conflicts with the product ID of an existing record. Specify a different product ID and try again.</ErrorMessage>
<UnManagedErrorName>IDS_PRODUCT_PRODUCTNUMBEREXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b05</ErrorId>
<ManagedErrorName>ProductNoProductNumber</ManagedErrorName>
<ErrorMessage>The product number can not be null.</ErrorMessage>
<UnManagedErrorName>IDS_PRODUCT_NOPRODUCTNUMBER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b04</ErrorId>
<ManagedErrorName>unManagedidscannotdeactivatepricelevel</ManagedErrorName>
<ErrorMessage>The price level cannot be deactivated because it is the default price level of an account, contact or product.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_DEACTIVATE_PRICE_LEVEL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b03</ErrorId>
<ManagedErrorName>BaseUnitNotDeletable</ManagedErrorName>
<ErrorMessage>The base unit of a schedule cannot be deleted.</ErrorMessage>
<UnManagedErrorName>IDS_BASE_UNIT_NOT_DELETABLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b02</ErrorId>
<ManagedErrorName>DiscountRangeOverlap</ManagedErrorName>
<ErrorMessage>The new quantities overlap the range covered by existing quantities.</ErrorMessage>
<UnManagedErrorName>IDS_DISCOUNT_RANGE_OVERLAP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b01</ErrorId>
<ManagedErrorName>LowQuantityGreaterThanHighQuantity</ManagedErrorName>
<ErrorMessage>Low quantity should be less than high quantity.</ErrorMessage>
<UnManagedErrorName>IDS_LOW_QUANTITY_GREATER_THAN_HIGH_QUANTITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043b00</ErrorId>
<ManagedErrorName>LowQuantityLessThanZero</ManagedErrorName>
<ErrorMessage>Low quantity should be greater than zero.</ErrorMessage>
<UnManagedErrorName>IDS_LOW_QUANTITY_LESS_THAN_ZERO</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043aff</ErrorId>
<ManagedErrorName>InvalidSubstituteProduct</ManagedErrorName>
<ErrorMessage>A product can't have a relationship with itself.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_SUBSTITUTE_PRODUCT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043afe</ErrorId>
<ManagedErrorName>InvalidKitProduct</ManagedErrorName>
<ErrorMessage>You cannot add a product kit to itself. Select a different product or product kit.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_KIT_PRODUCT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043afd</ErrorId>
<ManagedErrorName>InvalidKit</ManagedErrorName>
<ErrorMessage>The product is not a kit.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_KIT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043afc</ErrorId>
<ManagedErrorName>InvalidQuantityDecimalCode</ManagedErrorName>
<ErrorMessage>The quantity decimal code is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_QUANTITY_DECIMAL_CODE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043afb</ErrorId>
<ManagedErrorName>CannotSpecifyBothProductAndProductDesc</ManagedErrorName>
<ErrorMessage>You cannot set both 'productid' and 'productdescription' for the same record.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_SPECIFY_BOTH_PRODUCT_AND_PRODUCTDESC</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043afa</ErrorId>
<ManagedErrorName>CannotSpecifyBothUomAndProductDesc</ManagedErrorName>
<ErrorMessage>You cannot set both 'uomid' and 'productdescription' for the same record.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_SPECIFY_BOTH_UOM_AND_PRODUCTDESC</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043af9</ErrorId>
<ManagedErrorName>unManagedidsstatedoesnotexist</ManagedErrorName>
<ErrorMessage>The state is not valid for this object.</ErrorMessage>
<UnManagedErrorName>IDS_STATE_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043809</ErrorId>
<ManagedErrorName>FiscalSettingsAlreadyUpdated</ManagedErrorName>
<ErrorMessage>Fiscal settings have already been updated. They can be updated only once.</ErrorMessage>
<UnManagedErrorName>IDS_SALESPEOPLE_FISCALSETTINGS_ALREADY_UPDATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043808</ErrorId>
<ManagedErrorName>unManagedidssalespeopleinvalidfiscalcalendartype</ManagedErrorName>
<ErrorMessage>Invalid fiscal calendar type</ErrorMessage>
<UnManagedErrorName>IDS_SALESPEOPLE_INVALID_FISCALCALENDAR_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043807</ErrorId>
<ManagedErrorName>unManagedidssalespeopleinvalidfiscalperiodindex</ManagedErrorName>
<ErrorMessage>Invalid fiscal period index</ErrorMessage>
<UnManagedErrorName>IDS_SALESPEOPLE_INVALID_FISCALPERIOD_INDEX</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043805</ErrorId>
<ManagedErrorName>SalesPeopleManagerNotAllowed</ManagedErrorName>
<ErrorMessage>Territory manager cannot belong to other territory</ErrorMessage>
<UnManagedErrorName>IDS_SALESPEOPLE_MANAGER_NOT_ALLOWED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043804</ErrorId>
<ManagedErrorName>unManagedidssalespeopleinvalidterritoryobjecttype</ManagedErrorName>
<ErrorMessage>Territories cannot be retrieved by this kind of object</ErrorMessage>
<UnManagedErrorName>IDS_SALESPEOPLE_INVALID_TERRITORY_OBJECT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043803</ErrorId>
<ManagedErrorName>SalesPeopleDuplicateCalendarNotAllowed</ManagedErrorName>
<ErrorMessage>Fiscal calendar already exists for this salesperson/year</ErrorMessage>
<UnManagedErrorName>IDS_SALESPEOPLE_DUPLICATE_CALENDAR_NOT_ALLOWED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043802</ErrorId>
<ManagedErrorName>unManagedidssalespeopleduplicatecalendarfound</ManagedErrorName>
<ErrorMessage>Duplicate fiscal calendars found for this salesperson/year</ErrorMessage>
<UnManagedErrorName>IDS_SALESPEOPLE_DUPLICATE_CALENDAR_FOUND</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043801</ErrorId>
<ManagedErrorName>SalesPeopleEmptyEffectiveDate</ManagedErrorName>
<ErrorMessage>Fiscal calendar effective date cannot be empty</ErrorMessage>
<UnManagedErrorName>IDS_SALESPEOPLE_EMPTY_EFFECTIVEDATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043800</ErrorId>
<ManagedErrorName>SalesPeopleEmptySalesPerson</ManagedErrorName>
<ErrorMessage>Parent salesperson cannot be empty</ErrorMessage>
<UnManagedErrorName>IDS_SALESPEOPLE_EMPTY_SALESPERSON</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043700</ErrorId>
<ManagedErrorName>InvalidNumberGroupFormat</ManagedErrorName>
<ErrorMessage>Invalid input string for numbergroupformat. The input string should contain an array of integers. Every element in the value array should be between one and nine, except for the last element, which can be zero.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043810</ErrorId>
<ManagedErrorName>BaseUomNameNotSpecified</ManagedErrorName>
<ErrorMessage>baseuomname not specified</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043518</ErrorId>
<ManagedErrorName>InvalidActivityPartyAddress</ManagedErrorName>
<ErrorMessage>One or more activity parties have invalid addresses.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043517</ErrorId>
<ManagedErrorName>FaxNoSupport</ManagedErrorName>
<ErrorMessage>The fax cannot be sent because this type of attachment is not allowed or does not support virtual printing to a fax device.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043516</ErrorId>
<ManagedErrorName>FaxNoData</ManagedErrorName>
<ErrorMessage>The fax cannot be sent because there is no data to send. Specify at least one of the following: a cover page, a fax attachment, a fax description.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043515</ErrorId>
<ManagedErrorName>InvalidPartyMapping</ManagedErrorName>
<ErrorMessage>Invalid party mapping.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043514</ErrorId>
<ManagedErrorName>InvalidActivityXml</ManagedErrorName>
<ErrorMessage>Invalid Xml in an activity config file.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043513</ErrorId>
<ManagedErrorName>ActivityInvalidObjectTypeCode</ManagedErrorName>
<ErrorMessage>An Invalid type code was specified by the throwing method</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043512</ErrorId>
<ManagedErrorName>ActivityInvalidSessionToken</ManagedErrorName>
<ErrorMessage>An Invalid session token was passed into the throwing method</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043511</ErrorId>
<ManagedErrorName>FaxServiceNotRunning</ManagedErrorName>
<ErrorMessage>The Microsoft Windows fax service is not running or is not installed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80043510</ErrorId>
<ManagedErrorName>FaxSendBlocked</ManagedErrorName>
<ErrorMessage>The recipient is marked as "Do Not Fax".</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004350f</ErrorId>
<ManagedErrorName>NoDialNumber</ManagedErrorName>
<ErrorMessage>There is no fax number specified on the fax or for the recipient.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004350e</ErrorId>
<ManagedErrorName>TooManyRecipients</ManagedErrorName>
<ErrorMessage>Sending to multiple recipients is not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004350d</ErrorId>
<ManagedErrorName>MissingRecipient</ManagedErrorName>
<ErrorMessage>The fax must have a recipient before it can be sent.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004350b</ErrorId>
<ManagedErrorName>unManagedidsactivitynotroutable</ManagedErrorName>
<ErrorMessage>This type of activity is not routable</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_NOT_ROUTABLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004350a</ErrorId>
<ManagedErrorName>unManagedidsactivitydurationdoesnotmatch</ManagedErrorName>
<ErrorMessage>Activity duration does not match start/end time</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_DURATION_DOES_NOT_MATCH</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043509</ErrorId>
<ManagedErrorName>unManagedidsactivityinvalidduration</ManagedErrorName>
<ErrorMessage>Invalid activity duration</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_INVALID_DURATION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043508</ErrorId>
<ManagedErrorName>unManagedidsactivityinvalidtimeformat</ManagedErrorName>
<ErrorMessage>Invalid activity time, check format</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_INVALID_TIME_FORMAT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043507</ErrorId>
<ManagedErrorName>unManagedidsactivityinvalidregardingobject</ManagedErrorName>
<ErrorMessage>Invalid activity regarding object, it probably does not exist</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_INVALID_REGARDING_OBJECT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043506</ErrorId>
<ManagedErrorName>ActivityPartyObjectTypeNotAllowed</ManagedErrorName>
<ErrorMessage>Cannot create activity party of specified object type.</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_PARTY_OBJECT_TYPE_NOT_ALLOWED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043505</ErrorId>
<ManagedErrorName>unManagedidsactivityinvalidpartyobjecttype</ManagedErrorName>
<ErrorMessage>Activity party object type is invalid</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_INVALID_PARTY_OBJECT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043504</ErrorId>
<ManagedErrorName>unManagedidsactivitypartyobjectidortypemissing</ManagedErrorName>
<ErrorMessage>Activity party object Id or type is missing</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_PARTY_OBJECT_ID_OR_TYPE_MISSING</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043503</ErrorId>
<ManagedErrorName>unManagedidsactivityinvalidobjecttype</ManagedErrorName>
<ErrorMessage>Activity regarding object type is invalid</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_INVALID_OBJECT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043502</ErrorId>
<ManagedErrorName>unManagedidsactivityobjectidortypemissing</ManagedErrorName>
<ErrorMessage>Activity regarding object Id or type is missing</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_OBJECT_ID_OR_TYPE_MISSING</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043501</ErrorId>
<ManagedErrorName>unManagedidsactivityinvalidtype</ManagedErrorName>
<ErrorMessage>Invalid activity type code</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_INVALID_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043500</ErrorId>
<ManagedErrorName>unManagedidsactivityinvalidstate</ManagedErrorName>
<ErrorMessage>Invalid activity state</ErrorMessage>
<UnManagedErrorName>IDS_ACTIVITY_INVALID_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043218</ErrorId>
<ManagedErrorName>ContractInvalidDatesForRenew</ManagedErrorName>
<ErrorMessage>The start date / end date of this renewed contract can not overlap with any other invoiced / active contracts with the same contract number.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALIDSTARTENDDATESFORRENEWEDCONTRACT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043217</ErrorId>
<ManagedErrorName>unManagedidscontractinvalidstartdateforrenewedcontract</ManagedErrorName>
<ErrorMessage>The start date of the renewed contract can not be earlier than the end date of the originating contract.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALIDSTARTDATEFORRENEWEDCONTRACT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043216</ErrorId>
<ManagedErrorName>unManagedidscontracttemplateabbreviationexists</ManagedErrorName>
<ErrorMessage>The value for abbreviation already exists.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_TEMPLATE_ABBREVIATIONEXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043215</ErrorId>
<ManagedErrorName>ContractInvalidPrice</ManagedErrorName>
<ErrorMessage>The price is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALID_PRICE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043214</ErrorId>
<ManagedErrorName>unManagedidscontractinvalidtotalallotments</ManagedErrorName>
<ErrorMessage>The totalallotments is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALID_TOTALALLOTMENTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043213</ErrorId>
<ManagedErrorName>ContractInvalidContract</ManagedErrorName>
<ErrorMessage>The contract is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALID_CONTRACT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043212</ErrorId>
<ManagedErrorName>unManagedidscontractinvalidowner</ManagedErrorName>
<ErrorMessage>The owner of the contract is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALID_OWNER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043211</ErrorId>
<ManagedErrorName>ContractInvalidContractTemplate</ManagedErrorName>
<ErrorMessage>The contract template is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALID_CONTRACTTEMPLATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043210</ErrorId>
<ManagedErrorName>ContractInvalidBillToCustomer</ManagedErrorName>
<ErrorMessage>The bill-to customer of the contract is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALID_BILLTO_CUSTOMER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004320f</ErrorId>
<ManagedErrorName>ContractInvalidBillToAddress</ManagedErrorName>
<ErrorMessage>The bill-to address of the contract is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALID_BILLTO_ADDRESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004320e</ErrorId>
<ManagedErrorName>ContractInvalidServiceAddress</ManagedErrorName>
<ErrorMessage>The service address of the contract is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALID_SERVICE_ADDRESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004320d</ErrorId>
<ManagedErrorName>ContractInvalidCustomer</ManagedErrorName>
<ErrorMessage>The customer of the contract is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALID_CUSTOMER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004320c</ErrorId>
<ManagedErrorName>ContractNoLineItems</ManagedErrorName>
<ErrorMessage>There are no contract line items for this contract.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_NOLINEITEMS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004320b</ErrorId>
<ManagedErrorName>ContractTemplateNoAbbreviation</ManagedErrorName>
<ErrorMessage>Abbreviation can not be NULL.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_TEMPLATE_NOABBREVIATION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004320a</ErrorId>
<ManagedErrorName>unManagedidscontractopencasesexist</ManagedErrorName>
<ErrorMessage>There are open cases against this contract line item.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_OPENCASESEXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043208</ErrorId>
<ManagedErrorName>unManagedidscontractlineitemdoesnotexist</ManagedErrorName>
<ErrorMessage>The contract line item does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_LINEITEM_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043207</ErrorId>
<ManagedErrorName>unManagedidscontractdoesnotexist</ManagedErrorName>
<ErrorMessage>The contract does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043206</ErrorId>
<ManagedErrorName>ContractTemplateDoesNotExist</ManagedErrorName>
<ErrorMessage>The contract template does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_TEMPLATE_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043205</ErrorId>
<ManagedErrorName>ContractInvalidAllotmentTypeCode</ManagedErrorName>
<ErrorMessage>The allotment type code is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALIDALLOTMENTTYPECODE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043204</ErrorId>
<ManagedErrorName>ContractLineInvalidState</ManagedErrorName>
<ErrorMessage>The state of the contract line item is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_LINE_INVALIDSTATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043203</ErrorId>
<ManagedErrorName>ContractInvalidState</ManagedErrorName>
<ErrorMessage>The state of the contract is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALIDSTATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043202</ErrorId>
<ManagedErrorName>ContractInvalidStartEndDate</ManagedErrorName>
<ErrorMessage>Start date / end date or billing start date / billing end date is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALIDSTARTENDDATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043201</ErrorId>
<ManagedErrorName>unManagedidscontractaccountmissing</ManagedErrorName>
<ErrorMessage>Account is required to save a contract.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_ACCOUNTMISSING</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80043200</ErrorId>
<ManagedErrorName>unManagedidscontractunexpected</ManagedErrorName>
<ErrorMessage>An unexpected error occurred in Contracts.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_UNEXPECTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c4c</ErrorId>
<ManagedErrorName>unManagedidsevalerrorformatlookupparameter</ManagedErrorName>
<ErrorMessage>Error happens when evaluating WFPM_FORMAT_LOOKUP parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_FORMAT_LOOKUP_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c4b</ErrorId>
<ManagedErrorName>unManagedidsevalerrorformattimezonecodeparameter</ManagedErrorName>
<ErrorMessage>unManagedidsevalerrorformattimezonecodeparameter</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_FORMAT_TIMEZONECODE_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c4a</ErrorId>
<ManagedErrorName>unManagedidsevalerrorformatdecimalparameter</ManagedErrorName>
<ErrorMessage>Error happens when evaluating WFPM_FORMAT_DECIMAL parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_FORMAT_DECIMAL_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c49</ErrorId>
<ManagedErrorName>unManagedidsevalerrorformatintegerparameter</ManagedErrorName>
<ErrorMessage>Error happens when evaluating WFPM_FORMAT_INTEGER parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_FORMAT_INTEGER_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c48</ErrorId>
<ManagedErrorName>unManagedidsevalerrorobjecttype</ManagedErrorName>
<ErrorMessage>Error happens when evaluating WFPM_GetObjectType parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_OBJECT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c47</ErrorId>
<ManagedErrorName>unManagedidsevalerrorqueueidparameter</ManagedErrorName>
<ErrorMessage>unManagedidsevalerrorqueueidparameter</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_QUEUE_ID_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c46</ErrorId>
<ManagedErrorName>unManagedidsevalerrorformatpicklistparameter</ManagedErrorName>
<ErrorMessage>Error happens when evaluating WFPM_FORMAT_PICKLIST parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_FORMAT_PICKLIST_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c45</ErrorId>
<ManagedErrorName>unManagedidsevalerrorformatbooleanparameter</ManagedErrorName>
<ErrorMessage>Error happens when evaluating WFPM_FORMAT_BOOLEAN parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_FORMAT_BOOLEAN_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c44</ErrorId>
<ManagedErrorName>unManagedidsevalerrorformatdatetimeparameter</ManagedErrorName>
<ErrorMessage>Error happens when evaluating WFPM_FORMAT_DATETIME parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_FORMAT_DATETIME_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c43</ErrorId>
<ManagedErrorName>unManagedidsevalerrorisnulllistparameter</ManagedErrorName>
<ErrorMessage>unManagedidsevalerrorisnulllistparameter</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_ISNULL_LIST_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c42</ErrorId>
<ManagedErrorName>unManagedidsevalerrorinlistparameter</ManagedErrorName>
<ErrorMessage>unManagedidsevalerrorinlistparameter</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_IN_LIST_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c41</ErrorId>
<ManagedErrorName>unManagedidsevalerrorsetactivityparty</ManagedErrorName>
<ErrorMessage>unManagedidsevalerrorsetactivityparty</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_SET_ACTIVITYPARTY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c40</ErrorId>
<ManagedErrorName>unManagedidsevalerrorremovefromactivityparty</ManagedErrorName>
<ErrorMessage>unManagedidsevalerrorremovefromactivityparty</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_REMOVEFROM_ACTIVITYPARTY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c3f</ErrorId>
<ManagedErrorName>unManagedidsevalerrorappendtoactivityparty</ManagedErrorName>
<ErrorMessage>unManagedidsevalerrorappendtoactivityparty</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_APPENDTO_ACTIVITYPARTY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c3e</ErrorId>
<ManagedErrorName>unManagedidsevaltimererrorcalculatescheduletime</ManagedErrorName>
<ErrorMessage>Failed to calculate the schedule time for the timer action.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_TIMER_ERROR_CALCULATE_SCHEDULE_TIME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c3d</ErrorId>
<ManagedErrorName>unManagedidsevaltimerinvalidparameternumber</ManagedErrorName>
<ErrorMessage>Invalid parameters for Timer action.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_TIMER_INVALID_PARAMETER_NUMBER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c3c</ErrorId>
<ManagedErrorName>unManagedidsevalcreateshouldhave2parameters</ManagedErrorName>
<ErrorMessage>Create action should have 2 parameters.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_CREATE_SHOULD_HAVE_2_PARAMETERS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c3b</ErrorId>
<ManagedErrorName>unManagedidsevalerrorcreate</ManagedErrorName>
<ErrorMessage>Error in create update.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_CREATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c3a</ErrorId>
<ManagedErrorName>unManagedidsevalerrorcontainparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_CONTAIN parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_CONTAIN_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c39</ErrorId>
<ManagedErrorName>unManagedidsevalerrorendwithparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_END_WITH parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_END_WITH_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c38</ErrorId>
<ManagedErrorName>unManagedidsevalerrorbeginwithparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_BEGIN_WITH parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_BEGIN_WITH_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c37</ErrorId>
<ManagedErrorName>unManagedidsevalerrorstrlenparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_STRLEN parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_STRLEN_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c36</ErrorId>
<ManagedErrorName>unManagedidsevalerrorsubstrparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_SUBSTR parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_SUBSTR_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c35</ErrorId>
<ManagedErrorName>unManagedidsevalerrorinvalidrecipient</ManagedErrorName>
<ErrorMessage>Invalid email recipient.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_INVALID_RECIPIENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c34</ErrorId>
<ManagedErrorName>unManagedidsevalerrorinparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_IN parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_IN_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c33</ErrorId>
<ManagedErrorName>unManagedidsevalerrorbetweenparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_BETWEEN parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_BETWEEN_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c32</ErrorId>
<ManagedErrorName>unManagedidsevalerrorneqparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_NEQ parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_NEQ_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c31</ErrorId>
<ManagedErrorName>unManagedidsevalerroreqparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_EQ parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_EQ_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c30</ErrorId>
<ManagedErrorName>unManagedidsevalerrorleqparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_LEQ parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_LEQ_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c2f</ErrorId>
<ManagedErrorName>unManagedidsevalerrorltparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_LT parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_LT_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c2e</ErrorId>
<ManagedErrorName>unManagedidsevalerrorgeqparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_GEQ parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_GEQ_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c2d</ErrorId>
<ManagedErrorName>unManagedidsevalerrorgtparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_GT parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_GT_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c2c</ErrorId>
<ManagedErrorName>unManagedidsevalerrorabsparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_ABS parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_ABS_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c2b</ErrorId>
<ManagedErrorName>unManagedidsevalerrorinvalidparameter</ManagedErrorName>
<ErrorMessage>Invalid parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_INVALID_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c2a</ErrorId>
<ManagedErrorName>unManagedidsevalgenericerror</ManagedErrorName>
<ErrorMessage>Evaluation error.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_GENERIC_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c29</ErrorId>
<ManagedErrorName>unManagedidsevalerrorincidentqueue</ManagedErrorName>
<ErrorMessage>Failed to evaluate INCIDENT_QUEUE.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_INCIDENT_QUEUE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c28</ErrorId>
<ManagedErrorName>unManagedidsevalerrorhalt</ManagedErrorName>
<ErrorMessage>Error in action halt.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_HALT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c27</ErrorId>
<ManagedErrorName>unManagedidsevalerrorexec</ManagedErrorName>
<ErrorMessage>Error in action exec.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_EXEC</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c26</ErrorId>
<ManagedErrorName>unManagedidsevalerrorposturl</ManagedErrorName>
<ErrorMessage>Error in action posturl.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_POSTURL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c25</ErrorId>
<ManagedErrorName>unManagedidsevalerrorsetstate</ManagedErrorName>
<ErrorMessage>Error in action set state.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_SETSTATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c24</ErrorId>
<ManagedErrorName>unManagedidsevalerrorroute</ManagedErrorName>
<ErrorMessage>Error in action route.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_ROUTE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c23</ErrorId>
<ManagedErrorName>unManagedidsevalerrorupdate</ManagedErrorName>
<ErrorMessage>Error in action update.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_UPDATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c22</ErrorId>
<ManagedErrorName>unManagedidsevalerrorassign</ManagedErrorName>
<ErrorMessage>Error in action assign.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_ASSIGN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c21</ErrorId>
<ManagedErrorName>unManagedidsevalerroremailtemplate</ManagedErrorName>
<ErrorMessage>Error in action email template.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_EMAIL_TEMPLATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c20</ErrorId>
<ManagedErrorName>unManagedidsevalerrorsendemail</ManagedErrorName>
<ErrorMessage>Error in action send email.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_SEND_EMAIL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c1f</ErrorId>
<ManagedErrorName>unManagedidsevalerrorunhandleincident</ManagedErrorName>
<ErrorMessage>Error in action unhandle incident.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_UNHANDLE_INCIDENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c1e</ErrorId>
<ManagedErrorName>unManagedidsevalerrorhandleincident</ManagedErrorName>
<ErrorMessage>Error in action handle incident.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_HANDLE_INCIDENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c1d</ErrorId>
<ManagedErrorName>unManagedidsevalerrorcreateincident</ManagedErrorName>
<ErrorMessage>Error in action create incident.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_CREATE_INCIDENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c1c</ErrorId>
<ManagedErrorName>unManagedidsevalerrornoteattachment</ManagedErrorName>
<ErrorMessage>Error in action note attachment.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_NOTE_ATTACHMENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c1b</ErrorId>
<ManagedErrorName>unManagedidsevalerrorcreatenote</ManagedErrorName>
<ErrorMessage>Error in action create note.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_CREATE_NOTE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c1a</ErrorId>
<ManagedErrorName>unManagedidsevalerrorunhandleactivity</ManagedErrorName>
<ErrorMessage>Error in action unhandle activity.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_UNHANDLE_ACTIVITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c19</ErrorId>
<ManagedErrorName>unManagedidsevalerrorhandleactivity</ManagedErrorName>
<ErrorMessage>Error in action handle activity.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_HANDLE_ACTIVITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c18</ErrorId>
<ManagedErrorName>unManagedidsevalerroractivityattachment</ManagedErrorName>
<ErrorMessage>Error in action activity attachment.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_ACTIVITY_ATTACHMENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c17</ErrorId>
<ManagedErrorName>unManagedidsevalerrorcreateactivity</ManagedErrorName>
<ErrorMessage>Error in action create activity.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_CREATE_ACTIVITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c16</ErrorId>
<ManagedErrorName>unManagedidsevalerrordividedbyzero</ManagedErrorName>
<ErrorMessage>Divided by zero.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_DIVIDED_BY_ZERO</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c15</ErrorId>
<ManagedErrorName>unManagedidsevalerrormodulusparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_MODULUR parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_MODULUS_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c14</ErrorId>
<ManagedErrorName>unManagedidsevalerrormodulusparameters</ManagedErrorName>
<ErrorMessage>Modulus parameter can have only two subparameters.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_MODULUS_PARAMETERS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c13</ErrorId>
<ManagedErrorName>unManagedidsevalerrordivisionparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_DIVISION parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_DIVISION_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c12</ErrorId>
<ManagedErrorName>unManagedidsevalerrordivisionparameters</ManagedErrorName>
<ErrorMessage>Division parameter can have only two subparameters.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_DIVISION_PARAMETERS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c11</ErrorId>
<ManagedErrorName>unManagedidsevalerrormultiplicationparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_MULTIPLICATION parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_MULTIPLICATION_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c10</ErrorId>
<ManagedErrorName>unManagedidsevalerrorsubtractionparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_SUBTRACTION parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_SUBTRACTION_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c0f</ErrorId>
<ManagedErrorName>unManagedidsevalerroraddparameter</ManagedErrorName>
<ErrorMessage>Error occurred when evaluating a WFPM_ADD parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ERROR_ADD_PARAMETER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c0e</ErrorId>
<ManagedErrorName>unManagedidsevalmissselectquery</ManagedErrorName>
<ErrorMessage>Missing the query subparameter in a select parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_MISS_SELECT_QUERY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c0d</ErrorId>
<ManagedErrorName>unManagedidsevalchangetypeerror</ManagedErrorName>
<ErrorMessage>Change type error.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_CHANGE_TYPE_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c0c</ErrorId>
<ManagedErrorName>unManagedidsevalallcompleted</ManagedErrorName>
<ErrorMessage>Evaluation completed and stop further processing.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ALLCOMPLETED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c0b</ErrorId>
<ManagedErrorName>unManagedidsevalmetabaseattributenotmatchquery</ManagedErrorName>
<ErrorMessage>The specified refattributeid does not the query for a WFPM_SELECT parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_METABASE_ATTRIBUTE_NOT_MATCH_QUERY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c0a</ErrorId>
<ManagedErrorName>unManagedidsevalmetabaseentitynotmatchquery</ManagedErrorName>
<ErrorMessage>The specified refentityid does not the query for a WFPM_SELECT parameter.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_METABASE_ENTITY_NOT_MATCH_QUERY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c09</ErrorId>
<ManagedErrorName>unManagedidsevalpropertyisnull</ManagedErrorName>
<ErrorMessage>The required property of the object was not set.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_PROPERTY_IS_NULL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c08</ErrorId>
<ManagedErrorName>unManagedidsevalmetabaseattributenotfound</ManagedErrorName>
<ErrorMessage>The specified metabase attribute does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_METABASE_ATTRIBUTE_NOT_FOUND</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c07</ErrorId>
<ManagedErrorName>unManagedidsevalmetabaseentitycompoundkeys</ManagedErrorName>
<ErrorMessage>The specified metabase object has compound keys. We do not support compound-key entities yet.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_METABASE_ENTITY_COMPOUND_KEYS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c06</ErrorId>
<ManagedErrorName>unManagedidsevalpropertynotfound</ManagedErrorName>
<ErrorMessage>The required property of the object was not found.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_PROPERTY_NOT_FOUND</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c05</ErrorId>
<ManagedErrorName>unManagedidsevalobjectnotfound</ManagedErrorName>
<ErrorMessage>The required object does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_OBJECT_NOT_FOUND</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c04</ErrorId>
<ManagedErrorName>unManagedidsevalcompleted</ManagedErrorName>
<ErrorMessage>Evaluation completed.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_COMPLETED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c03</ErrorId>
<ManagedErrorName>unManagedidsevalaborted</ManagedErrorName>
<ErrorMessage>Evaluation aborted.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ABORTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c02</ErrorId>
<ManagedErrorName>unManagedidsevalallaborted</ManagedErrorName>
<ErrorMessage>Evaluation aborted and stop further processing.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ALLABORTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c01</ErrorId>
<ManagedErrorName>unManagedidsevalassignshouldhave4parameters</ManagedErrorName>
<ErrorMessage>Assign action should have 4 parameters.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_ASSIGN_SHOULD_HAVE_4_PARAMETERS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042c00</ErrorId>
<ManagedErrorName>unManagedidsevalupdateshouldhave3parameters</ManagedErrorName>
<ErrorMessage>Update action should have 3 parameters.</ErrorMessage>
<UnManagedErrorName>IDS_EVAL_UPDATE_SHOULD_HAVE_3_PARAMETERS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042903</ErrorId>
<ManagedErrorName>unManagedidscpdecryptfailed</ManagedErrorName>
<ErrorMessage>Decryption of the password failed.</ErrorMessage>
<UnManagedErrorName>IDS_CP_DECRYPT_FAILED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042902</ErrorId>
<ManagedErrorName>unManagedidscpencryptfailed</ManagedErrorName>
<ErrorMessage>Encryption of the supplied password failed.</ErrorMessage>
<UnManagedErrorName>IDS_CP_ENCRYPT_FAILED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042901</ErrorId>
<ManagedErrorName>unManagedidscpbadpassword</ManagedErrorName>
<ErrorMessage>Incorrect password for the specified customer portal user.</ErrorMessage>
<UnManagedErrorName>IDS_CP_BAD_PASSWORD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042900</ErrorId>
<ManagedErrorName>unManagedidscpuserdoesnotexist</ManagedErrorName>
<ErrorMessage>The customer portal user does not exist, or the password was incorrect.</ErrorMessage>
<UnManagedErrorName>IDS_CP_USER_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042300</ErrorId>
<ManagedErrorName>unManagedidsdataaccessunexpected</ManagedErrorName>
<ErrorMessage>Unexpected error in data access.  DB Connection may not have been opened successfully.</ErrorMessage>
<UnManagedErrorName>IDS_DATAACCESS_UNEXPECTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004203f</ErrorId>
<ManagedErrorName>unManagedidspropbagattributealreadyset</ManagedErrorName>
<ErrorMessage>One of the attributes passed has already been set</ErrorMessage>
<UnManagedErrorName>IDS_PROPBAG_ATTRIBUTE_ALREADY_SET</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004203e</ErrorId>
<ManagedErrorName>unManagedidspropbagattributenotnullable</ManagedErrorName>
<ErrorMessage>One of the attributes passed cannot be NULL</ErrorMessage>
<UnManagedErrorName>IDS_PROPBAG_ATTRIBUTE_NOT_NULLABLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004203d</ErrorId>
<ManagedErrorName>unManagedidsrspropbagdbinfoalreadyset</ManagedErrorName>
<ErrorMessage>The DB info for the recordset property bag has already been set.</ErrorMessage>
<UnManagedErrorName>IDS_RSPROPBAG_DBINFO_ALREADY_SET</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004203c</ErrorId>
<ManagedErrorName>unManagedidsrspropbagdbinfonotset</ManagedErrorName>
<ErrorMessage>The DB info for the recordset property bag has not been set.</ErrorMessage>
<UnManagedErrorName>IDS_RSPROPBAG_DBINFO_NOT_SET</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004201e</ErrorId>
<ManagedErrorName>unManagedidspropbagcolloutofrange</ManagedErrorName>
<ErrorMessage>The bag index in the collection was out of range.</ErrorMessage>
<UnManagedErrorName>IDS_PROPBAGCOLL_OUT_OF_RANGE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042002</ErrorId>
<ManagedErrorName>unManagedidspropbagnullproperty</ManagedErrorName>
<ErrorMessage>The specified property was null in the property bag.</ErrorMessage>
<UnManagedErrorName>IDS_PROPBAG_NULL_PROPERTY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042001</ErrorId>
<ManagedErrorName>unManagedidspropbagnointerface</ManagedErrorName>
<ErrorMessage>The property bag interface could not be found.</ErrorMessage>
<UnManagedErrorName>IDS_PROPBAG_NO_INTERFACE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042003</ErrorId>
<ManagedErrorName>unManagedMissingObjectType</ManagedErrorName>
<ErrorMessage>Object type must be specified for one of the attributes.</ErrorMessage>
<UnManagedErrorName>IDS_PROPBAG_MISSING_OBJECT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042004</ErrorId>
<ManagedErrorName>unManagedObjectTypeUnexpected</ManagedErrorName>
<ErrorMessage>Object type was specified for one of the attributes that does not allow it.</ErrorMessage>
<UnManagedErrorName>IDS_PROPBAG_OBJECT_TYPE_UNEXPECTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d59</ErrorId>
<ManagedErrorName>BusinessUnitCannotBeDisabled</ManagedErrorName>
<ErrorMessage>Business unit cannot be disabled: no active user with system admin role exists outside of business unit subtree.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d60</ErrorId>
<ManagedErrorName>BusinessUnitIsNotDisabledAndCannotBeDeleted</ManagedErrorName>
<ErrorMessage>Not disabled business unit cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d61</ErrorId>
<ManagedErrorName>BusinessUnitHasChildAndCannotBeDeleted</ManagedErrorName>
<ErrorMessage>Business unit has a child business unit and cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d62</ErrorId>
<ManagedErrorName>BusinessUnitDefaultTeamOwnsRecords</ManagedErrorName>
<ErrorMessage>Business unit default team owns records. Business unit cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d63</ErrorId>
<ManagedErrorName>RootBusinessUnitCannotBeDisabled</ManagedErrorName>
<ErrorMessage>Root Business unit cannot be disabled.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80042000</ErrorId>
<ManagedErrorName>unManagedidspropbagpropertynotfound</ManagedErrorName>
<ErrorMessage>The specified property was not found in the property bag.</ErrorMessage>
<UnManagedErrorName>IDS_PROPBAG_PROPERTY_NOT_FOUND</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d40</ErrorId>
<ManagedErrorName>ReadOnlyUserNotSupported</ManagedErrorName>
<ErrorMessage>The read-only access mode is not supported</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_READONLY_USER_NOT_SUPPORTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d41</ErrorId>
<ManagedErrorName>SupportUserCannotBeCreateNorUpdated</ManagedErrorName>
<ErrorMessage>The support user cannot not be updated</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d48</ErrorId>
<ManagedErrorName>ApplicationUserCannotBeUpdated</ManagedErrorName>
<ErrorMessage>The user representing an OAuth application cannot not be updated</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d49</ErrorId>
<ManagedErrorName>ApplicationNotRegisteredWithDeployment</ManagedErrorName>
<ErrorMessage>Application needs to be registered and enabled at deployment level before it can be created for this organization</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d50</ErrorId>
<ManagedErrorName>InvalidOAuthToken</ManagedErrorName>
<ErrorMessage>The OAuth token is invalid</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d52</ErrorId>
<ManagedErrorName>ExpiredOAuthToken</ManagedErrorName>
<ErrorMessage>The OAuth token has expired</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d51</ErrorId>
<ManagedErrorName>CannotAssignRolesToSupportUser</ManagedErrorName>
<ErrorMessage>The support user are read-only, which cannot be assigned with other roles</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d39</ErrorId>
<ManagedErrorName>CannotMakeSelfReadOnlyUser</ManagedErrorName>
<ErrorMessage>You cannot make yourself a read only user</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_MAKE_SELF_READONLY_USER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d38</ErrorId>
<ManagedErrorName>CannotMakeReadOnlyUser</ManagedErrorName>
<ErrorMessage>A user cannot be made a read only user if they are the last non read only user that has the System Administrator Role.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_MAKE_READONLY_USER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d36</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcantchangeorgname</ManagedErrorName>
<ErrorMessage>The organization name cannot be changed.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANT_CHANGE_ORGNAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d35</ErrorId>
<ManagedErrorName>MultipleOrganizationsNotAllowed</ManagedErrorName>
<ErrorMessage>Only one organization and one root business are allowed.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_NO_MULTI_ORG</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d34</ErrorId>
<ManagedErrorName>UserSettingsInvalidAdvancedFindStartupMode</ManagedErrorName>
<ErrorMessage>Invalid advanced find startup mode.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_USER_SETTINGS_INVALID_ADVANCEDFIND_STARTUP_MODE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d33</ErrorId>
<ManagedErrorName>CannotModifySpecialUser</ManagedErrorName>
<ErrorMessage>No modifications to the 'SYSTEM' or 'INTEGRATION' user are permitted.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_MODIFY_SPECIALUSER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d32</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotaddlocaluser</ManagedErrorName>
<ErrorMessage>A local user cannot be added to the CRM.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_ADD_LOCALUSER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d31</ErrorId>
<ManagedErrorName>CannotModifySysAdmin</ManagedErrorName>
<ErrorMessage>The System Administrator Role cannot be modified.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_MODIFY_SYSADMIN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d43</ErrorId>
<ManagedErrorName>CannotModifySupportUser</ManagedErrorName>
<ErrorMessage>The Support User Role cannot be modified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d44</ErrorId>
<ManagedErrorName>CannotAssignSupportUser</ManagedErrorName>
<ErrorMessage>The Support User Role cannot be assigned to a user.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d45</ErrorId>
<ManagedErrorName>CannotRemoveFromSupportUser</ManagedErrorName>
<ErrorMessage>A user cannot be removed from the Support User Role.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d46</ErrorId>
<ManagedErrorName>CannotCreateFromSupportUser</ManagedErrorName>
<ErrorMessage>Cannot create a role from Support User Role.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d47</ErrorId>
<ManagedErrorName>CannotUpdateSupportUser</ManagedErrorName>
<ErrorMessage>Cannot update the Support User Role.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d30</ErrorId>
<ManagedErrorName>CannotRemoveFromSysAdmin</ManagedErrorName>
<ErrorMessage>A user cannot be removed from the System Administrator Role if they are the only user that has the role.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_REMOVE_SYSADMIN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d2f</ErrorId>
<ManagedErrorName>CannotDisableSysAdmin</ManagedErrorName>
<ErrorMessage>A user cannot be disabled if they are the only user that has the System Administrator Role.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_DISABLE_SYSADMIN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d2e</ErrorId>
<ManagedErrorName>CannotDeleteSysAdmin</ManagedErrorName>
<ErrorMessage>The System Administrator Role cannot be deleted.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_DELETE_SYSADMIN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d42</ErrorId>
<ManagedErrorName>CannotDeleteSupportUser</ManagedErrorName>
<ErrorMessage>The Support User Role cannot be deleted.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_DELETE_SUPPORTUSER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d4a</ErrorId>
<ManagedErrorName>CannotDeleteSystemCustomizer</ManagedErrorName>
<ErrorMessage>The System Customizer Role cannot be deleted.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_DELETE_SYSTEMCUSTOMIZER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d4b</ErrorId>
<ManagedErrorName>CannotCreateSyncUserObjectMissing</ManagedErrorName>
<ErrorMessage>This is not a valid Microsoft Online Services ID for this organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d4c</ErrorId>
<ManagedErrorName>CannotUpdateSyncUserIsLicensedField</ManagedErrorName>
<ErrorMessage>The property IsLicensed cannot be modified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d4d</ErrorId>
<ManagedErrorName>CannotCreateSyncUserIsLicensedField</ManagedErrorName>
<ErrorMessage>The property IsLicensed cannot be set for Sync User Creation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d4e</ErrorId>
<ManagedErrorName>CannotUpdateSyncUserIsSyncWithDirectoryField</ManagedErrorName>
<ErrorMessage>The property IsSyncUserWithDirectory cannot be modified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d2d</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotreadaccountcontrol</ManagedErrorName>
<ErrorMessage>Insufficient permissions to the specified Active Directory user. Contact your System Administrator.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_READ_ACCOUNT_CONTROL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d2c</ErrorId>
<ManagedErrorName>UserAlreadyExists</ManagedErrorName>
<ErrorMessage>The specified Active Directory user already exists as a CRM user.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_USER_ALREADY_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d2b</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtusersettingsnotcreated</ManagedErrorName>
<ErrorMessage>The specified user's settings have not yet been created.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_USER_SETTINGS_NOT_CREATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d2a</ErrorId>
<ManagedErrorName>ObjectNotFoundInAD</ManagedErrorName>
<ErrorMessage>The object does not exist in active directory.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d37</ErrorId>
<ManagedErrorName>GenericActiveDirectoryError</ManagedErrorName>
<ErrorMessage>Active Directory Error.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d29</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtnoparentbusiness</ManagedErrorName>
<ErrorMessage>The specified business does not have a parent business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_NO_PARENTBUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d27</ErrorId>
<ManagedErrorName>ParentUserDoesNotExist</ManagedErrorName>
<ErrorMessage>The parent user Id is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_PARENTUSER_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d26</ErrorId>
<ManagedErrorName>ChildUserDoesNotExist</ManagedErrorName>
<ErrorMessage>The child user Id is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CHILDUSER_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d25</ErrorId>
<ManagedErrorName>UserLoopBeingCreated</ManagedErrorName>
<ErrorMessage>You cannot set the selected user as the manager for this user because the selected user is either already the manager or is in the user's immediate management hierarchy.  Either select another user to be the manager or do not update the record.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_USER_LOOP_BEING_CREATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d24</ErrorId>
<ManagedErrorName>UserLoopExists</ManagedErrorName>
<ErrorMessage>A manager for this user cannot be set because an existing relationship in the management hierarchy is causing a circular relationship.  This is usually caused by a manual edit of the Microsoft Dynamics CRM database. To fix this, the hierarchy in the database must be changed to remove the circular relationship.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_USER_LOOP_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d23</ErrorId>
<ManagedErrorName>ParentBusinessDoesNotExist</ManagedErrorName>
<ErrorMessage>The parent business Id is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_PARENTBUSINESS_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d22</ErrorId>
<ManagedErrorName>ChildBusinessDoesNotExist</ManagedErrorName>
<ErrorMessage>The child businesss Id is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CHILDBUSINESS_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d21</ErrorId>
<ManagedErrorName>BusinessManagementLoopBeingCreated</ManagedErrorName>
<ErrorMessage>Creating this parental association would create a loop in business hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_BUSINESS_LOOP_BEING_CREATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d20</ErrorId>
<ManagedErrorName>BusinessManagementLoopExists</ManagedErrorName>
<ErrorMessage>Loop exists in the business hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_BUSINESS_LOOP_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d1f</ErrorId>
<ManagedErrorName>BusinessManagementInvalidUserId</ManagedErrorName>
<ErrorMessage>The user Id is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_INVALID_USERID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d1e</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtuserdoesnothaveparent</ManagedErrorName>
<ErrorMessage>This user does not have a parent user.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_USER_DOES_NOT_HAVE_PARENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d1d</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotenableprovision</ManagedErrorName>
<ErrorMessage>This is a provisioned root-business. Use IBizProvision::Enable to enable this root-business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CAN_NOT_ENABLE_PROVISION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d1c</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotenablebusiness</ManagedErrorName>
<ErrorMessage>This is a sub-business. Use IBizMerchant::Enable to enable this sub-business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CAN_NOT_ENABLE_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d1b</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotdisableprovision</ManagedErrorName>
<ErrorMessage>This is a provisioned root-business. Use IBizProvision::Disable to disable this root-business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CAN_NOT_DISABLE_PROVISION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d1a</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotdisablebusiness</ManagedErrorName>
<ErrorMessage>This business unit cannot be disabled.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CAN_NOT_DISABLE_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d19</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotdeleteprovision</ManagedErrorName>
<ErrorMessage>This is a provisioned root-business. Use IBizProvision::Delete to delete this root-business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CAN_NOT_DELETE_PROVISION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d18</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotdeletebusiness</ManagedErrorName>
<ErrorMessage>This is a sub-business. Use IBizMerchant::Delete to delete this sub-business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CAN_NOT_DELETE_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d17</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotremovepartnershipdefaultuser</ManagedErrorName>
<ErrorMessage>The default user of a partnership can not be removed.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CAN_NOT_REMOVE_PARTNERSHIP_DEFAULTUSER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d16</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtpartnershipnotinpendingstatus</ManagedErrorName>
<ErrorMessage>The partnership has been accepted or declined.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_PARTNERSHIP_NOT_IN_PENDING_STATUS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d15</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtdefaultusernotinpartnerbusiness</ManagedErrorName>
<ErrorMessage>The default user is not from partner business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_DEFAULTUSER_NOT_IN_PARTNER_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d14</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcallernotinpartnerbusiness</ManagedErrorName>
<ErrorMessage>The caller is not from partner business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CALLER_NOT_IN_PARTNER_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d13</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtdefaultusernotinprimarybusiness</ManagedErrorName>
<ErrorMessage>The default user is not from primary business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_DEFAULTUSER_NOT_IN_PRIMARY_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d12</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcallernotinprimarybusiness</ManagedErrorName>
<ErrorMessage>The caller is not from primary business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CALLER_NOT_IN_PRIMARY_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d11</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtpartnershipalreadyexists</ManagedErrorName>
<ErrorMessage>A partnership between specified primary business and partner business already exists.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_PARTNERSHIP_ALREADY_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d10</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtprimarysameaspartner</ManagedErrorName>
<ErrorMessage>The primary business is the same as partner business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_PRIMARY_SAME_AS_PARTNER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d0f</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtmisspartnerbusiness</ManagedErrorName>
<ErrorMessage>The partnership partner business was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_MISS_PARTNER_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d0e</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtmissprimarybusiness</ManagedErrorName>
<ErrorMessage>The partnership primary business was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_MISS_PRIMARY_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d66</ErrorId>
<ManagedErrorName>InvalidAccessModeTransition</ManagedErrorName>
<ErrorMessage>The client access license cannot be changed because the user does not have a Microsoft Dynamics CRM Online license. To change the access mode, you must first add a license for this user in the Microsoft Online Service portal.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_INVALID_ACCESSMODE_TRANSITION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d0b</ErrorId>
<ManagedErrorName>MissingTeamName</ManagedErrorName>
<ErrorMessage>The team name was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_MISS_TEAM_NAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d0a</ErrorId>
<ManagedErrorName>TeamAdministratorMissedPrivilege</ManagedErrorName>
<ErrorMessage>The team administrator does not have privilege read team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041d65</ErrorId>
<ManagedErrorName>CannotDisableTenantAdmin</ManagedErrorName>
<ErrorMessage>Users who are granted the Microsoft Office 365 Global administrator or Service administrator role cannot be disabled in Microsoft Dynamics CRM Online. You must first remove the Microsoft Office 365 role, and then try again.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_DISABLE_TENANTADMIN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d64</ErrorId>
<ManagedErrorName>CannotRemoveTenantAdminFromSysAdminRole</ManagedErrorName>
<ErrorMessage>Users who are granted the Microsoft Office 365 Global administrator or Service administrator role cannot be removed from the Microsoft Dynamics CRM System Administrator security role. You must first remove the Microsoft Office 365 role, and then try again.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_REMOVE_TENANTADMIN_FROM_SYSADMIN_ROLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d07</ErrorId>
<ManagedErrorName>UserNotInParentHierarchy</ManagedErrorName>
<ErrorMessage>The user is not in parent user's business hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_USER_NOT_IN_PARENT_HIERARCHY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d06</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtusercannotbeownparent</ManagedErrorName>
<ErrorMessage>The user can not be its own parent user.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_USER_CAN_NOT_BE_OWN_PARENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d05</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtcannotmovedefaultuser</ManagedErrorName>
<ErrorMessage>unManagedidsbizmgmtcannotmovedefaultuser</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CAN_NOT_MOVE_DEFAULTUSER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d04</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtbusinessparentdiffmerchant</ManagedErrorName>
<ErrorMessage>The business is not in the same merchant as parent business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_BUSINESS_PARENT_DIFF_MERCHANT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d03</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtdefaultusernotinbusiness</ManagedErrorName>
<ErrorMessage>The default user is not in the business.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_DEFAULTUSER_NOT_IN_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d02</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtmissparentbusiness</ManagedErrorName>
<ErrorMessage>The parent business was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_MISS_PARENT_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d01</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtmissuserdomainname</ManagedErrorName>
<ErrorMessage>The user's domain name was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_MISS_USER_DOMAINNAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041d00</ErrorId>
<ManagedErrorName>unManagedidsbizmgmtmissbusinessname</ManagedErrorName>
<ErrorMessage>The business name was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_MISS_BUSINESS_NAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041a08</ErrorId>
<ManagedErrorName>unManagedidsxmlinvalidread</ManagedErrorName>
<ErrorMessage>A field that is not valid for read was specified</ErrorMessage>
<UnManagedErrorName>IDS_XML_INVALID_READ</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041a07</ErrorId>
<ManagedErrorName>unManagedidsxmlinvalidfield</ManagedErrorName>
<ErrorMessage>An invalid value was passed in for a field</ErrorMessage>
<UnManagedErrorName>IDS_XML_INVALID_FIELD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041a06</ErrorId>
<ManagedErrorName>unManagedidsxmlinvalidentityattributes</ManagedErrorName>
<ErrorMessage>Invalid attributes</ErrorMessage>
<UnManagedErrorName>IDS_XML_INVALID_ENTITY_ATTRIBUTES</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041a05</ErrorId>
<ManagedErrorName>unManagedidsxmlunexpected</ManagedErrorName>
<ErrorMessage>An unexpected error has occurred</ErrorMessage>
<UnManagedErrorName>IDS_XML_UNEXPECTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041a04</ErrorId>
<ManagedErrorName>unManagedidsxmlparseerror</ManagedErrorName>
<ErrorMessage>A parse error was encountered in the XML</ErrorMessage>
<UnManagedErrorName>IDS_XML_PARSE_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041a03</ErrorId>
<ManagedErrorName>unManagedidsxmlinvalidcollectionname</ManagedErrorName>
<ErrorMessage>The collection name specified is incorrect</ErrorMessage>
<UnManagedErrorName>IDS_XML_INVALID_COLLECTION_NAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041a02</ErrorId>
<ManagedErrorName>unManagedidsxmlinvalidupdate</ManagedErrorName>
<ErrorMessage>A field that is not valid for update was specified</ErrorMessage>
<UnManagedErrorName>IDS_XML_INVALID_UPDATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041a01</ErrorId>
<ManagedErrorName>unManagedidsxmlinvalidcreate</ManagedErrorName>
<ErrorMessage>A field that is not valid for create was specified</ErrorMessage>
<UnManagedErrorName>IDS_XML_INVALID_CREATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041a00</ErrorId>
<ManagedErrorName>unManagedidsxmlinvalidentityname</ManagedErrorName>
<ErrorMessage>The entity name specified is incorrect</ErrorMessage>
<UnManagedErrorName>IDS_XML_INVALID_ENTITY_NAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041704</ErrorId>
<ManagedErrorName>unManagedidsnotesnoattachment</ManagedErrorName>
<ErrorMessage>The specified note has no attachments.</ErrorMessage>
<UnManagedErrorName>IDS_NOTES_NO_ATTACHMENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041703</ErrorId>
<ManagedErrorName>unManagedidsnotesloopbeingcreated</ManagedErrorName>
<ErrorMessage>Creating this parental association would create a loop in the annotation hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_NOTES_LOOP_BEING_CREATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041702</ErrorId>
<ManagedErrorName>unManagedidsnotesloopexists</ManagedErrorName>
<ErrorMessage>A loop exists in the annotation hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_NOTES_LOOP_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041701</ErrorId>
<ManagedErrorName>unManagedidsnotesalreadyattached</ManagedErrorName>
<ErrorMessage>The specified note is already attached to an object.</ErrorMessage>
<UnManagedErrorName>IDS_NOTES_ALREADY_ATTACHED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041700</ErrorId>
<ManagedErrorName>unManagedidsnotesnotedoesnotexist</ManagedErrorName>
<ErrorMessage>The specified note does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_NOTES_NOTE_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004140f</ErrorId>
<ManagedErrorName>DuplicatedPrivilege</ManagedErrorName>
<ErrorMessage>Privilege {0} is duplicated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004140e</ErrorId>
<ManagedErrorName>MemberHasAlreadyBeenContacted</ManagedErrorName>
<ErrorMessage>This marketing list member was not contacted, because the member has previously received this communication.</ErrorMessage>
<UnManagedErrorName>IDS_USER_ALREADY_CONTACTED_FILTERED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004140d</ErrorId>
<ManagedErrorName>TeamInWrongBusiness</ManagedErrorName>
<ErrorMessage>The team belongs to a different business unit than the role.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004140c</ErrorId>
<ManagedErrorName>unManagedidsrolesdeletenonparentrole</ManagedErrorName>
<ErrorMessage>Cannot delete a role that is inherited from a parent business.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_DELETE_NONPARENT_ROLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004140b</ErrorId>
<ManagedErrorName>InvalidPrivilegeDepth</ManagedErrorName>
<ErrorMessage>Invalid privilege depth.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_INVALID_DEPTH</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004140a</ErrorId>
<ManagedErrorName>unManagedidsrolesinvalidrolename</ManagedErrorName>
<ErrorMessage>The role name is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_INVALID_ROLE_NAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041409</ErrorId>
<ManagedErrorName>UserInWrongBusiness</ManagedErrorName>
<ErrorMessage>The user belongs to a different business unit than the role.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_USER_IN_WRONG_BIZ</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041408</ErrorId>
<ManagedErrorName>unManagedidsrolesmissprivid</ManagedErrorName>
<ErrorMessage>The privilege ID was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_MISS_PRIVID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041407</ErrorId>
<ManagedErrorName>unManagedidsrolesmissrolename</ManagedErrorName>
<ErrorMessage>The role name was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_MISS_ROLE_NAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041406</ErrorId>
<ManagedErrorName>unManagedidsrolesmissbusinessid</ManagedErrorName>
<ErrorMessage>The role's business unit ID was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_MISS_BUSINESSID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041405</ErrorId>
<ManagedErrorName>unManagedidsrolesmissroleid</ManagedErrorName>
<ErrorMessage>The role ID was unexpectedly missing.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_MISS_ROLEID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041404</ErrorId>
<ManagedErrorName>unManagedidsrolesinvalidtemplateid</ManagedErrorName>
<ErrorMessage>Invalid role template ID.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_INVALID_TEMPLATE_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041403</ErrorId>
<ManagedErrorName>RoleAlreadyExists</ManagedErrorName>
<ErrorMessage>A role with the specified name already exists.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_ROLE_ALREADY_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041402</ErrorId>
<ManagedErrorName>unManagedidsrolesroledoesnotexist</ManagedErrorName>
<ErrorMessage>The specified role does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_ROLE_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041401</ErrorId>
<ManagedErrorName>unManagedidsrolesinvalidroleid</ManagedErrorName>
<ErrorMessage>Invalid role ID.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_INVALID_ROLE_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041400</ErrorId>
<ManagedErrorName>unManagedidsrolesinvalidroledata</ManagedErrorName>
<ErrorMessage>The role data is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_INVALID_ROLE_DATA</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041138</ErrorId>
<ManagedErrorName>QueryBuilderSerializationInvalidIsQuickFindFilter</ManagedErrorName>
<ErrorMessage>The only valid values for isquickfindfields attribute are 'true', 'false', '1', and '0'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041137</ErrorId>
<ManagedErrorName>QueryBuilderAttributeCannotBeGroupByAndAggregate</ManagedErrorName>
<ErrorMessage>An attribute can either be an aggregate or a Group By but not both</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041136</ErrorId>
<ManagedErrorName>SqlArithmeticOverflowError</ManagedErrorName>
<ErrorMessage>A SQL arithmetic overflow error occurred</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041135</ErrorId>
<ManagedErrorName>QueryBuilderInvalidDateGrouping</ManagedErrorName>
<ErrorMessage>An invalid value was specified for dategrouping.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041134</ErrorId>
<ManagedErrorName>QueryBuilderAliasRequiredForAggregateOrderBy</ManagedErrorName>
<ErrorMessage>An alias is required for an order clause for an aggregate Query.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041133</ErrorId>
<ManagedErrorName>QueryBuilderAttributeRequiredForNonAggregateOrderBy</ManagedErrorName>
<ErrorMessage>An attribute is required for an order clause for a non-aggregate Query.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041132</ErrorId>
<ManagedErrorName>QueryBuilderAliasNotAllowedForNonAggregateOrderBy</ManagedErrorName>
<ErrorMessage>An alias cannot be specified for an order clause for a non-aggregate Query. Use an attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041131</ErrorId>
<ManagedErrorName>QueryBuilderAttributeNotAllowedForAggregateOrderBy</ManagedErrorName>
<ErrorMessage>An attribute cannot be specified for an order clause for an aggregate Query. Use an alias.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041130</ErrorId>
<ManagedErrorName>QueryBuilderDuplicateAlias</ManagedErrorName>
<ErrorMessage>FetchXML should have unique aliases.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004112F</ErrorId>
<ManagedErrorName>QueryBuilderInvalidAggregateAttribute</ManagedErrorName>
<ErrorMessage>Aggregate {0} is not supported for attribute of type {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004112E</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidGroupBy</ManagedErrorName>
<ErrorMessage>The only valid values for groupby attribute are 'true', 'false', '1', and '0'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004112C</ErrorId>
<ManagedErrorName>QueryBuilderNoAttrsDistinctConflict</ManagedErrorName>
<ErrorMessage>The no-attrs tag cannot be used in conjuction with Distinct set to true.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004112A</ErrorId>
<ManagedErrorName>QueryBuilderInvalidPagingCookie</ManagedErrorName>
<ErrorMessage>Invalid page number in paging cookie.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_INVALID_PAGING_COOKIE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041129</ErrorId>
<ManagedErrorName>QueryBuilderPagingOrderBy</ManagedErrorName>
<ErrorMessage>Order by columns do not match those in paging cookie.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_PAGING_ORDERBY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041128</ErrorId>
<ManagedErrorName>QueryBuilderEntitiesDontMatch</ManagedErrorName>
<ErrorMessage>The entity name specified in fetchxml does not match the entity name specified in the Entity or Query Expression.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041126</ErrorId>
<ManagedErrorName>QueryBuilderLinkNodeForOrderNotFound</ManagedErrorName>
<ErrorMessage>Converting from Query to EntityExpression failed. Link Node for order was not found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041125</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeNoDocElemXml</ManagedErrorName>
<ErrorMessage>Document Element can't be null.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041124</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeEmptyXml</ManagedErrorName>
<ErrorMessage>Xml String can't be null.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041123</ErrorId>
<ManagedErrorName>QueryBuilderElementNotFound</ManagedErrorName>
<ErrorMessage>A required element was not specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041122</ErrorId>
<ManagedErrorName>QueryBuilderInvalidFilterType</ManagedErrorName>
<ErrorMessage>Unsupported filter type. Valid values are 'and', or 'or'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041121</ErrorId>
<ManagedErrorName>QueryBuilderInvalidJoinOperator</ManagedErrorName>
<ErrorMessage>Unsupported join operator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041120</ErrorId>
<ManagedErrorName>QueryBuilderInvalidConditionOperator</ManagedErrorName>
<ErrorMessage>Unsupported condition operator.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_CONDITION_OP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004111f</ErrorId>
<ManagedErrorName>QueryBuilderInvalidOrderType</ManagedErrorName>
<ErrorMessage>A valid order type must be set in the order before calling this method.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004111e</ErrorId>
<ManagedErrorName>QueryBuilderAttributeNotFound</ManagedErrorName>
<ErrorMessage>A required attribute was not specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004111d</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidUtcOffset</ManagedErrorName>
<ErrorMessage>The utc-offset attribute is not supported for deserialization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004111c</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidNode</ManagedErrorName>
<ErrorMessage>The element node encountered is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004111b</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidGetMinActiveRowVersion</ManagedErrorName>
<ErrorMessage>The only valid values for GetMinActiveRowVersion attribute are 'true', 'false', '1', and '0'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004111a</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidAggregate</ManagedErrorName>
<ErrorMessage>An error occurred while processing Aggregates in Query</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041119</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidDescending</ManagedErrorName>
<ErrorMessage>The only valid values for descending attribute are 'true', 'false', '1', and '0'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041118</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidNoLock</ManagedErrorName>
<ErrorMessage>The only valid values for no-lock attribute are 'true', 'false', '1', and '0'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041117</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidLinkType</ManagedErrorName>
<ErrorMessage>The only valid values for link-type attribute are 'natural', 'inner', and 'outer'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041116</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidMapping</ManagedErrorName>
<ErrorMessage>The only valid values for mapping are 'logical' or 'internal' which is deprecated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041115</ErrorId>
<ManagedErrorName>QueryBuilderDeserializeInvalidDistinct</ManagedErrorName>
<ErrorMessage>The only valid values for distinct attribute are 'true', 'false', '1', and '0'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041114</ErrorId>
<ManagedErrorName>QueryBuilderSerialzeLinkTopCriteria</ManagedErrorName>
<ErrorMessage>Fetch does not support where clause with conditions from linkentity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041113</ErrorId>
<ManagedErrorName>QueryBuilderColumnSetVersionMissing</ManagedErrorName>
<ErrorMessage>The specified columnset version is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041112</ErrorId>
<ManagedErrorName>QueryBuilderInvalidColumnSetVersion</ManagedErrorName>
<ErrorMessage>The specified columnset version is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041111</ErrorId>
<ManagedErrorName>QueryBuilderAttributePairMismatch</ManagedErrorName>
<ErrorMessage>AttributeFrom and AttributeTo must be either both specified or both omitted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80041110</ErrorId>
<ManagedErrorName>QueryBuilderByAttributeNonEmpty</ManagedErrorName>
<ErrorMessage>QueryByAttribute must specify a non-empty attribute array.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004110f</ErrorId>
<ManagedErrorName>QueryBuilderByAttributeMismatch</ManagedErrorName>
<ErrorMessage>QueryByAttribute must specify a non-empty value array with the same number of elements as in the attributes array.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004110e</ErrorId>
<ManagedErrorName>QueryBuilderMultipleIntersectEntities</ManagedErrorName>
<ErrorMessage>More than one intersect entity exists between the two entities specified.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_MULTIPLE_INTERSECT_ENTITIES</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004110d</ErrorId>
<ManagedErrorName>QueryBuilderReportView_Does_Not_Exist</ManagedErrorName>
<ErrorMessage>A report view does not exist for the specified entity.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_REPORTVIEW_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004110c</ErrorId>
<ManagedErrorName>QueryBuilderValue_GreaterThanZero</ManagedErrorName>
<ErrorMessage>A value greater than zero must be specified.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_VALUE_GREATERTHANZERO</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004110b</ErrorId>
<ManagedErrorName>QueryBuilderNoAlias</ManagedErrorName>
<ErrorMessage>No alias for the given entity in the condition was found.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_NOALIAS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004110a</ErrorId>
<ManagedErrorName>QueryBuilderAlias_Does_Not_Exist</ManagedErrorName>
<ErrorMessage>The specified alias for the given entity in the condition does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_ALIAS_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041109</ErrorId>
<ManagedErrorName>QueryBuilderInvalid_Alias</ManagedErrorName>
<ErrorMessage>Invalid alias for aggregate operation.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_INVALID_ALIAS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041108</ErrorId>
<ManagedErrorName>QueryBuilderInvalid_Value</ManagedErrorName>
<ErrorMessage>Invalid value specified for type.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_INVALID_VALUE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041107</ErrorId>
<ManagedErrorName>QueryBuilderAttribute_With_Aggregate</ManagedErrorName>
<ErrorMessage>Attributes can not be returned when aggregate operation is specified.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_ATTRIBUTE_WITH_AGGREGATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041106</ErrorId>
<ManagedErrorName>QueryBuilderBad_Condition</ManagedErrorName>
<ErrorMessage>Incorrect filter condition or conditions.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_BAD_CONDITION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041103</ErrorId>
<ManagedErrorName>QueryBuilderNoAttribute</ManagedErrorName>
<ErrorMessage>The specified attribute does not exist on this entity.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_NOATTRIBUTE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041102</ErrorId>
<ManagedErrorName>QueryBuilderNoEntity</ManagedErrorName>
<ErrorMessage>The specified entity was not found.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_NOENTITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041101</ErrorId>
<ManagedErrorName>QueryBuilderUnexpected</ManagedErrorName>
<ErrorMessage>An unexpected error occurred.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_UNEXPECTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80041100</ErrorId>
<ManagedErrorName>QueryBuilderInvalidUpdate</ManagedErrorName>
<ErrorMessage>An attempt was made to update a non-updateable field.</ErrorMessage>
<UnManagedErrorName>IDS_QUERYBUILDER_INVALIDUPDATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800410fe</ErrorId>
<ManagedErrorName>QueryBuilderInvalidLogicalOperator</ManagedErrorName>
<ErrorMessage>Unsupported logical operator: {0}.  Accepted values are ('and', 'or').</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040e02</ErrorId>
<ManagedErrorName>unManagedidsmetadatanorelationship</ManagedErrorName>
<ErrorMessage>The relationship does not exist</ErrorMessage>
<UnManagedErrorName>IDS_METADATA_NORELATIONSHIP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040e01</ErrorId>
<ManagedErrorName>MetadataNoMapping</ManagedErrorName>
<ErrorMessage>The mapping between specified entities does not exist</ErrorMessage>
<UnManagedErrorName>IDS_METADATA_NOMAPPING</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040e03</ErrorId>
<ManagedErrorName>MetadataNotSerializable</ManagedErrorName>
<ErrorMessage>The given metadata entity is not serializable</ErrorMessage>
<UnManagedErrorName>IDS_METADATA_NOT_SERIALIZABLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040e00</ErrorId>
<ManagedErrorName>unManagedidsmetadatanoentity</ManagedErrorName>
<ErrorMessage>The specified entity does not exist</ErrorMessage>
<UnManagedErrorName>IDS_METADATA_NOENTITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040b08</ErrorId>
<ManagedErrorName>unManagedidscommunicationsnosenderaddress</ManagedErrorName>
<ErrorMessage>The sender does not have an email address on the party record</ErrorMessage>
<UnManagedErrorName>IDS_COMMUNICATIONS_NOSENDERADDRESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040b07</ErrorId>
<ManagedErrorName>unManagedidscommunicationstemplateinvalidtemplate</ManagedErrorName>
<ErrorMessage>The template body is invalid</ErrorMessage>
<UnManagedErrorName>IDS_COMMUNICATIONS_TEMPLATE_INVALIDTEMPLATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040b06</ErrorId>
<ManagedErrorName>unManagedidscommunicationsnoparticipationmask</ManagedErrorName>
<ErrorMessage>Participation type is missing from an activity</ErrorMessage>
<UnManagedErrorName>IDS_COMMUNICATIONS_NOPARTICIPATIONMASK</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040b05</ErrorId>
<ManagedErrorName>unManagedidscommunicationsnorecipients</ManagedErrorName>
<ErrorMessage>At least one system user or queue in the organization must be a recipient</ErrorMessage>
<UnManagedErrorName>IDS_COMMUNICATIONS_NORECIPIENTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040b04</ErrorId>
<ManagedErrorName>EmailRecipientNotSpecified</ManagedErrorName>
<ErrorMessage>The e-mail must have at least one recipient before it can be sent</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040b02</ErrorId>
<ManagedErrorName>unManagedidscommunicationsnosender</ManagedErrorName>
<ErrorMessage>No email address was specified, and the calling user does not have an email address set</ErrorMessage>
<UnManagedErrorName>IDS_COMMUNICATIONS_NOSENDER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040b01</ErrorId>
<ManagedErrorName>unManagedidscommunicationsbadsender</ManagedErrorName>
<ErrorMessage>More than one sender specified</ErrorMessage>
<UnManagedErrorName>IDS_COMMUNICATIONS_BADSENDER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040b00</ErrorId>
<ManagedErrorName>unManagedidscommunicationsnopartyaddress</ManagedErrorName>
<ErrorMessage>Object address not found on party or party is marked as non-emailable</ErrorMessage>
<UnManagedErrorName>IDS_COMMUNICATIONS_NOPARTYADDRESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040809</ErrorId>
<ManagedErrorName>unManagedidsjournalingmissingincidentid</ManagedErrorName>
<ErrorMessage>Incident Id missed.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_MISSING_INCIDENT_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040808</ErrorId>
<ManagedErrorName>unManagedidsjournalingmissingcontactid</ManagedErrorName>
<ErrorMessage>Contact Id missed.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_MISSING_CONTACT_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040807</ErrorId>
<ManagedErrorName>unManagedidsjournalingmissingopportunityid</ManagedErrorName>
<ErrorMessage>Opportunity Id missed.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_MISSING_OPPORTUNITY_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040806</ErrorId>
<ManagedErrorName>unManagedidsjournalingmissingaccountid</ManagedErrorName>
<ErrorMessage>Account Id missed.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_MISSING_ACCOUNT_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040805</ErrorId>
<ManagedErrorName>unManagedidsjournalingmissingleadid</ManagedErrorName>
<ErrorMessage>Lead Id missed.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_MISSING_LEAD_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040804</ErrorId>
<ManagedErrorName>unManagedidsjournalingmissingeventtype</ManagedErrorName>
<ErrorMessage>Event type missed.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_MISSING_EVENT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040803</ErrorId>
<ManagedErrorName>unManagedidsjournalinginvalideventtype</ManagedErrorName>
<ErrorMessage>Invalid event type.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_INVALID_EVENT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040802</ErrorId>
<ManagedErrorName>unManagedidsjournalingmissingeventdirection</ManagedErrorName>
<ErrorMessage>Event direction code missed.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_MISSING_EVENT_DIRECTION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040801</ErrorId>
<ManagedErrorName>unManagedidsjournalingunsupportedobjecttype</ManagedErrorName>
<ErrorMessage>Unsupported type of objects passed in operation.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_UNSUPPORTED_OBJECT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040800</ErrorId>
<ManagedErrorName>SdkEntityDoesNotSupportMessage</ManagedErrorName>
<ErrorMessage>The method being invoked does not support provided entity type.</ErrorMessage>
<UnManagedErrorName>IDS_JOURNALING_INVALID_RECIPIENT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004051a</ErrorId>
<ManagedErrorName>OpportunityAlreadyInOpenState</ManagedErrorName>
<ErrorMessage>The opportunity is already in the open state.</ErrorMessage>
<UnManagedErrorName>IDS_OPPORTUNITY_ALREADY_IN_OPEN_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040519</ErrorId>
<ManagedErrorName>LeadAlreadyInClosedState</ManagedErrorName>
<ErrorMessage>The lead is already closed.</ErrorMessage>
<UnManagedErrorName>IDS_LEAD_ALREADY_IN_CLOSED_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040518</ErrorId>
<ManagedErrorName>LeadAlreadyInOpenState</ManagedErrorName>
<ErrorMessage>The lead is already in the open state.</ErrorMessage>
<UnManagedErrorName>IDS_LEAD_ALREADY_IN_OPEN_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040517</ErrorId>
<ManagedErrorName>CustomerIsInactive</ManagedErrorName>
<ErrorMessage>An inactive customer cannot be set as the parent of an object.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMER_IS_INACTIVE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040516</ErrorId>
<ManagedErrorName>OpportunityCannotBeClosed</ManagedErrorName>
<ErrorMessage>The opportunity cannot be closed.</ErrorMessage>
<UnManagedErrorName>IDS_OPPORTUNITY_CANNOT_BE_CLOSED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040515</ErrorId>
<ManagedErrorName>OpportunityIsAlreadyClosed</ManagedErrorName>
<ErrorMessage>The opportunity is already closed.</ErrorMessage>
<UnManagedErrorName>IDS_OPPORTUNITY_IS_ALREADY_CLOSED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040514</ErrorId>
<ManagedErrorName>unManagedidscustomeraddresstypeinvalid</ManagedErrorName>
<ErrorMessage>Invalid customer address type.</ErrorMessage>
<UnManagedErrorName>IDS_CUSTOMERADDRESS_TYPE_INVALID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040513</ErrorId>
<ManagedErrorName>unManagedidsleadnotassignedtocaller</ManagedErrorName>
<ErrorMessage>The lead is not being assigned to the caller for acceptance.</ErrorMessage>
<UnManagedErrorName>IDS_LEAD_NOT_ASSIGNED_TO_CALLER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040512</ErrorId>
<ManagedErrorName>unManagedidscontacthaschildopportunities</ManagedErrorName>
<ErrorMessage>The Contact has child opportunities.</ErrorMessage>
<UnManagedErrorName>IDS_CONTACT_HAS_CHILD_OPPORTUNITIES</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040511</ErrorId>
<ManagedErrorName>unManagedidsaccounthaschildopportunities</ManagedErrorName>
<ErrorMessage>The Account has child opportunities.</ErrorMessage>
<UnManagedErrorName>IDS_ACCOUNT_HAS_CHILD_OPPORTUNITIES</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040510</ErrorId>
<ManagedErrorName>unManagedidsleadoneaccount</ManagedErrorName>
<ErrorMessage>A lead can be associated with only one account.</ErrorMessage>
<UnManagedErrorName>IDS_LEAD_ONE_ACCOUNT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004050f</ErrorId>
<ManagedErrorName>unManagedidsopportunityorphan</ManagedErrorName>
<ErrorMessage>Removing this association will make the opportunity an orphan.</ErrorMessage>
<UnManagedErrorName>IDS_OPPORTUNITY_ORPHAN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004050e</ErrorId>
<ManagedErrorName>unManagedidsopportunityoneaccount</ManagedErrorName>
<ErrorMessage>An opportunity can be associated with only one account.</ErrorMessage>
<UnManagedErrorName>IDS_OPPORTUNITY_ONE_ACCOUNT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004050d</ErrorId>
<ManagedErrorName>unManagedidsleadusercannotreject</ManagedErrorName>
<ErrorMessage>The user does not have the privilege to reject a lead, so he cannot be assigned the lead for acceptance.</ErrorMessage>
<UnManagedErrorName>IDS_LEAD_USER_CANNOT_REJECT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004050c</ErrorId>
<ManagedErrorName>unManagedidsleadnotassigned</ManagedErrorName>
<ErrorMessage>The lead has not been assigned.</ErrorMessage>
<UnManagedErrorName>IDS_LEAD_NOT_ASSIGNED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004050b</ErrorId>
<ManagedErrorName>unManagedidsleadnoparent</ManagedErrorName>
<ErrorMessage>The lead does not have a parent.</ErrorMessage>
<UnManagedErrorName>IDS_LEAD_NO_PARENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004050a</ErrorId>
<ManagedErrorName>ContactLoopBeingCreated</ManagedErrorName>
<ErrorMessage>Creating this parental association would create a loop in Contacts hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_CONTACT_LOOP_BEING_CREATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040509</ErrorId>
<ManagedErrorName>ContactLoopExists</ManagedErrorName>
<ErrorMessage>Loop exists in the contacts hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_CONTACT_LOOP_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040508</ErrorId>
<ManagedErrorName>PresentParentAccountAndParentContact</ManagedErrorName>
<ErrorMessage>You can either specify a contacts parent contact or its account, but not both.</ErrorMessage>
<UnManagedErrorName>IDS_PRESENT_PARENTACCOUNT_AND_PARENTCONTACT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040507</ErrorId>
<ManagedErrorName>AccountLoopBeingCreated</ManagedErrorName>
<ErrorMessage>Creating this parental association would create a loop in Accounts hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_ACCOUNT_LOOP_BEING_CREATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040506</ErrorId>
<ManagedErrorName>AccountLoopExists</ManagedErrorName>
<ErrorMessage>Loop exists in the accounts hierarchy.</ErrorMessage>
<UnManagedErrorName>IDS_ACCOUNT_LOOP_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040505</ErrorId>
<ManagedErrorName>unManagedidsopportunitymissingparent</ManagedErrorName>
<ErrorMessage>The parent of the opportunity is missing.</ErrorMessage>
<UnManagedErrorName>IDS_OPPORTUNITY_MISSING_PARENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040504</ErrorId>
<ManagedErrorName>unManagedidsopportunityinvalidparent</ManagedErrorName>
<ErrorMessage>The parent of an opportunity must be an account or contact.</ErrorMessage>
<UnManagedErrorName>IDS_OPPORTUNITY_INVALID_PARENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040503</ErrorId>
<ManagedErrorName>ContactDoesNotExist</ManagedErrorName>
<ErrorMessage>Contact does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_CONTACT_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040502</ErrorId>
<ManagedErrorName>AccountDoesNotExist</ManagedErrorName>
<ErrorMessage>Account does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_ACCOUNT_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040501</ErrorId>
<ManagedErrorName>unManagedidsleaddoesnotexist</ManagedErrorName>
<ErrorMessage>Lead does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_LEAD_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040500</ErrorId>
<ManagedErrorName>unManagedidsopportunitydoesnotexist</ManagedErrorName>
<ErrorMessage>Opportunity does not exist.</ErrorMessage>
<UnManagedErrorName>IDS_OPPORTUNITY_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040499</ErrorId>
<ManagedErrorName>ReportDoesNotExist</ManagedErrorName>
<ErrorMessage>Report does not exist. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040498</ErrorId>
<ManagedErrorName>ReportLoopBeingCreated</ManagedErrorName>
<ErrorMessage>Creating this parental association would create a loop in Reports hierarchy.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040497</ErrorId>
<ManagedErrorName>ReportLoopExists</ManagedErrorName>
<ErrorMessage>Loop exists in the reports hierarchy.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040496</ErrorId>
<ManagedErrorName>ParentReportLinksToSameNameChild</ManagedErrorName>
<ErrorMessage>Parent report already links to another report with the same name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040495</ErrorId>
<ManagedErrorName>DuplicateReportVisibility</ManagedErrorName>
<ErrorMessage>A ReportVisibility with the same ReportId and VisibilityCode already exists. Duplicates are not allowed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040494</ErrorId>
<ManagedErrorName>ReportRenderError</ManagedErrorName>
<ErrorMessage>An error occurred during report rendering.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040493</ErrorId>
<ManagedErrorName>SubReportDoesNotExist</ManagedErrorName>
<ErrorMessage>Subreport does not exist. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040492</ErrorId>
<ManagedErrorName>SrsDataConnectorNotInstalled</ManagedErrorName>
<ErrorMessage>MSCRM Data Connector Not Installed</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040491</ErrorId>
<ManagedErrorName>InvalidCustomReportingWizardXml</ManagedErrorName>
<ErrorMessage>Invalid wizard xml</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040490</ErrorId>
<ManagedErrorName>UpdateNonCustomReportFromTemplate</ManagedErrorName>
<ErrorMessage>Cannot update a report from a template if the report was not created from a template</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040489</ErrorId>
<ManagedErrorName>SnapshotReportNotReady</ManagedErrorName>
<ErrorMessage>The selected report is not ready for viewing. The report is still being created or a report snapshot is not available. ReportId:{0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040488</ErrorId>
<ManagedErrorName>ExistingExternalReport</ManagedErrorName>
<ErrorMessage>The report could not be published for external use because a report of the same name already exists. Delete that report in SQL Server Reporting Services or rename this report, and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040487</ErrorId>
<ManagedErrorName>ParentReportNotSupported</ManagedErrorName>
<ErrorMessage>Parent report is not supported for the type of report specified. Only SQL Reporting Services reports can have parent reports.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040486</ErrorId>
<ManagedErrorName>ParentReportDoesNotReferenceChild</ManagedErrorName>
<ErrorMessage>Specified parent report does not reference the current one. Only SQL Reporting Services reports can have parent reports.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040485</ErrorId>
<ManagedErrorName>MultipleParentReportsFound</ManagedErrorName>
<ErrorMessage>More than one report link found. Each report can have only one parent.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040484</ErrorId>
<ManagedErrorName>ReportingServicesReportExpected</ManagedErrorName>
<ErrorMessage>The report is not a Reporting Services report.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040389</ErrorId>
<ManagedErrorName>InvalidTransformationParameter</ManagedErrorName>
<ErrorMessage>A parameter for the transformation is either missing or invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040388</ErrorId>
<ManagedErrorName>ReflexiveEntityParentOrChildDoesNotExist</ManagedErrorName>
<ErrorMessage>Either the parent or child entity does not exist</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040387</ErrorId>
<ManagedErrorName>EntityLoopBeingCreated</ManagedErrorName>
<ErrorMessage>Creating this parental association would create a loop in this entity hierarchy.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040386</ErrorId>
<ManagedErrorName>EntityLoopExists</ManagedErrorName>
<ErrorMessage>Loop exists in this entity hierarchy.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040385</ErrorId>
<ManagedErrorName>UnsupportedProcessCode</ManagedErrorName>
<ErrorMessage>The process code is not supported on this entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040384</ErrorId>
<ManagedErrorName>NoOutputTransformationParameterMappingFound</ManagedErrorName>
<ErrorMessage>There is no output transformation parameter mapping defined. A transformation mapping must have atleast one output transformation parameter mapping.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040383</ErrorId>
<ManagedErrorName>RequiredColumnsNotFoundInImportFile</ManagedErrorName>
<ErrorMessage>One or more source columns used in the transformation do not exist in the source file.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040382</ErrorId>
<ManagedErrorName>InvalidTransformationParameterMapping</ManagedErrorName>
<ErrorMessage>The transformation parameter mapping defined is invalid. Check that the target attribute name exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040381</ErrorId>
<ManagedErrorName>UnmappedTransformationOutputDataFound</ManagedErrorName>
<ErrorMessage>One or more outputs returned by the transformation is not mapped to target fields.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040380</ErrorId>
<ManagedErrorName>InvalidTransformationParameterDataType</ManagedErrorName>
<ErrorMessage>The data type of one or more of the transformation parameters is unsupported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004037f</ErrorId>
<ManagedErrorName>ArrayMappingFoundForSingletonParameter</ManagedErrorName>
<ErrorMessage>An array transformation parameter mapping is defined for a single parameter.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004037e</ErrorId>
<ManagedErrorName>SingletonMappingFoundForArrayParameter</ManagedErrorName>
<ErrorMessage>A single transformation parameter mapping is defined for an array parameter.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004037d</ErrorId>
<ManagedErrorName>IncompleteTransformationParameterMappingsFound</ManagedErrorName>
<ErrorMessage>One or more mandatory transformation parameters do not have mappings defined for them.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004037c</ErrorId>
<ManagedErrorName>InvalidTransformationParameterMappings</ManagedErrorName>
<ErrorMessage>One or more transformation parameter mappings are invalid or do not match the transformation parameter description.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004037b</ErrorId>
<ManagedErrorName>GenericTransformationInvocationError</ManagedErrorName>
<ErrorMessage>The transformation returned invalid data.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004037a</ErrorId>
<ManagedErrorName>InvalidTransformationType</ManagedErrorName>
<ErrorMessage>The specified transformation type is not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040379</ErrorId>
<ManagedErrorName>UnableToLoadTransformationType</ManagedErrorName>
<ErrorMessage>Unable to load the transformation type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040378</ErrorId>
<ManagedErrorName>UnableToLoadTransformationAssembly</ManagedErrorName>
<ErrorMessage>Unable to load the transformation assembly.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040377</ErrorId>
<ManagedErrorName>InvalidColumnMapping</ManagedErrorName>
<ErrorMessage>ColumnMapping is Invalid. Check that the target attribute exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040376</ErrorId>
<ManagedErrorName>CannotModifyOldDataFromImport</ManagedErrorName>
<ErrorMessage>The corresponding record in Microsoft Dynamics CRM has more recent data, so this record was ignored.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040375</ErrorId>
<ManagedErrorName>ImportFileTooLargeToUpload</ManagedErrorName>
<ErrorMessage>The import file is too large to upload.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040374</ErrorId>
<ManagedErrorName>InvalidImportFileContent</ManagedErrorName>
<ErrorMessage>The content of the import file is not valid. You must select a text file.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040373</ErrorId>
<ManagedErrorName>EmptyRecord</ManagedErrorName>
<ErrorMessage>The record is empty</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040372</ErrorId>
<ManagedErrorName>LongParseRow</ManagedErrorName>
<ErrorMessage>The row is too long to import</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040371</ErrorId>
<ManagedErrorName>ParseMustBeCalledBeforeTransform</ManagedErrorName>
<ErrorMessage>Cannot call transform before parse.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040370</ErrorId>
<ManagedErrorName>HeaderValueDoesNotMatchAttributeDisplayLabel</ManagedErrorName>
<ErrorMessage>The column heading does not match the attribute display label.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040369</ErrorId>
<ManagedErrorName>InvalidTargetEntity</ManagedErrorName>
<ErrorMessage>The specified target record type does not exist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040368</ErrorId>
<ManagedErrorName>NoHeaderColumnFound</ManagedErrorName>
<ErrorMessage>A column heading is missing.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040367</ErrorId>
<ManagedErrorName>ParsingMetadataNotFound</ManagedErrorName>
<ErrorMessage>Data required to parse the file, such as the data delimiter, field delimiter, or column headings, was not found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040366</ErrorId>
<ManagedErrorName>EmptyHeaderRow</ManagedErrorName>
<ErrorMessage>The first row of the file is empty.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040365</ErrorId>
<ManagedErrorName>EmptyContent</ManagedErrorName>
<ErrorMessage>The file is empty.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040364</ErrorId>
<ManagedErrorName>InvalidIsFirstRowHeaderForUseSystemMap</ManagedErrorName>
<ErrorMessage>The first row of the file does not contain column headings.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040363</ErrorId>
<ManagedErrorName>InvalidGuid</ManagedErrorName>
<ErrorMessage>The globally unique identifier (GUID) in this row is invalid</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040362</ErrorId>
<ManagedErrorName>GuidNotPresent</ManagedErrorName>
<ErrorMessage>The required globally unique identifier (GUID) in this row is not present</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040361</ErrorId>
<ManagedErrorName>OwnerValueNotMapped</ManagedErrorName>
<ErrorMessage>The owner value is not mapped</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040360</ErrorId>
<ManagedErrorName>PicklistValueNotMapped</ManagedErrorName>
<ErrorMessage>The record could not be processed as the Option set value could not be mapped.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004035a</ErrorId>
<ManagedErrorName>ErrorInDelete</ManagedErrorName>
<ErrorMessage>The Microsoft Dynamics CRM record could not be deleted</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040359</ErrorId>
<ManagedErrorName>ErrorIncreate</ManagedErrorName>
<ErrorMessage>The Microsoft Dynamics CRM record could not be created</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040358</ErrorId>
<ManagedErrorName>ErrorInUpdate</ManagedErrorName>
<ErrorMessage>The Microsoft Dynamics CRM record could not be updated</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040357</ErrorId>
<ManagedErrorName>ErrorInSetState</ManagedErrorName>
<ErrorMessage>The status or status reason of the Microsoft Dynamics CRM record could not be set</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040356</ErrorId>
<ManagedErrorName>InvalidDataFormat</ManagedErrorName>
<ErrorMessage>The source data is not in the required format</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040355</ErrorId>
<ManagedErrorName>InvalidFormatForDataDelimiter</ManagedErrorName>
<ErrorMessage>Mismatched data delimiter: only one delimiter was found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040354</ErrorId>
<ManagedErrorName>CRMUserDoesNotExist</ManagedErrorName>
<ErrorMessage>No Microsoft Dynamics CRM user exists with the specified domain name and user ID</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040353</ErrorId>
<ManagedErrorName>LookupNotFound</ManagedErrorName>
<ErrorMessage>The lookup reference could not be resolved</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040352</ErrorId>
<ManagedErrorName>DuplicateLookupFound</ManagedErrorName>
<ErrorMessage>A duplicate lookup reference was found</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040351</ErrorId>
<ManagedErrorName>InvalidImportFileData</ManagedErrorName>
<ErrorMessage>The data is not in the required format</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040350</ErrorId>
<ManagedErrorName>InvalidXmlSSContent</ManagedErrorName>
<ErrorMessage>The data file can’t be imported because it contains invalid entity data or it’s in the wrong format. Make sure that the file contains correct data and that it’s in the XML Spreadsheet 2003 format, and then try uploading again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040349</ErrorId>
<ManagedErrorName>InvalidImportFileParseData</ManagedErrorName>
<ErrorMessage>Field and data delimiters for this file are not specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040348</ErrorId>
<ManagedErrorName>InvalidValueForFileType</ManagedErrorName>
<ErrorMessage>The file type is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040347</ErrorId>
<ManagedErrorName>EmptyImportFileRow</ManagedErrorName>
<ErrorMessage>Empty row.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040346</ErrorId>
<ManagedErrorName>ErrorInParseRow</ManagedErrorName>
<ErrorMessage>The row could not be parsed. This is typically caused by a row that is too long.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040345</ErrorId>
<ManagedErrorName>DataColumnsNumberMismatch</ManagedErrorName>
<ErrorMessage>The number of fields differs from the number of column headings.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040344</ErrorId>
<ManagedErrorName>InvalidHeaderColumn</ManagedErrorName>
<ErrorMessage>The column heading contains an invalid combination of data delimiters.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040343</ErrorId>
<ManagedErrorName>OwnerMappingExistsWithSourceSystemUserName</ManagedErrorName>
<ErrorMessage>The data map already contains this owner mapping.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040342</ErrorId>
<ManagedErrorName>PickListMappingExistsWithSourceValue</ManagedErrorName>
<ErrorMessage>The data map already contains this list value mapping.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040341</ErrorId>
<ManagedErrorName>InvalidValueForDataDelimiter</ManagedErrorName>
<ErrorMessage>The data delimiter is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040340</ErrorId>
<ManagedErrorName>InvalidValueForFieldDelimiter</ManagedErrorName>
<ErrorMessage>The field delimiter is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004033f</ErrorId>
<ManagedErrorName>PickListMappingExistsForTargetValue</ManagedErrorName>
<ErrorMessage>This list value is mapped more than once. Remove any duplicate mappings, and then import this data map again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004033e</ErrorId>
<ManagedErrorName>MappingExistsForTargetAttribute</ManagedErrorName>
<ErrorMessage>This attribute is mapped more than once. Remove any duplicate mappings, and then import this data map again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004033d</ErrorId>
<ManagedErrorName>SourceEntityMappedToMultipleTargets</ManagedErrorName>
<ErrorMessage>This source entity is mapped to more than one Microsoft Dynamics CRM entity. Remove any duplicate mappings, and then import this data map again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004033c</ErrorId>
<ManagedErrorName>AttributeNotOfTypePicklist</ManagedErrorName>
<ErrorMessage>This attribute is not mapped to a drop-down list, Boolean, or state/status attribute. However, you have included a ListValueMap element for it.  Fix this inconsistency, and then import this data map again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040390</ErrorId>
<ManagedErrorName>AttributeNotOfTypeReference</ManagedErrorName>
<ErrorMessage>This attribute is not mapped as a reference attribute. However, you have included a ReferenceMap for it.  Fix this inconsistency, and then import this data map again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040391</ErrorId>
<ManagedErrorName>TargetEntityNotFound</ManagedErrorName>
<ErrorMessage>The file specifies an entity that does not exist in Microsoft Dynamics CRM.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040392</ErrorId>
<ManagedErrorName>TargetAttributeNotFound</ManagedErrorName>
<ErrorMessage>The file specifies an attribute that does not exist in Microsoft Dynamics CRM.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040393</ErrorId>
<ManagedErrorName>PicklistValueNotFound</ManagedErrorName>
<ErrorMessage>The file specifies a list value that does not exist in Microsoft Dynamics CRM.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040394</ErrorId>
<ManagedErrorName>TargetAttributeInvalidForMap</ManagedErrorName>
<ErrorMessage>This attribute is not valid for mapping.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040395</ErrorId>
<ManagedErrorName>TargetEntityInvalidForMap</ManagedErrorName>
<ErrorMessage>The file specifies an entity that is not valid for data migration.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040396</ErrorId>
<ManagedErrorName>InvalidFileBadCharacters</ManagedErrorName>
<ErrorMessage>The file could not be uploaded because it contains invalid character(s)</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004034a</ErrorId>
<ManagedErrorName>ErrorsInImportFiles</ManagedErrorName>
<ErrorMessage>Invalid File(s) for Import</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004033a</ErrorId>
<ManagedErrorName>InvalidOperationWhenListIsNotActive</ManagedErrorName>
<ErrorMessage>List is not active. Cannot perform this operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004033b</ErrorId>
<ManagedErrorName>InvalidOperationWhenPartyIsNotActive</ManagedErrorName>
<ErrorMessage>The party is not active. Cannot perform this operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040339</ErrorId>
<ManagedErrorName>AsyncOperationSuspendedOrLocked</ManagedErrorName>
<ErrorMessage>>A background job associated with this import is either suspended or locked. In order to delete this import, in the Workplace, click Imports, open the import, click System Jobs, and resume any suspended jobs.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040338</ErrorId>
<ManagedErrorName>DuplicateHeaderColumn</ManagedErrorName>
<ErrorMessage>A duplicate column heading exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040337</ErrorId>
<ManagedErrorName>EmptyHeaderColumn</ManagedErrorName>
<ErrorMessage>The column heading cannot be empty.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040336</ErrorId>
<ManagedErrorName>InvalidColumnNumber</ManagedErrorName>
<ErrorMessage>The column number specified in the data map does not exist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040335</ErrorId>
<ManagedErrorName>TransformMustBeCalledBeforeImport</ManagedErrorName>
<ErrorMessage>Cannot call import before transform.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040334</ErrorId>
<ManagedErrorName>OperationCanBeCalledOnlyOnce</ManagedErrorName>
<ErrorMessage>The specified action can be done only one time.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040333</ErrorId>
<ManagedErrorName>DuplicateRecordsFound</ManagedErrorName>
<ErrorMessage>A record was not created or updated because a duplicate of the current record already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040331</ErrorId>
<ManagedErrorName>CampaignActivityClosed</ManagedErrorName>
<ErrorMessage>This Campaign Activity is closed or canceled. Campaign activities cannot be distributed after they have been closed or canceled.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040330</ErrorId>
<ManagedErrorName>UnexpectedErrorInMailMerge</ManagedErrorName>
<ErrorMessage>There was an unexpected error during mail merge.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004032f</ErrorId>
<ManagedErrorName>UserCancelledMailMerge</ManagedErrorName>
<ErrorMessage>The mail merge operation was cancelled by the user.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004032e</ErrorId>
<ManagedErrorName>FilteredDuetoMissingEmailAddress</ManagedErrorName>
<ErrorMessage>This customer is filtered due to missing email address.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004032b</ErrorId>
<ManagedErrorName>CannotDeleteAsBackgroundOperationInProgress</ManagedErrorName>
<ErrorMessage>This record is currently being used by Microsoft Dynamics CRM and cannot be deleted. Try again later. If  the problem persists, contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004032a</ErrorId>
<ManagedErrorName>FilteredDuetoInactiveState</ManagedErrorName>
<ErrorMessage>This customer is filtered due to inactive state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040329</ErrorId>
<ManagedErrorName>MissingBOWFRules</ManagedErrorName>
<ErrorMessage>Bulk Operation related workflow rules are missing.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040327</ErrorId>
<ManagedErrorName>CannotSpecifyOwnerForActivityPropagation</ManagedErrorName>
<ErrorMessage>Cannot specify owner on activity for distribution</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040326</ErrorId>
<ManagedErrorName>CampaignActivityAlreadyPropagated</ManagedErrorName>
<ErrorMessage>This campaign activity has been distributed already. Campaign activities cannot be distributed more than one time.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040325</ErrorId>
<ManagedErrorName>FilteredDuetoAntiSpam</ManagedErrorName>
<ErrorMessage>This customer is filtered due to AntiSpam settings.</ErrorMessage>
<UnManagedErrorName>IDS_ANTISPAM_FILTERED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040324</ErrorId>
<ManagedErrorName>TemplateTypeNotSupportedForUnsubscribeAcknowledgement</ManagedErrorName>
<ErrorMessage>This template type is not supported for unsubscribe acknowledgement.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040323</ErrorId>
<ManagedErrorName>ErrorInImportConfig</ManagedErrorName>
<ErrorMessage>Cannot process with Bulk Import as Import Configuration has some errors.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040322</ErrorId>
<ManagedErrorName>ImportConfigNotSpecified</ManagedErrorName>
<ErrorMessage>Cannot process with Bulk Import as Import Configuration not specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040321</ErrorId>
<ManagedErrorName>InvalidActivityType</ManagedErrorName>
<ErrorMessage>An invalid object type was specified for distributing activities.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040320</ErrorId>
<ManagedErrorName>UnsupportedParameter</ManagedErrorName>
<ErrorMessage>A parameter specified is not supported by the Bulk Operation</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004031f</ErrorId>
<ManagedErrorName>MissingParameter</ManagedErrorName>
<ErrorMessage>A required parameter is missing for the Bulk Operation</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004031e</ErrorId>
<ManagedErrorName>CannotSpecifyCommunicationAttributeOnActivityForPropagation</ManagedErrorName>
<ErrorMessage>Cannot specify communication attribute on activity for distribution</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004031d</ErrorId>
<ManagedErrorName>CannotSpecifyRecipientForActivityPropagation</ManagedErrorName>
<ErrorMessage>Cannot specify a recipient for activity distribution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004031c</ErrorId>
<ManagedErrorName>CannotSpecifyAttendeeForAppointmentPropagation</ManagedErrorName>
<ErrorMessage>Cannot specify an attendee for appointment distribution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004031b</ErrorId>
<ManagedErrorName>CannotSpecifySenderForActivityPropagation</ManagedErrorName>
<ErrorMessage>Cannot specify a sender for appointment distribution</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004031a</ErrorId>
<ManagedErrorName>CannotSpecifyOrganizerForAppointmentPropagation</ManagedErrorName>
<ErrorMessage>Cannot specify an organizer for appointment distribution</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040319</ErrorId>
<ManagedErrorName>InvalidRegardingObjectTypeCode</ManagedErrorName>
<ErrorMessage>The regarding Object Type Code is not valid for the Bulk Operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040318</ErrorId>
<ManagedErrorName>UnspecifiedActivityXmlForCampaignActivityPropagate</ManagedErrorName>
<ErrorMessage>Must specify an Activity Xml for CampaignActivity Execute/Distribute</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040317</ErrorId>
<ManagedErrorName>MoneySizeExceeded</ManagedErrorName>
<ErrorMessage>Supplied value exceeded the MIN/MAX value of Money Type field.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040316</ErrorId>
<ManagedErrorName>ExtraPartyInformation</ManagedErrorName>
<ErrorMessage>Extra party information should not be provided for this operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040315</ErrorId>
<ManagedErrorName>NotSupported</ManagedErrorName>
<ErrorMessage>This action is not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040314</ErrorId>
<ManagedErrorName>InvalidOperationForClosedOrCancelledCampaignActivity</ManagedErrorName>
<ErrorMessage>Can not add items to closed (cancelled) campaignactivity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040313</ErrorId>
<ManagedErrorName>InvalidEmailTemplate</ManagedErrorName>
<ErrorMessage>Must specify a valid Template Id</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040312</ErrorId>
<ManagedErrorName>CannotCreateResponseForTemplate</ManagedErrorName>
<ErrorMessage>CampaignResponse can not be created for Template Campaign.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040311</ErrorId>
<ManagedErrorName>CannotPropagateCamapaignActivityForTemplate</ManagedErrorName>
<ErrorMessage>Cannot execute (distribute) a CampaignActivity for a template Campaign.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040310</ErrorId>
<ManagedErrorName>InvalidChannelForCampaignActivityPropagate</ManagedErrorName>
<ErrorMessage>Cannot distribute activities for campaign activities of the specified channel type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004030f</ErrorId>
<ManagedErrorName>InvalidActivityTypeForCampaignActivityPropagate</ManagedErrorName>
<ErrorMessage>Must specify a valid CommunicationActivity</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004030e</ErrorId>
<ManagedErrorName>ObjectNotRelatedToCampaign</ManagedErrorName>
<ErrorMessage>Specified Object not related to the parent Campaign</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004030d</ErrorId>
<ManagedErrorName>CannotRelateObjectTypeToCampaignActivity</ManagedErrorName>
<ErrorMessage>Specified Object Type not supported</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004030c</ErrorId>
<ManagedErrorName>CannotUpdateCampaignForCampaignResponse</ManagedErrorName>
<ErrorMessage>Parent campaign is not updatable.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004030b</ErrorId>
<ManagedErrorName>CannotUpdateCampaignForCampaignActivity</ManagedErrorName>
<ErrorMessage>Parent campaign is not updatable.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004030a</ErrorId>
<ManagedErrorName>CampaignNotSpecifiedForCampaignResponse</ManagedErrorName>
<ErrorMessage>RegardingObjectId is a required field.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040309</ErrorId>
<ManagedErrorName>CampaignNotSpecifiedForCampaignActivity</ManagedErrorName>
<ErrorMessage>RegardingObjectId is a required field.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040307</ErrorId>
<ManagedErrorName>CannotRelateObjectTypeToCampaign</ManagedErrorName>
<ErrorMessage>Specified Object Type not supported</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040306</ErrorId>
<ManagedErrorName>CannotCopyIncompatibleListType</ManagedErrorName>
<ErrorMessage>Cannot copy lists of different types.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040305</ErrorId>
<ManagedErrorName>InvalidActivityTypeForList</ManagedErrorName>
<ErrorMessage>Cannot create activities of the specified list type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040304</ErrorId>
<ManagedErrorName>CannotAssociateInactiveItemToCampaign</ManagedErrorName>
<ErrorMessage>Cannot associate an inactive item to a Campaign.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040303</ErrorId>
<ManagedErrorName>InvalidFetchXml</ManagedErrorName>
<ErrorMessage>Malformed FetchXml.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040302</ErrorId>
<ManagedErrorName>InvalidOperationWhenListLocked</ManagedErrorName>
<ErrorMessage>List is Locked. Cannot perform this action.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040301</ErrorId>
<ManagedErrorName>UnsupportedListMemberType</ManagedErrorName>
<ErrorMessage>Unsupported list member type.</ErrorMessage>
</crmerror>
  <crmerror>
<ErrorId>80040266</ErrorId>
<ManagedErrorName>InvalidPrimaryKey</ManagedErrorName>
<ErrorMessage>Invalid primary key.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_KEY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040265</ErrorId>
<ManagedErrorName>IsvAborted</ManagedErrorName>
<ErrorMessage>ISV code aborted the operation.</ErrorMessage>
<UnManagedErrorName>IDS_ISV_ABORTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040264</ErrorId>
<ManagedErrorName>CannotAssignOutlookFilters</ManagedErrorName>
<ErrorMessage>Cannot assign outlook filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040263</ErrorId>
<ManagedErrorName>CannotCreateOutlookFilters</ManagedErrorName>
<ErrorMessage>Cannot create outlook filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040268</ErrorId>
<ManagedErrorName>CannotGrantAccessToOutlookFilters</ManagedErrorName>
<ErrorMessage>Cannot grant access to outlook filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040269</ErrorId>
<ManagedErrorName>CannotModifyAccessToOutlookFilters</ManagedErrorName>
<ErrorMessage>Cannot modify access for outlook filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040270</ErrorId>
<ManagedErrorName>CannotRevokeAccessToOutlookFilters</ManagedErrorName>
<ErrorMessage>Cannot revoke access for outlook filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040271</ErrorId>
<ManagedErrorName>CannotGrantAccessToOfflineFilters</ManagedErrorName>
<ErrorMessage>Cannot grant access to offline filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040272</ErrorId>
<ManagedErrorName>CannotModifyAccessToOfflineFilters</ManagedErrorName>
<ErrorMessage>Cannot modify access for offline filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040273</ErrorId>
<ManagedErrorName>CannotRevokeAccessToOfflineFilters</ManagedErrorName>
<ErrorMessage>Cannot revoke access for offline filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040274</ErrorId>
<ManagedErrorName>DuplicateOutlookAppointment</ManagedErrorName>
<ErrorMessage>The Appointment being promoted from Outlook is already tracked in CRM</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040275</ErrorId>
<ManagedErrorName>AppointmentScheduleNotSet</ManagedErrorName>
<ErrorMessage>Scheduled End and Scheduled Start must be set for Appointments in order to sync with Outlook.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040276</ErrorId>
<ManagedErrorName>PrivilegeCreateIsDisabledForOrganization</ManagedErrorName>
<ErrorMessage>Privilege Create is disabled for organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040277</ErrorId>
<ManagedErrorName>UnauthorizedAccess</ManagedErrorName>
<ErrorMessage>Attempted to perform an unauthorized operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040278</ErrorId>
<ManagedErrorName>InvalidCharactersInField</ManagedErrorName>
<ErrorMessage>The field '{0}' contains one or more invalid characters.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040279</ErrorId>
<ManagedErrorName>CannotChangeStateOfNonpublicView</ManagedErrorName>
<ErrorMessage>Only public views can be deactivated and activated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004027a</ErrorId>
<ManagedErrorName>CannotDeactivateDefaultView</ManagedErrorName>
<ErrorMessage>Default views cannot be deactivated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004027b</ErrorId>
<ManagedErrorName>CannotSetInactiveViewAsDefault</ManagedErrorName>
<ErrorMessage>Inactive views cannot be set as default view.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004027c</ErrorId>
<ManagedErrorName>CannotExceedFilterLimit</ManagedErrorName>
<ErrorMessage>Cannot exceed synchronization filter limit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004027d</ErrorId>
<ManagedErrorName>CannotHaveMultipleDefaultFilterTemplates</ManagedErrorName>
<ErrorMessage>Cannot have multiple default synchronization templates for a single entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040262</ErrorId>
<ManagedErrorName>CrmConstraintParsingError</ManagedErrorName>
<ErrorMessage>Crm constraint parsing error occurred.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040261</ErrorId>
<ManagedErrorName>CrmConstraintEvaluationError</ManagedErrorName>
<ErrorMessage>Crm constraint evaluation error occurred.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040260</ErrorId>
<ManagedErrorName>CrmExpressionEvaluationError</ManagedErrorName>
<ErrorMessage>Crm expression evaluation error occurred.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004025f</ErrorId>
<ManagedErrorName>CrmExpressionParametersParsingError</ManagedErrorName>
<ErrorMessage>Crm expression parameters parsing error occurred.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004025e</ErrorId>
<ManagedErrorName>CrmExpressionBodyParsingError</ManagedErrorName>
<ErrorMessage>Crm expression body parsing error occurred.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004025d</ErrorId>
<ManagedErrorName>CrmExpressionParsingError</ManagedErrorName>
<ErrorMessage>Crm expression parsing error occurred.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004025c</ErrorId>
<ManagedErrorName>CrmMalformedExpressionError</ManagedErrorName>
<ErrorMessage>Crm malformed expression error occurred.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004025b</ErrorId>
<ManagedErrorName>CalloutException</ManagedErrorName>
<ErrorMessage>Callout Exception occurred.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004025a</ErrorId>
<ManagedErrorName>DateTimeFormatFailed</ManagedErrorName>
<ErrorMessage>Failed to produce a formatted datetime value.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040259</ErrorId>
<ManagedErrorName>NumberFormatFailed</ManagedErrorName>
<ErrorMessage>Failed to produce a formatted numeric value.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040258</ErrorId>
<ManagedErrorName>InvalidRestore</ManagedErrorName>
<ErrorMessage>RestoreCaller must be called after SwitchToSystemUser.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040257</ErrorId>
<ManagedErrorName>InvalidCaller</ManagedErrorName>
<ErrorMessage>Cannot switch ExecutionContext to system user without setting Caller first.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040256</ErrorId>
<ManagedErrorName>CrmSecurityError</ManagedErrorName>
<ErrorMessage>A failure occurred in CrmSecurity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040255</ErrorId>
<ManagedErrorName>TransactionAborted</ManagedErrorName>
<ErrorMessage>Transaction Aborted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040254</ErrorId>
<ManagedErrorName>CannotBindToSession</ManagedErrorName>
<ErrorMessage>Cannot bind to another session, session already bound.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040253</ErrorId>
<ManagedErrorName>SessionTokenUnavailable</ManagedErrorName>
<ErrorMessage>Session token is not available unless there is a transaction in place.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040252</ErrorId>
<ManagedErrorName>TransactionNotCommited</ManagedErrorName>
<ErrorMessage>Transaction not committed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040251</ErrorId>
<ManagedErrorName>TransactionNotStarted</ManagedErrorName>
<ErrorMessage>Transaction not started.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040250</ErrorId>
<ManagedErrorName>MultipleChildPicklist</ManagedErrorName>
<ErrorMessage>Crm Internal Exception: Picklists with more than one childAttribute are not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004024f</ErrorId>
<ManagedErrorName>InvalidSingletonResults</ManagedErrorName>
<ErrorMessage>Crm Internal Exception: Singleton Retrieve Query should not return more than 1 record.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004024e</ErrorId>
<ManagedErrorName>FailedToLoadAssembly</ManagedErrorName>
<ErrorMessage>Failed to load assembly</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004024d</ErrorId>
<ManagedErrorName>CrmQueryExpressionNotInitialized</ManagedErrorName>
<ErrorMessage>The QueryExpression has not been initialized. Please use the constructor that takes in the entity name to create a correctly initialized instance</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004024c</ErrorId>
<ManagedErrorName>InvalidRegistryKey</ManagedErrorName>
<ErrorMessage>Invalid registry key specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004024b</ErrorId>
<ManagedErrorName>InvalidPriv</ManagedErrorName>
<ErrorMessage>Invalid privilege type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004024a</ErrorId>
<ManagedErrorName>MetadataNotFound</ManagedErrorName>
<ErrorMessage>Metadata not found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040249</ErrorId>
<ManagedErrorName>InvalidEntityClassException</ManagedErrorName>
<ErrorMessage>Invalid entity class.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040248</ErrorId>
<ManagedErrorName>InvalidXmlEntityNameException</ManagedErrorName>
<ErrorMessage>Invalid Xml entity name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040247</ErrorId>
<ManagedErrorName>InvalidXmlCollectionNameException</ManagedErrorName>
<ErrorMessage>Invalid Xml collection name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040246</ErrorId>
<ManagedErrorName>InvalidRecurrenceRule</ManagedErrorName>
<ErrorMessage>Error in RecurrencePatternFactory.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040245</ErrorId>
<ManagedErrorName>CrmImpersonationError</ManagedErrorName>
<ErrorMessage>Error occurred in the Crm AutoReimpersonator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040244</ErrorId>
<ManagedErrorName>ServiceInstantiationFailed</ManagedErrorName>
<ErrorMessage>Instantiation of an Entity failed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040243</ErrorId>
<ManagedErrorName>EntityInstantiationFailed</ManagedErrorName>
<ErrorMessage>Instantiation of an Entity instance Service failed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040242</ErrorId>
<ManagedErrorName>FormTransitionError</ManagedErrorName>
<ErrorMessage>The import has failed because the system cannot transition the entity form {0} from unmanaged to managed. Add at least one full (root) component to the managed solution, and then try to import it again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040241</ErrorId>
<ManagedErrorName>UserTimeConvertException</ManagedErrorName>
<ErrorMessage>Failed to convert user time zone information.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040240</ErrorId>
<ManagedErrorName>UserTimeZoneException</ManagedErrorName>
<ErrorMessage>Failed to retrieve user time zone information.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004023f</ErrorId>
<ManagedErrorName>InvalidConnectionString</ManagedErrorName>
<UnManagedErrorName>IDS_INVALIDCONNSTRING</UnManagedErrorName>
<ErrorMessage>The connection string not found or invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004023e</ErrorId>
<ManagedErrorName>OpenCrmDBConnection</ManagedErrorName>
<ErrorMessage>Db Connection is Open, when it should be Closed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004023d</ErrorId>
<ManagedErrorName>UnpopulatedPrimaryKey</ManagedErrorName>
<ErrorMessage>Primary Key must be populated for calls to platform on rich client in offline mode.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004023c</ErrorId>
<ManagedErrorName>InvalidVersion</ManagedErrorName>
<ErrorMessage>Unhandled Version mismatch found.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_ASSIGN_OUTLOOK_FILTERS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004023b</ErrorId>
<ManagedErrorName>InvalidOperation</ManagedErrorName>
<ErrorMessage>Invalid Operation performed.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_CREATE_OUTLOOK_FILTERS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004023a</ErrorId>
<ManagedErrorName>InvalidMetadata</ManagedErrorName>
<ErrorMessage>Invalid Metadata.</ErrorMessage>
<UnManagedErrorName>IDS_TRANSACTION_TEST_FAIL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040239</ErrorId>
<ManagedErrorName>InvalidDateTime</ManagedErrorName>
<ErrorMessage>The date-time format is invalid, or value is outside the supported range.</ErrorMessage>
<UnManagedErrorName>IDS_INVALIDDATETIME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040238</ErrorId>
<ManagedErrorName>unManagedidscannotdefaultprivateview</ManagedErrorName>
<ErrorMessage>Private views cannot be default.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_DEFAULT_PRIVATE_VIEW</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040237</ErrorId>
<ManagedErrorName>DuplicateRecord</ManagedErrorName>
<ErrorMessage>Operation failed due to a SQL integrity violation.</ErrorMessage>
<UnManagedErrorName>IDS_DUPLICATE_RECORD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040236</ErrorId>
<ManagedErrorName>unManagedidsnorelationship</ManagedErrorName>
<ErrorMessage>No relationship exists between the objects specified.</ErrorMessage>
<UnManagedErrorName>IDS_NO_RELATIONSHIP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040235</ErrorId>
<ManagedErrorName>MissingQueryType</ManagedErrorName>
<ErrorMessage>The query type is missing.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_QUERY_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040234</ErrorId>
<ManagedErrorName>InvalidRollupType</ManagedErrorName>
<ErrorMessage>The rollup type is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ROLLUP_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040233</ErrorId>
<ManagedErrorName>InvalidState</ManagedErrorName>
<ErrorMessage>The object is not in a valid state to perform this operation.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040232</ErrorId>
<ManagedErrorName>unManagedidsviewisnotsharable</ManagedErrorName>
<ErrorMessage>The view is not sharable.</ErrorMessage>
<UnManagedErrorName>IDS_VIEW_IS_NOT_SHARABLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040231</ErrorId>
<ManagedErrorName>PrincipalPrivilegeDenied</ManagedErrorName>
<ErrorMessage>Target user or team does not hold required privileges.</ErrorMessage>
<UnManagedErrorName>IDS_PRINCIPAL_PRIVILEGE_DENIED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040230</ErrorId>
<ManagedErrorName>CannotUpdateObjectBecauseItIsInactive</ManagedErrorName>
<ErrorMessage>The object cannot be updated because it is inactive.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_UPDATE_OBJECT_BECAUSE_IT_IS_INACTIVE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004022f</ErrorId>
<ManagedErrorName>CannotDeleteCannedView</ManagedErrorName>
<ErrorMessage>System-defined views cannot be deleted.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_DELETE_CANNED_VIEW</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004022e</ErrorId>
<ManagedErrorName>CannotUpdateBecauseItIsReadOnly</ManagedErrorName>
<ErrorMessage>The object cannot be updated because it is read-only.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_UPDATE_OBJECT_BECAUSE_IT_IS_READ_ONLY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404cf</ErrorId>
<ManagedErrorName>CaseAlreadyResolved</ManagedErrorName>
<ErrorMessage>This case has already been resolved. Close and reopen the case record to see the updates.</ErrorMessage>
<UnManagedErrorName>IDS_CASE_ALREADY_RESOLVED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004022d</ErrorId>
<ManagedErrorName>InvalidCustomer</ManagedErrorName>
<ErrorMessage>The customer is invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_CUSTOMER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004022c</ErrorId>
<ManagedErrorName>unManagedidsdataoutofrange</ManagedErrorName>
<ErrorMessage>Data out of range</ErrorMessage>
<UnManagedErrorName>IDS_DATA_OUTOFRANGE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004022b</ErrorId>
<ManagedErrorName>unManagedidsownernotenabled</ManagedErrorName>
<ErrorMessage>The specified owner has been disabled.</ErrorMessage>
<UnManagedErrorName>IDS_OWNER_NOT_ENABLED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004022a</ErrorId>
<ManagedErrorName>BusinessManagementObjectAlreadyExists</ManagedErrorName>
<ErrorMessage>An object with the specified name already exists.</ErrorMessage>
<UnManagedErrorName>IDS_AD_OBJECT_ALREADY_EXISTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040229</ErrorId>
<ManagedErrorName>InvalidOwnerID</ManagedErrorName>
<ErrorMessage>The owner ID is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_OWNERID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040228</ErrorId>
<ManagedErrorName>CannotDeleteAsItIsReadOnly</ManagedErrorName>
<ErrorMessage>The object cannot be deleted because it is read-only.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_DELETE_OBJECT_BECAUSE_IT_IS_READ_ONLY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040227</ErrorId>
<ManagedErrorName>CannotDeleteDueToAssociation</ManagedErrorName>
<ErrorMessage>The object you tried to delete is associated with another object and cannot be deleted.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_DELETE_OBJECT_BECAUSE_OF_ASSOTIATION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040226</ErrorId>
<ManagedErrorName>unManagedidsanonymousenabled</ManagedErrorName>
<ErrorMessage>The logged-in user was not found in the Active Directory.</ErrorMessage>
<UnManagedErrorName>IDS_ANONYMOUS_ENABLED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040225</ErrorId>
<ManagedErrorName>unManagedidsusernotenabled</ManagedErrorName>
<ErrorMessage>The specified user is either disabled or is not a member of any business unit.</ErrorMessage>
<UnManagedErrorName>IDS_USER_NOT_ENABLED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004032c</ErrorId>
<ManagedErrorName>BusinessNotEnabled</ManagedErrorName>
<ErrorMessage>The specified business unit is disabled.</ErrorMessage>
<UnManagedErrorName>IDS_BUSINESS_NOT_ENABLED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004032d</ErrorId>
<ManagedErrorName>CannotAssignToDisabledBusiness</ManagedErrorName>
<ErrorMessage>The specified business unit cannot be assigned to because it is disabled.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_ASSIGN_TO_DISABLED_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040224</ErrorId>
<ManagedErrorName>IsvUnExpected</ManagedErrorName>
<ErrorMessage>An unexpected error occurred from ISV code.</ErrorMessage>
<UnManagedErrorName>IDS_ISV_UNEXPECTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040223</ErrorId>
<ManagedErrorName>OnlyOwnerCanRevoke</ManagedErrorName>
<ErrorMessage>Only the owner of an object can revoke the owner's access to that object.</ErrorMessage>
<UnManagedErrorName>IDS_ONLY_OWNER_CAN_REVOKE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040222</ErrorId>
<ManagedErrorName>unManagedidsoutofmemory</ManagedErrorName>
<ErrorMessage>Out of memory.</ErrorMessage>
<UnManagedErrorName>IDS_OUTOFMEMORY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040221</ErrorId>
<ManagedErrorName>unManagedidscannotassigntobusiness</ManagedErrorName>
<ErrorMessage>Cannot assign an object to a merchant.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_ASSIGN_TO_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040220</ErrorId>
<ManagedErrorName>PrivilegeDenied</ManagedErrorName>
<ErrorMessage>The user does not hold the necessary privileges.</ErrorMessage>
<UnManagedErrorName>IDS_PRIVILEGE_DENIED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004021f</ErrorId>
<ManagedErrorName>InvalidObjectTypes</ManagedErrorName>
<ErrorMessage>Invalid object type.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_OBJECT_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004021e</ErrorId>
<ManagedErrorName>unManagedidscannotgrantorrevokeaccesstobusiness</ManagedErrorName>
<ErrorMessage>Cannot grant or revoke access rights to a merchant.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_GRANT_OR_REVOKE_ACCESS_TO_BUSINESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004021d</ErrorId>
<ManagedErrorName>unManagedidsinvaliduseridorbusinessidorusersbusinessinvalid</ManagedErrorName>
<ErrorMessage>One of the following occurred: invalid user id, invalid business id or the user does not belong to the business.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_USERID_OR_BUSINESSID_OR_USERS_BUSINESS_INVALID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004021c</ErrorId>
<ManagedErrorName>unManagedidspresentuseridandteamid</ManagedErrorName>
<ErrorMessage>Both the user id and team id are present. Only one should be present.</ErrorMessage>
<UnManagedErrorName>IDS_PRESENT_USERID_AND_TEAMID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004021b</ErrorId>
<ManagedErrorName>MissingUserId</ManagedErrorName>
<ErrorMessage>The user id or the team id is missing.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_USERID_OR_TEAMID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004021a</ErrorId>
<ManagedErrorName>MissingBusinessId</ManagedErrorName>
<ErrorMessage>The business id is missing or invalid.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_BUSINESSID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040219</ErrorId>
<ManagedErrorName>NotImplemented</ManagedErrorName>
<ErrorMessage>The requested functionality is not yet implemented.</ErrorMessage>
<UnManagedErrorName>IDS_NOT_IMPLEMENTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040218</ErrorId>
<ManagedErrorName>InvalidPointer</ManagedErrorName>
<ErrorMessage>The object is disposed.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_POINTER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040217</ErrorId>
<ManagedErrorName>ObjectDoesNotExist</ManagedErrorName>
<ErrorMessage>The specified object was not found.</ErrorMessage>
<UnManagedErrorName>IDS_OBJECT_DOES_NOT_EXIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040216</ErrorId>
<ManagedErrorName>UnExpected</ManagedErrorName>
<ErrorMessage>An unexpected error occurred.</ErrorMessage>
<UnManagedErrorName>IDS_UNEXPECTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040215</ErrorId>
<ManagedErrorName>MissingOwner</ManagedErrorName>
<ErrorMessage>Item does not have an owner.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_OWNER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040214</ErrorId>
<ManagedErrorName>CannotShareWithOwner</ManagedErrorName>
<ErrorMessage>An item cannot be shared with the owning user.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_SHARE_OBJECT_WITH_OWNER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040213</ErrorId>
<ManagedErrorName>unManagedidsinvalidvisibilitymodificationaccess</ManagedErrorName>
<ErrorMessage>User does not have access to modify the visibility of this item.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_VISIBILITY_MODIFICATION_ACCESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040212</ErrorId>
<ManagedErrorName>unManagedidsinvalidowninguser</ManagedErrorName>
<ErrorMessage>Item does not have an owning user.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_OWNINGUSER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040211</ErrorId>
<ManagedErrorName>unManagedidsinvalidassociation</ManagedErrorName>
<ErrorMessage>Invalid association.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ASSOCIATION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040210</ErrorId>
<ManagedErrorName>InvalidAssigneeId</ManagedErrorName>
<ErrorMessage>Invalid assignee id.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ASSIGNEEID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004020f</ErrorId>
<ManagedErrorName>unManagedidsfailureinittoken</ManagedErrorName>
<ErrorMessage>Failure in obtaining user token.</ErrorMessage>
<UnManagedErrorName>IDS_FAILURE_INITTOKEN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004020e</ErrorId>
<ManagedErrorName>unManagedidsinvalidvisibility</ManagedErrorName>
<ErrorMessage>Invalid visibility.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_VISIBILITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004020d</ErrorId>
<ManagedErrorName>InvalidAccessRights</ManagedErrorName>
<ErrorMessage>Invalid access rights.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ACCESSRIGHTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004020c</ErrorId>
<ManagedErrorName>InvalidSharee</ManagedErrorName>
<ErrorMessage>Invalid share id.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_SHAREEID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004020b</ErrorId>
<ManagedErrorName>unManagedidsinvaliditemid</ManagedErrorName>
<ErrorMessage>Invalid item id.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ITEMID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004020a</ErrorId>
<ManagedErrorName>unManagedidsinvalidorgid</ManagedErrorName>
<ErrorMessage>Invalid organization id.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ORGID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040209</ErrorId>
<ManagedErrorName>unManagedidsinvalidbusinessid</ManagedErrorName>
<ErrorMessage>Invalid business id.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_BUSINESSID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040208</ErrorId>
<ManagedErrorName>unManagedidsinvalidteamid</ManagedErrorName>
<ErrorMessage>Invalid team id.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_TEAMID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040207</ErrorId>
<ManagedErrorName>unManagedidsinvaliduserid</ManagedErrorName>
<ErrorMessage>The user id is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_USERID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040206</ErrorId>
<ManagedErrorName>InvalidParentId</ManagedErrorName>
<ErrorMessage>The parent id is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PARENTID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040205</ErrorId>
<ManagedErrorName>InvalidParent</ManagedErrorName>
<ErrorMessage>The parent object is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PARENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040204</ErrorId>
<ManagedErrorName>InvalidUserAuth</ManagedErrorName>
<ErrorMessage>User does not have the privilege to act on behalf another user.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_USERAUTH</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040203</ErrorId>
<ManagedErrorName>InvalidArgument</ManagedErrorName>
<ErrorMessage>Invalid argument.</ErrorMessage>
<UnManagedErrorName>IDS_INVALIDARG</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040202</ErrorId>
<ManagedErrorName>EmptyXml</ManagedErrorName>
<ErrorMessage>Empty XML.</ErrorMessage>
<UnManagedErrorName>IDS_EMPTY_XML</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040201</ErrorId>
<ManagedErrorName>InvalidXml</ManagedErrorName>
<ErrorMessage>Invalid XML.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_XML</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040200</ErrorId>
<ManagedErrorName>RequiredFieldMissing</ManagedErrorName>
<ErrorMessage>Required field missing.</ErrorMessage>
<UnManagedErrorName>IDS_REQUIREDFIELDMISSING</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800401ff</ErrorId>
<ManagedErrorName>SearchTextLenExceeded</ManagedErrorName>
<ErrorMessage>Search Text Length Exceeded.</ErrorMessage>
<UnManagedErrorName>IDS_SEARCHTXTLENEXCEEDED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ff</ErrorId>
<ManagedErrorName>CannotAssignOfflineFilters</ManagedErrorName>
<ErrorMessage>Cannot assign offline filters</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>800404fe</ErrorId>
<ManagedErrorName>ArticleIsPublished</ManagedErrorName>
<ErrorMessage>The article cannot be updated or deleted because it is in published state</ErrorMessage>
<UnManagedErrorName>IDS_ARTICLE_IS_PUBLISHED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404fd</ErrorId>
<ManagedErrorName>InvalidArticleTemplateState</ManagedErrorName>
<ErrorMessage>The article template state is undefined</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ARTICLE_TEMPLATE_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404fc</ErrorId>
<ManagedErrorName>InvalidArticleStateTransition</ManagedErrorName>
<ErrorMessage>This article state transition is invalid because of the current state of the article</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ARTICLE_STATE_TRANSITION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404fb</ErrorId>
<ManagedErrorName>InvalidArticleState</ManagedErrorName>
<ErrorMessage>The article state is undefined</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ARTICLE_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404fa</ErrorId>
<ManagedErrorName>NullKBArticleTemplateId</ManagedErrorName>
<ErrorMessage>The kbarticletemplateid cannot be NULL</ErrorMessage>
<UnManagedErrorName>IDS_NULL_KB_ARTICLE_TEMPLATE_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f9</ErrorId>
<ManagedErrorName>NullArticleTemplateStructureXml</ManagedErrorName>
<ErrorMessage>The article template structurexml cannot be NULL</ErrorMessage>
<UnManagedErrorName>IDS_NULL_ARTICLE_TEMPLATE_STRUCTURE_XML</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f8</ErrorId>
<ManagedErrorName>NullArticleTemplateFormatXml</ManagedErrorName>
<ErrorMessage>The article template formatxml cannot be NULL</ErrorMessage>
<UnManagedErrorName>IDS_NULL_ARTICLE_TEMPLATE_FORMAT_XML</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f7</ErrorId>
<ManagedErrorName>NullArticleXml</ManagedErrorName>
<ErrorMessage>The article xml cannot be NULL</ErrorMessage>
<UnManagedErrorName>IDS_NULL_ARTICLE_XML</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f6</ErrorId>
<ManagedErrorName>InvalidContractDetailId</ManagedErrorName>
<ErrorMessage>The Contract detail id is invalid</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_CONTRACT_DETAIL_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f5</ErrorId>
<ManagedErrorName>InvalidTotalPrice</ManagedErrorName>
<ErrorMessage>The total price is invalid</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_TOTAL_PRICE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f4</ErrorId>
<ManagedErrorName>InvalidTotalDiscount</ManagedErrorName>
<ErrorMessage>The total discount is invalid</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_TOTAL_DISCOUNT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f3</ErrorId>
<ManagedErrorName>InvalidNetPrice</ManagedErrorName>
<ErrorMessage>The net price is invalid</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_NET_PRICE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f2</ErrorId>
<ManagedErrorName>InvalidAllotmentsRemaining</ManagedErrorName>
<ErrorMessage>The allotments remaining is invalid</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ALLOTMENTS_REMAINING</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f1</ErrorId>
<ManagedErrorName>InvalidAllotmentsUsed</ManagedErrorName>
<ErrorMessage>The allotments used is invalid</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ALLOTMENTS_USED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404f0</ErrorId>
<ManagedErrorName>InvalidAllotmentsTotal</ManagedErrorName>
<ErrorMessage>The total allotments is invalid</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ALLOTMENTS_TOTAL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ef</ErrorId>
<ManagedErrorName>InvalidAllotmentsCalc</ManagedErrorName>
<ErrorMessage>Allotments: remaining + used != total</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ALLOTMENTS_CALC</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004051b</ErrorId>
<ManagedErrorName>CannotRouteToSameQueue</ManagedErrorName>
<ErrorMessage>The queue item cannot be routed to the same queue</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_ROUTE_TO_SAMEQUEUE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004051c</ErrorId>
<ManagedErrorName>CannotAddSingleQueueEnabledEntityToQueue</ManagedErrorName>
<ErrorMessage>The entity record cannot be added to the queue as it already exists in other queue.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_ADD_SINGLE_Q_ENTITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004051d</ErrorId>
<ManagedErrorName>CannotUpdateDeactivatedQueueItem</ManagedErrorName>
<ErrorMessage>This item is deactivated. To work with this item, reactivate it and then try again.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_UPDATE_DEACTIVATED_QUEUEITEM</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004051e</ErrorId>
<ManagedErrorName>CannotCreateQueueItemInactiveObject</ManagedErrorName>
<ErrorMessage>Deactivated object cannot be added to queue.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_CREATE_QUEUEITEM_INACTIVE_OBJECT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80040520</ErrorId>
<ManagedErrorName>InsufficientPrivilegeToQueueOwner</ManagedErrorName>
<ErrorMessage>The owner of this queue does not have sufficient privileges to work with the queue.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040521</ErrorId>
<ManagedErrorName>NoPrivilegeToWorker</ManagedErrorName>
<ErrorMessage>You cannot add items to an inactive queue. Select another queue and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040522</ErrorId>
<ManagedErrorName>CannotAddQueueItemsToInactiveQueue</ManagedErrorName>
<ErrorMessage>The selected user does not have sufficient permissions to work on items in this queue.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040523</ErrorId>
<ManagedErrorName>EmailAlreadyExistsInDestinationQueue</ManagedErrorName>
<ErrorMessage>You cannot add this e-mail to the selected queue. A queue item for this e-mail already exists in the queue. You can delete the item from the queue, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040524</ErrorId>
<ManagedErrorName>CouldNotFindQueueItemInQueue</ManagedErrorName>
<ErrorMessage>Could not find any queue item associated with the Target in the specified SourceQueueId. Either the SourceQueueId or Target is invalid or the queue item does not exist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040525</ErrorId>
<ManagedErrorName>MultipleQueueItemsFound</ManagedErrorName>
<ErrorMessage>This item occurs in more than one queue and cannot be routed from this list. Locate the item in a queue and try to route the item again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040526</ErrorId>
<ManagedErrorName>ActiveQueueItemAlreadyExists</ManagedErrorName>
<ErrorMessage>An active queue item already exists for the given object. Cannot create more than one active queue item for this object.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040527</ErrorId>
<ManagedErrorName>CannotRouteInactiveQueueItem</ManagedErrorName>
<ErrorMessage>You can't route a queue item that has been deactivated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040528</ErrorId>
<ManagedErrorName>QueueIdNotPresent</ManagedErrorName>
<ErrorMessage>You must enter the target queue. Provide a valid value in the Queue field and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80040529</ErrorId>
<ManagedErrorName>QueueItemNotPresent</ManagedErrorName>
<ErrorMessage>You must enter the name of the record that you would like to put in the queue. Provide a valid value in the Queue Item field and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>800404ee</ErrorId>
<ManagedErrorName>CannotUpdatePrivateOrWIPQueue</ManagedErrorName>
<ErrorMessage>The private or WIP Bin queue is not allowed to be updated or deleted</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_UPDATE_PRIVATE_OR_QUEUE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ec</ErrorId>
<ManagedErrorName>CannotFindUserQueue</ManagedErrorName>
<ErrorMessage>Cannot find user queue</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_FIND_USER_QUEUE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404eb</ErrorId>
<ManagedErrorName>CannotFindObjectInQueue</ManagedErrorName>
<ErrorMessage>The object was not found in the given queue</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_FIND_OBJECT_IN_QUEUE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ea</ErrorId>
<ManagedErrorName>CannotRouteToQueue</ManagedErrorName>
<ErrorMessage>Cannot route to Work in progress queue</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_ROUTE_TO_QUEUE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404e9</ErrorId>
<ManagedErrorName>RouteTypeUnsupported</ManagedErrorName>
<ErrorMessage>The route type is unsupported</ErrorMessage>
<UnManagedErrorName>IDS_ROUTE_TYPE_UNSUPPORTED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404e8</ErrorId>
<ManagedErrorName>UserIdOrQueueNotSet</ManagedErrorName>
<ErrorMessage>Primary User Id or Destination Queue Type code not set</ErrorMessage>
<UnManagedErrorName>IDS_USER_ID_OR_QUEUE_NOT_SET</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404e7</ErrorId>
<ManagedErrorName>RoutingNotAllowed</ManagedErrorName>
<ErrorMessage>This object type can not be routed.</ErrorMessage>
<UnManagedErrorName>IDS_ROUTING_NOT_ALLOWED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044900</ErrorId>
<ManagedErrorName>CannotUpdateMetricOnChildGoal</ManagedErrorName>
<ErrorMessage>You cannot update metric on a child goal.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044901</ErrorId>
<ManagedErrorName>CannotUpdateGoalPeriodInfoChildGoal</ManagedErrorName>
<ErrorMessage>You cannot update goal period related attributes on a child goal.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044902</ErrorId>
<ManagedErrorName>CannotUpdateMetricOnGoalWithChildren</ManagedErrorName>
<ErrorMessage>You cannot update metric on a goal which has associated child goals.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044903</ErrorId>
<ManagedErrorName>FiscalPeriodGoalMissingInfo</ManagedErrorName>
<ErrorMessage>For a goal of fiscal period type, the fiscal period attribute must be set.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044904</ErrorId>
<ManagedErrorName>CustomPeriodGoalHavingExtraInfo</ManagedErrorName>
<ErrorMessage>For a goal of custom period type, fiscal year and fiscal period attributes must be left blank.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044905</ErrorId>
<ManagedErrorName>ParentChildMetricIdDiffers</ManagedErrorName>
<ErrorMessage>The metricid of child goal should be same as the parent goal.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044906</ErrorId>
<ManagedErrorName>ParentChildPeriodAttributesDiffer</ManagedErrorName>
<ErrorMessage>The period settings of child goal should be same as the parent goal.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044907</ErrorId>
<ManagedErrorName>CustomPeriodGoalMissingInfo</ManagedErrorName>
<ErrorMessage>For a goal of custom period type, goalstartdate and goalenddate attributes must have data.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044908</ErrorId>
<ManagedErrorName>GoalMissingPeriodTypeInfo</ManagedErrorName>
<ErrorMessage>Goal Period Type needs to be specified when creating a goal. This field cannot be null.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044909</ErrorId>
<ManagedErrorName>ParticipatingQueryEntityMismatch</ManagedErrorName>
<ErrorMessage>The entitytype of participating query should be the same as the entity specified in fetchxml.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044910</ErrorId>
<ManagedErrorName>CannotUpdateGoalPeriodInfoClosedGoal</ManagedErrorName>
<ErrorMessage>You cannot change the time period of this goal because there are one or more closed subordinate goals.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044911</ErrorId>
<ManagedErrorName>CannotUpdateRollupFields</ManagedErrorName>
<ErrorMessage>You cannot write on rollup fields if isoverride is not set to true in your create/update request.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044800</ErrorId>
<ManagedErrorName>CannotDeleteMetricWithGoals</ManagedErrorName>
<ErrorMessage>This goal metric is being used by one or more goals and cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044801</ErrorId>
<ManagedErrorName>CannotUpdateRollupAttributeWithClosedGoals</ManagedErrorName>
<ErrorMessage>The changes made to the roll-up field definition cannot be saved because the related goal metric is being used by one or more closed goals.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044802</ErrorId>
<ManagedErrorName>MetricNameAlreadyExists</ManagedErrorName>
<ErrorMessage>A goal metric with the same name already exists. Specify a different name, and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044803</ErrorId>
<ManagedErrorName>CannotUpdateMetricWithGoals</ManagedErrorName>
<ErrorMessage>The changes made to this record cannot be saved because this goal metric is being used by one or more goals.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044804</ErrorId>
<ManagedErrorName>CannotCreateUpdateSourceAttribute</ManagedErrorName>
<ErrorMessage>Source Attribute Not Valid For Create/Update if Metric Type is Count.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044805</ErrorId>
<ManagedErrorName>InvalidDateAttribute</ManagedErrorName>
<ErrorMessage>Date Attribute specified is not an attribute of Source Entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044806</ErrorId>
<ManagedErrorName>InvalidSourceEntityAttribute</ManagedErrorName>
<ErrorMessage>Attribute {0} is not an attribute of Entity {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044807</ErrorId>
<ManagedErrorName>GoalAttributeAlreadyMapped</ManagedErrorName>
<ErrorMessage>The Metric Detail for Specified Goal Attribute already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044808</ErrorId>
<ManagedErrorName>InvalidSourceAttributeType</ManagedErrorName>
<ErrorMessage>Source Attribute Type does not match the Amount Data Type specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004480a</ErrorId>
<ManagedErrorName>MaxLimitForRollupAttribute</ManagedErrorName>
<ErrorMessage>Only three metric details per metric can be created.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004480b</ErrorId>
<ManagedErrorName>InvalidGoalAttribute</ManagedErrorName>
<ErrorMessage>Goal Attribute does not match the specified metric type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004480c</ErrorId>
<ManagedErrorName>CannotUpdateParentAndDependents</ManagedErrorName>
<ErrorMessage>Cannot update metric or period attributes when parent is being updated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004480d</ErrorId>
<ManagedErrorName>UserDoesNotHaveSendAsAllowed</ManagedErrorName>
<ErrorMessage>User does not have send-as privilege</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004480e</ErrorId>
<ManagedErrorName>CannotUpdateQuoteCurrency</ManagedErrorName>
<ErrorMessage>The currency cannot be changed because this quote has Products associated with it. If you want to change the currency please delete all of the Products and then change the currency or create a new quote with the appropriate currency.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004480f</ErrorId>
<ManagedErrorName>UserDoesNotHaveSendAsForQueue</ManagedErrorName>
<ErrorMessage>You do not have sufficient privileges to send e-mail as the selected queue. Contact your system administrator for assistance.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044810</ErrorId>
<ManagedErrorName>InvalidSourceStateValue</ManagedErrorName>
<ErrorMessage>The source state specified for the entity is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044811</ErrorId>
<ManagedErrorName>InvalidSourceStatusValue</ManagedErrorName>
<ErrorMessage>The source status specified for the entity is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044812</ErrorId>
<ManagedErrorName>InvalidEntityForDateAttribute</ManagedErrorName>
<ErrorMessage>Entity For Date Attribute can be either source entity or its parent.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044813</ErrorId>
<ManagedErrorName>InvalidEntityForRollup</ManagedErrorName>
<ErrorMessage>The entity {0} is not a valid entity for rollup.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044814</ErrorId>
<ManagedErrorName>InvalidFiscalPeriod</ManagedErrorName>
<ErrorMessage>The fiscal period {0} does not fall in the permitted range of fiscal periods as per organization's fiscal settings.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>800404e6</ErrorId>
<ManagedErrorName>unManagedchildentityisnotchild</ManagedErrorName>
<ErrorMessage>The child entity supplied is not a child.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_CHILD_ENTITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404e5</ErrorId>
<ManagedErrorName>unManagedmissingparententity</ManagedErrorName>
<ErrorMessage>The parent entity could not be located.</ErrorMessage>
<UnManagedErrorName>IDS_PARENT_NOT_FOUND</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404e4</ErrorId>
<ManagedErrorName>unManagedunablegetexecutioncontext</ManagedErrorName>
<ErrorMessage>Failed to retrieve execution context (TLS).</ErrorMessage>
<UnManagedErrorName>IDS_UNEXPECTED_EXEC_CONTEXT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404e3</ErrorId>
<ManagedErrorName>unManagedpendingtrxexists</ManagedErrorName>
<ErrorMessage>A pending transaction already exists.</ErrorMessage>
<UnManagedErrorName>IDS_PENDING_TRX</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404e2</ErrorId>
<ManagedErrorName>unManagedinvalidtrxcountforcommit</ManagedErrorName>
<ErrorMessage>The transaction count was expected to be 1 in order to commit.</ErrorMessage>
<UnManagedErrorName>IDS_TRX_INVALID_COMMIT_COUNT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404e1</ErrorId>
<ManagedErrorName>unManagedinvalidtrxcountforrollback</ManagedErrorName>
<ErrorMessage>The transaction count was expected to be 1 in order to rollback.</ErrorMessage>
<UnManagedErrorName>IDS_TRX_INVALID_ROLLBACK_COUNT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404e0</ErrorId>
<ManagedErrorName>unManagedunableswitchusercontext</ManagedErrorName>
<ErrorMessage>Cannot set to a different user context.</ErrorMessage>
<UnManagedErrorName>IDS_CANNOT_SWITCH_USER_CONTEXT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404df</ErrorId>
<ManagedErrorName>unManagedmissingdataaccess</ManagedErrorName>
<ErrorMessage>The data access could not be retrieved from the ExecutionContext.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_DATA_ACCESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404de</ErrorId>
<ManagedErrorName>unManagedinvalidcharacterdataforaggregate</ManagedErrorName>
<ErrorMessage>Character data is not valid when clearing an aggregate.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_CHAR_DATA</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404dd</ErrorId>
<ManagedErrorName>unManagedtrxinterophandlerset</ManagedErrorName>
<ErrorMessage>The TrxInteropHandler has already been set.</ErrorMessage>
<UnManagedErrorName>IDS_TRXINTEROPHANDLER_SET</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404dc</ErrorId>
<ManagedErrorName>unManagedinvalidbinaryfield</ManagedErrorName>
<ErrorMessage>The platform cannot handle binary fields.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_BINARY_FIELD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404db</ErrorId>
<ManagedErrorName>unManagedinvaludidispatchfield</ManagedErrorName>
<ErrorMessage>The platform cannot handle idispatch fields.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_IDISPATCH_FIELD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404da</ErrorId>
<ManagedErrorName>unManagedinvaliddbdatefield</ManagedErrorName>
<ErrorMessage>The platform cannot handle dbdate fields.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_DBDATE_FIELD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404d9</ErrorId>
<ManagedErrorName>unManagedinvalddbtimefield</ManagedErrorName>
<ErrorMessage>The platform cannot handle dbtime fields.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_DBTIME_FIELD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404d8</ErrorId>
<ManagedErrorName>unManagedinvalidfieldtype</ManagedErrorName>
<ErrorMessage>The platform cannot handle the specified field type.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_FIELD_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404d7</ErrorId>
<ManagedErrorName>unManagedinvalidstreamfield</ManagedErrorName>
<ErrorMessage>The platform cannot handle stream fields.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_STREAM_FIELD</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404d6</ErrorId>
<ManagedErrorName>unManagedinvalidparametertypeforparameterizedquery</ManagedErrorName>
<ErrorMessage>A parameterized query is not supported for the supplied parameter type.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PARAMETER_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404d5</ErrorId>
<ManagedErrorName>unManagedinvaliddynamicparameteraccessor</ManagedErrorName>
<ErrorMessage>SetParam failed processing the DynamicParameterAccessor parameter.</ErrorMessage>
<UnManagedErrorName>IDS_FAILED_SETPARAM</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404d4</ErrorId>
<ManagedErrorName>unManagedunablegetsessiontokennotrx</ManagedErrorName>
<ErrorMessage>Unable to retrieve the session token as there are no pending transactions.</ErrorMessage>
<UnManagedErrorName>IDS_UNABLE_GET_SESSION_TOKEN_NO_TRX</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404d3</ErrorId>
<ManagedErrorName>unManagedunablegetsessiontoken</ManagedErrorName>
<ErrorMessage>Unable to retrieve the session token.</ErrorMessage>
<UnManagedErrorName>IDS_UNABLE_GET_SESSION_TOKEN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404d2</ErrorId>
<ManagedErrorName>unManagedinvalidsecurityprincipal</ManagedErrorName>
<ErrorMessage>The security principal is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PRINCIPAL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404d0</ErrorId>
<ManagedErrorName>unManagedmissingpreviousownertype</ManagedErrorName>
<ErrorMessage>Unable to determine the previous owner's type.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PREV_OWNER_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ce</ErrorId>
<ManagedErrorName>unManagedinvalidprivilegeid</ManagedErrorName>
<ErrorMessage>The privilege id is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PRIVILEGEID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404cd</ErrorId>
<ManagedErrorName>unManagedinvalidprivilegeusergroup</ManagedErrorName>
<ErrorMessage>The privilege user group id is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PRIVILEGEUSERGROUPID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404cc</ErrorId>
<ManagedErrorName>unManagedunexpectedpropertytype</ManagedErrorName>
<ErrorMessage>Unexpected type for the property.</ErrorMessage>
<UnManagedErrorName>IDS_UNEXPECTED_PROPERTY_TYPE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404cb</ErrorId>
<ManagedErrorName>unManagedmissingaddressentity</ManagedErrorName>
<ErrorMessage>The address entity could not be found.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_ADDRESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ca</ErrorId>
<ManagedErrorName>unManagederroraddingfiltertoqueryplan</ManagedErrorName>
<ErrorMessage>An error occurred adding a filter to the query plan.</ErrorMessage>
<UnManagedErrorName>IDS_UNEXPECTED_FILTER_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c9</ErrorId>
<ManagedErrorName>unManagedmissingreferencesfromrelationship</ManagedErrorName>
<ErrorMessage>Unable to access a relationship in an entity's ReferencesFrom collection.</ErrorMessage>
<UnManagedErrorName>IDS_UNEXPECTED_REL_ARRAY_ACCESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c8</ErrorId>
<ManagedErrorName>unManagedmissingreferencingattribute</ManagedErrorName>
<ErrorMessage>The relationship's ReferencingAttribute is missing or invalid.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_REFERENCING_ATTR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c7</ErrorId>
<ManagedErrorName>unManagedinvalidoperator</ManagedErrorName>
<ErrorMessage>The operator provided is not valid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_OPERATOR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c6</ErrorId>
<ManagedErrorName>unManagedunabletoaccessqueryplanfilter</ManagedErrorName>
<ErrorMessage>Unable to access a filter in the query plan.</ErrorMessage>
<UnManagedErrorName>IDS_ERROR_FILTER_ACCESS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c5</ErrorId>
<ManagedErrorName>unManagedmissingattributefortag</ManagedErrorName>
<ErrorMessage>An expected attribute was not found for the tag specified.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_ATTRIBUTE_FOR_TAG</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c4</ErrorId>
<ManagedErrorName>unManagederrorprocessingfilternodes</ManagedErrorName>
<ErrorMessage>An unexpected error occurred processing the filter nodes.</ErrorMessage>
<UnManagedErrorName>IDS_UNEXPECTED_FILTER_PROCESSING</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c3</ErrorId>
<ManagedErrorName>unManagedunabletolocateconditionfilter</ManagedErrorName>
<ErrorMessage>Unexpected error locating the filter for the condition.</ErrorMessage>
<UnManagedErrorName>IDS_UNEXPECTED_FILTER_CONDITION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c2</ErrorId>
<ManagedErrorName>unManagedinvalidpagevalue</ManagedErrorName>
<ErrorMessage>The page value is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PAGE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c1</ErrorId>
<ManagedErrorName>unManagedinvalidcountvalue</ManagedErrorName>
<ErrorMessage>The count value is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_COUNT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404c0</ErrorId>
<ManagedErrorName>unManagedinvalidversionvalue</ManagedErrorName>
<ErrorMessage>The version value is invalid or missing.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_VERSION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404bf</ErrorId>
<ManagedErrorName>unManagedinvalidvaluettagoutsideconditiontag</ManagedErrorName>
<ErrorMessage>A invalid value tag was found outside of it's condition tag.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_VALUE_CONDITION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404be</ErrorId>
<ManagedErrorName>unManagedinvalidorganizationid</ManagedErrorName>
<ErrorMessage>The organizationid is missing or invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ORG_ID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404bd</ErrorId>
<ManagedErrorName>unManagedinvalidowninguser</ManagedErrorName>
<ErrorMessage>The owninguser is mising or invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_OWNING_USER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404bc</ErrorId>
<ManagedErrorName>unManagedinvalidowningbusinessunitorbusinessunitid</ManagedErrorName>
<ErrorMessage>The owningbusinessunit or businessunitid is missing or invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_OWNING_OR_BUSUNITID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404bb</ErrorId>
<ManagedErrorName>unManagedinvalidprivilegeedepth</ManagedErrorName>
<ErrorMessage>Invalid privilege depth for user.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PRIV_DEPTH</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ba</ErrorId>
<ManagedErrorName>unManagedinvalidlinkobjects</ManagedErrorName>
<ErrorMessage>Invalid link entity, link to attribute, or link from attribute.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_LINK_OBJECTS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404b8</ErrorId>
<ManagedErrorName>unManagedpartylistattributenotsupported</ManagedErrorName>
<ErrorMessage>Attributes of type partylist are not supported.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ATTR_PARTYLIST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404b7</ErrorId>
<ManagedErrorName>unManagedinvalidargumentsforcondition</ManagedErrorName>
<ErrorMessage>An invalid number of arguments was supplied to a condition.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_CONDITION_ARGS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404b6</ErrorId>
<ManagedErrorName>unManagedunknownaggregateoperation</ManagedErrorName>
<ErrorMessage>An unknown aggregate operation was supplied.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_AGGREGATE_OP</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404b5</ErrorId>
<ManagedErrorName>unManagedmissingparentattributeonentity</ManagedErrorName>
<ErrorMessage>The parent attribute was not found on the expected entity.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_PARENT_ATTR_ON_ENTITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404b4</ErrorId>
<ManagedErrorName>unManagedinvalidprocesschildofcondition</ManagedErrorName>
<ErrorMessage>ProcessChildOfCondition was called with non-child-of condition.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_CHILDOF_COND</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404b3</ErrorId>
<ManagedErrorName>unManagedunexpectedrimarykey</ManagedErrorName>
<ErrorMessage>Primary key attribute was not as expected.</ErrorMessage>
<UnManagedErrorName>IDS_UNEXPECTED_PK</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404b2</ErrorId>
<ManagedErrorName>unManagedmissinglinkentity</ManagedErrorName>
<ErrorMessage>Unexpected error locating link entity.</ErrorMessage>
<UnManagedErrorName>IDS_UNEXPECTED_LINK_ENTITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404b1</ErrorId>
<ManagedErrorName>unManagedinvalidprocessliternalcondition</ManagedErrorName>
<ErrorMessage>ProcessLiteralCondition is only valid for use with Rollup queries.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ROLLUP_COND</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404b0</ErrorId>
<ManagedErrorName>unManagedemptyprocessliteralcondition</ManagedErrorName>
<ErrorMessage>No data specified for ProcessLiteralCondition.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PROCESSLITERALCOND</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404af</ErrorId>
<ManagedErrorName>unManagedunusablevariantdata</ManagedErrorName>
<ErrorMessage>Variant supplied contains data in an unusable format.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_VARIANTDATA</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ae</ErrorId>
<ManagedErrorName>unManagedfieldnotvalidatedbyplatform</ManagedErrorName>
<ErrorMessage>A field was not validated by the platform.</ErrorMessage>
<UnManagedErrorName>IDS_NOT_VALIDATED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ad</ErrorId>
<ManagedErrorName>unManagedmissingfilterattribute</ManagedErrorName>
<ErrorMessage>Missing filter attribute.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_FILTER_ATTR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ac</ErrorId>
<ManagedErrorName>unManagedinvalidequalityoperand</ManagedErrorName>
<ErrorMessage>Only QB_LITERAL is supported for equality operand.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_EQ_OP_LITERAL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404ab</ErrorId>
<ManagedErrorName>unManagedfilterindexoutofrange</ManagedErrorName>
<ErrorMessage>The filter index is out of range.</ErrorMessage>
<UnManagedErrorName>IDS_FILTER_INDEX_RANGE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404aa</ErrorId>
<ManagedErrorName>unManagedentityisnotintersect</ManagedErrorName>
<ErrorMessage>The entity is not an intersect entity.</ErrorMessage>
<UnManagedErrorName>IDS_NOT_INTERSECT_ENTITY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404a9</ErrorId>
<ManagedErrorName>unManagedcihldofconditionforoffilefilters</ManagedErrorName>
<ErrorMessage>Child-of condition is only allowed on offline filters.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_CHILDOF_COND_OFFLINE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404a8</ErrorId>
<ManagedErrorName>unManagedinvalidowningbusinessunit</ManagedErrorName>
<ErrorMessage>The owningbusinessunit is missing or invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_OWNINGBUSUNITID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404a7</ErrorId>
<ManagedErrorName>unManagedinvalidbusinessunitid</ManagedErrorName>
<ErrorMessage>The businessunitid is missing or invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_BUSUNITID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404a6</ErrorId>
<ManagedErrorName>unManagedmorethanonesortattribute</ManagedErrorName>
<ErrorMessage>More than one sort attributes were defined.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_SORT_ATTRIBUTE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404a5</ErrorId>
<ManagedErrorName>unManagedunabletoaccessqueryplan</ManagedErrorName>
<ErrorMessage>Unable to access the query plan.</ErrorMessage>
<UnManagedErrorName>IDS_UNABLE_ACCESS_QUERYPLAN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404a4</ErrorId>
<ManagedErrorName>unManagedparentattributenotfound</ManagedErrorName>
<ErrorMessage>The parent attribute was not found for the child attribute.</ErrorMessage>
<UnManagedErrorName>IDS_MISSING_PARENT_ATTR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404a2</ErrorId>
<ManagedErrorName>unManagedinvalidtlsmananger</ManagedErrorName>
<ErrorMessage>Failed to retrieve TLS Manager.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_TLSMNGR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404a1</ErrorId>
<ManagedErrorName>unManagedinvalidescapedxml</ManagedErrorName>
<ErrorMessage>Escaped xml size not as expected.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_ESCAPED_XML</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>800404a0</ErrorId>
<ManagedErrorName>unManagedunabletoretrieveprivileges</ManagedErrorName>
<ErrorMessage>Failed to retrieve privileges.</ErrorMessage>
<UnManagedErrorName>IDS_FAILED_RETRIEVE_PRIV</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004049f</ErrorId>
<ManagedErrorName>unManagedproxycreationfailed</ManagedErrorName>
<ErrorMessage>Cannot create an instance of managed proxy.</ErrorMessage>
<UnManagedErrorName>IDS_FAILED_CREATE_MANAGED_PROXY</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004049e</ErrorId>
<ManagedErrorName>unManagedinvalidprincipal</ManagedErrorName>
<ErrorMessage>The principal id is missing or invalid.</ErrorMessage>
<UnManagedErrorName>IDS_INVALID_PRINCIPALID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044152</ErrorId>
<ManagedErrorName>RestrictInheritedRole</ManagedErrorName>
<ErrorMessage>Inherited roles cannot be modified.</ErrorMessage>
<UnManagedErrorName>IDS_ROLES_RESTRICT_INHERITED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044153</ErrorId>
<ManagedErrorName>unManagedidsfetchbetweentext</ManagedErrorName>
<ErrorMessage>between, not-between, in, and not-in operators are not allowed on attributes of type text or ntext.</ErrorMessage>
<UnManagedErrorName>IDS_FETCHXML_BETWEEN_NOTEXT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044154</ErrorId>
<ManagedErrorName>unManagedidscantdisable</ManagedErrorName>
<ErrorMessage>The user cannot be disabled because they have workflow rules running under their context.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANT_DISABLE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044155</ErrorId>
<ManagedErrorName>CascadeInvalidLinkTypeTransition</ManagedErrorName>
<ErrorMessage>Invalid link type for system entity cascading actions.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044156</ErrorId>
<ManagedErrorName>InvalidOrgOwnedCascadeLinkType</ManagedErrorName>
<ErrorMessage>Cascade User-Owned is not a valid cascade link type for org-owned entity relationships.</ErrorMessage>
</crmerror>

<crmerror>
<ErrorId>80044161</ErrorId>
<ManagedErrorName>CallerCannotChangeOwnDomainName</ManagedErrorName>
<ErrorMessage>The caller cannot change their own domain name</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CALLER_CANNOT_CHANGE_OWN_DOMAIN_NAME</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044162</ErrorId>
<ManagedErrorName>AsyncOperationInvalidStateChange</ManagedErrorName>
<ErrorMessage>The target state could not be set because the state transition is not valid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044163</ErrorId>
<ManagedErrorName>AsyncOperationInvalidStateChangeUnexpected</ManagedErrorName>
<ErrorMessage>The target state could not be set because the state was changed by another process.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044164</ErrorId>
<ManagedErrorName>AsyncOperationMissingId</ManagedErrorName>
<ErrorMessage>The AsyncOperationId is required to do the update.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044165</ErrorId>
<ManagedErrorName>AsyncOperationInvalidStateChangeToComplete</ManagedErrorName>
<ErrorMessage>The target state could not be set to complete because the state transition is not valid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044166</ErrorId>
<ManagedErrorName>AsyncOperationInvalidStateChangeToReady</ManagedErrorName>
<ErrorMessage>The target state could not be set to ready because the state transition is not valid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044167</ErrorId>
<ManagedErrorName>AsyncOperationInvalidStateChangeToSuspended</ManagedErrorName>
<ErrorMessage>The target state could not be set to suspended because the state transition is not valid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044168</ErrorId>
<ManagedErrorName>AsyncOperationCannotUpdateNonrecurring</ManagedErrorName>
<ErrorMessage>Cannot update recurrence pattern for a job that is not recurring.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044169</ErrorId>
<ManagedErrorName>AsyncOperationCannotUpdateRecurring</ManagedErrorName>
<ErrorMessage>Cannot update recurrence pattern for a job type that is not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004416a</ErrorId>
<ManagedErrorName>AsyncOperationCannotDeleteUnlessCompleted</ManagedErrorName>
<ErrorMessage>Cannot delete async operation unless it is in Completed state.</ErrorMessage>
</crmerror>

<!--  8004416b - 80044191 is reserved for eventing framework and Sdk -->
<crmerror>
<ErrorId>8004416b</ErrorId>
<ManagedErrorName>SdkInvalidMessagePropertyName</ManagedErrorName>
<ErrorMessage>Message property name '{0}' is not valid on message {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004416c</ErrorId>
<ManagedErrorName>PluginAssemblyMustHavePublicKeyToken</ManagedErrorName>
<ErrorMessage>Public assembly must have public key token.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004416d</ErrorId>
<ManagedErrorName>SdkMessageInvalidImageTypeRegistration</ManagedErrorName>
<ErrorMessage>Message {0} does not support this image type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004416e</ErrorId>
<ManagedErrorName>SdkMessageDoesNotSupportPostImageRegistration</ManagedErrorName>
<ErrorMessage>PreEvent step registration does not support Post Image.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004416f</ErrorId>
<ManagedErrorName>CannotDeserializeRequest</ManagedErrorName>
<ErrorMessage>The SDK request could not be deserialized.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044170</ErrorId>
<ManagedErrorName>InvalidPluginRegistrationConfiguration</ManagedErrorName>
<ErrorMessage>The plug-in assembly registration configuration is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044171</ErrorId>
<ManagedErrorName>SandboxClientPluginTimeout</ManagedErrorName>
<ErrorMessage>The plug-in execution failed because the operation has timed-out at the Sandbox Client.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044172</ErrorId>
<ManagedErrorName>SandboxHostPluginTimeout</ManagedErrorName>
<ErrorMessage>The plug-in execution failed because the operation has timed-out at the Sandbox Host.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044173</ErrorId>
<ManagedErrorName>SandboxWorkerPluginTimeout</ManagedErrorName>
<ErrorMessage>The plug-in execution failed because the operation has timed-out at the Sandbox Worker.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044174</ErrorId>
<ManagedErrorName>SandboxSdkListenerStartFailed</ManagedErrorName>
<ErrorMessage>The plug-in execution failed because the Sandbox Client encountered an error during initialization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044175</ErrorId>
<ManagedErrorName>ServiceBusPostFailed</ManagedErrorName>
<ErrorMessage>The service bus post failed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044176</ErrorId>
<ManagedErrorName>ServiceBusIssuerNotFound</ManagedErrorName>
<ErrorMessage>Cannot find service integration issuer information.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044177</ErrorId>
<ManagedErrorName>ServiceBusIssuerCertificateError</ManagedErrorName>
<ErrorMessage>Service integration issuer certificate error.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044178</ErrorId>
<ManagedErrorName>ServiceBusExtendedTokenFailed</ManagedErrorName>
<ErrorMessage>Failed to retrieve the additional token for service bus post.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044179</ErrorId>
<ManagedErrorName>ServiceBusPostPostponed</ManagedErrorName>
<ErrorMessage>Service bus post is being postponed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004417A</ErrorId>
<ManagedErrorName>ServiceBusPostDisabled</ManagedErrorName>
<ErrorMessage>Service bus post is disabled for the organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044180</ErrorId>
<ManagedErrorName>SdkMessageNotSupportedOnServer</ManagedErrorName>
<ErrorMessage>The message requested is not supported on the server.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044181</ErrorId>
<ManagedErrorName>SdkMessageNotSupportedOnClient</ManagedErrorName>
<ErrorMessage>The message requested is not supported on the client.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044182</ErrorId>
<ManagedErrorName>SdkCorrelationTokenDepthTooHigh</ManagedErrorName>
<ErrorMessage>This workflow job was canceled because the workflow that started it included an infinite loop. Correct the workflow logic and try again. For information about workflow logic, see Help.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044184</ErrorId>
<ManagedErrorName>OnlyStepInPredefinedStagesCanBeModified</ManagedErrorName>
<ErrorMessage>Invalid plug-in registration stage. Steps can only be modified in stages BeforeMainOperationOutsideTransaction, BeforeMainOperationInsideTransaction, AfterMainOperationInsideTransaction and AfterMainOperationOutsideTransaction.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044185</ErrorId>
<ManagedErrorName>OnlyStepInServerOnlyCanHaveSecureConfiguration</ManagedErrorName>
<ErrorMessage>Only SdkMessageProcessingStep with ServerOnly supported deployment can have secure configuration.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044186</ErrorId>
<ManagedErrorName>OnlyStepOutsideTransactionCanCreateCrmService</ManagedErrorName>
<ErrorMessage>Only SdkMessageProcessingStep in parent pipeline and in stages outside transaction can create CrmService to prevent deadlock.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044187</ErrorId>
<ManagedErrorName>SdkCustomProcessingStepIsNotAllowed</ManagedErrorName>
<ErrorMessage>Custom SdkMessageProcessingStep is not allowed on the specified message and entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044188</ErrorId>
<ManagedErrorName>SdkEntityOfflineQueuePlaybackIsNotAllowed</ManagedErrorName>
<ErrorMessage>Entity '{0}' is not allowed in offline queue playback.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044189</ErrorId>
<ManagedErrorName>SdkMessageDoesNotSupportImageRegistration</ManagedErrorName>
<ErrorMessage>Message '{0}' does not support image registration.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004418a</ErrorId>
<ManagedErrorName>RequestLengthTooLarge</ManagedErrorName>
<ErrorMessage>Request message length is too large.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004418d</ErrorId>
<ManagedErrorName>SandboxWorkerNotAvailable</ManagedErrorName>
<ErrorMessage>The plug-in execution failed because no Sandbox Worker processes are currently available. Please try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004418e</ErrorId>
<ManagedErrorName>SandboxHostNotAvailable</ManagedErrorName>
<ErrorMessage>The plug-in execution failed because no Sandbox Hosts are currently available. Please check that you have a Sandbox server configured and that it is running.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004418f</ErrorId>
<ManagedErrorName>PluginAssemblyContentSizeExceeded</ManagedErrorName>
<ErrorMessage>"The assembly content size '{0} bytes' has exceeded the maximum value allowed for isolated plug-ins '{1} bytes'."</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044190</ErrorId>
<ManagedErrorName>UnableToLoadPluginType</ManagedErrorName>
<ErrorMessage>Unable to load plug-in type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044191</ErrorId>
<ManagedErrorName>UnableToLoadPluginAssembly</ManagedErrorName>
<ErrorMessage>Unable to load plug-in assembly.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004418b</ErrorId>
<ManagedErrorName>InvalidPluginAssemblyContent</ManagedErrorName>
<ErrorMessage>Plug-in assembly does not contain the required types or assembly content cannot be updated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004418c</ErrorId>
<ManagedErrorName>InvalidPluginTypeImplementation</ManagedErrorName>
<ErrorMessage>Plug-in type must implement exactly one of the following classes or interfaces: Microsoft.Crm.Sdk.IPlugin, Microsoft.Xrm.Sdk.IPlugin, System.Activities.Activity and System.Workflow.ComponentModel.Activity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004417B</ErrorId>
<ManagedErrorName>InvalidPluginAssemblyVersion</ManagedErrorName>
<ErrorMessage>Plug-in assembly fullnames must be unique (ignoring the version build and revision number).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004417C</ErrorId>
<ManagedErrorName>PluginTypeMustBeUnique</ManagedErrorName>
<ErrorMessage>Multiple plug-in types from the same assembly and with the same typename are not allowed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004417D</ErrorId>
<ManagedErrorName>InvalidAssemblySourceType</ManagedErrorName>
<ErrorMessage>The given plugin assembly source type is not supported for isolated plugin assemblies.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004417E</ErrorId>
<ManagedErrorName>InvalidAssemblyProcessorArchitecture</ManagedErrorName>
<ErrorMessage>The given plugin assembly was built with an unsupported target platform and cannot be loaded.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004417F</ErrorId>
<ManagedErrorName>CyclicReferencesNotSupported</ManagedErrorName>
<ErrorMessage>The input contains a cyclic reference, which is not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044183</ErrorId>
<ManagedErrorName>InvalidQuery</ManagedErrorName>
<ErrorMessage>The query specified for this operation is invalid</ErrorMessage>
</crmerror>

<!--  8004416b - 80044191 is reserved for eventing framework and Sdk -->
<crmerror>
<ErrorId>80044192</ErrorId>
<ManagedErrorName>InvalidEmailAddressFormat</ManagedErrorName>
<ErrorMessage>Invalid e-mail address. For more information, contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044193</ErrorId>
<ManagedErrorName>ContractInvalidDiscount</ManagedErrorName>
<ErrorMessage>Discount cannot be greater than total price.</ErrorMessage>
<UnManagedErrorName>IDS_CONTRACT_INVALIDDISCOUNT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80044195</ErrorId>
<ManagedErrorName>InvalidLanguageCode</ManagedErrorName>
<ErrorMessage>The specified language code is not valid for this organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044196</ErrorId>
<ManagedErrorName>ConfigNullPrimaryKey</ManagedErrorName>
<ErrorMessage>Primary Key cannot be nullable.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044197</ErrorId>
<ManagedErrorName>ConfigMissingDescription</ManagedErrorName>
<ErrorMessage>Description must be specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044198</ErrorId>
<ManagedErrorName>AttributeDoesNotSupportLocalizedLabels</ManagedErrorName>
<ErrorMessage>The specified attribute does not support localized labels.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044199</ErrorId>
<ManagedErrorName>NoLanguageProvisioned</ManagedErrorName>
<ErrorMessage>There is no language provisioned for this organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044246</ErrorId>
<ManagedErrorName>CannotImportNullStringsForBaseLanguage</ManagedErrorName>
<ErrorMessage>The base language translation string present in worksheet {0}, row {1}, column {2} is null.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044247</ErrorId>
<ManagedErrorName>CannotUpdateNonCustomizableString</ManagedErrorName>
<ErrorMessage>The translation string present in worksheet {0}, row {1}, column {2} is not customizable.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044248</ErrorId>
<ManagedErrorName>InvalidOrganizationId</ManagedErrorName>
<ErrorMessage>The Organization ID present in the translations file does not match the current Organization ID.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044249</ErrorId>
<ManagedErrorName>InvalidTranslationsFile</ManagedErrorName>
<ErrorMessage>The translations file is invalid or does not confirm to the required schema.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044250</ErrorId>
<ManagedErrorName>MetadataRecordNotDeletable</ManagedErrorName>
<ErrorMessage>The metadata record being deleted cannot be deleted by the end user</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044251</ErrorId>
<ManagedErrorName>InvalidImportJobTemplateFile</ManagedErrorName>
<ErrorMessage>The ImportJobTemplate.xml file is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044252</ErrorId>
<ManagedErrorName>InvalidImportJobId</ManagedErrorName>
<ErrorMessage>The requested importjob does not exist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044300</ErrorId>
<ManagedErrorName>MissingCrmAuthenticationToken</ManagedErrorName>
<ErrorMessage>CrmAuthenticationToken is missing.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044301</ErrorId>
<ManagedErrorName>IntegratedAuthenticationIsNotAllowed</ManagedErrorName>
<ErrorMessage>Integrated authentication is not allowed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044302</ErrorId>
<ManagedErrorName>RequestIsNotAuthenticated</ManagedErrorName>
<ErrorMessage>Request is not authenticated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044303</ErrorId>
<ManagedErrorName>AsyncOperationTypeIsNotRecognized</ManagedErrorName>
<ErrorMessage>The operation type of the async operation was not recognized.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044304</ErrorId>
<ManagedErrorName>FailedToDeserializeAsyncOperationData</ManagedErrorName>
<ErrorMessage>Failed to deserialize async operation data.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044305</ErrorId>
<ManagedErrorName>UserSettingsOverMaxPagingLimit</ManagedErrorName>
<ErrorMessage>Paging limit over maximum configured value.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044306</ErrorId>
<ManagedErrorName>AsyncNetworkError</ManagedErrorName>
<ErrorMessage>An error occurred while accessing the network.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044307</ErrorId>
<ManagedErrorName>AsyncCommunicationError</ManagedErrorName>
<ErrorMessage>A communication error occurred while processing the async operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044308</ErrorId>
<ManagedErrorName>MissingCrmAuthenticationTokenOrganizationName</ManagedErrorName>
<ErrorMessage>Organization Name must be specified in CrmAuthenticationToken.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044309</ErrorId>
<ManagedErrorName>SdkNotEnoughPrivilegeToSetCallerOriginToken</ManagedErrorName>
<ErrorMessage>Caller does not have enough privilege to set CallerOriginToken to the specified value.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004430A</ErrorId>
<ManagedErrorName>OverRetrievalUpperLimitWithoutPagingCookie</ManagedErrorName>
<ErrorMessage>Over upper limit of records that can be requested without a paging cookie. A paging cookie is required when retrieving a high page number.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004430B</ErrorId>
<ManagedErrorName>InvalidAllotmentsOverage</ManagedErrorName>
<ErrorMessage>Allotment overage is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004430C</ErrorId>
<ManagedErrorName>TooManyConditionsInQuery</ManagedErrorName>
<ErrorMessage>Number of conditions in query exceeded maximum limit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004430D</ErrorId>
<ManagedErrorName>TooManyLinkEntitiesInQuery</ManagedErrorName>
<ErrorMessage>Number of link entities in query exceeded maximum limit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004430E</ErrorId>
<ManagedErrorName>TooManyConditionParametersInQuery</ManagedErrorName>
<ErrorMessage>Number of parameters in a condition exceeded maximum limit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004430F</ErrorId>
<ManagedErrorName>InvalidOneToManyRelationshipForRelatedEntitiesQuery</ManagedErrorName>
<ErrorMessage>An invalid OneToManyRelationship has been specified for RelatedEntitiesQuery. Referenced Entity {0} should be the same as primary entity {1}</ErrorMessage>
</crmerror>

<crmerror>
<ErrorId>80044310</ErrorId>
<ManagedErrorName>PicklistValueNotUnique</ManagedErrorName>
<ErrorMessage>The picklist value already exists.  Picklist values must be unique.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044311</ErrorId>
<ManagedErrorName>UnableToLogOnUserFromUserNameAndPassword</ManagedErrorName>
<ErrorMessage>The specified user name and password can not logon.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004431A</ErrorId>
<ManagedErrorName>PicklistValueOutOfRange</ManagedErrorName>
<ErrorMessage>The picklist value is out of the range.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004431B</ErrorId>
<ManagedErrorName>WrongNumberOfBooleanOptions</ManagedErrorName>
<ErrorMessage>Boolean attributes must have exactly two option values.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004431C</ErrorId>
<ManagedErrorName>BooleanOptionOutOfRange</ManagedErrorName>
<ErrorMessage>Boolean attribute options must have a value of either 0 or 1.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004431D</ErrorId>
<ManagedErrorName>CannotAddNewBooleanValue</ManagedErrorName>
<ErrorMessage>You cannot add an option to a Boolean attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004431E</ErrorId>
<ManagedErrorName>CannotAddNewStateValue</ManagedErrorName>
<ErrorMessage>You cannot add state options to a State attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004431F</ErrorId>
<ManagedErrorName>NoMoreCustomOptionValuesExist</ManagedErrorName>
<ErrorMessage>All available custom option values have been used.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044320</ErrorId>
<ManagedErrorName>InsertOptionValueInvalidType</ManagedErrorName>
<ErrorMessage>You can add option values only to picklist and status attributes.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044321</ErrorId>
<ManagedErrorName>NewStatusRequiresAssociatedState</ManagedErrorName>
<ErrorMessage>The new status option must have an associated state value.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044322</ErrorId>
<ManagedErrorName>NewStatusHasInvalidState</ManagedErrorName>
<ErrorMessage>The state value that was provided for this new status option does not exist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044323</ErrorId>
<ManagedErrorName>CannotDeleteEnumOptionsFromAttributeType</ManagedErrorName>
<ErrorMessage>You can delete options only from picklist and status attributes.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044324</ErrorId>
<ManagedErrorName>OptionReorderArrayIncorrectLength</ManagedErrorName>
<ErrorMessage>The array of option values that were provided for reordering does not match the number of options for the attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044325</ErrorId>
<ManagedErrorName>ValueMissingInOptionOrderArray</ManagedErrorName>
<ErrorMessage>The options array is missing a value.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044327</ErrorId>
<ManagedErrorName>NavPaneOrderValueNotAllowed</ManagedErrorName>
<ErrorMessage>The provided nav pane order value is not allowed</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044328</ErrorId>
<ManagedErrorName>EntityRelationshipRoleCustomLabelsMissing</ManagedErrorName>
<ErrorMessage>Custom labels must be provided if an entity relationship role has a display option of UseCustomLabels</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044329</ErrorId>
<ManagedErrorName>NavPaneNotCustomizable</ManagedErrorName>
<ErrorMessage>The nav pane properties for this relationship are not customizable</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004432A</ErrorId>
<ManagedErrorName>EntityRelationshipSchemaNameRequired</ManagedErrorName>
<ErrorMessage>Entity relationships require a name</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004432B</ErrorId>
<ManagedErrorName>EntityRelationshipSchemaNameNotUnique</ManagedErrorName>
<ErrorMessage>A relationship with the specified name already exists. Please specify a unique name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004432C</ErrorId>
<ManagedErrorName>CustomReflexiveRelationshipNotAllowedForEntity</ManagedErrorName>
<ErrorMessage>This entity is not valid for a custom reflexive relationship</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004432D</ErrorId>
<ManagedErrorName>EntityCannotBeChildInCustomRelationship</ManagedErrorName>
<ErrorMessage>This entity is either not valid as a child in a custom parental relationship or is already a child in a parental relationship</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004432E</ErrorId>
<ManagedErrorName>ReferencedEntityHasLogicalPrimaryNameField</ManagedErrorName>
<ErrorMessage>This entity has a primary field that is logical and therefore cannot be the referenced entity in a one-to-many relationship</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004432F</ErrorId>
<ManagedErrorName>IntegerValueOutOfRange</ManagedErrorName>
<ErrorMessage>A validation error occurred. An integer provided is outside of the allowed values for this attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044330</ErrorId>
<ManagedErrorName>DecimalValueOutOfRange</ManagedErrorName>
<ErrorMessage>A validation error occurred. A decimal value provided is outside of the allowed values for this attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044331</ErrorId>
<ManagedErrorName>StringLengthTooLong</ManagedErrorName>
<ErrorMessage>A validation error occurred. A string value provided is too long.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044332</ErrorId>
<ManagedErrorName>EntityCannotParticipateInEntityAssociation</ManagedErrorName>
<ErrorMessage>This entity cannot participate in an entity association</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044333</ErrorId>
<ManagedErrorName>DataMigrationManagerUnknownProblem</ManagedErrorName>
<ErrorMessage>The Data Migration Manager encountered an unknown problem and cannot continue. To try again, restart the Data Migration Manager.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044334</ErrorId>
<ManagedErrorName>ImportOperationChildFailure</ManagedErrorName>
<ErrorMessage>One or more of the Import Child Jobs Failed</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044335</ErrorId>
<ManagedErrorName>AttributeDeprecated</ManagedErrorName>
<ErrorMessage>"Attribute '{0}' on entity '{1}' is deprecated."</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044336</ErrorId>
<ManagedErrorName>DataMigrationManagerMandatoryUpdatesNotInstalled</ManagedErrorName>
<ErrorMessage>First-time configuration of the Data Migration Manager has been canceled. You will not be able to use the Data Migration Manager until configuration is completed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044337</ErrorId>
<ManagedErrorName>ReferencedEntityMustHaveLookupView</ManagedErrorName>
<ErrorMessage>Referenced entities of a relationship must have a lookup view</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044338</ErrorId>
<ManagedErrorName>ReferencingEntityMustHaveAssociationView</ManagedErrorName>
<ErrorMessage>Referencing entities of a relationship must have an association view</ErrorMessage>
</crmerror>

<crmerror>
<ErrorId>80044339</ErrorId>
<ManagedErrorName>CouldNotObtainLockOnResource</ManagedErrorName>
<ErrorMessage>Database resource lock could not be obtained</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044340</ErrorId>
<ManagedErrorName>SourceAttributeHeaderTooBig</ManagedErrorName>
<ErrorMessage>Column headers must be 160 or fewer characters. Fix the column headers, and then run Data Migration Manager again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044341</ErrorId>
<ManagedErrorName>CannotDeleteDefaultStatusOption</ManagedErrorName>
<ErrorMessage>Default Status options cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044342</ErrorId>
<ManagedErrorName>CannotFindDomainAccount</ManagedErrorName>
<ErrorMessage>Invalid domain account</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044343</ErrorId>
<ManagedErrorName>CannotUpdateAppDefaultValueForStateAttribute</ManagedErrorName>
<ErrorMessage>The default value for a status (statecode) attribute cannot be updated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044344</ErrorId>
<ManagedErrorName>CannotUpdateAppDefaultValueForStatusAttribute</ManagedErrorName>
<ErrorMessage>The default value for a status reason (statuscode) attribute is not used. The default status reason is set in the associated status (statecode) attribute option.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044345</ErrorId>
<ManagedErrorName>InvalidOptionSetSchemaName</ManagedErrorName>
<ErrorMessage>An OptionSet with the specified name already exists. Please specify a unique name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044350</ErrorId>
<ManagedErrorName>ReferencingEntityCannotBeSolutionAware</ManagedErrorName>
<ErrorMessage>Referencing entities in a relationship cannot be a component in a solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044351</ErrorId>
<ManagedErrorName>ErrorInFieldWidthIncrease</ManagedErrorName>
<ErrorMessage>An error occurred while increasing the field width.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044352</ErrorId>
<ManagedErrorName>ExpiredVersionStamp</ManagedErrorName>
<ErrorMessage>Version stamp associated with the client has expired. Please perform a full sync.</ErrorMessage>
</crmerror>

<!-- Async Service specific error codes from 80044F00 to 80045000-->
<crmerror>
<ErrorId>80044F00</ErrorId>
<ManagedErrorName>AsyncOperationCannotCancel</ManagedErrorName>
<ErrorMessage>This system job cannot be canceled.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044F01</ErrorId>
<ManagedErrorName>AsyncOperationCannotPause</ManagedErrorName>
<ErrorMessage>This system job cannot be paused.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044F02</ErrorId>
<ManagedErrorName>CannotDeleteOrCancelSystemJobs</ManagedErrorName>
<ErrorMessage>You can't cancel or delete this system job because it's required by the system. You can only pause, resume, or postpone this job.</ErrorMessage>
</crmerror>
<!-- Workflow Error Codes are defined from 80045001 - 800450FF to distinguish them easily from other error codes.
-->
<crmerror>
<ErrorId>80045001</ErrorId>
<ManagedErrorName>WorkflowCompileFailure</ManagedErrorName>
<ErrorMessage>An error has occurred during compilation of the workflow.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045002</ErrorId>
<ManagedErrorName>UpdatePublishedWorkflowDefinition</ManagedErrorName>
<ErrorMessage>Cannot update a published workflow definition.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045003</ErrorId>
<ManagedErrorName>UpdateWorkflowActivation</ManagedErrorName>
<ErrorMessage>Cannot update a workflow activation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045004</ErrorId>
<ManagedErrorName>DeleteWorkflowActivation</ManagedErrorName>
<ErrorMessage>Cannot delete a workflow activation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045005</ErrorId>
<ManagedErrorName>DeleteWorkflowActivationWorkflowDependency</ManagedErrorName>
<ErrorMessage>Cannot delete a workflow dependency associated with a workflow activation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045006</ErrorId>
<ManagedErrorName>DeletePublishedWorkflowDefinitionWorkflowDependency</ManagedErrorName>
<ErrorMessage>Cannot delete a workflow dependency for a published workflow definition.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045007</ErrorId>
<ManagedErrorName>UpdateWorkflowActivationWorkflowDependency</ManagedErrorName>
<ErrorMessage>Cannot update a workflow dependency associated with a workflow activation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045008</ErrorId>
<ManagedErrorName>UpdatePublishedWorkflowDefinitionWorkflowDependency</ManagedErrorName>
<ErrorMessage>Cannot update a workflow dependency for a published workflow definition.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045009</ErrorId>
<ManagedErrorName>CreateWorkflowActivationWorkflowDependency</ManagedErrorName>
<ErrorMessage>Cannot create a workflow dependency associated with a workflow activation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004500A</ErrorId>
<ManagedErrorName>CreatePublishedWorkflowDefinitionWorkflowDependency</ManagedErrorName>
<ErrorMessage>Cannot create a workflow dependency for a published workflow definition.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004500B</ErrorId>
<ManagedErrorName>WorkflowPublishedByNonOwner</ManagedErrorName>
<ErrorMessage>The workflow cannot be published or unpublished by someone who is not its owner.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004500C</ErrorId>
<ManagedErrorName>PublishedWorkflowOwnershipChange</ManagedErrorName>
<ErrorMessage>A published workflow can only be assigned to the caller.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004500D</ErrorId>
<ManagedErrorName>OnlyWorkflowDefinitionOrTemplateCanBePublished</ManagedErrorName>
<ErrorMessage>Only workflow definition or draft workflow template can be published.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004500E</ErrorId>
<ManagedErrorName>OnlyWorkflowDefinitionOrTemplateCanBeUnpublished</ManagedErrorName>
<ErrorMessage>Only workflow definition or workflow template can be unpublished.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004500F</ErrorId>
<ManagedErrorName>DeleteWorkflowActiveDefinition</ManagedErrorName>
<ErrorMessage>Cannot delete an active workflow definition.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045010</ErrorId>
<ManagedErrorName>WorkflowConditionIncorrectUnaryOperatorFormation</ManagedErrorName>
<ErrorMessage>Incorrect formation of unary operator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045011</ErrorId>
<ManagedErrorName>WorkflowConditionIncorrectBinaryOperatorFormation</ManagedErrorName>
<ErrorMessage>Incorrect formation of binary operator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045012</ErrorId>
<ManagedErrorName>WorkflowConditionOperatorNotSupported</ManagedErrorName>
<ErrorMessage>Condition operator not supported for specified type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045013</ErrorId>
<ManagedErrorName>WorkflowConditionTypeNotSupport</ManagedErrorName>
<ErrorMessage>Invalid type specified on condition.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045014</ErrorId>
<ManagedErrorName>WorkflowValidationFailure</ManagedErrorName>
<ErrorMessage>Validation failed on the specified workflow.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045015</ErrorId>
<ManagedErrorName>PublishedWorkflowLimitForSkuReached</ManagedErrorName>
<ErrorMessage>This workflow cannot be published because your organization has reached its limit for the number of workflows that can be published at the same time. (There is no limit on the number of draft workflows.) You can publish this workflow by unpublishing a different workflow, or by upgrading your license to a license that supports more workflows.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045016</ErrorId>
<ManagedErrorName>NoPrivilegeToPublishWorkflow</ManagedErrorName>
<ErrorMessage>User does not have sufficient privileges to publish workflows.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045017</ErrorId>
<ManagedErrorName>WorkflowSystemPaused</ManagedErrorName>
<ErrorMessage>Workflow should be paused by system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045018</ErrorId>
<ManagedErrorName>WorkflowPublishNoActivationParameters</ManagedErrorName>
<ErrorMessage>Automatic workflow cannot be published if no activation parameters have been specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045019</ErrorId>
<ManagedErrorName>CreateWorkflowDependencyForPublishedTemplate</ManagedErrorName>
<ErrorMessage>Cannot create a workflow dependency for a published workflow template.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004501A</ErrorId>
<ManagedErrorName>DeleteActiveWorkflowTemplateDependency</ManagedErrorName>
<ErrorMessage>Cannot delete workflow dependency from a published workflow template .</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004501B</ErrorId>
<ManagedErrorName>UpdatePublishedWorkflowTemplate</ManagedErrorName>
<ErrorMessage>Cannot update a published workflow template.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004501C</ErrorId>
<ManagedErrorName>DeleteWorkflowActiveTemplate</ManagedErrorName>
<ErrorMessage>Cannot delete an active workflow template.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004501D</ErrorId>
<ManagedErrorName>CustomActivityInvalid</ManagedErrorName>
<ErrorMessage>Invalid custom activity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004501E</ErrorId>
<ManagedErrorName>PrimaryEntityInvalid</ManagedErrorName>
<ErrorMessage>Invalid primary entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004501F</ErrorId>
<ManagedErrorName>CannotDeserializeWorkflowInstance</ManagedErrorName>
<ErrorMessage>Workflow instance cannot be deserialized. A possible reason for this failure is a workflow referencing a custom activity that has been unregistered.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045020</ErrorId>
<ManagedErrorName>CannotDeserializeXamlWorkflow</ManagedErrorName>
<ErrorMessage>Xaml representing workflow cannot be deserialized into a DynamicActivity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004502C</ErrorId>
<ManagedErrorName>CannotDeleteCustomEntityUsedInWorkflow</ManagedErrorName>
<ErrorMessage>Cannot delete entity because it is used in a workflow.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004502D</ErrorId>
<ManagedErrorName>BulkMailOperationFailed</ManagedErrorName>
<ErrorMessage>The bulk e-mail job completed with {0} failures. The failures might be caused by missing e-mail addresses or because you do not have permission to send e-mail. To find records with missing e-mail addresses, use Advanced Find. If you need increased e-mail permissions, contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004502E</ErrorId>
<ManagedErrorName>WorkflowExpressionOperatorNotSupported</ManagedErrorName>
<ErrorMessage>Expression operator not supported for specified type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004502F</ErrorId>
<ManagedErrorName>ChildWorkflowNotFound</ManagedErrorName>
<ErrorMessage>This workflow cannot run because one or more child workflows it uses have not been published or have been deleted. Please check the child workflows and try running this workflow again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045030</ErrorId>
<ManagedErrorName>CannotDeleteAttributeUsedInWorkflow</ManagedErrorName>
<ErrorMessage>This attribute cannot be deleted because it is used in one or more workflows. Cancel any system jobs for workflows that use this attribute, then delete or modify any workflows that use the attribute, and then try to delete the attribute again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045031</ErrorId>
<ManagedErrorName>CannotLocateRecordForWorkflowActivity</ManagedErrorName>
<ErrorMessage>A record required by this workflow job could not be found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045032</ErrorId>
<ManagedErrorName>PublishWorkflowWhileActingOnBehalfOfAnotherUserError</ManagedErrorName>
<ErrorMessage>Publishing Workflows while acting on behalf of another user is not allowed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045033</ErrorId>
<ManagedErrorName>CannotDisableInternetMarketingUser</ManagedErrorName>
<ErrorMessage>You cannot disable the Internet Marketing Partner user. This user does not consume a user license and is not charged to your organization.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_DISABLE_INTERNETMARKETING_USER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045034</ErrorId>
<ManagedErrorName>CannotSetWindowsLiveIdForInternetMarketingUser</ManagedErrorName>
<ErrorMessage>You cannot change the Windows Live ID for the Internet Marketing Partner user. This user does not consume a user license and is not charged to your organization.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_CHANGE_WLID_OF_INTERNETMARKETING_USER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045035</ErrorId>
<ManagedErrorName>CannotChangeAccessModeForInternetMarketingUser</ManagedErrorName>
<ErrorMessage>Internet Marketing User is a system user. You cannot change its access mode.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_CHANGE_ACCESS_MODE_OF_INTERNETMARKETING_USER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045036</ErrorId>
<ManagedErrorName>CannotChangeInvitationStatusForInternetMarketingUser</ManagedErrorName>
<ErrorMessage>Internet Marketing User is a system user. You cannot change its invitation status.</ErrorMessage>
<UnManagedErrorName>IDS_BIZMGMT_CANNOT_CHANGE_INVITATION_STATUS_OF_INTERNETMARKETING_USER</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80045037</ErrorId>
<ManagedErrorName>UIDataGenerationFailed</ManagedErrorName>
<ErrorMessage>There was an error generating the UIData from XAML.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045038</ErrorId>
<ManagedErrorName>WorkflowReferencesInvalidActivity</ManagedErrorName>
<ErrorMessage>The workflow definition contains a step that references and invalid custom activity. Remove the invalid references and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045039</ErrorId>
<ManagedErrorName>PublishWorkflowWhileImpersonatingError</ManagedErrorName>
<ErrorMessage>Publishing Workflows while impersonating another user is not allowed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004503A</ErrorId>
<ManagedErrorName>ExchangeAutodiscoverError</ManagedErrorName>
<ErrorMessage>Autodiscover could not find the Exchange Web Services URL for the specified mailbox. Verify that the mailbox address and the credentials provided are correct and that Autodiscover is enabled and has been configured correctly.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045040</ErrorId>
<ManagedErrorName>NonCrmUIWorkflowsNotSupported</ManagedErrorName>
<ErrorMessage>This workflow cannot be created, updated or published because it was created outside the Microsoft Dynamics CRM Web application. Your organization does not allow this type of workflow.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045041</ErrorId>
<ManagedErrorName>NotEnoughPrivilegesForXamlWorkflows</ManagedErrorName>
<ErrorMessage>Not enough privileges to complete the operation. Only the deployment administrator can create or update workflows that are created outside the Microsoft Dynamics CRM Web application.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045042</ErrorId>
<ManagedErrorName>WorkflowAutomaticallyDeactivated</ManagedErrorName>
<ErrorMessage>The original workflow definition has been deactivated and replaced.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045043</ErrorId>
<ManagedErrorName>StepAutomaticallyDisabled</ManagedErrorName>
<ErrorMessage>The original sdkmessageprocessingstep has been disabled and replaced.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045044</ErrorId>
<ManagedErrorName>NonCrmUIInteractiveWorkflowNotSupported</ManagedErrorName>
<ErrorMessage>This interactive workflow cannot be created, updated or published because it was created outside the Microsoft Dynamics CRM Web application.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045045</ErrorId>
<ManagedErrorName>WorkflowActivityNotSupported</ManagedErrorName>
<ErrorMessage>This workflow cannot be created, updated or published because it's referring unsupported workflow step.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045046</ErrorId>
<ManagedErrorName>ExecuteNotOnDemandWorkflow</ManagedErrorName>
<ErrorMessage>Workflow must be marked as on-demand or child workflow.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045047</ErrorId>
<ManagedErrorName>ExecuteUnpublishedWorkflow</ManagedErrorName>
<ErrorMessage>Workflow must be in Published state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045048</ErrorId>
<ManagedErrorName>ChildWorkflowParameterMismatch</ManagedErrorName>
<ErrorMessage>This workflow cannot run because arguments provided by parent workflow does not match with the specified parameters in linked child workflow. Check the child workflow reference in parent workflow and try running this workflow again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045049</ErrorId>
<ManagedErrorName>InvalidProcessStateData</ManagedErrorName>
<ErrorMessage>ProcessState is not valid for given ProcessSession instance.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045050</ErrorId>
<ManagedErrorName>OutOfScopeSlug</ManagedErrorName>
<ErrorMessage>The data required to display the next dialog page cannot be found. To resolve this issue, contact the dialog owner or the system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80045051</ErrorId>
<ManagedErrorName>CustomWorkflowActivitiesNotSupported</ManagedErrorName>
<ErrorMessage>Custom Workflow Activities are not enabled.</ErrorMessage>
</crmerror>
<!-- SQL Governor Error Codes are defined from 8004A001 - 8004A0FF to distinguish them easily from other error codes.
-->
<crmerror>
<ErrorId>8004A001</ErrorId>
<ManagedErrorName>CrmSqlGovernorDatabaseRequestDenied</ManagedErrorName>
<ErrorMessage>The server is busy and the request was not completed. Try again later.</ErrorMessage>
</crmerror>

<!-- Pluggable Authentication Error Codes are defined from 8004A100 - 8004A1FF to distinguish them easily from other error codes.
-->
<crmerror>
<ErrorId>8004A100</ErrorId>
<ManagedErrorName>InvalidAuthTicket</ManagedErrorName>
<ErrorMessage>The ticket specified for authentication didn't pass validation</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A101</ErrorId>
<ManagedErrorName>ExpiredAuthTicket</ManagedErrorName>
<ErrorMessage>The ticket specified for authentication is expired</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A102</ErrorId>
<ManagedErrorName>BadAuthTicket</ManagedErrorName>
<ErrorMessage>The ticket specified for authentication is invalid</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A103</ErrorId>
<ManagedErrorName>InsufficientAuthTicket</ManagedErrorName>
<ErrorMessage>The ticket specified for authentication didn't meet policy</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A104</ErrorId>
<ManagedErrorName>OrganizationDisabled</ManagedErrorName>
<ErrorMessage>The CRM organization you are attempting to access is currently disabled.  Please contact your system administrator</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A105</ErrorId>
<ManagedErrorName>TamperedAuthTicket</ManagedErrorName>
<ErrorMessage>The ticket specified for authentication has been tampered with or invalidated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A106</ErrorId>
<ManagedErrorName>ExpiredKey</ManagedErrorName>
<ErrorMessage>The key specified to compute a hash value is expired, only active keys are valid.  Expired Key : {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A107</ErrorId>
<ManagedErrorName>ScaleGroupDisabled</ManagedErrorName>
<ErrorMessage>The specified scalegroup is disabled. Access to organizations in this scalegroup are not allowed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A108</ErrorId>
<ManagedErrorName>SupportLogOnExpired</ManagedErrorName>
<ErrorMessage>Support login is expired</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A109</ErrorId>
<ManagedErrorName>InvalidPartnerSolutionCustomizationProvider</ManagedErrorName>
<ErrorMessage>Invalid partner solution customization provider type</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A10a</ErrorId>
<ManagedErrorName>MultiplePartnerSecurityRoleWithSameInformation</ManagedErrorName>
<ErrorMessage>More than one security role found for partner user</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A10b</ErrorId>
<ManagedErrorName>MultiplePartnerUserWithSameInformation</ManagedErrorName>
<ErrorMessage>More than one partner user found with same information</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A10c</ErrorId>
<ManagedErrorName>MultipleRootBusinessUnit</ManagedErrorName>
<ErrorMessage>More than one root business unit found</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A10d</ErrorId>
<ManagedErrorName>CannotDeletePartnerWithPartnerSolutions</ManagedErrorName>
<ErrorMessage>Can not delete partner as one or more solutions are associated with it</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A10e</ErrorId>
<ManagedErrorName>CannotDeletePartnerSolutionWithOrganizations</ManagedErrorName>
<ErrorMessage>Can not delete partner solution as one or more organizations are associated with it</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A10f</ErrorId>
<ManagedErrorName>CannotProvisionPartnerSolution</ManagedErrorName>
<ErrorMessage>Can not provision partner solution as it is either already provisioned or going through provisioning.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A110</ErrorId>
<ManagedErrorName>CannotActOnBehalfOfAnotherUser</ManagedErrorName>
<ErrorMessage>User does not have the privilege to act on behalf another user.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A112</ErrorId>
<ManagedErrorName>SystemUserDisabled</ManagedErrorName>
<ErrorMessage>The system user was disabled therefore the ticket expired.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A113</ErrorId>
<ManagedErrorName>UserDoesNotHaveAdminOnlyModePermissions</ManagedErrorName>
<ErrorMessage>User does not have required privileges (or role membership) to access the org when it is in Admin Only mode.</ErrorMessage>
</crmerror>
<!-- Event Framework Error Codes are defined from 8004A200 - 8004A2FF to distinguish them easily from other error codes.
-->
<crmerror>
<ErrorId>8004A200</ErrorId>
<ManagedErrorName>PluginDoesNotImplementCorrectInterface</ManagedErrorName>
<ErrorMessage>The plug-in specified does not implement the required interface Microsoft.Xrm.Sdk.IPlugin or Microsoft.Crm.Sdk.IPlugin.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004A201</ErrorId>
<ManagedErrorName>CannotCreatePluginInstance</ManagedErrorName>
<ErrorMessage>Can not create instance of a plug-in. Verify that plug-in type is not defined as abstract and it has a public constructor supported by CRM SDK.</ErrorMessage>
</crmerror>
<!-- Crm Online Error Codes are defined from 8004B000-8004BFFF to distinguish them easily from other error codes.
-->
<crmerror>
<ErrorId>8004B000</ErrorId>
<ManagedErrorName>CrmLiveGenericError</ManagedErrorName>
<ErrorMessage>An error has occurred while processing your request.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B001</ErrorId>
<ManagedErrorName>CrmLiveOrganizationProvisioningFailed</ManagedErrorName>
<ErrorMessage>An error has occurred when provisioning the organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B002</ErrorId>
<ManagedErrorName>CrmLiveMissingActiveDirectoryGroup</ManagedErrorName>
<ErrorMessage>The specified Active Directory Group does not exist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B003</ErrorId>
<ManagedErrorName>CrmLiveInternalProvisioningError</ManagedErrorName>
<ErrorMessage>An unexpected error happened in the provisioning system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B004</ErrorId>
<ManagedErrorName>CrmLiveQueueItemDoesNotExist</ManagedErrorName>
<ErrorMessage>The specified queue item does not exist in the queue. It may have been deleted or its ID may not have been specified correctly</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B005</ErrorId>
<ManagedErrorName>CrmLiveInvalidSetupParameter</ManagedErrorName>
<ErrorMessage>The parameter to CRM Online Setup is incorrect or not specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B006</ErrorId>
<ManagedErrorName>CrmLiveMultipleWitnessServersInScaleGroup</ManagedErrorName>
<ErrorMessage>The ScaleGroup has multiple witness servers specified. There should be only 1 witness server in a scale group.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B007</ErrorId>
<ManagedErrorName>CrmLiveMissingServerRolesInScaleGroup</ManagedErrorName>
<ErrorMessage>The scalegroup is missing some required server roles. 1 Witness Server and 2 Sql Servers are required for Provisioning.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B008</ErrorId>
<ManagedErrorName>CrmLiveServerCannotHaveWitnessAndDataServerRoles</ManagedErrorName>
<ErrorMessage>A server cannot have both Witness and Data Server Roles.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B009</ErrorId>
<ManagedErrorName>IsNotLiveToSendInvitation</ManagedErrorName>
<ErrorMessage>This functionality is not supported, its only available for Online solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B00A</ErrorId>
<ManagedErrorName>MissingOrganizationFriendlyName</ManagedErrorName>
<ErrorMessage>Cannot install CRM without an organization friendly name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B00B</ErrorId>
<ManagedErrorName>MissingOrganizationUniqueName</ManagedErrorName>
<ErrorMessage>Cannot install CRM without an organization unique name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B00C</ErrorId>
<ManagedErrorName>OfferingCategoryAndTokenNull</ManagedErrorName>
<ErrorMessage>Offer category and Billing Token are both missing, but at least one is required.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B00D</ErrorId>
<ManagedErrorName>OfferingIdNotSupported</ManagedErrorName>
<ErrorMessage>This version does not support search for offering id.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B00E</ErrorId>
<ManagedErrorName>OrganizationTakenByYou</ManagedErrorName>
<ErrorMessage>The organization {0} is already purchased by you.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B00F</ErrorId>
<ManagedErrorName>OrganizationTakenBySomeoneElse</ManagedErrorName>
<ErrorMessage>The organization {0} is already purchased by another customer.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B010</ErrorId>
<ManagedErrorName>InvalidTemplate</ManagedErrorName>
<ErrorMessage>The Invitation Email template is not valid</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B011</ErrorId>
<ManagedErrorName>InvalidUserQuota</ManagedErrorName>
<ErrorMessage>You have reached the maximum number of user quota</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B012</ErrorId>
<ManagedErrorName>InvalidRole</ManagedErrorName>
<ErrorMessage>You have not assigned roles to this user</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B013</ErrorId>
<ManagedErrorName>ErrorGeneratingInvitation</ManagedErrorName>
<ErrorMessage>Some Internal error occurred in generating invitation token, Please try again later</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B014</ErrorId>
<ManagedErrorName>CrmLiveOrganizationUpgradeFailed</ManagedErrorName>
<ErrorMessage>Upgrade Of Crm Organization Failed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B015</ErrorId>
<ManagedErrorName>UnableToSendEmail</ManagedErrorName>
<ErrorMessage>Some Internal error occurred in sending invitation, Please try again later</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B016</ErrorId>
<ManagedErrorName>InvalidEmail</ManagedErrorName>
<ErrorMessage>Email generated from the template is not valid</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B020</ErrorId>
<ManagedErrorName>VersionMismatch</ManagedErrorName>
<ErrorMessage>Unsupported version - This is {0} version {1}, but version {2} was requested.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B021</ErrorId>
<ManagedErrorName>MissingParameterToMethod</ManagedErrorName>
<ErrorMessage>Missing parameter {0} to method {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B022</ErrorId>
<ManagedErrorName>InvalidValueForCountryCode</ManagedErrorName>
<ErrorMessage>Account Country/Region code must not be {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B023</ErrorId>
<ManagedErrorName>InvalidValueForCurrency</ManagedErrorName>
<ErrorMessage>Account currency code must not be {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B024</ErrorId>
<ManagedErrorName>InvalidValueForLocale</ManagedErrorName>
<ErrorMessage>Account locale code must not be {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B025</ErrorId>
<ManagedErrorName>CrmLiveSupportOrganizationExistsInScaleGroup</ManagedErrorName>
<ErrorMessage>Only one support organization is allowed in a scalegroup.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B026</ErrorId>
<ManagedErrorName>CrmLiveMonitoringOrganizationExistsInScaleGroup</ManagedErrorName>
<ErrorMessage>Only one monitoring organization is allowed in a scalegroup.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B027</ErrorId>
<ManagedErrorName>InvalidUserLicenseCount</ManagedErrorName>
<ErrorMessage>Cannot purchase {0} user licenses for the Offering {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B028</ErrorId>
<ManagedErrorName>MissingColumn</ManagedErrorName>
<ErrorMessage>The property bag is missing an entry for {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B029</ErrorId>
<ManagedErrorName>InvalidResourceType</ManagedErrorName>
<ErrorMessage>The requested action is not valid for resource type {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B02A</ErrorId>
<ManagedErrorName>InvalidMinimumResourceLimit</ManagedErrorName>
<ErrorMessage>The resource type {0} cannot have a minimum limit of {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B02B</ErrorId>
<ManagedErrorName>InvalidMaximumResourceLimit</ManagedErrorName>
<ErrorMessage>The resource type {0} cannot have a maximum limit of {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B02C</ErrorId>
<ManagedErrorName>ConflictingProvisionTypes</ManagedErrorName>
<ErrorMessage>The service component {0} has conflicting provision types.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B02D</ErrorId>
<ManagedErrorName>InvalidAmountProvided</ManagedErrorName>
<ErrorMessage>The service component {0} cannot have a provide {1} of resource type {2}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B02E</ErrorId>
<ManagedErrorName>CrmLiveOrganizationDeleteFailed</ManagedErrorName>
<ErrorMessage>An error has occurred when deleting the organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B02F</ErrorId>
<ManagedErrorName>OnlyDisabledOrganizationCanBeDeleted</ManagedErrorName>
<ErrorMessage>Can not delete enabled organization. Organization must be disabled before it can be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B030</ErrorId>
<ManagedErrorName>CrmLiveOrganizationDetailsNotFound</ManagedErrorName>
<ErrorMessage>Unable to find organization details.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B031</ErrorId>
<ManagedErrorName>CrmLiveOrganizationFriendlyNameTooShort</ManagedErrorName>
<ErrorMessage>The organization name provided is too short.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B032</ErrorId>
<ManagedErrorName>CrmLiveOrganizationFriendlyNameTooLong</ManagedErrorName>
<ErrorMessage>The organization name provided is too long.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B033</ErrorId>
<ManagedErrorName>CrmLiveOrganizationUniqueNameTooShort</ManagedErrorName>
<ErrorMessage>The unique name provided is too short.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B034</ErrorId>
<ManagedErrorName>CrmLiveOrganizationUniqueNameTooLong</ManagedErrorName>
<ErrorMessage>The unique name provided is too long.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B035</ErrorId>
<ManagedErrorName>CrmLiveOrganizationUniqueNameInvalid</ManagedErrorName>
<ErrorMessage>The unique name provided is not valid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B036</ErrorId>
<ManagedErrorName>CrmLiveOrganizationUniqueNameReserved</ManagedErrorName>
<ErrorMessage>The unique name is already reserved.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B037</ErrorId>
<ManagedErrorName>ValueParsingError</ManagedErrorName>
<ErrorMessage>Error parsing parameter {0} of type {1} with value {2}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B038</ErrorId>
<ManagedErrorName>InvalidGranularityValue</ManagedErrorName>
<ErrorMessage>The Granularity column value is incorrect. Each rule part must be a name-value pair separated by an equal sign (=). For example: FREQ=Minutes;INTERVAL=15</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B039</ErrorId>
<ManagedErrorName>CrmLiveInvalidQueueItemSchedule</ManagedErrorName>
<ErrorMessage>The QueueItem has an invalid schedule of start time {0} and end time {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B040</ErrorId>
<ManagedErrorName>CrmLiveQueueItemTimeInPast</ManagedErrorName>
<ErrorMessage>A QueueItem cannot be scheduled to start or end in the past.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B041</ErrorId>
<ManagedErrorName>CrmLiveUnknownSku</ManagedErrorName>
<ErrorMessage>This Sku specified is not valid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004b042</ErrorId>
<ManagedErrorName>ExceedCustomEntityQuota</ManagedErrorName>
<ErrorMessage>The custom entity limit has been reached.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004b043</ErrorId>
<ManagedErrorName>ImportWillExceedCustomEntityQuota</ManagedErrorName>
<ErrorMessage>This import process is trying to import {0} new custom entities. This would exceed the custom entity limits for this organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B044</ErrorId>
<ManagedErrorName>OrganizationMigrationUnderway</ManagedErrorName>
<ErrorMessage>Organization migration is already underway.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B045</ErrorId>
<ManagedErrorName>CrmLiveInvoicingAccountIdMissing</ManagedErrorName>
<ErrorMessage>Invoicing Account Number (SAP Id) cannot be empty for an invoicing sku.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B046</ErrorId>
<ManagedErrorName>CrmLiveDuplicateWindowsLiveId</ManagedErrorName>
<ErrorMessage>A user with this username already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B047</ErrorId>
<ManagedErrorName>CrmLiveDnsDomainNotFound</ManagedErrorName>
<ErrorMessage>Domain was not found in the DNS table.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B048</ErrorId>
<ManagedErrorName>CrmLiveDnsDomainAlreadyExists</ManagedErrorName>
<ErrorMessage>Domain already exists in the DNS table.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B049</ErrorId>
<ManagedErrorName>InvalidInteractiveUserQuota</ManagedErrorName>
<ErrorMessage>You have reached the maximum number of interactive/full users.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B050</ErrorId>
<ManagedErrorName>InvalidNonInteractiveUserQuota</ManagedErrorName>
<ErrorMessage>You have reached the maximum number of non-interactive users/</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B051</ErrorId>
<ManagedErrorName>CrmLiveCannotFindExternalMessageProvider</ManagedErrorName>
<ErrorMessage>External Message Provider could not be located for queue item type of: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B052</ErrorId>
<ManagedErrorName>CrmLiveInvalidExternalMessageData</ManagedErrorName>
<ErrorMessage>External Message Data has some invalid data.  Data: {0} External Message: {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B053</ErrorId>
<ManagedErrorName>CrmLiveOrganizationEnableFailed</ManagedErrorName>
<ErrorMessage>Enabling Organization Failed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B054</ErrorId>
<ManagedErrorName>CrmLiveOrganizationDisableFailed</ManagedErrorName>
<ErrorMessage>Disabling Organization Failed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B055</ErrorId>
<ManagedErrorName>CrmLiveAddOnUnexpectedError</ManagedErrorName>
<ErrorMessage>There was an error contacting the billing system.  Your request cannot be processed at this time.  No changes have been made to your account.  Close this wizard, and try again later.  If the problem persists, please contact our sales organization at 1-877-CRM-CHOICE (276-2464).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B056</ErrorId>
<ManagedErrorName>CrmLiveAddOnAddLicenseLimitReached</ManagedErrorName>
<ErrorMessage>Your subscription has the maximum number of user licenses available.  For additional licenses, please contact our sales organization at 1-877-CRM-CHOICE (276-2464).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B057</ErrorId>
<ManagedErrorName>CrmLiveAddOnAddStorageLimitReached</ManagedErrorName>
<ErrorMessage>Your subscription has the maximum amount of storage available.  For additional storage, please contact our sales organization at 1-877-CRM-CHOICE (276-2464).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B058</ErrorId>
<ManagedErrorName>CrmLiveAddOnRemoveStorageLimitReached</ManagedErrorName>
<ErrorMessage>Your organization has the minimum amount of storage allowed.  You can remove only storage that has been added to your organization, and  is not being used.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B059</ErrorId>
<ManagedErrorName>CrmLiveAddOnOrgInNoUpdateMode</ManagedErrorName>
<ErrorMessage>Your changes cannot be processed at this time. Your organization is currently being updated.  No changes have been made to your account.  Close this wizard, and try again later.  If the problem persists, please contact our sales organization at 1-877-CRM-CHOICE (276-2464).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B05A</ErrorId>
<ManagedErrorName>CrmLiveUnknownCategory</ManagedErrorName>
<ErrorMessage>This Category specified is not valid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B05B</ErrorId>
<ManagedErrorName>CrmLiveInvalidInvoicingAccountNumber</ManagedErrorName>
<ErrorMessage>This Invoicing Account Number is not valid because it contains an invalid character.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B05C</ErrorId>
<ManagedErrorName>CrmLiveAddOnDataChanged</ManagedErrorName>
<ErrorMessage>Due to recent changes you have made to your account, these changes cannot be made at this time.   Close this wizard, and try again later.  If the problem persists, please contact our sales organization at 1-877-CRM-CHOICE (276-2464).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B05D</ErrorId>
<ManagedErrorName>CrmLiveInvalidEmail</ManagedErrorName>
<ErrorMessage>Invalid email address entered.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B05E</ErrorId>
<ManagedErrorName>CrmLiveInvalidPhone</ManagedErrorName>
<ErrorMessage>Invalid phone number entered.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B05F</ErrorId>
<ManagedErrorName>CrmLiveInvalidZipCode</ManagedErrorName>
<ErrorMessage>Invalid zip code entered.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B060</ErrorId>
<ManagedErrorName>InvalidAmountFreeResourceLimit</ManagedErrorName>
<ErrorMessage>The resource type {0} cannot have an amount free value of {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B061</ErrorId>
<ManagedErrorName>InvalidToken</ManagedErrorName>
<ErrorMessage>The token is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B062</ErrorId>
<ManagedErrorName>CrmLiveRegisterCustomCodeDisabled</ManagedErrorName>
<ErrorMessage>Registration of custom code feature for this organization is disabled.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B063</ErrorId>
<ManagedErrorName>CrmLiveExecuteCustomCodeDisabled</ManagedErrorName>
<ErrorMessage>Execution of custom code feature for this organization is disabled.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B064</ErrorId>
<ManagedErrorName>CrmLiveInvalidTaxId</ManagedErrorName>
<ErrorMessage>Invalid TaxId entered.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B065</ErrorId>
<ManagedErrorName>DatacenterNotAvailable</ManagedErrorName>
<ErrorMessage>This datacenter endpoint is not currently available for this organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B066</ErrorId>
<ManagedErrorName>ErrorConnectingToDiscoveryService</ManagedErrorName>
<ErrorMessage>Error when trying to connect to customer's discovery service.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B067</ErrorId>
<ManagedErrorName>OrgDoesNotExistInDiscoveryService</ManagedErrorName>
<ErrorMessage>Organization not found in customer's discovery service</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B068</ErrorId>
<ManagedErrorName>ErrorConnectingToOrganizationService</ManagedErrorName>
<ErrorMessage>Error when trying to connect to customer's organization service.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B069</ErrorId>
<ManagedErrorName>UserIsNotSystemAdminInOrganization</ManagedErrorName>
<ErrorMessage>Current user is not a system admin in customer's organization</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B070</ErrorId>
<ManagedErrorName>MobileServiceError</ManagedErrorName>
<ErrorMessage>Error communicating with mobile service</ErrorMessage>
</crmerror>

<!-- CRM Online Platform Email Service from 8004B520 - 8004B524 -->
<crmerror>
<ErrorId>8005B520</ErrorId>
<ManagedErrorName>LivePlatformGeneralEmailError</ManagedErrorName>
<ErrorMessage>An Email Error Occurred</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B521</ErrorId>
<ManagedErrorName>LivePlatformEmailInvalidTo</ManagedErrorName>
<ErrorMessage>The "To" parameter is blank or null</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B522</ErrorId>
<ManagedErrorName>LivePlatformEmailInvalidFrom</ManagedErrorName>
<ErrorMessage>The "From" parameter is blank or null</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B523</ErrorId>
<ManagedErrorName>LivePlatformEmailInvalidSubject</ManagedErrorName>
<ErrorMessage>The "Subject" parameter is blank or null</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B524</ErrorId>
<ManagedErrorName>LivePlatformEmailInvalidBody</ManagedErrorName>
<ErrorMessage>The "Body" parameter is blank or null</ErrorMessage>
</crmerror>

<!-- CRM Online Billing from 8004B530 - 8004B53F -->
<crmerror>
<ErrorId>8004B530</ErrorId>
<ManagedErrorName>BillingPartnerCertificate</ManagedErrorName>
<ErrorMessage>Could not determine the right Partner certificate to use with Billing.  Issuer: {0}  Subject: {1}  Distinguished matches: [{2}]  Name matches: [{3}]  All valid certificates: [{4}].</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B531</ErrorId>
<ManagedErrorName>BillingNoSettingError</ManagedErrorName>
<ErrorMessage>No Billing application configuration setting [{0}] was found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B532</ErrorId>
<ManagedErrorName>BillingTestConnectionError</ManagedErrorName>
<ErrorMessage>Billing is not available: Call to IsServiceAvailable returned 'False'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B533</ErrorId>
<ManagedErrorName>BillingTestConnectionException</ManagedErrorName>
<ErrorMessage>Billing TestConnection exception.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B534</ErrorId>
<ManagedErrorName>BillingUserPuidNullError</ManagedErrorName>
<ErrorMessage>User Puid is required, but is null.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B535</ErrorId>
<ManagedErrorName>BillingUnmappedErrorCode</ManagedErrorName>
<ErrorMessage>Billing error code [{0}] was thrown with exception {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B536</ErrorId>
<ManagedErrorName>BillingUnknownErrorCode</ManagedErrorName>
<ErrorMessage>Billing error code [{0}] was thrown with exception {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B537</ErrorId>
<ManagedErrorName>BillingUnknownException</ManagedErrorName>
<ErrorMessage>Billing error was thrown with exception {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B538</ErrorId>
<ManagedErrorName>BillingRetrieveKeyError</ManagedErrorName>
<ErrorMessage>Could not retrieve Billing session key: "{0}"</ErrorMessage>
</crmerror>

<!-- BDK API errors 8004B540 - 8004B5BF -->
<crmerror>
<ErrorId>8004B540</ErrorId>
<ManagedErrorName>BDK_E_ADDRESS_VALIDATION_FAILURE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B541</ErrorId>
<ManagedErrorName>BDK_E_AGREEMENT_ALREADY_SIGNED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B542</ErrorId>
<ManagedErrorName>BDK_E_AUTHORIZATION_FAILED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B543</ErrorId>
<ManagedErrorName>BDK_E_AVS_FAILED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B544</ErrorId>
<ManagedErrorName>BDK_E_BAD_CITYNAME_LENGTH</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B545</ErrorId>
<ManagedErrorName>BDK_E_BAD_STATECODE_LENGTH</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B546</ErrorId>
<ManagedErrorName>BDK_E_BAD_ZIPCODE_LENGTH</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B547</ErrorId>
<ManagedErrorName>BDK_E_BADXML</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B548</ErrorId>
<ManagedErrorName>BDK_E_BANNED_PAYMENT_INSTRUMENT</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B549</ErrorId>
<ManagedErrorName>BDK_E_BANNEDPERSON</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B54A</ErrorId>
<ManagedErrorName>BDK_E_CANNOT_EXCEED_MAX_OWNERSHIP</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B54B</ErrorId>
<ManagedErrorName>BDK_E_COUNTRY_CURRENCY_PI_MISMATCH</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B54C</ErrorId>
<ManagedErrorName>BDK_E_CREDIT_CARD_EXPIRED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B54D</ErrorId>
<ManagedErrorName>BDK_E_DATE_EXPIRED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B54E</ErrorId>
<ManagedErrorName>BDK_E_ERROR_COUNTRYCODE_MISMATCH</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B54F</ErrorId>
<ManagedErrorName>BDK_E_ERROR_COUNTRYCODE_REQUIRED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B550</ErrorId>
<ManagedErrorName>BDK_E_EXTRA_REFERRAL_DATA</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B551</ErrorId>
<ManagedErrorName>BDK_E_GUID_EXISTS</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B552</ErrorId>
<ManagedErrorName>BDK_E_INVALID_ADDRESS_ID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B553</ErrorId>
<ManagedErrorName>BDK_E_INVALID_BILLABLE_ACCOUNT_ID</ManagedErrorName>
<ErrorMessage>{0}  The specified Billing account is invalid.  Or, although the objectID is of the correct type, the account it identifies does not exist in the system.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B554</ErrorId>
<ManagedErrorName>BDK_E_INVALID_BUF_SIZE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B555</ErrorId>
<ManagedErrorName>BDK_E_INVALID_CATEGORY_NAME</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B556</ErrorId>
<ManagedErrorName>BDK_E_INVALID_COUNTRY_CODE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B557</ErrorId>
<ManagedErrorName>BDK_E_INVALID_CURRENCY</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B558</ErrorId>
<ManagedErrorName>BDK_E_INVALID_CUSTOMER_TYPE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B559</ErrorId>
<ManagedErrorName>BDK_E_INVALID_DATE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B55A</ErrorId>
<ManagedErrorName>BDK_E_INVALID_EMAIL_ADDRESS</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B55B</ErrorId>
<ManagedErrorName>BDK_E_INVALID_FILTER</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B55C</ErrorId>
<ManagedErrorName>BDK_E_INVALID_GUID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B55D</ErrorId>
<ManagedErrorName>BDK_E_INVALID_INPUT_TO_TAXWARE_OR_VERAZIP</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B55E</ErrorId>
<ManagedErrorName>BDK_E_INVALID_LOCALE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B55F</ErrorId>
<ManagedErrorName>BDK_E_INVALID_OBJECT_ID</ManagedErrorName>
<ErrorMessage>{0}  The Billing system cannot find the object (e.g. account or subscription or offering).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B560</ErrorId>
<ManagedErrorName>BDK_E_INVALID_OFFERING_GUID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B561</ErrorId>
<ManagedErrorName>BDK_E_INVALID_PAYMENT_INSTRUMENT_STATUS</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B562</ErrorId>
<ManagedErrorName>BDK_E_INVALID_PAYMENT_METHOD_ID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B563</ErrorId>
<ManagedErrorName>BDK_E_INVALID_PHONE_TYPE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B564</ErrorId>
<ManagedErrorName>BDK_E_INVALID_POLICY_ID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B565</ErrorId>
<ManagedErrorName>BDK_E_INVALID_REFERRALDATA_XML</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B566</ErrorId>
<ManagedErrorName>BDK_E_INVALID_STATE_FOR_COUNTRY</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B567</ErrorId>
<ManagedErrorName>BDK_E_INVALID_SUBSCRIPTION_ID</ManagedErrorName>
<ErrorMessage>{0}  The subscription id specified is invalid.  Or, although the objectID is of correct type and also points to a valid account in SCS, the subscription it identifies does not exist in SCS.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B568</ErrorId>
<ManagedErrorName>BDK_E_INVALID_TAX_EXEMPT_TYPE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B569</ErrorId>
<ManagedErrorName>BDK_E_MEG_CONFLICT</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B56A</ErrorId>
<ManagedErrorName>BDK_E_MULTIPLE_CITIES_FOUND</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B56B</ErrorId>
<ManagedErrorName>BDK_E_MULTIPLE_COUNTIES_FOUND</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B56C</ErrorId>
<ManagedErrorName>BDK_E_NON_ACTIVE_ACCOUNT</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B56D</ErrorId>
<ManagedErrorName>BDK_E_NOPERMISSION</ManagedErrorName>
<ErrorMessage>{0}  The calling partner does not have access to this method or when the requester does not have permission to search against the supplied search PUID.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B56E</ErrorId>
<ManagedErrorName>BDK_E_OBJECT_ROLE_LIMIT_EXCEEDED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B56F</ErrorId>
<ManagedErrorName>BDK_E_OFFERING_ACCOUNT_CURRENCY_MISMATCH</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B570</ErrorId>
<ManagedErrorName>BDK_E_OFFERING_COUNTRY_ACCOUNT_MISMATCH</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B571</ErrorId>
<ManagedErrorName>BDK_E_OFFERING_NOT_PURCHASEABLE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B572</ErrorId>
<ManagedErrorName>BDK_E_OFFERING_PAYMENT_INSTRUMENT_MISMATCH</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B573</ErrorId>
<ManagedErrorName>BDK_E_OFFERING_REQUIRES_PI</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B574</ErrorId>
<ManagedErrorName>BDK_E_PARTNERNOTINBILLING</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B575</ErrorId>
<ManagedErrorName>BDK_E_PAYMENT_PROVIDER_CONNECTION_FAILED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B576</ErrorId>
<ManagedErrorName>BDK_E_PRIMARY_PHONE_REQUIRED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B577</ErrorId>
<ManagedErrorName>BDK_E_POLICY_DEAL_COUNTRY_MISMATCH</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B578</ErrorId>
<ManagedErrorName>BDK_E_PUID_ROLE_LIMIT_EXCEEDED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B579</ErrorId>
<ManagedErrorName>BDK_E_RATING_FAILURE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B57A</ErrorId>
<ManagedErrorName>BDK_E_REQUIRED_FIELD_MISSING</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B57B</ErrorId>
<ManagedErrorName>BDK_E_STATE_CITY_INVALID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B57C</ErrorId>
<ManagedErrorName>BDK_E_STATE_INVALID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B57D</ErrorId>
<ManagedErrorName>BDK_E_STATE_ZIP_CITY_INVALID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B57E</ErrorId>
<ManagedErrorName>BDK_E_STATE_ZIP_CITY_INVALID2</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B57F</ErrorId>
<ManagedErrorName>BDK_E_STATE_ZIP_CITY_INVALID3</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B580</ErrorId>
<ManagedErrorName>BDK_E_STATE_ZIP_CITY_INVALID4</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B581</ErrorId>
<ManagedErrorName>BDK_E_STATE_ZIP_COVERS_MULTIPLE_CITIES</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B582</ErrorId>
<ManagedErrorName>BDK_E_STATE_ZIP_INVALID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B583</ErrorId>
<ManagedErrorName>BDK_E_TAXID_EXPDATE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B584</ErrorId>
<ManagedErrorName>BDK_E_TOKEN_BLACKLISTED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B585</ErrorId>
<ManagedErrorName>BDK_E_TOKEN_EXPIRED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B586</ErrorId>
<ManagedErrorName>BDK_E_TOKEN_NOT_VALID_FOR_OFFERING</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B587</ErrorId>
<ManagedErrorName>BDK_E_TOKEN_RANGE_BLACKLISTED</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B588</ErrorId>
<ManagedErrorName>BDK_E_TRANS_BALANCE_TO_PI_INVALID</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B589</ErrorId>
<ManagedErrorName>BDK_E_UNKNOWN_SERVER_FAILURE</ManagedErrorName>
<ErrorMessage>{0}  Unknown server failure.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B58A</ErrorId>
<ManagedErrorName>BDK_E_UNSUPPORTED_CHAR_EXIST</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B58B</ErrorId>
<ManagedErrorName>BDK_E_VATID_DOESNOTHAVEEXPDATE</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B58C</ErrorId>
<ManagedErrorName>BDK_E_ZIP_CITY_MISSING</ManagedErrorName>
<ErrorMessage>{0}  </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B58D</ErrorId>
<ManagedErrorName>BDK_E_ZIP_INVALID</ManagedErrorName>
<ErrorMessage>{0}  Billing zip code error.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B58E</ErrorId>
<ManagedErrorName>BDK_E_ZIP_INVALID_FOR_ENTERED_STATE</ManagedErrorName>
<ErrorMessage>{0}  Billing zip code error.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004B58F</ErrorId>
<ManagedErrorName>BDK_E_USAGE_COUNT_FOR_TOKEN_EXCEEDED</ManagedErrorName>
<ErrorMessage>{0}  Billing token is already spent.</ErrorMessage>
</crmerror>

<!-- CRM Online Config database Error Codes 8004C000 - 8004CFFF to distinguish them easily from other error codes.
-->

<crmerror>
<ErrorId>8004C000</ErrorId>
<ManagedErrorName>MissingParameterToStoredProcedure</ManagedErrorName>
<ErrorMessage>Missing parameter to stored procedure:  {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004C001</ErrorId>
<ManagedErrorName>SqlErrorInStoredProcedure</ManagedErrorName>
<ErrorMessage>SQL error {0} occurred in stored procedure {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004C002</ErrorId>
<ManagedErrorName>StoredProcedureContext</ManagedErrorName>
<ErrorMessage>CRM error {0} in {1}:{2}</ErrorMessage>
</crmerror>

<!-- CRM Online Config database User Invitation 8004D200 8004D21F
-->

<crmerror>
<ErrorId>8004D200</ErrorId>
<ManagedErrorName>InvitingOrganizationNotFound</ManagedErrorName>
<ErrorMessage>{0} -- Inviting organization not found -- {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D201</ErrorId>
<ManagedErrorName>InvitingUserNotInOrganization</ManagedErrorName>
<ErrorMessage>{0} -- Inviting user is not in the inviting organization -- {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D202</ErrorId>
<ManagedErrorName>InvitedUserAlreadyExists</ManagedErrorName>
<ErrorMessage>{0} -- Invited user is already in an organization -- {1}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D203</ErrorId>
<ManagedErrorName>InvitedUserIsOrganization</ManagedErrorName>
<ErrorMessage>{0} -- The user {1} has authentication {2} and is already related to organization {3} with relation id {4}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D204</ErrorId>
<ManagedErrorName>InvitationNotFound</ManagedErrorName>
<ErrorMessage>{0} -- Invitation not found or status is not Open -- Token={1} Puid={2} Id={3} Status={4}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D205</ErrorId>
<ManagedErrorName>InvitedUserAlreadyAdded</ManagedErrorName>
<ErrorMessage>{0} -- The crm user {1} is already added, but to organization {2} instead of the inviting organization {3}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D206</ErrorId>
<ManagedErrorName>InvitationWrongUserOrgRelation</ManagedErrorName>
<ErrorMessage>{0} -- The pre-created userorg relation {1} is wrong.  Authentication {2} is already used by another user</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D207</ErrorId>
<ManagedErrorName>InvitationIsExpired</ManagedErrorName>
<ErrorMessage>{0} -- Invitation is expired -- Token={1} Puid={2} Id={3} Status={4}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D208</ErrorId>
<ManagedErrorName>InvitationIsAccepted</ManagedErrorName>
<ErrorMessage>{0} -- Invitation has already been accepted -- Token={1} Puid={2} Id={3} Status={4}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D209</ErrorId>
<ManagedErrorName>InvitationIsRejected</ManagedErrorName>
<ErrorMessage>{0} -- Invitation has already been rejected by the new user-- Token={1} Puid={2} Id={3} Status={4}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D20A</ErrorId>
<ManagedErrorName>InvitationIsRevoked</ManagedErrorName>
<ErrorMessage>{0} -- Invitation has been revoked by the organization -- Token={1} Puid={2} Id={3} Status={4}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D20B</ErrorId>
<ManagedErrorName>InvitedUserMultipleTimes</ManagedErrorName>
<ErrorMessage>The CRM user {0} has been invited multiple times.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D20C</ErrorId>
<ManagedErrorName>InvitationStatusError</ManagedErrorName>
<ErrorMessage>"The invitation has status {0}."</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D20D</ErrorId>
<ManagedErrorName>InvalidInvitationToken</ManagedErrorName>
<ErrorMessage>The invitation token {0} is not correctly formatted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D20E</ErrorId>
<ManagedErrorName>InvalidInvitationLiveId</ManagedErrorName>
<ErrorMessage>A user with this e-mail address was not found. Sign in to Windows Live ID with the same e-mail address where you received the invitation.  If you do not have a Windows Live ID, please create one using that e-mail address.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D20F</ErrorId>
<ManagedErrorName>InvitationSendToSelf</ManagedErrorName>
<ErrorMessage>The invitation cannot be sent to yourself.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D210</ErrorId>
<ManagedErrorName>InvitationCannotBeReset</ManagedErrorName>
<ErrorMessage>The invitation for the user cannot be reset.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D211</ErrorId>
<ManagedErrorName>UserDataNotFound</ManagedErrorName>
<ErrorMessage>The user data could not be found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D212</ErrorId>
<ManagedErrorName>CannotInviteDisabledUser</ManagedErrorName>
<ErrorMessage>An invitation cannot be sent to a disabled user</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D213</ErrorId>
<ManagedErrorName>InvitationBillingAdminUnknown</ManagedErrorName>
<ErrorMessage>You are not a billing administrator for this organization and therefore, you cannot send invitations.  You can either contact your billing administrator and ask him or her to send the invitation, or the billing administrator can visit https://billing.microsoft.com and make you a delegate billing administrator. You can then send invitations.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D214</ErrorId>
<ManagedErrorName>CannotResetSysAdminInvite</ManagedErrorName>
<ErrorMessage>An invitation cannot be reset for a user if they are the only user that has the System Administrator Role.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D215</ErrorId>
<ManagedErrorName>CannotSendInviteToDuplicateWindowsLiveId</ManagedErrorName>
<ErrorMessage>An invitation cannot be sent because there are multiple users with this WLID.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D216</ErrorId>
<ManagedErrorName>UserInviteDisabled</ManagedErrorName>
<ErrorMessage>Invitation cannot be sent because user invitations are disabled.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D217</ErrorId>
<ManagedErrorName>InvitationOrganizationNotEnabled</ManagedErrorName>
<ErrorMessage>The organization for the invitation is not enabled.</ErrorMessage>
</crmerror>

<!-- Client authentication Error Codes are defined from 8004D220 - 8004D22F to distinguish them easily from other error codes.
-->
<crmerror>
<ErrorId>8004D221</ErrorId>
<ManagedErrorName>ClientAuthSignedOut</ManagedErrorName>
<ErrorMessage>The user signed out.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D223</ErrorId>
<ManagedErrorName>ClientAuthSyncIssue</ManagedErrorName>
<ErrorMessage>Synchronization between processes failed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D224</ErrorId>
<ManagedErrorName>ClientAuthCanceled</ManagedErrorName>
<ErrorMessage>Authentication was canceled by the user.</ErrorMessage>
<UnManagedErrorName>IDS_CLIENT_AUTH_CANCELED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004D225</ErrorId>
<ManagedErrorName>ClientAuthNoConnectivityOffline</ManagedErrorName>
<ErrorMessage>There is no connectivity when running in offline mode.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D226</ErrorId>
<ManagedErrorName>ClientAuthNoConnectivity</ManagedErrorName>
<ErrorMessage>There is no connectivity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D227</ErrorId>
<ManagedErrorName>ClientAuthOfflineInvalidCallerId</ManagedErrorName>
<ErrorMessage>Offline SDK calls must be made in the offline user context.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D228</ErrorId>
<ManagedErrorName>AuthenticateToServerBeforeRequestingProxy</ManagedErrorName>
<ErrorMessage>Authenticate to serverType: {0} before requesting a proxy.</ErrorMessage>
</crmerror>

<!-- AdminService Config database Error Codes are defined from 8004D230 - 8004D23F to distinguish them easily from other error codes.
-->
<crmerror>
<ErrorId>8004D230</ErrorId>
<ManagedErrorName>ConfigDBObjectDoesNotExist</ManagedErrorName>
<ErrorMessage>'{0}' with Value = ({1}) does not exist in MSCRM_CONFIG database</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D231</ErrorId>
<ManagedErrorName>ConfigDBDuplicateRecord</ManagedErrorName>
<ErrorMessage>Duplicate '{0}' with Value = ({1}) exists in MSCRM_CONFIG database</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D232</ErrorId>
<ManagedErrorName>ConfigDBCannotDeleteObjectDueState</ManagedErrorName>
<ErrorMessage>Cannot delete '{0}' with Value = ({1}) in this State = ({2}) from MSCRM_CONFIG database</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D233</ErrorId>
<ManagedErrorName>ConfigDBCascadeDeleteNotAllowDelete</ManagedErrorName>
<ErrorMessage>Cannot delete '{0}' with Value = ({1}) due to child '{2}' references from MSCRM_CONFIG database</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D234</ErrorId>
<ManagedErrorName>MoveBothToPrimary</ManagedErrorName>
<ErrorMessage>Move operation would put both instances on the same server:  Database = {0}  Old Primary = {1}  Old Secondary = {2}  New Secondary = {3}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D235</ErrorId>
<ManagedErrorName>MoveBothToSecondary</ManagedErrorName>
<ErrorMessage>Move operation would put both instances on the same server:  Database = {0}  Old Primary = {1}  Old Secondary = {2}  New Secondary = {3}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D236</ErrorId>
<ManagedErrorName>MoveOrganizationFailedNotDisabled</ManagedErrorName>
<ErrorMessage>Move operation failed because organization {0} is not disabled</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D237</ErrorId>
<ManagedErrorName>ConfigDBCannotUpdateObjectDueState</ManagedErrorName>
<ErrorMessage>Cannot update '{0}' with Value = ({1}) in this State = ({2}) from MSCRM_CONFIG database</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D238</ErrorId>
<ManagedErrorName>LiveAdminUnknownObject</ManagedErrorName>
<ErrorMessage>Unknown administration target {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D239</ErrorId>
<ManagedErrorName>LiveAdminUnknownCommand</ManagedErrorName>
<ErrorMessage>Unknown administration command {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D23a</ErrorId>
<ManagedErrorName>OperationOrganizationNotFullyDisabled</ManagedErrorName>
<ErrorMessage>The {1} operation failed because organization {0} is not fully disabled yet.  Use FORCE to override</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D23B</ErrorId>
<ManagedErrorName>ConfigDBCannotDeleteDefaultOrganization</ManagedErrorName>
<ErrorMessage>The default {0} organization cannot be deleted from the MSCRM_CONFIG database.</ErrorMessage>
</crmerror>

<!-- License related errors; 8004D240 - 8004D24F
-->
<crmerror>
<ErrorId>80042f14</ErrorId>
<ManagedErrorName>LicenseNotEnoughToActivate</ManagedErrorName>
<ErrorMessage>There are not enough licenses available for the number of users being activated.</ErrorMessage>
<UnManagedErrorName>IDS_LICENSE_NOT_ENOUGH_TO_ACTIVATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042f09</ErrorId>
<ManagedErrorName>UserNotAssignedRoles</ManagedErrorName>
<ErrorMessage>The user has not been assigned any roles.</ErrorMessage>
<UnManagedErrorName>IDS_LICENSE_NO_LICENSES</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80042f0a</ErrorId>
<ManagedErrorName>TeamNotAssignedRoles</ManagedErrorName>
<ErrorMessage>The team has not been assigned any roles.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D240</ErrorId>
<ManagedErrorName>InvalidLicenseKey</ManagedErrorName>
<ErrorMessage>Invalid license key ({0}).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D241</ErrorId>
<ManagedErrorName>NoLicenseInConfigDB</ManagedErrorName>
<ErrorMessage>No license exists in MSCRM_CONFIG database.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D242</ErrorId>
<ManagedErrorName>InvalidLicensePid</ManagedErrorName>
<ErrorMessage>Invalid license. Invalid PID (Product Id) ({0}).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D243</ErrorId>
<ManagedErrorName>InvalidLicensePidGenCannotLoad</ManagedErrorName>
<ErrorMessage>Invalid license. PidGen.dll cannot be loaded from this path {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D244</ErrorId>
<ManagedErrorName>InvalidLicensePidGenOtherError</ManagedErrorName>
<ErrorMessage>Invalid license. Cannot generate PID (Product Id) from License key. PidGen error code ({0}).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D245</ErrorId>
<ManagedErrorName>InvalidLicenseCannotReadMpcFile</ManagedErrorName>
<ErrorMessage>Invalid license. MPC code cannot be read from MPC.txt file with this path {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D246</ErrorId>
<ManagedErrorName>InvalidLicenseMpcCode</ManagedErrorName>
<ErrorMessage>Invalid license. Invalid MPC code ({0}).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D247</ErrorId>
<ManagedErrorName>LicenseUpgradePathNotAllowed</ManagedErrorName>
<ErrorMessage>Cannot upgrade to specified license type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D24A</ErrorId>
<ManagedErrorName>OrgsInaccessible</ManagedErrorName>
<ErrorMessage>The client access license (CAL) results were not returned because one or more organizations in the deployment cannot be accessed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D24B</ErrorId>
<ManagedErrorName>UserNotAssignedLicense</ManagedErrorName>
<ErrorMessage>The user has not been assigned any License</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D24C</ErrorId>
<ManagedErrorName>UserCannotEnableWithoutLicense</ManagedErrorName>
<ErrorMessage>Cannot enable an unlicensed user</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D250</ErrorId>
<ManagedErrorName>LicenseConfigFileInvalid</ManagedErrorName>
<ErrorMessage>The provided configuration file {0} has invalid formatting.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004415c</ErrorId>
<ManagedErrorName>LicenseTrialExpired</ManagedErrorName>
<ErrorMessage>The trial installation of Microsoft Dynamics CRM has expired.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004415d</ErrorId>
<ManagedErrorName>LicenseRegistrationExpired</ManagedErrorName>
<ErrorMessage>The registration period for Microsoft Dynamics CRM has expired.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004415f</ErrorId>
<ManagedErrorName>LicenseTampered</ManagedErrorName>
<ErrorMessage>The licensing for this installation of Microsoft Dynamics CRM has been tampered with. The system is unusable. Please contact Microsoft Product Support Services.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80044160</ErrorId>
<ManagedErrorName>NonInteractiveUserCannotAccessUI</ManagedErrorName>
<ErrorMessage>Non-interactive users cannot access the web user interface. Contact your organization system administrator.</ErrorMessage>
</crmerror>

<!-- Organization related errors; 8004D250 - 8004D25F
-->
<crmerror>
<ErrorId>8004D251</ErrorId>
<ManagedErrorName>InvalidOrganizationUniqueName</ManagedErrorName>
<ErrorMessage>Invalid organization unique name ({0}). Reason: ({1})</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D252</ErrorId>
<ManagedErrorName>InvalidOrganizationFriendlyName</ManagedErrorName>
<ErrorMessage>Invalid organization friendly name ({0}). Reason: ({1})</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D253</ErrorId>
<ManagedErrorName>OrganizationNotConfigured</ManagedErrorName>
<ErrorMessage>Organization is not configured yet</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D254</ErrorId>
<ManagedErrorName>InvalidDeviceToConfigureOrganization</ManagedErrorName>
<ErrorMessage>Mobile device cannot be used to configured organization</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D255</ErrorId>
<ManagedErrorName>InvalidBrowserToConfigureOrganization</ManagedErrorName>
<ErrorMessage>Browser not compatible to configure organization</ErrorMessage>
</crmerror>

<!-- Deployment SDK related errors; 8004D260 - 8004D28F
-->
<crmerror>
<ErrorId>8004D260</ErrorId>
<ManagedErrorName>DeploymentServiceNotAllowSetToThisState</ManagedErrorName>
<ErrorMessage>Deployment Service for {0} allows the state Enabled or Disabled. Cannot set state to {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D261</ErrorId>
<ManagedErrorName>DeploymentServiceNotAllowOperation</ManagedErrorName>
<ErrorMessage>Deployment Service for {0} does not allow {1} operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D262</ErrorId>
<ManagedErrorName>DeploymentServiceCannotChangeStateForDeploymentService</ManagedErrorName>
<ErrorMessage>You cannot change the state of this server because it contains the Deployment Service server role.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D263</ErrorId>
<ManagedErrorName>DeploymentServiceRequestValidationFailure</ManagedErrorName>
<ErrorMessage>The Deployment Service cannot process the request because one or more validation checks failed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D264</ErrorId>
<ManagedErrorName>DeploymentServiceOperationIdentifierNotFound</ManagedErrorName>
<ErrorMessage>The Deployment Service could not find a deferred operation having the specified identifier.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D265</ErrorId>
<ManagedErrorName>DeploymentServiceCannotDeleteOperationInProgress</ManagedErrorName>
<ErrorMessage>The Deployment Service cannot delete the specified operation because it is currently in progress.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D266</ErrorId>
<ManagedErrorName>ConfigureClaimsBeforeIfd</ManagedErrorName>
<ErrorMessage>You must configure claims-based authentication before you can configure an Internet-facing deployment.</ErrorMessage>
</crmerror>

<!-- EndUserNotification related errors: 8004D290 - 8004D29F
-->

<crmerror>
<ErrorId>8004D291</ErrorId>
<ManagedErrorName>EndUserNotificationTypeNotValidForEmail</ManagedErrorName>
<ErrorMessage>Cannot send Email for EndUserNotification Type: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D294</ErrorId>
<ManagedErrorName>ClientUpdateAvailable</ManagedErrorName>
<ErrorMessage>There's an update available for CRM for Outlook.</ErrorMessage>
</crmerror>
<!--  Invalid Recurrence rule related errors: !
-->
<crmerror>
<ErrorId>8004D2A0</ErrorId>
<ManagedErrorName>InvalidRecurrenceRuleForBulkDeleteAndDuplicateDetection</ManagedErrorName>
<ErrorMessage>Bulk Delete and Duplicate Detection recurrence must be specified as daily.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D2A1</ErrorId>
<ManagedErrorName>InvalidRecurrenceInterval</ManagedErrorName>
<ErrorMessage>To set recurrence, you must specify an interval that is between 1 and 365.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D2A2</ErrorId>
<ManagedErrorName>InvalidRecurrenceIntervalForRollupJobs</ManagedErrorName>
<ErrorMessage>To set recurrence, you must specify an interval that should be greater than 1 hour.</ErrorMessage>
</crmerror>

<!-- Aggregate Query related errors
-->
<crmerror>
<ErrorId>8004D2B0</ErrorId>
<ManagedErrorName>QueriesForDifferentEntities</ManagedErrorName>
<ErrorMessage>The Inner and Outer Queries must be for the same entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004D2B1</ErrorId>
<ManagedErrorName>AggregateInnerQuery</ManagedErrorName>
<ErrorMessage>The Inner Query must not be an aggregate query.</ErrorMessage>
</crmerror>

<!-- Visualizations related errors: 8004E000 - 8004E0FF
-->
<crmerror>
<ErrorId>8004E000</ErrorId>
<ManagedErrorName>InvalidDataDescription</ManagedErrorName>
<ErrorMessage>The data description for the visualization is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E001</ErrorId>
<ManagedErrorName>NonPrimaryEntityDataDescriptionFound</ManagedErrorName>
<ErrorMessage>The data description for the visualization is invalid .The data description for the visualization can only have attributes either from the primary entity of the view or the linked entities.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E002</ErrorId>
<ManagedErrorName>InvalidPresentationDescription</ManagedErrorName>
<ErrorMessage>The presentation description is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E003</ErrorId>
<ManagedErrorName>SeriesMeasureCollectionMismatch</ManagedErrorName>
<ErrorMessage>Number of series for chart area and number of measure collections for category should be same.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E004</ErrorId>
<ManagedErrorName>YValuesPerPointMeasureMismatch</ManagedErrorName>
<ErrorMessage>Number of YValuesPerPoint for series and number of measures for measure collection for category should be same.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E005</ErrorId>
<ManagedErrorName>ChartAreaCategoryMismatch</ManagedErrorName>
<ErrorMessage>Number of chart areas and number of categories should be same.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E006</ErrorId>
<ManagedErrorName>MultipleSubcategoriesFound</ManagedErrorName>
<ErrorMessage>The data XML for the visualization cannot contain more than two Group By clauses.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E007</ErrorId>
<ManagedErrorName>MultipleMeasuresFound</ManagedErrorName>
<ErrorMessage>More than one measure is not supported for charts with subcategory i.e. comparison charts</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E008</ErrorId>
<ManagedErrorName>MultipleChartAreasFound</ManagedErrorName>
<ErrorMessage>Multiple Chart Areas are not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E009</ErrorId>
<ManagedErrorName>InvalidCategory</ManagedErrorName>
<ErrorMessage>Category is invalid. All the measures in the category either do not have same primary group by or are a mix of aggregate and non-aggregate data.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E00A</ErrorId>
<ManagedErrorName>InvalidMeasureCollection</ManagedErrorName>
<ErrorMessage>Measure collection is invalid. Not all the measures in the measure collection have the same group bys.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E00B</ErrorId>
<ManagedErrorName>DuplicateAliasFound</ManagedErrorName>
<ErrorMessage>Data Description is invalid. Duplicate alias found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E00C</ErrorId>
<ManagedErrorName>EntityNotEnabledForCharts</ManagedErrorName>
<ErrorMessage>Charts are not enabled on the specified primary entity type code: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E00D</ErrorId>
<ManagedErrorName>InvalidPageResponse</ManagedErrorName>
<ErrorMessage>Invalid Page Response generated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E00E</ErrorId>
<ManagedErrorName>VisualizationRenderingError</ManagedErrorName>
<ErrorMessage>An error occurred while the chart was rendering</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E00F</ErrorId>
<ManagedErrorName>InvalidGroupByAlias</ManagedErrorName>
<ErrorMessage>Data Description is invalid. Same group by alias cannot be used for different attributes.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E010</ErrorId>
<ManagedErrorName>MeasureDataTypeInvalid</ManagedErrorName>
<ErrorMessage>The Data Description for the visualization is invalid. The attribute type for one of the non aggregate measures is invalid. Correct the Data Description.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E011</ErrorId>
<ManagedErrorName>NoDataForVisualization</ManagedErrorName>
<ErrorMessage>There is no data to create this visualization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E012</ErrorId>
<ManagedErrorName>VisualizationModuleNotFound</ManagedErrorName>
<ErrorMessage>No visualization module found with the given name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E013</ErrorId>
<ManagedErrorName>ImportVisualizationDeletedError</ManagedErrorName>
<ErrorMessage>A saved query visualization with id {0} is marked for deletion in the system. Please publish the customized entity first and then import again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E014</ErrorId>
<ManagedErrorName>ImportVisualizationExistingError</ManagedErrorName>
<ErrorMessage>A saved query visualization with id {0} already exists in the system, and cannot be resused by a new custom entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E015</ErrorId>
<ManagedErrorName>VisualizationOtcNotFoundError</ManagedErrorName>
<ErrorMessage>Object type code is not specified for the visualization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E016</ErrorId>
<ManagedErrorName>InvalidDundasPresentationDescription</ManagedErrorName>
<ErrorMessage>The presentation description is not valid for dundas chart.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E017</ErrorId>
<ManagedErrorName>InvalidWebResourceForVisualization</ManagedErrorName>
<ErrorMessage>The web resource type {0} is not supported for visualizations.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E018</ErrorId>
<ManagedErrorName>ChartTypeNotSupportedForComparisonChart</ManagedErrorName>
<ErrorMessage>This chart type is not supported for comparison charts.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E019</ErrorId>
<ManagedErrorName>InvalidFetchCollection</ManagedErrorName>
<ErrorMessage>The fetch collection for the visualization is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E01A</ErrorId>
<ManagedErrorName>CategoryDataTypeInvalid</ManagedErrorName>
<ErrorMessage>The Data Description for the visualization is invalid. The attribute type for the group by of one of the categories is invalid. Correct the Data Description.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E01B</ErrorId>
<ManagedErrorName>DuplicateGroupByFound</ManagedErrorName>
<ErrorMessage>Data Description is invalid. Same attribute cannot be used as a group by more than once.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E01C</ErrorId>
<ManagedErrorName>MultipleMeasureCollectionsFound</ManagedErrorName>
<ErrorMessage>More than one measure collection is not supported for charts with subcategory i.e. comparison charts</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E01D</ErrorId>
<ManagedErrorName>InvalidGroupByColumn</ManagedErrorName>
<ErrorMessage>Group by not allowed on the attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E01E</ErrorId>
<ManagedErrorName>InvalidFilterCriteriaForVisualization</ManagedErrorName>
<ErrorMessage>The visualization cannot be rendered for the given filter criteria.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E01F</ErrorId>
<ManagedErrorName>CountSpecifiedWithoutOrder</ManagedErrorName>
<ErrorMessage>The Data Description for the visualization is invalid as it does not specify an order node for the count attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E020</ErrorId>
<ManagedErrorName>NoPreviewForCustomWebResource</ManagedErrorName>
<ErrorMessage>This chart uses a custom Web resource. You cannot preview this chart.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E021</ErrorId>
<ManagedErrorName>ChartTypeNotSupportedForMultipleSeriesChart</ManagedErrorName>
<ErrorMessage>Series of chart type {0} is not supported for multi-series charts.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E022</ErrorId>
<ManagedErrorName>InsufficientColumnsInSubQuery</ManagedErrorName>
<ErrorMessage>One or more columns required by the outer query are not available from the sub-query.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E023</ErrorId>
<ManagedErrorName>AggregateQueryRecordLimitExceeded</ManagedErrorName>
<ErrorMessage>The maximum record limit is exceeded. Reduce the number of records.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E025</ErrorId>
<ManagedErrorName>RollupAggregateQueryRecordLimitExceeded</ManagedErrorName>
<ErrorMessage>Calculations can't be performed online because the calculation limit of {0} related records has been reached.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E024</ErrorId>
<ManagedErrorName>QuickFindQueryRecordLimitExceeded</ManagedErrorName>
<ErrorMessage>QuickFindQueryRecordLimit exceeded. Cannot perform this operation.</ErrorMessage>
</crmerror>
<!-- Impersonator role/privilege related errors: 8004Ed43
-->
<crmerror>
<ErrorId>8004Ed43</ErrorId>
<ManagedErrorName>CannotAddOrActonBehalfAnotherUserPrivilege</ManagedErrorName>
<ErrorMessage>Act on Behalf of Another User privilege cannot be added or removed.</ErrorMessage>
</crmerror>

<!-- Hip related errors: 8004Ed44 - 8004Ed45
-->
<crmerror>
<ErrorId>8004Ed44</ErrorId>
<ManagedErrorName>HipNoSettingError</ManagedErrorName>
<ErrorMessage>No Hip application configuration setting [{0}] was found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004Ed45</ErrorId>
<ManagedErrorName>HipInvalidCertificate</ManagedErrorName>
<ErrorMessage>Invalid Certificate for using HIP.</ErrorMessage>
</crmerror>

<!-- Generic ConfigDB related errors: 8004Ed46 - 8004Ed47
-->
<crmerror>
<ErrorId>8004Ed46</ErrorId>
<ManagedErrorName>NoSettingError</ManagedErrorName>
<ErrorMessage>No configdb configuration setting [{0}] was found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004Ed47</ErrorId>
<ManagedErrorName>AppLockTimeout</ManagedErrorName>
<ErrorMessage>Timeout expired before applock could be acquired.</ErrorMessage>
</crmerror>

<!-- Recurring Activity related errors: 8004E100 - 8004E1FF
-->
<crmerror>
<ErrorId>8004E100</ErrorId>
<ManagedErrorName>InvalidRecurrencePattern</ManagedErrorName>
<ErrorMessage>Invalid recurrence pattern.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E101</ErrorId>
<ManagedErrorName>CreateRecurrenceRuleFailed</ManagedErrorName>
<ErrorMessage>Cannot create the recurrence rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E102</ErrorId>
<ManagedErrorName>PartialExpansionSettingLoadError</ManagedErrorName>
<ErrorMessage>Failed to retrieve partial expansion settings from the configuration database.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E103</ErrorId>
<ManagedErrorName>InvalidCrmDateTime</ManagedErrorName>
<ErrorMessage>Invalid CrmDateTime.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E104</ErrorId>
<ManagedErrorName>InvalidAppointmentInstance</ManagedErrorName>
<ErrorMessage>Invalid appointment entity instance.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E105</ErrorId>
<ManagedErrorName>InvalidSeriesId</ManagedErrorName>
<ErrorMessage>SeriesId is null or invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E106</ErrorId>
<ManagedErrorName>AppointmentDeleted</ManagedErrorName>
<ErrorMessage>The appointment entity instance is already deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E107</ErrorId>
<ManagedErrorName>InvalidInstanceTypeCode</ManagedErrorName>
<ErrorMessage>Invalid instance type code.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E108</ErrorId>
<ManagedErrorName>OverlappingInstances</ManagedErrorName>
<ErrorMessage>Two instances of the series cannot overlap.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E109</ErrorId>
<ManagedErrorName>InvalidSeriesIdOriginalStart</ManagedErrorName>
<ErrorMessage>Invalid seriesid or original start date.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E10A</ErrorId>
<ManagedErrorName>ValidateNotSupported</ManagedErrorName>
<ErrorMessage>Validate method is not supported for recurring appointment master.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E10B</ErrorId>
<ManagedErrorName>RecurringSeriesCompleted</ManagedErrorName>
<ErrorMessage>The series has invalid ExpansionStateCode.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E10C</ErrorId>
<ManagedErrorName>ExpansionRequestIsOutsideExpansionWindow</ManagedErrorName>
<ErrorMessage>The series is already expanded for CutOffWindow.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E10D</ErrorId>
<ManagedErrorName>InvalidInstanceEntityName</ManagedErrorName>
<ErrorMessage>Invalid instance entity name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E10E</ErrorId>
<ManagedErrorName>BookFirstInstanceFailed</ManagedErrorName>
<ErrorMessage>Failed to book first instance.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E10F</ErrorId>
<ManagedErrorName>InvalidSeriesStatus</ManagedErrorName>
<ErrorMessage>Invalid series status.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E110</ErrorId>
<ManagedErrorName>RecurrenceRuleUpdateFailure</ManagedErrorName>
<ErrorMessage>Cannot update a rule that is attached to an existing rule master. Update the rule by using the parent entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E111</ErrorId>
<ManagedErrorName>RecurrenceRuleDeleteFailure</ManagedErrorName>
<ErrorMessage>Cannot delete a rule that is attached to an existing rule master. Delete the rule by using the parent entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E112</ErrorId>
<ManagedErrorName>EntityNotRule</ManagedErrorName>
<ErrorMessage>The collection name is not a recurrence rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E113</ErrorId>
<ManagedErrorName>RecurringSeriesMasterIsLocked</ManagedErrorName>
<ErrorMessage>The recurring series master record is locked by some other process.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E114</ErrorId>
<ManagedErrorName>UpdateRecurrenceRuleFailed</ManagedErrorName>
<ErrorMessage>Failed to update the recurrence rule. A corresponding recurrence rule cannot be found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E115</ErrorId>
<ManagedErrorName>InstanceOutsideEffectiveRange</ManagedErrorName>
<ErrorMessage>Cannot perform the operation. An instance is outside of series effective expansion range.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E116</ErrorId>
<ManagedErrorName>RecurrenceCalendarTypeNotSupported</ManagedErrorName>
<ErrorMessage>The calendar type is not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E117</ErrorId>
<ManagedErrorName>RecurrenceHasNoOccurrence</ManagedErrorName>
<ErrorMessage>The recurrence pattern has no occurrences.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E118</ErrorId>
<ManagedErrorName>RecurrenceStartDateTooSmall</ManagedErrorName>
<ErrorMessage>The recurrence pattern start date is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E119</ErrorId>
<ManagedErrorName>RecurrenceEndDateTooBig</ManagedErrorName>
<ErrorMessage>The recurrence pattern end date is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E120</ErrorId>
<ManagedErrorName>OccurrenceCrossingBoundary</ManagedErrorName>
<ErrorMessage>Two occurrences cannot overlap.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E121</ErrorId>
<ManagedErrorName>OccurrenceTimeSpanTooBig</ManagedErrorName>
<ErrorMessage>Cannot perform the operation. An instance is outside of series effective expansion range.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E122</ErrorId>
<ManagedErrorName>OccurrenceSkipsOverForward</ManagedErrorName>
<ErrorMessage>Cannot reschedule an occurrence of the recurring appointment if it skips over a later occurrence of the same appointment.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E123</ErrorId>
<ManagedErrorName>OccurrenceSkipsOverBackward</ManagedErrorName>
<ErrorMessage>Cannot reschedule an occurrence of the recurring appointment if it skips over an earlier occurrence of the same appointment.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E124</ErrorId>
<ManagedErrorName>InvalidDaysInFebruary</ManagedErrorName>
<ErrorMessage>February 29 can occur only when pattern start date is in a leap year.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E125</ErrorId>
<ManagedErrorName>InvalidOccurrenceNumber</ManagedErrorName>
<ErrorMessage>The effective end date of the series cannot be earlier than today. Select a valid occurrence number.</ErrorMessage>
</crmerror>
<!-- Audit related errors: 8004E200 - 8004E2FF
-->
<crmerror>
<ErrorId>8004E200</ErrorId>
<ManagedErrorName>InvalidNumberOfPartitions</ManagedErrorName>
<ErrorMessage>You cannot delete audit data in the partitions that are currently in use, or delete the partitions that are created for storing future audit data.</ErrorMessage>
</crmerror>
<!-- Dashboards related errors: 8004E300 - 8004E3FF
-->
<crmerror>
<ErrorId>8004E300</ErrorId>
<ManagedErrorName>InvalidElementFound</ManagedErrorName>
<ErrorMessage>A dashboard Form XML cannot contain element: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E301</ErrorId>
<ManagedErrorName>MaximumControlsLimitExceeded</ManagedErrorName>
<ErrorMessage>The dashboard Form XML contains more than the maximum allowed number of control elements: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E302</ErrorId>
<ManagedErrorName>UserViewsOrVisualizationsFound</ManagedErrorName>
<ErrorMessage>A system dashboard cannot contain user views and visualizations.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E303</ErrorId>
<ManagedErrorName>InvalidAttributeFound</ManagedErrorName>
<ErrorMessage>A dashboard Form XML cannot contain attribute: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E304</ErrorId>
<ManagedErrorName>MultipleFormElementsFound</ManagedErrorName>
<ErrorMessage>A dashboard Form XML can contain only one form element.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E305</ErrorId>
<ManagedErrorName>NullDashboardName</ManagedErrorName>
<ErrorMessage>The name of a dashboard cannot be null.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E306</ErrorId>
<ManagedErrorName>InvalidFormType</ManagedErrorName>
<ErrorMessage>The type of the form must be set to {0} in the Form XML.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E307</ErrorId>
<ManagedErrorName>InvalidControlClass</ManagedErrorName>
<ErrorMessage>The dashboard Form XML cannot contain controls elements with class id: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E308</ErrorId>
<ManagedErrorName>ImportDashboardDeletedError</ManagedErrorName>
<ErrorMessage>A dashboard with the same id is marked as deleted in the system. Please first publish the system form entity and import again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E309</ErrorId>
<ManagedErrorName>PersonalReportFound</ManagedErrorName>
<ErrorMessage>A system dashboard cannot contain personal reports.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E30A</ErrorId>
<ManagedErrorName>ObjectAlreadyExists</ManagedErrorName>
<ErrorMessage>An object with id {0} already exists. Please change the id and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E30B</ErrorId>
<ManagedErrorName>EntityTypeSpecifiedForDashboard</ManagedErrorName>
<ErrorMessage>An entity type cannot be specified for a dashboard.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E30C</ErrorId>
<ManagedErrorName>UnrestrictedIFrameInUserDashboard</ManagedErrorName>
<ErrorMessage>A user dashboard Form XML cannot have Security = false.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E30D</ErrorId>
<ManagedErrorName>MultipleLabelsInUserDashboard</ManagedErrorName>
<ErrorMessage>A user dashboard can have at most one label for a form element.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E30E</ErrorId>
<ManagedErrorName>UnsupportedDashboardInEditor</ManagedErrorName>
<ErrorMessage>The dashboard could not be opened.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004E30F</ErrorId>
<ManagedErrorName>InvalidUrlProtocol</ManagedErrorName>
<ErrorMessage>The specified URL is invalid.</ErrorMessage>
</crmerror>
<!-- See comments above, create your own section! -->
<!-- Solution Management related errors: 8004F000 - 8004F0F0-->
<crmerror>
<ErrorId>8004F000</ErrorId>
<ManagedErrorName>CannotRemoveComponentFromDefaultSolution</ManagedErrorName>
<ErrorMessage>A Solution Component cannot be removed from the Default Solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F002</ErrorId>
<ManagedErrorName>InvalidSolutionUniqueName</ManagedErrorName>
<ErrorMessage>Invalid character specified for solution unique name. Only characters within the ranges [A-Z], [a-z], [0-9] or _ are allowed. The first character may only be in the ranges [A-Z], [a-z] or _.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F003</ErrorId>
<ManagedErrorName>CannotUndeleteLabel</ManagedErrorName>
<ErrorMessage>Attempting to undelete a label that is not marked as delete.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F004</ErrorId>
<ManagedErrorName>ErrorReactivatingComponentInstance</ManagedErrorName>
<ErrorMessage>After undeleting a label, there is no underlying label to reactivate.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F005</ErrorId>
<ManagedErrorName>CannotDeleteRestrictedSolution</ManagedErrorName>
<ErrorMessage>Attempting to delete a restricted solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F006</ErrorId>
<ManagedErrorName>CannotDeleteRestrictedPublisher</ManagedErrorName>
<ErrorMessage>Attempting to delete a restricted publisher.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F007</ErrorId>
<ManagedErrorName>ImportRestrictedSolutionError</ManagedErrorName>
<ErrorMessage>Solution ID provided is restricted and cannot be imported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F008</ErrorId>
<ManagedErrorName>CannotSetSolutionSystemAttributes</ManagedErrorName>
<ErrorMessage>System attributes ({0}) cannot be set outside of installation or upgrade.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F009</ErrorId>
<ManagedErrorName>CannotUpdateDefaultSolution</ManagedErrorName>
<ErrorMessage>Default solution attribute{0} {1} can only be set on installation or upgrade.  The value{0} cannot be modified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F00A</ErrorId>
<ManagedErrorName>CannotUpdateRestrictedSolution</ManagedErrorName>
<ErrorMessage>Restricted solution ({0}) cannot be updated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F00C</ErrorId>
<ManagedErrorName>CannotAddWorkflowActivationToSolution </ManagedErrorName>
<ErrorMessage>Cannot add Workflow Activation to solution </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F00D</ErrorId>
<ManagedErrorName>CannotQueryBaseTableWithAggregates</ManagedErrorName>
<ErrorMessage>Invalid query on base table.  Aggregates cannot be included in base table query.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F00E</ErrorId>
<ManagedErrorName>InvalidStateTransition</ManagedErrorName>
<ErrorMessage>The {0} (Id={1}) entity or component has attempted to transition from an invalid state: {2}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F00F</ErrorId>
<ManagedErrorName>CannotUpdateUnpublishedDeleteInstance</ManagedErrorName>
<ErrorMessage>The component that you are trying to update has been deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F010</ErrorId>
<ManagedErrorName>UnsupportedComponentOperation</ManagedErrorName>
<ErrorMessage>{0} is not recognized as a supported operation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F011</ErrorId>
<ManagedErrorName>InvalidCreateOnProtectedComponent</ManagedErrorName>
<ErrorMessage>You cannot create {0} {1}. Creation cannot be performed when {0} is managed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F012</ErrorId>
<ManagedErrorName>InvalidUpdateOnProtectedComponent</ManagedErrorName>
<ErrorMessage>You cannot update {0} {1}. Updates cannot be performed when {0} is managed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F013</ErrorId>
<ManagedErrorName>InvalidDeleteOnProtectedComponent</ManagedErrorName>
<ErrorMessage>You cannot delete {0} {1}. Deletion cannot be performed when {0} is managed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F014</ErrorId>
<ManagedErrorName>InvalidPublishOnProtectedComponent</ManagedErrorName>
<ErrorMessage>You cannot publish {0} {1}. Publish cannot be performed when {0} is managed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F015</ErrorId>
<ManagedErrorName>CannotAddNonCustomizableComponent</ManagedErrorName>
<ErrorMessage>The component {0} {1} cannot be added to the solution because it is not customizable</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F016</ErrorId>
<ManagedErrorName>CannotOverwriteActiveComponent</ManagedErrorName>
<ErrorMessage>A managed solution cannot overwrite the {0} component with Id={1} which has an unmanaged base instance.  The most likely scenario for this error is that an unmanaged solution has installed a new unmanaged {0} component on the target system, and now a managed solution from the same publisher is trying to install that same {0} component as managed.  This will cause an invalid layering of solutions on the target system and is not allowed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F017</ErrorId>
<ManagedErrorName>CannotUpdateRestrictedPublisher</ManagedErrorName>
<ErrorMessage>Restricted publisher ({0}) cannot be updated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F018</ErrorId>
<ManagedErrorName>CannotAddSolutionComponentWithoutRoots </ManagedErrorName>
<ErrorMessage>This item is not a valid solution component. For more information about solution components, see the Microsoft Dynamics CRM SDK documentation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F019</ErrorId>
<ManagedErrorName>ComponentDefinitionDoesNotExists</ManagedErrorName>
<ErrorMessage>No component definition exists for the component type {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F01A</ErrorId>
<ManagedErrorName>DependencyAlreadyExists</ManagedErrorName>
<ErrorMessage>A {0} dependency already exists between {1}({2}) and {3}({4}).  Cannot also create {5} dependency.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F01B</ErrorId>
<ManagedErrorName>DependencyTableNotEmpty</ManagedErrorName>
<ErrorMessage>The dependency table must be empty for initialization to complete successfully.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F01C</ErrorId>
<ManagedErrorName>InvalidPublisherUniqueName</ManagedErrorName>
<ErrorMessage>Publisher uniquename is required.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F01D</ErrorId>
<ManagedErrorName>CannotUninstallWithDependencies</ManagedErrorName>
<ErrorMessage>Solution dependencies exist, cannot uninstall.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F01E</ErrorId>
<ManagedErrorName>InvalidSolutionVersion</ManagedErrorName>
<ErrorMessage>An invalid solution version was specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F01F</ErrorId>
<ManagedErrorName>CannotDeleteInUseComponent</ManagedErrorName>
<ErrorMessage>The {0}({1}) component cannot be deleted because it is referenced by {2} other components. For a list of referenced components, use the RetrieveDependenciesForDeleteRequest.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F020</ErrorId>
<ManagedErrorName>CannotUninstallReferencedProtectedSolution</ManagedErrorName>
<ErrorMessage>This solution cannot be uninstalled because the '{0}' with id '{1}'  is required by the '{2}' solution. Uninstall the {2} solution and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F021</ErrorId>
<ManagedErrorName>CannotRemoveComponentFromSolution</ManagedErrorName>
<ErrorMessage>Cannot find solution component {0} {1} in solution {2}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F022</ErrorId>
<ManagedErrorName>RestrictedSolutionName</ManagedErrorName>
<ErrorMessage>The solution unique name '{0}' is restricted and can only be used by internal solutions.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F023</ErrorId>
<ManagedErrorName>SolutionUniqueNameViolation</ManagedErrorName>
<ErrorMessage>The solution unique name '{0}' is already being used and cannot be used again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F024</ErrorId>
<ManagedErrorName>CannotUpdateManagedSolution</ManagedErrorName>
<ErrorMessage>Cannot update solution '{0}' because it is a managed solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F025</ErrorId>
<ManagedErrorName>DependencyTrackingClosed</ManagedErrorName>
<ErrorMessage>Invalid attempt to process a dependency after the current transaction context has been closed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F026</ErrorId>
<ManagedErrorName>GenericManagedPropertyFailure</ManagedErrorName>
<ErrorMessage>The evaluation of the current component(name={0}, id={1}) in the current operation ({2}) failed during managed property evaluation of condition: {3}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F027</ErrorId>
<ManagedErrorName>CombinedManagedPropertyFailure</ManagedErrorName>
<ErrorMessage>The evaluation of the current component(name={0}, id={1}) in the current operation ({2}) failed during at least one managed property evaluations: {3}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F028</ErrorId>
<ManagedErrorName>ReportImportCategoryOptionNotFound</ManagedErrorName>
<ErrorMessage>A category option for the reports was not found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F029</ErrorId>
<ManagedErrorName>RequiredChildReportHasOtherParent</ManagedErrorName>
<ErrorMessage>A category option for the reports was not found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F030</ErrorId>
<ManagedErrorName>InvalidManagedPropertyException</ManagedErrorName>
<ErrorMessage>Managed property {0} does not contain enough information to be created.  Please provide (assembly, class), or (entity, attribute) or set the managed property to custom.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F031</ErrorId>
<ManagedErrorName>OnlyOwnerCanSetManagedProperties</ManagedErrorName>
<ErrorMessage>Cannot import component {0}: {1}. The publisher of the solution that is being imported does not match the publisher of the solution that installed this component.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F032</ErrorId>
<ManagedErrorName>CannotDeleteMetadata</ManagedErrorName>
<ErrorMessage>The '{2}' operation on the current component(name='{0}', id='{1}') failed during managed property evaluation of condition: '{3}'</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F033</ErrorId>
<ManagedErrorName>CannotUpdateReadOnlyPublisher</ManagedErrorName>
<ErrorMessage>Attempting to update a readonly publisher.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F034</ErrorId>
<ManagedErrorName>CannotSelectReadOnlyPublisher</ManagedErrorName>
<ErrorMessage>Attempting to  select a readonly publisher for solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F035</ErrorId>
<ManagedErrorName>CannotRemoveComponentFromSystemSolution</ManagedErrorName>
<ErrorMessage>A Solution Component cannot be removed from the System Solution.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F036</ErrorId>
<ManagedErrorName>InvalidDependency</ManagedErrorName>
<ErrorMessage>The {2} component {1} (Id={0}) does not exist.  Failure trying to associate it with {3} (Id={4}) as a dependency. Missing dependency lookup type = {5}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F037</ErrorId>
<ManagedErrorName>InvalidDependencyFetchXml</ManagedErrorName>
<ErrorMessage>The FetchXml ({2}) is invalid.  Failure while calculating dependencies for {1} (Id={0}).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F038</ErrorId>
<ManagedErrorName>CannotModifyReportOutsideSolutionIfManaged</ManagedErrorName>
<ErrorMessage>Managed solution cannot update reports which are not present in solution package.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F039</ErrorId>
<ManagedErrorName>DuplicateDetectionRulesWereUnpublished</ManagedErrorName>
<ErrorMessage>The duplicate detection rules for this entity have been unpublished due to possible modifications to the entity.</ErrorMessage>
</crmerror>
<!-- See comments above, create your own section! -->
<!-- SharePoint related errors: 8004F0F1 - 8004F100
-->
<crmerror>
<ErrorId>8004F0F1</ErrorId>
<ManagedErrorName>SharePointUnableToAddUserToGroup</ManagedErrorName>
<ErrorMessage>Microsoft Dynamics CRM cannot add this user {0} to the group {1} in SharePoint. Verify that the information for this user and group are correct and that the group exists in SharePoint, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0F2</ErrorId>
<ManagedErrorName>SharePointUnableToRemoveUserFromGroup</ManagedErrorName>
<ErrorMessage>Unable to remove user {0} from group {1} in SharePoint.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0F3</ErrorId>
<ManagedErrorName>SharePointSiteNotPresentInSharePoint</ManagedErrorName>
<ErrorMessage>Site {0} does not exists in SharePoint.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0F4</ErrorId>
<ManagedErrorName>SharePointUnableToRetrieveGroup</ManagedErrorName>
<ErrorMessage>Unable to retrieve the group {0} from SharePoint.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0F5</ErrorId>
<ManagedErrorName>SharePointUnableToAclSiteWithPrivilege</ManagedErrorName>
<ErrorMessage>Unable to ACL site {0} with privilege {1} in SharePoint.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0F6</ErrorId>
<ManagedErrorName>SharePointUnableToAclSite</ManagedErrorName>
<ErrorMessage>Unable to ACL site {0} in SharePoint.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0F7</ErrorId>
<ManagedErrorName>SharePointUnableToCreateSiteGroup</ManagedErrorName>
<ErrorMessage>Unable to create site group {0} in SharePoint.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0F8</ErrorId>
<ManagedErrorName>SharePointSiteCreationFailure</ManagedErrorName>
<ErrorMessage>Failed to create the site {0} in SharePoint.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0F9</ErrorId>
<ManagedErrorName>SharePointTeamProvisionJobAlreadyExists</ManagedErrorName>
<ErrorMessage>A system job to provision the selected team is pending. Any changes made to the team record before this system job starts will be applied to this system job.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0FA</ErrorId>
<ManagedErrorName>SharePointRoleProvisionJobAlreadyExists</ManagedErrorName>
<ErrorMessage>A system job to provision the selected security role is pending. Any changes made to the security role record before this system job starts will be applied to this system job.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0FB</ErrorId>
<ManagedErrorName>SharePointSiteWideProvisioningJobFailed</ManagedErrorName>
<ErrorMessage>SharePoint provisioning job has failed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0FC</ErrorId>
<ManagedErrorName>DataTypeMismatchForLinkedAttribute</ManagedErrorName>
<ErrorMessage>Data type mismatch found for linked attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0FD</ErrorId>
<ManagedErrorName>InvalidEntityForLinkedAttribute</ManagedErrorName>
<ErrorMessage>Not a valid entity for linked attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0FE</ErrorId>
<ManagedErrorName>AlreadyLinkedToAnotherAttribute</ManagedErrorName>
<ErrorMessage>Given linked attribute is alreadly linked to other attribute.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F0FF</ErrorId>
<ManagedErrorName>DocumentManagementDisabled</ManagedErrorName>
<ErrorMessage>Document Management has been disabled for this organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F100</ErrorId>
<ManagedErrorName>DefaultSiteCollectionUrlChanged</ManagedErrorName>
<ErrorMessage>Default site collection url has been changed this organization after this operation was created.</ErrorMessage>
</crmerror>

<!-- See comments above, create your own section! -->
<!-- Ribbon Import related errors: 8004F101 - 8004F110-->
<crmerror>
<ErrorId>8004F101</ErrorId>
<ManagedErrorName>RibbonImportHidingBasicHomeTab</ManagedErrorName>
<ErrorMessage>The definition of the ribbon being imported will remove the Microsoft Dynamics CRM home tab. Include a home tab definition, or a ribbon will not be displayed in areas of the application that display the home tab.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F102</ErrorId>
<ManagedErrorName>RibbonImportInvalidPrivilegeName</ManagedErrorName>
<ErrorMessage>The RibbonDiffXml in this solution contains a reference to an invalid privilege: {0}. Update the RibbonDiffXml to reference a valid privilege and try importing again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F103</ErrorId>
<ManagedErrorName>RibbonImportEntityNotSupported</ManagedErrorName>
<ErrorMessage>The solution cannot be imported because the {0} entity contains a Ribbon definition, which is not supported for that entity. Remove the RibbonDiffXml node from the entity definition and try to import again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F104</ErrorId>
<ManagedErrorName>RibbonImportDependencyMissingEntity</ManagedErrorName>
<ErrorMessage>The ribbon item '{0}' is dependent on entity {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F105</ErrorId>
<ManagedErrorName>RibbonImportDependencyMissingRibbonElement</ManagedErrorName>
<ErrorMessage>The ribbon item '{0}' is dependent on &lt;{1} Id="{2}" /&gt;.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F106</ErrorId>
<ManagedErrorName>RibbonImportDependencyMissingWebResource</ManagedErrorName>
<ErrorMessage>The ribbon item '{0}' is dependent on Web resource id='{1}'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F107</ErrorId>
<ManagedErrorName>RibbonImportDependencyMissingRibbonControl</ManagedErrorName>
<ErrorMessage>The ribbon item '{0}' is dependent on ribbon control id='{1}'.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F108</ErrorId>
<ManagedErrorName>RibbonImportModifyingTopLevelNode</ManagedErrorName>
<ErrorMessage>Ribbon customizations cannot be made to the following top-level ribbon nodes: &lt;Ribbon&gt;, &lt;ContextualGroups&gt;, and &lt;Tabs&gt;.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F109</ErrorId>
<ManagedErrorName>RibbonImportLocationAndIdDoNotMatch</ManagedErrorName>
<ErrorMessage>CustomAction Id '{0}' cannot override '{1}' because '{2}' does not match the CustomAction Location value.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F10A</ErrorId>
<ManagedErrorName>RibbonImportHidingJewel</ManagedErrorName>
<ErrorMessage>Ribbon customizations cannot hide the &lt;Jewel&gt; node. Any ribbon customization that hides this node is ignored during import and will not be exported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F10B</ErrorId>
<ManagedErrorName>RibbonImportDuplicateElementId</ManagedErrorName>
<ErrorMessage>The ribbon element with the Id:{0} cannot be imported because an existing ribbon element with the same Id already exists.</ErrorMessage>
</crmerror>
<!-- See comments above, create your own section! -->
<!-- WebResources related errors: 8004F111 - 8004F11F-->
<crmerror>
<ErrorId>8004F111</ErrorId>
<ManagedErrorName>WebResourceInvalidType</ManagedErrorName>
<ErrorMessage>Invalid web resource type specified.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F112</ErrorId>
<ManagedErrorName>WebResourceEmptySilverlightVersion</ManagedErrorName>
<ErrorMessage>Silverlight version cannot be empty for silverlight web resources.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F113</ErrorId>
<ManagedErrorName>WebResourceInvalidSilverlightVersion</ManagedErrorName>
<ErrorMessage>Silverlight version can only be of the format xx.xx[.xx.xx].</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F114</ErrorId>
<ManagedErrorName>WebResourceContentSizeExceeded</ManagedErrorName>
<ErrorMessage>Webresource content size is too big.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F115</ErrorId>
<ManagedErrorName>WebResourceDuplicateName</ManagedErrorName>
<ErrorMessage>A webresource with the same name already exists. Use a different name.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F116</ErrorId>
<ManagedErrorName>WebResourceEmptyName</ManagedErrorName>
<ErrorMessage>Webresource name cannot be null or empty.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F117</ErrorId>
<ManagedErrorName>WebResourceNameInvalidCharacters</ManagedErrorName>
<ErrorMessage>Web resource names may only include letters, numbers, periods, and nonconsecutive forward slash characters.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F118</ErrorId>
<ManagedErrorName>WebResourceNameInvalidPrefix</ManagedErrorName>
<ErrorMessage>Webresource name does not contain a valid prefix.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F119</ErrorId>
<ManagedErrorName>WebResourceNameInvalidFileExtension</ManagedErrorName>
<ErrorMessage>A Web resource cannot have the following file extensions: .aspx, .ascx, .asmx or .ashx.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F11A</ErrorId>
<ManagedErrorName>WebResourceImportMissingFile</ManagedErrorName>
<ErrorMessage>The file for this Web resource does not exist in the solution file.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F11B</ErrorId>
<ManagedErrorName>WebResourceImportError</ManagedErrorName>
<ErrorMessage>An error occurred while importing a Web resource. Try importing this solution again. For further assistance, contact Microsoft Dynamics CRM technical support.</ErrorMessage>
</crmerror>
<!-- See comments above, create your own section! -->
<!-- Custom Activities related errors: 8004F120 - 8004F140 -->
<crmerror>
<ErrorId>8004F120</ErrorId>
<ManagedErrorName>InvalidActivityOwnershipTypeMask</ManagedErrorName>
<ErrorMessage>A custom entity defined as an activity must be user or team owned.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F121</ErrorId>
<ManagedErrorName>ActivityCannotHaveRelatedActivities</ManagedErrorName>
<ErrorMessage>A custom entity defined as an activity must not have a relationship with Activities.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F122</ErrorId>
<ManagedErrorName>CustomActivityMustHaveOfflineAvailability</ManagedErrorName>
<ErrorMessage>A custom entity defined as an activity must have Offline Availability.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F123</ErrorId>
<ManagedErrorName>ActivityMustHaveRelatedNotes</ManagedErrorName>
<ErrorMessage>A custom entity defined as an activity must have a relationship to Notes by default.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F124</ErrorId>
<ManagedErrorName>CustomActivityCannotBeMailMergeEnabled</ManagedErrorName>
<ErrorMessage>A custom entity defined as an activity already cannot have MailMerge enabled.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F125</ErrorId>
<ManagedErrorName>InvalidCustomActivityType</ManagedErrorName>
<ErrorMessage>A custom entity defined as an activity must be of communicaton activity type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F126</ErrorId>
<ManagedErrorName>ActivityMetadataUpdate</ManagedErrorName>
<ErrorMessage>The metadata specified for activity is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F127</ErrorId>
<ManagedErrorName>InvalidPrimaryFieldForActivity</ManagedErrorName>
<ErrorMessage>A custom entity defined as an activity cannot have primary attribute other than subject.</ErrorMessage>
</crmerror>
<!-- See comments above, create your own section! -->
<!-- UI Script related errors: 8004F200 - 8004F300 -->
<crmerror>
<ErrorId>8004F200</ErrorId>
<ManagedErrorName>CannotDeleteNonLeafNode</ManagedErrorName>
<ErrorMessage>Only a leaf statement can be deleted. This statement is parenting some other statement.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F201</ErrorId>
<ManagedErrorName>DuplicateUIStatementRootsFound</ManagedErrorName>
<ErrorMessage>There can be only one root statement for a given uiscript.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F202</ErrorId>
<ManagedErrorName>ErrorUpdateStatementTextIsReferenced</ManagedErrorName>
<ErrorMessage>You cannot update this UI script statement text because it is being referred to by one or more published ui scripts.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F203</ErrorId>
<ManagedErrorName>ErrorDeleteStatementTextIsReferenced</ManagedErrorName>
<ErrorMessage>You cannot delete the UI script statement text because it is being referred by one or more ui script statements.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F204</ErrorId>
<ManagedErrorName>ErrorScriptSessionCannotCreateForDraftScript</ManagedErrorName>
<ErrorMessage>You cannot create a UI script session for a UI script which is not published.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F205</ErrorId>
<ManagedErrorName>ErrorScriptSessionCannotUpdateForDraftScript</ManagedErrorName>
<ErrorMessage>You cannot update a UI script session for a UI script which is not published.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F206</ErrorId>
<ManagedErrorName>ErrorScriptLanguageNotInstalled</ManagedErrorName>
<ErrorMessage>The language specified is not supported in your CRM install. Please check with your system administrator on the list of "enabled" languages.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F207</ErrorId>
<ManagedErrorName>ErrorScriptInitialStatementNotInScript</ManagedErrorName>
<ErrorMessage>The initial statement for this script does not belong to this script.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F208</ErrorId>
<ManagedErrorName>ErrorScriptInitialStatementNotRoot</ManagedErrorName>
<ErrorMessage>The initial statement should the root statement and cannot have a previous statement set.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F209</ErrorId>
<ManagedErrorName>ErrorScriptCannotDeletePublishedScript</ManagedErrorName>
<ErrorMessage>You cannot delete a UI script that is published. You must unpublish it first.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F20A</ErrorId>
<ManagedErrorName>ErrorScriptPublishMissingInitialStatement</ManagedErrorName>
<ErrorMessage>The selected UI script cannot be published. Provide a value for "First statement number" and try to publish again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F20B</ErrorId>
<ManagedErrorName>ErrorScriptPublishMalformedScript</ManagedErrorName>
<ErrorMessage>The selected UI script cannot be published. The UI script contains one or more paths which do not end in an end-script or next-script action node. Correct the paths and try to publish again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F20C</ErrorId>
<ManagedErrorName>ErrorScriptUnpublishActiveScript</ManagedErrorName>
<ErrorMessage>This script is in use and has active sessions (status-reason=incomplete). Please terminate the active sessions (i.e. status-reason=cancelled) and try to unpublish again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F20D</ErrorId>
<ManagedErrorName>ErrorScriptSessionCannotSetStateForDraftScript</ManagedErrorName>
<ErrorMessage>You cannot set the state of a UI script session for a UI script which is not published.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F20E</ErrorId>
<ManagedErrorName>ErrorScriptStatementResponseTypeOnlyForPrompt</ManagedErrorName>
<ErrorMessage>You cannot associate the response control type for a statement which is not a prompt.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F20F</ErrorId>
<ManagedErrorName>ErrorStatementOnlyForDraftScript</ManagedErrorName>
<ErrorMessage>You cannot create a UI script statement for a UI script which is not draft.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F210</ErrorId>
<ManagedErrorName>ErrorStatementDeleteOnlyForDraftScript</ManagedErrorName>
<ErrorMessage>You cannot delete a UI script statement for a UI script which is not draft.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F211</ErrorId>
<ManagedErrorName>ErrorInvalidUIScriptImportFile</ManagedErrorName>
<ErrorMessage>File type is not supported. Select an xml file for import.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F212</ErrorId>
<ManagedErrorName>ErrorScriptFileParse</ManagedErrorName>
<ErrorMessage>Error occurred while parsing the XML file.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F213</ErrorId>
<ManagedErrorName>ErrorScriptCannotUpdatePublishedScript</ManagedErrorName>
<ErrorMessage>You cannot update a UI script that is published. You must unpublish it first.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F214</ErrorId>
<ManagedErrorName>ErrorInvalidFileNameChars</ManagedErrorName>
<ErrorMessage>The Microsoft Excel file name cannot contain the following characters: *  \ : > &lt; | ? " /. Rename the file using valid characters, and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F215</ErrorId>
<ManagedErrorName>ErrorMimeTypeNullOrEmpty</ManagedErrorName>
<ErrorMessage>The MimeType property value of the UploadFromBase64DataUIScriptRequest method is null or empty. Specify a valid property value, and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F216</ErrorId>
<ManagedErrorName>ErrorImportInvalidForPublishedScript</ManagedErrorName>
<ErrorMessage>You cannot save data to a published UI script. Unpublish the UI script, and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F217</ErrorId>
<ManagedErrorName>UIScriptIdentifierDuplicate</ManagedErrorName>
<ErrorMessage>A variable or input argument with the same name already exists. Choose a different name, and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F218</ErrorId>
<ManagedErrorName>UIScriptIdentifierInvalid</ManagedErrorName>
<ErrorMessage>The variable or input argument name is invalid. The name can only contain '_', numerical, and alphabetical characters. Choose a different name, and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F219</ErrorId>
<ManagedErrorName>UIScriptIdentifierInvalidLength</ManagedErrorName>
<ErrorMessage>The variable or input argument name is too long. Choose a smaller name, and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F220</ErrorId>
<ManagedErrorName>ErrorNoQueryData</ManagedErrorName>
<ErrorMessage>An error has occurred. Either the data does not exist or you do not have sufficient privileges to view the data. Contact your system administrator for help.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F221</ErrorId>
<ManagedErrorName>ErrorUIScriptPromptMissing</ManagedErrorName>
<ErrorMessage>The dialog that is being activated has no prompt/response.</ErrorMessage>
</crmerror>
<!-- See comments above, create your own section! -->
<!-- SharePoint errors: 8004F301 - 8004F400 -->
<crmerror>
<ErrorId>8004F301</ErrorId>
<ManagedErrorName>SharePointUrlHostValidator</ManagedErrorName>
<ErrorMessage>The URL cannot be resolved into an IP.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F302</ErrorId>
<ManagedErrorName>SharePointCrmDomainValidator</ManagedErrorName>
<ErrorMessage>The SharePoint and Microsoft Dynamics CRM Servers are on different domains. Please ensure a trust relationship between the two domains.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F303</ErrorId>
<ManagedErrorName>SharePointServerDiscoveryValidator</ManagedErrorName>
<ErrorMessage>The URL is incorrect or the site is not running.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F304</ErrorId>
<ManagedErrorName>SharePointServerVersionValidator</ManagedErrorName>
<ErrorMessage>The SharePoint Site Collection must be running a supported version of Microsoft Office SharePoint Server or Microsoft Windows SharePoint Services. Please refer the implementation guide.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F305</ErrorId>
<ManagedErrorName>SharePointSiteCollectionIsAccessibleValidator</ManagedErrorName>
<ErrorMessage>The URL is incorrect or the site is not running.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F306</ErrorId>
<ManagedErrorName>SharePointUrlIsRootWebValidator</ManagedErrorName>
<ErrorMessage>The URL is not valid. The URL must be a valid site collection and cannot include a subsite. The URL must be in a valid form, such as http://SharePointServer/sites/CrmSite.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F307</ErrorId>
<ManagedErrorName>SharePointSitePermissionsValidator</ManagedErrorName>
<ErrorMessage>The current user does not have the appropriate privileges. You must be a SharePoint site administrator on the SharePoint site.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F308</ErrorId>
<ManagedErrorName>SharePointServerLanguageValidator</ManagedErrorName>
<ErrorMessage>Microsoft Dynamics CRM and Microsoft Office SharePoint Server must have the same base language.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F309</ErrorId>
<ManagedErrorName>SharePointCrmGridIsInstalledValidator</ManagedErrorName>
<ErrorMessage>The Microsoft Dynamics CRM Grid component must be installed on the SharePoint server. This component is required for SharePoint integration to work correctly.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F310</ErrorId>
<ManagedErrorName>SharePointErrorRetrieveAbsoluteUrl</ManagedErrorName>
<ErrorMessage>An error occurred while retrieving the absolute and site collection url for a SharePoint object.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F311</ErrorId>
<ManagedErrorName>SharePointInvalidEntityForValidation</ManagedErrorName>
<ErrorMessage>Entity Does not support SharePoint Url Validation.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F312</ErrorId>
<ManagedErrorName>DocumentManagementIsDisabled</ManagedErrorName>
<ErrorMessage>Document Management is not enabled for this Organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F313</ErrorId>
<ManagedErrorName>DocumentManagementNotEnabledNoPrimaryField</ManagedErrorName>
<ErrorMessage>Document management could not be enabled because a primary field is not defined for this entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F314</ErrorId>
<ManagedErrorName>SharePointErrorAbsoluteUrlClipped</ManagedErrorName>
<ErrorMessage>The URL exceeds the maximum number of 256 characters. Use shorter names for sites and folders, and try again.</ErrorMessage>
</crmerror>
<!-- Sitemap SDK errors: 8004F401 - 8004F40F -->
<crmerror>
<ErrorId>8004F401</ErrorId>
<ManagedErrorName>SiteMapXsdValidationError</ManagedErrorName>
<ErrorMessage>Sitemap xml failed XSD validation with the following error: '{0}' at line {1} position {2}.</ErrorMessage>
</crmerror>
<!-- Field Level Security errors: 8004F501 - 8004F51F -->
<crmerror>
<ErrorId>8004F501</ErrorId>
<ManagedErrorName>CannotSecureAttribute</ManagedErrorName>
<ErrorMessage>The field '{0}' is not securable</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F502</ErrorId>
<ManagedErrorName>AttributePrivilegeCreateIsMissing</ManagedErrorName>
<ErrorMessage>The user does not have create permissions to a secured field. The requested operation could not be completed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F503</ErrorId>
<ManagedErrorName>AttributePermissionUpdateIsMissingDuringShare</ManagedErrorName>
<ErrorMessage>The user does not have update permissions to a secured field. The requested operation could not be completed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F504</ErrorId>
<ManagedErrorName>AttributePermissionReadIsMissing</ManagedErrorName>
<ErrorMessage>The user does not have read permissions to a secured field. The requested operation could not be completed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F505</ErrorId>
<ManagedErrorName>CannotRemoveSysAdminProfileFromSysAdminUser</ManagedErrorName>
<ErrorMessage>The Sys Admin Profile cannot be removed from a user with a Sys Admin Role</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F506</ErrorId>
<ManagedErrorName>QueryContainedSecuredAttributeWithoutAccess</ManagedErrorName>
<ErrorMessage>The Query contained a secured attribute to which the caller does not have access</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F507</ErrorId>
<ManagedErrorName>AttributePermissionUpdateIsMissingDuringUpdate</ManagedErrorName>
<ErrorMessage>The user doesn't have AttributePrivilegeUpdate and not granted shared access for a secured attribute during update operation</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F508</ErrorId>
<ManagedErrorName>AttributeNotSecured</ManagedErrorName>
<ErrorMessage>One or more fields are not enabled for field level security. Field level security is not enabled until you publish the customizations.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F509</ErrorId>
<ManagedErrorName>AttributeSharingCreateShouldSetReadOrAndUpdateAccess</ManagedErrorName>
<ErrorMessage>You must set read and/or update access when you share a secured attribute. Attribute ID: {0}</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F50A</ErrorId>
<ManagedErrorName>AttributeSharingUpdateInvalid</ManagedErrorName>
<ErrorMessage>Both readAccess and updateAccess are false: call Delete instead of Update.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F50B</ErrorId>
<ManagedErrorName>AttributeSharingCreateDuplicate</ManagedErrorName>
<ErrorMessage>Attribute has already been shared.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F50C</ErrorId>
<ManagedErrorName>AdminProfileCannotBeEditedOrDeleted</ManagedErrorName>
<ErrorMessage>The System Administrator field security profile cannot be modified or deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F50D</ErrorId>
<ManagedErrorName>AttributePrivilegeInvalidToUnsecure</ManagedErrorName>
<ErrorMessage>You must have sufficient permissions for a secured field before you can change its field level security.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F50E</ErrorId>
<ManagedErrorName>AttributePermissionIsInvalid</ManagedErrorName>
<ErrorMessage>Permission '{0}' for field '{1}' with id={2} is invalid.</ErrorMessage>
</crmerror>
<!-- Update Via Import errors: 8004F600 - 8004F609 -->
<crmerror>
<ErrorId>8004F600</ErrorId>
<ManagedErrorName>RequireValidImportMapForUpdate</ManagedErrorName>
<ErrorMessage>The update operation cannot be completed because the import map used for the update is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F601</ErrorId>
<ManagedErrorName>InvalidFormatForUpdateMode</ManagedErrorName>
<ErrorMessage>The file that you uploaded is invalid and cannot be used for updating records.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F602</ErrorId>
<ManagedErrorName>MaximumCountForUpdateModeExceeded</ManagedErrorName>
<ErrorMessage>In an update operation, you can import only one file at a time.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F603</ErrorId>
<ManagedErrorName>RecordResolutionFailed</ManagedErrorName>
<ErrorMessage>The record could not be updated because the original record no longer exists in Microsoft Dynamics CRM.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F701</ErrorId>
<ManagedErrorName>InvalidOperationForDynamicList</ManagedErrorName>
<ErrorMessage>This action is not available for a dynamic marketing list.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F702</ErrorId>
<ManagedErrorName>QueryNotValidForStaticList</ManagedErrorName>
<ErrorMessage>Query cannot be specified for a static list.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F703</ErrorId>
<ManagedErrorName>LockStatusNotValidForDynamicList</ManagedErrorName>
<ErrorMessage>Lock Status cannot be specified for a dynamic list.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F704</ErrorId>
<ManagedErrorName>CannotCopyStaticList</ManagedErrorName>
<ErrorMessage>This action is valid only for dynamic list.</ErrorMessage>
</crmerror>
<!-- SystemForm errors: 8004F651 - 8004F670 -->
<crmerror>
<ErrorId>8004F652</ErrorId>
<ManagedErrorName>CannotDeleteSystemForm</ManagedErrorName>
<ErrorMessage>System forms cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F653</ErrorId>
<ManagedErrorName>CannotUpdateSystemEntityIcons</ManagedErrorName>
<ErrorMessage>System entity icons cannot be updated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F654</ErrorId>
<ManagedErrorName>FallbackFormDeletion</ManagedErrorName>
<ErrorMessage>You cannot delete this form because it is the only fallback form of type {0} for the {1} entity. Each entity must have at least one fallback form for each form type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F655</ErrorId>
<ManagedErrorName>SystemFormImportMissingRoles</ManagedErrorName>
<ErrorMessage>The unmanaged solution you are importing has displaycondition XML attributes that refer to security roles that are missing from the target system. Any displaycondition attributes that refer to these security roles will be removed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F656</ErrorId>
<ManagedErrorName>SystemFormCopyUnmatchedEntity</ManagedErrorName>
<ErrorMessage>The entity for the Target and the SourceId must match.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F657</ErrorId>
<ManagedErrorName>SystemFormCopyUnmatchedFormType</ManagedErrorName>
<ErrorMessage>The form type of the SourceId is not valid for the Target entity.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F658</ErrorId>
<ManagedErrorName>SystemFormCreateWithExistingLabel</ManagedErrorName>
<ErrorMessage>The label '{0}', id: '{1}' already exists. Supply unique labelid values.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F659</ErrorId>
<ManagedErrorName>QuickFormNotCustomizableThroughSdk</ManagedErrorName>
<ErrorMessage>The SDK does not support creating a form of type "Quick". This form type is reserved for internal use only.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F660</ErrorId>
<ManagedErrorName>InvalidDeactivateFormType</ManagedErrorName>
<ErrorMessage>You can’t deactivate {0} forms. Only Main forms can be inactive.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F661</ErrorId>
<ManagedErrorName>FallbackFormDeactivation</ManagedErrorName>
<ErrorMessage>This operation can’t be completed. You must have at least one active Main form.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F662</ErrorId>
<ManagedErrorName>DeprecatedFormActivation</ManagedErrorName>
<ErrorMessage>This form has been deprecated in the previous release and cannot be used anymore. Please migrate your changes to a different form. Deprecated forms will be removed from the system in the future.</ErrorMessage>
</crmerror>

<!-- Generic Ribbon errors: 8004F671 - 8004F680 -->
<crmerror>
<ErrorId>8004F671</ErrorId>
<ManagedErrorName>RuntimeRibbonXmlValidation</ManagedErrorName>
<ErrorMessage>The most recent customized ribbon for a tab on this page cannot be generated. The out-of-box version of the ribbon is displayed instead.</ErrorMessage>
</crmerror>

<!-- Field level security Biz Modules:errors: 8004F800 - 8004F809 -->
<crmerror>
<ErrorId>8004F800</ErrorId>
<ManagedErrorName>InitializeErrorNoReadOnSource</ManagedErrorName>
<ErrorMessage>The operation could not be completed because you donot have read access on some of the fields in {0} record.</ErrorMessage>
</crmerror>

<!-- Errors related to sales goal management 8004F681 - 8004F700 -->
<crmerror>
<ErrorId>8004F681</ErrorId>
<ManagedErrorName>NoRollupAttributesDefined</ManagedErrorName>
<ErrorMessage>For rollup to succeed atleast one rollup attribute needs to be associated with the goal metric</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F682</ErrorId>
<ManagedErrorName>GoalPercentageAchievedValueOutOfRange</ManagedErrorName>
<ErrorMessage>The percentage achieved value has been set to 0 because the calculated value is not in the allowed range.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F683</ErrorId>
<ManagedErrorName>InvalidRollupQueryAttributeSet</ManagedErrorName>
<ErrorMessage>A Rollup Query cannot be set for a Rollup Field that is not defined in the Goal Metric.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F684</ErrorId>
<ManagedErrorName>InvalidGoalManager</ManagedErrorName>
<ErrorMessage>The manager of a goal can only be a user and not a team.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F685</ErrorId>
<ManagedErrorName>InactiveRollupQuerySetOnGoal</ManagedErrorName>
<ErrorMessage>An inactive rollup query cannot be set on a goal.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F686</ErrorId>
<ManagedErrorName>InactiveMetricSetOnGoal</ManagedErrorName>
<ErrorMessage>An inactive metric cannot be set on a goal.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F687</ErrorId>
<ManagedErrorName>MetricEntityOrFieldDeleted</ManagedErrorName>
<ErrorMessage>The entity or field that is referenced in the goal metric is not valid</ErrorMessage>
</crmerror>
<!-- Errors related to activity feed 8004F6A0 - 8004F6Af-->
<!-- Errors related to activity feed 8004F700 - 8004F70f-->

<!-- Errors related to language provisioning 8004F710 - 8004F720-->
<crmerror>
<ErrorId>8004F6A0</ErrorId>
<ManagedErrorName>ExceededNumberOfRecordsCanFollow</ManagedErrorName>
<ErrorMessage>You have exceeded the number of records you can follow. Please unfollow some records to start following again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F6A1</ErrorId>
<ManagedErrorName>EntityIsNotEnabledForFollowUser</ManagedErrorName>
<ErrorMessage>This entity is not enabled to be followed. </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F6A2</ErrorId>
<ManagedErrorName>EntityIsNotEnabledForFollow</ManagedErrorName>
<ErrorMessage>This entity is not enabled to be followed. </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F6A3</ErrorId>
<ManagedErrorName>CannotFollowInactiveEntity</ManagedErrorName>
<ErrorMessage>Can't follow inactive record. </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F6A4</ErrorId>
<ManagedErrorName>MustContainAtLeastACharInMention</ManagedErrorName>
<ErrorMessage>The display name must contain atleast one non-whitespace character.</ErrorMessage>
</crmerror>
<!-- Errors related to activity feed 8004F700 - 8004F70f-->

<!-- Errors related to language provisioning 8004F710 - 8004F720-->
<crmerror>
<ErrorId>8004F710</ErrorId>
<ManagedErrorName>LanguageProvisioningSrsDataConnectorNotInstalled</ManagedErrorName>
<ErrorMessage>The Microsoft Dynamics CRM Reporting Extensions must be installed before the language can be provisioned for this organization.</ErrorMessage>
</crmerror>
<!-- Fetch based reports related errors: 8005E000 - 8005E0FF -->
<crmerror>
<ErrorId>8005E000</ErrorId>
<ManagedErrorName>BidsInvalidConnectionString</ManagedErrorName>
<ErrorMessage>Input connection string is invalid. Usage: ServerUrl[;OrganizationName][;HomeRealmUrl]</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E001</ErrorId>
<ManagedErrorName>BidsInvalidUrl</ManagedErrorName>
<ErrorMessage>Input url {0} is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E002</ErrorId>
<ManagedErrorName>BidsServerConnectionFailed</ManagedErrorName>
<ErrorMessage>Failed to connect to server {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E003</ErrorId>
<ManagedErrorName>BidsAuthenticationError</ManagedErrorName>
<ErrorMessage>An error occured while authenticating with server {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E004</ErrorId>
<ManagedErrorName>BidsNoOrganizationsFound</ManagedErrorName>
<ErrorMessage>No organizations found for the user.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E005</ErrorId>
<ManagedErrorName>BidsOrganizationNotFound</ManagedErrorName>
<ErrorMessage>Organization {0} cannot be found for the user.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E006</ErrorId>
<ManagedErrorName>BidsAuthenticationFailed</ManagedErrorName>
<ErrorMessage>Authentication failed when trying to connect to server {0}. The username or password is incorrect.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E007</ErrorId>
<ManagedErrorName>TransactionNotSupported</ManagedErrorName>
<ErrorMessage>The operation that you are trying to perform does not support transactions.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E008</ErrorId>
<ManagedErrorName>IndexOutOfRange</ManagedErrorName>
<ErrorMessage>The index {0} is out of range for {1}. Number of elements present are {2}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E009</ErrorId>
<ManagedErrorName>InvalidAttribute</ManagedErrorName>
<ErrorMessage>Attribute {0} cannot be found for entity {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E00A</ErrorId>
<ManagedErrorName>MultiValueParameterFound</ManagedErrorName>
<ErrorMessage>Fetch xml parameter {0} cannot obtain multiple values. Change report parameter {0} to single value parameter and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E00B</ErrorId>
<ManagedErrorName>QueryParameterNotUnique</ManagedErrorName>
<ErrorMessage>Query parameter {0} must be defined only once within the data set.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E00C</ErrorId>
<ManagedErrorName>InvalidEntity</ManagedErrorName>
<ErrorMessage>Entity {0} cannot be found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E00D</ErrorId>
<ManagedErrorName>UnsupportedAttributeType</ManagedErrorName>
<ErrorMessage>Attribute type {0} is not supported. Remove attribute {1} from the query and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E00E</ErrorId>
<ManagedErrorName>FetchDataSetQueryTimeout</ManagedErrorName>
<ErrorMessage>The fetch data set query timed out after {0} seconds. Increase the query timeout, and try again.</ErrorMessage>
</crmerror>
<!-- End fetch based reports related errors: 8005E000 - 8005E0FF -->
<!-- Sales Refresh related errors: 8005E100 - 8005E1FF -->
<crmerror>
<ErrorId>8005E100</ErrorId>
<ManagedErrorName>InvalidCommand</ManagedErrorName>
<ErrorMessage>Invalid command.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E101</ErrorId>
<ManagedErrorName>InvalidDataXml</ManagedErrorName>
<ErrorMessage>Invalid data xml.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E102</ErrorId>
<ManagedErrorName>InvalidLanguageForProcessConfiguration</ManagedErrorName>
<ErrorMessage>Process configuration is not available since your language does not match system base language.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E103</ErrorId>
<ManagedErrorName>InvalidComplexControlId</ManagedErrorName>
<ErrorMessage>The complex control id is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E104</ErrorId>
<ManagedErrorName>InvalidProcessControlEntity</ManagedErrorName>
<ErrorMessage>The process control definition contains an invalid entity or invalid entity order.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E105</ErrorId>
<ManagedErrorName>InvalidProcessControlAttribute</ManagedErrorName>
<ErrorMessage>The process control definition contains an invalid attribute.</ErrorMessage>
</crmerror>
<!-- End Sales Refresh related errors: 8005E100 - 8005E1FF -->
<!-- Yammer related errors: 8005F100 - 8005F110 -->
<crmerror>
<ErrorId>8005F100</ErrorId>
<ManagedErrorName>BadRequest</ManagedErrorName>
<ErrorMessage>The request could not be understood by the server.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F101</ErrorId>
<ManagedErrorName>AccessTokenExpired</ManagedErrorName>
<ErrorMessage>The requested resource requires authentication.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F102</ErrorId>
<ManagedErrorName>Forbidden</ManagedErrorName>
<ErrorMessage>The server refuses to fulfill the request.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F103</ErrorId>
<ManagedErrorName>Throttling</ManagedErrorName>
<ErrorMessage>Too many requests.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F104</ErrorId>
<ManagedErrorName>NetworkIssue</ManagedErrorName>
<ErrorMessage>Request failed due to unknown network issues or GateWay issues or server issues.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F105</ErrorId>
<ManagedErrorName>CouldNotReadAccessToken</ManagedErrorName>
<ErrorMessage>The system was not able to read users Yammer access token although a non-empty code was passed.</ErrorMessage>
<!-- The above error might happen when the code would have expired or when another unknown error at Yammer's end
 would have happened. -->
</crmerror>
<crmerror>
<ErrorId>8005F106</ErrorId>
<ManagedErrorName>NotVerifiedAdmin</ManagedErrorName>
<ErrorMessage>You need an enterprise account with Yammer in order to complete this setup. Please sign in with a Yammer administrator account or contact a Yammer administrator for help.</ErrorMessage>
<!-- The above error will happen when the user is not a verified admin of the specified network to which they logged into -->
</crmerror>
<crmerror>
<ErrorId>8005F107</ErrorId>
<ManagedErrorName>YammerAuthTimedOut</ManagedErrorName>
<ErrorMessage>You have waited too long to complete the Yammer authorization. Please try again.</ErrorMessage>
<!-- The above error will happen when the user takes too long (over 10 mins approx) to complete the oauth process with Yammer. -->
</crmerror>
<crmerror>
<ErrorId>8005F108</ErrorId>
<ManagedErrorName>NoYammerNetworksFound</ManagedErrorName>
<ErrorMessage>You are not authorized for any Yammer network. Please reauthorize the Yammer setup with a Yammer administrator account or contact a Yammer administrator for help.</ErrorMessage>
<!-- The above error will happen when the user's OAuth token could not fetch any networks. This is a rare occurrence and would
happen when the user gets kicked out of the network right after they complete the OAuth process -->
</crmerror>
<crmerror>
<ErrorId>8005F109</ErrorId>
<ManagedErrorName>OAuthTokenNotFound</ManagedErrorName>
<ErrorMessage>Yammer OAuth token is not found. You should configure Yammer before accessing any related feature.</ErrorMessage>
<!-- The above error will happen when a code path is encountered that tries to use Yammer OAuth token even before Yammer is configured. -->
</crmerror>
<crmerror>
<ErrorId>8005F110</ErrorId>
<ManagedErrorName>CouldNotDecryptOAuthToken</ManagedErrorName>
<ErrorMessage>Yammer OAuth token could not be decrypted. Please try to reconfigure Yammer once again.</ErrorMessage>
<!-- The above error will happen when the system fails to decrypt the Yammer token stored. The only remedy at this point is to reauthorize Yammer. -->
</crmerror>
<crmerror>
<ErrorId>8005F111</ErrorId>
<ManagedErrorName>UserNeverLoggedIntoYammer</ManagedErrorName>
<ErrorMessage>To follow other users, you must be logged in to Yammer. Log in to your Yammer account, and try again.</ErrorMessage>
<!-- The above error will happen when the user tries to follow without ever logging into Yammer -->
</crmerror>
<!-- End Yammer related errors -->

<!-- Business Rule(PBL) related errors: 80060000 - 80060013 -->
<crmerror>
<ErrorId>80060000</ErrorId>
<ManagedErrorName>StepNotSupportedForClientBusinessRule</ManagedErrorName>
<ErrorMessage>Step {0} is not supported for client side business rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060001</ErrorId>
<ManagedErrorName>EventNotSupportedForBusinessRule</ManagedErrorName>
<ErrorMessage>Event {0} is not supported for client side business rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060002</ErrorId>
<ManagedErrorName>CannotUpdateTriggerForPublishedRules</ManagedErrorName>
<ErrorMessage>A trigger cannot be added/deleted/updated for a published rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060003</ErrorId>
<ManagedErrorName>EventTypeAndControlNameAreMismatched</ManagedErrorName>
<ErrorMessage>This combination of event type and control name is unexpected</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060004</ErrorId>
<ManagedErrorName>ExpressionNotSupportedForEditor</ManagedErrorName>
<ErrorMessage>Rule contain an expression that is not supported by the editor.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060005</ErrorId>
<ManagedErrorName>EditorOnlySupportAndOperatorForLogicalConditions</ManagedErrorName>
<ErrorMessage>The rule expression contains logical operator which is not supported. The editor only support And operator for Logical conditions.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060006</ErrorId>
<ManagedErrorName>UnexpectedRightOperandCount</ManagedErrorName>
<ErrorMessage>The right operand array in the expression contain unexpected no. of operand.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060007</ErrorId>
<ManagedErrorName>RuleNotSupportedForEditor</ManagedErrorName>
<ErrorMessage>The current rule definition cannot be edited in the Business rule editor.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060008</ErrorId>
<ManagedErrorName>BusinessRuleEditorSupportsOnlyIfConditionBranch</ManagedErrorName>
<ErrorMessage>The business rule editor only supports one if condition. Please fix the rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060009</ErrorId>
<ManagedErrorName>UnsupportedStepForBusinessRuleEditor</ManagedErrorName>
<ErrorMessage>The rule contain a step which is not supported by the editor.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060010</ErrorId>
<ManagedErrorName>UnsupportedAttributeForEditor</ManagedErrorName>
<ErrorMessage>The rule contain an attribute which is not supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060011</ErrorId>
<ManagedErrorName>ExpectingAtLeastOneBusinessRuleStep</ManagedErrorName>
<ErrorMessage>There should be a minimum of one Business rule step.</ErrorMessage>
</crmerror>
  <crmerror>
    <ErrorId>80060012</ErrorId>
    <ManagedErrorName>RuleCreationNotAllowedForCyclicReferences</ManagedErrorName>
    <ErrorMessage>You can't create this rule because it contains a cyclical reference. Fix the rule and try again.</ErrorMessage>
  </crmerror>
  <crmerror>
    <ErrorId>80060013</ErrorId>
    <ManagedErrorName>NoConditionRuleCreationNotAllowedForSetValueShowError</ManagedErrorName>
    <ErrorMessage>The "Show error message" and "Set value" actions can't be used in a business rule that doesn't have a condition.</ErrorMessage>
  </crmerror>
<!-- End Business Rule(PBL) related errors: 80060000 - 80060013 -->

<!-- MultiEntitySearch related errors: 80060200 - 800603FF -->
<crmerror>
<ErrorId>80060200</ErrorId>
<ManagedErrorName>EntityLimitExceeded</ManagedErrorName>
<ErrorMessage>MultiEntitySearch exceeded Entity Limit defined for the Organization.</ErrorMessage>
<!-- The above error is thrown when the number of entities that participate in a multi entity search exceed the set limits. -->
</crmerror>
<crmerror>
<ErrorId>80060201</ErrorId>
<ManagedErrorName>InvalidSearchEntity</ManagedErrorName>
<ErrorMessage>Invalid Search Entity - {0}.</ErrorMessage>
<!-- The above error is thrown when the entity passed in is an invalid entity or does not have the search. -->
</crmerror>
<crmerror>
<ErrorId>80060202</ErrorId>
<ManagedErrorName>InvalidSearchEntities</ManagedErrorName>
<ErrorMessage>Search - {0} did not find any valid Entities.</ErrorMessage>
<!-- The above error is thrown when there are no valid entities that participate in a multi entity search. -->
</crmerror>
<crmerror>
<ErrorId>80060203</ErrorId>
<ManagedErrorName>NoQuickFindFound</ManagedErrorName>
<ErrorMessage>Entity - {0} did not have a valid Quickfind query.</ErrorMessage>
<!-- The above error is thrown when no quick find query is found for a given entity. -->
</crmerror>
<crmerror>
<ErrorId>80060204</ErrorId>
<ManagedErrorName>InvalidSearchName</ManagedErrorName>
<ErrorMessage>Invalid Search Name - {0}.</ErrorMessage>
<!-- The above error is thrown when the Search Name passed in is invalid. -->
</crmerror>
<crmerror>
<ErrorId>80060205</ErrorId>
<ManagedErrorName>EntityGroupNameOrEntityNamesMustBeProvided</ManagedErrorName>
<ErrorMessage>Missing parameter. You must provide EntityGroupName or EntityNames.</ErrorMessage>
<!-- The above error is thrown when the Search Name passed in is invalid. -->
</crmerror>
<crmerror>
<ErrorId>80060206</ErrorId>
<ManagedErrorName>OnlyOneSearchParameterMustBeProvided</ManagedErrorName>
<ErrorMessage>Extra parameter. You only need to provide EntityGroupName or EntityNames, not both.</ErrorMessage>
<!-- The above error is thrown when the Search Name passed in is invalid. -->
</crmerror>
<!-- MultiEntitySearch related errors: 80060200 - 800603FF -->

<!-- Business Process Flow (BPF) related errors: 80060399 - 80060421 -->
<crmerror>
<ErrorId>80060399</ErrorId>
<ManagedErrorName>ProcessEmptyBranches</ManagedErrorName>
<ErrorMessage>This process contains empty branches. Define or delete these branches and try again.</ErrorMessage>
<!-- The above error is thrown when the  BPF doesn't contain branches-->
</crmerror>
<crmerror>
<ErrorId>80060400</ErrorId>
<ManagedErrorName>WorkflowIdIsNull</ManagedErrorName>
<ErrorMessage>Workflow Id cannot be NULL while creating business process flow category</ErrorMessage>
<!-- The above error is thrown when the WorkflowId attribute is NULL -->
</crmerror>
<crmerror>
<ErrorId>80060401</ErrorId>
<ManagedErrorName>PrimaryEntityIsNull</ManagedErrorName>
<ErrorMessage>Primary Entity cannot be NULL while creating business process flow category</ErrorMessage>
<!-- The above error is thrown when the PrimaryEntity attribute is NULL -->
</crmerror>
<crmerror>
<ErrorId>80060402</ErrorId>
<ManagedErrorName>TypeNotSetToDefinition</ManagedErrorName>
<ErrorMessage>Type should be set to Definition while creating business process flow category</ErrorMessage>
<!-- The above error is thrown when Type is not set to Definition -->
</crmerror>
<crmerror>
<ErrorId>80060403</ErrorId>
<ManagedErrorName>ScopeNotSetToGlobal</ManagedErrorName>
<ErrorMessage>Scope should be set to Global while creating business process flow category</ErrorMessage>
<!-- The above error is thrown when Scope is not set to global -->
</crmerror>
<crmerror>
<ErrorId>80060404</ErrorId>
<ManagedErrorName>CategoryNotSetToBusinessProcessFlow</ManagedErrorName>
<ErrorMessage>Category should be set to BusinessProcessFlow while creating business process flow category</ErrorMessage>
<!-- The above error is thrown when the Category is not set to Business Process Flow -->
</crmerror>
<crmerror>
<ErrorId>80060405</ErrorId>
<ManagedErrorName>BusinessProcessFlowStepHasInvalidParent</ManagedErrorName>
<ErrorMessage>{0} parent is not of type {1}</ErrorMessage>
<!-- The above error is thrown when  parent of a step in OM is not of the expected type -->
</crmerror>
<crmerror>
<ErrorId>80060406</ErrorId>
<ManagedErrorName>NullOrEmptyAttributeInXaml</ManagedErrorName>
<ErrorMessage>Attribute - {0} of {1} cannot be null or empty</ErrorMessage>
<!-- The above error is thrown when a required attrbute in XAML is null or empty -->
</crmerror>
<crmerror>
<ErrorId>80060407</ErrorId>
<ManagedErrorName>InvalidGuidInXaml</ManagedErrorName>
<ErrorMessage>Guid - {0} in the Xaml is not valid</ErrorMessage>
<!-- The above error is thrown when XAML have an invalid Guid -->
</crmerror>
<crmerror>
<ErrorId>80060408</ErrorId>
<ManagedErrorName>NoLabelsAssociatedWithStep</ManagedErrorName>
<ErrorMessage>{0} does not have any labels associated with it</ErrorMessage>
<!-- The above error is thrown when there is no label associated with a step -->
</crmerror>
<crmerror>
<ErrorId>80060409</ErrorId>
<ManagedErrorName>StepStepDoesNotHaveAnyControlStepAsItsChildren</ManagedErrorName>
<ErrorMessage>StepStep does not have any ControlStep as its children</ErrorMessage>
<!-- The above error is thrown when StepStep does not have any ControlStep as its children -->
</crmerror>
<crmerror>
<ErrorId>80060410</ErrorId>
<ManagedErrorName>InvalidXmlForParameters</ManagedErrorName>
<ErrorMessage>Parameters node for ControlStep have invalid XML in it</ErrorMessage>
<!-- The above error is thrown when parameters node in controlstep have invalid XML in it -->
</crmerror>
<crmerror>
<ErrorId>80060411</ErrorId>
<ManagedErrorName>ControlIdIsNotUnique</ManagedErrorName>
<ErrorMessage>Control id {0} in the Xaml is not unique</ErrorMessage>
<!-- The above error is thrown when controlid in the XAML is not unique -->
</crmerror>
<crmerror>
<ErrorId>80060412</ErrorId>
<ManagedErrorName>InvalidAttributeInXaml</ManagedErrorName>
<ErrorMessage>Attribute - {0} in the XAML is invalid</ErrorMessage>
<!-- The above error is thrown when XAML contains an invalid attribute -->
</crmerror>
<crmerror>
<ErrorId>80060413</ErrorId>
<ManagedErrorName>AttributeCannotBeUpdated</ManagedErrorName>
<ErrorMessage>Attribute - {0} cannot be updated for a Business Process Flow</ErrorMessage>
<!-- The above error is thrown when user tries to update an attribute that cannot be updated -->
</crmerror>
<crmerror>
<ErrorId>80060414</ErrorId>
<ManagedErrorName>StepCountInXamlExceedsMaxAllowed</ManagedErrorName>
<ErrorMessage>There are {0} {1} in the Xaml. Max allowed is {2}.</ErrorMessage>
<!-- The above error is thrown when count of a step in Xaml exceeds the max allowed -->
</crmerror>
<crmerror>
<ErrorId>80060415</ErrorId>
<ManagedErrorName>EntitiesExceedMaxAllowed</ManagedErrorName>
<ErrorMessage>You can't cover more than five entities in a process flow. Remove some entities and try again.</ErrorMessage>
<!-- The above error is thrown when count of entities in BPF exceeds the max allowed -->
</crmerror>
<crmerror>
<ErrorId>80060416</ErrorId>
<ManagedErrorName>StepDoesNotHaveAnyChildInXaml</ManagedErrorName>
<ErrorMessage>{0} does not have at least one {1} as its child.</ErrorMessage>
<!-- The above error is thrown when a step does not have atleast one child in xaml -->
</crmerror>
<crmerror>
<ErrorId>80060417</ErrorId>
<ManagedErrorName>InvalidXaml</ManagedErrorName>
<ErrorMessage>XAML for workflow is NULL or Empty</ErrorMessage>
<!-- The above error is thrown when a workflow have a NULL or empty XAML -->
</crmerror>
<crmerror>
<ErrorId>80060418</ErrorId>
<ManagedErrorName>ProcessNameIsNullOrEmpty</ManagedErrorName>
<ErrorMessage>The business process flow name is NULL or empty. </ErrorMessage>
<!-- The above error is thrown when a BPF have a NULL or empty name -->
</crmerror>
<crmerror>
<ErrorId>80060419</ErrorId>
<ManagedErrorName>LabelIdDoesNotMatchStepId</ManagedErrorName>
<ErrorMessage>The label ID {0} doesn’t match the step ID {1}.</ErrorMessage>
<!-- The above error is thrown when a label in workflow does not match with the corresponding step id -->
</crmerror>
<crmerror>
<ErrorId>80060420</ErrorId>
<ManagedErrorName>EntityExceedsMaxActiveBusinessProcessFlows</ManagedErrorName>
<ErrorMessage>The {0} entity exceeds the maximum number of active business process flows. The limit is {1}.</ErrorMessage>
<!-- The above error is thrown when an entity exceeds the max number of active BPF allowed -->
</crmerror>
<crmerror>
<ErrorId>80060421</ErrorId>
<ManagedErrorName>EntityIsNotBusinessProcessFlowEnabled</ManagedErrorName>
<ErrorMessage>The IsBusinessProcessEnabled property of the {0} entity is false.</ErrorMessage>
<!-- The above error is thrown when an entity in BPF is not BPF enabled -->
</crmerror>
<!-- Ends Business Process Flow (BPF) related errors: 80060400 - 80060421 -->
<!-- Calculate Field related errors: 80060422 -80060437 -->
<crmerror>
<ErrorId>80060422</ErrorId>
<ManagedErrorName>CalculatedFieldsFeatureNotEnabled</ManagedErrorName>
<ErrorMessage>Calculated Field feature is not available</ErrorMessage>
<!-- The above error is thrown when user tries to use feature that is disabled -->
</crmerror>
<crmerror>
<ErrorId>80060423</ErrorId>
<ManagedErrorName>CalculatedFieldsInvalidEntity</ManagedErrorName>
<ErrorMessage>The formula contains an invalid reference: {0}.</ErrorMessage>
<!-- When an entity used in workflow is not valid -->
</crmerror>
<crmerror>
<ErrorId>80060424</ErrorId>
<ManagedErrorName>CalculatedFieldsInvalidXaml</ManagedErrorName>
<ErrorMessage>The {0} field has an invalid XAML formula definition.</ErrorMessage>
<!-- Used when there is not an error message to correctly describe the issue -->
</crmerror>
<crmerror>
<ErrorId>80060425</ErrorId>
<ManagedErrorName>CalculatedFieldsNonCalculatedFieldAssignment</ManagedErrorName>
<ErrorMessage>Only calculated fields can have a formula definition.</ErrorMessage>
<!-- Used when there is an attribute getting assigned other than the specific calculated field -->
</crmerror>
<crmerror>
<ErrorId>80060426</ErrorId>
<ManagedErrorName>CalculatedFieldsTypeMismatch</ManagedErrorName>
<ErrorMessage>You can't use {0}, which is of type {1}, with the current operator.</ErrorMessage>
<!-- Used when there is a mismatch between what type we were expecting to see for the operator -->
</crmerror>
<crmerror>
<ErrorId>80060427</ErrorId>
<ManagedErrorName>CalculatedFieldsInvalidFunction</ManagedErrorName>
<ErrorMessage>The {0} function doesn't exist.</ErrorMessage>
<!-- When a function used in workflow is not valid -->
</crmerror>
<crmerror>
<ErrorId>80060428</ErrorId>
<ManagedErrorName>CalculatedFieldsInvalidAttribute</ManagedErrorName>
<ErrorMessage>The {0} field doesn't exist.</ErrorMessage>
<!-- When an attribute used in workflow is not valid -->
</crmerror>
<crmerror>
 <ErrorId>80060429</ErrorId>
 <ManagedErrorName>TooManyCalculatedFieldsInQuery</ManagedErrorName>
 <ErrorMessage>Number of calculated fields in query exceeded maximum limit of {0}.</ErrorMessage>
</crmerror>
<crmerror>
 <ErrorId>8006042a</ErrorId>
 <ManagedErrorName>CalculatedFieldsPrimitiveOverflow</ManagedErrorName>
 <ErrorMessage>Cannot convert the value {0} into type {1}.</ErrorMessage>
</crmerror>
<crmerror>
 <ErrorId>8006042b</ErrorId>
 <ManagedErrorName>CalculatedFieldsAssignmentMismatch</ManagedErrorName>
 <ErrorMessage>You can’t set the value {0}, which is of type {1}, to type {2}.</ErrorMessage>
<!-- Used when there is a mismatch between what type we were expecting to see assigned to the calculated field -->
</crmerror>
<crmerror>
<ErrorId>8006042c</ErrorId>
<ManagedErrorName>CalculatedFieldsFunctionMismatch</ManagedErrorName>
<ErrorMessage>You can't use {0}, which is of type {1}, with the current function.</ErrorMessage>
<!-- Used when there is a mismatch between what type we were expecting to see for the function -->
</crmerror>
<crmerror>
<ErrorId>8006042d</ErrorId>
<ManagedErrorName>CalculatedFieldsDivideByZero</ManagedErrorName>
<ErrorMessage>You cannot divide by {0}, which evaluates to zero.</ErrorMessage>
<!-- Used when the user enters a divisor which evaluates to zero-->
</crmerror>
<crmerror>
<ErrorId>8006042e</ErrorId>
<ManagedErrorName>CalculatedFieldsInvalidAttributes</ManagedErrorName>
<ErrorMessage>The formula references the following attributes that don't exist: {0}.</ErrorMessage>
<!-- String for missing attribute when the user opens the formula -->
</crmerror>
<crmerror>
<ErrorId>8006042f</ErrorId>
<ManagedErrorName>CalculatedFieldsInvalidValue</ManagedErrorName>
<ErrorMessage>The formula references a value that doesn't exist.</ErrorMessage>
<!-- String for missing value when the user opens the formula -->
</crmerror>
<crmerror>
<ErrorId>80060430</ErrorId>
<ManagedErrorName>CalculatedFieldsInvalidValues</ManagedErrorName>
<ErrorMessage>The formula references the following values that don't exist: {0}.</ErrorMessage>
<!-- String for missing option value when the user opens the formula -->
</crmerror>
<crmerror>
<ErrorId>80060431</ErrorId>
<ManagedErrorName>CalculatedFieldsCyclicReference</ManagedErrorName>
<ErrorMessage>Field {0} cannot be used in calculated field {1} because it would create a circular reference.</ErrorMessage>
<!-- String when a cyclic reference is created in calculated field. -->
</crmerror>
<crmerror>
<ErrorId>80060432</ErrorId>
<ManagedErrorName>CalculatedFieldsDepthExceeded</ManagedErrorName>
<ErrorMessage>You can’t create or update the {0} field because the {1} field already has a calculated field chain of {2} deep.</ErrorMessage>
<!-- String when the calculated field depth reaches the max limit -->
</crmerror>
<crmerror>
<ErrorId>80060433</ErrorId>
<ManagedErrorName>CalculatedFieldsEntitiesExceeded</ManagedErrorName>
<ErrorMessage>Field {0} cannot be created or updated because field {1} contains an additional formula that uses a parent record.</ErrorMessage>
<!-- String when the calculated field entity depth reaches the max limit -->
</crmerror>
<crmerror>
<ErrorId>80060437</ErrorId>
<ManagedErrorName>InvalidSourceType</ManagedErrorName>
<ErrorMessage>SourceType {0} isn't valid for the {1} data type.</ErrorMessage>
<!-- String when the sourcetype used on attribute create isn't valid for the field type. This will not be shown in the UI. -->
</crmerror>
<crmerror>
<ErrorId>80060438</ErrorId>
<ManagedErrorName>CalculatedFieldsInvalidSourceTypeMask</ManagedErrorName>
<ErrorMessage>The formula can't be saved because it contains references to the following fields that have invalid definitions: {0}.</ErrorMessage>
<!-- String when the calculated field uses a field with an invalid source type mask -->
</crmerror>
<crmerror>
<ErrorId>80060439</ErrorId>
<ManagedErrorName>AttributeFormulaDefinitionIsEmpty</ManagedErrorName>
<ErrorMessage>The formula is empty.</ErrorMessage>
<!-- Occurs when non-empty attribute's formula definition is expected, but it is empty -->
</crmerror>
<!-- Ends Calculate Field related errors: 80060422 -80060450 -->
<!-- Rollup field related errors: 80060533 - 80060561 -->
<crmerror>
<ErrorId>80060533</ErrorId>
<ManagedErrorName>RollupFieldsTargetRelationshipNull</ManagedErrorName>
<ErrorMessage>The related entity is empty. It must be provided when the source entity hierarchy isn’t used for the rollup.</ErrorMessage>
<!-- Used when target relationship is not given if source entity hierarchy is not specified for the rollup  -->
</crmerror>
<crmerror>
<ErrorId>80060534</ErrorId>
<ManagedErrorName>RollupFieldsTargetRelationshipNotPartOfOneToNRelationship</ManagedErrorName>
<ErrorMessage>1:N relationship {0} from the source entity {1} to the related entity {2} doesn’t exist.</ErrorMessage>
<!-- Used when target relationship is not part of the 1:N relationship from the source entity  -->
</crmerror>
<crmerror>
<ErrorId>80060535</ErrorId>
<ManagedErrorName>RollupFieldsSourceEntityNotHierarchical</ManagedErrorName>
<ErrorMessage>The source entity {0} hierarchy doesn’t exist.</ErrorMessage>
<!-- Used when source entity is not hierarchical  -->
</crmerror>
<crmerror>
<ErrorId>80060536</ErrorId>
<ManagedErrorName>RollupFieldsAggregateNotDefined</ManagedErrorName>
<ErrorMessage>An aggregate function and an aggregated field must be provided for the rollup.</ErrorMessage>
<!-- Used when aggregate is not defined for rollup  -->
</crmerror>
<crmerror>
<ErrorId>80060537</ErrorId>
<ManagedErrorName>RollupFieldsAggregateFieldNotPartOfEntity</ManagedErrorName>
<ErrorMessage>Aggregated field {0} does not belong to entity {1}</ErrorMessage>
<!-- Used when aggregated field is not part of the entity  -->
</crmerror>
<crmerror>
<ErrorId>80060538</ErrorId>
<ManagedErrorName>RollupFieldsSourceFilterConditionInvalid</ManagedErrorName>
<ErrorMessage>The source entity {0} filter condition {1} isn’t valid.</ErrorMessage>
<!-- Used when source filter is not valid  -->
</crmerror>
<crmerror>
<ErrorId>80060539</ErrorId>
<ManagedErrorName>RollupFieldsTargetFilterConditionInvalid</ManagedErrorName>
<ErrorMessage>The related entity {0} filter condition {1} isn’t valid.</ErrorMessage>
<!-- Used when target filter is not valid  -->
</crmerror>
<crmerror>
<ErrorId>8006053a</ErrorId>
<ManagedErrorName>RollupFieldsAggregateFunctionTypeMismatch</ManagedErrorName>
<ErrorMessage>The {0} data type isn’t allowed for the aggregated field when the aggregate function is {1}.</ErrorMessage>
<!-- Used when aggregated field type is not supported for the aggregate function  -->
</crmerror>
<crmerror>
<ErrorId>8006053b</ErrorId>
<ManagedErrorName>RollupFieldsGeneric</ManagedErrorName>
<ErrorMessage>The rollup field definition isn't valid.</ErrorMessage>
<!-- Used when a generic validation error is thrown  -->
</crmerror>
<crmerror>
<ErrorId>8006053c</ErrorId>
<ManagedErrorName>RollupFieldsAggregateOnRollupFieldOrComplexCalcFieldNotAllowed</ManagedErrorName>
<ErrorMessage>The aggregated field must be either a simple field or a basic calculated field.</ErrorMessage>
<!-- Used when a aggregated field is a rollup field or a N:1 calc field or a calc on calc field  -->
</crmerror>
<crmerror>
<ErrorId>8006053d</ErrorId>
<ManagedErrorName>RollupFieldsAggregateFieldDataTypeNotAllowedSimilarRollupFieldDataType</ManagedErrorName>
<ErrorMessage>The {0} data type isn’t allowed for the aggregated field when the rollup field is a {1} data type.</ErrorMessage>
<!-- Used when a aggregated field data type field is not allowed for similar data type of rollup field  -->
</crmerror>
<crmerror>
<ErrorId>8006053e</ErrorId>
<ManagedErrorName>RollupFieldsDataTypeNotValid</ManagedErrorName>
<ErrorMessage>The {0} data type isn’t valid for the rollup field.</ErrorMessage>
<!-- Used when a data type for rollup field data is not supported -->
</crmerror>
<crmerror>
<ErrorId>8006053f</ErrorId>
<ManagedErrorName>RollupFieldsAggregateFieldNotBelongToSourceEntity</ManagedErrorName>
<ErrorMessage>The aggregated field {0} doesn’t belong to the source entity {1}.</ErrorMessage>
<!-- Used when aggregated field doesn’t belong to the source entity -->
</crmerror>
<crmerror>
<ErrorId>80060540</ErrorId>
<ManagedErrorName>RollupFieldsAggregateFieldNotBelongToRelatedEntity</ManagedErrorName>
<ErrorMessage>The aggregated field {0} doesn’t belong to the related entity {1}.</ErrorMessage>
<!-- Used when aggregated field doesn’t belong to the related entity -->
</crmerror>
<crmerror>
<ErrorId>80060541</ErrorId>
<ManagedErrorName>RollupFieldDependentFieldCannotDeleted</ManagedErrorName>
<ErrorMessage>Rollup field {0} depends on this field. It can only be deleted by deleting the corresponding rollup field {0}.</ErrorMessage>
<!-- Used when aggregated field doesn’t belong to the related entity -->
</crmerror>
<crmerror>
<ErrorId>80060542</ErrorId>
<ManagedErrorName>ExceededRollupFieldsPerOrgQuota</ManagedErrorName>
<ErrorMessage>You can't add a rollup field. You’ve reached the maximum number of {0} allowed for your organization.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060543</ErrorId>
<ManagedErrorName>ExceededRollupFieldsPerEntityQuota</ManagedErrorName>
<ErrorMessage>You can't add a rollup field. You’ve reached the maximum number of {0} allowed for this record type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060544</ErrorId>
<ManagedErrorName>RollupFieldAndAggregateFieldDataTypeFormatMismatch</ManagedErrorName>
<ErrorMessage>The {0} data type with format {1} isn’t allowed for the aggregated field when the rollup field is a {2} data type with format {3}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060545</ErrorId>
<ManagedErrorName>RollupFieldAggregateFunctionNotAllowedForRollupFieldDataType</ManagedErrorName>
<ErrorMessage>The aggregate function {0} isn’t allowed when the rollup field is a {1} data type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060546</ErrorId>
<ManagedErrorName>RollupFieldAggregateFunctionNotAllowed</ManagedErrorName>
<ErrorMessage>The aggregate function {0} isn’t allowed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060547</ErrorId>
<ManagedErrorName>HierarchyCalculateLimitReached</ManagedErrorName>
<ErrorMessage>Calculations can't be performed online because the master record hierarchy depth limit of {0} has been reached.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060548</ErrorId>
<ManagedErrorName>RollupFieldSourceFilterFieldNotAllowed</ManagedErrorName>
<ErrorMessage>The source entity filter must use either a simple field or a basic calculated field. It can't use a rollup field, or a calculated field that is using a rollup field.</ErrorMessage>
<!-- Used when trying to set a Source Entity filter to be a rollup field or a complex calculated field. -->
</crmerror>
<crmerror>
<ErrorId>80060549</ErrorId>
<ManagedErrorName>RollupFieldTargetFilterFieldNotAllowed</ManagedErrorName>
<ErrorMessage>The target entity filter must use either a simple field or a basic calculated field. It can't use a rollup field, or a calculated field that is using a rollup field.</ErrorMessage>
<!-- Used when trying to set a Target Entity filter to be a rollup field or a complex calculated field. -->
</crmerror>
<crmerror>
<ErrorId>80060550</ErrorId>
<ManagedErrorName>CalculatedFieldUsedInRollupFieldCannotBeComplex</ManagedErrorName>
<ErrorMessage>One or more rollup fields depend on this calculated field. This calculated field can't use a rollup field, another calculated field that is using a rollup field or a field from related entity.</ErrorMessage>
<!-- Used when updating a calculated field to use a complex calculated field or Rollup, and this calculated field is already used by a Rollup. -->
</crmerror>
<crmerror>
<ErrorId>80060551</ErrorId>
<ManagedErrorName>RollupFieldsTargetSameAsSourceEntity</ManagedErrorName>
<ErrorMessage>Self referential 1:N relationships are not allowed for the rollup field.</ErrorMessage>
<!-- Used when Target Entity cannot be the same as Source Entity  -->
</crmerror>
<crmerror>
<ErrorId>80060552</ErrorId>
<ManagedErrorName>RollupFieldsTargetEntityNotValid</ManagedErrorName>
<ErrorMessage>Related entity {0} is not allowed for rollups.</ErrorMessage>
<!-- Used when target entity part of the 1:N relationship from the source entity is not valid for rollups -->
</crmerror>
<crmerror>
<ErrorId>80060553</ErrorId>
<ManagedErrorName>RollupFieldDefinitionNotValid</ManagedErrorName>
<ErrorMessage>The calculation failed because the rollup field definition is invalid. Contact your system administrator.</ErrorMessage>
<!-- Used when the rollup field definition is not valid -->
</crmerror>
<crmerror>
<ErrorId>80060554</ErrorId>
<ManagedErrorName>RecalculateNotSupportedOnNonRollupField</ManagedErrorName>
<ErrorMessage>Field {0} of type {1} does not support Recalculate action. Recalculate action can only be invoked for rollup field.</ErrorMessage>
<!-- Used when a recalculate operation is invoked on a non rollup field -->
</crmerror>
<crmerror>
<ErrorId>80060555</ErrorId>
<ManagedErrorName>CannotModifyRollupDependentField</ManagedErrorName>
<ErrorMessage>Rollup field {0} created this field. It can’t be modified directly.</ErrorMessage>
<!-- Used when a rollup dependent field is modified -->
</crmerror>
<crmerror>
<ErrorId>80060556</ErrorId>
<ManagedErrorName>RollupDependentFieldNameAlreadyExists</ManagedErrorName>
<ErrorMessage>Required dependent field {0} for rollup field cannot be created as another field with same name already exists. Please use an alternative name to create the rollup field.</ErrorMessage>
<!-- Used when an attribute with same name as a rollup dependent field already exists -->
</crmerror>
<crmerror>
<ErrorId>80060557</ErrorId>
<ManagedErrorName>RollupOrCalcNotAllowedInWorkflowWaitCondition</ManagedErrorName>
<ErrorMessage>The field {0} is either a rollup field or a rollup dependent field or a calculated field. Such fields are not allowed in workflow wait condition.</ErrorMessage>
<!-- Used when an Rollup or rollup dependent or calculated field is used in workflow wait conditions -->
</crmerror>
<crmerror>
<ErrorId>80060558</ErrorId>
<ManagedErrorName>CalculateNowOverflowError</ManagedErrorName>
<ErrorMessage>The calculation failed due to an overflow error.</ErrorMessage>
<!-- Used when a calculate now SDK calls fails with overflow error -->
</crmerror>
  <crmerror>
    <ErrorId>80060559</ErrorId>
    <ManagedErrorName>AttributeCannotBeUsedInAggregate</ManagedErrorName>
    <ErrorMessage>The {0} attribute cannot be used with an aggregation function in a formula.</ErrorMessage>
    <!-- Used when an attribute like exchange rate cannot be used in rollup aggregation. -->
  </crmerror>
  <crmerror>
    <ErrorId>80060560</ErrorId>
    <ManagedErrorName>RollupFormulaFieldInvalid</ManagedErrorName>
    <ErrorMessage>The formula field isn’t valid.</ErrorMessage>
    <!-- Used when a rollup field formula is not valid -->
  </crmerror>
  <crmerror>
    <ErrorId>80060561</ErrorId>
    <ManagedErrorName>RollupCalculationLimitReached</ManagedErrorName>
    <ErrorMessage>Calculations can't be performed at this time because the calculation limit has been reached. Please wait and try again.</ErrorMessage>
    <!-- Used when a limit of calculate now requests per second is reached -->
  </crmerror>
<!-- Ends Rollup field related errors: 80060533 - 80060561-->
<crmerror>
<ErrorId>80060434</ErrorId>
<ManagedErrorName>ConditionBranchDoesHaveSetNextStageOnlyChildInXaml</ManagedErrorName>
<ErrorMessage>Branch condition can contain only SetNextStage as a child.</ErrorMessage>
<ErrorMessage></ErrorMessage>
<!-- The above error is thrown when a set next stage is not a child in branch condition -->
</crmerror>
<crmerror>
<ErrorId>80060435</ErrorId>
<ManagedErrorName>ConditionStepCountInXamlExceedsMaxAllowed</ManagedErrorName>
<ErrorMessage>{0} cannot have more than one {1}.</ErrorMessage>
<ErrorMessage></ErrorMessage>
<!-- The above error is thrown when a stage contains more than one conditionstep -->
</crmerror>
<crmerror>
<ErrorId>80060436</ErrorId>
<ManagedErrorName>ConditionAttributesNotAnSubsetOfStepAttributes</ManagedErrorName>
<ErrorMessage>Attributes of the condition are not the subset of attributes in the Step, for the Stage : {0}</ErrorMessage>
<!-- The above error is thrown for a Stage when the attributes in a condition are not subset of attributes in a Step -->
</crmerror>
<!-- See comments above, create your own section! -->

<!-- Start Email router related error 8005E200 - 8005E2FF-->
<crmerror>
<ErrorId>8005E200</ErrorId>
<ManagedErrorName>CannotDeleteUserMailbox</ManagedErrorName>
<ErrorMessage>The mailbox associated to a user or a queue cannot be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E201</ErrorId>
<ManagedErrorName>EmailServerProfileSslRequiredForOnline</ManagedErrorName>
<ErrorMessage>You cannot set SSL as false for Microsoft Dynamics CRM Online.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E202</ErrorId>
<ManagedErrorName>EmailServerProfileInvalidCredentialRetrievalForOnline</ManagedErrorName>
<ErrorMessage>Windows integrated or Anonymous authentication cannot be used as a connection type for Microsoft Dynamics CRM Online.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E203</ErrorId>
<ManagedErrorName>EmailServerProfileInvalidCredentialRetrievalForExchange</ManagedErrorName>
<ErrorMessage>No credentials (Anonymous) cannot be used a connection type for exchange e-mail server type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E204</ErrorId>
<ManagedErrorName>EmailServerProfileAutoDiscoverNotAllowed</ManagedErrorName>
<ErrorMessage>Auto discover server URL can location can only be used for an exchange e-mail server type.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E205</ErrorId>
<ManagedErrorName>EmailServerProfileLocationNotRequired</ManagedErrorName>
<ErrorMessage>You cannot specify the incoming/outgoing e-mail server location when Autodiscover server location has been set to true.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E207</ErrorId>
<ManagedErrorName>ForwardMailboxCannotAssociateWithUser</ManagedErrorName>
<ErrorMessage>A forward mailbox cannot be created for a specific user or a queue.  Please remove the regarding field and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E208</ErrorId>
<ManagedErrorName>MailboxCannotModifyEmailAddress</ManagedErrorName>
<ErrorMessage>E-mail Address of a mailbox cannot be updated when associated with an user/queue.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E209</ErrorId>
<ManagedErrorName>MailboxCredentialNotSpecified</ManagedErrorName>
<ErrorMessage>Username is not specified</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E20A</ErrorId>
<ManagedErrorName>EmailServerProfileInvalidServerLocation</ManagedErrorName>
<ErrorMessage>The specified server location {0} is invalid. Correct the server location and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E20B</ErrorId>
<ManagedErrorName>CannotAcceptEmail</ManagedErrorName>
<ErrorMessage>The email that you are trying to deliver cannot be accepted by Microsoft Dynamics CRM. Reason Code: {0}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E210</ErrorId>
<ManagedErrorName>QueueMailboxUnexpectedDeliveryMethod</ManagedErrorName>
<ErrorMessage>Delivery method for mailbox associated with a queue cannot be outlook client.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E211</ErrorId>
<ManagedErrorName>ForwardMailboxEmailAddressRequired</ManagedErrorName>
<ErrorMessage>An e-mail address is a required field in case of forward mailbox.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E212</ErrorId>
<ManagedErrorName>ForwardMailboxUnexpectedIncomingDeliveryMethod</ManagedErrorName>
<ErrorMessage>Forward mailbox incoming delivery method can only be none or router.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E213</ErrorId>
<ManagedErrorName>ForwardMailboxUnexpectedOutgoingDeliveryMethod</ManagedErrorName>
<ErrorMessage>Forward mailbox outgoing delivery method can only be none.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E214</ErrorId>
<ManagedErrorName>InvalidCredentialTypeForNonExchangeIncomingConnection</ManagedErrorName>
<ErrorMessage>For a POP3 email server type, you can only connect using credentials that are specified by a user or queue.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E215</ErrorId>
<ManagedErrorName>Pop3UnexpectedException</ManagedErrorName>
<ErrorMessage>Exception occur while polling mails using Pop3 protocol.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E216</ErrorId>
<ManagedErrorName>OpenMailboxException</ManagedErrorName>
<ErrorMessage>Exception occurs while opening mailbox for Exchaange mail server.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E217</ErrorId>
<ManagedErrorName>InvalidMailbox</ManagedErrorName>
<ErrorMessage>Invalid mailboxId passed in. Please check the mailboxid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E218</ErrorId>
<ManagedErrorName>InvalidEmailServerLocation</ManagedErrorName>
<ErrorMessage>The server location is either not present or is not valid. Please correct the server location.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E219</ErrorId>
<ManagedErrorName>InactiveMailbox</ManagedErrorName>
<ErrorMessage>The mailbox is in inactive state. Send/Receive mails are allowed only for active mailboxes.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E220</ErrorId>
<ManagedErrorName>UnapprovedMailbox</ManagedErrorName>
<ErrorMessage>The mailbox is not in approved state. Send/Receive mails are allowed only for approved mailboxes.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E221</ErrorId>
<ManagedErrorName>InvalidEmailAddressInMailbox</ManagedErrorName>
<ErrorMessage>The email address in the mailbox is not correct. Please enter the correct email address to process mails.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E222</ErrorId>
<ManagedErrorName>EmailServerProfileNotAssociated</ManagedErrorName>
<ErrorMessage>Email Server Profile is not associated with the current mailbox. Please associate a valid profile to send/receive mails.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E223</ErrorId>
<ManagedErrorName>IncomingDeliveryIsForwardMailbox</ManagedErrorName>
<ErrorMessage>Cannot poll mails from the mailbox. Its incoming delivery method is Forward mailbox.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E224</ErrorId>
<ManagedErrorName>InvalidIncomingDeliveryExpectingEmailConnector</ManagedErrorName>
<ErrorMessage>The incoming delivery method is not email connector. To receive mails its incoming delivery method should be Email Connector.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E225</ErrorId>
<ManagedErrorName>OutgoingNotAllowedForForwardMailbox</ManagedErrorName>
<ErrorMessage>Mailbox is a forward mailbox. A forward mailbox cannot send the mails.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E226</ErrorId>
<ManagedErrorName>InvalidOutgoingDeliveryExpectingEmailConnector</ManagedErrorName>
<ErrorMessage>The outgoing delivery method is not email connector. To send mails its outgoing delivery method should be Email Connector.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E227</ErrorId>
<ManagedErrorName>InaccessibleSmtpServer</ManagedErrorName>
<ErrorMessage>Cannot reach to the smtp server. Please check that the smtp server is accessible.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E228</ErrorId>
<ManagedErrorName>InactiveEmailServerProfile</ManagedErrorName>
<ErrorMessage>Email server profile is disabled. Cannot process email for disabled profile.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E229</ErrorId>
<ManagedErrorName>CannotUseUserCredentials</ManagedErrorName>
<ErrorMessage>Email connector cannot use the credentials specified in the mailbox entity. This might be because user has disallowed it. Please use other mode of credential retrieval or allow the use of credential by email connector.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E230</ErrorId>
<ManagedErrorName>CannotActivateMailboxForDisabledUserOrQueue</ManagedErrorName>
<ErrorMessage>Mailbox cannot be activated because the user or queue associated with the mailbox is in disabled state. Mailbox can only be activated for Active User/Queue.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E231</ErrorId>
<ManagedErrorName>ZeroEmailReceived</ManagedErrorName>
<ErrorMessage>There were no email available in the mailbox or could not be retrieved.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E232</ErrorId>
<ManagedErrorName>NoTestEmailAccessPrivilege</ManagedErrorName>
<ErrorMessage>There is not sufficient privilege to perform the test access.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E233</ErrorId>
<ManagedErrorName>MailboxCannotDeleteEmails</ManagedErrorName>
<ErrorMessage>The Delete Emails after Processing option cannot be set to Yes for user mailboxes.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E234</ErrorId>
<ManagedErrorName>EmailServerProfileSslRequiredForOnPremise</ManagedErrorName>
<ErrorMessage>Usage of SSL while contacting external email servers is mandatory for this CRM deployment.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E235</ErrorId>
<ManagedErrorName>EmailServerProfileDelegateAccessNotAllowed</ManagedErrorName>
<ErrorMessage>For an SMTP email server type, auto-granted delegate access cannot be used.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E236</ErrorId>
<ManagedErrorName>EmailServerProfileImpersonationNotAllowed</ManagedErrorName>
<ErrorMessage>For a Non Exchange email server type, impersonation cannot be used.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E237</ErrorId>
<ManagedErrorName>EmailMessageSizeExceeded</ManagedErrorName>
<ErrorMessage>Email Size Exceeds the MaximumMessageSizeLimit specified by the deployment.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E238</ErrorId>
<ManagedErrorName>OutgoingSettingsUpdateNotAllowed</ManagedErrorName>
<ErrorMessage>Different outgoing connection settings cannot be specified because the "Use Same Settings for Outgoing Connections" flag is set to True.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E239</ErrorId>
<ManagedErrorName>CertificateNotFound</ManagedErrorName>
<ErrorMessage>The given certificate cannot be found.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E23A</ErrorId>
<ManagedErrorName>InvalidCertificate</ManagedErrorName>
<ErrorMessage>The given certificate is invalid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E23B</ErrorId>
<ManagedErrorName>EmailServerProfileInvalidAuthenticationProtocol</ManagedErrorName>
<ErrorMessage>The authentication protocol is invalid for the specified server and connection type. For more information, contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E23C</ErrorId>
<ManagedErrorName>EmailServerProfileADBasedAuthenticationProtocolNotAllowed</ManagedErrorName>
<ErrorMessage>The authentication protocol cannot be set to Negotiate or NTLM for your organization because these require Active Directory. Use a different authentication protocol or contact your system administrator to enable an Active Directory-based authentication protocol.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E23D</ErrorId>
<ManagedErrorName>EmailServerProfileBasicAuthenticationProtocolNotAllowed</ManagedErrorName>
<ErrorMessage>The specified authentication protocol cannot be used because the protocol requires sending credentials on a secure channel. Use a different authentication protocol or contact your administrator to enable Basic authentication protocol on a non-secure channel.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E23E</ErrorId>
<ManagedErrorName>IncomingServerLocationAndSslSetToNo</ManagedErrorName>
<ErrorMessage>The URL specified for Incoming Server Location uses HTTPS but the Use SSL for Incoming Connection option is set to No. Set this option to Yes, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E23F</ErrorId>
<ManagedErrorName>OutgoingServerLocationAndSslSetToNo</ManagedErrorName>
<ErrorMessage>The URL specified for Outgoing Server Location uses HTTPS but the Use SSL for Outgoing Connection option is set to No. Set this option to Yes, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E240</ErrorId>
<ManagedErrorName>IncomingServerLocationAndSslSetToYes</ManagedErrorName>
<ErrorMessage>The URL specified for Incoming Server Location uses HTTP but the Use SSL for Incoming Connection option is set to Yes. Specify a server location that uses HTTPS, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E241</ErrorId>
<ManagedErrorName>OutgoingServerLocationAndSslSetToYes</ManagedErrorName>
<ErrorMessage>The URL specified for Outgoing Server Location uses HTTP but the Use SSL for Outgoing Connection option is set to Yes. Specify a server location that uses HTTPS, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E242</ErrorId>
<ManagedErrorName>UnsupportedEmailServer</ManagedErrorName>
<ErrorMessage>The email server isn't supported.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E243</ErrorId>
<ManagedErrorName>S2SAccessTokenCannotBeAcquired</ManagedErrorName>
<ErrorMessage>Failed to acquire S2S access token from authorization server.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E244</ErrorId>
<ManagedErrorName>InvalidValueProcessEmailAfter</ManagedErrorName>
<ErrorMessage>The date in the Process Email From field is earlier than what is allowed for your organization. Enter a date that is later than the one specified, and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E245</ErrorId>
<ManagedErrorName>InvalidS2SAuthentication</ManagedErrorName>
<ErrorMessage>You can use server-to-server authentication only for email server profiles created for a Microsoft Dynamics CRM Online organization that was set up through the Microsoft online services environment (Office 365).</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E246</ErrorId>
<ManagedErrorName>RouterIsDisabled</ManagedErrorName>
<ErrorMessage>Microsoft Dynamics CRM has been configured to use server-side synchronization to process email. If you want to use the Email Router to process email, go to System Settings and change the Process Email Using field to Microsoft Dynamics CRM 2013 Email Router.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005E247</ErrorId>
<ManagedErrorName>MailboxUnsupportedEmailServerType</ManagedErrorName>
<ErrorMessage>Server-side synchronization for appointments, contacts, and tasks isn't supported for POP3 or SMTP server types. Select a supported email type or change the synchronization method for appointments, contacts, and tasks to None.</ErrorMessage>
</crmerror>
<!-- End Email router related error 8005E200 - 8005E2FF-->
<crmerror>
<ErrorId>8004F900</ErrorId>
<ManagedErrorName>TraceMessageConstructionError</ManagedErrorName>
<ErrorMessage>The trace record has an invalid trace code or an insufficient number of trace parameters.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F901</ErrorId>
<ManagedErrorName>TooManyBytesInInputStream</ManagedErrorName>
<ErrorMessage>The stream being read from has too many bytes.</ErrorMessage>
</crmerror>
<!-- Errors related to email migration 8005F031 - 8005F040-->
<crmerror>
<ErrorId>8005F031</ErrorId>
<ManagedErrorName>EmailRouterFileTooLargeToProcess</ManagedErrorName>
<ErrorMessage>One or more of the email router configuration files is too large to get processed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F032</ErrorId>
<ManagedErrorName>ErrorsInEmailRouterMigrationFiles</ManagedErrorName>
<ErrorMessage>Invalid File(s) for Email Router Migration</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F033</ErrorId>
<ManagedErrorName>InvalidMigrationFileContent</ManagedErrorName>
<ErrorMessage>The content of the import file is not valid. You must select a text file.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F034</ErrorId>
<ManagedErrorName>ErrorMigrationProcessExcessOnServer</ManagedErrorName>
<ErrorMessage>The server is busy handling other migration processes. Please try after some time.</ErrorMessage>
</crmerror>
<!-- End email migration related errorrs 8005F031 - 8005F040-->
<!-- Tablet/Mobile Usage related errors: 8005F200 - 8005F2FF -->
<crmerror>
<ErrorId>8005F200</ErrorId>
<ManagedErrorName>EntityNotEnabledForThisDevice</ManagedErrorName>
<ErrorMessage>Entity not enabled to be viewed in this device</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F201</ErrorId>
<ManagedErrorName>MobileClientLanguageNotSupported</ManagedErrorName>
<ErrorMessage>The application could not find a supported language on the server. Contact an administrator to enable a supported language</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F202</ErrorId>
<ManagedErrorName>MobileClientVersionNotSupported</ManagedErrorName>
<ErrorMessage>Mobile Client version is not supported</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F203</ErrorId>
<ManagedErrorName>RoleNotEnabledForTabletApp</ManagedErrorName>
<ErrorMessage>You haven't been authorized to use this app.\nCheck with your system administrator to update your settings.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F20F</ErrorId>
<ManagedErrorName>NoMinimumRequiredPrivilegesForTabletApp</ManagedErrorName>
<ErrorMessage>You do not have sufficient permissions on the server to load the application.\nPlease contact your administrator to update your permissions.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F204</ErrorId>
<ManagedErrorName>FilePickerErrorAttachmentTypeBlocked</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F205</ErrorId>
<ManagedErrorName>FilePickerErrorFileSizeBreached</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F206</ErrorId>
<ManagedErrorName>FilePickerErrorFileSizeCannotBeZero</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F207</ErrorId>
<ManagedErrorName>FilePickerErrorUnableToOpenFile</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F208</ErrorId>
<ManagedErrorName>GetPhotoFromGalleryFailed</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F209</ErrorId>
<ManagedErrorName>SaveDataFileErrorOutOfSpace</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F20A</ErrorId>
<ManagedErrorName>OpenDocumentErrorCodeUnableToFindAnActivity</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F20B</ErrorId>
<ManagedErrorName>OpenDocumentErrorCodeUnableToFindTheDataId</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F20C</ErrorId>
<ManagedErrorName>OpenDocumentErrorCodeGeneric</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F20D</ErrorId>
<ManagedErrorName>FilePickerErrorApplicationInSnapView</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F20E</ErrorId>
<ManagedErrorName>MobileClientNotConfiguredForCurrentUser</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F210</ErrorId>
<ManagedErrorName>DataSourceInitializeFailedErrorCode</ManagedErrorName>
<ErrorMessage>Try this action again. If the problem continues, check the {0} for solutions or contact your organization's {#Brand_CRM} Administrator. Finally, you can contact {1}.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F211</ErrorId>
<ManagedErrorName>DataSourceOfflineErrorCode</ManagedErrorName>
<ErrorMessage>This operation failed because you're offline. Reconnect and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F212</ErrorId>
<ManagedErrorName>PingFailureErrorCode</ManagedErrorName>
<ErrorMessage>The system couldn't reconnect with your {#Brand_CRM} server.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F213</ErrorId>
<ManagedErrorName>RetrieveRecordOfflineErrorCode</ManagedErrorName>
<ErrorMessage>This record isn't available while you're offline.  Reconnect and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8005F215</ErrorId>
<ManagedErrorName>NotMobileEnabled</ManagedErrorName>
<ErrorMessage>You can't view this type of record on your tablet. Contact your system administrator.</ErrorMessage>
</crmerror>
<!-- Tablet/Mobile Usage related errors: 8005F200 - 8005F2FF -->
<!-- See comments above, create your own section! -->

<!-- Entitlement, Entitlement Channel related errors: 80060600 - 8006061F and 80060620 - 8006063F-->

<crmerror>
<ErrorId>80060600</ErrorId>
<ManagedErrorName>EntitlementInvalidStartEndDate</ManagedErrorName>
<ErrorMessage>Start Date cannot be more than the End Date</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDSTARTENDDATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060601</ErrorId>
<ManagedErrorName>EntitlementInvalidState</ManagedErrorName>
<ErrorMessage>You cannot delete an entitlement that is in active or waiting state</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDSTATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060602</ErrorId>
<ManagedErrorName>InvalidChannelOrigin</ManagedErrorName>
<ErrorMessage>An entitlement channel term with the same channel already exists. Specify a different channel and try again.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDCHANNELORIGIN</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060603</ErrorId>
<ManagedErrorName>EntitlementChannelInvalidState</ManagedErrorName>
<ErrorMessage>An entitlement channel term cannot be created, modified or deleted when the associated entitlement is not in draft state.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDCHANNELSTATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060604</ErrorId>
<ManagedErrorName>EntitlementInvalidTerms</ManagedErrorName>
<ErrorMessage>Specify a higher value for total terms so the remaining terms won't be a negative value.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENTTERMS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060605</ErrorId>
<ManagedErrorName>InvalidEntitlementChannelTerms</ManagedErrorName>
<ErrorMessage>Total terms for a specific case origin on an entitlement channel cannot be more than the total terms of the corresponding entitlement.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENTCHANNELTERMS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060606</ErrorId>
<ManagedErrorName>InvalidEntitlementActivate</ManagedErrorName>
<ErrorMessage>You can't activate an expired, waiting or canceled entitlement.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENTACTIVATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060607</ErrorId>
<ManagedErrorName>InvalidEntitlementCancel</ManagedErrorName>
<ErrorMessage>You can't cancel an entitlement that's in the Draft or Expired state.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENTCANCEL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060608</ErrorId>
<ManagedErrorName>InvalidEntitlementDeactivate</ManagedErrorName>
<ErrorMessage>You can deactivate only entitlements that are active or waiting</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENTDEACTIVATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060609</ErrorId>
<ManagedErrorName>InvalidEntitlementAssociationToCase</ManagedErrorName>
<ErrorMessage>You can't create a case for this entitlement because there are no available terms.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENT_ASSOCIATIONTOCASE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060610</ErrorId>
<ManagedErrorName>InvalidEntitlementRenew</ManagedErrorName>
<ErrorMessage>You can renew only the entitlements that are expired or canceled.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENTRENEW</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060611</ErrorId>
<ManagedErrorName>InvalidEntitlementStateAssociateToCase</ManagedErrorName>
<ErrorMessage>You can only associate a case with an active entitlement.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENTSTATEASSOCIATETOCASE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060612</ErrorId>
<ManagedErrorName>EntitlementChannelWithoutEntitlementId</ManagedErrorName>
<ErrorMessage>Associate the entitlement channel with an entitlement or entitlement template.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_ENTITLEMENTCHANNELWITHOUTENTITLEMENTID</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060613</ErrorId>
<ManagedErrorName>EntitlementEditDraft</ManagedErrorName>
<ErrorMessage>You can only edit a draft entitlement.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_ENTITLEMENTEDITDRAFT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060614</ErrorId>
<ManagedErrorName>EntitlementAlreadyInDraftState</ManagedErrorName>
<ErrorMessage>You can't deactivate an entitlement when it's in the draft state.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_ENTITLEMENTALREADYINDRAFTSTATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060615</ErrorId>
<ManagedErrorName>EntitlementAlreadyInactiveState</ManagedErrorName>
<ErrorMessage>You can't activate an entitlement when it's in the active state.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_ENTITLEMENTALREADYININACTIVESTATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060616</ErrorId>
<ManagedErrorName>EntitlementNotActiveInAssociationToCase</ManagedErrorName>
<ErrorMessage>You can't create a case for this entitlement because the entitlement is not in active state.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_ENTITLEMENTNOTACTIVEINASSOCIATIONTOCASE</UnManagedErrorName>
</crmerror>

<crmerror>
<ErrorId>80060617</ErrorId>
<ManagedErrorName>ExpiredEntitlementActivate</ManagedErrorName>
<ErrorMessage>You can't activate an expired entitlement.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDEXPIREDENTITLEMENTACTIVATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060618</ErrorId>
<ManagedErrorName>InvalidEntitlementExpire</ManagedErrorName>
<ErrorMessage>You can't set an entitlement to the Expired state. Active entitlements automatically expire when their end date passes.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENTEXPIRE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060691</ErrorId>
<ManagedErrorName>InvalidDeleteProcess</ManagedErrorName>
<ErrorMessage>This process can't be deleted because it is a system-generated process.</ErrorMessage>
<UnManagedErrorName>IDS_PROCESS_INVALIDDELETION</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060619</ErrorId>
<ManagedErrorName>EntitlementTotalTerms</ManagedErrorName>
<ErrorMessage>If the allocation type is the number of cases, the total terms can't be a decimal value. Specify a whole number.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_TOTALTERMS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060620</ErrorId>
<ManagedErrorName>EntitlementTemplateTotalTerms</ManagedErrorName>
<ErrorMessage>If the allocation type is the number of cases, the total terms can't be a decimal value. Specify a whole number.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENTTEMPLATE_TOTALTERMS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060621</ErrorId>
<ManagedErrorName>SocialCareDisabledError</ManagedErrorName>
<ErrorMessage>There's a problem communicating with the Microsoft Dynamics CRM Organization. The organization might be unavailable or the feature is set so that it can't receive social data. Try again later. If the problem persists, contact your CRM administrator.</ErrorMessage>
<UnManagedErrorName>SOCIAL_CARE_DISABLED_ERROR</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060622</ErrorId>
<ManagedErrorName>EntitlementBlankTerms</ManagedErrorName>
<ErrorMessage>Total terms can't be blank. Enter a value and try again.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_BLANK_TERMS</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060623</ErrorId>
<ManagedErrorName>InvalidProduct</ManagedErrorName>
<ErrorMessage>You can't add a product family.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDPROUDUCT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>80060624</ErrorId>
<ManagedErrorName>EntitlementInvalidRemainingTerms</ManagedErrorName>
<ErrorMessage>The number of remaining terms can't be greater than the number of total terms.</ErrorMessage>
<UnManagedErrorName>IDS_ENTITLEMENT_INVALIDENTITLEMENT_REMAININGTERMS</UnManagedErrorName>
</crmerror>
<!-- Incident Merge/ Parent Child related errors: 8003F450 - 8006061F -->
<crmerror>
<ErrorId>8003F450</ErrorId>
<ManagedErrorName>NoIncidentMergeHavingSameParent</ManagedErrorName>
<ErrorMessage>Child cases having different parent case associated can not be merged.</ErrorMessage>
<UnManagedErrorName>NO_INCIDENT_MERGE_HAVING_SAME_PARENT</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8003F451</ErrorId>
<ManagedErrorName>CancelActiveChildCaseFirst</ManagedErrorName>
<ErrorMessage>Cancel active child case before canceling parent case.</ErrorMessage>
<UnManagedErrorName>CANCEL_ACTIVE_CHILD_CASE_FIRST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8003F452</ErrorId>
<ManagedErrorName>CloseActiveChildCaseFirst</ManagedErrorName>
<ErrorMessage>Close active child case before closing parent case.</ErrorMessage>
<UnManagedErrorName>CLOSE_ACTIVE_CHILD_CASE_FIRST</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8003F453</ErrorId>
<ManagedErrorName>MultilevelParentChildRelationshipNotAllowed</ManagedErrorName>
<ErrorMessage>Associating child cases to the existing child case is not allowed.</ErrorMessage>
<UnManagedErrorName>MULTILEVEL_PARENT_CHILD_RELATIONSHIP_NOT_ALLOWED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8003F454</ErrorId>
<ManagedErrorName>MaxChildCasesLimitExceeded</ManagedErrorName>
<ErrorMessage>A Parent Case cannot have more than maximum child cases allowed. Contact your administrator for more details</ErrorMessage>
<UnManagedErrorName>MAX_CHILD_CASES_LIMIT_EXCEEDED</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8003F455</ErrorId>
<ManagedErrorName>ParentCaseNotAllowedAsAChildCase</ManagedErrorName>
<ErrorMessage>You can't add a parent case as a child case</ErrorMessage>
<UnManagedErrorName>PARENT_CASE_NOT_ALLOWED_AS_A_CHILD_CASE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004F456</ErrorId>
<ManagedErrorName>CannotCloseCase</ManagedErrorName>
<ErrorMessage>This operation can't be completed. One or more child cases can't be closed because of the status transition rules that are defined for cases.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F457</ErrorId>
<ManagedErrorName>CannotMergeCase</ManagedErrorName>
<ErrorMessage>The merge couldn't be performed. One or more of the selected cases couldn't be cancelled because of the status transition rules that are defined for cases.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006074</ErrorId>
<ManagedErrorName>CaseStateChangeInvalid</ManagedErrorName>
<ErrorMessage>Because of the status transition rules, you can't resolve a case in the current status. Change the case status, and then try resolving it, or contact your system administrator.</ErrorMessage>
</crmerror>
<!-- Routing Rule related errors: 8004F850 - 8004F853 -->
<crmerror>
<ErrorId>8004F850</ErrorId>
<ManagedErrorName>CannotDeleteActiveRule</ManagedErrorName>
<ErrorMessage>You can not delete an active routing rule. Deactivate the rule to delete it.</ErrorMessage>
<UnManagedErrorName>CANNOT_DELETE_ACTIVE_RULE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004F851</ErrorId>
<ManagedErrorName>CannotEditActiveRule</ManagedErrorName>
<ErrorMessage>You can not edit an active routing rule. Deactivate the rule to delete it.</ErrorMessage>
<UnManagedErrorName>CANNOT_EDIT_ACTIVE_RULE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004F852</ErrorId>
<ManagedErrorName>RuleAlreadyInactiveState</ManagedErrorName>
<ErrorMessage>This routing rule is already in Active state.</ErrorMessage>
<UnManagedErrorName>RULE_ALREADY_IN_ACTIVE_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004F853</ErrorId>
<ManagedErrorName>RuleAlreadyInDraftState</ManagedErrorName>
<ErrorMessage>You can not deactivate a draft routing rule.</ErrorMessage>
<UnManagedErrorName>RULE_ALREADY_IN_DRAFT_STATE</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004F884</ErrorId>
<ManagedErrorName>RuleAlreadyExistsWithSameQueueAndChannel</ManagedErrorName>
<ErrorMessage>A case creation rule for the specified channel and queue already exists. You can't create another one.</ErrorMessage>
<UnManagedErrorName>RULE_ALREADY_EXISTS_WITH_SAME_QUEUE_AND_CHANNEL</UnManagedErrorName>
</crmerror>
<crmerror>
<ErrorId>8004F885</ErrorId>
<ManagedErrorName>RoutingRuleActivateDeactivateByNonOwner</ManagedErrorName>
<ErrorMessage>This Routing Rule Set cannot be activated or deactivated by someone who is not its owner.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F886</ErrorId>
<ManagedErrorName>ConvertRuleActivateDeactivateByNonOwner</ManagedErrorName>
<ErrorMessage>This Convert Rule Set cannot be activated or deactivated by someone who is not its owner.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060730</ErrorId>
<ManagedErrorName>ConvertRuleResponseTemplateValidity</ManagedErrorName>
<ErrorMessage>Please select either a global or case template.</ErrorMessage>
</crmerror>
<!-- Queue SDK related errors: 80631117 - 80631130  and 80731118 - 80731130-->
<crmerror>
<ErrorId>80631117</ErrorId>
<ManagedErrorName>CannotDeleteQueueWithQueueItems</ManagedErrorName>
<ErrorMessage>You can't delete this queue because it has items assigned to it. Assign these items to another user, team, or queue and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80731118</ErrorId>
<ManagedErrorName>CannotDeleteQueueWithRouteRules</ManagedErrorName>
<ErrorMessage>You can't delete this queue because one or more routing rule sets use this queue. Remove the queue from the routing rule sets and try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80631121</ErrorId>
<ManagedErrorName>CannotRoutePrivateQueueItemNonmember</ManagedErrorName>
<ErrorMessage>This private queue item can't be assigned To the selected User.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80731119</ErrorId>
<ManagedErrorName>CannotRouteToNonQueueMember</ManagedErrorName>
<ErrorMessage>This item cannot be routed to a non-queue member.</ErrorMessage>
</crmerror>
<!-- State Model- errors: 8004F854 - 8004F858 -->
<crmerror>
<ErrorId>8004F854</ErrorId>
<ManagedErrorName>StateTransitionActiveToResolve</ManagedErrorName>
<ErrorMessage>Because of the status transition rules, you can't resolve a case in the current status.Change the case status, and then try resolving it, or contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F855</ErrorId>
<ManagedErrorName>StateTransitionActiveToCanceled</ManagedErrorName>
<ErrorMessage>Because of the status transition rules, you can't cancel the case in the current status.Change the case status, and then try canceling it, or contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F856</ErrorId>
<ManagedErrorName>StateTransitionResolvedOrCanceledToActive</ManagedErrorName>
<ErrorMessage>Because of the status transition rules, you can't activate the case from the current status.Contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F857</ErrorId>
<ManagedErrorName>StateTransitionActivateNewStatus</ManagedErrorName>
<ErrorMessage>You can't activate this record because of the status transition rules.Contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F858</ErrorId>
<ManagedErrorName>StateTransitionDeactivateNewStatus</ManagedErrorName>
<ErrorMessage>You can't deactivate this record because of the status transition rules.Contact your system administrator.</ErrorMessage>
</crmerror>
  <!-- SLA- errors: 8004F859 - 8004F63 -->
<crmerror>
<ErrorId>8004F859</ErrorId>
<ManagedErrorName>CannotDeleteRelatedSla</ManagedErrorName>
<ErrorMessage>The SLA record couldn't be deleted. Please try again or contact your system administrator</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F860</ErrorId>
<ManagedErrorName>CannotEditActiveSla</ManagedErrorName>
<ErrorMessage>You can't delete active SLA .Please deactivate the SLA to delete or Contact your system administrator.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F861</ErrorId>
<ManagedErrorName>SlaAlreadyInactiveState</ManagedErrorName>
<ErrorMessage>You can't activate this record because it's already active.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F862</ErrorId>
<ManagedErrorName>SlaAlreadyInDraftState </ManagedErrorName>
<ErrorMessage>You can't deactivate this record because it's in a draft state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F863</ErrorId>
<ManagedErrorName>CannotChangeState</ManagedErrorName>
<ErrorMessage>Error occured during activating SLA..Please check your privileges on Workflow and kindly try again or Contact your system administrator.</ErrorMessage>
</crmerror>
 <crmerror>
<ErrorId>8004F867</ErrorId>
<ManagedErrorName>ImportRoutingRuleError</ManagedErrorName>
<ErrorMessage>An error occurred while importing Routing Rule Sets.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F868</ErrorId>
<ManagedErrorName>ImportSlaError</ManagedErrorName>
<ErrorMessage>An error occurred while importing SLAs.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F869</ErrorId>
<ManagedErrorName>ImportConvertRuleError</ManagedErrorName>
<ErrorMessage>An error occurred while importing Convert Rules.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F870</ErrorId>
<ManagedErrorName>CannotDeleteActiveSla</ManagedErrorName>
<ErrorMessage>You can't delete an active SLA. Deactivate the SLA, and then try deleting it.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F871</ErrorId>
<ManagedErrorName>ActiveSlaCannotEdit</ManagedErrorName>
<ErrorMessage>You can't edit an active SLA. Deactivate the SLA, and then try editing it.</ErrorMessage>
</crmerror>
<!-- Product Taxonomy - errors: 8004F872 - 8004FFFF -->
<crmerror>
<ErrorId>8004F972</ErrorId>
<ManagedErrorName>BundleCannotContainBundle</ManagedErrorName>
<ErrorMessage>You can't add a bundle to a bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F973</ErrorId>
<ManagedErrorName>ProductOrBundleCannotBeAsParent</ManagedErrorName>
<ErrorMessage>Only Product Families can be parents to products.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F974</ErrorId>
<ManagedErrorName>CannotAssociateRetiredProducts</ManagedErrorName>
<ErrorMessage>You can't create a product relationship with a retired product.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F975</ErrorId>
<ManagedErrorName>CannotUpdateDraftProducts</ManagedErrorName>
<ErrorMessage>You can Only update draft products.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F976</ErrorId>
<ManagedErrorName>CannotAddProductToBundle</ManagedErrorName>
<ErrorMessage>You cannot add products to this bundle.The limit of {0} has been reached for this bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F977</ErrorId>
<ManagedErrorName>ProductFromRetiredToActiveState</ManagedErrorName>
<ErrorMessage>You can't set a retired property to an active state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F978</ErrorId>
<ManagedErrorName>ProductFromDraftToRetiredState</ManagedErrorName>
<ErrorMessage>You can't retire a product that's in the draft state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F979</ErrorId>
<ManagedErrorName>ProductFromRetiredToDraftState</ManagedErrorName>
<ErrorMessage>It is not possible to move product from Retired to Draft State.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F980</ErrorId>
<ManagedErrorName>ProductFromRetiredToRetiredState</ManagedErrorName>
<ErrorMessage>Product is already in Retired State.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F981</ErrorId>
<ManagedErrorName>ProductFromDraftToDraftState</ManagedErrorName>
<ErrorMessage>Product is already in Draft State.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F982</ErrorId>
<ManagedErrorName>ProductFromActiveToActiveState</ManagedErrorName>
<ErrorMessage>Product is already in Active State.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F983</ErrorId>
<ManagedErrorName>SaveRecordBeforeAddingBundle</ManagedErrorName>
<ErrorMessage>After you select a price list, you must save the record before you can add a bundle with optional products.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F883</ErrorId>
<ManagedErrorName>RecordCanOnlyBeRevisedFromActiveState</ManagedErrorName>
<ErrorMessage>You can only revise an active product.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F984</ErrorId>
<ManagedErrorName>CannotAddDraftFamilyProductBundleToCases</ManagedErrorName>
<ErrorMessage>You can't add a product family, a draft product, or a draft bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F985</ErrorId>
<ManagedErrorName>CannotCloneBundleAsProductLimitExceeded</ManagedErrorName>
<ErrorMessage>You can't create this new bundle because it contains more than the allowed number of {0} products that a bundle can contain.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F986</ErrorId>
<ManagedErrorName>CannotChangeSelectedBundleToAnotherValue</ManagedErrorName>
<ErrorMessage>If a bundle is selected as an existing product, you can't change it to another value.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F987</ErrorId>
<ManagedErrorName>CannotChangeSelectedProductWithBundle</ManagedErrorName>
<ErrorMessage>If a product is selected as an existing product, you can't change it to a bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F988</ErrorId>
<ManagedErrorName>InvalidRelationshipTypeForUpSell</ManagedErrorName>
<ErrorMessage>An upsell relationship is always unidirectional and can't be changed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F989</ErrorId>
<ManagedErrorName>InvalidRelationshipTypeForAccessory</ManagedErrorName>
<ErrorMessage>An accessory relationship is always unidirectional and can't be changed.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F990</ErrorId>
<ManagedErrorName>ProductNoSubstitutedProductNumber</ManagedErrorName>
<ErrorMessage>The substituted Product number cannot be a NULL.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F891</ErrorId>
<ManagedErrorName>DuplicateProductRelationship</ManagedErrorName>
<ErrorMessage>A product relationship with the same product and related product already exists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F992</ErrorId>
<ManagedErrorName>BundleCannotContainProductFamily</ManagedErrorName>
<ErrorMessage>You can't add a product family to a bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F993</ErrorId>
<ManagedErrorName>RetiredProductToBundle</ManagedErrorName>
<ErrorMessage>You can't add a retired product to a bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F994</ErrorId>
<ManagedErrorName>DraftBundleToProduct</ManagedErrorName>
<ErrorMessage>You can only add products to a draft bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F995</ErrorId>
<ManagedErrorName>ProductCanOnlyBeUpdatedInDraft</ManagedErrorName>
<ErrorMessage>Product, product family and bundle can only be updated in draft state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F996</ErrorId>
<ManagedErrorName>InconsistentProductRelationshipState</ManagedErrorName>
<ErrorMessage>The other row for the product relationship is not available.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F997</ErrorId>
<ManagedErrorName>CannotRetireProductFromActiveBundle</ManagedErrorName>
<ErrorMessage>This product cannot be retired because it is a part of some active bundles or pricelists. Please remove it from all bundles or pricelists before retiring.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F998</ErrorId>
<ManagedErrorName>CannotSetProductAsParent</ManagedErrorName>
<ErrorMessage>You can only select a product family as the parent.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F999</ErrorId>
<ManagedErrorName>CannotAssociateProductFamily</ManagedErrorName>
<ErrorMessage>You can't create a relationship with a product family.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F902</ErrorId>
<ManagedErrorName>CannotAddPricelistToProductFamily</ManagedErrorName>
<ErrorMessage>You can't add a product family to a pricelist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F903</ErrorId>
<ManagedErrorName>SdkMessagesDeprecatedError</ManagedErrorName>
<ErrorMessage>This message is no longer available. Please consult the SDK for alternative messages.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F906</ErrorId>
<ManagedErrorName>CanOnlySetActiveOrDraftProductFamilyAsParent</ManagedErrorName>
<ErrorMessage>You can only set product families in a draft or active state as parent.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F907</ErrorId>
<ManagedErrorName>CannotPublishBundleWithProductStateDraftOrRetire</ManagedErrorName>
<ErrorMessage>You can't publish this bundle because its associated products are in a draft state, are retired, or are being revised.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F916</ErrorId>
<ManagedErrorName>CannotPublishKitWithProductStateDraftOrRetire</ManagedErrorName>
<ErrorMessage>You can't publish this kit because its associated products are in a draft state, are retired, or are being revised.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F908</ErrorId>
<ManagedErrorName>CannotAddProduct</ManagedErrorName>
<ErrorMessage>You can only add Active products.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F909</ErrorId>
<ManagedErrorName>CannotPublishChildOfNonActiveProductFamily</ManagedErrorName>
<ErrorMessage>You can't publish this record because it belongs to a product family that isn't published.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F910</ErrorId>
<ManagedErrorName>ProductHasUnretiredChild</ManagedErrorName>
<ErrorMessage>You can't retire this product family because one or more of its child records aren't retired.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F912</ErrorId>
<ManagedErrorName>ProductFromActiveToDraftState</ManagedErrorName>
<ErrorMessage>You can't set a published product to the draft state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F913</ErrorId>
<ManagedErrorName>ProductFromDraftToRevisedState</ManagedErrorName>
<ErrorMessage>You can't revise a draft or a retired product.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F914</ErrorId>
<ManagedErrorName>CannotOverridePropertyFromDifferentHierarchy</ManagedErrorName>
<ErrorMessage>You can't override a property that belongs to a different product hierarchy.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F915</ErrorId>
<ManagedErrorName>CannotRetireProduct</ManagedErrorName>
<ErrorMessage>You can't retire this product because it belongs to active bundles or price lists. Remove it from any bundles or price lists before you retire it.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F90A</ErrorId>
<ManagedErrorName>InvalidStateForPublish</ManagedErrorName>
<ErrorMessage>The specified ProductFamily, Product or Bundle can only be published from Draft state or ActiveDraft status</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061000</ErrorId>
<ManagedErrorName>HiddenPropertyValidationFailed</ManagedErrorName>
<ErrorMessage>You can't create a property instance for a hidden property.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061001</ErrorId>
<ManagedErrorName>ActivePropertyValidationFailed</ManagedErrorName>
<ErrorMessage>You can't create a property instance for an inactive property.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061002</ErrorId>
<ManagedErrorName>ReadOnlyCreateValidationFailed</ManagedErrorName>
<ErrorMessage>You can't create and assign a value to a property instance for a read-only property.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061003</ErrorId>
<ManagedErrorName>ReadOnlyUpdateValidationFailed</ManagedErrorName>
<ErrorMessage>You can't update the property instance for a read-only property.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061004</ErrorId>
<ManagedErrorName>MinMaxValidationFailed</ManagedErrorName>
<ErrorMessage>Value out of range.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061005</ErrorId>
<ManagedErrorName>OptionSetValidationFailed</ManagedErrorName>
<ErrorMessage>Value out of range.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061021</ErrorId>
<ManagedErrorName>ValidationFailedForDynamicProperty</ManagedErrorName>
<ErrorMessage>An error occurred while saving the {0} property.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061006</ErrorId>
<ManagedErrorName>ProductCloneFailed</ManagedErrorName>
<ErrorMessage>You can't clone a child record of a retired product family.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061007</ErrorId>
<ManagedErrorName>CannotAddBundleToPricelist</ManagedErrorName>
<ErrorMessage>You can't add the {0} bundle to the pricelist because the {1} bundle product isn't in the pricelist.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061008</ErrorId>
<ManagedErrorName>CannotRemoveProductFromPricelist</ManagedErrorName>
<ErrorMessage>You can't remove this product from the pricelist because one or more bundles refer to it.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061009</ErrorId>
<ManagedErrorName>CannotAddRetiredProductToPricelist</ManagedErrorName>
<ErrorMessage>Retired products can not be added to pricelists.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061010</ErrorId>
<ManagedErrorName>CannotDeleteProductFromActiveBundle</ManagedErrorName>
<ErrorMessage>You can't remove products from a bundle that's either active or under revision.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061011</ErrorId>
<ManagedErrorName>CannotPublishNestedBundle</ManagedErrorName>
<ErrorMessage>You can't publish a bundle that contains bundles. Remove any bundles from this one, and then try to publish again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061012</ErrorId>
<ManagedErrorName>CannotCreateKitOfTypeFamilyOrBundle</ManagedErrorName>
<ErrorMessage>You can't create a kit of type bundle or product family.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061013</ErrorId>
<ManagedErrorName>CannotChangeProductRelationship</ManagedErrorName>
<ErrorMessage>You can't add or modify the product relationship of a retired product.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061014</ErrorId>
<ManagedErrorName>BundleCannotContainProductKit</ManagedErrorName>
<ErrorMessage>You can't add a kit to a bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061015</ErrorId>
<ManagedErrorName>CannotAddParentToAKit</ManagedErrorName>
<ErrorMessage>You can't specify a parent record for a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061016</ErrorId>
<ManagedErrorName>CannotConvertProductAssociatedWithFamilyToKit</ManagedErrorName>
<ErrorMessage>You can't convert a product that belongs to a product family to a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061017</ErrorId>
<ManagedErrorName>OnlyProductCanBeConvertedToKit</ManagedErrorName>
<ErrorMessage>Only products can be converted to kits.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061018</ErrorId>
<ManagedErrorName>CannotConvertProductAssociatedWithBundleToKit</ManagedErrorName>
<ErrorMessage>You can't convert a product that is a part of a bundle to a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061019</ErrorId>
<ManagedErrorName>UnsupportedCudOperationForDynamicProperties</ManagedErrorName>
<ErrorMessage>You can't create a property for a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061020</ErrorId>
<ManagedErrorName>CannotCloneProductKit</ManagedErrorName>
<ErrorMessage>You can't clone a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061022</ErrorId>
<ManagedErrorName>CannotAddProductBundleToKit</ManagedErrorName>
<ErrorMessage>You can't add a bundle to a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061023</ErrorId>
<ManagedErrorName>CannotAddProductFamilyToKit</ManagedErrorName>
<ErrorMessage>You can't add a product family to a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061024</ErrorId>
<ManagedErrorName>CannotAddProductToKit</ManagedErrorName>
<ErrorMessage>You can't add a product that belongs to a product family to a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061025</ErrorId>
<ManagedErrorName>UnsupportedSdkMessageForBundles</ManagedErrorName>
<ErrorMessage>This message isn't supported for products of type bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061026</ErrorId>
<ManagedErrorName>CannotAddProductToRetiredKit</ManagedErrorName>
<ErrorMessage>You can't add a product to a retired kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061027</ErrorId>
<ManagedErrorName>CannotAddRetiredProductToKit</ManagedErrorName>
<ErrorMessage>You can't add a retired product to a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061029</ErrorId>
<ManagedErrorName>CannotConvertProductFamilyToKit</ManagedErrorName>
<ErrorMessage>You can't convert a product family to a kit.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061030</ErrorId>
<ManagedErrorName>CannotConvertBundleToKit</ManagedErrorName>
<ErrorMessage>You can't convert a bundle to a kit.</ErrorMessage>
</crmerror>
  <crmerror>
    <ErrorId>80061031</ErrorId>
    <ManagedErrorName>CannotAddBundleToItself</ManagedErrorName>
    <ErrorMessage>You can't add a bundle to itself.</ErrorMessage>
  </crmerror>
  <crmerror>
    <ErrorId>80061032</ErrorId>
    <ManagedErrorName>CannotAddKitToItself</ManagedErrorName>
    <ErrorMessage>You can't add a kit to itself.</ErrorMessage>
  </crmerror>
  <crmerror>
    <ErrorId>80061033</ErrorId>
    <ManagedErrorName>CannotAddRetiredProduct</ManagedErrorName>
    <ErrorMessage>You can’t create a product relationship with a retired product.</ErrorMessage>
  </crmerror>
  <crmerror>
    <ErrorId>80061034</ErrorId>
    <ManagedErrorName>CannotCloneBundleWithRetiredProducts</ManagedErrorName>
    <ErrorMessage>You can't clone a bundle that contains retired products.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061035</ErrorId>
<ManagedErrorName>CannotSetPublishRetiredProductsToDraft</ManagedErrorName>
<ErrorMessage>You can't set a published or retired product record to the draft state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80061036</ErrorId>
<ManagedErrorName>CannotOverwriteProperty</ManagedErrorName>
<ErrorMessage>You can't overwrite this property as another overwritten version of this property already exists. Please delete the previously overwritten version, and then try again.</ErrorMessage>
</crmerror>
  <!-- DynamicProperty- errors: 80081000 - 80081020 -->
<crmerror>
<ErrorId>80081000</ErrorId>
<ManagedErrorName>DynamicPropertyInvalidStateForUpdate</ManagedErrorName>
<ErrorMessage>You can't update a property that isn't in the draft state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081001</ErrorId>
<ManagedErrorName>DynamicPropertyInvalidStateChange</ManagedErrorName>
<ErrorMessage>You can't set an inactive property to an active state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081002</ErrorId>
<ManagedErrorName>DynamicPropertyInvalidStateForDelete</ManagedErrorName>
<ErrorMessage>You can't delete a property that is in the active state.</ErrorMessage>
</crmerror>
  <crmerror>
<ErrorId>80081003</ErrorId>
<ManagedErrorName>CannotDeleteDynamicPropertyInUse</ManagedErrorName>
<ErrorMessage>Retired Properties being used in transactions can not be deleted.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081004</ErrorId>
<ManagedErrorName>DynamicPropertyInvalidRegardingForUpdate</ManagedErrorName>
<ErrorMessage>You can’t create or change properties for a published or retired product.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081005</ErrorId>
<ManagedErrorName>CannotOverrideOwnedDynamicProperty</ManagedErrorName>
<ErrorMessage>You can't override a property that isn't inherited from a product family.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081006</ErrorId>
<ManagedErrorName>CannotDeleteNotOwnedDynamicProperty</ManagedErrorName>
<ErrorMessage>You cannot delete a dynamic property that is inherited from a product family.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081007</ErrorId>
<ManagedErrorName>ProductFamilyCanCreateDynamicProperty</ManagedErrorName>
<ErrorMessage>A property can only be created for a product family.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081100</ErrorId>
<ManagedErrorName>CannotDeleteOverriddenProperty</ManagedErrorName>
<ErrorMessage>You can't delete this property because it's overridden for one more or child records. Remove the overridden versions of the property, republish the product family hierarchy, and then try deleting the property.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F872</ErrorId>
<ManagedErrorName>SlaActivateDeactivateByNonOwner</ManagedErrorName>
<ErrorMessage>This SLA cannot be activated or deactivated by someone who is not its owner.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F873</ErrorId>
<ManagedErrorName>PartialHolidayScheduleCreation</ManagedErrorName>
<ErrorMessage>Partial holiday schedule can not be created.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F874</ErrorId>
<ManagedErrorName>ErrorNoActiveRoutingRuleExists</ManagedErrorName>
<ErrorMessage>Currently there's no active rule to route this case.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F875</ErrorId>
<ManagedErrorName>SlaPermissionToPerformAction</ManagedErrorName>
<ErrorMessage>You don't have the required permissions on SLAs and processes to perform this action.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F876</ErrorId>
<ManagedErrorName>RoutingRulePublishedByOwner</ManagedErrorName>
<ErrorMessage>Your rule can't be activated until the current active rule is deactivated. The active rule can only be deactivated by the rule owner.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F877</ErrorId>
<ManagedErrorName>RoutingRuleMissingRuleCriteria</ManagedErrorName>
<ErrorMessage>You can't activate this rule until you resolve any missing rule criteria information in the rule items.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F878</ErrorId>
<ManagedErrorName>RoutingRulePublishedByNonOwner</ManagedErrorName>
<ErrorMessage>The Routing Rule Set cannot be published or unpublished by someone who is not its owner.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F879</ErrorId>
<ManagedErrorName>ConvertRuleInvalidAutoResponseSettings</ManagedErrorName>
<ErrorMessage>Select an email template for an autoresponse or set the autoresponse option to No.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F880</ErrorId>
<ManagedErrorName>CannotDeleteActiveCaseCreationRule</ManagedErrorName>
<ErrorMessage>You can’t delete an active case creation rule. Deactivate the case creation rule, and then try deleting it.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F887</ErrorId>
<ManagedErrorName>CannotOverrideProperty</ManagedErrorName>
<ErrorMessage>You can't override this property as another overriden version of this property already exists. Please delete the previously overridden version, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F888</ErrorId>
<ManagedErrorName>ParentHierarchyExistProperty</ManagedErrorName>
<ErrorMessage>A parent should exist for each node in hierarchy except the root node.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F889</ErrorId>
<ManagedErrorName>CreatePropertyError</ManagedErrorName>
<ErrorMessage>An error occurred while saving the {0} property.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F890</ErrorId>
<ManagedErrorName>CreatePropertyInstanceError</ManagedErrorName>
<ErrorMessage>An error occurred while saving the {0} property instance.</ErrorMessage>
</crmerror>
  <crmerror>
    <ErrorId>8004F892</ErrorId>
    <ManagedErrorName>CannotDeleteDynamicPropertyInRetiredState</ManagedErrorName>
    <ErrorMessage>You can't delete a property of a retired product.</ErrorMessage>
  </crmerror>

<!-- SharePoint errors: 80060700 - 80060740 -->
<crmerror>
<ErrorId>80060700</ErrorId>
<ManagedErrorName>SPFileNotCheckedOutErrorCode</ManagedErrorName>
<ErrorMessage>File is not checked out</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060701</ErrorId>
<ManagedErrorName>SPUnauthorizedAccessErrorCode</ManagedErrorName>
<ErrorMessage>Current user have insufficient privileges</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060702</ErrorId>
<ManagedErrorName>SPFileAlreadyCheckedOutErrorCode</ManagedErrorName>
<ErrorMessage>File is already checked out</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060703</ErrorId>
<ManagedErrorName>SPFileCheckedOutInvalidArgsErrorCode</ManagedErrorName>
<ErrorMessage>Checkout arguments are not valid</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060704</ErrorId>
<ManagedErrorName>SPSharedLockOnFileErrorCode</ManagedErrorName>
<ErrorMessage>Shared lock on the file</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060705</ErrorId>
<ManagedErrorName>SPExclusiveLockOnFileErrorCode</ManagedErrorName>
<ErrorMessage>Exclusive lock on the file</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060706</ErrorId>
<ManagedErrorName>SPFileNotFoundErrorCode</ManagedErrorName>
<ErrorMessage>File cannot be found</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060707</ErrorId>
<ManagedErrorName>SPFileNotLockedErrorCode</ManagedErrorName>
<ErrorMessage>The file in the collection is not locked</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060708</ErrorId>
<ManagedErrorName>SPDuplicateValuesFoundErrorCode</ManagedErrorName>
<ErrorMessage>The list item could not be updated because duplicate values were found for one or more field(s) in the list</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060709</ErrorId>
<ManagedErrorName>SPFileTooLargeOrInfectedErrorCode</ManagedErrorName>
<ErrorMessage>Virus checking indicates the file is infected with a virus or the file is too large</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006070A</ErrorId>
<ManagedErrorName>SPBadLockInFileCollectionErrorCode</ManagedErrorName>
<ErrorMessage>The file in the collection has bad lock </ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006070B</ErrorId>
<ManagedErrorName>SPInvalidLookupValuesErrorCode</ManagedErrorName>
<ErrorMessage>List item could not be updated because invalid lookup values were found for one or more field(s) in the list</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006070C</ErrorId>
<ManagedErrorName>SPNullFileUrlErrorCode</ManagedErrorName>
<ErrorMessage>URL of the file creation information must not be null and URL of the file creation information must not be invalid</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006070D</ErrorId>
<ManagedErrorName>SPFileContentNullErrorCode</ManagedErrorName>
<ErrorMessage>Content of the file creation information must not be null</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006070E</ErrorId>
<ManagedErrorName>SPFileSizeMismatchErrorCode</ManagedErrorName>
<ErrorMessage>There is a mismatch between the size of the document stream written and the size of the input document stream</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006070F</ErrorId>
<ManagedErrorName>SPFileIsReadOnlyErrorCode</ManagedErrorName>
<ErrorMessage>Field is read-only</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060710</ErrorId>
<ManagedErrorName>SPModifiedOnServerErrorCode</ManagedErrorName>
<ErrorMessage>List item was modified on the server so changes cannot be committed</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060711</ErrorId>
<ManagedErrorName>SPDataValidationFiledOnFieldErrorCode</ManagedErrorName>
<ErrorMessage>Data validation has failed on the field</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060712</ErrorId>
<ManagedErrorName>SPDataValidationFiledOnListErrorCode</ManagedErrorName>
<ErrorMessage>Data validation has failed on the list</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060713</ErrorId>
<ManagedErrorName>SPDataValidationFiledOnFieldAndListErrorCode</ManagedErrorName>
<ErrorMessage>Data validation has failed on the field and the list</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060714</ErrorId>
<ManagedErrorName>SPThrottlingLimitExceededErrorCode</ManagedErrorName>
<ErrorMessage>Throttling limit is exceeded by the operation</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060715</ErrorId>
<ManagedErrorName>SPOperationNotSupportedErrorCode</ManagedErrorName>
<ErrorMessage>List does not support this operation</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060716</ErrorId>
<ManagedErrorName>SPInstanceOfRecurringEventErrorCode</ManagedErrorName>
<ErrorMessage>List item is an instance of a recurring event which is not a recurrence exception, the list item is a workflow task whose parent workflow is in the recycle bin, or the parent list is a document library</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060717</ErrorId>
<ManagedErrorName>SPItemNotExistErrorCode</ManagedErrorName>
<ErrorMessage>List item does not exist</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060718</ErrorId>
<ManagedErrorName>SPInvalidSavedQueryErrorCode</ManagedErrorName>
<ErrorMessage>Error while doing this operation on SharePoint</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060719</ErrorId>
<ManagedErrorName>SPGenericErrorCode</ManagedErrorName>
<ErrorMessage>Error while doing this operation on SharePoint</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006071A</ErrorId>
<ManagedErrorName>SPSiteNotFoundErrorCode</ManagedErrorName>
<ErrorMessage>Site Not Found</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006071B</ErrorId>
<ManagedErrorName>SPFolderNotFoundErrorCode</ManagedErrorName>
<ErrorMessage>Folder Not Found</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006071C</ErrorId>
<ManagedErrorName>SPNoActiveDocumentLocationErrorCode</ManagedErrorName>
<ErrorMessage>No Active Document Location</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006071D</ErrorId>
<ManagedErrorName>SPIllegalFileTypeErrorCode</ManagedErrorName>
<ErrorMessage>Illegal file type</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006071E</ErrorId>
<ManagedErrorName>SPInvalidFieldValueErrorCode</ManagedErrorName>
<ErrorMessage>Invalid Field Value</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8006071F</ErrorId>
<ManagedErrorName>SPIllegalCharactersInFileNameErrorCode</ManagedErrorName>
<ErrorMessage>Illegal characters in filename</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060720</ErrorId>
<ManagedErrorName>SPCurrentDocumentLocationDisabledErrorCode</ManagedErrorName>
<ErrorMessage>Current document location is disabled by administrator</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060721</ErrorId>
<ManagedErrorName>SPCurrentFolderAlreadyExistErrorCode</ManagedErrorName>
<ErrorMessage>Record already present in db</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060723</ErrorId>
<ManagedErrorName>SPNullRegardingObjectErrorCode</ManagedErrorName>
<ErrorMessage>Regarding object id is null</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060724</ErrorId>
<ManagedErrorName>SPOperatorNotSupportedErrorCode</ManagedErrorName>
<ErrorMessage>{0} does not support the selected operator</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060725</ErrorId>
<ManagedErrorName>SPRequiredColCheckInErrorCode</ManagedErrorName>
<ErrorMessage>Exception occurred while doing document check-in as some columns are made required at SharePoint</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060728</ErrorId>
<ManagedErrorName>SPFileIsCheckedOutByOtherUser</ManagedErrorName>
<ErrorMessage>File is checked out to a user other than the current user</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060729</ErrorId>
<ManagedErrorName>SPFileNameModifiedErrorCode</ManagedErrorName>
<ErrorMessage>The folder can't be found. If you changed the automatically generated folder name for this document location directly in SharePoint, you must change the folder name in CRM to match the renamed folder. To do this, select Edit Location and type the matching name in Folder Name field.</ErrorMessage>
</crmerror>
<!-- End SharePoint errors: 80060700 - 80060740 -->
<crmerror>
<ErrorId>80081008</ErrorId>
<ManagedErrorName>RequiredBundleProductCannotBeDeleted</ManagedErrorName>
<ErrorMessage>You can't delete this product record because it's a required product in a bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081009</ErrorId>
<ManagedErrorName>RequiredBundleItemCannotBeUpdated</ManagedErrorName>
<ErrorMessage>You can't delete this bundle item because it's a required product in the bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8008100A</ErrorId>
<ManagedErrorName>DynamicPropertyInstanceMissingRequiredColumns</ManagedErrorName>
<ErrorMessage>The property instance can't be updated. Verify that the following fields are present: dynamicpropertyid, dynamicpropertyoptionsetvalueid, and regardingobjectid.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8008100B</ErrorId>
<ManagedErrorName>DynamicPropertyInstanceUpdateValuesDifferentRegarding</ManagedErrorName>
<ErrorMessage>The property instances couldn't be saved because they refer to different product line items.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8008100C</ErrorId>
<ManagedErrorName>DynamicPropertyOptionSetInvalidStateForUpdate</ManagedErrorName>
<ErrorMessage>You can't modify the property option set item for a property that is in the draft state.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8008100D</ErrorId>
<ManagedErrorName>ProductMaxPropertyLimitExceeded</ManagedErrorName>
<ErrorMessage>This product can't be published because it has too many properties. A product in your organization can't have more than {0} properties.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8008100E</ErrorId>
<ManagedErrorName>BundleMaxPropertyLimitExceeded</ManagedErrorName>
<ErrorMessage>This bundle can't be published because it has too many properties. A bundle in your organization can't have more than {0} properties.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8008100F</ErrorId>
<ManagedErrorName>HierarchicalOperationFailed</ManagedErrorName>
<ErrorMessage>This operation couldn't be completed on this hierarchy. An error occurred while performing this operation for {0}. You can perform the operation separately on this product to fix the error, and then try the operation again for the complete hierarchy.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081010</ErrorId>
<ManagedErrorName>ConflictForOverriddenPropertiesEncountered</ManagedErrorName>
<ErrorMessage>This record can't be published. One of the properties that was changed for this record conflicts with its inherited version. Remove the conflicting property, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8008101F</ErrorId>
<ManagedErrorName>ProductFamilyRootParentisLocked</ManagedErrorName>
<ErrorMessage>The product family root parent record is locked by some other process.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081011</ErrorId>
<ManagedErrorName>CannotAssociateRetiredBundles</ManagedErrorName>
<ErrorMessage>You can't create a product relationship with a retired bundle.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081012</ErrorId>
<ManagedErrorName>MissingQuantity</ManagedErrorName>
<ErrorMessage>The Quantity is missing.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081013</ErrorId>
<ManagedErrorName>CannotCreatePropertyOptionSetItem</ManagedErrorName>
<ErrorMessage>You can only create a property option set item record that refers to a property that has its data type set to Option Set.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081014</ErrorId>
<ManagedErrorName>CannotDeleteInheritedDynamicProperty</ManagedErrorName>
<ErrorMessage>You can't delete a property that is inherited from a product family.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081015</ErrorId>
<ManagedErrorName>CannotDeletePropertyOverriddenByBundleItem</ManagedErrorName>
<ErrorMessage>You can't delete this property because it's overridden in one or more related bundle products. Remove the overridden versions of the property from the related bundle products, publish the bundles that were changed, and then try again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081016</ErrorId>
<ManagedErrorName>CannotDeleteProductStatusCode</ManagedErrorName>
<ErrorMessage>You can't delete a system-generated status reason.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80081017</ErrorId>
<ManagedErrorName>CannotActivateRecord</ManagedErrorName>
<ErrorMessage>You can't activate a retired product family or bundle. Also, you can't activate a retired product that is part of a product family.</ErrorMessage>
</crmerror>
  <crmerror>
    <ErrorId>80081018</ErrorId>
    <ManagedErrorName>CannotQualifyLead</ManagedErrorName>
    <ErrorMessage>You can't qualify this lead because you don't have permission to create accounts. Work with your system administrator to create the account and then try again.</ErrorMessage>
  </crmerror>
<!-- Hierarchy Settings related errors: 8004F9A1 - 8004F9F0 -->
<crmerror>
<ErrorId>8004F9A1</ErrorId>
<ManagedErrorName>ImportHierarchyRuleDeletedError</ManagedErrorName>
<ErrorMessage>A hierarchy rule with the same id is marked as deleted in the system,So first publish the customized entity and import again.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F9A2</ErrorId>
<ManagedErrorName>ImportHierarchyRuleExistingError</ManagedErrorName>
<ErrorMessage>Cannot reuse existing hierarchy rule.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>8004F9A3</ErrorId>
<ManagedErrorName>ImportHierarchyRuleOtcMismatchError</ManagedErrorName>
<ErrorMessage>There was an error processing hierarchy rules of the same object type code.(unresolvable system collision)</ErrorMessage>
</crmerror>
<!-- SLA Enhancement  errors: 80045000 and 80055000-80055FFF -->
<crmerror>
<ErrorId>80045000</ErrorId>
<ManagedErrorName>HonorPauseWithoutSLAKPIError</ManagedErrorName>
<ErrorMessage>SLA can be set to honor pause and resume only if Use SLA KPI is set to Yes.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80055000</ErrorId>
<ManagedErrorName>CannotSetCaseOnHold</ManagedErrorName>
<ErrorMessage>You do not have the permissions to set this case to an on hold status type. Please contact your system administrator.</ErrorMessage>
</crmerror>
<!-- Errors related to Sync Attribute Mapping: 80060741 - 8006074F -->
<crmerror>
<ErrorId>80060741</ErrorId>
<ManagedErrorName>SyncAttributeMappingCannotBeUpdated</ManagedErrorName>
<ErrorMessage>The sync attribute mapping cannot be updated.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060742</ErrorId>
<ManagedErrorName>InvalidSyncDirectionValueForUpdate</ManagedErrorName>
<ErrorMessage>The sync direction is invalid as per the allowed sync direction for one or more attribute mappings.</ErrorMessage>
</crmerror>
<!-- End Errors related to Sync Attribute Mapping -->
<crmerror>
<ErrorId>80060750</ErrorId>
<ManagedErrorName>InvalidLanguageForCreate</ManagedErrorName>
<ErrorMessage>Rows with localizable attributes can only be created when the user interface (UI) language for the current user is set to the organization's base language.</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060751</ErrorId>
<ManagedErrorName>InvalidLanguageForUpdate</ManagedErrorName>
<ErrorMessage>Localizable attributes can only be updated via the string property when the user interface (UI) language for the current user is set to the organization's base language. Use SetLocLabels to update the localized values for the following attributes: [{0}].</ErrorMessage>
</crmerror>
<crmerror>
<ErrorId>80060752</ErrorId>
<ManagedErrorName>GenericImportTranslationsError</ManagedErrorName>
<ErrorMessage>Errors were encountered while processing the translations import file.</ErrorMessage>
</crmerror>
</crmerrors>

See Also

Concepts

Handle exceptions in your code

Other Resources

Troubleshooting and error handling

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the sample and helper code

Most managed code samples provided in the Microsoft Dynamics CRM SDK that use the organization and discovery web services are using shared helper code to perform common tasks. You might find this helper code useful in applications that you write. Sample helper code can be found in the following folders in the SDK, and also by following the links provided later in this topic. Download the Microsoft Dynamics CRM SDK package.

SDK\SampleCode\CS\HelperCode

SDK\SampleCode\VB\HelperCode

When writing an application that uses the Microsoft Dynamics CRM SDK, you typically have to perform a number of steps to configure your application’s project. To learn more about setting up a project in Microsoft Visual Studio, or other development environment, see Start a managed code project in Visual Studio.

For more information about running the samples included in the Microsoft Dynamics CRM SDK download, see the SDK\SampleCode\Readme.docx. To view a sample application that uses the helper code and includes the required .NET references, see Run a simple program using Microsoft Dynamics CRM web services.

A non-customized early-bound types file that is named MyOrganizationCrmSdkTypes is included in the SDK download in the SampleCode\CS\HelperCode and SampleCode\VB\HelperCode folders to help get you started. However, if your organization has custom or customized entities, you should generate a new early-bound types file. For the purposes of this documentation, the generated classes are included in the global namespace. For more information, see Create early bound entity classes with the code generation tool (CrmSvcUtil.exe).

See Also

Concepts

Best practices for developing with Microsoft Dynamics CRM
Sample code directory
Assemblies included in the Microsoft Dynamics CRM SDK
Use Microsoft Dynamics CRM services in code

Other Resources

Write applications and server extensions
Helper code: ServerConnection class
Helper code: DeviceIdManager class
Helper code: SystemUserProvider class
Helper code: Enumerations for option sets

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Helper code: ServerConnection class
See Also Example

The primary purpose of the ServerConnection class is to show how to connect to the Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update web services to invoke web methods. In addition, applications must typically perform other tasks such as obtaining server and organization information, obtaining user login credentials, creating a service proxy, and refreshing the WCF connection security token. The ServerConnection class provides this needed functionality.

Caution
The ServerConnection class is used by most samples that ship with the Microsoft Dynamics CRM SDK. The class is updated periodically with new functionality. Do not simply reuse the helper code for authentication in your applications. It is code that the Microsoft Dynamics CRM SDK uses to provide the optimum experience when you run our Console application samples included in the SDK. It contains all the key elements of authentication and demonstrates their use, but it may not represent the best solution for your application. It is sample code that you can use as a basis for designing an authentication management system that fits the requirements of your application. Refer to the topic Simplified connection to Microsoft Dynamics CRM for an alternate method for authenticating with the web services.

Download the Microsoft Dynamics CRM SDK package. This sample can be found in the following location:

SDK\SampleCode\CS\HelperCode\CrmServiceHelpers.cs

SDK\SampleCode\VB\HelperCode\CrmServiceHelpers.vb

Use the class source code in the CrmServiceHelpers files as a basis for your own classes or use the CrmConnection class for just the basic functionality of setting up a service connection.

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The ServerConnection class demonstrates how to establish a connection to the Microsoft Dynamics CRM web services for the purpose of invoking web methods. Before a connection can be created, information about the server, organization, and user must first be obtained. This information is gathered in either of two ways: by interactively prompting the user in the console window, or by loading saved server configuration information from the local disk. The server connection information is persisted to a file named Credentials.xml located at C:\Users\<username>\AppData\Roaming\CrmServer.

For each server configuration saved in the Credentials.xml file, the user’s logon password is stored as a generic credential in the Windows Credential Manager. The credential naming format is Microsoft_CRMSDK:<server>:<organization>:<userID>.

Useful code for authentication can be found in the GetProxy and GetOrganizationProxy methods. Also, the code that creates and reads a user’s password in the Windows Credential Manager may be of interest.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.Diagnostics.CodeAnalysis;
using System.DirectoryServices.AccountManagement;
using System.IO;
using System.Runtime.InteropServices;
using System.Security;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Text;
using System.Xml;
using System.Xml.Linq;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Crm.Services.Utility;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Provides server connection information.
    /// </summary>
    public class ServerConnection
    {
        #region Inner classes
        /// <summary>
        /// Stores Microsoft Dynamics CRM server configuration information.
        /// </summary>
        public class Configuration
        {
            public String ServerAddress;
            public String OrganizationName;
            public Uri DiscoveryUri;
            public Uri OrganizationUri;
            public Uri HomeRealmUri = null;
            public ClientCredentials DeviceCredentials = null;
            public ClientCredentials Credentials = null;
            public AuthenticationProviderType EndpointType;
            public String UserPrincipalName;
            #region internal members of the class
            internal IServiceManagement<IOrganizationService> OrganizationServiceManagement;
            internal SecurityTokenResponse OrganizationTokenResponse;
            internal Int16 AuthFailureCount = 0;
            #endregion

            public override bool Equals(object obj)
            {
                //Check for null and compare run-time types.
                if (obj == null || GetType() != obj.GetType()) return false;

                Configuration c = (Configuration)obj;

                if (!this.ServerAddress.Equals(c.ServerAddress, StringComparison.InvariantCultureIgnoreCase))
                    return false;
                if (!this.OrganizationName.Equals(c.OrganizationName, StringComparison.InvariantCultureIgnoreCase))
                    return false;
                if (this.EndpointType != c.EndpointType)
                    return false;
                if (null != this.Credentials && null != c.Credentials)
                {
                    if (this.EndpointType == AuthenticationProviderType.ActiveDirectory)
                    {

                        if (!this.Credentials.Windows.ClientCredential.Domain.Equals(
                            c.Credentials.Windows.ClientCredential.Domain, StringComparison.InvariantCultureIgnoreCase))
                            return false;
                        if (!this.Credentials.Windows.ClientCredential.UserName.Equals(
                            c.Credentials.Windows.ClientCredential.UserName, StringComparison.InvariantCultureIgnoreCase))
                            return false;

                    }
                    else if (this.EndpointType == AuthenticationProviderType.LiveId)
                    {
                        if (!this.Credentials.UserName.UserName.Equals(c.Credentials.UserName.UserName,
                            StringComparison.InvariantCultureIgnoreCase))
                            return false;
                        if (!this.DeviceCredentials.UserName.UserName.Equals(
                            c.DeviceCredentials.UserName.UserName, StringComparison.InvariantCultureIgnoreCase))
                            return false;
                        if (!this.DeviceCredentials.UserName.Password.Equals(
                            c.DeviceCredentials.UserName.Password, StringComparison.InvariantCultureIgnoreCase))
                            return false;
                    }
                    else
                    {

                        if (!this.Credentials.UserName.UserName.Equals(c.Credentials.UserName.UserName,
                            StringComparison.InvariantCultureIgnoreCase))
                            return false;

                    }
                }
                return true;
            }

            public override int GetHashCode()
            {
                int returnHashCode = this.ServerAddress.GetHashCode()
                    ^ this.OrganizationName.GetHashCode()
                    ^ this.EndpointType.GetHashCode();
                if (null != this.Credentials)
                {
                    if (this.EndpointType == AuthenticationProviderType.ActiveDirectory)
                        returnHashCode = returnHashCode
                            ^ this.Credentials.Windows.ClientCredential.UserName.GetHashCode()
                            ^ this.Credentials.Windows.ClientCredential.Domain.GetHashCode();
                    else if (this.EndpointType == AuthenticationProviderType.LiveId)
                        returnHashCode = returnHashCode
                            ^ this.Credentials.UserName.UserName.GetHashCode()
                            ^ this.DeviceCredentials.UserName.UserName.GetHashCode()
                            ^ this.DeviceCredentials.UserName.Password.GetHashCode();
                    else
                        returnHashCode = returnHashCode
                            ^ this.Credentials.UserName.UserName.GetHashCode();
                }
                return returnHashCode;
            }

        }
        #endregion Inner classes

        #region Public properties

        public List<Configuration> configurations = null;

        #endregion Public properties

        #region Private properties

        private Configuration config = new Configuration();

        #endregion Private properties

        #region Static methods
        /// <summary>
        /// Obtains the organization service proxy.
        /// This would give a better performance than directly calling GetProxy() generic method
        /// as it uses cached OrganizationServiceManagement in case it is present.
        /// </summary>
        /// <param name="serverConfiguration">An instance of ServerConnection.Configuration</param>
        /// <returns>An instance of organization service proxy</returns>
        public static OrganizationServiceProxy GetOrganizationProxy(
            ServerConnection.Configuration serverConfiguration)
        {
            // If organization service management exists, then use it.
            // Otherwise generate organization service proxy from scratch.
            if (null != serverConfiguration.OrganizationServiceManagement)
            {
                // Obtain the organization service proxy for the Federated, Microsoft account, and OnlineFederated environments.
                if (serverConfiguration.EndpointType != AuthenticationProviderType.ActiveDirectory)
                {
                    // get the organization service proxy.
                    return GetProxy<IOrganizationService, OrganizationServiceProxy>(serverConfiguration);

                }
                // Obtain organization service proxy for ActiveDirectory environment
                // using existing organization service management.
                else
                {
                    return new ManagedTokenOrganizationServiceProxy(
                        serverConfiguration.OrganizationServiceManagement,
                        serverConfiguration.Credentials);
                }
            }

            // Obtain the organization service proxy for all type of environments.
            return GetProxy<IOrganizationService, OrganizationServiceProxy>(serverConfiguration);

        }
        #endregion Static methods

        #region Public methods
        /// <summary>
        /// Obtains the server connection information including the target organization's
        /// Uri and user logon credentials from the user.
        /// </summary>
        public virtual Configuration GetServerConfiguration()
        {
            Boolean ssl;
            Boolean addConfig;
            int configNumber;
            // Read the configuration from the disk, if it exists, at C:\Users\<username>\AppData\Roaming\CrmServer\Credentials.xml.
            Boolean isConfigExist = ReadConfigurations();

            // Check if server configuration settings are already available on the disk.
            if (isConfigExist)
            {
                // List of server configurations that are available from earlier saved settings.
                Console.Write("\n(0) Add New Server Configuration (Maximum number up to 9)\t");
                for (int n = 0; n < configurations.Count; n++)
                {
                    String user;

                    switch (configurations[n].EndpointType)
                    {
                        case AuthenticationProviderType.ActiveDirectory:
                            if (configurations[n].Credentials != null)
                                user = configurations[n].Credentials.Windows.ClientCredential.Domain + "\\"
                                    + configurations[n].Credentials.Windows.ClientCredential.UserName;
                            else
                                user = "default";
                            break;
                        default:
                            if (configurations[n].Credentials != null)
                                user = configurations[n].Credentials.UserName.UserName;
                            else
                                user = "default";
                            break;
                    }

                    Console.Write("\n({0}) Server: {1},  Org: {2},  User: {3}\t",
                        n + 1, configurations[n].ServerAddress, configurations[n].OrganizationName, user);
                }

                Console.WriteLine();

                Console.Write("\nSpecify the saved server configuration number (1-{0}) [{0}] : ", configurations.Count);
                String input = Console.ReadLine();
                Console.WriteLine();
                if (input == String.Empty) input = configurations.Count.ToString();
                if (!Int32.TryParse(input, out configNumber)) configNumber = -1;

                if (configNumber == 0)
                {
                    addConfig = true;
                }
                else if (configNumber > 0 && configNumber <= configurations.Count)
                {
                    // Return the organization Uri.
                    config = configurations[configNumber - 1];
                    // Reorder the configuration list and save it to file to save the recent configuration as a latest one.
                    if (configNumber != configurations.Count)
                    {
                        Configuration temp = configurations[configurations.Count - 1];
                        configurations[configurations.Count - 1] = configurations[configNumber - 1];
                        configurations[configNumber - 1] = temp;
                    }
                    addConfig = false;
                }
                else
                    throw new InvalidOperationException("The specified server configuration does not exist.");
            }
            else
                addConfig = true;

            if (addConfig)
            {
                // Get the server address. If no value is entered, default to Microsoft Dynamics
                // CRM Online in the North American data center.
                config.ServerAddress = GetServerAddress(out ssl);

                if (String.IsNullOrWhiteSpace(config.ServerAddress))
                    config.ServerAddress = "crm.dynamics.com";

                // One of the Microsoft Dynamics CRM Online data centers.
                if (config.ServerAddress.EndsWith(".dynamics.com", StringComparison.InvariantCultureIgnoreCase))
                {
                    // Check if the organization is provisioned in Microsoft Office 365.
                    if (GetOrgType(config.ServerAddress))
                    {
                    config.DiscoveryUri =
                        new Uri(String.Format("https://disco.{0}/XRMServices/2011/Discovery.svc", config.ServerAddress));
                    }
                    else
                    {
                    config.DiscoveryUri =
                        new Uri(String.Format("https://dev.{0}/XRMServices/2011/Discovery.svc", config.ServerAddress));

                    // Get or set the device credentials. This is required for Microsoft account authentication.
                    config.DeviceCredentials = GetDeviceCredentials();
                    }
                }
                // Check if the server uses Secure Socket Layer (https).
                else if (ssl)
                    config.DiscoveryUri =
                        new Uri(String.Format("https://{0}/XRMServices/2011/Discovery.svc", config.ServerAddress));
                else
                    config.DiscoveryUri =
                        new Uri(String.Format("http://{0}/XRMServices/2011/Discovery.svc", config.ServerAddress));

                // Get the target organization.
                config.OrganizationUri = GetOrganizationAddress();
                configurations.Add(config);
                int length = configurations.Count;
                int i = length - 2;
                // Check if a new configuration already exists.
                // If found, reorder list to show latest in use.
                while (i > 0)
                {

                    if (configurations[configurations.Count - 1].Equals(configurations[i]))
                    {
                        configurations.RemoveAt(i);
                    }
                    i--;
                }
                // Set max configurations to 9 otherwise overwrite existing one.
                if (configurations.Count > 9)
                {
                    configurations.RemoveAt(0);
                }
            }
            else
            {
                // Get the existing user's logon credentials.
                config.Credentials = GetUserLogonCredentials(config);
            }
            SaveConfigurations();
            return config;
        }

        /// <summary>
        /// Discovers the organizations that the calling user belongs to.
        /// </summary>
        /// <param name="service">A Discovery service proxy instance.</param>
        /// <returns>Array containing detailed information on each organization that
        /// the user belongs to.</returns>
        public OrganizationDetailCollection DiscoverOrganizations(IDiscoveryService service)
        {
            if (service == null) throw new ArgumentNullException("service");
            RetrieveOrganizationsRequest orgRequest = new RetrieveOrganizationsRequest();
            RetrieveOrganizationsResponse orgResponse =
                (RetrieveOrganizationsResponse)service.Execute(orgRequest);

            return orgResponse.Details;
        }

        /// <summary>
        /// Finds a specific organization detail in the array of organization details
        /// returned from the Discovery service.
        /// </summary>
        /// <param name="orgFriendlyName">The friendly name of the organization to find.</param>
        /// <param name="orgDetails">Array of organization detail object returned from the discovery service.</param>
        /// <returns>Organization details or null if the organization was not found.</returns>
        /// <seealso cref="DiscoveryOrganizations"/>
        public OrganizationDetail FindOrganization(string orgFriendlyName,
            OrganizationDetail[] orgDetails)
        {
            if (String.IsNullOrWhiteSpace(orgFriendlyName))
                throw new ArgumentNullException("orgFriendlyName");
            if (orgDetails == null)
                throw new ArgumentNullException("orgDetails");
            OrganizationDetail orgDetail = null;

            foreach (OrganizationDetail detail in orgDetails)
            {
                if (String.Compare(detail.FriendlyName, orgFriendlyName,
                    StringComparison.InvariantCultureIgnoreCase) == 0)
                {
                    orgDetail = detail;
                    break;
                }
            }
            return orgDetail;
        }

        /// <summary>
        /// Reads a server configuration file.
        /// Read the configuration from disk, if it exists, at C:\Users\YourUserName\AppData\Roaming\CrmServer\Credentials.xml.
        /// </summary>
        /// <returns>Is configuration settings already available on disk.</returns>
        public Boolean ReadConfigurations()
        {
            Boolean isConfigExist = false;

            if (configurations == null)
                configurations = new List<Configuration>();

            if (File.Exists(CrmServiceHelperConstants.ServerCredentialsFile))
            {
                XElement configurationsFromFile =
                    XElement.Load(CrmServiceHelperConstants.ServerCredentialsFile);
                foreach (XElement config in configurationsFromFile.Nodes())
                {
                    Configuration newConfig = new Configuration();
                    var serverAddress = config.Element("ServerAddress");
                    if (serverAddress != null)
                        if (!String.IsNullOrEmpty(serverAddress.Value))
                            newConfig.ServerAddress = serverAddress.Value;
                    var organizationName = config.Element("OrganizationName");
                    if (organizationName != null)
                        if (!String.IsNullOrEmpty(organizationName.Value))
                            newConfig.OrganizationName = organizationName.Value;
                    var discoveryUri = config.Element("DiscoveryUri");
                    if (discoveryUri != null)
                        if (!String.IsNullOrEmpty(discoveryUri.Value))
                            newConfig.DiscoveryUri = new Uri(discoveryUri.Value);
                    var organizationUri = config.Element("OrganizationUri");
                    if (organizationUri != null)
                        if (!String.IsNullOrEmpty(organizationUri.Value))
                            newConfig.OrganizationUri = new Uri(organizationUri.Value);
                    var homeRealmUri = config.Element("HomeRealmUri");
                    if (homeRealmUri != null)
                        if (!String.IsNullOrEmpty(homeRealmUri.Value))
                            newConfig.HomeRealmUri = new Uri(homeRealmUri.Value);

                    var vendpointType = config.Element("EndpointType");
                    if (vendpointType != null)
                        newConfig.EndpointType =
                                RetrieveAuthenticationType(vendpointType.Value);
                    if (config.Element("Credentials").HasElements)
                    {
                        newConfig.Credentials =
                            ParseInCredentials(config.Element("Credentials"),
                            newConfig.EndpointType,
                            newConfig.ServerAddress + ":" + newConfig.OrganizationName + ":" + config.Element("Credentials").Element("UserName").Value);
                    }
                    if (newConfig.EndpointType == AuthenticationProviderType.LiveId)
                    {
                        newConfig.DeviceCredentials = GetDeviceCredentials();
                    }
                    var userPrincipalName = config.Element("UserPrincipalName");
                    if (userPrincipalName != null)
                        if (!String.IsNullOrWhiteSpace(userPrincipalName.Value))
                            newConfig.UserPrincipalName = userPrincipalName.Value;
                    configurations.Add(newConfig);
                }
            }

            if (configurations.Count > 0)
                isConfigExist = true;

            return isConfigExist;
        }

        /// <summary>
        /// Writes all server configurations to a file.
        /// </summary>
        /// <remarks>If the file exists, it is overwritten.</remarks>
        public void SaveConfigurations()
        {
            if (configurations == null)
                throw new NullReferenceException("No server connection configurations were found.");

            FileInfo file = new FileInfo(CrmServiceHelperConstants.ServerCredentialsFile);

            // Create directory if it does not exist.
            if (!file.Directory.Exists)
                file.Directory.Create();

            // Replace the file if it exists.
            using (FileStream fs = file.Open(FileMode.Create, FileAccess.Write, FileShare.None))
            {
                using (XmlTextWriter writer = new XmlTextWriter(fs, Encoding.UTF8))
                {
                    writer.Formatting = Formatting.Indented;
                    writer.WriteStartDocument();
                    writer.WriteStartElement("Configurations");
                    writer.WriteFullEndElement();
                    writer.WriteEndDocument();
                }
            }

            foreach (Configuration config in configurations)
                SaveConfiguration(CrmServiceHelperConstants.ServerCredentialsFile, config, true);
        }

        /// <summary>
        /// Writes a server configuration to a file.
        /// </summary>
        /// <param name="pathname">The file name and system path of the output configuration file.</param>
        /// <param name="config">A server connection configuration.</param>
        /// <param name="append">If true, the configuration is appended to the file, otherwise a new file
        /// is created.</param>
        public void SaveConfiguration(String pathname, Configuration config, bool append)
        {
            if (String.IsNullOrWhiteSpace(pathname)) throw new ArgumentNullException("pathname");
            if (config == null) throw new ArgumentNullException("config");
            // Target is the key with which associated credentials can be fetched from windows credentials manager.
            String target = config.ServerAddress + ":" + config.OrganizationName;
            if(null != config.Credentials)
            {
                switch(config.EndpointType)
                {
                    case AuthenticationProviderType.ActiveDirectory:
                        target = target + ":" + config.Credentials.Windows.ClientCredential.UserName;
                        break;
                    case AuthenticationProviderType.LiveId:
                    case AuthenticationProviderType.Federation:
                    case AuthenticationProviderType.OnlineFederation:
                        target = target + ":" + config.Credentials.UserName.UserName;
                        break;
                    default:
                        target = String.Empty;
                        break;
                }
            }

            XElement configurationsFromFile = XElement.Load(pathname);
            XElement newConfig =
                new XElement("Configuration",
                    new XElement("ServerAddress", config.ServerAddress),
                    new XElement("OrganizationName", config.OrganizationName),
                    new XElement("DiscoveryUri",
                        (config.DiscoveryUri != null)
                        ? config.DiscoveryUri.OriginalString
                        : String.Empty),
                    new XElement("OrganizationUri",
                        (config.OrganizationUri != null)
                        ? config.OrganizationUri.OriginalString
                        : String.Empty),
                    new XElement("HomeRealmUri",
                        (config.HomeRealmUri != null)
                        ? config.HomeRealmUri.OriginalString
                        : String.Empty),
                    ParseOutCredentials(config.Credentials, config.EndpointType, target),
                    new XElement("EndpointType", config.EndpointType.ToString()),
                    new XElement("UserPrincipalName",
                        (config.UserPrincipalName != null)
                        ? config.UserPrincipalName
                        : String.Empty)
                );

            if (append)
            {
                configurationsFromFile.Add(newConfig);
            }
            else
            {
                configurationsFromFile.ReplaceAll(newConfig);
            }

            using (XmlTextWriter writer = new XmlTextWriter(pathname, Encoding.UTF8))
            {
                writer.Formatting = Formatting.Indented;
                configurationsFromFile.Save(writer);
            }
        }

        /// <summary>
        /// Obtains the user's logon credentials for the target server.
        /// </summary>
        /// <param name="config">An instance of the Configuration.</param>
        /// <returns>Logon credentials of the user.</returns>
        public static ClientCredentials GetUserLogonCredentials(ServerConnection.Configuration config)
        {
            ClientCredentials credentials = new ClientCredentials();
            String userName;
            SecureString password;
            String domain;
            Boolean isCredentialExist = (config.Credentials != null) ? true : false;
            switch (config.EndpointType)
            {
                // An on-premises Microsoft Dynamics CRM server deployment.
                case AuthenticationProviderType.ActiveDirectory:
                    // Uses credentials from windows credential manager for earlier saved configuration.
                    if (isCredentialExist && !String.IsNullOrWhiteSpace(config.OrganizationName))
                    {
                        domain = config.Credentials.Windows.ClientCredential.Domain;
                        userName = config.Credentials.Windows.ClientCredential.UserName;
                        if (String.IsNullOrWhiteSpace(config.Credentials.Windows.ClientCredential.Password))
                        {
                            Console.Write("\nEnter domain\\username: ");
                            Console.WriteLine(
                            config.Credentials.Windows.ClientCredential.Domain + "\\"
                            + config.Credentials.Windows.ClientCredential.UserName);

                            Console.Write("       Enter Password: ");
                            password = ReadPassword();
                        }
                        else
                        {
                            password = config.Credentials.Windows.ClientCredential.SecurePassword;
                        }
                    }
                    // Uses default credentials saved in windows credential manager for current organization.
                    else if (!isCredentialExist && !String.IsNullOrWhiteSpace(config.OrganizationName))
                    {
                        return null;
                    }
                    // Prompts users to enter credential for current organization.
                    else
                    {
                        String[] domainAndUserName;
                        do
                        {
                            Console.Write("\nEnter domain\\username: ");
                            domainAndUserName = Console.ReadLine().Split('\\');

                            // If user do not choose to enter user name,
                            // then try to use default credential from windows credential manager.
                            if (domainAndUserName.Length == 1 && String.IsNullOrWhiteSpace(domainAndUserName[0]))
                            {
                                return null;
                            }
                        }
                        while (domainAndUserName.Length != 2 || String.IsNullOrWhiteSpace(domainAndUserName[0])
                            || String.IsNullOrWhiteSpace(domainAndUserName[1]));

                        domain = domainAndUserName[0];
                        userName = domainAndUserName[1];

                        Console.Write("       Enter Password: ");
                        password = ReadPassword();
                    }
                    if (null != password)
                    {
                        credentials.Windows.ClientCredential =
                            new System.Net.NetworkCredential(userName, password, domain);
                    }
                    else
                    {
                        credentials.Windows.ClientCredential = null;
                    }

                    break;
                // A Microsoft Dynamics CRM Online server deployment.
                case AuthenticationProviderType.LiveId:
                // An internet-facing deployment (IFD) of Microsoft Dynamics CRM.
                case AuthenticationProviderType.Federation:
                // Managed Identity/Federated Identity users using Microsoft Office 365.
                case AuthenticationProviderType.OnlineFederation:
                    // Use saved credentials.
                    if (isCredentialExist)
                    {
                        userName = config.Credentials.UserName.UserName;
                        if (String.IsNullOrWhiteSpace(config.Credentials.UserName.Password))
                        {
                            Console.Write("\n Enter Username: ");
                            Console.WriteLine(config.Credentials.UserName.UserName);

                            Console.Write(" Enter Password: ");
                            password = ReadPassword();
                        }
                        else
                        {
                            password = ConvertToSecureString(config.Credentials.UserName.Password);
                        }
                    }
                    // For OnlineFederation environments, initially try to authenticate with the current UserPrincipalName
                    // for single sign-on scenario.
                    else if (config.EndpointType == AuthenticationProviderType.OnlineFederation
                        && config.AuthFailureCount == 0
                        && !String.IsNullOrWhiteSpace(UserPrincipal.Current.UserPrincipalName))
                    {
                        config.UserPrincipalName = UserPrincipal.Current.UserPrincipalName;
                        return null;
                    }
                    // Otherwise request username and password.
                    else
                    {
                        config.UserPrincipalName = String.Empty;
                        if (config.EndpointType == AuthenticationProviderType.LiveId)
                            Console.Write("\n Enter Microsoft account: ");
                        else
                            Console.Write("\n Enter Username: ");
                        userName = Console.ReadLine();
                        if (string.IsNullOrWhiteSpace(userName))
                        {
                            return null;
                        }

                        Console.Write(" Enter Password: ");
                        password = ReadPassword();
                    }
                    credentials.UserName.UserName = userName;
                    credentials.UserName.Password = ConvertToUnsecureString(password);
                    break;
                default:
                    credentials = null;
                    break;
            }
            return credentials;
        }

        /// <summary>
        /// Prompts user to enter password in console window
        /// and capture the entered password into SecureString.
        /// </summary>
        /// <returns>Password stored in a secure string.</returns>
        public static SecureString ReadPassword()
        {
            SecureString ssPassword = new SecureString();

            ConsoleKeyInfo info = Console.ReadKey(true);
            while (info.Key != ConsoleKey.Enter)
            {
                if (info.Key == ConsoleKey.Backspace)
                {
                    if (ssPassword.Length != 0)
                    {
                        ssPassword.RemoveAt(ssPassword.Length - 1);
                        Console.Write("\b \b");     // erase last char
                    }
                }
                else if (info.KeyChar >= ' ')           // no control chars
                {
                    ssPassword.AppendChar(info.KeyChar);
                    Console.Write("*");
                }
                info = Console.ReadKey(true);
            }

            Console.WriteLine();
            Console.WriteLine();

            // Lock the secure string password.
            ssPassword.MakeReadOnly();

            return ssPassword;
        }

        /// <summary>
        /// Generic method to obtain discovery/organization service proxy instance.
        /// </summary>
        /// <typeparam name="TService">
        /// Set IDiscoveryService or IOrganizationService type
        /// to request respective service proxy instance.
        /// </typeparam>
        /// <typeparam name="TProxy">
        /// Set the return type to either DiscoveryServiceProxy
        /// or OrganizationServiceProxy type based on TService type.
        /// </typeparam>
        /// <param name="currentConfig">An instance of existing Configuration</param>
        /// <returns>An instance of TProxy
        /// i.e. DiscoveryServiceProxy or OrganizationServiceProxy</returns>
        public static TProxy GetProxy<TService, TProxy>(ServerConnection.Configuration currentConfig)
            where TService : class
            where TProxy : ServiceProxy<TService>
        {
            // Check if it is organization service proxy request.
            Boolean isOrgServiceRequest = typeof(TService).Equals(typeof(IOrganizationService));

            // Get appropriate Uri from Configuration.
            Uri serviceUri = isOrgServiceRequest ?
                currentConfig.OrganizationUri : currentConfig.DiscoveryUri;

            // Set service management for either organization service Uri or discovery service Uri.
            // For organization service Uri, if service management exists
            // then use it from cache. Otherwise create new service management for current organization.
            IServiceManagement<TService> serviceManagement =
                (isOrgServiceRequest && null != currentConfig.OrganizationServiceManagement) ?
                (IServiceManagement<TService>)currentConfig.OrganizationServiceManagement :
                ServiceConfigurationFactory.CreateManagement<TService>(
                serviceUri);

            if (isOrgServiceRequest)
            {
                if (currentConfig.OrganizationTokenResponse == null)
                {
                    currentConfig.OrganizationServiceManagement =
                        (IServiceManagement<IOrganizationService>)serviceManagement;
                }
            }
            // Set the EndpointType in the current Configuration object
            // while adding new configuration using discovery service proxy.
            else
            {
                // Get the EndpointType.
                currentConfig.EndpointType = serviceManagement.AuthenticationType;
                // Get the logon credentials.
                currentConfig.Credentials = GetUserLogonCredentials(currentConfig);
            }

            // Set the credentials.
            AuthenticationCredentials authCredentials = new AuthenticationCredentials();

            // If UserPrincipalName exists, use it. Otherwise, set the logon credentials from the configuration.
            if (!String.IsNullOrWhiteSpace(currentConfig.UserPrincipalName))
            {
                // Single sing-on with the Federated Identity organization using current UserPrinicipalName.
                authCredentials.UserPrincipalName = currentConfig.UserPrincipalName;
            }
            else
            {
                authCredentials.ClientCredentials = currentConfig.Credentials;
            }

            Type classType;

            // Obtain discovery/organization service proxy for Federated,
            // Microsoft account and OnlineFederated environments.
            if (currentConfig.EndpointType !=
                AuthenticationProviderType.ActiveDirectory)
            {
                if (currentConfig.EndpointType == AuthenticationProviderType.LiveId)
                {
                    authCredentials.SupportingCredentials = new AuthenticationCredentials();
                    authCredentials.SupportingCredentials.ClientCredentials =
                        currentConfig.DeviceCredentials;
                }

                AuthenticationCredentials tokenCredentials =
                    serviceManagement.Authenticate(
                        authCredentials);

                   if (isOrgServiceRequest)
                {
                    // Set SecurityTokenResponse for the current organization.
                    currentConfig.OrganizationTokenResponse = tokenCredentials.SecurityTokenResponse;
                    // Set classType to ManagedTokenOrganizationServiceProxy.
                    classType = typeof(ManagedTokenOrganizationServiceProxy);

                }
                else
                {
                    // Set classType to ManagedTokenDiscoveryServiceProxy.
                    classType = typeof(ManagedTokenDiscoveryServiceProxy);
                }

                // Invokes ManagedTokenOrganizationServiceProxy or ManagedTokenDiscoveryServiceProxy
                // (IServiceManagement<TService>, SecurityTokenResponse) constructor.
                return (TProxy)classType
                .GetConstructor(new Type[]
                    {
                        typeof(IServiceManagement<TService>),
                        typeof(SecurityTokenResponse)
                    })
                .Invoke(new object[]
                    {
                        serviceManagement,
                        tokenCredentials.SecurityTokenResponse
                    });
            }

            // Obtain discovery/organization service proxy for ActiveDirectory environment.
            if (isOrgServiceRequest)
            {
                classType = typeof(ManagedTokenOrganizationServiceProxy);
            }
            else
            {
                classType = typeof(ManagedTokenDiscoveryServiceProxy);
            }

            // Invokes ManagedTokenDiscoveryServiceProxy or ManagedTokenOrganizationServiceProxy
            // (IServiceManagement<TService>, ClientCredentials) constructor.
            return (TProxy)classType
                .GetConstructor(new Type[]
                   {
                       typeof(IServiceManagement<TService>),
                       typeof(ClientCredentials)
                   })
               .Invoke(new object[]
                   {
                       serviceManagement,
                       authCredentials.ClientCredentials
                   });
        }

        /// <summary>
        /// Convert SecureString to unsecure string.
        /// </summary>
        /// <param name="securePassword">Pass SecureString for conversion.</param>
        /// <returns>unsecure string</returns>
        public static String ConvertToUnsecureString(SecureString securePassword)
        {
            if (securePassword == null)
                throw new ArgumentNullException("securePassword");

            IntPtr unmanagedString = IntPtr.Zero;
            try
            {
                unmanagedString = Marshal.SecureStringToGlobalAllocUnicode(securePassword);
                return Marshal.PtrToStringUni(unmanagedString);
            }
            finally
            {
                Marshal.ZeroFreeGlobalAllocUnicode(unmanagedString);
            }
        }

        /// <summary>
        /// Convert unsecure string to SecureString.
        /// </summary>
        /// <param name="password">Pass unsecure string for conversion.</param>
        /// <returns>SecureString</returns>
        public static SecureString ConvertToSecureString(string password)
        {
            if (password == null)
                throw new ArgumentNullException("password");

            var securePassword = new SecureString();
            foreach (char c in password)
                securePassword.AppendChar(c);
            securePassword.MakeReadOnly();
            return securePassword;
        }
        #endregion Public methods

        #region Protected methods

        /// <summary>
        /// Obtains the name and port of the server running the Microsoft Dynamics CRM
        /// Discovery service.
        /// </summary>
        /// <returns>The server's network name and optional TCP/IP port.</returns>
        protected virtual String GetServerAddress(out bool ssl)
        {
            ssl = false;

            Console.Write("Enter a CRM server name and port [crm.dynamics.com]: ");
            String server = Console.ReadLine();

            if (server.EndsWith(".dynamics.com") || String.IsNullOrWhiteSpace(server))
            {
                ssl = true;
            }
            else
            {
                Console.Write("Is this server configured for Secure Socket Layer (https) (y/n) [n]: ");
                String answer = Console.ReadLine();

                if (answer == "y" || answer == "Y")
                    ssl = true;
            }

            return server;
        }

        /// <summary>
        /// Is this organization provisioned in Microsoft Office 365?
        /// </summary>
        /// <param name="server">The server's network name.</param>
        protected virtual Boolean GetOrgType(String server)
        {
            Boolean isO365Org = false;
            if (String.IsNullOrWhiteSpace(server))
                return isO365Org;
            if (server.IndexOf('.') == -1)
                return isO365Org;

            Console.Write("Is this organization provisioned in Microsoft Office 365 (y/n) [y]: ");
            String answer = Console.ReadLine();

            if (answer == "y" || answer == "Y" || answer.Equals(String.Empty))
                isO365Org = true;

            return isO365Org;
        }

        /// <summary>
        /// Obtains the web address (Uri) of the target organization.
        /// </summary>
        /// <returns>Uri of the organization service or an empty string.</returns>
        protected virtual Uri GetOrganizationAddress()
        {
            using (DiscoveryServiceProxy serviceProxy = GetDiscoveryProxy())
            {
                // Obtain organization information from the Discovery service.
                if (serviceProxy != null)
                {
                    // Obtain information about the organizations that the system user belongs to.
                    OrganizationDetailCollection orgs = DiscoverOrganizations(serviceProxy);

                    if (orgs.Count > 0)
                    {
                        Console.WriteLine("\nList of organizations that you belong to:");
                        for (int n = 0; n < orgs.Count; n++)
                        {
                            Console.Write("\n({0}) {1} ({2})\t", n + 1, orgs[n].FriendlyName, orgs[n].UrlName);
                        }

                        Console.Write("\n\nSpecify an organization number (1-{0}) [1]: ", orgs.Count);
                        String input = Console.ReadLine();
                        if (input == String.Empty)
                        {
                            input = "1";
                        }
                        int orgNumber;
                        Int32.TryParse(input, out orgNumber);
                        if (orgNumber > 0 && orgNumber <= orgs.Count)
                        {
                            config.OrganizationName = orgs[orgNumber - 1].FriendlyName;
                            // Return the organization Uri.
                            return new System.Uri(orgs[orgNumber - 1].Endpoints[EndpointType.OrganizationService]);
                        }
                        else
                            throw new InvalidOperationException("The specified organization does not exist.");
                    }
                    else
                    {
                        Console.WriteLine("\nYou do not belong to any organizations on the specified server.");
                        return new System.Uri(String.Empty);
                    }
                }
                else
                    throw new InvalidOperationException("An invalid server name was specified.");
            }
        }

        /// <summary>
        /// Get the device credentials by either loading from the local cache
        /// or request new device credentials by registering the device.
        /// </summary>
        /// <returns>Device Credentials.</returns>
        protected virtual ClientCredentials GetDeviceCredentials()
        {
            return Microsoft.Crm.Services.Utility.DeviceIdManager.LoadOrRegisterDevice();
        }

        /// <summary>
        /// Get the discovery service proxy based on existing configuration data.
        /// Added new way of getting discovery proxy.
        /// Also preserving old way of getting discovery proxy to support old scenarios.
        /// </summary>
        /// <returns>An instance of DiscoveryServiceProxy</returns>
        private DiscoveryServiceProxy GetDiscoveryProxy()
        {
            try
            {
                // Obtain the discovery service proxy.
                DiscoveryServiceProxy discoveryProxy = GetProxy<IDiscoveryService, DiscoveryServiceProxy>(this.config);
                // Checking authentication by invoking some SDK methods.
                discoveryProxy.Execute(new RetrieveOrganizationsRequest());
                return discoveryProxy;
            }
            catch (System.ServiceModel.Security.SecurityAccessDeniedException ex)
            {
                    // If authentication failed using current UserPrincipalName,
                    // request UserName and Password to try to authenticate using user credentials.
                    if (!String.IsNullOrWhiteSpace(config.UserPrincipalName) &&
                        ex.Message.Contains("Access is denied."))
                    {
                        config.AuthFailureCount += 1;
                    }
                    else
                    {
                        throw ex;
                    }
            }
            // You can also catch other exceptions to handle a specific situation in your code, for example,
            //      System.ServiceModel.Security.ExpiredSecurityTokenException
            //      System.ServiceModel.Security.MessageSecurityException
            //      System.ServiceModel.Security.SecurityNegotiationException

            // Second trial to obtain the discovery service proxy in case of single sign-on failure.
            return GetProxy<IDiscoveryService, DiscoveryServiceProxy>(this.config);

        }

        /// <summary>
        /// Verify passed strings with the supported AuthenticationProviderType.
        /// </summary>
        /// <param name="authType">String AuthenticationType</param>
        /// <returns>Supported AuthenticatoinProviderType</returns>
        private AuthenticationProviderType RetrieveAuthenticationType(String authType)
        {
            switch (authType)
            {
                case "ActiveDirectory":
                    return AuthenticationProviderType.ActiveDirectory;
                case "LiveId":
                    return AuthenticationProviderType.LiveId;
                case "Federation":
                    return AuthenticationProviderType.Federation;
                case "OnlineFederation":
                    return AuthenticationProviderType.OnlineFederation;
                default:
                    throw new ArgumentException(String.Format("{0} is not a valid authentication type", authType));
            }
        }

        /// <summary>
        /// Parse credentials from an XML node to required ClientCredentials data type
        /// based on passed AuthenticationProviderType.
        /// </summary>
        /// <param name="credentials">Credential XML node.</param>
        /// <param name="endpointType">AuthenticationProviderType of the credential.</param>
        /// <param name="target">Target is the key with which associated credentials can be fetched.</param>
        /// <returns>Required ClientCredentials type.</returns>
        private ClientCredentials ParseInCredentials(XElement credentials, AuthenticationProviderType endpointType, String target)
        {
            ClientCredentials result = new ClientCredentials();
            if (credentials.HasElements)
            {
                Credential cred = CredentialManager.ReadCredentials(target);
                switch (endpointType)
                {
                    case AuthenticationProviderType.ActiveDirectory:
                        if (null != cred && cred.UserName.Contains("\\"))
                        {
                            String[] domainAndUser = cred.UserName.Split('\\');
                            result.Windows.ClientCredential = new System.Net.NetworkCredential()
                                                    {
                                                        UserName = domainAndUser[1],
                                                        Domain = domainAndUser[0],
                                                        Password = cred.Password
                                                    };
                        }
                        else
                        {
                            result.Windows.ClientCredential = new System.Net.NetworkCredential()
                            {
                                UserName = credentials.Element("UserName").Value,
                                Domain = credentials.Element("Domain").Value
                            };
                        }
                        break;
                    case AuthenticationProviderType.LiveId:
                    case AuthenticationProviderType.Federation:
                    case AuthenticationProviderType.OnlineFederation:
                        if (null != cred)
                        {
                            result.UserName.UserName = cred.UserName;
                            result.UserName.Password = cred.Password;
                        }
                        else
                        {
                            result.UserName.UserName = credentials.Element("UserName").Value;
                        }
                        break;
                    default:
                        break;
                }
            }
            else
                return null;

            return result;
        }

        /// <summary>
        /// Parse ClientCredentials into XML node.
        /// </summary>
        /// <param name="clientCredentials">ClientCredentials type.</param>
        /// <param name="endpointType">AuthenticationProviderType of the credentials.</param>
        /// <param name="target">Target is the key with which associated credentials can be fetched.</param>
        /// <returns>XML node containing credentials data.</returns>
        private XElement ParseOutCredentials(ClientCredentials clientCredentials,
            AuthenticationProviderType endpointType, String target)
        {
            if (clientCredentials != null)
            {
                Credential cred = CredentialManager.ReadCredentials(target);
                switch (endpointType)
                {
                    case AuthenticationProviderType.ActiveDirectory:
                        if (cred == null)
                        {
                            // Add entry in windows credential manager for future use.
                            if (!String.IsNullOrWhiteSpace(clientCredentials.Windows.ClientCredential.Password))
                            {
                                CredentialManager.WriteCredentials(target,
                                    new Credential(clientCredentials.Windows.ClientCredential.Domain + "\\"
                                        + clientCredentials.Windows.ClientCredential.UserName,
                                        clientCredentials.Windows.ClientCredential.Password),
                                    true);
                            }
                        }
                        else
                        {
                            // Replace if the password has been changed.
                            if (!clientCredentials.Windows.ClientCredential.Password.Equals(cred.Password))
                            {
                                CredentialManager.DeleteCredentials(target, false);
                                CredentialManager.WriteCredentials(target,
                                    new Credential(clientCredentials.Windows.ClientCredential.Domain + "\\"
                                        + clientCredentials.Windows.ClientCredential.UserName,
                                        clientCredentials.Windows.ClientCredential.Password),
                                    true);
                            }
                        }
                        return new XElement("Credentials",
                            new XElement("UserName", clientCredentials.Windows.ClientCredential.UserName),
                            new XElement("Domain", clientCredentials.Windows.ClientCredential.Domain)
                            );
                    case AuthenticationProviderType.LiveId:
                    case AuthenticationProviderType.Federation:
                    case AuthenticationProviderType.OnlineFederation:
                        if (cred == null)
                        {
                            // Add entry in windows credential manager for future use.
                            if (!String.IsNullOrWhiteSpace(clientCredentials.UserName.Password))
                            {
                                CredentialManager.WriteCredentials(target,
                                    new Credential(clientCredentials.UserName.UserName,
                                        clientCredentials.UserName.Password),
                                    true);
                            }
                        }
                        else
                        {
                            // Replace if the password has been changed.
                            if (!clientCredentials.UserName.Password.Equals(cred.Password))
                            {
                                CredentialManager.DeleteCredentials(target, false);
                                CredentialManager.WriteCredentials(target,
                                   new Credential(clientCredentials.UserName.UserName,
                                       clientCredentials.UserName.Password),
                                   true);
                            }
                        }
                        return new XElement("Credentials",
                           new XElement("UserName", clientCredentials.UserName.UserName)
                           );
                    default:
                        break;
                }
            }

            return new XElement("Credentials", "");
        }
        #endregion Private methods

        #region Private Classes
        /// <summary>
        /// private static class to store constants required by the CrmServiceHelper class.
        /// </summary>
        private static class CrmServiceHelperConstants
        {
            /// <summary>
            /// Credentials file path.
            /// </summary>
            public static readonly string ServerCredentialsFile = Path.Combine(
                Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.ApplicationData), "CrmServer"),
                "Credentials.xml");
        }
        #endregion
    }

    #region Other Classes
    internal sealed class Credential
    {
        private SecureString _userName;
        private SecureString _password;

        internal Credential(CREDENTIAL_STRUCT cred)
        {
            _userName = ConvertToSecureString(cred.userName);
            int size = (int)cred.credentialBlobSize;
            if (size != 0)
            {
                byte[] bpassword = new byte[size];
                Marshal.Copy(cred.credentialBlob, bpassword, 0, size);
                _password = ConvertToSecureString(Encoding.Unicode.GetString(bpassword));
            }
            else
            {
                _password = ConvertToSecureString(String.Empty);
            }
        }

        public Credential(string userName, string password)
        {
            if (String.IsNullOrWhiteSpace(userName))
                throw new ArgumentNullException("userName");
            if (String.IsNullOrWhiteSpace(password))
                throw new ArgumentNullException("password");

            _userName = ConvertToSecureString(userName);
            _password = ConvertToSecureString(password);
        }

        public string UserName
        {
            get { return ConvertToUnsecureString(_userName); }
        }

        public string Password
        {
            get { return ConvertToUnsecureString(_password); }
        }

        /// <summary>
        /// This converts a SecureString password to plain text
        /// </summary>
        /// <param name="securePassword">SecureString password</param>
        /// <returns>plain text password</returns>
        private string ConvertToUnsecureString(SecureString secret)
        {
            if (secret == null)
                return string.Empty;

            IntPtr unmanagedString = IntPtr.Zero;
            try
            {
                unmanagedString = Marshal.SecureStringToGlobalAllocUnicode(secret);
                return Marshal.PtrToStringUni(unmanagedString);
            }
            finally
            {
                Marshal.ZeroFreeGlobalAllocUnicode(unmanagedString);
            }
        }

        /// <summary>
        /// This converts a string to SecureString
        /// </summary>
        /// <param name="password">plain text password</param>
        /// <returns>SecureString password</returns>
        private SecureString ConvertToSecureString(string secret)
        {
            if (string.IsNullOrEmpty(secret))
                return null;

            SecureString securePassword = new SecureString();
            char[] passwordChars = secret.ToCharArray();
            foreach (char pwdChar in passwordChars)
            {
                securePassword.AppendChar(pwdChar);
            }
            securePassword.MakeReadOnly();
            return securePassword;
        }

        /// <summary>
        /// This structure maps to the CREDENTIAL structure used by native code. We can use this to marshal our values.
        /// </summary>
        [StructLayout(LayoutKind.Sequential, CharSet = CharSet.Unicode)]
        internal struct CREDENTIAL_STRUCT
        {
            public UInt32 flags;
            public UInt32 type;
            public string targetName;
            public string comment;
            public System.Runtime.InteropServices.ComTypes.FILETIME lastWritten;
            public UInt32 credentialBlobSize;
            public IntPtr credentialBlob;
            public UInt32 persist;
            public UInt32 attributeCount;
            public IntPtr credAttribute;
            public string targetAlias;
            public string userName;
        }

    }

    /// <summary>
    /// This class exposes methods to read, write and delete user credentials
    /// </summary>
    internal static class CredentialManager
    {
        /// <summary>
        /// Target Name against which all credentials are stored on the disk.
        /// </summary>
        public const string TargetName = "Microsoft_CRMSDK:";

        /// <summary>
        /// Cache containing secrets in-memory (used to improve performance and avoid IO operations).
        /// </summary>
        private static Dictionary<string, Credential> credentialCache = new Dictionary<string, Credential>();

        public static Uri GetCredentialTarget(Uri target)
        {
            if (null == target)
                throw new ArgumentNullException("target");
            return new Uri(target.GetLeftPart(UriPartial.Authority));
        }

        private enum CRED_TYPE : int
        {
            GENERIC = 1,
            DOMAIN_PASSWORD = 2,
            DOMAIN_CERTIFICATE = 3,
            DOMAIN_VISIBLE_PASSWORD = 4,
            MAXIMUM = 5
        }

        internal enum CRED_PERSIST : uint
        {
            SESSION = 1,
            LOCAL_MACHINE = 2,
            ENTERPRISE = 3
        }

        private static class NativeMethods
        {
            [DllImport("advapi32.dll", SetLastError = true,
                EntryPoint = "CredReadW", CharSet = CharSet.Unicode)]
            [return: MarshalAs(UnmanagedType.Bool)]
            public static extern bool CredRead(string target, CRED_TYPE type, int reservedFlag,
                [MarshalAs(UnmanagedType.CustomMarshaler,
                    MarshalTypeRef = typeof(CredentialMarshaler))] out Credential credential);

            [DllImport("Advapi32.dll", SetLastError = true,
                EntryPoint = "CredWriteW", CharSet = CharSet.Unicode)]
            [return: MarshalAs(UnmanagedType.Bool)]
            public static extern bool CredWrite(ref Credential.CREDENTIAL_STRUCT credential, UInt32 flags);

            [DllImport("Advapi32.dll", EntryPoint = "CredFree", SetLastError = true)]
            [return: MarshalAs(UnmanagedType.Bool)]
            public static extern bool CredFree(IntPtr cred);

            [DllImport("advapi32.dll", EntryPoint = "CredDeleteW", CharSet = CharSet.Unicode)]
            [return: MarshalAs(UnmanagedType.Bool)]
            public static extern bool CredDelete(string target, int type, int flags);
        }

        private sealed class CredentialMarshaler : ICustomMarshaler
        {
            private static CredentialMarshaler _instance;

            public void CleanUpManagedData(object ManagedObj)
            {
                // Nothing to do since all data can be garbage collected.
            }

            public void CleanUpNativeData(IntPtr pNativeData)
            {
                if (pNativeData == IntPtr.Zero)
                {
                    return;
                }
                NativeMethods.CredFree(pNativeData);
            }

            public int GetNativeDataSize()
            {
                throw new NotImplementedException("The method or operation is not implemented.");
            }

            public IntPtr MarshalManagedToNative(object obj)
            {
                throw new NotImplementedException("Not implemented yet");
            }

            public object MarshalNativeToManaged(IntPtr pNativeData)
            {
                if (pNativeData == IntPtr.Zero)
                {
                    return null;
                }
                return new Credential((Credential.CREDENTIAL_STRUCT)Marshal.PtrToStructure(pNativeData, typeof(Credential.CREDENTIAL_STRUCT)));
            }

            public static ICustomMarshaler GetInstance(string cookie)
            {
                if (null == _instance)
                    _instance = new CredentialMarshaler();
                return _instance;
            }
        }

        public static Credential ReadCredentials(String target)
        {
            Credential cachedCredential;

            // Try to read the username from cache
            if (credentialCache.TryGetValue(TargetName + target, out cachedCredential))
            {
                return cachedCredential;
            }

            Credential credential;
            bool bSuccess = NativeMethods.CredRead(TargetName + target, CRED_TYPE.GENERIC, 0, out credential);
            // No match found.
            if (!bSuccess)
            {
                return null;
            }

            credentialCache[TargetName + target.ToString()] = credential;
            return credential;
        }

        public static Credential ReadWindowsCredential(Uri target)
        {
            Credential credential;
            bool bSuccess = NativeMethods.CredRead(target.Host, CRED_TYPE.DOMAIN_PASSWORD, 0, out credential);
            if (!bSuccess)
            {
                throw new InvalidOperationException("Unable to read windows credentials for Uri {0}. ErrorCode {1}",
                    new System.ComponentModel.Win32Exception(Marshal.GetLastWin32Error()));
            }
            return credential;
        }
        /// <summary>
        /// Fetches the credentials.
        /// </summary>
        /// <param name="target">Target is the key with which associated credentials can be fetched</param>
        /// <param name="userCredentials">It is the in parameter which contains the username and password</param>
        /// <param name="allowPhysicalStore">If allowPhysicalStore is true then the credentials are stored on disk</param>
        public static void WriteCredentials(String target, Credential userCredentials, bool allowPhysicalStore)
        {
            if (String.IsNullOrWhiteSpace(target))
                throw new ArgumentNullException("target");
            if (null == userCredentials)
                throw new ArgumentNullException("userCredentials");
            // Cache the username and password in memory
            credentialCache[TargetName + target] = userCredentials;

            // Store the credentials if allowed
            string passwordToStore = allowPhysicalStore ? userCredentials.Password : string.Empty;
            Credential.CREDENTIAL_STRUCT credential = new Credential.CREDENTIAL_STRUCT();
            try
            {
                credential.targetName = TargetName + target;
                credential.type = (UInt32)CRED_TYPE.GENERIC;
                credential.userName = userCredentials.UserName;
                credential.attributeCount = 0;
                credential.persist = (UInt32)CRED_PERSIST.LOCAL_MACHINE;
                byte[] bpassword = Encoding.Unicode.GetBytes(passwordToStore);
                credential.credentialBlobSize = (UInt32)bpassword.Length;
                credential.credentialBlob = Marshal.AllocCoTaskMem(bpassword.Length);
                Marshal.Copy(bpassword, 0, credential.credentialBlob, bpassword.Length);
                if (!NativeMethods.CredWrite(ref credential, 0))
                {
                    throw new System.ComponentModel.Win32Exception(Marshal.GetLastWin32Error());
                }
            }
            finally
            {
                if (IntPtr.Zero != credential.credentialBlob)
                    Marshal.FreeCoTaskMem(credential.credentialBlob);
            }
        }

        /// <summary>
        /// Deletes the credentials.
        /// </summary>
        /// <param name="target">Target is the key with which associated credentials can be fetched</param>
        /// <param name="softDelete">If a softDelete is done then credentials are deleted only from memory.
        /// They are completely removed otherwise.</param>
        public static void DeleteCredentials(String target, bool softDelete)
        {
            if (String.IsNullOrWhiteSpace(target))
                throw new ArgumentNullException("target");
            if (softDelete)
            {
                // Removes only the password
                try
                {
                    Credential tempCredential = ReadCredentials(target);
                    WriteCredentials(target, new Credential(tempCredential.UserName, String.Empty), true);
                }
                catch (Exception)
                {
                    // Do nothing
                }
            }
            else
            {
                // Removes the entry completely
                NativeMethods.CredDelete(TargetName + target, (int)CRED_TYPE.GENERIC, 0);
                credentialCache.Remove(TargetName + target);
            }
        }
    }

    /// <summary>
    /// Wrapper class for DiscoveryServiceProxy to support auto refresh security token.
    /// </summary>
    internal sealed class ManagedTokenDiscoveryServiceProxy : DiscoveryServiceProxy
    {
        private AutoRefreshSecurityToken<DiscoveryServiceProxy, IDiscoveryService> _proxyManager;

        public ManagedTokenDiscoveryServiceProxy(Uri serviceUri, ClientCredentials userCredentials)
            : base(serviceUri, null, userCredentials, null)
        {
            this._proxyManager = new AutoRefreshSecurityToken<DiscoveryServiceProxy, IDiscoveryService>(this);
        }

        public ManagedTokenDiscoveryServiceProxy(IServiceManagement<IDiscoveryService> serviceManagement,
            SecurityTokenResponse securityTokenRes)
            : base(serviceManagement, securityTokenRes)
        {
            this._proxyManager = new AutoRefreshSecurityToken<DiscoveryServiceProxy, IDiscoveryService>(this);
        }

        public ManagedTokenDiscoveryServiceProxy(IServiceManagement<IDiscoveryService> serviceManagement,
           ClientCredentials userCredentials)
            : base(serviceManagement, userCredentials)
        {
            this._proxyManager = new AutoRefreshSecurityToken<DiscoveryServiceProxy, IDiscoveryService>(this);
        }

        protected override SecurityTokenResponse AuthenticateDeviceCore()
        {
            return this._proxyManager.AuthenticateDevice();
        }

        protected override void AuthenticateCore()
        {
            this._proxyManager.PrepareCredentials();
            base.AuthenticateCore();
        }

        protected override void ValidateAuthentication()
        {
            this._proxyManager.RenewTokenIfRequired();
            base.ValidateAuthentication();
        }
    }

    /// <summary>
    /// Wrapper class for OrganizationServiceProxy to support auto refresh security token
    /// </summary>
    internal sealed class ManagedTokenOrganizationServiceProxy : OrganizationServiceProxy
    {
        private AutoRefreshSecurityToken<OrganizationServiceProxy, IOrganizationService> _proxyManager;

        public ManagedTokenOrganizationServiceProxy(Uri serviceUri, ClientCredentials userCredentials)
            : base(serviceUri, null, userCredentials, null)
        {
            this._proxyManager = new AutoRefreshSecurityToken<OrganizationServiceProxy, IOrganizationService>(this);
        }

        public ManagedTokenOrganizationServiceProxy(IServiceManagement<IOrganizationService> serviceManagement,
            SecurityTokenResponse securityTokenRes)
            : base(serviceManagement, securityTokenRes)
        {
            this._proxyManager = new AutoRefreshSecurityToken<OrganizationServiceProxy, IOrganizationService>(this);
        }

        public ManagedTokenOrganizationServiceProxy(IServiceManagement<IOrganizationService> serviceManagement,
            ClientCredentials userCredentials)
            : base(serviceManagement, userCredentials)
        {
            this._proxyManager = new AutoRefreshSecurityToken<OrganizationServiceProxy, IOrganizationService>(this);
        }

        protected override SecurityTokenResponse AuthenticateDeviceCore()
        {
            return this._proxyManager.AuthenticateDevice();
        }

        protected override void AuthenticateCore()
        {
            this._proxyManager.PrepareCredentials();
            base.AuthenticateCore();
        }

        protected override void ValidateAuthentication()
        {
            this._proxyManager.RenewTokenIfRequired();
            base.ValidateAuthentication();
        }
    }

    /// <summary>
    /// Class that wraps acquiring the security token for a service
    /// </summary>
    public sealed class AutoRefreshSecurityToken<TProxy, TService>
        where TProxy : ServiceProxy<TService>
        where TService : class
    {
        private ClientCredentials _deviceCredentials;
        private TProxy _proxy;

        /// <summary>
        /// Instantiates an instance of the proxy class
        /// </summary>
        /// <param name="proxy">Proxy that will be used to authenticate the user</param>
        public AutoRefreshSecurityToken(TProxy proxy)
        {
            if (null == proxy)
            {
                throw new ArgumentNullException("proxy");
            }

            this._proxy = proxy;
        }

        /// <summary>
        /// Prepares authentication before authen6ticated
        /// </summary>
        public void PrepareCredentials()
        {
            if (null == this._proxy.ClientCredentials)
            {
                return;
            }

            switch (this._proxy.ServiceConfiguration.AuthenticationType)
            {
                case AuthenticationProviderType.ActiveDirectory:
                    this._proxy.ClientCredentials.UserName.UserName = null;
                    this._proxy.ClientCredentials.UserName.Password = null;
                    break;
                case AuthenticationProviderType.Federation:
                case AuthenticationProviderType.LiveId:
                    this._proxy.ClientCredentials.Windows.ClientCredential = null;
                    break;
                default:
                    return;
            }
        }

        /// <summary>
        /// Authenticates the device token
        /// </summary>
        /// <returns>Generated SecurityTokenResponse for the device</returns>
        public SecurityTokenResponse AuthenticateDevice()
        {
            if (null == this._deviceCredentials)
            {
                this._deviceCredentials = DeviceIdManager.LoadOrRegisterDevice(
                    this._proxy.ServiceConfiguration.CurrentIssuer.IssuerAddress.Uri);
            }

            return this._proxy.ServiceConfiguration.AuthenticateDevice(this._deviceCredentials);
        }

        /// <summary>
        /// Renews the token (if it is near expiration or has expired)
        /// </summary>
        public void RenewTokenIfRequired()
        {
            if (null != this._proxy.SecurityTokenResponse &&
                DateTime.UtcNow.AddMinutes(15) >= this._proxy.SecurityTokenResponse.Response.Lifetime.Expires)
            {
                try
                {
                    this._proxy.Authenticate();
                }
                catch (CommunicationException)
                {
                    if (null == this._proxy.SecurityTokenResponse ||
                        DateTime.UtcNow >= this._proxy.SecurityTokenResponse.Response.Lifetime.Expires)
                    {
                        throw;
                    }

                    // Ignore the exception
                }
            }
        }
    }
    #endregion
}
Visual Basic Copy Code
Option Explicit On
Option Strict On
Imports Microsoft.VisualBasic
Imports System
Imports System.Collections.Generic
Imports System.Diagnostics.CodeAnalysis
Imports System.DirectoryServices.AccountManagement
Imports System.IO
Imports System.Runtime.InteropServices
Imports System.Security
Imports System.ServiceModel
Imports System.ServiceModel.Description
Imports System.Text
Imports System.Xml
Imports System.Xml.Linq

' These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
' located in the SDK\bin folder of the SDK download.
Imports Microsoft.Xrm.Sdk
Imports Microsoft.Xrm.Sdk.Client
Imports Microsoft.Xrm.Sdk.Discovery
Imports Microsoft.Crm.Services.Utility

Namespace Microsoft.Crm.Sdk.Samples
    ''' <summary>
    ''' Provides server connection information.
    ''' </summary>
    Public Class ServerConnection
        #Region "Inner classes"
        ''' <summary>
        ''' Stores Microsoft Dynamics CRM server configuration information.
        ''' </summary>
        Public Class Configuration
            Public ServerAddress As String
            Public OrganizationName As String
            Public DiscoveryUri As Uri
            Public OrganizationUri As Uri
            Public HomeRealmUri As Uri = Nothing
            Public DeviceCredentials As ClientCredentials = Nothing
            Public Credentials As ClientCredentials = Nothing
            Public EndpointType As AuthenticationProviderType
            Public UserPrincipalName As String
#Region "internal members of the class"
            Friend OrganizationServiceManagement As IServiceManagement(Of IOrganizationService)
            Friend OrganizationTokenResponse As SecurityTokenResponse
            Friend AuthFailureCount As Int16 = 0
#End Region

            Public Overrides Overloads Function Equals(ByVal obj As Object) As Boolean
                'Check for null and compare run-time types.
                If obj Is Nothing OrElse Me.GetType() IsNot obj.GetType() Then
                    Return False
                End If

                Dim c As Configuration = CType(obj, Configuration)

                If Not Me.ServerAddress.Equals(c.ServerAddress, StringComparison.InvariantCultureIgnoreCase) Then
                    Return False
                End If
                If Not Me.OrganizationName.Equals(c.OrganizationName, StringComparison.InvariantCultureIgnoreCase) Then
                    Return False
                End If
                If Me.EndpointType <> c.EndpointType Then
                    Return False
                End If
                If Nothing IsNot Me.Credentials AndAlso Nothing IsNot c.Credentials Then
                    If Me.EndpointType = AuthenticationProviderType.ActiveDirectory Then
                        If Not Me.Credentials.Windows.ClientCredential.Domain.Equals(c.Credentials.Windows.ClientCredential.Domain,
                                                                                StringComparison.InvariantCultureIgnoreCase) Then
                            Return False
                        End If
                        If Not Me.Credentials.Windows.ClientCredential.UserName.Equals(c.Credentials.Windows.ClientCredential.UserName,
                                                                                StringComparison.InvariantCultureIgnoreCase) Then
                            Return False
                        End If
                    ElseIf Me.EndpointType = AuthenticationProviderType.LiveId Then
                        If Not Me.Credentials.UserName.UserName.Equals(c.Credentials.UserName.UserName,
                                                                       StringComparison.InvariantCultureIgnoreCase) Then
                            Return False
                        End If
                        If Not Me.DeviceCredentials.UserName.UserName.Equals(c.DeviceCredentials.UserName.UserName,
                                                                             StringComparison.InvariantCultureIgnoreCase) Then
                            Return False
                        End If
                        If Not Me.DeviceCredentials.UserName.Password.Equals(c.DeviceCredentials.UserName.Password,
                                                                             StringComparison.InvariantCultureIgnoreCase) Then
                            Return False
                        End If
                    Else
                        If Not Me.Credentials.UserName.UserName.Equals(c.Credentials.UserName.UserName,
                                                                       StringComparison.InvariantCultureIgnoreCase) Then
                            Return False
                        End If

                    End If
                End If
                Return True
            End Function

            Public Overrides Function GetHashCode() As Integer
                Dim returnHashCode As Integer = Me.ServerAddress.GetHashCode() _
                                                Xor Me.OrganizationName.GetHashCode() _
                                                Xor Me.EndpointType.GetHashCode()
                If Nothing IsNot Me.Credentials Then
                If Me.EndpointType = AuthenticationProviderType.ActiveDirectory Then
                    returnHashCode = returnHashCode _
                        Xor Me.Credentials.Windows.ClientCredential.UserName.GetHashCode() _
                        Xor Me.Credentials.Windows.ClientCredential.Domain.GetHashCode()
                ElseIf Me.EndpointType = AuthenticationProviderType.LiveId Then
                    returnHashCode = returnHashCode _
                        Xor Me.Credentials.UserName.UserName.GetHashCode() _
                        Xor Me.DeviceCredentials.UserName.UserName.GetHashCode() _
                        Xor Me.DeviceCredentials.UserName.Password.GetHashCode()
                Else
                    returnHashCode = returnHashCode _
                        Xor Me.Credentials.UserName.UserName.GetHashCode()
                End If
                End If
                Return returnHashCode
            End Function

        End Class
#End Region ' Inner classes

#Region "Public properties"

        Public configurations As List(Of Configuration) = Nothing

#End Region ' Public properties

#Region "Private properties"

        Private config As New Configuration()

#End Region ' Private properties

        #Region "Static methods"
        ''' <summary>
        ''' Obtains the organization service proxy.
        ''' This would give a better performance than directly calling GetProxy() generic method
        ''' as it uses cached OrganizationServiceManagement in case it is present.
        ''' </summary>
        ''' <param name="serverConfiguration">An instance of ServerConnection.Configuration</param>
        ''' <returns>An instance of organization service proxy</returns>
        Public Shared Function GetOrganizationProxy(ByVal serverConfiguration As ServerConnection.Configuration) As OrganizationServiceProxy
            ' If organization service management exists, then use it.
            ' Otherwise generate organization service proxy from scratch.
            If Nothing IsNot serverConfiguration.OrganizationServiceManagement Then
                ' Obtain the organization service proxy for the Federated, Microsoft account, and OnlineFederated environments.
                If serverConfiguration.EndpointType <> AuthenticationProviderType.ActiveDirectory Then
                    ' get the organization service proxy.
                    Return GetProxy(Of IOrganizationService, OrganizationServiceProxy)(serverConfiguration)

                    ' Obtain organization service proxy for ActiveDirectory environment
                    ' using existing organization service management.
                Else
                    Return New ManagedTokenOrganizationServiceProxy(serverConfiguration.OrganizationServiceManagement, serverConfiguration.Credentials)
                End If
            End If

            ' Obtain the organization service proxy for all type of environments.
            Return GetProxy(Of IOrganizationService, OrganizationServiceProxy)(serverConfiguration)

        End Function
        #End Region ' Static methods

#Region "Public methods"
        ''' <summary>
        ''' Obtains the server connection information including the target organization's
        ''' Uri and user logon credentials from the user.
        ''' </summary>
        Public Overridable Function GetServerConfiguration() As Configuration
            Dim ssl As Boolean
            Dim addConfig As Boolean
            Dim configNumber As Integer
            ' Read the configuration from the disk, if it exists, at C:\Users\<username>\AppData\Roaming\CrmServer\Credentials.xml.
            Dim isConfigExist As Boolean = ReadConfigurations()

            ' Check if server configuration settings are already available on the disk.
            If isConfigExist Then
                ' List of server configurations that are available from earlier saved settings.
                Console.Write(vbLf & "(0) Add New Server Configuration (Maximum number up to 9)" & vbTab)
                For n As Integer = 0 To configurations.Count - 1
                    Dim user As String

                    Select Case configurations(n).EndpointType
                        Case AuthenticationProviderType.ActiveDirectory
                            If configurations(n).Credentials IsNot Nothing Then
                                user = configurations(n).Credentials.Windows.ClientCredential.Domain & "\" & _
                                    configurations(n).Credentials.Windows.ClientCredential.UserName
                            Else
                                user = "default"
                            End If
                        Case Else
                            If configurations(n).Credentials IsNot Nothing Then
                                user = configurations(n).Credentials.UserName.UserName
                            Else
                                user = "default"
                            End If
                    End Select

                    Console.Write(vbLf & "({0}) Server: {1},  Org: {2},  User: {3}" & vbTab, n + 1, configurations(n).ServerAddress, _
                                  configurations(n).OrganizationName, user)
                Next n

                Console.WriteLine()

                Console.Write(vbLf & "Specify the saved server configuration number (1-{0}) [{0}] : ", configurations.Count)
                Dim input As String = Console.ReadLine()
                Console.WriteLine()
                If input = String.Empty Then
                    input = configurations.Count.ToString()
                End If
                If Not Int32.TryParse(input, configNumber) Then
                    configNumber = -1
                End If

                If configNumber = 0 Then
                    addConfig = True
                ElseIf configNumber > 0 AndAlso configNumber <= configurations.Count Then
                    ' Return the organization Uri.
                    config = configurations(configNumber - 1)
                    ' Reorder the configuration list and save it to file to save the recent configuration as a latest one.
                    If configNumber <> configurations.Count Then
                        Dim temp As Configuration = configurations(configurations.Count - 1)
                        configurations(configurations.Count - 1) = configurations(configNumber - 1)
                        configurations(configNumber - 1) = temp
                    End If
                    addConfig = False
                Else
                    Throw New InvalidOperationException("The specified server configuration does not exist.")
                End If
            Else
                addConfig = True
            End If

            If addConfig Then
                ' Get the server address. If no value is entered, default to Microsoft Dynamics
                ' CRM Online in the North American data center.
                config.ServerAddress = GetServerAddress(ssl)
                If String.IsNullOrWhiteSpace(config.ServerAddress) Then
                    config.ServerAddress = "crm.dynamics.com"
                End If

                ' One of the Microsoft Dynamics CRM Online data centers.
                If config.ServerAddress.EndsWith(".dynamics.com", StringComparison.InvariantCultureIgnoreCase) Then
                    ' Check if the organization is provisioned in Microsoft Office 365.
                    If GetOrgType(config.ServerAddress) Then
                        config.DiscoveryUri = New Uri(String.Format("https://disco.{0}/XRMServices/2011/Discovery.svc", config.ServerAddress))
                    Else
                        config.DiscoveryUri = New Uri(String.Format("https://dev.{0}/XRMServices/2011/Discovery.svc", config.ServerAddress))

                        ' Get or set the device credentials. This is required for Microsoft account authentication.
                        config.DeviceCredentials = GetDeviceCredentials()
                    End If
                    ' Check if the server uses Secure Socket Layer (https).
                ElseIf ssl Then
                    config.DiscoveryUri = New Uri(String.Format("https://{0}/XRMServices/2011/Discovery.svc", config.ServerAddress))
                Else
                    config.DiscoveryUri = New Uri(String.Format("http://{0}/XRMServices/2011/Discovery.svc", config.ServerAddress))
                End If

                ' Get the target organization.
                config.OrganizationUri = GetOrganizationAddress()
                configurations.Add(config)
                Dim length As Integer = configurations.Count
                Dim i As Integer = length - 2
                ' Check if a new configuration already exists.
                ' If found, reorder list to show latest in use.
                Do While i > 0

                    If configurations(configurations.Count - 1).Equals(configurations(i)) Then
                        configurations.RemoveAt(i)
                    End If
                    i -= 1
                Loop
                ' Set max configurations to 9 otherwise overwrite existing one.
                If configurations.Count > 9 Then
                    configurations.RemoveAt(0)
                End If
            Else
                ' Get the existing user's logon credentials.
                config.Credentials = GetUserLogonCredentials(config)
            End If
            SaveConfigurations()
            Return config
        End Function

        ''' <summary>
        ''' Discovers the organizations that the calling user belongs to.
        ''' </summary>
        ''' <param name="service">A Discovery service proxy instance.</param>
        ''' <returns>Array containing detailed information on each organization that
        ''' the user belongs to.</returns>
        Public Function DiscoverOrganizations(ByVal service As IDiscoveryService) As OrganizationDetailCollection
            If service Is Nothing Then
                Throw New ArgumentNullException("service")
            End If
            Dim orgRequest As New RetrieveOrganizationsRequest()
            Dim orgResponse As RetrieveOrganizationsResponse = CType(service.Execute(orgRequest), RetrieveOrganizationsResponse)

            Return orgResponse.Details
        End Function

        ''' <summary>
        ''' Finds a specific organization detail in the array of organization details
        ''' returned from the Discovery service.
        ''' </summary>
        ''' <param name=orgFriendlyName">The friendly name of the organization to find.</param>
        ''' <param name="orgDetails">Array of organization detail object returned from the discovery service.</param>
        ''' <returns>Organization details or null if the organization was not found.</returns>
        ''' <seealso cref="DiscoveryOrganizations"/>
        Public Function FindOrganization(ByVal orgFriendlyName As String, ByVal orgDetails() As OrganizationDetail) As OrganizationDetail
            If String.IsNullOrWhiteSpace(orgFriendlyName) Then
                Throw New ArgumentNullException("orgFriendlyName")
            End If
            If orgDetails Is Nothing Then
                Throw New ArgumentNullException("orgDetails")
            End If
            Dim orgDetail As OrganizationDetail = Nothing

            For Each detail As OrganizationDetail In orgDetails
                If String.Compare(detail.FriendlyName, orgFriendlyName, StringComparison.InvariantCultureIgnoreCase) = 0 Then
                    orgDetail = detail
                    Exit For
                End If
            Next detail
            Return orgDetail
        End Function

        ''' <summary>
        ''' Reads a server configuration file.
        ''' Read the configuration from disk, if it exists, at C:\Users\YourUserName\AppData\Roaming\CrmServer\Credentials.xml.
        ''' </summary>
        ''' <returns>Is configuration settings already available on disk.</returns>
        Public Function ReadConfigurations() As Boolean
            Dim isConfigExist As Boolean = False

            If configurations Is Nothing Then
                configurations = New List(Of Configuration)()
            End If

            If File.Exists(CrmServiceHelperConstants.ServerCredentialsFile) Then
                Dim configurationsFromFile As XElement = XElement.Load(CrmServiceHelperConstants.ServerCredentialsFile)
                For Each config As XElement In configurationsFromFile.Nodes()
                    Dim newConfig As New Configuration()
                    Dim serverAddress = config.Element("ServerAddress")
                    If serverAddress IsNot Nothing Then
                        If Not String.IsNullOrEmpty(serverAddress.Value) Then
                            newConfig.ServerAddress = serverAddress.Value
                        End If
                    End If
                    Dim organizationName = config.Element("OrganizationName")
                    If organizationName IsNot Nothing Then
                        If Not String.IsNullOrEmpty(organizationName.Value) Then
                            newConfig.OrganizationName = organizationName.Value
                        End If
                    End If
                    Dim discoveryUri = config.Element("DiscoveryUri")
                    If discoveryUri IsNot Nothing Then
                        If Not String.IsNullOrEmpty(discoveryUri.Value) Then
                            newConfig.DiscoveryUri = New Uri(discoveryUri.Value)
                        End If
                    End If
                    Dim organizationUri = config.Element("OrganizationUri")
                    If organizationUri IsNot Nothing Then
                        If Not String.IsNullOrEmpty(organizationUri.Value) Then
                            newConfig.OrganizationUri = New Uri(organizationUri.Value)
                        End If
                    End If
                    Dim homeRealmUri = config.Element("HomeRealmUri")
                    If homeRealmUri IsNot Nothing Then
                        If Not String.IsNullOrEmpty(homeRealmUri.Value) Then
                            newConfig.HomeRealmUri = New Uri(homeRealmUri.Value)
                        End If
                    End If

                    Dim vendpointType = config.Element("EndpointType")
                    If vendpointType IsNot Nothing Then
                        newConfig.EndpointType = RetrieveAuthenticationType(vendpointType.Value)
                    End If
                    If config.Element("Credentials").HasElements Then
                        newConfig.Credentials =
                            ParseInCredentials(config.Element("Credentials"),
                                               newConfig.EndpointType,
                                               newConfig.ServerAddress + ":" + newConfig.OrganizationName + ":" + config.Element("Credentials").Element("UserName").Value)
                    End If
                    If newConfig.EndpointType = AuthenticationProviderType.LiveId Then
                        newConfig.DeviceCredentials = GetDeviceCredentials()
                    End If
                    Dim userPrincipalName = config.Element("UserPrincipalName")
                    If userPrincipalName IsNot Nothing Then
                        If Not String.IsNullOrWhiteSpace(userPrincipalName.Value) Then
                            newConfig.UserPrincipalName = userPrincipalName.Value
                        End If
                    End If
                    configurations.Add(newConfig)
                Next config
            End If

            If configurations.Count > 0 Then
                isConfigExist = True
            End If

            Return isConfigExist
        End Function

        ''' <summary>
        ''' Writes all server configurations to a file.
        ''' </summary>
        ''' <remarks>If the file exists, it is overwritten.</remarks>
        Public Sub SaveConfigurations()
            If configurations Is Nothing Then
                Throw New NullReferenceException("No server connection configurations were found.")
            End If

            Dim file As New FileInfo(CrmServiceHelperConstants.ServerCredentialsFile)

            ' Create directory if it does not exist.
            If Not file.Directory.Exists Then
                file.Directory.Create()
            End If

            ' Replace file if it exists.
            Using fs As FileStream = file.Open(FileMode.Create, FileAccess.Write, FileShare.None)
                Using writer As New XmlTextWriter(fs, Encoding.UTF8)
                    writer.Formatting = Formatting.Indented
                    writer.WriteStartDocument()
                    writer.WriteStartElement("Configurations")
                    writer.WriteFullEndElement()
                    writer.WriteEndDocument()
                End Using
            End Using

            For Each config As Configuration In configurations
                SaveConfiguration(CrmServiceHelperConstants.ServerCredentialsFile, config, True)
            Next config
        End Sub

        ''' <summary>
        ''' Writes a server configuration to a file.
        ''' </summary>
        ''' <param name="pathname">The file name and system path of the output configuration file.</param>
        ''' <param name="config">A server connection configuration.</param>
        ''' <param name="append">If true, the configuration is appended to the file, otherwise a new file
        ''' is created.</param>
        Public Sub SaveConfiguration(ByVal pathname As String, ByVal config As Configuration, ByVal append As Boolean)
            If String.IsNullOrWhiteSpace(pathname) Then
                Throw New ArgumentNullException("pathname")
            End If
            If config Is Nothing Then
                Throw New ArgumentNullException("config")
            End If
            ' Target is the key with which associated credentials can be fetched from windows credentials manager.
            Dim target As String = config.ServerAddress & ":" & config.OrganizationName
            If Nothing IsNot config.Credentials Then
                Select Case config.EndpointType
                    Case AuthenticationProviderType.ActiveDirectory
                        target = target & ":" & config.Credentials.Windows.ClientCredential.UserName
                    Case AuthenticationProviderType.LiveId,
                        AuthenticationProviderType.Federation,
                        AuthenticationProviderType.OnlineFederation
                        target = target & ":" & config.Credentials.UserName.UserName
                    Case Else
                        target = String.Empty
                End Select
            End If

            Dim configurationsFromFile As XElement = XElement.Load(pathname)
            Dim newConfig As New XElement("Configuration",
                                          New XElement("ServerAddress",
                                                       config.ServerAddress),
                                          New XElement("OrganizationName",
                                                       config.OrganizationName),
                                          New XElement("DiscoveryUri",
                                                       If(config.DiscoveryUri IsNot Nothing,
                                                          config.DiscoveryUri.OriginalString,
                                                          String.Empty)),
                                          New XElement("OrganizationUri",
                                                       If(config.OrganizationUri IsNot Nothing,
                                                          config.OrganizationUri.OriginalString,
                                                          String.Empty)),
                                          New XElement("HomeRealmUri",
                                                       If(config.HomeRealmUri IsNot Nothing,
                                                          config.HomeRealmUri.OriginalString,
                                                          String.Empty)),
                                          ParseOutCredentials(config.Credentials,
                                                              config.EndpointType,
                                                              target),
                                          New XElement("EndpointType",
                                                       config.EndpointType.ToString()),
                                          New XElement("UserPrincipalName",
                                                       If(config.UserPrincipalName IsNot Nothing,
                                                          config.UserPrincipalName, String.Empty)
                                                      )
                                         )

            If append Then
                configurationsFromFile.Add(newConfig)
            Else
                configurationsFromFile.ReplaceAll(newConfig)
            End If

            Using writer As New XmlTextWriter(pathname, Encoding.UTF8)
                writer.Formatting = Formatting.Indented
                configurationsFromFile.Save(writer)
            End Using
        End Sub

        ''' <summary>
        ''' Obtains the user's logon credentials for the target server.
        ''' </summary>
        ''' <param name="config">An instance of the Configuration.</param>
        ''' <returns>Logon credentials of the user.</returns>
        Public Shared Function GetUserLogonCredentials(ByVal config As ServerConnection.Configuration) As ClientCredentials
            Dim credentials As New ClientCredentials()
            Dim userName As String
            Dim password As SecureString
            Dim domain As String
            Dim isCredentialExist As Boolean = If(config.Credentials IsNot Nothing, True, False)
            Select Case config.EndpointType
                ' An on-premises Microsoft Dynamics CRM server deployment.
                Case AuthenticationProviderType.ActiveDirectory
                    ' Uses credentials from windows credential manager for earlier saved configuration.
                    If isCredentialExist AndAlso (Not String.IsNullOrWhiteSpace(config.OrganizationName)) Then
                        domain = config.Credentials.Windows.ClientCredential.Domain
                        userName = config.Credentials.Windows.ClientCredential.UserName
                        If String.IsNullOrWhiteSpace(config.Credentials.Windows.ClientCredential.Password) Then
                            Console.Write(vbLf & "Enter domain\username: ")
                            Console.WriteLine(config.Credentials.Windows.ClientCredential.Domain _
                                              & "\" & config.Credentials.Windows.ClientCredential.UserName)

                            Console.Write("       Enter Password: ")
                            password = ReadPassword()
                        Else
                            password = config.Credentials.Windows.ClientCredential.SecurePassword
                        End If
                        ' Uses default credentials saved in windows credential manager for current organization.
                    ElseIf (Not isCredentialExist) AndAlso (Not String.IsNullOrWhiteSpace(config.OrganizationName)) Then
                        Return Nothing
                        ' Prompts users to enter credential for current organization.
                    Else
                        Dim domainAndUserName() As String
                        Do
                            Console.Write(vbLf & "Enter domain\username: ")
                            domainAndUserName = Console.ReadLine().Split("\"c)

                            ' If user do not choose to enter user name,
                            ' then try to use default credential from windows credential manager.
                            If domainAndUserName.Length = 1 AndAlso
                                String.IsNullOrWhiteSpace(domainAndUserName(0)) Then
                                Return Nothing
                            End If
                        Loop While domainAndUserName.Length <> 2 OrElse
                            String.IsNullOrWhiteSpace(domainAndUserName(0)) OrElse
                            String.IsNullOrWhiteSpace(domainAndUserName(1))

                        domain = domainAndUserName(0)
                        userName = domainAndUserName(1)

                        Console.Write("       Enter Password: ")
                        password = ReadPassword()
                    End If
                    If Nothing IsNot password Then
                        credentials.Windows.ClientCredential =
                            New System.Net.NetworkCredential(userName, password, domain)
                    Else
                        credentials.Windows.ClientCredential = Nothing
                    End If

                    ' A Microsoft Dynamics CRM Online server deployment.
                Case AuthenticationProviderType.LiveId,
                    AuthenticationProviderType.Federation,
                    AuthenticationProviderType.OnlineFederation
                    ' An internet-facing deployment (IFD) of Microsoft Dynamics CRM.
                    ' Managed Identity/Federated Identity users using Microsoft Office 365.
                    ' Use saved credentials.
                    If isCredentialExist Then
                        userName = config.Credentials.UserName.UserName
                        If String.IsNullOrWhiteSpace(config.Credentials.UserName.Password) Then
                            Console.Write(vbLf & " Enter Username: ")
                            Console.WriteLine(config.Credentials.UserName.UserName)

                            Console.Write(" Enter Password: ")
                            password = ReadPassword()
                        Else
                            password = ConvertToSecureString(config.Credentials.UserName.Password)
                        End If
                        ' For OnlineFederation environments, initially try to authenticate with the current UserPrincipalName
                        ' for single sign-on scenario.
                    ElseIf config.EndpointType = AuthenticationProviderType.OnlineFederation AndAlso
                        config.AuthFailureCount = 0 AndAlso
                        (Not String.IsNullOrWhiteSpace(UserPrincipal.Current.UserPrincipalName)) Then
                        config.UserPrincipalName = UserPrincipal.Current.UserPrincipalName
                        Return Nothing
                        ' Otherwise request username and password.
                    Else
                        config.UserPrincipalName = String.Empty
                        If config.EndpointType = AuthenticationProviderType.LiveId Then
                            Console.Write(vbLf & " Enter Microsoft account: ")
                        Else
                            Console.Write(vbLf & " Enter Username: ")
                        End If
                        userName = Console.ReadLine()
                        If String.IsNullOrWhiteSpace(userName) Then
                            Return Nothing
                        End If

                        Console.Write(" Enter Password: ")
                        password = ReadPassword()
                    End If
                    credentials.UserName.UserName = userName
                    credentials.UserName.Password = ConvertToUnsecureString(password)
                Case Else
                    credentials = Nothing
            End Select
            Return credentials
        End Function

        ''' <summary>
        ''' Prompts user to enter password in console window
        ''' and capture the entered password into SecureString.
        ''' </summary>
        ''' <returns>Password stored in a secure string.</returns>
        Public Shared Function ReadPassword() As SecureString
            Dim ssPassword As New SecureString()

            Dim info As ConsoleKeyInfo = Console.ReadKey(True)
            Do While info.Key <> ConsoleKey.Enter
                If info.Key = ConsoleKey.Backspace Then
                    If ssPassword.Length <> 0 Then
                        ssPassword.RemoveAt(ssPassword.Length - 1)
                        Console.Write(vbBack & " " & vbBack) ' erase last char
                    End If
                ElseIf info.KeyChar >= " "c Then ' no control chars
                    ssPassword.AppendChar(info.KeyChar)
                    Console.Write("*")
                End If
                info = Console.ReadKey(True)
            Loop

            Console.WriteLine()
            Console.WriteLine()

            ' Lock the secure string password.
            ssPassword.MakeReadOnly()

            Return ssPassword
        End Function

        ''' <summary>
        ''' Generic method to obtain discovery/organization service proxy instance.
        ''' </summary>
        ''' <typeparam name="TService">
        ''' Set IDiscoveryService or IOrganizationService type
        ''' to request respective service proxy instance.
        ''' </typeparam>
        ''' <typeparam name="TProxy">
        ''' Set the return type to either DiscoveryServiceProxy
        ''' or OrganizationServiceProxy type based on TService type.
        ''' </typeparam>
        ''' <param name="currentConfig">An instance of existing Configuration</param>
        ''' <returns>An instance of TProxy
        ''' i.e. DiscoveryServiceProxy or OrganizationServiceProxy</returns>
        Public Shared Function GetProxy(Of TService As Class,
                                            TProxy As ServiceProxy(Of TService))(ByVal currentConfig As ServerConnection.Configuration) As TProxy
            ' Check if it is organization service proxy request.
            Dim isOrgServiceRequest As Boolean = GetType(TService).Equals(GetType(IOrganizationService))

            ' Get appropriate Uri from Configuration.
            Dim serviceUri As Uri = If(isOrgServiceRequest,
                                       currentConfig.OrganizationUri,
                                       currentConfig.DiscoveryUri)

            ' Set service management for either organization service Uri or discovery service Uri.
            ' For organization service Uri, if service management exists
            ' then use it from cache. Otherwise create new service management for current organization.
            Dim serviceManagement As IServiceManagement(Of TService) =
                If(isOrgServiceRequest AndAlso Nothing IsNot currentConfig.OrganizationServiceManagement,
                   CType(currentConfig.OrganizationServiceManagement, IServiceManagement(Of TService)),
                   ServiceConfigurationFactory.CreateManagement(Of TService)(serviceUri))

            If isOrgServiceRequest Then
                If currentConfig.OrganizationTokenResponse Is Nothing Then
                    currentConfig.OrganizationServiceManagement =
                        CType(serviceManagement, IServiceManagement(Of IOrganizationService))
                End If
                ' Set the EndpointType in the current Configuration object
                ' while adding new configuration using discovery service proxy.
            Else
                ' Get the EndpointType.
                currentConfig.EndpointType = serviceManagement.AuthenticationType
                ' Get the logon credentials.
                currentConfig.Credentials = GetUserLogonCredentials(currentConfig)
            End If

            ' Set the credentials.
            Dim authCredentials As New AuthenticationCredentials()

            ' If UserPrincipalName exists, use it. Otherwise, set the logon credentials from the configuration.
            If Not String.IsNullOrWhiteSpace(currentConfig.UserPrincipalName) Then
                ' Single sing-on with the Federated Identity organization using current UserPrinicipalName.
                authCredentials.UserPrincipalName = currentConfig.UserPrincipalName
            Else
                authCredentials.ClientCredentials = currentConfig.Credentials
            End If

            Dim classType As Type

            ' Obtain discovery/organization service proxy for Federated,
            ' Microsoft account and OnlineFederated environments.
            If currentConfig.EndpointType <> AuthenticationProviderType.ActiveDirectory Then
                If currentConfig.EndpointType = AuthenticationProviderType.LiveId Then
                    authCredentials.SupportingCredentials = New AuthenticationCredentials()
                    authCredentials.SupportingCredentials.ClientCredentials = currentConfig.DeviceCredentials
                End If

                Dim tokenCredentials As AuthenticationCredentials = serviceManagement.Authenticate(authCredentials)

                If isOrgServiceRequest Then
                    ' Set SecurityTokenResponse for the current organization.
                    currentConfig.OrganizationTokenResponse = tokenCredentials.SecurityTokenResponse
                    ' Set classType to ManagedTokenOrganizationServiceProxy.
                    classType = GetType(ManagedTokenOrganizationServiceProxy)

                Else
                    ' Set classType to ManagedTokenDiscoveryServiceProxy.
                    classType = GetType(ManagedTokenDiscoveryServiceProxy)
                End If

                ' Invokes ManagedTokenOrganizationServiceProxy or ManagedTokenDiscoveryServiceProxy
                ' (IServiceManagement<TService>, SecurityTokenResponse) constructor.
                Return CType(classType.GetConstructor(New Type() {GetType(IServiceManagement(Of TService)), GetType(SecurityTokenResponse)}).Invoke(New Object() {serviceManagement, tokenCredentials.SecurityTokenResponse}), TProxy)
            End If

            ' Obtain discovery/organization service proxy for ActiveDirectory environment.
            If isOrgServiceRequest Then
                classType = GetType(ManagedTokenOrganizationServiceProxy)
            Else
                classType = GetType(ManagedTokenDiscoveryServiceProxy)
            End If

            ' Invokes ManagedTokenDiscoveryServiceProxy or ManagedTokenOrganizationServiceProxy
            ' (IServiceManagement<TService>, ClientCredentials) constructor.
            Return CType(classType.GetConstructor(New Type() {GetType(IServiceManagement(Of TService)), GetType(ClientCredentials)}).Invoke(New Object() {serviceManagement, authCredentials.ClientCredentials}), TProxy)
        End Function

        ''' <summary>
        ''' Convert SecureString to unsecure string.
        ''' </summary>
        ''' <param name="securePassword">Pass SecureString for conversion.</param>
        ''' <returns>unsecure string</returns>
        Public Shared Function ConvertToUnsecureString(ByVal securePassword As SecureString) As String
            If securePassword Is Nothing Then
                Throw New ArgumentNullException("securePassword")
            End If

            Dim unmanagedString As IntPtr = IntPtr.Zero
            Try
                unmanagedString = Marshal.SecureStringToGlobalAllocUnicode(securePassword)
                Return Marshal.PtrToStringUni(unmanagedString)
            Finally
                Marshal.ZeroFreeGlobalAllocUnicode(unmanagedString)
            End Try
        End Function

        ''' <summary>
        ''' Convert unsecure string to SecureString.
        ''' </summary>
        ''' <param name="password">Pass unsecure string for conversion.</param>
        ''' <returns>SecureString</returns>
        Public Shared Function ConvertToSecureString(ByVal password As String) As SecureString
            If password Is Nothing Then
                Throw New ArgumentNullException("password")
            End If

            Dim securePassword = New SecureString()
            For Each c As Char In password
                securePassword.AppendChar(c)
            Next c
            securePassword.MakeReadOnly()
            Return securePassword
        End Function
#End Region ' Public methods

#Region "Protected methods"

        ''' <summary>
        ''' Obtains the name and port of the server running the Microsoft Dynamics CRM
        ''' Discovery service.
        ''' </summary>
        ''' <returns>The server's network name and optional TCP/IP port.</returns>
        Protected Overridable Function GetServerAddress(<System.Runtime.InteropServices.Out()> ByRef ssl As Boolean) As String
            ssl = False

            Console.Write("Enter a CRM server name and port [crm.dynamics.com]: ")
            Dim server As String = Console.ReadLine()

            If server.EndsWith(".dynamics.com") OrElse String.IsNullOrWhiteSpace(server) Then
                ssl = True
            Else
                Console.Write("Is this server configured for Secure Socket Layer (https) (y/n) [n]: ")
                Dim answer As String = Console.ReadLine()

                If answer = "y" OrElse answer = "Y" Then
                    ssl = True
                End If
            End If

            Return server
        End Function

        ''' <summary>
        ''' Is this organization provisioned in Microsoft Office 365?
        ''' </summary>
        ''' <param name="server">The server's network name.</param>
        Protected Overridable Function GetOrgType(ByVal server As String) As Boolean
            Dim isO365Org As Boolean = False
            If String.IsNullOrWhiteSpace(server) Then
                Return isO365Org
            End If
            If server.IndexOf("."c) = -1 Then
                Return isO365Org
            End If

            Console.Write("Is this organization provisioned in Microsoft Office 365 (y/n) [n]: ")
            Dim answer As String = Console.ReadLine()

            If answer = "y" OrElse answer = "Y" Then
                isO365Org = True
            End If

            Return isO365Org
        End Function

        ''' <summary>
        ''' Obtains the web address (Uri) of the target organization.
        ''' </summary>
        ''' <returns>Uri of the organization service or an empty string.</returns>
        Protected Overridable Function GetOrganizationAddress() As Uri
            Using serviceProxy As DiscoveryServiceProxy = GetDiscoveryProxy()
                ' Obtain organization information from the Discovery service.
                If serviceProxy IsNot Nothing Then
                    ' Obtain information about the organizations that the system user belongs to.
                    Dim orgs As OrganizationDetailCollection = DiscoverOrganizations(serviceProxy)

                    If orgs.Count > 0 Then
                        Console.WriteLine(vbLf & "List of organizations that you belong to:")
                        For n As Integer = 0 To orgs.Count - 1
                            Console.Write(vbLf & "({0}) {1} ({2})" & vbTab, n + 1, orgs(n).FriendlyName, orgs(n).UrlName)
                        Next n

                        Console.Write(vbLf & vbLf & "Specify an organization number (1-{0}) [1]: ", orgs.Count)
                        Dim input As String = Console.ReadLine()
                        If input = String.Empty Then
                            input = "1"
                        End If
                        Dim orgNumber As Integer
                        Int32.TryParse(input, orgNumber)
                        If orgNumber > 0 AndAlso orgNumber <= orgs.Count Then
                            config.OrganizationName = orgs(orgNumber - 1).FriendlyName
                            ' Return the organization Uri.
                            Return New Uri(orgs(orgNumber - 1).Endpoints(EndpointType.OrganizationService))
                        Else
                            Throw New InvalidOperationException("The specified organization does not exist.")
                        End If
                    Else
                        Console.WriteLine(vbLf & "You do not belong to any organizations on the specified server.")
                        Return New Uri(String.Empty)
                    End If
                Else
                    Throw New InvalidOperationException("An invalid server name was specified.")
                End If
            End Using
        End Function

        ''' <summary>
        ''' Get the device credentials by either loading from the local cache
        ''' or request new device credentials by registering the device.
        ''' </summary>
        ''' <returns>Device Credentials.</returns>
        Protected Overridable Function GetDeviceCredentials() As ClientCredentials
            Return Microsoft.Crm.Services.Utility.DeviceIdManager.LoadOrRegisterDevice()
        End Function

        ''' <summary>
        ''' Get the discovery service proxy based on existing configuration data.
        ''' Added new way of getting discovery proxy.
        ''' Also preserving old way of getting discovery proxy to support old scenarios.
        ''' </summary>
        ''' <returns>An instance of DiscoveryServiceProxy</returns>
        Private Function GetDiscoveryProxy() As DiscoveryServiceProxy
            Try
                ' Obtain the discovery service proxy.
                Dim discoveryProxy As DiscoveryServiceProxy =
                    GetProxy(Of IDiscoveryService, DiscoveryServiceProxy)(Me.config)
                ' Checking authentication by invoking some SDK methods.
                discoveryProxy.Execute(New RetrieveOrganizationsRequest())
                Return discoveryProxy
            Catch ex As System.ServiceModel.Security.SecurityAccessDeniedException
                ' If authentication failed using current UserPrincipalName,
                ' request UserName and Password to try to authenticate using user credentials.
                If (Not String.IsNullOrWhiteSpace(config.UserPrincipalName)) AndAlso
                    ex.Message.Contains("Access is denied.") Then
                    config.AuthFailureCount = CShort(config.AuthFailureCount + 1)
                Else
                    Throw ex
                End If
            End Try
            ' You can also catch other exceptions to handle a specific situation in your code, for example,
            '      System.ServiceModel.Security.ExpiredSecurityTokenException
            '      System.ServiceModel.Security.MessageSecurityException
            '      System.ServiceModel.Security.SecurityNegotiationException

            ' Second trial to obtain the discovery service proxy in case of single sign-on failure.
            Return GetProxy(Of IDiscoveryService, DiscoveryServiceProxy)(Me.config)

        End Function

        ''' <summary>
        ''' Verify passed strings with the supported AuthenticationProviderType.
        ''' </summary>
        ''' <param name="authType">String AuthenticationType</param>
        ''' <returns>Supported AuthenticatoinProviderType</returns>
        Private Function RetrieveAuthenticationType(ByVal authType As String) As AuthenticationProviderType
            Select Case authType
                Case "ActiveDirectory"
                    Return AuthenticationProviderType.ActiveDirectory
                Case "LiveId"
                    Return AuthenticationProviderType.LiveId
                Case "Federation"
                    Return AuthenticationProviderType.Federation
                Case "OnlineFederation"
                    Return AuthenticationProviderType.OnlineFederation
                Case Else
                    Throw New ArgumentException(String.Format("{0} is not a valid authentication type", authType))
            End Select
        End Function

        ''' <summary>
        ''' Parse credentials from an XML node to required ClientCredentials data type
        ''' based on passed AuthenticationProviderType.
        ''' </summary>
        ''' <param name="credentials">Credential XML node.</param>
        ''' <param name="endpointType">AuthenticationProviderType of the credential.</param>
        ''' <param name="target">Target is the key with which associated credentials can be fetched.</param>
        ''' <returns>Required ClientCredentials type.</returns>
        Private Function ParseInCredentials(ByVal credentials As XElement, ByVal endpointType As AuthenticationProviderType, ByVal target As String) As ClientCredentials
            Dim result As New ClientCredentials()
            If credentials.HasElements Then
                Dim cred As Credential = CredentialManager.ReadCredentials(target)
                Select Case endpointType
                    Case AuthenticationProviderType.ActiveDirectory
                        If Nothing IsNot cred AndAlso cred.UserName.Contains("\") Then
                            Dim domainAndUser() As String = cred.UserName.Split("\"c)
                            result.Windows.ClientCredential = New System.Net.NetworkCredential() With {.UserName = domainAndUser(1), .Domain = domainAndUser(0), .Password = cred.Password}
                        Else
                            result.Windows.ClientCredential = New System.Net.NetworkCredential() With {.UserName = credentials.Element("UserName").Value, .Domain = credentials.Element("Domain").Value}
                        End If
                    Case AuthenticationProviderType.LiveId, AuthenticationProviderType.Federation, AuthenticationProviderType.OnlineFederation
                        If Nothing IsNot cred Then
                            result.UserName.UserName = cred.UserName
                            result.UserName.Password = cred.Password
                        Else
                            result.UserName.UserName = credentials.Element("UserName").Value
                        End If
                    Case Else
                End Select
            Else
                Return Nothing
            End If

            Return result
        End Function

        ''' <summary>
        ''' Parse ClientCredentials into XML node.
        ''' </summary>
        ''' <param name="clientCredentials_Renamed">ClientCredentials type.</param>
        ''' <param name="endpointType">AuthenticationProviderType of the credentials.</param>
        ''' <param name="target">Target is the key with which associated credentials can be fetched.</param>
        ''' <returns>XML node containing credentials data.</returns>
        Private Function ParseOutCredentials(ByVal clientCredentials_Renamed As ClientCredentials, ByVal endpointType As AuthenticationProviderType, ByVal target As String) As XElement
            If clientCredentials_Renamed IsNot Nothing Then
                Dim cred As Credential = CredentialManager.ReadCredentials(target)
                Select Case endpointType
                    Case AuthenticationProviderType.ActiveDirectory
                        If cred Is Nothing Then
                            ' Add entry in windows credential manager for future use.
                            If Not String.IsNullOrWhiteSpace(clientCredentials_Renamed.Windows.ClientCredential.Password) Then
                                CredentialManager.WriteCredentials(target, New Credential(clientCredentials_Renamed.Windows.ClientCredential.Domain & "\" & clientCredentials_Renamed.Windows.ClientCredential.UserName, clientCredentials_Renamed.Windows.ClientCredential.Password), True)
                            End If
                        Else
                            ' Replace if the password has been changed.
                            If Not clientCredentials_Renamed.Windows.ClientCredential.Password.Equals(cred.Password) Then
                                CredentialManager.DeleteCredentials(target, False)
                                CredentialManager.WriteCredentials(target, New Credential(clientCredentials_Renamed.Windows.ClientCredential.Domain & "\" & clientCredentials_Renamed.Windows.ClientCredential.UserName, clientCredentials_Renamed.Windows.ClientCredential.Password), True)
                            End If
                        End If
                        Return New XElement("Credentials", New XElement("UserName", clientCredentials_Renamed.Windows.ClientCredential.UserName), New XElement("Domain", clientCredentials_Renamed.Windows.ClientCredential.Domain))
                    Case AuthenticationProviderType.LiveId, AuthenticationProviderType.Federation, AuthenticationProviderType.OnlineFederation
                        If cred Is Nothing Then
                            ' Add entry in windows credential manager for future use.
                            If Not String.IsNullOrWhiteSpace(clientCredentials_Renamed.UserName.Password) Then
                                CredentialManager.WriteCredentials(target, New Credential(clientCredentials_Renamed.UserName.UserName, clientCredentials_Renamed.UserName.Password), True)
                            End If
                        Else
                            ' Replace if the password has been changed.
                            If Not clientCredentials_Renamed.UserName.Password.Equals(cred.Password) Then
                                CredentialManager.DeleteCredentials(target, False)
                                CredentialManager.WriteCredentials(target, New Credential(clientCredentials_Renamed.UserName.UserName, clientCredentials_Renamed.UserName.Password), True)
                            End If
                        End If
                        Return New XElement("Credentials", New XElement("UserName", clientCredentials_Renamed.UserName.UserName))
                    Case Else
                End Select
            End If

            Return New XElement("Credentials", "")
        End Function
#End Region ' Private methods

        #Region "Private Classes"
        ''' <summary>
        ''' private static class to store constants required by the CrmServiceHelper class.
        ''' </summary>
        Private NotInheritable Class CrmServiceHelperConstants
            ''' <summary>
            ''' Credentials file path.
            ''' </summary>
            Public Shared ReadOnly ServerCredentialsFile As String = Path.Combine(Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.ApplicationData), "CrmServer"), "Credentials.xml")
        End Class
        #End Region
    End Class
    #Region "Other Classes"

    Friend NotInheritable Class Credential
        Private _userName As SecureString
        Private _password As SecureString

        Friend Sub New(ByVal cred As CREDENTIAL_STRUCT)
            _userName = ConvertToSecureString(cred.userName)
            Dim size As Integer = CInt(cred.credentialBlobSize)
            If size <> 0 Then
                Dim bpassword(size - 1) As Byte
                Marshal.Copy(cred.credentialBlob, bpassword, 0, size)
                _password = ConvertToSecureString(Encoding.Unicode.GetString(bpassword))
            Else
                _password = ConvertToSecureString(String.Empty)
            End If
        End Sub

        Public Sub New(ByVal userName As String, ByVal password As String)
            If (String.IsNullOrWhiteSpace(userName)) Then
                Throw New ArgumentNullException("userName")
            End If

            If (String.IsNullOrWhiteSpace(password)) Then
                Throw New ArgumentNullException("password")
            End If

            _userName = ConvertToSecureString(userName)
            _password = ConvertToSecureString(password)
        End Sub

        Public ReadOnly Property UserName() As String
            Get
                Return ConvertToUnsecureString(_userName)
            End Get
        End Property

        Public ReadOnly Property Password() As String
            Get
                Return ConvertToUnsecureString(_password)
            End Get
        End Property

        ''' <summary>
        ''' This converts a SecureString password to plain text
        ''' </summary>
        ''' <param name="securePassword">SecureString password</param>
        ''' <returns>plain text password</returns>
        Private Function ConvertToUnsecureString(ByVal secret As SecureString) As String
            If secret Is Nothing Then
                Return String.Empty
            End If

            Dim unmanagedString As IntPtr = IntPtr.Zero
            Try
                unmanagedString = Marshal.SecureStringToGlobalAllocUnicode(secret)
                Return Marshal.PtrToStringUni(unmanagedString)
            Finally
                Marshal.ZeroFreeGlobalAllocUnicode(unmanagedString)
            End Try
        End Function

        ''' <summary>
        ''' This converts a string to SecureString
        ''' </summary>
        ''' <param name="password">plain text password</param>
        ''' <returns>SecureString password</returns>
        Private Function ConvertToSecureString(ByVal secret As String) As SecureString
            If String.IsNullOrEmpty(secret) Then
                Return Nothing
            End If

            Dim securePassword As New SecureString()
            Dim passwordChars() As Char = secret.ToCharArray()
            For Each pwdChar As Char In passwordChars
                securePassword.AppendChar(pwdChar)
            Next pwdChar
            securePassword.MakeReadOnly()
            Return securePassword
        End Function

        ''' <summary>
        ''' This structure maps to the CREDENTIAL structure used by native code. We can use this to marshal our values.
        ''' </summary>
        <StructLayout(LayoutKind.Sequential, CharSet := CharSet.Unicode)> _
        Friend Structure CREDENTIAL_STRUCT
            Public flags As UInt32
            Public type As UInt32
            Public targetName As String
            Public comment As String
            Public lastWritten As System.Runtime.InteropServices.ComTypes.FILETIME
            Public credentialBlobSize As UInt32
            Public credentialBlob As IntPtr
            Public persist As UInt32
            Public attributeCount As UInt32
            Public credAttribute As IntPtr
            Public targetAlias As String
            Public userName As String
        End Structure

    End Class

    ''' <summary>
    ''' This class exposes methods to read, write and delete user credentials
    ''' </summary>
    Friend NotInheritable Class CredentialManager
        ''' <summary>
        ''' Target Name against which all credentials are stored on the disk.
        ''' </summary>
        Public Const TargetName As String = "Microsoft_CRMSDK:"

        ''' <summary>
        ''' Cache containing secrets in-memory (used to improve performance and avoid IO operations).
        ''' </summary>
        Private Shared credentialCache As New Dictionary(Of String, Credential)()

        Private Sub New()
        End Sub
        Public Shared Function GetCredentialTarget(ByVal target As Uri) As Uri
            If target Is Nothing Then
                Throw New ArgumentNullException("target")
            End If

            Return New Uri(target.GetLeftPart(UriPartial.Authority))
        End Function

        Private Enum CRED_TYPE As Integer
            GENERIC = 1
            DOMAIN_PASSWORD = 2
            DOMAIN_CERTIFICATE = 3
            DOMAIN_VISIBLE_PASSWORD = 4
            MAXIMUM = 5
        End Enum

        Friend Enum CRED_PERSIST As UInteger
            SESSION = 1
            LOCAL_MACHINE = 2
            ENTERPRISE = 3
        End Enum

        Private NotInheritable Class NativeMethods
            <DllImport("advapi32.dll", SetLastError:=True, EntryPoint:="CredReadW", CharSet:=CharSet.Unicode)> _
            Public Shared Function CredRead(ByVal target As String, ByVal type As CRED_TYPE, ByVal reservedFlag As Integer, <System.Runtime.InteropServices.Out(), MarshalAs(UnmanagedType.CustomMarshaler, MarshalTypeRef:=GetType(CredentialMarshaler))> ByRef credential As Credential) As <MarshalAs(UnmanagedType.Bool)> Boolean
            End Function

            <DllImport("Advapi32.dll", SetLastError:=True, EntryPoint:="CredWriteW", CharSet:=CharSet.Unicode)> _
            Public Shared Function CredWrite(ByRef credential As Credential.CREDENTIAL_STRUCT, ByVal flags As UInt32) As <MarshalAs(UnmanagedType.Bool)> Boolean
            End Function

            <DllImport("Advapi32.dll", EntryPoint:="CredFree", SetLastError:=True)> _
            Public Shared Function CredFree(ByVal cred As IntPtr) As <MarshalAs(UnmanagedType.Bool)> Boolean
            End Function

            <DllImport("advapi32.dll", EntryPoint:="CredDeleteW", CharSet:=CharSet.Unicode)> _
            Public Shared Function CredDelete(ByVal target As String, ByVal type As Integer, ByVal flags As Integer) As <MarshalAs(UnmanagedType.Bool)> Boolean
            End Function
        End Class

        Private NotInheritable Class CredentialMarshaler
            Implements ICustomMarshaler
            Private Shared _instance As CredentialMarshaler

            Public Sub CleanUpManagedData(ByVal ManagedObj As Object) Implements ICustomMarshaler.CleanUpManagedData
                ' Nothing to do since all data can be garbage collected.
            End Sub

            Public Sub CleanUpNativeData(ByVal pNativeData As IntPtr) Implements ICustomMarshaler.CleanUpNativeData
                If pNativeData = IntPtr.Zero Then
                    Return
                End If
                NativeMethods.CredFree(pNativeData)
            End Sub

            Public Function GetNativeDataSize() As Integer Implements ICustomMarshaler.GetNativeDataSize
                Throw New NotImplementedException("The method or operation is not implemented.")
            End Function

            Public Function MarshalManagedToNative(ByVal obj As Object) As IntPtr Implements ICustomMarshaler.MarshalManagedToNative
                Throw New NotImplementedException("Not implemented yet")
            End Function

            Public Function MarshalNativeToManaged(ByVal pNativeData As IntPtr) As Object Implements ICustomMarshaler.MarshalNativeToManaged
                If pNativeData = IntPtr.Zero Then
                    Return Nothing
                End If
                Return New Credential(CType(Marshal.PtrToStructure(pNativeData, GetType(Credential.CREDENTIAL_STRUCT)), Credential.CREDENTIAL_STRUCT))
            End Function

            Public Shared Function GetInstance(ByVal cookie As String) As ICustomMarshaler
                If Nothing Is _instance Then
                    _instance = New CredentialMarshaler()
                End If
                Return _instance
            End Function
        End Class

        Public Shared Function ReadCredentials(ByVal target As String) As Credential
            Dim cachedCredential As Credential = Nothing

            ' Try to read the username from cache
            If credentialCache.TryGetValue(TargetName & target, cachedCredential) Then
                Return cachedCredential
            End If

            Dim credential_Renamed As Credential = Nothing
        Dim bSuccess As Boolean = NativeMethods.CredRead(TargetName & target, CRED_TYPE.GENERIC, 0, credential_Renamed)
            ' No match found.
            If Not bSuccess Then
                Return Nothing
            End If

            credentialCache(TargetName & target.ToString()) = credential_Renamed
            Return credential_Renamed
        End Function

        Public Shared Function ReadWindowsCredential(ByVal target As Uri) As Credential
            Dim credential_Renamed As Credential = Nothing
            Dim bSuccess As Boolean = NativeMethods.CredRead(target.Host, CRED_TYPE.DOMAIN_PASSWORD, 0, credential_Renamed)
            If Not bSuccess Then
                Throw New InvalidOperationException("Unable to read windows credentials for Uri {0}. ErrorCode {1}",
                                    New System.ComponentModel.Win32Exception(Marshal.GetLastWin32Error()))
            End If
            Return credential_Renamed
        End Function
        ''' <summary>
        ''' Fetches the credentials.
        ''' </summary>
        ''' <param name="target">Target is the key with which associated credentials can be fetched</param>
        ''' <param name="userCredentials">It is the in parameter which contains the username and password</param>
        ''' <param name="allowPhysicalStore">If allowPhysicalStore is true then the credentials are stored on disk</param>
        Public Shared Sub WriteCredentials(ByVal target As String, ByVal userCredentials As Credential, ByVal allowPhysicalStore As Boolean)
            If String.IsNullOrWhiteSpace(target) Then
                Throw New ArgumentNullException("target")
            End If
            If userCredentials Is Nothing Then
                Throw New ArgumentNullException("userCredentials")
            End If
            If allowPhysicalStore = Nothing Then
                Throw New ArgumentNullException("allowPhysicalStore")
            End If
            ' Cache the username and password in memory
            credentialCache(TargetName & target) = userCredentials

            ' Store the credentials if allowed
            Dim passwordToStore As String = If(allowPhysicalStore, userCredentials.Password, String.Empty)
            Dim credential As New Credential.CREDENTIAL_STRUCT()
            Try
                credential.targetName = TargetName & target
                credential.type = CUInt(CRED_TYPE.GENERIC)
                credential.userName = userCredentials.UserName
                credential.attributeCount = 0
                credential.persist = CUInt(CRED_PERSIST.LOCAL_MACHINE)
                Dim bpassword() As Byte = Encoding.Unicode.GetBytes(passwordToStore)
                credential.credentialBlobSize = CUInt(bpassword.Length)
                credential.credentialBlob = Marshal.AllocCoTaskMem(bpassword.Length)
                Marshal.Copy(bpassword, 0, credential.credentialBlob, bpassword.Length)
                If Not NativeMethods.CredWrite(credential, 0) Then
                    Throw New System.ComponentModel.Win32Exception(Marshal.GetLastWin32Error())
                End If
            Finally
                If IntPtr.Zero <> credential.credentialBlob Then
                    Marshal.FreeCoTaskMem(credential.credentialBlob)
                End If
            End Try
        End Sub

        ''' <summary>
        ''' Deletes the credentials.
        ''' </summary>
        ''' <param name="target">Target is the key with which associated credentials can be fetched</param>
        ''' <param name="softDelete">If a softDelete is done then credentials are deleted only from memory.
        ''' They are completely removed otherwise.</param>
        Public Shared Sub DeleteCredentials(ByVal target As String, ByVal softDelete As Boolean)
            If String.IsNullOrWhiteSpace(target) Then
                Throw New ArgumentNullException("target")
            End If
            If Nothing = softDelete Then
                Throw New ArgumentNullException("softDelete")
            End If
            If softDelete Then
                ' Removes only the password
                Try
                    Dim tempCredential As Credential = ReadCredentials(target)
                    WriteCredentials(target, New Credential(tempCredential.UserName, String.Empty), True)
                Catch e1 As Exception
                    ' Do nothing
                End Try
            Else
                ' Removes the entry completely
                NativeMethods.CredDelete(TargetName & target, CInt(CRED_TYPE.GENERIC), 0)
                credentialCache.Remove(TargetName & target)
            End If
        End Sub
    End Class

    ''' <summary>
    ''' Wrapper class for DiscoveryServiceProxy to support auto refresh security token.
    ''' </summary>
    Friend NotInheritable Class ManagedTokenDiscoveryServiceProxy
        Inherits DiscoveryServiceProxy
        Private _proxyManager As AutoRefreshSecurityToken(Of DiscoveryServiceProxy, IDiscoveryService)

        Public Sub New(ByVal serviceUri As Uri, ByVal userCredentials As ClientCredentials)
            MyBase.New(serviceUri, Nothing, userCredentials, Nothing)
            Me._proxyManager = New AutoRefreshSecurityToken(Of DiscoveryServiceProxy, IDiscoveryService)(Me)
        End Sub

        Public Sub New(ByVal serviceManagement As IServiceManagement(Of IDiscoveryService), ByVal securityTokenRes As SecurityTokenResponse)
            MyBase.New(serviceManagement, securityTokenRes)
            Me._proxyManager = New AutoRefreshSecurityToken(Of DiscoveryServiceProxy, IDiscoveryService)(Me)
        End Sub

        Public Sub New(ByVal serviceManagement As IServiceManagement(Of IDiscoveryService), ByVal userCredentials As ClientCredentials)
            MyBase.New(serviceManagement, userCredentials)
            Me._proxyManager = New AutoRefreshSecurityToken(Of DiscoveryServiceProxy, IDiscoveryService)(Me)
        End Sub

        Protected Overrides Function AuthenticateDeviceCore() As SecurityTokenResponse
            Return Me._proxyManager.AuthenticateDevice()
        End Function

        Protected Overrides Sub AuthenticateCore()
            Me._proxyManager.PrepareCredentials()
            MyBase.AuthenticateCore()
        End Sub

        Protected Overrides Sub ValidateAuthentication()
            Me._proxyManager.RenewTokenIfRequired()
            MyBase.ValidateAuthentication()
        End Sub
    End Class

    ''' <summary>
    ''' Wrapper class for OrganizationServiceProxy to support auto refresh security token
    ''' </summary>
    Friend NotInheritable Class ManagedTokenOrganizationServiceProxy
        Inherits OrganizationServiceProxy
        Private _proxyManager As AutoRefreshSecurityToken(Of OrganizationServiceProxy, IOrganizationService)

        Public Sub New(ByVal serviceUri As Uri, ByVal userCredentials As ClientCredentials)
            MyBase.New(serviceUri, Nothing, userCredentials, Nothing)
            Me._proxyManager = New AutoRefreshSecurityToken(Of OrganizationServiceProxy, IOrganizationService)(Me)
        End Sub

        Public Sub New(ByVal serviceManagement As IServiceManagement(Of IOrganizationService), ByVal securityTokenRes As SecurityTokenResponse)
            MyBase.New(serviceManagement, securityTokenRes)
            Me._proxyManager = New AutoRefreshSecurityToken(Of OrganizationServiceProxy, IOrganizationService)(Me)
        End Sub

        Public Sub New(ByVal serviceManagement As IServiceManagement(Of IOrganizationService), ByVal userCredentials As ClientCredentials)
            MyBase.New(serviceManagement, userCredentials)
            Me._proxyManager = New AutoRefreshSecurityToken(Of OrganizationServiceProxy, IOrganizationService)(Me)
        End Sub

        Protected Overrides Function AuthenticateDeviceCore() As SecurityTokenResponse
            Return Me._proxyManager.AuthenticateDevice()
        End Function

        Protected Overrides Sub AuthenticateCore()
            Me._proxyManager.PrepareCredentials()
            MyBase.AuthenticateCore()
        End Sub

        Protected Overrides Sub ValidateAuthentication()
            Me._proxyManager.RenewTokenIfRequired()
            MyBase.ValidateAuthentication()
        End Sub
    End Class

    ''' <summary>
    ''' Class that wraps acquiring the security token for a service
    ''' </summary>
    Public NotInheritable Class AutoRefreshSecurityToken(Of TProxy As ServiceProxy(Of TService), TService As Class)
        Private _deviceCredentials As ClientCredentials
        Private _proxy As TProxy

        ''' <summary>
        ''' Instantiates an instance of the proxy class
        ''' </summary>
        ''' <param name="proxy">Proxy that will be used to authenticate the user</param>
        Public Sub New(ByVal proxy As TProxy)
            If Nothing Is proxy Then
                Throw New ArgumentNullException("proxy")
            End If

            Me._proxy = proxy
        End Sub

        ''' <summary>
        ''' Prepares authentication before authen6ticated
        ''' </summary>
        Public Sub PrepareCredentials()
            If Nothing Is Me._proxy.ClientCredentials Then
                Return
            End If

            Select Case Me._proxy.ServiceConfiguration.AuthenticationType
                Case AuthenticationProviderType.ActiveDirectory
                    Me._proxy.ClientCredentials.UserName.UserName = Nothing
                    Me._proxy.ClientCredentials.UserName.Password = Nothing
                Case AuthenticationProviderType.Federation, AuthenticationProviderType.LiveId
                    Me._proxy.ClientCredentials.Windows.ClientCredential = Nothing
                Case Else
                    Return
            End Select
        End Sub

        ''' <summary>
        ''' Authenticates the device token
        ''' </summary>
        ''' <returns>Generated SecurityTokenResponse for the device</returns>
        Public Function AuthenticateDevice() As SecurityTokenResponse
            If Nothing Is Me._deviceCredentials Then
                Me._deviceCredentials = DeviceIdManager.LoadOrRegisterDevice(Me._proxy.ServiceConfiguration.CurrentIssuer.IssuerAddress.Uri)
            End If

            Return Me._proxy.ServiceConfiguration.AuthenticateDevice(Me._deviceCredentials)
        End Function

        ''' <summary>
        ''' Renews the token (if it is near expiration or has expired)
        ''' </summary>
        Public Sub RenewTokenIfRequired()
            If Nothing IsNot Me._proxy.SecurityTokenResponse AndAlso Date.UtcNow.AddMinutes(15) >= Me._proxy.SecurityTokenResponse.Response.Lifetime.Expires Then
                Try
                    Me._proxy.Authenticate()
                Catch e1 As CommunicationException
                    If Nothing Is Me._proxy.SecurityTokenResponse OrElse Date.UtcNow >= Me._proxy.SecurityTokenResponse.Response.Lifetime.Expires Then
                        Throw
                    End If

                    ' Ignore the exception
                End Try
            End If
        End Sub
    End Class
#End Region
End Namespace

See Also

Concepts

Use the sample and helper code

Other Resources

Helper code: DeviceIdManager class
Sample: Quick start for Microsoft Dynamics CRM
Authenticate users with Microsoft Dynamics CRM web services

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Helper code: DeviceIdManager class
See Also Example

The DeviceIdManager class registers a computing device with Microsoft account, through the generation of a device ID and password, and optionally stores that information in an encrypted format on the local disk for later reuse. This functionality is required when authenticating with Microsoft Dynamics CRM Online through the Microsoft account identity provider. The device registration is stored in the %USERPROFILE%\LiveDeviceID folder on the computing device.

The primary class method to call from your code is LoadOrRegisterDevice. For an example of how the DeviceIdManager class is used, see the GetDeviceCredentials method in the Helper code: ServerConnection class topic.

A Microsoft Azure hosted application that must authenticate with Microsoft Dynamics CRM Online should either set the PersistToFile property of DeviceIdManager to false or call the two-parameter LoadOrRegisterDevice method passing in the required device ID and password. In both cases, the DeviceIdManager won’t attempt to save the device ID and password to a file.

Download the Microsoft Dynamics CRM SDK package. The source code for the class can be found in the following location in the download package:

SDK\SampleCode\CS\HelperCode\DeviceIdManager.cs

SDK\SampleCode\VB\HelperCode\DeviceIdManager.vb

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The DeviceIdManager class demonstrates how to manage the registration of computing devices with Microsoft account.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Diagnostics.CodeAnalysis;
using System.Globalization;
using System.IO;
using System.Net;
using System.Runtime.Serialization;
using System.Security.Cryptography;
using System.ServiceModel.Description;
using System.Text;
using System.Xml;
using System.Xml.Serialization;

namespace Microsoft.Crm.Services.Utility
{
    /// <summary>
    /// Management utility for the Device Id
    /// </summary>
    public static class DeviceIdManager
    {
        #region Fields
        private static readonly Random RandomInstance = new Random();

        public const int MaxDeviceNameLength = 24;
        public const int MaxDevicePasswordLength = 24;
        #endregion

        #region Constructor
        static DeviceIdManager()
        {
            PersistToFile = true;
        }
        #endregion

        #region Properties
        /// <summary>
        /// Indicates whether the registered device credentials should be persisted to the database
        /// </summary>
        public static bool PersistToFile { get; set; }

        /// <summary>
        /// Indicates that the credentials should be persisted to the disk if registration fails with DeviceAlreadyExists.
        /// </summary>
        /// <remarks>
        /// If the device already exists, there is a possibility that the credentials are the same as the current credentials that
        /// are being registered. This is especially true in automated environments where the same credentials are used continually (to avoid
        /// registering spurious device credentials.
        /// </remarks>
        public static bool PersistIfDeviceAlreadyExists { get; set; }
        #endregion

        #region Methods
        /// <summary>
        /// Loads the device credentials (if they exist).
        /// </summary>
        /// <returns></returns>
        public static ClientCredentials LoadOrRegisterDevice()
        {
            return LoadOrRegisterDevice(null);
        }

        /// <summary>
        /// Loads the device credentials (if they exist).
        /// </summary>
        /// <param name="deviceName">Device name that should be registered</param>
        /// <param name="devicePassword">Device password that should be registered</param>
        public static ClientCredentials LoadOrRegisterDevice(string deviceName, string devicePassword)
        {
            return LoadOrRegisterDevice(null, deviceName, devicePassword);
        }

        /// <summary>
        /// Loads the device credentials (if they exist).
        /// </summary>
        /// <param name="issuerUri">URL for the current token issuer</param>
        /// <remarks>
        /// The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        /// </remarks>
        public static ClientCredentials LoadOrRegisterDevice(Uri issuerUri)
        {
            return LoadOrRegisterDevice(issuerUri, null, null);
        }

        /// <summary>
        /// Loads the device credentials (if they exist).
        /// </summary>
        /// <param name="issuerUri">URL for the current token issuer</param>
        /// <param name="deviceName">Device name that should be registered</param>
        /// <param name="devicePassword">Device password that should be registered</param>
        /// <remarks>
        /// The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        /// </remarks>
        public static ClientCredentials LoadOrRegisterDevice(Uri issuerUri, string deviceName, string devicePassword)
        {
            ClientCredentials credentials = LoadDeviceCredentials(issuerUri);
            if (null == credentials)
            {
                credentials = RegisterDevice(Guid.NewGuid(), issuerUri, deviceName, devicePassword);
            }

            return credentials;
        }

        /// <summary>
        /// Registers the given device with Microsoft account with a random application ID
        /// </summary>
        /// <returns>ClientCredentials that were registered</returns>
        public static ClientCredentials RegisterDevice()
        {
            return RegisterDevice(Guid.NewGuid());
        }

        /// <summary>
        /// Registers the given device with Microsoft account
        /// </summary>
        /// <param name="applicationId">ID for the application</param>
        /// <returns>ClientCredentials that were registered</returns>
        public static ClientCredentials RegisterDevice(Guid applicationId)
        {
            return RegisterDevice(applicationId, (Uri)null);
        }

        /// <summary>
        /// Registers the given device with Microsoft account
        /// </summary>
        /// <param name="applicationId">ID for the application</param>
        /// <param name="issuerUri">URL for the current token issuer</param>
        /// <returns>ClientCredentials that were registered</returns>
        /// <remarks>
        /// The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        /// </remarks>
        public static ClientCredentials RegisterDevice(Guid applicationId, Uri issuerUri)
        {
            return RegisterDevice(applicationId, issuerUri, null, null);
        }

        /// <summary>
        /// Registers the given device with Microsoft account
        /// </summary>
        /// <param name="applicationId">ID for the application</param>
        /// <param name="deviceName">Device name that should be registered</param>
        /// <param name="devicePassword">Device password that should be registered</param>
        /// <returns>ClientCredentials that were registered</returns>
        public static ClientCredentials RegisterDevice(Guid applicationId, string deviceName, string devicePassword)
        {
            return RegisterDevice(applicationId, (Uri)null, deviceName, devicePassword);
        }

        /// <summary>
        /// Registers the given device with Microsoft account
        /// </summary>
        /// <param name="applicationId">ID for the application</param>
        /// <param name="issuerUri">URL for the current token issuer</param>
        /// <param name="deviceName">Device name that should be registered</param>
        /// <param name="devicePassword">Device password that should be registered</param>
        /// <returns>ClientCredentials that were registered</returns>
        /// <remarks>
        /// The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        /// </remarks>
        public static ClientCredentials RegisterDevice(Guid applicationId, Uri issuerUri, string deviceName, string devicePassword)
        {
            if (string.IsNullOrEmpty(deviceName) && !PersistToFile)
            {
                throw new ArgumentNullException("deviceName", "If PersistToFile is false, then deviceName must be specified.");
            }
            else if (string.IsNullOrEmpty(deviceName) != string.IsNullOrEmpty(devicePassword))
            {
                throw new ArgumentNullException("deviceName", "Either deviceName/devicePassword should both be specified or they should be null.");
            }

            LiveDevice device = GenerateDevice(deviceName, devicePassword);
            return RegisterDevice(applicationId, issuerUri, device);
        }

        /// <summary>
        /// Loads the device's credentials from the file system
        /// </summary>
        /// <returns>Device Credentials (if set) or null</returns>
        public static ClientCredentials LoadDeviceCredentials()
        {
            return LoadDeviceCredentials(null);
        }

        /// <summary>
        /// Loads the device's credentials from the file system
        /// </summary>
        /// <param name="issuerUri">URL for the current token issuer</param>
        /// <returns>Device Credentials (if set) or null</returns>
        /// <remarks>
        /// The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        /// </remarks>
        public static ClientCredentials LoadDeviceCredentials(Uri issuerUri)
        {
            //If the credentials should not be persisted to a file, then they won't be present on the disk.
            if (!PersistToFile)
            {
                return null;
            }

            EnvironmentConfiguration environment = DiscoverEnvironmentInternal(issuerUri);

            LiveDevice device = ReadExistingDevice(environment);
            if (null == device || null == device.User)
            {
                return null;
            }

            return device.User.ToClientCredentials();
        }

        /// <summary>
        /// Discovers the Microsoft account environment based on the Token Issuer
        /// </summary>
        public static string DiscoverEnvironment(Uri issuerUri)
        {
            return DiscoverEnvironmentInternal(issuerUri).Environment;
        }
        #endregion

        #region Private Methods
        private static EnvironmentConfiguration DiscoverEnvironmentInternal(Uri issuerUri)
        {
            if (null == issuerUri)
            {
                return new EnvironmentConfiguration(EnvironmentType.LiveDeviceID, "login.live.com", null);
            }

            Dictionary<EnvironmentType, string> searchList = new Dictionary<EnvironmentType, string>();
            searchList.Add(EnvironmentType.LiveDeviceID, "login.live");
            searchList.Add(EnvironmentType.OrgDeviceID, "login.microsoftonline");

            foreach (KeyValuePair<EnvironmentType, string> searchPair in searchList)
            {
                if (issuerUri.Host.Length > searchPair.Value.Length &&
                    issuerUri.Host.StartsWith(searchPair.Value, StringComparison.OrdinalIgnoreCase))
                {
                    string environment = issuerUri.Host.Substring(searchPair.Value.Length);

                    //Parse out the environment
                    if ('-' == environment[0])
                    {
                        int separatorIndex = environment.IndexOf('.', 1);
                        if (-1 != separatorIndex)
                        {
                            environment = environment.Substring(1, separatorIndex - 1);
                        }
                        else
                        {
                            environment = null;
                        }
                    }
                    else
                    {
                        environment = null;
                    }

                    return new EnvironmentConfiguration(searchPair.Key, issuerUri.Host, environment);
                }
            }

            //In all other cases the environment is either not applicable or it is a production system
            return new EnvironmentConfiguration(EnvironmentType.LiveDeviceID, issuerUri.Host, null);
        }

        private static void Serialize<T>(Stream stream, T value)
        {
            XmlSerializer serializer = new XmlSerializer(typeof(T), string.Empty);

            XmlSerializerNamespaces xmlNamespaces = new XmlSerializerNamespaces();
            xmlNamespaces.Add(string.Empty, string.Empty);

            serializer.Serialize(stream, value, xmlNamespaces);
        }

        private static T Deserialize<T>(string operationName, Stream stream)
        {
            //Read the XML into memory so that the data can be used in an exception if necessary
            using (StreamReader reader = new StreamReader(stream))
            {
                return Deserialize<T>(operationName, reader.ReadToEnd());
            }
        }

        private static T Deserialize<T>(string operationName, string xml)
        {
            //Attempt to deserialize the data. If deserialization fails, include the XML in the exception that is thrown for further
            //investigation
            using (StringReader reader = new StringReader(xml))
            {
                try
                {
                    XmlSerializer serializer = new XmlSerializer(typeof(T), string.Empty);
                    return (T)serializer.Deserialize(reader);
                }
                catch (InvalidOperationException ex)
                {
                    throw new InvalidOperationException(string.Format(CultureInfo.InvariantCulture,
                        "Unable to Deserialize XML (Operation = {0}):{1}{2}", operationName, Environment.NewLine, xml), ex);
                }
            }
        }

        private static FileInfo GetDeviceFile(EnvironmentConfiguration environment)
        {
            return new FileInfo(string.Format(CultureInfo.InvariantCulture, LiveIdConstants.FileNameFormat,
                environment.Type,
                string.IsNullOrEmpty(environment.Environment) ? null : "-" + environment.Environment.ToUpperInvariant()));
        }

        private static ClientCredentials RegisterDevice(Guid applicationId, Uri issuerUri, LiveDevice device)
        {
            EnvironmentConfiguration environment = DiscoverEnvironmentInternal(issuerUri);

            DeviceRegistrationRequest request = new DeviceRegistrationRequest(applicationId, device);

            string url = string.Format(CultureInfo.InvariantCulture, LiveIdConstants.RegistrationEndpointUriFormat,
                environment.HostName);

            DeviceRegistrationResponse response = ExecuteRegistrationRequest(url, request);
            if (!response.IsSuccess)
            {
                bool throwException = true;
                if (DeviceRegistrationErrorCode.DeviceAlreadyExists == response.Error.RegistrationErrorCode)
                {
                    if (!PersistToFile)
                    {
                        //If the file is not persisted, the registration will always occur (since the credentials are not
                        //persisted to the disk. However, the credentials may already exist. To avoid an exception being continually
                        //processed by the calling user, DeviceAlreadyExists will be ignored if the credentials are not persisted to the disk.
                        return device.User.ToClientCredentials();
                    }
                    else if (PersistIfDeviceAlreadyExists)
                    {
                        // This flag indicates that the
                        throwException = false;
                    }
                }

                if (throwException)
                {
                    throw new DeviceRegistrationFailedException(response.Error.RegistrationErrorCode, response.ErrorSubCode);
                }
            }

            if (PersistToFile || PersistIfDeviceAlreadyExists)
            {
                WriteDevice(environment, device);
            }

            return device.User.ToClientCredentials();
        }

        private static LiveDevice GenerateDevice(string deviceName, string devicePassword)
        {
            // If the deviceName hasn't been specified, it should be generated using random characters.
            DeviceUserName userNameCredentials;
            if (string.IsNullOrEmpty(deviceName))
            {
                userNameCredentials = GenerateDeviceUserName();
            }
            else
            {
                userNameCredentials = new DeviceUserName() { DeviceName = deviceName, DecryptedPassword = devicePassword };
            }

            return new LiveDevice() { User = userNameCredentials, Version = 1 };
        }

        private static LiveDevice ReadExistingDevice(EnvironmentConfiguration environment)
        {
            //Retrieve the file info
            FileInfo file = GetDeviceFile(environment);
            if (!file.Exists)
            {
                return null;
            }

            using (FileStream stream = file.Open(FileMode.Open, FileAccess.Read, FileShare.Read))
            {
                return Deserialize<LiveDevice>("Loading Device Credentials from Disk", stream);
            }
        }

        private static void WriteDevice(EnvironmentConfiguration environment, LiveDevice device)
        {
            FileInfo file = GetDeviceFile(environment);
            if (!file.Directory.Exists)
            {
                file.Directory.Create();
            }

            using (FileStream stream = file.Open(FileMode.CreateNew, FileAccess.Write, FileShare.None))
            {
                Serialize(stream, device);
            }
        }

        private static DeviceRegistrationResponse ExecuteRegistrationRequest(string url, DeviceRegistrationRequest registrationRequest)
        {
            //Create the request that will submit the request to the server
            WebRequest request = WebRequest.Create(url);
            request.ContentType = "application/soap+xml; charset=UTF-8";
            request.Method = "POST";
            request.Timeout = 180000;

            //Write the envelope to the RequestStream
            using (Stream stream = request.GetRequestStream())
            {
                Serialize(stream, registrationRequest);
            }

            // Read the response into an XmlDocument and return that doc
            try
            {
                using (WebResponse response = request.GetResponse())
                {
                    using (Stream stream = response.GetResponseStream())
                    {
                        return Deserialize<DeviceRegistrationResponse>("Deserializing Registration Response", stream);
                    }
                }
            }
            catch (WebException ex)
            {
                System.Diagnostics.Trace.TraceError("Microsoft account Device Registration Failed (HTTP Code: {0}): {1}",
                    ex.Status, ex.Message);

                if (null != ex.Response)
                {
                    using (Stream stream = ex.Response.GetResponseStream())
                    {
                        return Deserialize<DeviceRegistrationResponse>("Deserializing Failed Registration Response", stream);
                    }
                }

                throw;
            }
        }

        private static DeviceUserName GenerateDeviceUserName()
        {
            DeviceUserName userName = new DeviceUserName();
            userName.DeviceName = GenerateRandomString(LiveIdConstants.ValidDeviceNameCharacters, MaxDeviceNameLength);
            userName.DecryptedPassword = GenerateRandomString(LiveIdConstants.ValidDevicePasswordCharacters, MaxDevicePasswordLength);

            return userName;
        }

        private static string GenerateRandomString(string characterSet, int count)
        {
            //Create an array of the characters that will hold the final list of random characters
            char[] value = new char[count];

            //Convert the character set to an array that can be randomly accessed
            char[] set = characterSet.ToCharArray();

            lock (RandomInstance)
            {
                //Populate the array with random characters from the character set
                for (int i = 0; i < count; i++)
                {
                    value[i] = set[RandomInstance.Next(0, set.Length)];
                }
            }

            return new string(value);
        }
        #endregion

        #region Private Classes
        private enum EnvironmentType
        {
            LiveDeviceID,
            OrgDeviceID
        }

        private sealed class EnvironmentConfiguration
        {
            public EnvironmentConfiguration(EnvironmentType type, string hostName, string environment)
            {
                if (string.IsNullOrWhiteSpace(hostName))
                {
                    throw new ArgumentNullException("hostName");
                }

                this.Type = type;
                this.HostName = hostName;
                this.Environment = environment;
            }

            #region Properties
            public EnvironmentType Type { get; private set; }

            public string HostName { get; private set; }

            public string Environment { get; private set; }
            #endregion
        }

        private static class LiveIdConstants
        {
            public const string RegistrationEndpointUriFormat = @"https://{0}/ppsecure/DeviceAddCredential.srf";

            public static readonly string FileNameFormat = Path.Combine(
                Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.UserProfile), "LiveDeviceID"),
                "{0}{1}.xml");

            public const string ValidDeviceNameCharacters = "0123456789abcdefghijklmnopqrstuvqxyz";

            //Consists of the list of characters specified in the documentation
            public const string ValidDevicePasswordCharacters = "abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789!@#$%^*()-_=+;,./?`~";
        }
        #endregion
    }

    #region Public Classes & Enums
    /// <summary>
    /// Indicates an error during registration
    /// </summary>
    public enum DeviceRegistrationErrorCode
    {
        /// <summary>
        /// Unspecified or Unknown Error occurred
        /// </summary>
        Unknown = 0,

        /// <summary>
        /// Interface Disabled
        /// </summary>
        InterfaceDisabled = 1,

        /// <summary>
        /// Invalid Request Format
        /// </summary>
        InvalidRequestFormat = 3,

        /// <summary>
        /// Unknown Client Version
        /// </summary>
        UnknownClientVersion = 4,

        /// <summary>
        /// Blank Password
        /// </summary>
        BlankPassword = 6,

        /// <summary>
        /// Missing Device User Name or Password
        /// </summary>
        MissingDeviceUserNameOrPassword = 7,

        /// <summary>
        /// Invalid Parameter Syntax
        /// </summary>
        InvalidParameterSyntax = 8,

        /// <summary>
        /// Invalid Characters are used in the device credentials.
        /// </summary>
        InvalidCharactersInCredentials = 9,

        /// <summary>
        /// Internal Error
        /// </summary>
        InternalError = 11,

        /// <summary>
        /// Device Already Exists
        /// </summary>
        DeviceAlreadyExists = 13
    }

    /// <summary>
    /// Indicates that Device Registration failed
    /// </summary>
    [Serializable]
    public sealed class DeviceRegistrationFailedException : Exception
    {
        /// <summary>
        /// Construct an instance of the DeviceRegistrationFailedException class
        /// </summary>
        public DeviceRegistrationFailedException()
            : base()
        {
        }

        /// <summary>
        /// Construct an instance of the DeviceRegistrationFailedException class
        /// </summary>
        /// <param name="message">Message to pass</param>
        public DeviceRegistrationFailedException(string message)
            : base(message)
        {
        }

        /// <summary>
        /// Construct an instance of the DeviceRegistrationFailedException class
        /// </summary>
        /// <param name="message">Message to pass</param>
        /// <param name="innerException">Exception to include</param>
        public DeviceRegistrationFailedException(string message, Exception innerException)
            : base(message, innerException)
        {
        }

        /// <summary>
        /// Construct an instance of the DeviceRegistrationFailedException class
        /// </summary>
        /// <param name="code">Error code that occurred</param>
        /// <param name="subCode">Subcode that occurred</param>
        public DeviceRegistrationFailedException(DeviceRegistrationErrorCode code, string subCode)
            : this(code, subCode, null)
        {
        }

        /// <summary>
        /// Construct an instance of the DeviceRegistrationFailedException class
        /// </summary>
        /// <param name="code">Error code that occurred</param>
        /// <param name="subCode">Subcode that occurred</param>
        /// <param name="innerException">Inner exception</param>
        public DeviceRegistrationFailedException(DeviceRegistrationErrorCode code, string subCode, Exception innerException)
            : base(string.Concat(code.ToString(), ": ", subCode), innerException)
        {
            this.RegistrationErrorCode = code;
        }

        /// <summary>
        /// Construct an instance of the DeviceRegistrationFailedException class
        /// </summary>
        /// <param name="si"></param>
        /// <param name="sc"></param>
        private DeviceRegistrationFailedException(SerializationInfo si, StreamingContext sc)
            : base(si, sc)
        {
        }

        #region Properties
        /// <summary>
        /// Error code that occurred during registration
        /// </summary>
        public DeviceRegistrationErrorCode RegistrationErrorCode { get; private set; }
        #endregion

        #region Methods
        public override void GetObjectData(SerializationInfo info, StreamingContext context)
        {
            base.GetObjectData(info, context);
        }
        #endregion
    }

    #region Serialization Classes
    #region DeviceRegistrationRequest Class
    [EditorBrowsable(EditorBrowsableState.Never)]
    [XmlRoot("DeviceAddRequest")]
    public sealed class DeviceRegistrationRequest
    {
        #region Constructors
        public DeviceRegistrationRequest()
        {
        }

        public DeviceRegistrationRequest(Guid applicationId, LiveDevice device)
            : this()
        {
            if (null == device)
            {
                throw new ArgumentNullException("device");
            }

            this.ClientInfo = new DeviceRegistrationClientInfo() { ApplicationId = applicationId, Version = "1.0" };
            this.Authentication = new DeviceRegistrationAuthentication()
            {
                MemberName = device.User.DeviceId,
                Password = device.User.DecryptedPassword
            };
        }
        #endregion

        #region Properties
        [XmlElement("ClientInfo")]
        public DeviceRegistrationClientInfo ClientInfo { get; set; }

        [XmlElement("Authentication")]
        public DeviceRegistrationAuthentication Authentication { get; set; }
        #endregion
    }
    #endregion

    #region DeviceRegistrationClientInfo Class
    [EditorBrowsable(EditorBrowsableState.Never)]
    [XmlRoot("ClientInfo")]
    public sealed class DeviceRegistrationClientInfo
    {
        #region Properties
        [XmlAttribute("name")]
        public Guid ApplicationId { get; set; }

        [XmlAttribute("version")]
        public string Version { get; set; }
        #endregion
    }
    #endregion

    #region DeviceRegistrationAuthentication Class
    [EditorBrowsable(EditorBrowsableState.Never)]
    [XmlRoot("Authentication")]
    public sealed class DeviceRegistrationAuthentication
    {
        #region Properties
        [XmlElement("Membername")]
        public string MemberName { get; set; }

        [XmlElement("Password")]
        public string Password { get; set; }
        #endregion
    }
    #endregion

    #region DeviceRegistrationResponse Class
    [EditorBrowsable(EditorBrowsableState.Never)]
    [XmlRoot("DeviceAddResponse")]
    public sealed class DeviceRegistrationResponse
    {
        #region Properties
        [XmlElement("success")]
        public bool IsSuccess { get; set; }

        [XmlElement("puid")]
        public string Puid { get; set; }

        [XmlElement("Error")]
        public DeviceRegistrationResponseError Error { get; set; }

        [XmlElement("ErrorSubcode")]
        public string ErrorSubCode { get; set; }
        #endregion
    }
    #endregion

    #region DeviceRegistrationResponse Class
    [EditorBrowsable(EditorBrowsableState.Never)]
    [XmlRoot("Error")]
    public sealed class DeviceRegistrationResponseError
    {
        private string _code;

        #region Properties
        [XmlAttribute("Code")]
        public string Code
        {
            get
            {
                return this._code;
            }

            set
            {
                this._code = value;

                //Parse the error code
                if (!string.IsNullOrEmpty(value))
                {
                    //Parse the error code
                    if (value.StartsWith("dc", StringComparison.Ordinal))
                    {
                        int code;
                        if (int.TryParse(value.Substring(2), NumberStyles.Integer,
                            CultureInfo.InvariantCulture, out code) &&
                            Enum.IsDefined(typeof(DeviceRegistrationErrorCode), code))
                        {
                            this.RegistrationErrorCode = (DeviceRegistrationErrorCode)Enum.ToObject(
                                typeof(DeviceRegistrationErrorCode), code);
                        }
                    }
                }
            }
        }

        [XmlIgnore]
        public DeviceRegistrationErrorCode RegistrationErrorCode { get; private set; }
        #endregion
    }
    #endregion

    #region LiveDevice Class
    [EditorBrowsable(EditorBrowsableState.Never)]
    [XmlRoot("Data")]
    public sealed class LiveDevice
    {
        #region Properties
        [XmlAttribute("version")]
        public int Version { get; set; }

        [XmlElement("User")]
        public DeviceUserName User { get; set; }

        [SuppressMessage("Microsoft.Design", "CA1059:MembersShouldNotExposeCertainConcreteTypes", MessageId = "System.Xml.XmlNode", Justification = "This is required for proper XML Serialization")]
        [XmlElement("Token")]
        public XmlNode Token { get; set; }

        [XmlElement("Expiry")]
        public string Expiry { get; set; }

        [XmlElement("ClockSkew")]
        public string ClockSkew { get; set; }
        #endregion
    }
    #endregion

    #region DeviceUserName Class
    [EditorBrowsable(EditorBrowsableState.Never)]
    public sealed class DeviceUserName
    {
        private string _encryptedPassword;
        private string _decryptedPassword;
        private bool _encryptedValueIsUpdated;

        #region Constants
        private const string UserNamePrefix = "11";
        #endregion

        #region Constructors
        public DeviceUserName()
        {
            this.UserNameType = "Logical";
        }
        #endregion

        #region Properties
        [XmlAttribute("username")]
        public string DeviceName { get; set; }

        [XmlAttribute("type")]
        public string UserNameType { get; set; }

        [XmlElement("Pwd")]
        public string EncryptedPassword
        {
            get
            {
                this.ThrowIfNoEncryption();

                if (!this._encryptedValueIsUpdated)
                {
                    this._encryptedPassword = this.Encrypt(this._decryptedPassword);
                    this._encryptedValueIsUpdated = true;
                }

                return this._encryptedPassword;
            }

            set
            {
                this.ThrowIfNoEncryption();
                this.UpdateCredentials(value, null);
            }
        }

        public string DeviceId
        {
            get
            {
                return UserNamePrefix + DeviceName;
            }
        }

        [XmlIgnore]
        public string DecryptedPassword
        {
            get
            {
                return this._decryptedPassword;
            }

            set
            {
                this.UpdateCredentials(null, value);
            }
        }

        private bool IsEncryptionEnabled
        {
            get
            {
                //If the object is not going to be persisted to a file, then the value does not need to be encrypted. This is extra
                //overhead and will not function in partial trust.
                return DeviceIdManager.PersistToFile;
            }
        }
        #endregion

        #region Methods
        public ClientCredentials ToClientCredentials()
        {
            ClientCredentials credentials = new ClientCredentials();
            credentials.UserName.UserName = this.DeviceId;
            credentials.UserName.Password = this.DecryptedPassword;

            return credentials;
        }

        private void ThrowIfNoEncryption()
        {
            if (!this.IsEncryptionEnabled)
            {
                throw new NotSupportedException("Not supported when DeviceIdManager.UseEncryptionApis is false.");
            }
        }

        private void UpdateCredentials(string encryptedValue, string decryptedValue)
        {
            bool isValueUpdated = false;
            if (string.IsNullOrEmpty(encryptedValue) && string.IsNullOrEmpty(decryptedValue))
            {
                isValueUpdated = true;
            }
            else if (string.IsNullOrEmpty(encryptedValue))
            {
                if (this.IsEncryptionEnabled)
                {
                    encryptedValue = this.Encrypt(decryptedValue);
                    isValueUpdated = true;
                }
                else
                {
                    encryptedValue = null;
                    isValueUpdated = false;
                }
            }
            else
            {
                this.ThrowIfNoEncryption();

                decryptedValue = this.Decrypt(encryptedValue);
                isValueUpdated = true;
            }

            this._encryptedPassword = encryptedValue;
            this._decryptedPassword = decryptedValue;
            this._encryptedValueIsUpdated = isValueUpdated;
        }

        private string Encrypt(string value)
        {
            if (string.IsNullOrEmpty(value))
            {
                return value;
            }

            byte[] encryptedBytes = ProtectedData.Protect(Encoding.UTF8.GetBytes(value), null, DataProtectionScope.CurrentUser);
            return Convert.ToBase64String(encryptedBytes);
        }

        private string Decrypt(string value)
        {
            if (string.IsNullOrEmpty(value))
            {
                return value;
            }

            byte[] decryptedBytes = ProtectedData.Unprotect(Convert.FromBase64String(value), null, DataProtectionScope.CurrentUser);
            if (null == decryptedBytes || 0 == decryptedBytes.Length)
            {
                return null;
            }

            return Encoding.UTF8.GetString(decryptedBytes, 0, decryptedBytes.Length);
        }
        #endregion
    }
    #endregion
    #endregion
    #endregion
}
Visual Basic Copy Code
Imports System
Imports System.Collections.Generic
Imports System.ComponentModel
Imports System.Diagnostics.CodeAnalysis
Imports System.Globalization
Imports System.IO
Imports System.Net
Imports System.Runtime.Serialization
Imports System.Security.Cryptography
Imports System.ServiceModel.Description
Imports System.Text
Imports System.Xml
Imports System.Xml.Serialization

Namespace Microsoft.Crm.Services.Utility
    ''' <summary>
    ''' Management utility for the Device Id
    ''' </summary>
    Public NotInheritable Class DeviceIdManager
        #Region "Fields"
        Private Shared ReadOnly RandomInstance As New Random()

        Public Const MaxDeviceNameLength As Integer = 24
        Public Const MaxDevicePasswordLength As Integer = 24
        #End Region

        #Region "Constructor"
        Private Sub New()
        End Sub
        Shared Sub New()
            PersistToFile = True
        End Sub
        #End Region

        #Region "Properties"
        ''' <summary>
        ''' Indicates whether the registered device credentials should be persisted to the database
        ''' </summary>
        Public Shared Property PersistToFile() As Boolean

        ''' <summary>
        ''' Indicates that the credentials should be persisted to the disk if registration fails with DeviceAlreadyExists.
        ''' </summary>
        ''' <remarks>
        ''' If the device already exists, there is a possibility that the credentials are the same as the current credentials that
        ''' are being registered. This is especially true in automated environments where the same credentials are used continually (to avoid
        ''' registering spurious device credentials.
        ''' </remarks>
        Public Shared Property PersistIfDeviceAlreadyExists() As Boolean
        #End Region

        #Region "Methods"
        ''' <summary>
        ''' Loads the device credentials (if they exist).
        ''' </summary>
        ''' <returns></returns>
        Public Shared Function LoadOrRegisterDevice() As ClientCredentials
            Return LoadOrRegisterDevice(Nothing)
        End Function

        ''' <summary>
        ''' Loads the device credentials (if they exist).
        ''' </summary>
        ''' <param name="deviceName">Device name that should be registered</param>
        ''' <param name="devicePassword">Device password that should be registered</param>
        Public Shared Function LoadOrRegisterDevice(ByVal deviceName As String, ByVal devicePassword As String) As ClientCredentials
            Return LoadOrRegisterDevice(Nothing, deviceName, devicePassword)
        End Function

        ''' <summary>
        ''' Loads the device credentials (if they exist).
        ''' </summary>
        ''' <param name="issuerUri">URL for the current token issuer</param>
        ''' <remarks>
        ''' The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        ''' </remarks>
        Public Shared Function LoadOrRegisterDevice(ByVal issuerUri As Uri) As ClientCredentials
            Return LoadOrRegisterDevice(issuerUri, Nothing, Nothing)
        End Function

        ''' <summary>
        ''' Loads the device credentials (if they exist).
        ''' </summary>
        ''' <param name="issuerUri">URL for the current token issuer</param>
        ''' <param name="deviceName">Device name that should be registered</param>
        ''' <param name="devicePassword">Device password that should be registered</param>
        ''' <remarks>
        ''' The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        ''' </remarks>
        Public Shared Function LoadOrRegisterDevice(ByVal issuerUri As Uri, ByVal deviceName As String, ByVal devicePassword As String) _
               As ClientCredentials
            Dim credentials As ClientCredentials = LoadDeviceCredentials(issuerUri)
            If Nothing Is credentials Then
                credentials = RegisterDevice(Guid.NewGuid(), issuerUri, deviceName, devicePassword)
            End If

            Return credentials
        End Function

        ''' <summary>
        ''' Registers the given device with Microsoft account with a random application ID
        ''' </summary>
        ''' <returns>ClientCredentials that were registered</returns>
        Public Shared Function RegisterDevice() As ClientCredentials
            Return RegisterDevice(Guid.NewGuid())
        End Function

        ''' <summary>
        ''' Registers the given device with Microsoft account
        ''' </summary>
        ''' <param name="applicationId">ID for the application</param>
        ''' <returns>ClientCredentials that were registered</returns>
        Public Shared Function RegisterDevice(ByVal applicationId As Guid) As ClientCredentials
            Return RegisterDevice(applicationId, CType(Nothing, Uri))
        End Function

        ''' <summary>
        ''' Registers the given device with Microsoft account
        ''' </summary>
        ''' <param name="applicationId">ID for the application</param>
        ''' <param name="issuerUri">URL for the current token issuer</param>
        ''' <returns>ClientCredentials that were registered</returns>
        ''' <remarks>
        ''' The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        ''' </remarks>
        Public Shared Function RegisterDevice(ByVal applicationId As Guid, ByVal issuerUri As Uri) As ClientCredentials
            Return RegisterDevice(applicationId, issuerUri, Nothing, Nothing)
        End Function

        ''' <summary>
        ''' Registers the given device with Microsoft account
        ''' </summary>
        ''' <param name="applicationId">ID for the application</param>
        ''' <param name="deviceName">Device name that should be registered</param>
        ''' <param name="devicePassword">Device password that should be registered</param>
        ''' <returns>ClientCredentials that were registered</returns>
        Public Shared Function RegisterDevice(ByVal applicationId As Guid, ByVal deviceName As String, ByVal devicePassword As String) _
               As ClientCredentials
            Return RegisterDevice(applicationId, CType(Nothing, Uri), deviceName, devicePassword)
        End Function

        ''' <summary>
        ''' Registers the given device with Microsoft account
        ''' </summary>
        ''' <param name="applicationId">ID for the application</param>
        ''' <param name="issuerUri">URL for the current token issuer</param>
        ''' <param name="deviceName">Device name that should be registered</param>
        ''' <param name="devicePassword">Device password that should be registered</param>
        ''' <returns>ClientCredentials that were registered</returns>
        ''' <remarks>
        ''' The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        ''' </remarks>
        Public Shared Function RegisterDevice(ByVal applicationId As Guid, ByVal issuerUri As Uri, ByVal deviceName As String, _
                                              ByVal devicePassword As String) As ClientCredentials
            If String.IsNullOrEmpty(deviceName) AndAlso (Not PersistToFile) Then
                Throw New ArgumentNullException("deviceName", "If PersistToFile is false, then deviceName must be specified.")
            ElseIf String.IsNullOrEmpty(deviceName) <> String.IsNullOrEmpty(devicePassword) Then
                Throw New ArgumentNullException("deviceName", _
                                                "Either deviceName/devicePassword should both be specified or they should be null.")
            End If

            Dim device As LiveDevice = GenerateDevice(deviceName, devicePassword)
            Return RegisterDevice(applicationId, issuerUri, device)
        End Function

        ''' <summary>
        ''' Loads the device's credentials from the file system
        ''' </summary>
        ''' <returns>Device Credentials (if set) or null</returns>
        Public Shared Function LoadDeviceCredentials() As ClientCredentials
            Return LoadDeviceCredentials(Nothing)
        End Function

        ''' <summary>
        ''' Loads the device's credentials from the file system
        ''' </summary>
        ''' <param name="issuerUri">URL for the current token issuer</param>
        ''' <returns>Device Credentials (if set) or null</returns>
        ''' <remarks>
        ''' The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.
        ''' </remarks>
        Public Shared Function LoadDeviceCredentials(ByVal issuerUri As Uri) As ClientCredentials
            'If the credentials should not be persisted to a file, then they won't be present on the disk.
            If Not PersistToFile Then
                Return Nothing
            End If

            Dim environment As EnvironmentConfiguration = DiscoverEnvironmentInternal(issuerUri)

            Dim device As LiveDevice = ReadExistingDevice(environment)
            If Nothing Is device OrElse Nothing Is device.User Then
                Return Nothing
            End If

            Return device.User.ToClientCredentials()
        End Function

        ''' <summary>
        ''' Discovers the Windows Live environment based on the Token Issuer
        ''' </summary>
        Public Shared Function DiscoverEnvironment(ByVal issuerUri As Uri) As String
            Return DiscoverEnvironmentInternal(issuerUri).Environment
        End Function
        #End Region

        #Region "Private Methods"
        Private Shared Function DiscoverEnvironmentInternal(ByVal issuerUri As Uri) As EnvironmentConfiguration
            If Nothing Is issuerUri Then
                Return New EnvironmentConfiguration(EnvironmentType.LiveDeviceID, "login.live.com", Nothing)
            End If

            Dim searchList As New Dictionary(Of EnvironmentType, String)()
            searchList.Add(EnvironmentType.LiveDeviceID, "login.live")
            searchList.Add(EnvironmentType.OrgDeviceID, "login.microsoftonline")

            For Each searchPair As KeyValuePair(Of EnvironmentType, String) In searchList
                If issuerUri.Host.Length > searchPair.Value.Length AndAlso issuerUri.Host.StartsWith(searchPair.Value, StringComparison.OrdinalIgnoreCase) Then
                    Dim environment As String = issuerUri.Host.Substring(searchPair.Value.Length)

                    'Parse out the environment
                If "-"c = environment.Chars(0) Then
                    Dim separatorIndex As Integer = environment.IndexOf("."c, 1)
                    If -1 <> separatorIndex Then
                            environment = environment.Substring(1, separatorIndex - 1)
                        Else
                            environment = Nothing
                        End If
                    Else
                        environment = Nothing
                    End If

                    Return New EnvironmentConfiguration(searchPair.Key, issuerUri.Host, environment)
                End If
            Next searchPair

            'In all other cases the environment is either not applicable or it is a production system
            Return New EnvironmentConfiguration(EnvironmentType.LiveDeviceID, issuerUri.Host, Nothing)
        End Function

        Private Shared Sub Serialize(Of T)(ByVal stream As Stream, ByVal value As T)
            Dim serializer As New XmlSerializer(GetType(T), String.Empty)

            Dim xmlNamespaces As New XmlSerializerNamespaces()
            xmlNamespaces.Add(String.Empty, String.Empty)

            serializer.Serialize(stream, value, xmlNamespaces)
        End Sub

        Private Shared Function Deserialize(Of T)(ByVal operationName As String, ByVal stream As Stream) As T
            'Read the XML into memory so that the data can be used in an exception if necessary
            Using reader As New StreamReader(stream)
                Return Deserialize(Of T)(operationName, reader.ReadToEnd())
            End Using
        End Function

        Private Shared Function Deserialize(Of T)(ByVal operationName As String, ByVal xml As String) As T
            'Attempt to deserialize the data. If deserialization fails, include the XML in the exception that is thrown for further
            'investigation
            Using reader As New StringReader(xml)
                Try
                    Dim serializer As New XmlSerializer(GetType(T), String.Empty)
                    Return CType(serializer.Deserialize(reader), T)
                Catch ex As InvalidOperationException
                    Throw New InvalidOperationException(String.Format(CultureInfo.InvariantCulture, "Unable to Deserialize XML (Operation = {0}):{1}{2}", operationName, Environment.NewLine, xml), ex)
                End Try
            End Using
        End Function

        Private Shared Function GetDeviceFile(ByVal environment As EnvironmentConfiguration) As FileInfo
            Return New FileInfo(String.Format(CultureInfo.InvariantCulture, LiveIdConstants.FileNameFormat, environment.Type,If(String.IsNullOrEmpty(environment.Environment), Nothing, "-" & environment.Environment.ToUpperInvariant())))
        End Function

        Private Shared Function RegisterDevice(ByVal applicationId As Guid, ByVal issuerUri As Uri, ByVal device As LiveDevice) As ClientCredentials
            Dim environment As EnvironmentConfiguration = DiscoverEnvironmentInternal(issuerUri)

            Dim request As New DeviceRegistrationRequest(applicationId, device)

            Dim url As String = String.Format(CultureInfo.InvariantCulture, LiveIdConstants.RegistrationEndpointUriFormat, environment.HostName)

            Dim response As DeviceRegistrationResponse = ExecuteRegistrationRequest(url, request)
            If Not response.IsSuccess Then
                Dim throwException As Boolean = True
                If DeviceRegistrationErrorCode.DeviceAlreadyExists = response.Error.RegistrationErrorCode Then
                    If Not PersistToFile Then
                        'If the file is not persisted, the registration will always occur (since the credentials are not
                        'persisted to the disk. However, the credentials may already exist. To avoid an exception being continually
                        'processed by the calling user, DeviceAlreadyExists will be ignored if the credentials are not persisted to the disk.
                        Return device.User.ToClientCredentials()
                    ElseIf PersistIfDeviceAlreadyExists Then
                        ' This flag indicates that the
                        throwException = False
                    End If
                End If

                If throwException Then
                    Throw New DeviceRegistrationFailedException(response.Error.RegistrationErrorCode, response.ErrorSubCode)
                End If
            End If

            If PersistToFile OrElse PersistIfDeviceAlreadyExists Then
                WriteDevice(environment, device)
            End If

            Return device.User.ToClientCredentials()
        End Function

        Private Shared Function GenerateDevice(ByVal deviceName As String, ByVal devicePassword As String) As LiveDevice
            ' If the deviceName hasn't been specified, it should be generated using random characters.
            Dim userNameCredentials As DeviceUserName
            If String.IsNullOrEmpty(deviceName) Then
                userNameCredentials = GenerateDeviceUserName()
            Else
                userNameCredentials = New DeviceUserName() With {.DeviceName = deviceName, .DecryptedPassword = devicePassword}
            End If

            Return New LiveDevice() With {.User = userNameCredentials, .Version = 1}
        End Function

        Private Shared Function ReadExistingDevice(ByVal environment As EnvironmentConfiguration) As LiveDevice
            'Retrieve the file info
            Dim file As FileInfo = GetDeviceFile(environment)
            If Not file.Exists Then
                Return Nothing
            End If

            Using stream As FileStream = file.Open(FileMode.Open, FileAccess.Read, FileShare.Read)
                Return Deserialize(Of LiveDevice)("Loading Device Credentials from Disk", stream)
            End Using
        End Function

        Private Shared Sub WriteDevice(ByVal environment As EnvironmentConfiguration, ByVal device As LiveDevice)
            Dim file As FileInfo = GetDeviceFile(environment)
            If Not file.Directory.Exists Then
                file.Directory.Create()
            End If

            Using stream As FileStream = file.Open(FileMode.CreateNew, FileAccess.Write, FileShare.None)
                Serialize(stream, device)
            End Using
        End Sub

        Private Shared Function ExecuteRegistrationRequest(ByVal url As String, ByVal registrationRequest As DeviceRegistrationRequest) _
               As DeviceRegistrationResponse
            'Create the request that will submit the request to the server
            Dim request As WebRequest = WebRequest.Create(url)
            request.ContentType = "application/soap+xml; charset=UTF-8"
            request.Method = "POST"
            request.Timeout = 180000

            'Write the envelope to the RequestStream
            Using stream As Stream = request.GetRequestStream()
                Serialize(stream, registrationRequest)
            End Using

            ' Read the response into an XmlDocument and return that doc
            Try
                Using response As WebResponse = request.GetResponse()
                    Using stream As Stream = response.GetResponseStream()
                        Return Deserialize(Of DeviceRegistrationResponse)("Deserializing Registration Response", stream)
                    End Using
                End Using
            Catch ex As WebException
                System.Diagnostics.Trace.TraceError("Live ID Device Registration Failed (HTTP Code: {0}): {1}", ex.Status, ex.Message)
                If Nothing IsNot ex.Response Then
                    Using stream As Stream = ex.Response.GetResponseStream()
                        Return Deserialize(Of DeviceRegistrationResponse)("Deserializing Failed Registration Response", stream)
                    End Using
                End If

                Throw
            End Try
        End Function

        Private Shared Function GenerateDeviceUserName() As DeviceUserName
            Dim userName As New DeviceUserName()
            userName.DeviceName = GenerateRandomString(LiveIdConstants.ValidDeviceNameCharacters, MaxDeviceNameLength)
            userName.DecryptedPassword = GenerateRandomString(LiveIdConstants.ValidDevicePasswordCharacters, MaxDevicePasswordLength)

            Return userName
        End Function

        Private Shared Function GenerateRandomString(ByVal characterSet As String, ByVal count As Integer) As String
            'Create an array of the characters that will hold the final list of random characters
            Dim value(count - 1) As Char

            'Convert the character set to an array that can be randomly accessed
            Dim [set]() As Char = characterSet.ToCharArray()

            SyncLock RandomInstance
                'Populate the array with random characters from the character set
                For i As Integer = 0 To count - 1
                    value(i) = [set](RandomInstance.Next(0, [set].Length))
                Next i
            End SyncLock

            Return New String(value)
        End Function
        #End Region

        #Region "Private Classes"
        Private Enum EnvironmentType
            LiveDeviceID
            OrgDeviceID
        End Enum

        Private NotInheritable Class EnvironmentConfiguration
            Public Sub New(ByVal type As EnvironmentType, ByVal hostName As String, ByVal environment As String)
                If String.IsNullOrWhiteSpace(hostName) Then
                    Throw New ArgumentNullException("hostName")
                End If

                Me.Type = type
                Me.HostName = hostName
                Me.Environment = environment
            End Sub

            #Region "Properties"
            Private privateType As EnvironmentType
            Public Property Type() As EnvironmentType
                Get
                    Return privateType
                End Get
                Private Set(ByVal value As EnvironmentType)
                    privateType = value
                End Set
            End Property

            Private privateHostName As String
            Public Property HostName() As String
                Get
                    Return privateHostName
                End Get
                Private Set(ByVal value As String)
                    privateHostName = value
                End Set
            End Property

            Private privateEnvironment As String
            Public Property Environment() As String
                Get
                    Return privateEnvironment
                End Get
                Private Set(ByVal value As String)
                    privateEnvironment = value
                End Set
            End Property
            #End Region
        End Class

        Private NotInheritable Class LiveIdConstants
            Public Const RegistrationEndpointUriFormat As String = "https://{0}/ppsecure/DeviceAddCredential.srf"

            Public Shared ReadOnly FileNameFormat As String = Path.Combine(Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.UserProfile), "LiveDeviceID"), "{0}{1}.xml")

            Public Const ValidDeviceNameCharacters As String = "0123456789abcdefghijklmnopqrstuvqxyz"

            'Consists of the list of characters specified in the documentation
            Public Const ValidDevicePasswordCharacters As String = _
                "abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789!@#$%^*()-_=+;,./?`~"
        End Class
        #End Region
    End Class

    #Region "Public Classes & Enums"
    ''' <summary>
    ''' Indicates an error during registration
    ''' </summary>
    Public Enum DeviceRegistrationErrorCode
        ''' <summary>
        ''' Unspecified or Unknown Error occurred
        ''' </summary>
        Unknown = 0

        ''' <summary>
        ''' Interface Disabled
        ''' </summary>
        InterfaceDisabled = 1

        ''' <summary>
        ''' Invalid Request Format
        ''' </summary>
        InvalidRequestFormat = 3

        ''' <summary>
        ''' Unknown Client Version
        ''' </summary>
        UnknownClientVersion = 4

        ''' <summary>
        ''' Blank Password
        ''' </summary>
        BlankPassword = 6

        ''' <summary>
        ''' Missing Device User Name or Password
        ''' </summary>
        MissingDeviceUserNameOrPassword = 7

        ''' <summary>
        ''' Invalid Parameter Syntax
        ''' </summary>
        InvalidParameterSyntax = 8

        ''' <summary>
        ''' Invalid Characters are used in the device credentials.
        ''' </summary>
        InvalidCharactersInCredentials = 9

        ''' <summary>
        ''' Internal Error
        ''' </summary>
        InternalError = 11

        ''' <summary>
        ''' Device Already Exists
        ''' </summary>
        DeviceAlreadyExists = 13
    End Enum

    ''' <summary>
    ''' Indicates that Device Registration failed
    ''' </summary>
    <Serializable> _
    Public NotInheritable Class DeviceRegistrationFailedException
        Inherits Exception
        ''' <summary>
        ''' Construct an instance of the DeviceRegistrationFailedException class
        ''' </summary>
        Public Sub New()
            MyBase.New()
        End Sub

        ''' <summary>
        ''' Construct an instance of the DeviceRegistrationFailedException class
        ''' </summary>
        ''' <param name="message">Message to pass</param>
        Public Sub New(ByVal message As String)
            MyBase.New(message)
        End Sub

        ''' <summary>
        ''' Construct an instance of the DeviceRegistrationFailedException class
        ''' </summary>
        ''' <param name="message">Message to pass</param>
        ''' <param name="innerException">Exception to include</param>
        Public Sub New(ByVal message As String, ByVal innerException As Exception)
            MyBase.New(message, innerException)
        End Sub

        ''' <summary>
        ''' Construct an instance of the DeviceRegistrationFailedException class
        ''' </summary>
        ''' <param name="code">Error code that occurred</param>
        ''' <param name="subCode">Subcode that occurred</param>
        Public Sub New(ByVal code As DeviceRegistrationErrorCode, ByVal subCode As String)
            Me.New(code, subCode, Nothing)
        End Sub

        ''' <summary>
        ''' Construct an instance of the DeviceRegistrationFailedException class
        ''' </summary>
        ''' <param name="code">Error code that occurred</param>
        ''' <param name="subCode">Subcode that occurred</param>
        ''' <param name="innerException">Inner exception</param>
        Public Sub New(ByVal code As DeviceRegistrationErrorCode, ByVal subCode As String, ByVal innerException As Exception)
            MyBase.New(String.Concat(code.ToString(), ": ", subCode), innerException)
            Me.RegistrationErrorCode = code
        End Sub

        ''' <summary>
        ''' Construct an instance of the DeviceRegistrationFailedException class
        ''' </summary>
        ''' <param name="si"></param>
        ''' <param name="sc"></param>
        Private Sub New(ByVal si As SerializationInfo, ByVal sc As StreamingContext)
            MyBase.New(si, sc)
        End Sub

        #Region "Properties"
        ''' <summary>
        ''' Error code that occurred during registration
        ''' </summary>
        Private privateRegistrationErrorCode As DeviceRegistrationErrorCode
        Public Property RegistrationErrorCode() As DeviceRegistrationErrorCode
            Get
                Return privateRegistrationErrorCode
            End Get
            Private Set(ByVal value As DeviceRegistrationErrorCode)
                privateRegistrationErrorCode = value
            End Set
        End Property
        #End Region

        #Region "Methods"
        Public Overrides Sub GetObjectData(ByVal info As SerializationInfo, ByVal context As StreamingContext)
            MyBase.GetObjectData(info, context)
        End Sub
        #End Region
    End Class

    #Region "Serialization Classes"
    #Region "DeviceRegistrationRequest Class"
    <EditorBrowsable(EditorBrowsableState.Never), XmlRoot("DeviceAddRequest")> _
    Public NotInheritable Class DeviceRegistrationRequest
        #Region "Constructors"
        Public Sub New()
        End Sub

        Public Sub New(ByVal applicationId As Guid, ByVal device As LiveDevice)
            Me.New()
            If Nothing Is device Then
                Throw New ArgumentNullException("device")
            End If

            Me.ClientInfo = New DeviceRegistrationClientInfo() With {.ApplicationId = applicationId, .Version = "1.0"}
            Me.Authentication = New DeviceRegistrationAuthentication() With {.MemberName = device.User.DeviceId, _
                                                                             .Password = device.User.DecryptedPassword}
        End Sub
        #End Region

        #Region "Properties"
        <XmlElement("ClientInfo")> _
        Public Property ClientInfo() As DeviceRegistrationClientInfo

        <XmlElement("Authentication")> _
        Public Property Authentication() As DeviceRegistrationAuthentication
        #End Region
    End Class
    #End Region

    #Region "DeviceRegistrationClientInfo Class"
    <EditorBrowsable(EditorBrowsableState.Never), XmlRoot("ClientInfo")> _
    Public NotInheritable Class DeviceRegistrationClientInfo
        #Region "Properties"
        <XmlAttribute("name")> _
        Public Property ApplicationId() As Guid

        <XmlAttribute("version")> _
        Public Property Version() As String
        #End Region
    End Class
    #End Region

    #Region "DeviceRegistrationAuthentication Class"
    <EditorBrowsable(EditorBrowsableState.Never), XmlRoot("Authentication")> _
    Public NotInheritable Class DeviceRegistrationAuthentication
        #Region "Properties"
        <XmlElement("Membername")> _
        Public Property MemberName() As String

        <XmlElement("Password")> _
        Public Property Password() As String
        #End Region
    End Class
    #End Region

    #Region "DeviceRegistrationResponse Class"
    <EditorBrowsable(EditorBrowsableState.Never), XmlRoot("DeviceAddResponse")> _
    Public NotInheritable Class DeviceRegistrationResponse
        #Region "Properties"
        <XmlElement("success")> _
        Public Property IsSuccess() As Boolean

        <XmlElement("puid")> _
        Public Property Puid() As String

        <XmlElement("Error")> _
        Public Property [Error]() As DeviceRegistrationResponseError

        <XmlElement("ErrorSubcode")> _
        Public Property ErrorSubCode() As String
        #End Region
    End Class
    #End Region

    #Region "DeviceRegistrationResponse Class"
    <EditorBrowsable(EditorBrowsableState.Never), XmlRoot("Error")> _
    Public NotInheritable Class DeviceRegistrationResponseError
        Private _code As String

        #Region "Properties"
        <XmlAttribute("Code")> _
        Public Property Code() As String
            Get
                Return Me._code
            End Get

            Set(ByVal value As String)
                Me._code = value

                'Parse the error code
                If Not String.IsNullOrEmpty(value) Then
                    'Parse the error code
                    If value.StartsWith("dc", StringComparison.Ordinal) Then
                        Dim code_Renamed As Integer
                        If Integer.TryParse(value.Substring(2), NumberStyles.Integer, CultureInfo.InvariantCulture, code_Renamed) _
                               AndAlso System.Enum.IsDefined(GetType(DeviceRegistrationErrorCode), code_Renamed) Then
                            Me.RegistrationErrorCode = CType(System.Enum.ToObject(GetType(DeviceRegistrationErrorCode), code_Renamed), DeviceRegistrationErrorCode)
                        End If
                    End If
                End If
            End Set
        End Property

        Private privateRegistrationErrorCode As DeviceRegistrationErrorCode
        <XmlIgnore> _
        Public Property RegistrationErrorCode() As DeviceRegistrationErrorCode
            Get
                Return privateRegistrationErrorCode
            End Get
            Private Set(ByVal value As DeviceRegistrationErrorCode)
                privateRegistrationErrorCode = value
            End Set
        End Property
        #End Region
    End Class
    #End Region

    #Region "LiveDevice Class"
    <EditorBrowsable(EditorBrowsableState.Never), XmlRoot("Data")> _
    Public NotInheritable Class LiveDevice
        #Region "Properties"
        <XmlAttribute("version")> _
        Public Property Version() As Integer

        <XmlElement("User")> _
        Public Property User() As DeviceUserName

        <SuppressMessage("Microsoft.Design", "CA1059:MembersShouldNotExposeCertainConcreteTypes", _
            MessageId:="System.Xml.XmlNode", Justification:="This is required for proper XML Serialization"), XmlElement("Token")> _
        Public Property Token() As XmlNode

        <XmlElement("Expiry")> _
        Public Property Expiry() As String

        <XmlElement("ClockSkew")> _
        Public Property ClockSkew() As String
        #End Region
    End Class
    #End Region

    #Region "DeviceUserName Class"
    <EditorBrowsable(EditorBrowsableState.Never)> _
    Public NotInheritable Class DeviceUserName
        Private _encryptedPassword As String
        Private _decryptedPassword As String
        Private _encryptedValueIsUpdated As Boolean

        #Region "Constants"
        Private Const UserNamePrefix As String = "11"
        #End Region

        #Region "Constructors"
        Public Sub New()
            Me.UserNameType = "Logical"
        End Sub
        #End Region

        #Region "Properties"
        <XmlAttribute("username")> _
        Public Property DeviceName() As String

        <XmlAttribute("type")> _
        Public Property UserNameType() As String

        <XmlElement("Pwd")> _
        Public Property EncryptedPassword() As String
            Get
                Me.ThrowIfNoEncryption()

                If Not Me._encryptedValueIsUpdated Then
                    Me._encryptedPassword = Me.Encrypt(Me._decryptedPassword)
                    Me._encryptedValueIsUpdated = True
                End If

                Return Me._encryptedPassword
            End Get

            Set(ByVal value As String)
                Me.ThrowIfNoEncryption()
                Me.UpdateCredentials(value, Nothing)
            End Set
        End Property

        Public ReadOnly Property DeviceId() As String
            Get
                Return UserNamePrefix & DeviceName
            End Get
        End Property

        <XmlIgnore> _
        Public Property DecryptedPassword() As String
            Get
                Return Me._decryptedPassword
            End Get

            Set(ByVal value As String)
                Me.UpdateCredentials(Nothing, value)
            End Set
        End Property

        Private ReadOnly Property IsEncryptionEnabled() As Boolean
            Get
                'If the object is not going to be persisted to a file, then the value does not need to be encrypted. This is extra
                'overhead and will not function in partial trust.
                Return DeviceIdManager.PersistToFile
            End Get
        End Property
        #End Region

        #Region "Methods"
        Public Function ToClientCredentials() As ClientCredentials
            Dim credentials As New ClientCredentials()
            credentials.UserName.UserName = Me.DeviceId
            credentials.UserName.Password = Me.DecryptedPassword

            Return credentials
        End Function

        Private Sub ThrowIfNoEncryption()
            If Not Me.IsEncryptionEnabled Then
                Throw New NotSupportedException("Not supported when DeviceIdManager.UseEncryptionApis is false.")
            End If
        End Sub

        Private Sub UpdateCredentials(ByVal encryptedValue As String, ByVal decryptedValue As String)
            Dim isValueUpdated As Boolean = False
            If String.IsNullOrEmpty(encryptedValue) AndAlso String.IsNullOrEmpty(decryptedValue) Then
                isValueUpdated = True
            ElseIf String.IsNullOrEmpty(encryptedValue) Then
                If Me.IsEncryptionEnabled Then
                    encryptedValue = Me.Encrypt(decryptedValue)
                    isValueUpdated = True
                Else
                    encryptedValue = Nothing
                    isValueUpdated = False
                End If
            Else
                Me.ThrowIfNoEncryption()

                decryptedValue = Me.Decrypt(encryptedValue)
                isValueUpdated = True
            End If

            Me._encryptedPassword = encryptedValue
            Me._decryptedPassword = decryptedValue
            Me._encryptedValueIsUpdated = isValueUpdated
        End Sub

        Private Function Encrypt(ByVal value As String) As String
            If String.IsNullOrEmpty(value) Then
                Return value
            End If

            Dim encryptedBytes() As Byte = ProtectedData.Protect(Encoding.UTF8.GetBytes(value), Nothing, DataProtectionScope.CurrentUser)
            Return Convert.ToBase64String(encryptedBytes)
        End Function

        Private Function Decrypt(ByVal value As String) As String
            If String.IsNullOrEmpty(value) Then
                Return value
            End If

            Dim decryptedBytes() As Byte = ProtectedData.Unprotect(Convert.FromBase64String(value), Nothing, DataProtectionScope.CurrentUser)
            If Nothing Is decryptedBytes OrElse 0 = decryptedBytes.Length Then
                Return Nothing
            End If

            Return Encoding.UTF8.GetString(decryptedBytes, 0, decryptedBytes.Length)
        End Function
        #End Region
    End Class
    #End Region
    #End Region
    #End Region
End Namespace

See Also

Concepts

Use the sample and helper code
Use the sample and helper code

Other Resources

Helper code: SystemUserProvider class
Authenticate users with Microsoft Dynamics CRM web services
Helper code: ServerConnection class

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Helper code: SystemUserProvider class
See Also Example

Download the Microsoft Dynamics CRM SDK package. This sample can be found in the following location in the download package:

SDK\SampleCode\CS\HelperCode\SystemUserProvider.cs

SDK\SampleCode\VB\HelperCode\SystemUserProvider.vb

Requirements

The logged on system user must have system administration privileges for this sample code to create the new user accounts. For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The SystemUserProvider class demonstrates how to programmatically create additional users in Active Directory andMicrosoft Dynamics CRM 2015.

Several SDK samples require additional (fictitious) system users to exist in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, other than the logged on user, for the sample to perform its intended task. These samples use the SystemUserProvider class methods to create these additional required users. Since it currently is not possible to programmatically create a new Microsoft account user, when running against a Microsoft Dynamics CRM Online server, the code just prints the required user information to the console. You can then manually add and invite those users if desired.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.DirectoryServices;
using System.Threading;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This class contains methods which retrieve the IDs of several fictitious Microsoft Dynamics
    /// CRM system users.  Several SDK samples require these additional user accounts in order to run.
    /// </summary>
    /// <remarks>For On-premises and IFD deployments, if these users do not exist they are created in
    /// Active Directory. This assumes that the system user account under which the application runs has
    /// system administrator privileges. Since it is not possible to programmatically create user accounts
    /// in Microsoft account, when running this code against a Microsoft Dynamics CRM Online server, you will have
    /// to manually add these users.</remarks>
    public class SystemUserProvider
    {
        public static Guid RetrieveSalesManager(OrganizationServiceProxy proxy)
        {
            String ldapPath = String.Empty;
            return RetrieveSystemUser("kcook", "Kevin", "Cook", "Sales Manager", proxy, ref ldapPath);
        }
        public static Guid RetrieveSalesManager(OrganizationServiceProxy proxy, ref String ldapPath)
        {
            return RetrieveSystemUser("kcook", "Kevin", "Cook", "Sales Manager", proxy, ref ldapPath);
        }

        public static List<Guid> RetrieveSalespersons(OrganizationServiceProxy proxy, ref String ldapPath)
        {
            List<Guid> reps = new List<Guid>();

            reps.Add(RetrieveSystemUser("nanderson", "Nancy", "Anderson", "Salesperson", proxy, ref ldapPath));
            reps.Add(RetrieveSystemUser("dbristol", "David", "Bristol", "Salesperson", proxy, ref ldapPath));

            return reps;
        }

        public static List<Guid> RetrieveDelegates(OrganizationServiceProxy proxy,
            ref String ldapPath)
        {
            List<Guid> delegates = new List<Guid>();

            delegates.Add(RetrieveSystemUser("dwilson", "Dan", "Wilson", "Delegate", proxy, ref ldapPath));
            delegates.Add(RetrieveSystemUser("canderson", "Christen", "Anderson", "Delegate", proxy, ref ldapPath));
            return delegates;
        }

        public static Guid RetrieveVPSales(OrganizationServiceProxy proxy, ref String ldapPath)
        {
            return RetrieveSystemUser("mtucker", "Michael", "Tucker", "Vice President of Sales", proxy, ref ldapPath);
        }

        public static Guid RetrieveMarketingManager(OrganizationServiceProxy proxy)
        {
            String ldapPath = String.Empty;
            return RetrieveMarketingManager(proxy, ref ldapPath);
        }

        public static Guid RetrieveMarketingManager(OrganizationServiceProxy proxy, ref String ldapPath)
        {
            return RetrieveSystemUser("ssmith", "Samantha", "Smith", "Marketing Manager", proxy, ref ldapPath);
        }

        public static Guid RetrieveAUserWithoutAnyRoleAssigned(OrganizationServiceProxy proxy)
        {
            String ldapPath = String.Empty;
            return RetrieveSystemUser("dpark", "Dan", "Park", "", proxy, ref ldapPath);
        }

        /// <summary>
        /// Retrieves the requested SystemUser record.  If the record does not exist, a new
        /// Microsoft Dynamics CRM SystemUser record is created and an associated Active
        /// Directory account is created, if it doesn't currently exist.
        /// </summary>
        /// <param name="userName">The username field as set in Microsoft Dynamics CRM</param>
        /// <param name="firstName">The first name of the system user to be retrieved</param>
        /// <param name="lastName">The last name of the system user to be retrieved</param>
        /// <param name="roleStr">The string representing the Microsoft Dynamics CRM security
        /// role for the user</param>
        /// <param name="serviceProxy">The OrganizationServiceProxy object to your Microsoft
        /// Dynamics CRM environment</param>
        /// <param name="ldapPath">The LDAP path for your network - you can either call
        /// ConsolePromptForLDAPPath() to prompt the user or provide a value in code</param>
        /// <returns></returns>
        public static Guid RetrieveSystemUser(String userName, String firstName,
            String lastName, String roleStr, OrganizationServiceProxy serviceProxy,
            ref String ldapPath)
        {
            String domain;
            Guid userId = Guid.Empty;

            if (serviceProxy == null)
                throw new ArgumentNullException("serviceProxy");

            if (String.IsNullOrWhiteSpace(userName))
                throw new ArgumentNullException("UserName");

            if (String.IsNullOrWhiteSpace(firstName))
                throw new ArgumentNullException("FirstName");

            if (String.IsNullOrWhiteSpace(lastName))
                throw new ArgumentNullException("LastName");

            // Obtain the current user's information.
            WhoAmIRequest who = new WhoAmIRequest();
            WhoAmIResponse whoResp = (WhoAmIResponse)serviceProxy.Execute(who);
            Guid currentUserId = whoResp.UserId;

            SystemUser currentUser =
                serviceProxy.Retrieve(SystemUser.EntityLogicalName, currentUserId, new ColumnSet("domainname")).ToEntity<SystemUser>();

            // Extract the domain and create the LDAP object.
            String[] userPath = currentUser.DomainName.Split(new char[] { '\\' });
            if (userPath.Length > 1)
                domain = userPath[0] + "\\";
            else
                domain = String.Empty;

            SystemUser existingUser = GetUserIdIfExist(serviceProxy, domain, userName, firstName, lastName);

            if (existingUser != null)
            {
                userId = existingUser.SystemUserId.Value;

                if (!String.IsNullOrWhiteSpace(roleStr))
                {
                    // Check to make sure the user is assigned the correct role.
                    Role role = RetrieveRoleByName(serviceProxy, roleStr);

                    // Associate the user with the role when needed.
                    if (!UserInRole(serviceProxy, userId, role.Id))
                    {
                        AssociateRequest associate = new AssociateRequest()
                        {
                            Target = new EntityReference(SystemUser.EntityLogicalName, userId),
                            RelatedEntities = new EntityReferenceCollection()
                        {
                            new EntityReference(Role.EntityLogicalName, role.Id)
                        },
                            Relationship = new Relationship("systemuserroles_association")
                        };
                        serviceProxy.Execute(associate);
                    }
                }
            }
            else
            {
                // Create the system user in Microsoft Dynamics CRM if the user doesn't
                // already exist.
                userId = CreateSystemUser(userName, firstName, lastName, domain,
                    roleStr, serviceProxy, ref ldapPath);
            }

            return userId;
        }

        /// <summary>
        /// Helper method to check if system user already exist with either given username or first and last name.
        /// </summary>
        /// <param name="serviceProxy">The OrganizationServiceProxy object to your Microsoft
        /// Dynamics CRM environment</param>
        /// <param name="domainName">Current domain name of the account.</param>
        /// <param name="userName">The username field as set in Microsoft Dynamics CRM</param>
        /// <param name="firstName">The first name of the system user to be retrieved</param>
        /// <param name="lastName">The last name of the system user to be retrieved</param>
        /// <returns></returns>
        public static SystemUser GetUserIdIfExist(OrganizationServiceProxy serviceProxy,
            String domainName, String userName, String firstName, String lastName)
        {
            QueryExpression userQuery = new QueryExpression
            {
                EntityName = SystemUser.EntityLogicalName,
                ColumnSet = new ColumnSet("systemuserid"),
                Criteria =
                {
                    FilterOperator = LogicalOperator.Or,
                    Filters =
                    {
                        new FilterExpression
                        {
                            FilterOperator = LogicalOperator.And,
                            Conditions =
                            {
                                new ConditionExpression("domainname", ConditionOperator.Equal, domainName + userName)
                            }
                        },
                        new FilterExpression
                        {
                            FilterOperator = LogicalOperator.And,
                            Conditions =
                            {
                                new ConditionExpression("firstname", ConditionOperator.Equal, firstName),
                                new ConditionExpression("lastname", ConditionOperator.Equal, lastName)
                            }
                        }
                    }

                }
            };

            DataCollection<Entity> existingUsers = (DataCollection<Entity>)serviceProxy.RetrieveMultiple(userQuery).Entities;

            if (existingUsers.Count > 0)
                return existingUsers[0].ToEntity<SystemUser>();
            return null;
        }

        private static Guid CreateSystemUser(String userName, String firstName,
            String lastName, String domain, String roleStr,
            OrganizationServiceProxy serviceProxy, ref String ldapPath)
        {
            CreateADAccount(userName, firstName, lastName, serviceProxy, ref ldapPath);

            // Retrieve the default business unit needed to create the user.
            QueryExpression businessUnitQuery = new QueryExpression
            {
                EntityName = BusinessUnit.EntityLogicalName,
                ColumnSet = new ColumnSet("businessunitid"),
                Criteria =
                {
                    Conditions =
                    {
                        new ConditionExpression("parentbusinessunitid",
                            ConditionOperator.Null)
                    }
                }
            };

            BusinessUnit defaultBusinessUnit = serviceProxy.RetrieveMultiple(
                businessUnitQuery).Entities[0].ToEntity<BusinessUnit>();

            //Create a new system user.
            SystemUser user = new SystemUser
            {
                DomainName = domain + userName,
                FirstName = firstName,
                LastName = lastName,
                BusinessUnitId = new EntityReference
                {
                    LogicalName = BusinessUnit.EntityLogicalName,
                    Name = BusinessUnit.EntityLogicalName,
                    Id = defaultBusinessUnit.Id
                }
            };
            Guid userId = serviceProxy.Create(user);

            if (!String.IsNullOrWhiteSpace(roleStr))
            {
                // Retrieve the specified security role.
                Role role = RetrieveRoleByName(serviceProxy, roleStr);

                // Assign the security role to the newly created Microsoft Dynamics CRM user.
                AssociateRequest associate = new AssociateRequest()
                {
                    Target = new EntityReference(SystemUser.EntityLogicalName, userId),
                    RelatedEntities = new EntityReferenceCollection()
                {
                    new EntityReference(Role.EntityLogicalName, role.Id),
                },
                    Relationship = new Relationship("systemuserroles_association")
                };
                serviceProxy.Execute(associate);
            }
            return userId;
        }

        /// <summary>
        /// Helper method to create an active directory account
        /// </summary>
        /// <param name="userName">The username field as set in Microsoft Dynamics CRM</param>
        /// <param name="firstName">The first name of the system user to be retrieved</param>
        /// <param name="lastName">The last name of the system user to be retrieved</param>
        /// <param name="serviceProxy">The OrganizationServiceProxy object to your Microsoft
        /// Dynamics CRM environment</param>
        /// <param name="ldapPath">The LDAP path for your network - you can either call
        /// ConsolePromptForLDAPPath() to prompt the user or provide a value in code</param>
        /// <returns>Return true if new account is created or return false if account already exist.</returns>
        public static Boolean CreateADAccount(String userName,
            String firstName,
            String lastName,
            OrganizationServiceProxy serviceProxy,
            ref String ldapPath)
        {
            // Check to make sure this is not Microsoft Dynamics CRM Online.
            if (serviceProxy.ServiceConfiguration.AuthenticationType == AuthenticationProviderType.LiveId ||
                serviceProxy.ServiceConfiguration.AuthenticationType == AuthenticationProviderType.OnlineFederation)
                throw new Exception(String.Format("To run this sample, {0} {1} must be an active system user " +
                    "\nin your Microsoft Dynamics CRM Online organization.", firstName, lastName));

            if (String.IsNullOrEmpty(ldapPath))
                ldapPath = SystemUserProvider.ConsolePromptForLDAPPath();

            // Create an Active Directory user account if it doesn't exist already.
            if (String.IsNullOrEmpty(ldapPath))
                throw new ArgumentException("Required argument ldapPath was not provided.");

            DirectoryEntry directoryEntry;
            if (serviceProxy.ClientCredentials.Windows != null)
            {
                string LUser = serviceProxy.ClientCredentials.Windows.ClientCredential.UserName;
                string LPwd = serviceProxy.ClientCredentials.Windows.ClientCredential.Password;
                directoryEntry = new DirectoryEntry(ldapPath, LUser, LPwd);
            }
            else
            {
                directoryEntry = new DirectoryEntry(ldapPath);
            }

            DirectoryEntry userADAccount = null;

            // Search AD to see if the user already exists.
            DirectorySearcher search = new DirectorySearcher(directoryEntry);
            search.Filter = String.Format("(sAMAccountName={0})", userName);
            search.PropertiesToLoad.Add("samaccountname");
            search.PropertiesToLoad.Add("givenname");
            search.PropertiesToLoad.Add("sn");
            search.PropertiesToLoad.Add("cn");
            SearchResult result = search.FindOne();
            Boolean accountCreated = false;
            if (result == null)
            {
                // Create the Active Directory account.
                userADAccount = directoryEntry.Children.Add("CN= " + userName, "user");
                userADAccount.Properties["samAccountName"].Value = userName;
                userADAccount.Properties["givenName"].Value = firstName;
                userADAccount.Properties["sn"].Value = lastName;
                userADAccount.CommitChanges();
                accountCreated = true;
            }
            else
            {
                // Use the existing AD account.
                userADAccount = result.GetDirectoryEntry();
                accountCreated = false;
            }

            // Set the password for the account.
            String password = "pass@word1";
            userADAccount.Invoke("SetPassword", new object[] { password });
            userADAccount.CommitChanges();
            directoryEntry.Close();
            userADAccount.Close();

            // Enable the newly created Active Directory account.
            userADAccount.Properties["userAccountControl"].Value =
                (int)userADAccount.Properties["userAccountControl"].Value & ~0x2;
            userADAccount.CommitChanges();

            // Wait 10 seconds for the AD account to propagate.
            Thread.Sleep(10000);
            return accountCreated;
        }

        /// <summary>
        /// Helper method to prompt the user for the LDAP path for the network
        /// </summary>
        /// <returns>The LDAP path for your network</returns>
        public static String ConsolePromptForLDAPPath()
        {
            // Prompt for the LDAP path.
            Console.WriteLine("An Active Directory connection is required. Please enter an");
            Console.WriteLine("LDAP path for your network in the format 'LDAP://server/DC=subdomain,DC=domain,DC=com': ");
            String ldapPath = Console.ReadLine();

            return ldapPath;
        }

        private static bool UserInRole(OrganizationServiceProxy serviceProxy,
            Guid userId, Guid roleId)
        {
            // Establish a SystemUser link for a query.
            LinkEntity systemUserLink = new LinkEntity()
            {
                LinkFromEntityName = SystemUserRoles.EntityLogicalName,
                LinkFromAttributeName = "systemuserid",
                LinkToEntityName = SystemUser.EntityLogicalName,
                LinkToAttributeName = "systemuserid",
                LinkCriteria =
                {
                    Conditions =
                    {
                        new ConditionExpression(
                            "systemuserid", ConditionOperator.Equal, userId)
                    }
                }
            };

            // Build the query.
            QueryExpression query = new QueryExpression()
            {
                EntityName = Role.EntityLogicalName,
                ColumnSet = new ColumnSet("roleid"),
                LinkEntities =
                {
                    new LinkEntity()
                    {
                        LinkFromEntityName = Role.EntityLogicalName,
                        LinkFromAttributeName = "roleid",
                        LinkToEntityName = SystemUserRoles.EntityLogicalName,
                        LinkToAttributeName = "roleid",
                        LinkEntities = {systemUserLink}
                    }
                },
                Criteria =
                {
                    Conditions =
                    {
                        new ConditionExpression("roleid", ConditionOperator.Equal, roleId)
                    }
                }
            };

            // Retrieve matching roles.
            EntityCollection ec = serviceProxy.RetrieveMultiple(query);

            if (ec.Entities.Count > 0)
                return true;

            return false;
        }

        private static Role RetrieveRoleByName(OrganizationServiceProxy serviceProxy,
            String roleStr)
        {
            QueryExpression roleQuery = new QueryExpression
            {
                EntityName = Role.EntityLogicalName,
                ColumnSet = new ColumnSet("roleid"),
                Criteria =
                {
                    Conditions =
                    {
                        new ConditionExpression("name", ConditionOperator.Equal, roleStr)
                    }
                }
            };

            return serviceProxy.RetrieveMultiple(roleQuery).Entities[0].ToEntity<Role>();
        }
    }
}
Visual Basic Copy Code
Imports Microsoft.VisualBasic
Imports System
Imports System.Collections.Generic
Imports System.DirectoryServices
Imports System.Threading

' These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
' located in the SDK\bin folder of the SDK download.
Imports Microsoft.Xrm.Sdk
Imports Microsoft.Xrm.Sdk.Query
Imports Microsoft.Xrm.Sdk.Client
Imports Microsoft.Xrm.Sdk.Messages

' This namespace is found in the Microsoft.Crm.Sdk.Proxy.dll assembly
' located in the SDK\bin folder of the SDK download.
Imports Microsoft.Crm.Sdk.Messages

Namespace Microsoft.Crm.Sdk.Samples
    ''' <summary>
    ''' This class contains methods which retrieve the IDs of several fictitious Microsoft Dynamics
    ''' CRM system users.  Several SDK samples require these additional user accounts in order to run.
    ''' </summary>
    ''' <remarks>For On-premises and IFD deployments, if these users do not exist they are created in
    ''' Active Directory. This assumes that the system user account under which the application runs has
    ''' system administrator privileges. Since it is not possible to programmatically create user accounts
    ''' in Microsoft account, when running this code against a Microsoft Dynamics CRM Online server, you will have
    ''' to manually add these users.</remarks>
    Public Class SystemUserProvider
        Public Shared Function RetrieveSalesManager(ByVal proxy As OrganizationServiceProxy) As Guid
            Dim ldapPath As String = String.Empty
            Return RetrieveSystemUser("kcook", "Kevin", "Cook", "Sales Manager", proxy, ldapPath)
        End Function
        Public Shared Function RetrieveSalesManager(ByVal proxy As OrganizationServiceProxy, ByRef ldapPath As String) As Guid
            Return RetrieveSystemUser("kcook", "Kevin", "Cook", "Sales Manager", proxy, ldapPath)
        End Function

        Public Shared Function RetrieveSalespersons(ByVal proxy As OrganizationServiceProxy, ByRef ldapPath As String) As List(Of Guid)
            Dim reps As New List(Of Guid)()

            reps.Add(RetrieveSystemUser("nanderson", "Nancy", "Anderson", "Salesperson", proxy, ldapPath))
            reps.Add(RetrieveSystemUser("dbristol", "David", "Bristol", "Salesperson", proxy, ldapPath))

            Return reps
        End Function

        Public Shared Function RetrieveDelegates(ByVal proxy As OrganizationServiceProxy, ByRef ldapPath As String) As List(Of Guid)
            Dim delegates As New List(Of Guid)()

            delegates.Add(RetrieveSystemUser("dwilson", "Dan", "Wilson", "Delegate", proxy, ldapPath))
            delegates.Add(RetrieveSystemUser("canderson", "Christen", "Anderson", "Delegate", proxy, ldapPath))
            Return delegates
        End Function

        Public Shared Function RetrieveVPSales(ByVal proxy As OrganizationServiceProxy, ByRef ldapPath As String) As Guid
            Return RetrieveSystemUser("mtucker", "Michael", "Tucker", "Vice President of Sales", proxy, ldapPath)
        End Function

        Public Shared Function RetrieveMarketingManager(ByVal proxy As OrganizationServiceProxy) As Guid
            Dim ldapPath As String = String.Empty
            Return RetrieveMarketingManager(proxy, ldapPath)
        End Function

        Public Shared Function RetrieveMarketingManager(ByVal proxy As OrganizationServiceProxy, ByRef ldapPath As String) As Guid
            Return RetrieveSystemUser("ssmith", "Samantha", "Smith", "Marketing Manager", proxy, ldapPath)
        End Function

        Public Shared Function RetrieveAUserWithoutAnyRoleAssigned(ByVal proxy As OrganizationServiceProxy) As Guid
            Dim ldapPath As String = String.Empty
            Return RetrieveSystemUser("dpark", "Dan", "Park", "", proxy, ldapPath)
        End Function

        ''' <summary>
        ''' Retrieves the requested SystemUser record.  If the record does not exist, a new
        ''' Microsoft Dynamics CRM SystemUser record is created and an associated Active
        ''' Directory account is created, if it doesn't currently exist.
        ''' </summary>
        ''' <param name="userName">The username field as set in Microsoft Dynamics CRM</param>
        ''' <param name="firstName">The first name of the system user to be retrieved</param>
        ''' <param name="lastName">The last name of the system user to be retrieved</param>
        ''' <param name="roleStr">The string representing the Microsoft Dynamics CRM security
        ''' role for the user</param>
        ''' <param name="serviceProxy">The OrganizationServiceProxy object to your Microsoft
        ''' Dynamics CRM environment</param>
        ''' <param name="ldapPath">The LDAP path for your network - you can either call
        ''' ConsolePromptForLDAPPath() to prompt the user or provide a value in code</param>
        ''' <returns></returns>
        Public Shared Function RetrieveSystemUser(ByVal userName As String, ByVal firstName As String, ByVal lastName As String, _
                                                  ByVal roleStr As String, ByVal serviceProxy As OrganizationServiceProxy, _
                                                  ByRef ldapPath As String) As Guid
            Dim domain As String
            Dim userId As Guid = Guid.Empty

            If serviceProxy Is Nothing Then
                Throw New ArgumentNullException("serviceProxy")
            End If

            If String.IsNullOrWhiteSpace(userName) Then
                Throw New ArgumentNullException("UserName")
            End If

            If String.IsNullOrWhiteSpace(firstName) Then
                Throw New ArgumentNullException("FirstName")
            End If

            If String.IsNullOrWhiteSpace(lastName) Then
                Throw New ArgumentNullException("LastName")
            End If

            ' Obtain the current user's information.
            Dim who As New WhoAmIRequest()
            Dim whoResp As WhoAmIResponse = CType(serviceProxy.Execute(who), WhoAmIResponse)
            Dim currentUserId As Guid = whoResp.UserId

            Dim currentUser As SystemUser = serviceProxy.Retrieve(SystemUser.EntityLogicalName, currentUserId, _
                                                                        New ColumnSet("domainname")).ToEntity(Of SystemUser)()

            ' Extract the domain and create the LDAP object.
            Dim userPath() As String = currentUser.DomainName.Split(New Char() {"\"c})
            If userPath.Length > 1 Then
                domain = userPath(0) & "\"
            Else
                domain = String.Empty
            End If

            Dim existingUser As SystemUser = GetUserIdIfExist(serviceProxy, domain, userName, firstName, lastName)

            If existingUser IsNot Nothing Then
                userId = existingUser.SystemUserId.Value

                If Not String.IsNullOrWhiteSpace(roleStr) Then
                ' Check to make sure the user is assigned the correct role.
                Dim role_Renamed As Role = RetrieveRoleByName(serviceProxy, roleStr)

                ' Associate the user with the role when needed.
                If Not UserInRole(serviceProxy, userId, role_Renamed.Id) Then
                    Dim associate As New AssociateRequest() With { _
                        .Target = New EntityReference(SystemUser.EntityLogicalName, userId), _
                        .RelatedEntities = New EntityReferenceCollection() From {New EntityReference(Role.EntityLogicalName, role_Renamed.Id)}, _
                        .Relationship = New Relationship("systemuserroles_association")}
                    serviceProxy.Execute(associate)
                End If
                End If
            Else
                ' Create the system user in Microsoft Dynamics CRM if the user doesn't
                ' already exist.
                userId = CreateSystemUser(userName, firstName, lastName, domain, roleStr, serviceProxy, ldapPath)
            End If

            Return userId
        End Function

        ''' <summary>
        ''' Helper method to check if system user already exist with either given username or first and last name.
        ''' </summary>
        ''' <param name="serviceProxy">The OrganizationServiceProxy object to your Microsoft
        ''' Dynamics CRM environment</param>
        ''' <param name="domainName">Current domain name of the account.</param>
        ''' <param name="userName">The username field as set in Microsoft Dynamics CRM</param>
        ''' <param name="firstName">The first name of the system user to be retrieved</param>
        ''' <param name="lastName">The last name of the system user to be retrieved</param>
        ''' <returns></returns>
        Public Shared Function GetUserIdIfExist(ByVal serviceProxy As OrganizationServiceProxy,
                                                ByVal domainName As String,
                                                ByVal userName As String,
                                                ByVal firstName As String,
                                                ByVal lastName As String) As SystemUser
            Dim userQuery As QueryExpression = New QueryExpression With
                                               {
                                                   .EntityName = SystemUser.EntityLogicalName,
                                                   .ColumnSet = New ColumnSet("systemuserid")
                                               }
            userQuery.Criteria.Filters.Add(New FilterExpression(LogicalOperator.And))
            userQuery.Criteria.Filters(0).AddCondition(New ConditionExpression("domainname", ConditionOperator.Equal, domainName & userName))
            userQuery.Criteria.Filters.Add(New FilterExpression(LogicalOperator.And))
            userQuery.Criteria.Filters(1).AddCondition(New ConditionExpression("firstname", ConditionOperator.Equal, firstName))
            userQuery.Criteria.Filters(1).AddCondition(New ConditionExpression("lastname", ConditionOperator.Equal, lastName))
            userQuery.Criteria.FilterOperator = LogicalOperator.Or

            Dim existingUsers As DataCollection(Of Entity) = CType(serviceProxy.RetrieveMultiple(userQuery).Entities, DataCollection(Of Entity))

            If existingUsers.Count > 0 Then
                Return existingUsers(0).ToEntity(Of SystemUser)()
            End If
            Return Nothing
        End Function

        Private Shared Function CreateSystemUser(ByVal userName As String, ByVal firstName As String, ByVal lastName As String, _
                                                 ByVal domain As String, ByVal roleStr As String, ByVal serviceProxy As OrganizationServiceProxy, _
                                                 ByRef ldapPath As String) As Guid
            CreateADAccount(userName, firstName, lastName, serviceProxy, ldapPath)

            ' Retrieve the default business unit needed to create the user.
            Dim businessUnitQuery As QueryExpression = New QueryExpression With { _
                .EntityName = BusinessUnit.EntityLogicalName,
                .ColumnSet = New ColumnSet("businessunitid")
            }
            businessUnitQuery.Criteria.AddCondition(
                New ConditionExpression("parentbusinessunitid",
                                        ConditionOperator.Null))

            Dim defaultBusinessUnit As BusinessUnit =
                serviceProxy.RetrieveMultiple(businessUnitQuery).Entities(0).ToEntity(Of BusinessUnit)()

            'Create a new system user.
            Dim user As SystemUser = New SystemUser With
                                     {
                                         .DomainName = domain & userName,
                                         .FirstName = firstName,
                                         .LastName = lastName,
                                         .BusinessUnitId = New EntityReference With
                                                           {
                                                               .LogicalName = BusinessUnit.EntityLogicalName,
                                                               .Name = BusinessUnit.EntityLogicalName,
                                                               .Id = defaultBusinessUnit.Id
                                                           }
                                     }
            Dim userId As Guid = serviceProxy.Create(user)

            If Not String.IsNullOrWhiteSpace(roleStr) Then
            ' Retrieve the specified security role.
            Dim role_Renamed As Role = RetrieveRoleByName(serviceProxy, roleStr)

            ' Assign the security role to the newly created Microsoft Dynamics CRM user.
                Dim associate As New AssociateRequest() With
                    {
                        .Target = New EntityReference(SystemUser.EntityLogicalName, userId),
                        .RelatedEntities = New EntityReferenceCollection() From
                            {
                                New EntityReference(Role.EntityLogicalName, role_Renamed.Id)
                            },
                        .Relationship = New Relationship("systemuserroles_association")
                    }
            serviceProxy.Execute(associate)
            End If
            Return userId
        End Function

        ''' <summary>
        ''' Helper method to create an active directory account
        ''' </summary>
        ''' <param name="userName">The username field as set in Microsoft Dynamics CRM</param>
        ''' <param name="firstName">The first name of the system user to be retrieved</param>
        ''' <param name="lastName">The last name of the system user to be retrieved</param>
        ''' <param name="serviceProxy">The OrganizationServiceProxy object to your Microsoft
        ''' Dynamics CRM environment</param>
        ''' <param name="ldapPath">The LDAP path for your network - you can either call
        ''' ConsolePromptForLDAPPath() to prompt the user or provide a value in code</param>
        ''' <returns>Return true if new account is created or return false if account already exist.</returns>
        Public Shared Function CreateADAccount(ByVal userName As String, ByVal firstName As String, ByVal lastName As String, ByVal serviceProxy As OrganizationServiceProxy, ByRef ldapPath As String) As Boolean
            ' Check to make sure this is not Microsoft Dynamics CRM Online.
            If serviceProxy.ServiceConfiguration.AuthenticationType = AuthenticationProviderType.LiveId OrElse
                serviceProxy.ServiceConfiguration.AuthenticationType = AuthenticationProviderType.OnlineFederation Then
                Throw New Exception(String.Format("To run this sample, {0} {1} must be an active system user " & vbLf _
                                                  & "in your Microsoft Dynamics CRM Online organization.",
                                                  firstName, lastName))
            End If

            If String.IsNullOrEmpty(ldapPath) Then
                ldapPath = SystemUserProvider.ConsolePromptForLDAPPath()
            End If

            ' Create an Active Directory user account if it doesn't exist already.
            If String.IsNullOrEmpty(ldapPath) Then
                Throw New ArgumentException("Required argument ldapPath was not provided.")
            End If
            Dim directoryEntry_Renamed As DirectoryEntry
            If serviceProxy.ClientCredentials.Windows IsNot Nothing Then
                Dim LUser As String = serviceProxy.ClientCredentials.Windows.ClientCredential.UserName
                Dim LPwd As String = serviceProxy.ClientCredentials.Windows.ClientCredential.Password
                directoryEntry_Renamed = New DirectoryEntry(ldapPath, LUser, LPwd)
            Else
                directoryEntry_Renamed = New DirectoryEntry(ldapPath)
            End If

            Dim userADAccount As DirectoryEntry = Nothing

            ' Search AD to see if the user already exists.
            Dim search As New DirectorySearcher(directoryEntry_Renamed)
            search.Filter = String.Format("(sAMAccountName={0})", userName)
            search.PropertiesToLoad.Add("samaccountname")
            search.PropertiesToLoad.Add("givenname")
            search.PropertiesToLoad.Add("sn")
            search.PropertiesToLoad.Add("cn")
            Dim result As SearchResult = search.FindOne()
            Dim accountCreated As Boolean = False
            If result Is Nothing Then
                ' Create the Active Directory account.
                userADAccount = directoryEntry_Renamed.Children.Add("CN= " & userName, "user")
                userADAccount.Properties("samAccountName").Value = userName
                userADAccount.Properties("givenName").Value = firstName
                userADAccount.Properties("sn").Value = lastName
                userADAccount.CommitChanges()
                accountCreated = True
            Else
                ' Use the existing AD account.
                userADAccount = result.GetDirectoryEntry()
                accountCreated = False
            End If

            ' Set the password for the account.
            Dim password As String = "pass@word1"
            userADAccount.Invoke("SetPassword", New Object() { password })
            userADAccount.CommitChanges()
            directoryEntry_Renamed.Close()
            userADAccount.Close()

            ' Enable the newly created Active Directory account.
            userADAccount.Properties("userAccountControl").Value =
                CInt(Fix(userADAccount.Properties("userAccountControl").Value)) And Not &H2
            userADAccount.CommitChanges()

            ' Wait 10 seconds for the AD account to propagate.
            Thread.Sleep(10000)
            Return accountCreated
        End Function

        ''' <summary>
        ''' Helper method to prompt the user for the LDAP path for the network
        ''' </summary>
        ''' <returns>The LDAP path for your network</returns>
        Public Shared Function ConsolePromptForLDAPPath() As String
            ' Prompt for the LDAP path.
            Console.WriteLine("An Active Directory connection is required. Please enter an")
            Console.WriteLine("LDAP path for your network in the format 'LDAP://server/DC=subdomain,DC=domain,DC=com': ")
            Dim ldapPath As String = Console.ReadLine()

            Return ldapPath
        End Function

        Private Shared Function UserInRole(ByVal serviceProxy As OrganizationServiceProxy,
                                           ByVal userId As Guid, ByVal roleId As Guid) As Boolean
            ' Establish a SystemUser link for a query.
            Dim systemUserLink As New LinkEntity() With
                {
                    .LinkFromEntityName = SystemUserRoles.EntityLogicalName,
                    .LinkFromAttributeName = "systemuserid",
                    .LinkToEntityName = SystemUser.EntityLogicalName,
                    .LinkToAttributeName = "systemuserid"
                }
            systemUserLink.LinkCriteria.AddCondition(
                New ConditionExpression("systemuserid", ConditionOperator.Equal, userId))

            ' Build the query.
            Dim query As New QueryExpression() With
                {
                    .EntityName = Role.EntityLogicalName,
                    .ColumnSet = New ColumnSet("roleid")
                }
            query.Criteria.AddCondition(New ConditionExpression("roleid", ConditionOperator.Equal, roleId))
            Dim systemUserRoleLink As New LinkEntity() With
                {
                    .LinkFromEntityName = Role.EntityLogicalName,
                    .LinkFromAttributeName = "roleid",
                    .LinkToEntityName = SystemUserRoles.EntityLogicalName,
                    .LinkToAttributeName = "roleid"
                }
            systemUserRoleLink.LinkEntities.Add(systemUserLink)
            query.LinkEntities.Add(systemUserRoleLink)

            ' Retrieve matching roles.
            Dim ec As EntityCollection = serviceProxy.RetrieveMultiple(query)

            If ec.Entities.Count > 0 Then
                Return True
            End If

            Return False
        End Function

        Private Shared Function RetrieveRoleByName(ByVal serviceProxy As OrganizationServiceProxy,
                                                   ByVal roleStr As String) As Role
            Dim roleQuery As QueryExpression = New QueryExpression With
                                               {
                                                   .EntityName = Role.EntityLogicalName,
                                                   .ColumnSet = New ColumnSet("roleid")
                                               }
            roleQuery.Criteria.AddCondition(New ConditionExpression("name", ConditionOperator.Equal, roleStr))

            Return serviceProxy.RetrieveMultiple(roleQuery).Entities(0).ToEntity(Of Role)()
        End Function
    End Class
End Namespace

See Also

Concepts

Use the sample and helper code

Other Resources

Helper code: Enumerations for option sets
AssociateEntitiesRequest
RetrieveMultipleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Helper code: Enumerations for option sets

The SDK download package includes an extension to the CrmSvcUtil code generation tool that you can use to generate enumerations for all option set values including global option sets, picklist, state, and status values. For more information, see Sample Extension to Generate Enumerations for Option Sets. In addition, it includes a helper code file that contains the enumerations generated for all out-of-the-box values. These enumerations can be used in your code by adding the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb to your project.

Usage Example

The following example shows how to use one of these enumerations to set a value in the Account entity.

Generated Enumerations

Each numeration can be used to test or set the value for a property. Typically this property is an entity attribute but there are a few that are used for other properties.

The following table lists all the enumerations included in these helper files and maps the enumeration to the entity and attribute name.

Enumeration name | Entity name | Attribute name
account_statuscode | Account | StatusCode
AccountAccountCategoryCode | Account | CategoryCode
AccountAccountClassificationCode | Account | ClassificationCode
AccountAccountRatingCode | Account | RatingCode
AccountAddress1_AddressTypeCode | Account | Address1_AddressTypeCode
AccountAddress1_FreightTermsCode | Account | Address1_FreightTermsCode
AccountAddress1_ShippingMethodCode | Account | Address1_ShippingMethodCode
AccountAddress2_AddressTypeCode | Account | Address2_AddressTypeCode
AccountAddress2_FreightTermsCode | Account | Address2_FreightTermsCode
AccountAddress2_ShippingMethodCode | Account | Address2_ShippingMethodCode
AccountBusinessTypeCode | Account | BusinessTypeCode
AccountCustomerSizeCode | Account | CustomerSizeCode
AccountCustomerTypeCode | Account | CustomerTypeCode
AccountIndustryCode | Account | IndustryCode
AccountOwnershipCode | Account | OwnershipCode
AccountPaymentTermsCode | Account | PaymentTermsCode
AccountPreferredAppointmentDayCode | Account | PreferredAppointmentDayCode
AccountPreferredAppointmentTimeCode | Account | PreferredAppointmentTimeCode
AccountPreferredContactMethodCode | Account | PreferredContactMethodCode
AccountShippingMethodCode | Account | ShippingMethodCode
AccountTerritoryCode | Account | TerritoryCode
ActivityPartyInstanceTypeCode | ActivityParty | InstanceTypeCode
ActivityPartyParticipationTypeMask | ActivityParty | ParticipationTypeMask
activitypointer_activitytypecode | ActivityPointer | ActivityTypeCode
activitypointer_deliveryprioritycode | ActivityPointer | PriorityCode
activitypointer_statuscode | ActivityPointer | StatusCode
ActivityPointerInstanceTypeCode | ActivityPointer | InstanceTypeCode
ActivityPointerPriorityCode | ActivityPointer | PriorityCode
appointment_statuscode | Appointment | StatusCode
AppointmentAttachmentErrors | Appointment |
AppointmentInstanceTypeCode | Appointment | InstanceTypeCode
AppointmentPriorityCode | Appointment | PriorityCode
asyncoperation_statuscode | AsyncOperation | StatusCode
AsyncOperationOperationType | AsyncOperation | OperationType
AuditAction | Audit | Action
AuditOperation | Audit | Operation
budgetstatus | Lead Opportunity | BudgetStatus
bulkdeleteoperation_statuscode | BulkDeleteOperation | StatusCode
bulkoperation_statuscode | BulkOperation | StatusCode
BulkOperationCreatedRecordTypeCode | BulkOperation | CreatedRecordTypeCode
BulkOperationOperationTypeCode | BulkOperation | OperationTypeCode
BulkOperationTargetedRecordTypeCode | BulkOperation | TargetedRecordTypeCode
BusinessUnitAddress1_AddressTypeCode | BusinessUnit | Address1_AddressTypeCode
BusinessUnitAddress1_ShippingMethodCode | BusinessUnit | Address1_ShippingMethodCode
BusinessUnitAddress2_AddressTypeCode | BusinessUnit | Address2_AddressTypeCode
BusinessUnitAddress2_ShippingMethodCode | BusinessUnit | Address2_ShippingMethodCode
BusinessUnitNewsArticleArticleTypeCode | BusinessUnitNewsArticle | ArticleTypeCode
CalendarType | Calendar | Type
campaign_statuscode | Campaign | StatusCode
campaignactivity_statuscode | CampaignActivity | StatusCode
CampaignActivityChannelTypeCode | CampaignActivity | ChannelTypeCode
CampaignActivityPriorityCode | CampaignActivity | PriorityCode
CampaignActivityTypeCode | CampaignActivity | TypeCode
campaignresponse_statuscode | CampaignResponse | StatusCode
CampaignResponseChannelTypeCode | CampaignResponse | ChannelTypeCode
CampaignResponsePriorityCode | CampaignResponse | PriorityCode
CampaignResponseResponseCode | CampaignResponse | ResponseCode
CampaignTypeCode | Campaign | TypeCode
columnmapping_statuscode | ColumnMapping | StatusCode
ColumnMappingProcessCode | ColumnMapping | ProcessCode
CompetitorAddress1_AddressTypeCode | Competitor | Address1_AddressTypeCode
CompetitorAddress1_ShippingMethodCode | Competitor | Address1_ShippingMethodCode
CompetitorAddress2_AddressTypeCode | Competitor | Address2_AddressTypeCode
CompetitorAddress2_ShippingMethodCode | Competitor | Address2_ShippingMethodCode
componentstate | ActivityMimeAttachment AttributeMap ConnectionRole ContractTemplate DisplayString EntityMap FieldPermission FieldSecurityProfile KbArticleTemplate MailMergeTemplate PluginAssembly PluginType Report ReportCategory ReportEntity ReportVisibility Role SavedQuery SavedQueryVisualization SdkMessageProcessingStep SdkMessageProcessingStepImage SdkMessageProcessingStepSecureConfig ServiceEndpoint SystemForm Template WebResource Workflow | CompontentState
componenttype | SolutionComponent | ComponentType
connection_statuscode | Connection | StatusCode
ConnectionRecord1ObjectTypeCode | Connection | Record1ObjectTypeCode
ConnectionRecord2ObjectTypeCode | Connection | Record2ObjectTypeCode
connectionrole_category | ConnectionRole | Category
connectionrole_statuscode | ConnectionRole | StatusCode
ConstraintBasedGroupGroupTypeCode | ConstraintBasedGroup | GroupTypeCode
contact_statuscode | Contact | StatusCode
ContactAccountRoleCode | Contact | AccountRoleCode
ContactAddress1_AddressTypeCode | Contact | Address1_AddressTypeCode
ContactAddress1_FreightTermsCode | Contact | Address1_FreightTermsCode
ContactAddress1_ShippingMethodCode | Contact | Address1_ShippingMethodCode
ContactAddress2_AddressTypeCode | Contact | Address2_AddressTypeCode
ContactAddress2_FreightTermsCode | Contact | Address2_FreightTermsCode
ContactAddress2_ShippingMethodCode | Contact | Address2_ShippingMethodCode
ContactAddress3_AddressTypeCode | Contact | Address3_AddressTypeCode
ContactAddress3_FreightTermsCode | Contact | Address3_FreightTermsCode
ContactAddress3_ShippingMethodCode | Contact | Address3_ShippingMethodCode
ContactCustomerSizeCode | Contact | CustomerSizeCode
ContactCustomerTypeCode | Contact | CustomerTypeCode
ContactEducationCode | Contact | EducationCode
ContactFamilyStatusCode | Contact | FamilyStatusCode
ContactGenderCode | Contact | GenderCode
ContactHasChildrenCode | Contact | HasChildrenCode
ContactLeadSourceCode | Contact | LeadSourceCode
ContactPaymentTermsCode | Contact | PaymentTermsCode
ContactPreferredAppointmentDayCode | Contact | PreferredAppointmentDayCode
ContactPreferredAppointmentTimeCode | Contact | PreferredAppointmentTimeCode
ContactPreferredContactMethodCode | Contact | PreferredContactMethodCode
ContactShippingMethodCode | Contact | ShippingMethodCode
ContactTerritoryCode | Contact | TerritoryCode
contract_statuscode | Contract | StatusCode
ContractAllotmentTypeCode | Contract | AllotmentTypeCode
ContractBillingFrequencyCode | Contract | BillingFrequencyCode
ContractContractServiceLevelCode | Contract | ContractServiceLevelCode
contractdetail_statuscode | ContractDetail | StatusCode
ContractDetailContractStateCode | ContractDetail | ContractStateCode
ContractDetailServiceContractUnitsCode | ContractDetail | ServiceContractUnitsCode
ContractTemplateAllotmentTypeCode | ContractTemplate | AllotmentTypeCode
ContractTemplateBillingFrequencyCode | ContractTemplate | BillingFrequencyCode
ContractTemplateContractServiceLevelCode | ContractTemplate | ContractServiceLevelCode
convertrule_statuscode | ConvertRule | StatusCode
ConvertRuleSourceTypeCode | ConvertRule | SourceTypeCode
CustomerAddressAddressTypeCode | CustomerAddress | AddressTypeCode
CustomerAddressFreightTermsCode | CustomerAddress | FreightTermsCode
CustomerAddressShippingMethodCode | CustomerAddress | ShippingMethodCode
dependencytype | Dependency | DependencyType
discounttype_statuscode | DiscountType | StatusCode
duplicaterule_statuscode | DuplicateRule | StatusCode
DuplicateRuleBaseEntityTypeCode | DuplicateRule | BaseEntityTypeCode
DuplicateRuleConditionOperatorCode | DuplicateRule | ConditionOperatorCode
DuplicateRuleMatchingEntityTypeCode | DuplicateRule | MatchingEntityTypeCode
dynamicproperty_statuscode | DynamicProperty | StatusCode
DynamicPropertyAssociationAssociationStatus | DynamicPropertyAssociation | AssociationStatus
DynamicPropertyAssociationInheritanceState | DynamicPropertyAssociation | InheritanceState
DynamicPropertyDataType | DynamicProperty | DataType
email_statuscode | Email | StatusCode
EmailCorrelationMethod | Email | CorrelationMethod
EmailNotifications | Email | Notifications
EmailPriorityCode | Email | PriorityCode
emailserverprofile_authenticationprotocol | EmailServerProfile | IncomingAuthenticationProtocol OutgoingAuthenticationProtocol
emailserverprofile_statuscode | EmailServerProfile | StatusCode
EmailServerProfileExchangeVersion | EmailServerProfile | ExchangeVersion
EmailServerProfileIncomingCredentialRetrieval | EmailServerProfile | IncomingCredentialRetrieval
EmailServerProfileOutgoingCredentialRetrieval | EmailServerProfile | OutgoingCredentialRetrieval
EmailServerProfileServerType | EmailServerProfile | ServerType
entitlement_statuscode | Entitlement | StatusCode
EntitlementAllocationTypeCode | Entitlement | AllocationTypeCode
EntitlementDecreaseRemainingOn | Entitlement | DecreaseRemainingOn
EntitlementKbAccessLevel | Entitlement | KbAccessLevel
EntitlementTemplateAllocationTypeCode | EntitlementTemplate | AllocationTypeCode
EntitlementTemplateDecreaseRemainingOn | EntitlementTemplate | DecreaseRemainingOn
EntitlementTemplateKbAccessLevel | EntitlementTemplate | KbAccessLevel
fax_statuscode | Fax | StatusCode
FaxPriorityCode | Fax | PriorityCode
field_security_permission_type | Used in the FieldPermissionType class |
goal_fiscalperiod | Goal | FiscalPeriod
goal_fiscalyear | Goal | FiscalYear
goal_statuscode | Goal | StatusCode
goalrollupquery_statuscode | GoalRollupQuery | StatusCode
import_statuscode | Import | StatusCode
importentitymapping_statuscode | ImportEntityMapping | StatusCode
ImportEntityMappingDeDupe | ImportEntityMapping | DeDupe
ImportEntityMappingProcessCode | ImportEntityMapping | ProcessCode
importfile_statuscode | ImportFile | StatusCode
ImportFileDataDelimiterCode | ImportFile | DataDelimiterCode
ImportFileFieldDelimiterCode | ImportFile | FieldDelimiterCode
ImportFileFileTypeCode | ImportFile | FileTypeCode
ImportFileProcessCode | ImportFile | ProcessCode
ImportFileProcessingStatus | ImportFile | ProcessingStatus
importlog_statuscode | ImportLog | StatusCode
ImportLogLogPhaseCode | ImportLog | LogPhaseCode
importmap_statuscode | ImportMap | StatusCode
ImportMapEntitiesPerFile | ImportMap | EntitiesPerFile
ImportMapImportMapType | ImportMap | Type
ImportMapSourceType | ImportMap | SourceType
ImportMapTargetEntity | ImportMap | TargetEntity
ImportModeCode | Import | ModeCode
incident_caseorigincode | Incident | CaseOriginCode
incident_statuscode | Incident | StatusCode
IncidentCaseTypeCode | Incident | CaseTypeCode
IncidentContractServiceLevelCode | Incident | ContractServiceLevelCode
IncidentCustomerSatisfactionCode | Incident | CustomerSatisfactionCode
IncidentFirstResponseSLAStatus | Incident | FirstResponseSLAStatus
IncidentIncidentStageCode | Incident | StageCode
IncidentPriorityCode | Incident | PriorityCode
incidentresolution_statuscode | Incident | StatusCode
IncidentResolveBySLAStatus | Incident | ResolveBySLAStatus
IncidentSeverityCode | Incident | SeverityCode
initialcommunication | Lead Opportunity | InitialCommunication
invoice_statuscode | Invoice | StatusCode
InvoiceDetailInvoiceStateCode | InvoiceDetail | InvoiceStateCode
InvoiceDetailShipTo_FreightTermsCode | InvoiceDetail | ShipTo_FreightTermsCode
InvoicePaymentTermsCode | Invoice | PaymentTermsCode
InvoicePriorityCode | Invoice | PriorityCode
InvoiceShippingMethodCode | Invoice | ShippingMethodCode
InvoiceShipTo_FreightTermsCode | Invoice | ShipTo_FreightTermsCode
kbarticle_statuscode | KbArticle | StatusCode
lead_salesstage | Lead Opportunity | SalesStage
lead_statuscode | Lead | StatusCode
LeadAddress1_AddressTypeCode | Lead | Address1_AddressTypeCode
LeadAddress1_ShippingMethodCode | Lead | Address1_ShippingMethodCode
LeadAddress2_AddressTypeCode | Lead | Address2_AddressTypeCode
LeadAddress2_ShippingMethodCode | Lead | Address2_ShippingMethodCode
LeadIndustryCode | Lead | IndustryCode
LeadLeadQualityCode | Lead | LeadQualityCode
LeadLeadSourceCode | Lead | LeadSourceCode
LeadPreferredContactMethodCode | Lead | PreferredContactMethodCode
LeadPriorityCode | Lead | PriorityCode
LeadSalesStageCode | Lead | SalesStageCode
letter_statuscode | Letter | StatusCode
LetterPriorityCode | Letter | PriorityCode
list_statuscode | List | StatusCode
ListCreatedFromCode | List | CreatedFromCode
lookupmapping_statuscode | LookUpMapping | StatusCode
LookUpMappingLookUpSourceCode | LookUpMapping | LookUpSourceCode
LookUpMappingProcessCode | LookUpMapping | ProcessCode
MailboxACTDeliveryMethod | Mailbox | ACTDeliveryMethod
MailboxACTStatus | Mailbox | ACTStatus
MailboxEmailRouterAccessApproval | Mailbox | EmailRouterAccessApproval
MailboxIncomingEmailDeliveryMethod | Mailbox | IncomingEmailDeliveryMethod
MailboxIncomingEmailStatus | Mailbox | IncomingEmailStatus
MailboxOutgoingEmailDeliveryMethod | Mailbox | OutgoingEmailDeliveryMethod
MailboxOutgoingEmailStatus | Mailbox | OutgoingEmailStatus
mailbox_statuscode | Mailbox | StatusCode
mailmergetemplate_statuscode | MailMergeTemplate | StatusCode
MailMergeTemplateDocumentFormat | MailMergeTemplate | DocumentFormat
MailMergeTemplateMailMergeType | MailMergeTemplate | MailMergeType
metric_goaltype | Metric Goal | AmountDataType
metric_statuscode | Metric | StatusCode
msdyn_postalbum_statuscode | Msdyn_PostAlbum | StatusCode
msdyn_postconfig_statuscode | Msdyn_PostConfig | StatusCode
msdyn_postruleconfig_statuscode | Msdyn_PostRuleConfig | StatusCode
msdyn_wallsavedquery_statuscode | Msdyn_WallSavedQuery | StatusCode
msdyn_wallsavedqueryusersettings_statuscode | Msdyn_WallSavedQueryUserSettings | StatusCode
need | Lead Opportunity | StatusCode
opportunity_salesstage | Lead Opportunity | SalesStage
opportunity_statuscode | Opportunity | StatusCode
opportunityclose_statuscode | OpportunityClose | StatusCode
OpportunityOpportunityRatingCode | Opportunity | OpportunityRatingCode
OpportunityPriorityCode | Opportunity | PriorityCode
OpportunityProductOpportunityStateCode | OpportunityProduct | OpportunityStateCode
OpportunitySalesStageCode | Opportunity | SalesStageCode
OpportunityTimeLine | Opportunity | TimeLine
orderclose_statuscode | OrderClose | StatusCode
OrganizationCurrencyDisplayOption | Organization | CurrencyDisplayOption
OrganizationCurrencyFormatCode | Organization | CurrencyFormatCode
OrganizationDefaultRecurrenceEndRangeType | Organization | DefaultRecurrenceEndRangeType
OrganizationDiscountCalculationMethod | Organization | DiscountCalculationMethod
OrganizationEmailConnectionChannel | Organization | EmailConnectionChannel
OrganizationFiscalPeriodFormatPeriod | Organization | FiscalPeriodFormatPeriod
OrganizationFiscalYearFormatPrefix | Organization | FiscalYearFormatPrefix
OrganizationFiscalYearFormatSuffix | Organization | FiscalYearFormatSuffix
OrganizationFiscalYearFormatYear | Organization | FiscalYearFormatYear
OrganizationFullNameConventionCode | Organization | FullNameConventionCode
OrganizationISVIntegrationCode | Organization | ISVIntegrationCode
OrganizationNegativeFormatCode | Organization | NegativeFormatCode
OrganizationReportScriptErrors | Organization | ReportScriptErrors
OrganizationYammerPostMethod | Organization | YammerPostMethod
ownermapping_statuscode | OwnerMapping | StatusCode
OwnerMappingProcessCode | OwnerMapping | ProcessCode
phonecall_statuscode | PhoneCall | StatusCode
PhoneCallPriorityCode | PhoneCall | PriorityCode
picklistmapping_statuscode | PickListMapping | StatusCode
PickListMappingProcessCode | PickListMapping | ProcessCode
PluginAssemblyIsolationMode | PluginAssembly | IsolationMode
PluginAssemblySourceType | PluginAssembly | SourceType
position_statuscode | Position | StatusCode
PostSource | Post | Source
PostType | Post | Type
pricelevel_statuscode | PriceLevel | StatusCode
PriceLevelFreightTermsCode | PriceLevel | FreightTermsCode
PriceLevelPaymentMethodCode | PriceLevel | PaymentMethodCode
PriceLevelShippingMethodCode | PriceLevel | ShippingMethodCode
principalsyncattributemapping_syncdirection | PrincipalSyncAttributeMap | SyncDirection
processsession_statuscode | ProcessSession | StatusCode
processstage_category | ProcessStage | Category
ProcessTriggerControlType | ProcessTrigger | ControlType
ProcessTriggerScope | ProcessTrigger | Scope
product_statuscode | Product | StatusCode
productassociate_statuscode | ProductAssociation | StatusCode
ProductAssociationProductIsRequired | ProductAssociation | ProductIsRequired
ProductAssociationPropertyCustomizationStatus | ProductAssociation | PropertyCustomizationStatus
ProductPriceLevelPricingMethodCode | ProductPriceLevel | PricingMethodCode
ProductPriceLevelQuantitySellingCode | ProductPriceLevel | QuantitySellingCode
ProductPriceLevelRoundingOptionCode | ProductPriceLevel | RoundingOptionCode
ProductPriceLevelRoundingPolicyCode | ProductPriceLevel | RoundingPolicyCode
ProductProductStructure | Product | ProductStructure
ProductProductTypeCode | Product | ProductTypeCode
productsubstitute_statuscode | ProductSubstitute | StatusCode
ProductSubstituteDirection | ProductSubstitute | Direction
ProductSubstituteSalesRelationshipType | ProductSubstitute | SalesRelationshipType
PublisherAddress1_AddressTypeCode | Publisher | Address1_AddressTypeCode
PublisherAddress1_ShippingMethodCode | Publisher | Address1_ShippingMethodCode
PublisherAddress2_AddressTypeCode | Publisher | Address2_AddressTypeCode
PublisherAddress2_ShippingMethodCode | Publisher | Address2_ShippingMethodCode
PublisherAddressAddressTypeCode | PublisherAddress | AddressTypeCode
PublisherAddressFreightTermsCode | PublisherAddress | FreightTermsCode
PublisherAddressShippingMethodCode | PublisherAddress | ShippingMethodCode
purchaseprocess | Lead Opportunity | PurchaseProcess
purchasetimeframe | Lead Opportunity | PurchaseTimeframe
qooi_pricingerrorcode | Invoice InvoiceDetail Opportunity OpportunityProduct Quote QuoteDetail SalesOrder SalesOrderDetail | PricingErrorCode
qooiproduct_producttype |  |
qooiproduct_propertiesconfigurationstatus |  |
queue_statuscode | Queue | StatusCode
QueueEmailRouterAccessApproval | Queue | EmailRouterAccessApproval
QueueIncomingEmailDeliveryMethod | Queue | IncomingEmailDeliveryMethod
QueueIncomingEmailFilteringMethod | Queue | IncomingEmailFilteringMethod
queueitem_statuscode | QueueItem | StatusCode
QueueItemObjectTypeCode | QueueItem | ObjectTypeCode
QueueOutgoingEmailDeliveryMethod | Queue | OutgoingEmailDeliveryMethod
QueueQueueTypeCode | Queue | QueueTypeCode
QueueQueueViewType | Queue | QueueViewType
quote_statuscode | Quote | StatusCode
quoteclose_statuscode | QuoteClose | StatusCode
QuoteDetailQuoteStateCode | QuoteDetail | StateCode
QuoteDetailShipTo_FreightTermsCode | QuoteDetail | ShipTo_FreightTermsCode
QuoteFreightTermsCode | Quote | FreightTermsCode
QuotePaymentTermsCode | Quote | PaymentTermsCode
QuoteShippingMethodCode | Quote | ShippingMethodCode
QuoteShipTo_FreightTermsCode | Quote | ShipTo_FreightTermsCode
recurrencerule_monthofyear | RecurrenceRule | MonthOfYear
RecurrenceRuleInstance | RecurrenceRule | Instance
RecurrenceRulePatternEndType | RecurrenceRule | PatternEndType
RecurrenceRuleRecurrencePatternType | RecurrenceRule | RecurrencePatternType
recurringappointmentmaster_statuscode | RecurringAppointmentMaster | StatusCode
RecurringAppointmentMasterExpansionStateCode | RecurringAppointmentMaster | ExpansionStateCode
RecurringAppointmentMasterInstance | RecurringAppointmentMaster | Instance
RecurringAppointmentMasterInstanceTypeCode | RecurringAppointmentMaster | InstanceTypeCode
RecurringAppointmentMasterPatternEndType | RecurringAppointmentMaster | PatternEndType
RecurringAppointmentMasterPriorityCode | RecurringAppointmentMaster | PriorityCode
RecurringAppointmentMasterRecurrencePatternType | RecurringAppointmentMaster | RecurrencePatternType
relationshiprole_statuscode | RelationshipRole | StatusCode
ReportCategoryCategoryCode | ReportCategory | CategoryCode
ReportLinkLinkTypeCode | ReportLink | LinkTypeCode
ReportReportTypeCode | Report | ReportTypeCode
ReportVisibilityVisibilityCode | ReportVisibility | VisibilityCode
routingrule_statuscode | RoutingRule | StatusCode
SalesLiteratureItemFileTypeCode | SalesLiteratureItem | FileTypeCode
SalesLiteratureLiteratureTypeCode | SalesLiterature | LiteratureTypeCode
salesorder_statuscode | SalesOrder | StatusCode
SalesOrderDetailSalesOrderStateCode | SalesOrderDetail | SalesOrderStateCode
SalesOrderDetailShipTo_FreightTermsCode | SalesOrderDetail | ShipTo_FreightTermsCode
SalesOrderFreightTermsCode | SalesOrder | FreightTermsCode
SalesOrderPaymentTermsCode | SalesOrder | PaymentTermsCode
SalesOrderPriorityCode | SalesOrder | PriorityCode
SalesOrderShippingMethodCode | SalesOrder | ShippingMethodCode
SalesOrderShipTo_FreightTermsCode | SalesOrder | ShipTo_FreightTermsCode
savedquery_statuscode | SavedQuery | StatusCode
sdkmessageprocessingstep_statuscode | SdkMessageProcessingStep | StatusCode
SdkMessageProcessingStepImageImageType | SdkMessageProcessingStepImage | ImageType
SdkMessageProcessingStepInvocationSource | SdkMessageProcessingStep | SdkMessageProcessingStepInvocationSource
SdkMessageProcessingStepMode | SdkMessageProcessingStep | SdkMessageProcessingStepMode
SdkMessageProcessingStepStage | SdkMessageProcessingStep | SdkMessageProcessingStepStage
SdkMessageProcessingStepSupportedDeployment | SdkMessageProcessingStep | SdkMessageProcessingStepSupportedDeployment
service_initialstatuscode | Service | InitialStatusCode
serviceappointment_statuscode | ServiceAppointment | StatusCode
ServiceAppointmentPriorityCode | ServiceAppointment | PriorityCode
ServiceEndpointConnectionMode | ServiceEndpoint | ConnectionMode
ServiceEndpointContract | ServiceEndpoint | Contract
ServiceEndpointUserClaim | ServiceEndpoint | UserClaim
servicestage | Incident | ServiceStage
sharepoint_validationstatus | SharePointSite | StateCode
sharepoint_validationstatusreason | SharePointSite | StatusCode
sharepointdocumentlocation_statuscode | SharepointDocumentLocation | StatusCode
sharepointsite_statuscode | SharepointSite | StatusCode
SiteAddress1_AddressTypeCode | Site | Address1_AddressTypeCode
SiteAddress1_ShippingMethodCode | Site | Address1_ShippingMethodCode
SiteAddress2_AddressTypeCode | Site | Address2_AddressTypeCode
SiteAddress2_ShippingMethodCode | Site | Address2_ShippingMethodCode
sla_statuscode | SLA | StatusCode
SLAApplicableFromPickList | SLA | ApplicableFrom
SLAKPIInstanceStatus | SLAKPIInstance | Status
SLAKPIInstanceWarningTimeReached | SLAKPIInstance | WarningTimeReached
SLAObjectTypeCode | SLA | ObjectTypeCode
SLASLAType | SLA | SLAType
socialactivity_postmessagetype | SocialActivity | PostMessageType
socialactivity_statuscode | SocialActivity | StatusCode
SocialActivityPriorityCode | SocialActivity | PriorityCode
SocialInsightsConfigurationFormTypeCode | SocialInsightsConfiguration |
SocialInsightsConfigurationSocialDataItemType | SocialInsightsConfiguration | SocialDataItemType
socialprofile_community | SocialProfile | Community
socialprofile_statuscode | SocialProfile | StatusCode
syncattributemapping_syncdirection | SyncAttributeMapping | SyncDirection
SystemFormActivationState | SystemForm | FormActivationState
SystemFormPresentation | SystemForm | FormPresentation
SystemFormType | SystemForm | Type
SystemUserAccessMode | SystemUser | AccessMode
SystemUserAddress1_AddressTypeCode | SystemUser | Address1_AddressTypeCode
SystemUserAddress1_ShippingMethodCode | SystemUser | Address1_ShippingMethodCode
SystemUserAddress2_AddressTypeCode | SystemUser | Address2_AddressTypeCode
SystemUserAddress2_ShippingMethodCode | SystemUser | Address2_ShippingMethodCode
SystemUserCALType | SystemUser | CALType
SystemUserEmailRouterAccessApproval | SystemUser | EmailRouterAccessApproval
SystemUserIncomingEmailDeliveryMethod | SystemUser | IncomingEmailDeliveryMethod
SystemUserInviteStatusCode | SystemUser | InviteStatusCode
SystemUserOutgoingEmailDeliveryMethod | SystemUser | OutgoingEmailDeliveryMethod
SystemUserPreferredAddressCode | SystemUser | PreferredAddressCode
SystemUserPreferredEmailCode | SystemUser | PreferredEmailCode
SystemUserPreferredPhoneCode | SystemUser | PreferredPhoneCode
task_statuscode | Task | StatusCode
TaskPriorityCode | Task | PriorityCode
TeamTeamType | Team | TeamType
TraceLogLevel | TraceLog | Level
transactioncurrency_statuscode | TransactionCurrency | StatusCode
transformationmapping_statuscode | TransformationMapping | StatusCode
TransformationMappingProcessCode | TransformationMapping | ProcessCode
TransformationParameterMappingDataTypeCode | TransformationParameterMapping | DataTypeCode
TransformationParameterMappingParameterTypeCode | TransformationParameterMapping | ParameterTypeCode
uomschedule_statuscode | UoMSchedule | StatusCode
UserFormType | UserForm | Type
userquery_statuscode | UserQuery | StatusCode
UserSettingsDataValidationModeForExportToExcel | UserSettings | DataValidationModeForExportToExcel
UserSettingsEntityFormMode | UserSettings | EntityFormMode
UserSettingsIncomingEmailFilteringMethod | UserSettings | IncomingEmailFilteringMethod
UserSettingsReportScriptErrors | UserSettings | ReportScriptErrors
UserSettingsVisualizationPaneLayout | UserSettings | VisualizationPaneLayout
WebResourceWebResourceType | WebResource | WebResourceType
workflow_statuscode | Workflow | StatusCode
WorkflowCategory | Workflow | Category
WorkflowDependencyType | WorkflowDependency | Type
workflowlog_objecttypecode | WorkflowLog |
WorkflowMode | Workflow | Mode
WorkflowLogStatus | WorkflowLog | Status
workflow_runas | Workflow | RunAs
WorkflowScope | Workflow | Scope
workflow_stage | Workflow | CreateStage DeleteStage UpdateStage
WorkflowType | Workflow | Type

See Also

Tasks

Run a simple program using Microsoft Dynamics CRM web services

Reference

Sample Extension to Generate Enumerations for Option Sets

Concepts

Use the sample and helper code
Global option set metadata values

Other Resources

Helper code: ServerConnection class
Helper code: DeviceIdManager class
Helper code: SystemUserProvider class

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Best practices for developing with Microsoft Dynamics CRM

This topic describes best practices for customizing Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

In This Topic

Performance best practices

Customization best practices

Security best practices

ISV Extensibility best practices

Performance best practices

The following best practices can help you write code that performs better.

Use multiple threads

Add threading support to your application to break up the work across multiple CPUs. This suggestion assumes that you are running your code on a multiprocessor system. More information: NET Framework Advanced Development Guide article on Managed Threading.

Allow the system to create GUIDs

Allow the system to automatically assign the GUID (Id) for you instead of manually creating it yourself. This suggestion allows Microsoft Dynamics CRM to take advantage of sequential GUIDs, which provide better SQL performance. The following sample code shows how to call the Create method to obtain a system-assigned GUID.

Copy Code
// Instantiate an account object.Account account = new Account { Name = "Fourth Coffee" };
// Create an account record named Fourth Coffee and retrieve the GUID.accountId = serviceProxy.Create(account);

Use early-bound types

Use the Entity class when your code must work on entities and attributes that aren’t known at the time the code is written. In addition, if your custom code works with thousands of entity records, use of the Entity class results in slightly better performance than the early-bound entity types. However, this flexibility has a disadvantage because you cannot verify entity and attribute names at compile time. If your entities are already defined at code time and slight performance degradation is acceptable, you should use the early-bound types that you can generate by using the CrmSvcUtil tool. More information: Use the early bound entity classes in code

Disable plug-ins

If possible, disable registered plug-ins before you run your application.

Write plug-ins that execute faster

Always write a plug-in that takes the least time to perform its intended task. For example, the Execute method is frequently processed in Microsoft Dynamics CRM. If you register a plug-in on that message, your plug-in can have a significant performance impact on the system because it executes every time that the Execute method is processed, which frequently occurs.

If you intend to register your plug-ins for synchronous execution, we recommend that you design them to complete their operation in less than 10 seconds. It’s best to minimize processing time in plug-ins to maintain interactivity of the client applications that are connected to the same organization service that executes the plug-in.

Limit the data you retrieve

When you use the methods that retrieve data from the server, retrieve the minimum amount of data that your application needs. You do this by specifying the column set, which is the set of entity attributes to retrieve. For example, it is rarely a good idea to retrieve all the metadata with the RetrieveAllEntitiesRequest message, specifying the EntityFilters.All entity filter for the EntityFilters property. Instead, you might achieve better performance if you restrict the entity filter, or use one of the following messages: RetrieveEntityRequest, RetrieveOptionSetRequest, RetrieveAttributeRequest, or RetrieveRelationshipRequest.

Limit operations that cascade to related entities

When you use the Update method or UpdateRequest message, do not set the OwnerId attribute on a record unless the owner has actually changed. When you set this attribute, the changes often cascade to related entities, which increases the time that is required for the update operation. More information: Cascading behavior

Adjust proxy settings on the client (on-premises only)

A proxy server sits between a client application, such as a web browser, and the actual target server. When a computer is in a LAN, it can use a proxy server to connect to the Internet. In this case, the proxy server is combined with, or is a part of, the gateway server and firewall server. The proxy can cache web requests and serve multiple client requests by using its cached data. If the requested data is not present in the cache of the proxy server, it forwards the request to the actual server by using its own IP address. Here, the proxy server acts on behalf of the client computer.

Although a proxy server can act as a cache server and can help load a webpage faster, it can sometimes decrease performance if it is used incorrectly. Frequently, people avoid manual proxy configuration and use automatic proxy configuration. This shortcut helps in load balancing the proxy servers, but depending on the complexity of the configuration script, a significant delay can be experienced when you use automatic proxy configuration.

When the Microsoft Dynamics CRM server is installed, you can bypass the proxy server to achieve better throughput. The server offers a local web address that requires no proxy to be reached. You can select Bypass proxy server for local addresses and provide the fully qualified domain name of the Microsoft Dynamics CRM server in the exceptions list. This gives better throughput when records are created by using the Microsoft Dynamics CRM SDK.

Improve service channel allocation performance

You can establish a connection to the Microsoft Dynamics CRM web services and authenticate users by using the OrganizationServiceProxy and DiscoveryServiceProxy service proxy classes. However, improper use of these service proxy classes can sometimes reduce application performance. Therefore, if you understand when and how to use the different client classes that are available in the SDK, you can often obtain better application performance.

When you establish a Windows Communication Foundation (WCF) service channel by using a service endpoint, for example, by using the organization web service, your application must perform two time consuming operations: metadata download from the endpoint and user authentication. You can improve performance if your application performs these operations a minimum number of times for each application session. The OrganizationServiceProxy constructor shown here performs both these operations any time a service proxy object is created.

Copy Code
OrganizationServiceProxy (Uri uri, Uri homeRealmUri, ClientCredentials clientCredentials, ClientCredentials deviceCredentials)

You typically obtain better performance if your application uses this constructor to create an instance of the service proxy by using this constructor one time during the application session and cache the returned reference for use in different code paths within your application. Notice that the returned service reference is not thread safe so multi-threaded applications will need to allocate one instance per thread. Applications must also call Dispose on the service proxy object before they terminate in order to free service channel allocated resources.

The service proxy class performs the metadata download and user authentication by using the following class methods.

Copy Code
IServiceManagement<IOrganizationService> orgServiceManagement = ServiceConfigurationFactory.CreateManagement<IOrganizationService>(new Uri(organizationUrl))AuthenticationCredentials authCredentials = orgServiceManagement.Authenticate(credentials)

The CreateManagement method performs the metadata download while the Authenticate method authenticates the user. The returned objects from these methods are thread safe and can be statically cached by your application. You can then use these objects to construct a service proxy object that uses one of the other available constructors.

Copy Code
OrganizationServiceProxy (orgServiceManagement, authCredentials.ClientCredentials)OrganizationServiceProxy (orgServiceManagement, authCredentials.SecurityTokenResponse)

By caching the service management and authenticated credential objects, your application can more efficiently construct the service proxy objects more than one time per application session. If you enable early-bound types on OrganizationServiceProxy through one of the EnableProxyTypes methods, you must do the same on all service proxies that are created from the cached IServiceManagement`1 object. If your application uses the metadata, we recommend that it caches the metadata that it retrieves and periodically calls the RetrieveTimestampRequest message to determine whether it must refresh the cache.

In addition, monitor your WCF security token (Token) and refresh it before it expires so that you do not lose the token and have to start over with authentication. To check the token, create a custom class that inherits from the OrganizationServiceProxy or DiscoveryServiceProxy class and that implements the business logic to check the token. Or wrap the proxy classes in a new class. Another technique is to explicitly check the token before each call to the web service. Example code that demonstrates these techniques can be found in the ManagedTokenDiscoveryServiceProxy, ManagedTokenOrganizationServiceProxy, and AutoRefreshSecurityToken classes in the Helper code: ServerConnection class topic.

Customization best practices

The following best practices can help you customize and extend Microsoft Dynamics CRM.

Using custom entities and attributes

Save space on your server by using these techniques:

  • Create custom attributes for existing entities instead of creating a new entity.
  • Rename existing entities to make the entities more meaningful.

When should you customize an entity?

Customize a system entity, such as the opportunity entity, instead of replacing it with a new custom entity so that you can use the many built-in features in an existing entity. For example, the opportunity and case entities have lookup fields to associate customers. Customers may be accounts or contacts. You cannot create a custom entity that has the same type of lookup. You can change the display name of a system entity to make it more meaningful to your business.

When to use plug-ins vs. workflow?

As a developer who is interested in extending or customizing Microsoft Dynamics CRM, you can choose from several methods to perform your tasks. In addition to adding client-side JavaScript code to a form or adding custom ASP.NET pages, you can write a plug-in or create a custom workflow by using the web interface that calls a custom workflow activity. How do you decide when to use a plug-in and when to use a workflow? The technology that you use depends on the task that you have to perform and who will author the customization.

For example, you must use a synchronous plug-in real-time workflow if you want to execute custom code immediately before or after the core platform operation executes and before the result of the operation is returned from the platform. You cannot use an asynchronous workflow or asynchronous plug-in in this situation because they are queued to execute after the core operation finishes executing. Therefore, you cannot predict when they will run. If you want to add custom functionality to Microsoft Dynamics CRM Online, workflows and plug-ins are supported, but custom workflow activities are not.

Evaluate these technologies and choose the one that best suits your business objectives after you consider the deployment, performance, and maintenance concerns of your plug-in or workflow solution.

The following table summarizes the characteristics of plug-ins and workflows.

Criteria Plug-in Workflow

Execution before or after the core platform operation (Create, Update, Delete, and so on)

Executes immediately before or after the core operation (synchronous).

Can also be queued to execute after the core operation (asynchronous).

Asynchronous workflows are queued to execute after the core operation.

Real-time workflows have similar characteristics to plug-ins.

Performance impact on the server

Synchronous plug-ins can increase the platform response time because they are part of the main platform processing.

Asynchronous plug-ins have less impact on server response time because the code is run in a different process.

Asynchronous workflows have less impact on server response time because the code is run in a different process.

Real-time workflows have similar performance characteristics to sandboxed plug-ins.

Security restrictions

To register a plug-in with the platform requires a System Administrator or System Customizer security role and membership in the Deployment Administrator group.

Users can interactively create workflows in the web application.

However, to register a custom workflow activity, the deploying user must have the same security roles as those required for registering plug-ins.

Microsoft Dynamics CRM version (SKU) support

Supported in Microsoft Dynamics CRM Online when registered in the sandbox. May be supported in partner-hosted installations at the discretion of the partner.

Workflows are supported by all CRM deployments. Custom workflow activities are supported in the sandbox of Microsoft Dynamics CRM Online, and in or outside the sandbox for on-premises/IFD deployments.

Length of processing time

A plug-in registered for synchronous or asynchronous execution is restricted to complete its execution in a two-minute time limit.

Works well for either short or long processes. However, each activity in a workflow cannot take longer than two minutes to complete.

Works when the CRM for Outlook client is offline

Both online and offline are supported.

Workflows do not execute when offline.

Process and data persistence

Plug-ins execute until they are completed. Plug-ins must be written to be stateless where no in-memory data is persisted.

Asynchronous workflows can be paused, postponed, canceled, and resumed through SDK calls or by the user through the web application. The state of the workflow is automatically saved before it is paused or postponed.

Real-time workflows cannot have any wait states. They must execute to completion just like plug-ins.

Impersonation

Plug-ins can perform data operations on behalf of another system user.

Asynchronous workflows cannot use impersonation, while real-time workflows can. Real-time workflows can execute either as the owner of the workflow or as the calling user.

Authoring

Software engineers or programmers can author plug-ins.

Anyone, including an end user, business analyst, or administrator can author workflows if they have the proper permissions.

There is no significant performance impact on the server between an asynchronous plug-in and a workflow.

What type of workflow Is better?

From a performance perspective, is it better to create a single long workflow or is it better to have multiple child workflows and call them in one parent workflow? The child workflow approach achieves lower throughput, but it is more manageable if you frequently change your workflow definition. Compilation overhead is not a major concern because the workflow is compiled only during publishing. However, Microsoft Dynamics CRM incurs overhead when it starts each workflow instance. The overhead occurs when all entities that are used in the workflow are retrieved and the child workflow is started in a two-step process that includes a 'Workflow Expansion Task' and the actual workflow instance. Therefore, for maximum throughput, use a single long workflow.

How should you mark your custom workflow activity as completed?

The return value from the Execute method is used by the workflow runtime to mark the activity as “completed.” You should use return base.Execute(executionContext) unless the activity bypasses base class functionality. Avoid returning ActivityExecutionStatus.Closed. More information: ActivityExecutionStatus Enumeration

How should you report exceptions in custom workflow activities?

You should throw an InvalidPlugInExecutionException in your code. This error will be shown in the workflow instance form.

Can you define custom entities that are specific to business units?

Custom entities have privileges for each security role but not for each business unit. To define custom entities that are visible only to specified business units, you must create different security roles for each business unit and grant privileges to the custom entity in the appropriate role.

Security best practices

Follow these guidelines to help protect your business data.

General

Best practices for securing your implementation of Microsoft Dynamics CRM include the following:

  • Establish an approved security data plan for your organization's Microsoft Dynamics CRM implementation.
  • Assign the least privileges required when you set up your application pool.
  • Require that all users use strong passwords for their accounts. For more information, search for “strong passwords” in Windows Help.
  • Divide your organization into business units that match the organizational structure when you set up Microsoft Dynamics CRM. You can then restrict access based on roles.

More information: Security Considerations for Microsoft Dynamics CRM

Roles, privileges, and access rights

Best practices for use of the Microsoft Dynamics CRM security model include the following:

  • Strictly limit the number of people assigned the System Administrator role. Never remove this role.
  • Create roles according to the security best practice of least privilege, providing access to the minimum amount of business data required for the task. Assign users the appropriate role for their job.
  • Create a new role with those specific privileges and add the user to the new role if a user needs additional access levels or rights. A user's rights are the union of all the roles to which he or she has been assigned. Do not grant the original role privileges that are needed by only one or several members.
  • Use sharing, when appropriate, to give specific users specific rights on individual objects, instead of broader privileges on all objects of a given type.
  • Use teams to create cross-functional groups so that specific objects can be shared with the team.
  • Train users who have sharing access rights to share the minimum information needed.

Avoid elevation of privilege

Elevation of privilege attacks occur when a user can assume the privileges of a trusted account, such as an owner or administrator. Always run under least-privileged user accounts and assign only needed permissions. Avoid using administrative or owner accounts for executing code. This limits the amount of damage that can occur if an attack succeeds. When performing tasks that require additional permissions, use procedure signing or impersonation only for the duration of the task.

Server-side development

Best practices for developing server-side code for Microsoft Dynamics CRM include the following:

  • Do not modify the Microsoft Dynamics CRM database by any means other than using the SDK because this bypasses the Microsoft Dynamics CRM security model.
  • Plug-ins are running in an administrator's context – you should know that this code may access information that the logged-on user does not have access to.
  • For workflow assemblies, and plug-ins, avoid writing code that takes a long time to execute. It is important that plug-in code that is registered to execute synchronously returns as quickly as possible.
  • If you are replicating Microsoft Dynamics CRM data in your own data store, you are responsible for the security of the data. If you use a plug-in to transmit the data, make sure that you register the plug-in to execute after the core platform operation. Security privilege checks for the logged-on user occur during the core platform operation.
  • Data that comes out of Microsoft Dynamics CRM might not be safe for rendering. Data may have been injected with HTML tags that are not secure.
  • Adhere to the requirement of not accessing Microsoft Dynamics CRM databases directly through SQL Server Enterprise Manager. Bypassing the SDK can open you up to SQL injection threats.
  • For Internet facing deployments, remember that your solution is only as secure as the weakest link. After your application is exposed to the Internet, it is open to security threats.
  • Use only languages that produce managed code for the best security from buffer overruns, exceptions, and so on.

For more information about security, see the following topics:

  • .NET Framework Developer's Guide, Securing Applications
  • Secure Coding Guidelines for the .NET Framework
  • ASP.NET Security

Client-side development

Best practices for developing customizations for the CRM web application and Microsoft Dynamics CRM for Microsoft Office Outlook include the following:

  • Use web resources instead of pages that require server-side processing whenever possible. If your requirements can only be achieved by using server-side processing, adhere to the requirement that your custom webpages are installed in a separate website from Microsoft Dynamics CRM. Set the trust level for your site appropriately, depending on your confidence level in the security of your code. This reduces the threat from cross-site scripting and other threats.
  • For improved security, make sure that your separate website runs on a different account from Microsoft Dynamics CRM. This account should have the minimum access possible and one that does not have direct access to the Microsoft databases. You can use a complex password that doesn’t expire because no person signs in to this account – only in to your application.
  • Avoid use of ActiveX controls because they have known security problems.
  • Be aware of the limitations of client scripting. More information: Write code for Microsoft Dynamics CRM forms
  • Use plug-ins to apply business logic regardless of how the data changes are made.
  • Always use a modal confirmation dialog box when you delete records or apply sensitive changes, such as adding a new user to a security role. This helps prevent techniques such as click-jacking or UI redressing where a malicious developer may embed your page in a seemingly innocuous page to trick a user into performing actions that may compromise security or perform unwanted actions on data.

Security best practices for your website include the following:

  • Don’t use anonymous access.
  • Use integrated Windows authentication, NTLM, or Basic authentication over Secure Sockets Layer (SSL).
  • Use SSL to avoid sending unencrypted data over the network if your website is on a different computer than Microsoft Dynamics CRM.

For more information, see the following:

  • Overview of Web Application Security Threats
  • Microsoft Anti-Cross Site Scripting Library V4.2
  • ASP.NET Web Application Security
  • Introduction to Web Application Security

ISV extensibility best practices

One of the key tenets of ISV extensibility is that you should not assume that your ISV solution is the only one installed. The following is a list of best practices to follow.

Best practices for using the Microsoft Dynamics CRM web services

You should put the Microsoft Dynamics CRM web service URLs into a configuration file, for example, into an app.config file, so that your code is isolated from changes to the URL. For example, there are different URLs for the three Microsoft Dynamics CRM Online data centers throughout the world.

Where should you put plug-ins and custom workflow activities?

For on-disk plug-ins or custom workflow activities, place the assemblies in the <installdir>\Server\bin\assembly folder.

Where should you put your custom web applications or webpages?

Refer to the topic Implement single sign-on from an ASPX webpage or IFRAME.

How do you execute a plug-in when the web application’s grid view is updated?

Register the plug-in on the RetrieveMultipleRequest message request and do not specify any entity type during the registration.

When should you create a new website?

Create a new website for your code when any of the following applies:

  • Your application must be bound to a domain, protocol, or port that is different from the Microsoft Dynamics CRM application; or must run in a different application pool.
  • Your application can exist and be accessed on its own. For example, a portal that interacts with Microsoft Dynamics CRM as the server (by using web services) should be hosted as a new website.
  • Your application always uses Active Directory or integrated Windows authentication (not IFD) and cross-domain scripting is not an issue. For example, your application interacts with a back end by using web services and interacts with Microsoft Dynamics CRM forms. A page hosted in an IFRAME that is enclosed in Microsoft Dynamics CRM application that does not interact with the Microsoft Dynamics CRM form falls into this category.

See Also

Concepts

Set bit flags
Write code for Microsoft Dynamics CRM forms

Other Resources

Write applications and server extensions
Write plug-ins to extend business processes
Custom workflow activities (workflow assemblies)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Set bit flags

Bit-level manipulation is a common practice to conserve space in programs. Eight Yes/No, On/Off bits of data may be stored in a single byte instead of using up 8 bytes. The AccessMask property is an example of this kind.

Example

The following example shows how to turn on or off the specified display flag for an attribute.

C# Copy Code
//Turn flag on
    _currentAccessRights |= AccessRights.ReadAccess;
//Turn flag off
    _currentAccessRights &= ~AccessRights.ReadAccess;

// Test to see if flag is set
If (_currentAccessRights.HasFlag(AccessRights.ShareAccess))
    // Flag is set.

See Also

Concepts

Best practices for developing with Microsoft Dynamics CRM

Other Resources

Blog: A Quick Bitmask How to for Programmers
AccessMask

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Build Windows client applications using the XRM tools

XRM tooling is a set of new APIs built on top of the Microsoft Dynamics CRM APIs that provide support for building Windows client applications for Microsoft Dynamics CRM. It provides the following capabilities:

  • Supports all the authentication modes to sign in to CRM, except OAuth.
  • Provides Windows PowerShell support for authentication and connection to CRM.
  • Provides thread safety for actions performed in CRM in a multithreaded environment. More information: Multithreading in Components, Thread-Safe Components
  • Provides a common Windows Presentation Foundation (WPF) (WPF) login control for CRM for consistent sign-in experience to CRM from your Windows client applications.
  • Supports secure storage of the sign-in credentials and reuse of the stored credentials to automatically sign in to CRM after initial sign in.
  • Provides built-in diagnostic tracing and performance reporting of the actions performed in CRM, which you can configure based on your organization’s requirements.

Components of XRM tooling

XRM tooling has the following three components:

  • Interface for CRM APIs: This provides the low-level interaction and wrapper methods for the CRM APIs. It is an instrumented API that provides a thread safe environment for making calls to Microsoft Dynamics CRM with built-in diagnostic capabilities to help you determine the performance of individual calls. It also provides a standard set of trace listeners for debugging support. The namespace for this component is Microsoft.Xrm.Tooling.Connector.
  • Common login control: This is a WPF user control that provides a common user interface for the sign in experience to Microsoft Dynamics CRM. The login control supports all the authentication modes, except OAuth. The common login control has built-in encryption for securely storing your credentials/profile, and then reusing it at runtime to automatically sign in to CRM. The namespace for this component is Microsoft.Xrm.Tooling.CrmConnectControl.
  • Web resource utility: This provides support for accessing information from the following two types of web resources in CRM: Image and XML. You can access an image from a CRM web resource and return it as WPF BitmapImage objects. Similarly, you can return an XML web resource as a string. The namespace for this component is Microsoft.Xrm.Tooling.WebResourceUtility.

Client applications that use XRM tooling

The following applications in the current version of CRM use the common WPF login control for authenticating users while signing in to CRM from the client application:

  • Unified Service Desk for Microsoft Dynamics CRM. More information: Unified Service Desk Developer Guide
  • Package Deployer tool. More information: Deploy packages using CRM Package Deployer and Windows PowerShell
  • Configuration Migration tool. More information: Manage your configuration data

In This Section

Use XRM tooling to connect to CRM

Use PowerShell cmdlets for XRM tooling to connect to CRM

Use XRM tooling to execute actions in CRM

Use XRM tooling with classes generated by using the code-generation tool

Use the XRM tooling common login control in your client applications

Configure tracing for XRM tooling

See Also

Other Resources

Sample: Quick start for XRM Tooling API
Write applications and server extensions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use XRM tooling to connect to CRM

To connect to Microsoft Dynamics CRM, you create an instance of the CrmServiceClient class, and then use one of the constructors to connect. Each method call by an object of this class is considered an atomic unit of work, and all the calls to Microsoft Dynamics CRM are thread safe.

In this topic

Connect to CRM using OrganizationServiceProxy

Connect to CRM Online (Live ID)

Connect to CRM Online (Office 365)

Connect to CRM on-premises (Active Directory)

Connect to CRM Internet-facing deployment (IFD)

Connect to CRM (Claims-based)

Optional parameters for all the constructors

Determine your connection status

Connect to CRM using OrganizationServiceProxy

Use the following constructor to connect to CRM using the user-provided OrganizationServiceProxy instance.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(<orgServiceproxy>);

Connect to CRM Online (Live ID)

Use the following constructor.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient("<LiveID>", "<Password>", "<CRMonlineRegion>", "<OrgName>");

Valid values for the <CRMonlineRegion> parameter are: NorthAmerica, EMEA, and APAC. If you set this to String.Empty, it will search servers in all the regions for the CRM organization. For the <OrgName> parameter, you can specify either the unique or friendly name.

Connect to CRM Online (Office 365)

Use the following constructor.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient("<UserName>", "<Password>", "<CRMonlineRegion>", "<OrgName>", isOffice365:true);

Valid values for the <CRMonlineRegion> parameter are: NorthAmerica, EMEA, and APAC. If you set this to String.Empty, it will search servers in all the regions for the CRM organization. For the <OrgName> parameter, you can specify either the unique or friendly name.

Connect to CRM on-premises (Active Directory)

Use the following constructor.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", “<Domain>”),"<Server>", "<Port>", "<OrgName>");

This will run an Active Directory authentication based on the specified domain. For the <Server> parameter, specify the host name of your CRM server; for example: crmtest. For the <OrgName> parameter, you can specify either the unique or friendly name.

Connect to CRM Internet-facing deployment (IFD)

Use the following constructor.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", “<Domain>”), AuthenticationType.IFD, "<Server>", "<Port>", "<OrgName>");

This method will run a claims-based authentication based on the specified local domain. This is useful for customers that use AD FS, and have configured their CRM server as claims, where the user population lives in the same AD FS domain as the CRM server. For the <Server> parameter, specify the host name of your CRM server; for example: crmtest. For the <OrgName> parameter, you can specify either the unique or friendly name.

Connect to CRM (Claims-based)

Use the following constructor.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", “<Domain>”, "<HomeRealm>"),"<Server>", "<Port>", "<OrgName>");

This method will run a claims-based authentication against the specified Home realm. This is useful for customers that use AD FS, and have configured their CRM server as claims, where the user population lives in the same AD FS domain as the CRM server. For the <Server> parameter, specify the host name of your CRM server; for example: crmtest. For the <OrgName> parameter, you can specify either the unique or friendly name.

Optional parameters for all the constructors

These are the optional parameters that you can use with each of the constructors shown previously.

  • useUniqueInstance: Indicates whether to reuse an existing connection if recalled while the connection is still active. Default is false. If set to true, this will force the system to create a unique connection.
  • useSSL: Indicates whether to use SSL to connect to CRM. Defaults to false, that is, use http://. If set to true, it will use https://.
  • orgDetail: Defaults to null. If set, this is returned from a query to the Discovery service, and is generally used as the second leg of an organization selection process.

Determine your connection status

To determine if the connection request was successful, check the value of the CrmServiceClient.IsReady property. If true, the connection is successful, and you are ready to work. Otherwise, check the values of the CrmServiceClient. LastCrmError and CrmServiceClient.LastCrmException properties for the cause of the connection failure.

See Also

Concepts

Use PowerShell cmdlets for XRM tooling to connect to CRM
Use XRM tooling to execute actions in CRM
Build Windows client applications using the XRM tools

Other Resources

Sample: Quick start for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use PowerShell cmdlets for XRM tooling to connect to CRM

XRM tooling provides you with the following Windows PowerShell cmdlets that you can use to connect to Microsoft Dynamics CRM and retrieve organizations that the current user has access to: Get-CrmConnection and Get-CrmOrganizations.

In This Topic

Prerequisites

Register the cmdlets

Use the cmdlet to retrieve organizations from your CRM server

Use the cmdlet to connect to CRM

Prerequisites

  • To use the XRM tooling cmdlets, you need a version of PowerShell that is no earlier than version 3.0. To check the version, open a PowerShell window and run the following command: $Host
  • Set the execution policy to run the signed PowerShell scripts. To do so, open a PowerShell window as an administrator and run the following command: Set-ExecutionPolicy -ExecutionPolicy AllSigned

Register the cmdlets

Before you can use the PowerShell cmdlets, you have to register them.

  1. Download the Microsoft Dynamics CRM SDK package. Run the package file to extract the contents of the package. The PowerShell assembly (Microsoft.Xrm.Tooling.CrmConnector.Powershell.dll) and the script (RegisterXRMTooling.ps1) for registering the cmdlets are located in the \SDK\bin folder in the SDK.

  2. Start Windows PowerShell on your computer with elevated privileges (run as administrator).

  3. At the prompt, change your directory to the folder that contains the PowerShell dll file and the script for registering the cmdlets. For example:

    Copy Code
    cd c:\SDK\bin

  4. Run the RegisterXRMTooling.ps1 script to register the XRM tooling PowerShell assembly, and install the Windows PowerShell snap-in. Type the following command, and press ENTER:

    Copy Code
    .\RegisterXRMTooling.ps1

  5. Add the Windows PowerShell snap-in. This registers the Get-CrmConnection and Get-CrmOrganizations cmdlets.

    Copy Code
    Add-PSSnapin Microsoft.Xrm.Tooling.Connector

You’re now ready to use these Windows PowerShell cmdlets. To list the cmdlets that you registered, run the following command in the Windows PowerShell window:

Copy Code
Get-Help “Crm”

Use the cmdlet to retrieve organizations from CRM

Use the Get-CrmOrganizations cmdlet to retrieve the organizations that you have access to.

  1. Provide your credentials to connect to your Microsoft Dynamics CRM (on-premises) or Microsoft Dynamics CRM Online instance. Running the following command will prompt you to type your user name and password to connect to the CRM instance, and it will be stored in the $Cred variable.

    Copy Code
    $Cred = Get-Credential

  2. Use the following command to retrieve your organizations, and store the information in the $CRMOrgs variable:

    • If you’re connecting to the Microsoft Dynamics CRM (on-premises) server:
      Copy Code
      $CRMOrgs = Get-CrmOrganizations –ServerUrl http://<CRM_Server_Host> –Credential $Cred
    • If you’re connecting to the Microsoft Dynamics CRM Online instance:
      Copy Code
      $CRMOrgs = Get-CrmOrganizations -Credential $Cred -DeploymentRegion NorthAmerica –OnlineType Office365
      Note
      For the DeploymentRegion parameter, valid values are NorthAmerica, EMEA, and APAC. For the OnlineType parameter, valid values are Office365 and LiveID.

    • If you’re connecting to the CRM server using the claims-based authentication against the specified Home realm:
      Copy Code
      $CRMOrgs = Get-CrmOrganizations –ServerUrl http://<CRM_Server_Host> –Credential $Cred –HomRealmURL http://<Identity_Provider_Address>

  3. Your supplied credentials are validated when you run the command in step 2. On successful execution of the command, type the following command, and press ENTER to display the organizations that you have access to:

    Copy Code
    $CRMOrgs

    List of organizations returned by the cmdlet
    Tip
    You can use the variable that was used to store the retrieved CRM organizations (in this case $CRMOrgs) with the Get-CrmConnection cmdlet to connect to CRM. To specify the org name, use the following command: $CRMOrgs.UniqueName.

    If there is more than one organization value stored in the $CRMOrgs variable, you can refer to the nth organization using the following command: $CRMOrgs[n-1]. For example, to refer to the unique name of the third organization in the $CRMOrgs variable (”MyOrg”), use the following command: $CRMOrgs[2].UniqueName. More information: Accessing Values in an Array

Use the cmdlet to connect to CRM

Use the Get-CrmConnection cmdlet to connect to a CRM instance. The cmdlet lets you either use the XRM tooling common login control to specify your credentials and connect to CRM or lets you specify your credentials as inline parameters. More information: Use the XRM tooling common login control in your client applications

Connect to CRM using the common login control

  1. If you want to use the common login control to provide your credentials to connect to CRM, use the following command. The connection information is stored in the $CRMConn variable so that you can use it later.

    Copy Code
    $CRMConn = Get-CrmConnection -InteractiveMode

  2. The LoginControl dialog box appears. Provide your credentials to connect to your CRM instance, and click Login.

Connect to CRM by specifying credentials inline

  1. To connect to CRM, use the following commands. Note that these commands use the $Cred variable created earlier to store the credential while retrieving the organizations. The connection information is stored in the $CRMConn variable:

    • If you’re connecting to the Microsoft Dynamics CRM (on-premises) server:
      Copy Code
      $CRMConn = Get-CrmConnection –ServerUrl http://<CRM_Server_Host> -Credential $Cred -OrganizationName <OrgName>
    • If you’re connecting to the Microsoft Dynamics CRM Online instance:
      Copy Code
      $CRMConn = Get-CrmConnection -Credential $Cred -DeploymentRegion <Deployment region name> –OnlineType <Online type name> –OrganizationName <OrgName>
      Note
      For the DeploymentRegion parameter, valid values are NorthAmerica, EMEA, and APAC. For the OnlineType parameter, valid values are Office365 and LiveID.

    • If you’re connecting to the CRM server using the claims-based authentication against the specified Home realm:
      Copy Code
      $CRMConn = Get-CrmConnection –ServerUrl http://<CRM_Server_Host> -Credential $Cred -OrganizationName <OrgName> –HomRealmURL http://<Identity_Provider_Address>
    Note
    For the OrganizationName parameter in all the preceding commands, you can either specify the organization unique name or friendly name. You can also use the organization unique name or friendly name that you retrieved using the Get-CrmOrganizations cmdlet and stored in the $CRMOrgs variable. For example, you can use $CRMOrgs[x].UniqueName or $CRMOrgs[x].FriendlyName.

  2. Your supplied credentials are validated when you run the command in step 2. On successful execution of the cmdlet, type the following command, and press ENTER to display the connection information and status:

    Copy Code
    $CRMConn

    CRM connection information and status

See Also

Concepts

Use XRM tooling to connect to CRM
Build Windows client applications using the XRM tools

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use XRM tooling to execute actions in CRM

After you are connected to Microsoft Dynamics CRM, you can use the CrmServiceClient class object to perform actions on your CRM data such as create, update, retrieve or delete data. This section provides some examples on how you can perform actions in Microsoft Dynamics CRM using XRM tooling.

In This Section

Use XRM tooling to create data

Use XRM tooling to retrieve data

Use XRM tooling to update data

Use XRM tooling to delete data

Use messages (request and response classes) with the ExecuteCrmOrganizationRequest method

See Also

Concepts

Use XRM tooling to connect to CRM
Build Windows client applications using the XRM tools

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use XRM tooling to create data

There are seven methods available in the CrmServiceClient class for creating new data and associations. A create action using the XRM tooling API requires a data payload. The data payload takes the form of a Dictionary<string, CrmDataTypeWrapper> object. CrmDataTypeWrapper is used to inform the interface what sort of handling needs to be applied to the data point you are referencing. Some of the methods for creating data are listed in this topic.

CreateNewRecord

This method is used to create any type of entity data in Microsoft Dynamics CRM. To use it, you need to know the schema name of the entity you want to create a record in, and must construct a data payload to pass to it. This example creates an account record.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>",“<Domain>”),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you’re connected to.
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    // Create an account record
    Dictionary<string, CrmDataTypeWrapper> inData = new Dictionary<string, CrmDataTypeWrapper>();
    inData.Add("name", new CrmDataTypeWrapper("Sample Account Name", CrmFieldType.String));
    inData.Add("address1_city", new CrmDataTypeWrapper("Redmond", CrmFieldType.String));
    inData.Add("telephone1", new CrmDataTypeWrapper("555-0160", CrmFieldType.String));
    accountId = ctrl.CrmConnectionMgr.CrmSvc.CreateNewRecord("account", inData);

    // Verify if the account is created.
    if (accountId != Guid.Empty)
    {
        Console.WriteLine(“Account created.”);
    }
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

In this example, we created a data payload object called indata. Next, we populated it using the general syntax: crmFieldName , new CrmDataTypeWrapper(data,CrmFieldType). After setting up the indata object to get the values to create, we called CreateNewRecord method providing the entity logical name for the account and the data payload (indata).

Note
You can also create an entity record using XRM tooling by executing the CreateRequest message with the ExecuteCrmOrganizationRequest method. More information: Use messages (request and response classes) with the ExecuteCrmOrganizationRequest method

CreateAnnotation

This method is used to create and attach a note object to any entity record. While you can populate all the variables for the note in the first pass, you only need to provide subject and note text fields. In practice, this is generally used to attach system-generated notes to an entity, or to attach files that are stored in CRM to an entity. Additionally, if you provide your own UI for creating notes for your user, this is how you would attach that note to the owner entity in CRM. This example continues from the prior example to create a note on the newly created account.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", “<Domain>”),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected.
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you are connected to.
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    // Create and attach a note.
    inData.Clear();
    inData.Add("subject", new CrmDataTypeWrapper("This is a NOTE from the API" , CrmFieldType.String));
    inData.Add("notetext", new CrmDataTypeWrapper("This is text that will go in the body of the note" , CrmFieldType.String));
    Guid noteID = crmSvc.CreateAnnotation("account", accountId, inData);
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

See Also

Concepts

Use XRM tooling to execute actions in CRM

Other Resources

Sample: Quick start for XRM Tooling API

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use XRM tooling to retrieve data

There are many methods available in the CrmServiceClient class for retrieving data in Microsoft Dynamics CRM. The following examples demonstrate how you can retrieve a record by ID or FetchXML query.

GetEntityDataById

This method searches for an entity by the specified ID. In this sample, we specify null for the field list value to fetch all the attributes of the specified entity record (account), and then display the name of the retrieved account record.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", “<Domain>”),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected.
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you are connected to
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    Dictionary<string, object> data = crmSvc.GetEntityDataById("account", <Account_ID>, null);
    foreach (var pair in data)
    {
        if (pair.Key == "name")
        {
            Console.WriteLine("Name of the account is {0}", pair.Value);
        }
    }
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

GetEntityDataByFetchSearchEC

This method searches for the entity based on the specified FetchXML query. In this sample, we retrieve and display the count of all account records in the system.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", “<Domain>”),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected.
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you are connected to
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    string fetchXML =
        @"<fetch version='1.0' output-format='xml-platform' mapping='logical' distinct='false' returntotalrecordcount='true' >
            <entity name='account'>
              <attribute name='accountid' />
            </entity>
        </fetch>";
    var queryResult = crmSvc.GetEntityDataByFetchSearchEC(fetchXML);
    if (queryResult != null)
    {
        Console.WriteLine(String.Format("Account Records Count : {0}", queryResult.TotalRecordCount));
    }
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

See Also

Concepts

Use XRM tooling to connect to CRM
Use XRM tooling to execute actions in CRM

Other Resources

Sample: Quick start for XRM Tooling API

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use XRM tooling to update data

There are two methods available in the CrmServiceClient class for updating data in Microsoft Dynamics CRM: UpdateEntity and UpdateStateAndStatusForEntity.

An update action using XRM Tooling API requires a data payload. The data payload takes the form of a Dictionary<string, CrmDataTypeWrapper> object. CrmDataTypeWrapper is used to inform the interface what sort of handling needs to be applied to the data point you are referencing.

UpdateEntity

This is the anchor method for updating any record in CRM, with the exception of setting status or state of a record. To use it, you need to know the following information: schema name of the entity you want to update, the primary key field of the entity you want to update, the GUID of the record you want to update, and finally the data payload array to update it with.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", “<Domain>”),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you are connected to
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    // Update the account record
    Dictionary<string, CrmDataTypeWrapper> updateData = new Dictionary<string, CrmDataTypeWrapper>();
    updateData.Add("name", new CrmDataTypeWrapper("Updated Sample Account Name", CrmFieldType.String));
    updateData.Add("address1_city", new CrmDataTypeWrapper("Boston", CrmFieldType.String));
    updateData.Add("telephone1", new CrmDataTypeWrapper("555-0161", CrmFieldType.String));
    bool updateAccountStatus = crmSvc.UpdateEntity("account","accountid",_accountId,updateData);

    // Validate if the account record was updated successfully, and then display the updated information
    if (updateAccountStatus == true)
    {
        Console.WriteLine("Updated the account details as follows:");
        Dictionary<string, object> data = crmSvc.GetEntityDataById("account", accountId, null);
        foreach (var pair in data)
        {
            if ((pair.Key == "name") || (pair.Key == "address1_city") || (pair.Key == "telephone1"))
            {
                Console.WriteLine(pair.Key.ToUpper() + ": " + pair.Value);
            }
        }
    }
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

UpdateStateAndStatusForEntity

This method is used to set the state of a record in CRM. For example, all records generally start in an “open” state. The name of the state changes based on the kind of record, or even the developers choices. A quote, for example, has several possible status and states, Draft, Active, Close, Lost, Won.

Tip
You can use the OptionSets.cs file in the SDK\SampleCode\CS\HelperCode folder of the SDK download package to view and use the global option sets available for various entities in CRM. For more information about global option sets, see Customize global option sets.

Updating the state of an entity requires that you know what the target state and status are, either by the names or IDs. Both the names and the IDs can be found by querying the metadata for the entity and looking at the status and state fields. In this example, we will demonstrate how to set the status of an account record to Inactive.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", “<Domain>”),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you are connected to
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    // Here are the state and status code values
    // statecode = 1 ( Inactive )
    // statuscode = 2 ( Inactive )

    crmSvc.UpdateStateAndStatusForEntity("account" , accountId , 1 , 2 );

    // the same command using the second form of the method
    crmSvc.UpdateStateAndStatusForEntity("account" , accountId , "Inactive" , "Inactive");
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

See Also

Concepts

Use XRM tooling to connect to CRM
Use XRM tooling to execute actions in CRM
Work with attribute metadata

Other Resources

Sample: Quick start for XRM Tooling API

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use XRM tooling to delete data

There are two methods available in the CrmServiceClient class for deleting data in Microsoft Dynamics CRM: DeleteEntity and DeleteEntityAssociation.

DeleteEntity

DeleteEntity is used to remove a single row of data from CRM. To use this method, you need to know the entity schema name you wish to affect, and the GUID of the row you want to remove.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", <Domain>),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you are connected to
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    // Delete the entity record
    crmSvc.DeleteEntity("account", <accountId>);
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

DeleteEntityAssociation

DeleteEntityAssociation removes the many-to-many association between records in entities. In this example, we will remove the association between a record in the lead and account entities.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", <Domain>),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected
if (crmSvc != null && crmSvc.IsReady)
{
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    Guid accountId = new Guid("<Account_GUID>");
    Guid leadId = new Guid("<Lead_GUID>");
    string accountLeadRelationshipName= "accountleads_association";
    crmSvc.DeleteEntityAssociation("account" , accountId, "lead" ,  leadId, accountLeadRelationshipName)
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

See Also

Concepts

Use XRM tooling to connect to CRM
Use XRM tooling to execute actions in CRM

Other Resources

Sample: Quick start for XRM Tooling API

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use messages (request and response classes) with the ExecuteCrmOrganizationRequest method

In addition to using the IOrganizationService.Execute method, you can now use the CrmServiceClient.ExecuteCrmOrganizationRequest method to execute the xRM and CRM messages. Similar to the Execute method, the ExecuteCrmOrganizationRequest method takes a message request class as a parameter and returns a message response class. For a list of messages that you can execute using the CrmServiceClient.ExecuteCrmOrganizationRequest method, see xRM messages in the Organization service and CRM messages in the organization service.

The following code samples demonstrate how you can execute messages using the ExecuteCrmOrganizationRequest method.

Example 1: CreateRequest message

The following code sample demonstrates how to execute the CreateRequest message using the CrmServiceClient.ExecuteCrmOrganizationRequest method. In this example, you create an account, and then display the ID in the response object.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", "<Domain>"),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected.
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you are connected to.
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    CreateRequest request = new CreateRequest();
    Entity newAccount = new Entity("account");
    newAccount.Attributes.Add("name", "Sample Test Account");
    request.Target = newAccount;
    CreateResponse response = (CreateResponse)crmSvc.ExecuteCrmOrganizationRequest(request);

    // Display the ID of the newly created account record.
    Console.WriteLine("Account record created with the following ID: {0}", response.id.ToString());
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

Example 2: RetrieveMultipleRequest

The following code sample demonstrates how to execute the RetrieveMultipleRequest message using the CrmServiceClient.ExecuteCrmOrganizationRequest method. In this example, you execute a retrieve multiple request to fetch all the contacts in the system, and display their full name.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>", "<Domain>"),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected.
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you are connected to.
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    QueryExpression userSettingsQuery = new QueryExpression("contact");
    userSettingsQuery.ColumnSet.AllColumns = true;
    var retrieveRequest = new RetrieveMultipleRequest()
    {
        Query = userSettingsQuery
    };
    EntityCollection EntCol = (crmSvc.ExecuteCrmOrganizationRequest(retrieveRequest) as RetrieveMultipleResponse).EntityCollection;
    foreach (var a in EntCol.Entities)
    {
        Console.WriteLine("Account name: {0} {1}", a.Attributes["firstname"], a.Attributes["lastname"]);
    }
}
else
{
    // Display the last error.
    Console.WriteLine("An error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

See Also

Concepts

Use messages (request and response classes) with the Execute method
Use XRM tooling to connect to CRM
Use XRM tooling to execute actions in CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use XRM tooling with classes generated by using the code-generation tool

The Microsoft.Xrm.Tooling.Connector assembly doesn’t directly provide interfaces for the entity and data context classes generated using the code-generation tool. However, you can use the Microsoft Dynamics CRM connection created by the CrmServiceClient class to set up your entity and data context classes by using the code-generation tool. More information: Generate code with the code generation tool extensions

To use the CRM connection created by the CrmServiceClient class, create a connection to CRM by using an instance of this class, and then set the value of the OrganizationServiceProxy object to the CrmServiceClient.OrganizationServiceProxy property.

Copy Code
CrmServiceClient crmSvc = new CrmServiceClient(new System.Net.NetworkCredential("<UserName>", "<Password>",“<Domain>”),"<Server>", "<Port>", "<OrgName>");

// Verify that you are connected.
if (crmSvc != null && crmSvc.IsReady)
{
    //Display the CRM version number and org name that you are connected to
    Console.WriteLine("Connected to CRM! (Version: {0}; Org: {1}",
    crmSvc.ConnectedOrgVersion, crmSvc.ConnectedOrgUniqueName);

    Microsoft.Xrm.Sdk.Client.OrganizationServiceProxy prox = crmSvc.OrganizationServiceProxy;
}
else
{
    // Display the last error.
    Console.WriteLine("Error occurred: {0}", crmSvc.LastCrmError);

    // Display the last exception message if any.
    Console.WriteLine(crmSvc.LastCrmException.Message);
    Console.WriteLine(crmSvc.LastCrmException.Source);
    Console.WriteLine(crmSvc.LastCrmException.StackTrace);

    return;
}

Note
The OrganizationServiceProxy class isn’t thread safe. While working with the entity and data context classes generated by using the code-generation tool or using .NET Language-Integrated Query (LINQ) to retrieve data, you might consider creating a locking scheme in your code if it runs in a multithreaded environment.

See Also

Concepts

Build Windows client applications using the XRM tools

Other Resources

Use the IOrganizationService web service to read and write data or metadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the XRM tooling common login control in your client applications

The Microsoft Dynamics CRM SDK provides you with a template for Microsoft Visual Studio that enables you to use the common login control in your client applications. The code for CRM authentication, credential storage and retrieval, and diagnostic logging is built into the template so that you can quickly leverage these capabilities in your Windows client applications for CRM. The common login control is an implementation of the Microsoft.Xrm.Tooling.CrmConnectControl, and the control resembles the following image.

XRM Tooling common login control

In This Topic

Prerequisites

Create a WPF application using the common login control template

Add the common login control template to your existing WPF application

Prerequisites

  • .NET Framework 4.5.2
  • Microsoft Visual Studio 2012 or Visual Studio 2013
  • Nuget Package Manager for Visual Studio 2012 or Visual Studio 2013
  • Microsoft Dynamics CRM SDK templates for Visual Studio that contains the common login control template. You can get it in one of the following ways:
    • Download the CRM SDK template from Visual Studio gallery, and double-click the CRMSDKTemplates.vsix file to install the template in Visual Studio.
    • Download and extract the CRM SDK package. The templates file, CRMSDKTemplates.vsix, is located in the SDK\Templates folder. Double-click the CRMSDKTemplates.vsix file to install the template in Visual Studio.

Create a WPF application using the common login control template

Here is a quick way to create a Windows Presentation Foundation (WPF) application that leverages the common login control and the underlying code for authentication, credential storage and reuse, and default tracing or logging.

  1. Start Microsoft Visual Studio, and create a new project.

  2. In the New Project dialog box:

    1. From the list of installed templates, expand Visual C#, and select CRM SDK Templates.
    2. Ensure that .NET Framework 4.5.2 is selected.
    3. Select WPF Application for CRM.
    4. Specify the name and location of the project, and click OK.
    WPF Application for CRM template

  3. To test the project:

    1. Save the project and press F5 or click Debug > Start Debugging to verify if the project compiles successfully. On successful compilation, you’ll see a MainWindow with Login to CRM button. Click the button to display the common login control.
    2. Test the authentication by providing your credentials to connect to CRM, and then click Login. A message displays your CRM connection status.

For a sample that uses the common login control template to connect to CRM and perform various operations, see Sample: Quick start for XRM Tooling API.

Note
The WPF Application for CRM template uses the Microsoft.Xrm.Tooling.Ui.Styles.dll file instead of the Microsoft.Xrm.Tooling.Ui.Resources.dll file to provide XAML resources to the common login control. The Microsoft.Xrm.Tooling.Ui.Resources.dll file is deprecated in the current release, and the Microsoft.Xrm.Tooling.Ui.Styles.dll file provides the same capabilities as Microsoft.Xrm.Tooling.Ui.Resources.dll.

Add the common login control template to your existing WPF application

If you already have a WPF client application, you can easily add the common login control template to it to leverage the uniform sign-in experience and the underlying code for CRM authentication, credential storage and reuse, and default tracing or logging. In this case, you must create a control in the user interface of your existing client application to call the common login control, instantiate an instance of the CRM connection object, and then use the connection object to perform various operations in CRM.

  1. Open an existing WPF application project in Visual Studio. For this example, let’s assume that the name of your WPF application project is SampleWPFApp.

  2. Add the common login control template to your project.

    1. In the Solution Explorer pane, right-click the project name, and click Add > New Item.
    2. In the Add New Item dialog box, from the list of installed templates, expand Visual C#, and select CRM SDK Templates. Click CRM Login Form for WPF Applications, and click OK.
      Add the common login control template

  3. The newly added CrmLoginForm1.xaml login control is displayed in the XAML designer area. If it doesn’t, double-click the CrmLoginForm1.xaml file in the Solution Explorer pane.

    Verify that the login control renders properly

  4. You must now call the newly added login control from your application. To do this, add a Button control on your MainWindow.xaml file, and set the name and content to btnSignIn and Sign in to CRM respectively.

    Add a control to call the login form

  5. Double-click the button to add code for the click event of the btnSignIn button in the MainWindow.xaml.cs file.

  6. Add the following sample code in the click event of the btnSignIn button to call the CrmLoginForm1 control, and create an instance of the CRM connection object.

    Copy Code
    // Establish the Login control.
CRMLoginForm1 ctrl = new CRMLoginForm1();

// Wire event to login response.
ctrl.ConnectionToCrmCompleted += ctrl_ConnectionToCrmCompleted;

// Show the login control.
ctrl.ShowDialog();

// Handle the returned CRM connection object.
// On successful connection, display the CRM version and connected org name
if (ctrl.CrmConnectionMgr != null && ctrl.CrmConnectionMgr.CrmSvc != null && ctrl.CrmConnectionMgr.CrmSvc.IsReady)
{
    MessageBox.Show("Connected to CRM! Version: " + ctrl.CrmConnectionMgr.CrmSvc.ConnectedOrgVersion.ToString() +
    " Org: " + ctrl.CrmConnectionMgr.CrmSvc.ConnectedOrgUniqueName, "Connection Status");

    // Perform your actions here
}
else
{
    MessageBox.Show("Cannot connect; try again!", "Connection Status");
}

  7. Add the definition of the ctrl_ConnectionToCrmCompleted event below the click event of the button:

    Copy Code
    private void ctrl_ConnectionToCrmCompleted(object sender, EventArgs e)
{
    if (sender is CRMLoginForm1)
    {
        this.Dispatcher.Invoke(() =>
        {
            ((CRMLoginForm1)sender).Close();
        });
    }
}

  8. This is how your MainWindow.xaml.cs file appears after adding code from the previous two steps:

  9. To test the project:

    1. Save the project and press F5 or click Debug > Start Debugging to verify if the project compiles successfully. On successful compilation, you will see a MainWindow with the new Sign In to CRM button. Click it to display the common login control.
    2. Test the authentication by providing your credentials to connect to CRM, and then click Login. If successful, a message appears stating the version and the organization name that you are connected to. Click OK to close the message.
      Project test results
    3. If you click Sign In to CRM again, the application prompts you to either choose the saved credentials from the last sign-in activity, or to re-enter the new credentials.
      Stored credentials

See Also

Concepts

Build Windows client applications using the XRM tools

Other Resources

Sample: Quick start for XRM Tooling API

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Configure tracing for XRM tooling

You can enable tracing to record data related to process milestones across all components of XRM tooling, such as operation calls, warnings, exceptions, and other significant events. This information can be used for troubleshooting operational and performance issues in your Windows client applications. Tracing in XRM tooling is built on top of System.Tracing. To enable tracing for an assembly or component, for example Microsoft.Xrm.Tooling.Connector, you must define the following three things for each component in your code or in the application configuration file (<AppName>.exe.config):

  • A trace source
  • A trace listener
  • A trace level other than Off. These are the other values that you can specify: Error, Warning, Info, and Verbose.

Here is the configuration for enabling tracing for a component in XRM tooling. For example, the following configuration only enables tracing for the Microsoft.Xrm.Tooling.CrmConnectControl component:

Copy Code
</configuration>
  <system.diagnostics>
    <trace autoflush="true" />
    <sources>
      <source name="DynamicsCrm.CrmConnectControl"
        switchName="DynamicsCrm.CrmConnectControl"
        switchType="System.Diagnostics.SourceSwitch">
        <listeners>
          <add name="console" type="System.Diagnostics.DefaultTraceListener" />
          <remove name="Default"/>
          <add name ="fileListener"/>
        </listeners>
      </source>
    </sources>
    <switches>
      <!--
            Possible values for switches: Off, Error, Warning, Info, Verbose
                Verbose:    includes Error, Warning, Info, Trace levels
                Info:       includes Error, Warning, Info levels
                Warning:    includes Error, Warning levels
                Error:      includes Error level
        -->
      <add name="DynamicsCrm.CrmConnectControl" value="Verbose"/>
    </switches>
    <sharedListeners>
      <add name="fileListener" type="System.Diagnostics.TextWriterTraceListener" initializeData="XRMLoginControl.log"/>
      <add name="eventLogListener" type="System.Diagnostics.EventLogTraceListener" initializeData="XRMLogin"/>
    </sharedListeners>
  </system.diagnostics>
</configuration>

If you want to enable tracing for all of the components in XRM tooling, you can do that as well. Here is the configuration for a combined tracing of all three of the components in XRM tooling:

Copy Code
<configuration>
  <system.diagnostics>
    <trace autoflush="true" />
    <sources>
      <source name="Microsoft.Xrm.Tooling.Connector.CrmServiceClient"
              switchName="Microsoft.Xrm.Tooling.Connector.CrmServiceClient"
              switchType="System.Diagnostics.SourceSwitch">
        <listeners>
          <add name="console" type="System.Diagnostics.DefaultTraceListener" />
          <remove name="Default"/>
          <add name ="fileListener"/>
        </listeners>
      </source>

      <source name="Microsoft.Xrm.Tooling.CrmConnectControl"
              switchName="Microsoft.Xrm.Tooling.CrmConnectControl"
              switchType="System.Diagnostics.SourceSwitch">
        <listeners>
          <add name="console" type="System.Diagnostics.DefaultTraceListener" />
          <remove name="Default"/>
          <add name ="fileListener"/>
        </listeners>
      </source>

      <source name="Microsoft.Xrm.Tooling.WebResourceUtility"
        switchName="Microsoft.Xrm.Tooling.WebResourceUtility"
        switchType="System.Diagnostics.SourceSwitch">
        <listeners>
          <add name="console" type="System.Diagnostics.DefaultTraceListener" />
          <remove name="Default"/>
          <add name ="fileListener"/>
        </listeners>
      </source>
    </sources>
    <switches>
      <!--
            Possible values for switches: Off, Error, Warning, Info, Verbose
                Verbose:    includes Error, Warning, Info, Trace levels
                Info:       includes Error, Warning, Info levels
                Warning:    includes Error, Warning levels
                Error:      includes Error level
        -->
      <add name="Microsoft.Xrm.Tooling.Connector.CrmServiceClient" value="Verbose" />
      <add name="Microsoft.Xrm.Tooling.CrmConnectControl" value="Verbose"/>
      <add name="Microsoft.Xrm.Tooling.WebResourceUtility" value="Verbose" />

    </switches>
    <sharedListeners>
      <add name="fileListener" type="System.Diagnostics.TextWriterTraceListener" initializeData="XRMToolingLogs.log"/>
      <add name="eventLogListener" type="System.Diagnostics.EventLogTraceListener" initializeData="XRMTooling" />
    </sharedListeners>

  </system.diagnostics>
</configuration>

See Also

Concepts

Build Windows client applications using the XRM tools

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write client application extensions

This section contains information about changes developers and customizers can make to extend Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. These changes range from adding event handlers to form elements using JavaScript libraries to adding your own user interface elements using web resources with the OData or Modern App SOAP endpoints.

In This Section

Use JavaScript with Microsoft Dynamics CRM

Use web service data in web resources (OData and Modern app SOAP endpoint)

Write code for Microsoft Dynamics CRM forms

Open forms, views, dialogs and reports with a URL

Web resources for Microsoft Dynamics CRM

JavaScript libraries for Microsoft Dynamics CRM

Client-side programming reference

Related Sections

Write plug-ins to extend business processes

Write workflows to automate business processes

Developers guide to reports for Microsoft Dynamics CRM

Manage your data

Customize entity forms

Change application navigation using the SiteMap

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use JavaScript with Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update provide many opportunities to use JavaScript. All JavaScript used in Microsoft Dynamics CRM is added by creating JScript web resources. This topic has information for developers who use JavaScript and includes links to relevant topics in the Microsoft Dynamics CRM SDK and other sources.

In This Topic

Areas where you can use JavaScript in Microsoft Dynamics CRM

Use of jQuery

Write JavaScript for multiple browsers

Data access using JavaScript

JavaScript programming best practices

Debugging JavaScript in Microsoft Dynamics CRM

Areas where you can use JavaScript in Microsoft Dynamics CRM

You can use JavaScript to perform actions in form scripts, command bar (ribbon) commands, and web resources.

Form scripts

The most common use of JavaScript in Microsoft Dynamics CRM is to add functions as event handlers for entity form events. For more information, see Write code for Microsoft Dynamics CRM forms.

Command bar (ribbon) commands

When you customize the Microsoft Dynamics CRM command bar, you can configure commands for controls that you add. These commands contain rules that control whether the control is enabled and what action is performed when the control is used. For more information, see Customize commands and the ribbon.

Web resources

Microsoft Dynamics CRM provides an organization-owned entity that stores a binary representation of a file that can be accessed by using a URL. This file is called a web resource. There are several types of web resources. A web resource that represents a JavaScript library is called a JScript web resource. You can use a webpage (HTML) web resource to provide a user interface with JavaScript libraries included just as you would for files on a web server. Because these files are part of Microsoft Dynamics CRM, users who access them are already authenticated. Therefore, you can use Microsoft Dynamics CRM web services without having to write code to authenticate the user. For more information, see Web resources for Microsoft Dynamics CRM.

Use of jQuery

Use jQuery with HTML web resources

We recommend that you use jQuery together with HTML web resources to provide user interfaces because it is an excellent cross-browser library.

With HTML web resources, you control the libraries that are present and there is no restriction against manipulating the DOM. Feel free to use jQuery within your HTML Web resources.

Avoid using jQuery with form scripts or ribbon commands

We do not recommend using jQuery in form scripts and ribbon commands.

Most of the benefit provided by jQuery is that it allows for easy cross-browser manipulation of the DOM. This is explicitly unsupported within form scripts and ribbon commands. Restrict your scripts to use the Xrm.Page and Xrm.Utility libraries available in form scripts and ribbon commands. If you decide to use the remaining capabilities of jQuery that are useful with Microsoft Dynamics CRM and include the ability to use $.ajax, consider the following:

  • For best performance, don’t load jQuery in the page if you do not need it
  • Using $.ajax to perform requests against the OData and Modern Apps SOAP endpoint is supported, but there are alternatives. The alternative to using $.ajax is to use the browsers XMLHttpRequest object directly. The jQuery $.ajax method is just a wrapper for this object. If you use the native XMLHttpRequest object directly, you do not need to load jQuery.
    Compare the SDK.REST.js and SDK.JQuery.js sample libraries found in Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript and Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript and jQuery. Both perform the same operations, but SDK.REST.js doesn’t require jQuery.
  • Each version of jQuery that is loaded in a page can be a different version. Different versions of jQuery have different behaviors and these can cause problems when multiple versions of jQuery are loaded on the same page. There is a technique to mitigate this, but it depends on editing the jQuery library and any other libraries that depend on jQuery. More information: jQuery and jQuery UI with Dynamics CRM 2011 & 2013, jQuery.noConflict()

Write JavaScript for multiple browsers

Because you don’t know what browser will be in use, you should make sure that any scripts that you use will work with all supported browsers. Most of the significant differences between Internet Explorer and other browser have to do with HTML and XML DOM manipulation. Because HTML DOM manipulation is not supported, if script logic is only performing supported actions and using the Xrm.Page API the changes required to support other browsers could be small. Use the Custom Code Validation Tool to identify code that only works for Internet Explorer.

A cross-browser library like jQuery is a good solution for developing web resources but should not be necessary for form scripts or ribbon commands. More information: Use of jQuery

Support for other browsers

Because Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update supports W3C standards, the application will be accessible using any modern browser and from any platform that supports those standards. However Microsoft Dynamics CRM will only be tested using a specific set of browsers and platforms. For the list of supported platforms and browsers see Supported web browsers.

If you use a browser, or browser version, that is not supported and you type just the server name or server name with organization as the URL, you will be redirected to the Microsoft Dynamics CRM for phones page. The CRM for phones pages can be expected to work properly on most browsers, such as browsers used in mobile devices, with limited functionality.

Control browser support for your organization or solution

Although creating public websites requires that you support most modern browsers, few public websites support all browsers that have ever existed. You need to establish what browsers you will support. To save development and testing costs, many business applications require that users use specific browsers.

If you are an ISV preparing solutions for any organization using Microsoft Dynamics CRM, you should expect that any organization could use one of the browsers that Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update will support. However, if you are preparing customizations only for an organization that requires that people use a specific browser, there is no reason to develop and test your customizations for browsers the organization doesn’t support.

Network administrators may use Software Restriction Policies and/or AppLocker to enforce which applications are allowed to run or be installed on a domain.

Parsing XML

There are many opportunities where you will need to parse XML using JavaScript. Be aware that there are significant differences in the way you can parse XML using Internet Explorer and other browsers. Internet Explorer uses Microsoft XML Core Services (MSXML) APIs to interact with XML document objects. These APIs include a number of extensions to the W3C DOM that are not available to other browsers. Following are two examples:

  • Two common methods used to extract data from an XML document using Internet Explorer are selectNodes and selectSingleNode. Both of these methods use an XPath expression as the parameter and return either a node or a node list. For other browsers, use the evaluate method when you want to use an XPath expression. Alternatively, you can refactor your code to navigate the document hierarchy and use the getElementsByTagNameNS method.
  • Internet Explorer uses the text property to access the text of an element. Other browsers use the textContent property.

There are a number of different ways you can address these differences. The approach you use depends on your preferences and the requirements of your code.

The SDK.MetaData.js library found in Sample: Retrieve entity metadata using JavaScript uses helper functions. This library uses the SOAP endpoint for web resources to retrieve entity and attribute metadata. This library depends on parsing data from the XML document returned as XMLHttpRequest.responseXML. In this library the following helper functions were added and used throughout the other functions in the library.

With these helper functions the existing code that was written only for Internet Explorer was updated as shown:

Original Internet Explorer Only Code | New Function to Support Multiple Browsers
node.selectNodes(XPathExpr); | SDK.MetaData._selectNodes(node,XpathExpr);
node.selectSingleNode(XPathExpr); | SDK.MetaData._selectSingleNode(node, XPathExpr);
node.selectSingleNode(ElementName).text; | SDK.MetaData._selectSingleNodeText(node, ElementName);
node.text | SDK.MetaData._getNodeText(node);

Data access using JavaScript

There are two web services you can use within the application to access data by using JavaScript.

OData (REST) endpoint

Previously known as the ‘REST endpoint for web resources’. You can use the OData endpoint to execute HTTP requests by using a web service that is based on a Uniform Resource Identifier (URI). “RESTful” web services are popular because they can make programming easier.

The current implementation of the OData endpoint is limited to create, retrieve, update and delete operations. The Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript includes an SDK.REST.js library that provides an example of a reusable library that can further simplify using the OData endpoint.

One of the advantages of the OData endpoint is that it implements the OData protocol, which provides the way to query and update data. When you use JavaScript, you usually retrieve objects in JavaScript Object Notation (JSON) format. This makes the results easier to work with. The primary limitation of the OData endpoint is that you cannot use the IOrganizationService.Execute method to execute messages (Request and Response classes). You use the SOAP endpoint for web resources to execute messages.

For more information, see Use the OData endpoint with web resources.

SOAP endpoint

The SOAP endpoint lets you execute messages because the REST endpoint does not yet allow this. You can also call the Create, Retrieve, Update, Delete and RetrieveMultiple methods of this web service, but using it is not as easy as using the REST endpoint.

Microsoft Dynamics CRM does not provide a JavaScript library to facilitate using the SOAP endpoint. When using the SOAP endpoint, you must post http requests that contain the XML defining the request and then parse the XML returned in the response.

The Sdk.Soap.js sample library and other related samples provide an example of a library that you can use with the SOAP endpoint.

The SDK provides a Microsoft Visual C# solution called SoapLogger that lets you capture the XML sent and received when you perform operations with the Microsoft Dynamics CRM web services by using Visual C#. With this information, you can build your own JavaScript libraries.

For more information, see Use the Modern app SOAP endpoint for modern applications with web resources.

JavaScript programming best practices

The following sections describe best practices when you use JavaScript with Microsoft Dynamics CRM.

Avoid using unsupported methods

On the Internet, you can find many examples or suggestions that describe using unsupported methods. These may include leveraging undocumented internal function for page controls. These methods may work but because they are not supported you can’t expect that they will continue to work in future versions of Microsoft Dynamics CRM.

Use the Custom Code Validation Tool to identify code that is using unsupported methods.

Use a cross-browser JavaScript library for HTML web resource user interfaces

A cross-browser JavaScript library, such as jQuery, provides many advantages when developing HTML web resources that must support multiple browsers. JavaScript libraries like jQuery provide a unified development experience for all browsers supported by Microsoft Dynamics CRM. These capabilities are appropriate when you are using HTML web resources to provide user interfaces. JavaScript libraries like jQuery provide consistent ways to interact with the Document Object Model (DOM).

Do not use jQuery for form script or commands

We do not recommend or support using jQuery for any pages within the application. This includes form scripts and ribbon commands. More information: Use of jQuery.

Recognize limitations for content delivery network (CDN) libraries

Content delivery network (CDN) JavaScript libraries provide many advantages for public websites. Because these libraries are hosted on the Internet, you do not need to create web resources that contain the content of the libraries. For Microsoft Dynamics CRM you should consider the following issues before you use a CDN JavaScript library.

  • Users of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client have the capability to work with no Internet connection while working offline. If you are depending on an Internet connection for your JavaScript libraries, your code will fail.
  • Some organizations will restrict Internet access for employees. Unless they configure the network to allow access to the CDN library sites, your code may fail for those organizations.

The alternative to using CDN libraries is to create a script (JavaScript) web resource with the contents of the library. Because web resources are organization-owned entities they will be synchronized when a Microsoft Dynamics CRM for Outlook with Offline Access user goes offline. Because these web resources now become part of the application they will not be blocked if an organization restricts access to the Internet.

Use feature detection when writing functions for multiple browsers

Even when you use a cross-browser library like jQuery, you need to be very aware of differences between browsers. You can generally detect which browser is being used by querying the navigator.useragent property. This is called browser detection. Browser detection is not a good strategy for most cases because it can’t take into account what features newer versions of a browser have. Also, some browsers provide the capability to modify the navigation.useragent property so that they appear to be a different browser.

Feature detection is the recommended approach. By detecting what features are available, you can create code paths for the browsers you support without knowing exactly which browser is being used. For more information about feature detection, see How to Detect Features Instead of Browsers.

Do not access the DOM

JavaScript developers are used to interacting with Document Object Model (DOM) elements in code. You might use the window.getElementById method or the jQuery library. You are free to use these techniques in your HTML web resources, but they are not supported to access elements in Microsoft Dynamics CRM application pages or entity forms. Instead, access to entity form elements are exposed through the Xrm.Page object model. The Microsoft Dynamics CRM development team reserves the right to change how pages are composed, including the ID values for elements, so using the Xrm.Page object model protects your code from changes in how pages are implemented. For more information, see Use the Xrm.Page object model.

Define unique names for your JavaScript functions

When you are the only developer for an HTML page you can easily manage the names of the JavaScript functions you use. In Microsoft Dynamics CRM, other solutions may add JavaScript functions to the page where your function is used.

If two JavaScript functions on a page have the same name, the first function defined is overwritten by the second. For this reason, make sure that you define unique names for your JavaScript functions. For more information, see Creating Script Libraries.

Use asynchronous data access methods

When you access data by using the Microsoft Dynamics CRM web services that use the REST or SOAP endpoint for web resources, always use an XMLHttpRequest that is configured to execute asynchronously. The reason is that the browser operates on a single thread. If that thread is being used to execute a long-running process synchronously the browser will stop responding.

Debugging JavaScript in Microsoft Dynamics CRM

Each browser provides some kind of debugging extension. Internet Explorer provides developer tools you can use to debug scripts in Microsoft Dynamics CRM. The Internet Explorer developer tools can be opened by pressing F12 when viewing a page using Internet Explorer. For more information, see Using the F12 developer tools.

For Google Chrome, press F12 to open developer tools. Firebug is a popular browser extension for web development using Mozilla Firefox. For Apple Safari, you must first choose the Show Develop menu in menu bar in Advanced Preferences. Then you can choose Show Web Inspector from the Develop menu.

You can also use Microsoft Visual Studio. For more information, see How to Debug JScript in Microsoft Dynamics CRM 2011.

When you use JavaScript libraries in Microsoft Dynamics CRM, your libraries are added to a page that includes many libraries. It can sometimes be difficult to isolate your specific library in the debugging environment. When using debugging tools in Internet Explorer, on the Script tab, expand the available scripts and find the one with the name that corresponds to the name of your JavaScript web resource, such as the new_debugging_example_script.js web resource shown below.

Debugging tools for different browsers have similar capabilities. Once you have found your library, you can set a break point and recreate the event that should cause your code to run.

Write messages to the console

Using the window.alert method when debugging JavaScript is still a common way to troubleshoot code in the application. But now that all modern browsers provide easy access to debugging tools, it is not a best practice, especially when others might be using the application you are debugging.

Consider writing your messages to the console instead. The following is a small function you can add to your libraries that you can use to send any messages you want to view to the console when it is open.

JavaScript Copy Code
function writeToConsole(message)
{
 if (typeof console != 'undefined') {
  console.log(message);
 }
}

Unlike using the alert method, if you forget to remove any code that uses this function, people using the application will not see your messages.

See Also

Concepts

Write code for Microsoft Dynamics CRM forms
Web resources for Microsoft Dynamics CRM
Use the OData endpoint with web resources
Use the Modern app SOAP endpoint for modern applications with web resources
Use the Xrm.Page object model

Other Resources

Write client application extensions
Use web service data in web resources (OData and Modern app SOAP endpoint)
Write applications and server extensions
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use web service data in web resources (OData and Modern app SOAP endpoint)

You can use JavaScript and Silverlight web resources to access Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update data from within the application. There are two web services available, each provides specific strengths. The following table describes the appropriate web service to use depending on the task you need to perform.

Task | Web Service
Create, Retrieve, Update and Delete records. | OData endpoint
Associate and Disassociate records | OData endpoint
Assign Records | Modern app SOAP endpoint
Retrieve Metadata | Modern app SOAP endpoint
Execute Messages | Modern app SOAP endpoint

Note
In the previous version of CRM, the names “REST endpoint for web resources” and “SOAP endpoint for web resources” were used to describe the OData endpoint and the modern app SOAP endpoint, respectively. Because these endpoints are no longer only available for use in web resources, we have changed the names.

Both of these web services can use the authentication provided by the Microsoft Dynamics CRM application within web resources without the need to include any code to implement authentication. See Write mobile and modern apps for information about how to use these endpoints with authentication from outside the application.

The OData endpoint provides a “RESTful” web service using OData to provide a programming environment that is familiar to many developers. It is the recommended web service to use for tasks that involve creating, retrieving, updating and deleting records. However, in this release of Microsoft Dynamics CRM the capabilities of this web service are limited to these actions.

The modern app SOAP endpoint provides access to all the messages defined in the Organization service. However, only the types defined in the Web Services Description Language (WSDL) will be returned. There is no strong type support. While the modern app SOAP endpoint is also capable of performing create, retrieve, update and delete operations, the OData endpoint provides a better developer experience for client application extensions. In this release of Microsoft Dynamics CRM, the modern app SOAP endpoint provides an alternative way to perform operations that the OData endpoint isn’t capable of.

In This Section

Use the OData endpoint with web resources

Use the Modern app SOAP endpoint for modern applications with web resources

Related Sections

Write client application extensions

Use the OData endpoint with web resources

Use the Modern app SOAP endpoint for modern applications with web resources

Web resources for Microsoft Dynamics CRM

Write code for Microsoft Dynamics CRM forms

Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the OData endpoint with web resources

The OData endpoint with web resources provides an alternative interface to work with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update data. You can use the OData endpoint to execute HTTP requests by using a service that is based on a Uniform Resource Identifier (URI).

In This Topic

What is OData?

Microsoft Dynamics CRM implementation of REST

Third-party tools to generate code

What is OData?

The OData endpoint uses the Open Data protocol. This protocol implements a “RESTful” design pattern. REST represents Representational State Transfer. REST is an architectural style in which every resource is addressed by using a unique URI. In Microsoft Dynamics CRM, a resource can be an entity collection or a record.

REST works the way the Internet works. You interact with resources by using HTTP verbs such as GET, POST, MERGE, and DELETE. Various libraries can be used to process the HTTP requests and responses. REST provides a standard interface that you can use with any programming language. REST allows for either synchronous or asynchronous processing of operations. The capability to perform asynchronous operations makes REST well suited for web resources and scripts used in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Microsoft Dynamics CRM implementation of OData

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update uses the Windows Communication Foundation (WCF) Data Services framework to provide an Open Data Protocol (OData) endpoint that is a REST-based data service. This endpoint is called the Organization Data Service. In Microsoft Dynamics CRM, the service root URI is:

Copy Code
[Your Organization Root URL]/xrmservices/2011/organizationdata.svc

OData sends and receives data by using either ATOM or JavaScript Object Notation (JSON). ATOM is an XML-based format usually used for RSS feeds. JSON is a text format that allows for serialization of JavaScript objects.

To provide a consistent set of URIs that corresponds to the entities used in Microsoft Dynamics CRM, an Entity Data Model (EDM) organizes the data in the form of records of "entity types" and the associations between them.

OData Entity Data Model

The Microsoft Dynamics CRM EDM is described in an OData Service Metadata document available at the following path:

Copy Code
[Your Organization Root URL]/xrmservices/2011/organizationdata.svc/$metadata

This XML document uses conceptual schema definition language (CSDL) to describe the available data. You will download this document and use it to generate typed classes when you use managed code or as a reference for available objects when you use JavaScript.

Limitations

The OData endpoint provides an alternative to the SOAP endpoint, but there are currently some limitations.

Only Create, Retrieve, Update, and Delete actions can be performed on entity records.

  • Messages that require the Execute method can’t be performed.
  • Associate and disassociate actions can be performed by using navigation properties.
The OData protocol isn’t fully implemented. Some system query options are not available.

For more information, see OData system query options using the OData endpoint.

You can’t use late binding with managed code against custom entities, attributes, or relationships that did not exist when the code was written.

You will typically use WCF Data Services Client Data Service classes while programming by using managed code. These classes allow for early binding so that you get strongly typed classes at design time. The only entities available to you are those defined in the system when the classes were generated. This means that you can’t use late binding to work with custom entities, attributes, or relationships that were not included in the WCF Data Services Client Data Service classes when they were generated.

Third-party tools to generate code

The community of developers who work with Microsoft Dynamics CRM have created some tools that demonstrate how the OData endpoint works and can generate code you can use. The following tools provide capabilities to generate code to work with CRM data using the OData endpoint.

CRM REST Builder

Use this tool to build requests to retrieve data and perform operations using a variety of JavaScript libraries.

Thanks to Microsoft Dynamics CRM MVP Jason Lattimer for building this tool.

OData Query Designer

Included with the Dynamics XRM Tools project, the OData Query Designer allows you to create queries to retrieve data using the OData endpoint.

Thanks to Microsoft Dynamics CRM MVP Rhett Clinton for building this and other tools.

See Also

Concepts

Use the Modern app SOAP endpoint for modern applications with web resources
Web resources for Microsoft Dynamics CRM
Download the endpoints using the Microsoft Dynamics CRM Developer resources page
Query Microsoft Dynamics CRM data using the OData endpoint
Perform basic data operations using the OData endpoint
Use the OData endpoint with Ajax and JScript web resources
Perform additional data operations using the OData endpoint

Other Resources

Use web service data in web resources (OData and Modern app SOAP endpoint)
Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript and jQuery
Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript
Sample: OData endpoint jQuery contact editor
Open Data Protocol Overview
OData SDK
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Query Microsoft Dynamics CRM data using the OData endpoint

To locate and retrieve data with the OData endpoint, manipulate the URI. All actions require that you begin with the service root URI. In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update the service root URI is in the following example.

Copy Code
[Your Organization Root URL]/XRMServices/2011/OrganizationData.svc
Note
The organization root URL must include the organization name. Reference the service root by using the getClientUrl function in the context object. If a web resource will be hosted in a form, you can reference the Xrm.Page.context to call getClientUrl. Otherwise, you need to include a reference to the ClientGlobalContext.js.aspx page so that you can use the GetGlobalContext function to get the context object.

From the service root URI you identify specific resources using a resource path and further refine your query using system query options.

In This Topic

Accessing Microsoft Dynamics CRM entity data

Limitations on number of records returned

Entity properties

Microsoft Dynamics CRM complex types:

  • EntityReference
  • OptionSetValue
  • Money
  • BooleanManagedProperty

Related entities

Accessing Microsoft Dynamics CRM entity data

Each Microsoft Dynamics CRM entity is represented in the conceptual schema definition language (CSDL) as a collection using the <EntitySet> element. The name of each collection follows the naming convention of [Entity Schema Name]+ Set. This name is used in the URL to access a collection of entity records. A list of all the collections available is listed when you view the service root URI. To create a query you append your criteria to the resource path.

For example, in your browser you can view the ATOM Account entity records (called ”entries”) using the path in the following example.

Copy Code
[Your Organization Root URL]/XRMServices/2011/OrganizationData.svc/AccountSet

After you view the list of account records, you can see how each of them can be referenced individually using the URL syntax in the following example.

Copy Code
[Your Organization Root URL]/XRMServices/2011/OrganizationData.svc/AccountSet(guid'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx')
Note
To view the data in Internet Explorer, you must first make sure that Internet Explorer is not enabled to format RSS feeds. In the Content tab of Internet Options. select Settings in the Feeds and Web Slices group. Then, click to clear the Turn on feed reading view option. Close and re-open Internet Explorer.

Limitations on number of records returned

Each time that you retrieve records, only the top 50 records in your query are returned. If there are more than 50 records, there will be a <link rel="next" href="<url to next set of records>" > node in XML or a JSON __next property at the end of the result set. You can use the URL value in that node or property to continue with the next set of records. The URL contains a $skiptoken parameter that provides information about the paging boundary.

To retrieve additional records you must create a method that detects the existence of this node or property and use the URL provided to retrieve the next set of records. For more information, see: Sample: Retrieve multiple records using the OData endpoint with JavaScript

Entity properties

Each conceptual schema definition language (CSDL) <EntitySet> refers to an <EntityType> element that describes the properties and relationships for an entity. Within the <EntityType> elements the <Property> elements correspond to Microsoft Dynamics CRM entity attributes. Each property is assigned a data type that corresponds to one of the primitive Entity Data Model (EDM) data types or a <ComplexType> defined specifically for Microsoft Dynamics CRM. The following table lists the data types.

OData type | Microsoft Dynamics CRM data type
Edm.Boolean | Boolean
Edm.DateTime | DateTime
Edm.Decimal | Decimal
Edm.Double | Double
Edm.Guid | UniqueIdentifier
Edm.Int32 | Integer
Edm.Int64 | BigInt
Edm.String | String EntityName
Microsoft.Crm.Sdk.Data.Services.EntityReference | EntityReference Customer Owner
Microsoft.Crm.Sdk.Data.Services.OptionSetValue | OptionSetValue State Status
Microsoft.Crm.Sdk.Data.Services.Money | Money
Microsoft.Crm.Sdk.Data.Services.BooleanManagedProperty | BooleanManagedProperty

Microsoft Dynamics CRM complex types

Certain datatypes used by Microsoft Dynamics CRM cannot use the simple EDM datatypes.

Note
To set Microsoft Dynamics CRM complex type values to null, set each property of the complex type to null. For more information, see Setting Complex Types to null.

EntityReference

The Microsoft.Crm.Sdk.Data.Services.EntityReference type represents a lookup. It corresponds to EntityReference.The following table lists the properties.

Name | Type | Description
Id | GUID | The unique ID for the record associated in the lookup.
LogicalName | String | The name of the entity.
Name | String | The value of the primary attribute for the record associated in the lookup.

The following example is an ATOM XML EntityReference:

Xml Copy Code
<d:PrimaryContactId m:type="Microsoft.Crm.Sdk.Data.Services.EntityReference">
   <d:Id m:type="Edm.Guid">76713858-5e81-df11-afdb-00155dba380a</d:Id>
   <d:LogicalName>contact</d:LogicalName>
   <d:Name>Cat Francis (sample)</d:Name>
</d:PrimaryContactId>

The following example is a JSON EntityReference:

JScript Copy Code
"PrimaryContactId" :{
    "__metadata": {"type": "Microsoft.Crm.Sdk.Data.Services.EntityReference" },
    "Id": "78713858-5e81-df11-afdb-00155dba380a",
    "LogicalName": "contact",
    "Name": "Cathan Cook (sample)"}

OptionSetValue

The Microsoft.Crm.Sdk.Data.Services.OptionSetValue type represents a picklist attribute. It corresponds to OptionSetValue. The following table lists properties.

Name | Type | Description
Value | Number | The selected value of the OptionSet attribute.

The following example is an ATOM XML OptionSetValue:

Copy Code
<d:PreferredContactMethodCode m:type="Microsoft.Crm.Sdk.Data.Services.OptionSetValue">
   <d:Value m:type="Edm.Int32">1</d:Value>
</d:PreferredContactMethodCode>

The following example is a JSON OptionSetValue:

JScript Copy Code
"PreferredContactMethodCode" :{
    "__metadata": {"type": "Microsoft.Crm.Sdk.Data.Services.OptionSetValue" },
    "Value": 1}

Money

The Microsoft.Crm.Sdk.Data.Services.Money type represents a Money attribute. It corresponds to Money The following table lists the properties.

Name | Type | Description
Value | Number | The amount of money.

The following example is an ATOM XML Money:

Copy Code
<d:CreditLimit m:type="Microsoft.Crm.Sdk.Data.Services.Money">
  <d:Value m:type="Edm.Decimal">500.0000</d:Value>
</d:CreditLimit>

The following example is a JSON Money:

JScript Copy Code
"CreditLimit" :{
    "__metadata": {"type": "Microsoft.Crm.Sdk.Data.Services.Money" },
    "Value": 500.0000}

BooleanManagedProperty

Certain organization-owned entities have records that can be included in a solution, for example WebResource. Examples of managed properties include IsCustomizable, IsHidden, and CanBeDeleted. It corresponds to BooleanManagedProperty These Boolean properties control the behavior of managed solution components. For more information, see Use managed properties. The following table lists the BooleanManagedProperty.

Name | Type | Description
Value | Boolean | Indicates whether the managed property is in effect.
CanBeChanged | Boolean | Indicates whether the value of the managed property can be changed.
ManagedPropertyLogicalName | String | Specifies the name of the managed property. This property is read-only.

The following example is an ATOM XML BooleanManagedProperty:

Copy Code
<d:IsCustomizable m:type="Microsoft.Crm.Sdk.Data.Services.BooleanManagedProperty">
  <d:Value m:type="Edm.Boolean">true</d:Value>
   <d:CanBeChanged m:type="Edm.Boolean">true</d:CanBeChanged>
   <d:ManagedPropertyLogicalName>iscustomizableanddeletable</d:ManagedPropertyLogicalName>
</d:IsCustomizable>

The following example is a JSON BooleanManagedProperty:

JScript Copy Code
"IsCustomizable" :{
    "__metadata": { "type": "Microsoft.Crm.Sdk.Data.Services.BooleanManagedProperty" },
    "CanBeChanged": true,
    "ManagedPropertyLogicalName": "iscustomizableanddeletable",
    "Value": true}

Related entities

The conceptual schema definition language (CSDL) <NavigationProperty> element includes all the 1:N, and N:N relationships for the entity. If the relationship represents a self-referencing relationship, there will be two <NavigationProperty> elements for this relationship. The name of the relationship uses the prefix Referenced and Referencing to differentiate the role a specific record plays in the relationship. For more information, see Types of Entity Relationships.

Use the <NavigationProperty> when you want to create a query to retrieve related records. In the following example, if you want to retrieve a list of opportunities where a specific account is the customer, use the opportunity_customer_accounts entity relationship in the context of a specific account:

Copy Code
/AccountSet(guid'[GUID value]')/opportunity_customer_accounts

If you require only the URL addresses to related records you can use the $links query option shown in the following example:

Copy Code
/AccountSet(guid'[GUID value]')/$links/opportunity_customer_accounts

This will return only the URLs to the data for each related record. The results when viewed in the browser would resemble the following example.

Copy Code
<?xml version="1.0" encoding="utf-8" standalone="yes" ?>
<links xmlns="http://schemas.microsoft.com/ado/2007/08/dataservices">
   <uri>[Your Organization Root URL]/xrmservices/2011/OrganizationData.svc/OpportunitySet(guid'a6713858-5e81-df11-afdb-00155dba380a')</uri>
   <uri>[Your Organization Root URL]/xrmservices/2011/OrganizationData.svc/OpportunitySet(guid'1224342F-D024-4B47-A3F5-FB22D236E655')</uri>
   <uri>[Your Organization Root URL]/xrmservices/2011/OrganizationData.svc/OpportunitySet(guid'7AF675A8-4FBE-42E7-8279-C32605D2B49B')</uri>
   <uri>[Your Organization Root URL]/xrmservices/2011/OrganizationData.svc/OpportunitySet(guid'2DD9BA88-2A37-4F53-8946-68ABBDC73FC1')</uri>
</links>

If you want to include data from the related records when you retrieve a record, use the $expand system query option.

See Also

Concepts

Use the OData endpoint with web resources
OData system query options using the OData endpoint
Perform basic data operations using the OData endpoint
Perform additional data operations using the OData endpoint
Use the OData endpoint with Ajax and JScript web resources

Other Resources

Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript and jQuery
Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript
Sample: OData endpoint jQuery contact editor
Open Data Protocol (OData)
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OData system query options using the OData endpoint

You can refine the results of your query by using system query options. The following table lists the query string options defined in the OData protocol that are implemented in the OData endpoint for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Option | Description
$expand | Directs that related records should be retrieved in the record or collection being retrieved.
$filter | Specifies an expression or function that must evaluate to true for a record to be returned in the collection.
$orderby | Determines what values are used to order a collection of records.
$select | Specifies a subset of properties to return.
$skip | Sets the number of records to skip before it retrieves records in a collection.
$top | Determines the maximum number of records to return.

$expand

Directs that related records should be retrieved in the record or collection being retrieved.

If you want to retrieve related records, locate the name of the entity relationship that defines this relationship. You may have to view the entity relationship information in the application to correctly identify the relationship or the conceptual schema definition language (CSDL) for the Organization Data Service.

For example, to retrieve opportunity records related to accounts, use the opportunity_customer_accounts entity relationship. The query /AccountSet?$expand=opportunity_customer_accounts returns the opportunity records and the account records.

If you’re limiting the columns returned, you must also include the name of the navigation property in the query. For example, the query /AccountSet?$select=Name,opportunity_customer_accounts&$expand=opportunity_customer_accounts returns only the account name and the expanded opportunity records.

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update doesn’t support querying a multilevel relationship property. For example, this query, intended to retrieve information about the owning user of opportunities related to accounts, won’t work: /AccountSet?$expand=opportunity_customer_accounts/opportunity_owning_user.

By default, you can define up to six relationships to expand. This query, expanding both the opportunities and system user that owns the account, will work, /AccountSet?$select=Name,opportunity_customer_accounts,user_accounts&$expand=opportunity_customer_accounts,user_accounts.

Note
The number of related records returned is subject to the same limitation on the number of records returned. For more information, see Limitations on number of records returned. You can increase the number of relationships to expand by changing the ServerSettingsMaxExpandCount setting value.

More information: OData: Filter System Query Option ($expand)

$filter

Specifies an expression or function that must evaluate to true for a record to be returned in the collection.

If you’re retrieving additional sets of data using the next link, you shouldn’t change the $filter query option value because this causes unpredictable results.

The OData specification for the Filter System Query Option describes the operators used to create an expression to evaluate in the filter. Microsoft Dynamics CRM uses all the logical operators and a subset of the functions available, but doesn’t support use of the arithmetic operators. Filters can use grouped conditions indicated by parentheses. Comparisons of time values must use the following format: datetime’<time value>’, for example datetime'2010-07-15' or datetime'2010-07-15T16:19:54Z'.

The following table lists the operators supported by Microsoft Dynamics CRM.

Operator | Description | Example
eq | Equal | /AccountSet?$filter=Address1_City eq 'Redmond'
ne | Not equal | /AccountSet?$filter=Address1_City ne null
gt | Greater than | /AccountSet?$filter=CreditLimit/Value gt 1000
ge | Greater than or equal | /AccountSet?&$filter=CreditLimit/Value ge 1000
lt | Less than | /AccountSet?$filter=CreditLimit/Value lt 1000
le | Less than or equal | /AccountSet?$filter=CreditLimit/Value le 1000
and | Logical and | /AccountSet?$filter=CreditLimit/Value ge 1000 and Address1_StateOrProvince eq 'TX'
or | Logical or | /AccountSet?$filter=AccountCategoryCode/Value eq 2 or AccountRatingCode/Value eq 1
not | Logical Negation | /AccountSet?$filter=(AccountCategoryCode/Value ne null) and not (AccountCategoryCode/Value eq 1)

You can use the $filter query option to filter for the value of an EntityReference attribute. For example, if you have the Id value for a SystemUser record, you can retrieve a list of all the account records that a user is assigned by using the following filter:

Copy Code
/AccountSet?$filter=OwnerId/Id eq (guid'" + SystemUserId + "')

The following table lists the functions supported by Microsoft Dynamics CRM.

Function | Example
startswith | /AccountSet?$filter=startswith(Name, 'a')
substringof | /AccountSet?$filter=substringof('store',Name)
endswith | /AccountSet?$filter=endswith(Name, '(sample)')

More information: OData: Filter System Query Option ($filter)

$orderby

Determines what values are used to order a collection of records. By default, the order is ascending. Use desc to reverse the order or asc to explicitly set the default.

If you’re retrieving additional sets of data using the next link, you shouldn’t change the $orderby query option value because this causes unpredictable results.

Note
You can select up to 12 columns using $orderby.

When ordering by complex types, such as EntityReference or OptionSetValue, only the attribute name should be specified. For example, to order by the primary contact of an account, use the query $orderby=PrimaryContactId. Specifying $orderby=PrimaryContactId/Name will give you a Bad Request HTTP error (HTTP Error Code 400).

The following sample lists account records by country/region in ascending order, and by city in descending order:

Copy Code
/AccountSet?$select=Address1_Country,Address1_City,Name&$orderby=Address1_Country,Address1_City desc&$filter=(Address1_Country ne null) and (Address1_City ne null)

More information: OData: Filter System Query Option ($orderby)

$select

Specifies a subset of properties to return and the order in which the columns of data will be organized. The default is to return all columns that correspond to $select=*.

If you use $expand to include related data and you use $select to limit the columns returned, you must also include the name of the navigation property in the query. For example, the following query, /AccountSet?$select=Name,opportunity_customer_accounts&$expand=opportunity_customer_accounts, returns only the account name and the expanded opportunity records.

Note
There is a maximum path length of 2048 characters for POST and GET requests in Internet Explorer. You can easily reach this limit if you were to include every attribute in the account entity in the $select option. For more information, see Microsoft KB 208427

More information: OData: Filter System Query Option ($select)

$skip

Sets the number of records to skip before retrieving records in a collection.

If you’re retrieving additional sets of data using the next link, you shouldn’t change the $skip query option value because this causes unpredictable results.

More information: OData: Filter System Query Option ($skip)

$top

Determines a maximum number of records to return.

If you’re retrieving additional sets of data using the next link, you shouldn’t change the $top query option value because this will cause unpredictable results.

More information: OData: Filter System Query Option ($top)

Unsupported system query options

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update doesn’t support using the following system query options:

  • $inlinecount
  • $count
  • $format

See Also

Concepts

Query Microsoft Dynamics CRM data using the OData endpoint

Other Resources

OData: URI Conventions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Perform basic data operations using the OData endpoint

There are a variety of libraries or technologies that you might use to execute the HTTP requests to perform data operations using the OData endpoint with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. This topic describes the format of the low level HTTP requests. Regardless of the library or technology you use, with a Web debugging proxy tool such as Fiddler, you can examine the HTTP traffic and compare the results that you see with the requirements of the OData endpoint. This topic presents examples of the HTTP Requests and Responses captured using Fiddler. Some content in these examples have been edited for brevity and <placeholders> are included where the content would vary based on environmental variables.

For more information about applications that use a specific technology, see: Use the OData endpoint with Ajax and JScript web resources

In This Topic

Creating Records

  • Using ATOM
  • Using JSON

Retrieving Records

  • Using ATOM
  • Using JSON

Updating Records

  • Update using PUT
  • Update using MERGE
    • Using ATOM
    • Using JSON

Deleting Records

  • Using ATOM
  • Using JSON

HTTP Status codes

Creating records

New records, or entries, are created by executing an HTTP POST request against the URI of the collection where the entry is to be created. The POST request includes the new entry in its body using either ATOM or JSON formats.

The server assigns default values to any properties not specified in the request and returns the result with a ‘Location’ header that contains the URL for the record that was created. The entry title element reflects the primary attribute of the entity. For example, for the account entity the name attribute is the primary attribute. HTTP status code 201 indicates that the record was successfully created.

For more information about an alternative way to create new records in the context of a related record, see Using Deep Insert.

Using ATOM

For example, when a new account record is created by using System.Data.Services.Client library in managed code

HTTP request

Copy Code
POST <organization root>/xrmservices/2011/organizationdata.svc/AccountSet HTTP/1.1
Accept-Charset: UTF-8
Accept-Language: en-us
dataserviceversion: 1.0;NetFx
Accept:  application/atom+xml,application/xml
Content-Type:  application/atom+xml
maxdataserviceversion: 2.0;NetFx
Referer: <The URL to the HTML page >
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1)
Host: <CRM Server>
Content-Length: 26629
Connection: Keep-Alive
Pragma: no-cache
Cookie: <cookie data>
Authorization: Negotiate <authentication token>

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<entry xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices"
xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"
xmlns="http://www.w3.org/2005/Atom">
  <category
   scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme"
   term="Microsoft.Crm.Sdk.Data.Services.Account"
  />
  <title type="text">New Account Created</title>
  <author>
    <name />
  </author>
  <updated>2010-07-22T22:51:50.0051481Z</updated>
  <id />
  <content type="application/xml">
    <m:properties>
[ Properties removed for brevity]
    </m:properties>
   </content>
</entry>

HTTP response

Copy Code
HTTP/1.1 201 Created
Cache-Control: no-cache
Content-Length: 26756
Content-Type:  application/atom+xml;charset=utf-8
Location:  <organization root>/XRMServices/2011/OrganizationData.svc/AccountSet(guid'732b64b6-e395-df11-a492-00155dba380c')
Server: Microsoft-IIS/7.0
X-AspNet-Version: 4.0.30319
DataServiceVersion: 1.0;
X-Powered-By: ASP.NET
WWW-Authenticate: Negotiate <authentication token>
Date: Thu, 22 Jul 2010 22:51:49 GMT

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<entry xml:base="<organization root>/XRMServices/2011/OrganizationData.svc/"
xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices"
xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"
xmlns="http://www.w3.org/2005/Atom">
  <id><organization root>/XRMServices/2011/OrganizationData.svc/AccountSet(guid'732b64b6-e395-df11-a492-00155dba380c')</id>
  <title type="text">New Account Created</title>
  <updated>2010-07-22T22:51:50Z</updated>
  <author>
    <name />
  </author>
  <link rel="edit" title="Account" href="AccountSet(guid'732b64b6-e395-df11-a492-00155dba380c')" />
[Links removed for brevity]
  <category
   term="Microsoft.Crm.Sdk.Data.Services.Account"
   scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme"
  />
  <content type="application/xml">
    <m:properties>
[Properties removed for brevity]
</m:properties>
  </content>
</entry>

Go to top.

Using JSON

For example, when a new account record is created by using the XMLHttpRequest object from the browser.

HTTP request

Copy Code
POST <organization root>/XRMServices/2011/OrganizationData.svc/AccountSet HTTP/1.1
Content-Type:  application/json; charset=utf-8
Accept-Language: en-us
Referer: <The URL to the HTML page sending the request>
Accept:  application/json
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1)
Host: <CRM Server>
Content-Length: 25
Connection: Keep-Alive
Pragma: no-cache
Cookie: <cookie data>
Authorization: Negotiate <authentication token>

{"Name":"Sample Account"}

HTTP response

Copy Code
HTTP/1.1 201 Created
Cache-Control: no-cache
Content-Length: 17720
Content-Type:  application/json;charset=utf-8
Location: <organization root>/XRMServices/2011/OrganizationData.svc/AccountSet(guid'5784bd4a-f595-df11-a492-00155dba380c')
Server: Microsoft-IIS/7.0
X-AspNet-Version: 4.0.30319
DataServiceVersion: 1.0;
X-Powered-By: ASP.NET
WWW-Authenticate: Negotiate <authentication token>
Date: Fri, 23 Jul 2010 00:57:40 GMT

{
"d" : {
"__metadata": {
"uri": "<organization root>/XRMServices/2011/OrganizationData.svc/AccountSet(guid'5784bd4a-f595-df11-a492-00155dba380c')",
"type": "Microsoft.Crm.Sdk.Data.Services.Account"
},
[Properties removed for brevity]
 }
}

Go to top.

Retrieving records

HTTP GET is used when you are retrieving records. When a unique identifier for a specific record is provided, only that record will be retrieved. Otherwise, any system query options that are defined will be applied and up to 50 records will be retrieved that match any system query option filters.

Go to top.

Using ATOM

For example, when you are retrieving a single account record using System.Data.Services.Client library in managed code.

HTTP request

Copy Code
GET <organization root>/xrmservices/2011/organizationdata.svc/AccountSet(guid'732b64b6-e395-df11-a492-00155dba380c') HTTP/1.1
Accept-Charset: UTF-8
Accept-Language: en-us
dataserviceversion: 1.0;NetFx
Accept:  application/atom+xml,application/xml
maxdataserviceversion: 2.0;NetFx
Referer: <The URL to the HTML page >
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1)
Host: <CRM Server>
Connection: Keep-Alive
Cookie: <cookie data>
Authorization: Negotiate <authentication token>

HTTP response

Copy Code
HTTP/1.1 200 OK
Cache-Control: no-cache
Content-Length: 28231
Content-Type:  application/atom+xml;charset=utf-8
Server: Microsoft-IIS/7.0
X-AspNet-Version: 4.0.30319
DataServiceVersion: 1.0;
X-Powered-By: ASP.NET
WWW-Authenticate: Negotiate <authentication token>
Date: Thu, 22 Jul 2010 22:51:51 GMT

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<entry xml:base="<organization root>/XRMServices/2011/OrganizationData.svc/"
   xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices"
   xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"
   xmlns="http://www.w3.org/2005/Atom">
  <id><organization root>/XRMServices/2011/OrganizationData.svc/AccountSet(guid'732b64b6-e395-df11-a492-00155dba380c')</id>
  <title type="text">New Account Created </title>
  <updated>2010-07-22T22:51:51Z</updated>
  <author>
    <name />
  </author>
  <link rel="edit" title="Account" href="AccountSet(guid'732b64b6-e395-df11-a492-00155dba380c')" />
[Links removed for brevity]
  <category
   term="Microsoft.Crm.Sdk.Data.Services.Account"
   scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme"
  />
  <content type="application/xml">
    <m:properties>
[Properties removed for brevity]
    </m:properties>
  </content>
</entry>

Go to top.

Using JSON

For example, when you are retrieving an account record using the XMLHttpRequest object from the browser.

HTTP request

Copy Code
GET <organization root>/XRMServices/2011/OrganizationData.svc/AccountSet(guid'5784bd4a-f595-df11-a492-00155dba380c') HTTP/1.1
Content-Type:  application/json; charset=utf-8
Accept-Language: en-us
Referer: <The URL to the HTML page sending the request>
Accept:  application/json
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1)
Host: <CRM Server>
Connection: Keep-Alive
Cookie: <cookie data>
Authorization: Negotiate <authentication token>

HTTP response

Copy Code
GET <organization root>/XRMServices/2011/OrganizationData.svc/AccountSet(guid'5784bd4a-f595-df11-a492-00155dba380c') HTTP/1.1
Content-Type:  application/json; charset=utf-8
Accept-Language: en-us
Referer: <The URL to the HTML page sending the request>
Accept:  application/json
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1)
Host: <CRM Server>
Connection: Keep-Alive
Cookie: <cookie data>
Authorization: Negotiate <authentication token>

Go to top.

Updating records

In OData, you can use either the PUT method or the MERGE method to update records. MERGE is used to avoid overloading the meaning of PUT.

A successful update response contains the HTTP status code 204 and returns no content.

Note
To set Microsoft Dynamics CRM complex type values to null, set all the properties of the complex type to null. For more information, see Setting Complex Types to null.

Note
Some libraries might not include the body of the request when submitting a PUT or MERGE request to the server. As a workaround, OData supports Method Tunneling through Post using the POST HTTP operator. To use Method tunneling, submit a POST HTTP operation and set the X-HTTP-Method header to the HTTP operation that you want to execute. For example, to submit a MERGE request, the HTTP operation should be POST and the X-HTTP-Method HTTP header should be MERGE.

Update using PUT

Important
Updating records using PUT replaces the existing record with the data provided. All property values in the record either take the values provided in the request or are set to their default values if they are not included in the request. Links are not replaced.

Use PUT when you update individual properties. For more information, see Updating Individual Properties

Update using MERGE

The typical update logic in Microsoft Dynamics CRM matches the behavior usually defined by using MERGE. Property values included in the request are applied only to those properties. Other property data is not changed.

Important
Unless you take steps to mitigate this behavior, when using the proxy classes in managed code to update retrieved entity records MERGE is used and all properties are updated. This is true even if the value of the properties are not changed. This may cause undesirable side-effects when other event driven features, such as workflows or plugins, detect that the property has been updated. Also, auditing will record that the property has been updated.

Furthermore, if an entity instance is instantiated rather than being retrieved, all the properties for the entity are returned with the MERGE request. Any properties that are not set in code will be null. These null values overwrite any existing values for the record.

You can mitigate this behavior by implementing an event handler for the DataServiceContextReadingEntity and WritingEntity events.

Go to top.

Using ATOM

For example, when updating an account record using System.Data.Services.Client library in managed code:

HTTP request
Copy Code
POST <organization root>/xrmservices/2011/organizationdata.svc/AccountSet(guid'732b64b6-e395-df11-a492-00155dba380c') HTTP/1.1
Accept:  application/atom+xml,application/xml
Accept-Language: en-us
dataserviceversion: 1.0;NetFx
x-http-method: MERGE
Accept-Charset: UTF-8
Content-Type:  application/atom+xml
maxdataserviceversion: 2.0;NetFx
Referer: <The URL to the HTML page >
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1)
Host: <CRM Server>
Content-Length: 26753
Connection: Keep-Alive
Pragma: no-cache
Cookie: <cookie data>
Authorization: Negotiate <authentication token>

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<entry
   xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices"
   xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"
   xmlns="http://www.w3.org/2005/Atom">
  <category
   scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme"
   term="Microsoft.Crm.Sdk.Data.Services.Account"
  />
  <title type="text">Account updated </title>
  <author>
    <name />
  </author>
  <updated>2010-07-22T22:51:51.0053481Z</updated>
  <id><organization root>/xrmservices/2011/organizationdata.svc/AccountSet(guid'732b64b6-e395-df11-a492-00155dba380c')</id>
  <content type="application/xml">
    <m:properties>
[Properties removed for brevity]
    </m:properties>
  </content>
</entry>
HTTP response
Copy Code
HTTP/1.1 204 No Content
Cache-Control: no-cache
Content-Length: 0
Server: Microsoft-IIS/7.0
X-AspNet-Version: 4.0.30319
DataServiceVersion: 1.0;
X-Powered-By: ASP.NET
WWW-Authenticate: Negotiate <authentication token>
Date: Thu, 22 Jul 2010 22:51:51 GMT

Go to top.

Using JSON

For example, when updating an account record using the XMLHttpRequest object from the browser.

HTTP request
Copy Code
POST <organization root>/XRMServices/2011/OrganizationData.svc/AccountSet(guid'5784bd4a-f595-df11-a492-00155dba380c') HTTP/1.1
Accept:  application/json
Accept-Language: en-us
Referer: <The URL to the HTML page sending the request>
x-http-method: MERGE
Content-Type:  application/json; charset=utf-8
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1)
Host: <CRM Server>
Content-Length: 117
Connection: Keep-Alive
Pragma: no-cache
Cookie: <cookie data>
Authorization: Negotiate <authentication token>

{"Name":"Updated Sample","Telephone1":"555-0123","AccountNumber":"ABCDEFGHIJ","EMailAddress1":"someone1@example.com"}
HTTP response
Copy Code
HTTP/1.1 204 No Content
Cache-Control: no-cache
Content-Length: 0
Server: Microsoft-IIS/7.0
X-AspNet-Version: 4.0.30319
DataServiceVersion: 1.0;
X-Powered-By: ASP.NET
WWW-Authenticate: Negotiate <authentication token>
Date: Fri, 23 Jul 2010 00:57:41 GMT

Deleting records

Use a POST request with the X-HTTP-METHOD header set to DELETE with a URI reference to the record to be deleted.

Note
Although the OData specification indicates that a successful delete operation should return an HTTP status code of 200 (OK), the Microsoft Dynamics CRM implementation returns 204 (No Content).

For more information, see Associating and disassociating records.

Go to top.

Using ATOM

For example, when you delete an account record using System.Data.Services.Client library in managed code.

HTTP request

Copy Code
POST <organization root>/xrmservices/2011/organizationdata.svc/AccountSet(guid'732b64b6-e395-df11-a492-00155dba380c') HTTP/1.1
Accept:  application/atom+xml,application/xml
Accept-Language: en-us
dataserviceversion: 1.0;NetFx
x-http-method: DELETE
Accept-Charset: UTF-8
Content-Type:  application/atom+xml
maxdataserviceversion: 2.0;NetFx
Referer: <The URL to the HTML page >
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1)
Host: <CRM Server>
Content-Length: 0
Connection: Keep-Alive
Pragma: no-cache
Cookie: <cookie data>
Authorization: Negotiate <authentication token>

HTTP response

Copy Code
HTTP/1.1 204 No Content
Cache-Control: no-cache
Content-Length: 0
Server: Microsoft-IIS/7.0
X-AspNet-Version: 4.0.30319
DataServiceVersion: 1.0;
X-Powered-By: ASP.NET
WWW-Authenticate: Negotiate <authentication token>
Date: Thu, 22 Jul 2010 22:51:54 GMT

Go to top.

Using JSON

For example, when you delete an account record using the XMLHttpRequest object from the browser.

HTTP request

Copy Code
POST <organization root>/XRMServices/2011/OrganizationData.svc/AccountSet(guid'5784bd4a-f595-df11-a492-00155dba380c') HTTP/1.1
Accept:  application/json
Accept-Language: en-us
Referer: <The URL to the HTML page sending the request>
x-http-method: DELETE
Content-Type:  application/json; charset=utf-8
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1)
Host: <CRM Server>
Content-Length: 0
Connection: Keep-Alive
Pragma: no-cache
Cookie: <cookie data>
Authorization: Negotiate <authentication token>

HTTP response

Copy Code
HTTP/1.1 204 No Content
Cache-Control: no-cache
Content-Length: 0
Server: Microsoft-IIS/7.0
X-AspNet-Version: 4.0.30319
DataServiceVersion: 1.0;
X-Powered-By: ASP.NET
WWW-Authenticate: Negotiate <authentication token>
Date: Fri, 23 Jul 2010 00:57:57 GMT

Go to top.

HTTP status codes

Details about HTTP status codes returned are available in OData endpoint Http status codes.

See Also

Reference

OData endpoint Http status codes

Concepts

Use the OData endpoint with web resources
Perform additional data operations using the OData endpoint
Use the OData endpoint with Ajax and JScript web resources

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Perform additional data operations using the OData endpoint

In addition to basic data operations, you can use the REST endpoint for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update to perform some more specialized data operations.

In This Topic

Setting complex types to null

Using Deep insert

Updating individual properties

Associating and disassociating records

Setting complex types to null

In order to set Microsoft CRM Complex Types to null, you must explicitly set each primitive type within them to null.

For example, to set an EntityReference type to null, you must set the Id, the LogicalName, and the Name properties to null. The same is true for OptionSetValue, Money, and BooleanManagedProperty.

Using Deep insert

Deep insert is a technique in which you can create multiple new related records in the same operation.

The following sample shows JavaScriptcode that uses jQuery to define an account and two related tasks. For more information, see Using jQuery. When the tasks are assigned to the Account_Tasks property representing related tasks and submitted by using a POST request to the /AccountSet URI, the account and the two related tasks are created in a single operation:

Copy Code
var account = new Object();
account.Name = "Sample Account";

var task1 = new Object();
task1.Subject = "Sample Task 1";

var task2 = new Object();
task2.Subject = "Sample Task 2";

var tasks = new Array();
tasks.push(task1);
tasks.push(task2);

account.Account_Tasks = tasks;

var jsonAccount = window.JSON.stringify(account);

$.ajax({ type: "POST",
    contentType: "application/json; charset=utf-8",
    datatype: "json",
    url: ODataPath + "/AccountSet",
    data: jsonAccount,
    beforeSend: function (XMLHttpRequest) {
        //Specifying this header ensures that the results will be returned as JSON.
        XMLHttpRequest.setRequestHeader("Accept", "application/json");
    },
    success: function (data, textStatus, XmlHttpRequest) {},
    error: function (XMLHttpRequest, textStatus, errorThrown) {}
});

Deep insert works from either side of an entity relationship. The previous example created new tasks in the context of a new account record. You can reverse this to create a new account record in the context of creating a new related task by submitting a POST request to the /TaskSet URI.

Updating individual properties

You can update individual attribute values for a record by using a HTTP PUT request using a URI that addresses a specific attribute and passing the new value in the body of the request.

Copy Code
/AccountSet(guid'c2d26b79-7496-df11-a7c2-00155dba380d')/Name

Using this URI in an HTTP PUT request with a new name for the account in the body will update the value of only that property.

Associating and disassociating records

There are two ways to associate or disassociate records: by updating the data in the entity reference properties just as if they were any other type of property or through the URL of the link resource.

When associating or disassociating records on the many side of an N:1 entity relationship, use the $links URI. For N:N and 1:N entity relationships use the URI without $links.

The following sample shows that the URI will return a URI for any opportunity records associated with the account record specified in the URI:

Copy Code
/AccountSet(guid'c2d26b79-7496-df11-a7c2-00155dba380d')/$links/opportunity_customer_accounts

If you want to associate an existing opportunity record with this account, you must use this URI in a HTTP POST request that includes the URI for that opportunity in the body.

Note
When associating a record on the many side of a N:1 entity relationship, any existing value will be overwritten when the reference only supports a single value.

Similarly, to disassociate an opportunity, you must use an HTTP DELETE request that includes a reference to a specific link resource. The following sample shows that the URI represents a specific account record associated to another account by using ParentAccountId entity reference property:

Copy Code
/AccountSet(guid'c2d26b79-7496-df11-a7c2-00155dba380d')/$links/Referencedaccount_parent_account(guid'b0e5a4a6-8996-df11-a7c2-00155dba380d')

A HTTP DELETE request against this URI will remove the association.

Note
Some entity relationships are required. You will get an error if you attempt to delete data for a required relationship.

See Also

Concepts

Perform basic data operations using the OData endpoint
Use the OData endpoint with web resources
Use the OData endpoint with Ajax and JScript web resources

Other Resources

Sample: Associate and disassociate records using the OData endpoint with JavaScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the OData endpoint with Ajax and JScript web resources

The OData endpoint lets you interact with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update data by using JavaScript libraries. You create script web resources using files defining the JavaScript libraries. Then you associate functions in the libraries with form or field event handlers or ribbon command actions. You can use them as you would any other JavaScript library within webpage (HTML) web resources.

In This Topic

Ajax

Method tunneling through POST

Access the server URL

Use XMLHttpRequest

Use jQuery

Work with dates

Ajax

AJAX (Asynchronous JavaScript and XML) is a web development technique used to create interactive web applications. Server requests are made from the browser in the background using an XmlHttpRequest object. Although you can send synchronous requests, the recommended practice is to send asynchronous requests. Asynchronous requests require two JScript functions, one to send the request and a second “callback” function to process a response.

JSON

The JavaScript Object Notation (JSON) format is used for serializing and transmitting structured data much in the same way that XML is typically used. Like XML, it’is text based and designed to be readable by humans. To convert regular JavaScript objects into the JSON format you use the JSON.stringify method. Because the text in JSON defines JavaScript objects, the text could be converted to JavaScript objects by using the eval method. However, this practice creates security vulnerabilities. You should use the JSON.parse method instead.

XmlHttpRequest

XmlHttpRequest (sometimes referred to as XHR) provides capabilities to configure and send requests and define a callback function if the request is asynchronous. The HTTP response from the server includes a status code indicating whether the request was successful. HTTP status code values in the 200 range are considered successful.

An XmlHttpRequest provides instructions to the server about the format of any data to be included in the response. Because the ODATA endpoint supports both ATOM and JSON formats, you have the option to request data to be returned in the XML ATOM format. However, with JavaScript code the expected typical request will use JSON because it’s easily consumable using JavaScript.

Method tunneling through POST

The OData protocol uses less common HTTP verbs PUT and DELETE as well as defining a new verb: MERGE. Depending on the supporting libraries you use, you may encounter issues while using these verbs. The way to work around this is to use the POST verb and specify an X-HTTP-Method HTTP header with the desired action. Use the setRequestHeader method to override the action specified in the XmlHttpRequest.

Access the server URL

The first thing to do when you start to use the ODATA endpoint with JavaScript is establish the URL to the organization root URL. Use the getClientUrl function from the context object.

  • If your script is designed to operate in the context of a form or field event, or a <JavaScriptFunction> (RibbonDiffXml) for a ribbon command, you can use the Xrm.Page.context object to call getClientUrl.
  • If your script executes in the context of a webpage (HTML) web resource you must include a reference to the ClientGlobalContext.js.aspx page in the HTML web resource so that you can then use the GetGlobalContext function.

Use XMLHttpRequest

jQuery is a great library with a variety of uses, but using jQuery is not a prerequisite for performing operations using the ODATA endpoint for Microsoft Dynamics CRM. We recommend you don’t use jQuery in form scripts or command scripts that run in application pages but use the XmlHttpRequest directly and avoid having to load the jQuery library. jQuery $.ajax uses the XmlHttpRequest available in the browser. Using this object directly is slightly different from using $.ajax. If you’re already familiar with using XMLHttpRequest you should continue to use it. If you have always used jQuery, consider using XMLHttpRequest directly. More information: XMLHttpRequest Object

With XmlHttpRequest, you create an event handler for the onreadystatechange event and detect when the request has completed. In the event handler, check the status code returned to determine whether the request succeeded. Finally, use the open and send methods. The following sample uses XmlHttpRequest to create a new account record.

JScript Copy Code
var account = {};
    account.Name = "Sample Account";
    var jsonAccount = JSON.stringify(account);

    var createAccountReq = new XMLHttpRequest();
    createAccountReq.open("POST", Xrm.Page.context.getClientUrl() + "/XRMServices/2011/OrganizationData.svc/AccountSet", true);
    createAccountReq.setRequestHeader("Accept", "application/json");
    createAccountReq.setRequestHeader("Content-Type", "application/json; charset=utf-8");
    createAccountReq.onreadystatechange = function () {
        createAccountReqCallBack(this);
    };
    createAccountReq.send(jsonAccount);

function createAccountReqCallBack(createAccountReq) {
    if (createAccountReq.readyState == 4 /* complete */) {
        createAccountReq.onreadystatechange = null; //avoids memory leaks
        if (createAccountReq.status == 201) {
            //Success
            var newAccount = JSON.parse(createAccountReq.responseText).d;
        }
        else {
            //Failure
            errorHandler(createAccountReq);
        }
    }
};

For more examples using XMLHttpRequest, see Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript

Use jQuery

jQuery is a popular JavaScript library that is included with web application projects in Microsoft Visual Studio. jQuery provides an extensive framework of objects and functions that let you query and work with HTML pages using JavaScript. To use XMLHttpRequest, jQuery provides the jQuery.ajax method.

Note
We don’t recommend using jQuery with form scripts or commands. More information: Use of jQuery.

The jQuery object is referenced using the $ character so the short form for jQuery.ajax is $.ajax. The ajax method is typically used with an imperative syntax and the request is sent as soon as the object is instantiated. The following sample creates a new account record.

JScript Copy Code
    var account = {};
    account.Name = "Sample Account";
    var jsonAccount = window.JSON.stringify(account);
    $.ajax({
        type: "POST",
        contentType: "application/json; charset=utf-8",
        datatype: "json",
        url: Xrm.Page.context.getClientUrl() + "/XRMServices/2011/OrganizationData.svc/AccountSet",
        data: jsonAccount,
        beforeSend: function (XMLHttpRequest) {
            //Specifying this header ensures that the results will be returned as JSON.
            XMLHttpRequest.setRequestHeader("Accept", "application/json");
        },
        success: function (data, textStatus, XmlHttpRequest) {
            account = data.d;
        },
        error: function (XMLHttpRequest, textStatus, errorThrown) {
            errorHandler(XMLHttpRequest, textStatus, errorThrown);
        }
    });

The following table lists the properties you’ll have to know about to process HTTP requests and responses using the ODATA endpoint for Microsoft Dynamics CRM.

Property Name Type Comments

type

string

Use GET when you retrieve data and POST for all other operations. More information: Explicitly set the Request header to a different HTTP action

contentType

string

Specifies the type of content sent to the server. Use application/json; charset=utf-8 when you’re sending data in the JSON format.

dataType

string

The type of data expected to be returned by the server. Use json.

Note
Simply setting this property may be insufficient. More information: Explicitly set the Request Header to accept JSON

data

object

Set this to the value of a JSON object for create or update operations.

url

string

The ODATA endpoint URL appropriate for the action you’re performing.

beforeSend

function

A function that lets you modify the XMLHttpRequest object before it’s sent.

success

function

A callback function when a request succeeds. More information: Processing results

error

function

A function to be called if a request fails. More information: Handling errors

For more information, see Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript and jQuery.

Explicitly set the request header to accept JSON

When you’re expecting results in a JSON format, just setting the dataType property might not work. You can use the beforeSend property to explicitly set the headers on the XMLHttpRequest to return data as JSON. This is typically performed by using an anonymous function as shown in the following example.

JScript Copy Code
beforeSend: function (XMLHttpRequest) {
   //Specifying this header ensures that the results will be returned as JSON.
   XMLHttpRequest.setRequestHeader("Accept", "application/json");}

When specified, any errors in XMLHttpRequest.responseText will be formatted in JSON instead of in XML.

Tip
Even when you don’t expect any data to be returned, specifying that the results are always returned using JSON will simplify your error handling. More information: Handling errors

Explicitly set the request header to a different HTTP action

As described in POST Tunneling, when you perform an action that requires an HTTP action other than POST or GET, use POST and the beforeSend property to explicitly set the headers on the XMLHttpRequest to perform a different action. This is typically performed by using an anonymous function, as shown in the following example.

JScript Copy Code
beforeSend: function (XMLHttpRequest) {
   //Specify the HTTP method DELETE to perform a delete operation.
   XMLHttpRequest.setRequestHeader("X-HTTP-Method", "DELETE");
}

Handle errors

When a request isn’t successful, $.ajax will pass the following three arguments to a function set in the error property.

XMLHttpRequest

The XMLHttpRequest object.

textStatus

A string that describes the type of error that occurred. The possible values are as follows:

  • null
  • timeout
  • error
  • notmodified
  • parsererror
errorThrown

An optional exception object.

The following sample shows how to pass these arguments to a central function that manages errors.

JScript Copy Code
error: function (XMLHttpRequest, textStatus, errorThrown) {
   errorHandler(XMLHttpRequest, textStatus, errorThrown);
}

The following sample shows a simple function that captures the error message and displays the result using the showMessage function.

Note
This function expects that any error details will be returned in JSON format. Unless the $.ajax method is configured to return results using JSON, the XMLHttpRequest.responseText would be XML.

JScript Copy Code
function errorHandler(XMLHttpRequest, textStatus, errorThrown)
{ showMessage("Error : " + textStatus + ": " + JSON.parse(XMLHttpRequest.responseText).error.message.value); }

Process results

When you perform POST or GET operations you can expect that data will be returned. If you have specified that results be returned in the JSON format, the results will be in the d property of the data object returned. When you create or retrieve a record using the unique identifier, d will represent the data for the record. In every other case d will be an array.

The following sample shows processing the results of a query that returns multiple account records.

JScript Copy Code
success: function (data, textStatus, XmlHttpRequest) {
   var accounts = data.d;
   for (var i in accounts) {   showMessage(accounts[i].Name);
   }}

Work with dates

There are four tasks involving dates that you may need to perform:

  • Parse retrieved data
  • Display date values
  • Update date values
  • Set a date as criteria in a filter in a query

Parse retrieved data

When you retrieve records using the ODATA endpoint, date values are returned as strings that use the format “\/Date(<ticks>)\/” where <ticks> is the number of milliseconds since midnight January 1, 1970. For example: "\/Date(1311170400000)\/". All values returned from Microsoft Dynamics CRM represent the Coordinated Universal Time (UTC) values so no offset information is included.

There are two strategies you can use to parse dates in records returned using the ODATA endpoint:

  • Use a reviver function with the JSON.parse method
  • Use String.replace to generate a date value from a string

Use a reviver function with the JSON.parse method

The JSON.parse method supports an optional reviver argument as described in the JSON.parse method documentation on MSDN. The following is an example that converts the string values that match a pattern defined in a regular expression into Date objects.

JScript Copy Code
var jsontext = '{ "hiredate": "\/Date(1311170400000)\/", "birthdate": "\/Date(-158342400000)\/" }';
var dates = JSON.parse(jsontext, dateReviver);
var string = dates.hiredate.toUTCString();
// The value of string is "Wed, 20 Jul 2011 14:00:00 UTC"

function dateReviver(key, value) {
 var a;
 if (typeof value === 'string') {
  a = /Date\(([-+]?\d+)\)/.exec(value);
  if (a) {
   return new Date(parseInt(value.replace("/Date(", "").replace(")/", ""), 10));
  }
 }
 return value;
};
Note
This code assumes that date values will always be UTC data values and won’t include any offset information.

Use String.replace to generate a date value from a string

If you don’t use the reviver argument with the JSON.parse method, the following example shows how you can generate a Date value from a string.

JScript Copy Code
var dateValue = new Date(parseInt(stringDateValue.replace("/Date(", "").replace(")/", ""), 10));

Display date values

After the string date values are converted to Date objects, you can use a variety of JavaScript methods, or create your own, to display the date as a string in a user interface. Because the JavaScript Date object is UTC aware, the dates displayed in your user interface using methods such as toString or toLocaleString will reflect the time zone settings of the user’s operating system.

However, notice that the values in your application might be different from the same values displayed in Microsoft Dynamics CRM, which doesn’t rely on the user’s operating system time zone settings. These values will be different when the user’s current operating system time zone preference doesn’t match the time zone preference saved in Microsoft Dynamics CRM. Microsoft Dynamics CRM also allows for setting personalized presentation options that won’t be applied by using standard JavaScript date functions like toString.

If you want to reconcile the displayed date and time values to match the values shown in Microsoft Dynamics CRM, you can query data stored in the UserSettings entity and entities like TimeZoneDefinition and TimeZoneRule to create functions to display dates that match the user’s preference. Microsoft Dynamics CRM doesn’t provide functions to perform these actions.

Update date values

When you change the values of a JavaScript date using standard set methods such as setMinutes or setHours, these changes are in the user’s local time. When you save the record, the actual UTC values are serialized and saved back to Microsoft Dynamics CRM. You don’t have to do anything to convert the dates to a UTC value.

When a Date is serialized, the format differs from the format that was used when the data is retrieved. As noted in Parsing Retrieved Data, dates are retrieved as strings that use the format "\/Date(1311179400000)\/". When you examine the results of JSON.stringify for date values to be passed back to the server, the format is "2013-07-20T16:30:00Z".

Set a date as criteria in a filter in a query

When you use a date value with a $filter system query option, you must use a UTC date. To convert a JavaScript Date object into the format expected for a filter, you have to process the date using a function such as the following example. The result is a string that matches the following format: datetime'2010-09-28T18:21:46:594Z' .

JScript Copy Code
function getODataUTCDateFilter(date) {

 var monthString;
 var rawMonth = (date.getUTCMonth()+1).toString();
 if (rawMonth.length == 1) {
  monthString = "0" + rawMonth;
 }
 else
 { monthString = rawMonth; }

 var dateString;
 var rawDate = date.getUTCDate().toString();
 if (rawDate.length == 1) {
  dateString = "0" + rawDate;
 }
 else
 { dateString = rawDate; }

 var DateFilter = "datetime\'";
 DateFilter += date.getUTCFullYear() + "-";
 DateFilter += monthString + "-";
 DateFilter += dateString;
 DateFilter += "T" + date.getUTCHours() + ":";
 DateFilter += date.getUTCMinutes() + ":";
 DateFilter += date.getUTCSeconds() + ":";
 DateFilter += date.getUTCMilliseconds();
 DateFilter += "Z\'";
 return DateFilter;
}

See Also

Reference

OData endpoint Http status codes
Associate Functions with Form and Field Events

Concepts

Use the OData endpoint with web resources
JavaScript libraries for Microsoft Dynamics CRM
Script (JScript) web resources

Other Resources

jQuery.ajax method
XMLHttpRequest Object
Technical Article: Using Option Set Options with the ODATA Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OData endpoint Http status codes

Http status codes returned by the REST endpoint are described in the following table. The status codes follow RFC 2616 Hypertext Transfer Protocol -- HTTP/1.1.

Status Code | Text | Cause
200 | OK | The request is served.
400 | Bad Request | The request could not be parsed successfully because of a syntactically or semantically incorrect URI.
401 | Unauthorized | Authentication is required and has not been provided.
403 | Forbidden | User does not have privileges to access the entity
404 | Record Not Found | The record does not exist for the given query. OR The length of the URI exceeds the maximum allowed length for the browser. For Internet Explorer7 & 8 this is 2,048 characters.
405 | Method Not Allowed | A request cannot be used for this record.
406 | Not Acceptable | The requested format specified in the accept header cannot be satisfied for the entity/entity container/entity set.
413 | Request Entity Too Large | The request attempts to set too much data, or the requested range contains too many rows, returned data is too big.
500 | Internal Server Error | Internal Error
503 | Service Unavailable | Service Unavailable

See Also

Reference

OData endpoint Http status codes

Concepts

Use the OData endpoint with Ajax and JScript web resources
Use the OData endpoint with web resources
Perform basic data operations using the OData endpoint

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\JS\RESTEndpoint\JavaScriptRESTDataOperations

If you just want to see how this sample works you can install (import) the JavaScriptRESTDataOperations_1_0_0_1_managed.zip managed solution included in the download files. After you install this managed solution, view the solution configuration page to observe the actions performed.

If you install this managed solution and want to create the web resources using the names in this topic, your solution publisher customization prefix cannot be “sample” unless you uninstall (delete) the managed solution.

Requirements

This sample uses the following web resources:

sample_/JavaScriptRESTDataOperationsSample.htm

An HTML page that contains the UI elements for this sample.

sample_/Scripts/JavaScriptRESTDataOperationsSample

A library that contains functions to manage the UI elements on the page and includes the actions performed by the sample.

sample_/Scripts/SDK.REST.js

A reusable, generic library that simplifies asynchronous data operations using the REST Endpoint for web resources.

Note
The customization prefix “sample_” is not used in code. These samples will work using the customization prefix from any publisher. However, the relative path of the simulated Scripts folder must be included in the name of the web resources.

Demonstrates

This sample:

  • Shows how to perform the most basic data operations using the REST endpoint and JavaScript.
  • Uses the XMLHttpRequest object included with browsers supported by Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.
  • Sequentially executes the operations on a new account record. When you run the sample you will have the choice to delete the record that you created.
  • Displays the results similar to the following when you preview the sample_/JavaScriptRESTDataOperationsSample.htm web resource:

    1. Setting the primary contact to: <the full name of the first Contact record in your system>.
    2. Setting Preferred Contact Method to E-mail.
    3. Setting Annual Revenue to Two Million .
    4. Setting Contact Method Phone to "Do Not Allow".
    5. The account named "Test Account Name" was created with the AccountId : "7780cef2-fdf4-e011-9d26-00155dba3819".
    6. Retrieving account with the AccountId: "7780cef2-fdf4-e011-9d26-00155dba3819".
    7. Retrieved the account named "Test Account Name". This account was created on : "Wed Oct 12 11:13:56 PDT 2011".
    8. Changing the account Name to "Updated Account Name".
    9. Adding Address information
    10. Setting E-Mail address
    11. The account record changes were saved
    12. You chose to delete the account record.
    13. The account was deleted.

sample_/JavaScriptRESTDataOperationsSample.htm

This page provides some explanation and the buttons to start and reset the sample.

Copy Code
<html lang="en-us">
<head>
 <title>JavaScript REST Data Operations</title>
 <meta http-equiv="X-UA-Compatible" content="IE=edge" />
<!-- /WebResources/ClientGlobalContext.js.aspx is accessed using a relative path
because the name of the Web Resource created from this file is "sample_/JavaScriptRESTDataOperationsSample.htm".

The use of the backslash within the name creates a virtual folder that must be considered
in relative links between Web Resources.
-->
 <script src="../ClientGlobalContext.js.aspx"></script>
 <script src="Scripts/SDK.REST.js" type="text/javascript"></script>
 <script src="Scripts/JavaScriptRESTDataOperationsSample.js" type="text/javascript"></script>

</head>
<body style="background-color: White; font-family:Segoe UI;">
<h1>JavaScript REST Endpoint Data Operations Sample</h1>
<p>This page uses the <b>sample_/Scripts/JavaScriptRESTDataOperationsSample.js</b> JScript library to create, retrieve, and update an
 account record. It also provides the option to delete or view the record.</p>
<p>The <b>sample_/Scripts/JavaScriptRESTDataOperationsSample.js</b> JScript library uses the <b>sample_/Scripts/SDK.REST.js</b> JScript library to perform the data operations.</p>
<p>Use the buttons below to verify the functionality of this sample.</p>
 <button id="start" title="Click this button to start the sample.">
  Start</button>
 <button id="reset" title="Click this button to reset the sample." disabled="disabled">
  Reset</button>
 <ol id="output">
 </ol>
</body>
</html>

sample_/Scripts/JavaScriptRESTDataOperationsSample

This library contains functions to manage the UI elements on the page and includes the actions performed by the sample. Functions in this library depend on reusable, generic methods found in sample_/Scripts/SDK.REST.js.

JScript Copy Code
var primaryContact = null;
var startButton;
var resetButton;
var output; //The <ol> element used by the writeMessage function to display text showing the progress of this sample.

document.onreadystatechange = function () {
 if (document.readyState == "complete") {
  getFirstContactToBePrimaryContact();

  startButton = document.getElementById("start");
  resetButton = document.getElementById("reset");
  output = document.getElementById("output");

  startButton.onclick = createAccount;
  resetButton.onclick = resetSample;
 }
}

function createAccount() {
 var account = {};
 account.Name = "Test Account Name";
 account.Description = "This account was created by the JavaScriptRESTDataOperations sample.";
 if (primaryContact != null) {
  //Set a lookup value
  writeMessage("Setting the primary contact to: " + primaryContact.FullName + ".");
  account.PrimaryContactId = { Id: primaryContact.ContactId, LogicalName: "contact", Name: primaryContact.FullName };

 }
 //Set a picklist value
 writeMessage("Setting Preferred Contact Method to E-mail.");
 account.PreferredContactMethodCode = { Value: 2 }; //E-mail

 //Set a money value
 writeMessage("Setting Annual Revenue to Two Million .");
 account.Revenue = { Value: "2000000.00" }; //Set Annual Revenue

 //Set a Boolean value
 writeMessage("Setting Contact Method Phone to \"Do Not Allow\".");
 account.DoNotPhone = true; //Do Not Allow

 //Add Two Tasks
 var today = new Date();
 var startDate = new Date(today.getFullYear(), today.getMonth(), today.getDate() + 3); //Set a date three days in the future.

 var LowPriTask = { Subject: "Low Priority Task", ScheduledStart: startDate, PriorityCode: { Value: 0} }; //Low Priority Task
 var HighPriTask = { Subject: "High Priority Task", ScheduledStart: startDate, PriorityCode: { Value: 2} }; //High Priority Task
 account.Account_Tasks = [LowPriTask, HighPriTask]

 //Create the Account
 SDK.REST.createRecord(
     account,
     "Account",
     function (account) {
      writeMessage("The account named \"" + account.Name + "\" was created with the AccountId : \"" + account.AccountId + "\".");
      writeMessage("Retrieving account with the AccountId: \"" + account.AccountId + "\".");
      retrieveAccount(account.AccountId)
     },
     errorHandler
   );
 this.setAttribute("disabled", "disabled");
}

function retrieveAccount(AccountId) {
 SDK.REST.retrieveRecord(
     AccountId,
     "Account",
     null,null,
     function (account) {
      writeMessage("Retrieved the account named \"" + account.Name + "\". This account was created on : \"" + account.CreatedOn + "\".");
      updateAccount(AccountId);
     },
     errorHandler
   );
}

function updateAccount(AccountId) {
 var account = {};
 writeMessage("Changing the account Name to \"Updated Account Name\".");
 account.Name = "Updated Account Name";
 writeMessage("Adding Address information");
 account.Address1_AddressTypeCode = { Value: 3 }; //Address 1: Address Type = Primary
 account.Address1_City = "Sammamish";
 account.Address1_Line1 = "123 Maple St.";
 account.Address1_PostalCode = "98074";
 account.Address1_StateOrProvince = "WA";
 writeMessage("Setting E-Mail address");
 account.EMailAddress1 = "someone@microsoft.com";

 SDK.REST.updateRecord(
     AccountId,
     account,
     "Account",
     function () {
      writeMessage("The account record changes were saved");
      deleteAccount(AccountId);
     },
     errorHandler
   );
}

function deleteAccount(AccountId) {
 if (confirm("Do you want to delete this account record?")) {
  writeMessage("You chose to delete the account record.");
  SDK.REST.deleteRecord(
       AccountId,
       "Account",
       function () {
        writeMessage("The account was deleted.");
        enableResetButton();
       },
       errorHandler
     );
 }
 else {
  var li = document.createElement("li");

  var span = document.createElement("span");

  setElementText(span, "You chose not to delete the record. You can view the record ");

  var link = document.createElement("a");
  link.href = SDK.REST._getClientUrl() + "/main.aspx?etc=1&id=%7b" + AccountId + "%7d&pagetype=entityrecord";
  link.target = "_blank";
  setElementText(link, "here");

  li.appendChild(span);
  li.appendChild(link);
  output.appendChild(li);
  enableResetButton();

 }
}

function getFirstContactToBePrimaryContact() {

 SDK.REST.retrieveMultipleRecords(
     "Contact",
     "$select=ContactId,FullName&$top=1",
     function (results) {
      var firstResult = results[0];
      if (firstResult != null) {
       primaryContact = results[0];
      }
      else {
       writeMessage("No Contact records are available to set as the primary contact for the account.");
      }
     },
     errorHandler,
     function () {
     //OnComplete handler
      }
   );
}

function errorHandler(error) {
 writeMessage(error.message);
}

function enableResetButton() {
 resetButton.removeAttribute("disabled");
}

function resetSample() {
 output.innerHTML = "";
 startButton.removeAttribute("disabled");
 resetButton.setAttribute("disabled", "disabled");
}

//Helper function to write data to this page:
function writeMessage(message) {
    var li = document.createElement("li");

    setElementText(li, message);

 output.appendChild(li);
}
//Because Firefox doesn't  support innerText
function setElementText(element, text)
{
    if (element.innerText != undefined)
    {
        element.innerText = text;
    }
    else
    {
        element.textContent = text;
    }
}

sample_/Scripts/SDK.REST.js

This library contains public methods for the following operations:

  • SDK.REST.createRecord
  • SDK.REST.retrieveRecord
  • SDK.REST.updateRecord
  • SDK.REST.deleteRecord
  • SDK.REST.retrieveMultipleRecords
  • SDK.REST.associateRecords
  • SDK.REST.disassociateRecords

Each of these methods includes a successCallback and errorCallback parameter. These parameters accept a reference to a function that will be called when the data operation succeeds or fails. For examples that use the SDK.REST.associateRecords and SDK.REST.disassociateRecords methods, see Sample: Associate and disassociate records using the OData endpoint with JavaScript.

JScript Copy Code
if (typeof (SDK) == "undefined")
{ SDK = { __namespace: true }; }
SDK.REST = {
 _context: function () {
  ///<summary>
  /// Private function to the context object.
  ///</summary>
  ///<returns>Context</returns>
  if (typeof GetGlobalContext != "undefined")
  { return GetGlobalContext(); }
  else {
   if (typeof Xrm != "undefined") {
    return Xrm.Page.context;
   }
   else
   { throw new Error("Context is not available."); }
  }
 },
 _getClientUrl: function () {
  ///<summary>
  /// Private function to return the server URL from the context
  ///</summary>
  ///<returns>String</returns>
  var clientUrl = this._context().getClientUrl()

  return clientUrl;
 },
 _ODataPath: function () {
  ///<summary>
  /// Private function to return the path to the REST endpoint.
  ///</summary>
  ///<returns>String</returns>
  return this._getClientUrl() + "/XRMServices/2011/OrganizationData.svc/";
 },
 _errorHandler: function (req) {
  ///<summary>
  /// Private function return an Error object to the errorCallback
  ///</summary>
  ///<param name="req" type="XMLHttpRequest">
  /// The XMLHttpRequest response that returned an error.
  ///</param>
  ///<returns>Error</returns>
  //Error descriptions come from http://support.microsoft.com/kb/193625
  if (req.status == 12029)
  { return new Error("The attempt to connect to the server failed."); }
  if (req.status == 12007)
  { return new Error("The server name could not be resolved."); }
  var errorText;
  try
        { errorText = JSON.parse(req.responseText).error.message.value; }
  catch (e)
        { errorText = req.responseText }

  return new Error("Error : " +
        req.status + ": " +
        req.statusText + ": " + errorText);
 },
 _dateReviver: function (key, value) {
  ///<summary>
  /// Private function to convert matching string values to Date objects.
  ///</summary>
  ///<param name="key" type="String">
  /// The key used to identify the object property
  ///</param>
  ///<param name="value" type="String">
  /// The string value representing a date
  ///</param>
  var a;
  if (typeof value === 'string') {
   a = /Date\(([-+]?\d+)\)/.exec(value);
   if (a) {
    return new Date(parseInt(value.replace("/Date(", "").replace(")/", ""), 10));
   }
  }
  return value;
 },
 _parameterCheck: function (parameter, message) {
  ///<summary>
  /// Private function used to check whether required parameters are null or undefined
  ///</summary>
  ///<param name="parameter" type="Object">
  /// The parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if ((typeof parameter === "undefined") || parameter === null) {
   throw new Error(message);
  }
 },
 _stringParameterCheck: function (parameter, message) {
  ///<summary>
  /// Private function used to check whether required parameters are null or undefined
  ///</summary>
  ///<param name="parameter" type="String">
  /// The string parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if (typeof parameter != "string") {
   throw new Error(message);
  }
 },
 _callbackParameterCheck: function (callbackParameter, message) {
  ///<summary>
  /// Private function used to check whether required callback parameters are functions
  ///</summary>
  ///<param name="callbackParameter" type="Function">
  /// The callback parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if (typeof callbackParameter != "function") {
   throw new Error(message);
  }
 },
 createRecord: function (object, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to create a new record.
  ///</summary>
  ///<param name="object" type="Object">
  /// A JavaScript object with properties corresponding to the Schema name of
  /// entity attributes that are valid for create operations.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to create.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function can accept the returned record as a parameter.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._parameterCheck(object, "SDK.REST.createRecord requires the object parameter.");
  this._stringParameterCheck(type, "SDK.REST.createRecord requires the type parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.createRecord requires the successCallback is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.createRecord requires the errorCallback is a function.");
  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + type + "Set"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 201) {
     successCallback(JSON.parse(this.responseText, SDK.REST._dateReviver).d);
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send(JSON.stringify(object));
 },
 retrieveRecord: function (id, type, select, expand, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to retrieve a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to retrieve.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="select" type="String">
  /// A String representing the $select OData System Query Option to control which
  /// attributes will be returned. This is a comma separated list of Attribute names that are valid for retrieve.
  /// If null all properties for the record will be returned
  ///</param>
  ///<param name="expand" type="String">
  /// A String representing the $expand OData System Query Option value to control which
  /// related records are also returned. This is a comma separated list of of up to 6 entity relationship names
  /// If null no expanded related records will be returned.
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function must accept the returned record as a parameter.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(id, "SDK.REST.retrieveRecord requires the id parameter is a string.");
  this._stringParameterCheck(type, "SDK.REST.retrieveRecord requires the type parameter is a string.");
  if (select != null)
   this._stringParameterCheck(select, "SDK.REST.retrieveRecord requires the select parameter is a string.");
  if (expand != null)
   this._stringParameterCheck(expand, "SDK.REST.retrieveRecord requires the expand parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.retrieveRecord requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.retrieveRecord requires the errorCallback parameter is a function.");

  var systemQueryOptions = "";

  if (select != null || expand != null) {
   systemQueryOptions = "?";
   if (select != null) {
    var selectString = "$select=" + select;
    if (expand != null) {
     selectString = selectString + "," + expand;
    }
    systemQueryOptions = systemQueryOptions + selectString;
   }
   if (expand != null) {
    systemQueryOptions = systemQueryOptions + "&$expand=" + expand;
   }
  }

  var req = new XMLHttpRequest();
  req.open("GET", encodeURI(this._ODataPath() + type + "Set(guid'" + id + "')" + systemQueryOptions), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 200) {
     successCallback(JSON.parse(this.responseText, SDK.REST._dateReviver).d);
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();
 },
 updateRecord: function (id, object, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to update a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to retrieve.
  ///</param>
  ///<param name="object" type="Object">
  /// A JavaScript object with properties corresponding to the Schema Names for
  /// entity attributes that are valid for update operations.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(id, "SDK.REST.updateRecord requires the id parameter.");
  this._parameterCheck(object, "SDK.REST.updateRecord requires the object parameter.");
  this._stringParameterCheck(type, "SDK.REST.updateRecord requires the type parameter.");
  this._callbackParameterCheck(successCallback, "SDK.REST.updateRecord requires the successCallback is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.updateRecord requires the errorCallback is a function.");
  var req = new XMLHttpRequest();

  req.open("POST", encodeURI(this._ODataPath() + type + "Set(guid'" + id + "')"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.setRequestHeader("X-HTTP-Method", "MERGE");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send(JSON.stringify(object));
 },
 deleteRecord: function (id, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to delete a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to delete.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to delete.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(id, "SDK.REST.deleteRecord requires the id parameter.");
  this._stringParameterCheck(type, "SDK.REST.deleteRecord requires the type parameter.");
  this._callbackParameterCheck(successCallback, "SDK.REST.deleteRecord requires the successCallback is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.deleteRecord requires the errorCallback is a function.");
  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + type + "Set(guid'" + id + "')"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.setRequestHeader("X-HTTP-Method", "DELETE");
  req.onreadystatechange = function () {

   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();

 },
 retrieveMultipleRecords: function (type, options, successCallback, errorCallback, OnComplete) {
  ///<summary>
  /// Sends an asynchronous request to retrieve records.
  ///</summary>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="options" type="String">
  /// A String representing the OData System Query Options to control the data returned
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called for each page of records returned.
  /// Each page is 50 records. If you expect that more than one page of records will be returned,
  /// this function should loop through the results and push the records into an array outside of the function.
  /// Use the OnComplete event handler to know when all the records have been processed.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  ///<param name="OnComplete" type="Function">
  /// The function that will be called when all the requested records have been returned.
  /// No parameters are passed to this function.
  /// </param>
  this._stringParameterCheck(type, "SDK.REST.retrieveMultipleRecords requires the type parameter is a string.");
  if (options != null)
   this._stringParameterCheck(options, "SDK.REST.retrieveMultipleRecords requires the options parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.retrieveMultipleRecords requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.retrieveMultipleRecords requires the errorCallback parameter is a function.");
  this._callbackParameterCheck(OnComplete, "SDK.REST.retrieveMultipleRecords requires the OnComplete parameter is a function.");

  var optionsString;
  if (options != null) {
   if (options.charAt(0) != "?") {
    optionsString = "?" + options;
   }
   else
   { optionsString = options; }
  }
  var req = new XMLHttpRequest();
  req.open("GET", this._ODataPath() + type + "Set" + optionsString, true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 200) {
     var returned = JSON.parse(this.responseText, SDK.REST._dateReviver).d;
     successCallback(returned.results);
     if (returned.__next != null) {
      var queryOptions = returned.__next.substring((SDK.REST._ODataPath() + type + "Set").length);
      SDK.REST.retrieveMultipleRecords(type, queryOptions, successCallback, errorCallback, OnComplete);
     }
     else
     { OnComplete(); }
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();
 },
 associateRecords: function (parentId, parentType, relationshipName, childId, childType, successCallback, errorCallback) {
  this._stringParameterCheck(parentId, "SDK.REST.associateRecords requires the parentId parameter is a string.");
  ///<param name="parentId" type="String">
  /// The Id of the record to be the parent record in the relationship
  /// </param>
  ///<param name="parentType" type="String">
  /// The Schema Name of the Entity type for the parent record.
  /// For an Account record, use "Account"
  /// </param>
  ///<param name="relationshipName" type="String">
  /// The Schema Name of the Entity Relationship to use to associate the records.
  /// To associate account records as a Parent account, use "Referencedaccount_parent_account"
  /// </param>
  ///<param name="childId" type="String">
  /// The Id of the record to be the child record in the relationship
  /// </param>
  ///<param name="childType" type="String">
  /// The Schema Name of the Entity type for the child record.
  /// For an Account record, use "Account"
  /// </param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(parentType, "SDK.REST.associateRecords requires the parentType parameter is a string.");
  this._stringParameterCheck(relationshipName, "SDK.REST.associateRecords requires the relationshipName parameter is a string.");
  this._stringParameterCheck(childId, "SDK.REST.associateRecords requires the childId parameter is a string.");
  this._stringParameterCheck(childType, "SDK.REST.associateRecords requires the childType parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.associateRecords requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.associateRecords requires the errorCallback parameter is a function.");

  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + parentType + "Set(guid'" + parentId + "')/$links/" + relationshipName), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  var childEntityReference = {}
  childEntityReference.uri = this._ODataPath() + "/" + childType + "Set(guid'" + childId + "')";
  req.send(JSON.stringify(childEntityReference));
 },
 disassociateRecords: function (parentId, parentType, relationshipName, childId, successCallback, errorCallback) {
  this._stringParameterCheck(parentId, "SDK.REST.disassociateRecords requires the parentId parameter is a string.");
  ///<param name="parentId" type="String">
  /// The Id of the record to be the parent record in the relationship
  /// </param>
  ///<param name="parentType" type="String">
  /// The Schema Name of the Entity type for the parent record.
  /// For an Account record, use "Account"
  /// </param>
  ///<param name="relationshipName" type="String">
  /// The Schema Name of the Entity Relationship to use to disassociate the records.
  /// To disassociate account records as a Parent account, use "Referencedaccount_parent_account"
  /// </param>
  ///<param name="childId" type="String">
  /// The Id of the record to be disassociated as the child record in the relationship
  /// </param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(parentType, "SDK.REST.disassociateRecords requires the parentType parameter is a string.");
  this._stringParameterCheck(relationshipName, "SDK.REST.disassociateRecords requires the relationshipName parameter is a string.");
  this._stringParameterCheck(childId, "SDK.REST.disassociateRecords requires the childId parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.disassociateRecords requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.disassociateRecords requires the errorCallback parameter is a function.");

  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + parentType + "Set(guid'" + parentId + "')/$links/" + relationshipName + "(guid'" + childId + "')"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.setRequestHeader("X-HTTP-Method", "DELETE");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();
 },
 __namespace: true
};

See Also

Concepts

Use the OData endpoint with web resources

Other Resources

Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript and jQuery
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript and jQuery

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\JS\RESTEndpoint\JQueryRESTDataOperations

Important
We don’t recommend using jQuery in form scripts or ribbon commands. See Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript for a sample library that has the same capabilities without a dependency on jQuery.

More information: Use of jQuery.

Note
If you just want to see how this sample works you can install (import) the JQueryRESTDataOperations_1_0_1_2_managed.zip managed solution included in the download files. This installs the JQuery REST Data Operations solution. If you install this managed solution and want to create the web resources using the names below, your solution publisher customization prefix can’t be “sample” unless you uninstall (delete) the managed solution.

Requirements

This sample uses the following web resources:

sample_/JQueryRESTDataOperations.htm

Use this HTML page to start the sample and view the progress of the actions. This page is the configuration page for the JQuery REST Data Operations solution.

sample_/Scripts/jquery1.9.1.min.js

The minimized version of jQuery included with Microsoft Visual Studio web application projects. The content of this library is not included here.

sample_/Scripts/JQueryRESTDataOperationsSample.js

A JScript web resource that performs the operations. This library depends on the SDK.JQuery.js library.

sample_/Scripts/SDK.JQuery.js

A JScript web resource that contains a reusable library to perform actions with the REST endpoint using JQuery.

Note
A similar library without the dependency on JQuery is available in the Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript.

Note
The customization prefix “sample_” is not used in code. These samples will work using the customization prefix from any publisher. However, the relative path of the simulated Scripts folder must be included in the name of the web resources.

Demonstrates

This sample:

  • Performs create, retrieve, update and delete operations using the REST endpoint with JScript and jQuery.
  • Uses jQuery, a popular library that includes capabilities to perform data operations using the $.ajax method.
  • Sequentially executes the operations on a new account record.
    When you run the sample you will have the choice to delete the record created.
  • Displays results similar to the following when you preview the web resource: sample_/JQueryRESTDataOperations.htm

    1. Setting the primary contact to:<the full name of the first Contact record in your system>.
    2. Setting Preferred Contact Method to Email.
    3. Setting Annual Revenue to Two Million.
    4. Setting Contact Method Phone to "Do Not Allow".
    5. The account named "Test Account Name" was created with the AccountId: "7780cef2-fdf4-e011-9d26-00155dba3819".
    6. Retrieving account with the AccountId: "7780cef2-fdf4-e011-9d26-00155dba3819".
    7. Retrieved the account named "Test Account Name". This account was created on: "Wed Oct 12 11:13:56 PDT 2011".
    8. Changing the account Name to "Updated Account Name".
    9. Adding Address information.
    10. Setting Email address.
    11. The account record changes were saved
    12. You chose to delete the account record.
    13. The account was deleted.

If you choose not to delete the account you’ll see a link to open the record you created.

sample_/JQueryRESTDataOperations.htm

This page provides some explanation and the buttons to start and reset the sample.

Copy Code
<html lang="en-us">
<head>
 <title>JQuery REST Data Operations</title>
 <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <script src="Scripts/jquery_1.9.1.min.js"></script>
 <script src="Scripts/SDK.JQuery.js" type="text/javascript"></script>
 <script src="Scripts/JQueryRESTDataOperationsSample.js" type="text/javascript"></script>

<!-- /WebResources/ClientGlobalContext.js.aspx is accessed using a relative path
because the name of the Web Resource created from this file is "sample_/JQueryRESTDataOperationsSample.htm".

The use of the backslash within the name creates a virtual folder that must be considered
in relative links between Web Resources.
-->
 <script type="text/javascript" src="../ClientGlobalContext.js.aspx"></script>

</head>
<body style="background-color: White; font-family:Segoe UI;">
<h1>JavaScript jQuery REST Data Operations Sample</h1>
<p>This page uses the <b>sample_/Scripts/JQueryRESTDataOperationsSample.js</b> JScript library to create, retrieve, and update an
 account record. It also provides the option to delete or view the record.</p>
<p>The <b>sample_/Scripts/JQueryRESTDataOperationsSample.js</b> JScript library uses the <b>sample_/Scripts/SDK.JQuery.js</b> JScript library to perform the data operations.</p>
<p>Use the buttons below to verify the functionality of this sample.</p>
 <button id="start" title="Click this button to start the sample.">
  Start</button>
 <button id="reset" title="Click this button to reset the sample." disabled="disabled">
  Reset</button>
 <ol id="output">
 </ol>
</body>
</html>

sample_/Scripts/JQueryRESTDataOperationsSample.js

This library contains functions to manage the UI elements on the page and includes the actions performed by the sample. Functions in this library depend on reusable, generic methods found in sample_/Scripts/SDK.JQuery.js.

JScript Copy Code
/// <reference path="SDK.JQuery.js" />
/// <reference path="jquery-1.9.1.js" />

var primaryContact = null;
var startButton;
var resetButton;
var output; //The <ol> element used by the writeMessage function to display text showing the progress of this sample.

$(function () {
 getFirstContactToBePrimaryContact();
 startButton = $("#start");
 startButton.click(createAccount);
 resetButton = $("#reset");
 resetButton.click(resetSample);
 output = $("#output");

});

function createAccount() {
 startButton.attr("disabled", "disabled");
 var account = {};
 account.Name = "Test Account Name";
 account.Description = "This account was created by the JQueryRESTDataOperations sample.";
 if (primaryContact != null) {
  //Set a lookup value
  writeMessage("Setting the primary contact to: " + primaryContact.FullName + ".");
  account.PrimaryContactId = { Id: primaryContact.ContactId, LogicalName: "contact", Name: primaryContact.FullName };

 }
 //Set a picklist value
 writeMessage("Setting Preferred Contact Method to E-mail.");
 account.PreferredContactMethodCode = { Value: 2 }; //E-mail

 //Set a money value
 writeMessage("Setting Annual Revenue to Two Million .");
 account.Revenue = { Value: "2000000.00" }; //Set Annual Revenue

 //Set a Boolean value
 writeMessage("Setting Contact Method Phone to \"Do Not Allow\".");
 account.DoNotPhone = true; //Do Not Allow

 //Add Two Tasks
 var today = new Date();
 var startDate = new Date(today.getFullYear(), today.getMonth(), today.getDate() + 3); //Set a date three days in the future.

 var LowPriTask = { Subject: "Low Priority Task", ScheduledStart: startDate, PriorityCode: { Value: 0} }; //Low Priority Task
 var HighPriTask = { Subject: "High Priority Task", ScheduledStart: startDate, PriorityCode: { Value: 2} }; //High Priority Task
 account.Account_Tasks = [LowPriTask, HighPriTask]

 //Create the Account
 SDK.JQuery.createRecord(
     account,
     "Account",
     function (account) {
      writeMessage("The account named \"" + account.Name + "\" was created with the AccountId : \"" + account.AccountId + "\".");
      writeMessage("Retrieving account with the AccountId: \"" + account.AccountId + "\".");
      retrieveAccount(account.AccountId)
     },
     errorHandler
   );

}

function retrieveAccount(AccountId) {
 SDK.JQuery.retrieveRecord(
     AccountId,
     "Account",
     null, null,
     function (account) {
      writeMessage("Retrieved the account named \"" + account.Name + "\". This account was created on : \"" + account.CreatedOn + "\".");
      updateAccount(AccountId);
     },
     errorHandler
   );
}

function updateAccount(AccountId) {
 var account = {};
 writeMessage("Changing the account Name to \"Updated Account Name\".");
 account.Name = "Updated Account Name";
 writeMessage("Adding Address information");
 account.Address1_AddressTypeCode = { Value: 3 }; //Address 1: Address Type = Primary
 account.Address1_City = "Sammamish";
 account.Address1_Line1 = "123 Maple St.";
 account.Address1_PostalCode = "98074";
 account.Address1_StateOrProvince = "WA";
 writeMessage("Setting E-Mail address");
 account.EMailAddress1 = "someone@microsoft.com";

 SDK.JQuery.updateRecord(
     AccountId,
     account,
     "Account",
     function () {
      writeMessage("The account record changes were saved");
      deleteAccount(AccountId);
     },
     errorHandler
   );
}

function deleteAccount(AccountId) {
 if (confirm("Do you want to delete this account record?")) {
  writeMessage("You chose to delete the account record.");
  SDK.JQuery.deleteRecord(
       AccountId,
       "Account",
       function () {
        writeMessage("The account was deleted.");
        enableResetButton();
       },
       errorHandler
     );
 }
 else {
  var urlToAccountRecord = SDK.JQuery._getClientUrl() + "/main.aspx?etc=1&id=%7b" + AccountId + "%7d&pagetype=entityrecord";
  $("<li><span>You chose not to delete the record. You can view the record </span><a href='" +
  urlToAccountRecord +
  "' target='_blank'>here</a></li>").appendTo(output);
  enableResetButton();
 }
}

function getFirstContactToBePrimaryContact() {

 SDK.JQuery.retrieveMultipleRecords(
     "Contact",
     "$select=ContactId,FullName&$top=1",
     function (results) {
      var firstResult = results[0];
      if (firstResult != null) {
       primaryContact = results[0];
      }
      else {
       writeMessage("No Contact records are available to set as the primary contact for the account.");
      }
     },
     errorHandler,
     function () {
      //OnComplete handler
     }
   );
}

function errorHandler(error) {
 writeMessage(error.message);
}

function enableResetButton() {
 resetButton.removeAttr("disabled");
}

function resetSample() {
 output.empty();
 startButton.removeAttr("disabled");
 resetButton.attr("disabled", "disabled");
}

//Helper function to write data to this page:
function writeMessage(message) {
 $("<li>" + message + "</li>").appendTo(output);
}

sample_/Scripts/SDK.JQuery.js

This library contains public methods for the following operations:

  • createRecord
  • retrieveRecord
  • updateRecord
  • deleteRecord
  • retrieveMultipleRecords

Each of these methods includes a successCallback and errorCallback parameter. These parameters accept a reference to a function that is called when the data operation succeeds or fails.

JScript Copy Code
/// <reference path="jquery1.4.1vsdoc.js" />

if (typeof (SDK) == "undefined")
{ SDK = { __namespace: true }; }
SDK.JQuery = {
 _context: function () {
  ///<summary>
  /// Private function to the context object.
  ///</summary>
  ///<returns>Context</returns>
  if (typeof GetGlobalContext != "undefined")
  { return GetGlobalContext(); }
  else {
   if (typeof Xrm != "undefined") {
    return Xrm.Page.context;
   }
   else
   { throw new Error("Context is not available."); }
  }
 },
 _getClientUrl: function () {
  ///<summary>
  /// Private function to return the server URL from the context
  ///</summary>
  ///<returns>String</returns>
  var serverUrl = this._context().getClientUrl()

  return serverUrl;
 },
 _ODataPath: function () {
  ///<summary>
  /// Private function to return the path to the REST endpoint.
  ///</summary>
  ///<returns>String</returns>
  return this._getClientUrl() + "/XRMServices/2011/OrganizationData.svc/";
 },
 _errorHandler: function (req) {
  ///<summary>
  /// Private function return an Error object to the errorCallback
  ///</summary>
  ///<param name="req" type="XMLHttpRequest">
  /// The XMLHttpRequest response that returned an error.
  ///</param>
  ///<returns>Error</returns>
  return new Error("Error : " +
        req.status + ": " +
        req.statusText + ": " +
        JSON.parse(req.responseText).error.message.value);
 },
 _dateReviver: function (key, value) {
  ///<summary>
  /// Private function to convert matching string values to Date objects.
  ///</summary>
  ///<param name="key" type="String">
  /// The key used to identify the object property
  ///</param>
  ///<param name="value" type="String">
  /// The string value representing a date
  ///</param>
  var a;
  if (typeof value === 'string') {
   a = /Date\(([-+]?\d+)\)/.exec(value);
   if (a) {
    return new Date(parseInt(value.replace("/Date(", "").replace(")/", ""), 10));
   }
  }
  return value;
 },
 _parameterCheck: function (parameter, message) {
  ///<summary>
  /// Private function used to check whether required parameters are null or undefined
  ///</summary>
  ///<param name="parameter" type="Object">
  /// The parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if ((typeof parameter === "undefined") || parameter === null) {
   throw new Error(message);
  }
 },
 _stringParameterCheck: function (parameter, message) {
  ///<summary>
  /// Private function used to check whether required parameters are null or undefined
  ///</summary>
  ///<param name="parameter" type="String">
  /// The string parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if (typeof parameter != "string") {
   throw new Error(message);
  }
 },
 _callbackParameterCheck: function (callbackParameter, message) {
  ///<summary>
  /// Private function used to check whether required callback parameters are functions
  ///</summary>
  ///<param name="callbackParameter" type="Function">
  /// The callback parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if (typeof callbackParameter != "function") {
   throw new Error(message);
  }
 },
 createRecord: function (object, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to create a new record.
  ///</summary>
  ///<param name="object" type="Object">
  /// A JavaScript object with properties corresponding to the Schema name of
  /// entity attributes that are valid for create operations.
  ///</param>
  this._parameterCheck(object, "SDK.JQuery.createRecord requires the object parameter.");
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to create.
  /// For an Account record, use "Account"
  ///</param>
  this._stringParameterCheck(type, "SDK.JQuery.createRecord requires the type parameter is a string.");
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function can accept the returned record as a parameter.
  /// </param>
  this._callbackParameterCheck(successCallback, "SDK.JQuery.createRecord requires the successCallback is a function.");
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._callbackParameterCheck(errorCallback, "SDK.JQuery.createRecord requires the errorCallback is a function.");

  var jsonEntity = window.JSON.stringify(object);

  $.ajax({ type: "POST",
   contentType: "application/json; charset=utf-8",
   datatype: "json",
   url: this._ODataPath() + type + "Set",
   data: jsonEntity,
   beforeSend: function (xhr) {
    //Specifying this header ensures that the results will be returned as JSON.
    xhr.setRequestHeader("Accept", "application/json");
   },
   success: function (data, textStatus, xhr) {
    successCallback(data.d);
   },
   error: function (xhr, textStatus, errorThrown) {
    errorCallback(SDK.JQuery._errorHandler(xhr));
   }
  });
 },
 retrieveRecord: function (id, type, select, expand, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to retrieve a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to retrieve.
  ///</param>
  this._stringParameterCheck(id, "SDK.JQuery.retrieveRecord requires the id parameter is a string.");
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  this._stringParameterCheck(type, "SDK.JQuery.retrieveRecord requires the type parameter is a string.");
  ///<param name="select" type="String">
  /// A String representing the $select OData System Query Option to control which
  /// attributes will be returned. This is a comma separated list of Attribute names that are valid for retrieve.
  /// If null all properties for the record will be returned
  ///</param>
  if (select != null)
   this._stringParameterCheck(select, "SDK.JQuery.retrieveRecord requires the select parameter is a string.");
  ///<param name="expand" type="String">
  /// A String representing the $expand OData System Query Option value to control which
  /// related records are also returned. This is a comma separated list of of up to 6 entity relationship names
  /// If null no expanded related records will be returned.
  ///</param>
  if (expand != null)
   this._stringParameterCheck(expand, "SDK.JQuery.retrieveRecord requires the expand parameter is a string.");
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function must accept the returned record as a parameter.
  /// </param>
  this._callbackParameterCheck(successCallback, "SDK.JQuery.retrieveRecord requires the successCallback parameter is a function.");
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._callbackParameterCheck(errorCallback, "SDK.JQuery.retrieveRecord requires the errorCallback parameter is a function.");

  var systemQueryOptions = "";

  if (select != null || expand != null) {
   systemQueryOptions = "?";
   if (select != null) {
    var selectString = "$select=" + select;
    if (expand != null) {
     selectString = selectString + "," + expand;
    }
    systemQueryOptions = systemQueryOptions + selectString;
   }
   if (expand != null) {
    systemQueryOptions = systemQueryOptions + "&$expand=" + expand;
   }
  }

  $.ajax({
   type: "GET",
   contentType: "application/json; charset=utf-8",
   datatype: "json",
   url: this._ODataPath() + type + "Set" + "(guid'" + id + "')" + systemQueryOptions,
   beforeSend: function (xhr) {
    //Specifying this header ensures that the results will be returned as JSON.
    xhr.setRequestHeader("Accept", "application/json");
   },
   success: function (data, textStatus, xhr) {
    //JQuery does not provide an opportunity to specify a date reviver so this code
   // parses the xhr.responseText rather than use the data parameter passed by JQuery.
    successCallback(JSON.parse(xhr.responseText, SDK.JQuery._dateReviver).d);
   },
   error: function (xhr, textStatus, errorThrown) {
    errorCallback(SDK.JQuery._errorHandler(xhr));
   }
  });
 },
 updateRecord: function (id, object, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to update a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to retrieve.
  ///</param>
  this._stringParameterCheck(id, "SDK.JQuery.updateRecord requires the id parameter.");
  ///<param name="object" type="Object">
  /// A JavaScript object with properties corresponding to the Schema Names for
  /// entity attributes that are valid for update operations.
  ///</param>
  this._parameterCheck(object, "SDK.JQuery.updateRecord requires the object parameter.");
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  this._stringParameterCheck(type, "SDK.JQuery.updateRecord requires the type parameter.");
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  this._callbackParameterCheck(successCallback, "SDK.JQuery.updateRecord requires the successCallback is a function.");
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._callbackParameterCheck(errorCallback, "SDK.JQuery.updateRecord requires the errorCallback is a function.");

  var jsonEntity = window.JSON.stringify(object);

  $.ajax({
   type: "POST",
   contentType: "application/json; charset=utf-8",
   datatype: "json",
   data: jsonEntity,
   url: this._ODataPath() + type + "Set" + "(guid'" + id + "')",
   beforeSend: function (xhr) {
    //Specifying this header ensures that the results will be returned as JSON.
    xhr.setRequestHeader("Accept", "application/json");
    //Specify the HTTP method MERGE to update just the changes you are submitting.
    xhr.setRequestHeader("X-HTTP-Method", "MERGE");
   },
   success: function (data, textStatus, xhr) {
   //Nothing is returned to the success function
    successCallback();
   },
   error: function (xhr, textStatus, errorThrown) {
    errorCallback(SDK.JQuery._errorHandler(xhr));
   }
  });
 },
 deleteRecord: function (id, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to delete a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to delete.
  ///</param>
  this._stringParameterCheck(id, "SDK.JQuery.deleteRecord requires the id parameter.");
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to delete.
  /// For an Account record, use "Account"
  ///</param>
  this._stringParameterCheck(type, "SDK.JQuery.deleteRecord requires the type parameter.");
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  this._callbackParameterCheck(successCallback, "SDK.JQuery.deleteRecord requires the successCallback is a function.");
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._callbackParameterCheck(errorCallback, "SDK.JQuery.deleteRecord requires the errorCallback is a function.");

  $.ajax({
   type: "POST",
   contentType: "application/json; charset=utf-8",
   datatype: "json",
   url: this._ODataPath() + type + "Set(guid'" + id + "')",
   beforeSend: function (XMLHttpRequest) {
    //Specifying this header ensures that the results will be returned as JSON.
    XMLHttpRequest.setRequestHeader("Accept", "application/json");
    //Specify the HTTP method DELETE to perform a delete operation.
    XMLHttpRequest.setRequestHeader("X-HTTP-Method", "DELETE");
   },
   success: function (data, textStatus, xhr) {
   // Nothing is returned to the success function.
    successCallback();
   },
   error: function (xhr, textStatus, errorThrown) {
    errorCallback(SDK.JQuery._errorHandler(xhr));
   }
  });
 },
 retrieveMultipleRecords: function (type, options, successCallback, errorCallback, OnComplete) {
  ///<summary>
  /// Sends an asynchronous request to retrieve records.
  ///</summary>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type records to retrieve
  /// For an Account record, use "Account"
  ///</param>
  this._stringParameterCheck(type, "SDK.JQuery.retrieveMultipleRecords requires the type parameter is a string.");
  ///<param name="options" type="String">
  /// A String representing the OData System Query Options to control the data returned
  /// Do not include the $top option, use the top parameters to set the maximum number of records to return.
  ///</param>
  if (options != null)
   this._stringParameterCheck(options, "SDK.JQuery.retrieveMultipleRecords requires the options parameter is a string.");
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called for each page of records returned.
  /// This function should loop through the results and push the records into an array.
  /// </param>
  this._callbackParameterCheck(successCallback, "SDK.JQuery.retrieveMultipleRecords requires the successCallback parameter is a function.");
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._callbackParameterCheck(errorCallback, "SDK.JQuery.retrieveMultipleRecords requires the errorCallback parameter is a function.");
  ///<param name="OnComplete" type="Function">
  /// The function that will be called when all the requested records have been returned.
  /// No parameters are passed to this function.
  /// </param>
  this._callbackParameterCheck(OnComplete, "SDK.JQuery.retrieveMultipleRecords requires the OnComplete parameter is a function.");

  var optionsString;
  if (options != null) {
   if (options.charAt(0) != "?") {
    optionsString = "?" + options;
   }
   else
   { optionsString = options; }
  }

  $.ajax({
   type: "GET",
   contentType: "application/json; charset=utf-8",
   datatype: "json",
   url: this._ODataPath() + type + "Set" + optionsString,
   beforeSend: function (XMLHttpRequest) {
    //Specifying this header ensures that the results will be returned as JSON.
    XMLHttpRequest.setRequestHeader("Accept", "application/json");
   },
   success: function (data, textStatus, xhr) {
    if (data && data.d && data.d.results) {
     successCallback(JSON.parse(xhr.responseText, SDK.JQuery._dateReviver).d.results);
     if (data.d.__next != null) {
      var queryOptions = data.d.__next.substring((SDK.JQuery._ODataPath() + type + "Set").length);
      SDK.JQuery.retrieveMultipleRecords(type, queryOptions, successCallback, errorCallback, OnComplete);
     }
     else
     { OnComplete(); }
    }
   },
   error: function (xhr, textStatus, errorThrown) {
    errorCallback(SDK.JQuery._errorHandler(xhr));
   }
  });
 },
 __namespace: true
};

See Also

Concepts

Use the OData endpoint with web resources

Other Resources

Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript
Sample: Retrieve multiple records using the OData endpoint with JavaScript
JQuery
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve multiple records using the OData endpoint with JavaScript

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK/SampleCode/JS/RESTEndpoint/JavaScriptRESTRetrieveMultiple

If you just want to see how this sample works you can install (import) the JavaScriptRESTRetrieveMultiple_1_0_0_0_managed.zip managed solution included in the download files. If you install this managed solution and want to create the Web resources using the names below, your solution publisher customization prefix cannot be “sample” unless you uninstall (delete) the managed solution.

Requirements

You can view this sample in the configuration page for the solution after you install it.

Sample User Interface

This sample uses the following four Web resources:

sample_/JavaScriptRESTRetrieveMultiple.htm

An HTML page that provides the user interface and functions to call the SDK.REST.retrieveMultipleRecords function to retrieve data. This page is set as the configuration page for the sample solution.

sample_/Scripts/SDK.REST.js

This JavaScript library provides the SDK.REST.retrieveMultipleRecords function as well as other functions for using the REST endpoint for web resources.

sample_/Styles/JavaScriptRESTRetrieveMultiple.css

This Cascading Style Sheet file provides styles for sample_/JavaScriptRESTRetrieveMultiple.htm.

Note
The customization prefix ” sample_” is not used in code. These samples will work using the customization prefix from any publisher. However the relative path of the simulated Scripts and Styles folder must be included in the name of the Web resources.

Demonstrates

By default the number of records returned by the REST Endpoint is limited to 50 records. This sample shows how to retrieve multiple records without regard to this limitation.

This sample uses the following approach:

  1. The document.onreadystatechange event handler includes code to set various UI elements to global variables, set the retrieveAccounts function as the click event handler for the Retrieve Accounts button (btnRetrieveAccounts), and then call the click method for the btnRetrieveAccounts button.
  2. The retrieveAccounts function clears the accountGrid and retrieves the number of records to retrieve from the numberOfAccountsToRetrieve select control. This value is appended to the OData System query options to be passed to the SDK.REST.retrieveMultipleRecords options parameter.
  3. The SDK.REST.retrieveMultipleRecords method accepts the following parameters:
    • type: The Schema Name of the Entity type record to retrieve. In this example uses “Account” so that account records are retrieved..
    • options: A String that represents the OData System Query Options to control the data returned. In this example the account Name and Telephone1 attributes are set and a $top query option is set to a value above the 50 record limit that is the default.
    • successCallback: The function that will be passed through and be called for each page of records returned. This example uses the retrieveAccountsCallBack function.
    • errorCallback: The function that will be passed through and be called by a failed response. This example uses an anonymous function that displays the message of any error using the alert function.
    • OnComplete: The function that will be called when all the requested records have been returned. This example uses the accountsRetrieveComplete function.
  4. The SDK.REST.retrieveMultipleRecords function prepares an XMLHttpRequest to retrieve the requested account records and sends the request.
    • Within the request onreadystatechange event handler, the first 50 results are passed back to the retrieveAccountsCallBack function as the successCallback. This function generates HTML rows for each record and appends them to the accountsGrid table.
    • If the total number of records requested using the $top query option has not yet been retrieved, the __next object contains a URL to retrieve the next set of 50 records. The URL is manipulated to extract just the query options and then passed into the SDK.REST.retrieveMultipleRecords function. This self-referential function call repeats until the requested number of records is returned or there are no more records to return.
    • When the __next object is no longer returned with the results, the accountsRetrieveComplete function is executed as the OnComplete function. This function sets the total number of records returned and displays a success message.
  5. After the page loads with the default values you can request a different number of records using the Maximum Number of Accounts to Retrieve (numberOfAccountsToRetrieve) select control and send another request by using the Retrieve Accounts (btnRetrieveAccounts) button.

sample_/JavaScriptRESTRetrieveMultiple.htm

Copy Code
<html lang="en-us">
<head>
 <title>REST Endpoint Paging with JScript</title>
 <meta http-equiv="X-UA-Compatible" content="IE=edge" />
 <script src="../ClientGlobalContext.js.aspx" type="text/javascript"></script>
 <script src="Scripts/SDK.REST.js" type="text/javascript"></script>
 <link href="Styles/JavaScriptRESTRetrieveMultiple.css" rel="stylesheet" type="text/css" />
 <script type="text/javascript">
  var accountsGrid; //The tbody element of the accountsTable
  var numberOfAccountsToRetrieve; // The select control with options for the number of records to retrieve.
  var btnRetrieveAccounts; //The button to retrieve accounts
  var accountsRetrieved; //The span displaying the number of account records retrieved.
  var successMessage; // The message displayed when records are returned.
  var totalAccountCount = 0;
  document.onreadystatechange = function () {
   if (document.readyState == "complete") {
    btnRetrieveAccounts = document.getElementById("btnRetrieveAccounts");
    accountsGrid = document.getElementById("accountsGrid");
    numberOfAccountsToRetrieve = document.getElementById("numberOfAccountsToRetrieve");
    accountsRetrieved = document.getElementById("accountsRetrieved");
    successMessage = document.getElementById("successMessage");
    btnRetrieveAccounts.onclick = retrieveAccounts;
    btnRetrieveAccounts.click();
   }
  }
  function retrieveAccounts() {
   ///<summary>
   /// Retrieves accounts by passing a filter to the SDK.RestEndpointPaging.RetrieveRecords function
   ///</summary>
   clearaccountsGrid();
   var number = parseInt(numberOfAccountsToRetrieve.options[numberOfAccountsToRetrieve.selectedIndex].value, 10);
   var options = "$select=Name,Telephone1&$top=" + number;
   //The retrieveAccountsCallBack function is passed through as the successCallBack.
   SDK.REST.retrieveMultipleRecords("Account", options, retrieveAccountsCallBack, function (error) { alert(error.message); }, accountsRetrieveComplete);
  }
  function retrieveAccountsCallBack(retrievedAccounts) {
   ///<summary>
   /// This function is passed through the request and is iterated for each page of data
   /// This function appends rows to the accountsGrid.
   ///</summary>
   totalAccountCount = totalAccountCount + retrievedAccounts.length;
   for (var i = 0; i < retrievedAccounts.length; i++) {
    var account = retrievedAccounts[i];
    var row = document.createElement("tr");
    var nameCell = document.createElement("td");
    setElementText(nameCell, account.Name);
    row.appendChild(nameCell);
    var mainPhoneCell = document.createElement("td");
    setElementText(mainPhoneCell, (account.Telephone1 == null) ? "" : account.Telephone1);
    mainPhoneCell.className = "rightColumn";
    row.appendChild(mainPhoneCell);
    accountsGrid.appendChild(row);
   }
  }
  function accountsRetrieveComplete() {
   ///<summary>
   /// This function is called after all the records have been returned to update the actual total number of records.
   ///</summary>
   accountsRetrieved.innerText = totalAccountCount;
   successMessage.style.display = "block";
  }
  function clearaccountsGrid() {
   ///<summary>
   /// This function initializes the totalAccountCount and  clears all the rows from the accountsGrid
   /// in preparation for adding a new set of rows.
   ///</summary>
   successMessage.style.display = "none";
   totalAccountCount = 0;
   for (var i = accountsGrid.rows.length - 1; i >= 0; i--) {
    accountsGrid.deleteRow(i);
   }
  }
  function setElementText(element, text) {
   ///<summary>
   /// This function mitigates the fact that IE uses innerText and other browsers use textContent.
   ///</summary>
   if (typeof (element.innerText) != "undefined")
   { element.innerText = text; }
   else
   { element.textContent = text; }
  }
 </script>
</head>
<body>
 <table id="tableHeadings" summary="This table provides the headings for the list of accounts displayed in a grid.">
  <thead>
   <tr>
    <th class="leftColumn">
     Account Name
    </th>
    <th class="rightColumn">
     Main Phone
    </th>
   </tr>
  </thead>
 </table>
 <div id="tableContainer">
  <table id="accountsTable" rules="groups" summary="This table displays the accounts retrieved.">
   <tbody id="accountsGrid" />
  </table>
 </div>
 <div id="controlsContainer">
  <div>
   <span>Maximum Number of Accounts to Retrieve:
    <select id="numberOfAccountsToRetrieve">
     <option value="10" selected="selected">10</option>
     <option value="100" selected="selected">100</option>
     <option value="300">300</option>
     <option value="600">600</option>
     <option value="900">900</option>
    </select>
    <button id="btnRetrieveAccounts">
     Retrieve Accounts</button>
   </span>
  </div>
  <div id="successMessage" style="display: none;">
   Total Number of Accounts Retrieved : <span id="accountsRetrieved"></span>
  </div>
 </div>
</body>
</html>

sample_/Scripts/SDK.REST.js

JScript Copy Code
if (typeof (SDK) == "undefined")
{ SDK = { __namespace: true }; }
SDK.REST = {
 _context: function () {
  ///<summary>
  /// Private function to the context object.
  ///</summary>
  ///<returns>Context</returns>
  if (typeof GetGlobalContext != "undefined")
  { return GetGlobalContext(); }
  else {
   if (typeof Xrm != "undefined") {
    return Xrm.Page.context;
   }
   else
   { throw new Error("Context is not available."); }
  }
 },
 _getClientUrl: function () {
  ///<summary>
  /// Private function to return the server URL from the context
  ///</summary>
  ///<returns>String</returns>
  var clientUrl = this._context().getClientUrl()

  return clientUrl;
 },
 _ODataPath: function () {
  ///<summary>
  /// Private function to return the path to the REST endpoint.
  ///</summary>
  ///<returns>String</returns>
  return this._getClientUrl() + "/XRMServices/2011/OrganizationData.svc/";
 },
 _errorHandler: function (req) {
  ///<summary>
  /// Private function return an Error object to the errorCallback
  ///</summary>
  ///<param name="req" type="XMLHttpRequest">
  /// The XMLHttpRequest response that returned an error.
  ///</param>
  ///<returns>Error</returns>
  //Error descriptions come from http://support.microsoft.com/kb/193625
  if (req.status == 12029)
  { return new Error("The attempt to connect to the server failed."); }
  if (req.status == 12007)
  { return new Error("The server name could not be resolved."); }
  var errorText;
  try
        { errorText = JSON.parse(req.responseText).error.message.value; }
  catch (e)
        { errorText = req.responseText }

  return new Error("Error : " +
        req.status + ": " +
        req.statusText + ": " + errorText);
 },
 _dateReviver: function (key, value) {
  ///<summary>
  /// Private function to convert matching string values to Date objects.
  ///</summary>
  ///<param name="key" type="String">
  /// The key used to identify the object property
  ///</param>
  ///<param name="value" type="String">
  /// The string value representing a date
  ///</param>
  var a;
  if (typeof value === 'string') {
   a = /Date\(([-+]?\d+)\)/.exec(value);
   if (a) {
    return new Date(parseInt(value.replace("/Date(", "").replace(")/", ""), 10));
   }
  }
  return value;
 },
 _parameterCheck: function (parameter, message) {
  ///<summary>
  /// Private function used to check whether required parameters are null or undefined
  ///</summary>
  ///<param name="parameter" type="Object">
  /// The parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if ((typeof parameter === "undefined") || parameter === null) {
   throw new Error(message);
  }
 },
 _stringParameterCheck: function (parameter, message) {
  ///<summary>
  /// Private function used to check whether required parameters are null or undefined
  ///</summary>
  ///<param name="parameter" type="String">
  /// The string parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if (typeof parameter != "string") {
   throw new Error(message);
  }
 },
 _callbackParameterCheck: function (callbackParameter, message) {
  ///<summary>
  /// Private function used to check whether required callback parameters are functions
  ///</summary>
  ///<param name="callbackParameter" type="Function">
  /// The callback parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if (typeof callbackParameter != "function") {
   throw new Error(message);
  }
 },
 createRecord: function (object, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to create a new record.
  ///</summary>
  ///<param name="object" type="Object">
  /// A JavaScript object with properties corresponding to the Schema name of
  /// entity attributes that are valid for create operations.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to create.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function can accept the returned record as a parameter.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._parameterCheck(object, "SDK.REST.createRecord requires the object parameter.");
  this._stringParameterCheck(type, "SDK.REST.createRecord requires the type parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.createRecord requires the successCallback is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.createRecord requires the errorCallback is a function.");
  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + type + "Set"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 201) {
     successCallback(JSON.parse(this.responseText, SDK.REST._dateReviver).d);
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send(JSON.stringify(object));
 },
 retrieveRecord: function (id, type, select, expand, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to retrieve a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to retrieve.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="select" type="String">
  /// A String representing the $select OData System Query Option to control which
  /// attributes will be returned. This is a comma separated list of Attribute names that are valid for retrieve.
  /// If null all properties for the record will be returned
  ///</param>
  ///<param name="expand" type="String">
  /// A String representing the $expand OData System Query Option value to control which
  /// related records are also returned. This is a comma separated list of of up to 6 entity relationship names
  /// If null no expanded related records will be returned.
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function must accept the returned record as a parameter.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(id, "SDK.REST.retrieveRecord requires the id parameter is a string.");
  this._stringParameterCheck(type, "SDK.REST.retrieveRecord requires the type parameter is a string.");
  if (select != null)
   this._stringParameterCheck(select, "SDK.REST.retrieveRecord requires the select parameter is a string.");
  if (expand != null)
   this._stringParameterCheck(expand, "SDK.REST.retrieveRecord requires the expand parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.retrieveRecord requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.retrieveRecord requires the errorCallback parameter is a function.");

  var systemQueryOptions = "";

  if (select != null || expand != null) {
   systemQueryOptions = "?";
   if (select != null) {
    var selectString = "$select=" + select;
    if (expand != null) {
     selectString = selectString + "," + expand;
    }
    systemQueryOptions = systemQueryOptions + selectString;
   }
   if (expand != null) {
    systemQueryOptions = systemQueryOptions + "&$expand=" + expand;
   }
  }

  var req = new XMLHttpRequest();
  req.open("GET", encodeURI(this._ODataPath() + type + "Set(guid'" + id + "')" + systemQueryOptions), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 200) {
     successCallback(JSON.parse(this.responseText, SDK.REST._dateReviver).d);
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();
 },
 updateRecord: function (id, object, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to update a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to retrieve.
  ///</param>
  ///<param name="object" type="Object">
  /// A JavaScript object with properties corresponding to the Schema Names for
  /// entity attributes that are valid for update operations.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(id, "SDK.REST.updateRecord requires the id parameter.");
  this._parameterCheck(object, "SDK.REST.updateRecord requires the object parameter.");
  this._stringParameterCheck(type, "SDK.REST.updateRecord requires the type parameter.");
  this._callbackParameterCheck(successCallback, "SDK.REST.updateRecord requires the successCallback is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.updateRecord requires the errorCallback is a function.");
  var req = new XMLHttpRequest();

  req.open("POST", encodeURI(this._ODataPath() + type + "Set(guid'" + id + "')"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.setRequestHeader("X-HTTP-Method", "MERGE");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send(JSON.stringify(object));
 },
 deleteRecord: function (id, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to delete a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to delete.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to delete.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(id, "SDK.REST.deleteRecord requires the id parameter.");
  this._stringParameterCheck(type, "SDK.REST.deleteRecord requires the type parameter.");
  this._callbackParameterCheck(successCallback, "SDK.REST.deleteRecord requires the successCallback is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.deleteRecord requires the errorCallback is a function.");
  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + type + "Set(guid'" + id + "')"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.setRequestHeader("X-HTTP-Method", "DELETE");
  req.onreadystatechange = function () {

   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();

 },
 retrieveMultipleRecords: function (type, options, successCallback, errorCallback, OnComplete) {
  ///<summary>
  /// Sends an asynchronous request to retrieve records.
  ///</summary>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="options" type="String">
  /// A String representing the OData System Query Options to control the data returned
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called for each page of records returned.
  /// Each page is 50 records. If you expect that more than one page of records will be returned,
  /// this function should loop through the results and push the records into an array outside of the function.
  /// Use the OnComplete event handler to know when all the records have been processed.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  ///<param name="OnComplete" type="Function">
  /// The function that will be called when all the requested records have been returned.
  /// No parameters are passed to this function.
  /// </param>
  this._stringParameterCheck(type, "SDK.REST.retrieveMultipleRecords requires the type parameter is a string.");
  if (options != null)
   this._stringParameterCheck(options, "SDK.REST.retrieveMultipleRecords requires the options parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.retrieveMultipleRecords requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.retrieveMultipleRecords requires the errorCallback parameter is a function.");
  this._callbackParameterCheck(OnComplete, "SDK.REST.retrieveMultipleRecords requires the OnComplete parameter is a function.");

  var optionsString;
  if (options != null) {
   if (options.charAt(0) != "?") {
    optionsString = "?" + options;
   }
   else
   { optionsString = options; }
  }
  var req = new XMLHttpRequest();
  req.open("GET", this._ODataPath() + type + "Set" + optionsString, true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 200) {
     var returned = JSON.parse(this.responseText, SDK.REST._dateReviver).d;
     successCallback(returned.results);
     if (returned.__next != null) {
      var queryOptions = returned.__next.substring((SDK.REST._ODataPath() + type + "Set").length);
      SDK.REST.retrieveMultipleRecords(type, queryOptions, successCallback, errorCallback, OnComplete);
     }
     else
     { OnComplete(); }
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();
 },
 associateRecords: function (parentId, parentType, relationshipName, childId, childType, successCallback, errorCallback) {
  this._stringParameterCheck(parentId, "SDK.REST.associateRecords requires the parentId parameter is a string.");
  ///<param name="parentId" type="String">
  /// The Id of the record to be the parent record in the relationship
  /// </param>
  ///<param name="parentType" type="String">
  /// The Schema Name of the Entity type for the parent record.
  /// For an Account record, use "Account"
  /// </param>
  ///<param name="relationshipName" type="String">
  /// The Schema Name of the Entity Relationship to use to associate the records.
  /// To associate account records as a Parent account, use "Referencedaccount_parent_account"
  /// </param>
  ///<param name="childId" type="String">
  /// The Id of the record to be the child record in the relationship
  /// </param>
  ///<param name="childType" type="String">
  /// The Schema Name of the Entity type for the child record.
  /// For an Account record, use "Account"
  /// </param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(parentType, "SDK.REST.associateRecords requires the parentType parameter is a string.");
  this._stringParameterCheck(relationshipName, "SDK.REST.associateRecords requires the relationshipName parameter is a string.");
  this._stringParameterCheck(childId, "SDK.REST.associateRecords requires the childId parameter is a string.");
  this._stringParameterCheck(childType, "SDK.REST.associateRecords requires the childType parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.associateRecords requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.associateRecords requires the errorCallback parameter is a function.");

  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + parentType + "Set(guid'" + parentId + "')/$links/" + relationshipName), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  var childEntityReference = {}
  childEntityReference.uri = this._ODataPath() + "/" + childType + "Set(guid'" + childId + "')";
  req.send(JSON.stringify(childEntityReference));
 },
 disassociateRecords: function (parentId, parentType, relationshipName, childId, successCallback, errorCallback) {
  this._stringParameterCheck(parentId, "SDK.REST.disassociateRecords requires the parentId parameter is a string.");
  ///<param name="parentId" type="String">
  /// The Id of the record to be the parent record in the relationship
  /// </param>
  ///<param name="parentType" type="String">
  /// The Schema Name of the Entity type for the parent record.
  /// For an Account record, use "Account"
  /// </param>
  ///<param name="relationshipName" type="String">
  /// The Schema Name of the Entity Relationship to use to disassociate the records.
  /// To disassociate account records as a Parent account, use "Referencedaccount_parent_account"
  /// </param>
  ///<param name="childId" type="String">
  /// The Id of the record to be disassociated as the child record in the relationship
  /// </param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(parentType, "SDK.REST.disassociateRecords requires the parentType parameter is a string.");
  this._stringParameterCheck(relationshipName, "SDK.REST.disassociateRecords requires the relationshipName parameter is a string.");
  this._stringParameterCheck(childId, "SDK.REST.disassociateRecords requires the childId parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.disassociateRecords requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.disassociateRecords requires the errorCallback parameter is a function.");

  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + parentType + "Set(guid'" + parentId + "')/$links/" + relationshipName + "(guid'" + childId + "')"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.setRequestHeader("X-HTTP-Method", "DELETE");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();
 },
 __namespace: true
};

sample_/Styles/JavaScriptRESTRetrieveMultiple.css

Copy Code
html, body
{
    font-family: Segoe UI;
    background-color:White;
}
#tableContainer
{
    overflow-y: scroll;
    max-height: 300px;
    width: 600px;
    position: absolute;
    top: 35px;
    border: 1px solid black;
}
#tableHeadings
{
    width: 602px;
    position: absolute;
    top: 20;
    height: 25px;
    border: 1px solid black;
    border-bottom: 0px none;
    background-color:ButtonFace;
}

#accountsTable
{
    overflow: scroll;
    width: 583px;
    table-layout: fixed;
    border-collapse: collapse;
}
#controlsContainer
{
    position: absolute;
    top: 350px;
}
tr
{
    border-bottom: 1px solid black;
}
td
{
    padding-left: 5px;
}

.rightColumn
{
    border-left: 1px solid black;
}
.leftColumn
{
    width:285px;
}

See Also

Reference

Limitations on number of records returned

Concepts

Query Microsoft Dynamics CRM data using the OData endpoint
Use the OData endpoint with Ajax and JScript web resources
Use the OData endpoint with web resources

Other Resources

Sample: Associate and disassociate records using the OData endpoint with JavaScript
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Associate and disassociate records using the OData endpoint with JavaScript

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\JS\RESTEndpoint\JavaScriptRESTAssociateDisassociate

If you just want to see how this sample works you can install (import) the JavaScriptRESTAssociateDisassociateSample_1_0_0_2_managed.zip managed solution included in the download files. If you install this managed solution and want to create the Web resources using the names in this topic, your solution publisher customization prefix cannot be “sample” unless you uninstall (delete) the managed solution.

Requirements

To run the sample code, create the following Web resources:

sample_/JavaScriptRESTAssociateDisassociate.htm

An HTML page that provides the user interface to run the samples..

sample_/Scripts/JavaScriptRESTAssociateDisassociate.js

A JavaScript library that contains functions to manage the user interface.

sample_/Scripts/SDK.REST.js

This JavaScript library provides the SDK.REST.associateRecords and SDK.REST.disassociateRecords functions as well as other functions for using the REST endpoint for web resources.

Note
The customization prefix ‘sample_’ is not used in code. These samples will work using the customization prefix from any publisher. However the relative path of the simulated Scripts folder must be included in the name of the Web resources.

Demonstrates

This sample contains two examples:

Associate Accounts

This sample creates two new account records and associates them. The following steps describe the actions:

  1. Create a new account record named “Parent Account”.
  2. Create a new account record named “Child Account”.
  3. Associate the records setting the Parent Account as the parent of the Child Account.
  4. Display links to allow you to verify that the association was performed.
  5. Display buttons to allow you to disassociate and delete the records created by the sample.
Associate Account to Email as ActivityParty

This sample creates an account and email record and then associates the account to the email as the from field using an activityparty record. The following steps describe the actions:

  1. Create a new account record named “Email Sender Account”.
  2. Create a new email activity named “Email Activity”.
  3. Create a new activityparty record that associates the account to the email.
  4. Display links to allow you to delete the records.
  5. Display a button to allow you to delete the record.

Both samples have a button to start the sample. The results are displayed in the Results section at the bottom of the page. After running either sample, use the Rest Sample button to run the sample again.

sample_/JavaScriptRESTAssociateDisassociate.htm

This file provides the UI that explains the sample behavior and buttons to start and reset the samples.

Copy Code
<html lang="en-US">
<head>
 <meta http-equiv="X-UA-Compatible" content="IE=edge" />
 <title>JavaScript REST Associate and Disassociate Sample</title>
 <script src="../ClientGlobalContext.js.aspx" type="text/javascript"></script>
 <script src="Scripts/SDK.REST.js" type="text/javascript"></script>
 <script src="Scripts/JavaScriptRESTAssociateDisassociate.js" type="text/javascript"></script>
</head>
<body style="background-color: White; font-family: Segoe UI; font-size: small;">
 <h1 style="font-size: small;">
  Associating and Disassociating Records using JavaScript and the REST Endpoint for Web Resources</h1>
 <p>
  This page requires JavaScript and will update dynamically.</p>
 <p>
  <input id="dispalert" name="dispalert" type="checkbox" value="alert" /><label for="dispalert">Display alert window when data changes.</label></p>
 <table width="100%" summary="This table displays 2 samples which will demonstrate associating records using JavaScript and the REST Endpoint for Web Resources.">
  <thead>
   <tr>
    <th scope="col">
     Associate Accounts Sample
    </th>
    <th scope="col">
     Associate Account to Email as ActivityParty Sample
    </th>
   </tr>
  </thead>
  <tr>
   <td>
    <p>
     <label for="btnStartAssociateAccounts">
      Click the <b>Start Associate Accounts Sample</b> button to start the sample showing how to associate two account records.</label></p>
    <button id="btnStartAssociateAccounts" title="Start the Associate Accounts Sample">
     Start Associate Accounts Sample</button><br />
    <p>
     This sample will:</p>
    <ol>
     <li>Create a new account record named "Parent Account".</li>
     <li>Create a new account record named "Child Account".</li>
     <li>Associate the records setting the "Parent Account" as the Parent Account of the "Child Account".</li>
     <li>Display links to allow you to verify that the association was done.</li>
     <li>Display a button to allow you to disassociate the records.
      <ul>
       <li>If you choose this option the sample will display links to allow you to verify that the records are no longer associated.</li>
      </ul>
     </li>
     <li>Display a button to allow you to delete the records.
      <ul>
       <li>If you choose this option the sample will display a message when the records are deleted.</li>
      </ul>
     </li>
    </ol>
   </td>
   <td valign="top" style="border-left: 1px solid black; padding-left: 5px;">
    <p>
     Click the <b>Start Associate Account to Email as ActivityParty Sample</b> button to start the sample showing how to associate an account record to an activity using ActivityParty.</p>
    <button id="btnStartAssociateAccountToEmail" title="Start the Associate Account to Email as ActivityParty sample.">
     Start Associate Account to Email as ActivityParty Sample</button>
    <p>
     This sample will:</p>
    <ol>
     <li>Create a new account record named "Email Sender Account".</li>
     <li>Create a new email activity record named "Email Activity".</li>
     <li>Create a new activity party record that associates the "Email Sender Account" to the <b>From:</b> field of the "Email Activity".</li>
     <li>Display links to allow you to verify that the association was done.</li>
     <li>Display a button to allow you to delete the records.
      <ul>
       <li>If you choose this option the sample will display a message when the records are deleted.</li>
      </ul>
     </li>
    </ol>
   </td>
  </tr>
 </table>
 <p>
  <label for="btnResetSample">
   After running one of the samples, click the <b>Reset Sample</b> button to reset the sample.</label></p>
 <button id="btnResetSample" title="Reset the sample" disabled="disabled">
  Reset Sample</button>
 <h2 style="font-size: small;">
  Results:</h2>
 <hr />
 <ol id="output">
 </ol>
</body>
</html>

sample_/Scripts/JavaScriptRESTAssociateDisassociate.js

This JavaScript library provides functions to manage actions in the user interface.

JScript Copy Code
/// <reference path="SDK.REST.js" />
var btnStartAssociateAccounts,
btnStartAssociateAccountToEmail,
btnDisassociateAccounts,
btnResetSample,
parentAccount,
childAccount,
accountRelatedToEmail,
emailRecord,
output, alertFlag;

document.onreadystatechange = function () {
 ///<summary>
 /// Initializes the sample when the document is ready
 ///</summary>
 if (document.readyState == "complete") {

  btnStartAssociateAccounts = document.getElementById("btnStartAssociateAccounts");
  btnStartAssociateAccountToEmail = document.getElementById("btnStartAssociateAccountToEmail");
  btnResetSample = document.getElementById("btnResetSample");
  alertFlag = document.getElementById("dispalert");
  output = document.getElementById("output");

  btnStartAssociateAccounts.onclick = startAssociateAccounts;
  btnStartAssociateAccountToEmail.onclick = startAssociateAccountToEmail;
  btnResetSample.onclick = resetSample;
 }
}

function startAssociateAccounts() {
 ///<summary>
 /// Creates two account records asynchronously and displays a message showing the Id values of the created records
 /// Then calls the associateAccounts function to associate them.
 ///</summary>
 disableElement(btnStartAssociateAccounts);
 disableElement(btnStartAssociateAccountToEmail);
 //Create the first account record
 SDK.REST.createRecord({ Name: "Parent Account", Description: "This Account will be the parent account" },
    "Account",
    function (account) {
     parentAccount = account;
     writeMessage("Account Id: {" + account.AccountId + "} Name: \"" + account.Name + "\" created as the parent account.");
     // Create the second account record
     SDK.REST.createRecord({ Name: "Child Account", Description: "This Account will be the child account" },
        "Account",
        function (account) {
         childAccount = account;
         writeMessage("Account Id: {" + account.AccountId + "} Name: \"" + account.Name + "\" created as the child account.");
         // Associate the accounts that were created.
         associateAccounts(parentAccount, childAccount);
        },
     errorHandler);
    },
     errorHandler);

 scrollToResults();
}

function associateAccounts(parentAccount, childAccount) {
 ///<summary>
 /// Associates two account records asynchronously and displays messages so you can verify the association
 /// Displays  buttons to disassociate or delete the accounts.
 /// Enables the reset button
 ///</summary>
 SDK.REST.associateRecords(parentAccount.AccountId,
    "Account",
    "Referencedaccount_parent_account",
    childAccount.AccountId,
    "Account",
    function () {
     writeMessage("Association successful.");
     showLinksToVerifyAccountAssociation();
     showButtonToDisassociateAccounts();
     showButtonToDeleteAccounts();
     enableElement(btnResetSample);
     if (alertFlag.checked == true)
      alert("Association successful.");
    },
    errorHandler);
}

function getUrl()
{
    var context;
    var url;
    if (typeof GetGlobalContext != "undefined")
    { context = GetGlobalContext(); }
    else
    {
        if ((typeof Xrm != "undefined") && (typeof Xrm.Page != "undefined") && (typeof Xrm.Page.context != "undefined"))
        {
            context = Xrm.Page.context;
        }
        else
        { throw new Error("Context is not available."); }
    }

        url = context.getClientUrl();

    return url;
}

function showLinksToVerifyAccountAssociation() {
 ///<summary>
 /// Displays links to verify the associated accounts.
 ///</summary>
 var message = document.createElement("div");
 var message1 = document.createElement("span");
 setText(message, "Open the ");
 var childRecordlink = document.createElement("a");
 childRecordlink.href = getUrl() + "/main.aspx?etn=account&pagetype=entityrecord&id=%7B" + childAccount.AccountId + "%7D";
 childRecordlink.target = "_blank";
 setText(childRecordlink, childAccount.Name + " record");
 var message2 = document.createElement("span");
 setText(message2, " to verify that the Parent Account field is set to the ");
 var parentRecordlink = document.createElement("a");
 parentRecordlink.href = getUrl() + "/main.aspx?etn=account&pagetype=entityrecord&id=%7B" + parentAccount.AccountId + "%7D";
 parentRecordlink.target = "_blank";
 setText(parentRecordlink, parentAccount.Name + " record");
 period = document.createElement("span");
 setText(period, ".");
 message.appendChild(message1);
 message.appendChild(childRecordlink);
 message.appendChild(message2);
 message.appendChild(parentRecordlink);
 message.appendChild(period);
 writeMessage(message);
}

function showLinksToVerifyDisAssociation() {
 ///<summary>
 /// Displays links to verify accounts were disassociated
 ///</summary>
 var message = document.createElement("div");
 var message1 = document.createElement("span");
 setText(message, "Open the ");
 var childRecordlink = document.createElement("a");
 childRecordlink.href = getUrl() + "/main.aspx?etn=account&pagetype=entityrecord&id=%7B" + childAccount.AccountId + "%7D";
 childRecordlink.target = "_blank";
 setText(childRecordlink, childAccount.Name + " record");
 var message2 = document.createElement("span");
 setText(message2, " to verify that the Parent Account field not set to the ");
 var parentRecordlink = document.createElement("a");
 parentRecordlink.href = getUrl() + "/main.aspx?etn=account&pagetype=entityrecord&id=%7B" + parentAccount.AccountId + "%7D";
 parentRecordlink.target = "_blank";
 setText(parentRecordlink, parentAccount.Name + " record");
 period = document.createElement("span");
 setText(period, ".");
 message.appendChild(message1);
 message.appendChild(childRecordlink);
 message.appendChild(message2);
 message.appendChild(parentRecordlink);
 message.appendChild(period);
 writeMessage(message);
}

function showButtonToDeleteAccounts() {
 ///<summary>
 /// Diplays a button to allow for deletion of accounts created for this sample.
 ///</summary>
 var btnDeleteRecords = document.createElement("button");
 setText(btnDeleteRecords, "Delete both records");
 btnDeleteRecords.title = "Delete both records";
 btnDeleteRecords.onclick = function () {
  disableElement(btnDisassociateAccounts);
  disableElement(this);
  SDK.REST.deleteRecord(childAccount.AccountId,
            "Account",
            function () { writeMessage(childAccount.Name + " record deleted."); },
            errorHandler);
  SDK.REST.deleteRecord(parentAccount.AccountId,
            "Account",
            function () {
             writeMessage(parentAccount.Name + " record deleted.");
             if (alertFlag.checked == true)
              alert("Records deleted.");
            },
            errorHandler);
 }
 writeMessage(btnDeleteRecords);
}

function showButtonToDisassociateAccounts() {
 ///<summary>
 /// Displays a button to allow for disassociation of accounts associated by this sample.
 /// Then shows links to verify disassociation
 ///</summary>
 btnDisassociateAccounts = document.createElement("button");
 setText(btnDisassociateAccounts, "Disassociate the records");
 btnDisassociateAccounts.title = "Disassociate the records";
 btnDisassociateAccounts.onclick = function () {
  SDK.REST.disassociateRecords(parentAccount.AccountId,
    "Account",
    "Referencedaccount_parent_account",
    childAccount.AccountId,
    function () {
     showLinksToVerifyDisAssociation();
     if (alertFlag.checked == true)
      alert("Disassociation successful.");
    },
    errorHandler);
 }
 writeMessage(btnDisassociateAccounts);
}

function startAssociateAccountToEmail() {
 ///<summary>
 /// Creates an account and email record and displays message to verify that they were created
 /// Then calls associateAccountAsActivityPartyToEmail to associate them
 ///</summary>
 disableElement(btnStartAssociateAccounts);
 disableElement(btnStartAssociateAccountToEmail);

 //Create one account and one email record.
 SDK.REST.createRecord({ Name: "Email Sender Account", Description: "This Account will be the account shown as the sender of an email." },
    "Account",
    function (account) {
     accountRelatedToEmail = account;
     writeMessage("Account Id: {" + accountRelatedToEmail.AccountId + "} Name: \"" + accountRelatedToEmail.Name + "\" created as an account to be the sender of an email.");
     SDK.REST.createRecord({ Subject: "Email Activity", Description: "This email will be shown as sent by the " + accountRelatedToEmail.Name + " record." },
        "Email",
        function (email) {
         emailRecord = email;
         writeMessage("Email ActivityId: {" + emailRecord.ActivityId + "} Subject: \"" + emailRecord.Subject + "\" created to be shown as sent from the " + accountRelatedToEmail.Name + " record.");
         associateAccountAsActivityPartyToEmail();
        },
     errorHandler);
    },
     errorHandler);
 scrollToResults();

}

function associateAccountAsActivityPartyToEmail() {
 ///<summary>
 /// Creates a new ActivityParty record to associate an account record to an email record, making the account the sender of the email.
 /// Shows links to verify the association
 /// Shows buttons to delete the records. It is not possible to disassociate the records by deleting the ActivityParty record using the REST endpoint.
 ///</summary>
 var activityParty = {
  PartyId:
 {
  Id: accountRelatedToEmail.AccountId,
  LogicalName: "account"
 },
  ActivityId: {
   Id: emailRecord.ActivityId,
   LogicalName: "email"
  },
  // Set the participation type (what role the party has on the activity). For this
  // example, we'll put the account in the From field (which has a value of 1).
  // See http://msdn.microsoft.com/en-us/library/gg328549.aspx for other options.
  ParticipationTypeMask: { Value: 1 }
 };

 SDK.REST.createRecord(activityParty,
 "ActivityParty",
 function (ap) {
  test_activityPartyId = ap.ActivityPartyId;
  writeMessage("Created new ActivityParty ActivityPartyId: {" + ap.ActivityPartyId + "}. The account is now related to the email.");
  showLinksToVerifyActivityPartyAssociation();
  showButtonToDeleteAccountAndEmailRecords();
  enableElement(btnResetSample);
  if (alertFlag.checked == true)
   alert("The account is now related to the email.");
 },
 errorHandler);
}

// Note: Attempting to disassociate an activityparty relationship by deleting the ActivityParty record is not allowed.

function showLinksToVerifyActivityPartyAssociation() {
 ///<summary>
 /// Shows links to verify that an account and email are linked
 ///</summary>
 var message = document.createElement("div");
 var message1 = document.createElement("span");
 setText(message1, "Open the ");
 var childRecordlink = document.createElement("a");
 childRecordlink.href = getUrl() + "/main.aspx?etn=email&pagetype=entityrecord&id=%7B" + emailRecord.ActivityId + "%7D";
 childRecordlink.target = "_blank";
 setText(childRecordlink, emailRecord.Subject + " record");
 var message2 = document.createElement("span");
 setText(message2, " to verify that the ");
 var parentRecordlink = document.createElement("a");
 parentRecordlink.href = getUrl() + "/main.aspx?etn=account&pagetype=entityrecord&id=%7B" + accountRelatedToEmail.AccountId + "%7D";
 parentRecordlink.target = "_blank";
 setText(parentRecordlink, accountRelatedToEmail.Name + " record");
 message3 = document.createElement("span");
 setText(message3, " is set as the sender.");
 message.appendChild(message1);
 message.appendChild(childRecordlink);
 message.appendChild(message2);
 message.appendChild(parentRecordlink);
 message.appendChild(message3);
 writeMessage(message);
}

function showButtonToDeleteAccountAndEmailRecords() {
 ///<summary>
 /// Shows button to delete the account and email records created for this sample
 ///</summary>
 var btnDeleteRecords = document.createElement("button");
 setText(btnDeleteRecords, "Delete both records");
 btnDeleteRecords.title = "Delete both records";
 btnDeleteRecords.onclick = function () {
  disableElement(this);
  SDK.REST.deleteRecord(accountRelatedToEmail.AccountId,
            "Account",
            function () { writeMessage(accountRelatedToEmail.Name + " record deleted."); },
            errorHandler);
  SDK.REST.deleteRecord(emailRecord.ActivityId,
            "Email",
            function () {
             writeMessage(emailRecord.Subject + " record deleted.");
             if (alertFlag.checked == true)
              alert("Records deleted.");
            },
            errorHandler);
 }
 writeMessage(btnDeleteRecords);
}

function errorHandler(error) {
 ///<summary>
 /// Displays the message property of errors
 ///</summary>
 writeMessage(error.message);
 if (alertFlag.checked == true)
  alert(error.message);
}

function enableElement(element) {
 ///<summary>
 /// Enables an element that is disabled.
 ///</summary>
 element.removeAttribute("disabled");
}

function disableElement(element) {
 ///<summary>
 /// Disables an element that is enabled.
 ///</summary>
 element.setAttribute("disabled", "disabled");
}

function resetSample() {
 ///<summary>
 /// Clears out the results area and enable buttons to start one of the samples again.
 ///</summary>
 output.innerHTML = "";
 enableElement(btnStartAssociateAccounts);
 enableElement(btnStartAssociateAccountToEmail)
 disableElement(btnResetSample);
 if (alertFlag.checked == true)
  alert("Reset complete.");
}

//Helper function to write data to this page:
function writeMessage(message) {
 ///<summary>
 /// Displays a message or appends an element to the results area.
 ///</summary>
 var li = document.createElement("li");
 if (typeof (message) == "string") {

  setText(li, message);

 }
 else {
  li.appendChild(message);
 }

 output.appendChild(li);
}

function scrollToResults() {
 ///<summary>
 /// Scrolls to the bottom of the page so the results area can be seen.
 ///</summary>
 window.scrollTo(0, document.body.scrollHeight);
}

function setText(node, text) {
 ///<summary>
 /// Used to set the text content of elements to manage differences between browsers.
 ///</summary>
 if (typeof (node.innerText) != "undefined") {
  node.innerText = text;
 }
 else {
  node.textContent = text;
 }
}

sample_/Scripts/SDK.REST.js

This JavaScript library provides functions to perform actions using the REST endpoint including SDK.REST.associateRecords and SDK.REST.disassociateRecords. For information about the other operations this sample library supports, see Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript.

JScript Copy Code
if (typeof (SDK) == "undefined")
{ SDK = { __namespace: true }; }
SDK.REST = {
 _context: function () {
  ///<summary>
  /// Private function to the context object.
  ///</summary>
  ///<returns>Context</returns>
  if (typeof GetGlobalContext != "undefined")
  { return GetGlobalContext(); }
  else {
   if (typeof Xrm != "undefined") {
    return Xrm.Page.context;
   }
   else
   { throw new Error("Context is not available."); }
  }
 },
 _getClientUrl: function () {
  ///<summary>
  /// Private function to return the server URL from the context
  ///</summary>
  ///<returns>String</returns>
  var clientUrl = this._context().getClientUrl()

  return clientUrl;
 },
 _ODataPath: function () {
  ///<summary>
  /// Private function to return the path to the REST endpoint.
  ///</summary>
  ///<returns>String</returns>
  return this._getClientUrl() + "/XRMServices/2011/OrganizationData.svc/";
 },
 _errorHandler: function (req) {
  ///<summary>
  /// Private function return an Error object to the errorCallback
  ///</summary>
  ///<param name="req" type="XMLHttpRequest">
  /// The XMLHttpRequest response that returned an error.
  ///</param>
  ///<returns>Error</returns>
  //Error descriptions come from http://support.microsoft.com/kb/193625
  if (req.status == 12029)
  { return new Error("The attempt to connect to the server failed."); }
  if (req.status == 12007)
  { return new Error("The server name could not be resolved."); }
  var errorText;
  try
        { errorText = JSON.parse(req.responseText).error.message.value; }
  catch (e)
        { errorText = req.responseText }

  return new Error("Error : " +
        req.status + ": " +
        req.statusText + ": " + errorText);
 },
 _dateReviver: function (key, value) {
  ///<summary>
  /// Private function to convert matching string values to Date objects.
  ///</summary>
  ///<param name="key" type="String">
  /// The key used to identify the object property
  ///</param>
  ///<param name="value" type="String">
  /// The string value representing a date
  ///</param>
  var a;
  if (typeof value === 'string') {
   a = /Date\(([-+]?\d+)\)/.exec(value);
   if (a) {
    return new Date(parseInt(value.replace("/Date(", "").replace(")/", ""), 10));
   }
  }
  return value;
 },
 _parameterCheck: function (parameter, message) {
  ///<summary>
  /// Private function used to check whether required parameters are null or undefined
  ///</summary>
  ///<param name="parameter" type="Object">
  /// The parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if ((typeof parameter === "undefined") || parameter === null) {
   throw new Error(message);
  }
 },
 _stringParameterCheck: function (parameter, message) {
  ///<summary>
  /// Private function used to check whether required parameters are null or undefined
  ///</summary>
  ///<param name="parameter" type="String">
  /// The string parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if (typeof parameter != "string") {
   throw new Error(message);
  }
 },
 _callbackParameterCheck: function (callbackParameter, message) {
  ///<summary>
  /// Private function used to check whether required callback parameters are functions
  ///</summary>
  ///<param name="callbackParameter" type="Function">
  /// The callback parameter to check;
  ///</param>
  ///<param name="message" type="String">
  /// The error message text to include when the error is thrown.
  ///</param>
  if (typeof callbackParameter != "function") {
   throw new Error(message);
  }
 },
 createRecord: function (object, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to create a new record.
  ///</summary>
  ///<param name="object" type="Object">
  /// A JavaScript object with properties corresponding to the Schema name of
  /// entity attributes that are valid for create operations.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to create.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function can accept the returned record as a parameter.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._parameterCheck(object, "SDK.REST.createRecord requires the object parameter.");
  this._stringParameterCheck(type, "SDK.REST.createRecord requires the type parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.createRecord requires the successCallback is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.createRecord requires the errorCallback is a function.");
  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + type + "Set"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 201) {
     successCallback(JSON.parse(this.responseText, SDK.REST._dateReviver).d);
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send(JSON.stringify(object));
 },
 retrieveRecord: function (id, type, select, expand, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to retrieve a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to retrieve.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="select" type="String">
  /// A String representing the $select OData System Query Option to control which
  /// attributes will be returned. This is a comma separated list of Attribute names that are valid for retrieve.
  /// If null all properties for the record will be returned
  ///</param>
  ///<param name="expand" type="String">
  /// A String representing the $expand OData System Query Option value to control which
  /// related records are also returned. This is a comma separated list of of up to 6 entity relationship names
  /// If null no expanded related records will be returned.
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function must accept the returned record as a parameter.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(id, "SDK.REST.retrieveRecord requires the id parameter is a string.");
  this._stringParameterCheck(type, "SDK.REST.retrieveRecord requires the type parameter is a string.");
  if (select != null)
   this._stringParameterCheck(select, "SDK.REST.retrieveRecord requires the select parameter is a string.");
  if (expand != null)
   this._stringParameterCheck(expand, "SDK.REST.retrieveRecord requires the expand parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.retrieveRecord requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.retrieveRecord requires the errorCallback parameter is a function.");

  var systemQueryOptions = "";

  if (select != null || expand != null) {
   systemQueryOptions = "?";
   if (select != null) {
    var selectString = "$select=" + select;
    if (expand != null) {
     selectString = selectString + "," + expand;
    }
    systemQueryOptions = systemQueryOptions + selectString;
   }
   if (expand != null) {
    systemQueryOptions = systemQueryOptions + "&$expand=" + expand;
   }
  }

  var req = new XMLHttpRequest();
  req.open("GET", encodeURI(this._ODataPath() + type + "Set(guid'" + id + "')" + systemQueryOptions), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 200) {
     successCallback(JSON.parse(this.responseText, SDK.REST._dateReviver).d);
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();
 },
 updateRecord: function (id, object, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to update a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to retrieve.
  ///</param>
  ///<param name="object" type="Object">
  /// A JavaScript object with properties corresponding to the Schema Names for
  /// entity attributes that are valid for update operations.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(id, "SDK.REST.updateRecord requires the id parameter.");
  this._parameterCheck(object, "SDK.REST.updateRecord requires the object parameter.");
  this._stringParameterCheck(type, "SDK.REST.updateRecord requires the type parameter.");
  this._callbackParameterCheck(successCallback, "SDK.REST.updateRecord requires the successCallback is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.updateRecord requires the errorCallback is a function.");
  var req = new XMLHttpRequest();

  req.open("POST", encodeURI(this._ODataPath() + type + "Set(guid'" + id + "')"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.setRequestHeader("X-HTTP-Method", "MERGE");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send(JSON.stringify(object));
 },
 deleteRecord: function (id, type, successCallback, errorCallback) {
  ///<summary>
  /// Sends an asynchronous request to delete a record.
  ///</summary>
  ///<param name="id" type="String">
  /// A String representing the GUID value for the record to delete.
  ///</param>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to delete.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(id, "SDK.REST.deleteRecord requires the id parameter.");
  this._stringParameterCheck(type, "SDK.REST.deleteRecord requires the type parameter.");
  this._callbackParameterCheck(successCallback, "SDK.REST.deleteRecord requires the successCallback is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.deleteRecord requires the errorCallback is a function.");
  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + type + "Set(guid'" + id + "')"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.setRequestHeader("X-HTTP-Method", "DELETE");
  req.onreadystatechange = function () {

   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();

 },
 retrieveMultipleRecords: function (type, options, successCallback, errorCallback, OnComplete) {
  ///<summary>
  /// Sends an asynchronous request to retrieve records.
  ///</summary>
  ///<param name="type" type="String">
  /// The Schema Name of the Entity type record to retrieve.
  /// For an Account record, use "Account"
  ///</param>
  ///<param name="options" type="String">
  /// A String representing the OData System Query Options to control the data returned
  ///</param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called for each page of records returned.
  /// Each page is 50 records. If you expect that more than one page of records will be returned,
  /// this function should loop through the results and push the records into an array outside of the function.
  /// Use the OnComplete event handler to know when all the records have been processed.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  ///<param name="OnComplete" type="Function">
  /// The function that will be called when all the requested records have been returned.
  /// No parameters are passed to this function.
  /// </param>
  this._stringParameterCheck(type, "SDK.REST.retrieveMultipleRecords requires the type parameter is a string.");
  if (options != null)
   this._stringParameterCheck(options, "SDK.REST.retrieveMultipleRecords requires the options parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.retrieveMultipleRecords requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.retrieveMultipleRecords requires the errorCallback parameter is a function.");
  this._callbackParameterCheck(OnComplete, "SDK.REST.retrieveMultipleRecords requires the OnComplete parameter is a function.");

  var optionsString;
  if (options != null) {
   if (options.charAt(0) != "?") {
    optionsString = "?" + options;
   }
   else
   { optionsString = options; }
  }
  var req = new XMLHttpRequest();
  req.open("GET", this._ODataPath() + type + "Set" + optionsString, true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 200) {
     var returned = JSON.parse(this.responseText, SDK.REST._dateReviver).d;
     successCallback(returned.results);
     if (returned.__next != null) {
      var queryOptions = returned.__next.substring((SDK.REST._ODataPath() + type + "Set").length);
      SDK.REST.retrieveMultipleRecords(type, queryOptions, successCallback, errorCallback, OnComplete);
     }
     else
     { OnComplete(); }
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();
 },
 associateRecords: function (parentId, parentType, relationshipName, childId, childType, successCallback, errorCallback) {
  this._stringParameterCheck(parentId, "SDK.REST.associateRecords requires the parentId parameter is a string.");
  ///<param name="parentId" type="String">
  /// The Id of the record to be the parent record in the relationship
  /// </param>
  ///<param name="parentType" type="String">
  /// The Schema Name of the Entity type for the parent record.
  /// For an Account record, use "Account"
  /// </param>
  ///<param name="relationshipName" type="String">
  /// The Schema Name of the Entity Relationship to use to associate the records.
  /// To associate account records as a Parent account, use "Referencedaccount_parent_account"
  /// </param>
  ///<param name="childId" type="String">
  /// The Id of the record to be the child record in the relationship
  /// </param>
  ///<param name="childType" type="String">
  /// The Schema Name of the Entity type for the child record.
  /// For an Account record, use "Account"
  /// </param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(parentType, "SDK.REST.associateRecords requires the parentType parameter is a string.");
  this._stringParameterCheck(relationshipName, "SDK.REST.associateRecords requires the relationshipName parameter is a string.");
  this._stringParameterCheck(childId, "SDK.REST.associateRecords requires the childId parameter is a string.");
  this._stringParameterCheck(childType, "SDK.REST.associateRecords requires the childType parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.associateRecords requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.associateRecords requires the errorCallback parameter is a function.");

  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + parentType + "Set(guid'" + parentId + "')/$links/" + relationshipName), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  var childEntityReference = {}
  childEntityReference.uri = this._ODataPath() + "/" + childType + "Set(guid'" + childId + "')";
  req.send(JSON.stringify(childEntityReference));
 },
 disassociateRecords: function (parentId, parentType, relationshipName, childId, successCallback, errorCallback) {
  this._stringParameterCheck(parentId, "SDK.REST.disassociateRecords requires the parentId parameter is a string.");
  ///<param name="parentId" type="String">
  /// The Id of the record to be the parent record in the relationship
  /// </param>
  ///<param name="parentType" type="String">
  /// The Schema Name of the Entity type for the parent record.
  /// For an Account record, use "Account"
  /// </param>
  ///<param name="relationshipName" type="String">
  /// The Schema Name of the Entity Relationship to use to disassociate the records.
  /// To disassociate account records as a Parent account, use "Referencedaccount_parent_account"
  /// </param>
  ///<param name="childId" type="String">
  /// The Id of the record to be disassociated as the child record in the relationship
  /// </param>
  ///<param name="successCallback" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// Nothing will be returned to this function.
  /// </param>
  ///<param name="errorCallback" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  /// </param>
  this._stringParameterCheck(parentType, "SDK.REST.disassociateRecords requires the parentType parameter is a string.");
  this._stringParameterCheck(relationshipName, "SDK.REST.disassociateRecords requires the relationshipName parameter is a string.");
  this._stringParameterCheck(childId, "SDK.REST.disassociateRecords requires the childId parameter is a string.");
  this._callbackParameterCheck(successCallback, "SDK.REST.disassociateRecords requires the successCallback parameter is a function.");
  this._callbackParameterCheck(errorCallback, "SDK.REST.disassociateRecords requires the errorCallback parameter is a function.");

  var req = new XMLHttpRequest();
  req.open("POST", encodeURI(this._ODataPath() + parentType + "Set(guid'" + parentId + "')/$links/" + relationshipName + "(guid'" + childId + "')"), true);
  req.setRequestHeader("Accept", "application/json");
  req.setRequestHeader("Content-Type", "application/json; charset=utf-8");
  req.setRequestHeader("X-HTTP-Method", "DELETE");
  req.onreadystatechange = function () {
   if (this.readyState == 4 /* complete */) {
    req.onreadystatechange = null;
    if (this.status == 204 || this.status == 1223) {
     successCallback();
    }
    else {
     errorCallback(SDK.REST._errorHandler(this));
    }
   }
  };
  req.send();
 },
 __namespace: true
};

These functions create or delete associations using the $links segment of the URL and a specific navigation property that is the relationshipName parameter passed into the functions. For more information, see OData: URI Conventions 3.2. Addressing Links between Entries.

See Also

Reference

Related Entities

Concepts

Use the OData endpoint with web resources

Other Resources

Sample: OData endpoint jQuery contact editor
Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: OData endpoint jQuery contact editor

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK/SampleCode/JS/RESTEndpoint/RESTJQueryContactEditor

Note
If you just want to see how this sample works you can install (import) the RESTJQueryContactEditor_1_0_0_2_managed.zip managed solution included in the download files. If you install this managed solution and want to create the web resources using the names in the Readme.docx file, your solution publisher customization prefix can’t be “sample” unless you uninstall (delete) the managed solution.

Requirements

Use the instructions in the Readme.docx to create web resources using the files identified in the Visual Studio solution.

Demonstrates

This sample shows how to use of the REST endpoint in a basic application that provides interactive user interface using HTML, JScript, and JQuery.

This screenshot shows the user interface for the REST Endpoint JQuery Contact Editor.

REST JQuery Contact Editor sample

See Also

Concepts

Use the OData endpoint with web resources
Use the OData endpoint with Ajax and JScript web resources
Perform basic data operations using the OData endpoint

Other Resources

Use web service data in web resources (OData and Modern app SOAP endpoint)
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the Modern app SOAP endpoint for modern applications with web resources

Unlike the REST endpoint for web resources, the SOAP endpoint uses the Organization service. This is the same service used when writing applications that exist outside of the Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update application. The differences are:

  • Requests are sent to a different URL: <organization URL>/XRMServices/2011/Organization.svc/web.
  • Authentication for web resources is provided by the application.

If you use this endpoint outside the application, you must implement authentication. More information: Authenticate the user with the web services

Using the SOAP endpoint with JavaScript

With JavaScript, you will be using XmlHttpRequest to POST requests to the service. The body of the request must contain the XML appropriate for the message you are using. You must also parse the XML returned in a response. You have several options for using the SOAP endpoint with JavaScript:

  • Create a library yourself using the procedure described in Walkthrough: Use the Modern app SOAP endpoint with JavaScript.
  • Use the Sdk.Soap.js sample library described below.
  • Use open source libraries.

Sample: Sdk.Soap.js library

Sdk.Soap.js is a sample that demonstrates a JavaScript library that makes it easier to write code that uses the SOAP endpoint for modern applications with web resources. This library was created using the SOAPLogger sample application described in Walkthrough: Use the Modern app SOAP endpoint with JavaScript to capture and observe the XML data passed to the server. Sdk.Soap.js includes object definitions that correspond with classes and methods from the SDK assemblies. These include separate libraries for more than 200 messages you can use. Sdk.Soap.js is for use with web resources only. It does not provide the capability to authenticate from outside the application.

Sdk.Soap.js provides a programming model that is based on how you write C# code using the assemblies included in the SDK. You can write code using the late bound or early bound styles. To use the early bound style you must generate JavaScript libraries representing classes for the entities you will use in your code. Use the Sdk.Soap.js Entity Class Generator to generate the libraries you need. No additional libraries are required to write code using the late-bound style. More information: Entity programming (early bound vs. late bound vs. developer extensions)

If you use actions to create custom messages, you can use the Sdk.Soap.js Action Message Generator to generate JavaScript libraries for each action in your organization and then use Sdk.Soap.js to call those actions in your JavaScript code. More information: Create your own actions

Sdk.Soap.js Samples is a separate set of samples that demonstrates using Sdk.Soap.js with both late bound and early bound styles, messages, and queries.

See Also

Tasks

Walkthrough: Use the Modern app SOAP endpoint with JavaScript

Other Resources

Use web service data in web resources (OData and Modern app SOAP endpoint)
Sdk.Soap.js
Sdk.Soap.js Entity Class Generator
Sdk.Soap.js Action Message Generator
Sdk.Soap.js Samples

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Walkthrough: Use the Modern app SOAP endpoint with JavaScript

This walkthrough demonstrates creating a JavaScript library for use with the SOAP endpoint with web resources. At this time Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update doesn’t provide JavaScript libraries that you can use to call messages available using the SOAP endpoint. This walkthrough shows how to create a JScript library for the Assign message using the Organization Service Execute method. Any other message using the Execute method will follow a similar pattern. To create a JavaScript library for any message will require a similar process. For an example of a JavaScript library developed using this process, see Sample: Retrieve entity metadata using JavaScript.

Note
For a complete sample JavaScript library using the SOAP endpoint, see the Sdk.Soap.js library. The Sdk.Soap.js library was created using the process described here.

The process consists of capturing the HTTP requests and responses sent from a managed code console application and then creating a JavaScript library with functions to send the same requests and process similar responses. It is common to use an application like Fiddler to capture HTTP requests and responses but Fiddler and similar applications cannot capture the encrypted HTTP traffic used for on-premises Microsoft Dynamics CRM 2015. The SOAPLogger sample solution provided captures the HTTP requests before they are encrypted and the HTTP responses after they have been decrypted. The SOAPLogger sample solution works for both Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. SOAPLogger also filters out any HTTP traffic that is not relevant to the task of creating a JScript library.

This walkthrough guides you through the following tasks:

  1. In Capture Sample HTTP Request and Response you will edit the Run method of the SOAPLogger sample to perform an Assign request using managed code.
  2. Then you will run the SOAPLogger solution to generate information about the HTTP requests sent and responses received.
  3. In Create a JScript Library you will create a JScript library based on the captured HTTP traffic to send and receive the Assign message using the Organization Service Execute method.
  4. In Test the JScript Library you will test the JScript library to confirm it can be used to assign records.
  5. In Create an Interactive Web Resource you will create an HTML web resource that uses the library to assign Account records to a selected user as shown in the following screenshot.

    Assign Accounts Page

A managed solution representing this completed walkthrough is available in the SDK package at SDK\SampleCode\JS\SOAPForJScript\SOAPEndpointforJScript_1_0_0_1_managed.zip. Download the Microsoft Dynamics CRM SDK package. You can install (import) this solution and view the completed results. Because it is a managed solution you can easily uninstall (delete) it to completely remove it from your system.

The SDK\SampleCode\JS\SOAPForJScript\SOAPForJScript.sln is a Visual Studio solution containing the HTML and JS files with the code in this walkthrough.

Prerequisites

  • You must be able to write managed code corresponding to the functions you want to perform using JScript.
  • You need access to the SOAPLogger sample available with the SDK download files at SDK\SampleCode\CS\Client\SOAPLogger.

    Note
    The SOAPLogger sample in the Microsoft Dynamics CRM SDK is only available for Microsoft Visual C#. If you prefer a Microsoft Visual Basic .NET version, see Microsoft Dynamics CRM VB.Net SoapLogger on CodePlex.

  • You need Microsoft Visual Studio to run the SOAPLogger solution.
  • You need a good knowledge of JScript and asynchronous programming using XMLHttpRequest.

Capture sample HTTP Request and Response

Edit the SOAPLogger solution to add code to perform an AssignRequest using the SoapLoggerOrganizationService. The SoapLoggerOrganizationService inherits from the IOrganizationService and adds the capability to generate a log file that displays the relevant HTTP traffic sent and received.

  1. Using Microsoft Visual Studio, open the SOAPLogger solution located at SDK\SampleCode\CS\Client\SOAPLogger\SOAPLogger.sln.

  2. In the SoapLogger.cs file, locate the Run method as shown in the following example:

    C# Copy Code
    public void Run(ServerConnection.Configuration serverConfig)
{
 try
 {

  // Connect to the Organization service.
  // The using statement assures that the service proxy will be properly disposed.
     using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri, serverConfig.Credentials, serverConfig.DeviceCredentials))
  {
   // This statement is required to enable early-bound type support.
   _serviceProxy.EnableProxyTypes();

   IOrganizationService service = (IOrganizationService)_serviceProxy;

   using (StreamWriter output = new StreamWriter("output.txt"))
   {

    SoapLoggerOrganizationService slos = new SoapLoggerOrganizationService(serverConfig.OrganizationUri, service, output);

    //Add the code you want to test here:
    // You must use the SoapLoggerOrganizationService 'slos' proxy rather than the IOrganizationService proxy you would normally use.

   }

  }

 }

 // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
 catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
 {
  // You can handle an exception here or pass it back to the calling method.
  throw;
 }
}

  3. Identify a valid id for a SystemUser record and the ID of an Account record not assigned to that user.

    Tip
    To get the Id from any record in the application, open that record and use the Copy a Link command. Paste the link into Notepad and isolate the portion that contains the id parameter value excluding the encoded brackets (“%7b” = “{”) and (“%7d” = “}”). For example, the following represents a URL for an Account record. <your organization root url>/main.aspx?etc=1&id=%7bF2CA52DE-552D-E011-A8FB-00155DB059BE%7d&pagetype=entityrecord>. The id value is F2CA52DE-552D-E011-A8FB-00155DB059BE.

    Use those values to replace the placeholder values in the code below and add the code to the run method where indicated. For more information about the Assign request see AssignRequest.

    C# Copy Code
    Guid userId = new Guid("XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX");
Guid accountId = new Guid("XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX");
AssignRequest assign = new AssignRequest{Assignee = new EntityReference(SystemUser.EntityLogicalName, userId),Target = new EntityReference(Account.EntityLogicalName, accountId)};
AssignResponse assignResp = (AssignResponse)slos.Execute(assign);

  4. Press F5 to debug the application. Enter information about the server and your authentication credentials. If the code runs successfully the account record will now be assigned to the user you specified. For more information about running sample code, see Run a simple program using Microsoft Dynamics CRM web services

  5. In the SOAPLogger project folders, navigate to the bin and Debug folders and look for the output.txt file.

  6. Open the output.txt file and review the contents. They should look something like the following except actual GUID values will replace the placeholder “XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX”.

    Copy Code
    HTTP REQUEST
--------------------------------------------------
POST <your server root>/XRMServices/2011/Organization.svc/web
Content-Type: text/xml; charset=utf-8
SOAPAction: http://schemas.microsoft.com/xrm/2011/Contracts/Services/IOrganizationService/Execute

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
 <s:Body>
  <Execute xmlns="http://schemas.microsoft.com/xrm/2011/Contracts/Services"
           xmlns:i="http://www.w3.org/2001/XMLSchema-instance">
   <request i:type="b:AssignRequest"
            xmlns:a="http://schemas.microsoft.com/xrm/2011/Contracts"
            xmlns:b="http://schemas.microsoft.com/crm/2011/Contracts">
    <a:Parameters xmlns:c="http://schemas.datacontract.org/2004/07/System.Collections.Generic">
     <a:KeyValuePairOfstringanyType>
      <c:key>Target</c:key>
      <c:value i:type="a:EntityReference">
       <a:Id>XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX</a:Id>
       <a:LogicalName>account</a:LogicalName>
       <a:Name i:nil="true" />
      </c:value>
     </a:KeyValuePairOfstringanyType>
     <a:KeyValuePairOfstringanyType>
      <c:key>Assignee</c:key>
      <c:value i:type="a:EntityReference">
       <a:Id>XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX</a:Id>
       <a:LogicalName>systemuser</a:LogicalName>
       <a:Name i:nil="true" />
      </c:value>
     </a:KeyValuePairOfstringanyType>
    </a:Parameters>
    <a:RequestId i:nil="true" />
    <a:RequestName>Assign</a:RequestName>
   </request>
  </Execute>
 </s:Body>
</s:Envelope>
--------------------------------------------------

HTTP RESPONSE
--------------------------------------------------
<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
 <s:Body>
  <ExecuteResponse xmlns="http://schemas.microsoft.com/xrm/2011/Contracts/Services"
                   xmlns:i="http://www.w3.org/2001/XMLSchema-instance">
   <ExecuteResult i:type="b:AssignResponse"
                  xmlns:a="http://schemas.microsoft.com/xrm/2011/Contracts"
                  xmlns:b="http://schemas.microsoft.com/crm/2011/Contracts">
    <a:ResponseName>Assign</a:ResponseName>
    <a:Results xmlns:c="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
   </ExecuteResult>
  </ExecuteResponse>
 </s:Body>
</s:Envelope>
--------------------------------------------------

  7. Note the location of the variables you passed in using your code, including the logical name of the Account entity.

You have successfully captured the relevant portions of the HTTP traffic that performed the assign operation.

Create a JScript library

Exactly how you wish to construct your library is up to you. Each JScript should have the following elements:

  • A strategy to help ensure that the name of any function is unique.
  • A means to retrieve the URL to the SOAP endpoint for web resources.
  • Separate methods to send the request and receive the response asynchronously.
  • A function to process any WCF faults returned.

The following JScript library includes these elements and includes the assignRequest and assignResponse functions to use the Assign message based on the HTTP requests and responses captured using the SOAPLogger.

JScript Copy Code
if (typeof (SDK) == "undefined")
{ SDK = { __namespace: true }; }
//This will establish a more unique namespace for functions in this library. This will reduce the
// potential for functions to be overwritten due to a duplicate name when the library is loaded.
SDK.SOAPSamples = {
 _getClientUrl: function () {
  ///<summary>
  /// Returns the URL for the SOAP endpoint using the context information available in the form
  /// or HTML Web resource.
  ///</summary
  var OrgServicePath = "/XRMServices/2011/Organization.svc/web";
  var clientUrl = "";
  if (typeof GetGlobalContext == "function") {
   var context = GetGlobalContext();
   clientUrl = context.getClientUrl();
  }
  else {
   if (typeof Xrm.Page.context == "object") {
    clientUrl = Xrm.Page.context.getClientUrl();
   }
   else
   { throw new Error("Unable to access the server URL"); }
  }

  return clientUrl + OrgServicePath;
 },
 assignRequest: function (Assignee, Target, Type, successCallback, errorCallback) {
  ///<summary>
  /// Sends the Assign Request
  ///</summary>
  this._parameterCheck(Assignee, "GUID", "The SDK.SOAPSamples.assignRequest method Assignee parameter must be a string Representing a GUID value.");
  ///<param name="Assignee" Type="String">
  /// The GUID representing the  System user that the record will be assigned to.
  ///</param>
  this._parameterCheck(Target, "GUID", "The SDK.SOAPSamples.assignRequest method Target parameter must be a string Representing a GUID value.");
  ///<param name="Target" Type="String">
  /// The GUID representing the user-owned entity record that will be assigne to the Assignee.
  ///</param>
  this._parameterCheck(Type, "String", "The SDK.SOAPSamples.assignRequest method Type parameter must be a string value.");
  Type = Type.toLowerCase();
  ///<param name="Type" Type="String">
  /// The Logical name of the user-owned entity. For example, 'account'.
  ///</param>
  if (successCallback != null)
  this._parameterCheck(successCallback, "Function", "The SDK.SOAPSamples.assignRequest method successCallback parameter must be a function.");
  ///<param name="successCallback" Type="Function">
  /// The function to perform when an successfult response is returned.
  ///</param>
  this._parameterCheck(errorCallback, "Function", "The SDK.SOAPSamples.assignRequest method errorCallback parameter must be a function.");
  ///<param name="errorCallback" Type="Function">
  /// The function to perform when an error is returned.
  ///</param>
  //The request is simply the soap envelope captured by the SOAPLogger with variables added for the
  // values passed. All quotations must be escaped to create valid JScript strings.
  var request = [];

     request.push("<s:Envelope xmlns:s=\"http://schemas.xmlsoap.org/soap/envelope/\">");
     request.push("<s:Body>");
     request.push("<Execute xmlns=\"http://schemas.microsoft.com/xrm/2011/Contracts/Services\"");
     request.push(" xmlns:i=\"http://www.w3.org/2001/XMLSchema-instance\">");
     request.push("<request i:type=\"b:AssignRequest\"");
     request.push(" xmlns:a=\"http://schemas.microsoft.com/xrm/2011/Contracts\"");
     request.push(" xmlns:b=\"http://schemas.microsoft.com/crm/2011/Contracts\">");
     request.push("<a:Parameters xmlns:c=\"http://schemas.datacontract.org/2004/07/System.Collections.Generic\">");
     request.push("<a:KeyValuePairOfstringanyType>");
     request.push("<c:key>Target</c:key>");
     request.push("<c:value i:type=\"a:EntityReference\">");
     request.push("<a:Id>" + this._xmlEncode(Target) + "</a:Id>");
     request.push("<a:LogicalName>" + this._xmlEncode(Type) + "</a:LogicalName>");
     request.push("<a:Name i:nil=\"true\" />");
     request.push("</c:value>");
     request.push("</a:KeyValuePairOfstringanyType>");
     request.push("<a:KeyValuePairOfstringanyType>");
     request.push("<c:key>Assignee</c:key>");
     request.push("<c:value i:type=\"a:EntityReference\">");
     request.push("<a:Id>" + this._xmlEncode(Assignee) + "</a:Id>");
     request.push("<a:LogicalName>systemuser</a:LogicalName>");
     request.push("<a:Name i:nil=\"true\" />");
     request.push("</c:value>");
     request.push("</a:KeyValuePairOfstringanyType>");
     request.push("</a:Parameters>");
     request.push("<a:RequestId i:nil=\"true\" />");
     request.push("<a:RequestName>Assign</a:RequestName>");
     request.push("</request>");
     request.push("</Execute>");
     request.push("</s:Body>");
     request.push("</s:Envelope>");

  var req = new XMLHttpRequest();
  req.open("POST", SDK.SOAPSamples._getClientUrl(), true)
  // Responses will return XML. It isn't possible to return JSON.
  req.setRequestHeader("Accept", "application/xml, text/xml, */*");
  req.setRequestHeader("Content-Type", "text/xml; charset=utf-8");
  req.setRequestHeader("SOAPAction", "http://schemas.microsoft.com/xrm/2011/Contracts/Services/IOrganizationService/Execute");
  req.onreadystatechange = function () { SDK.SOAPSamples.assignResponse(req, successCallback, errorCallback); };
  req.send(request.join(""));

 },
 assignResponse: function (req, successCallback, errorCallback) {
  ///<summary>
  /// Recieves the assign response
  ///</summary>
  ///<param name="req" Type="XMLHttpRequest">
  /// The XMLHttpRequest response
  ///</param>
  ///<param name="successCallback" Type="Function">
  /// The function to perform when an successfult response is returned.
  /// For this message no data is returned so a success callback is not really necessary.
  ///</param>
  ///<param name="errorCallback" Type="Function">
  /// The function to perform when an error is returned.
  /// This function accepts a JScript error returned by the _getError function
  ///</param>
     if (req.readyState == 4) {
         req.onreadystatechange = null; //avoids memory leaks
   if (req.status == 200) {
    if (successCallback != null)
    { successCallback(); }
   }
   else {
    errorCallback(SDK.SOAPSamples._getError(req.responseXML));
   }
  }
 },
 _getError: function (faultXml) {
  ///<summary>
  /// Parses the WCF fault returned in the event of an error.
  ///</summary>
  ///<param name="faultXml" Type="XML">
  /// The responseXML property of the XMLHttpRequest response.
  ///</param>
  var errorMessage = "Unknown Error (Unable to parse the fault)";
  if (typeof faultXml == "object") {
   try {
    var bodyNode = faultXml.firstChild.firstChild;
    //Retrieve the fault node
    for (var i = 0; i < bodyNode.childNodes.length; i++) {
     var node = bodyNode.childNodes[i];

     //NOTE: This comparison does not handle the case where the XML namespace changes
     if ("s:Fault" == node.nodeName) {
      for (var j = 0; j < node.childNodes.length; j++) {
       var faultStringNode = node.childNodes[j];
       if ("faultstring" == faultStringNode.nodeName) {
        errorMessage = faultStringNode.textContent;
        break;
       }
      }
      break;
     }
    }
   }
   catch (e) { };
  }
  return new Error(errorMessage);
 },
 _xmlEncode: function (strInput) {
  var c;
  var XmlEncode = '';

  if (strInput == null) {
   return null;
  }
  if (strInput == '') {
   return '';
  }

  for (var cnt = 0; cnt < strInput.length; cnt++) {
   c = strInput.charCodeAt(cnt);

   if (((c > 96) && (c < 123)) ||
            ((c > 64) && (c < 91)) ||
            (c == 32) ||
            ((c > 47) && (c < 58)) ||
            (c == 46) ||
            (c == 44) ||
            (c == 45) ||
            (c == 95)) {
    XmlEncode = XmlEncode + String.fromCharCode(c);
   }
   else {
    XmlEncode = XmlEncode + '&#' + c + ';';
   }
  }

  return XmlEncode;
 },
 _parameterCheck: function (parameter, type, errorMessage) {
  switch (type) {
   case "String":
    if (typeof parameter != "string") {
     throw new Error(errorMessage);
    }
    break;
   case "Function":
    if (typeof parameter != "function") {
     throw new Error(errorMessage);
    }
    break;
   case "EntityFilters":
    var found = false;
    for (x in this.EntityFilters) {
     if (this.EntityFilters[x] == parameter) {
      found = true;
      break;
     }
    }
    if (!found) {
     throw new Error(errorMessage);
    }
    break;
   case "Boolean":
    if (typeof parameter != "boolean") {
     throw new Error(errorMessage);
    }
    break;
   case "GUID":
    var re = new RegExp("[0-9a-fA-F]{8}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{12}");
    if (!(typeof parameter == "string" && re.test(parameter))) {
     throw new Error(errorMessage);
    }

    break;
   default:
    throw new Error("An invalid type parameter value was passed to the SDK.MetaData._parameterCheck function.");
    break;
  }
 },
 __namespace: true
};

Test the JScript library

After you have prepared your JScript library you should perform some initial testing to confirm that it works as you expect. Because authentication only occurs within the application you must create a script web resource in Microsoft Dynamics CRM 2015 using the contents of your library. To use the functions in your library you will need some UI element, either a form or an HTML web resource to call the JScript functions in your library. The following procedure describes using a simple HTML web resource to test the functions in the library.

  1. Create an HTML document using the following code:

    Copy Code
    <html xmlns="http://www.w3.org/1999/xhtml">
<head>
 <title>Assign Test</title>
 <meta http-equiv="X-UA-Compatible" content="IE=edge" />
  <script src="../ClientGlobalContext.js.aspx" type="text/javascript"></script>
 <script src="Scripts/SDK.REST.js" type="text/javascript"></script>
 <script src="Scripts/SDK.SOAPSample.Assign.js" type="text/javascript"></script>
 <script type="text/javascript">
  var resultsArea = null;
  var userid;
  var accountid;
  var userLookup;
  var accountLookup;
  var accountsToShow = 10;
  var usersToShow = 10;
  var users = [];
  var accounts = [];

  document.onreadystatechange = function () {
   ///<summary>
   /// Initializes the sample when the document is ready
   ///</summary>
   if (document.readyState == "complete") {
    userid = document.getElementById("userid");
    accountid = document.getElementById("accountid");
    resultsArea = document.getElementById("results");
    userLookup = document.getElementById("userLookup");
    accountLookup = document.getElementById("accountLookup");

    populateUserLookup();
    populateAccountLookup();

   }
  }

  function testAssign() {
   //The field to enter the user id of the person the account record should be assigned to.
   userid.value;
   // The field to enter the account id of the account record to assign to the user
   accountid.value;
   // Since the response does not include any data to parse, simply display a success message.
   var successCallback = function () { setText(resultsArea, "Success!"); };
   // Display the error from the message passed back from the response.
   var errorCallback = function (error) { setText(resultsArea,"errorCallback error: "+error.message); };
   // Call the function
   try {
    SDK.SOAPSamples.assignRequest(userid.value, accountid.value, "account", successCallback, errorCallback);
   }
   catch (e) {
    setText(resultsArea, e.message);
   }

  }

  function populateUserLookup() {
   SDK.REST.retrieveMultipleRecords("SystemUser",
   "$top=" + usersToShow + "&$select=FullName,SystemUserId&$filter=FullName ne 'INTEGRATION' and FullName ne 'SYSTEM'",
   function (results) {
    for (var i = 0; i < results.length; i++) {
     users.push(results[i]);
    }
   },
   function (error) {
    alert(error.message);
   },
   function () {
    for (var i = 0; i < users.length; i++) {
     var user = users[i];
     userLookup.options[i] = new Option(user.FullName, user.SystemUserId);
    }
    userid.value = userLookup.options[0].value;

    userLookup.onchange = function () {
     userid.value = userLookup.options[userLookup.selectedIndex].value;
     clearMessage();
    };

   });
  }

  function populateAccountLookup() {
   SDK.REST.retrieveMultipleRecords("Account",
    "$top=" + accountsToShow + "&$select=AccountId,Name,OwnerId",
   function (results) {
    for (var i = 0; i < results.length; i++) {
     accounts.push(results[i]);

    }
   },
   function (error) {
    alert(error.message);
   },
   function () {
    for (var i = 0; i < accounts.length; i++) {
     var account = accounts[i];
     accountLookup.options[i] = new Option(account.Name + " : " + account.OwnerId.Name, account.AccountId);

    }
    accountid.value = accountLookup.options[0].value;

    accountLookup.onchange = function () {
     accountid.value = accountLookup.options[accountLookup.selectedIndex].value;
     clearMessage();
    };
   });
  }

  function clearMessage() {
   setText(resultsArea, "");
  }

  function setText(element, text) {
   if (typeof (element.innerText) != "undefined") {
    element.innerText = text;
   }
   else {
    element.textContent = text;
   }

  }

 </script>
</head>
<body>
 <table>
  <tr>
   <td>
    <label for="userid">
     SystemUserId:</label>
   </td>
   <td>
    <input id="userid" type="text" style="width:270px;"  />
   </td>
   <td>
   <select id="userLookup"></select>
   </td>
  </tr>
  <tr>
   <td>
    <label for="accountid">
     AccountId:</label>
   </td>
   <td>
    <input id="accountid" type="text" style="width:270px;" />
   </td>
      <td>
   <select id="accountLookup"></select>
   </td>
  </tr>
 </table>
 <button id="testAssign" title="Click this button to test the testAssign function." onclick="testAssign();">
  Test Assign</button>
 <div id="results">
  &nbsp;</div>
</body>
</html>

  2. Create an HTML web resource using this code. The full name of the HTML web resource will depend on the customization prefix of your solution. Assuming your solution customization prefix is ”new”, name this HTML web resource “new_/AssignTest.htm”. The specific customization prefix used has no effect on this example as long as all the web resources use the same customization prefix.

  3. Create a script web resource using the content of the JScript library. Name this web resource “new_/Scripts/SDK.SOAPSample.Assign.js”.

  4. Publish all customizations and open the new_/AssignTest.htm web resource. Click the Preview button.

  5. Using the same process you used in step three of the To Edit the SOAPLogger solution procedure, identify valid System User and Account record Id values and paste them into the page. Then click Test Assign to confirm you get a success response.

  6. Enter invalid values to confirm that the error is being parsed properly.

    For example, if you enter “A Store (sample)” rather than the Id for an account you should expect the following error message:

    Copy Code
    The formatter threw an exception while trying to deserialize the message:

There was an error while trying to deserialize parameter http://schemas.microsoft.com/xrm/2011/Contracts/Services:request.

The InnerException message was 'There was an error deserializing the object of type Microsoft.Xrm.Sdk.OrganizationRequest.

The value 'A Store (sample)' cannot be parsed as the type 'Guid'.'.  Please see InnerException for more details.

    If there is not an account record for the AccountId, the message you would expect is:

    Copy Code
    Account With Id = 883c3084-1f2f-e011-ad66-00155dba3814 Does Not Exist

Create an Interactive Web Resource

The next step is to use your JScript library in a form script, a Ribbon command or a web resource. The following code sample represents an HTML web resource that uses the REST endpoint to retrieve lists of SystemUser and Account records to provide an interactive user interface to assign account records to users. This page uses the Scripts/SDK.SOAPSample.Assign.js script web resource and a script web resource using the json2.js library to support the use of JSON objects with the REST endpoint. The SDK.REST.js library is used to retrieve data using the REST endpoint.

Copy Code
<html lang="en-us">
<head>
 <title>Assign Accounts Page</title>
 <meta http-equiv="X-UA-Compatible" content="IE=edge" />
 <style type="text/css">
  body
  {
   font-family: Segoe UI;
   background-color: #EFF2F6;
  }
  .dataTable
  {
   border-collapse: collapse;
   border: 1px solid black;
  }
  .tableHead
  {
   background-color: #C0C0C0;
   width: 100%;
  }
  .grid
  {
   border-bottom: 1px solid black;
  }
  td
  {
   padding-left: 5px;
   padding-right: 5px;
  }
  #accountList
  {
   background-color: White;
  }
  #checkboxCol
  {
   border-right: 1px solid black;
   width: 20px;
  }
  #nameCol
  {
   border-right: 1px solid black;
   width: 300px;
  }
  #ownerCol
  {
   width: 300px;
  }
 </style>
 <script src="../ClientGlobalContext.js.aspx" type="text/javascript"></script>
 <script src="Scripts/SDK.REST.js" type="text/javascript"></script>
 <script src="Scripts/SDK.SOAPSample.Assign.js" type="text/javascript"></script>
 <script type="text/javascript">
  //Set variables for page elements
  var userSelect; //The select control used to select the user to assign records to.
  var accountList; //The tbody element that rows will be added to for each retrieved account
  var selectAll; //The checkbox to select all the retrieved accounts
  var btnAssign; //The button to assign assign the accounts
  var tableCaption; //A label hidden on load
  var dataTable; //the table element hidden on load
  var alertFlag; // Alert flag to indicate the changes
  var users = []; //SystemUser records retrieved
  var accounts = []; //Accounts not assigned to the currently selected user.
  var accountsToShow = 5;
  var suppressRetrievedAccountsAlert = false;
  var accountsToAssign = [];
  var userId = null;

  function startSample() {
   ///<summary>
   /// Starts the sample
   ///</summary>
   alertFlag = document.getElementById("dispalert");
   userSelect = document.getElementById("userList");
   //A new set of a 5 accounts will be retrieved when the user changes
   userSelect.onchange = getAccounts;

   accountList = document.getElementById("accountList");
   selectAll = document.getElementById("selectAll");
   //When the select all checkbox is clicked, toggle the selection for each row of the table.
   selectAll.onclick = toggleSelectAllRecords;
   btnAssign = document.getElementById("btnAssign");
   //Add a helper function to enable or disable the assign button.
   btnAssign.setEnabled = setEnabled;
   //Set the event handler to the Assign button
   btnAssign.onclick = assignAccounts;
   tableCaption = document.getElementById("tableCaption");
   dataTable = document.getElementById("dataTable");
   var divSample = document.getElementById("divSample");
   //Load the list of users
   getUsers();
   divSample.style.display = "block";

   document.getElementById("btnStart").setAttribute("disabled", "disabled");

  }
  function getUsers() {
   SDK.REST.retrieveMultipleRecords("SystemUser",
   "$select=FullName,SystemUserId&$filter=FullName ne 'INTEGRATION' and FullName ne 'SYSTEM'",
   function (results) {
    for (var i = 0; i < results.length; i++) {
     users.push(results[i]);
    }
   },
   function (error) {
    showMessage(error.message);
   },
   function () {
    if (users.length > 1) {
     for (var i = 0; i < users.length; i++) {
      var user = users[i];
      userSelect.options[i + 1] = new Option(user.FullName, user.SystemUserId);
     }
     userSelect.removeAttribute("disabled");

     if (alertFlag.checked == true) {
      alert(users.length + " system users retrieved");
     }

    }
    else {
     var notification = "This sample requires that more than one user is available in the organization.";
     showMessage(notification);
     if (alertFlag.checked == true) {
      alert("This sample requires that more than one user is available in the organization.");
     }

    }
   });
  }
  function getAccounts() {
   //Clear out any records displayed in the table
   clearAccountList();
   var selectedUserId = userSelect.options[userSelect.selectedIndex].value;
   if (selectedUserId != "none") {

    SDK.REST.retrieveMultipleRecords("Account",
    "$top=" + accountsToShow + "&$select=AccountId,Name,OwnerId&$filter=OwnerId/Id ne (guid'" + encodeURIComponent(selectedUserId) + "')",
    function (results) {
     accounts.length = 0;
     for (var i = 0; i < results.length; i++) {
      accounts.push(results[i]);
     }
    },
    function (error) {
     showMessage(error.message);
    },
    function () {
     //onComplete
     if (accounts.length > 0) {

      for (var i = 0; i < accounts.length; i++) {
       var account = accounts[i];

       var row = document.createElement("tr");
       row.setAttribute("class", "grid");
       row.setAttribute("id", account.AccountId);
       var checkboxCell = document.createElement("td");
       var checkbox = document.createElement("input");
       checkbox.setAttribute("type", "checkbox");
       checkbox.onclick = validateAssignButton;
       checkboxCell.appendChild(checkbox);
       row.appendChild(checkboxCell);
       var nameCell = document.createElement("td");
       setText(nameCell, account.Name);
       row.appendChild(nameCell);
       var userNameCell = document.createElement("td");
       setText(userNameCell, account.OwnerId.Name);
       row.appendChild(userNameCell);
       accountList.appendChild(row);

      }

      if (alertFlag.checked == true && !suppressRetrievedAccountsAlert) {
       alert(accounts.length + " account records retrieved.");
       suppressRetrievedAccountsAlert = false;

      }
     }
     else {
      //If no records are returned display a message.
      clearAccountList();
      var row = document.createElement("tr");
      var cell = document.createElement("td");
      cell.setAttribute("colSpan", "3");
      setText(cell, "No Accounts were retrieved");
      row.appendChild(cell);
      accountList.appendChild(row);

     }
     //Show any of the UI elements that are initially hidden
     setVisibleUIElements(true);
    });
   }
   else { setVisibleUIElements(false); }
  }
  function assignAccounts() {
   ///<summary>
   /// queues the selected accounts to be assigned sequentially
   ///</summary>
   userId = userSelect.options[userSelect.selectedIndex].value;

   var checkboxes = accountList.getElementsByTagName("input");
   for (var i = checkboxes.length - 1; i >= 0; i--) {
    if (checkboxes[i].checked) {
     var accountId = checkboxes[i].parentElement.parentElement.id;
     accountsToAssign.push(accountId);
    }
   }
   assignNextAccount();
   selectAll.checked = false;
  }
  function assignNextAccount() {
   /// <summary>Assigns the queued accounts</summary>
   //Prevents a generic SQL error that can occur when too many assign requests occur in rapid succession
   if (accountsToAssign.length > 0) {
    SDK.SOAPSamples.assignRequest(userId, accountsToAssign.shift(), "account", function () {
     assignNextAccount();
    }, function (error) {
     showMessage("There was an error assigning the account with Id :" + accountId + ". The error message is " + error.message + ".");
     assignNextAccount();
    });

   }
   else {
    suppressRetrievedAccountsAlert = true;
    getAccounts();
    btnAssign.setEnabled(false)
    if (alertFlag.checked == true) {
     alert("Record assignment completed and next set of records retrieved.");
    }
   }

  }
  function showMessage(message) {
   ///<summary>
   /// Helper function to display message on the page if necessary.
   ///</summary
   var dvMessage = document.createElement("div");
   dvMessage.innerHTML = SDK.SOAPSamples._xmlEncode(message);
   document.getElementById("status").appendChild(dvMessage);
  }
  function clearAccountList() {
   ///<summary>
   /// Helper function remove rows from the Account List table.
   ///</summary
   for (var i = (accountList.rows.length - 1) ; i >= 0; i--) {
    accountList.deleteRow(i);
   }
   accounts.length = 0;

  }
  function toggleSelectAllRecords() {
   ///<summary>
   /// Helper function to toggle all selected rows in the account list table.
   ///</summary
   var checkboxes = accountList.getElementsByTagName("input");
   for (var i = 0; i < checkboxes.length; i++) {
    checkboxes[i].checked = this.checked;
   }
   btnAssign.setEnabled(this.checked);

  }
  function validateAssignButton() {
   ///<summary>
   /// Helper function to enable the Assign Records button when rows are selected.
   ///</summary
   if (this.checked == true)
   { btnAssign.setEnabled(true); }
   else {
    selectAll.checked = false;
    var checkboxes = accountList.getElementsByTagName("input");
    var checked = false;
    for (var i = 0; i < checkboxes.length; i++) {
     if (checkboxes[i].checked == true) {
      checked = true;
      break;
     }
    }
    btnAssign.setEnabled(checked);
   }
  }
  function setEnabled(bool) {
   ///<summary>
   /// Helper method attached to the Assign button to make it easier to enable/disable the button.
   ///</summary
   if (bool)
   { this.removeAttribute("disabled"); }
   else
   { this.setAttribute("disabled", "disabled"); }
  }
  function setVisibleUIElements(display) {
   ///<summary>
   /// Helper function to show those UI elements initially hidden.
   ///</summary
   if (display) {
    show(tableCaption);
    show(dataTable);
    show(btnAssign);
   }
   else {
    hide(tableCaption);
    hide(dataTable);
    hide(btnAssign);
   }

  }
  function show(element) {
   if (element.tagName.toLowerCase() == "table") {
    element.style.display = "table";
   }
   else {
    element.style.display = "block";
   }

  }
  function hide(element) {
   element.style.display = "none";
  }
  // setText  mitigate differences in how browsers set or get text content.
  function setText(node, text) {
   if (typeof (node.innerText) != "undefined") {
    node.innerText = text;
   }
   else {
    node.textContent = text;
   }

  }

 </script>
</head>
<body>
 <h1>
  Assign Accounts Sample
 </h1>
 <p>
  This page requires JavaScript and will update dynamically.
 </p>
 <p>
  <input id="dispalert" name="dispalert" type="checkbox" value="alert" /><label for="dispalert">Display alert window when data changes.</label>
 </p>
 <p>
  Click the <b>Start</b> button to begin the sample.
 </p>
 <input type="button" id="btnStart" name="btnStart" value="Start" onclick="startSample()" />
 <div id="divSample" style="display: none">
  <label for="userList">
   User:
  </label>
  <select id="userList" name="userList" title="Select a system user from this list." disabled>
   <option value="none">Select a User...</option>
  </select>
  <p id="tableCaption" style="display: none;">
   Top 5 Accounts not assigned to the selected user:
  </p>
  <table class="dataTable" id="dataTable" style="display: none; width: 100%;">
   <thead>
    <tr class="tableHead">
     <th scope="col" id="checkboxCol">
      <input id="selectAll" name="selectAll" title="Select this to select all records" type="checkbox" /><label for="selectAll">Select&nbsp;All</label>
     </th>
     <th scope="col" id="nameCol">
      Name
     </th>
     <th scope="col" id="ownerCol">
      Owner
     </th>
    </tr>
   </thead>
   <tbody id="accountList"></tbody>
  </table>
  <label style="display: none;" for="btnAssign">
   Click to assign selected records
  </label>
  <button id="btnAssign" name="btnAssign" disabled style="display: none; float: right;">
   Assign Records
  </button>
  <label style="display: none;" for="btnAssign">
   Click to assign selected records
  </label>
  <button id="Button1" name="btnAssign" disabled style="display: none; float: right;">
   Assign Records
  </button>
 </div>
 <div id="status">
  &nbsp;
 </div>
</body>
</html>

See Also

Concepts

Use the Modern app SOAP endpoint for modern applications with web resources
JavaScript libraries for Microsoft Dynamics CRM

Other Resources

Sample: Retrieve entity metadata using JavaScript
Use web service data in web resources (OData and Modern app SOAP endpoint)
Write applications and server extensions
AssignRequest
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve entity metadata using JavaScript
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK\SampleCode\JS\SOAPForJScript\SOAPForJScript\MetaDataDemo.htm

SDK\SampleCode\JS\SOAPForJScript\SOAPForJScript\Scripts\SDK.MetaData.js

Requirements

To use this code you must create Web resources for each file. The names for each Web resource must follow this pattern:

  • <solution publisher customization prefix>_/MetaDataDemo.htm
  • <solution publisher customization prefix>_/Scripts/SDK.MetaData.js

If you just want to see how this sample works, you can install (import) the SOAPEndpointforJScript_1_0_0_1_managed.zip managed solution included in the download files at SDK\SampleCode\JS\SOAPForJScript. If you install this managed solution and want to create the Web resources using the names in this topic, your solution publisher customization prefix cannot be “sample” unless you uninstall (delete) the managed solution.

Demonstrates

This sample shows how to how to use a sample JavaScript library that was created using the process described in Walkthrough: Use the Modern app SOAP endpoint with JavaScript. This library supports the use of the RetrieveAllEntitiesRequest and RetrieveEntityRequest messages using asynchronous JavaScript.

Example

The MetaDataDemo.htm page retrieves data using the SDK.MetaData.RetrieveAllEntities and SDK.MetaData.RetrieveEntity functions contained within the SDK.MetaData.js file.

When the page loads it retrieves information about all the entities in the system and then displays a list showing the SchemaName for each entity. When you click an entity list item, information about the entity attributes are retrieved and the attribute SchemaName is displayed. After the attributes have been retrieved, clicking an entity list item toggles the display of the list of attributes.

Copy Code
<html lang="en-US">
<head>
 <title>Metadata Demonstration</title>
 <meta http-equiv="X-UA-Compatible" content="IE=edge" />
  <script src="../ClientGlobalContext.js.aspx" type="text/javascript"></script>
 <script src="Scripts/SDK.MetaData.js" type="text/javascript"></script>
 <script type="text/javascript">
  // An unordered list element to add Entity list items to
  var results;
  // An area to display messages
  var message;

  // Alert flag to indicate the changes
  var alertFlag;

  function startSample() {
   ///<summary>
   /// Initializes the sample when the document is ready
   ///</summary>
   //Assign the global variables
   results = document.getElementById("results");
   message = document.getElementById("message");
   alertFlag = document.getElementById("dispalert");
   document.getElementById("btnstartSample").setAttribute("disabled", "disabled");
   //Retrieve entities
   SDK.Metadata.RetrieveAllEntities(SDK.Metadata.EntityFilters.Entity,
    false,
    successRetrieveAllEntities,
    errorRetrieveAllEntities);
   setText(message, "Loading...");

  }

  function successRetrieveAllEntities(entityMetadataCollection) {
   ///<summary>
   /// Receives the data from SDK.Metadata.RetrieveAllEntities and
   /// appends a list item to results for each one.
   ///</summary>

   entityMetadataCollection.sort(function (a, b) {
    if (a.LogicalName < b.LogicalName)
    { return -1 }
    if (a.LogicalName > b.LogicalName)
    { return 1 }
    return 0;
   });

   for (var i = 0; i < entityMetadataCollection.length; i++) {

    var entity = entityMetadataCollection[i];
    var entityNode = document.createElement("li");
    var entitySpan = document.createElement("span");

    setText(entitySpan, entity.SchemaName);
    entitySpan.id = entity.LogicalName;
    entitySpan.title = "Click to Retrieve Attributes.";
    entitySpan.attributesRetrieved = false;
    // Add the event handler to retrieve attributes
    entitySpan.onclick = retrieveAttributes;
    entitySpan.style.cursor = "pointer";

    entityNode.appendChild(entitySpan);
    results.appendChild(entityNode);

   }

   setText(message, entityMetadataCollection.length +
   " entities retrieved. Click each entity to retrieve the entity attributes.");
   if (alertFlag.checked == true)
    alert("Entity List Retrieved.");
  }
  function errorRetrieveAllEntities(error) {
   ///<summary>
   /// Displays the error returned from  SDK.Metadata.RetrieveAllEntities if it fails.
   ///</summary>
   setText(message, error.message);
   if (alertFlag.checked == true)
    alert("An Error occurred.");
  }

  function retrieveAttributes() {
   ///<summary>
   /// Retrieves attributes for the entity list item that is clicked
   ///</summary>
   if (this.attributesRetrieved == false) {
    var entityLogicalName = this.id;
    // Display an entity list item level notification while retrieving data.
    var notification = document.createElement("span");

    setText(notification, "   Retrieving attributes for " + getText(this) + "...");
    notification.id = entityLogicalName + "Notification";
    this.parentElement.appendChild(notification);

    SDK.Metadata.RetrieveEntity(SDK.Metadata.EntityFilters.Attributes,
    this.id,
    null,
    false,
    function (entityMetadata) { successRetrieveEntity(entityLogicalName, entityMetadata); },
    errorRetrieveEntity);

   }
   this.attributesRetrieved = true;
   this.title = "";
  }

  function successRetrieveEntity(logicalName, entityMetadata) {
   ///<summary>
   /// Retrieves attributes for the entity list item that is clicked
   ///</summary>

   // Update the entity list item notification when data is retrieved.

   entityMetadata.Attributes.sort(function (a, b) {
    if (a.LogicalName < b.LogicalName)
    { return -1 }
    if (a.LogicalName > b.LogicalName)
    { return 1 }
    return 0;
   });

   var notification = setText(document.getElementById(logicalName +
   "Notification"), "   Retrieved " + entityMetadata.Attributes.length + " attributes.");

   var attributeList = document.createElement("ul");

   for (var i = 0; i < entityMetadata.Attributes.length; i++) {
    var attribute = entityMetadata.Attributes[i];
    var attributeNode = document.createElement("li");
    setText(attributeNode, attribute.SchemaName);
    attributeList.appendChild(attributeNode);
   }
   // Access the entity list item element
   var entityNode = document.getElementById(logicalName).parentElement;

   entityNode.appendChild(attributeList);
   entityNode.attributesDisplayed = true;
   // Attach event handler to toggle display of attributes.
   entityNode.firstChild.onclick = toggleDisplayAttributes;
   entityNode.firstChild.title = "Click to hide attributes.";
   if (alertFlag.checked == true)
    alert(entityMetadata.SchemaName + " attributes retrieved.");
  }
  function errorRetrieveEntity(error) {
   ///<summary>
   /// Displays the error returned from SDK.Metadata.RetrieveEntity if it fails.
   ///</summary>
   setText(message, error.message);
   if (alertFlag.checked == true)
    alert("Error!");
  }

  function toggleDisplayAttributes() {
   ///<summary>
   /// toggles whether the list of attributes is displayed.
   ///</summary>

   if (this.parentElement.attributesDisplayed) {
    this.parentElement.lastChild.style.display = "none";
    this.parentElement.attributesDisplayed = false;
    this.title = "Click to show attributes.";

    if (alertFlag.checked == true)
     alert("Attributes were hidden.");
   }
   else {
    this.parentElement.lastChild.style.display = "block";
    this.parentElement.attributesDisplayed = true;
    this.title = "Click to hide attributes.";

    if (alertFlag.checked == true)
     alert("Attributes are displayed.");
   }

  }

  // setText and getText mitigate differences in how browsers set or get text content.
  function setText(node, text) {
   if (typeof (node.innerText) != "undefined") {
    node.innerText = text;
   }
   else {
    node.textContent = text;
   }

  }

  function getText(node) {
   if (typeof (node.innerText) != "undefined") {
    return node.innerText;
   }
   else {
    return node.textContent;
   }
  }

 </script>
</head>
<body style="font-family: Segoe UI;">
 <h1>
  Metadata Demonstration Sample</h1>
 <p>
  This form requires JavaScript and will update the page dynamically.</p>
 <p>
  <input id="dispalert" name="dispalert" type="checkbox" value="alert" /><label for="dispalert">Display alert window when data changes.</label></p>
 <p>
  <label id="lblstartSample" for="btnstartSample">
   Click to start the sample:
  </label>
  <input type="button" id="btnstartSample" name="btnstartSample" value="Start" onclick="startSample()" /></p>
 <div id="message">
 </div>
 <ul id="results">
 </ul>
</body>
</html>

The SDK.MetaData.js file is a JScript library contains the SDK.MetaData.RetrieveAllEntities and SDK.MetaData.RetrieveEntity public functions used by the calling page. These functions send asynchronous requests and pass the results back to the function specified in the successCallBack parameter for each function.

The SDK.MetaData.EntityFilters provides a type of enumeration that corresponds to the EntityFilters enumeration used by RetrieveAllEntitiesRequest and RetrieveEntityRequest messages. The rest of the private functions are used to parse the XML returned in the request results.

This example shows how the SdkClientVersion value of ‘6.0’ must be included in the SOAP header in order to return image attributes as shown in the following snippet.

Copy Code
"<soapenv:Header><a:SdkClientVersion xmlns:a=\"http://schemas.microsoft.com/xrm/2011/Contracts\">6.0</a:SdkClientVersion></soapenv:Header>",

JScript Copy Code

SDK = window.SDK || { __namespace: true };
SDK.Metadata = SDK.Metadata || { __namespace: true };

(function () {

 this.RetrieveAllEntities = function (EntityFilters, RetrieveAsIfPublished, successCallBack, errorCallBack, passThroughObject) {
  ///<summary>
  /// Sends an asynchronous RetrieveAllEntities Request to retrieve all entities in the system
  ///</summary>
  ///<returns>entityMetadataCollection</returns>
  ///<param name="EntityFilters" type="Number">
  /// SDK.Metadata.EntityFilters provides an enumeration for the filters available to filter which data is retrieved.
  /// Include only those elements of the entity you want to retrieve. Retrieving all parts of all entitities may take significant time.
  ///</param>
  ///<param name="RetrieveAsIfPublished" type="Boolean">
  /// Sets whether to retrieve the metadata that has not been published.
  ///</param>
  ///<param name="successCallBack" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function must accept the entityMetadataCollection as a parameter.
  ///</param>
  ///<param name="errorCallBack" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  ///</param>
  ///<param name="passThroughObject" optional="true"  type="Object">
  /// An Object that will be passed through to as the second parameter to the successCallBack.
  ///</param>
  if ((typeof EntityFilters != "number") || (EntityFilters < 1 || EntityFilters > 15))
  { throw new Error("SDK.Metadata.RetrieveAllEntities EntityFilters must be a SDK.Metadata.EntityFilters value."); }
  if (typeof RetrieveAsIfPublished != "boolean")
  { throw new Error("SDK.Metadata.RetrieveAllEntities RetrieveAsIfPublished must be a boolean value."); }
  if (typeof successCallBack != "function")
  { throw new Error("SDK.Metadata.RetrieveAllEntities successCallBack must be a function."); }
  if (typeof errorCallBack != "function")
  { throw new Error("SDK.Metadata.RetrieveAllEntities errorCallBack must be a function."); }

  var entityFiltersValue = _evaluateEntityFilters(EntityFilters);

  var request = [
  "<soapenv:Envelope xmlns:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\">",
    //Allows retrieval if ImageAttributeMetadata objects
  "<soapenv:Header><a:SdkClientVersion xmlns:a=\"http://schemas.microsoft.com/xrm/2011/Contracts\">7.0</a:SdkClientVersion></soapenv:Header>",
   "<soapenv:Body>",
    "<Execute xmlns=\"http://schemas.microsoft.com/xrm/2011/Contracts/Services\" xmlns:i=\"http://www.w3.org/2001/XMLSchema-instance\">",
     "<request i:type=\"a:RetrieveAllEntitiesRequest\" xmlns:a=\"http://schemas.microsoft.com/xrm/2011/Contracts\">",
      "<a:Parameters xmlns:b=\"http://schemas.datacontract.org/2004/07/System.Collections.Generic\">",
       "<a:KeyValuePairOfstringanyType>",
        "<b:key>EntityFilters</b:key>",
        "<b:value i:type=\"c:EntityFilters\" xmlns:c=\"http://schemas.microsoft.com/xrm/2011/Metadata\">" + _xmlEncode(entityFiltersValue) + "</b:value>",
       "</a:KeyValuePairOfstringanyType>",
       "<a:KeyValuePairOfstringanyType>",
        "<b:key>RetrieveAsIfPublished</b:key>",
        "<b:value i:type=\"c:boolean\" xmlns:c=\"http://www.w3.org/2001/XMLSchema\">" + _xmlEncode(RetrieveAsIfPublished.toString()) + "</b:value>",
       "</a:KeyValuePairOfstringanyType>",
      "</a:Parameters>",
      "<a:RequestId i:nil=\"true\" />",
      "<a:RequestName>RetrieveAllEntities</a:RequestName>",
    "</request>",
   "</Execute>",
  "</soapenv:Body>",
  "</soapenv:Envelope>"].join("");
  var req = new XMLHttpRequest();
  req.open("POST", _getUrl() + "/XRMServices/2011/Organization.svc/web", true);
  try { req.responseType = 'msxml-document'} catch(e){}
  req.setRequestHeader("Accept", "application/xml, text/xml, */*");
  req.setRequestHeader("Content-Type", "text/xml; charset=utf-8");
  req.setRequestHeader("SOAPAction", "http://schemas.microsoft.com/xrm/2011/Contracts/Services/IOrganizationService/Execute");
  req.onreadystatechange = function () {
   if (req.readyState == 4 /* complete */) {
   req.onreadystatechange = null; //Addresses potential memory leak issue with IE
    if (req.status == 200) {
     //Success
     var doc = req.responseXML;
     try{_setSelectionNamespaces(doc);}catch(e){}
     var entityMetadataNodes = _selectNodes(doc, "//c:EntityMetadata");
     var entityMetadataCollection = [];
     for (var i = 0; i < entityMetadataNodes.length; i++) {
      var a = _objectifyNode(entityMetadataNodes[i]);
      a._type = "EntityMetadata";
      entityMetadataCollection.push(a);
     }

     successCallBack(entityMetadataCollection, passThroughObject);
    }
    else {
     errorCallBack(_getError(req));
    }
   }
  };
  req.send(request);

 };

 this.RetrieveEntity = function (EntityFilters, LogicalName, MetadataId, RetrieveAsIfPublished, successCallBack, errorCallBack, passThroughObject) {
  ///<summary>
  /// Sends an asynchronous RetrieveEntity Request to retrieve a specific entity
  ///</summary>
  ///<returns>entityMetadata</returns>
  ///<param name="EntityFilters" type="Number">
  /// SDK.Metadata.EntityFilters provides an enumeration for the filters available to filter which data is retrieved.
  /// Include only those elements of the entity you want to retrieve. Retrieving all parts of all entitities may take significant time.
  ///</param>
  ///<param name="LogicalName" optional="true" type="String">
  /// The logical name of the entity requested. A null value may be used if a MetadataId is provided.
  ///</param>
  ///<param name="MetadataId" optional="true" type="String">
  /// A null value or an empty guid may be passed if a LogicalName is provided.
  ///</param>
  ///<param name="RetrieveAsIfPublished" type="Boolean">
  /// Sets whether to retrieve the metadata that has not been published.
  ///</param>
  ///<param name="successCallBack" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function must accept the entityMetadata as a parameter.
  ///</param>
  ///<param name="errorCallBack" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  ///</param>
  ///<param name="passThroughObject" optional="true"  type="Object">
  /// An Object that will be passed through to as the second parameter to the successCallBack.
  ///</param>
  if ((typeof EntityFilters != "number") || (EntityFilters < 1 || EntityFilters > 15))
  { throw new Error("SDK.Metadata.RetrieveEntity EntityFilters must be a SDK.Metadata.EntityFilters value."); }
  if (LogicalName == null && MetadataId == null) {
   throw new Error("SDK.Metadata.RetrieveEntity requires either the LogicalName or MetadataId parameter not be null.");
  }
  if (LogicalName != null) {
   if (typeof LogicalName != "string")
   { throw new Error("SDK.Metadata.RetrieveEntity LogicalName must be a string value."); }
   MetadataId = "00000000-0000-0000-0000-000000000000";
  }
  if (MetadataId != null && LogicalName == null) {
   if (typeof MetadataId != "string")
   { throw new Error("SDK.Metadata.RetrieveEntity MetadataId must be a string value."); }
  }
  if (typeof RetrieveAsIfPublished != "boolean")
  { throw new Error("SDK.Metadata.RetrieveEntity RetrieveAsIfPublished must be a boolean value."); }
  if (typeof successCallBack != "function")
  { throw new Error("SDK.Metadata.RetrieveEntity successCallBack must be a function."); }
  if (typeof errorCallBack != "function")
  { throw new Error("SDK.Metadata.RetrieveEntity errorCallBack must be a function."); }
  var entityFiltersValue = _evaluateEntityFilters(EntityFilters);

  var entityLogicalNameValueNode = "";
  if (LogicalName == null)
  { entityLogicalNameValueNode = "<b:value i:nil=\"true\" />"; }
  else
  { entityLogicalNameValueNode = "<b:value i:type=\"c:string\"   xmlns:c=\"http://www.w3.org/2001/XMLSchema\">" + _xmlEncode(LogicalName.toLowerCase()) + "</b:value>"; }
  var request = [
  "<soapenv:Envelope xmlns:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\">",
    //Allows retrieval if ImageAttributeMetadata objects
  "<soapenv:Header><a:SdkClientVersion xmlns:a=\"http://schemas.microsoft.com/xrm/2011/Contracts\">6.0</a:SdkClientVersion></soapenv:Header>",
   "<soapenv:Body>",
    "<Execute xmlns=\"http://schemas.microsoft.com/xrm/2011/Contracts/Services\" xmlns:i=\"http://www.w3.org/2001/XMLSchema-instance\">",
     "<request i:type=\"a:RetrieveEntityRequest\" xmlns:a=\"http://schemas.microsoft.com/xrm/2011/Contracts\">",
      "<a:Parameters xmlns:b=\"http://schemas.datacontract.org/2004/07/System.Collections.Generic\">",
       "<a:KeyValuePairOfstringanyType>",
        "<b:key>EntityFilters</b:key>",
        "<b:value i:type=\"c:EntityFilters\" xmlns:c=\"http://schemas.microsoft.com/xrm/2011/Metadata\">" + _xmlEncode(entityFiltersValue) + "</b:value>",
       "</a:KeyValuePairOfstringanyType>",
       "<a:KeyValuePairOfstringanyType>",
        "<b:key>MetadataId</b:key>",
        "<b:value i:type=\"ser:guid\"  xmlns:ser=\"http://schemas.microsoft.com/2003/10/Serialization/\">" + _xmlEncode(MetadataId) + "</b:value>",
       "</a:KeyValuePairOfstringanyType>",
       "<a:KeyValuePairOfstringanyType>",
        "<b:key>RetrieveAsIfPublished</b:key>",
        "<b:value i:type=\"c:boolean\" xmlns:c=\"http://www.w3.org/2001/XMLSchema\">" + _xmlEncode(RetrieveAsIfPublished.toString()) + "</b:value>",
       "</a:KeyValuePairOfstringanyType>",
       "<a:KeyValuePairOfstringanyType>",
        "<b:key>LogicalName</b:key>",
         entityLogicalNameValueNode,
       "</a:KeyValuePairOfstringanyType>",
      "</a:Parameters>",
      "<a:RequestId i:nil=\"true\" />",
      "<a:RequestName>RetrieveEntity</a:RequestName>",
     "</request>",
    "</Execute>",
   "</soapenv:Body>",
  "</soapenv:Envelope>"].join("");
  var req = new XMLHttpRequest();
  req.open("POST", _getUrl() + "/XRMServices/2011/Organization.svc/web", true);
  try { req.responseType = 'msxml-document'} catch(e){}
  req.setRequestHeader("Accept", "application/xml, text/xml, */*");
  req.setRequestHeader("Content-Type", "text/xml; charset=utf-8");
  req.setRequestHeader("SOAPAction", "http://schemas.microsoft.com/xrm/2011/Contracts/Services/IOrganizationService/Execute");
  req.onreadystatechange = function () {
   if (req.readyState == 4 /* complete */) {
   req.onreadystatechange = null; //Addresses potential memory leak issue with IE
    if (req.status == 200) {
     var doc = req.responseXML;
     try{_setSelectionNamespaces(doc);}catch(e){}
     var a = _objectifyNode(_selectSingleNode(doc, "//b:value"));
     a._type = "EntityMetadata";
     successCallBack(a, passThroughObject);
    }
    else {
     //Failure
     errorCallBack(_getError(req));
    }
   }

  };
  req.send(request);

 };

 this.RetrieveAttribute = function (EntityLogicalName, LogicalName, MetadataId, RetrieveAsIfPublished, successCallBack, errorCallBack, passThroughObject) {
  ///<summary>
  /// Sends an asynchronous RetrieveAttribute Request to retrieve a specific entity
  ///</summary>
  ///<returns>AttributeMetadata</returns>
  ///<param name="EntityLogicalName"  optional="true" type="String">
  /// The logical name of the entity for the attribute requested. A null value may be used if a MetadataId is provided.
  ///</param>
  ///<param name="LogicalName" optional="true" type="String">
  /// The logical name of the attribute requested.
  ///</param>
  ///<param name="MetadataId" optional="true" type="String">
  /// A null value may be passed if an EntityLogicalName and LogicalName is provided.
  ///</param>
  ///<param name="RetrieveAsIfPublished" type="Boolean">
  /// Sets whether to retrieve the metadata that has not been published.
  ///</param>
  ///<param name="successCallBack" type="Function">
  /// The function that will be passed through and be called by a successful response.
  /// This function must accept the entityMetadata as a parameter.
  ///</param>
  ///<param name="errorCallBack" type="Function">
  /// The function that will be passed through and be called by a failed response.
  /// This function must accept an Error object as a parameter.
  ///</param>
  ///<param name="passThroughObject" optional="true"  type="Object">
  /// An Object that will be passed through to as the second parameter to the successCallBack.
  ///</param>
  if (EntityLogicalName == null && LogicalName == null && MetadataId == null) {
   throw new Error("SDK.Metadata.RetrieveAttribute requires either the EntityLogicalName and LogicalName  parameters or the MetadataId parameter not be null.");
  }
  if (MetadataId != null && EntityLogicalName == null && LogicalName == null) {
   if (typeof MetadataId != "string")
   { throw new Error("SDK.Metadata.RetrieveEntity MetadataId must be a string value."); }
  }
  else
  { MetadataId = "00000000-0000-0000-0000-000000000000"; }
  if (EntityLogicalName != null) {
   if (typeof EntityLogicalName != "string") {
    { throw new Error("SDK.Metadata.RetrieveAttribute EntityLogicalName must be a string value."); }
   }
  }
  if (LogicalName != null) {
   if (typeof LogicalName != "string") {
    { throw new Error("SDK.Metadata.RetrieveAttribute LogicalName must be a string value."); }
   }

  }
  if (typeof RetrieveAsIfPublished != "boolean")
  { throw new Error("SDK.Metadata.RetrieveAttribute RetrieveAsIfPublished must be a boolean value."); }
  if (typeof successCallBack != "function")
  { throw new Error("SDK.Metadata.RetrieveAttribute successCallBack must be a function."); }
  if (typeof errorCallBack != "function")
  { throw new Error("SDK.Metadata.RetrieveAttribute errorCallBack must be a function."); }

  var entityLogicalNameValueNode;
  if (EntityLogicalName == null) {
   entityLogicalNameValueNode = "<b:value i:nil=\"true\" />";
  }
  else {
   entityLogicalNameValueNode = "<b:value i:type=\"c:string\" xmlns:c=\"http://www.w3.org/2001/XMLSchema\">" + _xmlEncode(EntityLogicalName.toLowerCase()) + "</b:value>";
  }
  var logicalNameValueNode;
  if (LogicalName == null) {
   logicalNameValueNode = "<b:value i:nil=\"true\" />";
  }
  else {
   logicalNameValueNode = "<b:value i:type=\"c:string\"   xmlns:c=\"http://www.w3.org/2001/XMLSchema\">" + _xmlEncode(LogicalName.toLowerCase()) + "</b:value>";
  }
  var request = [
  "<soapenv:Envelope xmlns:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\">",
  //Allows retrieval if ImageAttributeMetadata objects
  "<soapenv:Header><a:SdkClientVersion xmlns:a=\"http://schemas.microsoft.com/xrm/2011/Contracts\">6.0</a:SdkClientVersion></soapenv:Header>",
   "<soapenv:Body>",
    "<Execute xmlns=\"http://schemas.microsoft.com/xrm/2011/Contracts/Services\" xmlns:i=\"http://www.w3.org/2001/XMLSchema-instance\">",
     "<request i:type=\"a:RetrieveAttributeRequest\" xmlns:a=\"http://schemas.microsoft.com/xrm/2011/Contracts\">",
      "<a:Parameters xmlns:b=\"http://schemas.datacontract.org/2004/07/System.Collections.Generic\">",
       "<a:KeyValuePairOfstringanyType>",
        "<b:key>EntityLogicalName</b:key>",
         entityLogicalNameValueNode,
       "</a:KeyValuePairOfstringanyType>",
       "<a:KeyValuePairOfstringanyType>",
        "<b:key>MetadataId</b:key>",
        "<b:value i:type=\"ser:guid\"  xmlns:ser=\"http://schemas.microsoft.com/2003/10/Serialization/\">" + _xmlEncode(MetadataId) + "</b:value>",
       "</a:KeyValuePairOfstringanyType>",
        "<a:KeyValuePairOfstringanyType>",
        "<b:key>RetrieveAsIfPublished</b:key>",
      "<b:value i:type=\"c:boolean\" xmlns:c=\"http://www.w3.org/2001/XMLSchema\">" + _xmlEncode(RetrieveAsIfPublished.toString()) + "</b:value>",
       "</a:KeyValuePairOfstringanyType>",
       "<a:KeyValuePairOfstringanyType>",
        "<b:key>LogicalName</b:key>",
         logicalNameValueNode,
       "</a:KeyValuePairOfstringanyType>",
      "</a:Parameters>",
      "<a:RequestId i:nil=\"true\" />",
      "<a:RequestName>RetrieveAttribute</a:RequestName>",
     "</request>",
    "</Execute>",
   "</soapenv:Body>",
  "</soapenv:Envelope>"].join("");
  var req = new XMLHttpRequest();
  req.open("POST", _getUrl() + "/XRMServices/2011/Organization.svc/web", true);
      try { req.responseType = 'msxml-document'} catch(e){}
  req.setRequestHeader("Accept", "application/xml, text/xml, */*");
  req.setRequestHeader("Content-Type", "text/xml; charset=utf-8");
  req.setRequestHeader("SOAPAction", "http://schemas.microsoft.com/xrm/2011/Contracts/Services/IOrganizationService/Execute");
  req.onreadystatechange = function () {
   if (req.readyState == 4 /* complete */) {
   req.onreadystatechange = null; //Addresses potential memory leak issue with IE
    if (req.status == 200) {
     //Success
     var doc = req.responseXML;
     try{_setSelectionNamespaces(doc);}catch(e){}
     var a = _objectifyNode(_selectSingleNode(doc, "//b:value"));

     successCallBack(a, passThroughObject);
    }
    else {
     //Failure
     errorCallBack(_getError(req));
    }
   }
  };
  req.send(request);

 };

 this.EntityFilters = function () {
  /// <summary>SDK.Metadata.EntityFilters enum summary</summary>
  /// <field name="Default" type="Number" static="true">enum field summary for Default</field>
  /// <field name="Entity" type="Number" static="true">enum field summary for Entity</field>
  /// <field name="Attributes" type="Number" static="true">enum field summary for Attributes</field>
  /// <field name="Privileges" type="Number" static="true">enum field summary for Privileges</field>
  /// <field name="Relationships" type="Number" static="true">enum field summary for Relationships</field>
  /// <field name="All" type="Number" static="true">enum field summary for All</field>
  throw new Error("Constructor not implemented this is a static enum.");
 };

 var _arrayElements = ["Attributes",
  "ManyToManyRelationships",
  "ManyToOneRelationships",
  "OneToManyRelationships",
  "Privileges",
  "LocalizedLabels",
  "Options",
  "Targets"];

  function _getError(resp) {
  ///<summary>
  /// Private function that attempts to parse errors related to connectivity or WCF faults.
  ///</summary>
  ///<param name="resp" type="XMLHttpRequest">
  /// The XMLHttpRequest representing failed response.
  ///</param>

  //Error descriptions come from http://support.microsoft.com/kb/193625
  if (resp.status == 12029)
  { return new Error("The attempt to connect to the server failed."); }
  if (resp.status == 12007)
  { return new Error("The server name could not be resolved."); }
  var faultXml = resp.responseXML;
  var errorMessage = "Unknown (unable to parse the fault)";
  if (typeof faultXml == "object") {

   var faultstring = null;
   var ErrorCode = null;

   var bodyNode = faultXml.firstChild.firstChild;

   //Retrieve the fault node
   for (var i = 0; i < bodyNode.childNodes.length; i++) {
    var node = bodyNode.childNodes[i];

    //NOTE: This comparison does not handle the case where the XML namespace changes
    if ("s:Fault" == node.nodeName) {
     for (var j = 0; j < node.childNodes.length; j++) {
      var testNode = node.childNodes[j];
      if ("faultstring" == testNode.nodeName) {
       faultstring = _getNodeText(testNode);
      }
      if ("detail" == testNode.nodeName) {
       for (var k = 0; k < testNode.childNodes.length; k++) {
        var orgServiceFault = testNode.childNodes[k];
        if ("OrganizationServiceFault" == orgServiceFault.nodeName) {
         for (var l = 0; l < orgServiceFault.childNodes.length; l++) {
          var ErrorCodeNode = orgServiceFault.childNodes[l];
          if ("ErrorCode" == ErrorCodeNode.nodeName) {
           ErrorCode = _getNodeText(ErrorCodeNode);
           break;
          }
         }
        }
       }

      }
     }
     break;
    }

   }
  }
  if (ErrorCode != null && faultstring != null) {
   errorMessage = "Error Code:" + ErrorCode + " Message: " + faultstring;
  }
  else {
   if (faultstring != null) {
    errorMessage = faultstring;
   }
  }
  return new Error(errorMessage);
 };

 function _Context() {
  var errorMessage = "Context is not available.";
  if (typeof GetGlobalContext != "undefined")
  { return GetGlobalContext(); }
  else {
   if (typeof Xrm != "undefined") {
    return Xrm.Page.context;
   }
   else
   { return new Error(errorMessage); }
  }
 };

 function _getUrl() {
     var url = _Context().getClientUrl();
  return url;
 };

 function _evaluateEntityFilters(EntityFilters) {
  var entityFilterArray = [];
  if ((1 & EntityFilters) == 1) {
   entityFilterArray.push("Entity");
  }
  if ((2 & EntityFilters) == 2) {
   entityFilterArray.push("Attributes");
  }
  if ((4 & EntityFilters) == 4) {
   entityFilterArray.push("Privileges");
  }
  if ((8 & EntityFilters) == 8) {
   entityFilterArray.push("Relationships");
  }
  return entityFilterArray.join(" ");
 };

 function _isMetadataArray(elementName) {
  for (var i = 0; i < _arrayElements.length; i++) {
   if (elementName == _arrayElements[i]) {
    return true;
   }
  }
  return false;
 };

 function _objectifyNode(node) {
  //Check for null
  if (node.attributes != null && node.attributes.length == 1) {
   if (node.attributes.getNamedItem("i:nil") != null && node.attributes.getNamedItem("i:nil").nodeValue == "true") {
    return null;
   }
  }

  //Check if it is a value
  if ((node.firstChild != null) && (node.firstChild.nodeType == 3)) {
   var nodeName = _getNodeName(node);

   switch (nodeName) {
    //Integer Values
    case "ActivityTypeMask":
    case "ObjectTypeCode":
    case "ColumnNumber":
    case "DefaultFormValue":
    case "MaxValue":
    case "MinValue":
    case "MaxLength":
    case "Order":
    case "Precision":
    case "PrecisionSource":
    case "LanguageCode":
     return parseInt(node.firstChild.nodeValue, 10);
     // Boolean values
    case "AutoRouteToOwnerQueue":
    case "CanBeChanged":
    case "CanTriggerWorkflow":
    case "IsActivity":
    case "IsAIRUpdated":
    case "IsActivityParty":
    case "IsAvailableOffline":
    case "IsChildEntity":
    case "IsCustomEntity":
    case "IsCustomOptionSet":
    case "IsDocumentManagementEnabled":
    case "IsEnabledForCharts":
    case "IsGlobal":
    case "IsImportable":
    case "IsIntersect":
    case "IsManaged":
    case "IsReadingPaneEnabled":
    case "IsValidForAdvancedFind":
    case "CanBeSecuredForCreate":
    case "CanBeSecuredForRead":
    case "CanBeSecuredForUpdate":
    case "IsCustomAttribute":
    case "IsManaged":
    case "IsPrimaryId":
    case "IsPrimaryName":
    case "IsSecured":
    case "IsValidForCreate":
    case "IsValidForRead":
    case "IsValidForUpdate":
    case "IsCustomRelationship":
    case "CanBeBasic":
    case "CanBeDeep":
    case "CanBeGlobal":
    case "CanBeLocal":
     return (node.firstChild.nodeValue == "true") ? true : false;
     //OptionMetadata.Value and BooleanManagedProperty.Value and AttributeRequiredLevelManagedProperty.Value
    case "Value":
     //BooleanManagedProperty.Value
     if ((node.firstChild.nodeValue == "true") || (node.firstChild.nodeValue == "false")) {
      return (node.firstChild.nodeValue == "true") ? true : false;
     }
     //AttributeRequiredLevelManagedProperty.Value
     if (
  (node.firstChild.nodeValue == "ApplicationRequired") ||
  (node.firstChild.nodeValue == "None") ||
  (node.firstChild.nodeValue == "Recommended") ||
  (node.firstChild.nodeValue == "SystemRequired")
  ) {
      return node.firstChild.nodeValue;
     }
     var numberValue = parseInt(node.firstChild.nodeValue, 10);
     if (isNaN(numberValue)) {
         //FormatName.Value
         return node.firstChild.nodeValue;
     }
     else {
         //OptionMetadata.Value
         return numberValue;
     }
     break;
    //String values
    default:
     return node.firstChild.nodeValue;
   }

  }

  //Check if it is a known array
  if (_isMetadataArray(_getNodeName(node))) {
   var arrayValue = [];

   for (var i = 0; i < node.childNodes.length; i++) {
    var objectTypeName;
    if ((node.childNodes[i].attributes != null) && (node.childNodes[i].attributes.getNamedItem("i:type") != null)) {
     objectTypeName = node.childNodes[i].attributes.getNamedItem("i:type").nodeValue.split(":")[1];
    }
    else {

     objectTypeName = _getNodeName(node.childNodes[i]);
    }

    var b = _objectifyNode(node.childNodes[i]);
    b._type = objectTypeName;
    arrayValue.push(b);

   }

   return arrayValue;
  }

    //Null entity description labels are returned as <label/> - not using i:nil = true;
  if(node.childNodes.length == 0)
  {
  return null;
  }

  //Otherwise return an object
  var c = {};
  if (node.attributes.getNamedItem("i:type") != null) {
   c._type = node.attributes.getNamedItem("i:type").nodeValue.split(":")[1];
  }
  for (var i = 0; i < node.childNodes.length; i++) {
   if (node.childNodes[i].nodeType == 3) {
    c[_getNodeName(node.childNodes[i])] = node.childNodes[i].nodeValue;
   }
   else {
    c[_getNodeName(node.childNodes[i])] = _objectifyNode(node.childNodes[i]);
   }

  }
  return c;
 };

 function _selectNodes(node, XPathExpression) {
  if (typeof (node.selectNodes) != "undefined") {
   return node.selectNodes(XPathExpression);
  }
  else {
   var output = [];
   var XPathResults = node.evaluate(XPathExpression, node, _NSResolver, XPathResult.ANY_TYPE, null);
   var result = XPathResults.iterateNext();
   while (result) {
    output.push(result);
    result = XPathResults.iterateNext();
   }
   return output;
  }
 };

 function _selectSingleNode(node, xpathExpr) {
  if (typeof (node.selectSingleNode) != "undefined") {
   return node.selectSingleNode(xpathExpr);
  }
  else {
   var xpe = new XPathEvaluator();
   var xPathNode = xpe.evaluate(xpathExpr, node, _NSResolver, XPathResult.FIRST_ORDERED_NODE_TYPE, null);
   return (xPathNode != null) ? xPathNode.singleNodeValue : null;
  }
 };

 function _selectSingleNodeText(node, xpathExpr) {
  var x = _selectSingleNode(node, xpathExpr);
  if (_isNodeNull(x))
  { return null; }
  if (typeof (x.text) != "undefined") {
   return x.text;
  }
  else {
   return x.textContent;
  }
 };

 function _getNodeText(node) {
  if (typeof (node.text) != "undefined") {
   return node.text;
  }
  else {
   return node.textContent;
  }
 };

 function _isNodeNull(node) {
  if (node == null)
  { return true; }
  if ((node.attributes.getNamedItem("i:nil") != null) && (node.attributes.getNamedItem("i:nil").value == "true"))
  { return true; }
  return false;
 };

 function _getNodeName(node) {
  if (typeof (node.baseName) != "undefined") {
   return node.baseName;
  }
  else {
   return node.localName;
  }
 };

 function _setSelectionNamespaces(doc)
 {
 var namespaces = [
 "xmlns:s='http://schemas.xmlsoap.org/soap/envelope/'",
 "xmlns:a='http://schemas.microsoft.com/xrm/2011/Contracts'",
 "xmlns:i='http://www.w3.org/2001/XMLSchema-instance'",
 "xmlns:b='http://schemas.datacontract.org/2004/07/System.Collections.Generic'",
 "xmlns:c='http://schemas.microsoft.com/xrm/2011/Metadata'"
 ];
 doc.setProperty("SelectionNamespaces",namespaces.join(" "));

 }

 function _NSResolver(prefix) {
  var ns = {
   "s": "http://schemas.xmlsoap.org/soap/envelope/",
   "a": "http://schemas.microsoft.com/xrm/2011/Contracts",
   "i": "http://www.w3.org/2001/XMLSchema-instance",
   "b": "http://schemas.datacontract.org/2004/07/System.Collections.Generic",
   "c": "http://schemas.microsoft.com/xrm/2011/Metadata"
  };
  return ns[prefix] || null;
 };

 function _xmlEncode(strInput) {
  var c;
  var XmlEncode = '';
  if (strInput == null) {
   return null;
  }
  if (strInput == '') {
   return '';
  }
  for (var cnt = 0; cnt < strInput.length; cnt++) {
   c = strInput.charCodeAt(cnt);
   if (((c > 96) && (c < 123)) ||
            ((c > 64) && (c < 91)) ||
            (c == 32) ||
            ((c > 47) && (c < 58)) ||
            (c == 46) ||
            (c == 44) ||
            (c == 45) ||
            (c == 95)) {
    XmlEncode = XmlEncode + String.fromCharCode(c);
   }
   else {
    XmlEncode = XmlEncode + '&#' + c + ';';
   }
  }
  return XmlEncode;
 };

}).call(SDK.Metadata);

//SDK.Metadata.EntityFilters
// this enum is written this way to enable Visual Studio IntelliSense
SDK.Metadata.EntityFilters.prototype = {
 Default: 1,
 Entity: 1,
 Attributes: 2,
 Privileges: 4,
 Relationships: 8,
 All: 15
};
SDK.Metadata.EntityFilters.Default = 1;
SDK.Metadata.EntityFilters.Entity = 1;
SDK.Metadata.EntityFilters.Attributes = 2;
SDK.Metadata.EntityFilters.Privileges = 4;
SDK.Metadata.EntityFilters.Relationships = 8;
SDK.Metadata.EntityFilters.All = 15;
SDK.Metadata.EntityFilters.__enum = true;
SDK.Metadata.EntityFilters.__flags = true;

See Also

Tasks

Walkthrough: Use the Modern app SOAP endpoint with JavaScript

Concepts

Use the Modern app SOAP endpoint for modern applications with web resources

Other Resources

Use web service data in web resources (OData and Modern app SOAP endpoint)
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write code for Microsoft Dynamics CRM forms

Form programming provides ways to interact with entity forms by using JavaScript that is executed for events that occur on the form.

In This Topic

When to use form programming

Factors to consider when you use form programming

Write form scripts that perform well

Different form presentations

Development tools

When to use form programming

Microsoft Dynamics CRM provides many options to control business processes. Form programming is one option. But remember that you have another option: business rules. Business rules provide a way for someone who does not know JavaScript and is not a developer to apply business process logic in a form. See the customization guide topic:Create and edit business rules for more information.

The primary advantage of form programming and business rules is that they are immediate. They do not require data to be submitted to the server and, therefore, provides the best performance for many scenarios. Because they allow for human interaction, they are also the most flexible option.

While business rules have an advantage because they can be created and maintained by someone who is not a developer, they have certain limitations and are not intended to replace form scripts. Form programming allows you to achieve things that cannot yet be done using business rules.

Tasks frequently performed by using form programming include the following:

  • Data validation
  • Automation
  • Process enhancement and enforcement

Data Validation

Whenever possible, you should perform validation of data while the data is being edited. The definition of the Form field will perform the most common data validation for you. For example, a Single Line of Text field formatted for an email address will not allow an invalid value to be entered into it.

Use form programming for additional validation of data that is unique to your organization. For example, your organization may have specific rules about how telephone numbers should be formatted or a minimum length for the Subject field in a service activity.

Automation

You can achieve significant productivity enhancements when you use form scripting to automate common tasks. You can set field values that depend on the data that is entered into a form, that will help save users considerable time when entering data. Using form programming for automation is valuable because it lets the user verify that a standard process is valid in a particular case. Users can make necessary adjustments before saving a record.

Process Enhancement and Enforcement

You can customize what data to display in the form or the layout of the form to optimize it for specific tasks performed by people in your organization. You can use form programming to show or hide specific form elements, or to open different forms that have been defined for an entity. You can control which fields are required based on data present in the form or in related records.

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update you can write code to control the business process flows that appear at the top of forms. More information: Write scripts for business process flows.

Factors to Consider When You Use Form Programming

The logic applied in form programming can only be executed in the browser of someone interacting within the Microsoft Dynamics CRM application entity form. Because of this, you should not rely solely on form programming to initiate or enforce processes related to your data. Records can be created or updated directly through the Web service APIs or through workflows outside the context of the form. Form programming should complement business logic applied by using plugins and processes so that all records created or updated in any manner will comply with the same processes.

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, business rules can be defined to run at the entity scope so that the same logic is applied on the server regardless of where the action originated. More information: Create and edit business rules

While form programming provides capabilities to hide form fields so that users may not be able to view or update some entity data, it does not represent a complete solution for enforcing security requirements. A user can see entity data that is not visible on the form by using a variety of methods, such as Advanced Find. More information: The security model of Microsoft Dynamics CRM

Write form scripts that perform well

When you write scripts for forms, use the following practices to help achieve the best performance:

Avoid including unnecessary JavaScript web resource libraries

The more scripts you add to the form, the more time it will take to download them. Usually scripts are cached in your browser after they are loaded the first time, but the performance the first time a form is viewed often creates a significant impression.

For a specific example, don’t include jQuery in your form scripts simply because you want to use XMLHttpRequests. While jQuery has the $.ajax function that many people are familiar with to perform these requests, it is a developer preference, not a necessity. It is possible to perform these requests using the native XMLHttpRequest object found in all browsers supported by Microsoft Dynamics CRM. More information: Use of jQuery

Avoid loading all scripts in the Onload event

If you have code that only supports OnChange events for fields or the OnSave event, make sure to set the script library with the event handler for those events instead of the OnLoad event. This way loading those libraries can be deferred and increase performance when the form loads.

We do not recommend using the addOnChange method within the OnLoad event handler simply as a matter of convenience. While this may reduce the number of steps necessary to add your event handlers, it causes the form to load more slowly.

Use collapsed tabs to defer loading web resources

When web resources or IFRAMES are included in sections inside a collapsed tab, they will not be loaded if the tab is collapsed. They will be loaded when the tab is expanded. When the tab state changes, the TabStateChange event occurs. Any code that is required to support web resources or IFRAMEs within collapsed tabs can use event handlers for the TabStateChange event and reduce code that might otherwise have to occur in the OnLoad event.

Set default visibility options

Avoid using form scripts in the OnLoad event that hide form elements. Instead, set the default visibility options for form elements that might be hidden to not be visible by default when the form loads. Then, use scripts in the OnLoad event to show those form elements you want to display.

Different Form Presentations

There are several different ways that forms are presented. These affect the type of code or available events you can use for each.

Updated entities

All custom entities and certain system entities have an updated user interface that includes using the command bar and new form APIs. The updated system entities are listed in the following table:

Account | Appointment | Campaign
Campaign Activity | Campaign Response | Case
Competitor | Contact | Contract
Contract Line | Email | Entitlement
Entitlement Template | Fax | Invoice
Lead | Letter | Marketing List
Opportunity | Opportunity Product | Order
Phone Call | Position | Price List Item
Product | Product Association | Product Relationship
Queue | Quick Campaign | Quote
Recurring Appointment | Sales Literature | SLA
SLA KPI Instance | Social Activity | Social Profile
Task | Team | User

Note
Some updated entities include composite attributes. These require some special consideration. More information: Write scripts for composite attributes.

Updated entity forms may also include a collaboration control that provides access to Notes, Activities, and Posts if they are enabled for the entity. The Xrm.Page object does not provide access to the collaboration control. You can access the section element that contains the collaboration control if you want to show or hide it by using scripts.

Form programming methods and PreSearch event for updated entities

The following table lists the form programming methods available for updated entities only.

Method | Description
Xrm.Page.context. client.getClient | Returns a value to indicate which client the script is executing in.
Xrm.Page.context. client.getClientState | Returns a value to indicate the state of the client.
Xrm.Page.context. getUserName | Returns the name of the current user.
Xrm.Page.data.entity. getPrimaryAttributeValue | Gets a string for the value of the primary attribute of the entity.
Xrm.Page.data. refresh | Asynchronously refreshes the data of the form without reloading the page.
Xrm.Page.data. save | Saves the record asynchronously with the option to set callback functions to be executed after the save operation is completed.
Xrm.Page.data.entity attribute. getIsPartyList | Determines whether a lookup attribute represents a partylist lookup.
Xrm.Page.ui control. clearNotification | Removes a message already displayed for a control.
Xrm.Page.ui control. setNotification | Displays a message near the control to indicate that data is not valid.
Xrm.Page.ui. clearFormNotification | Use this method to remove form level notifications.
Xrm.Page.ui. setFormNotification | Use this method to display form level notifications.
Xrm.Page.ui control. addCustomFilter | Use fetchXml to add additional filters to the results displayed in the lookup. Each filter will be combined with any previously added filters as an ‘AND’ condition.
Xrm.Page.ui control. setShowTime | Specifies whether a date control should show the time portion of the date.
Xrm.Utility. alertDialog | Displays a non-blocking alert dialog with a callback function.
Xrm.Utility. confirmDialog | Displays a non-blocking confirm dialog with different callbacks depending on the button clicked by the user.

PreSearch Event

The new PreSearch Event occurs just before the search dialog box opens when you set a lookup value. This event does not have user interface to set an event handler in the application; it can only be set using the Xrm.Page.ui control. addPreSearch method. Use this event with the addCustomFilter, addCustomView and setDefaultView methods to control the views opened when people search for a record to set as the value of a lookup field.

Entities that use classic forms

System entities that were not updated use classic form presentation. Forms for these entities continue to use the ribbon if they did in CRM 2011 and do not have access to form APIs added in this release. These entities are listed in the following table:

Address | Article | Article Comment | Bulk Delete Operation | Business Unit
Connection | Discount | Discount List | Document Location | Email Attachment
Follow | Goal | Goal Metric | Import Source File | Invoice Product
Order Product | Price List | Queue Item | Quote Product | Rollup Field
Rollup Query | Saved View | Service | Service Activity | SharePoint Site
Site | Territory | Unit | Unit Group |

Entities enabled for CRM for tablets

Only selected system entities and custom entities are available to be shown by using Microsoft Dynamics CRM for tablets. The following system entities may have editable forms in CRM for tablets.

Account | Activity | Appointment | Case
Competitor | Connection | Contact | Lead
Note | Opportunity | Opportunity Product | Phone Call
Queue Item | Social Activity | Social Profile | Task

Because CRM for tablets does not have the same behaviors as forms in the web application, some APIs are not available. For example, in CRM for tablets tabs cannot be expanded or collapsed, so the Tab TabStateChange Event does not occur and the Xrm.Page.ui tab. setDisplayState cannot be used to expand or collapse tabs.

Development tools

Because JavaScript is an interpreted language special development tools are not required. JavaScript is just text so it can be edited in the application or in a text editor such as Notepad. However, you can achieve significant productivity gains when you use an integrated development environment (IDE) that provides features to support editing JavaScript files, such as Microsoft Visual Studio and Microsoft Visual Studio Express.

See Also

Concepts

Open forms, views, dialogs and reports with a URL
Form scripting quick reference
Use JavaScript with Microsoft Dynamics CRM
JavaScript libraries for Microsoft Dynamics CRM
Use form and field events
Use the Xrm.Page object model
Write and debug scripts for CRM for tablets
Write scripts for composite attributes
Write scripts for business process flows
Use execution context and the form event pipeline
Use an IFRAME and web resource controls on a form
Use the OData endpoint with Ajax and JScript web resources

Other Resources

Write client application extensions
Developers guide to customization for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use form and field events

You can add scripts for the OnLoad and OnSave events for forms and OnChange events for each field. Tabs have a TabStateChange event and IFRAMES have an OnReadyStateComplete event. Handlers for the PreSearch event and events raised by the business process flow control can only be added and removed using methods for the respective controls.

Note
Events in the form are disabled for the bulk edit form. The bulk edit form is displayed when multiple records in a list are edited.

In This Topic

OnLoad event

OnSave event

OnChange event

TabStateChange event

OnReadyStateComplete event

PreSearch event

Business Process Flow control events

OnLoad event

The OnLoad event occurs after the form has loaded. It cannot prevent the window from loading. Use the OnLoad event to prepare the data in the form for use. Actions that can be performed by using the OnLoad event include the following:

  • Perform calculations based on changing values.
  • Alert a user to a situation.
  • Disable fields that shouldn’t be updated.

More information: OnLoad Event

OnSave event

The OnSave event does not correspond to the standard HTML OnSubmit event. The OnSave event occurs when :

  • The user clicks the Auto save button button in the lower right corner of the form, even when there is no changed data to be saved.
  • Code executes the Xrm.Page.data.entity. save method, even when there is no changed data to be saved.
  • The user navigates away from the form and there is unsaved data in the form.
  • With auto-save enabled, 30 seconds after data has changed and there is unsaved data in the form.
  • Code executes the Xrm.Page.data. save method and there is unsaved data in the form.
  • Code executes the Xrm.Page.data. refresh method passing a true value as the first parameter and there is unsaved data in the form.

You can detect which action was performed to save the form by using the getSaveMode method in the save event arguments retrieved from the getEventArgs method execution context. Navigating away from a form when it contains unsaved data corresponds to the “Save and Close” behavior found in forms for entities that haven’t been updated.

The OnSave event can be canceled to prevent the data from being saved. Because of this it, is very common to use the OnSave event to validate data.

More information: OnSave Event

OnChange event

The OnChange event is available on every field. Generally, the OnChange event requires two conditions to be true:

  • The data in the field must change.
  • The field must lose focus.
Note
There is an exception to this behavior that applies to Two-Option (Boolean) fields that are formatted to use radio buttons or check boxes. For these controls the event occurs immediately.

This event also occurs when data changes on the server are retrieved to update a field when the form is refreshed, such as after a record is saved.

Using the Xrm.Page.data.entity attribute.fireOnChange method will also cause this event to occur.

The OnChange event doesn’t occur if the field is changed programmatically using the setValue method. If you want event handlers for the OnChange event to run after you set the value, you must use the fireOnChange method in your code.

After the event, the data in the field will be revalidated. This means that you can’t use the event to enter invalid data.

Actions that can be performed by using OnChange include the following:

  • Perform calculations to change other fields based on changing values.
  • Change the formatting of fields, such as telephone numbers.
  • Implement dependent option sets. For an example, see Sample: Create dependent OptionSets (picklists).

More information: Field OnChange Event

TabStateChange event

This event occurs when a tab is expanded or collapsed. You may want to defer execution of code until a tab is expanded.

Note
This event never occurs in Microsoft Dynamics CRM for tablets because tabs in that client don’t collapse.

This event is important if you use script to modify the src property of an IFRAME control. An IFRAME will be refreshed when the tab is expanded. Any changes to the src property will be removed. If you interact with the src property of an IFRAME, you should always include this code in the TabStateChange event instead of the Onload event.

More information: Tab TabStateChange Event

OnReadyStateComplete event

Any script that interacts with an IFRAME will fail unless the contents of the IFRAME have completed loading. This event provides a location to include script that executes as soon as the contents of the IFRAME have completed loading.

Note
This event never occurs in Microsoft Dynamics CRM for tablets because IFRAMEs aren’t displayed.

More information: IFRAME OnReadyStateComplete Event

PreSearch event

Use the addPreSearch method to add an event handler to a control for a lookup attribute. There is no user interface to add an event handler manually. Use this event with the addCustomFilter, addCustomView, and setDefaultView methods to control the views opened when people search for a record to set as the value of a lookup field.

More information: Lookup Control PreSearch Event

Business Process Flow control events

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update provides two events for user interaction with the business process flow control.

OnStageChange

Occurs when a stage changes. More information: OnStageChange event.

OnStageSelected

Occurs when a stage is selected. More information: OnStageSelected event.

There is no UI to register scripts for these events. Use the following methods in functions registered in the form OnLoad event to register your functions for these events.

  • Xrm.Page.data.process.addOnStageChange
  • Xrm.Page.data.process.addOnStageSelected
  • Xrm.Page.data.process.removeOnStageChange
  • Xrm.Page.data.process.removeOnStageSelected

Each of these methods accept a function as a parameter to add or remove from the event handler. More information: Methods to manage event handlers.

See Also

Reference

Form events (client-side reference)
<events> (FormXml)

Concepts

Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model
Form scripting quick reference
Use JavaScript with Microsoft Dynamics CRM

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the Xrm.Page object model

When you write form scripts you will interact with objects in the Xrm.Page namespace to perform the following actions:

  • Get or set attribute values.
  • Show and hide user interface elements.
  • Reference multiple controls per attribute.
  • Access multiple forms per entity.
  • Manipulate form navigation items.
  • Interact with the business process flow control.

For more examples, see Form scripting quick reference.

In This Topic

Xrm.Page Object Hierarchy

Execution context

Collections

Object descriptions

  • attribute
  • context
  • control
  • entity
  • formSelector
  • navigation
  • process
  • section
  • stage
  • step
  • tab

Xrm.Page object hierarchy

As shown in the following diagram, Xrm.Page provides a namespace container for three objects described in the following table:

Object | Description
context | Provides methods to retrieve information specific to an organization, a user, or parameters that were passed to the form in a query string.
data | Provides access to the entity data and methods to manage the data in the form as well as in the business process flow control
ui | Contains methods to retrieve information about the user interface, in addition to collections for several sub components of the form.

Xrm.Page object model

Execution context

When you register a function for an event handler you have the option to pass an execution context object as the first parameter to the function. This object contains methods that allows you to manage variables you wish to share with other event handlers and the save event. For more information, see Execution context (client-side reference) and Save event arguments (client-side reference).

Collections

The following table describes the Xrm.Page object model collections. See Collections (client-side reference) for information about the methods available for collections.

Collection Description

attributes

The Xrm.Page.data.entity.attributes collection provides access to each entity attribute that is available on the form. Only those attributes that correspond to fields added to the form are available.

controls

Three objects contain a controls collection:

ui.controls

The Xrm.Page.ui.controls collection provides access to each control present on the form.

attribute.controls

Because an attribute may have more than one control on the form, this collection provides access to each of them. This collection will contain only one item unless multiple controls for the attribute are added to the form.

section.controls

This collection only contains the controls found in the section.

navigation.items

The Xrm.Page.ui.navigation.items collection provides access to navigation items that are defined using the navigation area of the form editor. With Updated forms, people navigate to these using the command bar. In Classic formsthese are on the left side of the form.

formSelector.items

When multiple forms are provided for an entity, you can associate each form with security roles. When the security roles associated with a user enable them to see more than one form, the Xrm.Page.ui.formSelector.items collection provides access to each form definition available to that user.

tabs

You can organize each form by using one or more tabs. The Xrm.Page.ui.tabs collection provides access to each of these tabs.

sections

You can organize each form tab by using one or more sections. The tab sections collection provides access to each of these sections.

Business process flow collections

Collections for stages and steps within Xrm.Page.data.process are based on the same collection structure but also allow for adding or removing items from the collections.

Use the process.getStages method to access the collection of stages. Use the stage.getSteps method to access the collection of steps.

Object descriptions

Each object possesses several methods to retrieve data, get or set object properties, or perform actions:

attribute

Each attribute corresponds to an entity attribute that has been added to the form as a field. Generally only those entity attributes that have been added to the form as a field are available. Each instance of a field is a control. A field can be added to a form more than one time, which creates multiple controls that refer to the same attribute.

Note
Composite attributes have special behaviors. More information: Write scripts for composite attributes

Attributes are categorized by type. You can determine the type of an attribute by using the getAttributeType method.

While all attributes share some common methods, certain methods are only available for specific attribute types. For more information, see Xrm.Page.data.entity attribute (client-side reference).

Note
Attribute type information represents the behavior of the attribute in the form. It does not necessarily correspond to the field type defined in the application or the AttributeMetadata types. Attributes of a particular field type may behave differently depending on how they are formatted.

The following table lists the attribute type string values to expect for each type of attribute schema type and format option.

Application Field Type | Format Option | Attribute Type
Currency | NA | money
Date and Time | Date and Time, Date Only | datetime
Decimal Number | NA | decimal
Floating Point Number | NA | double
Lookup | NA | lookup
Multiple Lines of Text | NA | memo
Option Set | NA | optionset
Single Line of Text | E-mail, Text, Ticker Symbol, Url, Phone | string
Single Line of Text | Text Area | memo
Status | NA | optionset
Status Reason | NA | optionset
Two Options | Two Radio Buttons, Checkbox, List | boolean
Whole Number | None, Duration | integer
Whole Number | Language, Time Zone | optionset

context

Xrm.Page.context provides methods to retrieve information specific to an organization, a user, or parameters that were passed to the form in a query string. For more information, see Client-side context (client-side reference).

control

Represents an HTML element present on the form. Some controls are bound to a specific attribute, whereas others may represent unbound controls such as an IFRAME, Web resource, or a sub grid that has been added to the form.

Use specific control names in your code for IFrame, Web Resource, and Subgrid controls. These controls are not bound to an attribute. Avoid including specific control names in your code when the control is bound to an attribute. When multiple controls are bound to an attribute, the control names are determined at runtime and can vary depending on where the control is located in the form.

For most tasks related to attribute bound controls, you will access the controls by using the attribute controls collection or through the controls collection of a section. Rather than refer to a control by name, you will gain a reference to it based on the context of the collection. In this case, the name is not important. See the example found for the attribute Controls Collection for a way to create functions to perform actions across all the controls that are bound to a specific attribute.

Note
Composite attributes have special behaviors. More information: Write scripts for composite attributes.

Note
For most script development work outside of Microsoft Dynamics CRM, developers may be accustomed to referring to page elements by using the document.getElementById method. For Microsoft Dynamics CRM form scripts this method is not supported. It is important to recognize that the attribute stores the data and the control is simply the presentation of the attribute in the form. For controls bound to attributes you may need to adjust the way you are accustomed to accessing data in the form.

Controls are categorized by type. You can determine the type of a control by using the getControlType method. Certain control methods are only available for specific types of controls. For example, the addOption method is only available for controls that are presented as option sets. For more information, see Xrm.Page.ui control (client-side reference).

entity

Xrm.Page.data.entity provides methods to retrieve information specific to the record displayed on the page, the save method, and a collection of all the attributes included in the form. See Xrm.Page.data.entity (client-side reference) for more information.

formSelector

The Xrm.Page.ui.formSelector contains an items collection that provides capabilities to query the forms available for the current user. Use the navigate method to close the current form and open a different one. For more information, see Xrm.Page.ui.formSelector item (client-side reference).

navigation

Does not contain any methods. Provides access to navigation items through the items collection.

process

Contains methods to retrieve properties of a business process flow. More information: Process methods

section

A section contains methods to manage how it appears in addition to accessing the tab that contains the section. A section also provides access to the controls within it through a controls collection. More information: Xrm.Page.ui section (client-side reference)

stage

Each process has a collection of stages that can be access using the process getStages method.

One stage is the active stage. More information: Structure of business process flows

step

Steps represent individual items of data to be collected during a stage. Each stage has a collection of steps that can be accessed using the stage getSteps method. More information: Structure of Business process flows

You can access a step control within the active stage of a business process flow control by referencing the control name with the special prefix “header_process_<control name>”. For example, to hide the step that represents the purchaseprocess attribute, use the following:

JavaScript Copy Code
Xrm.Page.getControl("header_process_purchaseprocess").setVisible(false);

tab

A tab is a group of sections on a page. It contains methods to change the presentation of the tab. You will access sections in the tab through the sections collection. For more information, see Xrm.Page.ui tab (client-side reference).

See Also

Concepts

Form scripting quick reference
Write and debug scripts for CRM for tablets
Write code for Microsoft Dynamics CRM forms
Write scripts for composite attributes
Write scripts for business process flows
Use JavaScript with Microsoft Dynamics CRM
Sample: Create dependent OptionSets (picklists)
JavaScript libraries for Microsoft Dynamics CRM
Customize entity forms

Other Resources

Client-side programming reference
Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create dependent OptionSets (picklists)

It’s a common requirement that the values in one option set field need to be filtered by a value chosen in another option set field. This topic describes one approach to do this with a reusable JScript library, form events, and an XML web resource.

To observe and verify the functionality of this sample you can install the DependentOptionSetsSample_1_0_0_2_managed.zip managed solution from the following location in the SDK download: SDK\SampleCode\JS\FormScripts

Download the Microsoft Dynamics CRM SDK package.

Goals for this Solution

This solution is intended to meet the following requirements:

  • It provides a generic, reusable JScript library that can be used for any pair of option set fields.
  • It allows for a chain of dependent option set fields. Because the options of each dependent option set field are filtered based on the value of another field, additional option set field options can be filtered by the option chosen in the first dependent option set field. This allows for the possibility of a set of hierarchically dependent option set fields.
  • The filtering of dependent options is set in an XML web resource. This allows for changing the option mappings without changing the code. Editing an XML web resource is easier for a non-developer to configure options with less opportunity to break the code.
  • The solution supports multiple languages. The filtering is based solely on the data value of the options rather than any text in the options.
  • Filtering works for any number of instances of an attribute control on the form.

Example

This section describes one application of this approach and the procedure to apply the sample library.

The Ticket (sample_ticket) entity form has three option set fields and options that allow for categorization of products. The following table shows the desired filtering of options set options.

Category (sample_category) | Sub Category (sample_subcategory) | Type (sample_type)
Value:727000000 Label: Software | Value:727000000 Label: Personal Productivity | Value:727000000 Label: Word Processor
 |  | Value:727000001 Label: Spreadsheet
 |  | Value:727000002 Label: Internet Browser
 |  | Value:727000003 Label: E-mail
 | Value:727000001 Label: Business Applications | Value:727000004 Label: Customer Relationship Management
 |  | Value:727000005 Label: Enterprise Resource Management
 |  | Value:727000006 Label: Human Resource Management
 | Value:727000002 Label: Operating Systems | Value:727000007 Label: Windows Vista
 |  | Value:727000008 Label: Windows 7
 |  | Value:727000009 Label: Windows Server 2003
 |  | Value:727000010 Label: Windows Server 2008
Value:727000001 Label: Hardware | Value:727000003 Label: Desktop Computer | Value:727000011 Label: Workstation x1000
 |  | Value:727000012 Label: Workstation x2000
 |  | Value:727000013 Label: Workstation x3000
 |  | Value:727000014 Label: Workstation x4000
 | Value:727000004 Label: Laptop Computer | Value:727000015 Label: Laptop 1000 series
 |  | Value:727000016 Label: Laptop 2000 series
 |  | Value:727000017 Label: Laptop 3000 series
 |  | Value:727000018 Label: Laptop 4000 series
 | Value:727000005 Label: Monitor | Value:727000019 Label: CRT-XYZ 17 inch
 |  | Value:727000020 Label: LCD-XYZ 17 inch
 |  | Value:727000021 Label: LCD-XYZ 21 inch
 |  | Value:727000022 Label: LCD-XYZ 24 inch
 | Value:727000006 Label: Printer | Value:727000023 Label:Series 1000 Printer - Private
 |  | Value:727000024 Label: Series 2000 Color Printer - Private
 |  | Value:727000025 Label: Series 9000 Printer - Shared
 |  | Value:727000026 Label: Series 9000 Color Printer - Shared
 | Value:727000007 Label: Telephone | Value:727000027 Label: PSTN Phone
 |  | Value:727000028 Label: IP Phone
 |  | Value:727000029 Label: Mobile Phone

Enable filtering

  1. Convert the desired filtering of options into the following XML document and upload it as an XML web resource titled sample_TicketDependentOptionSetConfig.xml. The label values are included to make the document easier to edit but are not used in the script that filters the options.

    Copy Code
    <DependentOptionSetConfig entity="sample_ticket" >
 <ParentField id="sample_category"
              label="Category">
  <DependentField id="sample_subcategory"
                  label="Sub Category" />
  <Option value="727000000"
          label="Software">
   <ShowOption value="727000000"
               label="Personal Productivity" />
   <ShowOption value="727000001"
               label="Business Applications" />
   <ShowOption value="727000002"
               label="Operating Systems" />
  </Option>
  <Option value="727000001"
          label="Hardware">
   <ShowOption value="727000003"
               label="Desktop Computer" />
   <ShowOption value="727000004"
               label="Laptop Computer" />
   <ShowOption value="727000005"
               label="Monitor" />
   <ShowOption value="727000006"
               label="Printer" />
   <ShowOption value="727000007"
               label="Telephone" />
  </Option>
 </ParentField>
 <ParentField id="sample_subcategory"
              label="Sub Category">
  <DependentField id="sample_type"
                  label="Type" />
  <Option value="727000000"
          label="Personal Productivity">
   <ShowOption value="727000000"
               label="Word Processor" />
   <ShowOption value="727000001"
               label="Spreadsheet" />
   <ShowOption value="727000002"
               label="Internet Browser" />
   <ShowOption value="727000003"
               label="E-mail" />
  </Option>
  <Option value="727000001"
          label="Business Applications">
   <ShowOption value="727000004"
               label="Customer Relationship Management" />
   <ShowOption value="727000005"
               label="Enterprise Resource Management" />
   <ShowOption value="727000006"
               label="Human Resource Managment" />
  </Option>
  <Option value="727000002"
          label="Operating Systems">
   <ShowOption value="727000007"
               label="Windows Vista" />
   <ShowOption value="727000008"
               label="Windows 7" />
   <ShowOption value="727000009"
               label="Windows Server 2003" />
   <ShowOption value="727000010"
               label="Windows Server 2008" />
  </Option>
  <Option value="727000003"
          label="Desktop Computer">
   <ShowOption value="727000011"
               label="Workstation x1000" />
   <ShowOption value="727000012"
               label="Workstation x2000" />
   <ShowOption value="727000013"
               label="Workstation x3000" />
   <ShowOption value="727000014"
               label="Workstation x4000" />
  </Option>
  <Option value="727000004"
          label="Laptop Computer">
   <ShowOption value="727000015"
               label="Laptop 1000 series" />
   <ShowOption value="727000016"
               label="Laptop 2000 series" />
   <ShowOption value="727000017"
               label="Laptop 3000 series" />
   <ShowOption value="727000018"
               label="Laptop 4000 series" />
  </Option>
  <Option value="727000005"
          label="Monitor">
   <ShowOption value="727000019"
               label="CRT-XYZ 17 inch" />
   <ShowOption value="727000020"
               label="LCD-XYZ 17 inch" />
   <ShowOption value="727000021"
               label="LCD-XYZ 21 inch" />
   <ShowOption value="727000022"
               label="LCD-XYZ 24 inch" />
  </Option>
  <Option value="727000006"
          label="Printer">
   <ShowOption value="727000023"
               label="Series 1000 Printer - Private" />
   <ShowOption value="727000024"
               label="Series 2000 Color Printer - Private" />
   <ShowOption value="727000025"
               label="Series 9000 Printer - Shared" />
   <ShowOption value="727000026"
               label="Series 9000 Color Printer - Shared" />
  </Option>
  <Option value="727000007"
          label="Telephone">
   <ShowOption value="727000027"
               label="PSTN Phone" />
   <ShowOption value="727000028"
               label="IP Phone" />
   <ShowOption value="727000029"
               label="Mobile Phone" />
  </Option>
 </ParentField>
</DependentOptionSetConfig>

  2. Create a JScript web resource named sample_SDK.DependentOptionSetSample.js using the following code.

    JScript Copy Code

//If the SDK namespace object is not defined, create it.
if (typeof (SDK) == "undefined")
{ SDK = {}; }
// Create Namespace container for functions in this library;
SDK.DependentOptionSet = {};
SDK.DependentOptionSet.init = function (webResourceName) {
 //Retrieve the XML Web Resource specified by the parameter passed
 var clientURL = Xrm.Page.context.getClientUrl();

 var pathToWR = clientURL + "/WebResources/" + webResourceName;
 var xhr = new XMLHttpRequest();
 xhr.open("GET", pathToWR, true);
 xhr.setRequestHeader("Content-Type", "text/xml");
 xhr.onreadystatechange = function () { SDK.DependentOptionSet.completeInitialization(xhr); };
 xhr.send();
};
SDK.DependentOptionSet.completeInitialization = function (xhr) {
 if (xhr.readyState == 4 /* complete */) {
     if (xhr.status == 200) {
         xhr.onreadystatechange = null; //avoids memory leaks
   var JSConfig = [];
   var ParentFields = xhr.responseXML.documentElement.getElementsByTagName("ParentField");
   for (var i = 0; i < ParentFields.length; i++) {
    var ParentField = ParentFields[i];
    var mapping = {};
    mapping.parent = ParentField.getAttribute("id");
    mapping.dependent = SDK.Util.selectSingleNode(ParentField, "DependentField").getAttribute("id");
    mapping.options = [];
    var options = SDK.Util.selectNodes(ParentField, "Option");
    for (var a = 0; a < options.length; a++) {
     var option = {};
     option.value = options[a].getAttribute("value");
     option.showOptions = [];
     var optionsToShow = SDK.Util.selectNodes(options[a], "ShowOption");
     for (var b = 0; b < optionsToShow.length; b++) {
      var optionToShow = {};
      optionToShow.value = optionsToShow[b].getAttribute("value");
      optionToShow.text = optionsToShow[b].getAttribute("label");
      option.showOptions.push(optionToShow);
     }
     mapping.options.push(option);
    }
    JSConfig.push(mapping);
   }
   //Attach the configuration object to DependentOptionSet
   //so it will be available for the OnChange events
   SDK.DependentOptionSet.config = JSConfig;
   //Fire the onchange event for the mapped optionset fields
   // so that the dependent fields are filtered for the current values.
   for (var depOptionSet in SDK.DependentOptionSet.config) {
    var parent = SDK.DependentOptionSet.config[depOptionSet].parent;
    Xrm.Page.data.entity.attributes.get(parent).fireOnChange();
   }
  }
 }
};
 // This is the function set on the onchange event for
 // parent fields
SDK.DependentOptionSet.filterDependentField = function (parentField, childField) {
 for (var depOptionSet in SDK.DependentOptionSet.config) {
  var DependentOptionSet = SDK.DependentOptionSet.config[depOptionSet];
  /* Match the parameters to the correct dependent optionset mapping*/
  if ((DependentOptionSet.parent == parentField) && (DependentOptionSet.dependent == childField)) {
   /* Get references to the related fields*/
   var ParentField = Xrm.Page.data.entity.attributes.get(parentField);
   var ChildField = Xrm.Page.data.entity.attributes.get(childField);
   /* Capture the current value of the child field*/
   var CurrentChildFieldValue = ChildField.getValue();
   /* If the parent field is null the Child field can be set to null */
   if (ParentField.getValue() == null) {
    ChildField.setValue(null);
    ChildField.setSubmitMode("always");
    ChildField.fireOnChange();

    // Any attribute may have any number of controls
    // So disable each instance
    var controls = ChildField.controls.get()

    for (var ctrl in controls) {
     controls[ctrl].setDisabled(true);
    }
    return;
   }

   for (var os in DependentOptionSet.options) {
    var Options = DependentOptionSet.options[os];
    var optionsToShow = Options.showOptions;
    /* Find the Options that corresponds to the value of the parent field. */
    if (ParentField.getValue() == Options.value) {
     var controls = ChildField.controls.get();
     /*Enable the field and set the options*/
     for (var ctrl in controls) {
      controls[ctrl].setDisabled(false);
      controls[ctrl].clearOptions();

      for (var option in optionsToShow) {
       controls[ctrl].addOption(optionsToShow[option]);
      }

     }
     /*Check whether the current value is valid*/
     var bCurrentValueIsValid = false;
     var ChildFieldOptions = optionsToShow;

     for (var validOptionIndex in ChildFieldOptions) {
      var OptionDataValue = ChildFieldOptions[validOptionIndex].value;

      if (CurrentChildFieldValue == OptionDataValue) {
       bCurrentValueIsValid = true;
       break;
      }
     }
     /*
     If the value is valid, set it.
     If not, set the child field to null
     */
     if (bCurrentValueIsValid) {
      ChildField.setValue(CurrentChildFieldValue);
     }
     else {
      ChildField.setValue(null);
     }
     ChildField.setSubmitMode("always");
     ChildField.fireOnChange();
     break;
    }
   }
  }
 }
};

SDK.Util = {};
//Helper methods to merge differences between browsers for this sample
 SDK.Util.selectSingleNode = function (node, elementName) {
  if (typeof (node.selectSingleNode) != "undefined") {
   return node.selectSingleNode(elementName);
  }
  else {
   return node.getElementsByTagName(elementName)[0];
  }
 };
 SDK.Util.selectNodes = function (node, elementName) {
  if (typeof (node.selectNodes) != "undefined") {
   return node.selectNodes(elementName);
  }
  else {
   return node.getElementsByTagName(elementName);
  }
 };

  3. Add the sample_SDK.DependentOptionSetSample.js Script web resource to the JScript libraries available for the form.

  4. In the Onload event for the form, configure the event handler to call the SDK.DependentOptionSet.init function and pass in the name of the XML web resource as a parameter. Use the field on the Handler Properties dialog box to enter: "sample_TicketDependentOptionSetConfig.xml" into the field Comma separated list of parameters that will be passed to the function.

  5. In the OnChange event for the Category field, set the Function to SDK.DependentOptionSet.filterDependentField.

    In the Comma separated list of parameters that will be passed to the function text box enter: "sample_category", "sample_subcategory".

  6. In the OnChange event for the Sub Category field, set the Function to SDK.DependentOptionSet.filterDependentField.

    In the Comma separated list of parameters that will be passed to the function text box enter: "sample_subcategory ", "sample_type".

  7. Save and publish all customizations.

See Also

Reference

Xrm.Page.data.entity attribute (client-side reference)
Xrm.Page.ui control (client-side reference)

Concepts

Use the Xrm.Page object model
Write code for Microsoft Dynamics CRM forms
Use JavaScript with Microsoft Dynamics CRM
Customize entity forms

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write and debug scripts for CRM for tablets

Microsoft Dynamics CRM for tablets uses the same form definitions that are used in the web application. Any JavaScript code you add to form event handlers or ribbon commands in the web application may also run within CRM for tablets. There are some differences you need to be aware of.

In this topic

Some Xrm.Page or window object functions won’t work in CRM for tablets

Specify what code will run in CRM for tablets

Specify what commands will display in CRM for tablets

Be aware of differences between CRM for tablets and the web application in a browser

Debugging scripts for CRM for tablets

Some Xrm.Page or window object functions won’t work in CRM for tablets

CRM for tablets doesn’t allow any functions that can block execution of scripts. Common JavaScript functions such as window.alert, window.confirm, and window.prompt won’t work as you expect or will simply throw errors.

Use the Xrm.Utility alertDialog and confirmDialog functions to display messages to users. These functions operate differently than window functions because they don’t stop the processing of scripts until the user closes them. They provide callback functions to allow for an asynchronous response to user input. Using window.confirm, window.prompt, or any other native window function that blocks execution of scripts will throw an error.

Note
If you use window.alert in your form scripts, the message you set will automatically be displayed using Xrm.Utility.alertDialog without a callback function specified, but this is temporary and is already considered deprecated. You should move any code using window.alert to use Xrm.Utility.alertDialog instead.

The following methods won’t work in CRM for tablets.

Xrm.Page.context. getCurrentTheme | Xrm.Page.ui ViewPort Methods
Xrm.Page.data.entity. getDataXml | Xrm.Page.ui control Web resource and IFRAME control methods
Xrm.Page.ui. formSelector object methods | Xrm.Page.ui tab. setDisplayState
Xrm.Page.ui. navigation.items collection | Xrm.Utility. openWebResource
Xrm.Page.ui. refreshRibbon |

Most of these functions will simply execute an empty function and return nothing. If you have code that expects a return value from one of these functions it will be undefined.

Specify what code will run in CRM for tablets

When the capabilities of the client API are different you should include code similar to the following to separate the logic you apply for each client.

JavaScript Copy Code
var isCrmForTablets = (Xrm.Page.context.client.getClient() == "Mobile")
if (isCrmForTablets)
{
 // Code for CRM for tablets only goes here,
}
else
{
 // Code for web browser or CRM for Outlook only goes here.
}
// Code for any client goes here.

Specify what commands will display in CRM for tablets

When you use the <JavaScriptFunction> (RibbonDiffXml) action in your custom command bar (ribbon) commands you can also separate your code using Xrm.Page.context.client. getClient. If the action you want to perform won’t work using CRM for tablets you should include display rules so that the commands won’t appear in CRM for tablets. By default, any command defined will display in CRM for tablets unless you explicitly configure it not to. As a rule, you should define the following display rule and include it in every command unless you know it will work using CRM for tablets.

Xml Copy Code
<DisplayRule Id="My.HideOnModern">
 <CommandClientTypeRule Type="Modern"
                        InvertResult="true" />
</DisplayRule>

Be aware of differences between CRM for tablets and the web application in a browser

Other than the functions described in Some Xrm.Page or window object functions will not work in CRM for Tablets, you should also be aware that there are other differences.

Composite Fields

CRM for tablets implements composite fields differently. CRM for tablets won’t include composite attributes. It automatically substitutes the constituent attributes and display them instead. More information: Write scripts for composite attributes.

Web resources and IFRAMEs

CRM for tablets doesn’t support the display of web resources or IFRAMEs in forms. If any of your code interacts with these types of controls you can expect that the controls won’t appear in a CRM for tablets form and you should apply the guidance in Specify what code will run in CRM for Tablets so that that code is only run in the web browser client.

Debugging scripts for CRM for tablets

Because CRM for tablets is an app the normal JavaScript debugging tools you can use in the browser aren’t available. We recommend the following procedure to test and debug your form scripts and ribbon commands

  1. Test your scripts thoroughly using the web application.
  2. As part of testing using the web browser, reverse the criteria when you check for the client using Xrm.Page.context.client. getClient and verify that the logic is appropriate for the experience people should have when using CRM for tablets. The APIs available for CRM for tablets is a subset of the APIs available for the web browser, so you should be able to test your alternate flow in the web browser.
  3. If possible, install CRM for tablets on a computer with Windows 8 and Microsoft Visual Studio installed. Include debugger statements where you want to launch the debugger using Visual Studio.
  4. Finally, use Xrm.Utility. alertDialog to display values from your code within CRM for tablets.

See Also

Concepts

Write code for Microsoft Dynamics CRM forms
Use form and field events
Use the Xrm.Page object model
Write scripts for composite attributes
Form scripting quick reference
Command bar or ribbon presentation

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write scripts for composite attributes

Some fields added to a form can represent multiple items of data. These composite attributes behave differently from other attributes when displayed in the web application and you must write scripts differently to use them properly.

In This Topic

Composite attributes

Composite attributes in the web application

Composite attributes in CRM for Tablets

Mitigate the differences

Composite attributes

The following table lists the composite attributes:

Entity | Display Name | Logical name
Contact | Full Name | fullname
 | Address 1 | address1_composite
 | Address 2 | address2_composite
Lead | Full Name | fullname
 | Address 1 | address1_composite
 | Address 2 | address2_composite
User | Full Name | fullname
 | Address | address1_composite
 | Other Address | address2_composite
Account | Address 1 | address1_composite
 | Address 2 | address2_composite
Quote | Bill To Address | billto_composite
 | Ship To Address | shipto_composite
Order | Bill To Address | billto_composite
 | Ship To Address | shipto_composite
Invoice | Bill To Address | billto_composite
 | Ship To Address | shipto_composite

Composite attributes in the web application

When fields for composite attributes are added to a main form, the web application will show just the composite attribute. When someone edits the field, a flyout appears showing the individual attributes that comprise the composite attribute. Although not explicitly added to the form in the form editor, each of the attributes that are part of the attribute are available to the form. Although you can read the value of the composite value using getValue, you can’t use setValue to change the value of the composite attribute directly; you must set one or more of the attributes referenced by the composite attribute.

You can access the individual constituent controls displayed in the flyout by name. These controls use the following naming convention: <composite control name>_compositionLinkControl_<constituent attribute name>. To access just the address_line1 control in the address1_composite control you would use: Xrm.Page.getControl("address1_composite_compositionLinkControl_address1_line1").

Composite attributes in CRM for tablets

Microsoft Dynamics CRM for tablets uses the same form definitions used for the entities that have composite attributes but it interprets them differently. If a composite attribute is found in the form definition, it will show all the attributes that are part of the composite attribute in that section of the form. There is no need for a flyout because all the fields are visible. You can write scripts for the form accessing each of the individual attributes just as if they had been individually added to the form.

However, the actual composite control will not be present in the CRM for tablets page.

Mitigate the differences

If you want to access the fullname field for the Contact, Lead, or User entities, using the Xrm.Page.data.entity. getPrimaryAttributeValue method is an easy way to get the value for this attribute without referencing it directly. This method works for both the web application and CRM for tablets.

If you have code that needs to read the value of one of the address composite attributes, to work with both clients, you need to separate the code using Xrm.Page.context.client. getClient as shown in the following function that will display the formatted address using Xrm.Utility. alertDialog in either the main web application or the CRM for tablets version of the same form.

JavaScript Copy Code
function showAddressDialog() {
 var address1_compositeValue;
 if (Xrm.Page.context.client.getClient() != "Mobile") {
  address1_compositeValue = Xrm.Page.getAttribute("address1_composite").getValue();
 }
 else {
  var address1_line1 = Xrm.Page.getAttribute("address1_line1").getValue();
  var address1_line2 = Xrm.Page.getAttribute("address1_line2").getValue();
  var address1_line3 = Xrm.Page.getAttribute("address1_line3").getValue();
  var address1_city = Xrm.Page.getAttribute("address1_city").getValue();
  var address1_stateorprovince = Xrm.Page.getAttribute("address1_stateorprovince").getValue();
  var address1_postalcode = Xrm.Page.getAttribute("address1_postalcode").getValue();
  var address1_country = Xrm.Page.getAttribute("address1_country").getValue();

  // Achieve equivalent formatting
  //address1_line1
  //address1_line2
  //address1_line3
  //address1_city, address1_stateorprovince address1_postalcode
  //address1_country

  var addressText = "";
  if (address1_line1 != null) {
   addressText += address1_line1 + "\n";
  }
  if (address1_line2 != null) {
   addressText += address1_line2 + "\n";
  }
  if (address1_line3 != null) {
   addressText += address1_line3 + "\n";
  }
  if (address1_city != null) {
   addressText += address1_city + ", ";
  }
  if (address1_stateorprovince != null) {
   addressText += address1_stateorprovince + " ";
  }
  if (address1_postalcode != null) {
   addressText += address1_postalcode + "\n";
  }
  addressText += address1_country;

  address1_compositeValue = addressText;
 }
 Xrm.Utility.alertDialog(address1_compositeValue);
}

See Also

Reference

Xrm.Page.data.entity attribute (client-side reference)

Concepts

Write code for Microsoft Dynamics CRM forms
Use form and field events
Use the Xrm.Page object model
Write and debug scripts for CRM for tablets
Use execution context and the form event pipeline
Use an IFRAME and web resource controls on a form
Form scripting quick reference

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write scripts for business process flows

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update there is a client-side object you can use to interact with business process flows in your scripts. The Xrm.Page.data namespace is extended to include methods under Xrm.Page.data.process. The Xrm.Page.ui namespace is extended to include methods under Xrm.Page.ui.process.

In this topic

Structure of business process flows

Actions that can be automated

Events for business process flows

Structure of business process flows

Business process flows consist of a series of stages, each containing a number of steps. Only one stage is the active stage. When the required steps in each stage are complete, the process can move on to the next stage and it becomes the active stage. Which stage is next can be defined based on conditions in the business process flow as shown in the following diagram.

Business Process Flow Objects

Stages can be associated with specific related entities, so a business process flow can span multiple entities. The business process remains the same and leads the user to a desired conclusion. More information: Customization Guide topic: Business Process Flows

Actions that can be automated

Normally, progressing along the business process depends on user input. As a developer, you can perform the same actions programmatically in form scripts.

Change the process when there are more than one process available for the entity.

Use Xrm.Page.data.process. getEnabledProcesses to retrieve information about enabled processes that the user can choose for the entity. Then use Xrm.Page.data.process. setActiveProcess to make one of the enabled processes the active one.

Move to the next stage when all required steps are completed to make it the current active stage.

Use Xrm.Page.data.process. moveNext.

Move to the previous stage and make it the current active stage.

Use Xrm.Page.data.process. movePrevious.

Select a stage to view the status of the steps in the stage.

Use Xrm.Page.data.process. getActivePath to retrieve information about the stages that have been completed, the current active stage, and valid stages available from the current active stage. Examine the steps included in that stage and compare the corresponding form attribute values to determine whether they are completed.

Complete a step

Steps are completed when the corresponding data in the form is entered. You can determine the attribute using the step getAttribute method. This will return the logical name of the attribute. Then use Xrm.Page.getAttribute to retrieve attribute from the Xrm.Page.data.entity.attributes collection and then use the attribute setValue method to set the value.

Detect whether a step is required

Use the step isRequired method to determine if a step is required by the business process flow.

Expand or collapse the business process flow control

Use Xrm.Page.ui.process. setDisplayState.

There are also some things you can do as a developer that a user cannot perform.

Hide the process control

Use Xrm.Page.ui.process. setVisible, you can control whether to display the business process flow control.

Skip to a valid completed stage.

Use Xrm.Page.data.process.setActiveStage to set one of the valid completed stages for the current entity.

Query the process definition including stages not currently visible

Use Xrm.Page.data.process.getActiveProcess to query the definition of the business process flow, including stages that might not be visible because of branching logic in the process.

Events for business process flows

You can interact any event provided by the form with business process flows, but two new events allow you to execute code based on events just for the business process flow control. You can execute code when the active stage of a business process flow changes (OnStageChange event) or when a stage is selected (OnStageSelected event).

Neither of these new events provide a user interface to register your event handlers. You must use methods provided to add or remove handlers for these events in the form OnLoad event.. More information: Business Process Flow control events

See Also

Reference

Xrm.Page.data.process (client-side reference)
Business Process Flow control events

Concepts

Use the Xrm.Page object model

Other Resources

Sample: Xrm.Page.data.process.getEnabledProcesses
Sample: Xrm.Page.data.process.getActivePath
Customization Guide topic: Business Process Flows

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Xrm.Page.data.process.getActivePath
See Also Example

This sample demonstrates the data returned when you use the Xrm.Page.data.process. getActivePath method.

Requirements

The Sdk.formOnLoad function in the sample JavaScript library must be set as the OnLoad event handler for a form.

Demonstrates

The Xrm.Page.data.process. getActivePath method returns a collection of stages that represent any previous stages, the current active stage, and the predicted future stages taking into account the branching conditions and the current form data. Each stage has a getSteps method that you can use to retrieve information about each step in the stage.

This sample illustrates the use of some of the methods in the Xrm.Page.data.process API. It doesn’t represent using this API to meet a business requirement; it’s only intended to demonstrate how the key property values can be accessed in code.

Example

The Sdk.formOnLoad function uses the Xrm.Page.data.process.getActivePath method to retrieve a collection of stages. Then, the sample code uses the forEach method of the collection to loop through each stage. The code then writes key properties of the stage to the console using the Sdk.writeToConsole function defined in this library. The code then accesses a collection of steps for each stage using the getSteps method. Finally, the sample uses the forEach method of the steps collection to access each step and write key properties of the step to the console.

JavaScript Copy Code
var Sdk = window.Sdk || { __namespace: true };
(function () {

 // A function to log messages while debugging only
 this.writeToConsole = function (message) {
  if (typeof console != 'undefined')
  { console.log(message); }
 };

 //Code to run in the OnLoad event
 this.formOnLoad = function () {
  //Enumerate the stages and steps in the active path
  var activePathCollection = Xrm.Page.data.process.getActivePath();
  activePathCollection.forEach(function (stage, n) {
   Sdk.writeToConsole("Stage Index: " + n);
   Sdk.writeToConsole("Entity: " + stage.getEntityName());
   Sdk.writeToConsole("StageId: " + stage.getId());
   Sdk.writeToConsole("Status: " + stage.getStatus());
   var stageSteps = stage.getSteps();
   stageSteps.forEach(function (step, i) {
    Sdk.writeToConsole("    Step Name: " + step.getName());
    Sdk.writeToConsole("    Step Attribute: " + step.getAttribute());
    Sdk.writeToConsole("    Step Required: " + step.isRequired());
    Sdk.writeToConsole("    ---------------------------------------")
   })
   Sdk.writeToConsole("---------------------------------------")
  });
 };
}).call(Sdk);

When the sample runs in the browser, you can use the developer tools of the browser to view the text written to the console. For example, when this sample is run in the Lead entity form with the Lead to Opportunity Sales Process, the following is written to the console:

Copy Code
Stage Index: 0
Entity: lead
StageId: f99b4d48-7aad-456e-864a-8e7d543f7495
Status: active
    Step Name: Existing Contact?
    Step Attribute: null
    Step Required: false
    ---------------------------------------
    Step Name: Existing Account?
    Step Attribute: null
    Step Required: false
    ---------------------------------------
    Step Name: Purchase Timeframe
    Step Attribute: purchasetimeframe
    Step Required: false
    ---------------------------------------
    Step Name: Estimated Budget
    Step Attribute: budgetamount
    Step Required: false
    ---------------------------------------
    Step Name: Purchase Process
    Step Attribute: purchaseprocess
    Step Required: false
    ---------------------------------------
    Step Name: Identify Decision Maker
    Step Attribute: decisionmaker
    Step Required: false
    ---------------------------------------
    Step Name: Capture Summary
    Step Attribute: description
    Step Required: false
    ---------------------------------------
---------------------------------------
Stage Index: 1
Entity: opportunity
StageId: bfc9108c-8389-406b-9166-2c3298a2e41f
Status: inactive
    Step Name: Customer Need
    Step Attribute: customerneed
    Step Required: false
    ---------------------------------------
    Step Name: Proposed Solution
    Step Attribute: proposedsolution
    Step Required: false
    ---------------------------------------
    Step Name: Identify Stakeholders
    Step Attribute: identifycustomercontacts
    Step Required: false
    ---------------------------------------
    Step Name: Identify Competitors
    Step Attribute: identifycompetitors
    Step Required: false
    ---------------------------------------
---------------------------------------
Stage Index: 2
Entity: opportunity
StageId: 3a275c22-fc45-4e89-97fc-41e5ec578743
Status: inactive
    Step Name: Identify Sales Team
    Step Attribute: identifypursuitteam
    Step Required: false
    ---------------------------------------
    Step Name: Develop Proposal
    Step Attribute: developproposal
    Step Required: false
    ---------------------------------------
    Step Name: Complete Internal Review
    Step Attribute: completeinternalreview
    Step Required: false
    ---------------------------------------
    Step Name: Present Proposal
    Step Attribute: presentproposal
    Step Required: false
    ---------------------------------------
---------------------------------------
Stage Index: 3
Entity: opportunity
StageId: 7f5247fe-cfc3-42bc-aa77-b1d836d9b7c0
Status: inactive
    Step Name: Complete Final Proposal
    Step Attribute: completefinalproposal
    Step Required: false
    ---------------------------------------
    Step Name: Present Final Proposal
    Step Attribute: presentfinalproposal
    Step Required: false
    ---------------------------------------
    Step Name: Confirm Decision Date
    Step Attribute: finaldecisiondate
    Step Required: false
    ---------------------------------------
    Step Name: Send Thank You
    Step Attribute: sendthankyounote
    Step Required: false
    ---------------------------------------
    Step Name: File De-brief
    Step Attribute: filedebrief
    Step Required: false
    ---------------------------------------
---------------------------------------

See Also

Concepts

Write scripts for business process flows

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Xrm.Page.data.process.getEnabledProcesses
See Also Example

This sample demonstrates how to retrieve information about processes enabled for an entity by using the Xrm.Page.data.process. getEnabledProcesses method.

Requirements

The Sdk.formOnLoad function in the sample JavaScript library must be set as the OnLoad event handler for a form.

Demonstrates

The Xrm.Page.data.process. getEnabledProcesses method returns information about the processes enabled for an entity that are available for the current user to switch to. If you want to use the Xrm.Page.data.process. setActiveProcess method, you can use the getEnabledProcesses method to get information about any valid processes you could set.

This sample illustrates the use of some of the methods in the Xrm.Page.data.processs API. It doesn’t represent using this API to meet a business requirement; it’s only intended to demonstrate how the key property values can be accessed in code.

Example

The Sdk.formOnLoad function uses the Xrm.Page.data.process.getEnabledProcesses method to asynchronously retrieve information about business process flows that are enabled for the entity. The sample passes an anonymous function as the first parameter. This function is executed asynchronously when the data is returned and the data is passed as the parameter to the anonymous function.

The information about enabled business process flow is provided as a dictionary object where the Id of the process is the name of the property and the name of the business process flow is the value of the property. The sample code processes this information and sets the values in a global Sdk.enabledProcesses array to be accessed by logic that executes later. The sample also loops through the values in uses the Sdk.enabledProcesses array and uses the Sdk.writeToConsole function to write information about the retrieved business process flows to the console.

JavaScript Copy Code
//A namespace defined for SDK sample code
//You should define a unique namespace for your libraries
var Sdk = window.Sdk || { __namespace: true };
(function () {
 //A global variable to store information about enabled business processes after they are retrieved asynchronously
 this.enabledProcesses = [];

 // A function to log messages while debugging only
 this.writeToConsole = function (message) {
  if (typeof console != 'undefined')
  { console.log(message); }
 };

 //Code to run in the OnLoad event
 this.formOnLoad = function () {
  //Retrieve Enabled processes
  Xrm.Page.data.process.getEnabledProcesses(function (processes) {
   //Move processes to the global Sdk.enabledProcesses array;
   for (var processId in processes) {
    Sdk.enabledProcesses.push({ id: processId, name: processes[processId] })
   }
   Sdk.writeToConsole("Enabled business processes flows retrieved and added to Sdk.enabledProcesses array.");

   //Write the values of the Sdk.enabledProcesses array to the console
   if (Sdk.enabledProcesses.length < 0) {
    Sdk.writeToConsole("There are no enabled business process flows for this entity.");
   }
   else {
    Sdk.writeToConsole("These are the enabled business process flows for this entity:");
    for (var i = 0; i < Sdk.enabledProcesses.length; i++) {
     var enabledProcess = Sdk.enabledProcesses[i];
     Sdk.writeToConsole("id: " + enabledProcess.id + " name: " + enabledProcess.name)
    }
   }

   //Any code that depends on the Sdk.enabledProcesses array needs to be initiated here

  });
 };

}).call(Sdk);

When you run this sample with the browser developer tools open, the following is an example of the output written to the console for an entity with multiple business process flows enabled.

Copy Code
Enabled business processes flows retrieved and added to Sdk.enabledProcesses array.
These are the enabled business process flows for this entity:
id: 7994be68-899e-4a40-8d18-f5c3b6940188 name: Sample Lead Process
id: 919e14d1-6489-4852-abd0-a63a6ecaac5d name: Lead to Opportunity Sales Process

See Also

Concepts

Write scripts for business process flows

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use execution context and the form event pipeline

This topic describes how to use the Form event pipeline to manage multiple event handlers for an event, and how to use execution context to re-use JavaScript library functions for different events.

Execution context

When you associate a function in a JavaScript library to an event handler in Microsoft Dynamics CRM, you can check the Pass execution context as first parameter option. The following table lists the execution context object methods.

Method | Description
getContext | Returns the Xrm.Page.context object. See Client-side context (client-side reference) for more information.
getDepth | Returns a value indicating the order in which this handler is executed.
getEventSource | Returns a reference to the object that the event occurred on.
getSharedVariable | Retrieves a variable set using setSharedVariable.
setSharedVariable | Sets the value of a variable that can be used by a hander after the current handler finishes.

Use the getEventSource method in functions to make them more generic. For example, if you have a function that formats a telephone number, you can use the getEventSource method to refer to whatever attribute caused the onChange event. Your functions do not need to reference a specific attribute.

Form event pipeline

You can define up to 50 handlers for each event. Each handler is executed in the order that it is displayed on the Events tab of the form element properties dialog box. This corresponds to the list of <Handler> (FormXml) elements in the <Handlers> (FormXml) element for an event.

Use the setSharedVariable and getSharedVariable methods to pass a common variable between functions. Use the execution context getDepth method to know the sequence that a function is being executed in relative to other handlers.

See Also

Concepts

Write code for Microsoft Dynamics CRM forms
Use form and field events
Use the Xrm.Page object model
Use an IFRAME and web resource controls on a form
Use JavaScript with Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use an IFRAME and web resource controls on a form

IFRAME and web resource controls embed content from another location in pages by using an HTML IFRAME element.

Note
IFRAME and web resource elements aren’t displayed in Microsoft Dynamics CRM for tablets. With Microsoft Dynamics CRM Online 2015 Update you can start early development and testing of touch-enabled controls for CRM for tablets by enabling the preview feature to display IFrames and web resources in CRM for tablets. More information: Create web resources and IFRAME content for use with the CRM for tablets client.

Note
The designs you choose for the form are also used for the Microsoft Dynamics CRM for Microsoft Office Outlook reading pane and forms used by Microsoft Dynamics CRM for tablets. Web resources and IFRAMEs aren’t displayed using the CRM for Outlook reading pane or CRM for tablets. If your IFRAME depends on access to the Xrm.Page object of the page or any form event handlers, you should configure the IFRAME so that it's not visible by default.

You can use an IFRAME to display the contents from another website in a form, for example, in an ASP.NET page. Displaying an entity form within an IFrame embedded in another entity form is not supported.

You can use one of the following web resources to display the contents of web resources in a form:

  • Webpage (HTML) web resources
  • Silverlight (XAP) web resources
  • Image (JPG, PNG, GIF, ICO) web resources

The following sections describe your options if you want these controls to show more than static content.

In This Topic

Select whether to restrict cross-frame scripting

Pass contextual information about the record

Pass form data

Change the URL

Select whether to restrict cross-frame scripting

Use the Restrict cross-frame scripting, where supported option when you do not fully trust the content displayed in an IFRAME. When this option is selected, the IFRAME has the attributes set that are listed in the following table.

Attribute Description

security=”restricted”

This attribute is supported only by versions of Internet Explorer no earlier than version 6. The security attribute applies the user security setting Restricted Sites to the source file of the IFRAME. (Zone settings are found on the Security tab of the Internet Options dialog box.) By default, scripting isn’t enabled in the Restricted Sites zone. By changing the security settings of the zone, various negative results can occur, including allowing scripts to run. For more information, see security attribute.

sandbox=””

For browsers that support this attribute, the content in the IFRAME is essentially limited to only displaying information. The following restrictions could be applied:

  • Browser plug-ins are disabled.
  • Forms and scripts are disabled.
  • Links to other browsing contexts are disabled.
  • Content is treated as from a different domain even if the domain is the same.

This attribute is defined by W3C and is supported by the following browsers:

  • Internet Explorer 10
  • Google Chrome
  • Apple Safari
  • Mozilla Firefox

For more information about the sandbox attribute see:

  • How to Safeguard your Site with HTML5 Sandbox
  • WC3 Sandbox attribute
  • Sandbox

Enabling IFrame communication across domains

There are times when you want to enable communication for an IFRAME that contains content on a different domain. Window.postMessage is a browser method that provides this capability for versions of Internet Explorer no earlier than Internet Explorer 8. Google Chrome, Mozilla Firefox, and Apple Safari also support it. For more information about using postMessage, see the following blog posts:

  • Cross domain calls to the parent CRM 2011 form
  • Cross-Document Messaging and RPC

Pass contextual information about the record

You can provide contextual information by passing parameters to the URL defined in the control. The page that is displayed in the frame must be able to process parameters passed to it. All the parameters in the following table are passed if the IFRAME or web resource is configured by using the Pass record object-type code and unique identifier as parameters option. The corresponding form XML element is <PassParameters> (FormXml).

You can specify whether all the parameters in the following table will be passed.

Parameter | Name | Description
typename | Entity Name | The name of the entity.
type | Entity Type Code | The integer that uniquely identifies the entity in a specific organization.
id | Object GUID | A GUID that represents a record.
orgname | Organization Name | The unique name of the organization.
userlcid | User Language Code | The language code identifier that is being used by the current user.
orglcid | Organization Language Code | The language code identifier that represents the base language for the organization.

Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart).

Note
We suggest that you use the entity name instead of the type code because the entity type code for custom entities may be different between Microsoft Dynamics CRM organizations.

Example

The following sample shows the URL without parameters.

Copy Code
http://myserver/mypage.aspx

The following sample shows the URL with parameters.

Copy Code
http://myserver/mypage.aspx?id=%7bB2232821-A775-DF11-8DD1-00155DBA3809%7d&orglcid=1033&orgname=adventureworkscycle&type=1&typename=account&userlcid=1033

Read passed parameters

Passed parameters are typically read in the target .aspx page by using the HttpRequest.QueryString property. In an HTML page, the parameters can be accessed by using the window.location.search property in JavaScript. For more information, see HttpRequest.QueryString Property and search Property.

Pass form data

Use the getValue method on the attributes that contain the data that you want to pass to the other website, and compose a string of the query string arguments the other page will be able to use. Then use a Field OnChange Event, IFRAME OnReadyStateComplete Event, or Tab TabStateChange Event and the setSrc method to append your parameters to the src property of the IFRAME or web resource.

If you’re using the data parameter to pass data to a Silverlight web resource, you can use the getData and setData methods to manipulate the value passed via the data parameter. For webpage (HTML) web resources, use the setSrc method to manipulate the querystring parameter directly.

Avoid using the OnLoad Event. IFRAMES and web resources load asynchronously and the frame may not have finished loading before the Onload event script finishes. This can cause the src property of the IFRAME or web resource you have changed to be overwritten by the default value of the IFRAME or web resource URL property.

Change the URL

You may want to change the target of the IFRAME based on such considerations as the data in the form or whether the user is working offline. You can set the target of the IFRAME dynamically.

Note
When you change the target page for the IFRAME, parameters aren’t passed to the new URL automatically. You must append the query string parameters to the URL before you use the setSrc method.

Example

The following sample shows you how to set the src property for the IFRAME and any parameters by using the onChange event of an option set field.

JScript Copy Code
//Get the value of an option set attribute
var value = Xrm.Page.data.entity.attributes.get("new_pagechooser").getValue();
var newTarget = "";
//Set the target based on the value of the option set
switch (value) {
    case 100000001:
        newTarget = "http://myServer/test/pageOne.aspx";
        break;
    default:
        newTarget = "http://myServer/test/pageTwo.aspx";
        break;
}
//Get the default URL for the IFRAME, which includes the
// query string parameters
var IFrame = Xrm.Page.ui.controls.get("IFRAME_test");
var Url = IFrame.getSrc();
// Capture the parameters
var params = Url.substr(Url.indexOf("?"));
//Append the parameters to the new page URL
newTarget = newTarget + params;
// Use the setSrc method so that the IFRAME uses the
// new page with the existing parameters
IFrame.setSrc(newTarget);

See Also

Concepts

Write code for Microsoft Dynamics CRM forms
Use JavaScript with Microsoft Dynamics CRM
Form scripting quick reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Form scripting quick reference

This topic presents a quick reference of frequently used form scripting methods based on tasks you perform with them. For the full reference, see Client-side programming reference. All examples on this page use the default account entity main form unless otherwise specified.

In This Topic

Attributes

  • Access attributes
  • Get or set entity attribute data
  • Get attribute metadata

Save event arguments

Display notifications

Controls

  • Access form controls
  • Access header controls
  • Access business process flow controls
  • Form control methods
  • OptionSet control methods
  • IFRAME and web resource control methods
  • Lookup control methods
  • SubGrid control methods
  • Date Control methods

Form navigation

Tabs and sections

Add or remove event handlers at runtime

Contextual information methods

Get, refresh, or save entity data

Attributes

Attributes store the data available in the record.

Access attributes

Attributes are available from the Xrm.Page.data.entity.attributes collection. To access an attribute you can use the Xrm.Page.data.entity.attributes. get method or the shortcut version Xrm.Page.getAttribute. The get method accepts four types of arguments:

  • String: Returns an attribute object where the attribute name matches the string.
  • Number: Returns the attribute object where the Xrm.Page.data.entity.attributes collection index matches the number.
  • None: Returns an array of all the attributes.
  • Delegate function(attribute,index): Returns an array of any attributes from the Xrm.Page.data.entity.attributes collection that cause the delegate function to return true.

Task Example

Access an attribute by name

var nameAttribute = Xrm.Page.getAttribute("name");

Assigns the attribute for the Account Name field to the nameAttribute variable

Access an attribute by index

var firstAttribute = Xrm.Page.getAttribute(0);

Assigns the first attribute in the Xrm.Page.data.entity.attributes collection to the firstAttribute variable.

Access all attributes

var allAttributes = Xrm.Page.getAttribute();

Assigns an array of all the attributes in the Xrm.Page.data.entity.attributes collection to the allAttributes variable.

Access all attributes that meet a specific criteria

var optionsetAttributes = Xrm.Page.getAttribute(function (attribute, index) {
return attribute.getAttributeType() == "optionset";
});

Assigns an array of all the attributes in the Xrm.Page.data.entity.attributes collection that meet the criteria set in the anonymous function, which returns true when the attribute type is “optionset” to the optionsetAttributes variable.

The Xrm.Page.data.entity.attributes collection also has a forEach method that you can use to access attributes within a function. The following writeRequiredAttributesToConsole function will write the names of any attributes that require data to the debugging console:

JavaScript Copy Code
function writeRequiredAttributesToConsole() {
 var requiredAttributeNames = [];

 Xrm.Page.data.entity.attributes.forEach(
 function (attribute, index) {
  if (attribute.getRequiredLevel() == "required")
  { requiredAttributeNames.push(attribute.getName()); }
 });

 if (requiredAttributeNames.length > 0) {
  if (typeof console != "undefined") {
   console.log(requiredAttributeNames.join());
  }
 }
 else {
  if (typeof console != "undefined") {
   console.log("No required attributes detected");
  }
 }
}

Go to top

Get or set entity attribute data

The examples in the following table show how you can retrieve or change data stored in attributes.

Task | Method | Example
Get the value of an attribute | getValue | var nameValue = Xrm.Page.getAttribute("name").getValue(); Assigns the value of the Account Name field to the nameValue variable.
Set the value of an attribute | setValue | Xrm.Page.getAttribute("name").setValue("new name"); Sets the value of the Account Name field to “new name”.
Get the text value of the currently selected option of an optionset attribute | getText | var addressType = Xrm.Page.getAttribute("address1_addresstypecode").getText(); Assigns the text of the selected option in the Address Type field to the addressType variable.
Get the currently selected option object in an optionset attribute | getSelectedOption | var addressTypeOption = Xrm.Page.getAttribute("address1_addresstypecode").getSelectedOption(); Assigns the selected option in the Address Type field to the addressTypeOption variable.

Go to top

Get attribute metadata

The examples in the following table show how you can query attribute properties to understand what kind of attribute it is or change the behavior of the attribute.

Task Method Example

Get the type of attribute

getAttributeType

var attributeType = Xrm.Page.getAttribute(0).getAttributeType();

Assigns the string value that represents the type of attribute for the first attribute to the attributeType variable.

Get how the attribute is formatted

getFormat

var attributeFormat = Xrm.Page.getAttribute(0).getFormat();

Assigns the string value that represents the format of the first attribute to the attributeFormat variable.

Get the initial value of a Boolean or optionset attribute

getInitialValue

var attributeInitialValue = Xrm.Page.getAttribute("address1_addresstypecode").getInitialValue();

Assigns the initial number value of the Address Type field to the attributeInitialValue variable.

Determine whether an attribute value has changed

getIsDirty

var isNameChanged = Xrm.Page.getAttribute("name").getIsDirty();

Assigns a Boolean value that indicates whether the Account Name field value has changed to the isNameChanged variable.

Determines whether a lookup attribute represents a partylist lookup.

getIsPartyList

var isPartyList = Xrm.Page.getAttribute("to").getIsPartyList();

Assigns a Boolean value that indicates whether the Email entity to field represents a party list lookup.

This method is only available for Updated entities.

Get the maximum allowed value for an attribute that contains a number

getMax

var newValue = 100000000000001;
var newValueBelowMax = (newValue < Xrm.Page.getAttribute("creditlimit").getMax())

Assigns a Boolean value that indicates whether the value of the newValue variable exceeds the maximum value allowed for the Credit Limit field to the newValueBelowMax variable.

Get the maximum allowed length for an attribute that contains a string

getMaxLength

var newAccountName = "A Store";
var nameTooLong = (newAccountName.length > Xrm.Page.getAttribute("name").getMaxLength())

Assigns a Boolean value that indicates whether the value of the newAccountName variable exceeds the maximum length allowed for the Account Name field to the nameTooLong variable.

Get the minimum allowed value for an attribute that contains a number

getMin

var newValue = -1;
var newValueBelowMin = (newValue < Xrm.Page.getAttribute("creditlimit").getMin())

Assigns a Boolean value that indicates whether the value of the newValue variable is below the minimum value allowed for the Credit Limit field to the newValueBelowMin variable.

Gets the logical name of an attribute

getName

var attributeName = Xrm.Page.getAttribute(0).getName();

Assigns the logical name value of the first attribute on the page to the attributeName variable

Get the option object representing a value

getOption

var addressTypeOption = Xrm.Page.getAttribute("address1_addresstypecode").getOption(1);
alert(addressTypeOption.text); //displays 'Bill To'

Shows an alert that displays the text of the Address Type field option with a value of 1.

Get a number value representing the level of precision for the number attribute

getPrecision

var creditLimitPrecision = Xrm.Page.getAttribute("creditlimit").getPrecision();

Assigns the precision value of the Credit Limit field to the creditLimitPrecision variable.

Get a string value representing whether the an attribute is required to have a value

getRequiredLevel

var creditLimitRequired = Xrm.Page.getAttribute("creditlimit").getRequiredLevel();

The creditLimitRequired variable value may be none, required, or recommended.

Change whether data is required in a field in order to save a record

setRequiredLevel

Xrm.Page.getAttribute("creditlimit").setRequiredLevel("required");

Makes the Credit Limit field required.

Determine whether the data in an attribute will be submitted when the record is saved

getSubmitMode

var nameSubmitMode = Xrm.Page.getAttribute("name").getSubmitMode();

The nameSubmitMode variable value will be either always, never, or dirty to represent the submitMode for the Account Name field..

Control whether data in an attribute will be saved when the record is saved

setSubmitMode

Xrm.Page.getAttribute("name").setSubmitMode("always");

The example will force the Account Name field value to always be saved even when it has not changed.

When field level security has been applied to an attribute,
determine whether a user has privileges to perform create,
read, or update operations on the attribute. For more information, see
How field security can be used to control access to field values in Microsoft Dynamics CRM

getUserPrivilege

var canUpdateNameAttribute = Xrm.Page.getAttribute("name").getUserPrivilege().canUpdate;

Assigns a Boolean value that represents the user’s privilege to update the Account Name field to the canUpdateNameAttribute variable.

Go to top

Save event arguments

When enforcing business logic it is frequently necessary to prevent a record from being saved so that the user can include required information. To do this you must configure the event handler to pass in the execution context. The execution context contains the getEventArgs method to retrieve arguments for the event. These arguments include methods you can use to control whether a record will be saved or query properties that tell you about the save event.

Task Example

Prevent a record from being saved.

function My_PreventSaveFunction(eContext) {
 eContext.getEventArgs().preventDefault();
}

Use the eContext parameter to capture the execution context and use the preventDefault method included with the event arguments.

Determine what action initiated the save.

function My_GetSaveModeTextFunction(eContext) {
 var saveModeCode = eContext.getEventArgs().getSaveMode();
 var saveModeText = "Unknown";
 switch (saveModeCode) {
  case 1:
   saveModeText = "Save";
   break;
  case 2:
   saveModeText = "SaveAndClose";
   break;
  case 5:
   saveModeText = "Deactivate";
   break;
  case 6:
   saveModeText = "Reactivate";
   break;
  case 7:
   saveModeText = "Send";
   break;
  case 15:
   saveModeText = "Disqualify";
   break;
  case 16:
   saveModeText = "Qualify";
   break;
  case 47:
   saveModeText = "Assign";
   break;
  case 58:
   saveModeText = "SaveAsCompleted";
   break;
  case 59:
   saveModeText = "SaveAndNew";
   break;
  case 70:
   saveModeText = "AutoSave";
   break;
 }
 return saveModeText;
}

Use the eContext parameter to capture the execution context and use the getSaveMode method included with the event arguments to convert the integer code value into text.

Go to top

Display notifications

Notifications provide a way to display a message to the user.

Task Method Example

Display a message near the control to indicate that data is not valid.

setNotification

Xrm.Page.getAttribute("name").controls.forEach(
function (control, i) {
control.setNotification("'Test' is not a valid name.");
})

Sets a validation error message on every control in the form for the Account Name attribute.

While this message is displayed the record cannot be saved.

This method is only available for Updated entities.

Remove a message already displayed for a control.

clearNotification

Xrm.Page.getAttribute("name").controls.forEach(
function (control, i) {
control.clearNotification();
})

Clears all validation error messages on every control in the form for the Account Name attribute.

This method is only available for Updated entities.

Display form level notifications.

setFormNotification

Xrm.Page.ui.setFormNotification(
"Hello",
"INFO",
"helloMsg"
);

Displays the message “Hello” at the top of the form with a system info icon.

This method is only available for Updated entities.

Remove form level notifications

clearFormNotification

Xrm.Page.ui.clearFormNotification("helloMsg");

Clears the message previously set using “helloMsg” as the uniqueid parameter.

This method is only available for Updated entities.

Display a non-blocking alert dialog with a callback function.

alertDialog

var alertDisplayed = false;
Xrm.Utility.alertDialog(
"Showing Alert",
function () { alertDisplayed = true; }
)

Display an alert and set the value of the alertDisplayed variable when it is closed.

This method is only available for Updated entities.

Display a non-blocking confirm dialog with different callbacks depending on the button clicked by the user.

confirmDialog

var agree = false;
Xrm.Utility.confirmDialog(
"Do you agree?",
function () { agree = true;},
function () { agree = false; }
);

Display a confirmation message and set the value of the agree variable depending on the response.

This method is only available for Updated entities.

Go to top

Controls

Controls represent the user interface elements in the form. Each attribute in the form will have at least one control associated with it. Not every control is associated with an attribute. IFRAME, web resource, and subgrids are controls that do not have attributes.

Access form controls

Controls are available from the Xrm.Page.ui.controls collection. To access a control you can use the Xrm.Page.ui.controls. get method or the shortcut version Xrm.Page.getControl.

The get method accepts four types of arguments:

  • String: Returns a control where the logical name matches the string.
  • Number: Returns the control where the Xrm.Page.ui.controls collection index matches the number.
  • None: Returns an array of all the controls.
  • Delegate function(control,index): Returns an array of any controls from the Xrm.Page.ui.controls collection that cause the delegate function to return true.

Task Example

Access all the controls for a specific attribute

var nameControls = Xrm.Page.getAttribute("name").controls.get();

Assigns an array of all the controls for the name attribute to the nameControls variable.

Access a control by name

var nameControl = Xrm.Page.getControl("name");

Assigns the first control representing the Account Name field to the nameControl variable.

The first control added to a form for an attribute will have the same name as the attribute. Each additional control name will have an index number appended to the name. For example, three controls for the name attribute will have the names: name, name1, and name2 respectively.

Access a control by index

var firstControl = Xrm.Page.getControl(0);

Assigns the first control in the Xrm.Page.ui.controls collection to the firstControl variable.

Access all controls

var allControls = Xrm.Page.getControl();

Assigns an array of all the controls in the Xrm.Page.ui.controls collection to the allControls variable.

Access all controls that meet a specific criteria

var optionsetControls = Xrm.Page.getControl(function (control, index) {
return control.getControlType() == "optionset";
});

Assigns an array of all the attributes in the Xrm.Page.ui.controls collection that meet the criteria set in the anonymous function which returns true when the control type is “optionset” to the optionsetControls variable to.

Each section also has a controls collection that contains just the controls for that section. The following code sample assigns the generalTabAccountInfoSectionControls variable to an array of controls found in the Address section of the General tab.
var generalTabAccountInfoSectionControls = Xrm.Page.ui.tabs.get("general").sections.get("address").controls.get();

Note
Each attribute exists only once in the form, but a field can be added to the form for that attribute multiple times. Each field that is added creates another control. Forms may be further customized after you write your scripts. The scripts that you write for attribute controls should assume that it has been included in the form multiple times. Any actions you want to take on a control for an attribute should usually be applied to all controls for that attribute. For example, if you want to disable a control, but only disable one of them, the user may still enter data using a different one. For this reason we recommend you use the following pattern using the collection forEach method to apply the same logic to all controls for an attribute, even if there is only one control at the time you write your script.

Xrm.Page.getAttribute("name").controls.forEach(function (control, index) { control.setDisabled(true); });

Go to top

Access header controls

Controls in the header follow the naming convention where “header_” is prepended to the name of the control. For example, if the name attribute is in the header you can access it using:
var nameControlInHeader = Xrm.Page.getControl("header_name");

Access business process flow controls

Controls in the business process flow control follow the naming convention where “header_process_” is prepended to the name of the control. For example, if the name attribute is in the header you can access it using:
var nameControlInBPF = Xrm.Page.getControl("header_process_name");

Note
Only controls in the active stage are in the Xrm.Page.ui.controls collection when the form loads. Other business process flow controls are added when a stage for the current entity is selected.

Form control methods

After you have access to a control you can call the following methods.

Task Method Example

Determine if a control is visible

getVisible

var isNameVisible = Xrm.Page.getControl("name").getVisible();

Assigns a Boolean value to the isNameVisible variable that represents whether the Account Name field is visible.

Hide or show a control

setVisible

Xrm.Page.getControl("name").setVisible(false);

Hides the Account Name field.

Get a reference to the attribute for the control

getAttribute

var nameAttribute = Xrm.Page.getControl("name").getAttribute();

Assigns the attribute for the control for the Account Name field to the nameAttribute variable.

Note
Not all controls have attributes.

Determine the type of the control

getControlType

var optionSetControls = Xrm.Page.getControl(function (control, index) { return control.getControlType() == "optionset"; });

Assigns an array of optionset controls to the optionSetControls variable.

Determine if a control is enabled

getDisabled

var disabledControls = Xrm.Page.getControl(function(control, index) { return control.getDisabled(); });

Assigns an array of disabled controls to the disabledControls variable.

Note
Web resource and subgrid controls do not support this method.

Disable or enable a control

setDisabled

Xrm.Page.getAttribute("name").controls.forEach(function (control, index) { control.setDisabled(true); });

Disable each control for the name attribute.

Tip
Remember that any attribute may have multiple controls.

Get the label for a control

getLabel

var nameControlLabel = Xrm.Page.getControl("name").getLabel();

Assigns the value of the control for the Account Name field to the nameControlLabel variable.

Change the label for a control

setLabel

Xrm.Page.getControl("name").setLabel("Company Name");

Changes the label for the Account Name field to Company Name.

Get the name of a control

getName

var firstControlName = Xrm.Page.getControl(0).getName();

Assigns the name of the first control in the Xrm.Page.ui.controls collection to the firstControlName variable.

Get the parent of a control

getParent

var parentSection = Xrm.Page.getControl("name").getParent();

Assigns the parent section of the control for the Account Name field to the parentSection variable.

Set focus on a control

setFocus

Xrm.Page.getControl("name").setFocus();

Sets focus on the Account Name field.

Go to top

OptionSet control methods

Optionsets have some special methods. It is important to remember that the attribute defines the valid options for an optionset. When you work with an optionset control you can manipulate available options but you cannot create new options.

Task Method Example

Add an option to an optionset control

addOption

var addressTypeCodeControl = Xrm.Page.getControl("address1_addresstypecode");
var billToAddressOption = addressTypeCodeControl.getAttribute().getOption(1);
addressTypeCodeControl.clearOptions();
addressTypeCodeControl.addOption(billToAddressOption);

Using a reference to the control for the Address Type field, access the attribute for the control and use the getOption method to set the billToAddressOption variable to the option representing the Bill To option.

Use clearOptions to remove any existing options and use addOption to set billToAddressOption as the only option available for this control.

Remove all the options from an optionset control

clearOptions

Xrm.Page.getControl("address1_addresstypecode").clearOptions();

Remove all the options from the control for the Address Type field.

Remove a single option from an optionset control.

removeOption

Xrm.Page.getControl("address1_addresstypecode").removeOption(1);

Remove the Bill To option from the control for the Address Type field.

Go to top

IFRAME and web resource control methods

An IFRAME control allows you to include a page within a form by providing a URL. An HTML web resource added to a form is presented using an IFRAME element. Silverlight and image web resources are embedded directly within the page.

Task | Method | Example
Get the value of the data query string parameter passed to a Silverlight web resource. | getData | var dataValue = Xrm.Page.getControl("WebResource_SilverLightControl").getData(); Assigns the value passed through the data query string parameter to the dataValue variable.
Get the URL for the content currently displayed in an IFRAME. | getSrc | var iframeSource = Xrm.Page.getControl("IFRAME_targetPage").getSrc(); Assigns the string representing the current IFRAME.src attribute value to the iframeSource variable.
Set the URL for the content to be displayed in an IFRAME. | setSrc | Xrm.Page.getControl("IFRAME_targetPage").setSrc("http://www.bing.com"); Sets a URL to be the IFRAME.src for the control.
Get the URL that represents the default configured URL for an IFRAME. | getInitialUrl | var initialUrl = Xrm.Page.getControl("IFRAME_bing").getInitialUrl(); Assigns the initial URL configured to be displayed in the IFRAME to the initialUrl variable.
Gets the object in the form that represents the web resource or IFRAME. | getObject | var obj = Xrm.Page.getControl("IFRAME_bing").getObject(); Assigns an object reference to the obj variable. For an IFRAME this will be the IFRAME Document Object Model (DOM) element. For a Silverlight web resource it will be the Object Object element that represents the embedded Silverlight plug-in.

Go to top

Lookup control methods

A common requirement for lookup controls is to specify the default view displayed when a user updates the field.

Task Method Example

Add a custom view for a lookup.

addCustomView

var viewId = "{C7034F4F-6F92-4DD7-BD9D-9B9C1E996380}";
var viewDisplayName = "SDK Sample View";
var fetchXml = "<fetch version='1.0' " +
"output-format='xml-platform' " +
"mapping='logical'>" +
"<entity name='account'>" +
"<attribute name='name' />" +
"<attribute name='address1_city' />" +
"<order attribute='name' " +
"descending='false' />" +
"<filter type='and'>" +
"<condition attribute='ownerid' " +
"operator='eq-userid' />" +
"<condition attribute='statecode' " +
"operator='eq' " +
"value='0' />" +
"</filter>" +
"<attribute name='primarycontactid' />" +
"<attribute name='telephone1' />" +
"<attribute name='accountid' />" +
"<link-entity "+
"alias='accountprimarycontactidcontactcontactid' " +
"name='contact' " +
"from='contactid' " +
"to='primarycontactid' " +
"link-type='outer' " +
"visible='false'>" +
"<attribute name='emailaddress1' />" +
"</link-entity>" +
"</entity>" +
"</fetch>";
var layoutXml = "<grid name='resultset' " +
"object='1' " +
"jump='name' " +
"select='1' " +
"icon='1' " +
"preview='1'>" +
"<row name='result' " +
"id='accountid'>" +
"<cell name='name' " +
"width='300' />" +
"<cell name='telephone1' " +
"width='100' />" +
"<cell name='address1_city' " +
"width='100' />" +
"<cell name='primarycontactid' " +
"width='150' />" +
"<cell name='accountprimarycontactidcontactcontactid.emailaddress1' " +
"width='150' " +
"disableSorting='1' />" +
"</row>" +
"</grid>";
Xrm.Page.getControl("parentaccountid").addCustomView(viewId, "account", viewDisplayName, fetchXml, layoutXml, true);

Sets the viewId, viewDisplayName, fetchXml, and layoutXml variables to pass as arguments so that a custom view is added as the default view to the control for the Parent Account lookup field.

Get the default view for a lookup.

getDefaultView

var defaultViewId = Xrm.Page.getControl("parentaccountid").getDefaultView();

Assign the id value of the default view to the defaultViewId variable.

Set the default view for a lookup.

setDefaultView

var viewId = "{C7034F4F-6F92-4DD7-BD9D-9B9C1E996380}";
Xrm.Page.getControl("parentaccountid").setDefaultView(viewId);

Sets the default view for the control for the Parent Account field to the id value in the viewId variable.

Filter the records returned for a lookup control

addCustomFilter

The following code sample is for the opportunity form Account (parentaccountid) lookup. When the Sdk.setParentAccountIdFilter function is set in the form Onload event handler, the Sdk.filterCustomAccounts function is added to the PreSearch event for that lookup. The result is that only accounts with the Category (accountcategorycode) value of Preferred Customer (1) will be returned.

JavaScript Copy Code
var Sdk = window.Sdk || {};

Sdk.filterCustomerAccounts = function () {
    //Only show accounts with the type 'Preferred Customer'
    var customerAccountFilter = "<filter type='and'><condition attribute='accountcategorycode' operator='eq' value='1'/></filter>";
    Xrm.Page.getControl("parentaccountid").addCustomFilter(customerAccountFilter, "account");
}
//set 'Sdk.setParentAccountIdFilter' in the Opportunity form Onload event handler
Sdk.setParentAccountIdFilter = function () {
    Xrm.Page.getControl("parentaccountid").addPreSearch(Sdk.filterCustomerAccounts);
}

Go to top

SubGrid control methods

The SubGrid control is a grid within a form. It has one unique method.

Task | Method | Example
Refresh the data displayed in the subgrid | refresh | Xrm.Page.getControl("accountcontactsgrid").refresh(); Refresh the Contactssubgrid.

Go to top

Date Control methods

The Date control has one unique method.

Task | Method | Example
Specify whether a date control should show the time portion of the date. | setShowTime | Xrm.Page.getControl("createdon").setShowTime(false); Set the Created On field so the time is not shown. This method is only available for Updated entities.

Go to top

Form navigation

You can use and manipulate the navigation items on the left side of the form. These navigation items typically show records related to the record displayed in the form.

You can access navigation items using the Xrm.Page.ui.navigation.items collection Like all collections in the form, there is a get and forEach method.

Task Method Example

Get the name of a navigation item

getId

var navItemIds = [];
Xrm.Page.ui.navigation.items.forEach(
function (item, index)
{ navItemIds.push(item.getId()) }
);

Create a navItemIds array that contains the id values of each navigation item in the Xrm.Page.ui.navigation.items collection.

Get the label of a navigation item.

getLabel

var navAddressesLabel = Xrm.Page.ui.navigation.items.get("navAddresses").getLabel();

Assign the label for the More Addresses navigation item to the navAddressesLabel variable.

Set the label of a navigation item

setLabel

Xrm.Page.ui.navigation.items.get("navAddresses").setLabel("Other Addresses");

Change the More Addresses navigation item label to Other Addresses.

Show or hide a navigation item

setVisible

Xrm.Page.ui.navigation.items.get("navAddresses").setVisible(false);

Hide the More Addresses navigation item.

Determine if a navigation item is visible

getVisible

var moreAddressesVisible = Xrm.Page.ui.navigation.items.get("navAddresses").getVisible()

Assign a Boolean value to the moreAddressesVisible variable to represent whether the More Addresses navigation item is visible.

Set focus on a navigation item.

setFocus

Xrm.Page.ui.navigation.items.get("navAddresses").setFocus();

Set focus on the More Addresses navigation item.

Go to top

Tabs and sections

Each form has collection of tabs. Each Tab has a collection of sections. Each section has a collection of controls. You can programmatically access these elements and use their methods.

Task | Method | Example
Determine if a tab is expanded or collapsed | getDisplayState | var isGeneralTabExpanded = (Xrm.Page.ui.tabs.get("general").getDisplayState() == "expanded") Assign a Boolean value to the isGeneralTabExpanded variable that indicates whether the General tab is expanded.
Expand or collapse a tab | setDisplayState | Xrm.Page.ui.tabs.get("general").setDisplayState("collapsed"); Collapse the General tab.
Determine if a tab is visible | getVisible | var isGeneralTabVisible = Xrm.Page.ui.tabs.get("general").getVisible(); Assign a Boolean value to the isGeneralTabVisible variable indicating whether the General tab is visible.
Show or hide a tab | setVisible | Xrm.Page.ui.tabs.get("general").setVisible(false); Hide the General tab.
Get the label for a tab | getLabel | var generalTabLabel = Xrm.Page.ui.tabs.get("general").getLabel(); Assign the General tab label to the generalTabLabel variable.
Change the label for a tab | setLabel | Xrm.Page.ui.tabs.get("general").setLabel("Major"); Change the General tab label to Major.
Set focus on a tab | setFocus | Xrm.Page.ui.tabs.get("general").setFocus(); Set focus on the General tab.
Get the name of the tab | getName | var firstTabName = Xrm.Page.ui.tabs.get(0).getName(); Assign the name of the first tab to the firstTabName variable.
Get the parent tab of a section | getParent | Xrm.Page.getControl("industrycode").getParent().getParent().setFocus(); Set focus on the tab that contains the Industry field.
Determine if a section is visible | getVisible | var industrySectionVisible = Xrm.Page.getControl("industrycode").getParent().getVisible(); Assign a Boolean value to the industrySectionVisible variable indicating whether the section containing the Industry field is visible.
Show or hide a section | setVisible | Xrm.Page.getControl("industrycode").getParent().setVisible(false); Hide the section that contains the Industry field.
Get the label for a section | getLabel | var industryFieldSectionLabel = Xrm.Page.getControl("industrycode").getParent().getLabel(); Assign the label of the section containing the Industry field to the industryFieldSectionLabel variable.
Change the label for a section | setLabel | Xrm.Page.getControl("industrycode").getParent().setLabel("Detailed Information"); Change the label of the section that contains the Industry field to Detailed Information.

Go to top

Add or remove event handlers at runtime

Event handlers are usually configured using the form editor in the application but you can also add them to the form OnSave event and attribute OnChange events at run time using these APIs. The examples in this section will refer to the following function definition:
function myFunction() {
//perform action here
}

While you can add an anonymous function, the function must have a name to reference in order to remove it.

Task Method Example

Add a function to the OnSave event

addOnSave

Xrm.Page.data.entity.addOnSave(myFunction);

Add the myFunction function to the OnSave event.

Remove a function from the OnSave event

removeOnSave

Xrm.Page.data.entity.removeOnSave(myFunction);

Remove the myFunction function to the OnSave event.

Add a function to the OnChange event of an attribute.

addOnChange

Xrm.Page.getAttribute("name").addOnChange(myFunction);

Add the myFunction function to the OnChange event of the Account Name field.

Remove a function from the OnChange event of an attribute

removeOnChange

Xrm.Page.getAttribute("name").removeOnChange(myFunction);

Remove the myFunction function to the OnChange event of the Account Name field.

Add a function to the PreSearch event of a lookup control

addPreSearch

The following code sample is for the Opportunity form Account (parentaccountid) lookup. When the Sdk.setParentAccountIdFilter function is set in the form Onload event handler, the Sdk.filterCustomAccounts function is added to the PreSearch event for that lookup. The result is that only accounts with the Category (accountcategorycode) value of Preferred Customer (1) will be returned.

JavaScript Copy Code
var Sdk = window.Sdk || {};

Sdk.filterCustomerAccounts = function () {
    //Only show accounts with the type 'Preferred Customer'
    var customerAccountFilter = "<filter type='and'><condition attribute='accountcategorycode' operator='eq' value='1'/></filter>";
    Xrm.Page.getControl("parentaccountid").addCustomFilter(customerAccountFilter, "account");
}
//set 'Sdk.setParentAccountIdFilter' in the Opportunity form Onload event handler
Sdk.setParentAccountIdFilter = function () {
    Xrm.Page.getControl("parentaccountid").addPreSearch(Sdk.filterCustomerAccounts);
}

Use the OnStageChange event and OnStageSelected event for events that occur in the business process flow control. These events only have methods to add or remove event handlers programmatically. More information: Methods to manage event handlers.

Go to top

Contextual information methods

Use these methods to get information about the user, the organization, and the client. The following table provides some of the most useful context methods. For all the context methods, see Client-side context (client-side reference)

Task | Method | Example
Get the URL to connect to the organization. | getClientUrl | var serverUrl = Xrm.Page.context.getClientUrl(); Assign a string that represents the URL to the serverUrl variable.
Get the unique identifier for the current user. | getUserId | var userId = Xrm.Page.context.getUserId(); Assign a string that represents the user’s Id to the userId variable.
Get the name of the current user. | getUserName | var userName = Xrm.Page.context.getUserName(); Assign a string that represents the user’s name to the userName variable. This method is only available for Updated entities.
Get the language code that represents the user’s preferred user interface language. | getUserLcid | var userLCID = Xrm.Page.context.getUserLcid(); Assign a number that indicates the user’s preferred language to the userLCID variable.
Get an array of strings that represents the GUID values for each security role assigned to the current user and any teams that the user is associated with. | getUserRoles | var userRoles = Xrm.Page.context.getUserRoles(); Assign an array of strings that represents the user’s security roles to the userRoles variable.
Determine whether the script is running in the Microsoft Dynamics CRM for Microsoft Office Outlook client. | client.getClient | var isOutlookClient = (Xrm.Page.context.client.getClient() == "Outlook"); Assign a Boolean value that represents whether your code is running in the CRM for Outlook client to the isOutlookClient variable.
Determine whether the user is working offine with the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client. | client.getClientState | var IsOffline = (Xrm.Page.context.client.getClientState() == "Offline"); Assign a Boolean value that represents whether the user is currently working offline to the IsOffline variable.

Go to top

Get, refresh, or save entity data

The following table contains methods you can use to get information about the current record or to save changes. For more information, see Xrm.Page.data.entity (client-side reference) and Xrm.Page.data (client-side reference).

Task Method Example

Get the logical name of the current entity

getEntityName

var entityName = Xrm.Page.data.entity.getEntityName();

Assign the logical entity name to the entityName variable.

Get the value of the primary attribute for the current entity.
The primary attribute is the value used to identify the record. For example contact.fullname.

getPrimaryAttributeValue

var primaryAttributeValue = Xrm.Page.data.entity.getPrimaryAttributeValue();

Assign the value of the primary attribute to the primaryAttributeValue variable.

This method is only available for Updated entities.

Get the Id of the current record

getId

var recordId = Xrm.Page.data.entity.getId();

Assign the id of the record to the recordId variable.

Asynchronously refresh the data of the form without reloading the page.

refresh

Xrm.Page.data.refresh();

Refreshes the data in the form.

This method is only available for Updated entities.

Save the current record

Xrm.Page.data.entity. save

Xrm.Page.data.entity.save();

Saves the record. There are optional arguments. Use saveandclose or saveandnew to perform the equivalent actions.

Save the current record asynchronously with the option to set
callback functions to be executed after the save operation is completed.

Xrm.Page.data. save

Xrm.Page.data.save().then(
function(){
Xrm.Utility.alertDialog("Record saved");
},
function(error){
Xrm.Utility.alertDialog(error.message);
});

Saves the record and displays a message showing the status of the save.

This method is only available for Updated entities.

Determine whether any data in the current record is changed.

getIsDirty

var isDirty = Xrm.Page.data.entity.getIsDirty();

Assign a Boolean value that represents whether data in the record has changed to the isDirty variable.

Get a string that represents the data that will be sent to the server when the record is saved.

getDataXml

var dataXml = Xrm.Page.data.entity.getDataXml();

Assign a string that represents the data to be saved to the dataXml variable.

Go to top

See Also

Concepts

Use the Xrm.Page object model
Write code for Microsoft Dynamics CRM forms

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Open forms, views, dialogs and reports with a URL

URL addressable elements enable you to include links to Microsoft Dynamics CRM forms, views, dialogs, and reports in other applications. In this manner, you can easily extend other applications, reports, or websites so that users can view information and perform actions without switching applications.

Note
  • URL addressable forms, views, dialogs, and reports cannot bypass Microsoft Dynamics CRM security. Only licensed Microsoft Dynamics CRM users, based on their security roles, can access the data and the records they see.
  • Use Xrm.Utility. openEntityForm when you open entity forms programmatically within the application by using web resources. Do not use window.open.
  • Outside the application, where pages do not have access to the Xrm.Utility. openEntityForm function, use window.open or a link to open a specific record or form for an entity. The entire application will open for any of the Updated entities.

In This Topic

URL Addressable Forms and Views

  • Query String Parameters for the Main.aspx Page
  • Copy the URL for a View
  • Display a View in the Application Navigation using the Site Map

Opening a Dialog Process by using a URL

Opening a Report by using a URL

URL Addressable Forms and Views

All entity forms and views are displayed in the main.aspx page. Query string parameters passed to this page control what will be displayed. For example:

To open a new account entity record form for on-premises Microsoft Dynamics CRM:

Copy Code
http://mycrm/myOrg/main.aspx?etn=account&pagetype=entityrecord
To open an account entity record form for Microsoft Dynamics CRM Online where the id is {91330924-802A-4B0D-A900-34FD9D790829}:

Copy Code
http://myorg.crm.dynamics.com/main.aspx?etn=account&pagetype=entityrecord&id=%7B91330924-802A-4B0D-A900-34FD9D790829%7D
To open the Closed Opportunities view for Microsoft Dynamics CRM Online:

Copy Code
http://myorg.crm.dynamics.com/main.aspx?etn=opportunity&pagetype=entitylist&viewid=%7b00000000-0000-0000-00AA-000010003006%7d&viewtype=1039
To open the Active Contacts view for Microsoft Dynamics CRM Online with no navigation bar or command bar

Copy Code
http://myorg.crm.dynamics.com/main.aspx?etn=contact&pagetype=entitylist&viewid={00000000-0000-0000-00AA-000010001004}&viewtype=1039&navbar=off&cmdbar=false
Note
Opening entity forms in a dialog window by using showModalDialog or showModelessDialog is not supported.

Displaying an entity form within an IFrame embedded in another entity form is not supported.

You will typically use the getClientUrl method to retrieve the organization root Url for both on-premises Microsoft Dynamics CRM and Microsoft Dynamics CRM Online.

Query String Parameters for the Main.aspx Page

Tip
To get the id value for any record, use the Send a Link button the command bar. The following is an example of what will be opened in your email application:

<http://mycrm/myOrg/main.aspx?etc=4&id=%7b899D4FCF-F4D3-E011-9D26-00155DBA3819%7d&pagetype=entityrecord>.

The id parameter passed to the URL is the encoded id value for the record. In this example the id value is {899D4FCF-F4D3-E011-9D26-00155DBA3819}. The encoded version of the GUID substitutes opening and closing brackets “{” and “}” with “%7B” and “%7D”, respectively,

The following are the query string parameters used with the main.aspx page to open entity forms or views:

Parameter Description

etn

The logical name of the entity.

Important
Do not use the etc (entity type code) parameter that contains an integer code for the entity. This integer code varies for custom entities in different organizations.

extraqs

Optional for forms. This parameter contains encoded parameters within this parameter.

Use this parameter to pass values to a form. For more information, see Set field values using parameters passed to a form.

When an entity has more than one form defined, you can use this parameter to specify which form to open by passing the encoded parameter formid with the value equal to the ID value of the form. For example, to open a form with the ID of ‘6009c1fe-ae99-4a41-a59f-a6f1cf8b9daf’, include this value in the extraqs parameter: formid%3D6009c1fe-ae99-4a41-a59f-a6f1cf8b9daf%0D%0A.

pagetype

The type of page. There are two possible values:

  • entityrecord
    Displays an entity record form.
  • entitylist
    Displays an entity view.

id

Optional for forms. Use this when you open a specific entity record. Pass in the encoded GUID identifier for the entity. The encoded version of the GUID substitutes opening and closing brackets “{“ and “}” with “%7B” and “%7D”, respectively, for example {91330924-802A-4B0D-A900-34FD9D790829} is %7B91330924-802A-4B0D-A900-34FD9D790829%7D.

viewid

Required for views. This is the ID of the savedquery or userquery entity record that defines the view. The easiest way to get the URL for a view is to copy it. For more information, see Copy the URL for a View.

viewtype

Defines the view type. Possible values are as follows:

  • 1039
    Use for a system view. The viewid represents the Id of a savedquery record.
  • 4230
    Use for a personal view. The viewid represents the Id of a userquery record.

navbar

Controls whether the navigation bar is displayed and whether application navigation is available using the areas and subareas defined in the sitemap.

  • on
    The navigation bar is displayed. This is the default behavior if the navbar parameter is not used.
  • off
    The navigation bar is not displayed. People can navigate using other user interface elements or the back and forward buttons.
  • entity
    On an entity form, only the navigation options for related entities are available. After navigating to a related entity, a back button is displayed in the navigation bar to allow returning to the original record.

cmdbar

Controls whether the command bar is displayed.

Note
This capability supports requirements for the Unified Service Desk for Microsoft Dynamics CRM application.
Using this to display an entity form within an IFrame embedded in another entity form is not supported.

  • true
    The command bar is displayed. This is the default.
  • false
    The command bar is hidden.

Copy the URL for a View

Many views in Microsoft Dynamics CRM let a user copy the URL for a particular view or send an email with the URL for a particular view embedded in the message. This feature makes communication between users easier, and exposes a way for you to gain access to a URL for a view that users can include in another application, such as a SharePoint site.

Note
Do not use this URL to include the view in application navigation using the site map. For more information, see Display a View in the Application Navigation using the Site Map.

The page displayed by the URL includes the full view. This includes the ribbon, but does not include the application navigation.

Get the URL for a View

  1. Open the view you want to use.

  2. On the command bar, choose Send a Link, and then choose Of Current View.

  3. Paste the link into Notepad and edit it to extract only the URL part of the text that you want.

Note
  • Views that use the user context as a parameter, such as My Accounts, cannot be copied.
  • The GUID that represents system views for system entities will be the same for each on-premises Microsoft Dynamics CRM installation. The GUID for custom entities and custom views will be unique for each Microsoft Dynamics CRM installation.

Display a View in the Application Navigation using the Site Map

When you customize the application navigation using the site map, do not use the view URL that you copied from the application using the steps in Copy the URL for a View to set as the URL. That URL displays a page that includes the ribbon and produces undesirable results if used in a <SubArea> (SiteMap) Url attribute.

To display a list of entity records within the application for a SubArea set the Entity attribute value. This displays the default view for that entity and provides the correct title and icon.

However, if you want to have a SubArea element that uses a specific initial default view, use the following Url pattern.

Xml Copy Code
Url=“/_root/homepage.aspx?etn=<entity logical name >&amp;viewid=%7b<GUID value of view id>%7d”

When you use this URL, you must also specify appropriate values for <Titles> (SiteMap) and <Descriptions> (SiteMap), and specify an icon for the entity.

Note
If you specify the view using the /_root/homepage.aspx page, the view selector will still be shown. If the user changes the view, Microsoft Dynamics CRM remembers the user’s most recent selection and the initial default view displays after they close and re-open their browser.

Opening a Dialog Process by using a URL

A common customization is to enable a user to open a specific dialog process in the context of a specific record. For example, you might want to add a custom button to the ribbon for a specific entity using the id value for current record as an input parameter for the dialog process.

To open a dialog you need the following:

  • The unique identifier for the dialog.
  • The logical name for the entity the dialog is created for.
  • The unique identifier for the record you want to have the dialog run against.
Tip
To get the unique identifier for the dialog, navigate to Settings, in the default solution select Processes. Select a process and then in the Actions options on the command bar, choose Copy a Link. This will copy a link to edit the dialog to your clipboard, for example, [organization url]/sfa/workflow/edit.aspx?id=%7b6A6E93C9-1FE6-4C07-91A9-E0E2A7C70976%7d.

The following sample shows the URL and query string parameters to open a dialog:

Copy Code
[organization url]/cs/dialog/rundialog.aspx?DialogId=[dialog unique identifier]&EntityName=[entity logical name]&ObjectId=[unique identifier for the record]

For example, to open the dialog with id ={6A6E93C9-1FE6-4C07-91A9-E0E2A7C70976} with the account record id = {40C9ADFD-90A8-DF11-840E-00155DBA380F}, use the URL in the following example.

Copy Code
[organization url]/cs/dialog/rundialog.aspx?DialogId=%7b6A6E93C9-1FE6-4C07-91A9-E0E2A7C70976%7d&EntityName=account&ObjectId=%7b40C9ADFD-90A8-DF11-840E-00155DBA380F%7d
Tip
For browsers other than Internet Explorer, if a dialog process is opened from a link, the Finish button may not work. The data will be saved, but the user will need to choose the Close button on the window to close it. This is because other browsers do not provide a window.close method if the window is not opened using JavaScript from another window. When possible, use JavaScript and the window.open method to open dialog processes rather than simply providing links.

You can create a JavaScript function to open the dialog as shown in the following example:

JavaScript Copy Code
function openDialogProcess(dialogId, entityName, objectId)
{
 var url = Xrm.Page.context.getClientUrl() +
  "/cs/dialog/rundialog.aspx?DialogId=" +
  dialogId + "&EntityName=" +
  entityName + "&ObjectId=" +
  objectId;
 window.open(url);
}

Opening a Report by using a URL

You can open a report by passing appropriate parameter values to the following URL: [organization url]/crmreports/viewer/viewer.aspx.

This URL accepts the following parameters:

action

Two possible values for this parameter are run or filter. When run is used, the report will be displayed using the default filters. When filter is used, the report will display a filter that the user can edit before choosing the Run Report button to view the report.

helpID

This parameter is optional. For reports that are included with Microsoft Dynamics CRM the value in this parameter allows the Help button to display appropriate content about this report when Help on This Page is chosen. The value should correspond to the report FileName attribute value.

id

This parameter is the report ReportId attribute value.

The following examples show URLs that can be used to open reports in Microsoft Dynamics CRM.

Open the Neglected Cases report using the default filter:

Copy Code
[organization url]/crmreports/viewer/viewer.aspx?action=run&helpID=Neglected%20Cases.rdl&id=%7b8c9f3e6f-7839-e211-831e-00155db7d98f%7d
Open the Top Knowledge Base Articles report and prompt the user to set filter values:

Copy Code
[organization url]/crmreports/viewer/viewer.aspx?action=filter&helpID=Top%20Knowledge%20Base%20Articles.rdl&id=%7bd84ec390-7839-e211-831e-00155db7d98f%7d

The following function shows how to properly encode values in the URL:

JavaScript Copy Code
  function getReportURL(action,fileName,id) {
   var orgUrl = GetGlobalContext().getClientUrl();
   var reportUrl = orgUrl +
    "/crmreports/viewer/viewer.aspx?action=" +
    encodeURIComponent(action) +
    "&helpID=" +
    encodeURIComponent(fileName) +
    "&id=%7b" +
    encodeURIComponent(id) +
    "%7d";
   return reportUrl;
  }

See Also

Reference

Start Dialog by using a URL

Concepts

Set field values using parameters passed to a form
Configure a form to accept custom querystring parameters
Change application navigation using the SiteMap
Write code for Microsoft Dynamics CRM forms
Web resources for Microsoft Dynamics CRM

Other Resources

Write client application extensions
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Set field values using parameters passed to a form

The content in this topic can be used for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. You can set default values for new records created by users by specifying attribute values in the URL that is used to open the form. By default, these values are set in the form, but can be changed by users before they save the record.

In This Topic

Pass parameters to set field record values

Example: Set the value for string fields

Set values for lookup fields

Example: Set the value for lookup fields

Example: Set the value for date fields

Example: Set the value for option set fields

Example: Use Xrm.Utility.openEntityForm to open a new window

Example: Use window.open to open a new window

Pass parameters to set field record values

Note
You can pass parameter values to the form to set field values using the Xrm.Utility. openEntityForm function. For an example, see Example: Use Xrm.Utility.openEntityForm to Open a New Window.

When you open a new form by using the URL address, you can include arguments in the extraqs parameter to set field values. The following requirements must be met:

  • You must encode the parameters passed in the extraqs parameter. To encode the parameters, use encodeURIComponent.
  • The names of the query string arguments must match or include the names of attributes for the entity.
  • The values passed must be valid.
  • The value can’t be a script.

Any attempt to pass an invalid parameter or value will result in an error.

  • For Boolean fields, use either an integer value of 0 or 1, or a text value of true or false to set the value.
  • For DateTime fields, use the text value of the date.

Example: Set the value for string fields

The following sample sets the value for the Name field of a new account record to "New Account".

The unencoded value for the extraqs parameter is “name=New Account”.

Copy Code
/main.aspx?etn=account&extraqs=name%3DNew%20Account&pagetype=entityrecord

Set values for lookup fields

The following table describes five types of lookup fields. For examples using lookup fields, see Example: Set the Value for Lookup Fields and Example: Use Xrm.Utility.openEntityForm to Open a New Window.

Lookup Type | Description
simple lookup | Allows for a single reference to one type of entity.
customer lookup | Allows for a single reference to either an account or a contact record.
owner lookup | Allows for a single reference to either a team or a system user record.
partylist lookup | Allows for multiple references to multiple entities.
regarding lookup | Allows for a single reference to multiple entities.

The following guidelines apply when setting the value of a lookup on a form using a query string argument:

  • For simple lookups you must set the value and the text to display in the lookup. Use the suffix “name” with the name of the attribute to set the value for the text.
    Don’t use any other arguments.
  • For customer and owner lookups you must set the value and the name in the same way you set them for simple lookups. In addition you must use the suffix “type” to specify the type of entity. Allowable values are account, contact, systemuser, and team.
  • You can’t set the values for partylist or regarding lookups.

Example: Set the value for lookup fields

To set values for lookup fields, use the data value, the name value, and for customer or owner lookups only, specify the type value for the respective field. The following sample sets the owner field to a user named “Mark Folkerts”.

The unencoded value for the extraqs parameter is “ownerid={B8C6E040-656E-DF11-B414-00155DB1891A}&owneridname=Mark Folkerts&owneridtype=systemuser”.

Copy Code
/main.aspx?etn=lead&pagetype=entityrecord&extraqs=ownerid%3D%7bB8C6E040-656E-DF11-B414-00155DB1891A%7d%26owneridname%3DMark%20Folkerts%26owneridtype%3Dsystemuser

The following sample sets the primary contact field to a user named “Yvonne McKay (sample)”.The unencoded value for the extraqs parameter is “primarycontactid={43b58571-eefa-e311-80c1-00155d2a68c4}&primarycontactidname=Yvonne McKay (sample)”.

Copy Code
/main.aspx?etn=account&pagetype=entityrecord&extraqs=primarycontactid%3D%7B43b58571-eefa-e311-80c1-00155d2a68c4%7D%26primarycontactidname%3DYvonne%20McKay%20(sample)
Note
For a simple lookup like this, you don’t have to set a type value.

Example: Set the value for date fields

The following sample sets the Est. Close Date field for a new opportunity to January 31, 2011. The unencoded value for the extraqs parameter is “estimatedclosedate=01/31/11”.

Copy Code
/main.aspx?etn=opportunity&extraqs=estimatedclosedate%3D01%2F31%2F11&pagetype=entityrecord

Example: Set the value for option set fields

To set the value for an Option set field, set the integer value for the option. The following sample sets the Role field value to “Decision Maker” in a new contact record.

The unencoded value for the extraqs parameter is “accountrolecode=1”.

Copy Code
/main.aspx?etn=contact&extraqs=accountrolecode%3D1&pagetype=entityrecord

Example: Use Xrm.Utility.openEntityForm to open a new window

The following sample sets default values on several different fields and shows how to use the Xrm.Utility.openEntityForm function. It is equivalent to the previous example that used the window.open method.

JScript Copy Code
function OpenNewContact() {
 var parameters = {};
 //Set the Parent Customer field value to “Contoso”.
 parameters["parentcustomerid"] = "2878282E-94D6-E111-9B1D-00155D9D700B";
 parameters["parentcustomeridname"] = "Contoso";
 parameters["parentcustomeridtype"] = "account";
 //Set the Address Type to “Primary”.
 parameters["address1_addresstypecode"] = "3";
 //Set text in the Description field.
 parameters["description"] = "Default values for this record were set programmatically.";
 //Set Do not allow E-mails to "Do Not Allow".
 parameters["donotemail"] = "1";

 // Open the window.
 Xrm.Utility.openEntityForm("contact", null, parameters);
}

Example: Use window.open to open a new window

The following sample sets default values on several different fields and shows how to use encodeURIComponent to encode the value of the extraqs parameter. If you use the window.open method, you can control the features of the window that is opened.

JScript Copy Code
function OpenNewContact() {
    //Set the Parent Customer field value to “Contoso”.
    var extraqs = "parentcustomerid={F01F3F6D-896E-DF11-B414-00155DB1891A}";
    extraqs += "&parentcustomeridname=Contoso";
    extraqs += "&parentcustomeridtype=account";
    //Set the Address Type to “Primary”.
    extraqs += "&address1_addresstypecode=3";
    //Set text in the Description field.
    extraqs += "&description=Default values for this record were set programatically.";
    //Set Do not allow E-mails to "Do Not Allow".
    extraqs += "&donotemail=1";
    //Set features for how the window will appear.
    var features = "location=no,menubar=no,status=no,toolbar=no";
    // Open the window.
    window.open("/main.aspx?etn=contact&pagetype=entityrecord&extraqs=" +
     encodeURIComponent(extraqs), "_blank", features, false);
}

See Also

Reference

openEntityForm

Concepts

Open forms, views, dialogs and reports with a URL
Configure a form to accept custom querystring parameters

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Configure a form to accept custom querystring parameters

The ability to pass values to a Web page by using query strings represents a concern for security. Microsoft Dynamics CRM applies the best practice of always comparing any parameter passed as a query string against a list of expected parameter names and data types.

By default, Microsoft Dynamics CRM allows a specified set of query string parameters to be passed to a form. You use these parameters to set default values when you create a new record in the application. Each parameter must use a standard naming convention that includes a reference to the attribute logical name. For more information, see Set field values using parameters passed to a form.

In your applications, you may want to pass custom query string parameters to an entity form. This topic provides information about how you can define a set of specific parameter names and data types that can be accepted for a specific entity form.

Define allowed query string parameters

There are two ways to specify which query string parameters will be accepted by the form:

  • Edit form properties
  • Edit form XML

Edit form properties

When you edit an entity form, on the Home tab in the Form group, click Form Properties. In the Form Properties dialog box, select the Parameters tab.

Use this tab to modify the names and data types that the form allows.

Edit FormXml

Within the exported solution customizations.xml file, immediately following the footer element, you can add a <formparameters> (FormXml) element. In the <formparameters> element, add <querystringparameter> (FormXml) elements to specify which parameters will be allowed.

The following describes the querystringparameter element attributes, name and type:

  • name. Each name attribute must contain at least one underscore ('_') character, but the name of the query string parameter cannot begin with an underscore. The name also can’t start with “crm_”. We strongly recommend that you use the customization prefix of the solution publisher as the naming convention. A valid querystringparameter name attribute value is “myISV_contact_specialvalue”.
    Important
    If a querystringparameter element name is not unique, it may be overwritten by another parameter definition using a different data type.

  • Type. Match the data type values with the parameter values so that invalid data is not passed with the parameter. The following are valid data types:
    • Boolean
    • DateTime
    • Double
    • EntityType
    • Integer
    • Long
    • PositiveInteger
      Note
      PositiveInteger includes “0” in the range of valid values.

    • SafeString
    • UniqueId
    • UnsignedInt

See Also

Concepts

Set field values using parameters passed to a form
Open forms, views, dialogs and reports with a URL

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Web resources for Microsoft Dynamics CRM

Web resources are virtual files that are stored in the Microsoft Dynamics CRM database and that you can retrieve by using a unique URL address.

In This Topic

Capabilities of web resources

Web resource types

Reference web resources

Capabilities of web resources

Web resources represent files that can be used to extend the Microsoft Dynamics CRM web application such as html files, JScript, and Silverlight applications. You can use web resources in form customizations, the SiteMap, or the application ribbon because they can be referenced by using URL syntax.

The URL syntax for web resources allows for relative path references. With your development tools, you can create a group of interdependent files on a development server by using file types compatible with web resources. Then, if you use a consistent naming convention and relative path references, the website will function after you upload all the files into Microsoft Dynamics CRM.

Because web resources are stored in Microsoft Dynamics CRM and are solution components, they can be easily exported and installed to on-premises deployments of Microsoft Dynamics CRM or to Microsoft Dynamics CRM Online. Web resources are also available to users of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access when offline because they are synchronized with the user's data.

You can use the form editor to add and configure form-enabled web resources into your entity forms.

Because web resources are stored as records in the database, they can be managed programmatically by using the standard techniques to create, retrieve, and update records. Text-based web resources (JScript, CSS, XML, XSL, and HTML) can be edited and saved in the application.

Limitations of web resources

There is no type of web resource that supports the capabilities of an ASP.NET (.aspx) page to execute code on the server. Web resources are limited to static files or files that are processed in the browser. A web resource can contain code that is processed in the browser to execute web service calls to interact with Microsoft Dynamics CRM data. For more information, see Use web service data in web resources (OData and Modern app SOAP endpoint),

Web resources are only available by using the Microsoft Dynamics CRM web application security context. Only licensed Microsoft Dynamics CRM users who have the necessary privileges can access them.

Size limitations

The maximum size of files that can be uploaded is determined by the Organization.MaxUploadFileSize property. This property is set in the Email tab of the System Settings in the CRM application. This setting limits the size of files that can be attached to email messages, notes, and web resources. The default setting is 5 MB.

Web resource types

You can use ten file formats to create web resources. The following table lists each file format, the allowed file extensions, and the type value that you use for each.

File | File extensions | Type
Webpage (HTML) | .htm, .html | 1
Style Sheet (CSS) | .css | 2
Script (JScript) | .js | 3
Data (XML) | .xml | 4
Image (PNG) | .png | 5
Image (JPG) | .jpg | 6
Image (GIF) | .gif | 7
Silverlight (XAP) | .xap | 8
StyleSheet (XSL) | .xsl, .xslt | 9
Image (ICO) | .ico | 10

Reference web resources

There are several methods that you can use to reference web resources.

Note
  • When possible, use the $webresource directive. Only references that use the $webresource directive in the site map or ribbon commands will establish dependencies. Dependencies are not created when web resources reference each other.
  • To display a Silverlight web resource outside an entity form or chart, create an HTML web resource to be the host page for the Silverlight web resource. Then use the $webresource: directive to open the HTML web resource.

$webresource directive

You should always use the $webresource directive when referencing a web resource from a ribbon control or from a SiteMap sub area. Use the $webresource directive anywhere the XML allows a URL value. The following sample shows how to use it.

Xml Copy Code
$webresource:<name of Web Resource>
Note
When using the $webresource directive, Microsoft Dynamics CRM will create or update solution dependencies.

Xrm.Utility.openWebResource

The Xrm.Utility.openWebResource function will open an HTML web resource in a new window with parameters to pass the name of the web resource, any query string data to be passed in the data parameter, and information about height and width of the window.

The URL generated includes the unique GUID token so that the cached web resource will be loaded.

Relative URL

When referencing a web resource from areas that do not support using the $webresource: directive, a relative URL can be used. To enable this, we recommend that you use a consistent naming convention for the web resources that reflect a virtual file structure. The solution publisher’s customization prefix will always be included as a prefix to the name of the web resource. This can represent a virtual ”root” folder for all web resources added by that publisher. You can then use the forward slash character (/) to simulate a folder structure that will be honored by the web server.

From another web resource, you should always use relative URLs to reference each other. For example, for the web page web resource new_/content/contentpage.htm to reference the CSS web resource new_/Styles/styles.css, create the link as follows:

Html Copy Code
<link rel="stylesheet" type="text/css" href="../styles/styles.css" />

For the web page web resource new_/content/contentpage.htm to open the webpage web resource isv_/foldername/dialogpage.htm, create the link as follows:

Html Copy Code
<a href="../../isv_/foldername/dialogpage.htm">Dialog Page</a>
Note
Do not use a relative URL using the WebResources folder as the root path for the URL. For example, do not use this: /WebResources/<name of web resource>. When a user belongs to more than one organization on a server, this path will always refer to the users default organization. If the user is not using their default organization and the expected web resource is not included in the user’s default organization, a “File Not Found” error occurs even though the web resource does occur in the organization the user is currently working in.

Full URL

The following sample shows the style of URL you can use to view web resources.

Copy Code
<Microsoft CRM URL>/WebResources/<name of web resource>

The application will process this URL and return the file that contains the latest version of the web resource. This URL will look like this:

Copy Code
<Microsoft CRM URL>/%7B<GUID value>%7D/WebResources/<name of web resource>

The GUID value is updated when you publish customizations and ensures that the browser uses the latest cached version of the web resource. Because of this, use a relative path to a web resource, the Xrm.Utility.openWebResource function, or the $webresource Directive (when possible) because the GUID value will automatically be included. For large web resources such as Silverlight web resources, there can be significant performance implications if you don’t use the cached version of the file.

The following sample shows a URL for Microsoft Dynamics CRM Online, where MyOrganization is the name of your organization, and new_/test/test.htm is the name of the web resource:

Copy Code
https://MyOrganization.crm.dynamics.com/WebResources/new_/test/test.htm
Note
Including the ‘/’ character and a file name extension in the name of the web resource is an optional best practice.

The following sample shows a URL for on–premises Microsoft Dynamics CRM, where myServer is the server name:

Copy Code
http://myServer/MyOrganization/WebResources/new_/test/test.htm

When you write code to reference a web resource that will need to work for either Microsoft Dynamics CRM Online or on–premises Microsoft Dynamics CRM, you should use the getClientUrl function.

See Also

Tasks

Sample: Pass multiple values to a web resource through the data parameter

Concepts

JavaScript libraries for Microsoft Dynamics CRM
Create accessible web resources
Webpage (HTML) web resources
Silverlight (XAP) web resources
Script (JScript) web resources
Image (JPG, PNG, GIF, ICO) web resources
Stylesheet (XSL) web resources
Data (XML) Web resources
CSS web resources
WebResource entity messages and methods

Other Resources

Write client application extensions
Sample: Web resource utility
Sample: Import files as web resources
Use web service data in web resources (OData and Modern app SOAP endpoint)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create accessible web resources

When you include web resources that provide user interface elements in your solution, make sure that you include requirements that let people with disabilities use your web resources.

The Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update application user interface elements follow standards and best practices that will allow for equivalent functionality for all users. People with disabilities may rely on the use of assistive technology (AT) such as screen readers or a variety of alternative input devices to interact with applications.

This topic introduces general guidance and links to more resources that will help you design web resource user interface elements that are accessible to people with disabilities.

In This Topic

Assistive technology

Accessible HTML web resources

Accessible Silverlight web resources

Accessibility testing tools

Additional resources

Assistive technology

There are a variety of assistive technology (AT) applications that include screen readers, Braille terminals, and speech recognition software. These applications provide an intermediary with your user interface elements so that people using the AT application can use your program.

For Windows applications, the Microsoft UI Automation (UIA) classes provide programmatic access to user interface elements. These classes support both automated testing and AT. AT applications can use the properties and elements defined by the developer and exposed through UIA. A windows application developer has considerable control over how their UI elements are exposed by using UIA.

For web applications, certain HTML elements are exposed through the Document Object Model (DOM). The browser converts DOM elements to UIA objects with properties and events that AT can use to enable the user to use the web application. The developer has limited control over how the UI elements are exposed by the browser that uses UIA.

Accessible HTML web resources

The HTML in your web resources is processed by the browser and made available to AT applications.

The first thing to consider is making sure that your HTML follows expected patterns of usage. For example, you can define an HTML div element with a click event so that it functions exactly like an HTML button element. However, the browser will not expect that a div element is being used as a button and will not expose the same properties and events to an AT application.

It is important that you use the correct HTML elements for the types of interactions users will have with your web resources. This is known as semantic HTML.

However, semantic HTML can only go so far. Modern web applications typically include custom controls that are composed of many HTML elements working together. Page content that is frequently updated dynamically using asynchronous JavaScript is confusing for AT applications that rely only on semantic HTML. Accessible Rich Internet Applications (ARIA) technology provides a solution by extending HTML with additional attributes that communicate custom semantics.

ARIA provides a standard set of extended attributes that can be applied to HTML elements that are used in a control, or “widget.” These attributes describe the role that the HTML element plays in the control. ARIA also provides capabilities to improve the navigation experience and make the user aware of elements that may be updated dynamically. The recommended practice is to layer ARIA over semantic HTML.

In addition to including support for AT, there are other requirements you have to consider. For example, how does the UI adjust when the user increases the text size? Does your UI require that the user be able to differentiate colors to perform tasks? Can all actions be performed by using a keyboard? For more information, see Introduction to Web Accessibility.

Accessible Silverlight web resources

Silverlight web resources are hosted in a Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update form or an HTML web resource and the UI is rendered by the Silverlight browser plug-in. Silverlight is a subset of the Windows Presentation Framework (WPF) and therefore programmatic access and AT are exposed by using UIA that resembles WPF windows applications. For more information, see Silverlight Accessibility for Developers.

Accessibility testing tools

The following list provides some publicly available accessibility testing tools:

Visual Studio Accessibility Checker

If you are using Microsoft Visual Studio to edit your HTML web resource files, you will find that there are built-in tools to check for issues related to accessibility. In the Tools menu, select Check Accessibility to see a report that will provide guidance about accessibility related issues.

UI Accessibility Checker

UI Accessibility Checker (or AccChecker) enables testers to easily discover accessibility problems with Microsoft Active Accessibility (MSAA) and other user interface (UI) implementations for Windows. AccChecker was born from the realization that existing Windows Automation API tools, such as Inspect, provided in-depth details on the implementation, but no information about whether that implementation is correct or not.

Inspect (Inspect.exe)

Inspect (Inspect.exe) is a Windows-based tool that enables you select any UI element and view the element's accessibility data. You can view Microsoft UI Automation properties and control patterns in addition to Microsoft Active Accessibility properties. Inspect also enables you to test the navigational structure of the automation elements in the UI Automation tree, and the accessible objects in the Microsoft Active Accessibility hierarchy

Accessible Event Watcher (AccEvent.exe)

The Accessible Event Watcher (AccEvent) tool allows developers and testers to validate that an application's UI elements raise appropriate Microsoft UI Automation and Microsoft Active Accessibility events when UI changes occur. Changes in the UI can occur when the focus changes, or when a UI element is invoked, selected, or has a state or property change.

Additional resources

The following resources provide a starting point for defining requirements for making your web resources accessible:

  • CRM, Accessibility, and 508
  • Introduction to Web Accessibility
  • Accessibility in Visual Studio and ASP.NET
  • Silverlight Accessibility for Developers
  • Accessibility Overview
  • Accessibility - W3C
  • Web Content Accessibility Guidelines (WCAG) 2.0

See Also

Concepts

Webpage (HTML) web resources
Silverlight (XAP) web resources
Web resources for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create web resources and IFRAME content for use with the CRM for tablets client

Although Microsoft Dynamics CRM for tablets does not support IFrames or web resources in this release, you can get started developing solutions that use these capabilities for a future release that will support them.

For Microsoft Dynamics CRM Online 2015 Update the capability to display IFrames or web resources in CRM for tablets is available as a preview feature for selected regions. This feature is only available for Android and iOS tablets and is not available for Microsoft Dynamics CRM (on-premises).

In this topic

Enable this preview feature

Enable IFrames and web resources for CRM for tablets

Configure a web resource to be displayed in CRM for tablets

Configure a form or dashboard IFrame or web resource control to display in CRM for tablets

Known issues

Enable this preview feature

Preview features are not meant for production use and are subject to separate Supplemental Terms of Use for Microsoft Dynamics CRM Online Previews.

Note
Microsoft does not provide support for this preview feature. Use Microsoft Connect to report issues, suggestions, and any other product feedback for this preview feature.

The preview release of this feature is intended to facilitate early development and testing of touch-enabled controls for CRM for tablets. This preview also helps the product team to collect feedback from you.

Enable IFrames and web resources for CRM for tablets

When this preview feature is enabled you can configure IFrames and web resources in forms and dashboards in the Microsoft Dynamics CRM web app which can be configured to display in CRM for tablets. To enable this preview feature for your organization, you must be a CRM administrator.

  1. Go to Settings > Administration > System Settings and choose the Customization tab.

  2. Under Preview feature, choose agreement terms to review the terms of use.

  3. Under Preview feature, check both boxes to enable web resources and IFrames in CRM for tablets.

Configure a web resource to be displayed in CRM for tablets

After you have enabled this preview feature, you must also enable each web resource by selecting the CRM for tablets checkbox in the web resource form. The WebResource.IsEnabledForMobileClient attribute stores this data.

Configure a form or dashboard IFrame or web resource control to display in CRM for tablets

When you add an IFrame a web resource or to a form or dashboard you must select the CRM for tablets checkbox in the Add Web Resource dialog. This sets the <ShowOnMobileClient> (FormXml) parameter value for the control.

Known issues

You can’t use popups for authentication or other purposes from within IFrames and web resources on CRM for tablets.

Authentication for embedded O365 sites is not available.

Errors and memory leaks in IFrames and web resources can crash CRM for tablets and can cause client side data loss.

This preview feature can adversely affect application performance.

Microsoft Silverlight and image web resources are not available on CRM for tablets.

See Also

Concepts

Use an IFRAME and web resource controls on a form
Webpage (HTML) web resources

Other Resources

Preview: Web resource and IFRAME support on CRM for tablet
Preview feature: IFrame and web resource support in CRM for tablets

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Webpage (HTML) web resources

Use webpage (HTML) web resources to create user interface elements for client extensions.

In This Topic

Capabilities of HTML web resources

Limitations of HTML web resources

Use the text editor for HTML web resources

Prevent editing of web resources for managed solutions

Reference other web resources from an HTML web resource

Pass parameters to HTML web resources

Capabilities of HTML web resources

Because an HTML web resource is just streamed to the user's browser, it can include any content that is rendered on the user's browser.

Limitations of HTML web resources

  • An HTML web resource can’t contain any code that must be executed on the server. ASP.NET pages can’t be uploaded as HTML web resources.
  • HTML web resources can only accept a limited number of query string parameters. More information: Pass parameters to HTML web resources.

Use the text editor for HTML web resources

The text editor provided in the web resource form is intended for use with very simple HTML editing. For more sophisticated HTML documents, you should edit the code in an external editor and use the Browse button to upload the contents of your file.

For example, a more complex HTML page that requires script to render the contents of the page will begin like the following sample.

Xml Copy Code
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
 <title></title>
 <script src="Script/Script.js" type="text/javascript"></script>
 <link href="CSS/Styles.css" rel="stylesheet" type="text/css" />
</head>
<body onload="SDK.ImportWebResources.showData()">
 <div id="results" />
</body>
</html>

After the document is opened in the text editor and saved, the HTML will be changed to this.

Copy Code
<HTML><HEAD><TITLE></TITLE>
<META charset=utf-8></HEAD>
<BODY contentEditable=true onload=SDK.ImportWebResources.showData()>
<SCRIPT type=text/javascript src="Script/Script.js"></SCRIPT>
 <LINK rel=stylesheet type=text/css href="CSS/Styles.css">
<DIV id=results></DIV></BODY></HTML>

Prevent editing of web resources for managed solutions

Because of the capability for the HTML in web resources to be changed by using the text editor, it’s recommended that you use managed properties to set complex HTML web resources as not customizable for managed solutions. When viewing web resources in the solutions window, open the Managed Properties dialog box to set the Customizable property to false.

Reference other web resources from an HTML web resource

You can create a set of related files outside of Microsoft Dynamics CRM that use any of the web resource file types. If you’re careful to always use relative paths and import each web resource with a consistent naming convention that reflects the folder structure of your website, you’ll find that the HTML web resource will maintain links to related CSS, XML, JScript, image, and Silverlight files that have been imported as web resources.

For example, if you create a web application project that uses the following [folder]/file structure:

  • page.htm
  • [Styles]
    • style.css
  • [Scripts]
    • script.js

When you import these files as web resources, you can name where your solution publisher customization prefix is “new” in the following manner:

  • new_/page.htm
  • new_/Styles/style.css
  • new_/Scripts/script.js

When you follow this pattern, your new_/page.htm HTML web resource can reference the other files the most common way using relative paths as shown in the following example.

Html Copy Code
<script src="Scripts/script.js" type="text/javascript"></script>
<link href="Styles/style.css" rel="stylesheet" type="text/css" />

The solution publisher customization prefix becomes a virtual root folder for all the web resources in your solution. If you change your customization prefix, the relative paths within your HTML web resources won’t be changed.

Note
  • An HTML web resource added to a form cannot use global objects defined by JavaScript library loaded in the form. An HTML web resource may interact with the Xrm.Page or Xrm.Utility objects within the form by using parent.Xrm.Page or parent.Xrm.Utility, but global objects defined by form scripts will not be accessible using parent. You should load any libraries that an HTML web resource needs within the HTML web resource so they are not dependent on scripts loaded in the form.
  • References included in code between web resources are not tracked as solution dependencies.

Because web resources are also downloaded for users of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access, users will have access to web resource content while they’re working offline.

Pass parameters to HTML web resources

An HTML web resource can accept only the parameters in the following table.

Parameter | Name | Description
typename | Entity Name | The name of the entity.
type | Entity Type Code | An integer that uniquely identifies the entity in a specific organization.
id | Object GUID | The GUID that represents a record.
orgname | Organization Name | The unique name of the organization.
userlcid | User Language Code | The language code identifier being used by the current user.
orglcid | Organization Language Code | The language code identifier that represents the base language for the organization.
data | Optional Data Parameter | An optional value that may be passed.
formid | Form Id | The GUID that represents a form ID.
entrypoint | Entry Point | A string value. This parameter is intended to be passed as an optional value to web resources opened as custom help content for an entity. When enabled, custom help url will include a value of either ‘form’ or ‘hierarchychart’. More information: Add custom help content.
pagemode |  | For internal use only.
security |  | For internal use only.
tabSet |  | For internal use only.

To pass more than one value in the data parameter, you must encode parameters in the value of the data parameter and then include logic to decode the multiple parameters using script in your HTML web resource. The Sample: Pass multiple values to a web resource through the data parameter topic demonstrates one approach to address passing multiple parameter values.

See Also

Concepts

Web resources for Microsoft Dynamics CRM
Create accessible web resources
CSS web resources
Script (JScript) web resources
Data (XML) Web resources
Image (JPG, PNG, GIF, ICO) web resources
Silverlight (XAP) web resources
Stylesheet (XSL) web resources

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Silverlight (XAP) web resources

Important
Microsoft Silverlight web resources remain supported in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update for backwards compatibility. For components that will be able to be presented on all clients, we recommend using HTML web resources with HTML5 instead of Silverlight.

HTML5 is the preferred client technology for the web, over web plug-ins like Silverlight and Flash. HTML5 can be consumed from any device (PC, tablet, smartphone, and more) and heavily uses JavaScript (and many powerful JavaScript libraries, such as jQuery) and CSS.

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update support adding Silverlight 4.0 web resources to entity forms. You can display Silverlight 5.0 web resources within an HTML web resource using a hosting <object> element that is configured for that version.

Note
  • Microsoft Silverlight web resources cannot be viewed in the 64-bit version of Microsoft Office Outlook.
  • To display a Silverlight web resource outside an entity form or chart, create an HTML web resource to be the host page for the Silverlight web resource. Then use the $webresource: directive to open the HTML web resource.

In This Topic

Creating Silverlight Web Resources

Accessing Context data

Passing Data from a Form to an Embedded Silverlight Web Resource

Writing and Testing Silverlight Web Resources

Debugging Silverlight Web Resources

Creating Silverlight web resources

Silverlight web resources are easily created using the web resource form by entering a name, a display name, selecting Silverlight (XAP) as the type, and uploading the .xap file. The web resource must be published before you can use it. However, because Silverlight web resources typically provide some interaction with contextual data in Microsoft Dynamics CRM, you should plan how you create your web resources.

Accessing context data

When you use the Preview button in the web resources form or just browse to the URL provided, the Silverlight application is hosted in a generic HTML page without context information. If your Silverlight application does not require contextual information, you can use this URL to view your Silverlight web resource.

If you do require contextual information, you must either:

  1. Add your Silverlight web resource to an entity form.
  2. View your Silverlight web resource using an HTML web resource configured to provide context information.

If your Silverlight web resource is designed to be viewed in an entity form, the form has an Xrm.Page.context object you can use to access contextual information. For more information, see Client-side context (client-side reference)

If you need your Silverlight application to appear outside the context of the form you must configure an HTML web resource to provide this context information by adding a reference to the ClientGlobalContext.js.aspx page. After this reference is added, your Silverlight application can access contextual information in the same way it can in an entity form. The following sample shows how to call the getClientUrl function from the Xrm.Page.context object.

C# Copy Code
private string clientUrl = "";
ScriptObject xrm = (ScriptObject)HtmlPage.Window.GetProperty("Xrm");
ScriptObject page = (ScriptObject)xrm.GetProperty("Page");
ScriptObject pageContext = (ScriptObject)page.GetProperty("context");
clientUrl = (string)pageContext.Invoke("getClientUrl");

Passing data from a form to an embedded Silverlight web resource

When you add a Silverlight web resource to a form you can select the Pass record object-type code and unique identifier as parameters option. You also have the option to enter text as a custom parameter.

These values are passed to the Silverlight control as a InitParams, a dictionary of key/value pairs.

The values passed are described in the following table.

Key | Description
id | The unique identifier of the record.
type | The entity type code. For custom entities this can vary between organizations.
typename | The logical name of the entity.
orgname | The name of the organization.
userlcid | The language code representing the user’s language preference.
orglcid | The language code representing the organization’s base language.
data | The value of the text entered as a custom parameter.

These values can be accessed at run time using the syntax in the following example:

C# Copy Code
string entityTypeName = App.Current.Host.InitParams["typename"];

Writing and testing Silverlight web resources

If your Silverlight web resource is independent of any contextual data from Microsoft Dynamics CRM, you can write and test your Silverlight application as you typically would. After you create a new web resource by uploading your .xap file, you can test it by using the Preview button in the web resource form after you have saved and published the web resource.

However, it is more likely that your Silverlight application has contextual data dependencies that cannot be fully simulated outside of Microsoft Dynamics CRM.

The process of creating a Silverlight web resource that includes form or context dependencies is as follows:

  1. Create your Silverlight application project.

    You should select to create a web application with your project.

  2. Write and test as much of the application as you can without requiring contextual data from Microsoft Dynamics CRM.

  3. Create web resources by uploading the .xap and .htm files as Silverlight and HTML web resources.

  4. Write code in your Silverlight application project.

  5. Build your Silverlight application project.

  6. Upload the built version of the .xap file from the web application project ClientBin folder to update the Silverlight web resource you created in step 3.

  7. Test your Silverlight web resource by either:

    • Viewing it using the Preview button of the host HTML web resource you created.
    • Viewing it in the context of an entity form that you have added it to.
      Use this option is your Silverlight application has dependencies on Form elements or context information.

  8. Repeat steps 4 through 7 until you are finished.

Note
When you want to show a Silverlight web resource outside of an entity form, for example in the application main frame by editing the Site Map, you must provide a webpage (HTML) web resource to act as the host for the Silverlight web resource.

Important
Never edit the HTML source code for a page hosting a Silverlight web resource using the text editor provided in the application. The text editor changes the HTML and breaks <object> element definition necessary to host the Silverlight XAP web resource. For more information, see Using the Text Editor for HTML Web Resources.

If you must use the text editor, omit the data="data:application/x-silverlight-2," parameter in the <object> element. Although this should prevent breaking the Silverlight web resource, the text editor may still introduce other undesirable changes.

Debugging Silverlight web resources

Silverlight web resources that do not rely on contextual data from Microsoft Dynamics CRM can be debugged in Microsoft Visual Studio. However, if the Silverlight web resource requires contextual data to perform the functions, you will have to use a different procedure.

  1. Build your Silverlight application.

  2. Upload the built version of the .xap file from the web application project ClientBin folder.

  3. View your Silverlight application in the context it is designed to be used in.

  4. In your Silverlight application project, from the Visual Studio menu, select Debug and then Attach To Process.

  5. In the Attach to Process dialog box, find an iexplore.exe process where the Type column value is Silverlight, x86.

  6. Select that process and press Attach to close the dialog box and start debugging.

  7. In your Silverlight application project, set a breakpoint.

  8. Refresh the browser window or, in the Silverlight application, perform the action that you need to test your code.

See Also

Concepts

Create accessible web resources
Web resources for Microsoft Dynamics CRM
Webpage (HTML) web resources
CSS web resources
Script (JScript) web resources
Data (XML) Web resources
Image (JPG, PNG, GIF, ICO) web resources
Stylesheet (XSL) web resources

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Script (JScript) web resources

Use Script (JScript) web resources to create a library of JavaScript functions that can be accessed from anywhere.

In This Topic

Capabilities of script web resources

Limitations of script web resources

Using JavaScript libraries

Referencing a script web resource from a webpage web resource

Capabilities of script web resources

With Script web resources, you can more efficiently manage code used in form scripts, webpage (HTML) web resources, or ribbon commands by linking them to shared library of JavaScript functions.

Limitations of script web resources

Like all web resources, script web resources use the Microsoft Dynamics CRM web application security context. Only licensed Microsoft Dynamics CRM users who have the necessary privileges can access them.

Note
References included in code between web resources aren’t tracked as solution dependencies.

Using JavaScript libraries

For information about developing and testing JavaScript libraries as well as how to associate them with ribbon commands and form events, see JavaScript libraries for Microsoft Dynamics CRM.

Referencing a script web resource from a webpage web resource

All web resources can use relative URLs to reference each other. In the following example, for the webpage web resource new_/content/contentpage.htm to reference the script web resource new_/scripts/myScript.js, add the following HTML code to the head element of new_/content/contentpage.htm.

Html Copy Code
<script type="text/jscript" src="../scripts/myScript.js"></script>

To reference a script from a different publisher, the path must include the customization prefix for that publisher. For example, for the new_/content/contentpage.htm page to reference the MyIsv_/scripts/customscripts.js page, the src attribute value should be ../../MyIsv_/scripts/customscripts.js.

See Also

Concepts

Use JavaScript with Microsoft Dynamics CRM
JavaScript libraries for Microsoft Dynamics CRM
Web resources for Microsoft Dynamics CRM
Webpage (HTML) web resources
CSS web resources
Data (XML) Web resources
Image (JPG, PNG, GIF, ICO) web resources
Silverlight (XAP) web resources
Stylesheet (XSL) web resources

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Image (JPG, PNG, GIF, ICO) web resources

Use image web resources to make images available for use in Microsoft Dynamics CRM.

In This Topic

Capabilities of image web resources

Limitations of Image web resources

Reference an Image web resource from a web page web resource

Reference an Image web resource from a Microsoft Dynamics CRM form

Reference an Image web resource from a ribbon element or from the Site Map SubArea

Capabilities of image web resources

With image web resources you can add images where you need them. Common uses include the following:

  • Custom entity icons
  • Icons for custom Ribbon controls and SiteMap subareas
  • Decorative graphics for entity forms and webpage web resources.
  • Background images that are used by CSS web resources.

Limitations of image web resources

Like all web resources, image web resources use the Microsoft Dynamics CRM security context. Only licensed Microsoft Dynamics CRM users who have the necessary privileges can access them.

Only the four specified types of image files (*.jpg, *.png, *.gif, and *.ico) are supported.

Reference an image web resource from a webpage web resource

All web resources can use relative URLs to reference each other. In the following example, for the webpage (HTML) web resource new_/content/contentpage.htm to reference the image web resource new_/Images/image1.png, add the following HTML code to new_/content/contentpage.htm:

Html Copy Code
<img src="../Images/image1.png" />

Reference an image web resource from a Microsoft Dynamics CRM form

Add an image to an entity form

  1. Navigate to the form editor for an entity.

  2. Select where you want to add the image in the form.

  3. On the Insert tab, click Web Resource.

  4. On the General tab, select the web resource image that you want to add.

  5. Specify a name for the web resource. You can also specify a label and alternative text.

  6. On the Formatting tab, you can define:

    • The number of columns the images should use.
    • The number of rows the images should use, or if it should automatically expand to use available space.
    • The size of the image using the following options:
      • Stretch to fit
      • Stretch to fit (maintain aspect ratio)
      • Original
      • Specific
    • If you select “Specific,” you can enter the desired height and width in pixels.

  7. Click OK.

  8. You must save your changes and publish the form before users can see the image in the form.

Reference an image web resource from a ribbon element or from the Site Map subarea

Use the $webresource: directive to specify a web resource image to use as an icon in the ribbon or in the application navigation using Site Map. The following sample shows how to specify icons for a button in the ribbon.

Xml Copy Code
<Button Id="MyISV.opportunity.form.actions.FlyoutAnchor.Button.1" Image16by16="$webresource:new_/icons/oneIcon16.png" Image32by32="$webresource:new_/icons/oneIcon32.png"/>
Note
Using the $webresource: directive adds a solution dependency that prevents the referenced image web resources from being deleted as long as they are used by another solution component.

See Also

Concepts

Web resources for Microsoft Dynamics CRM
Webpage (HTML) web resources
CSS web resources
Script (JScript) web resources
Data (XML) Web resources
Silverlight (XAP) web resources
Stylesheet (XSL) web resources

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Stylesheet (XSL) web resources

Use Stylesheet (XSL) Web resources to transform XML data.

Capabilities of XSL Web resources

Use XSL Web resources to transform XML data used by your solution.

The following Web resources work together to render a page that displays a table using the data in the XML Web resource. The source files for these Web resources are part of the Import Web Resources sample included with the SDK Download the Microsoft Dynamics CRM SDK package. at sdk\samplecode\cs\client\webresources\importwebresources\importwebresources\filestoimport.

HTML Web resource: sample_/ImportWebResources/Content/ShowData.htm

Html Copy Code
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
 <title></title>
 <script src="Script/Script.js" type="text/javascript"></script>
 <link href="CSS/Styles.css" rel="stylesheet" type="text/css" />
</head>
<body onload="SDK.ImportWebResources.showData()">
 <div id="results" />
</body>
</html>
XSL Web resource: sample_/ImportWebResources/XSL/Transform.xslt

Xml Copy Code
<?xml version="1.0" encoding="utf-8"?>
<xsl:stylesheet version="1.0"
                xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
                xmlns:msxsl="urn:schemas-microsoft-com:xslt"
                exclude-result-prefixes="msxsl"
>
 <xsl:output method="xml"
             indent="yes"/>

 <xsl:template match="@* | node()">
  <xsl:copy>
   <xsl:apply-templates select="@* | node()"/>
  </xsl:copy>
 </xsl:template>

 <xsl:template match="people">
  <xsl:element name="table">
   <xsl:element name="thead">
    <xsl:element name="tr">
     <xsl:element name="th">
      <xsl:text>First Name</xsl:text>
     </xsl:element>
     <xsl:element name="th">
      <xsl:text>Last Name</xsl:text>
     </xsl:element>
    </xsl:element>
   </xsl:element>
   <xsl:element name="tbody">
    <xsl:apply-templates />
   </xsl:element>
  </xsl:element>

 </xsl:template>

 <xsl:template match="person">
  <xsl:element name="tr">
   <xsl:element name="td">
    <xsl:value-of select="@firstName"/>
   </xsl:element>
   <xsl:element name="td">
    <xsl:value-of select="@lastName"/>
   </xsl:element>
  </xsl:element>

 </xsl:template>

</xsl:stylesheet>
XML Web resource: sample_/ImportWebResources/Data/Data.xml

Xml Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<people>
 <person firstName="Apurva"
         lastName="Dalia" />
 <person firstName="Ofer"
         lastName="Daliot" />
 <person firstName="Jim"
         lastName="Daly" />
 <person firstName="Ryan"
         lastName="Danner" />
 <person firstName="Mike"
         lastName="Danseglio" />
 <person firstName="Alex"
         lastName="Darrow" />
</people>
Script Web resource: sample_/ImportWebResources/Script/Script.js

JScript Copy Code
//If the SDK namespace object is not defined, create it.
if (typeof (SDK) == "undefined")
{ SDK = {}; }
// Create Namespace container for functions in this library;
SDK.ImportWebResources = {
 dataFile: "Data/Data.xml",
 transformFile: "XSL/Transform.xslt",
 showData: function () {

  //Create an XML document from the Data.xml file
  var dataXml = new ActiveXObject("Msxml2.DOMDocument.6.0");
  dataXml.async = false;
  dataXml.load(this.dataFile);

  //Create an XML document from the Transform.xslt file
  var transformXSLT = new ActiveXObject("Msxml2.DOMDocument.6.0");
  transformXSLT.async = false;
  transformXSLT.load(this.transformFile);

  // Set the innerHTML of the results area to the output of the transformation.
  var resultsArea = document.getElementById("results");
  resultsArea.innerHTML = dataXml.transformNode(transformXSLT);
 }

}
CSS Web resource: sample_/ImportWebResources/CSS/Styles.css

Copy Code
body
{
    font-family: Calibri;
}
table
{
    border: 1px solid gray;
    border-collapse: collapse;
}
th
{
    text-align: left;
    border: 1px solid gray;
}
td
{
    border: 1px solid gray;
}

See Also

Concepts

Web resources for Microsoft Dynamics CRM
Webpage (HTML) web resources
CSS web resources
Script (JScript) web resources
Data (XML) Web resources
Image (JPG, PNG, GIF, ICO) web resources
Silverlight (XAP) web resources

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Data (XML) Web resources

Use Data (XML) Web resources to save and access data.

Capabilities of XML Web resources

Use XML Web resources to cache data that you want to use in your solution.

Limitations of XML Web resources

Use XML Web resources to cache configuration settings or metadata for your solutions.

An XML Web resource does not represent a robust solution for data that is frequently updated by multiple users. While one user is updating an XML Web resource, another user (or automated process) could update the Web resource and that data would be lost when the first user saves their changes.

All XML files must use the .xml file name extension. Files that use XML data but do not use the .xml file name extension cannot be uploaded as Web resources unless the file name extension is changed.

See Also

Concepts

Web resources for Microsoft Dynamics CRM
Webpage (HTML) web resources
CSS web resources
Script (JScript) web resources
Image (JPG, PNG, GIF, ICO) web resources
Silverlight (XAP) web resources
Stylesheet (XSL) web resources

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CSS web resources

Use cascading style sheet (CSS) web resources to create style sheets for use in webpage web resources.

Capabilities of CSS web resources

With CSS web resources, you can manage the appearance of webpage web resources by linking them to a shared library of CSS styles.

Limitations of CSS web resources

Like all web resources, CSS web resources are only available in the Microsoft Dynamics CRM security context. Only licensed CRM users who have the necessary privileges can access them.

Referencing a style sheet web resource from a webpage web resource

All web resources can use relative URLs to reference each other. In the following example, for the webpage web resource sample_/content/contentpage.htm to reference the style sheet web resource sample_/styles/styles.css, add the following example to the head element of sample_/content/contentpage.htm:

Html Copy Code
<link rel="stylesheet" type="text/css" href="../styles/styles.css" />

To reference a style sheet from a different publisher, the path must include that solution publisher customization prefix. For example, for the sample_/content/contentpage.htm page to reference the MyIsv_/styles/styles.css page, the href parameter value should be ../../MyIsv_/styles/styles.css.

Note
References included in code between web resources aren’t tracked as solution dependencies.

See Also

Concepts

Web resources for Microsoft Dynamics CRM
Webpage (HTML) web resources
Script (JScript) web resources
Data (XML) Web resources
Image (JPG, PNG, GIF, ICO) web resources
Silverlight (XAP) web resources
Stylesheet (XSL) web resources
WebResource entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WebResource entity messages and methods

A web resource stores the data equivalent to files used in web development. Web resources are client-side components that provide custom user interface elements. The schema name for this entity is WebResource. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a web resource. You can also call the IOrganizationService.Retrieve method.
DeleteRequest | Deletes a web resource. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a web resource. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of web resources. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveUnpublishedRequest | Retrieves the current saved definition of a web resource regardless whether it has been published.
RetrieveUnpublishedMultipleRequest | Retrieves the current saved definition of web resources regardless whether they have been published.
UpdateRequest | Updates a web resource. You can also call the IOrganizationService.Update method.

See Also

Tasks

Sample: Pass multiple values to a web resource through the data parameter

Concepts

Web resources for Microsoft Dynamics CRM
WebResource entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Pass multiple values to a web resource through the data parameter

A webpage (HTML) or Silverlight web resource page can only accept a single custom parameter called data. To pass more than one value in the data parameter, you need to encode the parameters and decode the parameters in your page.

The page here represents a technique to pass the additional values within a single parameter and then process them within your web resource. This page is available in the downloadable files for the SDK at sdk\samplecode\js\webresources\showdataparams.htm

Sample HTML web resource

The HTML code below represents a webpage (HTML) web resource that includes a script that defines three functions:

  • getDataParam : Called from the body.onload event, this function retrieves any query string parameters passed to the page and locates one named data.
  • parseDataValue : Receives the data parameter from getDataParam and builds a DHTML table to display any values passed within the data parameter.
    Note
    All characters included in the query string will be encoded using the encodeURIComponent method. This function uses the JScript decodeURIComponent method to decode the values passed.

  • noParams : Displays a message when no parameters are passed to the page.
Html Copy Code
<!DOCTYPE html >
<html lang="en-us">
<head>
 <title>Show Data Parameters Page</title>
 <style type="text/css">
  body
  {
   font-family: Segoe UI, Tahoma, Arial;
   background-color: #d6e8ff;
  }
  tbody
  {
   background-color: white;
  }
  th
  {
   background-color: black;
   color: White;
  }
 </style>
 <script type="text/javascript">
  document.onreadystatechange = function () {
   if (document.readyState == "complete") {
    getDataParam();
   }
  }

  function getDataParam() {
   //Get the any query string parameters and load them
   //into the vals array

   var vals = new Array();
   if (location.search != "") {
    vals = location.search.substr(1).split("&");
    for (var i in vals) {
     vals[i] = vals[i].replace(/\+/g, " ").split("=");
    }
    //look for the parameter named 'data'
    var found = false;
    for (var i in vals) {
     if (vals[i][0].toLowerCase() == "data") {
      parseDataValue(vals[i][1]);
      found = true;
      break;
     }
    }
    if (!found)
    { noParams(); }
   }
   else {
    noParams();
   }
  }

  function parseDataValue(datavalue) {
   if (datavalue != "") {
    var vals = new Array();

    var message = document.createElement("p");
    setText(message, "These are the data parameters values that were passed to this page:");
    document.body.appendChild(message);

    vals = decodeURIComponent(datavalue).split("&");
    for (var i in vals) {
     vals[i] = vals[i].replace(/\+/g, " ").split("=");
    }

    //Create a table and header using the DOM
    var oTable = document.createElement("table");
    var oTHead = document.createElement("thead");
    var oTHeadTR = document.createElement("tr");
    var oTHeadTRTH1 = document.createElement("th");
    setText(oTHeadTRTH1, "Parameter");
    var oTHeadTRTH2 = document.createElement("th");
    setText(oTHeadTRTH2, "Value");
    oTHeadTR.appendChild(oTHeadTRTH1);
    oTHeadTR.appendChild(oTHeadTRTH2);
    oTHead.appendChild(oTHeadTR);
    oTable.appendChild(oTHead);
    var oTBody = document.createElement("tbody");
    //Loop through vals and create rows for the table
    for (var i in vals) {
     var oTRow = document.createElement("tr");
     var oTRowTD1 = document.createElement("td");
     setText(oTRowTD1, vals[i][0]);
     var oTRowTD2 = document.createElement("td");
     setText(oTRowTD2, vals[i][1]);

     oTRow.appendChild(oTRowTD1);
     oTRow.appendChild(oTRowTD2);
     oTBody.appendChild(oTRow);
    }

    oTable.appendChild(oTBody);
    document.body.appendChild(oTable);
   }
   else {
    noParams();
   }
  }

  function noParams() {
   var message = document.createElement("p");
   setText(message, "No data parameter was passed to this page");

   document.body.appendChild(message);
  }
  //Added for cross browser support.
  function setText(element, text) {
   if (typeof element.innerText != "undefined") {
    element.innerText = text;
   }
   else {
    element.textContent = text;
   }

  }
 </script>
</head>
<body>
</body>
</html>

Using this page

  1. Create a webpage web resource called "new_/ShowDataParams.htm" using the sample code.

    The parameters you want to pass are: first=First Value&second=Second Value&third=Third Value

    Note
    If you’re adding static parameters using the Web Resource Properties dialog box from the form editor, you can simply paste the parameters without encoding them into the Custom Parameter(data) field. These values will be encoded for you, but you’ll still need to decode them and extract the values in your page.

  2. For dynamic values generated in code, use the encodeURIComponent method on the parameters. The encoded values should be:

    first%3DFirst%20Value%26second%3DSecond%20Value%26third%3DThird%20Value

    Open the page passing the encoded parameters as the value of the data parameter:

    Copy Code
    http://<server name>/WebResources/new_/ShowDataParams.htm?Data=first%3DFirst%20Value%26second%3DSecond%20Value%26third%3DThird%20Value
    Note
    If you have added the web resource to a form and have pasted the un-encoded parameters into the Custom Parameters(data) field, you can just preview the form.

  3. The new_/ShowDataParams.htm will display a dynamically generated table:

    Parameter Value

    first

    First Value

    second

    Second Value

    third

    Third Value

How it works

To access the values embedded within the data query string parameter value, in your webpage web resource you can extract the value of the data parameter and then use code to split the string into an array so you can access each name value pair individually.

When the page loads the getDataParam function is called. This function simply identifies the data parameter and passes the value to the ParseDataValue function. If no data parameter is found the noParams function will add a message to the page in place of the table.

The ParseDataValue function uses similar logic found in getDataParam to locate the custom parameter delimiters to create an array of name value pairs. Then it generates a table and appends it to the otherwise empty document.body.

See Also

Concepts

Web resources for Microsoft Dynamics CRM
Webpage (HTML) web resources
Silverlight (XAP) web resources

Other Resources

Sample: Import files as web resources

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Import files as web resources
See Also Example

When you develop a large number of files to use as Web resources you can save yourself the work of manually adding them through the application. Many Web resources can be developed and tested outside of Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update and then imported.

This sample provides a simplified example of this process. For a more complex sample that provides a WPF application you can use to import Web resources, see the Sample: Web resource utility.

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK\SampleCode\CS\Client\WebResources\ImportWebResources\

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

The sample code included in the SDK download package includes the following files required by this sample:

ImportJob.xml

This file provides data about the Web Resource records that will be created. For each file it contains the following data:

  • path: The path to each file from the FilesToImport folder.
  • displayName: The display name for the Web resource.
  • description: A description of what each file does.
  • name: The name that will be used for the Web Resource.

    Note
    • Each of these names begin with an underscore character. The customization prefix of the solution publisher will be prepended to the name when the Web resource is created. Rather than hard-coding a specific customization prefix, this sample will detect the current customization prefix for a publisher record that may already exist in the organization.
    • Because each of these files was developed outside of Microsoft Dynamics CRM and depend on relative paths to access each other, the names include backslash “/” characters to create a virtual folder structure so the relative links will continue to function within Microsoft Dynamics CRM.

  • type: Specifies the type of Web Resource to create using the integer values found in Web Resource Types.
FilesToImport/ShowData.htm

This HTML Web resource requires each of the other files to display the following table.

First Name

Last Name

Apurva

Dalia

Ofer

Daliot

Jim

Daly

Ryan

Danner

Mike

Danseglio

Alex

Darrow

FilesToImport/CSS/Styles.css

This file provides the CSS Styles used in ShowData.htm.

FilesToImport/Data/Data.xml

This file contains the list of names that is displayed in the table.

FilesToImport/Script/Script.js

This file contains a JScript library that contains information about the relative location of the Data.xml file and the Transform.xslt file. It also contains the showData function that transforms the data and adds it to the ShowData.htm page.

FilesToImport/XSL/Transform.xslt

This file contains the XSL definition of how to transform the data into an HTML table.

Demonstrates

Creating Web Resources in the Context of a Solution

Web Resources are organization-owned records so they can be created using either the IOrganizationService. Create method or by using the CreateRequest message and the IOrganizationService. Execute method. This sample will show how to use the SolutionUniqueName optional parameter to associate a Web resource with a specific solution when it is created. This requires using the CreateRequest message.

Uploading Files from Disk

The WebResource.Content property requires a Base 64 string representing the binary contents of the file. The following sample is the method used to convert the file into the required type.

C# Copy Code
//Encodes the Web Resource File
static public string getEncodedFileContents(String pathToFile)
{
    FileStream fs = new FileStream(pathToFile, FileMode.Open, FileAccess.Read);
    byte[] binaryData = new byte[fs.Length];
    long bytesRead = fs.Read(binaryData, 0, (int)fs.Length);
    fs.Close();
    return System.Convert.ToBase64String(binaryData, 0, binaryData.Length);
}

Combining Web Resource Record Data with File Data

The ImportJob.xml file demonstrates how the data about the files being imported and the data about the Web Resource to create are combined. In particular, in order for relative links between related files to continue to function, the name of the Web resources you create must preserve information about the relative position of the files on disk using simulated directories in the file name. Because of the data in the ImportJob.xml file all these related Web resource files will be created under a common virtual folder.

Note
It is not necessary to publish Web resources when they are created. It is necessary to publish them when they are updated.

Example

The following portion of the ImportWebResources.cs file expects the following variables:

  • _customizationPrefix : The customization prefix of the Microsoft Dynamics CRM SDK Samples publisher. If this publisher does not exist it will be created with the customization prefix of “sample”.
  • _ImportWebResourcesSolutionUniqueName : The unique name of the Import Web Resources Sample Solution created in this sample. The value is ImportWebResourcesSample.
C# Copy Code

//Read the descriptive data from the XML file
XDocument xmlDoc = XDocument.Load("../../ImportJob.xml");

//Create a collection of anonymous type references to each of the Web Resources
var webResources = from webResource in xmlDoc.Descendants("webResource")
                   select new
                   {
                       path = webResource.Element("path").Value,
                       displayName = webResource.Element("displayName").Value,
                       description = webResource.Element("description").Value,
                       name = webResource.Element("name").Value,
                       type = webResource.Element("type").Value
                   };

// Loop through the collection creating Web Resources
int counter = 0;
foreach (var webResource in webResources)
{
    //Set the Web Resource properties
    WebResource wr = new WebResource
    {
        Content = getEncodedFileContents(@"../../" + webResource.path),
        DisplayName = webResource.displayName,
        Description = webResource.description,
        Name = _customizationPrefix + webResource.name,
        LogicalName = WebResource.EntityLogicalName,
        WebResourceType = new OptionSetValue(Int32.Parse(webResource.type))
    };

    // Using CreateRequest because we want to add an optional parameter
    CreateRequest cr = new CreateRequest
    {
        Target = wr
    };
    //Set the SolutionUniqueName optional parameter so the Web Resources will be
    // created in the context of a specific solution.
    cr.Parameters.Add("SolutionUniqueName", _ImportWebResourcesSolutionUniqueName);

    CreateResponse cresp = (CreateResponse)_serviceProxy.Execute(cr);
    // Capture the id values for the Web Resources so the sample can delete them.
    _webResourceIds[counter] = cresp.id;
    counter++;
    Console.WriteLine("Created Web Resource: {0}", webResource.displayName);
}

It is not necessary to publish Web resources when they are created. It is necessary to publish them when they are updated.

See Also

Concepts

WebResource entity messages and methods
Web resources for Microsoft Dynamics CRM

Other Resources

Sample: Web resource utility

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Web resource utility

Manually creating Web resources one at a time using the customization tools can take a long time when you have to create many files. The Web Resource Utility is a WPF application project that you can compile and run to import many Web Resource eligible files from a folder structure with a consistent naming convention based on the folder structure.

The Web Resource Utility sample project is included with the downloadable files for the SDK at SDK\Tools\WebResourceUtility.

Requirements

For more information, see the Readme.docx file.

The solution must be built in Microsoft Visual Studio before running. Double-click the “WebResourceUtility.sln” to open the source code in Microsoft Visual Studio. Open and view the Solution Explorer.

This solution uses linked files and requires access to the following files also found in the SDK downloadable files in order to compile:

In the DataAccess folder:

  • sdk\samplecode\cs\helpercode\CrmServiceHelpers.cs
  • sdk\samplecode\cs\helpercode\deviceidmanager.cs
  • sdk\samplecode\cs\helpercode\myorganizationcrmsdktypes.cs
Note
You may need to manually update the links for these files before trying to build the solution or you may experience compilation errors.

This solution includes references to the following files:

  • sdk\bin\microsoft.crm.sdk.proxy.dll
  • sdk\bin\microsoft.xrm.sdk.dll

Demonstrates

In addition to creating and updating Web Resources, the Web Resource Utility code demonstrates several applications of the Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update APIs:

Managing connections

The Web Resource Utility preserves connections to multiple Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update servers so the user doesn’t need to enter connection information each time.

Retrieving data about solutions

The Web Resource Utility retrieves data about available unmanaged solutions and creates Web Resources using the customization prefix defined by the publisher of the solution.

Web Resource Utility

The following screenshot shows the Web Resource Utility user interface:

The Web Resource Utility user interface

See Also

Concepts

WebResource entity messages and methods
Web resources for Microsoft Dynamics CRM

Other Resources

Sample: Import files as web resources

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


JavaScript libraries for Microsoft Dynamics CRM

JavaScript libraries are Script (JScript) web resources that contain functions you can use to:

  • Handle form and field events.
  • Perform actions for controls configured in the Ribbon.
  • Support other functions.

Using JScript libraries

You can use JavaScript libraries much as you would use JavaScript libraries in any web application.

Associate functions with Form and Field events

You can associate up to 50 script web resources so that they will be loaded with an entity form.

After you add a library to the form, it’s available to all events in the form. For any event, you can decide which functions to be the event handlers. You can specify up to 50 functions as event handlers for any event.

Associate functions at run time

You can add functions to the OnChange attribute, form OnSave, and lookup control PreSearch events at run time by using Xrm.Page.data.entity attribute. addOnChange, the Xrm.Page.data.entity. addOnSave, and the lookup control addPreSearch methods. When these methods are used, the function is added at the bottom of the event handler pipeline and they receive the execution context as the first parameter. You can use the corresponding removeOnChange,removeOnSave and removePreSearch methods to remove functions added this way.

Execution context

Each event handler can be configured to accept an execution context object as the first parameter. The execution context includes functions that can be called to determine:

  • Depth: The relative order in which this handler is executed.
  • Event Source: A reference to the object that initiated the event.
    This capability is important when you’re creating a function that may respond to events from several different form or field events.
  • Shared Variables: This allows a function to set a variable as a key/value pair that can be accessed by other event handlers.

More information: Execution context (client-side reference)

In the handler properties dialog box, you can enter a comma-separated list of string values that will be passed to the function. This can be useful to allow the behavior of a function to be changed without requiring changes to the code.

Associate functions with command bar (Ribbon) commands

Each control in the command bar or Ribbon is associated with a <CommandUIDefinition> (RibbonDiffXml) that contains an <Actions> (RibbonDiffXml) element that contains one or more actions. <JavaScriptFunction> (RibbonDiffXml) is one of the available actions. The JavaScriptFunction element requires a reference to a library and a function in that library.

Develop and test scripts

You can edit scripts through the web resource form or from the Events tab where you configure form libraries and event handlers.

Or, you can use your favorite script editing tool and upload your changes to update your script web resource. You must publish the web resource after you make changes.

Creating script libraries

When you design functions that will be used in JScript libraries, your functions may be loaded into a form with other JScript libraries. If another library contains a function that has the same name as a function you provide, whichever function is loaded last is defined for the page. To avoid having your functions overwritten by functions in another library, you should make sure that your functions have unique names.

Two strategies that you can use to help make sure your functions have unique names are:

Unique function prefix

Define each of your functions using the standard syntax with a consistent name that includes a unique naming convention, as shown in the following example.

JScript Copy Code
function MyUniqueName_performMyAction()
{
// Code to perform your action.
}
Namespaced library names

Associate each of your functions with a JScript object to create a kind of namespace to use when you call your functions, as shown in the following example.

JScript Copy Code
//If the MyUniqueName namespace object isn’t defined, create it.
if (typeof (MyUniqueName) == "undefined")
 { MyUniqueName = {}; }
  // Create Namespace container for functions in this library;
  MyUniqueName.MyFunctions = {
   performMyAction: function(){
   // Code to perform your action.
   //Call another function in your library
   this.anotherAction();
  },
  anotherAction: function(){
   // Code in another function
  }
};
Then when you use your function you can specify the full name. The following example shows this.

JScript Copy Code
MyUniqueName.MyFunctions.performMyAction();
If you call a function within another function you can use the this keyword as a shortcut to the object that contains both functions. However, if your function is being used as an event handler, the this keyword will refer to the object that the event is occurring on.

Debugging Scripts

Each browser has their own set of developer tools. The following instructions describe using Internet Explorer.

Debug script in Microsoft Dynamics CRM forms

  1. Press F12 to open the developer tools.

  2. On the Script tab, to the right of the Start Debugging button, use the drop-down list to locate your JScript library.

  3. Set a breakpoint by clicking the left margin in your function.

  4. Click Start Debugging.

  5. If your script is in the Onload event, you may have to select the Microsoft Dynamics CRM window and press F5 to reload the window.

For more information, see Debugging Script with Developer Tools.

See Also

Concepts

Use JavaScript with Microsoft Dynamics CRM
Script (JScript) web resources
Write code for Microsoft Dynamics CRM forms
Customize entity forms
Define ribbon actions

Other Resources

Developers guide to customization for Microsoft Dynamics CRM
Write client application extensions
Sample: Import files as web resources
Sample: Web resource utility

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Client-side programming reference

This section contains reference documentation for client-side events and object models that can be used with JavaScript libraries.

Note
The client object model contains the Xrm.Internal namespace. Use of the objects within this namespace are not supported. These objects, and any parts of the HTML Document Object Model (DOM), are subject to change without notice. We recommend that you do not use these functions or any script that depends on the DOM.

In This Section

Form events (client-side reference)

Client-side context (client-side reference)

GetGlobalContext function and ClientGlobalContext.js.aspx (client-side reference)

Execution context (client-side reference)

Save event arguments (client-side reference)

Collections (client-side reference)

Xrm.Page.data (client-side reference)

Xrm.Page.data.entity (client-side reference)

Xrm.Page.data.entity attribute (client-side reference)

Xrm.Page.data.process (client-side reference)

Xrm.Page.ui control (client-side reference)

Xrm.Page.ui (client-side reference)

Xrm.Page.ui section (client-side reference)

Xrm.Page.ui tab (client-side reference)

Xrm.Page.ui.formSelector item (client-side reference)

Xrm.Page.ui.navigation item (client-side reference)

Xrm.Page.ui.process (client-side reference)

Xrm.Utility (client-side reference)

Related Sections

Form scripting quick reference

Use JavaScript with Microsoft Dynamics CRM

Use web service data in web resources (OData and Modern app SOAP endpoint)

Write code for Microsoft Dynamics CRM forms

Open forms, views, dialogs and reports with a URL

Web resources for Microsoft Dynamics CRM

JavaScript libraries for Microsoft Dynamics CRM

Write plug-ins to extend business processes

Write workflows to automate business processes

Developers guide to reports for Microsoft Dynamics CRM

Manage your data

Package and distribute extensions using solutions

Developers guide to customization for Microsoft Dynamics CRM

Extend Microsoft Dynamics CRM for Outlook

Integrate SharePoint with Microsoft Dynamics CRM

Advanced development

Sample code directory

Programming reference

Customize entity forms

Write client application extensions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Form events (client-side reference)

All client-side code is initiated by events. In Microsoft Dynamics CRM, you will associate a specific function within a JavaScript library to be executed when specific events occur.

All form events have a user interface you use to specify one or more event handers. Each event handler specifies a single function within a JavaScript library and any parameters that can be passed to the function.

Events

OnLoad Event

OnSave Event

Field OnChange Event

Tab TabStateChange Event

IFRAME OnReadyStateComplete Event

Lookup Control PreSearch Event

OnStageChange event

OnStageSelected event

OnLoad Event

The OnLoad event occurs after the form has loaded. It cannot prevent the window from loading. Use the OnLoad event to apply logic about how the form should be displayed, to set properties on fields, and interact with other page elements.

When the Microsoft Dynamics CRM for tablets client is disconnected, the OnLoad event is the only event that will occur.

Note
Forms for Updated entities don’t reload the page after the initial save creating a record or any subsequent saves. Therefore, the OnLoad event occurs only during the initial load of the form.

OnSave Event

The OnSave event occurs when:

  • The user clicks the Auto save button button in the lower right corner of the form, even when there is no changed data to be saved.
  • Code executes the Xrm.Page.data.entity. save method, even when there is no changed data to be saved.
  • The user navigates away from the form and there is unsaved data in the form.
  • With auto-save is enabled, 30 seconds after data has changed and there is unsaved data in the form.
  • Code executes the Xrm.Page.data. save method and there is unsaved data in the form.
  • Code executes the Xrm.Page.data. refresh method passing a true value as the first parameter and there is unsaved data in the form.

To determine which button was clicked to perform the save, use the getSaveMode method.

You can cancel the save action by using the preventDefault method within the event arguments object. The preventDefault method which is accessible by using the getEventArgs method that is part of the execution context. You must configure the form event handler to pass the execution context. For more information, see Use execution context and the form event pipeline.

Field OnChange Event

The OnChange event usually occurs when the data in a form field has changed and focus is lost.

Note
There is an exception to this behavior that applies to Two-Option (Boolean) fields that are formatted to use radio buttons or check boxes. In these cases the event occurs immediately.

This event also occurs when data changes on the server are retrieved to update a field when the form is refreshed, such as after a record is saved.

Using the Xrm.Page.data.entity attribute.fireOnChange method will also cause this event to occur.

The OnChange event does not occur if the field is changed programmatically using the setValue method. If you want event handlers for the OnChange event to run after you set the value you must use the Xrm.Page.data.entity attribute.fireOnChange method in your code.

All fields support the OnChange event. Data in the field is validated before and after the OnChange event.

Note
Although the Status field supports the OnChange event, the field is read-only on the form so the event cannot occur through user interaction. Another script could cause this event to occur by using the fireOnChange method on the field.

Tab TabStateChange Event

The TabStateChange event occurs when the DisplayState of the tab changes due to user interaction or when the setDisplayState method is applied in code. Use this event when you wish to change the src property of an IFRAME within the tab.

This event does not occur in CRM for tablets because tabs do not expand or collapse.

Note
If you set the IFrame. src property in the OnLoad event for an IFRAME within a collapsed tab, the value will be overwritten when the tab is expanded.

IFRAME OnReadyStateComplete Event

The OnReadyStateComplete event indicates that the content of the IFRAME has loaded and can be accessed in code. Use this event when referencing IFRAME controls within your scripts.

This event does not occur in CRM for tablets because IFRAMES are not supported.

Lookup Control PreSearch Event

The lookup control has a PreSearch event that occurs just before the control launches a dialog to search for records. There is no UI to set event handlers for this event. You must use the addPreSearch and removePreSearch methods on the lookup control to add or remove event handlers for this event.

Use this event with other Lookup Control Methods to change the results displayed in a lookup based on the form data current just before the lookup control shows search results for a user to choose from.

OnStageChange event

This event occurs when the stage of a business process flow control changes. This event occurs when the user clicks the Next Stage or Move to previous stage buttons in the user interface or when a developer uses the Xrm.Page.data.process.moveNext or Xrm.Page.data.process.movePrevious methods. You can’t cancel the stage change using code in a handler for this event.

An execution context object is passed to event handlers for this event. You can use the getEventArgs function to retrieve an object that has the following methods:

getDirection

Returns a string that is either “next” or “previous” to show the direction of the stage change.

getStage

Returns a stage object. Except when the navigation moves to a new entity, the stage returned represents the destination stage object,that is, the next active stage. When the navigation moves to a new entity, the stage is the stage being navigated from, that is, the previous active stage object. More information: Stage methods.

Use the Xrm.Page.data.process.addOnStageChange method to add event handlers for this event and the Xrm.Page.data.process.removeOnStageChange method to remove them. More information: Write scripts for business process flows.

OnStageSelected event

This event occurs when a stage of a business process flow control is selected. You can’t cancel the stage selection using code in a handler for this event.

An execution context object is passed to event handlers for this event. You can use the getEventArgs function to retrieve an object that has the following methods:

getStage

Returns a stage object representing the selected stage. More information: Stage methods.

Use the Xrm.Page.data.process.addOnStageSelected method to add event handlers for this event and the Xrm.Page.data.process.removeOnStageSelected method to remove them. More information: Write scripts for business process flows.

See Also

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model
Write scripts for business process flows

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Client-side context (client-side reference)

Your code will need to operate in a context where a number of variables are not known at design time. The context object provides methods to retrieve information specific to an organization, a user, or parameters passed to a page.

The context object is available in forms by referencing Xrm.Page.context.

For web resources executed outside of a form, use the GetGlobalContext function to retrieve a context object.

Context properties and methods

client

Provides access to the getClient and getClientState methods you can use to determine which client is being used and whether the client is connected to the server.

getClientUrl

Returns the base URL that was used to access the application.

getCurrentTheme

Returns a string representing the current Microsoft Office Outlook theme chosen by the user.

getIsAutoSaveEnabled

Returns whether Autosave is enabled for the organization.

getOrgLcid

Returns the language code identifier (LCID) value that represents the base language for the organization.

getOrgUniqueName

Returns the unique text value of the organization’s name.

getQueryStringParameters

Returns a dictionary object of key value pairs that represent the query string arguments that were passed to the page.

getUserId

Returns the GUID of the SystemUser.Id value for the current user.

getUserLcid

Returns the LCID value that represents the provisioned language that the user selected as their preferred language.

getUserName

Returns the name of the current user.

getUserRoles

Returns an array of strings that represent the GUID values of each of the security roles that the user is associated with or any teams that the user is associated with.

prependOrgName

Prepends the organization name to the specified path.

Removed methods

Removed methods are either obsolete or replaced with other methods. You should make sure these methods are not used in your scripts.

The getAuthenticationHeader and getServerUrl methods were deprecated with Microsoft Dynamics CRM 2011 and are no longer present in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

The isOutlookClient and isOutlookOnline methods were deprecated with Microsoft Dynamics CRM 2013 and are no longer present in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

client

Microsoft Dynamics CRM 2013 and Microsoft Dynamics CRM Online added the client object which contains the getClient and getClientState methods to get information about the client.

These methods are only available for Updated Entities.

getClient

Returns a value to indicate which client the script is executing in.

JScript Copy Code
context.client.getClient()

Use this instead of the removed isOutlookClient method.

Return Value

Type: String

The values returned are:

Client Value

Browser

Web

Outlook

Outlook

Mobile

Mobile

Remarks

This method is only available for Updated Entities.

getClientState

Use this instead of the removed isOutlookOnline method.

Returns a value to indicate the state of the client.

JScript Copy Code
context.client.getClientState()
Return Value

Type: String

The possible values returned are:

Client Values returned

Web, Outlook, Mobile

Online

Outlook, Mobile

Offline

Remarks

This method is only available for Updated Entities.

getClientUrl

Returns the base URL that was used to access the application.

JScript Copy Code
context.getClientUrl()

Use this instead of the removed getServerUrl method.

The values returned will resemble those listed in the following table.

Client | Value
Microsoft Dynamics CRM (on-premises) | http(s)://server/org
Microsoft Dynamics CRM Online | https://org.crm.dynamics.com
Microsoft Dynamics CRM for Outlook with Offline Access when offline | http://localhost:2525
Return Value

Type: String

getCurrentTheme

Returns a string representing the current Microsoft Office Outlook theme chosen by the user.

Note
This function doesn’t work with Microsoft Dynamics CRM for tablets.

JScript Copy Code
context.getCurrentTheme()
Return Value

Type: String

Use this information to select an appropriate theme for your HTML and Silverlight web resources when viewed in Microsoft Dynamics CRM for Microsoft Office Outlook. The following table lists the values that may be returned from this method.

Note
Forms don’t adapt to changes in the Microsoft Office theme, so the only case where you might want to adapt to the Microsoft Office themes is when you display a page in the navigation using an HTML web resource. Even in this scenario, visual differences may be difficult to detect.

Value | Theme
default | Microsoft Dynamics CRM web application
Office12Blue | Microsoft Dynamics CRM for Outlook 2007 or 2010 Blue Theme
Office14Silver | Microsoft Dynamics CRM for Outlook 2007 or 2010 Silver or Black Theme

getIsAutoSaveEnabled

This method is new for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update

Returns whether Autosave is enabled for the organization.

JScript Copy Code
context.getIsAutoSaveEnabled()
Return Value

Type: Boolean

Note
This function returns the value set at the time the page is opened. When testing code using this value, you must refresh the page after changing the value in order to get the new value.

More information: Manage auto-save.

getOrgLcid

Returns the LCID value that represents the base language for the organization.

JScript Copy Code
context.getOrgLcid()
Return Value

Type: Number

Example: 1033 indicates the English language. Valid locale ID values can be found at Locale ID (LCID) Chart.

JScript Copy Code
1033

getOrgUniqueName

Returns the unique text value of the organization’s name.

JScript Copy Code
context.getOrgUniqueName()
Return Value

Type: String

Example: This corresponds to the organization name value

JScript Copy Code
"adventureworkscycle"

getQueryStringParameters

Returns a dictionary object of key value pairs that represent the query string arguments that were passed to the page.

JScript Copy Code
context.getQueryStringParameters()
Return Value

Type: Object

getUserId

Returns the GUID of the SystemUser.Id value for the current user.

JScript Copy Code
context.getUserId()
Return Value

Type: String

Example:

JScript Copy Code
"{B05EC7CE-5D51-DF11-97E0-00155DB232D0}"

getUserLcid

Returns the LCID value that represents the Microsoft Dynamics CRM Language Pack that the user selected as their preferred language.

JScript Copy Code
context.getUserLcid()
Return Value

Type: Number

Example: 1041 indicates the Japanese language. Valid locale ID values can be found at Locale ID (LCID) Chart.

JScript Copy Code
1041

getUserName

Returns the name of the current user.

JScript Copy Code
context.getUserName()
Return Value

Type: String

Remarks

This method is only available for Updated Entities.

getUserRoles

Returns an array of strings that represent the GUID values of each of the security roles that the user is associated with or any teams that the user is associated with.

For more information about security roles, see How role-based security can be used to control access to entities in Microsoft Dynamics CRM.

JScript Copy Code
context.getUserRoles()
Return Value

Type: Array

Example: This user has only one security role associated with their user account. The JSON representation of this array with a single value is:

JScript Copy Code
["cf4cc7ce-5d51-df11-97e0-00155db232d0"]

prependOrgName

Prepends the organization name to the specified path.

JScript Copy Code
context.prependOrgName(sPath)
Arguments

Type: String

A local path to a resource.

Return Value

Type: String

The value returned follows this pattern:

Copy Code
"/"+ OrgName + sPath

Removed methods

Removed methods are either obsolete or replaced with other methods. You should make sure these methods aren’t used in your scripts.

The following methods were deprecated with earlier versions of Microsoft Dynamics CRM and are no longer present in the current version:

getAuthenticationHeader

This method supported use of the Microsoft Dynamics CRM 4.0 web services, which no longer exist.

getServerUrl

This method was replaced by getClientUrl.

isOutlookClient

This method was replaced by client.getClient

isOutlookOnline

This method was replaced by client.getClientState

See Also

Reference

GetGlobalContext function and ClientGlobalContext.js.aspx (client-side reference)

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetGlobalContext function and ClientGlobalContext.js.aspx (client-side reference)

Use the GetGlobalContext function when programming with web resources to gain access to context information. To get the GetGlobalContext function in your HTML web resource, include a reference to ClientGlobalContext.js.aspx.

GetGlobalContext function

The GetGlobalContext function returns the same context object found in the Xrm.Page.context.

When you need context information outside a form, include a reference to the ClientGlobalContext.js.aspx page in an HTML web resource.

The following example shows a function designed to return a context object when used in either a form script or a script used with an HTML web resource.

JavaScript Copy Code
  function _getContext() {
   var errorMessage = "Context is not available.";
   if (typeof GetGlobalContext != "undefined")
   { return GetGlobalContext(); }
   else
   {
    if (typeof Xrm != "undefined") {
     return Xrm.Page.context;
    }
    else { throw new Error(errorMessage); }
   }
  }

ClientGlobalContext.js.aspx

You can use the GetGlobalContext function when you include a reference to the ClientGlobalContext.js.aspx page located at the root of the web resources directory.

Note
If you are not using backslash characters in HTML web resource names to simulate a folder structure, you can include this script in your page using this script element: <script type="text/javascript" src="ClientGlobalContext.js.aspx"></script>

If you are using backslash characters in HTML web resource names to simulate a directory structure, you must reflect this in your script element. The following example is for an HTML web resource named ‘sdk_/Contoso.htm’ and a JScript web resource named ‘sdk_/Scripts/ContosoScript.js’ with a CSS web resource named ‘sdk_/Styles/ContosoStyles.css’.

Html Copy Code
<head>
    <title>HTML Web Resource</title>
    <script src="../ClientGlobalContext.js.aspx" type="text/javascript" ></script>

    <script src="Scripts/ContosoScript.js" type="text/javascript"></script>
    <link href="Styles/ContosoStyles.css" rel="stylesheet" type="text/css" />
</head>
Note
Using a relative path including the root WebResources folder, for example, /WebResources/ClientGlobalContext.js.aspx, is not recommended because it can cause the page to lose organization context in a multi-tenant environment.

The ClientGlobalContext.js.aspx page will include some global event handlers. These event handlers will cancel the onselectstart, contextmenu, and ondragstart events.

See Also

Reference

Client-side context (client-side reference)
Execution context (client-side reference)

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Execution context (client-side reference)

The execution context is an optional parameter that can be passed to a JavaScript library function through an event handler. This option is presented in the handler properties dialog when you specify the name of the function. This option is set for a <Handler> (FormXml) element using the passExecutionContext attribute.

Execution context is automatically passed to functions set using the Xrm.Page.data.entity.addOnSave and Xrm.Page.data.entityAttribute.addOnChange, and Xrm.Page.uiControl.addPreSearch methods.

Execution context methods

getContext

Method that returns the Client-side context (client-side reference) object.

getDepth

Method that returns a value that indicates the order in which this handler is executed.

getEventArgs

Method that returns an object with methods to manage the Save event.

getEventSource

Method that returns a reference to the object that the event occurred on.

Shared variables

Shared variables allow sharing of a variable with other handlers for the same event. You use the setSharedVariable and getSharedVariable methods to work with shared variables.

getContext

Method that returns the Client-side context (client-side reference) object

JScript Copy Code
ExecutionContextObj.getContext()
Return Value

Type: Object

getDepth

Method that returns a value that indicates the order in which this handler is executed.

Return Value

Type: Number

The order begins with 0.

getEventArgs

Method that returns an object with methods to manage the Save event.

Note
This method returns null for any event other than the Save event.

JScript Copy Code
ExecutionContextObj.getEventArgs()
Return Value

Type: Object

More information: Save event arguments (client-side reference).

getEventSource

Method that returns a reference to the object that the event occurred on.

JScript Copy Code
ExecutionContextObj.getEventSource()
Return Value

Type: Object

This method returns the object from the Xrm.Page object model that is the source of the event, not an HTML DOM object. For example, in an OnChange event, this method returns the Xrm.Page.data.entity attribute object that represents the changed attribute.

Shared variables

Shared variables allow sharing of a variable with other handlers for the same event. You use the setSharedVariable and getSharedVariable methods to pass variables between functions.

setSharedVariable

Sets the value of a variable to be used by a handler after the current handler completes.

JScript Copy Code
ExecutionContextObj.setSharedVariable(key, value)
Arguments

String: The name of the variable

Object: The value to set.

getSharedVariable

Retrieves a variable set using setSharedVariable.

JScript Copy Code
ExecutionContextObj.getSharedVariable(key)
Arguments

String: The name of the variable.

Return Value

Type: Object

The specific type depends on what the value object is.

See Also

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Save event arguments (client-side reference)

In the save event you can use the execution context object getEventArgs method to retrieve an object that contains methods you can use to manage the save event.

Save Event Argument Methods

getSaveMode

Returns a value indicating how the save event was initiated by the user.

isDefaultPrevented

Returns a value indicating whether the save event has been canceled because the preventDefault method was used in this event hander or a previous event handler.

preventDefault

Cancels the save operation, but all remaining handlers for the event will still be executed.

getSaveMode

Returns a value indicating how the save event was initiated by the user.

JScript Copy Code
execObj.getEventArgs().getSaveMode()
Return Value

Type: Number

The following table describes the supported values returned to detect different ways entity records may be saved by the user.

Entity Event Mode Value

All

Save

1

All

Save and Close

2

All

Save and New

59

All

AutoSave

70

Activities

Save as Completed

58

All

Deactivate

5

All

Reactivate

6

User or Team owned entities

Assign

47

Email (E-mail)

Send

7

Lead

Qualify

16

Lead

Disqualify

15

Remarks

This method is essential if you want to enable auto-save for most forms in an organization but disable it for specific forms. The following code registered for the onSave event with the execution context passed to it will prevent any saves that initiate from an auto-save but allow all others. With auto-save enabled, navigating away is equivalent to Save and Close. This code will prevent any saves that are initiated by the 30 second timer or when people navigate away from a form with unsaved data.

JavaScript Copy Code
function preventAutoSave(econtext) {
    var eventArgs = econtext.getEventArgs();
    if (eventArgs.getSaveMode() == 70 || eventArgs.getSaveMode() == 2) {
        eventArgs.preventDefault();
    }
}
To save a record the user must click the Save Auto save button icon at the bottom of the form or a custom Save command needs to be added to the command bar.

isDefaultPrevented

Returns a value indicating whether the save event has been canceled because the preventDefault method was used in this event hander or a previous event handler.

JScript Copy Code
execObj.getEventArgs().isDefaultPrevented()
Return Value

Type: Boolean

preventDefault

Cancels the save operation, but all remaining handlers for the event will still be executed.

JScript Copy Code
execObj.getEventArgs().preventDefault()

See Also

Reference

Collections (client-side reference)
Execution context (client-side reference)
getEventArgs

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Collections (client-side reference)

Collections are structures to provide access to data that represents an array, but without the ability to modify the data in the array.

The following list shows the collections that are available in the Xrm.Page object model:

  • Xrm.Page.data.entity. attributes: All the attributes on the page.
  • Xrm.Page.ui. controls: All the controls on the page.
  • Xrm.Page.ui. tabs: All the tabs on the page.
  • Xrm.Page.ui Tab. sections: All the sections in the tab.
  • Xrm.Page.ui Section. controls: All the controls in the section.
  • Xrm.Page.ui. navigation.items: All the items in the form navigation area.
  • Xrm.Page.ui. formSelector.items: All the forms available to the user.
  • Xrm.Page Attribute. controls: All the controls for the attribute.
  • Xrm.Page.data.process. getActivePath: The stages in the current active path based on branching rules.
  • The process getStages method for a process returned by Xrm.Page.data.process. getActiveProcess.
  • The stage getSteps method for stages returned by Xrm.Page.data.process. getActiveStage, Xrm.Page.data.process. getActivePath and Xrm.Page.data.process. getActiveProcess.
Note
The objects returned in the Xrm.Page.data.process namespace don’t contain names, so using the string parameter for the get method returns no objects.

Collection methods

forEach

Apply an action in a delegate function to each object in the collection.

get

Get one or more objects from the collection depending on the arguments passed.

getLength

Get the number of items in the collection.

forEach

Applies the action contained in a delegate function.

JavaScript Copy Code
collection.forEach(delegate function(attribute, index))
Arguments

Delegate function with parameters for attribute and index.

get

Get one or more objects from the collection depending on the arguments passed.

JavaScript Copy Code
collection.get([String][Number][delegate function(attribute, index)])
Note
The get method for the Xrm.Page.data.entity.attributes collection is available using the Xrm.Page.getAttribute shortcut method.

The get method for the Xrm.Page.ui.controls collection is available using the Xrm.Page.getControl shortcut method.

Arguments

None

Return Value All the objects in the collection.

Type: Array

String

Return Value The object where the name matches the argument.

Type: Object

Remarks: The objects returned in the Xrm.Page.data.process namespace don’t contain names, so using the string parameter for this method returns no objects.

Number

Return Value The object where the index matches the number

Type: Object

delegate function(attribute, index)

Return Value Any objects that cause the delegate function to return true.

Type: Array

getLength

Get the number of items in the collection.

JavaScript Copy Code
collection.getLength()
Return Value

Type: Number

See Also

Reference

Xrm.Page.data.entity (client-side reference)
Xrm.Page.ui (client-side reference)
Xrm.Page.ui tab (client-side reference)
Xrm.Page.ui section (client-side reference)
Xrm.Page.data.entity attribute (client-side reference)

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.data (client-side reference)

Xrm.Page.data provides methods to work with the form. You can refresh the data in the form and save the form asynchronously.

Xrm.Page.data properties and methods

refresh

Asynchronously refreshes and optionally saves all the data of the form without reloading the page.

save

Saves the record asynchronously with the option to set callback functions to be executed after the save operation is completed.

refresh

Asynchronously refreshes and optionally saves all the data of the form without reloading the page.

JScript Copy Code
Xrm.Page.data.refresh(save).then(successCallback, errorCallback);
Parameters

save

A Boolean value to indicate if data should be saved after it is refreshed.

successCallback

A function to call when the operation succeeds.

errorCallback

A function to call when the operation fails.

The errorCallback will be passed an object with the following properties:

errorCode

Type: Number. The error code.

message

Type: String. A localized error message.

Remarks

This method is only available for Updated Entities.

save

Saves the record asynchronously with the option to set callback functions to be executed after the save operation is completed.

JScript Copy Code
Xrm.Page.data.save().then(successCallback, errorCallback)
Parameters

The successCallback and errorCallback functions are executed depending on whether an error is returned.

The successCallback will not have any arguments passed to it. It will simply be called if the operation succeeds.

The errorCallback will be passed an object with the following properties:

errorCode

Type: Number. The error code.

message

Type: String. A localized error message.

Remarks

This method is only available for Updated Entities.

See Also

Reference

Xrm.Page.data.entity (client-side reference)
Xrm.Page.data.entity attribute (client-side reference)

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.data.entity (client-side reference)

Xrm.Page.data.entity provides methods to retrieve information specific to the record displayed on the page, the save method, and a collection of all the attributes included in the form. Attribute data is limited to attributes represented by fields on the form.

Xrm.Page.data.entity Properties and Methods

attributes

The collection of attributes for the entity.

getDataXml

Returns a string representing the xml that will be sent to the server when the record is saved.

getEntityName

Returns a string representing the logical name of the entity for the record.

getId

Returns a string representing the GUID id value for the record.

getIsDirty

Returns a Boolean value that indicates if any fields in the form have been modified.

OnSave

Use the addOnSave and removeOnSave methods to add or remove event handlers to the save event

getPrimaryAttributeValue

Gets a string for the value of the primary attribute of the entity.

save

Saves the record with the options to close the form or open a new form after the save is completed.

attributes

The Xrm.Page.data.entity.attributes collection provides methods to access the data for a record displayed on the form. For more information about this collection, see Collections (client-side reference). See Xrm.Page.data.entity attribute (client-side reference) for properties and methods available to objects in this collection.

getDataXml

Returns a string representing the XML that will be sent to the server when the record is saved. Only data in fields that have changed are set to the server.

Note
This function does not work with Microsoft Dynamics CRM for tablets.

JScript Copy Code
Xrm.Page.data.entity.getDataXml()
Return Value

Type: String

Example:In this example, the following three fields for an account record were updated:

  • name
  • accountnumber
  • telephone2
JScript Copy Code
"<account><name>Contoso</name><accountnumber>55555</accountnumber><telephone2>425 555-1234</telephone2></account>"

getEntityName

Returns a string representing the logical name of the entity for the record.

JScript Copy Code
Xrm.Page.data.entity.getEntityName()
Return Value

Type: String. The name of the entity.

Example: In this example, an account record was being edited.

JScript Copy Code
"account"

getId

Returns a string representing the GUID id value for the record.

JScript Copy Code
Xrm.Page.data.entity.getId()
Return Value

Type: String

Example: The GUID Id value for the record.

JScript Copy Code
"{825CB223-A651-DF11-AA8B-00155DBA3804}"

getIsDirty

Returns a Boolean value that indicates if any fields in the form have been modified.

JScript Copy Code
Xrm.Page.data.entity.getIsDirty()
Return Value

Type: Boolean

OnSave

Use the addOnSave and removeOnSave methods to add or remove event handlers to the save event

addOnSave

Adds a function to be called when the record is saved.

JScript Copy Code
Xrm.Page.data.entity.addOnSave([function reference])
Parameter

Type: function reference

Remarks: The function will be added to the bottom of the event handler pipeline. The execution context is automatically set to be passed as the first parameter passed to event handlers set using this method. See Execution context (client-side reference) for more information.

Example: In this example, the JavaScript library contains two functions. Adding the addMessageToOnSave function to the form OnLoad event will add the displayOrgName function as a handler for the OnSave event.

JavaScript Copy Code
function displayOrgName(execContext)
{
    try {
        alert(execContext.getContext().getOrgUniqueName());
    }
    catch (e) {
        alert(e.message);
    }
}

function addMessageToOnSave() {
    Xrm.Page.data.entity.addOnSave(displayOrgName);
}

removeOnSave

Removes a function to be called when the record is saved.

JScript Copy Code
Xrm.Page.data.entity.removeOnSave([function reference])
Parameter

Type: function reference

Example: In this example, the JavaScript library contains two functions. Adding the removeMessageFromOnSave function to a form event will remove the displayOrgName function as a handler for the OnSave event.

Copy Code
function displayOrgName(execContext)
{
    try {
        alert(execContext.getContext().getOrgUniqueName());
    }
    catch (e) {
        alert(e.message);
    }
}

function removeMessageFromOnSave() {
    Xrm.Page.data.entity.removeOnSave(displayOrgName);
}

getPrimaryAttributeValue

Gets a string for the value of the primary attribute of the entity.

JScript Copy Code
Xrm.Page.data.entity.getPrimaryAttributeValue()

Each entity has one string attribute that is designated as the PrimaryNameAttribute. The value for this attribute is used when links to the record are displayed.

Return Value

Type: String. The value of the primary attribute of the entity.

Remarks

This method is only available for Updated Entities.

save

Saves the record synchronously with the options to close the form or open a new form after the save is completed.

Both Xrm.Page.data.save and Xrm.Page.data.entity.save will save the record, but Xrm.Page.data.save provides callback functions after the save operation completes.

JScript Copy Code
Xrm.Page.data.entity.save( null | "saveandclose" |"saveandnew" )
Arguments

save()

If no parameter is included the record will simply be saved. This is the equivalent of using the Save command.

save("saveandclose")

This is the equivalent of using the Save and Close command.

save("saveandnew")

This is the equivalent of the using the Save and New command.

Remarks

When using quick create forms in the web application the saveandnew option is not applied. It will always work as if saveandclose were used. Quick create forms in Microsoft Dynamics CRM for tablets will apply the saveandnew behavior.

See Also

Reference

Xrm.Page.data.entity attribute (client-side reference)

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.data.entity attribute (client-side reference)

Attributes contain the data in the form. Use the Xrm.Page.data.entity.attributes collection or the Xrm.Page.getAttribute shortcut method to access a collection of attributes. For more information see Collections (client-side reference).

Attribute Properties and Methods

Boolean and OptionSet Attribute methods

The getInitialValue, getOption, getOptions, getSelectedOption, and getText methods provide ways to get information about Boolean or OptionSet attributes.

controls

Access controls associated with attributes.

getAttributeType

Get the type of attribute.

getFormat

Get the attribute format.

getIsDirty

Determine whether the value of an attribute has changed since it was last saved.

getIsPartyList

Determine whether a lookup attribute represents a partylist lookup.

getMaxLength

Get the maximum length of string which an attribute that stores string data can have.

getName

Get the name of the attribute.

getParent

Get a reference to the Xrm.Page.data.entity object that is the parent to all attributes.

getUserPrivilege

Determine what privileges a user has for fields using Field Level Security.

Number Attribute methods

Use the getMax, getMin, and getPrecision methods to access information about the properties of number attributes.

OnChange Event

Use the addOnChange, removeOnChange, and fireOnChange methods and to manage event handlers for the OnChange event.

RequiredLevel

Use the setRequiredLevel and getRequiredLevel methods to control whether an attribute must have a value in order to save a record.

SubmitMode

Use the setSubmitMode and getSubmitMode methods to control whether the value of an attribute will be submitted when a record is saved.

Value

Use the getValue and setValue methods to determine the values set for an attribute and change the value.

Boolean and OptionSet Attribute methods

The getInitialValue, getOption, getOptions, getSelectedOption, and getText methods provide ways to get information about Boolean or OptionSet attributes.

getInitialValue

Returns a value that represents the value set for an optionset or Boolean attribute when the form opened.

Attribute Types: Optionset and Boolean

JScript Copy Code
Xrm.Page.getAttribute(arg).getInitialValue()
Return Value

Type: Number. The initial value for the attribute.

getOption

Returns an option object with the value matching the argument passed to the method.

Attribute Types: optionset

JScript Copy Code
Xrm.Page.getAttribute(arg).getOption(value)
Arguments

String or Number value

Return Value

Type: Option object with text and value properties.

getOptions

Returns an array of option objects representing the valid options for an optionset attribute.

Attribute Types: optionset

JScript Copy Code
Xrm.Page.getAttribute(arg).getOptions()
Return Value

Type: Array of option objects.

getSelectedOption

Returns the option object that is selected in an optionset attribute.

Attribute Types: optionset

JScript Copy Code
Xrm.Page.getAttribute(arg).getSelectedOption()
Return Value

Type: Option object with text and value properties.

getText

Returns a string value of the text for the currently selected option for an optionset attribute.

Attribute Types: optionset

JScript Copy Code
Xrm.Page.getAttribute(arg).getText()
Return Value

Type: String. The text value of the selected option.

Note
When no option is selected, getText will return an empty string value.

controls

See Collections (client-side reference) to learn about the methods exposed by collections.

Because each attribute may be represented more than one time on the page, the controls collection provides access to all controls representing that attribute. If the attribute is represented by only one field in the page, the length of this collection will be 1. When you use the control getName method the name of the first control will be the same as the name of the attribute. The second instance of a control for that attribute will be ‘<attributeName>1’. The pattern <attributeName>+N will continue for each additional control added to the form for a specific attribute.

When a form displays a business process flow control in the header, additional controls will be added for each attribute that is displayed in the business process flow. These controls have a unique name like the following: header_process_<attribute name>.

When performing actions on controls that are tied to an attribute you should always consider that the control may be included on the page more than once and you should generally perform the same actions for each control for the attribute. You can do this by looping through the attribute controls collection and perform the actions on each control.

The following sample represents a JavaScript library with two reusable functions that use the attribute controls collection to hide and show controls:

  • SDK.Sample.hideAllAttributeControls: Hides all controls for the attribute.
  • SDK.Sample.showAllAttributeControls: Shows all controls for the attribute.
JavaScript Copy Code
if (typeof (SDK) == "undefined")
{SDK = { __namespace: true }; }
SDK.Sample = { __namespace: true };
SDK.Sample.hideAllAttributeControls = function (attributeLogicalName) {
    /// <summary>
    /// Hides all controls for the attribute.
    /// </summary>
    /// <param name="attributeLogicalName" type="String" mayBeNull="false" optional="false" >
    /// The logical name of an attribute.
    /// </param>
    if ((typeof attributeLogicalName != "string") ||
        (attributeLogicalName.length <= 3))
    { throw new Error("SDK.Sample.hideAllAttributeControls attributeLogicalName parameter must be a string at least 4 characters long."); }
    Xrm.Page.getAttribute(attributeLogicalName).controls.forEach(
        function (control, i) {
            control.setVisible(false);
            }
        );
}
SDK.Sample.showAllAttributeControls = function (attributeLogicalName) {
    /// <summary>
    /// Shows all controls for the attribute.
    /// </summary>
    /// <param name="attributeLogicalName" type="String" mayBeNull="false" optional="false" >
    /// The logical name of an attribute.
    /// </param>
    if ((typeof attributeLogicalName != "string") ||
        (attributeLogicalName.length <= 3))
    { throw new Error("SDK.Sample.showAllAttributeControls attributeLogicalName parameter must be a string at least 4 characters long."); }
    Xrm.Page.getAttribute(attributeLogicalName).controls.forEach(
        function (control, i) {
            control.setVisible(true);
            }
        );
}

To use these functions, pass the logical name of the attribute as shown here:

JavaScript Copy Code
//Hide the controls for the subject attribute.
SDK.Sample.hideAllAttributeControls("subject");
//Show the controls for the subject attribute.
SDK.Sample.showAllAttributeControls("subject");

getAttributeType

Returns a string value that represents the type of attribute.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).getAttributeType()
Return Value

Type: String

This method will return one of the following string values:

  • boolean
  • datetime
  • decimal
  • double
  • integer
  • lookup
  • memo
  • money
  • optionset
  • string

getFormat

Returns a string value that represents formatting options for the attribute.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).getFormat()
Return Value

Type: String

This method will return one of the following string values or null:

  • date
  • datetime
  • duration
  • email
  • language
  • none
  • phone
  • text
  • textarea
  • tickersymbol
  • timezone
  • url
Note
This format information generally represents the format options of the application field. Format options for Boolean fields are not provided.

The following table lists the format string values to expect for each type of attribute schema type and format option.

Application Field Type | Format Option | Attribute Type | Format Value
Date and Time | Date Only | datetime | date
Date and Time | Date and Time | datetime | datetime
Whole Number | Duration | integer | duration
Single Line of Text | E-mail | string | email
Whole Number | Language | optionset | language
Whole Number | None | integer | none
Single Line of Text | Text Area | string | textarea
Single Line of Text | Text | string | text
Single Line of Text | Ticker Symbol | string | tickersymbol
Single Line of Text | Phone | string | phone
Whole Number | Time Zone | optionset | timezone
Single Line of Text | Url | string | url

getIsDirty

Returns a Boolean value indicating if there are unsaved changes to the attribute value.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).getIsDirty()
Return Value

Type: Boolean. True if there are unsaved changes, otherwise false.

getIsPartyList

Returns a Boolean value indicating whether the lookup represents a partylist lookup. Partylist lookups allow for multiple records to be set, such as the To: field for an email entity record.

Attribute Types: lookup

JScript Copy Code
Xrm.Page.getAttribute(arg).getIsPartyList()
Return Value

Type: Boolean. True if the lookup attribute is a partylist, otherwise false.

Remarks

This method is only available for Updated Entities.

getMaxLength

Returns a number indicating the maximum length of a string or memo attribute.

Attribute Types: string, memo

JScript Copy Code
Xrm.Page.getAttribute(arg).getMaxLength()
Return Value

Type: Number. The maximum allowed length of a string for this attribute.

Note
The email form description attribute is a memo attribute, but it does not have a getMaxLength method.

getName

Returns a string representing the logical name of the attribute.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).getName()
Return Value

Type: String. The logical name of the attribute.

getParent

Returns the Xrm.Page.data.entity object that is the parent to all attributes.

This function exists to provide a consistent interface with other objects. In this case, because every attribute returns the same object, there are not many situations where it is useful.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).getParent()
Return Value

Type:Xrm.Page.data.entity object.

getUserPrivilege

Returns an object with three Boolean properties corresponding to privileges indicating if the user can create, read or update data values for an attribute. This function is intended for use when Field Level Security modifies a user’s privileges for a particular attribute. For more information, see How field security can be used to control access to field values in Microsoft Dynamics CRM.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).getUserPrivilege()
Return Value

Type:Object

The object has three Boolean properties:

  • canRead
  • canUpdate
  • canCreate

Number Attribute methods

Use the getMax, getMin, and getPrecision methods to access information about the properties of number attributes.

getMax

Returns a number indicating the maximum allowed value for an attribute.

Attribute Types: money, decimal, integer, double

JScript Copy Code
Xrm.Page.getAttribute(arg).getMax()
Return Value

Type: Number. The maximum allowed value for the attribute.

getMin

Returns a number indicating the minimum allowed value for an attribute.

Attribute Types: money, decimal, integer, double

JScript Copy Code
Xrm.Page.getAttribute(arg).getMin()
Return Value

Type: Number. The minimum allowed value for the attribute.

getPrecision

Returns the number of digits allowed to the right of the decimal point.

Attribute Types: money, decimal, double, and integer

JScript Copy Code
Xrm.Page.getAttribute(arg).getPrecision()
Return Value

Type: Number. The number of digits allowed to the right of the decimal point.

OnChange Event

There are three methods you can use to work with the OnChange event for an attribute:

  • addOnChange
  • removeOnChange
  • fireOnChange

addOnChange

Sets a function to be called when the attribute value is changed.

JScript Copy Code
Xrm.Page.getAttribute(arg).addOnChange([function reference])
Parameter

Type: function pointer

Remarks: The function will be added to the bottom of the event handler pipeline. The execution context is automatically set to be the first parameter passed to the event handler. See Execution context (client-side reference) for more information.

Example:In this example, the JScript library contains two functions. Adding the addMessageToOnChange function to the form OnLoad event will add the displayMessage function as a handler for the OnChange event for the first attribute in the form.

JScript Copy Code
function addMessageToOnChange()
{
   Xrm.Page.data.entity.attributes.get(0).addOnChange(displayOrgName);
}
function displayOrgName(execContext)
{
   Xrm.Utility.alertDialog(execContext.getContext().getOrgUniqueName());
}

removeOnChange

Removes a function from the OnChange event hander for an attribute.

JScript Copy Code
Xrm.Page.getAttribute(arg).removeOnChange([function reference])
Parameter

Type: function reference

Example: In this example, the JScript library contains two functions. Adding the removeMessageFromOnChange function to another form event will remove the displayOrgName function as a handler for the OnChange event for the first attribute on the form.

JScript Copy Code
function removeMessageFromOnChange()
{
   Xrm.Page.data.entity.attributes.get(0).removeOnChange(displayOrgName);
}
function displayOrgName(execContext)
{
   Xrm.Utility.alertDialog(execContext.getContext().getOrgUniqueName());
}

fireOnChange

Causes the OnChange event to occur on the attribute so that any script associated to that event can execute.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).fireOnChange()

RequiredLevel

You can control whether the application will require that a field contain data before a record can be saved. Use the getRequiredLevel and setRequiredLevel methods to adjust this requirement.

getRequiredLevel

Returns a string value indicating whether a value for the attribute is required or recommended.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).getRequiredLevel()
Return Value

Type: String

Returns one of the three possible values:

  • none
  • required
  • recommended

setRequiredLevel

Sets whether data is required or recommended for the attribute before the record can be saved.

Important
Reducing the required level of an attribute can cause an error when the page is saved. If the attribute is required by the server an error will occur if the there is no value for the attribute.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).setRequiredLevel(requirementLevel)
Arguments

Type: String

One of the following values:

  • none
  • required
  • recommended

SubmitMode

You can control when data for an attribute is submitted when a record is created or saved. For example, you may have a field on the form which is only intended to control logic in the form. You are not interested in capturing the data in it. You might set it so that the data is not saved. Or you may have a Plugin registered that depends on the value always being included. You may want to set the attribute so that it will always be included. Attributes that do not get updated after the initial save of the record, such as createdby, are set so that they will not be submitted on save. To force an attribute value to be submitted whether it has changed or not, use the setSubmitMode function with the mode parameter set to “always”.

When using setSubmitMode you have three options:

  • always: The value is always submitted.
  • never: The value is never submitted. When this option is set, data cannot be edited for any fields in the form for this attribute.
  • dirty (default): The value is submitted on create if it is not null, and on save only when it is changed.

Use getSubmitMode to determine the current setting.

getSubmitMode

Returns a string indicating when data from the attribute will be submitted when the record is saved.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).getSubmitMode()
Return Value

Type: String

Returns one of the three possible values:

  • always
  • never
  • dirty
The default value for editable fields is ‘dirty’, which means that the value will be submitted to the server only when that data value is changed.

setSubmitMode

Sets whether data from the attribute will be submitted when the record is saved.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).setSubmitMode()
Arguments

Type: String

One of the following values:

  • always: The data is always sent with a save.
  • never: The data is never sent with a save. When this is used the field(s) in the form for this attribute cannot be edited.
  • dirty: Default behavior. The data is sent with the save when it has changed.

Value

Accessing or setting the value of attributes are the most commonly performed actions in form scripts.

getValue

Retrieves the data value for an attribute.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).getValue()
Return Value

Type: Depends on type of attribute.

Attribute Type Return Type

boolean

Boolean

datetime

Date

To get the string version of a date using the Microsoft Dynamics CRM user’s locale preferences, use the format and localeFormat methods. Other methods will format dates using the operating system locale rather than the user’s Microsoft Dynamics CRM locale preferences.

decimal

Number

double

Number

integer

Number

lookup

Array

An array of lookup objects.

Note
Certain lookups allow for multiple records to be associated in a lookup, such as the To: field for an email entity record. Therefore, all lookup data values use an array of lookup objects – even when the lookup attribute does not support more than one record reference to be added.

Each lookup has the following properties:

entityType

String: the name of the entity displayed in the lookup

id

String: The string representation of the GUID value for the record displayed in the lookup.

name

String: The text representing the record to be displayed in the lookup.

memo

String

money

Number

optionset

Number

string

String

setValue

Sets the data value for an attribute.

Attribute Types: All

JScript Copy Code
Xrm.Page.getAttribute(arg).setValue()
Arguments

Depends on the type of attribute.

Attribute Type Argument Type

boolean

Boolean

datetime

Date

decimal

Number

double

Number

integer

Number

lookup

Array

An array of lookup objects.

Note
Certain lookups, known as ‘partylist’ lookups, allow for multiple records to be associated in a lookup, such as the To: field for an email entity record. Therefore, all lookup data values use an array of lookup objects – even when the lookup attribute does not support more than one record reference to be added.

Each lookup value has the following properties:

entityType

String: the logical name of the entity represented by the lookup.

id

String: The string representation of the GUID value for the record displayed in the lookup. The value should match the following format: {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}.

name

String: The text representing the record to be displayed in the lookup. Typically the primary attribute for the entity.

See Set Lookup Attribute Value for an example of a helper function you can create to set simple lookup attribute values.

memo

String

money

Number

optionset

Number

Note
The getOptions method returns option values as strings. You must use parseInt to convert them to numbers before you can use those values to set the value of an optionset attribute.

Valid statuscode (Status Reason) options depend on the current statecode of the record. The statecode (Status) field cannot be set in form scripts. To understand which statecode values are valid, refer to the metadata for the attributes. See Default status and status reason values for a list of default values for system entities. For custom entities use the Entity Metadata browser described in Browse the metadata for your organization. Finally, also consider any custom state transitions that have been applied to the field. More information: Define status reason transitions.

string

String

Note
A String field with the email format requires that the string represents a valid email address.

Note
  • Updating an attribute using setValue will not cause the OnChange event handlers to run. If you want the OnChange event handlers to run you must use fireOnChange in addition to setValue.
  • When Microsoft Dynamics CRM for tablets is not connected to the server setValue will not work.
  • You cannot set the value of composite attributes. More information: Write scripts for composite attributes.

Set Lookup Attribute Value

The following example shows the definition of a setSimpleLookupValue helper function that sets the value for simple lookup attributes.

JScript Copy Code
function setSimpleLookupValue(LookupId, Type, Id, Name) {
   /// <summary>
   /// Sets the value for lookup attributes that accept only a single entity reference.
   /// Use of this function to set lookups that allow for multiple references,
   /// a.k.a 'partylist' lookups, will remove any other existing references and
   /// replace it with just the single reference specified.
   /// </summary>
   /// <param name="LookupId" type="String" mayBeNull="false" optional="false" >
   /// The lookup attribute logical name
   /// </param>
   /// <param name="Type" type="String" mayBeNull="false" optional="false" >
   /// The logical name of the entity being set.
   /// </param>
   /// <param name="Id" type="String" mayBeNull="false" optional="false" >
   /// A string representation of the GUID value for the record being set.
   /// The expected format is "{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}".
   /// </param>
   /// <param name="Name" type="String" mayBeNull="false" optional="false" >
   /// The text to be displayed in the lookup.
   /// </param>
   var lookupReference = [];
   lookupReference[0] = {};
   lookupReference[0].id = Id;
   lookupReference[0].entityType = Type;
   lookupReference[0].name = Name;
   Xrm.Page.getAttribute(LookupId).setValue(lookupReference);
  }

The following is an example using the setSimpleLookupValue function to set the primarycontactid attribute value on an account form:

C# Copy Code
setSimpleLookupValue("primarycontactid", "contact", "{6D9D4FCF-F4D3-E011-9D26-00155DBA3819}", "Brian Lamee");

See Also

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.data.process (client-side reference)

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, the Xrm.Page.data.process namespace provides events, methods, and objects to interact with the business process flow data in a form.

See Xrm.Page.ui.process (client-side reference) for methods to interact with the business process flow control in the form.

Xrm.Page.data.process methods

ActiveProcess

Use getActiveProcess to retrieve information about the active process and setActiveProcess to set a different process as the active process.

ActiveStage

Use getActiveStage to retrieve information about the active stage and setActiveStage to set a completed stage for the current entity as the active stage.

getActivePath

Use this method to get a collection of stages currently in the active path with methods to interact with the stages displayed in the business process flow control.

The active path represents stages currently rendered in the process control based on the branching rules and current data in the record.

getEnabledProcesses

Use this method to asynchronously retrieve the enabled business process flows that the user can switch to for an entity.

Methods to manage event handlers

Use the addOnStageChange, removeOnStageChange, addOnStageSelected, and removeOnStageSelected methods to add or remove event handlers for the business process flow control.

Navigation methods

Use moveNext to move to the next stage and movePrevious to move to the previous stage.

Process methods

Use process methods to access properties of the process.

Stage methods

Use stage methods to access properties of the stage in a business process flow.

Step methods

Use step methods to access properties of the step in a in a stage in a business process flow.

ActiveProcess methods

Use getActiveProcess to retrieve information about the active process and setActiveProcess to set a different process as the active process.

getActiveProcess

Returns a Process object representing the active process.

JavaScript Copy Code
var activeProcess = Xrm.Page.data.process.getActiveProcess();
Return Value

Type: Process

Remarks: See Process methods for the methods to access the properties of the process returned.

setActiveProcess

Set a Process as the active process.

JavaScript Copy Code
Xrm.Page.data.process.setActiveProcess(processId, callbackFunction);

Parameters:

processId

Type:String

Remarks: The Id of the process to make the active process.

callbackFunction

Type:Function

Remarks: A function to call when the operation is complete. This callback function is passed one of the following string values to indicate whether the operation succeeded.

Value Description

success

The operation succeeded.

invalid

The processId isn’t valid or the process isn’t enabled.

ActiveStage methods

Use getActiveStage to retrieve information about the active stage and setActiveStage to set a different stage as the active stage.

getActiveStage

Returns a Stage object representing the active stage

JavaScript Copy Code
var activeStage = Xrm.Page.data.process.getActiveStage();
Return Value

Type: Stage

Remarks: See Stage methods for the methods to access the properties of the stage returned.

setActiveStage

Set a completed stage for the current entity as the active stage.

Note
Only a completed stage for the current entity can be set using this method.

JavaScript Copy Code
Xrm.Page.data.process.setActiveStage(stageId, callbackFunction);

Parameters:

stageId

Type:String

Remarks: The ID of the completed stage for the current entity to make the active stage.

callbackFunction

Type:Function

Remarks: An optional function to call when the operation is complete.

The callback function will be passed a string value of “success” if the operation completes successfully.

If the stageId represents a stage that isn,t valid, the stage won’t be made active and the callback function will be passed a string value indicating the reason. The values listed in the following table may be returned.

Value Reason

crossEntity

The stage must be one for the current entity.

invalid

There are three reasons why this value may be returned:

  • The stageId parameter is a non-existent stage ID value.
  • The active stage isn’t the selected stage
  • The record hasn’t been saved yet.

unreachable

The stage exists on a different path.

Important
This method can only be used when the selected stage and the active stage are the same. When your code is initiated from the OnStageChange event, the current stage will be selected. When your code is initiated from the OnStageSelected event, you should use Xrm.Page.data.process.getActiveStage to verify that the selected stage is also the active stage. For any other form event, it isn’t possible to determine which stage is currently selected. For best results, this method should only be used in code that is called in functions initiated by the OnStageChange and OnStageSelected events.

getActivePath

Use this method to get a collection of stages currently in the active path with methods to interact with the stages displayed in the business process flow control.

The active path represents stages currently rendered in the process control based on the branching rules and current data in the record.

JavaScript Copy Code
var stageCollection = Xrm.Page.data.process.getActivePath();

Example:

See Sample: Xrm.Page.data.process.getActivePath for sample using this method.

Return Value

Type: Collection

Remarks: A collection of all completed stages, the currently active stage, and the predicted set of future stages based on satisfied conditions in the branching rule. This may be a subset of the stages returned with Xrm.Page.data.process. getActiveProcess because it will only include those stages which represent a valid transition from the current stage based on branching that has occurred in the process.

getEnabledProcesses

Use this method to asynchronously retrieve the enabled business process flows that the user can switch to for an entity.

JavaScript Copy Code
Xrm.Page.data.process.getEnabledProcesses(callbackFunction(enabledProcesses));
Parameter

Type:Function

Remarks: The callback function must accept a parameter that contains an object with dictionary properties where the name of the property is the Id of the business process flow and the value of the property is the name of the business process flow.

The enabled processes are filtered according to the user’s privileges. The list of enabled processes is the same ones a user can see in the UI if they want to change the process manually.

Example:

See Sample: Xrm.Page.data.process.getEnabledProcesses for a sample using this method.

Methods to manage event handlers

Use these methods to add or remove event handlers for the business process flow control.

addOnStageChange

Use this to add a function as an event handler for the OnStageChange event so that it will be called when the business process flow stage changes.

JavaScript Copy Code
Xrm.Page.data.process.addOnStageChange(handler);
Parameter

Type: function reference

Remarks: The function will be added to the bottom of the event handler pipeline. The execution context is automatically set to be the first parameter passed to the event handler. See Execution context (client-side reference) for more information.

You should use a reference to a named function rather than an anonymous function if you may later want to remove the event handler.

removeOnStageChange

Use this to remove a function as an event handler for the OnStageChange event.

JavaScript Copy Code
Xrm.Page.data.process.removeOnStageChange(handler);
Parameter

Type: function reference

Remarks: If an anonymous function is set using the addOnStageChange method it cannot be removed using this method.

addOnStageSelected

Use this to add a function as an event handler for the OnStageSelected event so that it will be called when a business process flow stage is selected.

JavaScript Copy Code
Xrm.Page.data.process.addOnStageSelected(handler);
Parameter

Type: function reference

Remarks: The function will be added to the bottom of the event handler pipeline. The execution context is automatically set to be the first parameter passed to the event handler. See Execution context (client-side reference) for more information.

You should use a reference to a named function rather than an anonymous function if you may later want to remove the event handler.

removeOnStageSelected

Use this to remove a function as an event handler for the OnStageSelected event.

JavaScript Copy Code
Xrm.Page.data.process.removeOnStageSelected(function reference);
Parameter

Type: function reference

Remarks: If an anonymous function is set using the addOnStageSelected method it cannot be removed using this method.

Navigation methods

Use moveNext to move to the next stage and movePrevious to move to the previous stage. Both of these methods will cause the OnStageChange event to occur.

moveNext

Progresses to the next stage.

JavaScript Copy Code
Xrm.Page.data.process.moveNext(callbackFunction);
Parameter

Type: Function

Remarks: An optional function to call when the operation is complete. This callback function is passed one of the following string values to indicate whether the operation succeeded.

Value Description

success

The operation succeeded.

crossEntity

The next stage is for a different entity.

end

The active stage is the last stage of the active path.

invalid

The operation failed because the selected stage isn’t the same as the active stage.

Important
This method can only be used when the selected stage and the active stage are the same. When your code is initiated from the OnStageChange event, the current stage will be selected. When your code is initiated from the OnStageSelected event, you should use Xrm.Page.data.process.getActiveStage to verify that the selected stage is also the active stage. For any other form event, it isn’t possible to determine which stage is currently selected. For best results, this method should only be used in code that is called in functions initiated by the OnStageChange and OnStageSelected events.

movePrevious

Moves to the previous stage.

JavaScript Copy Code
Xrm.Page.data.process.movePrevious(callbackFunction);
Parameter

Type: Function

Remarks: An optional function to call when the operation is complete. This callback function is passed one of the following string values to indicate whether the operation succeeded.

Value Description

success

The operation succeeded.

crossEntity

The previous stage is for a different entity.

beginning

The active stage is the first stage of the active path.

invalid

The operation failed because the selected stage isn’t the same as the active stage.

Important
This method can only be used when the selected stage and the active stage are the same. When your code is initiated from the OnStageChange event, the current stage will be selected. When your code is initiated from the OnStageSelected event, you should use Xrm.Page.data.process.getActiveStage to verify that the selected stage is also the active stage. For any other form event, it isn’t possible to determine which stage is currently selected. For best results, this method should only be used in code that is called in functions initiated by the OnStageChange and OnStageSelected events.

Process methods

A process contains the data for a business process flow. Use the methods to access properties of the process.

getId

Returns the unique identifier of the process

JavaScript Copy Code
var processId = procObj.getId();
Return Value

Type:String

Remarks: Value represents the string representation of a GUID value.

getName

Returns the name of the process

JavaScript Copy Code
var processName = procObj.getName();
Return Value

Type:String

getStages

Returns an collection of stages in the process

JavaScript Copy Code
var stageCollection = procObj.getStages();
Return Value

Type: collection

See Stage methods for the methods to access the properties of the stages returned.

isRendered

Returns true if the process is rendered, false if not

JavaScript Copy Code
var processRendered = procObj.isRendered();
Return Value

Type:Boolean

Remarks: If the form used has been upgraded from a previous version of Microsoft Dynamics CRM and has not been upgraded to use new forms, the business process flow control cannot be rendered. More information: Update your forms to Microsoft Dynamics CRM 2013 or Microsoft Dynamics CRM Online Fall '13

Stage methods

A stage contains the data for a stage in a business process flow. Use the methods to access properties of the stage.

getCategory

Returns an object with a getValue method which will return the integer value of the business process flow category.

JavaScript Copy Code
var stageCategoryNumber = stageObj.getCategory().getValue();
Return Value

Type:Number

Remarks: See Stage Category (processstage_category) for the list of possible values.

getEntityName

Returns the logical name of the entity associated with the stage.

JavaScript Copy Code
var stageEntityName = stageObj.getEntityName();
Return Value

Type:String

getId

Returns the unique identifier of the stage

JavaScript Copy Code
var stageId = stageObj.getId();
Return Value

Type:String

getName

Returns the name of the stage

JavaScript Copy Code
var stageName = stageObj.getName();
Return Value

Type:String

getStatus

Returns the status of the stage

JavaScript Copy Code
var stageStatus = stageObj.getStatus();
Return Value

Type:String

Remarks: This method will return either active or inactive.

getSteps

Returns a collection of steps in the stage.

JavaScript Copy Code
var stepsCollection = stageObj.getSteps();
Return Value

Type:Array

See Step methods for methods to access the property values of the step.

Step methods

A step contains the data for a step in a stage in a business process flow. Use the methods to access properties of the step.

getAttribute

Returns the logical name of the attribute associated to the step.

JavaScript Copy Code
var stepAttributeName = stepObj.getAttribute();
Return Value

Type:String

Remarks: Some steps don’t contain an attribute value.

getName

Returns the name of the step.

JavaScript Copy Code
var stepName = stepObj.getName();
Return Value

Type:String

isRequired

Returns whether the step is required in the business process flow.

JavaScript Copy Code
var stepIsRequired = stepObj.isRequired();
Return Value

Type:Boolean

Remarks: Returns true if the step is marked as required in the Business Process Flow editor; otherwise, false. There is no connection between this value and the values you can change in the Xrm.Page.data.entity attribute RequiredLevel methods.

See Also

Reference

Xrm.Page.ui.process (client-side reference)

Concepts

Write scripts for business process flows
Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference
Sample: Xrm.Page.data.process.getEnabledProcesses
Sample: Xrm.Page.data.process.getActivePath

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.ui control (client-side reference)

The control object provides methods to change the presentation or behavior of a control and identify the corresponding attribute.

You access controls using the following collections: Xrm.Page.ui. controls, Xrm.Page.ui Section. controls, or Xrm.Page.data.entity Attribute. controls. The Xrm.Page.getControl method is a shortcut method to access Xrm.Page.ui.controls.get.

The syntax examples in this topic show the use of the Xrm.Page.getControl method to access a control. Which control depends on the arguments passed to the method. The args parameter to access a single control must be either the name of the control or the index.

When a form displays a business process flow control in the header, additional controls will be added for each attribute that is displayed in the business process flow. These controls have a unique name similar to the following example: header_process_<attribute name>.

Note
Only controls in the active stage of the business process flow can be accessed by name this way.

Controls displayed in the form header are accessible and have a unique name like the following: header_<attribute name>.

For controls that are bound to attributes it is common to access controls through the Xrm.Page.data.entity Attribute. controls collection.

Control properties and methods

Disabled

Detect the state and enable or disable controls using the getDisabled and setDisabled methods.

getAttribute

Get the attribute that the control is bound to.

getControlType

Get information about the type of control.

getName

Get the name of the control

getParent

Get the section object that the control is in.

Label

Get or change the label for a control using the getLabel and setLabel methods.

Lookup control methods

Control the results displayed for a user to choose from when they set the value of a lookup control using the addCustomFilter, addCustomView, getDefaultView, setDefaultView methods.

You can add or remove event handlers for the PreSearch Event using the addPreSearch and removePreSearch methods.

Notification

Display and remove notifications to users about a control using the setNotification and clearNotification methods.

OptionSet control methods

Modify the options displayed in OptionSet controls using the addOption, clearOptions, and removeOption methods.

refresh

Refresh the data displayed in a subgrid.

setFocus

Set focus on a control.

setShowTime

Specify whether a date control should show the time portion of the date.

Visible

Determine which controls are visible and show or hide them using the getVisible and setVisible methods.

Web resource and IFRAME control methods

Interact with web resource and IFRAME controls using the getData, setData, getInitialUrl, getObject, setSrc and getSrc methods.

Disabled

Use getDisabled and setDisabled to detect whether a control is disabled or to enable or disable it.

Control Types: standard, lookup, optionset.

getDisabled

Returns whether the control is disabled.

JScript Copy Code
Xrm.Page.getControl(arg).getDisabled()
Return Value

Type: Boolean. True if the control is disabled, otherwise false.

setDisabled

Sets whether the control is disabled.

JScript Copy Code
Xrm.Page.getControl(arg).setDisabled(bool)
Arguments

Type: Boolean. True if the control should be disabled, otherwise false.

getAttribute

Returns the attribute that the control is bound to.

Control Types: standard, lookup, optionset.

JScript Copy Code
Xrm.Page.getControl(arg).getAttribute()
Note
Controls that aren’t bound to an attribute (subgrid, web resource, and IFRAME) don’t have this method. An error will be thrown if you attempt to use this method on one of these controls.

Return Value

Type: Object: An attribute.

Remarks

The constituent controls within a quick view control are included in the controls collection and these controls have the getAttribute method. However, the attribute is not part of the attribute collection for the entity. While you can retrieve the value for that attribute using getValue and even change the value using setValue, changes you make will not be saved with the entity.

The following code shows using the value the contact mobilephone attribute when displayed on an account entity form using a quick view control named contactQuickForm. This code will hide the control when the value of the attribute is null.

JavaScript Copy Code
var quickViewMobilePhoneControl = Xrm.Page.getControl("contactQuickForm_contactQuickForm_contact_mobilephone");
 if (quickViewMobilePhoneControl.getAttribute().getValue() == null)
 {
  quickViewMobilePhoneControl.setVisible(false);
 }

getControlType

Returns a value that categorizes controls.

Control Types: all.

JScript Copy Code
Xrm.Page.getControl(arg).getControlType()
Return Value

Type: String

Possible return values of getControlType:

Return Value Description

standard

A standard control.

iframe

An IFRAME control

lookup

A lookup control.

optionset

An option set control.

subgrid

A subgrid control.

webresource

A web resource control.

notes

A notes control.

timercontrol

A timer control.

getName

Returns the name assigned to the control.

Note
The name assigned to a control is not determined until the form loads. Changes to the form may change the name assigned to a given control.

Control Types: all.

JScript Copy Code
Xrm.Page.getControl(arg).getName()
Return Value

Type: String. The name of the control.

getParent

Returns a reference to the section object that contains the control.

Control Types: all.

JScript Copy Code
Xrm.Page.getControl(arg).getParent()
Return Value

Type: Xrm.Page.ui section (client-side reference) object.

Label

Get or change the label for a control using the getLabel and setLabel methods.

Control Types: all.

getLabel

Returns the label for the control.

JScript Copy Code
Xrm.Page.getControl(arg).getLabel()
Return Value

Type: String. The label of the control.

setLabel

Sets the label for the control.

JScript Copy Code
Xrm.Page.getControl(arg).setLabel(label)
Arguments

Type: String. The new label for the control.

Lookup control methods and events

Control the results displayed for a user to choose from when they set the value of a lookup control using the addCustomFilter, addCustomView, getDefaultView, and setDefaultView methods. The Lookup control also exposes the PreSearch Event so that you can programmatically add event handlers using the addPreSearch and removePreSearch methods.

Control Types: lookup.

addCustomFilter

Use to add filters to the results displayed in the lookup. Each filter will be combined with any previously added filters as an “AND” condition.

JScript Copy Code
Xrm.Page.getControl(arg).addCustomFilter(filter, entityLogicaName)
Arguments

filterXml

Type: String: The fetchXml filter element to apply. For example:

Xml Copy Code
<filter type="and">
 <condition attribute="address1_city" operator="eq" value="Redmond" />
</filter>
entityLogicalName

Type: String: (Optional) If this is set, the filter only applies to that entity type. Otherwise, it applies to all types of entities returned.

Remarks

More information: FetchXML schema.

This method is only available for Updated Entities.

This method can only be used in a function in an event handler for the Lookup Control PreSearch Event.

The following code sample is for the Opportunity form Account (parentaccountid) lookup. When the Sdk.setParentAccountIdFilter function is set in the form Onload event handler, the Sdk.filterCustomAccounts function is added to the PreSearch event for that lookup. The result is that only accounts with the Category (accountcategorycode) value of Preferred Customer (1) will be returned.

JavaScript Copy Code
var Sdk = window.Sdk || {};

Sdk.filterCustomerAccounts = function () {
    //Only show accounts with the type 'Preferred Customer'
    var customerAccountFilter = "<filter type='and'><condition attribute='accountcategorycode' operator='eq' value='1'/></filter>";
    Xrm.Page.getControl("parentaccountid").addCustomFilter(customerAccountFilter, "account");
}
//set 'Sdk.setParentAccountIdFilter' in the Opportunity form onload event handler
Sdk.setParentAccountIdFilter = function () {
    Xrm.Page.getControl("parentaccountid").addPreSearch(Sdk.filterCustomerAccounts);
}

addCustomView

Adds a new view for the lookup dialog box.

JScript Copy Code
Xrm.Page.getControl(arg).addCustomView(viewId, entityName, viewDisplayName, fetchXml, layoutXml, isDefault)
Arguments

viewId

Type:String: The string representation of a GUID for a view.

Note
This value is never saved and only needs to be unique among the other available views for the lookup. A string for a non-valid GUID will work, for example “{00000000-0000-0000-0000-000000000001}”. It’s recommended that you use a tool like guidgen.exe to generate a valid GUID. The guidgen.exe tool is included in the Windows SDK.

entityName

Type: String: The name of the entity.

viewDisplayName

Type: String: The name of the view.

fetchXml

String: The fetchXml query for the view.

layoutXml

Type:String: The XML that defines the layout of the view.

isDefault

Type: Boolean: Whether the view should be the default view.

Remarks

This method doesn’t work with Owner lookups. Owner lookups are used to assign user-owned records.

DefaultView

You can detect which view is the default view that’s shown to allow users to select records in a lookup and change the default view using getDefaultView and setDefaultView.

getDefaultView

Returns the ID value of the default lookup dialog view.

JScript Copy Code
Xrm.Page.getControl(arg).getDefaultView()
Return Value

Type: String. The ID value of the default view.

setDefaultView

Sets the default view for the lookup control dialog box.

JScript Copy Code
Xrm.Page.getControl(arg).setDefaultView(viewGuid)
Arguments

Type: String. The ID of the view to be set as the default view.

Example: This setDefaultViewSample function will set the account entity form primary contact lookup default view to the My Active Contacts view.

JavaScript Copy Code
function setDefaultViewSample() {
    Xrm.Page.getControl("primarycontactid").setDefaultView("{00000000-0000-0000-00AA-000010001003}");
}​

PreSearch event

You can add or remove event handlers for the Lookup Control PreSearch Event using the addPreSearch and removePreSearch methods.

Use the PreSearch event to control what results are displayed for the control using the form data current as the user is beginning to search for records.

Both methods have the Execution context (client-side reference) passed as the first parameter.

addPreSearch

Use this method to apply changes to lookups based on values current just as the user is about to view results for the lookup.

JavaScript Copy Code
Xrm.Page.getControl(arg).addPreSearch(handler)
Arguments

Type: Function to add.

Remarks

This method is only available for Updated Entities.

The argument is a function that will be run just before the search to provide results for a lookup occurs. You can use this handler to call one of the other lookup control functions and improve the results to be displayed in the lookup.

removePreSearch

Use this method to remove event handler functions that have previously been set for the PreSearch event.

JScript Copy Code
Xrm.Page.getControl(arg).removePreSearch(handler)
Arguments

Type: Function to remove.

Remarks

This method is only available for Updated Entities.

Notification

Use setNotification to display a notification about the control and clearNotification to remove it.

setNotification

Display a message near the control to indicate that data isn’t valid. When this method is used on Microsoft Dynamics CRM for tablets a red "X" icon appears next to the control. Tapping on the icon will display the message.

JScript Copy Code
Xrm.Page.getControl(arg).setNotification(message,uniqueId)

Remarks

Setting a notification on a control will block the form from saving.

This method is only available for Updated Entities.

Arguments

message

Type: String: The message to display.

uniqueId

Type: String: The ID to use to clear just this message when using clearNotification.

Return Value

Type: Boolean: Indicates whether the method succeeded.

clearNotification

Remove a message already displayed for a control.

JScript Copy Code
Xrm.Page.getControl(arg).clearNotification(uniqueId)

Arguments

uniqueId

Type: String: The ID to use to clear a specific message set using setNotification.

If the uniqueId parameter isn’t used, the current notification shown will be removed.

Remarks

This method is only available for Updated Entities.

Return Value

Type: Boolean: Indicates whether the method succeeded.

OptionSet control methods

Use the addOption, clearOptions, and removeOption methods to manipulate options available for OptionSet controls. For an example of these functions being put to use, see Sample: Create dependent OptionSets (picklists).

addOption

Adds an option to an option set control.

JScript Copy Code
Xrm.Page.getControl(arg).addOption(option, [index])
Important
This method doesn’t check that the values in the options you add are valid. If you add invalid options they will not work correctly. You must only add options that have been defined for the specific option set attribute that the control is bound to. Use the attribute getOptions or getOption methods to get valid option objects to add using this method.

Arguments

option

Type: Object: An option object to add to the OptionSet.

index

Type: Number: (Optional) The index position to place the new option in. If not provided, the option will be added to the end.

clearOptions

Clears all options from an option set control.

JScript Copy Code
Xrm.Page.getControl(arg).clearOptions()

removeOption

Removes an option from an option set control.

JScript Copy Code
Xrm.Page.getControl(arg).removeOption(number)
Arguments

Type: Number: The value of the option you want to remove.

refresh

Refreshes the data displayed in a subgrid.

JScript Copy Code
Xrm.Page.getControl(arg).refresh()
Note
The refresh method isn’t available in the OnLoad Event form.

setFocus

Sets the focus on the control.

JScript Copy Code
Xrm.Page.getControl(arg).setFocus()

setShowTime

Specify whether a date control should show the time portion of the date.

Control Types: standard control for datetime attributes.

JScript Copy Code
Xrm.Page.getControl(arg).setShowTime(bool)

Remarks

This method is only available for Updated Entities. This method will show or hide the time component of a date control where the attribute uses the DateAndTime format. This method will have no effect when the DateOnly format is used.

Visible

Determine which controls are visible and show or hide them using the getVisible and setVisible methods.

getVisible

Returns a value that indicates whether the control is currently visible.

Note
If the containing section or tab for this control isn’t visible, this method can still return true. To make certain that the control is actually visible; you need to also check the visibility of the containing elements.

JScript Copy Code
Xrm.Page.getControl(arg).getVisible()
Return Value

Type: Boolean. True if the control is visible; otherwise, false.

setVisible

Sets a value that indicates whether the control is visible.

JScript Copy Code
Xrm.Page.getControl(arg).setVisible(bool)
Arguments

Type: Boolean. True if the control should be visible; otherwise, false.

Note
When you selectively show fields to users in code that runs in the Onload event, we recommend that you configure the fields to not be visible by default and then use setVisible(true) to show the fields when conditions are right. Using setVisible(false) to hide fields in the Onload event may result in the field briefly appearing to the user before being hidden.

If you’re hiding a larger number of fields using setVisible(false), consider if you can group them together into tabs or sections and hide the tab or section rather than the fields separately. This can improve performance.

Web resource and IFRAME control methods

Use these methods to interact with web resource and IFRAME controls.

Note
These methods don’t work with Microsoft Dynamics CRM for tablets.

Data

Web resources have a special query string parameter named data to pass custom data. The getData and setData methods only work for Silverlight web resources added to a form. More information: Passing Data from a Form to an Embedded Silverlight Web Resource

For web page (HTML) web resources, the data parameter can be extracted from the getSrc method or set using the setSrc method.

getData

Returns the value of the data query string parameter passed to a Silverlight web resource.

JScript Copy Code
Xrm.Page.getControl(arg).getData()
Return Value

Type: String. The data value passed to the Silverlight web resource.

setData

Sets the value of the data query string parameter passed to a Silverlight web resource.

JScript Copy Code
Xrm.Page.getControl(arg).setData(string)
Arguments

Type: String. The data value to pass to the Silverlight web resource.

getInitialUrl

Returns the default URL that an IFRAME control is configured to display. This method is not available for web resources.

JScript Copy Code
Xrm.Page.getControl(arg).getInitialUrl()
Return Value

Type: String. The initial URL.

getObject

Returns the object in the form that represents an I-frame or web resource.

JScript Copy Code
Xrm.Page.getControl(arg).getObject()
Return Value

Type: Object. Which object depends on the type of control.

An IFRAME returns the IFrame element from the Document Object Model (DOM).

A Silverlight web resource will return the Object element from the DOM that represents the embedded Silverlight plug-in.

Src

IFRAMEs or web resources have a src property to define what to display in the embedded window. You can get or change the src property using the getSrc and setSrc methods.

getSrc

Returns the current URL being displayed in an IFRAME or web resource.

JScript Copy Code
Xrm.Page.getControl(arg).getSrc()
Return Value

Type: String. A URL representing the src property of the IFRAME or web resource.

setSrc

Sets the URL to be displayed in an IFRAME or web resource.

JScript Copy Code
Xrm.Page.getControl(arg).setSrc(string)
Arguments

Type: String: The URL.

See Also

Reference

Xrm.Page.ui (client-side reference)

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.ui (client-side reference)

Xrm.Page.ui contains properties and methods to retrieve information about the user interface as well as collections for several subcomponents of the form.

Xrm.Page.ui Properties and Methods

close

Method to close the form.

controls

A collection of all the controls on the page.

formSelector

Use the formSelector.getCurrentItem method to retrieve information about the form currently in use and the formSelector.items collection containing information about all the forms available for the user.

getCurrentControl

Method to get the control object that currently has focus on the form.

Note
This method was deprecated in Microsoft Dynamics CRM 2013 Update Rollup 2.

getFormType

Method to get the form context for the record.

navigation.items

A collection of all the navigation items on the page.

Form Notification

Use setFormNotification to display form level notifications and clearFormNotification to remove notifications.

refreshRibbon

Method to cause the ribbon to re-evaluate data that controls what is displayed in it.

tabs

A collection of all the tabs on the page.

ViewPort Methods

The ViewPort is the area of the page containing form data. It corresponds to the body of the form and does not include the navigation, header, footer or form assistant areas of the page. Use the getViewPortHeight and getViewPortWidth methods to get the current size of the ViewPort.

close

Method to close the form.

Copy Code
Xrm.Page.ui.close()

Remarks:

The HTML Window.close method is suppressed. To close a form window you must use this method. If there are any unsaved changes in the form the user will be prompted whether they want to save their changes before the window closes.

With Microsoft Dynamics CRM for tablets this method mimics the behavior of the back navigation button.

controls

A collection of all the controls on the page.

See Collections (client-side reference) for information about the collection methods and Xrm.Page.ui control (client-side reference) for information about the control objects in the collection.

formSelector

Use the formSelector.getCurrentItem method to retrieve information about the form currently in use and the formSelector.items collection containing information about all the forms available for the user.

Note
The formSelectoritems collection does not exist and the formSelector.getCurrentItem method does not work with Microsoft Dynamics CRM for tablets.

formSelector.getCurrentItem

Method to return a reference to the form currently being shown.

Note
When only one form is available this method will return null.

Return Value

Type:Object

formSelector.items

A collection of all the form items accessible to the current user.

Note
Only those forms that share an association with one of the user’s security roles are available in this collection.

See Collections (client-side reference) for information about the collection methods and Xrm.Page.ui.formSelector item (client-side reference) for information about the items in the collection.

getCurrentControl

Method to get the control object that currently has focus on the form. Web Resource and IFRAME controls are not returned by this method.

Note
This method was deprecated in Microsoft Dynamics CRM 2013 Update Rollup 2.

This method doesn’t return a reference to the current control when the last field edited by the user was a Boolean attribute formatted as a radio button or check box control. This method also fails to return a reference immediately after using the Xrm.Page.ui control setFocus method.

Copy Code
Xrm.Page.ui.getCurrentControl()
Return Value

Type:Object

getFormType

Method to get the form context for the record.

Copy Code
Xrm.Page.ui.getFormType()
Return Value

Type:Number

The following table lists the form types that correspond to the return value.

Value Form Type

0

Undefined

1

Create

2

Update

3

Read Only

4

Disabled

5

Quick Create (Deprecated)

6

Bulk Edit

11

Read Optimized (Deprecated)

Note
Quick Create forms return 1. The value 5 was used for an earlier type of quick create form that was removed.

navigation.items

A collection of all the navigation items on the page.

Note
This collection does not exist with Microsoft Dynamics CRM for tablets.

See Collections (client-side reference) for information about the collection methods and Xrm.Page.ui.navigation item (client-side reference) for information about the items in the collection.

Form Notification

Use setFormNotification to display form level notifications and clearFormNotification to remove notifications.

clearFormNotification

Use this method to remove form level notifications.

JavaScript Copy Code
Xrm.Page.ui.clearFormNotification(uniqueId)
Parameters

uniqueId

Type: String. A unique identifier for the message used with setFormNotification to set the notification.

Return Value

Type: Boolean. True if the method succeeded, otherwise false.

Remarks

This method is only available for Updated Entities.

setFormNotification

Use this method to display form level notifications. You can display any number of notifications and they will be displayed until they are removed using clearFormNotification. The height of the notification area is limited so each new message will be added to the top. Users can scroll down to view older messages that have not yet been removed.

JavaScript Copy Code
Xrm.Page.ui.setFormNotification(message, level, uniqueId);
Parameters

message

Type: String. The text of the message.

level

Type: String. The level of the message.

The level defines how the message will be displayed.

  • ERROR : Notification will use the system error icon.
  • WARNING : Notification will use the system warning icon.
  • INFO : Notification will use the system info icon.
uniqueId

Type: String. A unique identifier for the message used with clearFormNotification to remove the notification.

Return Value

Type: Boolean. True if the method succeeded, otherwise false.

Remarks

This method is only available for Updated Entities.

refreshRibbon

Method to cause the ribbon to re-evaluate data that controls what is displayed in it.

Note
This method does not work with Microsoft Dynamics CRM for tablets.

Copy Code
Xrm.Page.ui.refreshRibbon()
Return Value

Type: None

Remarks: This function is typically used when a ribbon <EnableRule> (RibbonDiffXml) depends on a value in the form. After your code changes a value that is used by a rule, use this method to force the ribbon to re-evaluate the data in the form so that the rule can be applied.

tabs

A collection of all the tabs on the page.

See Collections (client-side reference) for information about the collection methods and Xrm.Page.ui tab (client-side reference) for information about the items in the collection.

ViewPort Methods

The ViewPort is the area of the page containing form data. It corresponds to the body of the form and does not include the navigation, header, footer or form assistant areas of the page. Use the getViewPortHeight and getViewPortWidth methods to get the current size of the ViewPort.

Note
These methods do not work with Microsoft Dynamics CRM for tablets.

getViewPortHeight

Method to get the height of the viewport in pixels.

Copy Code
Xrm.Page.ui.getViewPortHeight()
Return Value

Type:Number

getViewPortWidth

Method to get the width of the viewport in pixels.

Copy Code
Xrm.Page.ui.getViewPortWidth()
Return Value

Type:Number

See Also

Reference

Xrm.Page.data.entity (client-side reference)

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.ui section (client-side reference)

A section contains methods to manage how it appears as well as accessing the tab that contains the section.

Properties and Methods

controls

A collection of controls in the section.

getName

Method to return the name of the section.

getParent

Method to return the tab containing the section.

Label

Use the getLabel and setLabel methods to retrieve or change the label for the section.

Visible

Use the getVisible and setVisible methods to check whether the section is visible or hide and show the section.

controls

The section controls collection provides access to the controls within a section. See Collections (client-side reference) for information about the methods exposed by collections. See Xrm.Page.ui control (client-side reference) for information about the properties and methods exposed by the objects in this collection.

getName

Method to return the name of the section.

JScript Copy Code
sectionObj.getName()
Return Value

Type:String

getParent

Method to return the tab containing the section.

JScript Copy Code
sectionObj.getParent()
Return Value

Type:Object

Label

Use the getLabel and setLabel methods to retrieve or change the label for the section.

getLabel

Returns the label for the section.

JScript Copy Code
sectionObj.getLabel()
Return Value

Type:String

setLabel

Sets the label for the section.

JScript Copy Code
sectionObj.setLabel(
string
)
Arguments

String: The label text to set.

Visible

Use the getVisible and setVisible methods to check whether the section is visible or hide and show the section.

getVisible

Returns true if the section is visible, otherwise returns false.

JScript Copy Code
sectionObj.getVisible()
Return Value

Type:Boolean

setVisible

Sets a value to show or hide the section.

JScript Copy Code
sectionObj.setVisible(
Boolean
)
Arguments

Boolean

See Also

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.ui tab (client-side reference)

A tab is a group of sections on a page. It contains methods to manipulate tabs as well as access to sections within the tab through the sections collection.

Properties and Methods

DisplayState

Use the getDisplayState and setDisplayState methods to determine whether the tab is collapsed or to collapse and expand the tab.

getName

Method to get the name of the tab.

getParent

Method to return the Xrm.Page.ui (client-side reference) object that is the parent to all tabs.

Label

Use the getLabel and setLabel methods to determine the label for the tab or to hide and show the tab label.

sections

A collection of sections within the tab.

setFocus

Method to set focus on a tab.

Visible

Use the getVisible and setVisible methods to determine the tab is visible or to hide and show the tab.

DisplayState

Use the getDisplayState and setDisplayState methods to determine whether the tab is collapsed or to collapse and expand the tab.

getDisplayState

Returns a value that indicates whether the tab is collapsed or expanded.

JScript Copy Code
tabObj.getDisplayState()
Return Value

Type: String

Possible values:

  • expanded
  • collapsed
Remarks

For Microsoft Dynamics CRM for tablets this method will always return expanded because tabs cannot be collapsed.

setDisplayState

Sets the tab to be collapsed or expanded.

JScript Copy Code
tabObj.setDisplayState(string)
Arguments

String

Valid argument values:

  • expanded
  • collapsed
Remarks

This method does not work with Microsoft Dynamics CRM for tablets because tabs cannot be collapsed.

getName

Returns the name of the tab.

Copy Code
tabObj.getName()
Return Value

Type: String

getParent

Returns the Xrm.Page.ui (client-side reference) object.

JScript Copy Code
tabObj.getParent()
Return Value

Type: Object

Label

Use the getLabel and setLabel methods to determine the label for the tab or to hide and show the tab label.

getLabel

Returns the tab label.

JScript Copy Code
tabObj.getLabel()
Return Value

Type: String

setLabel

Sets the label for the tab.

JScript Copy Code
tabObj.setLabel(String)
Arguments

String

sections

The sections collection provides access to sections within the tab. See Collections (client-side reference) for information about methods to access the sections in the collection. See Xrm.Page.ui section (client-side reference) for information about the properties and methods of the section objects in the collection.

setFocus

Sets the focus on the tab.

JScript Copy Code
tabObj.setFocus()

Visible

Use the getVisible and setVisible methods to determine the tab is visible or to hide and show the tab.

Note
Another way to hide a tab is to hide all the sections within it. If all the sections within a tab are not visible, the tab will not be visible.

getVisible

Returns a value that indicates whether the tab is visible.

JScript Copy Code
tabObj.getVisible()
Return Value

Type: Boolean

setVisible

Sets a value that indicates whether the control is visible.

JScript Copy Code
tabObj.setVisible(boolean);
Arguments

Boolean

See Also

Reference

Xrm.Page.ui (client-side reference)

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.ui.formSelector item (client-side reference)

Form Items are available from the Xrm.Page.ui. formSelector.getCurrentItem or the Xrm.Page.ui. formSelector.items collection. A form item represents a form that is available to a user because it is associated with a security role that the user is also associated to. Often there will be only one form. When more than one form is available, these methods can be used to change the form the user is viewing.

Note
The Xrm.Page.ui. formSelector.items collection used to access these items is not available with Microsoft Dynamics CRM for tablets.

Form Item Methods

getId

Returns the GUID ID of the form.

getLabel

Returns the label of the form.

navigate

Opens the specified form.

getId

Returns the GUID ID of the form.

JScript Copy Code
itemObj.getId()
Return Value

Type: String

getLabel

Returns the label of the form.

JScript Copy Code
itemObj.getLabel()
Return Value

Type: String

navigate

Opens the specified form.

Note
When you use the navigate method while unsaved changes exist, the user is prompted to save changes before the new form can be displayed. The Onload event occurs when the new form loads.

JScript Copy Code
itemObj.navigate()

See Also

Reference

formSelector.getCurrentItem
formSelector.items

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.ui.navigation item (client-side reference)

Each item represents one of the available navigation options available in the navigation bar for entities that have been updated to the new user experience or on the left side of the form for entities that have not been updated.

Note
These methods do not work with Microsoft Dynamics CRM for tablets.

Navigation Item Methods

getId

Returns the name of the item.

Label

Get or change the label for a navigation item using the getLabel and setLabel methods.

setFocus

Sets the focus on the item.

Visible

Determine which navigation items are visible and show or hide them using the getVisible and setVisible methods.

getId

Returns the name of the item.

JScript Copy Code
navigationItemobj.getId()
Return Value

Type:String

Label

Get or change the label for a navigation item using the getLabel and setLabel methods.

getLabel

Returns the label for the item.

JScript Copy Code
navigationItemobj.getLabel()
Return Value

Type:String

setLabel

Sets the label for the item.

JScript Copy Code
navigationItemobj.setLabel(string)
Arguments

Type:String . The new label for the item.

setFocus

Sets the focus on the item.

JScript Copy Code
navigationItemobj.setFocus()

Visible

Determine which navigation items are visible and show or hide them using the getVisible and setVisible methods.

getVisible

Returns a value that indicates whether the item is currently visible.

JScript Copy Code
navigationItemobj.getVisible()
Return Value

Type:Boolean

setVisible

Sets a value that indicates whether the item is visible.

JScript Copy Code
navigationItemobj.setVisible(bool);
Arguments

Type:Boolean. Whether the item is visible.

See Also

Reference

Xrm.Page.ui (client-side reference)

Concepts

Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Page.ui.process (client-side reference)

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, the Xrm.Page.ui.process namespace provides methods to interact with the business process flow control in a form.

Xrm.Page.ui.process methods

setDisplayState

Use this method to expand or collapse the business process control.

setVisible

Use this method to show or hide the business process control.

setDisplayState

Use this method to expand or collapse the business process flow control.

JavaScript Copy Code
Xrm.Page.ui.process.setDisplayState(strExpanded);
Parameter

Type:String

Remarks: “expanded” to expand the control, “collapsed” to collapse it.

setVisible

Use this method to show or hide the business process flow control.

JavaScript Copy Code
Xrm.Page.ui.process.setVisible(boolVisible);
Parameter

Type:Boolean

Remarks:true to show the control; otherwise, false.

See Also

Reference

Xrm.Page.data.process (client-side reference)

Concepts

Write scripts for business process flows
Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference
Sample: Xrm.Page.data.process.getEnabledProcesses
Sample: Xrm.Page.data.process.getActivePath

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Xrm.Utility (client-side reference)

The Xrm.Utility object provides a container for useful functions not directly related to the current page.

These functions are available in every application page that supports scripting. You can use them in form scripts or in ribbon commands. For HTML web resources, they are available when you include the ClientGlobalContext.js.aspx page. For more information, see GetGlobalContext function and ClientGlobalContext.js.aspx (client-side reference).

Functions

Dialogs

Use alertDialog and confirmDialog display messages to users and set code to execute based on their response. These functions must be used with Microsoft Dynamics CRM for tablets in place of the window.alert and window.confirm methods.

isActivityType

Determine if an entity is an activity entity.

openEntityForm

Opens an entity form.

openWebResource

Opens an HTML web resource.

Dialogs

There are two types of dialogs: alertDialog and confirmDialog. These are included for use with scripts that will work with Microsoft Dynamics CRM for tablets. CRM for tablets will not allow the use of JavaScript functions that block the flow of code such as window.alert and window.confirm. Use these methods in place of those methods in case you need to display a message to the user. They key difference is that these methods will not block code until a user closes them. They contain a callback function parameter to indicate what code should be executed depending on the user’s response.

Note
In Microsoft Dynamics CRM for tablets any use of the window.alert method will be overridden to use Xrm.Utility.alertDialog without a callback. This will display the message but will not block the execution of code as window.alert does. This mapping of window.alert to Xrm.Utility.alertDialog in CRM for tablets is deprecated and will be removed in the next major release. You should migrate any code you have today to use Xrm.Utility.alertDialog rather than window.alert.

alertDialog

Displays a dialog box containing an application-defined message.

JavaScript Copy Code
Xrm.Utility.alertDialog(message,onCloseCallback)

Parameters

message

Type: String. The text of the message to display in the dialog.

onCloseCallback

Type: Function. A function to execute when the OK button is clicked.

Remarks

This method is only available for Updated Entities.

confirmDialog

Displays a confirmation dialog box that contains an optional message as well as OK and Cancel buttons.

JavaScript Copy Code
Xrm.Utility.confirmDialog(message,yesCloseCallback,noCloseCallback)

Parameters

message

Type: String. The text of the message to display in the dialog.

yesCloseCallback

Type: Function. A function to execute when the OK button is clicked.

noCloseCallback

Type: Function. A function to execute when the Cancel button is clicked.

Remarks

This method is only available for Updated Entities.

isActivityType

Determine if an entity is an activity entity.

JavaScript Copy Code
Xrm.Utility.isActivityType(entityName)

Parameter

entityName

Type: String. The logicalName of an entity.

Return Value

Type: Boolean. True if the entity is an activity entity, otherwise false.

openEntityForm

Opens an entity form.

JavaScript Copy Code
Xrm.Utility.openEntityForm(name,id,parameters)

Parameters

name

Type: String

Required: The logical name of an entity.

id

Type: String

Optional: The string representation of a unique identifier or the record to open in the form. If not set, a form to create a new record is opened.

parameters

Type: Object

Optional: A dictionary object that passes extra query string parameters to the form. Invalid query string parameters will cause an error.

Valid extra query string parameters are:

  • Form id: To set the id value of the main form to use when more than one form is available. The parameter is formid.
  • Default field ids: To set default values for a new record form. For more information, see Set field values using parameters passed to a form.
  • The navbar and cmdbar parameters described in Query String Parameters for the Main.aspx Page.
  • Custom query string parameters: A form can be configured to accept custom query string parameters. For more information, see Configure a form to accept custom querystring parameters.

Remarks: Using this function helps ensure that users are not prompted to log in again under certain circumstances.

Examples

Open a new account record

JavaScript Copy Code
Xrm.Utility.openEntityForm("account");
Open an existing account record

JavaScript Copy Code
Xrm.Utility.openEntityForm("account","A85C0252-DF8B-E111-997C-00155D8A8410");
Open a new account record with a specific form and setting default values

JavaScript Copy Code
var parameters = {};
parameters["formid"] = "b053a39a-041a-4356-acef-ddf00182762b";
parameters["name"] = "Test";
parameters["telephone1"] = "(425) 555-1234";
Xrm.Utility.openEntityForm("account", null, parameters);

openWebResource

Opens an HTML web resource.

Note
This function will not work with Microsoft Dynamics CRM for tablets.

JavaScript Copy Code
Xrm.Utility.openWebResource(webResourceName,webResourceData,width, height)

Parameters

webResourceName

Type: String

Required: The name of the HTML web resource to open.

webResourceData

Type: String

Optional: Data to be passed into the data parameter.

width

Type: Number

Optional: The width of the window to open in pixels.

height

Type: Number

Optional: The height of the window to open in pixels.

Return Value: Window object.

Remarks: An HTML web resource can accept the parameter values described in Passing Parameters to HTML Web Resources. This function only provides for passing in the optional data parameter. To pass values for the other valid parameters, you must append them to the webResourceName parameter.

Examples

Open an HTML web resource named “new_webResource.htm”

JavaScript Copy Code
Xrm.Utility.openWebResource("new_webResource.htm");
Open an HTML web resource including a single item of data for the data parameter

JavaScript Copy Code
Xrm.Utility.openWebResource("new_webResource.htm","dataItemValue");
Open an HTML web resource passing multiple values through the data parameter

JavaScript Copy Code
var customParameters = encodeURIComponent("first=First Value&second=Second Value&third=Third Value");
Xrm.Utility.openWebResource("new_webResource.htm",customParameters);
Note
These values have to be extracted from the value of the data parameter in the HTML web resource. For more information, see Sample: Pass multiple values to a web resource through the data parameter

Open an HTML web resource with the parameters expected by HTML web resources

JavaScript Copy Code
Xrm.Utility.openWebResource("new_webResource.htm?typename=account&userlcid=1033");
For more information, see Passing Parameters to HTML Web Resources.

Open an HTML web resource, setting the height and width

JavaScript Copy Code
Xrm.Utility.openWebResource("new_webResource.htm", null, 300,300);

See Also

Concepts

Open forms, views, dialogs and reports with a URL
Set field values using parameters passed to a form
Configure a form to accept custom querystring parameters
Form scripting quick reference
Write code for Microsoft Dynamics CRM forms
Use the Xrm.Page object model

Other Resources

Client-side programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write plug-ins to extend business processes

A plug-in is custom business logic that you can integrate with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online to modify or augment the standard behavior of the platform. Plug-ins are event handlers since they are registered to execute in response to a particular event being fired by the platform.

The following topics describe how to add custom business logic to Microsoft Dynamics CRM through the development and registration of plug-ins. For more information about the run-time execution of plug-ins and the plug-in development framework, see Introduction to the event framework.

You can also extend the functionality of Microsoft Dynamics CRM by using processes. For more information, see the related link below.

In This Section

Introduction to the event framework

Supported messages and entities for plug-ins

Plug-in development

Plug-in entities

Plug-in registration entities

Related Sections

Software Development Kit for Microsoft Dynamics CRM

Write workflows to automate business processes

Package and distribute extensions using solutions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Introduction to the event framework

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online you have the ability to extend or customize the functionality of the server through the integration of custom business logic (code). You can customize the product to support the way your company does business, and you can add new features to the product. The technology that enables your custom code to be developed and integrated into the Microsoft Dynamics CRM server is called the event framework.

The event framework enables you to create rich vertical and horizontal solutions on top of Microsoft Dynamics CRM by supporting the development and integration of custom business logic with Microsoft Dynamics CRM in a reliable and portable way. After your custom business logic has been integrated into Microsoft Dynamics CRM, it can be executed synchronously as part of the main Microsoft Dynamics CRM execution path, or asynchronously from a managed queue. Business data can be passed to your custom code, which can then perform actions based on the nature of the information, or modify the information itself.

The Event Framework provides the following key features:

  • An improved event processing subsystem. This subsystem provides a unified method of executing both plug-ins and workflow activities, which results in improved reliability, an enhanced feature set, and plug-in portability.
  • An event framework API for extending the Microsoft Dynamics CRM platform through the development of custom business logic in the form of plug-ins and workflow activities.
  • An API for the deployment of plug-ins and custom workflow activities to the Microsoft Dynamics CRM database. Deployment of plug-ins and workflow activities to the database enables automatic distribution of your plug-ins and custom workflow activities to servers running Microsoft Dynamics CRM services throughout a datacenter.
  • Synchronous and asynchronous execution of plug-ins. Synchronous plug-ins are executed in a pre-defined order as part of the main Microsoft Dynamics CRM event processing. Asynchronous plug-ins are queued and executed independently.

The Event Framework is only supported on the Microsoft Dynamics CRM server and the Microsoft Outlook client. For more information about how to extend the Microsoft Dynamics CRM Web application, see Developers guide to customization for Microsoft Dynamics CRM.

In This Section

Event execution pipeline

Plug-in isolation, trusts, and statistics

Related Sections

Write plug-ins to extend business processes

Supported messages and entities for plug-ins

Plug-in development

Plug-in entities

Plug-in registration entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Event execution pipeline

The Microsoft Dynamics CRM event processing subsystem executes plug-ins based on a message pipeline execution model. A user action in the Microsoft Dynamics CRM Web application or an SDK method call by a plug-in or other application results in a message being sent to the organization Web service. The message contains business entity information and core operation information. The message is passed through the event execution pipeline where it can be read or modified by the platform core operation and any registered plug-ins.

Note
While there are several Web services hosted by the Microsoft Dynamics CRM platform, only events triggered by the organization and OData endpoints can cause plug-ins to execute.

In This Topic

Architecture and related components

Pipeline stages

Message processing

Plug-in registration

Inclusion in database transactions

Architecture and related components

The following figure illustrates the overall architecture of the Microsoft Dynamics CRM platform with respect to both synchronous and asynchronous event processing.

Event processing architecture

The event execution pipeline processes events either synchronously or asynchronously. The platform core operation and any plug-ins registered for synchronous execution are executed immediately. Synchronous plug-ins that are registered for the event are executed in a well-defined order. Plug-ins registered for asynchronous execution are queued by the Asynchronous Queue Agent and executed at a later time by the asynchronous service.

Important
Regardless of whether a plug-in executes synchronously or asynchronously, there is a 2 minute time limit imposed on the execution of a (message) request. If the execution of your plug-in logic exceeds the time limit, a System.TimeoutException is thrown. If a plug-in needs more processing time than the 2 minute time limit, consider using a workflow or other background process to accomplish the intended task.

Pipeline stages

The event pipeline is divided into multiple stages, of which 4 are available to register custom developed or 3rd party plug-ins. Multiple plug-ins that are registered in each stage can be further be ordered (ranked) within that stage during plug-in registration.

Event Stage name Stage number Description

Pre-Event

Pre-validation

10

Stage in the pipeline for plug-ins that are to execute before the main system operation. Plug-ins registered in this stage may execute outside the database transaction.

Security Note
The pre-validation stage occurs prior to security checks being performed to verify the calling or logged on user has the correct permissions to perform the intended operation.

Pre-Event

Pre-operation

20

Stage in the pipeline for plug-ins that are to execute before the main system operation. Plug-ins registered in this stage are executed within the database transaction.

Platform Core Operation

MainOperation

30

In-transaction main operation of the system, such as create, update, delete, and so on. No custom plug-ins can be registered in this stage. For internal use only.

Post-Event

Post-operation

40

Stage in the pipeline for plug-ins which are to execute after the main operation. Plug-ins registered in this stage are executed within the database transaction.

Message processing

Whenever application code or a workflow invokes a Microsoft Dynamics CRM Web service method, a state change in the system occurs that raises an event. The information passed as a parameter to the Web service method is internally packaged up into a OrganizationRequest message and processed by the pipeline. The information in the OrganizationRequest message is passed to the first plug-in registered for that event where it can be read or modified before being passed to the next registered plug-in for that event and so on. Plug-ins receive the message information in the form of context that is passed to their Execute method. The message is also passed to the platform core operation.

Plug-in registration

Plug-ins can be registered to execute before or after the core platform operation. Pre-event registered plug-ins receive the OrganizationRequest message first and can modify the message information before the message is passed to the core operation. After the core platform operation has completed, the message is then known as the OrganizationResponse. The response is passed to the registered post-event plug-ins. Post-event plug-ins have the opportunity to modify the message before a copy of the response is passed to any registered asynchronous plug-ins. Finally, the response is returned to the application or workflow that invoked the original Web service method call.

Because a single Microsoft Dynamics CRM server can host more than one organization, the execution pipeline is organization specific. There is a virtual pipeline for every organization. Plug-ins registered with the pipeline can only process business data for a single organization. A plug-in that is designed to work with multiple organizations must be registered with each organization's execution pipeline.

Inclusion in database transactions

Plug-ins may or may not execute within the database transaction of the Microsoft Dynamics CRM platform. Whether a plug-in is part of the transaction is dependent on how the message request is processed by the pipeline. You can check if the plug-in is executing in-transaction by reading the IsInTransaction property inherited by IPluginExecutionContext that is passed to the plug-in. If a plug-in is executing in the database transaction and allows an exception to be passed back to the platform, the entire transaction will be rolled back. Stages 20 and 40 are guaranteed to be part of the database transaction while stage 10 may be part of the transaction.

Any registered plug-in that executes during the database transaction and that passes an exception back to the platform cancels the core operation. This results in a rollback of the core operation. In addition, any pre-event or post event registered plug-ins that have not yet executed and any workflow that is triggered by the same event that the plug-in was registered for will not execute.

See Also

Concepts

Plug-in isolation, trusts, and statistics
Register and Deploy Plug-Ins

Other Resources

Introduction to the event framework
Asynchronous service in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Plug-in isolation, trusts, and statistics

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update support the execution of plug-ins and custom workflow activities in an isolated environment. In this isolated environment, also known as a sandbox, a plug-in or custom activity can make use of the full power of the Microsoft Dynamics CRM SDK to access the organization web service. Access to the file system, system event log, certain network protocols, registry, and more is prevented in the sandbox. However, sandbox plug-ins and custom activities do have access to external endpoints like the Microsoft Azure cloud service.

Microsoft Dynamics CRM collects run-time statistics and monitors plug-ins and custom workflow activities that execute in the sandbox. If the sandbox worker process that hosts this custom code exceeds threshold CPU, memory, or handle limits or is otherwise unresponsive, that process will be killed by the platform. At that point any currently executing plug-in or custom workflow activity in that worker process will fail with exceptions. However, the next time that the plug-in or custom workflow activity is executed it will run normally. There is one worker process per organization so failures in one organization will not affect another organization.

In summary, the sandbox is the recommended execution environment for plug-ins as it is more secure, supports run-time monitoring and statistics reporting, and is supported on all Microsoft Dynamics CRM deployments. In addition, Microsoft Dynamics CRM Online only supports execution of custom workflow activities if they are registered in the sandbox.

Trusts

Developers have the option of registering their plug-ins in the sandbox, known as partial trust, or outside the sandbox, known as full trust. Full trust is supported for on-premises and Internet-facing Microsoft Dynamics CRM deployments. For a Microsoft Dynamics CRM Online deployment, plug-ins or custom workflow activities must be registered in the sandbox (partial trust) where they are isolated as previously described.

Important
Custom workflow activities and plug-ins that were developed using the Microsoft Dynamics CRM 4.0 SDK are not supported for execution in the sandbox or by Microsoft Dynamics CRM Online.

Run-time statistics

The Microsoft Dynamics CRM platform collects run-time information about plug-ins and custom workflow activities that execute in the sandbox. This information is stored in the database using PluginTypeStatistic entity records. These records are populated within 30 minutes to one hour after the sandboxed custom code executes. See the PluginTypeStatistic attributes to find out what information is collected. You can retrieve this information by using the retrieve message or method.

Web access

Sandboxed plug-ins and custom workflow activities can access the network through the HTTP and HTTPS protocols. This capability provides support for accessing popular web resources like social sites, news feeds, web services, and more. The following web access restrictions apply to this sandbox capability.

  • Only the HTTP and HTTPS protocols are allowed.
  • Access to localhost (loopback) is not permitted.
  • IP addresses cannot be used. You must use a named web address that requires DNS name resolution.
  • Anonymous authentication is supported and recommended. There is no provision for prompting the logged on user for credentials or saving those credentials.

These default web access restrictions are defined in a registry key on the server that is running the Microsoft.Crm.Sandbox.HostService.exe process. The value of the registry key can be changed by the System Administrator according to business and security needs. The registry key path on the server is:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\SandboxWorkerOutboundUriPattern

The key value is a regular expression string that defines the web access restrictions. The default key value is:

Copy Code
"^http[s]?://(?!((localhost[:/])|(\[.*\])|([0-9]+[:/])|(0x[0-9a-f]+[:/])|(((([0-9]+)|(0x[0-9A-F]+))\.){3}(([0-9]+)|(0x[0-9A-F]+))[:/]))).+";

By changing this registry key value, you can change the web access for sandboxed plug-ins.

Security Note
The sandbox processing service role defaults to outbound calls being enabled. If you do not want to permit outbound calls from custom code (plug-ins or custom workflow activities), you can disable outbound calls by setting the following registry key to 1 (DWORD) on the server that hosts the sandbox processing service role. Next, restart the Microsoft Dynamics CRM Sandbox Processing Service.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\SandboxWorkerDisableOutboundCalls

See Also

Concepts

Write a plug-in
Create a custom workflow activity
PluginTypeStatistic entity messages and methods

Other Resources

Introduction to the event framework
Azure extensions for Microsoft Dynamics CRM
Sample: Web access from a sandboxed plug-in

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Supported messages and entities for plug-ins

This topic contains a table that lists the message and entity combinations that support execution of plug-ins for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Alternatively, you can view this information in a Microsoft Office Excel worksheet, which you can find in the in the SDK package. Download the Microsoft Dynamics CRM SDK package. In the worksheet, filter on the message or entity columns to see where you can register plug-ins. The worksheet can be found at SDK\Message-entity support for plug-ins.xlsx.

The Message Availability column of the table indicates whether a message is available online, offline, or both. The Entity Deployment column indicates if the entity can be deployed on the server, on the client, or both. A value of null in the Primary Entity column means that there is no primary entity associated with the message. The same applies to the Secondary Entity column.

In plug-in code, you can send any message to the web services except those messages that create or update metadata.

Custom entities support the same base messages as system entities, depending on whether the entity is organization-owned or user-owned. For more information, see Actions on Entity Records.

Note
The term offline applies to the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access. The term client can apply to either Microsoft Dynamics CRM for Outlook Online or Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access.

Whether a message is available online or offline can be determined programmatically by inspecting the SdkMessage.Availability attribute. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

In This Topic

Supported messages for custom entities

Supported Messages for Default Entities

Supported messages for custom entities

Custom entities can be either organization-owned or user-owned, which defines the set of messages available for the entity. The following table lists the messages for custom entities that support the execution of plug-ins.

Message Name | Ownership Type | Message Availability | Entity Supported Deployment
Assign | User-owned entities only | Server | Server
Create | User-owned and organization-owned entities | Both | Server
Delete | User-owned and organization-owned entities | Both | Server
GrantAccess | User-owned entities only | Server | Server
ModifyAccess | User-owned entities only | Server | Server
Retrieve | User-owned and organization-owned entities | Both | Server
RetrieveMultiple | User-owned and organization-owned entities | Both | Server
RetrievePrincipalAccess | User-owned entities only | Both | Server
RetrieveSharedPrincipalsAndAccess | User-owned entities only | Both | Server
RevokeAccess | User-owned entities only | Server | Server
SetState | User-owned and organization-owned entities | Both | Server
SetStateDynamicEntity | User-owned and organization-owned entities | Both | Server
Update | User-owned and organization-owned entities | Both | Server

Supported messages for default entities

The following table lists the message and entity combinations that support the execution of plug-ins for default, or out-of-the-box entities.

Message Name | Primary Entity | Secondary Entity | Message Availability | Entity Supported Deployment
AddItem | Campaign | NULL | Both | Both
AddItem | CampaignActivity | NULL | Both | Both
AddListMembers | List | NULL | Server | Server
AddMember | List | NULL | Server | Server
AddMembers | Team | NULL | Server | Server
AddPrincipalToQueue | Queue | NULL | Both | Both
AddPrivileges | Role | NULL | Server | Server
AddProductToKit | Product | NULL | Both | Both
AddRecurrence | RecurringAppointmentMaster | NULL | Both | Both
AddToQueue | QueueItem | NULL | Both | Both
AddUserToRecordTeam | TeamTemplate | NULL | Server | Server
Assign | Account | NULL | Server | Server
Assign | Annotation | NULL | Server | Server
Assign | Appointment | NULL | Server | Server
Assign | Campaign | NULL | Server | Server
Assign | CampaignActivity | NULL | Server | Server
Assign | CampaignResponse | NULL | Server | Server
Assign | Connection | NULL | Server | Server
Assign | Contact | NULL | Server | Server
Assign | Contract | NULL | Server | Server
Assign | CustomerOpportunityRole | NULL | Server | Server
Assign | CustomerRelationship | NULL | Server | Server
Assign | Email | NULL | Server | Server
Assign | Entitlement | NULL | Server | Server
Assign | Fax | NULL | Server | Server
Assign | Goal | NULL | Server | Server
Assign | GoalRollupQuery | NULL | Server | Server
Assign | Incident | NULL | Server | Server
Assign | IncidentResolution | NULL | Server | Server
Assign | Invoice | NULL | Server | Server
Assign | Lead | NULL | Server | Server
Assign | Letter | NULL | Server | Server
Assign | List | NULL | Server | Server
Assign | msdyn_PostAlbum | NULL | Server | Server
Assign | msdyn_wallsavedqueryusersettings | NULL | Server | Server
Assign | Opportunity | NULL | Server | Server
Assign | OpportunityClose | NULL | Server | Server
Assign | OrderClose | NULL | Server | Server
Assign | PhoneCall | NULL | Server | Server
Assign | ProcessSession | NULL | Server | Server
Assign | Queue | NULL | Server | Server
Assign | Quote | NULL | Server | Server
Assign | QuoteClose | NULL | Server | Server
Assign | RecurringAppointmentMaster | NULL | Server | Server
Assign | SalesOrder | NULL | Server | Server
Assign | ServiceAppointment | NULL | Server | Server
Assign | SharePointDocumentLocation | NULL | Server | Server
Assign | SharePointSite | NULL | Server | Server
Assign | SocialActivity | NULL | Server | Server
Assign | SocialProfile | NULL | Server | Server
Assign | Task | NULL | Server | Server
Assign | Template | NULL | Server | Server
Assign | UserForm | NULL | Server | Server
Assign | UserQuery | NULL | Server | Server
Assign | UserQueryVisualization | NULL | Server | Server
AssignUserRoles | Role | NULL | Server | Server
Associate | NULL | NULL | Both | Both
BackgroundSend | Email | NULL | Both | Both
Book | Appointment | NULL | Server | Server
Book | RecurringAppointmentMaster | NULL | Server | Server
Book | ServiceAppointment | NULL | Server | Server
Cancel | Contract | NULL | Both | Both
Cancel | SalesOrder | NULL | Both | Both
CheckIncoming | Email | NULL | Both | Both
CheckPromote | Email | NULL | Both | Both
Clone | Contract | NULL | Both | Both
Close | Incident | NULL | Both | Both
Close | Quote | NULL | Both | Both
CopyDynamicListToStatic | List | NULL | Server | Server
CopySystemForm | SystemForm | NULL | Server | Server
Create | Account | NULL | Both | Both
Create | ActivityMimeAttachment | NULL | Both | Both
Create | Annotation | NULL | Both | Both
Create | Appointment | NULL | Both | Both
Create | BusinessUnit | NULL | Both | Server
Create | BusinessUnitNewsArticle | NULL | Both | Both
Create | Calendar | NULL | Both | Both
Create | Campaign | NULL | Both | Both
Create | CampaignActivity | NULL | Both | Both
Create | CampaignResponse | NULL | Both | Both
Create | Competitor | NULL | Both | Both
Create | Connection | NULL | Both | Both
Create | ConnectionRole | NULL | Both | Both
Create | ConnectionRoleObjectTypeCode | NULL | Both | Both
Create | Contact | NULL | Both | Both
Create | Contract | NULL | Both | Both
Create | ContractDetail | NULL | Both | Both
Create | ContractTemplate | NULL | Both | Server
Create | CustomerAddress | NULL | Both | Both
Create | CustomerOpportunityRole | NULL | Both | Both
Create | CustomerRelationship | NULL | Both | Both
Create | Discount | NULL | Both | Server
Create | DiscountType | NULL | Both | Server
Create | Email | NULL | Both | Both
Create | Entitlement | NULL | Both | Both
Create | EntitlementChannel | NULL | Both | Server
Create | EntitlementTemplate | NULL | Both | Server
Create | EntitlementTemplateChannel | NULL | Both | Server
Create | Equipment | NULL | Both | Server
Create | ExchangeSyncIdMapping | NULL | Both | Server
Create | Fax | NULL | Both | Both
Create | FieldPermission | NULL | Both | Server
Create | FieldSecurityProfile | NULL | Both | Server
Create | Goal | NULL | Both | Server
Create | GoalRollupQuery | NULL | Both | Server
Create | Incident | NULL | Both | Both
Create | IncidentResolution | NULL | Both | Both
Create | Invoice | NULL | Both | Both
Create | InvoiceDetail | NULL | Both | Both
Create | KbArticle | NULL | Both | Both
Create | KbArticleComment | NULL | Both | Both
Create | KbArticleTemplate | NULL | Both | Both
Create | Lead | NULL | Both | Both
Create | Letter | NULL | Both | Both
Create | List | NULL | Both | Both
Create | Metric | NULL | Both | Server
Create | msdyn_PostAlbum | NULL | Both | Server
Create | msdyn_PostConfig | NULL | Both | Server
Create | msdyn_PostRuleConfig | NULL | Both | Server
Create | msdyn_wallsavedquery | NULL | Both | Server
Create | msdyn_wallsavedqueryusersettings | NULL | Both | Server
Create | Opportunity | NULL | Both | Both
Create | OpportunityClose | NULL | Both | Both
Create | OpportunityProduct | NULL | Both | Both
Create | OrderClose | NULL | Both | Both
Create | PhoneCall | NULL | Both | Both
Create | Post | NULL | Both | Server
Create | PostComment | NULL | Both | Server
Create | PostFollow | NULL | Both | Server
Create | PriceLevel | NULL | Both | Server
Create | PrincipalObjectAttributeAccess | NULL | Both | Server
Create | ProcessSession | NULL | Both | Both
Create | Product | NULL | Both | Server
Create | ProductPriceLevel | NULL | Both | Server
Create | Queue | NULL | Both | Server
Create | QueueItem | NULL | Both | Both
Create | Quote | NULL | Both | Both
Create | QuoteClose | NULL | Both | Both
Create | QuoteDetail | NULL | Both | Both
Create | RecurrenceRule | NULL | Both | Server
Create | RecurringAppointmentMaster | NULL | Both | Both
Create | Role | NULL | Both | Server
Create | RollupField | NULL | Both | Server
Create | SalesLiterature | NULL | Both | Server
Create | SalesLiteratureItem | NULL | Both | Server
Create | SalesOrder | NULL | Both | Both
Create | SalesOrderDetail | NULL | Both | Both
Create | Service | NULL | Both | Server
Create | ServiceAppointment | NULL | Both | Both
Create | SharePointDocument | NULL | Both | Both
Create | SharePointDocumentLocation | NULL | Both | Server
Create | SharePointSite | NULL | Both | Server
Create | Site | NULL | Both | Server
Create | SocialActivity | NULL | Both | Both
Create | SocialProfile | NULL | Both | Both
Create | Subject | NULL | Both | Both
Create | SystemUser | NULL | Both | Server
Create | Task | NULL | Both | Both
Create | Team | NULL | Both | Server
Create | Template | NULL | Both | Both
Create | Territory | NULL | Both | Server
Create | TraceLog | NULL | Both | Both
Create | TransactionCurrency | NULL | Both | Server
Create | UoM | NULL | Both | Server
Create | UoMSchedule | NULL | Both | Both
Create | UserQuery | NULL | Both | Both
Create | WebResource | NULL | Both | Server
CreateException | Appointment | NULL | Both | Both
CreateInstance | RecurringAppointmentMaster | NULL | Server | Server
Delete | Account | NULL | Both | Both
Delete | ActivityMimeAttachment | NULL | Both | Both
Delete | Annotation | NULL | Both | Both
Delete | Appointment | NULL | Both | Both
Delete | BusinessUnit | NULL | Both | Server
Delete | BusinessUnitNewsArticle | NULL | Both | Both
Delete | Calendar | NULL | Both | Both
Delete | Campaign | NULL | Both | Both
Delete | CampaignActivity | NULL | Both | Both
Delete | CampaignResponse | NULL | Both | Both
Delete | Competitor | NULL | Both | Both
Delete | Connection | NULL | Both | Both
Delete | ConnectionRole | NULL | Both | Both
Delete | ConnectionRoleObjectTypeCode | NULL | Both | Both
Delete | Contact | NULL | Both | Both
Delete | Contract | NULL | Both | Server
Delete | ContractDetail | NULL | Both | Server
Delete | ContractTemplate | NULL | Both | Server
Delete | CustomerAddress | NULL | Both | Both
Delete | CustomerOpportunityRole | NULL | Both | Both
Delete | CustomerRelationship | NULL | Both | Both
Delete | Discount | NULL | Both | Server
Delete | DiscountType | NULL | Both | Server
Delete | Email | NULL | Both | Both
Delete | Entitlement | NULL | Both | Server
Delete | EntitlementChannel | NULL | Both | Server
Delete | EntitlementTemplate | NULL | Both | Server
Delete | EntitlementTemplateChannel | NULL | Both | Server
Delete | Equipment | NULL | Both | Server
Delete | ExchangeSyncIdMapping | NULL | Both | Server
Delete | Fax | NULL | Both | Both
Delete | FieldPermission | NULL | Both | Server
Delete | FieldSecurityProfile | NULL | Both | Server
Delete | Goal | NULL | Both | Server
Delete | GoalRollupQuery | NULL | Both | Server
Delete | Incident | NULL | Both | Both
Delete | IncidentResolution | NULL | Both | Both
Delete | Invoice | NULL | Both | Both
Delete | InvoiceDetail | NULL | Both | Both
Delete | KbArticle | NULL | Both | Both
Delete | KbArticleComment | NULL | Both | Both
Delete | KbArticleTemplate | NULL | Both | Both
Delete | Lead | NULL | Both | Both
Delete | Letter | NULL | Both | Both
Delete | List | NULL | Both | Server
Delete | Metric | NULL | Both | Server
Delete | msdyn_PostAlbum | NULL | Both | Server
Delete | msdyn_PostConfig | NULL | Both | Server
Delete | msdyn_PostRuleConfig | NULL | Both | Server
Delete | msdyn_wallsavedquery | NULL | Both | Server
Delete | msdyn_wallsavedqueryusersettings | NULL | Both | Server
Delete | Opportunity | NULL | Both | Both
Delete | OpportunityClose | NULL | Both | Both
Delete | OpportunityProduct | NULL | Both | Both
Delete | OrderClose | NULL | Both | Both
Delete | PhoneCall | NULL | Both | Both
Delete | Post | NULL | Both | Server
Delete | PostComment | NULL | Both | Server
Delete | PostFollow | NULL | Both | Server
Delete | PostLike | NULL | Both | Server
Delete | PriceLevel | NULL | Both | Both
Delete | PrincipalObjectAttributeAccess | NULL | Both | Server
Delete | ProcessSession | NULL | Both | Both
Delete | Product | NULL | Both | Both
Delete | ProductPriceLevel | NULL | Both | Both
Delete | Publisher | NULL | Both | Server
Delete | PublisherAddress | NULL | Both | Server
Delete | Queue | NULL | Both | Server
Delete | QueueItem | NULL | Both | Both
Delete | Quote | NULL | Both | Both
Delete | QuoteClose | NULL | Both | Both
Delete | QuoteDetail | NULL | Both | Both
Delete | RecurrenceRule | NULL | Both | Both
Delete | RecurringAppointmentMaster | NULL | Both | Both
Delete | Role | NULL | Both | Server
Delete | RollupField | NULL | Both | Server
Delete | SalesLiterature | NULL | Both | Server
Delete | SalesLiteratureItem | NULL | Both | Server
Delete | SalesOrder | NULL | Both | Both
Delete | SalesOrderDetail | NULL | Both | Both
Delete | Service | NULL | Both | Server
Delete | ServiceAppointment | NULL | Both | Both
Delete | SharePointDocument | NULL | Both | Both
Delete | SharePointDocumentLocation | NULL | Both | Server
Delete | SharePointSite | NULL | Both | Server
Delete | Site | NULL | Both | Server
Delete | SocialActivity | NULL | Both | Both
Delete | SocialProfile | NULL | Both | Both
Delete | Solution | NULL | Both | Server
Delete | Subject | NULL | Both | Both
Delete | Task | NULL | Both | Both
Delete | Team | NULL | Both | Server
Delete | Template | NULL | Both | Both
Delete | Territory | NULL | Both | Server
Delete | TransactionCurrency | NULL | Both | Server
Delete | UoM | NULL | Both | Server
Delete | UoMSchedule | NULL | Both | Both
Delete | UserForm | NULL | Both | Server
Delete | UserQuery | NULL | Both | Both
Delete | UserQueryVisualization | NULL | Both | Both
Delete | WebResource | NULL | Both | Server
DeleteOpenInstances | RecurringAppointmentMaster | NULL | Both | Both
DeliverIncoming | Email | NULL | Server | Server
DeliverPromote | Email | NULL | Both | Both
DetachFromQueue | Email | NULL | Both | Both
Disassociate | NULL | NULL | Both | Both
Execute | NULL | NULL | Both | Both
ExecuteById | SavedQuery | NULL | Both | Both
ExecuteById | UserQuery | NULL | Both | Both
Export | NULL | NULL | Server | Server
ExportAll | NULL | NULL | Server | Server
ExportCompressed | NULL | NULL | Server | Server
ExportCompressedAll | NULL | NULL | Server | Server
GenerateSocialProfile | SocialProfile | NULL | Both | Both
GrantAccess | Account | NULL | Server | Server
GrantAccess | Annotation | NULL | Server | Server
GrantAccess | Appointment | NULL | Server | Server
GrantAccess | Campaign | NULL | Server | Server
GrantAccess | CampaignActivity | NULL | Server | Server
GrantAccess | CampaignResponse | NULL | Server | Server
GrantAccess | Connection | NULL | Server | Server
GrantAccess | Contact | NULL | Server | Server
GrantAccess | Contract | NULL | Server | Server
GrantAccess | CustomerOpportunityRole | NULL | Server | Server
GrantAccess | CustomerRelationship | NULL | Server | Server
GrantAccess | Email | NULL | Server | Server
GrantAccess | Entitlement | NULL | Server | Server
GrantAccess | Fax | NULL | Server | Server
GrantAccess | Goal | NULL | Server | Server
GrantAccess | GoalRollupQuery | NULL | Server | Server
GrantAccess | Incident | NULL | Server | Server
GrantAccess | IncidentResolution | NULL | Server | Server
GrantAccess | Invoice | NULL | Server | Server
GrantAccess | Lead | NULL | Server | Server
GrantAccess | Letter | NULL | Server | Server
GrantAccess | List | NULL | Server | Server
GrantAccess | msdyn_PostAlbum | NULL | Server | Server
GrantAccess | msdyn_wallsavedqueryusersettings | NULL | Server | Server
GrantAccess | Opportunity | NULL | Server | Server
GrantAccess | OpportunityClose | NULL | Server | Server
GrantAccess | OrderClose | NULL | Server | Server
GrantAccess | PhoneCall | NULL | Server | Server
GrantAccess | ProcessSession | NULL | Server | Server
GrantAccess | Queue | NULL | Server | Server
GrantAccess | Quote | NULL | Server | Server
GrantAccess | QuoteClose | NULL | Server | Server
GrantAccess | RecurringAppointmentMaster | NULL | Server | Server
GrantAccess | SalesOrder | NULL | Server | Server
GrantAccess | ServiceAppointment | NULL | Server | Server
GrantAccess | SharePointDocumentLocation | NULL | Server | Server
GrantAccess | SharePointSite | NULL | Server | Server
GrantAccess | SocialActivity | NULL | Server | Server
GrantAccess | SocialProfile | NULL | Server | Server
GrantAccess | Task | NULL | Server | Server
GrantAccess | Template | NULL | Server | Server
GrantAccess | UserForm | NULL | Server | Server
GrantAccess | UserQuery | NULL | Server | Server
GrantAccess | UserQueryVisualization | NULL | Server | Server
Handle | Appointment | NULL | Both | Both
Handle | CampaignActivity | NULL | Both | Both
Handle | CampaignResponse | NULL | Both | Both
Handle | Email | NULL | Both | Both
Handle | Fax | NULL | Both | Both
Handle | Incident | NULL | Both | Both
Handle | Letter | NULL | Both | Both
Handle | PhoneCall | NULL | Both | Both
Handle | RecurringAppointmentMaster | NULL | Both | Both
Handle | ServiceAppointment | NULL | Both | Both
Handle | Task | NULL | Both | Both
Import | NULL | NULL | Server | Server
ImportAll | NULL | NULL | Server | Server
ImportCompressedAll | NULL | NULL | Server | Server
ImportCompressedWithProgress | NULL | NULL | Server | Server
ImportWithProgress | NULL | NULL | Server | Server
LockInvoicePricing | Invoice | NULL | Server | Server
LockSalesOrderPricing | SalesOrder | NULL | Server | Server
Lose | Opportunity | NULL | Both | Both
Merge | Account | NULL | Server | Server
Merge | Contact | NULL | Server | Server
Merge | Incident | NULL | Server | Server
Merge | Lead | NULL | Server | Server
ModifyAccess | Account | NULL | Server | Server
ModifyAccess | Annotation | NULL | Server | Server
ModifyAccess | Appointment | NULL | Server | Server
ModifyAccess | Campaign | NULL | Server | Server
ModifyAccess | CampaignActivity | NULL | Server | Server
ModifyAccess | CampaignResponse | NULL | Server | Server
ModifyAccess | Connection | NULL | Server | Server
ModifyAccess | Contact | NULL | Server | Server
ModifyAccess | Contract | NULL | Server | Server
ModifyAccess | CustomerOpportunityRole | NULL | Server | Server
ModifyAccess | CustomerRelationship | NULL | Server | Server
ModifyAccess | Email | NULL | Server | Server
ModifyAccess | Entitlement | NULL | Server | Server
ModifyAccess | Fax | NULL | Server | Server
ModifyAccess | Goal | NULL | Server | Server
ModifyAccess | GoalRollupQuery | NULL | Server | Server
ModifyAccess | Incident | NULL | Server | Server
ModifyAccess | IncidentResolution | NULL | Server | Server
ModifyAccess | Invoice | NULL | Server | Server
ModifyAccess | Lead | NULL | Server | Server
ModifyAccess | Letter | NULL | Server | Server
ModifyAccess | List | NULL | Server | Server
ModifyAccess | msdyn_PostAlbum | NULL | Server | Server
ModifyAccess | msdyn_wallsavedqueryusersettings | NULL | Server | Server
ModifyAccess | Opportunity | NULL | Server | Server
ModifyAccess | OpportunityClose | NULL | Server | Server
ModifyAccess | OrderClose | NULL | Server | Server
ModifyAccess | PhoneCall | NULL | Server | Server
ModifyAccess | ProcessSession | NULL | Server | Server
ModifyAccess | Queue | NULL | Server | Server
ModifyAccess | Quote | NULL | Server | Server
ModifyAccess | QuoteClose | NULL | Server | Server
ModifyAccess | RecurringAppointmentMaster | NULL | Server | Server
ModifyAccess | SalesOrder | NULL | Server | Server
ModifyAccess | ServiceAppointment | NULL | Server | Server
ModifyAccess | SharePointDocumentLocation | NULL | Server | Server
ModifyAccess | SharePointSite | NULL | Server | Server
ModifyAccess | SocialActivity | NULL | Server | Server
ModifyAccess | SocialProfile | NULL | Server | Server
ModifyAccess | Task | NULL | Server | Server
ModifyAccess | Template | NULL | Server | Server
ModifyAccess | UserForm | NULL | Server | Server
ModifyAccess | UserQuery | NULL | Server | Server
ModifyAccess | UserQueryVisualization | NULL | Server | Server
PickFromQueue | QueueItem | NULL | Both | Both
Publish | NULL | NULL | Server | Server
PublishAll | NULL | NULL | Server | Server
QualifyLead | Lead | NULL | Both | Both
Recalculate | Goal | NULL | Server | Server
ReleaseToQueue | QueueItem | NULL | Both | Both
RemoveFromQueue | QueueItem | NULL | Both | Both
RemoveItem | Campaign | NULL | Both | Both
RemoveItem | CampaignActivity | NULL | Both | Both
RemoveMember | List | NULL | Server | Server
RemoveMembers | Team | NULL | Server | Server
RemovePrivilege | Role | NULL | Server | Server
RemoveProductFromKit | NULL | NULL | Both | Both
RemoveRelated | Invoice | Contact | Both | Both
RemoveRelated | Lead | Account | Both | Both
RemoveRelated | Lead | Contact | Both | Both
RemoveRelated | Opportunity | Account | Both | Both
RemoveRelated | Opportunity | Contact | Both | Both
RemoveRelated | Opportunity | Competitor | Both | Both
RemoveRelated | Product | Lead | Both | Both
RemoveRelated | Product | Competitor | Both | Both
RemoveRelated | Quote | Contact | Both | Both
RemoveRelated | SalesLiterature | Competitor | Both | Both
RemoveRelated | SalesLiterature | Product | Both | Both
RemoveRelated | SalesOrder | Contact | Both | Both
RemoveUserFromRecordTeam | TeamTemplate | NULL | Server | Server
RemoveUserRoles | Role | NULL | Server | Server
ReplacePrivileges | Role | NULL | Server | Server
Reschedule | Appointment | NULL | Server | Server
Reschedule | RecurringAppointmentMaster | NULL | Server | Server
Reschedule | ServiceAppointment | NULL | Server | Server
Retrieve | Account | NULL | Both | Both
Retrieve | ActivityMimeAttachment | NULL | Both | Both
Retrieve | ActivityPointer | NULL | Both | Both
Retrieve | Annotation | NULL | Both | Both
Retrieve | Appointment | NULL | Both | Both
Retrieve | BusinessUnitNewsArticle | NULL | Both | Both
Retrieve | Calendar | NULL | Both | Both
Retrieve | Campaign | NULL | Both | Both
Retrieve | CampaignActivity | NULL | Both | Both
Retrieve | CampaignResponse | NULL | Both | Both
Retrieve | Competitor | NULL | Both | Both
Retrieve | Connection | NULL | Both | Both
Retrieve | ConnectionRole | NULL | Both | Both
Retrieve | ConnectionRoleObjectTypeCode | NULL | Both | Both
Retrieve | Contact | NULL | Both | Both
Retrieve | Contract | NULL | Both | Both
Retrieve | ContractDetail | NULL | Both | Both
Retrieve | ContractTemplate | NULL | Both | Both
Retrieve | CustomerAddress | NULL | Both | Both
Retrieve | CustomerOpportunityRole | NULL | Both | Both
Retrieve | CustomerRelationship | NULL | Both | Both
Retrieve | Dependency | NULL | Both | Server
Retrieve | Discount | NULL | Both | Both
Retrieve | DiscountType | NULL | Both | Both
Retrieve | Email | NULL | Both | Both
Retrieve | Entitlement | NULL | Both | Both
Retrieve | EntitlementChannel | NULL | Both | Both
Retrieve | EntitlementTemplate | NULL | Both | Both
Retrieve | EntitlementTemplateChannel | NULL | Both | Both
Retrieve | Equipment | NULL | Both | Both
Retrieve | ExchangeSyncIdMapping | NULL | Both | Server
Retrieve | Fax | NULL | Both | Both
Retrieve | Goal | NULL | Both | Both
Retrieve | GoalRollupQuery | NULL | Both | Both
Retrieve | Incident | NULL | Both | Both
Retrieve | IncidentResolution | NULL | Both | Both
Retrieve | InvalidDependency | NULL | Both | Server
Retrieve | Invoice | NULL | Both | Both
Retrieve | InvoiceDetail | NULL | Both | Both
Retrieve | KbArticle | NULL | Both | Both
Retrieve | KbArticleComment | NULL | Both | Both
Retrieve | KbArticleTemplate | NULL | Both | Both
Retrieve | Lead | NULL | Both | Both
Retrieve | LeadAddress | NULL | Both | Both
Retrieve | Letter | NULL | Both | Both
Retrieve | List | NULL | Both | Both
Retrieve | Metric | NULL | Both | Both
Retrieve | msdyn_PostAlbum | NULL | Both | Server
Retrieve | msdyn_PostConfig | NULL | Both | Server
Retrieve | msdyn_PostRuleConfig | NULL | Both | Server
Retrieve | msdyn_wallsavedquery | NULL | Both | Server
Retrieve | msdyn_wallsavedqueryusersettings | NULL | Both | Server
Retrieve | Opportunity | NULL | Both | Both
Retrieve | OpportunityClose | NULL | Both | Both
Retrieve | OpportunityProduct | NULL | Both | Both
Retrieve | OrderClose | NULL | Both | Both
Retrieve | PhoneCall | NULL | Both | Both
Retrieve | Post | NULL | Both | Server
Retrieve | PostComment | NULL | Both | Server
Retrieve | PostFollow | NULL | Both | Server
Retrieve | PostLike | NULL | Both | Server
Retrieve | PriceLevel | NULL | Both | Both
Retrieve | ProcessSession | NULL | Both | Both
Retrieve | Product | NULL | Both | Both
Retrieve | ProductPriceLevel | NULL | Both | Both
Retrieve | Publisher | NULL | Both | Both
Retrieve | PublisherAddress | NULL | Both | Server
Retrieve | Queue | NULL | Both | Both
Retrieve | Quote | NULL | Both | Both
Retrieve | QuoteClose | NULL | Both | Both
Retrieve | QuoteDetail | NULL | Both | Both
Retrieve | RecurringAppointmentMaster | NULL | Both | Both
Retrieve | RollupField | NULL | Both | Both
Retrieve | SalesLiterature | NULL | Both | Both
Retrieve | SalesLiteratureItem | NULL | Both | Both
Retrieve | SalesOrder | NULL | Both | Both
Retrieve | SalesOrderDetail | NULL | Both | Both
Retrieve | SavedQuery | NULL | Both | Both
Retrieve | SavedQueryVisualization | NULL | Both | Both
Retrieve | Service | NULL | Both | Both
Retrieve | ServiceAppointment | NULL | Both | Both
Retrieve | SharePointDocument | NULL | Both | Both
Retrieve | SharePointDocumentLocation | NULL | Both | Server
Retrieve | SharePointSite | NULL | Both | Server
Retrieve | Site | NULL | Both | Both
Retrieve | SocialActivity | NULL | Both | Both
Retrieve | SocialProfile | NULL | Both | Both
Retrieve | Solution | NULL | Both | Both
Retrieve | SolutionComponent | NULL | Both | Both
Retrieve | Subject | NULL | Both | Both
Retrieve | Task | NULL | Both | Both
Retrieve | Team | NULL | Both | Both
Retrieve | Template | NULL | Both | Both
Retrieve | Territory | NULL | Both | Both
Retrieve | UoM | NULL | Both | Both
Retrieve | UoMSchedule | NULL | Both | Both
Retrieve | UserForm | NULL | Both | Both
Retrieve | UserQuery | NULL | Both | Both
Retrieve | UserQueryVisualization | NULL | Both | Both
Retrieve | WebResource | NULL | Both | Both
RetrieveExchangeRate | TransactionCurrency | NULL | Both | Both
RetrieveFilteredForms | SystemForm | NULL | Both | Both
RetrieveMultiple | Account | NULL | Both | Both
RetrieveMultiple | AccountLeads | NULL | Both | Both
RetrieveMultiple | ActivityMimeAttachment | NULL | Both | Both
RetrieveMultiple | ActivityParty | NULL | Both | Both
RetrieveMultiple | ActivityPointer | NULL | Both | Both
RetrieveMultiple | Annotation | NULL | Both | Both
RetrieveMultiple | Appointment | NULL | Both | Both
RetrieveMultiple | BusinessUnitNewsArticle | NULL | Both | Both
RetrieveMultiple | Calendar | NULL | Both | Both
RetrieveMultiple | Campaign | NULL | Both | Both
RetrieveMultiple | CampaignActivity | NULL | Both | Both
RetrieveMultiple | CampaignActivityItem | NULL | Both | Both
RetrieveMultiple | CampaignItem | NULL | Both | Both
RetrieveMultiple | CampaignResponse | NULL | Both | Both
RetrieveMultiple | Competitor | NULL | Both | Both
RetrieveMultiple | CompetitorProduct | NULL | Both | Both
RetrieveMultiple | CompetitorSalesLiterature | NULL | Both | Both
RetrieveMultiple | Connection | NULL | Both | Both
RetrieveMultiple | ConnectionRole | NULL | Both | Both
RetrieveMultiple | ConnectionRoleAssociation | NULL | Both | Both
RetrieveMultiple | ConnectionRoleObjectTypeCode | NULL | Both | Both
RetrieveMultiple | Contact | NULL | Both | Both
RetrieveMultiple | ContactInvoices | NULL | Both | Both
RetrieveMultiple | ContactLeads | NULL | Both | Both
RetrieveMultiple | ContactOrders | NULL | Both | Both
RetrieveMultiple | ContactQuotes | NULL | Both | Both
RetrieveMultiple | Contract | NULL | Both | Both
RetrieveMultiple | ContractDetail | NULL | Both | Both
RetrieveMultiple | ContractTemplate | NULL | Both | Both
RetrieveMultiple | CustomerAddress | NULL | Both | Both
RetrieveMultiple | CustomerOpportunityRole | NULL | Both | Both
RetrieveMultiple | CustomerRelationship | NULL | Both | Both
RetrieveMultiple | Dependency | NULL | Both | Server
RetrieveMultiple | Discount | NULL | Both | Both
RetrieveMultiple | DiscountType | NULL | Both | Both
RetrieveMultiple | Email | NULL | Both | Both
RetrieveMultiple | Entitlement | NULL | Both | Both
RetrieveMultiple | EntitlementChannel | NULL | Both | Both
RetrieveMultiple | EntitlementContacts | NULL | Both | Both
RetrieveMultiple | EntitlementProducts | NULL | Both | Both
RetrieveMultiple | EntitlementTemplate | NULL | Both | Both
RetrieveMultiple | EntitlementTemplateChannel | NULL | Both | Both
RetrieveMultiple | EntitlementTemplateProducts | NULL | Both | Both
RetrieveMultiple | Equipment | NULL | Both | Both
RetrieveMultiple | ExchangeSyncIdMapping | NULL | Both | Server
RetrieveMultiple | Fax | NULL | Both | Both
RetrieveMultiple | Goal | NULL | Both | Both
RetrieveMultiple | GoalRollupQuery | NULL | Both | Both
RetrieveMultiple | Incident | NULL | Both | Both
RetrieveMultiple | IncidentResolution | NULL | Both | Both
RetrieveMultiple | InvalidDependency | NULL | Both | Server
RetrieveMultiple | Invoice | NULL | Both | Both
RetrieveMultiple | InvoiceDetail | NULL | Both | Both
RetrieveMultiple | KbArticle | NULL | Both | Both
RetrieveMultiple | KbArticleComment | NULL | Both | Both
RetrieveMultiple | KbArticleTemplate | NULL | Both | Both
RetrieveMultiple | Lead | NULL | Both | Both
RetrieveMultiple | LeadAddress | NULL | Both | Both
RetrieveMultiple | LeadCompetitors | NULL | Both | Both
RetrieveMultiple | LeadProduct | NULL | Both | Both
RetrieveMultiple | Letter | NULL | Both | Both
RetrieveMultiple | License | NULL | Both | Both
RetrieveMultiple | List | NULL | Both | Both
RetrieveMultiple | ListMember | NULL | Both | Both
RetrieveMultiple | Metric | NULL | Both | Both
RetrieveMultiple | msdyn_PostAlbum | NULL | Both | Server
RetrieveMultiple | msdyn_PostConfig | NULL | Both | Server
RetrieveMultiple | msdyn_PostRuleConfig | NULL | Both | Server
RetrieveMultiple | msdyn_wallsavedquery | NULL | Both | Server
RetrieveMultiple | msdyn_wallsavedqueryusersettings | NULL | Both | Server
RetrieveMultiple | Opportunity | NULL | Both | Both
RetrieveMultiple | OpportunityClose | NULL | Both | Both
RetrieveMultiple | OpportunityCompetitors | NULL | Both | Both
RetrieveMultiple | OpportunityProduct | NULL | Both | Both
RetrieveMultiple | OrderClose | NULL | Both | Both
RetrieveMultiple | PhoneCall | NULL | Both | Both
RetrieveMultiple | Post | NULL | Both | Server
RetrieveMultiple | PostComment | NULL | Both | Server
RetrieveMultiple | PostFollow | NULL | Both | Server
RetrieveMultiple | PostLike | NULL | Both | Server
RetrieveMultiple | PriceLevel | NULL | Both | Both
RetrieveMultiple | ProcessSession | NULL | Both | Both
RetrieveMultiple | Product | NULL | Both | Both
RetrieveMultiple | ProductAssociation | NULL | Both | Both
RetrieveMultiple | ProductPriceLevel | NULL | Both | Both
RetrieveMultiple | ProductSalesLiterature | NULL | Both | Both
RetrieveMultiple | ProductSubstitute | NULL | Both | Both
RetrieveMultiple | Publisher | NULL | Both | Both
RetrieveMultiple | PublisherAddress | NULL | Both | Server
RetrieveMultiple | Queue | NULL | Both | Both
RetrieveMultiple | QueueMembership | NULL | Both | Both
RetrieveMultiple | Quote | NULL | Both | Both
RetrieveMultiple | QuoteClose | NULL | Both | Both
RetrieveMultiple | QuoteDetail | NULL | Both | Both
RetrieveMultiple | RecurrenceRule | NULL | Both | Both
RetrieveMultiple | RecurringAppointmentMaster | NULL | Both | Both
RetrieveMultiple | RolePrivileges | NULL | Both | Both
RetrieveMultiple | RollupField | NULL | Both | Both
RetrieveMultiple | SalesLiterature | NULL | Both | Both
RetrieveMultiple | SalesLiteratureItem | NULL | Both | Both
RetrieveMultiple | SalesOrder | NULL | Both | Both
RetrieveMultiple | SalesOrderDetail | NULL | Both | Both
RetrieveMultiple | SavedQuery | NULL | Both | Both
RetrieveMultiple | SavedQueryVisualization | NULL | Both | Both
RetrieveMultiple | Service | NULL | Both | Both
RetrieveMultiple | ServiceAppointment | NULL | Both | Both
RetrieveMultiple | ServiceContractContacts | NULL | Both | Both
RetrieveMultiple | SharePointDocument | NULL | Both | Both
RetrieveMultiple | SharePointDocumentLocation | NULL | Both | Server
RetrieveMultiple | SharePointSite | NULL | Both | Server
RetrieveMultiple | Site | NULL | Both | Both
RetrieveMultiple | SocialActivity | NULL | Both | Both
RetrieveMultiple | SocialProfile | NULL | Both | Both
RetrieveMultiple | Solution | NULL | Both | Both
RetrieveMultiple | SolutionComponent | NULL | Both | Both
RetrieveMultiple | Subject | NULL | Both | Both
RetrieveMultiple | SystemUserLicenses | NULL | Both | Both
RetrieveMultiple | SystemUserProfiles | NULL | Both | Server
RetrieveMultiple | SystemUserRoles | NULL | Both | Both
RetrieveMultiple | Task | NULL | Both | Both
RetrieveMultiple | Team | NULL | Both | Both
RetrieveMultiple | TeamMembership | NULL | Both | Both
RetrieveMultiple | TeamProfiles | NULL | Both | Server
RetrieveMultiple | TeamRoles | NULL | Both | Both
RetrieveMultiple | Template | NULL | Both | Both
RetrieveMultiple | Territory | NULL | Both | Both
RetrieveMultiple | UoM | NULL | Both | Both
RetrieveMultiple | UoMSchedule | NULL | Both | Both
RetrieveMultiple | UserEntityInstanceData | NULL | Both | Both
RetrieveMultiple | UserForm | NULL | Both | Both
RetrieveMultiple | UserQuery | NULL | Both | Both
RetrieveMultiple | UserQueryVisualization | NULL | Both | Both
RetrieveMultiple | UserSettings | NULL | Both | Both
RetrieveMultiple | WebResource | NULL | Both | Both
RetrievePersonalWall | NULL | NULL | Server | Server
RetrievePrincipalAccess | Account | NULL | Both | Both
RetrievePrincipalAccess | Annotation | NULL | Both | Both
RetrievePrincipalAccess | Appointment | NULL | Both | Both
RetrievePrincipalAccess | Campaign | NULL | Both | Both
RetrievePrincipalAccess | CampaignActivity | NULL | Both | Both
RetrievePrincipalAccess | CampaignResponse | NULL | Both | Both
RetrievePrincipalAccess | Connection | NULL | Both | Both
RetrievePrincipalAccess | Contact | NULL | Both | Both
RetrievePrincipalAccess | Contract | NULL | Both | Both
RetrievePrincipalAccess | CustomerOpportunityRole | NULL | Both | Both
RetrievePrincipalAccess | CustomerRelationship | NULL | Both | Both
RetrievePrincipalAccess | Email | NULL | Both | Both
RetrievePrincipalAccess | Entitlement | NULL | Both | Both
RetrievePrincipalAccess | Fax | NULL | Both | Both
RetrievePrincipalAccess | Goal | NULL | Both | Both
RetrievePrincipalAccess | GoalRollupQuery | NULL | Both | Both
RetrievePrincipalAccess | Incident | NULL | Both | Both
RetrievePrincipalAccess | IncidentResolution | NULL | Both | Both
RetrievePrincipalAccess | Invoice | NULL | Both | Both
RetrievePrincipalAccess | Lead | NULL | Both | Both
RetrievePrincipalAccess | Letter | NULL | Both | Both
RetrievePrincipalAccess | List | NULL | Both | Both
RetrievePrincipalAccess | msdyn_PostAlbum | NULL | Both | Server
RetrievePrincipalAccess | msdyn_wallsavedqueryusersettings | NULL | Both | Server
RetrievePrincipalAccess | Opportunity | NULL | Both | Both
RetrievePrincipalAccess | OpportunityClose | NULL | Both | Both
RetrievePrincipalAccess | OrderClose | NULL | Both | Both
RetrievePrincipalAccess | PhoneCall | NULL | Both | Both
RetrievePrincipalAccess | ProcessSession | NULL | Both | Both
RetrievePrincipalAccess | Queue | NULL | Both | Both
RetrievePrincipalAccess | Quote | NULL | Both | Both
RetrievePrincipalAccess | QuoteClose | NULL | Both | Both
RetrievePrincipalAccess | RecurringAppointmentMaster | NULL | Both | Both
RetrievePrincipalAccess | SalesOrder | NULL | Both | Both
RetrievePrincipalAccess | ServiceAppointment | NULL | Both | Both
RetrievePrincipalAccess | SharePointDocumentLocation | NULL | Both | Both
RetrievePrincipalAccess | SharePointSite | NULL | Both | Both
RetrievePrincipalAccess | SocialActivity | NULL | Both | Both
RetrievePrincipalAccess | SocialProfile | NULL | Both | Both
RetrievePrincipalAccess | Task | NULL | Both | Both
RetrievePrincipalAccess | Template | NULL | Both | Both
RetrievePrincipalAccess | UserForm | NULL | Both | Both
RetrievePrincipalAccess | UserQuery | NULL | Both | Both
RetrievePrincipalAccess | UserQueryVisualization | NULL | Both | Both
RetrieveRecordWall | NULL | NULL | Server | Server
RetrieveSharedPrincipalsAndAccess | Account | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Annotation | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Appointment | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Campaign | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | CampaignActivity | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | CampaignResponse | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Connection | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Contact | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Contract | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | CustomerOpportunityRole | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | CustomerRelationship | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Email | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Entitlement | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Fax | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Goal | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | GoalRollupQuery | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Incident | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | IncidentResolution | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Invoice | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Lead | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Letter | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | List | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | msdyn_PostAlbum | NULL | Both | Server
RetrieveSharedPrincipalsAndAccess | msdyn_wallsavedqueryusersettings | NULL | Both | Server
RetrieveSharedPrincipalsAndAccess | Opportunity | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | OpportunityClose | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | OrderClose | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | PhoneCall | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | ProcessSession | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Queue | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Quote | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | QuoteClose | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | RecurringAppointmentMaster | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | SalesOrder | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | ServiceAppointment | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | SharePointDocumentLocation | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | SharePointSite | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | SocialActivity | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | SocialProfile | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Task | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | Template | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | UserForm | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | UserQuery | NULL | Both | Both
RetrieveSharedPrincipalsAndAccess | UserQueryVisualization | NULL | Both | Both
RetrieveUnpublished | WebResource | NULL | Server | Server
RetrieveUnpublishedMultiple | WebResource | NULL | Server | Server
RetrieveUserQueues | Queue | NULL | Both | Both
RevokeAccess | Account | NULL | Server | Server
RevokeAccess | Annotation | NULL | Server | Server
RevokeAccess | Appointment | NULL | Server | Server
RevokeAccess | Campaign | NULL | Server | Server
RevokeAccess | CampaignActivity | NULL | Server | Server
RevokeAccess | CampaignResponse | NULL | Server | Server
RevokeAccess | Connection | NULL | Server | Server
RevokeAccess | Contact | NULL | Server | Server
RevokeAccess | Contract | NULL | Server | Server
RevokeAccess | CustomerOpportunityRole | NULL | Server | Server
RevokeAccess | CustomerRelationship | NULL | Server | Server
RevokeAccess | Email | NULL | Server | Server
RevokeAccess | Entitlement | NULL | Server | Server
RevokeAccess | Fax | NULL | Server | Server
RevokeAccess | Goal | NULL | Server | Server
RevokeAccess | GoalRollupQuery | NULL | Server | Server
RevokeAccess | Incident | NULL | Server | Server
RevokeAccess | IncidentResolution | NULL | Server | Server
RevokeAccess | Invoice | NULL | Server | Server
RevokeAccess | Lead | NULL | Server | Server
RevokeAccess | Letter | NULL | Server | Server
RevokeAccess | List | NULL | Server | Server
RevokeAccess | msdyn_PostAlbum | NULL | Server | Server
RevokeAccess | msdyn_wallsavedqueryusersettings | NULL | Server | Server
RevokeAccess | Opportunity | NULL | Server | Server
RevokeAccess | OpportunityClose | NULL | Server | Server
RevokeAccess | OrderClose | NULL | Server | Server
RevokeAccess | PhoneCall | NULL | Server | Server
RevokeAccess | ProcessSession | NULL | Server | Server
RevokeAccess | Queue | NULL | Server | Server
RevokeAccess | Quote | NULL | Server | Server
RevokeAccess | QuoteClose | NULL | Server | Server
RevokeAccess | RecurringAppointmentMaster | NULL | Server | Server
RevokeAccess | SalesOrder | NULL | Server | Server
RevokeAccess | ServiceAppointment | NULL | Server | Server
RevokeAccess | SharePointDocumentLocation | NULL | Server | Server
RevokeAccess | SharePointSite | NULL | Server | Server
RevokeAccess | SocialActivity | NULL | Server | Server
RevokeAccess | SocialProfile | NULL | Server | Server
RevokeAccess | Task | NULL | Server | Server
RevokeAccess | Template | NULL | Server | Server
RevokeAccess | UserForm | NULL | Server | Server
RevokeAccess | UserQuery | NULL | Server | Server
RevokeAccess | UserQueryVisualization | NULL | Server | Server
Route | Appointment | NULL | Both | Both
Route | CampaignActivity | NULL | Both | Both
Route | CampaignResponse | NULL | Both | Both
Route | Email | NULL | Both | Both
Route | Fax | NULL | Both | Both
Route | Incident | NULL | Both | Both
Route | Letter | NULL | Both | Both
Route | PhoneCall | NULL | Both | Both
Route | RecurringAppointmentMaster | NULL | Both | Both
Route | ServiceAppointment | NULL | Both | Both
Route | Task | NULL | Both | Both
RouteTo | QueueItem | NULL | Both | Both
Send | Email | NULL | Both | Both
Send | Fax | NULL | Both | Both
Send | Template | NULL | Both | Both
SendFromTemplate | Email | NULL | Server | Server
SetRelated | Invoice | Contact | Both | Both
SetRelated | Lead | Account | Both | Both
SetRelated | Lead | Contact | Both | Both
SetRelated | Opportunity | Account | Both | Both
SetRelated | Opportunity | Contact | Both | Both
SetRelated | Opportunity | Competitor | Both | Both
SetRelated | Product | Lead | Both | Both
SetRelated | Product | Competitor | Both | Both
SetRelated | Quote | Contact | Both | Both
SetRelated | SalesLiterature | Competitor | Both | Both
SetRelated | SalesLiterature | Product | Both | Both
SetRelated | SalesOrder | Contact | Both | Both
SetState | Account | NULL | Both | Both
SetState | Appointment | NULL | Both | Both
SetState | BusinessUnit | NULL | Both | Server
SetState | Campaign | NULL | Both | Both
SetState | CampaignActivity | NULL | Both | Both
SetState | CampaignResponse | NULL | Both | Both
SetState | Connection | NULL | Both | Both
SetState | ConnectionRole | NULL | Both | Both
SetState | Contact | NULL | Both | Both
SetState | Contract | NULL | Both | Both
SetState | ContractDetail | NULL | Both | Both
SetState | DiscountType | NULL | Both | Both
SetState | Email | NULL | Both | Both
SetState | EmailServerProfile | NULL | Both | Server
SetState | Entitlement | NULL | Both | Both
SetState | Fax | NULL | Both | Both
SetState | Incident | NULL | Both | Both
SetState | IncidentResolution | NULL | Both | Both
SetState | Invoice | NULL | Both | Both
SetState | KbArticle | NULL | Both | Both
SetState | Lead | NULL | Both | Both
SetState | Letter | NULL | Both | Both
SetState | List | NULL | Both | Both
SetState | msdyn_PostAlbum | NULL | Both | Server
SetState | msdyn_PostConfig | NULL | Both | Server
SetState | msdyn_PostRuleConfig | NULL | Both | Server
SetState | msdyn_wallsavedquery | NULL | Both | Server
SetState | msdyn_wallsavedqueryusersettings | NULL | Both | Server
SetState | Opportunity | NULL | Both | Both
SetState | OpportunityClose | NULL | Both | Both
SetState | OrderClose | NULL | Both | Both
SetState | PhoneCall | NULL | Both | Both
SetState | PriceLevel | NULL | Both | Both
SetState | Product | NULL | Both | Both
SetState | Queue | NULL | Both | Both
SetState | QueueItem | NULL | Both | Both
SetState | Quote | NULL | Both | Both
SetState | QuoteClose | NULL | Both | Both
SetState | RecurringAppointmentMaster | NULL | Both | Both
SetState | SalesOrder | NULL | Both | Both
SetState | ServiceAppointment | NULL | Both | Both
SetState | SharePointDocumentLocation | NULL | Both | Both
SetState | SharePointSite | NULL | Both | Both
SetState | SocialActivity | NULL | Both | Both
SetState | SocialProfile | NULL | Both | Both
SetState | SystemUser | NULL | Both | Server
SetState | Task | NULL | Both | Both
SetState | TransactionCurrency | NULL | Both | Server
SetState | UserQuery | NULL | Both | Both
SetStateDynamicEntity | Account | NULL | Both | Both
SetStateDynamicEntity | Appointment | NULL | Both | Both
SetStateDynamicEntity | BusinessUnit | NULL | Both | Server
SetStateDynamicEntity | Campaign | NULL | Both | Both
SetStateDynamicEntity | CampaignActivity | NULL | Both | Both
SetStateDynamicEntity | CampaignResponse | NULL | Both | Both
SetStateDynamicEntity | Connection | NULL | Both | Both
SetStateDynamicEntity | ConnectionRole | NULL | Both | Both
SetStateDynamicEntity | Contact | NULL | Both | Both
SetStateDynamicEntity | Contract | NULL | Both | Both
SetStateDynamicEntity | ContractDetail | NULL | Both | Both
SetStateDynamicEntity | DiscountType | NULL | Both | Both
SetStateDynamicEntity | Email | NULL | Both | Both
SetStateDynamicEntity | Entitlement | NULL | Both | Both
SetStateDynamicEntity | Fax | NULL | Both | Both
SetStateDynamicEntity | Goal | NULL | Both | Server
SetStateDynamicEntity | GoalRollupQuery | NULL | Both | Server
SetStateDynamicEntity | Incident | NULL | Both | Both
SetStateDynamicEntity | IncidentResolution | NULL | Both | Both
SetStateDynamicEntity | Invoice | NULL | Both | Both
SetStateDynamicEntity | KbArticle | NULL | Both | Both
SetStateDynamicEntity | Lead | NULL | Both | Both
SetStateDynamicEntity | Letter | NULL | Both | Both
SetStateDynamicEntity | List | NULL | Both | Both
SetStateDynamicEntity | Metric | NULL | Both | Server
SetStateDynamicEntity | msdyn_PostAlbum | NULL | Both | Server
SetStateDynamicEntity | msdyn_PostConfig | NULL | Both | Server
SetStateDynamicEntity | msdyn_PostRuleConfig | NULL | Both | Server
SetStateDynamicEntity | msdyn_wallsavedquery | NULL | Both | Server
SetStateDynamicEntity | msdyn_wallsavedqueryusersettings | NULL | Both | Server
SetStateDynamicEntity | Opportunity | NULL | Both | Both
SetStateDynamicEntity | OpportunityClose | NULL | Both | Both
SetStateDynamicEntity | OrderClose | NULL | Both | Both
SetStateDynamicEntity | PhoneCall | NULL | Both | Both
SetStateDynamicEntity | PriceLevel | NULL | Both | Both
SetStateDynamicEntity | ProcessSession | NULL | Both | Both
SetStateDynamicEntity | Product | NULL | Both | Both
SetStateDynamicEntity | Queue | NULL | Both | Both
SetStateDynamicEntity | QueueItem | NULL | Both | Both
SetStateDynamicEntity | Quote | NULL | Both | Both
SetStateDynamicEntity | QuoteClose | NULL | Both | Both
SetStateDynamicEntity | RecurringAppointmentMaster | NULL | Both | Both
SetStateDynamicEntity | SalesOrder | NULL | Both | Both
SetStateDynamicEntity | SavedQuery | NULL | Both | Server
SetStateDynamicEntity | ServiceAppointment | NULL | Both | Both
SetStateDynamicEntity | SharePointDocumentLocation | NULL | Both | Both
SetStateDynamicEntity | SharePointSite | NULL | Both | Both
SetStateDynamicEntity | SocialActivity | NULL | Both | Both
SetStateDynamicEntity | SocialProfile | NULL | Both | Both
SetStateDynamicEntity | SystemUser | NULL | Both | Server
SetStateDynamicEntity | Task | NULL | Both | Both
SetStateDynamicEntity | TransactionCurrency | NULL | Both | Server
SetStateDynamicEntity | UoMSchedule | NULL | Both | Both
SetStateDynamicEntity | UserQuery | NULL | Both | Both
TriggerServiceEndpointCheck | ServiceEndpoint | NULL | Server | Server
UnlockInvoicePricing | NULL | NULL | Server | Server
UnlockSalesOrderPricing | NULL | NULL | Server | Server
Update | Account | NULL | Both | Both
Update | ActivityMimeAttachment | NULL | Both | Both
Update | Annotation | NULL | Both | Both
Update | Appointment | NULL | Both | Both
Update | BusinessUnit | NULL | Both | Server
Update | BusinessUnitNewsArticle | NULL | Both | Both
Update | Calendar | NULL | Both | Both
Update | Campaign | NULL | Both | Both
Update | CampaignActivity | NULL | Both | Both
Update | CampaignResponse | NULL | Both | Both
Update | Competitor | NULL | Both | Both
Update | Connection | NULL | Both | Both
Update | ConnectionRole | NULL | Both | Both
Update | Contact | NULL | Both | Both
Update | Contract | NULL | Both | Both
Update | ContractDetail | NULL | Both | Both
Update | ContractTemplate | NULL | Both | Server
Update | CustomerAddress | NULL | Both | Both
Update | CustomerOpportunityRole | NULL | Both | Both
Update | CustomerRelationship | NULL | Both | Both
Update | Discount | NULL | Both | Both
Update | DiscountType | NULL | Both | Both
Update | Email | NULL | Both | Both
Update | Entitlement | NULL | Both | Both
Update | EntitlementChannel | NULL | Both | Server
Update | EntitlementTemplate | NULL | Both | Server
Update | EntitlementTemplateChannel | NULL | Both | Server
Update | Equipment | NULL | Both | Server
Update | ExchangeSyncIdMapping | NULL | Both | Server
Update | Fax | NULL | Both | Both
Update | FieldPermission | NULL | Both | Server
Update | FieldSecurityProfile | NULL | Both | Server
Update | Goal | NULL | Both | Server
Update | GoalRollupQuery | NULL | Both | Server
Update | Incident | NULL | Both | Both
Update | IncidentResolution | NULL | Both | Both
Update | Invoice | NULL | Both | Both
Update | InvoiceDetail | NULL | Both | Both
Update | KbArticle | NULL | Both | Both
Update | KbArticleComment | NULL | Both | Both
Update | KbArticleTemplate | NULL | Both | Both
Update | Lead | NULL | Both | Both
Update | Letter | NULL | Both | Both
Update | List | NULL | Both | Both
Update | Metric | NULL | Both | Server
Update | msdyn_PostAlbum | NULL | Both | Server
Update | msdyn_PostConfig | NULL | Both | Server
Update | msdyn_PostRuleConfig | NULL | Both | Server
Update | msdyn_wallsavedquery | NULL | Both | Server
Update | msdyn_wallsavedqueryusersettings | NULL | Both | Server
Update | Opportunity | NULL | Both | Both
Update | OpportunityClose | NULL | Both | Both
Update | OpportunityProduct | NULL | Both | Both
Update | OrderClose | NULL | Both | Both
Update | Organization | NULL | Both | Server
Update | PhoneCall | NULL | Both | Both
Update | PriceLevel | NULL | Both | Both
Update | PrincipalObjectAttributeAccess | NULL | Both | Server
Update | ProcessSession | NULL | Both | Both
Update | Product | NULL | Both | Both
Update | ProductPriceLevel | NULL | Both | Both
Update | Queue | NULL | Both | Server
Update | QueueItem | NULL | Both | Both
Update | Quote | NULL | Both | Both
Update | QuoteClose | NULL | Both | Both
Update | QuoteDetail | NULL | Both | Both
Update | RecurrenceRule | NULL | Both | Server
Update | RecurringAppointmentMaster | NULL | Both | Both
Update | Role | NULL | Both | Server
Update | RollupField | NULL | Both | Server
Update | SalesLiterature | NULL | Both | Both
Update | SalesLiteratureItem | NULL | Both | Both
Update | SalesOrder | NULL | Both | Both
Update | SalesOrderDetail | NULL | Both | Both
Update | Service | NULL | Both | Server
Update | ServiceAppointment | NULL | Both | Both
Update | SharePointDocumentLocation | NULL | Both | Server
Update | SharePointSite | NULL | Both | Server
Update | Site | NULL | Both | Server
Update | SocialActivity | NULL | Both | Both
Update | SocialProfile | NULL | Both | Both
Update | Subject | NULL | Both | Both
Update | SystemUser | NULL | Both | Server
Update | Task | NULL | Both | Both
Update | Team | NULL | Both | Server
Update | Template | NULL | Both | Both
Update | Territory | NULL | Both | Server
Update | TransactionCurrency | NULL | Both | Server
Update | UoM | NULL | Both | Both
Update | UoMSchedule | NULL | Both | Both
Update | UserForm | NULL | Both | Server
Update | UserQuery | NULL | Both | Both
Update | UserQueryVisualization | NULL | Both | Both
Update | WebResource | NULL | Both | Server
ValidateRecurrenceRule | RecurrenceRule | NULL | Both | Both
Win | Opportunity | NULL | Both | Both
Win | Quote | NULL | Both | Both

See Also

Other Resources

Write plug-ins to extend business processes
Plug-in development
Introduction to the event framework

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Plug-in development

A plug-in is custom business logic (code) that you can integrate with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update to modify or augment the standard behavior of the platform. Another way to think about plug-ins is that they are handlers for events fired by Microsoft Dynamics CRM. You can subscribe, or register, a plug-in to a known set of events to have your code run when the event occurs.

For more information about plug-in run-time execution, see Event execution pipeline.

In This Section

Write a plug-in

Understand the data context passed to a plug-in

Handle exceptions in plug-ins

Pass data between plug-ins

Impersonation in plug-ins

Register and Deploy Plug-Ins

Debug a plug-In

Analyze plug-in performance

Walkthrough: Register a plug-in using the plug-in registration tool

Walkthrough: Configure assembly security for an offline plug-in

Sample: Basic plug-in

Sample: Web access from a sandboxed plug-in

Related Sections

Write plug-ins to extend business processes

Event execution pipeline

Authenticate users with Microsoft Dynamics CRM web services

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write a plug-in

Plug-ins are custom classes that implement the IPlugin interface. You can write a plug-in in any .NET Framework 4.5.2 CLR-compliant language such as Microsoft Visual C# and Microsoft Visual Basic .NET. To be able to compile plug-in code, you must add Microsoft.Xrm.Sdk.dll and Microsoft.Crm.Sdk.Proxy.dll assembly references to your project. These assemblies can be found in the SDK\Bin folder of the SDK. Download the Microsoft Dynamics CRM SDK package.

In This Topic

Plug-in design

Writing a Basic Plug-in

Write a Plug-in Constructor

Support Offline Execution

Web Access for Isolated (sandboxed) Plug-ins

Use Early-Bound Types

Plug-in Assemblies

Plug-in design

Your plug-in design should take into account the web application auto-save feature introduced in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Auto-save is enabled by default but can be disabled at an organization level. When auto-save is enabled there is no Save button. The web application will save data in the form automatically 30 seconds after the last unsaved change. You can apply form scripts to disable the auto-save behaviors on a form level. Depending on how you registered your plug-in, auto-save may result in your plug-in being called more frequently for individual field changes instead of one plug-in invocation for all changes. You should assume that any user can save any record at any time, whether this is done using Ctrl+S, by pressing a save button, or automatically due to the auto-save feature.

It is a best practice to register your plug-in or workflow on entities and specific fields that matter most. Avoid registering a plug-in or workflow for changes to all entity fields. If you have an existing plug-or workflow that was implemented before the availability of the auto save feature, you should re-test that code to verify its proper operation. For more information see the customization guide topic Manage auto-save.

Writing a Basic Plug-in

The following sample shows some of the common code found in a plug-in. For this sample, the code omits any custom business logic that would perform the intended task of the plug-in. However, the code does show a plug-in class that implements the IPlugin interface and the required Execute method.

C# Copy Code
using System;
using System.ServiceModel;
using Microsoft.Xrm.Sdk;

public class MyPlugin: IPlugin
{
    public void Execute(IServiceProvider serviceProvider)
    {
        // Extract the tracing service for use in debugging sandboxed plug-ins.
        // If you are not registering the plug-in in the sandbox, then you do
        // not have to add any tracing service related code.
        ITracingService tracingService =
            (ITracingService)serviceProvider.GetService(typeof(ITracingService));

        // Obtain the execution context from the service provider.
        IPluginExecutionContext context = (IPluginExecutionContext)
            serviceProvider.GetService(typeof(IPluginExecutionContext));

        // The InputParameters collection contains all the data passed in the message request.
        if (context.InputParameters.Contains("Target") &&
            context.InputParameters["Target"] is Entity)
        {
            // Obtain the target entity from the input parameters.
            Entity entity = (Entity)context.InputParameters["Target"];

            // Verify that the target entity represents an entity type you are expecting.
            // For example, an account. If not, the plug-in was not registered correctly.
            if (entity.LogicalName != "account")
                return;

            // Obtain the organization service reference which you will need for
            // web service calls.
            IOrganizationServiceFactory serviceFactory =
                (IOrganizationServiceFactory)serviceProvider.GetService(typeof(IOrganizationServiceFactory));
            IOrganizationService service = serviceFactory.CreateOrganizationService(context.UserId);

            try
            {
                // Plug-in business logic goes here.
            }

            catch (FaultException<OrganizationServiceFault> ex)
            {
                throw new InvalidPluginExecutionException("An error occurred in MyPlug-in.", ex);
            }

            catch (Exception ex)
            {
                tracingService.Trace("MyPlugin: {0}", ex.ToString());
                throw;
            }
        }
    }
}

The IServiceProvider parameter of the Execute method is a container for several service useful objects that can be accessed within a plug-in. The service provider contains instance references to the execution context, IOrganizationServiceFactory, ITracingService, and more. The sample code demonstrates how to obtain references to the execution context, IOrganizationService, and ITracingService from the service provider parameter. For more information about the tracing service, refer to Debug a plug-In.

The execution context contains a wealth of information about the event that caused the plug-in to execute and the data contained in the message that is currently being processed by the pipeline. For more information about the data context, see Understand the data context passed to a plug-in.

The platform provides the correct Web service URLs and network credentials when you obtain the organization Web service reference from the service provider. Instantiating your own Web service proxy is not supported because it creates deadlock and authentication issues. After you have the organization service reference, you can use it to make method calls to the organization Web service. You can retrieve or change business data in a single Microsoft Dynamics CRM organization by issuing one or more message requests to the Web service. For more information about message requests, see Use messages (request and response classes) with the Execute method.

A typical plug-in should access the information in the context, perform the required business operations, and handle exceptions. For more information about handling exceptions in a plug-in, refer to Handle exceptions in plug-ins. A more complete plug-in sample is available in the topic Sample: Basic plug-in.

Important
For improved performance, Microsoft Dynamics CRM caches plug-in instances. The plug-in's Execute method should be written to be stateless because the constructor is not called for every invocation of the plug-in. Also, multiple system threads could execute the plug-in at the same time. All per invocation state information is stored in the context, so you should not use global variables or attempt to store any data in member variables for use during the next plug-in invocation unless that data was obtained from the configuration parameter provided to the constructor. Changes to a plug-ins registration will cause the plug-in to be re-initialized.

Write a Plug-in Constructor

The Microsoft Dynamics CRM platform supports an optional plug-in constructor that accepts either one or two string parameters. If you write a constructor like this, you can pass any strings of information to the plug-in at run time.

The following sample shows the format of the constructor. In this example, the plug-in class is named SamplePlugin.

C# Copy Code
public SamplePlugin()
public SamplePlugin(string unsecure)
public SamplePlugin(string unsecure, string secure)

The first string parameter of the constructor contains public (unsecure) information. The second string parameter contains non-public (secure) information. In this discussion, secure refers to an encrypted value while unsecure is an unencrypted value. When using Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access, the secure string is not passed to a plug-in that executes while CRM for Outlook is offline.

The information that is passed to the plug-in constructor in these strings is specified when the plug-in is registered with Microsoft Dynamics CRM. When using the Plug-in Registration tool to register a plug-in, you can enter secure and unsecure information in the Secure Configuration and Unsecure Configuration fields provided in the Register New Step form. When registering a plug-in programmatically using the Microsoft Dynamics CRM SDK, SdkMessageProcessingStep.Configuration contains the unsecure value and SdkMessageProcessingStep.SecureConfigId refers to a SdkMessageProcessingStepSecureConfig record that contains the secure value.

Support Offline Execution

You can register plug-ins to execute in online mode, offline mode, or both. Offline mode is only supported on Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access. Your plug-in code can check whether it is executing in offline mode by checking the IsExecutingOffline property.

When you design a plug-in that will be registered for both online and offline execution, remember that the plug-in can execute twice. The first time is while Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is offline. The plug-in executes again when CRM for Outlook goes online and synchronization between CRM for Outlook and the Microsoft Dynamics CRM server occurs. You can check the IsOfflinePlayback property to determine if the plug-in is executing because of this synchronization.

Web Access for Isolated (sandboxed) Plug-ins

If you plan on registering your plug-in in the sandbox, you can still access Web addresses from your plug-in code. You can use any .NET Framework class in your plug-in code that provides Web access within the Web access restrictions outlined Plug-in isolation, trusts, and statistics. For example, the following plug-in code downloads a Web page.

C# Copy Code
// Download the target URI using a Web client. Any .NET class that uses the
// HTTP or HTTPS protocols and a DNS lookup should work.
using (WebClient client = new WebClient())
{
    byte[] responseBytes = client.DownloadData(webAddress);
    string response = Encoding.UTF8.GetString(responseBytes);
Security Note
For sandboxed plug-ins to be able to access external Web services, the server where the Sandbox Processing Service role is installed must be exposed to the Internet, and the account that the sandbox service runs under must have Internet access. Only outbound connections on ports 80 and 443 are required. Inbound connection access is not required. Use the Windows Firewall control panel to enable outbound connections for the Microsoft.Crm.Sandbox.WorkerProcess application located on the server in the %PROGRAMFILES%\Microsoft Dynamics CRM\Server\bin folder.

Use Early-Bound Types

To use early-bound Microsoft Dynamics CRM types in your plug-in code simply include the types file, generated using the CrmSvcUtil program, in your Microsoft Visual Studio plug-in project.

Conversion of a late-bound entity to an early-bound entity is handled as follows:

C# Copy Code
Account acct = entity.ToEntity<Account>();

In the previous line of code, the acct variable is an early-bound type. All Entity values that are assigned to IPluginExecutionContext must be late-bound types. If an early-bound type is assigned to the context, a SerializationException will occur. For more information, see Understand the data context passed to a plug-in. Make sure that you do not mix your types and use an early bound type where a late-bound type is called for as shown in the following code.

C# Copy Code
context.InputParameters["Target"] = new Account() { Name = "MyAccount" }; // WRONG: Do not do this.

In the example above, you do not want to store an early-bound instance in the plug-in context where a late-bound instance should go. This is to avoid requiring the platform to convert between early-bound and late bound types before calling a plug-in and when returning from the plug-in to the platform.

Plug-in Assemblies

There can be one or more plug-in types in an assembly. After the plug-in assembly is registered and deployed, plug-ins can perform their intended operation in response to a Microsoft Dynamics CRM run-time event.

Security Note
In Microsoft Dynamics CRM, plug-in assemblies must be readable by everyone to work correctly. Therefore, it is a security best practice to develop plug-in code that does not contain any system logon information, confidential information, or company trade secrets.

Each plug-in assembly must be signed, either by using the Signing tab of the project's properties sheet in Microsoft Visual Studio or the Strong Name tool, before being registered and deployed to Microsoft Dynamics CRM. For more information about the Strong Name tool, run the sn.exe program, without any arguments, from a Microsoft Visual Studio Command Prompt window.

If your assembly contains a plug-in that can execute while the CRM for Outlook is offline, there is additional security that the Microsoft Dynamics CRM platform imposes on assemblies. For more information, see Walkthrough: Configure assembly security for an offline plug-in.

See Also

Reference

Run the Code Generation Utility

Concepts

Understand the data context passed to a plug-in
Write a custom Azure-aware plug-in
Register and Deploy Plug-Ins
Handle exceptions in plug-ins

Other Resources

Plug-in development
Sample: Basic plug-in
Sample: Web access from a sandboxed plug-in
Blog: Using Plug-Ins To Modify Views

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Understand the data context passed to a plug-in

When a plug-in is run in response to an execution pipeline event for which it is registered, the plug-in’s Execute method is called. That method passes an IServiceProvider object as a parameter, which contains a number of useful objects. The following sections describe some of the information that is passed to a plug-in when executed.

In This Topic

Access the plug-in execution context

Access the Organization service

Access the Notification service

Input and output parameters

Pre and post entity images

Access the plug-in execution context

IPluginExecutionContext contains information that describes the run-time environment that the plug-in executes, information related to the execution pipeline, and entity business information. The context is contained in the System.IServiceProvider parameter that is passed at run time to a plug-in through its Execute method.

C# Copy Code
// Obtain the execution context from the service provider.
IPluginExecutionContext context = (IPluginExecutionContext)
    serviceProvider.GetService(typeof(IPluginExecutionContext));

When a system event is fired that a plug-in is registered for, the system creates and populates the context and passes it to a plug-in through the previously mentioned classes and methods. The execution context is passed to each registered plug-in in the pipeline when they are executed. Each plug-in in the execution pipeline is able to modify writable properties in the context. For example, given a plug-in registered for a pre-event and another plug-in registered for a post-event, the post-event plug-in can receive a context that has been modified by the pre-event plug-in. The same situation applies to plug-ins that are registered within the same stage.

All the properties in IPluginExecutionContext are read-only. However, your plug-in can modify the contents of those properties that are collections. For more information about infinite loop prevention, see Depth.

Access the Organization service

To access the Microsoft Dynamics CRM organization service, it is required that plug-in code create an instance of the service through the ServiceProvider.GetService method.

C# Copy Code
// Obtain the organization service reference.
IOrganizationServiceFactory serviceFactory = (IOrganizationServiceFactory)serviceProvider.GetService(typeof(IOrganizationServiceFactory));
IOrganizationService service = serviceFactory.CreateOrganizationService(context.UserId);

The platform provides the correct web service URLs and network credentials for you when you use this method. Instantiating your own Web service proxy is not supported as it will create deadlock and authentication issues.

Access the Notification service

Synchronous registered plug-ins can post the execution context to the Microsoft Azure Service Bus. The service provider object that is passed to the plug-in contains a reference to IServiceEndpointNotificationService. It is through that notification service that synchronous plug-ins can send brokered messages to the Microsoft Azure Service Bus. For more information about Microsoft Azure, see Azure integration with Microsoft Dynamics CRM. For more information about writing a plug-in that can post to the Microsoft Azure Service Bus, see Write a custom Azure-aware plug-in.

Input and output parameters

The InputParameters property contains the data that is in the request message currently being processed by the event execution pipeline. Your plug-in code can access this data. The property is of type ParameterCollection where the keys to access the request data are the names of the actual public properties in the request. As an example, take a look at CreateRequest. One property of CreateRequest is named Target, which is of type Entity. This is the entity currently being operated upon by the platform. To access the data of the entity you would use the name “Target” as the key in the input parameter collection. You also need to cast the returned instance.

C# Copy Code
// The InputParameters collection contains all the data passed in the message request.
if (context.InputParameters.Contains("Target") &&
    context.InputParameters["Target"] is Entity)
{
    // Obtain the target entity from the input parameters.
    Entity entity = (Entity)context.InputParameters["Target"];

Note that not all requests contain a Target property that is of type Entity, so you have to look at each request or response. For example, DeleteRequest has a Target property, but its type is EntityReference. The preceding code example would be changed as follows.

C# Copy Code
// The InputParameters collection contains all the data passed in the message request.
if (context.InputParameters.Contains("Target") &&    context.InputParameters["Target"] is EntityReference)
{
    // Obtain the target entity from the input parameters.
    EntityReference entity = (EntityReference)context.InputParameters["Target"];
}

Similarly, the OutputParameters property contains the data that is in the response message, for example CreateResponse, currently being passed through the event execution pipeline. However, only synchronous post-event and asynchronous registered plug-ins have OutputParameters populated as the response is the result of the core platform operation. The property is of type ParameterCollection where the keys to access the response data are the names of the actual public properties in the response.

Pre and post entity images

PreEntityImages and PostEntityImages contain snapshots of the primary entity's attributes before (pre) and after (post) the core platform operation. Microsoft Dynamics CRM populates the pre-entity and post-entity images based on the security privileges of the impersonated system user. Only entity attributes that are set to a value or are null are available in the pre or post entity images. You can specify to have the platform populate these PreEntityImages and PostEntityImages properties when you register your plug-in. The entity alias value you specify during plug-in registration is used as the key into the image collection in your plug-in code.

There are some events where images aren’t available. For example, only synchronous post-event and asynchronous registered plug-ins have PostEntityImages populated. The create operation doesn’t support a pre-image and a delete operation doesn’t support a post-image. In addition, only a small subset of messages support pre and post images as shown in the following table.

Message Request | Property | Description
AssignRequest | Target | The assigned entity.
CreateRequest | Target | The created entity.
DeleteRequest | Target | The deleted entity.
DeliverIncomingEmailRequest | EmailId | The delivered email ID.
DeliverPromoteEmailRequest | EmailId | The delivered email ID.
ExecuteWorkflowRequest | Target | The workflow entity.
MergeRequest | Target | The parent entity, into which the data from the child entity is being merged.
MergeRequest | SubordinateId | The child entity that is being merged into the parent entity.
SendEmailRequest | EmailId | The sent entity ID.
SetStateRequest | EntityMoniker | The entity for which the state is set.
UpdateRequest | Target | The updated entity.

Registering for pre or post images to access entity attribute values results in improved plug-in performance as compared to obtaining entity attributes in plug-in code through RetrieveRequest or RetrieveMultipleRequest requests.

Security Note
A pre-image passed in the execution context to a plug-in or custom workflow activity might contain data that the logged-on user doesn't have the privileges to access. Microsoft Dynamics CRM administrators and other users with high-level permissions can register plug-ins to run under the “system” user account or plug-in code can make calls as a “system” user on behalf of the logged-on user. If this happens, logged-on users can access data that their field level security does not allow access to. More information: Impersonation in plug-ins

See Also

Concepts

Handle exceptions in plug-ins
Event execution pipeline
Use messages (request and response classes) with the Execute method
Register and Deploy Plug-Ins

Other Resources

Plug-in development
Use the IOrganizationService web service to read and write data or metadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Handle exceptions in plug-ins

For synchronous plug-ins, whether registered in the sandbox or not, the Microsoft Dynamics CRM platform handles exceptions passed back from a plug-in by displaying an error message in a dialog of the web application user interface. The exception message for asynchronous registered plug-ins is written to a System Job (AsyncOperation) record which can be viewed in the System Jobs area of the web application.

For synchronous plug-ins, you can optionally display a custom error message in the error dialog of the web application by having your plug-in throw an InvalidPluginExecutionException exception with the custom message string as the exception Message property value. If you throw InvalidPluginExecutionException and do not provide a custom message, a generic default message is displayed in the error dialog. It is recommended that plug-ins only pass an InvalidPluginExecutionException back to the platform.

If a synchronous plug-in returns an exception other than InvalidPluginExecutionException back to the platform, the error dialog is displayed to the user and the exception message (System.Exception.Message) with stack trace is also written to one of two places. For plug-ins not registered in the sandbox, the information is written to the Application event log on the server that runs the plug-in. The event log can be viewed by using the Event Viewer administrative tool. For plug-ins registered in the sandbox, the exception message and stack trace is written to the Microsoft Dynamics CRM platform trace. For more information about tracing, see the Logging and Tracing section of the Debug a plug-In topic.

See Also

Concepts

Pass data between plug-ins
Write a plug-in
Debug a plug-In
Handle exceptions in your code

Other Resources

Plug-in development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Pass data between plug-ins

The message pipeline model for Microsoft Dynamics CRM defines a parameter collection of custom data values in the execution context that is passed through the pipeline and shared among registered plug-ins, even from different 3rd party developers. This collection of data can be used by different plug-ins to communicate information between plug-ins and enable chain processing where data processed by one plug-in can be processed by the next plug-in in the sequence and so on. This feature is especially useful in pricing engine scenarios where multiple pricing plug-ins pass data between one another to calculate the total price for a sales order or invoice. Another potential use for this feature is to communicate information between a plug-in registered for a pre-event and a plug-in registered for a post-event.

The name of the parameter that is used for passing information between plug-ins is SharedVariables. This is a collection of key\value pairs. At run time, plug-ins can add, read, or modify properties in the SharedVariables collection. This provides a method of information communication among plug-ins.

This sample shows how to use SharedVariables to pass data from a pre-event registered plug-in to a post-event registered plug-in.

C# Copy Code
using System;

// Microsoft Dynamics CRM namespace(s)
using Microsoft.Xrm.Sdk;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// A plug-in that sends data to another plug-in through the SharedVariables
    /// property of IPluginExecutionContext.
    /// </summary>
    /// <remarks>Register the PreEventPlugin for a pre-operation stage and the
    /// PostEventPlugin plug-in on a post-operation stage.
    /// </remarks>
    public class PreEventPlugin : IPlugin
    {
        public void Execute(IServiceProvider serviceProvider)
        {
            // Obtain the execution context from the service provider.
            Microsoft.Xrm.Sdk.IPluginExecutionContext context = (Microsoft.Xrm.Sdk.IPluginExecutionContext)
                serviceProvider.GetService(typeof(Microsoft.Xrm.Sdk.IPluginExecutionContext));

            // Create or retrieve some data that will be needed by the post event
            // plug-in. You could run a query, create an entity, or perform a calculation.
            //In this sample, the data to be passed to the post plug-in is
            // represented by a GUID.
            Guid contact = new Guid("{74882D5C-381A-4863-A5B9-B8604615C2D0}");

            // Pass the data to the post event plug-in in an execution context shared
            // variable named PrimaryContact.
            context.SharedVariables.Add("PrimaryContact", (Object)contact.ToString());
        }
    }

    public class PostEventPlugin : IPlugin
    {
        public void Execute(IServiceProvider serviceProvider)
        {
            // Obtain the execution context from the service provider.
            Microsoft.Xrm.Sdk.IPluginExecutionContext context = (Microsoft.Xrm.Sdk.IPluginExecutionContext)
                serviceProvider.GetService(typeof(Microsoft.Xrm.Sdk.IPluginExecutionContext));

            // Obtain the contact from the execution context shared variables.
            if (context.SharedVariables.Contains("PrimaryContact"))
            {
                Guid contact =
                    new Guid((string)context.SharedVariables["PrimaryContact"]);

                // Do something with the contact.
            }
        }
    }
}

It is important that any type of data added to the shared variables collection be serializable otherwise the server will not know how to serialize the data and plug-in execution will fail.

For a plug-in registered in stage 20 or 40, to access the shared variables from a stage 10 registered plug-in that executes on create, update, delete, or by a RetrieveExchangeRateRequest, you must access the ParentContext.SharedVariables collection. For all other cases, IPluginExecutionContext.SharedVariables contains the collection.

See Also

Concepts

Impersonation in plug-ins
Event execution pipeline

Other Resources

Plug-in development
IPluginExecutionContext

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Impersonation in plug-ins

Impersonation is used to execute business logic (custom code) on behalf of a Microsoft Dynamics CRM system user to provide a desired feature or service for that user. Any business logic executed within a plug-in, including Web service method calls and data access, is governed by the security privileges of the impersonated user.

Plug-ins not executed by either the sandbox or asynchronous service execute under the security account that is specified on the Identity tab of the CRMAppPool Properties dialog box. The dialog box can be accessed by right-clicking the CRMAppPool application pool in Internet Information Services (IIS) Manager and then clicking Properties in the shortcut menu. By default, CRMAppPool uses the Network Service account identity but this can be changed by a system administrator during installation. If the CRMAppPool identity is changed to a system account other than Network Service, the new identity account must be added to the PrivUserGroup group in Active Directory. More information: Change a Microsoft Dynamics CRM service account or AppPool identity for more detailed instructions.

The two methods that can be employed to impersonate a user are discussed below.

Impersonation during plug-in registration

One method to impersonate a system user within a plug-in is by specifying the impersonated user during plug-in registration. When registering a plug-in programmatically, if the SdkMessageProcessingStep.ImpersonatingUserId attribute is set to a specific Microsoft Dynamics CRM system user, Web service calls made by the plug-in execute on behalf of the impersonated user. If ImpersonatingUserId is set to a value of null or Guid.Empty during plug-in registration, the calling/logged on user or the standard "system" user is the impersonated user.

Whether the calling/logged on user or "system" user is used for impersonation is dependent on the request being processed by the pipeline and is beyond the scope of the SDK documentation. For more information about the "system" user, refer to the next topic.

Note
When you register a plug-in using the sample plug-in registration tool that is provided in the SDK download, service methods invoked by the plug-in execute under the account of the calling or logged on user by default unless you select a different user in the Run in User’s Context dropdown menu. For more information about the tool sample code, refer to the tool code under the SDK\Tools\PluginRegistration folder of the SDK package. Download the Microsoft Dynamics CRM SDK package.

Impersonation during plug-in execution

Impersonation that was defined during plug-in registration can be altered in a plug-in at run time. Even if impersonation was not defined at plug-in registration, plug-in code can still use impersonation. The following discussion identifies the key properties and methods that play a role in impersonation when making Web service method calls in a plug-in.

The platform passes the impersonated user ID to a plug-in at run time through the UserId property. This property can have one of three different values as shown in the table below.

UserId Value | Condition
Initiating user or "system" user | The SdkMessageProcessingStep.ImpersonatingUserId attribute is set to null or Guid.Empty at plug-in registration.
Impersonated user | The ImpersonatingUserId property is set to a valid system user ID at plug-in registration.
"system" user | The current pipeline was executed by the platform, not in direct response to a service method call.

The InitiatingUserId property of the execution context contains the ID of the system user that called the service method that ultimately caused the plug-in to execute.

Important
For plug-ins executing offline, any entities created by the plug-in are owned by the logged on user. Impersonation in plug-ins is not supported while in offline mode.

See Also

Concepts

Register and Deploy Plug-Ins
Understand the data context passed to a plug-in
Impersonate another user

Other Resources

Plug-in development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Register and Deploy Plug-Ins

Plug-ins and custom workflow activities are custom code that you develop to extend the existing functionality of Microsoft Dynamics CRM. Before a plug-in or custom workflow activity can be used, it must be registered with the server. You can programmatically register plug-ins and custom workflow activities with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update by writing registration code using certain SDK classes. However, to ease the learning curve and to speed up development and deployment of custom code, a plug-in and custom workflow activity registration tool is included in Bin folder of the SDK. Download the Microsoft Dynamics CRM SDK package.

While this topic focuses primarily on plug-ins, most of the information is also applicable to custom workflow activities. One difference between the two is that for custom workflow activity assemblies, you register just the assembly. For plug-ins, you register the plug-in assembly and one or more steps per plug-in. For more information about custom workflow activities, see Custom workflow activities (workflow assemblies).

Security Note
Do not register any plug-in or custom workflow activity unless it is obtained from a reliable and trusted source.

For more information about how to package your plug-ins as solution components, see Package and distribute extensions using solutions.

In This Topic

Plug-in Registration Tool

Plug-in Storage

Deployment

Assembly Versioning and Solutions

Security Restrictions

Register Plug-ins Programmatically

Enable or Disable Custom Code Execution

Plug-in Registration Tool

The Plug-in Registration tool provides a graphical user interface and supports registering plug-ins and custom workflow activities with Microsoft Dynamics CRM. However, plug-ins and custom workflow activities can only be registered in the sandbox (isolation mode) of Microsoft Dynamics CRM Online.

For more information about how to register and deploy a plug-in by using the tool, see Walkthrough: Register a plug-in using the plug-in registration tool. The tool can be added to the Visual Studio Tools menu as an external tool to speed up the development process.

Plug-in Storage

For an on-premises deployment, plug-ins that are not registered in the sandbox can be stored in the Microsoft Dynamics CRM server's database or the on-disk file system. We strongly recommend that you store your production-ready plug-ins in the Microsoft Dynamics CRM database, instead of on-disk. Plug-ins stored in the database are automatically distributed across multiple Microsoft Dynamics CRM servers in a data center cluster. On-disk storage of plug-ins is useful for debugging plug-ins using Microsoft Visual Studio. However, you can debug a plug-in that is stored in the database. For more information, see Debug a plug-In.

Plug-ins registered in the sandbox must be stored in the database regardless of the Microsoft Dynamics CRM deployment (on-premises, IFD, or Online).

Deployment

For on-premises or Internet-facing (IFD) Microsoft Dynamics CRM installations, when you deploy plug-ins from another computer to the Microsoft Dynamics CRM server disk (on-disk deployment), the plug-in assembly must be manually copied to the server before registration. The assembly must be deployed to the <installdir>\Program Files\Microsoft CRM\server\bin\assembly folder on each server where the plug-in is to execute.

Plug-in registration should be done after the assembly has been copied to the …\bin\assembly folder on the server to prevent the situation where a system user causes an event in Microsoft Dynamics CRM to be raised but the registered plug-in assembly does not yet exist on the server. For server database deployment, the plug-in assembly is automatically copied during plug-in registration so that the earlier situation is not an issue.

Depending on your plug-in’s design, your plug-ins may require other referenced assemblies to run. Regardless of whether you deploy your plug-in to the database or disk, if your plug-in requires other assemblies to run, you must put copies of these assemblies in the global assembly cache on each server where the plug-in is to execute. This does not apply to a Microsoft Dynamics CRM Online server because you do not have access to the global assembly cache on that server.

To move a plug-in from a development environment to a staging or production server

  1. On the development computer, build the plug-in code. Do not include debug information. Optimize the plug-in for performance.

  2. Register the plug-in in the Microsoft Dynamics CRM server database.

  3. Using the Microsoft Dynamics CRM web application, create a solution or use an existing one, and add the plug-in to that solution.

  4. After you have added any other desired components to the solution, export the solution.

  5. Import the solution on to the staging or production server.

Assembly Versioning and Solutions

Plug-in assemblies can be versioned using a number format of major.minor.build.revision defined in the Assembly.info file of the Microsoft Visual Studio project. Depending on what part of the assembly version number is changed in a newer solution, the following behavior applies when an existing solution is updated through import.

  • The build or revision assembly version number is changed.
    This is considered an in-place upgrade. The older version of the assembly is removed when the solution containing the updated assembly is imported. Any pre-existing steps from the older solution are automatically changed to refer to the newer version of the assembly.
  • The major or minor assembly version number, except for the build or revision numbers, is changed.
    When an updated solution containing the revised assembly is imported, the assembly is considered a completely different assembly than the previous version of that assembly in the existing solution. Plug-in registration steps in the existing solution will continue to refer to the previous version of the assembly. If you want existing plug-in registration steps for the previous assembly to point to the revised assembly, you will need to use the Plug-in Registration tool to manually change the step configuration to refer to the revised assembly type. This should be done before exporting the updated assembly into a solution for later import.

For more information about solutions, refer to Introduction to solutions.

Security Restrictions

There is a security restriction that enables only privileged users to register plug-ins. For plug-ins that are not registered in isolation, the system user account under which the plug-in is being registered must exist in the Deployment Administrators group of Deployment Manager. Only the System Administrator user account or any user account included in the Deployment Administrators group can run Deployment Manager.

Important
For non-isolated plug-ins, failure to include the registering user account in the Deployment Administrators group results in an exception being thrown during plug-in registration. The exception description states "Not have enough privilege to complete Create operation for an SDK entity."

The system user account under which the plug-in is being registered must have the following organization-wide security privileges:

  • prvCreatePluginAssembly
  • prvCreatePluginType
  • prvCreateSdkMessageProcessingStep
  • prvCreateSdkMessageProcessingStepImage
  • prvCreateSdkMessageProcessingStepSecureConfig

For more information, see Security role and privilege reference and The security model of Microsoft Dynamics CRM.

For plug-ins registered in the sandbox (isolation mode), the system user account under which the plug-in is being registered must have the System Administrator role. Membership in the Deployment Administrators group is not required.

Register Plug-ins Programmatically

The key entity types used to register plug-ins and images are: PluginAssembly, PluginType, SdkMessageProcessingStep, and SdkMessageProcessingStepImage. The key entity types used to register custom workflow activities are PluginAssembly and PluginType. Use these entities with the create, update, retrieve, and delete operations.

For more information on images, see Understand the data context passed to a plug-in.

Enable or Disable Custom Code Execution

You can use Windows PowerShell to enable or disable custom code, including plug-ins and custom workflow activities, on the server as described here. Alternatively, you can use the Deployment Web service. For more information, see Deployment entities and deployment configuration settings to set the CustomCodeSettings.AllowExternalCode property.

To enable custom code execution

  1. Open a Windows PowerShell command window.

  2. Add the Microsoft Dynamics CRM PowerShell snap-in:

    Windows PowerShell Copy Code
    Add-PSSnapin Microsoft.Crm.PowerShell

  3. Retrieve the current setting:

    Windows PowerShell Copy Code
    $setting = get-crmsetting customcodesettings

  4. Modify the current setting:

    Windows PowerShell Copy Code
    $setting.AllowExternalCode="True"
    Windows PowerShell Copy Code
    set-crmsetting $setting

  5. Verify the setting:

    Windows PowerShell Copy Code
    get-crmsetting customcodesettings

To disable custom code execution

  1. Open a Windows PowerShell command window.

  2. Add the Microsoft Dynamics CRM PowerShell snap-in:

    Windows PowerShell Copy Code
    Add-PSSnapin Microsoft.Crm.PowerShell

  3. Retrieve the current setting:

    NPL Copy Code
    $setting = get-crmsetting customcodesettings

  4. Modify the current setting:

    Windows PowerShell Copy Code
    $setting.AllowExternalCode=0
    Windows PowerShell Copy Code
    set-crmsetting $setting

  5. Verify the setting:

    Windows PowerShell Copy Code
    get-crmsetting customcodesettings

See Also

Concepts

Debug a plug-In
Plug-in isolation, trusts, and statistics
PluginAssembly entity privileges
PluginType entity privileges
SdkMessageProcessingStep entity privileges
SdkMessageProcessingStepImage entity privileges
SdkMessageProcessingStepSecureConfig entity privileges

Other Resources

Plug-in development
Package and distribute extensions using solutions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Debug a plug-In

The following steps describe how to debug a plug-in executing on Microsoft Dynamics CRM 2015. To debug a plug-in that executes in the sandbox on Microsoft Dynamics CRM Online, you must using tracing as described later in this topic.

In This Topic

Debug a plug-In

Debug a sandboxed plug-in

Logging and tracing

Debug a plug-in

  1. Register and deploy the plug-in assembly.

    If there is another copy of the assembly at the same location and you cannot overwrite that copy because it is locked by Microsoft Dynamics CRM, you must restart the service process that was executing the plug-in. Refer to the table below for the correct service process. More information: Register and Deploy Plug-Ins

  2. Configure the debugger.

    Attach the debugger to the process on the Microsoft Dynamics CRM server that will run your plug-in. Refer to the following table to identify the process.

    Plug-in Registration Configuration Service Process

    online

    w3wp.exe

    offline

    Microsoft.Crm.Application.Hoster.exe

    asynchronous registered plug-ins (or custom workflow assemblies)

    CrmAsyncService.exe

    sandbox (isolation mode)

    Microsoft.Crm.Sandbox.WorkerProcess.exe

    If there are multiple processes running the same executable file, for example multiple w3wp.exe processes, attach the debugger to all instances of the running executable process. Next, set one or more breakpoints in your plug-in code.

  3. Test the plug-in.

    Run the Microsoft Dynamics CRM application, or other custom application that uses the SDK, and perform whatever action is required to cause the plug-in to execute. For example, if a plug-in is registered for an account creation event, create a new account.

  4. Debug your plug-in code.

    Make any needed changes to your code so that it performs as you want. If the code is changed, compile the code into an assembly and repeat steps 1 through 4 in this procedure as necessary. However, if you change the plug-in assembly’s major or minor version numbers, you must unregister the earlier version of the assembly and register the new version. More information: Register and Deploy Plug-Ins

  5. Register the plug-in in the database.

    After the edit/compile/deploy/test/debug cycle for your plug-in has been completed, unregister the (on-disk) plug-in assembly and then reregister the plug-in in the Microsoft Dynamics CRM database. More information: Register and Deploy Plug-Ins

Tip
It is possible to debug a database deployed plug-in. The compiled plug-in assembly's symbol file (.pdb) must be copied to the server's <crm-root>\Server\bin\assembly folder and Internet Information Services (IIS) must then be restarted. After debugging has been completed, you must remove the symbol file and reset IIS to prevent the process that was executing the plug-in from consuming additional memory.

For more information about debugging a plug-in using the Plug-in Profiler tool, see Analyze plug-in performance.

Debug a sandboxed plug-in

It is important to perform these steps before the first execution of a sandboxed plug-in. If the plug-in has already been executed, either change the code of the assembly, causing the hash of the assembly to change on the server, or restart the Microsoft Dynamics CRM Sandbox Processing Service on the sandbox server.

Configure the Server

The sandbox host process monitors the sandbox worker process which is executing the plug-in. The host process checks if the plug-in stops responding, if it is exceeding memory thresholds, and more. If the worker process doesn't respond for than 30 seconds, it will be shutdown. In order to debug a sandbox plug-in, you must disable this shutdown feature. To disable the shutdown feature, set the following registry key to 1 (DWORD):

Copy Code
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\SandboxDebugPlugins

Debug the Plug-in

Follow these steps to debug a sandboxed plug-in.

  1. Register the plug-in in the sandbox (isolation mode) and deploy it to the Microsoft Dynamics CRM server database.
  2. Copy the symbol file (.pdb) of the compiled plug-in assembly to the server\bin\assembly folder on the server running the sandbox worker process named Microsoft.Crm.Sandbox.WorkerProcess.exe. This is the server hosting the Sandbox Processing Service role.
  3. Follow the instructions in steps 2 through 4 presented at the beginning of this topic.

For more information about debugging a plug-in using the Plug-in Profiler tool, see Analyze plug-in performance.

Logging and tracing

An alternative method to debug a plug-in is to use tracing. Tracing assists developers in troubleshooting plug-ins by providing run-time plug-in information as an aid in diagnosing the cause of plug-in failure. Tracing is especially useful to debug Microsoft Dynamics CRM Online registered plug-ins as it is the only supported debugging method for that scenario.

The tracing discussed here is different from ASP.NET tracing. Tracing is implemented in the Microsoft Dynamics CRM SDK through the use of the tracing service ITracingService. Developers add Trace statements to their plug-in code, then build and deploy the plug-in. During execution and only when that plug-in passes an exception back to the platform at run-time, tracing information is displayed to the user. For a synchronous registered plug-in, the tracing information is displayed in a dialog box of the Microsoft Dynamics CRM web application. For an asynchronous registered plug-in, the tracing information is shown in the Details area of the System Job form in the web application. The amount and nature of this information is up to you as a developer to code into your plug-ins.

The main reason for implementing this type of tracing is to support the isolated (sandboxed) plug-in and custom workflow activities capability in Microsoft Dynamics CRM. Sandboxed custom code is not able to write information to the system event log or the file system. The tracing service was implemented to provide sandboxed plug-ins and custom workflow activities with a means to output run-time information when an exception is thrown. In addition, tracing is also supported in plug-ins that are not sandboxed.

An important design feature of tracing is that the tracing information is only made available when an exception is passed from the plug-in or custom workflow activity back to the platform. When the error dialog box is displayed in the web application, the user must click the Download Log File button to view the log containing exception and trace output. If an exception is not thrown or is caught by the plug-in/custom activity code, any tracing information generated by your custom code is lost.

An alternate approach is to create a custom entity to track any run-time plug-in information that you want to record. When your plug-in executes, have the plug-in store its exception information in a record of your custom entity. In this way, you are logging your run-time plug-in information to the Microsoft Dynamics CRM database. This method works for any plug-in regardless of how it is registered. However, if the plug-in executes within the database transaction and an exception occurs that causes a transaction rollback, any entity data changes by the plug-in will be undone.

For more information about how to use tracing in plug-in code, see Sample: Azure aware custom plug-in. For more information about platform (ASP.NET based) tracing, see Monitor and troubleshoot Microsoft Dynamics CRM.

See Also

Concepts

Analyze plug-in performance
Register and Deploy Plug-Ins
Event execution pipeline
Write a plug-in
Plug-in isolation, trusts, and statistics

Other Resources

Plug-in development
ITracingService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Walkthrough: Register a plug-in using the plug-in registration tool

This walkthrough demonstrates how to register a plug-in by using the Plug-in Registration tool that is provided in the SDK. The plug-in to register is the FollowupPlugin from the Sample: Basic plug-in topic.

The plug-in is to be registered on the account entity, CreateRequest message, on a post-event, and in the sandbox. The plug-in can be registered on any Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update deployment where your user account has the System Customizer or System Administrator role.

The following prerequisites must be completed before starting this walkthrough:

  • Get the PluginRegistration.exe tool, located in the Tools\PluginRegistration folder of the SDK. Download the Microsoft Dynamics CRM SDK package.
  • Obtain a system user account on a Microsoft Dynamics CRM server.
  • Your user account must have the System Customizer or System Administrator role. See How role-based security can be used to control access to entities in Microsoft Dynamics CRM.

Connect to the Microsoft Dynamics CRM Server

  1. Run the Plug-in Registration tool.

  2. Choose CREATE NEW CONNECTION.

  3. In the Login dialog, select the deployment type radio button corresponding to the Microsoft Dynamics CRM server you intend to register plug-ins with. The On-premises radio button includes an IFD deployment, the Online button is for the Windows Live provider of Microsoft Dynamics CRM Online, and the Office 365 button is for the Microsoft Online Services provider of Microsoft Dynamics CRM Online.

    Login dialog for an online deployment Login window for an on-premises deployment

  4. If you check Always display list of available orgs, you are presented with a list of organizations that you belong to after you choose Login. This enables you to choose the organization that you want to register the plug-in with. Otherwise, your default organization is used.

  5. Enter the indicated information about the server and login account, and then choose Login.

You should see a collapsed list of registered plug-in or custom workflow activity assemblies and service endpoints. The activity feeds and Microsoft.Crm.ObjectModel assemblies are required for Microsoft Dynamics CRM to function properly so the tool prevents you from altering them. Selecting an item in the list results in the Properties and Details tab panes displaying information about that list item.

The application's main window

Register a plug-in assembly

  1. Select an organization tab to make it active.

  2. In the toolbar of the tab, choose Register and then Register New Assembly.

  3. In the Register New Assembly dialog box, choose the ellipses […] button to the right of the Step#1 field.

  4. In the Open dialog box, navigate to the location of the compiled SamplePlugin.dll assembly. The default location is SDK\SampleCode\CS\Plug-ins\bin\Debug. Select the assembly, and then choose Open.

  5. In the Step#2 section, expand the SamplePlugins assembly to view all plug-ins in that assembly. Select (check) only the Microsoft.Crm.Sdk.Samples.FollowupPlugin plug-in.

  6. In the Step#3 section, select the Sandbox option.

  7. In the Step#4 section, select the Database option.

    Dialog to register an assembly

  8. Choose Register Selected Plugins. You can close any open dialog boxes.

    A registered plug-in shown in the tree view

    Tip
    Do you see an error in the Log area and the log contains the following message?

    <Message>Action failed for assembly 'SamplePlugins, Version=0.0.0.0, Culture=neutral, PublicKeyToken=829f574d80e89132': Deployment/Scalegroup does not allow running external code.</Message>

    If so, you must enable custom code on the server and try again. For more information see Enable or Disable Custom Code Execution.

The SamplePlugins.dll assembly and FollowupPlugin plug-in are now registered and deployed to the server. If you used the tool to register a custom workflow activity assembly, the next section on registering a step does not apply.

Register a plug-in step for an event

  1. In the Registered Plug-ins & Custom Workflow Activities tree view, expand the (Assembly) SamplePlugins node and select a registered plug-in.

  2. Navigate to the Register menu in the toolbar, and then choose Register New Step.

    Note
    Plug-ins are registered to execute when an event is processed in the event execution pipeline. Each event has a stage name and number to indicate its location in the pipeline either before or after the core platform operation. A step refers to the SDK message processing step entity that is used to configure when and how the plug-in is to be executed.

  3. Complete the Register New Step dialog box as shown in the following figure.

    Dialog to register a new step

  4. Choose Register New Step.

  5. Expand the (Assembly) SamplePlugins node and sub-nodes to see the plug-in and step nodes you created. You can now close the tool, but you may want to keep it open until after you test the plug-in and unregister the assembly.

    Note
    To unregister the step, plug-in, or assembly, select its node in the tree, and then choose Unregister in the tool bar. To modify an assembly or step registration, double-click the assembly or step node in the tree view. Alternately, you can select the node and choose Update in the tool bar.

The plug-in is now registered to execute in the sandbox, for an account create event, and after the core operation executes. You registered the plug-in to run asynchronously since the creation of the follow-up task activity is not time critical. After an account is created, the plug-in will execute the next time the asynchronous service processes its queue.

Test the plug-in

After you register the plug-in you can optionally test its execution by using the following procedure.

  1. Open the Microsoft Dynamics CRM web application for the same organization that you registered the plug-in assembly under.

  2. Move to the workplace, select Accounts, and then choose New.

  3. In the Account Name box, type an account name, for example, Adventure Works Cycle, and then choose Save & Close.

  4. Double-click the form name in the Accounts grid to open the form.

  5. Choose Activities to display a list of related activities for the account. You should see the activity named “Send email to the new customer“ that the plug-in created.

  6. If you registered the plug-in to run asynchronously, and did not select the Delete AsyncOperation if StatusCode = Successful option on the Register New Step form, there will be a new system job named “FollowupPlugin: Create of account”. To view the related system job, choose Settings, and then choose System Jobs. Double-click the system job previously mentioned.

You can now unregister the step, plug-in, and assembly if you want. You may also want to delete the system job and account that you created.

See Also

Tasks

Walkthrough: Configure assembly security for an offline plug-in

Concepts

Register and Deploy Plug-Ins
Event execution pipeline
Plug-in isolation, trusts, and statistics
Supported messages and entities for plug-ins

Other Resources

Plug-in development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Walkthrough: Configure assembly security for an offline plug-in

The Microsoft Dynamics CRM platform applies an additional security restriction to registered offline plug-in assemblies. When Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is installed, an AllowList key is added to the system registry on the client computer. For each assembly containing an offline plug-in that you register, you must add a registry sub-key under the AllowList key with the key name derived from the assembly's public key token. Failure to add this key results in the offline plug-in not being executed by the platform even though the plug-in is registered. This walkthrough describes how to add this sub-key for a plug-in assembly.

Get the public key token

  1. Load the assembly containing the offline plug-in into the Plug-in Registration tool. For more information about how to use the tool, see Walkthrough: Register a plug-in using the plug-in registration tool.

  2. Select the plug-in assembly in the tree view of the tool.

  3. Copy (Ctrl+C) the value in the Public Key Token field into the paste buffer.

Add an AllowList key

  1. Run the registry editor by selecting Start, then select Run and type regedit.exe.

  2. In the tree view pane, navigate to the AllowList key. The complete path of the key is HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\AllowList.

  3. Select the AllowList key and right click to display the context menu.

  4. Select New then click Key to create a new sub-key.

  5. Paste the public key token value into the name of the new sub-key.

  6. Close the registry editor.

See Also

Concepts

Register and Deploy Plug-Ins

Other Resources

Plug-in development
Sample: Basic plug-in

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Basic plug-in
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK\SampleCode\CS\Plug-ins\FollowupPlugin.cs

Requirements

Register this plug-in for an account entity, on the Create message, and in asynchronous mode. Alternately, you can register the plug-in on a post-event in the sandbox.

Demonstrates

This sample shows how to write a basic plug-in that can access the Microsoft Dynamics CRM organization Web service.

The plug-in creates a task activity after a new account is created. The activity reminds the user to follow-up with the new account customer one week after the account was created.

Example

C# Copy Code
using System;
using System.ServiceModel;

// Microsoft Dynamics CRM namespace(s)
using Microsoft.Xrm.Sdk;

namespace Microsoft.Crm.Sdk.Samples
{
     public class FollowupPlugin: IPlugin
    {
        /// <summary>
        /// A plug-in that creates a follow-up task activity when a new account is created.
        /// </summary>
        /// <remarks>Register this plug-in on the Create message, account entity,
        /// and asynchronous mode.
        /// </remarks>
        public void Execute(IServiceProvider serviceProvider)
        {
            //Extract the tracing service for use in debugging sandboxed plug-ins.
            ITracingService tracingService =
                (ITracingService)serviceProvider.GetService(typeof(ITracingService));

            // Obtain the execution context from the service provider.
            IPluginExecutionContext context = (IPluginExecutionContext)
                serviceProvider.GetService(typeof(IPluginExecutionContext));

            // The InputParameters collection contains all the data passed in the message request.
            if (context.InputParameters.Contains("Target") &&
                context.InputParameters["Target"] is Entity)
            {
                // Obtain the target entity from the input parameters.
                Entity entity = (Entity)context.InputParameters["Target"];

                // Verify that the target entity represents an account.
                // If not, this plug-in was not registered correctly.
                if (entity.LogicalName != "account")
                    return;

                try
                {
                    // Create a task activity to follow up with the account customer in 7 days.
                    Entity followup = new Entity("task");

                    followup["subject"] = "Send e-mail to the new customer.";
                    followup["description"] =
                        "Follow up with the customer. Check if there are any new issues that need resolution.";
                    followup["scheduledstart"] = DateTime.Now.AddDays(7);
                    followup["scheduledend"] = DateTime.Now.AddDays(7);
                    followup["category"] = context.PrimaryEntityName;

                    // Refer to the account in the task activity.
                    if (context.OutputParameters.Contains("id"))
                    {
                        Guid regardingobjectid = new Guid(context.OutputParameters["id"].ToString());
                        string regardingobjectidType = "account";

                        followup["regardingobjectid"] =
                        new EntityReference(regardingobjectidType, regardingobjectid);
                    }

                    // Obtain the organization service reference.
                    IOrganizationServiceFactory serviceFactory = (IOrganizationServiceFactory)serviceProvider.GetService(typeof(IOrganizationServiceFactory));
                    IOrganizationService service = serviceFactory.CreateOrganizationService(context.UserId);

                    // Create the task in Microsoft Dynamics CRM.
                    tracingService.Trace("FollowupPlugin: Creating the task activity.");
                    service.Create(followup);
                }
                catch (FaultException<OrganizationServiceFault> ex)
                {
                    throw new InvalidPluginExecutionException("An error occurred in the FollupupPlugin plug-in.", ex);
                }

                catch (Exception ex)
                {
                    tracingService.Trace("FollowupPlugin: {0}", ex.ToString());
                    throw;
                }
            }
        }
    }
}

See Also

Concepts

Write a plug-in
Register and Deploy Plug-Ins
Event execution pipeline

Other Resources

Plug-in development
Sample: Web access from a sandboxed plug-in
IPlugin
IPluginExecutionContext
ITracingService
IOrganizationServiceFactory

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Web access from a sandboxed plug-in
See Also Example

Requirements

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK\SampleCode\CS\Plugins\WebClientPlugin.cs

Register the compiled plug-in to run in the sandbox on the Microsoft Dynamics CRM server.

Demonstrates

Demonstrates how to code a plug-in that has Web (network) access and be registered in the sandbox.

Example

C# Copy Code
using System;
using System.Globalization;
using System.IO;
using System.Text;
using System.Net;

// Microsoft Dynamics CRM namespace(s)
using Microsoft.Xrm.Sdk;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// A sandboxed plug-in that can access network (Web) resources.
    /// </summary>
    /// <remarks>Register this plug-in in the sandbox. You can provide an unsecure string
    /// during registration that specifies the Web address (URI) to access from the plug-in.
    /// </remarks>
    public sealed class WebClientPlugin : IPlugin
    {
        private string webAddress;

        /// <summary>
        /// The plug-in constructor.
        /// </summary>
        /// <param name="config">The Web address to access. An empty or null string
        /// defaults to accessing www.bing.com. The Web address can use the HTTP or
        /// HTTPS protocol.</param>
        public WebClientPlugin(string config)
        {
            if (String.IsNullOrEmpty(config))
            {
                webAddress = "http://www.bing.com";
            }
            else
            {
                webAddress = config;
            }
        }

        /// <summary>
        /// Main execute method that is required by the IPlugin interface. Uses the WebClient
        /// .NET class to access the target Web address.
        /// </summary>
        /// <param name="serviceProvider">The service provider from which you can obtain the
        /// tracing service, plug-in execution context, organization service, and more.</param>
        public void Execute(IServiceProvider serviceProvider)
        {
            //Extract the tracing service for use in plug-in debugging.
            ITracingService tracingService =
                (ITracingService)serviceProvider.GetService(typeof(ITracingService));

            try
            {
                tracingService.Trace("Downloading the target URI: " + webAddress);

                try
                {
                    // Download the target URI using a Web client. Any .NET class that uses the
                    // HTTP or HTTPS protocols and a DNS lookup should work.
                    using (WebClient client = new WebClient())
                    {
                        byte[] responseBytes = client.DownloadData(webAddress);
                        string response = Encoding.UTF8.GetString(responseBytes);
                        tracingService.Trace(response);

                        // For demonstration purposes, throw an exception so that the response
                        // is shown in the trace dialog of the Microsoft Dynamics CRM user interface.
                        throw new InvalidPluginExecutionException("WebClientPlugin completed successfully.");
                    }
                }

                catch (WebException exception)
                {
                    string str = string.Empty;
                    if (exception.Response != null)
                    {
                        using (StreamReader reader =
                            new StreamReader(exception.Response.GetResponseStream()))
                        {
                            str = reader.ReadToEnd();
                        }
                        exception.Response.Close();
                    }
                    if (exception.Status == WebExceptionStatus.Timeout)
                    {
                        throw new InvalidPluginExecutionException(
                            "The timeout elapsed while attempting to issue the request.", exception);
                    }
                    throw new InvalidPluginExecutionException(String.Format(CultureInfo.InvariantCulture,
                        "A Web exception occurred while attempting to issue the request. {0}: {1}",
                        exception.Message, str), exception);
                }
            }
            catch (Exception e)
            {
                tracingService.Trace("Exception: {0}", e.ToString());
                throw;
            }
        }
    }
}

See Also

Concepts

Write a plug-in
Plug-in isolation, trusts, and statistics

Other Resources

Plug-in development
IPlugin
ITracingService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Plug-in entities

A plug-in assembly stores information about an assembly that contains one or more plug-ins or custom workflow activities. This information includes the binary data of the assembly. A plug-in type identifies the object type that a plug-in assembly contains. This type can be either a plug-in or a custom workflow activity. A plug-in type statistics stores information about the run-time behavior of a plug-in type and other statistical information.

See Also

Concepts

Plug-in registration entities
PluginAssembly entity messages and methods
PluginType entity messages and methods
PluginTypeStatistic entity messages and methods
Event execution pipeline

Other Resources

Write plug-ins to extend business processes
IPlugin

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PluginAssembly entity messages and methods

A plug-in assembly represents an assembly that contains one or more plug-in or custom workflow activity types.

All users have read access to this entity. It is an unsafe practice to save logon credentials within this entity or within the assembly itself.

It is unsupported to create a plug-in assembly for a Microsoft Dynamics CRM assembly (Microsoft.Crm.*.dll or Microsoft.Xrm.*.dll) or to update or delete a system plug-in assembly. For more information, see Supported extensions for Microsoft Dynamics CRM. The schema name for this entity is PluginAssembly. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a plug-in assembly. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a plug-in assembly. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a plug-in assembly. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of plug-in assemblies. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a plug-in assembly. You can also call the IOrganizationService.Update method.

See Also

Concepts

Plug-in entities
PluginType entity messages and methods
PluginAssembly entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PluginType entity messages and methods

This entity represents a plug-in type or custom workflow activity type that is contained within a plug-in assembly. The schema name for this entity is PluginType. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a plug-in type. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a plug-in type. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a plug-in type. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of plug-in types. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a plug-in type. You can also call the IOrganizationService.Update method.

See Also

Concepts

Plug-in entities
PluginTypeStatistic entity messages and methods
PluginType entity privileges

Other Resources

IPlugin

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PluginTypeStatistic entity messages and methods

This entity is used by the platform to record execution statistics for plug-ins registered in the sandbox (isolation mode). The schema name for this entity is PluginTypeStatistic. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves plug-in type statistics. You can also call theIOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of plug-in type statistics. You can also call theIOrganizationService.RetrieveMultiple method.

See Also

Concepts

Plug-in entities
Plug-in isolation, trusts, and statistics
PluginType entity privileges

Other Resources

IPlugin

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Plug-in registration entities

The plug-in registration entities define a Microsoft Dynamics CRM SDK (SDK) message, the entities that support a particular SDK message, and the entities used during plug-in registration. These entities do not apply to custom workflow activities.

An SDK Message defines a message to the Microsoft Dynamics CRM platform. The message represents the operation that the platform is to perform. You should not create or update a record of this entity.

An SDK Message Filter defines what entity type, for example, account or contact, supports a particular SDK message. It also identifies whether a custom plug-in can be registered for the message and executed when the message is processed by the event execution pipeline.

The SDK message processing entities are used when registering a plug-in in the event execution pipeline. An SDK Message Processing Step entity identifies the event in the pipeline for which a plug-in should be executed. An SDK Message Processing Step Image entity stores a snapshot of an entity, including its attributes, during an event that occurs before or after the core platform operation. An SDK Message Processing Step Secure Configuration entity stores secure custom information that is passed to a plug-in’s constructor at run-time.

See Also

Concepts

SdkMessage entity messages and methods
SdkMessageFilter entity messages and methods
SdkMessageProcessingStep entity messages and methods
SdkMessageProcessingStepImage entity messages and methods
SdkMessageProcessingStepSecureConfiguration entity messages and methods
Plug-in entities

Other Resources

Write plug-ins to extend business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessage entity messages and methods

This entity represents a message that is supported by the SDK. The schema name for this entity is SdkMessage. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

message | Description
RetrieveRequest | Retrieves an SDK message. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of SDK messages. You can also call the IOrganizationService.RetrieveMultiple method.

Mapping between names

The following table contains the mappings for the SdkMessage.Name, SdkMessageRequest.Name and SdkMessage.CategoryName attributes.

SdkMessage.Name | SdkMessageRequest.Name | SdkMessage.CategoryName
AddItem | AddItemCampaignActivity | None
AddItem | AddItemCampaign | None
AddListMembers | AddListMembersList | None
AddMember | AddMemberList | None
AddMembers | AddMembersTeam | None
AddPrivileges | AddPrivilegesRole | None
AddProductToKit | AddProductToKit | None
AddRecurrence | AddRecurrence | RecurringSeries
AddSolutionComponent | AddSolutionComponent | Solution
AddSubstitute | AddSubstituteProduct | None
AddToQueue | AddToQueue | AddToQueue
Assign | Assign | Owned
Associate | Associate | None
AssociateEntities | AssociateEntities | None
AutoMapEntity | AutoMapEntity | None
BackgroundSend | BackgroundSendEmail | None
Book | Book | Schedule
BulkDelete | BulkDelete | None
BulkDetectDuplicates | BulkDetectDuplicates | None
BulkMail | SendBulkMail | None
BulkOperationStatusClose | BulkOperationStatusClose | None
CalculateActualValue | CalculateActualValueOpportunity | None
CalculateTotalTime | CalculateTotalTimeIncident | None
CanBeReferenced | CanBeReferenced | None
CanBeReferencing | CanBeReferencing | None
Cancel | CancelSalesOrder | None
Cancel | CancelContract | None
CanManyToMany | CanManyToMany | None
CheckIncoming | CheckIncomingEmail | None
CheckPromote | CheckPromoteEmail | None
CleanUpBulkOperation | CleanUpBulkOperation | None
Clone | CloneContract | None
Close | CloseQuote | None
Close | CloseIncident | None
CompoundCreate | CompoundCreate | Compound
CompoundUpdate | CompoundUpdate | Compound
CompoundUpdateDuplicateDetectionRule | CompoundUpdateDuplicateDetectionRule | Compound
ConvertKitToProduct | ConvertKitToProduct | None
ConvertProductToKit | ConvertProductToKit | None
ConvertQuoteToSalesOrder | ConvertQuoteToSalesOrder | None
ConvertSalesOrderToInvoice | ConvertSalesOrderToInvoice | None
Copy | CopyCampaign | None
CopyCampaignResponse | CopyCampaignResponse | None
CopyDynamicListToStatic | CopyDynamicListToStatic | None
CopyMembers | CopyMembersList | None
CopySystemForm | CopySystemForm | None
Create | Create | Create
CreateActivities | CreateActivitiesList | None
CreateAttribute | CreateAttribute | None
CreateEntity | CreateEntity | None
CreateException | CreateException | RecurringInstance
CreateInstance | CreateInstance | RecurringSeries
CreateManyToMany | CreateManyToMany | None
CreateOneToMany | CreateOneToMany | None
CreateOptionSet | CreateOptionSet | None
CreateWorkflowFromTemplate | CreateWorkflowFromTemplate | None
Delete | Delete | Delete
DeleteAttribute | DeleteAttribute | None
DeleteAuditData | DeleteAuditData | None
DeleteEntity | DeleteEntity | None
DeleteOpenInstances | DeleteOpenInstances | RecurringSeries
DeleteOptionSet | DeleteOptionSet | None
DeleteOptionValue | DeleteOptionValue | None
DeleteRelationship | DeleteRelationship | None
DeliverIncoming | DeliverIncomingEmail | None
DeliverPromote | DeliverPromoteEmail | None
DeprovisionLanguage | DeprovisionLanguage | None
Disassociate | Disassociate | None
DisassociateEntities | DisassociateEntities | None
DistributeCampaignActivity | DistributeCampaignActivity | None
DownloadReportDefinition | DownloadReportDefinition | None
EntityExpressionToFetchXml | QueryExpressionToFetchXml | None
Execute | ExecuteFetch | None
ExecuteById | ExecuteByIdSavedQuery | None
ExecuteById | ExecuteByIdUserQuery | None
ExecuteWorkflow | ExecuteWorkflow | None
Expand | ExpandCalendar | None
ExportMappings | ExportMappingsImportMap | None
ExportSolution | ExportSolution | None
ExportTranslation | ExportTranslation | None
FetchXmlToEntityExpression | FetchXmlToQueryExpression | None
FindParent | FindParentResourceGroup | None
Fulfill | FulfillSalesOrder | None
GenerateInvoiceFromOpportunity | GenerateInvoiceFromOpportunity | None
GenerateQuoteFromOpportunity | GenerateQuoteFromOpportunity | None
GenerateSalesOrderFromOpportunity | GenerateSalesOrderFromOpportunity | None
GetAllTimeZonesWithDisplayName | GetAllTimeZonesWithDisplayName | None
GetDecryptionKey | GetDecryptionKey | None
GetDistinctValues | GetDistinctValuesImportFile | None
GetHeaderColumns | GetHeaderColumnsImportFile | None
GetInvoiceProductsFromOpportunity | GetInvoiceProductsFromOpportunity | None
GetQuantityDecimal | GetQuantityDecimal | Quantify
GetQuoteProductsFromOpportunity | GetQuoteProductsFromOpportunity | None
GetReportHistoryLimit | GetReportHistoryLimit | None
GetSalesOrderProductsFromOpportunity | GetSalesOrderProductsFromOpportunity | None
GetTimeZoneCodeByLocalizedName | GetTimeZoneCodeByLocalizedName | None
GetTrackingToken | GetTrackingTokenEmail | None
GetValidManyToMany | GetValidManyToMany | None
GetValidReferencedEntities | GetValidReferencedEntities | None
GetValidReferencingEntities | GetValidReferencingEntities | None
GrantAccess | GrantAccess | Owned
ImportMappings | ImportMappingsImportMap | None
ImportRecords | ImportRecordsImport | None
ImportSolution | ImportSolution | None
ImportTranslation | ImportTranslation | None
InitializeFrom | InitializeFrom | None
InsertOptionValue | InsertOptionValue | None
InsertStatusValue | InsertStatusValue | None
InstallSampleData | InstallSampleData | None
Instantiate | InstantiateTemplate | None
InstantiateFilters | InstantiateFilters | None
IsBackOfficeInstalled | IsBackOfficeInstalled | None
IsComponentCustomizable | IsComponentCustomizable | Solution
IsValidStateTransition | IsValidStateTransition | None
LocalTimeFromUtcTime | LocalTimeFromUtcTime | None
LockInvoicePricing | LockInvoicePricing | None
LockSalesOrderPricing | LockSalesOrderPricing | None
LogFailure | LogFailureBulkOperation | None
LogSuccess | LogSuccessBulkOperation | None
Lose | LoseOpportunity | None
MakeAvailableToOrganization | MakeAvailableToOrganizationReport | None
MakeAvailableToOrganization | MakeAvailableToOrganizationTemplate | None
MakeUnavailableToOrganization | MakeUnavailableToOrganizationReport | None
MakeUnavailableToOrganization | MakeUnavailableToOrganizationTemplate | None
Merge | Merge | Merge
ModifyAccess | ModifyAccess | Owned
OrderOption | OrderOption | None
Parse | ParseImport | None
ProcessInbound | ProcessInboundEmail | None
ProcessOneMemberBulkOperation | ProcessOneMemberBulkOperation | None
PropagateByExpression | PropagateByExpression | None
ProvisionLanguage | ProvisionLanguage | None
Publish | PublishXml | None
Publish | PublishDuplicateRule | None
PublishAll | PublishAllXml | None
QualifyLead | QualifyLead | None
QualifyMember | QualifyMemberList | None
Query | QuerySchedule | None
QueryMultiple | QueryMultipleSchedules | None
ReassignObjects | ReassignObjectsSystemUser | None
ReassignObjectsEx | ReassignObjectsOwner | None
Recalculate | Recalculate | Recalculate
RemoveItem | RemoveItemCampaign | None
RemoveItem | RemoveItemCampaignActivity | None
RemoveMember | RemoveMemberList | None
RemoveMembers | RemoveMembersTeam | None
RemoveParent | RemoveParent | RemoveParent
RemovePrivilege | RemovePrivilegeRole | None
RemoveProductFromKit | RemoveProductFromKit | None
RemoveRelated | RemoveRelated | Related
RemoveSolutionComponent | RemoveSolutionComponent | Solution
RemoveSubstitute | RemoveSubstituteProduct | None
Renew | RenewContract | None
ReplacePrivileges | ReplacePrivilegesRole | None
Reschedule | Reschedule | Schedule
ResetUserFilters | ResetUserFilters | None
Retrieve | Retrieve | Retrieve
RetrieveAbsoluteAndSiteCollectionUrl | RetrieveAbsoluteAndSiteCollectionUrl | RetrieveAbsoluteUrl
RetrieveAllChildUsers | RetrieveAllChildUsersSystemUser | None
RetrieveAllEntities | RetrieveAllEntities | None
RetrieveAllManagedProperties | RetrieveAllManagedProperties | None
RetrieveAllOptionSets | RetrieveAllOptionSets | None
RetrieveApplicationRibbon | RetrieveApplicationRibbon | None
RetrieveAttribute | RetrieveAttribute | None
RetrieveAttributeChangeHistory | RetrieveAttributeChangeHistory | None
RetrieveAuditDetails | RetrieveAuditDetails | None
RetrieveAuditPartitionList | RetrieveAuditPartitionList | None
RetrieveAvailableLanguages | RetrieveAvailableLanguages | None
RetrieveBusinessHierarchy | RetrieveBusinessHierarchyBusinessUnit | None
RetrieveByGroup | RetrieveByGroupResource | None
RetrieveByResource | RetrieveByResourceResourceGroup | None
RetrieveByResources | RetrieveByResourcesService | None
RetrieveByTopIncidentProduct | RetrieveByTopIncidentProductKbArticle | None
RetrieveByTopIncidentSubject | RetrieveByTopIncidentSubjectKbArticle | None
RetrieveDependenciesForDelete | RetrieveDependenciesForDelete | None
RetrieveDependenciesForUninstall | RetrieveDependenciesForUninstall | None
RetrieveDependentComponents | RetrieveDependentComponents | None
RetrieveDeploymentLicenseType | RetrieveDeploymentLicenseType | None
RetrieveDeprovisionedLanguages | RetrieveDeprovisionedLanguages | None
RetrieveDuplicates | RetrieveDuplicates | None
RetrieveEntity | RetrieveEntity | None
RetrieveEntityRibbon | RetrieveEntityRibbon | None
RetrieveExchangeRate | RetrieveExchangeRate | None
RetrieveFilteredForms | RetrieveFilteredForms | None
RetrieveFormattedImportJobResults | RetrieveFormattedImportJobResults | None
RetrieveFormXml | RetrieveFormXml | None
RetrieveInstalledLanguagePacks | RetrieveInstalledLanguagePacks | None
RetrieveInstalledLanguagePackVersion | RetrieveInstalledLanguagePackVersion | None
RetrieveLicenseInfo | RetrieveLicenseInfo | None
RetrieveLocLabels | RetrieveLocLabels | None
RetrieveManagedProperty | RetrieveManagedProperty | None
RetrieveMembers | RetrieveMembersTeam | None
RetrieveMembersBulkOperation | RetrieveMembersBulkOperation | None
RetrieveMissingComponents | RetrieveMissingComponents | None
RetrieveMissingDependencies | RetrieveMissingDependencies | None
RetrieveMultiple | RetrieveMultiple | Retrieve
RetrieveOptionSet | RetrieveOptionSet | None
RetrieveOrganizationResources | RetrieveOrganizationResources | None
RetrieveParentGroups | RetrieveParentGroupsResourceGroup | None
RetrieveParsedData | RetrieveParsedDataImportFile | None
RetrievePrincipalAccess | RetrievePrincipalAccess | Owned
RetrievePrincipalAttributePrivileges | RetrievePrincipalAttributePrivileges | None
RetrievePrivilegeSet | RetrievePrivilegeSet | None
RetrieveProvisionedLanguagePackVersion | RetrieveProvisionedLanguagePackVersion | None
RetrieveProvisionedLanguages | RetrieveProvisionedLanguages | None
RetrieveRecordChangeHistory | RetrieveRecordChangeHistory | None
RetrieveRelationship | RetrieveRelationship | None
RetrieveRequiredComponents | RetrieveRequiredComponents | None
RetrieveRolePrivileges | RetrieveRolePrivilegesRole | None
RetrieveSharedPrincipalsAndAccess | RetrieveSharedPrincipalsAndAccess | Owned
RetrieveSubGroups | RetrieveSubGroupsResourceGroup | None
RetrieveSubsidiaryTeams | RetrieveSubsidiaryTeamsBusinessUnit | None
RetrieveSubsidiaryUsers | RetrieveSubsidiaryUsersBusinessUnit | None
RetrieveTeamPrivileges | RetrieveTeamPrivileges | None
RetrieveTeams | RetrieveTeamsSystemUser | None
RetrieveTimestamp | RetrieveTimestamp | None
RetrieveUnpublished | RetrieveUnpublished | RetrieveUnpublished
RetrieveUnpublishedMultiple | RetrieveUnpublishedMultiple | Retrieve
RetrieveUserPrivileges | RetrieveUserPrivileges | None
RetrieveUserSettings | RetrieveUserSettingsSystemUser | None
RetrieveVersion | RetrieveVersion | None
Revise | ReviseQuote | None
RevokeAccess | RevokeAccess | Owned
Rollup | Rollup | Rollup
Search | Search | None
SearchByBody | SearchByBodyKbArticle | None
SearchByKeywords | SearchByKeywordsKbArticle | None
SearchByTitle | SearchByTitleKbArticle | None
Send | SendTemplate | None
Send | SendFax | None
Send | SendEmail | None
SendFromTemplate | SendEmailFromTemplate | SendFromTemplate
SetBusiness | SetBusinessSystemUser | None
SetBusiness | SetBusinessEquipment | None
SetLocLabels | SetLocLabels | None
SetParent | SetParentBusinessUnit | None
SetParent | SetParentSystemUser | None
SetParent | SetParentTeam | None
SetRelated | SetRelated | Related
SetReportRelated | SetReportRelated | None
SetStateDynamicEntity | SetState | None
StatusUpdateBulkOperation | StatusUpdateBulkOperation | None
Transform | TransformImport | None
TriggerServiceEndpointCheck | TriggerServiceEndpointCheck | None
UninstallSampleData | UninstallSampleData | None
UnlockInvoicePricing | UnlockInvoicePricing | None
UnlockSalesOrderPricing | UnlockSalesOrderPricing | None
Unpublish | UnpublishDuplicateRule | None
Update | Update | Update
UpdateAttribute | UpdateAttribute | None
UpdateEntity | UpdateEntity | None
UpdateOptionSet | UpdateOptionSet | None
UpdateOptionValue | UpdateOptionValue | None
UpdateRelationship | UpdateRelationship | None
UpdateStateValue | UpdateStateValue | None
UpdateUserSettings | UpdateUserSettingsSystemUser | None
UtcTimeFromLocalTime | UtcTimeFromLocalTime | None
Validate | ValidateSavedQuery | None
Validate | Validate | None
ValidateRecurrenceRule | ValidateRecurrenceRule | Recurrence
VerifyProcessStateData | VerifyProcessStateData | None
WhoAmI | WhoAmI | None
Win | WinOpportunity | None
Win | WinQuote | None

See Also

Concepts

Plug-in registration entities
SdkMessageFilter entity messages and methods
SdkMessage entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessageFilter entity messages and methods

This entity represents a filter that defines which SDK messages are valid for each type of entity. The schema name for this entity is SdkMessageFilter. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves an SDK message filter. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of SDK message filters. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

Plug-in registration entities
SdkMessageProcessingStep entity messages and methods
SdkMessageFilter entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessageProcessingStep entity messages and methods

This entity defines how a plug-in or custom workflow activity should be registered in a stage of the event execution pipeline and under what conditions it should be executed. The schema name for this entity is SdkMessageProcessingStep. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an SDK message processing step. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an SDK message processing step. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an SDK message processing step. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of SDK message processing steps. You can also call the IOrganizationService.RetrieveMultiple method.
SetStateRequest | Sets the state of the SDK message processing step. The possible states are defined in the SdkMessageProcessingStepState enumeration. For a list of possible states, see SDKMessageProcessingStep entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an SDK message processing step. You can also call the IOrganizationService.Update method.

See Also

Concepts

Plug-in registration entities
SdkMessageProcessingStepImage entity messages and methods
SdkMessageProcessingStep entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessageProcessingStepImage entity messages and methods

This entity represents a copy (snapshot) of an entity's attributes before or after the core platform operation. The schema name for this entity is SdkMessageProcessingStepImage. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an SDK message processing step image. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an SDK message processing step image. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an SDK message processing step image. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of SDK message processing step images. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates an SDK message processing step image. You can also call the IOrganizationService.Update method.

See Also

Reference

Pre and Post Entity Images

Concepts

Plug-in registration entities
SdkMessageProcessingStepSecureConfiguration entity messages and methods
SdkMessageProcessingStepImage entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessageProcessingStepSecureConfiguration entity messages and methods

This entity represents a secure (not publicly readable) custom configuration that is passed to a plug-in's constructor. The schema name for this entity is SdkMessageProcessingStepSecureConfig. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an SDK message processing step secure configuration. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an SDK message processing step secure configuration. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an SDK message processing step secure configuration. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of SDK message processing step secure configurations. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updatea an SDK message processing step secure configuration. You can also call the IOrganizationService.Update method.

See Also

Concepts

Plug-in registration entities
SdkMessageProcessingStepSecureConfig entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write workflows to automate business processes

Business processes are an integral part of any enterprise software application. A business process can be of two types: automated processes that rely solely on communication among applications based on a set of rules, and interactive processes that also rely on people to initiate and run the process, and to make the appropriate decisions during the running of the process.

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, a process enables you to create and manage your automated and interactive business processes. While the name has been changed from workflow to process, the entity that is used to implement a process is still called workflow. A Microsoft Dynamics CRM process provides many out-of-the-box components that business users and administrators can use to model their business processes. Microsoft Dynamics CRM also offers developers a mechanism to extend and customize the standard behavior of processes to achieve the functionality that their business applications require by allowing them to develop custom components.

A Microsoft Dynamics CRM process is based on the Windows Workflow Foundation programming model. Windows Workflow Foundation provides a runtime engine, a framework, a base library of activities, and default implementations of the runtime services. The Windows Workflow Foundation runtime engine manages process execution, and supports processes that can remain active for extended periods of time. It preserves the state of process execution during computer shutdown and restart.

In This Section

Workflow categories

Workflow process architecture

Workflow and process entities

Supported types, triggers, and entities for processes

Custom workflow activities (workflow assemblies)

Custom XAML workflows

Model business process flows

Create real-time workflows

Create your own actions

Use dialogs for guided processes

Sample code for workflows

Related Sections

Software Development Kit for Microsoft Dynamics CRM

Write plug-ins to extend business processes

Asynchronous service in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Workflow categories

Processes enable you to model real-life business processes, for example best practices or standard practices, in Microsoft Dynamics CRM. There are four categories of processes you can choose from in when modeling your business practices:

  • Workflow. Use this process to model and automate real world business processes. These processes can be configured to run in the background or in real time and can optionally require user input. Workflow processes can start automatically based on specified conditions or can be started manually by a user.
  • Action. Use this process to create a new operation that is not available in a standard Microsoft Dynamics CRM installation or to combine multiple disparate operations into a single operation. For example, in the case of a support call center, you could combine create, assign, and setstate operations into a single new “escalate” operation.
  • Business process flow. Use this process to create a visualization of the business process flow. Users are guided through various stages of the sales or customer service processes. At each stage, you complete specific steps and then move to the next stage. You can customize the process flow by adding or removing steps, changing the order of the stages, or adding new entities to the process flow.
  • Dialog. Use this process to create an interactive step-by-step data entry form that requires user input to start and run to completion. When you start the dialog process, a wizard-like interface is presented so you can make appropriate selections or enter data as you progress through each page of the wizard.

The processes’ capability is implemented using Windows Workflow Foundation. The latest version of Windows Workflow Foundation has improved to facilitate easier creation, running, and maintenance of workflows to implement custom functionalities in your application. More information: What's New in Windows Workflow Foundation

There are three ways to create business processes: interactively through the web application forms and the workflow designer, by writing code that uses workflow related classes, and by importing a pre-made workflow in a solution. Because the SDK is developer-focused, we are covering the coding aspect of creating workflow processes.

XAML (Declarative) workflows

You can create XAML workflows for on-premises Microsoft Dynamics CRM, which you visually design and create by using the Microsoft Visual Studio Workflow Designer. This method of creating workflows does not require that you write code. Moreover, you do not have to compile these workflows, and can import the workflow definition (XAML) into Microsoft Dynamics CRM. In addition to creating new workflows, you can also use the Microsoft Visual Studio Workflow Designer to visually modify existing workflows in Microsoft Dynamics CRM, and then import the updated workflow into Microsoft Dynamics CRM.

Note
You cannot view or update a workflow definition for a workflow that was created or modified outside of Microsoft Dynamics CRM. You can only change the state (activate or deactivate) of the workflow, and run it. XAML workflows aren’t supported in Microsoft Dynamics CRM Online.

Differences between workflows and dialogs

The following table provides information about the differences between workflows and dialogs in Microsoft Dynamics CRM.

Workflows | Dialogs
Can be either started by a user or can be automated. | Must be started by a user.
Are asynchronous or real-time processes, and do not require user input to run to completion. Asynchronous processes run in the background while real-time processes run immediately. | Are real-time processes that require user input to run to completion. When you run these processes, a wizard-like interface is presented to you so you can make appropriate selections to run the processes.
The entity that stores the details about a running asynchronous workflow is AsyncOperation while a Process is used for a real-time workflow. | The entity that stores information generated by a running dialog is the ProcessSession entity.
Triggers are supported for workflows. For a list of supported triggers, see Supported types, triggers, and entities for processes. | Triggers are not supported for dialogs.
Workflows that are created or updated outside of Microsoft Dynamics CRM by creating or updating the underlying XAML file are supported in Microsoft Dynamics CRM on-premises. For information about these custom XAML workflows, see Custom XAML workflows. | There is no support for created dialogs outside of Microsoft Dynamics CRM by defining XAML.

When to use a workflow instead of a plug-in

Most operations that can be accomplished by using workflows can also be accomplished by using plug-ins. However, you should use workflow processes instead of plug-ins when:

  • Changes in the business logic must be performed by people who are not developers, or the changes should not be dependent on the availability of a developer to do the work. When custom workflow activities are defined as Workflow .NET assemblies, a person who is not a developer can use Microsoft Dynamics CRM to define the conditions when the custom actions are performed and the parameters that will be passed to the assembly.
  • You need the ability to let users apply your workflow logic manually. With workflow processes, users can trigger the processing of workflow rules by clicking Run Workflow on the form or from a grid.

Use plug-ins when you need the best performance possible from your custom business logic. Plug-ins can start quicker and therefore typically run faster that even a real-time workflow. However, the benefit in performance may be outweighed by the ease of use in creating and maintaining workflows where only a non-developer, for example a business analyst, is required to do the work.

For more information about plug-ins, see Write plug-ins to extend business processes.

Distributing workflows in solutions

You can include workflows and custom workflow activities in a solution that is imported into another Microsoft Dynamics CRM deployment. However, if you refer to specific entity instances in a workflow and the workflow is moved into another system, problems will arise because the unique IDs of the entity instances in the workflow will differ from those in the target system. Microsoft Dynamics CRM automatically resolves system user and currency entity records based on the full name property, but it won't automatically resolve records for other entity types.

More information: Package and distribute extensions using solutions.

See Also

Other Resources

Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Workflow process architecture

The process management system in Microsoft Dynamics CRM includes the Microsoft Dynamics CRM SDK, plug-ins, forms, and other components.

In This Topic

Process architecture diagram

Process and the unified event model

Process life cycle

Process and the asynchronous service: For workflows only

Process persistence and shutdown: For workflows only

Process architecture diagram

The following diagram illustrates the high-level system architecture for Microsoft Dynamics CRM, and highlights parts of the system that are specific to processes.

This diagram shows the process architecture of Microsoft Dynamics CRM including the internal components, the external components, the infrastructure, and the data.

Internal Components. The internal components that support the Microsoft Dynamics CRM process programming model include Web services, shared platform, and business logic. The shared platform consists of common Microsoft Dynamics CRM components that provide registration, metadata cache, and data access services. Business logic contains the implementation of business logic for Microsoft Dynamics CRM business entities.

External Components. The external components are as follows:

  • Windows Workflow Foundation object model, which contains a set of classes used to create and parse workflow process definitions in XAML format.
  • Windows Workflow Foundation execution, which contains a set of classes used to execute workflow processes.

Process Infrastructure. The Microsoft Dynamics CRM process infrastructure consists of the following components:

  • Process entity model, which contains a set of classes that use the Windows Workflow Foundation object model and expose Microsoft Dynamics CRM workflow activities.
  • Process business logic, which implements business logic for process-specific entities.
  • Process execution, which provides workflow execution services, such as workflow hosting and persistence.

Process Data. The Microsoft Dynamics CRM process programming model is supported by the following data:

  • Business data, which contains information associated with Microsoft Dynamics CRM entities.
  • Process configuration data, which includes workflow process definitions, compiled workflow processes, and workflow process settings.
  • Process runtime data, which is required to execute workflow processes and implement workflow process features, such as persistence and notifications.

Process and the unified event model

Microsoft Dynamics CRM uses a unified event model that is used in both plug-ins (callouts) and in processes. This event processing subsystem adds more flexibility to the execution of processes and plug-ins by introducing the pipeline execution model.

Using this model, processes and plug-ins are executed based on their registration, message type, and a predefined set of configurable parameters. The core platform operations take part in the execution sequence to form a much more reliable and extensible execution model.

Process life cycle

The life cycle of a process describes the state transitions from creation through execution. A process can be in one of the following states: Ready, Suspended, Locked, and Completed. The events that occur throughout the lifetime of the process cause a transition from one state to another.

Workflows

The workflow life cycle is as follows:

  1. When you create a workflow, it is in the Draft state. You must activate the workflow before it can run. When you activate a workflow, it subscribes to specific Microsoft Dynamics CRM events. When these events are triggered in the platform, a snapshot of the workflow dependencies and input parameters are created and a new asynchronous operation is added to the asynchronous service queue manager. The asynchronous operation represents a workflow execution job and awaits execution in the queue in the Ready state.
  2. When the asynchronous operation is processed, a workflow instance, associated with this operation, is created by the Windows Workflow Foundation run-time engine and the state of it is changed from Ready to Locked.
  3. The asynchronous operation is updated with the workflow instance state status on each transition. When the asynchronous operation is blocked, the Windows Workflow Foundation run-time engine puts the workflow instance into the Suspended state and removes it from memory. When the Suspended state conditions are satisfied, the workflow instance is loaded back into memory.
  4. The workflow execution resumes by putting the workflow instance into a Ready state and then into a Locked state. In the simple scenario, the workflow instance moves to a Completed state when all workflow activities have completed successfully.
    The state of asynchronous operations can also be changed by the user. For example, an asynchronous operation that is in a Suspended state can explicitly be restarted by the user.

Dialogs

A dialog life cycle is as follows:

  1. When you create a dialog, it is in the Draft state. You must activate the dialog before it can be run. A dialog can be run from its primary entity form and grid, or directly by using the URL of the dialog. For more information, see Start Dialog by using an URL.
  2. Every time that you run a dialog, a process session instance is created for the dialog. As you progress with running the dialog, the process session entity is updated with the actions performed during the running of the dialog.
  3. If you completed running the dialog successfully, the corresponding process session record is created with a Complete status. If you canceled the dialog without completing it, the corresponding process session record is created with an Incomplete status.

Process and the asynchronous service: For workflows only

The asynchronous service enables you to execute, monitor, and manage various long-running operations, such as bulk import, bulk mail, and workflow processes. To improve performance, scalability, and reliability of Microsoft Dynamics CRM, these operations are run asynchronously. This means that a requested operation is not processed instantly, but added to a queue and processed by Microsoft Dynamics CRM at an appropriate time.

When an event is raised in the Microsoft Dynamics CRM platform pipeline, all workflows that are associated with the event are executed by the asynchronous service. The workflow event handlers are added to the asynchronous queue and processed according to the event execution order.

Process persistence and shutdown: For workflows only

A workflow can be a long-running business operation that might take hours, weeks, or months to be completed. It can be effectively idle for long periods of time waiting for input from users or other systems.

To improve performance, scalability, and reliability of Microsoft Dynamics CRM, long-running operations such as workflows use the asynchronous service.

The asynchronous service, as the host of the Windows Workflow Foundation runtime engine, cannot always cache and keep active all objects that accumulate during continued workflow activity. When certain conditions, such as restart or shutdown occur when a workflow is running, the workflow runtime engine uses a persistence service to save the state of the workflow instance onto the disk. The persistence service is also invoked when other conditions occur, such as when a workflow becomes idle and is waiting for some external event to occur. Persisting these idle workflow instances saves memory and greatly increases scalability. If a server that is running the asynchronous service is shut down or if the workflow crashes during execution, the workflow can be restarted from its last persisted point after the server restarts. When the workflow is no longer idle, the state of the workflow instance is restored in memory to the state at the last persisted point.

More information: Workflow Persistence.

See Also

Concepts

Event execution pipeline

Other Resources

Asynchronous service in Microsoft Dynamics CRM
Introduction to the event framework
Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Workflow and process entities

The Microsoft Dynamics CRM workflow object model is a set of classes that uses the Windows Workflow Foundation object model and exposes Microsoft Dynamics CRM workflow activities. These classes are found in the Microsoft.Xrm.Sdk.Workflow assembly. For more information, see Microsoft.Xrm.Sdk.Workflow.

Workflow activities are the elemental units of a workflow (process). They are added to a workflow (process) to form a hierarchical tree structure. When all activities in a given path are finished running, the workflow (process) instance is completed.

The workflow entity stores the definition of a workflow (process). This definition contains the XAML string that describes the workflow activity, and also the rules used in the process.

The validity of a workflow definition may depend on external data. There are several types of dependencies that are supported:

  • SDK operation: If a process is triggered on a specific SDK operation, it cannot be deleted.
  • Input entity: A process depends on a snapshot of a record passed in to the workflow.
  • Local parameter: A formal description of a .NET property to be defined by the process type.

The workflow log entity contains detailed information about logical steps completed during the execution of a workflow. Similarly, the process session entity contains information about the running of a dialog.

If a workflow was created in the web application and the workflow definition has the Workflow.AsyncAutoDelete attribute set to true, and the workflow has a single step in it that is not a Stage/Wait/Condition step, no WorkflowLog records will be created. This is an platform optimization to improve performance and save disk space.

There are two messages you can use to work with processes. SetStateRequest is used to set the state of the process: draft or activated. CreateWorkflowFromTemplateRequest is used to create a process from a process template.

See Also

Concepts

Supported types, triggers, and entities for processes
Workflow (process) entity messages and methods
WorkflowLog (process log) entity messages and methods
ProcessSession entity messages and methods

Other Resources

Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Workflow (process) entity messages and methods

The workflow (process) entity represents a series of interrelated action steps and the workflow rules that drive the transition between these steps. A workflow process defines the actions the workflow should take at each step and the workflow rules that the workflow should use to evaluate when to go to the next step. The schema name for this entity is Workflow. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with theIOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a workflow to another user or team.
CreateRequest | Creates a workflow. You can also call the IOrganizationService.Create method.
CreateWorkflowFromTemplateRequest | Creates a workflow from a workflow template.
DeleteRequest | Deletes a workflow. You can also call the IOrganizationService.Delete method.
ExecuteWorkflowRequest | Executes a workflow.
GrantAccessRequest | Shares a workflow with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a workflow previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a workflow. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of workflows. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a workflow.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a workflow, together with their access rights to the workflow.
RevokeAccessRequest | Removes all access to a workflow for the specified security principal (user or team).
SetStateRequest | Sets the state of a workflow.The possible states are defined in the WorkflowState enumeration. You can see the states in the Workflow entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a workflow. You can also call the IOrganizationService.Update method.

See Also

Concepts

Workflow and process entities
Workflow (process) entity privileges
WorkflowLog (process log) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WorkflowLog (process log) entity messages and methods

A workflow log (process log) stores a result, succeed, failed or canceled, for each step of a process that is executed, for both workflows and dialogs. The schema name for this entity is WorkflowLog. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a workflow log (process log).You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a workflow log (process log).You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a workflow log (process log).You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of workflow logs (process logs).You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a workflow log (process log).You can also call the IOrganizationService.Update method.

See Also

Concepts

Workflow and process entities
ProcessSession entity messages and methods
Workflow categories
WorkflowLog (process log) entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProcessSession entity messages and methods

A process session is created every time you run a dialog process. It contains the log about the session such as the user who ran it, the time when it was started and completed, the actions performed during the running of the dialog process, and so on. The schema name for this entity is ProcessSession. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a process session to another user or team.
CreateRequest | Creates a process session. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a process session. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a process session with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a process session previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a process session. You can also call the Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of process sessions. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a process session.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a process session, together with their access rights to the process session.
RevokeAccessRequest | Removes all access to a process session for the specified security principal (user or team).
SetStateRequest | Sets the state of a process session. The possible states are defined in the ProcessSession.State attribute. If you are using early bound types, use the ProcessSessionState enumeration. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a process session. You can also call the IOrganizationService. Update method.
VerifyProcessStateDataRequest | Verifies the state of a process session .

See Also

Concepts

Use dialogs for guided processes
Workflow and process entities
Workflow (process) entity messages and methods
WorkflowLog (process log) entity messages and methods
Workflow (process) entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Supported types, triggers, and entities for processes

This topic provides information about the supported types and entities for processes in Microsoft Dynamics CRM, supported triggers for workflows, and entities that are supported for the CreateEntity activity.

In This Topic

Supported triggers for workflows

Supported types for processes

Supported entities for processes

Supported triggers for workflows

The following actions can be used to trigger a workflow automatically.

Request | Message | Trigger
AssignRequest | Assign | Record is assigned.
BookRequest | Book | Record is created.
CancelContractRequest CancelSalesOrderRequest | Cancel | Record status changes.
CloneContractRequest | Clone | Record is created.
CloseIncidentRequest CloseQuoteRequest | Close | Record status changes.
CompoundCreateRequest | CompoundCreate | Record is created.
CompoundUpdateRequest | CompoundUpdate | Record is updated.
ConvertKitToProductRequest | ConvertKitToProduct | Record is updated.
ConvertQuoteToSalesOrderRequest | ConvertProductToKit | Record is updated.
ConvertQuoteToSalesOrderRequest | ConvertQuoteToSalesOrder | Record is created.
ConvertSalesOrderToInvoiceRequest | ConvertSalesOrderToInvoice | Record is created.
CopyCampaignRequest CopyMembersListRequest | Copy | Record is created.
CreateRequest | Create | Record is created.
DeleteRequest | Delete | Record is deleted.
DeliverIncomingEmailRequest | DeliverIncoming | Record is created.
DeliverPromoteEmailRequest | DeliverPromote | Record is created.
FulfillSalesOrderRequest | Fulfill | Record status changes.
GenerateInvoiceFromOpportunityRequest | GenerateInvoiceFromOpportunity | Record is created.
GenerateQuoteFromOpportunityRequest | GenerateQuoteFromOpportunity | Record is created.
GenerateSalesOrderFromOpportunityRequest | GenerateSalesOrderFromOpportunity | Record is created.
GetInvoiceProductsFromOpportunityRequest | GetInvoiceProductsFromOpportunity | Record is created.
GetQuoteProductsFromOpportunityRequest | GetQuoteProductsFromOpportunity | Record is created.
GetSalesOrderProductsFromOpportunityRequest | GetSalesOrderProductsFromOpportunity | Record is created.
LockInvoicePricingRequest | LockInvoicePricing | Record is updated.
LockSalesOrderPricingRequest | LockSalesOrderPricing | Record is updated.
LoseOpportunityRequest | Lose | Record status changes.
MakeAvailableToOrganizationReportRequest MakeAvailableToOrganizationTemplateRequest | MakeAvailableToOrganization | Record is updated.
MakeUnavailableToOrganizationReportRequest MakeUnavailableToOrganizationTemplateRequest | MakeUnavailableToOrganization | Record is updated.
MergeRequest | Merge | Record is updated.
RemoveParentRequest | RemoveParent | Record is updated.
RenewContractRequest | Renew | Record is created.
RescheduleRequest | Reschedule | Record is updated.
ReviseQuoteRequest | Revise | Record is created.
SendBulkMailRequest | SendBulkMail | Record status changes.
SendEmailFromTemplateRequest | SendEmailFromTemplate | Record is created.
SendFaxRequest | SendFax | Record status changes.
SetBusinessEquipmentRequest SetBusinessSystemUserRequest | SetBusiness | Record is updated.
SetParentBusinessUnitRequest SetParentSystemUserRequest SetParentTeamRequest | SetParent | Record is updated.
SetStateRequest | SetState | Record status changes.
UnlockInvoicePricingRequest | UnlockInvoicePricing | Record is updated.
UnlockSalesOrderPricingRequest | UnlockSalesOrderPricing | Record is updated.
UpdateRequest | Update | Record is updated.
WinOpportunityRequest WinQuoteRequest | Win | Record status changes.

Supported types for processes

This topic provides the supported types that you can use in your code for processes inMicrosoft Dynamics CRM 2015.

Microsoft .NET Framework 4.5.2

Namespace | Type name
System.Activities.Statements | AddToCollection<T>
System.Activities.Statements | Assign
System.Activities.Statements | Catch<TException>
System.Activities.Statements | ClearCollection<T>
System.Activities.Statements | DoWhile
System.Activities.Statements | ExistsInCollection<T>
System.Activities.Statements | ForEach<T>
System.Activities.Statements | If
System.Activities.Statements | Interop
System.Activities.Statements | InvokeMethod
System.Activities.Statements | Persist
System.Activities.Statements | RemoveFromCollection<T>
System.Activities.Statements | Rethrow
System.Activities.Statements | Sequence
System.Activities.Statements | Switch<T>
System.Activities.Statements | TerminateWorkflow
System.Activities.Statements | Throw
System.Activities.Statements | TryCatch
System.Activities.Statements | While
System.Activities.Statements | Receive
System.Activities.Statements | Send
System.ServiceModel.Activities.Presentation.Factories | SendAndReceiveReplyFactory

For information about each type, see the following documentation for the respective namespaces:

  • System.Activities.Statements Namespace
  • System.ServiceModel.Activities Namespace
  • System.ServiceModel.Activities.Presentation.Factories

Microsoft Dynamics CRM 2015

Namespace | Type name
Microsoft.Xrm.Sdk | All types
Microsoft.Xrm.Sdk.Workflow | All types
Microsoft.Xrm.Sdk.Workflow.Activities | All types
Microsoft.Crm.Sdk | All types

Supported entities for processes

The following table lists the entities that can be used to trigger process execution or to create a record within a process by using the CreateEntity class. This list is determined by the CanTriggerWorkflow property for each entity.

Entity name | Trigger a process | Used for CreateEntity
Account | Yes | Yes
Annotation | Yes | Yes
Appointment | Yes | Yes
BusinessUnit | Yes | No
BusinessUnitNewsArticle | Yes | No
Campaign | Yes | Yes
CampaignActivity | Yes | Yes
CampaignResponse | Yes | Yes
Competitor | Yes | Yes
Connection | Yes | Yes
ConnectionRole | Yes | No
ConstraintbasedGroup | Yes | No
Contact | Yes | Yes
Contract | Yes | Yes
ContractDetail | Yes | No
ContractTemplate | Yes | No
CustomerAddress | Yes | No
CustomerOpportunityRole | Yes | No
CustomerRelationship | Yes | No
Discount | Yes | No
DiscountType | Yes | No
Email | Yes | Yes
Equipment | Yes | No
Fax | Yes | Yes
Goal | Yes | Yes
Incident | Yes | Yes
Invoice | Yes | Yes
InvoiceDetail | Yes | No
KbArticle | Yes | No
KbArticleComment | Yes | No
KbArticleTemplate | Yes | No
Lead | Yes | Yes
Letter | Yes | Yes
List | Yes | Yes
Metric | No | Yes
MailMergeTemplate | Yes | No
Opportunity | Yes | Yes
OpportunityProduct | Yes | No
PhoneCall | Yes | Yes
PriceLevel | Yes | Yes
ProcessSession | Yes | No
Product | Yes | No
ProductPriceLevel | Yes | No
Queue | Yes | Yes
QueueItem | No | Yes
Quote | Yes | Yes
QuoteDetail | Yes | No
RecurringAppointmentMaster | Yes | Yes
RollupField | No | Yes
RelationshipRole | Yes | No
Report | Yes | No
SalesLiterature | Yes | Yes
SalesLiteratureItem | Yes | No
SalesOrder | Yes | Yes
SalesOrderDetail | Yes | No
Service | Yes | No
ServiceAppointment | Yes | Yes
SharePointDocumentLocation | Yes | Yes
SharePointSite | Yes | Yes
Site | Yes | Yes
Subject | Yes | No
SystemUser | Yes | Yes
Task | Yes | Yes
Team | Yes | No
Template | Yes | No
Territory | Yes | Yes
TransactionCurrency | Yes | No

See Also

Other Resources

Write workflows to automate business processes
Custom workflow activities (workflow assemblies)
CreateEntity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Custom workflow activities (workflow assemblies)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update supports the registration and execution of custom workflow activities in addition to the out-of-box activities provided by Windows Workflow Foundation. Windows Workflow Foundation includes an activity library that provides activities for control flow, sending and receiving messages, doing work in parallel, and more. However, to build applications that satisfy your business needs, you may need activities that perform tasks specific to that application. To make this possible, Windows Workflow Foundation supports the creation of custom workflow activities.

You can write custom workflow activities in Microsoft Visual C# or Microsoft Visual Basic .NET code by creating an assembly that contains one or more classes derived from the Windows Workflow Foundation CodeActivity class. This assembly is annotated with .NET attributes to provide the metadata that Microsoft Dynamics CRM uses at runtime to link your code to the workflow engine.

After you have created an assembly that contains one or more custom workflow activities, you register this assembly with Microsoft Dynamics CRM. This process is similar to registering a plug-in. The custom workflow activity can then be incorporated into a workflow or dialog in the Process form in Microsoft Dynamics CRM.

Note
Microsoft Dynamics CRM Online only supports sandbox (partial trust) execution of custom workflow activities. On-premises Microsoft Dynamics CRM 2015 supports execution of custom workflow activities in partial or full trust.

In This Section

Create a custom workflow activity

Add metadata to a custom workflow activity

Use the IOrganization web service in a custom workflow activity

Register and use a custom workflow activity assembly

Debug a custom workflow activity

Update a custom workflow activity using assembly versioning

Process classes, attributes, and types

Sample: Create a custom workflow activity

Sample: Update next birthday using a custom workflow activity

Sample: Calculate a credit score with a custom workflow activity

Related Sections

Write workflows to automate business processes

Write plug-ins to extend business processes

Plug-in isolation, trusts, and statistics

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create a custom workflow activity

This topic describes how to create a custom workflow activity and register it for use in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. For Microsoft Dynamics CRM Online, custom workflow activities can only be registered to execute in the sandbox (partial trust). For more information about the sandbox and partial trust, see Plug-in isolation, trusts, and statistics.

In This Topic

Required software and assemblies

Use the CodeActivity workflow base class

Specify the name and group name for a custom workflow Activity

Required software and assemblies

To develop Windows Workflow Foundation 4 custom activities, you must develop them on Microsoft .NET Framework 4.5.2. The following assemblies must be added as references in your project. They can be found in the SDK\Bin folder of the Microsoft Dynamics CRM SDK. Download the Microsoft Dynamics CRM SDK package.

  • Microsoft.Xrm.Sdk.dll
  • Microsoft.Xrm.Sdk.Workflow.dll

Use the CodeActivity workflow base class

To create a custom workflow activity, create a class that inherits from the CodeActivity workflow base class. This class is available in the System.Activities namespace. Activities that inherit from the CodeActivity class can override the Execute method to produce custom functionality.

  1. Start Microsoft Visual Studio.

  2. On the File menu, click New, and then click Project.

  3. In the New Project dialog box, select Workflow under Visual C# in the Installed Templates pane, and then select Activity Library.

  4. Specify a name and location for the solution, and then click OK.

  5. Navigate to the Project menu and select Properties. On the Application tab, specify .NET Framework 4 as the target framework.

  6. Add references to the Microsoft.Xrm.Sdk.dll and Microsoft.Xrm.Workflow.dll assemblies.

  7. Delete the Activity1.xaml file in the project.

  8. Add a class file (.cs) to the project. In Solution Explorer, right-click the project, select Add, and then click Class. In the Add New Item dialog box, type a name for the class, and then click Add.

  9. Open the class file, and add the following using directives:

    C# Copy Code
    using System.Activities;using Microsoft.Xrm.Sdk;using Microsoft.Xrm.Sdk.Workflow;

  10. Make the class inherit from the CodeActivity class and give it a public access modifier as shown here:

    C# Copy Code
    public class SampleCustomActivity : CodeActivity

  11. Add functionality to the class by adding an Execute method:

    C# Copy Code
    protected override void Execute(CodeActivityContext context){    //Activity code}

    For more information, see Add metadata to a custom workflow activity.

  12. Specify input and output parameters. For more information, see Add metadata to a custom workflow activity.

  13. In the project properties, under the Signing tab, select Sign the assembly and provide a key file name. Custom workflow activity (and plug-in) assemblies must be signed.

  14. Compile the project to create an assembly (.dll).

To view a code sample that demonstrates how to create a custom workflow activity, see Sample: Create a custom workflow activity.

Important
For improved performance, Microsoft Dynamics CRM caches custom workflow activity instances. The custom workflow activity’s Execute method should be written to be stateless because the constructor is not called for every invocation of the custom workflow activity. Also, multiple system threads could execute the custom workflow activity at the same time. All per invocation state information is stored in the context, so it is not recommended to use global variables or member variables to pass data from one invocation to the next.

Specify the name and group name for a custom workflow activity

When you register a custom workflow activity assembly, specify the name and group name. The name property specifies the name of the workflow activity. The group name property specifies the name of the submenu added to the main menu in the Microsoft Dynamics CRM process designer. These properties link the custom workflow activity with the Microsoft Dynamics CRM process designer, so that the custom activity name will appear in the user interface.

To specify the name and group name for a custom workflow activity, use the PluginType.Name and PluginType.WorkflowActivityGroupName attributes when you register the custom workflow activity assembly. For more information about registering custom workflow activities, see Register and use a custom workflow activity assembly. If the PluginType.Name and PluginType.WorkflowActivityGroupName attributes are set to null, the custom activity is hidden from the Microsoft Dynamics CRM workflow designer and is only accessible from XAML workflows.

If you are using the Plug-in Registration tool to register the custom workflow activity assembly, you can specify appropriate values in the Name and WorkflowActivityGroupName boxes, under the Editable region. For more information about using the Plug-in Registration tool, see Walkthrough: Register a plug-in using the plug-in registration tool.

Specify the Group Name and Name while registering

After this custom workflow activity is registered, you can use it from the Microsoft Dynamics CRM process designer for workflows or dialogs. For more information, see Register and use a custom workflow activity assembly.

See Also

Concepts

Add metadata to a custom workflow activity
Use the IOrganization web service in a custom workflow activity

Other Resources

Custom workflow activities (workflow assemblies)
Sample: Create a custom workflow activity
Sample: Azure aware custom workflow activity
Windows Workflow Foundation 4 Base Activity Classes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Add metadata to a custom workflow activity

The assembly that contains the custom workflow activity definition is annotated using the .NET attributes to provide the metadata that Microsoft Dynamics CRM uses at runtime to link your code to the workflow engine. For more information about .NET attributes, see Extending Metadata Using Attributes.

Before you start adding metadata to your custom workflow activity definition, ensure that you’re aware of the Microsoft Dynamics CRM types and attributes that are supported for the custom workflow activities. More information: see Process classes, attributes, and types

In This Topic

Add input parameters

Add output parameters

Add input and output attributes for the same parameter

Additional attributes

Add the Execute method

Add input parameters

While specifying the input parameter in your workflow class, you can also specify a default value for the parameter. The following sample shows the definition of an input parameter.

C# Copy Code
[Input("DateTime input")]
[Default("2004-07-09T02:54:00Z")]
public InArgument<DateTime> Date { get; set; }

This input parameter is annotated with the .NET attribute Input. The InputAttribute class derives from the ParameterAttribute class, which takes a parameter (ParameterAttribute.Name) to specify the name of the input attribute. This name appears in the process form assistant in the web application. This lets you map an attribute as an input parameter to the process.

In addition, you can make the input parameter required. More information: RequiredArgumentAttribute

Add output parameters

Output parameters are added in the same manner as the input parameters. The following sample shows the definition of an output parameter.

C# Copy Code
[Output("Money output only")]
[Default("23.3")]
public OutArgument<Money> MoneyOutput { get; set; }

This output parameter is annotated with the .NET attribute Output. The OutputAttribute class derives from the ParameterAttribute class, which takes a parameter (ParameterAttribute.Name) to specify the name of the output attribute. This name appears in the process form assistant in the web application. This lets you map an attribute as an output.

Add input and output attributes for the same parameter

You can use the input and output attributes for the same parameter. In the following code example, IntParameter is the input as well as the output parameter.

C# Copy Code
[Input("Int input")]
[Output("Int output")]
[Default("2322")]
public InOutArgument<int> IntParameter { get; set; }

Additional attributes

Some types, such as EntityReference and OptionSetValue, require additional attributes apart from the Input, Output, and Default attributes. The additional attributes are: ReferenceTarget and AttributeTarget. The following sample shows the definition of a parameter of the EntityReference type.

C# Copy Code
[Input("EntityReference input")]
[Output("EntityReference output")]
[ReferenceTarget("account")]
[Default("3B036E3E-94F9-DE11-B508-00155DBA2902", "account")]
public InOutArgument<EntityReference> AccountReference { get; set; }

For a list of supported types and attributes, see Process classes, attributes, and types.

Add the Execute method

Your custom workflow activity must have an Execute method, as shown in the following example.

C# Copy Code
protected override void Execute(CodeActivityContext context)
{
   if (AccountReference.Get(context).Id != new Guid("3B036E3E-94F9-DE11-B508-00155DBA2902"))
      throw new InvalidPluginExecutionException("Unexpected default value");
}

See Also

Concepts

Create a custom workflow activity
Use the IOrganization web service in a custom workflow activity
Process classes, attributes, and types

Other Resources

Custom workflow activities (workflow assemblies)
Custom workflow activities (workflow assemblies)
Sample: Create a custom workflow activity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the IOrganization web service in a custom workflow activity

To call Microsoft Dynamics CRM 2015 or Microsoft Dynamics CRM Online organization web service methods from within a custom workflow activity, you must first obtain a reference to the web service. This is described in the following procedure and sample code.

  1. Get a reference to IOrganizationServiceFactory.
  2. Use the IOrganizationServiceFactory.CreateOrganizationService method to create an instance of IOrganizationService.
  3. Use the IOrganizationService instance to call the supported methods.

Example

The following sample shows how to get the IOrganizationService from within the Execute method of your custom workflow activity.

C# Copy Code
protected override void Execute(CodeActivityContext executionContext){   // Get the context service.   IWorkflowContext context = executionContext.GetExtension<IWorkflowContext>();   IOrganizationServiceFactory serviceFactory = executionContext.GetExtension<IOrganizationServiceFactory>();   // Use the context service to create an instance of IOrganizationService.   IOrganizationService _orgService = serviceFactory.CreateOrganizationService(context.InitiatingUserId);   // Use the service reference to call web methods.   _orgService.Execute(…);}

See Also

Concepts

Register and use a custom workflow activity assembly
Organization service methods

Other Resources

Custom workflow activities (workflow assemblies)
Sample: Create a custom workflow activity
Use the IOrganizationService web service to read and write data or metadata
IWorkflowContext
IOrganizationServiceFactory
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Register and use a custom workflow activity assembly

After you compile your custom workflow activity to create an assembly, you have to register the assembly with Microsoft Dynamics CRM. Your custom activity will then appear in the process form of Microsoft Dynamics CRM Online or Microsoft Dynamics CRM 2015 depending on which deployment you registered the custom workflow activity with.

In This Topic

Enable or disable custom code

Register a custom workflow activity

Use a custom workflow activity in a process

Enable or disable custom code

You can use Windows PowerShell to enable or disable custom workflow activities and plug-in execution for an on-premises server as described here. Alternatively, you can use the Deployment web service. For more information, see Deployment entities and deployment configuration settings to learn how to set the CustomCodeSettings.AllowExternalCode property.

To enable custom code

  1. Open a Windows PowerShell command window.

  2. Add the Microsoft Dynamics CRM PowerShell snap-in:

    Windows PowerShell Copy Code
    Add-PSSnapin Microsoft.Crm.PowerShell

  3. Retrieve the current setting:

    Windows PowerShell Copy Code
    $setting = get-crmsetting customcodesettings

  4. Modify the current setting:

    Windows PowerShell Copy Code
    $setting.AllowExternalCode="True"
    Windows PowerShell Copy Code
    set-crmsetting $setting

  5. Verify the setting:

    Windows PowerShell Copy Code
    get-crmsetting customcodesettings

To disable custom code

  1. Open a Windows PowerShell command window.

  2. Add the Microsoft Dynamics CRM PowerShell snap-in:

    Windows PowerShell Copy Code
    Add-PSSnapin Microsoft.Crm.PowerShell

  3. Retrieve the current setting:

    NPL Copy Code
    $setting = get-crmsetting customcodesettings

  4. Modify the current setting:

    Windows PowerShell Copy Code
    $setting.AllowExternalCode=0
    Windows PowerShell Copy Code
    set-crmsetting $setting

  5. Verify the setting:

    Windows PowerShell Copy Code
    get-crmsetting customcodesettings

Register a custom workflow activity

Custom workflow activity assemblies are registered using the Plug-in Registration tool. The tool provides a graphical user interface and supports registering assemblies that contain plug-ins or custom workflow activities. When registering an assembly that contains custom workflow activities with Microsoft Dynamics CRM Online, you must register the assembly in the sandbox (partial trust).

For more information about how to register and deploy a custom activity assembly by using the tool, see Specify the Name and Group Name for a Custom Workflow Activity.

Note
You can find the Plug-in Registration tool’s executable file in the SDK\Tools\PluginRegistration folder of the SDK. Download the Microsoft Dynamics CRM SDK package. The tool can be added to the Microsoft Visual Studio Tools menu as an external tool to speed up the development process.

Use a custom workflow activity in a process

After you have registered your custom workflow activity assembly, you can use it in the process designer in Microsoft Dynamics CRM.

To use your custom workflow activity in a process:

  1. Sign in to Microsoft Dynamics CRM.
  2. Go to Settings > Processes. (How do I get there?)
  3. Create or open an existing process.
  4. In the process designer, click or tap Add Step. Your custom workflow activity name will appear in the drop-down list.

See Also

Concepts

Debug a custom workflow activity
Plug-in isolation, trusts, and statistics
Register and Deploy Plug-Ins

Other Resources

Custom workflow activities (workflow assemblies)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Debug a custom workflow activity

To debug a custom workflow activity, copy the .pdb file for the assembly to the %installdir%\server\bin\assembly folder. The assembly can be deployed as on-disk or stored in the database. The recommended deployment is in the database, but for debugging you should choose on-disk. Next, attach the debugger to the CrmAsyncService.exe process. Make sure that you remove the .pdb file when you have finished debugging because it uses memory to have it loaded. For detailed information, see Debug a plug-In.

See Also

Concepts

Update a custom workflow activity using assembly versioning

Other Resources

Custom workflow activities (workflow assemblies)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Update a custom workflow activity using assembly versioning

In Microsoft Dynamics CRM 2015, updates to your custom workflow activity assembly are handled more efficiently because of the improved assembly versioning model.

In This Topic

Understand the assembly version number

Update a custom workflow activity

Upgrade a custom workflow activity

Understand the assembly version number

Each custom workflow activity assembly has a version number. This version number is represented as a four-part string in the following format:

<major_version>.<minor_version>.<build_number>.<revision>

For example, version 1.5.200.5 indicates 1 as the major version, 5 as the minor version, 200 as the build number, and 5 as the revision number.

Update a custom workflow activity

You might want to update your existing workflow activities to fix some bugs or to make changes in some of the private code implementation. When updating a custom workflow activity, make sure that you do not make significant changes in the public classes or method signatures in the underlying code, such as changing the input parameters, because this might break existing workflow instances that use the custom workflow activity.

  1. Make necessary changes in the underlying code of the custom workflow activity.

  2. Change the values for <build_number> and/or <revision> only in the assembly information of the custom workflow activity, and compile it. For example, change the value of your assembly from “1.0.0.0” to “1.0.10.5”.

  3. Update your registered custom workflow activity in Microsoft Dynamics CRM with the new assembly.

After updating the custom workflow activity in Microsoft Dynamics CRM, all existing running process (workflows and dialogs) instances that are using the custom workflow activity will automatically start using the updated activity without requiring you to update the process definitions.

Upgrade a custom workflow activity

You might want to make significant changes to your custom workflow activity such as adding or removing some actions or changing the input/output parameters. In that case, you should upgrade your custom workflow activity.

  1. Make necessary changes in the underlying code of the custom workflow activity.

  2. Change the values for <major_version> and/or <minor_version> in the assembly information of the custom workflow activity, and compile it. For example, change the value of your assembly from “1.0.0.0” to “2.0.0.0”.

  3. Register the upgraded custom workflow activity as a new assembly. Make sure that the new assembly has the same Name, PublicKeyToken, and Culture as the existing assembly to be considered as a different version of the same assembly.

After you upgrade the custom workflow activity, existing running process instances that are using the custom workflow activity will continue to use the older version of the custom workflow activity assembly. This ensures that your existing running process instances do not break. If you want the process to use the new version of the custom workflow activity, you must modify the process definition to use the new version. Microsoft Dynamics CRM displays all the <major_version> and <minor_version> combinations for an assembly in a drop-down list for you to choose from.

Choose a custom workflow activity version

Optionally, after you have updated all your process definitions to use the newer version, you could also unregister the older versions of the custom workflow activity.

See Also

Concepts

Process classes, attributes, and types

Other Resources

Custom workflow activities (workflow assemblies)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Process classes, attributes, and types

This topic provides information about the process classes and types found in Microsoft Dynamics CRM that you can use to work with the custom activities.

In This Topic

Process classes

Attributes and Microsoft Dynamics CRM types

InputAttribute and OutputAttribute

DefaultAttribute

ReferenceTargetAttribute

AttributeTargetAttribute

RequiredArgumentAttribute

Process classes

The process classes are available in the Microsoft.Xrm.Sdk.Workflow namespace (Microsoft.Xrm.Sdk.Workflow.dll). You can use these classes to create custom activities in Windows Workflow Foundation, and then use the activities in the Processes area of Microsoft Dynamics CRM, or in the XAML workflows. For detailed information about the process classes, see Microsoft.Xrm.Sdk.Workflow.

Attributes and Microsoft Dynamics CRM types

The Microsoft Dynamics CRM types are found in the Microsoft.Xrm.Sdk namespace (Microsoft.Xrm.Sdk.dll). Use the InputAttribute and OutputAttribute classes to annotate input and output properties.

The following types are supported for custom workflow activities:

  • Bool
  • DateTime
  • Decimal
  • Double
  • EntityReference
  • Int
  • Money
  • OptionSetValue
  • String

Apart from the Input, Output, and Default attributes, some of the supported Microsoft Dynamics CRM types in the custom workflow activities require you to specify additional attributes such as ReferenceTarget and AttributeTarget. These are described in the following section.

InputAttribute and OutputAttribute

The following sample shows how to add the input and output attributes to a Money parameter used in a custom workflow activity. It also shows how to specify a default value for the property.

C# Copy Code
[Input("Money input")]
[Output("Money output")]
[Default("232.3")]
public InOutArgument<Money> MoneyParameter { get; set; }

DefaultAttribute

You can use the DefaultAttribute class to specify a default value for an input parameter. The following examples show how to set the default value for each type using the Default attribute.

Bool

C# Copy Code
[Input("Bool input")]
[Output("Bool output")]
[Default("True")]
public InOutArgument<bool> Bool { get; set; }

DateTime

C# Copy Code
[Input("DateTime input")]
[Output("DateTime output")]
[Default("2004-07-09T02:54:00Z")]
public InOutArgument<DateTime> DateTime { get; set; }

Decimal

C# Copy Code
[Input("Decimal input")]
[Output("Decimal output")]
[Default("23.45")]
public InOutArgument<decimal> Decimal { get; set; }

Double

C# Copy Code
[Input("Double input")]
[Output("Double output")]
[Default("252.2")]
public InOutArgument<double> Double { get; set; }

EntityReference

C# Copy Code
[Input("EntityReference input")]
[Output("EntityReference output")]
[ReferenceTarget("account")]
[Default("3B036E3E-94F9-DE11-B508-00155DBA2902", "account")]
public InOutArgument<EntityReference> EntityReference { get; set; }

Int

C# Copy Code
[Input("Int input")]
[Output("Int output")]
[Default("2322")]
public InOutArgument<int> Int { get; set; }

Money

C# Copy Code
[Input("Money input")]
[Output("Money output")]
[Default("232.3")]
public InOutArgument<Money> Money { get; set; }

OptionSetValue

C# Copy Code
[Input("OptionSetValue input")]
[Output("OptionSetValue output")]
[AttributeTarget("account", "industrycode")]
[Default("3")]
public InOutArgument<OptionSetValue> OptionSetValue { get; set; }

String

C# Copy Code
[Input("String input")]
[Output("String output")]
[Default("string default")]
public InOutArgument<string> String { get; set; }

ReferenceTargetAttribute

The EntityReference attribute type requires you to specify the entity type being referenced using the ReferenceTargetAttribute class. The following sample shows how to add the input and output attributes to an AccountReference parameter in a custom workflow activity by using the ReferenceTarget attribute.

C# Copy Code
[Input("EntityReference input")]
[Output("EntityReference output")]
[ReferenceTarget("account")]
[Default("3B036E3E-94F9-DE11-B508-00155DBA2902", "account")]
public InOutArgument<EntityReference> AccountReference { get; set; }

AttributeTargetAttribute

The OptionSetValue attribute type requires you to specify the entity and the attribute being referenced using the AttributeTargetAttribute class. The following sample shows how to add the input and output attributes to an OptionSetValue parameter in a custom workflow activity by using the AttributeTarget attribute.

C# Copy Code
[Input("OptionSetValue input")]
[Output("OptionSetValue output")]
[AttributeTarget("account", "industrycode")]
[Default("3")]
public InOutArgument<OptionSetValue> OptionSetValue { get; set; }

RequiredArgumentAttribute

You can use the System.Activities.RequiredArgumentAttribute class to specify that an input parameter is required.

Copy Code
[RequiredArgument]
[Input("Update Next Birthdate for")]
[ReferenceTarget("contact")]
public InArgument<EntityReference> Contact { get; set; }

See Also

Concepts

Add metadata to a custom workflow activity

Other Resources

Custom workflow activities (workflow assemblies)
Sample: Create a custom workflow activity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a custom workflow activity

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Process\CustomWorkflowActivity\TestNet4Activity\SimpleSdkActivity.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write a custom workflow activity that can create an account and a task for the account. This sample uses early binding.

Example

See Also

Concepts

Create a custom workflow activity
Add metadata to a custom workflow activity
Use the IOrganization web service in a custom workflow activity

Other Resources

Custom workflow activities (workflow assemblies)
Sample: Update next birthday using a custom workflow activity
Sample code for workflows

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Update next birthday using a custom workflow activity

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Process\CustomWorkflowActivity\TestNet4Activity\ReleaseISVActivities.cs

Requirements

The following custom field must exist for this custom workflow activity to work:

  • Contact.new_nextbirthday

Demonstrates

The following sample workflow activity returns the next birthday. Use this in a workflow that sends a birthday greeting to a customer.

Example

See Also

Concepts

Add metadata to a custom workflow activity

Other Resources

Custom workflow activities (workflow assemblies)
Sample: Calculate a credit score with a custom workflow activity
IWorkflowContext

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Calculate a credit score with a custom workflow activity

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Process\CustomWorkflowActivities\TestNet4Activity\ReleaseISVActivities.cs

Requirements

The following customizations must exist for this custom workflow activity to work:

  • Entity Schema Name: new_loanapplication
  • Attribute: new_loanapplicationid as the primary key
  • Attribute: new_creditscore of type int with min of 0 and max of 1000 (if it is to be updated)
  • Attribute: new_loanamount of type money with default min/max
  • Customize the form to include the attribute new_loanapplicantid

The contact entity must have the following customizations:

  • Attribute: new_ssn as Single Line of Text with max length of 15
  • One-To-Many Relationship with these properties:
    • Relationship Definition Schema Name: new_loanapplicant
    • Relationship Definition Related Entity Display Name: Loan Application
    • Relationship Attribute Schema Name: new_loanapplicantid
    • Relationship Behavior Type: Referential

Demonstrates

The following sample workflow activity calculates the credit score based on the Social Security Number (SSN) and name.

Example

See Also

Concepts

Add metadata to a custom workflow activity

Other Resources

Custom workflow activities (workflow assemblies)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Custom XAML workflows

Microsoft Dynamics CRM 2015 on-premises supports the ability to create custom XAML workflows. Custom XAML workflows, also called declarative workflows, allow you to harness the power of Windows Workflow Foundation to create reusable workflows for Microsoft Dynamics CRM. Using the Microsoft Visual Studio Workflow Designer, you can create workflows by dragging workflow activities from the toolbox onto the design surface, create variables, and set properties of these activities to implement the workflow’s functionality. You can use built-in Windows Workflow Foundation activities or the process activities that are specific to Microsoft Dynamics CRM. For information about the process activities in Microsoft Dynamics CRM, see the Activities namespace.

Custom XAML workflows are not supported in Microsoft Dynamics CRM Online. This is because Microsoft Dynamics CRM workflows are not supported to run in sandbox mode, and if the custom XAML workflow contains malicious code, this can lead to data security issues.

After you have created a custom XAML workflow, you can import the XAML file into Microsoft Dynamics CRM, and use the workflow without compiling it. Moreover, you can export an existing workflow in Microsoft Dynamics CRM, edit the workflow definition (XAML) using the Microsoft Visual Studio Workflow Designer, import the XAML back in Microsoft Dynamics CRM, and then use it.

Note
The workflows that are created or modified outside of Microsoft Dynamics CRM cannot be viewed or modified in the Microsoft Dynamics CRM process designer. You can only change the status (Activate or Deactivate) of these workflows. These workflows will run in Microsoft Dynamics CRM as per the workflow definition.

In this topic

Prerequisites for working with custom XAML workflows

Enable or disable XAML workflows

Using the Visual Studio Workflow Designer

Prerequisites for working with custom XAML workflows

You must use Microsoft Visual Studio to develop custom XAML workflows for Microsoft Dynamics CRM.

To work with the XAML workflows that are created or modified outside of Microsoft Dynamics CRM, make sure that:

  • Your user account has the Deployment Administrator privilege in Microsoft Dynamics CRM.
  • Declarative workflows are enabled on the Microsoft Dynamics CRM server. By default they are not enabled. To enable them, use the following procedure.

Enable or disable XAML workflows

You can use Windows PowerShell to enable or disable XAML workflows, as described here. Alternatively, you can use the Deployment Web service. For more information, see Deployment entities and deployment configuration settings to learn how to programmatically update the AllowDeclarativeWorkflows property.

Enable XAML workflows

  1. Open a Windows PowerShell command window.

  2. Add the Microsoft Dynamics CRM PowerShell snap-in:

    Windows PowerShell Copy Code
    Add-PSSnapin Microsoft.Crm.PowerShell

  3. Retrieve the current setting:

    Windows PowerShell Copy Code
    $setting = get-crmsetting customcodesettings

  4. Modify the current setting:

    Windows PowerShell Copy Code
    $setting.AllowDeclarativeWorkflows="True"
    Windows PowerShell Copy Code
    set-crmsetting $setting

  5. Verify the setting:

    Windows PowerShell Copy Code
    get-crmsetting customcodesettings

Disable XAML workflows

  1. Open a Windows PowerShell command window.

  2. Add the Microsoft Dynamics CRM PowerShell snap-in:

    Windows PowerShell Copy Code
    Add-PSSnapin Microsoft.Crm.PowerShell

  3. Retrieve the current setting:

    NPL Copy Code
    $setting = get-crmsetting customcodesettings

  4. Modify the current setting:

    Windows PowerShell Copy Code
    $setting.AllowDeclarativeWorkflows=0
    Windows PowerShell Copy Code
    set-crmsetting $setting

  5. Verify the setting:

    Windows PowerShell Copy Code
    get-crmsetting customcodesettings

Using the Visual Studio Workflow Designer

Using the Visual Studio Workflow Designer, you can do the following:

  • Visually create workflows without having to write code. You can create a workflow project in Visual Studio by using the built-in Visual Studio Activity Library template, and then use a Workflow activity as the root activity.
  • Add the Microsoft Dynamics CRM workflow activities in the toolbox.
  • After a workflow project is created, you can add activities to the root activity.
  • Move activities in a workflow. Some activities, for example, the Sequence activity, can contain multiple child activities. You can create variables to hold values and references that are important to your workflow by using the variables designer.
  • Modify pre-existing workflows. In this case, workflows must first be exported from Microsoft Dynamics CRM, and can be modified in Visual Studio before being imported back into Microsoft Dynamics CRM.

See Also

Concepts

Model business process flows

Other Resources

Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Model business process flows

A business process flow lets you create more efficient and streamlined sales, service, and other business processes. Having high performing processes in place will help you to increase your win rates, improve customer satisfaction, and grow your revenue.

A business process flow creates a visualization of your business process by placing special controls at the top of the entity forms. Users are guided through various stages of sales, marketing, or service processes towards completion. Each process supports multiple stages and steps. You can add or remove steps, change the order of stages, or add new entities to the business process flow.

Video: Business Process in Microsoft Dynamics CRM 2015

In This Topic

What a business process flow does and how you can benefit from it

Example of a business process flow that uses multiple stages and entities

Implement business process flow in code

Maximum number of processes, stages and steps

Use client-side script to automate interaction with business process flows

What a business process flow does and how you can benefit from it

  • A business process flow guides you through various stages in the business process, from start to finish. Each stage contains predefined, logically connected steps. Your paradigm changes from form-centric to processes-centric. You no longer need to remember all the forms you have to use and in which order. The process flow will tell you where you are in the process, where you came from, and what to do next. You are able to continuously monitor your own progress.
  • The process flow assures accuracy and efficiency. It keeps you on track and won’t let you deviate from your task. The steps inside a stage don’t have to be completed in a specific order, but, you must complete all required steps in a stage before you can proceed to the next stage.
    Note
    Not all steps in the stage are marked as required. The steps that aren’t required can be skipped. There is no programmatic way to mark a step as required. You do that in the user interface (UI), when you create or edit the business process flow.

  • You can create multiple process flows for an entity. For example, you can create a process flow for a large order of computers and a different process for a small order.
  • A process flow is portable. You can export and import a process flow as a solution.
  • You can design a process flow for one entity type, or span the process over multiple entities, such as lead, account and contact entities.
  • In the multi-record process flow, you can close with any entity that participates in the process. For example, you can begin with an opportunity, then move to a quote, then move to an order, and then finally close at the last stage with winning the opportunity.
  • A process flow is highly customizable. You can easily add or remove stages, steps, or entities.
  • A process flow help to conform to your organization’s security policies. You choose specific security roles for the process flow. Only users that have these security roles are able to switch the process for the record or associate the process with the record.
  • You can switch a process for a record or associate a process with a new record. For example, you have an opportunity to sell a small number of medical supplies. You choose the “Small Opportunity” process flow for your opportunity. However, later you learn that this opportunity has a potential to become a much larger order. You can easily switch to a “Large Opportunity” process flow.

    Note
    The process flow always starts at the beginning, when you switch to another process.

  • Stage categories can be used to link stages across process flows for reporting purposes.
  • Process flows are available in the Microsoft Dynamics CRM web application and in Microsoft Dynamics CRM for tablets.
  • You can trigger an automatic workflow from the process flow (to run in the background), when a field value of a record participating in the process flow changes. For example, you can trigger a workflow to run if a zip code or a phone number for an account changes.

Example of a business process flow that uses multiple stages and entities

This example shows that you can easily switch sales processes, move across multiple records, from opportunity to case and back to opportunity. It also shows that you can include an approval process in the business process flow.

Your company sells Internet services for home and business. A typical team includes a sales representative, a sales manager, and a field technician. A sales rep works on sales opportunities that sell Internet services for both home and business.

Your system administrator defines two sales processes:

  • Internet services for home.
  • Internet services for business.

For business sales, a process for Internet services might consist of the following stages:

  • Develop a deal. The sales rep starts with developing a new opportunity. The rep fills out an opportunity form with all the necessary information for selling Internet services for home use. However, in the process, the rep realizes that it is a much bigger opportunity and decides to adjust the opportunity to sell to businesses. The sales rep switches the process flow from selling Internet services for home to selling Internet services for business.
  • Propose a deal. The sales rep submits the proposal to the sales manager for approval. The sales manager approves the proposal. The sales rep notifies the customer that proposal is approved.
  • Install the Internet service. The sales rep creates a case to track the installation and assigns it to the field technician. When installation is completed, the field technician notifies the sales representative. The sales representative closes the case as resolved.
  • Close a deal. The sales representative completes the form and closes the opportunity as won.

Implement business process flow in code

The business process flow is one of the categories of the workflow (process). Other process categories include action, workflow, and dialog. For more information, see Workflow categories. Several attributes support the business process flow functionality. Two attributes belong to the workflow (process) entity and other attributes, to any entity that participates in the process flow. Custom entities and entities that have updated UI forms can participate in the process flow. The updated UI entities have the IsAIRUpdated property set to true. To enable an entity for the business process flow, set the IsBusinessProcessEnabled property to true.

Important
Enabling an entity for business process flow is a one way process. You can’t reverse it.

Note
To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Before you can use the process flow, you have to activate it. To activate it, you must have the prvActivateBusinessProcessFlow privilege for the workflow (process) entity. Use the SetStateRequest message to set the state of the workflow (process) record to Activated.

The attributes supporting business process flow are listed in the following table.

Entity | Attribute name | Description | Type
workflow (process) | ProcessRoleAssignment | Security roles that are assigned to this business process flow. Only users with these security roles are able to switch a process for the record or associate a process with a new record. | Multiple lines of text
workflow (process) | ProcessOrder | Order of business process flows for an entity. The specified order is used to display the business process flows in a list. Depending on their security roles, users may not see every business process flow in the list. | Whole number
Entity enabled for business process flow | ProcessId | The ID of the business process flow in which the entity record participates. | GUID
Entity enabled for business process flow | StageId | The ID of the stage in the business process flow to which the entity record is assigned. The stage consists of logically connected steps. The stages and steps are described in the Workflow.XAML attribute. | GUID
Entity enabled for business process flow | TraversedPath | For internal use only. Updating this value is not supported. | String

Maximum number of processes, stages, and steps

Per entity, the default value for the maximum number of activated business process flows is 10. You can specify a different value by using the Organization.MaximumActiveBusinessProcessFlowsAllowedPerEntity attribute. However, if the value is greater than 10, you may see a decrease in your system’s performance when you switch processes or open a record that has an assigned business process flow. This may be especially noticeable if processes span multiple entities.

The following settings aren’t customizable:

  • The maximum number of stages per entity in the process is 30.
  • The maximum number of steps in each stage is 30.
  • The maximum number of entities that can participate in the process flow is 5.

Use client-side script to automate interaction with business process flows

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update there is a client-side object you can use to interact with business process flows in your form scripts. More information: Write scripts for business process flows

See Also

Concepts

Workflow categories
Create real-time workflows
Write scripts for business process flows

Other Resources

Write workflows to automate business processes
Video: Business Process in Microsoft Dynamics CRM 2015
Process Enablement with Microsoft Dynamics CRM 2013
Customer Center topic: Create a new business process
Customer Center topic: Assign a security role to a business process
Customer Center topic: Guide staff through common tasks with processes
Customer Center topic: Add ready-to-use business processes
Customization Guide topic: Business process flows

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create real-time workflows

Similar to asynchronous workflows, real-time workflows can be used to model and automate real world business processes. They can optionally require user input, can start automatically based on specified event conditions, or can be started manually by a user. Real-time workflows are for business users, for example business analysts, to implement similar functionality to synchronous plug-ins without requiring .NET Framework programming experience. You can create asynchronous or real-time workflows in the Microsoft Dynamics CRM web application or in code.

Some key points about a real-time workflow include the following items:

  • Defined by using a Workflow entity record, similar to an asynchronous workflow.
  • Executes in a stage of the event execution pipeline, similar to synchronous plug-ins. The real-time workflow can execute before (pre-operation), after (post-operation), or during the core operation. A real-time workflow that is executed during the core operation is the implementation of a custom action. Real-time workflows can be ranked within a stage just like you can do with plug-ins. More information: Pipeline Stages
  • Whether configured to run on-demand or in response to an event, a real-time workflow runs immediately rather than being queued to run at a later time.
  • Can run in the security context of the logged on user or owner of the workflow. However, workflows set to run on-demand always run under the security context of the logged on user.
  • Can’t contain any delay or wait activities.
  • Only logs errors, and only when logging is enabled.
  • Executes in the current transaction. All activities in the workflow and any child workflows, except asynchronous workflows, are part of a single transaction. Asynchronous child workflows are queued and execute in a separate transaction.
  • Can be converted to asynchronous workflow and back to real-time.

In This Topic

Required security privileges

Create a real-time workflow in code

Convert an asynchronous workflow to real-time and back

Error handling and rollback

Package a real-time workflow for distribution

Required security privileges

A security privilege named Activate Real-time Processes (prvActivateSynchronousWorkflow) is required to activate real-time workflows so that they can be executed. The Execute Workflow Job (prvWorkflowExecution) privilege is required to start the workflow. Because a real-time workflow impacts the core system operation, it is recommended that only a small experienced group of users are granted the activate privilege.

For more information on these privileges see Customization Tab.

Create a real-time workflow in code

While Microsoft Dynamics CRM Online does support real-time workflows, they must be created interactively in the web application. XAML based workflows, discussed in this section, are only supported by an on-premises or IFD server. For more information about XAML workflows see Custom XAML workflows.

You can create a real-time workflow in code by creating a Workflow entity record. Review the Workflow entity’s attribute metadata by using the Metadata Browser tool or the EntityMetadata.xlsx spreadsheet in the SDK package. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. Download the Microsoft Dynamics CRM SDK package.

The following example compares code that creates an asynchronous workflow to code that creates a real-time workflow.

C# Copy Code
// Create an asynchronous workflow.
// The workflow should execute after a new opportunity is created.
Workflow workflow = new Workflow()
{
    // These properties map to the New Process form settings in the web application.
    Name = "Set closeprobability on opportunity create (async)",
    Type = new OptionSetValue((int)WorkflowType.Definition),
    Category = new OptionSetValue((int)WorkflowCategory.Workflow),
    PrimaryEntity = Opportunity.EntityLogicalName,
    Mode = new OptionSetValue((int)WorkflowMode.Background),

    // Additional settings from the second New Process form.
    Description = @"When an opportunity is created, this workflow" +
        " sets the closeprobability field of the opportunity record to 40%.",
    OnDemand = false,
    Subprocess = false,
    Scope = new OptionSetValue((int)WorkflowScope.User),
    TriggerOnCreate = true,
    AsyncAutoDelete = true,
    Xaml = xamlWF,

    // Other properties not in the web forms.
    LanguageCode = 1033,  // U.S. English
};
_workflowId = _serviceProxy.Create(workflow);
C# Copy Code
// Create a real-time workflow.
// The workflow should execute after a new opportunity is created
// and run in the context of the logged on user.
Workflow workflow = new Workflow()
{
    // These properties map to the New Process form settings in the web application.
    Name = "Set closeprobability on opportunity create (real-time)",
    Type = new OptionSetValue((int)WorkflowType.Definition),
    Category = new OptionSetValue((int)WorkflowCategory.Workflow),
    PrimaryEntity = Opportunity.EntityLogicalName,
    Mode = new OptionSetValue((int)WorkflowMode.Realtime),

    // Additional settings from the second New Process form.
    Description = @"When an opportunity is created, this workflow" +
        " sets the closeprobability field of the opportunity record to 40%.",
    OnDemand = false,
    Subprocess = false,
    Scope = new OptionSetValue((int)WorkflowScope.User),
    RunAs = new OptionSetValue((int)workflow_runas.CallingUser),
    SyncWorkflowLogOnFailure = true,
    TriggerOnCreate = true,
    CreateStage = new OptionSetValue((int)workflow_stage.Postoperation),
    Xaml = xamlWF,

    // Other properties not in the web forms.
    LanguageCode = 1033,  // U.S. English
};
_workflowId = _serviceProxy.Create(workflow);

The real-time workflow has some additional properties set that the asynchronous workflow doesn’t:

Workflow attribute Description

Category

Set to WorkflowCategory.Workflow.

RunAs

Specifies to execute the workflow under the security context of the workflow owner (workflow_runas.Owner), or logged on user (workflow_runas.CallingUser).

SyncWorkflowLogOnError

When true, errors are logged to ProcessSession records. Unlike asynchronous workflows, real-time workflow execution isn’t logged to System Job records.

CreateStage, DeleteStage, or UpdateStage

Identifies the stage in the event execution pipeline where the workflow is to run: before the core operation (workflow_stage.Preoperation), or after (workflow_stage.Postoperation). You must match the stage to the trigger event for the intended operation. For example, if TriggerOnUpdate is true, you must also set UpdateStage.

Real-time workflows can’t be executed on retrieves. Other than retrieves, the rest of the supported web services messages map to one of these three supported events. For example, an assign or setstate ultimately is an update.

Mode

This is the execution mode. Set this to WorkflowMode.Realtime.

Rank

You can order the execution of plug-ins and real-time workflows within a stage by setting a rank. All plug-ins or real-time workflows with a rank of 1 execute before those with a rank of 2, and so on.

Xaml

Set to the XAML code that defines your real-time workflow.

You can see the complete sample code for creating a real-time workflow in the topic Sample: Create a real-time workflow in code.

Convert an asynchronous workflow to real-time and back

You can convert workflows from asynchronous to real-time and back using UpdateRequest without the need to rewrite the workflow, as long as the asynchronous workflow doesn’t contain any wait or delay activities. You can also do the conversion interactively by using the web application. The workflow must be in a draft state (not-activated) before the conversion is performed.

Convert an asynchronous workflow to real-time

  1. Create an UpdateRequest for the workflow.

  2. Set the workflow’s Mode property to WorkflowMode.Realtime.

  3. Set the workflow’s CreateStage, UpdateStage, or DeleteStage as appropriate. For example, if your workflow has TriggerOnDelete set, then also set the DeleteStage property.

  4. Call the Execute method passing the update request as a parameter.

Convert a real-time workflow to asynchronous

  1. Create an UpdateRequest for the workflow.

  2. Set the workflow’s Mode property to WorkflowMode.Background.

  3. Call the Execute method passing the update request as a parameter.

Error handling and rollback

Any workflow activity that executes during the database transaction and that passes an exception back to the platform cancels the core operation. This results in a rollback of the core operation if it’s already occurred. In addition, any pre-event or post-event registered plug-ins or real-time workflows that haven’t executed yet. Any asynchronous workflows that are triggered by the same event won’t execute.

If you include a stop workflow (TerminateWorkflow class) activity with the cancelled option in your workflow, you can add a custom status message (Reason property) to that activity containing a single line of text to be displayed to the user in the Business Process Error dialog.

When SyncWorkflowLogOnError is set to true, real-time workflow errors are logged in ProcessSession entity records.

Package a real-time workflow for distribution

To distribute your workflow so that it can be imported into a Microsoft Dynamics CRM organization, add your workflow to a Microsoft Dynamics CRM solution. This is easily done using the web application by navigating to SETTINGS > CUSTOMIZATIONS > Solutions. You can also write code to create the solution. For more information about solutions, see Package and distribute extensions using solutions.

See Also

Concepts

Create your own actions
Event execution pipeline

Other Resources

Write workflows to automate business processes
Write plug-ins to extend business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create your own actions

You can extend the functionality of Microsoft Dynamics CRM by creating custom messages known as actions. These actions will have associated request/response classes. Presently, actions are available to business applications and extensions through organization web service calls only. Actions are typically used to add new domain specific functionality to the organization web service or to combine multiple organization web service message requests into a single request. For example, in a support call center, you may want to combine the Create, Assign, and Setstate messages into a single new Escalate message.

The business logic of an action is implemented using a workflow. When you create an action, the associated real-time workflow is automatically registered to execute in stage 30 (core operation) of the execution pipeline. For more information about real-time workflows, see Workflow categories.

While actions are supported in both Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, creating an action in code (using XAML) is only supported by Microsoft Dynamics CRM 2015 on-premises and IFD. Online customers must create actions interactively in the web application.

In this topic

About action definitions

Required permissions

Create an action using code

Package an action for distribution

Generate early-bound types for an action

Execute the action using the organization web service

Watch out for long running actions

About action definitions

An action is defined by using a Workflow entity record, similar to a real-time workflow. Some key points of what an action is and how it works are in the following list:

  • Can be associated with a single entity or be global (not associated with any particular entity).
  • Is executed in the core operation stage 30 of the event execution pipeline.
  • Supports the invocation of plug-ins registered in the pre-operation and post-operation stages of the event execution pipeline.
  • Can have plug-ins registered in the pre-operation or post-operation stages only when the action status is Activated.
  • Is available through the organization.svc and organization.svc/ web endpoints, but not the organizationdata.svc (OData) endpoint.
  • Can be executed using a JavaScript web resource. More information:Execute an action using a JavaScript web resource
  • Always runs under the security context of the calling user.
  • Record can’t be deleted while there are plug-in steps registered on the action.
  • Can be invoked only by a web service method call, not directly from a workflow. However, the workaround is to write a custom workflow activity that invokes the action and add that to a workflow.
  • Can optionally, through a configuration setting, participate in the current database transaction.
  • Doesn’t support a scope where the execution is restricted to a user, business unit, or organization. Actions always execute in organization scope.
  • Supports input and output parameters.
  • Supports auditing of data changes.
  • Isn’t supported with offline clients.

Required permissions

A security privilege named Activate Real-time Processes (prvActivateSynchronousWorkflow) is required to activate an action’s real-time workflow so that it can be executed. This is in addition to any privileges needed to create a workflow. For more information on these privileges see the privilege UI mapping in the Customization Tab.

Create an action using code

Typically, an action would be implemented by a customizer using the interactive workflow designer of the web application. However, developers can implement actions using SDK calls and deploy to an on-premises or IFD server if desired.

The workflow entity attributes that are used for an action are described in the following table. Sample code for a real-time workflow can be found in the topic Create a real-time workflow in code.

Workflow attribute | Description
Category | Set to WorkflowCategory.CustomOperation.
SyncWorkflowLogOnError | When true, errors are logged to ProcessSession records. Unlike asynchronous workflows, real-time workflow execution isn’t logged to System Job records.
Mode | Not used.
IsTransacted | Set to true if the action should participate in the database transaction; otherwise, false. Default is true.
UniqueName | A unique name for the action. The name is composed of a publisher prefix + "_" + the unique name.
Xaml | Set to the XAML code that defines your action’s real-time workflow. There is no way to refer to another existing real-time workflow.

Add input and output parameters

Actions support input and output parameters that can be added to the workflow using a DynamicActivityProperty type. When you add these parameters to an action’s workflow, they become properties in the message request and response classes associated with that action. For example, the following example shows C# and XAML code for two input and one output parameters.

C# Copy Code
DynamicActivityProperty inputProperty1 = new DynamicActivityProperty     { Name = "Subject", Type = typeof(InArgument<string>) };
DynamicActivityProperty inputProperty2 = new DynamicActivityProperty     { Name = "EntityCollection", Type = typeof(InArgument<EntityCollection>) };
DynamicActivityProperty outputProperty1 = new DynamicActivityProperty     { Name = "Output", Type = typeof(OutArgument<string>) };

inputProperty1.Attributes.Add(new ArgumentRequiredAttribute(true));
inputProperty1.Attributes.Add(new ArgumentDescriptionAttribute("The subject"));
inputProperty1.Attributes.Add(new ArgumentDirectionAttribute(Microsoft.Xrm.Sdk.Workflow.ArgumentDirection.Input));

inputProperty2.Attributes.Add(new ArgumentRequiredAttribute(false));
inputProperty2.Attributes.Add(new ArgumentDescriptionAttribute("The entity collection"));
inputProperty2.Attributes.Add(new ArgumentDirectionAttribute(Microsoft.Xrm.Sdk.Workflow.ArgumentDirection.Input));

outputProperty1.Attributes.Add(new ArgumentRequiredAttribute(false));
outputProperty1.Attributes.Add(new ArgumentDescriptionAttribute("The output"));
outputProperty1.Attributes.Add(new ArgumentDirectionAttribute(Microsoft.Xrm.Sdk.Workflow.ArgumentDirection.Output));
XAML Copy Code
<x:Property Name="Subject"
            Type="InArgument(x:String)">
 <x:Property.Attributes>
  <mxsw:ArgumentRequiredAttribute Value="True" />
  <mxsw:ArgumentTargetAttribute Value="False" />
  <mxsw:ArgumentDescriptionAttribute Value="The subject " />
  <mxsw:ArgumentDirectionAttribute Value="Input" />
  <mxsw:ArgumentEntityAttribute Value="" />
 </x:Property.Attributes>
</x:Property>
<x:Property Name="EntityCollection"
            Type="InArgument(mxs:EntityCollection)">
 <x:Property.Attributes>
  <mxsw:ArgumentRequiredAttribute Value="False" />
  <mxsw:ArgumentTargetAttribute Value="False" />
  <mxsw:ArgumentDescriptionAttribute Value="The entity collection" />
  <mxsw:ArgumentDirectionAttribute Value="Input" />
  <mxsw:ArgumentEntityAttribute Value="" />
 </x:Property.Attributes>
</x:Property>
<x:Property Name="Output"
            Type="OutArgument(x:String)">
 <x:Property.Attributes>
  <mxsw:ArgumentRequiredAttribute Value="False" />
  <mxsw:ArgumentTargetAttribute Value="False" />
  <mxsw:ArgumentDescriptionAttribute Value="The output" />
  <mxsw:ArgumentDirectionAttribute Value="Output" />
  <mxsw:ArgumentEntityAttribute Value="" />
 </x:Property.Attributes>
</x:Property>

The names used for the properties should be consistent with parameter names since code generation will define these names as request or response properties.

Supported parameter types for the input and output arguments are shown in the following table.

.NET Type | Parameter Type
System.Int32 | Integer
System.String | String
Microsoft.Xrm.Sdk.EntityReference | EntityReference
Microsoft.Xrm.Sdk.Entity | Entity
Microsoft.Xrm.Sdk.EntityCollection | RelatedEntityCollection
System.DateTime | DateTime
System.Double | Float
System.Decimal | Decimal
Microsoft.Xrm.Sdk.Money | Money
System.Boolean | Boolean
Microsoft.Xrm.Sdk.OptionSetValue | Picklist

Supported argument attributes are listed in the following table.

Argument Attribute | Description
ArgumentRequiredAttribute | Indicates if the argument is required.
ArgumentDirectionAttribute | Indicates if the argument’s direction is an input or output.
ArgumentDescriptionAttribute | Specifies a description for the argument.
ArgumentEntityAttribute | Used if you want to pass in an entity.
ArgumentTargetAttribute | This attribute is automatically generated or added. It points to the primary entity for which the workflow is run. This attribute is optional for global actions.

Package an action for distribution

To distribute your action so that it can be imported into a Microsoft Dynamics CRM organization, add your action to a CRM solution. This is easily done using the web application by navigating to Settings> Customizations > Solutions. You can also write code to create the solution. For more information about solutions, see Package and distribute extensions using solutions.

Generate early-bound types for an action

Using the CrmSvcUtil tool supplied in the SDK package, you can generate request and response classes for your action to include in your application code. However, before you generate these classes, be sure to activate the action.

Download the Microsoft Dynamics CRM SDK package.

The following sample shows the format for running the tool from the command line for an on-premises installation of CRM. You supply the parameter values for your installation.

Copy Code
CrmSvcUtil.exe /url:http://<serverName>/<organizationName>/XRMServices/2011/Organization.svc /out:<outputFilename>.cs /username:<username> /password:<password> /domain:<domainName> /namespace:<outputNamespace> /serviceContextName:<serviceContextName> /generateActions

The following sample shows the format for running the tool from the command line with Microsoft Dynamics CRM Online. You supply the parameter values appropriate for your account and server.

Copy Code
CrmSvcUtil.exe /url:https://<organizationUrlName>.api.crm.dynamics.com/XRMServices/2011/Organization.svc /out:<outputFilename>.cs /username:<username> /password:<password> /namespace:<outputNamespace> /serviceContextName:<serviceContextName> /generateActions

Notice the use of the /generateActions parameter. More information: Create early bound entity classes with the code generation tool (CrmSvcUtil.exe).

You can use early-bound or late-bound types with the generated request and response classes for your action.

Execute an action using the web service

To execute an action using the organization web service using managed code, follow these steps.

  1. Include the early-bound types file that you generated using the CrmSvcUtil tool in your application’s project.

  2. In your application code, instantiate your action’s request and populate any required properties.

  3. Invoke Execute, passing your request as an argument.

Before you run your application code, make sure the action is activated. Otherwise, you’ll receive a run-time error.

Execute an action using a JavaScript web resource

The Sdk.Soap.js sample library demonstrates how messages can be used with JavaScript web resources and the Modern App SOAP endpoint (organization.svc/web). Use the companion Sdk.Soap.js Action Message Generator sample to generate JavaScript libraries that can be used with Sdk.Soap.js in the same way you can use the libraries for system messages provided in that sample. The files generated using the Sdk.Soap.js Action Message Generator are separate JavaScript libraries for each action. Each library contains a request and response class that correspond to the classes generated by the CrmSvcUtil.

Watch out for long running actions

If one of the steps in the action’s real-time workflow is a custom workflow activity, that custom workflow activity is executed inside the isolated sandbox run-time environment and will be subject to the two minute timeout limit, similar to how sandboxed plug-ins are managed. However, there are no restrictions on the amount of overall time the action itself can take. In addition, if an action participates in a transaction, where rollback is enabled, SQL Server timeouts will apply.

Tip
A best practice recommendation is that long running operations should be executed outside of Microsoft Dynamics CRM using .NET asynchronous or background processes.

See Also

Concepts

Create real-time workflows
Use dialogs for guided processes
Event execution pipeline

Other Resources

Write workflows to automate business processes
Customization Guide for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use dialogs for guided processes

Dialogs are the synchronous or interactive processes in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update that collect and process information by using step-by-step scripts to direct users through a process. For example, you can create dialogs to act as a guide for your service representatives for case resolution and case escalation. Similarly, you can create dialogs for standardizing sales processes such as opportunity qualification and lead scoring.

Every time that you run a dialog in CRM, a ProcessSession record is created. The process session stores the session log about the dialog process that was run.

Note
Due to the interactive nature of the dialog process, you can’t run a dialog using the Microsoft Dynamics CRM SDK. A dialog can only be run through the CRM web application. Dialogs aren’t supported in CRM for Outlook.

See Also

Concepts

Workflow categories

Other Resources

Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Understand dialogs

Dialogs contain a collection of pages, and each page can contain multiple sets of prompts and responses. You can also specify a dialog as a child dialog, and then invoke that dialog from within a parent dialog. Read this topic to understand the basics of dialogs in Microsoft Dynamics CRM.

In This Topic

Dialog components

Input argument and variable

Dialog limitations

Dialog components

The following diagram illustrates a sample dialog page and its components.

Components of a dialog

Let us look at each component in detail.

Page

A page is the basic unit of a dialog, and is the visual interface for the end user. A dialog can have multiple pages, and each page can have multiple prompts and responses. When a dialog is run, these pages appear to the user in the sequence you have defined them in the dialog definition.

Prompt and response

Prompts and responses allow you to ask a question to the end user, and capture their responses. For each prompt, you have to specify a response type that defines the type of input or response control presented to the user. You can specify one of the following response types:

  • None: No response is required for the prompt. This is typically used for introductory prompts where you welcome the user.
  • Single Line: Lets you input a single line of text, integer, or float value. A text box is displayed for the prompt, where you can type the response.
  • Radio Button: Lets you select from a predefined set of responses, or select from the data queried from Microsoft Dynamics CRM using the Query CRM Data step. For example, you could choose from the following modes of communication for the new offers: email, fax, phone, or letter. Further, you can specify the data type for the responses: text, integer, or float. The response options are displayed as radio buttons.
  • Picklist: Lets you select from a predefined set of responses, or select from the data queried from Microsoft Dynamics CRM using the Query CRM Data step. However, in this case, the response options are displayed in a drop-down list.
  • Multi-Line Text: Lets you input multiple lines of text only. A multi-line text box is displayed for the prompt, where you can type the response.
  • Date and Time: Lets you input a date and time.
  • Date Only: Lets you input a date without a time.
  • Lookup: Lets you specify an entity record.

The user response for each Prompt and Response step is stored as the step variable, and can be used later in the dialog flow.

You can add a static hyperlink or dynamic hyperlink to the prompt text. While specifying a text as static hyperlink, you must specify the full URL including the communication protocol (such as http, https, and ftp). For example, if you want to create a hyperlink text called Bing, you must specify the URL as “http://www.bing.com”, and not just “www.bing.com”. Dynamic hyperlinks can be inserted into any text field. The hyperlink refers to an entity record in Microsoft Dynamics CRM.

By default, each response is logged, and is available in the respective process session record. However, you can turn off response logging for a prompt and response step that contains sensitive customer information, such as credit card details, to prevent possible misuse of the data.

Tip

A tip is information that you specify for each prompt and response that helps the user in responding to the prompt. Tips are optional.

Input argument and variable

Apart from the dialog components that were discussed earlier, there are two more components that you should be aware of in order to work with dialogs: input arguments and variables.

Input argument

Input arguments enable data to be passed between parent and child dialogs. Input arguments are defined for child dialogs, and you can pass the values from the parent dialog by adding a Link Child Dialog step in the parent dialog, and then map the required responses with the input arguments in the child dialog. You can also perform simple arithmetic and string operations on input parameters using the Assign Value step. Input arguments can be of the following types: Single Line of Text, Whole Number, Floating Point Number, Date and Time, Date Only, or Lookup. You must also specify a default value for each of the argument types while creating them.

To illustrate the concept of input arguments in dialogs, consider the following example:

  • You have a parent dialog that creates a contact by taking the following three inputs: salutation, first name, and last name.
  • You have a child dialog that is used to create cases for the contacts.
  • In the child dialog, you might want to have some prompts that refer to the name of the caller, which is actually stored as a prompt and response variable in the parent dialog. Additionally, you might want to set the regarding field of the cases being created to the contact record that was created using the parent dialog.
  • You define the input arguments for the child dialog for all these inputs that you want from the parent record. Next, you create the parent dialog that has a Link Child Dialog step to invoke the child dialog, and map the correct prompt and response variables to the child dialog’s input arguments.

Variable

Variables allow you to store any intermediate values such as concatenated strings or computed data as a result of simple arithmetic calculations (add, subtract, and multiply). The intermediate values are the responses that you gather while running through a series of prompts and responses in a dialog, and are stored in the respective Prompt and Response step variables. You can use the intermediate variables and the Assign Value step to perform simple arithmetic and string operations on the variables defined by you. A variable in a dialog can be of the following types: Text, Integer, Float, Date and Time, Date Only, and Lookup. You must also specify a default value for each of the variables while creating them.

To illustrate the concept of variable in dialogs, consider an example of Lead Scoring where you would like to ask a set of questions, and then calculate the score based on a formula on weighted responses. To do this, you can define an integer variable called Score. Then, as you collect responses, you could use the Check Condition step to have different weights associated with the responses, and then add, subtract, or multiply those response values to the Score variable using the Assign Value step.

Comments

The comments section at the bottom of a page can be used to take notes while the dialog run is in progress. This section is common for the entire process session. The user can capture information such as feedback about the dialog or the customer's comment. The comments are stored in the Description attribute of the process session record when the process session is finished.

Dialog limitations

A link child dialog cannot be an intermediate step. You might try to split a complex dialog into child dialogs and invoke all of those child dialogs from a parent dialog. However, that is not supported in this release.

There is a limit to the number of nested steps you can use in a dialog. The limit depends on the browser you’re using and isn’t a limit in Microsoft Dynamics CRM. The nested steps are rendered in the browser as nested tables. Some browsers support more levels of nested tables than others. If the workflow designer becomes grayed out where you can’t add additional nested steps to your dialog, try the following workarounds:

  • Redesign the dialog to use fewer nested steps.
  • Add a child dialog to reduce the number of steps in the parent dialog.
  • Use a different browser.

See Also

Concepts

Use dialogs for guided processes
Actions on dialogs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Actions on dialogs

This topic describes the actions you can perform on dialogs.

In This Topic

Dialog-related activities

Workflow-related activities

Custom workflow activities

Start a dialog by using a URL

Dialog-related activities

These activities are available as steps in the Microsoft Dynamics CRM Process Designer.

Query CRM Data

Enables you to define query variables that can be used to query Microsoft Dynamics CRM data. These query variables can either have pre-defined values or can be parameterized so that they accept values at the runtime, and fetch records accordingly.

You can parameterize a query variable by using the Modify Query Variables tab on the Define Query page, and then use the dynamic values section on the query form to associate the prompt and response variables with the query variables.

The query variable defined using the Query CRM Data step is available for all the prompts and responses from the point where they have been defined in the dialog definition.

Assign Value

Enables you to perform simple arithmetic (increment, decrement, and multiply) and string (append) operations on the variables and input arguments in dialogs. You can also use the Assign Value step to clear any value that is stored in the variables or input parameters.

Link Child Dialog

You can specify a dialog as a child dialog, and invoke it from within another dialog (parent) by using the Link Child Dialog step in the parent dialog.

Stop Dialog

Enables you to end a dialog at a particular stage in the dialog flow. This step can be used in any conditional statement where you want a dialog to end at that point based on the response from the user.

Workflow-related activities

The following workflow-related activities can be used for dialogs: Create Record, Update Record, Assign Record, Update Record, Send E-mail, Start Child Workflow, and Change Status.

Custom workflow activities

You can create custom workflow activities to extend the dialogs in Microsoft Dynamics CRM. For detailed information about custom workflow activities, see Custom workflow activities (workflow assemblies).

Start a dialog by using a URL

You can start an activated dialog by specifying the URL of the dialog. To do so, you must specify the URL in the following format:

Copy Code
http://CRMServer_Name/Org_Name/cs/dialog/rundialog.aspx?DialogId=DialogID&EntityName=EntityLogicalName&ObjectId=EntityObjectId

Where,

  • CRMServer_Name is the name of your Microsoft Dynamics CRM server.
  • Org_Name is the organization name.
  • DialogID is GUID of the dialog that you want to run.
  • EntityLogicalName is the entity logical name of the primary entity of the dialog that you want to run.
  • EntityObjectId is the GUID of the primary entity record.

A sample URL to start a dialog:

http://crmserver/AdventureWorksCycle/cs/dialog/rundialog.aspx?DialogId=9F53D2D8-AC54-46A6-A190-F23DE6677C65&EntityName=contact&ObjectId=41D1884E-B4B6-DF11-BF5E-00155DB05986

See Also

Concepts

Use dialogs for guided processes
Understand dialogs

Other Resources

Sample: Create, retrieve, update, and delete a dialog

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample code for workflows

This section contains code examples that show how to use the workflow (process) entity.

In This Section

Sample: Create a process using a template

Sample: Execute a workflow

Sample: Create, retrieve, update, and delete a dialog

Sample: Create a workflow in code

Sample: Create a real-time workflow in code

Sample: Set the state of a workflow

Related Sections

Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a process using a template
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Process\Workflows\CreateProcessFromTemplate.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following code example demonstrates how to create a workflow process using a template using the CreateWorkflowFromTemplateRequest.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Create a Workflow Process from an existing Process Template.
    /// </summary>
    public class CreateProcessFromTemplate
    {

        #region Class Level Members

        private Guid _processTemplateId;
        private Guid _processId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// Demonstrates how to programmatically create a Workflow from an existing
        /// Process Template.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    OrganizationServiceContext _orgContext = new OrganizationServiceContext(_serviceProxy);

                    CreateRequiredRecords();

                    CreateWorkflowFromTemplateRequest request = new CreateWorkflowFromTemplateRequest()
                    {
                        WorkflowName = "Workflow From Template",
                        WorkflowTemplateId = _processTemplateId
                    };

                    // Execute request.
                    CreateWorkflowFromTemplateResponse response = (CreateWorkflowFromTemplateResponse)_serviceProxy.Execute(request);
                    _processId = response.Id;

                    // Verify success.
                    // Retrieve the name of the workflow.
                    ColumnSet cols = new ColumnSet("name");
                    Workflow newWorkflow = (Workflow)_serviceProxy.Retrieve(Workflow.EntityLogicalName, response.Id, cols);
                    if (newWorkflow.Name == "Workflow From Template")
                    {
                        Console.WriteLine("Created {0}.", request.WorkflowName);
                    }

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {

            // Define an anonymous type to define the possible values for
            // process type
            var ProcessType = new
            {
                Definition = 1,
                Activation = 2,
                Template = 3
            };

            // Define an anonymous type to define the possible values for
            // process category
            var ProcessCategory = new
            {
                Workflow = 0,
                Dialog = 1,
            };

            // Define an anonymous type to define the possible values for
            // process scope
            var ProcessScope = new
            {
                User = 1,
                BusinessUnit = 2,
                Deep = 3,
                Global = 4
            };

            // Create the Workflow template that we will use to generate the Workflow.
            Workflow processTemplate = new Workflow()
            {
                Name = "Sample Process Template",
                Type = new OptionSetValue(ProcessType.Template),
                Category = new OptionSetValue(ProcessCategory.Workflow),
                Scope = new OptionSetValue(ProcessScope.User),

                //Language code for U.S. English
                LanguageCode = 1033,
                TriggerOnCreate = true,
                OnDemand = false,
                PrimaryEntity = Account.EntityLogicalName,
                Xaml =
@"<?xml version=""1.0"" encoding=""utf-16""?>
<Activity x:Class=""SampleWorkflow"" xmlns=""http://schemas.microsoft.com/netfx/2009/xaml/activities"" xmlns:mva=""clr-namespace:Microsoft.VisualBasic.Activities;assembly=System.Activities, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" xmlns:mxs=""clr-namespace:Microsoft.Xrm.Sdk;assembly=Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" xmlns:mxsq=""clr-namespace:Microsoft.Xrm.Sdk.Query;assembly=Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" xmlns:mxswa=""clr-namespace:Microsoft.Xrm.Sdk.Workflow.Activities;assembly=Microsoft.Xrm.Sdk.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" xmlns:s=""clr-namespace:System;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"" xmlns:scg=""clr-namespace:System.Collections.Generic;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"" xmlns:sco=""clr-namespace:System.Collections.ObjectModel;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"" xmlns:srs=""clr-namespace:System.Runtime.Serialization;assembly=System.Runtime.Serialization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"" xmlns:this=""clr-namespace:"" xmlns:x=""http://schemas.microsoft.com/winfx/2006/xaml"">
  <x:Members>
    <x:Property Name=""InputEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
    <x:Property Name=""CreatedEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
  </x:Members>
  <this:SampleWorkflow.InputEntities>
    <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
  </this:SampleWorkflow.InputEntities>
  <this:SampleWorkflow.CreatedEntities>
    <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
  </this:SampleWorkflow.CreatedEntities>
  <mva:VisualBasic.Settings>Assembly references and imported namespaces for internal implementation</mva:VisualBasic.Settings>
  <mxswa:Workflow>
    <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.ConditionSequence, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""ConditionStep1: If Account Name is in the &quot;Sample&quot; family"">
      <mxswa:ActivityReference.Arguments>
        <InArgument x:TypeArguments=""x:Boolean"" x:Key=""Wait"">False</InArgument>
      </mxswa:ActivityReference.Arguments>
      <mxswa:ActivityReference.Properties>
        <sco:Collection x:TypeArguments=""Variable"" x:Key=""Variables"">
          <Variable x:TypeArguments=""x:Boolean"" Default=""False"" Name=""ConditionBranchStep2_condition"" />
          <Variable x:TypeArguments=""x:Object"" Name=""ConditionBranchStep2_1"" />
          <Variable x:TypeArguments=""x:Object"" Name=""ConditionBranchStep2_2"" />
        </sco:Collection>
        <sco:Collection x:TypeArguments=""Activity"" x:Key=""Activities"">
          <mxswa:GetEntityProperty Attribute=""name"" Entity=""[InputEntities(&quot;primaryEntity&quot;)]"" EntityName=""account"" Value=""[ConditionBranchStep2_1]"">
            <mxswa:GetEntityProperty.TargetType>
              <InArgument x:TypeArguments=""s:Type"">
                <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"">
                  <x:Null />
                </mxswa:ReferenceLiteral>
              </InArgument>
            </mxswa:GetEntityProperty.TargetType>
          </mxswa:GetEntityProperty>
          <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
            <mxswa:ActivityReference.Arguments>
              <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
              <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.String, ""Sample"", ""String"" }]</InArgument>
              <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
              </InArgument>
              <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[ConditionBranchStep2_2]</OutArgument>
            </mxswa:ActivityReference.Arguments>
          </mxswa:ActivityReference>
          <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateCondition, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateCondition"">
            <mxswa:ActivityReference.Arguments>
              <InArgument x:TypeArguments=""mxsq:ConditionOperator"" x:Key=""ConditionOperator"">Contains</InArgument>
              <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { ConditionBranchStep2_2 }]</InArgument>
              <InArgument x:TypeArguments=""x:Object"" x:Key=""Operand"">[ConditionBranchStep2_1]</InArgument>
              <OutArgument x:TypeArguments=""x:Boolean"" x:Key=""Result"">[ConditionBranchStep2_condition]</OutArgument>
            </mxswa:ActivityReference.Arguments>
          </mxswa:ActivityReference>
          <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.ConditionBranch, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""ConditionBranchStep2"">
            <mxswa:ActivityReference.Arguments>
              <InArgument x:TypeArguments=""x:Boolean"" x:Key=""Condition"">[ConditionBranchStep2_condition]</InArgument>
            </mxswa:ActivityReference.Arguments>
            <mxswa:ActivityReference.Properties>
              <mxswa:ActivityReference x:Key=""Then"" AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.Composite, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""ConditionBranchStep2"">
                <mxswa:ActivityReference.Properties>
                  <sco:Collection x:TypeArguments=""Variable"" x:Key=""Variables"" />
                  <sco:Collection x:TypeArguments=""Activity"" x:Key=""Activities"">
                    <Sequence DisplayName=""CreateStep3: Add new contact for Nancy Anderson at new account."">
                      <Sequence.Variables>
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_1"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_2"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_3"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_4"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_5"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_6"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_7"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_8"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_9"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_10"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_11"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_12"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_13"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_14"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_15"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_16"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_17"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_18"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_19"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_20"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_21"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_22"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_23"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_24"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_25"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_26"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_27"" />
                        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep3_28"" />
                      </Sequence.Variables>
                      <Assign x:TypeArguments=""mxs:Entity"" To=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" Value=""[New Entity(&quot;contact&quot;)]"" />
                      <mxswa:GetEntityProperty Attribute=""telephone1"" Entity=""[InputEntities(&quot;primaryEntity&quot;)]"" EntityName=""account"" Value=""[CreateStep3_2]"">
                        <mxswa:GetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
                          </InArgument>
                        </mxswa:GetEntityProperty.TargetType>
                      </mxswa:GetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">SelectFirstNonNull</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { CreateStep3_2 }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_1]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""telephone1"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_1]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.String, ""Nancy"", ""String"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_3]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""firstname"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_3]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.String, ""Anderson"", ""String"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_4]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""lastname"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_4]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:GetEntityProperty Attribute=""accountid"" Entity=""[InputEntities(&quot;primaryEntity&quot;)]"" EntityName=""account"" Value=""[CreateStep3_6]"">
                        <mxswa:GetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:EntityReference"" />
                          </InArgument>
                        </mxswa:GetEntityProperty.TargetType>
                      </mxswa:GetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">SelectFirstNonNull</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { CreateStep3_6 }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:EntityReference"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_5]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""parentcustomerid"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_5]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:EntityReference"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:GetEntityProperty Attribute=""transactioncurrencyid"" Entity=""[InputEntities(&quot;related_transactioncurrencyid#transactioncurrency&quot;)]"" EntityName=""transactioncurrency"" Value=""[CreateStep3_8]"">
                        <mxswa:GetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:EntityReference"" />
                          </InArgument>
                        </mxswa:GetEntityProperty.TargetType>
                      </mxswa:GetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">SelectFirstNonNull</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { CreateStep3_8 }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:EntityReference"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_7]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""transactioncurrencyid"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_7]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:EntityReference"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.Boolean, ""False"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_9]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""creditonhold"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_9]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_10]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""preferredcontactmethodcode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_10]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.Boolean, ""False"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_11]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""donotemail"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_11]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.Boolean, ""False"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_12]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""donotbulkemail"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_12]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.Boolean, ""False"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_13]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""donotphone"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_13]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.Boolean, ""False"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_14]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""donotfax"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_14]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.Boolean, ""False"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_15]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""donotpostalmail"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_15]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.Boolean, ""False"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_16]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""donotsendmm"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_16]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_17]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""preferredappointmenttimecode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_17]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_18]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""address2_addresstypecode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_18]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_19]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""address2_freighttermscode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_19]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_20]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""address2_shippingmethodcode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_20]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_21]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""customersizecode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_21]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_22]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""customertypecode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_22]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_23]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""educationcode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_23]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_24]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""haschildrencode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_24]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.Boolean, ""False"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_25]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""isbackofficecustomer"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_25]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_26]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""leadsourcecode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_26]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_27]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""shippingmethodcode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_27]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
                        <mxswa:ActivityReference.Arguments>
                          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
                          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
                          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep3_28]</OutArgument>
                        </mxswa:ActivityReference.Arguments>
                      </mxswa:ActivityReference>
                      <mxswa:SetEntityProperty Attribute=""territorycode"" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" Value=""[CreateStep3_28]"">
                        <mxswa:SetEntityProperty.TargetType>
                          <InArgument x:TypeArguments=""s:Type"">
                            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
                          </InArgument>
                        </mxswa:SetEntityProperty.TargetType>
                      </mxswa:SetEntityProperty>
                      <mxswa:CreateEntity EntityId=""{x:Null}"" DisplayName=""CreateStep3: Add new contact for Nancy Anderson at new account."" Entity=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" EntityName=""contact"" />
                      <Assign x:TypeArguments=""mxs:Entity"" To=""[CreatedEntities(&quot;CreateStep3_localParameter&quot;)]"" Value=""[CreatedEntities(&quot;CreateStep3_localParameter#Temp&quot;)]"" />
                      <Persist />
                    </Sequence>
                  </sco:Collection>
                </mxswa:ActivityReference.Properties>
              </mxswa:ActivityReference>
              <x:Null x:Key=""Else"" />
            </mxswa:ActivityReference.Properties>
          </mxswa:ActivityReference>
        </sco:Collection>
      </mxswa:ActivityReference.Properties>
    </mxswa:ActivityReference>
  </mxswa:Workflow>
</Activity>"
             };
            _processTemplateId = _serviceProxy.Create(processTemplate);

            Console.Write("Created {0},", processTemplate.Name);

            // Activate the process template
            SetStateRequest activateRequest = new SetStateRequest
            {
                EntityMoniker = new EntityReference(Workflow.EntityLogicalName, _processTemplateId),
                State = new OptionSetValue((int)WorkflowState.Activated),
                Status = new OptionSetValue(2)
            };
            _serviceProxy.Execute(activateRequest);
            Console.WriteLine(" and activated.");

        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Workflow.EntityLogicalName, _processId);

                // Deactivate the process template before you can delete it.
                SetStateRequest deactivateRequest = new SetStateRequest
                {
                    EntityMoniker = new EntityReference(Workflow.EntityLogicalName, _processTemplateId),
                    State = new OptionSetValue((int)WorkflowState.Draft),
                    Status = new OptionSetValue(1)
                };
                _serviceProxy.Execute(deactivateRequest);
                _serviceProxy.Delete(Workflow.EntityLogicalName, _processTemplateId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateProcessFromTemplate app = new CreateProcessFromTemplate();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Sample code for workflows
Sample: Execute a workflow
Write workflows to automate business processes
CreateWorkflowFromTemplateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Execute a workflow
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Process\Workflows\ExecuteWorkflow.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following sample demonstrates how to programmatically execute a workflow by using the ExecuteWorkflowRequest.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Execute a workflow programmatically.
    /// </summary>
    public class ExecuteWorkflow
    {

        #region Class Level Members

        private Guid _workflowId;
        private Guid _leadId;
        private Guid _asyncOperationId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// Demonstrates how to programmatically execute a workflow.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    OrganizationServiceContext _orgContext = new OrganizationServiceContext(_serviceProxy);

                    CreateRequiredRecords();

                    // Create an ExecuteWorkflow request.
                    ExecuteWorkflowRequest request = new ExecuteWorkflowRequest()
                    {
                        WorkflowId = _workflowId,
                        EntityId = _leadId
                    };
                    Console.Write("Created ExecuteWorkflow request, ");

                    // Execute the workflow.
                    ExecuteWorkflowResponse response =
                        (ExecuteWorkflowResponse)_serviceProxy.Execute(request);
                    Console.WriteLine("and sent request to service.");

                    #region Check success

                    ColumnSet cols = new ColumnSet("statecode");
                    QueryByAttribute retrieveOpQuery = new QueryByAttribute();
                    retrieveOpQuery.EntityName = AsyncOperation.EntityLogicalName;
                    retrieveOpQuery.ColumnSet = cols;
                    retrieveOpQuery.AddAttributeValue("asyncoperationid", response.Id);

                    // Wait for the asyncoperation to complete.
                    // (wait no longer than 1 minute)
                    for (int i = 0; i < 60; i++)
                    {
                        System.Threading.Thread.Sleep(1000);

                        EntityCollection retrieveOpResults =
                            _serviceProxy.RetrieveMultiple(retrieveOpQuery);

                        if (retrieveOpResults.Entities.Count() > 0)
                        {
                            AsyncOperation op =
                                (AsyncOperation)retrieveOpResults.Entities[0];
                            if (op.StateCode == AsyncOperationState.Completed)
                            {
                                _asyncOperationId = op.AsyncOperationId.Value;
                                Console.WriteLine("AsyncOperation completed successfully.");
                                break;
                            }
                        }

                        if (i == 59)
                        {
                            throw new TimeoutException("AsyncOperation failed to complete in under one minute.");
                        }
                    }

                    // Retrieve the task that was created by the workflow.
                    cols = new ColumnSet("activityid");
                    QueryByAttribute retrieveActivityQuery = new QueryByAttribute();
                    retrieveActivityQuery.EntityName = PhoneCall.EntityLogicalName;
                    retrieveActivityQuery.ColumnSet = cols;
                    retrieveActivityQuery.AddAttributeValue("subject", "First call to Diogo Andrade");

                    EntityCollection results =
                        _serviceProxy.RetrieveMultiple(retrieveActivityQuery);

                    if (results.Entities.Count() == 0)
                    {
                        throw new InvalidOperationException("Phone call activity was not successfully created");
                    }
                    else
                    {
                        Console.WriteLine("Phone call activity successfully created from workflow.");
                    }

                    #endregion Check success

                    DeleteRequiredRecords(promptforDelete);
                }

            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a Lead record on which we will execute the Workflow.
            Lead lead = new Lead()
            {
                FirstName = "Diogo",
                LastName = "Andrade"
            };
            _leadId = _serviceProxy.Create(lead);
            Console.WriteLine("Created Lead for workflow request.");

            // Define an anonymous type to define the possible values for
            // process type
            var ProcessType = new
            {
                Definition = 1,
                Activation = 2,
                Template = 3
            };

            // Define an anonymous type to define the possible values for
            // process category
            var ProcessCategory = new
            {
                Workflow = 0,
                Dialog = 1,
            };

            // Define an anonymous type to define the possible values for
            // process scope
            var ProcessScope = new
            {
                User = 1,
                BusinessUnit = 2,
                Deep = 3,
                Global = 4
            };

            // Create the Workflow that we will execute.
            Workflow workflow = new Workflow()
            {
                Name = "Sample Workflow", // friendly name of the record
                Type = new OptionSetValue(ProcessType.Definition),
                Category = new OptionSetValue(ProcessCategory.Workflow),
                Scope = new OptionSetValue(ProcessScope.User),
                OnDemand = true,
                PrimaryEntity = Lead.EntityLogicalName,
                Xaml =
@"<?xml version=""1.0"" encoding=""utf-16""?>
<Activity x:Class=""ExecuteWorkflowSample"" xmlns=""http://schemas.microsoft.com/netfx/2009/xaml/activities"" xmlns:mva=""clr-namespace:Microsoft.VisualBasic.Activities;assembly=System.Activities, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" xmlns:mxs=""clr-namespace:Microsoft.Xrm.Sdk;assembly=Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" xmlns:mxswa=""clr-namespace:Microsoft.Xrm.Sdk.Workflow.Activities;assembly=Microsoft.Xrm.Sdk.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" xmlns:s=""clr-namespace:System;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"" xmlns:scg=""clr-namespace:System.Collections.Generic;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"" xmlns:srs=""clr-namespace:System.Runtime.Serialization;assembly=System.Runtime.Serialization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"" xmlns:this=""clr-namespace:"" xmlns:x=""http://schemas.microsoft.com/winfx/2006/xaml"">
  <x:Members>
    <x:Property Name=""InputEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
    <x:Property Name=""CreatedEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
  </x:Members>
  <this:ExecuteWorkflowSample.InputEntities>
    <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
  </this:ExecuteWorkflowSample.InputEntities>
  <this:ExecuteWorkflowSample.CreatedEntities>
    <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
  </this:ExecuteWorkflowSample.CreatedEntities>
  <mva:VisualBasic.Settings>Assembly references and imported namespaces for internal implementation</mva:VisualBasic.Settings>
  <mxswa:Workflow>
    <Assign x:TypeArguments=""mxs:Entity"" To=""[CreatedEntities(&quot;CreateStep1_localParameter#Temp&quot;)]"" Value=""[New Entity(&quot;phonecall&quot;)]"" />
    <Sequence DisplayName=""CreateStep1: Set first activity for lead."">
      <Sequence.Variables>
        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep1_1"" />
        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep1_2"" />
        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep1_3"" />
        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep1_4"" />
        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep1_5"" />
        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep1_6"" />
        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep1_7"" />
        <Variable x:TypeArguments=""x:Object"" Name=""CreateStep1_8"" />
      </Sequence.Variables>
      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
        <mxswa:ActivityReference.Arguments>
          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.Boolean, ""True"" }]</InArgument>
          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
          </InArgument>
          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep1_1]</OutArgument>
        </mxswa:ActivityReference.Arguments>
      </mxswa:ActivityReference>
      <mxswa:SetEntityProperty Attribute=""directioncode"" Entity=""[CreatedEntities(&quot;CreateStep1_localParameter#Temp&quot;)]"" EntityName=""phonecall"" Value=""[CreateStep1_1]"">
        <mxswa:SetEntityProperty.TargetType>
          <InArgument x:TypeArguments=""s:Type"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:Boolean"" />
          </InArgument>
        </mxswa:SetEntityProperty.TargetType>
      </mxswa:SetEntityProperty>
      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
        <mxswa:ActivityReference.Arguments>
          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.String, ""First call to "", ""String"" }]</InArgument>
          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
          </InArgument>
          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep1_3]</OutArgument>
        </mxswa:ActivityReference.Arguments>
      </mxswa:ActivityReference>
      <mxswa:GetEntityProperty Attribute=""fullname"" Entity=""[InputEntities(&quot;primaryEntity&quot;)]"" EntityName=""lead"" Value=""[CreateStep1_5]"">
        <mxswa:GetEntityProperty.TargetType>
          <InArgument x:TypeArguments=""s:Type"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
          </InArgument>
        </mxswa:GetEntityProperty.TargetType>
      </mxswa:GetEntityProperty>
      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
        <mxswa:ActivityReference.Arguments>
          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">SelectFirstNonNull</InArgument>
          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { CreateStep1_5 }]</InArgument>
          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
          </InArgument>
          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep1_4]</OutArgument>
        </mxswa:ActivityReference.Arguments>
      </mxswa:ActivityReference>
      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
        <mxswa:ActivityReference.Arguments>
          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">Add</InArgument>
          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { CreateStep1_3, CreateStep1_4 }]</InArgument>
          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
          </InArgument>
          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep1_2]</OutArgument>
        </mxswa:ActivityReference.Arguments>
      </mxswa:ActivityReference>
      <mxswa:SetEntityProperty Attribute=""subject"" Entity=""[CreatedEntities(&quot;CreateStep1_localParameter#Temp&quot;)]"" EntityName=""phonecall"" Value=""[CreateStep1_2]"">
        <mxswa:SetEntityProperty.TargetType>
          <InArgument x:TypeArguments=""s:Type"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""x:String"" />
          </InArgument>
        </mxswa:SetEntityProperty.TargetType>
      </mxswa:SetEntityProperty>
      <mxswa:GetEntityProperty Attribute=""leadid"" Entity=""[InputEntities(&quot;primaryEntity&quot;)]"" EntityName=""lead"" Value=""[CreateStep1_7]"">
        <mxswa:GetEntityProperty.TargetType>
          <InArgument x:TypeArguments=""s:Type"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:EntityReference"" />
          </InArgument>
        </mxswa:GetEntityProperty.TargetType>
      </mxswa:GetEntityProperty>
      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
        <mxswa:ActivityReference.Arguments>
          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">SelectFirstNonNull</InArgument>
          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { CreateStep1_7 }]</InArgument>
          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:EntityReference"" />
          </InArgument>
          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep1_6]</OutArgument>
        </mxswa:ActivityReference.Arguments>
      </mxswa:ActivityReference>
      <mxswa:SetEntityProperty Attribute=""regardingobjectid"" Entity=""[CreatedEntities(&quot;CreateStep1_localParameter#Temp&quot;)]"" EntityName=""phonecall"" Value=""[CreateStep1_6]"">
        <mxswa:SetEntityProperty.TargetType>
          <InArgument x:TypeArguments=""s:Type"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:EntityReference"" />
          </InArgument>
        </mxswa:SetEntityProperty.TargetType>
      </mxswa:SetEntityProperty>
      <mxswa:ActivityReference AssemblyQualifiedName=""Microsoft.Crm.Workflow.Activities.EvaluateExpression, Microsoft.Crm.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"" DisplayName=""EvaluateExpression"">
        <mxswa:ActivityReference.Arguments>
          <InArgument x:TypeArguments=""x:String"" x:Key=""ExpressionOperator"">CreateCrmType</InArgument>
          <InArgument x:TypeArguments=""s:Object[]"" x:Key=""Parameters"">[New Object() { Microsoft.Xrm.Sdk.Workflow.WorkflowPropertyType.OptionSetValue, ""1"", ""Picklist"" }]</InArgument>
          <InArgument x:TypeArguments=""s:Type"" x:Key=""TargetType"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
          </InArgument>
          <OutArgument x:TypeArguments=""x:Object"" x:Key=""Result"">[CreateStep1_8]</OutArgument>
        </mxswa:ActivityReference.Arguments>
      </mxswa:ActivityReference>
      <mxswa:SetEntityProperty Attribute=""prioritycode"" Entity=""[CreatedEntities(&quot;CreateStep1_localParameter#Temp&quot;)]"" EntityName=""phonecall"" Value=""[CreateStep1_8]"">
        <mxswa:SetEntityProperty.TargetType>
          <InArgument x:TypeArguments=""s:Type"">
            <mxswa:ReferenceLiteral x:TypeArguments=""s:Type"" Value=""mxs:OptionSetValue"" />
          </InArgument>
        </mxswa:SetEntityProperty.TargetType>
      </mxswa:SetEntityProperty>
      <mxswa:CreateEntity EntityId=""{x:Null}"" DisplayName=""CreateStep1: Set first activity for lead."" Entity=""[CreatedEntities(&quot;CreateStep1_localParameter#Temp&quot;)]"" EntityName=""phonecall"" />
      <Assign x:TypeArguments=""mxs:Entity"" To=""[CreatedEntities(&quot;CreateStep1_localParameter&quot;)]"" Value=""[CreatedEntities(&quot;CreateStep1_localParameter#Temp&quot;)]"" />
      <Persist />
    </Sequence>
  </mxswa:Workflow>
</Activity>"
            };
            _workflowId = _serviceProxy.Create(workflow);
            Console.Write("Created workflow to call in Execute Workflow request, ");

            SetStateRequest setStateRequest = new SetStateRequest()
            {
                EntityMoniker =
                    new EntityReference(Workflow.EntityLogicalName, _workflowId),
                State = new OptionSetValue((int)WorkflowState.Activated),
                Status = new OptionSetValue(2)
            };
            _serviceProxy.Execute(setStateRequest);
            Console.WriteLine("and activated.");
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                SetStateRequest setStateRequest = new SetStateRequest()
                {
                    EntityMoniker =
                        new EntityReference(Workflow.EntityLogicalName, _workflowId),
                    State = new OptionSetValue((int)WorkflowState.Draft),
                    Status = new OptionSetValue(1)
                };
                _serviceProxy.Execute(setStateRequest);

                _serviceProxy.Delete(Workflow.EntityLogicalName, _workflowId);
                _serviceProxy.Delete(Lead.EntityLogicalName, _leadId);
                _serviceProxy.Delete(AsyncOperation.EntityLogicalName, _asyncOperationId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                ExecuteWorkflow app = new ExecuteWorkflow();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Sample code for workflows
Sample: Create, retrieve, update, and delete a dialog
Write workflows to automate business processes
ExecuteWorkflowRequest
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete a dialog
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Process\Dialogs\CRUDDialog.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create, retrieve, update, and delete a dialog process using these methods:

  • IOrganizationService.Create
  • IOrganizationService.Retrieve
  • IOrganizationService. Delete

Example

C# Copy Code
using System;
using System.IO;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to create, retrieve, update, and delete.
    /// a dialog process.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class CRUDDialog
    {
        #region Class Level Members

        private Guid _dialogId;
        private OrganizationServiceProxy _serviceProxy;

        /// <summary>
        /// TODO: Change the location and file name of the sample XAML file
        /// containing the dialog definition.
        /// e.g. Use the sample xml file located in the SDK\SampleCode\CS\Dialogs folder.
        /// </summary>
        String pathToXAML = Path.Combine(Environment.CurrentDirectory, @"CallCategorization.xml");

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// create, retrieve, update, and delete operations are performed on a
        /// dialog process.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Define an anonymous type to define the possible values for
                    // workflow category
                    var WorkflowCategory = new
                    {
                        Workflow = 0,
                        Dialog = 1
                    };

                    // Instantiate a Workflow object.
                    // See the Entity Metadata topic in the SDK documentation to determine
                    // which attributes must be set for each entity.
                    Workflow sampleDialog = new Workflow
                    {
                        Category = new OptionSetValue((int)WorkflowCategory.Dialog),
                        Name = "Sample Dialog: Call Categorization",
                        PrimaryEntity = PhoneCall.EntityLogicalName,

                        //Language code for U.S. English
                        LanguageCode = 1033,
                        Xaml = File.ReadAllText(pathToXAML)
                    };

                    // Create a dialog record.
                    _dialogId = _serviceProxy.Create(sampleDialog);
                    Console.Write("{0} created,", sampleDialog.Name);

                    // Activate the dialog.
                    SetStateRequest activateRequest = new SetStateRequest
                    {
                        EntityMoniker = new EntityReference(Workflow.EntityLogicalName, _dialogId),
                        State = new OptionSetValue((int)WorkflowState.Activated),
                        Status = new OptionSetValue(2)
                    };
                    _serviceProxy.Execute(activateRequest);
                    Console.WriteLine(" and activated.");

                    // Retrieve the dialog containing several of its attributes.
                    ColumnSet cols = new ColumnSet("name", "statecode", "statuscode");

                    Workflow retrievedDialog = (Workflow)_serviceProxy.Retrieve(Workflow.EntityLogicalName, _dialogId, cols);
                    Console.Write("Retrieved,");

                    // Update the dialog.
                    // Deactivate the dialog before you can update it.
                    SetStateRequest deactivateRequest = new SetStateRequest
                    {
                        EntityMoniker = new EntityReference(Workflow.EntityLogicalName, _dialogId),
                        State = new OptionSetValue((int)WorkflowState.Draft),
                        Status = new OptionSetValue(1)

                    };
                    _serviceProxy.Execute(deactivateRequest);

                    // Retrieve the dialog record again to get the unpublished
                    // instance in order to update.
                    Workflow retrievedDialogDeactivated = (Workflow)_serviceProxy.Retrieve(Workflow.EntityLogicalName, _dialogId, cols);

                    // Update the dialog.
                    retrievedDialogDeactivated.Name = "Updated Dialog: Call Categorization";
                    _serviceProxy.Update(retrievedDialogDeactivated);

                    Console.Write(" updated,");

                    // Activate the dialog.
                    SetStateRequest updateActivateRequest = new SetStateRequest
                    {
                        EntityMoniker = new EntityReference(Workflow.EntityLogicalName, _dialogId),
                        State = new OptionSetValue((int)WorkflowState.Activated),
                        Status = new OptionSetValue(2)
                    };
                    _serviceProxy.Execute(updateActivateRequest);
                    Console.WriteLine(" and activated again.");

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // For this sample, all required entities are created in the Run() method.
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                // Deactivate the dialog, and then delete it.
                SetStateRequest deactivateRequest = new SetStateRequest
                {
                    EntityMoniker = new EntityReference(Workflow.EntityLogicalName, _dialogId),
                    State = new OptionSetValue((int)WorkflowState.Draft),
                    Status = new OptionSetValue(1),
                };
                _serviceProxy.Execute(deactivateRequest);
                _serviceProxy.Delete(Workflow.EntityLogicalName, _dialogId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CRUDDialog app = new CRUDDialog();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Use dialogs for guided processes

Other Resources

Sample: Create a workflow in code
Sample code for workflows
IOrganizationService
SetStateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a workflow in code
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Process\Workflows\CreateAWorkflow.cs

Requirements

You must enable support for custom XAML workflows on your on-premises server. For more information, see Enable or Disable XAML Workflows. For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following sample shows how to programmatically create an asynchronous workflow in code instead of using a workflow editor or designer. This sample works only with an on-premises deployment of Microsoft Dynamics CRM 2015 because custom XAML workflows are not supported in Microsoft Dynamics CRM Online.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

// These namespaces are found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to use C# code to define a new workflow in Microsoft Dynamics CRM.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class CreateAWorkflow
    {
        #region Class Level Members

        private Guid _workflowId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        /// <summary>
        /// This method first creates XAML to define the custom workflow. Afterwards,
        /// it creates the workflow record with this XAML and then activates it.
        /// </summary>
        /// <remarks>
        /// Visit http://msdn.microsoft.com/en-us/library/gg309458.aspx
        /// for instructions on enabling XAML workflows on the Microsoft Dynamics CRM server.
        /// </remarks>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Create XAML

                    // Define the workflow XAML.
                    string xamlWF;

                    xamlWF = @"<?xml version=""1.0"" encoding=""utf-16""?>
                        <Activity x:Class=""SampleWF""
                                  xmlns=""http://schemas.microsoft.com/netfx/2009/xaml/activities""
                                  xmlns:mva=""clr-namespace:Microsoft.VisualBasic.Activities;assembly=System.Activities, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35""
                                  xmlns:mxs=""clr-namespace:Microsoft.Xrm.Sdk;assembly=Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35""
                                  xmlns:mxswa=""clr-namespace:Microsoft.Xrm.Sdk.Workflow.Activities;assembly=Microsoft.Xrm.Sdk.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35""
                                  xmlns:s=""clr-namespace:System;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089""
                                  xmlns:scg=""clr-namespace:System.Collections.Generic;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089""
                                  xmlns:srs=""clr-namespace:System.Runtime.Serialization;assembly=System.Runtime.Serialization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089""
                                  xmlns:this=""clr-namespace:"" xmlns:x=""http://schemas.microsoft.com/winfx/2006/xaml"">
                            <x:Members>
                                <x:Property Name=""InputEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
                                <x:Property Name=""CreatedEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
                            </x:Members>
                            <this:SampleWF.InputEntities>
                                <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
                            </this:SampleWF.InputEntities>
                            <this:SampleWF.CreatedEntities>
                              <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
                           </this:SampleWF.CreatedEntities>
                            <mva:VisualBasic.Settings>Assembly references and imported namespaces for internal implementation</mva:VisualBasic.Settings>
                            <mxswa:Workflow>
                                <Sequence>
                                    <Sequence.Variables>
                                        <Variable x:TypeArguments=""x:Int32"" Default=""[40]"" Name=""probability_value"" />
                                        <Variable x:TypeArguments=""mxs:Entity"" Default=""[CreatedEntities(&quot;primaryEntity#Temp&quot;)]"" Name=""CreatedEntity"" />
                                    </Sequence.Variables>
                                    <Assign x:TypeArguments=""mxs:Entity"" To=""[CreatedEntity]"" Value=""[New Entity(&quot;opportunity&quot;)]"" />
                                    <Assign x:TypeArguments=""s:Guid"" To=""[CreatedEntity.Id]"" Value=""[InputEntities(&quot;primaryEntity&quot;).Id]"" />
                                    <mxswa:SetEntityProperty Attribute=""closeprobability"" Entity=""[CreatedEntity]""
                                        EntityName=""opportunity"" TargetType=""[Type.GetType(&quot;probability_value&quot;)]""
                                                       Value=""[probability_value]"">
                                    </mxswa:SetEntityProperty>
                                    <mxswa:UpdateEntity Entity=""[CreatedEntity]"" EntityName=""opportunity"" />
                                    <Assign x:TypeArguments=""mxs:Entity"" To=""[InputEntities(&quot;primaryEntity&quot;)]"" Value=""[CreatedEntity]"" />
                                    <Persist />
                                </Sequence>
                            </mxswa:Workflow>
                        </Activity>";

                    #endregion Create XAML

                    #region Create Workflow

                    // Create an asynchronous workflow.
                    // The workflow should execute after a new opportunity is created.
                    Workflow workflow = new Workflow()
                    {
                        // These properties map to the New Process form settings in the web application.
                        Name = "Set closeprobability on opportunity create (async)",
                        Type = new OptionSetValue((int)WorkflowType.Definition),
                        Category = new OptionSetValue((int)WorkflowCategory.Workflow),
                        PrimaryEntity = Opportunity.EntityLogicalName,
                        Mode = new OptionSetValue((int)WorkflowMode.Background),

                        // Additional settings from the second New Process form.
                        Description = @"When an opportunity is created, this workflow" +
                            " sets the closeprobability field of the opportunity record to 40%.",
                        OnDemand = false,
                        Subprocess = false,
                        Scope = new OptionSetValue((int)WorkflowScope.User),
                        TriggerOnCreate = true,
                        AsyncAutoDelete = true,
                        Xaml = xamlWF,

                        // Other properties not in the web forms.
                        LanguageCode = 1033,  // U.S. English
                    };
                    _workflowId = _serviceProxy.Create(workflow);

                    Console.WriteLine("Created Workflow: " + workflow.Name);

                    #endregion Create Workflow

                    #region Activate Workflow

                    // Activate the workflow.
                    var activateRequest = new SetStateRequest
                    {
                        EntityMoniker = new EntityReference
                            (Workflow.EntityLogicalName, _workflowId),
                        State = new OptionSetValue((int)WorkflowState.Activated),
                        Status = new OptionSetValue((int)workflow_statuscode.Activated)
                    };
                    _serviceProxy.Execute(activateRequest);
                    Console.WriteLine("Activated Workflow: " + workflow.Name);

                    #endregion Activate Workflow

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #region Class methods

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {

        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {

                // Deactivate and delete workflow
                SetStateRequest deactivateRequest = new SetStateRequest
                {
                    EntityMoniker = new EntityReference(Workflow.EntityLogicalName, _workflowId),
                    State = new OptionSetValue((int)WorkflowState.Draft),
                    Status = new OptionSetValue((int)workflow_statuscode.Draft)
                };
                _serviceProxy.Execute(deactivateRequest);
                _serviceProxy.Delete(Workflow.EntityLogicalName, _workflowId);
                Console.WriteLine("Workflow has been deactivated and deleted.");

            }
        }

        #endregion Class methods

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateAWorkflow app = new CreateAWorkflow();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Custom XAML workflows
Workflow and process entities

Other Resources

Sample code for workflows
Sample: Create a real-time workflow in code
Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a real-time workflow in code
See Also Example

This sample code applies to on–premises Microsoft Dynamics CRM 2015. Complete source code for the sample can be found in the following location in the SDK Download the Microsoft Dynamics CRM SDK package. package:

SampleCode\CS\Process\Workflows\CreateRealtimeWorkflow.cs

Download the Microsoft Dynamics CRM SDK package.

Requirements

You must enable support for custom XAML workflows on your on-premises server. For more information, see Enable or Disable XAML Workflows. For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following sample shows you how to create a real-time workflow in code instead of using the interactive workflow designer in the web application. This sample works only with an on-premises or an Internet-facing deployment (IFD) of Microsoft Dynamics CRM because custom XAML workflows aren’t supported in Microsoft Dynamics CRM Online.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

// These namespaces are found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to use C# code to create a real-time workflow in Microsoft Dynamics CRM.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class CreateRealTimeWorkflow
    {
        #region Class Level Members

        private Guid _workflowId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        /// <summary>
        /// This method first creates XAML to define the custom workflow. Afterwards,
        /// it creates the workflow record with this XAML and then activates it.
        /// </summary>
        /// <remarks>
        /// Visit http://msdn.microsoft.com/en-us/library/gg309458.aspx
        /// for instructions on enabling XAML workflows on the Microsoft Dynamics CRM server.
        /// </remarks>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    #region Define the workflow in XAML

                    // Define the workflow using XAML. This is typically done in the Visual Studio
                    // workflow designer.
                    string xamlWF = @"<?xml version=""1.0"" encoding=""utf-16""?>
                        <Activity x:Class=""SampleWF""
                                  xmlns=""http://schemas.microsoft.com/netfx/2009/xaml/activities""
                                  xmlns:mva=""clr-namespace:Microsoft.VisualBasic.Activities;assembly=System.Activities, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35""
                                  xmlns:mxs=""clr-namespace:Microsoft.Xrm.Sdk;assembly=Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35""
                                  xmlns:mxswa=""clr-namespace:Microsoft.Xrm.Sdk.Workflow.Activities;assembly=Microsoft.Xrm.Sdk.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35""
                                  xmlns:s=""clr-namespace:System;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089""
                                  xmlns:scg=""clr-namespace:System.Collections.Generic;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089""
                                  xmlns:srs=""clr-namespace:System.Runtime.Serialization;assembly=System.Runtime.Serialization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089""
                                  xmlns:this=""clr-namespace:"" xmlns:x=""http://schemas.microsoft.com/winfx/2006/xaml"">
                            <x:Members>
                                <x:Property Name=""InputEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
                                <x:Property Name=""CreatedEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
                            </x:Members>
                            <this:SampleWF.InputEntities>
                                <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
                            </this:SampleWF.InputEntities>
                            <this:SampleWF.CreatedEntities>
                              <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
                           </this:SampleWF.CreatedEntities>
                            <mva:VisualBasic.Settings>Assembly references and imported namespaces for internal implementation</mva:VisualBasic.Settings>
                            <mxswa:Workflow>
                                <Sequence>
                                    <Sequence.Variables>
                                        <Variable x:TypeArguments=""x:Int32"" Default=""[40]"" Name=""probability_value"" />
                                        <Variable x:TypeArguments=""mxs:Entity"" Default=""[CreatedEntities(&quot;primaryEntity#Temp&quot;)]"" Name=""CreatedEntity"" />
                                    </Sequence.Variables>
                                    <Assign x:TypeArguments=""mxs:Entity"" To=""[CreatedEntity]"" Value=""[New Entity(&quot;opportunity&quot;)]"" />
                                    <Assign x:TypeArguments=""s:Guid"" To=""[CreatedEntity.Id]"" Value=""[InputEntities(&quot;primaryEntity&quot;).Id]"" />
                                    <mxswa:SetEntityProperty Attribute=""closeprobability"" Entity=""[CreatedEntity]""
                                        EntityName=""opportunity"" TargetType=""[Type.GetType(&quot;probability_value&quot;)]""
                                                       Value=""[probability_value]"">
                                    </mxswa:SetEntityProperty>
                                    <mxswa:UpdateEntity Entity=""[CreatedEntity]"" EntityName=""opportunity"" />
                                    <Assign x:TypeArguments=""mxs:Entity"" To=""[InputEntities(&quot;primaryEntity&quot;)]"" Value=""[CreatedEntity]"" />
                                    <Persist />
                                </Sequence>
                            </mxswa:Workflow>
                        </Activity>";

                    #endregion Define the workflow in XAML

                    #region Create the workflow

                    // Create a real-time workflow.
                    // The workflow should execute after a new opportunity is created
                    // and run in the context of the logged on user.
                    Workflow workflow = new Workflow()
                    {
                        // These properties map to the New Process form settings in the web application.
                        Name = "Set closeprobability on opportunity create (real-time)",
                        Type = new OptionSetValue((int)WorkflowType.Definition),
                        Category = new OptionSetValue((int)WorkflowCategory.Workflow),
                        PrimaryEntity = Opportunity.EntityLogicalName,
                        Mode = new OptionSetValue((int)WorkflowMode.Realtime),

                        // Additional settings from the second New Process form.
                        Description = @"When an opportunity is created, this workflow" +
                            " sets the closeprobability field of the opportunity record to 40%.",
                        OnDemand = false,
                        Subprocess = false,
                        Scope = new OptionSetValue((int)WorkflowScope.User),
                        RunAs = new OptionSetValue((int)workflow_runas.CallingUser),
                        SyncWorkflowLogOnFailure = true,
                        TriggerOnCreate = true,
                        CreateStage = new OptionSetValue((int)workflow_stage.Postoperation),
                        Xaml = xamlWF,

                        // Other properties not in the web forms.
                        LanguageCode = 1033,  // U.S. English
                    };
                    _workflowId = _serviceProxy.Create(workflow);

                    Console.WriteLine("Created Workflow: " + workflow.Name);

                    #endregion Create the workflow

                    #region Activate the workflow

                    // Activate the workflow. Initially, the workflow is created in
                    // a Draft state and must be activated before it can run.
                    var activateRequest = new SetStateRequest
                    {
                        EntityMoniker = new EntityReference
                            (Workflow.EntityLogicalName, _workflowId),
                        State = new OptionSetValue((int)WorkflowState.Activated),
                        Status = new OptionSetValue((int)workflow_statuscode.Activated)
                    };
                    _serviceProxy.Execute(activateRequest);
                    Console.WriteLine("Activated Workflow: " + workflow.Name);

                    #endregion Activate the workflow

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #region Class methods

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // No new entity records needed for this sample.
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {

                // Deactivate then delete the workflow.
                SetStateRequest deactivateRequest = new SetStateRequest
                {
                    EntityMoniker = new EntityReference(Workflow.EntityLogicalName, _workflowId),
                    State = new OptionSetValue((int)WorkflowState.Draft),
                    Status = new OptionSetValue((int)workflow_statuscode.Draft)
                };
                _serviceProxy.Execute(deactivateRequest);
                _serviceProxy.Delete(Workflow.EntityLogicalName, _workflowId);
                Console.WriteLine("Workflow has been deactivated and deleted.");
            }
        }

        #endregion Class methods

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateRealTimeWorkflow app = new CreateRealTimeWorkflow();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Create real-time workflows
Custom XAML workflows
Workflow and process entities

Other Resources

Sample: Set the state of a workflow
Write workflows to automate business processes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Set the state of a workflow
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Process\Workflows\SetStateWorkflow.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to change the state of a workflow, through activating and deactivating it, by using the SetStateRequest message. In addition, the sample shows how to create a custom XAML workflow. A snippet showing just the key sections of the sample is shown first, followed by the Complete Sample Code.

Example

Code snippet that shows how to activate and deactivate a workflow.

C# Copy Code
var activateRequest = new SetStateRequest
{
    EntityMoniker = new EntityReference
        (Workflow.EntityLogicalName, _workflowId),
    State = new OptionSetValue((int)WorkflowState.Activated),
    Status = new OptionSetValue((int)workflow_statuscode.Activated)
};
_serviceProxy.Execute(activateRequest);

   ...

SetStateRequest deactivateRequest = new SetStateRequest
{
    EntityMoniker =
        new EntityReference(Workflow.EntityLogicalName, _workflowId),
    State = new OptionSetValue((int)WorkflowState.Draft),
    Status = new OptionSetValue((int)workflow_statuscode.Draft)
};
_serviceProxy.Execute(deactivateRequest);

Code snippet that shows how to create a XAML workflow.

C# Copy Code
Workflow workflow = new Workflow()
{
    Name = "CreateTaskXAML",
    Type = new OptionSetValue((int)WorkflowType.Definition),
    Category = new OptionSetValue((int)WorkflowCategory.Workflow),
    Scope = new OptionSetValue((int)WorkflowScope.User),
    LanguageCode = 1033,                // U.S. English
    TriggerOnCreate = true,
    OnDemand = true,
    PrimaryEntity = Lead.EntityLogicalName,
    Description =
        "Test workflow for the SetStateWorkflow SDK sample",
    Xaml = xamlWF
};
_workflowId = _serviceProxy.Create(workflow);

For the XAML code that defines the workflow, see the Complete Sample Code.

Complete Sample Code

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

// These namespaces are found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to change the state of a workflow.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.
    /// </remarks>
    public class SetStateWorkflow
    {
        #region Class Level Members

        private Guid _workflowId;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first creates XAML to define the custom workflow. Afterwards,
        /// it creates the workflow record with this XAML and then activates it. Finally
        /// it checks if it is activated and, if so, deactivates it.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Activate the workflow.
                    Console.WriteLine("\nActivating the workflow...");
                    var activateRequest = new SetStateRequest
                    {
                        EntityMoniker = new EntityReference
                            (Workflow.EntityLogicalName, _workflowId),
                        State = new OptionSetValue((int)WorkflowState.Activated),
                        Status = new OptionSetValue((int)workflow_statuscode.Activated)
                    };
                    _serviceProxy.Execute(activateRequest);

                    // Verify that the workflow is activated.
                    Workflow retrievedWorkflow =
                        (Workflow)_serviceProxy.Retrieve("workflow", _workflowId, new ColumnSet("statecode", "name"));

                    Console.WriteLine("The state of workflow {0} is: {1}.", retrievedWorkflow.Name, retrievedWorkflow.StateCode);

                    // Deactivate the workflow.
                    if (retrievedWorkflow.StateCode == WorkflowState.Activated)
                    {
                        Console.WriteLine("\nDeactivating the workflow...");
                        SetStateRequest deactivateRequest = new SetStateRequest
                        {
                            EntityMoniker =
                                new EntityReference(Workflow.EntityLogicalName, _workflowId),
                            State = new OptionSetValue((int)WorkflowState.Draft),
                            Status = new OptionSetValue((int)workflow_statuscode.Draft)
                        };
                        _serviceProxy.Execute(deactivateRequest);
                    }

                    // Verify that the workflow is deactivated (in a draft state).
                    retrievedWorkflow =
                        (Workflow)_serviceProxy.Retrieve("workflow", _workflowId, new ColumnSet("statecode", "name"));

                    Console.WriteLine("The state of workflow {0} is: {1}.", retrievedWorkflow.Name, retrievedWorkflow.StateCode);

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #region Public methods

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            #region Create XAML

            // Define the workflow XAML.
            string xamlWF;

            // This xml defines a workflow that creates a new task when executed
            xamlWF = @"<?xml version=""1.0"" encoding=""utf-16""?>
                        <Activity x:Class=""CreateTask""
                                  xmlns=""http://schemas.microsoft.com/netfx/2009/xaml/activities""
                                  xmlns:mva=""clr-namespace:Microsoft.VisualBasic.Activities;assembly=System.Activities, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35""
                                  xmlns:mxs=""clr-namespace:Microsoft.Xrm.Sdk;assembly=Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35""
                                  xmlns:mxswa=""clr-namespace:Microsoft.Xrm.Sdk.Workflow.Activities;assembly=Microsoft.Xrm.Sdk.Workflow, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35""
                                  xmlns:s=""clr-namespace:System;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089""
                                  xmlns:scg=""clr-namespace:System.Collections.Generic;assembly=mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089""
                                  xmlns:srs=""clr-namespace:System.Runtime.Serialization;assembly=System.Runtime.Serialization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089""
                                  xmlns:this=""clr-namespace:"" xmlns:x=""http://schemas.microsoft.com/winfx/2006/xaml"">
                            <x:Members>
                                <x:Property Name=""InputEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
                                <x:Property Name=""CreatedEntities"" Type=""InArgument(scg:IDictionary(x:String, mxs:Entity))"" />
                            </x:Members>
                            <this:CreateTask.InputEntities>
                                <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
                            </this:CreateTask.InputEntities>
                            <this:CreateTask.CreatedEntities>
                              <InArgument x:TypeArguments=""scg:IDictionary(x:String, mxs:Entity)"" />
                           </this:CreateTask.CreatedEntities>
                            <mva:VisualBasic.Settings>Assembly references and imported namespaces for internal implementation</mva:VisualBasic.Settings>
                            <mxswa:Workflow>
                                <Sequence>
                                    <Assign x:TypeArguments=""mxs:Entity"" To=""[CreatedEntities(&quot;newTask&quot;)]"" Value=""[New Entity(&quot;task&quot;)]"" />
                                    <mxswa:SetEntityProperty Attribute=""subject"" Entity=""[CreatedEntities(&quot;newTask&quot;)]""
                                        EntityName=""task"" TargetType=""{x:Null}""
                                                       Value=""[&quot;New Task&quot;]"">
                                    </mxswa:SetEntityProperty>
                                    <mxswa:SetEntityProperty Attribute=""regardingobjectid"" Entity=""[CreatedEntities(&quot;newTask&quot;)]""
                                        EntityName=""task"" TargetType=""{x:Null}""
                                                       Value=""[New EntityReference(&quot;lead&quot;, New Guid(InputEntities(&quot;primaryEntity&quot;).Id.ToString()))]"">
                                    </mxswa:SetEntityProperty>
                                    <mxswa:CreateEntity EntityId=""{x:Null}"" Entity=""[CreatedEntities(&quot;newTask&quot;)]""
                                        EntityName=""task"" />
                                </Sequence>
                            </mxswa:Workflow>
                        </Activity>";

            #endregion Create XAML

            #region Create Workflow

            // Create the workflow
            Workflow workflow = new Workflow()
            {
                Name = "CreateTaskXAML",
                Type = new OptionSetValue((int)WorkflowType.Definition),
                Category = new OptionSetValue((int)WorkflowCategory.Workflow),
                Scope = new OptionSetValue((int)WorkflowScope.User),
                LanguageCode = 1033,                // U.S. English
                TriggerOnCreate = true,
                OnDemand = true,
                PrimaryEntity = Lead.EntityLogicalName,
                Description =
                    "Test workflow for the SetStateWorkflow SDK sample",
                Xaml = xamlWF
            };
            _workflowId = _serviceProxy.Create(workflow);

            Console.WriteLine("Created workflow {0}.", workflow.Name);

            #endregion Create Workflow
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete the workflow.
                _serviceProxy.Delete(Workflow.EntityLogicalName, _workflowId);
                Console.WriteLine("The workflow has been deleted.");
            }
        }
        #endregion Public Methods

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                SetStateWorkflow app = new SetStateWorkflow();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        #endregion Main method
    }
}

See Also

Concepts

Custom XAML workflows

Other Resources

Sample code for workflows
Write workflows to automate business processes
SetStateRequest
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Developers guide to reports for Microsoft Dynamics CRM

Microsoft Dynamics CRM includes reports that provide useful business information to the user. These reports are based on Microsoft SQL Server Reporting Services, and provide the same set of features that are available for the Microsoft SQL Server Reporting Services reports. More information: SQL Server Reporting Services

The Report Writers Guide has been moved to Deploying and administering Microsoft Dynamics CRM. The topics here are for developer scenarios.

The report definition (data and layout) of Microsoft Dynamics CRM reports are contained in an .rdl file, and the contents of the .rdl file conform to the Microsoft SQL Server Report Definition Language Specification. More information: Report Definition Language Reference

Microsoft Dynamics CRM provides many out-of-box reports for viewing your business data. You can create custom reports using one of these reports as templates or can create a custom report from scratch.

There are two types of reports in Microsoft Dynamics CRM:

SQL-based

These reports use SQL queries to securely retrieve data for reports from filtered views defined by the system. These are the same reports that have been available for previous versions of Microsoft Dynamics CRM. The default reports that are shipped with Microsoft Dynamics CRM are SQL-based reports.

For security reasons, you cannot deploy custom SQL-based reports to Microsoft Dynamics CRM Online.

Fetch-based

These reports are introduced in Microsoft Dynamics CRM and use FetchXML queries to retrieve data for reports. You can deploy custom fetch-based reports to Microsoft Dynamics CRM Online and to Microsoft Dynamics CRM (on-premises). All reports that are created using the Report Wizard in the Microsoft Dynamics CRM are Fetch-based reports.

Reports in Microsoft Dynamics CRM Online run in sandbox mode, and this is done by enabling RDL sandboxing in Microsoft SQL Server Reporting Services. As a result, certain features might not be available in Microsoft Dynamics CRM Online. For example, custom code in your report definition will not work. More information: Enabling and Disabling RDL Sandboxing

In This Section

Publish reports

Publish a report using the Microsoft Dynamics CRM web service

Manage a report in offline mode

Report configuration file schema

Report entities

Sample code for reporting

Reference

SQL Server Reporting Services Book Online

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Publish reports

There are two ways to publish a report for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update:

  • Publish a report using the Microsoft Dynamics CRM web application
  • Publish a report using the Microsoft Dynamics CRM web service

This topic contains information that applies to both methods.

In This Topic

Privileges for publishing reports

Ownership and sharing for reports

Link a report to another report

Privileges for publishing reports

To publish a report of type Reporting Services Report, you must have the prvPublishRSReport and prvCreateReport privileges for the report entity. However, you do not need the prvPublishRSReport privilege to publish the other two types of reports: Other Report and Linked Report. The report type is specified in the Report.ReportTypeCode attribute.

If the report is associated with the related report categories (ReportCategory), report entity (ReportEntity), and report area (ReportVisibility) entities, you must also have the prvAppendReport and prvAppendToReport privileges for the report entity. By default, the System Administrator and System Customizer security roles have these privileges. For more information, see Report entity privileges and Privileges not associated with an entity.

Ownership and sharing for reports

The reports can be organization-owned or user or team-owned. For more information, see Entity Ownership. If a report is organization-owned it is visible to the whole organization. If the report is user or team-owned, you can share the report with other users and teams.

You can change the ownership of a report as follows:

  • Use the IOrganizationService.Update method and set the Report.IsPersonal attribute to a desired value. For organization-owned reports, set the attribute value to false; for user-or team-owned reports, set it to true.
  • Use the MakeAvailableToOrganizationReportRequest and MakeUnavailableToOrganizationReportRequest messages

Changes in ownership cascade from a parent report to child reports. If you make a parent report organization-owned, all its children reports also become organization-owned. For more information, see Entity relationship behavior.

Link a report to another report

The report can be self-contained or have child reports that provide more detailed information. The parent and the child reports have a parental relationship (see Entity relationship behavior). This means that all operations on the parent record are propagated to the child records (cascade all). However, in a delete operation, the child report is not deleted, but the link between the parent report and the child report is removed.

The child report must contain the information about the parent report ID. To specify the parent report ID, set the Report.ParentReportId attribute in the child report. The linking between the parent report and child report is performed when the child report is created or updated. The parent can have multiple child reports. You must publish a parent report before publishing its child reports. If you create a child report before you create a parent report, you have to update the child report with the parent report ID after the parent report is created.

See Also

Concepts

Publish a report using the Microsoft Dynamics CRM web service
Publish a report using the Microsoft Dynamics CRM web service

Other Resources

Developers guide to reports for Microsoft Dynamics CRM
Developers guide to reports for Microsoft Dynamics CRM
Publish a report using the Microsoft Dynamics CRM web application
Copy reports between Microsoft Dynamics CRM deployments

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Publish a report using the Microsoft Dynamics CRM web service

To publish a report to Microsoft Dynamics CRM, you can either create a new report record or update an existing report record. Use the IOrganizationService.Create method to create a report, or use the IOrganizationService.Update method to update a report. You must specify the report type, report visibility, report category, and the related entities for the report as shown below.

Specify report type

When you create report record, specify the type of report using the Report.ReportTypeCode attribute. A report can be one of the following types:

  • Reporting Services Report: For this report type, set a value for the Report.BodyText attribute. Also, specify the name of the .rdl file that contains the report definition by using the Report.Filename attribute.
  • Other Report: For this report type, set a value for the Report.BodyBinary attribute. Specify the name of the .rdl file that contains the report definition by using the Report.Filename attribute.
  • Linked Report: For this report type, set a value for the Report.BodyUrl attribute.

Specify report category

To show and run a report in the different report categories, such as Marketing, Sales, or Service, use the ReportCategory.CategoryCode attribute to specify a category. You can specify multiple categories for a report.

Specify report visibility

By default, the report is visible in the All Reports, Including Sub-Reports view in the Reports grid. To show a report in additional views in the grid, or different areas, such as the entity form or entity grid, use the ReportVisibility.VisibilityCode attribute to specify the view or the area. You can specify multiple views and areas for a report.

Specify report entities

To specify a related entity for the report, use the ReportEntity.ObjectTypeCode attribute. You can specify multiple related entities.

Example

This sample shows how to create the records needed to publish a report.

C# Copy Code

// Define an anonymous type to define the possible values for
// report type.
var ReportTypeCode = new
{
    ReportingServicesReport = 1,
    OtherReport = 2,
    LinkedReport = 3
};

// Define an anonymous type to define the possible values for
// report category.
var ReportCategoryCode = new
{
    SalesReports = 1,
    ServiceReports = 2,
    MarketingReports = 3,
    AdministrativeReports = 4
};

// Define an anonymous type to define the possible values for
// report visibility
var ReportVisibilityCode = new
{
    ReportsGrid = 1,
    Form = 2,
    Grid = 3,
};

// Instantiate a report object.
// See the Entity Metadata topic in the SDK documentation to determine
// which attributes must be set for each entity.

Report sampleReport = new Report
{
    Name = "Sample Report",
    BodyText = File.ReadAllText("SampleReport.rdl"),
    FileName = "SampleReport.rdl",
    LanguageCode = 1033, // US English
    ReportTypeCode = new OptionSetValue(ReportTypeCode.ReportingServicesReport)
};
// Create a report record named Sample Report.
_reportId = _serviceProxy.Create(sampleReport);

// Set the report category.
ReportCategory sampleReportCategory = new ReportCategory
{
    ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
    CategoryCode = new OptionSetValue(ReportCategoryCode.AdministrativeReports)
};
_reportCategoryId = _serviceProxy.Create(sampleReportCategory);

// Define which entity this report uses.
ReportEntity reportEntity = new ReportEntity
{
    ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
    ObjectTypeCode = Account.EntityLogicalName
};
_reportEntityId = _serviceProxy.Create(reportEntity);

// Set the report visibility.
ReportVisibility rv = new ReportVisibility
{
    ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
    VisibilityCode = new OptionSetValue(ReportVisibilityCode.Form)
};
_reportVisibilityId1 = _serviceProxy.Create(rv);

rv = new ReportVisibility
{
    ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
    VisibilityCode = new OptionSetValue(ReportVisibilityCode.Grid)
};
_reportVisibilityId2 = _serviceProxy.Create(rv);

rv = new ReportVisibility
{
    ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
    VisibilityCode = new OptionSetValue(ReportVisibilityCode.ReportsGrid)
};
_reportVisibilityId3 = _serviceProxy.Create(rv);

Console.WriteLine("{0} published in Microsoft Dynamics CRM.", sampleReport.Name);

See Also

Concepts

Publish reports
Manage a report in offline mode

Other Resources

Developers guide to reports for Microsoft Dynamics CRM
Sample: Publish a report

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Manage a report in offline mode

The following report managing activities can’t be performed when the local Microsoft Dynamics CRM system remains in the offline mode:

  • Create reports or update reports by using the CreateRequest message or the UpdateRequest message, respectively.
  • Delete the reports by using the DeleteRequest message.
  • Change the ownership type of the reports by using the MakeAvailableToOrganizationReportRequest message or the MakeUnavailableToOrganizationReportRequest message.
  • Run the custom reports that use the multi-valued parameters. The multi-valued parameters are defined in the MultiValue element of the Report Definition Language (RDL) file.

However, you can retrieve the published reports in the offline mode by using the RetrieveRequest message and the RetrieveMultipleRequest message. This enables you to view the reports in the Microsoft Dynamics CRM Report Viewer and the Reports list.

Note
We don’t recommend that you use the ReportFolder, ReportName, and ReportServerUrl global variables in reports that run in the offline mode. These variables are members of the Globals collection that contains the global variables for the report, such as execution time, number of pages, and report name. More information: Using Global Collections in Expressions (Reporting Services)

See Also

Reference

Report configuration file schema

Other Resources

Developers guide to reports for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Report configuration file schema

New custom report types can be added to Microsoft Dynamics CRM through the reports configuration file. For each new report type, a viewer can be defined that specifies the report type's filename extension and a handler that can display a report of the given type.

You can find this schema in the SDK\Schemas\reports.config.xsd file in the SDK package. Download the Microsoft Dynamics CRM SDK package.

Schema

Xml Copy Code
<?xml version="1.0" encoding="utf-8"?>
<xs:schema id="viewers" xmlns="" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:msdata="urn:schemas-microsoft-com:xml-msdata">
  <xs:element name="viewers">
    <xs:complexType>
      <xs:choice maxOccurs="unbounded">
        <xs:element name="viewer">
          <xs:complexType>
            <xs:attribute name="extension" type="xs:string" use="required"/>
            <xs:attribute name="handler" type="xs:string" use="optional"/>
            <xs:attribute name="name" type="xs:string" use="required"/>
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:complexType>
  </xs:element>
</xs:schema>

Sample Report Configuration File

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<viewers>
  <viewer extension="xyz" handler="/Specialviewer.aspx"
    name="Special Report Type"/>
  <viewer extension="abc" name="Client Rendered Report"/>
</viewers>

See Also

Other Resources

Developers guide to reports for Microsoft Dynamics CRM
Report entities
Schemas used in Microsoft Dynamics CRM
Developers guide to reports for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Report entities

The report entity model contains a set of entities that are used for managing reports in Microsoft Dynamics CRM. The report entity represents a report definition. The other entities shown in the figure are used to: specify the entities and categories that are related to a report (report entity and report category), specify the areas in Microsoft Dynamics CRM where the report is shown (report visibility), and links and dependencies between related reports (report link).

The following illustration shows the entity relationships for this area. More information: Key to entity diagrams.

Report entity relationship diagram

In This Section

Report entity messages and methods

ReportCategory (report related category) entity messages and methods

ReportEntity (report related) entity messages and methods

ReportLink entity messages and methods

ReportVisibility entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Report entity messages and methods

A report is a data summary in an easy-to-read layout.The schema name for this entity is Report. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message Description

AssignRequest

Assigns a report to another user or team.

AssociateRequest

Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Report entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

CreateRequest

Creates a report. You can also call the IOrganizationService.Create method.

DeleteRequest

Deletes a report. You can also call the IOrganizationService.Delete method.

DisassociateRequest

Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService. Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Report entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

DownloadReportDefinitionRequest

Returns the report definition associated with the report.

Pass the ID of a report in the ReportId property of this request. The report definition is returned in the BodyText property of the message response.

GetReportHistoryLimitRequest

Retrieves an integer value that represents the number of report history snapshots that a given report is permitted to have.

The default number of the report history snapshots is 8. If -1 is returned, the report can have an unlimited number of report history snapshots.

GrantAccessRequest

Shares a report with another security principal (user or team).

InitializeFromRequest

Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.

MakeAvailableToOrganizationReportRequest

Deprecated. Use the UpdateRequest class. Changes the ownership of the report to organization-owned.

Pass the ID of a report in the ReportId property of this request.

MakeUnavailableToOrganizationReportRequest

Deprecated. Use the UpdateRequest class. Changes the ownership of the report to user-owned.

Pass the ID of a report in the ReportId property of this request.

ModifyAccessRequest

Changes the access rights for a report previously shared with another security principal (user or team).

RetrieveDuplicatesRequest

Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.

RetrieveRequest

Retrieves a report. You can also call the IOrganizationService.Retrieve method.

RetrieveMultipleRequest

Retrieves a collection of reports. You can also call the IOrganizationService.RetrieveMultiple method.

RetrievePrincipalAccessRequest

Retrieves the access the specified security principal (user or team) has to a report.

RetrieveSharedPrincipalsAndAccessRequest

Retrieves the security principals (users or teams) that have access to a report, and also retrieves their access rights to the report.

RevokeAccessRequest

Removes all access to a report for the specified security principal (user or team).

SetReportRelatedRequest

Specifies in which areas of Microsoft Dynamics CRM the report can be run and viewed.

UpdateRequest

Updates a report. You can also call the IOrganizationService.Update method.

See Also

Concepts

Report entity privileges
ReportCategory (report related category) entity messages and methods

Other Resources

Report entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReportCategory (report related category) entity messages and methods

A report category represents the category related to a report. A report can be related to multiple categories. The schema name for this entity is ReportCategory. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a report category. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a report category.You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a report category.You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of report categories..You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a report category.You can also call the IOrganizationService.Update method.

See Also

Concepts

ReportCategory (report related category) entity privileges
ReportEntity (report related) entity messages and methods

Other Resources

Report entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReportEntity (report related) entity messages and methods

This entity contains information about an entity related to a report. A report can be related to multiple entities. The schema name for this entity is ReportEntity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the Execute method.

Message | Description
CreateRequest | Creates a report entity. You can also call the Create method.
DeleteRequest | Deletes a report entity. You can also call the Delete method.
RetrieveRequest | Retrieves a report entity. You can also call the Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of report entities. You can also call the RetrieveMultiple method.
UpdateRequest | Updates a report entity. You can also call the Update method.

See Also

Concepts

Report entity privileges
ReportLink entity messages and methods

Other Resources

Report entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReportLink entity messages and methods

A report link represents links and dependencies between reporting services reports. A report can drill through to another report, or have another report as a sub-report. The schema name for this entity is ReportLink. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves a report link.You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of report links.You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

ReportLink entity privileges
ReportVisibility entity messages and methods

Other Resources

Report entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReportVisibility entity messages and methods

A report visibility represents the area in which to show a report. A report can be shown in multiple areas. The schema name for this entity is ReportVisibility. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a report visibility. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a report visibility. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a report visibility. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of report visibility records. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a report visibility. You can also call the IOrganizationService.Update method.

See Also

Concepts

ReportVisibility entity privileges

Other Resources

Report entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample code for reporting

This section provides samples showing how to implement common techniques in your reports for Microsoft Dynamics CRM.

In This Section

Sample: Publish a report

Sample: Make a report available or unavailable to organization

Sample: Download report definition

Sample: Get the report history limit

Related Sections

Developers guide to reports for Microsoft Dynamics CRM

Publish reports

Publish a report using the Microsoft Dynamics CRM web service

Manage a report in offline mode

Report configuration file schema

Report entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Publish a report
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Reporting\PublishReport.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to publish a report by creating a Report record and the related records that make it visible.

Example

C# Copy Code
using System;
using System.Xml;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve the history limit of a report.
    /// </summary>
    public class PublishReport
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        Guid _reportId;
        Guid _reportCategoryId;
        Guid _reportVisibilityId1;
        Guid _reportVisibilityId2;
        Guid _reportVisibilityId3;
        Guid _reportEntityId;
        //Guid _reportLinkId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Retrieve the history limit of a report.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Define an anonymous type to define the possible values for
                    // report type.
                    var ReportTypeCode = new
                    {
                        ReportingServicesReport = 1,
                        OtherReport = 2,
                        LinkedReport = 3
                    };

                    // Define an anonymous type to define the possible values for
                    // report category.
                    var ReportCategoryCode = new
                    {
                        SalesReports = 1,
                        ServiceReports = 2,
                        MarketingReports = 3,
                        AdministrativeReports = 4
                    };

                    // Define an anonymous type to define the possible values for
                    // report visibility
                    var ReportVisibilityCode = new
                    {
                        ReportsGrid = 1,
                        Form = 2,
                        Grid = 3,
                    };

                    // Instantiate a report object.
                    // See the Entity Metadata topic in the SDK documentation to determine
                    // which attributes must be set for each entity.

                    Report sampleReport = new Report
                    {
                        Name = "Sample Report",
                        BodyText = File.ReadAllText("SampleReport.rdl"),
                        FileName = "SampleReport.rdl",
                        LanguageCode = 1033, // US English
                        ReportTypeCode = new OptionSetValue(ReportTypeCode.ReportingServicesReport)
                    };
                    // Create a report record named Sample Report.
                    _reportId = _serviceProxy.Create(sampleReport);

                    // Set the report category.
                    ReportCategory sampleReportCategory = new ReportCategory
                    {
                        ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
                        CategoryCode = new OptionSetValue(ReportCategoryCode.AdministrativeReports)
                    };
                    _reportCategoryId = _serviceProxy.Create(sampleReportCategory);

                    // Define which entity this report uses.
                    ReportEntity reportEntity = new ReportEntity
                    {
                        ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
                        ObjectTypeCode = Account.EntityLogicalName
                    };
                    _reportEntityId = _serviceProxy.Create(reportEntity);

                    // Set the report visibility.
                    ReportVisibility rv = new ReportVisibility
                    {
                        ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
                        VisibilityCode = new OptionSetValue(ReportVisibilityCode.Form)
                    };
                    _reportVisibilityId1 = _serviceProxy.Create(rv);

                    rv = new ReportVisibility
                    {
                        ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
                        VisibilityCode = new OptionSetValue(ReportVisibilityCode.Grid)
                    };
                    _reportVisibilityId2 = _serviceProxy.Create(rv);

                    rv = new ReportVisibility
                    {
                        ReportId = new EntityReference(Report.EntityLogicalName, _reportId),
                        VisibilityCode = new OptionSetValue(ReportVisibilityCode.ReportsGrid)
                    };
                    _reportVisibilityId3 = _serviceProxy.Create(rv);

                    Console.WriteLine("{0} published in Microsoft Dynamics CRM.", sampleReport.Name);

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // No entity records are required for this sample.
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want the records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Report.EntityLogicalName, _reportId);
                /* There is no need to delete these records because deleting the report will delete all related records.
                _serviceProxy.Delete(ReportCategory.EntityLogicalName, _reportCategoryId);
                _serviceProxy.Delete(ReportEntity.EntityLogicalName, _reportEntityId);
                _serviceProxy.Delete(ReportLink.EntityLogicalName, _reportLinkId);
                _serviceProxy.Delete(ReportVisibility.EntityLogicalName, _reportVisibilityId1);
                _serviceProxy.Delete(ReportVisibility.EntityLogicalName, _reportVisibilityId2);
                _serviceProxy.Delete(ReportVisibility.EntityLogicalName, _reportVisibilityId3);
                */
                Console.WriteLine("Entity records have been deleted.");

            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                PublishReport app = new PublishReport();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Concepts

Publish a report using the Microsoft Dynamics CRM web service

Other Resources

Sample code for reporting
Sample: Make a report available or unavailable to organization

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Make a report available or unavailable to organization
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Reporting\MakeReportAvailableOrUnavailableToOrganization.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to make a report available or unavailable to an organization.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to make a report available and
    /// unavailable to the organization.
    /// </summary>
    public class MakeReportAvailableOrUnavailableToOrganization
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _reportId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Set the report to be available and then unavailable for the organization.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Retrieve existing personal report.
                    Report existingPersonalReport =
                        (Report)_serviceProxy.Retrieve(Report.EntityLogicalName,
                        _reportId,
                        new ColumnSet("ispersonal"));

                    // Set IsPersonal property to false.
                    existingPersonalReport.IsPersonal = false;

                    // Make the report available to the organization.
                    _serviceProxy.Update(existingPersonalReport);

                    // Retrieve the report and verify that the report is available to the organization
                    ColumnSet Cols1 = new ColumnSet("ispersonal");
                    Report retrieveAvailableReport =
                        (Report)_serviceProxy.Retrieve(Report.EntityLogicalName,
                        _reportId, Cols1);
                    if (retrieveAvailableReport.IsPersonal.Value == false)
                    {
                        Console.WriteLine("Report is available to the organization.");
                    }

                    // Now make the retrieved report unavailable to the organization
                    retrieveAvailableReport.IsPersonal = true;
                    _serviceProxy.Update(retrieveAvailableReport);

                    // Retrieve the report, and verify that the report is unavailable to the organization
                    ColumnSet Cols2 = new ColumnSet("ispersonal");
                    Report retrieveUnavailableReport =
                        (Report)_serviceProxy.Retrieve(Report.EntityLogicalName,
                        _reportId, Cols2);
                    if (retrieveUnavailableReport.IsPersonal.Value == true)
                    {
                        Console.WriteLine("Report is unavailable to the organization.");
                    }

                    DeleteRequiredRecords(promptforDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Define an anonymous type to define the possible values for
            // report type
            var ReportTypeCode = new
            {
                ReportingServicesReport = 1,
                OtherReport = 2,
                LinkedReport = 3
            };

            // Create a report
            Report newReport = new Report
            {
                Name = "Sample Report",
                Description = "Report created by the SDK code sample.",
                ReportTypeCode = new OptionSetValue((int)ReportTypeCode.OtherReport),

                //Base64-encoded "Hello, I am a text file."
                BodyBinary = "SGVsbG8sIEkgYW0gYSB0ZXh0IGZpbGUu",
                FileName = "textfile.txt",
                IsPersonal = true
            };
            _reportId = _serviceProxy.Create(newReport);
            Console.WriteLine("Created {0}.", newReport.Name);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete all records created in this sample.
                _serviceProxy.Delete(Report.EntityLogicalName, _reportId);
                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                MakeReportAvailableOrUnavailableToOrganization app =
                    new MakeReportAvailableOrUnavailableToOrganization();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additonal exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main method
    }
}

See Also

Other Resources

Developers guide to reports for Microsoft Dynamics CRM
Sample code for reporting
Sample: Download report definition

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Download report definition
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Reporting\DownloadReportDefinition.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to download a report definition (.rdl) file by using the DownloadReportDefinitionRequest message.

Example

C# Copy Code
using System;
using System.IO;
using System.Xml;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to download the report definition (RDL) file.
    /// </summary>
    public class DownloadReportDefinition
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the variables needed for this sample.
        String _currentDirectoryPath;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Download the report definition.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Query for an an existing report: Account Overview. This is a default report in Microsoft Dynamics CRM.
                    QueryByAttribute reportQuery = new QueryByAttribute(Report.EntityLogicalName);
                    reportQuery.AddAttributeValue("name", "Account Overview");
                    reportQuery.ColumnSet = new ColumnSet("reportid");

                    // Get the report.
                    EntityCollection retrieveReports = _serviceProxy.RetrieveMultiple(reportQuery);

                    // Convert retrieved Entity to a report
                    Report retrievedReport = (Report)retrieveReports.Entities[0];
                    Console.WriteLine("Retrieved the 'Account Overview' report.");

                    // Use the Download Report Definition message.
                    DownloadReportDefinitionRequest rdlRequest = new DownloadReportDefinitionRequest
                    {
                        ReportId = retrievedReport.ReportId.Value
                    };

                    DownloadReportDefinitionResponse rdlResponse = (DownloadReportDefinitionResponse)_serviceProxy.Execute(rdlRequest);

                    // Get the current directory path.
                    _currentDirectoryPath = Directory.GetCurrentDirectory();

                    // Access the xml data and save to disk
                    XmlTextWriter reportDefinitionFile = new XmlTextWriter( _currentDirectoryPath + "\\NewReport.rdl", System.Text.Encoding.UTF8);
                    reportDefinitionFile.WriteRaw(rdlResponse.BodyText);
                    reportDefinitionFile.Close();

                    if (File.Exists(_currentDirectoryPath + "\\NewReport.rdl"))
                    {
                        Console.WriteLine("Downloaded the report definition (NewReport.rdl) to '{0}'.", _currentDirectoryPath.ToString());
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // All the entity records in this sample are created in the Run() method.
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want the records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                File.Delete(_currentDirectoryPath + "\\NewReport.rdl");
                Console.WriteLine("The downloaded report definition has been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DownloadReportDefinition app = new DownloadReportDefinition();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Other Resources

Sample code for reporting
Developers guide to reports for Microsoft Dynamics CRM
Sample: Get the report history limit
DownloadReportDefinitionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Get the report history limit
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Reporting\GetReportHistoryLimit.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following code sample demonstrates how to get the history limit of a report using the GetReportHistoryLimitRequest message.

Example

C# Copy Code
using System;
using System.Xml;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve the history limit of a report.
    /// </summary>
    public class GetReportHistoryLimit
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Retrieve the history limit of a report.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Query for an an existing report: Account Overview. This is a default report in Microsoft Dynamics CRM.
                    QueryByAttribute reportQuery = new QueryByAttribute(Report.EntityLogicalName);
                    reportQuery.AddAttributeValue("name", "Account Overview");
                    reportQuery.ColumnSet = new ColumnSet("reportid");

                    // Get the report.
                    EntityCollection retrieveReports = _serviceProxy.RetrieveMultiple(reportQuery);

                    // Convert retrieved Entity to a report
                    Report retrievedReport = (Report)retrieveReports.Entities[0];
                    Console.WriteLine("Retrieved the 'Account Overview' report.");

                    // Use the Download Report Definition message.
                    GetReportHistoryLimitRequest reportHistoryRequest = new GetReportHistoryLimitRequest
                    {
                        ReportId = retrievedReport.ReportId.Value
                    };

                    GetReportHistoryLimitResponse reportHistoryResponse = (GetReportHistoryLimitResponse)_serviceProxy.Execute(reportHistoryRequest);

                    // Access the history limit data
                    int historyLimit = reportHistoryResponse.HistoryLimit;

                    Console.WriteLine("The report history limit is {0}.", historyLimit);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // No entity records are created in this sample.
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                GetReportHistoryLimit app = new GetReportHistoryLimit();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Other Resources

Sample code for reporting
Developers guide to reports for Microsoft Dynamics CRM
GetReportHistoryLimitRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Manage your data

Data management features let you efficiently manage and audit your data in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. You’ll be able to import new data and audit data changes, detect duplicates and delete data in bulk.

Based on the provided functionality, you can develop custom data management tools.

In This Section

Audit entity data changes

Detect duplicate data

Delete data in bulk

Import data

Related Sections

Write applications and server extensions

Software Development Kit for Microsoft Dynamics CRM

Package and distribute extensions using solutions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Audit entity data changes

Organizations need to track changes made to business data for maintaining security, examining the history of a particular data record, documenting modifications for future analysis and record keeping, and being in compliance with regulations. Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update support auditing of entity and attribute data changes on a per organization basis.

In This Section

Auditing overview

Configure entities and attributes for auditing

Retrieve and delete the history of audited data changes

Audit user access

Audit entity messages and methods

Sample: Audit entity data changes

Sample: Audit user access

Related Sections

Manage your data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Auditing overview

Organizations often need to be in compliance with various regulations to ensure availability of customer interaction history, audit logs, access reports, and security incident tracking reports. Organizations may want to track changes in Microsoft Dynamics CRM data for security and analytical purpose.

Microsoft Dynamics CRM supports an auditing capability where entity and attribute data changes within an organization can be recorded over time for use in analysis and reporting purposes. Auditing is supported on all custom and most customizable entities and attributes. Auditing is not supported on metadata changes, retrieve operations, export operations, or during authentication. For information on how to configure auditing, see Configure entities and attributes for auditing.

Supported for auditing

The following table lists what can be audited for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update:

Audit of customizable entities

Audit of custom entities

Configure entities for audit

Configure attributes for audit

Privilege-based audit trail viewing

Privilege-based audit summary viewing

Audit log deletion for a partitioned SQL database

Audit log deletion for a non-partitioned SQL database

Microsoft Dynamics CRM SDK programming support

Audit of record create, update, and delete operations

Audit of relationships (1:N, N:N)

Audit of audit events

Audit of user access

Adherence to regulatory standards

Not supported for auditing

The following table lists what cannot be audited for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update:

Audit of read operations

Audit of metadata changes

Audit of text blobs, notes, and attachments

Key concepts

The following bullets identify some key auditing concepts:

  • You can enable or disable auditing at the organization, entity, and attribute levels. If auditing is not enabled at the organization level, auditing of entities and attributes, even if it is enabled, does not occur. By default, auditing is enabled on all auditable entity attributes, but is disabled at the entity and organization level.
  • For Microsoft Dynamics CRM servers that use Microsoft SQL Server Enterprise editions, auditing data is recorded over time (quarterly) in partitions. A partition is called an audit log in the Microsoft Dynamics CRM web application. Partitions are not supported, and therefore, not used, on a Microsoft Dynamics CRM 2015 server that is running Microsoft SQL Server, Standard edition.
  • The ability to retrieve and display the audit history is restricted to users who have certain security privileges: View Audit History, and View Audit Summary. There are also privileges specific to partitions: View Audit Partitions, and Delete Audit Partitions. See the specific message request documentation for information about the required privileges for each message.
  • Audited data changes are stored in records of the audit entity.

Data that can be audited

The following list identifies the data and operations that can be audited:

  • Create, update, and delete operations on records.
  • Changes to the shared privileges of a record.
  • N:N association or disassociation of records.
  • Changes to security roles.
  • Audit changes at the entity, attribute, and organization level. For example, enabling audit on an entity.
  • Deletion of audit logs.
  • When (date/time) a user accesses Microsoft Dynamics CRM data, for how long, and from what client.

Enabling or disabling of field level security by setting the IsSecured attribute cannot be audited.

See Also

Reference

Audit (auditing) entity privileges
Privileges not associated with an entity

Concepts

Configure entities and attributes for auditing
Audit entity messages and methods

Other Resources

Manage your data
Audit entity data changes
Blog: Recover your deleted CRM data and recreate them using CRM API

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Configure entities and attributes for auditing

There are three levels where auditing can be configured: organization, entity, and attribute. The organization level is the highest level, followed by the entity level, and finally the attribute level. For attribute auditing to take place, auditing must be enabled at the attribute, entity, and organization levels. For entity auditing to take place, auditing must be enabled at the entity and organization levels.

There is a slight difference in how auditing is enabled or disable for an organization compared to an entity or attribute. You enable or disable auditing at the organization level by setting a particular attribute value of the organization record. However, for entities and attributes, you set a property value of the entity or attribute metadata.

A user must be assigned the System Administrator or System Customizer role to enable or disable auditing.

Enabling auditing

By setting the IsAuditEnabled property of an entity’s metadata and the IsAuditEnabled property of each desired attribute’s metadata to true, data changes to records of those entities can be logged by the platform. However, when enabling auditing on an entity, all of the entity’s attributes are enabled for auditing by default. Of course you can explicitly disable auditing on any or all of the attributes as needed. The IsAuditEnabled property can be set when entity or attribute metadata is created or updated through the following requests: CreateEntityRequest, UpdateEntityRequest, CreateAttributeRequest, UpdateAttributeRequest.

After changing the entity attribute metadata, you must publish the entity by using PublishXmlRequest. Changing the IsAuditEnabled property at the entity level does not require publishing. Typically, customization and publishing is performed by the same user. However, if these tasks are performed by different users, auditing will record the publish action, the user that initiated the publish operation, and not the update action.

In addition, auditing is enabled at the organization level by setting the IsAuditEnabled attribute value of the target organization record to true.

Disabling auditing

To disable auditing, just set IsAuditEnabled, as described previously, to false. Publish the entity customizations if you have disabled auditing on any attributes. You can disable auditing for a whole organization by setting the IsAuditEnabled attribute to false in the target organization’s record.

Entities that can be audited

All custom and most customizable entities can be audited. For a list of customizable entities, see Which entities are customizable?.

The following table lists the non-customizable entities that cannot be audited. This table was obtained by testing for a CanModifyAuditSettings attribute value of false on each entity’s metadata.

ActivityPointer

Annotation

BulkOperation

Calendar

CalendarRule

CustomerOpportunityRole

Discount

DiscountType

IncidentResolution

KbArticle

KbArticleComment

KbArticleTemplate

Notification

OpportunityClose

OrderClose

ProductPriceLevel

QuoteClose

RecurrenceRule

Resource

ResourceGroup

ResourceGroupExpansion

ResourceSpec

SalesLiteratureItem

SalesProcessInstance

Service

Subject

Template

UoM

UoMSchedule

Workflow

WorkflowLog

See Also

Concepts

Retrieve and delete the history of audited data changes

Other Resources

Manage your data
Audit entity data changes
Sample: Audit entity data changes
Audit entity data changes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Retrieve and delete the history of audited data changes

After auditing is enabled and data changes are made to those entities and attributes being audited, you can proceed to obtain the data change history. Optionally, you can delete the audit records after you review the change history. Follow the sample code link at the end of this topic for more information.

Retrieve the change history

There are several messages requests that can be used to retrieve the audit change history. These requests are differentiated by the nature of what they retrieve. Refer to the topic Audit entity messages and methods for a list of message requests related to auditing. Refer to the sample link at the end of this topic for sample code that demonstrates some of these change history message requests.

Delete audit records

You can delete audit records using the DeleteAuditDataRequest request. Audit data records are deleted sequentially from the oldest to the newest. The functionality of this request is slightly different based on the edition of Microsoft SQL Server being used by your Microsoft Dynamics CRM server. Microsoft Dynamics CRM Online uses an enterprise edition of SQL Server.

If your Microsoft Dynamics CRM server uses Microsoft SQL Server standard edition, which does not support the database partitioning feature, the DeleteAuditDataRequest request deletes all audit records created up to the end date specified in the EndDate property.

If your Microsoft Dynamics CRM server uses an Enterprise edition of Microsoft SQL Server that does support partitioning, the DeleteAuditDataRequest request will delete all audit data in those partitions where the end date is before the date specified in the EndDate property. Any empty partitions are also deleted. However, neither the current (active) partition nor the audit records in that active partition can be deleted by using this request or any other request.

New partitions are automatically created by the Microsoft Dynamics CRM platform on a quarterly basis each year. This functionality is non-configurable and cannot be changed. You can obtain the list of partitions using the RetrieveAuditPartitionListRequest request. If the end date of any partition is later than the current date, you cannot delete that partition or any audit records in it.

See Also

Concepts

Audit user access
Audit entity messages and methods

Other Resources

Manage your data
Audit entity data changes
Sample: Audit entity data changes
Audit entity data changes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Audit user access

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update support the ability to audit user access. The information that is recorded includes when the user started accessing Microsoft Dynamics CRM and if access originated from the Microsoft Dynamics CRM web application, CRM for Outlook, or SDK calls to the web services.

Enable user access auditing

Auditing of user access is enabled at the organization level. To enable or disable user access auditing, you must retrieve the target organization’s record, and update the Organization.IsUserAccessAuditEnabled attribute value for the organization. Global auditing on the organization must also be enabled by setting the Organization.IsAuditEnabled attribute to true in the organization record. To audit the origin of user access, for example: web application, CRM for Outlook or SDK, you must enable auditing on the entities being accessed.

The frequency of auditing user access can be read or set using the Organization.UserAccessAuditingInterval attribute. The default attribute value of 4 indicates user access is audited once every 4 hours.

For more information about enabling auditing for an organization and entity, see Configure entities and attributes for auditing.

Filter on user access events

To search for audit records that are related to user access, your code should retrieve Audit records of an organization and filter on the value in Audit.Action. An enumeration named AuditAction is provided to identify supported audit actions. The actions related to user access are shown in the following list.

  • AuditAction.UserAccessviaWeb
  • AuditAction.UserAccessviaWebServices
  • AuditAction.UserAccessAuditStarted
  • AuditAction.UserAccessAuditStopped

UserAccessviaWeb indicates access from the Microsoft Dynamics CRM web application or Microsoft Outlook. UserAccessviaWebServices indicates a web service request from the SDK. The AuditAction enumeration is available to your code when you include SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your application’s project.

See Also

Concepts

Configure entities and attributes for auditing
Audit entity messages and methods

Other Resources

Audit entity data changes
Sample: Audit entity data changes
Sample: Audit user access

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Audit entity messages and methods

The audit entity is used to store the history of data changes to a record or attribute. You should never directly create, update, or delete an instance of this entity. The schema name for this entity is Audit. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
DeleteAuditDataRequest | Deletes all partitions containing audit data created before a given end date.
RetrieveAttributeChangeHistoryRequest | Retrieves all changes to a specific attribute.
RetrieveAuditDetailsRequest | Retrieves the full audit details of a particular audit record. The record to retrieve is specified in the AuditId property.
RetrieveRequest | Retrieves an audit record. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of audit records. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveRecordChangeHistoryRequest | Retrieves all changes to a specific entity.

See Also

Reference

Audit (auditing) entity privileges

Other Resources

Manage your data
Audit entity data changes
Sample: Audit entity data changes
RetrieveAuditPartitionListRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Audit entity data changes
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. The sample can be found in the following location in the download package:

SampleCode\CS\DataManagement\Auditing\Program.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code. This sample requires the logged on user to have the System Administrator role.

Demonstrates

How to enable and disable auditing on an entity and its attributes, retrieve the data change history of the audited entity, and delete the audit records.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Collections.Generic;
using System.Linq;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;

// These namespaces are found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    public class Auditing
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        private Guid _newAccountId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the organization service. Next, auditing
        /// is enabled on the organization and an account entity. The account record
        /// is updated and the audit history printed out.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri, serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // Enable early-bound type support.
                _serviceProxy.EnableProxyTypes();

                // You can access the service through the proxy, but this sample uses the interface instead.
                _service = _serviceProxy;

                #region Enable Auditing for an Account
                Console.WriteLine("Enabling auditing on the organization and account entities.");

                // Enable auditing on the organization.
                // First, get the organization's ID from the system user record.
                Guid orgId = ((WhoAmIResponse)_service.Execute(new WhoAmIRequest())).OrganizationId;

                // Next, retrieve the organization's record.
                Organization org = _service.Retrieve(Organization.EntityLogicalName, orgId,
                    new ColumnSet(new string[] { "organizationid", "isauditenabled" })) as Organization;

                // Finally, enable auditing on the organization.
                bool organizationAuditingFlag = org.IsAuditEnabled.Value;
                org.IsAuditEnabled = true;
                _service.Update(org);

                // Enable auditing on account entities.
                bool accountAuditingFlag = EnableEntityAuditing(Account.EntityLogicalName, true);
                #endregion Enable Auditing for an Account

                CreateRequiredRecords();

                #region Retrieve the Record Change History
                Console.WriteLine("Retrieving the account change history.\n");
                // Retrieve the audit history for the account and display it.
                RetrieveRecordChangeHistoryRequest changeRequest = new RetrieveRecordChangeHistoryRequest();
                changeRequest.Target = new EntityReference(Account.EntityLogicalName, _newAccountId);

                RetrieveRecordChangeHistoryResponse changeResponse =
                    (RetrieveRecordChangeHistoryResponse)_service.Execute(changeRequest);

                AuditDetailCollection details = changeResponse.AuditDetailCollection;

                foreach (AttributeAuditDetail detail in details.AuditDetails)
                {
                    // Display some of the detail information in each audit record.
                    DisplayAuditDetails(detail);
                }
                #endregion Retrieve the Record Change History

                #region Retrieve the Attribute Change History

                // Update the Telephone1 attribute in the Account entity record.
                Account accountToUpdate = new Account();
                accountToUpdate.AccountId = _newAccountId;
                accountToUpdate.Telephone1 = "123-555-5555";
                _serviceProxy.Update(accountToUpdate);
                Console.WriteLine("Updated the Telephone1 field in the Account entity.");

                // Retrieve the attribute change history.
                Console.WriteLine("Retrieving the attribute change history for Telephone1.");

                var attributeChangeHistoryRequest = new RetrieveAttributeChangeHistoryRequest
                {
                    Target = new EntityReference(
                        Account.EntityLogicalName, _newAccountId),
                    AttributeLogicalName = "telephone1"
                };

                var attributeChangeHistoryResponse =
                    (RetrieveAttributeChangeHistoryResponse)_service.Execute(attributeChangeHistoryRequest);

                // Display the attribute change history.
                details = attributeChangeHistoryResponse.AuditDetailCollection;

                foreach (var detail in details.AuditDetails)
                {
                    DisplayAuditDetails(detail);
                }

                // Save an Audit record ID for later use.
                Guid auditSampleId = details.AuditDetails.First().AuditRecord.Id;
                #endregion Retrieve the Attribute Change History

                #region Retrieve the Audit Details
                Console.WriteLine("Retrieving audit details for an audit record.");

                // Retrieve the audit details and display them.
                var auditDetailsRequest = new RetrieveAuditDetailsRequest
                {
                    AuditId = auditSampleId
                };

                var auditDetailsResponse =
                    (RetrieveAuditDetailsResponse)_service.Execute(auditDetailsRequest);
                DisplayAuditDetails(auditDetailsResponse.AuditDetail);

                #endregion Retrieve the Audit Details

                #region Revert Auditing
                // Set the organization and account auditing flags back to the old values
                org.IsAuditEnabled = organizationAuditingFlag;
                _service.Update(org);

                EnableEntityAuditing(Account.EntityLogicalName, accountAuditingFlag);

                #endregion Revert Auditing

                DeleteRequiredRecords(promptforDelete);
            }
        }

        #endregion How To Sample Code

        #region Class methods
        /// <summary>
        /// Displays audit change history details on the console.
        /// </summary>
        /// <param name="detail"></param>
        private static void DisplayAuditDetails(AuditDetail detail)
        {
            // Write out some of the change history information in the audit record.
            Audit record = (Audit)detail.AuditRecord;

            Console.WriteLine("\nAudit record created on: {0}", record.CreatedOn.Value.ToLocalTime());
            Console.WriteLine("Entity: {0}, Action: {1}, Operation: {2}",
                record.ObjectId.LogicalName, record.FormattedValues["action"],
                record.FormattedValues["operation"]);

            // Show additional details for certain AuditDetail sub-types.
            var detailType = detail.GetType();
            if (detailType == typeof(AttributeAuditDetail))
            {
                var attributeDetail = (AttributeAuditDetail)detail;

                // Display the old and new attribute values.
                foreach (KeyValuePair<String, object> attribute in attributeDetail.NewValue.Attributes)
                {
                    String oldValue = "(no value)", newValue = "(no value)";

                    //TODO Display the lookup values of those attributes that do not contain strings.
                    if (attributeDetail.OldValue.Contains(attribute.Key))
                        oldValue = attributeDetail.OldValue[attribute.Key].ToString();

                    newValue = attributeDetail.NewValue[attribute.Key].ToString();

                    Console.WriteLine("Attribute: {0}, old value: {1}, new value: {2}",
                        attribute.Key, oldValue, newValue);
                }

                foreach (KeyValuePair<String, object> attribute in attributeDetail.OldValue.Attributes)
                {
                    if (!attributeDetail.NewValue.Contains(attribute.Key))
                    {
                        String newValue = "(no value)";

                        //TODO Display the lookup values of those attributes that do not contain strings.
                        String oldValue = attributeDetail.OldValue[attribute.Key].ToString();

                        Console.WriteLine("Attribute: {0}, old value: {1}, new value: {2}",
                            attribute.Key, oldValue, newValue);
                    }
                }
            }
            Console.WriteLine();
        }

        /// <summary>
        /// Enable auditing on an entity.
        /// </summary>
        /// <param name="entityLogicalName">The logical name of the entity.</param>
        /// <param name="flag">True to enable auditing, otherwise false.</param>
        /// <returns>The previous value of the IsAuditEnabled attribute.</returns>
        private bool EnableEntityAuditing(string entityLogicalName, bool flag)
        {
            // Retrieve the entity metadata.
            RetrieveEntityRequest entityRequest = new RetrieveEntityRequest
            {
                LogicalName = entityLogicalName,
                EntityFilters = EntityFilters.Attributes
            };

            RetrieveEntityResponse entityResponse =
                (RetrieveEntityResponse)_service.Execute(entityRequest);

            // Enable auditing on the entity. By default, this also enables auditing
            // on all the entity's attributes.
            EntityMetadata entityMetadata = entityResponse.EntityMetadata;

            bool oldValue = entityMetadata.IsAuditEnabled.Value;
            entityMetadata.IsAuditEnabled = new BooleanManagedProperty(flag);

            UpdateEntityRequest updateEntityRequest = new UpdateEntityRequest { Entity = entityMetadata };

            UpdateEntityResponse updateEntityResponse =
                (UpdateEntityResponse)_service.Execute(updateEntityRequest);

            return oldValue;
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            Console.Write("Creating an account, ");

            // Account entity category codes.
            var Categories = new { PreferredCustomer = 1, Standard = 2 };

            // Create a new account entity.
            Account newAccount = new Account { Name = "Example Account" };
            _newAccountId = _service.Create(newAccount);

            Console.WriteLine("then updating the account.");

            // Set the values of some other attributes.
            newAccount.AccountId = _newAccountId;
            newAccount.AccountNumber = "1-A";
            newAccount.AccountCategoryCode = new OptionSetValue(Categories.PreferredCustomer);
            newAccount.Telephone1 = "555-555-5555";

            _service.Update(newAccount);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want to delete the account record? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _service.Delete(Account.EntityLogicalName, _newAccountId);
                Console.WriteLine("The account record has been deleted.");
            }

            if (prompt)
            {
                Console.WriteLine("\nDo you want to delete ALL audit records? (y/n) [n]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                // Get the list of audit partitions.
                RetrieveAuditPartitionListResponse partitionRequest =
                    (RetrieveAuditPartitionListResponse)_service.Execute(new RetrieveAuditPartitionListRequest());
                AuditPartitionDetailCollection partitions = partitionRequest.AuditPartitionDetailCollection;

                // Create a delete request with an end date earlier than possible.
                DeleteAuditDataRequest deleteRequest = new DeleteAuditDataRequest();
                deleteRequest.EndDate = new DateTime(2000, 1, 1);

                // Check if partitions are not supported as is the case with SQL Server Standard edition.
                if (partitions.IsLogicalCollection)
                {
                    // Delete all audit records created up until now.
                    deleteRequest.EndDate = DateTime.Now;
                }

                // Otherwise, delete all partitions that are older than the current partition.
                // Hint: The partitions in the collection are returned in sorted order where the
                // partition with the oldest end date is at index 0.
                else
                {
                    for (int n = partitions.Count - 1; n >= 0; --n)
                    {
                        if (partitions[n].EndDate <= DateTime.Now && partitions[n].EndDate > deleteRequest.EndDate)
                        {
                            deleteRequest.EndDate = (DateTime)partitions[n].EndDate;
                            break;
                        }
                    }
                }

                // Delete the audit records.
                if (deleteRequest.EndDate != new DateTime(2000, 1, 1))
                {
                    _service.Execute(deleteRequest);
                    Console.WriteLine("Audit records have been deleted.");
                }
                else
                    Console.WriteLine("There were no audit records that could be deleted.");
            }
        }
        #endregion Class methods

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                Auditing app = new Auditing();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Audit entity messages and methods

Other Resources

Audit entity data changes
Sample: Audit user access
IsAuditEnabled
IsAuditEnabled
RetrieveRecordChangeHistoryRequest
AttributeAuditDetail
RetrieveAuditPartitionListRequest
DeleteAuditDataRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Audit user access
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DataManagement\Auditing\UserAccessAuditing.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code. This sample requires the logged on user to have the System Administrator role for enabling auditing on an organization.

Demonstrates

This sample demonstrates how to audit user access to Microsoft Dynamics CRM.

Example

The sample first enables user access auditing with the logged on user’s organization. Next, it creates and modifies an account entity so that audit records are generated. Finally, the sample displays the audited information.

C# Copy Code
using System;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    public class UserAccessAuditing
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;

        private Guid _newAccountId;
        private Guid _systemUserId;
        private static DateTime _sampleStartTime;

        #endregion

        #region How To Sample Code

        /// <summary>
        /// This sample demonstrates how to audit user access to Microsoft Dynamics CRM.
        /// The sample first enables user access auditing on an organization. Next, it
        /// creates and modifies an entity. Finally, the sample displays a report of the
        /// audited information.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            _sampleStartTime = DateTime.Now;
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();

                #region Enable Auditing

                // Enable auditing on the organization and for user access by editing the
                // organization's settings.
                // First, get the organization's ID from the system user record.
                var whoAmIReq = new WhoAmIRequest();
                var whoAmIRes = (WhoAmIResponse)_serviceProxy.Execute(whoAmIReq);
                Guid orgId = whoAmIRes.OrganizationId;
                _systemUserId = whoAmIRes.UserId;

                // Next, retrieve the organization's record.
                var org = (Organization)_serviceProxy.Retrieve(
                    Organization.EntityLogicalName, orgId,
                    new ColumnSet("organizationid", "isauditenabled", "isuseraccessauditenabled", "useraccessauditinginterval"));

                // Finally, enable auditing on the organization, including auditing for
                // user access.
                bool organizationAuditingFlag = org.IsAuditEnabled.Value;
                bool userAccessAuditingFlag = org.IsUserAccessAuditEnabled.Value;
                if (!organizationAuditingFlag || !userAccessAuditingFlag)
                {
                    org.IsAuditEnabled = true;
                    org.IsUserAccessAuditEnabled = true;
                    _serviceProxy.Update(org);
                    Console.WriteLine("Enabled auditing for the organization and for user access.");
                    Console.WriteLine("Auditing interval is set to {0} hours.", org.UserAccessAuditingInterval);
                }
                else
                {
                    Console.WriteLine("Auditing was enabled before the sample began, so no auditing settings were changed.");
                }

                // Enable auditing on the account entity, since no audits will be created
                // when we create/update an account entity, otherwise.
                var oldAccountAuditing = EnableEntityAuditing(Account.EntityLogicalName, true);

                #endregion Enable Auditing

                #region Make Audited Service Calls

                CreateRequiredRecords();

                // Make an update request to the Account entity to be tracked by auditing.
                var newAccount = new Account();
                newAccount.AccountId = _newAccountId;
                newAccount.AccountNumber = "1-A";
                newAccount.AccountCategoryCode = new OptionSetValue(
                    (int)AccountAccountCategoryCode.PreferredCustomer);
                newAccount.Telephone1 = "555-555-5555";

                _serviceProxy.Update(newAccount);

                Console.WriteLine("Created an account and made updates which should be captured by auditing.");

                #endregion Make Audited Service Calls

                #region Revert auditing

                // Set the organization and account auditing flags back to the old values
                if (!organizationAuditingFlag || !userAccessAuditingFlag)
                {
                    // Only revert them if they were actually changed to begin with.
                    org.IsAuditEnabled = organizationAuditingFlag;
                    org.IsUserAccessAuditEnabled = userAccessAuditingFlag;
                    _serviceProxy.Update(org);
                    Console.WriteLine("Reverted organization and user access auditing to their previous values.");
                }
                else
                {
                    Console.WriteLine("Auditing was enabled before the sample began, so no auditing settings were reverted.");
                }

                // Revert the account entity auditing.
                EnableEntityAuditing(Account.EntityLogicalName, oldAccountAuditing);

                #endregion Revert auditing

                #region Show Audited Records

                // Select all columns for convenience.
                var query = new QueryExpression(Audit.EntityLogicalName)
                {
                    ColumnSet = new ColumnSet(true),
                    Criteria = new FilterExpression(LogicalOperator.And)
                };

                // Only retrieve audit records that track user access.
                query.Criteria.AddCondition("action", ConditionOperator.In,
                    (int)AuditAction.UserAccessAuditStarted,
                    (int)AuditAction.UserAccessAuditStopped,
                    (int)AuditAction.UserAccessviaWebServices,
                    (int)AuditAction.UserAccessviaWeb);

                // Change this to false in order to retrieve audit records for all users
                // when running the sample.
                var filterAuditsRetrievedByUser = true;
                if (filterAuditsRetrievedByUser)
                {
                    // Only retrieve audit records for the current user or the "SYSTEM"
                    // user.
                    var userFilter = new FilterExpression(LogicalOperator.Or);
                    userFilter.AddCondition(
                        "userid", ConditionOperator.Equal, _systemUserId);
                    userFilter.AddCondition(
                        "useridname", ConditionOperator.Equal, "SYSTEM");
                }
                // Only retrieve records for this sample run, so that we don't get too
                // many results if auditing was enabled previously.
                query.Criteria.AddCondition(
                    "createdon", ConditionOperator.GreaterEqual, _sampleStartTime);

                var results = _serviceProxy.RetrieveMultiple(query);
                Console.WriteLine("Retrieved audit records:");
                foreach (Audit audit in results.Entities)
                {
                    Console.Write("\r\n  Action: {0},  User: {1},"
                        + "\r\n    Created On: {2}, Operation: {3}",
                        (AuditAction)audit.Action.Value,
                        audit.UserId.Name,
                        audit.CreatedOn.Value.ToLocalTime(),
                        (AuditOperation)audit.Operation.Value);

                    // Display the name of the related object (which will be the user
                    // for audit records with Action UserAccessviaWebServices.
                    if (!String.IsNullOrEmpty(audit.ObjectId.Name))
                    {
                        Console.WriteLine(
                            ",\r\n    Related Record: {0}", audit.ObjectId.Name);
                    }
                    else
                    {
                        Console.WriteLine();
                    }
                }

                #endregion Show Audited Records

                DeleteRequiredRecords(promptforDelete);
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a new account entity.
            Account newAccount = new Account { Name = "Example Account" };
            _newAccountId = _serviceProxy.Create(newAccount);
        }

        private bool EnableEntityAuditing(String entityLogicalName, bool flag)
        {
            // Retrieve the entity metadata.
            RetrieveEntityRequest entityRequest = new RetrieveEntityRequest
            {
                LogicalName = entityLogicalName,
                EntityFilters = EntityFilters.Attributes
            };

            RetrieveEntityResponse entityResponse =
                (RetrieveEntityResponse)_serviceProxy.Execute(entityRequest);

            // Enable auditing on the entity. By default, this also enables auditing
            // on all the entity's attributes.
            EntityMetadata entityMetadata = entityResponse.EntityMetadata;

            bool oldValue = entityMetadata.IsAuditEnabled.Value;
            entityMetadata.IsAuditEnabled = new BooleanManagedProperty(flag);

            UpdateEntityRequest updateEntityRequest = new UpdateEntityRequest { Entity = entityMetadata };

            UpdateEntityResponse updateEntityResponse =
                (UpdateEntityResponse)_serviceProxy.Execute(updateEntityRequest);

            return oldValue;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want to delete the account record? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Account.EntityLogicalName, _newAccountId);
                Console.WriteLine("The account record has been deleted.");
            }

            if (prompt)
            {
                Console.WriteLine("\nDo you want to delete ALL audit records? (y/n) [n]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                // Get the list of audit partitions.
                RetrieveAuditPartitionListResponse partitionRequest =
                    (RetrieveAuditPartitionListResponse)_serviceProxy.Execute(new RetrieveAuditPartitionListRequest());
                AuditPartitionDetailCollection partitions = partitionRequest.AuditPartitionDetailCollection;

                // Create a delete request with an end date earlier than possible.
                DeleteAuditDataRequest deleteRequest = new DeleteAuditDataRequest();
                deleteRequest.EndDate = new DateTime(2000, 1, 1);

                // Check if partitions are not supported as is the case with SQL Server Standard edition.
                if (partitions.IsLogicalCollection)
                {
                    // Delete all audit records created up until now.
                    deleteRequest.EndDate = DateTime.Now;
                }

                // Otherwise, delete all partitions that are older than the current partition.
                // Hint: The partitions in the collection are returned in sorted order where the
                // partition with the oldest end date is at index 0.  Also, if the partition's
                // end date is greater than the current date, neither the partition nor any
                // audit records contained in the partition can be deleted.
                else
                {
                    for (int n = partitions.Count - 1; n >= 0; --n)
                    {
                        if (partitions[n].EndDate <= DateTime.Now && partitions[n].EndDate > deleteRequest.EndDate)
                        {
                            deleteRequest.EndDate = (DateTime)partitions[n].EndDate;
                            break;
                        }
                    }
                }

                // Delete the audit records.
                if (deleteRequest.EndDate != new DateTime(2000, 1, 1))
                {
                    _serviceProxy.Execute(deleteRequest);
                    Console.WriteLine("Audit records have been deleted.");
                }
                else
                    Console.WriteLine("There were no audit records that could be deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new UserAccessAuditing();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Audit entity messages and methods

Other Resources

Audit entity data changes

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Detect duplicate data

Duplicate detection lets organizations set duplicate detection policies and create duplicate detection rules for business and custom entities. These rules can be applied across different record types in Microsoft Dynamics CRM. For example, an organization may define that a lead is a duplicate of a contact, if they have the same name and phone number. Based on the duplicate detection rules set by the administrator, the system alerts the user about potential duplicates when the user tries to create new records or update existing records. To maintain data quality, you can schedule a duplicate detection job to check for duplicates for all records that match a certain criteria. You can clean the data by deleting, deactivating, or merging the duplicates reported by a duplicate detection job.

To detect duplicates in the system, create a duplicate detection rule for a specific entity type. A duplicate detection rule is represented by the duplicate rule (DuplicateRule) entity. You can create multiple detection rules for the same entity type. However, you can publish a maximum of five duplicate detection rules per entity type at one time.

A rule can have one or more duplicate detection rule conditions that are represented by the duplicate rule condition (DuplicateRuleCondition) entity. The conditions are combined by the system as in logical AND operation. A duplicate detection rule specifies a base entity type and a matching entity type. A duplicate rule condition specifies the name of a base attribute and the name of a matching attribute. For example, specify an account as a base entity and a contact as a matching entity to compare last names and addresses. The matching criteria consist of operators such as exactly match, first n-number of characters, or last n-number of characters.

To create duplicate detection rules and duplicate detection rule conditions in the Microsoft Dynamics CRM database, use the IOrganizationService.Create method or the CreateRequest message.

Important
Take special precautions when you create duplicate detection rules for appointments. The recurring appointment master and the recurring appointment records share some of the same attribute values, such as subject, location, and regarding object. Using any of these attributes as a duplicate detection rule condition (DuplicateRuleCondition), may result in incorrectly marking recurring appointment records as duplicates. To avoid this, also include a start time attribute as a duplicate detection rule condition. For more information about working with recurring appointments, see Schedule and appointment entities.

The duplicate detection rules are system-wide. You must publish them before running a duplicate detection job to detect duplicates for bulk data or retrieve duplicates for a particular entity record. To publish a duplicate detection rule, use the PublishDuplicateRuleRequest message. Duplicate rule publishing is an asynchronous operation that runs in the background.

In This Section

Enable duplicate detection

Run duplicate detection

Duplicate detection messages

Ignore blank values and inactive records in duplicate detection

Disable duplicate detection

DuplicateRule entity messages and methods

DuplicateRuleCondition entity messages and methods

DuplicateRecord entity messages and methods

Sample: Enable duplicate detection and retrieve duplicates

Sample: Invoke duplicate detection for creating and updating records

Sample: Detect multiple duplicate records

Related Sections

Manage your data

Delete data in bulk

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Enable duplicate detection

Before running duplicate detection, enable it for each of the following:

  • Globally (for all entities in the organization).
  • For an entity.
  • For specific operations.
Note
You must enable duplicate detection in all three areas to detect duplicates for an entity and for operations on an entity.

Enable duplicate detection globally

  • Use the UpdateRequest message to set the Organization.IsDuplicateDetectionEnabled attribute to true.

Enable duplicate detection for an entity

  • Use the UpdateRequest message to set the IsDuplicateDetectionEnabled property to true.

Enable duplicate detection for specific operations

  • Set the following attributes to true:

    • Organization.IsDuplicateDetectionEnabledForOnlineCreateUpdate. Create and update records in Microsoft Dynamics CRM by using the Web application or Microsoft Dynamics CRM for Microsoft Office Outlook. This attribute enables or disables duplicate detection for records created or updated with the CreateRequest and UpdateRequest messages. However, it does not affect records created or updated with the IOrganizationService.Create and IOrganizationService.Update methods.
    • Organization.IsDuplicateDetectionEnabledForOfflineSync. Synchronize offline records when Microsoft Dynamics CRM for Microsoft Office Outlook goes from offline to online.
    • Organization.IsDuplicateDetectionEnabledForImport. Import bulk data.

    Note
    You do not have to publish the duplicate detection rules to enable duplicate detection for these operations. However, you must publish the duplicate detection rules before you perform the operations.

See Also

Concepts

Run duplicate detection
Enable duplicate detection

Other Resources

Detect duplicate data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Run duplicate detection

There are several ways to perform duplicate detection after you enable it and publish the duplicate detection rules.

Action Description

Detect duplicates for a specified record

Use the RetrieveDuplicatesRequest message. For example, you can use this message to find all the contacts that are duplicates of a particular account record.

Detect duplicates for an entity type

Use the BulkDetectDuplicatesRequest message. This message submits an asynchronous duplicate detection job that runs in the background. The BulkDetectDuplicates message is used to find the duplicate records for a specified entity type based on the query expression passed in this message request. The duplicates are detected according to the published duplicate rules for the entity type. The detected duplicates are stored as duplicate record (DuplicateRecord) records in Microsoft Dynamics CRM. You can retrieve duplicate records by using the Retrieve method or the RetrieveMultiple method.

A maximum of 5000 duplicates are returned by the duplicate detection job.

Detect duplicates during Create and Update operations

Pass the duplicate detection optional parameter SuppressDuplicateDetection by adding a value to the Parameters property of the CreateRequest and UpdateRequest message requests. The SuppressDuplicateDetection parameter value determines whether the Create or Update operation can be completed:

  • true – Create or update the record, if a duplicate is found.
  • false - Do not create or update the record, if a duplicate is found.
Note
Passing of the CalculateMatchCodeSynchronously optional parameter is not required. The match codes used to detect duplicates are calculated synchronously regardless of the value passed in this parameter.

Note
If the duplicate detection optional parameter is set to false and a duplicate is found, an exception is thrown and the record is not created or updated.

The following example shows how to pass the duplicate detection option as a part of the CreateRequest and UpdateRequest message requests:

C# Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    _service = (IOrganizationService)_serviceProxy;

    CreateRequiredRecords();

    // Create and account record with the named Proseware, Inc. and already existing Account Number.
    Account account = new Account
    {
        Name = "Proseware, Inc.",
        AccountNumber = "ACC005"
    };

    // Create operation by suppressing duplicate detection
    CreateRequest reqCreate = new CreateRequest();
    reqCreate.Target = account;
    reqCreate.Parameters.Add("SuppressDuplicateDetection", true); // Change to false to activate the duplicate detection.
    CreateResponse createResponse = (CreateResponse)_service.Execute(reqCreate);
    _dupAccountId = createResponse.id;
    Console.Write("Account: {0} {1} created with SuppressDuplicateDetection to true, ",
        account.Name, account.AccountNumber);

    // Retrieve the account containing with its few attributes.
    ColumnSet cols = new ColumnSet(
        new String[] { "name", "accountnumber"});

    Account retrievedAccount = (Account)_service.Retrieve("account", _dupAccountId, cols);
    Console.Write("retrieved, ");

    // Update the existing account with new account number.
    retrievedAccount.AccountNumber = "ACC006";

    // Update operation – update record, if a duplicate is not found.
    UpdateRequest reqUpdate = new UpdateRequest();
    reqUpdate.Target = retrievedAccount;
    reqUpdate["SuppressDuplicateDetection"] = false; // Duplicate detection is activated.

    // Update the account record.
    UpdateResponse updateResponse = (UpdateResponse)_service.Execute(reqUpdate);
    Console.WriteLine("and updated.");

    DeleteRequiredRecords(promptforDelete);
}

See Also

Concepts

Enable duplicate detection
Use messages (request and response classes) with the Execute method
Duplicate detection messages

Other Resources

Detect duplicate data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Duplicate detection messages

Use the messages listed in the following table to detect duplicates in Microsoft Dynamics CRM.

Message Description

BulkDetectDuplicatesRequest

Detects duplicates for a specified entity type based on query criteria and store them as instances of a duplicate record entity type in the Microsoft Dynamics CRM database.

The query expression that describes the records on which to run the duplicate detection job is specified in the Query property of this request.

RetrieveDuplicatesRequest

Detects and retrieves duplicates for a specified record.

The matching entity type is specified in the MatchingEntityName property of this request.

See Also

Concepts

Run duplicate detection
Ignore blank values and inactive records in duplicate detection

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Ignore blank values and inactive records in duplicate detection

You can improve data results by creating duplicate detection rules that ignore blank values and inactive records. This will help to refine your results and reduce the amount of erroneous data.

Rules for Ignoring Blank Values and Inactive Records

A duplicate detection rule can have more than one rule condition. For example, you can specify that an account is a duplicate of another record if both of the following conditions are satisfied:

  • Account names match in both records.
  • Email IDs match in both records.

However, with this rule, the system flags any two records as duplicates if the account names match and the email IDs are null values. In another example, two records are flagged as duplicates if their email IDs and status match. In this case, all active, and inactive, records that have email IDs equal to null are flagged as duplicates. This may flood a system with a large number of unintended duplicate records. To avoid flagging inactive records and records with null values as duplicates, two new attributes were added, IgnoreBlankValues and ExcludeInactiveRecords.

The following table describes the new attributes.

Entity Attribute Type Description

DuplicateRuleCondition

IgnoreBlankValues

Boolean

Specifies whether to consider blank values as non-duplicate values. The default value of this attribute is false. Set it to true if you do not want the duplicate detection rule to consider null) values as equal. When you upgrade from earlier versions of Microsoft Dynamics CRM, this attribute is set to false.

Important
For a duplicate detection rule with one condition, if you set the attribute value to false, it is treated by the system as a true value.

DuplicateRule

ExcludeInactiveRecords

Boolean

Specifies whether to flag inactive records as duplicates. The default value is false. Set it to true if you do not want inactive records to be flagged as duplicates, even if they meet duplication detection rule criteria. When you upgrade from earlier versions of Microsoft Dynamics CRM, this attribute is set to false.

There are entities that have states other than Active and Inactive. If you set the ExcludeInactiveRecords attribute to true, the duplicate detection process will consider matching records only in the Active states or in states that are considered Active.

The following table lists the entity records and the corresponding states.

Entity Record | Considered as Active State | Considered as Inactive State
Appointment | Open, Scheduled | Completed, Canceled
CampaignActivity | Open | Closed, Canceled
CampaignResponse | Open | Completed, Canceled
Contract | Draft, Invoiced, On Hold | Canceled, Expired
ContractDetail | Existing, Renewed | Canceled, Expired
Email | Open | Completed, Canceled
Fax | Open | Completed, Canceled
Incident | Active | Resolved, Canceled, Closed
Invoice | Active | Closed, Paid, Canceled
KbArticle | Draft, Unapproved, Published | N/A
Lead | Open | Qualified, Disqualified
Letter | Open | Completed, Canceled
Opportunity | Open | Won, Lost
PhoneCall | Open | Completed, Canceled
Quote | Draft, Active | Won, Closed
SalesOrder | Active, Submitted, Invoiced | Canceled, Fulfilled
ServiceAppointment | Open, Scheduled | Closed, Canceled
Task | Open | Completed, Canceled

For example, if you set the ExcludeInactiveRecords attribute to true, only active, submitted, and invoiced sales orders will be considered for matching during duplicate detection.

See Also

Concepts

Disable duplicate detection

Other Resources

Detect duplicate data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Disable duplicate detection

Disable duplicate detection globally or for an entity type by unpublishing the duplicate detection rules or by deleting the published rules.

Disable duplicate detection globally

To disable duplicate detection globally, use the UpdateRequest message to set the Organization.IsDuplicateDetectionEnabled attribute to false. This automatically unpublishes all duplicate detection rules for all entity types in the organization.

Disable duplicate detection for an entity

To disable duplicate detection for an entity type, do one of the following:

  • Use the UpdateEntityRequest message to set the IsDuplicateDetectionEnabled property to false. This automatically unpublishes all duplicate detection rules for an entity type. This removes duplicate detection support for the entity type and you cannot create a new duplicate detection rule for this entity type.
  • Unpublish all duplicate detection rules for an entity type by using the UnpublishDuplicateRuleRequest message.

Delete published duplicate detection rules

Delete all published rules in the system to disable duplicate detection globally, or delete published rules for specific entity types by using the IOrganizationService.Delete method.

See Also

Concepts

Enable duplicate detection
DuplicateRule entity messages and methods

Other Resources

Detect duplicate data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DuplicateRule entity messages and methods

A duplicate rule is a rule based on which duplicate records are detected for a specified entity type. The schema name for this entity is DuplicateRule. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a duplicate rule to another user or team.
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the duplicate rule entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CompoundCreateRequest | Deprecated. Use the CreateRequest class. Creates a duplicate rule and its related duplicate rule conditions.
CompoundUpdateDuplicateDetectionRuleRequest | Updates a duplicate rule and its related duplicate rule conditions.
CreateRequest | Creates a duplicate rule. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a duplicate rule. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService. Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, refer to the duplicate rule entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
GrantAccessRequest | Shares a duplicate rule with another security principal (user or team).
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
ModifyAccessRequest | Changes the access rights for a duplicate rule previously shared with another security principal (user or team).
PublishDuplicateRuleRequest | Publishes the duplicate rule.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a duplicate rule. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of duplicate rules. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a duplicate rule.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a duplicate rule, and their access rights to the duplicate rule.
RevokeAccessRequest | Revokes the access rights for a duplicate rule for the specified security principal (user or team).
UnpublishDuplicateRuleRequest | Unpublishes a duplicate rule.
UpdateRequest | Updates a duplicate rule. You can also call the IOrganizationService.Update method.

See Also

Concepts

DuplicateRule (duplicate detection rule) entity privileges
DuplicateRuleCondition entity messages and methods

Other Resources

Detect duplicate data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DuplicateRuleCondition entity messages and methods

A duplicate rule condition represents matching criteria in the duplicate detection rule that is used to detect duplicate records in the system.

The schema name for this entity is DuplicateRuleCondition. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a duplicate rule condition. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a duplicate rule condition. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a duplicate rule condition. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of duplicate rule conditions. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a duplicate rule condition. You can also call the IOrganizationService.Update method.
Important
Prevent validation errors:

  1. If you set the OperatorCode attribute to ExactMatch, do not set the OperatorParam attribute to any value.
  2. Do not set the OperatorParam to zero during Create or Update operations.

See Also

Concepts

DuplicateRuleCondition entity privileges
DuplicateRecord entity messages and methods

Other Resources

Detect duplicate data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DuplicateRecord entity messages and methods

A duplicate record contains the information about a duplicate detected by the duplicate detection job.

The schema name for this entity is DuplicateRecord. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves a duplicate record. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of duplicate records. You can also call the IOrganizationService.RetrieveMultiple method.
Important
If the caller (system user) of the RetrieveRequest message or the RetrieveMultipleRequest message does not have Read privileges on some of the fields in the detected duplicate records, these records are not returned.

See Also

Concepts

DuplicateRecord entity privileges

Other Resources

Detect duplicate data
Sample: Enable duplicate detection and retrieve duplicates

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Enable duplicate detection and retrieve duplicates
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DataManagement\DuplicateDetection\EnableDuplicateDetectionAndRetrieveDuplicates.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to enable duplicate detection and retrieve duplicate records.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to enable duplicate detection and retrieve duplicate
    /// records based on the active duplicate detection rule(s).
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.
    /// </remarks>
    public class EnableDuplicateDetectionAndRetrieveDuplicates
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private Guid? _accountId1;
        private Guid? _accountId2;
        #endregion

        #region How To Sample Code

        /// <summary>
        /// Enables dupe detection and retrieves duplicates.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig,bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();
                EnableDuplicateDetectionForOrg();
                EnableDuplicateDetectionForEntity(Account.EntityLogicalName);
                PublishRulesForEntity(Account.EntityLogicalName);
                CreateAccountRecords();
                RetrieveDuplicates();
                DeleteRequiredRecords(promptforDelete);
            }
        }

        /// <summary>
        /// Create some account records to retrieve duplicates
        /// </summary>
        private void CreateAccountRecords()
        {
            var crmAccount = new Account { Name="Microsoft"};

            _accountId1 = _serviceProxy.Create(crmAccount);
            _accountId2 = _serviceProxy.Create(crmAccount);
            Console.WriteLine(String.Concat("Creating duplicate records:\n\taccount 1 - ",
                _accountId1.Value, "\n\taccount 2 - ", _accountId2.Value));
        }

        /// <summary>
        /// Call the method to retrieve duplicate records.
        /// </summary>
        private void RetrieveDuplicates()
        {
            // PagingInfo is Required.
            var request = new RetrieveDuplicatesRequest
            {
                BusinessEntity = new Account { Name = "Microsoft" }.ToEntity<Entity>(),
                MatchingEntityName = Account.EntityLogicalName,
                PagingInfo = new PagingInfo() { PageNumber = 1, Count = 50 }
            };

            Console.WriteLine("Retrieving duplicates");
            var response =(RetrieveDuplicatesResponse)_serviceProxy.Execute(request);

            for (int i = 0; i < response.DuplicateCollection.Entities.Count; i++)
            {
                var crmAccount = response.DuplicateCollection.Entities[i]
                    .ToEntity<Account>();
                Console.WriteLine(crmAccount.Name + ", " + crmAccount.AccountId.Value.ToString());
            }
        }

        /// <summary>
        /// Enables duplicate detection for the organization
        /// </summary>
        private void EnableDuplicateDetectionForOrg()
        {
            // Retrieve the org ID
            var orgId = RetrieveOrganizationId();
            if (!orgId.HasValue)
                return;

            Console.WriteLine(String.Concat("Enabling duplicate detection for organization: ",
                orgId.Value));

            // Enable dupe detection for each type
            var crmOrganization = new Organization
            {
                Id = orgId.Value,
                IsDuplicateDetectionEnabled = true,
                IsDuplicateDetectionEnabledForImport = true,
                IsDuplicateDetectionEnabledForOfflineSync = true,
                IsDuplicateDetectionEnabledForOnlineCreateUpdate = true,
            };

            _serviceProxy.Update(crmOrganization);
        }

        /// <summary>
        /// Enabling the dupe detection unpublishes the rules.
        /// This will publish them, and wait for them to complete publishing.
        /// </summary>
        /// <param name="entityName"></param>
        private void PublishRulesForEntity(string entityName)
        {
            // Retrieve all rules for the entity
            var rules = _serviceProxy.RetrieveMultiple(
                new QueryByAttribute(DuplicateRule.EntityLogicalName)
            {
                ColumnSet = new ColumnSet("duplicateruleid"),
                Attributes = { "matchingentityname" },
                Values = { entityName }
            });

            List<Guid> crmAsyncOperationIds = new List<Guid>();
            foreach (var item in rules.Entities)
            {
                Console.WriteLine(String.Concat("Publishing duplicate rule: ", item.Id));

                // Publish each rule and get the job id since it is async
                var response = (PublishDuplicateRuleResponse)_serviceProxy.Execute(
                        new PublishDuplicateRuleRequest { DuplicateRuleId = item.Id });

                crmAsyncOperationIds.Add(response.JobId);
            }

            // Wait until all the rules are published before testing the dupe detection
            WaitForAsyncJobCompletion(crmAsyncOperationIds);
        }

        /// <summary>
        /// Updates the entity customizations and publishes the entity
        /// </summary>
        /// <param name="entityName"></param>
        private void EnableDuplicateDetectionForEntity(string entityName)
        {
            Console.WriteLine(String.Format("Retrieving entity metadata for {0}",
                entityName));

            // Retrieve the entity metadata
            var crmEntity = ((RetrieveEntityResponse)_serviceProxy.Execute(
                new RetrieveEntityRequest
                {
                    RetrieveAsIfPublished = true,
                    LogicalName = entityName
                })).EntityMetadata;

            Console.WriteLine(String.Concat("Enabling duplicate for ", entityName));

            // Update the duplicate detection flag
            crmEntity.IsDuplicateDetectionEnabled =
                new BooleanManagedProperty(true);

            // Update the entity metadata
            _serviceProxy.Execute(new UpdateEntityRequest
            {
                Entity = crmEntity
            });

            Console.WriteLine(String.Concat("Publishing ", entityName, " entity"));

            // Publish the entity
            var publishRequest = new PublishXmlRequest
            {
                ParameterXml = String.Concat("<importexportxml><entities><entity>",
                    entityName, "</entity></entities></importexportxml>"),
            };

            _serviceProxy.Execute(publishRequest);
        }

        /// <summary>
        /// There should only be one organization record per Crm Org
        /// </summary>
        /// <returns></returns>
        private Guid? RetrieveOrganizationId()
        {
            // Retrieve the first record in the organization table.
            // There should only be one organization record.
            var entities = _serviceProxy.RetrieveMultiple(
                new QueryExpression(Organization.EntityLogicalName)
                {
                    ColumnSet = new ColumnSet("organizationid"),
                    PageInfo = new PagingInfo { PageNumber = 1, Count = 1 },
                });

            if (entities != null && entities.Entities.Count > 0)
                return entities.Entities[0].Id;

            return null;
        }

        /// <summary>
        ///
        /// </summary>
        /// <param name="prompt"></param>
        private void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete records created in this sample.
                if (_accountId1.HasValue)
                {
                    Console.WriteLine(String.Concat("Deleting account: ", _accountId1.Value));
                    _serviceProxy.Delete(Account.EntityLogicalName, _accountId1.Value);
                }
                if (_accountId2.HasValue)
                {
                    Console.WriteLine(String.Concat("Deleting account: ", _accountId2.Value));
                    _serviceProxy.Delete(Account.EntityLogicalName, _accountId2.Value);
                }
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        /// <summary>
        /// Waits for async job to complete
        /// </summary>
        /// <param name="asyncJobId"></param>
        public void WaitForAsyncJobCompletion(IEnumerable<Guid> asyncJobIds)
        {
            List<Guid> asyncJobList = new List<Guid>(asyncJobIds);
            ColumnSet cs = new ColumnSet("statecode", "asyncoperationid");
            int retryCount = 100;

            while (asyncJobList.Count != 0 && retryCount > 0)
            {
                // Retrieve the async operations based on the ids
                var crmAsyncJobs = _serviceProxy.RetrieveMultiple(
                    new QueryExpression("asyncoperation")
                    {
                        ColumnSet = cs,
                        Criteria = new FilterExpression
                        {
                            Conditions =
                            {
                                new ConditionExpression("asyncoperationid",
                                    ConditionOperator.In, asyncJobList.ToArray())
                            }
                        }
                    });

                // Check to see if the operations are completed and if so remove them from the Async Guid list
                foreach (var item in crmAsyncJobs.Entities)
                {
                    var crmAsyncJob = item.ToEntity<AsyncOperation>();
                    if (crmAsyncJob.StateCode.HasValue &&
                        crmAsyncJob.StateCode.Value == AsyncOperationState.Completed)
                        asyncJobList.Remove(crmAsyncJob.AsyncOperationId.Value);

                    Console.WriteLine(String.Concat("Async operation state is ",
                        crmAsyncJob.StateCode.Value.ToString(),
                        ", async operation id: ", crmAsyncJob.AsyncOperationId.Value.ToString()));
                }

                // If there are still jobs remaining, sleep the thread.
                if (asyncJobList.Count > 0)
                    System.Threading.Thread.Sleep(2000);

                retryCount--;
            }

            if (retryCount == 0 && asyncJobList.Count > 0)
            {
                for (int i = 0; i < asyncJobList.Count; i++)
                {
                    Console.WriteLine(String.Concat(
                        "The following async operation has not completed: ",
                        asyncJobList[i].ToString()));
                }
            }
        }

        #endregion

        #region Main method
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new EnableDuplicateDetectionAndRetrieveDuplicates();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion
    }
}

See Also

Concepts

Enable duplicate detection
Run duplicate detection

Other Resources

Detect duplicate data
Sample: Invoke duplicate detection for creating and updating records
RetrieveDuplicatesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Invoke duplicate detection for creating and updating records
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DataManagement\DuplicateDetection\InvokeDuplicateDetectionForCreateAndUpdate.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to invoke duplicate detection for creating and updating entity records.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to do basic entity operations like create, and
    /// update, using Duplicate Detection attribute.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class InvokeDuplicateDetectionForCreateAndUpdate
    {
        #region Class Level Members

        private Guid _accountId;
        private Guid _ruleId;
        private Guid _dupAccountId;
        private OrganizationServiceProxy _serviceProxy;
        private IOrganizationService _service;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// basic create, retrieve, update, and delete entity operations are performed.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    _service = (IOrganizationService)_serviceProxy;

                    CreateRequiredRecords();

                    // Create and account record with the named Proseware, Inc. and already existing Account Number.
                    Account account = new Account
                    {
                        Name = "Proseware, Inc.",
                        AccountNumber = "ACC005"
                    };

                    // Create operation by suppressing duplicate detection
                    CreateRequest reqCreate = new CreateRequest();
                    reqCreate.Target = account;
                    reqCreate.Parameters.Add("SuppressDuplicateDetection", true); // Change to false to activate the duplicate detection.
                    CreateResponse createResponse = (CreateResponse)_service.Execute(reqCreate);
                    _dupAccountId = createResponse.id;
                    Console.Write("Account: {0} {1} created with SuppressDuplicateDetection to true, ",
                        account.Name, account.AccountNumber);

                    // Retrieve the account containing with its few attributes.
                    ColumnSet cols = new ColumnSet(
                        new String[] { "name", "accountnumber"});

                    Account retrievedAccount = (Account)_service.Retrieve("account", _dupAccountId, cols);
                    Console.Write("retrieved, ");

                    // Update the existing account with new account number.
                    retrievedAccount.AccountNumber = "ACC006";

                    // Update operation – update record, if a duplicate is not found.
                    UpdateRequest reqUpdate = new UpdateRequest();
                    reqUpdate.Target = retrievedAccount;
                    reqUpdate["SuppressDuplicateDetection"] = false; // Duplicate detection is activated.

                    // Update the account record.
                    UpdateResponse updateResponse = (UpdateResponse)_service.Execute(reqUpdate);
                    Console.WriteLine("and updated.");

                    DeleteRequiredRecords(promptforDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create an account record named Fourth Coffee.
            Account account = new Account
            {
                Name = "Fourth Coffee",
                AccountNumber = "ACC005"
            };
            _accountId = _service.Create(account);
            Console.Write("Account {0} {1} created, ", account.Name, account.AccountNumber);

            // Create a duplicate detection rule
            DuplicateRule accountDuplicateRule = new DuplicateRule
            {
                Name = "DuplicateRule: Accounts with the same Account Number",
                BaseEntityName = "account",
                MatchingEntityName = "account"
            };
            _ruleId = _service.Create(accountDuplicateRule);

            // Create a duplicate detection rule condition
            DuplicateRuleCondition accountDupCondition = new DuplicateRuleCondition
            {
                BaseAttributeName = "accountnumber",
                MatchingAttributeName = "accountnumber",
                OperatorCode = new OptionSetValue(0), // Exact Match.
                RegardingObjectId = new EntityReference(DuplicateRule.EntityLogicalName, _ruleId)
            };
            Guid conditionId = _service.Create(accountDupCondition);

            Console.Write("'{0}' created, ", accountDuplicateRule.Name);

            // Execute the publish request.
            PublishDuplicateRuleResponse response =
                (PublishDuplicateRuleResponse)_service.Execute(new PublishDuplicateRuleRequest() { DuplicateRuleId = _ruleId });

            // When the publishDuplicateRule request returns, the state of the rule will still be "Publishing" (StatusCode = 1).
            // we need to wait for the publishing operation to complete, so we keep polling the state of the
            // rule until it becomes "Published" (StatusCode = 2).
            int i = 0;
            DuplicateRule retrievedRule =
                (DuplicateRule)_service.Retrieve(DuplicateRule.EntityLogicalName, _ruleId, new ColumnSet(new String[] { "statuscode" }));
            while (retrievedRule.StatusCode.Value == 1 && i < 20)
            {
                i++;
                System.Threading.Thread.Sleep(1000);
                retrievedRule =
                    (DuplicateRule)_service.Retrieve(DuplicateRule.EntityLogicalName, _ruleId, new ColumnSet(new String[] { "statuscode" }));
            }

            Console.Write("published.\n");
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") ||
                                answer.StartsWith("Y") ||
                                answer == String.Empty);
            }

            if (deleteRecords)
            {
                _service.Delete(Account.EntityLogicalName, _accountId);
                UnpublishDuplicateRuleRequest unpublishRequest = new UnpublishDuplicateRuleRequest
                {
                    DuplicateRuleId = _ruleId
                };
                _service.Execute(unpublishRequest);
                _service.Delete(DuplicateRule.EntityLogicalName, _ruleId);
                _service.Delete(Account.EntityLogicalName, _dupAccountId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                InvokeDuplicateDetectionForCreateAndUpdate app = new InvokeDuplicateDetectionForCreateAndUpdate();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Reference

Pass Optional Parameters in Messages

Concepts

Run duplicate detection
Use messages (request and response classes) with the Execute method

Other Resources

Detect duplicate data
Sample: Detect multiple duplicate records

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Detect multiple duplicate records
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DataManagement\DuplicateDetection\BulkDetectDuplicates.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to detect and log multiple duplicate records for a specified entity type.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This samples shows how to issue a BulkDetectDuplicates request.
    /// </summary>
    /// <param name="serverConfig">Contains server connection information.</param>
    /// <param name="promptforDelete">When True, the user will be prompted to delete all
    /// created entities.</param>
    public class BulkDetectDuplicates
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;

        private Account[] _duplicateAccounts = new Account[2];
        private Account _account;
        private DuplicateRule _rule;
        private BulkDetectDuplicatesResponse _response;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first creates 3 accounts with the same name, then issues a BulkDetectDuplicates
        /// request to show the duplicate detection.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Create the BulkDetectDuplicatesRequest object
                    Console.WriteLine("  Creating the BulkDetectDuplicatesRequest object");
                    BulkDetectDuplicatesRequest request = new BulkDetectDuplicatesRequest()
                    {
                        JobName = "Detect Duplicate Accounts",
                        Query = new QueryExpression()
                        {
                            EntityName = Account.EntityLogicalName,
                            ColumnSet = new ColumnSet(true)
                        },
                        RecurrencePattern = String.Empty,
                        RecurrenceStartTime = DateTime.Now,
                        ToRecipients = new Guid[0],
                        CCRecipients = new Guid[0]
                    };

                    // Execute the request
                    Console.WriteLine("  Executing BulkDetectDuplicatesRequest");
                    _response = (BulkDetectDuplicatesResponse)_serviceProxy
                        .Execute(request);

                    #region check success

                    Console.WriteLine("  Waiting for job to complete...");
                    WaitForAsyncJobToFinish(_response.JobId, 120);

                    QueryByAttribute query = new QueryByAttribute()
                    {
                        ColumnSet = new ColumnSet(true),
                        EntityName = "duplicaterecord"
                    };
                    query.Attributes.Add("asyncoperationid");
                    query.Values.Add(_response.JobId);
                    EntityCollection results = _serviceProxy.RetrieveMultiple(query);

                    // check to make sure each id is found in the collection
                    var duplicateIds = results.Entities.Select((entity) =>
                        ((DuplicateRecord)entity).BaseRecordId.Id);
                    foreach (var id in _duplicateAccounts.Select((account) => account.Id))
                    {
                        if (!duplicateIds.Contains(id))
                        {
                            throw new Exception(String.Format(
                                "Account with ID {0} was not detected as a duplicate",
                                id));
                        }
                    }
                    Console.WriteLine("  All accounts detected as duplicates successfully");

                    #endregion

                    Console.WriteLine();

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #region Helper methods

        private void WaitForAsyncJobToFinish(Guid jobId, int maxTimeSeconds)
        {
            for (int i = 0; i < maxTimeSeconds; i++)
            {
                var asyncJob = _serviceProxy.Retrieve(AsyncOperation.EntityLogicalName,
                    jobId, new ColumnSet("statecode")).ToEntity<AsyncOperation>();
                if (asyncJob.StateCode.HasValue && asyncJob.StateCode.Value == AsyncOperationState.Completed)
                    return;
                System.Threading.Thread.Sleep(1000);
            }
            throw new Exception(String.Format(
                "  Exceeded maximum time of {0} seconds waiting for asynchronous job to complete",
                maxTimeSeconds
            ));
        }

        #endregion

        #region Public methods

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            #region Creating Accounts

            String accountName = "Contoso, Ltd";
            String websiteUrl = "http://www.contoso.com/";

            Console.WriteLine("  Creating duplicate records (Account name={0}, Website URL={1})", accountName,
                websiteUrl);
            // Create some duplicate records
            for (int i = 0; i < 2; i++)
            {
                Account account = new Account()
                {
                    Name = accountName,
                    WebSiteURL = websiteUrl
                };
                account.Id = _serviceProxy.Create(account);
                _duplicateAccounts[i] = account;
            }

            accountName = "Contoso Pharmaceuticals";
            Console.WriteLine("  Creating a non-duplicate record (Account name={0}, Website URL={1})",
                accountName, websiteUrl);
            // Create a record that is NOT a duplicate
            Account distinctAccount = new Account()
            {
                Name = accountName,
                WebSiteURL = websiteUrl
            };
            distinctAccount.Id = _serviceProxy.Create(distinctAccount);
            _account = distinctAccount;

            #endregion

            #region Create and Publish duplicate detection rule

            Console.WriteLine("  Creating a duplicate detection rule");
            // Create a duplicate detection rule
            _rule = new DuplicateRule()
            {
                Name = "Accounts with the same Account name and website url",
                BaseEntityName = Account.EntityLogicalName,
                MatchingEntityName = Account.EntityLogicalName
            };
            _rule.Id = _serviceProxy.Create(_rule);

            // Create a duplicate detection rule condition
            DuplicateRuleCondition nameCondition = new DuplicateRuleCondition()
            {
                BaseAttributeName = "name",
                MatchingAttributeName = "name",
                OperatorCode = new OptionSetValue(0), // value 0 = 'exact match'
                // set the regarding id to point to the rule created earlier,
                // associating this condition with that rule
                RegardingObjectId = _rule.ToEntityReference()
            };
            _serviceProxy.Create(nameCondition);

            DuplicateRuleCondition websiteCondition = new DuplicateRuleCondition()
            {
                BaseAttributeName = "websiteurl",
                MatchingAttributeName = "websiteurl",
                OperatorCode = new OptionSetValue(0),
                RegardingObjectId = _rule.ToEntityReference()
            };
            _serviceProxy.Create(websiteCondition);

            Console.WriteLine("  Publishing duplicate detection rule");
            // Publish the rule
            PublishDuplicateRuleRequest publishRequest = new PublishDuplicateRuleRequest()
            {
                DuplicateRuleId = _rule.Id
            };
            PublishDuplicateRuleResponse publishResponse = (PublishDuplicateRuleResponse)_serviceProxy.Execute(publishRequest);

            // The PublishDuplicateRule request returns before the publish is completed,
            // so we keep retrieving the async job state until it is "Completed"
            Console.WriteLine("  Checking to see if duplicate detection rule has finished publishing");
            WaitForAsyncJobToFinish(publishResponse.JobId, 60);

            #endregion
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete the job
                Console.WriteLine("  Deleting the job");
                _serviceProxy.Delete(AsyncOperation.EntityLogicalName, _response.JobId);

                // Delete the duplicate detection rule
                Console.WriteLine("  Deleting the duplicate detection rule");
                _serviceProxy.Delete(DuplicateRule.EntityLogicalName, _rule.Id);

                // Delete the accounts
                Console.WriteLine("  Deleting the accounts");
                foreach (Account account in _duplicateAccounts)
                    _serviceProxy.Delete(Account.EntityLogicalName, account.Id);
                _serviceProxy.Delete(Account.EntityLogicalName, _account.Id);
                Console.WriteLine("Entity records have been deleted.");
            }
        }
        #endregion Public Methods

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                BulkDetectDuplicates app = new BulkDetectDuplicates();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }

        #endregion Main method
    }
}

See Also

Concepts

Enable duplicate detection
Run duplicate detection

Other Resources

Detect duplicate data
BulkDetectDuplicatesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Delete data in bulk

The bulk deletion feature helps you to maintain data quality and manage the consumption of system storage in Microsoft Dynamics CRM by deleting data that you no longer need.

For example, you can delete the following data in bulk:

  • Stale data.
  • Data that is irrelevant to the business.
  • Unneeded test or sample data.
  • Data that is incorrectly imported from other systems.

With bulk deletion you can perform the following operations:

  • Delete data across multiple entities.
  • Delete records for a specified entity.
  • Receive email notifications when a bulk deletion finishes.
  • Delete data periodically.
  • Schedule the start time of a recurring bulk delete.
  • Retrieve the information about the failures that occurred during a bulk deletion.

In This Section

Run bulk delete

BulkDeleteOperation entity messages and methods

BulkDeleteFailure entity messages and methods

Related Sections

Manage your data

Import data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Run bulk delete

To delete data in bulk, you have to submit a bulk delete job by using the BulkDeleteRequest message. The bulk delete job runs asynchronously in the background without blocking other activities. The query expressions that describe the records on which to run the bulk delete job are specified in the QuerySet property of this request.

A bulk delete job is represented by the bulk delete operation entity. The schema name for this entity is BulkDeleteOperation. A bulk delete operation record includes the following information:

  • Number of records that the bulk delete job deleted.
  • Number of records that the bulk delete job failed to delete.
  • Whether the bulk delete job is a recurring job or not.
  • Start time of the bulk delete job.

A bulk delete job only deletes records that are created before the job starts to run.

Note
If a bulk delete job fails or ends prematurely, any records that were deleted before the failure or ending of the job are not rolled back and remain deleted. The failures of the BulkDeleteOperation are stored in the BulkDeleteFailure records and can be retrieved by using the RetrieveRequest message or the RetrieveMultiple message.

A bulk delete job deletes the specified records according to the cascading rules. These rules are based on the relationship type between the entities. For more information, see Entity relationship behavior.

To run a bulk delete job, a user must have the BulkDelete message privileges and Delete message privileges for the entity types being deleted. The user must also have read permissions to the entity records that are specified in the BulkDeleteRequest message. By default, a system administrator has the necessary permissions; however, other users must be granted these permissions.

You can perform a bulk deletion on all entities that are supported by the delete action. For information about possible actions on entity records, see Actions on Entity Records.

If a plug-in or a workflow (process) is triggered by the delete action on a specific entity type, it is triggered every time that an entity record of this type is deleted by the bulk delete job.

See Also

Concepts

Entity relationship behavior
Recurrence pattern in asynchronous job execution
BulkDeleteOperation entity messages and methods

Other Resources

Delete data in bulk
Manage your data
Security role and privilege reference
Sample: Bulk delete exported records
Sample: Bulk delete records that match common criteria

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkDeleteOperation entity messages and methods

A bulk delete operation entity represents an asynchronous bulk delete job that is submitted by the BulkDeleteRequest message. The schema name for this entity is BulkDeleteOperation. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The bulk delete operation entity tracks the following information:

  • The number of records that a bulk delete job deleted.
  • The number of records that a bulk delete job failed to delete.
  • The start time of a bulk delete job.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
DeleteRequest | Deletes a bulk delete operation. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a bulk delete operation. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of bulk delete operations. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Reference

BulkDeleteOperation entity privileges

Concepts

BulkDeleteFailure entity messages and methods

Other Resources

Delete data in bulk

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkDeleteFailure entity messages and methods

The bulk delete failure entity represents a failure that occurred during a bulk delete job. This entity provides a description of the failure and the error number.

The schema name for this entity is BulkDeleteFailure. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves a bulk delete failure. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of bulk delete failures. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Reference

BulkDeleteFailure entity privileges

Other Resources

Delete data in bulk
Sample: Bulk delete exported records

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Bulk delete exported records
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DataManagement\BulkDelete\BulkDeleteBackup.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to perform a bulk deletion of records that were previously exported from Microsoft Dynamics CRM by using the Export to Excel option.

Example

C# Copy Code
using System;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to perform a bulk delete asynchronous
    /// operation on the records that have been manually exported
    /// from Microsoft Dynamics CRM by using Export to Excel in a grid's view.
    /// </summary>
    public class BulkDeleteBackup
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private BulkDeleteResponse _bulkDeleteResponse;
        private Guid? _asyncOperationId;
        private Guid? _bulkDeleteOperationId;
        #endregion

        #region How To Sample Code

        /// <summary>
        /// Run the sample.
        /// </summary>
        /// <param name="serverConfig">configuration for the server.</param>
        /// <param name="promptToDelete">
        /// whether or not to prompt the user to delete created records.
        /// </param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptToDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();

                PerformBulkDeleteBackup();
                DeleteRequiredRecords(promptToDelete);
            }
        }

        /// <summary>
        /// Performs the main operation of the sample - performs a bulk delete on inactive
        /// opportunities and activities to remove them from the system.
        /// </summary>
        private void PerformBulkDeleteBackup()
        {
            try
            {
                // Query for a system user to send an email to after the bulk delete
                // operation completes.
                var userRequest = new WhoAmIRequest();
                var userResponse = (WhoAmIResponse)_serviceProxy.Execute(userRequest);
                Guid currentUserId = userResponse.UserId;

                // Create a condition for a bulk delete request.
                // NOTE: This sample uses very specific queries for deleting records
                // that have been manually exported in order to free space.
                QueryExpression opportunitiesQuery = BuildOpportunityQuery();

                // Create the bulk delete request.
                BulkDeleteRequest bulkDeleteRequest = new BulkDeleteRequest();

                // Set the request properties.
                bulkDeleteRequest.JobName = "Backup Bulk Delete";

                // Querying activities
                bulkDeleteRequest.QuerySet = new QueryExpression[]
                {
                    opportunitiesQuery,
                    BuildActivityQuery(Task.EntityLogicalName),
                    BuildActivityQuery(Fax.EntityLogicalName),
                    BuildActivityQuery(PhoneCall.EntityLogicalName),
                    BuildActivityQuery(Email.EntityLogicalName),
                    BuildActivityQuery(Letter.EntityLogicalName),
                    BuildActivityQuery(Appointment.EntityLogicalName),
                    BuildActivityQuery(ServiceAppointment.EntityLogicalName),
                    BuildActivityQuery(CampaignResponse.EntityLogicalName),
                    BuildActivityQuery(RecurringAppointmentMaster.EntityLogicalName)
                };

                // Set the start time for the bulk delete.
                bulkDeleteRequest.StartDateTime = DateTime.Now;

                // Set the required recurrence pattern.
                bulkDeleteRequest.RecurrencePattern = String.Empty;

                // Set email activity properties.
                bulkDeleteRequest.SendEmailNotification = false;
                bulkDeleteRequest.ToRecipients = new Guid[] { currentUserId };
                bulkDeleteRequest.CCRecipients = new Guid[] { };

                // Submit the bulk delete job.
                // NOTE: Because this is an asynchronous operation, the response will be immediate.
                _bulkDeleteResponse =
                    (BulkDeleteResponse)_serviceProxy.Execute(bulkDeleteRequest);
                Console.WriteLine("The bulk delete operation has been requested.");

                CheckSuccess();
            }
            catch (System.Web.Services.Protocols.SoapException)
            {
                // Perform error handling here.
                throw;
            }
            catch (Exception)
            {
                throw;
            }
        }

        /// <summary>
        /// This method will query for the BulkDeleteOperation until it has been
        /// completed or until the designated time runs out.  It then checks to see if
        /// the operation was successful.
        /// </summary>
        private void CheckSuccess()
        {
            // Query for bulk delete operation and check for status.
            QueryByAttribute bulkQuery = new QueryByAttribute(
                BulkDeleteOperation.EntityLogicalName);
            bulkQuery.ColumnSet = new ColumnSet(true);

            // NOTE: When the bulk delete operation was submitted, the GUID that was
            // returned was the asyncoperationid, not the bulkdeleteoperationid.
            bulkQuery.Attributes.Add("asyncoperationid");
            _asyncOperationId = _bulkDeleteResponse.JobId;
            bulkQuery.Values.Add(_asyncOperationId);

            // With only the asyncoperationid at this point, a RetrieveMultiple is
            // required to get the
            // bulk delete operation created above.
            EntityCollection entityCollection = _serviceProxy.RetrieveMultiple(bulkQuery);
            BulkDeleteOperation createdBulkDeleteOperation = null;

            // Monitor the async operation via polling until it is complete or max
            // polling time expires.
            const int ARBITRARY_MAX_POLLING_TIME = 60;
            int secondsTicker = ARBITRARY_MAX_POLLING_TIME;
            while (secondsTicker > 0)
            {
                // Make sure the async operation was retrieved.
                if (entityCollection.Entities.Count > 0)
                {
                    // Grab the one bulk operation that has been created.
                    createdBulkDeleteOperation = (BulkDeleteOperation)entityCollection.Entities[0];

                    // Check the operation's state.
                    if (createdBulkDeleteOperation.StateCode.Value != BulkDeleteOperationState.Completed)
                    {
                        // The operation has not yet completed.  Wait a second for the
                        // status to change.
                        System.Threading.Thread.Sleep(1000);
                        secondsTicker--;

                        // Retrieve a fresh version of the bulk delete operation.
                        entityCollection = _serviceProxy.RetrieveMultiple(bulkQuery);
                    }
                    else
                    {
                        // Stop polling as the operation's state is now complete.
                        secondsTicker = 0;
                    }
                }
                else
                {
                    // Wait a second for async operation to activate.
                    System.Threading.Thread.Sleep(1000);
                    secondsTicker--;

                    // Retrieve the entity again.
                    entityCollection = _serviceProxy.RetrieveMultiple(bulkQuery);
                }
            }

            // Validate that the operation was completed.
            if (createdBulkDeleteOperation != null)
            {
                _bulkDeleteOperationId = createdBulkDeleteOperation.BulkDeleteOperationId;
                if (createdBulkDeleteOperation.StateCode.Value != BulkDeleteOperationState.Completed)
                {
                    Console.WriteLine(
                        "Polling for the BulkDeleteOperation took longer than allowed ({0} seconds).",
                        ARBITRARY_MAX_POLLING_TIME);
                }
                else
                {
                    Console.WriteLine("The BulkDeleteOperation succeeded.\r\n  Successes: {0}, Failures: {1}",
                        createdBulkDeleteOperation.SuccessCount,
                        createdBulkDeleteOperation.FailureCount);
                }
            }
            else
            {
                Console.WriteLine("The BulkDeleteOperation could not be retrieved.");
            }
        }

        /// <summary>
        /// Builds a query that matches all opportunities that are not in the open state.
        /// </summary>
        private static QueryExpression BuildOpportunityQuery()
        {
            // Create a query that will match all opportunities that do not have a state
            // of open.
            var closedCondition = new ConditionExpression(
                "statecode", ConditionOperator.NotEqual, (int)OpportunityState.Open);

            // Create a filter expression for a bulk delete request.
            var closedFilter = new FilterExpression();
            closedFilter.Conditions.Add(closedCondition);

            var queryExpression = new QueryExpression();

            queryExpression.EntityName = Opportunity.EntityLogicalName;
            queryExpression.Criteria = closedFilter;

            // Return all records
            queryExpression.Distinct = false;

            return queryExpression;
        }

        /// <summary>
        /// Builds a query which will match all activities that are in the canceled or
        /// completed state.
        /// </summary>
        private static QueryExpression BuildActivityQuery(String entityName)
        {
            var canceledCondition = new ConditionExpression(
                "statecode", ConditionOperator.Equal, (int)ActivityPointerState.Canceled);
            var completedCondition = new ConditionExpression(
                "statecode", ConditionOperator.Equal, (int)ActivityPointerState.Completed);

            var closedFilter = new FilterExpression(LogicalOperator.Or);
            closedFilter.Conditions.AddRange(canceledCondition, completedCondition);

            var queryExpression = new QueryExpression();

            queryExpression.EntityName = entityName;
            queryExpression.Criteria = closedFilter;

            queryExpression.Distinct = false;

            return queryExpression;
        }

        /// <summary>
        /// This method deletes the AsyncOperation and BulkDeleteOperation that were
        /// created in the database, if the user confirms that deleting these is
        /// desired.
        /// </summary>
        private void DeleteRequiredRecords(bool promptToDelete)
        {
            var toBeDeleted = true;
            if (promptToDelete)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete the bulk delete operation so that it won't clutter the
                // database.
                if (_bulkDeleteOperationId.HasValue)
                {
                    _serviceProxy.Delete(
                        BulkDeleteOperation.EntityLogicalName,
                        _bulkDeleteOperationId.Value);
                }

                if (_asyncOperationId.HasValue)
                {
                    _serviceProxy.Delete(
                        AsyncOperation.EntityLogicalName, _asyncOperationId.Value);
                }

                Console.WriteLine("The AsyncOperation and BulkDeleteOperation have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new BulkDeleteBackup();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Run bulk delete
Recurrence pattern in asynchronous job execution

Other Resources

Delete data in bulk
Sample: Bulk delete records that match common criteria
BulkDeleteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Bulk delete records that match common criteria
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DataManagement\BulkDelete\BulkDeleteOperations.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to delete records, in bulk, that match common criteria.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to perform a bulk delete request to remove the records in
    /// Microsoft Dynamics CRM that match certain criteria.
    /// </summary>
    public class BulkDeleteOperations
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private ServiceContext _context;
        private Guid _bulkDeleteOperationId;
        private Guid _asyncOperationId;
        #endregion

        #region How To Sample Code

        /// <summary>
        /// Run the sample.
        /// </summary>
        /// <param name="serverConfig">configuration for the server.</param>
        /// <param name="promptToDelete">
        /// whether or not to prompt the user to delete created records.
        /// </param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptToDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                using (_context = new ServiceContext(_serviceProxy))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // This statments checks whether Standard Email templates are present
                    var emailTemplateId = (
                                       from emailTemplate in _context.TemplateSet
                                       where emailTemplate.Title == "Contact Reconnect"
                                       select emailTemplate.Id
                                      ).FirstOrDefault();

                    if (emailTemplateId != Guid.Empty)
                    {
                        CreateRequiredRecords();

                        // Perform the bulk delete.  If you want to perform a recurring delete
                        // operation, then leave this as it is.  Otherwise, pass in false as the
                        // first parameter.
                        PerformBulkDelete(true, promptToDelete);
                    }
                    else
                    {
                        throw new ArgumentException("Standard Email Templates are missing");
                    }
                }
            }
        }

        /// <summary>
        /// Create an account that will be deleted in the main portion of the sample.
        /// </summary>
        private void CreateRequiredRecords()
        {
            var account = new Account
            {
                Name = "Fourth Coffee",
                WebSiteURL = "http://www.fourthcoffee.com/"
            };
            _serviceProxy.Create(account);
        }

        /// <summary>
        /// Perform the main action of the sample - issuing a BulkDeleteRequest.
        /// </summary>
        /// <param name="useRecurrence">
        /// whether or not to create a recurring BulkDeleteRequest.
        /// </param>
        private void PerformBulkDelete(bool useRecurrence, bool promptToDelete)
        {
            try
            {
                Console.WriteLine("Performing Bulk Delete Operation");

                // Query for a system user to send an email to after the bulk delete
                // operation completes.
                var userRequest = new WhoAmIRequest();
                var userResponse = (WhoAmIResponse)_serviceProxy.Execute(userRequest);
                Guid currentUserId = userResponse.UserId;

                Console.WriteLine("  Requesting user retrieved.");

                // Create a condition for a bulk delete request.
                // NOTE: If no records are found that match this condition, the bulk delete
                // will not fail.  It will succeed with 0 successes and 0 failures.
                var deleteCondition = new ConditionExpression(
                    "name", ConditionOperator.Equal, "Fourth Coffee");

                // Create a fiter expression for the bulk delete request.
                var deleteFilter = new FilterExpression();
                deleteFilter.Conditions.Add(deleteCondition);

                // Create the bulk delete query set.
                var bulkDeleteQuery = new QueryExpression
                {
                    EntityName = Account.EntityLogicalName,
                    Distinct = false,
                    Criteria = deleteFilter
                };

                // Create the bulk delete request.
                var bulkDeleteRequest = new BulkDeleteRequest
                {
                    JobName = "Sample Bulk Delete",
                    QuerySet = new[] { bulkDeleteQuery },
                    StartDateTime = DateTime.Now,
                    ToRecipients = new[] { currentUserId },
                    CCRecipients = new Guid[] {},
                    SendEmailNotification = true,
                    RecurrencePattern = String.Empty

                };

                // Create a recurring BulkDeleteOperation.
                if (useRecurrence)
                {
                    bulkDeleteRequest.RecurrencePattern = "FREQ=DAILY;INTERVAL=1;";
                }

                // Submit the bulk delete job.
                // NOTE: Because this is an asynchronous operation, the response will be
                // immediate.
                var bulkDeleteResponse =
                    (BulkDeleteResponse)_serviceProxy.Execute(bulkDeleteRequest);
                _asyncOperationId = bulkDeleteResponse.JobId;

                Console.WriteLine("  The Bulk Delete Request was made and the Bulk\n" +
                                  "    Delete Operation should be created.");

                // To monitor the asynchronous operation, retrieve the
                // bulkdeleteoperation object.
                // NOTE: There will be a period of time from when the async operation
                // request was submitted to the time when a successful query for that
                // async operation can be made.  When using plug-ins, events can be
                // subscribed to that will fire when the async operation status changes.
                var bulkQuery = new QueryByAttribute();
                bulkQuery.ColumnSet = new ColumnSet(true);
                bulkQuery.EntityName = BulkDeleteOperation.EntityLogicalName;

                // NOTE: When the bulk delete operation was submitted, the GUID that was
                // returned was the asyncoperationid, not the bulkdeleteoperationid.
                bulkQuery.Attributes.Add("asyncoperationid");
                bulkQuery.Values.Add(bulkDeleteResponse.JobId);

                // With only the asyncoperationid at this point, a RetrieveMultiple is
                // required to get the bulk delete operation created above.
                var entityCollection =
                    _serviceProxy.RetrieveMultiple(bulkQuery);
                BulkDeleteOperation createdBulkDeleteOperation = null;

                // When creating a recurring BulkDeleteOperation, the BulkDeleteOperation
                // will be in suspended status after the current instance has completed.
                // When creating a non-recurring BulkDeleteOperation, it will be in
                // Completed status when it is finished.
                var bulkOperationEnded = useRecurrence
                    ? BulkDeleteOperationState.Suspended
                    : BulkDeleteOperationState.Completed;

                createdBulkDeleteOperation = RetrieveBulkDeleteOperation(
                    bulkQuery, entityCollection, bulkOperationEnded);
                _bulkDeleteOperationId = createdBulkDeleteOperation.Id;

                if (createdBulkDeleteOperation != null)
                {
                    // If the BulkDeleteOperation is recurring, the status will be
                    // "Waiting" after the operation completes this instance.  If it is
                    // non-recurring, the status will be "Succeeded".
                    var bulkOperationSuccess = useRecurrence
                        ? bulkdeleteoperation_statuscode.Waiting
                        : bulkdeleteoperation_statuscode.Succeeded;

                    InspectBulkDeleteOperation(createdBulkDeleteOperation,
                        bulkOperationEnded, bulkOperationSuccess, useRecurrence);

                    DeleteRecords(promptToDelete);
                }
                else
                {
                    Console.WriteLine("  The Bulk Delete Operation could not be retrieved.");
                }
            }
            catch (System.Web.Services.Protocols.SoapException)
            {
                // Perform error handling here.
                throw;
            }
        }

        /// <summary>
        /// Inspect and display information about the created BulkDeleteOperation.
        /// </summary>
        /// <param name="createdBulkDeleteOperation">
        /// the BulkDeleteOperation to inspect.
        /// </param>
        /// <param name="bulkOperationEnded">
        /// the statecode that will tell us if the BulkDeleteOperation is ended.
        /// </param>
        /// <param name="bulkOperationSuccess">
        /// the statuscode that will tell us if the BulkDeleteOperation was successful.
        /// </param>
        /// <param name="useRecurrence">
        /// whether or not the BulkDeleteOperation is a recurring operation.
        /// </param>
        private void InspectBulkDeleteOperation(
            BulkDeleteOperation createdBulkDeleteOperation,
            BulkDeleteOperationState bulkOperationEnded,
            bulkdeleteoperation_statuscode bulkOperationSuccess,
            bool useRecurrence)
        {
            // Validate that the operation was completed.
            if (createdBulkDeleteOperation.StateCode != bulkOperationEnded)
            {
                // This will happen if it took longer than the polling time allowed
                // for this operation to complete.
                Console.WriteLine("  Completion of the Bulk Delete took longer\n" +
                                  "    than the polling time allotted.");
            }
            else if (createdBulkDeleteOperation.StatusCode.Value
                     != (int)bulkOperationSuccess)
            {
                Console.WriteLine("  The Bulk Delete operation failed.");
            }
            else if (!useRecurrence)
            {
                // Check for the number of successful deletes.
                var successfulDeletes = createdBulkDeleteOperation.SuccessCount ?? 0;
                Console.WriteLine("  {0} records were successfully deleted",
                                  successfulDeletes);

                // Check for any failures that may have occurred during the bulk
                // delete operation.
                if (createdBulkDeleteOperation.FailureCount > 0)
                {
                    Console.WriteLine("  {0} records failed to be deleted:",
                                      createdBulkDeleteOperation.FailureCount);

                    // Query for all the failures.
                    var failureQuery = new QueryByAttribute();
                    failureQuery.ColumnSet = new ColumnSet(true);
                    failureQuery.EntityName = BulkDeleteFailure.EntityLogicalName;
                    failureQuery.Attributes.Add("bulkdeleteoperationid");
                    var bulkDeleteOperationId =
                        createdBulkDeleteOperation.BulkDeleteOperationId ?? Guid.Empty;
                    failureQuery.Values.Add(bulkDeleteOperationId);

                    // Retrieve the bulkdeletefailure objects.
                    EntityCollection entityCollection = _serviceProxy.RetrieveMultiple(
                        failureQuery);

                    // Examine each failure for information regarding the failure.
                    foreach (BulkDeleteFailure failureOperation in
                        entityCollection.Entities)
                    {
                        // Process failure information.
                        Console.WriteLine(String.Format(
                            "    {0}, {1}",
                            failureOperation.RegardingObjectId.Name,
                            failureOperation.RegardingObjectId.Id));
                    }
                }
            }
            else
            {
                // NOTE: If recurrence is used, we cannot reliably retrieve data
                // about the records that were deleted, since a sub-BulkDeleteOperation
                // is created by Microsoft Dynamics CRM that does not have any fields tying it back to the
                // Asynchronous operation or the BulkDeleteOperation. This makes it
                // unreliable to know which subprocess to retrieve.
                Console.WriteLine("  The recurring Bulk Delete Operation was created successfully.");
            }
        }

        /// <summary>
        /// Retrieves the BulkDeleteOperation, but it's not necessarily created
        /// immediately, so this method uses polling.
        /// </summary>
        /// <param name="bulkQuery">the query to find the BulkDeleteOperation.</param>
        /// <param name="entityCollection">the initial results of the query.</param>
        /// <param name="operationEndedStatus">
        /// the statecode that will indicate that the operation has ended.
        /// </param>
        private BulkDeleteOperation RetrieveBulkDeleteOperation(
            QueryByAttribute bulkQuery, EntityCollection entityCollection,
            BulkDeleteOperationState operationEndedStatus)
        {
            BulkDeleteOperation createdBulkDeleteOperation = null;
            // Monitor the async operation via polling until it is complete or max
            // polling time expires.
            const int ARBITRARY_MAX_POLLING_TIME = 60;
            int secondsTicker = ARBITRARY_MAX_POLLING_TIME;
            while (secondsTicker > 0)
            {
                // Make sure the async operation was retrieved.
                if (entityCollection.Entities.Count > 0)
                {
                    // Grab the one bulk operation that has been created.
                    createdBulkDeleteOperation =
                        (BulkDeleteOperation) entityCollection.Entities[0];

                    // Check the operation's state.
                    // NOTE: If a recurrence for the BulkDeleteOperation was
                    // specified, the state of the operation will be Suspended,
                    // not Completed, since the operation will run again in the
                    // future.
                    if (createdBulkDeleteOperation.StateCode !=
                        operationEndedStatus)
                    {
                        // The operation has not yet completed.  Wait a second for
                        // the status to change.
                        System.Threading.Thread.Sleep(1000);
                        secondsTicker--;

                        // Retrieve a fresh version of the bulk delete operation.
                        entityCollection = _serviceProxy.RetrieveMultiple(bulkQuery);
                    }
                    else
                    {
                        // Stop polling as the operation's state is now complete.
                        secondsTicker = 0;
                        Console.WriteLine(
                            "  The BulkDeleteOperation record has been retrieved.");
                    }
                }
                else
                {
                    // Wait a second for async operation to activate.
                    System.Threading.Thread.Sleep(1000);
                    secondsTicker--;

                    // Retrieve the entity again.
                    entityCollection = _serviceProxy.RetrieveMultiple(bulkQuery);
                }
            }
            return createdBulkDeleteOperation;
        }

        /// <summary>
        /// Deletes records that were created in the sample.
        /// </summary>
        /// <param name="prompt">whether or not to prompt the user for deletion.</param>
        private void DeleteRecords(bool prompt)
        {
            var toBeDeleted = true;
            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Delete the bulk delete operation so that it won't clutter the
                // database.
                _serviceProxy.Delete(
                    BulkDeleteOperation.EntityLogicalName, _bulkDeleteOperationId);

                var asyncOperationEntity = _serviceProxy.Retrieve(
                    AsyncOperation.EntityLogicalName,
                    _asyncOperationId,
                    new ColumnSet("statecode", "asyncoperationid"));
                var asyncOperation = asyncOperationEntity.ToEntity<AsyncOperation>();

                if (asyncOperation.StateCode != AsyncOperationState.Completed)
                {
                    // We have to update the AsyncOperation to be in a Completed state
                    // before we can delete it.
                    asyncOperation.StateCode = AsyncOperationState.Completed;
                    _serviceProxy.Update(asyncOperation);
                }

                _serviceProxy.Delete(
                    AsyncOperation.EntityLogicalName, _asyncOperationId);

                Console.WriteLine("  The AsyncOperation and BulkDeleteOperation have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new BulkDeleteOperations();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Run bulk delete
Recurrence pattern in asynchronous job execution

Other Resources

Delete data in bulk
BulkDeleteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Import data

If you want to import data into Microsoft Dynamics CRM, you can use the data import feature. Data import lets you upload data from various customer relationship management systems and data sources into Microsoft Dynamics CRM. You can import data into standard and customized attributes of most business and custom entities. You can also include related data, such as notes and attachments.

Microsoft Dynamics CRM includes a web application tool called Import Data Wizard. You use this tool to import data records from one or more comma-separated values (.csv), XML Spreadsheet 2003 (.xml), or text files.

For more information about the Import Data Wizard, see Microsoft Dynamics CRM Help.

The Microsoft Dynamics CRM web services provide the following additional capabilities that aren’t available in the Import Data Wizard:

  • Create data maps that include complex transformation mapping, such as concatenation, split, and replace.
  • Define custom transformation mapping.
  • View source data that is stored inside the temporary parse tables.
  • Access error logs to build custom error reporting tools with improved error logging views.
  • Run data import by using command-line scripts.
  • Add LookupMap XML tags in the data map to indicate that the data lookup will be initiated and performed on a source file that is used in the import.
  • Add custom OwnerMetadata XML tags in the data map to match the user records in the source file with the records of the user (system user) in Microsoft Dynamics CRM.
  • Use optional validation checks.
    Note
    Validation isn’t optional in the Import Data Wizard.

To implement data import, you typically do the following:

  • Create a comma-separated values (CSV), XML Spreadsheet 2003 (XMLSS), or text source file.
  • Create a data map or use an existing data map.
  • Associate an import file with a data map.
  • Upload the content from a source file to the associated import file.
  • Parse the import file.
  • Transform the parsed data.
  • Upload the transformed data into the target Microsoft Dynamics CRM server.

You can import data from one source file or several source files. A source file can contain data for one entity type or multiple entity types.

Parsing, transforming, and uploading of data is done by the asynchronous jobs that run in the background.

Note
By default, all custom entities are enabled for import. To determine if a business entity is enabled for import, see the entity metadata for the specific entity. If an entity is enabled for import, the entity metadata property IsImportable is set to true. The value of this property can’t be changed for the out-of-the-box business entities. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

In This Section

Prepare source files for import

Create data maps for import

Add transformation mappings for import

Configure data import

Run data import

Data import entities

Sample: Export and import a data map

Sample: Import data using complex data map

Related Sections

Manage your data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Prepare source files for import

Before you can import data into Microsoft Dynamics CRM, you must create the source data files.

The data source files that you use in an import must be formatted as comma-separated values (.csv), XML Spreadsheet 2003 (.xml), or text files. The use of source files enables the transfer of data from database systems that use different formats into Microsoft Dynamics CRM.

A source file may contain data for one entity type or multiple entity types, such as accounts and contacts. For the source files that contain multiple entity data, you must provide a map that includes the <EntitiesPerFile> tag. Set the value of this tag to “Multiple” to indicate that there is more than one entity type in the source file. Add the Dedupe = “Eliminate” attribute to the <EntityMap> tag. This assures that if the file contains duplicate rows for the entity type, a single row is used to minimize lookup related errors.

An example of the data map with multiple entity types can be found in this location of the SDK:

SDK\Resources\DataImportMaps\MapForSalesForceContactAccount.xml

Download the Microsoft Dynamics CRM SDK package.

The field values in the source file can be separated by commas, tabs, or other characters that are defined in the ImportFile.FieldDelimiterCode attribute.

Note
Do not use non-printable characters, null (\0) or break (\b), as delimiters for the field values.

The first row in the source file should contain column headings. If you do not include headings, use the ImportFile.IsFirstRowHeader attribute to specify that the first row represents actual data. In this case, default column headings are created with the names Col1, Col2, and so on.

See Also

Concepts

Create data maps for import

Other Resources

Import data
Blog Post: How to Import attachments programmatically

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create data maps for import

To import data into Microsoft Dynamics CRM, you must provide the appropriate data maps.

The examples of the data maps can be found in this location in the SDK: SDK\Resources\DataImportMaps\. Download the Microsoft Dynamics CRM SDK package.

You use data maps to map the data contained in the source file to the Microsoft Dynamics CRM entity attributes. You must map every column in the source file to an appropriate attribute. The data in the unmapped columns is not imported during the data import operation.

The data map is represented by the import map (data map) entity. You can create a new map by using the CreateRequest message or update an existing map by using the IOrganizationService.Update method. The map has a unique name that is contained in the ImportMap.Name attribute. You can specify the name of the import source for which this data map is created by using the ImportMap.Source attribute.

In This Topic

Column, list value, and lookup mappings

Owner mapping

Notes and attachments

Import and export data maps

Column, list value, and lookup mappings

To map a column, a list value, or lookup value in the source file to a Microsoft Dynamics CRM attribute, use the following mappings:

Column Mapping

Maps a column in a source file to a Microsoft Dynamics CRM entity attribute. For column mapping, use the column mapping (ColumnMapping) entity. You can use 1:1 (one-to-one) or 1:N (one-to-many) relationships between source and target attributes. For example, you can map account address information to the billing and shipping addresses in an order.

List Value Mapping

Maps a list value in a source file to a Microsoft Dynamics CRM attribute of the OptionSetValue type. For list value mapping, use the picklist mapping (PicklistMapping) entity.

If a value specified in the source file column is a list value, such as an OptionSetValue, Status, State, and Boolean, you must provide a list value mapping additionally to a column mapping. For example, map the "bill" and "ship" list values in the source file to the bill and ship values of the OptionSetValue type.

Lookup Mapping

Maps a lookup value in a source file to a Microsoft Dynamics CRM attribute of the EntityReference type. For lookup mapping, use the lookup mapping (LookupMapping) entity.

If the value specified in the source file references an entity, you must provide a lookup mapping for this value. Use the LookupMapping.LookupSourceCode attribute to specify whether to search for the referenced entity inside the source file or inside Microsoft Dynamics CRM. If you are using early bound types, you can use the LookupSourceType enumeration to set the lookup values. To search inside the source file, use the LookupSourceType.Source value. To search inside Microsoft Dynamics CRM, use the LookupSourceType.System value. For a list of the LookupSourceCode values, see the picklist values for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. You can provide multiple lookup mappings. The asynchronous transformation job processes all available mappings. It finds the referenced records and updates the parse table with the record unique identifiers. For more information, see Run data import.

Owner mapping

Use owner mapping to map a user specified in the source file to a user in Microsoft Dynamics CRM. For logging information, use the Microsoft Dynamics CRM user logon name. For owner mapping, use the owner mapping (OwnerMapping) entity.

Notes and attachments

Mapping for notes and attachments is handled differently from other entities. Notes and attachments are used to append additional information to a record in Microsoft Dynamics CRM. Notes are stored as text and attachments are stored as files in the Microsoft Dynamics CRM database.

To create a note in Microsoft Dynamics CRM, set the Annotation.IsDocument attribute in the annotation (note) entity to false. To create an attachment, set IsDocument to true.

Use the following settings for mapping notes and attachments:

  • Set the ColumnMapping.SourceAttributeName attribute to “true” or “false”. The “true” value indicates an attachment. The “false” value indicates a note.
  • Set the ColumnMapping.TargetAttributeName attribute to IsDocument.
  • Set the ColumnMapping.ProcessCode attribute to the ImportProcessCode.Internal value of the ImportProcessCode enumeration, if you are using early bound types. For a list of the ProcessCode values, see the picklist values for this entity.

If the source data represents a note, map the text of the note to the Annotation.NoteText attribute. If you are working with Salesforce files, they are usually stored on the disk under unique identification numbers. To import an attachment, you must map a file identification number that is contained in the source file to the Annotation.DocumentBody attribute. The DocumentBody attribute stores the contents of the attachment.

The import asynchronous job checks for mappings that have the source attribute name set to “true” and “false” to discover notes and attachments. If it finds an attachment mapping, it looks for the specified files on the disk and uploads the file contents as attachments into Microsoft Dynamics CRM. If a file is not found, an error is returned.

If you do not provide mapping for an annotation (note) entity, the import job generates a default mapping for the note.

Note
The maximum size of files that can be uploaded is determined by the Organization.MaxUploadFileSize property. This property is set in the Email tab of the System Settings in the CRM application. This setting limits the size of files that can be attached to email messages, notes, and web resources. The default setting is 5 MB. However, an attachment size cannot exceed the maximum HTTP request size (the default is 16MB). For the change to take effect, reset Internet Information Services (IIS). To do this, click Start, click Run, type iisreset, and then click OK.

Import and export data maps

You can export an existing data map to an XML file and import XML data mappings into Microsoft Dynamics CRM. To export a data map from Microsoft Dynamics CRM, use the ExportMappingsImportMapRequest message. To import XML data mappings and create a data map in Microsoft Dynamics CRM, use the ImportMappingsImportMapRequest message.

See Also

Concepts

Add transformation mappings for import
Add transformation mappings for import

Other Resources

Import data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Add transformation mappings for import

Use transformation mapping to modify data before importing it. For example, split a full name that is contained in the source file into a first name and a last name to match the target attributes for an entity.

To implement transformation mapping, use the transformation mapping (TransformationMapping) entity and transformation parameter mapping (TransformationParameterMapping) entity.

The transformed data must be compatible with the Microsoft Dynamics CRM entity attribute types.

The transformation type is described by the TransformationMapping.TransformationTypeName property. The valid values for this property are listed in the following table:

Field | Value
AddToCurrentDate | "Microsoft.Crm.Transformations.AddToCurrentDate"
AddToDate | "Microsoft.Crm.Transformations.AddToDate"
AdvancedAddToCurrentDate | "Microsoft.Crm.Transformations.AdvancedAddToCurrentDate"
AssignValue | "Microsoft.Crm.Transformations.AssignValue"
Concatenate | "Microsoft.Crm.Transformations.Concatenate"
Replace | "Microsoft.Crm.Transformations.Replace"
Split | "Microsoft.Crm.Transformations.Split"
Substring | "Microsoft.Crm.Transformations.Substring"

The following sections describe the available transformations.

In This Topic

Concatenation

Split

Substring

Replace

Assign Value

Add to Date

Adjust Current Date and Set Time

Advanced Add to Current Date

Concatenation

Concatenates strings and separates them with a delimiter.

Input Parameters | Description
Prefix | String that is used as a prefix in the concatenated string.
Suffix | String that is used as a suffix in the concatenated string.
Delimiter | One character or combination of characters that separate substrings inside the concatenated string. The delimiter is not used between the prefix and the substring or between the suffix and the substring. Do not use the backspace (\b), newline (\n), and return (\r) characters as a delimiter.
<Variable> | Array of variable length that contains substrings.

Output Parameters | Description
String | Concatenated string.

Split

Separates a string that includes a delimiter into substrings. There can be up to ten substrings.

Input Parameters | Description
Input String | String that contains one or more substrings that is separated with delimiters.
Delimiter | One character or combination of characters that separate substrings inside the string. Do not use the backspace (\b), newline (\n), and return (\r) characters or empty strings as a delimiter.

Output Parameters | Description
Variable | Substrings 1 through maximum of 10.

For example, if the input string contains eleven substrings, the output contains ten substrings as shown in the following example:

Input string: a;b;c;d;e;f;g;h;i;j;k

Output:

a

b

c

d

e

f

g

h

i

j;k

Substring

Returns a substring of a specified length, starting at a specified point in the string.

Input Parameters | Description
Input String | String that contains a substring.
Start Index | Starting position of the substring.
Length | Length of the substring. If the length is null, returns a complete string from the start index.

Output Parameters | Description
Substring | Returned substring.

Replace

Replaces all occurrences of a specified string with another specified string.

Input Parameters | Description
Input String | String that contains a search string.
Search String | Search string. Do not use the backspace (\b), newline (\n), and return (\r) characters as a search string.
Replace String | Replacement string. Use an empty string to remove a search string. Do not use the backspace (\b), newline (\n), and return (\r) characters as a replacement string.

Output Parameters | Description
Value | Replacement value (same as assigned value).

Assign value

Replaces all values with a specified value.

Input Parameters | Description
Value | Value that you want to assign.

Output Parameters | Description
Value | Replacement value (same as assigned value).
Note
Date transformations can only be used for correctly formatted dates. For information about how to format dates, see Microsoft Dynamics CRM Help.

Add to date

Adds a specified number of days, months, and years to a date.

Input Parameters | Description
Date | Date string that is to be modified.
Year Offset | Positive or negative value that is added to the year component of an input date.
Month Offset | Positive or negative value that is added to the month component of an input date.
Day Offset | Positive or negative value that is added to the day component of an input date.

Output Parameters | Description
New Date | New data string that contains day, month, and year added in this order.

Adjust current date and set time

Adds a specified number of days, months, and years to the current date and sets the specified time. The offsets can only be integer numbers.

Input Parameters | Description
Year Offset | Positive or negative value that is added to the year component of a current date.
Month Offset | Positive or negative value that is added to the month component of a current date.
Day Offset | Positive or negative value that is added to the day component of a current date.
Hours | Value that is used to set the hours component of a current date.
Minutes | Value that is used to set the minutes component of a current date.
Seconds | Value that is used to set the seconds component of a current date.
Day of Week | Day of the week that can be Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, or Sunday. The days of the week are represented by whole numbers, starting with decimal 1 for Monday. The values for days of the week are contained in the DayOfWeek enumeration. For more information about this enumeration, see the MSDN topic, DayOfWeekEnumeration. If the calculated current date does not fall on the specified day of the week, it is adjusted to the nearest earlier date that falls on the specified day of the week. The current date is always adjusted to a date in the past. For example, if you specify Wednesday as a day of the week, and the newly calculated date falls on Tuesday, March 9, then the date is adjusted to Wednesday, March 3.

Output Parameters | Description
New Date | New data string that contains day, month, and year added in this order.

Advanced add to current date

Adds a specified number of days, months, and years to the current date. You can specify whether offsets are relative to the current date or absolute values. The offsets can only be integer numbers.

For example, if you use an absolute value of 3 for a month offset, the newly calculated month is March. If you set a relative to current date month offset to 3, and the current month is April, the newly calculated month is July.

Input Parameters | Description
Year Offset | Positive or negative value that is added to the year component of a current date or absolute year.
Year Offset Mode | Specify whether the offset is relative to the current date or absolute value by using the TransformationParameterMapping.Data attribute. If you are using early bound types, you can use the TransformationOffsetMode enumeration to specify relative or absolute offset. For a list of the DataTypeCode values, see the picklist values for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.
Month Offset | Positive or negative value that is added to the month component of a current date or absolute month.
Month Offset Mode | Specify whether the offset is relative to the current date or absolute value by using the TransformationParameterMapping.Data attribute. If you are using early bound types, you can use the TransformationOffsetMode enumeration to specify relative or absolute offset. For a list of the DataTypeCode values, see the picklist values for this entity.
Day Offset | Positive or negative value that is added to the day component of a current date or absolute day.
Day Offset Mode | Specify whether the offset is relative to the current date or absolute value by using the TransformationParameterMapping.Data attribute. If you are using early bound types, you can use the TransformationOffsetMode enumeration to specify relative or absolute offset. For a list of the DataTypeCode values, see the picklist values for this entity.
Hours | Value that sets the hours component of a current date.
Minutes | Value that sets the minutes component of a current date.
Seconds | Value that sets the seconds component of a current date.

Output Parameters | Description
New Date | New data string that contains day, month, and year, added in this order. First, the relative components are added, and then the absolute values are used to form a date.

See Also

Concepts

Create data maps for import
Configure data import

Other Resources

Import data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Configure data import

The configuration information that is required for importing data is contained in the data import (Import) entity and the import source file (ImportFile) entity.

To configure data import, do the following:

  • Use the Import.ModeCode attribute to specify whether to create or update data during import. If you are using early bound types, you can use the ImportModeCode enumeration. For a list of the ModeCode values, see the picklist values for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.
  • Set Import.IsImport to true.
  • Use the ImportFile.FileTypeCode attribute to specify the type of the import file. If you are using early bound types, you can use the ImportFileType enumeration. For a list of the FileTypeCode values, see the picklist values for this entity. This attribute is only available in Microsoft Dynamics CRM Online.
  • Use the ImportFile.DataDelimiterCode attribute to specify the single character data delimiter in the import file. If you are using early bound types, you can use the ImportDataDelimiter enumeration. For a list of the ImportDataDelimiter values, see the picklist values for this entity.
  • Use the ImportFile.FieldDelimiterCode attribute to specify the single character field delimiter in the import file. If you are using early bound types, you can use the ImportFieldDelimiter enumeration. For a list of the FieldDelimiterCode values, see the picklist values for this entity.
  • Set ImportFile.IsFirstRowHeader to true to indicate that the first row in the source file contains column headings or to false to indicate that the first row contains actual data. If set to false, default column headings are generated.
  • Set ImportFile.ImportId to the ID of the import (data import) that the import file is associated with.
  • Set ImportFile.ImportMapId to the ID of the associated import map (data map).
  • Set ImportFile.EnableDuplicateDetection to true to enable duplicate detection during data import.
  • Read the content of the source file into the ImportFile.Content.

Important
We do not recommend updating records by using data import programmatically. To update, use the data export and import capabilities of the Microsoft Dynamics CRM Web application. Use Export to Excel to export records to an XML Spreadsheet 2003 (.xml) file. This is the only valid source file type for the Update mode. Re-importing data from the XML Spreadsheet 2003 (.xml) source file ensures that the data integrity in Microsoft Dynamics CRM is maintained. To import updated data, use the Microsoft Dynamics CRM Import Data Wizard. For more information about the Import Data Wizard, see Microsoft Dynamics CRM Help.

See Also

Concepts

Run data import

Other Resources

Import data
Blog Post: How to Import attachments programmatically

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Run data import

Data import runs directly on the Microsoft Dynamics CRM server. To run data import, set up asynchronous jobs to run in the background that do the following, in this order:

  • Parse source data that is contained in the import file.
  • Transform parsed data by using the data map.
  • Upload transformed data into Microsoft Dynamics CRM.

All Microsoft Dynamics CRM users who have appropriate permissions can run data import.

In This Topic

Parse source data

Transform parsed data

Upload transformed data to the target server

Log failures

Import auditing data

Parse source data

Parsing source data includes parsing of all import files associated with a particular import (data import).

Parsed data is stored in the temporary parse tables that are created for every imported file. The name of the parse table is stored in the ImportFile.ParsedTableName attribute. The source file column headings are specified in the ImportFile.HeaderRow attribute. If the source file does not include a first row that contains the column headings, this attribute specifies the system-generated default column headings.

Save parsed data in the parse table by using the ParseImportRequest message. Retrieve data from the parse table by using the GetDistinctValuesImportFileRequest message and the RetrieveParsedDataImportFileRequest message.

The following table lists the messages that you can use to parse the import files and retrieve the parsed data from the parse tables.

Message Description

ParseImportRequest

Submits an asynchronous job that parses all import files associated with the specified import (data import). Pass the ID of the associated import (data import) in the ImportId property of this request. The ID of the asynchronous job that runs in the background and performs parsing of data is returned in the AsyncOperationId property of the message response.

GetDistinctValuesImportFileRequest

Returns distinct values for a column in the source file that contains list values. Pass the ID of the associated import file in the ImportFileId property of this request. The distinct values are returned in an array of strings, in the Values property of the message response. Use this message only after you have created a parse table by using the ParseImportRequest message.

Important
Do not use this message after you use the ImportRecordsImportRequest message. You cannot access the parse table after the import job submitted by the ImportRecordsImportRequest message has finished running.

RetrieveParsedDataImportFileRequest

Retrieves the data from the parse table. Pass the ID of the associated import file in the ImportFileId property of this request. The parsed data is returned in a two-dimensional array of strings in the Values property of the message response. The data is returned with the same column order as the column order in the source file. Use this message only after you have created a parse table by using the ParseImportRequest message.

Important
Do not use this message after you use the ImportRecordsImportRequest message. You cannot access the parse table after the import job submitted by the ImportRecordsMessage message has finished running.

Transform parsed data

During transformation, you change parsed data by applying all available data mappings and transformations that are associated with a particular import (data import) to the data.

Use the TransformImportRequest message to submit an asynchronous job to transform the parsed data. Pass a unique identifier of the associated import (data import) in the Import.ImportId attribute of the request. A unique identifier of the asynchronous job that runs in the background and performs the transformation is returned in the AsyncOperationId property of the message response.

Upload transformed data to the target server

After you successfully complete the transformation, the data is ready to be uploaded into the Microsoft Dynamics CRM server.

Use the ImportRecordsImportRequest message to submit an asynchronous job to upload the transformed data into Microsoft Dynamics CRM. The unique identifier of the associated import (data import) must be specified in the ImportId property of the request. A unique identifier of the asynchronous job that runs in the background and uploads the data into Microsoft Dynamics CRM is returned in the AsyncOperationId property of the message response. All import files that are associated with the specified import (data import) are imported.

Each import job has a unique sequence number that it stores in the ImportSequenceNumber attribute of records it creates. The Organization.CurrentImportSequenceNumber attribute contains a unique sequence number of the last import job that ran in the system. You can use these unique sequence numbers to track records that belong to one import job.

Log failures

A failure to import a record can occur during parsing, transformation, or uploading of data. The failure reasons and other detailed information about the records that failed to import are captured in the import log (ImportLog) entity.

To find out how many records failed to import, retrieve the ImportFile.FailureCount attribute of the record. To verify how many records had partial failures during import, retrieve the ImportData.HasError attribute. If the HasError attribute is true, a partial failure occurred, if it is false, the record imported successfully.

Import auditing data

The Microsoft Dynamics CRM entities have four default attributes that are used to track the date and time when a record was created and last modified, and the person who created and modified it.

The createdon attribute specifies the date and time that the record was created. To import data in the createdon attribute, map the source column that contains this data to the overriddencreatedon attribute. During import, the record’s createdon attribute is updated with the value that was mapped to the overriddencreatedon attribute and the overriddencreatedon attribute is set to the date and time that the data was imported. If no source value is mapped to the overriddencreatedon attribute, the createdon attribute is set to the date and time that the data was imported and the overriddencreatedon attribute is not set to any value.

Note
To override the value in the createdon attribute during import, you need the prvOverrideCreatedOnCreatedBy privilege. Note that the privilege name implies that you can also override the createdby attribute during import. However, this capability is not currently supported.

You cannot import data into the modifiedon, createdby, and modifiedby attributes. If you have to store data related to who created and modified the data and when the data was modified, you can create custom attributes in Microsoft Dynamics CRM and map the source columns to the new custom attributes.

See Also

Concepts

Configure data import
Data import entities

Other Resources

Import data
Blog Post: How to Import attachments programmatically

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Data import entities

The Microsoft Dynamics CRM data import entities are used to create data maps, configure and run data imports, and log failure information.

The following table lists the entities that are used to configure, run, and log failures for import operations.

Entity name (display name) | Description
import (data import) | Status and ownership information for the import job.
importfile (import source file) | Logical source file.
importlog (import log) | Failure reason and other detailed information for a record that failed to import.

The following table lists the entities that are used for creating data maps.

Entity name (display name) | Description
importmap (data map) | Data map that is used for import.
columnmapping (column mapping) | Mapping between a column in the source file and a target attribute in Microsoft Dynamics CRM.
lookupmapping (lookup mapping) | Mapping between a column in the source file, or an output of a complex transformation and a target attribute of type EntityReference. Used in conjunction with column mapping or complex transformation mapping.
ownermapping (owner mapping) | Mapping between a user specified in the source file and a user in Microsoft Dynamics CRM.
picklistmapping (picklist mapping) | Mapping between a column in the source file and a target attribute of OptionSetValue, Boolean, state, or status type in Microsoft Dynamics CRM. Used in conjunction with column mapping.
transformationmapping (transformation mapping) | Complex transformation mapping.
transformationparametermapping (transformation parameter mapping) | Parameter mapping that is used in complex transformation mapping.

See Also

Concepts

Import (data import) entity messages and methods
ImportFile entity messages and methods
ImportLog entity messages and methods
ImportMap (data map) entity messages and methods
ColumnMapping entity messages and methods
LookupMapping entity messages and methods
OwnerMapping entity messages and methods
PicklistMapping (list value mapping) entity messages and methods
TransformationMapping entity messages and methods
TransformationParameterMapping entity messages and methods

Other Resources

Import data
Sample: Export and import a data map

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Import (data import) entity messages and methods

This entity represents the status and ownership for the import job. The schema name for this entity is Import. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a data import. You can also call the IOrganizationService.CreateRequest method.
DeleteRequest | Deletes a data import. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a data import with another security principal (user or team).
ImportRecordsImportRequest | Submits an asynchronous job that uploads transformed data to the target server. The import records job imports all import files associated with the specified import (data import). Pass the ID of the associated import (data import) in the ImportId property of this request. The ID of the asynchronous job that runs in the background and performs uploading of data is returned in the AsyncOperationId property of the message response.
ModifyAccessRequest | Changes the access rights for a data import previously shared with another security principal (user or team).
ParseImportRequest | Submits an asynchronous job that parses all import files associated with the specified import (data import). Pass the ID of the associated import (data import) in the ImportId property of this request. The ID of the asynchronous job runs in the background and performs parsing of data is returned in the AsyncOperationId property of the message response.
RetrieveRequest | Retrieves a data import. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of data imports. You can also call the IOrganizationService.RetrieveMultiplemethod.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a data import.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a data import, and their access rights to the data import.
RevokeAccessRequest | Revokes access rights to the data import for the specified security principal (user or team).
TransformImportRequest | Submits an asynchronous job to transform the parsed data. Pass the ID of the associated import (data import) in the ImportId property of this request. The ID of the asynchronous job runs in the background and performs transformation of data is returned in the AsyncOperationId property of the message response.
UpdateRequest | Updates a data import. You can also call the UpdateRequest method.
Note
The parse table is not accessible after the asynchronous import records job is completed.

Use the following messages in this order:

  • ParseImport to parse data.
  • TransformImport to transform data.
  • ImportRecordsImport to upload data.

Do not submit a request for the next job before the previous job has finished running successfully.

See Also

Concepts

Data import entities
Import (data import) entity privileges
ImportFile entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportFile entity messages and methods

This entity represents a logical source file that is used in data import. The schema name for this entity is ImportFile. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an import file to another user or team.
CreateRequest | Creates an import file. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an import file. You can also call the IOrganizationService.Delete method.
GetDistinctValuesImportFileRequest | Returns distinct values for a column in the source file that contains list values. Use this message only after you have created a parse table by using the ParseImport message. Do not use this message after you use the ImportRecordsImport message. You cannot access the parse table after the import job submitted by the ImportRecordsImport message has finished running.
GetHeaderColumnsImportFileRequest | Retrieves source file column headings, or system-generated column headings if the source file does not contain column headings.
GrantAccessRequest | Shares an import file with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for an import file previously shared with another security principal (user or team).
RetrieveRequest | Retrieves an import file. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of import files. You can also call the IOrganizationService.RetrieveMultiplemethod.
RetrieveParsedDataImportFileRequest | Retrieves the data from the parse table. Use this message only after you have created a parse table by using the ParseImport message. Do not use this message after you use the ImportRecordsImport message. You cannot access the parse table after the import job submitted by the ImportRecordsMessage message has finished running.
RetrievePrincipalAccessRequest | Retrieves the access rights that the specified security principal (user or team) has to an import file.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves all the security principals (users or teams) that have access to an account, and their access rights to the import file.
RevokeAccessRequest | Removes all access rights to an import file for the specified security principal (user or team).
UpdateRequest | Updates an import file. You can also call the IOrganizationService.Update method.

See Also

Concepts

Data import entities
ImportFile (import source file) entity privileges
ImportLog entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportLog entity messages and methods

An import log represents a failure reason and other detailed information about a record that failed to import. The failure can occur during parsing, transformation, or uploading of data. The schema name for this entity is ImportLog. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves an import log. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of import logs. You can also call the IOrganizationService.RetrieveMultiplemethod.

See Also

Concepts

Data import entities
ImportLog entity privileges
ImportMap (data map) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportMap (data map) entity messages and methods

An import map (data map) represents a data map that is used for data import. The schema name for this entity is ImportMap. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns an import map to another user or team.
CreateRequest | Creates an import map. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an import map. You can also call the IOrganizationService.Delete method.
ExportMappingsImportMapRequest | Exports an import map as an XML formatted data.
GrantAccessRequest | Shares an import map with another security principal (user or team).
ImportMappingsImportMapRequest | Imports XML representation of a data map and creates an import map (data map) based on this data.
ModifyAccessRequest | Changes the access rights for an import map previously shared with another security principal (user or team).
RetrieveRequest | Retrieves an import map. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of import maps. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access rights the specified security principal (user or team) has to an import map.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves all the security principals (users or teams) that have access to an import map, and their access rights to the import map.
RevokeAccessRequest | Removes all access rights to an import map for the specified security principal (user or team).
SetStateRequest | Sets the state of an import map. If you are using early bound types, use the ImportMapState enumeration. For a list of the state values, refer to the ImportMap entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates an import map. You can also call the IOrganizationService.Update method.

See Also

Concepts

Data import entities
ImportMap (data map) entity privileges
ColumnMapping entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ColumnMapping entity messages and methods

The column mapping entity represents the mapping between a column in a source file and a target attribute in Microsoft Dynamics CRM.

Cascading rules are applied between this entity and the picklist mapping and lookup mapping entities. For example, if you delete the column mapping record, the picklist mapping and lookup mapping records are also deleted. For more information, see Entity relationship behavior. The schema name for this entity is ColumnMapping. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a column mapping. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a column mapping. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a column mapping. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of column mappings. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

Data import entities
ColumnMapping entity privileges
LookupMapping entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


LookupMapping entity messages and methods

A lookup mapping represents the mapping between a column in the source file, or an output of a complex transformation and a target attribute of type EntityReference. This is used in conjunction with column mapping or complex transformation mapping. The schema name for this entity is LookupMapping. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a lookup mapping. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a lookup mapping. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a lookup mapping. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of lookup mappings. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

Data import entities
LookUpMapping entity privileges
OwnerMapping entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OwnerMapping entity messages and methods

An owner mapping entity represents the mapping between a user specified in the source file and a user in Microsoft Dynamics CRM. The schema name for this entity is OwnerMapping. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Deprecated.
CreateRequest | Creates an owner mapping. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an owner mapping. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an owner mapping. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of owner mappings. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

Data import entities
OwnerMapping entity privileges
PicklistMapping (list value mapping) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PicklistMapping (list value mapping) entity messages and methods

A picklist mapping represents a mapping between a column in the source file and a target attribute of picklist, Boolean, state, or status type in Microsoft Dynamics CRM. This is used in conjunction with column mapping.

Each list value in the source column must be mapped to a valid picklist option value for the target attribute. The schema name for this entity is PicklistMapping. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a picklist mapping. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a picklist mapping. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a picklist mapping. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of picklist mappings. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

Data import entities
PickListMapping (list value mapping) entity privileges
TransformationMapping entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TransformationMapping entity messages and methods

A transformation mapping represents the mapping in a data map between the transformation of the source attribute and the Microsoft Dynamics CRM entity attribute. The schema name for this entity is TransformationMapping. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Note
Cascading rules are applied between this entity and the transformation parameter mapping entity. For example, if you delete the transformation mapping record, the transformation parameter mapping record is also deleted. For more information, see Entity relationship behavior.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | You can also call the
CreateRequest | Creates a transformation mapping. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a transformation mapping. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a transformation mapping. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of transformation mappings. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

Data import entities
TransformationMapping entity privileges
TransformationParameterMapping entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TransformationParameterMapping entity messages and methods

A transformation parameter mapping defines the parameters for a transformation. The schema name for this entity is TransformationParameterMapping. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Note
The transformation parameter mapping does not support the output parameters of type Owner, Picklist, Boolean, State, and Status.

Cascading rules are applied between this entity and the lookup mapping entity. For example, if you delete the transformation parameter mapping record, the lookup mapping record that is associated with it is also deleted. For more information, see Entity relationship behavior.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a transformation parameter mapping. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a transformation parameter mapping. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a transformation parameter mapping. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of transformation parameter mappings. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

TransformationParameterMapping entity privileges
Data import entities

Other Resources

Import data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Export and import a data map
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DataManagement\DataImport\UsingExportAndImportMappings.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create an import map (data map) in Microsoft Dynamics CRM, export it as an XML formatted data, import modified mappings, and create a new import map in Dynamics CRM based on the imported mappings.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Xml.Linq;
using Microsoft.Crm.Sdk.Messages;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to define an import mapping, export the import mapping
    /// record and re-import a modified import mapping.
    /// </summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.
    /// </remarks>
    public class UsingExportAndImportMappings
    {
        #region Class Level Members
        private OrganizationServiceProxy _serviceProxy;
        private Guid? _importMapId;
        private String _mappingXml;
        private Guid? _newImportMapId;
        #endregion

        #region How To Sample Code

        /// <summary>
        /// Creates an import mapping, retrieves the xml, modifies the name,
        /// and re-imports the import mappings
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig,
           bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early-bound type support.
                _serviceProxy.EnableProxyTypes();

                CreateImportMapping();
                RetrieveMappingXml();
                ChangeMappingName();
                ImportMappingsByXml();

                DeleteRequiredRecords(promptforDelete);
            }
        }

        /// <summary>
        /// Creates the import mapping record.
        /// </summary>
        private void CreateImportMapping()
        {
            // Create the import map and populate a column
            ImportMap importMap = new ImportMap()
            {
                Name = "Original Import Mapping"  + DateTime.Now.Ticks.ToString(),
                Source = "Import Accounts.csv",
                Description = "Description of data being imported",
                EntitiesPerFile =
                    new OptionSetValue((int)ImportMapEntitiesPerFile.SingleEntityPerFile),
                EntityState = EntityState.Created
            };

            _importMapId = _serviceProxy.Create(importMap);

            Console.WriteLine(String.Concat("Import map created: ", _importMapId.Value));

            #region Column One Mappings
            // Create a column mapping for a 'text' type field
            ColumnMapping colMapping1 = new ColumnMapping()
            {
                // Set source properties
                SourceAttributeName = "name",
                SourceEntityName = "Account_1",

                // Set target properties
                TargetAttributeName = "name",
                TargetEntityName = Account.EntityLogicalName,

                // Relate this column mapping with the data map
                ImportMapId =
                    new EntityReference(ImportMap.EntityLogicalName, _importMapId.Value),

                // Force this column to be processed
                ProcessCode =
                    new OptionSetValue((int)ColumnMappingProcessCode.Process)
            };

            // Create the mapping
            Guid colMappingId1 = _serviceProxy.Create(colMapping1);

            Console.WriteLine(String.Concat("Column mapping added SourceAttributeName: name",
                ", TargetAttributeName: name, TargetEntityName: account"));
            #endregion
        }

        /// <summary>
        /// Export the mapping that we created
        /// </summary>
        private void RetrieveMappingXml()
        {
            if (!_importMapId.HasValue)
                return;

            // Retrieve the xml for the mapping
            var exportRequest = new ExportMappingsImportMapRequest
            {
                ImportMapId = _importMapId.Value,
                ExportIds = true,
            };

            var exportResponse = (ExportMappingsImportMapResponse)_serviceProxy
                .Execute(exportRequest);

            _mappingXml = exportResponse.MappingsXml;

            Console.WriteLine(String.Concat("Import mapping exported for ",
                _importMapId.Value, "\nMappingsXml:\n", _mappingXml));
        }

        /// <summary>
        /// Parse the XML to change the name attribute
        /// </summary>
        private void ChangeMappingName()
        {
            if (string.IsNullOrWhiteSpace(_mappingXml))
                return;

            // Load into XElement
            var xElement = XElement.Parse(_mappingXml);

            // Get the Name attribute
            var nameAttribute = xElement.Attribute("Name");

            // Swap the name out
            if (nameAttribute != null)
            {
                string newName = "New Import Mapping" + DateTime.Now.Ticks.ToString();
                Console.WriteLine(String.Concat("\nChanging the import name\n\tfrom: ",
                    nameAttribute.Value, ",\n\tto: ", newName));

                nameAttribute.Value = newName;
                _mappingXml = xElement.ToString();
            }
        }

        /// <summary>
        /// Create a mapping from Xml
        /// </summary>
        private void ImportMappingsByXml()
        {
            if (string.IsNullOrWhiteSpace(_mappingXml))
                return;

            // Create the import mapping from the XML
            var request = new ImportMappingsImportMapRequest
            {
                MappingsXml = _mappingXml,

                ReplaceIds = true,
            };

            Console.WriteLine(String.Concat("\nCreating mapping based on XML:\n",
                _mappingXml));

            var response = (ImportMappingsImportMapResponse)
                _serviceProxy.Execute(request);

            _newImportMapId = response.ImportMapId;

            Console.WriteLine(String.Concat("\nNew import mapping created: ",
                _newImportMapId.Value));

            // Retrieve the value for validation
            var exportRequest = new ExportMappingsImportMapRequest
            {
                ImportMapId = _newImportMapId.Value,
                ExportIds = true,
            };

            var exportResponse = (ExportMappingsImportMapResponse)_serviceProxy
                .Execute(exportRequest);

            var mappingXml = exportResponse.MappingsXml;

            Console.WriteLine(String.Concat("\nValidating mapping xml for : ",
                _newImportMapId.Value, ",\nMappingsXml:\n", mappingXml));
        }

        /// <summary>
        /// Deletes the records created by this sample
        /// </summary>
        /// <param name="prompt"></param>
        private void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                if (_importMapId.HasValue)
                {
                    Console.WriteLine(String.Concat("Deleting import mapping: ", _importMapId.Value));
                    _serviceProxy.Delete(ImportMap.EntityLogicalName, _importMapId.Value);
                }

                if (_newImportMapId.HasValue)
                {
                    Console.WriteLine(String.Concat("Deleting import mapping: ", _newImportMapId.Value));
                    _serviceProxy.Delete(ImportMap.EntityLogicalName, _newImportMapId.Value);
                }

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion

        #region Main method
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new UsingExportAndImportMappings();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion
    }
}

See Also

Other Resources

Import data
Sample: Import data using complex data map
ExportMappingsImportMapRequest
ImportMappingsImportMapRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Import data using complex data map
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DataManagement\DataImport\ImportWithCreate.cs

SampleCode\CS\datamanagement\DataImport\BulkImportHelper.cs

Note
The source data for this sample is contained in the following file:

SampleCode\CS\datamanagement\DataImport\import accounts.csv

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to to create new records in Microsoft Dynamics CRM by using data import. The sample uses a complex data map.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.Collections.Generic;
using System.Linq;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;

// These namespaces are found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to define a complex mapping for importing and then use the
    /// Microsoft Dynamics CRM 2011 API to bulk import records with that mapping.
    /// </summary>
    public class ImportWithCreate
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;
        private DateTime _executionDate;

        #endregion

        /// <summary>
        /// This method first connects to the organization service. Afterwards,
        /// auditing is enabled on the organization, account entity, and a couple
        /// of attributes.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
            {
                // This statement is required to enable early bound type support.
                _serviceProxy.EnableProxyTypes();

                // Log the start time to ensure deletion of records created during execution.
                _executionDate = DateTime.Today;
                ImportRecords();
                DeleteRequiredRecords(promptforDelete);
            }
        }

        /// <summary>
        /// Imports records to Microsoft Dynamics CRM from the specified .csv file.
        /// </summary>
        public void ImportRecords()
        {
            // Create an import map.
            ImportMap importMap = new ImportMap()
            {
                Name = "Import Map " + DateTime.Now.Ticks.ToString(),
                Source = "Import Accounts.csv",
                Description = "Description of data being imported",
                EntitiesPerFile =
                    new OptionSetValue((int)ImportMapEntitiesPerFile.SingleEntityPerFile),
                EntityState = EntityState.Created
            };
            Guid importMapId = _serviceProxy.Create(importMap);

            // Create column mappings.

            #region Column One Mappings
            // Create a column mapping for a 'text' type field.
            ColumnMapping colMapping1 = new ColumnMapping()
            {
                // Set source properties.
                SourceAttributeName = "src_name",
                SourceEntityName = "Account_1",

                // Set target properties.
                TargetAttributeName = "name",
                TargetEntityName = Account.EntityLogicalName,

                // Relate this column mapping with the data map.
                ImportMapId =
                    new EntityReference(ImportMap.EntityLogicalName, importMapId),

                // Force this column to be processed.
                ProcessCode =
                    new OptionSetValue((int)ColumnMappingProcessCode.Process)
            };

            // Create the mapping.
            Guid colMappingId1 = _serviceProxy.Create(colMapping1);
            #endregion

            #region Column Two Mappings
            // Create a column mapping for a 'lookup' type field.
            ColumnMapping colMapping2 = new ColumnMapping()
            {
                // Set source properties.
                SourceAttributeName = "src_parent",
                SourceEntityName = "Account_1",

                // Set target properties.
                TargetAttributeName = "parentaccountid",
                TargetEntityName = Account.EntityLogicalName,

                // Relate this column mapping with the data map.
                ImportMapId =
                    new EntityReference(ImportMap.EntityLogicalName, importMapId),

                // Force this column to be processed.
                ProcessCode =
                    new OptionSetValue((int)ColumnMappingProcessCode.Process),
            };

            // Create the mapping.
            Guid colMappingId2 = _serviceProxy.Create(colMapping2);

            // Because we created a column mapping of type lookup, we need to specify lookup details in a lookupmapping.
            // One lookupmapping will be for the parent account, and the other for the current record.
            // This lookupmapping is important because without it the current record
            // cannot be used as the parent of another record.

            // Create a lookup mapping to the parent account.
            LookUpMapping parentLookupMapping = new LookUpMapping()
            {
                // Relate this mapping with its parent column mapping.
                ColumnMappingId =
                    new EntityReference(ColumnMapping.EntityLogicalName, colMappingId2),

                // Force this column to be processed.
                ProcessCode =
                    new OptionSetValue((int)LookUpMappingProcessCode.Process),

                // Set the lookup for an account entity by its name attribute.
                LookUpEntityName = Account.EntityLogicalName,
                LookUpAttributeName = "name",
                LookUpSourceCode =
                    new OptionSetValue((int)LookUpMappingLookUpSourceCode.System)
            };

            // Create the lookup mapping.
            Guid parentLookupMappingId = _serviceProxy.Create(parentLookupMapping);

            // Create a lookup on the current record's "src_name" so that this record can
            // be used as the parent account for another record being imported.
            // Without this lookup, no record using this account as its parent will be imported.
            LookUpMapping currentLookUpMapping = new LookUpMapping()
            {
                // Relate this lookup with its parent column mapping.
                ColumnMappingId =
                    new EntityReference(ColumnMapping.EntityLogicalName, colMappingId2),

                // Force this column to be processed.
                ProcessCode =
                    new OptionSetValue((int)LookUpMappingProcessCode.Process),

                // Set the lookup for the current record by its src_name attribute.
                LookUpAttributeName = "src_name",
                LookUpEntityName = "Account_1",
                LookUpSourceCode =
                    new OptionSetValue((int)LookUpMappingLookUpSourceCode.Source)
            };

            // Create the lookup mapping
            Guid currentLookupMappingId = _serviceProxy.Create(currentLookUpMapping);
            #endregion

            #region Column Three Mappings
            // Create a column mapping for a 'picklist' type field
            ColumnMapping colMapping3 = new ColumnMapping()
            {
                // Set source properties
                SourceAttributeName = "src_addresstype",
                SourceEntityName = "Account_1",

                // Set target properties
                TargetAttributeName = "address1_addresstypecode",
                TargetEntityName = Account.EntityLogicalName,

                // Relate this column mapping with its parent data map
                ImportMapId =
                    new EntityReference(ImportMap.EntityLogicalName, importMapId),

                // Force this column to be processed
                ProcessCode =
                    new OptionSetValue((int)ColumnMappingProcessCode.Process)
            };

            // Create the mapping
            Guid colMappingId3 = _serviceProxy.Create(colMapping3);

            // Because we created a column mapping of type picklist, we need to specify picklist details in a picklistMapping
            PickListMapping pickListMapping1 = new PickListMapping()
            {
                SourceValue = "bill",
                TargetValue = 1,

                // Relate this column mapping with its column mapping data map
                ColumnMappingId =
                    new EntityReference(ColumnMapping.EntityLogicalName, colMappingId3),

                // Force this column to be processed
                ProcessCode =
                    new OptionSetValue((int)PickListMappingProcessCode.Process)
            };

            // Create the mapping
            Guid picklistMappingId1 = _serviceProxy.Create(pickListMapping1);

            // Need a picklist mapping for every address type code expected
            PickListMapping pickListMapping2 = new PickListMapping()
            {
                SourceValue = "ship",
                TargetValue = 2,

                // Relate this column mapping with its column mapping data map
                ColumnMappingId =
                    new EntityReference(ColumnMapping.EntityLogicalName, colMappingId3),

                // Force this column to be processed
                ProcessCode =
                    new OptionSetValue((int)PickListMappingProcessCode.Process)
            };

            // Create the mapping
            Guid picklistMappingId2 = _serviceProxy.Create(pickListMapping2);
            #endregion

            // Create Import
            Import import = new Import()
            {
                // IsImport is obsolete; use ModeCode to declare Create or Update.
                ModeCode = new OptionSetValue((int)ImportModeCode.Create),
                Name = "Importing data"
            };
            Guid importId = _serviceProxy.Create(import);

            // Create Import File.
            ImportFile importFile = new ImportFile()
            {
                Content = BulkImportHelper.ReadCsvFile("Import Accounts.csv"), // Read contents from disk.
                Name = "Account record import",
                IsFirstRowHeader = true,
                ImportMapId = new EntityReference(ImportMap.EntityLogicalName, importMapId),
                UseSystemMap = false,
                Source = "Import Accounts.csv",
                SourceEntityName = "Account_1",
                TargetEntityName = Account.EntityLogicalName,
                ImportId = new EntityReference(Import.EntityLogicalName, importId),
                EnableDuplicateDetection = false,
                FieldDelimiterCode =
                    new OptionSetValue((int)ImportFileFieldDelimiterCode.Comma),
                DataDelimiterCode =
                    new OptionSetValue((int)ImportFileDataDelimiterCode.DoubleQuote),
                ProcessCode =
                    new OptionSetValue((int)ImportFileProcessCode.Process)
            };

            // Get the current user to set as record owner.
            WhoAmIRequest systemUserRequest = new WhoAmIRequest();
            WhoAmIResponse systemUserResponse =
                (WhoAmIResponse)_serviceProxy.Execute(systemUserRequest);

            // Set the owner ID.
            importFile.RecordsOwnerId =
                new EntityReference(SystemUser.EntityLogicalName, systemUserResponse.UserId);

            Guid importFileId = _serviceProxy.Create(importFile);

            // Retrieve the header columns used in the import file.
            GetHeaderColumnsImportFileRequest headerColumnsRequest = new GetHeaderColumnsImportFileRequest()
            {
                ImportFileId = importFileId
            };
            GetHeaderColumnsImportFileResponse headerColumnsResponse =
                (GetHeaderColumnsImportFileResponse)_serviceProxy.Execute(headerColumnsRequest);

            // Output the header columns.
            int columnNum = 1;
            foreach (string headerName in headerColumnsResponse.Columns)
            {
                Console.WriteLine("Column[" + columnNum.ToString() + "] = " + headerName);
                columnNum++;
            }

            // Parse the import file.
            ParseImportRequest parseImportRequest = new ParseImportRequest()
            {
                ImportId = importId
            };
            ParseImportResponse parseImportResponse =
                (ParseImportResponse)_serviceProxy.Execute(parseImportRequest);
            Console.WriteLine("Waiting for Parse async job to complete");
            BulkImportHelper.WaitForAsyncJobCompletion(_serviceProxy, parseImportResponse.AsyncOperationId);
            BulkImportHelper.ReportErrors(_serviceProxy, importFileId);

            // Retrieve the first two distinct values for column 1 from the parse table.
            // NOTE: You must create the parse table first using the ParseImport message.
            // The parse table is not accessible after ImportRecordsImportResponse is called.
            GetDistinctValuesImportFileRequest distinctValuesRequest = new GetDistinctValuesImportFileRequest()
            {
                columnNumber = 1,
                ImportFileId = importFileId,
                pageNumber = 1,
                recordsPerPage = 2,
            };
            GetDistinctValuesImportFileResponse distinctValuesResponse =
                (GetDistinctValuesImportFileResponse)_serviceProxy.Execute(distinctValuesRequest);

            // Output the distinct values.  In this case: (column 1, row 1) and (column 1, row 2).
            int cellNum = 1;
            foreach (string cellValue in distinctValuesResponse.Values)
            {
                Console.WriteLine("(1, " + cellNum.ToString() + "): " + cellValue);
                Console.WriteLine(cellValue);
                cellNum++;
            }

            // Retrieve data from the parse table.
            // NOTE: You must create the parse table first using the ParseImport message.
            // The parse table is not accessible after ImportRecordsImportResponse is called.
            RetrieveParsedDataImportFileRequest parsedDataRequest = new RetrieveParsedDataImportFileRequest()
            {
                ImportFileId = importFileId,
                PagingInfo = new PagingInfo()
                {
                    // Specify the number of entity instances returned per page.
                    Count = 2,
                    // Specify the number of pages returned from the query.
                    PageNumber = 1,
                    // Specify a total number of entity instances returned.
                    PagingCookie = "1"
                }
            };

            RetrieveParsedDataImportFileResponse parsedDataResponse =
                (RetrieveParsedDataImportFileResponse)_serviceProxy.Execute(parsedDataRequest);

            // Output the first two rows retrieved.
            int rowCount = 1;
            foreach (string[] rows in parsedDataResponse.Values)
            {
                int colCount = 1;
                foreach (string column in rows)
                {
                    Console.WriteLine("(" + rowCount.ToString() + "," + colCount.ToString() + ") = " + column);
                    colCount++;
                }
                rowCount++;
            }

            // Transform the import
            TransformImportRequest transformImportRequest = new TransformImportRequest()
            {
                ImportId = importId
            };
            TransformImportResponse transformImportResponse =
                (TransformImportResponse)_serviceProxy.Execute(transformImportRequest);
            Console.WriteLine("Waiting for Transform async job to complete");
            BulkImportHelper.WaitForAsyncJobCompletion(_serviceProxy, transformImportResponse.AsyncOperationId);
            BulkImportHelper.ReportErrors(_serviceProxy, importFileId);

            // Upload the records.
            ImportRecordsImportRequest importRequest = new ImportRecordsImportRequest()
            {
                ImportId = importId
            };
            ImportRecordsImportResponse importResponse =
                (ImportRecordsImportResponse)_serviceProxy.Execute(importRequest);
            Console.WriteLine("Waiting for ImportRecords async job to complete");
            BulkImportHelper.WaitForAsyncJobCompletion(_serviceProxy, importResponse.AsyncOperationId);
            BulkImportHelper.ReportErrors(_serviceProxy, importFileId);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool toBeDeleted = true;

            if (prompt)
            {
                // Ask the user if the created entities should be deleted.
                Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();
                if (answer.StartsWith("y") ||
                    answer.StartsWith("Y") ||
                    answer == String.Empty)
                {
                    toBeDeleted = true;
                }
                else
                {
                    toBeDeleted = false;
                }
            }

            if (toBeDeleted)
            {
                // Retrieve all account records created in this sample.
                QueryExpression query = new QueryExpression()
                {
                    EntityName = Account.EntityLogicalName,
                    Criteria = new FilterExpression()
                    {
                        Conditions =
                        {
                            new ConditionExpression("createdon", ConditionOperator.OnOrAfter, _executionDate),
                        }
                    },
                    ColumnSet = new ColumnSet(false)
                };
                var accountsCreated = _serviceProxy.RetrieveMultiple(query).Entities;

                // Delete all records created in this sample.
                foreach (var account in accountsCreated)
                {
                    _serviceProxy.Delete(Account.EntityLogicalName, account.Id);
                }

                Console.WriteLine("Entity record(s) have been deleted.");
            }
        }
        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                var app = new ImportWithCreate();
                app.Run(config, true);
            }

            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Other Resources

Import data
GetHeaderColumnsImportFileRequest
ParseImportRequest
GetDistinctValuesImportFileRequest
RetrieveParsedDataImportFileRequest
TransformImportRequest
ImportRecordsImportRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Package and distribute extensions using solutions

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, solutions give you a framework for packaging, installing, and uninstalling components that provide specific business functionality. Solutions are used primarily by ISVs and other Microsoft Dynamics CRM solution providers.

In This Section

Introduction to solutions

Plan for solution development

Dependency tracking for solution components

Create, export, or import an unmanaged solution

Create, install, and update a managed solution

Uninstall or delete a solution

Create solutions that support multiple languages

Solution entities

Work with solutions

Sample: Work with solutions

Sample: Detect solution dependencies

Related Sections

Developer overview

Model your business data

Developer tools

Write applications and server extensions

Write client application extensions

Write plug-ins to extend business processes

Write workflows to automate business processes

Developers guide to reports for Microsoft Dynamics CRM

Manage your data

Developers guide to customization for Microsoft Dynamics CRM

Extend Microsoft Dynamics CRM for Outlook

Integrate SharePoint with Microsoft Dynamics CRM

Advanced development

Sample code directory

Programming reference

Use the IOrganizationService web service to read and write data or metadata

Developers guide to customization for Microsoft Dynamics CRM

Publish customizations

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Introduction to solutions

Solutions are how customizers and developers author, package, and maintain units of software that extend Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Customizers and developers distribute solutions so that organizations can use Microsoft Dynamics CRM to install and uninstall the business functionality defined by the solution.

In This Topic

Extensibility choices

Version compatibility

Solution components

Unmanaged and managed solutions

Managed properties

Conflict resolution

Dependency tracking

Support for multiple languages

Extensibility choices

Use solutions to extend the capability of Microsoft Dynamics CRM. For software that operates outside the application, use traditional methods to package and install your application, such as an installer program.

If your application consists only of Microsoft Dynamics CRM solution components, it can be imported directly into CRM. You won’t have to create an installer program.

An application with external components

However, if your extensions include a combination of Microsoft Dynamics CRM solution components and external components, which are not Microsoft Dynamics CRM solution components, you’ll need an installer.

For example, you can create a .NET Framework application that manages data stored in custom Microsoft Dynamics CRM entities using the web service APIs. People who install your application may install a Microsoft Dynamics CRM solution to create the custom entities and then install your application separately by using an installer. Or, you could include the installation of the Microsoft Dynamics CRM solution into the installer you create for your application.

Version compatibility

Solutions exported from an earlier version of CRM can be imported into later versions as shown in the following chart.

CRM 2015 Solution Compatiblity

Generally, solutions can be imported into organizations less than two versions higher than the version the solution was exported from. Service pack releases will provide the option to either export a solution with compatibility for that service pack, or just with capabilities included in the base version. More information: Maintain managed solutions: Version compatibility.

For Microsoft Dynamics CRM 2013 Service Pack 1 (SP1), enhanced service capabilities were included for new Microsoft Dynamics CRM Online organizations and existing Microsoft Dynamics CRM organizations had the option to install these capabilities. Solutions exported from organizations with the enhanced service capabilities cannot be installed into a CRM 2013 SP1 organization without the enhanced service capabilities enabled unless the solution is exported using the option to choose compatibility for the base version. More information: Detect enhanced service capabilities available with product updates

Solution components

Solution components are created by using the customization tools or APIs included in Microsoft Dynamics CRM and are fully hosted in the application. The following diagram shows the types of solution components.

When you define a CRM solution you create a group of solution components that can be managed together.

Note
Solutions can only add new solution components or overwrite existing solution components. Solutions can’t be used to delete solution components.

Unmanaged and managed solutions

There are two types of Microsoft Dynamics CRM solutions: managed and unmanaged. A managed solution is a completed solution that is intended to be distributed and installed. An unmanaged solution is one that is still under development or isn’t intended to be distributed. When the unmanaged solution is complete and you want to distribute it, export it and package it as a managed solution.

The following diagram introduces how managed and unmanaged solutions interact with the system solution to control application behavior.

System solution

The system solution represents the solution components defined within Microsoft Dynamics CRM. Without any managed solutions or customizations, the system solution defines the default application behavior.

Many of the components in the system solution are customizable and can be used in managed solutions or unmanaged customizations.

Managed solutions

Managed solutions are installed on top of the system solution and can modify any customizable solution components or add more solution components.

Managed solutions can also be layered on top of other managed solutions. As long as a managed solution enables customization of its solution components, other managed solutions can be installed on top of it and modify any customizable solution components that it provides.

Unmanaged customizations

All customizable solution components provided by the system solution or any managed solutions can be customized in the unmanaged customizations.

Unmanaged solutions

Unmanaged solutions are groups of unmanaged customizations. Any unmanaged customized solution component can be associated with any number of unmanaged solutions.

You create a managed solution by exporting an unmanaged solution and selecting to package it as a managed solution.

Application behavior

The ultimate behavior of an instance of Microsoft Dynamics CRM for a specific organization is the culmination of the system solution, any managed solutions, and any unmanaged customizations.

Unmanaged solutions

When a solution is unmanaged, you can perform the following actions:

  • Add components.
  • Remove components.
  • Delete components that allow for deletion.
  • Export and import the unmanaged solution.
  • Export the solution as a managed solution.

More information: Create, export, or import an unmanaged solution

Importing unmanaged solutions

When you import an unmanaged solution, you can edit its components in the new organization.

Important
When you import an unmanaged solution, the definitions of any solution components that already are in the organization will be overwritten. You can’t undo this action.

Unmanaged customizations

Each Microsoft Dynamics CRM organization contains customizable solution components. Together, all of these solution components are called the default solution. This is the solution you edit when you select Customize the System in the application. You can export this solution and the customizations in it in just like an unmanaged solution. However, you can’t export the default solution as a managed solution.

Create an unmanaged solution

If you don’t intend to generate a managed solution, you don’t have to create an unmanaged solution. You can customize the system directly. Organizations that just want to be able to edit, back up, and transport their customizations don’t have to use the more advanced capabilities of the Microsoft Dynamics CRM solutions framework.

When you create an unmanaged solution, you create a way to group a subset of the available customizable solution components. The solution components in an unmanaged solution are references to customizable solution components in the organization.

After you create an unmanaged solution, you can add solution components to it. By using this smaller set of components you can decide to only include those solution components that are relevant to a particular functionality. This allows for a smaller size package when you export your solution and makes a more manageable set of components.

Any components you add to your unmanaged solution are included in the customizable solution components for the system. Unmanaged solution components can be added to multiple unmanaged solutions.

Important
Because each unmanaged solution contains a reference to the shared group of solutions, changes you make to solution components in one solution are also applied for all unmanaged solutions that reference those solution components.

Tip
You can also create unmanaged solutions just to provide convenient access to specific solution components. For example, you may use lots of HTML web resources but only some of them represent top-level user interface elements in your solution. You may want to create an unmanaged solution that includes only those top-level user interface components so that you can locate and open them easily.

Solution publisher for unmanaged solutions

Each solution requires a solution publisher. For an unmanaged solution, the solution publisher provides a common customization prefix and option value prefix. More information: Create a Solution Publisher

Many solutions can be associated with a single solution publisher. Each organization will have a solution publisher called “Default Publisher for <OrganizationUniqueName>”. If you want all your unmanaged solutions to share the same customization prefix and option value prefix, we recommend that you just associate your unmanaged solutions with the default publisher for your organization.

Note
The solution publisher controls how managed solutions can be updated. When you install a managed solution, the publisher is visible but you can’t associate an unmanaged solution with it. If you intend to distribute a managed solution, see Solution Publisher for managed solutions.

Delete an unmanaged solution

If you delete an unmanaged solution, you just delete the group used to contain references to solution components. The solution components in an unmanaged solution remain in the system but they are no longer associated with the unmanaged solution you delete.

Note
If you delete a solution component in an unmanaged solution, it is deleted from the system and is no longer available from any other unmanaged solution. Use “remove” instead of “delete” if you just want to remove a solution component from an unmanaged solution.

Managed solutions

If you intend to distribute your solution as a managed solution, export your unmanaged solution and select the Managed option in the Package Type dialog box.

Note
After you generate a managed solution, you can’t install it in the same Microsoft Dynamics CRM organization that contains the unmanaged solution used to create it. It must be installed in a different organization.

After you install a managed solution, the following applies:

  • You can’t add or remove solution components in a managed solution.
  • You can’t export a managed solution.
  • Deleting a managed solution uninstalls all the solution components in it.

For more information about the specific tasks you can perform with managed solutions, see Create, install, and update a managed solution.

After you install a managed solution you may be able to customize the solution components if the creator of the managed solution has configured the managed solution to enable it. You must access the customizable solution components using Customize the System instead of through the managed solution itself.

Whether a solution component is customizable and what specific customization actions are enabled is controlled by using Managed Properties.

Solution publisher for managed solutions

When you intend to distribute managed solutions, the solution publisher record associated with your managed solution is created in each organization that installs your solution. Use the solution publisher to provide information about how people who install your solution can contact you.

The solution publisher for a managed solution is also important if you want to release an update to your managed solution. If you use the same solution publisher you can create a new managed solution with the ability to update a managed solution you previously released. More information: Maintain managed solutions

Managed properties

Using managed properties, the creator of a managed solution can control whether a solution component is customizable and which specific parts of it can be customized.

Note
Managed properties must be set in an unmanaged solution. The managed property settings are only applied after the managed solution has been packaged and installed.

The exact managed properties available depend on the type of solution component. The following screenshot shows the managed properties for a custom entity.

Managed properties for an entity

By default, the managed property settings assume that any kind of solution component is fully customizable. Solution developers are encouraged to enable solution components in their solutions to be customizable. However, there are situations where the definition of a solution component must be ”locked down” to avoid potential breaking changes or to make future maintenance of the solution component easier.

More information: Use managed properties

Conflict resolution

When two or more solutions define solution components differently, Microsoft Dynamics CRM resolves the conflict using two strategies, Merge and Top Wins. The following diagram illustrates the differences.

Two Solution conflict resolution strategies

Merge

User interface components (command bar, ribbons, forms, and site map) are merged. This means that the solution components are re-calculated from the lowest level to the highest so that the organization’s unmanaged customizations are the last to be applied.

Top Wins

For all other solution components any conflict is calculated in favor of the customization that is applied last. For managed solutions this usually means that the last solution installed is applied. However, there is a special case when an update to a managed solution is installed.

Conflict resolution on the update of a managed solution

Because unmanaged customizations are considered ”above” any managed solution in terms of conflict resolution, organizations installing an update to a managed solution may not see their changes applied because of unmanaged modifications. An option exists to make sure that changes applied by an update to a managed solution are available.

When you release an update to a managed solution, the organization installing the update can select:

  • To preserve any customizations it has applied on top of your managed solution.
  • To overwrite any customizations it has applied on top of your managed solution.

Organizations installing an update to a managed solution should work with the managed solution creator to evaluate which option is best.

Important
Changes to entity forms and the sitemap won’t be overwritten even when the overwrite option is selected. Refer to Merge Form Customizations and Merge Navigation (SiteMap) Customizations for guidance about managing changes. Some manual customization may be required to merge unmanaged customizations into changes included in an update to a managed solution.

Dependency tracking

The solutions framework automatically tracks dependencies for solution components. Every operation on a solution component automatically calculates any dependencies to other components in the system. The dependency information is used to maintain the integrity of the system and prevent operations that would lead to an inconsistent state.

As a result of dependency tracking, the following behaviors are enforced:

  • Deleting a component is prevented if another component in the system depends on it.
  • Exporting a solution warns the user if there are any missing components that could potentially cause failure when importing that solution in another system.
    Warnings during export can be ignored if the solution developer intends that the solution is only to be installed in an organization where dependent components are expected to exist. For example, when you’re creating a solution that’s designed to be installed over a pre-installed “base” solution.
  • Importing a solution fails if all required components aren’t included in the solution and also don’t exist in the target system.
    • Additionally, when you import a managed solution, all required components must match the package type of the solution. A component in a managed solution can only depend on another managed component.

More information: Dependency tracking for solution components

Support for multiple languages

Microsoft Dynamics CRM natively supports multiple languages. Whenever a language pack (sometimes referred to as a ”MUI pack”) is installed, user interface elements can be displayed in a different language.

There are a number of different tactics you should apply based on the type of solution components included in your solution. More information: Create solutions that support multiple languages

See Also

Concepts

Dependency tracking for solution components
Create, export, or import an unmanaged solution
Create, install, and update a managed solution
Uninstall or delete a solution
Create solutions that support multiple languages
Work with solutions

Other Resources

Package and distribute extensions using solutions
Plan for solution development
Solution entities
Sample: Work with solutions
Sample: Detect solution dependencies
Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Plan for solution development

Solutions introduce factors to take into consideration during your planning. The following topics introduce strategies to use while planning your solution development efforts.

In This Section

Organize your solutions

Organize your team to develop solutions

Understand how managed solutions are merged

Use managed properties

Maintain managed solutions

Register your solution with the Microsoft Dynamics Marketplace

Related Sections

Package and distribute extensions using solutions

Introduction to solutions

Dependency tracking for solution components

Create, export, or import an unmanaged solution

Create, install, and update a managed solution

Uninstall or delete a solution

Solution entities

Work with solutions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Organize your solutions

Before you create solutions, take some time to plan ahead. For example, think about how many solutions you want to release and whether the solutions will share components.

Also, determine how many Microsoft Dynamics CRM organizations you’ll need to develop your line of solutions. You can use a single organization for most strategies described in this topic. However, if you choose to have only one organization and later realize that you need more, it can be challenging to change the solutions if people have already installed them. Using multiple organizations, although introducing more complexity, can provide better flexibility.

Strategies to organize your solutions

The following are some strategies for creating solutions listed in order from simplest to most complex:

  • No custom solutions
  • Single solution
  • Multiple solutions
  • Multiple solutions with shared components
  • Solution libraries

No custom solutions

You don’t have to create solutions. You can customize Microsoft Dynamics CRM directly by using the default solution.

You can still export your default solution as an unmanaged solution to transport it between organizations.

Tip
If you change the customization prefix for the default publisher to a value that matches a publisher you may want to create in the future, any new customizations that you create will include this customization prefix in the name. This way, if you choose to use solutions, you can add the customizations that you created in your default solution to an unmanaged solution so they can have consistent names.

Single solution

By creating a solution, you establish a working set of customizations. This makes it easier to find items that you have customized.

This approach is recommended when you only want to create a single managed solution. If you think you may have to split up the solution in the future, consider using multiple solutions.

Multiple solutions

If you have two unrelated solutions that don’t share components, the most direct approach is to create two unmanaged solutions.

Note
It is very common in solutions to modify the application ribbons or the Sitemap. If both of your solutions modify these solution components, they are shared components. See the following section to see how to work with shared components.

Multiple solutions with shared components

You may have multiple solutions that share components. You may have a certain set of common functionality within multiple solutions and that common functionality is compatible with any of the other functionality unique to each solution. For example, you may have a set of utility plug-ins that each solution uses yet each of the separate solutions do not share any other components.

In this case, each solution can be developed in a single organization. Some components can be included in more than one solution as long as any changes that were made to them are compatible with all other solutions that use them. It is important that all the solutions share the same solution publisher. If the solution publisher is not identical, organizations will not be able to install more than one of your solutions.

Solution libraries

For an ISV with multiple solutions or a large enterprise deployment, many solution components will probably have to be shared. The best ways for solutions to share components is through solution libraries. Create a solution library by creating an unmanaged solution in a separate organization and then packaging those components into a managed solution. Install the managed solution into another organization and let developers reference these shared components.

The Microsoft Dynamics CRM Solutions Framework lets you build layers of solutions that depend on each other. Typically, you create a solution library representing a ”base” solution. Other solutions can be built on top of this base solution. This allows for cleaner separation of components. Development teams that are working on solution libraries and those working on the dependent solutions can develop at different paces. The dependent solutions must be created after the solution libraries are installed.

This requires that you create a prerequisite solution that customers must install before they can install a dependent solution. Developers working on the solution libraries can continue to work on them and update them as long as they don’t break any dependent solutions that require them.

See Also

Concepts

Organize your team to develop solutions

Other Resources

Plan for solution development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Organize your team to develop solutions

When multiple developers have to work on the same solution, you may want to create an environment where each developer can create customizations that will not interfere with the work of other developers. You may also need to move your solution from development environments to test environments and user acceptance testing (UAT) environments.

In This Topic

Strategies for Team Development

Deploy Solutions from Development through Test and Production Environments

Strategies for team development

Some strategies to manage team development of solutions are as follows:

  • Single Organization: One Master Solution
  • Single Organization: Multiple Developer Solutions + Master Solution
  • One Organization per Developer

Single organization: One master solution

Multiple developers can work on a single organization; however, they have to be careful to work on separate components. This is easier when any prerequisite managed solutions (shared libraries) are installed first.

Single organization: Multiple developer solutions + master solution

In a single organization, you can create separate unmanaged solutions for each developer. Each solution contains a sub set of a master solution. Each solution component exists in only one unmanaged solution. Developers do not add existing solution components to the unmanaged solutions assigned to them. This provides a clear separation of components that are being modified. You do not have to merge changes because each developer’s solution contains a reference to components that are contained in the master solution.

One organization per developer

Each developer can work on their own organization. To check their changes into Microsoft Dynamics CRM, they must export their solution as an unmanaged solution. The solution from each developer’s organization is then imported into a master solution. Use the master solution to export the managed solution.

Deploy solutions from development through test and production environments

In development organizations, solutions are deployed into various test and staging environments for analysis before they are deployed into a production environment. The white paper Deploying Microsoft Dynamics CRM 2011 and CRM Online Solutions from Development through Test and Production Environments explores how to deploy real-world Microsoft Dynamics CRM solutions across test and production environments in reliable and repeatable ways by using automation. The paper also highlights specific constraints that exist when you deploy and test solutions in Microsoft Dynamics CRM Online.

See Also

Concepts

Organize your solutions

Other Resources

Plan for solution development
White Paper: Deploying Microsoft Dynamics CRM 2011 and CRM Online Solutions from Development through Test and Production Environments

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Understand how managed solutions are merged

When you prepare your managed solution to be installed, remember that an organization may have multiple solutions installed or that other solutions may be installed in the future. Construct a solution that follows best practices so that your solution will not interfere with other solutions.

The processes that Microsoft Dynamics CRM uses to merge customizations emphasize maintaining the functionality of the solution. While every effort is made to preserve the presentation, some incompatibilities between customizations may require that the computed resolution will change some presentation details in favor of maintaining the customization functionality.

In This Topic

Merge form customizations

Merge navigation (SiteMap) customizations

Merge option set options

Merge form customizations

The only form customizations that have to be merged are those that are performed on any entity forms that are already in the organization. Typically, this means that form customizations only have to be merged when your solution customizes the forms that were included for entities created when Microsoft Dynamics CRM was installed. One way to avoid form merging is to provide new forms for any Microsoft Dynamics CRM entities. Forms for custom entities will not require merging unless you are creating a solution that updates or modifies an existing managed solution that created the custom entities and their forms.

When a solution is packaged as a managed solution the form definitions stored in FormXML are compared to the original FormXML and only the differences are included in the managed solution. When the managed solution is installed in a new organization, the form customization differences are then merged with the FormXML for the existing form to create a new form definition. This new form definition is what the user sees and what a system customizer can modify. When the managed solution is uninstalled, only those form elements found in the managed solution are removed.

When you add new elements to a form that is to be merged, we recommend that you include your new elements within new container elements (tabs or sections). Additions to any container will be appended to the end of the container. For example, fields added to a section will be positioned at the end of the section. It is expected that a customizer installing a solution will then modify the form to re-arrange elements after it is installed.

Managed solutions that contain forms that use new security roles depend on those roles. You should include these security roles with your managed solution. If there are security roles associated with a form that are not in the organization that the managed solution is being installed on, the installation will not fail but the forms may not be associated with any security roles. When the managed solution is uninstalled, any security roles included with it will be removed. Any forms outside the managed solution can no longer be associated with those security roles.

Note
When a managed solution entity contains multiple forms and the organization entity form also contains multiple forms, the new forms are not appended to the bottom of the list of available forms – they are interleaved with the original entity forms.

Merge navigation (SiteMap) customizations

When a solution is packaged as managed the SiteMap XML is compared to the original SiteMap XML and any other customizations made to the SiteMap. Only the differences are included in the managed solution. These differences include items that are changed, moved, added or removed. When the managed solution is installed in a new organization, the SiteMap changes are merged with the SiteMap XML found for the organization where the managed solution is being installed. A new SiteMap definition is what people see.

At this point, a customizer can export the SiteMap to an unmanaged solution and that SiteMap definition will include all the elements of the active SiteMap. A customizer can then modify the SiteMap and re-import it as an unmanaged customization. Later, if the managed solution is uninstalled, the SiteMap XML that was imported with the managed solution will be referenced to remove the changes introduced with that managed solution. A new active SiteMap is then calculated.

Whenever a new visible element is added to the SiteMap, it appears at the bottom of whatever container it belongs in. For example, a new area appears at the bottom of the Navigation area. To position the elements that have been added, you must export the SiteMap, edit it to set the precise position and then import it again as an unmanaged solution.

Note
Only one SiteMap customization can be applied between publishing. Any unpublished SiteMap customizations will be lost when a new SiteMap definition is imported.

Merge option set options

Each new option set option is initialized with an integer value assigned that includes an option value prefix. The option value prefix is a set of five digits prepended to the option value. An option value prefix is generated based on the solution publishers customization prefix but may be set to any value. The option value prefix helps differentiate new option set options created in the context of a specific solution publisher and reduces the opportunity for collisions of option values. Using the option value prefix is recommended but not required.

A managed solution usually updates or adds options for option sets that are already in the organization, for example, the account Category or Industry option sets. When a managed solution modifies the options available in an option set, all the options defined in the managed solution are available in the organization. When the managed solution is uninstalled, the option set options will be returned to their original state.

See Also

Concepts

Use managed properties
Customize entity forms
Change application navigation using the SiteMap

Other Resources

Plan for solution development
Package and distribute extensions using solutions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use managed properties

You can control which of your managed solution components are customizable by using managed properties. You should allow as much customization as possible for those solution components that represent business entities. This lets organizations customize your solution to their requirements. Limit or eliminate customization of critical solution components that provide the core functionality of your solution so that you can predictably support and maintain it.

Managed properties are intended to protect your solution from modifications that may cause it to break. Managed properties do not provide digital rights management (DRM), or capabilities to license your solution or control who may install it.

Apply managed properties

You apply managed properties when the solution is unmanaged. The managed properties will take effect after you package the managed solution and install it in a different organization. After the managed solution is installed, the managed properties cannot be updated except by an update of the solution by the original publisher.

Most solution components have a Managed Properties button when viewing a list of solution components. You can view or update the managed properties for a solution component when you click this button. To access managed properties for solutions that do not display this button, select Managed Properties from the More Actions drop-down list.

By default, all custom solution components are customizable. To change the managed properties for a solution component, click the Managed Properties button in the toolbar for the solution component. Each solution component has a Can be customized (IsCustomizable) property. As long as this property is true, more properties specific to the type of solution component can be specified. If you set the IsCustomizable.Value property to false, after the solution is installed as a managed solution the solution component will not be customizable. The following table lists the managed properties for each solution component.

Component Display Name Property

Entity

Can be customized

IsCustomizable.Value

Display name can be modified

IsRenameable.Value

Can be related entity in relationship

CanBeRelatedEntityInRelationship.Value (Read Only)

Can be primary entity in relationship

CanBePrimaryEntityInRelationship.Value (Read Only)

Can be in many-to-many relationship

CanBeInManyToMany.Value (Read Only)

New forms can be created

CanCreateForms.Value

New charts can be created

CanCreateCharts.Value

New views can be created

CanCreateViews.Value

Can change any other entity properties not represented by a managed property

CanModifyAdditionalSettings.Value

Field (Attribute)

Can be customized

IsCustomizable.Value

Display name can be modified

IsRenameable.Value

Can change requirement level

RequiredLevel.CanBeChanged

Note
RequiredLevel is the only managed property to use the CanBeChanged property.

Can change any other attribute properties not represented by a managed property

CanModifyAdditionalSettings.Value

Entity Relationship

Can be customized

IsCustomizable.Value

Form

Can be customized

SystemForm.IsCustomizable.Value

Chart

Can be customized

SavedQueryVisualization.IsCustomizable.Value

View

Can be customized

SavedQuery.IsCustomizable.Value

Option Set

Can be customized

IsCustomizable.Value

Web Resource

Can be customized

WebResource.IsCustomizable.Value

Workflow

Can be customized

Workflow.IsCustomizable.Value

Assembly

Can be customized

SdkMessageProcessingStep.IsCustomizable.Value

Assembly Registration

Can be customized

ServiceEndpoint.IsCustomizable.Value

E-mail Template

Can be customized

Template.IsCustomizable.Value

KB Article Template

Can be customized

KbArticleTemplate.IsCustomizable.Value

Contract Template

Can be customized

ContractTemplate.IsCustomizable.Value

Mail Merge Template

Can be customized

MailMergeTemplate.IsCustomizable.Value

Dashboard

Can be customized

SystemForm.IsCustomizable.Value

Security Roles

Can be customized

Role.IsCustomizable.Value

Update managed properties

After you release your managed solution, you may decide that you want to change the managed properties. You can only change managed properties to make them less restrictive. For example, after your initial release you can decide to allow customization of an entity.

You update managed properties for your solution by releasing an update to your solution with the changed managed properties. Your managed solution can only be updated by another managed solution associated with the same publisher record as the original managed solution. If your update includes a change in managed properties to make them more restrictive, those managed property changes will be ignored but other changes in the update will be applied.

Because the original publisher is a requirement to update managed properties for a managed solution, any unmanaged solution cannot be associated with a publisher that has been used to install a managed solution.

Note
This means you will not be able to develop an update for your solution by using an organization where your managed solution is installed.

Check managed properties

Use the IsComponentCustomizableRequest to check whether a solution component is customizable. Alternatively, you can check the solution component properties but you must consider that the ultimate determination of the meaning depends on the values of several properties. Each solution component has an IsCustomizable property. When a solution component is installed as part of a managed solution, the IsManaged property will be true. Managed properties are only enforced for managed solutions. When checking managed properties to determine if an individual solution component is customizable, you must check both the IsCustomizable and IsManaged properties. A solution component where IsCustomizable is false and IsManaged is false, is customizable.

Entity and attribute have more managed properties in addition to IsCustomizable. These managed properties are not updated if IsCustomizable is set to false. This means that in addition to checking the individual managed property, you must also check the IsCustomizable property to see if the managed property is being enforced.

See Also

Reference

Managed Properties

Concepts

Maintain managed solutions

Other Resources

Plan for solution development
Package and distribute extensions using solutions
IsComponentCustomizableRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Maintain managed solutions

Before you release your managed solution you should consider how you will maintain it. Uninstalling and reinstalling a managed solution is practically never an option when the solution contains entities or attributes. This is because data is lost when entities are deleted. Fortunately, solutions provide a way to update your managed solution while maintaining the data. Exactly how you update your solutions will depend on the characteristics of the solution and the requirements of the change.

In this topic

Version compatibility

Create managed solution updates

  • Release a new version of your managed solution
  • Release an update for your managed solution

Version compatibility

Any solution exported from a newer version of Microsoft Dynamics CRM cannot be imported into an older version of Microsoft Dynamics CRM. This includes major and minor versions. Solutions exported from an earlier version of CRM can be imported into later versions as shown in the following chart.

CRM 2015 Solution Compatiblity

Solutions exported from Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online versions 5 or earlier cannot be imported into Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Only solutions exported from the most recent previous major version can be imported.

You can install solutions exported from Microsoft Dynamics CRM 2013 (on-premises) and Microsoft Dynamics CRM Online version 6 into Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Solutions exported from Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update cannot be imported into earlier versions.

As additional update rollups or service updates are applied to Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, solutions exported from organizations with those updates cannot be imported into organizations which do not have those updates. More information:Introduction to Solutions: Version compatibility.

The <ImportExportXml> root element uses a SolutionPackageVersion attribute to set the value for the version that the solution is compatible with. You should not manually edit this value.

Create managed solution updates

There are two basic approaches to updating solutions:

  • Release a new version of your managed solution
  • Release an update for your managed solution

Release a new version of your managed solution

The preferred method is to release a new version of your managed solution. Using your original unmanaged source solution, you can make necessary changes and increase the version number of the solution before packaging it as a managed solution. When the organizations that use your solution install the new version, their capabilities will be upgraded to include your changes. If you want to go back to the behavior in a previous version, simply re-install the previous version. This overwrites any solution components with the definitions from the previous version but does not remove solution components added in the newer version. Those newer solution components remain in the system but have no effect because the older solution component definitions will not use them.

During the installation of a previous version of a solution Microsoft Dynamics CRM will confirm that the person installing the previous version wants to proceed.

Release an update for your managed solution

When only a small subset of solution components urgently requires a change you can release an update to address the issue. To release an update, create a new unmanaged solution and add any components from the original unmanaged source solution that you want to update. You must associate the new unmanaged solution with the same publisher record as was used for the original solution. After you finish with your changes, package the new solution as a managed solution.

When the update solution is installed in an organization where the original solution was installed the changes included in the update will be applied to the organization. If an organization needs to ‘roll back’ to the original version they can simply uninstall the update.

Any customizations applied to the solution components in the update will be overridden. When you uninstall the update they will return.

See Also

Concepts

Register your solution with the Microsoft Dynamics Marketplace

Other Resources

Plan for solution development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Register your solution with the Microsoft Dynamics Marketplace

After you create your solution, you need to make it available so that people can use it. To distribute your solutions, use the Microsoft Dynamics Marketplace. Registering your solutions on Microsoft Dynamics Marketplace is free.

The Microsoft Dynamics Marketplace allows people to find information about your solution when searching Microsoft.com. This way you can benefit from Microsoft marketing campaigns and you’ll have access to a dashboard that provides analytics and reviews from visitors.

Register your solution

When you’re ready to distribute your solution, get it tested by using Microsoft Platform Ready (MPR). The test confirms that your solution installs cleanly into Microsoft Dynamics CRM, and that it uses the supported APIs. After you register and sign in, you can create a profile for your solution and download tools to test your solution. You’ll run the tool against your solution and upload the results to MPR.

After your solution passes the test, you can log on to Pinpoint by using the Microsoft account that is associated with your Microsoft Partner Network account. There, you can use a wizard to describe your solution. You have the option to upload a single .exe, .msi, or .zip file so that people can download and try your solution.

Note
You should only distribute managed solutions using the Microsoft Dynamics Marketplace because unmanaged solutions can’t be uninstalled easily.

See Also

Other Resources

Plan for solution development
Blog: Testing Your Microsoft Dynamics CRM 2011 Application

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Dependency tracking for solution components

Solutions are made of solution components. You’ll use the Solutions area in Microsoft Dynamics CRM to create or add solution components. You can perform these actions programmatically by using the AddSolutionComponentRequest message or any messages that create or update solution components that include a SolutionUniqueName parameter.

Solution components often depend on other solution components. You can’t delete any solution component that has dependencies on another solution component. For example, a customized ribbon typically requires image or script web resources to display icons and perform actions using scripts. As long as the customized ribbon is in the solution, the specific web resources it uses are required. Before you can delete the web resources you must remove references to them in the customized ribbon. These solution component dependencies can be viewed in the application by clicking Show Dependencies.

This topic describes the types of solution components you can include in your solutions and how they depend on each other.

In This Topic

All solution components

Solution component dependencies

Check for solution component dependencies

Common solution components

All solution components

The complete list of available solutions component types is located in the system Component Type (componenttype) global option set. The supported range of values for this property is available by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project. However, many of the solution component types listed there are for internal use only and the list doesn’t provide information about the relationships between solution components.

Solution component dependencies

Solution component dependencies help make sure you have a reliable experience working with solutions. They prevent actions that you normally perform from unintentionally breaking customizations defined in a solution. These dependencies are what allow a managed solution to be installed and uninstalled simply by importing or deleting a solution.

The solutions framework automatically tracks dependencies for solution components. Every operation on a solution component automatically calculates any dependencies to other components in the system. The dependency information is used to maintain the integrity of the system and prevent operations that could lead to an inconsistent state.

As a result of dependency tracking the following behaviors are enforced:

  • Deletion of a component is prevented if another component in the system depends on it.
  • Export of a solution warns the user if there are any missing components that could cause failure when importing that solution in another system.
    Warnings during export can be ignored if the solution developer intends that the solution is only to be installed in an organization where dependent components are expected to exist. For example, when you create a solution that is designed to be installed over a pre-installed ”base” solution.
  • Import of a solution fails if all required components aren’t included in the solution and also don’t exist in the target system.
    • Additionally, when you import a managed solution all required components must match the package type of the solution. A component in a managed solution can only depend on another managed component.

There are three types of solution component dependencies:

Solution Internal

Internal dependencies are managed by Microsoft Dynamics CRM. They exist when a particular solution component can’t exist without another solution component.

Published

Published dependencies are created when two solution components are related to each other and then published. To remove this type of dependency, the association must be removed and the entities published again.

Unpublished

Unpublished dependencies apply to the unpublished version of a publishable solution component that is being updated. After the solution component is published, it becomes a published dependency.

Solution internal dependencies are dependencies where actions with a solution component require an action for another solution component. For example, if you delete an entity, you should expect that all the entity attributes will be deleted with it. Any entity relationships with other entities will also be deleted.

However, an internal dependency may lead to a published dependency and still require manual intervention. For example, if you include a lookup field on an entity form and then delete the primary entity in the relationship, you can’t complete that deletion until you remove the lookup field from the related entity form and then publish the form.

When you perform actions programmatically with solutions, you can use messages related to the Dependency entity. See Dependency entity messages and methods for messages you can use to identify dependencies that may exist before you delete a component or uninstall a solution.

Check for solution component dependencies

When you edit solutions you may find that you can’t delete a solution component because it has a published dependency with another solution component. Or, you may not be able to uninstall a managed solution because one of the components in the managed solution has been used in a customization in another unmanaged solution.

The following table lists the messages that you can use to retrieve data about solution component dependencies.

Message Description

RetrieveDependentComponentsRequest

Returns a list of dependencies for solution components that directly depend on a solution component.

For example, when you use this message for a global option set solution component, dependency records for solution components representing any option set attributes that reference the global option set solution component are returned.

When you use this message for the solution component record for the account entity, dependency records for all of the solution components representing attributes, views, and forms used for that entity are returned.

RetrieveRequiredComponentsRequest

Returns a list of the dependencies for solution components that another solution component directly depends on. This message provides the reverse of the RetrieveDependentComponentsRequest message.

RetrieveDependenciesForDeleteRequest

Returns a list of all the dependencies for solution components that could prevent deleting a solution component.

RetrieveDependenciesForUninstallRequest

Returns a list of all the dependencies for solution components that could prevent uninstalling a managed solution.

Common Solution components

These are the solution components displayed in the application and the components that you’ll work with directly when adding or removing solution components using the solution page. Each of the other types of solution components will depend on one or more of these solution components to exist.

Application Ribbons (RibbonCustomization) | Entity (Entity) | Report (Report)
Article Template (KBArticleTemplate) | Field Security Profile (FieldSecurityProfile) | SDK Message Processing Step (SDKMessageProcessingStep)
Connection Role (ConnectionRole) | Mail Merge Template (MailMergeTemplate) | Security Role (Role)
Contract Template (ContractTemplate) | Option Set (OptionSet) | Service Endpoint (ServiceEndpoint)
Dashboard or Entity Form (SystemForm) | Plug-in Assembly (PluginAssembly) | Site Map (SiteMap)
Email Template (EmailTemplate) | Process (Workflow) | Web Resource (WebResource)

Application ribbons (RibbonCustomization)

Ribbon customizations for the application ribbon and entity ribbon templates. Application ribbons don’t include definitions of ribbons at the entity or form level.

Custom application ribbons frequently have published dependencies on web resources. Web resources are used to define ribbon button icons and JScript functions to control when ribbon elements are displayed or what actions are performed when a particular ribbon control is used. Dependencies are only created when the ribbon definitions use the $webresource: directive to associate the web resource to the ribbon. More information: $webresource directive

Article template (KBArticleTemplate)

Template that contains the standard attributes of an article. There is always an internal dependency between the article template and the KbArticle entity.

Connection role (ConnectionRole)

Role describing a relationship between a two records. Each connection role defines what types of entity records can be linked using the connection role. This creates a published dependency between the connection role and the entity.

Contract template (ContractTemplate)

Template that contains the standard attributes of a contract. There is always an internal dependency between the contract template and the contract entity.

Dashboard or entity form (SystemForm)

System form entity records are used to define dashboards and entity forms. When a SystemForm is used as an entity form there is an internal dependency on the entity. When a SystemForm is used as a dashboard there are no internal dependencies. Both entity forms and dashboards commonly have published dependencies related to their content. An entity form may have lookup fields that depend on an entity relationship. Both dashboards and entity forms may contain charts or subgrids that will create a published dependency on a view, which then has an internal dependency on an entity. A published dependency on web resources can be created because of content displayed within the dashboard or form or when a form contains JScript libraries. Entity forms have published dependencies on any attributes that are displayed as fields in the form.

Email template (EmailTemplate)

Template that contains the standard attributes of an email message. An email template typically includes fields that insert data from specified entity attributes. An email template can be linked to a specific entity when it is created so there can be an internal dependency on the entity. A global email template isn’t associated with a specific entity, but it may have published dependencies on entity attributes used to provide data. A process (workflow) frequently is configured to send an email using an email template creating a published dependency with the workflow.

Entity (Entity)

The primary structure used to model and manage data in Microsoft Dynamics CRM. Charts, forms, entity relationships, views, and attributes associated with an entity are deleted automatically when the entity is deleted because of the internal dependencies between them. Entities frequently have published dependencies with processes, dashboards, and email templates.

Field security profile (FieldSecurityProfile)

Profile that defines the access level for secured attributes.

Mail merge template (MailMergeTemplate)

Template that contains the standard attributes of a mail merge document. A mail merge template has a published dependency on the entity it’s associated with.

Option set (OptionSet)

An option set defines a set of options. A picklist attribute uses an option set to define the options provided. Several picklist attributes may use a global option set so that the options they provide are always the same and can be maintained in one place. A published dependency occurs when a picklist attribute references a global option set. You can’t delete a global option set that is being used by a picklist attribute.

Plug-in assembly (PluginAssembly)

Assembly that contains one or more plug-in types. Plug-ins are registered to events that are typically associated with an entity. This creates a published dependency.

Process (Workflow)

Set of logical rules that define the steps necessary to automate a specific business process, task, or set of actions to be performed. Processes provide a wide range of actions that create published dependencies on any other solution component referenced by the process. Each process also has a published dependency on the entity it’s associated with.

Report (Report)

Data summary in an easy-to-read layout. A report has published dependencies on any entity or attribute data included in the report. Each report must also be associated with a Report category creating an internal dependency on a solution component called Report Related Category (ReportCategory). Reports may be configured to be subreports creating a published dependency with the parent report.

SDK message processing step (SDKMessageProcessingStep)

Stage in the execution pipeline that a plug-in is to execute.

Security role (Role)

Grouping of security privileges. Users are assigned roles that authorize their access to the Microsoft Dynamics CRM system. Entity forms can be associated with specific security roles to control who can view the form. This creates a published dependency between the security role and the form.

Note
Only security roles from the organization business unit can be added to a solution. Only a user with read access to those security roles can add them to a solution.

Service endpoint (ServiceEndpoint)

Service endpoint that can be contacted.

Site map (SiteMap)

XML data used to control the application navigation pane. The site map may be linked to display an HTML web resource or an icon in the site map may use an image web resource. When the $webresource: directive is used to establish these associations a published dependency is created. More information: $webresource directive

Web resource (WebResource)

Data equivalent to files used in web development. Web resources provide client-side components that are used to provide custom user interface elements. Web resources may have published dependencies with entity forms, ribbons and the SiteMap. When the $webresource: directive is used to establish associations in a ribbon or the SiteMap, a published dependency is created. For more information, see $webresource directive.

Note
Web resources may depend on other web resources based on relative links. For example, an HTML web resource may use a CSS or script web resource. A Silverlight web resource displayed outside of an entity form or chart must have an HTML web resource to host it. These dependencies aren’t tracked as solution dependencies.

See Also

Concepts

Introduction to solutions
Create, export, or import an unmanaged solution
Create, install, and update a managed solution
Create, install, and update a managed solution
Uninstall or delete a solution

Other Resources

Package and distribute extensions using solutions
Plan for solution development
Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create, export, or import an unmanaged solution

In addition to being a prerequisite to creating a managed solution, an unmanaged solution is useful as a way to group a set of unmanaged customizations into a set that can be transported between organizations.

For more information, see the Customization Guide topic: Using Solutions.

In This Topic

Create an unmanaged solution

Export an unmanaged solution

Import an unmanaged solution

Create an unmanaged solution

Every solution requires a publisher. If you do not intend to distribute your solution, you can use the default publisher already created for your organization. See Create a Solution Publisher for information about how to create a solution publisher.

The following table lists the fields and descriptions that a solution contains.

Field Label | Description
Display Name | The name for the solution.
Name | Microsoft Dynamics CRM generates a unique name is based on the Display Name. You can edit the unique name. The unique name must only contain alphanumeric characters or the underscore character.
Publisher | Use the Publisher lookup to associate the solution with a publisher.
Version | Specify a version with the following format: major.minor.build.revision, for example: 1.0.0.0.
Configuration Page | If you include an HTML Web resource in your solution, you can use this lookup to add it as your designated configuration page. More information: Use the Solution Configuration Page
Description | Use this field to include any relevant details about your solution.

After you create an unmanaged solution you can add solution components by creating them in the context of this solution or by adding existing components from other solutions. For more information abouthow to create a solution programmatically, see Create a Solution

Create a solution publisher

If you want to distribute managed solutions, you should create a Publisher. The following table lists the fields and descriptions that a Publisher contains.

Label Description

Display Name

The name that to display in the Publisher lookup field in the solution.

Name

Microsoft Dynamics CRM generates a unique name is based on the Display Name. The unique name can only contain alphanumeric characters and the underscore character.

Note
You use the Unique Name to uniquely identify a Publisher. Managed solutions that share the same publisher can update each other.

Description

Use this field to include any relevant details about your solution.

Prefix

The customization prefix helps you identify which publisher added a solution component. For example the prefix is added to the logical name of any entities or attributes created in the context of a solution associated with this publisher. The prefix must be between two and eight characters long, and can contain only alphanumeric characters. It cannot start with ‘mscrm’.

Option Value Prefix

This value lets you help separate options that you add to option sets to support merging options. A value is auto-generated based on the Prefix text to help make it more unique. The value must be between 10,000 and 99,999.

More information: Merging Option set options

Contact Details

Use these fields to add information that will enable people who install the solution to contact you.

See Create a Publisher for information about how to create a publisher programmatically.

Use the Solution Configuration page

The solution configuration page provides a canvas you can use to display information or enable customers to perform actions in the context of your solution. Set the configuration page by using the Configuration Page lookup field to select a Web Page (HTML) Web resource included in the solution. This will cause a new Configuration node to appear in the Solution window underneath the Information node and above the Components node. The Configuration node will display the Web resource you set.

You can use the solution configuration page to display controls that will configure your solution. For example, you may provide some entities in your solution that control the behavior of your solution. By using the OData endpoint for Microsoft Dynamics CRM, you can provide custom controls on your Web resource page to update data in these entities.

Export an unmanaged solution

You may want to export an unmanaged solution in the following situations:

  • You have to edit certain XML content in the customizations.xml file, for example, you may want to edit the SiteMap or create customized ribbons.
  • You want to transport your unmanaged solution from one organization to another.
  • You want to create a backup of your current set of customizations.

Exporting an unmanaged solution will create a compressed (zipped) file that can then be imported into another organization or the same organization.

Only published customizations are included when you export a solution, so be sure to publish any changes before you export a solution.

When you export a solution by using the web application, if your solution contains any missing required components, you will see the Missing Required Components step. You can disregard this warning only if you intend to import this as an unmanaged solution back into the original organization. Otherwise, follow the instructions in the dialog box to cancel the export and add the required components.

Use the ExportSolutionRequest message to programmatically export a solution. More information: Export or Package a Solution

When you export a solution by using the web application, in the Export System Settings (Advanced) step, you can choose which system settings to include in your solution. These options are available to developers by using the ExportSolutionRequest via the members available in the request. See the remarks for the request for details about which settings are included.

Import an unmanaged solution

You should import an unmanaged solution in the following situations:

  • You want to transport a set of customizations from one organization to another, and you want to allow the solution components to be changed.
  • You want to restore or revert to an earlier set of solution component definitions

Importing an unmanaged solution is an additive process. Importing an older version of a managed solution will not remove solution components included in a newer version. However the definition of any solution component properties will be overwritten with the definition included in the last unmanaged solution you import.

Important
Changes applied by importing an unmanaged solution cannot be uninstalled. Do not install an unmanaged solution if you want to roll back the changes.

This operation is performed programmatically by using the ImportSolutionRequest message. You can write code to execute this message asynchronously. More information: Execute messages in the background (asynchronously). You can track the progress of the import or generate a report of the success of the import by using the ImportJob entity. More information: Install or Upgrade a Solution

Important
Installing a solution or publishing customizations can interfere with normal system operation. We recommend that you schedule solution imports when it’s least disruptive to users.

Maximum size of solution to import

For Microsoft Dynamics CRM Online the maximum size for a solution is 29.296 MB.

For on-premises organizations, the default maximum size for a solution is 6 MB, but this can be increased as needed.

Change the maximum allowed size by editing the <httpRuntime> element in the web.config file for the application. Edit the executionTimeout and maxRequestLength attributes to allow for the necessary size. After you finish installing the solution you can set it to the size you want.

See Also

Reference

Customization solutions file schema

Concepts

Create, install, and update a managed solution
Uninstall or delete a solution

Other Resources

Plan for solution development
Package and distribute extensions using solutions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create, install, and update a managed solution

You create a managed solution by exporting an unmanaged solution as a managed solution. The organizations that use your managed solution will install it and any updates that you create for it.

For more information, see the Customization Guide topic: Use solutions for your customizations.

In This Topic

Create a managed solution

Install a managed solution

Update a managed solution

Create a managed solution

Before you can create a managed solution you must first create an unmanaged solution. For more information about how to create an unmanaged solution, see Create an Unmanaged Solution.

You create a managed solution by selecting the Managed option in the Package Type dialog box when exporting the solution.

A managed solution only includes any customizable solution components that have been customized. Not only does this prevent unintentionally changing existing solution components on the system where the solution is installed, it also keeps the size of the managed solution smaller.

Before the final step of creating a managed solution, you must decide whether there are any customization capabilities that you do not want to allow people who install your managed solution to perform. Each solution component contains a set of managed properties that control which customization capabilities you want to allow. The default settings allow all customization capabilities. More information: Use managed properties

You can create a managed solution programmatically by using the ExportSolutionRequest message. More information: Export or Package a Solution

Important
You should not import a managed solution back into the organization you used to create it.

Install a managed solution

You install a managed solution in the same way you import an unmanaged solution. The difference is in how the solution has been packaged.

Important
Installing a solution or publishing customizations can interfere with normal system operation. We recommend that you schedule solution imports when it’s least disruptive to users.

If the solution did not import successfully, you can click Download Log in the dialog box to download a report that will provide information about errors that occurred that prevented successful import of the managed solution. This file is an XML document configured to be opened by using Microsoft Office Excel.

You can import or update a managed solution programmatically by using the ImportSolutionRequest message. When using this message, you can request a reference to an ImportJob entity record that will include details about the success of the import. More information: Install or Upgrade a Solution

The ImportSolutionRequest can be called using the ExecuteAsyncRequest. More information: Execute messages in the background (asynchronously)

There are limits to the size of a solution you can install. More information: Maximum Size of Solution to Import

Update a managed solution

When you install a managed solution that already exists in the organization, the import solution dialog will provide the following options:

Maintain customizations (recommended)

This option maintains any unmanaged customizations performed on components, but also implies that some of the updates included in this solution will not take effect.

Overwrite customizations

This option overwrites any unmanaged customizations previously performed on components included in this solution. All updates included in this solution will take effect.

Note
You may want to direct people who install your managed solution to use the Overwrite customizations option when investigating issues where the customizations conflict with the behavior of your solutions. They should always export their unmanaged solutions first so that they can re-apply them if they need to.

See Also

Reference

Customization solutions file schema

Concepts

Introduction to solutions
Dependency tracking for solution components
Create, export, or import an unmanaged solution
Uninstall or delete a solution

Other Resources

Package and distribute extensions using solutions
Plan for solution development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Uninstall or delete a solution

You delete managed and unmanaged solutions in the same way, but the resulting actions are very different. Deleting a managed solution will uninstall the managed solution.

In This Topic

Delete a solution

Access the solutions list with a URL

Delete a solution

Depending on the type of solution that you want to delete, you’ll see one of the following Confirm Deletion messages:

Managed solution

“You are deleting a managed solution. The solution and all its components will be deleted. This action cannot be undone. This solution might take several minutes to uninstall. You cannot cancel the uninstallation after it starts. Do you want to continue?”

Unmanaged solution

“You are deleting an unmanaged solution. The solution will be deleted but components that are contained in this solution will not be deleted. This action cannot be undone. Do you want to continue?”

To delete a solution programmatically use the IOrganizationService.Delete method. More information: Delete a Solution

Uninstall a managed solution

Deleting a managed solution will uninstall the solution. All the solution components defined in it are deleted.

Important
When you uninstall a managed solution, the following data is lost: data stored in custom entities that are part of the solution and data stored in custom attributes on system entities that are part of the solution.

Delete an unmanaged solution

An unmanaged solution is a group of solution components. Deleting the solution deletes a single solution record in the database. Solution components are not affected by the solution being deleted, they remain in the system.

Access the solutions list with a URL

If you need to navigate directly to the solutions list you can use the following URL:

Copy Code
<organization root url>/tools/Solution/home_solution.aspx?etn=solution

See Also

Reference

Delete a Solution
Create a Managed Solution
Export an Unmanaged Solution
Import an Unmanaged Solution
Create a Managed Solution
Install a Managed Solution

Concepts

Introduction to solutions
Dependency tracking for solution components
Create solutions that support multiple languages

Other Resources

Package and distribute extensions using solutions
Plan for solution development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create solutions that support multiple languages

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update support multiple languages. If you want your solution to be installed for organizations that include different base languages or that have multiple languages provisioned, take this into account when planning your solution. The following table lists tactics to use along with solution components to include in a solution that supports multiple languages.

Tactic | Solution component type
Developer option | Web Resources
Embedded labels | Application Navigation (SiteMap) Ribbons
Export and import translations | Attributes Charts Dashboards Entity Entity Relationships Forms Messages Option Sets Views
Localization in base language strings | Contract Templates Connection Roles Processes (Workflow) Security Roles Field Security Profiles
Localization not required | SDK Message Processing Steps Service Endpoints
Separate component for each language | Article Templates Email Templates Mail Merge Templates Reports Dialogs
Use XML web resources as language resources | Plug-in Assemblies

The following sections provide additional details for each tactic.

Developer option

Web resources have a LanguageCode attribute that can be set in the user interface but this value is not used by the application. Because web resources are URL addressable, you typically access a web resource by name instead of by querying available web resources with LanguageCode as a criterion. Therefore, the LanguageCode is of limited value. The more common scenario is that you’ll have to detect the appropriate language based on the context in which the web resource is displayed. For web resources, the context object provides access to the getOrgLcid and getUserLcid functions. Both of these functions return an integer value that corresponds to the Locale ID (LCID) values. Valid locale ID values can be found at Locale ID (LCID) Chart.

For web resources that expose text in the user interface, you can use any method that you want to manage how the text and layout will support the user’s language preferences. The specific implementation depends on the type of web resource.

HTML web resources

One option is to create separate localized web resources that vary depending on the name applied. For example, you may have a web resource named new_/my_solution/1033/content.htm to support English and one named new_/my_solution/1041/content.htm to support Japanese. For languages that require right-to-left direction, see How to: Display Right-to-Left Text Using HTML Tags for Globalization.

If you want to be able to dynamically set UI text based on a user’s language, you can store all the localized string values in an object defined throughout a script web resource file. Based on the user’s language preference, you can set the UI text elements by using strings stored in the object when the page loads. The following JavaScript code sample shows a method to set localized strings.

JScript Copy Code
  var userLcid = 1033;

  var localizedStrings = {
   ErrorMessage: {
    _1033: "There was an error completing this action. Please try again.",
    _1041: "このアクションを完了、エラーが発生しました。もう一度実行してください。",
    _1031: "Es ist ein Fehler aufgetreten, der Abschluss dieser Aktion. Bitte versuchen Sie es erneut.",
    _1036: "Il y avait une erreur complétant cette action. Veuillez essayer à nouveau.",
    _1034: "Hubo un error al completar esta acción. Vuelva a intentarlo.",
    _1049: "Произошла ошибка, выполнение этого действия. Пожалуйста, попробуйте снова."
   },
   Welcome: {
    _1033: "Welcome",
    _1041: "ようこそ",
    _1031: "Willkommen",
    _1036: "Bienvenue",
    _1034: "Bienvenido",
    _1049: "Добро пожаловать"
   }
  };
  var LocalizedErrorMessage = localizedStrings.ErrorMessage["_" + userLcid];
  var LocalizedWelcomeMessage = localizedStrings.Welcome["_" + userLcid];

Silverlight web resources

Silverlight applications can be written to support localized language resources. More information: Localizing Silverlight-based Applications.

The following class provides access to the user’s language preference based on the context in which the Silverlight web resource is presented. This class supports US English, Arabic, German, Hebrew and Japanese. It needs to be modified for the specific languages that are supported by the Silverlight web resource.

C# Copy Code
public static class Localization
    {
    // The locale ID.
    public static int LCID { get; set; }
    // Create a dictionary of right-to-left language codes (Hebrew and Arabic).
    private static Dictionary<int, bool> _rightToLeftLanguages =
        new Dictionary<int, bool>
        {
            { 1025, true },
            { 1037, true },
        };
    private static Dictionary<int, String> _lcidToCultureNameMap =
        new Dictionary<int, String>
        {
            { 1025, "ar-SA" },
            { 1031, "de-DE" },
            { 1033, "en-US" },
            { 1037, "he-IL" },
            { 1041, "ja-JP" }
        };
    public static void InitializeCulture()
    {
        // Get the user's LCID from the page's context to determine what language to
        // display.
        dynamic window = HtmlPage.Window;
        //Get the user's language code from the context.
        try
        {
            //If the containing window is a CRM form
            LCID = Convert.ToInt32(window.Xrm.Page.context.getUserLcid());
            // For testing, comment the line above and uncomment one of the lines below
            //representing a user language.
            //LCID = 1033; //English
            //LCID = 1041; //Japanese
            //LCID = 1031; //German
            //LCID = 1037; //Hebrew - a right-to-left language.
            //LCID = 1025; //Arabic - a right-to-left language.
        }
        catch (Microsoft.CSharp.RuntimeBinder.RuntimeBinderException)
        {
            try
            {
                //If the containing window is a CRM web resource with
                //the WebResources/ClientGlobalContext.js.aspx page linked
                LCID = Convert.ToInt32(window.GetGlobalContext().getUserLcid());
            }
            catch (Microsoft.CSharp.RuntimeBinder.RuntimeBinderException)
            {
                LCID = 1033; //Setting a default for design time when the context
                //object is not present and one of the sample languages are not set.
            }
        }
        // Sets the culture of the thread to the appropriate culture, based on what
        // LCID was retrieved.
        if (_lcidToCultureNameMap.ContainsKey(LCID))
        {
            var culture = new CultureInfo(_lcidToCultureNameMap[LCID]);
            Thread.CurrentThread.CurrentCulture = culture;
            Thread.CurrentThread.CurrentUICulture = culture;
        }
    }
    public static FlowDirection GetFlowDirection()
    {
        if (_rightToLeftLanguages.ContainsKey(LCID))
        {
            return FlowDirection.RightToLeft;
        }
        return FlowDirection.LeftToRight;
    }
}

For languages that require right-to-left direction, see FrameworkElement.FlowDirection Property.

XML web resources

While XML web resources are usually not displayed to users, they can be useful to store localized strings as resources for other solution components as described in Use XML Web Resources as Language Resources.

Embedded labels

Each of the solution components that use this tactic requires that any localized text be included in the solution component.

Ribbons

When a language pack is installed, the application ribbon automatically displays localized text for all of the default text in the ribbon. System labels are defined in a ResourceId attribute value that is for internal use only. When you add your own text you should use the <LocLabels> (RibbonDiffXml) element to provide localized text for the languages you support. More information: Use localized labels with ribbons

SiteMap

When a language pack is installed, the default text in the application navigation bar automatically displays localized text. To override the default text or to provide your own text, use the <Titles> (SiteMap) element. The Titles element should contain a <Title> (SiteMap) element that contains localized text for any languages your solution supports. If a Title element isn’t available for the user’s preferred language, the title that corresponds to the organization base language is displayed.

The <SubArea> (SiteMap) element allows for passing the user’s language preference by using the userlcid parameter so that content that is the target of the SubArea.Url attribute can be aware of the user’s language preference and adjust accordingly. More information: Pass parameters to a URL using the SiteMap

Export and import translations

Localizable labels for the solution components in the following table can be exported for localization.

Entities | Attributes | Relationships
Global Option Sets | Entity Messages | Entity Forms
Entity Views (SavedQuery) | Charts | Dashboards

Translating labels and display strings

You can only perform customizations in the application by using the base language. Therefore, when you want to provide localized labels and display strings for these customizations, you must export the text of the labels so that they can be localized for any other languages enabled for the organization. Use the following steps:

  1. Ensure that the organization that you’re working on has all the MUI packs installed and languages provisioned for languages you want to provide translations for.
  2. Create your solution and modify the components.
  3. After you have finished developing your solution use the “Export Translations” functionality. This generates a Microsoft Office Excel spreadsheet (CrmTranslations.xml) that contains all the labels that need translation.
  4. In the spreadsheet, provide the corresponding translations.
  5. Import translations back into the same Microsoft Dynamics CRM organization using the “Import Translations” functionality and publish your changes.
  6. The next time the solution is exported it carries all the translations that you provided.

When a solution is imported, labels for languages that aren’t available in the target system are discarded and a warning is logged.

If labels for the base language of the target system are not provided in the solution package, the labels of the base language of the source are used instead. For example, if you import a solution that contains labels for English and French with English as the base language, but the target system has Japanese and French with Japanese as the base language, English labels are used instead of Japanese labels. The base languages labels cannot be null or empty.

Exporting translations

Before you export translations you must first install the language packs and provision all the languages you want to have localized. You can export the translations in the web application or by using the ExportTranslationRequest message. For more information, see Export Customized Entity and Field Text for Translation.

Translating text

When you open the CrmTranslations.xml file in Excel you will see the three worksheets listed in the following table.

Worksheet | Description
Information | Displays information about the organization and solution that the labels and strings were exported from.
Display Strings | Display strings that represent the text of any messages associated with a metadata component. This table includes error messages and strings used for system ribbon elements.
Localized Labels | Displays all of the text for any metadata component labels.

You can send this file to a linguistic expert, translation agency, or localization firm. They will need to provide localized strings for any of the empty cells.

Note
For custom entities there are some common labels that are shared with system entities, such as Created On or Created By. Because you have already installed and provisioned the languages, if you export languages for the default solution you may be able to match some labels in your custom entities with localized text for identical labels used by other entities. This can reduce the localization costs and improve consistency.

After the text in the worksheets has been localized, add both the CrmTranslations.xml and [Content_Types].xml files to a single compressed .zip file. You can now import this file.

If you prefer to work with the exported files programmatically as an XML document, see Office 2003 XML Reference Schemas for information about the schemas these files use.

Importing translated text

Important
You can only import translated text back into the same organization it was exported from.

After you have exported the customized entity or attribute text and had it translated, you can import the translated text strings in the web application by using the ImportTranslationRequest message. The file that you import must be a compressed file that contains the CrmTranslations.xml and the [Content_Types].xml file at the root. For more information, see Import Translated Entity and Field Text.

After you import the completed translations, customized text appears for users who work in the languages that you had the text translated into.

Note
Microsoft Dynamics CRM cannot import translated text that is over 500 characters long. If any of the items in your translation file are longer than 500 characters, the import process fails. If the import process fails, review the line in the file that caused the failure, reduce the number of characters, and try to import again.

Because customization is supported only in the base language, you may be working in Microsoft Dynamics CRM with the base language set as your language preference. To verify that the translated text appears, you must change your language preference for the Microsoft Dynamics CRM user interface. To perform additional customization work, you must change back to the base language.

Localization in base language strings

Some solution components do not support multiple languages. These components include names or text that can only be meaningful in a specific language. If you create a solution for a specific language, define these solution components for the intended organization base language.

If you need to support multiple languages, one tactic is to include localization within the base language strings. For example, if you have a Connection Role named “Friend” and you need to support English, Spanish, and German, you might use the text “Friend (Amigo / Freund)” as the name of the connection role. Due to issues of the length of the text there are limitations on how many languages can be supported using this tactic.

Some solution components in this group are only visible to administrators. Because customization of the system can only be done in the organization base language it is not necessary to provide multiple language versions. Security Roles and Field Security Profile components belong to this group.

Contract Templates provide a description of a type of service contract. These require text for the Name and Abbreviation fields. You should consider using names and abbreviations that are unique and appropriate for all users of the organization.

Connection Roles rely on a person selecting descriptive Connection Role categories and names. Because these may be relatively short, it is recommended that you include localization in base language strings.

Processes (Workflows) that are initiated for events can work well as long as they do not need to update records with text that is to be localized. It is possible to use a workflow assembly so that logic that might apply to localized text could use the same strategy as plug-in assemblies (Use XML Web Resources as Language Resources).

On-Demand workflows require a name so that people can choose them. In addition to including localization within the name of the on-demand workflow, another tactic is to create multiple workflows with localized names that each call the same child process. However, all users will see the complete list of on-demand workflows, not just the ones in their preferred user interface language.

Localization not required

SDK Message Processing Step and Service Endpoint solution components do not expose localizable text to users. If it is important that these components have names and descriptions that correspond to the organization’s base language, you can create and export a managed solution with names and descriptions in that language.

Separate component for each language

The following solution components each may contain a considerable amount of text to be localized:

  • Article Templates
  • Email Templates
  • Mail Merge Templates
  • Reports
  • Dialogs

For these types of solution components, the recommended tactic is to create separate components for each language. This means that you typically create a base managed solution that contains your core solution components and then a separate managed solution that contains these solution components for each language. After customers install the base solution, they can install the managed solutions for the languages they have provisioned for the organization.

Unlike Processes (Workflows), you can create Dialogs that will reflect the user’s current language preference settings and display the dialogs only to users of that language.

Create a localized dialog box

  1. Install the appropriate language pack and provision the language.

    For more information, see Language Pack Installation Instructions.

  2. Change your personal options to specify the User Interface Language for the language you want for the dialog.

  3. Navigate to Settings and, in the Process Center group, select Processes.

  4. Click New and create the dialog in the language that you specified.

  5. After you have created the dialog, change your personal options to specify the organization base language.

  6. While using the organization base language you can navigate to the Solutions area in Settings and add the localized dialog as part of a solution.

The dialog created in the other language will only be displayed to users who view Microsoft Dynamics CRM using that language.

Use XML web resources as language resources

Plug-in assembly solution components can send messages to an end user by throwing an InvalidPluginExecutionException as well as creating and updating records. Unlike Silverlight web resources, plug-ins cannot use resource files.

When a plug-in requires localized text, you can use an XML web resource to store the localized strings so the plug-in can access them when needed. The structure of the XML is your option, but you may want to follow the structure used by ASP.NET Resource (.resx) files to create separate XML web resources for each language. For example, the following is an XML web resource named localizedString.en_US that follows the pattern used by . resx files.

Xml Copy Code
<root>
 <data name="ErrorMessage">
  <value>There was an error completing this action. Please try again.</value>
 </data>
 <data name="Welcome">
  <value>Welcome</value>
 </data>
</root>

The following code shows how a localized message can be passed back in a plug-in to display a message to a user. It is for the pre-validation stage of a Delete event for the Account entity:

C# Copy Code
protected void ExecutePreValidateAccountDelete(LocalPluginContext localContext)
  {
   if (localContext == null)
   {
    throw new ArgumentNullException("localContext");
   }
   int OrgLanguage = RetrieveOrganizationBaseLanguageCode(localContext.OrganizationService);
   int UserLanguage = RetrieveUserUILanguageCode(localContext.OrganizationService,
 localContext.PluginExecutionContext.InitiatingUserId);
   String fallBackResourceFile = "";
   switch (OrgLanguage)
   {
    case 1033:
     fallBackResourceFile = "new_localizedStrings.en_US";
     break;
    case 1041:
     fallBackResourceFile = "new_localizedStrings.ja_JP";
     break;
    case 1031:
     fallBackResourceFile = "new_localizedStrings.de_DE";
     break;
    case 1036:
     fallBackResourceFile = "new_localizedStrings.fr_FR";
     break;
    case 1034:
     fallBackResourceFile = "new_localizedStrings.es_ES";
     break;
    case 1049:
     fallBackResourceFile = "new_localizedStrings.ru_RU";
     break;
    default:
     fallBackResourceFile = "new_localizedStrings.en_US";
     break;
   }
   String ResourceFile = "";
   switch (UserLanguage)
   {
    case 1033:
     ResourceFile = "new_localizedStrings.en_US";
     break;
    case 1041:
     ResourceFile = "new_localizedStrings.ja_JP";
     break;
    case 1031:
     ResourceFile = "new_localizedStrings.de_DE";
     break;
    case 1036:
     ResourceFile = "new_localizedStrings.fr_FR";
     break;
    case 1034:
     ResourceFile = "new_localizedStrings.es_ES";
     break;
    case 1049:
     ResourceFile = "new_localizedStrings.ru_RU";
     break;
    default:
     ResourceFile = fallBackResourceFile;
     break;
   }
   XmlDocument messages = RetrieveXmlWebResourceByName(localContext, ResourceFile);
   String message = RetrieveLocalizedStringFromWebResource(localContext, messages, "ErrorMessage");
   throw new InvalidPluginExecutionException(message);
  }
  protected static int RetrieveOrganizationBaseLanguageCode(IOrganizationService service)
  {
   QueryExpression organizationEntityQuery = new QueryExpression("organization");
   organizationEntityQuery.ColumnSet.AddColumn("languagecode");
   EntityCollection organizationEntities = service.RetrieveMultiple(organizationEntityQuery);
   return (int)organizationEntities[0].Attributes["languagecode"];
  }
  protected static int RetrieveUserUILanguageCode(IOrganizationService service, Guid userId)
  {
   QueryExpression userSettingsQuery = new QueryExpression("usersettings");
   userSettingsQuery.ColumnSet.AddColumns("uilanguageid", "systemuserid");
   userSettingsQuery.Criteria.AddCondition("systemuserid", ConditionOperator.Equal, userId);
   EntityCollection userSettings = service.RetrieveMultiple(userSettingsQuery);
   if (userSettings.Entities.Count > 0)
   {
    return (int)userSettings.Entities[0]["uilanguageid"];
   }
   return 0;
  }
  protected static XmlDocument RetrieveXmlWebResourceByName(LocalPluginContext context, string webresourceSchemaName)
  {
   context.TracingService.Trace("Begin:RetrieveXmlWebResourceByName, webresourceSchemaName={0}", webresourceSchemaName);
   QueryExpression webresourceQuery = new QueryExpression("webresource");
   webresourceQuery.ColumnSet.AddColumn("content");
   webresourceQuery.Criteria.AddCondition("name", ConditionOperator.Equal, webresourceSchemaName);
   EntityCollection webresources = context.OrganizationService.RetrieveMultiple(webresourceQuery);
   context.TracingService.Trace("Webresources Returned from server. Count={0}", webresources.Entities.Count);
   if (webresources.Entities.Count > 0)
   {
    byte[] bytes = Convert.FromBase64String((string)webresources.Entities[0]["content"]);
    // The bytes would contain the ByteOrderMask. Encoding.UTF8.GetString() does not remove the BOM.
    // Stream Reader auto detects the BOM and removes it on the text
    XmlDocument document = new XmlDocument();
    document.XmlResolver = null;
    using (MemoryStream ms = new MemoryStream(bytes))
    {
     using (StreamReader sr = new StreamReader(ms))
     {
      document.Load(sr);
     }
    }
    context.TracingService.Trace("End:RetrieveXmlWebResourceByName , webresourceSchemaName={0}", webresourceSchemaName);
    return document;
   }
   else
   {
    context.TracingService.Trace("{0} Webresource missing. Reinstall the solution", webresourceSchemaName);
    throw new InvalidPluginExecutionException(String.Format("Unable to locate the web resource {0}.", webresourceSchemaName));
    return null;
 // This line never reached
   }
  }
  protected static string RetrieveLocalizedStringFromWebResource(LocalPluginContext context, XmlDocument resource, string resourceId)
  {
   XmlNode valueNode = resource.SelectSingleNode(string.Format(CultureInfo.InvariantCulture, "./root/data[@name='{0}']/value", resourceId));
   if (valueNode != null)
   {
    return valueNode.InnerText;
   }
   else
   {
    context.TracingService.Trace("No Node Found for {0} ", resourceId);
    throw new InvalidPluginExecutionException(String.Format("ResourceID {0} was not found.", resourceId));
   }
  }

See Also

Concepts

Introduction to solutions
Dependency tracking for solution components
Create, export, or import an unmanaged solution
Create, install, and update a managed solution
Uninstall or delete a solution
Localize product property values

Other Resources

Package and distribute extensions using solutions
Plan for solution development
Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Solution entities

Solutions let you create and package customizations as a single unit of software.

The following diagram describes selected attributes of the solution entities.

Solution entities object model

In This Section

Publisher entity messages and methods

PublisherAddress entity messages and methods

Solution entity messages and methods

SolutionComponent entity messages and methods

Dependency entity messages and methods

InvalidDependency entity messages and methods

ImportJob entity messages and methods

Related Sections

Package and distribute extensions using solutions

Work with solutions

Sample: Work with solutions

Sample: Detect solution dependencies

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Publisher entity messages and methods

A publisher represents a publisher for a solution. The schema name for this entity is Publisher. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a publisher. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a publisher. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a publisher. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of publishers. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a publisher. You can also call the IOrganizationService.Update method.

See Also

Concepts

PublisherAddress entity messages and methods
InvalidDependency entity messages and methods
ImportJob entity privileges
Publisher entity privileges

Other Resources

Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PublisherAddress entity messages and methods

A publisher address contains address and shipping information for a publisher. The schema name for this entity is PublisherAddress. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates a publisher address. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a publisher address. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a publisher address. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of publisher addresses. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a publisher address. You can also call the IOrganizationService.Update method.

See Also

Concepts

Solution entity messages and methods
ImportJob entity messages and methods
Dependency entity messages and methods
InvalidDependency entity messages and methods

Other Resources

Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Solution entity messages and methods

A solution represents a group of solution components that can be exported or imported.

When a solution is managed, it is treated as a single unit of software. Deleting a managed solution removes all the solution components.

When a solution is unmanaged, it is just a named grouping for a set of solution components. Deleting an unmanaged solution just removes the group. All solution components remain. A managed solution is created by exporting an unmanaged solution and selecting to export it as a managed solution. The schema name for this entity is Solution. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message Description

AssociateRequest

Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Solution entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

CreateRequest

Creates a solution. You can also call the IOrganizationService.Create method.

DeleteRequest

Deletes a solution. You can also call the IOrganizationService.Delete method.

DisassociateRequest

Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see Solution entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.

ExportSolutionRequest

Export a managed or unmanaged solution.

ImportSolutionRequest

Import a managed or unmanaged solution.

Note
This message can be used with the ExecuteAsyncRequest See Execute messages in the background (asynchronously) for more information.

InitializeFromRequest

Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.

RetrieveDuplicatesRequest

Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.

RetrieveRequest

Retrieves a solution. You can also call the IOrganizationService.Retrieve method.

RetrieveMultipleRequest

Retrieves a collection of solutions. You can also call the IOrganizationService.RetrieveMultiple method.

UpdateRequest

Updates a solution. You can also call the IOrganizationService.Update method.

Constant SolutionId Values

When you program using solutions you may need to reference the following solution records. Each Microsoft Dynamics CRM organization has the following solutions that can be referenced by the SolutionId values.

Name | SolutionId | Description
Default | {FD140AAF-4DF4-11DD-BD17-0019B9312238} | The Default solution does not contain any solution components. It contains references to all the managed and unmanaged solution components in the system.
Active | {FD140AAE-4DF4-11DD-BD17-0019B9312238} | The Active solution represents the current published unmanaged customizations that define the behavior of the application.

See Also

Concepts

SolutionComponent entity messages and methods
Introduction to solutions
Solution entity privileges

Other Resources

Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SolutionComponent entity messages and methods

A solution component represents one of the customizable items that can be included in a solution. The schema name for this entity is SolutionComponent. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AddSolutionComponentRequest | Adds a solution component to an unmanaged solution.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
IsComponentCustomizableRequest | Returns a Boolean value indicating whether a solution component is customizable.
RemoveSolutionComponentRequest | Removes a solution component to an unmanaged solution.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveMissingComponentsRequest | Retrieves information about solution components required by a solution but not found in the organization.
RetrieveRequest | Retrieves a solution component. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of solution components. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveRequiredComponentsRequest | Retrieves all components that this component requires.

See Also

Concepts

SolutionComponent entity privileges
Dependency entity messages and methods

Other Resources

Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Dependency entity messages and methods

A dependency record contains data about how a solution component depends on another solution component. A solution component cannot be deleted while another solution component depends on it. The schema name for this entity is Dependency. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Dependency entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the Dependency entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a dependency. You can also call the IOrganizationService.Retrieve method.
RetrieveDependenciesForDeleteRequest | Determines what dependencies will prevent deleting this component.
RetrieveDependenciesForUninstallRequest | Retrieves any components that will become invalid if the solution is uninstalled.
RetrieveDependentComponentsRequest | Retrieves all components that depend on this component.
RetrieveMissingDependenciesRequest | Verifies whether any solution components are not included in the solution but possibly should be for a complete solution to be exported. Use this message before you export a solution.
RetrieveMultipleRequest | Retrieves a collection of dependencies. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveRequiredComponentsRequest | Retrieves all components that this component requires.

See Also

Concepts

InvalidDependency entity messages and methods
ImportJob entity messages and methods
Dependency tracking for solution components
Dependency entity privileges

Other Resources

Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InvalidDependency entity messages and methods

An invalid dependency record contains information about a solution component dependency that could not be created because one of the components does not exist in the system. The schema name for this entity is InvalidDependency. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the InvalidDependency entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see the InvalidDependency entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves an invalid dependency. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of invalid dependencies. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Concepts

ImportJob entity messages and methods
InvalidDependency entity privileges

Other Resources

Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportJob entity messages and methods

An import job record contains status and progress information for an import operation that imports entity customizations or translations.

The schema name for this entity is ImportJob. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an import job. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an import job. You can also call the IOrganizationService.Delete method.
RetrieveFormattedImportJobResultsRequest | Retrieves the results of an ImportJob as an XML document designed to be opened using Microsoft Office Excel.
RetrieveRequest | Retrieves an import job. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of import jobs. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates an import job. You can also call the IOrganizationService.Update method.

See Also

Concepts

InvalidDependency entity messages and methods
ImportJob entity privileges

Other Resources

Solution entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Work with solutions

This topic presents specific programming tasks included in Sample: Work with solutions and Sample: Detect solution dependencies.

In This Topic

Create a publisher

Retrieve the default publisher

Create a solution

Retrieve a solution

Add a new solution component

Add an existing solution component

Remove a solution component

Export or package a solution

Install or upgrade a solution

Delete a solution

Detect solution dependencies

Create a publisher

Every solution requires a publisher, represented by the Publisher entity. A solution cannot use the Microsoft Corporation publisher but it can use the Default publisher for the organization or a new publisher

A publisher requires the following:

  • A customization prefix
  • A unique name
  • A friendly name

The following sample first defines a publisher and then checks to see whether the publisher already exists based on the unique name. If it already exists, the customization prefix may have been changed, so this sample seeks to capture the current customization prefix. The PublisherId is also captured so that the publisher record can be deleted. If the publisher is not found, a new publisher is created using the IOrganizationService. Create method

C# Copy Code

//Define a new publisher
Publisher _crmSdkPublisher = new Publisher
{
    UniqueName = "sdksamples",
    FriendlyName = "Microsoft CRM SDK Samples",
    SupportingWebsiteUrl = "http://msdn.microsoft.com/en-us/dynamics/crm/default.aspx",
    CustomizationPrefix = "sample",
    EMailAddress = "someone@microsoft.com",
    Description = "This publisher was created with samples from the Microsoft Dynamics CRM SDK"
};

//Does publisher already exist?
QueryExpression querySDKSamplePublisher = new QueryExpression
{
    EntityName = Publisher.EntityLogicalName,
    ColumnSet = new ColumnSet("publisherid", "customizationprefix"),
    Criteria = new FilterExpression()
};

querySDKSamplePublisher.Criteria.AddCondition("uniquename", ConditionOperator.Equal, _crmSdkPublisher.UniqueName);
EntityCollection querySDKSamplePublisherResults = _serviceProxy.RetrieveMultiple(querySDKSamplePublisher);
Publisher SDKSamplePublisherResults = null;

//If it already exists, use it
if (querySDKSamplePublisherResults.Entities.Count > 0)
{
    SDKSamplePublisherResults = (Publisher)querySDKSamplePublisherResults.Entities[0];
    _crmSdkPublisherId = (Guid)SDKSamplePublisherResults.PublisherId;
    _customizationPrefix = SDKSamplePublisherResults.CustomizationPrefix;
}
//If it doesn't exist, create it
if (SDKSamplePublisherResults == null)
{
    _crmSdkPublisherId = _serviceProxy.Create(_crmSdkPublisher);
    Console.WriteLine(String.Format("Created publisher: {0}.", _crmSdkPublisher.FriendlyName));
    _customizationPrefix = _crmSdkPublisher.CustomizationPrefix;
}

Retrieve the default publisher

This sample shows how toretrieve the default publisher. The default publisher has a constant GUID value: d21aab71-79e7-11dd-8874-00188b01e34f.

C# Copy Code
// Retrieve the Default Publisher

//The default publisher has a constant GUID value;
Guid DefaultPublisherId = new Guid("{d21aab71-79e7-11dd-8874-00188b01e34f}");

Publisher DefaultPublisher = (Publisher)_serviceProxy.Retrieve(Publisher.EntityLogicalName, DefaultPublisherId, new ColumnSet(new string[] {"friendlyname" }));

EntityReference DefaultPublisherReference = new EntityReference
{
    Id = DefaultPublisher.Id,
    LogicalName = Publisher.EntityLogicalName,
    Name = DefaultPublisher.FriendlyName
};
Console.WriteLine("Retrieved the {0}.", DefaultPublisherReference.Name);

Create a solution

The following sample shows how to create an unmanaged solution using the Microsoft Dynamics CRM SDK Samples publisher created in Create a Publisher.

A solution requires the following:

  • A Publisher
  • A Friendly Name
  • A Unique Name
  • A Version Number

The variable _crmSdkPublisherId is a GUID value representing the publisherid value.

This sample checks whether the Solution already exists in the organization based on the unique name. If the solution does not exist it is created. The SolutionId value is captured so the solution can be deleted.

C# Copy Code
// Create a Solution
//Define a solution
Solution solution = new Solution
{
    UniqueName = "samplesolution",
    FriendlyName = "Sample Solution",
    PublisherId = new EntityReference(Publisher.EntityLogicalName, _crmSdkPublisherId),
    Description = "This solution was created by the WorkWithSolutions sample code in the Microsoft Dynamics CRM SDK samples.",
    Version = "1.0"
};

//Check whether it already exists
QueryExpression queryCheckForSampleSolution = new QueryExpression
{
    EntityName = Solution.EntityLogicalName,
    ColumnSet = new ColumnSet(),
    Criteria = new FilterExpression()
};
queryCheckForSampleSolution.Criteria.AddCondition("uniquename", ConditionOperator.Equal, solution.UniqueName);

//Create the solution if it does not already exist.
EntityCollection querySampleSolutionResults = _serviceProxy.RetrieveMultiple(queryCheckForSampleSolution);
Solution SampleSolutionResults = null;
if (querySampleSolutionResults.Entities.Count > 0)
{
    SampleSolutionResults = (Solution)querySampleSolutionResults.Entities[0];
    _solutionsSampleSolutionId = (Guid)SampleSolutionResults.SolutionId;
}
if (SampleSolutionResults == null)
{
    _solutionsSampleSolutionId = _serviceProxy.Create(solution);
}

Retrieve a solution

To retrieve a specific solution you can use the solution’s UniqueName. Each organization will have a default solution with a constant GUID value: FD140AAF-4DF4-11DD-BD17-0019B9312238.

This sample shows how to retrieve data for a solution with the unique name ”samplesolution”. A solution with this name is created in Create a Solution.

C# Copy Code
// Retrieve a solution
String solutionUniqueName = "samplesolution";
QueryExpression querySampleSolution = new QueryExpression
{
    EntityName = Solution.EntityLogicalName,
    ColumnSet = new ColumnSet(new string[] { "publisherid", "installedon", "version", "versionnumber", "friendlyname" }),
    Criteria = new FilterExpression()
};

querySampleSolution.Criteria.AddCondition("uniquename", ConditionOperator.Equal, solutionUniqueName);
Solution SampleSolution = (Solution)_serviceProxy.RetrieveMultiple(querySampleSolution).Entities[0];

Add a new solution component

This sample shows how to create a solution component that is associated with a specific solution. If you don’t associate the solution component to a specific solution when it is created it will only be added to the default solution and you will need to add it to a solution manually or by using the code included in the Add an Existing Solution Component.

This code creates a new global option set and adds it to the solution with a unique name equal to _primarySolutionName.

C# Copy Code
OptionSetMetadata optionSetMetadata = new OptionSetMetadata()
{
    Name = _globalOptionSetName,
    DisplayName = new Label("Example Option Set", _languageCode),
    IsGlobal = true,
    OptionSetType = OptionSetType.Picklist,
    Options =
{
    new OptionMetadata(new Label("Option 1", _languageCode), 1),
    new OptionMetadata(new Label("Option 2", _languageCode), 2)
}
};
CreateOptionSetRequest createOptionSetRequest = new CreateOptionSetRequest
{
    OptionSet = optionSetMetadata
};

createOptionSetRequest.SolutionUniqueName = _primarySolutionName;
_serviceProxy.Execute(createOptionSetRequest);

Add an existing solution component

This sample shows how to add an existing solution component to a solution.

The following code uses the AddSolutionComponentRequest to add the Account entity as a solution component to an unmanaged solution.

C# Copy Code
// Add an existing Solution Component
//Add the Account entity to the solution
RetrieveEntityRequest retrieveForAddAccountRequest = new RetrieveEntityRequest()
{
    LogicalName = Account.EntityLogicalName
};
RetrieveEntityResponse retrieveForAddAccountResponse = (RetrieveEntityResponse)_serviceProxy.Execute(retrieveForAddAccountRequest);
AddSolutionComponentRequest addReq = new AddSolutionComponentRequest()
{
    ComponentType = (int)componenttype.Entity,
    ComponentId = (Guid)retrieveForAddAccountResponse.EntityMetadata.MetadataId,
    SolutionUniqueName = solution.UniqueName
};
_serviceProxy.Execute(addReq);

Remove a solution component

This sample shows how to remove a solution component from an unmanaged solution. The following code uses the RemoveSolutionComponentRequest to remove an entity solution component from an unmanaged solution. The solution.UniqueName references the Solution created in the Create a Solution.

C# Copy Code
// Remove a Solution Component
//Remove the Account entity from the solution
RetrieveEntityRequest retrieveForRemoveAccountRequest = new RetrieveEntityRequest()
{
    LogicalName = Account.EntityLogicalName
};
RetrieveEntityResponse retrieveForRemoveAccountResponse = (RetrieveEntityResponse)_serviceProxy.Execute(retrieveForRemoveAccountRequest);

RemoveSolutionComponentRequest removeReq = new RemoveSolutionComponentRequest()
{
    ComponentId = (Guid)retrieveForRemoveAccountResponse.EntityMetadata.MetadataId,
    ComponentType = (int)componenttype.Entity,
    SolutionUniqueName = solution.UniqueName
};
_serviceProxy.Execute(removeReq);

Export or package a solution

This sample shows how to export an unmanaged solution or package a managed solution. The code uses ExportSolutionRequest to export a compressed file representing an unmanaged solution. The option to create a managed solution is set using the Managed property. This sample saves a file named samplesolution.zip to the c:\temp\ folder.

C# Copy Code
// Export or package a solution
//Export an a solution

ExportSolutionRequest exportSolutionRequest = new ExportSolutionRequest();
exportSolutionRequest.Managed = false;
exportSolutionRequest.SolutionName = solution.UniqueName;

ExportSolutionResponse exportSolutionResponse = (ExportSolutionResponse)_serviceProxy.Execute(exportSolutionRequest);

byte[] exportXml = exportSolutionResponse.ExportSolutionFile;
string filename = solution.UniqueName + ".zip";
File.WriteAllBytes(outputDir + filename, exportXml);

Console.WriteLine("Solution exported to {0}.", outputDir + filename);

Install or upgrade a solution

This sample shows how to install or upgrade a solution using the ImportSolutionRequest message.

You can use the ImportJob entity to capture data about the success of the import.

The following sample shows how to import a solution without tracking the success.

C# Copy Code
// Install or Upgrade a Solution

byte[] fileBytes = File.ReadAllBytes(ManagedSolutionLocation);

ImportSolutionRequest impSolReq = new ImportSolutionRequest()
{
    CustomizationFile = fileBytes
};

_serviceProxy.Execute(impSolReq);

Console.WriteLine("Imported Solution from {0}", ManagedSolutionLocation);

Tracking import success

When you specify an ImportJobId for the ImportSolutionRequest, you can use that value to query the ImportJob entity about the status of the import.

The ImportJobId can also be used to download an import log file using the RetrieveFormattedImportJobResultsRequest message.

Retrieving import job data

The following sample shows how to retrieve the import job record and the content of the ImportJob.Data attribute.

C# Copy Code
// Monitor import success
byte[] fileBytesWithMonitoring = File.ReadAllBytes(ManagedSolutionLocation);

ImportSolutionRequest impSolReqWithMonitoring = new ImportSolutionRequest()
{
    CustomizationFile = fileBytes,
    ImportJobId = Guid.NewGuid()
};

_serviceProxy.Execute(impSolReqWithMonitoring);
Console.WriteLine("Imported Solution with Monitoring from {0}", ManagedSolutionLocation);

ImportJob job = (ImportJob)_serviceProxy.Retrieve(ImportJob.EntityLogicalName, impSolReqWithMonitoring.ImportJobId, new ColumnSet(new System.String[] { "data", "solutionname" }));

System.Xml.XmlDocument doc = new System.Xml.XmlDocument();
doc.LoadXml(job.Data);

String ImportedSolutionName = doc.SelectSingleNode("//solutionManifest/UniqueName").InnerText;
String SolutionImportResult = doc.SelectSingleNode("//solutionManifest/result/@result").Value;

Console.WriteLine("Report from the ImportJob data");
Console.WriteLine("Solution Unique name: {0}", ImportedSolutionName);
Console.WriteLine("Solution Import Result: {0}", SolutionImportResult);
Console.WriteLine("");

// This code displays the results for Global Option sets installed as part of a solution.

System.Xml.XmlNodeList optionSets = doc.SelectNodes("//optionSets/optionSet");
foreach (System.Xml.XmlNode node in optionSets)
{
    string OptionSetName = node.Attributes["LocalizedName"].Value;
    string result = node.FirstChild.Attributes["result"].Value;

    if (result == "success")
    {
        Console.WriteLine("{0} result: {1}",OptionSetName, result);
    }
    else
    {
        string errorCode = node.FirstChild.Attributes["errorcode"].Value;
        string errorText = node.FirstChild.Attributes["errortext"].Value;

        Console.WriteLine("{0} result: {1} Code: {2} Description: {3}",OptionSetName, result, errorCode, errorText);
    }
}

The contents of the Data property is a string representing an XML file. The following is a sample captured using the code in this sample. This managed solution contained a single global option set called sample_tempsampleglobaloptionsetname.

Xml Copy Code
<importexportxml start="634224017519682730"
                 stop="634224017609764033"
                 progress="80"
                 processed="true">
 <solutionManifests>
  <solutionManifest languagecode="1033"
                    id="samplesolutionforImport"
                    LocalizedName="Sample Solution for Import"
                    processed="true">
   <UniqueName>samplesolutionforImport</UniqueName>
   <LocalizedNames>
    <LocalizedName description="Sample Solution for Import"
                   languagecode="1033" />
   </LocalizedNames>
   <Descriptions>
    <Description description="This solution was created by the WorkWithSolutions sample code in the Microsoft Dynamics CRM SDK samples."
                 languagecode="1033" />
   </Descriptions>
   <Version>1.0</Version>
   <Managed>1</Managed>
   <Publisher>
    <UniqueName>sdksamples</UniqueName>
    <LocalizedNames>
     <LocalizedName description="Microsoft CRM SDK Samples"
                    languagecode="1033" />
    </LocalizedNames>
    <Descriptions>
     <Description description="This publisher was created with samples from the Microsoft Dynamics CRM SDK"
                  languagecode="1033" />
    </Descriptions>
    <EMailAddress>someone@microsoft.com</EMailAddress>
    <SupportingWebsiteUrl>http://msdn.microsoft.com/en-us/dynamics/crm/default.aspx</SupportingWebsiteUrl>
    <Addresses>
     <Address>
      <City />
      <Country />
      <Line1 />
      <Line2 />
      <PostalCode />
      <StateOrProvince />
      <Telephone1 />
     </Address>
    </Addresses>
   </Publisher>
   <results />
   <result result="success"
           errorcode="0"
           errortext=""
           datetime="20:49:12.08"
           datetimeticks="634224269520845122" />
  </solutionManifest>
 </solutionManifests>
 <upgradeSolutionPackageInformation>
  <upgradeRequired>0</upgradeRequired>
  <upgradeValid>1</upgradeValid>
  <fileVersion>5.0.9669.0</fileVersion>
  <currentVersion>5.0.9669.0</currentVersion>
  <fileSku>OnPremise</fileSku>
  <currentSku>OnPremise</currentSku>
 </upgradeSolutionPackageInformation>
 <entities />
 <nodes />
 <settings />
 <dashboards />
 <securityroles />
 <workflows />
 <templates />
 <optionSets>
  <optionSet id="sample_tempsampleglobaloptionsetname"
             LocalizedName="Example Option Set"
             Description=""
             processed="true">
   <result result="success"
           errorcode="0"
           errortext=""
           datetime="20:49:16.10"
           datetimeticks="634224269561025400" />
  </optionSet>
 </optionSets>
 <ConnectionRoles />
 <SolutionPluginAssemblies />
 <SdkMessageProcessingSteps />
 <ServiceEndpoints />
 <webResources />
 <reports />
 <FieldSecurityProfiles />
 <languages>
  <language>
   <result result="success"
           errorcode="0"
           errortext=""
           datetime="20:49:12.00"
           datetimeticks="634224269520092986" />
  </language>
 </languages>
 <entitySubhandlers />
 <publishes>
  <publish processed="false" />
 </publishes>
 <rootComponents>
  <rootComponent processed="true">
   <result result="success"
           errorcode="0"
           errortext=""
           datetime="20:49:20.83"
           datetimeticks="634224269608387238" />
  </rootComponent>
 </rootComponents>
 <dependencies>
  <dependency processed="true">
   <result result="success"
           errorcode="0"
           errortext=""
           datetime="20:49:20.97"
           datetimeticks="634224269609715208" />
  </dependency>
 </dependencies>
</importexportxml>

Delete a solution

This sample shows how to delete a solution.The following sample shows how to retrieve a solution using the solution uniquename and then extract the solutionid from the results. Use the solutionid with the IOrganizationService. Delete method.

C# Copy Code
// Delete a solution

QueryExpression queryImportedSolution = new QueryExpression
{
    EntityName = Solution.EntityLogicalName,
    ColumnSet = new ColumnSet(new string[] { "solutionid", "friendlyname" }),
    Criteria = new FilterExpression()
};

queryImportedSolution.Criteria.AddCondition("uniquename", ConditionOperator.Equal, ImportedSolutionName);

Solution ImportedSolution = (Solution)_serviceProxy.RetrieveMultiple(queryImportedSolution).Entities[0];

_serviceProxy.Delete(Solution.EntityLogicalName, (Guid)ImportedSolution.SolutionId);

Console.WriteLine("Deleted the {0} solution.", ImportedSolution.FriendlyName);

Detect solution dependencies

This sample shows how to create a report showing the dependencies between solution components.

This code will:

  • Retrieve all the components for a solution.
  • Retrieve all the dependencies for each component.
  • For each dependency found display a report describing the dependency.
C# Copy Code

// Grab all Solution Components for a solution.
QueryByAttribute componentQuery = new QueryByAttribute
{
    EntityName = SolutionComponent.EntityLogicalName,
    ColumnSet = new ColumnSet("componenttype", "objectid", "solutioncomponentid", "solutionid"),
    Attributes = { "solutionid" },

    // In your code, this value would probably come from another query.
    Values = { _primarySolutionId }
};

IEnumerable<SolutionComponent> allComponents =
    _serviceProxy.RetrieveMultiple(componentQuery).Entities.Cast<SolutionComponent>();

foreach (SolutionComponent component in allComponents)
{
    // For each solution component, retrieve all dependencies for the component.
    RetrieveDependentComponentsRequest dependentComponentsRequest =
        new RetrieveDependentComponentsRequest
        {
            ComponentType = component.ComponentType.Value,
            ObjectId = component.ObjectId.Value
        };
    RetrieveDependentComponentsResponse dependentComponentsResponse =
        (RetrieveDependentComponentsResponse)_serviceProxy.Execute(dependentComponentsRequest);

    // If there are no dependent components, we can ignore this component.
    if (dependentComponentsResponse.EntityCollection.Entities.Any() == false)
        continue;

    // If there are dependencies upon this solution component, and the solution
    // itself is managed, then you will be unable to delete the solution.
    Console.WriteLine("Found {0} dependencies for Component {1} of type {2}",
        dependentComponentsResponse.EntityCollection.Entities.Count,
        component.ObjectId.Value,
        component.ComponentType.Value
        );
    //A more complete report requires more code
    foreach (Dependency d in dependentComponentsResponse.EntityCollection.Entities)
    {
        DependencyReport(d);
    }
}

The DependencyReport method is in the following code sample.

Dependency report

The DependencyReport method provides a friendlier message based on information found within the dependency.

Note
In this sample the method is only partially implemented. It can display messages only for attribute and option set solution components.

C# Copy Code
   /// <summary>
   /// Shows how to get a more friendly message based on information within the dependency
   /// <param name="dependency">A Dependency returned from the RetrieveDependentComponents message</param>
   /// </summary>
public void DependencyReport(Dependency dependency)
   {
 //These strings represent parameters for the message.
    String dependentComponentName = "";
    String dependentComponentTypeName = "";
    String dependentComponentSolutionName = "";
    String requiredComponentName = "";
    String requiredComponentTypeName = "";
    String requiredComponentSolutionName = "";

 //The ComponentType global Option Set contains options for each possible component.
    RetrieveOptionSetRequest componentTypeRequest = new RetrieveOptionSetRequest
    {
     Name = "componenttype"
    };

    RetrieveOptionSetResponse componentTypeResponse = (RetrieveOptionSetResponse)_serviceProxy.Execute(componentTypeRequest);
    OptionSetMetadata componentTypeOptionSet = (OptionSetMetadata)componentTypeResponse.OptionSetMetadata;
 // Match the Component type with the option value and get the label value of the option.
    foreach (OptionMetadata opt in componentTypeOptionSet.Options)
    {
     if (dependency.DependentComponentType.Value == opt.Value)
     {
      dependentComponentTypeName = opt.Label.UserLocalizedLabel.Label;
     }
     if (dependency.RequiredComponentType.Value == opt.Value)
     {
      requiredComponentTypeName = opt.Label.UserLocalizedLabel.Label;
     }
    }
 //The name or display name of the compoent is retrieved in different ways depending on the component type
    dependentComponentName = getComponentName(dependency.DependentComponentType.Value, (Guid)dependency.DependentComponentObjectId);
    requiredComponentName = getComponentName(dependency.RequiredComponentType.Value, (Guid)dependency.RequiredComponentObjectId);

 // Retrieve the friendly name for the dependent solution.
    Solution dependentSolution = (Solution)_serviceProxy.Retrieve
     (
      Solution.EntityLogicalName,
      (Guid)dependency.DependentComponentBaseSolutionId,
      new ColumnSet("friendlyname")
     );
    dependentComponentSolutionName = dependentSolution.FriendlyName;

 // Retrieve the friendly name for the required solution.
    Solution requiredSolution = (Solution)_serviceProxy.Retrieve
      (
       Solution.EntityLogicalName,
       (Guid)dependency.RequiredComponentBaseSolutionId,
       new ColumnSet("friendlyname")
      );
    requiredComponentSolutionName = requiredSolution.FriendlyName;

 //Display the message
     Console.WriteLine("The {0} {1} in the {2} depends on the {3} {4} in the {5} solution.",
     dependentComponentName,
     dependentComponentTypeName,
     dependentComponentSolutionName,
     requiredComponentName,
     requiredComponentTypeName,
     requiredComponentSolutionName);
   }

Detect whether a solution component may be deleted

Use the RetrieveDependenciesForDeleteRequest message to identify any other solution components which would prevent a given solution component from being deleted. The following code sample looks for any attributes using a known global optionset. Any attribute using the global optionset would prevent the global optionset from being deleted.

C# Copy Code
// Use the RetrieveOptionSetRequest message to retrieve
// a global option set by it's name.
RetrieveOptionSetRequest retrieveOptionSetRequest =
    new RetrieveOptionSetRequest
    {
     Name = _globalOptionSetName
    };

// Execute the request.
RetrieveOptionSetResponse retrieveOptionSetResponse =
    (RetrieveOptionSetResponse)_serviceProxy.Execute(
    retrieveOptionSetRequest);
_globalOptionSetId = retrieveOptionSetResponse.OptionSetMetadata.MetadataId;
if (_globalOptionSetId != null)
{
 //Use the global OptionSet MetadataId with the appropriate componenttype
 // to call RetrieveDependenciesForDeleteRequest
 RetrieveDependenciesForDeleteRequest retrieveDependenciesForDeleteRequest = new RetrieveDependenciesForDeleteRequest
{
 ComponentType = (int)componenttype.OptionSet,
 ObjectId = (Guid)_globalOptionSetId
};

 RetrieveDependenciesForDeleteResponse retrieveDependenciesForDeleteResponse =
  (RetrieveDependenciesForDeleteResponse)_serviceProxy.Execute(retrieveDependenciesForDeleteRequest);
 Console.WriteLine("");
 foreach (Dependency d in retrieveDependenciesForDeleteResponse.EntityCollection.Entities)
 {

  if (d.DependentComponentType.Value == 2)//Just testing for Attributes
  {
   String attributeLabel = "";
   RetrieveAttributeRequest retrieveAttributeRequest = new RetrieveAttributeRequest
   {
    MetadataId = (Guid)d.DependentComponentObjectId
   };
   RetrieveAttributeResponse retrieveAttributeResponse = (RetrieveAttributeResponse)_serviceProxy.Execute(retrieveAttributeRequest);

   AttributeMetadata attmet = retrieveAttributeResponse.AttributeMetadata;

   attributeLabel = attmet.DisplayName.UserLocalizedLabel.Label;

    Console.WriteLine("An {0} named {1} will prevent deleting the {2} global option set.",
   (componenttype)d.DependentComponentType.Value,
   attributeLabel,
   _globalOptionSetName);
  }
 }
}

See Also

Concepts

Introduction to solutions
Dependency tracking for solution components
Create, export, or import an unmanaged solution
Create, install, and update a managed solution
Uninstall or delete a solution

Other Resources

Package and distribute extensions using solutions
Plan for solution development
Solution entities
Sample: Work with solutions
Sample: Detect solution dependencies

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create packages for the CRM Package Deployer

Microsoft Dynamics CRM Package Deployer is a new tool that enables administrators to deploy packages on Microsoft Dynamics CRM Online and Microsoft Dynamics CRM (on-premises) instances. A “package” can consist of any or all of the following:

  • One or more CRM solution files.
  • Flat files or exported data files from the Configuration Migration tool. For more information about the tool, see Manage your configuration data.
  • Custom code that can run while the package is being deployed to the CRM server, or after it’s been deployed.
  • HTML content specific to the package that can display at the beginning and end of the deployment process. This can be useful to provide a description of the solutions and files that are deployed in the package.

Microsoft Dynamics CRM provides you with a Visual Studio template for creating these packages that can be used with the Package Deployer tool to deploy them to a CRM server.

In This Topic

Prerequisites

Create a package

Deploy a package

Best practices for creating and deploying packages

Prerequisites

  • Ensure that you have all the solutions and files ready that you want to include in the package.
  • Microsoft .NET Framework 4.5.2
  • Microsoft Visual Studio 2012 or Visual Studio 2013
  • NuGet Package Manager for Visual Studio 2012 or NuGet Package Manager for Visual Studio 2013
  • Microsoft Dynamics CRM SDK templates for Visual Studio that contains the package template. You can get it in one of the following ways:
    • Download the CRM SDK templates and double-click the CRMSDKTemplates.vsix file to install the template in Visual Studio.
    • Download and extract the CRM SDK package. The templates file, CRMSDKTemplates.vsix, is located in the SDK\Templates folder. Double-click the CRMSDKTemplates.vsix file to install the template in Visual Studio.

Create a package

Perform the following five steps to create a package:

Step 1: Create a project using the template

Step 2: Add your files to the project

Step 3: Update the HTML files

Step 4: Specify the configuration values for the package

Step 5: Define custom code for your package

Step 1: Create a project using the template

  1. Start Microsoft Visual Studio, and create a new project.

  2. In the New Project dialog box:

    1. From the list of installed templates, expand Visual C#, and select CRM SDK Templates.
    2. Ensure that .NET Framework 4.5.2 is selected.
    3. Select CRM Package.
    4. Specify the name and location of the project, and click OK.
    New project for creating a custom package

Step 2: Add your files to the project

  1. In the Solutions Explorer pane, add your solutions and files under the PkgFolder folder.

  2. For each file that you add under the PkgFolder folder, in the Properties pane, set the Copy to Output Directory value to Copy Always. This ensures that your file is available in the generated package.

Step 3: Update the HTML files: English and other languages

  1. In the Solution Explorer pane, expand PkgFolder > Content > en-us. You’ll find two folders called EndHTML and WelcomeHTML. These folders contain the HTML and associated files that enable you to display information at the end and beginning of the package deployment process. Edit the files in the HTML folder of these folders to add information for your package.

  2. You can also add the HTML files in your package in other languages so that the content in the HTML appears in the language based on the locale settings of the user’s computer. To do so:

    1. Create a copy of the en-us folder under PkgFolder > Content.
    2. Rename the copied folder to the appropriate language. For example, for the Spanish language, rename it to es-ES.
    3. Modify the content of the HTML files to add Spanish content.

Step 4: Specify the configuration values for the package

  1. Define the package configuration by adding information about your package in the ImportConfig.xml file available in the PkgFolder. Double-click the file to open it for editing. The following table lists information about each parameter and node in the config file.

    Parameter/Node Description

    installsampledata

    true or false. If true, installs sample data to CRM instance. This is the same sample data that you can install from Settings > Data Management area.

    waitforsampledatatoinstall

    true or false. If true, and if installsampledata is also set to true, waits for sample data to install before deploying the package.

    agentdesktopzipfile

    File name of the zip file to unpack. If you specify a .zip file name here, it adds a screen during the package deployment process that prompts you to select a location where you want to unpack the contents of the file.

    This is commonly used for creating packages for Unified Service Desk for Microsoft Dynamics CRM. For information about Unified Service Desk, see the Unified Service Desk Administration Guide.

    agentdesktopexename

    Name of the .exe or .msi file in the zip file or a URL to be invoked at the end of the deployment process.

    This is commonly used for creating packages for Unified Service Desk.

    crmmigdataimportfile

    File name of the data file (.zip) exported using the Configuration Migration tool.

    Important
    If your data file contains user information, the user information won’t be imported. To import user information from the source CRM instance to the target instance, you must use the Configuration Migration tool. For more information, see Manage your configuration data in theDeploying and administering Microsoft Dynamics CRM documentation.

    <solutions> node

    Contains an array of <configsolutionfile> nodes that describe the solutions to import. The order of the solutions under this node indicates the order in which the solutions will be imported on the target server.

    <configsolutionfile> node

    Use this node under the <solutions> node to specify the individual solution file name to be imported. You use the solutionpackagefilename attribute under this node to specify the .zip file name of your solution. You can add multiple solution file names in a package by adding as many <configsolutionfile> nodes. For example, if you want three solution files to be imported, add them like this:

    Copy Code
    <solutions>
    <configsolutionfile solutionpackagefilename="SampleSolutionOne_1_0_managed.zip" />
    <configsolutionfile solutionpackagefilename="SampleSolutionTwo_2_0_managed.zip" />
    <configsolutionfile solutionpackagefilename="SampleSolutionThree_3_0_managed.zip" />
</solutions>

    <filestoimportnode> node

    Contains an array of <configimportfile> and <zipimportdetails> nodes that are used to describe individual files and zip files respectively to be imported.

    <configimportfile> node

    Use this node under the <configimportfile> node to describe a file to be imported to CRM. You can add multiple files in a package by adding as many <configimportfile> nodes.

    Copy Code
    <filestoimport>
  <configimportfile
    filename="File.csv"
    filetype="CSV"
    associatedmap="FileMap"
    importtoentity="FileEntity"
    datadelimiter="" fielddelimiter="comma"
    enableduplicatedetection="true"
    isfirstrowheader="true"  isrecordownerateam="false"
    owneruser=""
    waitforimporttocomplete="true"/>
  <configimportfile
    filename="File.zip"
    filetype="ZIP"
    associatedmap="FileMapName"
    importtoentity="FileEntity"
    datadelimiter=""
    fielddelimiter="comma"
    enableduplicatedetection="true"
    isfirstrowheader="true"
    isrecordownerateam="false"
    owneruser=""
    waitforimporttocomplete="true"/>
  ...
  ...
</filestoimport>

    This has the following attributes:

    Attribute Description

    filename

    Name of the file that contains the import data. If the file is a .zip file, a <zipimportdetails> node must be present with a <zipimportdetail> node for each file in the .zip file.

    filetype

    This can be csv, xml, or zip.

    associatedmap

    Name of the CRM import data map to use with this file. If blank, attempts to use the system determined import data map name for this file.

    importtoentity

    Can be the name of the exe in the zip file, a URL, or an .msi file to provide a link to invoke at the end of the process.

    datadelimiter

    Name of the data delimiter used in the import file. Valid values are singlequote or doublequotes.

    fielddelimiter

    Name of the field delimiter used in the import file. Valid values are comma or colon, or singlequote.

    enableduplicatedetection

    Indicates whether to enable duplicate detections rules on data import. Valid values are true or false.

    isfirstrowheader

    Used to denote that the first row of the import file contains the field names. Valid values are true or false.

    isrecordownerateam

    Indicates whether the owner of the record on import should be a team. Valid values are true or false.

    owneruser

    Indicates the user ID that should own the records. The default value is the currently logged in user.

    waitforimporttocomplete

    If true, the system waits for the import to complete before proceeding. If false, it queues the jobs and moves on.

    <zipimportdetails> node

    This node contains an array of <zipimportdetail> nodes that describe the files included in a zip file that is used to import to CRM.

    <zipimportdetail> node

    Use this node under the <zipimportdetails> node to provide information about an individual file in a .zip file that is specified in the <configimportfile> node.

    Copy Code
    <filestoimport>
...
...
    <zipimportdetails>
      <zipimportdetail filename="subfile1.csv" filetype="csv" importtoentity="account" />
      <zipimportdetail filename="subfile2.txt" filetype="csv" importtoentity="contact" />
    </zipimportdetails>
</filestoimport>

    This has the following attributes:

    Attribute Description

    filename

    Name of the file that contains the import data.

    filetype

    This can be csv or xml.

    importtoentity

    Can be the name of the exe in the zip file, a url, or an .msi file to provide a link to invoke at the end of the process.

    <filesmapstoimport> node

    This node contains an array of <configmapimportfile> nodes to import. The order of the map files in this node indicates the order in which they are imported. For information about data maps, see Create data maps for import.

    <configimportmapfile> node

    Use this node under the <filesmapstoimport> node to provide information about an individual map file to import in CRM.

    Copy Code
    <filesmapstoimport>
    <configimportmapfile filename="FileMap.xml" />
</filesmapstoimport>

  2. Click Save All.

Step 5: Define custom code for your package

  1. In the Solution Explorer pane, double-click the PackageTemplate.cs file at the root to edit it.

  2. In the PackageTemplate.cs file, you can:

    1. Enter custom code to execute when the package is initialized in the override method definition of InitializeCustomExtension().
    2. Enter custom code to execute before the import starts in the BeforeImportStage() function.
    3. Use the RunSolutionUpgradeMigrationStep() function to perform data transformation or upgrade between two versions of a solution while a solution update is occurring.
      Copy Code
      public override void RunSolutionUpgradeMigrationStep(string solutionName, string oldVersion, string newVersion, Guid oldSolutionId, Guid newSolutionId)
{
    base.RunSolutionUpgradeMigrationStep(solutionName, oldVersion, newVersion, oldSolutionId, newSolutionId);
}
      This function expects the following parameters:

      Parameter Description

      solutionName

      Name of the solution

      oldVersion

      Version number of the old solution

      newVersion

      Version number of the new solution

      oldSolutionId

      GUID of the old solution.

      newSolutionId

      GUID of the new solution.

    4. Enter custom code to execute after the import completes in the AfterPrimaryImport() function.
    5. Change the default name of the package folder from PkgFolder to something else. To do so, rename the PkgFolder in the Solution Explorer pane, and then edit the return value under the GetImportPackageDataFolderName property.
      Copy Code
      public override string GetImportPackageDataFolderName
{
    get
    {
        // WARNING this value directly correlates to the folder name in the Solution Explorer where the ImportConfig.xml and sub content is located.
        // Changing this name requires that you also change the correlating name in the Solution Explorer
        return "PkgFolder";
    }
}
    6. Change the package name by editing the return value under the GetNameOfImport property.
      Copy Code
      public override string GetNameOfImport(bool plural)
{
     return "Package Short Name";
}
      This is the name of your package that will appear on the package selection page in the CRM Package Deployer wizard.
    7. Change the package description by editing the return value under the GetImportPackageDescriptionText property.
      Copy Code
      public override string GetImportPackageDescriptionText
{
       get { return "Package Description"; }
}
      This is the package description that will appear alongside the package name on the on the package selection page in the Package Deployer wizard.
    8. Change the package long name by editing the return value under the GetLongNameOfImport property.
      Copy Code
      public override string GetLongNameOfImport
{
     get { return "Package Long Name"; }
}
      The package long name appears on the next page after you have selected the package to install.

  3. Additionally, the following function and variables are available to the package:

    Name Type Description

    CreateProgressItem

    Function

    Used to create a new progress item in the user interface (UI).

    RaiseUpdateEvent

    Function

    Used to update the progress created by the call to CreateProgressItem.

    ProgressPanelItemStatus is an enum:

    Copy Code
    public enum ProgressPanelItemStatus
{
    Working = 0,
    Complete = 1,
    Failed = 2,
    Warning = 3,
    Unknown = 4
}

    RaiseFailEvent

    Function

    Used to fail the current status import with an exception message.

    IsRoleAssoicatedWithTeam

    Function

    Used to determine if a role is associated with a specified team.

    IsWorkflowActive

    Function

    Used to determine if a specified workflow is active.

    PackageLog

    Class Pointer

    This is a pointer to the initialized logging interface for the package. This interface is used by a package to log messages and exceptions to the package log file.

    RootControlDispatcher

    Variable

    This is a dispatcher interface used to allow your control to render its own UI during package deployment. Use this interface to wrap any UI elements or commands. It is important to check this variable for null values before using it as it may or may not be set to a value.

    CrmSvc

    Variable

    This is a pointer to Microsoft.Xrm.Tooling.Connector that allows for a package to address CRM from within the package. Use this class to execute actions in the overridden methods.

    You can use any of these functions or variables using the this keyword:

    Keyword used to include functions or variables

  4. Save your project, and then build it (Build > Build Solution) to create the package. The entire contents in the <Project>\Bin\Debug folder is your package. Note that an assembly file (.dll) is created with the same name as your Visual Studio project name; this file contains the custom code that that you created in this section.

Deploy a package

After you create a package, you can deploy it on the CRM instance by using either the Package Deployer tool or Windows PowerShell. For detailed information, see Deploy packages using CRM Package Deployer or Windows PowerShell.

Best practices for creating and deploying packages

While creating packages, developers must ensure that the package assemblies are signed.

While deploying the packages, CRM administrators must:

  • Insist on a signed package assembly so that you can track an assembly back to its source.
  • Test the package on a pre-production instance (preferably a mirror image of the production instance) before running it on a production instance.
  • Back up the production instance before deploying the package.

See Also

Concepts

What's new for developers

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Work with solutions
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Solutions\WorkWithSolutions.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to how to perform the following actions with solutions:

  • Create a publisher.
  • Retrieve the default publisher.
  • Create a solution.
  • Retrieve a solution.
  • Add an existing solution component.
  • Remove a solution component.
  • Export or package a solution.
  • Install or upgrade a solution.
  • Delete a solution.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{

    /// <summary>
    /// Demonstrates common tasks performed using Microsoft Dynamics CRM Solutions
    /// </summary>
    public class WorkWithSolutions
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        private Guid _crmSdkPublisherId;
        private System.String _customizationPrefix;
        private Guid _solutionsSampleSolutionId;
        System.String ManagedSolutionLocation = @"C:\temp\ManagedSolutionForImportExample.zip";
        String outputDir = @"C:\temp\";

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        private const int _languageCode = 1033;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Shows how to perform the following tasks with solutions:
        /// - Create a Publisher
        /// - Retrieve the Default Publisher
        /// - Create a Solution
        /// - Retrieve a Solution
        /// - Add an existing Solution Component
        /// - Remove a Solution Component
        /// - Export or Package a Solution
        /// - Install or Upgrade a solution
        /// - Delete a Solution
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    //Define a new publisher
                    Publisher _crmSdkPublisher = new Publisher
                    {
                        UniqueName = "sdksamples",
                        FriendlyName = "Microsoft CRM SDK Samples",
                        SupportingWebsiteUrl = "http://msdn.microsoft.com/en-us/dynamics/crm/default.aspx",
                        CustomizationPrefix = "sample",
                        EMailAddress = "someone@microsoft.com",
                        Description = "This publisher was created with samples from the Microsoft Dynamics CRM SDK"
                    };

                    //Does publisher already exist?
                    QueryExpression querySDKSamplePublisher = new QueryExpression
                    {
                        EntityName = Publisher.EntityLogicalName,
                        ColumnSet = new ColumnSet("publisherid", "customizationprefix"),
                        Criteria = new FilterExpression()
                    };

                    querySDKSamplePublisher.Criteria.AddCondition("uniquename", ConditionOperator.Equal, _crmSdkPublisher.UniqueName);
                    EntityCollection querySDKSamplePublisherResults = _serviceProxy.RetrieveMultiple(querySDKSamplePublisher);
                    Publisher SDKSamplePublisherResults = null;

                    //If it already exists, use it
                    if (querySDKSamplePublisherResults.Entities.Count > 0)
                    {
                        SDKSamplePublisherResults = (Publisher)querySDKSamplePublisherResults.Entities[0];
                        _crmSdkPublisherId = (Guid)SDKSamplePublisherResults.PublisherId;
                        _customizationPrefix = SDKSamplePublisherResults.CustomizationPrefix;
                    }
                    //If it doesn't exist, create it
                    if (SDKSamplePublisherResults == null)
                    {
                        _crmSdkPublisherId = _serviceProxy.Create(_crmSdkPublisher);
                        Console.WriteLine(String.Format("Created publisher: {0}.", _crmSdkPublisher.FriendlyName));
                        _customizationPrefix = _crmSdkPublisher.CustomizationPrefix;
                    }

                    // Retrieve the Default Publisher

                    //The default publisher has a constant GUID value;
                    Guid DefaultPublisherId = new Guid("{d21aab71-79e7-11dd-8874-00188b01e34f}");

                    Publisher DefaultPublisher = (Publisher)_serviceProxy.Retrieve(Publisher.EntityLogicalName, DefaultPublisherId, new ColumnSet(new string[] {"friendlyname" }));

                    EntityReference DefaultPublisherReference = new EntityReference
                    {
                        Id = DefaultPublisher.Id,
                        LogicalName = Publisher.EntityLogicalName,
                        Name = DefaultPublisher.FriendlyName
                    };
                    Console.WriteLine("Retrieved the {0}.", DefaultPublisherReference.Name);

                    // Create a Solution
                    //Define a solution
                    Solution solution = new Solution
                    {
                        UniqueName = "samplesolution",
                        FriendlyName = "Sample Solution",
                        PublisherId = new EntityReference(Publisher.EntityLogicalName, _crmSdkPublisherId),
                        Description = "This solution was created by the WorkWithSolutions sample code in the Microsoft Dynamics CRM SDK samples.",
                        Version = "1.0"
                    };

                    //Check whether it already exists
                    QueryExpression queryCheckForSampleSolution = new QueryExpression
                    {
                        EntityName = Solution.EntityLogicalName,
                        ColumnSet = new ColumnSet(),
                        Criteria = new FilterExpression()
                    };
                    queryCheckForSampleSolution.Criteria.AddCondition("uniquename", ConditionOperator.Equal, solution.UniqueName);

                    //Create the solution if it does not already exist.
                    EntityCollection querySampleSolutionResults = _serviceProxy.RetrieveMultiple(queryCheckForSampleSolution);
                    Solution SampleSolutionResults = null;
                    if (querySampleSolutionResults.Entities.Count > 0)
                    {
                        SampleSolutionResults = (Solution)querySampleSolutionResults.Entities[0];
                        _solutionsSampleSolutionId = (Guid)SampleSolutionResults.SolutionId;
                    }
                    if (SampleSolutionResults == null)
                    {
                        _solutionsSampleSolutionId = _serviceProxy.Create(solution);
                    }

                    // Retrieve a solution
                    String solutionUniqueName = "samplesolution";
                    QueryExpression querySampleSolution = new QueryExpression
                    {
                        EntityName = Solution.EntityLogicalName,
                        ColumnSet = new ColumnSet(new string[] { "publisherid", "installedon", "version", "versionnumber", "friendlyname" }),
                        Criteria = new FilterExpression()
                    };

                    querySampleSolution.Criteria.AddCondition("uniquename", ConditionOperator.Equal, solutionUniqueName);
                    Solution SampleSolution = (Solution)_serviceProxy.RetrieveMultiple(querySampleSolution).Entities[0];

                    // Add an existing Solution Component
                    //Add the Account entity to the solution
                    RetrieveEntityRequest retrieveForAddAccountRequest = new RetrieveEntityRequest()
                    {
                        LogicalName = Account.EntityLogicalName
                    };
                    RetrieveEntityResponse retrieveForAddAccountResponse = (RetrieveEntityResponse)_serviceProxy.Execute(retrieveForAddAccountRequest);
                    AddSolutionComponentRequest addReq = new AddSolutionComponentRequest()
                    {
                        ComponentType = (int)componenttype.Entity,
                        ComponentId = (Guid)retrieveForAddAccountResponse.EntityMetadata.MetadataId,
                        SolutionUniqueName = solution.UniqueName
                    };
                    _serviceProxy.Execute(addReq);

                    // Remove a Solution Component
                    //Remove the Account entity from the solution
                    RetrieveEntityRequest retrieveForRemoveAccountRequest = new RetrieveEntityRequest()
                    {
                        LogicalName = Account.EntityLogicalName
                    };
                    RetrieveEntityResponse retrieveForRemoveAccountResponse = (RetrieveEntityResponse)_serviceProxy.Execute(retrieveForRemoveAccountRequest);

                    RemoveSolutionComponentRequest removeReq = new RemoveSolutionComponentRequest()
                    {
                        ComponentId = (Guid)retrieveForRemoveAccountResponse.EntityMetadata.MetadataId,
                        ComponentType = (int)componenttype.Entity,
                        SolutionUniqueName = solution.UniqueName
                    };
                    _serviceProxy.Execute(removeReq);

                    // Export or package a solution
                    //Export an a solution

                    ExportSolutionRequest exportSolutionRequest = new ExportSolutionRequest();
                    exportSolutionRequest.Managed = false;
                    exportSolutionRequest.SolutionName = solution.UniqueName;

                    ExportSolutionResponse exportSolutionResponse = (ExportSolutionResponse)_serviceProxy.Execute(exportSolutionRequest);

                    byte[] exportXml = exportSolutionResponse.ExportSolutionFile;
                    string filename = solution.UniqueName + ".zip";
                    File.WriteAllBytes(outputDir + filename, exportXml);

                    Console.WriteLine("Solution exported to {0}.", outputDir + filename);

                    // Install or Upgrade a Solution

                    byte[] fileBytes = File.ReadAllBytes(ManagedSolutionLocation);

                    ImportSolutionRequest impSolReq = new ImportSolutionRequest()
                    {
                        CustomizationFile = fileBytes
                    };

                    _serviceProxy.Execute(impSolReq);

                    Console.WriteLine("Imported Solution from {0}", ManagedSolutionLocation);

                    // Monitor import success
                    byte[] fileBytesWithMonitoring = File.ReadAllBytes(ManagedSolutionLocation);

                    ImportSolutionRequest impSolReqWithMonitoring = new ImportSolutionRequest()
                    {
                        CustomizationFile = fileBytes,
                        ImportJobId = Guid.NewGuid()
                    };

                    _serviceProxy.Execute(impSolReqWithMonitoring);
                    Console.WriteLine("Imported Solution with Monitoring from {0}", ManagedSolutionLocation);

                    ImportJob job = (ImportJob)_serviceProxy.Retrieve(ImportJob.EntityLogicalName, impSolReqWithMonitoring.ImportJobId, new ColumnSet(new System.String[] { "data", "solutionname" }));

                    System.Xml.XmlDocument doc = new System.Xml.XmlDocument();
                    doc.LoadXml(job.Data);

                    String ImportedSolutionName = doc.SelectSingleNode("//solutionManifest/UniqueName").InnerText;
                    String SolutionImportResult = doc.SelectSingleNode("//solutionManifest/result/@result").Value;

                    Console.WriteLine("Report from the ImportJob data");
                    Console.WriteLine("Solution Unique name: {0}", ImportedSolutionName);
                    Console.WriteLine("Solution Import Result: {0}", SolutionImportResult);
                    Console.WriteLine("");

                    // This code displays the results for Global Option sets installed as part of a solution.

                    System.Xml.XmlNodeList optionSets = doc.SelectNodes("//optionSets/optionSet");
                    foreach (System.Xml.XmlNode node in optionSets)
                    {
                        string OptionSetName = node.Attributes["LocalizedName"].Value;
                        string result = node.FirstChild.Attributes["result"].Value;

                        if (result == "success")
                        {
                            Console.WriteLine("{0} result: {1}",OptionSetName, result);
                        }
                        else
                        {
                            string errorCode = node.FirstChild.Attributes["errorcode"].Value;
                            string errorText = node.FirstChild.Attributes["errortext"].Value;

                            Console.WriteLine("{0} result: {1} Code: {2} Description: {3}",OptionSetName, result, errorCode, errorText);
                        }
                    }

                    // Delete a solution

                    QueryExpression queryImportedSolution = new QueryExpression
                    {
                        EntityName = Solution.EntityLogicalName,
                        ColumnSet = new ColumnSet(new string[] { "solutionid", "friendlyname" }),
                        Criteria = new FilterExpression()
                    };

                    queryImportedSolution.Criteria.AddCondition("uniquename", ConditionOperator.Equal, ImportedSolutionName);

                    Solution ImportedSolution = (Solution)_serviceProxy.RetrieveMultiple(queryImportedSolution).Entities[0];

                    _serviceProxy.Delete(Solution.EntityLogicalName, (Guid)ImportedSolution.SolutionId);

                    Console.WriteLine("Deleted the {0} solution.", ImportedSolution.FriendlyName);

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a managed solution for the Install or upgrade a solution sample

            Guid _tempPublisherId = new Guid();
            System.String _tempCustomizationPrefix = "new";
            Guid _tempSolutionsSampleSolutionId = new Guid();
            System.String _TempGlobalOptionSetName = "_TempSampleGlobalOptionSetName";
            Boolean _publisherCreated = false;
            Boolean _solutionCreated = false;

            //Define a new publisher
            Publisher _crmSdkPublisher = new Publisher
            {
                UniqueName = "sdksamples",
                FriendlyName = "Microsoft CRM SDK Samples",
                SupportingWebsiteUrl = "http://msdn.microsoft.com/en-us/dynamics/crm/default.aspx",
                CustomizationPrefix = "sample",
                EMailAddress = "someone@microsoft.com",
                Description = "This publisher was created with samples from the Microsoft Dynamics CRM SDK"
            };

            //Does publisher already exist?
            QueryExpression querySDKSamplePublisher = new QueryExpression
            {
                EntityName = Publisher.EntityLogicalName,
                ColumnSet = new ColumnSet("publisherid", "customizationprefix"),
                Criteria = new FilterExpression()
            };

            querySDKSamplePublisher.Criteria.AddCondition("uniquename", ConditionOperator.Equal, _crmSdkPublisher.UniqueName);
            EntityCollection querySDKSamplePublisherResults = _serviceProxy.RetrieveMultiple(querySDKSamplePublisher);
            Publisher SDKSamplePublisherResults = null;

            //If it already exists, use it
            if (querySDKSamplePublisherResults.Entities.Count > 0)
            {
                SDKSamplePublisherResults = (Publisher)querySDKSamplePublisherResults.Entities[0];
                _tempPublisherId = (Guid)SDKSamplePublisherResults.PublisherId;
                _tempCustomizationPrefix = SDKSamplePublisherResults.CustomizationPrefix;
            }
            //If it doesn't exist, create it
            if (SDKSamplePublisherResults == null)
            {
                _tempPublisherId = _serviceProxy.Create(_crmSdkPublisher);
                _tempCustomizationPrefix = _crmSdkPublisher.CustomizationPrefix;
                _publisherCreated = true;
            }

            //Create a Solution
            //Define a solution
            Solution solution = new Solution
            {
                UniqueName = "samplesolutionforImport",
                FriendlyName = "Sample Solution for Import",
                PublisherId = new EntityReference(Publisher.EntityLogicalName, _tempPublisherId),
                Description = "This solution was created by the WorkWithSolutions sample code in the Microsoft Dynamics CRM SDK samples.",
                Version = "1.0"
            };

            //Check whether it already exists
            QueryExpression querySampleSolution = new QueryExpression
            {
                EntityName = Solution.EntityLogicalName,
                ColumnSet = new ColumnSet(),
                Criteria = new FilterExpression()
            };
            querySampleSolution.Criteria.AddCondition("uniquename", ConditionOperator.Equal, solution.UniqueName);

            EntityCollection querySampleSolutionResults = _serviceProxy.RetrieveMultiple(querySampleSolution);
            Solution SampleSolutionResults = null;
            if (querySampleSolutionResults.Entities.Count > 0)
            {
                SampleSolutionResults = (Solution)querySampleSolutionResults.Entities[0];
                _tempSolutionsSampleSolutionId = (Guid)SampleSolutionResults.SolutionId;
            }
            if (SampleSolutionResults == null)
            {
                _tempSolutionsSampleSolutionId = _serviceProxy.Create(solution);
                _solutionCreated = true;
            }

            // Add a solution Component
            OptionSetMetadata optionSetMetadata = new OptionSetMetadata()
            {
                Name = _tempCustomizationPrefix + _TempGlobalOptionSetName,
                DisplayName = new Label("Example Option Set", _languageCode),
                IsGlobal = true,
                OptionSetType = OptionSetType.Picklist,
                Options =
                    {
                        new OptionMetadata(new Label("Option A", _languageCode), null),
                        new OptionMetadata(new Label("Option B", _languageCode), null )
                    }
            };
            CreateOptionSetRequest createOptionSetRequest = new CreateOptionSetRequest
            {
                OptionSet = optionSetMetadata,
                SolutionUniqueName = solution.UniqueName

            };

            _serviceProxy.Execute(createOptionSetRequest);

            //Export an a solution

            ExportSolutionRequest exportSolutionRequest = new ExportSolutionRequest();
            exportSolutionRequest.Managed = true;
            exportSolutionRequest.SolutionName = solution.UniqueName;

            ExportSolutionResponse exportSolutionResponse = (ExportSolutionResponse)_serviceProxy.Execute(exportSolutionRequest);

            byte[] exportXml = exportSolutionResponse.ExportSolutionFile;
            System.IO.Directory.CreateDirectory(outputDir);
            File.WriteAllBytes(ManagedSolutionLocation, exportXml);

            // Delete the solution and the components so it can be installed.

            DeleteOptionSetRequest delOptSetReq = new DeleteOptionSetRequest { Name = (_tempCustomizationPrefix + _TempGlobalOptionSetName).ToLower() };
            _serviceProxy.Execute(delOptSetReq);

            if (_solutionCreated)
            {
                _serviceProxy.Delete(Solution.EntityLogicalName, _tempSolutionsSampleSolutionId);
            }

            if (_publisherCreated)
            {
                _serviceProxy.Delete(Publisher.EntityLogicalName, _tempPublisherId);
            }

            Console.WriteLine("Managed Solution created and copied to {0}", ManagedSolutionLocation);

        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(Solution.EntityLogicalName, _solutionsSampleSolutionId);
                _serviceProxy.Delete(Publisher.EntityLogicalName, _crmSdkPublisherId);
                // Remove the managed solution created by the create required fields code.
                File.Delete(ManagedSolutionLocation);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                WorkWithSolutions app = new WorkWithSolutions();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Introduction to solutions
Dependency tracking for solution components
Create, export, or import an unmanaged solution
Create, install, and update a managed solution
Uninstall or delete a solution
Work with solutions

Other Resources

Package and distribute extensions using solutions
Sample: Detect solution dependencies
Plan for solution development
Solution entities
Sample: Detect solution dependencies

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Detect solution dependencies
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Solutions\GetSolutionDependencies.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to how to detect dependencies before you delete a solution component.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{

    /// <summary>
    /// Demonstrates how to detect any dependencies prior to deleting a
    /// solution component.
    /// </summary>
    public class GetSolutionDependencies
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        private Guid _publisherId;
        private const string _primarySolutionName = "PrimarySolution";
        private Guid _primarySolutionId;
        private Guid _secondarySolutionId;
        private const String _prefix = "sample";
        private const String _globalOptionSetName = _prefix + "_exampleoptionset";
        private Guid? _globalOptionSetId;
        private const String _picklistName = _prefix + "_examplepicklist";

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        private const int _languageCode = 1033;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Shows how to detect dependencies that may cause a managed solution to become
        /// un-deletable.
        ///
        /// Get all solution components of a solution
        /// For each solution component, list the dependencies upon that component.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Grab all Solution Components for a solution.
                    QueryByAttribute componentQuery = new QueryByAttribute
                    {
                        EntityName = SolutionComponent.EntityLogicalName,
                        ColumnSet = new ColumnSet("componenttype", "objectid", "solutioncomponentid", "solutionid"),
                        Attributes = { "solutionid" },

                        // In your code, this value would probably come from another query.
                        Values = { _primarySolutionId }
                    };

                    IEnumerable<SolutionComponent> allComponents =
                        _serviceProxy.RetrieveMultiple(componentQuery).Entities.Cast<SolutionComponent>();

                    foreach (SolutionComponent component in allComponents)
                    {
                        // For each solution component, retrieve all dependencies for the component.
                        RetrieveDependentComponentsRequest dependentComponentsRequest =
                            new RetrieveDependentComponentsRequest
                            {
                                ComponentType = component.ComponentType.Value,
                                ObjectId = component.ObjectId.Value
                            };
                        RetrieveDependentComponentsResponse dependentComponentsResponse =
                            (RetrieveDependentComponentsResponse)_serviceProxy.Execute(dependentComponentsRequest);

                        // If there are no dependent components, we can ignore this component.
                        if (dependentComponentsResponse.EntityCollection.Entities.Any() == false)
                            continue;

                        // If there are dependencies upon this solution component, and the solution
                        // itself is managed, then you will be unable to delete the solution.
                        Console.WriteLine("Found {0} dependencies for Component {1} of type {2}",
                            dependentComponentsResponse.EntityCollection.Entities.Count,
                            component.ObjectId.Value,
                            component.ComponentType.Value
                            );
                        //A more complete report requires more code
                        foreach (Dependency d in dependentComponentsResponse.EntityCollection.Entities)
                        {
                            DependencyReport(d);
                        }
                    }

                 //Find out if any dependencies on a  specific global option set would prevent it from being deleted
                    // Use the RetrieveOptionSetRequest message to retrieve
                    // a global option set by it's name.
                    RetrieveOptionSetRequest retrieveOptionSetRequest =
                        new RetrieveOptionSetRequest
                        {
                         Name = _globalOptionSetName
                        };

                    // Execute the request.
                    RetrieveOptionSetResponse retrieveOptionSetResponse =
                        (RetrieveOptionSetResponse)_serviceProxy.Execute(
                        retrieveOptionSetRequest);
                    _globalOptionSetId = retrieveOptionSetResponse.OptionSetMetadata.MetadataId;
                    if (_globalOptionSetId != null)
                    {
                     //Use the global OptionSet MetadataId with the appropriate componenttype
                     // to call RetrieveDependenciesForDeleteRequest
                     RetrieveDependenciesForDeleteRequest retrieveDependenciesForDeleteRequest = new RetrieveDependenciesForDeleteRequest
                    {
                     ComponentType = (int)componenttype.OptionSet,
                     ObjectId = (Guid)_globalOptionSetId
                    };

                     RetrieveDependenciesForDeleteResponse retrieveDependenciesForDeleteResponse =
                      (RetrieveDependenciesForDeleteResponse)_serviceProxy.Execute(retrieveDependenciesForDeleteRequest);
                     Console.WriteLine("");
                     foreach (Dependency d in retrieveDependenciesForDeleteResponse.EntityCollection.Entities)
                     {

                      if (d.DependentComponentType.Value == 2)//Just testing for Attributes
                      {
                       String attributeLabel = "";
                       RetrieveAttributeRequest retrieveAttributeRequest = new RetrieveAttributeRequest
                       {
                        MetadataId = (Guid)d.DependentComponentObjectId
                       };
                       RetrieveAttributeResponse retrieveAttributeResponse = (RetrieveAttributeResponse)_serviceProxy.Execute(retrieveAttributeRequest);

                       AttributeMetadata attmet = retrieveAttributeResponse.AttributeMetadata;

                       attributeLabel = attmet.DisplayName.UserLocalizedLabel.Label;

                        Console.WriteLine("An {0} named {1} will prevent deleting the {2} global option set.",
                       (componenttype)d.DependentComponentType.Value,
                       attributeLabel,
                       _globalOptionSetName);
                      }
                     }
                    }

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Shows how to get a more friendly message based on information within the dependency
        /// <param name="dependency">A Dependency returned from the RetrieveDependentComponents message</param>
        /// </summary>
     public void DependencyReport(Dependency dependency)
        {
      //These strings represent parameters for the message.
         String dependentComponentName = "";
         String dependentComponentTypeName = "";
         String dependentComponentSolutionName = "";
         String requiredComponentName = "";
         String requiredComponentTypeName = "";
         String requiredComponentSolutionName = "";

      //The ComponentType global Option Set contains options for each possible component.
         RetrieveOptionSetRequest componentTypeRequest = new RetrieveOptionSetRequest
         {
          Name = "componenttype"
         };

         RetrieveOptionSetResponse componentTypeResponse = (RetrieveOptionSetResponse)_serviceProxy.Execute(componentTypeRequest);
         OptionSetMetadata componentTypeOptionSet = (OptionSetMetadata)componentTypeResponse.OptionSetMetadata;
      // Match the Component type with the option value and get the label value of the option.
         foreach (OptionMetadata opt in componentTypeOptionSet.Options)
         {
          if (dependency.DependentComponentType.Value == opt.Value)
          {
           dependentComponentTypeName = opt.Label.UserLocalizedLabel.Label;
          }
          if (dependency.RequiredComponentType.Value == opt.Value)
          {
           requiredComponentTypeName = opt.Label.UserLocalizedLabel.Label;
          }
         }
      //The name or display name of the compoent is retrieved in different ways depending on the component type
         dependentComponentName = getComponentName(dependency.DependentComponentType.Value, (Guid)dependency.DependentComponentObjectId);
         requiredComponentName = getComponentName(dependency.RequiredComponentType.Value, (Guid)dependency.RequiredComponentObjectId);

      // Retrieve the friendly name for the dependent solution.
         Solution dependentSolution = (Solution)_serviceProxy.Retrieve
          (
           Solution.EntityLogicalName,
           (Guid)dependency.DependentComponentBaseSolutionId,
           new ColumnSet("friendlyname")
          );
         dependentComponentSolutionName = dependentSolution.FriendlyName;

      // Retrieve the friendly name for the required solution.
         Solution requiredSolution = (Solution)_serviceProxy.Retrieve
           (
            Solution.EntityLogicalName,
            (Guid)dependency.RequiredComponentBaseSolutionId,
            new ColumnSet("friendlyname")
           );
         requiredComponentSolutionName = requiredSolution.FriendlyName;

      //Display the message
          Console.WriteLine("The {0} {1} in the {2} depends on the {3} {4} in the {5} solution.",
          dependentComponentName,
          dependentComponentTypeName,
          dependentComponentSolutionName,
          requiredComponentName,
          requiredComponentTypeName,
          requiredComponentSolutionName);
        }

     // The name or display name of the component depends on the type of component.
        public String getComponentName(int ComponentType, Guid ComponentId)
        {
         String name = "";

         switch (ComponentType)
         {
           // A separate method is required for each type of component
          case (int)componenttype.Attribute:
           name = getAttributeInformation(ComponentId);
           break;
          case (int)componenttype.OptionSet:
           name = getGlobalOptionSetName(ComponentId);
           break;
          default:
           name = "not implemented";
           break;
         }

         return name;

        }

     // Retrieve the display name and parent entity information about an attribute solution component.
        public string getAttributeInformation(Guid id)
        {
         String attributeInformation = "";
         RetrieveAttributeRequest req = new RetrieveAttributeRequest
         {
          MetadataId = id
         };
         RetrieveAttributeResponse resp = (RetrieveAttributeResponse)_serviceProxy.Execute(req);

         AttributeMetadata attmet = resp.AttributeMetadata;

         attributeInformation = attmet.EntityLogicalName + " : " + attmet.DisplayName.UserLocalizedLabel.Label;

         return attributeInformation;
        }
     //Retrieve the name of a global Option set
        public String getGlobalOptionSetName(Guid id)
        {
         String name = "";
          RetrieveOptionSetRequest req = new RetrieveOptionSetRequest
          {
           MetadataId = id
          };
          RetrieveOptionSetResponse resp = (RetrieveOptionSetResponse)_serviceProxy.Execute(req);
          OptionSetMetadataBase os = (OptionSetMetadataBase)resp.OptionSetMetadata;
          name = os.DisplayName.UserLocalizedLabel.Label;
         return name;
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create a publisher
        /// Create a new solution, "Primary"
        /// Create a Global Option Set in solution "Primary"
        /// Export the "Primary" solution, setting it to Protected
        /// Delete the option set and solution
        /// Import the "Primary" solution, creating a managed solution in CRM.
        /// Create a new solution, "Secondary"
        /// Create an attribute in "Secondary" that references the Global Option Set
        /// </summary>
        public void CreateRequiredRecords()
        {
            //Create the publisher that will "own" the two solutions
            Publisher publisher = new Publisher
            {
                UniqueName = "examplepublisher",
                FriendlyName = "An Example Publisher",
                Description = "This is an example publisher",
                CustomizationPrefix = _prefix
            };
            _publisherId = _serviceProxy.Create(publisher);
            //Create the primary solution - note that we are not creating it
            //as a managed solution as that can only be done when exporting the solution.
            Solution primarySolution = new Solution
            {
                Version = "1.0",
                FriendlyName = "Primary Solution",
                PublisherId = new EntityReference(Publisher.EntityLogicalName, _publisherId),
                UniqueName = _primarySolutionName
            };
            _primarySolutionId = _serviceProxy.Create(primarySolution);
            //Now, create the Global Option Set and associate it to the solution.
            OptionSetMetadata optionSetMetadata = new OptionSetMetadata()
            {
                Name = _globalOptionSetName,
                DisplayName = new Label("Example Option Set", _languageCode),
                IsGlobal = true,
                OptionSetType = OptionSetType.Picklist,
                Options =
            {
                new OptionMetadata(new Label("Option 1", _languageCode), 1),
                new OptionMetadata(new Label("Option 2", _languageCode), 2)
            }
            };
            CreateOptionSetRequest createOptionSetRequest = new CreateOptionSetRequest
            {
                OptionSet = optionSetMetadata
            };

            createOptionSetRequest.SolutionUniqueName = _primarySolutionName;
            _serviceProxy.Execute(createOptionSetRequest);
            //Export the solution as managed so that we can later import it.
            ExportSolutionRequest exportRequest = new ExportSolutionRequest
            {
                Managed = true,
                SolutionName = _primarySolutionName
            };
            ExportSolutionResponse exportResponse =
                (ExportSolutionResponse)_serviceProxy.Execute(exportRequest);
            // Delete the option set previous created, so it can be imported under the
            // managed solution.
            DeleteOptionSetRequest deleteOptionSetRequest = new DeleteOptionSetRequest
            {
                Name = _globalOptionSetName
            };
            _serviceProxy.Execute(deleteOptionSetRequest);
            // Delete the previous primary solution, so it can be imported as managed.
            _serviceProxy.Delete(Solution.EntityLogicalName, _primarySolutionId);
            _primarySolutionId = Guid.Empty;

            // Re-import the solution as managed.
            ImportSolutionRequest importRequest = new ImportSolutionRequest
            {
                CustomizationFile = exportResponse.ExportSolutionFile
            };
            _serviceProxy.Execute(importRequest);

            // Retrieve the solution from CRM in order to get the new id.
            QueryByAttribute primarySolutionQuery = new QueryByAttribute
            {
                EntityName = Solution.EntityLogicalName,
                ColumnSet = new ColumnSet("solutionid"),
                Attributes = { "uniquename" },
                Values = { _primarySolutionName }
            };
            _primarySolutionId = _serviceProxy.RetrieveMultiple(primarySolutionQuery).Entities
                .Cast<Solution>().FirstOrDefault().SolutionId.GetValueOrDefault();

            // Create a secondary solution.
            Solution secondarySolution = new Solution
            {
                Version = "1.0",
                FriendlyName = "Secondary Solution",
                PublisherId = new EntityReference(Publisher.EntityLogicalName, _publisherId),
                UniqueName = "SecondarySolution"
            };
            _secondarySolutionId = _serviceProxy.Create(secondarySolution);

            // Create a Picklist attribute in the secondary solution linked to the option set in the
            // primary - see WorkWithOptionSets.cs for more on option sets.
            PicklistAttributeMetadata picklistMetadata = new PicklistAttributeMetadata
            {
                SchemaName = _picklistName,
                LogicalName = _picklistName,
                DisplayName = new Label("Example Picklist", _languageCode),
                RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                OptionSet = new OptionSetMetadata
                {
                    IsGlobal = true,
                    Name = _globalOptionSetName
                }

            };

            CreateAttributeRequest createAttributeRequest = new CreateAttributeRequest
            {
                EntityName = Contact.EntityLogicalName,
                Attribute = picklistMetadata
            };
            createAttributeRequest["SolutionUniqueName"] = secondarySolution.UniqueName;
            _serviceProxy.Execute(createAttributeRequest);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {

                DeleteAttributeRequest deleteAttributeRequest = new DeleteAttributeRequest
                {
                    EntityLogicalName = Contact.EntityLogicalName,
                    LogicalName = _picklistName
                };
                _serviceProxy.Execute(deleteAttributeRequest);
                _serviceProxy.Delete(Solution.EntityLogicalName, _primarySolutionId);
                _serviceProxy.Delete(Solution.EntityLogicalName, _secondarySolutionId);
                _serviceProxy.Delete(Publisher.EntityLogicalName, _publisherId);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                GetSolutionDependencies app = new GetSolutionDependencies();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Introduction to solutions
Dependency tracking for solution components
Create, export, or import an unmanaged solution
Create, install, and update a managed solution
Uninstall or delete a solution
Work with solutions

Other Resources

Package and distribute extensions using solutions
Plan for solution development
Solution entities
Sample: Work with solutions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Developers guide to customization for Microsoft Dynamics CRM

This section describes the ways that you can use the customization methods in your custom code for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. For an in-depth guide to customization by using the tools available in the web application, see the Customization Guide.

In This Section

Extend the metadata model

Customize entity forms

Customize visualizations and dashboards

Customize entity views

Customize global option sets

Change application navigation using the SiteMap

Customize commands and the ribbon

Service calendar appearance configuration

Publish customizations

When to edit the customizations file

Add custom help content

Related Sections

Write client application extensions

Package and distribute extensions using solutions

Write plug-ins to extend business processes

Extend Microsoft Dynamics CRM for Outlook

Developers guide to reports for Microsoft Dynamics CRM

Write workflows to automate business processes

Integrate SharePoint with Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Extend the metadata model

Metadata refers to the structure of entities used to manage data within Microsoft Dynamics CRM. Virtually all tasks to manage metadata can be performed by using the customization tools in the CRM application. This section describes how to programmatically access and modify the metadata model.

In This Section

Customize entity metadata

Customize entity attribute metadata

Customize entity relationship metadata

Customize entity and attribute mappings

Customize labels to support multiple languages

Reference

Microsoft.Xrm.Sdk.Metadata

Related Sections

Customize entity forms

Customize visualizations and dashboards

Customize entity views

Customize global option sets

Change application navigation using the SiteMap

Customize commands and the ribbon

Service calendar appearance configuration

Publish customizations

When to edit the customizations file

Package and distribute extensions using solutions

Developers guide to customization for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize entity metadata

Entities are defined by metadata. By defining or changing the entity metadata, you can control the capabilities of an entity. To view the metadata for your organization, use the metadata browser provided in the SDK package. Download the Microsoft Dynamics CRM SDK package. More information: Browse the metadata for your organization

This topic is about how to work with entities programmatically. See Create and edit entities for information about working with entities in the application.

In This Topic

Options available when you create a custom entity

Enable entity capabilities

Editable entity properties

Entity metadata messages

Messages supported by custom entities

Options available when you create a custom entity

The following table lists the options that are available when you create a custom entity. You can only set these properties when you create a custom entity.

Option Description

Create as custom activity

You can create an entity that is an activity by setting the EntityMetadata.IsActivity property. For more information, see Custom activities.

Entity Names

There are two types of names, and both must have a customization prefix:

  • EntityMetadata.LogicalName: Name that is the version of the entity name that is set in all lowercase letters.
  • EntityMetadata.SchemaName: Name that will be used to create the database tables for the entity. This name can be mixed case. The casing that you use sets the name of the object generated for programming with strong types or when you use the REST endpoint.
Note
If the logical name differs from the schema name, the schema name will override the value that you set for the logical name.

When an entity is created in the application in the context of a specific solution, the customization prefix used is the one set for the Publisher of the solution. When an entity is created programmatically, you can set the customization prefix to a string that is between two and eight characters in length, all alphanumeric characters and it must start with a letter. It cannot start with “mscrm”. The best practice is to use the customization prefix defined by the publisher that the solution is associated with, but this is not a requirement. An underscore character must be included between the customization prefix and the logical or schema name.

Ownership

Use the EntityMetadata.OwnershipType property to set this. Use the OwnershipTypes enumeration to set the type of entity ownership. The only valid values for custom entities are OrgOwned or UserOwned. For more information, see Entity Ownership.

Primary Attribute

Use CreateEntityRequest.PrimaryAttribute to set this. Each entity has a StringAttributeMetadata attribute that uses StringFormat.Text as the primary attribute. The value of this attribute is what is shown in a lookup for any related entities. Therefore, the value of the field should represent a name for the entity record.

Enable entity capabilities

The following table lists entity capabilities. You can set these capabilities when you create an entity or you can enable them later. Once enabled, these capabilities cannot be disabled.

Capability | Description
Business Process flows | Set the EntityMetadata. IsBusinessProcessEnabled to true in order to enable the entity for business process flows.
Notes | Use the CreateEntityRequest or UpdateEntityRequest.HasNotes property to create an entity relationship with the Annotation entity and enable the inclusion of a Notes area in the entity form. By including Notes, you can also add attachments to records.
Activities | Use the CreateEntityRequest or UpdateEntityRequest.HasActivities property to create an entity relationship with the ActivityPointer entity so that all the activity type entities can be associated with this entity.
Connections | Set the EntityMetadata.IsConnectionsEnabled property to enable creating connection records to associate this entity with other connection entities.
Queues | Use the EntityMetadata.IsValidForQueue property to add support for queues. When you enable this option, you can also set the EntityMetadata.AutoRouteToOwnerQueue property to automatically move records to the owner’s default queue when a record of this type is created or assigned.
E-mail | Set the EntityMetadata.IsActivityParty property so that you can send e-mail to an e-mail address in this type of record.

Editable entity properties

The following table lists entity properties that you can edit. Unless a managed property disallows these options, you can update them at any time.

Property Description

Allow Quick Create

Use EntityMetadata.IsQuickCreateEnabled to enable quick create forms for the entity. Before you can use quick create forms you must first create and publish a quick create form.

Note
Activity entities do not support quick create forms.

Access Teams

Use EntityMetadata.AutoCreateAccessTeams to enable the entity for access teams. See About team templatesfor more information.

Primary Image

If an entity has an image attribute you can enable or disable displaying that image in the application using PrimaryImageAttribute. For more information see Entity Images.

Change display text

The managed property EntityMetadata.IsRenameable prevents the display name from being changed in the application. You can still programmatically change the labels by updating the EntityMetadata.DisplayName and EntityMetadata.DisplayCollectionName properties.

Edit the entity Description

The managed property EntityMetadata.IsRenameable prevents the entity description from being changed in the application. You can still programmatically change the labels by updating the EntityMetadata.Description property.

Enable for use while offline

Use EntityMetadata.IsAvailableOffline to enable or disable the ability of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access users to take data for this entity offline.

Enable the Outlook Reading Pane

Note
The EntityMetadata.IsReadingPaneEnabled property is For internal use only.

To enable or disable the ability of Microsoft Dynamics CRM for Microsoft Office Outlook users to view data for this entity, use the Microsoft Outlook reading pane. You must set this property in the application.

Enable Mail Merge

Use EntityMetadata.IsMailMergeEnabled to enable or disable the ability to generate Microsoft Office Word merged documents that use data from this entity.

Enable Duplicate Detection

Use EntityMetadata.IsDuplicateDetectionEnabled to enable or disable duplicate detection for the entity. For more information, see Detect duplicate data.

Enable SharePoint Integration

Use EntityMetadata.IsDocumentManagementEnabled to enable or disable SharePoint Server integration for the entity. For more information, see Enable document management for entities.

Enable CRM for phones

Use EntityMetadata.IsVisibleInMobile to enable or disable the ability of Microsoft Dynamics CRM for phones users to see data for this entity.

CRM for tablets

Use EntityMetadata.IsVisibleInMobileClient to enable or disable the ability of Microsoft Dynamics CRM for tablets users to see data for this entity.

If the entity is available for CRM for tablets you can use EntityMetadata.IsReadOnlyInMobileClient to specify that the data for the record is read-only.

Enable Auditing

Use EntityMetadata.IsAuditEnabled to enable or disable auditing for the entity. For more information, see Configure entities and attributes for auditing.

Change areas that display the entity

You can control where entity grids appear in the application Navigation Pane. This is controlled by the SiteMap. For more information, see Edit the site map.

Add or Remove Attributes

As long as the managed property EntityMetadata.CanCreateAttributes allows for creating attributes, you can use the CreateAttributeRequest message to add attributes. For more information, see Customize entity attribute metadata.

Add or Remove Views

As long as the managed property EntityMetadata.CanCreateViews allows for creating views, you can use the SavedQuery entity to create views for an entity.

Add or Remove Charts

As long as the managed property EntityMetadata.CanCreateCharts allows for creating charts and the EntityMetadata.IsEnabledForCharts entity property is true, you can use SavedQueryVisualization to create charts for an entity. For more information, see View data with visualizations (charts).

Add or Remove Entity Relationships

There are several managed properties that control the types of entity relationships that you can create for an entity. For more information, see Customize entity relationship metadata.

Change Icons

You can change the icons used for custom entities. For more information, see Modify the icons for an entity.

Use custom Help

EntityMetadata.EntityHelpUrlEnabled controls whether custom help is enabled for the entity. More information: Add custom help content.

Help URL

EntityMetadata.EntityHelpUrl controls what resource is displayed for help content for the entity if custom help is enabled. More information: Add custom help content.

Can Change Hierarchical Relationship

EntityMetadata.CanChangeHierarchicalRelationship controls whether the hierarchical state of entity relationships included in your managed solutions can be changed. More information:

Entity metadata messages

The following table lists the messages that you can use to create, retrieve, update and delete entity metadata.

Message name | Description
CreateEntityRequest | Creates a custom entity.
DeleteEntityRequest | Deletes a custom entity.
RetrieveAllEntitiesRequest | Retrieves the metadata for all entities.
RetrieveEntityRequest | Retrieves the metadata for an entity.
UpdateEntityRequest | Updates the metadata for an entity.
RetrieveMetadataChangesRequest | Used together with objects in the Microsoft.Xrm.Sdk.Metadata.Query namespace to create a query to efficiently retrieve and detect changes to specific metadata. More information:Retrieve and detect changes to metadata.

Messages supported by custom entities

Custom entities support the same base messages as system entities. The set of messages available depends on whether the custom entity is user-owned or organization owned. For more information, see Actions on Entity Records.

See Also

Concepts

Introduction to entities in Microsoft Dynamics CRM
Browse the metadata for your organization
Customize entity attribute metadata
Customize entity relationship metadata
Enable document management for entities
Configure entities and attributes for auditing
Edit the site map
View data with visualizations (charts)
Which entities are customizable?
Create a custom entity
Retrieve, update, and delete entities
Create and update an entity than can be emailed
Create a custom activity entity
Modify the icons for an entity
Modify the messages for an entity

Other Resources

Extend the metadata model
Detect duplicate data
Sample: Create and update entity metadata
Sample: Create a custom activity entity
Sample: Create and update an emailable entity
Sample: Dump entity metadata to a file
Sample: Dump entity privilege information to a file

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Which entities are customizable?

Microsoft Dynamics CRM 2015 has 271 entities; of these, 98 entities are customizable. Any custom entities that you add are also customizable. Creators of managed solutions can use managed properties to select whether to enable customization of entities in their solutions. The specific customizations that are allowed for customizable entities are defined by other properties.

In This Topic

EntityMetadata properties that control customization

Fully customizable entities

Customizable entity properties

EntityMetadata properties that control customization

The following entity metadata properties define what types of customizations any entity will support.

Property | Description
IsCustomizable | Specifies whether an entity allows customization.
IsRenameable | Specifies whether you can change the display name for an entity in the application.
CanBeRelatedEntityInRelationship | Specifies whether you can add a lookup attribute to an entity to establish a custom entity relationship.
CanBePrimaryEntityInRelationship | Specifies whether you can set the entity to be the primary entity in a custom entity relationship.
CanBeInManyToMany | Specifies whether the entity can participate in a many-to-many custom entity relationship.
CanCreateForms | Specifies whether you can create custom forms for the entity.
CanCreateCharts | Specifies whether you can create charts for the entity.
CanCreateViews | Specifies whether you can create views for the entity.
CanCreateAttributes | Specifies whether you can create attributes for the entity.
CanModifyAdditionalSettings | Specifies whether any other entity properties not represented by a managed property can be changed.

Fully customizable entities

The following table lists the entities that support all the customization capabilities. Any custom entities you add will support the same capabilities.

Account | Campaign | CampaignActivity | CampaignResponse | Competitor | Connection
Contact | Contract | Email | Fax | Goal | Incident
Invoice | InvoiceDetail | Lead | Letter | List | Opportunity
OpportunityProduct | PhoneCall | Product | QueueItem | Quote | QuoteDetail
SalesLiterature | SalesOrder | SalesOrderDetail | ServiceAppointment | SystemUser | Task
Territory |  |  |  |  |

Customizable entity properties

The following table lists the customizable entities and the values for the entity metadata properties that control customizations.

DisplayName | IsCustomizable | CanBeInManyToMany | CanBePrimaryEntityInRelationship | CanBeRelatedEntityInRelationship | CanCreateAttributes | CanCreateCharts | CanCreateForms | CanCreateViews | CanModifyAdditionalSettings | IsRenameable
Account | True | True | True | True | True | True | True | True | True | True
ActivityMimeAttachment | True | False | False | False | False | False | False | False | True | False
ActivityPointer | True | False | False | False | False | True | False | True | True | True
Annotation | True | False | False | False | False | False | False | True | True | False
Appointment | True | True | True | True | True | True | False | True | True | True
BulkOperation | True | False | False | False | False | True | False | True | True | True
BusinessUnit | True | True | True | True | True | False | True | True | True | True
Campaign | True | True | True | True | True | True | True | True | True | True
CampaignActivity | True | True | True | True | True | True | True | True | True | True
CampaignResponse | True | True | True | True | True | True | True | True | True | True
Competitor | True | True | True | True | True | True | True | True | True | True
CompetitorAddress | True | False | False | False | False | False | False | False | True | False
Connection | True | True | True | True | True | True | True | True | True | True
ConnectionRole | True | False | False | False | False | False | False | False | True | True
Contact | True | True | True | True | True | True | True | True | True | True
Contract | True | True | True | True | True | True | True | True | True | True
ContractDetail | True | True | True | True | True | False | True | True | True | True
ContractTemplate | True | False | True | False | False | False | False | False | True | True
CustomerAddress | True | True | True | True | True | False | True | True | True | True
CustomerOpportunityRole | True | False | False | False | False | False | False | False | True | False
Discount | True | True | False | False | False | False | False | False | True | False
DiscountType | True | True | True | False | False | False | False | False | True | False
DuplicateRule | True | False | False | False | False | False | False | False | True | False
DuplicateRuleCondition | True | False | False | False | False | False | False | False | True | False
Email | True | True | True | True | True | True | True | True | True | True
EmailServerProfile | True | False | True | True | False | False | False | False | True | False
Equipment | True | True | True | True | True | False | True | True | True | True
Fax | True | True | True | True | True | True | True | True | True | True
FieldPermission | True | False | False | False | False | False | False | False | True | False
FieldSecurityProfile | True | False | False | False | False | False | False | False | True | False
Goal | True | True | True | True | True | True | True | True | True | True
GoalRollupQuery | True | True | True | True | False | True | False | True | True | True
ImportMap | True | False | True | False | False | False | False | False | True | False
Incident | True | True | True | True | True | True | True | True | True | True
IncidentResolution | True | False | False | False | False | False | False | False | True | True
InternalAddress | True | False | False | False | False | False | False | False | True | False
Invoice | True | True | True | True | True | True | True | True | True | True
InvoiceDetail | True | True | True | True | True | True | True | True | True | True
KbArticle | True | True | True | True | True | True | False | True | True | True
KbArticleTemplate | True | False | True | False | False | False | False | False | False | False
Lead | True | True | True | True | True | True | True | True | True | True
LeadAddress | True | False | False | False | False | False | False | False | True | False
Letter | True | True | True | True | True | True | True | True | True | True
List | True | True | True | True | True | True | True | True | True | True
Mailbox | True | False | True | True | True | True | True | True | True | False
MailMergeTemplate | True | True | True | True | True | False | True | True | True | True
Metric | True | True | True | True | False | True | False | True | True | True
Opportunity | True | True | True | True | True | True | True | True | True | True
OpportunityClose | True | False | False | False | False | False | False | False | True | False
OpportunityProduct | True | True | True | True | True | True | True | True | True | True
OrderClose | True | False | False | False | False | False | False | False | True | False
Organization | True | False | False | False | False | False | False | False | True | False
PhoneCall | True | True | True | True | True | True | True | True | True | True
PriceLevel | True | True | True | True | True | True | True | True | True | False
ProcessSession | True | False | False | False | False | False | False | True | True | False
ProcessStage | True | False | True | True | False | False | False | False | True | False
ProcessTrigger | True | True | False | False | False | False | False | False | True | False
Product | True | True | True | True | True | True | True | True | True | True
ProductPriceLevel | True | True | False | False | False | False | False | False | True | False
Publisher | True | False | False | False | False | False | False | False | True | False
Queue | True | True | True | True | True | False | True | True | True | True
QueueItem | True | True | True | True | True | True | True | True | True | True
Quote | True | True | True | True | True | True | True | True | True | True
QuoteClose | True | False | False | False | False | False | False | False | True | False
QuoteProduct | True | True | True | True | True | True | True | True | True | True
RecurringAppointmentMaster | True | True | True | True | True | True | False | True | True | True
Report | True | False | False | False | False | True | False | True | True | True
ReportCategory | True | True | True | True | True | False | True | True | True | False
Resource | True | False | False | False | False | False | False | False | True | False
ResourceGroup | True | False | False | False | False | False | False | False | True | False
ResourceGroupExpansion | True | False | False | False | False | False | False | False | True | False
Role | True | False | True | False | False | False | False | False | True | False
RolePrivileges | True | False | False | False | False | False | False | False | True | False
RollupField | True | False | False | False | False | False | False | False | True | True
SalesLiterature | True | True | True | True | True | True | True | True | True | True
SalesOrder | True | True | True | True | True | True | True | True | True | True
SalesOrderDetail | True | True | True | True | True | True | True | True | True | True
SavedQuery | True | False | False | False | False | False | False | False | True | False
SavedQueryVisualization | True | False | False | False | False | False | False | False | True | False
Service | True | False | True | False | False | True | False | True | True | False
ServiceAppointment | True | True | True | True | True | True | True | True | True | True
SharePointDocumentLocation | True | True | True | True | True | False | True | True | True | True
SharePointSite | True | True | True | True | True | False | True | True | True | True
Site | True | False | True | False | False | False | False | False | True | False
Solution | True | False | False | False | False | False | False | False | True | False
Subject | True | False | True | False | False | False | False | False | True | False
SystemUser | True | True | True | True | True | True | True | True | True | True
Task | True | True | True | True | True | True | True | True | True | True
Team | True | True | True | True | True | True | True | True | True | False
TeamTemplate | True | False | False | False | False | False | False | False | False | False
Template | True | False | False | False | False | False | False | True | True | True
Territory | True | True | True | True | True | True | True | True | True | True
TransactionCurrency | True | True | True | False | False | False | False | False | True | True
UoM | True | True | True | False | False | False | False | False | True | False
UoMSchedule | True | False | True | False | False | True | False | True | True | False
UserQuery | True | False | False | False | False | False | False | False | True | False
UserQueryVisualization | True | False | False | False | False | False | False | False | True | False
Workflow | True | False | True | False | False | False | False | False | True | False

See Also

Concepts

Use managed properties
Customize entity metadata
Create a custom entity
Modify the icons for an entity
Modify the messages for an entity

Other Resources

Sample: Create and update entity metadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create a custom entity

This topic shows how to create a custom user-owned entity called Bank Account and add four different types of attributes to it.

You can also create organization-owned custom entities. More information: Entity Ownership

Note
You won’t be able to see this entity in the application navigation unless the entity properties are edited to set the Areas that display this entity are set.

In This Topic

Create a custom entity

Add a String attribute to the custom entity

Add a Money attribute to the custom entity

Add a DateTime attribute to the custom entity

Add a Lookup attribute to the custom entity

Create a custom entity

The following sample uses the CreateEntityRequest to create the entity and the StringAttributeMetadata PrimaryAttribute.

The _customEntityName value is “new_bankaccount”.

C# Copy Code
CreateEntityRequest createrequest = new CreateEntityRequest
{

 //Define the entity
 Entity = new EntityMetadata
 {
  SchemaName = _customEntityName,
  DisplayName = new Label("Bank Account", 1033),
  DisplayCollectionName = new Label("Bank Accounts", 1033),
  Description = new Label("An entity to store information about customer bank accounts", 1033),
  OwnershipType = OwnershipTypes.UserOwned,
  IsActivity = false,

 },

 // Define the primary attribute for the entity
 PrimaryAttribute = new StringAttributeMetadata
 {
  SchemaName = "new_accountname",
  RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
  MaxLength = 100,
  FormatName = StringFormatName.Text,
  DisplayName = new Label("Account Name", 1033),
  Description = new Label("The primary attribute for the Bank Account entity.", 1033)
 }

};
_serviceProxy.Execute(createrequest);
Console.WriteLine("The bank account entity has been created.");

Add a String attribute to the custom entity

The following sample adds a StringAttributeMetadata attribute to the Bank Account entity.

C# Copy Code
CreateAttributeRequest createBankNameAttributeRequest = new CreateAttributeRequest
{
 EntityName = _customEntityName,
 Attribute = new StringAttributeMetadata
 {
  SchemaName = "new_bankname",
  RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
  MaxLength = 100,
  FormatName = StringFormatName.Text,
  DisplayName = new Label("Bank Name", 1033),
  Description = new Label("The name of the bank.", 1033)
 }
};

_serviceProxy.Execute(createBankNameAttributeRequest);

Add a Money attribute to the custom entity

The following sample adds a MoneyAttributeMetadata attribute to the Bank Account entity.

C# Copy Code
CreateAttributeRequest createBalanceAttributeRequest = new CreateAttributeRequest
{
 EntityName = _customEntityName,
 Attribute = new MoneyAttributeMetadata
 {
  SchemaName = "new_balance",
  RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
  PrecisionSource = 2,
  DisplayName = new Label("Balance", 1033),
  Description = new Label("Account Balance at the last known date", 1033),

 }
};

_serviceProxy.Execute(createBalanceAttributeRequest);

Add a DateTime attribute to the custom entity

The following sample adds a DateTimeAttributeMetadata attribute to the Bank Account entity.

C# Copy Code
CreateAttributeRequest createCheckedDateRequest = new CreateAttributeRequest
{
 EntityName = _customEntityName,
 Attribute = new DateTimeAttributeMetadata
 {
  SchemaName = "new_checkeddate",
  RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
  Format = DateTimeFormat.DateOnly,
  DisplayName = new Label("Date", 1033),
  Description = new Label("The date the account balance was last confirmed", 1033)

 }
};

_serviceProxy.Execute(createCheckedDateRequest);
Console.WriteLine("An date attribute has been added to the bank account entity.");

Add a Lookup attribute to the custom entity

The following sample uses CreateOneToManyRequest to create a one-to-many relationship with the Contact entity so that a LookupAttributeMetadata attribute is added to the Bank Account entity.

C# Copy Code
CreateOneToManyRequest req = new CreateOneToManyRequest()
{
 Lookup = new LookupAttributeMetadata()
 {
  Description = new Label("The owner of the bank account", 1033),
  DisplayName = new Label("Account Owner", 1033),
  LogicalName = "new_parent_contactid",
  SchemaName = "New_Parent_ContactId",
  RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.ApplicationRequired)
 },
 OneToManyRelationship = new OneToManyRelationshipMetadata()
 {
  AssociatedMenuConfiguration = new AssociatedMenuConfiguration()
  {
   Behavior = AssociatedMenuBehavior.UseCollectionName,
   Group = AssociatedMenuGroup.Details,
   Label = new Label("Bank Accounts", 1033),
   Order = 10000
  },
  CascadeConfiguration = new CascadeConfiguration()
  {
   Assign = CascadeType.Cascade,
   Delete = CascadeType.Cascade,
   Merge = CascadeType.Cascade,
   Reparent = CascadeType.Cascade,
   Share = CascadeType.Cascade,
   Unshare = CascadeType.Cascade
  },
  ReferencedEntity = Contact.EntityLogicalName,
  ReferencedAttribute = "contactid",
  ReferencingEntity = _customEntityName,
  SchemaName = "new_contact_new_bankaccount"
 }
};
_serviceProxy.Execute(req);

See Also

Concepts

Use the sample and helper code
Customize entity metadata
Which entities are customizable?
Retrieve, update, and delete entities
Create and update an entity than can be emailed
Create a custom activity entity
Modify the icons for an entity
Modify the messages for an entity

Other Resources

CreateEntityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Retrieve, update, and delete entities

This topic shows how to retrieve, update, and delete an entity by using the custom Bank Account entity created in Create a custom entity.

In This Topic

Retrieve and update an entity

Delete a custom entity

Retrieve and update an entity

The following sample retrieves an entity by using the RetrieveEntityRequest message. It then updates the entity to disable mail merge by setting the IsMailMergeEnabled property to false, and sets HasNotes to true in the UpdateEntityRequest to specify that the entity should include a relationship to the Annotation entity so that the entity can display notes.

C# Copy Code

RetrieveEntityRequest retrieveBankAccountEntityRequest = new RetrieveEntityRequest
{
 EntityFilters = EntityFilters.Entity,
 LogicalName = _customEntityName
};
RetrieveEntityResponse retrieveBankAccountEntityResponse = (RetrieveEntityResponse)_serviceProxy.Execute(retrieveBankAccountEntityRequest);
EntityMetadata BankAccountEntity = retrieveBankAccountEntityResponse.EntityMetadata;

// Disable Mail merge
BankAccountEntity.IsMailMergeEnabled = new BooleanManagedProperty(false);
// Enable Notes
UpdateEntityRequest updateBankAccountRequest = new UpdateEntityRequest
{
 Entity = BankAccountEntity,
 HasNotes = true
};

_serviceProxy.Execute(updateBankAccountRequest);

Delete a custom entity

The following sample uses the DeleteEntityRequest message to delete the entity with the logical name specified by the _customEntityName variable.

C# Copy Code
DeleteEntityRequest request = new DeleteEntityRequest()
{
 LogicalName = _customEntityName,
};
_serviceProxy.Execute(request);

See Also

Concepts

Use the sample and helper code
Customize entity metadata
Create and update an entity than can be emailed
Create a custom entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create and update an entity than can be emailed

You can create an entity that contains an email address you can use to send email activities to records for that entity.

The following sample creates a custom entity and sets the IsActivityParty property to true. It also creates a StringAttributeMetadata attribute using StringFormatName.Email to provide an email address to use.

Even if you add other StringAttributeMetadata attributes formatted as an email address, only the first one specified is used.

C# Copy Code

// Create the custom entity.
CreateEntityRequest createrequest = new CreateEntityRequest
{
    // Define an entity to enable for emailing. In order to do so,
    // IsActivityParty must be set.
    Entity = new EntityMetadata
    {
        SchemaName = _customEntityName,
        DisplayName = new Label("Agent", 1033),
        DisplayCollectionName = new Label("Agents", 1033),
        Description = new Label("Insurance Agents", 1033),
        OwnershipType = OwnershipTypes.UserOwned,
        IsActivity = false,

        // Unless this flag is set, this entity cannot be party to an
        // activity.
        IsActivityParty = true
    },

    // As with built-in emailable entities, the Primary Attribute will
    // be used in the activity party screens. Be sure to choose descriptive
    // attributes.
    PrimaryAttribute = new StringAttributeMetadata
    {
        SchemaName = "new_fullname",
        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
        MaxLength = 100,
        FormatName = StringFormatName.Text,
        DisplayName = new Label("Agent Name", 1033),
        Description = new Label("Agent Name", 1033)
    }
};

_serviceProxy.Execute(createrequest);
Console.WriteLine("The emailable entity has been created.");

// The entity will not be selectable as an activity party until its customizations
// have been published. Otherwise, the e-mail activity dialog cannot find
// a correct default view.
PublishAllXmlRequest publishRequest = new PublishAllXmlRequest();
_serviceProxy.Execute(publishRequest);

// Before any emails can be created for this entity, an Email attribute
// must be defined.
CreateAttributeRequest createFirstEmailAttributeRequest = new CreateAttributeRequest
{
    EntityName = _customEntityName,
    Attribute = new StringAttributeMetadata
    {
        SchemaName = "new_emailaddress",
        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
        MaxLength = 100,
        FormatName = StringFormatName.Email,
        DisplayName = new Label("Email Address", 1033),
        Description = new Label("Email Address", 1033)
    }
};

_serviceProxy.Execute(createFirstEmailAttributeRequest);
Console.WriteLine("An email attribute has been added to the emailable entity.");

// Create a second, alternate email address. Since there is already one
// email attribute on the entity, this will never be used for emailing
// even if the first one is not populated.
CreateAttributeRequest createSecondEmailAttributeRequest = new CreateAttributeRequest
{
    EntityName = _customEntityName,
    Attribute = new StringAttributeMetadata
    {
        SchemaName = "new_secondaryaddress",
        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
        MaxLength = 100,
        FormatName = StringFormatName.Email,
        DisplayName = new Label("Secondary Email Address", 1033),
        Description = new Label("Secondary Email Address", 1033)
    }
};

_serviceProxy.Execute(createSecondEmailAttributeRequest);

Console.WriteLine("A second email attribute has been added to the emailable entity.");

See Also

Concepts

Use the sample and helper code
Customize entity metadata
Which entities are customizable?
Create a custom entity
Retrieve, update, and delete entities
Create a custom activity entity
Modify the icons for an entity
Modify the messages for an entity

Other Resources

Sample: Create and update an emailable entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create a custom activity entity

This topic contains a sample that shows how to create a custom activity entity.

The following sample creates a custom entity and sets the IsActivity property to true. All activities must have a PrimaryAttribute SchemaName set to Subject so that it corresponds to the common ActivityPointer.Subject attribute used by all activities.

C# Copy Code
 // The custom prefix would typically be passed in as an argument or
 // determined by the publisher of the custom solution.
 String prefix = "new_";

 String customEntityName = prefix + "instantmessage";

 // Create the custom activity entity.
 CreateEntityRequest request = new CreateEntityRequest
 {
     HasNotes = true,
     HasActivities = false,
     PrimaryAttribute = new StringAttributeMetadata
     {
         SchemaName = "Subject",
         RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
         MaxLength = 100,
         DisplayName = new Label("Subject", 1033)
     },
     Entity = new EntityMetadata
     {
         IsActivity = true,
         SchemaName = customEntityName,
         DisplayName = new Label("Instant Message", 1033),
         DisplayCollectionName = new Label("Instant Messages", 1033),
         OwnershipType = OwnershipTypes.UserOwned,
         IsAvailableOffline = true,

     }
 };

 _serviceProxy.Execute(request);

 //Entity must be published

 // Add few attributes to the custom activity entity.
 CreateAttributeRequest fontFamilyAttributeRequest =
     new CreateAttributeRequest
{
    EntityName = customEntityName,
    Attribute = new StringAttributeMetadata
    {
        SchemaName = prefix + "fontfamily",
        DisplayName = new Label("Font Family", 1033),
        MaxLength = 100
    }
};
 CreateAttributeResponse fontFamilyAttributeResponse =
     (CreateAttributeResponse)_serviceProxy.Execute(
     fontFamilyAttributeRequest);

 CreateAttributeRequest fontColorAttributeRequest =
     new CreateAttributeRequest
 {
     EntityName = customEntityName,
     Attribute = new StringAttributeMetadata
     {
         SchemaName = prefix + "fontcolor",
         DisplayName = new Label("Font Color", 1033),
         MaxLength = 50
     }
 };
 CreateAttributeResponse fontColorAttributeResponse =
     (CreateAttributeResponse)_serviceProxy.Execute(
     fontColorAttributeRequest);

 CreateAttributeRequest fontSizeAttributeRequest =
     new CreateAttributeRequest
 {
     EntityName = customEntityName,
     Attribute = new IntegerAttributeMetadata
     {
         SchemaName = prefix + "fontSize",
         DisplayName = new Label("Font Size", 1033)
     }
 };
 CreateAttributeResponse fontSizeAttributeResponse =
     (CreateAttributeResponse)_serviceProxy.Execute(
     fontSizeAttributeRequest);

See Also

Concepts

Use the sample and helper code
Custom activities
Customize entity metadata
Modify the icons for an entity
Modify the messages for an entity

Other Resources

Sample: Create a custom activity entity
CreateEntityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Modify the icons for an entity

When you create a new entity, default icons are provided. You can change the icons of custom entities by creating image Web resources and updating EntityMetadata properties. Use the specifications in this topic when creating or ordering icons. You will need the icon files before you begin.

Note
When you first associate Web Resources with icons in the application the size of the icons will be checked. If you associate Web Resources programmatically, no size validation occurs. If the Web Resource is later updated with a large size image, no validation occurs.

For more information about how to manually update icons, see the Customer Center help topic Change entity icons.

Types of icons

The following table liststhe types of entity icons you can update.

Type Specifications Property

Icon in Web application

Displays when records for this entity are displayed in a grid.

  • 16x16px
  • Less than 10k

IconSmallName

Icon for Entity Forms

  • 32x32px
  • Less than 10k

IconMediumName

This size icon is not used in Microsoft Dynamics CRM 2015.

  • 66x48px
  • Less than 10k

IconLargeName

PNG Web resources are recommended because they support transparency and good compression with a better color fidelity than GIF. GIF, JPG, and ICO formats are supported for backwards compatibility when organizations are upgraded from Microsoft Dynamics CRM 4.0.

See Also

Concepts

Customize entity metadata
Modify the messages for an entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Modify the messages for an entity

When you customize system entity or system attribute display names, some messages displayed by Microsoft Dynamics CRM will reference the default display names. Edit the default messages to match your customized display names.

Edit messages by exporting, editing, and importing translations

You can edit text values for the base language exported by using the feature that allows for exporting and importing translations. When you export translations, you will download a compressed file. Extract the files and edit the CRMTranslations.xml file by using Microsoft Office Excel. You can edit display strings and localized labels. After editing the base language data in the exported file, you must compress the XRMTranslations.xml and [Content_Types].xml files and import them.

Note
You should evaluate each instance of the strings you want to change and look for variants that include uppercase letters or plural references. Avoid using a global find/replace.

Manually edit entity messages

For entity messages related to a specific entity, you can manually edit these messages in the entity customization user interface. You must save and publish each message and then publish customizations for your changes to be applied.

Note
The messages displayed in the user interface for a particular entity may not include every instance of the entity name for that entity.

Programmatically update entity display dtrings

The display strings are stored in the DisplayString entity. Note this entity doesn’t contain the default display strings. The two attributes for this entity that contain text are CustomDisplayString and PublishedDisplayString. By default, these attribute values are null unless the display string has been customized.

See Also

Concepts

Customize entity metadata
DisplayString entity messages and methods
Customize labels to support multiple languages

Other Resources

Sample: Create and update entity metadata
ExportTranslationRequest
ImportTranslationRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DisplayString entity messages and methods

A display string represents a customized message for an entity that has been renamed. The schema name for this entity is DisplayString. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves a display string. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of display strings. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a display string. You can also call the IOrganizationService.Update method.

See Also

Concepts

Modify the messages for an entity
Service calendar appearance configuration
DisplayString entity privileges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create and update entity metadata
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Entities\CreateUpdateEntityMetadata.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a custom entity by using the CreateEntityRequest message. It also uses the CreateAttributeRequest to add several different types of attributes to the entity.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Diagnostics;
using System.Xml.Linq;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
 public class CreateUpdateEntityMetadata
 {
  #region Class Level Members
  /// <summary>
  /// Stores the organization service proxy.
  /// </summary>
  private OrganizationServiceProxy _serviceProxy;

  private const String _customEntityName = "new_bankaccount";

  #endregion Class Level Members

  #region How To Sample Code
  /// <summary>
  /// Create a custom entity.
  /// Update the custom entity.
  /// Optionally delete the custom entity.
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>
  /// <param name="promptForDelete">When True, the user will be prompted to delete all
  /// created entities.</param>
  public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
  {
   try
   {

    // Connect to the Organization service.
    // The using statement assures that the service proxy will be properly disposed.
    using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();

     // Create the custom entity.
     CreateEntityRequest createrequest = new CreateEntityRequest
     {

      //Define the entity
      Entity = new EntityMetadata
      {
       SchemaName = _customEntityName,
       DisplayName = new Label("Bank Account", 1033),
       DisplayCollectionName = new Label("Bank Accounts", 1033),
       Description = new Label("An entity to store information about customer bank accounts", 1033),
       OwnershipType = OwnershipTypes.UserOwned,
       IsActivity = false,

      },

      // Define the primary attribute for the entity
      PrimaryAttribute = new StringAttributeMetadata
      {
       SchemaName = "new_accountname",
       RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
       MaxLength = 100,
       FormatName = StringFormatName.Text,
       DisplayName = new Label("Account Name", 1033),
       Description = new Label("The primary attribute for the Bank Account entity.", 1033)
      }

     };
     _serviceProxy.Execute(createrequest);
     Console.WriteLine("The bank account entity has been created.");

     // Add some attributes to the Bank Account entity
     CreateAttributeRequest createBankNameAttributeRequest = new CreateAttributeRequest
     {
      EntityName = _customEntityName,
      Attribute = new StringAttributeMetadata
      {
       SchemaName = "new_bankname",
       RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
       MaxLength = 100,
       FormatName = StringFormatName.Text,
       DisplayName = new Label("Bank Name", 1033),
       Description = new Label("The name of the bank.", 1033)
      }
     };

     _serviceProxy.Execute(createBankNameAttributeRequest);
     Console.WriteLine("An bank name attribute has been added to the bank account entity.");

     CreateAttributeRequest createBalanceAttributeRequest = new CreateAttributeRequest
     {
      EntityName = _customEntityName,
      Attribute = new MoneyAttributeMetadata
      {
       SchemaName = "new_balance",
       RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
       PrecisionSource = 2,
       DisplayName = new Label("Balance", 1033),
       Description = new Label("Account Balance at the last known date", 1033),

      }
     };

     _serviceProxy.Execute(createBalanceAttributeRequest);
     Console.WriteLine("An account balance attribute has been added to the bank account entity.");

     CreateAttributeRequest createCheckedDateRequest = new CreateAttributeRequest
     {
      EntityName = _customEntityName,
      Attribute = new DateTimeAttributeMetadata
      {
       SchemaName = "new_checkeddate",
       RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
       Format = DateTimeFormat.DateOnly,
       DisplayName = new Label("Date", 1033),
       Description = new Label("The date the account balance was last confirmed", 1033)

      }
     };

     _serviceProxy.Execute(createCheckedDateRequest);
     Console.WriteLine("An date attribute has been added to the bank account entity.");
     //Create a lookup attribute to link the bank account with a contact record.

     CreateOneToManyRequest req = new CreateOneToManyRequest()
     {
      Lookup = new LookupAttributeMetadata()
      {
       Description = new Label("The owner of the bank account", 1033),
       DisplayName = new Label("Account Owner", 1033),
       LogicalName = "new_parent_contactid",
       SchemaName = "New_Parent_ContactId",
       RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.ApplicationRequired)
      },
      OneToManyRelationship = new OneToManyRelationshipMetadata()
      {
       AssociatedMenuConfiguration = new AssociatedMenuConfiguration()
       {
        Behavior = AssociatedMenuBehavior.UseCollectionName,
        Group = AssociatedMenuGroup.Details,
        Label = new Label("Bank Accounts", 1033),
        Order = 10000
       },
       CascadeConfiguration = new CascadeConfiguration()
       {
        Assign = CascadeType.Cascade,
        Delete = CascadeType.Cascade,
        Merge = CascadeType.Cascade,
        Reparent = CascadeType.Cascade,
        Share = CascadeType.Cascade,
        Unshare = CascadeType.Cascade
       },
       ReferencedEntity = Contact.EntityLogicalName,
       ReferencedAttribute = "contactid",
       ReferencingEntity = _customEntityName,
       SchemaName = "new_contact_new_bankaccount"
      }
     };
     _serviceProxy.Execute(req);
     Console.WriteLine("A lookup attribute has been added to the bank account entity to link it with the Contact entity.");

     //Create an Image attribute for the custom entity
     // Only one Image attribute can be added to an entity that doesn't already have one.
     CreateAttributeRequest createEntityImageRequest = new CreateAttributeRequest
     {
      EntityName = _customEntityName,
      Attribute = new ImageAttributeMetadata
      {
       SchemaName = "EntityImage", //The name is always EntityImage
       RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
       DisplayName = new Label("Image", 1033),
       Description = new Label("An image to represent the bank account.", 1033)

      }
     };

     _serviceProxy.Execute(createEntityImageRequest);
     Console.WriteLine("An image attribute has been added to the bank account entity.");

     RetrieveEntityRequest retrieveBankAccountEntityRequest = new RetrieveEntityRequest
     {
      EntityFilters = EntityFilters.Entity,
      LogicalName = _customEntityName
     };
     RetrieveEntityResponse retrieveBankAccountEntityResponse = (RetrieveEntityResponse)_serviceProxy.Execute(retrieveBankAccountEntityRequest);
     EntityMetadata BankAccountEntity = retrieveBankAccountEntityResponse.EntityMetadata;

     // Disable Mail merge
     BankAccountEntity.IsMailMergeEnabled = new BooleanManagedProperty(false);
     // Enable Notes
     UpdateEntityRequest updateBankAccountRequest = new UpdateEntityRequest
     {
      Entity = BankAccountEntity,
      HasNotes = true
     };

     _serviceProxy.Execute(updateBankAccountRequest);

     Console.WriteLine("The bank account entity has been updated");

     //Update the entity form so the new fields are visible
     UpdateEntityForm(_customEntityName);

     // Customizations must be published after an entity is updated.
     PublishAllXmlRequest publishRequest = new PublishAllXmlRequest();
     _serviceProxy.Execute(publishRequest);
     Console.WriteLine("Customizations were published.");

     //Provides option to view the entity in the default solution
     ShowEntityInBrowser(promptForDelete, BankAccountEntity);
     //Provides option to view the entity form with the fields added
     ShowEntityFormInBrowser(promptForDelete, BankAccountEntity);

     DeleteRequiredRecords(promptForDelete);
    }
   }

   // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  /// <summary>
  /// Deletes the custom entity that was created for this sample.
  /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
  /// </summary>
  public void DeleteRequiredRecords(bool prompt)
  {
   bool deleteEntity = true;

   if (prompt)
   {
    Console.WriteLine("\nDo you want this custom entity deleted? (y/n)");
    String answer = Console.ReadLine();

    deleteEntity = (answer.StartsWith("y") || answer.StartsWith("Y"));
   }

   if (deleteEntity)
   {
    DeleteEntityRequest request = new DeleteEntityRequest()
    {
     LogicalName = _customEntityName,
    };
    _serviceProxy.Execute(request);
    Console.WriteLine("The records have been deleted.");
   }
  }

  public void ShowEntityInBrowser(bool prompt, EntityMetadata BankAccountEntity)
  {

   if (prompt)
   {

    Console.WriteLine("\nDo you want to view this custom entity in the default solution? (y/n)");
    String answer = Console.ReadLine();
    if (answer.StartsWith("y") || answer.StartsWith("Y"))
    {

     try
     {
      String webServiceURL = _serviceProxy.EndpointSwitch.PrimaryEndpoint.AbsoluteUri;
      String entityInDefaultSolutionUrl = webServiceURL.Replace("XRMServices/2011/Organization.svc",
       String.Format("tools/solution/edit.aspx?def_category=9801&def_type={0}&id=%7bFD140AAF-4DF4-11DD-BD17-0019B9312238%7d", BankAccountEntity.ObjectTypeCode));

      ProcessStartInfo browserProcess = new ProcessStartInfo("iexplore.exe");
      browserProcess.Arguments = entityInDefaultSolutionUrl;
      Process.Start(browserProcess);

     }
     catch (SystemException)
     {
      Console.WriteLine("\nThere was a problem opening Internet Explorer.");
     }

    }

   }

  }

  public void ShowEntityFormInBrowser(bool prompt, EntityMetadata BankAccountEntity)
  {
   if (prompt)
   {
    Console.WriteLine("\nDo you want to view the form for this entity? (y/n)");
    String viewFormAnswer = Console.ReadLine();
    if (viewFormAnswer.StartsWith("y") || viewFormAnswer.StartsWith("Y"))
    {
     try
     {
      String webServiceURL = _serviceProxy.EndpointSwitch.PrimaryEndpoint.AbsoluteUri;
      String entityInDefaultSolutionUrl = webServiceURL.Replace("XRMServices/2011/Organization.svc",
       String.Format("main.aspx?etn={0}&pagetype=entityrecord", BankAccountEntity.LogicalName));

      ProcessStartInfo browserProcess = new ProcessStartInfo("iexplore.exe");
      browserProcess.Arguments = entityInDefaultSolutionUrl;
      Process.Start(browserProcess);

     }
     catch (SystemException)
     {
      Console.WriteLine("\nThere was a problem opening Internet Explorer.");
     }
    }
   }
  }
  /// <summary>
  /// Updates the formXml to add a new tab containing the fields added by this sample.
  /// <param name="entityLogicalName">The logical name of the new_bankaccount entity used in this sample</param>
  /// </summary>
  public void UpdateEntityForm(String entityLogicalName)
  {

   QueryExpression qe = new QueryExpression("systemform");
   qe.Criteria.AddCondition("type", ConditionOperator.Equal, 2); //main form
   qe.Criteria.AddCondition("objecttypecode", ConditionOperator.Equal, entityLogicalName); //for new_bankaccount entity
   qe.ColumnSet.AddColumn("formxml");
   //Retrieve the first main entity form for this entity
   SystemForm bankAccountMainForm = (SystemForm)_serviceProxy.RetrieveMultiple(qe).Entities[0];

   XDocument bankAccountFormXml = XDocument.Parse(bankAccountMainForm.FormXml);
   //Set the showImage attribute so the entity image will be displayed
   bankAccountFormXml.Root.SetAttributeValue("showImage", true);

   // Definition of a custom tab containing the custom attributes created in this sample
   String formTabXmlString = @"<tab name=""custom_attributes""
       id=""{824792c4-ea85-1504-40e2-b780b26dc6ab}""
       IsUserDefined=""0""
       locklevel=""0""
       showlabel=""true""
       expanded=""true"">
   <labels>
    <label description=""Custom Attributes""
           languagecode=""1033"" />
   </labels>
   <columns>
    <column width=""100%"">
     <sections>
      <section name=""custom_section""
               showlabel=""false""
               showbar=""false""
               locklevel=""0""
               id=""{9bda81ec-e41b-7a4d-08b4-4536c5862ce1}""
               IsUserDefined=""0""
               layout=""varwidth""
               columns=""1""
               labelwidth=""115""
               celllabelalignment=""Left""
               celllabelposition=""Left"">
       <labels>
        <label description=""Section""
               languagecode=""1033"" />
       </labels>
       <rows>
        <row>
         <cell id=""{04b95931-78c7-6913-a005-922d20e521b7}""
               showlabel=""true""
               locklevel=""0"">
          <labels>
           <label description=""Account Owner""
                  languagecode=""1033"" />
          </labels>
          <control id=""new_parent_contactid""
                   classid=""{270BD3DB-D9AF-4782-9025-509E298DEC0A}""
                   datafieldname=""new_parent_contactid""
                   disabled=""false"" />
         </cell>
        </row>
        <row>
         <cell id=""{6e5975d3-64b5-14eb-00e4-064e3dd298b9}""
               showlabel=""true""
               locklevel=""0"">
          <labels>
           <label description=""Bank Name""
                  languagecode=""1033"" />
          </labels>
          <control id=""new_bankname""
                   classid=""{4273EDBD-AC1D-40d3-9FB2-095C621B552D}""
                   datafieldname=""new_bankname""
                   disabled=""false"" />
         </cell>
        </row>
        <row>
         <cell id=""{3b436dba-6156-42e9-697b-e275d373505b}""
               showlabel=""true""
               locklevel=""0"">
          <labels>
           <label description=""Balance""
                  languagecode=""1033"" />
          </labels>
          <control id=""new_balance""
                   classid=""{533B9E00-756B-4312-95A0-DC888637AC78}""
                   datafieldname=""new_balance""
                   disabled=""false"" />
         </cell>
        </row>
        <row>
         <cell id=""{0e9a3d8a-bd69-71ad-4ca4-2dcd10858719}""
               showlabel=""true""
               locklevel=""0"">
          <labels>
           <label description=""Date""
                  languagecode=""1033"" />
          </labels>
          <control id=""new_checkeddate""
                   classid=""{5B773807-9FB2-42db-97C3-7A91EFF8ADFF}""
                   datafieldname=""new_checkeddate""
                   disabled=""false"" />
         </cell>
        </row>
       </rows>
      </section>
     </sections>
    </column>
   </columns>
  </tab>";

   XDocument formTabXml = XDocument.Parse(formTabXmlString);

   //Adding this tab to the tabs element
   bankAccountFormXml.Root.Element("tabs").Add(formTabXml.Root);
   //Updateing the entity form definition
   bankAccountMainForm.FormXml = bankAccountFormXml.ToString();
   //saving the bank account form
   _serviceProxy.Update(bankAccountMainForm);

  }
  #endregion How To Sample Code

  #region Main
  /// <summary>
  /// Standard Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    CreateUpdateEntityMetadata app = new CreateUpdateEntityMetadata();
    app.Run(config, true);
   }
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
     }
    }
   }
   // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {

    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }

  }
  #endregion Main

 }
}

See Also

Concepts

Customize entity metadata

Other Resources

Sample: Create a custom activity entity
Extend the metadata model
RetrieveAllEntitiesRequest
RetrieveAllEntitiesResponse

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a custom activity entity
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Entities\CreateCustomActivityEntity.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create a custom activity entity. It uses the CreateEntityRequest message and sets the EntityMetadata.IsActivity property to true.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to create a custom activity.
    /// </summary>
    public class CreateCustomActivityEntity
    {
        #region Class Level Members
        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create the custom entity.
        /// Optionally delete the custom entity.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // The custom prefix would typically be passed in as an argument or
                    // determined by the publisher of the custom solution.
                    String prefix = "new_";

                    String customEntityName = prefix + "instantmessage";

                    // Create the custom activity entity.
                    CreateEntityRequest request = new CreateEntityRequest
                    {
                        HasNotes = true,
                        HasActivities = false,
                        PrimaryAttribute = new StringAttributeMetadata
                        {
                            SchemaName = "Subject",
                            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                            MaxLength = 100,
                            DisplayName = new Label("Subject", 1033)
                        },
                        Entity = new EntityMetadata
                        {
                            IsActivity = true,
                            SchemaName = customEntityName,
                            DisplayName = new Label("Instant Message", 1033),
                            DisplayCollectionName = new Label("Instant Messages", 1033),
                            OwnershipType = OwnershipTypes.UserOwned,
                            IsAvailableOffline = true,

                        }
                    };

                    _serviceProxy.Execute(request);

                    //Entity must be published

                    // Add few attributes to the custom activity entity.
                    CreateAttributeRequest fontFamilyAttributeRequest =
                        new CreateAttributeRequest
                   {
                       EntityName = customEntityName,
                       Attribute = new StringAttributeMetadata
                       {
                           SchemaName = prefix + "fontfamily",
                           DisplayName = new Label("Font Family", 1033),
                           MaxLength = 100
                       }
                   };
                    CreateAttributeResponse fontFamilyAttributeResponse =
                        (CreateAttributeResponse)_serviceProxy.Execute(
                        fontFamilyAttributeRequest);

                    CreateAttributeRequest fontColorAttributeRequest =
                        new CreateAttributeRequest
                    {
                        EntityName = customEntityName,
                        Attribute = new StringAttributeMetadata
                        {
                            SchemaName = prefix + "fontcolor",
                            DisplayName = new Label("Font Color", 1033),
                            MaxLength = 50
                        }
                    };
                    CreateAttributeResponse fontColorAttributeResponse =
                        (CreateAttributeResponse)_serviceProxy.Execute(
                        fontColorAttributeRequest);

                    CreateAttributeRequest fontSizeAttributeRequest =
                        new CreateAttributeRequest
                    {
                        EntityName = customEntityName,
                        Attribute = new IntegerAttributeMetadata
                        {
                            SchemaName = prefix + "fontSize",
                            DisplayName = new Label("Font Size", 1033)
                        }
                    };
                    CreateAttributeResponse fontSizeAttributeResponse =
                        (CreateAttributeResponse)_serviceProxy.Execute(
                        fontSizeAttributeRequest);

                    Console.WriteLine("The custom activity has been created.");

                    DeleteCustomEntity(prefix, promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes the custom entity that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the entity created in this sample.</param>
        /// </summary>
        public void DeleteCustomEntity(String prefix, bool prompt)
        {
            bool deleteEntity = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want this custom entity deleted? (y/n)");
                char answer = Convert.ToChar(Console.ReadLine().Substring(0, 1));

                deleteEntity = (answer == 'y' || answer == 'Y');
            }

            if (deleteEntity)
            {
                DeleteEntityRequest request = new DeleteEntityRequest()
                {
                    LogicalName = prefix + "instantmessage",
                };
                _serviceProxy.Execute(request);

                Console.WriteLine("Entity has been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateCustomActivityEntity app = new CreateCustomActivityEntity();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Create a custom activity entity
Customize entity metadata

Other Resources

Extend the metadata model
Sample: Create and update an emailable entity
CreateEntityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create and update an emailable entity
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Entities\CreateUpdateEmailableEntity.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create an entity that can be used in the To field of an email activity. It uses the CreateEntityRequest message.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    public class CreateUpdateEmailableEntity
    {
        #region Class Level Members
        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        private const String _customEntityName = "new_agent";

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create a custom entity that can be used in the To field of an email activity.
        /// Update the custom entity.
        /// Optionally delete the custom entity.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Create the custom entity.
                    CreateEntityRequest createrequest = new CreateEntityRequest
                    {
                        // Define an entity to enable for emailing. In order to do so,
                        // IsActivityParty must be set.
                        Entity = new EntityMetadata
                        {
                            SchemaName = _customEntityName,
                            DisplayName = new Label("Agent", 1033),
                            DisplayCollectionName = new Label("Agents", 1033),
                            Description = new Label("Insurance Agents", 1033),
                            OwnershipType = OwnershipTypes.UserOwned,
                            IsActivity = false,

                            // Unless this flag is set, this entity cannot be party to an
                            // activity.
                            IsActivityParty = true
                        },

                        // As with built-in emailable entities, the Primary Attribute will
                        // be used in the activity party screens. Be sure to choose descriptive
                        // attributes.
                        PrimaryAttribute = new StringAttributeMetadata
                        {
                            SchemaName = "new_fullname",
                            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                            MaxLength = 100,
                            FormatName = StringFormatName.Text,
                            DisplayName = new Label("Agent Name", 1033),
                            Description = new Label("Agent Name", 1033)
                        }
                    };

                    _serviceProxy.Execute(createrequest);
                    Console.WriteLine("The emailable entity has been created.");

                    // The entity will not be selectable as an activity party until its customizations
                    // have been published. Otherwise, the e-mail activity dialog cannot find
                    // a correct default view.
                    PublishAllXmlRequest publishRequest = new PublishAllXmlRequest();
                    _serviceProxy.Execute(publishRequest);

                    // Before any emails can be created for this entity, an Email attribute
                    // must be defined.
                    CreateAttributeRequest createFirstEmailAttributeRequest = new CreateAttributeRequest
                    {
                        EntityName = _customEntityName,
                        Attribute = new StringAttributeMetadata
                        {
                            SchemaName = "new_emailaddress",
                            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                            MaxLength = 100,
                            FormatName = StringFormatName.Email,
                            DisplayName = new Label("Email Address", 1033),
                            Description = new Label("Email Address", 1033)
                        }
                    };

                    _serviceProxy.Execute(createFirstEmailAttributeRequest);
                    Console.WriteLine("An email attribute has been added to the emailable entity.");

                    // Create a second, alternate email address. Since there is already one
                    // email attribute on the entity, this will never be used for emailing
                    // even if the first one is not populated.
                    CreateAttributeRequest createSecondEmailAttributeRequest = new CreateAttributeRequest
                    {
                        EntityName = _customEntityName,
                        Attribute = new StringAttributeMetadata
                        {
                            SchemaName = "new_secondaryaddress",
                            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                            MaxLength = 100,
                            FormatName = StringFormatName.Email,
                            DisplayName = new Label("Secondary Email Address", 1033),
                            Description = new Label("Secondary Email Address", 1033)
                        }
                    };

                    _serviceProxy.Execute(createSecondEmailAttributeRequest);

                    Console.WriteLine("A second email attribute has been added to the emailable entity.");

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes the custom entity that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteEntity = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want this custom entity deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteEntity = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteEntity)
            {
                DeleteEntityRequest request = new DeleteEntityRequest()
                {
                    LogicalName = _customEntityName,
                };
                _serviceProxy.Execute(request);

                Console.WriteLine("The records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateUpdateEmailableEntity app = new CreateUpdateEmailableEntity();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize entity metadata
Create and update an entity than can be emailed

Other Resources

Extend the metadata model
Sample: Dump entity metadata to a file

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Dump entity metadata to a file
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Entities\DumpEntityInfo.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write out all the entity metadata to an XML file. It uses the RetrieveAllEntitiesRequest message.

The following sample creates a new file at \Entities\bin\Debug\EntityInfo.xml. You can open this file in Microsoft Office Excel to see a tabular report. You may need this information to discover the entity type code for a custom entity for use in reports.

Example

C# Copy Code
using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;
using System.Xml.Serialization;
using System.Xml;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve and write out entity metadata.
    /// </summary>
    public class DumpEntityInfo
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Create storage for new attributes being created
        public List<AttributeMetadata> addedAttributes;

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        public const int _languageCode = 1033;

        // Define the IDs/variables needed for this sample.
        public int _insertedStatusValue;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    RetrieveAllEntitiesRequest request = new RetrieveAllEntitiesRequest()
                    {
                        EntityFilters = EntityFilters.Entity,
                        RetrieveAsIfPublished = true
                    };

                    // Retrieve the MetaData.
                    RetrieveAllEntitiesResponse response = (RetrieveAllEntitiesResponse)_serviceProxy.Execute(request);

                    // Create an instance of StreamWriter to write text to a file.
                    // The using statement also closes the StreamWriter.
            // To view this file, right click the file and choose open with Excel.
            // Excel will figure out the schema and display the information in columns.

                    String filename = String.Concat("EntityInfo.xml");
                    using (StreamWriter sw = new StreamWriter(filename))
                    {
                        // Create Xml Writer.
                        XmlTextWriter metadataWriter = new XmlTextWriter(sw);

                        // Start Xml File.
                        metadataWriter.WriteStartDocument();

                        // Metadata Xml Node.
                        metadataWriter.WriteStartElement("Metadata");

                        foreach (EntityMetadata currentEntity in response.EntityMetadata)
                        {
                            //if (currentEntity.IsIntersect.Value == false)
                            if (true)
                            {
                                // Start Entity Node
                                metadataWriter.WriteStartElement("Entity");

                                // Write the Entity's Information.
                                metadataWriter.WriteElementString("EntitySchemaName", currentEntity.SchemaName);
                                metadataWriter.WriteElementString("OTC", currentEntity.ObjectTypeCode.ToString());
                                metadataWriter.WriteElementString("OwnershipType", currentEntity.OwnershipType.Value.ToString());
                                if (currentEntity.DisplayName.UserLocalizedLabel != null)
                                    metadataWriter.WriteElementString("DisplayName", currentEntity.DisplayName.UserLocalizedLabel.Label);
                                if (currentEntity.DisplayCollectionName.UserLocalizedLabel != null)
                                    metadataWriter.WriteElementString("DisplayCollectionName", currentEntity.DisplayCollectionName.UserLocalizedLabel.Label);

                                metadataWriter.WriteElementString("AutoRouteToOwnerQueue", currentEntity.AutoRouteToOwnerQueue.ToString());
                                metadataWriter.WriteElementString("CanBeInManyToMany", currentEntity.CanBeInManyToMany.Value.ToString());
                                metadataWriter.WriteElementString("CanBePrimaryEntityInRelationship", currentEntity.CanBePrimaryEntityInRelationship.Value.ToString());
                                metadataWriter.WriteElementString("CanBeRelatedEntityInRelationship", currentEntity.CanBeRelatedEntityInRelationship.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateAttributes", currentEntity.CanCreateAttributes.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateCharts", currentEntity.CanCreateCharts.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateForms", currentEntity.CanCreateForms.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateViews", currentEntity.CanCreateViews.Value.ToString());
                                metadataWriter.WriteElementString("CanModifyAdditionalSettings", currentEntity.CanModifyAdditionalSettings.Value.ToString());
                                metadataWriter.WriteElementString("CanTriggerWorkflow", currentEntity.CanTriggerWorkflow.Value.ToString());

                                metadataWriter.WriteElementString("IsActivity", currentEntity.IsActivity.Value.ToString());
                                //metadataWriter.WriteElementString("ActivityTypeMask", currentEntity.ActivityTypeMask.ToString());

                                metadataWriter.WriteElementString("IsActivityParty", currentEntity.IsActivityParty.Value.ToString());

                                metadataWriter.WriteElementString("IsAuditEnabled", currentEntity.IsAuditEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsAvailableOffline", currentEntity.IsAvailableOffline.ToString());
                                metadataWriter.WriteElementString("IsChildEntity", currentEntity.IsChildEntity.ToString());
                                metadataWriter.WriteElementString("IsConnectionsEnabled", currentEntity.IsConnectionsEnabled.ManagedPropertyLogicalName.ToString());
                                metadataWriter.WriteElementString("IsCustomEntity", currentEntity.IsCustomEntity.Value.ToString());
                                metadataWriter.WriteElementString("IsCustomizable", currentEntity.IsCustomizable.Value.ToString());

                                metadataWriter.WriteElementString("IsDocumentManagementEnabled", currentEntity.IsDocumentManagementEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsDuplicateDetectionEnabled", currentEntity.IsDuplicateDetectionEnabled.Value.ToString());
                                if (currentEntity.IsEnabledForCharts != null)
                                    metadataWriter.WriteElementString("IsEnabledForCharts", currentEntity.IsEnabledForCharts.Value.ToString());
                                metadataWriter.WriteElementString("IsImportable", currentEntity.IsImportable.Value.ToString());
                                metadataWriter.WriteElementString("IsIntersect", currentEntity.IsIntersect.Value.ToString());

                                metadataWriter.WriteElementString("IsMailMergeEnabled", currentEntity.IsMailMergeEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsManaged", currentEntity.IsManaged.Value.ToString());
                                metadataWriter.WriteElementString("IsMappable", currentEntity.IsMappable.Value.ToString());

                                metadataWriter.WriteElementString("IsReadingPaneEnabled", currentEntity.IsReadingPaneEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsRenameable", currentEntity.IsRenameable.Value.ToString());
                                metadataWriter.WriteElementString("IsValidForAdvancedFind", currentEntity.IsValidForAdvancedFind.Value.ToString());
                                metadataWriter.WriteElementString("IsValidForQueue", currentEntity.IsValidForQueue.Value.ToString());
                                metadataWriter.WriteElementString("IsVisibleInMobile", currentEntity.IsVisibleInMobile.Value.ToString());

                                metadataWriter.WriteElementString("PrimaryIdAttribute", currentEntity.PrimaryIdAttribute);
                                metadataWriter.WriteElementString("PrimaryNameAttribute", currentEntity.PrimaryNameAttribute);
                                metadataWriter.WriteElementString("ReportViewName", currentEntity.ReportViewName);
                                metadataWriter.WriteElementString("RecurrenceBaseEntityLogicalName", currentEntity.RecurrenceBaseEntityLogicalName);
                                if (currentEntity.Description.UserLocalizedLabel != null)
                                    metadataWriter.WriteElementString("Description", currentEntity.Description.UserLocalizedLabel.Label);

                                // End Entity Node
                                metadataWriter.WriteEndElement();
                            }
                        }

                        // End Metadata Xml Node
                        metadataWriter.WriteEndElement();
                        metadataWriter.WriteEndDocument();

                        // Close xml writer.
                        metadataWriter.Close();
                    }

                   Console.WriteLine("Done.");

                    //DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes/Reverts the record that was created/changed for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine(
                    "\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {

            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DumpEntityInfo app = new DumpEntityInfo();
                app.Run(config, false);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize entity metadata

Other Resources

Sample: Dump entity privilege information to a file
Extend the metadata model
RetrieveAllEntitiesRequest
RetrieveAllEntitiesResponse

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Dump entity privilege information to a file
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Entities\DumpEntityPrivileges.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write entity privilege information to an XML file, which will be located at \Entities\bin\Debug\EntityPrivileges.xml. It uses the RetrieveAllEntitiesRequest message.

Example

C# Copy Code
using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;
using System.Xml.Serialization;
using System.Xml;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve and write out entity metadata.
    /// </summary>
    public class DumpEntityInfo
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Create storage for new attributes being created
        public List<AttributeMetadata> addedAttributes;

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        public const int _languageCode = 1033;

        // Define the IDs/variables needed for this sample.
        public int _insertedStatusValue;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    RetrieveAllEntitiesRequest request = new RetrieveAllEntitiesRequest()
                    {
                        EntityFilters = EntityFilters.Entity,
                        RetrieveAsIfPublished = true
                    };

                    // Retrieve the MetaData.
                    RetrieveAllEntitiesResponse response = (RetrieveAllEntitiesResponse)_serviceProxy.Execute(request);

                    // Create an instance of StreamWriter to write text to a file.
                    // The using statement also closes the StreamWriter.
            // To view this file, right click the file and choose open with Excel.
            // Excel will figure out the schema and display the information in columns.

                    String filename = String.Concat("EntityInfo.xml");
                    using (StreamWriter sw = new StreamWriter(filename))
                    {
                        // Create Xml Writer.
                        XmlTextWriter metadataWriter = new XmlTextWriter(sw);

                        // Start Xml File.
                        metadataWriter.WriteStartDocument();

                        // Metadata Xml Node.
                        metadataWriter.WriteStartElement("Metadata");

                        foreach (EntityMetadata currentEntity in response.EntityMetadata)
                        {
                            //if (currentEntity.IsIntersect.Value == false)
                            if (true)
                            {
                                // Start Entity Node
                                metadataWriter.WriteStartElement("Entity");

                                // Write the Entity's Information.
                                metadataWriter.WriteElementString("EntitySchemaName", currentEntity.SchemaName);
                                metadataWriter.WriteElementString("OTC", currentEntity.ObjectTypeCode.ToString());
                                metadataWriter.WriteElementString("OwnershipType", currentEntity.OwnershipType.Value.ToString());
                                if (currentEntity.DisplayName.UserLocalizedLabel != null)
                                    metadataWriter.WriteElementString("DisplayName", currentEntity.DisplayName.UserLocalizedLabel.Label);
                                if (currentEntity.DisplayCollectionName.UserLocalizedLabel != null)
                                    metadataWriter.WriteElementString("DisplayCollectionName", currentEntity.DisplayCollectionName.UserLocalizedLabel.Label);

                                metadataWriter.WriteElementString("AutoRouteToOwnerQueue", currentEntity.AutoRouteToOwnerQueue.ToString());
                                metadataWriter.WriteElementString("CanBeInManyToMany", currentEntity.CanBeInManyToMany.Value.ToString());
                                metadataWriter.WriteElementString("CanBePrimaryEntityInRelationship", currentEntity.CanBePrimaryEntityInRelationship.Value.ToString());
                                metadataWriter.WriteElementString("CanBeRelatedEntityInRelationship", currentEntity.CanBeRelatedEntityInRelationship.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateAttributes", currentEntity.CanCreateAttributes.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateCharts", currentEntity.CanCreateCharts.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateForms", currentEntity.CanCreateForms.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateViews", currentEntity.CanCreateViews.Value.ToString());
                                metadataWriter.WriteElementString("CanModifyAdditionalSettings", currentEntity.CanModifyAdditionalSettings.Value.ToString());
                                metadataWriter.WriteElementString("CanTriggerWorkflow", currentEntity.CanTriggerWorkflow.Value.ToString());

                                metadataWriter.WriteElementString("IsActivity", currentEntity.IsActivity.Value.ToString());
                                //metadataWriter.WriteElementString("ActivityTypeMask", currentEntity.ActivityTypeMask.ToString());

                                metadataWriter.WriteElementString("IsActivityParty", currentEntity.IsActivityParty.Value.ToString());

                                metadataWriter.WriteElementString("IsAuditEnabled", currentEntity.IsAuditEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsAvailableOffline", currentEntity.IsAvailableOffline.ToString());
                                metadataWriter.WriteElementString("IsChildEntity", currentEntity.IsChildEntity.ToString());
                                metadataWriter.WriteElementString("IsConnectionsEnabled", currentEntity.IsConnectionsEnabled.ManagedPropertyLogicalName.ToString());
                                metadataWriter.WriteElementString("IsCustomEntity", currentEntity.IsCustomEntity.Value.ToString());
                                metadataWriter.WriteElementString("IsCustomizable", currentEntity.IsCustomizable.Value.ToString());

                                metadataWriter.WriteElementString("IsDocumentManagementEnabled", currentEntity.IsDocumentManagementEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsDuplicateDetectionEnabled", currentEntity.IsDuplicateDetectionEnabled.Value.ToString());
                                if (currentEntity.IsEnabledForCharts != null)
                                    metadataWriter.WriteElementString("IsEnabledForCharts", currentEntity.IsEnabledForCharts.Value.ToString());
                                metadataWriter.WriteElementString("IsImportable", currentEntity.IsImportable.Value.ToString());
                                metadataWriter.WriteElementString("IsIntersect", currentEntity.IsIntersect.Value.ToString());

                                metadataWriter.WriteElementString("IsMailMergeEnabled", currentEntity.IsMailMergeEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsManaged", currentEntity.IsManaged.Value.ToString());
                                metadataWriter.WriteElementString("IsMappable", currentEntity.IsMappable.Value.ToString());

                                metadataWriter.WriteElementString("IsReadingPaneEnabled", currentEntity.IsReadingPaneEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsRenameable", currentEntity.IsRenameable.Value.ToString());
                                metadataWriter.WriteElementString("IsValidForAdvancedFind", currentEntity.IsValidForAdvancedFind.Value.ToString());
                                metadataWriter.WriteElementString("IsValidForQueue", currentEntity.IsValidForQueue.Value.ToString());
                                metadataWriter.WriteElementString("IsVisibleInMobile", currentEntity.IsVisibleInMobile.Value.ToString());

                                metadataWriter.WriteElementString("PrimaryIdAttribute", currentEntity.PrimaryIdAttribute);
                                metadataWriter.WriteElementString("PrimaryNameAttribute", currentEntity.PrimaryNameAttribute);
                                metadataWriter.WriteElementString("ReportViewName", currentEntity.ReportViewName);
                                metadataWriter.WriteElementString("RecurrenceBaseEntityLogicalName", currentEntity.RecurrenceBaseEntityLogicalName);
                                if (currentEntity.Description.UserLocalizedLabel != null)
                                    metadataWriter.WriteElementString("Description", currentEntity.Description.UserLocalizedLabel.Label);

                                // End Entity Node
                                metadataWriter.WriteEndElement();
                            }
                        }

                        // End Metadata Xml Node
                        metadataWriter.WriteEndElement();
                        metadataWriter.WriteEndDocument();

                        // Close xml writer.
                        metadataWriter.Close();
                    }

                   Console.WriteLine("Done.");

                    //DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes/Reverts the record that was created/changed for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine(
                    "\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {

            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DumpEntityInfo app = new DumpEntityInfo();
                app.Run(config, false);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize entity metadata

Other Resources

Extend the metadata model
RetrieveAllEntitiesRequest
RetrieveAllEntitiesResponse

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize entity attribute metadata

Use the AttributeMetadata class to retrieve existing attributes. This class is returned by the RetrieveAttributeRequest message. The AttributeMetadata class inherits from the abstract MetadataBase class.

Use the specific class for each attribute type with the CreateAttributeRequest message to update attributes or create custom attributes.

Note
You can access custom attributes programmatically after you create them, but you must add them to an entity form and publish them before users can see them.

Attribute types

The following table lists each type of Attribute you can work with. Each attribute inherits from the AttributeMetadata class.

Class Application Label Description

BooleanAttributeMetadata

Two Option

A Boolean attribute. You can specify the text for both options. When added to a form, the field properties control whether the attribute is displayed as two radio buttons, a check box, or a list.

DateTimeAttributeMetadata

Date and Time

A date and time attribute. You can format the attribute to show only the date or the date and the time.

DecimalAttributeMetadata

Decimal Number

A decimal attribute. You can specify the level of precision up to ten decimal places and the minimum and maximum values from -100,000,000,000 to 100,000,000,000.

DoubleAttributeMetadata

Floating Point Number

A double attribute. You can specify the level of precision up to five decimal places and the minimum and maximum values from -100,000,000,000 to 100,000,000,000.

Note
DoubleAttributeMetadata replaces the FloatAttributeMetadata used in Microsoft Dynamics CRM 4.0.

ImageAttributeMetadata

Image

An image attribute. Each entity can have one image attribute. Certain system entities have image attributes and new image attributes cannot be added to system entities that do not have them. You can add an image attribute to custom entities

All image attributes have the SchemaName ‘EntityImage’ and the LogicalName ‘entityimage’. Custom image attributes will not use the solution publisher customization prefix in the name. More information: Entity images.

IntegerAttributeMetadata

Whole Number

An integer attribute. You can specify the maximum and minimum values from -2,147,483,648 to 2,147,483,647.

This attribute can be formatted to create the following types of fields using the IntegerFormat enumeration:

  • Duration: Displays a drop-down list that contains time intervals. A user can select a value from the list or type an integer value that represents the number of minutes.
  • TimeZone: Displays a drop-down list that contains a list of time zones.
  • Language: Displays a drop-down list that contains a list of languages that have been enabled for the organization. If no other languages have been enabled, the base language will be the only option. The value saved is the LCID value for the language.

LookupAttributeMetadata

Lookup

An attribute created when an entity relationship is created by using the CreateOneToManyRequest message.

MemoAttributeMetadata

Multiple Lines of Text

A memo attribute. Displays as a text box field in a form. The maximum length is 1048576 characters.

MoneyAttributeMetadata

Currency

A money attribute. You can specify the maximum and minimum values between - 922,337,203,685,477 and 922,337,203,685,477.

The level of precision can be set by using the PrecisionSource property:

  • When the precision is set to zero (0), the MoneyAttributeMetadata.Precision value is used.
  • When the precision is set to one (1), the Organization.PricingDecimalPrecision value is used.
  • When the precision is set to two (2), the TransactionCurrency.CurrencyPrecision value is used.

PicklistAttributeMetadata

Options Set

A picklistattribute. This attribute provides a set of options that are displayed in a drop-down list. You can create the picklist attribute so that it can contain its own options or use a global options set.

StateAttributeMetadata

Status

The state attribute is created automatically when the entity is created.

Note
The options available for this attribute are read-only.

StatusAttributeMetadata

Status Reason

The status attribute is created automatically when the entity is created. Each of the options must be associated with the StateAttributeMetadata attribute for the entity. Use the InsertStatusValueRequest message to update options available for this attribute.

Note
Each StatusOption must reference a specific state attribute value because status values depend on a specific state value.

StringAttributeMetadata

Single Line of Text

See StringAttributeMetadata formats.

StringAttributeMetadata formats

String attributes can be formatted to allow links to initiate phone calls by using Lync or Skype. This changes requires that a new FormatName property be added to the StringAttributeMetadata class and the deprecation of the Format property.

Using the StringFormat enumeration to define the format for StringAttributeMetadata.Format is deprecated. Instead, use the StringFormatName class to set the value of StringAttributeMetadata.FormatName.

This allows for setting the format value of PhoneNumber, which does not exist in the StringFormat enumeration.

For backwards compatibility, you can set a value to control how the attribute is formatted by using either the Format or FormatName property. Your existing code will continue to work if you only use Format, but you will not be able to format an attribute as a phone number without using FormatName. If both properties are set, the value set using FormatName is the one that will be applied.

The StringFormatName class contains the following members; each member returns a string with the same value as the member name:

Member name and value | Description
Email | The form field will validate the text value as an e-mail address and create a mailto link in the field.
PhoneNumber | The form field will contain a link to initiate a phone call by using Lync or Skype.
PhoneticGuide | For internal use only.
Text | The form will display a text box.
TextArea | The form will display a text area field.
TickerSymbol | The form will display a link that will open to display a quote for the stock ticker symbol.
URL | The form will display a link to open the URL.
VersionNumber | For internal use only.

See Also

Concepts

Work with attribute metadata
Entity attribute metadata messages

Other Resources

Extend the metadata model
Sample: Work with attribute metadata
Sample: Dump attribute metadata to a file
Sample: Dump attribute picklist metadata to a file
Technical Article: Using Option Set Options with the REST Endpoint - JScript

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Work with attribute metadata

This topic uses code snippets from the Sample: Work with attribute metadata to show how to perform common tasks when working with attributes.

In This Topic

Create attributes

Retrieve an attribute

Update an attribute

Create a lookup attribute

Update a state value

Create a picklist that uses a global option set

Insert a new status value

Insert a new option in a local option set

Change the order of options in a local option set

Delete an attribute

Create attributes

You create attributes by defining one of the AttributeMetadata types and then passing it to the CreateAttributeRequest message.

The following sample defines the AttributeMetadata for a number of different types of attributes and adds them to a List<AttributeMetadata>. At the end of the code the attribute definitions are passed to an instance of the CreateAttributeRequest class and the attribute is created using the Execute method.

The following sample assumes that the current customization prefix is ‘new’ because that is the default customization prefix for the organization solution publisher. You should use the customization prefix for the solution publisher that makes sense for your solution context.

C# Copy Code
// Create storage for new attributes being created
addedAttributes = new List<AttributeMetadata>();

// Create a boolean attribute
BooleanAttributeMetadata boolAttribute = new BooleanAttributeMetadata
{
    // Set base properties
    SchemaName = "new_boolean",
    DisplayName = new Label("Sample Boolean", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Boolean Attribute", _languageCode),
    // Set extended properties
    OptionSet = new BooleanOptionSetMetadata(
        new OptionMetadata(new Label("True", _languageCode), 1),
        new OptionMetadata(new Label("False", _languageCode), 0)
        )
};

// Add to list
addedAttributes.Add(boolAttribute);

// Create a date time attribute
DateTimeAttributeMetadata dtAttribute = new DateTimeAttributeMetadata
{
    // Set base properties
    SchemaName = "new_datetime",
    DisplayName = new Label("Sample DateTime", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("DateTime Attribute", _languageCode),
    // Set extended properties
    Format = DateTimeFormat.DateOnly,
    ImeMode = ImeMode.Disabled
};

// Add to list
addedAttributes.Add(dtAttribute);

// Create a decimal attribute
DecimalAttributeMetadata decimalAttribute = new DecimalAttributeMetadata
{
    // Set base properties
    SchemaName = "new_decimal",
    DisplayName = new Label("Sample Decimal", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Decimal Attribute", _languageCode),
    // Set extended properties
    MaxValue = 100,
    MinValue = 0,
    Precision = 1
};

// Add to list
addedAttributes.Add(decimalAttribute);

// Create a integer attribute
IntegerAttributeMetadata integerAttribute = new IntegerAttributeMetadata
{
    // Set base properties
    SchemaName = "new_integer",
    DisplayName = new Label("Sample Integer", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Integer Attribute", _languageCode),
    // Set extended properties
    Format = IntegerFormat.None,
    MaxValue = 100,
    MinValue = 0
};

// Add to list
addedAttributes.Add(integerAttribute);

// Create a memo attribute
MemoAttributeMetadata memoAttribute = new MemoAttributeMetadata
{
    // Set base properties
    SchemaName = "new_memo",
    DisplayName = new Label("Sample Memo", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Memo Attribute", _languageCode),
    // Set extended properties
    Format = StringFormat.TextArea,
    ImeMode = ImeMode.Disabled,
    MaxLength = 500
};

// Add to list
addedAttributes.Add(memoAttribute);

// Create a money attribute
MoneyAttributeMetadata moneyAttribute = new MoneyAttributeMetadata
{
    // Set base properties
    SchemaName = "new_money",
    DisplayName = new Label("Money Picklist", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Money Attribue", _languageCode),
    // Set extended properties
    MaxValue = 1000.00,
    MinValue = 0.00,
    Precision = 1,
    PrecisionSource = 1,
    ImeMode = ImeMode.Disabled
};

// Add to list
addedAttributes.Add(moneyAttribute);

// Create a picklist attribute
PicklistAttributeMetadata pickListAttribute =
    new PicklistAttributeMetadata
{
    // Set base properties
    SchemaName = "new_picklist",
    DisplayName = new Label("Sample Picklist", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Picklist Attribute", _languageCode),
    // Set extended properties
    // Build local picklist options
    OptionSet = new OptionSetMetadata
        {
            IsGlobal = false,
            OptionSetType = OptionSetType.Picklist,
            Options =
        {
            new OptionMetadata(
                new Label("Created", _languageCode), null),
            new OptionMetadata(
                new Label("Updated", _languageCode), null),
            new OptionMetadata(
                new Label("Deleted", _languageCode), null)
        }
        }
};

// Add to list
addedAttributes.Add(pickListAttribute);

// Create a string attribute
StringAttributeMetadata stringAttribute = new StringAttributeMetadata
{
    // Set base properties
    SchemaName = "new_string",
    DisplayName = new Label("Sample String", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("String Attribute", _languageCode),
    // Set extended properties
    MaxLength = 100
};

// Add to list
addedAttributes.Add(stringAttribute);

// NOTE: LookupAttributeMetadata cannot be created outside the context of a relationship.
// Refer to the WorkWithRelationships.cs reference SDK sample for an example of this attribute type.

// NOTE: StateAttributeMetadata and StatusAttributeMetadata cannot be created via the SDK.

foreach (AttributeMetadata anAttribute in addedAttributes)
{
    // Create the request.
    CreateAttributeRequest createAttributeRequest = new CreateAttributeRequest
    {
        EntityName = Contact.EntityLogicalName,
        Attribute = anAttribute
    };

    // Execute the request.
    _serviceProxy.Execute(createAttributeRequest);

    Console.WriteLine("Created the attribute {0}.", anAttribute.SchemaName);
}

Retrieve an attribute

This sample shows how to retrieve the AttributeMetadata for an attribute using the RetrieveAttributeRequest. This sample retrieves the metadata for a custom StringAttributeMetadata attribute called ‘new_string’ from the Contact entity that was created in Create Attributes.

Note
Because RetrieveAsIfPublished is true, this request returns the current unpublished definition of this attribute. You might use this if you are creating an Attribute editor and you want to retrieve the unpublished definition of the attribute. Otherwise, you should not specify RetrieveAsIfPublished. More information: Retrieving unpublished metadata

C# Copy Code
// Create the request
RetrieveAttributeRequest attributeRequest = new RetrieveAttributeRequest
{
    EntityLogicalName = Contact.EntityLogicalName,
    LogicalName = "new_string",
    RetrieveAsIfPublished = true
};

// Execute the request
RetrieveAttributeResponse attributeResponse =
    (RetrieveAttributeResponse)_serviceProxy.Execute(attributeRequest);

Console.WriteLine("Retrieved the attribute {0}.",
    attributeResponse.AttributeMetadata.SchemaName);

Update an attribute

This sample shows how to update an attribute. This sample uses the UpdateAttributeRequest to change the AttributeMetadata.DisplayName property of a previously retrieved custom attribute for the Contact entity.

C# Copy Code
// Modify the retrieved attribute
AttributeMetadata retrievedAttributeMetadata =
    attributeResponse.AttributeMetadata;
retrievedAttributeMetadata.DisplayName =
    new Label("Update String Attribute", _languageCode);

// Update an attribute retrieved via RetrieveAttributeRequest
UpdateAttributeRequest updateRequest = new UpdateAttributeRequest
{
    Attribute = retrievedAttributeMetadata,
    EntityName = Contact.EntityLogicalName,
    MergeLabels = false
};

// Execute the request
_serviceProxy.Execute(updateRequest);

Console.WriteLine("Updated the attribute {0}.",
    retrievedAttributeMetadata.SchemaName);

Create a lookup attribute

This sample shows how to create a lookup attribute.

A lookup attribute is created by using the CreateOneToManyRequest.

C# Copy Code
CreateOneToManyRequest req = new CreateOneToManyRequest()
{
 Lookup = new LookupAttributeMetadata()
 {
  Description = new Label("The owner of the bank account", 1033),
  DisplayName = new Label("Account Owner", 1033),
  LogicalName = "new_parent_contactid",
  SchemaName = "New_Parent_ContactId",
  RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.ApplicationRequired)
 },
 OneToManyRelationship = new OneToManyRelationshipMetadata()
 {
  AssociatedMenuConfiguration = new AssociatedMenuConfiguration()
  {
   Behavior = AssociatedMenuBehavior.UseCollectionName,
   Group = AssociatedMenuGroup.Details,
   Label = new Label("Bank Accounts", 1033),
   Order = 10000
  },
  CascadeConfiguration = new CascadeConfiguration()
  {
   Assign = CascadeType.Cascade,
   Delete = CascadeType.Cascade,
   Merge = CascadeType.Cascade,
   Reparent = CascadeType.Cascade,
   Share = CascadeType.Cascade,
   Unshare = CascadeType.Cascade
  },
  ReferencedEntity = Contact.EntityLogicalName,
  ReferencedAttribute = "contactid",
  ReferencingEntity = _customEntityName,
  SchemaName = "new_contact_new_bankaccount"
 }
};
_serviceProxy.Execute(req);

Create a picklist that uses a global option set

This sample shows how to create a PicklistAttributeMetadata attribute that is associated with a global option set.

The following sample uses CreateAttributeRequest to set the options for a PicklistAttributeMetadata attribute to use a global option set with a name represented by the string variable _globalOptionSetName. More information: Customize global option sets

C# Copy Code
// Create a Picklist linked to the option set.
// Specify which entity will own the picklist, and create it.
CreateAttributeRequest createRequest = new CreateAttributeRequest
{
    EntityName = Contact.EntityLogicalName,
    Attribute = new PicklistAttributeMetadata
    {
        SchemaName = "sample_examplepicklist",
        LogicalName = "sample_examplepicklist",
        DisplayName = new Label("Example Picklist", _languageCode),
        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),

        // In order to relate the picklist to the global option set, be sure
        // to specify the two attributes below appropriately.
        // Failing to do so will lead to errors.
        OptionSet = new OptionSetMetadata
        {
            IsGlobal = true,
            Name = _globalOptionSetName
        }
    }
};

_serviceProxy.Execute(createRequest);

Insert a new status value

This sample shows how to insert a new Status Reason option for StatusAttributeMetadata attribute.

The following sample uses the InsertStatusValueRequest to specify a new option for the Contact entity Contact.StatusCode attribute that is valid when the Contact.StateCode is 0 (Active). The IOrganizationService.Execute method processes the request.

The following sample allows two valid Status Reason options for active contacts: Active and Dormant.

C# Copy Code
// Use InsertStatusValueRequest message to insert a new status
// in an existing status attribute.
// Create the request.
InsertStatusValueRequest insertStatusValueRequest =
    new InsertStatusValueRequest
{
    AttributeLogicalName = "statuscode",
    EntityLogicalName = Contact.EntityLogicalName,
    Label = new Label("Dormant", _languageCode),
    StateCode = 0
};

// Execute the request and store newly inserted value
// for cleanup, used later part of this sample.
_insertedStatusValue = ((InsertStatusValueResponse)_serviceProxy.Execute(
    insertStatusValueRequest)).NewOptionValue;

Console.WriteLine("Created {0} with the value of {1}.",
    insertStatusValueRequest.Label.LocalizedLabels[0].Label,
    _insertedStatusValue);

Update a state value

This sample shows how to change the label for an option in a StateAttributeMetadata attribute.

The following sample uses UpdateStateValueRequest to change the Contact.StateCode option label from Active to Open.

C# Copy Code
// Modify the state value label from Active to Open.
// Create the request.
UpdateStateValueRequest updateStateValue = new UpdateStateValueRequest
{
    AttributeLogicalName = "statecode",
    EntityLogicalName = Contact.EntityLogicalName,
    Value = 1,
    Label = new Label("Open", _languageCode)
};

// Execute the request.
_serviceProxy.Execute(updateStateValue);

Console.WriteLine(
    "Updated {0} state attribute of {1} entity from 'Active' to '{2}'.",
    updateStateValue.AttributeLogicalName,
    updateStateValue.EntityLogicalName,
    updateStateValue.Label.LocalizedLabels[0].Label
    );

You cannot add or remove StateCode options, but you can change the labels for the options.

Insert a new option in a local option set

This sample shows how to add a new option to a local option set. The following sampleuses InsertOptionValueRequest to add a new option to a custom PicklistAttributeMetadata attribute for the Contact entity.

C# Copy Code
// Create a request.
InsertOptionValueRequest insertOptionValueRequest =
    new InsertOptionValueRequest
{
    AttributeLogicalName = "new_picklist",
    EntityLogicalName = Contact.EntityLogicalName,
    Label = new Label("New Picklist Label", _languageCode)
};

// Execute the request.
int insertOptionValue = ((InsertOptionValueResponse)_serviceProxy.Execute(
    insertOptionValueRequest)).NewOptionValue;

Console.WriteLine("Created {0} with the value of {1}.",
    insertOptionValueRequest.Label.LocalizedLabels[0].Label,
    insertOptionValue);

Change the order of options in a local option set

This sample shows how to change the order of options in a local option set. The following sampleretrieves a custom PicklistAttributeMetadata attribute and changes the order of the original options using the OrderBy LINQ function to sort items in ascending order by the label text. Then it uses OrderOptionRequest to set the new order of the options for the attribute.

Use the OrderByDecending linq function to order the items in descending order.

C# Copy Code
// Use the RetrieveAttributeRequest message to retrieve
// a attribute by it's logical name.
RetrieveAttributeRequest retrieveAttributeRequest =
    new RetrieveAttributeRequest
{
    EntityLogicalName = Contact.EntityLogicalName,
    LogicalName = "new_picklist",
    RetrieveAsIfPublished = true
};

// Execute the request.
RetrieveAttributeResponse retrieveAttributeResponse =
    (RetrieveAttributeResponse)_serviceProxy.Execute(
    retrieveAttributeRequest);

// Access the retrieved attribute.
PicklistAttributeMetadata retrievedPicklistAttributeMetadata =
    (PicklistAttributeMetadata)
    retrieveAttributeResponse.AttributeMetadata;

// Get the current options list for the retrieved attribute.
OptionMetadata[] optionList =
    retrievedPicklistAttributeMetadata.OptionSet.Options.ToArray();

// Change the order of the original option's list.
// Use the OrderBy (OrderByDescending) linq function to sort options in
// ascending (descending) order according to label text.
// For ascending order use this:
var updateOptionList =
    optionList.OrderBy(x => x.Label.LocalizedLabels[0].Label).ToList();

// For descending order use this:
// var updateOptionList =
//      optionList.OrderByDescending(
//      x => x.Label.LocalizedLabels[0].Label).ToList();

// Create the request.
OrderOptionRequest orderOptionRequest = new OrderOptionRequest
{
    // Set the properties for the request.
    AttributeLogicalName = "new_picklist",
    EntityLogicalName = Contact.EntityLogicalName,
    // Set the changed order using Select linq function
    // to get only values in an array from the changed option list.
    Values = updateOptionList.Select(x => x.Value.Value).ToArray()
};

// Execute the request
_serviceProxy.Execute(orderOptionRequest);

Console.WriteLine("Option Set option order changed");

Delete an attribute

This sample shows how to delete attributes stored in a List< AttributeMetadata > that were created for the Contact entity in Create Attributes. For each AttributeMetadata the DeleteAttributeRequest prepares the request that is processed using IOrganizationService.Execute.

C# Copy Code
// Delete all attributes created for this sample.
foreach (AttributeMetadata anAttribute in addedAttributes)
{
    // Create the request object
    DeleteAttributeRequest deleteAttribute = new DeleteAttributeRequest
    {
        // Set the request properties
        EntityLogicalName = Contact.EntityLogicalName,
        LogicalName = anAttribute.SchemaName
    };
    // Execute the request
    _serviceProxy.Execute(deleteAttribute);
}

See Also

Concepts

Customize entity attribute metadata
Entity attribute metadata messages
Customize entity and attribute mappings

Other Resources

Sample: Work with attribute metadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Entity attribute metadata messages

An entity attribute is a container for a piece of data in an entity. In the Microsoft Dynamics CRM SDK documentation the term “attribute” and “property” (class property) are often used interchangeably with the term “entity attribute.” The Microsoft Dynamics CRM application uses the term “field” when it refers to entity attributes.

Entity attribute messages

The following table lists the messages that you can use to perform actions on entity attributes.

Message | Description
CreateAttributeRequest | Creates entity attributes.
DeleteAttributeRequest | Deletes entity attributes.
DeleteOptionValueRequest | Deletes an option from PicklistAttributeMetadata or StatusAttributeMetadata attributes.
InsertOptionValueRequest | Adds an option to a PicklistAttributeMetadata attribute.
InsertStatusValueRequest | Adds an option to a StatusAttributeMetadata attribute.
OrderOptionRequest | Changes the order of the options presented in an PicklistAttributeMetadata attribute.
RetrieveAttributeRequest | Retrieves entity attributes.
UpdateAttributeRequest | Updates entity attributes.
UpdateStateValueRequest | Updates a label for a StateAttributeMetadata attribute.

See Also

Concepts

Customize entity attribute metadata
Work with attribute metadata

Other Resources

Sample: Work with attribute metadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Work with attribute metadata
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Attributes\WorkWithAttributes.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to perform various actions on attributes.

Example

C# Copy Code
using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to create, retrieve, update and delete attribute.
    /// </summary>
    public class WorkWithAttributes
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Create storage for new attributes being created
        public List<AttributeMetadata> addedAttributes;

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        public const int _languageCode = 1033;

        // Define the IDs/variables needed for this sample.
        public int _insertedStatusValue;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create few types of attributes.
        /// Insert status in the existing status list.
        /// Retrieve attribute.
        /// Update attribute.
        /// Update existing state value.
        /// Optionally delete/revert any attributes
        /// that were created/changed for this sample.
         /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    #region How to create attributes
                    // Create storage for new attributes being created
                    addedAttributes = new List<AttributeMetadata>();

                    // Create a boolean attribute
                    BooleanAttributeMetadata boolAttribute = new BooleanAttributeMetadata
                    {
                        // Set base properties
                        SchemaName = "new_boolean",
                        DisplayName = new Label("Sample Boolean", _languageCode),
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        Description = new Label("Boolean Attribute", _languageCode),
                        // Set extended properties
                        OptionSet = new BooleanOptionSetMetadata(
                            new OptionMetadata(new Label("True", _languageCode), 1),
                            new OptionMetadata(new Label("False", _languageCode), 0)
                            )
                    };

                    // Add to list
                    addedAttributes.Add(boolAttribute);

                    // Create a date time attribute
                    DateTimeAttributeMetadata dtAttribute = new DateTimeAttributeMetadata
                    {
                        // Set base properties
                        SchemaName = "new_datetime",
                        DisplayName = new Label("Sample DateTime", _languageCode),
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        Description = new Label("DateTime Attribute", _languageCode),
                        // Set extended properties
                        Format = DateTimeFormat.DateOnly,
                        ImeMode = ImeMode.Disabled
                    };

                    // Add to list
                    addedAttributes.Add(dtAttribute);

                    // Create a decimal attribute
                    DecimalAttributeMetadata decimalAttribute = new DecimalAttributeMetadata
                    {
                        // Set base properties
                        SchemaName = "new_decimal",
                        DisplayName = new Label("Sample Decimal", _languageCode),
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        Description = new Label("Decimal Attribute", _languageCode),
                        // Set extended properties
                        MaxValue = 100,
                        MinValue = 0,
                        Precision = 1
                    };

                    // Add to list
                    addedAttributes.Add(decimalAttribute);

                    // Create a integer attribute
                    IntegerAttributeMetadata integerAttribute = new IntegerAttributeMetadata
                    {
                        // Set base properties
                        SchemaName = "new_integer",
                        DisplayName = new Label("Sample Integer", _languageCode),
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        Description = new Label("Integer Attribute", _languageCode),
                        // Set extended properties
                        Format = IntegerFormat.None,
                        MaxValue = 100,
                        MinValue = 0
                    };

                    // Add to list
                    addedAttributes.Add(integerAttribute);

                    // Create a memo attribute
                    MemoAttributeMetadata memoAttribute = new MemoAttributeMetadata
                    {
                        // Set base properties
                        SchemaName = "new_memo",
                        DisplayName = new Label("Sample Memo", _languageCode),
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        Description = new Label("Memo Attribute", _languageCode),
                        // Set extended properties
                        Format = StringFormat.TextArea,
                        ImeMode = ImeMode.Disabled,
                        MaxLength = 500
                    };

                    // Add to list
                    addedAttributes.Add(memoAttribute);

                    // Create a money attribute
                    MoneyAttributeMetadata moneyAttribute = new MoneyAttributeMetadata
                    {
                        // Set base properties
                        SchemaName = "new_money",
                        DisplayName = new Label("Money Picklist", _languageCode),
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        Description = new Label("Money Attribue", _languageCode),
                        // Set extended properties
                        MaxValue = 1000.00,
                        MinValue = 0.00,
                        Precision = 1,
                        PrecisionSource = 1,
                        ImeMode = ImeMode.Disabled
                    };

                    // Add to list
                    addedAttributes.Add(moneyAttribute);

                    // Create a picklist attribute
                    PicklistAttributeMetadata pickListAttribute =
                        new PicklistAttributeMetadata
                    {
                        // Set base properties
                        SchemaName = "new_picklist",
                        DisplayName = new Label("Sample Picklist", _languageCode),
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        Description = new Label("Picklist Attribute", _languageCode),
                        // Set extended properties
                        // Build local picklist options
                        OptionSet = new OptionSetMetadata
                            {
                                IsGlobal = false,
                                OptionSetType = OptionSetType.Picklist,
                                Options =
                            {
                                new OptionMetadata(
                                    new Label("Created", _languageCode), null),
                                new OptionMetadata(
                                    new Label("Updated", _languageCode), null),
                                new OptionMetadata(
                                    new Label("Deleted", _languageCode), null)
                            }
                            }
                    };

                    // Add to list
                    addedAttributes.Add(pickListAttribute);

                    // Create a string attribute
                    StringAttributeMetadata stringAttribute = new StringAttributeMetadata
                    {
                        // Set base properties
                        SchemaName = "new_string",
                        DisplayName = new Label("Sample String", _languageCode),
                        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                        Description = new Label("String Attribute", _languageCode),
                        // Set extended properties
                        MaxLength = 100
                    };

                    // Add to list
                    addedAttributes.Add(stringAttribute);

                    // NOTE: LookupAttributeMetadata cannot be created outside the context of a relationship.
                    // Refer to the WorkWithRelationships.cs reference SDK sample for an example of this attribute type.

                    // NOTE: StateAttributeMetadata and StatusAttributeMetadata cannot be created via the SDK.

                    foreach (AttributeMetadata anAttribute in addedAttributes)
                    {
                        // Create the request.
                        CreateAttributeRequest createAttributeRequest = new CreateAttributeRequest
                        {
                            EntityName = Contact.EntityLogicalName,
                            Attribute = anAttribute
                        };

                        // Execute the request.
                        _serviceProxy.Execute(createAttributeRequest);

                        Console.WriteLine("Created the attribute {0}.", anAttribute.SchemaName);
                    }
                    #endregion How to create attributes

                    #region How to insert status
                    // Use InsertStatusValueRequest message to insert a new status
                    // in an existing status attribute.
                    // Create the request.
                    InsertStatusValueRequest insertStatusValueRequest =
                        new InsertStatusValueRequest
                    {
                        AttributeLogicalName = "statuscode",
                        EntityLogicalName = Contact.EntityLogicalName,
                        Label = new Label("Dormant", _languageCode),
                        StateCode = 0
                    };

                    // Execute the request and store newly inserted value
                    // for cleanup, used later part of this sample.
                    _insertedStatusValue = ((InsertStatusValueResponse)_serviceProxy.Execute(
                        insertStatusValueRequest)).NewOptionValue;

                    Console.WriteLine("Created {0} with the value of {1}.",
                        insertStatusValueRequest.Label.LocalizedLabels[0].Label,
                        _insertedStatusValue);
                    #endregion How to insert status

                    #region How to retrieve attribute
                    // Create the request
                    RetrieveAttributeRequest attributeRequest = new RetrieveAttributeRequest
                    {
                        EntityLogicalName = Contact.EntityLogicalName,
                        LogicalName = "new_string",
                        RetrieveAsIfPublished = true
                    };

                    // Execute the request
                    RetrieveAttributeResponse attributeResponse =
                        (RetrieveAttributeResponse)_serviceProxy.Execute(attributeRequest);

                    Console.WriteLine("Retrieved the attribute {0}.",
                        attributeResponse.AttributeMetadata.SchemaName);
                    #endregion How to retrieve attribute

                    #region How to update attribute
                    // Modify the retrieved attribute
                    AttributeMetadata retrievedAttributeMetadata =
                        attributeResponse.AttributeMetadata;
                    retrievedAttributeMetadata.DisplayName =
                        new Label("Update String Attribute", _languageCode);

                    // Update an attribute retrieved via RetrieveAttributeRequest
                    UpdateAttributeRequest updateRequest = new UpdateAttributeRequest
                    {
                        Attribute = retrievedAttributeMetadata,
                        EntityName = Contact.EntityLogicalName,
                        MergeLabels = false
                    };

                    // Execute the request
                    _serviceProxy.Execute(updateRequest);

                    Console.WriteLine("Updated the attribute {0}.",
                        retrievedAttributeMetadata.SchemaName);
                    #endregion How to update attribute

                    #region How to update state value
                    // Modify the state value label from Active to Open.
                    // Create the request.
                    UpdateStateValueRequest updateStateValue = new UpdateStateValueRequest
                    {
                        AttributeLogicalName = "statecode",
                        EntityLogicalName = Contact.EntityLogicalName,
                        Value = 1,
                        Label = new Label("Open", _languageCode)
                    };

                    // Execute the request.
                    _serviceProxy.Execute(updateStateValue);

                    Console.WriteLine(
                        "Updated {0} state attribute of {1} entity from 'Active' to '{2}'.",
                        updateStateValue.AttributeLogicalName,
                        updateStateValue.EntityLogicalName,
                        updateStateValue.Label.LocalizedLabels[0].Label
                        );
                    #endregion How to update state value

                    #region How to insert a new option item in a local option set
                    // Create a request.
                    InsertOptionValueRequest insertOptionValueRequest =
                        new InsertOptionValueRequest
                    {
                        AttributeLogicalName = "new_picklist",
                        EntityLogicalName = Contact.EntityLogicalName,
                        Label = new Label("New Picklist Label", _languageCode)
                    };

                    // Execute the request.
                    int insertOptionValue = ((InsertOptionValueResponse)_serviceProxy.Execute(
                        insertOptionValueRequest)).NewOptionValue;

                    Console.WriteLine("Created {0} with the value of {1}.",
                        insertOptionValueRequest.Label.LocalizedLabels[0].Label,
                        insertOptionValue);
                    #endregion How to insert a new option item in a local option set

                    #region How to change the order of options of a local option set
                    // Use the RetrieveAttributeRequest message to retrieve
                    // a attribute by it's logical name.
                    RetrieveAttributeRequest retrieveAttributeRequest =
                        new RetrieveAttributeRequest
                    {
                        EntityLogicalName = Contact.EntityLogicalName,
                        LogicalName = "new_picklist",
                        RetrieveAsIfPublished = true
                    };

                    // Execute the request.
                    RetrieveAttributeResponse retrieveAttributeResponse =
                        (RetrieveAttributeResponse)_serviceProxy.Execute(
                        retrieveAttributeRequest);

                    // Access the retrieved attribute.
                    PicklistAttributeMetadata retrievedPicklistAttributeMetadata =
                        (PicklistAttributeMetadata)
                        retrieveAttributeResponse.AttributeMetadata;

                    // Get the current options list for the retrieved attribute.
                    OptionMetadata[] optionList =
                        retrievedPicklistAttributeMetadata.OptionSet.Options.ToArray();

                    // Change the order of the original option's list.
                    // Use the OrderBy (OrderByDescending) linq function to sort options in
                    // ascending (descending) order according to label text.
                    // For ascending order use this:
                    var updateOptionList =
                        optionList.OrderBy(x => x.Label.LocalizedLabels[0].Label).ToList();

                    // For descending order use this:
                    // var updateOptionList =
                    //      optionList.OrderByDescending(
                    //      x => x.Label.LocalizedLabels[0].Label).ToList();

                    // Create the request.
                    OrderOptionRequest orderOptionRequest = new OrderOptionRequest
                    {
                        // Set the properties for the request.
                        AttributeLogicalName = "new_picklist",
                        EntityLogicalName = Contact.EntityLogicalName,
                        // Set the changed order using Select linq function
                        // to get only values in an array from the changed option list.
                        Values = updateOptionList.Select(x => x.Value.Value).ToArray()
                    };

                    // Execute the request
                    _serviceProxy.Execute(orderOptionRequest);

                    Console.WriteLine("Option Set option order changed");
                    #endregion How to change the order of options of a global option set

                    // NOTE: All customizations must be published before they can be used.
                    _serviceProxy.Execute(new PublishAllXmlRequest());
                    Console.WriteLine("Published all customizations.");

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes/Reverts the record that was created/changed for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine(
                    "\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                #region How to delete attribute
                // Delete all attributes created for this sample.
                foreach (AttributeMetadata anAttribute in addedAttributes)
                {
                    // Create the request object
                    DeleteAttributeRequest deleteAttribute = new DeleteAttributeRequest
                    {
                        // Set the request properties
                        EntityLogicalName = Contact.EntityLogicalName,
                        LogicalName = anAttribute.SchemaName
                    };
                    // Execute the request
                    _serviceProxy.Execute(deleteAttribute);
                }
                #endregion How to delete attribute

                #region How to remove inserted status value
                // Delete the newly inserted status value.
                // Create the request object
                DeleteOptionValueRequest deleteRequest = new DeleteOptionValueRequest
                {
                    AttributeLogicalName = "statuscode",
                    EntityLogicalName = Contact.EntityLogicalName,
                    Value = _insertedStatusValue
                };

                // Execute the request
                _serviceProxy.Execute(deleteRequest);

                Console.WriteLine("Deleted all attributes created for this sample.");
                #endregion How to remove inserted status value

                #region Revert the changed state value
                // Revert the state value label from Open to Active.
                // Create the request.
                UpdateStateValueRequest revertStateValue = new UpdateStateValueRequest
                {
                    AttributeLogicalName = "statecode",
                    EntityLogicalName = Contact.EntityLogicalName,
                    Value = 1,
                    Label = new Label("Active", _languageCode)
                };

                // Execute the request.
                _serviceProxy.Execute(revertStateValue);

                // NOTE: All customizations must be published before they can be used.
                _serviceProxy.Execute(new PublishAllXmlRequest());

                Console.WriteLine(
                    "Reverted {0} state attribute of {1} entity from 'Open' to '{2}'.",
                    revertStateValue.AttributeLogicalName,
                    revertStateValue.EntityLogicalName,
                    revertStateValue.Label.LocalizedLabels[0].Label
                    );
                #endregion Revert the changed state value
            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                WorkWithAttributes app = new WorkWithAttributes();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize entity attribute metadata
Work with attribute metadata

Other Resources

Extend the metadata model
Sample: Dump attribute metadata to a file

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Dump attribute metadata to a file
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Attributes\DumpAttributeInfo.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write out all the attribute metadata to an XML file. It uses the RetrieveAllEntitiesRequest message.

The following sample creates a new file at \Entities\bin\Debug\AllAttributeDesc.xml. You can open this file in Microsoft Office Excel to see a tabular report. You can easily look up information such as which attributes can be specified in a create, retrieve, or update operation. This information can also be found in the “EntityName Entity Attribute Metadata” topic for each entity.

Example

C# Copy Code
using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;
using System.Xml.Serialization;
using System.Xml;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how retreive all the attribute info and dump it to an Excel file.
    /// </summary>
    public class DumpAttributeInfo
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Create storage for new attributes being created
        public List<AttributeMetadata> addedAttributes;

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        public const int _languageCode = 1033;

        // Define the IDs/variables needed for this sample.
        public int _insertedStatusValue;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    #region How to dump attribute info
                    RetrieveAllEntitiesRequest request = new RetrieveAllEntitiesRequest()
                    {
                        EntityFilters = EntityFilters.Attributes,
                        RetrieveAsIfPublished = true
                    };

                    // Retrieve the MetaData.
                    RetrieveAllEntitiesResponse response = (RetrieveAllEntitiesResponse)_serviceProxy.Execute(request);

                    // Create an instance of StreamWriter to write text to a file.
                    // The using statement also closes the StreamWriter.
            // To view this file, right click the file and choose open with Excel.
            // Excel will figure out the schema and display the information in columns.
                    String filename = String.Concat("AllAttributeDesc.xml");
                    using (StreamWriter sw = new StreamWriter(filename))
                    {
                        // Create Xml Writer.
                        XmlTextWriter metadataWriter = new XmlTextWriter(sw);

                        // Start Xml File.
                        metadataWriter.WriteStartDocument();

                        // Metadata Xml Node.
                        metadataWriter.WriteStartElement("Metadata");

                        foreach (EntityMetadata currentEntity in response.EntityMetadata)
                        {

                            //if (currentEntity.IsIntersect.Value == false)
                            if (true)
                            {
                                // Start Entity Node
                                metadataWriter.WriteStartElement("Entity");

                                // Write the Entity's Information.
                                metadataWriter.WriteElementString("EntitySchemaName", currentEntity.SchemaName);
                                if (currentEntity.IsCustomizable.Value == true)
                                    metadataWriter.WriteElementString("IsCustomizable", "yes");
                                else
                                    metadataWriter.WriteElementString("IsCustomizable", "no");
                                if (currentEntity.IsIntersect.Value == true)
                                    metadataWriter.WriteElementString("IsIntersect", "yes");
                                else
                                    metadataWriter.WriteElementString("IsIntersect", "no");

                                #region Attributes

                                // Write Entity's Attributes.
                                metadataWriter.WriteStartElement("Attributes");

                                foreach (AttributeMetadata currentAttribute in currentEntity.Attributes)
                                {
                                    // Only write out main attributes.
                                    if (currentAttribute.AttributeOf == null)
                                    {

                                        // Start Attribute Node
                                        metadataWriter.WriteStartElement("Attribute");

                                        // Write Attribute's information.
                                        metadataWriter.WriteElementString("LogialName", currentAttribute.LogicalName);
                                        // Write the Description if it is set.
                                        if (currentAttribute.Description.UserLocalizedLabel != null)
                                        {
                                            metadataWriter.WriteElementString("Description", currentAttribute.Description.UserLocalizedLabel.Label.ToString());
                                        }

                                        metadataWriter.WriteElementString("Type", currentAttribute.AttributeType.Value.ToString());
                                        if (currentAttribute.DisplayName.UserLocalizedLabel != null)
                                            metadataWriter.WriteElementString("DisplayName", currentAttribute.DisplayName.UserLocalizedLabel.Label.ToString());
                                        if (currentAttribute.SchemaName != null)
                                            metadataWriter.WriteElementString("SchemaName", currentAttribute.SchemaName.ToString());
                                        if (currentAttribute.DeprecatedVersion != null)
                                            metadataWriter.WriteElementString("DeprecatedVersion", currentAttribute.DeprecatedVersion.ToString());
                                        metadataWriter.WriteElementString("IsCustomAttribute", currentAttribute.IsCustomAttribute.Value.ToString());
                                        metadataWriter.WriteElementString("IsCustomizable", currentAttribute.IsCustomizable.Value.ToString());
                                        metadataWriter.WriteElementString("RequiredLevel", currentAttribute.RequiredLevel.Value.ToString());
                                        metadataWriter.WriteElementString("IsValidForCreate", currentAttribute.IsValidForCreate.Value.ToString());
                                        metadataWriter.WriteElementString("IsValidForRead", currentAttribute.IsValidForRead.Value.ToString());
                                        metadataWriter.WriteElementString("IsValidForUpdate", currentAttribute.IsValidForUpdate.Value.ToString());
                                        metadataWriter.WriteElementString("CanBeSecuredForCreate", currentAttribute.CanBeSecuredForCreate.Value.ToString());
                                        metadataWriter.WriteElementString("CanBeSecuredForRead", currentAttribute.CanBeSecuredForRead.Value.ToString());
                                        metadataWriter.WriteElementString("CanBeSecuredForUpdate", currentAttribute.CanBeSecuredForUpdate.Value.ToString());
                                        metadataWriter.WriteElementString("IsAuditEnabled", currentAttribute.IsAuditEnabled.Value.ToString());
                                        metadataWriter.WriteElementString("IsManaged", currentAttribute.IsManaged.Value.ToString());
                                        metadataWriter.WriteElementString("IsPrimaryId", currentAttribute.IsPrimaryId.Value.ToString());
                                        metadataWriter.WriteElementString("IsPrimaryName", currentAttribute.IsPrimaryName.Value.ToString());
                                        metadataWriter.WriteElementString("IsRenameable", currentAttribute.IsRenameable.Value.ToString());
                                        metadataWriter.WriteElementString("IsSecured", currentAttribute.IsSecured.Value.ToString());
                                        metadataWriter.WriteElementString("IsValidForAdvancedFind", currentAttribute.IsValidForAdvancedFind.Value.ToString());

                                        // End Attribute Node
                                        metadataWriter.WriteEndElement();
                                    }
                                }
                                // End Attributes Node
                                metadataWriter.WriteEndElement();

                                #endregion

                                // End Entity Node
                                metadataWriter.WriteEndElement();
                            }
                        }

                        // End Metadata Xml Node
                        metadataWriter.WriteEndElement();
                        metadataWriter.WriteEndDocument();

                        // Close xml writer.
                        metadataWriter.Close();
                    }

                    #endregion How to dump attribute info

                   Console.WriteLine("Done.");

                    //DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes/Reverts the record that was created/changed for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine(
                    "\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {

            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DumpAttributeInfo app = new DumpAttributeInfo();
                app.Run(config, false);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize entity attribute metadata

Other Resources

Sample: Dump attribute picklist metadata to a file
Extend the metadata model
RetrieveAllEntitiesRequest
RetrieveAllEntitiesResponse

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Dump attribute picklist metadata to a file
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Attributes\DumpPicklistInfo.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write out all the entity metadata to an XML file. It uses the RetrieveAllEntitiesRequest message.

The following sample creates a new file at \Entities\bin\Debug\AttributePicklistValues.xml. You can open this file in Microsoft Office Excel to see a tabular report. This is useful to look up the valid values for each picklist. This information can also be found in the “EntityName Entity OptionSet Attribute Metadata” topic for each entity.

Example

C# Copy Code
using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;
using System.Xml.Serialization;
using System.Xml;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve and write out all the option set values:
    /// picklist, state and status attribute types.
    /// </summary>
    public class DumpPicklistInfo
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Create storage for new attributes being created
        public List<AttributeMetadata> addedAttributes;

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        public const int _languageCode = 1033;

        // Define the IDs/variables needed for this sample.
        public int _insertedStatusValue;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    #region How to dump attribute info
                    RetrieveAllEntitiesRequest request = new RetrieveAllEntitiesRequest()
                    {
                        EntityFilters = EntityFilters.Attributes,
                        RetrieveAsIfPublished = true
                    };

                    // Retrieve the MetaData.
                    RetrieveAllEntitiesResponse response = (RetrieveAllEntitiesResponse)_serviceProxy.Execute(request);

                    // Create an instance of StreamWriter to write text to a file.
                    // The using statement also closes the StreamWriter.
            // To view this file, right click the file and choose open with Excel.
            // Excel will figure out the schema and display the information in columns.

                    String filename = String.Concat("AttributePicklistValues.xml");
                    using (StreamWriter sw = new StreamWriter(filename))
                    {
                        // Create Xml Writer.
                        XmlTextWriter metadataWriter = new XmlTextWriter(sw);

                        // Start Xml File.
                        metadataWriter.WriteStartDocument();

                        // Metadata Xml Node.
                        metadataWriter.WriteStartElement("Metadata");

                        foreach (EntityMetadata currentEntity in response.EntityMetadata)
                        {

                            if (currentEntity.IsIntersect.Value == false)
                            {
                                // Start Entity Node
                                metadataWriter.WriteStartElement("Entity");

                                // Write the Entity's Information.
                                metadataWriter.WriteElementString("EntitySchemaName", currentEntity.SchemaName);
                                if (currentEntity.IsCustomizable.Value == true)
                                    metadataWriter.WriteElementString("IsCustomizable", "yes");
                                else
                                    metadataWriter.WriteElementString("IsCustomizable", "no");

                                #region Attributes

                                // Write Entity's Attributes.
                                metadataWriter.WriteStartElement("Attributes");

                                foreach (AttributeMetadata currentAttribute in currentEntity.Attributes)
                                {
                                    // Only write out main attributes.
                                    if (currentAttribute.AttributeOf == null)
                                    {

                                        // Start Attribute Node
                                        metadataWriter.WriteStartElement("Attribute");

                                        // Write Attribute's information.
                                        metadataWriter.WriteElementString("SchemaName", currentAttribute.SchemaName);
                                        metadataWriter.WriteElementString("Type", currentAttribute.AttributeType.Value.ToString());

                                        if (currentAttribute.GetType() == typeof(PicklistAttributeMetadata))
                                        {
                                            PicklistAttributeMetadata optionMetadata = (PicklistAttributeMetadata)currentAttribute;
                                            // Writes the picklist's options
                                            metadataWriter.WriteStartElement("Options");

                                            // Writes the attributes of each picklist option
                                            for (int c = 0; c < optionMetadata.OptionSet.Options.Count; c++)
                                            {
                                                metadataWriter.WriteStartElement("Option");
                                                metadataWriter.WriteElementString("OptionValue", optionMetadata.OptionSet.Options[c].Value.Value.ToString());
                                                metadataWriter.WriteElementString("OptionDescription", optionMetadata.OptionSet.Options[c].Label.UserLocalizedLabel.Label.ToString());
                                                metadataWriter.WriteEndElement();
                                            }

                                            metadataWriter.WriteEndElement();

                                        }
                                        else if (currentAttribute.GetType() == typeof(StateAttributeMetadata))
                                        {
                                            StateAttributeMetadata optionMetadata = (StateAttributeMetadata)currentAttribute;
                                            // Writes the picklist's options
                                            metadataWriter.WriteStartElement("Options");

                                            // Writes the attributes of each picklist option
                                            for (int c = 0; c < optionMetadata.OptionSet.Options.Count; c++)
                                            {
                                                metadataWriter.WriteStartElement("Option");
                                                metadataWriter.WriteElementString("OptionValue", optionMetadata.OptionSet.Options[c].Value.Value.ToString());
                                                metadataWriter.WriteElementString("OptionDescription", optionMetadata.OptionSet.Options[c].Label.UserLocalizedLabel.Label.ToString());
                                                metadataWriter.WriteEndElement();
                                            }

                                            metadataWriter.WriteEndElement();
                                        }
                                        else if (currentAttribute.GetType() == typeof(StatusAttributeMetadata))
                                        {
                                            StatusAttributeMetadata optionMetadata = (StatusAttributeMetadata)currentAttribute;
                                            // Writes the picklist's options
                                            metadataWriter.WriteStartElement("Options");

                                            // Writes the attributes of each picklist option
                                            for (int c = 0; c < optionMetadata.OptionSet.Options.Count; c++)
                                            {
                                                metadataWriter.WriteStartElement("Option");
                                                metadataWriter.WriteElementString("OptionValue", optionMetadata.OptionSet.Options[c].Value.Value.ToString());
                                                metadataWriter.WriteElementString("OptionDescription", optionMetadata.OptionSet.Options[c].Label.UserLocalizedLabel.Label.ToString());
                                                if (optionMetadata.OptionSet.Options[c] is StatusOptionMetadata)
                                                    metadataWriter.WriteElementString("RelatedToState", ((StatusOptionMetadata)optionMetadata.OptionSet.Options[c]).State.ToString());
                                                metadataWriter.WriteEndElement();
                                            }

                                            metadataWriter.WriteEndElement();
                                        }

                                        // End Attribute Node
                                        metadataWriter.WriteEndElement();
                                    }
                                }
                                // End Attributes Node
                                metadataWriter.WriteEndElement();

                                #endregion

                                // End Entity Node
                                metadataWriter.WriteEndElement();
                            }
                        }

                        // End Metadata Xml Node
                        metadataWriter.WriteEndElement();
                        metadataWriter.WriteEndDocument();

                        // Close xml writer.
                        metadataWriter.Close();
                    }

                    #endregion How to dump attribute info

                   Console.WriteLine("Done.");

                    //DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes/Reverts the record that was created/changed for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine(
                    "\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {

            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DumpPicklistInfo app = new DumpPicklistInfo();
                app.Run(config, false);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize entity metadata
Customize entity attribute metadata

Other Resources

Extend the metadata model
RetrieveAllEntitiesRequest
RetrieveAllEntitiesResponse

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize entity relationship metadata

Entity relationships define the ways that entity records can be associated with records of other entities or the same entity. Creating new entity relationships creates new table relationships in the database. Use entity relationships to define specific associations that are frequently used to associate records for reports or in the user interface. Once a relationship exists, you can associate and disassociate records based on the relationship using the Associate and Disassociate methods. More information: Actions on Entity Records

For relationships between individual records that are less formal and more flexible, see Connection entities.

This topic is about working with entity relationships programmatically. For information about working with entity relationship in the application, see Create and edit entity relationships.

In This Topic

Types of entity relationships

One-to-many relationships

Many-to-many relationships

Configure associated menus

Types of entity relationships

Microsoft Dynamics CRM provides two types of entity relationships. Both of these inherit from the RelationshipMetadataBase class:

  • One-to-many relationships
  • Many-to-many relationships

Before you create a new entity relationship programmatically, check to see whether the entities are eligible to participate in the relationship. There are constraints applied to entity relationships that use the following EntityMetadata properties: CanBeInManyToMany, CanBePrimaryEntityInRelationship, and CanBeRelatedEntityInRelationship. These restrictions are taken into account when you manually create entity relationships in the customization tools. There are messages that you can use to determine which relationships an entity can use and what other entities are valid for that type of relationship. More information: Entity relationship eligibility

Both types of entity relationships allow for options to display navigation links between related records. More information: Configuring Associated Menus

One-to-many relationships

In a one-to-many entity relationship, many referencing (related) entity records can be associated with a single referenced (primary) entity record. The referenced entity record is sometimes referred to as the ”parent” and records of the referencing entity are referred to as ”children.”

In an entity node on a solution page, this kind of entity relationship is displayed as either a 1-to-Many (1:N) Relationship or a Many-to-1 (N:1) Relationship. These terms are used because you navigate to entity relationships through one of the entities. The label reflects which role the current entity has in the relationship.

You use an instance of the OneToManyRelationshipMetadata class when you work with this kind of entity relationship. Each entity relationship has a unique schema name that you use to retrieve it. For more information, see SchemaName. Each entity relationship of this kind also has a referenced entity (Primary Entity) with a referenced attribute, and a referencing entity (Related Entity) with a referencing attribute. The referencing attribute can be displayed as a lookup field in an entity form. For more information, see ReferencedEntity, ReferencedAttribute, ReferencingEntity, and ReferencingAttribute.

You may require that a referencing entity have a reference by setting the AttributeRequiredLevel to ApplicationRequired on the referencing attribute. To maintain data integrity, when you do this you should also specify what you want to occur if the primary record is deleted. Use the CascadeConfiguration property to either prevent deleting the primary record or automatically delete the related record as well to prevent an orphaned record.

You can also use cascading configuration to automate behavior when specific actions are taken on related records in the organization. More information: Entity relationship behavior

Map data to new records

When there is a one-to-many entity relationship, you can specify that data from certain fields in the referenced entity can be transferred to any new related records created in the context of the relationship. This can streamline data entry when you are creating new related records. For more information, see Customize entity and attribute mappings.

Self-referencing one-to-many entity relationships

A self-referencing relationship is where the referencing and referenced entity is the same. For example, the account entity has a self-referencing one-to-many relationship that allows for a lookup labeled Parent Account. If the entity relationship behavior is defined as Parental it is not possible for a record to reference itself because this would create a circular reference when cascading behaviors are applied. More information: Entity relationship behavior

Hierarchical one-to-many entity relationships

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can specify one self-referencing one-to-many entity relationship as the designated hierarchical relationship for an entity. The OneToManyRelationshipMetadata.IsHierarchical property flags this relationship as the one-to-many relationship to use for the entity.

All one-to-many entity relationships represent a type of hierarchy, but relationships explicitly flagged using the IsHierarchical property are the only entity relationships that support the hierarchy visualizations in the application as well as new query operators to retrieve hierarchically related records. More information: Query hierarchical data

Many-to-many relationships

In a ,many-to-many entity relationship many entity records can be associated with many other entity records. Unlike one-to-many relationships, there is no lookup field on either entity and therefore no intended hierarchy. Records related using a many-to-many relationship can be considered peers and the relationship is reciprocal. A many-to-many relationship may also be self-referential. Because there is no cascading behavior involved in many-to-many relationships, you can allow an individual record to have a reference to itself.

You use an instance of the ManyToManyRelationshipMetadata class when you work with this kind of entity relationship. Each entity relationship has a unique SchemaName that you use to retrieve it

Creating a many-to-many entity relationship creates a new intersect entity where the IsIntersect property is true. Records for this entity track each individual many-to-many relationship. You cannot add custom attributes to intersect entities.

Configure associated menus

Both types of entity relationships allow for configuration of navigation links between related records. Use the AssociatedMenuConfiguration properties in each type of entity relationship definition to specify how you want the navigation links in an entity form to be displayed.

These values provide the default configuration for the relationship. You can use the form editor to override these options for each form. More information: Customization Guide: Use the form editor: Edit Navigation

Behavior

Provides the following options:

  • DoNotDisplay
  • UseCollectionName
  • UseLabel
Group

Provides the following options:

  • Details
  • Marketing
  • Sales
  • Service
You cannot add new groups, but you can change the text displayed for them using the form editor.

Label

If you select AssociatedMenuBehavior.UseLabel, you must provide a custom label.

Order

The integer provided for the order will control the relative position of navigation items in the group. The lower the value, the higher the item appears relative to the values of other items in the group.

See Also

Concepts

Entity relationship metadata messages
Entity relationship eligibility
Entity relationship behavior
Create and retrieve entity relationships
Customize entity and attribute mappings
Retrieve records for many-to-many relationships using intersect entities

Other Resources

Extend the metadata model
Sample: Create and retrieve entity relationships
Sample: Dump entity relationship information to a file

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create and retrieve entity relationships

This topic shows how to create and retrieve entity relationships.

In This Topic

Create a 1:N Entity Relationship

Create an N:N Entity Relationship

Retrieve Entity Relationships

Create a 1:N entity relationship

The following sample uses the EligibleCreateOneToManyRelationship method to verify that the Account and Campaign entities can participate in a 1:N entity relationship and then creates the entity relationship by using CreateOneToManyRequest.

C# Copy Code

bool eligibleCreateOneToManyRelationship =
    EligibleCreateOneToManyRelationship("account", "campaign");

if (eligibleCreateOneToManyRelationship)
{
    CreateOneToManyRequest createOneToManyRelationshipRequest =
        new CreateOneToManyRequest
    {
        OneToManyRelationship =
        new OneToManyRelationshipMetadata
        {
            ReferencedEntity = "account",
            ReferencingEntity = "campaign",
            SchemaName = "new_account_campaign",
            AssociatedMenuConfiguration = new AssociatedMenuConfiguration
            {
                Behavior = AssociatedMenuBehavior.UseLabel,
                Group = AssociatedMenuGroup.Details,
                Label = new Label("Account", 1033),
                Order = 10000
            },
            CascadeConfiguration = new CascadeConfiguration
            {
                Assign = CascadeType.NoCascade,
                Delete = CascadeType.RemoveLink,
                Merge = CascadeType.NoCascade,
                Reparent = CascadeType.NoCascade,
                Share = CascadeType.NoCascade,
                Unshare = CascadeType.NoCascade
            }
        },
        Lookup = new LookupAttributeMetadata
        {
            SchemaName = "new_parent_accountid",
            DisplayName = new Label("Account Lookup", 1033),
            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
            Description = new Label("Sample Lookup", 1033)
        }
    };

    CreateOneToManyResponse createOneToManyRelationshipResponse =
        (CreateOneToManyResponse)_serviceProxy.Execute(
        createOneToManyRelationshipRequest);

    _oneToManyRelationshipId =
        createOneToManyRelationshipResponse.RelationshipId;
    _oneToManyRelationshipName =
        createOneToManyRelationshipRequest.OneToManyRelationship.SchemaName;

    Console.WriteLine(
        "The one-to-many relationship has been created between {0} and {1}.",
        "account", "campaign");
}

EligibleCreateOneToManyRelationship

The following sample creates a EligibleCreateOneToManyRelationship method that uses CanBeReferencedRequest and CanBeReferencingRequest to verify whether two entities can participate in a 1:N entity relationship.

C# Copy Code
/// <summary>
/// Determines whether two entities are eligible to participate in a relationship
/// </summary>
/// <param name="referencedEntity">Primary Entity</param>
/// <param name="referencingEntity">Referencing Entity</param>
/// <returns></returns>
public bool EligibleCreateOneToManyRelationship(string referencedEntity,
    string referencingEntity)
{
    //Checks whether the specified entity can be the primary entity in one-to-many
    //relationship.
    CanBeReferencedRequest canBeReferencedRequest = new CanBeReferencedRequest
    {
        EntityName = referencedEntity
    };

    CanBeReferencedResponse canBeReferencedResponse =
        (CanBeReferencedResponse)_serviceProxy.Execute(canBeReferencedRequest);

    if (!canBeReferencedResponse.CanBeReferenced)
    {
        Console.WriteLine(
            "Entity {0} can't be the primary entity in this one-to-many relationship",
            referencedEntity);
    }

    //Checks whether the specified entity can be the referencing entity in one-to-many
    //relationship.
    CanBeReferencingRequest canBereferencingRequest = new CanBeReferencingRequest
    {
        EntityName = referencingEntity
    };

    CanBeReferencingResponse canBeReferencingResponse =
        (CanBeReferencingResponse)_serviceProxy.Execute(canBereferencingRequest);

    if (!canBeReferencingResponse.CanBeReferencing)
    {
        Console.WriteLine(
            "Entity {0} can't be the referencing entity in this one-to-many relationship",
            referencingEntity);
    }

    if (canBeReferencedResponse.CanBeReferenced == true
        && canBeReferencingResponse.CanBeReferencing == true)
    {
        return true;
    }
    else
    {
        return false;
    }
}

Create an N:N entity relationship

The following sample uses a EligibleCreateManyToManyRelationship method to verify that the Account and Campaign entities can participate in a N:N entity relationship and then creates the entity relationship by using CreateManyToManyRequest.

C# Copy Code

bool accountEligibleParticipate =
    EligibleCreateManyToManyRelationship("account");
bool campaignEligibleParticipate =
    EligibleCreateManyToManyRelationship("campaign");

if (accountEligibleParticipate && campaignEligibleParticipate)
{

    CreateManyToManyRequest createManyToManyRelationshipRequest =
        new CreateManyToManyRequest
    {
        IntersectEntitySchemaName = "new_accounts_campaigns",
        ManyToManyRelationship = new ManyToManyRelationshipMetadata
        {
            SchemaName = "new_accounts_campaigns",
            Entity1LogicalName = "account",
            Entity1AssociatedMenuConfiguration =
            new AssociatedMenuConfiguration
            {
                Behavior = AssociatedMenuBehavior.UseLabel,
                Group = AssociatedMenuGroup.Details,
                Label = new Label("Account", 1033),
                Order = 10000
            },
            Entity2LogicalName = "campaign",
            Entity2AssociatedMenuConfiguration =
            new AssociatedMenuConfiguration
            {
                Behavior = AssociatedMenuBehavior.UseLabel,
                Group = AssociatedMenuGroup.Details,
                Label = new Label("Campaign", 1033),
                Order = 10000
            }
        }
    };

    CreateManyToManyResponse createManytoManyRelationshipResponse =
        (CreateManyToManyResponse)_serviceProxy.Execute(
        createManyToManyRelationshipRequest);

    _manyToManyRelationshipId =
        createManytoManyRelationshipResponse.ManyToManyRelationshipId;
    _manyToManyRelationshipName =
        createManyToManyRelationshipRequest.ManyToManyRelationship.SchemaName;

    Console.WriteLine(
        "The many-to-many relationship has been created between {0} and {1}.",
        "account", "campaign");
}

EligibleCreateManyToManyRelationship

The following sample creates a EligibleCreateManyToManyRelationship method that uses CanManyToManyRequest to verify whether an entity can participate in a N:N entity relationship.

C# Copy Code
/// <summary>
/// Determines whether the entity can participate in a many-to-many relationship.
/// </summary>
/// <param name="entity">Entity</param>
/// <returns></returns>
public bool EligibleCreateManyToManyRelationship(string entity)
{
    CanManyToManyRequest canManyToManyRequest = new CanManyToManyRequest
    {
        EntityName = entity
    };

    CanManyToManyResponse canManyToManyResponse =
        (CanManyToManyResponse)_serviceProxy.Execute(canManyToManyRequest);

    if (!canManyToManyResponse.CanManyToMany)
    {
        Console.WriteLine(
            "Entity {0} can't participate in a many-to-many relationship.",
            entity);
    }

    return canManyToManyResponse.CanManyToMany;
}

Retrieve entity relationships

The following sample retrieves the two entity relationships previously created using RetrieveRelationshipRequest. The first example uses the MetadataId and the second uses the Name.

C# Copy Code

//You can use either the Name or the MetadataId of the relationship.

//Retrieve the One-to-many relationship using the MetadataId.
RetrieveRelationshipRequest retrieveOneToManyRequest =
    new RetrieveRelationshipRequest { MetadataId = _oneToManyRelationshipId };
RetrieveRelationshipResponse retrieveOneToManyResponse =
    (RetrieveRelationshipResponse)_serviceProxy.Execute(retrieveOneToManyRequest);

Console.WriteLine("Retrieved {0} One-to-many relationship by id", retrieveOneToManyResponse.RelationshipMetadata.SchemaName);

//Retrieve the Many-to-many relationship using the Name.
RetrieveRelationshipRequest retrieveManyToManyRequest =
    new RetrieveRelationshipRequest { Name = _manyToManyRelationshipName};
RetrieveRelationshipResponse retrieveManyToManyResponse =
    (RetrieveRelationshipResponse)_serviceProxy.Execute(retrieveManyToManyRequest);

Console.WriteLine("Retrieved {0} Many-to-Many relationship by Name", retrieveManyToManyResponse.RelationshipMetadata.MetadataId);

See Also

Concepts

Customize entity relationship metadata
Entity relationship metadata messages

Other Resources

Sample: Create and retrieve entity relationships

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Entity relationship metadata messages

Entity relationships define how entities are related to each other. This includes information about how relationships are represented in the application. Also, when actions are performed on a record, the relationship indicates what actions to perform on related records.

Entity relationship messages

The following table lists the messages that you can use to create, retrieve, update, and delete entity relationships.

Message | Description
CreateManyToManyRequest | Creates a many-to-many relationship between two entities.
CreateOneToManyRequest | Creates a one-to-many relationship between two entities.
DeleteRelationshipRequest | Deletes an entity relationship.
RetrieveRelationshipRequest | Retrieves an entity relationship.
UpdateRelationshipRequest | Updates an entity relationship.

See Also

Concepts

Customize entity relationship metadata
Entity relationship eligibility
Entity relationship behavior

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Entity relationship eligibility

Before you create an entity relationship you should confirm whether the entity is eligible to participate in the relationship. The following table lists the messages that you can use to determine whether entities can participate in entity relationships.

Message | Description
CanBeReferencedRequest | Checks whether the specified entity can be the primary entity (one) in a one-to-many relationship.
CanBeReferencingRequest | Checks whether the specified entity can be the referencing entity (many) in a one-to-many relationship.
CanManyToManyRequest | Checks whether the entity can participate in a many-to-many relationship.
GetValidManyToManyRequest | Returns the set of entities that can participate in a many-to-many relationship.
GetValidReferencedEntitiesRequest | Returns the set of entities that are valid as the primary entity (one) from the specified entity in a one-to-many relationship.
GetValidReferencingEntitiesRequest | Returns the set of entities that are valid as the related entity (many) to the specified entity in a one-to-many relationship.

See Also

Reference

Create a 1:N Entity Relationship
Create an N:N Entity Relationship

Concepts

Customize entity relationship metadata
Customize entity relationship metadata
Entity relationship metadata messages
Entity relationship behavior

Other Resources

Extend the metadata model

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Entity relationship behavior

When a one-to-many entity relationship exists there are cascading behaviors that can be configured to preserve data integrity and automate business processes. This topic will explain some key concepts and describe how you can configure these cascading behaviors.

Before describing how to configure entity relationship behaviors it is useful to consider how it applies to your business. Three key concepts are:

  • Preserve data integrity
  • Automate business processes
  • Cascading behavior

In This Topic

Preserve data integrity

Automate business processes

Cascading behavior

Configure entity relationship behavior

Preserve data integrity

Each entity can have rules that define a valid record. For example, a Microsoft Dynamics CRM opportunity record must include a reference to a potential customer. Users can’t create a new opportunity record without either adding an existing customer or creating a new customer record.

But what if the account or contact that represents the customer is deleted? In a case like this, possible alternatives are to either:

  • Restrict any attempt to delete a customer record with an associated opportunity.
  • Cascade the delete action when a corresponding customer record is deleted so that any related opportunity records are automatically deleted.

In Microsoft Dynamics CRM for the one-to-many relationships that relate opportunities with customers, such as Opportunity.opportunity_customer_accounts and Contact.opportunity_customer_contacts, the behavior is to cascade the delete action.

When you model your data to use in Microsoft Dynamics CRM you will have similar decisions for how you want to preserve data integrity.

Automate business processes

Your business processes may require you to perform actions on records that have related records. For example, you may need to assign an account to a new salesperson. If that account record has any opportunity records, some options include:

  • Do nothing. The opportunities should continue to be owned by the individuals who work on them.
  • Assign all the opportunities to the new salesperson. As the new owner of this account record, the salesperson is now responsible for all opportunities related to that account.
  • Only assign the active opportunities to the new salesperson. Preserve the owner for any inactive opportunity records for reporting purposes.
  • Only assign the opportunities owned by the previous account owner to the new salesperson. This allows the new salesperson to replace the previous owner.

These options are common ones you can configure using entity relationship behavior in Microsoft Dynamics CRM. If you require different behaviors consider purchasing a solution containing the behavior you need or developing a plugin to provide additional options.

Cascading behavior

These configuration options are called cascading behaviors because they cascade down the hierarchy of related entities. For example, if deleting an account causes related opportunities to be deleted, what about the activities associated with the opportunities? In Microsoft Dynamics CRM the behavior defined in each of the entity relationships for activity type entities is that they are deleted as well.

However, not all entities are treated this way. For example, orders and invoices contain important business data that shouldn’t be inadvertently deleted. They have entity relationship behavior configured to restrict deleting customer or opportunity records that they are associated with. Before you can delete the customer or opportunity that has a related order or invoice record, you must delete the order or invoice first.

As you model your business data by creating custom entities or when using existing Microsoft Dynamics CRM system entities, consider the behavior you require and the implications for the entire hierarchy of related entities.

Parental entity relationships

Each pair of entities that are eligible to have a 1:N relationship can have multiple 1:N relationships between them. Yet only one of those relationships can be considered a parental entity relationship. See Customizable parental entity relationships for a list of all the customizable parental entity relationships.

A parental entity relationship is any 1:N entity relationship where one of the cascading options (defined in CascadeType) in the Parental column of the following table is true.

Action | Parental | Not Parental
Delete | Cascade | RemoveLink Restrict
Share | Cascade UserOwned Active | NoCascade
Unshare | Cascade UserOwned Active | NoCascade
Assign | Cascade UserOwned Active | NoCascade
Reparent | Cascade UserOwned Active | NoCascade

Each referencing entity in a 1:N entity relationship has one referencing attribute where the relationship can be considered parental.

For example, if you create a new custom entity and add a 1:N entity relationship with the account entity where your custom entity is the referencing entity, you can configure the actions for that entity relationship to use the options in the Parental column. If you later add another 1:N entity relationship with your custom entity as the referencing entity you can only configure the actions to use the options in the Not Parental column.

Usually this means that for each entity pair there is only one parental relationship. There are some cases where the referencing attribute on the referencing may include a reference to more than one type of entity.

For example, the Opportunity entity has a referencing attribute called customerid where a reference to either a contact or account record may be stored. There are two separate parental 1:N entity relationships in this case.

Any activity entity, for example, a task, fax, phone call, and so on, has a similar set of parental entity relationships for entities that can be associated using the regardingobjectid referencing attribute.

Configure entity relationship behavior

When you use CreateOneToManyRequest or UpdateRelationshipRequest you include an instance of a OneToManyRelationshipMetadata class in the body of the request. In the CascadeConfiguration property of that class you use the CascadeConfiguration class.

The CascadeConfiguration class contains the properties representing actions that may be performed on the referenced entity in the one-to-many entity relationship. Each property can be assigned one of the values of the CascadeType enumeration.

Value | Application label | Description
Active | Cascade Active | Perform the action on all active referencing entity records associated with the referenced entity record.
Cascade | Cascade All | Perform the action on all referencing entity records associated with the referenced entity record.
NoCascade | Cascade None | Do nothing.
RemoveLink | Remove Link | Remove the value of the referencing attribute for all referencing entity records associated with the referenced entity record.
Restrict | Restrict | Prevent the Referenced entity record from being deleted when referencing entities exist.
UserOwned | Cascade User Owned | Perform the action on all referencing entity records owned by the same user as the referenced entity record.

The CascadeConfiguration class contains the following properties representing actions that may be performed on the referenced entity in the one-to-many entity relationship.

Action Description Valid options

Assign

The referenced entity record owner is changed.

Active
Cascade
NoCascade
UserOwned

Delete

The referenced entity record is deleted.

Note
The options for this action are limited.

Cascade
RemoveLink
Restrict

Merge

The record is merged with another record.

Note
For referenced entities that can be merged, Cascade is the only valid option. In other cases use NoCascade.

Cascade
NoCascade

Reparent

See About the Reparent action below.

Active
Cascade
NoCascade
UserOwned

Share

When the referenced entity record is shared with another user.

Active
Cascade
NoCascade
UserOwned

Unshare

When sharing is removed for the referenced entity record.

Active
Cascade
NoCascade
UserOwned

About the reparent action

The reparent action is very similar to the share action except that it deals with the inherited read access rights instead of explicit read access rights.

Note
For more information about inherited access rights, see How record-based security can be used to control access to records in Microsoft Dynamics CRM, especially the Sharing and Inheritance section.

The reparent action is when you change the value of the referencing attribute in a parental relationship. When a reparent action occurs, the desired scope of the inherited read access rights for related entities might change. The cascade actions related to the reparent action refer to changes to read access rights for the entity record and any entity records related to it. For more information about how an entity relationship is configured to be parental, see Parental Entity Relationships.

For example, there is a parental relationship between Opportunity and Account based on the CustomerId referencing attribute. If you are the owner of an account and there is an opportunity associated with that account, you inherit read access rights to that opportunity and any records associated with it. If the CustomerId referencing attribute value for the opportunity is changed to refer to a different account, the owner of that account inherits read access rights to the opportunity if the Reparent action is Cascade. You can disable this automatic inheritance of read access rights if you set the reparent action to NoCascade. You can use the Active or UserOwned options to specify filters on which records are affected by the change in access rights. For any records related to the opportunity using a parental relationship, the reparent action cascades down those entity relationships and read access rights are inherited based on the filters set for the Reparent action.

See Also

Reference

One-To-Many Relationships

Concepts

Customize entity metadata
Customize entity attribute metadata
Customize entity relationship metadata
Customize entity and attribute mappings
Customize labels to support multiple languages
How record-based security can be used to control access to records in Microsoft Dynamics CRM

Other Resources

Extend the metadata model
Sample: Create and retrieve entity relationships

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create and retrieve entity relationships
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Relationships\WorkWithRelationships.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to verify that entities are eligible to participate in an entity relationship and then creates a 1:N and an N:N entity relationship.

Example

C# Copy Code
using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to create one to many, many to many relationship.
    /// </summary>
    public class WorkWithRelationships
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _oneToManyRelationshipId;
        private System.String _oneToManyRelationshipName;

        private Guid _manyToManyRelationshipId;
        private System.String _manyToManyRelationshipName;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create one-to-many relationship.
        /// Create many-to-many relationship.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    bool eligibleCreateOneToManyRelationship =
                        EligibleCreateOneToManyRelationship("account", "campaign");

                    if (eligibleCreateOneToManyRelationship)
                    {
                        CreateOneToManyRequest createOneToManyRelationshipRequest =
                            new CreateOneToManyRequest
                        {
                            OneToManyRelationship =
                            new OneToManyRelationshipMetadata
                            {
                                ReferencedEntity = "account",
                                ReferencingEntity = "campaign",
                                SchemaName = "new_account_campaign",
                                AssociatedMenuConfiguration = new AssociatedMenuConfiguration
                                {
                                    Behavior = AssociatedMenuBehavior.UseLabel,
                                    Group = AssociatedMenuGroup.Details,
                                    Label = new Label("Account", 1033),
                                    Order = 10000
                                },
                                CascadeConfiguration = new CascadeConfiguration
                                {
                                    Assign = CascadeType.NoCascade,
                                    Delete = CascadeType.RemoveLink,
                                    Merge = CascadeType.NoCascade,
                                    Reparent = CascadeType.NoCascade,
                                    Share = CascadeType.NoCascade,
                                    Unshare = CascadeType.NoCascade
                                }
                            },
                            Lookup = new LookupAttributeMetadata
                            {
                                SchemaName = "new_parent_accountid",
                                DisplayName = new Label("Account Lookup", 1033),
                                RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
                                Description = new Label("Sample Lookup", 1033)
                            }
                        };

                        CreateOneToManyResponse createOneToManyRelationshipResponse =
                            (CreateOneToManyResponse)_serviceProxy.Execute(
                            createOneToManyRelationshipRequest);

                        _oneToManyRelationshipId =
                            createOneToManyRelationshipResponse.RelationshipId;
                        _oneToManyRelationshipName =
                            createOneToManyRelationshipRequest.OneToManyRelationship.SchemaName;

                        Console.WriteLine(
                            "The one-to-many relationship has been created between {0} and {1}.",
                            "account", "campaign");
                    }

                    bool accountEligibleParticipate =
                        EligibleCreateManyToManyRelationship("account");
                    bool campaignEligibleParticipate =
                        EligibleCreateManyToManyRelationship("campaign");

                    if (accountEligibleParticipate && campaignEligibleParticipate)
                    {

                        CreateManyToManyRequest createManyToManyRelationshipRequest =
                            new CreateManyToManyRequest
                        {
                            IntersectEntitySchemaName = "new_accounts_campaigns",
                            ManyToManyRelationship = new ManyToManyRelationshipMetadata
                            {
                                SchemaName = "new_accounts_campaigns",
                                Entity1LogicalName = "account",
                                Entity1AssociatedMenuConfiguration =
                                new AssociatedMenuConfiguration
                                {
                                    Behavior = AssociatedMenuBehavior.UseLabel,
                                    Group = AssociatedMenuGroup.Details,
                                    Label = new Label("Account", 1033),
                                    Order = 10000
                                },
                                Entity2LogicalName = "campaign",
                                Entity2AssociatedMenuConfiguration =
                                new AssociatedMenuConfiguration
                                {
                                    Behavior = AssociatedMenuBehavior.UseLabel,
                                    Group = AssociatedMenuGroup.Details,
                                    Label = new Label("Campaign", 1033),
                                    Order = 10000
                                }
                            }
                        };

                        CreateManyToManyResponse createManytoManyRelationshipResponse =
                            (CreateManyToManyResponse)_serviceProxy.Execute(
                            createManyToManyRelationshipRequest);

                        _manyToManyRelationshipId =
                            createManytoManyRelationshipResponse.ManyToManyRelationshipId;
                        _manyToManyRelationshipName =
                            createManyToManyRelationshipRequest.ManyToManyRelationship.SchemaName;

                        Console.WriteLine(
                            "The many-to-many relationship has been created between {0} and {1}.",
                            "account", "campaign");
                    }

                    // Publish the customization changes.
                    _serviceProxy.Execute(new PublishAllXmlRequest());

                    //You can use either the Name or the MetadataId of the relationship.

                    //Retrieve the One-to-many relationship using the MetadataId.
                    RetrieveRelationshipRequest retrieveOneToManyRequest =
                        new RetrieveRelationshipRequest { MetadataId = _oneToManyRelationshipId };
                    RetrieveRelationshipResponse retrieveOneToManyResponse =
                        (RetrieveRelationshipResponse)_serviceProxy.Execute(retrieveOneToManyRequest);

                    Console.WriteLine("Retrieved {0} One-to-many relationship by id", retrieveOneToManyResponse.RelationshipMetadata.SchemaName);

                    //Retrieve the Many-to-many relationship using the Name.
                    RetrieveRelationshipRequest retrieveManyToManyRequest =
                        new RetrieveRelationshipRequest { Name = _manyToManyRelationshipName};
                    RetrieveRelationshipResponse retrieveManyToManyResponse =
                        (RetrieveRelationshipResponse)_serviceProxy.Execute(retrieveManyToManyRequest);

                    Console.WriteLine("Retrieved {0} Many-to-Many relationship by Name", retrieveManyToManyResponse.RelationshipMetadata.MetadataId);

                    DeleteRequiredRecords(promptForDelete);

                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Determines whether the entity can participate in a many-to-many relationship.
        /// </summary>
        /// <param name="entity">Entity</param>
        /// <returns></returns>
        public bool EligibleCreateManyToManyRelationship(string entity)
        {
            CanManyToManyRequest canManyToManyRequest = new CanManyToManyRequest
            {
                EntityName = entity
            };

            CanManyToManyResponse canManyToManyResponse =
                (CanManyToManyResponse)_serviceProxy.Execute(canManyToManyRequest);

            if (!canManyToManyResponse.CanManyToMany)
            {
                Console.WriteLine(
                    "Entity {0} can't participate in a many-to-many relationship.",
                    entity);
            }

            return canManyToManyResponse.CanManyToMany;
        }
        /// <summary>
        /// Determines whether two entities are eligible to participate in a relationship
        /// </summary>
        /// <param name="referencedEntity">Primary Entity</param>
        /// <param name="referencingEntity">Referencing Entity</param>
        /// <returns></returns>
        public bool EligibleCreateOneToManyRelationship(string referencedEntity,
            string referencingEntity)
        {
            //Checks whether the specified entity can be the primary entity in one-to-many
            //relationship.
            CanBeReferencedRequest canBeReferencedRequest = new CanBeReferencedRequest
            {
                EntityName = referencedEntity
            };

            CanBeReferencedResponse canBeReferencedResponse =
                (CanBeReferencedResponse)_serviceProxy.Execute(canBeReferencedRequest);

            if (!canBeReferencedResponse.CanBeReferenced)
            {
                Console.WriteLine(
                    "Entity {0} can't be the primary entity in this one-to-many relationship",
                    referencedEntity);
            }

            //Checks whether the specified entity can be the referencing entity in one-to-many
            //relationship.
            CanBeReferencingRequest canBereferencingRequest = new CanBeReferencingRequest
            {
                EntityName = referencingEntity
            };

            CanBeReferencingResponse canBeReferencingResponse =
                (CanBeReferencingResponse)_serviceProxy.Execute(canBereferencingRequest);

            if (!canBeReferencingResponse.CanBeReferencing)
            {
                Console.WriteLine(
                    "Entity {0} can't be the referencing entity in this one-to-many relationship",
                    referencingEntity);
            }

            if (canBeReferencedResponse.CanBeReferenced == true
                && canBeReferencingResponse.CanBeReferencing == true)
            {
                return true;
            }
            else
            {
                return false;
            }
        }
        /// <summary>
        /// Deletes the relationships that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity relationships to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                DeleteRelationshipRequest deleteOneToManyRelationshipRequest =
                    new DeleteRelationshipRequest
                {
                    Name = "new_account_campaign"
                };

                _serviceProxy.Execute(deleteOneToManyRelationshipRequest);

                DeleteRelationshipRequest deleteManyToManyRelationshipRequest =
                    new DeleteRelationshipRequest
                {
                    Name = "new_accounts_campaigns"
                };

                _serviceProxy.Execute(deleteManyToManyRelationshipRequest);

                Console.WriteLine("Entity Relationships have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                WorkWithRelationships app = new WorkWithRelationships();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize entity relationship metadata
Create and retrieve entity relationships

Other Resources

Extend the metadata model
Sample: Dump entity relationship information to a file

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Dump entity relationship information to a file
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\Relationships\DumpRelationships.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write out all the entity relationship metadata to an XML file. It uses the RetrieveAllEntitiesRequest message.

The following sample creates a new file at \Relationships\bin\Debug\RelationshipInfo.xml. You can open this file in Microsoft Office Excel to see a tabular report. You may need this information to discover the entity type code for a custom entity for use in reports.

Example

C# Copy Code
using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;
using System.Xml.Serialization;
using System.Xml;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve and write out entity metadata.
    /// </summary>
    public class DumpEntityInfo
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Create storage for new attributes being created
        public List<AttributeMetadata> addedAttributes;

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        public const int _languageCode = 1033;

        // Define the IDs/variables needed for this sample.
        public int _insertedStatusValue;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    RetrieveAllEntitiesRequest request = new RetrieveAllEntitiesRequest()
                    {
                        EntityFilters = EntityFilters.Entity,
                        RetrieveAsIfPublished = true
                    };

                    // Retrieve the MetaData.
                    RetrieveAllEntitiesResponse response = (RetrieveAllEntitiesResponse)_serviceProxy.Execute(request);

                    // Create an instance of StreamWriter to write text to a file.
                    // The using statement also closes the StreamWriter.
            // To view this file, right click the file and choose open with Excel.
            // Excel will figure out the schema and display the information in columns.

                    String filename = String.Concat("EntityInfo.xml");
                    using (StreamWriter sw = new StreamWriter(filename))
                    {
                        // Create Xml Writer.
                        XmlTextWriter metadataWriter = new XmlTextWriter(sw);

                        // Start Xml File.
                        metadataWriter.WriteStartDocument();

                        // Metadata Xml Node.
                        metadataWriter.WriteStartElement("Metadata");

                        foreach (EntityMetadata currentEntity in response.EntityMetadata)
                        {
                            //if (currentEntity.IsIntersect.Value == false)
                            if (true)
                            {
                                // Start Entity Node
                                metadataWriter.WriteStartElement("Entity");

                                // Write the Entity's Information.
                                metadataWriter.WriteElementString("EntitySchemaName", currentEntity.SchemaName);
                                metadataWriter.WriteElementString("OTC", currentEntity.ObjectTypeCode.ToString());
                                metadataWriter.WriteElementString("OwnershipType", currentEntity.OwnershipType.Value.ToString());
                                if (currentEntity.DisplayName.UserLocalizedLabel != null)
                                    metadataWriter.WriteElementString("DisplayName", currentEntity.DisplayName.UserLocalizedLabel.Label);
                                if (currentEntity.DisplayCollectionName.UserLocalizedLabel != null)
                                    metadataWriter.WriteElementString("DisplayCollectionName", currentEntity.DisplayCollectionName.UserLocalizedLabel.Label);

                                metadataWriter.WriteElementString("AutoRouteToOwnerQueue", currentEntity.AutoRouteToOwnerQueue.ToString());
                                metadataWriter.WriteElementString("CanBeInManyToMany", currentEntity.CanBeInManyToMany.Value.ToString());
                                metadataWriter.WriteElementString("CanBePrimaryEntityInRelationship", currentEntity.CanBePrimaryEntityInRelationship.Value.ToString());
                                metadataWriter.WriteElementString("CanBeRelatedEntityInRelationship", currentEntity.CanBeRelatedEntityInRelationship.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateAttributes", currentEntity.CanCreateAttributes.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateCharts", currentEntity.CanCreateCharts.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateForms", currentEntity.CanCreateForms.Value.ToString());
                                metadataWriter.WriteElementString("CanCreateViews", currentEntity.CanCreateViews.Value.ToString());
                                metadataWriter.WriteElementString("CanModifyAdditionalSettings", currentEntity.CanModifyAdditionalSettings.Value.ToString());
                                metadataWriter.WriteElementString("CanTriggerWorkflow", currentEntity.CanTriggerWorkflow.Value.ToString());

                                metadataWriter.WriteElementString("IsActivity", currentEntity.IsActivity.Value.ToString());
                                //metadataWriter.WriteElementString("ActivityTypeMask", currentEntity.ActivityTypeMask.ToString());

                                metadataWriter.WriteElementString("IsActivityParty", currentEntity.IsActivityParty.Value.ToString());

                                metadataWriter.WriteElementString("IsAuditEnabled", currentEntity.IsAuditEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsAvailableOffline", currentEntity.IsAvailableOffline.ToString());
                                metadataWriter.WriteElementString("IsChildEntity", currentEntity.IsChildEntity.ToString());
                                metadataWriter.WriteElementString("IsConnectionsEnabled", currentEntity.IsConnectionsEnabled.ManagedPropertyLogicalName.ToString());
                                metadataWriter.WriteElementString("IsCustomEntity", currentEntity.IsCustomEntity.Value.ToString());
                                metadataWriter.WriteElementString("IsCustomizable", currentEntity.IsCustomizable.Value.ToString());

                                metadataWriter.WriteElementString("IsDocumentManagementEnabled", currentEntity.IsDocumentManagementEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsDuplicateDetectionEnabled", currentEntity.IsDuplicateDetectionEnabled.Value.ToString());
                                if (currentEntity.IsEnabledForCharts != null)
                                    metadataWriter.WriteElementString("IsEnabledForCharts", currentEntity.IsEnabledForCharts.Value.ToString());
                                metadataWriter.WriteElementString("IsImportable", currentEntity.IsImportable.Value.ToString());
                                metadataWriter.WriteElementString("IsIntersect", currentEntity.IsIntersect.Value.ToString());

                                metadataWriter.WriteElementString("IsMailMergeEnabled", currentEntity.IsMailMergeEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsManaged", currentEntity.IsManaged.Value.ToString());
                                metadataWriter.WriteElementString("IsMappable", currentEntity.IsMappable.Value.ToString());

                                metadataWriter.WriteElementString("IsReadingPaneEnabled", currentEntity.IsReadingPaneEnabled.Value.ToString());
                                metadataWriter.WriteElementString("IsRenameable", currentEntity.IsRenameable.Value.ToString());
                                metadataWriter.WriteElementString("IsValidForAdvancedFind", currentEntity.IsValidForAdvancedFind.Value.ToString());
                                metadataWriter.WriteElementString("IsValidForQueue", currentEntity.IsValidForQueue.Value.ToString());
                                metadataWriter.WriteElementString("IsVisibleInMobile", currentEntity.IsVisibleInMobile.Value.ToString());

                                metadataWriter.WriteElementString("PrimaryIdAttribute", currentEntity.PrimaryIdAttribute);
                                metadataWriter.WriteElementString("PrimaryNameAttribute", currentEntity.PrimaryNameAttribute);
                                metadataWriter.WriteElementString("ReportViewName", currentEntity.ReportViewName);
                                metadataWriter.WriteElementString("RecurrenceBaseEntityLogicalName", currentEntity.RecurrenceBaseEntityLogicalName);
                                if (currentEntity.Description.UserLocalizedLabel != null)
                                    metadataWriter.WriteElementString("Description", currentEntity.Description.UserLocalizedLabel.Label);

                                // End Entity Node
                                metadataWriter.WriteEndElement();
                            }
                        }

                        // End Metadata Xml Node
                        metadataWriter.WriteEndElement();
                        metadataWriter.WriteEndDocument();

                        // Close xml writer.
                        metadataWriter.Close();
                    }

                   Console.WriteLine("Done.");

                    //DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes/Reverts the record that was created/changed for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine(
                    "\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {

            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DumpEntityInfo app = new DumpEntityInfo();
                app.Run(config, false);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize entity relationship metadata

Other Resources

Extend the metadata model
RetrieveAllEntitiesRequest
RetrieveAllEntitiesResponse

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize entity and attribute mappings

You can map attributes between entities that have an entity relationship. This lets you set default values for a record that is created in the context of another record. Use the customization tools in the application to map attributes. See the Customization Guide topic Create and edit entity relationships : Mapping Entity Fields. See the section on Mapping entity fields for more information.

See Entity and attribute mappings for a table that shows the default system entity and field mappings.

In This Topic

Behavior in the application

Using entity and attribute mapping data

Auto-mapping attributes between entities

Behavior in the application

Mapping in Microsoft Dynamics CRM streamlines data entry when you create new records that are associated with another record. When an entity has an entity relationship with another entity, you can create new related entity records by using the Create Related tab in the ribbon. When you create a new record in this manner, mapped data from the primary entity record is copied to the form for the new related entity record. By mapping entity attributes, you control what data is copied by adding new mappings in the relationship between the two entities. If you create a record in any way other than from the associated view of the primary entity, data is not mapped.

For example, you might want to set up a mapping between the address fields in accounts and the address fields in contacts. With this mapping, when a user adds a contact associated with a specific account, the address fields for the contact are populated automatically.

You can map one attribute to multiple target attributes. For example, you can map address information in an account to both the billing and shipping addresses in an order.

Mapping is applied before a new, related record is created. Users can make changes before saving the record. Later changes to the data in the primary record are not applied to the related record.

Using entity and attribute mapping data

When creating new records in the context of an existing record where a mapping exists between the entities, you can use the InitializeFromRequest message to define a new record that contains the values specified in the mapping. You can then use the IOrganizationService.Create method to save the record. In in this manner, any mappings that you define are applied.

Valid entity maps are created when an entity relationship is created. Use the entity_map_attribute_maps entity relationship to retrieve the attribute maps for the pair of entities specified by the entity map.

You can create or update attribute map records. The following requirements must be met for attribute maps:

  • The AttributeMetadata type must match.
  • The length of the target field cannot be shorter than the source field.
  • The format must match.
  • The target field must not be used in another mapping.
  • The source field must be visible on the entity form.
  • The target field must be a field in which a user can enter data.
  • Address ID values cannot be mapped.
  • PartyList attributes, where AttributeMetadata.AttributeType is AttributeTypeCode.PartyList cannot be mapped.

Auto-mapping attributes between entities

You can edit attribute mappings between entities for entity relationships that support mapping.

In addition to creating each attribute map manually, you can use the AutoMapEntityRequest message to generate a new set of attribute mappings. This message performs the action found under the Generate Mappings menu option in the More Actions menu on the toolbar. This message maps all the attributes between the two related entities where the attribute names and types are identical. This message is provided as a productivity enhancement so that you do not have to manually add all attribute mappings. Instead, you can generate a set of likely mappings and minimize the amount of manual work to add or remove individual mappings to meet your requirements.

Note
Automatically generating mappings in this manner will remove any previously defined attribute mappings and may include mappings that you do not want.

See Also

Concepts

EntityMap entity messages and methods
AttributeMap entity messages and methods

Other Resources

Extend the metadata model
Customization Guide Create and edit entity relationships : Mapping Entity Fields

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


EntityMap entity messages and methods

An entity map contains the attribute mappings between two entities. The schema name for this entity is EntityMap. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
RetrieveRequest | Retrieves an entity map. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of entity maps. You can also call the IOrganizationService.RetrieveMultiple method.

See Also

Reference

EntityMap Entity Privileges

Concepts

Customize entity and attribute mappings
AttributeMap entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AttributeMap entity messages and methods

An attribute map represents a mapping between two attributes. The schema name for this entity is AttributeMap. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an attribute map. You can also call the Create method.
DeleteRequest | Deletes an attribute map. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves an attribute map. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of attribute maps. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates an attribute map. You can also call the IOrganizationService.Update method.

See Also

Reference

AttributeMap entity privileges

Concepts

Service calendar appearance configuration
Customize entity and attribute mappings
EntityMap entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize labels to support multiple languages

When you create customizations in Microsoft Dynamics CRM, you can support multiple languages by using labels.

In This Topic

Using labels

Messages to use with labels

Customize labels in the base language

Translate customized entity and attribute text

Manage languages for your organization

Using labels

Labels are localized strings displayed to users in the client applications. They are implemented by using the Label class, which supports language packs. Strings that are displayed to users, such as entity display names or options in an option set, can be stored in multiple languages. Users can select which language they want displayed in forms and views in Microsoft Dynamics CRM.

The following table lists all of the metadata that uses the Label class.

Metadata property | Description
AttributeMetadata.Description | Description for an attribute.
AttributeMetadata.DisplayName | Display name for an attribute.
EntityMetadata.Description | Description for an entity.
EntityMetadata.DisplayCollectionName | Plural display name for an entity.
EntityMetadata.DisplayName | Display name for an entity.
Label | Label used for an entity in an entity relationship.
OptionMetadata.Label | Label used for an option in a picklist, state, or status attribute.

The Label class can store one string for each installed language. This array is the LocalizedLabels property. There must always be a label stored for the base language. The labels for other languages can be null. If the user wants to display the user interface in a language and a label does not have a string for that language, the label for the base language is used.

You can use the UserLocalizedLabel property to retrieve the label for the language chosen by the user.

Messages to use with labels

The following table lists the messages you can use to work with localized labels to support multiple languages. When you import translations you can generate a report based on the import Jjob in the same way you can when importing a solution. For more information, see Install or Upgrade a Solution.

Message | Description
ExportTranslationRequest | Exports all translations for a specific solution to a compressed file.
ImportTranslationRequest | Imports all translations from a compressed file.
RetrieveFormattedImportJobResultsRequest | Retrieves the results of an ImportJob as an XML document designed to be opened using Microsoft Office Excel.
RetrieveLocLabelsRequest | Retrieves the localized labels for the specified attribute.
SetLocLabelsRequest | Sets the localized labels for the specified attribute.

Customize labels in the base language

The customization tools provide ways to edit entity display names and you can customize these properties programmatically. You can also edit entity messages. But not every message is exposed. Another way to locate and customize text used in the application is to export the translations, edit the values for the base language and import the translations again. Although this is not the intended purpose of this feature it is a supported way to identify and customize text used in the application. For more information, see Modify the messages for an entity.

Translate customized entity and attribute text

Because you can only perform customizations in the application by using the base language, when you want to provide localized labels for these customizations you must export the text of the labels so that they can be localized for any other languages enabled for the organization.

Export customized text for translation

You can export the translations in the Web application or by using the ExportTranslationRequest message.

Exported text is saved as a compressed file that contains a CrmTranslations.xml that you open by using Microsoft Office Excel. You can send this file to a linguistic expert, translation agency, or localization firm.

For more information, see Office 2003 XML Reference Schemas.

Import translated text

After you have exported the customized entity or attribute text and had it translated, you can import the translated text strings in the Web application by using the ImportTranslationRequest message. The file that you import must be a compressed file that contains the CrmTranslations.xml and the [Content_Types].xml file just as they were exported.

After you import the completed translations, customized text appears for users who work in the languages that you had the text translated into.

Note
Microsoft Dynamics CRM cannot import translated text that is over 500 characters long. If any of the items in your translation file are longer than 500 characters, the import process will fail. If the import process fails, review the line in the file that caused the failure, reduce the number of characters, and try to import again.

Because customization is supported only in the base language, you may be working in Microsoft Dynamics CRM with the base language set as your language preference. To verify that the translated text appears, you must change your language preference for the Microsoft Dynamics CRM user interface. To perform additional customization work, you must change back to the base language.

Manage languages for your organization

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update enables you to install multiple language packs on a server and allows the user to select a language pack. For more information about how to install language packs, see the Installing Guide, Install and deploy a language pack. This section contains information about messages used to manage languages installed for your organization.

The following table lists the messages that you use to work with language packs. Use these messages with the Execute method.

Message | Description
DeprovisionLanguageRequest | Contains the data needed to deprovision a language
ProvisionLanguageRequest | Contains the data needed to provision a new language.
RetrieveAvailableLanguagesRequest | Retrieves the list of available languages.
RetrieveDeprovisionedLanguagesRequest | Retrieves the list of language packs installed on the server that have been disabled.
RetrieveInstalledLanguagePacksRequest | Contains the data needed to retrieve the list of language packs installed on the server.
RetrieveInstalledLanguagePackVersionRequest | Contains the data needed to retrieve the version of an installed language pack.
RetrieveProvisionedLanguagesRequest | Retrieves the list of language packs installed on the server that are enabled.
RetrieveProvisionedLanguagePackVersionRequest | Retrieves the version of the language packs installed on the server.

See Also

Concepts

Modify the messages for an entity

Other Resources

Extend the metadata model
Developers guide to customization for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize entity forms

Forms provide the user interface (UI) that people use to create, view, or edit entity records. Use the form designer in the customization tools to create and edit entity forms. See the customization guide topic Create and design forms for information about tasks related to working with forms in the application.

This topic will provide information necessary to create or edit forms programmatically.

In This Topic

Access form definitions

Form properties

Create and edit forms

Access form definitions

Entity forms are stored in the SystemForm entity along with dashboards and visualizations. There are two ways that you can inspect the form definitions for an entity:

  • Include the entity in an unmanaged solution and export the solution.
  • Query the SystemForm entity

View FormXML from an exported entity

Only definitions of system entity forms that have been customized are included in exported managed solution. To view the definition of a system entity form, you must either change it in some way, or create a new form by saving the existing form with a new name.

After you export the solution, extract the contents and view the customizations.xml file. You’ll find the definition of the forms in ImportExportXml > Entities > Entity > FormXml. In the <FormXml> (FormXml) node, you’ll find each type of form is grouped in a <forms> (FormXml) element with the type attribute specifying the type of form.

Form properties

The following table describes key SystemForm entity attributes and the corresponding data included in the XML elements exported with the solution.

SystemForm property FormXML element Description

AncestorFormId

<Ancestor> (FormXml)

Unique identifier of the parent form. This is set when you choose to create a new form by creating a form by using Save As for an existing form or by using CopySystemFormRequest.

CanBeDeleted

<CanBeDeleted> (FormXml)

Information that specifies whether this component can be deleted.This managed property is only applied if the form was created by importing a managed solution.

Description

<Descriptions> (FormXml)

Description is a string and <Descriptions> (FormXml) contains any localized labels for the description of the form.

The localized labels can be retrieved using the RetrieveLocLabelsRequest.

FormActivationState

<FormActivationState> (FormXml)

Specifies the state of the form.

Only forms of type “main” can be deactivated.

Valid Values:

  • 0: Inactive
  • 1: Active

FormId

<formid> (FormXml)

Unique identifier of the form

FormPresentation

<FormPresentation> (FormXml)

Specifies whether this form is in the updated UI layout in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

FormXml

<form> (FormXml)

XML representation of the form layout.

For details about the form structure, see <form> (FormXml).

IntroducedVersion

<IntroducedVersion> (FormXml)

Version of the solution that the form was added in.

IsAIRMerged

N/A

Specifies whether this form is merged with the updated UI layout in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

IsCustomizable

<IsCustomizable> (FormXml)

Information that specifies whether this component can be customized.

This managed property is only applied if the form was created by importing a managed solution.

IsDefault

N/A

Information that specifies whether the form or the dashboard is the system default.

Name

<LocalizedNames> (FormXml)

Name is a string and <Descriptions> (FormXml) contains any localized labels for the name of the form.

The localized labels can be retrieved using the RetrieveLocLabelsRequest.

ObjectTypeCode

The form is a decedent of the Entity element.

The ObjectTypeCode value is the entity logical name.

Type

<forms> (FormXml) element type attribute

Valid values for forms are:

  • 2: main
  • 5: mobile
  • 6: quick
  • 7: quickCreate

Create and edit forms

You can only create new forms for an entity where EntityMetadata. CanCreateForms allows it.

You can create new forms using either a CreateRequest or the CopySystemFormRequest. When using CopySystemFormRequest or using Save As in the form editor, note that there is no inheritance between forms. Therefore, changes to the base form aren’t automatically applied to any forms created from it.

Editing the form definitions from an exported managed solution and then re-importing the solution is a supported method to edit entity forms. When manually editing forms we strongly recommend you use an XML editor that allows for schema validation. More information: Edit the customizations XML file with schema validation

See Also

Reference

Form XML schema

Concepts

SystemForm (system dashboard) entity messages and methods
Create or edit how business rules are initiated

Other Resources

Developers guide to customization for Microsoft Dynamics CRM
Form XML reference
Create and design forms

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create or edit how business rules are initiated

Business rules is a new feature that allows for defining logic that takes place in a form. Business rules provide an alternative to form scripts because they can be defined within a user interface without writing code. Business rules do not offer any opportunities for the actions they perform to be extended in this release, but by using the Process Trigger entity, you can modify how existing business rules are initiated or register an existing business rule to different events that will initiate it.

More information: Create and edit business rules

Registering business rules

When you create a business rule, you must set the scope and configure conditions that will initiate the business rule. The business rule editor stores this information in the Process Trigger entity. You can read, create, update, and delete process trigger records to modify how business rules are initiated.

The primary scenarios for working with the process trigger entity are:

  • Clone a business rule that is applied to one or more forms to another form.
  • Modify a business rule that is applied to one or more forms so that it applies to all forms.
  • Modify a business rule that is applied to all forms so that it applies only to one or more specific forms.
  • Register a business rule to be applied on the Save event.
Note
If you use the business rule editor to modify a business rule that has been programmatically set to be applied on the Save event, it will revert to either load or change. You must re-apply the change programmatically to have the rule applied on the Save event.

The following table describes relevant process trigger entity attributes.

SchemaName Type Description

ControlName

String

Name of the attribute that a change event is registered for. For other events this value is null.

ControlType

Picklist

Type of the control to which this trigger is bound.

The only valid value for this release is 1. This indicates that the control is an attribute. This value only applies when the ControlName is not null.

Event

String

There are three valid values to indicate the event:

  • load
  • change
  • save

FormId

Lookup

ID of the form associated with the business rule.

This value is null when the rule applies to all forms for the entity that supports business rules.

IsCustomizable

ManagedProperty

Information that specifies whether this component can be customized.

You cannot change process trigger records included in a managed solution when the IsCustomizable.Value is false.

PrimaryEntityTypeCode

EntityName

Logical name for the entity that the business rule is applied on.

ProcessId

Lookup

ID of the process.

ProcessTriggerId

Uniqueidentifier

ID of the process trigger record.

See Also

Concepts

ProcessTrigger entity messages and methods

Other Resources

Create and edit business rules

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProcessTrigger entity messages and methods

The process trigger entity. The schema name for this entity is ProcessTrigger. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

See Create or edit how business rules are initiated for more information.

Message | Description
CreateRequest | Creates a process trigger. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a process trigger. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieves a process trigger. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of workflows. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a process trigger. You can also call the IOrganizationService.Update method.

See Also

Reference

ProcessTrigger entity privileges

Concepts

Create or edit how business rules are initiated
Workflow and process entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SystemForm (system dashboard) entity messages and methods

The system form entity represents the entity forms and organization-owned dashboards in Microsoft Dynamics CRM. The display name for this entity is System Dashboard, but this entity is used for all entity forms. The schema name for this entity is SystemForm. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see SystemForm entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a system form. You can also call the IOrganizationService.Create method.
CopySystemFormRequest | Creates a new entity form that is based on an existing entity form.
DeleteRequest | Deletes a system form. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see SystemFrom entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a system form. You can also call the IOrganizationService.Retrieve method.
RetrieveFilteredFormsRequest | Retrieves the system forms for the specified user.
RetrieveLocLabelsRequest | Retrieves localized labels for SystemForm.Name and SystemForm.Description attributes.
RetrieveMultipleRequest | Retrieves a collection of organization-owned dashboards. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveUnpublishedRequest | Retrieves an unpublished organization-owned dashboard.
RetrieveUnpublishedMultipleRequest | Retrieves a collection of unpublished organization-owned dashboards.
SetLocLabelsRequest | Sets localized labels for SystemForm.Name and SystemForm.Description attributes.
UpdateRequest | Updates a system form. You can also call the IOrganizationService.Update method.

See Also

Concepts

UserForm (user dashboard) entity messages and methods
Customize entity forms
SystemForm entity privileges

Other Resources

Dashboard entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Form XML reference

Use the Form editor to manipulate the XML that defines forms. Use the information in this section when you edit the Form XML.

The root element is <FormXml> (FormXml).

In This Section

<AddressField> (FormXml)

Specifies the composite address field used by a Bing Maps control.

<AllowFilterOff> (FormXml)

Specifies whether users can turn off the record filter when record filtering is enabled.

<Ancestor> (FormXml)

Contains the ID of the updated user experience form that this form was created from.

<AltText> (FormXml)

A parameter for Web resource controls. The value of this element specifies alternative text for image Web resources.

<AutoExpand> (FormXml)

Specifies whether a sub-grid automatically expands to use available space in the form tab.

<AutoResolve> (FormXml)

Specifies whether automatic resolutions in the field are enabled.

<AvailableViewIds> (FormXml)

Controls which views are available for selection, when view selection is enabled.

<Border> (FormXml)

A parameter for IFrame or web resource controls. The value of this element specifies whether to display a border around the control.

<CanBeDeleted> (FormXml)

Specifies whether the form can be deleted.

<cell> (FormXml)

A form layout element. A cell contains the labels and the control to display.

<ChartGridMode> (FormXml)

Specifies whether the sub-grid displays a chart, a grid, or both.

<clientincludes> (FormXml)

Contains references to Web resources or internal files to include with the form.

<clientresources> (FormXml)

Contains files and script objects to be included with the form.

<clientvariables> (FormXml)

For internal use only. Specifies application variables that are available to scripts in the form.

<column> (FormXml)

Specifies a column within a tab element.

<columns> (FormXml)

Contains the columns within a tab.

<control> (FormXml)

Specifies the control to display within a form cell.

<data> (FormXml)

For internal use only.

<Data> Web Resource Parameter (FormXml)

Represents query string parameters to pass to the Web resource.

<DefaultViewId> (FormXml)

Specifies the default view.

<DefaultViewReadOnly> (FormXml)

Specifies that the default view cannot be changed in the form editor.

<dependencies> (FormXml)

Contains the dependencies for an event.

<dependency> (FormXml)

Specifies an attribute that is required by code in an event.

<DependentAttributeName> (FormXml)

Specifies the name of an attribute to use when filtering related records.

<DependentAttributeType> (FormXml)

Specifies the type of entity for the lookup field used to filter related records.

<Description> (FormXml)

Provides a localized description of a form.

<Descriptions> (FormXml)

Contains a set of localized descriptions of the form.

<DisableMru> (FormXml)

Disables the most recently used items for the lookup.

<DisableQuickFind> (FormXml)

Specifies whether to display the search box in the lookup dialog box.

<DisableViewPicker> (FormXml)

Specifies whether to display a list of views to choose from when searching for a record to set in the lookup.

<DisplayConditions> (FormXml)

Contains definitions of any security role membership conditions that must be met to display the form.

<EnableChartPicker> (FormXml)

Specifies whether a chart selection is available.

<EnableContextualActions> (FormXml)

Specifies whether the contextual actions are shown in the inline subgrid. For internal use only.

<EnableJumpBar> (FormXml)

Specifies whether an index is displayed for the sub-grid.

<EnableQuickFind> (FormXml)

Specifies whether to display a search box in the sub-grid.

<EnableViewPicker> (FormXml)

Specifies whether to display a view selection option for the sub-grid.

<EntityLogicalName> (FormXml)

Specifies the entity logical name of the quick create form to open. This parameter is used by lookups to determine the type of record to be created when the New button is clicked.

<event> (FormXml)

Specifies an event for the form or field.

<events> (FormXml)

Contains all the event definitions for a cell or form.

<Everyone> (FormXml)

Specifies that the form is visible to everyone.

<externaldependencies> (FormXml)

Contains dependencies that represent fields that cannot be removed from the form.

<FilterRelationshipName> (FormXml)

Specifies the name of an entity relationship that filters records to only those that use that relationship.

<footer> (FormXml)

Displays read-only information at the bottom of a form.

<form> (FormXml)

Displays read-only information at the bottom of a form.

<formid> (FormXml)

Contains the unique ID value for a form.

<formLibraries> (FormXml)

Contains the JavaScript libraries that are available in the form.

<formparameters> (FormXml)

Contains definitions of custom parameters that will be accepted by the form.

<forms> (FormXml)

Contains all the system form definitions for a specific type of form.

<FormXml> (FormXml)

Contains all the forms definitions for an entity.

<Handler> (FormXml)

Specifies a JavaScript library and function to call for an event.

<Handlers> (FormXml)

Contains all the event handlers for an event.

<header> (FormXml)

Displays read-only information at the top of the form.

<Height> (FormXml)

Provides the height value, when a Web resource for an image uses the Specific parameter.

<hiddencontrols> (FormXml)

For internal use only.

<HorizontalAlignment> (FormXml)

Specifies the horizontal alignment of image Web resources.

<InlineViewIds> (FormXml)

Specifies the GUIDs of the views that are used for inline lookup. These views contain the columns that are displayed in the search results.

<internalcssfile> (FormXml)

For internal use only. Defines style sheets used by the form.

<InternalHandlers> (FormXml)

For internal use only. Contains event handlers defined by Microsoft Dynamics CRM.

<internaljscriptfile> (FormXml)

For internal use only. Defines script Web resources used by the form.

<internaljscriptvariable> (FormXml)

For internal use only. Defines script variables for the form.

<internalresources> (FormXml)

For internal use only. Defines form resources that control the functionality of forms.

<IsCustomizable> (FormXml)

Indicates whether the form is customizable.

<IsInlineNewEnabled> (FormXml)

Specifies whether the New button is shown in the inline lookup. For internal use only.

<IsPassword> (FormXml)

Formats a string attribute field so that the password is hidden when data is typed in the field.

<IsUserChart> (FormXml)

Specifies that the chart displayed is owned by a user rather than by the system.

<IsUserView> (FormXml)

Specifies that the view displayed is owned by a user rather than by the system.

<isvresources> (FormXml)

Contains form resources specified by independent software vendors.

<label> (FormXml)

Defines label text for a specified language.

<labels> (FormXml)

Contains form label definitions.

<Library> (FormXml)

Specifies a JavaScript library that is available to the form.

<LinkControlDefinitionId> (FormXml)

Defines the link control XML to be loaded for the associated flyout definition.

<LocalizedName> (FormXml)

Specifies a name for the form in a specified language.

<LocalizedNames> (FormXml)

Contains names of the form for different languages.

<MaxRowsBeforeScroll> (FormXml)

<NavBar> (FormXml)

Represents a container for items added to the navigation pane in a detail form window.

<NavBarArea> (FormXml)

Contains the titles that replace the navigation group labels in the entity form.

<NavBarAreas> (FormXml)

Contains the NavBarArea definitions for the entity form.

<NavBarByRelationshipItem> (FormXml)

Specifies a navigation item in an entity form that is associated with an entity relationship.

<NavBarItem> (FormXml)

Specifies a navigation item to display in a form. Use this element when the navigation item is not associated with an entity relationship.

<Navigation> (FormXml)

Contains definitions of navigation options that appear in the form page.

<parameters> (FormXml)

Contains the parameters to be passed to a control in a form.

<PassParameters> (FormXml)

A parameter for IFrame and Web Resource controls that specifies that a set of context parameters will be passed in a query string to the URL of the control.

<Preload> (FormXml)

A parameter for IFrame or Web Resource controls. For internal use only.

<Privilege> (FormXml)

Specifies a permission that a user must possess in order for the parent navigation item to be displayed in the form.

<Privileges> (FormXml)

Contains the set of rights that a user needs in order for the navigation item to display in the form.

<PromptAreaCollapsed> (FormXml)

Specifies whether to show the Prompt Area collapsed in the report.

<querystringparameter> (FormXml)

Specifies a query string parameter signature that will be allowed for a form.

<RecordsPerPage> (FormXml)

Sets the number of records to display per page. This is a parameter for sub-grid controls.

<RelationshipName> (FormXml)

Specifies a relationship to be used by a sub-grid control.

<RelationshipRoleOrdinal> (FormXml)

Sets the direction of a Connection Role relationship. This is a parameter for sub-grid controls.

<ReportId> (FormXml)

Specifies the report to display.

<ResolveEmailAddress> (FormXml)

Specifies whether the lookup control should attempt to resolve an email address for the text displayed in the window.

<RibbonDiffXml> (FormXml)

Specifies custom ribbon actions for a form.

<Role> (FormXml)

Specifies a security role that a user must be associated with to view a form.

<row> (FormXml)

Specifies a row used to organize form elements.

<rows> (FormXml)

Specifies rows used to compose form layout.

<Scrolling> (FormXml)

Specifies the scrolling behavior of the IFrame. This is a parameter for IFrame, Web resource, and report controls.

<section> (FormXml)

Specifies a section within a form.

<sections> (FormXml)

Contains the definitions of sections used in the form layout.

<Security> (FormXml)

Indicates whether cross-site scripting restrictions are applied. This is a parameter for IFrame controls.

<ShowInROF> (FormXml)

(Deprecated) Indicated whether this web resource would be displayed in a read-optimized form.

<ShowLinkControlLabel> (FormXml)

For internal use only.

<SizeType> (FormXml)

Specifies how the web resource should be sized to fit in the form.

<SnapshotId> (FormXml)

A parameter for report controls.

<systemform> (FormXml)

Contains the definition of a form and supporting data.

<tab> (FormXml)

Specifies a tab element in the organization of a form.

<tabs> (FormXml)

Contains the tab definitions for a form.

<TargetEntityType> (FormXml)

Specifies the entity records to be displayed in the sub-grid.

<TeamTemplateId> (FormXml)

For internal use only.

<Title> (FormXml)

Specifies the text for a title for a specific language.

<Titles> (FormXml)

Contains definitions of Title elements.

<ToolTip> (FormXml)

Specifies the text to display for a tooltip in a navigation item for a form.

<UnboundLookupControlType> (FormXml)

For internal use only

<UnboundLookupBrowse> (FormXml)

For internal use only

<UnboundLookupStyle> (FormXml)

For internal use only

<UnboundLookupTypes> (FormXml)

For internal use only

<Url> (FormXml)

A parameter for IFrame and Web resource controls that specifies the location of the page or HTML Web resource to open.

<VerticalAlignment> (FormXml)

Specifies the horizontal alignment of image Web resources.

<ViewId> (FormXml)

Specifies the view to be used as the data source for the sub-grid.

<ViewIds> (FormXml)

Specifies the views to be available for selection in the sub-grid.

<ViewPickerReadOnly> (FormXml)

Specifies if enabling or disabling the view picker is allowed by the form editor.

<VisualizationId> (FormXml)

Sets the default chart when chart selection is not enabled.

<webresource> (FormXml)

Specifies a Web resource to be available to the form.

<Width> (FormXml)

A parameter for web resource controls. When a web resource for an image uses the Specific parameter, this parameter provides the width value.

Related Sections

Customize entity forms

Form XML schema

Edit the customizations XML file with schema validation

When to edit the customizations file

Customization XML reference

Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<AddressField> (FormXml)

Specifies the composite address field used by a Bing Maps control.

Syntax

Xml
<AddressField>String</AddressField>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/AddressField

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<AllowFilterOff> (FormXml)

Specifies whether users can turn off the record filter when record filtering is enabled.

Syntax

Xml
<AllowFilterOff>[ true | false]</AllowFilterOff>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Valid for Lookup controls

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//section/rows/row/cell/control/parameters/AllowFilterOff |
//header/rows/row/cell/control/parameters/AllowFilterOff |
//footer/rows/row/cell/control/parameters/AllowFilterOff

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Ancestor> (FormXml)

Contains the ID of the updated user experience form that this form was created from.

Syntax

Xml
<ancestor id = “guid”/>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Id | Guid of the Parent Form, Form Id | String (FormGuidType) | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Remarks

The form editor controls the parameter usage.

Example

The following shows an example of the Ancestor element.

Copy Code
<ancestor id="{8448b78f-8f42-454e-8e2a-f8196b0419af}" />

Element Information

Schema Type

FormGuidType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/ancestor
//FormXml/forms/systemform/ancestor

For internal use only? (Yes/no)

Yes

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<AltText> (FormXml)

A parameter for Web resource controls. The value of this element specifies alternative text for image Web resources.

Syntax

Xml
<AltText>String</AltText>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//section/rows/row/cell/control/parameters/AltText |
//header/rows/row/cell/control/parameters/AltText |
//footer/rows/row/cell/control/parameters/AltText

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<AutoExpand> (FormXml)

Specifies whether a sub-grid automatically expands to use available space in the form tab.

Syntax

Xml
<AutoExpand>[ Auto | Fixed | AutoWithFixedMax]</AutoExpand>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Valid values:

  • Auto
  • Fixed
  • AutoWithFixedMax

Element Information

Schema Type

GridResizeType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//section/rows/row/cell/control/parameters/AutoExpand |
//header/rows/row/cell/control/parameters/AutoExpand |
//footer/rows/row/cell/control/parameters/AutoExpand

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<AutoResolve> (FormXml)

Specifies whether automatic resolutions in the field are enabled.

Syntax

Xml
<AutoResolve>[false|true]</AutoResolve>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

The default value is true. It can be set to false to enhance performance.

Example

The following shows an example of the AutoResolve element.

Xml Copy Code
<AutoResolve>false</AutoResolve>

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//section/rows/row/cell/control/parameters/ AutoResolve |
//header/rows/row/cell/control/parameters/ AutoResolve |
//footer/rows/row/cell/control/parameters/ AutoResolve

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<AvailableViewIds> (FormXml)

Controls which views are available for selection, when view selection is enabled.

Syntax

Xml
<AvailableViewIds>String</AvailableViewIds>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Example

The ViewId values are a comma-separated list of the GUID values for each view.

Copy Code
<AvailableViewIds>{E88CA999-0B16-4AE9-B6A9-9EDC840D42D8},{89939D86-F073-42BA-BFC4-DA7999C78825}</AvailableViewIds>

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/AvailableViewIds

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Border> (FormXml)

A parameter for IFrame or web resource controls. The value of this element specifies whether to display a border around the control.

Syntax

Xml
<Border>[false|true]</Border>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Contains a value of true or false.

Example

Xml Copy Code
<Border>false</Border>

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/Border

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CanBeDeleted> (FormXml)

Specifies whether the form can be deleted.

Syntax

Xml
<CanBeDeleted>[0|1]</CanBeDeleted>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Remarks

The text value can be either a “1” or “0” to indicate true or false.

Element Information

Schema Type

TrueFalse01Type

Validation File

customizationSolution.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/CanBeDeleted

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CancelConditionName> (FormXml)

Specifies the field used by the SLA timer control to check for cancellation condition.

Syntax

Xml
<CancelConditionName>String</CancelConditionName>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/CancelConditionName

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CancelConditionValue> (FormXml)

Specifies the value used by the SLA timer control when determining cancellation.

Syntax

Xml
<CancelConditionValue>String</CancelConditionValue>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/CancelConditionValue

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<cell> (FormXml)

A form layout element. A cell contains the labels and the control to display.

Syntax

Xml
<cell
 addedby="String"
 auto=["0" | "1" | "true" | "false"]
 colspan=Integer
 id="String"
 ispreviewcell=["0" | "1" | "true" | "false"]
 labelid="String"
 locklevel=Integer
 rowspan=Integer
 showlabel=["0" | "1" | "true" | "false"]
 userspacer=["0" | "1" | "true" | "false"]
 visible=["0" | "1" | "true" | "false"]
 <control />
 <events />
 <labels />
</cell>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional
auto | Not used. | Boolean | Optional
colspan | Represents the number of columns used in the row to display the field. | Nonnegative Integer | Optional
id | Unique identifier for the cell. See Remarks. | String (FormGuidType) | Required
ispreviewcell | Used by the dashboard designer to indicate cells in which a user can insert different components. See Remarks. | Boolean | Optional
labelid | A unique id value for the cell label. | String (FormGuidType) | Optional
locklevel | Matches the field formatting property Lock the field on the form. | Non Negative Integer | Optional
rowspan | Represents the number of rows used to display the field in the form. | Non Negative Integer | Optional
showlabel | Determines whether to display the label for the field. | Boolean | Optional
userspacer | Specifies that the cell contains a spacer. | Boolean | Optional
visible | Determines whether the cell is visible on the form by default. | Boolean | Optional

Child Elements

Element | Description
<labels> (FormXml) | Contains form label definitions.
<control> (FormXml) | Specifies the control to display within a form cell.
<events> (FormXml) | Contains all the event definitions for a cell or form.

Parent Elements

Element | Description
<row> (FormXml) | Specifies a row used to organize form elements.

Remarks

If you create a new <tab> (FormXml), <section> (FormXml) or <cell> (FormXml) element by copying from an existing form definition or by manually editing an exported customization.xml file you should create a new GUID value for the id attribute. You should use a tool like guidgen.exe to guarantee a unique valid GUID value. The guidgen.exe is included as part of the Windows SDK.

If you do not specify a new GUID value for the element id, you must create a new GUID value for the labelid attribute and add the labelid attribute. If you have duplicate element id values AND do not specify a unique labelid attribute value you will not be able to uninstall your solution. To address this issue you must export the default solution containing the form definitions, edit each element in the existing forms to add a unique labelid value, and then import those modified form definitions.

The auto attribute is not used. If you want the control in the cell to expand to use all the available space, set the height attribute of the parent row element to auto.

If the rowspan is greater than 1, the number of row elements within the rows element must be equal to or greater than the value of the rowspan attribute.

The ispreviewcell attribute can be used to define dashboard templates. This attribute is not valid for forms.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell |
//FormXml/forms/systemform/form/header/rows/row/cell|
//FormXml/forms/systemform/form/footer/rows/row/cell

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ChartGridMode> (FormXml)

Specifies whether the sub-grid displays a chart, a grid, or both.

Syntax

Xml
<ChartGridMode>String</ChartGridMode>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Valid values for this element are:

  • Chart
  • Grid
  • All

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/ChartGridMode

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<clientincludes> (FormXml)

Contains references to Web resources or internal files to include with the form.

Syntax

Xml
<clientresources>
 <internalresources>
  <clientincludes>
   <internaljscriptfile />
  </clientincludes>
 </internalresources>
 <isvresources>
  <clientincludes>
   <webresource />
  </clientincludes>
 </isvresources>
</clientresources>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<webresource> (FormXml) | Specifies a Web resource to be available to the form.
<internalcssfile> (FormXml) | For internal use only. Defines style sheets used by the form.
<internaljscriptfile> (FormXml) | For internal use only. Defines script Web resources used by the form.

Parent Elements

Element | Description
<isvresources> (FormXml) | Contains form resources specified by independent software vendors.
<internalresources> (FormXml) | For internal use only. Defines form resources that control the functionality of forms.

Remarks

<webresource> (FormXml) elements are only valid when this element is a child of <isvresources> (FormXml).

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/clientresources/isvresources/clientincludes |
//FormXml/forms/systemform/form/clientresources/internalresources/clientincludes

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<clientresources> (FormXml)

Contains files and script objects to be included with the form.

Syntax

Xml
<clientresources>
 <internalresources />
 <isvresources />
</clientresources>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<internalresources> (FormXml) | For internal use only. Defines form resources that control the functionality of forms.
<isvresources> (FormXml) | Contains form resources specified by independent software vendors.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Element Information

Schema Type

ClientResourcesType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/clientresources

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<clientvariables> (FormXml)

For internal use only. Specifies application variables that are available to scripts in the form.

Syntax

Xml
<clientvariables>
 <internaljscriptvariable />
</clientvariables>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<internaljscriptvariable> (FormXml) | For internal use only. Defines script variables for the form.

Parent Elements

Element | Description
<internalresources> (FormXml) | For internal use only. Defines form resources that control the functionality of forms.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/clientresources/internalresources/clientvariables

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<column> (FormXml)

Specifies a column within a tab element.

Syntax

Xml
<column width="String">
 <sections />
</column>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
width | Specifies the width of a column by a percentage. | String (FormPercentageType) | Required

Child Elements

Element | Description
<sections> (FormXml) | Contains the definitions of sections used in the form layout.

Parent Elements

Element | Description
<columns> (FormXml) | Contains the columns within a tab.

Remarks

The width attribute must match this regular expression: ^(100|[0-9]{1,2})%$

Example

Xml Copy Code
<column width="100%">
 <sections />
</column>

Element Information

Schema Name

complexType

Validation File

FormXml.xsd

Number of Occurrences

1 to 3

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<columns> (FormXml)

Contains the columns within a tab.

Syntax

Xml
<columns>
 <column />
</columns>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<column> (FormXml) | Specifies a column within a tab element.

Parent Elements

Element | Description
<tab> (FormXml) | Specifies a tab element in the organization of a form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<control> (FormXml)

Specifies the control to display within a form cell.

Syntax

Xml
<control
 addedby="String"
 classid="String"
 datafieldname="String"
 disabled=["0" | "1" | "true" | "false"]
 id="String" >
 <parameters />
</control>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
id | Represents a string that uniquely identifies the control on the form. | String | Optional
classid | Specifies the unique ID for the control used for the field. | String (FormGuidType) | Optional
datafieldname | Matches the control to the name of the data field. | String | Optional
disabled | Matches the field display property Field is read-only. | Boolean | Optional
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional

Child Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Parent Elements

Element | Description
<cell> (FormXml) | A form layout element. A cell contains the labels and the control to display.

Remarks

The classid corresponds to the following field types:

Name | GUID
AccessPrivilegeControl | {F93A31B2-99AC-4084-8EC2-D4027C31369A}
AccessTeamEntityPicker | {3F4E2A56-F102-4B4D-AB9C-F1574CA5BFDA}
ActivitiesContainerControl | {C72511AB-84E5-4FB7-A543-25B4FC01E83E}
ActivitiesWallControl | {6636847D-B74D-4994-B55A-A6FAF97ECEA2}
ArticleContentControl | {F02EF977-2564-4B9A-B2F0-DF083D8A019B}
CheckBoxControl | {B0C6723A-8503-4FD7-BB28-C8A06AC933C2}
CompositionLinkControl | {DB1284EF-9FFC-4E99-B382-0CC082FE2364}
ConnectionControl | {3246F906-1F71-45F7-B11F-D7BE0F9D04C9}
ConnectionRoleObjectTypeListControl | {821ACF1A-7E46-4A0C-965D-FE14A57D78C7}
CoverPagePicklistControl | {4168A05C-D857-46AF-8457-5BB47EB04EA1}
DateTimeControl | {5B773807-9FB2-42DB-97C3-7A91EFF8ADFF}
DecimalControl | {C3EFE0C3-0EC6-42BE-8349-CBD9079DFD8E}
DurationControl | {AA987274-CE4E-4271-A803-66164311A958}
DynamicPropertyListControl | {6896F004-B17A-4202-861E-8B7EA2080E0B}
EmailAddressControl | {ADA2203E-B4CD-49BE-9DDF-234642B43B52}
EmailBodyControl | {6F3FB987-393B-4D2D-859F-9D0F0349B6AD}
ErrorStatusControl | {F4C16ECA-CA81-4E39-9448-834B8378721E}
FloatControl | {0D2C745A-E5A8-4C8F-BA63-C6D3BB604660}
FrameControl | {FD2A7985-3187-444E-908D-6624B21F69C0}
GridControl | {E7A81278-8635-4D9E-8D4D-59480B391C5B}
HiddenInputControl | {5546E6CD-394C-4BEE-94A8-4425E17EF6C6}
IntegerControl | {C6D124CA-7EDA-4A60-AEA9-7FB8D318B68F}
KBViewerControl | {A62B6FA9-169E-406C-B1AA-EAB828CB6026}
LanguagePicker | {671A9387-CA5A-4D1E-8AB7-06E39DDCF6B5}
LinkControl | {DFDF1CDE-837B-4AC9-98CF-AC74361FD89D}
LookupControl | {270BD3DB-D9AF-4782-9025-509E298DEC0A}
MailMergeLanguagePicker | {B634828E-C390-444A-AFE6-E07315D9D970}
MapLinkControl | {91DC0675-C8B9-4421-B1E0-261CEBF02BAC}
MapsControl | {62B0DF79-0464-470F-8AF7-4483CFEA0C7D}
MoneyControl | {533B9E00-756B-4312-95A0-DC888637AC78}
NotesControl | {06375649-C143-495E-A496-C962E5B4488E}
PartyListControl | {CBFB742C-14E7-4A17-96BB-1A13F7F64AA2}
PhoneNumberControl | {8C10015A-B339-4982-9474-A95FE05631A5}
PicklistControl | {3EF39988-22BB-4F0B-BBBE-64B5A3748AEE}
PicklistLookupControl | {2305E33A-BAD3-4022-9E15-1856CF218333}
PicklistStatusControl | {5D68B988-0661-4DB2-BC3E-17598AD3BE6C}
ProcessControl | {06E9F7AF-1F54-4681-8EEC-1E21A1CEB465}
QuickFormCollectionControl | {5C5600E0-1D6E-4205-A272-BE80DA87FD42}
QuickFormControl | {69AF7DCA-2E3B-4EE7-9201-0DA731DD2413}
RadioControl | {67FAC785-CD58-4F9F-ABB3-4B7DDC6ED5ED}
RegardingControl | {F3015350-44A2-4AA0-97B5-00166532B5E9}
RelatedInformationControl | {163B90A6-EB64-49D2-9DF8-3C84A4F0A0F8}
RelationshipRolePicklist | {5F986642-5961-4D9F-AB5E-643D71E231E9}
ReportControl | {A28F441B-916C-4865-87FD-0C5D53BD59C9}
SocialInsightControl | {86B9E25E-695E-4FEF-AC69-F05CFA96739C}
TextAreaControl | {E0DECE4B-6FC8-4A8F-A065-082708572369}
TextBoxControl | {4273EDBD-AC1D-40D3-9FB2-095C621B552D}
TickerControl | {1E1FC551-F7A8-43AF-AC34-A8DC35C7B6D4}
TimerControl | {9C5CA0A1-AB4D-4781-BE7E-8DFBE867B87E}
TimeZonePicklistControl | {7C624A0B-F59E-493D-9583-638D34759266}
UrlControl | {71716B6C-711E-476C-8AB8-5D11542BFB47}
WebResourceHtmlControl | {9FDF5F91-88B1-47F4-AD53-C11EFC01A01D}
WebResourceImageControl | {587CDF98-C1D5-4BDE-8473-14A0BC7644A7}
WebResourceSilverlightControl | {080677DB-86EC-4544-AC42-F927E74B491F}

Element Information

Schema Type

FormXmlControlType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ControlMode> (FormXml)

Indicates the mode of the quick form control. This parameter can have the following values:

  • Create: The form will always create a record.
  • Edit: The existing record can be edited.
  • Read: This represents the "read-only" behavior of the form. The record cannot be edited in the quick form.
  • Inherit: The quick form can inherit the mode of the root form.

Syntax

Xml
<ControlMode>String</ControlMode>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

StringType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/section/rows/row/cell/control/parameters/ControlMode

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<data> (FormXml)

For internal use only.

Syntax

Xml
<hiddencontrols>
 <data
  id="String"
  datafieldname="String"
  classid="{5546E6CD-394C-4bee-94A8-4425E17EF6C6}" />
</hiddencontrols>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
id | Represents the unique ID used to represent the control in the form. | String | Required
datafieldname | Matches the control to the name of the data field. | String | Required
classid | The data element always uses the following classid: {5546E6CD-394C-4bee-94A8-4425E17EF6C6} | String (FormGuidType) | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<hiddencontrols> (FormXml) | For internal use only.

Remarks

Although the schema does not require the attributes, the hidden field cannot function without them.

The datafieldname and the id attribute values are usually the same.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/hiddencontrols/data

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Data> Web Resource Parameter (FormXml)

Represents query string parameters to pass to the Web resource.

Syntax

Xml
<Data>String</Data>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/Data

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DefaultViewId> (FormXml)

Specifies the default view.

Syntax

Xml
<DefaultViewId>String</DefaultViewId>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

The value must match this regular expression: \{[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}\}

Element Information

Schema Type

FormGuidType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/DefaultViewId

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DefaultViewReadOnly> (FormXml)

Specifies that the default view cannot be changed in the form editor.

Syntax

Xml
<DefaultViewReadOnly>[true|false]</DefaultViewReadOnly>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/DefaultViewReadOnly

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<dependencies> (FormXml)

Contains the dependencies for an event.

Syntax

Xml
<dependencies>
 <dependency />
</dependencies>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<dependency> (FormXml) | Specifies an attribute that is required by code in an event.

Parent Elements

Element | Description
<event> (FormXml) | Specifies an event for the form or field.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/event/InternalHandlers/Handler/dependencies |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/event/Handlers/Handler/dependencies |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/event/dependencies |
//FormXml/forms/systemform/form/externaldependencies

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<dependency> (FormXml)

Specifies an attribute that is required by code in an event.

Syntax

Xml
<dependency id="String"/>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
id | Specifies the ID of a field that cannot be removed from the form while the dependency exists. | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<dependencies> (FormXml) | Contains the dependencies for an event.
<externaldependencies> (FormXml) | Contains dependencies that represent fields that cannot be removed from the form.

Remarks

With the <externaldependencies> (FormXml) element, at least one dependency must exist. With the <dependencies> (FormXml) element, a dependency is not required.

Example

The following shows an example of the dependency element.

Xml Copy Code
<dependency id="transactioncurrencyid" />

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/event/InternalHandlers/Handler/dependencies/dependency |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/event/Handlers/Handler/dependencies/dependency |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/event/dependencies/dependency |
//FormXml/forms/systemform/form/externaldependencies/dependency

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DependentAttributeName> (FormXml)

Specifies the name of an attribute to use when filtering related records.

Syntax

Xml
<DependentAttributeName>String</DependentAttributeName>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/DependentAttributeName

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DependentAttributeType> (FormXml)

Specifies the type of entity for the lookup field used to filter related records.

Syntax

Xml
<DependentAttributeType>String</DependentAttributeType>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/DependentAttributeType

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Description> (FormXml)

Provides a localized description of a form.

Syntax

Xml
<Description
 description="String"
 id="String"
 languagecode=Integer
/>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
id | The unique id of the description. | String (guid) | Optional
description | The text of the description | String | Required
languagecode | A four or five digit locale ID. | positive integer | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Descriptions> (FormXml) | Contains a set of localized descriptions of the form.

Remarks

Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart).

Element Information

Schema Type

FieldXmlFieldUIType

Validation File

customizationSolution.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/Descriptions/Description

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Descriptions> (FormXml)

Contains a set of localized descriptions of the form.

Syntax

Xml
<Descriptions >
 <Description />
</Descriptions>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Description> (FormXml) | Provides a localized description of a form.

Parent Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Element Information

Schema Type

DescriptionsType

Validation File

customizationSolutions.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/Descriptions

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DisableMru> (FormXml)

Disables the most recently used items for the lookup.

Syntax

Xml
<DisableMru>[true|false]</DisableMru>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/DisableMru

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DisableQuickFind> (FormXml)

Specifies whether to display the search box in the lookup dialog box.

Syntax

Xml
<DisableQuickFind>[true|false]</DisableQuickFind>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/DisableQuickFind

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DisableViewPicker> (FormXml)

Specifies whether to display a list of views to choose from when searching for a record to set in the lookup.

Syntax

Xml
<DisableViewPicker>[true|false]</DisableViewPicker>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/DisableViewPicker

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DisplayConditions> (FormXml)

Contains definitions of any security role membership conditions that must be met to display the form.

Syntax

Xml
<DisplayConditions
 FallbackForm =["0" | "1" | "true" | "false"]
 Order=Integer>
 [<Everyone />|<Role />]
</DisplayConditions>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
FallbackForm | Indicates if this form represents a fallback form for the entity. | Boolean | Optional
Order | The relative order in which to display the form. | Integer | Optional

Child Elements

Element | Description
<Everyone> (FormXml) | Specifies that the form is visible to everyone.
<Role> (FormXml) | Specifies a security role that a user must be associated with to view a form.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Element Information

Schema Type

FormDisplayConditionsType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/DisplayConditions

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EnableChartPicker> (FormXml)

Specifies whether a chart selection is available.

Syntax

Xml
<EnableChartPicker>[true|false]</EnableChartPicker>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/EnableChartPicker

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EnableContextualActions> (FormXml)

Specifies whether the contextual actions are shown in the inline subgrid. For internal use only.

Syntax

Xml
<EnableContextualActions>[false|true]</EnableContextualActions>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

This parameter is unsupported and is for internal use only.

Example

The following shows an example of the EnableContextualActions element.

Copy Code
<EnableContextualActions>false</EnableContextualActions>

Element Information

For internal use only.

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EnableJumpBar> (FormXml)

Specifies whether an index is displayed for the sub-grid.

Syntax

Xml
<EnableJumpBar>[true|false]</EnableJumpBar>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/EnableJumpBar

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EnableQuickFind> (FormXml)

Specifies whether to display a search box in the sub-grid.

Syntax

Xml
<EnableQuickFind>[true|false]</EnableQuickFind>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/EnableQuickFind

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EnableViewPicker> (FormXml)

Specifies whether to display a view selection option for the sub-grid.

Syntax

Xml
<EnableViewPicker>[true|false]</EnableViewPicker>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/EnableViewPicker

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EntityLogicalName> (FormXml)

Specifies the entity logical name of the quick create form to open. This parameter is used by lookups to determine the type of record to be created when the New button is clicked.

This parameter is applicable only when <IsInlineNewEnabled> (FormXml) is set to true. For internal use only.

Syntax

Xml
<EntityLogicalName>string</EntityLogicalName>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

This parameter is unsupported and is for internal use only.

Example

The following shows an example of the EntityLogicalName element.

Copy Code
<EntityLogicalName>Contact</EntityLogicalName>

Element Information

For internal use only.

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<event> (FormXml)

Specifies an event for the form or field.

Syntax

Xml
<event
 active=["0" | "1" | "true" | "false"]
 application=["0" | "1" | "true" | "false"]
 attribute="String"
 BehaviorInBulkEditForm="String"
 eventType=["DataEvent" | "ControlEvent"]
 name="String">
 <dependencies />
 <Handlers />
 <InternalHandlers />
</event>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

active

Describes whether the event is enabled for the form or the field. The default value is false.

Boolean

Optional

application

For internal use only.

Boolean

Optional

attribute

The name of an attribute for an OnChange event.

String

Optional

BehaviorInBulkEditForm

For internal use only. Do not change this value.

Enumeration (BehaviorInBulkEditForm)

Optional

eventType

Valid values:

  • DataEvent
  • ControlEvent

Enumeration (CrmEventType)

Optional

name

The name of the event to associate scripts with. Valid values:

  • onload
  • onchange
  • onsave
  • tabstatechange
  • onreadystatecomplete

String

Optional

Child Elements

Element | Description
<dependencies> (FormXml) | Contains the dependencies for an event.
<Handlers> (FormXml) | Contains all the event handlers for an event.
<InternalHandlers> (FormXml) | For internal use only. Contains event handlers defined by Microsoft Dynamics CRM.

Parent Elements

Element | Description
<events> (FormXml) | Contains all the event definitions for a cell or form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/events/event |
//FormXml/forms/systemform/form/tabs/tab/events/event |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/events/event  |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/event

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<events> (FormXml)

Contains all the event definitions for a cell or form.

Syntax

Xml
<events>
 <event />
</events>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<event> (FormXml) | Specifies an event for the form or field.

Parent Elements

Element | Description
<cell> (FormXml) | A form layout element. A cell contains the labels and the control to display.
<form> (FormXml) | Contains the definition of a form.
<section> (FormXml) | Specifies a section within a form.
<tab> (FormXml) | Specifies a tab element in the organization of a form.

Element Information

Schema Type

FormXmlEventsType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/events |
//FormXml/forms/systemform/form/tabs/tab/events |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/events |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Everyone> (FormXml)

Specifies that the form is visible to everyone.

Syntax

Xml
<Everyone />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayConditions> (FormXml) | Contains definitions of any security role membership conditions that must be met to display the form.

Element Information

Schema Name

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/DisplayConditions/Everyone

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<externaldependencies> (FormXml)

Contains dependencies that represent fields that cannot be removed from the form.

Syntax

Xml
<externaldependencies>
 <dependency />
</externaldependencies>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<dependency> (FormXml) | Specifies an attribute that is required by code in an event.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Remarks

The <dependency> (FormXml) element is a required child of this element.

External dependencies are set in the form properties Non-Event Dependencies tab. Each event has an area where dependencies may be recorded that are specific to that event. External dependencies are not related to a specific form or field event. For example, if you are setting the default value of a field by using a query string to open a form for a new record, or if the target of an IFrame or a Web Resource dialog reads data from the form.

Element Information

Schema Type

FormXmlExternalDependenciesType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/externaldependencies

See Also

Concepts

Customize entity forms
Set field values using parameters passed to a form

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FailureTimeField> (FormXml)

Specifies the time field used by the SLA timer control to assess failure.

Syntax

Xml
<FailureTimeField>String</FailureTimeField>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/FailureTimeField

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FailureConditionName> (FormXml)

Specifies the field used by the SLA timer control to check for failure conditions.

Syntax

Xml
<FailureConditionName>String</FailureConditionName>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/FailureConditionName

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FailureConditionValue> (FormXml)

Specifies the value used by the SLA timer control when determining failure.

Syntax

Xml
<FailureConditionValue>String</FailureConditionValue>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/FailureConditionValue

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FilterRelationshipName> (FormXml)

Specifies the name of an entity relationship that filters records to only those that use that relationship.

Syntax

Xml
<FilterRelationshipName>String</FilterRelationshipName>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/FilterRelationshipName

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<footer> (FormXml)

Displays read-only information at the bottom of a form.

Syntax

Xml
<footer
 celllabelalignment=["Center " | "Left" | "Right"]
 celllabelposition=["Top " | "Left"]
 columns="Integer"
 id="String"
 labelwidth="Integer" >
 <rows />
</footer>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

celllabelalignment

Valid Values:

  • Center
  • Left
  • Right

Enumeration

Optional

celllabelposition

Valid Values:

  • Top
  • Left

Enumeration

Optional

columns

For internal use only.

Non Negative Integer

Optional

id

Unique ID for the footer.

String (FormGuidType)

Required

labelwidth

Defines the horizontal space for a footer label in pixels. The default is 110 pixels.

Non Negative Integer

Optional

Child Elements

Element | Description
<rows> (FormXml) | Specifies rows used to compose form layout.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Element Information

Schema Type

FormXmlHeaderFooterType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/footer

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<form> (FormXml)

Contains the definition of a form.

Syntax

Xml
<form
 addedby="String"
 enablerelatedinformation=["0" | "1" | "true" | "false"]
 hasmargin=["0" | "1" | "true" | "false"] maxWidth="Integer"
 relatedInformationCollapsed=["0" | "1" | "true" | "false"] showImage=["0" | "1" | "true" | "false"] >
 shownavigationbar=["0" | "1" | "true" | "false"] >
 <ancestor/>
 <clientresources />
 <DisplayConditions />
 <events />
 <externaldependencies />
 <footer />
 <formLibraries />
 <formparameters />
 <header />
 <hiddencontrols />
 <Navigation />
 <RibbonDiffXml />
 <tabs />
</form>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
enablerelatedinformation | Controls whether the Form Assistant is enabled. The default value is false. | Boolean | Optional
relatedInformationCollapsed | Controls whether the Form Assistant pane is expanded by default. The default value is false. | Boolean | Optional
maxWidth | Specifies a maximum width for the form in pixels. This value must be greater than or equal to 400. | Integer | Optional
hasmargin | For internal use only. | Boolean | Optional
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional
showImage | Controls whether the entity image is displayed. The default value is false. | Boolean | Optional
shownavigationbar | Sets whether the navigation area of the form is displayed. | Boolean | Optional

Child Elements

Element | Description
<Ancestor> (FormXml) | Contains the ID of the updated user experience form that this form was created from.
<clientresources> (FormXml) | Contains files and script objects to be included with the form.
<DisplayConditions> (FormXml) | Contains definitions of any security role membership conditions that must be met to display the form.
<events> (FormXml) | Contains all the event definitions for a cell or form.
<externaldependencies> (FormXml) | Contains dependencies that represent fields that cannot be removed from the form.
<footer> (FormXml) | Displays read-only information at the bottom of a form.
<formLibraries> (FormXml) | Contains the JavaScript libraries that are available in the form.
<formparameters> (FormXml) | Contains definitions of custom parameters that will be accepted by the form.
<header> (FormXml) | Displays read-only information at the top of the form.
<hiddencontrols> (FormXml) | For internal use only.
<Navigation> (FormXml) | Contains definitions of navigation options that appear in the form page.
<RibbonDiffXml> (FormXml) | Specifies custom ribbon actions for a form.
<tabs> (FormXml) | Contains the tab definitions for a form.

Parent Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Element Information

Schema Type

FormType

Validation File

customizationSolution.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/form

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FormActivationState> (FormXml)

Specifies the state of the form.

Syntax

Xml
<FormActivationState>Integer</FormActivationState>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Remarks

Only main forms can be deactivated.

Valid Values:

  • 0 : Inactive
  • 1 : Active

Element Information

Schema Name

Non Negative Integer

Validation File

customizationSolutions.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/FormActivationState

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<formid> (FormXml)

Contains the unique ID value for a form.

Syntax

Xml
<formid>String</formid>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Remarks

A valid value must represent a GUID and match this regular expression:

Copy Code
\{[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}\}

Element Information

Schema Name

GuidType

Validation File

customizationSolutions.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/formid

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FormPresentation> (FormXml)

Specifies whether this form uses in the updated UI layout or the classic form from earlier versions.

Syntax

Xml
<FormPresentation>Integer</FormPresentation>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Remarks

Valid Values:

  • 0 : Classic form
  • 1 : Updated form

Element Information

Schema Name

Non Negative Integer

Validation File

customizationSolutions.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/FormPresentation

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<formLibraries> (FormXml)

Contains the JavaScript libraries that are available in the form.

Syntax

Xml
<formLibraries >
 <Library />
</formLibraries>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Library> (FormXml) | Specifies a JavaScript library that is available to the form.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Element Information

Schema Type

FormXmlLibraryType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/formLibraries

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<formparameters> (FormXml)

Contains definitions of custom parameters that will be accepted by the form.

Syntax

Xml
<formparameters>
 <querystringparameter />
</formparameters>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<querystringparameter> (FormXml) | Specifies a query string parameter signature that will be allowed for a form.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Element Information

Schema Type

FormParametersType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/formparameters

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<forms> (FormXml)

Contains all the system form definitions for a specific type of form.

Syntax

Xml
<forms
 type=["main" | "preview" | "appointmentBook" | "minicampaignbo"| "mobile" | "dashboard" | "other" | "quick" | "quickCreate"]
 >
 <systemform />
</forms>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

type

Valid values include:

  • main
  • preview
  • appointmentBook
  • minicampaignbo
  • mobile
  • dashboard
  • other
  • quick
  • quickCreate

Enumeration

Optional

Child Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Parent Elements

Element | Description
<FormXml> (FormXml) | Contains all the forms definitions for an entity.

Remarks

The following describes the meaning of the type attribute values.

Type | Description
main | An entity form displayed in the application.
preview | The entity preview form displayed as an expanding element in the grid.
appointmentBook | Used with the appointment, equipment, serviceappointment, and systemeser entities for the Service Scheduling user interface.
minicampaignbo | Used with the bulkoperation (quick campaign) entity.
mobile | Defines the form used by Microsoft Dynamics CRM for phones.
dashboard | The form defines a dashboard.
other | Not used.
quick | Used to define Quick View forms.
quickCreate | Used to define Quick Create forms.

Element Information

Schema Type

SystemFormsType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FormXml> (FormXml)

Contains all the forms definitions for an entity.

Syntax

Xml
<FormXml>
 <forms />
</FormXml>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<forms> (FormXml) | Contains all the system form definitions for a specific type of form.

Parent Elements

Element | Description
<Entity> (ImportExportXml) | The root element for the definition of an entity.

Element Information

Schema Name

FormXml

Validation File

customizaitonSolution.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Handler> (FormXml)

Specifies a JavaScript library and function to call for an event.

Syntax

Xml
<Handler
 enabled=["0" | "1" | "true" | "false"]
 functionName="String"
 handlerUniqueId="String"
 libraryName="String"
 parameters="String"
 passExecutionContext=["0" | "1" | "true" | "false"]
 <dependencies />
</Handler>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
enabled | Specifies whether the handler is enabled | Boolean | Optional
functionName | Specifies the name of the function. | String | Required
handlerUniqueId | The unique ID for the handler. | String | Required
libraryName | The name of the Script Web Resource that contains the function. | String | Required
parameters | The values passed to the function | String | Optional
passExecutionContext | Indicates whether the execution context should be passed to the function. | Boolean | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Handlers> (FormXml) | Contains all the event handlers for an event.

Element Information

Schema Type

FormXmlHandlerType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/events/Handlers/Handler |
//FormXml/forms/systemform/form/tabs/tab/events/Handlers/Handler |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/events/Handlers/Handler |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/Handlers/Handler

See Also

Reference

Execution context (client-side reference)

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Handlers> (FormXml)

Contains all the event handlers for an event.

Syntax

Xml
<Handlers>
 <Handler />
</Handlers>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Handler> (FormXml) | Specifies a JavaScript library and function to call for an event.

Parent Elements

Element | Description
<event> (FormXml) | Specifies an event for the form or field.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/events/Handlers |
//FormXml/forms/systemform/form/tabs/tab/events/Handlers |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/events/Handlers |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/Handlers

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<header> (FormXml)

Displays read-only information at the top of the form.

Syntax

Xml
<header
 celllabelalignment=["Center " | "Left" | "Right"]
 celllabelposition=["Top " | "Left"]
 columns="Integer"
 id="String"
 labelwidth="Integer" >
 <rows />
</header>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

celllabelalignment

Valid Values:

  • Center
  • Left
  • Right

Enumeration

Optional

celllabelposition

Valid Values:

  • Top
  • Left

Enumeration

Optional

columns

For internal use only.

Non Negative Integer

Optional

id

Unique ID for the header.

String (FormGuidType)

Required

labelwidth

Defines the horizontal space for a header label in pixels. The default is 110 pixels.

Non Negative Integer

Optional

Child Elements

Element | Description
<rows> (FormXml) | Specifies rows used to compose form layout.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Element Information

Schema Type

FormXmlHeaderFooterType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/header

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Height> (FormXml)

Provides the height value, when a Web resource for an image uses the Specific parameter.

Syntax

Xml
<Height>Integer</Height>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Unsigned Integer

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/Height

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<hiddencontrols> (FormXml)

For internal use only.

Syntax

Xml
<hiddencontrols>
 <data />
</hiddencontrols>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<data> (FormXml) | For internal use only.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/hiddencontrols

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<HorizontalAlignment> (FormXml)

Specifies the horizontal alignment of image Web resources.

Syntax

Xml
<HorizontalAlignment>String</HorizontalAlignment>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Valid values:

  • Left
  • Right
  • Center
  • NotSet

Element Information

Schema Type

ImageHorizontalAlignmentType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/HorizontalAlignment

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<InlineViewIds> (FormXml)

Specifies the GUIDs of the views that are used for inline lookup. These views contain the columns that are displayed in the search results.

Syntax

Xml
<InlineViewIds>String</InlineViewIds>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

This parameter is unsupported and is for internal use only.

Example

The following shows an example of the InlineViewIds element.

Copy Code
<InlineViewIds>{c14e0638-4996-4720-97cd-c58f0df74228},{f9e54d49-0c76-4cbd-979b-5fe94b496beb}</InlineViewIds>

Element Information

For internal use only.

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<internalcssfile> (FormXml)

For internal use only. Defines style sheets used by the form.

Syntax

Xml
<internalcssfile src="String" />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
src | Valid values match this regular expression: (\$webresource:)?/(.)+ | String | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<clientincludes> (FormXml) | Contains references to Web resources or internal files to include with the form.

Element Information

Schema Type

ClientFileIncludeAttributeType

Validation File

FormXml.xsd

Number of Occurrences

0 to 100000

XPath

Copy Code
//FormXml/forms/systemform/form/clientresources/internalresources/clientincludes/internalcssfile

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<InternalHandlers> (FormXml)

For internal use only. Contains event handlers defined by Microsoft Dynamics CRM.

Syntax

Xml
<InternalHandlers >
 <Handler />
</InternalHandlers>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Handler> (FormXml) | Specifies a JavaScript library and function to call for an event.

Parent Elements

Element | Description
<event> (FormXml) | Specifies an event for the form or field.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or one

XPath

Copy Code
//FormXml/forms/systemform/form/events/InternalHandlers |
//FormXml/forms/systemform/form/tabs/tab/events/InternalHandlers |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/events/InternalHandlers |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/events/InternalHandlers

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<internaljscriptfile> (FormXml)

For internal use only. Defines script Web resources used by the form.

Syntax

Xml
<internaljscriptfile src="String" />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
src | Valid values match this regular expression: (\$webresource:)?/(.)+ | String | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<clientincludes> (FormXml) | Contains references to Web resources or internal files to include with the form.

Element Information

Schema Type

ClientFileIncludeAttributeType

Validation File

FormXml.xsd

Number of Occurrences

0 to 100000

XPath

Copy Code
//FormXml/forms/systemform/form/clientresources/internalresources/clientincludes/internaljscriptfile

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<internaljscriptvariable> (FormXml)

For internal use only. Defines script variables for the form.

Syntax

Xml
<internaljscriptvariable
 name="String"
 resourceid="String" />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
name | Valid values must not exceed 32 characters and must match this regular expression: LOCID_([A-Za-z0-9_])+ | String | Required
resourceid | Valid values must match this regular expression: ([A-Za-z0-9_.])+ | String | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<clientvariables> (FormXml) | For internal use only. Specifies application variables that are available to scripts in the form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 to 100000

XPath

Copy Code
//FormXml/forms/systemform/form/clientresources/internalresources/clientvariables/internaljscriptvariable

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<internalresources> (FormXml)

For internal use only. Defines form resources that control the functionality of forms.

Syntax

Xml
<clientresources>
 <internalresources />
 <isvresources />
</clientresources>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<clientincludes> (FormXml) | Contains references to Web resources or internal files to include with the form.
<clientvariables> (FormXml) | For internal use only. Specifies application variables that are available to scripts in the form.

Parent Elements

Element | Description
<clientresources> (FormXml) | Contains files and script objects to be included with the form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/clientresources/internalresources

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<IntroducedVersion> (FormXml)

A version number that represents the version of the solution that the solution component was added in.

Syntax

Xml
<IntroducedVersion>String</IntroducedVersion>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Remarks

The string must match this regular expression pattern: ^[0-9]+(\.[0-9]+){1,3}$.

Element Information

Schema Name

VersionType

Validation File

customizationSolutions.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/IntroducedVersion

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<IsCustomizable> (FormXml)

Indicates whether the form is customizable.

Syntax

Xml
<IsCustomizable>[0|1]</IsCustomizable>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Remarks

The text value can be either a “1” or “0” to indicate true or false.

Element Information

Schema Type

TrueFalse01Type

Validation File

customizationSolution.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/IsCustomizable

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<IsInlineNewEnabled> (FormXml)

Specifies whether the New button is shown in the inline lookup. For internal use only.

Syntax

Xml
<IsInlineNewEnabled>[false|true]</IsInlineNewEnabled>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

For the New button to show up in the inline lookup, the <IsInlineNewEnabled> parameter must be passed as true, and the <EntityLogicalName> (FormXml) parameter should not be empty and must have a valid value. This parameter is unsupported and is for internal use only.

Example

The following shows an example of the IsInlineNewEnabled element.

Copy Code
<IsInlineNewEnabled>true</IsInlineNewEnabled>

Element Information

For internal use only.

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<IsPassword> (FormXml)

Formats a string attribute field so that the password is hidden when data is typed in the field.

Syntax

Xml
<IsPassword>[true|false]</IsPassword>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/IsPassword

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<IsUserChart> (FormXml)

Specifies that the chart displayed is owned by a user rather than by the system.

Syntax

Xml
<IsUserChart>[false|true]</IsUserChart>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/IsUserChart

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<IsUserView> (FormXml)

Specifies that the view displayed is owned by a user rather than by the system.

Syntax

Xml
<IsUserView>[false|true]</IsUserView>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/IsUserView

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<isvresources> (FormXml)

Contains form resources specified by independent software vendors.

Syntax

Xml
<isvresources >
 <clientincludes />
</isvresources>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<clientincludes> (FormXml) | Contains references to Web resources or internal files to include with the form.

Parent Elements

Element | Description
<clientresources> (FormXml) | Contains files and script objects to be included with the form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/clientresources/isvresources

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<label> (FormXml)

Defines label text for a specified language.

Syntax

Xml
<label
 addedby="String"
 description="String"
 languagecode="Integer"
/>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
description | Text providing a label. | String | Required
languagecode | A four or five digit locale ID. | Positive Integer | Required
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<labels> (FormXml) | Contains form label definitions.

Remarks

Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart).

Example

The following shows an example of the label element.

Xml Copy Code
<labels>
  <label description="Due Date" languagecode="1033" />
  <label description="入金期日" languagecode="1041" />
  <label description="تاريخ الاستحقاق" languagecode="1025" />
  <label description="Fälligkeitsdatum" languagecode="1031" />
  <label description="Date d"échéance" languagecode="1036" />
  <label description="Fecha de vencimiento" languagecode="3082" />
</labels>

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/labels/label |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/labels/label |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/labels/label

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<labels> (FormXml)

Contains form label definitions.

Syntax

Xml
<labels>
 <label />
</labels>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<label> (FormXml) | Defines label text for a specified language.

Parent Elements

Element | Description
<tab> (FormXml) | Specifies a tab element in the organization of a form.
<section> (FormXml) | Specifies a section within a form.
<cell> (FormXml) | A form layout element. A cell contains the labels and the control to display.

Example

The following shows an example of the labels element.

Xml Copy Code
<labels>
  <label description="Due Date" languagecode="1033" />
  <label description="入金期日" languagecode="1041" />
  <label description="تاريخ الاستحقاق" languagecode="1025" />
  <label description="Fälligkeitsdatum" languagecode="1031" />
  <label description="Date d"échéance" languagecode="1036" />
  <label description="Fecha de vencimiento" languagecode="3082" />
</labels>

Element Information

Schema Type

FormXmlLabelsType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/labels |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/labels |
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/labels

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Library> (FormXml)

Specifies a JavaScript library that is available to the form.

Syntax

Xml
<Library
 libraryUniqueId="String"
 name="String"
/>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
libraryUniqueId | A unique identifier for the library. See Remarks. | String | Required
name | The name of the Script Web Resource. | String | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<formLibraries> (FormXml) | Contains the JScript libraries that are available in the form.

Remarks

You should generate a unique GUID value for the libraryUniqueId attribute. The Windows SDK includes a guidgen.exe application that you can use to generate a GUID value.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

1 or 50

XPath

Copy Code
//FormXml/forms/systemform/form/formLibraries/Library

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<LinkControlDefinitionId> (FormXml)

Defines the link control XML to be loaded for the associated flyout definition.

Syntax

Xml
<LinkControlDefinitionId>String</LinkControlDefinitionId>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Example

The following shows an example of the LinkControlDefinitionId element.

Copy Code
<LinkControlDefinitionId>{0F337699-D595-48D9-B733-6479E5F5EB07}</LinkControlDefinitionId>

Element Information

Schema Type

FormGuidType

Validation File

FormXml.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/section/rows/row/cell/control/parameters/LinkControlDefinitionId

For internal use only?(Yes/No)

Yes

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<LocalizedName> (FormXml)

Specifies a name for the form in a specified language.

Syntax

Xml
<LocalizedName
 description="String"
 id="String"
 languagecode="Positive Integer"
/>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
id | The unique ID for the localized name. | String | Optional
description | The text of the localized name. | String | Required
languagecode | A four or five digit locale ID. | positive integer | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<LocalizedNames> (FormXml) | Contains names of the form for different languages.

Remarks

Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart).

Element Information

Schema Type

FieldXmlFieldUIType

Validation File

customizationSolution.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/LocalizedNames/LocalizedName

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<LocalizedNames> (FormXml)

Contains names of the form for different languages.

Syntax

Xml
<LocalizedNames>
 <LocalizedName />
</LocalizedNames>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<LocalizedName> (FormXml) | Specifies a name for the form in a specified language.

Parent Elements

Element | Description
<systemform> (FormXml) | Contains the definition of a form and supporting data.

Element Information

Schema Type

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/LocalizedNames

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<MaxRowsBeforeScroll> (FormXml)

For internal use only.

Syntax

Xml
<MaxRowsBeforeScroll>Integer</MaxRowsBeforeScroll>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Integer

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/MaxRowsBeforeScroll

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<NavBar> (FormXml)

Represents a container for items added to the navigation pane in a detail form window.

Syntax

Xml
<NavBar
 ValidForCreate="Unsigned Byte"
 ValidForUpdate="Unsigned Byte" >
 <NavBarByRelationshipItem />
 <NavBarItem />
</NavBar>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
ValidForCreate | Specifies whether the NavBar should be shown in the form navigation when a record is being created. | Unsigned Byte | Optional
ValidForUpdate | Specifies whether the NavBar should be shown in the form navigation when a record is being updated. | Unsigned Byte | Optional

Child Elements

Element | Description
<NavBarByRelationshipItem> (FormXml) | Specifies a navigation item in an entity form that is associated with an entity relationship.
<NavBarItem> (FormXml) | Specifies a navigation item to display in a form. Use this element when the navigation item is not associated with an entity relationship.

Parent Elements

Element | Description
<Navigation> (FormXml) | Contains definitions of navigation options that appear in the form page.

Element Information

Schema Type

FormNavBarType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBar

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<NavBarArea> (FormXml)

Contains the titles that replace the navigation group labels in the entity form.

Syntax

Xml
<NavBarArea
 Id="String">
 <Titles />
</NavBarArea>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Id | Specifies the navigation area that the child Title elements should replace. | String | Required

Child Elements

Element | Description
<Titles> (FormXml) | Contains definitions of Title elements.

Parent Elements

Element | Description
<NavBarAreas> (FormXml) | Contains the NavBarArea definitions for the entity form.

Remarks

The possible id attribute values are shown in the following table.

Value | Description
Details | Title value will replace Common.
Info | Title value will replace Common.
Sales | Title value will replace Sales.
Service | Title value will replace Service.
Marketing | Title value will replace Marketing.
InternetMarketing | Title value will replace Internet Marketing.
Processes | Title value will replace Processes.

Example

The following shows an example of

Xml Copy Code
<NavBarAreas>
 <NavBarArea Id="Details">
  <Titles>
   <Title LCID="1033" Text="Customized Details Title" />
 </Titles>
 </NavBarArea>
 <NavBarArea Id="Sales">
  <Titles>
   <Title LCID="1033" Text="Customized Sales Title" />
   <Title LCID="1031" Text="Custom Sales Title in German" />
  </Titles>
 </NavBarArea>
 <NavBarArea Id="Service">
  <Titles>
   <Title LCID="1033" Text="Customized Service Title" />
   </Titles>
 </NavBarArea>
</NavBarAreas>

Element Information

Schema Name

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBarAreas/NavBarArea

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<NavBarAreas> (FormXml)

Contains the NavBarArea definitions for the entity form.

Syntax

Xml
<NavBarAreas>
 <NavBarArea />
</NavBarAreas>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<NavBarArea> (FormXml) | Contains the titles that replace the navigation group labels in the entity form.

Parent Elements

Element | Description
<Navigation> (FormXml) | Contains definitions of navigation options that appear in the form page.

Element Information

Schema Name

FormNavBarAreasType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBarAreas

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<NavBarByRelationshipItem> (FormXml)

Specifies a navigation item in an entity form that is associated with an entity relationship.

Syntax

Xml
<NavBarByRelationshipItem
 Area= ["Details" | "Info" | "Sales" | "Service" | "Marketing" | "InternetMarketing" | "Processes"]
 AvailableOffline=["0" | "1" | "true" | "false"]
 Client="String"
 Icon="String"
 Id="String"
 RelationshipName="String"
 Sequence="Non Negative Integer"
 Show=["0" | "1" | "true" | "false"]
 TitleResourceId="String"
 ViewId="String">
 <Privileges />
 <Titles />
 <ToolTip />
</NavBarByRelationshipItem>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Area

Indicates which Area the relationship will display in. Valid values:

  • Details
  • Info
  • Sales
  • Service
  • Marketing
  • InternetMarketing
  • Processes

String

Optional

AvailableOffline

Indicates whether the navigation item will be show when the user is not connected to the server

Boolean

Optional

Client

Specifies the Microsoft Dynamics CRM clients that will display this navigation item.

String

Optional

Icon

The path to the image or Web Resource that represents the icon.

String

Optional

Id

The unique string identifying the navigation item.

String

Required

RelationshipName

The name of the entity relationship.

String

Required

Sequence

Indicates the order to display the item relative to other items.

Non Negative Integer

Optional

Show

Indicates whether the Navigation Link should be displayed by default.

Boolean

Optional

TitleResourceId

For internal use only.

String

Optional

ViewId

Valid value must match this regular expression:

Copy Code
\{?[0-9a-fA-F]{8}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{12}\}?

String (FormISVGuid)

Optional

Child Elements

Element | Description
<Privileges> (FormXml) | Contains the set of rights that a user needs in order for the navigation item to display in the form.
<Titles> (FormXml) | Contains definitions of Title elements.
<ToolTip> (FormXml) | Specifies the text to display for a tooltip in a navigation item for a form.

Parent Elements

Element | Description
<NavBar> (FormXml) | Represents a container for items added to the navigation pane in a detail form window.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBar/NavBarByRelationshipItem

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<NavBarItem> (FormXml)

Specifies a navigation item to display in a form. Use this element when the navigation item is not associated with an entity relationship.

Syntax

Xml
<NavBarItem
  Area = ["Details" | "Info" | "Sales" | "Service" | "Marketing" | "InternetMarketing" | "Processes"]
  AvailableOffline=["0" | "1" | "true" | "false"]
  Client= ["Web" | "Outlook"]
  Icon="String"
  Id="String"
  PassParams="Unsigned Byte"
  Sequence="Non Negative Integer"
  Url="String" >
  <Titles />
 </NavBarItem>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Area | Specifies which area to include the element. See Remarks. | String | Optional
AvailableOffline | Specifies whether the item should be displayed while the user is not connected to the server. The default is ‘true’. | Boolean | Optional
Client | Specifies the intended client for the control. Valid Values: Web Outlook | String | Optional
Icon | Specifies the image Web Resource to be displayed. The icon should be 16x16 pixels. | String | Required
Id | A unique id for the item. | String | Required
PassParams | Valid Values: 0 = do not pass parameters [default] 1 = pass parameters | Unsigned Byte (FormCRM_Boolean) | Optional
Sequence | Indicates the order to display the item relative to other items. | Non Negative Integer | Optional
Url | Specifies the URL or Web Resource to display. | String | Optional

Child Elements

Element | Description
<Titles> (FormXml) | Contains definitions of Title elements.

Parent Elements

Element | Description
<NavBar> (FormXml) | Represents a container for items added to the navigation pane in a detail form window.

Remarks

For each entity there is an Area attribute on the navigation area. This corresponds to the expandable areas in the navigation pane on a form. You can add a new NavBarItem to each area described here.

The possible values are shown in the following table.

Area value | Description
“Info” or “Details” | The item is added under Common. This is the default.
Sales | The item is added under Sales.
Service | The item is added under Service.
Marketing | The item is added under Marketing.
InternetMarketing | The item is added under Internet Marketing.
Processes | The item is added under Processes.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 to 100000

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBar/NavBarItem

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Navigation> (FormXml)

Contains definitions of navigation options that appear in the form page.

Syntax

Xml
<Navigation>
 <NavBar />
 <NavBarAreas />
</Navigation>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<NavBarAreas> (FormXml) | Contains the NavBarArea definitions for the entity form.
<NavBar> (FormXml) | Represents a container for items added to the navigation pane in a detail form window.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Element Information

Schema Type

FormNavigationType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<parameters> (FormXml)

Contains the parameters to be passed to a control in a form.

Syntax

Xml
<parameters>
 <!-- For Lookup controls-->
 <AllowFilterOff />
 <AutoResolve />
 <AvailableViewIds />
 <DefaultViewId />
 <DefaultViewReadOnly />
 <DependentAttributeName />
 <DependentAttributeType />
 <DisableMru />
 <DisableQuickFind />
 <DisableViewPicker />
 <EntityLogicalName/>
 <FilterRelationshipName />
 <InlineViewIds/>
 <IsInlineNewEnabled/>
 <ResolveEmailAddress />
 <UnboundLookupBrowse />
 <UnboundLookupControlType />
 <UnboundLookupStyle />
 <UnboundLookupTypes />
 <ViewPickerReadOnly />

 <!-- For Link Control-->
 <LinkControlDefinitionId/>
 <ShowLinkControlLabel />
 <!-- For IFrame or Web resource controls-->
 <Border />
 <IsPassword />
 <PassParameters />
 <Preload />
 <Scrolling /><!-- For Reports too-->
 <ShowOnMobileClient/>
 <Security /><!-- For IFrame controls only-->
 <Url />
 <!-- For Web resource controls-->
 <AltText />
 <Data />
 <Height />
 <HorizontalAlignment />
 <ShowInROF/>
 <SizeType />
 <VerticalAlignment />
 <Width />

 <!-- For Sub-Grid controls-->
 <AutoExpand />
 <ChartGridMode />
 <EnableChartPicker />
 <EnableContextualActions/>
 <EnableJumpBar />
 <EnableQuickFind />
 <EnableViewPicker />
 <IsUserChart />
 <IsUserView />
 <MaxRowsBeforeScroll>
 <RecordsPerPage />
 <RelationshipName />
 <RelationshipRoleOrdinal />
 <TargetEntityType />
 <TeamTemplateId />
 <ViewId />
 <ViewIds />
 <VisualizationId />
 <!-- For Reports -->
 <PromptAreaCollapsed />
 <ReportId />
 <SnapshotId />

<!-- For Bing Maps  -->
 <AddressField />

<!-- For SLA Timer  -->
 <FailureTimeField />
<FailureConditionName />
<FailureConditionValue />
<SuccessConditionName />
<SuccessConditionValue />
<WarningConditionName />
<WarningConditionValue />
<CancelConditionName />
<CancelConditionValue />

</parameters>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<AddressField> (FormXml) | Specifies the composite address field used by a Bing Maps control.
<AllowFilterOff> (FormXml) | Specifies whether users can turn off the record filter when record filtering is enabled.
<AltText> (FormXml) | A parameter for Web resource controls. The value of this element specifies alternative text for image Web resources.
<AutoExpand> (FormXml) | Specifies whether a sub-grid automatically expands to use available space in the form tab.
<AutoResolve> (FormXml) | Specifies whether automatic resolutions in the field are enabled.
<AvailableViewIds> (FormXml) | Specifies the views to be available for selection in the sub-grid.
<Border> (FormXml) | A parameter for IFrame or web resource controls. The value of this element specifies whether to display a border around the control.
<CancelConditionName> (FormXml) | Specifies the field used by the SLA timer control to check for cancellation condition.
<CancelConditionValue> (FormXml) | Specifies the value used by the SLA timer control when determining cancellation.
<ChartGridMode> (FormXml) | Specifies whether the sub-grid displays a chart, a grid, or both.
<Data> Web Resource Parameter (FormXml) | Represents query string parameters to pass to the Web resource.
<DefaultViewId> (FormXml) | Specifies the default view.
<DefaultViewReadOnly> (FormXml) | Specifies that the default view cannot be changed in the form editor.
<DependentAttributeName> (FormXml) | Specifies the name of an attribute to use when filtering related records.
<DependentAttributeType> (FormXml) | Specifies the type of entity for the lookup field used to filter related records.
<DisableMru> (FormXml) | Disables the most recently used items for the lookup.
<DisableQuickFind> (FormXml) | Specifies whether to display the search box in the lookup dialog box.
<DisableViewPicker> (FormXml) | Specifies whether to display a list of views to choose from when searching for a record to set in the lookup.
<EnableChartPicker> (FormXml) | Specifies whether a chart selection is available.
<EnableContextualActions> (FormXml) | Specifies whether the contextual actions are shown in the inline subgrid. For internal use only.
<EnableJumpBar> (FormXml) | Specifies whether an index is displayed for the sub-grid.
<EnableQuickFind> (FormXml) | Specifies whether to display a search box in the sub-grid.
<EnableViewPicker> (FormXml) | Specifies whether to display a view selection option for the sub-grid.
<EntityLogicalName> (FormXml) | Specifies the entity logical name of the quick create form to open. This parameter is used by lookups to determine the type of record to be created when the New button is clicked.
<FailureTimeField> (FormXml) | Specifies the time field used by the SLA timer control to assess failure.
<FailureConditionName> (FormXml) | Specifies the field used by the SLA timer control to check for failure conditions.
<FailureConditionValue> (FormXml) | Specifies the value used by the SLA timer control when determining failure.
<FilterRelationshipName> (FormXml) | Specifies the name of an entity relationship that filters records to only those that use that relationship.
<Height> (FormXml) | Provides the height value, when a Web resource for an image uses the Specific parameter.
<HorizontalAlignment> (FormXml) | Specifies the horizontal alignment of image Web resources.
<InlineViewIds> (FormXml) | Specifies the GUIDs of the views that are used for inline lookup. These views contain the columns that are displayed in the search results.
<IsInlineNewEnabled> (FormXml) | Specifies whether the New button is shown in the inline lookup. For internal use only.
<IsPassword> (FormXml) | Formats a string attribute field so that the password is hidden when data is typed in the field.
<IsUserChart> (FormXml) | Specifies that the chart displayed is owned by a user rather than by the system.
<IsUserView> (FormXml) | Specifies that the view displayed is owned by a user rather than by the system.
<LinkControlDefinitionId> (FormXml) | Defines the link control XML to be loaded for the associated flyout definition.
<MaxRowsBeforeScroll> (FormXml) | For internal use only.
<PassParameters> (FormXml) | A parameter for IFrame and Web Resource controls that specifies that a set of context parameters will be passed in a query string to the URL of the control.
<Preload> (FormXml) | A parameter for IFrame or Web Resource controls. For internal use only.
<PromptAreaCollapsed> (FormXml) | Specifies whether to show the Prompt Area collapsed in the report.
<RecordsPerPage> (FormXml) | Sets the number of records to display per page. This is a parameter for sub-grid controls.
<RelationshipName> (FormXml) | Specifies a relationship to be used by a sub-grid control.
<RelationshipRoleOrdinal> (FormXml) | Sets the direction of a Connection Role relationship. This is a parameter for sub-grid controls.
<ReportId> (FormXml) | Specifies the report to display.
<ResolveEmailAddress> (FormXml) | Specifies whether the lookup control should attempt to resolve an email address for the text displayed in the window.
<Scrolling> (FormXml) | Specifies the scrolling behavior of the IFrame. This is a parameter for IFrame, Web resource, and report controls.
<Security> (FormXml) | Indicates whether cross-site scripting restrictions are applied. This is a parameter for IFrame controls.
<ShowLinkControlLabel> (FormXml) | For internal use only.
<ShowInROF> (FormXml) | (Deprecated) Indicated whether this web resource would be displayed in a read-optimized form.
<ShowOnMobileClient> (FormXml) | Indicates whether the Iframe or web resource control is displayed for entity forms and dashboards in Microsoft Dynamics CRM for tablets.
<SizeType> (FormXml) | Specifies how the web resource should be sized to fit in the form.
<SnapshotId> (FormXml) | A parameter for report controls.
<SuccessConditionName> (FormXml) | Specifies the field used by the SLA timer control to check for success condition.
<SuccessConditionValue> (FormXml) | Specifies the value used by the SLA timer control when determining success.
<TargetEntityType> (FormXml) | Specifies the entity records to be displayed in the sub-grid.
<TeamTemplateId> (FormXml) | For internal use only.
<UnboundLookupBrowse> (FormXml) | For internal use only.
<UnboundLookupControlType> (FormXml) | For internal use only.
<UnboundLookupStyle> (FormXml) | For internal use only.
<UnboundLookupTypes> (FormXml) | For internal use only.
<Url> (FormXml) | A parameter for IFrame and Web resource controls that specifies the location of the page or HTML Web resource to open.
<VerticalAlignment> (FormXml) | Specifies the horizontal alignment of image Web resources.
<ViewId> (FormXml) | Specifies the view to be used as the data source for the sub-grid.
<ViewIds> (FormXml) | Specifies the views to be available for selection in the sub-grid.
<ViewPickerReadOnly> (FormXml) | Specifies if enabling or disabling the view picker is allowed by the form editor.
<VisualizationId> (FormXml) | Sets the default chart when chart selection is not enabled.
<WarningConditionName> (FormXml) | Specifies the field used by the SLA timer control to check for warning condition.
<WarningConditionValue> (FormXml) | Specifies the value used by the SLA timer control when determining warning.
<Width> (FormXml) | A parameter for web resource controls. When a web resource for an image uses the Specific parameter, this parameter provides the width value.

Parent Elements

Element | Description
<control> (FormXml) | Specifies the control to display within a form cell.

Remarks

The parameters element is valid for several different types of controls. Specific child elements are only valid for particular types of controls. The following table breaks out which parameters are valid for each type of control:

Child element | Lookup | Link | IFrame | Web Resource | Sub-Grid | Report | Bing Maps | Timer
AddressField |  |  |  |  |  |  | X |
AllowFilterOff | X |  |  |  |  |  |  |
AutoResolve | X |  |  |  |  |  |  |
AvailableViewIds | X |  |  |  |  |  |  |
DefaultViewId | X |  |  |  |  |  |  |
DefaultViewReadOnly | X |  |  |  |  |  |  |
DependentAttributeName | X |  |  |  |  |  |  |
DependentAttributeType | X |  |  |  |  |  |  |
DisableMru | X |  |  |  |  |  |  |
DisableQuickFind | X |  |  |  |  |  |  |
DisableViewPicker | X |  |  |  |  |  |  |
EnableContextualActions |  |  |  |  | X |  |  |
EntityLogicalName | X |  |  |  |  |  |  |
FilterRelationshipName | X |  |  |  |  |  |  |
InlineViewIds | X |  |  |  |  |  |  |
IsInlineNewEnabled | X |  |  |  |  |  |  |
LinkControlDefinitionId |  | X |  | X |  |  |  |
ShowLinkControlLabel |  | X |  |  |  |  |  |
ResolveEmailAddress | X |  |  |  |  |  |  |
UnboundLookupBrowse | X |  |  |  |  |  |  |
UnboundLookupControlType | X |  |  |  |  |  |  |
UnboundLookupStyle | X |  |  |  |  |  |  |
UnboundLookupTypes | X |  |  |  |  |  |  |
ShowInROF |  |  |  | X |  |  |  |
ViewPickerReadOnly | X |  |  |  |  |  |  |
Border |  |  | X | X |  |  |  |
IsPassword |  |  | X | X |  |  |  |
PassParameters |  |  | X | X |  |  |  |
Preload |  |  | X | X |  |  |  |
Scrolling |  |  | X | X |  | X |  |
Security |  |  | X |  |  |  |  |
Url |  |  | X | X |  |  |  |
ShowOnMobileClient |  |  | X | X |  |  |  |
AltText |  |  |  | X |  |  |  |
Data |  |  |  | X |  |  |  |
Height |  |  |  | X |  |  |  |
HorizontalAlignment |  |  |  | X |  |  |  |
SizeType |  |  |  | X |  |  |  |
VerticalAlignment |  |  |  | X |  |  |  |
Width |  |  |  | X |  |  |  |
AutoExpand |  |  |  |  | X |  |  |
ChartGridMode |  |  |  |  | X |  |  |
EnableChartPicker |  |  |  |  | X |  |  |
EnableJumpBar |  |  |  |  | X |  |  |
EnableQuickFind |  |  |  |  | X |  |  |
EnableViewPicker |  |  |  |  | X |  |  |
IsUserChart |  |  |  |  | X |  |  |
IsUserView |  |  |  |  | X |  |  |
RecordsPerPage |  |  |  |  | X |  |  |
RelationshipName |  |  |  |  | X |  |  |
RelationshipRoleOrdinal |  |  |  |  | X |  |  |
TargetEntityType |  |  |  |  | X |  |  |
ViewId |  |  |  |  | X |  |  |
ViewIds |  |  |  |  | X |  |  |
VisualizationId |  |  |  |  | X |  |  |
TeamTemplateId |  |  |  |  | X |  |  |
MaxRowsBeforeScroll |  |  |  |  | X |  |  |
PromptAreaCollapsed |  |  |  |  |  | X |  |
ReportId |  |  |  |  |  | X |  |
SnapshotId |  |  |  |  |  | X |  |
FailureTimeField |  |  |  |  |  |  |  | X
SuccessConditionName |  |  |  |  |  |  |  | X
SuccessConditionValue |  |  |  |  |  |  |  | X
WarningConditionName |  |  |  |  |  |  |  | X
WarningConditionValue |  |  |  |  |  |  |  | X
CancelConditionName |  |  |  |  |  |  |  | X
CancelConditionValue |  |  |  |  |  |  |  | X

Example

The following shows an example of parameters.

Xml Copy Code
<control id="IFRAME_sdk" classid="{FD2A7985-3187-444e-908D-6624B21F69C0}">
 <parameters>
  <Url>http://bing.com</Url>
  <PassParameters>false</PassParameters>
  <Security>true</Security>
  <Scrolling>auto</Scrolling>
  <Border>true</Border>
 </parameters>
</control>

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<PassParameters> (FormXml)

A parameter for IFrame and Web Resource controls that specifies that a set of context parameters will be passed in a query string to the URL of the control.

Syntax

Xml
<PassParameters>[true|false]</PassParameters>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

For more information see Pass Contextual Information About the Record.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/PassParameters

See Also

Reference

Pass Contextual Information About the Record

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Preload> (FormXml)

A parameter for IFrame or Web Resource controls. For internal use only.

Syntax

Xml
<Preload>[true|false]</Preload>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/Preload

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Privilege> (FormXml)

Specifies a permission that a user must possess in order for the parent navigation item to be displayed in the form.

Syntax

Xml
<Privilege
 Entity="String"
 Privilege=["Read"|"Write"|"Append"|"AppendTo"|"Create"|"Delete"|"Share"|"Assign"|"All"|"AllowQuickCampaign"|"UseInternetMarketing"]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Entity

Specifies the name of the entity to check privileges for.

String

Required

Privilege

The privilege to check.

Valid values include:

  • Read
  • Write
  • Append
  • AppendTo
  • Create
  • Delete
  • Share
  • Assign
  • All
  • AllowQuickCampaign
  • UseInternetMarketing

Multiple values can be used as long as they are separated by a comma and do not contain spaces.

String

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Privileges> (FormXml) | Contains the set of rights that a user needs in order for the navigation item to display in the form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

1 to 100000

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBar/NavBarByRelationshipItem/Privileges/Privilege

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Privileges> (FormXml)

Contains the set of rights that a user needs in order for the navigation item to display in the form.

Syntax

Xml
<Privileges>
 <Privilege />
</Privileges>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Privilege> (FormXml) | Specifies a permission that a user must possess in order for the parent navigation item to be displayed in the form.

Parent Elements

Element | Description
<NavBarByRelationshipItem> (FormXml) | Specifies a navigation item in an entity form that is associated with an entity relationship.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBar/NavBarByRelationshipItem/Privileges

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<PromptAreaCollapsed> (FormXml)

Specifies whether to show the Prompt Area collapsed in the report.

Syntax

Xml
<PromptAreaCollapsed>[true|false]</PromptAreaCollapsed>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/ PromptAreaCollapsed

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<querystringparameter> (FormXml)

Specifies a query string parameter signature that will be allowed for a form.

Syntax

Xml
<querystringparameter
 name="String"
 type =["Boolean"|"DateTime"|"Double"|"EntityType"|"Integer"|"Long"|"PositiveInteger"|"SafeString"|"UniqueId" |"UnsignedInt"]
/>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

name

Valid values must match the following regular expression:.

Copy Code
(?![cC][rR][mM]_)([A-Za-z0-9])+([_])+([A-Za-z0-9_])*

String (FormQueryStringParameterNameAttributeType)

Required

Type

Valid values:

  • Boolean
  • DateTime
  • Double
  • EntityType
  • Integer
  • Long
  • PositiveInteger
  • SafeString
  • UniqueId
  • UnsignedInt

Enumeration (FormParameterAttributeType)

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<formparameters> (FormXml) | Contains definitions of custom parameters that will be accepted by the form.

Element Information

Schema Name

FormQueryStringParameterType

Validation File

FormXml.xsd

Number of Occurrences

1 to 100000

XPath

Copy Code
//FormXml/forms/systemform/form/formparameters/querystringparameter

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RecordsPerPage> (FormXml)

Sets the number of records to display per page. This is a parameter for sub-grid controls.

Syntax

Xml
<RecordsPerPage>Unsigned Short</RecordsPerPage>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Unsigned Short

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/RecordsPerPage

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RelationshipName> (FormXml)

Specifies a relationship to be used by a sub-grid control.

Syntax

Xml
<RelationshipName>String</RelationshipName>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/RelationshipName

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RelationshipRoleOrdinal> (FormXml)

Sets the direction of a Connection Role relationship. This is a parameter for sub-grid controls.

Syntax

Xml
<RelationshipRoleOrdinal>[1|2]</RelationshipRoleOrdinal>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Valid values:

  • 1
  • 2

Element Information

Schema Type

RelationshipRoleOrdinalType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/RelationshipRoleOrdinal

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ReportId> (FormXml)

Specifies the report to display.

Syntax

Xml
<ReportId>String</ReportId>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

The value must match this regular expression: \{[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}\}.

Element Information

Schema Type

FormGuidType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/ReportId

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ResolveEmailAddress> (FormXml)

Specifies whether the lookup control should attempt to resolve an email address for the text displayed in the window.

Syntax

Xml
<ResolveEmailAddress>[true|false]</ResolveEmailAddress>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/ResolveEmailAddress

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RibbonDiffXml> (FormXml)

Specifies custom ribbon actions for a form.

Syntax

Xml
<RibbonDiffXml>
 <CustomActions />
 <Templates />
 <CommandDefinitions />
 <RuleDefinitions />
 <LocLabels />
</RibbonDiffXml>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<CustomActions> (RibbonDiffXml) | Contains a collection of actions that can add, replace, or remove items from the ribbon.
<Templates> (RibbonDiffXml) | Contains a collection of ribbon templates.
<CommandDefinitions> (RibbonDiffXml) | Contains a collection of commands that can be referenced by ribbon controls.
<RuleDefinitions> (RibbonDiffXml) | Contains a collection of rule definitions.
<LocLabels> (RibbonDiffXml) | Contains a collection of LocLabel elements.
<RibbonNotSupported> (RibbonDiffXml) | An element included with the RibbbonDiffXml for an entity to indicate that the entity does not support the ribbon.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Element Information

Schema Type

RibbonEntityDiffXmlType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/RibbonDiffXml

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Role> (FormXml)

Specifies a security role that a user must be associated with to view a form.

Syntax

Xml
<Role Id="String />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Id | Valid values must match this regular expression: \{[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}\} | String (FormGuidType) | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayConditions> (FormXml) | Contains definitions of any security role membership conditions that must be met to display the form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

1 or more

XPath

Copy Code
//FormXml/forms/systemform/form/DisplayConditions/Role

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<row> (FormXml)

Specifies a row used to organize form elements.

Syntax

Xml
<row
 addedby="String"
 height="String" >
 <cell />
</row>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

addedby

Identifies the name of the ISV or customizer that added the element.

String

Optional

height

Controls the height of the row. Valid values are:

  • auto
  • min
  • std
  • An integer representing the number of pixels

String

Optional

Child Elements

Element | Description
<cell> (FormXml) | A form layout element. A cell contains the labels and the control to display.

Parent Elements

Element | Description
<rows> (FormXml) | Specifies rows used to compose form layout.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<rows> (FormXml)

Specifies rows used to compose form layout.

Syntax

Xml
<rows
 addedby="String"
>
 <row />
</rows>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional

Child Elements

Element | Description
<row> (FormXml) | Specifies a row used to organize form elements.

Parent Elements

Element | Description
<section> (FormXml) | Specifies a section within a form.
<header> (FormXml) | Displays read-only information at the top of the form.
<footer> (FormXml) | Displays read-only information at the bottom of a form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Scrolling> (FormXml)

Specifies the scrolling behavior of the IFrame. This is a parameter for IFrame, Web resource, and report controls.

Syntax

Xml
<Scrolling>["auto" | "no" | "yes"]</Scrolling>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Valid values for this element correspond to the formatting options for the Scrolling property.

  • As Necessary : auto
  • Always : yes
  • Never : no

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/Scrolling

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<section> (FormXml)

Specifies a section within a form.

Syntax

Xml
<section
 addedby="String"
 celllabelalignment=["Center"|"Left"|"Right"]
 celllabelposition=["Top"|"Left"]
 columns="Non Negative Integer"
 group="String"
 height="String"
 id="String"
 IsUserDefined="String"
 labelid="String"
 labelwidth="Non Negative Integer"
 layout="String"
 locklevel="Non Negative Integer"
 name="String"
 showbar=["0" | "1" | "true" | "false"]
 showlabel=["0" | "1" | "true" | "false"]
 visible=["0" | "1" | "true" | "false"]>
 <labels />
 <rows />
</section>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

addedby

Identifies the name of the ISV or customizer that added the element.

String

Optional

celllabelalignment

Specifies label alignment.

Valid Values:

  • Center
  • Left
  • Right

Enumeration

Optional

celllabelposition

Specifies label position.

Valid Values:

  • Top
  • Left

Enumeration

Optional

columns

For internal use only.

Non Negative Integer

Optional

group

For internal use only.

String

Optional

height

Contols the height of the section. Set the value to "auto" to make the section expand to fill all the available space.

String

Optional

id

Unique ID for the section. See Remarks.

String (FormGuidType)

Required

IsUserDefined

"1" indicates a custom section.

"0" indicates a default section.

String

Optional

labelid

A unique id value for the section label.

See Remarks.

String (FormGuidType)

Optional

labelwidth

Defines the horizontal space for a section label in pixels. The default is 110 pixels.

Non Negative Integer

Optional

layout

Defines the section layout property, either variable field width (varwidth) or fixed field width (varheight). The default is varwidth.

String

Optional

locklevel

Prevents the section from being deleted from the form or having its properties modified. This attribute cannot be set in the UI. Valid values:

  • 0 = Do not lock
  • 1= Locked

Non Negative Integer

Optional

name

The name of the section displayed in the section properties.

String

Optional

showbar

Indicates whether to show divider line below the section name. The divider line will only display when the showlabel attribute value is also true.

Boolean

Optional

showlabel

Show the name of this section on the form.

Boolean

Optional

visible

Specifies whether the section is displayed by default.

Boolean

Optional

Child Elements

Element | Description
<labels> (FormXml) | Contains form label definitions.
<rows> (FormXml) | Specifies rows used to compose form layout.

Parent Elements

Element | Description
<sections> (FormXml) | Contains the definitions of sections used in the form layout.

Remarks

If you create a new <tab> (FormXml), <section> (FormXml) or <cell> (FormXml) element by copying from an existing form definition or by manually editing an exported customization.xml file you should create a new GUID value for the id attribute. You should use a tool like guidgen.exe to guarantee a unique valid GUID value. The guidgen.exe is included as part of the Windows SDK.

If you do not specify a new GUID value for the element id, you must create a new GUID value for the labelid attribute and add the labelid attribute. If you have duplicate element id values AND do not specify a unique labelid attribute value you will not be able to uninstall your solution. To address this issue you must export the default solution containing the form definitions, edit each element in the existing forms to add a unique labelid value, and then import those modified form definitions.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/Sections/section

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<sections> (FormXml)

Contains the definitions of sections used in the form layout.

Syntax

Xml
<sections
 addedby="String"
>
 <section />
<sections>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional

Child Elements

Element | Description
<section> (FormXml) | Specifies a section within a form.

Parent Elements

Element | Description
<column> (FormXml) | Specifies a column within a tab element.

Element Information

Schema Name

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Security> (FormXml)

Indicates whether cross-site scripting restrictions are applied. This is a parameter for IFrame controls.

Syntax

Xml
<Security>[true|false]</Security>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Contains a string with the value ‘true’ or ‘false’.

Example

The following shows an example of

Xml Copy Code
<Security>true</Security>

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/Security

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ShowInROF> (FormXml)

(Deprecated) Indicated whether this web resource would be displayed in a read-optimized form.

Syntax

Xml
<ShowInROF>[0|1]</ShowInROF>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Read-optimized forms were removed in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Element Information

Schema Type

BooleanType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/section/rows/row/cell/control/parameters/ShowInROF

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ShowLinkControlLabel> (FormXml)

For internal use only.

Syntax

Xml
<ShowLinkControlLabel>[true|false]</ShowLinkControlLabel>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

1 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/ShowLinkControlLabel

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ShowOnMobileClient> (FormXml)

Indicates whether the Iframe or web resource control is displayed for entity forms and dashboards in Microsoft Dynamics CRM for tablets.

Syntax

<ShowOnMobileClient>[0|1]</ShowOnMobileClient>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

This parameter supports the preview feature to enable the display of IFrame and web resources in entity forms and dashboards in Microsoft Dynamics CRM for tablets. More information: Create web resources and IFRAME content for use with the CRM for tablets client

Element Information

Schema Type

BooleanType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/section/rows/row/cell/control/parameters/ShowOnMobileClient

See Also

Concepts

Create web resources and IFRAME content for use with the CRM for tablets client
Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SizeType> (FormXml)

Specifies how the web resource should be sized to fit in the form.

Syntax

Xml
<SizeType>String</SizeType>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Valid Values:

  • StretchToFit
  • StretchMaintainAspectRatio
  • Original
  • Specific

Element Information

Schema Type

WebResourceSizeType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/SizeType

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SnapshotId> (FormXml)

A parameter for report controls.

Syntax

Xml
<ReportId>String</ReportId>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

The value must match the following regular expression: \{[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}\}.

Element Information

Schema Type

FormGuidType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/SnapshotId

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SuccessConditionName> (FormXml)

Specifies the field used by the SLA timer control to check for success condition.

Syntax

Xml
<SuccessConditionName>String</SuccessConditionName>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/SuccessConditionName

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SuccessConditionValue> (FormXml)

Specifies the value used by the SLA timer control when determining success.

Syntax

Xml
<SuccessConditionValue>String</SuccessConditionValue>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/SuccessConditionValue

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<systemform> (FormXml)

Contains the definition of a form and supporting data.

Syntax

Xml
<systemform>
 <CanBeDeleted />
 <Descriptions />
 <form />
 <formid />
 <IsCustomizable />
 <LocalizedNames /> <FormPresentation />
 <FormActivationState /> <IntroducedVersion />
</systemform>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<CanBeDeleted> (FormXml) | Specifies whether the form can be deleted.
<Descriptions> (FormXml) | Contains a set of localized descriptions of the form.
<form> (FormXml) | Contains the definition of a form.
<formid> (FormXml) | Contains the unique ID value for a form.
<FormPresentation> (FormXml) | Specifies whether this form uses in the updated UI layout or the classic form from earlier versions.
<FormActivationState> (FormXml) | Specifies the state of the form.
<IntroducedVersion> (FormXml) | A version number that represents the version of the solution that the solution component was added in.
<IsCustomizable> (FormXml) | Indicates whether the form is customizable.
<LocalizedNames> (FormXml) | Contains names of the form for different languages.

Parent Elements

Element | Description
<forms> (FormXml) | Contains all the system form definitions for a specific type of form.

Element Information

Schema Name

systemform

Validation File

customizationSolution.xsd

Number of Occurrences

1 or more

XPath

Copy Code
//FormXml/forms/systemform

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<tab> (FormXml)

Specifies a tab element in the organization of a form.

Syntax

Xml
<tab
 addedby="String"
 expanded =["0" | "1" | "true" | "false"]
 group="String"
 id="String"
 IsUserDefined="String"
 labelid="String"
 locklevel="Non Negative Integer"
 name="String"
 showlabel =["0" | "1" | "true" | "false"]
 verticallayout =["0" | "1" | "true" | "false"]
 visible= =["0" | "1" | "true" | "false"]>
 <columns />
 <events />
 <labels />
</tab>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional
expanded | Specifies whether the tab should be expanded by default. | Boolean | Optional
group | Not used. | String | Optional
id | Unique ID for the tab. See Remarks. | String (FormGuidType) | Required
IsUserDefined | "1" indicates a custom tab. "0" indicates a default tab. | String | Optional
labelid | A unique id value for the tab label. | String (FormGuidType) | Optional Sometimes Required. See Remarks.
locklevel | Prevents the tab from being deleted from the form or having its properties modified. 0 = Do not lock 1= Locked | Non Negative Integer | Optional
name | The name of the tab. | String | Optional
showlabel | Deprecated | Boolean | Optional
verticallayout | Not used. | Boolean | Optional
visible | Specifies whether the tab is visible by default. | Boolean | Optional

Child Elements

Element | Description
<labels> (FormXml) | Contains form label definitions.
<columns> (FormXml) | Contains the columns within a tab.
<events> (FormXml) | Contains all the event definitions for a cell or form.

Parent Elements

Element | Description
<tabs> (FormXml) | Contains the tab definitions for a form.

Remarks

If you create a new <tab> (FormXml), <section> (FormXml) or <cell> (FormXml) element by copying from an existing form definition or by manually editing an exported customization.xml file you should create a new GUID value for the id attribute. You should use a tool like guidgen.exe to guarantee a unique valid GUID value. The guidgen.exe is included as part of the Windows SDK.

If you do not specify a new GUID value for the element id, you must create a new GUID value for the labelid attribute and add the labelid attribute. If you have duplicate element id values AND do not specify a unique labelid attribute value you will not be able to uninstall your solution. To address this issue you must export the default solution containing the form definitions, edit each element in the existing forms to add a unique labelid value, and then import those modified form definitions.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

1 to 100

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<tabs> (FormXml)

Contains the tab definitions for a form.

Syntax

Xml
<tabs
 addedby="String"
 showlabels="true"
 >
 <tab />
</tabs>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional
showlabels | Specifies whether the tabs are displayed. | Boolean | Optional

Child Elements

Element | Description
<tab> (FormXml) | Specifies a tab element in the organization of a form.

Parent Elements

Element | Description
<form> (FormXml) | Contains the definition of a form.

Remarks

If the showlabels attribute is set to false, the tabs on a form will be hidden. You should set this to false only when there is one tab on the form. Otherwise, users will not be able to navigate to other tabs.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<TargetEntityType> (FormXml)

Specifies the entity records to be displayed in the sub-grid.

Syntax

Xml
<TargetEntityType>String</TargetEntityType>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Set the value to the logical name for the entity

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/TargetEntityType

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<TeamTemplateId> (FormXml)

For internal use only.

Syntax

Xml
<TeamTemplateId>String</TeamTemplateId>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

The value must match this regular expression: \{[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}\}.

Element Information

Schema Type

FormGuidType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/TeamTemplateId

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Title> (FormXml)

Specifies the text for a title for a specific language.

Syntax

Xml
<Title
 LCID="1033"
 Text="Common" />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
LCID | A four or five digit locale ID. | Integer | Optional
Text | The localized text to display. | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Titles> (FormXml) | Contains definitions of Title elements.

Remarks

Valid locale ID values can be found at Locale ID (LCID) Chart.

Element Information

Schema Type

FormLocalizedLabel

Validation File

FormXml.xsd

Number of Occurrences

1 or more

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBar/NavBarItem/Titles/Title |
//FormXml/forms/systemform/form/Navigation/NavBar/NavBarByRelationshipItem/ToolTip/Titles/Title |
//FormXml/forms/systemform/form/Navigation/NavBarAreas/NavBarArea/Titles/Title

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Titles> (FormXml)

Contains definitions of Title elements.

Syntax

Xml
<Titles>
 <Title />
</Titles>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Title> (FormXml) | Specifies the text for a title for a specific language.

Parent Elements

Element | Description
<NavBarArea> (FormXml) | Contains the titles that replace the navigation group labels in the entity form.
<ToolTip> (FormXml) | Specifies the text to display for a tooltip in a navigation item for a form.
<NavBarItem> (FormXml) | Specifies a navigation item to display in a form. Use this element when the navigation item is not associated with an entity relationship.

Element Information

Schema Name

FormLocalizedTitles

Validation File

FormXml.xsd

Number of Occurrences

1 or more

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBar/NavBarItem/Titles |
//FormXml/forms/systemform/form/Navigation/NavBar/NavBarByRelationshipItem/ToolTip/Titles |
//FormXml/forms/systemform/form/Navigation/NavBarAreas/NavBarArea/Titles

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ToolTip> (FormXml)

Specifies the text to display for a tooltip in a navigation item for a form.

Syntax

Xml
<ToolTip>
 <Titles />
</ToolTip>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Titles> (FormXml) | Contains definitions of Title elements.

Parent Elements

Element | Description
<NavBarByRelationshipItem> (FormXml) | Specifies a navigation item in an entity form that is associated with an entity relationship.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/Navigation/NavBar/NavBarByRelationshipItem/ToolTip

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<UnboundLookupControlType> (FormXml)

For internal use only.

Syntax

Xml
<UnboundLookupControlType>String</UnboundLookupControlType>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/UnboundLookupControlType

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<UnboundLookupBrowse> (FormXml)

For internal use only.

Syntax

Xml
<UnboundLookupBrowse>[true|false]</UnboundLookupBrowse>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/UnboundLookupBrowse

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<UnboundLookupStyle> (FormXml)

For internal use only.

Syntax

Xml
<UnboundLookupStyle>String</UnboundLookupStyle>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/UnboundLookupStyle

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<UnboundLookupTypes> (FormXml)

For internal use only.

Syntax

Xml
<UnboundLookupTypes>String</UnboundLookupTypes>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/UnboundLookupTypes

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Url> (FormXml)

A parameter for IFrame and Web resource controls that specifies the location of the page or HTML Web resource to open.

Syntax

Xml
<Url>String</Url>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/Url

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<VerticalAlignment> (FormXml)

Specifies the horizontal alignment of image Web resources.

Syntax

Xml
<VerticalAlignment>[Top|Middle|Bottom|NotSet]</VerticalAlignment>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

Valid values:

  • Top
  • Middle
  • Bottom
  • NotSet

Element Information

Schema Type

ImageVerticalAlignmentType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/VerticalAlignment

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ViewId> (FormXml)

Specifies the view to be used as the data source for the sub-grid.

Syntax

Xml
<ViewId>String</ViewId>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

The value must match the following regular expression: \{[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}\}.

Element Information

Schema Type

FormGuidType

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/ViewId

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ViewIds> (FormXml)

Specifies the views to be available for selection in the sub-grid.

Syntax

Xml
<ViewIds>String</ViewIds>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Remarks

The value is a comma-separated list of view ids.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/ViewIds

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ViewPickerReadOnly> (FormXml)

Specifies if enabling or disabling the view picker is allowed by the form editor.

Syntax

Xml
<ViewPickerReadOnly>[true|false]</ViewPickerReadOnly>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Boolean

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/ViewPickerReadOnly

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<VisualizationId> (FormXml)

Sets the default chart when chart selection is not enabled.

Syntax

Xml
<VisualizationId>String</VisualizationId>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/VisualizationId

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<WarningConditionName> (FormXml)

Specifies the field used by the SLA timer control to check for warning condition.

Syntax

Xml
<WarningConditionName>String</WarningConditionName>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/WarningConditionName

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<WarningConditionValue> (FormXml)

Specifies the value used by the SLA timer control when determining warning.

Syntax

Xml
<WarningConditionValue>String</WarningConditionValue>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

String

Validation File

FormXml.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/WarningConditionValue

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<webresource> (FormXml)

Specifies a Web resource to be available to the form.

Syntax

Xml
<webresource path="String" type=[jscript|css] />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

path

The reference to the Web Resource.

Use

Copy Code
$webresource:+<web resource name>

String

Required

type

Valid values are:

  • jscript
  • css

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<clientincludes> (FormXml) | Contains references to Web resources or internal files to include with the form.

Element Information

Schema Type

complexType

Validation File

FormXml.xsd

Number of Occurrences

0 to 100000

XPath

Copy Code
//FormXml/forms/systemform/form/clientresources/isvresources/clientincludes/webresource

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Width> (FormXml)

A parameter for web resource controls. When a web resource for an image uses the Specific parameter, this parameter provides the width value.

Syntax

Xml
<Width>Integer</Width>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<parameters> (FormXml) | Contains the parameters to be passed to a control in a form.

Element Information

Schema Type

Unsigned Integer

Validation File

FormXml.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//FormXml/forms/systemform/form/tabs/tab/columns/column/sections/section/rows/row/cell/control/parameters/Width

See Also

Concepts

Customize entity forms

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Form XML schema

The following is the schema definition for form customizations for Microsoft Dynamics CRM. For more information, see Customize entity forms. You can find this schema in the SDK\Schemas\FormXML.xsd file in the SDK package. Download the Microsoft Dynamics CRM SDK package.

Schema

Xml Copy Code
<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
           elementFormDefault="qualified"
           attributeFormDefault="unqualified">
 <xs:include schemaLocation="RibbonCore.xsd" />
 <xs:element name="form"
             type="FormType" />
 <xs:complexType name="ClientFileIncludeAttributeType">
  <xs:attribute name="src"
                use="required">
   <xs:simpleType>
    <xs:restriction base ="xs:string">
     <xs:pattern value ="(\$webresource:|/)(.)+"/>
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>

 </xs:complexType>
 <xs:complexType name="ClientResourcesType">
  <xs:all>
   <xs:element name="internalresources"
               minOccurs ="0"
               maxOccurs ="1">
    <xs:complexType>
     <xs:all>
      <xs:element name ="clientincludes"
                  minOccurs ="0"
                  maxOccurs ="1">
       <xs:complexType >
        <xs:choice minOccurs="0"
                   maxOccurs ="100000" >
         <xs:element name ="internaljscriptfile"
                     type="ClientFileIncludeAttributeType"
                     minOccurs ="0"
                     maxOccurs ="1" />
         <xs:element name ="internalcssfile"
                     type="ClientFileIncludeAttributeType"
                     minOccurs ="0"
                     maxOccurs ="1" />
        </xs:choice>

       </xs:complexType >
      </xs:element>
      <xs:element name ="clientvariables"
                  minOccurs="0"
                  maxOccurs ="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name ="internaljscriptvariable"
                     minOccurs ="0"
                     maxOccurs ="100000">
          <xs:complexType>
           <xs:attribute name="name"
                         use ="required">
            <xs:simpleType>
             <xs:restriction base ="xs:string">
              <xs:pattern value="LOCID_([A-Za-z0-9_])+"/>
              <xs:maxLength value ="32"/>
             </xs:restriction>
            </xs:simpleType>
           </xs:attribute>
           <xs:attribute name ="resourceid"
                         use="required" >
            <xs:simpleType>
             <xs:restriction base ="xs:string">
              <xs:pattern value="([A-Za-z0-9_.])+"/>
             </xs:restriction>
            </xs:simpleType>
           </xs:attribute>

          </xs:complexType>
         </xs:element>
        </xs:sequence>

       </xs:complexType>
      </xs:element>
     </xs:all>

    </xs:complexType>
   </xs:element>
   <xs:element name="isvresources"
               minOccurs ="0"
               maxOccurs ="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name ="clientincludes"
                  minOccurs ="0"
                  maxOccurs ="1">
       <xs:complexType >
        <xs:sequence>
         <xs:element name ="webresource"
                     minOccurs ="0"
                     maxOccurs ="100000">
          <xs:complexType>
           <xs:attribute name="path"
                         type="xs:string"
                         use ="required"/>
           <xs:attribute name="type"
                         use ="required">
            <xs:simpleType>
             <xs:restriction base="xs:string">
              <xs:enumeration value="jscript"/>
              <xs:enumeration value ="css" />
             </xs:restriction>
            </xs:simpleType>
           </xs:attribute>

          </xs:complexType>
         </xs:element>
        </xs:sequence>

       </xs:complexType>
      </xs:element>
     </xs:sequence>

    </xs:complexType>
   </xs:element>
  </xs:all>

 </xs:complexType>
 <xs:complexType name="FormDisplayConditionsType">
  <xs:choice minOccurs="0"
             maxOccurs="1">
   <xs:element name="Everyone"
               minOccurs="1"
               maxOccurs="1">
    <xs:complexType>

    </xs:complexType>
   </xs:element>
   <xs:element name="Role"
               minOccurs="1"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:attribute name="Id"
                   type="FormGuidType"
                   use="required" />

    </xs:complexType>
   </xs:element>
  </xs:choice>
  <xs:attribute name="FallbackForm"
                type="xs:boolean"
                use="optional" />
  <xs:attribute name="Order"
                type="xs:integer"
                use="optional" />

 </xs:complexType>
 <xs:complexType name="FormLocalizedLabel">
  <xs:attribute name="LCID"
                type="xs:integer" />
  <xs:attribute name="Text"
                type="xs:string" />

 </xs:complexType>
 <xs:complexType name="FormLocalizedTitles">
  <xs:sequence minOccurs="1"
               maxOccurs="unbounded">
   <xs:element name="Title"
               type="FormLocalizedLabel" />
  </xs:sequence>

 </xs:complexType>
 <xs:complexType name="FormNavBarAreasType">
  <xs:sequence>
   <xs:element name="NavBarArea"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="Titles"
                  minOccurs="1"
                  maxOccurs="1"
                  type="FormLocalizedTitles" />
     </xs:sequence>
     <xs:attribute name="Id"
                   type="xs:string"
                   use="required" />

    </xs:complexType>
   </xs:element>
  </xs:sequence>

 </xs:complexType>
 <xs:complexType name="FormNavBarType">
  <xs:choice minOccurs="0"
             maxOccurs="100000">
   <xs:element minOccurs="0"
               maxOccurs="1"
               name="NavBarItem">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="Titles"
                  minOccurs="1"
                  maxOccurs="1"
                  type="FormLocalizedTitles" />
     </xs:sequence>
     <xs:attribute name="Icon"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Url"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Id"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="PassParams"
                   type="FormCRM_Boolean"
                   use="optional" />
     <xs:attribute name="Sequence"
                   type="xs:nonNegativeInteger"
                   use="optional" />
     <xs:attribute name="Area"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="Client"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="AvailableOffline"
                   type="xs:boolean"
                   use="optional" />

    </xs:complexType>
   </xs:element>
   <xs:element name="NavBarByRelationshipItem"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:all>
      <xs:element name="Titles"
                  minOccurs="0"
                  maxOccurs="1"
                  type="FormLocalizedTitles" />
      <xs:element name="ToolTip"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="Titles"
                     minOccurs="1"
                     maxOccurs="1"
                     type="FormLocalizedTitles" />
        </xs:sequence>

       </xs:complexType>
      </xs:element>
      <xs:element name="Privileges"
                  minOccurs="0"
                  maxOccurs ="1">
       <xs:complexType>
        <xs:sequence >
         <xs:element name ="Privilege"
                     minOccurs ="1"
                     maxOccurs ="100000">
          <xs:complexType>
           <xs:attribute name ="Entity"
                         type ="xs:string"
                         use ="required"/>
           <xs:attribute name="Privilege"
                         type ="xs:string"
                         use ="required"/>

          </xs:complexType>
         </xs:element>
        </xs:sequence>

       </xs:complexType>
      </xs:element>
     </xs:all>
     <xs:attribute name="RelationshipName"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Id"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Area"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="TitleResourceId"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="Client"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="AvailableOffline"
                   type="xs:boolean"
                   use="optional" />
     <xs:attribute name="Icon"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="Sequence"
                   type="xs:nonNegativeInteger"
                   use="optional" />
     <xs:attribute name="Show"
                   type="xs:boolean"
                   use="optional" />
     <xs:attribute name="ViewId"
                   type="FormISVGuid"
                   use="optional" />

    </xs:complexType>
   </xs:element>
  </xs:choice>
  <xs:attribute name="ValidForCreate"
                type="FormCRM_Boolean"
                use="optional" />
  <xs:attribute name="ValidForUpdate"
                type="FormCRM_Boolean"
                use="optional" />

 </xs:complexType>
 <xs:complexType name="FormNavigationType">
  <xs:all>
   <xs:element name="NavBarAreas"
               type="FormNavBarAreasType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="NavBar"
               type="FormNavBarType"
               minOccurs="0"
               maxOccurs="1" />
  </xs:all>

 </xs:complexType>
 <xs:complexType name ="FormParametersType">
  <xs:choice minOccurs="1"
             maxOccurs ="100000">
   <xs:element name ="querystringparameter"
               type="FormQueryStringParameterType"
               minOccurs ="0"
               maxOccurs ="1" />
  </xs:choice>

 </xs:complexType>
 <xs:complexType name="FormQueryStringParameterType">
  <xs:attribute name="name"
                type="FormQueryStringParameterNameAttributeType"
                use="required" />
  <xs:attribute name="type"
                type="FormParameterAttributeType"
                use="required" />

 </xs:complexType>
 <xs:complexType name="FormType">
  <xs:all>
   <xs:element name="ancestor"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:attribute  name="id"
                    type="FormGuidType"
                    use="required" />
    </xs:complexType>
   </xs:element>
   <xs:element name="hiddencontrols"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="data"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:attribute name="id"
                      type="xs:string" />
        <xs:attribute name="datafieldname"
                      type="xs:string" />
        <xs:attribute name="classid"
                      type="FormGuidType" />

       </xs:complexType>
      </xs:element>
     </xs:sequence>

    </xs:complexType>
   </xs:element>
   <xs:element name="tabs"
               minOccurs="1"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="tab"
                  minOccurs="1"
                  maxOccurs="100">
       <xs:complexType>
        <xs:all>
         <xs:element name="labels"
                     type="FormXmlLabelsType"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="columns"
                     minOccurs="1"
                     maxOccurs="1">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="column"
                        minOccurs="1"
                        maxOccurs="3">
             <xs:complexType>
              <xs:sequence>
               <xs:element name="sections"
                           minOccurs="0"
                           maxOccurs="1">
                <xs:complexType>
                 <xs:sequence>
                  <xs:element name="section"
                              minOccurs="0"
                              maxOccurs="unbounded">
                   <xs:complexType>
                    <xs:all>
                     <xs:element name="labels"
                                 type="FormXmlLabelsType"
                                 minOccurs="0"
                                 maxOccurs="1" />
                     <xs:element name="rows"
                                 minOccurs="0"
                                 maxOccurs="1">
                      <xs:complexType>
                       <xs:sequence>
                        <xs:element name="row"
                                    minOccurs="0"
                                    maxOccurs="unbounded">
                         <xs:complexType>
                          <xs:sequence>
                           <xs:element name="cell"
                                       minOccurs="0"
                                       maxOccurs="unbounded">
                            <xs:complexType>
                             <xs:all>
                              <xs:element name="labels"
                                          type="FormXmlLabelsType"
                                          minOccurs="0"
                                          maxOccurs="1" />
                              <xs:element name="control"
                                          type="FormXmlControlType"
                                          minOccurs="0"
                                          maxOccurs="1" />
                              <xs:element name="events"
                                          type="FormXmlEventsType"
                                          minOccurs="0"
                                          maxOccurs="1" />
                             </xs:all>
                             <xs:attribute name="auto"
                                           type="xs:boolean" />
                             <xs:attribute name="addedby"
                                           type="xs:string" />
                             <xs:attributeGroup ref="FormXmlCellCommon"/>
                            </xs:complexType>
                           </xs:element>
                          </xs:sequence>
                          <xs:attribute name="addedby"
                                        type="xs:string" />
                          <xs:attributeGroup ref="FormXmlRowCommon"/>
                         </xs:complexType>
                        </xs:element>
                       </xs:sequence>
                       <xs:attribute name="addedby"
                                     type="xs:string" />

                      </xs:complexType>
                     </xs:element>
                    </xs:all>
                    <xs:attribute name="group"
                                  type="xs:string" />
                    <xs:attribute name="name"
                                  type="xs:string" />
                    <xs:attribute name="showlabel"
                                  type="xs:boolean" />
                    <xs:attribute name="labelid"
                                  type="FormGuidType"
                                  use="optional" />
                    <xs:attribute name="showbar"
                                  type="xs:boolean" />
                    <xs:attribute name="id"
                                  type="FormGuidType" />
                    <xs:attribute name="IsUserDefined"
                                  type="xs:string" />
                    <xs:attribute name="height"
                                  type="xs:string" />
                    <xs:attribute name="locklevel"
                                  type="xs:nonNegativeInteger" />
                    <xs:attribute name="layout"
                                  type="xs:string" />
                    <xs:attribute name="addedby"
                                  type="xs:string" />
                    <xs:attribute name="visible"
                                  type="xs:boolean" />
                    <xs:attributeGroup ref="FormXmlSectionCommon"/>

                   </xs:complexType>
                  </xs:element>
                 </xs:sequence>
                 <xs:attribute name="addedby"
                               type="xs:string" />

                </xs:complexType>
               </xs:element>
              </xs:sequence>
              <xs:attribute name="width"
                            type="FormPercentageType"
                            use="required" />

             </xs:complexType>
            </xs:element>
           </xs:sequence>

          </xs:complexType>
         </xs:element>
         <xs:element name="events"
                     type="FormXmlEventsType"
                     minOccurs="0"
                     maxOccurs="1" />
        </xs:all>
        <xs:attribute name="group"
                      type="xs:string" />
        <xs:attribute name="name"
                      type="xs:string" />
        <xs:attribute name="verticallayout"
                      type="xs:boolean" />
        <xs:attribute name="showlabel"
                      type="xs:boolean" />
        <xs:attribute name="labelid"
                      type="FormGuidType"
                      use="optional" />
        <xs:attribute name="id"
                      type="FormGuidType" />
        <xs:attribute name="IsUserDefined"
                      type="xs:string" />
        <xs:attribute name="locklevel"
                      type="xs:nonNegativeInteger" />
        <xs:attribute name="addedby"
                      type="xs:string" />
        <xs:attribute name="expanded"
                      type="xs:boolean" />
        <xs:attribute name="visible"
                      type="xs:boolean" />

       </xs:complexType>
      </xs:element>
     </xs:sequence>
     <xs:attribute name="showlabels"
                   type="xs:boolean" />
     <xs:attribute name="addedby"
                   type="xs:string" />

    </xs:complexType>
   </xs:element>
   <xs:element name="header"
               type="FormXmlHeaderFooterType"
               minOccurs="0"
               maxOccurs="1"/>
   <xs:element name="footer"
               type="FormXmlHeaderFooterType"
               minOccurs="0"
               maxOccurs="1"/>
   <xs:element name="events"
               type="FormXmlEventsType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="formLibraries"
               type="FormXmlLibraryType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="externaldependencies"
               type="FormXmlExternalDependenciesType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="formparameters"
               type="FormParametersType"
               minOccurs="0"
               maxOccurs="1">
    <xs:unique name="UniqueName">
     <xs:selector xpath ="./querystringparameter"/>
     <xs:field xpath ="@name"/>
    </xs:unique>
   </xs:element>
   <xs:element name ="clientresources"
               type ="ClientResourcesType"
               minOccurs ="0"
               maxOccurs ="1"></xs:element>
   <xs:element name="Navigation"
               type="FormNavigationType"
               minOccurs="0"
               maxOccurs="1"/>
   <xs:element name="DisplayConditions"
               type="FormDisplayConditionsType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="RibbonDiffXml"
               type="RibbonEntityDiffXmlType"
               minOccurs="0"
               maxOccurs="1" />
  </xs:all>
  <xs:attribute name="enablerelatedinformation"
                type="xs:boolean" />
  <xs:attribute name="relatedInformationCollapsed"
                type="xs:boolean" />
  <xs:attribute name="hasmargin"
                type="xs:boolean" />
  <xs:attribute name="addedby"
                type="xs:string" />
  <xs:attribute name="shownavigationbar"
                type="xs:boolean" />
  <xs:attribute name="showImage"
                type="xs:boolean" />
  <xs:attribute name="maxWidth"
                use="optional">
   <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
     <xs:minInclusive value="400" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>

 </xs:complexType>
 <xs:complexType name="FormXmlControlType">
  <xs:sequence>
   <xs:element name="parameters"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:choice minOccurs="1"
                maxOccurs="1">
      <!-- LATER: (TobinZ, 2008-07-24) - Divide this list up into sets that are valid together. -->
      <xs:choice minOccurs="1"
                 maxOccurs="unbounded">
       <xs:element name="Url"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="PassParameters"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="Security"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="Scrolling"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="Border"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="Preload"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="IsPassword"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <!--Web Resource related parameters. Included in this section since they
                can include Url, PassParameters etc-->
       <xs:element name="Height"
                   type="xs:unsignedInt"
                   minOccurs="0"
                   maxOccurs="1"/>
       <xs:element name="Width"
                   type="xs:unsignedInt"
                   minOccurs="0"
                   maxOccurs="1"/>
       <xs:element name="AltText"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1"/>
       <xs:element name="SizeType"
                   type="WebResourceSizeType"
                   minOccurs="0"
                   maxOccurs="1"/>
       <xs:element name="ShowInROF"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="ShowOnMobileClient"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="HorizontalAlignment"
                   type="ImageHorizontalAlignmentType"
                   minOccurs="0"
                   maxOccurs="1"/>
       <xs:element name="VerticalAlignment"
                   type="ImageVerticalAlignmentType"
                   minOccurs="0"
                   maxOccurs="1"/>
       <xs:element name="Data"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="WebResourceId"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
      </xs:choice>
      <!-- Parameters for the subgrid control -->
      <xs:choice minOccurs="1"
                 maxOccurs="unbounded">
       <xs:element name="ViewId"
                   type="FormGuidType"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="IsUserView"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="IsUserChart"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="RelationshipName"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="RelationshipRoleOrdinal"
                   type="RelationshipRoleOrdinalType"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="TargetEntityType"
                   type="xs:string"
                   minOccurs="1"
                   maxOccurs="1" />
       <xs:element name="AutoExpand"
                   type="GridResizeType"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="RecordsPerPage"
                   type="xs:unsignedShort"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="MaxRowsBeforeScroll"
                   type="xs:integer"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="EnableQuickFind"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="EnableJumpBar"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="EnableViewPicker"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="ViewIds"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="ChartGridMode"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="VisualizationId"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="EnableChartPicker"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="EnableContextualActions"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="TeamTemplateId"
                   type="FormGuidType"
                   minOccurs="0"
                   maxOccurs="1" />
      </xs:choice>
      <!-- Parameters for the lookup control -->
      <xs:choice minOccurs="1"
                 maxOccurs="unbounded">
       <xs:element name="DefaultViewId"
                   type="FormGuidType"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="FilterRelationshipName"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="DependentAttributeName"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="DependentAttributeType"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="AutoResolve"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="ResolveEmailAddress"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="DefaultViewReadOnly"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="ViewPickerReadOnly"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="AllowFilterOff"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="DisableMru"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="DisableQuickFind"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="DisableViewPicker"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="AvailableViewIds"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="EntityLogicalName"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="IsInlineNewEnabled"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="InlineViewIds"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="UnboundLookupTypes"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="UnboundLookupBrowse"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="UnboundLookupStyle"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="UnboundLookupControlType"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="ShowAsBreadcrumbControl"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
      </xs:choice>
      <!-- Parameters for the quickformcollection control -->
      <xs:choice minOccurs="1"
                 maxOccurs="unbounded">
       <xs:element name="QuickForms"
                   type="xs:string"
                   minOccurs="1"
                   maxOccurs="1" />
       <xs:element name="ControlMode"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
      </xs:choice>
      <!-- Parameters for the tabs control -->
      <xs:choice minOccurs="1"
                 maxOccurs="unbounded">
       <xs:element name="DefaultTabId"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
      </xs:choice>
      <!-- Link Control parameters -->
      <xs:choice minOccurs="1"
                 maxOccurs="unbounded">
       <xs:element name="LinkControlDefinitionId"
                   type="FormGuidType"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="ShowLinkControlLabel"
                   type="xs:boolean"
                   minOccurs="0"
                   maxOccurs="1" />
      </xs:choice>
      <!-- Bing Maps Control parameters -->
      <xs:choice minOccurs="1"
                 maxOccurs="unbounded">
       <xs:element name="AddressField"
                   type="xs:string"
                   minOccurs="1"
                   maxOccurs="1" />
      </xs:choice>
      <!-- Timer Control parameters -->
      <xs:choice minOccurs="1"
                 maxOccurs="unbounded">
       <xs:element name="FailureTimeField"
                   type="xs:string"
                   minOccurs="1"
                   maxOccurs="1" />
       <xs:element name="SuccessConditionName"
                   type="xs:string"
                   minOccurs="1"
                   maxOccurs="1" />
       <xs:element name="SuccessConditionValue"
                   type="xs:string"
                   minOccurs="1"
                   maxOccurs="1" />
       <xs:element name="FailureConditionName"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="FailureConditionValue"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="WarningConditionName"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="WarningConditionValue"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="CancelConditionName"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="CancelConditionValue"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="PauseConditionName"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="PauseConditionValue"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1" />
      </xs:choice>
     </xs:choice>

    </xs:complexType>
   </xs:element>
  </xs:sequence>
  <xs:attribute name="id"
                type="xs:string" />
  <xs:attribute name="classid"
                type="FormGuidType" />
  <xs:attribute name="datafieldname"
                type="xs:string" />
  <xs:attribute name="disabled"
                type="xs:boolean" />
  <xs:attribute name="addedby"
                type="xs:string" />
  <xs:attribute name="isunbound"
                type="xs:boolean" />

 </xs:complexType>
 <xs:complexType name="FormXmlLibraryType">
  <xs:sequence>
   <xs:element name="Library"
               minOccurs="1"
               maxOccurs="50">
    <xs:complexType>
     <xs:attribute name="name"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="libraryUniqueId"
                   type="xs:string"
                   use="required" />

    </xs:complexType>
   </xs:element>
  </xs:sequence>

 </xs:complexType>
 <xs:simpleType name="CrmEventType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="DataEvent" />
   <xs:enumeration value="ControlEvent" />
  </xs:restriction>
 </xs:simpleType>
 <xs:complexType name="FormXmlHandlerType">
  <xs:sequence>
   <xs:element name="dependencies"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="dependency"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:attribute name="id"
                      type="xs:string" />

       </xs:complexType>
      </xs:element>
     </xs:sequence>

    </xs:complexType>
   </xs:element>
  </xs:sequence>
  <xs:attribute name="functionName"
                type="xs:string"
                use="required" />
  <xs:attribute name="libraryName"
                type="xs:string"
                use="required" />
  <xs:attribute name="handlerUniqueId"
                type="xs:string"
                use="required" />
  <xs:attribute name="enabled"
                type="xs:boolean" />
  <xs:attribute name="passExecutionContext"
                type="xs:boolean" />
  <xs:attribute name="parameters"
                type="xs:string" />

 </xs:complexType>
 <xs:complexType name="FormXmlEventsType">
  <xs:sequence>
   <xs:element name="event"
               minOccurs="1"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:all>
      <xs:element name="Handlers"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="Handler"
                     type="FormXmlHandlerType"
                     minOccurs="0"
                     maxOccurs="50" />
        </xs:sequence>

       </xs:complexType>
      </xs:element>
      <xs:element name="InternalHandlers"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="Handler"
                     type="FormXmlHandlerType"
                     minOccurs="0"
                     maxOccurs="50" />
        </xs:sequence>

       </xs:complexType>
      </xs:element>
      <xs:element name="dependencies"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="dependency"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:complexType>
           <xs:attribute name="id"
                         type="xs:string" />

          </xs:complexType>
         </xs:element>
        </xs:sequence>

       </xs:complexType>
      </xs:element>
     </xs:all>
     <xs:attribute name="name"
                   type="xs:string" />
     <xs:attribute name="BehaviorInBulkEditForm"
                   type="BehaviorInBulkEditForm" />
     <xs:attribute name="application"
                   type="xs:boolean" />
     <xs:attribute name="active"
                   type="xs:boolean" />
     <xs:attribute name="eventType"
                   type="CrmEventType" />
     <xs:attribute name="attribute"
                   type="xs:string" />

    </xs:complexType>
   </xs:element>
  </xs:sequence>

 </xs:complexType>
 <xs:complexType name="FormXmlExternalDependenciesType">
  <xs:sequence>
   <xs:element name="dependency"
               minOccurs="1"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:attribute name="id"
                   type="xs:string" />

    </xs:complexType>
   </xs:element>
  </xs:sequence>

 </xs:complexType>
 <xs:complexType name="FormXmlLabelsType">
  <xs:sequence>
   <xs:element name="label"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:attribute name="description"
                   use="required"
                   type="xs:string" />
     <xs:attribute name="languagecode"
                   use="required"
                   type="xs:positiveInteger" />
     <xs:attribute name="addedby"
                   type="xs:string" />

    </xs:complexType>
   </xs:element>
  </xs:sequence>

 </xs:complexType>
 <xs:complexType name="FormXmlHeaderFooterType">
  <xs:sequence>
   <xs:element name="rows"
               minOccurs="1"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="row"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="cell"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:complexType>
           <xs:all>
            <xs:element name="labels"
                        type="FormXmlLabelsType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="control"
                        type="FormXmlControlType"
                        minOccurs="0"
                        maxOccurs="1" />
           </xs:all>
           <xs:attributeGroup ref="FormXmlCellCommon"/>
          </xs:complexType>
         </xs:element>
        </xs:sequence>
        <xs:attributeGroup ref="FormXmlRowCommon"/>
       </xs:complexType>
      </xs:element>
     </xs:sequence>

    </xs:complexType>
   </xs:element>
  </xs:sequence>
  <xs:attribute name="id"
                type="FormGuidType"
                use="required" />
  <xs:attributeGroup ref="FormXmlSectionCommon" />
 </xs:complexType>
 <xs:attributeGroup name="FormXmlSectionCommon">
  <xs:attribute name="columns"
                type="xs:nonNegativeInteger" />
  <xs:attribute name="labelwidth"
                type="xs:nonNegativeInteger" />
  <xs:attribute name="celllabelalignment"
                use="optional">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="Center"/>
     <xs:enumeration value="Left"/>
     <xs:enumeration value="Right"/>
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attribute name="celllabelposition"
                use="optional">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="Top"/>
     <xs:enumeration value="Left"/>
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>

 </xs:attributeGroup>
 <xs:attributeGroup name="FormXmlRowCommon">
  <xs:attribute name="height"
                type="xs:string" />

 </xs:attributeGroup>
 <xs:attributeGroup name="FormXmlCellCommon">
  <xs:attribute name="id"
                type="FormGuidType" />
  <xs:attribute name="showlabel"
                type="xs:boolean" />
  <xs:attribute name="labelid"
                type="FormGuidType"
                use="optional" />
  <xs:attribute name="locklevel"
                type="xs:nonNegativeInteger" />
  <xs:attribute name="rowspan"
                type="xs:nonNegativeInteger" />
  <xs:attribute name="colspan"
                type="xs:nonNegativeInteger" />
  <xs:attribute name="userspacer"
                type="xs:boolean" />
  <xs:attribute name="ispreviewcell"
                type="xs:boolean"/>
  <xs:attribute name="visible"
                type="xs:boolean" />

 </xs:attributeGroup>
 <xs:simpleType name="BehaviorInBulkEditForm">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Disabled" />
   <xs:enumeration value="EnabledButNoRender" />
   <xs:enumeration value="Enabled" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="FormCRM_Boolean">
  <xs:restriction base="xs:unsignedByte">
   <xs:minInclusive value="0" />
   <xs:maxInclusive value="1" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="FormGuidType">
  <xs:annotation>
   <xs:documentation xml:lang="en">
    The representation of a GUID, generally the id of an element.
   </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
   <xs:pattern value="\{[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}\}" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="FormISVGuid">
  <xs:restriction base="xs:string">
   <xs:pattern value="\{?[0-9a-fA-F]{8}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{12}\}?" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name ="FormParameterAttributeType">
  <xs:restriction base ="xs:string">
   <xs:enumeration value ="Boolean" />
   <xs:enumeration value ="DateTime" />
   <xs:enumeration value ="Double" />
   <xs:enumeration value ="EntityType" />
   <xs:enumeration value ="Integer" />
   <xs:enumeration value ="Long" />
   <xs:enumeration value ="PositiveInteger" />
   <xs:enumeration value ="SafeString" />
   <xs:enumeration value ="UniqueId" />
   <xs:enumeration value ="UnsignedInt" />
  </xs:restriction>
 </xs:simpleType >
 <xs:simpleType name ="FormParameterPassAsAttributeType">
  <xs:restriction base ="xs:string">
   <xs:enumeration value ="QueryString" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="FormPercentageType">
  <xs:restriction base="xs:string">
   <xs:pattern value="^(100|[0-9]{1,2})%$" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="FormQueryStringParameterNameAttributeType">
  <xs:restriction base="xs:string">
   <xs:pattern value="(?![cC][rR][mM]_)([A-Za-z0-9])+([_])+([A-Za-z0-9_])*"/>
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="GridResizeType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Auto"/>
   <xs:enumeration value="Fixed"/>
   <xs:enumeration value="AutoWithFixedMax"/>
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="ImageHorizontalAlignmentType">
  <xs:restriction base ="xs:string">
   <xs:enumeration value ="Left" />
   <xs:enumeration value ="Right" />
   <xs:enumeration value ="Center" />
   <xs:enumeration value ="NotSet" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="ImageVerticalAlignmentType">
  <xs:restriction base ="xs:string">
   <xs:enumeration value ="Top" />
   <xs:enumeration value ="Middle" />
   <xs:enumeration value ="Bottom" />
   <xs:enumeration value ="NotSet" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="RelationshipRoleOrdinalType">
  <xs:restriction base="xs:unsignedByte">
   <xs:enumeration value="1" />
   <xs:enumeration value="2" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name ="WebResourceSizeType">
  <xs:restriction base ="xs:string">
   <xs:enumeration value ="StretchToFit" />
   <xs:enumeration value ="StretchMaintainAspectRatio" />
   <xs:enumeration value ="Original" />
   <xs:enumeration value ="Specific" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="solutionactionType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Added" />
   <xs:enumeration value="Removed" />
   <xs:enumeration value="Modified" />
  </xs:restriction>
 </xs:simpleType >
 <xs:attributeGroup name="FormXmlBaseElementCommon">
  <xs:attribute name="solutionaction"
                type="solutionactionType" />
 </xs:attributeGroup>
 <xs:complexType name ="solutionStringType">
  <xs:simpleContent>
   <xs:extension base="xs:string">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name ="solutionBooleanType">
  <xs:simpleContent>
   <xs:extension base="xs:boolean">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name ="solutionFormGuidType">
  <xs:simpleContent>
   <xs:extension base="FormGuidType">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name ="solutionUnsignedIntType">
  <xs:simpleContent>
   <xs:extension base="xs:unsignedInt">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name ="solutionWebResourceSizeType">
  <xs:simpleContent>
   <xs:extension base="WebResourceSizeType">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name ="solutionImageHorizontalAlignmentType">
  <xs:simpleContent>
   <xs:extension base="ImageHorizontalAlignmentType">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name ="solutionImageVerticalAlignmentType">
  <xs:simpleContent>
   <xs:extension base="ImageVerticalAlignmentType">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name ="solutionRelationshipRoleOrdinalType">
  <xs:simpleContent>
   <xs:extension base="RelationshipRoleOrdinalType">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name ="solutionGridResizeType">
  <xs:simpleContent>
   <xs:extension base="GridResizeType">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name ="solutionUnsignedShortType">
  <xs:simpleContent>
   <xs:extension base="xs:unsignedShort">
    <xs:attributeGroup ref="FormXmlBaseElementCommon"/>
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
</xs:schema>

See Also

Concepts

Customize entity forms
Create, install, and update a managed solution
Create, export, or import an unmanaged solution

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize visualizations and dashboards

Data visualization and analytics in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update enable you to graphically view and analyze the data for your business, and help you to derive quick insights to make important business decisions. Further, you can configure dashboards in such a way that enables you to view data from multiple areas of Microsoft Dynamics CRM such as sales, marketing, and service. You can even adjust the data displayed in visualizations and dashboards per your business requirements by applying filters.

The following elements constitute the visualization and analytics abilities in Microsoft Dynamics CRM:

  • Visualization. Visualizations enable you to present your data graphically in the form of charts. Charts enable you to view the aggregate or non-aggregate summary of grid data in Microsoft Dynamics CRM. The charts are integrated with the grid, and display data in context with the grids. The charts update automatically to reflect the filtering done on the data in the grids. Similarly, when you perform a drill down operation on the chart, the data in the corresponding grid updates accordingly. You can also use a Web resource instead of charts in visualization.
  • Dashboard. Dashboards act as a business intelligence tool in Microsoft Dynamics CRM by providing a snapshot of your data in various forms. You can use a dashboard to simultaneously present data from charts, grids, IFRAMES, and Web resources. A dashboard acts as a container for these objects, and can simultaneously present data from up to six visualizations, grids, IFRAMES, or web resources.

In This Section

View data with visualizations (charts) View data with visualizations (charts)

Analyze data with dashboards

Visualization data description schema

Related Sections

Extend the metadata model

Customize entity forms

Customize entity views

Customize global option sets

Change application navigation using the SiteMap

Customize commands and the ribbon

Service calendar appearance configuration

Publish customizations

When to edit the customizations file

Customize entity views

Change application navigation using the SiteMap

Write client application extensions

Web resources for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


View data with visualizations (charts)

Visualizations let you see your business data graphically. A visualization is attached to an entity in Microsoft Dynamics CRM. You can attach multiple visualizations to an entity, however, only one visualization can be displayed at a time along-side a grid. You can view multiple visualizations at the same time by using a dashboard. More information: Analyze data with dashboards

You can use a chart or a web resource as a visualization in Microsoft Dynamics CRM. For charts, you can use the chart designer in Microsoft Dynamics CRM. However, to use a web resource in a visualization, you must either use the SDK or import a custom visualization XML into Microsoft Dynamics CRM. More information: Sample: Create, retrieve, update, and delete a chart

In This Topic

Visualization ownership

Chart visualizations

Web resource visualizations

Entities supported for visualizations

Visualization ownership

In Microsoft Dynamics CRM, there are two types of visualization ownership: organization-owned and user-owned.

  • An organization-owned visualization is owned by an organization, and cannot be assigned or shared. The SavedQueryVisualization entity represents the organization-owned visualization. These visualizations are solution-aware entities in Microsoft Dynamics CRM. Whenever you update a saved query visualization, you must publish the changes for the updates to be available across the organization by using the PublishAllXmlRequest message. This entity is referred to as a System Chart in the Microsoft Dynamics CRM web application.
  • A user-owned visualization is owned by an individual user, and can be assigned and shared with other users and teams. The UserQueryVisualization entity represents the user-owned visualization. This entity is referred to as a User Chart in the Microsoft Dynamics CRM web application, and is displayed under My Charts in the chart drop-down list.

A user query visualization is not associated with a user query (view), despite the entity name. The view aspect of this entity is used only for setting the filter criteria.

Chart visualizations

Charts let you see summaries of grid data. The charts are built by using the Microsoft Chart Controls for Microsoft .NET Framework 3.5. For more information about Microsoft Chart Controls, see Chart Controls for .NET Framework.

These charts are integrated with the grids in the web application. When you apply a filter (query) to the data in a grid, the filter is applied to the chart also, and the chart is updated accordingly. Similarly, when you perform drill-down operations on a chart, the grid data is updated automatically.

A chart attached to an entity is available for all the views for the entity. A chart displays data according to the currently selected (or displayed) view of an entity. A chart can display data from both a saved query (organization-owned view) and a user query (user-owned view).

Charts display data for only those saved queries (organization-owned views) that use FetchXML (SavedQuery.FetchXml attribute) to filter the records. If a saved query uses the query API (SavedQuery.QueryAPI attribute) to filter the records, the chart will not appear for that saved query. This limitation is not applicable for user queries (user-owned views) because the user query entity does not use the QueryAPI attribute to filter the records.

For more information about how to work with charts, see Understand charts: Underlying data and chart representation.

Chart types in Microsoft chart controls

Microsoft Chart Controls is used to build charts in Microsoft Dynamics CRM. Microsoft Chart Controls enable you to create various chart types such as column, bar, area, stacked, line, bubble, and pie.

The following chart types are supported out-of-box in Microsoft Dynamics CRM: Column, Area, Bar, Line, Pie, and Funnel. However, you can extend the functionality by creating other supported Microsoft Chart Controls chart types such as multi-series, stacked, and 100% stacked (comparison) charts by using the Microsoft Dynamics CRM SDK. This is done by specifying appropriate content in the data description and presentation description XML strings for a chart. More information: Understand charts: Underlying data and chart representation

Web resource visualizations

Web resources are virtual files that are stored in the Microsoft Dynamics CRM database and may be retrieved using a unique URL address. You can display an existing web resource as a visualization, and display it in the Charts area in Microsoft Dynamics CRM together with other charts for an entity. For more information about web resources, see Web resources for Microsoft Dynamics CRM.

You can use the following types of web resources in a visualization: Webpage (HTML) web resources and Image (JPG, PNG, GIF, ICO) web resources. For more information about how to create a visualization with a web resource, see Create a Web Resource Visualization.

Entities supported for visualizations

You can create and attach visualizations to only those entities in Microsoft Dynamics CRM that support the new ribbon interface. This is because all of the chart controls are only present in the ribbon interface of Microsoft Dynamics CRM 2015. Custom entities are also supported for visualizations. You can turn off the visualization support for custom entities if you want to. However, you cannot disable visualization support for the default entities.

The following lists the default entities that are supported for visualizations.

Account
ActivityPointer
Appointment
BulkOperation
Campaign
CampaignActivity
CampaignResponse
Competitor
Connection
Contact
Contract
Email
Entitlement
EntitlementChannel
EntitlementTemplateChannel
Fax
Goal
GoalRollupQuery
Incident
Invoice
InvoiceDetail
KbArticle
Lead
Letter
List
Mailbox
Metric
Opportunity
OpportunityProduct
PhoneCall
Position
PriceLevel
Product
ProductAssociation
ProductSubstitute
QueueItem
Quote
QuoteDetail
RecurringAppointmentMaster
Report
SalesLiterature
SalesOrder
SalesOrderDetail
Service
ServiceAppointment
SLAKPIInstance
SocialActivity
SocialProfile
SystemUser
Task
Team
Territory
UoMSchedule

See Also

Concepts

Understand charts: Underlying data and chart representation
Actions on visualizations (charts)
Create a visualization (chart)
Sample charts
SavedQueryVisualization (system chart) entity messages and methods
UserQueryVisualization (user chart) entity messages and methods

Other Resources

Customize visualizations and dashboards
Sample code for charts (visualizations)
Chart Controls for .NET Framework Language Pack
Chart Controls Add-on for Visual Studio
Chart Controls for .NET Framework Documentation
Samples Environment for Microsoft Chart Controls
Chart Controls Forum

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Understand charts: Underlying data and chart representation

Charts display data visually by mapping textual values on two axes: horizontal (x) and vertical (y). In Microsoft Dynamics CRM, the x axis is called the category axis and the y axis is called the series axis. The category axis can display numeric as well as non-numeric values whereas the series axis only displays numeric values.

Charts in Microsoft Dynamics CRM can be further classified into the following:

  • Single-series charts: Charts that display data with a series (y) value mapped to a category (x) value.
  • Multi-series charts: Charts that display data with multiple series values mapped to a single category value. Multi-series charts include stacked column charts, which vertically display the contribution of each series to a total across categories, and 100% stacked column charts, which compare the percentage that each series contributes to a total across categories. You can combine different compatible chart types in multi-series charts, for example, column and line, bar and line, and so on.
Note
Multi-category charts can be created through the web application or by modifying the XML strings described here.

While authoring a chart in Microsoft Dynamics CRM using the SDK, you need to consider the following two important aspects:

  • Underlying data for the chart: Specified using the data description XML string.
  • Data representation (appearance): Specified using the presentation description XML string.
Note
Microsoft Chart Controls lets you create various types of charts such as column, bar, area, line, pie, funnel, bubble, and radar. The chart designer in Microsoft Dynamics CRM lets you create only certain types of charts. However, using the SDK, you can create most of the chart types that are supported by Microsoft Chart Controls.

Use the data description XML string to specify chart data

The data description XML string defines the data that will displayed on the chart. The contents of the XML string are validated against the visualization data description schema. For more information about the schema, see Visualization data description schema.

You can specify the data description XML string while you are creating a chart using the SavedQueryVisualization.DataDescription or the UserQueryVisualization.DataDescription attribute for the organization-owned or user-owned chart respectively.

The data description XML string contains the following two elements: <FetchCollection> and <CategoryCollection>.

The <FetchCollection> element

The <FetchCollection> element uses FetchXML to retrieve data for the chart. The FetchXML query specifies information about the entity attributes, aggregate functions, and the group by clauses for the data to be displayed in a chart. All the FetchXML aggregate functions are supported for charts. For more information about the FetchXML aggregate functions, see Use FetchXML aggregation.

The FetchXML query enables you to filter your data. Also, filters are applied on charts through views. Therefore, if a filter condition is already specified in the FetchXML query in the <FetchCollection> element, and additionally a filter is applied through a view, the chart will display data that is returned after it applies all the filters. For more information about how to use the FetchXML query to filter data, see Build queries with FetchXML.

Note
Although the data description XML string is validated again the visualization data description schema, the FetchXML query inside the <FetchCollection> element is not. The FetchXML query is validated against the FetchXML schema. For more information, see FetchXML schema.

If the chart is a comparison chart, the <FetchCollection> element will contain two group by clauses.

The <CategoryCollection> element

The <CategoryCollection> element contains information about the category (horizontal) and the series (vertical) axes in a chart.

  • Each <Category> sub-element has a child element called <MeasureCollection> that maps to the <Series> element in the presentation description XML. A single series chart has a single <MeasureCollection> child element whereas a multi-series chart will have multiple <MeasureCollection> child elements, each mapped to the respective <Series> element in the presentation description XML.
  • Each <MeasureCollection> child element has an element called <Measure> that corresponds to the series (vertical) axis value, corresponding to each value on the category (horizontal) axis.

Example

The following is a sample data description XML string:

Xml Copy Code
<datadefinition>
  <fetchcollection>
    <fetch mapping="logical" count="10">
      <entity name="opportunity">
        <attribute name="estimatedvalue" />
        <order attribute="estimatedvalue" descending="true" />
      </entity>
    </fetch>
  </fetchcollection>
  <categorycollection>
    <category>
      <measurecollection>
        <measure alias="estimatedvalue" />
      </measurecollection>
    </category>
  </categorycollection></datadefinition>

For more sample data description XML strings, see Sample charts.

Use the presentation description XML string to specify data representation

The presentation description XML string contains information about the appearance of the chart such as chart title, chart color, and chart type (bar, column, line, and so on). There is no schema definition for this XML string. However, the XML is a serialization of the Chart class in Microsoft Chart Controls. More information: Chart Controls

You can specify the presentation description XML string while you are creating a chart using the SavedQueryVisualization.PresentationDescription or UserQueryVisualization.PresentationDescription attribute for the organization-owned or user-owned chart, respectively.

Example

The following is a sample presentation description XML string:

Xml Copy Code
<Chart Palette="BrightPastel">
  <Series>
    <Series _Template_="All" Color="153, 204, 255" BorderColor="164, 164, 164" BorderDashStyle="Solid" BorderWidth="1" ShadowColor="128, 128, 128, 128" ShadowOffset="1" IsValueShownAsLabel="true" Font="{0}, 6.75pt" BackGradientStyle="TopBottom" BackSecondaryColor="0, 102, 153" LabelForeColor="100, 100, 100" ChartType="Column">
      <SmartLabelStyle Enabled="True" />
      <Points />
    </Series>
  </Series>
  <ChartAreas>
    <ChartArea _Template_="All" BackColor="White" BorderColor="26, 59, 105" BorderWidth="0" BorderDashStyle="Solid">      <AxisY LineColor="204, 204, 204" TitleFont="{0}, 8pt, GdiCharSet=0" TitleForeColor="100, 100, 100" LabelAutoFitMaxFontSize="7" LabelAutoFitMinFontSize="7">
        <MajorTickMark LineColor="Gray" />
        <MajorGrid Enabled="false" />
        <LabelStyle Font="{0}, 6.75pt, GdiCharSet=0" ForeColor="100, 100, 100" />
      </AxisY>
      <AxisX LineColor="204, 204, 204" TitleFont="{0}, 8pt, GdiCharSet=0" TitleForeColor="100, 100, 100" LabelAutoFitMaxFontSize="7" LabelAutoFitMinFontSize="7">        <MajorTickMark LineColor="Gray" />        <MajorGrid Enabled="false" />
        <LabelStyle Font="{0}, 6.75pt, GdiCharSet=0" ForeColor="100, 100, 100" />
      </AxisX>
    </ChartArea>
  </ChartAreas>
  <Titles>
    <Title _Template_="All" Font="{0}, 9pt, style=Bold, GdiCharSet=0" ForeColor="100, 100, 100"></Title>
  </Titles>
  <BorderSkin PageColor="Control" BackColor="CornflowerBlue" BackSecondaryColor="CornflowerBlue" />
</Chart>

For more sample presentation description XML strings, see Sample charts.

See Also

Reference

FetchXML schema
Visualization data description schema

Concepts

View data with visualizations (charts)
Actions on visualizations (charts)
Create a visualization (chart)
Sample charts

Other Resources

Build queries with FetchXML
Chart Class (Microsoft Chart Controls)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Actions on visualizations (charts)

Using the Microsoft Dynamics CRM SDK, you can perform the following actions on the visualization entities.

Actions on organization-owned visualizations

To perform actions on an organization-owned visualization (SavedQueryVisualization), you must have the System Administrator or the System Customizer role. You can perform the following actions on an organization-owned visualization:

  • Create, retrieve, update, and delete an organization-owned visualization. More information: Create a visualization (chart)
    Note
    After updating an organization-owned visualization, you must publish the metadata changes to make it visible across the organization by using the PublishAllXmlRequest message. Alternatively, whenever you publish an entity, all the unpublished organization-owned visualizations that are attached to the entity are published automatically.

  • Query and retrieve all the organization-owned visualizations that are attached to an entity using the SavedQueryVisualization.PrimaryEntityTypeCode attribute. Multiple organization-owned visualizations can be attached to a single entity. For a list of entities with which you can attach a visualization, see Entities Supported for Visualizations. For a code sample that demonstrates how to retrieve all the organization-owned visualizations attached to an entity, see Sample: Retrieve all charts attached to an entity.
    Note
    You cannot change or update a visualization to attach it with a different entity after you have created the visualization. It implies that the SavedQueryVisualization.PrimaryEntityTypeCode attribute is not valid for the update action on the organization-owned visualization.

  • Specify an organization-owned visualization as the default visualization for the associated entity by setting the SavedQueryVisualization.IsDefault attribute to true. When you set an organization-owned visualization as the default visualization for an entity, the visualization is displayed by default when you select to view the visualizations for this entity in the Microsoft Dynamics CRM.
    Note
    Using the Microsoft Dynamics CRM SDK, if you set an organization-owned visualization as default for an entity that already has another visualization set as default, both the visualizations are marked as default visualizations for the entity. To set a visualization as a default visualization for an entity, make sure that no other visualization is set as the default visualization for the entity.

For a list of supported messages on the organization-owned visualization entity, see SavedQueryVisualization (system chart) entity messages and methods.

Actions on user-owned visualizations

You can perform the following actions on a user-owned visualization (UserQueryVisualization):

  • Create, retrieve, update, and delete a user-owned visualization. More information: Create a visualization (chart)
  • Query and retrieve all the user-owned visualizations that are attached to an entity using the UserQueryVisualization.PrimaryEntityTypeCode attribute. Multiple user-owned visualizations can be attached to an entity. For a list of entities with which you can attach a visualization, see Entities Supported for Visualizations.
    Note
    You cannot change or update a visualization to attach it with a different entity after you have created the visualization. It implies that the UserQueryVisualization.PrimaryEntityTypeCode attribute is not valid for the update action on the user-owned visualization.

  • Change the ownership of a user-owned visualization by assigning it to another user or team using AssignRequest.
  • Retrieve the access that the specified security principal (user or team) has to a user-owned visualization using RetrievePrincipalAccessRequest. You can also retrieve all the security principals (users or teams) that have access to a user-owned visualization, along with their access rights to the user-owned visualization using the RetrieveSharedPrincipalsAndAccessRequest.
  • Collaborate with other users and teams on specific areas by sharing a user-owned visualization with them using GrantAccessRequest, ModifyAccessRequest, and RevokeAccessRequest.

For a list of supported messages on the user-owned visualization entity, see UserQueryVisualization (user chart) entity messages and methods.

See Also

Concepts

View data with visualizations (charts)
Understand charts: Underlying data and chart representation
Create a visualization (chart)
Sample charts
SavedQueryVisualization (system chart) entity messages and methods
UserQueryVisualization (user chart) entity messages and methods

Other Resources

Sample: Create, retrieve, update, and delete a chart
Sample: Retrieve all charts attached to an entity
Sample: Assign a chart to another user

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create a visualization (chart)

To create a visualization using the Microsoft Dynamics CRM SDK, you must create a record for the SavedQueryVisualization or UserQueryVisualization entity to create an organization-owned or user-owned chart respectively. This topic shows how to create a chart visualization and a web resource visualization.

In This Topic

Before you create a visualization

Create a chart visualization

Create a web resource visualization

Before you create a visualization

Before creating a visualization, make sure that you are aware of the following:

  • Type of visualization: If you want your visualizations to be available across the organization and don’t want to manage the access levels at a more granular level, you might want to create an organization-owned visualization. However, if you’re concerned about the access privileges and security of your visualization, consider creating a user-owned visualization where you have more control over who can access it.
    Note
    Organization-owned visualizations can only be created by those users who have the System Administrator or System Customizer role.

  • Associated Entity: Visualizations are attached to entities. More information: Entities Supported for Visualizations. You can attach a chart to a supported entity by using the SavedQueryVisualization.PrimaryEntityTypeCode or UserQueryVisualization.PrimaryEntityTypeCode attribute.

Create a chart visualization

Charts require you to specify the underlying data for the charts and how the charts will look in the form of data description and presentation description XML strings. More information: Understand charts: Underlying data and chart representation and Sample charts.

For a complete sample on how to create an organization-owned chart, see Sample: Create, retrieve, update, and delete a chart.

Create a multi-series chart

Multi-series charts map multiple series (vertical) axis values to a single category (horizontal) axis value. The only difference from a single series chart is that these charts have multiple <measurecollection> and corresponding <series> elements specified in the XML strings. Each <measurecollection> element contains a child element called <measure> that defines a series (vertical) axis value for the same category (horizontal) value. More information: Understand charts: Underlying data and chart representation.

For a sample multi-series chart and the corresponding data description and presentation descriptions XML strings, see Multi-Series Chart.

Create a web resource visualization

Visualizations containing web resources don’t require you to specify the data description and presentation description XML strings. The following sample demonstrates how to create an organization-owned visualization containing a web resource by using the SDK.

C# Copy Code
SavedQueryVisualization newWebResourceVisualization = new SavedQueryVisualization()
{
   Name = "Sample Dashboard Visualization",
   Description = "Sample organization-owned visualization",
                           PrimaryEntityTypeCode = Account.EntityLogicalName,
   WebResourceId = new EntityReference(WebResource.EntityLogicalName, _webResourceId))

};
_orgOwnedVisualizationId = _serviceProxy.Create(newWebResourceVisualization);

If you want to create a web resource visualization by using the Microsoft Dynamics CRM web application, you must create an XML file in the following format, and then use Import Chart in the ribbon to import the visualization.

Xml Copy Code
<visualization>
  <name>Visualization_Name</name>
  <description>Description</description>
  <webresourcename>Name_Of_An_Existing_Web_Resource</webresourcename>
  <primaryentitytypecode>Entity_Logical_Name</primaryentitytypecode>
  <isdefault>Value: true or false</isdefault>
</visualization>

For example, to create a Sample Visualization that displays an existing Web resource called new_TestWebResource, and the visualization should be attached to the account entity, the XML should look like.

Xml Copy Code
<visualization>
  <name>Sample Visualization</name>
  <description>Sample Web Resource Visualization.</description>
  <webresourcename>new_TestWebResource</webresourcename>
  <primaryentitytypecode>account</primaryentitytypecode>
  <isdefault>false</isdefault>
</visualization>

For more information on how to export the chart, edit the chart definition file, and then import it back into Microsoft Dynamics CRM, see Export a user or a system chart.

See Also

Concepts

View data with visualizations (charts)
Understand charts: Underlying data and chart representation
Actions on visualizations (charts)
Sample charts

Other Resources

Customize visualizations and dashboards
Sample: Create, retrieve, update, and delete a chart

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample charts

This topic contains sample charts along with the respective data description and presentation XML strings. You can specify the:

  • Data description XML string for a chart using the SavedQueryVisualization.DataDescription or UserQueryVisualization.DataDescription attribute for the organization-owned or user-owned chart respectively.
  • Presentation description XML string for a chart using the SavedQueryVisualization.PresentationDescription or UserQueryVisualization. PresentationDescription attribute for the organization-owned or user-owned chart respectively.

In This Topic

Column Chart

Bar Chart

Area Chart

Line Chart

Pie Chart

Funnel Chart

Multi-Series Chart

Comparison Chart (Stacked Chart)

Comparison Chart (100% Stacked Chart)

Column Chart

The following is a column chart that shows the account by industry. We modified the presentation description of the existing Account By Industry default chart available in Microsoft Dynamics CRM for the Account entity to change it to a column chart.

Sample column chart: Accounts by Industry

Data Description

The following is the contents of the data description XML string for this chart.

Xml Copy Code
<datadefinition>
  <fetchcollection>
    <fetch mapping="logical" aggregate="true">
      <entity name="account">
        <attribute groupby="true" alias="groupby_column" name="industrycode" />
        <attribute alias="aggregate_column" name="name" aggregate="count" />
      </entity>
    </fetch>
  </fetchcollection>
  <categorycollection>
    <category>
      <measurecollection>
        <measure alias="aggregate_column" />
      </measurecollection>
    </category>
  </categorycollection>
</datadefinition>

Presentation Description

The following is the contents of the presentation description XML string for this chart.

Xml Copy Code
<Chart>
  <Series>
    <Series ChartType="Column" IsValueShownAsLabel="True" Color="149, 189, 66" BackGradientStyle="TopBottom" BackSecondaryColor="112, 142, 50" Font="{0}, 9.5px" LabelForeColor="59, 59, 59" CustomProperties="MinPixelPointWidth=5, PointWidth=0.75, MaxPixelPointWidth=40">
      <SmartLabelStyle Enabled="True" />
    </Series>
  </Series>
  <ChartAreas>
    <ChartArea BorderColor="White" BorderDashStyle="Solid">
      <AxisY IsLabelAutoFit="False" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IsReversed="False">
        <MajorGrid LineColor="239, 242, 246" />
        <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
      </AxisY>
      <AxisX IsLabelAutoFit="True" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IsReversed="False">
        <MajorGrid Enabled="False" />
        <MajorTickMark Enabled="False" />
        <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
      </AxisX>
    </ChartArea>
  </ChartAreas>
  <Titles>
    <Title Name="Chart Title" DockingOffset="-3" Font="{0}, 13px" ForeColor="59, 59, 59" Alignment="TopLeft"></Title>
  </Titles>
</Chart>

Bar Chart

The following is a bar chart that shows the top 10 customers. This is one of the default charts available in Microsoft Dynamics CRM for the Opportunity entity.

Sample bar chart: Top 10 Customers

Data Description

The following is the contents of the data description XML string for this chart.

Xml Copy Code
<datadefinition>
  <fetchcollection>
    <fetch mapping="logical" count="10" aggregate="true">
      <entity name="opportunity">
        <attribute name="estimatedvalue" aggregate="sum" alias="sum_estimatedvalue" />
        <attribute name="customerid" groupby="true" alias="customerid" />
        <order alias="sum_estimatedvalue" descending="true" />
      </entity>
    </fetch>
  </fetchcollection>
  <categorycollection>
    <category>
      <measurecollection>
        <measure alias="sum_estimatedvalue" />
      </measurecollection>
    </category>
  </categorycollection>
</datadefinition>

Presentation Description

The following is the contents of the presentation description XML string for this chart.

Xml Copy Code
<Chart>
  <Series>
    <Series ChartType="Bar" IsValueShownAsLabel="True" Color="149, 189, 66" BackGradientStyle="TopBottom" BackSecondaryColor="112, 142, 50" Font="{0}, 9.5px" LabelForeColor="59, 59, 59" CustomProperties="MinPixelPointWidth=5, PointWidth=0.75, MaxPixelPointWidth=40">
      <SmartLabelStyle Enabled="True" />
    </Series>
  </Series>
  <ChartAreas>
    <ChartArea BorderColor="White" BorderDashStyle="Solid">
      <AxisY IsLabelAutoFit="False" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IsReversed="False">
        <MajorGrid LineColor="239, 242, 246" />
        <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
      </AxisY>
      <AxisX IsLabelAutoFit="False" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IsReversed="False">
        <MajorGrid Enabled="False" />
        <MajorTickMark Enabled="False" />
        <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
      </AxisX>
    </ChartArea>
  </ChartAreas>
  <Titles>
    <Title DockingOffset="-3" Font="{0}, 13px" ForeColor="59, 59, 59" Alignment="TopLeft"></Title>
  </Titles>
</Chart>

Area Chart

The following is an area chart that shows the number of records generated between a given date range.

Sample area chart

Data Description

The following is the contents of the data description XML string for this chart.

Copy Code
<datadefinition>
      <fetchcollection>
        <fetch mapping="logical" aggregate="true">
          <entity name="incident">
            <attribute name="createdon" groupby="true" alias="_CRMAutoGen_groupby_column_Num_0" dategrouping="day" />
            <attribute name="incidentid" aggregate="count" alias="_CRMAutoGen_aggregate_column_Num_0" />
          </entity>
        </fetch>
      </fetchcollection>
      <categorycollection>
        <category alias="_CRMAutoGen_groupby_column_Num_0">
          <measurecollection>
            <measure alias="_CRMAutoGen_aggregate_column_Num_0" />
          </measurecollection>
        </category>
      </categorycollection>
    </datadefinition>

Presentation Description

The following is the contents of the presentation description XML for this chart.

Copy Code
<Chart Palette="None" PaletteCustomColors="149,189,66; 197,56,52; 55,118,193; 117,82,160; 49,171,204; 255,136,35; 168,203,104; 209,98,96; 97,142,206; 142,116,178; 93,186,215; 255,155,83">
      <Series>
        <Series ChartType="StackedArea" Font="{0}, 9.5px" LabelForeColor="59, 59, 59" CustomProperties="PointWidth=0.75, MaxPixelPointWidth=40" />
      </Series>
      <ChartAreas>
        <ChartArea BorderColor="White" BorderDashStyle="Solid">
          <AxisY LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount">
            <MajorGrid LineColor="239, 242, 246" />
            <MajorTickMark LineColor="165, 172, 181" />
            <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
          </AxisY>
          <AxisX LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount">
            <MajorTickMark LineColor="165, 172, 181" />
            <MajorGrid LineColor="Transparent" />
            <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
          </AxisX>
        </ChartArea>
      </ChartAreas>
      <Titles>
        <Title Alignment="TopLeft" DockingOffset="-3" Font="{0}, 13px" ForeColor="59, 59, 59" />
      </Titles>
      <Legends>
        <Legend Alignment="Center" LegendStyle="Table" Docking="right" IsEquallySpacedItems="True" Font="{0}, 11px" ShadowColor="0, 0, 0, 0" ForeColor="59, 59, 59" />
      </Legends>
    </Chart>

Line Chart

The following is a line chart that shows the number of leads generated in the last five months. This is one of the default charts available in Microsoft Dynamics CRM for the Lead entity.

Sample line chart: Lead Generation Rate

Data Description

The following is the contents of the data description XML string for this chart.

Xml Copy Code
<datadefinition>
  <fetchcollection>
    <fetch mapping="logical" count="5" aggregate="true">
      <entity name="lead">
        <attribute name="leadid" aggregate="countcolumn" alias="count_leadid" />
        <attribute name="createdon" groupby="true" dategrouping="month" usertimezone="false" alias="createdon" />
        <order alias="createdon" descending="false" />
      </entity>
    </fetch>
  </fetchcollection>
  <categorycollection>
    <category>
      <measurecollection>
        <measure alias="count_leadid" />
      </measurecollection>
    </category>
  </categorycollection>
</datadefinition>

Presentation Description

The following is the contents of the presentation description XML string for this chart.

Xml Copy Code
<Chart>
  <Series>
    <Series IsValueShownAsLabel="True" BorderWidth="3" ChartType="Line" Color="49, 171, 204" MarkerStyle="Square" MarkerSize="9" MarkerColor="37, 128, 153"></Series>
  </Series>
  <ChartAreas>
    <ChartArea BorderColor="White">
      <AxisY LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181">
        <MajorGrid LineColor="239, 242, 230" />
        <MajorTickMark LineColor="165, 172, 181" />
        <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
      </AxisY>
      <AxisX LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181">
        <MajorGrid Enabled="False" />
        <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
      </AxisX>
    </ChartArea>
  </ChartAreas>
  <Titles>
    <Title DockingOffset="-3" Font="{0}, 13px" ForeColor="59, 59, 59" Alignment="TopLeft"></Title>
  </Titles>
</Chart>

Pie Chart

The following is a pie chart that shows the total number of leads and their importance. This is one of the default charts available in Microsoft Dynamics CRM for the Lead entity.

Sample pie chart: Leads by Rating

Data Description

The following is the contents of the data description XML string for this chart.

Xml Copy Code
<datadefinition>
  <fetchcollection>
    <fetch mapping="logical" aggregate="true">
      <entity name="lead">
        <attribute groupby="true" alias="groupby_column" name="leadqualitycode" />
        <attribute alias="aggregate_column" name="fullname" aggregate="count" />
      </entity>
    </fetch>
  </fetchcollection>
  <categorycollection>
    <category>
      <measurecollection>
        <measure alias="aggregate_column" />
      </measurecollection>
    </category>
  </categorycollection>
</datadefinition>

Presentation Description

The following is the contents of the presentation description XML string for this chart.

Xml Copy Code
<Chart Palette="None" PaletteCustomColors="97,142,206; 209,98,96; 168,203,104; 142,116,178; 93,186,215; 255,155,83; 148,172,215; 217,148,147; 189,213,151; 173,158,196; 145,201,221; 255,180,138">
  <Series>
    <Series ShadowOffset="0" IsValueShownAsLabel="true" Font="{0}, 9.5px" LabelForeColor="59, 59, 59" CustomProperties="PieLabelStyle=Inside, PieDrawingStyle=Default" ChartType="pie">
      <SmartLabelStyle Enabled="True" />
    </Series>
  </Series>
  <ChartAreas>
    <ChartArea>
      <Area3DStyle Enable3D="false" />
    </ChartArea>
  </ChartAreas>
  <Legends>
    <Legend Alignment="Center" LegendStyle="Table" Docking="right" Font="{0}, 11px" ShadowColor="0, 0, 0, 0" ForeColor="59, 59, 59" />
  </Legends>
  <Titles>
    <Title Alignment="TopLeft" DockingOffset="-3" Font="{0}, 13px" ForeColor="0, 0, 0"></Title>
  </Titles>
</Chart>

Funnel Chart

The following is a funnel chart that shows the sum of estimated revenue in each stage of the sales pipeline. This is one of the default charts available in Microsoft Dynamics CRM for the Opportunity entity.

Sample funnel chart: Sales Pipeline

Data Description

The following is the contents of the data description XML string for this chart.

Xml Copy Code
<datadefinition>
  <fetchcollection>
    <fetch mapping="logical" count="10" aggregate="true">
      <entity name="opportunity">
        <attribute name="estimatedvalue" aggregate="sum" alias="sum_estimatedvalue" />
        <attribute name="stepname" groupby="true" alias="stepname" />
        <order alias="stepname" descending="false" />
      </entity>
    </fetch>
  </fetchcollection>
  <categorycollection>
    <category>
      <measurecollection>
        <measure alias="sum_estimatedvalue" />
      </measurecollection>
    </category>
  </categorycollection>
</datadefinition>

Presentation Description

The following is the contents of the presentation description XML string for this chart.

Xml Copy Code
<Chart Palette="None" PaletteCustomColors="55,118,193; 197,56,52; 149,189,66; 117,82,160; 49,171,204; 255,136,35; 97,142,206; 209,98,96; 168,203,104; 142,116,178; 93,186,215; 255,155,83">
  <Series>
    <Series ShadowOffset="0" IsValueShownAsLabel="true" Font="{0}, 9.5px" LabelForeColor="59, 59, 59" ChartType="Funnel" CustomProperties="FunnelLabelStyle=Outside, FunnelNeckHeight=0, FunnelPointGap=1, FunnelNeckWidth=5">
      <SmartLabelStyle Enabled="True" />
    </Series>
  </Series>
  <ChartAreas>
    <ChartArea>
      <Area3DStyle Enable3D="True" />
    </ChartArea>
  </ChartAreas>
  <Legends>
    <Legend Alignment="Center" LegendStyle="Table" Docking="right" Font="{0}, 11px" ShadowColor="0, 0, 0, 0" ForeColor="59, 59, 59" />
  </Legends>
  <Titles>
    <Title Alignment="TopLeft" DockingOffset="-3" Font="Segeo UI, 13px" ForeColor="0, 0, 0"></Title>
  </Titles>
</Chart>

Multi-Series Chart

The following is a multi-series chart that shows the estimated vs. actual revenue closed by month. You can use the chart designer in Microsoft Dynamics CRM or methods described in the Microsoft Dynamics CRM SDK to create these types of charts.

A multi-series chart has multiple <measurecollection> elements in the data description, each mapping to the corresponding <Series> element in the presentation description XML string.

A multi-series chart has multiple <Series> elements in the presentation description; the number of <Series> elements is the same as the number of <measurecollection> elements in the data description XML string.

Sample multi-series chart

Data Description

The following is the contents of the data description XML string for this chart.

Xml Copy Code
<datadefinition>
  <fetchcollection>
    <fetch mapping="logical" aggregate="true">
      <entity name="opportunity">
        <attribute name="estimatedvalue" aggregate="sum" alias="estvalue" />
        <attribute name="actualvalue" aggregate="sum" alias="actvalue" />
        <attribute name="actualclosedate" groupby="true" alias="actclosedate" dategrouping="month" />
      </entity>
    </fetch>
  </fetchcollection>
  <categorycollection>
    <category>
      <measurecollection>
        <measure alias="estvalue" />
      </measurecollection>
      <measurecollection>
        <measure alias="actvalue" />
      </measurecollection>
    </category>
  </categorycollection>
</datadefinition>

Presentation Description

The following is the contents of the presentation description XML string for this chart.

Xml Copy Code
<Chart Palette="BrightPastel">
  <Series>
    <Series _Template_="All" Color="112, 162, 213" BorderColor="164, 164, 164" BorderDashStyle="Solid" BorderWidth="1" ShadowColor="128, 128, 128, 128" ShadowOffset="1" IsValueShownAsLabel="true" Font="{0}, 6.75pt, GdiCharSet=0" BackGradientStyle="TopBottom" BackSecondaryColor="0, 102, 153" LabelForeColor="100, 100, 100" ChartType="Column">
      <SmartLabelStyle Enabled="True" />
      <Points />
    </Series>
    <Series _Template_="All" Color="204,0,0" BorderColor="204,0,0" BorderDashStyle="Solid" BorderWidth="1" ShadowColor="128, 128, 128, 128" ShadowOffset="1" IsValueShownAsLabel="true" Font="{0}, 6.75pt, GdiCharSet=0" BackSecondaryColor="0, 102, 153" LabelForeColor="100, 100, 100" ChartType="Column">
      <SmartLabelStyle Enabled="True" />
      <Points />
    </Series>
  </Series>
  <ChartAreas>
    <ChartArea _Template_="All" BackColor="White" BorderColor="26, 59, 105" BorderWidth="0" BorderDashStyle="Solid">
      <AxisY LineColor="204, 204, 204" TitleFont="{0}, 8pt, GdiCharSet=0" TitleForeColor="100, 100, 100" LabelAutoFitMaxFontSize="7" LabelAutoFitMinFontSize="7">
        <MajorTickMark LineColor="Gray" />
        <MajorGrid Enabled="false" />
        <LabelStyle Font="{0}, 6.75pt, GdiCharSet=0" ForeColor="100, 100, 100" />
      </AxisY>
      <AxisX LineColor="204, 204, 204" TitleFont="{0}, 8pt, GdiCharSet=0" TitleForeColor="100, 100, 100" LabelAutoFitMaxFontSize="7" LabelAutoFitMinFontSize="7">
        <MajorTickMark LineColor="Gray" />
        <MajorGrid Enabled="false" />
        <LabelStyle Font="{0}, 6.75pt, GdiCharSet=0" ForeColor="100, 100, 100" />
      </AxisX>
      <Area3DStyle LightStyle="Realistic" IsClustered="True" />
    </ChartArea>
  </ChartAreas>
  <Legends>
    <Legend _Template_="All" Alignment="Center" LegendStyle="Table" Docking="Bottom" IsEquallySpacedItems="True" BackColor="White" BorderColor="228, 228, 228" BorderWidth="0" Font="{0}, 8pt, GdiCharSet=0" ShadowColor="0, 0, 0, 0" ForeColor="100, 100, 100"></Legend>
  </Legends>
  <Titles>
    <Title _Template_="All" Font="{0}, 9pt, style=Bold, GdiCharSet=0" ForeColor="100, 100, 100"></Title>
  </Titles>
  <BorderSkin PageColor="Control" BackColor="CornflowerBlue" BackSecondaryColor="CornflowerBlue" />
</Chart>

Comparison Chart (Stacked Chart)

The following is a comparison chart that shows the number of activities by type and priority. You can use the chart designer in Microsoft Dynamics CRM or methods described in the Microsoft Dynamics CRM SDK to create these types of charts.

A comparison chart has two groupby clauses in the data description XML.

Sample comparison chart

Data Description

The following is the contents of the data description XML string for this chart.

Xml Copy Code
<datadefinition>
  <fetchcollection>
    <fetch mapping="logical" aggregate="true">
      <entity name="activitypointer">
        <attribute alias="aggregate_column" name="subject" aggregate="count" />
        <attribute groupby="true" alias="groupby_column" name="activitytypecode" />
        <attribute groupby="true" alias="groupby_priority" name="prioritycode" />
      </entity>
    </fetch>
  </fetchcollection>
  <categorycollection>
    <category>
      <measurecollection>
        <measure alias="aggregate_column" />
      </measurecollection>
    </category>
  </categorycollection>
</datadefinition>

Presentation Description

The following is the contents of the presentation description XML string for this chart.

Xml Copy Code
<Chart Palette="None" PaletteCustomColors="41,88,145; 147, 42, 39; 112,142,50; 88,62,120; 37,128,153; 194,103,28; 74,107,155; 155,77,73; 126,153,79; 107,88,134; 71,140,162; 199,118,64; 112,131,162;164,112,111; 143,161,115;131,120,148;111,152,167; 195,137,106">
  <Series>
    <Series Name="Series1" ChartType="StackedColumn" ChartArea="ChartArea1" IsValueShownAsLabel="True" Font="{0}, 9.5px" LabelForeColor="59, 59, 59" CustomProperties="MinPixelPointWidth=5, PointWidth=0.75, PixelPointWidth=26, MaxPixelPointWidth=40"></Series>
  </Series>
  <ChartAreas>
    <ChartArea BorderColor="Transparent" BorderDashStyle="Solid" Name="ChartArea1">
      <AxisY TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount">
        <MajorGrid LineColor="239, 242, 246" />
        <MajorTickMark LineColor="165, 172, 181" />
        <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
      </AxisY>
      <AxisX TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount">
        <MajorGrid LineColor="Transparent" />
        <MajorTickMark LineDashStyle="NotSet" />
        <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
      </AxisX>
    </ChartArea>
  </ChartAreas>
  <Legends>
    <Legend Alignment="Center" LegendStyle="Table" Docking="Bottom" IsEquallySpacedItems="True" Font="{0}, 11px" ShadowColor="0, 0, 0, 0" ForeColor="59,59,59"></Legend>
  </Legends>
  <Titles>
    <Title Alignment="TopLeft" Name="Title1" DockingOffset="-3" Font="{0}, 13px" ForeColor="59, 59, 59"></Title>
  </Titles>
</Chart>

Comparison Chart (100% Stacked Chart)

The following is a comparison chart that shows the number of cases opened on any date, grouped by priority. You can use the chart designer in Microsoft Dynamics CRM or methods described in the Microsoft Dynamics CRM SDK to create these types of charts.

A comparison chart has two groupby clauses in the data description XML.

Sample100% stacked chart

Data Description

The following is the contents of the data description XML string for this chart.

Xml Copy Code
<datadefinition>
      <fetchcollection>
        <fetch mapping="logical" aggregate="true">
          <entity name="incident">
            <order alias="groupby_column" descending="false" />
            <attribute alias="aggregate_column" name="incidentid" aggregate="count" />
            <attribute groupby="true" alias="groupby_column" dategrouping="day" name="createdon" />
            <attribute groupby="true" alias="groupby_priority" name="prioritycode" />
          </entity>
        </fetch>
      </fetchcollection>
      <categorycollection>
        <category>
          <measurecollection>
            <measure alias="aggregate_column" />
          </measurecollection>
        </category>
      </categorycollection>
    </datadefinition>

Presentation Description

The following is the contents of the presentation description XML string for this chart.

Xml Copy Code
<Chart Palette="None" PaletteCustomColors="149,189,66; 197,56,52; 55,118,193; 117,82,160; 49,171,204; 255,136,35; 168,203,104; 209,98,96; 97,142,206; 142,116,178; 93,186,215; 255,155,83">
      <Series>
        <Series ChartType="StackedBar100" Font="{0}, 9.5px" LabelForeColor="59, 59, 59" CustomProperties="PointWidth=0.75, MaxPixelPointWidth=40">
          <SmartLabelStyle Enabled="True" />
        </Series>
      </Series>
      <ChartAreas>
        <ChartArea BorderColor="White" BorderDashStyle="Solid">
          <AxisY LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount">
            <MajorGrid LineColor="239, 242, 246" />
            <MajorTickMark LineColor="165, 172, 181" />
            <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
          </AxisY>
          <AxisX LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount">
            <MajorGrid Enabled="False" />
            <MajorTickMark Enabled="False" />
            <LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" />
          </AxisX>
        </ChartArea>
      </ChartAreas>
      <Titles>
        <Title Alignment="TopLeft" DockingOffset="-3" Font="{0}, 13px" ForeColor="0, 0, 0" />
      </Titles>
    </Chart>

See Also

Reference

Visualization data description schema

Concepts

Create a visualization (chart)
View data with visualizations (charts)

Other Resources

Customize visualizations and dashboards
Sample code for charts (visualizations)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample code for charts (visualizations)

This section contains code examples that demonstrate how to use visualization entities.

In This Section

Sample: Create, retrieve, update, and delete a chart

Sample: Retrieve all charts attached to an entity

Sample: Assign a chart to another user

Related Sections

Actions on visualizations (charts)

View data with visualizations (charts)

Understand charts: Underlying data and chart representation

Create a visualization (chart)

Sample charts

SavedQueryVisualization (system chart) entity messages and methods

UserQueryVisualization (user chart) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete a chart
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\VisualizationsAndDashboards\CRUDVisualizations.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create, retrieve, update, and delete an organization-owned visualization. This sample uses the following common methods:

  • IOrganizationService.Create
  • IOrganizationService.Retrieve
  • IOrganizationService.Update
  • IOrganizationService.Delete

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to create retrieve, update, and delete an
    /// organization-owned visualization. The visualization will be attached
    /// to the 'Opportunity' entity. As part of updating the visualization,
    /// we will also set it to be the default visualization for the Opportunity
    /// entity.
    /// </summary>
    public class CRUDVisualization
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _orgOwnedVisualizationId;
        private Guid _accountId;
        private Guid[] _opportunitiyIds;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Initiate the method to create any data that this sample requires.
        /// Create an organization-owned visualization.
        /// Retrieve the visualization.
        /// Update the visualization; update the name and set it as the default
        /// visualization for the Opportunity entity.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

       public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    // Create a visualization

                    // Set The presentation XML string.
                    string presentationXml = @"
                    <Chart Palette='BrightPastel'>
                        <Series>
                            <Series _Template_='All' ShadowOffset='2'
                                BorderColor='64, 64, 64' BorderDashStyle='Solid'
                                BorderWidth='1' IsValueShownAsLabel='true'
                                Font='Tahoma, 6.75pt, GdiCharSet=0'
                                LabelForeColor='100, 100, 100'
                                CustomProperties='FunnelLabelStyle=Outside'
                                ChartType='Funnel'>
                                <SmartLabelStyle Enabled='True' />
                                <Points />
                            </Series>
                         </Series>
                        <ChartAreas>
                            <ChartArea _Template_='All' BackColor='Transparent'
                                BorderColor='Transparent'
                                BorderDashStyle='Solid'>
                                <Area3DStyle Enable3D='True'
                                    IsClustered='True'/>
                            </ChartArea>
                        </ChartAreas>
                        <Legends>
                            <Legend _Template_='All' Alignment='Center'
                                LegendStyle='Table' Docking='Bottom'
                                IsEquallySpacedItems='True' BackColor='White'
                                BorderColor='228, 228, 228' BorderWidth='0'
                                Font='Tahoma, 8pt, GdiCharSet=0'
                                ShadowColor='0, 0, 0, 0'
                                ForeColor='100, 100, 100'>
                            </Legend>
                        </Legends>
                        <Titles>
                            <Title _Template_='All'
                                Font='Tahoma, 9pt, style=Bold, GdiCharSet=0'
                                ForeColor='102, 102, 102'>
                            </Title>
                        </Titles>
                        <BorderSkin PageColor='Control'
                            BackColor='CornflowerBlue'
                            BackSecondaryColor='CornflowerBlue' />
                    </Chart>
                    ";

                    // Set the data XML string.
                    string dataXml = @"
                    <datadefinition>
                        <fetchcollection>
                            <fetch mapping='logical' count='10'
                                aggregate='true'>
                                <entity name='opportunity'>
                                    <attribute name='actualvalue_base'
                                        aggregate='sum'
                                        alias='sum_actualvalue_base' />
                                    <attribute name='stepname' groupby='true'
                                        alias='stepname' />
                                    <order alias='stepname' descending='false'/>
                                </entity>
                            </fetch>
                        </fetchcollection>
                        <categorycollection>
                            <category>
                                <measurecollection>
                                    <measure alias='sum_actualvalue_base'/>
                                </measurecollection>
                            </category>
                        </categorycollection>
                    </datadefinition>
                    ";
                    // Create the visualization entity instance.
                    SavedQueryVisualization newOrgOwnedVisualization = new SavedQueryVisualization
                    {
                        Name = "Sample Visualization",
                        Description = "Sample organization-owned visualization.",
                        PresentationDescription = presentationXml,
                        DataDescription = dataXml,
                        PrimaryEntityTypeCode = Opportunity.EntityLogicalName,
                        IsDefault = false
                    };
                    _orgOwnedVisualizationId = _serviceProxy.Create(newOrgOwnedVisualization);
                    Console.WriteLine("Created {0}.", newOrgOwnedVisualization.Name);

                    // Retrieve the visualization
                    SavedQueryVisualization retrievedOrgOwnedVisualization = (SavedQueryVisualization)_serviceProxy.Retrieve(SavedQueryVisualization.EntityLogicalName, _orgOwnedVisualizationId, new ColumnSet(true));
                    Console.WriteLine("Retrieved the visualization.");

                    // Update the retrieved visualization
                    // 1.  Update the name.
                    // 2.  Update the data description string.

                    string newDataXml = @"<datadefinition>
                                        <fetchcollection>
                                            <fetch mapping='logical' count='10'
                                                aggregate='true'>
                                                <entity name='opportunity'>
                                                    <attribute name='estimatedvalue_base'
                                                        aggregate='sum'
                                                        alias='sum_estimatedvalue_base' />
                                                    <attribute name='name'
                                                        groupby='true'
                                                        alias='name' />
                                                    <order alias='name'
                                                        descending='false'/>
                                                </entity>
                                            </fetch>
                                        </fetchcollection>
                                        <categorycollection>
                                            <category>
                                                <measurecollection>
                                                    <measure alias='sum_estimatedvalue_base'/>
                                                </measurecollection>
                                            </category>
                                        </categorycollection>
                                    </datadefinition>";

                    retrievedOrgOwnedVisualization.Name = "Updated Sample Visualization";
                    retrievedOrgOwnedVisualization.DataDescription = newDataXml;

                    _serviceProxy.Update(retrievedOrgOwnedVisualization);

                    // Publish the changes to the solution. This step is only required
                    // for organization-owned visualizations.
                    PublishAllXmlRequest updateRequest = new PublishAllXmlRequest();
                    _serviceProxy.Execute(updateRequest);

                    Console.WriteLine("Updated the visualization.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Create an account and few opportuntiy records for sample data
        /// for the chart.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a sample account
            Account setupAccount = new Account { Name = "Sample Account" };
            _accountId = _serviceProxy.Create(setupAccount);
            Console.WriteLine("Created {0}.", setupAccount.Name);

            // Create some oppotunity records for the visualization
            Opportunity[] setupOpportunities = new Opportunity[]
                {
                    new Opportunity
                    {
                        Name = "Sample Opp 01",
                        EstimatedValue = new Money(120000.00m),
                        ActualValue = new Money(100000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 02",
                        EstimatedValue = new Money(240000.00m),
                        ActualValue = new Money(200000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 03",
                        EstimatedValue = new Money(360000.00m),
                        ActualValue = new Money(300000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 04",
                        EstimatedValue = new Money(500000.00m),
                        ActualValue = new Money(500000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 05",
                        EstimatedValue = new Money(110000.00m),
                        ActualValue = new Money(60000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 06",
                        EstimatedValue = new Money(90000.00m),
                        ActualValue = new Money(70000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 07",
                        EstimatedValue = new Money(620000.00m),
                        ActualValue = new Money(480000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 08",
                        EstimatedValue = new Money(440000.00m),
                        ActualValue = new Money(400000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 09",
                        EstimatedValue = new Money(410000.00m),
                        ActualValue = new Money(400000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 10",
                        EstimatedValue = new Money(650000.00m),
                        ActualValue = new Money(650000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    }
                };

            _opportunitiyIds = (from opp in setupOpportunities
                                select _serviceProxy.Create(opp)).ToArray();

            Console.WriteLine("Created few opportunity records for {0}.", setupAccount.Name);

            return;
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(SavedQueryVisualization.EntityLogicalName,
                    _orgOwnedVisualizationId);
                _serviceProxy.Delete("account", _accountId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CRUDVisualization app = new CRUDVisualization();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Reference

Create
Update
Retrieve

Concepts

Actions on visualizations (charts)
Create a visualization (chart)

Other Resources

Helper code: ServerConnection class
Sample code for charts (visualizations)
Sample: Retrieve all charts attached to an entity
IOrganizationService
PublishAllXmlRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve all charts attached to an entity
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\VisualizationsAndDashboards\RetrieveVisualizationsAttachedToAnEntity.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve all the organization-owned visualizations attached to an entity by using the IOrganizationService.RetrieveMultiple method.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve organization-owned visualizations attached to
    /// an entity. This sample specifically retrieves organization-owned visualizations
    /// that are attached to the 'Account' entity.
    /// </summary>
    public class RetrieveVisualizationsAttachedToAnEntity
    {
        #region Class Level Members
        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Retrieve organization-owned visualizations.
        /// Optionally delete any entity records that were created for this sample.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

       public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Create a query for retrieving all organization-owned visualizations
                    // that are attached to the account entity.
                    QueryExpression mySavedQuery = new QueryExpression
                    {
                        EntityName = SavedQueryVisualization.EntityLogicalName,
                        ColumnSet = new ColumnSet("name"),
                        Criteria = new FilterExpression
                        {
                            Conditions =
                         {
                            new ConditionExpression
                               {
                                  AttributeName = "primaryentitytypecode",
                                  Operator = ConditionOperator.Equal,
                                  Values =  {Account.EntityLogicalName}
                               }
                         }
                        }
                    };

                    // Retrieve a collection of organization-owned visualizations that are attached to the account entity.
                    DataCollection<Entity> results = _serviceProxy.RetrieveMultiple(mySavedQuery).Entities;

                    // Display the names of the retrieved organization-owned visualizations.
                    Console.WriteLine("Retrieved the following visualizations for the Account entity:");
                    foreach (Entity entity in results)
                    {
                        SavedQueryVisualization orgVisualization = (SavedQueryVisualization)entity;
                        Console.WriteLine("{0}", orgVisualization.Name);
                    }
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #endregion How To Sample Code

        #region Main
       /// <summary>
       /// Main. Runs the sample and provides error output.
       /// <param name="args">Array of arguments to Main method.</param>
       /// </summary>
       static public void Main(string[] args)
       {
           try
           {
               // Obtain the target organization's Web address and client logon
               // credentials from the user.
               ServerConnection serverConnect = new ServerConnection();
               ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

               RetrieveVisualizationsAttachedToAnEntity app = new RetrieveVisualizationsAttachedToAnEntity();
               app.Run(config, true);

           }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
           // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
           // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
               Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Reference

RetrieveMultiple

Concepts

View data with visualizations (charts)

Other Resources

Helper code: ServerConnection class
Sample code for charts (visualizations)
Sample: Assign a chart to another user
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Assign a chart to another user
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\VisualizationsAndDashboards\AssignVisualizationToUser.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to assign a user-owned visualization to another user using the AssignRequest message.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using System.Xml.Linq;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

using System.DirectoryServices;
using System.Threading;

namespace Microsoft.Crm.Sdk.Samples
{
    public class AssignVisualizationToUser
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _userOwnedVisualizationId;
        private Guid _accountId;
        private Guid[] _opportunitiyIds;
        private Guid _otherUserId;

        #endregion Class Level Members

        #region How To Sample Code

        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

       public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    AssignRequest assignRequest = new AssignRequest
                    {
                        Assignee = new EntityReference
                        {
                            LogicalName = SystemUser.EntityLogicalName,
                            // Here we could assign the visualization to the newly created user
                            Id = _otherUserId
                        },

                        Target = new EntityReference
                        {
                            LogicalName = UserQueryVisualization.EntityLogicalName,
                            Id = _userOwnedVisualizationId
                        }
                    };
                    _serviceProxy.Execute(assignRequest);

                    Console.WriteLine("The user visualization has been assigned to Kevin Cook.");

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Creates the visualization.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create a sample account
            Account setupAccount = new Account { Name = "Sample Account" };
            _accountId = _serviceProxy.Create(setupAccount);
            Console.WriteLine("Created {0}.", setupAccount.Name);

            // Create some oppotunity records for the visualization
            Opportunity[] setupOpportunities = new Opportunity[]
                {
                    new Opportunity
                    {
                        Name = "Sample Opp 01",
                        EstimatedValue = new Money(120000.00m),
                        ActualValue = new Money(100000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 02",
                        EstimatedValue = new Money(240000.00m),
                        ActualValue = new Money(200000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 03",
                        EstimatedValue = new Money(360000.00m),
                        ActualValue = new Money(300000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 04",
                        EstimatedValue = new Money(500000.00m),
                        ActualValue = new Money(500000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 05",
                        EstimatedValue = new Money(110000.00m),
                        ActualValue = new Money(60000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 06",
                        EstimatedValue = new Money(90000.00m),
                        ActualValue = new Money(70000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 07",
                        EstimatedValue = new Money(620000.00m),
                        ActualValue = new Money(480000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 08",
                        EstimatedValue = new Money(440000.00m),
                        ActualValue = new Money(400000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 09",
                        EstimatedValue = new Money(410000.00m),
                        ActualValue = new Money(400000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    },
                    new Opportunity
                    {
                        Name = "Sample Opp 10",
                        EstimatedValue = new Money(650000.00m),
                        ActualValue = new Money(650000.00m),
                        CustomerId = new EntityReference(Account.EntityLogicalName,
                            _accountId),
                        StepName = "Open"
                    }
                };

            _opportunitiyIds = (from opp in setupOpportunities
                                select _serviceProxy.Create(opp)).ToArray();

            Console.WriteLine("Created few opportunity records for {0}.", setupAccount.Name);

            // Create a visualization

            // Set The presentation XML string.
            string presentationXml = @"
                    <Chart Palette='BrightPastel'>
                        <Series>
                            <Series _Template_='All' ShadowOffset='2'
                                BorderColor='64, 64, 64' BorderDashStyle='Solid'
                                BorderWidth='1' IsValueShownAsLabel='true'
                                Font='Tahoma, 6.75pt, GdiCharSet=0'
                                LabelForeColor='100, 100, 100'
                                CustomProperties='FunnelLabelStyle=Outside'
                                ChartType='Funnel'>
                                <SmartLabelStyle Enabled='True' />
                                <Points />
                            </Series>
                         </Series>
                        <ChartAreas>
                            <ChartArea _Template_='All' BackColor='Transparent'
                                BorderColor='Transparent'
                                BorderDashStyle='Solid'>
                                <Area3DStyle Enable3D='True'
                                    IsClustered='True'/>
                            </ChartArea>
                        </ChartAreas>
                        <Legends>
                            <Legend _Template_='All' Alignment='Center'
                                LegendStyle='Table' Docking='Bottom'
                                IsEquallySpacedItems='True' BackColor='White'
                                BorderColor='228, 228, 228' BorderWidth='0'
                                Font='Tahoma, 8pt, GdiCharSet=0'
                                ShadowColor='0, 0, 0, 0'
                                ForeColor='100, 100, 100'>
                            </Legend>
                        </Legends>
                        <Titles>
                            <Title _Template_='All'
                                Font='Tahoma, 9pt, style=Bold, GdiCharSet=0'
                                ForeColor='102, 102, 102'>
                            </Title>
                        </Titles>
                        <BorderSkin PageColor='Control'
                            BackColor='CornflowerBlue'
                            BackSecondaryColor='CornflowerBlue' />
                    </Chart>
                    ";

            // Set the data XML string.
            string dataXml = @"
                    <datadefinition>
                        <fetchcollection>
                            <fetch mapping='logical' count='10'
                                aggregate='true'>
                                <entity name='opportunity'>
                                    <attribute name='actualvalue_base'
                                        aggregate='sum'
                                        alias='sum_actualvalue_base' />
                                    <attribute name='stepname' groupby='true'
                                        alias='stepname' />
                                    <order alias='stepname' descending='false'/>
                                </entity>
                            </fetch>
                        </fetchcollection>
                        <categorycollection>
                            <category>
                                <measurecollection>
                                    <measure alias='sum_actualvalue_base'/>
                                </measurecollection>
                            </category>
                        </categorycollection>
                    </datadefinition>
                    ";

            // Create the visualization entity instance.
            UserQueryVisualization newUserOwnedVisualization = new UserQueryVisualization
            {
                Name = "Sample User Visualization",
                Description = "Sample user-owned visualization.",
                PresentationDescription = presentationXml,
                DataDescription = dataXml,
                PrimaryEntityTypeCode = Opportunity.EntityLogicalName,
            };
            _userOwnedVisualizationId = _serviceProxy.Create(newUserOwnedVisualization);

            Console.WriteLine("Created {0}.", newUserOwnedVisualization.Name);

            // Create another user to whom the visualization will be assigned.
            _otherUserId = SystemUserProvider.RetrieveSalesManager(_serviceProxy);

        }

        /// <summary>
        /// Deletes the entity record that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the entity created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                // Delete action doesn't work on the UserQueryVisualization instance if it is assigned
                // to a user other than current user.
                // So as a workaround, we are impersonating the actual owner of
                // the UserQueryVisualization instance to complete the delete action.
                // To impersonate another user, set the OrganizationServiceProxy.CallerId
                // property to the ID of the other user.
                _serviceProxy.CallerId = _otherUserId;

                _serviceProxy.Delete(UserQueryVisualization.EntityLogicalName, _userOwnedVisualizationId);
                _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                AssignVisualizationToUser app = new AssignVisualizationToUser();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

View data with visualizations (charts)

Other Resources

Helper code: ServerConnection class
Sample code for charts (visualizations)
AssignRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SavedQueryVisualization (system chart) entity messages and methods

The saved query visualization (system chart) entity represents a chart that is owned by an organization. The schema name for this entity is SavedQueryVisualization. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
CreateRequest | Creates an organization-owned chart. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes an organization-owned chart. You can also call the IOrganizationService.Delete method.
RetrieveLocLabelsRequest | Retrieves localized labels for the SavedQueryVisualization.Name and SavedQueryVisualization.Description attributes.
RetrieveRequest | Retrieves an organization-owned chart. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of organization-owned charts. You can also call the IOrganizationService.RetrieveMultiple method.
RetrieveUnpublishedRequest | Retrieves an unpublished organization-owned chart.
RetrieveUnpublishedMultipleRequest | Retrieves a collection of unpublished organization-owned charts.
SetLocLabelsRequest | Sets localized labels for the SavedQueryVisualization.Name and SavedQueryVisualization.Description attributes.
UpdateRequest | Updates a user chart. You can also call the IOrganizationService.Update method.

See Also

Concepts

SavedQueryVisualization (system chart) entity privileges
View data with visualizations (charts)
UserQueryVisualization (user chart) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserQueryVisualization (user chart) entity messages and methods

A user query visualization (user chart) is a chart that is owned by a user or team. The schema name for this entity is UserQueryVisualization. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a user-owned chart to another user or a team.
CreateRequest | Creates a user-owned chart. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a user-owned chart. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a user-owned chart with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a user-owned chart previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a user-owned chart. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of user-owned charts. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a user-owned chart.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a user-owned chart, and their access rights to the user-owned chart.
RevokeAccessRequest | Removes all access to a user-owned chart for the specified security principal (user or team).
UpdateRequest | Updates a user-owned chart. You can also call the IOrganizationService.Update method.

See Also

Concepts

View data with visualizations (charts)
UserQueryVisualization (user chart) entity privileges
View data with visualizations (charts)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Analyze data with dashboards

The dashboard entities in Microsoft Dynamics CRM enable you to present data from various charts, grids, IFRAMEs, or web resources simultaneously. Dashboards allow you to compare and analyze various pieces of customer information, and give you data snapshots.

Types of dashboards

In Microsoft Dynamics CRM, there are two types of dashboards: organization-owned dashboards and user-owned dashboards.

  • Organization-owned dashboard. An organization-owned dashboard is represented by the SystemForm entity, and can’t be assigned or shared. These dashboards are solution-aware entities in CRM. When you perform an update operation on this entity, you must publish the changes for the updates to be available across the organization. When you publish customizations using the PublishAllXmlRequest message, the newly-created organization-owned dashboards are also published and become available across the organization. Alternatively, you can publish the changes done to a specific dashboard by using the PublishXmlRequest message, and specifying the dashboard ID as the parameter in the request message.
  • User-owned dashboard. A user-owned dashboard is represented by the UserForm entity, can be assigned and shared with other users, and can be viewed by other users depending on the dashboard’s access privileges.

See Also

Reference

Visualization data description schema
<FormXml> (FormXml)

Concepts

Understand dashboards: Dashboard components and FormXML
Actions on dashboards
Create a dashboard
Sample dashboards

Other Resources

Dashboard entities
Sample: Create, retrieve, update, and delete a dashboard
Sample: Assign a user-owned dashboard to another user
Customize visualizations and dashboards

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Understand dashboards: Dashboard components and FormXML

Dashboards are one of the different types of forms in Microsoft Dynamics CRM. You can use the SystemForm.Type or UserForm.Type attribute to determine whether the form is a dashboard. A form of dashboard type has the property value of ”0”.

The definition of the form content and presentation is stored in the FormXML. More information: Form XML schema

For sample FormXML strings for different types of dashboards, see Sample dashboards.

In This Topic

Dashboard components

Dashboard components and FormXML elements

FormXML elements supported for dashboards

Set the number of dashboard controls

Dashboard components

A dashboard can contain charts, grids, IFRAMEs, or web resources. By default, a single dashboard can contain up to six of these components.

In the Microsoft Dynamics CRM on-premises version, you can change the number of components to be displayed on a dashboard using Windows PowerShell. More information: Set the Number of Dashboard Controls

Charts

An organization-owned dashboard can contain only organization-owned charts. However, a user-owned dashboard can contain user-owned and organization-owned charts. More information: View data with visualizations (charts)

Grids

Grids fetch data from queries (views) in Microsoft Dynamics CRM. An organization-owned dashboard can contain only the grids that fetch data from saved queries. However, a user-owned dashboard can contain grids that fetch data from user and saved queries. More information: SavedQuery (view) entity messages and methods

IFRAMEs

When you add an IFRAME to an organization-owned dashboard, you can specify whether to restrict or allow cross-frame scripting. To do so, you have to use the <Security> (FormXml) parameter in the IFRAME control in the FormXML. However, for user-owned dashboards, cross-frame scripting for IFRAMEs is restricted, and you can’t change it. If you attempt to create a user-owned dashboard that contains an IFRAME with cross-frame scripting enabled, an error message will be displayed. More information: Use an IFRAME and web resource controls on a form.

Web resources

Only form-enabled web resources can be included in a dashboard. Although this restriction is applicable when you are adding a web resource using the Dashboard designer in the web application, there is no such restriction applied when adding a web resource to a dashboard using the SDK. More information: Web resources for Microsoft Dynamics CRM

Dashboard components and FormXML elements

The dashboard components are displayed in Microsoft Dynamics CRM based on the values specified in the FormXML. The following image shows an example of a dashboard. Each dashboard can include multiple tabs. Tabs are a vertical stack separating the body of the dashboard, and can be expanded or collapsed. More information: <tabs> (FormXml). A tab can contain multiple sections. Sections enable for grouping and layout of dashboard components. More information: <sections> (FormXml)

Dashboard components layout

FormXML elements supported for dashboards

Although dashboards are a type of forms, not all FormXML elements and attributes are supported by dashboards. The following table provides information about the FormXML elements, child elements, and attributes supported by dashboards. More information: Form XML reference

For sample FormXML for different types of dashboards, see Sample dashboards.

Element Child Elements Element attributes

<form> (FormXml)

<tabs> (FormXml)

-

<tabs> (FormXml)

<tab> (FormXml)

-

<tab> (FormXml)

  • <labels> (FormXml)
  • <columns> (FormXml)

  • id
  • name
  • expanded
  • verticallayout
  • showlabel
  • locklevel

<labels> (FormXml)

<label> (FormXml)

-

<label> (FormXml)

-

  • description
  • languagecode

<columns> (FormXml)

<column> (FormXml)

-

<column> (FormXml)

<sections> (FormXml)

width

<sections> (FormXml)

<section> (FormXml)

addedby

<section> (FormXml)

  • <labels> (FormXml)
  • <rows> (FormXml)
  • id
  • name
  • showlabel
  • showbar
  • columns

<rows> (FormXml)

<row> (FormXml)

addedby

<row> (FormXml)

<cell> (FormXml)

addedby

<cell> (FormXml)

  • <labels> (FormXml)
  • <control> (FormXml)
  • auto
  • addedby
  • id
  • showlabel
  • rowspan
  • colspan

<control> (FormXml)

<parameters> (FormXml)

  • id
  • classid

<parameters> (FormXml)

  • <Url> (FormXml)
  • <PassParameters> (FormXml)
  • <Security> (FormXml)
  • <Scrolling> (FormXml)
  • <Border> (FormXml)
  • <ViewIds> (FormXml)
  • <ViewId> (FormXml)
  • <IsUserView> (FormXml)
  • <IsUserChart> (FormXml)
  • <TargetEntityType> (FormXml)
  • <AutoExpand> (FormXml)
  • <RecordsPerPage> (FormXml)
  • <EnableQuickFind> (FormXml)
  • <EnableJumpBar> (FormXml)
  • <EnableChartPicker> (FormXml)
  • <EnableViewPicker> (FormXml)
  • <ChartGridMode> (FormXml)
  • <VisualizationId> (FormXml)

-

Set the number of dashboard controls

You can use Windows PowerShell to adjust the number of dashboard controls as described here. Alternatively, you can use the Deployment Web service. The maximum value is 20. For more information, see Introduction to the deployment web service to learn how to update the MaximumControlsLimit property.

To retrieve and set the dashboard limit

  1. Open a Windows PowerShell command window.

  2. Add the Microsoft Dynamics CRM Windows PowerShell snap-in:

    Windows PowerShell Copy Code
    Add-PSSnapin Microsoft.Crm.PowerShell

  3. Retrieve the current setting:

    Windows PowerShell Copy Code
    $setting = Get-CrmSetting -SettingType DashboardSettings

  4. Modify the current setting:

    Windows PowerShell Copy Code
    $setting.MaximumControlsLimit = 5
    Windows PowerShell Copy Code
    Set-CrmSetting -Setting $setting

See Also

Concepts

Analyze data with dashboards
Actions on dashboards
Create a dashboard

Other Resources

Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Actions on dashboards

You can perform actions such as create, retrieve, update, or delete, on organization-owned and user-owned dashboards.

Actions on an Organization-Owned Dashboard

To perform the following actions on an organization-owned dashboard (SystemForm), you must have the System Administrator or the System Customizer role assigned to your account in Microsoft Dynamics CRM:

  • Create, retrieve, update, and delete. You can create or update an organization-owned dashboard by using the Microsoft Dynamics CRM SDK or by customizing the entity form. For detailed information about creating a dashboard, see Create a dashboard.
  • Set an organization-owned dashboard as the default dashboard for an organization by setting the SystemForm.IsDefault attribute value to true while creating or updating the dashboard.
    Important
    Using the methods described in the Microsoft Dynamics CRM SDK, it is possible to set two dashboards as the default. Make sure that no other dashboard is the default dashboard for the organization before updating this setting programmatically.

After you update an organization-owned dashboard, you must publish the metadata changes to make it visible across the organization. You can use the PublishAllXmlRequest message or PublishXmlRequest message to publish the changes made for an organization-owned dashboard. For a sample code that demonstrates this, see Sample: Create, retrieve, update, and delete a dashboard.

For a list of supported messages on the organization-owned dashboard entity, see SystemForm (system dashboard) entity messages and methods.

Actions on a User-Owned Dashboard

You can perform the following actions on a user-owned dashboard (UserForm):

  • Create, retrieve, update, and delete. For detailed information about creating a user-owned dashboard, see Create a dashboard.
  • Change the ownership of a user-owned dashboard by assigning it to another user or team using the AssignRequest message.
  • Retrieve the access that the specified security principal (user or team) has to a user-owned dashboard using the RetrievePrincipalAccessRequest message. You can also retrieve all the security principals (users or teams) that have access to a user-owned dashboard, along with their access rights to the user dashboard using the RetrieveSharedPrincipalsAndAccessRequest message.
  • Collaborate with other users and teams on specific areas by sharing a user-owned dashboard with them using the GrantAccessRequest, ModifyAccessRequest, and RevokeAccessRequest messages.

For a list of supported messages on the user-owned dashboard entity, see UserForm (user dashboard) entity messages and methods.

See Also

Concepts

Analyze data with dashboards
Understand dashboards: Dashboard components and FormXML
Create a dashboard
Sample dashboards

Other Resources

Dashboard entities
Sample: Create, retrieve, update, and delete a dashboard
Sample: Assign a user-owned dashboard to another user

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create a dashboard

Organization-owned dashboards can be created by using the Microsoft Dynamics CRM SDK or by customizing the entity form in Microsoft Dynamics CRM by editing the customizations.xml file.

Note
Some dashboards that are created by using the SDK or by customizing the entity form are not supported by the Dashboard Designer in the Web application. For more information, see Limitations: Creating dashboards by using the SDK or through form customization later in this topic.

Before creating a dashboard, consider the following:

  • Type of dashboard: If you want your dashboards to be available across the organization and do not want to manage the access levels at a more granular level, you might want to create an organization-owned dashboard. However, if you are concerned about the access privileges and security of your dashboard, consider creating a user-owned dashboard where you have more control on who can access it.
    To create organization-owned dashboards, you must have the System Administrator or System Customizer role.
  • Dashboard layout: While creating dashboards, you have to use the FormXML to define the dashboard components and layout. For information about working with FormXML to define a dashboard, see Dashboard Components and FormXML Elements. For some sample FormXMLs of different types of dashboards, see Sample dashboards.

In This Topic

Create a dashboard by using the SDK

Create an organization-owned dashboard by customizing the entity form

Limitations: Creating dashboards by using the SDK or through form customization

Create a dashboard by using the SDK

To create a dashboard, create an instance of SystemForm for an organization-owned dashboard, or UserForm for a user-owned dashboard. The following sample shows how to create an organization-owned dashboard.

C# Copy Code
//This is the language code for U.S. English. If you are running this code
//in a different locale, you will need to modify this value.
int languageCode = 1033;

//We set up our dashboard and specify the FormXml. Refer to the
//FormXml schema in the Microsoft Dynamics CRM SDK for more information.
SystemForm dashboard = new SystemForm
{
    Name = "Sample Dashboard",
    Description = "Sample organization-owned dashboard.",
    FormXml = String.Format(@"<form>
            <tabs>
                <tab name='Test Dashboard' verticallayout='true'>
                    <labels>
                        <label description='Sample Dashboard' languagecode='{0}' />
                    </labels>
                    <columns>
                        <column width='100%'>
                            <sections>
                                <section name='Information Section'
                                    showlabel='false' showbar='false'
                                    columns='111'>
                                    <labels>
                                        <label description='Information Section'
                                            languagecode='{0}' />
                                    </labels>
                                    <rows>
                                        <row>
                                            <cell colspan='1' rowspan='10'
                                                showlabel='false'>
                                                <labels>
                                                    <label description='Top Opportunitiess - 1'
                                                    languagecode='{0}' />
                                                </labels>
                                                <control id='TopOpportunities'
                                                    classid='{{E7A81278-8635-4d9e-8D4D-59480B391C5B}}'>
                                                    <parameters>
                                                        <ViewId>{1}</ViewId>
                                                        <IsUserView>false</IsUserView>
                                                        <RelationshipName />
                                                        <TargetEntityType>opportunity</TargetEntityType>
                                                        <AutoExpand>Fixed</AutoExpand>
                                                        <EnableQuickFind>false</EnableQuickFind>
                                                        <EnableViewPicker>false</EnableViewPicker>
                                                        <EnableJumpBar>false</EnableJumpBar>
                                                        <ChartGridMode>Chart</ChartGridMode>
                                                        <VisualizationId>{2}</VisualizationId>
                                                        <EnableChartPicker>false</EnableChartPicker>
                                                        <RecordsPerPage>10</RecordsPerPage>
                                                    </parameters>
                                                </control>
                                            </cell>
                                            <cell colspan='1' rowspan='10'
                                                showlabel='false'>
                                                <labels>
                                                    <label description='Top Opportunities - 2'
                                                    languagecode='{0}' />
                                                </labels>
                                                <control id='TopOpportunities2'
                                                    classid='{{E7A81278-8635-4d9e-8D4D-59480B391C5B}}'>
                                                    <parameters>
                                                        <ViewId>{1}</ViewId>
                                                        <IsUserView>false</IsUserView>
                                                        <RelationshipName />
                                                        <TargetEntityType>opportunity</TargetEntityType>
                                                        <AutoExpand>Fixed</AutoExpand>
                                                        <EnableQuickFind>false</EnableQuickFind>
                                                        <EnableViewPicker>false</EnableViewPicker>
                                                        <EnableJumpBar>false</EnableJumpBar>
                                                        <ChartGridMode>Grid</ChartGridMode>
                                                        <VisualizationId>{2}</VisualizationId>
                                                        <EnableChartPicker>false</EnableChartPicker>
                                                        <RecordsPerPage>10</RecordsPerPage>
                                                    </parameters>
                                                </control>
                                            </cell>
                                        </row>
                                        <row />
                                        <row />
                                        <row />
                                        <row />
                                        <row />
                                        <row />
                                        <row />
                                        <row />
                                        <row />
                                    </rows>
                                </section>
                            </sections>
                        </column>
                    </columns>
                </tab>
            </tabs>
        </form>",
    languageCode,
    defaultOpportunityQuery.SavedQueryId.Value.ToString("B"),
    visualization.SavedQueryVisualizationId.Value.ToString("B")),
    IsDefault = false
};
_dashboardId = _serviceProxy.Create(dashboard);

For a complete sample, see Sample: Create, retrieve, update, and delete a dashboard. For a sample to create a user-owned dashboard, and assign it to another user, see Sample: Assign a user-owned dashboard to another user.

Create an organization-owned dashboard by customizing the entity form

The customizations.xml file that is exported with an unmanaged solution contains definitions for entity forms and dashboards. You can add or modify the customizations.xml file to add or update a dashboard.

Create a dashboard by customizing an entity form

  1. Log on to Microsoft Dynamics CRM.

  2. Export a solution. For information about doing so, see Export, prepare to edit, and import the ribbon.

  3. Browse to the customizations.xml file in the exported solution folder, and open it for editing.

  4. Browse to the end of the dashboards area in the customizations.xml file by searching for the following tag: </Dashboards>

  5. Before the </Dashboards> tag, add the following to define a new dashboard:

    Xml Copy Code
    <Dashboard>   <LocalizedNames>      <LocalizedName description="<Dashboard_Name>" languagecode="1033" />   </LocalizedNames>      <IsCustomizable>1</IsCustomizable>   <IsDefault>0</IsDefault>   <FormXml>      <forms type="dashboard">         *** Dashboard definition goes here. *** </forms>   </FormXml></Dashboard>

  6. Save the customizations.xml file.

  7. Import the .zip file as a solution in Microsoft Dynamics CRM. More information: Export, prepare to edit, and import the ribbon.

Limitations: Creating dashboards by using the SDK or through form customization

Certain dashboards that are created or modified using the Microsoft Dynamics CRM SDK or through form customization are not supported by the dashboard designer in the Web application. Avoid the following while creating or modifying a dashboard using the SDK or through form customization.

General

  • Problem: You can create a dashboard that contains a tab without any section defined in the FormXML.
    Resolution: Make sure that you create a dashboard with at least one section defined for each tab in the FormXML.
  • Problem: You can create a dashboard that does not have the same number of <row> (FormXml) elements for a section as specified in the rowspan property of a <cell> (FormXml) element of the section in the FormXML. Ideally, the rowspan property value of a <cell> (FormXml) element and the number of <row> (FormXml) elements in a section must be same.
    Resolution: Make sure that you create a dashboard that has the same number of <row> (FormXml) elements for a section as specified in the rowspan property of a <cell> (FormXml) element in the section.

Grids

Problem: You can create a dashboard that contains grids with the <AutoExpand> (FormXml) parameter value set to Auto for the grid.

Resolution: Make sure that you specify the <AutoExpand> (FormXml) parameter value as Fixed for the grids in the FormXML while creating a dashboard.

IFRAMEs

Problem: You can create a dashboard that contains an IFRAME. This happens when you do not specify any value for the <Url> (FormXml) parameter for the IFRAME control in the FormXML.

Resolution: Make sure that you specify a value for the <Url> (FormXml) parameter while creating an IFRAME in the FormXML.

See Also

Concepts

Analyze data with dashboards
Understand dashboards: Dashboard components and FormXML
Actions on dashboards
Sample dashboards
Customize entity forms

Other Resources

Sample: Create, retrieve, update, and delete a dashboard

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample dashboards

This topic contains sample dashboards along with the respective FormXML strings. You can specify the FormXML string for a dashboard using the SystemForm.FormXml attribute for an organization-owned dashboard or UserForm.FormXml for a user-owned dashboard.

Dashboard with charts and grids

The following is a sample dashboard that has four components: three charts and a grid. This is one of the default organization-owned dashboards, Microsoft Dynamics CRM Overview, available in Microsoft Dynamics CRM.

Sample dashboard: Microsoft Dynamics CRM Overview

FormXML

The following sample shows the FormXML for this dashboard.

Xml Copy Code
<form>
 <tabs>
  <tab showlabel="true"
       verticallayout="true"
       id="{4e5d00ec-6b2a-447a-afdf-235e6c5d4599}"
       name="{4e5d00ec-6b2a-447a-afdf-235e6c5d4599}"
       locklevel="0"
       expanded="true">
   <columns>
    <column width="100%">
     <sections>
      <section showlabel="false"
               showbar="false"
               columns="111"
               id="{7f7bbdb7-15d6-4664-bda7-6060d0cd3105}"
               name="{7f7bbdb7-15d6-4664-bda7-6060d0cd3105}">
       <rows>
        <row>
         <cell colspan="1"
               rowspan="12"
               showlabel="false"
               id="{cfa8b70b-b0f0-4b91-9cf3-c4e29925186f}"
               auto="false">
          <control id="Chart1"
                   classid="{E7A81278-8635-4d9e-8D4D-59480B391C5B}">
           <parameters>
            <TargetEntityType>opportunity</TargetEntityType>
            <ChartGridMode>Chart</ChartGridMode>
            <EnableQuickFind>true</EnableQuickFind>
            <EnableViewPicker>false</EnableViewPicker>
            <EnableJumpBar>true</EnableJumpBar>
            <RecordsPerPage>12</RecordsPerPage>
            <ViewId>{00000000-0000-0000-00AA-000010003001}</ViewId>
            <IsUserView>false</IsUserView>
            <ViewIds></ViewIds>
            <AutoExpand>Fixed</AutoExpand>
            <VisualizationId>{87293554-2482-DE11-9FF3-00155DA3B012}</VisualizationId>
            <IsUserChart>false</IsUserChart>
            <EnableChartPicker>false</EnableChartPicker>
            <RelationshipName></RelationshipName>
           </parameters>
          </control>
         </cell>
         <cell colspan="1"
               rowspan="12"
               showlabel="false"
               id="{5fc07b79-9f15-4396-9a66-c8ca4a13cac3}"
               auto="false">
          <control id="Chart2"
                   classid="{E7A81278-8635-4d9e-8D4D-59480B391C5B}">
           <parameters>
            <TargetEntityType>lead</TargetEntityType>
            <ChartGridMode>Chart</ChartGridMode>
            <EnableQuickFind>true</EnableQuickFind>
            <EnableViewPicker>false</EnableViewPicker>
            <EnableJumpBar>true</EnableJumpBar>
            <RecordsPerPage>12</RecordsPerPage>
            <ViewId>{5A926B99-3A5F-DF11-AE90-00155D2E3002}</ViewId>
            <IsUserView>false</IsUserView>
            <ViewIds></ViewIds>
            <AutoExpand>Fixed</AutoExpand>
            <VisualizationId>{3ED18B7C-5693-DE11-97D4-00155DA3B01E}</VisualizationId>
            <IsUserChart>false</IsUserChart>
            <EnableChartPicker>false</EnableChartPicker>
            <RelationshipName></RelationshipName>
           </parameters>
          </control>
         </cell>
         <cell colspan="1"
               rowspan="12"
               showlabel="false"
               id="{378521f2-889b-4e56-ae46-0b69e87dd0b8}"
               auto="false">
          <control id="Chart3"
                   classid="{E7A81278-8635-4d9e-8D4D-59480B391C5B}">
           <parameters>
            <TargetEntityType>incident</TargetEntityType>
            <ChartGridMode>Chart</ChartGridMode>
            <EnableQuickFind>true</EnableQuickFind>
            <EnableViewPicker>false</EnableViewPicker>
            <EnableJumpBar>true</EnableJumpBar>
            <RecordsPerPage>12</RecordsPerPage>
            <ViewId>{00000000-0000-0000-00AA-000010001032}</ViewId>
            <IsUserView>false</IsUserView>
            <ViewIds></ViewIds>
            <AutoExpand>Fixed</AutoExpand>
            <VisualizationId>{DF31B045-1D63-DF11-AE90-00155D2E3002}</VisualizationId>
            <IsUserChart>false</IsUserChart>
            <EnableChartPicker>false</EnableChartPicker>
            <RelationshipName></RelationshipName>
           </parameters>
          </control>
         </cell>
        </row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
       </rows>
      </section>
     </sections>
    </column>
   </columns>
  </tab>
  <tab showlabel="true"
       verticallayout="true"
       id="{3fb82356-c884-44b6-b11e-d3292776dfb8}"
       name="{3fb82356-c884-44b6-b11e-d3292776dfb8}"
       locklevel="0"
       expanded="true">
   <columns>
    <column width="100%">
     <sections>
      <section showlabel="false"
               showbar="false"
               columns="111"
               id="{02aab82b-167e-4f61-8d10-9b5a3fab3d76}"
               name="{02aab82b-167e-4f61-8d10-9b5a3fab3d76}">
       <rows>
        <row>
         <cell colspan="3"
               rowspan="12"
               showlabel="false"
               id="{f0114d8b-f5c9-41b2-9b59-07ff839ef176}"
               auto="false">
          <control id="Grid1"
                   classid="{E7A81278-8635-4d9e-8D4D-59480B391C5B}">
           <parameters>
            <TargetEntityType>activitypointer</TargetEntityType>
            <ChartGridMode>All</ChartGridMode>
            <EnableQuickFind>false</EnableQuickFind>
            <EnableViewPicker>true</EnableViewPicker>
            <EnableJumpBar>true</EnableJumpBar>
            <RecordsPerPage>8</RecordsPerPage>
            <ViewId>{00000000-0000-0000-00AA-000010001899}</ViewId>
            <IsUserView>false</IsUserView>
            <ViewIds></ViewIds>
            <AutoExpand>Fixed</AutoExpand>
            <VisualizationId>{EDF35649-5293-DE11-97D4-00155DA3B01E}</VisualizationId>
            <IsUserChart>false</IsUserChart>
            <EnableChartPicker>false</EnableChartPicker>
            <RelationshipName></RelationshipName>
           </parameters>
          </control>
         </cell>
        </row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
        <row></row>
       </rows>
      </section>
     </sections>
    </column>
   </columns>
  </tab>
 </tabs>
</form>

See Also

Concepts

Analyze data with dashboards

Other Resources

Dashboard entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Dashboard entities

The dashboard entities enable you to simultaneously present data from up to six charts, grids or IFRAMES. The following illustration shows the entity relationships for this area. More information: Key to entity diagrams.

Dashboard entity model

In This Section

SystemForm (system dashboard) entity messages and methods

UserForm (user dashboard) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserForm (user dashboard) entity messages and methods

A user form represents a user-owned dashboard. The schema name for this entity is UserForm. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a user-owned dashboard to another user or a team.
CreateRequest | Creates a user-owned dashboard. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a user-owned dashboard. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a user-owned dashboard with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a user-owned dashboard previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a user-owned dashboard. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of user-owned dashboards. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the specified security principal (user or team) has to a user-owned dashboard.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a user-owned dashboard, and their access rights to the account.
RevokeAccessRequest | Removes all access to a user-owned dashboard for the specified security principal (user or team).
UpdateRequest | Updates a user-owned dashboard. You can also use the IOrganizationService.Update method.

See Also

Concepts

UserForm (user dashboard) entity privileges

Other Resources

Dashboard entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete a dashboard
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\VisualizationsAndDashboards\CRUDDashboards.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create, retrieve, update, and delete an organization-owned dashboard. As part of updating the dashboard, it’s set to be the default dashboard for the organization. This sample uses the following common methods:

  • IOrganizationService.Create
  • IOrganizationService.Retrieve
  • IOrganizationService.Update
  • IOrganizationService.Delete

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Xml.Linq;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{

    /// <summary>
    /// This sample shows how to perform Create, Retrieve,
    /// Update, and Delete operations on a dashboard.
    /// </summary>

    public class CRUDDashboards
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        public Guid _dashboardId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create and configure the organization service proxy.
        /// Create a dashboard.
        /// Retrieve the dashboard.
        /// Update the dashboard.
        /// Delete the dashboard.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>

       public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    //Grab the default public view for opportunities.
                    QueryExpression mySavedQuery = new QueryExpression
                    {
                        ColumnSet = new ColumnSet("savedqueryid"),
                        EntityName = SavedQuery.EntityLogicalName,
                        Criteria = new FilterExpression
                        {
                            Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "isdefault",
                                Operator = ConditionOperator.Equal,
                                Values = {true}
                            },
                            new ConditionExpression
                            {
                                AttributeName = "querytype",
                                Operator = ConditionOperator.Equal,
                                Values = {0}
                            },
                            new ConditionExpression
                            {
                                AttributeName = "returnedtypecode",
                                Operator = ConditionOperator.Equal,
                                Values = {Opportunity.EntityTypeCode}
                            }
                        }
                        }
                    };

                    //This query should return one and only one result.
                    SavedQuery defaultOpportunityQuery = _serviceProxy.RetrieveMultiple(mySavedQuery)
                        .Entities.Select(x => (SavedQuery)x).FirstOrDefault();

                    // Retrieve visualizations out of the system.
                    // This sample assumes that you have the "Top Opportunities"
                    // visualization that is installed with Microsoft Dynamics CRM.
                    QueryByAttribute visualizationQuery = new QueryByAttribute
                    {
                        EntityName = SavedQueryVisualization.EntityLogicalName,
                        ColumnSet = new ColumnSet("savedqueryvisualizationid"),
                        Attributes = { "name" },
                        //If you do not have this visualization, you will need to change
                        //this line.
                        Values = { "Top Opportunities" }
                    };

                    SavedQueryVisualization visualization = _serviceProxy.RetrieveMultiple(visualizationQuery).
                        Entities.Select(x => (SavedQueryVisualization)x).FirstOrDefault();
                    //This is the language code for U.S. English. If you are running this code
                    //in a different locale, you will need to modify this value.
                    int languageCode = 1033;

                    //We set up our dashboard and specify the FormXml. Refer to the
                    //FormXml schema in the Microsoft Dynamics CRM SDK for more information.
                    SystemForm dashboard = new SystemForm
                    {
                        Name = "Sample Dashboard",
                        Description = "Sample organization-owned dashboard.",
                        FormXml = String.Format(@"<form>
                                <tabs>
                                    <tab name='Test Dashboard' verticallayout='true'>
                                        <labels>
                                            <label description='Sample Dashboard' languagecode='{0}' />
                                        </labels>
                                        <columns>
                                            <column width='100%'>
                                                <sections>
                                                    <section name='Information Section'
                                                        showlabel='false' showbar='false'
                                                        columns='111'>
                                                        <labels>
                                                            <label description='Information Section'
                                                                languagecode='{0}' />
                                                        </labels>
                                                        <rows>
                                                            <row>
                                                                <cell colspan='1' rowspan='10'
                                                                    showlabel='false'>
                                                                    <labels>
                                                                        <label description='Top Opportunitiess - 1'
                                                                        languagecode='{0}' />
                                                                    </labels>
                                                                    <control id='TopOpportunities'
                                                                        classid='{{E7A81278-8635-4d9e-8D4D-59480B391C5B}}'>
                                                                        <parameters>
                                                                            <ViewId>{1}</ViewId>
                                                                            <IsUserView>false</IsUserView>
                                                                            <RelationshipName />
                                                                            <TargetEntityType>opportunity</TargetEntityType>
                                                                            <AutoExpand>Fixed</AutoExpand>
                                                                            <EnableQuickFind>false</EnableQuickFind>
                                                                            <EnableViewPicker>false</EnableViewPicker>
                                                                            <EnableJumpBar>false</EnableJumpBar>
                                                                            <ChartGridMode>Chart</ChartGridMode>
                                                                            <VisualizationId>{2}</VisualizationId>
                                                                            <EnableChartPicker>false</EnableChartPicker>
                                                                            <RecordsPerPage>10</RecordsPerPage>
                                                                        </parameters>
                                                                    </control>
                                                                </cell>
                                                                <cell colspan='1' rowspan='10'
                                                                    showlabel='false'>
                                                                    <labels>
                                                                        <label description='Top Opportunities - 2'
                                                                        languagecode='{0}' />
                                                                    </labels>
                                                                    <control id='TopOpportunities2'
                                                                        classid='{{E7A81278-8635-4d9e-8D4D-59480B391C5B}}'>
                                                                        <parameters>
                                                                            <ViewId>{1}</ViewId>
                                                                            <IsUserView>false</IsUserView>
                                                                            <RelationshipName />
                                                                            <TargetEntityType>opportunity</TargetEntityType>
                                                                            <AutoExpand>Fixed</AutoExpand>
                                                                            <EnableQuickFind>false</EnableQuickFind>
                                                                            <EnableViewPicker>false</EnableViewPicker>
                                                                            <EnableJumpBar>false</EnableJumpBar>
                                                                            <ChartGridMode>Grid</ChartGridMode>
                                                                            <VisualizationId>{2}</VisualizationId>
                                                                            <EnableChartPicker>false</EnableChartPicker>
                                                                            <RecordsPerPage>10</RecordsPerPage>
                                                                        </parameters>
                                                                    </control>
                                                                </cell>
                                                            </row>
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                        </rows>
                                                    </section>
                                                </sections>
                                            </column>
                                        </columns>
                                    </tab>
                                </tabs>
                            </form>",
                        languageCode,
                        defaultOpportunityQuery.SavedQueryId.Value.ToString("B"),
                        visualization.SavedQueryVisualizationId.Value.ToString("B")),
                        IsDefault = false
                    };
                    _dashboardId = _serviceProxy.Create(dashboard);
                    Console.WriteLine("Created {0}.", dashboard.Name);

                    //Now we will retrieve the dashboard.
                    SystemForm retrievedDashboard = (SystemForm)_serviceProxy.Retrieve(SystemForm.EntityLogicalName, _dashboardId, new ColumnSet(true));
                    Console.WriteLine("Retrieved the dashboard.");

                    // Update the retrieved dashboard. Enable the chart picker on the chart.
                    XDocument xDocument = XDocument.Parse(retrievedDashboard.FormXml);

                    var chartPicker = (from control in xDocument.Descendants("control")
                                       where control.Attribute("id").Value == "TopOpportunities"
                                       select control.Descendants("EnableChartPicker").First()
                                     ).First();
                    chartPicker.Value = "true";

                    //Now we place the updated Xml back into the dashboard, and update it.
                    retrievedDashboard.FormXml = xDocument.ToString();
                    _serviceProxy.Update(retrievedDashboard);

                    // Publish the dashboard changes to the solution.
                    // This is only required for organization-owned dashboards.
                    PublishXmlRequest updateRequest = new PublishXmlRequest
                    {
                        ParameterXml = @"<dashboard>_dashboardId</dashboard>"
                    };

                    _serviceProxy.Execute(updateRequest);

                    Console.WriteLine("Updated the dashboard.");

                    DeleteRequiredRecords(promptForDelete);

                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }
        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name='prompt'>Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(SystemForm.EntityLogicalName, _dashboardId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CRUDDashboards app = new CRUDDashboards();
                app.Run(config, true);

            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                 Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Analyze data with dashboards
Actions on dashboards

Other Resources

Sample: Assign a user-owned dashboard to another user
Helper code: ServerConnection class
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Assign a user-owned dashboard to another user
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. This code can be found in the following location in the download package:

SampleCode\CS\VisualizationsAndDashboards\AssignDashboardToUser.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to assign a user-owned dashboard to another user by using the AssignRequest message. Because you can’t delete a user-owned dashboard that is assigned to another user, this sample shows how to use impersonation to delete the user-owned dashboard.

Example

C# Copy Code
using System;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using System.Xml.Linq;
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Client;
// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

using System.DirectoryServices;
using System.Threading;

namespace Microsoft.Crm.Sdk.Samples
{
    public class AssignDashboardToUser
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Define the IDs needed for this sample.
        private Guid _userDashboardId;
        private Guid _otherUserId;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// a user dashbaord is assigned to another user.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Call the method to create any data that this sample requires.
                    CreateRequiredRecords();

                    AssignRequest assignRequest = new AssignRequest
                    {
                        Assignee = new EntityReference
                        {
                            LogicalName = SystemUser.EntityLogicalName,
                            // Here we could assign the visualization to the newly created user
                            Id = _otherUserId
                        },

                        Target = new EntityReference
                        {
                            LogicalName = UserForm.EntityLogicalName,
                            Id = _userDashboardId
                        }
                    };
                    _serviceProxy.Execute(assignRequest);

                    Console.WriteLine("The user dashboard has been assigned to Kevin Cook.");

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// This method creates any entity records that this sample requires.
        /// Creates the dashboard.
        /// </summary>
        public void CreateRequiredRecords()
        {
            //Grab the default public view for opportunities.
            QueryExpression mySavedQuery = new QueryExpression
            {
                ColumnSet = new ColumnSet("savedqueryid"),
                EntityName = SavedQuery.EntityLogicalName,
                Criteria = new FilterExpression
                {
                    Conditions =
                        {
                            new ConditionExpression
                            {
                                AttributeName = "isdefault",
                                Operator = ConditionOperator.Equal,
                                Values = {true}
                            },
                            new ConditionExpression
                            {
                                AttributeName = "querytype",
                                Operator = ConditionOperator.Equal,
                                Values = {0}
                            },
                            new ConditionExpression
                            {
                                AttributeName = "returnedtypecode",
                                Operator = ConditionOperator.Equal,
                                Values = {Opportunity.EntityTypeCode}
                            }
                        }
                }
            };

            //This query should return one and only one result.
            SavedQuery defaultOpportunityQuery = _serviceProxy.RetrieveMultiple(mySavedQuery)
                .Entities.Select(x => (SavedQuery)x).FirstOrDefault();

            // Retrieve visualizations out of the system.
            // This sample assumes that you have the "Top Opportunities"
            // visualization that is installed with Microsoft Dynamics CRM.
            QueryByAttribute visualizationQuery = new QueryByAttribute
            {
                EntityName = SavedQueryVisualization.EntityLogicalName,
                ColumnSet = new ColumnSet("savedqueryvisualizationid"),
                Attributes = { "name" },
                //If you do not have this visualization, you will need to change
                //this line.
                Values = { "Top Opportunities" }
            };

            SavedQueryVisualization visualization = _serviceProxy.RetrieveMultiple(visualizationQuery).
                Entities.Select(x => (SavedQueryVisualization)x).FirstOrDefault();

            //This is the language code for U.S. English. If you are running this code
            //in a different locale, you will need to modify this value.
            int languageCode = 1033;

            //We set up our dashboard and specify the FormXml. Refer to the
            //FormXml schema in the Microsoft Dynamics CRM SDK for more information.
            UserForm dashboard = new UserForm
            {
                Name = "Sample User Dashboard",
                Description = "Sample user-owned dashboard.",
                FormXml = String.Format(@"<form>
                                <tabs>
                                    <tab name='Test Dashboard' verticallayout='true'>
                                        <labels>
                                            <label description='Sample User Dashboard' languagecode='{0}' />
                                        </labels>
                                        <columns>
                                            <column width='100%'>
                                                <sections>
                                                    <section name='Information Section'
                                                        showlabel='false' showbar='false'
                                                        columns='111'>
                                                        <labels>
                                                            <label description='Information Section'
                                                                languagecode='{0}' />
                                                        </labels>
                                                        <rows>
                                                            <row>
                                                                <cell colspan='1' rowspan='10'
                                                                    showlabel='false'>
                                                                    <labels>
                                                                        <label description='Top Opportunities - 1'
                                                                        languagecode='{0}' />
                                                                    </labels>
                                                                    <control id='Top10Opportunities'
                                                                        classid='{{E7A81278-8635-4d9e-8D4D-59480B391C5B}}'>
                                                                        <parameters>
                                                                            <ViewId>{1}</ViewId>
                                                                            <IsUserView>false</IsUserView>
                                                                            <RelationshipName />
                                                                            <TargetEntityType>opportunity</TargetEntityType>
                                                                            <AutoExpand>Fixed</AutoExpand>
                                                                            <EnableQuickFind>false</EnableQuickFind>
                                                                            <EnableViewPicker>false</EnableViewPicker>
                                                                            <EnableJumpBar>false</EnableJumpBar>
                                                                            <ChartGridMode>Chart</ChartGridMode>
                                                                            <VisualizationId>{2}</VisualizationId>
                                                                            <EnableChartPicker>false</EnableChartPicker>
                                                                            <RecordsPerPage>10</RecordsPerPage>
                                                                        </parameters>
                                                                    </control>
                                                                </cell>
                                                                <cell colspan='1' rowspan='10'
                                                                    showlabel='false'>
                                                                    <labels>
                                                                        <label description='Top Opportunities - 2'
                                                                        languagecode='{0}' />
                                                                    </labels>
                                                                    <control id='Top10Opportunities2'
                                                                        classid='{{E7A81278-8635-4d9e-8D4D-59480B391C5B}}'>
                                                                        <parameters>
                                                                            <ViewId>{1}</ViewId>
                                                                            <IsUserView>false</IsUserView>
                                                                            <RelationshipName />
                                                                            <TargetEntityType>opportunity</TargetEntityType>
                                                                            <AutoExpand>Fixed</AutoExpand>
                                                                            <EnableQuickFind>false</EnableQuickFind>
                                                                            <EnableViewPicker>false</EnableViewPicker>
                                                                            <EnableJumpBar>false</EnableJumpBar>
                                                                            <ChartGridMode>Grid</ChartGridMode>
                                                                            <VisualizationId>{2}</VisualizationId>
                                                                            <EnableChartPicker>false</EnableChartPicker>
                                                                            <RecordsPerPage>10</RecordsPerPage>
                                                                        </parameters>
                                                                    </control>
                                                                </cell>
                                                            </row>
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                            <row />
                                                        </rows>
                                                    </section>
                                                </sections>
                                            </column>
                                        </columns>
                                    </tab>
                                </tabs>
                            </form>",
                languageCode,
                defaultOpportunityQuery.SavedQueryId.Value.ToString("B"),
                visualization.SavedQueryVisualizationId.Value.ToString("B"))
            };
            _userDashboardId = _serviceProxy.Create(dashboard);

            Console.WriteLine("Created {0}.", dashboard.Name);

            // Create another user to whom the dashboard will be assigned.
            _otherUserId = SystemUserProvider.RetrieveSalesManager(_serviceProxy);
        }

        /// <summary>
        /// Deletes the entity record that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the entity created in this sample.</param>
        /// The system user named "Kevin Cook" that was created by this sample will
        /// continue to exist on your system because system users cannot be deleted
        /// in Microsoft Dynamics CRM. They can only be enabled or disabled.

        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            if (!prompt) return;

            // Ask the user if the created entities should be deleted.
            Console.Write("\nDo you want these entity records deleted? (y/n) [y]: ");
            String answer = Console.ReadLine();

            if (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty)
            {
                // Delete action doesn't work on the UserForm instance if it is assigned
                // to a user other than current user.
                // So as a workaround, we are impersonating the actual owner of
                // the UserForm instance to complete the delete action.
                // To impersonate another user, set the OrganizationServiceProxy.CallerId
                // property to the ID of the other user.
                _serviceProxy.CallerId = _otherUserId;

                _serviceProxy.Delete(UserForm.EntityLogicalName, _userDashboardId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Main. Runs the sample and provides error output.
        /// <param name="args">Array of arguments to Main method.</param>
        /// </summary>
        static public void Main(string[] args)
        {

            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                AssignDashboardToUser app = new AssignDashboardToUser();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Reference

Assign

Concepts

Actions on dashboards

Other Resources

AssignRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Visualization data description schema

The following is the schema for the data description XML string for charts in visualization. This can be used to validate the contents of the data description XML string while creating a chart. For more information, see Understand charts: Underlying data and chart representation. You can find this schema in the SDK\Schemas\VisualizationDataDescription.xsd file in the SDK Download the Microsoft Dynamics CRM SDK package. package.

Schema

Xml Copy Code
<?xml version='1.0' encoding='utf-8'?>
<xs:schema attributeFormDefault='unqualified' elementFormDefault='qualified' xmlns:xs='http://www.w3.org/2001/XMLSchema'>
  <xs:element name='datadefinition'>
    <xs:complexType>
      <xs:sequence>
        <xs:element name='fetchcollection'>
          <xs:complexType>
            <xs:sequence>
              <xs:element maxOccurs='unbounded' name='fetch'>
                <xs:annotation>
                  <[FetchXML goes here]>
                </xs:annotation>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
        <xs:element name='categorycollection'>
          <xs:complexType>
            <xs:sequence>
              <xs:element name='category' type='CategoryType' minOccurs='1' maxOccurs='unbounded' />
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:complexType>
  </xs:element>
  <xs:complexType name ='CategoryType'>
    <xs:sequence>
      <xs:element minOccurs='1' maxOccurs='unbounded' name='measurecollection'>
        <xs:complexType>
          <xs:sequence>
            <xs:element minOccurs='1' maxOccurs='unbounded' name='measure'>
              <xs:complexType>
                <xs:attribute name='alias' type='xs:string' use='required' />
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:schema>

See Also

Concepts

Understand charts: Underlying data and chart representation
Sample charts
Use FetchXML to construct a query

Other Resources

Customize visualizations and dashboards
Schemas used in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize entity views

Entity views are special saved queries that retrieve data by using a specific filter. They also contain information about how the data in the view should be displayed in the application. Entity views are SavedQuery records that you can create programmatically. You can also define them as XML, and import them into Microsoft Dynamics CRM with an unmanaged solution.

An Entity view is different from a UserQuery. A user query, called a Saved view in the application, is owned by an individual user, can be assigned and shared with other users, and can be viewed by other users depending on the query's access privileges. This is appropriate for frequently used queries that span entity types and queries that perform aggregation. More information: UserQuery (saved view) entity

In This Topic

Types of Views

View Tasks

  • Create Views
  • Update Views
  • Delete Views
  • Retrieve Views
  • Deactivate Views
  • Edit Filter Criteria or Configure Sorting
  • Edit columns
  • Set as Default

Types of views

The following table lists the five types of views that are supported for customization. The type code of a view is stored in the SavedQuery.QueryType attribute. Note that there are other valid values for the QueryType attribute not listed here because this entity is also used to store Microsoft Office Outlook filters and templates. For more information, see Offline and Outlook filters and templates.

When views are defined for a specific entity, the SavedQuery.ReturnedTypeCode attribute returns the entity logical name.

View Type Type Code Description

Public

0

  • Occurrence: Many
  • Actions: Create, Update, Delete
  • Comments: You can set one of these views as the default public view by setting SavedQuery.IsDefault to true.

Advanced Find

1

  • Occurrence: 1
  • Actions: Update only.
  • Comments: By default, this view is displayed when results are shown in Advanced Find.

Associated

2

  • Occurrence: 1
  • Actions: Update only,
  • Comments: By default, this view is displayed when a grid of related records appears in the navigation pane of a record.

Quick Find

4

  • Occurrence: 1
  • Actions: Update only.
  • Comments: This view defines the columns that will be searched when a user searches for records by using the search field in a list view.

Lookup

64

  • Occurrence: 1
  • Actions: Update only.
  • Comments: This is the default view that will be used to look up a record when no other view has been configured for the lookup field.

View tasks

Because views are SavedQuery records, you can create, update, retrieve, delete and deactivate them. In addition you can edit filter criteria or configure sorting, edit columns or set a view as a default view.

Create views

To create a public view, specify the following properties:

  • SavedQuery.Name: A unique identifier for the saved query.
  • SavedQuery.ReturnedTypeCode: Matches the logical name of the entity.
  • SavedQuery.FetchXml: See Use FetchXML to construct a query.
  • SavedQuery.LayoutXml: See <layoutxml> (SavedQuery) for the valid elements.
  • SavedQuery.QueryType: Must always be zero (0).

The following sample creates a new public view for the opportunity entity:

C# Copy Code
                    System.String layoutXml =
@"<grid name='resultset' object='3' jump='name' select='1'
    preview='1' icon='1'>
    <row name='result' id='opportunityid'>
    <cell name='name' width='150' />
    <cell name='customerid' width='150' />
    <cell name='estimatedclosedate' width='150' />
    <cell name='estimatedvalue' width='150' />
    <cell name='closeprobability' width='150' />
    <cell name='opportunityratingcode' width='150' />
    <cell name='opportunitycustomeridcontactcontactid.emailaddress1'
        width='150' disableSorting='1' />
    </row>
</grid>";

                    System.String fetchXml =
                    @"<fetch version='1.0' output-format='xml-platform'
    mapping='logical' distinct='false'>
    <entity name='opportunity'>
    <order attribute='estimatedvalue' descending='false' />
    <filter type='and'>
        <condition attribute='statecode' operator='eq'
        value='0' />
    </filter>
    <attribute name='name' />
    <attribute name='estimatedvalue' />
    <attribute name='estimatedclosedate' />
    <attribute name='customerid' />
    <attribute name='opportunityratingcode' />
    <attribute name='closeprobability' />
    <link-entity alias='opportunitycustomeridcontactcontactid'
        name='contact' from='contactid' to='customerid'
        link-type='outer' visible='false'>
        <attribute name='emailaddress1' />
    </link-entity>
    <attribute name='opportunityid' />
    </entity>
</fetch>";

                    SavedQuery sq = new SavedQuery
                    {
                        Name = "A New Custom Public View",
                        Description = "A Saved Query created in code",
                        ReturnedTypeCode = "opportunity",
                        FetchXml = fetchXml,
                        LayoutXml = layoutXml,
                        QueryType = 0
                    };

                    _customViewId = _serviceProxy.Create(sq);
                    Console.WriteLine("A new view with the name {0} was created.", sq.Name);

Update views

If the SavedQuery.IsCustomizable managed property allows the view to be updated, you can use the IOrganizationService.Update method or the UpdateRequest message to update the view.

Delete views

You should only delete saved queries that you have created. A solution component or part of the application may depend on a specific saved query. If there are queries you do not want to appear in the application, you should deactivate them.

Retrieve views

Use a RetrieveMultipleRequest or IOrganizationService.RetrieveMultiple to retrieve saved query records.

The following sample retrieves all the public views for the opportunity entity:

C# Copy Code
        QueryExpression mySavedQuery = new QueryExpression
        {
            ColumnSet = new ColumnSet("savedqueryid", "name", "querytype", "isdefault", "returnedtypecode", "isquickfindquery"),
            EntityName = SavedQuery.EntityLogicalName,
            Criteria = new FilterExpression
            {
                Conditions =
{
    new ConditionExpression
    {
        AttributeName = "querytype",
        Operator = ConditionOperator.Equal,
        Values = {0}
    },
    new ConditionExpression
    {
        AttributeName = "returnedtypecode",
        Operator = ConditionOperator.Equal,
        Values = {Opportunity.EntityTypeCode}
    }
}
            }
        };
        RetrieveMultipleRequest retrieveSavedQueriesRequest = new RetrieveMultipleRequest { Query = mySavedQuery };

        RetrieveMultipleResponse retrieveSavedQueriesResponse = (RetrieveMultipleResponse)_serviceProxy.Execute(retrieveSavedQueriesRequest);

        DataCollection<Entity> savedQueries = retrieveSavedQueriesResponse.EntityCollection.Entities;

        //Display the Retrieved views
        foreach (Entity ent in savedQueries)
        {
            SavedQuery rsq = (SavedQuery)ent;
            Console.WriteLine("{0} : {1} : {2} : {3} : {4} : {5},", rsq.SavedQueryId, rsq.Name, rsq.QueryType, rsq.IsDefault, rsq.ReturnedTypeCode, rsq.IsQuickFindQuery);
        }

Deactivate views

If you do not want a public view to appear in the application, you can deactivate it. You cannot deactivate a public view that is set as the default view. The following sample deactivates the Closed Opportunities in Current Fiscal Year view for the Opportunity entity:

C# Copy Code
System.String SavedQueryName = "Closed Opportunities in Current Fiscal Year";
QueryExpression ClosedOpportunitiesViewQuery = new QueryExpression
{
    ColumnSet = new ColumnSet("savedqueryid", "statecode", "statuscode"),
    EntityName = SavedQuery.EntityLogicalName,
    Criteria = new FilterExpression
    {
        Conditions =
        {
            new ConditionExpression
            {
                AttributeName = "querytype",
                Operator = ConditionOperator.Equal,
                Values = {0}
            },
            new ConditionExpression
            {
                AttributeName = "returnedtypecode",
                Operator = ConditionOperator.Equal,
                Values = {Opportunity.EntityTypeCode}
            },
                            new ConditionExpression
            {
                AttributeName = "name",
                Operator = ConditionOperator.Equal,
                Values = {SavedQueryName}
            }
        }
    }
};

RetrieveMultipleRequest retrieveOpportuntiesViewRequest = new RetrieveMultipleRequest { Query = ClosedOpportunitiesViewQuery };

RetrieveMultipleResponse retrieveOpportuntiesViewResponse = (RetrieveMultipleResponse)_serviceProxy.Execute(retrieveOpportuntiesViewRequest);

SavedQuery OpportunityView = (SavedQuery)retrieveOpportuntiesViewResponse.EntityCollection.Entities[0];
_viewOriginalState = (SavedQueryState)OpportunityView.StateCode;
_viewOriginalStatus = OpportunityView.StatusCode;

SetStateRequest ssreq = new SetStateRequest
{
    EntityMoniker = new EntityReference(SavedQuery.EntityLogicalName, (Guid)OpportunityView.SavedQueryId),
    State = new OptionSetValue((int)SavedQueryState.Inactive),
    Status = new OptionSetValue(2)
};
_serviceProxy.Execute(ssreq);

Edit filter criteria or configure sorting

To edit the filter or edit how the data is sorted, you must set the SavedQuery.FetchXml attribute. For more information, see Build queries with FetchXML.

Tip
If you are not familiar with FetchXML the following messages can be used to convert between QueryExpression and FetchXML:QueryExpressionToFetchXmlRequest and FetchXmlToQueryExpressionRequest.

Edit columns

The columns that you want to display in views can be taken from the entity or related entities. For more information about how to specify the columns to display, see <layoutxml> (SavedQuery).

Set as default

Only one active public view can be set as the default view. To make a view the default view, set the IsDefault property to true.

See Also

Reference

Saved query XML reference

Concepts

SavedQuery (view) entity messages and methods
Customize entity forms
Customize global option sets

Other Resources

Sample: Work with views
Build queries with FetchXML
Extend the metadata model
Developers guide to customization for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SavedQuery (view) entity messages and methods

This entity stores a saved query against the database. This is used for both views and for Microsoft Office Outlook filters and templates. The schema name for this entity is SavedQuery. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see SavedQuery entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a saved query. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a saved query. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see SavedQuery entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
ExecuteByIdSavedQueryRequest | Executes a previously saved query specified by an ID.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveLocLabelsRequest | Retrieves localized labels for SavedQuery.Name and SavedQuery.Description attributes.
RetrieveRequest | Retrieves a saved query. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of saved queries. You can also call the IOrganizationService.RetrieveMultiple method.
SetLocLabelsRequest | Sets localized labels for SavedQuery.Name and SavedQuery.Description attributes.
SetStateRequest | Sets the state of a saved query (view). The possible states are defined in the SavedQueryState enumeration. For a list of states, see SavedQuery entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a saved query. You can also call the IOrganizationService.Update method.
ValidateSavedQueryRequest | Validates a saved query.

See Also

Concepts

Customize entity views
Offline and Outlook filters and templates
SavedQuery (view) entity privileges

Other Resources

Sample: Work with views

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Work with views
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Customizations\Views\WorkWithViews\WorkWithViews.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to perform various actions on views.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    public class WorkWithViews
    {
        #region Class Level Members
        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        //private const String _customEntityName = "new_bankaccount";
        private Guid _customViewId;
        private Guid _deactivatedViewId;
        private SavedQueryState _viewOriginalState;
        private OptionSetValue _viewOriginalStatus;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create a view.
        /// Retrieve Views
        /// Deactivate a view
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        /// <param name="promptForReactivate">When True, the user will be prompted to reactivate
        /// a view that was deactivated.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete, bool promptForReactivate)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri, serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Create the view.
                    System.String layoutXml =
@"<grid name='resultset' object='3' jump='name' select='1'
    preview='1' icon='1'>
    <row name='result' id='opportunityid'>
    <cell name='name' width='150' />
    <cell name='customerid' width='150' />
    <cell name='estimatedclosedate' width='150' />
    <cell name='estimatedvalue' width='150' />
    <cell name='closeprobability' width='150' />
    <cell name='opportunityratingcode' width='150' />
    <cell name='opportunitycustomeridcontactcontactid.emailaddress1'
        width='150' disableSorting='1' />
    </row>
</grid>";

                    System.String fetchXml =
                    @"<fetch version='1.0' output-format='xml-platform'
    mapping='logical' distinct='false'>
    <entity name='opportunity'>
    <order attribute='estimatedvalue' descending='false' />
    <filter type='and'>
        <condition attribute='statecode' operator='eq'
        value='0' />
    </filter>
    <attribute name='name' />
    <attribute name='estimatedvalue' />
    <attribute name='estimatedclosedate' />
    <attribute name='customerid' />
    <attribute name='opportunityratingcode' />
    <attribute name='closeprobability' />
    <link-entity alias='opportunitycustomeridcontactcontactid'
        name='contact' from='contactid' to='customerid'
        link-type='outer' visible='false'>
        <attribute name='emailaddress1' />
    </link-entity>
    <attribute name='opportunityid' />
    </entity>
</fetch>";

                    SavedQuery sq = new SavedQuery
                    {
                        Name = "A New Custom Public View",
                        Description = "A Saved Query created in code",
                        ReturnedTypeCode = "opportunity",
                        FetchXml = fetchXml,
                        LayoutXml = layoutXml,
                        QueryType = 0
                    };

                    _customViewId = _serviceProxy.Create(sq);
                    Console.WriteLine("A new view with the name {0} was created.", sq.Name);

                    // Retrieve Views
                    QueryExpression mySavedQuery = new QueryExpression
                    {
                        ColumnSet = new ColumnSet("savedqueryid", "name", "querytype", "isdefault", "returnedtypecode", "isquickfindquery"),
                        EntityName = SavedQuery.EntityLogicalName,
                        Criteria = new FilterExpression
                        {
                            Conditions =
            {
                new ConditionExpression
                {
                    AttributeName = "querytype",
                    Operator = ConditionOperator.Equal,
                    Values = {0}
                },
                new ConditionExpression
                {
                    AttributeName = "returnedtypecode",
                    Operator = ConditionOperator.Equal,
                    Values = {Opportunity.EntityTypeCode}
                }
            }
                        }
                    };
                    RetrieveMultipleRequest retrieveSavedQueriesRequest = new RetrieveMultipleRequest { Query = mySavedQuery };

                    RetrieveMultipleResponse retrieveSavedQueriesResponse = (RetrieveMultipleResponse)_serviceProxy.Execute(retrieveSavedQueriesRequest);

                    DataCollection<Entity> savedQueries = retrieveSavedQueriesResponse.EntityCollection.Entities;

                    //Display the Retrieved views
                    foreach (Entity ent in savedQueries)
                    {
                        SavedQuery rsq = (SavedQuery)ent;
                        Console.WriteLine("{0} : {1} : {2} : {3} : {4} : {5},", rsq.SavedQueryId, rsq.Name, rsq.QueryType, rsq.IsDefault, rsq.ReturnedTypeCode, rsq.IsQuickFindQuery);
                    }

                    // Deactivate a view
                    System.String SavedQueryName = "Closed Opportunities in Current Fiscal Year";
                    QueryExpression ClosedOpportunitiesViewQuery = new QueryExpression
                    {
                        ColumnSet = new ColumnSet("savedqueryid", "statecode", "statuscode"),
                        EntityName = SavedQuery.EntityLogicalName,
                        Criteria = new FilterExpression
                        {
                            Conditions =
                            {
                                new ConditionExpression
                                {
                                    AttributeName = "querytype",
                                    Operator = ConditionOperator.Equal,
                                    Values = {0}
                                },
                                new ConditionExpression
                                {
                                    AttributeName = "returnedtypecode",
                                    Operator = ConditionOperator.Equal,
                                    Values = {Opportunity.EntityTypeCode}
                                },
                                                new ConditionExpression
                                {
                                    AttributeName = "name",
                                    Operator = ConditionOperator.Equal,
                                    Values = {SavedQueryName}
                                }
                            }
                        }
                    };

                    RetrieveMultipleRequest retrieveOpportuntiesViewRequest = new RetrieveMultipleRequest { Query = ClosedOpportunitiesViewQuery };

                    RetrieveMultipleResponse retrieveOpportuntiesViewResponse = (RetrieveMultipleResponse)_serviceProxy.Execute(retrieveOpportuntiesViewRequest);

                    SavedQuery OpportunityView = (SavedQuery)retrieveOpportuntiesViewResponse.EntityCollection.Entities[0];
                    _viewOriginalState = (SavedQueryState)OpportunityView.StateCode;
                    _viewOriginalStatus = OpportunityView.StatusCode;

                    SetStateRequest ssreq = new SetStateRequest
                    {
                        EntityMoniker = new EntityReference(SavedQuery.EntityLogicalName, (Guid)OpportunityView.SavedQueryId),
                        State = new OptionSetValue((int)SavedQueryState.Inactive),
                        Status = new OptionSetValue(2)
                    };
                    _serviceProxy.Execute(ssreq);
                    _deactivatedViewId = (Guid)OpportunityView.SavedQueryId;

                    DeleteRequiredRecords(promptForDelete);
                    ReactivateDeactivatedView(promptForReactivate);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes the custom view that was created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteView = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want this custom view deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteView = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteView)
            {
                _serviceProxy.Delete(SavedQuery.EntityLogicalName, _customViewId);
                Console.WriteLine("The view has been deleted.");
            }
        }
        /// <summary>
        /// Reactivates the view that was deactivated for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to reactivate the view deactivated in this sample.</param>
        /// </summary>
        public void ReactivateDeactivatedView(bool prompt)
        {
            bool reactivateView = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want to reactivate the \"Closed Opportunities in Current Fiscal Year\" view? (y/n)");
                String answer = Console.ReadLine();

                reactivateView = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (reactivateView)
            {
                SetStateRequest reactivateViewRequest = new SetStateRequest
                {
                    EntityMoniker = new EntityReference(SavedQuery.EntityLogicalName, _deactivatedViewId),
                    State = new OptionSetValue((int)_viewOriginalState),
                    Status = _viewOriginalStatus
                };
                _serviceProxy.Execute(reactivateViewRequest);
                Console.WriteLine("The view has been reactivated.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Slightly modified Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                WorkWithViews app = new WorkWithViews();
                // The Run method has an additional parameter to prompt for reactivation of a view.
                app.Run(config, true, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main
    }
}

See Also

Reference

Saved query XML reference

Concepts

Customize entity views
SavedQuery (view) entity messages and methods

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Saved query XML reference

Use the View editor to manipulate the XML that defines views. Use the information in this section when you edit the Saved Query XML.

In This Section

<ascend> (SavedQuery)

Specifies the attribute (column) in the columnset that will be sorted in ascending order.

<CanBeDeleted> (SavedQuery)

Specifies whether the view can be deleted.

<cell> (SavedQuery)

Describes a field returned in the layoutxml of a savedquery.

<column> (SavedQuery)

Describes a field returned in a saved query using columnsetxml.

<columnset> (SavedQuery)

Describes a group of columns to return when columnsetxml is used in a saved query.

<columnsetxml> (SavedQuery)

Defines a set of columns to return in a saved query.

<conditionalformatting> (SavedQuery)

Specifies the conditional formatting of this view.

<descend> (SavedQuery)

Specifies the attribute (column) in the columnset that will be sorted in descending order.

<Description> (SavedQuery)

Provides a description in a specific language for the parent of the Descriptions element.

<Descriptions> (SavedQuery)

Specifies a group of descriptions for different languages.

<fetchxml> (SavedQuery)

Describes the data to return in the saved query using the FetchXML language.

<grid> (SavedQuery)

Defines a grid structure for the presentation of data in a saved query.

<IntroducedVersion> (SavedQuery)

The representation of a version number representing the version of the solution that the solution component was added in.

<IsCustomizable> (SavedQuery)

Indicates that the saved query is customizable.

<isdefault> (SavedQuery)

Indicates that the saved query represents the default view of an entity.

<isprivate> (SavedQuery)

This element is deprecated.

<isquickfindquery> (SavedQuery)

Indicates whether the saved query represents a Quick Find view.

<CanBeDeleted> (SavedQuery)

This element is deprecated.

<layoutxml> (SavedQuery)

Defines a grid that displays results from the saved query.

<LocalizedName> (SavedQuery)

Provides a localized name for the saved query.

<LocalizedNames> (SavedQuery)

Specifies a group of LocalizedName elements for the saved query.

<queryapi> (SavedQuery)

For internal use only.

<querytype> (SavedQuery)

Describes the type of the query.

<returnedtypecode> (SavedQuery)

Describes the entity information returned using the entity type code.

<row> (SavedQuery)

Contains a row in a grid for a saved query.

<savedqueries> (SavedQuery)

Groups all the saved queries.

<SavedQueries> (SavedQuery) (Parent of <savedqueries>)

Groups all of the saved queries for a particular entity.

<savedquery> (SavedQuery)

Defines a saved query.

<savedqueryid> (SavedQuery)

Defines an ID value for a saved query.

See Also

Reference

Edit the customizations XML file with schema validation
When to edit the customizations file

Concepts

Customize entity views

Other Resources

Customization XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ascend> (SavedQuery)

Specifies the attribute (column) in the columnset that will be sorted in ascending order.

Syntax

Xml Copy Code
<ascend>String</ascend>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<columnset> (SavedQuery) | Describes a group of columns to return when columnsetxml is used in a saved query.

Element Information

Schema Type | String
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/columnsetxml/columnset/ascend

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CanBeDeleted> (SavedQuery)

Specifies whether the view can be deleted.

Syntax

Xml Copy Code
<CanBeDeleted>[0|1]</CanBeDeleted>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | TrueFalse01Type
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/CanBeDeleted

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<cell> (SavedQuery)

Describes a field returned in the layoutxml of a savedquery.

Syntax

Xml Copy Code
<cell
 addedby="String"
 cellType="String"
 desc="String"
 disableMetaDataBinding=[0|1]
 disableSorting=[0|1]
 ishidden=[0|1]
 LabelId="String"
 name="String"
 width="Positive Number"
/>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional
cellType | For internal use only. | String | Optional
desc | Deprecated. | String | Optional
disableMetaDataBinding | For internal use only. | Boolean | Optional
disableSorting | Prevents the UI from making the column sortable. Used to improve performance when the attribute is a partylist or related entity column. | Boolean | Optional
ishidden | Prevents the column from being displayed in the application. | Boolean | Optional
LabelId | For internal use only. | String | Optional
name | Specifies the name of the attribute or the name of the attribute prefixed by the FetchXML link-entity alias when used with a related entity column. | String | Required
width | Specifies the width of the cell in pixels. | Positive Number | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<row> (SavedQuery) | Contains a row in a grid for a saved query.

Element Information

Schema Type | complexType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or more
XPath | //Entity/SavedQueries/savedqueries/savedquery/layoutxml/grid/row/cell

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<column> (SavedQuery)

Describes a field returned in a saved query using columnsetxml.

Syntax

Xml Copy Code
<column addedby="String">String</column>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
addedby | Identifies the name of the ISV or customizer that added the element. | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<columnset> (SavedQuery) | Describes a group of columns to return when columnsetxml is used in a saved query.

Element Information

Schema Type | String
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or more
XPath | //Entity/SavedQueries/savedqueries/savedquery/columnsetxml/columnset/column

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<columnset> (SavedQuery)

Describes a group of columns to return when columnsetxml is used in a saved query.

Syntax

Xml Copy Code
<columnset
 distinct=["0" | "1" | "true" | "false"]
 version="String">
 <ascend />
 <column />
 <descend />
 <filter />
</columnset>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
distinct | Not used. | Boolean | Optional
version | Deprecated. | String | Optional

Child Elements

Element | Description
<column> (SavedQuery) | Describes a field returned in a saved query using columnsetxml.
<ascend> (SavedQuery) | Specifies the attribute (column) in the columnset that will be sorted in ascending order.
<descend> (SavedQuery) | Specifies the attribute (column) in the columnset that will be sorted in descending order.
<filter> (Fetch XML) | Used for constructing complex conditionals.

Parent Elements

Element | Description
<columnsetxml> (SavedQuery) | Defines a set of columns to return in a saved query.

Element Information

Schema Type | complexType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/columnsetxml/columnset

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<columnsetxml> (SavedQuery)

Defines a set of columns to return in a saved query.

Syntax

Xml Copy Code
<columnsetxml>
 <columnset />
</columnsetxml>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<columnset> (SavedQuery) | Describes a group of columns to return when columnsetxml is used in a saved query.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | complexType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/columnsetxml

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<conditionalformatting> (SavedQuery)

Specifies the conditional formatting of this view.

Syntax

Xml Copy Code
<conditionalformatting>String</conditionalformatting>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | String
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/conditionalformatting

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<descend> (SavedQuery)

Specifies the attribute (column) in the columnset that will be sorted in descending order.

Syntax

Xml Copy Code
<descend>String</descend>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<columnset> (SavedQuery) | Describes a group of columns to return when columnsetxml is used in a saved query.

Element Information

Schema Type | String
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/columnsetxml/columnset/descend

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Description> (SavedQuery)

Provides a description in a specific language for the parent of the Descriptions element.

Syntax

Xml Copy Code
<Description
 description="String"
 id="String"
 languagecode="String"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Element | Description | Type | Usage
description | Text providing the description. | String | Required
languagecode | Valid locale ID values can be found at Locale ID (LCID) Chart. | Positive Integer | Required
id | For internal use only. | String | Optional

Child Elements

This element has no attributes.

Parent Elements

Element | Description
<Descriptions> (SavedQuery) | Descriptions

Element Information

Schema Type | FieldXmlFieldUIType
Validation File | fetch.xsd
Number of occurrences | 0 or more
XPath | //Entity/SavedQueries/savedqueries/savedquery/Descriptions/Description

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Descriptions> (SavedQuery)

Specifies a group of descriptions for different languages.

Syntax

Xml Copy Code
<Descriptions >
 <Description />
</Descriptions>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Description> (SavedQuery) | Provides a description in a specific language for the parent of the Descriptions element.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | DescriptionsType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/Descriptions

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<fetchxml> (SavedQuery)

Describes the data to return in the saved query using the FetchXML language.

Syntax

Xml Copy Code
<fetchxml>
 <fetch />
</fetchxml>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<fetch> (Fetch XML) | The definition of a query to execute for the view.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | complexType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/fetchxml

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<grid> (SavedQuery)

Defines a grid structure for the presentation of data in a saved query.

Syntax

Xml Copy Code
<grid
 icon = [0|1]
 iconrenderer="String"
 jump="String"
 name="String"
 object="String"
 preview= [0|1]
 select = [0|1] >
 <row />
</grid>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
icon | Indicates whether to display an icon with the grid. | Boolean | Required
iconrenderer | For internal use only. | String | Optional
jump | Contains the name of the attribute used to filter rows using the alphabetical index at the bottom of the grid. | String | Required
name | Should be the plural entity name or "resultset". | string | Required
object | Specifies the entity type code. | Positive Integer | Required
preview | Indicates if the saved query represents a preview. | Boolean | Required
select | This value should always be 1. | Boolean | Required

Child Elements

Element | Description
<row> (SavedQuery) | Contains a row in a grid for a saved query.

Parent Elements

Element | Description
<layoutxml> (SavedQuery) | Defines a grid that displays results from the saved query.

Element Information

Schema Type | complexType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/layoutxml/grid

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<IntroducedVersion> (SavedQuery)

The representation of a version number representing the version of the solution that the solution component was added in.

Syntax

Xml Copy Code
<IntroducedVersion>String</IntroducedVersion>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Remarks

The string must match this regular expression pattern: ^[0-9]+(\.[0-9]+){1,3}$.

Schema Type | VersionType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/IntroducedVersion

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<IsCustomizable> (SavedQuery)

Indicates that the saved query is customizable.

Syntax

Xml Copy Code
<IsCustomizable name=["Yes"|"No"]>[1|0]</IsCustomizable>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
name | The value of the element is 0 or 1 and corresponds to the value of the name attribute, which is "No" or "Yes". | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | SerializedTrueFalse01Type
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/IsCustomizable

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<isdefault> (SavedQuery)

Indicates that the saved query represents the default view of an entity.

Syntax

Xml Copy Code
<isdefault name=["Yes"|"No"]>[1|0]</isdefault>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description |  |
name | The value of the element is 0 or 1 and corresponds to the value of the name attribute, which is "No" or "Yes". | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Remarks

Each querytype can have a default view defined.

Element Information

Schema Type | SerializedTrueFalse01Type
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/isdefault

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<isprivate> (SavedQuery)

This element is deprecated.

Syntax

Xml Copy Code
<isprivate>[0|1]</isprivate>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | TrueFalse01Type
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/isprivate

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<isquickfindquery> (SavedQuery)

Indicates whether the saved query represents a Quick Find view.

Syntax

Xml Copy Code
<isquickfindquery name=["Yes"|"No"]>[1|0]</isquickfindquery>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
nane | The value of the element can be 0 or 1 and corresponds to the value of the name attribute, which is "Yes" or "No". | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | SerializedTrueFalse01Type
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/isquickfindquery

See Also

Reference

Saved query XML reference
Types of Views

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<layoutxml> (SavedQuery)

Defines a grid that displays results from the saved query.

Syntax

Xml Copy Code
<layoutxml>
 <grid />
</layoutxml>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<grid> (SavedQuery) | Defines a grid structure for the presentation of data in a saved query.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | complexType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/layoutxml

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<LocalizedName> (SavedQuery)

Provides a localized name for the saved query.

Syntax

Xml Copy Code
<LocalizedName
 description="String"
 id="GUID"
 languagecode="Positive Integer"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
description | Text providing the localized name. | String | Required
id | For internal use only. | GUID | Optional
languagecode | Valid locale ID values can be found at Locale ID (LCID) Chart. | Positive Integer | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<LocalizedNames> (SavedQuery) |

Element Information

Schema Type | FieldXmlFieldUIType
Validation File | Fetch.xsd
Number of occurrences | 0 or more
XPath | //Entity/SavedQueries/savedqueries/savedquery/LocalizedNames/LocalizedName

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<LocalizedNames> (SavedQuery)

Specifies a group of LocalizedName elements for the saved query.

Syntax

Xml Copy Code
<LocalizedNames>
 <LocalizedName />
</LocalizedNames>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<LocalizedName> (SavedQuery) | Provides a localized name for the saved query.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | LocalizedNamesType
Validation File | CustomizationSolution.xsd
Number of occurrences | 1 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/LocalizedNames

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<queryapi> (SavedQuery)

For internal use only.

Syntax

Xml Copy Code
<queryapi>String</queryapi>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | String
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/queryapi

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<querytype> (SavedQuery)

Describes the type of the query.

Syntax

Xml Copy Code
<querytype formattedvalue="String">Integer</querytype>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
formattedvalue | Must match the value of the node. | String | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Remarks

The value of the node must use one of the values listed in this table.

Type | Value
Main Application View | 0
Advanced Search | 1
Associated View | 2
Quick find search | 4
Lookup View | 64

Example

The following code sample shows the use of the querytype element.

Xml Copy Code
<querytype formattedvalue="64">64</querytype>

Element Information

Schema Type | SerializedInteger
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/querytype

See Also

Reference

Saved query XML reference
Types of Views

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<returnedtypecode> (SavedQuery)

Describes the entity information returned using the entity type code.

Syntax

Xml Copy Code
<returnedtypecode formattedvalue="String">Integer</returnedtypecode>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
formattedvalue | Formatted value of the node. | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Remarks

The Entity Type Code corresponds to the EntityMetadata. ObjectTypeCode. For custom entities this value may be different for each organization so it is not recommended as a unique identifier for an entity.

Example

The following code sample shows the use of the returnedtypecode element.

Xml Copy Code
<returnedtypecode formattedvalue="1,090">1090</returnedtypecode>

Element Information

Schema Type | SerializedInteger
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/returnedtypecode

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<row> (SavedQuery)

Contains a row in a grid for a saved query.

Syntax

Xml Copy Code
<row
 id="String"
 layoutstyle="String"
 multiobjectidfield="String"
 name="String">
 <cell />
</row>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
id | Represents the attribute that represents the unique id in the row. | String | Optional
layoutstyle | For internal use only. | String | Optional
multiobjectidfield | Used when a saved query can return multiple types of entities. If so, this contains the name of the attribute that differentiates the type of entity. | String | Optional
name | The value is either the entity singular name or "result". | String | Optional

Child Elements

Element | Description
<cell> (SavedQuery) | Describes a field returned in the layoutxml of a savedquery.

Parent Elements

Element | Description
<grid> (SavedQuery) | Defines a grid structure for the presentation of data in a saved query.

Element Information

Schema Type | complexType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or more
XPath | //Entity/SavedQueries/savedqueries/savedquery/layoutxml/grid/row

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<savedqueries> (SavedQuery)

<savedqueries> (SavedQuery)

Syntax

Xml Copy Code
<savedqueries
 entity="String"
 morerecords="String"
 paging-cookie="String"
 version="String"
 >
 <savedquery />
</savedqueries>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
entity | Value is always "SavedQuery". | String | Required
morerecords | Deprecated. | String | Optional
paging-cookie | Deprecated. | String | Optional
version | Deprecated. | String | Optional

Child Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Parent Elements

Element | Description
<SavedQueries> (SavedQuery) (Parent of <savedqueries>) | Groups all of the saved queries for a particular entity.

Element Information

Schema Type | complexType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries/savedqueries

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SavedQueries> (SavedQuery) (Parent of <savedqueries>)

Groups all of the saved queries for a particular entity.

Syntax

Xml Copy Code
<SavedQueries>
 <savedqueries />
<SavedQueries>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<savedqueries> (SavedQuery) | Groups all the saved queries.

Parent Elements

Element | Description
<Entity> (ImportExportXml) | The root node for the definition of an entity.

Element Information

Schema Type | SavedQueriesType
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or 1
XPath | //Entity/SavedQueries

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<savedquery> (SavedQuery)

Defines a saved query.

Syntax

Xml Copy Code
<savedquery>
 <CanBeDeleted />
 <columnsetxml />
 <conditionalformatting />
 <Descriptions />
 <fetchxml />
 <IsCustomizable />
 <isdefault />
 <isprivate />
 <isquickfindquery />
 <layoutxml />
 <LocalizedNames />
 <queryapi />
 <querytype />
 <returnedtypecode />
 <savedqueryid />
</savedquery>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<CanBeDeleted> (SavedQuery) | Specifies whether the view can be deleted.
<columnsetxml> (SavedQuery) | Defines a set of columns to return in a saved query.
<conditionalformatting> (SavedQuery) | Specifies the conditional formatting of this view.
<Descriptions> (SavedQuery) | Specifies a group of descriptions for different languages.
<fetchxml> (SavedQuery) | Describes the data to return in the saved query using the FetchXML language.
<IsCustomizable> (SavedQuery) | Indicates that the saved query is customizable.
<isdefault> (SavedQuery) | Indicates that the saved query represents the default view of an entity.
<isprivate> (SavedQuery) | This element is deprecated.
<isquickfindquery> (SavedQuery) | Indicates whether the saved query represents a Quick Find view.
<layoutxml> (SavedQuery) | Defines a grid that displays results from the saved query.
<LocalizedNames> (SavedQuery) | Specifies a group of LocalizedName elements for the saved query.
<queryapi> (SavedQuery) | For internal use only.
<querytype> (SavedQuery) | Describes the type of the query.
<returnedtypecode> (SavedQuery) | Describes the entity information returned using the entity type code.
<savedqueryid> (SavedQuery) | Defines an ID value for a saved query.

Parent Elements

Element | Description
<savedqueries> (SavedQuery) | Groups all the saved queries.

Element Information

Schema Type | String
Validation File | CustomizationSolution.xsd
Number of occurrences | 0 or more
XPath | //Entity/SavedQueries/savedqueries/savedquery

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<savedqueryid> (SavedQuery)

Defines an ID value for a saved query.

Syntax

Xml Copy Code
<savedqueryid>String</savedqueryid>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<savedquery> (SavedQuery) | Defines a saved query.

Element Information

Schema Type | GuidType
Validation File | CustomizationSolution.xsd
Number of occurrences | 1
XPath | //Entity/SavedQueries/savedqueries/savedquery/savedqueryid

See Also

Reference

Saved query XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize global option sets

Typically, you use global option sets to set fields so that different fields can share the same set of options, which are maintained in one location. You can reuse global option sets. You will also see them used in request parameters in a manner similar to an enumeration.

When you define an option value by using OptionMetadata, we recommend that you let the system assign a value. You do this by passing a null value when you create the new OptionMetadata instance. When you define an option, it will contain an option value prefix specific to the context of the publisher set for the solution that the option set is created in. This prefix helps reduce the chance of creating duplicate option sets for a managed solution, and in any option sets that are defined in organizations where your managed solution is installed. For more information, see Merging Option set options.

In This Topic

Retrieve a Global Option Set

Create a Global Option Set

Create a Picklist That Uses a Global Option Set

Update a Global Option Set

Retrieve all Global Option Sets

Delete a Global Option Set

Retrieve a global option set

The following sample shows how to retrieve a global option set by name using the RetrieveOptionSetRequest message:

C# Copy Code
// Use the RetrieveOptionSetRequest message to retrieve
// a global option set by it's name.
RetrieveOptionSetRequest retrieveOptionSetRequest =
    new RetrieveOptionSetRequest
    {
        Name = _globalOptionSetName
    };

// Execute the request.
RetrieveOptionSetResponse retrieveOptionSetResponse =
    (RetrieveOptionSetResponse)_serviceProxy.Execute(
    retrieveOptionSetRequest);

Console.WriteLine("Retrieved {0}.",
    retrieveOptionSetRequest.Name);

// Access the retrieved OptionSetMetadata.
OptionSetMetadata retrievedOptionSetMetadata =
    (OptionSetMetadata)retrieveOptionSetResponse.OptionSetMetadata;

// Get the current options list for the retrieved attribute.
OptionMetadata[] optionList =
    retrievedOptionSetMetadata.Options.ToArray();

Create a global option set

Use the CreateOptionSetRequest message to create a new global option set. Set the IsGlobal property to true to indicate that the option set is global. The following code example creates a global option set called “Example Option Set”:

C# Copy Code
#region How to create global option set
// Define the request object and pass to the service.
CreateOptionSetRequest createOptionSetRequest = new CreateOptionSetRequest
{
    // Create a global option set (OptionSetMetadata).
    OptionSet = new OptionSetMetadata
    {
        Name = _globalOptionSetName,
        DisplayName = new Label("Example Option Set", _languageCode),
        IsGlobal = true,
        OptionSetType = OptionSetType.Picklist,
        Options =
    {
        new OptionMetadata(new Label("Open", _languageCode), null),
        new OptionMetadata(new Label("Suspended", _languageCode), null),
        new OptionMetadata(new Label("Cancelled", _languageCode), null),
        new OptionMetadata(new Label("Closed", _languageCode), null)
    }
    }
};

// Execute the request.
CreateOptionSetResponse optionsResp =
    (CreateOptionSetResponse)_serviceProxy.Execute(createOptionSetRequest);

Create a picklist that uses a global option set

The following sample shows how to create a picklist attribute that uses a global option set by using CreateAttributeRequest:

C# Copy Code
// Create a Picklist linked to the option set.
// Specify which entity will own the picklist, and create it.
CreateAttributeRequest createRequest = new CreateAttributeRequest
{
    EntityName = Contact.EntityLogicalName,
    Attribute = new PicklistAttributeMetadata
    {
        SchemaName = "sample_examplepicklist",
        LogicalName = "sample_examplepicklist",
        DisplayName = new Label("Example Picklist", _languageCode),
        RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),

        // In order to relate the picklist to the global option set, be sure
        // to specify the two attributes below appropriately.
        // Failing to do so will lead to errors.
        OptionSet = new OptionSetMetadata
        {
            IsGlobal = true,
            Name = _globalOptionSetName
        }
    }
};

_serviceProxy.Execute(createRequest);

Update a global option set

The following sample shows how to update the label for a global option set by using UpdateOptionSetRequest:

C# Copy Code
// Use UpdateOptionSetRequest to update the basic information of an option
// set. Updating option set values requires different messages (see below).
UpdateOptionSetRequest updateOptionSetRequest = new UpdateOptionSetRequest
{
    OptionSet = new OptionSetMetadata
    {
        DisplayName = new Label("Updated Option Set", _languageCode),
        Name = _globalOptionSetName,
        IsGlobal = true
    }
};

_serviceProxy.Execute(updateOptionSetRequest);

//Publish the OptionSet
PublishXmlRequest pxReq1 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
_serviceProxy.Execute(pxReq1);

Ordering options

The following sample shows how the options in a global option set can be ordered by using OrderOptionRequest:

C# Copy Code
// Change the order of the original option's list.
// Use the OrderBy (OrderByDescending) linq function to sort options in
// ascending (descending) order according to label text.
// For ascending order use this:
var updateOptionList =
    optionList.OrderBy(x => x.Label.LocalizedLabels[0].Label).ToList();

// For descending order use this:
// var updateOptionList =
//      optionList.OrderByDescending(
//      x => x.Label.LocalizedLabels[0].Label).ToList();

// Create the request.
OrderOptionRequest orderOptionRequest = new OrderOptionRequest
{
    // Set the properties for the request.
    OptionSetName = _globalOptionSetName,
    // Set the changed order using Select linq function
    // to get only values in an array from the changed option list.
    Values = updateOptionList.Select(x => x.Value.Value).ToArray()
};

// Execute the request
_serviceProxy.Execute(orderOptionRequest);

//Publish the OptionSet
PublishXmlRequest pxReq4 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
_serviceProxy.Execute(pxReq4);

Retrieve all global option sets

The following sample shows how to retrieve all global option sets by using RetrieveAllOptionSetsRequest:

C# Copy Code
// Use RetrieveAllOptionSetsRequest to retrieve all global option sets.
// Create the request.
RetrieveAllOptionSetsRequest retrieveAllOptionSetsRequest =
    new RetrieveAllOptionSetsRequest();

// Execute the request
RetrieveAllOptionSetsResponse retrieveAllOptionSetsResponse =
    (RetrieveAllOptionSetsResponse)_serviceProxy.Execute(
    retrieveAllOptionSetsRequest);

// Now you can use RetrieveAllOptionSetsResponse.OptionSetMetadata property to
// work with all retrieved option sets.
if (retrieveAllOptionSetsResponse.OptionSetMetadata.Count() > 0)
{
    Console.WriteLine("All the global option sets retrieved as below:");
    int count = 1;
    foreach (OptionSetMetadataBase optionSetMetadata in
        retrieveAllOptionSetsResponse.OptionSetMetadata)
    {
        Console.WriteLine("{0} {1}", count++,
            (optionSetMetadata.DisplayName.LocalizedLabels.Count >0)? optionSetMetadata.DisplayName.LocalizedLabels[0].Label : String.Empty);
    }
}

Delete a global option set

The following sample shows how to check whether a global option set is being used by another solution component by using RetrieveDependentComponentsRequest, and then how to delete it by using DeleteOptionSetRequest:

C# Copy Code
// Create the request to see which components have a dependency on the
// global option set.
RetrieveDependentComponentsRequest dependencyRequest =
    new RetrieveDependentComponentsRequest
    {
        ObjectId = _optionSetId,
        ComponentType = (int)componenttype.OptionSet
    };

RetrieveDependentComponentsResponse dependencyResponse =
    (RetrieveDependentComponentsResponse)_serviceProxy.Execute(
    dependencyRequest);

// Here you would check the dependencyResponse.EntityCollection property
// and act as appropriate. However, we know there is exactly one
// dependency so this example deals with it directly and deletes
// the previously created attribute.
DeleteAttributeRequest deleteAttributeRequest =
    new DeleteAttributeRequest
{
    EntityLogicalName = Contact.EntityLogicalName,
    LogicalName = "sample_examplepicklist"
};

_serviceProxy.Execute(deleteAttributeRequest);

Console.WriteLine("Referring attribute deleted.");
#endregion How to delete attribute

#region How to delete global option set

// Finally, delete the global option set. Attempting this before deleting
// the picklist above will result in an exception being thrown.
DeleteOptionSetRequest deleteRequest = new DeleteOptionSetRequest
{
    Name = _globalOptionSetName
};

_serviceProxy.Execute(deleteRequest);

See Also

Concepts

Insert, update, delete, and order global option set options
Global option set messages
Global option set metadata values

Other Resources

Developers guide to customization for Microsoft Dynamics CRM
Extend the metadata model
Sample: Create a global option set
Sample: Work with global option sets
Sample: Dump global option set information to a file

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Insert, update, delete, and order global option set options

These code samples show you how to insert, update, delete, and order options in a global option set.

In This Topic

Insert a new option

Update an option

Delete an option

Order options

Insert a new option

The following sample shows how to add a new option to a global option set by using InsertOptionValueRequest:

C# Copy Code
// Use InsertOptionValueRequest to insert a new option into a
// global option set.
InsertOptionValueRequest insertOptionValueRequest =
    new InsertOptionValueRequest
    {
        OptionSetName = _globalOptionSetName,
        Label = new Label("New Picklist Label", _languageCode)
    };

// Execute the request and store the newly inserted option value
// for cleanup, used in the later part of this sample.
_insertedOptionValue = ((InsertOptionValueResponse)_serviceProxy.Execute(
    insertOptionValueRequest)).NewOptionValue;

//Publish the OptionSet
PublishXmlRequest pxReq2 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
_serviceProxy.Execute(pxReq2);

Update an option

The following sample shows how to update an option in a global option set by using UpdateOptionValueRequest:

C# Copy Code
// In order to change labels on option set values (or delete) option set
// values, you must use UpdateOptionValueRequest
// (or DeleteOptionValueRequest).
UpdateOptionValueRequest updateOptionValueRequest =
    new UpdateOptionValueRequest
    {
        OptionSetName = _globalOptionSetName,
        // Update the second option value.
        Value = optionList[1].Value.Value,
        Label = new Label("Updated Option 1", _languageCode)
    };

_serviceProxy.Execute(updateOptionValueRequest);

//Publish the OptionSet
PublishXmlRequest pxReq3 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
_serviceProxy.Execute(pxReq3);

Delete an option

The following sample shows how to deletes an option in a global option set by using DeleteOptionValueRequest:

C# Copy Code
// Use the DeleteOptionValueRequest message
// to remove the newly inserted label.
DeleteOptionValueRequest deleteOptionValueRequest =
    new DeleteOptionValueRequest
{
    OptionSetName = _globalOptionSetName,
    Value = _insertedOptionValue
};

// Execute the request.
_serviceProxy.Execute(deleteOptionValueRequest);

Order options

The following sample shows how to set the order of options in a global option set by using OrderOptionRequest:

C# Copy Code
// Change the order of the original option's list.
// Use the OrderBy (OrderByDescending) linq function to sort options in
// ascending (descending) order according to label text.
// For ascending order use this:
var updateOptionList =
    optionList.OrderBy(x => x.Label.LocalizedLabels[0].Label).ToList();

// For descending order use this:
// var updateOptionList =
//      optionList.OrderByDescending(
//      x => x.Label.LocalizedLabels[0].Label).ToList();

// Create the request.
OrderOptionRequest orderOptionRequest = new OrderOptionRequest
{
    // Set the properties for the request.
    OptionSetName = _globalOptionSetName,
    // Set the changed order using Select linq function
    // to get only values in an array from the changed option list.
    Values = updateOptionList.Select(x => x.Value.Value).ToArray()
};

// Execute the request
_serviceProxy.Execute(orderOptionRequest);

//Publish the OptionSet
PublishXmlRequest pxReq4 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
_serviceProxy.Execute(pxReq4);

See Also

Concepts

Customize global option sets
Global option set messages
Global option set metadata values

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Global option set messages

A global option set, sometimes called a global picklist, provides a common set of options that can be used by multiple entity option set attributes.

Messages

The following table lists the messages that you can use with global option sets.

Message | Description
CreateOptionSetRequest | Creates a new global option set.
DeleteOptionSetRequest | Deletes a global option set.
DeleteOptionValueRequest | Deletes one of the values in a global option set.
InsertOptionValueRequest | Inserts a new option into a global option set.
InsertStatusValueRequest | Inserts a new option into the global option set used in the Status attribute.
OrderOptionRequest | Changes the relative order of the options in an option set.
RetrieveAllOptionSetsRequest | Retrieves all the global option sets.
RetrieveOptionSetRequest | Retrieves a global option set.
UpdateOptionSetRequest | Updates a global option set.
UpdateOptionValueRequest | Updates an option in a global option set.
UpdateStateValueRequest | Inserts a new option into the option set used in the Status attribute.

See Also

Concepts

Customize global option sets
Global option set metadata values

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Global option set metadata values

This topic lists the global option set values for a default, un-customized installation of Microsoft Dynamics CRM. Except for the Global Boolean Option Sets listed below, enumerations for properties that use these values are available by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project. For more information, see Helper code: Enumerations for option sets.

The values in this topic were generated using the code in Sample: Dump global option set information to a file.

In This Topic

Global Boolean Option Sets

A Yes or No Boolean (field_security_permission_type)

Activity Type (activitypointer_activitytypecode)

Authentication Protocol

Budget

Case Origin (incident_caseorigincode)

Category (connectionrole_category)

Component State (componentstate)

Component Type (componenttype)

Delivery Priority

Dependency Type (dependencytype)

Executing User

Fiscal Period (goal_fiscalperiod)

Fiscal Year (goal_fiscalyear)

Goal Type (metric_goaltype)

Initial Communication

Lead Sales Stage

MonthOfYear (recurrencerule_monthofyear)

Need

Object Type (workflowlog_objecttypecode)

Opportunity Sales Stage

Post Message type (socialactivity_postmessagetype)

Pricing Error (qooi_pricingerrorcode)

Product Type

Properties Configuration

Purchase Process

Purchase Timeframe

Service Stage

Social Channel (socialprofile_community)

Sync Direction

Stage Category

Validation Status (sharepoint_validationstatus)

Validation Status Reason (sharepoint_validationstatusreason)

Workflow Stage

Global Boolean Option Sets

BooleanAttributeMetadata attributes have an OptionSet property and can be assigned to use a global option set, although this is not commonly done. The RetrieveAllOptionSetsRequest will return these option sets but they are not included in the Helper code: Enumerations for option sets. These global option sets are also not displayed in the application or available to be set as the options for a Boolean attribute using the application.

The following global Boolean option sets are for internal use only:

  • Confirm Interest
  • Decision Maker?
  • Description
  • Identified Competitors?
  • Identified Customer Contacts?
  • Identified Pursuit Team?
  • Is Encrypted Attribute Value Set

Is Component Managed

A Boolean option set used for whether a solution component is managed. These values are used to set the IsManaged attribute in the following entities: ActivityMimeAttachment, AttributeMap, ConnectionRole, ContractTemplate, DisplayString, EntityMap, FieldPermission, FieldSecurityProfile, KbArticleTemplate, MailMergeTemplate, PluginAssembly, PluginType, Report, ReportCategory, ReportEntity, ReportVisibility, Role, SavedQuery, SavedQueryVisualization, SdkMessageProcessingStep, SdkMessageProcessingStepImage, SdkMessageProcessingStepSecureConfig, ServiceEndpoint, SystemForm, Template, WebResource and Workflow.

Value | Label
0 | Unmanaged
1 | Managed

Is Regular Activity

A Boolean option set used by the RecurringAppointmentMaster.IsRegularActivity attribute for information regarding whether an activity is a regular activity type or event type.

Value | Label
0 | No
1 | Yes

Metric Type

A Boolean option set used for the Metric.IsAmount attribute.

Value | Label
0 | Count
1 | Amount

A Yes or No Boolean (field_security_permission_type)

An option set used for field security permission in the FieldPermissionType class.

Value | Label
0 | Not Allowed
4 | Allowed

Activity Type (activitypointer_activitytypecode)

Use this to set or compare the activitytypecode attribute in the following entities: ActivityPointer, Appointment, BulkOperation, CampaignActivity, CampaignResponse, Email, Fax, IncidentResolution, Letter, OpportunityClose, OrderClose, PhoneCall, QuoteClose, RecurringAppointmentMaster, ServiceAppointment and Task.

Value | Label
4201 | Appointment
4202 | Email
4204 | Fax
4206 | Case Resolution
4207 | Letter
4208 | Opportunity Close
4209 | Order Close
4210 | Phone Call
4211 | Quote Close
4212 | Task
4214 | Service Activity
4251 | Recurring Appointment
4401 | Campaign Response
4402 | Campaign Activity
4406 | Bulk Operation

Authentication Protocol

This option set is used to set or compare these attributes in the EmailServerProfile entity: IncomingAuthenticationProtocol, and OutgoingAuthenticationProtocol attributes.

Value | Label
0 | Auto Detect
1 | Negotiate
2 | NTLM
3 | Basic

Budget

Use these values to set or compare the Lead and OpportunityBudgetStatus attributes.

Value | Label
0 | No Committed Budget
1 | May Buy
2 | Can Buy
3 | Will Buy

Case Origin (incident_caseorigincode)

Use these values to set or compare the EntitlementChannel.Channel,EntitlementTemplateChannel.Channel, andIncident.CaseOriginCode attributes.

Value | Label
1 | Phone
2 | Email
3 | Web
2483 | Facebook
3986 | Twitter

Category (connectionrole_category)

Use these values to specify the connection role category. To set the category, use the ConnectionRole.Category attribute.

OptionSetDisplayName | OptionValue | OptionDescription
Category | 1 | Business
Category | 2 | Family
Category | 3 | Social
Category | 4 | Sales
Category | 5 | Other
Category | 1000 | Stakeholder
Category | 1001 | Sales Team
Category | 1002 | Service

Component State (componentstate)

These values represent the possible states of solution components. These values are used to set the ComponentState attribute in the following entities: ActivityMimeAttachment, AttributeMap, ConnectionRole, ContractTemplate, DependencyFeature, DisplayString, EntityMap, FieldPermission, FieldSecurityProfile, KbArticleTemplate, MailMergeTemplate, PluginAssembly, PluginType, ProcessTrigger, Report, ReportCategory, ReportEntity, ReportVisibility, Role, SavedQuery, SavedQueryVisualization, SdkMessageProcessingStep, SdkMessageProcessingStepImage, SdkMessageProcessingStepSecureConfig, ServiceEndpoint, SystemForm, Template, WebResource and Workflow. This value is also used for the ComponentState property.

Value | Label
0 | Published
1 | Unpublished
2 | Deleted
3 | Deleted Unpublished

Component Type (componenttype)

These values represent the possible types of solution components for the SolutionComponent.ComponentType attribute and the following properties: EmptyParentComponentType, ComponentType, ComponentType, ComponentType, ComponentType, ComponentType, ComponentType and ParentComponentType.

Value | Label
1 | Entity
2 | Attribute
3 | Relationship
4 | Attribute Picklist Value
5 | Attribute Lookup Value
6 | View Attribute
7 | Localized Label
8 | Relationship Extra Condition
9 | Option Set
10 | Entity Relationship
11 | Entity Relationship Role
12 | Entity Relationship Relationships
13 | Managed Property
20 | Role
21 | Role Privilege
22 | Display String
23 | Display String Map
24 | Form
25 | Organization
26 | Saved Query
29 | Workflow
31 | Report
32 | Report Entity
33 | Report Category
34 | Report Visibility
35 | Attachment
36 | Email Template
37 | Contract Template
38 | KB Article Template
39 | Mail Merge Template
44 | Duplicate Rule
45 | Duplicate Rule Condition
46 | Entity Map
47 | Attribute Map
48 | Ribbon Command
49 | Ribbon Context Group
50 | Ribbon Customization
52 | Ribbon Rule
53 | Ribbon Tab To Command Map
55 | Ribbon Diff
59 | Saved Query Visualization
60 | System Form
61 | Web Resource
62 | Site Map
63 | Connection Role
65 | Hierarchy Rule
70 | Field Security Profile
71 | Field Permission
90 | Plugin Type
91 | Plugin Assembly
92 | SDK Message Processing Step
93 | SDK Message Processing Step Image
95 | Service Endpoint
150 | Routing Rule
151 | Routing Rule Item
152 | SLA
153 | SLA Item
154 | Convert Rule
155 | Convert Rule Item

Delivery Priority

Use these values to set or compare the ActivityPointer or EmailDeliverPriorityCode attribute.

Value | Label
0 | Low
1 | Normal
2 | High

Dependency Type (dependencytype)

These values describe the type of solution component dependencies. The Dependency.DependencyType and InvalidDependency.ExistingDependencyType attributes use these values. For more information, see Dependency tracking for solution components.

Value | Label
0 | None
1 | Solution Internal
2 | Published
4 | Unpublished

Executing User

Use these values to specify the system user account under which a workflow executes using the RunAs attribute of the Process entity.

Value | Label
0 | Owner
1 | Calling User

Fiscal Period (goal_fiscalperiod)

Use these values to specify the fiscal period for the goal. To set the fiscal period, use the Goal.FiscalPeriod attribute.

Value | Label
1 | Quarter 1
2 | Quarter 2
3 | Quarter 3
4 | Quarter 4
101 | January
102 | February
103 | March
104 | April
105 | May
106 | June
107 | July
108 | August
109 | September
110 | October
111 | November
112 | December
201 | Semester 1
202 | Semester 2
301 | Annual
401 | P1
402 | P2
403 | P3
404 | P4
405 | P5
406 | P6
407 | P7
408 | P8
409 | P9
410 | P10
411 | P11
412 | P12
413 | P13

Fiscal Year (goal_fiscalyear)

Use these values to specify the fiscal year for the goal. To set the fiscal year, use the Goal.FiscalYear attribute.

Value | Label
1970 | FY1970
1971 | FY1971
1972 | FY1972
1973 | FY1973
1974 | FY1974
1975 | FY1975
1976 | FY1976
1977 | FY1977
1978 | FY1978
1979 | FY1979
1980 | FY1980
1981 | FY1981
1982 | FY1982
1983 | FY1983
1984 | FY1984
1985 | FY1985
1986 | FY1986
1987 | FY1987
1988 | FY1988
1989 | FY1989
1990 | FY1990
1991 | FY1991
1992 | FY1992
1993 | FY1993
1994 | FY1994
1995 | FY1995
1996 | FY1996
1997 | FY1997
1998 | FY1998
1999 | FY1999
2000 | FY2000
2001 | FY2001
2002 | FY2002
2003 | FY2003
2004 | FY2004
2005 | FY2005
2006 | FY2006
2007 | FY2007
2008 | FY2008
2009 | FY2009
2010 | FY2010
2011 | FY2011
2012 | FY2012
2013 | FY2013
2014 | FY2014
2015 | FY2015
2016 | FY2016
2017 | FY2017
2018 | FY2018
2019 | FY2019
2020 | FY2020
2021 | FY2021
2022 | FY2022
2023 | FY2023
2024 | FY2024
2025 | FY2025
2026 | FY2026
2027 | FY2027
2028 | FY2028
2029 | FY2029
2030 | FY2030
2031 | FY2031
2032 | FY2032
2033 | FY2033
2034 | FY2034
2035 | FY2035
2036 | FY2036
2037 | FY2037
2038 | FY2038

Goal Type (metric_goaltype)

Use these values to set or compare values for the Metric.AmountDataType and Goal.AmountDataType attributes.

Value | Label
0 | Money
1 | Decimal
2 | Integer

Initial Communication

Use these values to set or compare values for the Lead.InitialCommunication and Opportunity.InitialCommunication properties.

Value | Label
0 | Contacted
1 | Not Contacted

Lead Sales Stage

Use these values to set or compare values for the Lead.SalesStage attribute.

Value | Label
0 | Qualify

MonthOfYear (recurrencerule_monthofyear)

Use these values to set or compare the RecurrenceRule.MonthOfYear and RecurringAppointmentMaster.MonthOfYear attribute values.

Value | Label
0 | Invalid Month Of Year
1 | January
2 | February
3 | March
4 | April
5 | May
6 | June
7 | July
8 | August
9 | September
10 | October
11 | November
12 | December

Need

Use these values to set or compare values for the Lead.Need and Opportunity.Need attributes.

OptionValue | OptionDescription
0 | Must have
1 | Should have
2 | Good to have
3 | No need

Object Type (workflowlog_objecttypecode)

Type of entity with which the workflow log is associated.

Value | Label
4700 | System Job
4710 | Workflow Session

Opportunity Sales Stage

Use these values to set or compare values for the Opportunity.SalesStage attribute.

OptionValue | OptionDescription
0 | Qualify
1 | Develop
2 | Propose
3 | Close

Post Message type (socialactivity_postmessagetype)

Use these values to specify types of posts for the Incident.MessageTypeCode and SocialActivity.PostMessageType attributes.

Value | Label
0 | Public Message
1 | Private Message

Pricing Error (qooi_pricingerrorcode)

Use these values to specify pricing error codes for the quote detail (quote product), sales order detail (order product) and invoice detail (invoice product). To set the pricing error code, use the PricingErrorCode attribute for the entity in the following entities: Invoice, InvoiceDetail, Opportunity, OpportunityProduct, Quote, QuoteDetail, SalesOrder and SalesOrderDetail.

Value | Label
0 | None
1 | Detail Error
2 | Missing Price Level
3 | Inactive Price Level
4 | Missing Quantity
5 | Missing Unit Price
6 | Missing Product
7 | Invalid Product
8 | Missing Pricing Code
9 | Invalid Pricing Code
10 | Missing UOM
11 | Product Not In Price Level
12 | Missing Price Level Amount
13 | Missing Price Level Percentage
14 | Missing Price
15 | Missing Current Cost
16 | Missing Standard Cost
17 | Invalid Price Level Amount
18 | Invalid Price Level Percentage
19 | Invalid Price
20 | Invalid Current Cost
21 | Invalid Standard Cost
22 | Invalid Rounding Policy
23 | Invalid Rounding Option
24 | Invalid Rounding Amount
25 | Price Calculation Error
26 | Invalid Discount Type
27 | Discount Type Invalid State
28 | Invalid Discount
29 | Invalid Quantity
30 | Invalid Pricing Precision
31 | Missing Product Default UOM
32 | Missing Product UOM Schedule
33 | Inactive Discount Type
34 | Invalid Price Level Currency
35 | Price Attribute Out Of Range
36 | Base Currency Attribute Overflow
37 | Base Currency Attribute Underflow

Product Type

Use these values to specify the type of product or bundle to be attached to an InvoiceDetail, OpportunityProduct, QuoteDetail, or SalesOrderDetail.

Value | Label
1 | Product
2 | Bundle
3 | Required Bundle Product
4 | Optional Bundle Product

Properties Configuration

Use these values to specify the status of the properties of the product or bundle attached to an InvoiceDetail, OpportunityProduct, QuoteDetail, or SalesOrderDetail.

Value | Label
0 | Edit
1 | Rectify
2 | NotConfigured

Purchase Process

Use these values to set or compare values for the Lead.PurchaseProcess and Opportunity.PurchaseProcess attributes.

Value | Label
0 | Individual
1 | Committee
2 | Unknown

Purchase Timeframe

Use these values to set or compare values for the Lead.PurchaseTimeframe and Opportunity.PurchaseTimeframe attributes.

Value | Label
0 | Immediate
1 | This Quarter
2 | Next Quarter
3 | This Year
4 | Unknown

Service Stage

Use these values to set or compare values for the Incident.ServiceStage attributes.

Value | Label
0 | Identify
1 | Research
2 | Resolve

Social Channel (socialprofile_community)

Use these values to set or compare values for the ActivityPointer.Community,SocialActivity.Community, and SocialProfile.Community attributes.

Sync Direction

Use these values to set the DefaultSyncDirection and SyncDirection attributes for the PrincipalSyncAttributeMap and SyncAttributeMapping entities.

Value | Label
0 | None
1 | ToExchange
2 | ToCRM
3 | Bidirectional

Stage Category (processstage_category)

Used to set the ProcessStage.StageCategory attribute.

Value | Label
0 | Qualify
1 | Develop
2 | Propose
3 | Close
4 | Identify
5 | Research
6 | Resolve

Validation Status (sharepoint_validationstatus)

Use these values to set or compare the SharepointSite.ValidationStatus attribute.

Value | Label
1 | Not Validated
2 | In Progress
3 | Invalid
4 | Valid
5 | Could not validate

Validation Status Reason (sharepoint_validationstatusreason)

Use these values to set or compare the SharepointSite.ValidationStatusErrorCode attribute.

Value | Label
1 | This record's URL has not been validated.
2 | This record's URL is valid.
3 | This record's URL is not valid.
4 | The URL schemes of Microsoft Dynamics CRM and SharePoint Server are different.
5 | The URL could not be accessed because of Internet Explorer security settings.
6 | Authentication failure.
7 | Invalid certificates.

Workflow Stage (workflow_stage)

Used to set the Worfklow.CreateStage, Workflow.DeleteStage, and Workflow.UpdateStage attributes.

Value | Label
20 | Pre-operation
40 | Post-operation

See Also

Concepts

Customize global option sets

Other Resources

Sample: Create a global option set
Sample: Work with global option sets
Sample: Dump global option set information to a file

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create a global option set
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\OptionSets\CreateOptionSet.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to how to create a global option set. It uses the CreateOptionSetRequest message.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{

    /// <summary>
    /// Demonstrates how to create an option set in CRM.
    /// </summary>
    public class CreateOptionSet
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        private const int _languageCode = 1033;

        private const String _optionSetName = "new_exampleoptionset";

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Shows how to create an Option Set.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Define the option set to create.
                    OptionSetMetadata setupOptionSetMetadata = new OptionSetMetadata()
                    {
                        // The name will be used to uniquely identify the option set.
                        // Normally you should generate this identifier using the publisher's
                        // prefix and double-check that the name is not in use.
                        Name = _optionSetName,
                        DisplayName = new Label("Example Option Set", _languageCode),
                        Description = new Label("An Example Option Set", _languageCode),
                        IsGlobal = true,
                        OptionSetType = OptionSetType.Picklist,

                        // Define the list of options that populate the option set
                        // The order here determines the order shown in the option set.
                        Options =
                    {
                        // Options accepts any number of OptionMetadata instances, which
                        // are simply pairs of Labels and integer values.
                        new OptionMetadata(new Label("Option 1", _languageCode), null ),
                        new OptionMetadata(new Label("Option 2", _languageCode), null )
                    }
                    };

                    // Wrap the OptionSetMetadata in the appropriate request.
                    CreateOptionSetRequest createOptionSetRequest = new CreateOptionSetRequest
                    {
                        OptionSet = setupOptionSetMetadata
                    };

                    // Pass the execute statement to the CRM service.
                    _serviceProxy.Execute(createOptionSetRequest);
                    Console.WriteLine("Option Set created");

                    DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {

                DeleteOptionSetRequest deleteRequest = new DeleteOptionSetRequest
                {
                    Name = _optionSetName
                };
                _serviceProxy.Execute(deleteRequest);

                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CreateOptionSet app = new CreateOptionSet();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize global option sets
Global option set messages

Other Resources

Extend the metadata model
Sample: Work with global option sets

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Work with global option sets
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\OptionSets\WorkWithOptionSets.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to perform the following actions with global option sets:

  • Create, retrieve, or update a global option set.
  • Create a PicklistAttributeMetadata attribute using a global option set.
  • Insert or update an option item.
  • Re-order option items.
  • Retrieve all global option sets.

Example

C# Copy Code
using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Discovery;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{

    /// <summary>
    /// Create a global option set.
    /// Set the options for that option set.
    /// Create a new reference to that option set on an entity.
    /// Update the option set's properties.
    /// Check the global option set for dependencies.
    /// Delete the option set.
    /// </summary>
    public class WorkwithGlobalOptionSets
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        private OrganizationServiceProxy _serviceProxy;

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        private const int _languageCode = 1033;

        // Specify the option set's schema name is used in many operations related to
        // global option sets.
        private const string _globalOptionSetName = "sample_exampleoptionset";

        // Define the IDs needed for this sample.
        private Guid _optionSetId;
        private int _insertedOptionValue;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// Create a global option set.
        /// Set the options for that option set.
        /// Create a new reference to that option set on an entity.
        /// Update the option set's properties.
        /// Check the global option set for dependencies.
        /// Delete the option set.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    #region How to create global option set
                    // Define the request object and pass to the service.
                    CreateOptionSetRequest createOptionSetRequest = new CreateOptionSetRequest
                    {
                        // Create a global option set (OptionSetMetadata).
                        OptionSet = new OptionSetMetadata
                        {
                            Name = _globalOptionSetName,
                            DisplayName = new Label("Example Option Set", _languageCode),
                            IsGlobal = true,
                            OptionSetType = OptionSetType.Picklist,
                            Options =
                        {
                            new OptionMetadata(new Label("Open", _languageCode), null),
                            new OptionMetadata(new Label("Suspended", _languageCode), null),
                            new OptionMetadata(new Label("Cancelled", _languageCode), null),
                            new OptionMetadata(new Label("Closed", _languageCode), null)
                        }
                        }
                    };

                    // Execute the request.
                    CreateOptionSetResponse optionsResp =
                        (CreateOptionSetResponse)_serviceProxy.Execute(createOptionSetRequest);

                    #endregion How to create global option set

                    // Store the option set's id as it will be needed to find all the
                    // dependent components.
                    _optionSetId = optionsResp.OptionSetId;
                    Console.WriteLine("The global option set has been created.");

                    #region How to create a picklist linked to the global option set
                    // Create a Picklist linked to the option set.
                    // Specify which entity will own the picklist, and create it.
                    CreateAttributeRequest createRequest = new CreateAttributeRequest
                    {
                        EntityName = Contact.EntityLogicalName,
                        Attribute = new PicklistAttributeMetadata
                        {
                            SchemaName = "sample_examplepicklist",
                            LogicalName = "sample_examplepicklist",
                            DisplayName = new Label("Example Picklist", _languageCode),
                            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),

                            // In order to relate the picklist to the global option set, be sure
                            // to specify the two attributes below appropriately.
                            // Failing to do so will lead to errors.
                            OptionSet = new OptionSetMetadata
                            {
                                IsGlobal = true,
                                Name = _globalOptionSetName
                            }
                        }
                    };

                    _serviceProxy.Execute(createRequest);
                    Console.WriteLine("Referring picklist attribute created.");
                    #endregion How to create a picklist linked to the global option set

                    #region How to update a global option set
                    // Use UpdateOptionSetRequest to update the basic information of an option
                    // set. Updating option set values requires different messages (see below).
                    UpdateOptionSetRequest updateOptionSetRequest = new UpdateOptionSetRequest
                    {
                        OptionSet = new OptionSetMetadata
                        {
                            DisplayName = new Label("Updated Option Set", _languageCode),
                            Name = _globalOptionSetName,
                            IsGlobal = true
                        }
                    };

                    _serviceProxy.Execute(updateOptionSetRequest);

                    //Publish the OptionSet
                    PublishXmlRequest pxReq1 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
                    _serviceProxy.Execute(pxReq1);
                    Console.WriteLine("Option Set display name changed.");
                    #endregion How to update a global option set properties

                    #region How to insert a new option item in a global option set
                    // Use InsertOptionValueRequest to insert a new option into a
                    // global option set.
                    InsertOptionValueRequest insertOptionValueRequest =
                        new InsertOptionValueRequest
                        {
                            OptionSetName = _globalOptionSetName,
                            Label = new Label("New Picklist Label", _languageCode)
                        };

                    // Execute the request and store the newly inserted option value
                    // for cleanup, used in the later part of this sample.
                    _insertedOptionValue = ((InsertOptionValueResponse)_serviceProxy.Execute(
                        insertOptionValueRequest)).NewOptionValue;

                    //Publish the OptionSet
                    PublishXmlRequest pxReq2 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
                    _serviceProxy.Execute(pxReq2);
                    Console.WriteLine("Created {0} with the value of {1}.",
                        insertOptionValueRequest.Label.LocalizedLabels[0].Label,
                        _insertedOptionValue);
                    #endregion How to insert a new option item in a global option set

                    #region How to retrieve a global option set by it's name
                    // Use the RetrieveOptionSetRequest message to retrieve
                    // a global option set by it's name.
                    RetrieveOptionSetRequest retrieveOptionSetRequest =
                        new RetrieveOptionSetRequest
                        {
                            Name = _globalOptionSetName
                        };

                    // Execute the request.
                    RetrieveOptionSetResponse retrieveOptionSetResponse =
                        (RetrieveOptionSetResponse)_serviceProxy.Execute(
                        retrieveOptionSetRequest);

                    Console.WriteLine("Retrieved {0}.",
                        retrieveOptionSetRequest.Name);

                    // Access the retrieved OptionSetMetadata.
                    OptionSetMetadata retrievedOptionSetMetadata =
                        (OptionSetMetadata)retrieveOptionSetResponse.OptionSetMetadata;

                    // Get the current options list for the retrieved attribute.
                    OptionMetadata[] optionList =
                        retrievedOptionSetMetadata.Options.ToArray();
                    #endregion How to retrieve a global option set by it's name

                    #region How to update an option item in a picklist
                    // In order to change labels on option set values (or delete) option set
                    // values, you must use UpdateOptionValueRequest
                    // (or DeleteOptionValueRequest).
                    UpdateOptionValueRequest updateOptionValueRequest =
                        new UpdateOptionValueRequest
                        {
                            OptionSetName = _globalOptionSetName,
                            // Update the second option value.
                            Value = optionList[1].Value.Value,
                            Label = new Label("Updated Option 1", _languageCode)
                        };

                    _serviceProxy.Execute(updateOptionValueRequest);

                    //Publish the OptionSet
                    PublishXmlRequest pxReq3 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
                    _serviceProxy.Execute(pxReq3);

                    Console.WriteLine("Option Set option label changed.");
                    #endregion How to update an option item in a picklist

                    #region How to change the order of options of a global option set
                    // Change the order of the original option's list.
                    // Use the OrderBy (OrderByDescending) linq function to sort options in
                    // ascending (descending) order according to label text.
                    // For ascending order use this:
                    var updateOptionList =
                        optionList.OrderBy(x => x.Label.LocalizedLabels[0].Label).ToList();

                    // For descending order use this:
                    // var updateOptionList =
                    //      optionList.OrderByDescending(
                    //      x => x.Label.LocalizedLabels[0].Label).ToList();

                    // Create the request.
                    OrderOptionRequest orderOptionRequest = new OrderOptionRequest
                    {
                        // Set the properties for the request.
                        OptionSetName = _globalOptionSetName,
                        // Set the changed order using Select linq function
                        // to get only values in an array from the changed option list.
                        Values = updateOptionList.Select(x => x.Value.Value).ToArray()
                    };

                    // Execute the request
                    _serviceProxy.Execute(orderOptionRequest);

                    //Publish the OptionSet
                    PublishXmlRequest pxReq4 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
                    _serviceProxy.Execute(pxReq4);
                    Console.WriteLine("Option Set option order changed");
                    #endregion How to change the order of options of a global option set

                    #region How to retrieve all global option sets
                    // Use RetrieveAllOptionSetsRequest to retrieve all global option sets.
                    // Create the request.
                    RetrieveAllOptionSetsRequest retrieveAllOptionSetsRequest =
                        new RetrieveAllOptionSetsRequest();

                    // Execute the request
                    RetrieveAllOptionSetsResponse retrieveAllOptionSetsResponse =
                        (RetrieveAllOptionSetsResponse)_serviceProxy.Execute(
                        retrieveAllOptionSetsRequest);

                    // Now you can use RetrieveAllOptionSetsResponse.OptionSetMetadata property to
                    // work with all retrieved option sets.
                    if (retrieveAllOptionSetsResponse.OptionSetMetadata.Count() > 0)
                    {
                        Console.WriteLine("All the global option sets retrieved as below:");
                        int count = 1;
                        foreach (OptionSetMetadataBase optionSetMetadata in
                            retrieveAllOptionSetsResponse.OptionSetMetadata)
                        {
                            Console.WriteLine("{0} {1}", count++,
                                (optionSetMetadata.DisplayName.LocalizedLabels.Count >0)? optionSetMetadata.DisplayName.LocalizedLabels[0].Label : String.Empty);
                        }
                    }
                    #endregion How to retrieve all global option sets

                    DeleteRequiredRecords(promptForDelete);
                }
            }
            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to
        /// delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {
                #region How to delete a option from a option set
                // Use the DeleteOptionValueRequest message
                // to remove the newly inserted label.
                DeleteOptionValueRequest deleteOptionValueRequest =
                    new DeleteOptionValueRequest
                {
                    OptionSetName = _globalOptionSetName,
                    Value = _insertedOptionValue
                };

                // Execute the request.
                _serviceProxy.Execute(deleteOptionValueRequest);

                Console.WriteLine("Option Set option removed.");
                #endregion How to delete a option from a option set

                #region How to delete attribute
                // Create the request to see which components have a dependency on the
                // global option set.
                RetrieveDependentComponentsRequest dependencyRequest =
                    new RetrieveDependentComponentsRequest
                    {
                        ObjectId = _optionSetId,
                        ComponentType = (int)componenttype.OptionSet
                    };

                RetrieveDependentComponentsResponse dependencyResponse =
                    (RetrieveDependentComponentsResponse)_serviceProxy.Execute(
                    dependencyRequest);

                // Here you would check the dependencyResponse.EntityCollection property
                // and act as appropriate. However, we know there is exactly one
                // dependency so this example deals with it directly and deletes
                // the previously created attribute.
                DeleteAttributeRequest deleteAttributeRequest =
                    new DeleteAttributeRequest
                {
                    EntityLogicalName = Contact.EntityLogicalName,
                    LogicalName = "sample_examplepicklist"
                };

                _serviceProxy.Execute(deleteAttributeRequest);

                Console.WriteLine("Referring attribute deleted.");
                #endregion How to delete attribute

                #region How to delete global option set

                // Finally, delete the global option set. Attempting this before deleting
                // the picklist above will result in an exception being thrown.
                DeleteOptionSetRequest deleteRequest = new DeleteOptionSetRequest
                {
                    Name = _globalOptionSetName
                };

                _serviceProxy.Execute(deleteRequest);
                Console.WriteLine("Global Option Set deleted");
                #endregion How to delete global option set
            }
        }

        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                WorkwithGlobalOptionSets app = new WorkwithGlobalOptionSets();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe =
                        ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize global option sets
Global option set messages

Other Resources

Extend the metadata model
Sample: Dump global option set information to a file

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Dump global option set information to a file
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Metadata\OptionSets\DumpOptionSetInfo.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write out all the global OptionSet metadata to an XML file. It uses the RetrieveAllOptionSetsRequest message.

The following sample creates a new file at \OptionSets\bin\Debug\AllOptionSetValues.xml. You can open this file in Microsoft Office Excel to see a tabular report. You may need this information to discover the entity type code for a custom entity for use in reports.

Example

C# Copy Code
using System;
using System.Linq;
using System.Xml.Linq;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Collections.Generic;
using System.Xml.Serialization;
using System.Xml;
using System.IO;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Metadata;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This sample shows how to retrieve and write out global option set values.
    /// </summary>
    public class DumpOptionSetInfo
    {
        #region Class Level Members

        /// <summary>
        /// Stores the organization service proxy.
        /// </summary>
        OrganizationServiceProxy _serviceProxy;

        // Create storage for new attributes being created
        public List<AttributeMetadata> addedAttributes;

        // Specify which language code to use in the sample. If you are using a language
        // other than US English, you will need to modify this value accordingly.
        // See http://msdn.microsoft.com/en-us/library/0h88fahh.aspx
        public const int _languageCode = 1033;

        // Define the IDs/variables needed for this sample.
        public int _insertedStatusValue;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptForDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptForDelete)
        {
            try
            {

                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    #region How to dump option set info

                    RetrieveAllOptionSetsRequest retrieveAllOptionSetsRequest =
                         new RetrieveAllOptionSetsRequest();

                    // Execute the request
                    RetrieveAllOptionSetsResponse retrieveAllOptionSetsResponse =
                        (RetrieveAllOptionSetsResponse)_serviceProxy.Execute(
                        retrieveAllOptionSetsRequest);

                    // Create an instance of StreamWriter to write text to a file.
                    // The using statement also closes the StreamWriter.
            // To view this file, right click the file and choose open with Excel.
            // Excel will figure out the schema and display the information in columns.

                    String filename = String.Concat("AllOptionSetValues.xml");
                    using (StreamWriter sw = new StreamWriter(filename))
                    {
                        // Create Xml Writer.
                        XmlTextWriter metadataWriter = new XmlTextWriter(sw);

                        // Start Xml File.
                        metadataWriter.WriteStartDocument();

                        // Metadata Xml Node.
                        metadataWriter.WriteStartElement("Metadata");

                        if (retrieveAllOptionSetsResponse.OptionSetMetadata.Count() > 0)
                        {

                            foreach (OptionSetMetadataBase optionSetMetadataBase in
                                retrieveAllOptionSetsResponse.OptionSetMetadata)
                            {
                                if (optionSetMetadataBase.OptionSetType != null)
                                {
                                    if ((OptionSetType)optionSetMetadataBase.OptionSetType == OptionSetType.Picklist)
                                    {
                                        OptionSetMetadata optionSetMetadata = (OptionSetMetadata)optionSetMetadataBase;
                                        // Start OptionSet Node
                                        metadataWriter.WriteStartElement("OptionSet");
                                        metadataWriter.WriteAttributeString("OptionSetType", OptionSetType.Picklist.ToString());
                                        metadataWriter.WriteElementString("OptionSetDisplayName",
                                            (optionSetMetadata.DisplayName.LocalizedLabels.Count > 0)? optionSetMetadata.DisplayName.LocalizedLabels[0].Label : String.Empty);

                                        // Writes the options
                                        metadataWriter.WriteStartElement("Options");

                                        foreach (OptionMetadata option in optionSetMetadata.Options)
                                        {
                                            metadataWriter.WriteStartElement("Option");
                                            metadataWriter.WriteElementString("OptionValue", option.Value.ToString());
                                            metadataWriter.WriteElementString("OptionDescription", option.Label.UserLocalizedLabel.Label.ToString());
                                            metadataWriter.WriteEndElement();
                                        }
                                        metadataWriter.WriteEndElement();

                                        // End OptionSet Node
                                        metadataWriter.WriteEndElement();
                                    }
                                    else if ((OptionSetType)optionSetMetadataBase.OptionSetType == OptionSetType.Boolean)
                                    {
                                        BooleanOptionSetMetadata optionSetMetadata = (BooleanOptionSetMetadata)optionSetMetadataBase;
                                        // Start OptionSet Node
                                        metadataWriter.WriteStartElement("OptionSet");
                                        metadataWriter.WriteAttributeString("OptionSetType", OptionSetType.Boolean.ToString());
                                        if (optionSetMetadata.DisplayName.LocalizedLabels.Count != 0)
                                            metadataWriter.WriteElementString("OptionSetDisplayName", optionSetMetadata.DisplayName.LocalizedLabels[0].Label);
                                        else
                                            metadataWriter.WriteElementString("OptionSetDisplayName", "UNDEFINED");

                                        // Writes the TrueOption
                                        metadataWriter.WriteStartElement("TrueOption");
                                        metadataWriter.WriteElementString("OptionValue", optionSetMetadata.TrueOption.Value.ToString());
                                        metadataWriter.WriteElementString("OptionDescription", optionSetMetadata.TrueOption.Label.UserLocalizedLabel.Label.ToString());
                                        metadataWriter.WriteEndElement();
                                        // Writes the FalseOption
                                        metadataWriter.WriteStartElement("FalseOption");
                                        metadataWriter.WriteElementString("OptionValue", optionSetMetadata.FalseOption.Value.ToString());
                                        metadataWriter.WriteElementString("OptionDescription", optionSetMetadata.FalseOption.Label.UserLocalizedLabel.Label.ToString());
                                        metadataWriter.WriteEndElement();

                                        // End OptionSet Node
                                        metadataWriter.WriteEndElement();
                                    }
                                }
                            }
                        }

                        // End Metadata Xml Node
                        metadataWriter.WriteEndElement();
                        metadataWriter.WriteEndDocument();

                        // Close xml writer.
                        metadataWriter.Close();
                    }

                    #endregion How to dump option set info

                    Console.WriteLine("Done.");

                    //DeleteRequiredRecords(promptForDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Deletes/Reverts the record that was created/changed for this sample.
        /// <param name="prompt">Indicates whether to prompt the user to delete
        /// the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine(
                    "\nDo you want these entity records to be deleted? (y/n)");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y"));
            }

            if (deleteRecords)
            {

            }
        }
        #endregion How To Sample Code

        #region Main
        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                DumpOptionSetInfo app = new DumpOptionSetInfo();
                app.Run(config, false);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe
                        = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {

                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }

        }
        #endregion Main

    }
}

See Also

Concepts

Customize global option sets
Global option set messages
Global option set metadata values

Other Resources

Extend the metadata model

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Change application navigation using the SiteMap

The SiteMap is a node in the customizations.xml file of an exported unmanaged solution. You can edit the navigation options available with Microsoft Dynamics CRM by using security role privileges and by editing the SiteMap. More information: Edit the site map

In this topic

Application navigation

Configuration options available by using the SiteMap

Application navigation

The SiteMap provides the structure for navigation in Microsoft Dynamics CRM. It is evaluated together with your security privileges to display navigation options in the application. If your security privileges do not provide read access to an entity specified in the SiteMap, that navigation option will not be displayed to you. The <Privilege> (SiteMap) element can also be used to specify privilege requirements to view a page that is not related to a specific entity.

To understand the data that defines the application navigation options, compare what you see in the application with the Default SiteMap XML or the customized sitemap element exported from your organization.

Web application navigation bar

The following image shows the web application navigation bar. The default areas shown are SFA (SALES), CS (SERVICE), MA (MARKETING), Settings (SETTINGS), and HLP (HELP).

SiteMap shows Areas in Dynamics CRM

Selectable areas appear at the bottom of the navigation bar. When an area is selected, the area displays as the selected area. The most recently used subarea for that area is automatically shown. When the selected area is clicked or tapped, the available groups and subareas are displayed as shown in the following image.

SiteMap shows groups and subareas in CRM

In this image the SFA area is selected and the groups MyWork (My Work), Customers (Customers), and SFA (Sales) are visible. To view the remaining groups and subareas people must scroll to the right.

Each group contains a number of subareas. When a subarea is selected, the content defined in the site map for that subarea is displayed below the navigation bar.

Microsoft Dynamics CRM for Outlook navigation

The following diagram shows the CRM for Outlook navigation. Microsoft Outlook presents each navigation area in alphabetical order in a tree view instead of using the order specified in the SiteMap. Each person can choose to position the reading pane at the bottom as shown or on the side. They can also choose not to show it. Each entity can be configured to determine whether it will display the reading pane. More information: Editable Entity Properties

SiteMap in Outlook

Configuration options available by using the SiteMap

The following sections describe common tasks that can be performed by using the SiteMap.

Edit labels

All of the text displayed in the default SiteMap uses a ResourceId attribute to specify the text. You should not change or remove the ResourceId attribute values. If you want to change the label displayed in an element, use the <Titles> (SiteMap) and <Title> (SiteMap) elements to specify the text you want to use for your organization or solution. Any title elements will override the ResourceId attribute values.

Add or change icons

Both <Area> (SiteMap) and <SubArea> (SiteMap) elements have an Icon attribute that you can use to specify a 16x16 pixel image to display as the icon.

You should use a GIF, PNG, or JPG image web resource as the source of your icon. When you reference the web resource, make sure that you use the web resource directive ($webresource:). For example, use Icon="$webresource:sample_/icons/MyIcon16.png" when the name of the web resource is “sample_/icons/MyIcon16.png”. Using this directive will create a dependency so that the web resource can’t be deleted as long as your SiteMap element requires it.

Add or remove elements

To add elements

When editing XML elements in the SiteMap, you can to copy and paste existing XML elements to provide an advanced starting point.

Important
If you create a new element it must have a unique Id attribute value or importing your solution will fail. You should prepend an appropriate solution publisher customization prefix to the Id value of any new elements that you add.

More information: Add new pages to an Area

To remove elements

Before you remove elements in the SiteMap, consider whether editing the security role privileges for users will achieve your goal. Each <SubArea> (SiteMap) element that is associated with an entity page is evaluated with the user’s privileges and only shown if a user is allowed to view records for that entity.

If the subarea displays a page, such as a web resource that is not associated with a specific entity, you can add <Privilege> (SiteMap) elements to the subarea to associate that page with privileges for a specific action or access to an entity.

If none of the subarea elements in a <Group> (SiteMap) or <Area> (SiteMap) can be viewed by a user because of their security privileges, that element will not be displayed.

If you use the <SubArea> (SiteMap) AvailableOffine attribute to prevent a subarea from being displayed while the CRM for Outlook user is working offline, users can still navigate to the subarea but they’ll see a message indicating that the page to display isn’t available offline.

Note
We recommend that you use security role privileges to control access to areas of the application.

If you do not want to edit security roles, you can comment out the node in the SiteMap XML. Commenting out a node is better than deleting it because you can always uncomment the node if you want to restore it in the future.

Group links within areas

The Workplace and the Settings areas include multiple groups of links. You can use the <Group> (SiteMap) element in a similar manner to create groups in the other areas. A group element is required, but you must include the <Title> (SiteMap) and <Description> (SiteMap) elements for it to be displayed as a group. Finally, you must edit the <Area> (SiteMap) element to add the ShowGroups attribute and set it to true.

Add new pages to an area

Use <SubArea> (SiteMap) elements to add new pages to an area. If you want to include a grid for an entity, you include a unique ID, specify the entity by using the Entity attribute, and then provide a title and description by using the <Title> (SiteMap) and <Description> (SiteMap) elements.

To display a custom page in the application, you must set the Url attribute instead of the Entity attribute. The Url attribute can reference a page on an external website or an HTML web resource.

When referencing the HTML web resource, make sure that you use the web resource directive ($webresource:). For example, use Icon="$webresource:sample_/Pages/MyCustomPage.htm" when the name of the HTML web resource is “sample_/Pages/MyCustomPage.htm”. Using this directive will create a dependency so that the HTML web resource can’t be deleted as long as your SiteMap element requires it.

Note
To display a Silverlight web resource outside an entity form or chart, create an HTML web resource to be the host page for the Silverlight web resource. Then use the $webresource: directive to open the HTML web resource.

When adding an external page from the SiteMap, it’s a common requirement to pass data in the form of a query string to the page. To pass information about your organization name and the language for the user and organization, use the PassParams attribute. More information: Pass parameters to a URL using the SiteMap

See Also

Reference

When to edit the customizations file

Concepts

Edit the site map
Pass parameters to a URL using the SiteMap
Control access to the Customer Center
Customize entity forms
Customize entity views
Customize global option sets
Service calendar appearance configuration
Publish customizations

Other Resources

Developers guide to customization for Microsoft Dynamics CRM
Extend the metadata model
Customize visualizations and dashboards
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Edit the site map

Before you can edit the site map, you must export an unmanaged solution that contains the site map. The solution can be the default solution, or, to reduce the amount of data exported, you can add the site map to a new solution.

In This Topic

Site map editors

Editing the site map manually

Editing with schema validation

Encode the ampersand character

Recovering from errors

Site map editors

Using a sitemap editor can facilitate editing the sitemap.

A popular one is included in the Toolbox for Dynamics CRM 2011/2013 released by Microsoft CRM MVP Tanguy Touzard.

While these applications streamline the process to edit the site map, they still require that you have some understanding of the site map XML schema. For more information, see SiteMap XML reference.

Note
Microsoft Dynamics CRM technical support doesn’t provide support for these applications. If you have questions about these applications, contact the application publisher.

Editing the site map manually

If you don’t use one of the site map editor applications, you can edit the site map manually using the following steps.

To edit the site map

  1. In the Navigation Pane, click Settings, click Customizations, and then click Solutions.

  2. Add the Site Map to a new or existing unmanaged solution. In the solution, select Client Extensions from the list of Components. Select Add Existing, and then select Site Map. Then click Export Solution.

  3. Extract the files from the compressed .zip file.

    Tip
    Keep the compressed .zip file as your backup.

  4. In the customizations.xml file, locate the SiteMap node at ImportExportXml/SiteMap/SiteMap.

  5. Edit the SiteMap node.

    Note
    Editing XML is much easier if you use an editor that provides schema validation. For more information, see Editing with Schema Validation.

  6. Create a new compressed .zip file, including the extracted solution files and your edited customizations.xml.

    Tip
    In Windows Explorer, select all the files. Then right-click and select Send To and Compressed (zipped) folder.

  7. Import the new solutions file.

    1. In Microsoft Dynamics CRM, click Settings, click Customization, and then click Solutions.
    2. Click Import.
    3. Click Browse, locate your modified solutions .zip file, click Next, and then click Import.
    4. When the import is finished, click Close.

  8. Publish the customizations.

    Tip
    If you don’t see the changes right away, in Internet Explorer press F5 to reload the page.

Editing with schema validation

For a better experience, edit the customizations.xml file with an application that can use schema validation to provide IntelliSense support. For more information, see Edit the customizations XML file with schema validation.

Encode the ampersand character

When you add a URL to the site map that includes the ampersand character (&), you must encode it by replacing it with “&amp;”. XML validation fails if you don’t encode this character and you won’t be able to import the solution. For example:

Correct:

<SubArea Id="new_customSubArea" Url="http://mysite/mypage.aspx?parameter1=value&amp;parameter2=value ">

Incorrect:

<SubArea Id="new_customSubArea" Url="http://mysite/mypage.aspx?parameter1=value&parameter2=value">

Recovering from errors

The solution import tool performs validations on the site map. If errors occur, the default site map is applied and an error message is displayed. You must fix the errors in the site map and import it again. However, it’s still possible that some errors might occur.

See Also

Reference

SiteMap schema

Concepts

Change application navigation using the SiteMap
Pass parameters to a URL using the SiteMap
Control access to the Customer Center

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Pass parameters to a URL using the SiteMap

To give the target application information about the organization and the language context of the user and organization, pass parameters to the target URL for a <SubArea> (SiteMap) element in the site map. All the parameters are passed if the <SubArea> (SiteMap) element is configured by setting the PassParams attribute to true.

The following table shows the parameters that are passed.

Parameter | Name | Description
orgname | Organization Name | Unique name of the organization.
userlcid | User Language Code | Language code ID that is used by the current user.
orglcid | Organization Language Code | Language code identifier that represents the base language for the organization.

Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart).

Example

The following sample shows the URL without parameters.

Copy Code
http://myserver/mypage.aspx

The following sample shows the URL with parameters.

Copy Code
http://myserver/mypage.aspx?orgname=AdventureWorksCycle&userlcid=1033&orglcid=1033

Reading passed parameters

Webpage (HTML) web resources will accept these parameters. More information: Passing parameters to HTML web resources

See Also

Concepts

Change application navigation using the SiteMap
Edit the site map

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Control access to the Customer Center

The Customer Center contains information that is designed to help you get the most from your implementation of Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. However, you may want to control access to the Customer Center for some users.

This topic describes how you can control access to all or part of the Customer Center by using the same methods that can be used to customize the Navigation Bar areas of Microsoft Dynamics CRM.

Use the Privilege element to control access to Navigation Bar areas

Each area in the Navigation Bar is defined by an <Area> (SiteMap) element that contains a number of <SubArea> (SiteMap) elements. The following XML represents a simplified example:

Xml Copy Code
<SiteMap>
 <Area Id="MA"> <!-- Marketing Area -->
  <Group Id="MA">
   <SubArea Id="nav_leads"
            Entity="lead"/> <!-- Displays Leads Grid -->
   <SubArea Id="nav_accts"
            Entity="account"/> <!-- Displays Accounts Grid -->
   <SubArea Id="nav_conts"
            Entity="contact"/> <!-- Displays Contacts Grid -->
   <SubArea Id="nav_lists"
            Entity="list"/> <!-- Displays Marketing Lists Grid -->
  </Group>
 </Area>
 <Area Id="CS"> <!-- Service Area -->
  <Group Id="CS">
   <SubArea Id="nav_cases"
            Entity="incident"/> <!-- Displays Cases Grid -->
   <SubArea Id="nav_accts"
            Entity="account" /> <!-- Displays Accounts Grid -->
   <SubArea Id="nav_contacts"
            Entity="contact"/> <!-- Displays Contacts Grid -->
   <SubArea Id="nav_managekb"
            Url="/_root/homepage.aspx?etc=127"> <!-- Displays Manage KB page -->
    <Privilege Entity="kbarticle"
               Privilege="Read,Write,Create"/>
   </SubArea>
  </Group>
 </Area>
</SiteMap>

Each <SubArea> (SiteMap) element provides navigation to a grid view for a particular entity or a specific page defined by a URL.

For those <SubArea> (SiteMap) elements that define an entity grid view, the entity grid will only be displayed when the security role for a user includes the read privilege for that entity

However, notice that one of these <SubArea> (SiteMap) elements has a URL defined rather than the name of a specific entity. The following XML shows that access to the /_root/homepage.aspx?etc=127 page is controlled using the <Privilege> (SiteMap) element.

Xml Copy Code
   <SubArea Id="nav_managekb"
            Url="/_root/homepage.aspx?etc=127"> <!-- Displays Manage KB page -->
    <Privilege Entity="kbarticle"
               Privilege="Read,Write,Create"/>
   </SubArea>

In this case, the optional <Privilege> (SiteMap) element defines that only users with Read, Write, and Create privileges for the kbarticle entity will be able to view the Manage KB articles page located at /_root/homepage.aspx?etc=127. If this <SubArea> (SiteMap) element were included without the <Privilege> (SiteMap) element, all users would be able to access the page.

Note
If a user is not allowed to view any of the subareas within an area, that area will not appear in the Navigation Bar for that user.

Available options

The most obvious way to remove a <SubArea> (SiteMap) from the navigation is to delete it. However, we recommend that you comment out any SubAreas that you do not want to display rather than delete the element. This makes it easier to recover in the future.

For more precise control over access to a SubArea, use privileges. For more information, see Privileges by entity. In most cases, associating access to a privilege associated with an entity is sufficient. See Privileges not associated with an entity for additional privileges you can use. In this case, you should remove the “prv” prefix to the privilege name when you use it.

Example: Show the Customer Center to administrators only

You can modify the default definition of the Customer Center in the Site Map to limit access to only those users who have specific privileges. The following XML shows the default definition for the Customer Center <Area> (SiteMap).

Xml Copy Code
   <Area Id="HLP"
         ResourceId="Area_Help"
         ShowGroups="true"
         Icon="/_imgs/settings_24x24.gif"
         DescriptionResourceId="Help_Area_Description">
    <Group Id="HLP_GRP"
           ResourceId="Group_Help"
           DescriptionResourceId="Help_Description">
     <SubArea Id="Help_Resource_Center"
              Url="http://go.microsoft.com/fwlink/?LinkId=296269"
              ResourceId="Area_CustomerCenter"
              DescriptionResourceId="ResourceCenter_Area_Description"
              AvailableOffline="false">
      <Privilege Privilege="CreateEntity" />
      <Privilege Entity="solution" Privilege="Create" />
      <Privilege Privilege="ImportCustomization" />
     </SubArea>
    </Group>
   </Area>

See Also

Reference

SiteMap schema

Concepts

Change application navigation using the SiteMap
Edit the site map
Pass parameters to a URL using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SiteMap XML reference

Use SiteMap XML to edit the application navigation options available to people using Microsoft Dynamics CRM.

In This Section

Default SiteMap XML

This topic describes the structure of the default SiteMap and includes the XML for the default SiteMap.

<Area> (SiteMap)

Specifies an area that appears in the navigation pane.

<Description> (SiteMap)

Provides a description in a specific language for the parent of the Descriptions element.

<Descriptions> (SiteMap)

Contains a set of localizable Descriptions for the parent element.

<Group> (SiteMap)

Specifies a group of subareas.

<Privilege> (SiteMap)

Controls whether a subarea is displayed based on privileges available in any security roles assigned to the user.

<SiteMap> (SiteMap)

Specifies the root node for the site map.

<SubArea> (SiteMap)

Specifies a navigation option within an Area. Defines what will be displayed in the main pane of the application when selected.

<Title> (SiteMap)

Provides a title in a specific language for the parent of the Titles element.

<Titles> (SiteMap)

Specifies a set of localizable Titles for the parent element.

Related Sections

Change application navigation using the SiteMap

Edit the site map

Pass parameters to a URL using the SiteMap

SiteMap schema

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Default SiteMap XML

This topic describes the data in an unmodified SiteMap. This topic includes:

SiteMap Structure

This section describes how the elements in the SiteMap are organized by displaying selected data.

Default SiteMap XML

This section provides the XML for the full definition of the SiteMap.

SiteMap Structure

The following table describes the structure of the SiteMap by displaying element id values. The <SubArea> (SiteMap) element Url and Entity attributes are included as well as any <Privilege> (SiteMap) element values.

Area Id | Group Id | SubArea Id | Url/Entity | Privileges
SFA | MyWork | nav_dashboards | /workplace/home_dashboards.aspx |
 |  | nav_personalwal | $webresource:msdyn_/PersonalWall.htm?data=HideUserProfile%3D0 | Read: post
 |  | nav_activities | activitypointer |
 | Customers | nav_accts | account |
 |  | nav_conts | contact |
 | SFA | nav_leads | lead |
 |  | nav_oppts | opportunity |
 |  | nav_comps | competitor |
 | Collateral | nav_quotes | quote |
 |  | nav_orders | salesorder |
 |  | nav_invoices | invoice |
 |  | nav_products | product |
 |  | nav_saleslit | salesliterature |
 | MA | nav_lists | list |
 |  | nav_minicamps | bulkoperation |
 | Goals | nav_goals | goal |
 |  | nav_metric | metric |
 |  | nav_goalrollupqueries | goalrollupquery |
 | Tools | nav_reports | report | Read: report
 |  | nav_traces | /_root/tracewall.aspx | Read: tracelog
 |  | nav_calendar | /workplace/home_calendar.aspx | Read: activitypointer
CS | MyWork | nav_dashboards | /workplace/home_dashboards.aspx |
 |  | nav_activities | activitypointer |
 | Customers | nav_accts | account |
 |  | nav_contacts | contact |
 |  | nav_socialprofiles | socialprofile |
 | CS | nav_cases | incident |
 |  | nav_apptbook | /sm/home_apptbook.aspx |
 |  | nav_queues | /_root/homepage.aspx?etc=2029 | Read: queue
 | Collateral | nav_answers | kbarticle | Create,Read,Write:kbarticle
 |  | nav_contracts | contract |
 |  | nav_products | product |
 |  | nav_services | service |
 | Goals | nav_goals | goal |
 |  | nav_metric | metric |
 |  | nav_goalrollupqueries | goalrollupquery |
 | Tools | nav_reports | report | Read: report
 |  | nav_traces | /_root/tracewall.aspx | Read: tracelog
 |  | nav_calendar | /workplace/home_calendar.aspx | Read: activitypointer
MA | MyWork | nav_dashboards | /workplace/home_dashboards.aspx |
 |  | nav_activities | activitypointer |
 | Customers | nav_accts | account |
 |  | nav_conts | contact |
 | MA | nav_leads | lead |
 |  | nav_lists | list |
 |  | nav_campaigns | campaign |
 |  | nav_minicamps | bulkoperation |
 | Collateral | nav_products | product |
 |  | nav_saleslit | salesliteratur |
 | Tools | nav_reports | report | Read: report
 |  | nav_traces | /_root/tracewall.aspx | Read: tracelog
 |  | nav_calendar | /workplace/home_calendar.aspx | Read: activitypointer
Settings | Business_Setting | nav_businessmanagement | /tools/business/business.aspx |
 |  | nav_template | /tools/templates/templates.aspx |
 |  | nav_productcata | /tools/productcatalog/productcatalog.aspx | Read: product
 |  | nav_servicemanagement | /tools/servicemanagement/servicemanagement.aspx |
 | Customizations | nav_syscust | /tools/systemcustomization/systemcustomization.aspx |
 |  | nav_solution | solution | Read: solution
 |  | nav_marketplace | /tools/SystemCustomization/SolutionsMarketplace/SolutionsMarketplace.aspx |
 | System_Setting | nav_administrat | /tools/Admin/admin.aspx |
 |  | nav_security | /tools/AdminSecurity/adminsecurity_area.aspx |
 |  | nav_datamanagem | /tools/DataManagement/datamanagement.aspx |
 |  | nav_systemjobs | /tools/business/home_asyncoperation.aspx |
 |  | nav_documentman | /tools/documentmanagement/documentmanagement.aspx | Read: sharepointsite Read: sharepointdocumentlocation
 |  | nav_audit | /tools/audit/audit_area.aspx |
 |  | nav_social | /tools/social/social_area.aspx |
 |  | msdyn_postconfi | msdyn_postconfig |
 |  | msdyn_postrulec | msdyn_postruleconfig |
 | ProcessCenter | nav_workflow | workflow |
HLP | HLP_GRP | Help_Resource_C | http://go.microsoft.com/fwlink/?LinkId=296269 |

Default SiteMap XML

The following XML is the default SiteMap.

Xml Copy Code
<SiteMap IntroducedVersion="7.0.0.0">
 <Area Id="SFA"
       ResourceId="Area_Sales"
       DescriptionResourceId="Sales_Description"
       Icon="/_imgs/sales_24x24.gif"
       ShowGroups="true"
       IntroducedVersion="7.0.0.0">
  <Group Id="MyWork"
         ResourceId="Group_MyWork"
         DescriptionResourceId="My_Work_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_dashboards"
            ResourceId="Homepage_Dashboards"
            DescriptionResourceId="Dashboards_Description"
            Icon="/_imgs/area/18_home.gif"
            Url="/workplace/home_dashboards.aspx"
            GetStartedPanePath="Dashboards_Web_User_Visor.html"
            GetStartedPanePathAdmin="Dashboards_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Dashboards_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Dashboards_Outlook_Admin_Visor.html"
            DefaultDashboard="2701de60-8f2a-48a4-8262-4a35ca7441fa"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_personalwall"
            ResourceId="Whats_New_Label"
            DescriptionResourceId="Whats_New_Description"
            Icon="$webresource:msdyn_/Images/Wall_16.png"
            OutlookShortcutIcon="$webresource:msdyn_/Images/Wall_16.png"
            AvailableOffline="false"
            Url="$webresource:msdyn_/PersonalWall.htm?data=HideUserProfile%3D0"
            GetStartedPanePath="Dashboards_Web_User_Visor.html"
            GetStartedPanePathAdmin="Dashboards_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Dashboards_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Dashboards_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="post"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_activities"
            DescriptionResourceId="Activities_SubArea_Description"
            Url="/_root/homepage.aspx?etc=4200"
            Entity="activitypointer"
            GetStartedPanePath="Activities_Web_User_Visor.html"
            GetStartedPanePathAdmin="Activities_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Activities_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Activities_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Customers"
         ResourceId="Group_Customers"
         DescriptionResourceId="Customers_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_accts"
            DescriptionResourceId="Account_SubArea_Description"
            Entity="account"
            GetStartedPanePath="Accounts_Web_User_Visor.html"
            GetStartedPanePathAdmin="Accounts_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Accounts_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Accounts_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_conts"
            DescriptionResourceId="Contact_SubArea_Description"
            Entity="contact"
            GetStartedPanePath="Contacts_Web_User_Visor.html"
            GetStartedPanePathAdmin="Contacts_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Contacts_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Contacts_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="SFA"
         ResourceId="Area_Sales"
         DescriptionResourceId="Sales_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_leads"
            DescriptionResourceId="Lead_SubArea_Description"
            Entity="lead"
            GetStartedPanePath="Leads_Web_User_Visor.html"
            GetStartedPanePathAdmin="Leads_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Leads_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Leads_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_oppts"
            DescriptionResourceId="Opportunity_SubArea_Description"
            Entity="opportunity"
            GetStartedPanePath="Opportunities_Web_User_Visor.html"
            GetStartedPanePathAdmin="Opportunities_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Opportunities_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Opportunities_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_comps"
            DescriptionResourceId="Competitor_SubArea_Description"
            Entity="competitor"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Collateral"
         ResourceId="Area_Collateral"
         DescriptionResourceId="Area_Collateral_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_quotes"
            DescriptionResourceId="Quote_SubArea_Description"
            Entity="quote"
            GetStartedPanePath="Quotes_Web_User_Visor.html"
            GetStartedPanePathAdmin="Quotes_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Quotes_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Quotes_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_orders"
            DescriptionResourceId="Orders_SubArea_Description"
            Entity="salesorder"
            GetStartedPanePath="Orders_Web_User_Visor.html"
            GetStartedPanePathAdmin="Orders_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Orders_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Orders_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_invoices"
            DescriptionResourceId="Invoice_SubArea_Description"
            Entity="invoice"
            GetStartedPanePath="Invoices_Web_User_Visor.html"
            GetStartedPanePathAdmin="Invoices_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Invoices_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Invoices_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_products"
            DescriptionResourceId="Product_SubArea_Description"
            Entity="product"
            GetStartedPanePath="Products_Web_User_Visor.html"
            GetStartedPanePathAdmin="Products_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Products_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Products_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_saleslit"
            DescriptionResourceId="SalesLit_SubArea_Description"
            Entity="salesliterature"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="MA"
         ResourceId="Area_Marketing"
         DescriptionResourceId="Marketing_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_lists"
            DescriptionResourceId="MarketingList_SubArea_Description"
            Entity="list"
            GetStartedPanePath="Marketing-Lists_Web_User_Visor.html"
            GetStartedPanePathAdmin="Marketing-Lists_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Marketing-Lists_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Marketing-Lists_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_minicamps"
            DescriptionResourceId="Quick_Campaign_Description"
            Icon="/_imgs/ico_18_minicamps.gif"
            Entity="bulkoperation"
            GetStartedPanePath="Quick-Campaigns_Web_User_Visor.html"
            GetStartedPanePathAdmin="Quick-Campaigns_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Quick-Campaigns_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Quick-Campaigns_Outlook_Admin_Visor.html"
            OutlookShortcutIcon="/_imgs/olk_4400.ico"
            IntroducedVersion="7.0.0.0">
    <Privilege Privilege="AllowQuickCampaign" />
   </SubArea>
  </Group>
  <Group Id="Goals"
         ResourceId="Area_Goals"
         DescriptionResourceId="Area_Goals_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_goals"
            DescriptionResourceId="Goals_SubArea_Description"
            Icon="/_imgs/ico_18_9600.png"
            Entity="goal"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_metric"
            DescriptionResourceId="Metrics_SubArea_Description"
            Entity="metric"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_goalrollupqueries"
            DescriptionResourceId="GoalQueries_SubArea_Description"
            Icon="/_imgs/ico_18_9602.png"
            Entity="goalrollupquery"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Tools"
         ResourceId="Area_Tools"
         IsProfile="true"
         DescriptionResourceId="Area_Tools_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_reports"
            Entity="report"
            DescriptionResourceId="Reports_Description"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="report"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_traces"
            Icon="/_imgs/area/18_alerts.png"
            Url="/_root/tracewall.aspx"
            ResourceId="Homepage_Alerts"
            AvailableOffline="false"
            DescriptionResourceId="Alerts_SubArea_Description"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="tracelog"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_calendar"
            ResourceId="Homepage_Calendar"
            Icon="/_imgs/area/18_calendar.gif"
            Url="/workplace/home_calendar.aspx"
            Client="Web"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="activitypointer"
               Privilege="Read" />
   </SubArea>
  </Group>
 </Area>
 <Area Id="CS"
       ResourceId="Area_Service"
       DescriptionResourceId="Customer_Service_Description"
       Icon="/_imgs/services_24x24.gif"
       ShowGroups="true"
       IntroducedVersion="7.0.0.0">
  <Group Id="MyWork"
         ResourceId="Group_MyWork"
         DescriptionResourceId="My_Work_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_dashboards"
            ResourceId="Homepage_Dashboards"
            DescriptionResourceId="Dashboards_Description"
            Icon="/_imgs/area/18_home.gif"
            Url="/workplace/home_dashboards.aspx"
            GetStartedPanePath="Dashboards_Web_User_Visor.html"
            GetStartedPanePathAdmin="Dashboards_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Dashboards_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Dashboards_Outlook_Admin_Visor.html"
            DefaultDashboard="063e7659-05d9-4030-960d-10fe269a5a8b"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_activities"
            DescriptionResourceId="Activities_SubArea_Description"
            Url="/_root/homepage.aspx?etc=4200"
            Entity="activitypointer"
            GetStartedPanePath="Activities_Web_User_Visor.html"
            GetStartedPanePathAdmin="Activities_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Activities_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Activities_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Customers"
         ResourceId="Group_Customers"
         DescriptionResourceId="Customers_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_accts"
            DescriptionResourceId="Account_SubArea_Description"
            Entity="account"
            GetStartedPanePath="Accounts_Web_User_Visor.html"
            GetStartedPanePathAdmin="Accounts_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Accounts_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Accounts_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_contacts"
            DescriptionResourceId="Contact_SubArea_Description"
            Entity="contact"
            GetStartedPanePath="Contacts_Web_User_Visor.html"
            GetStartedPanePathAdmin="Contacts_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Contacts_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Contacts_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_socialprofiles"
            DescriptionResourceId="SocialProfile_SubArea_Description"
            Entity="socialprofile"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="CS"
         ResourceId="Area_Service"
         DescriptionResourceId="Customer_Service_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_cases"
            DescriptionResourceId="Cases_SubArea_Description"
            Entity="incident"
            GetStartedPanePath="Cases_Web_User_Visor.html"
            GetStartedPanePathAdmin="Cases_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Cases_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Cases_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_apptbook"
            ResourceId="Homepage_AppointmentBook"
            DescriptionResourceId="AppointmentBook_SubArea_Description"
            Icon="/_imgs/ico_18_servicecal.gif"
            Url="/sm/home_apptbook.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_queues"
            ResourceId="Homepage_Queues"
            Entity="queueitem"
            DescriptionResourceId="Queues_SubArea_Description"
            Icon="/_imgs/ico_18_2020.gif"
            Url="/_root/homepage.aspx?etc=2029"
            GetStartedPanePath="Queues_Web_User_Visor.html"
            GetStartedPanePathAdmin="Queues_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Queues_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Queues_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="queue"
               Privilege="Read" />
   </SubArea>
  </Group>
  <Group Id="Collateral"
         ResourceId="Area_Collateral"
         DescriptionResourceId="Area_Collateral_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_answers"
            DescriptionResourceId="Article_SubArea_Description"
            Entity="kbarticle"
            GetStartedPanePath="KB_Web_User_Visor.html"
            GetStartedPanePathAdmin="KB_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="KB_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="KB_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="kbarticle"
               Privilege="Create,Read,Write" />
   </SubArea>
   <SubArea Id="nav_contracts"
            DescriptionResourceId="Contract_SubArea_Description"
            Entity="contract"
            GetStartedPanePath="Contracts_Web_User_Visor.html"
            GetStartedPanePathAdmin="Contracts_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Contracts_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Contracts_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_products"
            DescriptionResourceId="Product_SubArea_Description"
            Entity="product"
            GetStartedPanePath="Products_Web_User_Visor.html"
            GetStartedPanePathAdmin="Products_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Products_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Products_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_services"
            DescriptionResourceId="Service_SubArea_Description"
            Entity="service"
            GetStartedPanePath="Services_Web_User_Visor.html"
            GetStartedPanePathAdmin="Services_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Services_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Services_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Goals"
         ResourceId="Area_Goals"
         DescriptionResourceId="Area_Goals_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_goals"
            DescriptionResourceId="Goals_SubArea_Description"
            Icon="/_imgs/ico_18_9600.png"
            Entity="goal"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_metric"
            DescriptionResourceId="Metrics_SubArea_Description"
            Entity="metric"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_goalrollupqueries"
            DescriptionResourceId="GoalQueries_SubArea_Description"
            Icon="/_imgs/ico_18_9602.png"
            Entity="goalrollupquery"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Tools"
         ResourceId="Area_Tools"
         IsProfile="true"
         DescriptionResourceId="Area_Tools_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_reports"
            Entity="report"
            DescriptionResourceId="Reports_Description"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="report"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_traces"
            Icon="/_imgs/area/18_alerts.png"
            Url="/_root/tracewall.aspx"
            ResourceId="Homepage_Alerts"
            AvailableOffline="false"
            DescriptionResourceId="Alerts_SubArea_Description"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="tracelog"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_calendar"
            ResourceId="Homepage_Calendar"
            Icon="/_imgs/area/18_calendar.gif"
            Url="/workplace/home_calendar.aspx"
            Client="Web"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="activitypointer"
               Privilege="Read" />
   </SubArea>
  </Group>
 </Area>
 <Area Id="MA"
       ResourceId="Area_Marketing"
       DescriptionResourceId="Marketing_Description"
       Icon="/_imgs/marketing_24x24.gif"
       ShowGroups="true"
       IntroducedVersion="7.0.0.0">
  <Group Id="MyWork"
         ResourceId="Group_MyWork"
         DescriptionResourceId="My_Work_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_dashboards"
            ResourceId="Homepage_Dashboards"
            DescriptionResourceId="Dashboards_Description"
            Icon="/_imgs/area/18_home.gif"
            Url="/workplace/home_dashboards.aspx"
            GetStartedPanePath="Dashboards_Web_User_Visor.html"
            GetStartedPanePathAdmin="Dashboards_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Dashboards_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Dashboards_Outlook_Admin_Visor.html"
            DefaultDashboard="B46AEB74-BF0C-44FB-8158-9575588D1B57"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_activities"
            DescriptionResourceId="Activities_SubArea_Description"
            Url="/_root/homepage.aspx?etc=4200"
            Entity="activitypointer"
            GetStartedPanePath="Activities_Web_User_Visor.html"
            GetStartedPanePathAdmin="Activities_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Activities_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Activities_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Customers"
         ResourceId="Group_Customers"
         DescriptionResourceId="Customers_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_accts"
            DescriptionResourceId="Account_SubArea_Description"
            Entity="account"
            GetStartedPanePath="Accounts_Web_User_Visor.html"
            GetStartedPanePathAdmin="Accounts_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Accounts_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Accounts_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_conts"
            DescriptionResourceId="Contact_SubArea_Description"
            Entity="contact"
            GetStartedPanePath="Contacts_Web_User_Visor.html"
            GetStartedPanePathAdmin="Contacts_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Contacts_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Contacts_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="MA"
         ResourceId="Area_Marketing"
         DescriptionResourceId="Marketing_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_leads"
            Entity="lead"
            DescriptionResourceId="Lead_SubArea_Description"
            GetStartedPanePath="Leads_Web_User_Visor.html"
            GetStartedPanePathAdmin="Leads_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Leads_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Leads_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_lists"
            DescriptionResourceId="MarketingList_SubArea_Description"
            Entity="list"
            GetStartedPanePath="Marketing-Lists_Web_User_Visor.html"
            GetStartedPanePathAdmin="Marketing-Lists_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Marketing-Lists_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Marketing-Lists_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_campaigns"
            DescriptionResourceId="Campaign_SubArea_Description"
            Entity="campaign"
            GetStartedPanePath="Campaigns_Web_User_Visor.html"
            GetStartedPanePathAdmin="Campaigns_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Campaigns_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Campaigns_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_minicamps"
            DescriptionResourceId="Quick_Campaign_Description"
            Icon="/_imgs/ico_18_minicamps.gif"
            Entity="bulkoperation"
            GetStartedPanePath="Quick-Campaigns_Web_User_Visor.html"
            GetStartedPanePathAdmin="Quick-Campaigns_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Quick-Campaigns_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Quick-Campaigns_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Collateral"
         ResourceId="Area_Collateral"
         DescriptionResourceId="Area_Collateral_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_products"
            DescriptionResourceId="Product_SubArea_Description"
            Entity="product"
            GetStartedPanePath="Products_Web_User_Visor.html"
            GetStartedPanePathAdmin="Products_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Products_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Products_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_saleslit"
            DescriptionResourceId="SalesLit_SubArea_Description"
            Entity="salesliterature"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Tools"
         ResourceId="Area_Tools"
         IsProfile="true"
         DescriptionResourceId="Area_Tools_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_reports"
            Entity="report"
            DescriptionResourceId="Reports_Description"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="report"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_traces"
            Icon="/_imgs/area/18_alerts.png"
            Url="/_root/tracewall.aspx"
            ResourceId="Homepage_Alerts"
            AvailableOffline="false"
            DescriptionResourceId="Alerts_SubArea_Description"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="tracelog"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_calendar"
            ResourceId="Homepage_Calendar"
            Icon="/_imgs/area/18_calendar.gif"
            Url="/workplace/home_calendar.aspx"
            Client="Web"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="activitypointer"
               Privilege="Read" />
   </SubArea>
  </Group>
 </Area>
 <Area Id="Settings"
       ResourceId="Area_Settings"
       ShowGroups="true"
       Icon="/_imgs/settings_24x24.gif"
       DescriptionResourceId="Settings_Area_Description"
       IntroducedVersion="7.0.0.0">
  <Group Id="Business_Setting"
         ResourceId="Menu_Label_Business"
         DescriptionResourceId="Menu_Label_Business"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_businessmanagement"
            ResourceId="Homepage_BusinessManagement"
            DescriptionResourceId="BizManagement_SubArea_Description"
            Icon="/_imgs/ico_18_busmanagement.gif"
            Url="/tools/business/business.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_template"
            ResourceId="Homepage_Template"
            DescriptionResourceId="Template_SubArea_Description"
            Icon="/_imgs/ico_18_templates.gif"
            Url="/tools/templates/templates.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_productcatalog"
            ResourceId="Homepage_ProductCatalog"
            DescriptionResourceId="ProductCatalog_SubArea_Description"
            Icon="/_imgs/ico_18_productcatalog.gif"
            Url="/tools/productcatalog/productcatalog.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="product"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_servicemanagement"
            ResourceId="Homepage_ServiceManagement"
            DescriptionResourceId="ServiceManagement_SubArea_Description"
            Url="/tools/servicemanagement/servicemanagement.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="Customizations"
         ResourceId="Homepage_SystemCustomization"
         DescriptionResourceId="Homepage_SystemCustomization"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_syscust"
            ResourceId="Menu_Label_Customizations"
            DescriptionResourceId="Customization_SubArea_Description"
            Icon="/_imgs/area/18_syscust.gif"
            Url="/tools/systemcustomization/systemcustomization.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_solution"
            Entity="solution"
            ResourceId="Web.Tools.Solution.map_xml.aspx_1"
            AvailableOffline="false"
            GetStartedPanePath="Solutions_Web_Admin_Visor.html"
            GetStartedPanePathAdmin="Solutions_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Solutions_Outlook_Admin_Visor.html"
            GetStartedPanePathAdminOutlook="Solutions_Outlook_Admin_Visor.html"
            DescriptionResourceId="Web.Tools.Solution.map_xml.aspx_2"
            Url="/tools/Solution/home_solution.aspx?etc=7100"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="solution"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_marketplace"
            ResourceId="Homepage_Marketplace"
            DescriptionResourceId="Marketplace_SubArea_Description"
            Icon="/_imgs/SystemCustomization/ico_18_marketplace.png"
            Url="/tools/SystemCustomization/SolutionsMarketplace/SolutionsMarketplace.aspx"
            Client="Web"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="System_Setting"
         ResourceId="Menu_Label_System"
         DescriptionResourceId="Menu_Label_System"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_administration"
            ResourceId="Homepage_Administration"
            DescriptionResourceId="Administration_SubArea_Description"
            Icon="/_imgs/ico_18_administration.gif"
            Url="/tools/Admin/admin.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_security"
            ResourceId="AdminSecurity_SubArea_Title"
            DescriptionResourceId="AdminSecurity_SubArea_Description"
            Icon="/_imgs/area/Security_32.png"
            Url="/tools/AdminSecurity/adminsecurity_area.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_datamanagement"
            ResourceId="Homepage_DataManagement"
            DescriptionResourceId="DataManagement_SubArea_Description"
            Icon="/_imgs/ico_18_datamanagement.gif"
            Url="/tools/DataManagement/datamanagement.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_systemjobs"
            ResourceId="Homepage_SystemJobs"
            DescriptionResourceId="SystemJobs_SubArea_Description"
            Entity="asyncoperation"
            Url="/tools/business/home_asyncoperation.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_documentmanagement"
            ResourceId="DocumentManagement.SettingsArea.Heading"
            DescriptionResourceId="DocumentManagement.SettingsArea.Description"
            Icon="/_imgs/DocumentManagement_16.png"
            Url="/tools/documentmanagement/documentmanagement.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0">
    <Privilege Entity="sharepointsite"
               Privilege="Read" />
    <Privilege Entity="sharepointdocumentlocation"
               Privilege="Read" />
   </SubArea>
   <SubArea Id="nav_audit"
            ResourceId="Audit_SubArea_Title"
            DescriptionResourceId="Audit_SubArea_Description"
            Icon="/_imgs/area/16_audit.png"
            Url="/tools/audit/audit_area.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="nav_social"
            ResourceId="Social_SubArea_Title"
            DescriptionResourceId="Social_SubArea_Description"
            Icon="/_imgs/area/16_social.png"
            Url="/tools/social/social_area.aspx"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="msdyn_postconfig"
            ResourceId="Activity_Feed_Configuration"
            Entity="msdyn_postconfig"
            IntroducedVersion="7.0.0.0" />
   <SubArea Id="msdyn_postruleconfig"
            ResourceId="Activity_Feed_Rules_Configuration"
            Entity="msdyn_postruleconfig"
            IntroducedVersion="7.0.0.0" />
  </Group>
  <Group Id="ProcessCenter"
         ResourceId="Menu_Label_ProcessCenter"
         DescriptionResourceId="Menu_Label_ProcessCenter"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="nav_workflow"
            Entity="workflow"
            DescriptionResourceId="Workflow_SubArea_Description"
            AvailableOffline="false"
            GetStartedPanePath="Workflows_Web_User_Visor.html"
            GetStartedPanePathAdmin="Workflows_Web_Admin_Visor.html"
            GetStartedPanePathOutlook="Workflows_Outlook_User_Visor.html"
            GetStartedPanePathAdminOutlook="Workflows_Outlook_Admin_Visor.html"
            IntroducedVersion="7.0.0.0" />
  </Group>
 </Area>
 <Area Id="HLP"
       ResourceId="Area_Help"
       ShowGroups="true"
       Icon="/_imgs/icn_help16.png"
       DescriptionResourceId="Help_Area_Description"
       IntroducedVersion="7.0.0.0">
  <Group Id="HLP_GRP"
         ResourceId="Group_Help"
         DescriptionResourceId="Help_Description"
         IntroducedVersion="7.0.0.0">
   <SubArea Id="Help_Resource_Center"
            Url="http://go.microsoft.com/fwlink/?LinkId=296269&amp;clcid=0x409"
            ResourceId="Area_CustomerCenter"
            DescriptionResourceId="ResourceCenter_Area_Description"
            AvailableOffline="false"
            IntroducedVersion="7.0.0.0" />
  </Group>
 </Area>
</SiteMap>

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Area> (SiteMap)

Specifies the areas that appear in the navigation pane.

Syntax

<Area
  URL=string
  Id=string
  ShowGroups=true|false>
  <Titles>
  <Descriptions>
  <Group>
</Area>

Attributes and Elements

Attributes

Attribute | Description | Type | Usage
Description | Deprecated. Use the <Description> (SiteMap) element. | String | Optional
DescriptionResourceID | For internal use only. | String | Optional
Icon | Specifies a URL to a 16x16 pixel image that will be displayed in the Navigation pane for this area. | String | Optional
Id | Specifies a unique identifier in ASCII. Valid values are a-z, A-Z, 0-9, and underscore (_). Spaces are not allowed. | String | Required
License | Deprecated. | String | Optional
ResourceId | For internal use only. | String | Optional
ShowGroups | Controls whether groups of sub-areas are shown in the navigation pane. Valid values are true and false. | Boolean | Optional
Title | Deprecated. Use the <Titles> (SiteMap) and <Title> (SiteMap) elements. | String | Optional
Url | Specifies the CRM for Outlook URL to render for the Outlook folder that represents the Area. | String | Optional

Child Elements

Element | Description
<Titles> (SiteMap) | Contains a set of localized titles for an area.
<Descriptions> (SiteMap) | Contains a set of localized descriptions.
<Group> (SiteMap) | Specifies a group of subareas.

Parent Elements

Element | Description
<SiteMap> (SiteMap) | Specifies the root node for the site map.

Remarks

The Application Areas in Microsoft Dynamics CRM include Workplace, Sales, Marketing, Customer Service, Settings and Help. New areas can be added or existing Areas can be removed. However, removing the Settings area is not recommended. Instead, use privileges to control access to Settings.

The Navigation Pane will not display Area elements without visible SubArea elements. SubArea elements may be hidden from users based on security privileges. If all the SubArea elements in an Area are hidden, or none are defined, the Area will not display.

Example

The following shows an example of how to use the Area element.

Xml Copy Code
<Area Id="Custom_Area">
 <Titles>
  <Title LCID="1033" Title="English Area Title"/>
  <Title LCID="1031" Title="German Area Title"/>
 </Titles>
 <Descriptions>
  <Description LCID="1033" Description="English Description"/>
  <Description LCID="1031" Description="German Description"/>
 </Descriptions>
 <Group Id="Custom_Group">
  <SubArea Id="Custom_SubArea"
   Url="http://my_app/my_page.aspx"
   AvailableOffline="false" >
   <Titles>
    <Title LCID="1033" Title="English SubArea Title"/>
    <Title LCID="1031" Title="German SubArea Title"/>
   </Titles>
  </SubArea>
 </Group>
</Area>

Element Information

Schema Name | SiteMap
Validation File | SiteMapType.xsd
Number of Occurrences | 0 or More
XPath | //SiteMap/SiteMap/Area

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Description> (SiteMap)

Provides a description in a specific language for the parent of the Descriptions element.

Syntax

Xml
<Description
 LCID=string
 Description=string
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
LCID | A four or five digit locale ID for the Description. | String | Required
Description | Text to be displayed. | String | Required

Child Elements

This element has no child elements

Parent Elements

Element | Description
<Descriptions> (SiteMap) | Specifies a set of localizable Descriptions for the parent element.

Remarks

These descriptions appear in Microsoft Dynamics CRM for Microsoft Office Outlook and Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access clients.

Valid locale ID values can be found at Locale ID (LCID) Chart.

Element Information

Schema Name

Description

Validation File

SiteMapType.xsd

Number of Occurrences

1 or more

XPath

Copy Code
//SiteMap/Area/Descriptions/Description | //SiteMap/Area/Group/Descriptions/Description |//SiteMap/Area/Group/SubArea/Descriptions/Description

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Descriptions> (SiteMap)

Specifies a set of localizable Descriptions for the parent element.

Syntax

Xml
<Descriptions>
 <Description />
</Descriptions>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Description> (SiteMap) | Provides a description in a specific language for the parent of the Descriptions element. Descriptions appear in Microsoft Dynamics CRM for Microsoft Office Outlook and Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access.

Parent Elements

Element | Description
<Area> (SiteMap) | Specifies an area that appears in the navigation pane.
<Group> (SiteMap) | Specifies a group of subareas. Groups can be shown or hidden as defined by the area. Groups defined within the Workplace area can be marked as a user selectable profile. These profiles are available for users to select in their personal options.
<SubArea> (SiteMap) | Specifies a navigation option within an Area. Defines what is displayed in the main pane of the application when selected.

Element Information

Schema Name

DescriptionsType_SiteMap

Validation File

SiteMapType.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//SiteMap/Area/Descriptions |
//SiteMap/Area/Group/SubArea/Descriptions |
//SiteMap/Area/Group/Descriptions

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Group> (SiteMap)

Specifies a group of subareas.

Syntax

Xml
<Group
 Description="String"
 DescriptionResourceId="String"
 Icon="String"
 Id="String"
 IsProfile=["0" | "1" | "true" | "false"]
 License="String"
 ResourceId="String"
 Title="String"
 Url="String" >
 <Titles />
 <Descriptions />
 <SubArea />
</Group>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Description | Deprecated. Use the Group/Descriptions/Description element instead. | String | Optional
DescriptionResourceId | For internal use only. Use the Group/Descriptions/Description element instead. | String | Optional
Icon | Unused. It is not possible to display an icon for a group. | String | Optional
Id | A unique identifier for this Group element. | String | Required
IsProfile | Controls whether this Group represents a user selectable Profile for the Workplace. This only applies for Groups within the Workplace Area. | Boolean | Optional
License | Deprecated. | String | Optional
ResourceId | For internal use only. Use the Group/Titles/Title element to set the text to display for this Group. | String | Optional
Title | Deprecated. Use the Group/Titles/Title element instead. | String | Optional
Url | Specifies the URL to render for the Outlook folder that represents the Group in CRM for Outlook. | String | Optional

Child Elements

Element | Description
<Descriptions> (SiteMap) | Specifies a set of localizable Descriptions for the Group.
<SubArea> (SiteMap) | Specifies a navigation option within an Area. Defines what will be displayed in the main pane of the application when selected.
<Titles> (SiteMap) | Specifies a set of localizable Titles for the Group.

Parent Elements

Element | Description
<Area> (SiteMap) | Specifies an area that appears in the navigation pane.

Remarks

Groups can be shown or hidden as defined by the area. Groups defined within the Workplace area can be marked as a user selectable profile. These profiles are available for users to select in their personal options.

Element Information

Schema Name

Group

Validation File

SiteMapType.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//SiteMap/Area/Group

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Privilege> (SiteMap)

Controls whether a subarea is displayed based on privileges available in any security roles assigned to the user.

Syntax

Xml
<Privilege
 Entity=String
 Privilege=[Read|Write|Append|AppendTo|Create|Delete|Share|Assign|All|AllowQuickCampaign|UseInternetMarketing]
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Entity

Specifies the name of the entity to check privileges for. A valid value has a length greater than 1.

String

Privilege

The privilege to check.

Valid values include:

  • Read
  • Write
  • Append
  • AppendTo
  • Create
  • Delete
  • Share
  • Assign
  • All
  • AllowQuickCampaign
  • UseInternetMarketing

Multiple values can be used as long as they are separated by a comma and do not contain spaces.

String

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<SubArea> (SiteMap) | Specifies a navigation option within an Area. Defines what is displayed in the main pane of the application when selected.

Element Information

Schema Name

Privilege

Validation File

SiteMapType.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//SiteMap/Area/Group/SubArea/Privilege

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SiteMap> (SiteMap)

Specifies the root node for the site map.

Syntax

Xml
<SiteMap
 Url=string>
 <Area />
</SiteMap>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Url | Specifies the URL for CRM for Outlook to render | String | Optional

Child Elements

Element | Description
<Area> (SiteMap) | Defines an area in the navigation pane.

Parent Elements

Element | Description
<SiteMap> (ImportExportXml) | The container node for the <SiteMap> (SiteMap) node within the customization.xml file.

Element Information

Schema Name

SiteMapType

Validation File

SiteMapType.xsd

Number of Occurrences

1

XPath

Copy Code
//SiteMap/SiteMap

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SubArea> (SiteMap)

Specifies a navigation option within an <Area> (SiteMap). Defines what will be displayed in the main pane of the application when selected.

Syntax

Xml
<SubArea
 AvailableOffline=["0" | "1" | "true" | "false"]
 CheckExtensionProperty="String"
 Client=["All" | "Outlook" | "OutlookLaptopClient" | "OutlookWorkstationClient"  | "Web" ]
 Description="String"
 DescriptionResourceId="String"
 Entity="String"
 GetStartedPanePath="String"
 GetStartedPanePathAdmin="String"
 GetStartedPanePathAdminOutlook="String"
 GetStartedPanePathOutlook="String"
 Icon="String"
 Id="String"
 License="String"
 OutlookShortcutIcon="String"
 PassParams=["0" | "1" | "true" | "false"]
 ResourceId="String"
 Sku=["All" | "OnPremise" | "Live" | "SPLA"]
 Title="String"
 Url="String">
 <Titles />
 <Descriptions />
 <Privilege/>
</SubArea>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AvailableOffline

Controls whether SubArea is available offline.

Boolean

Optional

CheckExtensionProperty

For internal use only.

String

Optional

Client

Specifies the type of client.

Default: All

Valid values:

  • All
  • Outlook
  • OutlookLaptopClient
  • OutlookWorkstationClient
  • Web

Multiple values can be used as long as they are separated by a comma and do not contain spaces.

There is not a separate value for Microsoft Dynamics CRM for tablets. Setting this to All or Web will not filter the display of this SubArea in the CRM for tablets client.

String

Optional

Description

Deprecated. Use the SubArea/Descriptions/Description element instead.

String

Optional

DescriptionResourceId

For internal use only. Use the SubArea/Descriptions/Description element instead.

String

Optional

DefaultDashboard

Specifies the GUID for default dashboard to be displayed for this subarea.

String

Optional

Entity

Specifies the name for the entity. A valid value has a length greater then 1. If a Url is not specified, the default view of the specified entity will be displayed.

String

Optional

GetStartedPanePath

The Get Started Pane was removed from Microsoft Dynamics CRM 2013 and the Microsoft Dynamics CRM Online Fall '13 Service Update.

String

Optional

GetStartedPanePathAdmin

The Get Started Pane was removed from Microsoft Dynamics CRM 2013 and the Microsoft Dynamics CRM Online Fall '13 Service Update.

String

Optional

GetStartedPanePathAdminOutlook

The Get Started Pane was removed from Microsoft Dynamics CRM 2013 and the Microsoft Dynamics CRM Online Fall '13 Service Update.

String

Optional

GetStartedPanePathOutlook

The Get Started Pane was removed from Microsoft Dynamics CRM 2013 and the Microsoft Dynamics CRM Online Fall '13 Service Update.

String

Optional

Icon

Specifies a URL for an 18x18 pixel image to display for the SubArea.

String

Optional

Id

A unique identifier for this SubArea element.

Valid values:

a-z, A-Z, 0-9, and underscore (_)

String

Required

License

Deprecated.

String

Optional

OutlookShortcutIcon

Specifies the icon to display in Microsoft Dynamics CRM for Microsoft Office Outlook.

String

Optional

PassParams

Specifies whether information about the organization and language context are passed to the URL.

Boolean

Optional

ResourceId

For internal use only. Use the SubArea/Titles/Title element to set the text to display for this SubArea.

String

Optional

Sku

Specifies the versions of Microsoft Dynamics CRM that displays this SubArea.

Default: All

Valid values:

  • All
  • OnPremise
  • Live
  • SPLA

Multiple values can be used as long as they are separated by a comma and do not contain spaces.

String

Optional

Title

Deprecated. Use the SubArea/Titles/Title element instead.

String

Optional

Url

Specifies a URL or HTML Web Resource for a page to display in the main frame of the application when this subarea is selected.

String

Optional

Child Elements

Element | Description
<Privilege> (SiteMap) | Controls whether a subarea is displayed based on privileges available in any security roles assigned to the user.

Parent Elements

Element | Description
<Group> (SiteMap) | Specifies a group of subareas. Groups can be shown or hidden as defined by the area. Groups defined within the Workplace area can be marked as a user selectable profile. These profiles are available for users to select in their personal options.

Remarks

The SubArea element must contain a <Titles> (SiteMap) element or a valid Title attribute for the user language or a value for the ResourceId attribute.

For CRM for Outlook, titles must be defined through the <Titles> (SiteMap) element, the Entity, or the ResourceId attribute value and must be unique within the parent group.

More than one instance of the same pages may occur. Therefore, you must make sure that each belongs to different combinations of clients and offline modes.

These changes affect the structure of CRM for Outlook shortcuts and the Web client Go To menu.

The OutlookWorkstationClientClient attribute value refers to CRM for Outlook.

The OutlookLaptopClientClient attribute value refers to Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access.

Example

The following shows an example of how to use the SubArea element.

Xml Copy Code
<SubArea Id="nav_dashboard" PassParams="1"
 Url="$webresource:MyIsv_/navDashboard.htm" >
 <Titles>
  <Title LCID="1033" Title="Dashboard" />
 </Titles>
</SubArea>

When referring to an HTML or Image Web Resource use the web resource directive and the HTML or Image Web Resource name. “$webresource:+ Web resource name.”. This creates a dependency so the HTML or Image Web Resource cannot be removed while the SubArea is referencing it.

Element Information

Schema Name

SubArea

Validation File

SiteMapType.xsd

Number of Occurrences

0 or more

XPath

Copy Code
//SiteMap/Area/Group/SubArea

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Title> (SiteMap)

Provides a title in a specific language for the parent of the <Titles> (SiteMap) element.

Syntax

Xml
<Title
 LCID=string
 Title=string
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
LCID | A four or five digit Locale ID for the title. | String | Required
Title | Text to be displayed. | String | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Titles> (SiteMap) | Specifies a set of localizable Titles for the parent element.

Remarks

Valid locale ID values can be found at Locale ID (LCID) Chart.

Element Information

Schema Name

Title

Validation File

SiteMapType.xsd

Number of Occurrences

1 or more

XPath

Copy Code
//SiteMap/Area/Titles/Title | //SiteMap/Area/Group/SubArea/Titles/Title | //SiteMap/Area/Group/Titles/Title

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Titles> (SiteMap)

Specifies a set of localizable Titles for the parent element.

Syntax

Xml
<Titles>
 <Title />
</Title>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Title> (SiteMap) | Specifies the text in a specific language to be displayed for the parent of the Titles element.

Parent Elements

Element | Description
<Area> (SiteMap) | Specifies an area that appears in the navigation pane.
<Group> (SiteMap) | Specifies a group of subareas. Groups can be shown or hidden as defined by the area. Groups defined within the Workplace area can be marked as a user selectable profile. These profiles are available for users to select in their personal options.
<SubArea> (SiteMap) | Specifies a navigation option within an Area. Defines what will be displayed in the main pane of the application when selected.

Element Information

Schema Name

TitlesType_SiteMap

Validation File

SiteMapType.xsd

Number of Occurrences

0 or 1

XPath

Copy Code
//SiteMap/Area/Titles | //SiteMap/Area/Group/SubArea/Titles | //SiteMap/Area/Group/Titles

See Also

Concepts

Change application navigation using the SiteMap

Other Resources

SiteMap XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SiteMap schema

The following is the schema definition for the SiteMap portion of an import/export customization file. It is included from the Customization solutions file schema. For more information, see Package and distribute extensions using solutions.

SiteMap Schema

You can find this schema in the SDK\Schemas\SiteMap.xsd file in the SDK package. Download the Microsoft Dynamics CRM SDK package.

Xml Copy Code
<?xml version="1.0"?>
<xs:schema attributeFormDefault="unqualified"
           elementFormDefault="qualified"
           xmlns:xs="http://www.w3.org/2001/XMLSchema">
 <xs:include schemaLocation="SiteMapType.xsd" />
 <xs:element name="SiteMap"
             type="SiteMapType">
  <xs:unique name="AreaIdMustBeUnique">
   <xs:selector xpath="Area" />
   <xs:field xpath="@Id" />
  </xs:unique>
 </xs:element>
</xs:schema>

SiteMap Type Schema

You can find this schema in the SDK\Schemas\SiteMapType.xsd file in the SDK download package.

Xml Copy Code
<?xml version="1.0"?>
<xs:schema attributeFormDefault="unqualified"
           elementFormDefault="qualified"
           xmlns:xs="http://www.w3.org/2001/XMLSchema">
 <xs:simpleType name="LCIDType_SiteMap">
  <xs:restriction base="xs:decimal">
   <xs:fractionDigits value="0"
                      fixed="true" />
   <xs:totalDigits value="4" />
  </xs:restriction>
 </xs:simpleType>
 <xs:complexType name="TitlesType_SiteMap">
  <xs:sequence>
   <xs:element name="Title"
               minOccurs="1"
               maxOccurs="unbounded">
    <xs:annotation>
     <xs:appinfo>Title</xs:appinfo>
     <xs:documentation>Specifies the text in a specific language to be displayed for the parent of the Titles element.</xs:documentation>
    </xs:annotation>
    <xs:complexType>
     <xs:attribute name="LCID"
                   type="LCIDType_SiteMap"
                   use="required" >
      <xs:annotation>
       <xs:appinfo>Title.LCID</xs:appinfo>
       <xs:documentation>A four digit Locale ID for the title.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="Title"
                   type="xs:string"
                   use="required" >
      <xs:annotation>
       <xs:appinfo>Title.Title</xs:appinfo>
       <xs:documentation>Text to be displayed.</xs:documentation>
      </xs:annotation>
     </xs:attribute>

    </xs:complexType>
   </xs:element>
  </xs:sequence>

 </xs:complexType>
 <xs:complexType name="DescriptionsType_SiteMap">
  <xs:sequence>
   <xs:element name="Description"
               minOccurs="1"
               maxOccurs="unbounded">
    <xs:annotation>
     <xs:appinfo>Description</xs:appinfo>
     <xs:documentation>Provides a description in a specific language for the parent of the Descriptions element. Descriptions appear in Microsoft Dynamics CRM for Microsoft Office Outlook and Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access clients.</xs:documentation>
    </xs:annotation>
    <xs:complexType>
     <xs:attribute name="LCID"
                   type="LCIDType_SiteMap"
                   use="required" >
      <xs:annotation>
       <xs:appinfo>Description.LCID</xs:appinfo>
       <xs:documentation>A four digit Locale ID for the title.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="Description"
                   type="xs:string"
                   use="required" >
      <xs:annotation>
       <xs:appinfo>Description.Description</xs:appinfo>
       <xs:documentation>Text to be displayed.</xs:documentation>
      </xs:annotation>
     </xs:attribute>

    </xs:complexType>
   </xs:element>
  </xs:sequence>

 </xs:complexType>
 <xs:complexType name ="SiteMapType">
  <xs:annotation>
   <xs:appinfo>SiteMap</xs:appinfo>
   <xs:documentation>Specifies the root node for the site map.</xs:documentation>
  </xs:annotation>
  <xs:sequence>
   <xs:element name="Area"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:annotation>
     <xs:appinfo>Area</xs:appinfo>
     <xs:documentation>Specifies an area that appears in the navigation pane.</xs:documentation>
    </xs:annotation>
    <xs:complexType>
     <xs:sequence>
      <xs:element name="Titles"
                  type="TitlesType_SiteMap"
                  minOccurs="0"
                  maxOccurs="1" >
       <xs:annotation>
        <xs:appinfo>Area/Titles</xs:appinfo>
        <xs:documentation>Specifies a set of localizable Titles for the Area.</xs:documentation>
       </xs:annotation>
      </xs:element>
      <xs:element name="Descriptions"
                  type="DescriptionsType_SiteMap"
                  minOccurs="0"
                  maxOccurs="1" >
       <xs:annotation>
        <xs:appinfo>Area/Descriptions</xs:appinfo>
        <xs:documentation>Specifies a set of localizable Descriptions for the Area.</xs:documentation>
       </xs:annotation>
      </xs:element>
      <xs:element name="Group"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:annotation>
        <xs:appinfo>Group</xs:appinfo>
        <xs:documentation>Specifies a group of subareas. Groups can be shown or hidden as defined by the area. Groups defined within the Workplace area can be marked as a user selectable profile. These profiles are available for users to select in their personal options.</xs:documentation>
       </xs:annotation>
       <xs:complexType>
        <xs:sequence>
         <xs:element name="Titles"
                     type="TitlesType_SiteMap"
                     minOccurs="0"
                     maxOccurs="1" >
          <xs:annotation>
           <xs:appinfo>Group/Titles</xs:appinfo>
           <xs:documentation>Specifies a set of localizable Titles for the Group.</xs:documentation>
          </xs:annotation>
         </xs:element>
         <xs:element name="Descriptions"
                     type="DescriptionsType_SiteMap"
                     minOccurs="0"
                     maxOccurs="1" >
          <xs:annotation>
           <xs:appinfo>Group/Descriptions</xs:appinfo>
           <xs:documentation>Specifies a set of localizable Descriptions for the SubArea.</xs:documentation>
          </xs:annotation>
         </xs:element>
         <xs:element name="SubArea"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:annotation>
           <xs:appinfo>SubArea</xs:appinfo>
           <xs:documentation>Specifies a navigation option within an Area. Defines what will be displayed in the main pane of the application when selected.</xs:documentation>
          </xs:annotation>
          <xs:complexType>
           <xs:sequence>
            <xs:element name="Titles"
                        type="TitlesType_SiteMap"
                        minOccurs="0"
                        maxOccurs="1" >
             <xs:annotation>
              <xs:appinfo>SubArea/Titles</xs:appinfo>
              <xs:documentation>Specifies a set of localizable Titles for the SubArea.</xs:documentation>
             </xs:annotation>
            </xs:element>
            <xs:element name="Descriptions"
                        type="DescriptionsType_SiteMap"
                        minOccurs="0"
                        maxOccurs="1" >
             <xs:annotation>
              <xs:appinfo>SubArea/Descriptions</xs:appinfo>
              <xs:documentation>Specifies a set of localizable Descriptions for the SubArea.</xs:documentation>
             </xs:annotation>
            </xs:element>
            <xs:element name="Privilege"
                        minOccurs="0"
                        maxOccurs="unbounded">
             <xs:annotation>
              <xs:appinfo>Privilege</xs:appinfo>
              <xs:documentation>Controls whether a subarea is displayed based on privileges available in any security roles assigned to the user.</xs:documentation>
             </xs:annotation>
             <xs:complexType>
              <xs:attribute name="Entity"
                            type="CRM_Entity_SiteMap" >
               <xs:annotation>
                <xs:appinfo>Privilege.Entity</xs:appinfo>
                <xs:documentation>Specifies the name of the entity to check privileges with.</xs:documentation>
               </xs:annotation>
              </xs:attribute>
              <xs:attribute name="Privilege"
                            type="CRM_PrivilegeId_SiteMap" >
               <xs:annotation>
                <xs:appinfo>Privilege.Privilege</xs:appinfo>
                <xs:documentation>Specifies the privileges needed on the entity to display this subarea. </xs:documentation>
               </xs:annotation>
              </xs:attribute>

             </xs:complexType>
            </xs:element>
           </xs:sequence>
           <xs:attribute name="Id"
                         type="CRM_Identifier_SiteMap"
                         use="required" >
            <xs:annotation>
             <xs:appinfo>SubArea.Id</xs:appinfo>
             <xs:documentation>A unique identifier for this SubArea element.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="Title"
                         type="xs:string" >
            <xs:annotation>
             <xs:appinfo>SubArea.Title</xs:appinfo>
             <xs:documentation>Deprecated. Use the SubArea/Titles/Title element instead.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="ResourceId"
                         type="xs:string" >
            <xs:annotation>
             <xs:appinfo>SubArea.ResourceId</xs:appinfo>
             <xs:documentation>For internal use only. Use the SubArea/Titles/Title element to set the text to display for this Group.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="Icon"
                         type="xs:string" >
            <xs:annotation>
             <xs:appinfo>SubArea.Icon</xs:appinfo>
             <xs:documentation>Specifies a URL for an 18x18 pixel image to display for the SubArea.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="OutlookShortcutIcon"
                         type="xs:string" >
            <xs:annotation>
             <xs:appinfo>SubArea.OutlookShortcutIcon</xs:appinfo>
             <xs:documentation>Specifies the icon to display in Microsoft Dynamics CRM for Microsoft Office Outlook.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="Url"
                         type="xs:string" >
            <xs:annotation>
             <xs:appinfo>SubArea.Url</xs:appinfo>
             <xs:documentation>Specifies a URL for a page to display in the main frame of the application when this subarea is selected.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="PassParams"
                         type="xs:boolean"
                         use="optional" >
            <xs:annotation>
             <xs:appinfo>SubArea.PassParams</xs:appinfo>
             <xs:documentation>Specifies whether information about the organization and language context are passed to the URL.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="Client"
                         type="CRM_Client_SiteMap" >
            <xs:annotation>
             <xs:appinfo>SubArea.Client</xs:appinfo>
             <xs:documentation>Specifies the client(s) that will display this SubArea.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="AvailableOffline"
                         type="xs:boolean" >
            <xs:annotation>
             <xs:appinfo>SubArea.AvailableOffline</xs:appinfo>
             <xs:documentation>Controls whether SubArea is available when a user is working offline with the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="CheckExtensionProperty"
                         type="xs:string" >
            <xs:annotation>
             <xs:appinfo>SubArea.CheckExtensionProperty</xs:appinfo>
             <xs:documentation>Controls whether SubArea is available based on the extension property.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="Sku"
                         type="CRM_Sku_SiteMap" >
            <xs:annotation>
             <xs:appinfo>SubArea.Sku</xs:appinfo>
             <xs:documentation>Specifies the version(s) of Microsoft CRM that will display this SubArea.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="License"
                         type="CRM_License_SiteMap" >
            <xs:annotation>
             <xs:appinfo>SubArea.License</xs:appinfo>
             <xs:documentation>Deprecated.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="Entity"
                         type="CRM_Entity_SiteMap" >
            <xs:annotation>
             <xs:appinfo>SubArea.Entity</xs:appinfo>
             <xs:documentation>Specifies the name for the entity. If a Url is not specified, the default view of the specified entity will be displayed.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="IntroducedVersion"
                         type="xs:string" >
            <xs:annotation>
             <xs:appinfo>SubArea.IntroducedVersion</xs:appinfo>
             <xs:documentation>IntroducedVersion of the SubArea.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="Description"
                         type="xs:string" >
            <xs:annotation>
             <xs:appinfo>SubArea.Description</xs:appinfo>
             <xs:documentation>Deprecated. Use the SubArea/Descriptions/Description element instead.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="DescriptionResourceId"
                         type="xs:string" >
            <xs:annotation>
             <xs:appinfo>SubArea.DescriptionResourceId</xs:appinfo>
             <xs:documentation>For internal use only. Use the SubArea/Descriptions/Description element instead.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="GetStartedPanePath"
                         type="xs:string"
                         use="optional" >
            <xs:annotation>
             <xs:appinfo>SubArea.GetStartedPanePath</xs:appinfo>
             <xs:documentation>Specifies the path to the Get Started page for this subarea.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="GetStartedPanePathOutlook"
                         type="xs:string"
                         use="optional" >
            <xs:annotation>
             <xs:appinfo>SubArea.GetStartedPanePathOutlook</xs:appinfo>
             <xs:documentation>Specifies the path to the Get Started page for this subarea when Microsoft Dynamics CRM for Outlook is in use.</xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="GetStartedPanePathAdmin"
                         type="xs:string"
                         use="optional" >
            <xs:annotation>
             <xs:appinfo>SubArea.GetStartedPanePathAdmin</xs:appinfo>
             <xs:documentation>Specifies the path to the Get Started page for this subarea if the user is logged in as an administrator. </xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="DefaultDashboard"
                         type="xs:string"
                         use="optional" >
            <xs:annotation>
             <xs:appinfo>SubArea.DefaultDashboard</xs:appinfo>
             <xs:documentation>Specifies the GUID for default dashboard to be displayed for this subarea. </xs:documentation>
            </xs:annotation>
           </xs:attribute>
           <xs:attribute name="GetStartedPanePathAdminOutlook"
                         type="xs:string"
                         use="optional" >
            <xs:annotation>
             <xs:appinfo>SubArea.GetStartedPanePathAdminOutlook</xs:appinfo>
             <xs:documentation>Specifies the path to the Get Started page for this subarea if the user is logged in as an administrator and Microsoft Dynamics CRM for Outlook is in use.</xs:documentation>
            </xs:annotation>
           </xs:attribute>

          </xs:complexType>
         </xs:element>
        </xs:sequence>
        <xs:attribute name="Id"
                      type="CRM_Identifier_SiteMap"
                      use="required" >
         <xs:annotation>
          <xs:appinfo>Group.Id</xs:appinfo>
          <xs:documentation>A unique identifier for this Group element.</xs:documentation>
         </xs:annotation>
        </xs:attribute>
        <xs:attribute name="Title"
                      type="xs:string" >
         <xs:annotation>
          <xs:appinfo>Group.Title</xs:appinfo>
          <xs:documentation>Deprecated. Use the Group/Titles/Title element instead.</xs:documentation>
         </xs:annotation>
        </xs:attribute>
        <xs:attribute name="Icon"
                      type="xs:string" >
         <xs:annotation>
          <xs:appinfo>Group.Icon</xs:appinfo>
          <xs:documentation>Unused. It is not possible to display an icon for a group.</xs:documentation>
         </xs:annotation>
        </xs:attribute>
        <xs:attribute name="Url"
                      type="xs:string" >
         <xs:annotation>
          <xs:appinfo>Group.Url</xs:appinfo>
          <xs:documentation>
           Specifies the URL to render for the Outlook folder that represents the Group in Microsoft Dynamics CRM for Outlook.
          </xs:documentation>
         </xs:annotation>
        </xs:attribute>
        <xs:attribute name="ResourceId"
                      type="xs:string" >
         <xs:annotation>
          <xs:appinfo>Group.ResourceId</xs:appinfo>
          <xs:documentation>For internal use only. Use the Group/Titles/Title element to set the text to display for this Group.</xs:documentation>
         </xs:annotation>
        </xs:attribute>
        <xs:attribute name="IsProfile"
                      type="xs:boolean" >
         <xs:annotation>
          <xs:appinfo>Group.IsProfile</xs:appinfo>
          <xs:documentation>Controls whether this Group represents a user selectable Profile for the Workplace. This only applies for Groups within the Workplace Area.</xs:documentation>
         </xs:annotation>
        </xs:attribute>
        <xs:attribute name="License"
                      type="CRM_License_SiteMap" >
         <xs:annotation>
          <xs:appinfo>Group.License</xs:appinfo>
          <xs:documentation>Deprecated.</xs:documentation>
         </xs:annotation>
        </xs:attribute>
        <xs:attribute name="IntroducedVersion"
                      type="xs:string" >
         <xs:annotation>
          <xs:appinfo>Group.IntroducedVersion</xs:appinfo>
          <xs:documentation>IntroducedVersion of the Group.</xs:documentation>
         </xs:annotation>
        </xs:attribute>
        <xs:attribute name="Description"
                      type="xs:string" >
         <xs:annotation>
          <xs:appinfo>Group.Description</xs:appinfo>
          <xs:documentation>Deprecated. Use the Group/Descriptions/Description element instead.</xs:documentation>
         </xs:annotation>
        </xs:attribute>
        <xs:attribute name="DescriptionResourceId"
                      type="xs:string" >
         <xs:annotation>
          <xs:appinfo>Group.DescriptionResourceId</xs:appinfo>
          <xs:documentation>For internal use only. Use the Group/Descriptions/Description element instead.</xs:documentation>
         </xs:annotation>
        </xs:attribute>

       </xs:complexType>
      </xs:element>
     </xs:sequence>
     <xs:attribute name="Id"
                   type="CRM_Identifier_SiteMap"
                   use="required" >
      <xs:annotation>
       <xs:appinfo>Area.Id</xs:appinfo>
       <xs:documentation>A unique identifier for this Area element.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="Title"
                   type="xs:string" >
      <xs:annotation>
       <xs:appinfo>Area.Title</xs:appinfo>
       <xs:documentation>Deprecated. Use the Area/Titles/Title element instead.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="ResourceId"
                   type="xs:string" >
      <xs:annotation>
       <xs:appinfo>Area.ResourceId</xs:appinfo>
       <xs:documentation>For internal use only. Use the Area/Titles/Title element to set the text to display for this Area.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="Icon"
                   type="xs:string" >
      <xs:annotation>
       <xs:appinfo>Area.Icon</xs:appinfo>
       <xs:documentation>Specifies a URL for a 24x24 pixel image to display for the Area.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="Url"
                   type="xs:string" >
      <xs:annotation>
       <xs:appinfo>Area.Url</xs:appinfo>
       <xs:documentation>Specifies the Microsoft Dynamics CRM for Outlook URL to render for the Outlook folder that represents the Area.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="ShowGroups"
                   type="xs:boolean" >
      <xs:annotation>
       <xs:appinfo>Area.ShowGroups</xs:appinfo>
       <xs:documentation>Control whether Groups of SubAreas within this Area are shown in the Navigation pane.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="License"
                   type="CRM_License_SiteMap" >
      <xs:annotation>
       <xs:appinfo>Area.License</xs:appinfo>
       <xs:documentation>Deprecated.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="IntroducedVersion"
                   type="xs:string" >
      <xs:annotation>
       <xs:appinfo>Area.IntroducedVersion</xs:appinfo>
       <xs:documentation>IntroducedVersion of the Area node.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="Description"
                   type="xs:string" >
      <xs:annotation>
       <xs:appinfo>Area.Description</xs:appinfo>
       <xs:documentation>Deprecated. Use the Area/Descriptions/Description element instead.</xs:documentation>
      </xs:annotation>
     </xs:attribute>
     <xs:attribute name="DescriptionResourceId"
                   type="xs:string" >
      <xs:annotation>
       <xs:appinfo>Area.DescriptionResourceId</xs:appinfo>
       <xs:documentation>For internal use only. Use the Area/Descriptions/Description element instead.</xs:documentation>
      </xs:annotation>
     </xs:attribute>

    </xs:complexType>
    <xs:unique name="GroupIdMustBeUnique">
     <xs:selector xpath="Group" />
     <xs:field xpath="@Id" />
    </xs:unique>
   </xs:element>
  </xs:sequence>
  <xs:attribute name="IntroducedVersion"
                type="xs:string" >
   <xs:annotation>
    <xs:appinfo>SiteMap.IntroducedVersion</xs:appinfo>
    <xs:documentation>Specifies the IntroducedVersion of sitemap.</xs:documentation>
   </xs:annotation>
  </xs:attribute>
  <xs:attribute name="Url"
                type="xs:string" >
   <xs:annotation>
    <xs:appinfo>SiteMap.Url</xs:appinfo>
    <xs:documentation>Specifies the Microsoft Dynamics CRM URL for Microsoft Office Outlook to load.</xs:documentation>
   </xs:annotation>
  </xs:attribute>

 </xs:complexType>
 <xs:simpleType name="CRM_Identifier_SiteMap">
  <xs:annotation>
   <xs:appinfo>CRM_Identifier_SiteMap</xs:appinfo>
   <xs:documentation>Valid characters in this string are limited to: a-z, A-Z, 0-9, and the underscore(_) character. Spaces are not allowed.</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
   <xs:pattern value="[a-zA-Z0-9_]+" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CRM_Client_SiteMap">
  <xs:annotation>
   <xs:appinfo>CRM_Client_SiteMap</xs:appinfo>
   <xs:documentation>Valid values include:  'All'(default value),'Outlook', 'Web', 'OutlookWorkstationClient', and 'OutlookLaptopClient'. Multiple values can be used as long as they are separated by a comma and do not contain spaces. </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
   <xs:pattern value="((Outlook|Web|All|OutlookWorkstationClient|OutlookLaptopClient),?)+" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CRM_Sku_SiteMap">
  <xs:annotation>
   <xs:appinfo>CRM_Sku_SiteMap</xs:appinfo>
   <xs:documentation>Valid values include: 'All'(default value), 'OnPremise', 'Live', and 'SPLA'. Multiple values can be used as long as they are separated by a comma and do not contain spaces.</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
   <xs:pattern value="((All|OnPremise|Live|SPLA),?)+" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CRM_License_SiteMap">
  <xs:restriction base="xs:string" />
 </xs:simpleType>
 <xs:simpleType name="CRM_PrivilegeId_SiteMap">
  <xs:annotation>
   <xs:appinfo>CRM_PrivilegeId_SiteMap</xs:appinfo>
   <xs:documentation>Valid values include: 'Read', 'Write', 'Append', 'AppendTo', 'Create', 'Delete', 'Share', 'Assign', 'All', 'AllowQuickCampaign', and 'UseInternetMarketing'. Multiple values can be used as long as they are separated by a comma and do not contain spaces.</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
   <xs:pattern value="((Read|Write|Append|AppendTo|Create|Delete|Share|Assign|All|AllowQuickCampaign|CreateEntity|ImportCustomization|UseInternetMarketing),?)+" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CRM_Entity_SiteMap">
  <xs:annotation>
   <xs:appinfo>CRM_Entity_SiteMap</xs:appinfo>
   <xs:documentation>Valid Entity has length greater than 1.</xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
   <xs:minLength value="1"/>
  </xs:restriction>
 </xs:simpleType>
</xs:schema>

See Also

Reference

Customization solutions file schema

Concepts

Change application navigation using the SiteMap

Other Resources

Customization XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customize commands and the ribbon

Microsoft Dynamics CRM displays commands in different ways depending on the entity and the client. In most places in the web application you will see a command bar instead of a ribbon. CRM for tablets also uses data defined as ribbons to control what commands are available using a command bar that is optimized for touch.

The command bar provides better performance. The ribbon is still displayed in the web application for certain entity forms and it is still used for list views in Microsoft Dynamics CRM 2015 for Microsoft Office Outlook.

Both the command bar and the ribbon use the same underlying XML data to define what commands to display, when the commands are enabled, and what the commands do.

The topics in this section introduce you to key concepts that you must understand, and common tasks you perform when you customize the command bar or the ribbon.

Note
Because the underlying XML schema was designed to display commands as ribbons, the term ribbon will continue to be used in the documentation.

The SDK describes the process of editing the ribbon by editing the customization.xml file directly. Several people have created ribbon editors that provide a user interface to make editing the ribbon easier. Currently the following projects are available on CodePlex and other locations:

  • Ribbon Workbench for Dynamics CRM 2013
  • MS CRM 2011 : Pragma Toolkit : Ribbon, Site Map Editor
  • CRM 2011 Visual Ribbon Editor

To obtain support or help to use these programs, contact the program publisher.

In This Section

Ribbons available in Microsoft Dynamics CRM

Export ribbon definitions

Export, prepare to edit, and import the ribbon

Use localized labels with ribbons

Define ribbon commands

Define ribbon enable rules

Define ribbon display rules

Define ribbon actions

Pass Microsoft Dynamics CRM data from a page as a parameter to Ribbon Actions

Define custom actions to modify the ribbon

Define scaling for ribbon elements

Define ribbon tab display rules

Pass parameters to a URL by using the ribbon

Sample: Export ribbon definitions

Ribbon XML reference

Ribbon core schema

Ribbon types schema

Ribbon WSS schema

Related Sections

Extend the metadata model

Customize visualizations and dashboards

Customize entity views

Customize global option sets

Service calendar appearance configuration

Publish customizations

When to edit the customizations file

Developers guide to customization for Microsoft Dynamics CRM

Change application navigation using the SiteMap

Customize entity forms

Write code for Microsoft Dynamics CRM forms

Web resources for Microsoft Dynamics CRM

JavaScript libraries for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Ribbons available in Microsoft Dynamics CRM

This topic describes where ribbons are defined and modified in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

In This Topic

Ribbon definitions

Entity ribbons

Basic home Tab

Microsoft Dynamics CRM for Microsoft Office Outlook ribbons

Other ribbons

Ribbons for custom pages

Ribbon definitions

Microsoft Dynamics CRM contains default <RibbonDiffXml> (RibbonDiffXml) definitions for all ribbons in the application. You can export and view the current XML defining the ribbon for your organization, but you cannot update the XML directly. You customize the ribbon by defining how you want it to be changed. The change definitions that you specify are applied at runtime when the ribbon is displayed in the application. All of your changes will be in the <CustomAction> (RibbonDiffXml) or <HideCustomAction> (RibbonDiffXml) elements. These elements are applied over the default ribbon definitions provided by Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

When you write your change definitions, you will frequently need to reference the definitions of the default ribbons. For example, if you want to hide a specific ribbon element, you will need to know the unique Id of that element. If you want to position a new ribbon element within or next to an existing ribbon element, you will need to know the Id values for those elements, as well as the sequence order that will control the relative position of the elements.

Because of this requirement to reference the definitions of existing ribbon elements, it is very important to understand the current ribbon definitions in your organization. There are two messages you can use to export XML files representing the current state of your ribbons. These definitions include any customizations that have already been applied to your system so that you can customize any custom ribbons that were previously applied. For more information, see Export ribbon definitions.

To help you get started, the definitions of the default ribbon definitions are included in the downloadable files in the Microsoft Dynamics CRM SDK. The SDK\Resources\ExportedRibbonXml folder includes the output files you would have for an organization with a ribbon that has not been customized. You don’t need to run the sample application to export this data. If you have a customized ribbon, you should run the sample application to refresh the files in this folder with any customizations previously applied for your organization.

Within the exported ribbon XML files, the applicationRibbon.xml file includes all the ribbons that are not defined for a specific entity. These correspond to the Application Ribbons solution component. For each entity, you will find an entity nameribbon.xml file. This corresponds to the RibbonDiffXml that is included in each entity. If you want to edit the ribbon for a specific entity, you should locate the ribbon XML file for that entity.

Entity ribbons

All entities use a common ribbon definition called the Entity Ribbon Template. The entity ribbon template definition is located in the applicationribbon.xml file. When you create a custom entity, the ribbon you see is the default ribbon defined by the entity ribbon template. Each system entity has a separate <RibbonDiffXml> (RibbonDiffXml) definition that builds upon the entity ribbon template definition.

Within the applicationribbon.xml file, you can see the following tabs that apply to all entities:

  • Mscrm.Form.{!EntityLogicalName}.MainTab
    Tab displays the entity display name in the label.
  • Mscrm.Form.{!EntityLogicalName}.Related
    Tab has the label Add.
  • Mscrm.Form.{!EntityLogicalName}.Developer
    Tab has the label Customize.
  • Mscrm.HomepageGrid.{!EntityLogicalName}.MainTab
    Tab displays the plural entity display name in the label.
  • Mscrm.HomepageGrid.{!EntityLogicalName}.View
    Tab has the label View.
  • Mscrm.HomepageGrid.{!EntityLogicalName}.Related
    Tab has the label Add.
  • Mscrm.HomepageGrid.{!EntityLogicalName}.Developer
    Tab has the label Customize.
  • Mscrm.SubGrid.{!EntityLogicalName}.ContextualTabs
    When a sub grid in a form or chart has focus, the contextual tab appears with the label List Tools.
    • Mscrm.SubGrid.{!EntityLogicalName}.MainTab
      Tab displays the plural entity display name.

When you view the ribbon definitions for a specific entity, you will see that the name of the entity usually replaces the {!EntityLogicalName} token. When you see the {!EntityLogicalName} token in the ribbon definition for a specific entity, that means there is no specific definition for that entity and it simply uses the definition from the entity ribbon template. When you define ribbons for a specific entity, always use the actual entity name. Ribbon modifications for a specific entity must be defined in the //ImportExportXml/Entities/Entity/RibbonDiffXml node.

You can make changes that apply to all entities by defining the changes to the application ribbons substituting the token {!EntityLogicalName} in place of an entity logical name in your RibbonDiffXml node. Changes to application ribbons that are defined for all entities must be defined in the ImportExportXml/RibbonDiffXml node. They cannot be defined in the RibbonDiffXml node for a specific entity.

Grid ribbons

The entity grid ribbon is a collection of tabs that have an Id attribute value beginning with Mscrm.HomepageGrid.<entity logical name>. For example, the tab with the text "Accounts" on an account entity grid is Mscrm.HomepageGrid.account.MainTab. All the tabs displayed on the account entity grid will have an Id value that begins with Mscrm.HomepageGrid.account.

Subgrid ribbons

The entity subgrid ribbon is a contextual group with a collection of tabs that have an Id attribute value beginning with Mscrm.SubGrid.<entity logical name>. For example, the tab with the text "Accounts" on account entity sub grid is Mscrm.SubGrid.account.MainTab.

When a list of records for an entity is displayed within a sub grid on the form of another entity or in a chart, there will be only three controls available directly above or within the subgrid. The behaviors for these controls can be modified by changing the commands that they are associated with.

  • Add The default behavior of the command with the Add button icon depends on whether the records in the subgrid are related to the current record.
    If the records are related to the current record, the default behavior is look for existing records. If an existing record cannot be found, or if the user simply wants to create a new record, they can click Add New.
    If the records are not related to the current record, the default behavior is to add a new record. If the entity has a Quick Create form this will be displayed, otherwise a new full form will be shown.
    Activities are the exception to this pattern. The add command will always prompt for the type of activity first.
  • Show List The command with the Open view button icon will open the full list where all available commands can be used.
    If the subgrid is associated with the current record, the default behavior of this command is to open the associated view.
    If the subgrid is not associated with the current record, the default behavior of this command is to open the view in the main list view.
  • Delete The Sub-grid delete icon icon is shown on the right side of the row when people hover over the records in the list.
    For records with a 1:N relationship or no relationship, the default behavior is to delete the record. The delete may be blocked if it is not allowed due to relationship configurations. Open activities and invoices are common examples of records that may not be deleted due to relationship configurations.
    For relationships displaying N:N relationships the default behavior is to remove the relationship joining the records rather than the record itself.

You can change the default behavior by changing the actions associated with the command using <CommandDefinition> (RibbonDiffXml), but you cannot change the name of the command. For example, you could change the delete action so that it deactivates the record rather than deleting it.

It is not possible to change the icons displayed for these commands. You can hide these commands by using <HideCustomAction> (RibbonDiffXml).

Form ribbons

Each entity can have multiple forms. You can define changes to the form ribbon for all forms for that entity by adding your definition at the entity level (//ImportExportXml/Entities/Entity/RibbonDiffXml).

Each entity form can have a specific ribbon definition. In the exported customizations.xml file, you must add your modified <RibbonDiffXml> (FormXml) to this location://ImportExportXml/Entities/Entity/FormXml/forms/systemform/form/RibbonDiffXml.

The entity form ribbon is a collection of tabs that have an Id attribute value beginning with Mscrm.Form.<entity logical name>. For example, the tab with the label Account on account entity form is Mscrm.Form.account.MainTab. All the tabs displayed on the account entity form will have an Id value that begins with Mscrm.Form.account.

Basic home tab

The basic home tab is displayed on the main application ribbon whenever an alternative tab is not defined because of entity context or a display rule that suppresses it for specific pages. For example, this tab is displayed when you view the Microsoft Dynamics CRM Help. The Id of the basic home tab is Mscrm.BasicHomeTab.

Note
The Jewel that was shown in Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online is no longer displayed. Changes to the Jewel will not appear in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update

Microsoft Dynamics CRM for Microsoft Office Outlook ribbons

Microsoft Office Outlook 2007 do not display a ribbon. Microsoft Office Outlook 2010 uses the ribbon. You can use Microsoft Dynamics CRM ribbon definitions to add controls to all of them.

Microsoft Office Outlook 2007

The Microsoft Dynamics CRM for Microsoft Office Outlook controls to support older versions of Microsoft Office Outlook toolbars and menus are defined as tabs with the Id values of Mscrm.LegacyOfficeToolbar and Mscrm.LegacyOfficeMenubar, respectively.

Microsoft Office Outlook 2010

The Microsoft Dynamics CRM for Microsoft Office Outlook controls to support Microsoft Office Outlook 2010 toolbars and menus are defined as tabs with the Id values of Mscrm.Outlook14GlobalToolbar and Mscrm.Outlook14GlobalMenubar, respectively.

Other ribbons

Several other special purpose ribbon tabs and a contextual group are defined byMicrosoft Dynamics CRM. Each tab is associated with a specific <TabDisplayRule> (RibbonDiffXml) that controls when they will display. The following table lists these tabs.

Tab | Root Id | Description
Web Resource Edit page tab. | Mscrm.WebResourceEditTab | Displays when editing Web resources within a solution.
Form Editor tab | Mscrm.FormEditorTab | Provides Save, Edit, Select, and View groups of actions for entity forms.
Form Editor Insert tab | Mscrm.FormEditorInsertTab | Provides buttons to insert Sections, Tabs, and Controls in entity forms.
Dashboard Homepage tab | Mscrm.DashboardTab | Displays in the Workplace area.
Visualization Tools Contextual Group | Mscrm.VisualizationTools | Displays when the New Chart button is clicked on the Charts tab displayed in the entity grid ribbon.
AptbookTab Homepage tab | Mscrm.AptbookTab | Displays when viewing the Service Calendar in the Service area.
Advanced Find tab | Mscrm.AdvancedFind | Displays in the Advanced Find window.
Dashboard Editor tab | Mscrm.DashboardEditorTab | Displays when editing a dashboard.
Documents tab | Mscrm.DocumentsTab | Displays if SharePoint integration has been enabled for the organization.
Chart Editor tab | Mscrm.VisualizationDesignerTab | Displays when editing a chart from the solutions window.
Search Tools Contextual Group | Mscrm.ArticleSearch | Displays when viewing the KBarticle entity.

Ribbons for custom pages

You can display custom pages in the application navigation using the SiteMap. These pages will always display the Basic Home Tab (Mscrm.BasicHomeTab). It is not possible to use a <PageRule> (RibbonDiffXml) to enable or display custom ribbon components on custom pages.

See Also

Concepts

Command bar or ribbon presentation

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Command bar or ribbon presentation

Data defining commands in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update can be presented in several different ways depending on the client and differences in how some entities are treated. You need to take these factors into consideration as you change ribbon commands or define new ones.

In This Topic

Different presentations of commands

Command data

Filtering commands based on Presentation and Client

Different presentations of commands

There are three different ways that command data can be displayed.

Updated user experience

This is the presentation of the command bar throughout the application and for forms for entities that have the updated user experience.

Account command bar in CRM Online and CRM 2015

In this experience, only the first seven commands are displayed and any remaining commands are available in a flyout menu.

Enable rules will hide commands that should not be used.

Subgrids have a limited number of controls. Only controls to allow adding records, deleting records, or opening a view of the grid are available. But these commands are still defined by ribbon data and can be customized.

Contact sub-grid in Dynamics CRM

To perform more actions on the list of records displayed in a subgrid, you must choose the option to open a view of the grid.

For more information about the behavior of subgrid controls and how they can be customized, see Sub Grid Ribbons.

Classic user experience

This is the presentation using the ribbon. It is used for lists within the Outlook client and for the forms of entities that do not use the updated user experience.

Article ribbon in Dynamics CRM

In this experience tabs are available and groups can define scaling so that all available commands in a tab are shown as the width of the screen changes.

Enable rules can disable commands that should not be used so that they are still visible.

Subgrid commands are shown in a List Tools contextual tab at the top of the page when the subgrid is selected.

Article Comments sub-grid ribbon in CRM

CRM for tablets

Microsoft Dynamics CRM for tablets presents commands in a manner optimized for touch experiences. Commands appear in the command bar at the bottom right of the screen in order from right to left.

Account form commands for CRM for tablets
Note
Icons configured for commands will not display and labels that are too long will be truncated.

Subgrid commands are displayed when people tap and press the subgrid control. These commands are shown on the bottom left of the screen in order from left to right.

Activity sub-grid commands in CRM for tablets

Command data

Despite these very different presentations, the data that defines the commands for entities is consistent regardless of how the commands are presented. It contains definitions for tabs and groups with scaling, but the visible parts of these containers for controls are only displayed in the classic user interface.

In both the updated user experience and CRM for tablets, tabs and groups still act as containers for controls, but there is no visual indication of these containers and scaling is not applied.

Filtering commands based on presentation and client

Important
Including some kind of rule to filter the display of your commands is necessary unless you want the command to be available for all clients and presentations.

With this release there is a new element that can be used in display and enable rules to adapt the commands you display with the presentation.

<CommandClientTypeRule> (RibbonDiffXml) contains a Type attribute that will be evaluated based on the presentation. The following valid options correspond to the presentation:

  • Refresh: Updated user experience
  • Legacy: Classic user experience
  • Modern: CRM for tablets

Use this element as you define commands to control whether they display in the different presentations.

There is also a pre-existing <CrmClientTypeRule> (RibbonDiffXml) element, but the Type attribute for element can only differentiate between Web and Outlook clients. This rule will evaluate the CRM for tablets client as the web client.

See Also

Concepts

Ribbons available in Microsoft Dynamics CRM
Export ribbon definitions

Other Resources

Customize commands and the ribbon
Developers guide to customization for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Export ribbon definitions

To effectively define changes to the default RibbonXml, you must be able to reference the RibbonXml data that defines those ribbons.

Access the ribbon definitions for your organization

If the Ribbon for your organization has been modified, you should export the current definitions if you intend to work with the customized ribbon elements. To do this, use the exportribbonxml sample located at SampleCode\CS\Client\Ribbon\ExportRibbonXml.

Access the default ribbon data

The default ribbon definitions for Microsoft Dynamics CRM can be found in the SDK package: SDK\Resources\ExportedRibbonXml. Download the Microsoft Dynamics CRM SDK package.

The applicationRibbon.xml file contains the definition of the core application ribbons.

The remaining files contain the definitions used by entities that have ribbon definitions that differ from the entity template. Each file is named according to the name of the entity: logical entity name + Ribbon.xml.

These files represent the output of two messages using the Sample: Export ribbon definitions:

RetrieveApplicationRibbonRequest

This message retrieves the core application ribbons including the entity template.

RetrieveEntityRibbonRequest

This message retrieves the ribbon definition used for a specific entity.

Decompress the ribbon data

The ribbon data is exported as a compressed file. To decompress the file into XML you have to use the System.IO.Packaging.ZipPackage class. The following example is a helper method used in the SDK sample to decompress the file.

C# Copy Code
/// <summary>
/// A helper method that decompresses the the Ribbon data returned
/// </summary>
/// <param name="data">The compressed ribbon data</param>
/// <returns></returns>
public byte[] unzipRibbon(byte[] data)
{
 System.IO.Packaging.ZipPackage package = null;
 MemoryStream memStream = null;

 memStream = new MemoryStream();
 memStream.Write(data, 0, data.Length);
 package = (ZipPackage)ZipPackage.Open(memStream, FileMode.Open);

 ZipPackagePart part = (ZipPackagePart)package.GetPart(new Uri("/RibbonXml.xml", UriKind.Relative));
 using (Stream strm = part.GetStream())
 {
  long len = strm.Length;
  byte[] buff = new byte[len];
  strm.Read(buff, 0, (int)len);
  return buff;
 }
}

Retrieve the application ribbon data

The application ribbon can be retrieved using the RetrieveApplicationRibbonRequest as shown in the following sample.

C# Copy Code
//Retrieve the Appliation Ribbon
RetrieveApplicationRibbonRequest appribReq = new RetrieveApplicationRibbonRequest();
RetrieveApplicationRibbonResponse appribResp = (RetrieveApplicationRibbonResponse)_serviceProxy.Execute(appribReq);

System.String applicationRibbonPath = Path.GetFullPath(exportFolder + "\\applicationRibbon.xml");
File.WriteAllBytes(applicationRibbonPath, unzipRibbon(appribResp.CompressedApplicationRibbonXml));

Retrieve entity ribbons

To retrieve the ribbon definition for entities, you can just include the name of the entity as a parameter to the RetrieveEntityRibbonRequest.

To retrieve the ribbon definitions for all entities that support the ribbon you need a list of those system entities that have ribbon definitions that vary from the entity ribbon template. The following sample shows an array of all the system entities that have ribbon definitions.

C# Copy Code
  //This array contains all of the system entities that use the ribbon.
  public System.String[] entitiesWithRibbons = {"account",
"activitymimeattachment",
"activitypointer",
"appointment",
"bulkoperation",
"calendar",
"campaign",
"campaignactivity",
"campaignresponse",
"competitor",
"connection",
"contact",
"contract",
"contractdetail",
"convertrule",
"convertruleitem",
"customeraddress",
"discount",
"discounttype",
"email",
"emailserverprofile",
"entitlement",
"entitlementchannel",
"entitlementtemplate",
"entitlementtemplatechannel",
"fax",
"goal",
"goalrollupquery",
"importfile",
"incident",
"invoice",
"invoicedetail",
"kbarticle",
"kbarticlecomment",
"lead",
"letter",
"list",
"listmember",
"mailbox",
"metric",
"opportunity",
"opportunityproduct",
"partnerapplication",
"phonecall",
"postfollow",
"pricelevel",
"product",
"productpricelevel",
"queue",
"queueitem",
"quote",
"quotedetail",
"recurringappointmentmaster",
"report",
"rollupfield",
"routingrule",
"routingruleitem",
"salesliterature",
"salesliteratureitem",
"salesorder",
"salesorderdetail",
"service",
"serviceappointment",
"sharepointdocument",
"sharepointdocumentlocation",
"sharepointsite",
"site",
"sla",
"slaitem",
"socialactivity",
"socialprofile",
"systemuser",
"task",
"team",
"teamtemplate",
"territory",
"uom",
"uomschedule",
"userquery"};

The following sample shows how to retrieve the ribbon definitions for a set of entities.

C# Copy Code
//Retrieve system Entity Ribbons
RetrieveEntityRibbonRequest entRibReq = new RetrieveEntityRibbonRequest() { RibbonLocationFilter = RibbonLocationFilters.All };

foreach (System.String entityName in entitiesWithRibbons)
{
 entRibReq.EntityName = entityName;
 RetrieveEntityRibbonResponse entRibResp = (RetrieveEntityRibbonResponse)_serviceProxy.Execute(entRibReq);

 System.String entityRibbonPath = Path.GetFullPath(exportFolder + "\\" + entityName + "Ribbon.xml");
 File.WriteAllBytes(entityRibbonPath, unzipRibbon(entRibResp.CompressedEntityXml));
 //Write the path where the file has been saved.
 Console.WriteLine(entityRibbonPath);
}

Any custom entities also support ribbon customizations. To get a list of custom entities, use the RetrieveAllEntitiesRequest and retrieve the names of custom entities. The following sample shows how to retrieve ribbon definitions for all custom entities.

C# Copy Code
 //Check for custom entities
 RetrieveAllEntitiesRequest raer = new RetrieveAllEntitiesRequest() { EntityFilters = EntityFilters.Entity };

 RetrieveAllEntitiesResponse resp = (RetrieveAllEntitiesResponse)_serviceProxy.Execute(raer);

 foreach (EntityMetadata em in resp.EntityMetadata)
 {
  if (em.IsCustomEntity == true && em.IsIntersect == false)
  {
   entRibReq.EntityName = em.LogicalName;
   RetrieveEntityRibbonResponse entRibResp = (RetrieveEntityRibbonResponse)_serviceProxy.Execute(entRibReq);

   System.String entityRibbonPath = Path.GetFullPath(exportFolder + "\\" + em.LogicalName + "Ribbon.xml");
   File.WriteAllBytes(entityRibbonPath, unzipRibbon(entRibResp.CompressedEntityXml));
   //Write the path where the file has been saved.
   Console.WriteLine(entityRibbonPath);
  }
 }
}

See Also

Concepts

Command bar or ribbon presentation
Export, prepare to edit, and import the ribbon

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Export, prepare to edit, and import the ribbon

To edit the ribbon, you must perform the following steps:

  1. Export the ribbon
  2. Prepare to edit the XML
  3. Edit the <RibbonDiffXml> (RibbonDiffXml)
  4. Import the ribbon

Export the ribbon

You export the ribbon by including it in a solution and then exporting the solution. You can choose to export all the customizations, but that can represent a large amount of data. We recommend that you use an existing unmanaged solution or create a new solution.

Create a new solution

  1. On the nav bar, choose Microsoft Dynamics CRM > Settings.

  2. Go to Settings > Customizations. (How do I get there?)

  3. Go to Settings > Solutions. (How do I get there?)

  4. Click or tap New.

  5. Type a meaningful Display Name, Unique Name and enter a Publisher and type a Version number.

    Note
    You can usually use the default publisher for the organization.

  6. Click the Save icon.

  7. If you want to edit the ribbon for specific entities:

    1. Click Add Existing and then click Entity.
    2. Select the entities you want to include in the Solution and then click OK.
      Note
      For the purpose of editing entity ribbons, you do not have to include required components. If you intend to export this solution and apply it to another system, you should include required components.

  8. If you want to edit global ribbons or add a custom group to all entities, click Add Existing and then click Application Ribbons.

  9. Click Save and Close.

Use an existing solution

  1. On the nav bar, choose Microsoft Dynamics CRM > Settings.

  2. Go to Settings > Customizations. (How do I get there?)

  3. Go to Settings > Solutions. (How do I get there?)

  4. Double-click a solution to open it.

  5. If you want to edit the ribbon for specific entities:

    1. Click Add Existing and then click Entity.
    2. Select the entities you want to include in the Solution and then click OK.
      Note
      For the purpose of editing entity ribbons, you do not have to include required components. If you intend to export this solution and apply it to another system, you should include required components.

  6. If you want to edit global ribbons, such as to add custom button to all entities: click Add Existing and then click Application Ribbons.

  7. Click Save and Close.

Export the ribbon

  1. On the nav bar, choose Microsoft Dynamics CRM > Settings.

  2. Go to Settings > Customizations. (How do I get there?)

  3. Go to Settings > Solutions. (How do I get there?)

  4. Select the solution you want and then click Export.

  5. If you have made recent changes that have not yet been published, click Publish All Customizations. Otherwise, click Next.

  6. With the Unmanaged option selected, click Export.

  7. Click Save in the File Download dialog box and then click Open Folder in the Download complete dialog box.

  8. Right-click the compressed .zip file that you downloaded and select Extract All... .

  9. Select a location to extract the files and then click Extract.

  10. The customizations.xml file is the file that you will edit.

Prepare to edit the XML

For a better experience, edit the customizations.xml file with an application that can use schema validation to provide IntelliSense support. For more information, see Edit the customizations XML file with schema validation.

Import the ribbon

  1. After you have edited the customization.xml file, from Visual Studio or Microsoft Visual Web Developer 2010 Express, right-click the customization.xml tab and select Open Containing Folder.

  2. Select all of the files or folders that were included when you extracted the solution. Right-click the selected files, select Send To, and then select Compressed (zipped) folder.

    Note
    This creates a compressed .zip file in the same folder. The name of the file may vary, but it will be the same as one of the other files in the folder - except with a .zip file name extension.

  3. On the nav bar, choose Microsoft Dynamics CRM > Settings.

  4. Go to Settings > Customizations. (How do I get there?)

  5. Go to Settings > Solutions. (How do I get there?)

  6. Click Import.

  7. Click Browse and locate the compressed .zip file that you created in step 2 of this procedure.

  8. Click Next and then click Import.

  9. After the import has finished, you will see the message indicating that the import completed successfully. Click Close.

  10. After you have successfully imported your solution, you must publish customizations before you can see the changes. In the Solutions list, click Publish All Customizations.

Dealing with errors on import

  1. If you receive a notification that there were errors that caused the import to fail, click Export Log.

  2. Save the export log file. Select the file and right-click it. Choose Open With and then select Microsoft Office Excel.

  3. Select the Components worksheet and note any messages in the ErrorText column.

    Tip
    The most common type of failure is an error when referencing a dependent element in the RibbonDiffXml. Perhaps you forgot to include a LocLabel that was referenced somewhere. Perhaps there is an extra blank character included at the end of an XML attribute referencing another element. All references must match exactly.

  4. After you have corrected the error, complete the steps to import the Ribbon again.

See Also

Concepts

Export ribbon definitions
Use localized labels with ribbons

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use localized labels with ribbons

Although Ribbon elements that display text allow for direct entry of text, it is a best practice to use localized labels to define text displayed in the ribbon. This enables multi-language capabilities and better management of shared text.

Using localized labels

The <RibbonDiffXml> (RibbonDiffXml) element includes the <LocLabels> (RibbonDiffXml) element. As shown in the following example, this is where you can specify which text to display in the ribbon labels and tooltips using the <Titles> (RibbonDiffXml) element.

Xml Copy Code
<LocLabels>
 <LocLabel Id="MyISV.account.SendToOtherSystem.LabelText">
  <Titles>
   <Title languagecode="1033"
          description="Send to Other System" />
  </Titles>
 </LocLabel>
 <LocLabel Id="MyISV.account.SendToOtherSystem.ToolTip">
  <Titles>
   <Title languagecode="1033"
          description="Sends this Record to another system" />
  </Titles>
 </LocLabel>
</LocLabels>

Within the definition of a ribbon element that displays text, the following example show how the localized label can be referenced using the $LocLabels: directive.

Xml Copy Code
ToolTipTitle="$LocLabels:MyISV.account.SendToOtherSystem.LabelText"
ToolTipDescription="$LocLabels:MyISV.account.SendToOtherSystem.ToolTip"

Force a line break in a ribbon control label

If you have a ribbon control label that is very long, the text will wrap to fit the available space. You can specify where you want to include a line break by using the following characters: &#x200b;&#x200b;.

If the label text is very long without a space for the text to wrap, the width of the control expands to allow for the entire label to be displayed.

See Also

Concepts

Export, prepare to edit, and import the ribbon
Use localized labels with ribbons
Define ribbon commands

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Define ribbon commands

A Ribbon command creates a reusable definition that can be referenced by ribbon control elements.

Ribbon command elements

The <CommandDefinition> (RibbonDiffXml) element defines a command in the ribbon. The Id attribute specifies a unique identifier for the command that can be referenced by ribbon control elements by using the Command parameter.

A ribbon command defines three things:

  • Enable Rules: Specifies when a specific ribbon control is enabled.
  • Display Rules: Specifies when a specific ribbon element is visible.
  • Actions: Specifies what code executes when a ribbon control is used.

Security Note
All command definitions are downloaded to a user's computer so that they can be evaluated at run time. This means that a user without the privileges to see a particular control in the ribbon can use the browser View Source command, review the code, and determine that a control exists that isn’t displayed to them in Microsoft Dynamics CRM.

See Also

Concepts

Use localized labels with ribbons
Define ribbon enable rules

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Define ribbon enable rules

When configuring Ribbon elements you can define specific rules to control when the ribbon elements are enabled. The <EnableRule> (RibbonDiffXml) element is used as follows:

  • Use the /RuleDefinitions/EnableRules/EnableRule element to define rules controlling when the ribbon element should be enabled.
  • Use the /CommandDefinitions/CommandDefinition/EnableRules/EnableRule element to associate specific enable rules to a command definition.

What does enabled mean?

With the command bar, commands that are disabled are hidden. With the ribbon, commands that are disabled are visible but do not respond to events.

Control when ribbon elements are enabled

Enable rules are intended to be re-used. By defining them with rule definitions, you can use the same enable rule for many command definitions. When more than one enable rule is defined for a command definition, all of the enable rules must evaluate as true for the ribbon element to be enabled.

All Enable rules provide an optional attribute to specify whether the default value of the rule is true or false and an optional InvertResult attribute to allow for returning a negative result when the item being tested returns true.

The /RuleDefinitions/EnableRules/EnableRule element supports the following types of rules:

<CommandClientTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of presentation being used.

The Type values correspond to the following:

Value Presentation

Modern

The command bar is presented using Microsoft Dynamics CRM for tablets.

Refresh

The command bar is presented using the updated user interface.

Legacy

The ribbon is presented in forms for entities that were not updated or in a list view in Microsoft Dynamics CRM for Microsoft Office Outlook.

<CrmClientTypeRule> (RibbonDiffXml)

Allows definition of rules depending on the type of client used. Type options are as follows:

  • Web
  • Outlook
<CrmOfflineAccessStateRule> (RibbonDiffXml)

Use this criteria to enable a ribbon element based on whether Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is currently offline.

<CrmOutlookClientTypeRule> (RibbonDiffXml)

Use this rule if you want to only display a button for a specific type of Microsoft Dynamics CRM for Microsoft Office Outlook. Type options are as follows:

  • CrmForOutlook
  • CrmForOutlookOfflineAccess
<CustomRule> (RibbonDiffXml)

Use this kind of rule to call a function in a JavaScript Library that returns a Boolean value.

Note
Custom rules that do not return a value quickly can affect the performance of the ribbon. If you have to perform logic that might take some time to complete, use the following strategy to make your custom rule asynchronous:

  1. Define a rule that checks for a custom object. You might check for an object such as Window.ContosoCustomObject.RuleIsTrue that you just attach to the Window.
  2. If that object exists, return it.
  3. If that object does not exist, define the object and set the value as false.
  4. Before you return a value, use settimeout to execute an asynchronous callback function to re-set the object. Then return false.
  5. After the callback function has performed the operations that are required to determine the correct result, it sets the value of the object and uses the refreshRibbon method to refresh the ribbon.
  6. When the ribbon is refreshed, it detects the object together with the accurate value set and the rule is evaluated.

<EntityRule> (RibbonDiffXml)

Entity rules allow for evaluation of the current entity. This is useful when you define custom actions that apply to the Entity Template instead of for specific entities. For example, you may want to add a ribbon element to all entities except for several specific entities. It is easier to define the custom action for the Entity Template that applies to all entities and then use an Entity Rule to filter out those that should be excluded.

The entity rule also includes an optional Context attribute to specify whether the entity is being displayed in the Form or a list (HomePageGrid). The optional AppliesTo attribute can be set to PrimaryEntity or SelectedEntity to distinguish whether the entity is being displayed in a subgrid.

<FormStateRule> (RibbonDiffXml)

Use the FormState rule to determine the current type of form that is displaying a record. State options are as follows:

  • Create
  • Existing
  • ReadOnly
  • Disabled
  • BulkEdit
<OrRule> (RibbonDiffXml)

The OrRule lets you override the default AND comparison for multiple enable rule types. Use the OrRule element to define several possible valid combinations to check.

<OutlookItemTrackingRule> (RibbonDiffXml)

Use the TrackedInCrm attribute for this element to determine whether the record is being tracked in Microsoft Dynamics CRM.

<OutlookVersionRule> (RibbonDiffXml)

Use this to enable a ribbon element for a specific version of Microsoft Office Outlook as follows:

  • 2003
  • 2007
  • 2010
<PageRule> (RibbonDiffXml)

This type of rule checks the URL of the page being displayed. It returns true if the Address matches.

<RecordPrivilegeRule> (RibbonDiffXml)

Use this rule to determine whether the current user has privileges on a specific record. These privileges differ from an Entity privilege because they can include privileges gained by another user sharing the record with the current user.

<SelectionCountRule> (RibbonDiffXml)

Use this kind of rule with a ribbon displayed for a list to enable a button when specific maximum and minimum numbers of records in the grid are selected. For example, if your button merges records, you should make sure at least two records are selected before enabling the ribbon control.

<SkuRule> (RibbonDiffXml)

Use this kind of rule to enable a ribbon element for a specific SKU version of Microsoft Dynamics CRM as follows:

  • OnPremise
  • Online
  • Spla
<ValueRule> (RibbonDiffXml)

Use this rule to check the value of a specific field in the record being displayed in the form. You must specify the Field and the Value to check.

See Also

Concepts

Define ribbon commands
Define ribbon display rules

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Define ribbon display rules

When configuring ribbon elements, you can define specific rules to control when the ribbon elements will display.

  • Use the /RuleDefinitions/DisplayRules/<DisplayRule> (RibbonDiffXml) element to define rules controlling when the ribbon element should be displayed.
  • Use the /CommandDefinitions/CommandDefinition/DisplayRules/<DisplayRule> (RibbonDiffXml) element to associate specific display rules to a command definition.

Control when ribbon elements are displayed

By defining display rules in rule definitions, you can use the same display rule for many command definitions. When more than one display rule is defined for a command definition, all of the display rules must evaluate as true for the ribbon element to be displayed.

All display rules provide an optional attribute to specify whether the default value of the rule is true or false and an optional InvertResult attribute to enable returning a negative result when the item being tested returns true.

The /RuleDefinitions/DisplayRules/DisplayRule element supports the following types of rules:

<CommandClientTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of presentation being used.

The Type values correspond to the following:

Value Presentation

Modern

The command bar is presented using Microsoft Dynamics CRM for tablets.

Refresh

The command bar is presented using the updated user interface.

Legacy

The ribbon is presented in forms for entities that were not updated or in a list view in Microsoft Dynamics CRM for Microsoft Office Outlook.

<CrmClientTypeRule> (RibbonDiffXml)

Allows definition of rules depending on the type of client used. Type options are as follows:

  • Web
  • Outlook
<CrmOfflineAccessStateRule> (RibbonDiffXml)

Use this criteria to display a ribbon element based on whether Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is currently offline.

<CrmOutlookClientTypeRule> (RibbonDiffXml)

Use this rule if you want to display a button for the specific type of Microsoft Dynamics CRM for Microsoft Office Outlook. Type options are as follows:

  • CrmForOutlook
  • CrmForOutlookOfflineAccess
<CrmOutlookClientVersionRule> (RibbonDiffXml)

Detects the version of Microsoft Dynamics CRM for Microsoft Office Outlook.

Valid values:

  • 2003
  • 2007
  • 2010
<EntityPrivilegeRule> (RibbonDiffXml)

Use this kind of rule to display ribbon elements when a user has specific privileges for an entity. You must specify the privilege depth and the specific privilege you want to check.

<EntityPropertyRule> (RibbonDiffXml)

Allows definition of rules depending on the Boolean values of specific entity properties. PropertyName options are as follows:

  • DuplicateDetectionEnabled
  • GridFiltersEnabled
  • HasStateCode
  • IsConnectionsEnabled
  • MailMergeEnabled
  • WorksWithQueue
  • HasActivities
  • IsActivity
  • HasNotes
<EntityRule> (RibbonDiffXml)

Entity rules allow for evaluation of the current entity. This is useful when you define custom actions that apply to the entity template instead of for specific entities. For example, you may want to add a ribbon element to all entities except for some specific entities. It is easier to define the custom action for the entity template that applies to all entities and then use an entity rule to filter out those that should be excluded.

The entity rule also includes an optional context attribute to specify whether the entity is being displayed in the form or a list (HomePageGrid). The optional AppliesTo attribute can be set to PrimaryEntity or SelectedEntity to distinguish whether the entity is being displayed in a subgrid.

<FormEntityContextRule> (RibbonDiffXml)

Specifies a rule that can detect whether a form ribbon is displayed in the context of a specific entity.

<FormStateRule> (RibbonDiffXml)

Use the form state rule to determine the current type of form that is displaying a record. State options are as follows:

  • Create
  • Existing
  • ReadOnly
  • Disabled
  • BulkEdit
<FormTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of Microsoft Dynamics CRM form.

The Type values correspond to the following:

Value Presentation

Main

An entity form displayed in the application.

Preview

The entity preview form displayed as an expanding element in the grid.

AppointmentBook

Used with the appointment, equipment, serviceappointment, and systemuser entities for the Service Scheduling user interface.

Dashboard

The form defines a dashboard.

Quick

A quick view form.

QuickCreate

A quick create form.

<HideForTabletExperienceRule> (RibbonDiffXml)

Specifies a rule that will return false when the web application is viewed in a mobile browser on a tablet device.

<MiscellaneousPrivilegeRule> (RibbonDiffXml)

Use this kind of rule to check for privileges that do not apply to a specific entity, such as ExportToExcel, MailMerge, or GoOffline.

<OrganizationSettingRule> (RibbonDiffXml)

Use this to display a ribbon element if specific organization settings are enabled. Setting options are as follows:

  • IsSharepointEnabled
  • IsSOPIntegrationEnabled
  • IsFiscalCalendarDefined
<OrRule> (RibbonDiffXml)

This rule lets you override the default AND comparison for multiple display rule types. Use the OrRule element to define several possible valid combinations to check.

<OutlookRenderTypeRule> (RibbonDiffXml)

Use this to display a ribbon element if the ribbon is being displayed in Microsoft Outlook in a specific way. Type options are as follows:

  • Web
  • Outlook
<OutlookVersionRule> (RibbonDiffXml)

Use this to display a ribbon element for a specific version of Microsoft Outlook. Version options are as follows:

  • 2003
  • 2007
  • 2010
<PageRule> (RibbonDiffXml)

This type of rule checks the URL of the page being displayed. It returns true if the address matches.

<RelationshipTypeRule> (RibbonDiffXml)

This type of rule is applied to records selected in a grid. It lets you determine the type of relationship, as follows:

  • OneToMany
  • ManyToMany
  • NoRelationship
<SkuRule> (RibbonDiffXml)

Use this kind of rule to display a ribbon element for a specific SKU version of Microsoft Dynamics CRM, as follows:

  • OnPremise
  • Online
  • Spla
<ValueRule> (RibbonDiffXml)

Use this rule to check the value of a specific field in the record being displayed in the form.

Note
For commands defined for subgrid for forms using the updated user experience, value rules cannot be used within display rules. Use this element within an <EnableRule> (RibbonDiffXml) to hide an element.

See Also

Concepts

Define ribbon enable rules
Define ribbon actions

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Define ribbon actions

Define the actions to be performed by a command bar or ribbon control in a <CommandDefinition> (RibbonDiffXml) element together with rules that control whether the control is enabled or visible in the ribbon.

A Ribbon control can perform two types actions and may include multiple actions:

  • JavaScript Functions: A <JavaScriptFunction> (RibbonDiffXml) element references a function defined in a Script Web resource.
  • Open a URL: The ribbon opens a URL using the value from an Address attribute in the <Url> (RibbonDiffXml) element. Additional parameters can pass information about how what querystring parameters are passed and the mode in which the window opens.
    You have several options to pass parameters to a URL using the ribbon. More information: Pass parameters to a URL by using the ribbon

Passing parameters to ribbon actions

Use the following elements to define data to pass to your custom action:

<BoolParameter> (RibbonDiffXml)

Specifies a value with a Boolean data type that may be passed as a parameter.

<CrmParameter> (RibbonDiffXml)

Represents data retrieved from the Microsoft Dynamics CRM application that may be passed as a parameter. More information: Pass Microsoft Dynamics CRM data from a page as a parameter to Ribbon Actions

<DecimalParameter> (RibbonDiffXml)

Specifies a value with a decimal data type that may be passed as a parameter.

<IntParameter> (RibbonDiffXml)

Specifies a value with an integer data type that may be passed as a parameter.

<StringParameter> (RibbonDiffXml)

Specifies a value with a string data type that may be passed as a parameter.

When parameters are passed to a <Url> (RibbonDiffXml) element they are passed as a query string. Therefore, they must include a name value to represent the ”key” in the query string key/value pair.

Parameters passed to a <JavaScriptFunction> (RibbonDiffXml) do not require a name but they must be included in the order expected by the function and be of the correct data type.

See Also

Concepts

Define ribbon display rules
Pass Microsoft Dynamics CRM data from a page as a parameter to Ribbon Actions

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Pass Microsoft Dynamics CRM data from a page as a parameter to Ribbon Actions

When you define an action in a ribbon, you frequently have to pass data from the page to either a JavaScript function or a URL. This topic describes options for using the <CrmParameter> (RibbonDiffXml) element to retrieve these values.

Grid values

The majority of the values available for the <CrmParameter> (RibbonDiffXml) element are related to working with data displayed in a grid or hierarchy chart. By using the Value attribute enumeration options, you can easily isolate items by:

  • Selected items
    • SelectedControlSelectedItemCount
    • SelectedControlSelectedItemIds
    • SelectedControlSelectedItemReferences
  • All items
    • SelectedControlAllItemCount
    • SelectedControlAllItemIds
    • SelectedControlAllItemReferences
  • Unselected items
    • SelectedControlUnselectedItemCount
    • SelectedControlUnselectedItemIds
    • SelectedControlUnselectedItemReferences

For each of these groupings, you can gather the number of items and the GUID identifier. If you are passing the values to a URL, you can also retrieve EntityReference objects that contain all the information that you need to uniquely identify the objects in the grid. These parameters apply whether the page viewed is the main grid (HomepageGrid) or a sub grid located in a form. When used together with the SelectedEntityTypeName parameter, you have all the information that you must have to pass to another application.

Form values

With a form ribbon, you can use the Xrm.Page.data.entity.attributes collection and the Xrm.Page.ui.controls collection to retrieve values for known fields. However, if you want to pass the value of a selected form field, you’ll have to do more scripting to get the value.

You can use the PrimaryControlId parameter to get the Id value for the control that has focus when the ribbon control received focus. This Id is the Document Object Model (DOM) Id value. To get the data value, you will have to try using that value by using code such as that in the following example:

Copy Code
var focusFieldValue = Xrm.Page.ui.controls.get(PrimaryControlId).getAttribute().getValue()

Context information

In addition to data values, you can retrieve additional context information by using <CrmParameter> (RibbonDiffXml).

For convenience, the Value attribute options OrgName, OrgLcid, and UserLcid are available without requiring that you use Xrm.Page.context to use the getOrgUniqueName, getOrgLcid, and getUserId methods. For a <Url> (RibbonDiffXml) action, you can also use the PassParams attribute to include contextual information.

Value options PrimaryEntityTypeName and FirstPrimaryItemId provide information for an entity record. You can use PrimaryItemIds for a HomepageGrid ribbon to get a list of all the displayed items.

Finally, you can use the CommandProperties value to pass details about the event from the ribbon control. You can use this to send contextual information to a central function where specific actions can be determined based on the context of the event.

See Also

Reference

<CrmParameter> (RibbonDiffXml)
<JavaScriptFunction> (RibbonDiffXml)
<Url> (RibbonDiffXml)

Concepts

Pass parameters to a URL by using the ribbon
Define ribbon actions
Define custom actions to modify the ribbon

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Define custom actions to modify the ribbon

The default, an application command bar or ribbon is defined by Microsoft Dynamics CRM metadata. This default data can’t be changed, but you can include definitions of specific actions that will override the default ribbon.

Types of custom actions

There are two types of custom actions for ribbons:

  • <CustomAction> (RibbonDiffXml): Defines an action to add or replace items in the ribbon.
  • <HideCustomAction> (RibbonDiffXml) : Removes an existing ribbon element from being processed for the ribbon.

Custom actions

A custom action is a statement of how you want to change the default ribbon definition. It is evaluated and applied to the ribbon at runtime. To set the context for a custom action, you must include information about the location of the items that you want to change. Use the Location attribute to specify where your change applies.

When you add a new ribbon element, you refer to the containing element, for example, an existing tab or group. You then include the suffix ._children to indicate that this custom action will add something to an existing item.

When you change the definition of an existing item, the Location value will match the ID of that item.

You must also specify a unique identifier for the custom action. Use the Id attribute to set this value. We strongly recommend that you use a naming convention that will guarantee a unique value. For consistency and readability, we recommend that you use a period to separate consistent components. The first item in your naming convention should be something related to your solutions publisher or solution, for example, Contoso.contact.form.CustomButton.CustomAction.

Tip
Consistently applying your Id attribute naming conventions will greatly enhance your productivity while editing RibbonDiffXml.

Based on the location information that you provide, the Sequence attribute value determines the order in which to render items. If you want a custom control to appear between two existing controls, you must select a sequence value that is in between the sequence values of the existing items.

Hide custom actions

A <HideCustomAction> (RibbonDiffXml) is a statement that you use when you want to remove an existing ribbon element so that it is not rendered. This does not hide the ribbon element, it actually removes the ribbon element at runtime so that it doesn’t exist in the ribbon.

Note
Because the HideCustomAction element removes a specified node from the ribbon, removing ribbon elements in this manner may not be the best option for every situation.

  • If you want to remove a button that is associated with a specific privilege, you should adjust the privileges for the entity in the security roles in your implementation. This will allow the default ribbon display and enables rules to hide or disable ribbon elements from users who do not have the necessary privileges to perform those actions.
  • If you want to replace an existing ribbon element with a custom ribbon element, you can overwrite that element by specifying a CustomAction.Location value identical to the existing element.

The HideActionId element provides a unique ID for the action. For consistency and readability, you should follow the same naming convention described for <CustomAction> elements. The Location attribute must match the Id of the ribbon element you want to remove.

See Also

Concepts

Pass Microsoft Dynamics CRM data from a page as a parameter to Ribbon Actions
Define scaling for ribbon elements

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Define scaling for ribbon elements

For application ribbons and updated entity form ribbons there is no scaling. Scaling only applies to forms for entities that weren’t updated and list ribbons displayed using Microsoft Dynamics CRM 2015 for Microsoft Office Outlook.

The goal of the Ribbon is to maintain visibility of relevant controls even when the horizontal size of the window changes. To achieve this, the UI definition allows you to control how controls in a group change size in response to changes in the size of the window. This is known as scaling.

Associate groups and controls to layout templates

Each <Group> (RibbonDiffXml) element in the ribbon is associated with a <GroupTemplate> (RibbonDiffXml). The GroupTemplate specifies one or more ways the controls in the group can be presented using <Layout> (RibbonDiffXml) elements. Each Layout may contain one of two types of definition for how the controls in the group are displayed.

  • An <OverflowSection> (RibbonDiffXml) allows for controls to change relative position depending on the available space.
  • A <Section> (RibbonDiffXml) controls the number of rows to display and where each control is displayed.

Almost all the Layout elements used in ribbons use OverflowSection elements.

Each <Tab> (RibbonDiffXml) element must contain one <MaxSize> (RibbonDiffXml) in the <Scaling> (RibbonDiffXml). The MaxSize element is required because it establishes the default presentation of each Group in a Tab without any scaling applied. Scaling occurs when a Tab is associated with one or more <Scale> (RibbonDiffXml). Each MaxSize and Scale element is associated via the Size attribute with one of the Layout elements in the GroupTemplate used by each Group within a Tab.

Note
The value of the Size attribute of any MaxSize or Scale element must match the Title of the available Layout elements specified in the GroupTemplate. These values are strings and there is no validation in the XSD to help you select values that are a match. The XML is always case-sensitive.

The following diagram shows how MaxSize, Scale, Group, Layout and OverflowSection elements must reference each other to enable scaling when you are using a <OverflowSection> (RibbonDiffXml) element.

Element relationships with OverflowSection

The following diagram shows how MaxSize, Scale, Group, Layout and ControlRef elements must reference each other to enable scaling when you are using a <Section> (RibbonDiffXml) element.

Element Relationships with Section

Use existing group templates

When creating a new group, instead of defining new group templates, you can re-use existing GroupTemplate elements.

Associate your new group to that template. For each control in the group, use a TemplateAlias value from one of the <Section> (RibbonDiffXml) or <OverflowSection> (RibbonDiffXml) elements found in one of the Layout elements used by that GroupTemplate. Each <OverflowSection> (RibbonDiffXml) includes an isvTemplateAlias that is not used by Microsoft Dynamics CRM. This TemplateAlias is provided to allow ISVs to add controls to that group.

Control how scaling is applied

Each Scale element in the Scaling element for a particular tab represents one scale step. Each Scale is applied sequentially by the order in which the Scale element appears. When reducing the horizontal space available for the ribbon, each scale element is applied in order from top down. When increasing the horizontal space available, from the smallest space the bottom scale element is in effect. Each of the available Scale elements are applied in order from the bottom to the top until all the MaxSize elements are in effect.

Note
The Scale element Sequence attribute values aren’t used to determine the order in which scaling is applied. Scaling is applied by the relative order the MaxSize and Scale elements appear in the RibbonDiffXML. The Sequence value is important for both MaxSize and Scale elements because all the MaxSize elements must be grouped together above the Scale elements. When you add new MaxSize or Scale elements, be sure that you review the Sequence default value ranges assigned to all the MaxSize elements and the Scale elements. A common error is to assign Sequence values that could cause the ranges to overlap.

See Also

Concepts

Define custom actions to modify the ribbon
Define ribbon tab display rules

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Define ribbon tab display rules

Tab display rules control whether a specific tab is displayed for a ribbon or not.

Unlike other ribbon elements like groups or specific controls, you must explicitly provide a tab display rule for a tab to be displayed in the ribbon. By default, other ribbon elements will always display unless a display rule removes them.

<TabDisplayRule> (RibbonDiffXml) elements require that the TabCommand attribute matches a <Tab> (RibbonDiffXml) Command attribute value.

In the RibbonDiffXml, tabs can be defined for specific entities or defined globally. If the tab is defined for an entity, the only valid type of rule is <EntityRule> (RibbonDiffXml). Because defining a tab in the scope of a particular entity already limits the tab to only that entity, the only valid attributes are AppliesTo (PrimaryEntity or SelectedEntity) and Context (Form, HomePageGrid, SubGridStandard, or SubGridAssociated).

When you define a tab display rule globally in the RibbonDiffXml for the application ribbons, you can apply both EntityRule elements and <PageRule> (RibbonDiffXml) elements.

See Also

Concepts

Define scaling for ribbon elements
Pass parameters to a URL by using the ribbon

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Pass parameters to a URL by using the ribbon

Ribbon actions are defined in the <Actions> (RibbonDiffXml) element of a <CommandDefinition> (RibbonDiffXml) element. There are several ways to pass contextual Microsoft Dynamics CRM information as query string parameters to a URL by using the ribbon.

  • Use a <Url> (RibbonDiffXml) element. Within the Url element, use the PassParams attribute.
  • Use a <Url> (RibbonDiffXml) element together with a <CrmParameter> (RibbonDiffXml) element. When used from a Url element, the name attribute value must be set.
  • Use a <JavaScriptFunction> (RibbonDiffXml) element together with a <CrmParameter> (RibbonDiffXml) element.

Use the PassParams attribute to set dynamic values

Passing parameters to the target URL by using the PassParams attribute provides information to the target application about the context of the record or the user. All the parameters are passed if the ribbon control is configured by using the PassParams attribute. The following table lists the parameters that are passed.

Parameter Name Description

typename

Entity Name

Name of the entity. For custom entities, this includes the customization prefix, for example, new_entityname.

type

Entity Type Code

Integer that uniquely identifies the entity in the current organization.

Note
Entity Type Code values are determined by the order in which an entity is created in an organization. Entity Type Codes for custom entities are usually different in different organizations.

id

Object GUID

Globally unique identifier (GUID) that represents a record.

orgname

Organization Name

Unique name of the organization.

userlcid

User Language Code

Language code identifier that is used by the current user.

orglcid

Organization Language Code

Language code identifier that represents the base language for the organization.

Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart).

Note
We recommend that you use the entity name instead of the entity type code because the entity type code may be different between Microsoft Dynamics CRM installations.

Example

The following sample shows shows the URL without parameters:

Copy Code
http://myserver/mypage.aspx

The following sample shows shows the parameters included when the ribbon control is presented for the account entity, for an organization called ‘AdventureWorksCycle’, when the user’s language and the organization base language is English, and the GUID for the account record is DBD5DBFB-0666-DC11-A5D9-0003FF9CE217:

Copy Code
http://myserver/mypage.aspx?orgname=AdventureWorksCycle&userlcid=1033&orglcid=1033&type=1&typename=account&id=%7BDBD5DBFB-0666-DC11-A5D9-0003FF9CE217%7D

Use a Querystring parameter in the URL

You can include a querystring parameter in the URL attribute. This can be very useful if you want to open a specific Microsoft Dynamics CRM record or view by using Open forms, views, dialogs and reports with a URL.

Note
You will not be able to import the ribbon if the URL includes the ampersand (&) character that is used to separate multiple querystring parameters in the URL. This character makes the XML invalid. You must escape the ampersand character in the URL attribute value with "&amp;".

Reading passed parameters

Passed parameters are usually read in the target .aspx page by using the HttpRequest.QueryString property. More information: http://msdn2.microsoft.com/en-us/library/system.web.httprequest.querystring.aspx

Note
If the target of your URL is a Web resource, it can accept only the parameters identified in the topic Passing Parameters to HTMLWeb Resources. The only opportunity to pass custom values is by including them within the data parameter. Some special handling is required to include multiple values in a single parameter. More information: Sample: Pass multiple values to a web resource through the data parameter

See Also

Reference

<Url> (RibbonDiffXml)

Concepts

Open forms, views, dialogs and reports with a URL
Define ribbon tab display rules

Other Resources

Customize commands and the ribbon
Sample: Export ribbon definitions

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Export ribbon definitions
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Client\Ribbon\ExportRibbonXml\ExportRibbonXml.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to export Ribbon definitions. It uses the RetrieveApplicationRibbonRequest and RetrieveEntityRibbonRequest messages.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;

using Microsoft.Crm.Sdk.Messages;

//These references are required for this sample
using System.IO;
using System.IO.Packaging;

namespace Microsoft.Crm.Sdk.Samples
{
 /// <summary>
 /// Demonstrates how to export the RibbonXml definitions.</summary>
 /// <remarks>
 /// The generated XML files will be created in the ExportedRibbonXml folder of this project.</remarks>
 public class ExportRibbonXml
 {
  #region Class Level Members

  private OrganizationServiceProxy _serviceProxy;
  //This array contains all of the system entities that use the ribbon.
  public System.String[] entitiesWithRibbons = {"account",
"activitymimeattachment",
"activitypointer",
"appointment",
"bulkoperation",
"calendar",
"campaign",
"campaignactivity",
"campaignresponse",
"competitor",
"connection",
"contact",
"contract",
"contractdetail",
"convertrule",
"convertruleitem",
"customeraddress",
"discount",
"discounttype",
"email",
"emailserverprofile",
"entitlement",
"entitlementchannel",
"entitlementtemplate",
"entitlementtemplatechannel",
"fax",
"goal",
"goalrollupquery",
"importfile",
"incident",
"invoice",
"invoicedetail",
"kbarticle",
"kbarticlecomment",
"lead",
"letter",
"list",
"listmember",
"mailbox",
"metric",
"opportunity",
"opportunityproduct",
"partnerapplication",
"phonecall",
"postfollow",
"pricelevel",
"product",
"productpricelevel",
"queue",
"queueitem",
"quote",
"quotedetail",
"recurringappointmentmaster",
"report",
"rollupfield",
"routingrule",
"routingruleitem",
"salesliterature",
"salesliteratureitem",
"salesorder",
"salesorderdetail",
"service",
"serviceappointment",
"sharepointdocument",
"sharepointdocumentlocation",
"sharepointsite",
"site",
"sla",
"slaitem",
"socialactivity",
"socialprofile",
"systemuser",
"task",
"team",
"teamtemplate",
"territory",
"uom",
"uomschedule",
"userquery"};
  //Folder name for exported ribbon xml files.
  public String exportFolder = "ExportedRibbonXml";

  #endregion Class Level Members

  #region How To Sample Code
  /// <summary>
  /// This method first connects to the Organization service. Afterwards,
  /// basic create, retrieve, update, and delete entity operations are performed.
  /// </summary>
  /// <param name="serverConfig">Contains server connection information.</param>
  /// <param name="promptforDelete">When True, the user will be prompted to delete all
  /// created entities.</param>
  public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
  {
   try
   {
    // Connect to the Organization service.
    // The using statement assures that the service proxy will be properly disposed.
    using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
    {
     // This statement is required to enable early-bound type support.
     _serviceProxy.EnableProxyTypes();

     //Create export folder for ribbon xml files if not already exist.
     if (!Directory.Exists(exportFolder))
         Directory.CreateDirectory(exportFolder);

     //Retrieve the Appliation Ribbon
     RetrieveApplicationRibbonRequest appribReq = new RetrieveApplicationRibbonRequest();
     RetrieveApplicationRibbonResponse appribResp = (RetrieveApplicationRibbonResponse)_serviceProxy.Execute(appribReq);

     System.String applicationRibbonPath = Path.GetFullPath(exportFolder + "\\applicationRibbon.xml");
     File.WriteAllBytes(applicationRibbonPath, unzipRibbon(appribResp.CompressedApplicationRibbonXml));
     //Write the path where the file has been saved.
     Console.WriteLine(applicationRibbonPath);
     //Retrieve system Entity Ribbons
     RetrieveEntityRibbonRequest entRibReq = new RetrieveEntityRibbonRequest() { RibbonLocationFilter = RibbonLocationFilters.All };

     foreach (System.String entityName in entitiesWithRibbons)
     {
      entRibReq.EntityName = entityName;
      RetrieveEntityRibbonResponse entRibResp = (RetrieveEntityRibbonResponse)_serviceProxy.Execute(entRibReq);

      System.String entityRibbonPath = Path.GetFullPath(exportFolder + "\\" + entityName + "Ribbon.xml");
      File.WriteAllBytes(entityRibbonPath, unzipRibbon(entRibResp.CompressedEntityXml));
      //Write the path where the file has been saved.
      Console.WriteLine(entityRibbonPath);
     }

     //Check for custom entities
     RetrieveAllEntitiesRequest raer = new RetrieveAllEntitiesRequest() { EntityFilters = EntityFilters.Entity };

     RetrieveAllEntitiesResponse resp = (RetrieveAllEntitiesResponse)_serviceProxy.Execute(raer);

     foreach (EntityMetadata em in resp.EntityMetadata)
     {
      if (em.IsCustomEntity == true && em.IsIntersect == false)
      {
       entRibReq.EntityName = em.LogicalName;
       RetrieveEntityRibbonResponse entRibResp = (RetrieveEntityRibbonResponse)_serviceProxy.Execute(entRibReq);

       System.String entityRibbonPath = Path.GetFullPath(exportFolder + "\\" + em.LogicalName + "Ribbon.xml");
       File.WriteAllBytes(entityRibbonPath, unzipRibbon(entRibResp.CompressedEntityXml));
       //Write the path where the file has been saved.
       Console.WriteLine(entityRibbonPath);
      }
     }
    }
   }

   // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
   {
    // You can handle an exception here or pass it back to the calling method.
    throw;
   }
  }

  /// <summary>
  /// A helper method that decompresses the the Ribbon data returned
  /// </summary>
  /// <param name="data">The compressed ribbon data</param>
  /// <returns></returns>
  public byte[] unzipRibbon(byte[] data)
  {
   System.IO.Packaging.ZipPackage package = null;
   MemoryStream memStream = null;

   memStream = new MemoryStream();
   memStream.Write(data, 0, data.Length);
   package = (ZipPackage)ZipPackage.Open(memStream, FileMode.Open);

   ZipPackagePart part = (ZipPackagePart)package.GetPart(new Uri("/RibbonXml.xml", UriKind.Relative));
   using (Stream strm = part.GetStream())
   {
    long len = strm.Length;
    byte[] buff = new byte[len];
    strm.Read(buff, 0, (int)len);
    return buff;
   }
  }

  #endregion How To Sample Code

  #region Main method

  /// <summary>
  /// Standard Main() method used by most SDK samples.
  /// </summary>
  /// <param name="args"></param>
  static public void Main(string[] args)
  {
   try
   {
    // Obtain the target organization's Web address and client logon
    // credentials from the user.
    ServerConnection serverConnect = new ServerConnection();
    ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

    ExportRibbonXml app = new ExportRibbonXml();
    app.Run(config, true);
   }
   catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
    Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
    Console.WriteLine("Message: {0}", ex.Detail.Message);
    Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
   }
   catch (System.TimeoutException ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine("Message: {0}", ex.Message);
    Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
    Console.WriteLine("Inner Fault: {0}",
        null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
   }
   catch (System.Exception ex)
   {
    Console.WriteLine("The application terminated with an error.");
    Console.WriteLine(ex.Message);

    // Display the details of the inner exception.
    if (ex.InnerException != null)
    {
     Console.WriteLine(ex.InnerException.Message);

     FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
         as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
     if (fe != null)
     {
      Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
      Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
      Console.WriteLine("Message: {0}", fe.Detail.Message);
      Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
      Console.WriteLine("Inner Fault: {0}",
          null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
     }
    }
   }
   // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
   // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

   finally
   {
    Console.WriteLine("Press <Enter> to exit.");
    Console.ReadLine();
   }
  }
  #endregion Main method
 }
}

See Also

Concepts

Pass parameters to a URL by using the ribbon

Other Resources

Customize commands and the ribbon
Ribbon XML reference
RetrieveApplicationRibbonRequest
RetrieveEntityRibbonRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Ribbon XML reference

Use RibbonDiffXml to create declarative definitions of modifications to the default Microsoft Dynamics CRM ribbon.

In This Section

This list provides links to schema information about all the RibbonDiffXml elements.

Reference

<Actions> (RibbonDiffXml)

Specifies the actions that a command will perform.

<BoolParameter> (RibbonDiffXml)

Specifies a value with a Boolean data type that may be passed as a parameter.

<Button> (RibbonDiffXml)

Specifies a simple button used to perform an action.

<CheckBox> (RibbonDiffXml)

Specifies a check box used to select an option.

<Color> (RibbonDiffXml)

Specifies a color within a collection of colors for a color picker control.

<ColorPicker> (RibbonDiffXml)

Deprecated: Specified a grid used to select a color or style.

<Colors> (RibbonDiffXml)

Specifies a collection of colors for a color picker control.

<ComboBox> (RibbonDiffXml)

Deprecated: Specified a list used to select a value by clicking or typing.

<CommandClientTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of presentation being used.

<CommandDefinition> (RibbonDiffXml)

Specifies a set of rules that control how a ribbon element is displayed and actions to perform that can be referenced by ribbon elements and controls.

<CommandDefinitions> (RibbonDiffXml)

Contains a collection of commands that can be referenced by ribbon controls.

<CommandUIDefinition> (RibbonDiffXml)

Specifies the visible Ribbon elements to be included within a CustomAction element.

<ContextualGroup> (RibbonDiffXml)

Contains a collection of tabs to be displayed within a specific context.

<ControlRef> (RibbonDiffXml)

Specifies a placeholder for a control within a layout template.

<Controls> (RibbonDiffXml)

Contains a collection of controls.

<CrmClientTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of Microsoft Dynamics CRM client.

<CrmOutlookClientVersionRule> (RibbonDiffXml)

Detects the version of Microsoft Dynamics CRM for Microsoft Office Outlook.

<CrmOfflineAccessStateRule> (RibbonDiffXml)

Specifies a rule that can be used to detect whether Microsoft Dynamics CRM for Outlook with Offline Access is currently operating offline.

<CrmOutlookClientTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of Microsoft Dynamics CRM for Microsoft Office Outlook client.

<CrmParameter> (RibbonDiffXml)

Represents data retrieved from the Microsoft Dynamics CRM application that may be passed as a parameter.

<CustomAction> (RibbonDiffXml)

Defines an action to add or replace items in the ribbon.

<CustomActions> (RibbonDiffXml)

Contains a collection of actions that can add, replace, or remove items from the ribbon.

<CustomRule> (RibbonDiffXml)

Specifies a rule used with an EnableRule definition that is composed of a reference to a function within a JavaScript library.

<DecimalParameter> (RibbonDiffXml)

Specifies a value with a decimal data type that may be passed as a parameter.

<DisplayRule> (RibbonDiffXml)

Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.

<DisplayRules> (RibbonDiffXml)

Contains a collection of display rules.

<DropDown> (RibbonDiffXml)

Deprecated: Specified a list used to select a value by clicking.

<EnableRule> (RibbonDiffXml)

Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.

<EnableRules> (RibbonDiffXml)

Contains a collection of enable rules.

<EntityPrivilegeRule> (RibbonDiffXml)

Specifies a rule that can detect the current user's permissions for a specific entity.

<EntityPropertyRule> (RibbonDiffXml)

Specifies a rule that can detect specific Boolean entity properties.

<EntityRule> (RibbonDiffXml)

Specifies a rule that can detect whether a specific entity is in context.

<FlyoutAnchor> (RibbonDiffXml)

Specifies a button with a down arrow used to open a menu.

<FormEntityContextRule> (RibbonDiffXml)

Specifies a rule that can detect whether a form ribbon is displayed in the context of a specific entity.

<FormStateRule> (RibbonDiffXml)

Specifies a rule that can detect the state of the form.

<FormTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of Microsoft Dynamics CRM form.

<Gallery> (RibbonDiffXml)

Deprecated: Specified a control that displays a collection of related controls in the Ribbon. If there are too many items in the gallery, an expand arrow is provided to display the rest of the collection in a pane.

<GalleryButton> (RibbonDiffXml)

Deprecated: Specified a button control within a gallery element.

<Group> (RibbonDiffXml)

Specifies a group of controls within a tab that share a common layout template.

<Groups> (RibbonDiffXml)

Contains a collection of Group elements.

<GroupTemplate> (RibbonDiffXml)

Specifies a collection of layout definitions that a group can use when the ribbon width changes.

<HideCustomAction> (RibbonDiffXml)

Removes an existing ribbon element from being processed for the ribbon.

<HideForTabletExperienceRule> (RibbonDiffXml)

Specifies a rule that will return false when the web application is viewed in a mobile browser on a tablet device.

<InsertTable> (RibbonDiffXml)

Deprecated: Specified a 10 by 10 grid used to specify the dimensions of a table.

<IntParameter> (RibbonDiffXml)

Specifies a value with an integer data type that may be passed as a parameter.

<JavaScriptFunction> (RibbonDiffXml)

Specifies an action that calls a function from a specific JavaScript library.

<Label> (RibbonDiffXml)

Specifies a line of text used to provide information.

<Layout> (RibbonDiffXml)

Specifies a layout for a Group within a GroupTemplate.

<LocLabel> (RibbonDiffXml)

Specifies a text string associated with a language code.

<LocLabels> (RibbonDiffXml)

Contains a collection of LocLabel elements.

<LowScaleWarning> (RibbonDiffXml)

For internal use only.

<MaxSize> (RibbonDiffXml)

Defines the largest layout possible for a group.

<Menu> (RibbonDiffXml)

Specifies a container used to show pop-up menus.

<MenuSection> (RibbonDiffXml)

Specifies a section used to divide a menu. A menu section can have a title and contain controls.

<MiscellaneousPrivilegeRule> (RibbonDiffXml)

Specifies a rule that can detect whether the user possesses a specific Microsoft Dynamics CRM privilege.

<MRUSplitButton> (RibbonDiffXml)

Deprecated: Specified a split button control that displays Most Recently Used items.

<Or> (RibbonDiffXml)

Specifies a set of rules that must be evaluated together.

<OrganizationSettingRule> (RibbonDiffXml)

A rule that can detect two specific organization settings within a DisplayRule.

<OrRule> (RibbonDiffXml)

A rule that contains a collection of rules so that this rule will evaluate as true if any of the rules in the collection evaluates as true.

<OutlookCommand> (RibbonDiffXml)

For internal use only.

<OutlookItemTrackingRule> (RibbonDiffXml)

A rule that detects whether the item is enabled for items tracked in Microsoft Dynamics CRM in order to enable a ribbon element.

<OutlookRenderTypeRule> (RibbonDiffXml)

A rule that can detect whether a form or list item is rendered as a web page or natively in Outlook in order to determine if a ribbon element should be displayed.

<OutlookVersionRule> (RibbonDiffXml)

A rule that detects the version of Microsoft Office Outlook client.

<OverflowArea> (RibbonDiffXml)

Defines an area where multiple controls can render as a list.

<OverflowSection> (RibbonDiffXml)

Specifies a division of a Layout which allows controls to change relative position depending on the available space.

<PageRule> (RibbonDiffXml)

A rule that evaluates the address of the current page.

<RecordPrivilegeRule> (RibbonDiffXml)

A rule that detects a user’s privileges for a specific record in order to enable a ribbon element.

<ReferencingAttributeRequiredRule> (RibbonDiffXml)

A rule that detects whether the referencing attribute for an entity is required.

<RelationshipTypeRule> (RibbonDiffXml)

A rule that detects whether a specific type of formal entity relationship exists between two entities.

<RibbonDiffXml> (RibbonDiffXml)

The root element for all the elements that define custom ribbons.

<RibbonNotSupported> (RibbonDiffXml)

An element included with the RibbbonDiffXml for an entity to indicate that the entity does not support the ribbon.

<RibbonTemplates> (RibbonDiffXml)

Contains a collection of group templates.

<Row> (RibbonDiffXml)

Specifies a row within a Section.

<RuleDefinitions> (RibbonDiffXml)

Contains a collection of rule definitions.

<Scale> (RibbonDiffXml)

Specifies one of the possible layouts that may be used by a group when the maximum size layout cannot be displayed.

<Scaling> (RibbonDiffXml)

Contains a collection of elements used to define how ribbon groups are presented when the horizontal space available changes.

<Section> (RibbonDiffXml)

Contains a collection of rows.

<SelectionCountRule> (RibbonDiffXml)

A rule that detects how many items in a grid are selected.

<SkuRule> (RibbonDiffXml)

A rule that detects the Microsoft Dynamics CRM edition.

<Spinner> (RibbonDiffXml)

Specifies a control used to insert a value by typing or using the arrow keys to cycle through the values.

<SplitButton> (RibbonDiffXml)

Specifies a control used as both a button and a menu.

<StringParameter> (RibbonDiffXml)

Specifies a value with a string data type that may be passed as a parameter.

<Strip> (RibbonDiffXml)

Contains a collection of control references.

<Tab> (RibbonDiffXml)

Specifies a tab in the ribbon.

<TabDisplayRule> (RibbonDiffXml)

Specifies conditions when a tab will display.

<TabDisplayRules> (RibbonDiffXml)

Contains a collection of TabDisplayRule elements.

<Templates> (RibbonDiffXml)

Contains a collection of ribbon templates.

<TextBox> (RibbonDiffXml)

Deprecated: Specified a control used to enter text.

<Title> (RibbonDiffXml)

Specifies title text for a specific language.

<Titles> (RibbonDiffXml)

Contains a collection of title elements.

<ToggleButton> (RibbonDiffXml)

Specifies a button used to toggle between an on and off state.

<Unit> (RibbonDiffXml)

Specifies a unit in a spinner control.

<UnitAbbreviation> (RibbonDiffXml)

Specifies an abbreviation for a unit.

<Url> (RibbonDiffXml)

An action that opens a web page at a specified address.

<ValueRule> (RibbonDiffXml)

A rule that detects the value of a specific field.

See Also

Reference

Ribbon core schema

Other Resources

Customize commands and the ribbon
Sample: Export ribbon definitions
Customization XML reference
Server Ribbon in SharePoint Foundation

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Actions> (RibbonDiffXml)

Specifies the actions that a command will perform.

Syntax

Xml
<Actions>
 [<JavaScriptFunction /> | <Url /> ]
</Actions>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<JavaScriptFunction> (RibbonDiffXml) | Specifies an action that calls a function from a specific JavaScript library.
<Url> (RibbonDiffXml) | An action that opens a web page at a specified address.

Parent Elements

Element | Description
<CommandDefinition> (RibbonDiffXml) | Specifies a set of rules that control how a ribbon element is displayed and actions to perform that can be referenced by ribbon elements and controls.

Example

This Actions element contains a <Url> (RibbonDiffXml) action that opens a Web resource into a window of a specified size while passing contextual parameters.

Xml Copy Code
<Actions> <Url Address="$webresource:New_ShowParams.htm"      PassParams="true"      WinParams="height=200, width=400,toolbar=no, menubar=no,location=no" /></Actions>

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions

Schema Name

ActionsType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<BoolParameter> (RibbonDiffXml)

Specifies a value with a Boolean data type that may be passed as a parameter.

Syntax

Xml
<BoolParameter
 Name="string"
 Value=["0" | "1" | "true" | "false"]
</ BoolParameter >

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Value

Specifies the value to be passed as a parameter.

Boolean

Required

Name

Represents the name of a query string parameter passed for this value when using a Url element.

The name of the Boolean value to pass when BoolParameter is used as a child of <Url> (RibbonDiffXml).

String

Required

Note
This parameter is only available when BooleanParameter is a child of <Url> (RibbonDiffXml).

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<JavaScriptFunction> (RibbonDiffXml) | Specifies an action that calls a function from a specific JavaScript library.
<CustomRule> (RibbonDiffXml) | Specifies a rule used with an EnableRule definition that is composed of a reference to a function within a JavaScript library.
<Url> (RibbonDiffXml) | An action that opens a web page at a specified address.

Example

This <Url> (RibbonDiffXml) action passes the Boolean value of ”false” with the name ”test” to a Web resource.

Xml Copy Code
<Actions> <Url Address="$webresource:New_ShowParams.htm">  <BoolParameter Name="test"                 Value="false"/> </Url></Actions>

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/JavaScriptFunction/BoolParameter |
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/Url/BoolParameter |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CustomRule/BoolParameter |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CustomRule/BoolParameter |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/CustomRule/BoolParameter |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/CustomRule/BoolParameter

Schema Name

BoolParameterType or BoolNamedParameterType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Button> (RibbonDiffXml)

Specifies a simple button used to perform an action.

Syntax

<Button Alt="String"
  Command="String"
  CommandType=["General" | "OptionSelection" | "IgnoredByMenu" ]
  CommandValueId="String"
  Description="String"
  Id="String"
  Image16by16="String"
  Image16by16Class="String"
  Image16by16Left="Non Positive Integer"
  Image16by16Top="Non Positive Integer"
  Image32by32="String"
  Image32by32Class="String"
  Image32by32Left="String"
  Image32by32Top="String"
  LabelCss="String"
  LabelText="String"
  MenuItemId="String"
  ModernCommandType=[ "ControlCommand"| "System"]
  ModernImage=”String”
  Sequence="1"
  TemplateAlias="String"
  ToolTipDescription="String"
  ToolTipHelpKeyWord="String"
  ToolTipImage32by32="String"
  ToolTipImage32by32Class="String"
  ToolTipImage32by32Left="Non Positive Integer"
  ToolTipImage32by32Top="Non Positive Integer"
  ToolTipShortcutKey="String"
  ToolTipTitle="String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alt

String or reference to a localized label to display as alternative text.

String

Optional

Command

Specifies the ID of the ribbon command for this control.

The command to perform when this button is pressed.

A reference to an existing CommandDefinition.Id value.

String

Optional

CommandType

Allows for specifying a different type of command.

Valid values:

Value | Description
General | Not a specific type of command.
OptionSelection | A command that is generated when a user selects one option in an option group.
IgnoredByMenu | A command that is used for controls that should not close the menu when clicked.

Enumeration

Optional

CommandValueId

A string that is sent with the command event when the button is clicked.

String

Optional

Description

The Description attribute is not used by Microsoft Dynamics CRM.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Image16by16

Specifies a 16 by 16 pixel image. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image16by16Class

Specifies the name of a CSS class to use for the 16 by 16 pixel image.

String

Optional

Image16by16Left

Specifies the number of pixels to move the 16 by 16 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

Image16by16Top

Specifies the number of pixels to move the 16 by 16 pixel image toward the top. This is represented by a negative number.

Non Positive Integer

Optional

Image32by32

Specifies a 32 by 32 pixel image. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image32by32Class

Specifies the name of a CSS class to use for the 16 by 16 pixel image.

String

Optional

Image32by32Left

Specifies the number of pixels to move the 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

Image32by32Top

Specifies the number of pixels to move the 32 by 32 pixel image toward the top. This is represented by a negative number.

Non Positive Integer

Optional

LabelCss

Specifies a CSS class to apply to the label for the control.

String

Optional

LabelText

Specifies a string to display as the text for the control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

MenuItemId

Specifies a reference from a control to the ID of a menu item.

String

Optional

ModernCommandType

For internal use only.

Valid values:

Value | Description
ControlCommand | For internal use only.
System | For internal use only.

Enumeration

Optional

ModernImage

For internal use only.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Example

Xml Copy Code
<Button Id="MyISV.account.form.SendToOtherSystem.Button"        Command="MyISV.account.form.SendToOtherSystem.Command"        LabelText="$LocLabels:MyISV.account.SendToOtherSystem.LabelText"        ToolTipTitle="$LocLabels:MyISV.account.SendToOtherSystem.LabelText"        ToolTipDescription="$LocLabels:MyISV.account.SendToOtherSystem.ToolTip"        TemplateAlias="o2"        Image16by16="$webresource:New_TIcon16x16.png"        Image32by32="$webresource:New_TIcon32x32.png" />

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Button |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Controls/Button |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls/Button

Schema Name

ButtonType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CheckBox> (RibbonDiffXml)

Specifies a check box used to select an option.

Syntax

Xml
<CheckBox
 Alt="String"
 Command="String"
 Id="String"
 LabelText="String"
 MenuItemId="String"
 QueryCommand="String"
 Sequence="integer"
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="NonPositiveInteger"
 ToolTipImage32by32Top="NonPositiveInteger"
 ToolTipShortcutKey="String"
 ToolTipTitle="String" />

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alt

String or reference to a localized label to display as alternative text.

String

Optional

Command

Specifies the ID of the ribbon command for this control.

A reference to an existing CommandDefinition.Id value.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

LabelText

Specifies a string to display as the text for the control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

MenuItemId

Specifies a reference from a control to the ID of a menu item.

String

Optional

QueryCommand

Specifies the name of the command to run when polling for state information.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

Note
This element cannot be associated with a template alias that represents an <OverflowSection> (RibbonDiffXml) or a <ControlRef> (RibbonDiffXml) element that uses the Large display mode.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Example

Xml Copy Code
<CheckBox Command="MyISV.account.form.SendToOtherSystem.Command" Id="MyISV.account.form.SendToOtherSystem.Button" LabelText="$LocLabels:MyISV.account.SendToOtherSystem.LabelText" TemplateAlias="o2" ToolTipDescription="$LocLabels:MyISV.account.SendToOtherSystem.ToolTip" ToolTipTitle="$LocLabels:MyISV.account.SendToOtherSystem.LabelText" />

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/CheckBox |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Controls/CheckBox

Schema Name

CheckBoxType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Color> (RibbonDiffXml)

Specifies a color within a collection of colors for a color picker control.

Syntax

Xml
<Color Color="String"
 DisplayColor="String"
 Sequence="String"
 Style="String"
 Title="String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Color | Specifies a color within a collection of colors for a color picker control. | String | Optional
DisplayColor | A hexadecimal color code to use for the background color of the table cell, such as "#FF0000" (red). | String | Optional
Sequence | Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements. | Integer | Optional
Style | The name of a CSS selector to apply to the table cell that represents the color. | String | Optional
Title | This element is not used in Microsoft Dynamics CRM. | String | Optional

Child Elements

This element has no attributes.

Parent Elements

Element | Description
<Colors> (RibbonDiffXml) | Specifies a collection of colors for a color picker control.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls/ColorPicker/Colors/Color

Schema Name

ColorStyleType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ColorPicker> (RibbonDiffXml)

Deprecated: Specified a grid used to select a color or style.

Important
This control was deprecated in Microsoft Dynamics CRM 2011. This control will not render with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Syntax

Xml
<ColorPicker
 Command="String"
 CommandPreview="String"
 CommandRevert="String"
 Id="String"
 QueryCommand="String"
 Sequence="Integer"
 TemplateAlias="String" >
 <Colors />
</ColorPicker>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CommandPreview

Specifies the ID of the ribbon command to run when the cursor hovers over the control before it is selected.

String

Optional

CommandRevert

Specifies the ID of the ribbon command to run when the user selects undo.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

QueryCommand

Specifies the name of the command to run when polling for state information.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

Child Elements

Element | Description
<Colors> (RibbonDiffXml) | Specifies a collection of colors for a color picker control.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ColorPicker |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Controls/ColorPicker |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls/ColorPicker

Schema Name

ColorPickerType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Colors> (RibbonDiffXml)

Specifies a collection of colors for a color picker control.

Syntax

Xml
<Colors>
 <Color />
</Colors>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Color> (RibbonDiffXml) | Specifies a color within a collection of colors for a color picker control.

Parent Elements

Element | Description
<ColorPicker> (RibbonDiffXml) | Deprecated: Specified a grid used to select a color or style.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls/ColorPicker/Colors

Schema Name

ColorStylesType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ComboBox> (RibbonDiffXml)

Deprecated: Specified a list used to select a value by clicking or typing.

Important
This control was deprecated in Microsoft Dynamics CRM 2011. This control will not render with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Syntax

Xml
<ComboBox
 AllowFreeForm=["0" | "1" | "true" | "false"]
 Alt="String"
 AltArrow="String"
 AutoComplete="true"
 AutoCompleteDelay="Integer"
 CacheMenuVersions=["0" | "1" | "true" | "false"]
 Command="String"
 CommandMenuClose="String"
 CommandMenuOpen="String"
 CommandPreview="String"
 CommandPreviewRevert="String"
 Id="String"
 ImeEnabled=["0" | "1" | "true" | "false"]
 InitialItem="String"
 PopulateDynamically=["0" | "1" | "true" | "false"]
 PopulateOnlyOnce =["0" | "1" | "true" | "false"]
 PopulateQueryCommand="String"
 QueryCommand="String"
 Sequence="Integer"
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="NonPositiveInteger"
 ToolTipImage32by32Top="NonPositiveInteger "
 ToolTipSelectedItemTitle="String"
 ToolTipShortcutKey="String"
 ToolTipTitle="String"
 Width="String" >
 <Menu />
</ComboBox>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AllowFreeForm

False to restrict input so that only items on the menu are submitted; otherwise, true. The default is false.

Boolean

Optional

Alt

String or reference to a localized label to display as alternative text.

String

Optional

AltArrow

A path or web resource reference to an alternative image for the arrow icon for combo box or drop-down controls.

String

Optional

AutoComplete

False to turn AutoComplete suggestions off. The default is true (on).

Boolean

Optional

AutoCompleteDelay

The delay in milliseconds before AutoComplete fills the text box with a best-guess match. The default is 100.

Integer

Optional

CacheMenuVersions

Indicates whether the definition for the control should be cached for better performance. Select this value if you do not select PopulateDynamically.

Default value = "false".

Boolean

Optional

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CommandMenuClose

Specifies the ID of the menu command to run when the menu closes.

String

Optional

CommandMenuOpen

Specifies the ID of the ribbon command to run when the menu opens.

String

Optional

CommandPreview

Specifies the ID of the ribbon command to run when the cursor hovers over the control before it is selected.

String

Optional

CommandPreviewRevert

Specifies the ID of the ribbon command to run when the control loses focus after preview.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

ImeEnabled

Specifies whether the active state of an Input Method Editor (IME) is enabled. An IME lets you enter and edit Chinese, Japanese, and Korean characters. IMEs can be in an active or inactive state. The active state accepts Chinese, Japanese, or Korean characters. The inactive state behaves like a regular keyboard and uses a limited set of characters.

Boolean

Optional

InitialItem

Specifies the initial menu to display in the control.

String

Optional

PopulateDynamically

Specifies that the menu elements that provide options for this control will be populated dynamically at run-time using the command defined by the PopulateQueryCommand attribute.

Default value = "false".

Boolean

Optional

PopulateOnlyOnce

When the control is populated dynamically, this setting indicates that the command defined by the PopulateQueryCommand attribute should only be called once.

Default Value = "false".

Boolean

Optional

PopulateQueryCommand

When the control is populated dynamically, this command retrieves the menu elements that provide options for this control.

String

Optional

QueryCommand

When the control is populated dynamically, this command retrieves the menu elements that provide options for this control.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipSelectedItemTitle

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Width

Specifies a desired width for the control in pixels.

String

Optional

Child Elements

Element | Description
<Menu> (RibbonDiffXml) | Specifies a container used to show pop-up menus.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ComboBox |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Controls/ComboBox |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls/ComboBox

Schema Name

ComboBoxType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CommandClientTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of presentation being used.

Syntax

Xml
<CommandClientTypeRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 Type=["Modern" | "Refresh" | "Legacy"]
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

Type

Specifies the type of presentation.

Valid values:

  • Modern
  • Refresh
  • Legacy

See Remarks.

Enumeration

Required

Child Elements

This element has no attributes.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Remarks

The Type values correspond to the following:

Value | Presentation
Modern | The command bar is presented using Microsoft Dynamics CRM for tablets.
Refresh | The command bar is presented using the updated user interface.
Legacy | The ribbon is presented in forms for entities that were not updated or in a list view in Microsoft Dynamics CRM for Microsoft Office Outlook.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/CommandClientTypeRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CommandClientTypeRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/CommandClientTypeRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CommandClientTypeRule

Schema Name

CommandClientTypeRule

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CommandDefinition> (RibbonDiffXml)

Specifies a set of rules that control how a ribbon element is displayed and actions to perform that can be referenced by ribbon elements and controls.

Syntax

Xml
<CommandDefinition
Id="String">
 <EnableRules />
 <DisplayRules />
 <Actions />
</CommandDefinition>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Id | Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button. | String | Required

Child Elements

Element | Description
<EnableRules> (RibbonDiffXml) | Contains a collection of enable rules.
<DisplayRules> (RibbonDiffXml) | Contains a collection of display rules.
<Actions> (RibbonDiffXml) | Specifies the actions that a command will perform.

Parent Elements

Element | Description
<CommandDefinitions> (RibbonDiffXml) | Contains a collection of commands that can be referenced by ribbon controls.

Remarks

This element must contain all child elements even when no enable rules, display rules, or actions are defined.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition

Schema Name

CommandDefinitionType

Validation File

RibbonTypes.xsd

Can be Empty

No

See Also

Concepts

Define ribbon commands

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CommandDefinitions> (RibbonDiffXml)

Contains a collection of commands that can be referenced by ribbon controls.

Syntax

Xml
<CommandDefinitions>
 <CommandDefinition />
</CommandDefinitions>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<CommandDefinition> (RibbonDiffXml) | Specifies a set of rules that control how a ribbon element is displayed and actions to perform that can be referenced by ribbon elements and controls.

Parent Elements

Element | Description
<RibbonDiffXml> (RibbonDiffXml) | The root element for all the elements that define custom ribbons.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions

Schema Name

CommandDefinitionsType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CommandUIDefinition> (RibbonDiffXml)

Specifies the visible Ribbon elements to be included within a CustomAction element.

Syntax

Xml
<CommandUIDefinition >
[
 <Button /> |
 <CheckBox /> |
 <ComboBox /> |
 <ColorPicker /> |
 <ContextualGroup /> |
 <Controls /> |
 <DropDown /> |
 <FlyoutAnchor /> |
 <Gallery /> |
 <GalleryButton /> |
 <GroupTemplate /> |
 <Group /> |
 <Groups /> |
 <InsertTable /> |
 <Label /> |
 <MRUSplitButton /> |
 <MaxSize /> |
 <Menu /> |
 <MenuSection /> |
 <Scale /> |
 <Scaling /> |
 <Spinner /> |
 <SplitButton /> |
 <Tab /> |
 <TextBox /> |
 <ToggleButton />
]
</CommandUIDefinition>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Button> (RibbonDiffXml) | Specifies a simple button used to perform an action.
<CheckBox> (RibbonDiffXml) | Specifies a check box used to select an option.
<ComboBox> (RibbonDiffXml) | Deprecated: Specified a list used to select a value by clicking or typing.
<ColorPicker> (RibbonDiffXml) | Deprecated: Specified a grid used to select a color or style.
<ContextualGroup> (RibbonDiffXml) | Contains a collection of tabs to be displayed within a specific context.
<Controls> (RibbonDiffXml) | Contains a collection of controls.
<DropDown> (RibbonDiffXml) | Deprecated: Specified a list used to select a value by clicking.
<FlyoutAnchor> (RibbonDiffXml) | Specifies a button with a down arrow used to open a menu.
<Gallery> (RibbonDiffXml) | Deprecated: Specified a control that displays a collection of related controls in the Ribbon. If there are too many items in the gallery, an expand arrow is provided to display the rest of the collection in a pane.
<GalleryButton> (RibbonDiffXml) | Deprecated: Specified a button control within a gallery element.
<GroupTemplate> (RibbonDiffXml) | Specifies a collection of layout definitions that a group can use when the ribbon width changes.
<Group> (RibbonDiffXml) | Specifies a group of controls within a tab that share a common layout template.
<Groups> (RibbonDiffXml) | Contains a collection of Group elements.
<InsertTable> (RibbonDiffXml) | Deprecated: Specified a 10 by 10 grid used to specify the dimensions of a table.
<Label> (RibbonDiffXml) | Specifies a line of text used to provide information.
<MRUSplitButton> (RibbonDiffXml) | Deprecated: Specified a split button control that displays Most Recently Used items.
<MaxSize> (RibbonDiffXml) | Defines the largest layout possible for a group.
<Menu> (RibbonDiffXml) | Specifies a container used to show pop-up menus.
<MenuSection> (RibbonDiffXml) | Specifies a section used to divide a menu. A menu section can have a title and contain controls.
<Scale> (RibbonDiffXml) | Specifies one of the possible layouts that may be used by a group when the maximum size layout cannot be displayed.
<Scaling> (RibbonDiffXml) | Contains a collection of elements used to define how ribbon groups are presented when the horizontal space available changes.
<Spinner> (RibbonDiffXml) | Specifies a control used to insert a value by typing or using the arrow keys to cycle through the values.
<SplitButton> (RibbonDiffXml) | Specifies a control used as both a button and a menu.
<Tab> (RibbonDiffXml) | Specifies a tab in the ribbon.
<TextBox> (RibbonDiffXml) | Deprecated: Specified a control used to enter text.
<ToggleButton> (RibbonDiffXml) | Specifies a button used to toggle between an on and off state.

Parent Elements

Element | Description
<CustomAction> (RibbonDiffXml) | Defines an action to add or replace items in the ribbon.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition

Schema Name

CommandUIDefinition

Validation File

RibbonCore.xsd

Can be Empty

No

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ContextualGroup> (RibbonDiffXml)

Contains a collection of tabs to be displayed within a specific context.

Syntax

Xml
<ContextualGroup
 Color=[ "None" | "DarkBlue" | "LightBlue" | "Teal" | "Orange" | "Green" | "Magenta" | "Yellow" | "Purple"]
 Command="String"
 ContextualGroupId="String"
 Id="String"
 Sequence="Integer"
 Title="String" >
  <Tab />
</ContextualGroup>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Color

Specifies a color scheme for the group.

Valid values include:

  • None
  • DarkBlue
  • LightBlue
  • Teal
  • Orange
  • Green
  • Magenta
  • Yellow
  • Purple

Enumeration

Optional

Command

Specifies the ID of the ribbon command for this control.

String

Optional

ContextualGroupId

A string that identifies the contextual group, such as Mscrm.VisualizationTools.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

Title

This element is not used in Microsoft Dynamics CRM.

String

Optional

Child Elements

Element | Description
<Tab> (RibbonDiffXml) | Specifies a tab in the ribbon.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.

Remarks

When you export a ContextualGroup that you have previously defined you may see that the ContextualGroup and any <Tab> (RibbonDiffXml) elements that it contains are refactored into separate <CustomAction> (RibbonDiffXml) elements. This is due to the way that Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update stores the data in the database. It does not change the behavior of the original definition.

For example, if you define a <CustomAction> (RibbonDiffXml) to add a ContextualGroup as shown in the following pseudo code snippet:

Xml Copy Code
<CustomAction Location='Mscrm.ContextualGroups._children' >   <CommandUIDefinition>      <ContextualGroup Id='CG1'>         <Tab Id='T1'>...</Tab>         <Tab Id='T2'>...</Tab>      </ContextualGroup>   </CommandUIDefinition></CustomAction>

When you later export customizations including this definition, you should expect that the definition will appear as shown in the following pseudo code snippet:

Xml Copy Code
<CustomAction Location='Mscrm.ContextualGroups._children' >   <CommandUIDefinition>      <ContextualGroup Id='CG1' />   </CommandUIDefinition></CustomAction><CustomAction Location='CG1._children'>   <CommandUIDefinition>      <Tab Id='T1'>...</Tab>   </CommandUIDefinition></CustomAction><CustomAction Location='CG1._children'>   <CommandUIDefinition>      <Tab Id='T2'>...</Tab>   </CommandUIDefinition></CustomAction>

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ContextualGroup

Schema Name

ContextualGroupType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ControlRef> (RibbonDiffXml)

Specifies a placeholder for a control within a layout template.

Syntax

Xml
<ControlRef
 DisplayMode=["Default" | "Small" | "Medium" | "Large" | "Text" | "Menu" | "Menu16" | "Menu32" | "Thin" ]
 TemplateAlias="String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

DisplayMode

Controls the mode used to display the element.

Valid Values:

Value | Description
Default | Displays the element using the default mode.
Small | Displays the element in small mode.
Medium | Displays the element in medium mode.
Large | Displays the element in large mode.
Text | Displays the element in text mode.
Menu | Displays the element like a menu.
Menu16 | Displays the element in a menu with a height of 16 pixels.
Menu32 | Displays the element in a menu with a height of 32 pixels.
Thin | Displays the element in thin mode.

Enumeration

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Row> (RibbonDiffXml) | Specifies a row within a Section.
<Strip> (RibbonDiffXml) | Contains a collection of control references.

Element Information

XPath

Copy Code
//RibbonDiffXml/Templates/RibbonTemplates/GroupTemplate/Layout/Section/Row/ControlRef |
//RibbonDiffXml/Templates/RibbonTemplates/GroupTemplate/Layout/Section/Row/Strip/ControlRef

Schema Name

ControlRefType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Controls> (RibbonDiffXml)

Contains a collection of controls.

Important
The valid child elements of the Controls element depend on the parent element.

Syntax

<CommandUIDefinition>
 <Controls
  Id="String"
  ToolTipDescription="String"
  ToolTipHelpKeyWord="String"
  ToolTipImage32by32="String"
  ToolTipImage32by32Class="String"
  ToolTipImage32by32Left="NonPositiveInteger"
  ToolTipImage32by32Top="NonPositiveInteger"
  ToolTipTitle="String">
  [
    <Button /> |
    <CheckBox /> |
    <ComboBox /> |
    <ColorPicker /> |
    <ContextualGroup /> |
    <Controls /> |
    <DropDown /> |
    <FlyoutAnchor /> |
    <Gallery /> |
    <GalleryButton /> |
    <GroupTemplate /> |
    <Group /> |
    <Groups /> |
    <InsertTable /> |
    <Label /> |
    <MRUSplitButton /> |
    <MaxSize /> |
    <Menu /> |
    <MenuSection /> |
    <Scale /> |
    <Scaling /> |
    <Spinner /> |
    <SplitButton /> |
    <Tab /> |
    <TextBox/> |
    <ToggleButton />
   ]
 </Controls>
</CommandUIDefinition>
<MenuSection>
 <Controls
  Id="String"
  ToolTipDescription="String"
  ToolTipHelpKeyWord="String"
  ToolTipImage32by32="String"
  ToolTipImage32by32Class="String"
  ToolTipImage32by32Left="NonPositiveInteger"
  ToolTipImage32by32Top="NonPositiveInteger"
  ToolTipTitle="String">
  [
    <ToggleButton /> |
    <Button /> |
    <ColorPicker /> |
    <FlyoutAnchor /> |
    <InsertTable />
   ]
 </Controls>
</MenuSection>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

Important

String

Required

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipSelectedItemTitle

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Child Elements

Element | Description
<Button> (RibbonDiffXml) | Specifies a simple button used to perform an action.
<CheckBox> (RibbonDiffXml) | Specifies a check box used to select an option. This element is only valid when Controls is a child of <CommandUIDefinition> (RibbonDiffXml).
<ColorPicker> (RibbonDiffXml) | Deprecated: Specified a grid used to select a color or style. This element is only valid when Controls is a child of <MenuSection> (RibbonDiffXml)
<ComboBox> (RibbonDiffXml) | Deprecated: Specified a list used to select a value by clicking or typing. This element is only valid when Controls is a child of <CommandUIDefinition> (RibbonDiffXml).
<DropDown> (RibbonDiffXml) | Deprecated: Specified a list used to select a value by clicking. This element is only valid when Controls is a child of <CommandUIDefinition> (RibbonDiffXml).
<FlyoutAnchor> (RibbonDiffXml) | Specifies a button with a down arrow used to open a menu.
<GalleryButton> (RibbonDiffXml) | Deprecated: Specified a button control within a gallery element. This element is only valid when Controls is a child of <CommandUIDefinition> (RibbonDiffXml).
<InsertTable> (RibbonDiffXml) | Deprecated: Specified a 10 by 10 grid used to specify the dimensions of a table. This element is only valid when Controls is a child of <MenuSection> (RibbonDiffXml)
<Label> (RibbonDiffXml) | Specifies a line of text used to provide information. This element is only valid when Controls is a child of <CommandUIDefinition> (RibbonDiffXml).
<MRUSplitButton> (RibbonDiffXml) | Deprecated: Specified a split button control that displays Most Recently Used items. This element is only valid when Controls is a child of <CommandUIDefinition> (RibbonDiffXml).
<Spinner> (RibbonDiffXml) | Specifies a control used to insert a value by typing or using the arrow keys to cycle through the values. This element is only valid when Controls is a child of <CommandUIDefinition> (RibbonDiffXml).
<SplitButton> (RibbonDiffXml) | Specifies a control used as both a button and a menu. This element is only valid when Controls is a child of <CommandUIDefinition> (RibbonDiffXml).
<TextBox> (RibbonDiffXml) | Deprecated: Specified a control used to enter text. This element is only valid when Controls is a child of <CommandUIDefinition> (RibbonDiffXml).
<ToggleButton> (RibbonDiffXml) | Specifies a button used to toggle between an on and off state.

Parent Elements

Element | Description
<Group> (RibbonDiffXml) | Specifies a group of controls within a tab that share a common layout template.
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<MenuSection> (RibbonDiffXml) | Specifies a section used to divide a menu. A menu section can have a title and contain controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Controls |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/MenuSection/Controls

Schema Name

ControlsType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CrmClientTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of Microsoft Dynamics CRM client.

Syntax

Xml
<CrmClientTypeRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 Type=["Web" | "Outlook"]
 />

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

Type

Specifies the type of section.

Valid values:

  • Web
  • Outlook

Enumeration

Required

Child Elements

This element has no attributes.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/CrmClientTypeRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CrmClientTypeRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/CrmClientTypeRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CrmClientTypeRule

Schema Name

CrmClientTypeRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CrmOfflineAccessStateRule> (RibbonDiffXml)

Specifies a rule that can be used to detect whether Microsoft Dynamics CRM for Outlook with Offline Access is currently operating offline.

Syntax

Xml
<CrmOfflineAccessStateRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 State=["Online" |"Offline"]
 />

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

State

The State value to check.

Valid Values:

  • Online
  • Offline

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/CrmOfflineAccessStateRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CrmOfflineAccessStateRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/CrmOfflineAccessStateRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CrmOfflineAccessStateRule

Schema Name

CrmOfflineAccessStateRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CrmOutlookClientTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of Microsoft Dynamics CRM for Microsoft Office Outlook client.

Syntax

Xml
<CrmOutlookClientTypeRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 Type=["CrmForOutlook" | "CrmForOutlookOfflineAccess"]
 />

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

Type

Specifies the type of CRM for Outlook client.

Valid values:

  • CrmForOutlook
  • CrmForOutlookOfflineAccess

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/CrmOutlookClientTypeRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CrmOutlookClientTypeRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/CrmOutlookClientTypeRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CrmOutlookClientTypeRule

Schema Name

CrmOutlookClientTypeRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CrmOutlookClientVersionRule> (RibbonDiffXml)

Detects the version of Microsoft Dynamics CRM for Microsoft Office Outlook.

Syntax

Xml
<CrmOutlookClientVersionRule
 Build="Integer"
 Default =["0" | "1" | "true" | "false"]
 InvertResult =["0" | "1" | "true" | "false"]
 Major="Integer"
 Minor="Integer"
 Revision="Integer"
 />

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Major | The major version number. Valid values are 4 and 5. | Integer | Required
Minor | The minor version number. This is a single digit. | Integer | Optional
Build | The build number. This is a four-digit number. | Integer | Optional
Revision | The revision number. This is a single-digit number. | Integer | Optional
Default | Sets the default return value for the rule if the actual value cannot be determined. | Boolean | Optional
InvertResult | Negates the return value of the rule. | Boolean | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/CrmOutlookClientVersionRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CrmOutlookClientVersionRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/CrmOutlookClientVersionRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CrmOutlookClientVersionRule

Schema Name

CrmOutlookClientVersionRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CrmParameter> (RibbonDiffXml)

Represents data retrieved from the Microsoft Dynamics CRM application that may be passed as a parameter.

Syntax

Xml
<CrmParameter
 Name = “String”
 Value= ["CommandProperties" |
         "PrimaryEntityTypeCode" |
         "PrimaryEntityTypeName" |
         "PrimaryItemIds" |
         "FirstPrimaryItemId" |
         "PrimaryControl" |
         "PrimaryControlId" |
         "SelectedEntityTypeCode" |
         "SelectedEntityTypeName" |
         "FirstSelectedItemId" |
         "SelectedControl" |
         "SelectedControlSelectedItemCount" |
         "SelectedControlSelectedItemIds" |
         "SelectedControlSelectedItemReferences" |
         "SelectedControlAllItemCount" |
         "SelectedControlAllItemIds" |
         "SelectedControlAllItemReferences" |
         "SelectedControlUnselectedItemCount" |
         "SelectedControlUnselectedItemIds" |
         "SelectedControlUnselectedItemReferences" |
         "OrgName" |
         "OrgLcid" |
         "UserLcid"]
 />

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Name

Represents the name of a query string parameter passed for this value when using a Url element.

Represents the name of a query string parameter passed using the <Url> (RibbonDiffXml) element.

String

See Remarks

Value

Specifies the value to be passed as a parameter.

Valid values:

Value Description

CommandProperties

An object with the following three properties: SourceControlId, CommandValueId, and MenuItemId

  • SourceControlId : The Id value of the Ribbon control that initiated the event.
  • CommandValueId : A string that is sent with the command event when a button is clicked.
  • MenuItemId: A reference from a control to the Id of a menu item.

PrimaryEntityTypeCode

A number representing the unique type of entity for a specific Microsoft CRM deployment.

PrimaryEntityTypeName

A string representing the unique name of an entity.

PrimaryItemIds

A string array providing the GUID Id values for the Primary Item.

FirstPrimaryItemId

Provides one GUID identifier as a string for the record being viewed.

PrimaryControl

An Object referencing the Control that had focus when the Ribbon Command action occurred.

PrimaryControlId

A string providing the Id value of the control that had focus.

SelectedEntityTypeCode

A number representing the unique type of entity for a record selected in a grid. The Entity type code will vary between deployments.

SelectedEntityTypeName

A string representing the unique name of the entity for a record selected in a grid.

FirstSelectedItemId

Provides one GUID identifier as a string for the first item selected in a grid.

SelectedControl

An Object referencing the Control that had focus when the Ribbon Command action occurred.

SelectedControlSelectedItemCount

The number of selected items in a grid.

SelectedControlSelectedItemIds

A string array of GUID Id values for all selected items in a grid.

SelectedControlSelectedItemReferences

An array of EntityReference objects that represent all the selected items in the grid.

This option is only available when used with the <JavaScriptFunction> (RibbonDiffXml) element.

SelectedControlAllItemCount

A number showing the total number of items displayed in a grid.

SelectedControlAllItemIds

A string array providing the GUID Id values for all items displayed in a grid.

SelectedControlAllItemReferences

An array of EntityReference objects representing all the items in the grid.

This option is only available when used with the <JavaScriptFunction> (RibbonDiffXml) element.

SelectedControlUnselectedItemCount

The number of unselected items in a grid.

SelectedControlUnselectedItemIds

A string array of GUID Id values for all unselected items in a grid.

SelectedControlUnselectedItemReferences

An array of EntityReference objects representing all the items not selected in the grid.

This option is only available when used with the <JavaScriptFunction> (RibbonDiffXml) element.

OrgName

The name of the organization.

OrgLcid

The Language Code representing the base Language for the organization.

UserLcid

The Language Code representing the language preference chosen by the user..

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<JavaScriptFunction> (RibbonDiffXml) | Specifies an action that calls a function from a specific JavaScript library.
<CustomRule> (RibbonDiffXml) | Specifies a rule used with an EnableRule definition that is composed of a reference to a function within a JavaScript library.
<Url> (RibbonDiffXml) | An action that opens a web page at a specified address.

Remarks

When the CrmParameter is a child of the <Url> (RibbonDiffXml) a Name attribute is required. When the CrmParameter is a child of the <JavaScriptFunction> (RibbonDiffXml) element, the Name attribute is not valid.

Note
  • Value attributes referring to a "Primary..." item refer to the record being viewed in the form.
  • Value attributes referring to the "Selected..." item refer to rows selected within a grid.
When a grid is presented within a form or as an associated view the "Primary.." values refer to the record context in which the grid is displayed. This is true as long as the grid is associated with an entity relationship.

When a grid is displayed independently from any entity relationship, such as in the Homepage grid or if a subgrid is added to a form without being associated with an entity relationship, the "Primary..." values will be null.

Note
Some CrmParameter values pass an EntityReference object. This object contains the following properties:

  • Id: A string of the GUID Id value for the record.
  • Name: A string of the value of the Primary field for the record.
  • TypeCode: A number representing the unique type of entity for the record.
  • TypeName: A string representing the unique name of the entity for the record.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/JavaScriptFunction/CrmParameter |
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/Url/CrmParameter |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CustomRule/CrmParameter |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CustomRule/CrmParameter |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/CustomRule/CrmParameter |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/CustomRule/CrmParameter

Schema Name

  • CrmParameterType
  • CrmNamedParameterType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CustomAction> (RibbonDiffXml)

Defines an action to add or replace items in the ribbon.

Syntax

Xml
<CustomAction
 Id="String"
 Location="String"
 Sequence="Integer"
 Title="String">
 <CommandUIDefinition />
</CustomAction>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

The recommended naming convention is to use a period to separate consistent components like so: <solution identifier>.<entity>.<ribbon>.<function>.<element name>. For example: MyISV.account.form.SendToOtherSystem.CustomAction.

String

Optional

Location

References the Id of an existing ribbon element that contains the modification defined in the CustomAction. To add a new ribbon element, refer to the containing element Id and include the suffix ”._children”.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

Title

This element is not used in Microsoft Dynamics CRM.

String

Optional

Child Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.

Parent Elements

Element | Description
<CustomActions> (RibbonDiffXml) | Contains a collection of actions that can add, replace, or remove items from the ribbon.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction

Schema Name

CustomActionType

Validation File

RibbonCore.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CustomActions> (RibbonDiffXml)

Contains a collection of actions that can add, replace, or remove items from the ribbon.

Syntax

Xml
<CustomActions >
 <CustomAction />
 <HideCustomAction />
</CustomActions>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<CustomAction> (RibbonDiffXml) | Defines an action to add or replace items in the ribbon.
<HideCustomAction> (RibbonDiffXml) | Removes an existing ribbon element from being processed for the ribbon.

Parent Elements

Element | Description
<RibbonDiffXml> (RibbonDiffXml) | The root element for all the elements that define custom ribbons.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions

Schema Name

CustomActionsType

Validation File

RibbonCore.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<CustomRule> (RibbonDiffXml)

Specifies a rule used with an EnableRule definition that is composed of a reference to a function within a JavaScript library.

Syntax

Xml
<CustomRule
 Default=["0" | "1" | "true" | "false"]
 FunctionName="String"
 InvertResult=["0" | "1" | "true" | "false"]
 Library="String" >
 <BoolParameter />
 <CrmParameter />
 <DecimalParameter />
 <StringParameter />
</CustomRule>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

FunctionName

The name of a JScript function located in the library designated by the Library attribute.

FunctionName must follow this naming convention:

  • The first character must be a letter, an underscore ("_") character, or a dollar ("$") symbol.
  • The remaining characters may be any combination of letters, underscore characters, dollar symbols, numbers or periods.

String

Required

InvertResult

Negates the return value of the rule.

Boolean

Optional

Library

The path to a .js file containing the function named in the FunctionName attribute.

String

Required

Child Elements

Element | Description
<BoolParameter> (RibbonDiffXml) | Specifies a value with a Boolean data type that may be passed as a parameter.
<CrmParameter> (RibbonDiffXml) | Represents data retrieved from the Microsoft Dynamics CRM application that may be passed as a parameter.
<DecimalParameter> (RibbonDiffXml) | Specifies a value with a decimal data type that may be passed as a parameter.
<IntParameter> (RibbonDiffXml) | Specifies a value with an integer data type that may be passed as a parameter.
<StringParameter> (RibbonDiffXml) | Specifies a value with a string data type that may be passed as a parameter.

Parent Elements

Element | Description
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CustomRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CustomRule

Schema Name

CustomRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DecimalParameter> (RibbonDiffXml)

Specifies a value with a decimal data type that may be passed as a parameter.

Syntax

Xml
<DecimalParameter
 Name="String"
 Value="Decimal"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Name | Represents the name of a query string parameter passed using the <Url> (RibbonDiffXml) element. | String | See Remarks
Value | Specifies the value to be passed as a parameter. | Decimal | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<JavaScriptFunction> (RibbonDiffXml) | Specifies an action that calls a function from a specific JavaScript library.
<CustomRule> (RibbonDiffXml) | Specifies a rule used with an EnableRule definition that is composed of a reference to a function within a JavaScript library.
<Url> (RibbonDiffXml) | An action that opens a web page at a specified address.

Remarks

When the DecimalParameter is a child of the <Url> (RibbonDiffXml) a Name attribute is required. When the DecimalParameter is a child of the <JavaScriptFunction> (RibbonDiffXml) or <CustomRule> (RibbonDiffXml) element, the Name attribute is not valid.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/JavaScriptFunction/DecimalParameter |
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/Url/DecimalParameter |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CustomRule/DecimalParameter |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CustomRule/DecimalParameter |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/CustomRule/DecimalParameter |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/CustomRule/DecimalParameter

Schema Name

  • DecimalNamedParameterType
  • DecimalParameterType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DisplayRule> (RibbonDiffXml)

Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.

Note
The DisplayRule element child elements are only valid when it is a grandchild of <RuleDefinitions> (RibbonDiffXml).

Syntax

Xml
<CommandDefinition>
 <DisplayRules>
  <DisplayRule
   Id="String"
  />
 </DisplayRules>
</CommandDefinition>
Xml
<RuleDefinitions>
 <DisplayRules>
  <DisplayRule
   Id="String">
   <CommandClientTypeRule />
   <CrmClientTypeRule />
   <CrmOfflineAccessStateRule />
   <CrmOutlookClientTypeRule />
   <CrmOutlookClientVersionRule />
   <EntityPrivilegeRule />
   <EntityPropertyRule />
   <EntityRule />
   <FormEntityContextRule />
   <FormStateRule />
   <FormTypeRule />
   <HideForTabletExperienceRule />
   <MiscellaneousPrivilegeRule />   <OptionSetRule />
   <OrganizationSettingRule />
   <OrRule />
   <OutlookRenderTypeRule />
   <OutlookVersionRule />
   <PageRule />
   <ReferencingAttributeRequiredRule />
   <RelationshipTypeRule />
   <SkuRule />
   <ValueRule />
  </DisplayRule>
 </DisplayRules>
</RuleDefinitions>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Id

Either:

  • A unique identifier for the definition of a Display Rule
  • A reference to the Id value of a definition of a Display Rule.

String

Required

Child Elements

Element | Description
<CommandClientTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of presentation being used.
<CrmClientTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of Microsoft Dynamics CRM client.
<CrmOutlookClientTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of Microsoft Dynamics CRM for Microsoft Office Outlook client.
<CrmOfflineAccessStateRule> (RibbonDiffXml) | Specifies a rule that can be used to detect whether Microsoft Dynamics CRM for Outlook with Offline Access is currently operating offline.
<EntityPrivilegeRule> (RibbonDiffXml) | Specifies a rule that can detect the current user's permissions for a specific entity.
<EntityPropertyRule> (RibbonDiffXml) | Specifies a rule that can detect specific Boolean entity properties.
<EntityRule> (RibbonDiffXml) | Specifies a rule that can detect whether a specific entity is in context.
<FormEntityContextRule> (RibbonDiffXml) | Specifies a rule that can detect whether a form ribbon is displayed in the context of a specific entity.
<FormStateRule> (RibbonDiffXml) | Specifies a rule that can detect the state of the form.
<FormTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of Microsoft Dynamics CRM form.
<HideForTabletExperienceRule> (RibbonDiffXml) | Specifies a rule that will return false when the web application is viewed in a mobile browser on a tablet device.
<MiscellaneousPrivilegeRule> (RibbonDiffXml) | Specifies a rule that can detect whether the user possesses a specific Microsoft Dynamics CRM privilege.
<OptionSetRule> (RibbonDiffXml) | For internal use only.
<OrganizationSettingRule> (RibbonDiffXml) | A rule that can detect two specific organization settings within a DisplayRule.
<OrRule> (RibbonDiffXml) | A rule that contains a collection of rules so that this rule will evaluate as true if any of the rules in the collection evaluates as true.
<OutlookRenderTypeRule> (RibbonDiffXml) | A rule that can detect whether a form or list item is rendered as a web page or natively in Outlook in order to determine if a ribbon element should be displayed.
<OutlookVersionRule> (RibbonDiffXml) | A rule that detects the version of Microsoft Office Outlook client.
<PageRule> (RibbonDiffXml) | A rule that evaluates the address of the current page.
<ReferencingAttributeRequiredRule> (RibbonDiffXml) | A rule that detects whether the referencing attribute for an entity is required.
<RelationshipTypeRule> (RibbonDiffXml) | A rule that detects whether a specific type of formal entity relationship exists between two entities.
<SkuRule> (RibbonDiffXml) | A rule that detects the Microsoft Dynamics CRM edition.
<ValueRule> (RibbonDiffXml) | A rule that detects the value of a specific field.

Parent Elements

Element | Description
<DisplayRules> (RibbonDiffXml) | Contains a collection of display rules.

Remarks

The <DisplayRules> (RibbonDiffXml) element is used as a child of <RuleDefinitions> (RibbonDiffXml) and <CommandDefinition> (RibbonDiffXml). When the DisplayRule element is a grandchild of RuleDefinitions it defines a rule and supports a variety of child rule elements. When DisplayRule is a grandchild of CommandDefinition, it simply references the DisplayRule definition using the Id attribute.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/DisplayRules/DisplayRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule

Schema Name

  • DisplayRulesType/DisplayRule
  • ReferenceDisplayRuleType

Validation File

RibbonTypes.xsd

Can be Empty

When a grandchild of <CommandDefinition> (RibbonDiffXml)

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DisplayRules> (RibbonDiffXml)

Contains a collection of display rules.

Syntax

Xml
<DisplayRules>
 <DisplayRule />
</DisplayRules>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.

Parent Elements

Element | Description
<RuleDefinitions> (RibbonDiffXml) | Contains a collection of rule definitions.
<CommandDefinition> (RibbonDiffXml) | Specifies a set of rules that control how a ribbon element is displayed and actions to perform that can be referenced by ribbon elements and controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/DisplayRules |
//RibbonDiffXml/RuleDefinitions/DisplayRules

Schema Name

  • ReferenceDisplayRulesType
  • DisplayRulesType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<DropDown> (RibbonDiffXml)

Deprecated: Specified a list used to select a value by clicking.

Important
This control was deprecated in Microsoft Dynamics CRM 2011. This control will not render with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Use <FlyoutAnchor> (RibbonDiffXml) instead.

Syntax

Xml
<DropDown
 Alt="String"
 AltArrow="String"
 CacheMenuVersions=["0" | "1" | "true" | "false"]
 Command="String"
 CommandMenuClose="String"
 CommandMenuOpen="String"
 CommandPreview="String"
 CommandPreviewRevert="String"
 Id="String"
 InitialItem="String"
 PopulateDynamically=["0" | "1" | "true" | "false"]
 PopulateOnlyOnce=["0" | "1" | "true" | "false"]
 PopulateQueryCommand="String"
 QueryCommand="String"
 SelectedItemDisplayMode="Default"
 Sequence="Integer"
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="Non-Postive Integer"
 ToolTipImage32by32Top="Non-Postive Integer"
 ToolTipSelectedItemTitle="String"
 ToolTipShortcutKey="String"
 ToolTipTitle="String"
 Width="String" >
 <Menu />
</DropDown>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alt

String or reference to a localized label to display as alternative text.

String

Optional

AltArrow

A path or web resource reference to an alternative image for the arrow icon for combo box or drop-down controls.

String

Optional

CacheMenuVersions

Indicates whether the definition for the control should be cached for better performance. Select this value if you do not select PopulateDynamically.

Boolean

Optional

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CommandMenuClose

Specifies the ID of the menu command to run when the menu closes.

String

Optional

CommandMenuOpen

Specifies the ID of the ribbon command to run when the menu opens.

String

Optional

CommandPreview

Specifies the ID of the ribbon command to run when the cursor hovers over the control before it is selected.

String

Optional

CommandPreviewRevert

Specifies the ID of the ribbon command to run when the control loses focus after preview.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

Important

String

Required

InitialItem

Specifies the initial menu to display in the control.

String

Optional

PopulateDynamically

Specifies that the menu elements that provide options for this control will be populated dynamically at run-time using the command defined by the PopulateQueryCommand attribute.

Boolean

Optional

PopulateOnlyOnce

When the control is populated dynamically, this setting indicates that the command defined by the PopulateQueryCommand attribute should only be called once.

Boolean

Optional

PopulateQueryCommand

When the control is populated dynamically, this command retrieves the menu elements that provide options for this control.

String

Optional

QueryCommand

Specifies the name of the command to run when polling for state information.

String

Optional

SelectedItemDisplayMode

The display mode of the selected option.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipSelectedItemTitle

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Width

Specifies a desired width for the control in pixels.

String

Optional

Child Elements

Element | Description
<Menu> (RibbonDiffXml) | Specifies a container used to show pop-up menus.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/DropDown |
//Controls/DropDown

Schema Name

DropDownType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EnableRule> (RibbonDiffXml)

Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.

Note
The EnableRule element child elements are only valid when it is a grandchild of <RuleDefinitions> (RibbonDiffXml).

Syntax

<CommandDefinition>
 <EnableRules>
  <EnableRule Id="String" />
 </EnableRules>
</CommandDefinition>
Xml
<RuleDefinitions>
 <EnableRules >
  <EnableRule
   Id="String">
   <CommandClientTypeRule />
   <CrmClientTypeRule />
   <CrmOfflineAccessStateRule />
   <CrmOutlookClientTypeRule />
   <CustomRule />
   <EntityRule />
   <FormStateRule />
   <OrRule />
   <OutlookItemTrackingRule />
   <OutlookVersionRule />
   <PageRule />
   <RecordPrivilegeRule />
   <SelectionCountRule />
   <SkuRule />
   <ValueRule />
  </EnableRule>
 </EnableRules>
</RuleDefinitions>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Id

Either

  • A unique identifier for the definition of an Enable Rule
  • A reference to the Id value of a definition of an Enable Rule.

String

Required

Child Elements

Element | Description
<CommandClientTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of presentation being used.
<CrmClientTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of Microsoft Dynamics CRM client.
<CrmOfflineAccessStateRule> (RibbonDiffXml) | Specifies a rule that can be used to detect whether Microsoft Dynamics CRM for Outlook with Offline Access is currently operating offline.
<CrmOutlookClientTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of Microsoft Dynamics CRM for Microsoft Office Outlook client.
<CustomRule> (RibbonDiffXml) | Specifies a rule used with an EnableRule definition that is composed of a reference to a function within a JavaScript library.
<EntityRule> (RibbonDiffXml) | Specifies a rule that can detect whether a specific entity is in context.
<FormStateRule> (RibbonDiffXml) | Specifies a rule that can detect the state of the form.
<OrRule> (RibbonDiffXml) | A rule that contains a collection of rules so that this rule will evaluate as true if any of the rules in the collection evaluates as true.
<OutlookItemTrackingRule> (RibbonDiffXml) | A rule that detects whether the item is enabled for items tracked in Microsoft Dynamics CRM in order to enable a ribbon element.
<OutlookVersionRule> (RibbonDiffXml) | A rule that detects the version of Microsoft Office Outlook client.
<PageRule> (RibbonDiffXml) | A rule that evaluates the address of the current page.
<RecordPrivilegeRule> (RibbonDiffXml) | A rule that detects a user’s privileges for a specific record in order to enable a ribbon element.
<SelectionCountRule> (RibbonDiffXml) | A rule that detects how many items in a grid are selected.
<SkuRule> (RibbonDiffXml) | A rule that detects the Microsoft Dynamics CRM edition.
<ValueRule> (RibbonDiffXml) | A rule that detects the value of a specific field.

Parent Elements

Element | Description
<EnableRules> (RibbonDiffXml) | Contains a collection of enable rules.

Remarks

The <EnableRules> (RibbonDiffXml) element is used as a child of <RuleDefinitions> (RibbonDiffXml) and <CommandDefinition> (RibbonDiffXml). When the EnableRule element is a grandchild of RuleDefinitions it defines a rule and supports a variety of child rule elements. When EnableRule is a grandchild of CommandDefinition, it simply references the EnableRule definition using the Id attribute.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule |
//RibbonDiffXml/CommandDefinitions/CommandDefinition/EnableRules/EnableRule

Schema Name

  • ReferenceEnableRulesType/EnableRule
  • EnableRulesType/EnableRule

Validation File

RibbonTypes.xsd

Can be Empty

When a grandchild of <CommandDefinition> (RibbonDiffXml).

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EnableRules> (RibbonDiffXml)

Contains a collection of enable rules.

Syntax

Xml
<EnableRules >
 <EnableRule />
</EnableRules>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.

Parent Elements

Element | Description
<CommandDefinition> (RibbonDiffXml) | Specifies a set of rules that control how a ribbon element is displayed and actions to perform that can be referenced by ribbon elements and controls.
<RuleDefinitions> (RibbonDiffXml) | Contains a collection of rule definitions.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/EnableRules |
//RibbonDiffXml/RuleDefinitions/EnableRules

Schema Name

  • CommandDefinitionType/EnableRules
  • EnableRulesType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EntityPrivilegeRule> (RibbonDiffXml)

Specifies a rule that can detect the current user's permissions for a specific entity.

Syntax

Xml
<EntityPrivilegeRule
 AppliesTo=["PrimaryEntity" | " SelectedEntity "]
 Default =["0" | "1" | "true" | "false"]
 EntityName="String"
 InvertResult =["0" | "1" | "true" | "false"]
 PrivilegeDepth=["None" | "Basic" | "Local" | "Deep" | "Global"]
 PrivilegeType=["Create" | "Read" | "Write" | "Delete" | "Assign" | "Share" | "Append" | "AppendTo"]
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AppliesTo

Determines whether the rule applies to the entity record being displayed in the form or entity records being displayed in a sub-grid.

Valid values:

Value | Description
PrimaryEntity | For a form or Subgrid ribbon, the rule applies to the entity displayed in the form. This will option does not apply for a Grid Ribbon.
SelectedEntity | For a Grid or Subgrid ribbon this rule applies to the entity that appears in the grid.

String

Optional

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

EntityName

Specifies the entity that this rule will apply to. Use the entity logical name, for example, "new_customentity".

String

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

PrivilegeDepth

The Privilege Depth criteria to check.

Valid values:

Value | Description
None | No access is allowed.
Basic | This access level exposes to a user entity instances he or she owns, objects that are shared with the user, and objects that are shared with a team of which the user is a member. The application refers to this access level as User.
Local | This access level exposes to a user entity instances in the user's business unit. The application refers to this access level as Business Unit.
Deep | This access level exposes to a user entity instances in the user's business unit and all business units subordinate to the user's business unit. The application refers to this access level as Parent: Child Business Units.
Global | This access level exposes to a user all entity instances within the organization, regardless of the business unit hierarchical level to which the instance or the user belongs. The application refers to this access level as Organization.

Enumeration

Required

PrivilegeType

The type of privilege to check.

Valid values:

Value | Description
Create | To create new entity instances for this entity.
Read | To view a records of this entity.
Write | To update an entity instance.
Delete | To delete a record for this entity.
Assign | To change the owner of user-owned instances of an entity.
Share | To assign specific privileges to another user for an entity instance.
Append | To associate a selected entity instance to another entity instance.
AppendTo | To associate an entity instance to this entity instance.

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Remarks

If you do not provide a value for EntityName, you must specify AppliesTo = PrimaryEntity.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/EntityPrivilegeRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/EntityPrivilegeRule

Schema Name

EntityPrivilegeRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EntityPropertyRule> (RibbonDiffXml)

Specifies a rule that can detect specific Boolean entity properties.

Syntax

Xml
<EntityPropertyRule
 AppliesTo=["PrimaryEntity" | " SelectedEntity "]
 Default =["0" | "1" | "true" | "false"]
 EntityName="String"
 InvertResult =["0" | "1" | "true" | "false"]
 PropertyName=["DuplicateDetectionEnabled" | "GridFiltersEnabled" | "HasStateCode"  | "IsConnectionsEnabled"  | "MailMergeEnabled"  | "WorksWithQueue"  | "HasActivities"  | "IsActivity"  | "IsBusinessProcessEnabled"  | "HasNotes"  | "IsCustomizable"]
 PropertyValue=["0" | "1" | "true" | "false"]
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AppliesTo

Determines whether the rule applies to the entity record being displayed in the form or entity records being displayed in a sub-grid.

Valid values:

Value | Description
PrimaryEntity | For a form or Subgrid ribbon, the rule applies to the entity displayed in the form. This will option does not apply for a Grid Ribbon.
SelectedEntity | For a Grid or Subgrid ribbon this rule applies to the entity that appears in the grid.

Enumeration

Optional

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

EntityName

Specifies the entity that this rule will apply to. Use the entity logical name, for example, "new_customentity".

String

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

PropertyName

The name of the boolean entity property to check.

Valid values:

Value | Description
DuplicateDetectionEnabled | Allows defining duplicate detection rules with this entity.
GridFiltersEnabled | Corresponds to the IsValidForAdvancedFind property.
HasStateCode | The entity has a Status (statecode) field.
IsConnectionsEnabled | Allows Connections to be established between instances of this entity and other Connections enabled entities.
MailMergeEnabled | The entity allows users to generate mail merge documents.
WorksWithQueue | The entity is enabled to work with queues.
HasActivities | The entity has a relationship with the Activity (activitypointer) entity so that the entity can appear in the Regarding lookup field in Activities.
IsActivity | The entity is defined as an activity.
IsBusinessProcessEnabled | The entity is enabled for business processes.
HasNotes | The entity has a entity relationship with the Note (annotation) entity.
IsCustomizable | The entity provides some degree of customizability.

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/EntityPropertyRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/EntityPropertyRule

Schema Name

EntityPropertyRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<EntityRule> (RibbonDiffXml)

Specifies a rule that can detect whether a specific entity is in context.

Syntax

Xml
<EntityRule
 AppliesTo=["PrimaryEntity" | "SelectedEntity"]
 Context=["Form" | "HomePageGrid" | "SubGridStandard" |"SubGridAssociated"]
 Default=["0" | "1" | "true" | "false"]
 EntityName="String"
 InvertResult=["0" | "1" | "true" | "false"]
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AppliesTo

Determines whether the rule applies to the entity record being displayed in the form or entity records being displayed in a sub-grid.

Valid values:

Value | Description
PrimaryEntity | For a form or Subgrid ribbon, the rule applies to the entity displayed in the form. This will option does not apply for a Grid Ribbon.
SelectedEntity | For a Grid or Subgrid ribbon this rule applies to the entity that appears in the grid.

Enumeration

Optional

Context

Specifies the context of the ribbon.

Valid values:

Value | Description
Form | For the form ribbon.
HomePageGrid | For the ribbon that is displayed for the list of records that appear in the main application navigation pane.
SubGridStandard | For the ribbon that is displayed for the list of records that appear in a subgrid in a form.
SubGridAssociated | For the ribbon that is displayed for the list of records that appear in the navigation area of a form.

String

Optional

Default

Sets the default return value for the rule if the actual value cannot be determined.

This attribute is not valid when this element is a child of <TabDisplayRule> (RibbonDiffXml)

Boolean

Optional

EntityName

Specifies the entity that this rule will apply to. Use the entity logical name, for example, "new_customentity".

String

Required

InvertResult

Negates the return value of the rule.

This attribute is not valid when this element is a child of <TabDisplayRule> (RibbonDiffXml)

Boolean

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<TabDisplayRule> (RibbonDiffXml) | Specifies conditions when a tab will display.
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Remarks

The InvertResult and Default attributes are not valid when this element is a child of <TabDisplayRule> (RibbonDiffXml)

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/TabSelectionRules/TabSelectionRule/EntityRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/EntityRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/EntityRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/EntityRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/EntityRule

Schema Name

EntityRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FlyoutAnchor> (RibbonDiffXml)

Specifies a button with a down arrow used to open a menu.

Syntax

Xml
<FlyoutAnchor
 Alt="String"
 CacheMenuVersions=["0" | "1" | "true" | "false"]
 Command="String"
 CommandMenuClose="String"
 CommandType=["General" | "OptionSelection" | "IgnoredByMenu"]
 Id="String"
 Image16by16="String"
 Image16by16Class="String"
 Image16by16Left="Non Positive Integer"
 Image16by16Top="Non Positive Integer"
 Image32by32="String"
 Image32by32Class="String"
 Image32by32Left="Non Positive Integer"
 Image32by32Top="Non Positive Integer"
 LabelText="String"
 ModernCommandType=["ControlCommand" | "System"]
 ModernImage=”String”
 PopulateDynamically=["0" | "1" | "true" | "false"]
 PopulateOnlyOnce=["0" | "1" | "true" | "false"]
 PopulateQueryCommand="String"
 Sequence="Integer"
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="Non Positive Integer"
 ToolTipImage32by32Top="Non Positive Integer"
 ToolTipSelectedItemTitle="String"
 ToolTipShortcutKey="String"
 ToolTipTitle="String"
  >
 <Menu />
</FlyoutAnchor>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alt

String or reference to a localized label to display as alternative text.

String

Optional

CacheMenuVersions

Indicates whether the definition for the control should be cached for better performance. Select this value if you do not select PopulateDynamically.

Boolean

Optional

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CommandMenuClose

Specifies the ID of the menu command to run when the menu closes.

String

Optional

CommandType

Allows for specifying a different type of command.

Valid values:

Value | Description
General | Not a specific type of command.
OptionSelection | A command that is generated when a user selects one option in an option group.
IgnoredByMenu | A command that is used for controls that should not close the menu when clicked.

Enumeration

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Image16by16

Specifies a 16 by 16 pixel image. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image16by16Class

Specifies the name of a CSS class to use for the 16 by 16 pixel image.

String

Optional

Image16by16Left

Specifies the number of pixels to move the 16 by 16 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

Image16by16Top

Specifies the number of pixels to move the 16 by 16 pixel image toward the top. This is represented by a negative number.

Non Positive Integer

Optional

Image32by32

Specifies a 32 by 32 pixel image. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image32by32Class

Specifies the name of a CSS class to use for the 16 by 16 pixel image.

String

Optional

Image32by32Left

Specifies the number of pixels to move the 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

Image32by32Top

Specifies the number of pixels to move the 32 by 32 pixel image toward the top. This is represented by a negative number.

Non Positive Integer

Optional

LabelText

Specifies a string to display as the text for the control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

ModernCommandType

For internal use only.

Valid values:

Value | Description
ControlCommand | For internal use only.
System | For internal use only.

Enumeration

Optional

ModernImage

For internal use only.

String

Optional

PopulateDynamically

Specifies that the menu elements that provide options for this control will be populated dynamically at run-time using the command defined by the PopulateQueryCommand attribute.

Boolean

Optional

PopulateOnlyOnce

When the control is populated dynamically, this setting indicates that the command defined by the PopulateQueryCommand attribute should only be called once.

Boolean

Optional

PopulateQueryCommand

When the control is populated dynamically, this command retrieves the menu elements that provide options for this control.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipSelectedItemTitle

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Child Elements

Element | Description
<Menu> (RibbonDiffXml) | Specifies a container used to show pop-up menus.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Remarks

If this element does not have any <Menu> elements and does not have a valid PopulateQueryCommand, the application will throw the following script error at run time: ‘attrs' is null or not an object.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/FlyoutAnchor |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Controls/FlyoutAnchor |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls/FlyoutAnchor

Schema Name

FlyoutAnchorType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FormEntityContextRule> (RibbonDiffXml)

Specifies a rule that can detect whether a form ribbon is displayed in the context of a specific entity.

Syntax

Xml
<FormEntityContextRule
 Default=["0" | "1" | "true" | "false"]
 EntityName="String"
 InvertResult=["0" | "1" | "true" | "false"]
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Default | Sets the default return value for the rule if the actual value cannot be determined. | Boolean | Optional
EntityName | Specifies the entity that this rule will apply to. Use the entity logical name, for example, "new_customentity". | String | Required
InvertResult | Negates the return value of the rule. | Boolean | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/FormEntityContextRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/FormEntityContextRule

Schema Name

FormEntityContextRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FormStateRule> (RibbonDiffXml)

Specifies a rule that can detect the state of the form.

Syntax

Xml
<FormStateRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 State=["Create" | "Existing" | "ReadOnly"  | "Disabled"  | "BulkEdit"]
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

State

Describes the type of form. These correspond to the values returned by the Xrm.Page.ui (client-side reference).getFormType method.

Valid values:

Value | Description
Create | Used before a record is saved.
Existing | Used after a record is saved and the user has access to edit it.
ReadOnly | Used to display a record that the user cannot edit.
Disabled | Used when the record is inactive and cannot be edited.
BulkEdit | Used when many records are updated at once.

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/FormStateRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/FormStateRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/FormStateRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/FormStateRule

Schema Name

FormStateRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<FormTypeRule> (RibbonDiffXml)

Specifies a rule that detects the type of Microsoft Dynamics CRM form.

Syntax

Xml
<FormTypeRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 Type=["Main" | "Preview" | "AppointmentBook" | "Dashboard" | "Quick" | "QuickCreate"]
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

Type

Specifies the type of form.

Valid values:

  • Main
  • Preview
  • AppointmentBook
  • Dashboard
  • Quick
  • QuickCreate

See Remarks.

Enumeration

Required

Child Elements

This element has no attributes.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Remarks

The Type values correspond to the following:

Value | Presentation
Main | An entity form displayed in the application.
Preview | The entity preview form displayed as an expanding element in the grid.
AppointmentBook | Used with the appointment, equipment, serviceappointment, and systemuser entities for the Service Scheduling user interface.
Dashboard | The form defines a dashboard.
Quick | A quick view form.
QuickCreate | A quick create form.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/FormTypeRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/FormTypeRule

Schema Name

FormTypeRule

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Gallery> (RibbonDiffXml)

Deprecated: Specified a control that displays a collection of related controls in the Ribbon. If there are too many items in the gallery, an expand arrow is provided to display the rest of the collection in a pane.

Important
This control was deprecated in Microsoft Dynamics CRM 2011. This control will not render with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Syntax

Xml
<Gallery
 Command="String"
 CommandPreview="String"
 CommandRevert="String"
 ElementDimensions=
 ["Size16by16" |
  "Size32by32" |
  "Size48by48" |
  "Size64by48" |
  "Size72by96" |
  "Size96by72" |
  "Size96by96" |
  "Size128by128" |
  "Size190by30" |
  "Size190by40" |
  "Size190by50" |
  "Size190by60"]
 Id="String"
 QueryCommand="String"
 Sequence="Integer"
 Width="Integer" >
 <GalleryButton />
</Gallery>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CommandPreview

Specifies the ID of the ribbon command to run when the cursor hovers over the control before it is selected.

String

Optional

CommandRevert

Specifies the ID of the ribbon command to run when the user selects undo.

String

Optional

ElementDimensions

Controls the size of a Gallery or GalleryButton element.

Valid values:

  • Size16by16
  • Size32by32
  • Size48by48
  • Size64by48
  • Size72by96
  • Size96by72
  • Size96by96
  • Size128by128
  • Size190by30
  • Size190by40
  • Size190by50
  • Size190by60

Enumeration

Required

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

QueryCommand

Specifies the name of the command to run when polling for state information.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

Width

Specifies a desired width for the control in pixels.

Integer

Required

Child Elements

Element | Description
<GalleryButton> (RibbonDiffXml) | Deprecated: Specified a button control within a gallery element.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<MenuSection> (RibbonDiffXml) | Specifies a section used to divide a menu. A menu section can have a title and contain controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Gallery |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/MenuSection/Gallery |
//Menu/MenuSection/Gallery

Schema Name

GalleryType

Validation File

RibbonWSS.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<GalleryButton> (RibbonDiffXml)

Deprecated: Specified a button control within a gallery element.

Important
This control was deprecated in Microsoft Dynamics CRM 2011. This control will not render with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Syntax

Xml
<GalleryButton
 Alt="String"
 Command="String"
 CommandPreview="String"
 CommandRevert="String"
 CommandType=["General" | "OptionSelection" | "IgnoredByMenu"]
 CommandValueId="String"
 ElementDimensions=
  ["Size16by16" |
  "Size32by32" |
  "Size48by48" |
  "Size64by48" |
  "Size72by96" |
  "Size96by72" |
  "Size96by96" |
  "Size128by128" |
  "Size190by30" |
  "Size190by40" |
  "Size190by50" |
  "Size190by60"]
 Id="String"
 Image="String"
 ImageClass="String"
 ImageLeft="Non Positive Integer"
 ImageTop="Non Positive Integer"
 InnerHTML="String"
 MenuItemId="String"
 QueryCommand="String"
 Sequence="Integer"
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="Non Positive Integer"
 ToolTipImage32by32Top="Non Positive Integer"
 ToolTipShortcutKey="String"
 ToolTipTitle="String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alt

String or reference to a localized label to display as alternative text.

String

Optional

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CommandPreview

Specifies the ID of the ribbon command to run when the cursor hovers over the control before it is selected.

String

Optional

CommandRevert

Specifies the ID of the ribbon command to run when the user selects undo.

String

Optional

CommandType

Allows for specifying a different type of command.

Valid values:

Value | Description
General | Not a specific type of command.
OptionSelection | A command that is generated when a user selects one option in an option group.
IgnoredByMenu | A command that is used for controls that should not close the menu when clicked.

Enumeration

Optional

CommandValueId

A string that is sent with the command event when the button is clicked.

String

Optional

ElementDimensions

Controls the size of a Gallery or GalleryButton element.

Valid values:

  • Size16by16
  • Size32by32
  • Size48by48
  • Size64by48
  • Size72by96
  • Size96by72
  • Size96by96
  • Size128by128
  • Size190by30
  • Size190by40
  • Size190by50
  • Size190by60

Enumeration

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Image

A server-relative URL to a file that contains an image to be used as an icon.If an Image attribute is not defined, an InnerHTML attribute must be defined.

String

Optional

ImageClass

The name of a CSS class selector to be applied to the image.

String

Optional

ImageLeft

A negative integer that represents an offset for the left edge of the image. Use this attribute when the Image attribute points to an image file that contains images for several icons.

Non positive Integer

Optional

ImageTop

A negative integer that represents an offset for the top edge of the image. Use this attribute when the Image attribute points to an image file that contains images for several icons.

Non positive Integer

Optional

InnerHTML

HTML markup that illustrates the choice that the button represents.If the InnerHTML attribute is not defined, the Image attribute must be defined.

String

Optional

MenuItemId

Specifies a reference from a control to the ID of a menu item.

String

Optional

QueryCommand

Specifies the name of the command to run when polling for state information.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non positive Integer

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Gallery> (RibbonDiffXml) | Deprecated: Specified a control that displays a collection of related controls in the Ribbon. If there are too many items in the gallery, an expand arrow is provided to display the rest of the collection in a pane.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Gallery/GalleryButton |
//Menu/MenuSection/Gallery/GalleryButton

Schema Name

GalleryButtonType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Group> (RibbonDiffXml)

Specifies a group of controls within a tab that share a common layout template.

Syntax

Xml
<Group
 Command="String"
 Description="String"
 Id="String"
 Image32by32Popup="String"
 Image32by32PopupClass="String"
 Image32by32PopupLeft="Non Positive Integer"
 Image32by32PopupTop="Non Positive Integer"
 PopupWidth ="String"
 Sequence="Integer"
 Template="String"
 Title="String" >
 <Controls />
</Group>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Command

Specifies the ID of the ribbon command for this control.

String

Optional

Description

The Description attribute is not used by Microsoft Dynamics CRM.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Image32by32Popup

Specifies the 32 by 32 pixel image displayed when a group is displayed as pop-up list in the ribbon. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image32by32PopupClass

The name of a CSS class selector to be applied to the image.

String

Optional

Image32by32PopupLeft

A negative integer that represents an offset for the left edge of the image. Use this attribute when the Image32by32Popup attribute points to an image file that contains images for many icons. The value of the Image32by32PopupLeft attribute is used to set the CSS left attribute for the inline style of an HTML img tag.

Non Positive Integer

Optional

Image32by32PopupTop

A negative integer that represents an offset for the top edge of the image. Use this attribute when the Image32by32Popup attribute points to an image file that contains images for many icons. The value of the Image32by32PopupTop attribute is used to set the CSS top attribute for the inline style of an HTML img tag.

Non Positive Integer

Optional

PopupWidth

The width of the popup to display in pixels.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

Template

A string that corresponds to the Id attribute of a <GroupTemplate> (RibbonDiffXml) element.

String

Optional

Title

The text to include in the label for the group.

String

Optional

Child Elements

Element | Description
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Groups> (RibbonDiffXml) | Contains a collection of Group elements.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Group |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Groups/Group

Schema Name

GroupType

Validation File

RibbonWSS.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Groups> (RibbonDiffXml)

Contains a collection of Group elements.

Syntax

Xml
<Groups
 Id ="String"
 >
 <Group />
</Groups>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Child Elements

Element | Description
<Group> (RibbonDiffXml) | Specifies a group of controls within a tab that share a common layout template.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Tab> (RibbonDiffXml) | Specifies a tab in the ribbon.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Groups |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ContextualGroup/Tab/Groups

Schema Name

GroupsType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<GroupTemplate> (RibbonDiffXml)

Specifies a collection of layout definitions that a group can use when the ribbon width changes.

Syntax

Xml
<GroupTemplate
 Id="String"
 ClassName="String">
 <Layout />
</GroupTemplate>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

ClassName

The name of a CSS class selector to apply to the group.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Child Elements

Element | Description
<Layout> (RibbonDiffXml) | Specifies a layout for a Group within a GroupTemplate.

Parent Elements

Element | Description
<RibbonTemplates> (RibbonDiffXml) | Contains a collection of group templates.

Element Information

XPath

Copy Code
//RibbonDiffXml/Templates/RibbonTemplates/GroupTemplate

Schema Name

GroupTemplateType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<HideCustomAction> (RibbonDiffXml)

Removes an existing ribbon element from being processed for the ribbon.

Syntax

Xml
<HideCustomAction
 HideActionId="String"
 Location="String"
 Sequence="Integer"
 Title="String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
HideActionId | A unique name for the HideCustomAction | String | Optional
Location | The id value of the element to be hidden. | String | Optional
Sequence | Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements. | Integer | Optional
Title | This element is not used in Microsoft Dynamics CRM. | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CustomActions> (RibbonDiffXml) | Contains a collection of actions that can add, replace, or remove items from the ribbon.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/HideCustomAction

Schema Name

HideCustomActionType

Validation File

RibbonCore.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<HideForTabletExperienceRule> (RibbonDiffXml)

Specifies a rule that will return false when the web application is viewed in a mobile browser on a tablet device.

Syntax

Xml
< HideForTabletExperienceRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Default | Sets the default return value for the rule if the actual value cannot be determined. | Boolean | Optional
InvertResult | Negates the return value of the rule. | Boolean | Optional

Child Elements

This element has no attributes.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/HideForTabletExperienceRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/HideForTabletExperienceRule

Schema Name

HideForTabletExperienceRule

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<InsertTable> (RibbonDiffXml)

Deprecated: Specified a 10 by 10 grid used to specify the dimensions of a table.

Important
This control was deprecated in Microsoft Dynamics CRM 2011. This control will not render with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Syntax

Xml
<InsertTable
 Alt="String"
 Command="String"
 CommandPreview="String"
 CommandRevert="String"
 CommandType=["General" | "OptionSelection" | "IgnoredByMenu"]
 Id="String"
 MenuSectionInitialTitle="String"
 MenuSectionTitle="String"
 Sequence="Integer"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alt

String or reference to a localized label to display as alternative text.

String

Optional

CommandPreview

Specifies the ID of the ribbon command to run when the cursor hovers over the control before it is selected.

String

Optional

CommandRevert

Specifies the ID of the ribbon command to run when the user selects undo.

String

Optional

CommandType

Allows for specifying a different type of command.

Valid values:

Value | Description
General | Not a specific type of command.
OptionSelection | A command that is generated when a user selects one option in an option group.
IgnoredByMenu | A command that is used for controls that should not close the menu when clicked.

Enumeration

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

MenuSectionInitialTitle

The title of the menu section before table cells are selected, such as "Insert Table".

String

Optional

MenuSectionTitle

The title of the menu section when table cells are selected. This could be a format string such as "Insert a {0} by {1} Table".

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/InsertTable |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Controls/InsertTable |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls/InsertTable

Schema Name

InsertTableType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<IntParameter> (RibbonDiffXml)

Specifies a value with an integer data type that may be passed as a parameter.

Syntax

Xml
<IntParameter
 Name="String"
 Value="String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Name | Represents the name of a query string parameter passed for this value when using a Url element. | String | See Remarks
Value | Specifies the value to be passed as a parameter. | Int | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CustomRule> (RibbonDiffXml) | Specifies a rule used with an EnableRule definition that is composed of a reference to a function within a JavaScript library.
<JavaScriptFunction> (RibbonDiffXml) | Specifies an action that calls a function from a specific JavaScript library.
<Url> (RibbonDiffXml) | An action that opens a web page at a specified address.

Remarks

When the IntParameter is a child of the <Url> (RibbonDiffXml) a Name attribute is required. When the IntParameter is a child of the <JavaScriptFunction> (RibbonDiffXml) or <CustomRule> (RibbonDiffXml)elements, the Name attribute is not valid.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/JavaScriptFunction/IntParameter |
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/Url/IntParameter |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CustomRule/IntParameter |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CustomRule/IntParameter |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/CustomRule/IntParameter |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/CustomRule/IntParameter

Schema Name

  • IntParameter
  • IntNamedParameterType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<JavaScriptFunction> (RibbonDiffXml)

Specifies an action that calls a function from a specific JavaScript library.

Syntax

Xml
<JavaScriptFunction
 FunctionName="String"
 Library="String" >
 <BoolParameter/>
 <CrmParameter />
 <DecimalParameter/>
 <IntParameter/>
 <StringParameter/>
</JavaScriptFunction>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
FunctionName | The name of the JScript function to call. This string must begin with a letter, the underscore (“_”) character, or the dollar (“$”) symbol. The remaining characters can be any combination of letters, numbers, the underscore character, the dollar symbol or periods. | String | Required
Library | The name of the JScript library Web resource that contains the function. Use the $webresource: directive when specifying the library. | String | Required

Child Elements

Element | Description
<BoolParameter> (RibbonDiffXml) | Specifies a value with a Boolean data type that may be passed as a parameter.
<CrmParameter> (RibbonDiffXml) | Represents data retrieved from the Microsoft Dynamics CRM application that may be passed as a parameter.
<DecimalParameter> (RibbonDiffXml) | Specifies a value with a decimal data type that may be passed as a parameter.
<IntParameter> (RibbonDiffXml) | Specifies a value with an integer data type that may be passed as a parameter.
<StringParameter> (RibbonDiffXml) | Specifies a value with a string data type that may be passed as a parameter.

Parent Elements

Element | Description
<Actions> (RibbonDiffXml) | Specifies the actions that a command will perform.

Remarks

If you are using this element to call a function that will use window.open to open a web resource, consider using the <Url> (RibbonDiffXml) action instead. With the <Url> action you can specify the Web resource using the $webresource Directive to specify the web resource to open. This will allow the application to specify the URL to the cached web resource and will result in better performance, particularly if the web resource is an HTML web resource that hosts a Silverlight web resource.

Note
Opening entity forms in a dialog window using showModalDialog or showModelessDialog is not supported.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/JavaScriptFunction

Schema Name

JavaScriptFunctionType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Concepts

Use JavaScript with Microsoft Dynamics CRM

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Label> (RibbonDiffXml)

Specifies a line of text used to provide information.

Syntax

Xml
<Label
 Command="String"
 ForId="String"
 Id="String"
 Image16by16="String"
 Image16by16Class="String"
 Image16by16Left="Non Positive Integer"
 Image16by16Top="Non Positive Integer"
 LabelText="String"
 ModernImage=”String”
 QueryCommand="String"
 Sequence="Integer"
 TemplateAlias="String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Command

Specifies the ID of the ribbon command for this control.

String

Optional

ForId

The ID of the control that this control labels.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Image16by16

Specifies a 16 by 16 pixel image. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image16by16Left

Specifies the number of pixels to move the 16 by 16 pixel image to the left. This is represented by a negative number.

Non positive integer

Optional

Image16by16Top

Specifies the number of pixels to move the 16 by 16 pixel image toward the top. This is represented by a negative number.

Non positive integer

Optional

LabelText

Specifies a string to display as the text for the control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

ModernImage

For internal use only.

String

Optional

QueryCommand

Specifies the name of the command to run when polling for state information.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Label

Schema Name

LabelType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Layout> (RibbonDiffXml)

Specifies a layout for a Group within a GroupTemplate.

Syntax

Xml
<Layout
 LayoutTitle="String"
 Title="String"
>
 <OverflowSection />
 <Section />
</Layout>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
LayoutTitle | An alternative identifier for the element. Use this attribute to provide a title when the value of the Title attribute is "Popup". | String | Optional
Title | This element is not used in Microsoft Dynamics CRM. | String | Required

Child Elements

Element | Description
<OverflowSection> (RibbonDiffXml) | Specifies a division of a Layout which allows controls to change relative position depending on the available space.
<Section> (RibbonDiffXml) | Contains a collection of rows.

Parent Elements

Element | Description
<GroupTemplate> (RibbonDiffXml) | Specifies a collection of layout definitions that a group can use when the ribbon width changes.

Element Information

XPath

Copy Code
//RibbonDiffXml/Templates/RibbonTemplates/GroupTemplate/Layout

Schema Name

LayoutType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<LocLabel> (RibbonDiffXml)

Specifies a text string associated with a language code.

Syntax

Xml
<LocLabel
 Id="String"
 >
 <Titles />
</LocLabel>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Id | Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button. | String | Required

Child Elements

Element | Description
<Titles> (RibbonDiffXml) | Contains a collection of title elements.

Parent Elements

Element | Description
<LocLabels> (RibbonDiffXml) | Contains a collection of LocLabel elements.

Element Information

XPath

Copy Code
//RibbonDiffXml/LocLabels/LocLabel

Schema Name

RibbonLocLabelType

Validation File

RibbonTypes.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<LocLabels> (RibbonDiffXml)

Contains a collection of LocLabel elements.

Syntax

Xml
<LocLabels >
 <LocLabel />
</LocLabels>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<LocLabel> (RibbonDiffXml) | Specifies a text string associated with a language code.

Parent Elements

Element | Description
<RibbonDiffXml> (RibbonDiffXml) | The root element for all the elements that define custom ribbons.

Element Information

XPath

Copy Code
//RibbonDiffXml/LocLabels

Schema Name

RibbonLocLabelsType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<LowScaleWarning> (RibbonDiffXml)

For internal use only.

Syntax

Xml
<LowScaleWarning
 Id="String"
 Message="String"
 Sequence="Integer"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Id | Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button. | String | Required
Message | For internal use only. | String | Optional
Sequence | Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements. | Integer | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Scaling> (RibbonDiffXml) | Contains a collection of elements used to define how ribbon groups are presented when the horizontal space available changes.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Tab/Scaling/LowScaleWarning |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ContextualGroup/Tab/Scaling/LowScaleWarning

Schema Name

LowScaleWarningType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<MaxSize> (RibbonDiffXml)

Defines the largest layout possible for a group.

Syntax

Xml
<MaxSize
 GroupId="String"
 Id="String"
 Sequence="Integer"
 Size="String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

GroupId

A string that identifies the <Group> (RibbonDiffXml) that this element pertains to.

String

Required

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

Size

Links to a specific layout with a reference to a LayoutTitle attribute value.

String

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
CommandUIDefinition | Specifies the visible Ribbon elements to be included within a CustomAction element.
Scaling | Contains a collection of elements used to define how ribbon groups are presented when the horizontal space available changes.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/MaxSize |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ContextualGroup/Tab/Scaling/MaxSize

Schema Name

MaxSizeType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Menu> (RibbonDiffXml)

Specifies a container used to show pop-up menus.

Syntax

Xml
<Menu
 Id="String"
 MaxWidth="String"
>
 <MenuSection />
</Menu>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

MaxWidth

The maximum width in pixels.

String

Optional

Child Elements

Element | Description
<MenuSection> (RibbonDiffXml) | Specifies a section used to divide a menu. A menu section can have a title and contain controls.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<ComboBox> (RibbonDiffXml) | Deprecated: Specified a list used to select a value by clicking or typing.
<FlyoutAnchor> (RibbonDiffXml) | Specifies a button with a down arrow used to open a menu.
<DropDown> (RibbonDiffXml) | Deprecated: Specified a list used to select a value by clicking.
<MRUSplitButton> (RibbonDiffXml) | Deprecated: Specified a split button control that displays Most Recently Used items.
<SplitButton> (RibbonDiffXml) | Specifies a control used as both a button and a menu.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ComboBox/Menu |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls/FlyoutAnchor/Menu |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/DropDown/Menu |
//Controls/DropDown/Menu |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/MRUSplitButton/Menu |
//Controls/MRUSplitButton/Menu |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/SplitButton/Menu |
//Controls/SplitButton/Menu

Schema Name

MenuType

Validation File

RibbonWSS.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<MenuSection> (RibbonDiffXml)

Specifies a section used to divide a menu. A menu section can have a title and contain controls.

Syntax

Xml
<MenuSection
 DisplayMode=["Default" | "Small" | "Medium"  | "Large"  | "Text"  | "Menu"  | "Menu16"  | "Menu32"  | "Thin"]
 Id="String"
 MaxHeight="String"
 Scrollable="true"
 Sequence="Integer"
 Title="String">
 [<Controls /> | <Gallery />]
</MenuSection>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

DisplayMode

Controls the mode used to display the element.

Valid values:

Value | Description
Menu | Displays the element like a menu.
Menu16 | Displays the element in a menu with a height of 16 pixels.
Menu32 | Displays the element in a menu with a height of 32 pixels.

Enumeration

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

MaxHeight

Specifies the maximum height of the section in pixels.

String

Optional

Scrollable

Specifies whether to make this section of the menu scrollable. Set to true to make scrollable. The default is false.

Boolean

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

Title

Species the label to display for the MenuSection.

String

Optional

Child Elements

Element | Description
<Controls> (RibbonDiffXml) | Contains a collection of controls.
<Gallery> (RibbonDiffXml) | Deprecated: Specified a control that displays a collection of related controls in the Ribbon. If there are too many items in the gallery, an expand arrow is provided to display the rest of the collection in a pane.

Parent Elements

Element | Description
<Menu> (RibbonDiffXml) | Specifies a container used to show pop-up menus.

Remarks

You may get the following error “MenuSections can only have children of type MenuItem, Gallery or GroupPopup.” when viewing a Ribbon that has a MenuSection DisplayMode attribute value set to the following values: Default, Small, Medium, Large, Text, Thin. While according to the RibbonWSS.xsd these are valid values, they should not be used.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ComboBox/Menu/MenuSection

Schema Name

MenuSectionType

Validation File

RibbonWSS.xsd

Can be Empty

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<MiscellaneousPrivilegeRule> (RibbonDiffXml)

Specifies a rule that can detect whether the user possesses a specific Microsoft Dynamics CRM privilege.

Syntax

Xml
<MiscellaneousPrivilegeRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 PrivilegeDepth=["None" | "Basic" | "Local"  | "Deep"  | "Global"]
 PrivilegeName="String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

PrivilegeDepth

The Privilege Depth to check.

Valid values:

Value | Description
Basic | This access level exposes to a user entity instances he or she owns, objects that are shared with the user, and objects that are shared with a team of which the user is a member. The application refers to this access level as User.
Local | This access level exposes to a user entity instances in the user's business unit. The application refers to this access level as Business Unit.
Deep | This access level exposes to a user entity instances in the user's business unit and all business units subordinate to the user's business unit. The application refers to this access level as Parent: Child Business Units.
Global | This access level exposes to a user all entity instances within the organization, regardless of the business unit hierarchical level to which the instance or the user belongs. The application refers to this access level as Organization.

Enumeration

Optional

PrivilegeName

The name of the privilege to evaluate. See Remarks.

String

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Remarks

The string used to specify the privilege not associated with an entity. The PrivilegeName must correspond to a valid privilege name. See Privileges not associated with an entity. The privileges listed in that table include the prefix ‘prv’. Remove that prefix and use the remaining privilege name. For example, for the privilege name prvCreateEntity, just use CreateEntity.

For privileges associated with an entity use <EntityPrivilegeRule> (RibbonDiffXml).

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/MiscellaneousPrivilegeRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/MiscellaneousPrivilegeRule

Schema Name

MiscellaneousPrivilegeRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<MRUSplitButton> (RibbonDiffXml)

Deprecated: Specified a split button control that displays Most Recently Used items.

Important
This control was deprecated in Microsoft Dynamics CRM 2011. This control will not render with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Use the <SplitButton> (RibbonDiffXml) instead.

Syntax

Xml
<MRUSplitButton
 Alt="String"
 CacheMenuVersions=["0" | "1" | "true" | "false"]
 Command="String"
 CommandMenuClose="String"
 CommandMenuOpen="Strimg"
 CommandPreview="String"
 CommandPreviewRevert="String"
 Id="String"
 InitialItem="String"
 MenuAlt="String"
 MenuCommand="String"
 PopulateDynamically=["0" | "1" | "true" | "false"]
 PopulateOnlyOnce=["0" | "1" | "true" | "false"]
 PopulateQueryCommand="String"
 QueryCommand="String"
 Sequence="Integer"
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="Non Positive Integer"
 ToolTipImage32by32Top="Non Positive Integer"
 ToolTipSelectedItemTitle="String"
 ToolTipShortcutKey="String"
 ToolTipTitle="String"
>
 <Menu />
</MRUSplitButton>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alt

String or reference to a localized label to display as alternative text.

String

Optional

CacheMenuVersions

Indicates whether the definition for the control should be cached for better performance. Select this value if you do not select PopulateDynamically.

Boolean

Default = false.

Optional

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CommandMenuClose

Specifies the ID of the menu command to run when the menu closes.

String

Optional

CommandMenuOpen

Specifies the ID of the ribbon command to run when the menu opens.

String

Optional

CommandPreview

Specifies the ID of the ribbon command to run when the cursor hovers over the control before it is selected.

String

Optional

CommandPreviewRevert

Specifies the ID of the ribbon command to run when the control loses focus after preview.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

InitialItem

Specifies the initial menu to display in the control.

String

Optional

See Remarks

MenuAlt

Alternative text to represent the menu.

String

Optional

MenuCommand

The name of the command to execute when the menu is clicked.

String

Optional

PopulateDynamically

Specifies that the menu elements that provide options for this control will be populated dynamically at run-time using the command defined by the PopulateQueryCommand attribute.

Boolean

Default = false.

Optional

PopulateOnlyOnce

When the control is populated dynamically, this setting indicates that the command defined by the PopulateQueryCommand attribute should only be called once.

Boolean

Default = false.

Optional

PopulateQueryCommand

When the control is populated dynamically, this command retrieves the menu elements that provide options for this control.

String

Optional

QueryCommand

For internal use only.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non positive Integer

Optional

ToolTipSelectedItemTitle

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Child Elements

Element | Description
<Menu> (RibbonDiffXml) | Specifies a container used to show pop-up menus.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Remarks

If the InitialItem attribute refers to a Id that does not exist at runtime and error will occur.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/MRUSplitButton |
//Controls/MRUSplitButton

Schema Name

MRUSplitButtonType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<OptionSetRule> (RibbonDiffXml)

For internal use only.

Syntax

Xml
<OptionSetRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 OptionSet = "String"
 StateCode = "String"
 ObjectTypeCode = "String"
/>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Default | Sets the default return value for the rule if the actual value cannot be determined. | Boolean | Optional
InvertResult | Negates the return value of the rule. | Boolean | Optional
OptionSet | For internal use only. | String | Required
StateCode | For internal use only. | String | Required
ObjectTypeCode | For internal use only. | String | Required

Child Elements

This element has no attributes.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Remarks

Use <ValueRule> (RibbonDiffXml) instead of this.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OptionSetRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/OptionSetRule

Schema Name

OptionSetRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Or> (RibbonDiffXml)

Specifies a set of rules that must be evaluated together.

Syntax

Xml
<OrRule>
 <Or >
  <CommandClientTypeRule />
  <CrmClientTypeRule />
  <CrmOfflineAccessStateRule/>
  <CrmOutlookClientTypeRule/>
  <CrmOutlookClientVersionRule/>
  <EntityPrivilegeRule/>
  <EntityPropertyRule/>
  <EntityRule/>
  <FormEntityContextRule/>
  <FormStateRule/>
  <MiscellaneousPrivilegeRule/>  <OptionsSetRule />
  <OrganizationSettingRule/>
  <OutlookRenderTypeRule/>
  <OutlookVersionRule/>
  <PageRule/>
  <ReferencingAttributeRequiredRule/>
  <RelationshipTypeRule/>
  <SkuRule/>
  <ValueRule/>
 </Or>
</OrRule>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<CommandClientTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of presentation being used.
<CrmClientTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of Microsoft Dynamics CRM client.
<CrmOutlookClientTypeRule> (RibbonDiffXml) | Specifies a rule that detects the type of Microsoft Dynamics CRM for Microsoft Office Outlook client.
<CrmOfflineAccessStateRule> (RibbonDiffXml) | Specifies a rule that can be used to detect whether Microsoft Dynamics CRM for Outlook with Offline Access is currently operating offline.
<CustomRule> (RibbonDiffXml) | Specifies a rule used with an EnableRule definition that is composed of a reference to a function within a JavaScript library. When descendant of <EnableRule> (RibbonDiffXml).
<EntityRule> (RibbonDiffXml) | Specifies a rule that can detect whether a specific entity is in context.
<EntityPrivilegeRule> (RibbonDiffXml) | Specifies a rule that can detect the current user's permissions for a specific entity. When descendant of <DisplayRule> (RibbonDiffXml).
<EntityPropertyRule> (RibbonDiffXml) | Specifies a rule that can detect specific Boolean entity properties. When descendant of <DisplayRule> (RibbonDiffXml).
<FormEntityContextRule> (RibbonDiffXml) | Specifies a rule that can detect whether a form ribbon is displayed in the context of a specific entity. When descendant of <DisplayRule> (RibbonDiffXml).
<FormStateRule> (RibbonDiffXml) | Specifies a rule that can detect the state of the form.
<MiscellaneousPrivilegeRule> (RibbonDiffXml) | Specifies a rule that can detect whether the user possesses a specific Microsoft Dynamics CRM privilege. When descendant of <DisplayRule> (RibbonDiffXml).
<OptionSetRule> (RibbonDiffXml) | For internal use only.
<OrganizationSettingRule> (RibbonDiffXml) | A rule that can detect two specific organization settings within a DisplayRule. When descendant of <DisplayRule> (RibbonDiffXml).
<OutlookRenderTypeRule> (RibbonDiffXml) | A rule that can detect whether a form or list item is rendered as a web page or natively in Outlook in order to determine if a ribbon element should be displayed. When descendant of <DisplayRule> (RibbonDiffXml).
<OutlookItemTrackingRule> (RibbonDiffXml) | A rule that detects whether the item is enabled for items tracked in Microsoft Dynamics CRM in order to enable a ribbon element. When descendant of <EnableRule> (RibbonDiffXml).
<OutlookVersionRule> (RibbonDiffXml) | A rule that detects the version of Microsoft Office Outlook client.
<PageRule> (RibbonDiffXml) | A rule that evaluates the address of the current page.
<RecordPrivilegeRule> (RibbonDiffXml) | A rule that detects a user’s privileges for a specific record in order to enable a ribbon element. When descendant of <EnableRule> (RibbonDiffXml).
<ReferencingAttributeRequiredRule> (RibbonDiffXml) | A rule that detects whether the referencing attribute for an entity is required. When descendant of <DisplayRule> (RibbonDiffXml).
<RelationshipTypeRule> (RibbonDiffXml) | A rule that detects whether the referencing attribute for an entity is required. When descendant of <DisplayRule> (RibbonDiffXml).
<SelectionCountRule> (RibbonDiffXml) | A rule that detects how many items in a grid are selected. When descendant of <EnableRule> (RibbonDiffXml).
<SkuRule> (RibbonDiffXml) | A rule that detects the Microsoft Dynamics CRM edition.
<ValueRule> (RibbonDiffXml) | A rule that detects the value of a specific field.

Parent Elements

Element | Description
<OrRule> (RibbonDiffXml) | A rule that contains a collection of rules so that this rule will evaluate as true if any of the rules in the collection evaluates as true.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or

Schema Name

  • OrEnableRuleType/Or
  • OrDisplayRuleType/Or

Validation File

RibbonTypes.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<OrganizationSettingRule> (RibbonDiffXml)

A rule that can detect two specific organization settings within a DisplayRule.

Syntax

Xml
<OrganizationSettingRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 Setting=["IsSharepointEnabled" |"IsSOPIntegrationEnabled" | "IsFiscalCalendarDefined"]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

Setting

Specifies that a ribbon element should be displayed only if specific organization settings are enabled.

Valid values:

Value | Description
IsSharepointEnabled | The organization is using SharePoint integration.
IsSOPIntegrationEnabled | The organization setting to enable Sales Order Processing is set. This indicates that Microsoft CRM is integrated with a system to connect quotes, orders, and invoices with an inventory or financial accounting system.
IsFiscalCalendarDefined | Indicates that a Fiscal Calendar is defined. A Fiscal Calendar is a prerequisite for features like quotas.

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrganizationSettingRule

Schema Name

OrganizationSettingRuleType

Validation File

RibbonTypes

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<OrRule> (RibbonDiffXml)

A rule that contains a collection of rules so that this rule will evaluate as true if any of the rules in the collection evaluates as true.

Syntax

Xml
<OrRule>
 <Or />
</OrRule>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule

Schema Name

  • OrDisplayRuleType
  • OrEnableRuleType

Validation File

RibbonTypes.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<OutlookCommand> (RibbonDiffXml)

For internal use only.

Syntax

  Attributes and Elements
Attributes
Child Elements
Parent Elements
  Element Information

  See Also
Other Resources
Ribbon XML reference
Customize commands and the ribbon

    Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<OutlookItemTrackingRule> (RibbonDiffXml)

A rule that detects whether the item is enabled for items tracked in Microsoft Dynamics CRM in order to enable a ribbon element.

Syntax

Xml
<OutlookItemTrackingRule
 AppliesTo="PrimaryEntity"
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 TrackedInCrm=["0" | "1" | "true" | "false"]
 />

Attributes and Elements

The following describes thee attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AppliesTo

Determines whether the rule applies to the entity record being displayed in the form or entity records being displayed in a sub-grid.

Valid values:

Value | Description
PrimaryEntity | For a form or Subgrid ribbon, the rule applies to the entity displayed in the form. This will option does not apply for a Grid Ribbon.

Enumeration

Optional

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

TrackedInCrm

Whether the item is tracked inMicrosoft Dynamics CRM.

Boolean

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OutlookItemTrackingRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/OutlookItemTrackingRule

Schema Name

OutlookItemTrackingRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<OutlookRenderTypeRule> (RibbonDiffXml)

A rule that can detect whether a form or list item is rendered as a web page or natively in Outlook in order to determine if a ribbon element should be displayed.

Syntax

Xml
<OutlookRenderTypeRule
 Default =["0" | "1" | "true" | "false"]
 InvertResult =["0" | "1" | "true" | "false"]
 Type=["Web" | "Outlook"]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

Type

Specifies the type of section.

Valid values:

Value | Definition
Web | The form or list item is rendered as a webpage.
Outlook | Specifies that the form or list item is rendered natively in Outlook.

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OutlookRenderTypeRule

Schema Name

OutlookRenderTypeRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<OutlookVersionRule> (RibbonDiffXml)

A rule that detects the version of Microsoft Office Outlook client.

Syntax

Xml
<OutlookVersionRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 Version=["2003" | "2007" | "2010"]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

Version

The version of Microsoft Outlook to check.

Valid values:

  • 2003
  • 2007
  • 2010

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OutlookVersionRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/OutlookVersionRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OutlookVersionRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/OutlookVersionRule

Schema Name

OutlookVersionRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<OverflowArea> (RibbonDiffXml)

Defines an area where multiple controls can render as a list.

Syntax

Xml
<OverflowArea
 DisplayMode=["Default" | "Small" | "Medium" | "Large" | "Text" | "Menu" | "Menu16" | "Menu32" | "Thin"]
 TemplateAlias="String"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

DisplayMode

Controls the mode used to display the element.

Valid values:

Value | Description
Default | Displays the element using the default mode.
Small | Displays the element in small mode.
Medium | Displays the element in medium mode.
Large | Displays the element in large mode.
Text | Displays the element in text mode.
Menu | Displays the element like a menu.
Menu16 | Displays the element in a menu with a height of 16 pixels.
Menu32 | Displays the element in a menu with a height of 32 pixels.
Thin | Displays the element in thin mode.

Enumeration

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Row> (RibbonDiffXml) | Specifies a row within a Section.

Element Information

XPath

Copy Code
//RibbonDiffXml/Templates/RibbonTemplates/GroupTemplate/Layout/Section/Row/OverflowArea

Schema Name

OverflowAreaType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<OverflowSection> (RibbonDiffXml)

Specifies a division of a Layout which allows controls to change relative position depending on the available space.

Syntax

Xml
<OverflowSection
 DisplayMode=["Default" | "Small" | "Medium" | "Large" | "Text" | "Menu" | "Menu16" | "Menu32" | "Thin"]
 DividerAfter=["0" | "1" | "true" | "false"]
 DividerBefore=["0" | "1" | "true" | "false"]
 TemplateAlias="String"
 Type=["Divider" | "OneRow" | "TwoRow" | "ThreeRow"]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

DisplayMode

Controls the mode used to display the element.

Valid values:

Value | Description
Default | Displays the element using the default mode.
Small | Displays the element in small mode.
Medium | Displays the element in medium mode.
Large | Displays the element in large mode.
Text | Displays the element in text mode.
Menu | Displays the element like a menu.
Menu16 | Displays the element in a menu with a height of 16 pixels.
Menu32 | Displays the element in a menu with a height of 32 pixels.
Thin | Displays the element in thin mode.

Enumeration

Optional

DividerAfter

TRUE to render a divider at the end of the section.

Boolean

Optional

DividerBefore

TRUE to render a divider at the start of the section.

Boolean

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

Type

Specifies the type of section.

Valid values:

Value | Description
Divider | The section acts as a divider between sections.
OneRow | The section will display one row.
TwoRow | The section will display two rows.
ThreeRow | The section will display three rows.

Enumeration

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Layout> (RibbonDiffXml) | Specifies a layout for a Group within a GroupTemplate.

Element Information

XPath

Copy Code
//RibbonDiffXml/Templates/RibbonTemplates/GroupTemplate/Layout/OverflowSection

Schema Name

OverflowSectionType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<PageRule> (RibbonDiffXml)

A rule that evaluates the address of the current page.

Syntax

Xml
<PageRule
 Address="String"
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Address | The address of the page to evaluate. It should be a relative path to the page. Only Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update pages can be evaluated. | String | Required
Default | Sets the default return value for the rule if the actual value cannot be determined. | Boolean | Optional
InvertResult | Negates the return value of the rule. | Boolean | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<TabDisplayRule> (RibbonDiffXml) | Specifies conditions when a tab will display.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Remarks

Only Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update pages can be evaluated to apply a page rule. External pages or HTML Web resources cannot be used.

This rule cannot be used with Microsoft Dynamics CRM for tablets because it will always refer to the same page.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/TabDisplayRules/TabDisplayRule/PageRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/PageRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/PageRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/PageRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/PageRule

Schema Name

PageRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RecordPrivilegeRule> (RibbonDiffXml)

A rule that detects a user’s privileges for a specific record in order to enable a ribbon element.

Syntax

Xml
<RecordPrivilegeRule
 AppliesTo="PrimaryEntity"
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 PrivilegeType=[ "Create" | "Read"  | "Write" | "Delete" | "Assign" | "Share" | "Append" | "AppendTo" ]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AppliesTo

Determines whether the rule applies to the entity record being displayed in the form or entity records being displayed in a sub-grid.

Valid values:

Value | Description
PrimaryEntity | For a form or Subgrid ribbon, the rule applies to the entity displayed in the form. This will option does not apply for a Grid Ribbon.

Enumeration

Optional

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

PrivilegeType

Describes the type of operation for the privilege.

Valid values:

Value | Description
Create | To create new entity instances for this entity.
Read | To view a records of this entity.
Write | To update an entity instance.
Delete | To delete a record for this entity.
Assign | To change the owner of user-owned instances of an entity.
Share | To assign specific privileges to another user for an entity instance.
Append | To associate a selected entity instance to another entity instance.
AppendTo | To associate an entity instance to this entity instance.

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/RecordPrivilegeRule
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/RecordPrivilegeRule

Schema Name

RecordPrivilegeRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ReferencingAttributeRequiredRule> (RibbonDiffXml)

A rule that detects whether the referencing attribute for an entity is required.

Syntax

Xml
<ReferencingAttributeRequiredRule
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Default | Sets the default return value for the rule if the actual value cannot be determined. | Boolean | Optional
InvertResult | Negates the return value of the rule. | Boolean | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Remarks

This is a very specific rule for a very specific case. Use this rule when there is a relationship bound subgrid or an associated grid on the page. This rule will test whether the referencing attribute used in the relationship is required. This rule is used to hide the Add Existing <record type> button when it isn’t appropriate to display it.

In an entity relationship the lookup field in the related record (the referencing attribute) may be required or not. For example, the Regarding field of an activity is not required yet the Potential Customer field of an opportunity is required. The Add Existing Activity button will set the Regarding field value to the current record context and it can only work if the Regarding field doesn’t already have a value. All Opportunity records have a value in their Potential Customer field, so it never makes sense to display an Add Existing Opportunity button. This rule detects that the referencing attribute is required and therefore returns true.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/ReferencingAttributeRequiredRule
|
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/ReferencingAttributeRequiredRule

Schema Name

ReferencingAttributeRequiredRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RelationshipTypeRule> (RibbonDiffXml)

A rule that detects whether a specific type of formal entity relationship exists between two entities.

Syntax

Xml
<RelationshipTypeRule
 AllowCustomRelationship=["0" | "1" | "true" | "false"]
 AllowSystemRelationship=["0" | "1" | "true" | "false"]
 AppliesTo="SelectedEntity"
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 RelationshipType=["OneToMany" | "ManyToMany" | "NoRelationship"]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AppliesTo

Determines whether the rule applies to the entity record being displayed in the form or entity records being displayed in a sub-grid.

Valid values:

Value | Description
SelectedEntity | For a Grid or Subgrid ribbon this rule applies to the entity that appears in the grid.

Enumeration

Required

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

RelationshipType

Describes the type of entity relationship to check.

Valid values:

Value | Description
OneToMany | In a 1:N (One-to-Many) entity relationship one entity has a lookup attribute that allows an entity object to store a reference to another entity object for a particular entity.
ManyToMany | A N:N (Many-To-Many) entity relationship allows for a formal entity relationship where each entity can display an associated view of another entity or even a self-referencing relationship. N:N relationships use an Intersect Entity that stores entity object ids so that they can be associated.
NoRelationship | There is no entity relationship defined between the entities.

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/RelationshipTypeRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/RelationshipTypeRule

Schema Name

RelationshipTypeRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RibbonDiffXml> (RibbonDiffXml)

The root element for all the elements that define custom ribbons.

Syntax

Xml
<RibbonDiffXml>
 <CustomActions />
 <Templates />
 <CommandDefinitions />
 <RuleDefinitions />
 <LocLabels />
</RibbonDiffXml>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<CustomActions> (RibbonDiffXml) | Contains a collection of actions that can add, replace, or remove items from the ribbon.
<Templates> (RibbonDiffXml) | Contains a collection of ribbon templates.
<CommandDefinitions> (RibbonDiffXml) | Contains a collection of commands that can be referenced by ribbon controls.
<RuleDefinitions> (RibbonDiffXml) | Contains a collection of rule definitions.
<LocLabels> (RibbonDiffXml) | Contains a collection of LocLabel elements.
<RibbonNotSupported> (RibbonDiffXml) | An element included with the RibbbonDiffXml for an entity to indicate that the entity does not support the ribbon.

Parent Elements

Element | Description
ImportExportXml | The root element of the customizations.xml file. Parent element for application ribbons.
Entity | The root element for entity definitions. Parent element for entity ribbons.
<form> (FormXml) | The root element for a form. Parent element for form ribbons.

Element Information

XPath

Copy Code
/ImportExportXml/RibbonDiffXml |
/ImportExportXml/Entities/Entity/RibbonDiffXml |
/ImportExportXml/Entities/Entity/FormXml/forms/systemform/form/RibbonDiffXml

Schema Name

  • RibbonGlobalDiffXmlType
  • RibbonEntityDiffXmlType

Validation File

RibbonCore.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RibbonNotSupported> (RibbonDiffXml)

An element included with the RibbbonDiffXml for an entity to indicate that the entity does not support the ribbon.

Syntax

Xml
<RibbonNotSupported />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<RibbonDiffXml> (RibbonDiffXml) | The root element for all the elements that define custom ribbons.

Remarks

This element is included with the definition of entities that do not support the ribbon.

Example

Xml Copy Code
<RibbonDiffXml>
 <RibbonNotSupported />
</RibbonDiffXml>

Element Information

XPath

Copy Code
/ImportExportXml/Entities/Entity/RibbonDiffXml/RibbonNotSupported

Schema Name

RibbonNotSupported

Validation File

RibbonCore.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RibbonTemplates> (RibbonDiffXml)

Contains a collection of group templates.

Syntax

Xml
<RibbonTemplates
 Id="String">
 <GroupTemplate />
</RibbonTemplates>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Id | Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button. | String | Required

Child Elements

Element | Description
<GroupTemplate> (RibbonDiffXml) | Specifies a collection of layout definitions that a group can use when the ribbon width changes.

Parent Elements

Element | Description
<Templates> (RibbonDiffXml) | Contains a collection of ribbon templates.

Element Information

XPath

Copy Code
//RibbonDiffXml/Templates/RibbonTemplates

Schema Name

RibbonTemplatesType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Row> (RibbonDiffXml)

Specifies a row within a Section.

Syntax

Xml
<Row>
 <ControlRef />
 <OverflowArea />
 <Strip />
</Row>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<ControlRef> (RibbonDiffXml) | Specifies a placeholder for a control within a layout template.
<OverflowArea> (RibbonDiffXml) | Defines an area where multiple controls can render as a list.
<Strip> (RibbonDiffXml) | Contains a collection of control references.

Parent Elements

Element | Description
<Section> (RibbonDiffXml) | Contains a collection of rows.

Element Information

XPath

Copy Code
//RibbonDiffXml/Templates/RibbonTemplates/GroupTemplate/Layout/Section/Row

Schema Name

RowType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<RuleDefinitions> (RibbonDiffXml)

Contains a collection of rule definitions.

Syntax

Xml
<RuleDefinitions>
  <TabDisplayRules />
  <DisplayRules />
  <EnableRules />
</RuleDefinitions>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<TabDisplayRules> (RibbonDiffXml) | Contains a collection of TabDisplayRule elements.
<DisplayRules> (RibbonDiffXml) | Contains a collection of display rules.
<EnableRules> (RibbonDiffXml) | Contains a collection of enable rules.

Parent Elements

Element | Description
<RibbonDiffXml> (RibbonDiffXml) | The root element for all the elements that define custom ribbons.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions

Schema Name

  • RuleDefinitionsGlobalType
  • RuleDefinitionsEntityType

Validation File

RibbonTypes.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Scale> (RibbonDiffXml)

Specifies one of the possible layouts that may be used by a group when the maximum size layout cannot be displayed.

Syntax

Xml
<Scale
 GroupId="String"
 Id="String"
 PopupSize="String"
 Sequence="Integer"
 Size="String"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

GroupId

A string that identifies the <Group> (RibbonDiffXml)that this scale applies to.

String

Required

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

PopupSize

A string that corresponds to the value of the Title attribute of a <Layout> (RibbonDiffXml) element that defines the size.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

Size

Links to a specific layout with a reference to a LayoutTitle attribute value.

String

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Scaling> (RibbonDiffXml) | Contains a collection of elements used to define how ribbon groups are presented when the horizontal space available changes.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ContextualGroup/Tab/Scaling/Scale |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Tab/Scaling/Scale |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Scaling/Scale |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Scale

Schema Name

ScaleType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Scaling> (RibbonDiffXml)

Contains a collection of elements used to define how ribbon groups are presented when the horizontal space available changes.

Syntax

Xml
<Scaling
 Id="String"
 >
 <MaxSize/>
 <Scale/>
 <LowScaleWarning />
</Scaling>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Child Elements

Element | Description
<MaxSize> (RibbonDiffXml) | Defines the largest layout possible for a group.
<Scale> (RibbonDiffXml) | Specifies one of the possible layouts that may be used by a group when the maximum size layout cannot be displayed.
<LowScaleWarning> (RibbonDiffXml) | For internal use only.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Tab> (RibbonDiffXml) | Specifies a tab in the ribbon.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ContextualGroup/Tab/Scaling |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Tab/Scaling |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Scaling

Schema Name

ScalingType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Section> (RibbonDiffXml)

Contains a collection of rows.

Syntax

Xml
<Section
 Alignment=["Top" | "Middle"]
 Type=["Divider" | "OneRow" | "TwoRow" | "ThreeRow"]
 >
 <Row />
</Section>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alignment

Specifies the vertical alignment of controls within the section.

Valid values:

Value | Description
Top | The rows should be aligned to the top.
Middle | The rows should be aligned to the middle.

Enumeration

Optional

Type

Specifies the type of section.

Valid values:

Value | Description
Divider | The section acts as a divider between sections.
OneRow | The section will display one row.
TwoRow | The section will display two rows.
ThreeRow | The section will display three rows.

Enumeration

Optional

Child Elements

Element | Description
<Row> (RibbonDiffXml) | Specifies a row within a Section.

Parent Elements

Element | Description
<Layout> (RibbonDiffXml) | Specifies a layout for a Group within a GroupTemplate.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/GroupTemplate/Layout/Section

Schema Name

SectionType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SelectionCountRule> (RibbonDiffXml)

A rule that detects how many items in a grid are selected.

Syntax

Xml
<SelectionCountRule
 AppliesTo=["PrimaryEntity" | "SelectedEntity"]
 Default=["0" | "1" | "true" | "false"]
 InvertResult=["0" | "1" | "true" | "false"]
 Maximum="Integer"
 Minimum="Integer"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AppliesTo

Determines whether the rule applies to the entity record being displayed in the form or entity records being displayed in a sub-grid.

Valid values:

Value | Description
PrimaryEntity | For a form or Subgrid ribbon, the rule applies to the entity displayed in the form. This will option does not apply for a Grid Ribbon.
SelectedEntity | For a Grid or Subgrid ribbon this rule applies to the entity that appears in the grid.

Enumeration

Optional

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

Maximum

The maximum number of selected elements.

Integer

Optional

Minimum

The minimum number of selected elements.

Integer

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/SelectionCountRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/SelectionCountRule

Schema Name

SelectionCountRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SkuRule> (RibbonDiffXml)

A rule that detects the Microsoft Dynamics CRM edition.

Syntax

Xml
<SkuRule
 Default =["0" | "1" | "true" | "false"]
 InvertResult =["0" | "1" | "true" | "false"]
 Sku =[" OnPremise" | " Online" | " Spla"]
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Default

Sets the default return value for the rule if the actual value cannot be determined.

Boolean

Optional

InvertResult

Negates the return value of the rule.

Boolean

Optional

Sku

The version of Microsoft Dynamics CRM 2015 to check.

Valid values:

Value | Description
OnPremise | Microsoft Dynamics CRM 2015.
Online | Microsoft Dynamics CRM Online. The edition of Microsoft Dynamics CRM 2015 hosted by Microsoft.
Spla | Microsoft Dynamics CRM 2015 Service Provider License Agreement. An edition of Microsoft Dynamics CRM 2015 hosted by Microsoft Partners.

Enumeration

Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/SkuRule
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/SkuRule
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/SkuRule
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/SkuRule

Schema Name

SkuRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Spinner> (RibbonDiffXml)

Specifies a control used to insert a value by typing or using the arrow keys to cycle through the values.

Syntax

Xml
<Spinner
 AccelerationInterval="Integer"
 AltDownArrow="String"
 AltUpArrow="String"
 Command="String"
 DefaultUnit="String"
 DefaultValue="Decimal"
 Id="String"
 ImeEnabled=["0" | "1" | "true" | "false"]
 MultiplierInterval="Integer"
 QueryCommand="String"
 Sequence="Integer"
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="Non Positive Integer"
 ToolTipImage32by32Top="Non Positive Integer"
 ToolTipShortcutKey="String"
 ToolTipTitle="String" >
 <Unit />
</Spinner>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

AccelerationInterval

Specifies how much the value increases or decreases when you maintain focus on the up or down button.

Integer

Optional

AltDownArrow

Alternative text that is used for the decrement arrow.

String

Optional

AltUpArrow

Alternative text that is used for the increment arrow.

String

Optional

Command

Specifies the ID of the ribbon command for this control.

String

Optional

DefaultUnit

The name or abbreviation for the default <Unit> (RibbonDiffXml).

String

Optional

DefaultValue

Specifies the initial numeric value that is displayed in the control.

Decimal

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

ImeEnabled

Specifies whether the active state of an Input Method Editor (IME) is enabled. An IME lets you enter and edit Chinese, Japanese, and Korean characters. IMEs can be in an active or inactive state. The active state accepts Chinese, Japanese, or Korean characters. The inactive state behaves like a regular keyboard and uses a limited set of characters.

Boolean

Optional

MultiplierInterval

Specifies a factor by which to increase the speed of incrementing or decrementing the value when focus is maintained on the up or down arrow.

Integer

Optional

QueryCommand

Specifies the name of the command to run when polling for state information.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non positive Integer

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Child Elements

Element | Description
<Unit> (RibbonDiffXml) | Specifies a unit in a spinner control.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Spinner
//Controls/Spinner

Schema Name

SpinnerType

Validation File

RibbonWSS.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<SplitButton> (RibbonDiffXml)

Specifies a control used as both a button and a menu.

Syntax

Xml
<SplitButton
 Alt="String"
 CacheMenuVersions="true"
 Command="String"
 CommandMenuClose="String"
 CommandMenuOpen="String"
 CommandType="General"
 Id="String"
 Image16by16="String"
 Image16by16Class="String"
 Image16by16Left="Non Positive Integer"
 Image16by16Top="Non Positive Integer"
 Image32by32="String"
 Image32by32Class="String"
 Image32by32Left="Non Positive Integer"
 Image32by32Top="Non Positive Integer"
 LabelText="String"
 MenuAlt="String"
 MenuCommand="String"
 ModernImage=”String”
 PopulateDynamically=["0" | "1" | "true" | "false"]
 PopulateOnlyOnce=["0" | "1" | "true" | "false"]
 PopulateQueryCommand="String"
 Sequence="Integer"
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="Non Postive Integer"
 ToolTipImage32by32Top="Non Postive Integer"
 ToolTipSelectedItemTitle="String"
 ToolTipShortcutKey="String"
 ToolTipTitle="String"
 >
 <Menu />
</SplitButton>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alt

String or reference to a localized label to display as alternative text.

String

Optional

CacheMenuVersions

Indicates whether the definition for the control should be cached for better performance. Select this value if you do not select PopulateDynamically.

String

Optional

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CommandMenuClose

Specifies the ID of the menu command to run when the menu closes.

String

Optional

CommandMenuOpen

Specifies the ID of the ribbon command to run when the menu opens.

String

Optional

CommandType

Allows for specifying a different type of command.

Valid values:

Value | Description
General | Not a specific type of command.
OptionSelection | A command that is generated when a user selects one option in an option group.
IgnoredByMenu | A command that is used for controls that should not close the menu when clicked.

Enumeration

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you are defining a ribbon element that will be used for multiple entities. This will insert the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity the Id will be MyISV.contact.form.SendToOtherSystem.Button

Important
Failing to set a globally unique Id value can cause the ribbon not to display.

String

Required

Image16by16

Specifies a 16 by 16 pixel image. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image16by16Class

Specifies the name of a CSS class to use for the 16 by 16 pixel image.

String

Optional

Image16by16Left

Specifies the number of pixels to move the 16 by 16 pixel image to the left. This is represented by a negative number.

Non positive Integer

Optional

Image16by16Top

Specifies the number of pixels to move the 16 by 16 pixel image toward the top. This is represented by a negative number.

Non positive Integer

Optional

Image32by32

Specifies a 32 by 32 pixel image. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image32by32Class

Specifies the name of a CSS class to use for the 16 by 16 pixel image.

String

Optional

Image32by32Left

Specifies the number of pixels to move the 32 by 32 pixel image to the left. This is represented by a negative number.

Non positive Integer

Optional

Image32by32Top

Specifies the number of pixels to move the 32 by 32 pixel image toward the top. This is represented by a negative number.

Non positive Integer

Optional

LabelText

Specifies a string to display as the text for the control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

MenuAlt

Alternative text to represent the menu.

String

Optional

MenuCommand

The name of the command to execute when the menu is clicked.

String

Optional

ModernImage

For internal use only.

String

Optional

PopulateDynamically

Specifies that the menu elements that provide options for this control will be populated dynamically at run-time using the command defined by the PopulateQueryCommand attribute.

Boolean

Default = false.

Optional

PopulateOnlyOnce

When the control is populated dynamically, this setting indicates that the command defined by the PopulateQueryCommand attribute should only be called once.

Boolean

Default = false.

Optional

PopulateQueryCommand

When the control is populated dynamically, this command retrieves the menu elements that provide options for this control.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non positive Integer

Optional

ToolTipSelectedItemTitle

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Child Elements

Element | Description
<Menu> (RibbonDiffXml) | Specifies a container used to show pop-up menus.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Remarks

If this element does not have any <Menu> elements and does not have a valid PopulateQueryCommand, the application will throw the following script error at run time: ‘attrs' is null or not an object.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/SplitButton |
//Controls/SplitButton

Schema Name

SplitButtonType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<StringParameter> (RibbonDiffXml)

Specifies a value with a string data type that may be passed as a parameter.

Syntax

Xml
<StringParameter
 Name="String"
 Value="String"
/>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Name | Represents the name of a query string parameter passed for this value when using a Url element. | String | See Remarks
Value | Specifies the value to be passed as a parameter. | String | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CustomRule> (RibbonDiffXml) | Specifies a rule used with an EnableRule definition that is composed of a reference to a function within a JavaScript library.
<JavaScriptFunction> (RibbonDiffXml) | Specifies an action that calls a function from a specific JavaScript library.
<Url> (RibbonDiffXml) | An action that opens a web page at a specified address.

Remarks

When the StringParameter is a child of the <Url> (RibbonDiffXml) a Name attribute is required. When the StringParameter is a child of the <JavaScriptFunction> (RibbonDiffXml) or <CustomRule> (RibbonDiffXml) elements, the Name attribute is not valid.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/CustomRule/StringParameter |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/OrRule/Or/CustomRule/StringParameter |
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/Url/Stringparameter |
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/JavaScriptFunction/Stringparameter

Schema Name

  • StringParameterType
  • StringNamedParameterType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Strip> (RibbonDiffXml)

Contains a collection of control references.

Syntax

Xml
<Strip >
 <ControlRef/>
</Strip>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<ControlRef> (RibbonDiffXml) | Specifies a placeholder for a control within a layout template.

Parent Elements

Element | Description
<Row> (RibbonDiffXml) | Specifies a row within a Section.

Element Information

XPath

Copy Code
//RibbonDiffXml/Templates/RibbonTemplates/GroupTemplate/Layout/Section/Row/Strip

Schema Name

StripType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Tab> (RibbonDiffXml)

Specifies a tab in the ribbon.

Syntax

Xml
<Tab
 Command="String"
 CssClass="String"
 Description="String"
 Id="String"
 Sequence="Integer"
 Title="String">
 <Scaling />
 <Groups />
</Tab>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CssClass

The name of the CSS class to apply when the tab is rendered.

String

Optional

Description

The Description attribute is not used by Microsoft Dynamics CRM.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

Title

This element is not used in Microsoft Dynamics CRM.

String

Optional

Child Elements

Element | Description
<Scaling> (RibbonDiffXml) | Contains a collection of elements used to define how ribbon groups are presented when the horizontal space available changes.
<Groups> (RibbonDiffXml) | Contains a collection of Group elements.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<ContextualGroup> (RibbonDiffXml) | Contains a collection of tabs to be displayed within a specific context.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Tab |
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ContextualGroup/Tab

Schema Name

TabType

Validation File

RibbonWSS.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<TabDisplayRule> (RibbonDiffXml)

Specifies conditions when a tab will display.

Syntax

Xml
<TabDisplayRule
 TabCommand="String"
 >
 <EntityRule />
 <PageRule />
</TabDisplayRule>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
TabCommand | Associates the TabDisplayRule with a corresponding Tab.Command. | String | Required

Child Elements

Element | Description
<EntityRule> (RibbonDiffXml) | Specifies a rule that can detect whether a specific entity is in context.
<PageRule> (RibbonDiffXml) | A rule that evaluates the address of the current page. PageRule is valid when TabDisplayRule is a descendent of ImportExportXml/RibbonDiffXml

Parent Elements

Element | Description
<TabDisplayRules> (RibbonDiffXml) | Contains a collection of TabDisplayRule elements.

Remarks

When a TabDisplayRule is defined outside a specific entity using ImportExportXml/RibbonDiffXml/RuleDefinitions, <PageRule> (RibbonDiffXml) is a valid child element.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/TabDisplayRules/TabDisplayRule

Schema Name

  • TabDisplayRulesEntityType
  • TabDisplayRulesGlobalType

Validation File

RibbonTypes.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<TabDisplayRules> (RibbonDiffXml)

Contains a collection of TabDisplayRule elements.

Syntax

Xml
<TabDisplayRules >
 <TabDisplayRule />
</TabDisplayRules>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<TabDisplayRule> (RibbonDiffXml) | Specifies conditions when a tab will display.

Parent Elements

Element | Description
<RuleDefinitions> (RibbonDiffXml) | Contains a collection of rule definitions.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/TabDisplayRules

Schema Name

  • RuleDefinitionsEntityType
  • TabDisplayRulesGlobalType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Templates> (RibbonDiffXml)

Contains a collection of ribbon templates.

Syntax

Xml
<Templates>
 <RibbonTemplates />
</Templates>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<RibbonTemplates> (RibbonDiffXml) | Contains a collection of group templates.

Parent Elements

Element | Description
<RibbonDiffXml> (RibbonDiffXml) | The root element for all the elements that define custom ribbons.

Element Information

XPath

Copy Code
//RibbonDiffXml/Templates

Schema Name

TemplatesType

Validation File

RibbonWSS.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<TextBox> (RibbonDiffXml)

Deprecated: Specified a control used to enter text.

Important
This control was deprecated in Microsoft Dynamics CRM 2011. This control will not render with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

Syntax

Xml
<TextBox
 Command="String"
 Id="String"
 ImeEnabled =["0" | "1" | "true" | "false"]
 MaxLength="Integer"
 QueryCommand="String"
 Sequence="Integer"
 ShowAsLabel =["0" | "1" | "true" | "false"]
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="Non Positive Integer"
 ToolTipImage32by32Top="Non Positive Integer"
 ToolTipShortcutKey="String"
 ToolTipTitle="String"
 Width="String"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Command

Specifies the ID of the ribbon command for this control.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you define a ribbon element that will be used for multiple entities. This inserts the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity, the Id will be MyISV.contact.form.SendToOtherSystem.Button.

Important
If you don’t set a globally unique Id value, the ribbon might not display.

String

Required

ImeEnabled

Specifies whether the active state of an Input Method Editor (IME) is enabled. An IME lets you enter and edit Chinese, Japanese, and Korean characters. IMEs can be in an active or inactive state. The active state accepts Chinese, Japanese, or Korean characters. The inactive state behaves like a regular keyboard and uses a limited set of characters.

Boolean

Optional

MaxLength

The maximum number of characters that a user can enter.

Integer

Optional

QueryCommand

Specifies the name of the command to run when polling for state information.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

ShowAsLabel

Set to TRUE to disable the text box so that it does not respond to user input and looks the same as a <Label> (RibbonDiffXml) control. The default value is FALSE.

String

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

Note
This element cannot be associated with a template alias that represents an <OverflowSection> (RibbonDiffXml) or a <ControlRef> (RibbonDiffXml) element that uses the Large display mode.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Width

Specifies a desired width for the control in pixels.

String

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/TextBox |
//Controls/TextBox

Schema Name

TextBoxType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Title> (RibbonDiffXml)

Specifies title text for a specific language.

Syntax

Xml
<Title
 description="String"
 languagecode="String"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
description | Contains the localized text to display. | String | Required
languagecode | Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart). | String | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Titles> (RibbonDiffXml) | Contains a collection of title elements.

Element Information

XPath

Copy Code
//RibbonDiffXml/LocLabels/LocLabel/Titles/Title

Schema Name

RibbonTitleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Titles> (RibbonDiffXml)

Contains a collection of title elements.

Syntax

Xml
<Titles>
 <Title />
</Titles>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

This element has no attributes.

Child Elements

Element | Description
<Title> (RibbonDiffXml) | Specifies title text for a specific language.

Parent Elements

Element | Description
<LocLabel> (RibbonDiffXml) | Specifies a text string associated with a language code.

Element Information

XPath

Copy Code
//RibbonDiffXml/LocLabels/LocLabel/Titles

Schema Name

RibbonTitlesType

Validation File

RibbonTypes.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ToggleButton> (RibbonDiffXml)

Specifies a button used to toggle between an on and off state.

Syntax

Xml
<ToggleButton
 Alt="String"
 Command="String"
 CommandValueId="String"
 Description="String"
 Id="String"
 Image16by16="String"
 Image16by16Class="String"
 Image16by16Left="Non Positive Integer"
 Image16by16Top="Non Positive Integer"
 Image32by32="String"
 Image32by32Class="String"
 Image32by32Left="Non Postive Integer"
 Image32by32Top="Non Positive Integer"
 LabelCss="String"
 LabelText="String"
 MenuItemId="String"
 ModernCommandType=["ControlCommand" | "System"]
 ModernImage=”String”
 QueryCommand="String"
 Sequence="Integer"
 TemplateAlias="String"
 ToolTipDescription="String"
 ToolTipHelpKeyWord="String"
 ToolTipImage32by32="String"
 ToolTipImage32by32Class="String"
 ToolTipImage32by32Left="Non Positive Integer"
 ToolTipImage32by32Top="Non Positive Integer"
 ToolTipShortcutKey="String"
 ToolTipTitle="String"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Alt

String or reference to a localized label to display as alternative text.

String

Optional

Command

Specifies the ID of the ribbon command for this control.

String

Optional

CommandValueId

A string that is sent with the command event when the button is clicked.

String

Optional

Description

The Description attribute is not used by Microsoft Dynamics CRM.

String

Optional

Id

Specifies a unique identifier for the definition of a ribbon element. The strongly recommended naming convention is to use a period to separate the parts of the name like so: [solution identifier].[entity].[ribbon].[function].[element name]. For example: MyISV.account.form.SendToOtherSystem.Button.

Use the {!EntityLogicalName} token in the Id attribute when you are defining a ribbon element that will be used for multiple entities. This will insert the entity logical name into the Id value to make sure that the Id value is globally unique.

For example, if you use MyISV.{!EntityLogicalName}.form.SendToOtherSystem.Button with the account entity, the Id will be MyISV.account.form.SendToOtherSystem.Button. For the contact entity the Id will be MyISV.contact.form.SendToOtherSystem.Button

Important
Failing to set a globally unique Id value can cause the ribbon not to display.

String

Required

Image16by16

Specifies a 16 by 16 pixel image. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image16by16Class

Specifies the name of a CSS class to use for the 16 by 16 pixel image.

String

Optional

Image16by16Left

Specifies the number of pixels to move the 16 by 16 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

Image16by16Top

Specifies the number of pixels to move the 16 by 16 pixel image toward the top. This is represented by a negative number.

Non Positive Integer

Optional

Image32by32

Specifies a 32 by 32 pixel image. This can be the path to an image file or it can reference a web resource using the $webresource: directive.

String

Optional

Image32by32Class

Specifies the name of a CSS class to use for the 16 by 16 pixel image.

String

Optional

Image32by32Left

Specifies the number of pixels to move the 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

Image32by32Top

Specifies the number of pixels to move the 32 by 32 pixel image toward the top. This is represented by a negative number.

Non Positive Integer

Optional

LabelCss

Specifies a CSS class to apply to the label for the control.

String

Optional

LabelText

Specifies a string to display as the text for the control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

MenuItemId

Specifies a reference from a control to the ID of a menu item.

String

Optional

ModernCommandType

For internal use only.

Valid values:

Value | Description
ControlCommand | For internal use only.
System | For internal use only.

Enumeration

Optional

ModernImage

For internal use only.

String

Optional

QueryCommand

Specifies the name of the command to run when polling for state information.

String

Optional

Sequence

Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements.

Integer

Optional

TemplateAlias

Associates a ribbon element child of CommandUIDefinition with a location placeholder within a child of a Layout element. This value defines where the control will display within a group of controls when the layout changes.

String

Optional

ToolTipDescription

Specifies a string to display for the tooltip for a control. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Tooltip".

String

Optional

ToolTipHelpKeyWord

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipImage32by32

Specifies a 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Class

Specifies a CSS class to apply to the 32 by 32 pixel image to be displayed with the tooltip.

String

Optional

ToolTipImage32by32Left

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the left. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipImage32by32Top

Specifies the number of pixels to move the tooltip 32 by 32 pixel image to the top. This is represented by a negative number.

Non Positive Integer

Optional

ToolTipShortcutKey

This element is not used in Microsoft Dynamics CRM.

String

Optional

ToolTipTitle

Specifies a string to display for the title of a tooltip for a control. This is typically the same value as the control LabelText. This can reference a LocLabel element using the $LocLabels: directive, for example, "$LocLabels:MyISV.account.Save.Button.Label".

String

Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<CommandUIDefinition> (RibbonDiffXml) | Specifies the visible Ribbon elements to be included within a CustomAction element.
<Controls> (RibbonDiffXml) | Contains a collection of controls.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/ToggleButton
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Controls/ToggleButton
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Menu/MenuSection/Controls/ToggleButton

Schema Name

ToggleButtonType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Unit> (RibbonDiffXml)

Specifies a unit in a spinner control.

Syntax

Xml
<Unit
 DecimalDigits="Integer"
 Interval="Double"
 MaximumValue="Decimal"
 MinimumValue="Decimal"
 Name="String">
 <UnitAbbreviation />
</Unit>

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
DecimalDigits | The number of decimal digits to display. | Integer | Required
Interval | The amount by which the value should be incremented or decremented. | Double | Required
MaximumValue | The maximum acceptable value. | Decimal | Required
MinimumValue | The minimum acceptable value. | Decimal | Required
Name | Represents the name of a query string parameter passed for this value when using a Url element. | String | Required

Child Elements

Element | Description
<UnitAbbreviation> (RibbonDiffXml) | Specifies an abbreviation for a unit.

Parent Elements

Element | Description
<Spinner> (RibbonDiffXml) | Specifies a control used to insert a value by typing or using the arrow keys to cycle through the values.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Spinner/Unit
//Controls/Spinner/Unit

Schema Name

UnitType

Validation File

RibbonWSS.xsd

Can be Empty

No

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<UnitAbbreviation> (RibbonDiffXml)

Specifies an abbreviation for a unit.

Syntax

Xml
<UnitAbbreviation
 Sequence="Integer"
 Value="String"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Sequence | Specify the location of the ribbon modification by setting the Sequence value higher or lower than existing ribbon elements. | Integer | Optional
Value | Specifies the value to be passed as a parameter. | String | Optional

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<Unit> (RibbonDiffXml) | Specifies a unit in a spinner control.

Element Information

XPath

Copy Code
//RibbonDiffXml/CustomActions/CustomAction/CommandUIDefinition/Spinner/Unit/UnitAbbreviation |
//Controls/Spinner/Unit/UnitAbbreviation

Schema Name

UnitAbbreviationType

Validation File

RibbonWSS.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<Url> (RibbonDiffXml)

An action that opens a web page at a specified address.

Syntax

Xml
<Url
 Address="String"
 PassParams=["0" | "1" | "true" | "false"]
 WinMode="Integer"
 WinParams="String"
>
 <BoolParameter/>
 <CrmParameter/>
 <DecimalParameter/>
 <IntParameter/>
 <StringParameter/>
</Url>

Attributes and Elements

The following table lists the attributes, child elements, and parent elements.

Attributes

Attribute Description Type Usage

Address

The address of the page to open. This value must represent a Uniform Resource Identifier (URI). It can be an absolute or relative path to the page.

String

Required

PassParams

Specifies whether information about the record and language context are passed to the URL.

Boolean

Optional

WinMode

Specifies the window mode. See Remarks.

Valid values:

Value | Description
0 | Window [Default]
1 | Modal Dialog
2 | Modeless Dialog

Enumeration

Optional

WinParams

Specifies the parameters to be passed to the window. The format of this parameter is different depending on the value of the WinMode parameter.

String

Optional

Child Elements

Element | Description
<BoolParameter> (RibbonDiffXml) | Specifies a value with a Boolean data type that may be passed as a parameter.
<CrmParameter> (RibbonDiffXml) | Represents data retrieved from the Microsoft Dynamics CRM application that may be passed as a parameter.
<DecimalParameter> (RibbonDiffXml) | Specifies a value with a decimal data type that may be passed as a parameter.
<IntParameter> (RibbonDiffXml) | Specifies a value with an integer data type that may be passed as a parameter.
<StringParameter> (RibbonDiffXml) | Specifies a value with a string data type that may be passed as a parameter.

Parent Elements

Element | Description
<Actions> (RibbonDiffXml) | Specifies the actions that a command will perform.

Remarks

For WinMode = 0, the window.open method is used. For more information, see the open Method topic in the MSDN Library.

For WinMode = 1 (modal dialog), the window.showModalDialog method is used. For more information, see the showModalDialog Method topic in the MSDN Library.

For WinMode = 2 (modeless dialog), the window.showModelessDialog method is used. For more information, see the showModelessDialog Method topic in the MSDN Library.

Note
Don’t use this action to open entity forms or web resources. Use the <JavaScriptFunction> (RibbonDiffXml) with a function that uses Xrm.Utility. openEntityForm or Xrm.Utility. openWebResource instead.

Element Information

XPath

Copy Code
//RibbonDiffXml/CommandDefinitions/CommandDefinition/Actions/Url

Schema Name

UrlType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


<ValueRule> (RibbonDiffXml)

A rule that detects the value of a specific field.

Syntax

Xml
<ValueRule
 Default=["0" | "1" | "true" | "false"]
 Field="String"
 InvertResult=["0" | "1" | "true" | "false"]
 Value="String"
 />

Attributes and Elements

The following describes the attributes, child elements, and parent elements.

Attributes

Attribute | Description | Type | Usage
Default | Sets the default return value for the rule if the actual value cannot be determined. | Boolean | Optional
Field | The name of the form attribute to check. | String | Required
InvertResult | Negates the return value of the rule. | Boolean | Optional
Value | Specifies the value to be passed as a parameter. | String | Required

Child Elements

This element has no child elements.

Parent Elements

Element | Description
<DisplayRule> (RibbonDiffXml) | Specifies either the definition of a rule used to display a ribbon element or a reference to a DisplayRule from a command definition.
<EnableRule> (RibbonDiffXml) | Specifies either the definition of a rule used to enable or disable a ribbon element or a reference to an EnableRule from a command definition.
<Or> (RibbonDiffXml) | Specifies a set of rules that must be evaluated together.

Remarks

For commands defined for subgrid for forms using the updated user experience, value rules cannot be used within display rules. Use this element within an <EnableRule> (RibbonDiffXml) to hide an element.

Element Information

XPath

Copy Code
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/ValueRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/ValueRule |
//RibbonDiffXml/RuleDefinitions/DisplayRules/DisplayRule/OrRule/Or/ValueRule |
//RibbonDiffXml/RuleDefinitions/EnableRules/EnableRule/ValueRule

Schema Name

ValueRuleType

Validation File

RibbonTypes.xsd

Can be Empty

Yes

See Also

Other Resources

Ribbon XML reference
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Ribbon core schema

The following is the schema definition for the ribbon core portion of an import/export customization file. It is included from the Customization solutions file schema. This schema includes RibbonTypes.xsd and RibbonWss.xsd which you can find in the SDK\Schemas folder in the SDK package. Download the Microsoft Dynamics CRM SDK package. For more information, see Package and distribute extensions using solutions.

Ribbon Core Schema

Xml Copy Code
<?xml version="1.0" encoding="utf-8"?>
<xs:schema id="CrmRibbonCore"
           xmlns:xs="http://www.w3.org/2001/XMLSchema">
 <xs:include schemaLocation="RibbonTypes.xsd" />
 <xs:include schemaLocation="RibbonWSS.xsd" />

 <!-- Root Element-->
 <xs:element name="RibbonDiffXml"
             type="RibbonGlobalDiffXmlType" />
 <xs:element name="CommandDefinitions"
             type="CommandDefinitionsType" />
 <xs:element name="RuleDefinitions"
             type="RuleDefinitionsGlobalType" />
 <xs:element name="Templates"
             type="TemplatesType" />
 <xs:element name="CustomActions"
             type="CustomActionsType" />

 <xs:element name="UI"
             type="CommandUIType">
 </xs:element>

 <!-- Element Types -->
 <xs:complexType name="RibbonEntityDiffXmlType">
  <xs:choice minOccurs="1"
             maxOccurs="1">
   <xs:sequence>
    <xs:element name="CustomActions"
                minOccurs="0"
                maxOccurs="1"
                type="CustomActionsType" />
    <xs:element name="Templates"
                type="TemplatesType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="CommandDefinitions"
                minOccurs="0"
                maxOccurs="1"
                type="CommandDefinitionsType" />
    <xs:element name="RuleDefinitions"
                minOccurs="0"
                maxOccurs="1"
                type="RuleDefinitionsEntityType" />
    <xs:element name="LocLabels"
                minOccurs="0"
                maxOccurs="1"
                type="RibbonLocLabelsType" />
   </xs:sequence>
   <xs:sequence>
    <xs:element name="RibbonNotSupported"
                minOccurs="1"
                maxOccurs="1">
     <xs:complexType>
      <xs:sequence />
     </xs:complexType>
    </xs:element>
   </xs:sequence>
  </xs:choice>
 </xs:complexType>

 <xs:complexType name="RibbonGlobalDiffXmlType">
  <xs:sequence>
   <xs:element name="CustomActions"
               minOccurs="0"
               maxOccurs="1"
               type="CustomActionsType" />
   <xs:element name="Templates"
               type="TemplatesType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="CommandDefinitions"
               minOccurs="0"
               maxOccurs="1"
               type="CommandDefinitionsType" />
   <xs:element name="RuleDefinitions"
               minOccurs="0"
               maxOccurs="1"
               type="RuleDefinitionsGlobalType" />
   <xs:element name="LocLabels"
               minOccurs="0"
               maxOccurs="1"
               type="RibbonLocLabelsType" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="CustomActionsType">
  <xs:choice minOccurs="0"
             maxOccurs="unbounded">
   <xs:element name="CustomAction"
               type="CustomActionType" />
   <xs:element name="HideCustomAction"
               type="HideCustomActionType" />
  </xs:choice>
 </xs:complexType>

 <xs:complexType name="CustomActionType">
  <xs:sequence>
   <xs:element name="CommandUIDefinition"
               minOccurs="1"
               maxOccurs="1">
    <xs:complexType>
     <xs:choice>
      <xs:element name="Button"
                  type="ButtonType" />
      <xs:element name="CheckBox"
                  type="CheckBoxType" />
      <xs:element name="ComboBox"
                  type="ComboBoxType" />
      <xs:element name="ColorPicker"
                  type="ColorPickerType" />
      <xs:element name="ContextualGroup"
                  type="ContextualGroupType" />
      <!-- <xs:element name="ContextualTabs" type="ContextualTabsType" /> -->
      <xs:element name="Controls"
                  type="ControlsType" />
      <xs:element name="DropDown"
                  type="DropDownType" />
      <xs:element name="FlyoutAnchor"
                  type="FlyoutAnchorType" />
      <xs:element name="Gallery"
                  type="GalleryType" />
      <xs:element name="GalleryButton"
                  type="GalleryButtonType" />
      <xs:element name="GroupTemplate"
                  type="GroupTemplateType" />
      <xs:element name="Group"
                  type="GroupType" />
      <xs:element name="Groups"
                  type="GroupsType" />
      <xs:element name="InsertTable"
                  type="InsertTableType" />
      <!-- <xs:element name="Jewel" type="JewelType" /> -->
      <xs:element name="Label"
                  type="LabelType" />
      <xs:element name="MRUSplitButton"
                  type="MRUSplitButtonType" />
      <xs:element name="MaxSize"
                  type="MaxSizeType" />
      <xs:element name="Menu"
                  type="MenuType" />
      <xs:element name="MenuSection"
                  type="MenuSectionType" />
      <!-- <xs:element name="QAT" type="QATType" /> -->
      <!-- <xs:element name="Ribbon" type="RibbonType" /> -->
      <xs:element name="Scale"
                  type="ScaleType" />
      <xs:element name="Scaling"
                  type="ScalingType" />
      <xs:element name="Spinner"
                  type="SpinnerType" />
      <xs:element name="SplitButton"
                  type="SplitButtonType" />
      <xs:element name="Tab"
                  type="TabType" />
      <!-- <xs:element name="Tabs" type="TabsType" /> -->
      <xs:element name="TextBox"
                  type="TextBoxType" />
      <xs:element name="ToggleButton"
                  type="ToggleButtonType" />
     </xs:choice>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
  <xs:attribute name="Id"
                type="xs:string" />
  <xs:attribute name="Location"
                type="xs:string" />
  <xs:attribute name="Sequence"
                type="xs:int" />
  <xs:attribute name="Title"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="HideCustomActionType">
  <xs:attribute name="HideActionId"
                type="xs:string" />
  <xs:attribute name="Location"
                type="xs:string" />
  <xs:attribute name="Sequence"
                type="xs:int" />
  <xs:attribute name="Title"
                type="xs:string" />
 </xs:complexType>
</xs:schema>

See Also

Reference

Ribbon types schema
Customization solutions file schema

Other Resources

Customize commands and the ribbon
Ribbon XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Ribbon types schema

The following is the schema definition for the ribbon types portion of an import/export customization file. It is included from the Ribbon core schema. For more information, see Package and distribute extensions using solutions. You can find this schema in the SDK\Schemas\ribbontypes.xsd file in the SDK package. Download the Microsoft Dynamics CRM SDK package.

Schema

Xml Copy Code
<?xml version="1.0" encoding="utf-8"?>
<xs:schema id="CrmRibbonTypes"
           xmlns:xs="http://www.w3.org/2001/XMLSchema" >

 <!-- Command Definition Types -->
 <xs:complexType name="ActionsType">
  <xs:choice minOccurs="0"
             maxOccurs="unbounded">
   <xs:element name="JavaScriptFunction"
               type="JavaScriptFunctionType" />
   <xs:element name="Url"
               type="UrlType" />
   <xs:element name="OutlookCommand"
               type="OutlookCommandType" />
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="CommandDefinitionsType">
  <xs:sequence>
   <xs:element name="CommandDefinition"
               type="CommandDefinitionType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="CommandDefinitionType">
  <xs:sequence>
   <xs:element name="EnableRules"
               type="ReferenceEnableRulesType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="DisplayRules"
               type="ReferenceDisplayRulesType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="Actions"
               type="ActionsType"
               minOccurs="1"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="Id"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="JavaScriptFunctionType">
  <xs:sequence>
   <xs:group ref="ParameterType"
             minOccurs="0"
             maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="FunctionName"
                type="JavaScriptIdentifier"
                use="required" />
  <xs:attribute name="Library"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="OutlookCommandType">
  <xs:attribute name="ActionType"
                type="OutlookActionType"
                use="required" />
  <xs:attribute name="Data"
                type="xs:string"
                use="optional" />
 </xs:complexType>
 <xs:complexType name="ReferenceEnableRulesType">
  <xs:sequence>
   <xs:element name="EnableRule"
               type="ReferenceEnableRuleType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="ReferenceDisplayRulesType">
  <xs:sequence>
   <xs:element name="DisplayRule"
               type="ReferenceDisplayRuleType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="ReferenceEnableRuleType">
  <xs:attribute name="Id"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="ReferenceDisplayRuleType">
  <xs:attribute name="Id"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="UrlType">
  <xs:sequence>
   <xs:group ref="NamedParameterType"
             minOccurs="0"
             maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Address"
                type="xs:anyURI"
                use="required" />
  <xs:attribute name="WinMode"
                type="WinMode"
                use="optional" />
  <xs:attribute name="WinParams"
                type="xs:string"
                use="optional" />
  <xs:attribute name="PassParams"
                type="xs:boolean"
                use="optional" />
 </xs:complexType>

 <!-- Command Value Restrictions -->
 <xs:simpleType name="JavaScriptIdentifier">
  <xs:restriction base="xs:string">
   <xs:pattern value="[a-zA-Z_$][a-zA-Z_$0-9.]*" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="OutlookActionType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="CheckForUpdates" />
   <xs:enumeration value="ConfigWizard" />
   <xs:enumeration value="GoTo" />
   <xs:enumeration value="GoOffline" />
   <xs:enumeration value="Help" />
   <xs:enumeration value="OpenOlkForm" />
   <xs:enumeration value="Promote" />
   <xs:enumeration value="SetRegarding" />
   <xs:enumeration value="Settings" />
   <xs:enumeration value="SignOut" />
   <xs:enumeration value="SignOutForgetMe" />
   <xs:enumeration value="OutlookImport" />
   <xs:enumeration value="Sync" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="WinMode">
  <xs:restriction base="xs:integer">
   <xs:minInclusive value="0" />
   <xs:maxInclusive value="2" />
  </xs:restriction>
 </xs:simpleType>

 <!-- Rule Container Types -->
 <xs:complexType name="RuleDefinitionsEntityType">
  <xs:sequence>
   <xs:element name="TabDisplayRules"
               type="TabDisplayRulesEntityType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="DisplayRules"
               type="DisplayRulesType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="EnableRules"
               type="EnableRulesType"
               minOccurs="1"
               maxOccurs="1" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="RuleDefinitionsGlobalType">
  <xs:sequence>
   <xs:element name="TabDisplayRules"
               type="TabDisplayRulesGlobalType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="DisplayRules"
               type="DisplayRulesType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="EnableRules"
               type="EnableRulesType"
               minOccurs="1"
               maxOccurs="1" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="EnableRulesType">
  <xs:sequence minOccurs="0"
               maxOccurs="unbounded">
   <xs:element name="EnableRule">
    <xs:complexType>
     <xs:choice minOccurs="1"
                maxOccurs="unbounded">
      <xs:group ref="EnableRulesGroup" />
      <xs:element name="OrRule"
                  type="OrEnableRuleType" />
     </xs:choice>
     <xs:attribute name="Id"
                   type="xs:string"
                   use="required" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="OrEnableRuleType">
  <xs:sequence minOccurs="2"
               maxOccurs="unbounded">
   <xs:element name="Or">
    <xs:complexType>
     <xs:choice minOccurs="1"
                maxOccurs="unbounded">
      <xs:group ref="EnableRulesGroup" />
     </xs:choice>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>

 <xs:group name="EnableRulesGroup">
  <xs:choice>
   <xs:element name="CrmClientTypeRule"
               type="CrmClientTypeRuleType" />
   <xs:element name="CrmOutlookClientTypeRule"
               type="CrmOutlookClientTypeRuleType" />
   <xs:element name="CrmOfflineAccessStateRule"
               type="CrmOfflineAccessStateRuleType" />
   <xs:element name="CustomRule"
               type="CustomRuleType" />
   <xs:element name="EntityRule"
               type="EntityRuleType" />
   <xs:element name="FormStateRule"
               type="FormStateRuleType" />
   <xs:element name="OutlookItemTrackingRule"
               type="OutlookItemTrackingRuleType" />
   <xs:element name="OutlookVersionRule"
               type="OutlookVersionRuleType" />
   <xs:element name="PageRule"
               type="PageRuleType" />
   <xs:element name="RecordPrivilegeRule"
               type="RecordPrivilegeRuleType" />
   <xs:element name="SelectionCountRule"
               type="SelectionCountRuleType" />
   <xs:element name="SkuRule"
               type="SkuRuleType" />
   <xs:element name="ValueRule"
               type="ValueRuleType" />
   <xs:element name="CommandClientTypeRule"
               type="CommandClientTypeRuleType" />
  </xs:choice>
 </xs:group>

 <xs:complexType name="TabDisplayRulesEntityType">
  <xs:sequence minOccurs="0"
               maxOccurs="unbounded">
   <xs:element name="TabDisplayRule">
    <xs:complexType>
     <xs:choice minOccurs="1"
                maxOccurs="unbounded">
      <xs:element name="EntityRule"
                  type="EntityTabRuleType" />
     </xs:choice>
     <xs:attribute name="TabCommand"
                   type="xs:string"
                   use="required" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="TabDisplayRulesGlobalType">
  <xs:sequence minOccurs="0"
               maxOccurs="unbounded">
   <xs:element name="TabDisplayRule">
    <xs:complexType>
     <xs:choice minOccurs="1"
                maxOccurs="unbounded">
      <xs:element name="EntityRule"
                  type="EntityTabRuleType" />
      <xs:element name="PageRule"
                  type="PageTabRuleType" />
     </xs:choice>
     <xs:attribute name="TabCommand"
                   type="xs:string"
                   use="required" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="DisplayRulesType">
  <xs:sequence minOccurs="0"
               maxOccurs="unbounded">
   <xs:element name="DisplayRule">
    <xs:complexType>
     <xs:choice minOccurs="1"
                maxOccurs="unbounded">
      <xs:group ref="DisplayRulesGroup" />
      <xs:element name="OrRule"
                  type="OrDisplayRuleType" />
     </xs:choice>
     <xs:attribute name="Id"
                   type="xs:string"
                   use="required" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="OrDisplayRuleType">
  <xs:sequence minOccurs="2"
               maxOccurs="unbounded">
   <xs:element name="Or">
    <xs:complexType>
     <xs:choice minOccurs="1"
                maxOccurs="unbounded">
      <xs:group ref="DisplayRulesGroup" />
     </xs:choice>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>

 <xs:group name="DisplayRulesGroup">
  <xs:choice>
   <xs:element name="CrmClientTypeRule"
               type="CrmClientTypeRuleType" />
   <xs:element name="CommandClientTypeRule"
               type="CommandClientTypeRuleType" />
   <xs:element name="CrmOutlookClientTypeRule"
               type="CrmOutlookClientTypeRuleType" />
   <xs:element name="CrmOutlookClientVersionRule"
               type="CrmOutlookClientVersionRuleType" />
   <xs:element name="CrmOfflineAccessStateRule"
               type="CrmOfflineAccessStateRuleType" />
   <xs:element name="EntityRule"
               type="EntityRuleType" />
   <xs:element name="EntityPrivilegeRule"
               type="EntityPrivilegeRuleType" />
   <xs:element name="EntityPropertyRule"
               type="EntityPropertyRuleType" />
   <xs:element name="FormEntityContextRule"
               type="FormEntityContextRuleType" />
   <xs:element name="FormStateRule"
               type="FormStateRuleType" />
   <xs:element name="MiscellaneousPrivilegeRule"
               type="MiscellaneousPrivilegeRuleType" />
   <xs:element name="OrganizationSettingRule"
               type="OrganizationSettingRuleType" />
   <xs:element name="OutlookRenderTypeRule"
               type="OutlookRenderTypeRuleType" />
   <xs:element name="OutlookVersionRule"
               type="OutlookVersionRuleType" />
   <xs:element name="PageRule"
               type="PageRuleType" />
   <xs:element name="ReferencingAttributeRequiredRule"
               type="ReferencingAttributeRequiredRuleType" />
   <xs:element name="RelationshipTypeRule"
               type="RelationshipTypeRuleType" />
   <xs:element name="SkuRule"
               type="SkuRuleType" />
   <xs:element name="ValueRule"
               type="ValueRuleType" />
   <xs:element name="OptionSetRule"
               type ="OptionSetRuleType" />
   <xs:element name="FormTypeRule"
               type ="FormTypeRuleType" />
   <xs:element name="HideForTabletExperienceRule"
               type ="HideForTabletExperienceRuleType" />
   <xs:element name="HideIfNetBreezeNotAvailableRule"
               type ="HideIfNetBreezeNotAvailableRuleType" />
   <xs:element name="HideIfServiceMetadataAvailableRule"
               type ="HideIfServiceMetadataAvailableRuleType" />
   <xs:element name="HideIfSharepointS2SConfigurationEnabledRule"
               type ="HideIfSharepointS2SConfigurationEnabledRuleType" />
  </xs:choice>
 </xs:group>

 <!-- Rule Types -->
 <xs:complexType name="CrmClientTypeRuleType">
  <xs:attribute name="Type"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="Web" />
     <xs:enumeration value="Outlook" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="CommandClientTypeRuleType">
  <xs:attribute name="Type"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="Modern" />
     <xs:enumeration value="Refresh" />
     <xs:enumeration value="Legacy" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="CrmOfflineAccessStateRuleType">
  <xs:attribute name="State"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="Online" />
     <xs:enumeration value="Offline" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="CrmOutlookClientTypeRuleType">
  <xs:attribute name="Type"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="CrmForOutlook" />
     <xs:enumeration value="CrmForOutlookOfflineAccess" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="OptionSetRuleType">
  <xs:attribute name="OptionSet"
                type="xs:string"
                use="required"/>
  <xs:attribute name="StateCode"
                type="xs:string"
                use="required"/>
  <xs:attribute name="ObjectTypeCode"
                type="xs:string"
                use="required"/>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="CustomRuleType">
  <xs:sequence>
   <xs:group ref="ParameterType"
             minOccurs="0"
             maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="FunctionName"
                type="JavaScriptIdentifier"
                use="required" />
  <xs:attribute name="Library"
                type="xs:string"
                use="required" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="EntityRuleType">
  <xs:attributeGroup ref="EntityRuleTypeAttributes" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>
 <xs:complexType name="EntityTabRuleType">
  <xs:attributeGroup ref="EntityRuleTypeAttributes" />
 </xs:complexType>
 <xs:attributeGroup name="EntityRuleTypeAttributes">
  <xs:attribute name="EntityName"
                type="xs:string"
                use="optional" />
  <xs:attribute name="AppliesTo"
                type="AppliesToType"
                use="optional" />
  <xs:attribute name="Context"
                use="optional">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:pattern value="[a-zA-Z_][a-zA-Z_0-9]*" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
 </xs:attributeGroup>

 <xs:complexType name="EntityPropertyRuleType">
  <xs:attribute name="EntityName"
                type="xs:string"
                use="optional" />
  <xs:attribute name="AppliesTo"
                type="AppliesToType"
                use="optional" />
  <xs:attribute name="PropertyName"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="DuplicateDetectionEnabled" />
     <xs:enumeration value="GridFiltersEnabled" />
     <xs:enumeration value="HasStateCode" />
     <xs:enumeration value="IsConnectionsEnabled" />
     <xs:enumeration value="MailMergeEnabled" />
     <xs:enumeration value="WorksWithQueue" />
     <xs:enumeration value="HasActivities" />
     <xs:enumeration value="IsActivity" />
     <xs:enumeration value="HasNotes" />
     <xs:enumeration value="IsCustomizable" />
     <xs:enumeration value="IsActivityParty" />
     <xs:enumeration value="HasEmailAddresses" />
     <xs:enumeration value="IsChildEntity" />
     <xs:enumeration value="IsImportable" />
     <xs:enumeration value="IsEnabledForCharts" />
     <xs:enumeration value="IsBusinessProcessEnabled" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attribute name="PropertyValue"
                type="xs:boolean"
                use="required" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="FormEntityContextRuleType">
  <xs:attribute name="EntityName"
                type="xs:string"
                use="required" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="FormStateRuleType">
  <xs:attribute name="State"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="Create" />
     <xs:enumeration value="Existing" />
     <xs:enumeration value="ReadOnly" />
     <xs:enumeration value="Disabled" />
     <xs:enumeration value="BulkEdit" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="OrganizationSettingRuleType">
  <xs:attribute name="Setting"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="IsSharepointEnabled" />
     <xs:enumeration value="IsSOPIntegrationEnabled" />
     <xs:enumeration value="IsFiscalCalendarDefined" />
     <xs:enumeration value="IsReadFormModeDefined" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="FormTypeRuleType">
  <xs:attribute name="Type"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="Main" />
     <xs:enumeration value="Preview" />
     <xs:enumeration value="AppointmentBook" />
     <xs:enumeration value="Dashboard" />
     <xs:enumeration value="Quick" />
     <xs:enumeration value="QuickCreate" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="HideForTabletExperienceRuleType">
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="HideIfNetBreezeNotAvailableRuleType">
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="HideIfServiceMetadataAvailableRuleType">
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="HideIfSharepointS2SConfigurationEnabledRuleType">
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="OutlookItemTrackingRuleType">
  <xs:attribute name="TrackedInCrm"
                type="xs:boolean"
                use="required" />
  <xs:attribute name="AppliesTo"
                type="AppliesToPrimaryType"
                use="optional" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="OutlookRenderTypeRuleType">
  <xs:attribute name="Type"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="Web" />
     <xs:enumeration value="Outlook" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="OutlookVersionRuleType">
  <xs:attribute name="Version"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="2003" />
     <xs:enumeration value="2007" />
     <xs:enumeration value="2010" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="CrmOutlookClientVersionRuleType">
  <xs:attribute name="Major"
                type="xs:integer"
                use="required"/>
  <xs:attribute name="Minor"
                type="xs:integer"
                use="optional"/>
  <xs:attribute name="Build"
                type="xs:integer"
                use="optional"/>
  <xs:attribute name="Revision"
                type="xs:integer"
                use="optional"/>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="PageRuleType">
  <xs:attribute name="Address"
                type="xs:anyURI"
                use="required" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>
 <xs:complexType name="PageTabRuleType">
  <xs:attribute name="Address"
                type="xs:anyURI"
                use="required" />
 </xs:complexType>

 <xs:complexType name="RecordPrivilegeRuleType">
  <xs:attribute name="PrivilegeType"
                type="PrivilegeTypeType"
                use="required" />
  <xs:attribute name="AppliesTo"
                type="AppliesToPrimaryType"
                use="optional" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>
 <xs:complexType name="EntityPrivilegeRuleType">
  <xs:attribute name="PrivilegeType"
                type="PrivilegeTypeType"
                use="required" />
  <xs:attribute name="PrivilegeDepth"
                type="PrivilegeDepthType"
                use="required" />
  <xs:attribute name="AppliesTo"
                type="AppliesToType"
                use="optional" />
  <xs:attribute name="EntityName"
                type="xs:string"
                use="optional" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="MiscellaneousPrivilegeRuleType">
  <xs:attribute name="PrivilegeName"
                type="xs:string"
                use="required" />
  <xs:attribute name="PrivilegeDepth"
                type="PrivilegeDepthType"
                use="optional" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="ReferencingAttributeRequiredRuleType">
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="RelationshipTypeRuleType">
  <xs:attribute name="AppliesTo"
                type="AppliesToSelectedType"
                use="required" />
  <xs:attribute name="RelationshipType"
                use="optional">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="OneToMany" />
     <xs:enumeration value="ManyToMany" />
     <xs:enumeration value="NoRelationship" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attribute name="AllowCustomRelationship"
                use="optional"
                type="xs:boolean"
                default="true" />
  <xs:attribute name="AllowSystemRelationship"
                use="optional"
                type="xs:boolean"
                default="true" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="SelectionCountRuleType">
  <xs:attribute name="AppliesTo"
                type="AppliesToType"
                use="optional" />
  <xs:attribute name="Minimum"
                type="xs:integer"
                use="optional" />
  <xs:attribute name="Maximum"
                type="xs:integer"
                use="optional" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="SkuRuleType">
  <xs:attribute name="Sku"
                use="required">
   <xs:simpleType>
    <xs:restriction base="xs:string">
     <xs:enumeration value="OnPremise" />
     <xs:enumeration value="Online" />
     <xs:enumeration value="Spla" />
    </xs:restriction>
   </xs:simpleType>
  </xs:attribute>
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <xs:complexType name="ValueRuleType">
  <xs:attribute name="Field"
                type="xs:string"
                use="required" />
  <xs:attribute name="Value"
                type="xs:string"
                use="required" />
  <xs:attributeGroup ref="StandardRuleAttributes" />
 </xs:complexType>

 <!-- Rule Attributes -->
 <xs:attributeGroup name="StandardRuleAttributes">
  <xs:attribute name="Default"
                type="xs:boolean"
                use="optional" />
  <xs:attribute name="InvertResult"
                type="xs:boolean"
                use="optional" />
 </xs:attributeGroup>

 <!-- Rule Value Restrictions -->
 <xs:simpleType name="AppliesToType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="PrimaryEntity" />
   <xs:enumeration value="SelectedEntity" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="AppliesToPrimaryType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="PrimaryEntity" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="AppliesToSelectedType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="SelectedEntity" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="PrivilegeDepthType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="None" />
   <xs:enumeration value="Basic" />
   <xs:enumeration value="Local" />
   <xs:enumeration value="Deep" />
   <xs:enumeration value="Global" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="PrivilegeTypeType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Create" />
   <xs:enumeration value="Read" />
   <xs:enumeration value="Write" />
   <xs:enumeration value="Delete" />
   <xs:enumeration value="Assign" />
   <xs:enumeration value="Share" />
   <xs:enumeration value="Append" />
   <xs:enumeration value="AppendTo" />
  </xs:restriction>
 </xs:simpleType>

 <!-- Parameter Types -->
 <xs:group name="ParameterType">
  <xs:choice>
   <xs:element name="BoolParameter"
               type="BoolParameterType" />
   <xs:element name="CrmParameter"
               type="CrmParameterType" />
   <xs:element name="DecimalParameter"
               type="DecimalParameterType" />
   <xs:element name="IntParameter"
               type="IntParameterType" />
   <xs:element name="StringParameter"
               type="StringParameterType" />
  </xs:choice>
 </xs:group>
 <xs:group name="NamedParameterType">
  <xs:choice>
   <xs:element name="BoolParameter"
               type="BoolNamedParameterType" />
   <xs:element name="CrmParameter"
               type="CrmNamedParameterType" />
   <xs:element name="DecimalParameter"
               type="DecimalNamedParameterType" />
   <xs:element name="IntParameter"
               type="IntNamedParameterType" />
   <xs:element name="StringParameter"
               type="StringNamedParameterType" />
  </xs:choice>
 </xs:group>
 <xs:complexType name="BoolParameterType">
  <xs:attribute name="Value"
                type="xs:boolean"
                use="required" />
 </xs:complexType>
 <xs:complexType name="BoolNamedParameterType">
  <xs:attribute name="Value"
                type="xs:boolean"
                use="required" />
  <xs:attribute name="Name"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="CrmParameterType">
  <xs:attribute name="Value"
                type="CrmParameterValue"
                use="required" />
 </xs:complexType>
 <xs:complexType name="CrmNamedParameterType">
  <xs:attribute name="Value"
                type="CrmNamedParameterValue"
                use="required" />
  <xs:attribute name="Name"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="DecimalParameterType">
  <xs:attribute name="Value"
                type="xs:decimal"
                use="required" />
 </xs:complexType>
 <xs:complexType name="DecimalNamedParameterType">
  <xs:attribute name="Value"
                type="xs:decimal"
                use="required" />
  <xs:attribute name="Name"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="IntParameterType">
  <xs:attribute name="Value"
                type="xs:integer"
                use="required" />
 </xs:complexType>
 <xs:complexType name="IntNamedParameterType">
  <xs:attribute name="Value"
                type="xs:integer"
                use="required" />
  <xs:attribute name="Name"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="StringParameterType">
  <xs:attribute name="Value"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="StringNamedParameterType">
  <xs:attribute name="Value"
                type="xs:string"
                use="required" />
  <xs:attribute name="Name"
                type="xs:string"
                use="required" />
 </xs:complexType>

 <xs:simpleType name="CrmParameterValue">
  <xs:restriction base="xs:string">
   <xs:enumeration value="PrimaryEntityTypeCode" />
   <xs:enumeration value="PrimaryEntityTypeName" />
   <xs:enumeration value="PrimaryItemIds" />
   <xs:enumeration value="FirstPrimaryItemId" />
   <xs:enumeration value="PrimaryControl" />
   <xs:enumeration value="PrimaryControlId" />
   <xs:enumeration value="SelectedEntityTypeCode" />
   <xs:enumeration value="SelectedEntityTypeName" />
   <xs:enumeration value="FirstSelectedItemId" />
   <xs:enumeration value="SelectedControl" />
   <xs:enumeration value="SelectedControlSelectedItemCount" />
   <xs:enumeration value="SelectedControlSelectedItemIds" />
   <xs:enumeration value="SelectedControlSelectedItemReferences" />
   <xs:enumeration value="SelectedControlAllItemCount" />
   <xs:enumeration value="SelectedControlAllItemIds" />
   <xs:enumeration value="SelectedControlAllItemReferences" />
   <xs:enumeration value="SelectedControlUnselectedItemCount" />
   <xs:enumeration value="SelectedControlUnselectedItemIds" />
   <xs:enumeration value="SelectedControlUnselectedItemReferences" />
   <xs:enumeration value="OrgName" />
   <xs:enumeration value="OrgLcid" />
   <xs:enumeration value="UserLcid" />
   <xs:enumeration value="CommandProperties" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="CrmNamedParameterValue">
  <xs:restriction base="xs:string">
   <xs:enumeration value="PrimaryEntityTypeCode" />
   <xs:enumeration value="PrimaryEntityTypeName" />
   <xs:enumeration value="PrimaryItemIds" />
   <xs:enumeration value="FirstPrimaryItemId" />
   <xs:enumeration value="PrimaryControl" />
   <xs:enumeration value="PrimaryControlId" />
   <xs:enumeration value="SelectedEntityTypeCode" />
   <xs:enumeration value="SelectedEntityTypeName" />
   <xs:enumeration value="FirstSelectedItemId" />
   <xs:enumeration value="SelectedControl" />
   <xs:enumeration value="SelectedControlSelectedItemCount" />
   <xs:enumeration value="SelectedControlSelectedItemIds" />
   <xs:enumeration value="SelectedControlAllItemCount" />
   <xs:enumeration value="SelectedControlAllItemIds" />
   <xs:enumeration value="SelectedControlUnselectedItemCount" />
   <xs:enumeration value="SelectedControlUnselectedItemIds" />
   <xs:enumeration value="OrgName" />
   <xs:enumeration value="OrgLcid" />
   <xs:enumeration value="UserLcid" />
   <xs:enumeration value="CommandProperties" />
  </xs:restriction>
 </xs:simpleType>

 <!-- LocLabels Types -->
 <xs:complexType name="RibbonLocLabelsType">
  <xs:sequence minOccurs="1"
               maxOccurs="1">
   <xs:element name="LocLabel"
               type="RibbonLocLabelType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="RibbonLocLabelType">
  <xs:sequence minOccurs="1"
               maxOccurs="1">
   <xs:element name="Titles"
               type="RibbonTitlesType"
               minOccurs="1"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="Id"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <xs:complexType name="RibbonTitlesType">
  <xs:sequence minOccurs="1"
               maxOccurs="1">
   <xs:element name="Title"
               type="RibbonTitleType"
               minOccurs="1"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="RibbonTitleType">
  <xs:attribute name="description"
                type="xs:string"
                use="required" />
  <xs:attribute name="languagecode"
                type="xs:int"
                use="required" />
 </xs:complexType>
</xs:schema>

See Also

Reference

Ribbon core schema
Ribbon WSS schema

Other Resources

Customize commands and the ribbon
Schemas used in Microsoft Dynamics CRM
Customization XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Ribbon WSS schema

The following is the schema definition for the ribbon types WSS of an import/export customization file. It is included from the Ribbon core schema. For more information, see Package and distribute extensions using solutions. You can find this schema in the SDK\Schemas\ribbonwss.xsd file in the SDK package. Download the Microsoft Dynamics CRM SDK package.

Schema

Xml Copy Code
<?xml version="1.0" encoding="utf-8"?>
<xs:schema id="CrmRibbonWss"
           xmlns:xs="http://www.w3.org/2001/XMLSchema">

 <xs:simpleType name="AltType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="ClassNameType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="ContextualColorType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="None" />
   <xs:enumeration value="DarkBlue" />
   <xs:enumeration value="LightBlue" />
   <xs:enumeration value="Teal" />
   <xs:enumeration value="Orange" />
   <xs:enumeration value="Green" />
   <xs:enumeration value="Magenta" />
   <xs:enumeration value="Yellow" />
   <xs:enumeration value="Purple" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="CommandType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="CommandTypeType">
  <xs:restriction base="xs:string" >
   <xs:enumeration value="General" />
   <xs:enumeration value="OptionSelection" />
   <xs:enumeration value="IgnoredByMenu" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="DescriptionType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="DisplayModeType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Default" />
   <xs:enumeration value="Small" />
   <xs:enumeration value="Medium" />
   <xs:enumeration value="Large" />
   <xs:enumeration value="Text" />
   <xs:enumeration value="Menu" />
   <xs:enumeration value="Menu16" />
   <xs:enumeration value="Menu32" />
   <xs:enumeration value="Thin" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="ElementDimensionsType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Size16by16" />
   <xs:enumeration value="Size32by32" />
   <xs:enumeration value="Size48by48" />
   <xs:enumeration value="Size64by48" />
   <xs:enumeration value="Size72by96" />
   <xs:enumeration value="Size96by72" />
   <xs:enumeration value="Size96by96" />
   <xs:enumeration value="Size128by128" />
   <xs:enumeration value="Size190by30" />
   <xs:enumeration value="Size190by40" />
   <xs:enumeration value="Size190by50" />
   <xs:enumeration value="Size190by60" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="HTMLType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="IdType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="ImageClassType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="ImagePositionType">
  <xs:restriction base="xs:nonPositiveInteger" />
 </xs:simpleType>

 <xs:simpleType name="ImageUrlType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="LabelCssType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="LabelTextType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="MenuItemIdType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="ModernCommandTypeType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="ControlCommand" />
   <xs:enumeration value="System" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="PixelLengthType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="SectionTypeType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Divider" />
   <xs:enumeration value="OneRow" />
   <xs:enumeration value="TwoRow" />
   <xs:enumeration value="ThreeRow" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="SectionAlignmentType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Top" />
   <xs:enumeration value="Middle" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="SequenceType">
  <xs:restriction base="xs:integer" />
 </xs:simpleType>

 <xs:simpleType name="SizeType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="TemplateType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="TemplateAliasType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="TextDirectionType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="TitleType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="UnitNameType">
  <xs:restriction base="xs:string" />
 </xs:simpleType>

 <xs:simpleType name="ValueType">
  <xs:restriction base="xs:decimal" />
 </xs:simpleType>

 <xs:complexType name="ButtonType">
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandType"
                type="CommandTypeType" />
  <xs:attribute name="CommandValueId"
                type="xs:string" />
  <xs:attribute name="Description"
                type="xs:string" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Image32by32"
                type="ImageUrlType" />
  <xs:attribute name="Image32by32Class"
                type="ImageClassType" />
  <xs:attribute name="Image32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="Image32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="Image16by16"
                type="ImageUrlType" />
  <xs:attribute name="Image16by16Class"
                type="ImageClassType" />
  <xs:attribute name="Image16by16Left"
                type="ImagePositionType" />
  <xs:attribute name="Image16by16Top"
                type="ImagePositionType" />
  <xs:attribute name="LabelCss"
                type="LabelCssType" />
  <xs:attribute name="LabelText"
                type="LabelTextType" />
  <xs:attribute name="MenuItemId"
                type="MenuItemIdType" />
  <xs:attribute name="ModernCommandType"
                type="ModernCommandTypeType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
  <xs:attribute name="ModernImage"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="CheckBoxType">
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="LabelText"
                type="LabelTextType" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="MenuItemId"
                type="MenuItemIdType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="ColorPickerType">
  <xs:sequence>
   <xs:element name="Colors"
               type="ColorStylesType"
               minOccurs="0"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandPreview"
                type="CommandType" />
  <xs:attribute name="CommandRevert"
                type="CommandType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
 </xs:complexType>

 <xs:complexType name="ColorStylesType">
  <xs:sequence>
   <xs:element name="Color"
               type="ColorStyleType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="ColorStyleType">
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="Title"
                type="AltType" />
  <xs:attribute name="Style"
                type="xs:string" />
  <xs:attribute name="Color"
                type="xs:string" />
  <xs:attribute name="DisplayColor"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="ComboBoxType">
  <xs:sequence>
   <xs:element name="Menu"
               type="MenuType"
               minOccurs="0"
               maxOccurs="1"/>
  </xs:sequence>
  <xs:attribute name="AllowFreeForm"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="AltArrow"
                type="AltType" />
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="AutoComplete"
                type="xs:boolean"
                default="true" />
  <xs:attribute name="AutoCompleteDelay"
                type="xs:integer"
                default="100" />
  <xs:attribute name="CacheMenuVersions"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandMenuOpen"
                type="CommandType" />
  <xs:attribute name="CommandMenuClose"
                type="CommandType" />
  <xs:attribute name="CommandPreview"
                type="CommandType" />
  <xs:attribute name="CommandPreviewRevert"
                type="CommandType" />
  <xs:attribute name="ImeEnabled"
                type="xs:boolean" />
  <xs:attribute name="InitialItem"
                type="MenuItemIdType"/>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="PopulateDynamically"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="PopulateQueryCommand"
                type="CommandType" />
  <xs:attribute name="PopulateOnlyOnce"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipSelectedItemTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
  <xs:attribute name="Width"
                type="PixelLengthType" />
 </xs:complexType>

 <xs:complexType name="CommandUIType">
  <xs:sequence>
   <xs:choice minOccurs="1"
              maxOccurs="unbounded">
    <xs:element name="Ribbon"
                type="RibbonType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="QAT"
                type="QATType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="Jewel"
                type="JewelType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="Templates"
                type="TemplatesType"
                minOccurs="0"
                maxOccurs="1" />
   </xs:choice>
  </xs:sequence>
 </xs:complexType>

 <xs:element name="CommandUI"
             type="CommandUIType">
 </xs:element>

 <xs:complexType name="ContextualGroupType">
  <xs:sequence>
   <xs:element name="Tab"
               type="TabType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Color"
                type="ContextualColorType" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="ContextualGroupId"
                type="xs:string" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="Title"
                type="TitleType" />
 </xs:complexType>

 <xs:complexType name="ContextualTabsType">
  <xs:sequence>
   <xs:element name="ContextualGroup"
               type="ContextualGroupType"
               minOccurs="0"
               maxOccurs="unbounded"/>
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
 </xs:complexType>

 <xs:complexType name="ControlRefType">
  <xs:attribute name="DisplayMode"
                type="DisplayModeType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
 </xs:complexType>

 <xs:complexType name="ControlsType">
  <xs:sequence>
   <xs:choice minOccurs="0"
              maxOccurs="unbounded">
    <xs:element name="Button"
                type="ButtonType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="CheckBox"
                type="CheckBoxType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="ComboBox"
                type="ComboBoxType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="DropDown"
                type="DropDownType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="FlyoutAnchor"
                type="FlyoutAnchorType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="GalleryButton"
                type="GalleryButtonType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="Label"
                type="LabelType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="MRUSplitButton"
                type="MRUSplitButtonType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="Spinner"
                type="SpinnerType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="SplitButton"
                type="SplitButtonType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="TextBox"
                type="TextBoxType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="ToggleButton"
                type="ToggleButtonType"
                minOccurs="0"
                maxOccurs="unbounded" />
   </xs:choice>
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
  <xs:attribute name="ToolTipSelectedItemTitle"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="DropDownType">
  <xs:sequence>
   <xs:element name="Menu"
               type="MenuType"
               minOccurs="0"
               maxOccurs="1"/>
  </xs:sequence>
  <xs:attribute name="AltArrow"
                type="AltType" />
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="CacheMenuVersions"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandMenuOpen"
                type="CommandType" />
  <xs:attribute name="CommandMenuClose"
                type="CommandType" />
  <xs:attribute name="CommandPreview"
                type="CommandType" />
  <xs:attribute name="CommandPreviewRevert"
                type="CommandType" />
  <xs:attribute name="InitialItem"
                type="MenuItemIdType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="PopulateDynamically"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="PopulateQueryCommand"
                type="CommandType" />
  <xs:attribute name="PopulateOnlyOnce"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
  <xs:attribute name="ToolTipSelectedItemTitle"
                type="xs:string" />
  <xs:attribute name="Width"
                type="PixelLengthType" />
  <xs:attribute name="SelectedItemDisplayMode"
                type="DisplayModeType" />
 </xs:complexType>

 <xs:complexType name="FlyoutAnchorType">
  <xs:sequence>
   <xs:element name="Menu"
               type="MenuType"
               minOccurs="0"
               maxOccurs="1"/>
  </xs:sequence>
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="CacheMenuVersions"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandType"
                type="CommandTypeType" />
  <xs:attribute name="CommandMenuClose"
                type="CommandType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Image16by16"
                type="ImageUrlType" />
  <xs:attribute name="Image16by16Class"
                type="ImageClassType" />
  <xs:attribute name="Image16by16Left"
                type="ImagePositionType" />
  <xs:attribute name="Image16by16Top"
                type="ImagePositionType" />
  <xs:attribute name="Image32by32"
                type="ImageUrlType" />
  <xs:attribute name="Image32by32Class"
                type="ImageClassType" />
  <xs:attribute name="Image32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="Image32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="LabelText"
                type="LabelTextType" />
  <xs:attribute name="ModernCommandType"
                type="ModernCommandTypeType" />
  <xs:attribute name="PopulateDynamically"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="PopulateQueryCommand"
                type="CommandType" />
  <xs:attribute name="PopulateOnlyOnce"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipSelectedItemTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
  <xs:attribute name="ModernImage"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="GalleryType">
  <xs:sequence>
   <xs:element name="GalleryButton"
               type="GalleryButtonType"
               minOccurs="1"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandPreview"
                type="CommandType" />
  <xs:attribute name="CommandRevert"
                type="CommandType" />
  <xs:attribute name="ElementDimensions"
                type="ElementDimensionsType"
                use="required" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="Width"
                type="xs:integer"
                use="required" />
 </xs:complexType>

 <xs:complexType name="GalleryButtonType">
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandPreview"
                type="CommandType" />
  <xs:attribute name="CommandRevert"
                type="CommandType" />
  <xs:attribute name="CommandType"
                type="CommandTypeType" />
  <xs:attribute name="CommandValueId"
                type="xs:string" />
  <xs:attribute name="ElementDimensions"
                type="ElementDimensionsType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Image"
                type="ImageUrlType" />
  <xs:attribute name="ImageClass"
                type="ImageClassType" />
  <xs:attribute name="ImageLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageTop"
                type="ImagePositionType" />
  <xs:attribute name="InnerHTML"
                type="HTMLType" />
  <xs:attribute name="MenuItemId"
                type="MenuItemIdType" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="GroupTemplateType">
  <xs:sequence>
   <xs:element name="Layout"
               type="LayoutType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="ClassName"
                type="ClassNameType" />
 </xs:complexType>

 <xs:complexType name="GroupsType">
  <xs:sequence>
   <xs:element name="Group"
               type="GroupType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
 </xs:complexType>

 <xs:complexType name="GroupType">
  <xs:all>
   <xs:element name="Controls"
               type="ControlsType"
               minOccurs="1"
               maxOccurs="1" />
  </xs:all>
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="Description"
                type="DescriptionType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Image32by32Popup"
                type="ImageUrlType" />
  <xs:attribute name="Image32by32PopupClass"
                type="ImageClassType" />
  <xs:attribute name="Image32by32PopupLeft"
                type="ImagePositionType" />
  <xs:attribute name="Image32by32PopupTop"
                type="ImagePositionType" />
  <xs:attribute name="PopupWidth"
                type="PixelLengthType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="Template"
                type="TemplateType" />
  <xs:attribute name="Title"
                type="TitleType" />
 </xs:complexType>

 <xs:complexType name="InsertTableType">
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandType"
                type="CommandTypeType" />
  <xs:attribute name="CommandPreview"
                type="CommandType" />
  <xs:attribute name="CommandRevert"
                type="CommandType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="MenuSectionInitialTitle"
                type="xs:string" />
  <xs:attribute name="MenuSectionTitle"
                type="xs:string" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
 </xs:complexType>

 <xs:complexType name="JewelType">
  <xs:sequence>
   <xs:element name="Menu"
               type="MenuType"
               minOccurs="0"
               maxOccurs="1"/>
  </xs:sequence>
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="CacheMenuVersions"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandMenuClose"
                type="CommandType" />
  <xs:attribute name="CommandMenuOpen"
                type="CommandType" />
  <xs:attribute name="Height"
                type="xs:integer" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="ImageDownArrow"
                type="ImageUrlType" />
  <xs:attribute name="ImageDownArrowClass"
                type="ImageClassType" />
  <xs:attribute name="ImageDownArrowLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageDownArrowTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageSideArrow"
                type="ImageUrlType" />
  <xs:attribute name="ImageSideArrowClass"
                type="ImageClassType" />
  <xs:attribute name="ImageSideArrowLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageSideArrowTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageUpArrow"
                type="ImageUrlType" />
  <xs:attribute name="ImageUpArrowClass"
                type="ImageClassType" />
  <xs:attribute name="ImageUpArrowLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageUpArrowTop"
                type="ImagePositionType" />
  <xs:attribute name="Image"
                type="ImageUrlType" />
  <xs:attribute name="ImageClass"
                type="ImageClassType" />
  <xs:attribute name="ImageLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageHover"
                type="ImageUrlType" />
  <xs:attribute name="ImageHoverClass"
                type="ImageClassType" />
  <xs:attribute name="ImageHoverLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageHoverTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageDown"
                type="ImageUrlType" />
  <xs:attribute name="ImageDownClass"
                type="ImageClassType" />
  <xs:attribute name="ImageDownLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageDownTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageLeftSide"
                type="ImageUrlType" />
  <xs:attribute name="ImageLeftSideClass"
                type="ImageClassType" />
  <xs:attribute name="ImageLeftSideLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageLeftSideTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageLeftSideWidth"
                type="xs:integer" />
  <xs:attribute name="ImageLeftSideHover"
                type="ImageUrlType" />
  <xs:attribute name="ImageLeftSideHoverClass"
                type="ImageClassType" />
  <xs:attribute name="ImageLeftSideHoverLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageLeftSideHoverTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageLeftSideDown"
                type="ImageUrlType" />
  <xs:attribute name="ImageLeftSideDownClass"
                type="ImageClassType" />
  <xs:attribute name="ImageLeftSideDownLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageLeftSideDownTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageRightSide"
                type="ImageUrlType" />
  <xs:attribute name="ImageRightSideClass"
                type="ImageClassType" />
  <xs:attribute name="ImageRightSideLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageRightSideTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageRightSideWidth"
                type="xs:integer" />
  <xs:attribute name="ImageRightSideHover"
                type="ImageUrlType" />
  <xs:attribute name="ImageRightSideHoverClass"
                type="ImageClassType" />
  <xs:attribute name="ImageRightSideHoverLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageRightSideHoverTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageRightSideDown"
                type="ImageUrlType" />
  <xs:attribute name="ImageRightSideDownClass"
                type="ImageClassType" />
  <xs:attribute name="ImageRightSideDownLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageRightSideDownTop"
                type="ImagePositionType" />
  <xs:attribute name="LabelCss"
                type="LabelCssType" />
  <xs:attribute name="LabelText"
                type="LabelTextType" />
  <xs:attribute name="PopulateDynamically"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="PopulateQueryCommand"
                type="CommandType" />
  <xs:attribute name="PopulateOnlyOnce"
                type="xs:boolean"
                default="false" />
 </xs:complexType>

 <xs:complexType name="LabelType">
  <xs:attribute name="ForId"
                type="xs:string" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="LabelText"
                type="LabelTextType" />
  <xs:attribute name="Image16by16"
                type="ImageUrlType" />
  <xs:attribute name="Image16by16Class"
                type="ImageClassType" />
  <xs:attribute name="Image16by16Left"
                type="ImagePositionType" />
  <xs:attribute name="Image16by16Top"
                type="ImagePositionType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="ModernImage"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="LayoutType">
  <xs:sequence>
   <xs:choice minOccurs="0"
              maxOccurs="unbounded">
    <xs:element name="Section"
                type="SectionType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="OverflowSection"
                type="OverflowSectionType"
                minOccurs="0"
                maxOccurs="unbounded" />
   </xs:choice>
  </xs:sequence>
  <xs:attribute name="Title"
                type="TitleType"
                use="required" />
  <xs:attribute name="LayoutTitle"
                type="TitleType" />
 </xs:complexType>

 <xs:complexType name="MaxSizeType">
  <xs:attribute name="GroupId"
                type="IdType"
                use="required" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="Size"
                type="SizeType"
                use="required" />
 </xs:complexType>

 <xs:complexType name="MenuType">
  <xs:sequence>
   <xs:element name="MenuSection"
               type="MenuSectionType"
               minOccurs="1"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="MaxWidth"
                type="PixelLengthType" />
 </xs:complexType>

 <xs:complexType name="MenuSectionType">
  <xs:choice minOccurs="1"
             maxOccurs="1">
   <xs:element name="Controls"
               type="MenuSectionControlsType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="Gallery"
               type="GalleryType"
               minOccurs="1"
               maxOccurs="1" />
  </xs:choice>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Title"
                type="TitleType"/>
  <xs:attribute name="Scrollable"
                type="xs:boolean"
                default="false"/>
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="MaxHeight"
                type="PixelLengthType" />
  <xs:attribute name="DisplayMode"
                type="DisplayModeType"
                default="Menu" />
 </xs:complexType>

 <xs:complexType name="MenuSectionControlsType">
  <xs:sequence>
   <xs:choice minOccurs="0"
              maxOccurs="unbounded">
    <xs:element name="ToggleButton"
                type="ToggleButtonType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="Button"
                type="ButtonType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="ColorPicker"
                type="ColorPickerType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="FlyoutAnchor"
                type="FlyoutAnchorType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="InsertTable"
                type="InsertTableType"
                minOccurs="0"
                maxOccurs="unbounded" />
   </xs:choice>
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
 </xs:complexType>

 <xs:complexType name="MRUSplitButtonType">
  <xs:sequence>
   <xs:element name="Menu"
               type="MenuType"
               minOccurs="0"
               maxOccurs="1"/>
  </xs:sequence>
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="CacheMenuVersions"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandMenuOpen"
                type="CommandType" />
  <xs:attribute name="CommandMenuClose"
                type="CommandType" />
  <xs:attribute name="CommandPreview"
                type="CommandType" />
  <xs:attribute name="CommandPreviewRevert"
                type="CommandType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="InitialItem"
                type="MenuItemIdType"
                use="required" />
  <xs:attribute name="MenuAlt"
                type="AltType" />
  <xs:attribute name="MenuCommand"
                type="CommandType" />
  <xs:attribute name="PopulateDynamically"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="PopulateQueryCommand"
                type="CommandType" />
  <xs:attribute name="PopulateOnlyOnce"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipSelectedItemTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="LowScaleWarningType">
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Message"
                type="xs:string" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
 </xs:complexType>

 <xs:complexType name="OverflowAreaType">
  <xs:attribute name="DisplayMode"
                type="DisplayModeType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
 </xs:complexType>

 <xs:complexType name="OverflowSectionType">
  <xs:attribute name="DisplayMode"
                type="DisplayModeType" />
  <xs:attribute name="DividerAfter"
                type="xs:boolean" />
  <xs:attribute name="DividerBefore"
                type="xs:boolean" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="Type"
                type="SectionTypeType" />
 </xs:complexType>

 <xs:complexType name="QATType">
  <xs:sequence>
   <xs:element name="Controls"
               type="ControlsType"
               minOccurs="1"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="ImageDownArrow"
                type="ImageUrlType" />
  <xs:attribute name="ImageDownArrowClass"
                type="ImageClassType" />
  <xs:attribute name="ImageDownArrowLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageDownArrowTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageSideArrow"
                type="ImageUrlType" />
  <xs:attribute name="ImageSideArrowClass"
                type="ImageClassType" />
  <xs:attribute name="ImageSideArrowLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageSideArrowTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageUpArrow"
                type="ImageUrlType" />
  <xs:attribute name="ImageUpArrowClass"
                type="ImageClassType" />
  <xs:attribute name="ImageUpArrowLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageUpArrowTop"
                type="ImagePositionType" />
 </xs:complexType>

 <xs:complexType name="RibbonTemplatesType">
  <xs:sequence>
   <xs:element name="GroupTemplate"
               type="GroupTemplateType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
 </xs:complexType>

 <xs:complexType name="RibbonType">
  <xs:sequence>
   <xs:element name="Tabs"
               type="TabsType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="ContextualTabs"
               type="ContextualTabsType"
               minOccurs="1"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Image32by32GroupPopupDefault"
                type="ImageUrlType" />
  <xs:attribute name="Image32by32GroupPopupDefaultClass"
                type="ImageClassType" />
  <xs:attribute name="Image32by32GroupPopupDefaultLeft"
                type="ImagePositionType" />
  <xs:attribute name="Image32by32GroupPopupDefaultTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageDownArrow"
                type="ImageUrlType" />
  <xs:attribute name="ImageDownArrowClass"
                type="ImageClassType" />
  <xs:attribute name="ImageDownArrowLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageDownArrowTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageSideArrow"
                type="ImageUrlType" />
  <xs:attribute name="ImageSideArrowClass"
                type="ImageClassType" />
  <xs:attribute name="ImageSideArrowLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageSideArrowTop"
                type="ImagePositionType" />
  <xs:attribute name="ImageUpArrow"
                type="ImageUrlType" />
  <xs:attribute name="ImageUpArrowClass"
                type="ImageClassType" />
  <xs:attribute name="ImageUpArrowLeft"
                type="ImagePositionType" />
  <xs:attribute name="ImageUpArrowTop"
                type="ImagePositionType" />
  <xs:attribute name="RootEventCommand"
                type="CommandType" />
  <xs:attribute name="TabSwitchCommand"
                type="CommandType" />
  <xs:attribute name="ScaleCommand"
                type="CommandType" />
  <xs:attribute name="TextDirection"
                type="TextDirectionType" />
  <xs:attribute name="ToolTipFooterText"
                type="xs:string" />
  <xs:attribute name="ToolTipFooterImage16by16"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipFooterImage16by16Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipFooterImage16by16Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipFooterImage16by16Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipDisabledCommandImage16by16"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipDisabledCommandImage16by16Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipDisabledCommandImage16by16Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipDisabledCommandImage16by16Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipDisabledCommandDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipDisabledCommandTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDisabledCommandHelpKey"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpCommand"
                type="xs:string" />
  <xs:attribute name="ToolTipSelectedItemTitlePrefix"
                type="xs:string" />
  <xs:attribute name="ShortcutKeyJumpToRibbon_Ctrl"
                type="xs:string" />
  <xs:attribute name="ShortcutKeyJumpToRibbon_Alt"
                type="xs:string" />
  <xs:attribute name="ShortcutKeyJumpToRibbon_Shift"
                type="xs:string" />
  <xs:attribute name="ShortcutKeyJumpToRibbon_AccessKey"
                type="xs:string" />
  <xs:attribute name="ShortcutKeyJumpToFirstControl_Ctrl"
                type="xs:string" />
  <xs:attribute name="ShortcutKeyJumpToFirstControl_Alt"
                type="xs:string" />
  <xs:attribute name="ShortcutKeyJumpToFirstControl_Shift"
                type="xs:string" />
  <xs:attribute name="ShortcutKeyJumpToFirstControl_AccessKey"
                type="xs:string" />
  <xs:attribute name="ATContextualTabText"
                type="xs:string" />
  <xs:attribute name="ATTabPositionText"
                type="xs:string" />
  <xs:attribute name="NavigationHelpText"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="RowType">
  <xs:sequence>
   <xs:choice minOccurs="0"
              maxOccurs="unbounded">
    <xs:element name="ControlRef"
                type="ControlRefType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="Strip"
                type="StripType"
                minOccurs="0"
                maxOccurs="unbounded" />
    <xs:element name="OverflowArea"
                type="OverflowAreaType"
                minOccurs="0"
                maxOccurs="unbounded" />
   </xs:choice>
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="ScaleType">
  <xs:attribute name="GroupId"
                type="IdType"
                use="required" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="Size"
                type="SizeType"
                use="required" />
  <xs:attribute name="PopupSize"
                type="SizeType" />
 </xs:complexType>

 <xs:complexType name="ScalingType">
  <xs:sequence>
   <xs:element name="MaxSize"
               type="MaxSizeType"
               minOccurs="0"
               maxOccurs="unbounded"/>
   <xs:choice minOccurs="0"
              maxOccurs="unbounded">
    <xs:element name="Scale"
                type="ScaleType"
                minOccurs="0"
                maxOccurs="1"/>
    <xs:element name="LowScaleWarning"
                type="LowScaleWarningType"
                minOccurs="0"
                maxOccurs="1"/>
   </xs:choice>
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
 </xs:complexType>

 <xs:complexType name="SectionType">
  <xs:sequence>
   <xs:element name="Row"
               type="RowType"
               minOccurs="0"
               maxOccurs="3" />
  </xs:sequence>
  <xs:attribute name="Type"
                type="SectionTypeType" />
  <xs:attribute name="Alignment"
                type="SectionAlignmentType" />
 </xs:complexType>

 <xs:complexType name="SpinnerType">
  <xs:sequence>
   <xs:element name="Unit"
               type="UnitType"
               minOccurs="1"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="AccelerationInterval"
                type="xs:integer" />
  <xs:attribute name="AltDownArrow"
                type="AltType" />
  <xs:attribute name="AltUpArrow"
                type="AltType" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="DefaultUnit"
                type="UnitNameType" />
  <xs:attribute name="DefaultValue"
                type="ValueType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="ImeEnabled"
                type="xs:boolean" />
  <xs:attribute name="MultiplierInterval"
                type="xs:integer" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="SplitButtonType">
  <xs:sequence>
   <xs:element name="Menu"
               type="MenuType"
               minOccurs="0"
               maxOccurs="1"/>
  </xs:sequence>
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="CacheMenuVersions"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandMenuOpen"
                type="CommandType" />
  <xs:attribute name="CommandMenuClose"
                type="CommandType" />
  <xs:attribute name="CommandType"
                type="CommandTypeType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Image32by32"
                type="ImageUrlType" />
  <xs:attribute name="Image32by32Class"
                type="ImageClassType" />
  <xs:attribute name="Image32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="Image32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="Image16by16"
                type="ImageUrlType" />
  <xs:attribute name="Image16by16Class"
                type="ImageClassType" />
  <xs:attribute name="Image16by16Left"
                type="ImagePositionType" />
  <xs:attribute name="Image16by16Top"
                type="ImagePositionType" />
  <xs:attribute name="LabelText"
                type="LabelTextType" />
  <xs:attribute name="MenuAlt"
                type="AltType" />
  <xs:attribute name="MenuCommand"
                type="CommandType" />
  <xs:attribute name="PopulateDynamically"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="PopulateQueryCommand"
                type="CommandType" />
  <xs:attribute name="PopulateOnlyOnce"
                type="xs:boolean"
                default="false" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipSelectedItemTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
  <xs:attribute name="ModernImage"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="StripType">
  <xs:sequence>
   <xs:element name="ControlRef"
               type="ControlRefType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="TabType">
  <xs:sequence>
   <xs:element name="Scaling"
               type="ScalingType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="Groups"
               type="GroupsType"
               minOccurs="1"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CssClass"
                type="ClassNameType" />
  <xs:attribute name="Description"
                type="DescriptionType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="Title"
                type="TitleType" />
 </xs:complexType>

 <xs:complexType name="TabsType">
  <xs:sequence>
   <xs:element name="Tab"
               type="TabType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
 </xs:complexType>

 <xs:complexType name="TemplatesType">
  <xs:all>
   <xs:element name="RibbonTemplates"
               type="RibbonTemplatesType" />
  </xs:all>
 </xs:complexType>

 <xs:complexType name="TextBoxType">
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="ImeEnabled"
                type="xs:boolean" />
  <xs:attribute name="MaxLength"
                type="xs:integer" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="ShowAsLabel"
                type="xs:boolean" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
  <xs:attribute name="Width"
                type="PixelLengthType" />
 </xs:complexType>

 <xs:complexType name="ToggleButtonType">
  <xs:attribute name="Alt"
                type="AltType" />
  <xs:attribute name="Command"
                type="CommandType" />
  <xs:attribute name="CommandValueId"
                type="xs:string" />
  <xs:attribute name="Description"
                type="xs:string" />
  <xs:attribute name="Id"
                type="IdType"
                use="required" />
  <xs:attribute name="LabelCss"
                type="LabelCssType" />
  <xs:attribute name="LabelText"
                type="LabelTextType" />
  <xs:attribute name="Image32by32"
                type="ImageUrlType" />
  <xs:attribute name="Image32by32Class"
                type="ImageClassType" />
  <xs:attribute name="Image32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="Image32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="Image16by16"
                type="ImageUrlType" />
  <xs:attribute name="Image16by16Class"
                type="ImageClassType" />
  <xs:attribute name="Image16by16Left"
                type="ImagePositionType" />
  <xs:attribute name="Image16by16Top"
                type="ImagePositionType" />
  <xs:attribute name="MenuItemId"
                type="MenuItemIdType" />
  <xs:attribute name="QueryCommand"
                type="CommandType" />
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="TemplateAlias"
                type="TemplateAliasType" />
  <xs:attribute name="ToolTipImage32by32"
                type="ImageUrlType" />
  <xs:attribute name="ToolTipImage32by32Class"
                type="ImageClassType" />
  <xs:attribute name="ToolTipImage32by32Left"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipImage32by32Top"
                type="ImagePositionType" />
  <xs:attribute name="ToolTipTitle"
                type="xs:string" />
  <xs:attribute name="ToolTipDescription"
                type="xs:string" />
  <xs:attribute name="ToolTipHelpKeyWord"
                type="xs:string" />
  <xs:attribute name="ToolTipShortcutKey"
                type="xs:string" />
  <xs:attribute name="ModernImage"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="UnitType">
  <xs:sequence>
   <xs:element name="UnitAbbreviation"
               type="UnitAbbreviationType"
               minOccurs="1"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="Name"
                type="UnitNameType" />
  <xs:attribute name="MinimumValue"
                type="ValueType" />
  <xs:attribute name="MaximumValue"
                type="ValueType" />
  <xs:attribute name="DecimalDigits"
                type="xs:integer" />
  <xs:attribute name="Interval"
                type="xs:double" />
 </xs:complexType>

 <xs:complexType name="UnitAbbreviationType">
  <xs:attribute name="Sequence"
                type="SequenceType" />
  <xs:attribute name="Value"
                type="UnitNameType" />
 </xs:complexType>
</xs:schema>

See Also

Reference

Ribbon types schema

Other Resources

Customize commands and the ribbon
Customization XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Service calendar appearance configuration

You can control the appearance and behavior of the service calendar in the following ways:

  • Set time block appearance
  • Set smooth scroll limit
  • Set validation chunk size

To edit these settings you must export the ISV.Config file by adding it as part of a solution, edit the <IsvConfig> element in the customizations.xml file, and then re-import and publish the solution. More information: Export the ISV.Config

Set time block appearance

You can control the appearance of the rendered blocks in the service calendar. You can control the color used to render the given entity type and status code.

Create a CSS web resource with a display name of “AppointmentBookConfig”. In the CSS web resource, define CSS classes using the following naming convention:

[div.ganttBlock<entityname>Status<statuscode>]

For example, to set the CSS class to apply to a Service Activity entity status of Reserved, the CSS class could be defined as shown in the following example.

Copy Code
div.ganttBlockServiceAppointmentStatus4
{
border: 1px solid #848284;
FILTER: progid:DXImageTransform.Microsoft.Gradient(gradientType=0,startColorStr=#CEC7BD,endColorStr=#848284);
}

Set smooth scroll limit

You can specify the limit when smooth scrolling is used based on the number of blocks rendered in the service calendar.

When the service calendar renders more blocks than indicated in the SmoothScrollLimit element, the behavior changes from scrolling to simply jumping to the first appointment. The service calendar automatically scrolls to the first appointment when it’s first displayed and when a row is selected.

To set this value, you must export the ISV.Config file as part of a solution and locate the SmoothScrollLimit element at /ImportExportXml/IsvConfig/configuration/ServiceManagement/AppointmentBook/SmoothScrollLimit.

The default value is 2000. You must edit the value, and the re-import and publish the solution before the change will take effect.

Set validation chunk size

You can specify the number of appointments or service activities that are passed to the server at a time to check for scheduling errors in the service calendar.

To set this value you must export the ISV.Config file as part of a solution and locate the ValidationChunkSize element at /ImportExportXml/IsvConfig/configuration/ServiceManagement/AppointmentBook/ValidationChunkSize. This element isn’t included in the ISV.Config file by default so you must add it as a child of the AppointmentBook element.

Export the ISV.Config

When you export a solution the Export Solution dialog box provides the Export System Settings (Advanced) option page. Select ISV Config as an option. The IsvConfig element will be included as a child of the ImportExportXml node.

See Also

Reference

ISV configuration file schema
When to edit the customizations file
ISV configuration file schema

Concepts

Customize entity views
Create, export, or import an unmanaged solution
Publish customizations

Other Resources

Developers guide to customization for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ISV configuration file schema

This topic shows you the schema definition for the ISV Configuration section of an import/export customization file. This schema is included from the Customization solutions file schema. For more information, see Package and distribute extensions using solutions. You can find this schema in the SDK\Schemas\ISV.config.xsd file in the SDK package. Download the Microsoft Dynamics CRM SDK package.

Schema

Xml Copy Code
<?xml version="1.0"?>
<xs:schema attributeFormDefault="unqualified"
           elementFormDefault="qualified"
           xmlns:xs="http://www.w3.org/2001/XMLSchema">
 <xs:element name="configuration"
             type="IsvConfigurationType" />
 <xs:complexType name="IsvConfigurationType">
  <xs:sequence>
   <xs:element name="Root">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="NavBarAreas"
                  type="NavBarAreasType"
                  minOccurs="0"
                  maxOccurs="1">
      </xs:element>

      <xs:element name="MenuBar"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="CustomMenus"
                     minOccurs="0"
                     maxOccurs="1">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="Menu"
                        minOccurs="0"
                        maxOccurs="unbounded"
                        type="Menu" />
           </xs:sequence>
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="ToolBar"
                  type="ToolBar"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Areas"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:all>
         <xs:element name="Home"
                     type="NavigationArea"
                     maxOccurs="1"
                     minOccurs="0" />
         <xs:element name="Workplace"
                     type="NavigationArea"
                     maxOccurs="1"
                     minOccurs="0" />
         <xs:element name="Sales"
                     type="NavigationArea"
                     maxOccurs="1"
                     minOccurs="0" />
         <xs:element name="Marketing"
                     type="NavigationArea"
                     maxOccurs="1"
                     minOccurs="0" />
         <xs:element name="Service"
                     type="NavigationArea"
                     maxOccurs="1"
                     minOccurs="0" />
         <xs:element name="Reports"
                     type="NavigationArea"
                     maxOccurs="1"
                     minOccurs="0" />
        </xs:all>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="Entities"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="Entity"
                  type="EntityNode"
                  minOccurs="0"
                  maxOccurs="unbounded" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="ServiceManagement"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="AppointmentBook"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="SmoothScrollLimit"
                     type="xs:integer"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="ValidationChunkSize"
                     type="xs:integer"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="TimeBlocks"
                     minOccurs="0"
                     maxOccurs="1">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="TimeBlock"
                        type="TimeBlockNode"
                        minOccurs="0"
                        maxOccurs="unbounded" />
           </xs:sequence>
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
  <xs:attribute name="version"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <!--
A Timeblock definition
-->
 <xs:complexType name="TimeBlockNode">
  <xs:attribute name="EntityType"
                type="xs:string"
                use="required" />
  <xs:attribute name="StatusCode"
                type="xs:string"
                use="required" />
  <xs:attribute name="CssClass"
                type="xs:string"
                use="required" />
  <xs:attribute name="Client"
                type="xs:string"
                use="optional" />
  <xs:attribute name="AvailableOffline"
                type="xs:boolean"
                use="optional" />
 </xs:complexType>
 <!--
The Homepage Left Navigation Area
-->
 <xs:complexType name="NavigationArea">
  <xs:sequence>
   <xs:element minOccurs="0"
               maxOccurs="unbounded"
               name="NavBarItem">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="Titles"
                  minOccurs="1"
                  maxOccurs="1"
                  type="LocalizedTitles" />
     </xs:sequence>
     <xs:attribute name="Icon"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Url"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Id"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="PassParams"
                   type="CRM_Boolean"
                   use="optional" />
     <xs:attribute name="Client"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="AvailableOffline"
                   type="xs:boolean"
                   use="optional" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
  <xs:attribute name="code"
                type="xs:string"
                use="required" />
 </xs:complexType>
 <!--
A Menu that contains 1 or more Menu Items or Sub-Menus
-->
 <xs:complexType name="Menu">
  <xs:sequence>
   <xs:element name="Titles"
               minOccurs="0"
               maxOccurs="1"
               type="LocalizedTitles" />
   <xs:group ref="MenuNodes"
             minOccurs="0"
             maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="AccessKey"
                type="CRM_AccessKey"
                use="optional" />
  <xs:attribute name="ValidForCreate"
                type="CRM_Boolean"
                use="optional" />
  <xs:attribute name="ValidForUpdate"
                type="CRM_Boolean"
                use="optional" />
 </xs:complexType>
 <!--
Valid nodes that may appear inside of a Menu
This may appear in any order and may occur as many times as needed
-->
 <xs:group name="MenuNodes">
  <xs:choice>
   <xs:element name="MenuItem"
               type="MenuItem" />
   <xs:element name="MenuSpacer" />
   <xs:element name="SubMenu"
               type="Menu" />
  </xs:choice>
 </xs:group>
 <!--
A Menu Item that appears in a top-level menu or in a sub-menu
-->
 <xs:complexType name="MenuItem">
  <xs:sequence>
   <xs:element name="Titles"
               minOccurs="1"
               maxOccurs="1"
               type="LocalizedTitles" />
  </xs:sequence>
  <xs:attribute name="Url"
                type="xs:string"
                use="optional" />
  <xs:attribute name="Icon"
                type="xs:string"
                use="optional" />
  <xs:attribute name="WinMode"
                type="xs:unsignedByte"
                use="optional" />
  <xs:attribute name="PassParams"
                type="CRM_Boolean"
                use="optional" />
  <xs:attribute name="WinParams"
                type="xs:string"
                use="optional" />
  <xs:attribute name="JavaScript"
                type="xs:string"
                use="optional" />
  <xs:attribute name="Client"
                type="xs:string"
                use="optional" />
  <xs:attribute name="AvailableOffline"
                type="xs:boolean"
                use="optional" />
  <xs:attribute name="AccessKey"
                type="CRM_AccessKey"
                use="optional" />
  <xs:attribute name="ValidForCreate"
                type="CRM_Boolean"
                use="optional" />
  <xs:attribute name="ValidForUpdate"
                type="CRM_Boolean"
                use="optional" />
 </xs:complexType>
 <!--
A Tool Bar that contains buttons
-->
 <xs:complexType name="ToolBar">
  <xs:sequence>
   <xs:choice maxOccurs="unbounded">
    <xs:element name="Button">
     <xs:complexType>
      <xs:sequence>
       <xs:element name="Titles"
                   minOccurs="0"
                   maxOccurs="1"
                   type="LocalizedTitles" />
       <xs:element name="ToolTips"
                   minOccurs="0"
                   maxOccurs="1"
                   type="LocalizedToolTips" />
      </xs:sequence>
      <xs:attribute name="Icon"
                    type="xs:string"
                    use="optional" />
      <xs:attribute name="Url"
                    type="xs:string"
                    use="optional" />
      <xs:attribute name="JavaScript"
                    type="xs:string"
                    use="optional" />
      <xs:attribute name="PassParams"
                    type="CRM_Boolean"
                    use="optional" />
      <xs:attribute name="WinParams"
                    type="xs:string"
                    use="optional" />
      <xs:attribute name="WinMode"
                    type="xs:unsignedByte"
                    use="optional" />
      <xs:attribute name="Client"
                    type="xs:string"
                    use="optional" />
      <xs:attribute name="AvailableOffline"
                    type="xs:boolean"
                    use="optional" />
      <xs:attribute name="AccessKey"
                    type="CRM_AccessKey"
                    use="optional" />
      <xs:attribute name="ValidForCreate"
                    type="CRM_Boolean"
                    use="optional" />
      <xs:attribute name="ValidForUpdate"
                    type="CRM_Boolean"
                    use="optional" />
     </xs:complexType>
    </xs:element>
    <xs:element name="ToolBarSpacer" />
   </xs:choice>
  </xs:sequence>
  <xs:attribute name="ValidForCreate"
                type="CRM_Boolean"
                use="optional" />
  <xs:attribute name="ValidForUpdate"
                type="CRM_Boolean"
                use="optional" />
 </xs:complexType>
 <xs:complexType name="LocalizedTitles">
  <xs:sequence minOccurs="1"
               maxOccurs="unbounded">
   <xs:element name="Title"
               type="LocalizedLabel" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="LocalizedToolTips">
  <xs:sequence minOccurs="1"
               maxOccurs="unbounded">
   <xs:element name="ToolTip"
               type="LocalizedLabel" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="LocalizedLabel">
  <xs:attribute name="LCID"
                type="xs:integer" />
  <xs:attribute name="Text"
                type="xs:string" />
 </xs:complexType>
 <xs:complexType name="EntityNode">
  <xs:all>
   <xs:element name="MenuBar"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="CustomMenus"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="Menu"
                     minOccurs="0"
                     maxOccurs="unbounded"
                     type="Menu" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="ToolBar"
               minOccurs="0"
               maxOccurs="1"
               type="ToolBar" />
   <xs:element name="NavBar"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element maxOccurs="unbounded"
                  name="NavBarItem">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="Titles"
                     minOccurs="1"
                     maxOccurs="1"
                     type="LocalizedTitles" />
        </xs:sequence>
        <xs:attribute name="Icon"
                      type="xs:string"
                      use="required" />
        <xs:attribute name="Url"
                      type="xs:string"
                      use="required" />
        <xs:attribute name="Id"
                      type="xs:string"
                      use="required" />
        <xs:attribute name="PassParams"
                      type="CRM_Boolean"
                      use="optional" />
        <xs:attribute name="Area"
                      type="xs:string"
                      use="optional" />
        <xs:attribute name="Client"
                      type="xs:string"
                      use="optional" />
        <xs:attribute name="AvailableOffline"
                      type="xs:boolean"
                      use="optional" />
       </xs:complexType>
      </xs:element>
     </xs:sequence>
     <xs:attribute name="ValidForCreate"
                   type="CRM_Boolean"
                   use="optional" />
     <xs:attribute name="ValidForUpdate"
                   type="CRM_Boolean"
                   use="optional" />
    </xs:complexType>
   </xs:element>
   <xs:element name="Grid"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="MenuBar">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="ActionsMenu"
                     type="Menu"
                     minOccurs="0" />
         <xs:element name="Buttons"
                     type="ToolBar"
                     minOccurs="0" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:all>
  <xs:attribute name="name"
                type="xs:string"
                use="required" />
  <xs:attribute name="Client"
                type="CRM_Client"
                use="optional" />
  <xs:attribute name="AvailableOffline"
                type="xs:boolean"
                use="optional" />
 </xs:complexType>
 <xs:simpleType name="CRM_Client">
  <xs:restriction base="xs:string">
   <xs:pattern value="((None|Outlook|Web|All|OutlookWorkstationClient|OutlookLaptopClient),?)+" />
  </xs:restriction>
 </xs:simpleType>
 <xs:complexType name="NavBarAreasType">
  <xs:sequence>
   <xs:element name="NavBarArea"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="Titles"
                  minOccurs="1"
                  maxOccurs="1"
                  type="LocalizedTitles" />
     </xs:sequence>
     <xs:attribute name="Id"
                   type="xs:string"
                   use="required" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="NavBarType">
  <xs:choice minOccurs="0"
             maxOccurs="100000">
   <xs:element minOccurs="0"
               maxOccurs="1"
               name="NavBarItem">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="Titles"
                  minOccurs="1"
                  maxOccurs="1"
                  type="LocalizedTitles" />
     </xs:sequence>
     <xs:attribute name="Icon"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Url"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Id"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="PassParams"
                   type="CRM_Boolean"
                   use="optional" />
     <xs:attribute name="Area"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="Client"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="AvailableOffline"
                   type="xs:boolean"
                   use="optional" />
    </xs:complexType>
   </xs:element>
   <xs:element name="NavBarByRelationshipItem"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:all>
      <xs:element name="Titles"
                  minOccurs="0"
                  maxOccurs="1"
                  type="LocalizedTitles" />
      <xs:element name="ToolTip"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="Titles"
                     minOccurs="1"
                     maxOccurs="1"
                     type="LocalizedTitles" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="Privileges"
                  minOccurs="0"
                  maxOccurs ="1">
       <xs:complexType>
        <xs:sequence >
         <xs:element name ="Privilege"
                     minOccurs ="1"
                     maxOccurs ="100000">
          <xs:complexType>
           <xs:attribute name ="Entity"
                         type ="xs:string"
                         use ="required"/>
           <xs:attribute name="Privilege"
                         type ="xs:string"
                         use ="required"/>
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:all>
     <xs:attribute name="RelationshipName"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Id"
                   type="xs:string"
                   use="required" />
     <xs:attribute name="Area"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="TitleResourceId"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="Client"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="AvailableOffline"
                   type="xs:boolean"
                   use="optional" />
     <xs:attribute name="Icon"
                   type="xs:string"
                   use="optional" />
     <xs:attribute name="Sequence"
                   type="xs:nonNegativeInteger"
                   use="optional" />
     <xs:attribute name="Show"
                   type="xs:boolean"
                   use="optional" />
     <xs:attribute name="ViewId"
                   type="ISVGuid"
                   use="optional" />
    </xs:complexType>
   </xs:element>
  </xs:choice>
  <xs:attribute name="ValidForCreate"
                type="CRM_Boolean"
                use="optional" />
  <xs:attribute name="ValidForUpdate"
                type="CRM_Boolean"
                use="optional" />
 </xs:complexType>
 <xs:simpleType name="ISVGuid">
  <xs:restriction base="xs:string">
   <xs:pattern value="\{?[0-9a-fA-F]{8}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{12}\}?" />
  </xs:restriction>
 </xs:simpleType>

 <xs:simpleType name="CRM_Boolean">
  <xs:restriction base="xs:unsignedByte">
   <xs:minInclusive value="0" />
   <xs:maxInclusive value="1" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CRM_AccessKey">
  <xs:restriction base="xs:string">
   <xs:length value="1" />
  </xs:restriction>
 </xs:simpleType>
</xs:schema>

See Also

Reference

Edit the customizations XML file with schema validation

Concepts

Service calendar appearance configuration

Other Resources

Schemas used in Microsoft Dynamics CRM
ExportIsvConfig

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Publish customizations

Publishing customizations makes the Web application aware of changes to the data that affects the user interface.

When to publish customizations

Customizations are automatically published when new items are created or existing items are deleted.

You must publish changes after updating schema metadata or entities that affect the user interface. You can decide to wait and publish a set of related changes together.

Only published customizations are exported with a solution. You should always publish customizations before exporting a solution.

When you perform customizations that will appear in Microsoft Dynamics CRM for tablets, you should always explicitly publish your customizations to make sure that every item is synchronized with the CRM for tablets application.

Note
Publishing customizations can interfere with normal system operation. In a production environment, we recommend that you schedule publishing customizations when it’s least disruptive to users.

Publishing programmatically

The following table lists the two messages that you can use to publish customizations.

Message | Description
PublishAllXmlRequest | Publishes all customizations.
PublishXmlRequest | Publishes the specified customizations.

When you use the PublishXmlRequest message, you specify which items you want to publish by using the ParameterXml parameter. ParameterXML must comply with the Publish request schema.

Retrieving unpublished metadata

If you want to create an application to edit customizable items in Microsoft Dynamics CRM, you must retrieve any unpublished definitions of those items. If a developer defines some changes but does not publish them, your application must be able to retrieve them to display them in the user interface.

Use the following two methods to retrieve unpublished metadata:

RetrieveAsIfPublished parameter

Retrieves entity, attribute, entity relationship, and option set data by using the following messages:

  • RetrieveAllEntitiesRequest
  • RetrieveAllOptionSetsRequest
  • RetrieveAttributeRequest
  • RetrieveEntityRequest
  • RetrieveOptionSetRequest
  • RetrieveRelationshipRequest
RetrieveUnpublished Request

Retrieves user interface items, such as form, template, visualization and Web resource definitions, by using the following messages:

  • RetrieveUnpublishedRequest
  • RetrieveUnpublishedMultipleRequest

See Also

Reference

Publish request schema

Concepts

Customize entity forms
Customize entity views
Customize global option sets
Change application navigation using the SiteMap
Open forms, views, dialogs and reports with a URL
Write code for Microsoft Dynamics CRM forms
Web resources for Microsoft Dynamics CRM
JavaScript libraries for Microsoft Dynamics CRM

Other Resources

Developers guide to customization for Microsoft Dynamics CRM
Extend the metadata model
Customize commands and the ribbon

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Publish request schema

The following is the schema definition for the PublishXmlRequest message. For more information, see Publish customizations. You can find this schema in the SDK\Schemas\ParameterXml.xsd file in the SDK package. Download the Microsoft Dynamics CRM SDK package.

Schema

Xml Copy Code
<?xml version="1.0" encoding="utf-8"?>
<xs:schema attributeFormDefault="unqualified"
           elementFormDefault="qualified"
           xmlns:xs="http://www.w3.org/2001/XMLSchema">
 <xs:element name="importexportxml">
  <xs:complexType>
   <xs:sequence>
    <xs:element name="entities"
                minOccurs="0">
     <xs:complexType>
      <xs:sequence minOccurs="0"
                   maxOccurs="unbounded">
       <!-- Name of the entity to publish-->
       <xs:element maxOccurs="unbounded"
                   name="entity"
                   type="xs:string" />
      </xs:sequence>
     </xs:complexType>
    </xs:element>
    <xs:element name="ribbons"
                minOccurs="0">
     <xs:complexType>
      <xs:sequence minOccurs="0"
                   maxOccurs="unbounded">
       <!-- Application ribbon. : This value is not used. We publish the application ribbon if there is at least one <ribbon> node present -->
       <xs:element maxOccurs="unbounded"
                   name="ribbon"
                   type="xs:string" />
      </xs:sequence>
     </xs:complexType>
    </xs:element>
    <xs:element name="dashboards"
                minOccurs="0">
     <xs:complexType>
      <xs:sequence minOccurs="0"
                   maxOccurs="unbounded">
       <!-- Guid of the systemform to publish-->
       <xs:element maxOccurs="unbounded"
                   name="dashboard"
                   type="xs:string" />
      </xs:sequence>
     </xs:complexType>
    </xs:element>
    <xs:element name="optionsets"
                minOccurs="0">
     <xs:complexType>
      <xs:sequence minOccurs="0"
                   maxOccurs="unbounded">
       <!-- Name of the optionset to publish-->
       <xs:element maxOccurs="unbounded"
                   name="optionset"
                   type="xs:string" />
      </xs:sequence>
     </xs:complexType>
    </xs:element>
    <xs:element name="sitemaps"
                minOccurs="0">
     <xs:complexType>
      <xs:sequence minOccurs="0"
                   maxOccurs="unbounded">
       <!-- Guid of the sitemap to publish : This value is not used. We publish the sitemap if there is at least one <sitemap> node present-->
       <xs:element maxOccurs="unbounded"
                   name="sitemap"
                   type="xs:string" />
      </xs:sequence>
     </xs:complexType>
    </xs:element>
    <xs:element name="webresources"
                minOccurs="0">
     <xs:complexType>
      <xs:sequence minOccurs="0"
                   maxOccurs="unbounded">
       <!-- Guid of the web resource to publish -->
       <xs:element maxOccurs="unbounded"
                   name="webresource"
                   type="xs:string" />
      </xs:sequence>
     </xs:complexType>
    </xs:element>
   </xs:sequence>
  </xs:complexType>
 </xs:element>
</xs:schema>

See Also

Concepts

Publish customizations

Other Resources

Schemas used in Microsoft Dynamics CRM
PublishXmlRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


When to edit the customizations file

The customizations.xml file that is exported as part of an unmanaged solution can be edited to perform specific customization tasks. After editing the file you can compress the modified file together with the other files exported in the unmanaged solution. You apply the changes by importing that modified unmanaged solution.

Editing a complex XML file like the customizations.xml file is much easier and less prone to errors if you use a program designed to support schema validation. While it is possible to edit this file using a simple text editor like Notepad, this is not recommended unless you are very familiar with editing this file. For more information, see Edit the customizations XML file with schema validation.

Important
Invalid XML or incorrect definition of solution components can cause errors that will prevent importing a manually edited unmanaged solution.

Supported tasks

You can edit the customization.xml file to perform the following tasks.

Editing the ribbon

The Microsoft Dynamics CRM SDK describes the process of editing the ribbon by editing the customization.xml file directly. Several people have created ribbon editors that provide a user interface to make editing the ribbon easier. Currently the following projects are available on CodePlex:

  • Ribbon Editor for Microsoft Dynamics CRM 2011
  • MS CRM 2011 : Pragma Toolkit : Ribbon, Site Map Editor
  • CRM 2011 Visual Ribbon Editor
For support using these programs, contact the program publisher.

For more information about editing the ribbon by editing the customization.xml manually, see Customize commands and the ribbon.

Editing the SiteMap

The SDK describes the process of editing the SiteMap by editing the customization.xml file directly.

Several people have also created SiteMap editors. Currently the following projects are available on CodePlex:

  • SiteMap Editor for Microsoft Dynamics CRM 2011
  • MS CRM 2011 : Pragma Toolkit : Ribbon, Site Map Editor

For more information see Change application navigation using the SiteMap

Editing FormXml

FormXml is used to define entity forms and dashboards. The form editor and dashboard designer in the application are the most commonly used tools for this purpose. Editing the customizations.xml file is an alternative method. For more information, see Customize entity forms and Create a dashboard.

Editing saved queries

Definitions of views for entities are included in the customizations.xml file and may be manually edited. The view editor in the application is the most commonly used tool for this purpose. Editing customizations.xml is an alternative method. For more information, see Customize entity views.

Editing the ISV.config

In earlier versions of Microsoft Dynamics CRM, ISV.Config was the way to add client application extensions as well as some other configuration options. For Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online, the Ribbon provides the way to extend the application. The only remaining capability left in ISV.Config is to customize the appearance of the Service Calendar. For more information, see Service calendar appearance configuration.

Unsupported tasks

Defining any other solution components by editing the exported customizations.xml file is not supported. This includes the following:

  • Entities
  • Attributes
  • Entity Relationships
  • Entity Messages
  • Option Sets
  • Web Resources
  • Processes (Workflows)
  • Plugin Assemblies
  • SDK Message Processing steps
  • Service Endpoints
  • Reports
  • Connection Roles
  • Article Templates
  • Contract Templates
  • E-mail Templates
  • Mail Merge Templates
  • Security Roles
  • Field Security Profiles

See Also

Reference

Customization solutions file schema
Saved query XML reference
Edit the customizations XML file with schema validation

Other Resources

Developers guide to customization for Microsoft Dynamics CRM
Customization XML reference
Ribbon XML reference
SiteMap XML reference
Form XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Edit the customizations XML file with schema validation

The customizations.xml file is included within the compressed .zip file exported as a solution. Certain portions of the customizations.xml file can be edited manually. Information about the schema helps you confirm that any modifications you make are valid.

XSD schema files

The XSD schema files used to validate the customization.xml file in a solution are available at SDK\Schemas. The necessary files are:

  • CustomizationsSolution.xsd
  • fetch.xsd
  • FormXml.xsd
  • isv.config.xsd
  • RibbonCore.xsd
  • RibbonTypes.xsd
  • RibbonWSS.xsd
  • SiteMap.xsd
  • SiteMapType.xsd
  • VisualizationDataDescription.xsd

These files are also installed on the on-premises Microsoft Dynamics CRM 2015 server at: [Install Drive]\Program Files\Microsoft Dynamics CRM\Server\ApplicationFiles

CustomizationsSolution.xsd is the schema for the exported solution. It contains references to the other XSD files. All the files should be located in the same folder.

Using schema validation

Because the exported XML is a text file, you can edit it using a text editor such as Notepad. However, we strongly recommend that you use an application that supports XSD schema validation such as Microsoft Visual Studio. XSD validation in Microsoft Visual Studio or Visual Studio Express 2012 for Web provides IntelliSense information and schema validation to help prevent errors.

The XSD schema files that are used to validate the customization.xml file in a solution are available at SDK\Schemas. Make sure to copy all the files from that folder into the same directory. You will need to associate the customizations.xml file to the CustomizationsSolution.xsd file. That file has links to all the other XSD files in the folder.

  1. Download the XSD schema files and copy all of them to your computer. Save them in the location that Microsoft Visual Studio uses for XSD validation files. This location is probably [install drive]\Program Files (x86)\Microsoft Visual Studio X.0\Xml\Schemas where X represents the version of Visual Studio.

  2. Right-click the customizations.xml file and select Open With and then select the version of Visual Studio.

  3. Select View and then select Properties Window.

  4. In the Properties window, in the Schemas field, click the ellipsis [...] button.

  5. In the Xml Schemas dialog box you should see the customizationsSolution.xsd. In the Use column, select Use this schema.

    Note
    If you do not see it, click Add and browse to where you saved it.

  6. Click OK.

You are now ready to begin editing the XML with XSD validation.

See Also

Reference

When to edit the customizations file
Saved query XML reference
ISV configuration file schema

Other Resources

Ribbon XML reference
SiteMap XML reference
Form XML reference
Build queries with FetchXML

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customization solutions file schema

The following is the schema definition for an import/export customization file from Microsoft Dynamics CRM. Note that this file includes the following schemas:

  • ISV configuration file schema
  • SiteMap schema
  • Ribbon core schema

For more information, see Package and distribute extensions using solutions. You can find this schema in the SDK\Schemas\CustomizationsSolution.xsd file in the SDK package. Download the Microsoft Dynamics CRM SDK package.

Schema

Xml Copy Code
<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
           elementFormDefault="qualified"
           attributeFormDefault="unqualified">
 <xs:include schemaLocation="isv.config.xsd" />
 <xs:include schemaLocation="SiteMapType.xsd" />
 <xs:include schemaLocation="FormXml.xsd" />
 <xs:include schemaLocation="Fetch.xsd" />
 <xs:simpleType name="ObjectTypeCodeType">
  <xs:restriction base="xs:positiveInteger"></xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="TrueFalseType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="True" />
   <xs:enumeration value="False" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="GuidType">
  <xs:annotation>
   <xs:documentation xml:lang="en">
    The representation of a GUID, generally the id of an element.
   </xs:documentation>
  </xs:annotation>
  <xs:restriction base="xs:string">
   <xs:pattern value="\{[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}\}" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="LengthPositiveInteger">
  <xs:restriction base="xs:positiveInteger" />
 </xs:simpleType>
 <xs:simpleType name="LengthMax">
  <xs:restriction base="xs:string">
   <xs:pattern value="max" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="LengthMinusOne">
  <xs:restriction base="xs:string">
   <xs:pattern value="-1" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="LengthType">
  <xs:union memberTypes="LengthPositiveInteger LengthMax LengthMinusOne" />
 </xs:simpleType>
 <xs:simpleType name="PercentageType">
  <xs:restriction base="xs:string">
   <xs:pattern value="^(100|[0-9]{1,2})%$" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="OptionSetEnumType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="picklist" />
   <xs:enumeration value="state" />
   <xs:enumeration value="status" />
   <xs:enumeration value="bit" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CrmDataType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="virtual" />
   <xs:enumeration value="primarykey" />
   <xs:enumeration value="uniqueidentifier" />
   <xs:enumeration value="char" />
   <xs:enumeration value="nchar" />
   <xs:enumeration value="varchar" />
   <xs:enumeration value="nvarchar" />
   <xs:enumeration value="ntext" />
   <xs:enumeration value="text" />
   <xs:enumeration value="numeric" />
   <xs:enumeration value="int" />
   <xs:enumeration value="smallint" />
   <xs:enumeration value="tinyint" />
   <xs:enumeration value="bigint" />
   <xs:enumeration value="binary" />
   <xs:enumeration value="varbinary" />
   <xs:enumeration value="image" />
   <xs:enumeration value="float" />
   <xs:enumeration value="decimal" />
   <xs:enumeration value="real" />
   <xs:enumeration value="money" />
   <xs:enumeration value="smallmoney" />
   <xs:enumeration value="bit" />
   <xs:enumeration value="timezone" />
   <xs:enumeration value="datetime" />
   <xs:enumeration value="smalldatetime" />
   <xs:enumeration value="timestamp" />
   <xs:enumeration value="lookup" />
   <xs:enumeration value="picklist" />
   <xs:enumeration value="partylist" />
   <xs:enumeration value="customer" />
   <xs:enumeration value="owner" />
   <xs:enumeration value="state" />
   <xs:enumeration value="status" />
   <xs:enumeration value="sql_variant" />
   <xs:enumeration value="phoneticguide" />
   <xs:enumeration value="HierarchyId" />
   <xs:enumeration value="managedproperty" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CrmCascadeSecurityLinkType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="ActiveOnly" />
   <xs:enumeration value="Cascade" />
   <xs:enumeration value="NoCascade" />
   <xs:enumeration value="UserOwned" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CrmCascadeDeleteLinkType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Cascade" />
   <xs:enumeration value="NoCascade" />
   <xs:enumeration value="RemoveLink" />
   <xs:enumeration value="Restrict" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="NavPaneDisplayOptionType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="UseCollectionName" />
   <xs:enumeration value="UseLabel" />
   <xs:enumeration value="DoNotDisplay" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="NavPaneAreaType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Details" />
   <xs:enumeration value="Sales" />
   <xs:enumeration value="Service" />
   <xs:enumeration value="Marketing" />
   <xs:enumeration value="InternetMarketing" />
   <xs:enumeration value="ProcessCenter" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CrmEntityIconType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="GridIcon" />
   <xs:enumeration value="NavigationIcon" />
   <xs:enumeration value="OutlookShortcutIcon" />
   <xs:enumeration value="WatermarkIcon" />
   <xs:enumeration value="LargeEntityIcon" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="EntityAttributeNameBaseType">
  <xs:restriction base="xs:string">
   <xs:minLength value="1" />
   <xs:maxLength value="50" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="EntityAttributeLocalizedNameBaseType">
  <xs:restriction base="xs:string">
   <xs:minLength value="1" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="EntityRelationshipTypeType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="OneToMany" />
   <xs:enumeration value="ManyToMany" />
  </xs:restriction>
 </xs:simpleType>
 <xs:complexType name="EntityRelationshipRolesType">
  <xs:sequence>
   <xs:element name="EntityRelationshipRole"
               minOccurs="1"
               maxOccurs="2">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="NavPaneDisplayOption"
                  type="NavPaneDisplayOptionType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="NavPaneArea"
                  type="NavPaneAreaType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="NavPaneOrder"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CustomLabels"
                  type="CustomLabelsType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="AssociationRoleOrdinal"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:element name="LocalizedName"
             type="EntityAttributeLocalizedNameBaseType" />
 <xs:element name="LocalizedCollectionName"
             type="EntityAttributeLocalizedNameBaseType" />
 <xs:complexType name="EntityNameType">
  <xs:simpleContent>
   <xs:extension base="EntityAttributeNameBaseType">
    <xs:attribute name="LocalizedName"
                  type="EntityAttributeLocalizedNameBaseType"
                  use="required" />
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:complexType name="LocalizedCollectionNamesType">
  <xs:sequence>
   <xs:element name="LocalizedCollectionName"
               type="FieldXmlFieldUIType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="CustomLabelsType">
  <xs:sequence>
   <xs:element name="CustomLabel"
               type="FieldXmlFieldUIType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="LookupTypesType">
  <xs:sequence>
   <xs:element minOccurs="0"
               maxOccurs="unbounded"
               name="LookupType">
    <xs:complexType>
     <xs:simpleContent>
      <xs:extension base="xs:integer">
       <xs:attribute name="id"
                     type="xs:string"
                     use="required" />
      </xs:extension>
     </xs:simpleContent>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="displaynamestype">
  <xs:sequence>
   <xs:element name="displayname"
               type="FieldXmlFieldUIType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="statestype">
  <xs:sequence>
   <xs:element name="state"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="labels"
                  minOccurs="1"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="label"
                     type="FieldXmlFieldUIType"
                     minOccurs="1"
                     maxOccurs="unbounded" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="Descriptions"
                  type="DescriptionsType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
     <xs:attribute name="value"
                   use="required"
                   type="xs:integer" />
     <xs:attribute name="defaultstatus"
                   use="required"
                   type="xs:integer" />
     <xs:attribute name="invariantname"
                   use="required"
                   type="xs:string" />
     <xs:attribute name="addedby"
                   type="xs:string"></xs:attribute>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="statusestype">
  <xs:sequence>
   <xs:element name="status"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="labels"
                  minOccurs="1"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="label"
                     type="FieldXmlFieldUIType"
                     minOccurs="1"
                     maxOccurs="unbounded" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="Descriptions"
                  type="DescriptionsType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
     <xs:attribute name="value"
                   use="required"
                   type="xs:integer" />
     <xs:attribute name="state"
                   type="xs:integer" />
     <xs:attribute name="defaultstatus"
                   type="xs:integer" />
     <xs:attribute name="addedby"
                   type="xs:string"></xs:attribute>
     <xs:attribute name="TransitionData"
                   type="xs:string"></xs:attribute>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="optionsetstype">
  <xs:sequence>
   <xs:element name="optionset"
               type="optionsettype"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="optionsettype">
  <xs:sequence>
   <xs:element name="OptionSetType"
               type="OptionSetEnumType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsGlobal"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IntroducedVersion"
               type="VersionType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsCustomizable"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="displaynames"
               type="displaynamestype"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Descriptions"
               type="DescriptionsType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="options"
               type="optionstype"
               minOccurs="0"
               maxOccurs="1"/>
   <xs:element name="statuses"
               type="statusestype"
               minOccurs="0"
               maxOccurs="1"/>
   <xs:element name="states"
               type="statestype"
               minOccurs="0"
               maxOccurs="1"/>
  </xs:sequence>
  <xs:attribute name="Name"
                use="required"
                type="xs:string" />
  <xs:attribute name="localizedName"
                use="optional"
                type="xs:string" />
  <xs:attribute name="description"
                use="optional"
                type="xs:string" />
  <xs:attribute name="unmodified"
                use="optional"
                type="TrueFalse01Type" />
 </xs:complexType>

 <xs:complexType name="pluginassembliestype">
  <xs:sequence>
   <xs:element name="PluginAssembly"
               type="pluginassemblytype"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="pluginassemblytype">
  <xs:sequence>
   <xs:element name="Description"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsolationMode"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="SourceType"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Path"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IntroducedVersion"
               type="VersionType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="FileName"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="PluginTypes"
               type="plugintypestype"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsHidden"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="FullName"
                use="required"
                type="xs:string" />
  <xs:attribute name="CustomizationLevel"
                use="optional"
                type="xs:integer" />
  <xs:attribute name="unmodified"
                use="optional"
                type="TrueFalse01Type" />
 </xs:complexType>

 <xs:complexType name="plugintypestype">
  <xs:sequence>
   <xs:element name="PluginType"
               type="plugintypetype"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="plugintypetype">
  <xs:sequence>
   <xs:element name="Description"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="FriendlyName"
               type="xs:string"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="WorkflowActivityGroupName"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="Name"
                use="optional"
                type="xs:string" />
  <xs:attribute name="AssemblyQualifiedName"
                use="required"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="sdkmessageprocessingstepstype">
  <xs:sequence>
   <xs:element name="SdkMessageProcessingStep"
               type="sdkmessageprocessingsteptype"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="sdkmessageprocessingsteptype">
  <xs:sequence>
   <xs:element name="PluginTypeName"
               type="xs:string"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="PrimaryEntity"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="SecondaryEntity"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="AsyncAutoDelete"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Configuration"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Description"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="FilteringAttributes"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="ImpersonatingUserIdName"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="InvocationSource"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Mode"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Rank"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="SdkMessageId"
               type="GuidType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="EventHandler"
               type="GuidType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="EventHandlerTypeCode"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Stage"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsCustomizable"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsHidden"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="SupportedDeployment"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IntroducedVersion"
               type="VersionType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="SdkMessageProcessingStepImages"
               type="sdkmessageprocessingstepimagestype"
               minOccurs="0"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="SdkMessageProcessingStepId"
                use="required"
                type="GuidType" />
  <xs:attribute name="Name"
                use="optional"
                type="xs:string" />
  <xs:attribute name="unmodified"
                use="optional"
                type="TrueFalse01Type" />
 </xs:complexType>

 <xs:complexType name="sdkmessageprocessingstepimagestype">
  <xs:sequence>
   <xs:element name="SdkMessageProcessingStepImage"
               type="sdkmessageprocessingstepimagetype"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="sdkmessageprocessingstepimagetype">
  <xs:sequence>
   <xs:element name="Description"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="SdkMessageProcessingStepImageId"
               type="GuidType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Attributes"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="EntityAlias"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="ImageType"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="MessagePropertyName"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="RelatedAttributeName"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsCustomizable"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IntroducedVersion"
               type="VersionType"
               minOccurs="0"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="Name"
                use="optional"
                type="xs:string" />
 </xs:complexType>

 <xs:complexType name="serviceendpointstype">
  <xs:sequence>
   <xs:element name="ServiceEndpoint"
               type="serviceendpointtype"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="serviceendpointtype">
  <xs:sequence>
   <xs:element name="ConnectionMode"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Contract"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Description"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Path"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="SolutionNamespace"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="UserClaim"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsCustomizable"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IntroducedVersion"
               type="VersionType"
               minOccurs="0"
               maxOccurs="1" />
  </xs:sequence>
  <xs:attribute name="ServiceEndpointId"
                use="required"
                type="GuidType" />
  <xs:attribute name="Description"
                use="optional"
                type="xs:string" />
  <xs:attribute name="Name"
                use="optional"
                type="xs:string" />
  <xs:attribute name="unmodified"
                use="optional"
                type="TrueFalse01Type" />

 </xs:complexType>

 <xs:complexType name="webresourcestype">
  <xs:sequence>
   <xs:element name="WebResource"
               type="webresourcetype"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="webresourcetype">
  <xs:sequence>
   <xs:element name="WebResourceId"
               type="GuidType"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="Name"
               type="xs:string"
               minOccurs="1"
               maxOccurs="1" />
   <xs:element name="DisplayName"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="Description"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="SilverlightVersion"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="LanguageCode"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="WebResourceType"
               type="xs:integer"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IntroducedVersion"
               type="VersionType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsEnabledForMobileClient"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsCustomizable"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="CanBeDeleted"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="IsHidden"
               type="TrueFalse01Type"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="FileName"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1"/>
  </xs:sequence>
  <xs:attribute name="unmodified"
                use="optional"
                type="TrueFalse01Type" />
 </xs:complexType>
 <xs:complexType name="optionstype">
  <xs:sequence>
   <xs:element name="option"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="labels"
                  minOccurs="1"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="label"
                     type="FieldXmlFieldUIType"
                     minOccurs="1"
                     maxOccurs="unbounded" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="Descriptions"
                  type="DescriptionsType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
     <xs:attribute name="id"
                   type="GuidType" />
     <xs:attribute name="value"
                   use="required"
                   type="xs:integer" />
     <xs:attribute name="addedby"
                   type="xs:string" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:simpleType name="CrmIdentifier">
  <xs:restriction base="xs:string">
   <xs:pattern value="[a-zA-Z0-9_]+" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CrmClient">
  <xs:restriction base="xs:string">
   <xs:pattern value="((Outlook|Web|All|OutlookWorkstationClient|OutlookLaptopClient),?)+" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CrmLicense">
  <xs:restriction base="xs:string">
   <xs:pattern value="((SmallBusiness|Professional|All),?)+" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="CrmPrivilegeId">
  <xs:restriction base="xs:string">
   <xs:pattern value="((Read|Write|Append|AppendTo|Create|Delete|Share|Assign|All|AllowQuickCampaign),?)+" />
  </xs:restriction>
 </xs:simpleType>
 <xs:complexType name="LookupType">
  <xs:simpleContent>
   <xs:extension base="GuidType">
    <xs:attribute name="name"
                  type="xs:string" />
    <xs:attribute name="dsc"
                  type="xs:nonNegativeInteger" />
   </xs:extension>
  </xs:simpleContent>
 </xs:complexType>
 <xs:element name="ImportExportXml">
  <xs:complexType>
   <xs:sequence>
    <xs:element name="Entities"
                type="EntitiesType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="Roles"
                type="RolesType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="Workflows"
                type="WorkflowsType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="FieldSecurityProfiles"
                type="FieldSecurityProfilesType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="Templates"
                type="CrmTemplatesType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="RibbonDiffXml"
                type="RibbonGlobalDiffXmlType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="IsvConfig"
                minOccurs="0"
                maxOccurs="1">
     <xs:complexType>
      <xs:sequence>
       <xs:element name="configuration"
                   type="IsvConfigurationType"
                   maxOccurs="1" />
      </xs:sequence>
     </xs:complexType>
    </xs:element>
    <xs:element name="RelationshipRoles"
                type="RelationshipRolesType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="ConnectionRoles"
                type="ConnectionRolesType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="SiteMap"
                minOccurs="0"
                maxOccurs="1">
     <xs:complexType>
      <xs:sequence>
       <xs:element name="SiteMap"
                   type="SiteMapType"
                   maxOccurs="1">
        <xs:unique name="AreaIdMustBeUnique">
         <xs:selector xpath="Area" />
         <xs:field xpath="@Id" />
        </xs:unique>
       </xs:element>
      </xs:sequence>
     </xs:complexType>
    </xs:element>
    <xs:element name="EntityMaps"
                type="EntityMapsType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="EntityRelationships"
                type="EntityRelationShipsType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="OrganizationSettings"
                type="OrganizationSettingsType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="optionsets"
                type="optionsetstype"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="Reports"
                type="ReportsType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="RoutingRules"
                type="RoutingRulesType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="ConvertRules"
                type="ConvertRulesType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="Slas"
                type="SlasType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="Dashboards"
                type="DashboardsType"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="WebResources"
                type="webresourcestype"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="SolutionPluginAssemblies"
                type="pluginassembliestype"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="SdkMessageProcessingSteps"
                type="sdkmessageprocessingstepstype"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="ServiceEndpoints"
                type="serviceendpointstype"
                minOccurs="0"
                maxOccurs="1" />
    <xs:element name="Languages"
                type="LanguagesType"
                minOccurs="0"
                maxOccurs="1" />
   </xs:sequence>
  </xs:complexType>
 </xs:element>
 <xs:complexType name="LanguagesType">
  <xs:sequence>
   <xs:element name="Language"
               type="xs:nonNegativeInteger"
               minOccurs="1"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="DependentType">
  <xs:attribute name="type"
                use="required"
                type="xs:string" />
  <xs:attribute name="name"
                use="required"
                type="xs:string" />
 </xs:complexType>
 <xs:complexType name="DependentsType">
  <xs:sequence>
   <xs:element name="Dependent"
               type="DependentType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="EntitiesType">
  <xs:sequence>
   <xs:element name="Entity"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:all>
      <xs:element name="Name"
                  minOccurs="1"
                  maxOccurs="1">
       <xs:complexType>
        <xs:simpleContent>
         <xs:extension base="EntityNameType">
          <xs:attribute name="OriginalName"
                        type="xs:string"
                        use="required" />
         </xs:extension>
        </xs:simpleContent>
       </xs:complexType>
      </xs:element>
      <xs:element name="ObjectTypeCode"
                  type="ObjectTypeCodeType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="EntityInfo"
                  type="EntityInfoType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="FormXml"
                  minOccurs="0"
                  maxOccurs="1" >
       <xs:complexType>
        <xs:sequence>
         <xs:element name="forms"
                     type="SystemFormsType"
                     minOccurs="0"
                     maxOccurs="unbounded">
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="SavedQueries"
                  type="SavedQueriesType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Visualizations"
                  type="VisualizationsType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="RibbonDiffXml"
                  type="RibbonEntityDiffXmlType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Icons"
                  type="IconsType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Strings"
                  type="StringsType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="HierarchyRules"
                  type="HierarchyRulesType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:all>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="EntityInfoType">
  <xs:choice minOccurs="1"
             maxOccurs="1">
   <xs:element name="entity">
    <xs:complexType>
     <xs:all>
      <xs:element name="HasRelatedNotes"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="HasRelatedActivities"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsConnectionsEnabled"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsDocumentManagementEnabled"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsCollaboration"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="AutoRouteToOwnerQueue"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="AutoCreateAccessTeams"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="OwnershipTypeMask"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsAuditEnabled"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsActivity"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ActivityTypeMask"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsActivityParty"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsReplicated"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsReplicationUserFiltered"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsRequiredOffline"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsDuplicateCheckSupported"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsBusinessProcessEnabled"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsMailMergeEnabled"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsVisibleInMobile"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="MobileClientType"
                  type="xs:int"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsVisibleInMobileClient"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsReadOnlyInMobileClient"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsReadingPaneEnabled"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsMapiGridEnabled"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsCustomizable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsRenameable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsMappable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanModifyConnectionSettings"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanModifyAuditSettings"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanModifyMobileVisibility"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanModifyMobileClientVisibility"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanModifyMobileClientReadOnly"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanModifyDuplicateDetectionSettings"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanModifyMailMergeSettings"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanModifyQueueSettings"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanCreateAttributes"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanBeRelatedEntityInRelationship"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanBePrimaryEntityInRelationship"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanBeInManyToMany"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanCreateForms"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanCreateCharts"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanCreateViews"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanModifyAdditionalSettings"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="LocalizedNames"
                  type="LocalizedNamesType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="LocalizedCollectionNames"
                  type="LocalizedCollectionNamesType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Descriptions"
                  type="DescriptionsType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="EntityMask"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="EntityHelpUrlEnabled"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="EntityHelpUrl"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IconLargeName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IconMediumName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IconSmallName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsQuickCreateEnabled"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IntroducedVersion"
                  type="VersionType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="EnforceStateTransitions"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanChangeHierarchicalRelationship"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="attributes"
                  minOccurs="1"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="attribute"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:complexType>
           <xs:all>
            <xs:element name="Type"
                        type="CrmDataType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="Name"
                        type="EntityAttributeNameBaseType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="LogicalName"
                        type="EntityAttributeNameBaseType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="IsCustomField"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="ValidForCreateApi"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="ValidForReadApi"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="ValidForUpdateApi"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="DisplayMask"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="Length"
                        type="LengthType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="IsLogical"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="AttributeOf"
                        type="EntityAttributeNameBaseType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="YomiOf"
                        type="EntityAttributeNameBaseType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="CalculationOf"
                        type="EntityAttributeNameBaseType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="AggregateOf"
                        type="EntityAttributeNameBaseType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="IsAuditEnabled"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="XmlAbbreviation"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="ImeMode"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="RequiredLevel"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="LinkedAttribute"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="Format"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="MaxLength"
                        type="xs:integer"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="MinValue"
                        type="xs:double"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="MaxValue"
                        type="xs:double"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="Accuracy"
                        type="xs:integer"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="Descriptions"
                        type="DescriptionsType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="displaynames"
                        type="displaynamestype"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="OptionSetName"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="optionset"
                        type="optionsettype"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="AppDefaultValue"
                        type="xs:integer"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="AccuracySource"
                        type="xs:integer"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="ReferencedEntityObjectTypeCode"
                        type="ObjectTypeCodeType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="LookupBrowse"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="LookupStyle"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="LookupTypes"
                        type="LookupTypesType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="IsSecured"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="IsCustomizable"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="IsRenameable"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="CanModifySearchSettings"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="CanModifyRequirementLevelSettings"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="CanModifyFieldLevelSecuritySettings"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="CanModifyAdditionalSettings"
                        type="TrueFalse01Type"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="IntroducedVersion"
                        type="VersionType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="SourceType"
                        type="xs:integer"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="FormulaDefinitionFileName"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
           </xs:all>
           <xs:attribute name="PhysicalName"
                         use="required"
                         type="EntityAttributeNameBaseType" />
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:all>
     <xs:attribute name="Name"
                   use="required"
                   type="EntityAttributeNameBaseType" />
    </xs:complexType>
   </xs:element>
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="ConvertRulesType">
  <xs:choice minOccurs="0"
             maxOccurs="unbounded">
   <xs:element name="ConvertRule">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="ConvertRuleItems"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="ConvertRuleItem"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="ConvertRuleItemId"
                        type="GuidType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="ConvertRuleId"
                        type="GuidType"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="Name"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="Description"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="ConditionXml"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="PropertiesXml"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
           </xs:sequence>
           <xs:attribute name="ConvertRuleItemId"
                         type="xs:string"
                         use="required" />
           <xs:attribute name="Name"
                         use="required"
                         type="xs:string" />
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="ConvertRuleId"
                  type="GuidType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Name"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="SourceTypeCode"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="AllowUnknownSender"
                  type="xs:boolean"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="SendAutomaticResponse"
                  type="xs:boolean"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CheckIfResolved"
                  type="xs:boolean"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CheckActiveEntitlement"
                  type="xs:boolean"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CheckDirectMessages"
                  type="xs:boolean"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CheckBlockedSocialProfile"
                  type="xs:boolean"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ResponseTemplateId"
                  type="GuidType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ResolvedSince"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="WorkflowId"
                  type="GuidType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
     <xs:attribute name="ConvertRuleId"
                   use="required"
                   type="xs:string" />
     <xs:attribute name="Name"
                   use="required"
                   type="xs:string" />
    </xs:complexType>
   </xs:element>
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="RoutingRulesType">
  <xs:choice minOccurs="0"
             maxOccurs="unbounded">
   <xs:element name="RoutingRule">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="RoutingRuleId"
                  type="GuidType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Name"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Description"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="RoutingRuleItems"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="RoutingRuleItem"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="Name"
                        type="xs:string"
                        minOccurs="1"
                        maxOccurs="1" />
            <xs:element name="Description"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="RoutingRuleId"
                        type="GuidType"
                        minOccurs="1"
                        maxOccurs="1" />
            <xs:element name="ConditionXml"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
           </xs:sequence>
           <xs:attribute name="RoutingRuleItemId"
                         type="xs:string"
                         use="required" />
           <xs:attribute name="Name"
                         use="required"
                         type="xs:string" />
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="Workflows"
                  type="WorkflowsType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
     <xs:attribute name="RoutingRuleId"
                   use="required"
                   type="xs:string" />
     <xs:attribute name="Name"
                   use="required"
                   type="xs:string" />
    </xs:complexType>
   </xs:element>
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="HierarchyRulesType">
  <xs:choice minOccurs="0"
             maxOccurs="unbounded">
   <xs:element name="HierarchyRule">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="HierarchyRuleID"
                  type="GuidType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="PrimaryEntityFormID"
                  type="GuidType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="PrimaryEntityLogicalName"
                  type="xs:string"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="ShowDisabled"
                  type="TrueFalse01Type"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="IntroducedVersion"
                  type="VersionType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsCustomizable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="LocalizedNames"
                  type="LocalizedNamesType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="Descriptions"
                  type="DescriptionsType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="EntityMapsType">
  <xs:choice minOccurs="0"
             maxOccurs="unbounded">
   <xs:element name="EntityMap">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="EntitySource"
                  type="xs:string"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="EntityTarget"
                  type="xs:string"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="AttributeMaps"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="AttributeMap"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="AttributeSource"
                        type="EntityAttributeNameBaseType"
                        minOccurs="1"
                        maxOccurs="1" />
            <xs:element name="AttributeTarget"
                        type="EntityAttributeNameBaseType"
                        minOccurs="1"
                        maxOccurs="1" />
           </xs:sequence>
           <xs:attribute name="addedby"
                         type="xs:string" />
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
     <xs:attribute name="addedby"
                   type="xs:string" />
    </xs:complexType>
   </xs:element>
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="RolesType">
  <xs:sequence>
   <xs:element name="Role"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="IsCustomizable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IntroducedVersion"
                  type="VersionType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="RolePrivileges"
                  type="RolePrivilegestype"
                  minOccurs="0"
                  maxOccurs="1"/>
     </xs:sequence>
     <xs:attribute name="name"
                   use="required"
                   type="xs:string" />
     <xs:attribute name="id"
                   use="required"
                   type="GuidType" />
     <xs:attribute name="unmodified"
                   use="optional"
                   type="TrueFalse01Type" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="RolePrivilegestype">
  <xs:sequence>
   <xs:element name="RolePrivilege"
               type="RolePrivilegeType"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="RolePrivilegeType">
  <xs:attribute name="name"
                use="required"
                type="xs:string" />
  <xs:attribute name="level"
                use="required"
                type="PrivilegeLevelType" />
 </xs:complexType>
 <xs:simpleType name="PrivilegeLevelType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Basic" />
   <xs:enumeration value="Local" />
   <xs:enumeration value="Deep" />
   <xs:enumeration value="Global" />
  </xs:restriction>
 </xs:simpleType>
 <xs:complexType name="FieldSecurityProfilesType">
  <xs:sequence>
   <xs:element name="FieldSecurityProfile"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="FieldPermissions"
                  type="FieldPermissionsType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
     <xs:attribute name="name"
                   use="required"
                   type="xs:string" />
     <xs:attribute name="description"
                   use="optional"
                   type="xs:string" />
     <xs:attribute name="fieldsecurityprofileid"
                   use="required"
                   type="GuidType" />
     <xs:attribute name="unmodified"
                   use="optional"
                   type="TrueFalse01Type" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="FieldPermissionsType">
  <xs:sequence>
   <xs:element name="FieldPermission"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="EntityName"
                  type="xs:string"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="AttributeName"
                  type="xs:string"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="CanRead"
                  type="xs:integer"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="CanUpdate"
                  type="xs:integer"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="CanCreate"
                  type="xs:integer"
                  minOccurs="1"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="WorkflowsType">
  <xs:sequence>
   <xs:element name="Workflow"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="XamlFileName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Type"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Subprocess"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Category"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Mode"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="LanguageCode"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Scope"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="OnDemand"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="TriggerOnUpdateAttributeList"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="TriggerOnCreate"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="TriggerOnDelete"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="AsyncAutodelete"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="SyncWorkflowLogOnFailure"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="StateCode"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="StatusCode"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CreateStage"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="UpdateStage"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="DeleteStage"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Rank"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="processorder"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="processroleassignment"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="RunAs"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="SdkMessageId"
                  type="GuidType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="UniqueName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsTransacted"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IntroducedVersion"
                  type="VersionType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsCustomizable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="RendererObjectTypeCode"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="PrimaryEntity"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="labels"
                  minOccurs="0"
                  maxOccurs="1"
                  type="WorkflowLabelsType"/>
      <xs:element name="ProcessTriggers"
                  type="ProcessTriggersType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
     <xs:attribute name="Name"
                   use="required"
                   type="xs:string" />
     <xs:attribute name="Description"
                   use="optional"
                   type="xs:string" />
     <xs:attribute name="WorkflowId"
                   use="required"
                   type="GuidType" />
     <xs:attribute name="unmodified"
                   use="optional"
                   type="TrueFalse01Type" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="WorkflowLabelsType">
  <xs:sequence>
   <xs:element name="steplabels"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="label"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:attribute name="languagecode"
                      type="xs:string"
                      use="required"/>
        <xs:attribute name="description"
                      type="xs:string"
                      use="required"/>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
     <xs:attribute name="id"
                   use="required"
                   type="GuidType"/>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="ProcessTriggersType">
  <xs:sequence>
   <xs:element name="ProcessTrigger"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="controltype"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="methodid"
                  type="GuidType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="formid"
                  type="GuidType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="scope"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="controlname"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="event"
                  type="xs:string"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="iscustomizable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="primaryentitytypecode"
                  type="xs:string"
                  minOccurs="1"
                  maxOccurs="1" />
     </xs:sequence>
     <xs:attribute name="processtriggerid"
                   use="required"
                   type="GuidType" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="DashboardsType">
  <xs:sequence>
   <xs:element name="Dashboard"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:all>
      <xs:element name="FormId"
                  type="GuidType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="LocalizedNames"
                  type="LocalizedNamesType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="Descriptions"
                  type="DescriptionsType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsCustomizable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsDefault"
                  type="SerializedTrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanBeDeleted"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="FormXml"
                  type="FormXmlType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IntroducedVersion"
                  type="VersionType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsTabletEnabled"
                  type="SerializedTrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:all>
     <xs:attribute name="unmodified"
                   use="optional"
                   type="TrueFalse01Type" />
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="ReportsType">
  <xs:sequence>
   <xs:element name="ReportSignatureIdMappings"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="ReportSignatureIdMapping"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:attribute name="reportid"
                      type="GuidType"
                      use="required" />
        <xs:attribute name="signatureid"
                      type="GuidType"
                      use="required" />
        <xs:attribute name="signaturelcid"
                      type="xs:integer"
                      use="required" />
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="Report"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:all>
      <xs:element name="name"
                  type="xs:string"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="defaultfilter"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:annotation> </xs:annotation>
      </xs:element>
      <xs:element name="iscustomreport"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="description"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="filename"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="languagecode"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="bodyurl"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="mimetype"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="reportid"
                  type="GuidType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="iscustomizable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IntroducedVersion"
                  type="VersionType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="createdinmajorversion"
                  type="xs:int"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="reporttypecode"
                  minOccurs="1"
                  maxOccurs="1">
       <xs:simpleType>
        <xs:restriction base="xs:integer">
         <xs:enumeration value="1" />
         <xs:enumeration value="2" />
         <xs:enumeration value="3" />
        </xs:restriction>
       </xs:simpleType>
      </xs:element>
      <xs:element name="ExportedFileName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ReportVisibilities"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="ReportVisbility"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:simpleType>
           <xs:restriction base="xs:integer">
            <xs:enumeration value="1" />
            <xs:enumeration value="2" />
            <xs:enumeration value="3" />
           </xs:restriction>
          </xs:simpleType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="ReportCategories"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="ReportCategory"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:complexType>
           <xs:simpleContent>
            <xs:extension base="xs:integer">
             <xs:attribute name="name"
                           type="xs:string"
                           use="required" />
            </xs:extension>
           </xs:simpleContent>
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="ReportEntities"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="ReportEntity"
                     type="EntityAttributeNameBaseType"
                     minOccurs="0"
                     maxOccurs="unbounded" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:all>
     <xs:attribute name="unmodified"
                   use="optional"
                   type="TrueFalse01Type" />
    </xs:complexType>
   </xs:element>
   <xs:element name="ReportLinks"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="ReportLink"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:attribute name="reportid"
                      type="GuidType"
                      use="required" />
        <xs:attribute name="parentreportid"
                      type="GuidType"
                      use="required" />
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="SlasType">
  <xs:choice minOccurs="0"
             maxOccurs="unbounded">
   <xs:element name="Sla">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="SLAId"
                  type="GuidType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ApplicableFrom"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Name"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="Description"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="AllowPauseResume"
                  type="xs:boolean"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="SLAType"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="SlaItems"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="SlaItem"
                     minOccurs="0"
                     maxOccurs="unbounded">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="slaid"
                        type="xs:string"
                        minOccurs="1"
                        maxOccurs="1" />
            <xs:element name="slaitemid"
                        type="xs:string"
                        minOccurs="1"
                        maxOccurs="1" />
            <xs:element name="relatedfield"
                        type="xs:string"
                        minOccurs="1"
                        maxOccurs="1" />
            <xs:element name="name"
                        type="xs:string"
                        minOccurs="1"
                        maxOccurs="1" />
            <xs:element name="description"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="applicablewhenxml"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="successconditionsxml"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="sequencenumber"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="workflowid"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="failureafter"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
            <xs:element name="warnafter"
                        type="xs:string"
                        minOccurs="0"
                        maxOccurs="1" />
           </xs:sequence>
           <xs:attribute name="slaitemid"
                         type="xs:string"
                         use="required" />
           <xs:attribute name="name"
                         use="required"
                         type="xs:string" />
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
     <xs:attribute name="SLAId"
                   use="required"
                   type="xs:string" />
     <xs:attribute name="Name"
                   use="required"
                   type="xs:string" />
    </xs:complexType>
   </xs:element>
  </xs:choice>
 </xs:complexType>

 <xs:complexType name="OrganizationSettingsType">
  <xs:sequence>
   <xs:element name="general"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="fullnameconventioncode"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="numberformat"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="negativeformatcode"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="currencysymbol"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="currencyformatcode"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="pricingdecimalprecision"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="sharetopreviousowneronassign"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="blockedattachments"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="getstartedpanecontentenabled"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ispresenceenabled"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="isautosaveenabled"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="globalhelpurl"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="globalhelpurlenabled"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="globalappendurlparametersenabled"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="calendar"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="weekstartdaycode"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="calendartype"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="dateformatcode"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="dateseparator"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="timeformatcode"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="showweeknumber"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="maxappointmentdurationdays"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="email"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="trackingprefix"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="trackingtokenidbase"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="trackingtokeniddigits"
                  type="xs:byte"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="maximumtrackingnumber"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ignoreinternalemail"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="rendersecureiframeforemail"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="allowunresolvedpartiesonemailsend"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="marketing"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="allowmarketingemailexecution"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="allowautoresponsecreation"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="allowautounsubscribe"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="allowautounsubscribeacknowledgement"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="acknowledgementtemplateid"
                  type="GuidType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="customization"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="isappmode"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="outlookSynchronization"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="tagpollingperiod"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="tagmaxaggressivecycles"
                  type="xs:byte"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="allowoutlookscheduledsyncs"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="minoutlooksyncinterval"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="emailsendpollingperiod"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="allowofflinescheduledsyncs"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="minofflinesyncinterval"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="allowaddressbooksyncs"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="minaddressbooksyncinterval"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="autoNumbering"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="campaignprefix"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="contractprefix"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="caseprefix"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="kbprefix"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="orderprefix"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="invoiceprefix"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="uniquespecifierlength"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="sales"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="useinbuiltrulefordefaultpricelistselection"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="maxproductsinbundle"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="oobpricecalculationenabled"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="discountcalculationmethod"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="maximumdynamicpropertiesallowed"
                  type="xs:integer"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="createproductswithoutparentinactivestate"
                  type="TrueFalseType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="EntityRelationShipsType">
  <xs:choice minOccurs="0"
             maxOccurs="unbounded">
   <xs:element name="EntityRelationship">
    <xs:complexType>
     <xs:all>
      <xs:element name="EntityRelationshipType"
                  type="EntityRelationshipTypeType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="IntroducedVersion"
                  type="VersionType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsHierarchical"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsCustomizable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ReferencingAttributeName"
                  type="EntityAttributeNameBaseType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ReferencingAttributeRequiredLevel"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="RelationshipDescription"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="Descriptions"
                     type="DescriptionsType"
                     minOccurs="0"
                     maxOccurs="1" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
      <xs:element name="ReferencingEntityName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="ReferencedEntityName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="FirstEntityName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="SecondEntityName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IntersectEntityName"
                  type="xs:string"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CascadeAssign"
                  type="CrmCascadeSecurityLinkType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CascadeDelete"
                  type="CrmCascadeDeleteLinkType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CascadeReparent"
                  type="CrmCascadeSecurityLinkType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CascadeShare"
                  type="CrmCascadeSecurityLinkType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CascadeUnshare"
                  type="CrmCascadeSecurityLinkType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IsValidForAdvancedFind"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="field"
                  minOccurs="0"
                  maxOccurs="1">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="IsCustomizable"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IsRenameable"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="CanModifySearchSettings"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="CanModifyRequirementLevelSettings"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="CanModifyFieldLevelSecuritySettings"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IsSecured"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="DisplayMask"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IsAuditEnabled"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="LinkedAttribute"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="displaynames"
                     type="displaynamestype"
                     minOccurs="0"
                     maxOccurs="unbounded" />
        </xs:sequence>
        <xs:attribute name="name"
                      type="xs:string"
                      use="required" />
        <xs:attribute name="requiredlevel"
                      type="xs:string"
                      use="required" />
        <xs:attribute name="imemode"
                      type="xs:string"
                      use="optional" />
        <xs:attribute name="lookupstyle"
                      type="xs:string"
                      use="optional" />
        <xs:attribute name="lookupbrowse"
                      type="TrueFalse01Type"
                      use="optional" />
        <xs:attribute name="lookuptypes"
                      type="xs:string"
                      use="optional" />
        <xs:attribute name="format"
                      type="xs:string"
                      use="optional" />
       </xs:complexType>
      </xs:element>
      <xs:element name="EntityRelationshipRoles"
                  type="EntityRelationshipRolesType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:all>
     <xs:attribute name="Name"
                   use="required"
                   type="xs:string" />
    </xs:complexType>
   </xs:element>
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="IconsType">
  <xs:sequence>
   <xs:element name="Icon"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:simpleContent>
      <xs:extension base="xs:base64Binary">
       <xs:attribute name="type"
                     use="required"
                     type="CrmEntityIconType" />
      </xs:extension>
     </xs:simpleContent>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="StringsType">
  <xs:choice maxOccurs="unbounded">
   <xs:element name="Strings"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="String"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:simpleContent>
         <xs:extension base="xs:string">
          <xs:attribute name="languagecode"
                        use="required"
                        type="xs:string" />
          <xs:attribute name="Comment"
                        use="required"
                        type="xs:string" />
         </xs:extension>
        </xs:simpleContent>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
     <xs:attribute name="ResourceKey"
                   use="required"
                   type="xs:string" />
    </xs:complexType>
   </xs:element>
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="FormXmlType">
  <xs:sequence>
   <xs:element name="forms"
               type="FormsType"
               minOccurs="0"
               maxOccurs="unbounded">
   </xs:element>
  </xs:sequence>
  <xs:attribute name="addedby"
                type="xs:string" />
  <xs:attribute name="id"
                type="GuidType" />
 </xs:complexType>
 <xs:complexType name="FormsType">
  <xs:sequence>
   <xs:element name="form"
               type="FormType"
               minOccurs="1"
               maxOccurs="unbounded" />
  </xs:sequence>
  <xs:attribute name="type"
                type="SystemFormType" />
 </xs:complexType>
 <xs:complexType name="SystemFormsType">
  <xs:sequence>
   <xs:element name="systemform"
               minOccurs="1"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:all>
      <xs:element name="formid"
                  type="GuidType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="IsCustomizable"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="IntroducedVersion"
                  type="VersionType"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="CanBeDeleted"
                  type="TrueFalse01Type"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="FormPresentation"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="FormActivationState"
                  type="xs:nonNegativeInteger"
                  minOccurs="0"
                  maxOccurs="1" />
      <xs:element name="form"
                  type="FormType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="LocalizedNames"
                  type="LocalizedNamesType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="Descriptions"
                  type="DescriptionsType"
                  minOccurs="0"
                  maxOccurs="1" />
     </xs:all>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
  <xs:attribute name="type"
                type="SystemFormType" />
 </xs:complexType>
 <xs:simpleType name="NonEmptyStringType">
  <xs:restriction base="xs:string">
   <xs:minLength value="1" />
  </xs:restriction>
 </xs:simpleType>
 <xs:complexType name="RelationshipRolesType">
  <xs:sequence>
   <xs:element name="RelationshipRole"
               minOccurs="0"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="relationshiproleid"
                  type="GuidType"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="name"
                  type="xs:string"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="statecode"
                  type="xs:nonNegativeInteger"
                  minOccurs="1"
                  maxOccurs="1" />
      <xs:element name="RelationshipRoleMap"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="relationshiprolemapid"
                     type="GuidType"
                     minOccurs="1"
                     maxOccurs="1" />
         <xs:element name="associateobjecttypecode"
                     type="ObjectTypeCodeType"
                     minOccurs="1"
                     maxOccurs="1" />
         <xs:element name="primaryobjecttypecode"
                     type="ObjectTypeCodeType"
                     minOccurs="1"
                     maxOccurs="1" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="ConnectionRolesType">
  <xs:sequence>
   <xs:element name="ConnectionRoles"
               minOccurs="1"
               maxOccurs="unbounded">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="ConnectionRole"
                  minOccurs="1"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="connectionroleid"
                     type="GuidType"
                     minOccurs="1"
                     maxOccurs="1" />
         <xs:element name="name"
                     type="xs:string"
                     minOccurs="1"
                     maxOccurs="1" />
         <xs:element name="category"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="description"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IsCustomizable"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IntroducedVersion"
                     type="VersionType"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="ConnectionRoleObjectTypeCodes"
                     minOccurs="0"
                     maxOccurs="1" >
          <xs:complexType>
           <xs:sequence>
            <xs:element name="ConnectionRoleObjectTypeCode"
                        minOccurs="1"
                        maxOccurs="unbounded">
             <xs:complexType>
              <xs:sequence>
               <xs:element name="connectionroleobjecttypecodeid"
                           type="GuidType"
                           minOccurs="1"
                           maxOccurs="1" />
               <xs:element name="associatedobjecttypecode"
                           type="xs:string"
                           minOccurs="1"
                           maxOccurs="1" />
              </xs:sequence>
             </xs:complexType>
            </xs:element>
           </xs:sequence>
          </xs:complexType>
         </xs:element>
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="ConnectionRoleAssociations"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="ConnectionRoleAssociation"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:sequence>
         <xs:element name="connectionroleid"
                     type="GuidType"
                     minOccurs="1"
                     maxOccurs="1" />
         <xs:element name="associatedconnectionroleid"
                     type="GuidType"
                     minOccurs="1"
                     maxOccurs="1" />
        </xs:sequence>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>
 <xs:complexType name="CrmTemplatesType">
  <xs:sequence>
   <xs:element name="KBArticleTemplates"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="kbarticletemplate"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:all>
         <xs:element name="kbarticletemplateid"
                     type="GuidType"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="structurexml"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="formatxml"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="title"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="description"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="languagecode"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IsCustomizable"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IntroducedVersion"
                     type="VersionType"
                     minOccurs="0"
                     maxOccurs="1" />
        </xs:all>
        <xs:attribute name="addedby"
                      type="xs:string" />
        <xs:attribute name="id"
                      use="optional"
                      type="GuidType" />
        <xs:attribute name="name"
                      use="optional"
                      type="xs:string" />
        <xs:attribute name="description"
                      use="optional"
                      type="xs:string" />
        <xs:attribute name="unmodified"
                      use="optional"
                      type="TrueFalse01Type" />
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="EmailTemplates"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="emailtemplate"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:all>
         <xs:element name="templateid"
                     type="GuidType"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="subject"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="subjectpresentationxml"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="ispersonal"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="mimetype"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="templatetypecode"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="generationtypecode"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="body"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="title"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="description"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="presentationxml"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="versionnumber"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="languagecode"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IsCustomizable"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="ActivityMimeAttachments"
                     type="activitymimeattachmentstype"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IntroducedVersion"
                     type="VersionType"
                     minOccurs="0"
                     maxOccurs="1" />
        </xs:all>
        <xs:attribute name="addedby"
                      type="xs:string" />
        <xs:attribute name="id"
                      use="optional"
                      type="GuidType" />
        <xs:attribute name="name"
                      use="optional"
                      type="xs:string" />
        <xs:attribute name="description"
                      use="optional"
                      type="xs:string" />
        <xs:attribute name="unmodified"
                      use="optional"
                      type="TrueFalse01Type" />
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="ContractTemplates"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="contracttemplate"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:all>
         <xs:element name="contracttemplateid"
                     type="GuidType"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="name"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="abbreviation"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="description"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IsCustomizable"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IntroducedVersion"
                     type="VersionType"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="contractservicelevelcode"
                     minOccurs="0"
                     maxOccurs="1">
          <xs:complexType>
           <xs:simpleContent>
            <xs:extension base="xs:nonNegativeInteger">
             <xs:anyAttribute processContents="skip" />
            </xs:extension>
           </xs:simpleContent>
          </xs:complexType>
         </xs:element>
         <xs:element name="billingfrequencycode"
                     minOccurs="0"
                     maxOccurs="1">
          <xs:complexType>
           <xs:simpleContent>
            <xs:extension base="xs:nonNegativeInteger">
             <xs:anyAttribute processContents="skip" />
            </xs:extension>
           </xs:simpleContent>
          </xs:complexType>
         </xs:element>
         <xs:element name="allotmenttypecode"
                     minOccurs="0"
                     maxOccurs="1">
          <xs:complexType>
           <xs:simpleContent>
            <xs:extension base="xs:nonNegativeInteger">
             <xs:anyAttribute processContents="skip" />
            </xs:extension>
           </xs:simpleContent>
          </xs:complexType>
         </xs:element>
         <xs:element name="usediscountaspercentage"
                     minOccurs="0"
                     maxOccurs="1">
          <xs:complexType>
           <xs:simpleContent>
            <xs:extension base="xs:nonNegativeInteger">
             <xs:anyAttribute processContents="skip" />
            </xs:extension>
           </xs:simpleContent>
          </xs:complexType>
         </xs:element>
         <xs:element name="effectivitycalendar"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
        </xs:all>
        <xs:attribute name="addedby"
                      type="xs:string" />
        <xs:attribute name="id"
                      use="optional"
                      type="GuidType" />
        <xs:attribute name="name"
                      use="optional"
                      type="xs:string" />
        <xs:attribute name="description"
                      use="optional"
                      type="xs:string" />
        <xs:attribute name="unmodified"
                      use="optional"
                      type="TrueFalse01Type" />
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
   <xs:element name="MailMergeTemplates"
               minOccurs="0"
               maxOccurs="1">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="mailmergetemplate"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:all>
         <xs:element name="mailmergetemplateid"
                     type="GuidType"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="name"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="defaultfilter"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="filename"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="parameterxml"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="mimetype"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="templatetypecode"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="mailmergetype"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="filesize"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="documentformat"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="languagecode"
                     type="xs:nonNegativeInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="body"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="description"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="entityPlatformName"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1"/>
         <xs:element name="IsCustomizable"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IntroducedVersion"
                     type="VersionType"
                     minOccurs="0"
                     maxOccurs="1" />
        </xs:all>
        <xs:attribute name="addedby"
                      type="xs:string" />
        <xs:attribute name="id"
                      use="optional"
                      type="GuidType" />
        <xs:attribute name="name"
                      use="optional"
                      type="xs:string" />
        <xs:attribute name="description"
                      use="optional"
                      type="xs:string" />
        <xs:attribute name="unmodified"
                      use="optional"
                      type="TrueFalse01Type" />
       </xs:complexType>
      </xs:element>
     </xs:sequence>
    </xs:complexType>
   </xs:element>
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="activitymimeattachmentstype">
  <xs:sequence>
   <xs:element name="ActivityMimeAttachment"
               type="activitymimeattachmenttype"
               minOccurs="0"
               maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="activitymimeattachmenttype">
  <xs:sequence>
   <xs:element name="activitymimeattachmentid"
               type="GuidType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="attachmentid"
               type="GuidType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="attachmentnumber"
               type="xs:nonNegativeInteger"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="filename"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="filesize"
               type="xs:nonNegativeInteger"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="objectid"
               type="GuidType"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="mimetype"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="subject"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
   <xs:element name="SolutionAttachmentsFileName"
               type="xs:string"
               minOccurs="0"
               maxOccurs="1" />
  </xs:sequence>
 </xs:complexType>

 <xs:complexType name="SavedQueriesType">
  <xs:choice maxOccurs="unbounded">
   <xs:element name="savedqueries">
    <xs:complexType>
     <xs:sequence>
      <xs:element name="savedquery"
                  minOccurs="0"
                  maxOccurs="unbounded">
       <xs:complexType>
        <xs:all>
         <xs:element name="savedqueryid"
                     type="GuidType"
                     minOccurs="1"
                     maxOccurs="1" />
         <xs:element name="queryapi"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="LocalizedNames"
                     type="LocalizedNamesType"
                     minOccurs="1"
                     maxOccurs="1" />
         <xs:element name="Descriptions"
                     type="DescriptionsType"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="IsCustomizable"
                     type="SerializedTrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="CanBeDeleted"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="isquickfindquery"
                     type="SerializedTrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="fetchxml"
                     minOccurs="0"
                     maxOccurs="1">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="fetch"
                        type="FetchType"
                        minOccurs="0"
                        maxOccurs="1" />
           </xs:sequence>
          </xs:complexType>
         </xs:element>
         <xs:element name="IntroducedVersion"
                     type="VersionType"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="isdefault"
                     type="SerializedTrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="isprivate"
                     type="TrueFalse01Type"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="returnedtypecode"
                     type="SerializedInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="conditionalformatting"
                     type="xs:string"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="layoutxml"
                     minOccurs="0"
                     maxOccurs="1">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="grid"
                        minOccurs="0"
                        maxOccurs="1">
             <xs:complexType>
              <xs:sequence>
               <xs:element name="row"
                           minOccurs="0"
                           maxOccurs="unbounded">
                <xs:complexType>
                 <xs:sequence>
                  <xs:element name="cell"
                              minOccurs="0"
                              maxOccurs="unbounded">
                   <xs:complexType>
                    <xs:attribute name="name"
                                  type="xs:string" />
                    <xs:attribute name="width"
                                  type="xs:nonNegativeInteger" />
                    <xs:attribute name="disableMetaDataBinding"
                                  type="TrueFalse01Type" />
                    <xs:attribute name="LabelId"
                                  type="xs:string" />
                    <xs:attribute name="ishidden"
                                  type="TrueFalse01Type" />
                    <xs:attribute name="disableSorting"
                                  type="TrueFalse01Type" />
                    <xs:attribute name="addedby"
                                  type="xs:string" />
                    <xs:attribute name="desc"
                                  type ="xs:string" />
                    <xs:attribute name="cellType"
                                  type ="xs:string" />
                   </xs:complexType>
                  </xs:element>
                 </xs:sequence>
                 <xs:attribute name="name"
                               type="xs:string" />
                 <xs:attribute name="id"
                               type="xs:string" />
                 <xs:attribute name="multiobjectidfield"
                               type="xs:string" />
                 <xs:attribute name="layoutstyle"
                               type="xs:string" />
                </xs:complexType>
               </xs:element>
              </xs:sequence>
              <xs:attribute name="name"
                            type="xs:string" />
              <xs:attribute name="object"
                            type="ObjectTypeCodeType" />
              <xs:attribute name="jump"
                            type="xs:string" />
              <xs:attribute name="select"
                            type="TrueFalse01Type" />
              <xs:attribute name="icon"
                            type="TrueFalse01Type" />
              <xs:attribute name="preview"
                            type="TrueFalse01Type" />
              <xs:attribute name="iconrenderer"
                            type="xs:string" />
             </xs:complexType>
            </xs:element>
           </xs:sequence>
          </xs:complexType>
         </xs:element>
         <xs:element name="querytype"
                     type="SerializedInteger"
                     minOccurs="0"
                     maxOccurs="1" />
         <xs:element name="columnsetxml"
                     minOccurs="0"
                     maxOccurs="1">
          <xs:complexType>
           <xs:sequence>
            <xs:element name="columnset"
                        minOccurs="0"
                        maxOccurs="1">
             <xs:complexType>
              <xs:choice minOccurs="0"
                         maxOccurs="unbounded">
               <xs:element name="ascend"
                           type="xs:string"
                           minOccurs="0" />
               <xs:element name="descend"
                           type="xs:string"
                           minOccurs="0" />
               <xs:element name="column"
                           minOccurs="0"
                           maxOccurs="unbounded">
                <xs:complexType>
                 <xs:simpleContent>
                  <xs:extension base="xs:string">
                   <xs:attribute name="addedby"
                                 type="xs:string" />
                  </xs:extension>
                 </xs:simpleContent>
                </xs:complexType>
               </xs:element>
               <xs:element ref="filter"
                           minOccurs="0"
                           maxOccurs="unbounded" />
              </xs:choice>
              <xs:attribute name="version"
                            type="xs:string" />
              <xs:attribute name="distinct"
                            type="xs:boolean" />
             </xs:complexType>
            </xs:element>
           </xs:sequence>
          </xs:complexType>
         </xs:element>
        </xs:all>
       </xs:complexType>
      </xs:element>
     </xs:sequence>
     <xs:attribute name="entity"
                   type="xs:string" />
     <xs:attribute name="morerecords"
                   type="xs:string" />
     <xs:attribute name="paging-cookie"
                   type="xs:string" />
     <xs:attribute name="version"
                   type="xs:string" />
    </xs:complexType>
   </xs:element>
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="VisualizationsType">
  <xs:choice maxOccurs="unbounded">
   <xs:sequence>
    <xs:element name="visualization"
                minOccurs ="0"
                maxOccurs="unbounded">
     <xs:complexType>
      <xs:all>
       <xs:element name="savedqueryvisualizationid"
                   type="GuidType"
                   minOccurs="1"
                   maxOccurs="1"/>
       <xs:element name="LocalizedNames"
                   type="LocalizedNamesType"
                   minOccurs="1"
                   maxOccurs="1" />
       <xs:element name="Descriptions"
                   type="DescriptionsType"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="webresourcename"
                   type="xs:string"
                   minOccurs="0"
                   maxOccurs="1"/>
       <xs:element name="customizationlevel"
                   minOccurs="0"
                   maxOccurs="1">
        <xs:complexType>
         <xs:simpleContent>
          <xs:extension base="xs:integer">
           <xs:attribute name="formattedvalue"
                         type="xs:integer"
                         use="required" />
          </xs:extension>
         </xs:simpleContent>
        </xs:complexType>
       </xs:element>

       <xs:element name="datadescription"
                   minOccurs="0"
                   maxOccurs="1">
        <xs:annotation> </xs:annotation>
       </xs:element>
       <xs:element name="presentationdescription"
                   minOccurs="0"
                   maxOccurs="1">
        <xs:annotation> </xs:annotation>
       </xs:element>
       <xs:element name="isdefault"
                   type="SerializedTrueFalse01Type"
                   minOccurs="0"
                   maxOccurs ="1"/>
       <xs:element name="IsCustomizable"
                   type="TrueFalse01Type"
                   minOccurs="0"
                   maxOccurs="1" />
       <xs:element name="IntroducedVersion"
                   type="VersionType"
                   minOccurs="0"
                   maxOccurs="1" />
      </xs:all>
     </xs:complexType>
    </xs:element>
   </xs:sequence>
  </xs:choice>
 </xs:complexType>
 <xs:complexType name="IgnoredType">
  <xs:sequence>
   <xs:any processContents="skip"
           minOccurs="0"
           maxOccurs="unbounded" />
  </xs:sequence>
 </xs:complexType>
 <xs:simpleType name="ChartGridMode">
  <xs:restriction base="xs:string">
   <xs:enumeration value="Chart" />
   <xs:enumeration value="Grid" />
   <xs:enumeration value="All" />
  </xs:restriction>
 </xs:simpleType>
 <xs:simpleType name="SystemFormType">
  <xs:restriction base="xs:string">
   <xs:enumeration value="main" />
   <xs:enumeration value="preview" />
   <xs:enumeration value="appointmentBook" />
   <xs:enumeration value="minicampaignbo" />
   <xs:enumeration value="mobile" />
   <xs:enumeration value="dashboard" />
   <xs:enumeration value="other" />
   <xs:enumeration value="quick" />
   <xs:enumeration value="quickCreate" />
  </xs:restriction>
 </xs:simpleType>
</xs:schema>

See Also

Reference

When to edit the customizations file

Concepts

Create, install, and update a managed solution
Create, export, or import an unmanaged solution

Other Resources

Customization XML reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Add custom help content

With Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, administrators can configure what help content page will appear in the entire organization or for specific entities. Organizations that have a highly customized system, especially those that use custom entities, will find that the application help content is of limited use. Administrators can configure the system to override the default help content by specifying a URL to open instead. The page to open might be a static page on a SharePoint site, a webpage on the Internet, or a custom help application created using web resources and included with a solution.

Developers need to understand the options available and what contextual information can be passed with the URL so that they can create pages to display appropriate content. You can also find more information in the topic Customize your CRM system: Customize the Help experience.

In this topic

Custom help options

Contextual query string parameters

Use web resources to provide help content

Custom help options

Custom help behavior depends on data stored in the Organization entity and the EntityMetadata definitions for each entity as described in the following table.

System or entity setting | Data | Type | Description
System Setting: Use custom help for customizable entities | Organization.GlobalHelpUrlEnabled | Boolean | Indicates whether custom help is enabled for the organization.
System Setting: Global Custom Help URL | Organization.GlobalHelpUrl | String | The global help URL for the organization.
System Setting: Append Parameters to URL | Organization.GlobalAppendUrlParametersEnabled | Boolean | Indicates whether query string parameters with context information are appended to the help URL. More information: Contextual query string parameters
Entity Setting: Use Custom help | EntityMetadata.EntityHelpUrlEnabled | Boolean | Indicates whether custom help is enabled for the entity.
Entity Setting: Help URL | EntityMetadata.EntityHelpUrl | String | The custom help page to display for this entity.

The combination of settings applied controls which help topic will be displayed. The options are described in the following table.

Organization.GlobalHelpUrlEnabled | Organization.GlobalHelpUrl | EntityMetadata.EntityHelpUrlEnabled | EntityMetadata.EntityHelpUrl | Behavior
false | N/A | N/A | N/A | Default Help page opens
true | No | false | N/A | Default Help page opens
true | No | true | No | Default Help page opens
true | No | true | Yes | Entity Help Page opens
true | Yes | true | Yes | Entity Help Page opens
true | Yes | true | No | Global URL page opens
true | Yes | false | N/A | Global URL page opens

Note
When global help is enabled, the custom page will appear whenever any help button in the application is used, including pages not related to any customizable area of the application. Because this hides content that may be valuable to administrators, generally custom help should be applied on a per entity basis.

Contextual query string parameters

When Organization.GlobalAppendUrlParametersEnabled is true, the following query string parameter values may be appended to the custom help URL.

Parameter | Description
entrypoint | The type of page that the help was opened from. Possible values are form and hierarchychart. This parameter isn’t included if help is opened from a list view.
formid | The GUID value for the form or hierarchy chart that help was opened from.
typename | The logical name of the entity that the help content was opened from.
userlcid | Language code identifier that is used by the current user. Valid locale ID values can be found at Locale ID (LCID) Chart.

Accessing query string values

The following HTML provides an example showing how to access these query string values using JavaScript. This page will display a table showing the values for these parameters if they are passed.

Html Copy Code
<!DOCTYPE html>
<html>
<head>
 <title>Help topic</title>
 <style>
  body {
   font-family: 'Segoe UI';
  }
 </style>
 <script type="text/javascript">
  function getQueryStringParameter(parameter) {
   /// <summary>Parses query string values passed to the page and returns the value for the requested parameter or 'null'</summary>
   /// <param name="parameter" type="String">The parameter value to look for</param>
   /// <returns type="String" />
   var query = window.location.search.substring(1);
   var params = query.split("&");
   for (var i = 0; i < params.length; i++) {
    var pair = params[i].split("=");
    if (pair[0] == parameter) {
     return pair[1];
    }
   }
   return "null";
  }

  document.onreadystatechange = function () {
   if (document.readyState == "complete") {

    var entrypointValue = getQueryStringParameter("entrypoint");
    var formidValue = getQueryStringParameter("formid");
    var typenameValue = getQueryStringParameter("typename");
    var userlcidValue = getQueryStringParameter("userlcid");

    if ((document.documentMode) && (document.documentMode <= 8))
    {
     //If page is being displayed in IE Compatibility mode
     document.getElementById("entrypointValue").innerText = entrypointValue;
     document.getElementById("formidValue").innerText = formidValue;
     document.getElementById("typenameValue").innerText = typenameValue;
     document.getElementById("userlcidValue").innerText = userlcidValue;
    }
    else
    {
     document.getElementById("entrypointValue").textContent = entrypointValue;
     document.getElementById("formidValue").textContent = formidValue;
     document.getElementById("typenameValue").textContent = typenameValue;
     document.getElementById("userlcidValue").textContent = userlcidValue;
    }

   }
  }

 </script>
</head>
<body>
 <p>This is a custom help topic that can accept query string parameters</p>
 <table>
  <thead><tr><th>Parameter</th><th>Value</th></tr></thead>
  <tbody>
   <tr><td>entrypoint</td><td id="entrypointValue">null</td></tr>
   <tr><td>formid</td><td id="formidValue">null</td></tr>
   <tr><td>typename</td><td id="typenameValue">null</td></tr>
   <tr><td>userlcid</td><td id="userlcidValue">null</td></tr>
  </tbody>
 </table>
</body>
</html>

Use web resources to provide help content

Using HTML web resources as help content has the advantage that they can be included together in a solution for any custom entities that they describe. It is also possible to use JavaScript in these pages to access CRM data and metadata to provide dynamic content that may reflect the current fields in a form or to get information about the privileges assigned to the user.

The Organization.GlobalHelpUrl and EntityMetadata.EntityHelpUrl fields are simple string values without any formatting to require a valid protocol. This allows for using relative path descriptions to the URL representing a web resource so that the reference to the web resource can work without being modified when a solution is used to move the help content from one organization to another. A specific web resource can be referenced using a relative URL like this:

Copy Code
/WebResources/new_/help/content/account.htm
Important
When a user belongs to more than one organization on a server, this path will always refer to the users default organization. If the user isn’t using the default organization and the expected web resource isn’t included in the user’s default organization, a “File Not Found” error occurs even though the web resource does occur in the organization the user is currently working in. If a web resource with the same name exists in the default organization, the web resource for that organization will be displayed and may not be correct for the current organization.

If this causes problems for users in the organization, the URL values for the settings can be updated to prepend the base organization URL to the relative URL for the web resource in the organization.

See Also

Concepts

Web resources for Microsoft Dynamics CRM
Webpage (HTML) web resources

Other Resources

Developers guide to customization for Microsoft Dynamics CRM
Customize your CRM system: Customize the Help experience
EntityMetadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Extend Microsoft Dynamics CRM for Outlook

In Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, Microsoft Dynamics CRM for Outlook lets users interact with data while they’re offline and not connected to a server. Microsoft Dynamics CRM includes features that let you extend your solutions to offline scenarios by calling the web services offline from your custom code. In addition, the Microsoft.Crm.Outlook.Sdk assembly provides programmatic support for basic Microsoft Outlook actions such as synchronization, going offline or online, and CRM for Outlook state verification. Offline programming uses the Microsoft ASP.NET Development Server.

This version of CRM includes new features that allow administrators to customize and manage filters for their users. Filter templates provide the starting point for entity synchronization on CRM for Outlook. Filters determine which entity collections are synchronized to Outlook and to Microsoft SQL Server 2008 Express Edition for offline-enabled Microsoft Dynamics CRM solutions.

In This Section

Write custom code for Microsoft Dynamics CRM for Outlook

Offline and Outlook filters and templates

SavedQuery (view) entity messages and methods

Sample: Create and retrieve Outlook filters

Sample: Use Outlook methods

Related Sections

Developer overview

Model your business data

Developer tools

Write mobile and modern apps

Write applications and server extensions

Write client application extensions

Write plug-ins to extend business processes

Write workflows to automate business processes

Developers guide to reports for Microsoft Dynamics CRM

Manage your data

Package and distribute extensions using solutions

Developers guide to customization for Microsoft Dynamics CRM

Integrate SharePoint with Microsoft Dynamics CRM

Advanced development

Sample code directory

Programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write custom code for Microsoft Dynamics CRM for Outlook

There are two Microsoft Office Outlook clients for Microsoft Dynamics CRM:

  • Microsoft Dynamics CRM for Microsoft Office Outlook
  • Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access

Microsoft Dynamics CRM for Microsoft Office Outlook can only be used when you are connected to the Microsoft Dynamics CRM server through an Internet connection. It enables multiple users to access Microsoft Dynamics CRM through Microsoft Outlook on the same computer with rich integration with Microsoft Outlook, including synchronization and mail merge and other features.

Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access supports offline use. Users interact with their CRM data exactly like they do in CRM for Outlook, but they can continue to access the data while disconnected from the Internet. To support offline use, Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access uses a local version of the Microsoft Dynamics CRM server hosted on a local Web server (also known as Cassini). This local Web server can only be used for the local instance of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access to access Microsoft Dynamics CRM. A Microsoft SQL Server 2008 Express Edition database provides data storage. When Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is synchronized, any data modifications and customizations applied on the server are transferred to the local Microsoft Dynamics CRM application. For more information about customizing the filters used for synchronizing entity data, see Offline and Outlook filters and templates.

Microsoft Dynamics CRM contains the assembly Microsoft.Crm.Outlook.Sdk, which you can use when customizing Microsoft Outlook. This includes methods to determine which client is being used and whether the user is online or offline. You can use these criteria to disable functionality that requires a connection to the network.

Workflows are not included in Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access, but plug-ins can be deployed that will function while offline. Workflows and plug-ins are applied when the user synchronizes data.

Methods

The following table lists the methods that are available in CrmOutlookService:

Instance Method | Description
GoOffline | Takes Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access into an offline state and triggers a synchronization of the offline database with the online server. This method cannot be called from a plug-in.
GoOnline | Synchronizes Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access with the online Microsoft Dynamics CRM server. This method cannot be called from a plug-in.
SetOffline | Sets Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access into an offline state without triggering a synchronization of the offline database with the online server.
Sync | Triggers a synchronization event between Microsoft Outlook and the Microsoft Dynamics CRM server.

Properties

The following table lists the properties available in CrmOutlookService:

Instance Property | Description
IsCrmClientLoaded | Gets a value that indicates whether CRM for Outlook is loaded by Microsoft Outlook.
IsCrmClientOffline | Gets a value that indicates whether Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is offline.
IsCrmDesktopClient | Gets a value that indicates whether CRM for Outlook is installed.
ServerUri | Gets the server URI to use to connect to the Microsoft Dynamics CRM server based on the state of CRM for Outlook.
State | Gets the state of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access.

See Also

Concepts

Offline and Outlook filters and templates

Other Resources

Extend Microsoft Dynamics CRM for Outlook
Sample: Use Outlook methods
Microsoft.Crm.Outlook.Sdk

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Offline and Outlook filters and templates

Data filters for Microsoft Office Outlook determine what data should be synchronized between the Microsoft Dynamics CRM server and CRM for Outlook. Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online support the ability to change the default filter using the SDK and push these changes to any or all users.

As part of the new support for filter customization, you can write code that allows administrators to create and publish filter templates. This allows a Microsoft Dynamics CRM administrator to create common or desirable filters that can be published to users for synchronizing with the Microsoft Outlook Store and offline database. This also provides a way to customize the default filter template that will be applied for users who are added to the system after the templates are originally published. The administrator also has the ability to update or delete user filters after they are published.

To support these customizations, there are four new query types for saved query (view). When you create a saved query (view) record, specify one of these types in the SavedQuery.QueryType attribute, using the SavedQueryQueryType enumeration. These are only accessible by using the methods described here; there is no UI available to change them. You can specify different filters so that you can avoid synchronizing everything to Microsoft Outlook for your mobile phone. Filter templates are solution aware so they can be exported along with a solution.

The following table lists the new query types used for filters and filter templates.

Query type | Description
OutlookFilters | Defines the subset of an entity to be synchronized with CRM for Outlook. The subset of data defined by these filters will synchronize to Microsoft Outlook folders such as Contacts, Calendar, and so on.
OfflineFilters | Defines the subset of an entity to be synchronized with Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access. The subset of data defined by these filters will synchronize to the offline database.
OutlookTemplate | Defines a filter template applied to new users for synchronization with CRM for Outlook.
OfflineTemplate | Defines a filter template applied to new users for synchronization with Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access.

Instantiate a filter

Default filter templates are automatically instantiated to the UserQuery entity for each user when the synchronization subscription is created. When synchronization to Microsoft Outlook or to the offline database is initiated, the filters for that user are collected and used to filter the collections of entries and attributes that are being synchronized. If multiple filters are specified for a particular entity, the resulting set of entries will be a union of results of individual filters.

There is a new privilege allowing the administrator to access other user's filters: prvAdminFilter. This is called Manage User Synchronization Filters in the Web application. The system administrator role includes this privilege because without it, only the user can see his or her filters. Calling the IOrganizationService.RetrieveMultiple method on the user query will retrieve records only for the owning user, unless the caller has the prvAdminFilter privilege The query must contain conditions where QueryType equals OutlookFilters or OfflineFilters AND OwnerId equals UserId, where the UserId is not equal to caller. If any other conditions are added to the query, this will not work.

New users automatically are given the filters from the filter templates that are marked as default in the SavedQuery.IsDefault attribute. Administrators need to know that they can change this value to affect this. Each entity can have only one filter template that is marked as default. There can be no default filters, only filter templates. If you create a custom entity, and set the IsAvailableOffline property, a default filter template is created automatically.

There is a new type of filter that administrators can define, called system filters. These filters are defined as SavedQuery records with the query type of OutlookFilters or OfflineFilters. System filters automatically apply to all users, and cannot be modified by the users.

There is a limit on the number of filters you can add. This setting is controlled by the Microsoft Dynamics CRM deployment administrator to prevent users or administrators from creating too many filters, which affects server performance. The same limit setting is applied to all entities.

By default, there are unlimited settings for both system filters and user filters.

Instantiate a template

You can instantiate one or more filters per user. To do this manually, use the InstantiateFiltersRequest to instantiate a filter, creating a user query record. Each user query record contains a reference back to the filter. If you update the filter, you can call instantiate again to refresh or override the user’s changes to the filter (user query record).

Reset a user’s filters to the default

You can reset the filters for a user to the default by using the ResetUserFiltersRequest.

See Also

Reference

Privileges not associated with an entity

Concepts

Write custom code for Microsoft Dynamics CRM for Outlook
SavedQuery (view) entity messages and methods

Other Resources

Extend Microsoft Dynamics CRM for Outlook
Sample: Create and retrieve Outlook filters
InstantiateFiltersRequest
ResetUserFiltersRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create and retrieve Outlook filters
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Client\Outlook\RetrieveDataFilters.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve filters for Microsoft Dynamics CRM for Outlook.

Example

C# Copy Code

// Create and Retrieve Offline Filter
// In your Outlook client, this will appear in the System Filters tab
// under File | CRM | Synchronize | Outlook Filters.
Console.Write("Creating offline filter");
String contactName = String.Format("offlineFilteredContact {0}",
    DateTime.Now.ToLongTimeString());
String fetchXml = String.Format("<fetch version=\"1.0\" output-format=\"xml-platform\" mapping=\"logical\"><entity name=\"contact\"><attribute name=\"contactid\" /><filter type=\"and\">" +
    "<condition attribute=\"ownerid\" operator=\"eq-userid\" /><condition attribute=\"description\" operator=\"eq\" value=\"{0}\" />" +
    "<condition attribute=\"statecode\" operator=\"eq\" value=\"0\" /></filter></entity></fetch>", contactName);
SavedQuery filter = new SavedQuery();
filter.FetchXml = fetchXml;
filter.IsQuickFindQuery = false;
filter.QueryType = SavedQueryQueryType.OfflineFilters;
filter.ReturnedTypeCode = Contact.EntityLogicalName;
filter.Name = "ReadOnlyFilter_" + contactName;
filter.Description = "Sample offline filter for Contact entity";
_offlineFilter = _serviceProxy.Create(filter);

Console.WriteLine(" and retrieving offline filter");
SavedQuery result = (SavedQuery)_serviceProxy.Retrieve(
    SavedQuery.EntityLogicalName,
    _offlineFilter,
    new ColumnSet("name", "description"));
Console.WriteLine("Name: {0}", result.Name);
Console.WriteLine("Description: {0}", result.Description);
Console.WriteLine();

// Create and Retrieve Offline Template
// In your Outlook client, this will appear in the User Filters tab
// under File | CRM | Synchronize | Outlook Filters.
Console.Write("Creating offline template");
String accountName = String.Format("offlineFilteredAccount {0}",
    DateTime.Now.ToLongTimeString());
fetchXml = String.Format("<fetch version=\"1.0\" output-format=\"xml-platform\" mapping=\"logical\"><entity name=\"account\"><attribute name=\"accountid\" /><filter type=\"and\">" +
    "<condition attribute=\"ownerid\" operator=\"eq-userid\" /><condition attribute=\"name\" operator=\"eq\" value=\"{0}\" />" +
    "<condition attribute=\"statecode\" operator=\"eq\" value=\"0\" /></filter></entity></fetch>", accountName);
SavedQuery template = new SavedQuery();
template.FetchXml = fetchXml;
template.IsQuickFindQuery = false;
template.QueryType = SavedQueryQueryType.OfflineTemplate;
template.ReturnedTypeCode = Account.EntityLogicalName;
template.Name = "ReadOnlyFilter_" + accountName;
template.Description = "Sample offline template for Account entity";
_offlineTemplate = _serviceProxy.Create(template);

Console.WriteLine(" and retrieving offline template");
result = (SavedQuery)_serviceProxy.Retrieve(
    SavedQuery.EntityLogicalName,
    _offlineTemplate,
    new ColumnSet("name", "description"));
Console.WriteLine("Name: {0}", result.Name);
Console.WriteLine("Description: {0}", result.Description);
Console.WriteLine();

See Also

Concepts

Offline and Outlook filters and templates
SavedQuery (view) entity messages and methods

Other Resources

Extend Microsoft Dynamics CRM for Outlook
Sample: Use Outlook methods
IOrganizationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Use Outlook methods
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Client\Outlook\UseOutlookSdk.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to use the methods available in the Microsoft.Crm.Outlook.Sdk.dll assembly.

Example

C# Copy Code
// Set up the CRM Service.
CrmOutlookService outlookService = new CrmOutlookService();

// Determine if the Outlook client is running
if (outlookService.IsCrmClientLoaded)
{
    if (outlookService.IsCrmDesktopClient)
    {
        // The desktop client cannot go offline
        Console.WriteLine("CRM Client Desktop URL: " +
            outlookService.ServerUri.AbsoluteUri);
        Console.WriteLine("CRM Client state: " +
            outlookService.State.ToString());
    }
    else
    {
        // See if laptop client is offline
        if (outlookService.IsCrmClientOffline)
        {
            Console.WriteLine("CRM Client Offline URL: " +
                outlookService.ServerUri.AbsoluteUri);
            Console.WriteLine("CRM Client state: " +
                outlookService.State.ToString());

            // Take client online
            // NOTE: GoOnline() will automatically Sync up with CRM
            // database, no need to call Sync() manually
            Console.WriteLine("Going Online...");
            outlookService.GoOnline();

            Console.WriteLine("CRM Client state: " +
                outlookService.State.ToString());
        }
        else
        {
            Console.WriteLine("CRM Client Online URL: " +
                outlookService.ServerUri.AbsoluteUri);
            Console.WriteLine("CRM Client state: " +
                outlookService.State.ToString());

            // Take client offline
            // NOTE: GoOffline triggers a synchronization of the
            // offline database with the online server.
            // If a sync is not required, you can use SetOffline().
            Console.WriteLine("Going Offline...");
            outlookService.GoOffline();

            Console.WriteLine("CRM Client state: " +
                outlookService.State.ToString());
        }
    }
}

See Also

Concepts

Write custom code for Microsoft Dynamics CRM for Outlook

Other Resources

Extend Microsoft Dynamics CRM for Outlook
CrmOutlookService
GoOnline
GoOffline

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Integrate SharePoint with Microsoft Dynamics CRM

Microsoft SharePoint Server is a collaboration and content management application that simplifies how people store, find, and share information. It helps people to collaborate effectively by having secure access to documents and information that they require to make business decisions.

With Microsoft Dynamics CRM (on-premises) and Microsoft Dynamics CRM Online, you can use the document management capabilities of SharePoint from within Microsoft Dynamics CRM. You can store and manage documents in the context of a Microsoft Dynamics CRM record on a server that is running SharePoint, and leverage the SharePoint infrastructure to share, manage, and collaborate efficiently. Because the documents are stored on a server that is running SharePoint, non-Microsoft Dynamics CRM users can directly access the documents on the server, provided they have the appropriate permissions on the server that is running SharePoint Server to do so.

SharePoint integration with Microsoft Dynamics CRM enables you to:

  • Create, upload, view, and delete documents on a server that is running SharePoint from within Microsoft Dynamics CRM.
  • Use the SharePoint document management abilities within Microsoft Dynamics CRM, such as checking the document in and out, viewing version history, and changing document properties.

You use the following entities to store and manage the SharePoint Server location records: SharePointSite and SharePointDocumentLocation.

Server-based SharePoint Integration for Microsoft Dynamics CRM Online and SharePoint Online

You can enable server-to-server authentication for integration with SharePoint Online. The server-based authentication does not require you to install the Microsoft Dynamics CRM list component in the sandboxed environment of SharePoint Online. After you enable server-based SharePoint integration, you can’t revert to the previous client-based authentication method. You can enable server-based SharePoint integration for Microsoft Dynamics CRM Online only by using the web or Microsoft Dynamics CRM for Outlook. For more information, see Enable server-based SharePoint Integration in the Microsoft Dynamics CRM Installing Guide.

No entities or messages are exposed for developers for the server-based SharePoint integration feature, and all the existing entities and messages for SharePoint integration will continue to work after you enable this feature.

In This Section

Introduction to SharePoint integration

Enable document management for entities

Actions on SharePoint location records

SharePoint integration entities

Sample: Enable document management for entities

Sample: Create, retrieve, update, and delete a SharePoint location record

Sample: Retrieve absolute URL and site collection URL of a location record

Related Sections

Write applications and server extensions

SharePoint Server Developer Center

Document Management in SharePoint

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Introduction to SharePoint integration

SharePoint Server integration enables document management capabilities in Microsoft Dynamics CRM. There are two aspects to SharePoint Server integration:

  • Setting up SharePoint integration. A system administrator sets up a SharePoint Server environment. The Microsoft Dynamics CRM administrator (a user who has the SharePoint Site Collection Administrator role) selects the Microsoft Dynamics CRM entities for which to enable the document management feature, and specifies the target SharePoint Server. As part of specifying the target server, the Microsoft Dynamics CRM administrator specifies the SharePoint Server site collection or the SharePoint Server site URL by using the SharePointSite entity.
  • Creating and managing SharePoint document location records. Microsoft Dynamics CRM users can create and manage SharePoint Server document location records after SharePoint Server integration is enabled. You can create and manage SharePoint Server document location records by using the SharePointDocumentLocation entity. Microsoft Dynamics CRM also allows for the automatic creation of folders on the server that is running SharePoint Server for entity records under certain conditions. However, automatic creation of folders cannot be done through the Microsoft Dynamics CRM SDK.

In This Topic

SharePoint storage concepts

Supported SharePoint server versions

Microsoft Dynamics CRM list component for Microsoft SharePoint Server

SharePoint integration is enabled by default

SharePoint storage concepts

By using SharePoint Server document management capabilities, you can control the life cycle of documents in your organization: how they are created, reviewed, published, and disposed or archived. SharePoint Server uses a hierarchical storage model to store and manage documents. Some of the SharePoint Server storage concepts that you should know are as follows: Site Collection, Site, Document Library, and Document Folder. These storage objects provide the framework for the content management infrastructure that SharePoint Server provides. For more information about these storage concepts, see Storage levels: content storage benefits and considerations.

Supported SharePoint server versions

SharePoint integration is supported for SharePoint Server 2010, SharePoint Server 2013, and SharePoint Server Online.

Microsoft Dynamics CRM list component for Microsoft SharePoint Server

Microsoft Dynamics CRM List Component for Microsoft SharePoint Server 2010 and Microsoft SharePoint 2013 is a SharePoint Server solution package file (.wsp) that must be installed (uploaded and activated) on the site collection on the target Microsoft SharePoint 2010 or 2013 server to enable the following:

  • View documents that are stored on the SharePoint Server 2010 server in a Microsoft Dynamics CRM List view (look and feel of CRM).
  • Automatic creation of the document locations on the SharePoint Server server.

You can download and install Microsoft Dynamics CRM List Component for Microsoft SharePoint Server 2010 and Microsoft SharePoint 2013 from the Microsoft Download Center. To install this component, you must have SharePoint Server site collection administrator privileges on the target SharePoint server.

There are two versions of the Microsoft Dynamics CRM List Component:

  • Microsoft Dynamics CRM List Component for Microsoft SharePoint Server 2010 : This version doesn’t work with SharePoint 2013.
  • Microsoft Dynamics CRM List Component for Microsoft SharePoint Server 2013 : This version doesn’t work with SharePoint 2010.
Note
If you are using Microsoft Dynamics CRM Online Spring ‘14 with SharePoint Server Online, you can enable server-based SharePoint integration, which does not require you to install Microsoft Dynamics CRM list component in your SharePoint Server Online sandbox environment. For more information, see Enable server-based SharePoint Integration in the Microsoft Dynamics CRM Installing Guide.

SharePoint integration is enabled by default

When you install Microsoft Dynamics CRM, SharePoint Server integration is enabled by default. However, for a richer user experience, you can do the following:

  • Install Microsoft Dynamics CRM List Component for Microsoft SharePoint Server 2010 server or Microsoft SharePoint Server 2013.
  • Enable Document Management for Entities: Select the entities in Microsoft Dynamics CRM for which you want to create and manage documents on SharePoint Server. More information: Enable document management for entities.
    When you enable document management for an entity in Microsoft Dynamics CRM, a Documents link under the Common group in the left pane is added for the all entity records in the Microsoft Dynamics CRM Web application. You can use the Documents link to create or manage SharePoint Server location records for the entity record.
  • Specify the target SharePoint server: Specify the URL of a site or site collection on the SharePoint Server 2010 or SharePoint Server 2013. This URL is used to automatically create folders and document libraries on SharePoint.

See Also

Concepts

Enable document management for entities
Actions on SharePoint location records

Other Resources

Integrate SharePoint with Microsoft Dynamics CRM
SharePoint integration entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Enable document management for entities

Document management can be enabled for those entities in Microsoft Dynamics CRM that can be customized. By default, document management is enabled only for the following entities in a new installation of CRM:

  • Account
  • KbArticle
  • Lead
  • Opportunity
  • Product
  • Quote
  • SalesLiterature

To enable document management for an entity, set the EntityMetadata.IsDocumentManagementEnabled attribute value to true. To disable document management for an entity, set the value to false.

Note
You must have the System Administrator or System Customizer role to enable or disable document management for an entity.

See Also

Concepts

Actions on SharePoint location records

Other Resources

Integrate SharePoint with Microsoft Dynamics CRM
Sample: Enable document management for entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Actions on SharePoint location records

Using the Microsoft Dynamics CRM SDK, you can perform the following actions on Microsoft SharePoint location records.

  • Create, retrieve, update, and delete location records
  • Set a site location record as default
  • Associate a document location record with an entity record
  • Retrieve absolute and site collection URLs for a location record

Create, retrieve, update, and delete location records

Using the Microsoft Dynamics CRM SDK messages on the SharePointSite and SharePointDocumentLocation entities, you can create, retrieve, update, and delete records. To perform these operations on the SharePointSite entity, you must have the System Administrator role in Microsoft Dynamics CRM. For a list of supported messages, see SharePointSite entity messages and methods and SharePointDocumentLocation entity messages and methods.

Note
Performing these operations on SharePoint location records only manipulates the data in Microsoft Dynamics CRM. It does not create, update, or delete the locations on the SharePoint server.

The SharepointSite.ValidationStatus attribute shows the validation status of the SharePoint site URL. The possible values for this attribute are defined in the Validation Status option set.

The SharepointSite.ValidationStatusErrorCode attribute shows the reason for the validation status of the SharePoint site URL. The possible values for this attribute are defined in the Validation Status Reason option set.

The storage locations on SharePoint Server are hierarchical where the SharePoint site collection is the container that can contain multiple sites, and each site can contain multiple sites or document libraries. Each document library can contain multiple document folders. While creating location records in Microsoft Dynamics CRM, specify the path or the URL of these locations on SharePoint Server.

Absolute URL of the SharePoint location records

This is the complete URL of a storage location on SharePoint. You can specify the absolute URL using the SharePointSite.AbsoluteURL or SharePointDocumentLocation.AbsoluteURL property.

C# Copy Code
// Instantiate a SharePoint site object.
// See the Entity Metadata topic in the SDK documentation to determine
// which attributes must be set for each entity.
SharePointSite spSite = new SharePointSite
{
    Name = "Sample SharePoint Site",
    Description = "Sample SharePoint Site Location record",

    // TODO: Change this URL to a valid SharePoint URL.
    AbsoluteURL = "http://www.example.com",
};

// Create a SharePoint site record named Sample SharePoint Site.
_spSiteId = _serviceProxy.Create(spSite);

Similarly, to create a SharePoint document location record by specifying the absolute URL:

C# Copy Code
SharePointDocumentLocation spDocLoc = new SharePointDocumentLocation
{
    Name = "Sample SharePoint Document Location",
    Description = "Sample SharePoint Document Location record",
    AbsoluteUrl = "http://www.example.com/spdocloc"
};
_spDocLocId = _serviceProxy.Create(spDocLoc);

Absolute URLs are typically provided for the SharePoint site records because these are the container or parent objects under which you want to create other locations for storing and managing your documents.

Relative URL of the SharePoint location records

This is the relative location of a location record with respect to its parent location record on the SharePoint server. When you specify a relative URL for a SharePoint location record, you must also specify the parent object under which it should be created. Microsoft Dynamics CRM internally uses the URL of the parent object to determine the absolute URL for the child object. For example, to create a record for a SharePoint document location under the SharePoint site created in the previous example, you must specify the following:

C# Copy Code
// Instantiate a SharePoint document location object.
// See the Entity Metadata topic in the SDK documentation to determine
// which attributes must be set for each entity.
SharePointDocumentLocation spDocLoc = new SharePointDocumentLocation
{
    Name = "Sample SharePoint Document Location",
    Description = "Sample SharePoint Document Location record",

    // Set the Sample SharePoint Site created earlier as the parent site.
    ParentSiteOrLocation = new EntityReference(SharePointSite.EntityLogicalName, _spSiteId),
    RelativeUrl = "spdocloc",

    // Associate this document location instance with the Fourth Coffee
    // sample account record.
    RegardingObjectId = new EntityReference(Account.EntityLogicalName, _account1Id)
};

// Create a SharePoint document location record named Sample SharePoint Document Location.
_spDocLocId = _serviceProxy.Create(spDocLoc);

The absolute URL of the child object (document location in this example) is: “Parent_URL/Relative_URL”. So, in this example, the absolute URL of the document location is http://www.example.com/spdocloc.

Relative URLs are typically provided when you want to create a location record lower down the hierarchy or as a child record.

The benefit of using the relative URL is that if you decide to move to a different SharePoint server to store your documents, you just need to update the absolute URL of the parent object location record (probably a site collection or site record) in Microsoft Dynamics CRM, and all the other records down the hierarchy will continue functioning as before because the absolute URLs (determined automatically by Microsoft Dynamics CRM) will not be broken. If you had used absolute URLs for these child location records, you would have to fix the URLs individually.

Set a site location record as default

You can set a SharePoint site location record as default so that all the document locations created using Microsoft Dynamics CRM will be automatically created under this site. To create a site location record as default, use the SharePointSite.IsDefault property, and set it to true. You can set a site location record as default while creating or updating a site location record.

Note
Automatic creation of document location records is possible only if the target site is a SharePoint 2010 or SharePoint 2013 server and Microsoft Dynamics CRM List Component for SharePoint Server is installed on the target SharePoint Site Collection. For more information about the Microsoft Dynamics CRM List Component, see Microsoft Dynamics CRM list component for Microsoft SharePoint Server.

Associate a document location record with an entity record

You can associate a document location record with an entity record. When you do this, all the documents for the entity record are stored at this location on the SharePoint server. You can associate a SharePoint document location record with an entity using the SharePointDocumentLocation.RegardingObjectId property. The following sample shows how you can do this:

C# Copy Code
// Instantiate a SharePoint document location object.
// See the Entity Metadata topic in the SDK documentation to determine
// which attributes must be set for each entity.
SharePointDocumentLocation spDocLoc = new SharePointDocumentLocation
{
    Name = "Sample SharePoint Document Location",
    Description = "Sample SharePoint Document Location record",

    // Set the Sample SharePoint Site created earlier as the parent site.
    ParentSiteOrLocation = new EntityReference(SharePointSite.EntityLogicalName, _spSiteId),
    RelativeUrl = "spdocloc",

    // Associate this document location instance with the Fourth Coffee
    // sample account record.
    RegardingObjectId = new EntityReference(Account.EntityLogicalName, _account1Id)
};

// Create a SharePoint document location record named Sample SharePoint Document Location.
_spDocLocId = _serviceProxy.Create(spDocLoc);

Retrieve absolute and site collection URLs for a location record

As explained earlier, SharePoint Server follows a hierarchical model to store records. If you want to retrieve the absolute (complete) URL of a location record in the hierarchy and the SiteCollection URL under which the location record is present, you can use the RetrieveAbsoluteAndSiteCollectionUrlRequest message to do so.

The RetrieveAbsoluteAndSiteCollectionUrlRequest message will work properly only if both are true:

  • The Microsoft Dynamics CRM List Component for SharePoint Server is installed on the SharePoint site collection on the target SharePoint 2010 or SharePoint 2013 server. For more information, see Microsoft Dynamics CRM list component for Microsoft SharePoint Server.
  • The location record for the parent SharePoint site collection exists in Microsoft Dynamics CRM, and the SharePointSite.IsGridPresent property was set to true while creating the parent location record.

Otherwise, you will get a blank value or an incorrect value for the SiteCollectionUrl property.

For more information, see RetrieveAbsoluteAndSiteCollectionUrlRequest.

The following sample shows how to use the RetrieveAbsoluteAndSiteCollectionUrl message:

C# Copy Code
// Retrieve the absolute URL and the Site Collection URL
// of the SharePoint document location record.
RetrieveAbsoluteAndSiteCollectionUrlRequest retrieveRequest = new RetrieveAbsoluteAndSiteCollectionUrlRequest
{
    Target = new EntityReference(SharePointDocumentLocation.EntityLogicalName, _spDocLocId)
};
RetrieveAbsoluteAndSiteCollectionUrlResponse retriveResponse = (RetrieveAbsoluteAndSiteCollectionUrlResponse)_serviceProxy.Execute(retrieveRequest);

Console.WriteLine("Absolute URL of document location record is '{0}'.", retriveResponse.AbsoluteUrl.ToString());
Console.WriteLine("Site Collection URL of document location record is '{0}'.", retriveResponse.SiteCollectionUrl.ToString());

See Also

Concepts

Introduction to SharePoint integration
Enable document management for entities

Other Resources

Integrate SharePoint with Microsoft Dynamics CRM
SharePoint integration entities
Sample: Enable document management for entities
Sample: Create, retrieve, update, and delete a SharePoint location record
Sample: Retrieve absolute URL and site collection URL of a location record
RetrieveAbsoluteAndSiteCollectionUrlRequest
RetrieveAbsoluteAndSiteCollectionUrlResponse

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SharePoint integration entities

If you use SharePoint Server with Microsoft Dynamics CRM, CRM users and non-CRM users can work together as a team to achieve common business goals through improved communication. The document records are stored in SharePoint, and you can view them from within Microsoft Dynamics CRM. In addition, you can take advantage of SharePoint capabilities, such as checking documents in and out, viewing version history, and changing document properties.

The SharePoint entities in Microsoft Dynamics CRM allow you to store information about the SharePoint locations where documents are stored.

In This Section

SharePointSite entity messages and methods

SharePointDocumentLocation entity messages and methods

See Also

Other Resources

Integrate SharePoint with Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SharePointSite entity messages and methods

The SharePoint site entity represents a location record in Microsoft Dynamics CRM that points to a site collection or a site on a server that is running SharePoint Server. The schema name for this entity is SharePointSite. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a SharePoint site record to another user or team.
CreateRequest | Creates a SharePoint site record. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a SharePoint site record. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a SharePoint site record with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a SharePoint site record previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a SharePoint site record. You can also call the IOrganizationService.Retrieve method.
RetrieveAbsoluteAndSiteCollectionUrlRequest | Retrieves the absolute (complete) URL and the site collection URL of a SharePoint site record.
RetrieveMultipleRequest | Retrieves a collection of SharePoint site records. You can also call theIOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a SharePoint site record.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a SharePoint site, and their access rights to the SharePoint site record.
RevokeAccessRequest | Removes all access to a SharePoint site record for the specified security principal (user or team).
SetStateRequest | Sets the state of a SharePoint site record. The possible values for this attribute are defined in the SharePointSite.State attribute. If you are using early bound types, you can use the SharePointSiteState enumeration. For a list of states, see SharePointSite entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a SharePoint site record. You can also call the IOrganizationService.Update method.

See Also

Concepts

Actions on SharePoint location records
SharePointSite entity privileges

Other Resources

SharePoint integration entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SharePointDocumentLocation entity messages and methods

A SharePoint document location entity represents a location record in Microsoft Dynamics CRM that points to a Document Folder on a server that is running SharePoint Server. You can associate the SharePoint document location records in Microsoft Dynamics CRM with the entity records for the entities for which the SharePoint Server integration or document management feature is enabled. The schema name for this entity is SharePointDocumentLocation. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssignRequest | Assigns a SharePoint document location record to another user or team.
CreateRequest | Creates a SharePoint document location record. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a SharePoint document location record. You can also call the IOrganizationService.Delete method.
GrantAccessRequest | Shares a SharePoint document location record with another security principal (user or team).
ModifyAccessRequest | Changes the access rights for a SharePoint document location record previously shared with another security principal (user or team).
RetrieveRequest | Retrieves a SharePoint document location record. You can also call the IOrganizationService.Retrieve method.
RetrieveAbsoluteAndSiteCollectionUrlRequest | Retrieves the absolute (complete) URL and the site collection URL of a SharePoint document location record.
RetrieveMultipleRequest | Retrieves a collection of SharePoint document location records. You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access the specified security principal (user or team) has to a SharePoint document location record.
RetrieveSharedPrincipalsAndAccessRequest | Retrieves the security principals (users or teams) that have access to a SharePoint document location record, and their access rights to the SharePoint document location record.
RevokeAccessRequest | Removes all access to a SharePoint document location record for the specified security principal (user or team).
SetStateRequest | Sets the state of a SharePoint document location record. The possible states are defined in theSharePointDocumentLocation.Statecode attribute. If you are using early bound types, use the SharePointDocumentLocationState enumeration. For a list of states, see SharePointDocumentLocation entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
UpdateRequest | Updates a SharePoint document location record. You can also call the IOrganizationService.Update method.

See Also

Concepts

Enable document management for entities
Actions on SharePoint location records

Other Resources

SharePoint integration entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Enable document management for entities
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\SharePointIntegration\EnableDocumentManagement.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The following sample shows how to enable document management for entities in Microsoft Dynamics CRM. In this sample code, document management is enabled for the Contact entity using the UpdateEntityRequest message. By default, the setting for the Contact entity isn’t enabled in a new installation of Dynamics CRM.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Client;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Messages;
using Microsoft.Xrm.Sdk.Metadata;

// This namespace is found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to enable document management
    /// for an entity.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to revert
    /// the changes done by this program.</remarks>
    public class EnableDocumentManagement
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// retrieves the Contact entity record, and then enables the document management
        /// for the entity.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforRevert">When True, the user will be prompted to revert all
        /// the changes done in this sample.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforRevert)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();

                    // Retrieve an entity for which you want to enable document management.
                    // In this sample, we will retrieve and enable document management
                    // for the Contact entity because by default, document management is
                    // not enabled for this entity.

                    RetrieveEntityRequest entityRequest = new RetrieveEntityRequest
                    {
                        EntityFilters = EntityFilters.All,
                        LogicalName = Contact.EntityLogicalName,

                        // Retrieve only the currently published changes, ignoring the changes
                        // that have not been published.
                        RetrieveAsIfPublished = false
                    };
                    RetrieveEntityResponse entityResponse = (RetrieveEntityResponse)_serviceProxy.Execute(entityRequest);
                    Console.WriteLine("Retrieved the contact entity.");

                    // Get the entity from the response.
                    EntityMetadata contactEntity = entityResponse.EntityMetadata;

                    // Enable document management for the retrieved entity.
                    contactEntity.IsDocumentManagementEnabled = true;

                    // Create an update request.
                    UpdateEntityRequest updateRequest = new UpdateEntityRequest
                    {
                        Entity = contactEntity
                    };
                    _serviceProxy.Execute(updateRequest);

                    // Publish the entity.
                    // All customizations must be published before they can be used.
                    PublishAllXmlRequest enableRequest = new PublishAllXmlRequest();
                    _serviceProxy.Execute(enableRequest);

                    // Retrieve the contact entity, and verify that document management is enabled.
                    entityResponse = (RetrieveEntityResponse)_serviceProxy.Execute(entityRequest);
                    contactEntity = entityResponse.EntityMetadata;
                    if (contactEntity.IsDocumentManagementEnabled.Value == true)
                    {
                        Console.WriteLine("Enabled document management for the contact entity.");
                    }

                    RevertChanges(promptforRevert);
                }

            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // For this sample, no entities are created.
        }

        /// <summary>
        /// Reverts any changes that were done by this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to revert the changes done by this sample.</param>
        /// </summary>
        public void RevertChanges(bool prompt)
        {
            bool revertChanges = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these changes reverted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                revertChanges = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (revertChanges)
            {
                RetrieveEntityRequest entityRequest = new RetrieveEntityRequest
                {
                    EntityFilters = EntityFilters.All,
                    LogicalName = Contact.EntityLogicalName,
                    RetrieveAsIfPublished = false
                };
                RetrieveEntityResponse entityResponse = (RetrieveEntityResponse)_serviceProxy.Execute(entityRequest);

                EntityMetadata contactEntity = entityResponse.EntityMetadata;

                // Disable document management for the retrieved entity.
                contactEntity.IsDocumentManagementEnabled = false;

                UpdateEntityRequest updateRequest = new UpdateEntityRequest
                {
                    Entity = contactEntity
                };
                _serviceProxy.Execute(updateRequest);

                // Publish the customizations to the entity.
                PublishAllXmlRequest disableRequest = new PublishAllXmlRequest();
                _serviceProxy.Execute(disableRequest);

                Console.WriteLine("Changes have been reverted.");
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                EnableDocumentManagement app = new EnableDocumentManagement();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Enable document management for entities

Other Resources

Integrate SharePoint with Microsoft Dynamics CRM
Sample: Create, retrieve, update, and delete a SharePoint location record
Helper code: ServerConnection class
Sample: Create, retrieve, update, and delete a SharePoint location record

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Create, retrieve, update, and delete a SharePoint location record
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. The sample can be found in the following location in the download package:

SampleCode\CS\SharePointIntegration\CRUDSharePointLocationRecords.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to create, retrieve, update, and delete a SharePoint Server document location records.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to create, retrieve, update, and delete.
    /// SharePoint location records.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class CRUDSharePointLocationRecords
    {
        #region Class Level Members

        private Guid _spSiteId;
        private Guid _spDocLocId;
        private Guid _account1Id;
        private Guid _account2Id;
        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// create, retrieve, update, and delete operations are performed on the
        /// SharePoint location records.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();
                    // Instantiate a SharePoint site object.
                    // See the Entity Metadata topic in the SDK documentation to determine
                    // which attributes must be set for each entity.
                    SharePointSite spSite = new SharePointSite
                    {
                        Name = "Sample SharePoint Site",
                        Description = "Sample SharePoint Site Location record",

                        // TODO: Change this URL to a valid SharePoint URL.
                        AbsoluteURL = "http://www.example.com",
                    };

                    // Create a SharePoint site record named Sample SharePoint Site.
                    _spSiteId = _serviceProxy.Create(spSite);
                    Console.WriteLine("{0} created.", spSite.Name);
                    // Instantiate a SharePoint document location object.
                    // See the Entity Metadata topic in the SDK documentation to determine
                    // which attributes must be set for each entity.
                    SharePointDocumentLocation spDocLoc = new SharePointDocumentLocation
                    {
                        Name = "Sample SharePoint Document Location",
                        Description = "Sample SharePoint Document Location record",

                        // Set the Sample SharePoint Site created earlier as the parent site.
                        ParentSiteOrLocation = new EntityReference(SharePointSite.EntityLogicalName, _spSiteId),
                        RelativeUrl = "spdocloc",

                        // Associate this document location instance with the Fourth Coffee
                        // sample account record.
                        RegardingObjectId = new EntityReference(Account.EntityLogicalName, _account1Id)
                    };

                    // Create a SharePoint document location record named Sample SharePoint Document Location.
                    _spDocLocId = _serviceProxy.Create(spDocLoc);
                    Console.WriteLine("{0} created.", spDocLoc.Name);

                    // Retrieve the SharePoint site and SharePoint document location containing several of its attributes.
                    ColumnSet colsSpSite = new ColumnSet("name", "absoluteurl");
                    SharePointSite retrievedSpSite = (SharePointSite)_serviceProxy.Retrieve(SharePointSite.EntityLogicalName, _spSiteId, colsSpSite);

                    ColumnSet colsSpDocLoc = new ColumnSet("name", "regardingobjectid");
                    SharePointDocumentLocation retrievedSpDocLoc = (SharePointDocumentLocation)_serviceProxy.Retrieve(SharePointDocumentLocation.EntityLogicalName, _spDocLocId, colsSpDocLoc);
                    Console.Write("Retrieved,");

                    // Update the URL of the SharePoint site.
                    // TODO: Change this URL to a valid SharePoint URL.
                    retrievedSpSite.AbsoluteURL = "http://www.example.net";
                    _serviceProxy.Update(retrievedSpSite);

                    // Update the SharePoint document location to associate it with the
                    // Northwind Traders sample account.
                    retrievedSpDocLoc.RegardingObjectId = new EntityReference(Account.EntityLogicalName,_account2Id);
                    _serviceProxy.Update(retrievedSpDocLoc);

                    Console.WriteLine(" and updated the records.");

                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Create two account records

            Account account1 = new Account { Name = "Fourth Coffee" };
            _account1Id = _serviceProxy.Create(account1);

            Account account2 = new Account { Name = "Northwind Traders" };
            _account2Id = _serviceProxy.Create(account2);

            Console.WriteLine("{0} and {1} sample accounts created.", account1.Name, account2.Name);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(SharePointDocumentLocation.EntityLogicalName, _spDocLocId);
                _serviceProxy.Delete(SharePointSite.EntityLogicalName, _spSiteId);
                _serviceProxy.Delete(Account.EntityLogicalName, _account1Id);
                _serviceProxy.Delete(Account.EntityLogicalName, _account2Id);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                CRUDSharePointLocationRecords app = new CRUDSharePointLocationRecords();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Actions on SharePoint location records

Other Resources

Integrate SharePoint with Microsoft Dynamics CRM
Sample: Retrieve absolute URL and site collection URL of a location record

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Retrieve absolute URL and site collection URL of a location record
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. The sample can be found in the following location in the download package:

SampleCode\CS\SharepointIntegration\RetrieveAbsoluteAndSiteCollectionURLs.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to retrieve the absolute URL and the site collection URL of a SharePoint Server location record in Dynamics CRM using the RetrieveAbsoluteAndSiteCollectionUrlRequest message.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Description;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in the Microsoft.Crm.Sdk.Proxy.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to retrieve the absolute URL and the parent
    /// site collection URL of a SharePoint location record.</summary>
    /// <remarks>
    /// At run-time, you will be given the option to delete all the
    /// database records created by this program.</remarks>
    public class RetrieveAbsoluteAndSiteCollectionURLs
    {
        #region Class Level Members

        private Guid _spSiteId;
        private Guid _spDocLocId;
        private OrganizationServiceProxy _serviceProxy;

        // TODO: Appropriately change the absolute URL of the SharePoint site
        // record.
        private String _siteAbsoluteURL = "http://www.example.com";

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// This method first connects to the Organization service. Afterwards,
        /// retrieves the absolute URL and the parent site collection URL of a
        /// SharePoint document location record.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete all
        /// created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    CreateRequiredRecords();
                    // Retrieve the absolute URL and the Site Collection URL
                    // of the SharePoint document location record.
                    RetrieveAbsoluteAndSiteCollectionUrlRequest retrieveRequest = new RetrieveAbsoluteAndSiteCollectionUrlRequest
                    {
                        Target = new EntityReference(SharePointDocumentLocation.EntityLogicalName, _spDocLocId)
                    };
                    RetrieveAbsoluteAndSiteCollectionUrlResponse retriveResponse = (RetrieveAbsoluteAndSiteCollectionUrlResponse)_serviceProxy.Execute(retrieveRequest);

                    Console.WriteLine("Absolute URL of document location record is '{0}'.", retriveResponse.AbsoluteUrl.ToString());
                    Console.WriteLine("Site Collection URL of document location record is '{0}'.", retriveResponse.SiteCollectionUrl.ToString());
                    DeleteRequiredRecords(promptforDelete);
                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        /// <summary>
        /// Creates any entity records that this sample requires.
        /// </summary>
        public void CreateRequiredRecords()
        {
            // Instantiate a SharePoint site object.
            // See the Entity Metadata topic in the SDK documentation to determine
            // which attributes must be set for each entity.
            SharePointSite spSite = new SharePointSite
            {
                Name = "Sample SharePoint Site",
                Description = "Sample SharePoint Site Location record",
                AbsoluteURL = _siteAbsoluteURL,
                IsGridPresent = true
            };

            // Create a SharePoint site record named Sample SharePoint Site.
            _spSiteId = _serviceProxy.Create(spSite);
            Console.WriteLine("{0} created.", spSite.Name);

            // Instantiate a SharePoint document location object.
            // See the Entity Metadata topic in the SDK documentation to determine
            // which attributes must be set for each entity.
            SharePointDocumentLocation spDocLoc = new SharePointDocumentLocation
            {
                Name = "Sample SharePoint Document Location",
                Description = "Sample SharePoint Document Location record",

                // Set the Sample SharePoint Site created earlier as the parent site.
                ParentSiteOrLocation = new EntityReference(SharePointSite.EntityLogicalName, _spSiteId),
                RelativeUrl = "spdocloc"
            };

            // Create a SharePoint document location record named Sample SharePoint Document Location.
            _spDocLocId = _serviceProxy.Create(spDocLoc);
            Console.WriteLine("{0} created.", spDocLoc.Name);
        }

        /// <summary>
        /// Deletes any entity records that were created for this sample.
        /// <param name="prompt">Indicates whether to prompt the user
        /// to delete the records created in this sample.</param>
        /// </summary>
        public void DeleteRequiredRecords(bool prompt)
        {
            bool deleteRecords = true;

            if (prompt)
            {
                Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
                String answer = Console.ReadLine();

                deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
            }

            if (deleteRecords)
            {
                _serviceProxy.Delete(SharePointDocumentLocation.EntityLogicalName, _spDocLocId);
                _serviceProxy.Delete(SharePointSite.EntityLogicalName, _spSiteId);
                Console.WriteLine("Entity records have been deleted.");
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                RetrieveAbsoluteAndSiteCollectionURLs app = new RetrieveAbsoluteAndSiteCollectionURLs();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Reference

Retrieve Absolute and Site Collection URLs for a Location Record

Other Resources

Integrate SharePoint with Microsoft Dynamics CRM
Helper code: ServerConnection class
Sample: Create, retrieve, update, and delete a SharePoint location record
RetrieveAbsoluteAndSiteCollectionUrlRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Advanced development

This section contains advanced development topics for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online.

In This Section

Asynchronous service in Microsoft Dynamics CRM

Azure extensions for Microsoft Dynamics CRM

Disaster recovery in Microsoft Dynamics CRM Online

Administer the deployment using the deployment web service

Custom email providers for Microsoft Dynamics CRM

Write Java and other non-.NET client applications

Sample data for Microsoft Dynamics CRM

Related Sections

Developer overview

Model your business data

Developer tools

Write applications and server extensions

Write client application extensions

Write plug-ins to extend business processes

Write workflows to automate business processes

Developers guide to reports for Microsoft Dynamics CRM

Manage your data

Package and distribute extensions using solutions

Developers guide to customization for Microsoft Dynamics CRM

Extend Microsoft Dynamics CRM for Outlook

Integrate SharePoint with Microsoft Dynamics CRM

Sample code directory

Programming reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Asynchronous service in Microsoft Dynamics CRM

The asynchronous service executes long-running operations independent of the main Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update core operation. This results in improved overall system performance and improved scalability. The asynchronous service features a managed queue for the execution of asynchronous registered plug-ins, workflows, and operations such as bulk mail, bulk import, and campaign activity propagation. These operations are registered with the asynchronous service and executed periodically when the service processes its queue. The asynchronous service can be hosted on a server other that the server running Microsoft Dynamics CRM.

In This Section

Asynchronous service architecture

AsyncOperation (system job) entity

AsyncOperation (system job) entity messages and methods

Asynchronous operation states

Dependency and execution order in asynchronous operations

Recurrence pattern in asynchronous job execution

Supported entities for asynchronous operations

Stop and start the asynchronous service

Related Sections

Advanced development

Event execution pipeline

Write workflows to automate business processes

Manage your data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Asynchronous service architecture

The Microsoft Dynamics CRM system architecture can be divided into three major components: the core system, which features the event execution pipeline, the database component, which hosts the asynchronous queue, and the asynchronous service. One benefit of the scalable architecture of Microsoft Dynamics CRM is that the asynchronous service can be hosted on servers other than the Microsoft Dynamics CRM server, resulting in improved performance. For more information, see the architecture diagram in Event execution pipeline.

Register plug-ins for asynchronous events when they have to perform lots of processing or for functions that are not time critical. Registering a plug-in that performs lots of processing for a synchronous event can adversely affect the performance of Microsoft Dynamics CRM.

You should stop the asynchronous service before you unregister a plug-in that was registered to execute asynchronously. Stopping the service prevents a situation where an asynchronous registered plug-in has been queued for execution but for which there is no plug-in assembly currently registered. For example, consider the situation in which a plug-in has been registered to execute asynchronously and the related event has fired. After the asynchronous operation has been queued by the queue manager, you then unregister (delete) the plug-in assembly from the Microsoft Dynamics CRM database. In this case, an error occurs when the asynchronous service tries to execute the queued asynchronous operation but the plug-in assembly no longer exists.

Queue manager

The queue manager creates and manages asynchronous operations that are sent to the asynchronous service either from the event execution pipeline or directly by a Web service call. When an event is raised in the event execution pipeline, and if one or more plug-ins are registered for that event, the queue manager creates a new asynchronous operation in the queue. Throughout the lifetime of the asynchronous operation, its status may change multiple times from creation until it is completed. The queue manager runs as part of the asynchronous service and manages the state changes of the asynchronous operations. A part of the queue manager, known as the asynchronous queue agent, is located on the Microsoft Dynamics CRM server.

See Also

Concepts

Register and Deploy Plug-Ins
Stop and start the asynchronous service
AsyncOperation (system job) entity

Other Resources

Asynchronous service in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AsyncOperation (system job) entity

A system job, also known as an asynchronous operation, is used to define and track the execution of an asynchronous operation, for example an asynchronous registered plug-in, workflow, or other background system operation. When dealing with asynchronous plug-ins and workflows, you typically don’t create an asyncoperation entity record directly. Instead, an asyncoperation record is automatically created in the database whenever an asynchronous system operation, such as an asynchronous plug-in or a workflow, is going to run. However, you can use the asyncoperation entity when you develop custom tools to manage or report on asynchronous operations in Microsoft Dynamics CRM.

Note that System Job is the display name of this entity when you view it in CRM. When you program by using the Microsoft Dynamics CRM SDK, you use the asyncoperation logical name.

See Also

Reference

AsyncOperation (system job) entity privileges

Concepts

AsyncOperation (system job) entity messages and methods

Other Resources

Asynchronous service in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AsyncOperation (system job) entity messages and methods

An asynchronous operation (system job) represents a process whose execution can continue independently or in the background. The schema name for this entity is AsyncOperation. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with theIOrganizationService.Execute method.

Message | Description
CreateRequest | For internal use only.
DeleteRequest | Deletes an asynchronous operation (system job). The asynchronous operation can be deleted only if the AsyncOperation.AsyncOperationState is Completed. You can also call the IOrganizationService.Delete method.
RetrieveRequest | Retrieve an asynchronous operation (system job). You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of asynchronous operations (system jobs). You can also call the IOrganizationService.RetrieveMultiple method.
RetrievePrincipalAccessRequest | Retrieves the access that the security principal (user) has for an asynchronous operation (system job).
UpdateRequest | Updates an asynchronous operation (system job). Typically, you would update only the AsyncOperation.StateCode or AsyncOperation.PostponeUntil attributes of the asynchronous operation (system job). You can also call the IOrganizationService.Update method.

See Also

Reference

AsyncOperation (system job) entity privileges

Concepts

AsyncOperation (system job) entity
Asynchronous operation states

Other Resources

Asynchronous service in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Asynchronous operation states

After asynchronous operations are added to the asynchronous queue, they exist in a well-defined state. An asynchronous operation can be waiting to run, it can be running, or it can be completed. There are also other possible states before the operation is eventually deleted from the queue. The states define the life cycle of the asynchronous operation.

In This Topic

States for asynchronous operations

Retrieve and update AsyncOperation states

States for asynchronous operations

The state of the asynchronous operation can be altered through three means: by the platform as part of regular queue processing, by the user interacting with the Microsoft Dynamics CRM Web application, or by a Web service call that alters the asynchronous operation. As a developer you can retrieve the current state of any asynchronous operation that you have access to and also change the state.

The following table lists the states, and the statuses for each state, of an AsyncOperation.

State | Status | Numeric status value
Ready | WaitingForResources | 0
Suspended | Waiting | 10
Locked | InProgress | 20
Locked | Pausing | 21
Locked | Canceling | 22
Completed | Succeeded | 30
Completed | Failed | 31
Completed | Canceled | 32

The supported states are defined in the AsyncOperationState enumeration. In the early bound AsyncOperation class, the state is available in the AsyncOperation.StateCode attribute while the status is available in the AsyncOperation.StatusCode attribute. For more information, see the AsyncOperation entity metadata. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.. The statuses are shown in the Microsoft Dynamics CRM Web application in the Status Reason field in System Jobs grid. By selecting any of the menu items in the More Actions menu in System Jobs, you can interactively alter the state of an asynchronous operation. Allowed actions include the following: Cancel, Resume, Postpone, and Pause.

The following diagram shows the asynchronous operation state transitions that are supported.

AsyncOperation state diagram

Notice that an asynchronous operation can only transition from one state to another along specific paths as shown in the diagram. Some paths are initiated by the user interacting with the Microsoft Dynamics CRM Web application while other paths are initiated by the Microsoft Dynamics CRM platform as part of regular asynchronous queue processing or because of a Web service call. For example, an asynchronous operation cannot transition directly from a Suspended state to a Locked state.

A locked state indicates that the AsyncOperation instance is being used by the asynchronous service. While it is locked it cannot be used by another instance of the service. This ensures that the instance is not executed more than once, for example by two different asynchronous services.

Retrieve and update AsyncOperation states

Monitoring and updating the state of an asynchronous operation is typically done interactively through the System Jobs grid in the Microsoft Dynamics CRM Web application. However, you can also use the SDK to write code that performs those same tasks.

Read the state of an asynchronous operation

  1. Retrieve an AsyncOperation by name using the RetrieveMultiple method or by ID using the Retrieve method.

  2. Read the AsyncOperation.StateCode attribute.

Change the state code

  1. Modify the retrieved state code attribute to a new value according to the allowed operation states. You could also change the AsyncOperation.PostponeUntil attribute.

  2. Call Update to change the value of those attributes in the database.

The previous operations can also be performed by using the Execute method with the appropriate request messages. Attributes of AsyncOperation other than AsyncOperation.StateCode and AsyncOperation.PostponeUntil should be considered read-only.

Recurring system jobs

You cannot cancel, pause, or resume most system jobs. Refer to the following list that identifies some of these restricted system jobs. The value in the first column is the value of the OperationType attribute of the AsyncOperation entity.

Async Operation Type (Option Value) | Operation Description
22 | Calculate Organization Maximum Storage Size
18 | Calculate Organization Storage Size
19 | Collect Organization Database Statistics
20 | Collection Organization Size Statistics
16 | Collect Organization Statistics
9 | SQM Data Collection
25 | Organization Full Text Catalog Index
31 | Storage Limit Notification
24 | Update Statistic Intervals
27 | Update Contract States

For the complete list of supported asynchronous operation types, see the AsyncOperation entity metadata. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

See Also

Concepts

AsyncOperation (system job) entity
Dependency and execution order in asynchronous operations

Other Resources

Asynchronous service in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Dependency and execution order in asynchronous operations

An asynchronous operation can be made dependent with another asynchronous operation. A dependent asynchronous operation does not execute until the operation that it is dependent with has finished executing. For example, if asynchronous operation B is dependent with asynchronous operation A, operation B does not execute until after operation A executes and is completed. This dependency between asynchronous operations is established by setting the AsyncOperation.DependencyToken attribute, which can contain any string value. Any dependent asynchronous operations must have the same AsyncOperation.DependencyToken value.

The Microsoft Dynamics CRM platform establishes which asynchronous operation is dependent when the operations are created in the asynchronous queue. For example, consider three asynchronous operations named A, B, and C, where B and C should only execute after A is completed. To establish the correct dependencies, A must be created in the queue first, followed by B and then C. This is because the order in which the operations are created establishes the sequence of their execution. In this example, all three asynchronous operations have the same AsyncOperation.DependencyToken. At run time, A executes first. After A has completed, B executes to completion, and then C executes until completion.

In the previous example, if operation B is postponed, operation A executes until it is completed and operation C is blocked until operation B is no longer postponed and executes until completed. You can postpone execution of an asynchronous operation by using the AsyncOperation.PostponeUntil attribute.

Any asynchronous operation that has a AsyncOperation.DependencyToken value of null executes independent of all other asynchronous operations in the queue. The order of execution with regard to other independent operations is not guaranteed. However, asynchronous operations created earlier have a better chance of executing before operations created later. This assumes that the operations are not postponed and are not set to a state of Completed.

The dependency token must be set when the asynchronous operation is created. Because Microsoft Dynamics CRM creates asynchronous operations for bulk operations such as bulk email, bulk delete, and import, you cannot make use of the dependency token for these operations. In addition, the dependency token cannot be used to order execution of asynchronous registered plug-ins because the asynchronous operation that executes plug-ins is created by the Queue Manager. For more information, refer to Asynchronous service architecture.

See Also

Concepts

Recurrence pattern in asynchronous job execution

Other Resources

Asynchronous service in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Recurrence pattern in asynchronous job execution

You can execute asynchronous system operations one time or on a recurring basis by using a recurrence rule. Use the AsyncOperation.RecurrencePattern attribute to specify the recurrence rule. This property is included in the request classes of the IOrganizationService messages that submit asynchronous jobs, such as bulk delete, or bulk detect duplicates. It is also included in the entities that represent asynchronous operations, such as the AsyncOperation (system job) entity.

Use the following format to set the AsyncOperation.RecurrencePattern attribute.

Recurrence pattern | Frequency of job execution
"FREQ=MONTHLY;" | Once a month
"FREQ=WEEKLY;" | Once a week
FREQ=DAILY;" | Once a day
"FREQ=HOURLY;" | Once an hour
Note
A complete format for a recurrence rule is described in the RFC2445 Internet standard (Internet Calendaring and Scheduling Core Object Specification).

You can specify how frequently you want to repeat the recurrence rule by using an INTERVAL part of the rule. For example, to execute a job every three days, use the following format: "FREQ=DAILY;INTERVAL=3;". The INTERVAL is an optional part of the recurrence rule. If you do not specify INTERVAL, it is set to 1.

To run an asynchronous job without recurrence, set this property to a value that is specified in the AsyncOperation.RecurrencePattern property programming reference topic for a particular message request class or an entity.

To specify the start time of the job execution, use the AsyncOperation.RecurrenceStartTime property or the StartDateTime property in the message request classes or in the records that represent asynchronous operations. If the property is not set, the start time is set to the value that is contained in the DateTime.Now property.

See Also

Concepts

AsyncOperation (system job) entity
Supported entities for asynchronous operations

Other Resources

Delete data in bulk
Asynchronous service in Microsoft Dynamics CRM
RecurrencePattern
StartDateTime
RecurrencePattern
RecurrenceStartTime

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Supported entities for asynchronous operations

The entities and messages that are supported in asynchronous operations are the same as the message and entity combinations that support plug-ins. For more information, seeSupported messages and entities for plug-ins.

Asynchronous operations are spawned to handle many types of Microsoft Dynamics CRM operations, for example import/export, bulk operations, duplicate detection, recurring appointments, recurring (internal) system jobs, and more.

See Also

Concepts

Asynchronous operation states
Recurring appointment partial expansion model

Other Resources

Detect duplicate data
Delete data in bulk
Import data

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Stop and start the asynchronous service

For Microsoft Dynamics CRM on-premises (including IFD) deployments, the asynchronous service can be stopped and restarted by using the Services administrative tool. The service should be stopped before a plug-in assembly that contains asynchronous plug-ins is deleted.

Stop and restart the service

  1. Navigate to Start, select Administrative Tools, then click Services.

  2. Right-click Microsoft Dynamics CRM Asynchronous Processing Service in the Name column of the service listing.

  3. Click Start or Stop. Or, you can click Properties in the shortcut menu and then click Start or Stop in the dialog box.

You must have System Administrator privileges to stop or start the service.

See Also

Other Resources

Asynchronous service in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Azure extensions for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update support integration with Microsoft Azure. Developers can register plug-ins with Microsoft Dynamics CRM that can pass run-time message data, known as the execution context, to one or more Microsoft Azure solutions in the cloud. This is especially important for Microsoft Dynamics CRM Online because Microsoft Azure is one of two supported solutions for communicating run-time context obtained in a plug-in to external line of business (LOB) applications. The other solution is the external custom endpoint access capability from a plug-in registered in the sandbox.

The Microsoft Azure Service Bus combined with the Microsoft Azure Active Directory Access Control Service (ACS) provides a secure communication channel for Microsoft Dynamics CRM run-time data to external line of business applications. This capability is especially useful in keeping disparate Microsoft Dynamics CRM systems or other CRM servers synchronized with Microsoft Dynamics CRM business data changes.

In This Section

Azure integration with Microsoft Dynamics CRM

Configure Azure integration with Microsoft Dynamics CRM

Write a listener for a Microsoft Azure solution

Write a custom Azure-aware plug-in

Send Microsoft Dynamics CRM data over the Azure Service Bus

ServiceEndpoint entity messages and methods

Walkthrough: Configure CRM for integration with Microsoft Azure

Walkthrough: Configure Microsoft Azure ACS for integration with Microsoft Dynamics CRM 2015

Walkthrough: Register an Azure-aware plug-in with the CRM plug-in registration tool

Sample code for Microsoft Dynamics CRM and Microsoft Azure integration

Related Sections

Advanced development

Write plug-ins to extend business processes

Microsoft Azure Platform Developer Center

Microsoft Azure Service Bus

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Azure integration with Microsoft Dynamics CRM

You can connect Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update with the Microsoft Azure platform by coupling the CRM event execution pipeline to the Microsoft Azure Service Bus. This connection lets the data that’s been processed as part of the current CRM operation to be posted to the bus. Microsoft Azure Service Bus solutions that are “CRM-aware” can listen for and read the data that’s posted on the service bus by Microsoft Dynamics CRM. The posted data is stored in a RemoteExecutionContext class instance that is an extended version of IExecutionContext passed at run time to Microsoft Dynamics CRM asynchronous plug-ins.

This connection between Microsoft Dynamics CRM and the Microsoft Azure platform provides a secure channel for communicating CRM run-time data to external cloud-based line-of-business (LOB) applications.

In This Topic

Key elements of the connection

A CRM to service bus scenario

Establish a contract between CRM and an Azure solution

Manage run-time errors

Key elements of the connection

The key elements that implement the connection between Microsoft Dynamics CRM and the Microsoft Azure Service Bus are as follows:

Asynchronous service

The asynchronous service is responsible for posting the Microsoft Dynamics CRM remote execution context to the Microsoft Azure Service Bus. Each post is performed by a system job of the asynchronous service. A user can view the status of each system job by using the Microsoft Dynamics CRM web application.

Plug-ins

There are two kinds of asynchronous registered plug-ins supported by the connection feature: out-of-box (OOB), those plug-ins that are provided with CRM, and custom. For more information about using synchronous plug-ins with Microsoft Azure, see Access the Notification Service.

An Azure-aware plug-in is provided with CRM. This plug-in executes in full trust with the Microsoft Dynamics CRM platform. When registered with Microsoft Dynamics CRM, the plug-in can notify the asynchronous service to post the current request’s context to the Microsoft Azure Service Bus. A developer needs to register a step on this plug-in that identifies the target message and entity to enable the service bus posting functionality.

You can also write your own custom plug-in that is “Azure-aware”. The custom plug-in executes in partial trust mode in the sandbox and can call any Microsoft Dynamics CRM SDK methods. A custom plug-in can initiate posting of the Microsoft Dynamics CRM context to the service bus by including some standard lines of code that notifies the asynchronous service to post the request context. This cloud-specific code makes the plug-ins “Azure-aware”. For more information about plug-ins in general, see Write a plug-in. For more information about Azure-aware plug-ins, see Write a custom Azure-aware plug-in.

Custom workflow Activities

Custom workflow activities can be written to post the current request’s data context to the Microsoft Azure Service Bus. More information: Sample: Azure aware custom workflow activity.

Microsoft Azure Service Bus

The service bus relays the remote execution context between Microsoft Dynamics CRM and Microsoft Azure Service Bus solution listeners. The Microsoft Azure Active Directory Access Control Service (ACS) manages claims-based authentication security.

Microsoft Azure solution

For the CRM and Azure connection to work there must be at least one solution in an Microsoft Azure Service Bus solution account, where the solution contains one or more service endpoints. For a relay endpoint contract, a listener that is “CRM-aware” must be actively listening on the endpoint for the CRM request on the service bus. For a queue endpoint contract, a listener doesn’t have to be actively listening. A listener is made “CRM-aware” by linking it to the Microsoft.Xrm.Sdk assembly so that type RemoteExecutionContext is defined. More information: Write a listener for a Microsoft Azure solution

The solution rules must be configured to allow the Microsoft Dynamics CRM remote execution context to be posted to the service bus. To enable this posting, ACS needs to recognize the CRM deployment as a supported issuer. More information: Configure Azure integration with Microsoft Dynamics CRM.

Important
To develop a solution listener for the Microsoft Azure platform, you need to install the Microsoft Azure SDK version 1.7 or 1.8. on your development computer.

A CRM-to-service bus scenario

Let us now identify a scenario that implements the previously mentioned connection components. As a prerequisite, ACS has been configured to recognize Microsoft Dynamics CRM as the supported issuer and the Microsoft Azure Service Bus solution configured with rules to allow Microsoft Dynamics CRM to post to the endpoint where the listener is.

The following diagram shows the physical elements that make up the scenario.

Microsoft Dynamics CRM to Service Bus scenario

The sequence of events as identified in this diagram are as follows:

  1. A listener is registered on a Microsoft Azure Service Bus solution endpoint and begins actively listening for the Microsoft Dynamics CRM remote execution context on the service bus.
  2. A user performs some operation in Microsoft Dynamics CRM that triggers execution of the registered OOB plug-in or a custom Azure-aware plug-in. The plug-in initiates a post, through an asynchronous service system job, of the current request context to the service bus.
  3. ACS authenticates the claims posted by Microsoft Dynamics CRM. The service bus then relays the remote execution context to the listener. The listener processes the context information and performs some business-related task with that information. The service bus notifies the asynchronous service of a successful post and sets the related system job to a completed status.

Establish a contract between CRM and an Azure solution

For each solution endpoint, you configure a contract that defines the handling of these remote execution context “messages” on the service bus and the security that should be used on that endpoint. Service bus messages are received at an endpoint using one of the supported contracts listed here.

Queue

A queue contract provides a message queue in the cloud. With a queue contract, a listener doesn’t have to be actively listening for messages on the endpoint. For queues, there is a destructive read and a non-destructive read. A destructive read reads an available message from the queue and the message is removed. A non-destructive read doesn’t remove a message from the queue.

There are two types of queues supported in Microsoft Dynamics CRM: a message buffer queue, and a persistent queue. For message buffer queues, messages in the queue are automatically deleted if not read within a pre-configured length of time that typically is less than 10 minutes. Persistent queues have a much longer message availability duration that can be specified in code.

One-way

A one-way contract requires an active listener. If there is no active listener on an endpoint, the Microsoft Dynamics CRM post to the service bus fails. Microsoft Dynamics CRM will retry the post in exponentially larger and larger time spans until the asynchronous system job that is posting the request is eventually aborted and its status is set to “Failed.”

Two-way

A two-way contract is similar to a one-way contract except that a string value can be returned from the listener to Microsoft Dynamics CRM.

REST

A REST contract is similar to a two-way contract on a REST endpoint.

Topic

Similar to a queue except that one or more listeners can subscribe to receive messages from the topic.

Important
To use these contracts, you must write your listener applications using the Microsoft Azure SDK v1.7 or 1.8.

Message buffer queues are deprecated and won’t be supported in a future release of the Microsoft Dynamics CRM SDK.

Identifying the kind of security a contract uses is part of the contract’s configuration. A contract can use Transport security, which uses Secure Sockets Layer (SSL) (https).

Claims authentication is used for secure access to the service bus. The claim used to authenticate to the service bus is generated in Microsoft Dynamics CRM and signed by the AppFabricIssuer certificate specified in the Microsoft Dynamics CRM configuration database.

Manage of run-time errors

If an error occurred after a post was attempted to the service bus, check the status of the related system job in the Microsoft Dynamics CRM web application for more information on the error. If the service bus is down or a listener/endpoint isn’t available, the current message being processed in Microsoft Dynamics CRM will not be posted to the bus. The asynchronous service will continue to try to post the message in an exponential pattern where it will try to post frequently at first and then at longer and longer intervals. For an internal Microsoft Dynamics CRM error, message posts are not attempted. For an external service bus or network error, the related system job will be in a “Wait” state.

See Also

Concepts

Configure Azure integration with Microsoft Dynamics CRM
AsyncOperation (system job) entity

Other Resources

Azure extensions for Microsoft Dynamics CRM
Write plug-ins to extend business processes
Asynchronous service in Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Configure Azure integration with Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update are capable of posting the message request data for the current core operation to the Microsoft Azure cloud. To enable this capability in Microsoft Dynamics CRM, perform the tasks detailed in this topic.

In This Topic

Configuration tasks for Microsoft Dynamics CRM/Azure integration

Get a public certificate

Configure Microsoft Dynamics CRM for Azure integration

Configure Azure ACS for Microsoft Dynamics CRM integration

Configuration tasks for Microsoft Dynamics CRM/Azure integration

  1. Obtain a Public Certificate from Microsoft Dynamics CRM Online or from an issuing authority.

  2. Configure Microsoft Dynamics CRM for Azure Integration.

  3. Configure Azure ACS for Microsoft Dynamics CRM Integration.

These tasks are expanded upon in this topic. After configuring Microsoft Dynamics CRM and Microsoft Azure integration, you will need to perform these additional tasks.

  1. Write and register a listener application with a Microsoft Azure Service Bus solution endpoint. For more information, see the Microsoft Azure Service Bus documentation.
  2. Register a Microsoft Azure aware plug-in, for example the ServiceBusPlugin plug-in, or a Microsoft Azure aware custom workflow activity with Microsoft Dynamics CRM. More information: Walkthrough: Register an Azure-aware plug-in with the CRM plug-in registration tool
  3. Perform the necessary Microsoft Dynamics CRM operation that triggers the plug-in or custom workflow activity to run.

If all of the preceding steps were performed correctly, a message containing the Microsoft Dynamics CRM data context should be sent to a Microsoft Azure queue or topic and ultimately received by the listener application. You can navigate to the System Jobs grid in the Microsoft Dynamics CRM web application and check the status of the related System Job to see if the post to the Microsoft Azure Service Bus succeeded. In case of errors, the message section of the System Job displays the error details.

For more information, see the See Also links at the end of this topic.

Important
As a prerequisite, you should download and read the Azure SDK documentation before attempting to understand this topic and configure Microsoft Dynamics CRM and Microsoft Azure integration.

Get a public certificate

For Microsoft Dynamics CRM Online users, a public certificate can be downloaded from the Web application. To download the certificate from the Web application, select Settings, click Customizations, and then select Developer Resources. On that page, click the Download Certificate link below Microsoft Azure Issuer Certificate to download and save the public certificate. In addition, write down the issuer name because you will need it later.

For Microsoft Dynamics CRM 2015 on-premises and IFD installations, you can purchase a private certificate from an issuing authority. Import the certificate file into the Personal\Certificates store on your computer using the certificate Microsoft Management Console (MMC) snap-in. Next, export a public key file of your certificate in Base64 format. This public certificate will be used in the next task. For more information, see the MMC Help.

Configure Microsoft Dynamics CRM for Azure integration

For Microsoft Dynamics CRM 2015 on-premises and IFD deployments, configuring the server for Microsoft Azure integration involves storing the public certificate in the Microsoft Dynamics CRM configuration database and setting the proper security access to the certificate so Microsoft Dynamics CRM can read it. Microsoft Dynamics CRM Online comes pre-configured to work with Microsoft Azure.

Refer to the topic Walkthrough: Configure CRM for integration with Microsoft Azure for step-by-step instructions on configuring Microsoft Dynamics CRM 2015 integration with the Microsoft Azure platform.

Security Note
For the Microsoft Dynamics CRM 2015 and Microsoft Azure Service Bus integration feature to work, the Microsoft Dynamics CRM asynchronous service must have access to the Internet through the server’s firewall. The server where the Asynchronous Service role is installed must be exposed to the Internet, and the account that the service runs under must have Internet access. Only outbound connections on ports 80 and 443 are required. Inbound connection access is not required. Use the Windows Firewall control panel to enable outbound connections for the CrmAsyncService.exe application located on the server in the %PROGRAMFILES%\Microsoft Dynamics CRM\Server\bin folder.

Configure Azure ACS for Microsoft Dynamics CRM integration

You need to configure the rules and issuers of your Microsoft Azure solution to allow a listener to read the Microsoft Dynamics CRM message posted to the Microsoft Azure Service Bus. In addition, you must configure the service bus rules to accept the Microsoft Dynamics CRM issuer claim.

More information: Walkthrough: Configure Microsoft Azure ACS for integration with Microsoft Dynamics CRM 2015

See Also

Concepts

Write a plug-in
Send Microsoft Dynamics CRM data over the Azure Service Bus
Write a listener for a Microsoft Azure solution

Other Resources

Azure extensions for Microsoft Dynamics CRM
Azure Platform – Getting Started

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write a listener for a Microsoft Azure solution

This topic describes how to write a listener that can read and process Microsoft Dynamics CRM 2015 messages that are posted to the Microsoft Azure Service Bus. As a prerequisite, you should familiarize yourself with how to write a Microsoft Azure Service Bus listener before trying to learn the specifics of a Microsoft Dynamics CRM listener. For more information, see the Azure Service Bus documentation and sample code.

In This Topic

Write a queue listener

Write a one-way, two-way, or REST listener

Filter messages

Write a queue listener

A message queue is a repository of messages received at a service bus endpoint. A queue listener is an application that reads and processes these queued messages. Because the service bus messages are stored in a queue, a listener doesn’t have to be actively listening in order for messages to be received in the queue. A queue listener can be started after messages have arrived in the queue and still process those messages. Other types of listeners discussed in the next section must be actively listening or they will miss the opportunity to read a message. These messages can originate from Microsoft Dynamics CRM or from some other source. When writing a queue listener, it is important to check each message header action to determine if the message originated from Microsoft Dynamics CRM.

You can do a destructive message read using Receive in ReceiveAndDelete mode, where the message is read and removed from the queue, or a non-destructive read using PeekLock mode, where the message is read but still available in the queue. The persistent queue listener sample code provided in this SDK does a destructive read. For more information about reading messages from a queue, see How to Receive Messages from a Queue.

A topic is similar to a queue but implements a publish/subscribe model. One or more listeners can subscribe to the topic and receive messages from its queue. More information: Queues, Topics, and Subscriptions

Important
Support for persistent queues and topics is supported. To use these contracts, you must write your listener applications using the Azure SDK version 1.7 or 1.8.

Message buffer queues are deprecated and won’t be supported in a future release of the Microsoft Dynamics CRM SDK.

Use of queues and topics in your multisystem software design can result in the decoupling of systems. If the listener application ever becomes unavailable, the message delivery from Microsoft Dynamics CRM will still succeed and the listener application can continue processing the queue message when it is back online. More information: Queues, Topics, and Subscriptions.

Update a message buffer listener to use persistent queues

The following procedure lists the generic steps you would follow to update a listener application that retrieves message from a message buffer to one that receives message from a persistent queue.

  1. On the Microsoft Azure portal and in the same solution, create a queue in the same path as was used for the message buffer.

  2. Install the Microsoft Azure SDK version 1.7 or 1.8 on your development machine.

  3. Update the listener code by removing the message buffer related classes and methods, and then replace them with QueueClient and Receive. Be sure to use the desired read mode: RetrieveAndDelete or PeekLock. For more information about reading messages from a queue, see Queues, Topics, and Subscriptions.

  4. Build the listener application.

No Microsoft Dynamics CRM configuration changes are necessary as long as the queue endpoint uses the same solution path that the message buffer had used.

Write a one-way, two-way, or REST listener

In addition to the queue listener described previously, you can write a listener for three other service bus contracts that are supported by Microsoft Dynamics CRM: one-way, two-way, and REST. A one-way listener can read and process a message posted to the service bus. A two-way listener can do the same but can also return a string of some information back to CRM. A REST listener is the same as the two-way listener except that it works with a REST endpoint. Notice that these listeners must be actively listening at a service endpoint to read a message sent over the service bus. If the listener isn’t listening when Microsoft Dynamics CRM attempts to post a message to the service bus, the message doesn’t get sent.

Writing a listener is structured around what is known as ABC: address, binding, and contract. The following information identifies the ABCs of a one-way listener.

  • Address: service URI
  • Binding: WS2007HttpRelayBinding
  • Contract: IServiceEndpointPlugin

After your listener is registered with an endpoint, the listener’s Execute method is invoked whenever a message is posted to the service bus by Microsoft Dynamics CRM. The Execute method doesn’treturn any data from the method call. For more information, see the one-way listener sample, Sample: One-way listener.

A two-way listener is coded in a similar fashion as a one-way listener. The ABCs of a two-way listener are as follows:

  • Address: service URI
  • Binding: WS2007HttpRelayBinding
  • Contract: ITwoWayServiceEndpointPlugin

For this two-way contract, the Execute method returns a string from the method call. For more information, see the two-way listener sample, Sample: Two-way listener.

A REST listener is coded in a similar fashion as a two-way listener. The ABCs of a REST listener are as follows:

  • Address: service URI
  • Binding: WebHttpRelayBinding
  • Contract: IWebHttpServiceEndpointPlugin

For the REST contract, the Execute method returns a string from the method call. Refer to the REST listener sample, Sample: REST listener, for more information. Notice that in the REST listener sample, a WebServiceHost is instantiated and not a ServiceHost as was done in the two-way sample.

Note
When using the out-of-box (ServiceBusPlugin) plug-in with a two-way or REST listener, the plug-in doesn’t use any string data returned from the listener. However, a custom Azure-aware plug-in could make use of this information.

When you run the listener samples, the issuer secret you’re prompted for is the Microsoft Azure Service Bus management key. The WS2007 Federation HTTP binding uses “token” mode and the WS-Trust 1.3 protocol.

Filter messages

There is a property bag of extra information added to each brokered message Properties property sent from Microsoft Dynamics CRM 2015 and CRM Online. The property bag, available with persistent queue and topic contract endpoints, contains the following information.

  • Organization Url
  • Calling user ID
  • Initiating user ID
  • Entity logical name
  • Request name

This information identifies the organization, user, entity, and message request being processed by Microsoft Dynamics CRM that resulted in the service bus message being posted. Your listener code can choose to process a message it receives based on this information. More information: Sample: Execute multiple requests

See Also

Concepts

Write a custom Azure-aware plug-in
Send Microsoft Dynamics CRM data over the Azure Service Bus

Other Resources

Azure extensions for Microsoft Dynamics CRM
Sample: Persistent queue listener
Sample: One-way listener
Sample: Two-way listener
Sample: REST listener

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write a custom Azure-aware plug-in

Writing a plug-in that works with Microsoft Azure is similar to writing any other Microsoft Dynamics CRM plug-in. However, in addition to invoking any desired web service methods, the plug-in must include code to initiate posting the execution context to the Microsoft Azure Service Bus.

In This Topic

Plug-in design considerations

Writing the plug-in code

Plug-in registration

Handle a failed service bus post

Plug-in design considerations

For a plug-in that executes synchronously, the recommended design is for the plug-in to send a message to Microsoft Azure for the purpose of retrieving information from a listener application or other external service. Use of a two-way or REST contract on the Microsoft Azure Service Bus endpoint allows a data string to be returned to the plug-in.

It is not recommended that a synchronous plug-in use the Microsoft Azure Service Bus to update data with an external service. Problems can arise if the external service becomes unavailable or if there is a lot of data to update. Synchronous plug-ins should execute fast and not hold up all logged in users of an organization while a lengthy operation is performed. In addition, if a rollback of the current core operation that invoked the plug-in occurs, any data changes made by the plug-in are undone. This could leave Microsoft Dynamics CRM and an external service in an unsynchronized state.

Note that it is possible for synchronous registered plug-ins to post the execution context to the Microsoft Azure Service Bus.

Write the plug-in code

In the following sample plug-in code has been added to obtain the Microsoft Azure service provider and initiate posting the execution context to the service bus by calling Execute. Tracing code has been added to facilitate debugging of the plug-in because the plug-in must run in the sandbox.

C# Copy Code
using System;
using System.Diagnostics;
using System.Threading;
using System.Runtime.Serialization;

using System.ServiceModel;
using System.ServiceModel.Channels;
using System.ServiceModel.Description;

using Microsoft.Xrm.Sdk;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// A custom plug-in that can post the execution context of the current message to the Windows
    /// Azure Service Bus. The plug-in also demonstrates tracing which assist with
    /// debugging for plug-ins that are registered in the sandbox.
    /// </summary>
    /// <remarks>This sample requires that a service endpoint be created first, and its ID passed
    /// to the plug-in constructor through the unsecure configuration parameter when the plug-in
    /// step is registered.</remarks>
    public sealed class SandboxPlugin : IPlugin
    {
        private Guid serviceEndpointId;

        /// <summary>
        /// Constructor.
        /// </summary>
        public SandboxPlugin(string config)
        {
            if (String.IsNullOrEmpty(config) || !Guid.TryParse(config, out serviceEndpointId))
            {
                throw new InvalidPluginExecutionException("Service endpoint ID should be passed as config.");
            }
        }

        public void Execute(IServiceProvider serviceProvider)
        {
            // Retrieve the execution context.
            IPluginExecutionContext context = (IPluginExecutionContext)serviceProvider.GetService(typeof(IPluginExecutionContext));

            // Extract the tracing service.
            ITracingService tracingService = (ITracingService)serviceProvider.GetService(typeof(ITracingService));
            if (tracingService == null)
                throw new InvalidPluginExecutionException("Failed to retrieve the tracing service.");

            IServiceEndpointNotificationService cloudService = (IServiceEndpointNotificationService)serviceProvider.GetService(typeof(IServiceEndpointNotificationService));
            if (cloudService == null)
                throw new InvalidPluginExecutionException("Failed to retrieve the service bus service.");

            try
            {
                tracingService.Trace("Posting the execution context.");
                string response = cloudService.Execute(new EntityReference("serviceendpoint", serviceEndpointId), context);
                if (!String.IsNullOrEmpty(response))
                {
                    tracingService.Trace("Response = {0}", response);
                }
                tracingService.Trace("Done.");
            }
            catch (Exception e)
            {
                tracingService.Trace("Exception: {0}", e.ToString());
                throw;
            }
        }
    }
}

In your plug-in code, you can update the writeable data in the context before initiating the post. For example, you can add a key/value pair to the shared variables in the context.

Plug-in registration

There are a few restrictions when you register a Microsoft Azure aware custom plug-in. The plug-in must be registered to execute in the sandbox. Because of this, the plug-in is limited to calling Microsoft Dynamics CRM SDK methods, Microsoft Azure solution methods, or accessing a network using a web client. No other external access, such as access to a local file system, is allowed.

For a plug-in registered to execute in asynchronous mode, this also means that the order of plug-in execution compared to other asynchronous plug-ins is not guaranteed. In addition, asynchronous plug-ins always execute after the Microsoft Dynamics CRM core operation.

Handle a failed service bus post

The expected behavior from a failed service bus post is dependent on whether the plug-in was registered for synchronous or asynchronous execution. For asynchronous plug-ins, the system job that actually posts the execution context to the service bus will retry the post. For a synchronous registered plug-in, an exception is returned. More information: Management and Notification of Run-time Errors

Important
For asynchronous registered plug-ins only, when the asynchronous job that posts to the Microsoft Azure Service Bus is retried after a post failure, the entire plug-in logic is executed again. Because of this, don’t add any other logic to the custom Microsoft Azure aware plug-in other than just modifying the context and posting to the service bus.

For a plug-in registered to execute asynchronously, the RemoteExecutionContext contained in the body of the message that is sent over the service bus includes a OperationId property and a OperationCreatedOn property. These properties contain the same data as the AsyncOperationId and CreatedOn attributes of the related System Job (AsyncOperation) record. These additional properties facilitate sequencing and duplicate detection if the Microsoft Azure Service Bus post must be retried.

See Also

Concepts

Send Microsoft Dynamics CRM data over the Azure Service Bus
Write a plug-in
Plug-in isolation, trusts, and statistics
Event execution pipeline
Register and Deploy Plug-Ins

Other Resources

Azure extensions for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Send Microsoft Dynamics CRM data over the Azure Service Bus

An internal plug-in named ServiceBusPlugin is provided with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. The plug-in contains the business logic to post the Microsoft Dynamics CRM message execution context to the Microsoft Azure Service Bus. To use this plug-in, you need to register a Microsoft Azure Service Bus solution endpoint and a step for the plug-in. The step defines what message and entity combination being processed by the core Microsoft Dynamics CRM operation should trigger the plug-in to execute. The ServiceBusPlugin can only be registered to run asynchronously. For more information, see Walkthrough: Register an Azure-aware plug-in with the CRM plug-in registration tool.

In addition, you can write a custom plug-in that includes the required lines of code to post to the service bus. The plug-in is registered in a similar way, except that it must be registered in the sandbox and run under partial trust. For more information on writing a custom plug-in that can post to the Microsoft Azure Service Bus, see Write a custom Azure-aware plug-in.

You can also write a custom workflow activity that can post the execution context to the service bus and include this activity in your workflows. Sample code for a custom Microsoft Azure-aware workflow activity is provided in the topic Sample: Azure aware custom workflow activity.

See Also

Tasks

Walkthrough: Register a plug-in using the plug-in registration tool

Concepts

Write a plug-in
Plug-in isolation, trusts, and statistics
Understand the data context passed to a plug-in
Register and Deploy Plug-Ins
Event execution pipeline
ServiceEndpoint entity messages and methods

Other Resources

Azure extensions for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ServiceEndpoint entity messages and methods

A service endpoint represents a Microsoft Azure platform endpoint. This entity stores the configuration information of a service endpoint. The schema name for this entity is ServiceEndpoint. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the metadata for your organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

The following table describes the messages for this entity, which you use with the IOrganizationService.Execute method.

Message | Description
AssociateRequest | Creates a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Associate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see ServiceEndpoint entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
CreateRequest | Creates a service endpoint. You can also call the IOrganizationService.Create method.
DeleteRequest | Deletes a service endpoint. You can also call the IOrganizationService.Delete method.
DisassociateRequest | Removes a link between a record and one or more records that participate in a relationship. You can also use the IOrganizationService.Disassociate method. For more information, see Actions on Entity Records. For a list of default relationships for this entity, see ServiceEndpoint entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.
InitializeFromRequest | Initializes a new record from an existing record provided that an attribute map is defined for the two entities. For more information, see Customize entity and attribute mappings.
RetrieveDuplicatesRequest | Detects and retrieves duplicate records for the specified record provided that duplicate detection is enabled and there are published duplicate detection rules for the entity. For more information, see Detect duplicate data.
RetrieveRequest | Retrieves a service endpoint. You can also call the IOrganizationService.Retrieve method.
RetrieveMultipleRequest | Retrieves a collection of accounts. You can also call the IOrganizationService.RetrieveMultiple method.
UpdateRequest | Updates a service endpoint. You can also call the IOrganizationService.Update method.
TriggerServiceEndpointCheckRequest | Validates the configuration of the service endpoint of a Microsoft Azure platform solution.

See Also

Concepts

Send Microsoft Dynamics CRM data over the Azure Service Bus
ServiceEndpoint entity privileges
Walkthrough: Configure CRM for integration with Microsoft Azure

Other Resources

Azure extensions for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Walkthrough: Configure CRM for integration with Microsoft Azure

This walkthrough guides you through configuring on-premises or Internet-facing deployments of Microsoft Dynamics CRM 2015 for posting the execution data context to the Microsoft Azure Service Bus. This walkthrough doesn’t apply to Microsoft Dynamics CRM Online, which is pre-configured for Microsoft Azure.

Perform the following tasks before continuing with this walkthrough:

  1. Obtain a certificate from an issuing authority.
  2. Install the certificate in the certificate store of the server running the Microsoft Dynamics CRM asynchronous service.
  3. Generate a public key file in Base64 format from the certificate. More information: Get a public certificate.
  4. Verify that Windows PowerShell is installed on your Microsoft Dynamics CRM server.

Configure certificate read access

The system user account under which the Microsoft Dynamics CRM asynchronous service runs must have read access to your certificate in the certificate store. Either a user account that is identified by the deployment administrator during server setup or NetworkService is used. You can verify the account used by running the Services administrative tool. In the tool, look up the service named “Microsoft Dynamics CRM Asynchronous Processing Service” and see what account that service is running under.

You must grant read access by the above mentioned account to your certificate in the certificate store. You can do this by setting an ACL on the certificate by using the certificate snap-in of the mmc (Microsoft Management Console) or by typing the following command.

Copy Code
winhttpcertcfg -g -c <certLocation> -s <subjectStr> -a <accountName>

Substitute the correct values, described in the following table, for the <> parameters shown in the command.

<certLocation> | The location (path) of the certificate in the certificate store. Use the Certificate snap-in of mmc (Microsoft Management Console) to locate the certificate.
<subjectStr> | The certificate’s subject value. You can obtain this value by double-clicking the public certificate key file (.cer) file in Windows Explorer. In the Details tab of the Certificate dialog box, look for the value of the Subject field.
<accountName> | The name of the account to grant read access to. For a default Microsoft Dynamics CRM installation, the name of the account is “NetworkService”.

Configure the MSCRM_Config database

Follow these procedures to configure the Microsoft Dynamics CRM MSCRM_Config database.

Register the Microsoft Dynamics CRM PowerShell cmdlets

  1. Log on to the administrator account on your Microsoft Dynamics CRM server.

  2. In a Windows PowerShell command window, enter the following command.

    Windows PowerShell Copy Code
    Add-PSSnapin Microsoft.Crm.PowerShell

    This command adds the CRM Windows PowerShell snap-in to the current session. The snap-in is registered during installation and setup of the Microsoft Dynamics CRM server.

Set the Microsoft Dynamics CRM certificate

  1. Enter the following command in the Windows PowerShell window.

    Windows PowerShell Copy Code
    Set-CrmCertificate –CertificateType AppFabricIssuer –Name <issuerName> -StoreName My –StoreLocation LocalMachine -StoreFindType FindBySubjectDistinguishedName –DataFile <certificateFilename>

    In this command, the issuer name <issuerName> can be any name. However, you’ll be using this same issuer name when you configure Microsoft Azure Active Directory Access Control Service (ACS). The -DataFile parameter value is the file name or path of the public certificate file.

  2. List the installed certificates in the MSCRM_CONFIG database. You should see the certificate that you just added.

    Windows PowerShell Copy Code
    Get-CrmCertificate

See Also

Concepts

Walkthrough: Configure Microsoft Azure ACS for integration with Microsoft Dynamics CRM 2015

Other Resources

Azure extensions for Microsoft Dynamics CRM
Administer the deployment using Windows PowerShell
WinHttpCertCfg.exe, a Certificate Configuration Tool

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Walkthrough: Configure Microsoft Azure ACS for integration with Microsoft Dynamics CRM 2015

This walkthrough guides you through configuring the Microsoft Azure Active Directory Access Control Service (ACS) 2.0 issuer, scope, and rules to allow a listener application to read the Microsoft Dynamics CRM messages posted to the Microsoft Azure Service Bus. This walkthrough applies to integration with any deployment type of Microsoft Dynamics CRM.

Tip
The Plug-in Registration tool provided in the SDK is the recommended way to automate the configuration of ACS for basic scenarios. Refer to the section named “Configure ACS” in the topic Walkthrough: Register an Azure-aware plug-in with the CRM plug-in registration tool for instructions on how to configure ACS using the tool. For more advanced scenarios, you’ll need to use the Azure Management Portal described later in this topic. Download the Microsoft Dynamics CRM SDK package.

As a prerequisite to this walkthrough, if you’re running Microsoft Dynamics CRM 2015 (on-premises or IFD), configure Microsoft Dynamics CRM 2015 for Microsoft Azure integration. For more information, see Walkthrough: Configure CRM for integration with Microsoft Azure. Microsoft Dynamics CRM Online is pre-configured for Microsoft Azure integration.

In This Topic

Create a new service namespace

Create a service identity (issuer)

Create a rule group and a rule

Configure the scope

Create a new service namespace

If you have an existing ACS version 2 service namespace that you want to use, continue with the next section named Create a Service Identity.

Warning
Do not use the Microsoft Azure portal to create a service namespace for use with Dynamics CRM. The portal will create a SAS namespace but CRM requires an ACS namespace.

Use PowerShell commands to create a new service namespace

  1. Download and install the Microsoft Azure PowerShell module. More information: How to install and configure Azure PowerShell

  2. From the Start menu, open the Microsoft Azure PowerShell program and enter the following commands.

    Windows PowerShell Copy Code
    > Add-AzureAccount
> New-AzureSBNamespace –Name YOUR_NAMESPACE -Location "YOUR_LOCATION" -CreateACSNamespace $true
    Note
    Version 0.8.9 or later of Azure PowerShell supports the –CreateACSNamespace parameter in the New-AzureSBNamespace command. If your installed version of Azure PowerShell doesn’t support the –CreateACSNamespace parameter, install the latest version. To see the version of Azure PowerShell that you’re using, enter the command Get-Module Azure.

    Newer versions of the command may support a –NamespaceType parameter. If so, use –NamespaceType Messaging.

    After you enter Add-AzureAccount, you’ll be prompted to provide the sign-in credentials for your Azure subscription. Substitute an appropriate namespace name for YOUR_NAMESPACE and an approximate location for YOUR_LOCATION. The supported locations are: Central US, East US, East US 2, North Central US, South Central US, West US, North Europe, West Europe, East Asia, Southeast Asia, Brazil South, Japan East, and Japan West.

After you enter these commands, the namespace is created and you should see output that looks similar to the following text.

Copy Code
Name                  : mynamespace
Region                : Central US
DefaultKey            : 1eKDTIYEACFP7Geiy5QV/hqJnWHeroJyKk/PBzv42Rw=
Status                : Active
CreatedAt             : 8/25/2014 3:36:47 PM
AcsManagementEndpoint : https://mynamespace-sb.accesscontrol.windows.net/
ServiceBusEndpoint    : https://mynamespace.servicebus.windows.net/
ConnectionString      : Endpoint=sb://mynamespace.servicebus.windows.net/;SharedSecretIssuer=owner;SharedSecretValue=1
                        eKDTIYEACFP7Geiy5QV/hqJnWHeroJyKk/PBzv42Rw=

Create a service identity (issuer)

  1. If you haven’t already done so, go to the Microsoft Azure Management Portal and sign in.

  2. In the management portal, click Service Bus and then select your existing namespace in the list.

  3. Click Connection Information.

  4. At the bottom of the form, click Open ACS Management Portal.

  5. Under Service Settings, select Service identities, and then click Add.

  6. On the Add Service Identity page, enter a name for the issuer identity. This must be the same issuer name that Microsoft Dynamics CRM is configured with. You can find this issuer name in the CRM web application by choosing Settings > Customizations > Developer Resources.

  7. Select a credential type of X.509 Certificate.

  8. Browse to the location of the certificate on your local computer. Obtain the certificate by clicking the Download Certificate link on the Developer Resources page of the CRM web application.

  9. Click Save.

If you’re working with Microsoft Dynamics CRM Online and see an indication that the certificate you obtained from that server is expired, you can ignore that warning.

Create a rule group and a rule

Create a rule for the target scope that will allow Microsoft Dynamics CRM to send or “post” to the Microsoft Azure Service Bus. You do this by configuring ACS to map the input “Organization” claim from Microsoft Dynamics CRM to the output “Send” claim of the Microsoft Azure Service Bus.

First, create a rule group by following these steps.

  1. Below Trust relationships, select Rule groups.

  2. Click Add.

  3. Enter a name for the rule group and select Save.

Next, add a claim rule to the rule group.

  1. On the Edit Rule Group page, click Add.

  2. In the If section of the page, select Access Control Service.

  3. For the input claim type, select Enter type and then enter http://schemas.microsoft.com/xrm/2011/Claims/Organization.

  4. For the input claim value, select Enter value, and then enter the name of a Microsoft Dynamics CRM organization.

    For an Internet-facing or on-premises deployment, enter the unique name of the desired organization in lowercase characters. You can find this name on the Developer Resources page of the CRM web application next to the Organization Unique Name label. To navigate to that page in CRM, choose Settings > Customizations > Developer Resources.

    For a Microsoft Dynamics CRM Online deployment, specify the complete hostname part of the Web service URL. For example, given a URL of https://myorg.crm.dynamics.com/main.aspx, the host name part is myorg.crm.dynamics.com.

  5. In the Then section, for the output claim type, click Select type and then select the http://docs.oasis-open.org/wsfed/authorization/200706/claims/action item from the drop-down list.

  6. For the output claim value, select Enter value, and enter a value of Send for the output claim.

  7. Add a description of the rule (optional). For example, you could type: “Allow the Contoso organization to send to the Microsoft Azure Service Bus.”

  8. Click Save.

Configure the scope

The following steps describe how to configure the Microsoft Azure Service Bus scope of ACS for a normal mode post by Microsoft Dynamics CRM. Defining a scope provides more restricted access to the service namespace.

  1. Below Trust relationships, select Relying party applications, and then click Add.

  2. On the Add Relying Party Application page, enter a display name for the relying party. For example, enter internal. This name is the scope name.

  3. Enter the realm URI of your Microsoft Azure service endpoint and append the scope name, for example, https://crmsdkdemo.servicebus.windows.net/internal.

  4. Enter the return URL, which can be the same value as the realm URI you just entered.

  5. Select a token format of SAML 2.0.

  6. You may optionally increase the token lifetime value.

  7. Make sure the Windows Live ID identity provider is selected.

  8. Select the name of the rule group you created previously. If the check box next to your rule appears ghosted, first clear the check box that is currently checked, and then select the check box for your rule.

  9. Click Save.

Important
If you’re using federated mode, the process is similar to what is described in this walkthrough. You would add an issuer, and create a scope specific to the Uri (recommended) or a new base scope. You will need to configure both –sb and non–sb scopes. You may also need to create a token policy for the creating the issuer.

See Also

Concepts

Walkthrough: Configure CRM for integration with Microsoft Azure
Configure Azure integration with Microsoft Dynamics CRM

Other Resources

Azure extensions for Microsoft Dynamics CRM
ACS Management Portal

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Walkthrough: Register an Azure-aware plug-in with the CRM plug-in registration tool

This walkthrough demonstrates how to configure Microsoft Azure Active Directory Access Control Service (ACS) and register a service endpoint step using the Plug-in Registration tool. Once configured, Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online can post the execution context of the current operation to a Microsoft Azure solution endpoint. For this walkthrough, the step is registered to post the execution context of the CreateRequest message for an Account entity to the Microsoft Azure Service Bus.

The following prerequisites must be completed before you start this walkthrough:

  • Access to the Plug-in Registration tool. You can find the tool’s executable file in the Tools\PluginRegistration folder of the SDK. Download the Microsoft Dynamics CRM SDK package.
  • Obtain an account on Microsoft Dynamics CRM 2015 or Microsoft Dynamics CRM Online.
  • Your system user account must have the System Customizer or System Administrator role. For more information, see How role-based security can be used to control access to entities in Microsoft Dynamics CRM.
  • Have access to a Microsoft Azure platform service namespace that uses ACS version 2, to which Microsoft Dynamics CRM will post a message. For more information about creating an ACS namespace see Create a new service namespace.
  • If you are using Microsoft Dynamics CRM 2015, the server must be configured for Microsoft Azure integration according to the instructions in the topic Configure Azure integration with Microsoft Dynamics CRM.
  • There must be a listener application actively listening to the specified solution endpoint for Microsoft Dynamics CRM to successfully post to the Microsoft Azure Service Bus. For more information, see Write a listener for a Microsoft Azure solution.

Steps

This walkthrough contains the following steps:

  1. Connect to the Microsoft Dynamics CRM server

  2. Create a service endpoint configuration

  3. Configure ACS

  4. Register a service endpoint step for an event

  5. Test the endpoint registration

Connect to the Microsoft Dynamics CRM server

Follow the steps below to connect to the Microsoft Dynamics CRM server using the Plug-in Registration tool.

  1. Run the Plug-in Registration tool.

  2. Choose Create New Connection.

  3. In the Login dialog box, select the deployment type radio button corresponding to the Microsoft Dynamics CRM server you intend to register a service endpoint with. The On-premises radio button includes an IFD deployment, the Online button is for the Windows Live provider of Microsoft Dynamics CRM Online, and the Office 365 button is for the Microsoft Online Services provider of Microsoft Dynamics CRM Online.

    Login form for an online deployment Login window for an on-premises deployment

  4. If you check Always display list of available orgs, you are presented with a list of organizations that you belong to after you choose Login. This enables you to choose the organization that you want to register the service endpoint with. Otherwise, your default organization is used.

  5. Enter the indicated information about the server and login account, and then choose Login.

Create a service endpoint configuration

Follow the steps below to register a Microsoft Azure service endpoint.

  1. Select the tab of the organization that you want to register a service endpoint with.

  2. In the toolbar of the tab, choose Register and then Register New Service Endpoint.

  3. Fill out the Service Endpoint Registration dialog box with the information related to your solution as shown in the following figure and described in the table that follows. Make sure the contract you specify is the same contract used by your solution’s listener application.

    Creating a service endpoint

    UI Element description

    Name (field)

    A name for your service endpoint registration.

    Description (field)

    A description of this endpoint registration.

    Solution Namespace (field)

    The name of the solution’s service namespace.

    Path (field)

    The path of your project. For example, given a service endpoint URL of https://crmsdkdemo-sb.accesscontrol.windows.net/TwoWayService/Demo, the path is TwoWayService/Demo.

    Contract (drop-down menu)

    The endpoint contract. A listener application must use this contract to read the posted message. For more information, see Write a listener for a Microsoft Azure solution.

    Claim (drop-down menu)

    The claims to send to Microsoft Azure. Use None for the standard claim. Specify UserId or UserInfo to send additional information about the logged on user.

    Federated Mode (checkbox)

    Check this box to use federated mode.

    ID (field)

    Non-writeable field that is filled in automatically with the ID of your endpoint configuration.

    Save & Configure ACS (button)

    Saves the configuration you entered and automates the process of configuring ACS for you. Provides an interactive way to accomplish what is described in the topic Walkthrough: Configure Microsoft Azure ACS for integration with Microsoft Dynamics CRM 2015.

    Save & Verify Authentication (button)

    Saves the configuration you entered and verifies that ACS is configured correctly.

    Save (button)

    Saves the configuration you entered and closes the dialog.

  4. If you have not yet configured ACS integration with Microsoft Dynamics CRM, and you would like the Plug-in Registration tool to do the configuration for you, choose Save & Configure ACS, and then follow the instructions in the next section of this walkthrough. If you have already configured ACS, choose Save & Verify Authentication or Save and continue with the instructions in Register a service endpoint step for an event.

Configure ACS

Follow the steps below to configure Microsoft Azure Active Directory Access Control Service (ACS).

  1. After choosing Save & Configure ACS, the ACS Configuration dialog box appears. Enter the appropriate data values into the form fields as described in the following table.

    Field Name Description

    Management Key

    The management key for your solution. You can obtain this key value from the Azure Management Portal.

    Obtain a Management Key for a Service Bus Namespace

    1. Sign in to the Azure portal.

    2. In the left pane, choose Service Bus, and then select the target namespace in the list.

    3. At the bottom of the page, choose Connection Information.

    4. In the Access connection information dialog box, the Default Key is shown. This is the management key.

    Certificate File

    The public certificate file that was used to configure Microsoft Dynamics CRM for integration with Microsoft Azure.

    For Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, you can download this certificate file from the server. In the Microsoft Dynamics CRM web application choose Settings > Customizations, and then choose Developer Resources. Download and save the certificate file using the link provided below Microsoft Azure Service Bus Issuer Certificate.

    Issuer Name

    The name of the issuer. This name must be the same name that was used to configure Microsoft Dynamics CRM for Microsoft Azure integration. You can obtain the issuer name from the Developer Resources webpage mentioned in the previous description.

    For more information, see Configure Azure integration with Microsoft Dynamics CRM.

  2. Choose Configure ACS. A log of the configuration process is displayed in the output area of the form.

  3. Choose Close.

  4. Choose Save & Verify Authentication in the Service Endpoint Registration dialog box. After the verification is finished you can close the dialog boxes.

Register a service endpoint step for an event

Follow the steps below to register a step for an event on the service endpoint.

  1. Select the service endpoint that you previously registered in the tree view of the tool.

  2. Navigate to the Register menu and choose Register New Step.

  3. Fill out the Register New Step dialog box for an account create event as shown in the following figure.

    Creating a service endpoint step

  4. Choose Register New Step.

Microsoft Dynamics CRM will now post the current message containing the execution context to the service bus whenever an account is created. The post is performed asynchronously and is not executed immediately.

Test the endpoint registration

After you register the endpoint you can test it. A listener must be running or a queue available on the target endpoint for the service bus post from the plug-in to happen.

  1. Open the Microsoft Dynamics CRM web application for the same organization that you registered the service endpoint under.

  2. Choose the Create button Create button, and then choose Account.

  3. Enter an account name, for example Adventure Works Cycle, into the Account Name field, and then choose Save.

  4. Wait about 10 minutes for the Microsoft Azure Service Bus post to occur.

  5. Choose Settings > System Jobs.

  6. Open the system job that has the same name that you specified for your service endpoint. Check the status to see if the post was successful, is waiting, or failed.

You can now unregister the endpoint, if so desired, by selecting it in the tool’s tree view and choose Unregister.

See Also

Concepts

Azure integration with Microsoft Dynamics CRM
Active Directory and claims-based authentication

Other Resources

Azure extensions for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample code for Microsoft Dynamics CRM and Microsoft Azure integration

This section contains sample code for integrating Microsoft Dynamics CRM 2015 and Microsoft Azure through the Microsoft Azure Service Bus. To build the listener samples, you need to install the v1.7 or 1.8 Microsoft Azure SDK that includes the Microsoft.ServiceBus.dll assembly referenced by the samples.

In This Section

Sample: Azure aware custom plug-in

Sample: Azure aware custom workflow activity

Sample: One-way listener

Sample: Two-way listener

Sample: REST listener

Sample: Persistent queue listener

Related Sections

Azure extensions for Microsoft Dynamics CRM

Write a listener for a Microsoft Azure solution

Write plug-ins to extend business processes

Microsoft Azure Platform

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Azure aware custom plug-in
See Also Example

This is a sample custom plug-in that can post the pipeline execution context to the Microsoft Azure Service Bus.

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\Azure\Plug-ins\SandboxPlugin.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

The plug-in demonstrates how to obtain the execution context and the tracing service from the service provider parameter of the Execute method. The plug-in then posts the context to the Microsoft Azure Service Bus endpoint and writes information to the trace log to facilitate debugging.

Example

C# Copy Code
using System;
using System.Diagnostics;
using System.Threading;
using System.Runtime.Serialization;

using System.ServiceModel;
using System.ServiceModel.Channels;
using System.ServiceModel.Description;

using Microsoft.Xrm.Sdk;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// A custom plug-in that can post the execution context of the current message to the Windows
    /// Azure Service Bus. The plug-in also demonstrates tracing which assist with
    /// debugging for plug-ins that are registered in the sandbox.
    /// </summary>
    /// <remarks>This sample requires that a service endpoint be created first, and its ID passed
    /// to the plug-in constructor through the unsecure configuration parameter when the plug-in
    /// step is registered.</remarks>
    public sealed class SandboxPlugin : IPlugin
    {
        private Guid serviceEndpointId;

        /// <summary>
        /// Constructor.
        /// </summary>
        public SandboxPlugin(string config)
        {
            if (String.IsNullOrEmpty(config) || !Guid.TryParse(config, out serviceEndpointId))
            {
                throw new InvalidPluginExecutionException("Service endpoint ID should be passed as config.");
            }
        }

        public void Execute(IServiceProvider serviceProvider)
        {
            // Retrieve the execution context.
            IPluginExecutionContext context = (IPluginExecutionContext)serviceProvider.GetService(typeof(IPluginExecutionContext));

            // Extract the tracing service.
            ITracingService tracingService = (ITracingService)serviceProvider.GetService(typeof(ITracingService));
            if (tracingService == null)
                throw new InvalidPluginExecutionException("Failed to retrieve the tracing service.");

            IServiceEndpointNotificationService cloudService = (IServiceEndpointNotificationService)serviceProvider.GetService(typeof(IServiceEndpointNotificationService));
            if (cloudService == null)
                throw new InvalidPluginExecutionException("Failed to retrieve the service bus service.");

            try
            {
                tracingService.Trace("Posting the execution context.");
                string response = cloudService.Execute(new EntityReference("serviceendpoint", serviceEndpointId), context);
                if (!String.IsNullOrEmpty(response))
                {
                    tracingService.Trace("Response = {0}", response);
                }
                tracingService.Trace("Done.");
            }
            catch (Exception e)
            {
                tracingService.Trace("Exception: {0}", e.ToString());
                throw;
            }
        }
    }
}

See Also

Concepts

Write a plug-in

Other Resources

Sample code for Microsoft Dynamics CRM and Microsoft Azure integration
Sample: Azure aware custom workflow activity
IPlugin
IPluginExecutionContext
ITracingService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Azure aware custom workflow activity
See Also Example

This sample obtains the data context from the current Microsoft Dynamics CRM operation and posts it to the Microsoft Azure Service Bus.

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. This code can be found in the following location in the download package:

SampleCode\CS\Azure\AzureAwareWorkflowActivity\Activity.cs

Requirements

You must configure Microsoft Dynamics CRM to connect with Microsoft Azure before registering and executing this sample custom workflow activity. More information: Configure Azure integration with Microsoft Dynamics CRM.

Notice the “Input id” required argument in the code. When you add this activity to a workflow, you must provide the GUID of a Microsoft Azure service endpoint. More information: Create a service endpoint configuration.

When registering this custom workflow activity with Microsoft Dynamics CRM Online, you must register it in the sandbox (partial trust).

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to write a custom workflow activity that can post the data context from the current Microsoft Dynamics CRM operation to the Microsoft Azure Service Bus. The posting of the data context is done through the Execute method.

Example

C# Copy Code
// This namespace is found in the System.Activities.dll assembly.
using System.Activities;

// This namespace is found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk;

// This namespace is found in the Microsoft.Xrm.Sdk.Workflow.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk.Workflow;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// This class is able to post the execution context to the Windows Azure
    /// Service Bus.
    /// </summary>
    public class AzureAwareWorkflowActivity : CodeActivity
    {
        /// <summary>
        /// This method is called when the workflow executes.
        /// </summary>
        /// <param name="executionContext">The data for the event triggering
        /// the workflow.</param>
        protected override void Execute(CodeActivityContext executionContext)
        {
            IWorkflowContext context = executionContext.GetExtension<IWorkflowContext>();

            IServiceEndpointNotificationService endpointService =
                     executionContext.GetExtension<IServiceEndpointNotificationService>();
            endpointService.Execute(ServiceEndpoint.Get(executionContext), context);
        }

        /// <summary>
        /// Enables the service endpoint to be provided when this activity is added as a
        /// step in a workflow.
        /// </summary>
        [RequiredArgument]
        [ReferenceTarget("serviceendpoint")]
        [Input("Input id")]
        public InArgument<EntityReference> ServiceEndpoint { get; set; }
    }
}

See Also

Other Resources

Sample code for Microsoft Dynamics CRM and Microsoft Azure integration
Sample: Persistent queue listener
Custom workflow activities (workflow assemblies)
IServiceEndpointNotificationService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: One-way listener
See Also Example

This sample listener application registers a remote service plug-in that executes whenever a Microsoft Dynamics CRM message is posted to a one-way endpoint on the Microsoft Azure Service Bus. When the plug-in executes, it outputs to the console the contents of the Microsoft Dynamics CRM execution context contained in the message.

Requirements

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online. Download the Microsoft Dynamics CRM SDK package. This code can be found in the following location in the download package:

SDK\SampleCode\CS\Azure\OneWayListener\OneWayListener.cs

Demonstrates

This sample shows how to write a Microsoft Azure Service Bus listener for a one-way endpoint contract.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Text;

using Microsoft.Xrm.Sdk;
using Microsoft.ServiceBus;

namespace Microsoft.Crm.Sdk.Samples
{
    [ServiceBehavior]
    class RemoteService : IServiceEndpointPlugin
    {
        #region IServiceEndpointPlugin Member

        public void Execute(RemoteExecutionContext context)
        {
            Utility.Print(context);
        }

        #endregion
    }

    class Program
    {
        static void Main(string[] args)
        {
            ServiceBusEnvironment.SystemConnectivity.Mode = ConnectivityMode.Http;

            Console.Write("Your Service Namespace: ");
            string serviceNamespace = Console.ReadLine();
            Console.Write("Your Issuer Name: ");
            string issuerName = Console.ReadLine();

            // The issuer secret is the Service Bus namespace management key.
            Console.Write("Your Issuer Secret: ");
            string issuerSecret = Console.ReadLine();

            // Create the service URI based on the service namespace.
            Uri address = ServiceBusEnvironment.CreateServiceUri(Uri.UriSchemeHttps, serviceNamespace, "RemoteService");
            Console.WriteLine("Service address: " + address);

            // Create the credentials object for the endpoint.
            TransportClientEndpointBehavior sharedSecretServiceBusCredential = new TransportClientEndpointBehavior()
            {
                TokenProvider = TokenProvider.CreateSharedSecretTokenProvider(issuerName, issuerSecret)
            };

            // Create the binding object.
            WS2007HttpRelayBinding binding = new WS2007HttpRelayBinding();
            binding.Security.Mode = EndToEndSecurityMode.Transport;

            // Create the service host reading the configuration.
            ServiceHost host = new ServiceHost(typeof(RemoteService));
            host.AddServiceEndpoint(typeof(IServiceEndpointPlugin), binding, address);

            // Create the ServiceRegistrySettings behavior for the endpoint.
            IEndpointBehavior serviceRegistrySettings = new ServiceRegistrySettings(DiscoveryType.Public);

            // Add the Service Bus credentials to all endpoints specified in configuration.
            foreach (ServiceEndpoint endpoint in host.Description.Endpoints)
            {
                endpoint.Behaviors.Add(serviceRegistrySettings);
                endpoint.Behaviors.Add(sharedSecretServiceBusCredential);
            }

            // Open the service.
            host.Open();

            Console.WriteLine("Press [Enter] to exit");
            Console.ReadLine();

            // Close the service.
            Console.Write("Closing the service host...");
            host.Close();
            Console.WriteLine(" done.");
        }
    }

    internal static class Utility
    {
        public static void Print(RemoteExecutionContext context)
        {
            Console.WriteLine("----------");
            if (context == null)
            {
                Console.WriteLine("Context is null.");
                return;
            }

            Console.WriteLine("UserId: {0}", context.UserId);
            Console.WriteLine("OrganizationId: {0}", context.OrganizationId);
            Console.WriteLine("OrganizationName: {0}", context.OrganizationName);
            Console.WriteLine("MessageName: {0}", context.MessageName);
            Console.WriteLine("Stage: {0}", context.Stage);
            Console.WriteLine("Mode: {0}", context.Mode);
            Console.WriteLine("PrimaryEntityName: {0}", context.PrimaryEntityName);
            Console.WriteLine("SecondaryEntityName: {0}", context.SecondaryEntityName);

            Console.WriteLine("BusinessUnitId: {0}", context.BusinessUnitId);
            Console.WriteLine("CorrelationId: {0}", context.CorrelationId);
            Console.WriteLine("Depth: {0}", context.Depth);
            Console.WriteLine("InitiatingUserId: {0}", context.InitiatingUserId);
            Console.WriteLine("IsExecutingOffline: {0}", context.IsExecutingOffline);
            Console.WriteLine("IsInTransaction: {0}", context.IsInTransaction);
            Console.WriteLine("IsolationMode: {0}", context.IsolationMode);
            Console.WriteLine("Mode: {0}", context.Mode);
            Console.WriteLine("OperationCreatedOn: {0}", context.OperationCreatedOn.ToString());
            Console.WriteLine("OperationId: {0}", context.OperationId);
            Console.WriteLine("PrimaryEntityId: {0}", context.PrimaryEntityId);
            Console.WriteLine("OwningExtension LogicalName: {0}", context.OwningExtension.LogicalName);
            Console.WriteLine("OwningExtension Name: {0}", context.OwningExtension.Name);
            Console.WriteLine("OwningExtension Id: {0}", context.OwningExtension.Id);
            Console.WriteLine("SharedVariables: {0}", (context.SharedVariables == null ? "NULL" :
                SerializeParameterCollection(context.SharedVariables)));
            Console.WriteLine("InputParameters: {0}", (context.InputParameters == null ? "NULL" :
                SerializeParameterCollection(context.InputParameters)));
            Console.WriteLine("OutputParameters: {0}", (context.OutputParameters == null ? "NULL" :
                SerializeParameterCollection(context.OutputParameters)));
            Console.WriteLine("PreEntityImages: {0}", (context.PreEntityImages == null ? "NULL" :
                SerializeEntityImageCollection(context.PreEntityImages)));
            Console.WriteLine("PostEntityImages: {0}", (context.PostEntityImages == null ? "NULL" :
                SerializeEntityImageCollection(context.PostEntityImages)));
            Console.WriteLine("----------");
        }

        #region Private methods.
        private static string SerializeEntity(Entity e)
        {
            StringBuilder sb = new StringBuilder();
            sb.Append(Environment.NewLine);
            sb.Append(" LogicalName: " + e.LogicalName);
            sb.Append(Environment.NewLine);
            sb.Append(" EntityId: " + e.Id);
            sb.Append(Environment.NewLine);
            sb.Append(" Attributes: [");
            foreach (KeyValuePair<string, object> parameter in e.Attributes)
            {
                sb.Append(parameter.Key + ": " + parameter.Value + "; ");
            }
            sb.Append("]");
            return sb.ToString();
        }

        private static string SerializeParameterCollection(ParameterCollection parameterCollection)
        {
            StringBuilder sb = new StringBuilder();
            foreach (KeyValuePair<string, object> parameter in parameterCollection)
            {
                if (parameter.Value != null && parameter.Value.GetType() == typeof(Entity))
                {
                    Entity e = (Entity)parameter.Value;
                    sb.Append(parameter.Key + ": " + SerializeEntity(e));
                }
                else
                {
                    sb.Append(parameter.Key + ": " + parameter.Value + "; ");
                }
            }
            return sb.ToString();
        }

        private static string SerializeEntityImageCollection(EntityImageCollection entityImageCollection)
        {
            StringBuilder sb = new StringBuilder();
            foreach (KeyValuePair<string, Entity> entityImage in entityImageCollection)
            {
                sb.Append(Environment.NewLine);
                sb.Append(entityImage.Key + ": " + SerializeEntity(entityImage.Value));
            }
            return sb.ToString();
        }
        #endregion
    }
}

See Also

Reference

Write a One-way, Two-way, or REST Listener

Other Resources

Sample code for Microsoft Dynamics CRM and Microsoft Azure integration
Sample: Two-way listener
IServiceEndpointPlugin

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Two-way listener
See Also Example

This sample registers a remote service plug-in that executes whenever a Microsoft Dynamics CRM message is posted to a two-way endpoint on the Microsoft Azure Service Bus. When the plug-in executes, it prints to the console the contents of the Microsoft Dynamics CRM execution context contained in the message.

Requirements

This sample code is Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SDK\SampleCode\CS\Azure\TwoWayListener\TwoWayListener.cs

Demonstrates

This sample shows how to write a Microsoft Azure Service Bus Listener for a two-way endpoint contract.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ServiceModel;
using System.Text;

// This namespace is found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;

// This namespace is found in Microsoft.ServiceBus.dll assembly
// found in the Windows Azure SDK
using Microsoft.ServiceBus;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Creates a two-way endpoint listening for messages from the Windows Azure Service
    /// Bus.
    /// </summary>
    public class TwoWayListener
    {
        #region How-To Sample Code

        /// <summary>
        /// The Execute method is called when a message is posted to the Azure Service
        /// Bus.
        /// </summary>
        [ServiceBehavior]
        private class TwoWayEndpoint : ITwoWayServiceEndpointPlugin
        {
            #region ITwoWayServiceEndpointPlugin Member

            /// <summary>
            /// This method is called when a message is posted to the Azure Service Bus.
            /// </summary>
            /// <param name="context">Data for the request.</param>
            /// <returns>A 'Success' string.</returns>
            public string Execute(RemoteExecutionContext context)
            {
                Utility.Print(context);
                return "Success";
            }

            #endregion
        }

        /// <summary>
        /// Prompts for required information and hosts a service until the user ends the
        /// session.
        /// </summary>
        public void Run()
        {
            ServiceBusEnvironment.SystemConnectivity.Mode = ConnectivityMode.Http;

            Console.Write("Enter your Azure service namespace: ");
            string serviceNamespace = Console.ReadLine();

            // The service namespace issuer name to use.  If one hasn't been setup
            // explicitly it will be the default issuer name listed on the service
            // namespace.
            Console.Write("Enter your service namespace issuer name: ");
            string issuerName = Console.ReadLine();

            // Issuer secret is the Windows Azure Service Bus namespace current management key.
            Console.Write("Enter your service namespace issuer key: ");
            string issuerKey = Console.ReadLine();

            // Input the same path that was specified in the Service Bus Configuration dialog
            // when registering the Azure-aware plug-in with the Plug-in Registration tool.
            Console.Write("Enter your endpoint path: ");
            string servicePath = Console.ReadLine();

            // Leverage the Azure API to create the correct URI.
            Uri address = ServiceBusEnvironment.CreateServiceUri(
                Uri.UriSchemeHttps,
                serviceNamespace,
                servicePath);

            Console.WriteLine("The service address is: " + address);

            // Create the shared secret credentials object for the endpoint matching the
            // Azure access control services issuer
            var sharedSecretServiceBusCredential = new TransportClientEndpointBehavior()
            {
                TokenProvider = TokenProvider.CreateSharedSecretTokenProvider(issuerName, issuerKey)
            };

            // Using an HTTP binding instead of a SOAP binding for this endpoint.
            WS2007HttpRelayBinding binding = new WS2007HttpRelayBinding();
            binding.Security.Mode = EndToEndSecurityMode.Transport;

            // Create the service host for Azure to post messages to.
            ServiceHost host = new ServiceHost(typeof(TwoWayEndpoint));
            host.AddServiceEndpoint(typeof(ITwoWayServiceEndpointPlugin), binding, address);

            // Create the ServiceRegistrySettings behavior for the endpoint.
            var serviceRegistrySettings = new ServiceRegistrySettings(DiscoveryType.Public);

            // Add the service bus credentials to all endpoints specified in configuration.

            foreach (var endpoint in host.Description.Endpoints)
            {
                endpoint.Behaviors.Add(serviceRegistrySettings);
                endpoint.Behaviors.Add(sharedSecretServiceBusCredential);
            }

            // Begin listening for messages posted to Azure.
            host.Open();

            Console.WriteLine(Environment.NewLine + "Listening for messages from Azure" +
                Environment.NewLine + "Press [Enter] to exit");

            // Keep the listener open until Enter is pressed.
            Console.ReadLine();

            Console.Write("Closing the service host...");
            host.Close();
            Console.WriteLine(" done.");
        }

        /// <summary>
        /// Containts methods to display the RemoteExecutionContext provided when a
        /// message is posted to the Azure Service Bus.
        /// </summary>
        private static class Utility
        {
            /// <summary>
            /// Writes out the RemoteExecutionContext to the Console.
            /// </summary>
            /// <param name="context"></param>
            public static void Print(RemoteExecutionContext context)
            {
                Console.WriteLine("----------");
                if (context == null)
                {
                    Console.WriteLine("Context is null.");
                    return;
                }

                Console.WriteLine("UserId: {0}", context.UserId);
                Console.WriteLine("OrganizationId: {0}", context.OrganizationId);
                Console.WriteLine("OrganizationName: {0}", context.OrganizationName);
                Console.WriteLine("MessageName: {0}", context.MessageName);
                Console.WriteLine("Stage: {0}", context.Stage);
                Console.WriteLine("Mode: {0}", context.Mode);
                Console.WriteLine("PrimaryEntityName: {0}", context.PrimaryEntityName);
                Console.WriteLine("SecondaryEntityName: {0}", context.SecondaryEntityName);

                Console.WriteLine("BusinessUnitId: {0}", context.BusinessUnitId);
                Console.WriteLine("CorrelationId: {0}", context.CorrelationId);
                Console.WriteLine("Depth: {0}", context.Depth);
                Console.WriteLine("InitiatingUserId: {0}", context.InitiatingUserId);
                Console.WriteLine("IsExecutingOffline: {0}", context.IsExecutingOffline);
                Console.WriteLine("IsInTransaction: {0}", context.IsInTransaction);
                Console.WriteLine("IsolationMode: {0}", context.IsolationMode);
                Console.WriteLine("Mode: {0}", context.Mode);
                Console.WriteLine("OperationCreatedOn: {0}", context.OperationCreatedOn.ToString());
                Console.WriteLine("OperationId: {0}", context.OperationId);
                Console.WriteLine("PrimaryEntityId: {0}", context.PrimaryEntityId);
                Console.WriteLine("OwningExtension LogicalName: {0}", context.OwningExtension.LogicalName);
                Console.WriteLine("OwningExtension Name: {0}", context.OwningExtension.Name);
                Console.WriteLine("OwningExtension Id: {0}", context.OwningExtension.Id);
                Console.WriteLine("SharedVariables: {0}", (context.SharedVariables == null
                    ? "NULL" : SerializeParameterCollection(context.SharedVariables)));
                Console.WriteLine("InputParameters: {0}", (context.InputParameters == null
                    ? "NULL" : SerializeParameterCollection(context.InputParameters)));
                Console.WriteLine("OutputParameters: {0}", (context.OutputParameters == null
                    ? "NULL" : SerializeParameterCollection(context.OutputParameters)));
                Console.WriteLine("PreEntityImages: {0}", (context.PreEntityImages == null
                    ? "NULL" : SerializeEntityImageCollection(context.PreEntityImages)));
                Console.WriteLine("PostEntityImages: {0}", (context.PostEntityImages == null
                    ? "NULL" : SerializeEntityImageCollection(context.PostEntityImages)));
                Console.WriteLine("----------");
            }

            /// <summary>
            /// Writes out the attributes of an entity.
            /// </summary>
            /// <param name="e">The entity to serialize.</param>
            /// <returns>A human readable representation of the entity.</returns>
            private static string SerializeEntity(Entity e)
            {
                StringBuilder sb = new StringBuilder();
                sb.AppendFormat("{0} LogicalName: {1}{0} EntityId: {2}{0} Attributes: [",
                    Environment.NewLine,
                    e.LogicalName,
                    e.Id);
                foreach (KeyValuePair<string, object> parameter in e.Attributes)
                {
                    sb.AppendFormat("{0}: {1}; ", parameter.Key, parameter.Value);
                }
                sb.Append("]");
                return sb.ToString();
            }

            /// <summary>
            /// Flattens a collection into a delimited string.
            /// </summary>
            /// <param name="parameterCollection">The values must be of type Entity
            /// to print the values.</param>
            /// <returns>A string representing the collection passed in.</returns>
            private static string SerializeParameterCollection(ParameterCollection parameterCollection)
            {
                StringBuilder sb = new StringBuilder();
                foreach (KeyValuePair<string, object> parameter in parameterCollection)
                {
                    Entity e = parameter.Value as Entity;
                    if (e != null)
                    {
                        sb.AppendFormat("{0}: {1}", parameter.Key, SerializeEntity(e));
                    }
                    else
                    {
                        sb.AppendFormat("{0}: {1}; ", parameter.Key, parameter.Value);
                    }
                }
                return sb.ToString();
            }

            /// <summary>
            /// Flattens a collection into a delimited string.
            /// </summary>
            /// <param name="entityImageCollection">The collection to flatten.</param>
            /// <returns>A string representation of the collection.</returns>
            private static string SerializeEntityImageCollection(EntityImageCollection entityImageCollection)
            {
                StringBuilder sb = new StringBuilder();
                foreach (KeyValuePair<string, Entity> entityImage in entityImageCollection)
                {
                    sb.AppendFormat("{0}{1}: {2}", Environment.NewLine, entityImage.Key,
                        SerializeEntity(entityImage.Value));
                }
                return sb.ToString();
            }
        }

        #endregion How-To Sample Code

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        static public void Main()
        {
            try
            {
                TwoWayListener app = new TwoWayListener();
                app.Run();
            }
            catch (FaultException<ServiceEndpointFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<ServiceEndpointFault> fe = ex.InnerException
                        as FaultException<ServiceEndpointFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Inner Fault: {0}",
                            null == ex.InnerException.Message ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
    }
}

See Also

Other Resources

Azure extensions for Microsoft Dynamics CRM
Sample code for Microsoft Dynamics CRM and Microsoft Azure integration
Sample: REST listener
ITwoWayServiceEndpointPlugin

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: REST listener
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. This code can be found in the following location in the download package:

SDK\SampleCode\CS\Azure\RestListenere\RestListener.cs

Requirements

You must configure Microsoft Dynamics CRM integration with Microsoft Azure prior to registering and executing this sample activity.

Demonstrates

This sample shows how to write a Microsoft Azure Service Bus Listener for a REST endpoint contract.

This sample registers a remote service plug-in that executes whenever a Microsoft Dynamics CRM message is posted to a REST endpoint on the service bus. When the plug-in executes, it prints to the console the contents of the Microsoft Dynamics CRM execution context contained in the message.

Example

C# Copy Code
using System;
using System.Collections.Generic;
using System.ServiceModel;
using System.ServiceModel.Web;
using System.Text;

// This namespace is found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk;

// This namespace is found in Microsoft.ServiceBus.dll assembly
// found in the Windows Azure SDK
using Microsoft.ServiceBus;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Creates a REST endpoint listening for messages from the Windows Azure Service Bus.
    /// </summary>
    public class RestListener
    {
        #region How-To Sample Code

        /// <summary>
        /// The Execute method is called when a message is posted to the Azure Service
        /// Bus.
        /// </summary>
        [ServiceBehavior]
        private class RestServiceEndPoint : IWebHttpServiceEndpointPlugin
        {
            #region IRestServiceEndpointPlugin Member

            /// <summary>
            /// This method is called when a message is posted to the Azure Service Bus.
            /// </summary>
            /// <param name="context">Data for the request.</param>
            /// <returns>A 'Success' string.</returns>
            public string Execute(RemoteExecutionContext context)
            {
                Utility.Print(context);
                return "Success";
            }

            #endregion
        }

        /// <summary>
        /// Prompts for required information and hosts a service until the user ends the
        /// session.
        /// </summary>
        public void Run()
        {
            ServiceBusEnvironment.SystemConnectivity.Mode = ConnectivityMode.Http;

            Console.Write("Enter your Azure service namespace: ");
            string serviceNamespace = Console.ReadLine();

            // The service namespace issuer name to use.  If one hasn't been setup
            // explicitly it will be the default issuer name listed on the service
            // namespace.
            Console.Write("Enter your service namespace issuer name: ");
            string issuerName = Console.ReadLine();

            // Issuer secret is the Windows Azure Service Bus namespace current management key.
            Console.Write("Enter your service namespace issuer key: ");
            string issuerKey = Console.ReadLine();

            // Input the same path that was specified in the Service Bus Configuration dialog
            // when registering the Azure-aware plug-in with the Plug-in Registration tool.
            Console.Write("Enter your endpoint path: ");
            string servicePath = Console.ReadLine();

            // Leverage the Azure API to create the correct URI.
            Uri address = ServiceBusEnvironment.CreateServiceUri(
                Uri.UriSchemeHttps,
                serviceNamespace,
                servicePath);

            Console.WriteLine("The service address is: " + address);

            // Create the shared secret credentials object for the endpoint matching the
            // Azure access control services issuer
            var sharedSecretServiceBusCredential = new TransportClientEndpointBehavior()
            {
                TokenProvider = TokenProvider.CreateSharedSecretTokenProvider(issuerName, issuerKey)
            };

            // Using an HTTP binding instead of a SOAP binding for this RESTful endpoint.
            WebHttpRelayBinding binding = new WebHttpRelayBinding();
            binding.Security.Mode = EndToEndWebHttpSecurityMode.Transport;

            // Create the service host for Azure to post messages to.
            WebServiceHost host = new WebServiceHost(typeof(RestServiceEndPoint));
            host.AddServiceEndpoint(typeof(IWebHttpServiceEndpointPlugin), binding, address);

            // Create the ServiceRegistrySettings behavior for the endpoint.
            var serviceRegistrySettings = new ServiceRegistrySettings(DiscoveryType.Public);

            // Add the service bus credentials to all endpoints specified in configuration.

            foreach (var endpoint in host.Description.Endpoints)
            {
                endpoint.Behaviors.Add(serviceRegistrySettings);
                endpoint.Behaviors.Add(sharedSecretServiceBusCredential);
            }

            // Begin listening for messages posted to Azure.
            host.Open();

            Console.WriteLine(Environment.NewLine + "Listening for messages from Azure" +
                Environment.NewLine + "Press [Enter] to exit");

            // Keep the listener open until Enter is pressed.
            Console.ReadLine();

            Console.Write("Closing the service host...");
            host.Close();
            Console.WriteLine(" done.");
        }

        /// <summary>
        /// Containts methods to display the RemoteExecutionContext provided when a
        /// message is posted to the Azure Service Bus.
        /// </summary>
        private static class Utility
        {
            /// <summary>
            /// Writes out the RemoteExecutionContext to the Console.
            /// </summary>
            /// <param name="context"></param>
            public static void Print(RemoteExecutionContext context)
            {
                Console.WriteLine("----------");
                if (context == null)
                {
                    Console.WriteLine("Context is null.");
                    return;
                }

                Console.WriteLine("UserId: {0}", context.UserId);
                Console.WriteLine("OrganizationId: {0}", context.OrganizationId);
                Console.WriteLine("OrganizationName: {0}", context.OrganizationName);
                Console.WriteLine("MessageName: {0}", context.MessageName);
                Console.WriteLine("Stage: {0}", context.Stage);
                Console.WriteLine("Mode: {0}", context.Mode);
                Console.WriteLine("PrimaryEntityName: {0}", context.PrimaryEntityName);
                Console.WriteLine("SecondaryEntityName: {0}", context.SecondaryEntityName);

                Console.WriteLine("BusinessUnitId: {0}", context.BusinessUnitId);
                Console.WriteLine("CorrelationId: {0}", context.CorrelationId);
                Console.WriteLine("Depth: {0}", context.Depth);
                Console.WriteLine("InitiatingUserId: {0}", context.InitiatingUserId);
                Console.WriteLine("IsExecutingOffline: {0}", context.IsExecutingOffline);
                Console.WriteLine("IsInTransaction: {0}", context.IsInTransaction);
                Console.WriteLine("IsolationMode: {0}", context.IsolationMode);
                Console.WriteLine("Mode: {0}", context.Mode);
                Console.WriteLine("OperationCreatedOn: {0}", context.OperationCreatedOn.ToString());
                Console.WriteLine("OperationId: {0}", context.OperationId);
                Console.WriteLine("PrimaryEntityId: {0}", context.PrimaryEntityId);
                Console.WriteLine("OwningExtension LogicalName: {0}", context.OwningExtension.LogicalName);
                Console.WriteLine("OwningExtension Name: {0}", context.OwningExtension.Name);
                Console.WriteLine("OwningExtension Id: {0}", context.OwningExtension.Id);
                Console.WriteLine("SharedVariables: {0}", (context.SharedVariables == null
                    ? "NULL" : SerializeParameterCollection(context.SharedVariables)));
                Console.WriteLine("InputParameters: {0}", (context.InputParameters == null
                    ? "NULL" : SerializeParameterCollection(context.InputParameters)));
                Console.WriteLine("OutputParameters: {0}", (context.OutputParameters == null
                    ? "NULL" : SerializeParameterCollection(context.OutputParameters)));
                Console.WriteLine("PreEntityImages: {0}", (context.PreEntityImages == null
                    ? "NULL" : SerializeEntityImageCollection(context.PreEntityImages)));
                Console.WriteLine("PostEntityImages: {0}", (context.PostEntityImages == null
                    ? "NULL" : SerializeEntityImageCollection(context.PostEntityImages)));
                Console.WriteLine("----------");
            }

            /// <summary>
            /// Writes out the attributes of an entity.
            /// </summary>
            /// <param name="e">The entity to serialize.</param>
            /// <returns>A human readable representation of the entity.</returns>
            private static string SerializeEntity(Entity e)
            {
                StringBuilder sb = new StringBuilder();
                sb.AppendFormat("{0} LogicalName: {1}{0} EntityId: {2}{0} Attributes: [",
                    Environment.NewLine,
                    e.LogicalName,
                    e.Id);
                foreach (KeyValuePair<string, object> parameter in e.Attributes)
                {
                    sb.AppendFormat("{0}: {1}; ", parameter.Key, parameter.Value);
                }
                sb.Append("]");
                return sb.ToString();
            }

            /// <summary>
            /// Flattens a collection into a delimited string.
            /// </summary>
            /// <param name="parameterCollection">The values must be of type Entity
            /// to print the values.</param>
            /// <returns>A string representing the collection passed in.</returns>
            private static string SerializeParameterCollection(ParameterCollection parameterCollection)
            {
                StringBuilder sb = new StringBuilder();
                foreach (KeyValuePair<string, object> parameter in parameterCollection)
                {
                    Entity e = parameter.Value as Entity;
                    if (e != null)
                    {
                        sb.AppendFormat("{0}: {1}", parameter.Key, SerializeEntity(e));
                    }
                    else
                    {
                        sb.AppendFormat("{0}: {1}; ", parameter.Key, parameter.Value);
                    }
                }
                return sb.ToString();
            }

            /// <summary>
            /// Flattens a collection into a delimited string.
            /// </summary>
            /// <param name="entityImageCollection">The collection to flatten.</param>
            /// <returns>A string representation of the collection.</returns>
            private static string SerializeEntityImageCollection(EntityImageCollection entityImageCollection)
            {
                StringBuilder sb = new StringBuilder();
                foreach (KeyValuePair<string, Entity> entityImage in entityImageCollection)
                {
                    sb.AppendFormat("{0}{1}: {2}", Environment.NewLine, entityImage.Key,
                        SerializeEntity(entityImage.Value));
                }
                return sb.ToString();
            }
        }

        #endregion How-To Sample Code

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        static public void Main()
        {
            try
            {
                RestListener app = new RestListener();
                app.Run();
            }
            catch (FaultException<ServiceEndpointFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<ServiceEndpointFault> fe = ex.InnerException
                        as FaultException<ServiceEndpointFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Inner Fault: {0}",
                            null == ex.InnerException.Message ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
    }
}

See Also

Concepts

Configure Azure integration with Microsoft Dynamics CRM

Other Resources

Sample code for Microsoft Dynamics CRM and Microsoft Azure integration
Sample: Persistent queue listener
IWebHttpServiceEndpointPlugin

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Persistent queue listener
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. This code can be found in the following location in the download package:

SampleCode\CS\Azure\PersistentQueueListener\PersistentQueueListener.cs

Requirements

This sample code requires the following additional Microsoft Visual Studio project reference: Microsoft.ServiceBus. The Microsoft.ServiceBus.dll assembly can be found in the Microsoft Azure SDK.

Demonstrates

This sample shows how to write a Microsoft Azure Service Bus listener application for a persistent queue endpoint contract.

The listener waits for a Microsoft Dynamics CRM message to be posted to the service bus and to be available in the endpoint queue. When a message is available in the queue, the listener reads the message, prints the Microsoft Dynamics CRM execution context contained in the message to the console, and deletes the message from the queue.

Example

C# Copy Code
using System;
using System.ServiceModel;
using System.ServiceModel.Channels;
using System.Collections.Generic;
using System.Text;

using Microsoft.ServiceBus;
using Microsoft.ServiceBus.Messaging;
using Microsoft.Xrm.Sdk;

namespace Microsoft.Crm.Sdk.Samples
{
    class Program
    {
        public static void Main(string[] args)
        {
            Consumer consumer = new Consumer();

            consumer.CreateQueueClient();
            consumer.ProcessMessages();
            consumer.DeleteQueue();
        }
    }

    internal class Consumer
    {
        private const String MyQueuePath = "MyQueue";
        private QueueDescription queueDescription;
        private QueueClient queueClient;
        private Uri namespaceUri;
        private TransportClientEndpointBehavior credential;

        public Consumer()
        {
            Console.Write("Your Service Namespace: ");
            string serviceNamespace = Console.ReadLine();
            Console.Write("Your Issuer Name: ");
            string issuerName = Console.ReadLine();
            Console.Write("Your Issuer Secret: ");
            string issuerSecret = Console.ReadLine();

            // Configure queue settings.
            this.queueDescription = new QueueDescription(MyQueuePath);
            // Setting Max Size and TTL for demonstration purpose
            // but can be changed per user discretion to suite their system needs.
            // Refer service bus documentation to understand the limitations.
            // Setting Queue max size to 1GB where as default Max Size is 5GB.
            this.queueDescription.MaxSizeInMegabytes = 1024;
            // Setting message TTL to 5 days where as default TTL is 14 days.
            this.queueDescription.DefaultMessageTimeToLive = TimeSpan.FromDays(5);

            // Create management credentials.
            this.credential = new TransportClientEndpointBehavior()
            {
                TokenProvider = TokenProvider.CreateSharedSecretTokenProvider(issuerName, issuerSecret)
            };

            // Create the URI for the queue.
            this.namespaceUri = ServiceBusEnvironment.CreateServiceUri("sb", serviceNamespace, String.Empty);
            Console.WriteLine("Service Bus Namespace Uri address '{0}'", this.namespaceUri.AbsoluteUri);
        }

        public void CreateQueueClient()
        {
            // get the existing queue or create a new queue if it doesn't exist.
            this.queueClient = GetOrCreateQueue(namespaceUri, this.credential.TokenProvider);
        }

        public void ProcessMessages()
        {
            // Get receive mode (PeekLock or ReceiveAndDelete) from queueClient.
            ReceiveMode mode = this.queueClient.Mode;
            while (true)
            {
                Console.Write("Press [Enter] to retrieve a message from the queue (type quit to exit): ");
                string line = Console.ReadLine();

                if (!string.IsNullOrEmpty(line) && string.Equals(line, "quit", StringComparison.OrdinalIgnoreCase))
                {
                    break;
                }

                // Retrieve a message from the queue.
                Console.WriteLine("Waiting for a message from the queue... ");
                BrokeredMessage message;
                try
                {
                    message = this.queueClient.Receive();
                    // Check if the message received.
                    if (message != null)
                    {
                        try
                        {
                            // Verify EntityLogicalName and RequestName message properties
                            // to only process specific message sent from Microsoft Dynamics CRM.
                            string keyRoot = "http://schemas.microsoft.com/xrm/2011/Claims/";
                            string entityLogicalNameKey = "EntityLogicalName";
                            string requestNameKey = "RequestName";
                            object entityLogicalNameValue;
                            object requestNameValue;
                            message.Properties.TryGetValue(keyRoot + entityLogicalNameKey, out entityLogicalNameValue);
                            message.Properties.TryGetValue(keyRoot + requestNameKey, out requestNameValue);

                            // Filter message with specific message properties. i.e. EntityLogicalName=letter and RequestName=Create
                            if (entityLogicalNameValue != null && requestNameValue != null)
                            {
                                if (entityLogicalNameValue.ToString() == "letter" && requestNameValue.ToString() == "Create")
                                {
                                    Console.WriteLine("--------------------------------");
                                    Console.WriteLine(string.Format("Message received: Id = {0}", message.MessageId));
                                    // Display message properties that are set on the brokered message.
                                    Utility.PrintMessageProperties(message.Properties);
                                    // Display body details.
                                    Utility.Print(message.GetBody<RemoteExecutionContext>());
                                    Console.WriteLine("--------------------------------");
                                }
                                else
                                {
                                    continue;
                                }
                            }
                            else
                            {
                                continue;
                            }
                            // If receive mode is PeekLock then set message complete to remove message from queue.
                            if (mode == ReceiveMode.PeekLock)
                            {
                                message.Complete();
                            }
                        }
                        catch (System.Exception ex)
                        {
                            // Indicate a problem, unlock message in queue.
                            if (mode == ReceiveMode.PeekLock)
                            {
                                message.Abandon();
                            }
                            Console.WriteLine(ex.Message);
                            continue;
                        }
                    }
                    else
                    {
                        break;
                    }
                }
                catch (System.TimeoutException e)
                {
                    Console.WriteLine(e.Message);
                    continue;
                }
                catch (System.ServiceModel.FaultException e)
                {
                    Console.WriteLine(e.Message);
                    continue;
                }
            }
        }

        public void DeleteQueue()
        {
            DeleteQueueInternal(namespaceUri, MyQueuePath, credential.TokenProvider);
        }

        private void DeleteQueueInternal(Uri address, string path, TokenProvider tokenProvider)
        {
            var settings = new NamespaceManagerSettings() { TokenProvider = tokenProvider };
            var namespaceClient = new ServiceBus.NamespaceManager(address, settings);
            try
            {
                namespaceClient.DeleteQueue(path);
                Console.WriteLine("Queue deleted successfully.");
            }
            catch (FaultException e)
            {
                Console.WriteLine("Exception when deleting queue.. {0}", e);
            }
        }

        private QueueClient GetOrCreateQueue(Uri namespaceUri, TokenProvider tokenProvider)
        {
            NamespaceManager namespaceClient = new NamespaceManager(namespaceUri, tokenProvider);

            // Create queue if not already exist.
            if (!namespaceClient.QueueExists(MyQueuePath))
            {
                namespaceClient.CreateQueue(this.queueDescription);
                Console.WriteLine("Queue created.");
            }
            else
            {
                Console.WriteLine("Queue already exists.");
            }

            MessagingFactory factory = MessagingFactory.Create(namespaceUri, tokenProvider);
            Console.WriteLine("Creating queue client...");
            return factory.CreateQueueClient(MyQueuePath, ReceiveMode.PeekLock);
        }
    }

    internal static class Utility
    {
        public static void Print(RemoteExecutionContext context)
        {
            if (context == null)
            {
                Console.WriteLine("Context is null.");
                return;
            }

            Console.WriteLine("UserId: {0}", context.UserId);
            Console.WriteLine("OrganizationId: {0}", context.OrganizationId);
            Console.WriteLine("OrganizationName: {0}", context.OrganizationName);
            Console.WriteLine("MessageName: {0}", context.MessageName);
            Console.WriteLine("Stage: {0}", context.Stage);
            Console.WriteLine("Mode: {0}", context.Mode);
            Console.WriteLine("PrimaryEntityName: {0}", context.PrimaryEntityName);
            Console.WriteLine("SecondaryEntityName: {0}", context.SecondaryEntityName);

            Console.WriteLine("BusinessUnitId: {0}", context.BusinessUnitId);
            Console.WriteLine("CorrelationId: {0}", context.CorrelationId);
            Console.WriteLine("Depth: {0}", context.Depth);
            Console.WriteLine("InitiatingUserId: {0}", context.InitiatingUserId);
            Console.WriteLine("IsExecutingOffline: {0}", context.IsExecutingOffline);
            Console.WriteLine("IsInTransaction: {0}", context.IsInTransaction);
            Console.WriteLine("IsolationMode: {0}", context.IsolationMode);
            Console.WriteLine("Mode: {0}", context.Mode);
            Console.WriteLine("OperationCreatedOn: {0}", context.OperationCreatedOn.ToString());
            Console.WriteLine("OperationId: {0}", context.OperationId);
            Console.WriteLine("PrimaryEntityId: {0}", context.PrimaryEntityId);
            Console.WriteLine("OwningExtension LogicalName: {0}", context.OwningExtension.LogicalName);
            Console.WriteLine("OwningExtension Name: {0}", context.OwningExtension.Name);
            Console.WriteLine("OwningExtension Id: {0}", context.OwningExtension.Id);
            Console.WriteLine("SharedVariables: {0}", (context.SharedVariables == null ? "NULL" :
                SerializeParameterCollection(context.SharedVariables)));
            Console.WriteLine("InputParameters: {0}", (context.InputParameters == null ? "NULL" :
                SerializeParameterCollection(context.InputParameters)));
            Console.WriteLine("OutputParameters: {0}", (context.OutputParameters == null ? "NULL" :
                SerializeParameterCollection(context.OutputParameters)));
            Console.WriteLine("PreEntityImages: {0}", (context.PreEntityImages == null ? "NULL" :
                SerializeEntityImageCollection(context.PreEntityImages)));
            Console.WriteLine("PostEntityImages: {0}", (context.PostEntityImages == null ? "NULL" :
                SerializeEntityImageCollection(context.PostEntityImages)));
        }

        #region Private methods.
        private static string SerializeEntity(Entity e)
        {
            StringBuilder sb = new StringBuilder();
            sb.Append(Environment.NewLine);
            sb.Append(" LogicalName: " + e.LogicalName);
            sb.Append(Environment.NewLine);
            sb.Append(" EntityId: " + e.Id);
            sb.Append(Environment.NewLine);
            sb.Append(" Attributes: [");
            foreach (KeyValuePair<string, object> parameter in e.Attributes)
            {
                sb.Append(parameter.Key + ": " + parameter.Value + "; ");
            }
            sb.Append("]");
            return sb.ToString();
        }

        private static string SerializeParameterCollection(ParameterCollection parameterCollection)
        {
            StringBuilder sb = new StringBuilder();
            foreach (KeyValuePair<string, object> parameter in parameterCollection)
            {
                if (parameter.Value != null && parameter.Value.GetType() == typeof(Entity))
                {
                    Entity e = (Entity)parameter.Value;
                    sb.Append(parameter.Key + ": " + SerializeEntity(e));
                }
                else
                {
                    sb.Append(parameter.Key + ": " + parameter.Value + "; ");
                }
            }
            return sb.ToString();
        }
        private static string SerializeEntityImageCollection(EntityImageCollection entityImageCollection)
        {
            StringBuilder sb = new StringBuilder();
            foreach (KeyValuePair<string, Entity> entityImage in entityImageCollection)
            {
                sb.Append(Environment.NewLine);
                sb.Append(entityImage.Key + ": " + SerializeEntity(entityImage.Value));
            }
            return sb.ToString();
        }
        #endregion

        internal static void PrintMessageProperties(IDictionary<string, object> iDictionary)
        {
            if (iDictionary.Count == 0)
            {
                Console.WriteLine("No Message properties found.");
                return;
            }
            foreach (var item in iDictionary)
            {
                String key = (item.Key != null) ? item.Key.ToString() : "";
                String value = (item.Value != null)? item.Value.ToString() : "";
                Console.WriteLine( key + " " + value);
            }
        }
    }
}

See Also

Concepts

Write a listener for a Microsoft Azure solution

Other Resources

Sample code for Microsoft Dynamics CRM and Microsoft Azure integration

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Disaster recovery in Microsoft Dynamics CRM Online

Disaster recovery is a feature of Microsoft Dynamics CRM Online to recover from a planned or unplanned service interruption. An example of a planned service interruption is regular and periodic datacenter system maintenance. An example of an unplanned service interruption is a failure of a key computer system or network component in a data center. For either case, you temporarily lose access to your organization's data and the Microsoft Dynamics CRM Online services.

Planned service interruptions are preceded by a public notice in the web application or CRM for Outlook identifying the date and time of the service maintenance so that businesses can plan for the interruption in accessing their organization's data. Unplanned service interruptions result in a notice that the organization is currently undergoing unplanned maintenance.

When a failure or a disaster occurs, well-defined processes are applied by the administrators of the Microsoft Dynamics CRM Online data center to recover from a service interruption. The processes and software to recover from these service interruptions is known as disaster recovery failover. Your Microsoft Dynamics CRM Online datacenter maintains a duplicate and synchronized (alternate) copy of your organization's data on a different server. Should a disaster occur in the data center where you no longer have access to your data, the administrators monitoring the datacenter can switch access from your primary organization to this alternate organization, thereby minimizing the service interruption. When the failure has been corrected, service access to your primary organization can be restored.

This recovery happens in the datacenter and is handled transparently to you and your .NET managed applications. However, there is one issue that application developers must deal with: data loss. When the Microsoft Dynamics CRM Online services encounter a failure, data change operations that your application performs using web service calls may not complete successfully. This can result in data loss. The following sections in this topic describe how you can write your applications to deal with data loss issues.

In This Topic

Develop a .NET Managed Code application for failover recovery

Develop a Non-.NET application for failover recovery

Best practices

Develop a .NET Managed Code application for failover recovery

Developers can write their applications to account for data center failure and recovery by implementing code to check for and handle a failover event gracefully. An application can subscribe to the EndpointSwitched and EndpointSwitchRequired notification events. These events are also available in derived classes like OrganizationServiceProxy. For more information about these events, see the ServiceProxy`1 class documentation.

Your application can check the EndpointAutoSwitchEnabled property to determine whether automatic failover behavior is enabled for an organization. This property is set to true for organizations where a failover alternate endpoint is available. No other special code is required in your application other than optionally subscribing to the notification events when EndpointAutoSwitchEnabled is true.

Typical application logic flow for a disaster event and failover

  1. A disaster event occurs in the Microsoft Dynamics CRM Online datacenter.

  2. Your application makes a service call through a service proxy class object: OrganizationServiceProxy, DiscoveryServiceProxy.

  3. The service proxy class object receives an exception after attempting the service call.

  4. If the target organization of the call is not enabled for failover, go to step 9.

  5. The EndpointSwitchRequired event is thrown.

  6. The EndpointSwitched event is thrown.

  7. The service proxy class object automatically tries the call again.

  8. If the second call was successful, the application continues normally.

  9. If the call was not successful, an exception is returned to the application: EndpointNotFoundException, TimeoutException, FaultException<OrganizationServiceFault> where fault.Detail.ErrorCode == -2147176347.

You may want to implement code that checks for potential data loss after endpoint switch events are received and handle it appropriately.

After the disaster affecting the primary organization endpoint has been corrected in the datacenter, a fail back from the alternate endpoint URL to the primary endpoint URL for the organization occurs as part of planned organization maintenance.

Develop a Non-.NET application for failover recovery

Applications that do not link to the Microsoft Dynamics CRM SDK assemblies, for example Java applications that access the web services by using SOAP or ODATA, can try accessing the failover URL for the target organization. The URL for a failover alternate organization is the same as the URL for the primary organization with “--S” added to the organization name. For example, an organization named Contoso would have the primary and alternate URLs shown in the following table.

Primary Organization URL | Alternate Organization URL
https://CONTOSO.API.CRM.DYNAMICS.COM | https://CONTOSO--S.API.CRM.DYNAMICS.COM

For non.NET-connected applications, there is no notification event to which your application can subscribe to receive notice of a service interruption and failover. Your application will begin to receive a variety of fault exceptions, as listed previously, during the service interruption. At that point, the application can attempt to connect to the failover alternate URL for the target organization. After the disaster has been corrected, a fail back to the primary URL for the organization occurs as part of planned organization maintenance.

Best practices

The following list describes some best practices you can implement in your applications to make them more robust when they deal with service interruptions and failure recovery.

  • Write application code to check the EndpointAutoSwitchEnabled property value to determine whether it is set to true. If true, consider subscribing to the EndpointSwitched and EndpointSwitchRequired notification events.
  • If your application works with critical data where any data loss is disastrous, write event handler code or catch the indicated exceptions to handle the disaster event and failover as appropriate for business needs.

See Also

Other Resources

Advanced development
Administer the deployment using the deployment web service

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Administer the deployment using the deployment web service

For an on-premises deployment, you can use the deployment web service (deployment service) as a programmatic alternative to using the Deployment Manager. Note that the caller must be a Deployment Administrator to use this web service. This allows you to manage organizations, servers, and licenses for deployments of Microsoft Dynamics CRM 2015.

In Microsoft Dynamics CRM 2015, use of the advanced settings (UpdateAdvancedSettingsRequest has been changed to internal use only. The relevant settings have all been incorporated into settings classes that you can update by using standard deployment entities or by using the Deployment Configuration Tool when it becomes available. You can find information about these classes in Deployment entities and deployment configuration settings. These can also be retrieved and updated using Windows PowerShell. More information: Administer the deployment using Windows PowerShell.

You can create solutions to do the following:

  • Manipulate the organization entity to create, import, upgrade, enable, or disable organizations.
  • Retrieve and view Microsoft Dynamics CRM license information for a deployment.
  • Update deployment configuration settings.
  • Add or remove deployment administrators.
  • Enable, disable, or delete servers.
  • Enumerate and change the state of servers in the deployment.

The deployment service works with Windows integrated authentication (Active Directory) only.

In This Section

Introduction to the deployment web service

Deployment web service messages

Deployment entities and deployment configuration settings

Sample: Use deployment service messages

Related Sections

Asynchronous service in Microsoft Dynamics CRM

Azure extensions for Microsoft Dynamics CRM

Disaster recovery in Microsoft Dynamics CRM Online

Custom email providers for Microsoft Dynamics CRM

Write Java and other non-.NET client applications

Sample data for Microsoft Dynamics CRM

Administer the deployment using Windows PowerShell

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Introduction to the deployment web service

The deployment service allows you to create solutions to take advantage of support for multiple organizations—also called multi-tenant support. Microsoft Dynamics CRM enables you to host multiple customer organizations within a single deployment. This capability benefits hosted solutions or businesses that require a separation of data inside the organization. Because using the deployment service requires access to the CRM server, it can only be used for Microsoft Dynamics CRM 2015 on-premises deployments.

With multiple organization support, the Microsoft Dynamics CRM web application and web services support the storage and retrieval of data across multiple business organizations while maintaining the security and privacy of each individual organization. A single Microsoft Dynamics CRM configuration database stores the metadata and location information for all customer organizations. However, each customer organization has its own database on a server running Microsoft SQL Server. For more information about the entities and configuration settings controlled by the deployment service, see Deployment entities and deployment configuration settings.

Microsoft Dynamics CRM 2015 does not support a backward compatible end-point for the deployment service so any code written for the Microsoft Dynamics CRM 4.0 deployment service must be updated and recompiled with the new assembly.

Add the deployment service to your project

You can use the deployment service by adding a reference to the assembly Microsoft.Xrm.Sdk.Deployment.dll, which you can find in the SDK\bin folder. Alternatively, you can add the following service reference to your solution.

Copy Code
http://myservername/xrmdeployment/2011/deployment.svc
Copy Code
svcutil.exe http:// myservername/XRMDeployment/2011/Deployment.svc?wsdl

This will generate a configuration file and a code file that contains the client class. Add these two files to your client application and use the generated client class to call the service.

Deployment service installation

To execute calls against Microsoft Dynamics CRM deployment entities, the Deployment Service server role must be correctly installed on a Microsoft Dynamics CRM server. Make sure that the following criteria are met in your Deployment Service installation:

  • In order to use organization operations such as create or upgrade, you must install the Deployment Service server role using a domain user. The domain user account must have local admin and system admin rights on the SQL Server on which organization databases will be hosted.
  • The Deployment Service should be run with a different service identity than the other Microsoft Dynamics CRM services and application server. If you are using Network Service, the server role should be installed on a separate server by itself without any other Microsoft Dynamics CRM server roles installed. Installing the Deployment Service role alongside other server roles can cause security risks because both servers run under the Network Service account. If you use the Network service account you will not be able to perform organization operations using Windows PowerShell or the deployment web service.

For more information about installation of the deployment service, see the Microsoft Dynamics CRM server roles.

Microsoft Dynamics CRM has two primary server components: the Microsoft Dynamics CRM application server and the Microsoft Dynamics CRM Server. Each includes a separate group of server roles that are installed when Setup is run. The Deployment Service role is automatically installed when using the Setup wizard to install the Microsoft Dynamics CRM platform server.

Deployment service authentication and impersonation

Deployment Service authentication is handled through Active Directory, which is also known as Windows integrated authentication. You can also use impersonation, which enables you to call web service methods on behalf of another authenticated user to provide a desired feature or service. To call the deployment web service, you must be a Microsoft Dynamics CRM Deployment Administrator. For more information, see Add a deployment administrator.

The following sample shows how to use the ProxyClientHelper class to authenticate and use the deployment service using default credentials.

C# Copy Code
DeploymentServiceClient service = Microsoft.Xrm.Sdk.Deployment.Proxy.ProxyClientHelper.CreateClient(new Uri("http://MyServerName/XRMDeployment/2011/Deployment.svc"));
RetrieveAllRequest request = new RetrieveAllRequest()
{
   EntityType = DeploymentEntityType.DefaultOrganization};
   RetrieveAllResponse response = (RetrieveAllResponse) service.Execute(request);
}

Microsoft Dynamics CRM web services can be called by various clients and services on behalf of a Microsoft Dynamics CRM user. Every call must be an authenticated call. Impersonation is used to execute a call on behalf of an authenticated Microsoft Dynamics CRM user. When using impersonation, you avoid dealing with authentication and authorization issues in the web service (ASP.NET) code. Instead, you rely on Internet Information Services (IIS) to authenticate the user and pass an authenticated token to the web service. If the user cannot be authenticated, IIS passes an unauthenticated token.

The following sample shows how to use impersonation with the deployment service.

C# Copy Code
DeploymentServiceClient service = Microsoft.Xrm.Sdk.Deployment.Proxy.ProxyClientHelper.CreateClient(new Uri("http://myservername/XRMDeployment/2011/Deployment.svc"));
service.ClientCredentials.Windows.ClientCredential = new NetworkCredential("administrator", "myp@ssword!", "myservernamedom");
RetrieveAllRequest request = new RetrieveAllRequest()
{
   EntityType = DeploymentEntityType.DefaultOrganization};
   RetrieveAllResponse response = (RetrieveAllResponse) service.Execute(request);
}

Deployment service capabilities

The deployment service follows a development model similar to the main Microsoft Dynamics CRM web service. There are entities, methods and messages that you use to interact with the deployment service. For more information about the main Microsoft Dynamics CRM web service, see Use Microsoft Dynamics CRM services in code.

There are two types of entities for the deployment service: deployment entities and deployment configuration settings. Both are accessed by the same set of methods. For more information about these entities, see Deployment entities and deployment configuration settings.

In addition to the core deployment entities, the deployment service provides the ability to read and edit advanced settings driven by metadata. These advanced settings provide access to information stored in the configuration database.

The deployment service supports both synchronous and asynchronous messages for the Execute method. For more information, see Deployment web service messages.

The following table lists the methods available in the deployment service.

Method name | Description
IDeploymentService.Delete | Deletes a record from a deployment entity.
IDeploymentService.Execute | Executes a request for the deployment service. For more information, see Deployment web service messages.
IDeploymentService.Retrieve | Retrieves a record from a deployment entity or deployment configuration settings.
IDeploymentService.RetrieveAll | Retrieves all records for a deployment entity or deployment configuration settings.
IDeploymentService.Update | Updates a record from a deployment entity or deployment configuration settings.

See Also

Concepts

Deployment entities and deployment configuration settings
Deployment web service messages

Other Resources

Administer the deployment using the deployment web service
IDeploymentService
Microsoft.Xrm.Sdk.Deployment.Proxy
ProxyClientHelper

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Deployment web service messages

You can use deployment server messages to retrieve and update deployment settings. Most of these messages use the classes described in Deployment entities and deployment configuration settings. The base class for all messages is DeploymentServiceRequest.

In This Topic

Synchronous messages

Asynchronous messages

Synchronous messages

The following table lists the synchronous messages supported by the deployment service, to be used with the IDeploymentService. Execute method. Synchronous requests will be committed within a 60-second timeout.

Request class name | Description
AddDeploymentAdministratorRequest | Adds a deployment service administrator account. The user must already exist in Active Directory.
DeferredOperationRequest | Base class for asynchronous operations. See Asynchronous Messages.
DeleteRequest | Deletes a deployment or configuration settings record. You can also call the Delete method.
RetrieveAdvancedSettingsRequest | For internal use only. Retrieves values from the configuration database.
RetrieveAllRequest | Retrieves all records for the specified deployment or configuration settings entity. You can also call the RetrieveAll method.
RetrieveRequest | Retrieves the specified deployment or configuration settings record by name or by ID. You can also call the Retrieve method.
TrackLicenseRequest | Tracks client access license (CAL) usage and server license usage.
UpdateAdvancedSettingsRequest | For internal use only. Updates a writable setting in the configuration database.
UpdateProductKeyRequest | Updates the product key.
UpdateRequest | Updates a deployment or configuration settings record. You can also call the Update method.

Asynchronous messages

Asynchronous requests return an ID that can be used to retrieve current state and show status. For example, in a create organization request a retrieve would show the org status as ”pending.” If you make multiple asynchronous requests they will be queued. Each request in the queue is processed serially.

The following table lists the asynchronous messages supported by the deployment service.

Request class name | Description
BeginCreateOrganizationRequest | Initiates the creation of a new organization. This is an asynchronous request.
BeginImportOrganizationRequest | Initiates the import of an organization. This is an asynchronous request.
BeginUpdateOrganizationRequest | Initiates the update of a Microsoft Dynamics CRM Online organization. This is an asynchronous request.
BeginUpgradeOrganizationRequest | Initiates the upgrade of an on-premises Microsoft Dynamics CRM organization. This is an asynchronous request.

Before you begin to create or import an organization, check to see if the unique name for the organization is not on the reserved names list defined in the configuration database. For a partial list, see UniqueName.

See Also

Concepts

Introduction to the deployment web service
Deployment entities and deployment configuration settings

Other Resources

Administer the deployment using the deployment web service
IDeploymentService
DeploymentServiceRequest
DeploymentServiceResponse

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Deployment entities and deployment configuration settings

There are two types of settings managed by the deployment web service: deployment entities (derived from DeploymentEntity) and deployment configuration settings (derived from DeploymentConfigSettings). You can use the RetrieveAllRequest, RetrieveRequest, UpdateRequest and DeleteRequest messages to interact with these entity types.

Alternatively, you can use Windows PowerShell commands to interact with these entity types. Each one has its own command such as Get-CrmOrganization. For more information, see Administer the deployment using Windows PowerShell.

When you retrieve, delete or update a deployment record, you specify the type of deployment entity you are working with using the DeploymentEntityType enumeration. These types correspond to the classes shown below.

In This Topic

Deployment entities

Deployment configuration settings

Deployment web service object model

Deployment entities

The following table lists the deployment entity classes.

Entity class name | Description
Certificate | Contains information about a certificate.
DeploymentAdministrator | Contains information about the administrator for a Microsoft Dynamics CRM deployment.
LicenseProperties | Contains information about a license.
Organization | Contains information about the organizations in a deployment.
Server | Contains information about the servers for a deployment.

Deployment configuration settings

The following table lists the configuration settings classes.

Configuration settings class name | Description
AsyncSettings | Contains settings values regarding asynchronous jobs and can be used to tune the asynchronous processing service.
ClaimsSettingsBase | Base class for ClaimsSettings and OAuthClaimsSettings.
ClaimsSettings | Contains settings for claims authentication.
CustomCodeSettings | Contains settings that pertain to running custom code.
DashboardSettings | Contains settings for dashboards.
DupSettings | Contains settings that tune the operation of duplicate detection.
EtmSettings | Contains settings for enterprise transaction management that can be used to throttle CRM for Outlook.
IfdSettings | Contains settings for Internet facing deployments.
ImportSettings | Contains settings that tune a data import operation.
MarketplaceSettings | Contains settings for the Marketplace.
MonitoringSettings | Contains monitoring settings.
MultiEntityQuickFindSettings | Contains settings for multi-entity quick find (finds records of different types).
OAuthClaimsSettings | Contains settings for OAuth.
QuickFindSettings | Contains settings for quick find (finds records of one type).
ServerSideSyncACTSettings | Contains settings for controlling server-side synchronization for accounts, contacts, and tasks.
ServerSideSyncEmailSettings | Contains settings for controlling server-side synchronization for emails.
ServerSideSyncQueueSettings | Contains settings for controlling server-side synchronization for queues.
SqmSettings | Contains SQM settings.
TeamSettings | Contains settings for auto created (system-managed) access teams.
ThrottleSettings | Contains settings that can be used to throttle CRM for Outlook.
TraceSettings | Contains settings that tune the amount of trace information generated.
WebAddressSettings | Contains deployment root domain address values.
WorkflowSettings | Contains deployment wide workflow settings.
YammerSettings | Contains settings for Yammer.

Deployment web service object model

The following shows the class diagram for the deployment service entities and settings entities.

Deployment web service object model

See Also

Concepts

Introduction to the deployment web service
Deployment web service messages

Other Resources

Administer the deployment using the deployment web service

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Use deployment service messages
See Also Example

Requirements

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\DeploymentService\UseDeploymentServiceMessages.cs

Demonstrates

The following sample shows how to access and call the deployment service using the IDeploymentService. Execute method. To add the service to your project, see Introduction to the deployment web service.

Example

C# Copy Code
using System;
using System.Net;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk.Query;
using Microsoft.Xrm.Sdk.Client;

// These namespaces are found in the Microsoft.Xrm.Sdk.Deployment.dll assembly
// located in the SDK\bin folder of the SDK download.
using Microsoft.Xrm.Sdk.Deployment;
using Deployment = Microsoft.Xrm.Sdk.Deployment;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Demonstrates how to retrieve deployment information programmatically.</summary>
    /// <remarks>
    /// NOTE: The deployment service only supports Active Directory, so the user running
    /// this sample must have a valid Active Directory account.
    /// </remarks>
    public class UseDeploymentServiceMessages
    {
        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How To Sample Code
        /// <summary>
        /// This method first connects to the Deployment service. Then,
        /// a variety of messages are used to retrieve deployment information.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">When True, the user will be prompted to delete
        /// all created entities.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Instantiate DeploymentServiceClient for calling the service.
                    DeploymentServiceClient serviceClient =
                        Deployment.Proxy.ProxyClientHelper.CreateClient(
                        new Uri(serverConfig.DiscoveryUri.ToString()
                            .Replace("Services", "Deployment")
                            .Replace("Discovery", "Deployment")));

                    // Setting credentials from the current security context.
                    if (serverConfig.Credentials == null)
                    {
                        serviceClient.ClientCredentials.Windows.ClientCredential =
                            CredentialCache.DefaultNetworkCredentials;
                    }
                    else
                    {
                        serviceClient.ClientCredentials.Windows.ClientCredential =
                            serverConfig.Credentials.Windows.ClientCredential;
                    }

                    // Retrieve all deployed instances of Microsoft Dynamics CRM.
                    var organizations =
                        serviceClient.RetrieveAll(DeploymentEntityType.Organization);

                    // Print list of all retrieved organizations.
                    Console.WriteLine("Organizations in your deployment");
                    Console.WriteLine("================================");
                    foreach (var organization in organizations)
                    {
                        Console.WriteLine(organization.Name);
                    }
                    Console.WriteLine("<End of Listing>");
                    Console.WriteLine();

                    // Retrieve details of first organization from previous call.
                    Deployment.Organization deployment =
                        (Deployment.Organization)serviceClient.Retrieve(
                            DeploymentEntityType.Organization,
                            organizations[0]);

                    // Print out retrieved details about your organization.
                    Console.WriteLine(String.Format(
                        "Selected deployment details for {0}",
                        serverConfig.OrganizationName));
                    Console.WriteLine("=========================================");
                    Console.Write("Friendly Name: ");
                    Console.WriteLine(deployment.FriendlyName);
                    Console.Write("Unique Name: ");
                    Console.WriteLine(deployment.UniqueName);
                    Console.Write("Organization Version: ");
                    Console.WriteLine(deployment.Version);
                    Console.Write("SQL Server Name: ");
                    Console.WriteLine(deployment.SqlServerName);
                    Console.Write("SRS URL: ");
                    Console.WriteLine(deployment.SrsUrl);
                    Console.WriteLine("<End of Listing>");
                    Console.WriteLine();

                    // Retrieve license and user information for your organization.
                    TrackLicenseRequest licenseRequest = new TrackLicenseRequest();
                    TrackLicenseResponse licenseResponse =
                        (TrackLicenseResponse)serviceClient.Execute(licenseRequest);

                    // Print out the number of servers and the user list.
                    Console.WriteLine(String.Format(
                        "License and user information for {0}",
                        serverConfig.OrganizationName));
                    Console.WriteLine("=========================================");
                    Console.Write("Number of servers: ");
                    Console.WriteLine(licenseResponse.Servers != null
                        ? licenseResponse.Servers.Count.ToString()
                        : "null");
                    Console.WriteLine("Users:");
                    foreach (OrganizationUserInfo user in licenseResponse.Users.ToArray())
                    {
                        Console.WriteLine(user.FullName);
                    }
                    Console.WriteLine("<End of Listing>");
                    Console.WriteLine();

                    // Retrieve advanced settings for your organization.
                    // Note that the columnset must contain at least one column. Setting
                    // AllColumns to true results in an error.
                    RetrieveAdvancedSettingsRequest request =
                        new RetrieveAdvancedSettingsRequest
                        {
                            ConfigurationEntityName = "Server",
                            ColumnSet = new ColumnSet(
                                new string[] { "Id", "FullName", "Name", "Roles", "State", "Version" })
                        };
                    ConfigurationEntity configuration =
                        ((RetrieveAdvancedSettingsResponse)serviceClient.Execute(request)).Entity;

                    // Print out all advanced settings where IsWritable==true.
                    Console.WriteLine("Advanced deployment settings that can be updated");
                    Console.WriteLine("================================================");
                    foreach (var setting in configuration.Attributes)
                    {
                        if (setting.Key != "Id")
                        {
                            Console.WriteLine(
                                String.Format("{0}: {1}",
                                    setting.Key,
                                    setting.Value));
                        }
                    }
                    Console.WriteLine("<End of Listing>");
                    Console.WriteLine();

                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #endregion How To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                UseDeploymentServiceMessages app = new UseDeploymentServiceMessages();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method

    }
}

See Also

Concepts

Introduction to the deployment web service

Other Resources

Administer the deployment using the deployment web service
IDeploymentService

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Custom email providers for Microsoft Dynamics CRM

An email provider is a pluggable component that is integrated with the Microsoft Dynamics CRM Email Router service. The provider is responsible for specialized email processing and interfacing with an email protocol. The Email Router manages the routing of email to or from the Microsoft Dynamics CRM platform. Other forms of messaging, such as a fax, InfoPath form, out-of-office notification, and more are not supported by the router. The Email Router is supported by on-premises, Internet-facing, hosted, and online versions of Microsoft Dynamics CRM.

The Microsoft Dynamics CRM Email Router includes different email providers, each implementing a particular email protocol. For example, the POP3 email provider examines email messages that are received by a POP3 mailbox and calls into Microsoft Dynamics CRM to create email activities. The SMTP email provider connects to Microsoft Dynamics CRM to download email activities waiting to be sent, composes the email messages, and submits the email messages to an SMTP server.

For each type of email provider, several instances of the provider may be executing at the same time. For example, at a given time, five instances of the POP3 email provider may be running, each processing email messages from one mailbox and delivering email to a different organization.

In addition, the platform supports the integration of custom email providers to the Email Router service to extend or customize the email handling functionality of Microsoft Dynamics CRM. An extensible framework based on the concept of email providers and XML files is provided to develop custom providers. This email provider documentation explains how you can extend the object model to build your own highly specialized email provider.

From a design perspective, each type of email provider should accept configuration parameters. Two examples of configuration parameters are name of the mailbox to connect to and name of the email server to connect to. Some email providers may also have to persist run-time state information. For example, a provider might need persistent values for the time stamp of the last processed message or number of email messages processed to this point. Such state information should not be lost if the Email Router service is restarted.

For more information about writing email providers, refer to the E-mail Providers documentation in the Microsoft Dynamics CRM 4.0 SDK.

Related Sections

Advanced development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Write Java and other non-.NET client applications

Developers who use Java, or other non-.NET technologies can write applications that use data fromMicrosoft Dynamics CRM 2015.

You can also access data from Microsoft Dynamics CRM 2015 using the Web Services Description Language (WSDL) from the web service.

Related Sections

Advanced development

Sample data for Microsoft Dynamics CRM

Authenticate users with Microsoft Dynamics CRM web services

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample data for Microsoft Dynamics CRM

You can install and uninstall sample data programmatically for an organization using these messages: InstallSampleDataRequest and UnInstallSampleDataRequest. For more information, see Sample: Install or remove sample data.

See Also

Other Resources

Advanced development
Sample: Install or remove sample data
Write applications and server extensions
Use the IOrganizationService web service to read and write data or metadata

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample: Install or remove sample data
See Also Example

This sample code is for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Download the Microsoft Dynamics CRM SDK package. It can be found in the following location in the download package:

SampleCode\CS\GeneralProgramming\Other\ImportOrRemoveSampleData.cs

Requirements

For more information about the requirements for running the sample code provided in this SDK, see Use the sample and helper code.

Demonstrates

This sample shows how to install or uninstall the sample data for an organization by using the InstallSampleDataRequest message.

Example

C# Copy Code
using System;
using System.ServiceModel;

// These namespaces are found in the Microsoft.Xrm.Sdk.dll assembly
// found in the SDK\bin folder.
using Microsoft.Xrm.Sdk.Client;

// This namespace is found in Microsoft.Crm.Sdk.Proxy.dll assembly
// found in the SDK\bin folder.
using Microsoft.Crm.Sdk.Messages;

namespace Microsoft.Crm.Sdk.Samples
{
    /// <summary>
    /// Install or uninstall the Microsoft Dynamics CRM sample data records.
    /// </summary>
    public class ImportOrRemoveSampleData
    {

        #region Class Level Members

        private OrganizationServiceProxy _serviceProxy;

        #endregion Class Level Members

        #region How-To Sample Code
        /// <summary>
        /// Demonstrates how to programmatically install and uninstall the Microsoft
        /// Dynamics CRM sample data records.
        /// </summary>
        /// <param name="serverConfig">Contains server connection information.</param>
        /// <param name="promptforDelete">Not applicable for this sample.</param>
        public void Run(ServerConnection.Configuration serverConfig, bool promptforDelete)
        {
            try
            {
                // Connect to the Organization service.
                // The using statement assures that the service proxy will be properly disposed.
                using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
                {
                    // This statement is required to enable early-bound type support.
                    _serviceProxy.EnableProxyTypes();

                    // Prompt user to install/uninstall sample data.
                    Console.WriteLine("Would you like to:");
                    Console.WriteLine("1) Install sample data for Microsoft Dynamics CRM?");
                    Console.WriteLine("2) Uninstall sample data for Microsoft Dynamics CRM?");
                    Console.Write("Press [1] to Install, [2] to Uninstall: ");
                    String answer = Console.ReadLine();

                    // Update the sample data based on the user's response.
                    switch (answer)
                    {
                        case "1":
                            Console.WriteLine("Installing sample data...");
                            InstallSampleDataRequest request =
                                new InstallSampleDataRequest();
                            InstallSampleDataResponse response =
                                (InstallSampleDataResponse)_serviceProxy.Execute(request);
                            Console.WriteLine("Sample data successfully installed.");
                            break;
                        case "2":
                            Console.WriteLine("Uninstalling sample data...");
                            UninstallSampleDataRequest request2 =
                                new UninstallSampleDataRequest();
                            UninstallSampleDataResponse response2 =
                                (UninstallSampleDataResponse)_serviceProxy.Execute(request2);
                            Console.WriteLine("Sample data successfully uninstalled.");
                            break;
                        default:
                            Console.WriteLine("Neither option was selected. No changes have been made to your records.");
                            break;
                    }

                }
            }

            // Catch any service fault exceptions that Microsoft Dynamics CRM throws.
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>)
            {
                // You can handle an exception here or pass it back to the calling method.
                throw;
            }
        }

        #endregion How-To Sample Code

        #region Main method

        /// <summary>
        /// Standard Main() method used by most SDK samples.
        /// </summary>
        /// <param name="args"></param>
        static public void Main(string[] args)
        {
            try
            {
                // Obtain the target organization's Web address and client logon
                // credentials from the user.
                ServerConnection serverConnect = new ServerConnection();
                ServerConnection.Configuration config = serverConnect.GetServerConfiguration();

                ImportOrRemoveSampleData app = new ImportOrRemoveSampleData();
                app.Run(config, true);
            }
            catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Timestamp: {0}", ex.Detail.Timestamp);
                Console.WriteLine("Code: {0}", ex.Detail.ErrorCode);
                Console.WriteLine("Message: {0}", ex.Detail.Message);
                Console.WriteLine("Plugin Trace: {0}", ex.Detail.TraceText);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
            }
            catch (System.TimeoutException ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine("Message: {0}", ex.Message);
                Console.WriteLine("Stack Trace: {0}", ex.StackTrace);
                Console.WriteLine("Inner Fault: {0}",
                    null == ex.InnerException.Message ? "No Inner Fault" : ex.InnerException.Message);
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("The application terminated with an error.");
                Console.WriteLine(ex.Message);

                // Display the details of the inner exception.
                if (ex.InnerException != null)
                {
                    Console.WriteLine(ex.InnerException.Message);

                    FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> fe = ex.InnerException
                        as FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault>;
                    if (fe != null)
                    {
                        Console.WriteLine("Timestamp: {0}", fe.Detail.Timestamp);
                        Console.WriteLine("Code: {0}", fe.Detail.ErrorCode);
                        Console.WriteLine("Message: {0}", fe.Detail.Message);
                        Console.WriteLine("Plugin Trace: {0}", fe.Detail.TraceText);
                        Console.WriteLine("Inner Fault: {0}",
                            null == fe.Detail.InnerFault ? "No Inner Fault" : "Has Inner Fault");
                    }
                }
            }
            // Additional exceptions to catch: SecurityTokenValidationException, ExpiredSecurityTokenException,
            // SecurityAccessDeniedException, MessageSecurityException, and SecurityNegotiationException.

            finally
            {
                Console.WriteLine("Press <Enter> to exit.");
                Console.ReadLine();
            }
        }
        #endregion Main method
    }
}

See Also

Concepts

Sample data for Microsoft Dynamics CRM

Other Resources

InstallSampleDataRequest
UnInstallSampleDataRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Sample code directory

The following sample code is included for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online.

Helper code: DeviceIdManager class

Helper code: SystemUserProvider class

Helper code: ServerConnection class

Sample: Access the Discovery service

Sample: Add a record to a queue (early bound)

Sample: Add a principal to a queue (early bound)

Sample: Add products to a bundle

Sample: Assign a chart to another user

Sample: Assign a record to a new owner

Sample: Assign a record to a team

Sample: Assign a user-owned dashboard to another user

Sample: Associate a security role to a team

Sample: Associate a Security Role to a User

Sample: Associate and disassociate records using the OData endpoint with JavaScript

Sample: Associate records (early bound)

Sample: Audit entity data changes

Sample: Audit user access

Sample: Authenticate users with Microsoft Dynamics CRM web services

Sample: Azure aware custom plug-in

Sample: Azure aware custom workflow activity

Sample: Basic plug-in

Sample: Book an appointment

Sample: Bulk delete exported records

Sample: Bulk delete records that match common criteria

Sample: Calculate a credit score with a custom workflow activity

Sample: Calculate Price plug-in

Sample: Clean up history for a queue (early bound)

Sample: Close an incident

Sample: Clone product records

Sample: Collaborate with activity feeds

Sample: Complex LINQ queries

Sample: Convert a fax to a task

Sample: Convert an appointment to a recurring appointment

Sample: Convert an opportunity to a quote (early bound)

Sample: Convert queries between Fetch and QueryExpression

Sample: Create a connection (early bound)

Sample: Create a connection role (early bound)

Sample: Create a custom activity

Sample: Create a custom activity entity

Sample: Create a custom workflow activity

Sample: Create and publish products

Sample: Create a global option set

Sample: Create a LINQ query

Sample: Create a process using a template

Sample: Create a queue (early bound)

Sample: Create a reciprocal connection role (early bound)

Sample: Create a real-time workflow in code

Sample: Create a workflow in code

Sample: Create an email using a template

Sample: Create an on-premises user

Sample: Create an opportunity (early bound)

Sample: Create and retrieve entity relationships

Sample: Create and retrieve Outlook filters

Sample: Create and update an emailable entity

Sample: Create and update entity metadata

Sample: Create and update records with related records (early bound)

Sample: Create dependent OptionSets (picklists)

Sample: Create, retrieve, update, and delete (late bound)

Sample: Create, retrieve, update, and delete a dashboard

Sample: Create, retrieve, update, and delete records (early bound)

Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript and jQuery

Sample: Create, retrieve, update, and delete using the OData endpoint with JavaScript and jQuery

Sample: Create, retrieve, update, and delete a chart

Sample: Create, retrieve, update, and delete a dialog

Sample: Create, retrieve, update, and delete a recurring appointment

Sample: Create, retrieve, update, and delete a SharePoint location record

Sample: Create, retrieve, update, and delete an email attachment

Sample: Delete a queue (early bound)

Sample: Detect multiple duplicate records

Sample: Detect solution dependencies

Sample: Determine whether a user has a role

Sample: Disable a user

Sample: Distribute a quick campaign

Sample: Distribute campaign activities to dynamic and static lists

Sample: Distribute campaign activities to qualified marketing list

Sample: Download report definition

Sample: Dump attribute metadata to a file

Sample: Dump attribute picklist metadata to a file

Sample: Dump entity metadata to a file

Sample: Dump entity privilege information to a file

Sample: Dump entity relationship information to a file

Sample: Dump global option set information to a file

Sample: Enable document management for entities

Sample: Enable duplicate detection and retrieve duplicates

Sample: Enable field security for an entity

Sample: End a recurring appointment series

Sample: Execute a workflow

Sample: Execute multiple requests

Sample: Export and import a data map

Sample: Export ribbon definitions

Sample: Fulfill a sales order

Sample: Get the report history limit

Sample: Impersonate using the ActOnBehalfOf privilege

Sample: Import data using complex data map

Sample: Import files as web resources

Sample: Install or remove sample data

Sample: Invoke duplicate detection for creating and updating records

Sample: Link custom attributes between series and instances

Sample: Make a report available or unavailable to organization

Sample: Manage contracts

Sample: Merge two records

Sample: More LINQ query examples

Sample: OData endpoint jQuery contact editor

Sample: One-way listener

Sample: Override goal total count and close the goal

Sample: Pass multiple values to a web resource through the data parameter

Sample: Process quotes, sales orders and invoices

Sample: Promote an email message to Microsoft Dynamics CRM

Sample: Publish a report

Sample: Qualify a lead

Sample: Query connection roles by entity type code (early bound)

Sample: Query connections by reciprocal roles (early bound)

Sample: Query metadata and detect changes

Sample: Query the working hours of a user

Sample: Query the working hours of multiple users

Sample: Quick start for Microsoft Dynamics CRM

Sample: Release a queue item to the queue (early bound)

Sample: Remove a role for a user

Sample: Reschedule and cancel a recurring appointment

Sample: OData endpoint jQuery contact editor

Sample: REST listener

Sample: Retrieve absolute URL and site collection URL of a location record

Sample: Retrieve all charts attached to an entity

Sample: Retrieve an opportunity (early bound)

Sample: Retrieve email attachments for an email template

Sample: Retrieve entity metadata using JavaScript

Sample: Retrieve field permissions

Sample: Retrieve field sharing records

Sample: Retrieve license information

Sample: Retrieve multiple records using the OData endpoint with JavaScript

Sample: Retrieve multiple with the QueryByAttribute class

Sample: Retrieve multiple with the QueryExpression class

Sample: Retrieve records from an intersect table

Sample: Retrieve the roles for an organization

Sample: Retrieve time zone information

Sample: Retrieve with one-to-many relationship

Sample: RetrieveMultiple with condition operators using LINQ

Sample: Rollup goal data for a custom period against the target revenue

Sample: Rollup goal data for a fiscal period against the stretch target count

Sample: Rollup records related to a specific record

Sample: Search for openings to schedule a resource

Sample: Search and retrieve articles

Sample: Send an email

Sample: Send an email using a template

Sample: Send bulk email and monitor results

Sample: Serialize and deserialize an entity Instance

Sample: Set and retrieve entity images

Sample: Set negative prices in opportunities, quotes, and sales orders

Sample: Set the state of a workflow

Sample: Add a principal to a queue (early bound)

Sample: Share records using GrantAccess, ModifyAccess and RevokeAccess messages

Sample: Simplified connection quick start using Microsoft Dynamics CRM

Sample: Specify a queue item to work on (early bound)

Sample: Two-way listener

Sample: Update a connection role (early bound)

Sample: Update next birthday using a custom workflow activity

Sample: Upload, retrieve, and download an attachment

Sample: Use aggregation in FetchXML

Sample: Use FetchXML with a paging cookie

Sample: Use LINQ with late binding

Sample: Use Outlook methods

Sample: Use rollup queries to track goals

Sample: Use the organization service context

Sample: Validate an appointment

Sample: Validate and execute a saved query

Sample: Validate record state and set the state of the record

Sample: Web access from a sandboxed plug-in

Sample: Web resource utility

Sample: Windows 8 desktop modern OData app

Sample: Windows 8 desktop modern SOAP app

Sample: Work with activity party records

Sample: Work with attribute metadata

Sample: Work with global option sets

Sample: Work with solutions

Sample: Work with views

Sample: Xrm.Page.data.process.getEnabledProcesses

Sample: Xrm.Page.data.process.getActivePath

See Also

Concepts

Tutorials for learning about development for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Programming reference

This section contains reference documentation of the public assemblies, web services, schemas, and error codes that constitute the Microsoft Dynamics CRM SDK for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

In This Section

Web Service and Assembly Reference for Microsoft Dynamics CRM

Security role and privilege reference

Customization XML reference

Schemas used in Microsoft Dynamics CRM

Related Sections

Developer overview

Model your business data

Developer tools

Write applications and server extensions

Write client application extensions

Write plug-ins to extend business processes

Write workflows to automate business processes

Developers guide to reports for Microsoft Dynamics CRM

Manage your data

Package and distribute extensions using solutions

Developers guide to customization for Microsoft Dynamics CRM

Extend Microsoft Dynamics CRM for Outlook

Integrate SharePoint with Microsoft Dynamics CRM

Advanced development

Sample code directory

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Class Library

Namespaces

Namespace
Microsoft.Crm.Outlook.Sdk
Microsoft.Crm.Sdk
Microsoft.Crm.Sdk.Messages
Microsoft.Xrm.Sdk
Microsoft.Xrm.Sdk.Client
Microsoft.Xrm.Sdk.Deployment
Microsoft.Xrm.Sdk.Deployment.Proxy
Microsoft.Xrm.Sdk.Discovery
Microsoft.Xrm.Sdk.Messages
Microsoft.Xrm.Sdk.Metadata
Microsoft.Xrm.Sdk.Metadata.Query
Microsoft.Xrm.Sdk.Organization
Microsoft.Xrm.Sdk.Query
Microsoft.Xrm.Sdk.WebServiceClient
Microsoft.Xrm.Sdk.Workflow
Microsoft.Xrm.Sdk.Workflow.Activities
Microsoft.Xrm.Sdk.Workflow.Designers
Microsoft.Xrm.Tooling.Connector
Microsoft.Xrm.Tooling.Connector.Model
Microsoft.Xrm.Tooling.CrmConnectControl
Microsoft.Xrm.Tooling.CrmConnectControl.Model
Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Microsoft.Xrm.Tooling.WebResourceUtility


Microsoft.Crm.Outlook.Sdk Namespace

Classes

Class | Description
CrmOutlookService | Provides methods for interacting with CRM for Outlook.

Enumerations

Enumeration | Description
ClientState | Contains the possible states for the State property.
OutlookSyncType | Contains the possible synchronization type values that can be passed to the Sync method to trigger a background synchronization operation.


ClientState Enumeration
[image]

Contains the possible states for the State property.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration ClientState

C#
public enum ClientState

C++

J#

JScript

  Members
Member name | Description
BackgroundGoingOffline | The background synchronization to the offline database is in progress. Value = 12.
ClientLoadFailure | There was a failure in loading CRM for Outlook during Microsoft Outlook startup.Value = 6.
ClientVersionHigher | The CRM for Outlook version is later than that on the server. Value = 8.
ClientVersionLower | The CRM for Outlook version is earlier than that on the server. Value = 7.
Disable | The CRM for Outlook client is disabled. Value = 14.
GoingOffline | CRM for Outlook is going offline. Value = 4.
GoingOfflineCanceled | The user canceled the go offline process.Value = 11.
GoingOnline | CRM for Outlook is going online.Value = 5.
NotConfigured | The CRM for Outlook client is not yet configured. Value = 13.
Offline | CRM for Outlook is offline. Value = 1.
Online | CRM for Outlook is online. Value = 0.
OnlineCrmNotAvailable | The Microsoft Dynamics CRM server is not available. Value = 10.
PostOfflineUpgrade | CRM for Outlook was upgraded while offline. Value = 9.
SyncToOutlook | CRM for Outlook is currently synchronizing Microsoft Outlook with Microsoft Dynamics CRM.Value = 2.
SyncToOutlookError | There was an error in the last synchronization between Microsoft Outlook and Microsoft Dynamics CRM.Value = 3.
Unknown | The state of the CRM for Outlook client is unknown. Value = -1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Outlook.Sdk Namespace


CrmOutlookService Class
See Also Members
[image]

Provides methods for interacting with CRM for Outlook.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CrmOutlookService

C#
public sealed class CrmOutlookService

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Outlook.Sdk.CrmOutlookService
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Write Custom Code for Microsoft Dynamics CRM for Outlook
Sample: Use Outlook Methods


CrmOutlookService Members
See Also Constructors Methods Properties
[image]

Provides methods for interacting with CRM for Outlook.

The following tables list the members exposed by the CrmOutlookService type.

Public Constructors

Name | Description
CrmOutlookService | Initializes a new instance of the CrmOutlookService class.
Top

Public Properties

 | Name | Description
public property | IsCrmClientLoaded | Gets a value that indicates whether CRM for Outlook is loaded by Microsoft Office Outlook.
public property | IsCrmClientOffline | Gets a value that indicates whether Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is offline.
public property | IsCrmDesktopClient | Gets a value that indicates whether CRM for Outlook is installed. This version has no offline access.
public property | ServerUri | Gets the server URI to use to connect to the Microsoft Dynamics CRM server based on the state of CRM for Outlook.
public property | State | Gets the state of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | GoOffline | Takes Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access into an offline state and triggers a synchronization of the offline database with the online server.
public method | GoOnline | Synchronizes Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access with the online Microsoft Dynamics CRM server.
public method | SetOffline | Sets Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access into an offline state without triggering a synchronization of the offline database with the online server.
public method | Sync | Triggers a synchronization event between Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access in Microsoft Office Outlook and the Microsoft Dynamics CRM server.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CrmOutlookService Class
Microsoft.Crm.Outlook.Sdk Namespace

Other Resources

Write Custom Code for Microsoft Dynamics CRM for Outlook
Sample: Use Outlook Methods


CrmOutlookService Constructor
[image]

Initializes a new instance of the CrmOutlookService class.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmOutlookService ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace


CrmOutlookService Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | GoOffline | Takes Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access into an offline state and triggers a synchronization of the offline database with the online server.
public method | GoOnline | Synchronizes Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access with the online Microsoft Dynamics CRM server.
public method | SetOffline | Sets Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access into an offline state without triggering a synchronization of the offline database with the online server.
public method | Sync | Triggers a synchronization event between Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access in Microsoft Office Outlook and the Microsoft Dynamics CRM server.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmOutlookService Class
Microsoft.Crm.Outlook.Sdk Namespace

Other Resources

Write Custom Code for Microsoft Dynamics CRM for Outlook
Sample: Use Outlook Methods


CrmOutlookService.GoOffline Method
[image]

Takes Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access into an offline state and triggers a synchronization of the offline database with the online server.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub GoOffline

C#
public void GoOffline ()

C++

J#

JScript

  Remarks
This method is synchronous and triggers UI interaction with the user. If there are errors when taking CRM for Outlook offline, the method will not return until the error dialog box is dismissed.
  Warning

                        Because this function triggers UI interaction with the user it cannot be used within a plugin. This can cause the process to stop responding or cause unexpected behavior.

Throws an InvalidOperationException if the client is not loaded, CRM for Outlook client (no offline access) is installed or if the client is offline.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Sample: Use Outlook Methods


CrmOutlookService.GoOnline Method
[image]

Synchronizes Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access with the online Microsoft Dynamics CRM server.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub GoOnline

C#
public void GoOnline ()

C++

J#

JScript

  Remarks
Replays all the operations that were performed while Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access was offline to the server. This method is synchronous and triggers UI interaction with the user. If there are errors during the playback, the method will not return until the error dialog box is dismissed.
  Warning

                        Because this function triggers UI interaction with the user it cannot be used within a plugin. This can cause the process to stop responding or cause unexpected behavior.

Throws an InvalidOperationException if the client is not loaded, CRM for Outlook client (no offline access) is installed or if the client is offline.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Sample: Use Outlook Methods


CrmOutlookService.SetOffline Method
[image]

Sets Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access into an offline state without triggering a synchronization of the offline database with the online server.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub SetOffline

C#
public void SetOffline ()

C++

J#

JScript

  Remarks
Throws an InvalidOperationException if the client is not loaded, CRM for Outlook client (no offline access) is installed or if the client is offline.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Sample: Use Outlook Methods


CrmOutlookService.Sync Method
[image]

Triggers a synchronization event between Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access in Microsoft Office Outlook and the Microsoft Dynamics CRM server.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Sync ( _
    syncType As OutlookSyncType _
)

C#
public void Sync (
    OutlookSyncType syncType
)

C++

J#

JScript

Parameters
syncType
Type: OutlookSyncType. The target to which synchronization needs to be triggered: Outlook, the Microsoft Dynamics CRM Address Book Provider or the Offline database.
  Remarks
Triggers a synchronization event between Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access and the Microsoft Dynamics CRM Server. The synchronization occurs in the background and there is no user interaction. If there is a failure during synchronization there is no feedback provided. The method is synchronous and will not return until the synchronization operation is completed.
Throws an InvalidOperationException if the client is not loaded, CRM for Outlook client (no offline access) is installed or if the client is offline.
Throws an ArgumentException if the syncType is not supported.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Sample: Use Outlook Methods


CrmOutlookService Properties
[image]

Public Properties

 | Name | Description
public property | IsCrmClientLoaded | Gets a value that indicates whether CRM for Outlook is loaded by Microsoft Office Outlook.
public property | IsCrmClientOffline | Gets a value that indicates whether Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is offline.
public property | IsCrmDesktopClient | Gets a value that indicates whether CRM for Outlook is installed. This version has no offline access.
public property | ServerUri | Gets the server URI to use to connect to the Microsoft Dynamics CRM server based on the state of CRM for Outlook.
public property | State | Gets the state of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access.

See Also

Reference

CrmOutlookService Class
Microsoft.Crm.Outlook.Sdk Namespace

Other Resources

Write Custom Code for Microsoft Dynamics CRM for Outlook
Sample: Use Outlook Methods


CrmOutlookService.IsCrmClientLoaded Property
[image]

Gets a value that indicates whether CRM for Outlook is loaded by Microsoft Office Outlook.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsCrmClientLoaded As Boolean

C#
public bool IsCrmClientLoaded { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if CRM for Outlook is loaded by Microsoft Office Outlook; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Sample: Use Outlook Methods


CrmOutlookService.IsCrmClientOffline Property
[image]

Gets a value that indicates whether Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is offline.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsCrmClientOffline As Boolean

C#
public bool IsCrmClientOffline { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access is offline; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Sample: Use Outlook Methods


CrmOutlookService.IsCrmDesktopClient Property
[image]

Gets a value that indicates whether CRM for Outlook is installed. This version has no offline access.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsCrmDesktopClient As Boolean

C#
public bool IsCrmDesktopClient { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if CRM for Outlook is installed; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Sample: Use Outlook Methods


CrmOutlookService.ServerUri Property
[image]

Gets the server URI to use to connect to the Microsoft Dynamics CRM server based on the state of CRM for Outlook.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ServerUri As Uri

C#
public Uri ServerUri { get; }

C++

J#

JScript

Property Value
Type: URI

the server URI to use to connect to the Microsoft Dynamics CRM server based on the state of CRM for Outlook.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Sample: Use Outlook Methods


CrmOutlookService.State Property
[image]

Gets the state of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property State As ClientState

C#
public ClientState State { get; }

C++

J#

JScript

Property Value
Type: ClientState
The state of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOutlookService Class
CrmOutlookService Members
Microsoft.Crm.Outlook.Sdk Namespace
Other Resources
Sample: Use Outlook Methods


OutlookSyncType Enumeration
[image]

Contains the possible synchronization type values that can be passed to the Sync method to trigger a background synchronization operation.

Namespace: Microsoft.Crm.Outlook.Sdk
Assembly: Microsoft.Crm.Outlook.Sdk (in Microsoft.Crm.Outlook.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration OutlookSyncType

C#
public enum OutlookSyncType

C++

J#

JScript

  Members
Member name | Description
AddressBook | The Microsoft Dynamics CRM Address Book Provider has to be synchronized with the data in Microsoft Dynamics CRM. Value = 1.
Offline | The user's offline database has to be synchronized with the data in Microsoft Dynamics CRM. Value = 2.
Outlook | The user's Microsoft Outlook store has to be synchronized with the data in Microsoft Dynamics CRM. Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Outlook.Sdk Namespace
Sync


Microsoft.Crm.Sdk Namespace

Classes

Class | Description
BusinessUnitInheritanceMask | Contains integer values that are used for the BusinessUnit.InheritanceMask attribute.
CalendarRuleExtentCode | Contains integer flags that are used for the CalendarRule.ExtentCode attribute.
ListMemberType | Contains integer flags that are used for the List.MemberType attribute, used to indicate whether a list specifies accounts, contacts, or leads.
OrganizationFiscalYearDisplayCode | Contains integer values that are used for the Organization.FiscalYearDisplayCode attribute.
SavedQueryQueryType | Contains integer values that are used for the SavedQuery.QueryType attribute.
SdkMessageAvailability | Contains integer values that are used for the SdkMessage.Availability and SdkMessageFilter.Availability attributes.
SdkMessageFilterAvailability | Contains integer values that are used for the SdkMessageFilter.Availability attribute.
SubscriptionSubscriptionType | For internal use only.
TemplateGenerationTypeCode | Contains integer values that are used for the Template.GenerationTypeCode attribute.
UserQueryQueryType | Contains integer values that are used for the UserQuery.QueryType attribute.
UserSettingsAdvancedFindStartupMode | Contains integer values that are used for the UserSettings.AdvancedFindStartupMode attribute.
UserSettingsDefaultCalendarView | Contains integer values that are used for the UserSettings.DefaultCalendarView attribute.
UserSettingsFullNameConventionCode | Contains integer values that are used for the UserSettings.FullNameConventionCode attribute.


BusinessUnitInheritanceMask Class
See Also Members
[image]

Contains integer values that are used for the BusinessUnit.InheritanceMask attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class BusinessUnitInheritanceMask

C#
public static class BusinessUnitInheritanceMask

C++

J#

JScript

  Remarks
The following table shows the values that you can set for this class.
Member | Value | Description
InheritAll | 1023 | The business inherits all the inheritance values.
InheritCompetitor | 8 | The business inherits competitors from its parent business.
InheritEmailTemplate | 2 | The business inherits email templates from its parent business.
InheritNone | 0 | The business does not inherit from its parent business.
InheritProcessTemplate | 1 | All child business units inherit their process templates from this business.
InheritReferralSource | 4 | All child business units inherit their referral sources from this business.
InheritSalesProcess | 16 | The business inherits sale processes from its parent business.
MustInheritCompetitor | 256 | The business inherits competitors from its parent business.
MustInheritEmailTemplate | 64 | All child business units inherit email templates from this business.
MustInheritProcessTemplate | 32 | The business inherits process templates from its parent business.
MustInheritReferralSource | 128 | All child business units inherit referral sources from this business.
MustInheritSalesProcess | 512 | The business inherits sale processes from its parent business.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.BusinessUnitInheritanceMask
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace
Other Resources
Setting Bit Flags
BusinessUnit Entity


BusinessUnitInheritanceMask Members
See Also Fields
[image]

Contains integer values that are used for the BusinessUnit.InheritanceMask attribute.

The following tables list the members exposed by the BusinessUnitInheritanceMask type.

Public Fields

Name | Description
InheritAll | The business inherits all inheritance values. Value = 0x3ff.
InheritCompetitor | The business inherits competitors from its parent business. Value = 8.
InheritEmailTemplate | The business inherits email templates from its parent business. Value = 2.
InheritNone | The business does not inherit from its parent business. Value = 0.
InheritProcessTemplate | All child business units inherit process templates from this business. Value = 1.
InheritReferralSource | All child business units inherit referral sources from this business. Value = 4.
InheritSalesProcess | The business inherits sale processes from its parent business. Value = 0x10.
MustInheritCompetitor | The business inherits competitors from its parent business. Value = 0x100.
MustInheritEmailTemplate | All child business units inherit email templates from this business. Value = 0x40.
MustInheritProcessTemplate | The business inherits process templates from its parent business. Value = 0x20.
MustInheritReferralSource | All child business units inherit referral sources from this business. Value = 0x80.
MustInheritSalesProcess | The business inherits sale processes from its parent business. Value = 0x200.
Top

See Also

Reference

BusinessUnitInheritanceMask Class
Microsoft.Crm.Sdk Namespace

Other Resources

Setting Bit Flags
BusinessUnit Entity


BusinessUnitInheritanceMask Fields
[image]

Public Fields

Name | Description
InheritAll | The business inherits all inheritance values. Value = 0x3ff.
InheritCompetitor | The business inherits competitors from its parent business. Value = 8.
InheritEmailTemplate | The business inherits email templates from its parent business. Value = 2.
InheritNone | The business does not inherit from its parent business. Value = 0.
InheritProcessTemplate | All child business units inherit process templates from this business. Value = 1.
InheritReferralSource | All child business units inherit referral sources from this business. Value = 4.
InheritSalesProcess | The business inherits sale processes from its parent business. Value = 0x10.
MustInheritCompetitor | The business inherits competitors from its parent business. Value = 0x100.
MustInheritEmailTemplate | All child business units inherit email templates from this business. Value = 0x40.
MustInheritProcessTemplate | The business inherits process templates from its parent business. Value = 0x20.
MustInheritReferralSource | All child business units inherit referral sources from this business. Value = 0x80.
MustInheritSalesProcess | The business inherits sale processes from its parent business. Value = 0x200.

See Also

Reference

BusinessUnitInheritanceMask Class
Microsoft.Crm.Sdk Namespace

Other Resources

Setting Bit Flags
BusinessUnit Entity


BusinessUnitInheritanceMask.InheritAll Field
[image]

The business inherits all inheritance values. Value = 0x3ff.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InheritAll As Integer

C#
public const int InheritAll

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.InheritCompetitor Field
[image]

The business inherits competitors from its parent business. Value = 8.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InheritCompetitor As Integer

C#
public const int InheritCompetitor

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.InheritEmailTemplate Field
[image]

The business inherits email templates from its parent business. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InheritEmailTemplate As Integer

C#
public const int InheritEmailTemplate

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.InheritNone Field
[image]

The business does not inherit from its parent business. Value = 0.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InheritNone As Integer

C#
public const int InheritNone

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.InheritProcessTemplate Field
[image]

All child business units inherit process templates from this business. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InheritProcessTemplate As Integer

C#
public const int InheritProcessTemplate

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.InheritReferralSource Field
[image]

All child business units inherit referral sources from this business. Value = 4.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InheritReferralSource As Integer

C#
public const int InheritReferralSource

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.InheritSalesProcess Field
[image]

The business inherits sale processes from its parent business. Value = 0x10.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InheritSalesProcess As Integer

C#
public const int InheritSalesProcess

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.MustInheritCompetitor Field
[image]

The business inherits competitors from its parent business. Value = 0x100.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MustInheritCompetitor As Integer

C#
public const int MustInheritCompetitor

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.MustInheritEmailTemplate Field
[image]

All child business units inherit email templates from this business. Value = 0x40.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MustInheritEmailTemplate As Integer

C#
public const int MustInheritEmailTemplate

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.MustInheritProcessTemplate Field
[image]

The business inherits process templates from its parent business. Value = 0x20.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MustInheritProcessTemplate As Integer

C#
public const int MustInheritProcessTemplate

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.MustInheritReferralSource Field
[image]

All child business units inherit referral sources from this business. Value = 0x80.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MustInheritReferralSource As Integer

C#
public const int MustInheritReferralSource

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


BusinessUnitInheritanceMask.MustInheritSalesProcess Field
[image]

The business inherits sale processes from its parent business. Value = 0x200.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MustInheritSalesProcess As Integer

C#
public const int MustInheritSalesProcess

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessUnitInheritanceMask Class
BusinessUnitInheritanceMask Members
Microsoft.Crm.Sdk Namespace


CalendarRuleExtentCode Class
See Also Members
[image]

Contains integer flags that are used for the CalendarRule.ExtentCode attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CalendarRuleExtentCode

C#
public static class CalendarRuleExtentCode

C++

J#

JScript

  Remarks
The ExtentCode attribute defines how calendar rule overlap is handled during calendar rule expansion.
The following table shows the values for this class.
Member | Value | Description
SubtractRecurrenceIntervals | 1 | The recurrence duration determines the shadowing of that rule. Use this value to indicate working hours and a full day 24-hour shadow.
SubtractResults | 2 | Specifies that only the rule duration is shadowed. Use this value to indicate time off. For example, 4 hours of time off allow working hours to appear before and after.
Transparent | 0 | Specifies no shadowing of calendar rules. All rules are displayed even if they are shadowed or preceded by other rules.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.CalendarRuleExtentCode
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalendarRuleExtentCode Members
Microsoft.Crm.Sdk Namespace
Other Resources
CalendarRule Entity Messages and Methods


CalendarRuleExtentCode Members
See Also Fields
[image]

Contains integer flags that are used for the CalendarRule.ExtentCode attribute.

The following tables list the members exposed by the CalendarRuleExtentCode type.

Public Fields

Name | Description
SubtractRecurrenceIntervals | The recurrence duration determines the shadowing of that rule. Use this value to indicate working hours and a full day 24-hour shadow. Value = 1.
SubtractResults | Only the rule duration is shadowed. Use this value to indicate time off. For example, 4 hours of time off allow working hours to appear before and after. Value = 2.
Transparent | No shadowing of calendar rules. All rules are displayed even if they are shadowed or preceded by other rules. Value = 0.
Top

See Also

Reference

CalendarRuleExtentCode Class
Microsoft.Crm.Sdk Namespace

Other Resources

CalendarRule Entity Messages and Methods


CalendarRuleExtentCode Fields
[image]

Public Fields

Name | Description
SubtractRecurrenceIntervals | The recurrence duration determines the shadowing of that rule. Use this value to indicate working hours and a full day 24-hour shadow. Value = 1.
SubtractResults | Only the rule duration is shadowed. Use this value to indicate time off. For example, 4 hours of time off allow working hours to appear before and after. Value = 2.
Transparent | No shadowing of calendar rules. All rules are displayed even if they are shadowed or preceded by other rules. Value = 0.

See Also

Reference

CalendarRuleExtentCode Class
Microsoft.Crm.Sdk Namespace

Other Resources

CalendarRule Entity Messages and Methods


CalendarRuleExtentCode.SubtractRecurrenceIntervals Field
[image]

The recurrence duration determines the shadowing of that rule. Use this value to indicate working hours and a full day 24-hour shadow. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SubtractRecurrenceIntervals As Integer

C#
public const int SubtractRecurrenceIntervals

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalendarRuleExtentCode Class
CalendarRuleExtentCode Members
Microsoft.Crm.Sdk Namespace


CalendarRuleExtentCode.SubtractResults Field
[image]

Only the rule duration is shadowed. Use this value to indicate time off. For example, 4 hours of time off allow working hours to appear before and after. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SubtractResults As Integer

C#
public const int SubtractResults

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalendarRuleExtentCode Class
CalendarRuleExtentCode Members
Microsoft.Crm.Sdk Namespace


CalendarRuleExtentCode.Transparent Field
[image]

No shadowing of calendar rules. All rules are displayed even if they are shadowed or preceded by other rules. Value = 0.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Transparent As Integer

C#
public const int Transparent

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalendarRuleExtentCode Class
CalendarRuleExtentCode Members
Microsoft.Crm.Sdk Namespace


ListMemberType Class
See Also Members
[image]

Contains integer flags that are used for the List.MemberType attribute, used to indicate whether a list specifies accounts, contacts, or leads.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ListMemberType

C#
public static class ListMemberType

C++

J#

JScript

  Remarks
The following table shows the values for this class.
Member | Value | Description
Account | 1 | Specifies a list of accounts.
Contact | 2 | Specifies a list of contacts.
Lead | 4 | Specifies a list of leads.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.ListMemberType
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ListMemberType Members
Microsoft.Crm.Sdk Namespace
Other Resources
List (Marketing List) Entity
Sample: Distribute Campaign Activities to Dynamic and Static Lists


ListMemberType Members
See Also Fields
[image]

Contains integer flags that are used for the List.MemberType attribute, used to indicate whether a list specifies accounts, contacts, or leads.

The following tables list the members exposed by the ListMemberType type.

Public Fields

Name | Description
Account | A list of accounts. Value = 1.
Contact | A list of contacts. Value = 2.
Lead | A list of leads. Value = 4.
Top

See Also

Reference

ListMemberType Class
Microsoft.Crm.Sdk Namespace

Other Resources

List (Marketing List) Entity
Sample: Distribute Campaign Activities to Dynamic and Static Lists


ListMemberType Fields
[image]

Public Fields

Name | Description
Account | A list of accounts. Value = 1.
Contact | A list of contacts. Value = 2.
Lead | A list of leads. Value = 4.

See Also

Reference

ListMemberType Class
Microsoft.Crm.Sdk Namespace

Other Resources

List (Marketing List) Entity
Sample: Distribute Campaign Activities to Dynamic and Static Lists


ListMemberType.Account Field
[image]

A list of accounts. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Account As Integer

C#
public const int Account

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ListMemberType Class
ListMemberType Members
Microsoft.Crm.Sdk Namespace


ListMemberType.Contact Field
[image]

A list of contacts. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Contact As Integer

C#
public const int Contact

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ListMemberType Class
ListMemberType Members
Microsoft.Crm.Sdk Namespace


ListMemberType.Lead Field
[image]

A list of leads. Value = 4.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Lead As Integer

C#
public const int Lead

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ListMemberType Class
ListMemberType Members
Microsoft.Crm.Sdk Namespace


OrganizationFiscalYearDisplayCode Class
See Also Members
[image]

Contains integer values that are used for the Organization.FiscalYearDisplayCode attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class OrganizationFiscalYearDisplayCode

C#
public static class OrganizationFiscalYearDisplayCode

C++

J#

JScript

  Remarks
The following table shows the values for this class.
Member | Value | Description
UseEndDate | 2 | Displays the fiscal year based on the end date of the fiscal year.
UseStartDate | 1 | Displays the fiscal year based on the start date of the fiscal year.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.OrganizationFiscalYearDisplayCode
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationFiscalYearDisplayCode Members
Microsoft.Crm.Sdk Namespace
Other Resources
Organization Entities


OrganizationFiscalYearDisplayCode Members
See Also Fields
[image]

Contains integer values that are used for the Organization.FiscalYearDisplayCode attribute.

The following tables list the members exposed by the OrganizationFiscalYearDisplayCode type.

Public Fields

Name | Description
UseEndDate | Displays the fiscal year based on the end date of the fiscal year. Value = 2.
UseStartDate | Displays the fiscal year based on the start date of the fiscal year. Value = 1.
Top

See Also

Reference

OrganizationFiscalYearDisplayCode Class
Microsoft.Crm.Sdk Namespace

Other Resources

Organization Entities


OrganizationFiscalYearDisplayCode Fields
[image]

Public Fields

Name | Description
UseEndDate | Displays the fiscal year based on the end date of the fiscal year. Value = 2.
UseStartDate | Displays the fiscal year based on the start date of the fiscal year. Value = 1.

See Also

Reference

OrganizationFiscalYearDisplayCode Class
Microsoft.Crm.Sdk Namespace

Other Resources

Organization Entities


OrganizationFiscalYearDisplayCode.UseEndDate Field
[image]

Displays the fiscal year based on the end date of the fiscal year. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const UseEndDate As Integer

C#
public const int UseEndDate

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationFiscalYearDisplayCode Class
OrganizationFiscalYearDisplayCode Members
Microsoft.Crm.Sdk Namespace


OrganizationFiscalYearDisplayCode.UseStartDate Field
[image]

Displays the fiscal year based on the start date of the fiscal year. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const UseStartDate As Integer

C#
public const int UseStartDate

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationFiscalYearDisplayCode Class
OrganizationFiscalYearDisplayCode Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType Class
See Also Members
[image]

Contains integer values that are used for the SavedQuery.QueryType attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SavedQueryQueryType

C#
public static class SavedQueryQueryType

C++

J#

JScript

  Remarks
The following table shows the values for this class.
Member | Value | Description
AddressBookFilters | 512 | An address book filter.
AdvancedSearch | 1 | An advanced search.
CustomDefinedView | 16384 | A custom view.
InteractiveWorkflowView | 4096 | A view for a dialog (workflow process)
LookupView | 64 | A lookup view.
MainApplicationView | 0 | Specifies the main application view.
MainApplicationViewWithoutSubject | 1024 | Specifies the main application view without a subject.
OfflineFilters | 16 | An offline Microsoft Dynamics CRM for Microsoft Office Outlook filter query.
OfflineTemplate | 8192 | An offline template for CRM for Outlook.
OutlookFilters | 256 | A Microsoft Dynamics CRM for Outlook filter query.
OutlookTemplate | 131072 | A template for CRM for Outlook.
QuickFindSearch | 4 | A quick find query, which defines the columns searched using the Search field in a list view.
Reporting | 8 | A reporting query.
SavedQueryTypeOther | 2048 | A saved query used for workflow templates and e-mail templates.
SmAppointmentbookView | 128 | Specifies the service management appointment book view.
SubGrid | 2 | A sub-grid.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.SavedQueryQueryType
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace
Other Resources
SavedQuery (View) Entity Messages and Methods
Types of Views
Customize Entity Views in Microsoft Dynamics CRM


SavedQueryQueryType Members
See Also Fields
[image]

Contains integer values that are used for the SavedQuery.QueryType attribute.

The following tables list the members exposed by the SavedQueryQueryType type.

Public Fields

Name | Description
AddressBookFilters | An address book filter. Value = 512.
AdvancedSearch | An advanced search. Value = 1.
CustomDefinedView | A custom view. Value = 16384.
ExportFieldTranslationsView | Specifies a view on the Product, DynamicProperty and DynamicPropertyOptionSetItem entities that can be used to filter out the entities for which labels will be exported using the ExportFieldTranslationRequest message. Value = 65536.
InteractiveWorkflowView | A view for a dialog (workflow process). Value = 4096.
LookupView | A lookup view. Value = 64.
MainApplicationView | Specifies the main application view. Value = 0.
MainApplicationViewWithoutSubject | Specifies the main application view without a subject. Value = 1024.
OfflineFilters | An offline filter for CRM for Outlook. Value = 16.
OfflineTemplate | An offline template for CRM for Outlook. Value = 8192.
OutlookFilters | A filter for CRM for Outlook. Value = 256.
OutlookTemplate | A template for CRM for Outlook. Value = 131072.
QuickFindSearch | A quick find query, which defines the columns searched using the Search field in a list view. Value = 4.
Reporting | A reporting query. Value = 8.
SavedQueryTypeOther | A saved query used for workflow templates and e-mail templates. Value = 2048.
SMAppointmentBookView | Specifies the service management appointment book view. Value = 128.
SubGrid | A sub-grid query. Value = 2.
Top

See Also

Reference

SavedQueryQueryType Class
Microsoft.Crm.Sdk Namespace

Other Resources

SavedQuery (View) Entity Messages and Methods
Types of Views
Customize Entity Views in Microsoft Dynamics CRM


SavedQueryQueryType Fields
[image]

Public Fields

Name | Description
AddressBookFilters | An address book filter. Value = 512.
AdvancedSearch | An advanced search. Value = 1.
CustomDefinedView | A custom view. Value = 16384.
ExportFieldTranslationsView | Specifies a view on the Product, DynamicProperty and DynamicPropertyOptionSetItem entities that can be used to filter out the entities for which labels will be exported using the ExportFieldTranslationRequest message. Value = 65536.
InteractiveWorkflowView | A view for a dialog (workflow process). Value = 4096.
LookupView | A lookup view. Value = 64.
MainApplicationView | Specifies the main application view. Value = 0.
MainApplicationViewWithoutSubject | Specifies the main application view without a subject. Value = 1024.
OfflineFilters | An offline filter for CRM for Outlook. Value = 16.
OfflineTemplate | An offline template for CRM for Outlook. Value = 8192.
OutlookFilters | A filter for CRM for Outlook. Value = 256.
OutlookTemplate | A template for CRM for Outlook. Value = 131072.
QuickFindSearch | A quick find query, which defines the columns searched using the Search field in a list view. Value = 4.
Reporting | A reporting query. Value = 8.
SavedQueryTypeOther | A saved query used for workflow templates and e-mail templates. Value = 2048.
SMAppointmentBookView | Specifies the service management appointment book view. Value = 128.
SubGrid | A sub-grid query. Value = 2.

See Also

Reference

SavedQueryQueryType Class
Microsoft.Crm.Sdk Namespace

Other Resources

SavedQuery (View) Entity Messages and Methods
Types of Views
Customize Entity Views in Microsoft Dynamics CRM


SavedQueryQueryType.AddressBookFilters Field
[image]

An address book filter. Value = 512.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const AddressBookFilters As Integer

C#
public const int AddressBookFilters

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.AdvancedSearch Field
[image]

An advanced search. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const AdvancedSearch As Integer

C#
public const int AdvancedSearch

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.CustomDefinedView Field
[image]

A custom view. Value = 16384.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const CustomDefinedView As Integer

C#
public const int CustomDefinedView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.ExportFieldTranslationsView Field
[image]

Specifies a view on the Product, DynamicProperty and DynamicPropertyOptionSetItem entities that can be used to filter out the entities for which labels will be exported using the ExportFieldTranslationRequest message. Value = 65536.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const ExportFieldTranslationsView As Integer

C#
public const int ExportFieldTranslationsView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.InteractiveWorkflowView Field
[image]

A view for a dialog (workflow process). Value = 4096.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InteractiveWorkflowView As Integer

C#
public const int InteractiveWorkflowView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.LookupView Field
[image]

A lookup view. Value = 64.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const LookupView As Integer

C#
public const int LookupView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.MainApplicationView Field
[image]

Specifies the main application view. Value = 0.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MainApplicationView As Integer

C#
public const int MainApplicationView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.MainApplicationViewWithoutSubject Field
[image]

Specifies the main application view without a subject. Value = 1024.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MainApplicationViewWithoutSubject As Integer

C#
public const int MainApplicationViewWithoutSubject

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.OfflineFilters Field
[image]

An offline filter for CRM for Outlook. Value = 16.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const OfflineFilters As Integer

C#
public const int OfflineFilters

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.OfflineTemplate Field
[image]

An offline template for CRM for Outlook. Value = 8192.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const OfflineTemplate As Integer

C#
public const int OfflineTemplate

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.OutlookFilters Field
[image]

A filter for CRM for Outlook. Value = 256.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const OutlookFilters As Integer

C#
public const int OutlookFilters

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.OutlookTemplate Field
[image]

A template for CRM for Outlook. Value = 131072.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const OutlookTemplate As Integer

C#
public const int OutlookTemplate

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.QuickFindSearch Field
[image]

A quick find query, which defines the columns searched using the Search field in a list view. Value = 4.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const QuickFindSearch As Integer

C#
public const int QuickFindSearch

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.Reporting Field
[image]

A reporting query. Value = 8.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Reporting As Integer

C#
public const int Reporting

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.SavedQueryTypeOther Field
[image]

A saved query used for workflow templates and e-mail templates. Value = 2048.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SavedQueryTypeOther As Integer

C#
public const int SavedQueryTypeOther

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.SMAppointmentBookView Field
[image]

Specifies the service management appointment book view. Value = 128.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SMAppointmentBookView As Integer

C#
public const int SMAppointmentBookView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SavedQueryQueryType.SubGrid Field
[image]

A sub-grid query. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SubGrid As Integer

C#
public const int SubGrid

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SavedQueryQueryType Class
SavedQueryQueryType Members
Microsoft.Crm.Sdk Namespace


SdkMessageAvailability Class
See Also Members
[image]

Contains integer values that are used for the SdkMessage.Availability and SdkMessageFilter.Availability attributes.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SdkMessageAvailability

C#
public static class SdkMessageAvailability

C++

J#

JScript

  Remarks
The following table contains the values for this class.
Member | Value | Description
All | 2 | The message is available on both the client and the server.
Client | 1 | The message is available only on the client.
Server | 0 | The message is available only on the server.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.SdkMessageAvailability
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SdkMessageAvailability Members
Microsoft.Crm.Sdk Namespace
Other Resources
Plug-in Registration Entities


SdkMessageAvailability Members
See Also Fields
[image]

Contains integer values that are used for the SdkMessage.Availability and SdkMessageFilter.Availability attributes.

The following tables list the members exposed by the SdkMessageAvailability type.

Public Fields

Name | Description
All | The message is available on both connected and disconnected from the server. Value = 2.
Client | The message is available only on the client. Value = 1.
Server | The message is available only on the server. Value = 0.
Top

See Also

Reference

SdkMessageAvailability Class
Microsoft.Crm.Sdk Namespace

Other Resources

Plug-in Registration Entities


SdkMessageAvailability Fields
[image]

Public Fields

Name | Description
All | The message is available on both connected and disconnected from the server. Value = 2.
Client | The message is available only on the client. Value = 1.
Server | The message is available only on the server. Value = 0.

See Also

Reference

SdkMessageAvailability Class
Microsoft.Crm.Sdk Namespace

Other Resources

Plug-in Registration Entities


SdkMessageAvailability.All Field
[image]

The message is available on both connected and disconnected from the server. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const All As Integer

C#
public const int All

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SdkMessageAvailability Class
SdkMessageAvailability Members
Microsoft.Crm.Sdk Namespace


SdkMessageAvailability.Client Field
[image]

The message is available only on the client. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Client As Integer

C#
public const int Client

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SdkMessageAvailability Class
SdkMessageAvailability Members
Microsoft.Crm.Sdk Namespace


SdkMessageAvailability.Server Field
[image]

The message is available only on the server. Value = 0.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Server As Integer

C#
public const int Server

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SdkMessageAvailability Class
SdkMessageAvailability Members
Microsoft.Crm.Sdk Namespace


SdkMessageFilterAvailability Class
See Also Members
[image]

Contains integer values that are used for the SdkMessageFilter.Availability attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SdkMessageFilterAvailability

C#
public static class SdkMessageFilterAvailability

C++

J#

JScript

  Remarks
The following table contains the values for this class.
Member | Value | Description
All | 2 | The message is available on both the client and the server.
Client | 1 | The message is available only on the client.
Server | 0 | The message is available only on the server.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.SdkMessageFilterAvailability
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SdkMessageFilterAvailability Members
Microsoft.Crm.Sdk Namespace
Other Resources
Plug-in Registration Entities


SdkMessageFilterAvailability Members
See Also Fields
[image]

Contains integer values that are used for the SdkMessageFilter.Availability attribute.

The following tables list the members exposed by the SdkMessageFilterAvailability type.

Public Fields

Name | Description
All | The message is available on both connected and disconnected from the server. Value = 2.
Client | The message is available only on the client. Value = 1.
Server | The message is available only on the server. Value = 0.
Top

See Also

Reference

SdkMessageFilterAvailability Class
Microsoft.Crm.Sdk Namespace

Other Resources

Plug-in Registration Entities


SdkMessageFilterAvailability Fields
[image]

Public Fields

Name | Description
All | The message is available on both connected and disconnected from the server. Value = 2.
Client | The message is available only on the client. Value = 1.
Server | The message is available only on the server. Value = 0.

See Also

Reference

SdkMessageFilterAvailability Class
Microsoft.Crm.Sdk Namespace

Other Resources

Plug-in Registration Entities


SdkMessageFilterAvailability.All Field
[image]

The message is available on both connected and disconnected from the server. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const All As Integer

C#
public const int All

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SdkMessageFilterAvailability Class
SdkMessageFilterAvailability Members
Microsoft.Crm.Sdk Namespace


SdkMessageFilterAvailability.Client Field
[image]

The message is available only on the client. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Client As Integer

C#
public const int Client

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SdkMessageFilterAvailability Class
SdkMessageFilterAvailability Members
Microsoft.Crm.Sdk Namespace


SdkMessageFilterAvailability.Server Field
[image]

The message is available only on the server. Value = 0.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Server As Integer

C#
public const int Server

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SdkMessageFilterAvailability Class
SdkMessageFilterAvailability Members
Microsoft.Crm.Sdk Namespace


SubscriptionSubscriptionType Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SubscriptionSubscriptionType

C#
public static class SubscriptionSubscriptionType

C++

J#

JScript

  Remarks
The following table shows the values for this class.
Member | Value | Description
AddressBookProvider | 2 | For internal use only.
Offline | 0 | For internal use only.
Outlook | 1 | For internal use only.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.SubscriptionSubscriptionType
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SubscriptionSubscriptionType Members
Microsoft.Crm.Sdk Namespace


SubscriptionSubscriptionType Members
See Also Fields
[image]

For internal use only.

The following tables list the members exposed by the SubscriptionSubscriptionType type.

Public Fields

Name | Description
AddressBookProvider | For internal use only.
Offline | For internal use only.
Outlook | For internal use only.
Top

See Also

Reference

SubscriptionSubscriptionType Class
Microsoft.Crm.Sdk Namespace


SubscriptionSubscriptionType Fields
[image]

Public Fields

Name | Description
AddressBookProvider | For internal use only.
Offline | For internal use only.
Outlook | For internal use only.

See Also

Reference

SubscriptionSubscriptionType Class
Microsoft.Crm.Sdk Namespace


SubscriptionSubscriptionType.AddressBookProvider Field
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const AddressBookProvider As Integer

C#
public const int AddressBookProvider

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SubscriptionSubscriptionType Class
SubscriptionSubscriptionType Members
Microsoft.Crm.Sdk Namespace


SubscriptionSubscriptionType.Offline Field
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Offline As Integer

C#
public const int Offline

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SubscriptionSubscriptionType Class
SubscriptionSubscriptionType Members
Microsoft.Crm.Sdk Namespace


SubscriptionSubscriptionType.Outlook Field
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Outlook As Integer

C#
public const int Outlook

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SubscriptionSubscriptionType Class
SubscriptionSubscriptionType Members
Microsoft.Crm.Sdk Namespace


TemplateGenerationTypeCode Class
See Also Members
[image]

Contains integer values that are used for the Template.GenerationTypeCode attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class TemplateGenerationTypeCode

C#
public static class TemplateGenerationTypeCode

C++

J#

JScript

  Remarks
The following table shows the values for this class.
Member | Value | Description
BulkDeleteCompleted | 2 | Bulk delete has completed.
BulkDeleteCompletedWithFailures | 3 | Bulk delete has completed, but failures occurred.
BulkDeleteFailed | 4 | Bulk delete failed.
BulkDupDetectCompleted | 1 | Bulk duplicate detection has completed.
ImportCompleted | 5 | Import has completed.
ImportFailed | 6 | Import has failed.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.TemplateGenerationTypeCode
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TemplateGenerationTypeCode Members
Microsoft.Crm.Sdk Namespace


TemplateGenerationTypeCode Members
See Also Fields
[image]

Contains integer values that are used for the Template.GenerationTypeCode attribute.

The following tables list the members exposed by the TemplateGenerationTypeCode type.

Public Fields

Name | Description
BulkDeleteCompleted | Bulk delete has completed. Value = 2.
BulkDeleteCompletedWithFailures | Bulk delete has completed, but failures occurred. Value = 3.
BulkDeleteFailed | Bulk delete failed. Value = 4.
BulkDupDetectCompleted | Bulk duplicate detection has completed. Value = 1.
ImportCompleted | Import has completed. Value = 5.
ImportFailed | Import has failed. Value = 6.
Top

See Also

Reference

TemplateGenerationTypeCode Class
Microsoft.Crm.Sdk Namespace


TemplateGenerationTypeCode Fields
[image]

Public Fields

Name | Description
BulkDeleteCompleted | Bulk delete has completed. Value = 2.
BulkDeleteCompletedWithFailures | Bulk delete has completed, but failures occurred. Value = 3.
BulkDeleteFailed | Bulk delete failed. Value = 4.
BulkDupDetectCompleted | Bulk duplicate detection has completed. Value = 1.
ImportCompleted | Import has completed. Value = 5.
ImportFailed | Import has failed. Value = 6.

See Also

Reference

TemplateGenerationTypeCode Class
Microsoft.Crm.Sdk Namespace


TemplateGenerationTypeCode.BulkDeleteCompleted Field
[image]

Bulk delete has completed. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const BulkDeleteCompleted As Integer

C#
public const int BulkDeleteCompleted

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TemplateGenerationTypeCode Class
TemplateGenerationTypeCode Members
Microsoft.Crm.Sdk Namespace


TemplateGenerationTypeCode.BulkDeleteCompletedWithFailures Field
[image]

Bulk delete has completed, but failures occurred. Value = 3.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const BulkDeleteCompletedWithFailures As Integer

C#
public const int BulkDeleteCompletedWithFailures

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TemplateGenerationTypeCode Class
TemplateGenerationTypeCode Members
Microsoft.Crm.Sdk Namespace


TemplateGenerationTypeCode.BulkDeleteFailed Field
[image]

Bulk delete failed. Value = 4.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const BulkDeleteFailed As Integer

C#
public const int BulkDeleteFailed

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TemplateGenerationTypeCode Class
TemplateGenerationTypeCode Members
Microsoft.Crm.Sdk Namespace


TemplateGenerationTypeCode.BulkDupDetectCompleted Field
[image]

Bulk duplicate detection has completed. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const BulkDupDetectCompleted As Integer

C#
public const int BulkDupDetectCompleted

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TemplateGenerationTypeCode Class
TemplateGenerationTypeCode Members
Microsoft.Crm.Sdk Namespace


TemplateGenerationTypeCode.ImportCompleted Field
[image]

Import has completed. Value = 5.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const ImportCompleted As Integer

C#
public const int ImportCompleted

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TemplateGenerationTypeCode Class
TemplateGenerationTypeCode Members
Microsoft.Crm.Sdk Namespace


TemplateGenerationTypeCode.ImportFailed Field
[image]

Import has failed. Value = 6.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const ImportFailed As Integer

C#
public const int ImportFailed

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TemplateGenerationTypeCode Class
TemplateGenerationTypeCode Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType Class
See Also Members
[image]

Contains integer values that are used for the UserQuery.QueryType attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class UserQueryQueryType

C#
public static class UserQueryQueryType

C++

J#

JScript

  Remarks
The following table shows the values for this class.
Member | Value | Description
AddressBookFilters | 512 | AAn address book filter.
AdvancedSearch | 1 | AAn advanced search.
CustomDefinedView | 16384 | A custom view.
InteractiveWorkflowView | 4096 | A view for a dialog (workflow process)
LookupView | 64 | A lookup view.
MainApplicationView | 0 | The main application view.
MainApplicationViewWithoutSubject | 1024 | The main application view without a subject.
OfflineFilters | 16 | AAn offline Microsoft Dynamics CRM for Microsoft Office Outlook filter query.
OutlookFilters | 256 | A Microsoft Dynamics CRM for Outlook filter query.
QuickFindSearch | 4 | A quick find query, which defines the columns searched using the Search field in a list view.
Reporting | 8 | A reporting query.
SavedQueryTypeOther | 2048 | A saved query used for workflow templates and e-mail templates.
SmAppointmentbookView | 128 | The service management appointment book view.
SubGrid | 2 | A sub-grid.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.UserQueryQueryType
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace
Other Resources
UserQuery (Saved View) Entity
Types of Views
Customize Entity Views in Microsoft Dynamics CRM


UserQueryQueryType Members
See Also Fields
[image]

Contains integer values that are used for the UserQuery.QueryType attribute.

The following tables list the members exposed by the UserQueryQueryType type.

Public Fields

Name | Description
AddressBookFilters | AAn address book filter. Value = 512.
AdvancedSearch | AAn advanced search. Value = 1.
CustomDefinedView | A custom view. Value = 16384.
InteractiveWorkflowView | A view for a dialog (workflow process). Value = 4096.
LookupView | A lookup view. Value = 64.
MainApplicationView | The main application view. Value = 0.
MainApplicationViewWithoutSubject | The main application view without a subject. Value = 1024.
OfflineFilters | AAn offline filter for CRM for Outlook. Value = 16.
OutlookFilters | A filter for CRM for Outlook. Value = 256.
QuickFindSearch | A quick find query, which defines the columns searched using the Search field in a list view. Value = 4.
Reporting | A reporting query. Value = 8.
SavedQueryTypeOther | A saved query used for workflow templates and e-mail templates. Value = 2048.
SMAppointmentBookView | The service management appointment book view. Value = 128.
SubGrid | A sub-grid query. Value = 2.
Top

See Also

Reference

UserQueryQueryType Class
Microsoft.Crm.Sdk Namespace

Other Resources

UserQuery (Saved View) Entity
Types of Views
Customize Entity Views in Microsoft Dynamics CRM


UserQueryQueryType Fields
[image]

Public Fields

Name | Description
AddressBookFilters | AAn address book filter. Value = 512.
AdvancedSearch | AAn advanced search. Value = 1.
CustomDefinedView | A custom view. Value = 16384.
InteractiveWorkflowView | A view for a dialog (workflow process). Value = 4096.
LookupView | A lookup view. Value = 64.
MainApplicationView | The main application view. Value = 0.
MainApplicationViewWithoutSubject | The main application view without a subject. Value = 1024.
OfflineFilters | AAn offline filter for CRM for Outlook. Value = 16.
OutlookFilters | A filter for CRM for Outlook. Value = 256.
QuickFindSearch | A quick find query, which defines the columns searched using the Search field in a list view. Value = 4.
Reporting | A reporting query. Value = 8.
SavedQueryTypeOther | A saved query used for workflow templates and e-mail templates. Value = 2048.
SMAppointmentBookView | The service management appointment book view. Value = 128.
SubGrid | A sub-grid query. Value = 2.

See Also

Reference

UserQueryQueryType Class
Microsoft.Crm.Sdk Namespace

Other Resources

UserQuery (Saved View) Entity
Types of Views
Customize Entity Views in Microsoft Dynamics CRM


UserQueryQueryType.AddressBookFilters Field
[image]

AAn address book filter. Value = 512.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const AddressBookFilters As Integer

C#
public const int AddressBookFilters

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.AdvancedSearch Field
[image]

AAn advanced search. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const AdvancedSearch As Integer

C#
public const int AdvancedSearch

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.CustomDefinedView Field
[image]

A custom view. Value = 16384.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const CustomDefinedView As Integer

C#
public const int CustomDefinedView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.InteractiveWorkflowView Field
[image]

A view for a dialog (workflow process). Value = 4096.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InteractiveWorkflowView As Integer

C#
public const int InteractiveWorkflowView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.LookupView Field
[image]

A lookup view. Value = 64.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const LookupView As Integer

C#
public const int LookupView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.MainApplicationView Field
[image]

The main application view. Value = 0.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MainApplicationView As Integer

C#
public const int MainApplicationView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.MainApplicationViewWithoutSubject Field
[image]

The main application view without a subject. Value = 1024.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MainApplicationViewWithoutSubject As Integer

C#
public const int MainApplicationViewWithoutSubject

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.OfflineFilters Field
[image]

AAn offline filter for CRM for Outlook. Value = 16.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const OfflineFilters As Integer

C#
public const int OfflineFilters

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.OutlookFilters Field
[image]

A filter for CRM for Outlook. Value = 256.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const OutlookFilters As Integer

C#
public const int OutlookFilters

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.QuickFindSearch Field
[image]

A quick find query, which defines the columns searched using the Search field in a list view. Value = 4.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const QuickFindSearch As Integer

C#
public const int QuickFindSearch

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.Reporting Field
[image]

A reporting query. Value = 8.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Reporting As Integer

C#
public const int Reporting

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.SavedQueryTypeOther Field
[image]

A saved query used for workflow templates and e-mail templates. Value = 2048.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SavedQueryTypeOther As Integer

C#
public const int SavedQueryTypeOther

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.SMAppointmentBookView Field
[image]

The service management appointment book view. Value = 128.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SMAppointmentBookView As Integer

C#
public const int SMAppointmentBookView

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserQueryQueryType.SubGrid Field
[image]

A sub-grid query. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SubGrid As Integer

C#
public const int SubGrid

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserQueryQueryType Class
UserQueryQueryType Members
Microsoft.Crm.Sdk Namespace


UserSettingsAdvancedFindStartupMode Class
See Also Members
[image]

Contains integer values that are used for the UserSettings.AdvancedFindStartupMode attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class UserSettingsAdvancedFindStartupMode

C#
public static class UserSettingsAdvancedFindStartupMode

C++

J#

JScript

  Remarks
The following table shows the values for this class.
Member | Value | Description
Detailed | 2 | Show the detailed version of advanced find at startup.
Simple | 1 | Show the simple version of advanced find at startup.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.UserSettingsAdvancedFindStartupMode
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsAdvancedFindStartupMode Members
Microsoft.Crm.Sdk Namespace
Other Resources
UserSettings Entity Messages and Methods


UserSettingsAdvancedFindStartupMode Members
See Also Fields
[image]

Contains integer values that are used for the UserSettings.AdvancedFindStartupMode attribute.

The following tables list the members exposed by the UserSettingsAdvancedFindStartupMode type.

Public Fields

Name | Description
Detailed | Show the detailed version of advanced find at startup. Value = 2.
Simple | Show the simple version of advanced find at startup. Value = 1.
Top

See Also

Reference

UserSettingsAdvancedFindStartupMode Class
Microsoft.Crm.Sdk Namespace

Other Resources

UserSettings Entity Messages and Methods


UserSettingsAdvancedFindStartupMode Fields
[image]

Public Fields

Name | Description
Detailed | Show the detailed version of advanced find at startup. Value = 2.
Simple | Show the simple version of advanced find at startup. Value = 1.

See Also

Reference

UserSettingsAdvancedFindStartupMode Class
Microsoft.Crm.Sdk Namespace

Other Resources

UserSettings Entity Messages and Methods


UserSettingsAdvancedFindStartupMode.Detailed Field
[image]

Show the detailed version of advanced find at startup. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Detailed As Integer

C#
public const int Detailed

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsAdvancedFindStartupMode Class
UserSettingsAdvancedFindStartupMode Members
Microsoft.Crm.Sdk Namespace


UserSettingsAdvancedFindStartupMode.Simple Field
[image]

Show the simple version of advanced find at startup. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Simple As Integer

C#
public const int Simple

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsAdvancedFindStartupMode Class
UserSettingsAdvancedFindStartupMode Members
Microsoft.Crm.Sdk Namespace


UserSettingsDefaultCalendarView Class
See Also Members
[image]

Contains integer values that are used for the UserSettings.DefaultCalendarView attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class UserSettingsDefaultCalendarView

C#
public static class UserSettingsDefaultCalendarView

C++

J#

JScript

  Remarks
The following table shows the values for this class.
Member | Value | Description
Day | 0 | Show the day by default.
Month | 2 | Show the month by default.
Week | 1 | Show the week by default.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.UserSettingsDefaultCalendarView
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsDefaultCalendarView Members
Microsoft.Crm.Sdk Namespace
Other Resources
UserSettings Entity Messages and Methods


UserSettingsDefaultCalendarView Members
See Also Fields
[image]

Contains integer values that are used for the UserSettings.DefaultCalendarView attribute.

The following tables list the members exposed by the UserSettingsDefaultCalendarView type.

Public Fields

Name | Description
Day | Show the day by default. Value = 0.
Month | Show the month by default. Value = 2.
Week | Show the week by default. Value = 1.
Top

See Also

Reference

UserSettingsDefaultCalendarView Class
Microsoft.Crm.Sdk Namespace

Other Resources

UserSettings Entity Messages and Methods


UserSettingsDefaultCalendarView Fields
[image]

Public Fields

Name | Description
Day | Show the day by default. Value = 0.
Month | Show the month by default. Value = 2.
Week | Show the week by default. Value = 1.

See Also

Reference

UserSettingsDefaultCalendarView Class
Microsoft.Crm.Sdk Namespace

Other Resources

UserSettings Entity Messages and Methods


UserSettingsDefaultCalendarView.Day Field
[image]

Show the day by default. Value = 0.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Day As Integer

C#
public const int Day

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsDefaultCalendarView Class
UserSettingsDefaultCalendarView Members
Microsoft.Crm.Sdk Namespace


UserSettingsDefaultCalendarView.Month Field
[image]

Show the month by default. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Month As Integer

C#
public const int Month

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsDefaultCalendarView Class
UserSettingsDefaultCalendarView Members
Microsoft.Crm.Sdk Namespace


UserSettingsDefaultCalendarView.Week Field
[image]

Show the week by default. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Week As Integer

C#
public const int Week

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsDefaultCalendarView Class
UserSettingsDefaultCalendarView Members
Microsoft.Crm.Sdk Namespace


UserSettingsFullNameConventionCode Class
See Also Members
[image]

Contains integer values that are used for the UserSettings.FullNameConventionCode attribute.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class UserSettingsFullNameConventionCode

C#
public static class UserSettingsFullNameConventionCode

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.UserSettingsFullNameConventionCode
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsFullNameConventionCode Members
Microsoft.Crm.Sdk Namespace
Other Resources
UserSettings Entity Messages and Methods


UserSettingsFullNameConventionCode Members
See Also Fields
[image]

Contains integer values that are used for the UserSettings.FullNameConventionCode attribute.

The following tables list the members exposed by the UserSettingsFullNameConventionCode type.

Public Fields

Name | Description
FirstLast | Show the first and last name. Value = 1.
FirstMiddleInitialLast | Show the first name, middle initial and last name. Value = 3.
FirstMiddleLast | Show the first, middle and last names. Value = 5.
LastFirst | Show the last name and then the first name. Value = 0.
LastFirstMiddle | Show the last name first, then the first name and the middle name. Value = 4.
LastFirstMiddleInitial | Show the last name first, then the first name and the middle initial. Value = 2.
LastNoSpaceFirst | Show the last name and then the first name, with no space separating the names. Value = 7.
LastSpaceFirst | Show the last name and then the first name, with a space separating the names. Value = 6.
Top

See Also

Reference

UserSettingsFullNameConventionCode Class
Microsoft.Crm.Sdk Namespace

Other Resources

UserSettings Entity Messages and Methods


UserSettingsFullNameConventionCode Fields
[image]

Public Fields

Name | Description
FirstLast | Show the first and last name. Value = 1.
FirstMiddleInitialLast | Show the first name, middle initial and last name. Value = 3.
FirstMiddleLast | Show the first, middle and last names. Value = 5.
LastFirst | Show the last name and then the first name. Value = 0.
LastFirstMiddle | Show the last name first, then the first name and the middle name. Value = 4.
LastFirstMiddleInitial | Show the last name first, then the first name and the middle initial. Value = 2.
LastNoSpaceFirst | Show the last name and then the first name, with no space separating the names. Value = 7.
LastSpaceFirst | Show the last name and then the first name, with a space separating the names. Value = 6.

See Also

Reference

UserSettingsFullNameConventionCode Class
Microsoft.Crm.Sdk Namespace

Other Resources

UserSettings Entity Messages and Methods


UserSettingsFullNameConventionCode.FirstLast Field
[image]

Show the first and last name. Value = 1.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const FirstLast As Integer

C#
public const int FirstLast

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsFullNameConventionCode Class
UserSettingsFullNameConventionCode Members
Microsoft.Crm.Sdk Namespace


UserSettingsFullNameConventionCode.FirstMiddleInitialLast Field
[image]

Show the first name, middle initial and last name. Value = 3.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const FirstMiddleInitialLast As Integer

C#
public const int FirstMiddleInitialLast

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsFullNameConventionCode Class
UserSettingsFullNameConventionCode Members
Microsoft.Crm.Sdk Namespace


UserSettingsFullNameConventionCode.FirstMiddleLast Field
[image]

Show the first, middle and last names. Value = 5.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const FirstMiddleLast As Integer

C#
public const int FirstMiddleLast

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsFullNameConventionCode Class
UserSettingsFullNameConventionCode Members
Microsoft.Crm.Sdk Namespace


UserSettingsFullNameConventionCode.LastFirst Field
[image]

Show the last name and then the first name. Value = 0.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const LastFirst As Integer

C#
public const int LastFirst

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsFullNameConventionCode Class
UserSettingsFullNameConventionCode Members
Microsoft.Crm.Sdk Namespace


UserSettingsFullNameConventionCode.LastFirstMiddle Field
[image]

Show the last name first, then the first name and the middle name. Value = 4.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const LastFirstMiddle As Integer

C#
public const int LastFirstMiddle

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsFullNameConventionCode Class
UserSettingsFullNameConventionCode Members
Microsoft.Crm.Sdk Namespace


UserSettingsFullNameConventionCode.LastFirstMiddleInitial Field
[image]

Show the last name first, then the first name and the middle initial. Value = 2.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const LastFirstMiddleInitial As Integer

C#
public const int LastFirstMiddleInitial

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsFullNameConventionCode Class
UserSettingsFullNameConventionCode Members
Microsoft.Crm.Sdk Namespace


UserSettingsFullNameConventionCode.LastNoSpaceFirst Field
[image]

Show the last name and then the first name, with no space separating the names. Value = 7.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const LastNoSpaceFirst As Integer

C#
public const int LastNoSpaceFirst

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsFullNameConventionCode Class
UserSettingsFullNameConventionCode Members
Microsoft.Crm.Sdk Namespace


UserSettingsFullNameConventionCode.LastSpaceFirst Field
[image]

Show the last name and then the first name, with a space separating the names. Value = 6.

Namespace: Microsoft.Crm.Sdk
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const LastSpaceFirst As Integer

C#
public const int LastSpaceFirst

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserSettingsFullNameConventionCode Class
UserSettingsFullNameConventionCode Members
Microsoft.Crm.Sdk Namespace


Microsoft.Crm.Sdk.Messages Namespace

Classes

Class | Description
AddItemCampaignActivityRequest | Contains the data that is needed to add an item to a campaign activity.
AddItemCampaignActivityResponse | Contains the response from the AddItemCampaignActivityRequest class.
AddItemCampaignRequest | Contains the data that is needed to add an item to a campaign.
AddItemCampaignResponse | Contains the response from the AddItemCampaignRequest class.
AddListMembersListRequest | Contains the data that is needed to add members to the list.
AddListMembersListResponse | Contains the response from the AddListMembersListRequest class.
AddMemberListRequest | Contains the data that is needed to add a member to a list (marketing list).
AddMemberListResponse | Contains the response from the AddMemberListRequest class.
AddMembersTeamRequest | Contains the data that is needed to add members to a team.
AddMembersTeamResponse | Contains the response from the AddMembersTeamRequest class.
AddPrincipalToQueueRequest | Contains the data to add the specified principal to the list of queue members. If the principal is a team, add each team member to the queue.
AddPrincipalToQueueResponse | Contains the response from the AddPrincipalToQueueRequest message.
AddPrivilegesRoleRequest | Contains the data that is needed to add a set of existing privileges to an existing role.
AddPrivilegesRoleResponse | Contains the response from the AddPrivilegesRoleRequest class.
AddProductToKitRequest | Deprecated. Use the ProductAssociation entity. Contains the data that is needed to add a product to a kit.
AddProductToKitResponse | Deprecated. Use the ProductAssociation entity. Contains the response from the AddProductToKitRequest class.
AddRecurrenceRequest | Contains the data that is needed to add recurrence information to an existing appointment.
AddRecurrenceResponse | Contains the response from the AddRecurrenceRequest class.
AddSolutionComponentRequest | Contains the data that is needed to add a solution component to an unmanaged solution.
AddSolutionComponentResponse | Contains the response from the AddSolutionComponentRequest message.
AddSubstituteProductRequest | Deprecated. Use the AssociateRequest class. Adds a link between two entity instances in a many-to-many relationship.
AddSubstituteProductResponse | Deprecated. Use the AssociateRequest class and its associated response class. Contains the response from the AddSubstituteProductRequest class.
AddToQueueRequest | Contains the data that is needed to move an entity record from a source queue to a destination queue.
AddToQueueResponse | Contains the response from the AddToQueueRequest class.
AddUserToRecordTeamRequest | Contains the data that is needed to add a user to the auto created access team for the specified record.
AddUserToRecordTeamResponse | Contains the response from the AddUserToRecordTeamRequest class.
ApplyRoutingRuleRequest | Contains the data that is needed to apply the active routing rule to an incident.
ApplyRoutingRuleResponse | Contains the response from the ApplyRoutingRuleRequest message.
AppointmentProposal | Represents a proposed appointment time and date as a result of the SearchRequest message.
AppointmentRequest | Provides the details of an appointment request for the SearchRequest class.
AppointmentsToIgnore | Specifies the appointments to ignore in an appointment request from the SearchRequest class.
AssignRequest | Contains the data that is needed to assign the specified record to a new owner (user or team) by changing the OwnerId attribute of the record.
AssignResponse | Contains the response from the AssignRequest.
AssociateEntitiesRequest | Deprecated. Use the AssociateRequest class. Contains the data that is needed to add a link between two entity instances in a many-to-many relationship.
AssociateEntitiesResponse | Deprecated. Use the AssociateRequest class and its associated response class. Contains the response from the AssociateEntitiesRequest class.
AttributeAuditDetail | Contains the details of changes to entity attributes.
AuditDetail | Provides a base class for storing the details of data changes.
AuditDetailCollection | Contains a collection of AuditDetail objects.
AuditPartitionDetail | Identifies a Microsoft SQL Server partition that is used to store changes to entity data records.
AuditPartitionDetailCollection | Contains a data collection of AuditDetail objects.
AutoMapEntityRequest | Contains the data that is needed to generate a new set of attribute mappings based on the metadata.
AutoMapEntityResponse | Contains the response from the AutoMapEntityRequest class.
BackgroundSendEmailRequest | Contains the data that is needed to send email messages asynchronously.
BackgroundSendEmailResponse | Contains the response from the BackgroundSendEmailRequest class.
BookRequest | Contains the data that is needed to schedule or “book” an appointment, recurring appointment, or service appointment (service activity).
BookResponse | Contains the response from the BookRequest class.
BulkDeleteRequest | Contains the data that’s needed to submit a bulk delete job that deletes selected records in bulk. This job runs asynchronously in the background without blocking other activities.
BulkDeleteResponse | Contains the response from the BulkDeleteRequest class.
BulkDetectDuplicatesRequest | Contains the data that is needed to submit an asynchronous system job that detects and logs multiple duplicate records.
BulkDetectDuplicatesResponse | Contains the response from the BulkDetectDuplicatesRequest class.
BulkOperationStatusCloseRequest | For internal use only.
BulkOperationStatusCloseResponse | For internal use only.
BusinessNotification | For internal use only.
BusinessNotificationParameter | For internal use only.
CalculateActualValueOpportunityRequest | Contains the data that is needed to calculate the value of an opportunity that is in the "Won" state.
CalculateActualValueOpportunityResponse | Contains the response from the CalculateActualValueOpportunityRequest class.
CalculatePriceRequest | Contains the data that is needed to calculate price in an opportunity, quote, order, and invoice. This is used internally for custom pricing calculation when the default system pricing is overridden.
CalculatePriceResponse | Contains the response from the CalculatePriceRequest class.
CalculateRollupFieldRequest | Contains the data that is needed to calculate the value of a rollup attribute.
CalculateRollupFieldResponse | Contains the response from the CalculateRollupFieldRequest class.
CalculateTotalTimeIncidentRequest | Contains the data that is needed to calculate the total time, in minutes, that you used while you worked on an incident (case).
CalculateTotalTimeIncidentResponse | Contains the response from the CalculateTotalTimeIncidentRequest class.
CancelContractRequest | Contains the data that is needed to cancel a contract.
CancelContractResponse | Contains the response from the CancelContractRequest class.
CancelSalesOrderRequest | Contains the data that is needed to cancel a sales order (order).
CancelSalesOrderResponse | Contains the response from the CancelSalesOrderRequest class.
CheckIncomingEmailRequest | Contains the data that is needed to check whether the incoming email message is relevant to the Microsoft Dynamics CRM system.
CheckIncomingEmailResponse | Contains the response from the CheckIncomingEmailRequest class.
CheckPromoteEmailRequest | Contains the data that is needed to check whether the incoming email message should be promoted to the Microsoft Dynamics CRM system.
CheckPromoteEmailResponse | Contains the response from the CheckPromoteEmailRequest class.
CleanUpBulkOperationRequest | For internal use only.
CleanUpBulkOperationResponse | For internal use only.
CloneContractRequest | Contains the data that is needed to copy an existing contract and its line items.
CloneContractResponse | Contains the response from the CancelContractRequest class.
CloneProductRequest | Contains the data that is needed to copy an existing product family, product, or bundle under the same parent record.
CloneProductResponse | Contains the response from the CloneProductRequest class.
CloseIncidentRequest | Contains the data that is needed to close an incident (case).
CloseIncidentResponse | Contains the response from the CloseIncidentRequest class.
CloseQuoteRequest | Contains the data that is needed to close a quote.
CloseQuoteResponse | Contains the response from the CloseQuoteRequest class.
ComponentDetail | Provides additional information about the solution components that are related to a missing component.
CompoundCreateRequest | Deprecated. Use the CreateRequest class. Creates a compound entity, such as a sales order (order), invoice, quote, or duplicate rule (duplicate detection rule); and its related entity, such as a sales order detail (order product), invoice detail (invoice product), quote detail (quote product), or duplicate rule condition.
CompoundCreateResponse | Deprecated. Use the CreateRequest class and its associated response class.
CompoundUpdateDuplicateDetectionRuleRequest | Contains the data that is needed to update a duplicate rule (duplicate detection rule) and its related duplicate rule conditions.
CompoundUpdateDuplicateDetectionRuleResponse | Contains the response from the CompoundUpdateDuplicateDetectionRuleRequest class.
CompoundUpdateRequest | Deprecated. Use the CreateRequest class. Contains the data that is needed to update a compound record, such as a sales order (order), invoice, quote, or duplicate rule (duplicate detection rule); and its related detail record, such as a sales order detail (order product), invoice detail (invoice product), quote detail (quote product), or duplicate rule condition.
CompoundUpdateResponse | Deprecated. Use the CreateRequest class and its associated response class. Contains the response from the CompoundUpdateRequest class.
ConstraintRelation | Specifies additional constraints to be applied when you select resources for appointments.
ConvertKitToProductRequest | Deprecated. Contains the data that is needed to convert a kit to a product.
ConvertKitToProductResponse | Deprecated. Contains the response from the ConvertKitToProductRequest class.
ConvertOwnerTeamToAccessTeamRequest | Contains the data that is needed to convert a team of type owner to a team of type access.
ConvertOwnerTeamToAccessTeamResponse | Contains the response from the ConvertOwnerTeamToAccessTeamRequest class.
ConvertProductToKitRequest | Deprecated. Contains the data that is needed to convert a product to a kit.
ConvertProductToKitResponse | Deprecated. Contains the response from the ConvertProductToKitRequest class.
ConvertQuoteToSalesOrderRequest | Contains the data that is needed to convert a quote to a sales order.
ConvertQuoteToSalesOrderResponse | Contains the response from the ConvertQuoteToSalesOrderRequest class.
ConvertSalesOrderToInvoiceRequest | Contains the data that is needed to convert a sales order to an invoice.
ConvertSalesOrderToInvoiceResponse | Contains the response from the ConvertSalesOrderToInvoiceRequest class.
CopyCampaignRequest | Contains the data that is needed to copy a campaign.
CopyCampaignResponse | Contains the response from the CopyCampaignRequest class.
CopyCampaignResponseRequest | Contains the data that is needed to create a copy of the campaign response.
CopyCampaignResponseResponse | Contains the response from the CopyCampaignResponseRequest class.
CopyDynamicListToStaticRequest | Contains the data that is needed to create a static list from the specified dynamic list and add the members that satisfy the dynamic list query criteria to the static list.
CopyDynamicListToStaticResponse | Contains the response from the CopyDynamicListToStaticRequest class.
CopyMembersListRequest | Contains the data that is needed to copy the members from the source list to the target list without creating duplicates.
CopyMembersListResponse | Contains the response from the CopyMembersListRequest class.
CopySystemFormRequest | Contains the data that is needed to create a new entity form that is based on an existing entity form.
CopySystemFormResponse | Contains the response from the CopySystemFormRequest class.
CreateActivitiesListRequest | Contains the data that is needed to create a quick campaign to distribute an activity to members of a list (marketing list).
CreateActivitiesListResponse | Contains the response from the CreateActivitiesListRequest class.
CreateExceptionRequest | Contains the data that is needed to create an exception for the recurring appointment instance.
CreateExceptionResponse | Contains the response from the CreateExceptionRequest class.
CreateInstanceRequest | Contains the data that is needed to create future unexpanded instances for the recurring appointment master.
CreateInstanceResponse | Contains the response from the CreateInstanceRequest class.
CreateWorkflowFromTemplateRequest | Contains the data that is needed to create a workflow (process) from a workflow template.
CreateWorkflowFromTemplateResponse | Contains the response from the CreateWorkflowFromTemplateRequest class.
DeleteAuditDataRequest | Contains the data that is needed to delete all audit data records up until a specified end date.
DeleteAuditDataResponse | Contains the response from the DeleteAuditDataRequest class.
DeleteOpenInstancesRequest | Contains the data that is needed to delete instances of a recurring appointment master that have an “Open” state.
DeleteOpenInstancesResponse | Contains the response from the DeleteOpenInstancesRequest class.
DeliverIncomingEmailRequest | Contains the data that is needed to create an email activity record from an incoming email message (Track in CRM).
DeliverIncomingEmailResponse | Contains the response from the DeliverIncomingEmailRequest class.
DeliverPromoteEmailRequest | Contains the data that is needed to create an email activity record from the specified email message (Track in CRM).
DeliverPromoteEmailResponse | Contains the response from the DeliverPromoteEmailRequest class.
DeprovisionLanguageRequest | Contains the data that is needed to deprovision a language.
DeprovisionLanguageResponse | Contains the response from the DeprovisionLanguageRequest class.
DisassociateEntitiesRequest | Deprecated. Use the DisassociateRequest class. Contains the data that is needed to remove a link between two entity instances in a many-to-many relationship.
DisassociateEntitiesResponse | Deprecated. Use the DisassociateRequest class and its associated response class. Contains the response from the DisassociateEntitiesRequest class.
DistributeCampaignActivityRequest | Contains the data that is needed to create a bulk operation that distributes a campaign activity. The appropriate activities, such as a phone call or fax, are created for the members of the list that is associated with the specified campaign activity.
DistributeCampaignActivityResponse | Contains the response from the DistributeCampaignActivityRequest class.
DownloadReportDefinitionRequest | Contains the data that is needed to download a report definition.
DownloadReportDefinitionResponse | Contains the response from the DownloadReportDefinitionRequest class.
ErrorInfo | Specifies the results of a scheduling operation using the ValidateRequest, BookRequest, or RescheduleRequest message.
ExecuteByIdSavedQueryRequest | Contains the data that is needed to execute a saved query (view) that has the specified ID.
ExecuteByIdSavedQueryResponse | Contains the response from the ExecuteByIdSavedQueryRequest class.
ExecuteByIdUserQueryRequest | Contains the data that is needed to execute the user query (saved view) that has the specified ID.
ExecuteByIdUserQueryResponse | Contains the response from the ExecuteByIdUserQueryRequest class.
ExecuteFetchRequest | Deprecated. Use the RetrieveMultipleRequest class.
ExecuteFetchResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
ExecuteWorkflowRequest | Contains the data that’s needed to execute a workflow.
ExecuteWorkflowResponse | Contains the response from the ExecuteWorkflowResponse class.
ExpandCalendarRequest | Contains the data that is needed to convert the calendar rules to an array of available time blocks for the specified period.
ExpandCalendarResponse | Contains the response from the ExpandCalendarRequest class.
ExportFieldTranslationRequest | Contains the data that is needed to export localizable fields values to a compressed file.
ExportFieldTranslationResponse | Contains the response from the ExportFieldTranslationRequest class.
ExportMappingsImportMapRequest | Contains the data that is needed to export a data map as an XML formatted data.
ExportMappingsImportMapResponse | Contains the response from the ExportMappingsImportMapRequest class.
ExportSolutionRequest | Contains the data that’s needed to export a solution.
ExportSolutionResponse | Contains the response from the ExportSolutionRequest class.
ExportTranslationRequest | Contains the data that is needed to export all translations for a specific solution to a compressed file.
ExportTranslationResponse | Contains the response from the ExportTranslationRequest class.
FetchXmlToQueryExpressionRequest | Contains the data that is needed to convert a query in FetchXML to a QueryExpression.
FetchXmlToQueryExpressionResponse | Contains the response from the FetchXmlToQueryExpressionRequest class.
FindParentResourceGroupRequest | Contains the data that is needed to find a parent resource group (scheduling group) for the specified resource groups (scheduling groups).
FindParentResourceGroupResponse | Contains the response from the FindParentResourceGroupRequest class.
FulfillSalesOrderRequest | Contains the data that is needed to fulfill the sales order (order).
FulfillSalesOrderResponse | Contains the response from the FulfillSalesOrderRequest class.
GenerateInvoiceFromOpportunityRequest | Contains the data that is needed to generate an invoice from an opportunity.
GenerateInvoiceFromOpportunityResponse | Contains the response from the GenerateInvoiceFromOpportunityRequest class.
GenerateQuoteFromOpportunityRequest | Contains the data that is needed to generate a quote from an opportunity.
GenerateQuoteFromOpportunityResponse | Contains the response from the GenerateQuoteFromOpportunityRequest class.
GenerateSalesOrderFromOpportunityRequest | Contains the data that is needed to generate a sales order (order) from an opportunity.
GenerateSalesOrderFromOpportunityResponse | Contains the response from the GenerateSalesOrderFromOpportunityRequest class.
GenerateSocialProfileRequest | Contains the data to return an existing social profile record if one exists, otherwise generates a new one and returns it.
GenerateSocialProfileResponse | Contains the response from the GenerateSocialProfileRequest message.
GetAllTimeZonesWithDisplayNameRequest | Contains the data that is needed to retrieve all the time zone definitions for the specified locale and to return only the display name attribute.
GetAllTimeZonesWithDisplayNameResponse | Contains the response from the GetAllTimeZonesWithDisplayNameRequest class.
GetDecryptionKeyRequest | For internal use only. See RetrieveDataEncryptionKeyRequest.
GetDecryptionKeyResponse | For internal use only.
GetDefaultPriceLevelRequest | For internal use only.
GetDefaultPriceLevelResponse | For internal use only.
GetDistinctValuesImportFileRequest | Contains the data that is needed to retrieve distinct values from the parse table for a column in the source file that contains list values.
GetDistinctValuesImportFileResponse | Contains the response from the GetDistinctValuesImportFileRequest class.
GetHeaderColumnsImportFileRequest | Contains the data that is needed to retrieve the source-file column headings; or retrieve the system-generated column headings if the source file does not contain column headings.
GetHeaderColumnsImportFileResponse | Contains the response from the GetHeaderColumnsImportFileRequest class.
GetInvoiceProductsFromOpportunityRequest | Contains the data that is needed to retrieve the products from an opportunity and copy them to the invoice.
GetInvoiceProductsFromOpportunityResponse | Contains the response from the GetInvoiceProductsFromOpportunityRequest class.
GetQuantityDecimalRequest | Contains the data that is needed to get the quantity decimal value of a product for the specified entity in the target.
GetQuantityDecimalResponse | Contains the response from the GetQuantityDecimalRequest class.
GetQuoteProductsFromOpportunityRequest | Contains the data that is needed to retrieve the products from an opportunity and copy them to the quote.
GetQuoteProductsFromOpportunityResponse | Contains the response from the GetQuoteProductsFromOpportunityRequest class.
GetReportHistoryLimitRequest | Contains the data that is needed to retrieve the history limit for a report.
GetReportHistoryLimitResponse | Contains the response from the GetReportHistoryLimitRequest class.
GetSalesOrderProductsFromOpportunityRequest | Contains the data that is needed to retrieve the products from an opportunity and copy them to the sales order (order).
GetSalesOrderProductsFromOpportunityResponse | Contains the response from the GetSalesOrderProductsFromOpportunityRequest class.
GetTimeZoneCodeByLocalizedNameRequest | Contains the data that is needed to retrieve the time zone code for the specified localized time zone name.
GetTimeZoneCodeByLocalizedNameResponse | Contains the response from the GetTimeZoneCodeByLocalizedNameRequest class.
GetTrackingTokenEmailRequest | Contains the data that is needed to return a tracking token that can then be passed as a parameter to the SendEmailRequest message.
GetTrackingTokenEmailResponse | Contains the response from the GetTrackingTokenEmailRequest class.
GrantAccessRequest | Contains the data that is needed to grant a security principal (user or team) access to the specified record.
GrantAccessResponse | Contains the response from the GrantAccessRequest class.
ImportFieldTranslationRequest | Contains the data that is needed to import translations from a compressed file.
ImportFieldTranslationResponse | Contains the response from the ImportFieldTranslationRequest class.
ImportMappingsImportMapRequest | Contains the data that is needed to import the XML representation of a data map and create an import map (data map) based on this data.
ImportMappingsImportMapResponse | Contains the response from the ImportMappingsImportMapRequest class.
ImportRecordsImportRequest | Contains the data that is needed to submit an asynchronous job that uploads the transformed data into Microsoft Dynamics CRM.
ImportRecordsImportResponse | Contains the response from the ImportRecordsImportRequest class.
ImportSolutionRequest | Contains the data that is needed to import a solution.
ImportSolutionResponse | Contains the response from the ImportSolutionRequest class.
ImportTranslationRequest | Contains the data that is needed to import translations from a compressed file.
ImportTranslationResponse | Contains the response from the ImportTranslationRequest class.
InitializeFromRequest | Contains the data that is needed to initialize a new record from an existing record.
InitializeFromResponse | Contains the response from the InitializeFromRequest class.
InputArgument | Contains custom application data.
InputArgumentCollection | Contains a collection of InputArgument objects.
InstallSampleDataRequest | Contains the data that is needed to install the sample data.
InstallSampleDataResponse | Contains the response from the InstallSampleDataRequest class.
InstantiateFiltersRequest | Contains the data that is needed to instantiate a set of filters for CRM for Outlook for the specified user.
InstantiateFiltersResponse | Contains the response from the InstantiateFiltersRequest class.
InstantiateTemplateRequest | Contains the parameters that are needed to create an email message from a template (email template).
InstantiateTemplateResponse | Contains the response from the InstantiateTemplateRequest class.
IsBackOfficeInstalledRequest | Deprecated. Checks whether Microsoft Dynamics GP 9.0 is installed.
IsBackOfficeInstalledResponse | Deprecated.
IsComponentCustomizableRequest | Contains the data that is needed to determine whether a solution component is customizable.
IsComponentCustomizableResponse | Contains the response from the IsComponentCustomizableRequest class.
IsValidStateTransitionRequest | Contains the data that is needed to validate the state transition.
IsValidStateTransitionResponse | Contains the response from the IsValidStateTransitionRequest class.
LocalTimeFromUtcTimeRequest | Contains the data that is needed to retrieve the local time for the specified Coordinated Universal Time (UTC).
LocalTimeFromUtcTimeResponse | Contains the response from the LocalTimeFromUtcTimeRequest class.
LockInvoicePricingRequest | Contains the data that is needed to lock the total price of products and services that are specified in the invoice.
LockInvoicePricingResponse | Contains the response from the LockInvoicePricingRequest class.
LockSalesOrderPricingRequest | Contains the data that is needed to lock the total price of products and services that are specified in the sales order (order).
LockSalesOrderPricingResponse | Contains the response from the LockSalesOrderPricingRequest class.
LogFailureBulkOperationRequest | For internal use only.
LogFailureBulkOperationResponse | For internal use only.
LogSuccessBulkOperationRequest | For internal use only.
LogSuccessBulkOperationResponse | For internal use only.
LoseOpportunityRequest | Contains the data that is needed to set the state of an opportunity to Lost.
LoseOpportunityResponse | Contains the response from the LoseOpportunityRequest class.
MakeAvailableToOrganizationReportRequest | Deprecated. Use the UpdateRequest class.
MakeAvailableToOrganizationReportResponse | Deprecated. Use the UpdateRequest class and its associated response class.
MakeAvailableToOrganizationTemplateRequest | Deprecated. Use the UpdateRequest class.
MakeAvailableToOrganizationTemplateResponse | Deprecated. Use the UpdateRequest class and its associated response class.
MakeUnavailableToOrganizationReportRequest | Deprecated. Use the UpdateRequest class.
MakeUnavailableToOrganizationReportResponse | Deprecated. Use the UpdateRequest class and its associated response class.
MakeUnavailableToOrganizationTemplateRequest | Deprecated. Use the UpdateRequest class.
MakeUnavailableToOrganizationTemplateResponse | Deprecated. Use the UpdateRequest class and its associated response class.
MergeRequest | Contains the data that’s needed to merge the information from two entity records of the same type.
MergeResponse | Contains the response from the MergeRequest class.
MissingComponent | Contains the data to describe a solution component that is required by a solution but not found in the system.
ModifyAccessRequest | Contains the data that is needed to replace the access rights on the target record for the specified security principal (user or team).
ModifyAccessResponse | Contains the response from the ModifyAccessRequest class.
ObjectiveRelation | Contains the data that describes the scheduling strategy for an AppointmentRequest and that overrides the default constraints.
OrganizationResources | Contains data regarding the resources used by an organization.
ParseImportRequest | Contains the data that is needed to submit an asynchronous job that parses all import files that are associated with the specified import (data import).
ParseImportResponse | Contains the response from the ParseImportRequest class.
PickFromQueueRequest | Contains the data that is needed to assign a queue item to a user and optionally remove the queue item from the queue.
PickFromQueueResponse | Contains the response from the PickFromQueueRequest message.
PrincipalAccess | Contains access rights information for the security principal (user or team).
ProcessInboundEmailRequest | Contains the data that is needed to process the email responses from a marketing campaign.
ProcessInboundEmailResponse | Contains the response from the ProcessInboundEmailRequest class.
ProcessOneMemberBulkOperationRequest | For internal use only.
ProcessOneMemberBulkOperationResponse | For internal use only.
PropagateByExpressionRequest | Contains the data that is needed to create a quick campaign to distribute an activity to accounts, contacts, or leads that are selected by a query.
PropagateByExpressionResponse | Contains the response from the PropagateByExpressionRequest class.
ProposalParty | Represents a party (user, team, or resource) that is needed for the proposed appointment.
ProvisionLanguageRequest | Contains the data that is needed to provision a new language.
ProvisionLanguageResponse | Contains the response from the ProvisionLanguageRequest class.
PublishAllXmlRequest | Contains the data that is needed to publish all changes to solution components.
PublishAllXmlResponse | Contains the response from the PublishAllXmlRequest class.
PublishDuplicateRuleRequest | Contains the data that is needed to submit an asynchronous job to publish a duplicate rule.
PublishDuplicateRuleResponse | Contains the response from the PublishDuplicateRuleRequest class.
PublishProductHierarchyRequest | Contain the data that is needed to publish a product family record and all its child records.
PublishProductHierarchyResponse | Contains the response from the PublishProductHierarchyRequest class.
PublishXmlRequest | Contains the data that is needed to publish specified solution components.
PublishXmlResponse | Contains the response from the PublishXmlRequest class.
QualifyLeadRequest | Contains the data that is needed to qualify a lead and create account, contact, and opportunity records that are linked to the originating lead record.
QualifyLeadResponse | Contains the response from the QualifyLeadRequest class.
QualifyMemberListRequest | Contains the data that is needed to qualify the specified list and either override the list members or remove them according to the specified option.
QualifyMemberListResponse | Contains the response from the QualifyMemberListRequest class.
QueryExpressionToFetchXmlRequest | Contains the data that is needed to convert a query, which is represented as a QueryExpression class, to its equivalent query, which is represented as FetchXML.
QueryExpressionToFetchXmlResponse | Contains the response from the QueryExpressionToFetchXmlRequest class.
QueryMultipleSchedulesRequest | Contains the data that is needed to search multiple resources for available time block that match the specified parameters.
QueryMultipleSchedulesResponse | Contains the response from the QueryMultipleSchedulesRequest class.
QueryScheduleRequest | Contains the data that is needed to search the specified resource for an available time block that matches the specified parameters.
QueryScheduleResponse | Contains response from QueryScheduleRequest.
ReassignObjectsOwnerRequest | Contains the data that is needed to reassign all records that are owned by the security principal (user or team) to another security principal (user or team).
ReassignObjectsOwnerResponse | Contains the response from the ReassignObjectsOwnerRequest class.
ReassignObjectsSystemUserRequest | Contains the data that is needed to reassign all records that are owned by a specified user to another security principal (user or team).
ReassignObjectsSystemUserResponse | Contains the response from the ReassignObjectsSystemUserRequest class.
RecalculateRequest | Contains the data that is needed to recalculate system-computed values for rollup fields in the goal hierarchy.
RecalculateResponse | Contains the response from the RecalculateRequest.
RelationshipAuditDetail | Contains the audited details of a change in a relationship.
ReleaseToQueueRequest | Contains the data that is needed to assign a queue item back to the queue owner so others can pick it.
ReleaseToQueueResponse | Contains the response from the ReleaseToQueueRequest message.
RemoveFromQueueRequest | Contains the data that is needed to remove a queue item from a queue.
RemoveFromQueueResponse | Contains the response from the RemoveFromQueueRequest message.
RemoveItemCampaignActivityRequest | Contains the data that is needed to remove an item from a campaign activity.
RemoveItemCampaignActivityResponse | Contains the response from the RemoveItemCampaignActivityRequest class.
RemoveItemCampaignRequest | Contains the data that is needed to remove an item from a campaign.
RemoveItemCampaignResponse | Contains the response from the RemoveItemCampaignRequest class.
RemoveMemberListRequest | Contains the data that is needed to remove a member from a list (marketing list).
RemoveMemberListResponse | Contains the response from the RemoveMemberListRequest class.
RemoveMembersTeamRequest | Contains the data that is needed to remove members from a team.
RemoveMembersTeamResponse | Contains the response from the RemoveMembersTeamRequest class.
RemoveParentRequest | Contains the data that is needed to remove the parent for a system user (user) record.
RemoveParentResponse | Contains the response from the RemoveParentRequest class.
RemovePrivilegeRoleRequest | Contains the data that is needed to remove a privilege from an existing role.
RemovePrivilegeRoleResponse | Contains the response from the RemovePrivilegeRoleRequest class.
RemoveProductFromKitRequest | Deprecated. Use the ProductAssociation entity. Contains the data that is needed to remove a product from a kit.
RemoveProductFromKitResponse | Deprecated. Use the ProductAssociation entity. Contains the response from the RemoveProductFromKitRequest.
RemoveRelatedRequest | Use the DisassociateRequest class. Contains the data that is needed to remove the relationship between the specified records for specific relationships.
RemoveRelatedResponse | Contains the response from the RemoveRelatedRequest class.
RemoveSolutionComponentRequest | Contains the data that is needed to remove a component from an unmanaged solution.
RemoveSolutionComponentResponse | Contains the response from the RemoveSolutionComponentRequest class.
RemoveSubstituteProductRequest | Deprecated. Use the ProductSubstitute entity.
RemoveSubstituteProductResponse | Deprecated. Use the ProductSubstitute entity.
RemoveUserFromRecordTeamRequest | Contains the data that is needed to remove a user from the auto created access team for the specified record.
RemoveUserFromRecordTeamResponse | Contains the response from the RemoveUserFromRecordTeamRequest class.
RenewContractRequest | Contains the data that is needed to renew a contract and create the contract details for a new contract.
RenewContractResponse | Contains the response from the RenewContractRequest class.
RenewEntitlementRequest | Contains the data that is needed to renew an entitlement.
RenewEntitlementResponse | Contains the response from the RenewEntitlementRequest message.
ReplacePrivilegesRoleRequest | Contains the data that is needed to replace the privilege set of an existing role.
ReplacePrivilegesRoleResponse | Contains the response from the ReplacePrivilegesRoleRequest class.
RequiredResource | Specifies a resource that is required for a scheduling operation.
RescheduleRequest | Contains the data that is needed to reschedule an appointment, recurring appointment, or service appointment (service activity).
RescheduleResponse | Contains the response from the RescheduleRequest class.
ResetUserFiltersRequest | Contains the data that is needed to reset the offline data filters for the calling user to the default filters for the organization.
ResetUserFiltersResponse | Contains the response from the ResetUserFiltersRequest class.
ResourceInfo | Contains information about a resource that has a scheduling problem for an appointment.
RetrieveAbsoluteAndSiteCollectionUrlRequest | Contains the data that is needed to retrieve the absolute URL and the site collection URL for a SharePoint location record in Microsoft Dynamics CRM.
RetrieveAbsoluteAndSiteCollectionUrlResponse | Contains the response from the RetrieveAbsoluteAndSiteCollectionUrlRequest class.
RetrieveAllChildUsersSystemUserRequest | Contains the data that is needed to retrieve the collection of users that report to the specified system user (user).
RetrieveAllChildUsersSystemUserResponse | Contains the response from the RetrieveAllChildUsersSystemUserRequest class.
RetrieveApplicationRibbonRequest | Contains the data that is needed to retrieve the data that defines the content and behavior of the application ribbon.
RetrieveApplicationRibbonResponse | Contains the response from the RetrieveApplicationRibbonRequest class.
RetrieveAttributeChangeHistoryRequest | Contains the data that is needed to retrieve all metadata changes to a specific attribute.
RetrieveAttributeChangeHistoryResponse | Contains the response from the RetrieveAttributeChangeHistoryRequest class.
RetrieveAuditDetailsRequest | Contains the data that is needed to retrieve the full audit details from an Audit record.
RetrieveAuditDetailsResponse | Contains the response from the RetrieveAuditDetailsRequest class.
RetrieveAuditPartitionListRequest | Contains the data that is needed to retrieve the list of database partitions that are used to store audited history data.
RetrieveAuditPartitionListResponse | Contains the response from the RetrieveAuditPartitionListRequest class.
RetrieveAvailableLanguagesRequest | Contains the data that is needed to retrieve the list of language packs that are installed and enabled on the server.
RetrieveAvailableLanguagesResponse | Contains the response from the RetrieveAvailableLanguagesRequest class.
RetrieveBusinessHierarchyBusinessUnitRequest | Contains the data that is needed to retrieve all business units (including the specified business unit) from the business unit hierarchy.
RetrieveBusinessHierarchyBusinessUnitResponse | Contains the response from the RetrieveBusinessHierarchyBusinessUnitRequest class.
RetrieveByGroupResourceRequest | Contains the data that is needed to retrieve all resources that are related to the specified resource group (scheduling group).
RetrieveByGroupResourceResponse | Contains the response from the RetrieveByGroupResourceRequest class.
RetrieveByResourceResourceGroupRequest | Contains the data that is needed to retrieve the resource groups (scheduling groups) that contain the specified resource.
RetrieveByResourceResourceGroupResponse | Contains the response from the RetrieveByResourceResourceGroupRequest class.
RetrieveByResourcesServiceRequest | Contains the data that is needed to retrieve the collection of services that are related to the specified set of resources.
RetrieveByResourcesServiceResponse | Contains the response from the RetrieveByResourcesServiceRequest class.
RetrieveByTopIncidentProductKbArticleRequest | Contains the data that is needed to retrieve the top-ten articles about a specified product from the knowledge base of articles for your organization.
RetrieveByTopIncidentProductKbArticleResponse | Contains the response from the RetrieveByTopIncidentProductKbArticleRequest class.
RetrieveByTopIncidentSubjectKbArticleRequest | Contains the data that is needed to retrieve the top-ten articles about a specified subject from the knowledge base of articles for your organization.
RetrieveByTopIncidentSubjectKbArticleResponse | Contains the response from the RetrieveByTopIncidentSubjectKbArticleRequest class.
RetrieveCurrentOrganizationRequest | Contains the data that’s needed to retrieve information about the current organization.
RetrieveCurrentOrganizationResponse | Contains the response from processing RetrieveCurrentOrganizationRequest.
RetrieveDependenciesForDeleteRequest | Contains the data that is needed to retrieve a collection of dependency records that describe any solution components that would prevent a solution component from being deleted.
RetrieveDependenciesForDeleteResponse | Contains the response from the RetrieveDependenciesForDeleteRequest class.
RetrieveDependenciesForUninstallRequest | Contains the data that is needed to retrieve a list of the solution component dependencies that can prevent you from uninstalling a managed solution.
RetrieveDependenciesForUninstallResponse | Contains the response from the RetrieveDependenciesForUninstallRequest class.
RetrieveDependentComponentsRequest | Contains the data that is needed to retrieves a list dependencies for solution components that directly depend on a solution component.
RetrieveDependentComponentsResponse | Contains the response from the RetrieveDependentComponentsRequest class.
RetrieveDeploymentLicenseTypeRequest | Contains the data that is needed to retrieve the type of license for a deployment of Microsoft Dynamics CRM.
RetrieveDeploymentLicenseTypeResponse | Contains the response from the RetrieveDeploymentLicenseTypeRequest class.
RetrieveDeprovisionedLanguagesRequest | Contains the data that is needed to retrieve a list of language packs that are installed on the server that have been disabled.
RetrieveDeprovisionedLanguagesResponse | Contains the response from the RetrieveDeprovisionedLanguagesRequest class.
RetrieveDuplicatesRequest | Contains the data that is needed to detect and retrieve duplicates for a specified record.
RetrieveDuplicatesResponse | Contains the response from the RetrieveDuplicatesRequest class.
RetrieveEntityRibbonRequest | Contains the data that is needed to retrieve ribbon definitions for an entity.
RetrieveEntityRibbonResponse | Contains the response from the RetrieveEntityRibbonRequest class.
RetrieveExchangeRateRequest | Contains the data that is needed to retrieve the exchange rate.
RetrieveExchangeRateResponse | Contains the response from the RetrieveExchangeRateRequest class.
RetrieveFilteredFormsRequest | Contains the data that is needed to retrieve the entity forms that are available for a specified user.
RetrieveFilteredFormsResponse | Contains the response from the RetrieveFilteredFormsRequest class.
RetrieveFormattedImportJobResultsRequest | Contains the data that is needed to retrieve the formatted results from an import job.
RetrieveFormattedImportJobResultsResponse | Contains the response from the RetrieveFormattedImportJobResultsRequest class.
RetrieveFormXmlRequest | For internal use only.
RetrieveFormXmlResponse | For internal use only.
RetrieveInstalledLanguagePacksRequest | Contains the data that is needed to retrieve the list of language packs that are installed on the server.
RetrieveInstalledLanguagePacksResponse | Contains the response from the RetrieveInstalledLanguagePacksRequest class.
RetrieveInstalledLanguagePackVersionRequest | Contains the data that is needed to retrieve the version of an installed language pack.
RetrieveInstalledLanguagePackVersionResponse | Contains the response from the RetrieveInstalledLanguagePackVersionRequest class.
RetrieveLicenseInfoRequest | Contains the data that is needed to retrieve the number of used and available licenses for a deployment of Microsoft Dynamics CRM.
RetrieveLicenseInfoResponse | Contains the response from the RetrieveLicenseInfoRequest class.
RetrieveLocLabelsRequest | Contains the data that is needed to retrieve localized labels for a limited set of entity attributes.
RetrieveLocLabelsResponse | Contains the response from the RetrieveLocLabelsRequest class.
RetrieveMembersBulkOperationRequest | Contains the data that is needed to retrieve the members of a bulk operation.
RetrieveMembersBulkOperationResponse | Contains the response from the RetrieveMembersBulkOperationRequest class.
RetrieveMembersTeamRequest | Deprecated. Use the RetrieveMultipleRequest class.
RetrieveMembersTeamResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class. Contains the response from the RetrieveMembersTeamRequest class.
RetrieveMissingComponentsRequest | Contains the data that is needed to retrieve a list of missing components in the target organization.
RetrieveMissingComponentsResponse | Contains the response from the RetrieveMissingComponentsRequest class.
RetrieveMissingDependenciesRequest | Contains the data that is needed to retrieve any required solution components that are not included in the solution.
RetrieveMissingDependenciesResponse | Contains the response from the RetrieveMissingDependenciesRequest class.
RetrieveOrganizationResourcesRequest | Contains the data that is needed to retrieve the resources that are used by an organization.
RetrieveOrganizationResourcesResponse | Contains the response from the RetrieveOrganizationResourcesRequest class.
RetrieveParentGroupsResourceGroupRequest | Contains the data needed to retrieve the collection of the parent resource groups of the specified resource group (scheduling group).
RetrieveParentGroupsResourceGroupResponse | Contains the response from the RetrieveParentGroupsResourceGroupRequest class.
RetrieveParsedDataImportFileRequest | Contains the data that is needed to retrieve the data from the parse table.
RetrieveParsedDataImportFileResponse | Contains the response from the RetrieveParsedDataImportFileRequest class.
RetrievePersonalWallRequest | Contains the data that is needed to retrieve pages of posts, including comments for each post, for all records that the calling user is following.
RetrievePersonalWallResponse | Contains the response from the RetrievePersonalWallRequest class.
RetrievePrincipalAccessRequest | Contains the data that is needed to retrieve the access rights of the specified security principal (team or user) to the specified record.
RetrievePrincipalAccessResponse | Contains the response from the RetrievePrincipalAccessRequest class.
RetrievePrincipalAttributePrivilegesRequest | Contains the data that is needed to retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity.
RetrievePrincipalAttributePrivilegesResponse | Contains the response from the RetrievePrincipalAttributePrivilegesRequest class.
RetrievePrincipalSyncAttributeMappingsRequest | This message doesn’t have any extensibility scenarios in this release.
RetrievePrincipalSyncAttributeMappingsResponse | This message doesn’t have any extensibility scenarios in this release.
RetrievePrivilegeSetRequest | Contains the data needed to retrieve the set of privileges defined in the system.
RetrievePrivilegeSetResponse | Contains the response from the RetrievePrivilegeSetRequest class.
RetrieveProductPropertiesRequest | Contains data that is needed to retrieve all the property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.
RetrieveProductPropertiesResponse | Contains the response from the RetrieveProductPropertiesRequest class.
RetrieveProvisionedLanguagePackVersionRequest | Contains the data that is needed to retrieve the version of a provisioned language pack.
RetrieveProvisionedLanguagePackVersionResponse | Contains the response from the RetrieveProvisionedLanguagePackVersionRequest class.
RetrieveProvisionedLanguagesRequest | Contains the data that is needed to retrieve the list of provisioned languages.
RetrieveProvisionedLanguagesResponse | Contains the response from the RetrieveProvisionedLanguagesRequest class.
RetrieveRecordChangeHistoryRequest | Contains the data that is needed to retrieve all attribute data changes for a specific entity.
RetrieveRecordChangeHistoryResponse | Contains the response from the RetrieveRecordChangeHistoryRequest class.
RetrieveRecordWallRequest | Contains the data that is needed to retrieve pages of posts, including comments for each post, for a specified record.
RetrieveRecordWallResponse | Contains the response from the RetrieveRecordWallRequest class.
RetrieveRequiredComponentsRequest | Contains the data that is needed to retrieve a collection of solution components that are required for a solution component.
RetrieveRequiredComponentsResponse | Contains the response from the RetrieveRequiredComponentsRequest class.
RetrieveRolePrivilegesRoleRequest | Contains the data that is needed to retrieve the privileges that are assigned to the specified role.
RetrieveRolePrivilegesRoleResponse | Contains the response from the RetrieveRolePrivilegesRoleRequest class.
RetrieveSharedPrincipalsAndAccessRequest | Contains the data that is needed to retrieve all security principals (users or teams) that have access to, and access rights for, the specified record.
RetrieveSharedPrincipalsAndAccessResponse | Contains the response from the RetrieveSharedPrincipalsAndAccessRequest class.
RetrieveSubGroupsResourceGroupRequest | Contains the data that is needed to retrieve the collection of child resource groups from the specified resource group (scheduling group).
RetrieveSubGroupsResourceGroupResponse | Contains the response from the RetrieveSubGroupsResourceGroupRequest class.
RetrieveSubsidiaryTeamsBusinessUnitRequest | Deprecated. Use the RetrieveMultipleRequest class.Contains the data needed to retrieve a collection of entity instances based on the specified query criteria.
RetrieveSubsidiaryTeamsBusinessUnitResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
RetrieveSubsidiaryUsersBusinessUnitRequest | Deprecated. Use the RetrieveMultipleRequest class.Contains the data needed to retrieve all user information from the child business units of the specified business unit.
RetrieveSubsidiaryUsersBusinessUnitResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.Contains the response from the RetrieveSubsidiaryUsersBusinessUnitRequest message.
RetrieveTeamPrivilegesRequest | Contains the data that is needed to retrieve the privileges for a team.
RetrieveTeamPrivilegesResponse | Contains the response from the RetrieveTeamPrivilegesRequest class.
RetrieveTeamsSystemUserRequest | Deprecated. Use the RetrieveMultipleRequest class.Contains the data needed to retrieve the list of teams of which the specified user is a member.
RetrieveTeamsSystemUserResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.Contains the response from the RetrieveTeamsSystemUserRequest message.
RetrieveUnpublishedMultipleRequest | Contains the data that is needed to retrieve a collection of unpublished organization-owned records that satisfy the specified query criteria.
RetrieveUnpublishedMultipleResponse | Contains the response from the RetrieveUnpublishedMultipleRequest class.
RetrieveUnpublishedRequest | Contains the data that is needed to retrieve an unpublished record.
RetrieveUnpublishedResponse | Contains the response from the RetrieveUnpublishedRequest class.
RetrieveUserPrivilegesRequest | Contains the data needed to retrieve the privileges a system user (user) has through his or her roles in the specified business unit.
RetrieveUserPrivilegesResponse | Contains the response from the RetrieveUserPrivilegesRequest class.
RetrieveUserQueuesRequest | Contains the data needed to retrieve all private queues of a specified user and optionally all public queues.
RetrieveUserQueuesResponse | Contains the response from the RetrieveUserQueuesRequest message.
RetrieveUserSettingsSystemUserRequest | Deprecated. Use the RetrieveMultipleRequest class.Contains the data needed to retrieve the user settings for the specified system user (user).
RetrieveUserSettingsSystemUserResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
RetrieveVersionRequest | Contains the data that is needed to retrieve the version number of the Microsoft Dynamics CRM Server.
RetrieveVersionResponse | Contains the response from the RetrieveVersionRequest class.
RevertProductRequest | Contains the data that is needed to revert changes done to properties of a product family, product, or bundle record, and set it back to its last published (active) state.
RevertProductResponse | Contains the response from the RevertProductRequest class.
ReviseQuoteRequest | Contains the data that is needed to set the state of a quote to Draft.
ReviseQuoteResponse | Contains the response from the ReviseQuoteRequest class.
RevokeAccessRequest | Contains the data that is needed to replace the access rights on the target record for the specified security principal (user or team).
RevokeAccessResponse | Contains the response from the RevokeAccessRequest class.
RolePrivilege | Contains information about a privilege.
RolePrivilegeAuditDetail | Represents audited changes to the privileges of a security role.
RollupRequest | Contains the data that is needed to retrieve all the entity records that are related to the specified record.
RollupResponse | Contains the response from the RollupRequest class.
RouteToRequest | Contains the data that is needed to route a queue item to a queue, a user, or a team.
RouteToResponse | Contains the response from the RouteToRequest message.
SearchByBodyKbArticleRequest | Contains the data that is needed to search for knowledge base articles that contain the specified body text.
SearchByBodyKbArticleResponse | Contains the response from the SearchByBodyKbArticleRequest class.
SearchByKeywordsKbArticleRequest | Contains the data that is needed to search for knowledge base articles that contain the specified keywords.
SearchByKeywordsKbArticleResponse | Contains the response from the SearchByKeywordsKbArticleRequest class.
SearchByTitleKbArticleRequest | Contains the data that is needed to search for knowledge base articles that contain the specified title.
SearchByTitleKbArticleResponse | Contains the response from the SearchByTitleKbArticleRequest class.
SearchRequest | Contains the data needed to search for available time slots that fulfill the specified appointment request.
SearchResponse | Contains the response from the SearchRequest class.
SearchResults | Contains the results from the SearchRequest message.
SendBulkMailRequest | Contains the data that is needed to send bulk email messages.
SendBulkMailResponse | Contains the response from the SendBulkMailRequest class.
SendEmailFromTemplateRequest | Contains the data that is needed to send an email message using a template.
SendEmailFromTemplateResponse | Contains the response from the SendEmailFromTemplateRequest class.
SendEmailRequest | Contains the data that is needed to send an email message.
SendEmailResponse | Contains the response from the BackgroundSendEmailRequest class.
SendFaxRequest | Contains the data that is needed to send a fax.
SendFaxResponse | Contains the response from the SendFaxRequest class.
SendTemplateRequest | Contains the data that is needed to send a bulk email message that is created from a template.
SendTemplateResponse | Contains the response from the SendTemplateRequest class.
SetBusinessEquipmentRequest | Contains the data that is needed to assign equipment (facility/equipment) to a specific business unit.
SetBusinessEquipmentResponse | Contains the response from the SetBusinessEquipmentRequest class.
SetBusinessSystemUserRequest | Contains the data that is needed to move a system user (user) to a different business unit.
SetBusinessSystemUserResponse | Contains the response from the SetBusinessSystemUserRequest class.
SetLocLabelsRequest | Contains the data that is needed to set localized labels for a limited set of entity attributes.
SetLocLabelsResponse | Contains the response from the SetLocLabelsRequest class.
SetParentBusinessUnitRequest | Contains the data that is needed to set the parent business unit for a business unit.
SetParentBusinessUnitResponse | Contains the response from the SetParentBusinessUnitRequest class.
SetParentSystemUserRequest | Contains the data needed to set a new parent system user (user) for the specified user.
SetParentSystemUserResponse | Contains the response from the SetParentSystemUserRequest class.
SetParentTeamRequest | Contains the data needed to set the parent business unit of a team.
SetParentTeamResponse | Contains the response from the SetParentTeamRequest class.
SetRelatedRequest | Contains the data needed to create a relationship between a set of records that participate in specific relationships.
SetRelatedResponse | Contains the response from the SetRelatedRequest class.
SetReportRelatedRequest | Contains the data needed to link an instance of a report entity to related entities.
SetReportRelatedResponse | Contains the response from SetReportRelatedRequest.
SetStateRequest | Contains the data that’s needed to set the state of an entity record.
SetStateResponse | Contains the response from the SetStateRequest class.
ShareAuditDetail | Represents a shared audit detail record.
StatusUpdateBulkOperationRequest | For internal use only.
StatusUpdateBulkOperationResponse | For internal use only.
TimeInfo | Specifies a set of time blocks with appointment information.
TraceInfo | Specifies the results of a scheduling operation using the ValidateRequest, BookRequest, RescheduleRequest, or SearchRequest messages.
TransformImportRequest | Contains the data that is needed to submit an asynchronous job that transforms the parsed data.
TransformImportResponse | Contains the response from the TransformImportRequest class.
TriggerServiceEndpointCheckRequest | Contains the data that is needed to validate the configuration of a Microsoft Azure Service Bus solution’s service endpoint.
TriggerServiceEndpointCheckResponse | Contains the response from the TriggerServiceEndpointCheckRequest.
UninstallSampleDataRequest |
UninstallSampleDataResponse |
UnlockInvoicePricingRequest | Contains the data that is needed to unlock pricing for an invoice.
UnlockInvoicePricingResponse | Contains the response from the UnlockInvoicePricingRequest class.
UnlockSalesOrderPricingRequest | Contains the data that is needed to unlock pricing for a sales order (order).
UnlockSalesOrderPricingResponse | Contains the response from the UnlockSalesOrderPricingRequest class.
UnpublishDuplicateRuleRequest | Contains the data that is needed to submit an asynchronous job to unpublish a duplicate rule.
UnpublishDuplicateRuleResponse | Contains the response from the UnpublishDuplicateRuleRequest class.
UpdateProductPropertiesRequest | Contains the data that is needed to update values of the property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.
UpdateProductPropertiesResponse | Contains the response from the UpdateProductPropertiesRequest class.
UpdateUserSettingsSystemUserRequest | Deprecated. Use the UpdateRequest class.
UpdateUserSettingsSystemUserResponse | Deprecated. Use the UpdateRequest class and its associated response class.
UserAccessAuditDetail | For internal use only.
UtcTimeFromLocalTimeRequest | Contains the data that is needed to retrieve the Coordinated Universal Time (UTC) for the specified local time.
UtcTimeFromLocalTimeResponse | Contains the response from the UtcTimeFromLocalTimeRequest class.
ValidateRecurrenceRuleRequest | Contains the data that is needed to validate a rule for a recurring appointment.
ValidateRecurrenceRuleResponse | Contains the response from the ValidateRecurrenceRuleRequest class.
ValidateRequest | Contains the data that is needed to verify that an appointment or service appointment (service activity) has valid available resources for the activity, duration, and site, as appropriate.
ValidateResponse | Contains the response from the ValidateRequest class.
ValidateSavedQueryRequest | Contains the data that is needed to validate a saved query (view).
ValidateSavedQueryResponse | Contains the response from the ValidateSavedQueryRequest class.
ValidationResult | Contains the result from the ValidateRequest, BookRequest, or RescheduleRequest messages.
VerifyProcessStateDataRequest | For internal use only.
VerifyProcessStateDataResponse | Contains the response from the VerifyProcessStateDataRequest class.
WhoAmIRequest | Contains the data that is needed to retrieve the system user ID for the currently logged on user or the user under whose context the code is running.
WhoAmIResponse | Contains the response from the WhoAmIRequest class.
WinOpportunityRequest | Contains the data that is needed to set the state of an opportunity to Won.
WinOpportunityResponse | Contains the response from the WinOpportunityRequest class.
WinQuoteRequest | Contains the data that is needed to set the state of a quote to Won.
WinQuoteResponse | Contains the response from the WinQuoteRequest class.

Enumerations

Enumeration | Description
AccessRights | Contains the possible access rights for a user.
BulkOperationSource | Contains the possible sources of a bulk operation.
BusinessNotificationParameterType | For internal use only.
BusinessNotificationSeverity | For internal use only.
EntitySource | Describes which members of a bulk operation to retrieve.
PrivilegeDepth | Contains the possible values for the depth of a privilege within a role. This enumeration is used to compare and set values in records returned from Fetch or QueryExpression queries. If you use LINQ, the privilege depth is returned as a bit mask. In this case you can use the following constants to determine the privilege depth. public const int BASIC_MASK = 0x00000001; public const int LOCAL_MASK = 0x00000002; public const int DEEP_MASK = 0x00000004; public const int GLOBAL_MASK = 0x00000008;
PropagationOwnershipOptions | Contains the possible values for propagation ownership options.
RibbonLocationFilters | Contains the values for ribbon filters for an entity.
RollupType | Contains the possible values for the RollupType property in the RollupRequest class, which you use to retrieve all the entity records for a specified record.
SearchDirection | Contains the possible values for the search direction in an appointment request.
SubCode | Contains the possible values for a subcode, used in scheduling appointments.
TargetFieldType | Indicates the attribute type for the target of the InitializeFromRequest message.
TimeCode | Contains the possible values for a time code, used when querying a schedule.


AccessRights Enumeration
[image]

Contains the possible access rights for a user.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FlagsAttribute> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration AccessRights

C#
[FlagsAttribute]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum AccessRights

C++

J#

JScript

  Members
Member name | Description
AppendAccess | The right to append the specified record to another object. Value = 4 (0x04).
AppendToAccess | The right to append another record to the specified object. Value = 16 (0x10).
AssignAccess | The right to assign the specified record to another user or team. Value = 524288 (0x80000).
CreateAccess | The right to create a record. Value = 32 (0x20).
DeleteAccess | The right to delete the specified record. Value = 65536 (0x10000).
None | No access. Value = 0 (0x00).
ReadAccess | The right to read the specified type of record. Value = 1 (0x01).
ShareAccess | The right to share the specified record. Value = 262144 (0x40000).
WriteAccess | The right to update the specified record. Value = 2 (0x02).
  Remarks
This enumeration is used for the AccessMask property.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace
AccessMask
Other Resources
The Security Model of Microsoft Dynamics CRM
Setting Bit Flags


AddItemCampaignActivityRequest Class
See Also Members
[image]

Contains the data that is needed to add an item to a campaign activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddItemCampaignActivityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddItemCampaignActivityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the AddItemCampaignActivityResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the CampaignActivity entity and on the specified entity in the ItemId property. The caller must also have access rights on the specified records in the CampaignActivityId and ItemId properties.
For a complete list of the required privileges, see AddItemCampaignActivity Privileges.
Notes to Callers
The added item must be one of the following entity types: List or SalesLiterature.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddItemCampaignActivityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignActivityResponse
Other Resources
Campaign Entities
Sample: Distribute Campaign Activities to Dynamic and Static Lists
AddItemCampaignActivity Privileges
CampaignActivityItem Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddItemCampaignActivityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add an item to a campaign activity.

The following tables list the members exposed by the AddItemCampaignActivityRequest type.

Public Constructors

Name | Description
AddItemCampaignActivityRequest | Initializes a new instance of the AddItemCampaignActivityRequest class.
Top

Public Properties

 | Name | Description
public property | CampaignActivityId | Gets or sets the ID of the campaign activity. Required.
public property | EntityName | Gets or sets the name of the entity type that is used in the operation. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ItemId | Gets or sets the ID of the item to be added to the campaign activity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddItemCampaignActivityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignActivityResponse

Other Resources

Campaign Entities
Sample: Distribute Campaign Activities to Dynamic and Static Lists
AddItemCampaignActivity Privileges
CampaignActivityItem Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddItemCampaignActivityRequest Constructor
[image]

Initializes a new instance of the AddItemCampaignActivityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddItemCampaignActivityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignActivityRequest Class
AddItemCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddItemCampaignActivityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddItemCampaignActivityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignActivityResponse

Other Resources

Campaign Entities
Sample: Distribute Campaign Activities to Dynamic and Static Lists
AddItemCampaignActivity Privileges
CampaignActivityItem Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddItemCampaignActivityRequest Properties
[image]

Public Properties

 | Name | Description
public property | CampaignActivityId | Gets or sets the ID of the campaign activity. Required.
public property | EntityName | Gets or sets the name of the entity type that is used in the operation. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ItemId | Gets or sets the ID of the item to be added to the campaign activity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

AddItemCampaignActivityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignActivityResponse

Other Resources

Campaign Entities
Sample: Distribute Campaign Activities to Dynamic and Static Lists
AddItemCampaignActivity Privileges
CampaignActivityItem Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddItemCampaignActivityRequest.CampaignActivityId Property
[image]

Gets or sets the ID of the campaign activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CampaignActivityId As Guid

C#
public Guid CampaignActivityId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the campaign activity.

  Remarks
The CampaignActivityId property corresponds to the CampaignActivity.ActivityId attribute, which is the primary key for the CampaignActivity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignActivityRequest Class
AddItemCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddItemCampaignActivityRequest.EntityName Property
[image]

Gets or sets the name of the entity type that is used in the operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type:  String
The name of the entity type that is used in the operation.

  Remarks
This property must be assigned the entity logical name that corresponds to the specified record type in the ItemId property. The valid entity names for this property are SalesLiterature and List.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignActivityRequest Class
AddItemCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
CampaignActivityItem Intersect Entity Metadata


AddItemCampaignActivityRequest.ItemId Property
[image]

Gets or sets the ID of the item to be added to the campaign activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ItemId As Guid

C#
public Guid ItemId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the item to be added to the campaign activity.

  Remarks
The valid values for this property are SalesLiterature.SalesLiteratureId, which is the primary key for the SalesLiterature entity, or List.ListId, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignActivityRequest Class
AddItemCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
CampaignActivityItem Intersect Entity Metadata


AddItemCampaignActivityResponse Class
See Also Members
[image]

Contains the response from the AddItemCampaignActivityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddItemCampaignActivityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddItemCampaignActivityResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddItemCampaignActivityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignActivityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignActivityRequest
Other Resources
Campaign Entities


AddItemCampaignActivityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddItemCampaignActivityRequest class.

The following tables list the members exposed by the AddItemCampaignActivityResponse type.

Public Constructors

Name | Description
AddItemCampaignActivityResponse | Initializes a new instance of the AddItemCampaignActivityResponse class.
Top

Public Properties

 | Name | Description
public property | CampaignActivityItemId | Gets the ID of the resulting campaign activity item.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddItemCampaignActivityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignActivityRequest

Other Resources

Campaign Entities


AddItemCampaignActivityResponse Constructor
[image]

Initializes a new instance of the AddItemCampaignActivityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddItemCampaignActivityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignActivityResponse Class
AddItemCampaignActivityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddItemCampaignActivityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddItemCampaignActivityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignActivityRequest

Other Resources

Campaign Entities


AddItemCampaignActivityResponse Properties
[image]

Public Properties

 | Name | Description
public property | CampaignActivityItemId | Gets the ID of the resulting campaign activity item.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddItemCampaignActivityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignActivityRequest

Other Resources

Campaign Entities


AddItemCampaignActivityResponse.CampaignActivityItemId Property
[image]

Gets the ID of the resulting campaign activity item.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CampaignActivityItemId As Guid

C#
public Guid CampaignActivityItemId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the resulting campaign activity item.

  Remarks
The CampaignActivityItemId property corresponds to the CampaignActivityItem.CampaignActivityItemId property, which is the primary key for the CampaignActivityItem intersect entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignActivityResponse Class
AddItemCampaignActivityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignActivityRequest
Other Resources
CampaignActivityItem Intersect Entity Metadata


AddItemCampaignRequest Class
See Also Members
[image]

Contains the data that is needed to add an item to a campaign.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddItemCampaignRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddItemCampaignRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of the AddItemCampaignResponse class.
Privileges and Access Rights
 To perform this action, the caller must have privileges on the Campaign entity and on the entity that is specified in the EntityId property. The caller must also have access rights on the specified records in the CampaignId and EntityId properties.
 For a complete list of the required privileges, see AddItemCampaign Privileges.
Notes to Callers
The added item must be one of the following entity types: Campaign, List, Product, or SalesLiterature.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddItemCampaignRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignResponse
Other Resources
Campaign Entities
Sample: Distribute Campaign Activities to Dynamic and Static Lists
Sample: Distribute Campaign Activities to Qualified Marketing List
AddItemCampaign Privileges
CampaignItem Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddItemCampaignRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add an item to a campaign.

The following tables list the members exposed by the AddItemCampaignRequest type.

Public Constructors

Name | Description
AddItemCampaignRequest | Initializes a new instance of the AddItemCampaignRequest class.
Top

Public Properties

 | Name | Description
public property | CampaignId | Gets or sets the ID of the campaign. Required.
public property | EntityId | Gets or sets the ID of the record to be added to the campaign. Required.
public property | EntityName | Gets or sets the name of the type of entity that is used in the operation. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddItemCampaignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignResponse

Other Resources

Campaign Entities
Sample: Distribute Campaign Activities to Dynamic and Static Lists
Sample: Distribute Campaign Activities to Qualified Marketing List
AddItemCampaign Privileges
CampaignItem Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddItemCampaignRequest Constructor
[image]

Initializes a new instance of the AddItemCampaignRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddItemCampaignRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignRequest Class
AddItemCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddItemCampaignRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddItemCampaignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignResponse

Other Resources

Campaign Entities
Sample: Distribute Campaign Activities to Dynamic and Static Lists
Sample: Distribute Campaign Activities to Qualified Marketing List
AddItemCampaign Privileges
CampaignItem Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddItemCampaignRequest Properties
[image]

Public Properties

 | Name | Description
public property | CampaignId | Gets or sets the ID of the campaign. Required.
public property | EntityId | Gets or sets the ID of the record to be added to the campaign. Required.
public property | EntityName | Gets or sets the name of the type of entity that is used in the operation. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

AddItemCampaignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignResponse

Other Resources

Campaign Entities
Sample: Distribute Campaign Activities to Dynamic and Static Lists
Sample: Distribute Campaign Activities to Qualified Marketing List
AddItemCampaign Privileges
CampaignItem Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddItemCampaignRequest.CampaignId Property
[image]

Gets or sets the ID of the campaign. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CampaignId As Guid

C#
public Guid CampaignId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the campaign.

  Remarks
The CampaignId property corresponds to the Campaign.CampaignId attribute, which is the primary key for the Campaign entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignRequest Class
AddItemCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddItemCampaignRequest.EntityId Property
[image]

Gets or sets the ID of the record to be added to the campaign. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the record to be added to the campaign.

  Remarks
The EntityId property must be assigned a record ID of one of the following entity types: Campaign, List, Product, or SalesLiterature. The EntityName property must contain the corresponding logical name of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignRequest Class
AddItemCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
CampaignItem Intersect Entity Metadata


AddItemCampaignRequest.EntityName Property
[image]

Gets or sets the name of the type of entity that is used in the operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type:  String
 The name of the type of entity that is used in the operation.

  Remarks
This property must be assigned the logical name of the entity that corresponds to the record type that is specified in the EntityId property. The valid entity names for this property are campaign, list, salesliterature, and product.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignRequest Class
AddItemCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
CampaignItem Intersect Entity Metadata


AddItemCampaignResponse Class
See Also Members
[image]

Contains the response from the AddItemCampaignRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddItemCampaignResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddItemCampaignResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddItemCampaignResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignRequest


AddItemCampaignResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddItemCampaignRequest class.

The following tables list the members exposed by the AddItemCampaignResponse type.

Public Constructors

Name | Description
AddItemCampaignResponse | Initializes a new instance of the AddItemCampaignResponse class.
Top

Public Properties

 | Name | Description
public property | CampaignItemId | Gets the ID of the resulting campaign item.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddItemCampaignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignRequest


AddItemCampaignResponse Constructor
[image]

Initializes a new instance of the AddItemCampaignResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddItemCampaignResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignResponse Class
AddItemCampaignResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddItemCampaignResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddItemCampaignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignRequest


AddItemCampaignResponse Properties
[image]

Public Properties

 | Name | Description
public property | CampaignItemId | Gets the ID of the resulting campaign item.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddItemCampaignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddItemCampaignRequest


AddItemCampaignResponse.CampaignItemId Property
[image]

Gets the ID of the resulting campaign item.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CampaignItemId As Guid

C#
public Guid CampaignItemId { get; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the resulting campaign item.

  Remarks
The CampaignItemId property corresponds to the CampaignItem.CampaignItemId property, which is the primary key for the CampaignItem intersect entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddItemCampaignResponse Class
AddItemCampaignResponse Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
CampaignItem Intersect Entity Metadata


AddListMembersListRequest Class
See Also Example Members
[image]

Contains the data that is needed to add members to the list.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddListMembersListRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddListMembersListRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Add a list of contacts to the marketing list.
var addMemberListReq = new AddListMembersListRequest
{
    MemberIds = new[] { _contactIdList[0], _contactIdList[2] },
    ListId = _marketingListId
};

_serviceProxy.Execute(addMemberListReq);

Console.WriteLine("  Contacts with GUIDs \r\n\t{{{0}}}\r\n\tand {{{1}}}\r\n  were added to the list.",
    _contactIdList[0], _contactIdList[1]);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the AddListMembersListResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the List entity and on the specified entity in the MemberIds property. The caller must also have access rights on the specified records in the ListId property and the MemberIds property. For a complete list of the required privileges, see AddListMembersList Privileges.
Notes for Callers
The members that are added to the list must be of the same type: Account, Contact, or Lead. For example, you cannot add accounts and contacts to the same list.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddListMembersListRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AddListMembersListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddListMembersListResponse
Other Resources
List (Marketing List) Entity
AddListMembersList Privileges
Sample: Distribute Campaign Activities to Qualified Marketing List
List Member Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddListMembersListRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add members to the list.

The following tables list the members exposed by the AddListMembersListRequest type.

Public Constructors

Name | Description
AddListMembersListRequest | Initializes a new instance of the AddListMembersListRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list. Required.
public property | MemberIds | Gets or sets an array of IDs of the members that you want to add to the list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddListMembersListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddListMembersListResponse

Other Resources

List (Marketing List) Entity
AddListMembersList Privileges
Sample: Distribute Campaign Activities to Qualified Marketing List
List Member Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddListMembersListRequest Constructor
[image]

Initializes a new instance of the AddListMembersListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddListMembersListRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddListMembersListRequest Class
AddListMembersListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddListMembersListRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddListMembersListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddListMembersListResponse

Other Resources

List (Marketing List) Entity
AddListMembersList Privileges
Sample: Distribute Campaign Activities to Qualified Marketing List
List Member Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddListMembersListRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list. Required.
public property | MemberIds | Gets or sets an array of IDs of the members that you want to add to the list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

AddListMembersListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddListMembersListResponse

Other Resources

List (Marketing List) Entity
AddListMembersList Privileges
Sample: Distribute Campaign Activities to Qualified Marketing List
List Member Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddListMembersListRequest.ListId Property
[image]

Gets or sets the ID of the list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ListId As Guid

C#
public Guid ListId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the list. This corresponds to the List.ListId attribute, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddListMembersListRequest Class
AddListMembersListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddListMembersListRequest.MemberIds Property
[image]

Gets or sets an array of IDs of the members that you want to add to the list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MemberIds As Guid()

C#
public Guid[] MemberIds { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]

The array of IDs of the members that you want to add to the list.

  Remarks
Each element of the MemberIds array corresponds to the Account.AccountId attribute, Contact.ContactId attribute, or Lead.LeadId attribute. These record IDs are the primary keys for the corresponding entities: Account, Contact, and Lead.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddListMembersListRequest Class
AddListMembersListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
List Member Intersect Entity Metadata


AddListMembersListResponse Class
See Also Members
[image]

Contains the response from the AddListMembersListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddListMembersListResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddListMembersListResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddListMembersListResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddListMembersListResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddListMembersListRequest


AddListMembersListResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddListMembersListRequest class.

The following tables list the members exposed by the AddListMembersListResponse type.

Public Constructors

Name | Description
AddListMembersListResponse | Initializes a new instance of the AddListMembersListResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddListMembersListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddListMembersListRequest


AddListMembersListResponse Constructor
[image]

Initializes a new instance of the AddListMembersListResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddListMembersListResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddListMembersListResponse Class
AddListMembersListResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddListMembersListResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddListMembersListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddListMembersListRequest


AddListMembersListResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddListMembersListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddListMembersListRequest


AddMemberListRequest Class
See Also Example Members
[image]

Contains the data that is needed to add a member to a list (marketing list).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddMemberListRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddMemberListRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the AddMemberListResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the List entity and on the specified entity in the EntityId property. The caller must also have access rights on the specified records in the EntityId and ListId properties.
For a complete list of the required privileges, see AddMemberList Privileges.
Notes for Callers
A member that is added to the list must be of the same type: Account, Contact, or Lead. For example, you cannot add accounts and contacts to the same list.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddMemberListRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddMemberListResponse
Other Resources
AddMemberList Privileges
Campaign Entities
Sample: Distribute a Quick Campaign
List (Marketing List) Entity
List Member Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddMemberListRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add a member to a list (marketing list).

The following tables list the members exposed by the AddMemberListRequest type.

Public Constructors

Name | Description
AddMemberListRequest | Initializes a new instance of the AddMemberListRequest class.
Top

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the member you want to add to the list. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddMemberListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddMemberListResponse

Other Resources

AddMemberList Privileges
Campaign Entities
Sample: Distribute a Quick Campaign
List (Marketing List) Entity
List Member Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddMemberListRequest Constructor
[image]

Initializes a new instance of the AddMemberListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddMemberListRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMemberListRequest Class
AddMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddMemberListRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddMemberListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddMemberListResponse

Other Resources

AddMemberList Privileges
Campaign Entities
Sample: Distribute a Quick Campaign
List (Marketing List) Entity
List Member Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddMemberListRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the member you want to add to the list. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

AddMemberListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddMemberListResponse

Other Resources

AddMemberList Privileges
Campaign Entities
Sample: Distribute a Quick Campaign
List (Marketing List) Entity
List Member Intersect Entity Metadata
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddMemberListRequest.EntityId Property
[image]

Gets or sets the ID of the member you want to add to the list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the member you want to add to the list.

  Remarks
The EntityId property must contain the record ID of one of the following types: Account, Contact, or Lead.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMemberListRequest Class
AddMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
List Member Intersect Entity Metadata


AddMemberListRequest.ListId Property
[image]

Gets or sets the ID of the list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ListId As Guid

C#
public Guid ListId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the list that corresponds to the List.ListId attribute, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMemberListRequest Class
AddMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddMemberListResponse Class
See Also Members
[image]

Contains the response from the AddMemberListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddMemberListResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddMemberListResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddMemberListResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMemberListResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddMemberListRequest


AddMemberListResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddMemberListRequest class.

The following tables list the members exposed by the AddMemberListResponse type.

Public Constructors

Name | Description
AddMemberListResponse | Initializes a new instance of the AddMemberListResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets the ID of the resulting list member.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddMemberListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddMemberListRequest


AddMemberListResponse Constructor
[image]

Initializes a new instance of the AddMemberListResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddMemberListResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMemberListResponse Class
AddMemberListResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddMemberListResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddMemberListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddMemberListRequest


AddMemberListResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets the ID of the resulting list member.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddMemberListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddMemberListRequest


AddMemberListResponse.Id Property
[image]

Gets the ID of the resulting list member.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Id As Guid

C#
public Guid Id { get; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the resulting list member that corresponds to the ListMember.ListMemberId property, which is the primary key for the ListMember intersect entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMemberListResponse Class
AddMemberListResponse Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
List Member Intersect Entity Metadata


AddMembersTeamRequest Class
See Also Members
[image]

Contains the data that is needed to add members to a team.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddMembersTeamRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddMembersTeamRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of the AddMembersTeamResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Team entity and access rights on the specified record in the TeamId property. For a complete list of the required privileges, see AddMembersTeam Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddMembersTeamRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddMembersTeamResponse
Other Resources
User and Team Entities
Team Entity Messages and Methods
AddMembersTeam Privileges


AddMembersTeamRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add members to a team.

The following tables list the members exposed by the AddMembersTeamRequest type.

Public Constructors

Name | Description
AddMembersTeamRequest | Initializes a new instance of the AddMembersTeamRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MemberIds | Gets or sets an array of IDs for the users you want to add to the team. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the ID of the team. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddMembersTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddMembersTeamResponse

Other Resources

User and Team Entities
Team Entity Messages and Methods
AddMembersTeam Privileges


AddMembersTeamRequest Constructor
[image]

Initializes a new instance of the AddMembersTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddMembersTeamRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMembersTeamRequest Class
AddMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddMembersTeamRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddMembersTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddMembersTeamResponse

Other Resources

User and Team Entities
Team Entity Messages and Methods
AddMembersTeam Privileges


AddMembersTeamRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MemberIds | Gets or sets an array of IDs for the users you want to add to the team. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the ID of the team. Required.

See Also

Reference

AddMembersTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddMembersTeamResponse

Other Resources

User and Team Entities
Team Entity Messages and Methods
AddMembersTeam Privileges


AddMembersTeamRequest.MemberIds Property
[image]

Gets or sets an array of IDs for the users you want to add to the team. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MemberIds As Guid()

C#
public Guid[] MemberIds { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]

The array of user IDs to add to the team. Each element of the MemberIds array corresponds to the SystemUser.SystemUserId property, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMembersTeamRequest Class
AddMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddMembersTeamRequest.TeamId Property
[image]

Gets or sets the ID of the team. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TeamId As Guid

C#
public Guid TeamId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the team, that corresponds to the Team.TeamId attribute, which is the primary key for the Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMembersTeamRequest Class
AddMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddMembersTeamResponse Class
See Also Members
[image]

Contains the response from the AddMembersTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddMembersTeamResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddMembersTeamResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddMembersTeamResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMembersTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddMembersTeamRequest


AddMembersTeamResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddMembersTeamRequest class.

The following tables list the members exposed by the AddMembersTeamResponse type.

Public Constructors

Name | Description
AddMembersTeamResponse | Initializes a new instance of the AddMembersTeamResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddMembersTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddMembersTeamRequest


AddMembersTeamResponse Constructor
[image]

Initializes a new instance of the AddMembersTeamResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddMembersTeamResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddMembersTeamResponse Class
AddMembersTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddMembersTeamResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddMembersTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddMembersTeamRequest


AddMembersTeamResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddMembersTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddMembersTeamRequest


AddPrincipalToQueueRequest Class
See Also Members
[image]

Contains the data to add the specified principal to the list of queue members. If the principal is a team, add each team member to the queue.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddPrincipalToQueueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddPrincipalToQueueRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute  method, which returns an instance of the AddPrincipalToQueueResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Queue entity and access rights on the specified record in the QueueId property. For a complete list of the required privileges, see AddPrincipalToQueue message privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddPrincipalToQueueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrincipalToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddPrincipalToQueueResponse
Other Resources
Sample: Add a principal to a queue (early bound)
Queue Entity Messages and Methods


AddPrincipalToQueueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data to add the specified principal to the list of queue members. If the principal is a team, add each team member to the queue.

The following tables list the members exposed by the AddPrincipalToQueueRequest type.

Public Constructors

Name | Description
AddPrincipalToQueueRequest | Initializes a new instance of the AddPrincipalToQueueRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Principal | Gets or sets the principal to add to the queue. Required.
public property | QueueId | Gets or sets the ID of the queue. Required
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddPrincipalToQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrincipalToQueueResponse

Other Resources

Sample: Add a principal to a queue (early bound)
Queue Entity Messages and Methods


AddPrincipalToQueueRequest Constructor
[image]

Initializes a new instance of the AddPrincipalToQueueRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddPrincipalToQueueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrincipalToQueueRequest Class
AddPrincipalToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddPrincipalToQueueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddPrincipalToQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrincipalToQueueResponse

Other Resources

Sample: Add a principal to a queue (early bound)
Queue Entity Messages and Methods


AddPrincipalToQueueRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Principal | Gets or sets the principal to add to the queue. Required.
public property | QueueId | Gets or sets the ID of the queue. Required
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

AddPrincipalToQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrincipalToQueueResponse

Other Resources

Sample: Add a principal to a queue (early bound)
Queue Entity Messages and Methods


AddPrincipalToQueueRequest.Principal Property
[image]

Gets or sets the principal to add to the queue. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Principal As Entity

C#
public Entity Principal { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The principal to add to the queue.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrincipalToQueueRequest Class
AddPrincipalToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddPrincipalToQueueRequest.QueueId Property
[image]

Gets or sets the ID of the queue. Required

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueueId As Guid

C#
public Guid QueueId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the queue.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrincipalToQueueRequest Class
AddPrincipalToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddPrincipalToQueueResponse Class
See Also Members
[image]

Contains the response from the AddPrincipalToQueueRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddPrincipalToQueueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddPrincipalToQueueResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddPrincipalToQueueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrincipalToQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddPrincipalToQueueRequest


AddPrincipalToQueueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddPrincipalToQueueRequest message.

The following tables list the members exposed by the AddPrincipalToQueueResponse type.

Public Constructors

Name | Description
AddPrincipalToQueueResponse | Initializes a new instance of the AddPrincipalToQueueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddPrincipalToQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrincipalToQueueRequest


AddPrincipalToQueueResponse Constructor
[image]

Initializes a new instance of the AddPrincipalToQueueResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddPrincipalToQueueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrincipalToQueueResponse Class
AddPrincipalToQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddPrincipalToQueueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddPrincipalToQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrincipalToQueueRequest


AddPrincipalToQueueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddPrincipalToQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrincipalToQueueRequest


AddPrivilegesRoleRequest Class
See Also Example Members
[image]

Contains the data that is needed to add a set of existing privileges to an existing role.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddPrivilegesRoleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddPrivilegesRoleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationServiceinterface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Add the prvReadAccount privilege to the example roles to assure the
// team can read accounts.
AddPrivilegesRoleRequest addPrivilegesRequest = new AddPrivilegesRoleRequest
{
    RoleId = _roleId,
    Privileges = new[]
    {
        // Grant prvReadAccount privilege.
        new RolePrivilege
        {
            PrivilegeId = readAccountPrivilege.Id
        }
    }
};
_service.Execute(addPrivilegesRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the AddPrivilegesRoleResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Role entity and access rights on the specified record in the RoleId property. For a complete list of the required privileges, see AddPrivilegesRole Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddPrivilegesRoleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AddPrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleResponse
Other Resources
Privilege and Role Entities
Role Entity Messages and Methods
Privilege Entity Messages and Methods
Sample: Assign a Record to a Team
AddPrivilegesRole Privileges


AddPrivilegesRoleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add a set of existing privileges to an existing role.

The following tables list the members exposed by the AddPrivilegesRoleRequest type.

Public Constructors

Name | Description
AddPrivilegesRoleRequest | Initializes a new instance of the AddPrivilegesRoleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Privileges | Gets or sets the IDs and depths of the privileges you want to add. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RoleId | Gets or sets the ID of the role for which you want to add the privileges. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddPrivilegesRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleResponse

Other Resources

Privilege and Role Entities
Role Entity Messages and Methods
Privilege Entity Messages and Methods
Sample: Assign a Record to a Team
AddPrivilegesRole Privileges


AddPrivilegesRoleRequest Constructor
[image]

Initializes a new instance of the AddPrivilegesRoleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddPrivilegesRoleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrivilegesRoleRequest Class
AddPrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddPrivilegesRoleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddPrivilegesRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleResponse

Other Resources

Privilege and Role Entities
Role Entity Messages and Methods
Privilege Entity Messages and Methods
Sample: Assign a Record to a Team
AddPrivilegesRole Privileges


AddPrivilegesRoleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Privileges | Gets or sets the IDs and depths of the privileges you want to add. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RoleId | Gets or sets the ID of the role for which you want to add the privileges. Required.

See Also

Reference

AddPrivilegesRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleResponse

Other Resources

Privilege and Role Entities
Role Entity Messages and Methods
Privilege Entity Messages and Methods
Sample: Assign a Record to a Team
AddPrivilegesRole Privileges


AddPrivilegesRoleRequest.Privileges Property
[image]

Gets or sets the IDs and depths of the privileges you want to add. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Privileges As RolePrivilege()

C#
public RolePrivilege[] Privileges { get; set; }

C++

J#

JScript

Property Value
Type: RolePrivilege
The IDs and depths of the privileges you want to add.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrivilegesRoleRequest Class
AddPrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddPrivilegesRoleRequest.RoleId Property
[image]

Gets or sets the ID of the role for which you want to add the privileges. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RoleId As Guid

C#
public Guid RoleId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the role for which you want to add the privileges. This corresponds to the Role.RoleId attribute, which is the primary key for the Role entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrivilegesRoleRequest Class
AddPrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddPrivilegesRoleResponse Class
See Also Members
[image]

Contains the response from the AddPrivilegesRoleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddPrivilegesRoleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddPrivilegesRoleResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddPrivilegesRoleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrivilegesRoleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleRequest


AddPrivilegesRoleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddPrivilegesRoleRequest class.

The following tables list the members exposed by the AddPrivilegesRoleResponse type.

Public Constructors

Name | Description
AddPrivilegesRoleResponse | Initializes a new instance of the AddPrivilegesRoleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddPrivilegesRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleRequest


AddPrivilegesRoleResponse Constructor
[image]

Initializes a new instance of the AddPrivilegesRoleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddPrivilegesRoleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddPrivilegesRoleResponse Class
AddPrivilegesRoleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddPrivilegesRoleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddPrivilegesRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleRequest


AddPrivilegesRoleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddPrivilegesRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleRequest


AddProductToKitRequest Class
See Also Members
[image]

Deprecated. Use the ProductAssociation entity. Contains the data that is needed to add a product to a kit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddProductToKitRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddProductToKitRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the AddProductToKitResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Product entity and access rights on the specified records in the KitId and ProductId properties.
For a complete list of the required privileges, see AddProductToKit Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddProductToKitRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddProductToKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddProductToKitResponse
Other Resources
Bundles and kits
Product Catalog Entities
AddProductToKit Privileges
Product Entity Messages and Methods


AddProductToKitRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the ProductAssociation entity. Contains the data that is needed to add a product to a kit.

The following tables list the members exposed by the AddProductToKitRequest type.

Public Constructors

Name | Description
AddProductToKitRequest | Initializes a new instance of the AddProductToKitRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | KitId | Gets or sets the ID of the kit. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddProductToKitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddProductToKitResponse

Other Resources

Bundles and kits
Product Catalog Entities
AddProductToKit Privileges
Product Entity Messages and Methods


AddProductToKitRequest Constructor
[image]

Initializes a new instance of the AddProductToKitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddProductToKitRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddProductToKitRequest Class
AddProductToKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddProductToKitRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddProductToKitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddProductToKitResponse

Other Resources

Bundles and kits
Product Catalog Entities
AddProductToKit Privileges
Product Entity Messages and Methods


AddProductToKitRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | KitId | Gets or sets the ID of the kit. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

AddProductToKitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddProductToKitResponse

Other Resources

Bundles and kits
Product Catalog Entities
AddProductToKit Privileges
Product Entity Messages and Methods


AddProductToKitRequest.KitId Property
[image]

Gets or sets the ID of the kit. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property KitId As Guid

C#
public Guid KitId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the kit that corresponds to the Product.ProductId attribute, which is the primary key for the Product entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddProductToKitRequest Class
AddProductToKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddProductToKitRequest.ProductId Property
[image]

Gets or sets the ID of the product. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ProductId As Guid

C#
public Guid ProductId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the product that corresponds to the Product.ProductId attribute, which is the primary key for the Product entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddProductToKitRequest Class
AddProductToKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddProductToKitResponse Class
See Also Members
[image]

Deprecated. Use the ProductAssociation entity. Contains the response from the AddProductToKitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddProductToKitResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddProductToKitResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddProductToKitResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddProductToKitResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddProductToKitRequest
Other Resources
Bundles and kits


AddProductToKitResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the ProductAssociation entity. Contains the response from the AddProductToKitRequest class.

The following tables list the members exposed by the AddProductToKitResponse type.

Public Constructors

Name | Description
AddProductToKitResponse | Initializes a new instance of the AddProductToKitResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddProductToKitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddProductToKitRequest

Other Resources

Bundles and kits


AddProductToKitResponse Constructor
[image]

Initializes a new instance of the AddProductToKitResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddProductToKitResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddProductToKitResponse Class
AddProductToKitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddProductToKitResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddProductToKitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddProductToKitRequest

Other Resources

Bundles and kits


AddProductToKitResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddProductToKitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddProductToKitRequest

Other Resources

Bundles and kits


AddRecurrenceRequest Class
See Also Example Members
[image]

Contains the data that is needed to add recurrence information to an existing appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddRecurrenceRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddRecurrenceRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Specify the recurrence information that needs to be added to the
// existing appointment.
// 1.  Define an anonymous type to define the possible recurrence pattern values.
var RecurrencePatternTypes = new
{
    Daily = 0,
    Weekly = 1,
    Monthly = 2,
    Yearly = 3
};

// 2.  Define an anonymous type to define the possible values for days
// of the week
var DayOfWeek = new
{
    Sunday = 0x01,
    Monday = 0x02,
    Tuesday = 0x04,
    Wednesday = 0x08,
    Thursday = 0x10,
    Friday = 0x20,
    Saturday = 0x40
};

// 3.  Define an anonymous type to define the possible values
// for the recurrence rule pattern end type.
var RecurrenceRulePatternEndType = new
{
    NoEndDate = 1,
    Occurrences = 2,
    PatternEndDate = 3
};

// 4.  Finally, use a recurring appointment master object to specify
//     the recurrence information. Other appointment details such as
//     'subject' and 'location' are copied from the existing appointment
//     to the recurring appointment master object.

RecurringAppointmentMaster newRecurringAppointmentInfo = new RecurringAppointmentMaster
    {
        StartTime = DateTime.Now.AddHours(2),
        EndTime = DateTime.Now.AddHours(3),
        RecurrencePatternType = new OptionSetValue(RecurrencePatternTypes.Weekly),
        Interval = 1,
        DaysOfWeekMask = DayOfWeek.Thursday,
        PatternStartDate = DateTime.Today,
        PatternEndType = new OptionSetValue(RecurrenceRulePatternEndType.Occurrences),
        Occurrences = 5
    };

// Use the AddRecurrence message to convert the existing appointment
// object to a recurring appointment master object. The existing
// appointment object is deleted thereafter.

AddRecurrenceRequest recurringInfoRequest = new AddRecurrenceRequest
{
    Target = newRecurringAppointmentInfo,
    AppointmentId = _appointmentId
};

AddRecurrenceResponse recurringInfoResponse = (AddRecurrenceResponse)_serviceProxy.Execute(recurringInfoRequest);
__recurringAppointmentMasterId = recurringInfoResponse.id;

// Verify that the newly created recurring appointment master has same 'subject'
// as the existing appointment.

RecurringAppointmentMaster retrievedMasterAppointment = (RecurringAppointmentMaster)_serviceProxy.Retrieve(RecurringAppointmentMaster.EntityLogicalName, __recurringAppointmentMasterId, new ColumnSet(true));
if (retrievedMasterAppointment.Subject == "Sample Appointment")
{
    Console.WriteLine("Sample Appointment is converted to a recurring appointment.");
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the AddRecurrenceResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the RecurringAppointmentMaster and Appointment entities, and access rights on the specified record in the Target property. For a complete list of the required privileges, see AddRecurrence Privileges.
Notes for Callers
When you convert an existing appointment to a recurring appointment by using this message, the data from the existing appointment is copied to a new recurring appointment master instance, and the existing appointment record is deleted.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddRecurrenceRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AddRecurrenceRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddRecurrenceResponse
Other Resources
Create a Recurring Appointment Series, Instance or Exception
RecurringAppointmentMaster Entity Messages and Methods
AddRecurrence Privileges
Sample: Convert an Appointment to a Recurring Appointment


AddRecurrenceRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add recurrence information to an existing appointment.

The following tables list the members exposed by the AddRecurrenceRequest type.

Public Constructors

Name | Description
AddRecurrenceRequest | Initializes a new instance of the AddRecurrenceRequest class.
Top

Public Properties

 | Name | Description
public property | AppointmentId | Gets or sets the ID of the appointment that needs to be converted into a recurring appointment. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target, which is a recurring appointment master record to which the appointment is converted. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddRecurrenceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddRecurrenceResponse

Other Resources

Create a Recurring Appointment Series, Instance or Exception
RecurringAppointmentMaster Entity Messages and Methods
AddRecurrence Privileges
Sample: Convert an Appointment to a Recurring Appointment


AddRecurrenceRequest Constructor
[image]

Initializes a new instance of the AddRecurrenceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddRecurrenceRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddRecurrenceRequest Class
AddRecurrenceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddRecurrenceRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddRecurrenceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddRecurrenceResponse

Other Resources

Create a Recurring Appointment Series, Instance or Exception
RecurringAppointmentMaster Entity Messages and Methods
AddRecurrence Privileges
Sample: Convert an Appointment to a Recurring Appointment


AddRecurrenceRequest Properties
[image]

Public Properties

 | Name | Description
public property | AppointmentId | Gets or sets the ID of the appointment that needs to be converted into a recurring appointment. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target, which is a recurring appointment master record to which the appointment is converted. Required.

See Also

Reference

AddRecurrenceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddRecurrenceResponse

Other Resources

Create a Recurring Appointment Series, Instance or Exception
RecurringAppointmentMaster Entity Messages and Methods
AddRecurrence Privileges
Sample: Convert an Appointment to a Recurring Appointment


AddRecurrenceRequest.AppointmentId Property
[image]

Gets or sets the ID of the appointment that needs to be converted into a recurring appointment. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AppointmentId As Guid

C#
public Guid AppointmentId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the appointment that needs to be converted into a recurring appointment. This corresponds to the Appointment.ActivityId attribute, which is the primary key for the Appointment entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddRecurrenceRequest Class
AddRecurrenceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddRecurrenceRequest.Target Property
[image]

Gets or sets the target, which is a recurring appointment master record to which the appointment is converted. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The target, which must be an entity reference for a RecurringAppointmentMaster entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddRecurrenceRequest Class
AddRecurrenceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddRecurrenceResponse Class
See Also Members
[image]

Contains the response from the AddRecurrenceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddRecurrenceResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddRecurrenceResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddRecurrenceResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddRecurrenceResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddRecurrenceRequest
Other Resources
AddRecurrence Privileges
Create a Recurring Appointment Series, Instance or Exception


AddRecurrenceResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddRecurrenceRequest class.

The following tables list the members exposed by the AddRecurrenceResponse type.

Public Constructors

Name | Description
AddRecurrenceResponse | Initializes a new instance of the AddRecurrenceResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Gets the ID of the newly created recurring appointment.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddRecurrenceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddRecurrenceRequest

Other Resources

AddRecurrence Privileges
Create a Recurring Appointment Series, Instance or Exception


AddRecurrenceResponse Constructor
[image]

Initializes a new instance of the AddRecurrenceResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddRecurrenceResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddRecurrenceResponse Class
AddRecurrenceResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddRecurrenceResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddRecurrenceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddRecurrenceRequest

Other Resources

AddRecurrence Privileges
Create a Recurring Appointment Series, Instance or Exception


AddRecurrenceResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Gets the ID of the newly created recurring appointment.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddRecurrenceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddRecurrenceRequest

Other Resources

AddRecurrence Privileges
Create a Recurring Appointment Series, Instance or Exception


AddRecurrenceResponse.id Property
[image]

Gets the ID of the newly created recurring appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property id As Guid

C#
public Guid id { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the newly created recurring appointment. This corresponds to the RecurringAppointmentMaster.ActivityId attribute, which is the primary key for the RecurringAppointmentMaster entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddRecurrenceResponse Class
AddRecurrenceResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddSolutionComponentRequest Class
See Also Example Members
[image]

Contains the data that is needed to add a solution component to an unmanaged solution.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddSolutionComponentRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddSolutionComponentRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
The following code example adds the account entity to a solution that is specified in the SolutionUniqueName property.
C#    Copy Code
// Add an existing Solution Component
//Add the Account entity to the solution
RetrieveEntityRequest retrieveForAddAccountRequest = new RetrieveEntityRequest()
{
    LogicalName = Account.EntityLogicalName
};
RetrieveEntityResponse retrieveForAddAccountResponse = (RetrieveEntityResponse)_serviceProxy.Execute(retrieveForAddAccountRequest);
AddSolutionComponentRequest addReq = new AddSolutionComponentRequest()
{
    ComponentType = (int)componenttype.Entity,
    ComponentId = (Guid)retrieveForAddAccountResponse.EntityMetadata.MetadataId,
    SolutionUniqueName = solution.UniqueName
};
_serviceProxy.Execute(addReq);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of AddSolutionComponentResponse class.
Privileges and Access Rights
To perform this action, the caller must have the privileges that are listed in AddSolutionComponent Privileges.
Notes for Callers
The componenttype enumeration defines the supported range of values for this property. You can access the available values by including the  SampleCode\CS\HelperCode\OptionSets.cs file or the SampleCode\VB\HelperCode\OptionSets.vb file in your project.
An alternative to using this message is to create or update the solution component for a specific solution. When you use this technique, you add the solution component to both the default solution and the specified solution. You can implement the specific-solution technique in two ways.
  • Use the SolutionUniqueName parameter on the solution component create and update requests.
  • Pass the SolutionUniqueName optional parameter to the CreateRequest or UpdateRequest.
Use the SolutionUniqueName parameter on the solution component create and update requests.
For solution components that have a create or update request message that includes the SolutionUniqueName property, passing the unique name of the solution adds the solution component to that solution. The following messages include a SolutionUniqueName property:
  • CreateAttributeRequest
  • UpdateAttributeRequest
  • CreateEntityRequest
  • UpdateEntityRequest
  • CreateManyToManyRequest
  • CreateOneToManyRequest
  • UpdateRelationshipRequest
  • CreateOptionSetRequest
  • UpdateOptionSetRequest
  • UpdateOptionValueRequest
  • InsertOptionValueRequest
  • InsertStatusValueRequest
  • OrderOptionRequest
Pass the SolutionUniqueName optional parameter to the CreateRequest or UpdateRequest.
For other solution components, add “SolutionUniqueName” as a parameter to the Parameters property when you use the CreateRequest or UpdateRequest messages.  For more information, see Pass Optional Parameters in Messages.
Supported Entities
This message can only be used for valid solution components.
Adding Application Ribbons to a Solution.
When you use AddSolutionComponentRequest to add application ribbons to your solution, you must make sure to include the RibbonCustomization solution component that is associated with the active solution. Use the Active Solution.SolutionId in the query expression you use to retrieve the RibbonCustomization record.
C#    Copy Code
QueryExpression query = new QueryExpression("ribboncustomization");
query.ColumnSet = new ColumnSet("ribboncustomizationid");
query.Criteria = new FilterExpression();
query.Criteria.AddCondition("entity", ConditionOperator.Null);
query.Criteria.AddCondition("solutionid", ConditionOperator.Equal, new Guid("{FD140AAE-4DF4-11DD-BD17-0019B9312238}"));
RetrieveMultipleRequest req = new RetrieveMultipleRequest();
req.Query = query;
RetrieveMultipleResponse resp = (RetrieveMultipleResponse)_context.Execute(req);
RibbonCustomization activeRibbonCustomization = (RibbonCustomization)resp.EntityCollection[0];

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddSolutionComponentRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AddSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddSolutionComponentResponse
Other Resources
AddSolutionComponent Privileges
Sample: Work With Solutions
Work with Solutions
SolutionComponent Entity Messages and Methods
Dependency Tracking for Solution Components
Constant SolutionId Values


AddSolutionComponentRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add a solution component to an unmanaged solution.

The following tables list the members exposed by the AddSolutionComponentRequest type.

Public Constructors

Name | Description
AddSolutionComponentRequest | Initializes a new instance of the AddSolutionComponentRequest class.
Top

Public Properties

 | Name | Description
public property | AddRequiredComponents | Gets or sets a value that indicates whether other solution components that are required by the solution component that you are adding should also be added to the unmanaged solution. Required.
public property | ComponentId | Gets or sets the ID of the solution component. Required.
public property | ComponentType | Gets or sets the value that represents the solution component that you are adding. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the unique name of the solution you are adding the solution component to. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddSolutionComponentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddSolutionComponentResponse

Other Resources

AddSolutionComponent Privileges
Sample: Work With Solutions
Work with Solutions
SolutionComponent Entity Messages and Methods
Dependency Tracking for Solution Components
Constant SolutionId Values


AddSolutionComponentRequest Constructor
[image]

Initializes a new instance of the AddSolutionComponentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddSolutionComponentRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSolutionComponentRequest Class
AddSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddSolutionComponentRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddSolutionComponentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddSolutionComponentResponse

Other Resources

AddSolutionComponent Privileges
Sample: Work With Solutions
Work with Solutions
SolutionComponent Entity Messages and Methods
Dependency Tracking for Solution Components
Constant SolutionId Values


AddSolutionComponentRequest Properties
[image]

Public Properties

 | Name | Description
public property | AddRequiredComponents | Gets or sets a value that indicates whether other solution components that are required by the solution component that you are adding should also be added to the unmanaged solution. Required.
public property | ComponentId | Gets or sets the ID of the solution component. Required.
public property | ComponentType | Gets or sets the value that represents the solution component that you are adding. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the unique name of the solution you are adding the solution component to. Required.

See Also

Reference

AddSolutionComponentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddSolutionComponentResponse

Other Resources

AddSolutionComponent Privileges
Sample: Work With Solutions
Work with Solutions
SolutionComponent Entity Messages and Methods
Dependency Tracking for Solution Components
Constant SolutionId Values


AddSolutionComponentRequest.AddRequiredComponents Property
[image]

Gets or sets a value that indicates whether other solution components that are required by the solution component that you are adding should also be added to the unmanaged solution. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AddRequiredComponents As Boolean

C#
public bool AddRequiredComponents { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the components that are required by the solution component you are adding should also be added to the unmanaged solution; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSolutionComponentRequest Class
AddSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddSolutionComponentRequest.ComponentId Property
[image]

Gets or sets the ID of the solution component. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ComponentId As Guid

C#
public Guid ComponentId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the solution component.

  Remarks
For solution components that derive from MetadataBase, this value is the MetadataId property.
For other solution components, use the property that is the unique identifier for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSolutionComponentRequest Class
AddSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddSolutionComponentRequest.ComponentType Property
[image]

Gets or sets the value that represents the solution component that you are adding. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ComponentType As Integer

C#
public int ComponentType { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The integer value of the componenttype enumeration.

  Remarks
An enumeration named componenttype that defines the supported range of values for this property is available by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project. These values are defined by the global option set Component Type (componenttype).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSolutionComponentRequest Class
AddSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddSolutionComponentRequest.SolutionUniqueName Property
[image]

Gets or sets the unique name of the solution you are adding the solution component to. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String

The unique name of the solution you are adding the solution component to.

  Remarks
This value can be found in the Solution.UniqueName attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSolutionComponentRequest Class
AddSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddSolutionComponentResponse Class
See Also Members
[image]

Contains the response from the AddSolutionComponentRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddSolutionComponentResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddSolutionComponentResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddSolutionComponentResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSolutionComponentResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddSolutionComponentRequest


AddSolutionComponentResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddSolutionComponentRequest message.

The following tables list the members exposed by the AddSolutionComponentResponse type.

Public Constructors

Name | Description
AddSolutionComponentResponse | Initializes a new instance of the AddSolutionComponentResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Returns the ID of the new solution component record.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddSolutionComponentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddSolutionComponentRequest


AddSolutionComponentResponse Constructor
[image]

Initializes a new instance of the AddSolutionComponentResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddSolutionComponentResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSolutionComponentResponse Class
AddSolutionComponentResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddSolutionComponentResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddSolutionComponentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddSolutionComponentRequest


AddSolutionComponentResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Returns the ID of the new solution component record.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddSolutionComponentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddSolutionComponentRequest


AddSolutionComponentResponse.id Property
[image]

Returns the ID of the new solution component record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property id As Guid

C#
public Guid id { get; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the new solution component record. This corresponds to the SolutionComponent. SolutionComponentId attribute, which is the primary key for the SolutionComponent entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSolutionComponentResponse Class
AddSolutionComponentResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddSolutionComponentRequest


AddSubstituteProductRequest Class
See Also Members
[image]

Deprecated. Use the AssociateRequest class. Adds a link between two entity instances in a many-to-many relationship.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddSubstituteProductRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddSubstituteProductRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddSubstituteProductRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSubstituteProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddSubstituteProductResponse
Other Resources
AddSubstituteProduct Privileges


AddSubstituteProductRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the AssociateRequest class. Adds a link between two entity instances in a many-to-many relationship.

The following tables list the members exposed by the AddSubstituteProductRequest type.

Public Constructors

Name | Description
AddSubstituteProductRequest | Deprecated. Use the AssociateRequest class and its members.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Deprecated. Use the AssociateRequest class and its members.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SubstituteId | Deprecated. Use the AssociateRequest class and its members.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddSubstituteProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddSubstituteProductResponse

Other Resources

AddSubstituteProduct Privileges


AddSubstituteProductRequest Constructor
[image]

Deprecated. Use the AssociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddSubstituteProductRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSubstituteProductRequest Class
AddSubstituteProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddSubstituteProductRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddSubstituteProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddSubstituteProductResponse

Other Resources

AddSubstituteProduct Privileges


AddSubstituteProductRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Deprecated. Use the AssociateRequest class and its members.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SubstituteId | Deprecated. Use the AssociateRequest class and its members.

See Also

Reference

AddSubstituteProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddSubstituteProductResponse

Other Resources

AddSubstituteProduct Privileges


AddSubstituteProductRequest.ProductId Property
[image]

Deprecated. Use the AssociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ProductId As Guid

C#
public Guid ProductId { get; set; }

C++

J#

JScript

Property Value
Type: Guid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSubstituteProductRequest Class
AddSubstituteProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddSubstituteProductRequest.SubstituteId Property
[image]

Deprecated. Use the AssociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SubstituteId As Guid

C#
public Guid SubstituteId { get; set; }

C++

J#

JScript

Property Value
Type: Guid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSubstituteProductRequest Class
AddSubstituteProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddSubstituteProductResponse Class
See Also Members
[image]

Deprecated. Use the AssociateRequest class and its associated response class. Contains the response from the AddSubstituteProductRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddSubstituteProductResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddSubstituteProductResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddSubstituteProductResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSubstituteProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddSubstituteProductRequest


AddSubstituteProductResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the AssociateRequest class and its associated response class. Contains the response from the AddSubstituteProductRequest class.

The following tables list the members exposed by the AddSubstituteProductResponse type.

Public Constructors

Name | Description
AddSubstituteProductResponse | Deprecated. Use the AssociateRequest class and its associated response class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddSubstituteProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddSubstituteProductRequest


AddSubstituteProductResponse Constructor
[image]

Deprecated. Use the AssociateRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddSubstituteProductResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddSubstituteProductResponse Class
AddSubstituteProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddSubstituteProductResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddSubstituteProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddSubstituteProductRequest


AddSubstituteProductResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddSubstituteProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddSubstituteProductRequest


AddToQueueRequest Class
See Also Example Members
[image]

Contains the data that is needed to move an entity record from a source queue to a destination queue.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddToQueueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddToQueueRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Move a record from a source queue to a destination queue
// by using the AddToQueue request message.
AddToQueueRequest routeRequest = new AddToQueueRequest
{
    SourceQueueId = sourceQueueId,
    Target = new EntityReference(Letter.EntityLogicalName, _letterId),
    DestinationQueueId = destinationQueueId
};

// Execute the Request
_serviceProxy.Execute(routeRequest);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of  the AddToQueueResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Queue and QueueItem entities and on the entity that is referred to in the Target property. You must also have access rights on the source and destination queue records and on the specified record in the Target property. For a complete list of required privileges, see AddToQueue Privileges.
Notes for Callers
Specifying the SourceQueueId property is optional. If the record that is specified by the Target is not in a queue, it is added to the destination queue. If the record is already in a queue, it is moved from the queue to the destination queue. The records cannot be added to multiple queues, except for email records that have the status “Received.” However, a “Received” email record cannot be added multiple times to the same queue.
Specifying the QueueItemProperties property is optional. The minimally required data for creating a queue item is provided in the DestinationQueueId and Target properties. However, if you want to include additional data, such as who works on the case (QueueItem.WorkerId), or to add custom fields, you have to use the QueueItemProperties property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddToQueueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AddToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddToQueueResponse
Other Resources
Queue Entities
Sample: Add a Record to a Queue (Early Bound)
AddToQueue Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddToQueueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to move an entity record from a source queue to a destination queue.

The following tables list the members exposed by the AddToQueueRequest type.

Public Constructors

Name | Description
AddToQueueRequest | Initializes a new instance of the AddToQueueRequest class.
Top

Public Properties

 | Name | Description
public property | DestinationQueueId | Gets or sets the ID of the destination queue. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemProperties | Gets or sets the properties that are needed to create a queue item in the destination queue. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SourceQueueId | Gets or sets the ID of the source queue. Optional.
public property | Target | Gets or sets the target record to add to the destination queue. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddToQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddToQueueResponse

Other Resources

Queue Entities
Sample: Add a Record to a Queue (Early Bound)
AddToQueue Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddToQueueRequest Constructor
[image]

Initializes a new instance of the AddToQueueRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddToQueueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddToQueueRequest Class
AddToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddToQueueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddToQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddToQueueResponse

Other Resources

Queue Entities
Sample: Add a Record to a Queue (Early Bound)
AddToQueue Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddToQueueRequest Properties
[image]

Public Properties

 | Name | Description
public property | DestinationQueueId | Gets or sets the ID of the destination queue. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemProperties | Gets or sets the properties that are needed to create a queue item in the destination queue. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SourceQueueId | Gets or sets the ID of the source queue. Optional.
public property | Target | Gets or sets the target record to add to the destination queue. Required.

See Also

Reference

AddToQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddToQueueResponse

Other Resources

Queue Entities
Sample: Add a Record to a Queue (Early Bound)
AddToQueue Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddToQueueRequest.DestinationQueueId Property
[image]

Gets or sets the ID of the destination queue. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DestinationQueueId As Guid

C#
public Guid DestinationQueueId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the destination queue that corresponds to the Queue.QueueId attribute, which is the primary key for the Queue entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddToQueueRequest Class
AddToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddToQueueRequest.QueueItemProperties Property
[image]

Gets or sets the properties that are needed to create a queue item in the destination queue. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueueItemProperties As Entity

C#
public Entity QueueItemProperties { get; set; }

C++

J#

JScript

Property Value
Type: Entity

The properties that are needed to create a queue item in the destination queue. The destination queue must be an instance of the QueueItem class, which is a subclass of the Entity class.

  Remarks
  Note

                        The QueueItem.QueueId and QueueItem.ObjectId attribute values that are provided in this property are ignored by the operation. These values are obtained from the DestinationQueueId property and the Target property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AddToQueueRequest Class
AddToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddToQueueRequest.SourceQueueId Property
[image]

Gets or sets the ID of the source queue. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SourceQueueId As Guid

C#
public Guid SourceQueueId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the source queue that corresponds to the Queue.QueueId attribute, which is the primary key for the Queue entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddToQueueRequest Class
AddToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddToQueueRequest.Target Property
[image]

Gets or sets the target record to add to the destination queue. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference

The target record to add to the destination queue, which must be an entity reference for an entity that is enabled for queues. For more information, see Enabling Entities for Queues.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddToQueueRequest Class
AddToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddToQueueResponse Class
See Also Members
[image]

Contains the response from the AddToQueueRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddToQueueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddToQueueResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddToQueueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddToQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddToQueueRequest


AddToQueueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddToQueueRequest class.

The following tables list the members exposed by the AddToQueueResponse type.

Public Constructors

Name | Description
AddToQueueResponse | Initializes a new instance of the AddToQueueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | QueueItemId | Gets the ID of the queue item that is created in the destination queue.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddToQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddToQueueRequest


AddToQueueResponse Constructor
[image]

Initializes a new instance of the AddToQueueResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddToQueueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddToQueueResponse Class
AddToQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddToQueueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddToQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddToQueueRequest


AddToQueueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | QueueItemId | Gets the ID of the queue item that is created in the destination queue.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddToQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddToQueueRequest


AddToQueueResponse.QueueItemId Property
[image]

Gets the ID of the queue item that is created in the destination queue.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property QueueItemId As Guid

C#
public Guid QueueItemId { get; }

C++

J#

JScript

Property Value
Type:  Guid

The ID of the queue item that is created in the destination queue,  which corresponds to the QueueItem.QueueItemId attribute, which is the primary key for the QueueItem entity

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddToQueueResponse Class
AddToQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddUserToRecordTeamRequest Class
See Also Members
[image]

Contains the data that is needed to add a user to the auto created access team for the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddUserToRecordTeamRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddUserToRecordTeamRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of the AddUserToRecordTeamResponse class.
Privileges and Access Rights
To perform this action, the caller must have the Share privilege on the entity specified in the Record property. The caller must also have privileges on the SystemUser entity and the TeamTemplate entity and access rights on the records specified in the SystemUserId property and the TeamTemplateId property. In addition, the caller must have access rights on the record specified in the Record property that match access rights specified in the team template. For example, if the team template specifies the Read access right on the account entity, the caller must have the Read access right on the account record, specified in the Record property. For a complete list of required privileges, see AddUserToRecordTeam message privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AddUserToRecordTeamRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddUserToRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AddUserToRecordTeamResponse
Other Resources
AddUserToRecordTeam message privileges
Use Teams to Collaborate and Share Information
User and Team Entities
Team Entity Messages and Methods
TeamTemplate entity messages and methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddUserToRecordTeamRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add a user to the auto created access team for the specified record.

The following tables list the members exposed by the AddUserToRecordTeamRequest type.

Public Constructors

Name | Description
AddUserToRecordTeamRequest | Initializes a new instance of the AddUserToRecordTeamRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Record | Gets or sets the record for which the access team is auto created. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SystemUserId | Gets or sets the ID of system user (user) to add to the auto created access team. Required.
public property | TeamTemplateId | Gets or sets the ID of team template which is used to create the access team. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddUserToRecordTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddUserToRecordTeamResponse

Other Resources

AddUserToRecordTeam message privileges
Use Teams to Collaborate and Share Information
User and Team Entities
Team Entity Messages and Methods
TeamTemplate entity messages and methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddUserToRecordTeamRequest Constructor
[image]

Initializes a new instance of the AddUserToRecordTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddUserToRecordTeamRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddUserToRecordTeamRequest Class
AddUserToRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddUserToRecordTeamRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddUserToRecordTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddUserToRecordTeamResponse

Other Resources

AddUserToRecordTeam message privileges
Use Teams to Collaborate and Share Information
User and Team Entities
Team Entity Messages and Methods
TeamTemplate entity messages and methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddUserToRecordTeamRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Record | Gets or sets the record for which the access team is auto created. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SystemUserId | Gets or sets the ID of system user (user) to add to the auto created access team. Required.
public property | TeamTemplateId | Gets or sets the ID of team template which is used to create the access team. Required.

See Also

Reference

AddUserToRecordTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AddUserToRecordTeamResponse

Other Resources

AddUserToRecordTeam message privileges
Use Teams to Collaborate and Share Information
User and Team Entities
Team Entity Messages and Methods
TeamTemplate entity messages and methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


AddUserToRecordTeamRequest.Record Property
[image]

Gets or sets the record for which the access team is auto created. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Record As EntityReference

C#
public EntityReference Record { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The record for which the access team is auto created, which must be an entity reference for an entity that is enabled for access teams.
To enable an entity for the auto created access teams, set the AutoCreateAccessTeams attribute to true.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddUserToRecordTeamRequest Class
AddUserToRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddUserToRecordTeamRequest.SystemUserId Property
[image]

Gets or sets the ID of system user (user) to add to the auto created access team. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SystemUserId As Guid

C#
public Guid SystemUserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the system user (user) that corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddUserToRecordTeamRequest Class
AddUserToRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddUserToRecordTeamRequest.TeamTemplateId Property
[image]

Gets or sets the ID of team template which is used to create the access team. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TeamTemplateId As Guid

C#
public Guid TeamTemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the team template that corresponds to the TeamTemplate.TeamTemplateId attribute, which is the primary key for the TeamTemplate entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddUserToRecordTeamRequest Class
AddUserToRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AddUserToRecordTeamResponse Class
See Also Members
[image]

Contains the response from the AddUserToRecordTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AddUserToRecordTeamResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AddUserToRecordTeamResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AddUserToRecordTeamResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddUserToRecordTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AddUserToRecordTeamRequest


AddUserToRecordTeamResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddUserToRecordTeamRequest class.

The following tables list the members exposed by the AddUserToRecordTeamResponse type.

Public Constructors

Name | Description
AddUserToRecordTeamResponse | Initializes a new instance of the AddUserToRecordTeamResponse class.
Top

Public Properties

 | Name | Description
public property | AccessTeamId | Gets the ID of the auto created access team.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddUserToRecordTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddUserToRecordTeamRequest


AddUserToRecordTeamResponse Constructor
[image]

Initializes a new instance of the AddUserToRecordTeamResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddUserToRecordTeamResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddUserToRecordTeamResponse Class
AddUserToRecordTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AddUserToRecordTeamResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddUserToRecordTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddUserToRecordTeamRequest


AddUserToRecordTeamResponse Properties
[image]

Public Properties

 | Name | Description
public property | AccessTeamId | Gets the ID of the auto created access team.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AddUserToRecordTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AddUserToRecordTeamRequest


AddUserToRecordTeamResponse.AccessTeamId Property
[image]

Gets the ID of the auto created access team.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AccessTeamId As Guid

C#
public Guid AccessTeamId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the auto created access team, which corresponds to the Team.TeamId attribute, which is the primary key for the Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AddUserToRecordTeamResponse Class
AddUserToRecordTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ApplyRoutingRuleRequest Class
See Also Members
[image]

Contains the data that is needed to apply the active routing rule to an incident.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ApplyRoutingRuleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ApplyRoutingRuleRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of  ApplyRoutingRuleResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Incident entity and access rights on the record specified in the Target property. For a complete list of the privileges required, see ApplyRoutingRule message privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ApplyRoutingRuleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ApplyRoutingRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ApplyRoutingRuleResponse
Other Resources
Incident (Case) Entities


ApplyRoutingRuleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to apply the active routing rule to an incident.

The following tables list the members exposed by the ApplyRoutingRuleRequest type.

Public Constructors

Name | Description
ApplyRoutingRuleRequest | Initializes a new instance of the ApplyRoutingRuleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target incident to apply the routing rule to. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ApplyRoutingRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ApplyRoutingRuleResponse

Other Resources

Incident (Case) Entities


ApplyRoutingRuleRequest Constructor
[image]

Initializes a new instance of the ApplyRoutingRuleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ApplyRoutingRuleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ApplyRoutingRuleRequest Class
ApplyRoutingRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ApplyRoutingRuleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ApplyRoutingRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ApplyRoutingRuleResponse

Other Resources

Incident (Case) Entities


ApplyRoutingRuleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target incident to apply the routing rule to. Required.

See Also

Reference

ApplyRoutingRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ApplyRoutingRuleResponse

Other Resources

Incident (Case) Entities


ApplyRoutingRuleRequest.Target Property
[image]

Gets or sets the target incident to apply the routing rule to. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target incident to apply the routing rule to.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ApplyRoutingRuleRequest Class
ApplyRoutingRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ApplyRoutingRuleResponse Class
See Also Members
[image]

Contains the response from the ApplyRoutingRuleRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ApplyRoutingRuleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ApplyRoutingRuleResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ApplyRoutingRuleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ApplyRoutingRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ApplyRoutingRuleRequest


ApplyRoutingRuleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ApplyRoutingRuleRequest message.

The following tables list the members exposed by the ApplyRoutingRuleResponse type.

Public Constructors

Name | Description
ApplyRoutingRuleResponse | Initializes a new instance of the ApplyRoutingRuleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ApplyRoutingRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ApplyRoutingRuleRequest


ApplyRoutingRuleResponse Constructor
[image]

Initializes a new instance of the ApplyRoutingRuleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ApplyRoutingRuleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ApplyRoutingRuleResponse Class
ApplyRoutingRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ApplyRoutingRuleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ApplyRoutingRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ApplyRoutingRuleRequest


ApplyRoutingRuleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ApplyRoutingRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ApplyRoutingRuleRequest


AppointmentProposal Class
See Also Members
[image]

Represents a proposed appointment time and date as a result of the SearchRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AppointmentProposal
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AppointmentProposal : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.AppointmentProposal
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest
SearchResults


AppointmentProposal Members
See Also Constructors Methods Properties
[image]

Represents a proposed appointment time and date as a result of the SearchRequest message.

The following tables list the members exposed by the AppointmentProposal type.

Public Constructors

Name | Description
AppointmentProposal | Overloaded. Initializes a new instance of the AppointmentProposal class.
Top

Public Properties

 | Name | Description
public property | End | Gets or sets the proposed appointment end date and time.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ProposalParties | Gets or sets an array of parties needed for the proposed appointment.
public property | SiteId | Gets or sets the ID of the site for the proposed appointment.
public property | SiteName | Gets or sets the name of the site for the proposed appointment.
public property | Start | Gets or sets the proposed appointment start date and time.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AppointmentProposal Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest
SearchResults


AppointmentProposal Constructor
[image]

Initializes a new instance of the AppointmentProposal class.

Overload List

Name | Description
AppointmentProposal () | Initializes a new instance of the AppointmentProposal class.
AppointmentProposal (Nullable, Nullable, Guid, String, ProposalParty[]) | Initializes a new instance of the AppointmentProposal class setting the start, end, site ID, site name, and proposal parties.

See Also

Reference

AppointmentProposal Class
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentProposal Constructor ()
[image]

Initializes a new instance of the AppointmentProposal class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AppointmentProposal ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentProposal Class
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentProposal Constructor (Nullable, Nullable, Guid, String, ProposalParty[])
[image]

Initializes a new instance of the AppointmentProposal class setting the start, end, site ID, site name, and proposal parties.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    start As Nullable(Of DateTime), _
    end As Nullable(Of DateTime), _
    siteId As Guid, _
    siteName As String, _
    proposalParties As ProposalParty() _
)

C#
public AppointmentProposal (
    Nullable<DateTime> start,
    Nullable<DateTime> end,
    Guid siteId,
    string siteName,
    ProposalParty[] proposalParties
)

C++

J#

JScript

Parameters
start
Type: Nullable<DateTime>. The proposed appointment start date and time.
end
Type: Nullable<DateTime>. The proposed appointment end date and time.
siteId
Type: Guid. The ID of the site for the proposed appointment.
siteName
Type: String. The name of the site for the proposed appointment.
proposalParties
Type: ProposalParty[]. An array of parties needed for the proposed appointment.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentProposal Class
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentProposal Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AppointmentProposal Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest
SearchResults


AppointmentProposal Properties
[image]

Public Properties

 | Name | Description
public property | End | Gets or sets the proposed appointment end date and time.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ProposalParties | Gets or sets an array of parties needed for the proposed appointment.
public property | SiteId | Gets or sets the ID of the site for the proposed appointment.
public property | SiteName | Gets or sets the name of the site for the proposed appointment.
public property | Start | Gets or sets the proposed appointment start date and time.

See Also

Reference

AppointmentProposal Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest
SearchResults


AppointmentProposal.End Property
[image]

Gets or sets the proposed appointment end date and time.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property End As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> End { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTime>The proposed appointment end date and time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentProposal Class
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentProposal.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentProposal Class
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentProposal.ProposalParties Property
[image]

Gets or sets an array of parties needed for the proposed appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ProposalParties As ProposalParty()

C#
[DataMemberAttribute]
public ProposalParty[] ProposalParties { get; set; }

C++

J#

JScript

Property Value
Type: ProposalParty[]
The array of parties needed for the proposed appointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentProposal Class
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentProposal.SiteId Property
[image]

Gets or sets the ID of the site for the proposed appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SiteId As Guid

C#
[DataMemberAttribute]
public Guid SiteId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the site for the proposed appointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentProposal Class
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentProposal.SiteName Property
[image]

Gets or sets the name of the site for the proposed appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SiteName As String

C#
[DataMemberAttribute]
public string SiteName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the site for the proposed appointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentProposal Class
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentProposal.Start Property
[image]

Gets or sets the proposed appointment start date and time.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Start As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> Start { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTime>
The proposed appointment start date and time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentProposal Class
AppointmentProposal Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest Class
See Also Example Members
[image]

Provides the details of an appointment request for the SearchRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AppointmentRequest
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AppointmentRequest : IExtensibleDataObject

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create the van required resource object.
RequiredResource vanReq = new RequiredResource
{
    ResourceId = _vanId,
    ResourceSpecId = _specId
};

// Create the appointment request.
AppointmentRequest appointmentReq = new AppointmentRequest
{
    RequiredResources = new RequiredResource[] { vanReq },
    Direction = SearchDirection.Backward,
    Duration = 60,
    NumberOfResults = 10,
    ServiceId = _plumberServiceId,
    // The search window describes the time when the resouce can be scheduled.
    // It must be set.
    SearchWindowStart = DateTime.Now.ToUniversalTime(),
    SearchWindowEnd = DateTime.Now.AddDays(7).ToUniversalTime(),
    UserTimeZoneCode = 1
};

// Verify whether there are openings available to schedule the appointment using this resource
SearchRequest search = new SearchRequest
{
    AppointmentRequest = appointmentReq
};
SearchResponse searched = (SearchResponse)_serviceProxy.Execute(search);

if (searched.SearchResults.Proposals.Length > 0)
{
    Console.WriteLine("Openings are available to schedule the resource.");
}

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.AppointmentRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest
Other Resources
Sample: Schedule a Resource


AppointmentRequest Members
See Also Constructors Methods Properties
[image]

Provides the details of an appointment request for the SearchRequest class.

The following tables list the members exposed by the AppointmentRequest type.

Public Constructors

Name | Description
AppointmentRequest | Initializes a new instance of the AppointmentRequest class.
Top

Public Properties

 | Name | Description
public property | AnchorOffset | Gets or sets the time offset in minutes, from midnight, when the first occurrence of the appointment can take place.
public property | AppointmentsToIgnore | Gets or sets the appointments to ignore in the search for possible appointments.
public property | Constraints | Gets or sets any additional constraints.
public property | Direction | Gets or sets the direction of the search.
public property | Duration | Gets or sets the appointment duration, in minutes.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | NumberOfResults | Gets or sets the number of results to be returned from the search request.
public property | Objectives | Gets or sets the scheduling strategy that overrides the default constraints.
public property | RecurrenceDuration | Gets or sets the time, in minutes, for which the appointment recurrence is valid.
public property | RecurrenceTimeZoneCode | Gets or sets a value to override the time zone that is specified by the UserTimeZoneCode property.
public property | RequiredResources | Gets or sets the resources that are needed for this appointment.
public property | SearchRecurrenceRule | Gets or sets the recurrence rule for appointment recurrence.
public property | SearchRecurrenceStart | Gets or sets the date and time for the first possible instance of the appointment.
public property | SearchWindowEnd | Gets or sets the date and time to end the search.
public property | SearchWindowStart | Gets or sets the date and time to begin the search.
public property | ServiceId | Gets or sets the ID of the service to search for.
public property | Sites | Gets or sets the sites where the requested appointment can take place.
public property | UserTimeZoneCode | Gets or sets the time zone code of the user who is requesting the appointment.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AppointmentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest

Other Resources

Sample: Schedule a Resource


AppointmentRequest Constructor
[image]

Initializes a new instance of the AppointmentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AppointmentRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AppointmentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest

Other Resources

Sample: Schedule a Resource


AppointmentRequest Properties
[image]

Public Properties

 | Name | Description
public property | AnchorOffset | Gets or sets the time offset in minutes, from midnight, when the first occurrence of the appointment can take place.
public property | AppointmentsToIgnore | Gets or sets the appointments to ignore in the search for possible appointments.
public property | Constraints | Gets or sets any additional constraints.
public property | Direction | Gets or sets the direction of the search.
public property | Duration | Gets or sets the appointment duration, in minutes.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | NumberOfResults | Gets or sets the number of results to be returned from the search request.
public property | Objectives | Gets or sets the scheduling strategy that overrides the default constraints.
public property | RecurrenceDuration | Gets or sets the time, in minutes, for which the appointment recurrence is valid.
public property | RecurrenceTimeZoneCode | Gets or sets a value to override the time zone that is specified by the UserTimeZoneCode property.
public property | RequiredResources | Gets or sets the resources that are needed for this appointment.
public property | SearchRecurrenceRule | Gets or sets the recurrence rule for appointment recurrence.
public property | SearchRecurrenceStart | Gets or sets the date and time for the first possible instance of the appointment.
public property | SearchWindowEnd | Gets or sets the date and time to end the search.
public property | SearchWindowStart | Gets or sets the date and time to begin the search.
public property | ServiceId | Gets or sets the ID of the service to search for.
public property | Sites | Gets or sets the sites where the requested appointment can take place.
public property | UserTimeZoneCode | Gets or sets the time zone code of the user who is requesting the appointment.

See Also

Reference

AppointmentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest

Other Resources

Sample: Schedule a Resource


AppointmentRequest.AnchorOffset Property
[image]

Gets or sets the time offset in minutes, from midnight, when the first occurrence of the appointment can take place.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AnchorOffset As Integer

C#
[DataMemberAttribute]
public int AnchorOffset { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The time offset in minutes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.AppointmentsToIgnore Property
[image]

Gets or sets the appointments to ignore in the search for possible appointments.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AppointmentsToIgnore As AppointmentsToIgnore()

C#
[DataMemberAttribute]
public AppointmentsToIgnore[] AppointmentsToIgnore { get; set; }

C++

J#

JScript

Property Value
Type: AppointmentsToIgnore
The appointments to ignore in the search for possible appointments.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.Constraints Property
[image]

Gets or sets any additional constraints.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Constraints As ConstraintRelation()

C#
[DataMemberAttribute]
public ConstraintRelation[] Constraints { get; set; }

C++

J#

JScript

Property Value
Type: ConstraintRelation

Additional constraints for the appointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.Direction Property
[image]

Gets or sets the direction of the search.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Direction As SearchDirection

C#
[DataMemberAttribute]
public SearchDirection Direction { get; set; }

C++

J#

JScript

Property Value
Type: SearchDirection

The search direction.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.Duration Property
[image]

Gets or sets the appointment duration, in minutes.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Duration As Integer

C#
[DataMemberAttribute]
public int Duration { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The appointment duration, in minutes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.NumberOfResults Property
[image]

Gets or sets the number of results to be returned from the search request.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property NumberOfResults As Integer

C#
[DataMemberAttribute]
public int NumberOfResults { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The number of results to be returned from the search request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.Objectives Property
[image]

Gets or sets the scheduling strategy that overrides the default constraints.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Objectives As ObjectiveRelation()

C#
[DataMemberAttribute]
public ObjectiveRelation[] Objectives { get; set; }

C++

J#

JScript

Property Value
Type: ObjectiveRelation

The scheduling strategy that overrides the default constraints.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ObjectiveRelation
ObjectiveExpression


AppointmentRequest.RecurrenceDuration Property
[image]

Gets or sets the time, in minutes, for which the appointment recurrence is valid.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RecurrenceDuration As Integer

C#
[DataMemberAttribute]
public int RecurrenceDuration { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The time, in minutes, for which the appointment recurrence is valid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.RecurrenceTimeZoneCode Property
[image]

Gets or sets a value to override the time zone that is specified by the UserTimeZoneCode property.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RecurrenceTimeZoneCode As Integer

C#
[DataMemberAttribute]
public int RecurrenceTimeZoneCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32

A value to override the time zone that is specified by the UserTimeZoneCode property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.RequiredResources Property
[image]

Gets or sets the resources that are needed for this appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RequiredResources As RequiredResource()

C#
[DataMemberAttribute]
public RequiredResource[] RequiredResources { get; set; }

C++

J#

JScript

Property Value
Type: RequiredResource

The resources that are needed for this appointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.SearchRecurrenceRule Property
[image]

Gets or sets the recurrence rule for appointment recurrence.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SearchRecurrenceRule As String

C#
[DataMemberAttribute]
public string SearchRecurrenceRule { get; set; }

C++

J#

JScript

Property Value
Type: String

The recurrence rule.

Example:
"FREQ=WEEKLY;BYDAY=MO;INTERVAL=60";

Where:
BYDAY means which day = MO,TU,TH
INTERVAL is an integer value
FREQ="DAILY","WEEKLY"

This is similar to the   Recurrence Pattern in Asynchronous Job Execution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.SearchRecurrenceStart Property
[image]

Gets or sets the date and time for the first possible instance of the appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SearchRecurrenceStart As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> SearchRecurrenceStart { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTime>

The date and time for the first possible instance of the appointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.SearchWindowEnd Property
[image]

Gets or sets the date and time to end the search.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SearchWindowEnd As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> SearchWindowEnd { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTime>

The date and time to end the search.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.SearchWindowStart Property
[image]

Gets or sets the date and time to begin the search.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SearchWindowStart As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> SearchWindowStart { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTime>

The date and time to begin the search.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.ServiceId Property
[image]

Gets or sets the ID of the service to search for.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ServiceId As Guid

C#
[DataMemberAttribute]
public Guid ServiceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the service, which corresponds to the Service.ServiceId attribute, which is the primary key for the Service entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.Sites Property
[image]

Gets or sets the sites where the requested appointment can take place.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Sites As Guid()

C#
[DataMemberAttribute]
public Guid[] Sites { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]

The array of site IDs,  where the requested appointment can take place. The site ID corresponds to the Site.SiteId attribute, which is the primary key for the Site entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentRequest.UserTimeZoneCode Property
[image]

Gets or sets the time zone code of the user who is requesting the appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UserTimeZoneCode As Integer

C#
[DataMemberAttribute]
public int UserTimeZoneCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The time zone code of the user who is requesting the appointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentRequest Class
AppointmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentsToIgnore Class
See Also Members
[image]

Specifies the appointments to ignore in an appointment request from the SearchRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AppointmentsToIgnore
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AppointmentsToIgnore : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.AppointmentsToIgnore
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentsToIgnore Members
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest


AppointmentsToIgnore Members
See Also Constructors Methods Properties
[image]

Specifies the appointments to ignore in an appointment request from the SearchRequest class.

The following tables list the members exposed by the AppointmentsToIgnore type.

Public Constructors

Name | Description
AppointmentsToIgnore | Overloaded. Initializes a new instance of the AppointmentsToIgnore class.
Top

Public Properties

 | Name | Description
public property | Appointments | Gets or sets an array of IDs of appointments to ignore.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ResourceId | Gets or sets the resource for which appointments are to be ignored.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AppointmentsToIgnore Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest


AppointmentsToIgnore Constructor
[image]

Initializes a new instance of the AppointmentsToIgnore class.

Overload List

Name | Description
AppointmentsToIgnore () | Initializes a new instance of the AppointmentsToIgnore class.
AppointmentsToIgnore (Guid[], Guid) | Initializes a new instance of the AppointmentsToIgnore class setting the appointments and resource ID.

See Also

Reference

AppointmentsToIgnore Class
AppointmentsToIgnore Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentsToIgnore Constructor ()
[image]

Initializes a new instance of the AppointmentsToIgnore class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AppointmentsToIgnore ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentsToIgnore Class
AppointmentsToIgnore Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentsToIgnore Constructor (Guid[], Guid)
[image]

Initializes a new instance of the AppointmentsToIgnore class setting the appointments and resource ID.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    appointments As Guid(), _
    resourceId As Guid _
)

C#
public AppointmentsToIgnore (
    Guid[] appointments,
    Guid resourceId
)

C++

J#

JScript

Parameters
appointments
Type: Guid[]. The array of IDs of appointments to ignore.
resourceId
Type: Guid. The resource for which appointments are to be ignored.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentsToIgnore Class
AppointmentsToIgnore Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentsToIgnore Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AppointmentsToIgnore Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest


AppointmentsToIgnore Properties
[image]

Public Properties

 | Name | Description
public property | Appointments | Gets or sets an array of IDs of appointments to ignore.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ResourceId | Gets or sets the resource for which appointments are to be ignored.

See Also

Reference

AppointmentsToIgnore Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest


AppointmentsToIgnore.Appointments Property
[image]

Gets or sets an array of IDs of appointments to ignore.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Appointments As Guid()

C#
[DataMemberAttribute]
public Guid[] Appointments { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]

The array of IDs of appointments to ignore.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentsToIgnore Class
AppointmentsToIgnore Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentsToIgnore.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentsToIgnore Class
AppointmentsToIgnore Members
Microsoft.Crm.Sdk.Messages Namespace


AppointmentsToIgnore.ResourceId Property
[image]

Gets or sets the resource for which appointments are to be ignored.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResourceId As Guid

C#
[DataMemberAttribute]
public Guid ResourceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The resource for which appointments are to be ignored.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AppointmentsToIgnore Class
AppointmentsToIgnore Members
Microsoft.Crm.Sdk.Messages Namespace


AssignRequest Class
See Also Example Members
[image]

Contains the data that is needed to assign the specified record to a new owner (user or team) by changing the OwnerId attribute of the record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AssignRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AssignRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create the Request Object and Set the Request Object's Properties
AssignRequest assign = new AssignRequest
    {
        Assignee = new EntityReference(SystemUser.EntityLogicalName,
            _otherUserId),
        Target = new EntityReference(Account.EntityLogicalName,
            _accountId)
    };

// Execute the Request
_service.Execute(assign);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of the AssignResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the Target property and access rights on the specified record in the Target property. For a list of the required privileges, see Assign Privileges.
Notes for Callers
This action applies to the parent record and the associated records that have the same owner as the parent record. Therefore, when you assign the parent record to a new owner, only the associated records that have the same owner as the parent record are also assigned.
If the value of the Organization.ShareToPreviousOwnerOnAssign attribute is true, when a record is assigned to a new owner, it is shared with the previous owner with full rights. In this case, either the new owner or the previous owner can remove the relationship or lower the level of privileges that the previous owner has on the record.
For a description of how actions on a parent record affect child records, see Cascading Behavior.
Supported Entities
You can use this message to associate records of any two entities that participate in a relationship, including records for custom entities. You can find the default relationships listed in the Entity Metadata topic for each entity.

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

Entity | Availability
Account | 0 (Server)
Annotation | 0 (Server)
Appointment | 0 (Server)
Campaign | 0 (Server)
CampaignActivity | 0 (Server)
CampaignResponse | 0 (Server)
Connection | 0 (Server)
Contact | 0 (Server)
Contract | 0 (Server)
ConvertRule | 0 (Server)
CustomerOpportunityRole | 0 (Server)
CustomerRelationship | 0 (Server)
DuplicateRule | 0 (Server)
Email | 0 (Server)
EmailServerProfile | 0 (Server)
Entitlement | 0 (Server)
Fax | 0 (Server)
Goal | 0 (Server)
GoalRollupQuery | 0 (Server)
ImportFile | 0 (Server)
ImportMap | 0 (Server)
Incident | 0 (Server)
IncidentResolution | 0 (Server)
Invoice | 0 (Server)
Lead | 0 (Server)
Letter | 0 (Server)
List | 0 (Server)
Mailbox | 0 (Server)
MailMergeTemplate | 0 (Server)
msdyn_PostAlbum | 0 (Server)
msdyn_wallsavedqueryusersettings | 0 (Server)
Opportunity | 0 (Server)
OpportunityClose | 0 (Server)
OrderClose | 0 (Server)
PhoneCall | 0 (Server)
ProcessSession | 0 (Server)
Queue | 0 (Server)
Quote | 0 (Server)
QuoteClose | 0 (Server)
RecurringAppointmentMaster | 0 (Server)
Report | 0 (Server)
RoutingRule | 0 (Server)
SalesOrder | 0 (Server)
ServiceAppointment | 0 (Server)
SharePointDocumentLocation | 0 (Server)
SharePointSite | 0 (Server)
SLA | 0 (Server)
SLAKPIInstance | 0 (Server)
SocialActivity | 0 (Server)
SocialProfile | 0 (Server)
Task | 0 (Server)
Template | 0 (Server)
UserForm | 0 (Server)
UserQuery | 0 (Server)
UserQueryVisualization | 0 (Server)
Workflow | 0 (Server)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AssignRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AssignRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AssignResponse
Other Resources
Actions on Entity Records
Entity Ownership
Sample: Assign a Record to a New Owner
Sample: Assign Record to Team


AssignRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to assign the specified record to a new owner (user or team) by changing the OwnerId attribute of the record.

The following tables list the members exposed by the AssignRequest type.

Public Constructors

Name | Description
AssignRequest | Initializes a new instance of the AssignRequest class.
Top

Public Properties

 | Name | Description
public property | Assignee | Gets or sets the user or team for which you want to assign a record. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record to assign to another user or team. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AssignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AssignResponse

Other Resources

Actions on Entity Records
Entity Ownership
Sample: Assign a Record to a New Owner
Sample: Assign Record to Team


AssignRequest Constructor
[image]

Initializes a new instance of the AssignRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AssignRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignRequest Class
AssignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AssignRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AssignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AssignResponse

Other Resources

Actions on Entity Records
Entity Ownership
Sample: Assign a Record to a New Owner
Sample: Assign Record to Team


AssignRequest Properties
[image]

Public Properties

 | Name | Description
public property | Assignee | Gets or sets the user or team for which you want to assign a record. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record to assign to another user or team. Required.

See Also

Reference

AssignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AssignResponse

Other Resources

Actions on Entity Records
Entity Ownership
Sample: Assign a Record to a New Owner
Sample: Assign Record to Team


AssignRequest.Assignee Property
[image]

Gets or sets the user or team for which you want to assign a record. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Assignee As EntityReference

C#
public EntityReference Assignee { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The reference to a user or team record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignRequest Class
AssignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AssignRequest.Target Property
[image]

Gets or sets the target record to assign to another user or team. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target record to assign. The value must be an entity reference for an entity that supports this message. For a list of supported entity types, see the AssignRequest class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignRequest Class
AssignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AssignResponse Class
See Also Members
[image]

Contains the response from the AssignRequest.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AssignResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AssignResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AssignResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AssignRequest
Other Resources
Assign Privileges
Sample: Assign a Record to a New Owner


AssignResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AssignRequest.

The following tables list the members exposed by the AssignResponse type.

Public Constructors

Name | Description
AssignResponse | Initializes a new instance of the AssignResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AssignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AssignRequest

Other Resources

Assign Privileges
Sample: Assign a Record to a New Owner


AssignResponse Constructor
[image]

Initializes a new instance of the AssignResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AssignResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignResponse Class
AssignResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AssignResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AssignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AssignRequest

Other Resources

Assign Privileges
Sample: Assign a Record to a New Owner


AssignResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AssignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AssignRequest

Other Resources

Assign Privileges
Sample: Assign a Record to a New Owner


AssociateEntitiesRequest Class
See Also Members
[image]

Deprecated. Use the AssociateRequest class. Contains the data that is needed to add a link between two entity instances in a many-to-many relationship.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AssociateEntitiesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AssociateEntitiesRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AssociateEntitiesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AssociateEntitiesResponse


AssociateEntitiesRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the AssociateRequest class. Contains the data that is needed to add a link between two entity instances in a many-to-many relationship.

The following tables list the members exposed by the AssociateEntitiesRequest type.

Public Constructors

Name | Description
AssociateEntitiesRequest | Deprecated. Use the AssociateRequest class and its members.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Moniker1 | Deprecated. Use the AssociateRequest class and its members.
public property | Moniker2 | Deprecated. Use the AssociateRequest class and its members.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelationshipName | Deprecated. Use the AssociateRequest class and its members.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AssociateEntitiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AssociateEntitiesResponse


AssociateEntitiesRequest Constructor
[image]

Deprecated. Use the AssociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AssociateEntitiesRequest ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateEntitiesRequest Class
AssociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AssociateEntitiesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AssociateEntitiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AssociateEntitiesResponse


AssociateEntitiesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Moniker1 | Deprecated. Use the AssociateRequest class and its members.
public property | Moniker2 | Deprecated. Use the AssociateRequest class and its members.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelationshipName | Deprecated. Use the AssociateRequest class and its members.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

AssociateEntitiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AssociateEntitiesResponse


AssociateEntitiesRequest.Moniker1 Property
[image]

Deprecated. Use the AssociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Moniker1 As EntityReference

C#
public EntityReference Moniker1 { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The entity reference for the first record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateEntitiesRequest Class
AssociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AssociateEntitiesRequest.Moniker2 Property
[image]

Deprecated. Use the AssociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Moniker2 As EntityReference

C#
public EntityReference Moniker2 { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The entity reference for the second record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateEntitiesRequest Class
AssociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AssociateEntitiesRequest.RelationshipName Property
[image]

Deprecated. Use the AssociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RelationshipName As String

C#
public string RelationshipName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the relationship between the two entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateEntitiesRequest Class
AssociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AssociateEntitiesResponse Class
See Also Members
[image]

Deprecated. Use the AssociateRequest class and its associated response class. Contains the response from the AssociateEntitiesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AssociateEntitiesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AssociateEntitiesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AssociateEntitiesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateEntitiesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AssociateEntitiesRequest


AssociateEntitiesResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the AssociateRequest class and its associated response class. Contains the response from the AssociateEntitiesRequest class.

The following tables list the members exposed by the AssociateEntitiesResponse type.

Public Constructors

Name | Description
AssociateEntitiesResponse | Deprecated. Use the AssociateRequest class and its associated response class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AssociateEntitiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AssociateEntitiesRequest


AssociateEntitiesResponse Constructor
[image]

Deprecated. Use the AssociateRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AssociateEntitiesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateEntitiesResponse Class
AssociateEntitiesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AssociateEntitiesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AssociateEntitiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AssociateEntitiesRequest


AssociateEntitiesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AssociateEntitiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AssociateEntitiesRequest


AttributeAuditDetail Class
See Also Members
[image]

Contains the details of changes to entity attributes.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AttributeAuditDetail
    Inherits AuditDetail

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AttributeAuditDetail : AuditDetail

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Crm.Sdk.Messages.AuditDetail
    Microsoft.Crm.Sdk.Messages.AttributeAuditDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Sample: Audit Entity Data Changes


AttributeAuditDetail Members
See Also Constructors Methods Properties
[image]

Contains the details of changes to entity attributes.

The following tables list the members exposed by the AttributeAuditDetail type.

Public Constructors

Name | Description
AttributeAuditDetail | Initializes a new instance of the AttributeAuditDetail class.
Top

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | DeletedAttributes | Gets a list of deleted attributes.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | InvalidNewValueAttributes | Gets a collection of attempted attribute changes that are not valid.
public property | LocLabelLanguageCode | Gets or sets the language code for the label.
public property | NewValue | Gets or sets a collection of new values for an entity attribute.
public property | OldValue | Gets or sets a collection of former values for an entity attribute.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AttributeAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Audit Entity Data Changes


AttributeAuditDetail Constructor
[image]

Initializes a new instance of the AttributeAuditDetail class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeAuditDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeAuditDetail Class
AttributeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AttributeAuditDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AttributeAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Audit Entity Data Changes


AttributeAuditDetail Properties
[image]

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | DeletedAttributes | Gets a list of deleted attributes.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | InvalidNewValueAttributes | Gets a collection of attempted attribute changes that are not valid.
public property | LocLabelLanguageCode | Gets or sets the language code for the label.
public property | NewValue | Gets or sets a collection of new values for an entity attribute.
public property | OldValue | Gets or sets a collection of former values for an entity attribute.

See Also

Reference

AttributeAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Audit Entity Data Changes


AttributeAuditDetail.DeletedAttributes Property
[image]

Gets a list of deleted attributes.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public ReadOnly Property DeletedAttributes As Dictionary(Of Integer, String)

C#
[DataMemberAttribute(Order=60)]
public Dictionary<int,string> DeletedAttributes { get; }

C++

J#

JScript

Property Value
Type: Dictionary
A dictionary containing the deleted attributes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeAuditDetail Class
AttributeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AttributeAuditDetail.InvalidNewValueAttributes Property
[image]

Gets a collection of attempted attribute changes that are not valid.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public ReadOnly Property InvalidNewValueAttributes As DataCollection(Of String)

C#
[DataMemberAttribute]
public DataCollection<string> InvalidNewValueAttributes { get; }

C++

J#

JScript

Property Value
Type: DataCollection
The data collection of attempted attribute changes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeAuditDetail Class
AttributeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AttributeAuditDetail.LocLabelLanguageCode Property
[image]

Gets or sets the language code for the label.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property LocLabelLanguageCode As Integer

C#
[DataMemberAttribute(Order=70)]
public int LocLabelLanguageCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The language code for the label.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeAuditDetail Class
AttributeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AttributeAuditDetail.NewValue Property
[image]

Gets or sets a collection of new values for an entity attribute.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property NewValue As Entity

C#
[DataMemberAttribute]
public Entity NewValue { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The collection of new values for an entity attribute.

  Remarks
You can access the individual attribute values in the Entity.Attributes collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeAuditDetail Class
AttributeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Sample: Audit Entity Data Changes


AttributeAuditDetail.OldValue Property
[image]

Gets or sets a collection of former values for an entity attribute.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OldValue As Entity

C#
[DataMemberAttribute]
public Entity OldValue { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The collection of former values for an entity attribute.

  Remarks
You can access the individual attribute values in the Entity.Attributes collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeAuditDetail Class
AttributeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Sample: Audit Entity Data Changes


AuditDetail Class
See Also Members
[image]

Provides a base class for storing the details of data changes.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(ShareAuditDetail))> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
<KnownTypeAttribute(GetType(AttributeAuditDetail))> _
<KnownTypeAttribute(GetType(RelationshipAuditDetail))> _
Public Class AuditDetail
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute(typeof(ShareAuditDetail))]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
[KnownTypeAttribute(typeof(AttributeAuditDetail))]
[KnownTypeAttribute(typeof(RelationshipAuditDetail))]
public class AuditDetail : IExtensibleDataObject

C++

J#

JScript

  Remarks
When you cast an object of this type, use one of its specialized (derived) types: AttributeAuditDetail, RelationshipAuditDetail, RolePrivilegeAuditDetail, or ShareAuditDetail.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.AuditDetail

                Microsoft.Crm.Sdk.Messages.AttributeAuditDetail

                Microsoft.Crm.Sdk.Messages.RelationshipAuditDetail

                Microsoft.Crm.Sdk.Messages.RolePrivilegeAuditDetail

                Microsoft.Crm.Sdk.Messages.ShareAuditDetail

                Microsoft.Crm.Sdk.Messages.UserAccessAuditDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetail Members
See Also Constructors Methods Properties
[image]

Provides a base class for storing the details of data changes.

The following tables list the members exposed by the AuditDetail type.

Public Constructors

Name | Description
AuditDetail | Initializes a new instance of the AuditDetail class.
Top

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace


AuditDetail Constructor
[image]

Initializes a new instance of the AuditDetail class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AuditDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetail Class
AuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace


AuditDetail Properties
[image]

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional.

See Also

Reference

AuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace


AuditDetail.AuditRecord Property
[image]

Gets or sets the related Audit record that contains the change details.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AuditRecord As Entity

C#
[DataMemberAttribute]
public Entity AuditRecord { get; set; }

C++

J#

JScript

Property Value
Type:  Entity
 The audit record.

  Remarks
Cast this property value to an Audit entity type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetail Class
AuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetail.ExtensionData Property
[image]

Gets or sets the structure that contains extra data. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type:  ExtensionDataObject.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetail Class
AuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection Class
See Also Members
[image]

Contains a collection of AuditDetail objects.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DefaultMemberAttribute("Item")> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AuditDetailCollection
    Implements IExtensibleDataObject

C#
[DefaultMemberAttribute("Item")]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AuditDetailCollection : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.AuditDetailCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection Members
See Also Constructors Methods Properties
[image]

Contains a collection of AuditDetail objects.

The following tables list the members exposed by the AuditDetailCollection type.

Public Constructors

Name | Description
AuditDetailCollection | Initializes a new instance of the AuditDetailCollection class.
Top

Public Properties

 | Name | Description
public property | AuditDetails | Gets the AuditDetail collection.
public property | Count | Indicates the number of elements in the AuditDetails collection.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Item | Gets or sets the element at the specified index.
public property | MoreRecords | Indicates whether more records exist.
public property | PagingCookie | Gets or sets a paging cookie.
public property | TotalRecordCount | Gets or sets the total record count in the collection.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Adds an AuditDetail object to the AuditDetails collection.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AuditDetailCollection Class
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection Constructor
[image]

Initializes a new instance of the AuditDetailCollection class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AuditDetailCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Class
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Adds an AuditDetail object to the AuditDetails collection.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AuditDetailCollection Class
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection.Add Method
[image]

Adds an AuditDetail object to the AuditDetails collection.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Add ( _
    auditDetail As AuditDetail _
)

C#
public void Add (
    AuditDetail auditDetail
)

C++

J#

JScript

Parameters
auditDetail
An object that contains change details.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Class
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection Properties
[image]

Public Properties

 | Name | Description
public property | AuditDetails | Gets the AuditDetail collection.
public property | Count | Indicates the number of elements in the AuditDetails collection.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Item | Gets or sets the element at the specified index.
public property | MoreRecords | Indicates whether more records exist.
public property | PagingCookie | Gets or sets a paging cookie.
public property | TotalRecordCount | Gets or sets the total record count in the collection.

See Also

Reference

AuditDetailCollection Class
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection.AuditDetails Property
[image]

Gets the AuditDetail collection.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AuditDetails As DataCollection(Of AuditDetail)

C#
[DataMemberAttribute]
public DataCollection<AuditDetail> AuditDetails { get; }

C++

J#

JScript

Property Value
Type: DataCollection<AuditDetail>
The collection of AuditDetail instances.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Class
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection.Count Property
[image]

Indicates the number of elements in the AuditDetails collection.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Count As Integer

C#
public int Count { get; }

C++

J#

JScript

Property Value
Type: Int32
The number of elements in the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Class
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Class
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection.Item Property
[image]

Gets or sets the element at the specified index.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As AuditDetail

C#
public AuditDetail this [
    int index
] { get; set; }

C++

J#

JScript

Parameters
index
Type: Int32. The element index.
Property Value
Type:AuditDetail

The element at the specified index.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Class
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection.MoreRecords Property
[image]

Indicates whether more records exist.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MoreRecords As Boolean

C#
[DataMemberAttribute]
public bool MoreRecords { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if more records exist; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Class
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection.PagingCookie Property
[image]

Gets or sets a paging cookie.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PagingCookie As String

C#
[DataMemberAttribute]
public string PagingCookie { get; set; }

C++

J#

JScript

Property Value
Type: String

The paging cookie value.

  Remarks
For more information on using a paging cookie, see Using a paging cookie with QueryExpression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Class
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditDetailCollection.TotalRecordCount Property
[image]

Gets or sets the total record count in the collection.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TotalRecordCount As Integer

C#
[DataMemberAttribute]
public int TotalRecordCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The total record count in the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditDetailCollection Class
AuditDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditPartitionDetail Class
See Also Members
[image]

Identifies a Microsoft SQL Server partition that is used to store changes to entity data records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AuditPartitionDetail
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AuditPartitionDetail : IExtensibleDataObject

C++

J#

JScript

  Remarks
You can use this class only on Microsoft SQL Servers that support partitioning, such as the Enterprise edition.

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.AuditPartitionDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetail Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditPartitionListRequest


AuditPartitionDetail Members
See Also Constructors Methods Properties
[image]

Identifies a Microsoft SQL Server partition that is used to store changes to entity data records.

The following tables list the members exposed by the AuditPartitionDetail type.

Public Constructors

Name | Description
AuditPartitionDetail | Initializes a new instance of the AuditPartitionDetail class.
Top

Public Properties

 | Name | Description
public property | EndDate | Gets or sets the end date and time for the last audit record in the partition.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PartitionNumber | Gets or sets the sequence (serial) number of the partition.
public property | Size | Gets or sets the size, in bytes, of the partition.
public property | StartDate | Gets or sets the creation date and time of the first audit record in the partition.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AuditPartitionDetail Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditPartitionListRequest


AuditPartitionDetail Constructor
[image]

Initializes a new instance of the AuditPartitionDetail class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AuditPartitionDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetail Class
AuditPartitionDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditPartitionDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AuditPartitionDetail Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditPartitionListRequest


AuditPartitionDetail Properties
[image]

Public Properties

 | Name | Description
public property | EndDate | Gets or sets the end date and time for the last audit record in the partition.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PartitionNumber | Gets or sets the sequence (serial) number of the partition.
public property | Size | Gets or sets the size, in bytes, of the partition.
public property | StartDate | Gets or sets the creation date and time of the first audit record in the partition.

See Also

Reference

AuditPartitionDetail Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditPartitionListRequest


AuditPartitionDetail.EndDate Property
[image]

Gets or sets the end date and time for the last audit record in the partition.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EndDate As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> EndDate { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTime>

The date and time of the last audit record in the partition.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetail Class
AuditPartitionDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditPartitionDetail.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type:  ExtensionDataObject
A structure that contains extra data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetail Class
AuditPartitionDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditPartitionDetail.PartitionNumber Property
[image]

Gets or sets the sequence (serial) number of the partition.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PartitionNumber As Integer

C#
[DataMemberAttribute]
public int PartitionNumber { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The sequence (serial) number of the partition.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetail Class
AuditPartitionDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditPartitionDetail.Size Property
[image]

Gets or sets the size, in bytes, of the partition.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Size As Long

C#
[DataMemberAttribute]
public long Size { get; set; }

C++

J#

JScript

Property Value
Type: Int64
The size, in bytes, of the partition.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetail Class
AuditPartitionDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditPartitionDetail.StartDate Property
[image]

Gets or sets the creation date and time of the first audit record in the partition.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property StartDate As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> StartDate { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTime>
The creation date and time of the first audit record in the partition.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetail Class
AuditPartitionDetail Members
Microsoft.Crm.Sdk.Messages Namespace


AuditPartitionDetailCollection Class
See Also Members
[image]

Contains a data collection of AuditDetail objects.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AuditPartitionDetailCollection
    Inherits DataCollection(Of AuditPartitionDetail)
    Implements IExtensibleDataObject

C#
[CollectionDataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AuditPartitionDetailCollection : DataCollection<AuditPartitionDetail>, IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Crm.Sdk.Messages.AuditPartitionDetailCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditPartitionListResponse


AuditPartitionDetailCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a data collection of AuditDetail objects.

The following tables list the members exposed by the AuditPartitionDetailCollection type.

Public Constructors

Name | Description
AuditPartitionDetailCollection | Initializes a new instance of theAuditPartitionDetailCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | IsLogicalCollection | Gets or sets whether the partition change list is a logical collection.
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

AuditPartitionDetailCollection Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditPartitionListResponse


AuditPartitionDetailCollection Constructor
[image]

Initializes a new instance of the AuditPartitionDetailCollection class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AuditPartitionDetailCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetailCollection Class
AuditPartitionDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditPartitionDetailCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

AuditPartitionDetailCollection Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditPartitionListResponse


AuditPartitionDetailCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | IsLogicalCollection | Gets or sets whether the partition change list is a logical collection.
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

AuditPartitionDetailCollection Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditPartitionListResponse


AuditPartitionDetailCollection.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetailCollection Class
AuditPartitionDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AuditPartitionDetailCollection.IsLogicalCollection Property
[image]

Gets or sets whether the partition change list is a logical collection.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsLogicalCollection As Boolean

C#
[DataMemberAttribute]
public bool IsLogicalCollection { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the audit partition list is a logical collection; otherwise, false.

  Remarks
The partition list is logical when the SQL Server edition does not support partitions. Currently, the auditing partitioning feature is available only with the Enterprise Edition of Microsoft SQL Server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuditPartitionDetailCollection Class
AuditPartitionDetailCollection Members
Microsoft.Crm.Sdk.Messages Namespace


AutoMapEntityRequest Class
See Also Members
[image]

Contains the data that is needed to generate a new set of attribute mappings based on the metadata.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AutoMapEntityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AutoMapEntityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the AutoMapEntityResponse class.
Privileges and Access Rights
To perform this action, the caller must have the privileges that are listed in AutoMapEntity Privileges.
Notes for Callers
Use this helper function after you create a new relationship. This message is provided as a productivity enhancement so that you don’t have to manually add all attribute mappings. Instead, you can generate a set of likely mappings and minimize the amount of manual work to add or remove individual mappings to meet your requirements. This message will map all the attributes between the two related entities where the attribute names are identical and the types are identical. The mapping may result in some mappings that you don’t want; therefore, you should always check the resulting mapping before you publish the customization.
  Note

                        If you use this function where entity mappings already exist, the existing mappings are removed.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.AutoMapEntityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AutoMapEntityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Entity and Attribute Mappings
AutoMapEntity Privileges


AutoMapEntityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to generate a new set of attribute mappings based on the metadata.

The following tables list the members exposed by the AutoMapEntityRequest type.

Public Constructors

Name | Description
AutoMapEntityRequest | Initializes a new instance of the AutoMapEntityRequest class.
Top

Public Properties

 | Name | Description
public property | EntityMapId | Gets or sets the ID of the entity map to overwrite when the automated mapping is performed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AutoMapEntityRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Entity and Attribute Mappings
AutoMapEntity Privileges


AutoMapEntityRequest Constructor
[image]

Initializes a new instance of the AutoMapEntityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AutoMapEntityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AutoMapEntityRequest Class
AutoMapEntityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AutoMapEntityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AutoMapEntityRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Entity and Attribute Mappings
AutoMapEntity Privileges


AutoMapEntityRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityMapId | Gets or sets the ID of the entity map to overwrite when the automated mapping is performed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

AutoMapEntityRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Entity and Attribute Mappings
AutoMapEntity Privileges


AutoMapEntityRequest.EntityMapId Property
[image]

Gets or sets the ID of the entity map to overwrite when the automated mapping is performed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityMapId As Guid

C#
public Guid EntityMapId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the entity map.

  Remarks
Use the names of the related entities to query the EntityMap entity where the EntityMap.SourceEntityName attribute equals the referenced entity and the EntityMap.TargetEntityName attribute equals the referencing entity. Use the EntityMap.EntityMapId attribute value for the matching record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AutoMapEntityRequest Class
AutoMapEntityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


AutoMapEntityResponse Class
See Also Members
[image]

Contains the response from the AutoMapEntityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class AutoMapEntityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class AutoMapEntityResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.AutoMapEntityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AutoMapEntityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
AutoMapEntityRequest


AutoMapEntityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AutoMapEntityRequest class.

The following tables list the members exposed by the AutoMapEntityResponse type.

Public Constructors

Name | Description
AutoMapEntityResponse | Initializes a new instance of theAutoMapEntityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AutoMapEntityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AutoMapEntityRequest


AutoMapEntityResponse Constructor
[image]

Initializes a new instance of the AutoMapEntityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AutoMapEntityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AutoMapEntityResponse Class
AutoMapEntityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


AutoMapEntityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AutoMapEntityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AutoMapEntityRequest


AutoMapEntityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AutoMapEntityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
AutoMapEntityRequest


BackgroundSendEmailRequest Class
See Also Members
[image]

Contains the data that is needed to send email messages asynchronously.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BackgroundSendEmailRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BackgroundSendEmailRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute method, which returns an instance of  BackgroundSendEmailResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the email entity and access rights on the records returned from the query. For a complete list of the privileges required, see BackgroundSendEmail Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.BackgroundSendEmailRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BackgroundSendEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailResponse
Other Resources
Email (E-mail) Activity Entities
Email (E-mail) Entity Messages and Methods


BackgroundSendEmailRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to send email messages asynchronously.

The following tables list the members exposed by the BackgroundSendEmailRequest type.

Public Constructors

Name | Description
BackgroundSendEmailRequest | Initializes a new instance of the BackgroundSendEmailRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query to find the email activities to send.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BackgroundSendEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailResponse

Other Resources

Email (E-mail) Activity Entities
Email (E-mail) Entity Messages and Methods


BackgroundSendEmailRequest Constructor
[image]

Initializes a new instance of the BackgroundSendEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BackgroundSendEmailRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BackgroundSendEmailRequest Class
BackgroundSendEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BackgroundSendEmailRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BackgroundSendEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailResponse

Other Resources

Email (E-mail) Activity Entities
Email (E-mail) Entity Messages and Methods


BackgroundSendEmailRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query to find the email activities to send.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

BackgroundSendEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailResponse

Other Resources

Email (E-mail) Activity Entities
Email (E-mail) Entity Messages and Methods


BackgroundSendEmailRequest.Query Property
[image]

Gets or sets the query to find the email activities to send.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query to find the email activities to send.

  Remarks
Assign an instance of the QueryExpression, QueryByAttribute, or FetchExpression class. The query must specify an entity name of “email” and a ColumnSet. If the column set includes attributes that are not valid for retrieve or for which you do not have access, they will be ignored.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BackgroundSendEmailRequest Class
BackgroundSendEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailResponse
Other Resources
Email (E-mail) Activity Entities
Email (E-mail) Entity Messages and Methods
BackgroundSendEmail Privileges


BackgroundSendEmailResponse Class
See Also Members
[image]

Contains the response from the BackgroundSendEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BackgroundSendEmailResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BackgroundSendEmailResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.BackgroundSendEmailResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BackgroundSendEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailRequest
Other Resources
BackgroundSendEmail Privileges
Email (E-mail) Entity Messages and Methods


BackgroundSendEmailResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the BackgroundSendEmailRequest class.

The following tables list the members exposed by the BackgroundSendEmailResponse type.

Public Constructors

Name | Description
BackgroundSendEmailResponse | Initializes a new instance of the BackgroundSendEmailResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting emails. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | HasAttachments | Gets a value that indicates whether the email has attachments. Required.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BackgroundSendEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailRequest

Other Resources

BackgroundSendEmail Privileges
Email (E-mail) Entity Messages and Methods


BackgroundSendEmailResponse Constructor
[image]

Initializes a new instance of the BackgroundSendEmailResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BackgroundSendEmailResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BackgroundSendEmailResponse Class
BackgroundSendEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BackgroundSendEmailResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BackgroundSendEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailRequest

Other Resources

BackgroundSendEmail Privileges
Email (E-mail) Entity Messages and Methods


BackgroundSendEmailResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting emails. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | HasAttachments | Gets a value that indicates whether the email has attachments. Required.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

BackgroundSendEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailRequest

Other Resources

BackgroundSendEmail Privileges
Email (E-mail) Entity Messages and Methods


BackgroundSendEmailResponse.EntityCollection Property
[image]

Gets the resulting emails. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of resulting emails.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BackgroundSendEmailResponse Class
BackgroundSendEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BackgroundSendEmailResponse.HasAttachments Property
[image]

Gets a value that indicates whether the email has attachments. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property HasAttachments As Boolean()

C#
public bool[] HasAttachments { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the email has attachments; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BackgroundSendEmailResponse Class
BackgroundSendEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BookRequest Class
See Also Example Members
[image]

Contains the data that is needed to schedule or “book” an appointment, recurring appointment, or service appointment (service activity).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BookRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BookRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Get the current user information
WhoAmIRequest userRequest = new WhoAmIRequest();
WhoAmIResponse userResponse = (WhoAmIResponse)_serviceProxy.Execute(userRequest);

// Create the ActivityParty instance.
ActivityParty party = new ActivityParty
{
    PartyId = new EntityReference(SystemUser.EntityLogicalName, userResponse.UserId)
};

// Create the appointment instance.
Appointment appointment = new Appointment
{
    Subject = "Test Appointment",
    Description = "Test Appointment created using the BookRequest Message.",
    ScheduledStart = DateTime.Now.AddHours(1),
    ScheduledEnd = DateTime.Now.AddHours(2),
    Location = "Office",
    RequiredAttendees = new ActivityParty[] { party },
    Organizer = new ActivityParty[] { party }
};

// Use the Book request message.
BookRequest book = new BookRequest
{
    Target = appointment
};
BookResponse booked = (BookResponse)_serviceProxy.Execute(book);
_appointmentId = booked.ValidationResult.ActivityId;

// Verify that the appointment has been scheduled.
if (_appointmentId != Guid.Empty)
{
    Console.WriteLine("Succesfully booked {0}.", appointment.Subject) ;
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the BookResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the Target property and access rights on the specified record in the Target property. For a complete list of the required privileges, see Book Privileges.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

Entity | Availability
appointment | Server
recurringappointmentmaster | Server
serviceappointment | Server

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.BookRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
BookRequest Members
Microsoft.Crm.Sdk.Messages Namespace
BookResponse
Other Resources
Schedule and Appointment Entities
Create a Recurring Appointment Series
Sample: Book an Appointment


BookRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to schedule or “book” an appointment, recurring appointment, or service appointment (service activity).

The following tables list the members exposed by the BookRequest type.

Public Constructors

Name | Description
BookRequest | Initializes a new instance of the BookRequest Class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReturnNotifications | For internal use only.
public property | Target | Gets or sets the record that is the target of the book operation. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BookRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BookResponse

Other Resources

Schedule and Appointment Entities
Create a Recurring Appointment Series
Sample: Book an Appointment


BookRequest Constructor
[image]

Initializes a new instance of the BookRequest Class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BookRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BookRequest Class
BookRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BookRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BookRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BookResponse

Other Resources

Schedule and Appointment Entities
Create a Recurring Appointment Series
Sample: Book an Appointment


BookRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReturnNotifications | For internal use only.
public property | Target | Gets or sets the record that is the target of the book operation. Required.

See Also

Reference

BookRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BookResponse

Other Resources

Schedule and Appointment Entities
Create a Recurring Appointment Series
Sample: Book an Appointment


BookRequest.ReturnNotifications Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReturnNotifications As Boolean

C#
public bool ReturnNotifications { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if you want notifications returned; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BookRequest Class
BookRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BookRequest.Target Property
[image]

Gets or sets the record that is the target of the book operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type:Entity
 The target entity instance for the book operation.

  Remarks
Set the value of this property to an instance of the entity type that you want to schedule: Appointment, RecurringAppointmentMaster, or ServiceAppointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BookRequest Class
BookRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BookResponse Class
See Also Members
[image]

Contains the response from the BookRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BookResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BookResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.BookResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BookResponse Members
Microsoft.Crm.Sdk.Messages Namespace
BookRequest
Other Resources
Book Privileges
Sample: Book an Appointment


BookResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the BookRequest class.

The following tables list the members exposed by the BookResponse type.

Public Constructors

Name | Description
BookResponse | Initializes a new instance of the BookResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Notifications | For internal use only.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ValidationResult | Gets the appointment validation results.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BookResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BookRequest

Other Resources

Book Privileges
Sample: Book an Appointment


BookResponse Constructor
[image]

Initializes a new instance of the BookResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BookResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BookResponse Class
BookResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BookResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BookResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BookRequest

Other Resources

Book Privileges
Sample: Book an Appointment


BookResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Notifications | For internal use only.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ValidationResult | Gets the appointment validation results.

See Also

Reference

BookResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BookRequest

Other Resources

Book Privileges
Sample: Book an Appointment


BookResponse.Notifications Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Notifications As Object

C#
public Object Notifications { get; }

C++

J#

JScript

Property Value
Type: Object
The notifications.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BookResponse Class
BookResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BookResponse.ValidationResult Property
[image]

Gets the appointment validation results.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ValidationResult As ValidationResult

C#
public ValidationResult ValidationResult { get; }

C++

J#

JScript

Property Value
Type:ValidationResult
The appointment validation results.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BookResponse Class
BookResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteRequest Class
See Also Example Members
[image]

Contains the data that’s needed to submit a bulk delete job that deletes selected records in bulk. This job runs asynchronously in the background without blocking other activities.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BulkDeleteRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BulkDeleteRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create a condition for a bulk delete request.
// NOTE: This sample uses very specific queries for deleting records
// that have been manually exported in order to free space.
QueryExpression opportunitiesQuery = BuildOpportunityQuery();

// Create the bulk delete request.
BulkDeleteRequest bulkDeleteRequest = new BulkDeleteRequest();

// Set the request properties.
bulkDeleteRequest.JobName = "Backup Bulk Delete";

// Querying activities
bulkDeleteRequest.QuerySet = new QueryExpression[]
{
    opportunitiesQuery,
    BuildActivityQuery(Task.EntityLogicalName),
    BuildActivityQuery(Fax.EntityLogicalName),
    BuildActivityQuery(PhoneCall.EntityLogicalName),
    BuildActivityQuery(Email.EntityLogicalName),
    BuildActivityQuery(Letter.EntityLogicalName),
    BuildActivityQuery(Appointment.EntityLogicalName),
    BuildActivityQuery(ServiceAppointment.EntityLogicalName),
    BuildActivityQuery(CampaignResponse.EntityLogicalName),
    BuildActivityQuery(RecurringAppointmentMaster.EntityLogicalName)
};

// Set the start time for the bulk delete.
bulkDeleteRequest.StartDateTime = DateTime.Now;

// Set the required recurrence pattern.
bulkDeleteRequest.RecurrencePattern = String.Empty;

// Set email activity properties.
bulkDeleteRequest.SendEmailNotification = false;
bulkDeleteRequest.ToRecipients = new Guid[] { currentUserId };
bulkDeleteRequest.CCRecipients = new Guid[] { };

// Submit the bulk delete job.
// NOTE: Because this is an asynchronous operation, the response will be immediate.
_bulkDeleteResponse =
    (BulkDeleteResponse)_serviceProxy.Execute(bulkDeleteRequest);
Console.WriteLine("The bulk delete operation has been requested.");

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the BulkDeleteResponse class.
Privileges and Access Rights
To perform this action, the caller must have read access rights on the entity records that are specified in the request class. The caller must also have Delete Privileges for the entity types being deleted. For a complete list of the required privileges, see BulkDelete Privileges.
Notes for Callers
By default, a system administrator has the BulkDelete privileges for bulk deletions. Other users must be granted the BulkDelete privileges before they can perform a bulk deletion.
When a record is deleted, all its child records are also deleted. The entire deletion fails if the caller doesn’t have delete privileges or access rights to perform bulk deletions for any of these records.
The deletion order of the related records depends on the cascade configuration for each entity relationship. For a description of how actions on a parent record can affect related records, see Entity Relationship Behavior.
Supported Entities
You can delete the records in bulk of an entity that supports the BulkDeleteRequest message, including custom entities.

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

Entity | Availability
account | Server
activitymimeattachment | Server
annotation | Server
annualfiscalcalendar | Server
appointment | Server
asyncoperation | Server
attributemap | Server
bulkdeleteoperation | Server
bulkoperation | Server
businessunit | Server
businessunitnewsarticle | Server
calendar | Server
campaign | Server
campaignactivity | Server
campaignresponse | Server
columnmapping | Server
competitor | Server
connection | Server
connectionrole | Server
connectionroleobjecttypecode | Server
constraintbasedgroup | Server
contact | Server
contract | Server
contractdetail | Server
contracttemplate | Server
customeraddress | Server
customeropportunityrole | Server
customerrelationship | Server
discount | Server
discounttype | Server
duplicaterule | Server
duplicaterulecondition | Server
email | Server
equipment | Server
fax | Server
fieldpermission | Server
fieldsecurityprofile | Server
fixedmonthlyfiscalcalendar | Server
goal | Server
goalrollupquery | Server
import | Server
importdata | Server
importentitymapping | Server
importfile | Server
importjob | Server
importmap | Server
incident | Server
incidentresolution | Server
invoice | Server
invoicedetail | Server
isvconfig | Server
kbarticle | Server
kbarticlecomment | Server
kbarticletemplate | Server
lead | Server
letter | Server
list | Server
lookupmapping | Server
mailmergetemplate | Server
metric | Server
monthlyfiscalcalendar | Server
opportunity | Server
opportunityclose | Server
opportunityproduct | Server
orderclose | Server
ownermapping | Server
phonecall | Server
picklistmapping | Server
pluginassembly | Server
plugintype | Server
pricelevel | Server
principalobjectattributeaccess | Server
processsession | Server
product | Server
productpricelevel | Server
publisher | Server
publisheraddress | Server
quarterlyfiscalcalendar | Server
queue | Server
queueitem | Server
quote | Server
quoteclose | Server
quotedetail | Server
recurrencerule | Server
recurringappointmentmaster | Server
relationshiprole | Server
relationshiprolemap | Server
report | Server
reportcategory | Server
reportentity | Server
reportvisibility | Server
resourcespec | Server
role | Server
rollupfield | Server
salesliterature | Server
salesliteratureitem | Server
salesorder | Server
salesorderdetail | Server
savedquery | Server
savedqueryvisualization | Server
sdkmessageprocessingstep | Server
sdkmessageprocessingstepimage | Server
sdkmessageprocessingstepsecureconfig | Server
semiannualfiscalcalendar | Server
service | Server
serviceappointment | Server
serviceendpoint | Server
sharepointdocumentlocation | Server
sharepointsite | Server
site | Server
solution | Server
subject | Server
systemform | Server
task | Server
team | Server
template | Server
territory | Server
transactioncurrency | Server
transformationmapping | Server
transformationparametermapping | Server
uom | Server
uomschedule | Server
userentityinstancedata | Server
userentityuisettings | Server
userform | Server
userquery | Server
userqueryvisualization | Server
webresource | Server
webwizard | Server
wizardaccessprivilege | Server
wizardpage | Server
workflow | Server
workflowdependency | Server
workflowlog | Server

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.BulkDeleteRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace
BulkDeleteResponse
Other Resources
Delete Data in Bulk in Microsoft Dynamics CRM
Sample: Bulk Delete Exported Records
Sample: Bulk Delete Records That Match Common Criteria
BulkDelete Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


BulkDeleteRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that’s needed to submit a bulk delete job that deletes selected records in bulk. This job runs asynchronously in the background without blocking other activities.

The following tables list the members exposed by the BulkDeleteRequest type.

Public Constructors

Name | Description
BulkDeleteRequest | Initializes a new instance of the BulkDeleteRequest class.
Top

Public Properties

 | Name | Description
public property | CCRecipients | Gets or sets an array of IDs for the system users (users) who are listed in the Cc box of the email notification. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | JobName | Gets or sets the name of an asynchronous bulk delete job. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuerySet | Gets or sets an array of queries for a bulk delete job. Required.
public property | RecurrencePattern | Gets or sets the recurrence pattern for the bulk delete job. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SendEmailNotification | Gets or sets a value that indicates whether an email notification is sent after the bulk delete job has finished running. Required.
public property | SourceImportId | Gets or sets the ID of the data import job. Optional.
public property | StartDateTime | Gets or sets the start date and time to run a bulk delete job. Optional.
public property | ToRecipients | Gets or sets an array of IDs for the system users (users) who are listed in the To box of an email notification. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BulkDeleteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDeleteResponse

Other Resources

Delete Data in Bulk in Microsoft Dynamics CRM
Sample: Bulk Delete Exported Records
Sample: Bulk Delete Records That Match Common Criteria
BulkDelete Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


BulkDeleteRequest Constructor
[image]

Initializes a new instance of the BulkDeleteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BulkDeleteRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteRequest Class
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BulkDeleteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDeleteResponse

Other Resources

Delete Data in Bulk in Microsoft Dynamics CRM
Sample: Bulk Delete Exported Records
Sample: Bulk Delete Records That Match Common Criteria
BulkDelete Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


BulkDeleteRequest Properties
[image]

Public Properties

 | Name | Description
public property | CCRecipients | Gets or sets an array of IDs for the system users (users) who are listed in the Cc box of the email notification. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | JobName | Gets or sets the name of an asynchronous bulk delete job. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuerySet | Gets or sets an array of queries for a bulk delete job. Required.
public property | RecurrencePattern | Gets or sets the recurrence pattern for the bulk delete job. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SendEmailNotification | Gets or sets a value that indicates whether an email notification is sent after the bulk delete job has finished running. Required.
public property | SourceImportId | Gets or sets the ID of the data import job. Optional.
public property | StartDateTime | Gets or sets the start date and time to run a bulk delete job. Optional.
public property | ToRecipients | Gets or sets an array of IDs for the system users (users) who are listed in the To box of an email notification. Required.

See Also

Reference

BulkDeleteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDeleteResponse

Other Resources

Delete Data in Bulk in Microsoft Dynamics CRM
Sample: Bulk Delete Exported Records
Sample: Bulk Delete Records That Match Common Criteria
BulkDelete Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


BulkDeleteRequest.CCRecipients Property
[image]

Gets or sets an array of IDs for the system users (users) who are listed in the Cc box of the email notification. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CCRecipients As Guid()

C#
public Guid[] CCRecipients { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]
The array of IDs for the system users (users) who are listed in the Cc box of the email notification.

  Remarks
Each element in the CCRecipients array corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.
Each ID in the CCRecipients array must be for a user who has a valid email address. This property is required if the SendEmailNotification property is set to true; otherwise, it is optional. If you set this property to true, an email notification is sent to all users who have the IDs that are specified in this property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteRequest Class
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteRequest.JobName Property
[image]

Gets or sets the name of an asynchronous bulk delete job. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property JobName As String

C#
public string JobName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the asynchronous bulk delete job.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteRequest Class
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteRequest.QuerySet Property
[image]

Gets or sets an array of queries for a bulk delete job. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QuerySet As QueryExpression()

C#
public QueryExpression[] QuerySet { get; set; }

C++

J#

JScript

Property Value
Type: QueryExpression
The array of queries for a bulk delete job.

  Remarks
The bulk delete job deletes the records that match the conditions that are specified in the queries.
The query must specify entity names and a column set. If the column set includes attributes where IsValidForRead is false or for which you don’t have access, they are ignored. For more information about field security, see How Field Security Can Be Used to Control Access to Field Values in Microsoft Dynamics CRM.
When you use the QuerySet property, the value in the QueryExpression.PageInfo property is ignored. Instead, the system uses the query expression and creates a new PagingInfo object to retrieve up to 1000 records at a time. The process increments the page by 1 until all records that are included in the query are processed. You should modify the query as needed to match the exact set of records that you want to delete.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteRequest Class
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteRequest.RecurrencePattern Property
[image]

Gets or sets the recurrence pattern for the bulk delete job. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RecurrencePattern As String

C#
public string RecurrencePattern { get; set; }

C++

J#

JScript

Property Value
Type: String
The recurrence pattern for the bulk delete job.

  Remarks
You can run the bulk delete job daily or without recurrence. To run without recurrence, set the property to String.Empty. For more information, see Recurrence Pattern in Asynchronous Job Execution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteRequest Class
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteRequest.SendEmailNotification Property
[image]

Gets or sets a value that indicates whether an email notification is sent after the bulk delete job has finished running. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SendEmailNotification As Boolean

C#
public bool SendEmailNotification { get; set; }

C++

J#

JScript

Property Value
 Type: Boolean
true if an email notification should be sent after the bulk deletion is finished or has failed; otherwise, false.

  Remarks
If you set this property to true, the caller must have prvCreateEmailTemplate and prvReadEmailTemplate privileges in addition to the privileges that are needed to delete the entity instances. If you specify to send an email notification, you must also specify a value for the ToRecipients property. The email notification is based on these email templates: Bulk Deletion Task Completion ,  Bulk Deletion Task Completed With Failure, or Bulk Deletion Task Failed. To customize these email templates, see the Templates area of the web application. To access these templates, in the Navigation Pane, click Settings, click Templates, and then click Email Templates.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteRequest Class
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteRequest.SourceImportId Property
[image]

Gets or sets the ID of the data import job. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SourceImportId As Nullable(Of Guid)

C#
public Nullable<Guid> SourceImportId { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Guid>
The ID of the data import job that corresponds to the ImportrId property, which is the primary key for the Import entity.

  Remarks

If you provide the ID of the import job in this property, all records imported by this job will be deleted from the system by the bulk delete job.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteRequest Class
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteRequest.StartDateTime Property
[image]

Gets or sets the start date and time to run a bulk delete job. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property StartDateTime As DateTime

C#
public DateTime StartDateTime { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The start date and time to run a bulk delete job.

  Remarks
StartDateTime is an optional property that specifies the start date and time of an one-time-only bulk delete job, or the start date and time of a recurring bulk delete job. If this property is not set, the start date and time are set to the value that is contained in the Now. For more information, see Recurrence Pattern in Asynchronous Job Execution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteRequest Class
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteRequest.ToRecipients Property
[image]

Gets or sets an array of IDs for the system users (users) who are listed in the To box of an email notification. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ToRecipients As Guid()

C#
public Guid[] ToRecipients { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]
The array of IDs for the system users (users) who are listed in the To box of an email notification.

  Remarks
Each element in the ToRecipients array corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.
Each ID the ToRecipients array must be for a user who has a valid email address. This property is required if the SendEmailNotification property is set to true; otherwise, it is optional. If the SendEmailNotification property is set to true, an email notification is sent to all users who have the IDs that are specified in this property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteRequest Class
BulkDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteResponse Class
See Also Members
[image]

Contains the response from the BulkDeleteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BulkDeleteResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BulkDeleteResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.BulkDeleteResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteResponse Members
Microsoft.Crm.Sdk.Messages Namespace
BulkDeleteRequest


BulkDeleteResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the BulkDeleteRequest class.

The following tables list the members exposed by the BulkDeleteResponse type.

Public Constructors

Name | Description
BulkDeleteResponse | Initializes a new instance of the BulkDeleteResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | JobId | Gets the ID of an asynchronous bulk delete job that performs a bulk deletion.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BulkDeleteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDeleteRequest


BulkDeleteResponse Constructor
[image]

Initializes a new instance of the BulkDeleteResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BulkDeleteResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteResponse Class
BulkDeleteResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDeleteResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BulkDeleteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDeleteRequest


BulkDeleteResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | JobId | Gets the ID of an asynchronous bulk delete job that performs a bulk deletion.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

BulkDeleteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDeleteRequest


BulkDeleteResponse.JobId Property
[image]

Gets the ID of an asynchronous bulk delete job that performs a bulk deletion.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property JobId As Guid

C#
public Guid JobId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of an asynchronous bulk delete job that performs a bulk deletion..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDeleteResponse Class
BulkDeleteResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesRequest Class
See Also Example Members
[image]

Contains the data that is needed to submit an asynchronous system job that detects and logs multiple duplicate records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BulkDetectDuplicatesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BulkDetectDuplicatesRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Create the BulkDetectDuplicatesRequest object
    Console.WriteLine("  Creating the BulkDetectDuplicatesRequest object");
    BulkDetectDuplicatesRequest request = new BulkDetectDuplicatesRequest()
    {
        JobName = "Detect Duplicate Accounts",
        Query = new QueryExpression()
        {
            EntityName = Account.EntityLogicalName,
            ColumnSet = new ColumnSet(true)
        },
        RecurrencePattern = String.Empty,
        RecurrenceStartTime = DateTime.Now,
        ToRecipients = new Guid[0],
        CCRecipients = new Guid[0]
    };

    // Execute the request
    Console.WriteLine("  Executing BulkDetectDuplicatesRequest");
    _response = (BulkDetectDuplicatesResponse)_serviceProxy
        .Execute(request);

    #region check success

    Console.WriteLine("  Waiting for job to complete...");
    WaitForAsyncJobToFinish(_response.JobId, 120);

    QueryByAttribute query = new QueryByAttribute()
    {
        ColumnSet = new ColumnSet(true),
        EntityName = "duplicaterecord"
    };
    query.Attributes.Add("asyncoperationid");
    query.Values.Add(_response.JobId);
    EntityCollection results = _serviceProxy.RetrieveMultiple(query);

    // check to make sure each id is found in the collection
    var duplicateIds = results.Entities.Select((entity) =>
        ((DuplicateRecord)entity).BaseRecordId.Id);
    foreach (var id in _duplicateAccounts.Select((account) => account.Id))
    {
        if (!duplicateIds.Contains(id))
        {
            throw new Exception(String.Format(
                "Account with ID {0} was not detected as a duplicate",
                id));
        }
    }
    Console.WriteLine("  All accounts detected as duplicates successfully");

    #endregion

    Console.WriteLine();

    DeleteRequiredRecords(promptforDelete);
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the BulkDetectDuplicatesResponse class.
Privileges and Access Rights
To perform this action, the caller must have access rights on the entity records that are specified in the request class. For a complete list of the required privileges, see BulkDetectDuplicates Privileges.
Notes for Callers
The asynchronous system job detects multiple duplicate records and logs them as duplicate records by using the DuplicateRecord entity. Before you use this message, set the IsDuplicateDetectionEnabled attribute for an entity to true and publish all duplicate rules (duplicate detection rules) for an entity.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.BulkDetectDuplicatesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
BulkDetectDuplicatesResponse
Other Resources
Detect Duplicate Data in Microsoft Dynamics CRM
Run Duplicate Detection
Sample: Detect Multiple Duplicate Records
BulkDetectDuplicates Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


BulkDetectDuplicatesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to submit an asynchronous system job that detects and logs multiple duplicate records.

The following tables list the members exposed by the BulkDetectDuplicatesRequest type.

Public Constructors

Name | Description
BulkDetectDuplicatesRequest | Initializes a new instance of the BulkDetectDuplicatesRequest class.
Top

Public Properties

 | Name | Description
public property | CCRecipients | Gets or sets an array of IDs for the system users (users) who are listed in the Cc box of the email notification.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | JobName | Gets or sets the name of the asynchronous system job that detects and logs multiple duplicate records. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query criteria for detecting multiple duplicate records. Required.
public property | RecurrencePattern | Gets or sets the recurrence pattern for the asynchronous system job that detects multiple duplicate records. Optional.
public property | RecurrenceStartTime | Gets or sets the start date and time of an asynchronous system job that detects and logs multiple duplicate records. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SendEmailNotification | Gets or sets a value that indicates whether an email notification is sent after the asynchronous system job that detects multiple duplicate records finishes running. Required.
public property | TemplateId | Sets the ID of the template (email template) that is used for the email notification.
public property | ToRecipients | Gets or sets an array of IDs for the system users (users) who are listed in the “To” box (recipients) of the email notification.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BulkDetectDuplicatesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDetectDuplicatesResponse

Other Resources

Detect Duplicate Data in Microsoft Dynamics CRM
Run Duplicate Detection
Sample: Detect Multiple Duplicate Records
BulkDetectDuplicates Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


BulkDetectDuplicatesRequest Constructor
[image]

Initializes a new instance of the BulkDetectDuplicatesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BulkDetectDuplicatesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesRequest Class
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BulkDetectDuplicatesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDetectDuplicatesResponse

Other Resources

Detect Duplicate Data in Microsoft Dynamics CRM
Run Duplicate Detection
Sample: Detect Multiple Duplicate Records
BulkDetectDuplicates Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


BulkDetectDuplicatesRequest Properties
[image]

Public Properties

 | Name | Description
public property | CCRecipients | Gets or sets an array of IDs for the system users (users) who are listed in the Cc box of the email notification.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | JobName | Gets or sets the name of the asynchronous system job that detects and logs multiple duplicate records. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query criteria for detecting multiple duplicate records. Required.
public property | RecurrencePattern | Gets or sets the recurrence pattern for the asynchronous system job that detects multiple duplicate records. Optional.
public property | RecurrenceStartTime | Gets or sets the start date and time of an asynchronous system job that detects and logs multiple duplicate records. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SendEmailNotification | Gets or sets a value that indicates whether an email notification is sent after the asynchronous system job that detects multiple duplicate records finishes running. Required.
public property | TemplateId | Sets the ID of the template (email template) that is used for the email notification.
public property | ToRecipients | Gets or sets an array of IDs for the system users (users) who are listed in the “To” box (recipients) of the email notification.

See Also

Reference

BulkDetectDuplicatesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDetectDuplicatesResponse

Other Resources

Detect Duplicate Data in Microsoft Dynamics CRM
Run Duplicate Detection
Sample: Detect Multiple Duplicate Records
BulkDetectDuplicates Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


BulkDetectDuplicatesRequest.CCRecipients Property
[image]

Gets or sets an array of IDs for the system users (users) who are listed in the Cc box of the email notification.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CCRecipients As Guid()

C#
public Guid[] CCRecipients { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]
The array of IDs for the system users (users) who are listed in the Cc box of the email notification.

  Remarks
Each element in the CCRecipients array corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.
Each ID must be for a user who has a valid email address.
This property is required if the SendEmailNotification property is set to true; otherwise, it is optional. If you set this property to true, an email notification is sent to all users who have the IDs that are specified in this property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesRequest Class
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesRequest.JobName Property
[image]

Gets or sets the name of the asynchronous system job that detects and logs multiple duplicate records. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property JobName As String

C#
public string JobName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the asynchronous system job that detects and logs multiple duplicate records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesRequest Class
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesRequest.Query Property
[image]

Gets or sets the query criteria for detecting multiple duplicate records. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryExpression
The query criteria for detecting multiple duplicate records.

  Remarks
The asynchronous system job detects duplicate records that match the query criteria.
 Assign an instance of the FetchExpression, QueryExpression, or QueryByAttribute class. The query must specify entity names and a column set. If the column set includes attributes where IsValidForRead is false or for which you do not have access, they are ignored. For more information about field security, see How Field Security Can Be Used to Control Access to Field Values in Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesRequest Class
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesRequest.RecurrencePattern Property
[image]

Gets or sets the recurrence pattern for the asynchronous system job that detects multiple duplicate records. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RecurrencePattern As String

C#
public string RecurrencePattern { get; set; }

C++

J#

JScript

Property Value
Type: String
The recurrence pattern for the asynchronous system job that detects multiple duplicate records.

  Remarks
 You can run the bulk detect duplicates job daily or without recurrence. To run without recurrence, set this property to String.Empty. For more information, see Recurrence Pattern in Asynchronous Job Execution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesRequest Class
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesRequest.RecurrenceStartTime Property
[image]

Gets or sets the start date and time of an asynchronous system job that detects and logs multiple duplicate records. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RecurrenceStartTime As DateTime

C#
public DateTime RecurrenceStartTime { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The start date and time of an asynchronous system job that detects and logs multiple duplicate record.

  Remarks
This optional property specifies the start date and time of either a one-time-only job that detects multiple duplicate records, or of a recurring job that detects multiple duplicate records. If this property is not set, the start date and time are set to the value that is contained in the Now property. For more information, see Recurrence Pattern in Asynchronous Job Execution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesRequest Class
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesRequest.SendEmailNotification Property
[image]

Gets or sets a value that indicates whether an email notification is sent after the asynchronous system job that detects multiple duplicate records finishes running. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SendEmailNotification As Boolean

C#
public bool SendEmailNotification { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if an email notification should be sent after the job to detect multiple duplicate records is finished running or has failed; otherwise, false.

  Remarks
If you set this property to true, the following requirements also apply:
  • The caller must have prvCreateEmailTemplate and prvReadEmailTemplate privileges in addition to the privileges that are needed to detect duplicate records.
  • You must specify a value for the ToRecipients property.
  • For the email notification, use the email template or custom email templates. To customize the email templates, see the Templates area of the web application. To access these templates, in the nav bar, choose Settings > Templates > Email Templates.
If you set the SendEmailNotification property to false, the TemplateId, ToRecipients, and CCRecipients properties are not used in the BulkDetectDuplicatesRequest class. We recommend that you set the unused properties to the following values:
C#    Copy Code
TemplateId = Guid.Empty;
ToRecipients = new Guid[0];
CCRecipients = new Guid[0];

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
BulkDetectDuplicatesRequest Class
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesRequest.TemplateId Property
[image]

Sets the ID of the template (email template) that is used for the email notification.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the template (email template) that is used for the email notification that corresponds to the TemplateId attribute, which is the primary key for the Template entity..

  Remarks
This property is required if the SendEmailNotification property is set to true; otherwise, it is optional. If you send a notification and this property is set to Guid.Empty, an exception is thrown.
This property is write-only. The TemplateId property corresponds to the Template.TemplateId attribute, which is the primary key for the Template entity.
When you use the BulkDetectDuplicatesRequest class, you can only use a template of the Asyncoperation entity type. Use the Template.TemplateTypeCode attribute to set the template type. If you use a template of any other type, an exception is thrown.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesRequest Class
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesRequest.ToRecipients Property
[image]

Gets or sets an array of IDs for the system users (users) who are listed in the “To” box (recipients) of the email notification.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ToRecipients As Guid()

C#
public Guid[] ToRecipients { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]
The array of IDs for the system users (users) who are listed in the “To” box (recipients) of the email notification.

  Remarks
Each element in the ToRecipients array corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.
Each ID must be for a user who has a valid email address. This property is required if the SendEmailNotification property is set to true; otherwise, it is optional. If the SendEmailNotification property is set to true, an email notification is sent to all users who have the IDs that are specified in this property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesRequest Class
BulkDetectDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesResponse Class
See Also Members
[image]

Contains the response from the BulkDetectDuplicatesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BulkDetectDuplicatesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BulkDetectDuplicatesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.BulkDetectDuplicatesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
BulkDetectDuplicatesRequest


BulkDetectDuplicatesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the BulkDetectDuplicatesRequest class.

The following tables list the members exposed by the BulkDetectDuplicatesResponse type.

Public Constructors

Name | Description
BulkDetectDuplicatesResponse | Initializes a new instance of the BulkDetectDuplicatesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | JobId | Gets the ID of an asynchronous bulk detect duplicates job that detects and logs duplicate records.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BulkDetectDuplicatesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDetectDuplicatesRequest


BulkDetectDuplicatesResponse Constructor
[image]

Initializes a new instance of the BulkDetectDuplicatesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BulkDetectDuplicatesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesResponse Class
BulkDetectDuplicatesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BulkDetectDuplicatesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BulkDetectDuplicatesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDetectDuplicatesRequest


BulkDetectDuplicatesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | JobId | Gets the ID of an asynchronous bulk detect duplicates job that detects and logs duplicate records.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

BulkDetectDuplicatesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BulkDetectDuplicatesRequest


BulkDetectDuplicatesResponse.JobId Property
[image]

Gets the ID of an asynchronous bulk detect duplicates job that detects and logs duplicate records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property JobId As Guid

C#
public Guid JobId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of an asynchronous bulk detect duplicates job that detects and logs duplicate records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkDetectDuplicatesResponse Class
BulkDetectDuplicatesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BulkOperationSource Enumeration
[image]

Contains the possible sources of a bulk operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration BulkOperationSource

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum BulkOperationSource

C++

J#

JScript

  Members
Member name | Description
CampaignActivity | The bulk operation is for distributing a campaign activity to members of a list. Value = 1.
QuickCampaign | The bulk operation is to distribute a quick campaign to members of a list of accounts, contacts, or leads that are selected by a query. Value = 0.
  Remarks
This enumeration is used for the BulkOperationSource property.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Campaign Entities


BulkOperationStatusCloseRequest Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BulkOperationStatusCloseRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BulkOperationStatusCloseRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.BulkOperationStatusCloseRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkOperationStatusCloseRequest Members
Microsoft.Crm.Sdk.Messages Namespace
BulkOperationStatusCloseResponse
Other Resources
BulkOperationStatusClose Privileges


BulkOperationStatusCloseRequest Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the BulkOperationStatusCloseRequest type.

Public Constructors

Name | Description
BulkOperationStatusCloseRequest | For internal use only.
Top

Public Properties

 | Name | Description
public property | BulkOperationId | For internal use only.
public property | ErrorCode | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FailureCount | For internal use only.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | StatusReason | For internal use only.
public property | SuccessCount | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BulkOperationStatusCloseRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BulkOperationStatusCloseResponse

Other Resources

BulkOperationStatusClose Privileges


BulkOperationStatusCloseRequest Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BulkOperationStatusCloseRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkOperationStatusCloseRequest Class
BulkOperationStatusCloseRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkOperationStatusCloseRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BulkOperationStatusCloseRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BulkOperationStatusCloseResponse

Other Resources

BulkOperationStatusClose Privileges


BulkOperationStatusCloseRequest Properties
[image]

Public Properties

 | Name | Description
public property | BulkOperationId | For internal use only.
public property | ErrorCode | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FailureCount | For internal use only.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | StatusReason | For internal use only.
public property | SuccessCount | For internal use only.

See Also

Reference

BulkOperationStatusCloseRequest Class
Microsoft.Crm.Sdk.Messages Namespace
BulkOperationStatusCloseResponse

Other Resources

BulkOperationStatusClose Privileges


BulkOperationStatusCloseRequest.BulkOperationId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkOperationStatusCloseRequest Class
BulkOperationStatusCloseRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkOperationStatusCloseRequest.ErrorCode Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ErrorCode As Integer

C#
public int ErrorCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkOperationStatusCloseRequest Class
BulkOperationStatusCloseRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkOperationStatusCloseRequest.FailureCount Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FailureCount As Integer

C#
public int FailureCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkOperationStatusCloseRequest Class
BulkOperationStatusCloseRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkOperationStatusCloseRequest.StatusReason Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property StatusReason As Integer

C#
public int StatusReason { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkOperationStatusCloseRequest Class
BulkOperationStatusCloseRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkOperationStatusCloseRequest.SuccessCount Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SuccessCount As Integer

C#
public int SuccessCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkOperationStatusCloseRequest Class
BulkOperationStatusCloseRequest Members
Microsoft.Crm.Sdk.Messages Namespace


BulkOperationStatusCloseResponse Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BulkOperationStatusCloseResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BulkOperationStatusCloseResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.BulkOperationStatusCloseResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkOperationStatusCloseResponse Members
Microsoft.Crm.Sdk.Messages Namespace
BulkOperationStatusCloseRequest


BulkOperationStatusCloseResponse Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the BulkOperationStatusCloseResponse type.

Public Constructors

Name | Description
BulkOperationStatusCloseResponse | For internal use only.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BulkOperationStatusCloseResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BulkOperationStatusCloseRequest


BulkOperationStatusCloseResponse Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BulkOperationStatusCloseResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BulkOperationStatusCloseResponse Class
BulkOperationStatusCloseResponse Members
Microsoft.Crm.Sdk.Messages Namespace


BulkOperationStatusCloseResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BulkOperationStatusCloseResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BulkOperationStatusCloseRequest


BulkOperationStatusCloseResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

BulkOperationStatusCloseResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BulkOperationStatusCloseRequest


BusinessNotification Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class BusinessNotification
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class BusinessNotification : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.BusinessNotification
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotification Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotification Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the BusinessNotification type.

Public Constructors

Name | Description
BusinessNotification |
Top

Public Properties

 | Name | Description
public property | ExtensionData |
public property | Message |
public property | Parameters |
public property | Severity |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BusinessNotification Class
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotification Constructor
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    severity As BusinessNotificationSeverity, _
    message As String _
)

C#
public BusinessNotification (
    BusinessNotificationSeverity severity,
    string message
)

C++

J#

JScript

Parameters
severity
message
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotification Class
BusinessNotification Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotification Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BusinessNotification Class
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotification Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData |
public property | Message |
public property | Parameters |
public property | Severity |

See Also

Reference

BusinessNotification Class
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotification.ExtensionData Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Returns ExtensionDataObject.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotification Class
BusinessNotification Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotification.Message Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Message As String

C#
[DataMemberAttribute]
public string Message { get; set; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotification Class
BusinessNotification Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotification.Parameters Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Parameters As BusinessNotificationParameter()

C#
[DataMemberAttribute]
public BusinessNotificationParameter[] Parameters { get; set; }

C++

J#

JScript

Property Value
Returns BusinessNotificationParameter.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotification Class
BusinessNotification Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotification.Severity Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Severity As BusinessNotificationSeverity

C#
[DataMemberAttribute]
public BusinessNotificationSeverity Severity { get; set; }

C++

J#

JScript

Property Value
Returns BusinessNotificationSeverity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotification Class
BusinessNotification Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotificationParameter Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class BusinessNotificationParameter

C#
public sealed class BusinessNotificationParameter

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.BusinessNotificationParameter
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotificationParameter Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotificationParameter Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the BusinessNotificationParameter type.

Public Constructors

Name | Description
BusinessNotificationParameter |
Top

Public Properties

 | Name | Description
public property | Data |
public property | ParameterType |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BusinessNotificationParameter Class
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotificationParameter Constructor
[image]

Initializes a new instance of the BusinessNotificationParameter Class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BusinessNotificationParameter ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotificationParameter Class
BusinessNotificationParameter Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotificationParameter Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BusinessNotificationParameter Class
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotificationParameter Properties
[image]

Public Properties

 | Name | Description
public property | Data |
public property | ParameterType |

See Also

Reference

BusinessNotificationParameter Class
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotificationParameter.Data Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Data As String

C#
[DataMemberAttribute]
public string Data { get; set; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotificationParameter Class
BusinessNotificationParameter Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotificationParameter.ParameterType Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ParameterType As BusinessNotificationParameterType

C#
[DataMemberAttribute]
public BusinessNotificationParameterType ParameterType { get; set; }

C++

J#

JScript

Property Value
Returns BusinessNotificationParameterType.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BusinessNotificationParameter Class
BusinessNotificationParameter Members
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotificationParameterType Enumeration
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration BusinessNotificationParameterType

C#
public enum BusinessNotificationParameterType

C++

J#

JScript

  Members
Member name | Description
Attribute |
None |
String |
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace


BusinessNotificationSeverity Enumeration
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration BusinessNotificationSeverity

C#
public enum BusinessNotificationSeverity

C++

J#

JScript

  Members
Member name | Description
Error |
Information |
None |
UserDefined |
Warning |
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace


CalculateActualValueOpportunityRequest Class
See Also Members
[image]

Contains the data that is needed to calculate the value of an opportunity that is in the "Won" state.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CalculateActualValueOpportunityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CalculateActualValueOpportunityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the CalculateActualValueOpportunityResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Opportunity entity and access rights on the specified record in the OpportunityId property. For a complete list of the required privileges, see CalculateActualValueOpportunity Privileges.
Notes for Callers
"Won" is one of the possible states for an opportunity. It indicates that the opportunity has been won. The state of an Opportunity record is specified in the Opportunity.StateCode attribute. For a list of the opportunity state and status values, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.  For more information, see Record State and Status.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CalculateActualValueOpportunityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateActualValueOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CalculateActualValueOpportunityResponse
Other Resources
Opportunity Entities
CalculateActualValueOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CalculateActualValueOpportunityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to calculate the value of an opportunity that is in the "Won" state.

The following tables list the members exposed by the CalculateActualValueOpportunityRequest type.

Public Constructors

Name | Description
CalculateActualValueOpportunityRequest | Initializes a new instance of the CalculateActualValueOpportunityRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CalculateActualValueOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateActualValueOpportunityResponse

Other Resources

Opportunity Entities
CalculateActualValueOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CalculateActualValueOpportunityRequest Constructor
[image]

Initializes a new instance of the CalculateActualValueOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CalculateActualValueOpportunityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateActualValueOpportunityRequest Class
CalculateActualValueOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateActualValueOpportunityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CalculateActualValueOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateActualValueOpportunityResponse

Other Resources

Opportunity Entities
CalculateActualValueOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CalculateActualValueOpportunityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CalculateActualValueOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateActualValueOpportunityResponse

Other Resources

Opportunity Entities
CalculateActualValueOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CalculateActualValueOpportunityRequest.OpportunityId Property
[image]

Gets or sets the ID of the opportunity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityId As Guid

C#
public Guid OpportunityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the opportunity that corresponds to the Opportunity.OpportunityId attribute, which is the primary key for the Opportunity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateActualValueOpportunityRequest Class
CalculateActualValueOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateActualValueOpportunityResponse Class
See Also Members
[image]

Contains the response from the CalculateActualValueOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CalculateActualValueOpportunityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CalculateActualValueOpportunityResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CalculateActualValueOpportunityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateActualValueOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CalculateActualValueOpportunityRequest


CalculateActualValueOpportunityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CalculateActualValueOpportunityRequest class.

The following tables list the members exposed by the CalculateActualValueOpportunityResponse type.

Public Constructors

Name | Description
CalculateActualValueOpportunityResponse | Initializes a new instance of the CalculateActualValueOpportunityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Value | Gets the actual value of an opportunity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CalculateActualValueOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateActualValueOpportunityRequest


CalculateActualValueOpportunityResponse Constructor
[image]

Initializes a new instance of the CalculateActualValueOpportunityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CalculateActualValueOpportunityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateActualValueOpportunityResponse Class
CalculateActualValueOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateActualValueOpportunityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CalculateActualValueOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateActualValueOpportunityRequest


CalculateActualValueOpportunityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Value | Gets the actual value of an opportunity.

See Also

Reference

CalculateActualValueOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateActualValueOpportunityRequest


CalculateActualValueOpportunityResponse.Value Property
[image]

Gets the actual value of an opportunity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Value As Decimal

C#
public decimal Value { get; }

C++

J#

JScript

Property Value
Type: Decimal
The actual value of an opportunity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateActualValueOpportunityResponse Class
CalculateActualValueOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CalculatePriceRequest Class
See Also Members
[image]

Contains the data that is needed to calculate price in an opportunity, quote, order, and invoice. This is used internally for custom pricing calculation when the default system pricing is overridden.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CalculatePriceRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CalculatePriceRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
This message does not have any usage scenario of its own. It provides you the capability to plug in your own custom pricing calculation logic if you do not want to use the out-of-box pricing provided by CRM. To use this message, you must create a plug-in with the custom pricing logic, and register the plug-in on the CalculatePrice message. Additionally, you must set the value of the Organization.OOBPriceCalculationEnabled attribute to 0 (false) to override the system pricing engine. More information:Use custom pricing for products
Privileges and Access Rights
To perform this action, the caller must have privileges on the Opportunity, Quote, SalesOrder, and Invoice entities.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CalculatePriceRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculatePriceRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Use custom pricing for products
Sample: Calculate Price plug-in


CalculatePriceRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to calculate price in an opportunity, quote, order, and invoice. This is used internally for custom pricing calculation when the default system pricing is overridden.

The following tables list the members exposed by the CalculatePriceRequest type.

Public Constructors

Name | Description
CalculatePriceRequest | Initializes a new instance of the CalculatePriceRequest.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentId | For internal use only.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CalculatePriceRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Use custom pricing for products
Sample: Calculate Price plug-in


CalculatePriceRequest Constructor
[image]

Initializes a new instance of the CalculatePriceRequest.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CalculatePriceRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculatePriceRequest Class
CalculatePriceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculatePriceRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CalculatePriceRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Use custom pricing for products
Sample: Calculate Price plug-in


CalculatePriceRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentId | For internal use only.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | For internal use only.

See Also

Reference

CalculatePriceRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Use custom pricing for products
Sample: Calculate Price plug-in


CalculatePriceRequest.ParentId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ParentId As Guid

C#
public Guid ParentId { get; set; }

C++

J#

JScript

Property Value
Type Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculatePriceRequest Class
CalculatePriceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculatePriceRequest.Target Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type EntityReference
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculatePriceRequest Class
CalculatePriceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculatePriceResponse Class
See Also Members
[image]

Contains the response from the CalculatePriceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CalculatePriceResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CalculatePriceResponse : OrganizationResponse

C++

J#

JScript

  Remarks
There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CalculatePriceResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculatePriceResponse Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Use custom pricing for products


CalculatePriceResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CalculatePriceRequest class.

The following tables list the members exposed by the CalculatePriceResponse type.

Public Constructors

Name | Description
CalculatePriceResponse | Initializes a new instance of the CalculatePriceResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CalculatePriceResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Use custom pricing for products


CalculatePriceResponse Constructor
[image]

Initializes a new instance of the CalculatePriceResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CalculatePriceResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculatePriceResponse Class
CalculatePriceResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CalculatePriceResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CalculatePriceResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Use custom pricing for products


CalculatePriceResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CalculatePriceResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Use custom pricing for products


CalculateRollupFieldRequest Class
See Also Members
[image]

Contains the data that is needed to calculate the value of a rollup attribute.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CalculateRollupFieldRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CalculateRollupFieldRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the CalculateRollupFieldResponse class.
Privileges and Access Rights
To perform this action, the caller must have read privileges on the entity instance that contains the rollup field.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CalculateRollupFieldRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateRollupFieldRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CalculateRollupFieldResponse
Other Resources
Calculated and Rollup Attributes


CalculateRollupFieldRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to calculate the value of a rollup attribute.

The following tables list the members exposed by the CalculateRollupFieldRequest type.

Public Constructors

Name | Description
CalculateRollupFieldRequest | Initializes a new instance of the CalculateRollupFieldRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FieldName | Gets or sets logical name of the attribute to calculate. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets a reference to the record containing the rollup attribute to calculate. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CalculateRollupFieldRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateRollupFieldResponse

Other Resources

Calculated and Rollup Attributes


CalculateRollupFieldRequest Constructor
[image]

Initializes a new instance of the CalculateRollupFieldRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CalculateRollupFieldRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateRollupFieldRequest Class
CalculateRollupFieldRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateRollupFieldRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CalculateRollupFieldRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateRollupFieldResponse

Other Resources

Calculated and Rollup Attributes


CalculateRollupFieldRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FieldName | Gets or sets logical name of the attribute to calculate. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets a reference to the record containing the rollup attribute to calculate. Required.

See Also

Reference

CalculateRollupFieldRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateRollupFieldResponse

Other Resources

Calculated and Rollup Attributes


CalculateRollupFieldRequest.FieldName Property
[image]

Gets or sets logical name of the attribute to calculate. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FieldName As String

C#
public string FieldName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the attribute to calculate.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateRollupFieldRequest Class
CalculateRollupFieldRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateRollupFieldRequest.Target Property
[image]

Gets or sets a reference to the record containing the rollup attribute to calculate. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
A reference to the record containing the rollup attribute to calculate.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateRollupFieldRequest Class
CalculateRollupFieldRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateRollupFieldResponse Class
See Also Members
[image]

Contains the response from the CalculateRollupFieldRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CalculateRollupFieldResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CalculateRollupFieldResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CalculateRollupFieldResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateRollupFieldResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CalculateRollupFieldRequest
Other Resources
Calculated and Rollup Attributes


CalculateRollupFieldResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CalculateRollupFieldRequest class.

The following tables list the members exposed by the CalculateRollupFieldResponse type.

Public Constructors

Name | Description
CalculateRollupFieldResponse | Initializes a new instance of the CalculateRollupFieldResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets an entity that contains the attributes relevant to the calculated rollup attribute.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CalculateRollupFieldResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateRollupFieldRequest

Other Resources

Calculated and Rollup Attributes


CalculateRollupFieldResponse Constructor
[image]

Initializes a new instance of the CalculateRollupFieldResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CalculateRollupFieldResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateRollupFieldResponse Class
CalculateRollupFieldResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateRollupFieldResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CalculateRollupFieldResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateRollupFieldRequest

Other Resources

Calculated and Rollup Attributes


CalculateRollupFieldResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets an entity that contains the attributes relevant to the calculated rollup attribute.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CalculateRollupFieldResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateRollupFieldRequest

Other Resources

Calculated and Rollup Attributes


CalculateRollupFieldResponse.Entity Property
[image]

Gets an entity that contains the attributes relevant to the calculated rollup attribute.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
An entity that contains the attributes relevant to the calculated rollup attribute.

  Remarks
This entity will contain three attributes that are returned in this entity instance.
Attribute Name | Type | Description
<attribute SchemaName> | Depends on the type of attribute. | The rollup attribute value.
<attribute SchemaName>_Date | DateTime | When the rollup was last calculated.
<attribute SchemaName>_State | Int32 | The state of the rollup calculation. See Rollup State Values for information on the possible state values.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateRollupFieldResponse Class
CalculateRollupFieldResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateTotalTimeIncidentRequest Class
See Also Members
[image]

Contains the data that is needed to calculate the total time, in minutes, that you used while you worked on an incident (case).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CalculateTotalTimeIncidentRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CalculateTotalTimeIncidentRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the CalculateTotalTimeIncidentResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Incident entity and access rights on the specified record in the IncidentId property. For a complete list of the required privileges, see CalculateTotalTimeIncident Privileges.
Notes for Callers
If an activity that is used to resolve the incident (case) has already been billed, those minutes are not included in the calculation of the current incident.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CalculateTotalTimeIncidentRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateTotalTimeIncidentRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CalculateTotalTimeIncidentResponse
Other Resources
Incident (Case) Entities
Sample: Close an Incident
CalculateTotalTimeIncident Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CalculateTotalTimeIncidentRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to calculate the total time, in minutes, that you used while you worked on an incident (case).

The following tables list the members exposed by the CalculateTotalTimeIncidentRequest type.

Public Constructors

Name | Description
CalculateTotalTimeIncidentRequest | Initializes a new instance of the CalculateTotalTimeIncidentRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncidentId | Gets or sets the ID of the incident (case). Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CalculateTotalTimeIncidentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateTotalTimeIncidentResponse

Other Resources

Incident (Case) Entities
Sample: Close an Incident
CalculateTotalTimeIncident Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CalculateTotalTimeIncidentRequest Constructor
[image]

Initializes a new instance of the CalculateTotalTimeIncidentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CalculateTotalTimeIncidentRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateTotalTimeIncidentRequest Class
CalculateTotalTimeIncidentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateTotalTimeIncidentRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CalculateTotalTimeIncidentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateTotalTimeIncidentResponse

Other Resources

Incident (Case) Entities
Sample: Close an Incident
CalculateTotalTimeIncident Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CalculateTotalTimeIncidentRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncidentId | Gets or sets the ID of the incident (case). Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CalculateTotalTimeIncidentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateTotalTimeIncidentResponse

Other Resources

Incident (Case) Entities
Sample: Close an Incident
CalculateTotalTimeIncident Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CalculateTotalTimeIncidentRequest.IncidentId Property
[image]

Gets or sets the ID of the incident (case). Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IncidentId As Guid

C#
public Guid IncidentId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the incident (case) that corresponds to the IncidentId.IncidentId attribute, which is the primary key for the Incident entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateTotalTimeIncidentRequest Class
CalculateTotalTimeIncidentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateTotalTimeIncidentResponse Class
See Also Members
[image]

Contains the response from the CalculateTotalTimeIncidentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CalculateTotalTimeIncidentResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CalculateTotalTimeIncidentResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CalculateTotalTimeIncidentResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateTotalTimeIncidentResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CalculateTotalTimeIncidentRequest


CalculateTotalTimeIncidentResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CalculateTotalTimeIncidentRequest class.

The following tables list the members exposed by the CalculateTotalTimeIncidentResponse type.

Public Constructors

Name | Description
CalculateTotalTimeIncidentResponse | Initializes a new instance of the CalculateTotalTimeIncidentResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TotalTime | Gets the total time, in minutes that you use when you work on an incident (case).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CalculateTotalTimeIncidentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateTotalTimeIncidentRequest


CalculateTotalTimeIncidentResponse Constructor
[image]

Initializes a new instance of the CalculateTotalTimeIncidentResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CalculateTotalTimeIncidentResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateTotalTimeIncidentResponse Class
CalculateTotalTimeIncidentResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CalculateTotalTimeIncidentResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CalculateTotalTimeIncidentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateTotalTimeIncidentRequest


CalculateTotalTimeIncidentResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TotalTime | Gets the total time, in minutes that you use when you work on an incident (case).

See Also

Reference

CalculateTotalTimeIncidentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CalculateTotalTimeIncidentRequest


CalculateTotalTimeIncidentResponse.TotalTime Property
[image]

Gets the total time, in minutes that you use when you work on an incident (case).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property TotalTime As Long

C#
public long TotalTime { get; }

C++

J#

JScript

Property Value
Type: Int64
The total time, in minutes that you use when you work on an incident (case).

  Remarks
If an activity that is used to resolve the incident (case) has already been billed, those minutes are not included in the calculation.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CalculateTotalTimeIncidentResponse Class
CalculateTotalTimeIncidentResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CancelContractRequest Class
See Also Members
[image]

Contains the data that is needed to cancel a contract.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CancelContractRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CancelContractRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the CancelContractResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Contract entity and access rights on the specified record in the ContractId property. For a complete list of the required privileges, see CancelContract Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CancelContractRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CancelContractResponse
Other Resources
Contract Entities
CancelContract Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CancelContractRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to cancel a contract.

The following tables list the members exposed by the CancelContractRequest type.

Public Constructors

Name | Description
CancelContractRequest | Initializes a new instance of the CancelContractRequest class.
Top

Public Properties

 | Name | Description
public property | CancelDate | Gets or sets the contract cancellation date. Required.
public property | ContractId | Gets or sets the ID of the contract. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets the status of the contract. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CancelContractRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CancelContractResponse

Other Resources

Contract Entities
CancelContract Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CancelContractRequest Constructor
[image]

Initializes a new instance of the CancelContractRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CancelContractRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelContractRequest Class
CancelContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CancelContractRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CancelContractRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CancelContractResponse

Other Resources

Contract Entities
CancelContract Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CancelContractRequest Properties
[image]

Public Properties

 | Name | Description
public property | CancelDate | Gets or sets the contract cancellation date. Required.
public property | ContractId | Gets or sets the ID of the contract. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets the status of the contract. Required.

See Also

Reference

CancelContractRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CancelContractResponse

Other Resources

Contract Entities
CancelContract Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CancelContractRequest.CancelDate Property
[image]

Gets or sets the contract cancellation date. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CancelDate As DateTime

C#
public DateTime CancelDate { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The contract cancellation date.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelContractRequest Class
CancelContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CancelContractRequest.ContractId Property
[image]

Gets or sets the ID of the contract. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ContractId As Guid

C#
public Guid ContractId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the contract that corresponds to the Contract.ContractId attribute, which is the primary key for the Contract entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelContractRequest Class
CancelContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CancelContractRequest.Status Property
[image]

Gets or sets the status of the contract. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The status of the contract.

  Remarks
The Status property corresponds to the Contract.StatusCode attribute. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system sets the corresponding status value. For a list of the status values, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download. For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelContractRequest Class
CancelContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CancelContractResponse Class
See Also Members
[image]

Contains the response from the CancelContractRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CancelContractResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CancelContractResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CancelContractResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelContractResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CancelContractRequest


CancelContractResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CancelContractRequest class.

The following tables list the members exposed by the CancelContractResponse type.

Public Constructors

Name | Description
CancelContractResponse | Initializes a new instance of the CancelContractResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CancelContractResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CancelContractRequest


CancelContractResponse Constructor
[image]

Initializes a new instance of the CancelContractResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CancelContractResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelContractResponse Class
CancelContractResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CancelContractResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CancelContractResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CancelContractRequest


CancelContractResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CancelContractResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CancelContractRequest


CancelSalesOrderRequest Class
See Also Example Members
[image]

Contains the data that is needed to cancel a sales order (order).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CancelSalesOrderRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CancelSalesOrderRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Define columns to be retrieved after creating the order
salesOrderColumns = new ColumnSet("salesorderid", "totalamount");

// Convert the quote to a sales order
convertQuoteRequest =
    new ConvertQuoteToSalesOrderRequest()
    {
        QuoteId = _quoteId,
        ColumnSet = salesOrderColumns
    };
convertQuoteResponse =
    (ConvertQuoteToSalesOrderResponse)_serviceProxy.Execute(convertQuoteRequest);
SalesOrder closeSalesOrder = (SalesOrder)convertQuoteResponse.Entity;
_closeSalesOrderId = closeSalesOrder.Id;

CancelSalesOrderRequest cancelRequest = new CancelSalesOrderRequest()
{
    OrderClose = new OrderClose()
    {
        SalesOrderId = closeSalesOrder.ToEntityReference(),
        Subject = "Close Sales Order " + DateTime.Now
    },
    Status = new OptionSetValue(-1)
};
_serviceProxy.Execute(cancelRequest);

Console.WriteLine("Canceled sales order");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the CancelSalesOrderResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the SalesOrder entity. For a complete list of the required privileges, see CancelSalesOrder Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CancelSalesOrderRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CancelSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CancelSalesOrderResponse
Other Resources
Quote, Order and Invoice Entities
SalesOrder (Order) Entity Messages and Methods
Sample: Process Quotes, Sales Orders and Invoices
CancelSalesOrder Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CancelSalesOrderRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to cancel a sales order (order).

The following tables list the members exposed by the CancelSalesOrderRequest type.

Public Constructors

Name | Description
CancelSalesOrderRequest | Initializes a new instance of the CancelSalesOrderRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OrderClose | Gets or sets the close activity that is associated with the sales order (order) that you want to cancel. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets the status of the sales order (order). Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CancelSalesOrderRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CancelSalesOrderResponse

Other Resources

Quote, Order and Invoice Entities
SalesOrder (Order) Entity Messages and Methods
Sample: Process Quotes, Sales Orders and Invoices
CancelSalesOrder Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CancelSalesOrderRequest Constructor
[image]

Initializes a new instance of the CancelSalesOrderRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CancelSalesOrderRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelSalesOrderRequest Class
CancelSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CancelSalesOrderRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CancelSalesOrderRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CancelSalesOrderResponse

Other Resources

Quote, Order and Invoice Entities
SalesOrder (Order) Entity Messages and Methods
Sample: Process Quotes, Sales Orders and Invoices
CancelSalesOrder Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CancelSalesOrderRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OrderClose | Gets or sets the close activity that is associated with the sales order (order) that you want to cancel. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets the status of the sales order (order). Required.

See Also

Reference

CancelSalesOrderRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CancelSalesOrderResponse

Other Resources

Quote, Order and Invoice Entities
SalesOrder (Order) Entity Messages and Methods
Sample: Process Quotes, Sales Orders and Invoices
CancelSalesOrder Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CancelSalesOrderRequest.OrderClose Property
[image]

Gets or sets the close activity that is associated with the sales order (order) that you want to cancel. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OrderClose As Entity

C#
public Entity OrderClose { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The close activity that is associated with the sales order (order) that you want to cancel. This is an instance of the OrderClose class, which is a subclass of the Entity class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelSalesOrderRequest Class
CancelSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CancelSalesOrderRequest.Status Property
[image]

Gets or sets the status of the sales order (order). Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The status of the sales order (order).

  Remarks
The Status property corresponds to the SalesOrder.StatusCode attribute. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system sets the corresponding status value. For a list of the status values, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.  For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelSalesOrderRequest Class
CancelSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CancelSalesOrderResponse Class
See Also Members
[image]

Contains the response from the CancelSalesOrderRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CancelSalesOrderResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CancelSalesOrderResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CancelSalesOrderResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelSalesOrderResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CancelSalesOrderRequest


CancelSalesOrderResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CancelSalesOrderRequest class.

The following tables list the members exposed by the CancelSalesOrderResponse type.

Public Constructors

Name | Description
CancelSalesOrderResponse | Initializes a new instance of the CancelSalesOrderResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CancelSalesOrderResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CancelSalesOrderRequest


CancelSalesOrderResponse Constructor
[image]

Initializes a new instance of the CancelSalesOrderResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CancelSalesOrderResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelSalesOrderResponse Class
CancelSalesOrderResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CancelSalesOrderResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CancelSalesOrderResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CancelSalesOrderRequest


CancelSalesOrderResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CancelSalesOrderResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CancelSalesOrderRequest


CheckIncomingEmailRequest Class
See Also Members
[image]

Contains the data that is needed to check whether the incoming email message is relevant to the Microsoft Dynamics CRM system.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CheckIncomingEmailRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CheckIncomingEmailRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of CheckIncomingEmailResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the activity entity. For a complete list of the privileges required, see CheckIncomingEmail Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CheckIncomingEmailRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CheckIncomingEmailResponse
Other Resources
Email (E-mail) Entity Messages and Methods
CheckIncomingEmail Privileges


CheckIncomingEmailRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to check whether the incoming email message is relevant to the Microsoft Dynamics CRM system.

The following tables list the members exposed by the CheckIncomingEmailRequest type.

Public Constructors

Name | Description
CheckIncomingEmailRequest | Initializes a new instance of the CheckIncomingEmailRequest class.
Top

Public Properties

 | Name | Description
public property | Bcc | Gets or sets the addresses of the blind carbon copy (Bcc) recipients for the email message.
public property | Cc | Gets or sets the addresses of the carbon copy (Cc) recipients for the email message.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ExtraProperties | For internal use only.
public property | From | Gets or sets the from address for the email message.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MessageId | Gets or sets the ID of the email message stored in the email header. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the subject line for the email message. Optional.
public property | To | Gets or sets the addresses of the recipients of the email message.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CheckIncomingEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CheckIncomingEmailResponse

Other Resources

Email (E-mail) Entity Messages and Methods
CheckIncomingEmail Privileges


CheckIncomingEmailRequest Constructor
[image]

Initializes a new instance of the CheckIncomingEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CheckIncomingEmailRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailRequest Class
CheckIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CheckIncomingEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CheckIncomingEmailResponse

Other Resources

Email (E-mail) Entity Messages and Methods
CheckIncomingEmail Privileges


CheckIncomingEmailRequest Properties
[image]

Public Properties

 | Name | Description
public property | Bcc | Gets or sets the addresses of the blind carbon copy (Bcc) recipients for the email message.
public property | Cc | Gets or sets the addresses of the carbon copy (Cc) recipients for the email message.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ExtraProperties | For internal use only.
public property | From | Gets or sets the from address for the email message.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MessageId | Gets or sets the ID of the email message stored in the email header. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the subject line for the email message. Optional.
public property | To | Gets or sets the addresses of the recipients of the email message.

See Also

Reference

CheckIncomingEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CheckIncomingEmailResponse

Other Resources

Email (E-mail) Entity Messages and Methods
CheckIncomingEmail Privileges


CheckIncomingEmailRequest.Bcc Property
[image]

Gets or sets the addresses of the blind carbon copy (Bcc) recipients for the email message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Bcc As String

C#
public string Bcc { get; set; }

C++

J#

JScript

Property Value
Type: String
The addresses of the blind carbon copy (Bcc) recipients for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailRequest Class
CheckIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailRequest.Cc Property
[image]

Gets or sets the addresses of the carbon copy (Cc) recipients for the email message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Cc As String

C#
public string Cc { get; set; }

C++

J#

JScript

Property Value
Type: String
The carbon copy (Cc) recipients for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailRequest Class
CheckIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailRequest.ExtraProperties Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtraProperties As Entity

C#
public Entity ExtraProperties { get; set; }

C++

J#

JScript

Property Value
Type: Entity
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailRequest Class
CheckIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailRequest.From Property
[image]

Gets or sets the from address for the email message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property From As String

C#
public string From { get; set; }

C++

J#

JScript

Property Value
Type: String
The from address for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailRequest Class
CheckIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailRequest.MessageId Property
[image]

Gets or sets the ID of the email message stored in the email header. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MessageId As String

C#
public string MessageId { get; set; }

C++

J#

JScript

Property Value
Type: String
The ID of the email message stored in the email header.

  Remarks
All email messages have an ID property in their headers. This is similar to a GUID and is used to identify the message and to see whether a specific email message has already been promoted (added) to Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailRequest Class
CheckIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailRequest.Subject Property
[image]

Gets or sets the subject line for the email message. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Subject As String

C#
public string Subject { get; set; }

C++

J#

JScript

Property Value
Type: String
The subject line for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailRequest Class
CheckIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailRequest.To Property
[image]

Gets or sets the addresses of the recipients of the email message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property To As String

C#
public string To { get; set; }

C++

J#

JScript

Property Value
Type: String
The addresses of the recipients of the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailRequest Class
CheckIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailResponse Class
See Also Members
[image]

Contains the response from the CheckIncomingEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CheckIncomingEmailResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CheckIncomingEmailResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CheckIncomingEmailResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CheckIncomingEmailRequest
Other Resources
Email (E-mail) Entity Messages and Methods
CheckIncomingEmail Privileges


CheckIncomingEmailResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CheckIncomingEmailRequest class.

The following tables list the members exposed by the CheckIncomingEmailResponse type.

Public Constructors

Name | Description
CheckIncomingEmailResponse | Initializes a new instance of the CheckIncomingEmailResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ReasonCode | Gets the reason for the result in the ShouldDeliver property.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ShouldDeliver | Gets a value that indicates whether the message should be delivered to Microsoft Dynamics CRM.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CheckIncomingEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CheckIncomingEmailRequest

Other Resources

Email (E-mail) Entity Messages and Methods
CheckIncomingEmail Privileges


CheckIncomingEmailResponse Constructor
[image]

Initializes a new instance of the CheckIncomingEmailResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CheckIncomingEmailResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailResponse Class
CheckIncomingEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CheckIncomingEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CheckIncomingEmailRequest

Other Resources

Email (E-mail) Entity Messages and Methods
CheckIncomingEmail Privileges


CheckIncomingEmailResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ReasonCode | Gets the reason for the result in the ShouldDeliver property.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ShouldDeliver | Gets a value that indicates whether the message should be delivered to Microsoft Dynamics CRM.

See Also

Reference

CheckIncomingEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CheckIncomingEmailRequest

Other Resources

Email (E-mail) Entity Messages and Methods
CheckIncomingEmail Privileges


CheckIncomingEmailResponse.ReasonCode Property
[image]

Gets the reason for the result in the ShouldDeliver property.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ReasonCode As Integer

C#
public int ReasonCode { get; }

C++

J#

JScript

Property Value
Type: Int32

The reason for the failure.

  Remarks
The reason code is one of these values:
Field | Value | Description
Unknown | -1 | Specifies an unknown reason.
Duplicate | 0 | Specifies a duplicate e-mail message.
NoCorrelationMatch | 1 | Specifies that the Microsoft Dynamics CRMCorrelationToken is present on the subject line but does not map to anything inCRM.
CorrelationMatch | 2 | Specifies that the Microsoft Dynamics CRMCorrelationToken on the subject line maps to a value in CRM.
NoRecipientMatch | 3 | Specifies that none of the recipients are users in Microsoft Dynamics CRM.
InternalEmailReject | 4 | Email delivery determined that the e-mail is internal communication and the e-mail will be rejected.
SenderMatch | 5 | Email accepted because of the sender.
AcceptAll | 6 | A recipient accepts all emails.
InvalidSender | 7 | The sender email address could not be found or is invalid

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailResponse Class
CheckIncomingEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CheckIncomingEmailResponse.ShouldDeliver Property
[image]

Gets a value that indicates whether the message should be delivered to Microsoft Dynamics CRM.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ShouldDeliver As Boolean

C#
public bool ShouldDeliver { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the message should be delivered to Microsoft Dynamics CRM; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckIncomingEmailResponse Class
CheckIncomingEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CheckPromoteEmailRequest Class
See Also Members
[image]

Contains the data that is needed to check whether the incoming email message should be promoted to the Microsoft Dynamics CRM system.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CheckPromoteEmailRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CheckPromoteEmailRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of CheckPromoteEmailResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the activity entity. For a complete list of the privileges required, see CheckPromoteEmail Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CheckPromoteEmailRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CheckPromoteEmailResponse
Other Resources
Email (E-mail) Entity Messages and Methods
E-mail Activity Entities


CheckPromoteEmailRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to check whether the incoming email message should be promoted to the Microsoft Dynamics CRM system.

The following tables list the members exposed by the CheckPromoteEmailRequest type.

Public Constructors

Name | Description
CheckPromoteEmailRequest | Initializes a new instance of the CheckPromoteEmailRequest class.
Top

Public Properties

 | Name | Description
public property | DirectionCode | Provides the direction of a mail checked for promotion for uniqueness.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MessageId | Gets or sets the message ID that is contained in the email header. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the subject of the message. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CheckPromoteEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CheckPromoteEmailResponse

Other Resources

Email (E-mail) Entity Messages and Methods
E-mail Activity Entities


CheckPromoteEmailRequest Constructor
[image]

Initializes a new instance of the CheckPromoteEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CheckPromoteEmailRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckPromoteEmailRequest Class
CheckPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckPromoteEmailRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CheckPromoteEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CheckPromoteEmailResponse

Other Resources

Email (E-mail) Entity Messages and Methods
E-mail Activity Entities


CheckPromoteEmailRequest Properties
[image]

Public Properties

 | Name | Description
public property | DirectionCode | Provides the direction of a mail checked for promotion for uniqueness.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MessageId | Gets or sets the message ID that is contained in the email header. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the subject of the message. Optional.

See Also

Reference

CheckPromoteEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CheckPromoteEmailResponse

Other Resources

Email (E-mail) Entity Messages and Methods
E-mail Activity Entities


CheckPromoteEmailRequest.DirectionCode Property
[image]

Provides the direction of a mail checked for promotion for uniqueness.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DirectionCode As Integer

C#
public int DirectionCode { get; set; }

C++

J#

JScript

Property Value
Returns Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckPromoteEmailRequest Class
CheckPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckPromoteEmailRequest.MessageId Property
[image]

Gets or sets the message ID that is contained in the email header. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MessageId As String

C#
public string MessageId { get; set; }

C++

J#

JScript

Property Value
Type: String
The message ID that is contained in the email header.
All email messages have an ID property in their headers. This is similar to a GUID and is used to identify the message and to see if a specific email message has already been promoted (added) to Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckPromoteEmailRequest Class
CheckPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckPromoteEmailRequest.Subject Property
[image]

Gets or sets the subject of the message. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Subject As String

C#
public string Subject { get; set; }

C++

J#

JScript

Property Value
Type: String
The subject of the message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckPromoteEmailRequest Class
CheckPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CheckPromoteEmailResponse Class
See Also Members
[image]

Contains the response from the CheckPromoteEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CheckPromoteEmailResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CheckPromoteEmailResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CheckPromoteEmailResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckPromoteEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CheckPromoteEmailRequest
Other Resources
Email (E-mail) Entity Messages and Methods
CheckPromoteEmail Privileges


CheckPromoteEmailResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CheckPromoteEmailRequest class.

The following tables list the members exposed by the CheckPromoteEmailResponse type.

Public Constructors

Name | Description
CheckPromoteEmailResponse | Initializes a new instance of the CheckPromoteEmailResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ReasonCode | Gets the reason for the result in the ShouldDeliver property.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ShouldPromote | Gets a value that indicates whether the message should be promoted to Microsoft Dynamics CRM.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CheckPromoteEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CheckPromoteEmailRequest

Other Resources

Email (E-mail) Entity Messages and Methods
CheckPromoteEmail Privileges


CheckPromoteEmailResponse Constructor
[image]

Initializes a new instance of the CheckPromoteEmailResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CheckPromoteEmailResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckPromoteEmailResponse Class
CheckPromoteEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CheckPromoteEmailResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CheckPromoteEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CheckPromoteEmailRequest

Other Resources

Email (E-mail) Entity Messages and Methods
CheckPromoteEmail Privileges


CheckPromoteEmailResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ReasonCode | Gets the reason for the result in the ShouldDeliver property.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ShouldPromote | Gets a value that indicates whether the message should be promoted to Microsoft Dynamics CRM.

See Also

Reference

CheckPromoteEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CheckPromoteEmailRequest

Other Resources

Email (E-mail) Entity Messages and Methods
CheckPromoteEmail Privileges


CheckPromoteEmailResponse.ReasonCode Property
[image]

Gets the reason for the result in the ShouldDeliver property.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ReasonCode As Integer

C#
public int ReasonCode { get; }

C++

J#

JScript

Property Value
Type: Int32
The reason for the result in the ShouldDeliver property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckPromoteEmailResponse Class
CheckPromoteEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CheckPromoteEmailResponse.ShouldPromote Property
[image]

Gets a value that indicates whether the message should be promoted to Microsoft Dynamics CRM.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ShouldPromote As Boolean

C#
public bool ShouldPromote { get; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether the message should be promoted to Microsoft Dynamics CRM.
true, to promote, otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CheckPromoteEmailResponse Class
CheckPromoteEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CleanUpBulkOperationRequest Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CleanUpBulkOperationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CleanUpBulkOperationRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CleanUpBulkOperationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CleanUpBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CleanUpBulkOperationResponse
Other Resources
CleanUpBulkOperation Privileges


CleanUpBulkOperationRequest Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the CleanUpBulkOperationRequest type.

Public Constructors

Name | Description
CleanUpBulkOperationRequest | For internal use only.
Top

Public Properties

 | Name | Description
public property | BulkOperationId | For internal use only.
public property | BulkOperationSource | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CleanUpBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CleanUpBulkOperationResponse

Other Resources

CleanUpBulkOperation Privileges


CleanUpBulkOperationRequest Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CleanUpBulkOperationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CleanUpBulkOperationRequest Class
CleanUpBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CleanUpBulkOperationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CleanUpBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CleanUpBulkOperationResponse

Other Resources

CleanUpBulkOperation Privileges


CleanUpBulkOperationRequest Properties
[image]

Public Properties

 | Name | Description
public property | BulkOperationId | For internal use only.
public property | BulkOperationSource | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CleanUpBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CleanUpBulkOperationResponse

Other Resources

CleanUpBulkOperation Privileges


CleanUpBulkOperationRequest.BulkOperationId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CleanUpBulkOperationRequest Class
CleanUpBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CleanUpBulkOperationRequest.BulkOperationSource Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationSource As Integer

C#
public int BulkOperationSource { get; set; }

C++

J#

JScript

Property Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CleanUpBulkOperationRequest Class
CleanUpBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CleanUpBulkOperationResponse Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CleanUpBulkOperationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CleanUpBulkOperationResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CleanUpBulkOperationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CleanUpBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CleanUpBulkOperationRequest


CleanUpBulkOperationResponse Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the CleanUpBulkOperationResponse type.

Public Constructors

Name | Description
CleanUpBulkOperationResponse | For internal use only.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CleanUpBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CleanUpBulkOperationRequest


CleanUpBulkOperationResponse Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CleanUpBulkOperationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CleanUpBulkOperationResponse Class
CleanUpBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CleanUpBulkOperationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CleanUpBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CleanUpBulkOperationRequest


CleanUpBulkOperationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CleanUpBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CleanUpBulkOperationRequest


CloneContractRequest Class
See Also Example Members
[image]

Contains the data that is needed to copy an existing contract and its line items.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CloneContractRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CloneContractRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create the first clone of the contract.
CloneContractRequest cloneRequest = new CloneContractRequest()
{
    ContractId = _contractId,
    IncludeCanceledLines = false
};
CloneContractResponse cloneResponse =
    (CloneContractResponse)_serviceProxy.Execute(cloneRequest);
_firstCloneId = ((Contract)cloneResponse.Entity).ContractId.Value;

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  CloneContractResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Contract entity and access rights on the record specified in the ContractId property. For a complete list of the required privileges, see CloneContract Privileges.
Notes for Callers
By default the caller will become the owner for the new record. For this to work, the caller must have both Create and Read privileges for the contract entity. For more information, see Privileges by Entity. Alternatively, you can set the ownerid property to the ID of another user.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CloneContractRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CloneContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CloneContractResponse
Other Resources
Contract Entities
CloneContract Privileges
Contract Entity Messages and Methods
Sample: Manage Contracts
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloneContractRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to copy an existing contract and its line items.

The following tables list the members exposed by the CloneContractRequest type.

Public Constructors

Name | Description
CloneContractRequest | Initializes a new instance of the CloneContractRequest class.
Top

Public Properties

 | Name | Description
public property | ContractId | Gets or sets the ID of the contract to be copied. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncludeCanceledLines | Gets or sets a value that indicates whether the canceled line items of the originating contract are to be included in the copy (clone). Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CloneContractRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CloneContractResponse

Other Resources

Contract Entities
CloneContract Privileges
Contract Entity Messages and Methods
Sample: Manage Contracts
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloneContractRequest Constructor
[image]

Initializes a new instance of the CloneContractRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CloneContractRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneContractRequest Class
CloneContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloneContractRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CloneContractRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CloneContractResponse

Other Resources

Contract Entities
CloneContract Privileges
Contract Entity Messages and Methods
Sample: Manage Contracts
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloneContractRequest Properties
[image]

Public Properties

 | Name | Description
public property | ContractId | Gets or sets the ID of the contract to be copied. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncludeCanceledLines | Gets or sets a value that indicates whether the canceled line items of the originating contract are to be included in the copy (clone). Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CloneContractRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CloneContractResponse

Other Resources

Contract Entities
CloneContract Privileges
Contract Entity Messages and Methods
Sample: Manage Contracts
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloneContractRequest.ContractId Property
[image]

Gets or sets the ID of the contract to be copied. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ContractId As Guid

C#
public Guid ContractId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the contract to be copied that corresponds to the Contract.ContractId attribute, which is the primary key for the Contract entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneContractRequest Class
CloneContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloneContractRequest.IncludeCanceledLines Property
[image]

Gets or sets a value that indicates whether the canceled line items of the originating contract are to be included in the copy (clone). Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IncludeCanceledLines As Boolean

C#
public bool IncludeCanceledLines { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to include canceled line items, otherwise, false (default).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneContractRequest Class
CloneContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloneContractResponse Class
See Also Members
[image]

Contains the response from the CancelContractRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CloneContractResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CloneContractResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CloneContractResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneContractResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CancelContractRequest
Other Resources
Contract Entity Messages and Methods
Sample: Manage Contracts


CloneContractResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CancelContractRequest class.

The following tables list the members exposed by the CloneContractResponse type.

Public Constructors

Name | Description
CloneContractResponse | Initializes a new instance of the CloneContractResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the resulting contract.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CloneContractResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CancelContractRequest

Other Resources

Contract Entity Messages and Methods
Sample: Manage Contracts


CloneContractResponse Constructor
[image]

Initializes a new instance of the CloneContractResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CloneContractResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneContractResponse Class
CloneContractResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CloneContractResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CloneContractResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CancelContractRequest

Other Resources

Contract Entity Messages and Methods
Sample: Manage Contracts


CloneContractResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the resulting contract.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CloneContractResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CancelContractRequest

Other Resources

Contract Entity Messages and Methods
Sample: Manage Contracts


CloneContractResponse.Entity Property
[image]

Gets the resulting contract.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type:  Entity
The resulting contract. This is an instance of the Contract class, which is a subclass of the Entity class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneContractResponse Class
CloneContractResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CloneProductRequest Class
See Also Members
[image]

Contains the data that is needed to copy an existing product family, product, or bundle under the same parent record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CloneProductRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CloneProductRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of CloneProductResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Product entity and access rights on the record specified in the Source property.
Notes for Callers
By default, the caller will become the owner for the new record. For this to work, the caller must have both Create and Read privileges for the product entity. For more information, see Privileges by Entity.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CloneProductRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Clone a product family, product, or bundle
Sample: Clone product records


CloneProductRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to copy an existing product family, product, or bundle under the same parent record.

The following tables list the members exposed by the CloneProductRequest type.

Public Constructors

Name | Description
CloneProductRequest | Initializes a new instance of the CloneProductRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Source | Gets or sets the source product family, product, or bundle record that you want to clone.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CloneProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Clone a product family, product, or bundle
Sample: Clone product records


CloneProductRequest Constructor
[image]

Initializes a new instance of the CloneProductRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CloneProductRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneProductRequest Class
CloneProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloneProductRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CloneProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Clone a product family, product, or bundle
Sample: Clone product records


CloneProductRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Source | Gets or sets the source product family, product, or bundle record that you want to clone.

See Also

Reference

CloneProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Clone a product family, product, or bundle
Sample: Clone product records


CloneProductRequest.Source Property
[image]

Gets or sets the source product family, product, or bundle record that you want to clone.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Source As EntityReference

C#
public EntityReference Source { get; set; }

C++

J#

JScript

Property Value
Type EntityReference
The source product family, product, or bundle record that you want to clone.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneProductRequest Class
CloneProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloneProductResponse Class
See Also Members
[image]

Contains the response from the CloneProductRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CloneProductResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CloneProductResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CloneProductResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Clone a product family, product, or bundle
Sample: Clone product records


CloneProductResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CloneProductRequest class.

The following tables list the members exposed by the CloneProductResponse type.

Public Constructors

Name | Description
CloneProductResponse | Initializes a new instance of the CloneProductResponse class.
Top

Public Properties

 | Name | Description
public property | ClonedProduct | Gets the cloned product record.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CloneProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Clone a product family, product, or bundle
Sample: Clone product records


CloneProductResponse Constructor
[image]

Initializes a new instance of the CloneProductResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CloneProductResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneProductResponse Class
CloneProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CloneProductResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CloneProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Clone a product family, product, or bundle
Sample: Clone product records


CloneProductResponse Properties
[image]

Public Properties

 | Name | Description
public property | ClonedProduct | Gets the cloned product record.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CloneProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Clone a product family, product, or bundle
Sample: Clone product records


CloneProductResponse.ClonedProduct Property
[image]

Gets the cloned product record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ClonedProduct As EntityReference

C#
public EntityReference ClonedProduct { get; }

C++

J#

JScript

Property Value
Type EntityReference
The cloned product record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloneProductResponse Class
CloneProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CloseIncidentRequest Class
See Also Example Members
[image]

Contains the data that is needed to close an incident (case).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CloseIncidentRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CloseIncidentRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// First close the Incident

// Create resolution for the closing incident
IncidentResolution resolution = new IncidentResolution
{
    Subject = "Case Closed",
};

resolution.IncidentId = caseReference;

// Create the request to close the incident, and set its resolution to the
// resolution created above
CloseIncidentRequest closeRequest = new CloseIncidentRequest();
closeRequest.IncidentResolution = resolution;

// Set the requested new status for the closed Incident
closeRequest.Status =
    new OptionSetValue((int)incident_statuscode.ProblemSolved);

// Execute the close request
CloseIncidentResponse closeResponse =
    (CloseIncidentResponse)_serviceProxy.Execute(closeRequest);

//Check if the incident was successfully closed
Incident incident = _serviceProxy.Retrieve(Incident.EntityLogicalName,
    _caseIncidentId, new ColumnSet(allColumns: true)).ToEntity<Incident>();

if (incident.StateCode.HasValue &&
    incident.StateCode == IncidentState.Resolved)
{
    Console.WriteLine("The incident was closed out as Resolved.");
}
else
{
    Console.WriteLine("The incident's state was not changed.");
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the CloseIncidentResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Incident entity.
For a complete list of the required privileges, see CloseIncident Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CloseIncidentRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CloseIncidentRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CloseIncidentResponse
Other Resources
CloseIncident Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloseIncidentRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to close an incident (case).

The following tables list the members exposed by the CloseIncidentRequest type.

Public Constructors

Name | Description
CloseIncidentRequest | Initializes a new instance of the CloseIncidentRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncidentResolution | Gets or sets the incident resolution (case resolution) that is associated with the incident (case) to be closed. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a status of the incident. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CloseIncidentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CloseIncidentResponse

Other Resources

CloseIncident Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloseIncidentRequest Constructor
[image]

Initializes a new instance of the CloseIncidentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CloseIncidentRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseIncidentRequest Class
CloseIncidentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloseIncidentRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CloseIncidentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CloseIncidentResponse

Other Resources

CloseIncident Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloseIncidentRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncidentResolution | Gets or sets the incident resolution (case resolution) that is associated with the incident (case) to be closed. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a status of the incident. Required.

See Also

Reference

CloseIncidentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CloseIncidentResponse

Other Resources

CloseIncident Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloseIncidentRequest.IncidentResolution Property
[image]

Gets or sets the incident resolution (case resolution) that is associated with the incident (case) to be closed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IncidentResolution As Entity

C#
public Entity IncidentResolution { get; set; }

C++

J#

JScript

Property Value
Type:  Entity
The incident resolution (case resolution) that is associated with the incident (case) to be closed. This is an instance of the IncidentResolution class, which is a subclass of the Entity class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseIncidentRequest Class
CloseIncidentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloseIncidentRequest.Status Property
[image]

Gets or sets a status of the incident. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The status of the incident.

  Remarks
The Status property corresponds to the Incident.StatusCode attribute. It is shown as “Status Reason” in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system sets the appropriate corresponding status value. For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseIncidentRequest Class
CloseIncidentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloseIncidentResponse Class
See Also Members
[image]

Contains the response from the CloseIncidentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CloseIncidentResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CloseIncidentResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CloseIncidentResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseIncidentResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CloseIncidentRequest


CloseIncidentResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CloseIncidentRequest class.

The following tables list the members exposed by the CloseIncidentResponse type.

Public Constructors

Name | Description
CloseIncidentResponse | Initializes a new instance of the CloseIncidentResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CloseIncidentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CloseIncidentRequest


CloseIncidentResponse Constructor
[image]

Initializes a new instance of the CloseIncidentResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CloseIncidentResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseIncidentResponse Class
CloseIncidentResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CloseIncidentResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CloseIncidentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CloseIncidentRequest


CloseIncidentResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CloseIncidentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CloseIncidentRequest


CloseQuoteRequest Class
See Also Example Members
[image]

Contains the data that is needed to close a quote.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CloseQuoteRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CloseQuoteRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// convert the opportunity to a quote
genQuoteFromOppRequest = new GenerateQuoteFromOpportunityRequest
{
    OpportunityId = _opportunityId,
    ColumnSet = new ColumnSet("quoteid", "name")
};
genQuoteFromOppResponse = (GenerateQuoteFromOpportunityResponse)
    _serviceProxy.Execute(genQuoteFromOppRequest);

Quote closeQuote = genQuoteFromOppResponse.Entity.ToEntity<Quote>();
_closeQuoteId = closeQuote.Id;

// Activate the quote
SetStateRequest activateQuote = new SetStateRequest()
{
    EntityMoniker = closeQuote.ToEntityReference(),
    State = new OptionSetValue((int)QuoteState.Active),
    Status = new OptionSetValue((int)quote_statuscode.InProgress)
};
_serviceProxy.Execute(activateQuote);

// Close the quote
CloseQuoteRequest closeQuoteRequest = new CloseQuoteRequest()
{
    QuoteClose = new QuoteClose()
    {
        QuoteId = closeQuote.ToEntityReference(),
        Subject = "Quote Close " + DateTime.Now.ToString()
    },
    Status = new OptionSetValue(-1)
};
_serviceProxy.Execute(closeQuoteRequest);

Console.WriteLine("Quote Closed");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of CloseQuoteResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Quote entity.
For a complete list of the required privileges, see CloseQuote Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CloseQuoteRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CloseQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CloseQuoteResponse
Other Resources
CloseQuote Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloseQuoteRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to close a quote.

The following tables list the members exposed by the CloseQuoteRequest type.

Public Constructors

Name | Description
CloseQuoteRequest | Initializes a new instance of the CloseQuoteRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteClose | Gets or sets a quote to be closed. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a status of the quote. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CloseQuoteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CloseQuoteResponse

Other Resources

CloseQuote Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloseQuoteRequest Constructor
[image]

Initializes a new instance of the CloseQuoteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CloseQuoteRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseQuoteRequest Class
CloseQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloseQuoteRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CloseQuoteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CloseQuoteResponse

Other Resources

CloseQuote Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloseQuoteRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteClose | Gets or sets a quote to be closed. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a status of the quote. Required.

See Also

Reference

CloseQuoteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CloseQuoteResponse

Other Resources

CloseQuote Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CloseQuoteRequest.QuoteClose Property
[image]

Gets or sets a quote to be closed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QuoteClose As Entity

C#
public Entity QuoteClose { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The quote to be closed. This is an instance of the QuoteClose class, which is a subclass of the Entity class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseQuoteRequest Class
CloseQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloseQuoteRequest.Status Property
[image]

Gets or sets a status of the quote. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The status of the quote.

  Remarks
The Status property corresponds to the Quote.StatusCode attribute. It is shown as “Status Reason” in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system sets the appropriate corresponding status value. For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseQuoteRequest Class
CloseQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CloseQuoteResponse Class
See Also Members
[image]

Contains the response from the CloseQuoteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CloseQuoteResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CloseQuoteResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CloseQuoteResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseQuoteResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CloseQuoteRequest


CloseQuoteResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CloseQuoteRequest class.

The following tables list the members exposed by the CloseQuoteResponse type.

Public Constructors

Name | Description
CloseQuoteResponse | Initializes a new instance of the CloseQuoteResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CloseQuoteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CloseQuoteRequest


CloseQuoteResponse Constructor
[image]

Initializes a new instance of the CloseQuoteResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CloseQuoteResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CloseQuoteResponse Class
CloseQuoteResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CloseQuoteRequest


CloseQuoteResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CloseQuoteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CloseQuoteRequest


CloseQuoteResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CloseQuoteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CloseQuoteRequest


ComponentDetail Class
See Also Members
[image]

Provides additional information about the solution components that are related to a missing component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ComponentDetail
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ComponentDetail : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.ComponentDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Dependency Tracking for Solution Components


ComponentDetail Members
See Also Constructors Methods Properties
[image]

Provides additional information about the solution components that are related to a missing component.

The following tables list the members exposed by the ComponentDetail type.

Public Constructors

Name | Description
ComponentDetail | Initializes a new instance of theComponentDetail class.
Top

Public Properties

 | Name | Description
public property | DisplayName | Gets or sets the display name of the solution component.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Id | Gets or sets the ID of the solution component.
public property | ParentDisplayName | Gets or sets the display name of the parent solution component.
public property | ParentId | Gets or sets the ID of the parent solution component.
public property | ParentSchemaName | Gets or sets the schema name of the parent solution component.
public property | SchemaName | Gets or sets the schema name of the solution component.
public property | Solution | Gets or sets the name of the solution.
public property | Type | Gets or sets the component type of the solution component.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ComponentDetail Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components


ComponentDetail Constructor
[image]

Initializes a new instance of the ComponentDetail class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ComponentDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ComponentDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ComponentDetail Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components


ComponentDetail Properties
[image]

Public Properties

 | Name | Description
public property | DisplayName | Gets or sets the display name of the solution component.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Id | Gets or sets the ID of the solution component.
public property | ParentDisplayName | Gets or sets the display name of the parent solution component.
public property | ParentId | Gets or sets the ID of the parent solution component.
public property | ParentSchemaName | Gets or sets the schema name of the parent solution component.
public property | SchemaName | Gets or sets the schema name of the solution component.
public property | Solution | Gets or sets the name of the solution.
public property | Type | Gets or sets the component type of the solution component.

See Also

Reference

ComponentDetail Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components


ComponentDetail.DisplayName Property
[image]

Gets or sets the display name of the solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DisplayName As String

C#
[DataMemberAttribute]
public string DisplayName { get; set; }

C++

J#

JScript

Property Value
Type: String

The display name of the solution component.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ComponentDetail.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ComponentDetail.Id Property
[image]

Gets or sets the ID of the solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the solution component.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ComponentDetail.ParentDisplayName Property
[image]

Gets or sets the display name of the parent solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ParentDisplayName As String

C#
[DataMemberAttribute]
public string ParentDisplayName { get; set; }

C++

J#

JScript

Property Value
Type: String

The display name of the parent solution component.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ComponentDetail.ParentId Property
[image]

Gets or sets the ID of the parent solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ParentId As Guid

C#
[DataMemberAttribute]
public Guid ParentId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the parent solution component.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ComponentDetail.ParentSchemaName Property
[image]

Gets or sets the schema name of the parent solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ParentSchemaName As String

C#
[DataMemberAttribute]
public string ParentSchemaName { get; set; }

C++

J#

JScript

Property Value
Type: String

The schema name of the parent solution component..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ComponentDetail.SchemaName Property
[image]

Gets or sets the schema name of the solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SchemaName As String

C#
[DataMemberAttribute]
public string SchemaName { get; set; }

C++

J#

JScript

Property Value
Type: String

The schema name of the solution component.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ComponentDetail.Solution Property
[image]

Gets or sets the name of the solution.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Solution As String

C#
[DataMemberAttribute]
public string Solution { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ComponentDetail.Type Property
[image]

Gets or sets the component type of the solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Type As Integer

C#
[DataMemberAttribute]
public int Type { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The component type of the solution component.

  Remarks
The enumeration named componenttype defines the supported range of values for this property. You can access the available values by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project. These values are defined by the global option set Component Type (componenttype).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ComponentDetail Class
ComponentDetail Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundCreateRequest Class
See Also Members
[image]

Deprecated. Use the CreateRequest class. Creates a compound entity, such as a sales order (order), invoice, quote, or duplicate rule (duplicate detection rule); and its related entity, such as a sales order detail (order product), invoice detail (invoice product), quote detail (quote product), or duplicate rule condition.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CompoundCreateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CompoundCreateRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CompoundCreateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundCreateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CompoundCreateResponse
Other Resources
CompoundCreate Privileges


CompoundCreateRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the CreateRequest class. Creates a compound entity, such as a sales order (order), invoice, quote, or duplicate rule (duplicate detection rule); and its related entity, such as a sales order detail (order product), invoice detail (invoice product), quote detail (quote product), or duplicate rule condition.

The following tables list the members exposed by the CompoundCreateRequest type.

Public Constructors

Name | Description
CompoundCreateRequest | Initializes a new instance of the CompoundCreateRequest class.
Top

Public Properties

 | Name | Description
public property | ChildEntities | Deprecated.
public property | Entity | Deprecated.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CompoundCreateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundCreateResponse

Other Resources

CompoundCreate Privileges


CompoundCreateRequest Constructor
[image]

Initializes a new instance of the CompoundCreateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CompoundCreateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundCreateRequest Class
CompoundCreateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundCreateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CompoundCreateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundCreateResponse

Other Resources

CompoundCreate Privileges


CompoundCreateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ChildEntities | Deprecated.
public property | Entity | Deprecated.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CompoundCreateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundCreateResponse

Other Resources

CompoundCreate Privileges


CompoundCreateRequest.ChildEntities Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ChildEntities As EntityCollection

C#
public EntityCollection ChildEntities { get; set; }

C++

J#

JScript

Property Value
Type: EntityCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundCreateRequest Class
CompoundCreateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundCreateRequest.Entity Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As Entity

C#
public Entity Entity { get; set; }

C++

J#

JScript

Property Value
Type: Entity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundCreateRequest Class
CompoundCreateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundCreateResponse Class
See Also Members
[image]

Deprecated. Use the CreateRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CompoundCreateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CompoundCreateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CompoundCreateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundCreateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CompoundCreateRequest


CompoundCreateResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the CreateRequest class and its associated response class.

The following tables list the members exposed by the CompoundCreateResponse type.

Public Constructors

Name | Description
CompoundCreateResponse | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Deprecated.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CompoundCreateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundCreateRequest


CompoundCreateResponse Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CompoundCreateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundCreateResponse Class
CompoundCreateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundCreateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CompoundCreateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundCreateRequest


CompoundCreateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Deprecated.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CompoundCreateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundCreateRequest


CompoundCreateResponse.Id Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Id As Guid

C#
public Guid Id { get; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundCreateResponse Class
CompoundCreateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundUpdateDuplicateDetectionRuleRequest Class
See Also Members
[image]

Contains the data that is needed to update a duplicate rule (duplicate detection rule) and its related duplicate rule conditions.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CompoundUpdateDuplicateDetectionRuleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CompoundUpdateDuplicateDetectionRuleRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the CompoundUpdateDuplicateDetectionRuleResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the DuplicateRule entity and the DuplicateRuleCondition entity.
For a complete list of the required privileges, see CompoundUpdateDuplicateDetectionRule Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CompoundUpdateDuplicateDetectionRuleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateDuplicateDetectionRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateDuplicateDetectionRuleResponse
Other Resources
Detect Duplicate Data in Microsoft Dynamics CRM
DuplicateRule Entity Messages and Methods
CompoundUpdateDuplicateDetectionRule Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


CompoundUpdateDuplicateDetectionRuleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update a duplicate rule (duplicate detection rule) and its related duplicate rule conditions.

The following tables list the members exposed by the CompoundUpdateDuplicateDetectionRuleRequest type.

Public Constructors

Name | Description
CompoundUpdateDuplicateDetectionRuleRequest | Initializes a new instance of the CompoundUpdateDuplicateDetectionRuleRequest class.
Top

Public Properties

 | Name | Description
public property | ChildEntities | Gets or sets a collection of the duplicate rule conditions that you want updated. Required.
public property | Entity | Gets or sets the duplicate rule that you want updated. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CompoundUpdateDuplicateDetectionRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateDuplicateDetectionRuleResponse

Other Resources

Detect Duplicate Data in Microsoft Dynamics CRM
DuplicateRule Entity Messages and Methods
CompoundUpdateDuplicateDetectionRule Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


CompoundUpdateDuplicateDetectionRuleRequest Constructor
[image]

Initializes a new instance of the CompoundUpdateDuplicateDetectionRuleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CompoundUpdateDuplicateDetectionRuleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateDuplicateDetectionRuleRequest Class
CompoundUpdateDuplicateDetectionRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundUpdateDuplicateDetectionRuleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CompoundUpdateDuplicateDetectionRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateDuplicateDetectionRuleResponse

Other Resources

Detect Duplicate Data in Microsoft Dynamics CRM
DuplicateRule Entity Messages and Methods
CompoundUpdateDuplicateDetectionRule Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


CompoundUpdateDuplicateDetectionRuleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ChildEntities | Gets or sets a collection of the duplicate rule conditions that you want updated. Required.
public property | Entity | Gets or sets the duplicate rule that you want updated. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CompoundUpdateDuplicateDetectionRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateDuplicateDetectionRuleResponse

Other Resources

Detect Duplicate Data in Microsoft Dynamics CRM
DuplicateRule Entity Messages and Methods
CompoundUpdateDuplicateDetectionRule Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


CompoundUpdateDuplicateDetectionRuleRequest.ChildEntities Property
[image]

Gets or sets a collection of the duplicate rule conditions that you want updated. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ChildEntities As EntityCollection

C#
public EntityCollection ChildEntities { get; set; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of the duplicate rule conditions that you want updated.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateDuplicateDetectionRuleRequest Class
CompoundUpdateDuplicateDetectionRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundUpdateDuplicateDetectionRuleRequest.Entity Property
[image]

Gets or sets the duplicate rule that you want updated. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As Entity

C#
public Entity Entity { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The duplicate rule that you want updated. This is instance of a DuplicateRule class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateDuplicateDetectionRuleRequest Class
CompoundUpdateDuplicateDetectionRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundUpdateDuplicateDetectionRuleResponse Class
See Also Members
[image]

Contains the response from the CompoundUpdateDuplicateDetectionRuleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CompoundUpdateDuplicateDetectionRuleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CompoundUpdateDuplicateDetectionRuleResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CompoundUpdateDuplicateDetectionRuleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateDuplicateDetectionRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateDuplicateDetectionRuleRequest


CompoundUpdateDuplicateDetectionRuleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CompoundUpdateDuplicateDetectionRuleRequest class.

The following tables list the members exposed by the CompoundUpdateDuplicateDetectionRuleResponse type.

Public Constructors

Name | Description
CompoundUpdateDuplicateDetectionRuleResponse | Initializes a new instance of the CompoundUpdateDuplicateDetectionRuleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CompoundUpdateDuplicateDetectionRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateDuplicateDetectionRuleRequest


CompoundUpdateDuplicateDetectionRuleResponse Constructor
[image]

Initializes a new instance of the CompoundUpdateDuplicateDetectionRuleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CompoundUpdateDuplicateDetectionRuleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateDuplicateDetectionRuleResponse Class
CompoundUpdateDuplicateDetectionRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundUpdateDuplicateDetectionRuleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CompoundUpdateDuplicateDetectionRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateDuplicateDetectionRuleRequest


CompoundUpdateDuplicateDetectionRuleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CompoundUpdateDuplicateDetectionRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateDuplicateDetectionRuleRequest


CompoundUpdateRequest Class
See Also Members
[image]

Deprecated. Use the CreateRequest class. Contains the data that is needed to update a compound record, such as a sales order (order), invoice, quote, or duplicate rule (duplicate detection rule); and its related detail record, such as a sales order detail (order product), invoice detail (invoice product), quote detail (quote product), or duplicate rule condition.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CompoundUpdateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CompoundUpdateRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CompoundUpdateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateResponse
Other Resources
CompoundUpdate Privileges


CompoundUpdateRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the CreateRequest class. Contains the data that is needed to update a compound record, such as a sales order (order), invoice, quote, or duplicate rule (duplicate detection rule); and its related detail record, such as a sales order detail (order product), invoice detail (invoice product), quote detail (quote product), or duplicate rule condition.

The following tables list the members exposed by the CompoundUpdateRequest type.

Public Constructors

Name | Description
CompoundUpdateRequest | Initializes a new instance of the CompoundUpdateRequest class.
Top

Public Properties

 | Name | Description
public property | ChildEntities | Deprecated.
public property | Entity | Deprecated.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CompoundUpdateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateResponse

Other Resources

CompoundUpdate Privileges


CompoundUpdateRequest Constructor
[image]

Initializes a new instance of the CompoundUpdateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CompoundUpdateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateRequest Class
CompoundUpdateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundUpdateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CompoundUpdateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateResponse

Other Resources

CompoundUpdate Privileges


CompoundUpdateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ChildEntities | Deprecated.
public property | Entity | Deprecated.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CompoundUpdateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateResponse

Other Resources

CompoundUpdate Privileges


CompoundUpdateRequest.ChildEntities Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ChildEntities As EntityCollection

C#
public EntityCollection ChildEntities { get; set; }

C++

J#

JScript

Property Value
Type: EntityCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateRequest Class
CompoundUpdateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundUpdateRequest.Entity Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As Entity

C#
public Entity Entity { get; set; }

C++

J#

JScript

Property Value
Type: Entity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateRequest Class
CompoundUpdateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundUpdateResponse Class
See Also Members
[image]

Deprecated. Use the CreateRequest class and its associated response class. Contains the response from the CompoundUpdateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CompoundUpdateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CompoundUpdateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CompoundUpdateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateRequest


CompoundUpdateResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the CreateRequest class and its associated response class. Contains the response from the CompoundUpdateRequest class.

The following tables list the members exposed by the CompoundUpdateResponse type.

Public Constructors

Name | Description
CompoundUpdateResponse | Initializes a new instance of the CompoundUpdateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CompoundUpdateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateRequest


CompoundUpdateResponse Constructor
[image]

Initializes a new instance of the CompoundUpdateResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CompoundUpdateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CompoundUpdateResponse Class
CompoundUpdateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CompoundUpdateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CompoundUpdateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateRequest


CompoundUpdateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CompoundUpdateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CompoundUpdateRequest


ConstraintRelation Class
See Also Members
[image]

Specifies additional constraints to be applied when you select resources for appointments.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConstraintRelation
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConstraintRelation : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.ConstraintRelation
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstraintRelation Members
Microsoft.Crm.Sdk.Messages Namespace
Constraints
Constraints
Other Resources
Calendar Entities


ConstraintRelation Members
See Also Constructors Methods Properties
[image]

Specifies additional constraints to be applied when you select resources for appointments.

The following tables list the members exposed by the ConstraintRelation type.

Public Constructors

Name | Description
ConstraintRelation | Overloaded. Initializes a new instance of the ConstraintRelation class.
Top

Public Properties

 | Name | Description
public property | Constraints | Gets or sets the set of additional constraints.
public property | ConstraintType | Gets or sets the type of constraints.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ObjectId | Gets or sets the ID of the calendar rule to which the constraint is applied.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConstraintRelation Class
Microsoft.Crm.Sdk.Messages Namespace
Constraints
Constraints

Other Resources

Calendar Entities


ConstraintRelation Constructor
[image]

Initializes a new instance of the ConstraintRelation class.

Overload List

Name | Description
ConstraintRelation () | Initializes a new instance of theConstraintRelation class.
ConstraintRelation (Guid, String, String) | Initializes a new instance of the ConstraintRelation class that sets the object ID, constraint type, and constraints.

See Also

Reference

ConstraintRelation Class
ConstraintRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ConstraintRelation Constructor ()
[image]

Initializes a new instance of the ConstraintRelation class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConstraintRelation ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstraintRelation Class
ConstraintRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ConstraintRelation Constructor (Guid, String, String)
[image]

Initializes a new instance of the ConstraintRelation class that sets the object ID, constraint type, and constraints.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    objectId As Guid, _
    constraintType As String, _
    constraints As String _
)

C#
public ConstraintRelation (
    Guid objectId,
    string constraintType,
    string constraints
)

C++

J#

JScript

Parameters
objectId
Type: Guid. The ID of the calendar rule.
constraintType
Type: String. The constraint type. Must be "Resource Selection".
constraints
Type: String. The set of constraints.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstraintRelation Class
ConstraintRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ConstraintRelation Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConstraintRelation Class
Microsoft.Crm.Sdk.Messages Namespace
Constraints
Constraints

Other Resources

Calendar Entities


ConstraintRelation Properties
[image]

Public Properties

 | Name | Description
public property | Constraints | Gets or sets the set of additional constraints.
public property | ConstraintType | Gets or sets the type of constraints.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ObjectId | Gets or sets the ID of the calendar rule to which the constraint is applied.

See Also

Reference

ConstraintRelation Class
Microsoft.Crm.Sdk.Messages Namespace
Constraints
Constraints

Other Resources

Calendar Entities


ConstraintRelation.Constraints Property
See Also Example
[image]

Gets or sets the set of additional constraints.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Constraints As String

C#
[DataMemberAttribute]
public string Constraints { get; set; }

C++

J#

JScript

Property Value
Type: String

The set of additional constraints.

  Example
The following example selects the resource only if the name is "John".
C#    Copy Code
string constraint = @"
          <Constraints>
            <Constraint>
              <Expression>
                <Body>resource[""name""] == ""John""</Body>
                <Parameters>
                  <Parameter name=""resource""></Parameter>
                </Parameters>
              </Expression>
            </Constraint>
          </Constraints>";

constraintRelation.Constraints = constraint;

  Remarks
Constraints can specify resources to be included or excluded from the search criteria. Attributes that can be used in the expression for the constraint are:
calendarid
isdisabled
name
organizationid
resourceid
resourceskill
siteid
typecode
The expression also supports operations such as And, Or, In, Not, and so on.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ConstraintRelation Class
ConstraintRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ConstraintRelation.ConstraintType Property
[image]

Gets or sets the type of constraints.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ConstraintType As String

C#
[DataMemberAttribute]
public string ConstraintType { get; set; }

C++

J#

JScript

Property Value
Type: String

The type of constraints, which must be "Resource Selection".

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstraintRelation Class
ConstraintRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ConstraintRelation.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstraintRelation Class
ConstraintRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ConstraintRelation.ObjectId Property
[image]

Gets or sets the ID of the calendar rule to which the constraint is applied.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ObjectId As Guid

C#
[DataMemberAttribute]
public Guid ObjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the calendar rule to which the constraint is applied. This corresponds to the CalendarRule.CalenderRuleID attribute, which is the primary key for the CalendarRule entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstraintRelation Class
ConstraintRelation Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
CalendarRule Entity Messages and Methods


ConvertKitToProductRequest Class
See Also Members
[image]

Deprecated. Contains the data that is needed to convert a kit to a product.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertKitToProductRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertKitToProductRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the ConvertKitToProductResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Product entity and access rights on the specified record in the KitId property.
For a complete list of the required privileges, see ConvertKitToProduct Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ConvertKitToProductRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertKitToProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertKitToProductResponse
Other Resources
Bundles and kits
Product Catalog Entities
Product Entity Messages and Methods
ConvertKitToProduct Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


ConvertKitToProductRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Contains the data that is needed to convert a kit to a product.

The following tables list the members exposed by the ConvertKitToProductRequest type.

Public Constructors

Name | Description
ConvertKitToProductRequest | Initializes a new instance of the ConvertKitToProductRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | KitId | Gets or sets the ID of the kit. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertKitToProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertKitToProductResponse

Other Resources

Bundles and kits
Product Catalog Entities
Product Entity Messages and Methods
ConvertKitToProduct Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


ConvertKitToProductRequest Constructor
[image]

Initializes a new instance of the ConvertKitToProductRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertKitToProductRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertKitToProductRequest Class
ConvertKitToProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertKitToProductRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertKitToProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertKitToProductResponse

Other Resources

Bundles and kits
Product Catalog Entities
Product Entity Messages and Methods
ConvertKitToProduct Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


ConvertKitToProductRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | KitId | Gets or sets the ID of the kit. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ConvertKitToProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertKitToProductResponse

Other Resources

Bundles and kits
Product Catalog Entities
Product Entity Messages and Methods
ConvertKitToProduct Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


ConvertKitToProductRequest.KitId Property
[image]

Gets or sets the ID of the kit. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property KitId As Guid

C#
public Guid KitId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the kit that corresponds to the Product.ProductId attribute, which is the primary key for the Product entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertKitToProductRequest Class
ConvertKitToProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertKitToProductResponse Class
See Also Members
[image]

Deprecated. Contains the response from the ConvertKitToProductRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertKitToProductResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertKitToProductResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ConvertKitToProductResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertKitToProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertKitToProductRequest


ConvertKitToProductResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Contains the response from the ConvertKitToProductRequest class.

The following tables list the members exposed by the ConvertKitToProductResponse type.

Public Constructors

Name | Description
ConvertKitToProductResponse | Initializes a new instance of the ConvertKitToProductResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertKitToProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertKitToProductRequest


ConvertKitToProductResponse Constructor
[image]

Initializes a new instance of the ConvertKitToProductResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertKitToProductResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertKitToProductResponse Class
ConvertKitToProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertKitToProductResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertKitToProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertKitToProductRequest


ConvertKitToProductResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ConvertKitToProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertKitToProductRequest


ConvertOwnerTeamToAccessTeamRequest Class
See Also Members
[image]

Contains the data that is needed to convert a team of type owner to a team of type access.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertOwnerTeamToAccessTeamRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertOwnerTeamToAccessTeamRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the ConvertOwnerTeamToAccessTeamResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Team entity. For a complete list of required privileges, see ConvertOwnerTeamToAccessTeam message privileges.
Notes for Callers
You can convert an owner team to an access team, if the owner team doesn’t have the records and security roles assigned to the team. After you convert the owner team to the access team, it can’t convert the team back to the owner team. It is a one way process. During conversion, all queues and mailboxes associated with the team are deleted.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ConvertOwnerTeamToAccessTeamRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertOwnerTeamToAccessTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertOwnerTeamToAccessTeamResponse
Other Resources
Use Teams to Collaborate and Share Information
Team Entity Messages and Methods
ConvertOwnerTeamToAccessTeam message privileges


ConvertOwnerTeamToAccessTeamRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to convert a team of type owner to a team of type access.

The following tables list the members exposed by the ConvertOwnerTeamToAccessTeamRequest type.

Public Constructors

Name | Description
ConvertOwnerTeamToAccessTeamRequest | Initializes a new instance of the ConvertOwnerTeamToAccessTeamRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the ID of the owner team to be converted. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertOwnerTeamToAccessTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertOwnerTeamToAccessTeamResponse

Other Resources

Use Teams to Collaborate and Share Information
Team Entity Messages and Methods
ConvertOwnerTeamToAccessTeam message privileges


ConvertOwnerTeamToAccessTeamRequest Constructor
[image]

Initializes a new instance of the ConvertOwnerTeamToAccessTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertOwnerTeamToAccessTeamRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertOwnerTeamToAccessTeamRequest Class
ConvertOwnerTeamToAccessTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertOwnerTeamToAccessTeamRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertOwnerTeamToAccessTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertOwnerTeamToAccessTeamResponse

Other Resources

Use Teams to Collaborate and Share Information
Team Entity Messages and Methods
ConvertOwnerTeamToAccessTeam message privileges


ConvertOwnerTeamToAccessTeamRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the ID of the owner team to be converted. Required.

See Also

Reference

ConvertOwnerTeamToAccessTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertOwnerTeamToAccessTeamResponse

Other Resources

Use Teams to Collaborate and Share Information
Team Entity Messages and Methods
ConvertOwnerTeamToAccessTeam message privileges


ConvertOwnerTeamToAccessTeamRequest.TeamId Property
[image]

Gets or sets the ID of the owner team to be converted. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TeamId As Guid

C#
public Guid TeamId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the team to be converted that corresponds to the Team.TeamId attribute, which is the primary key for the Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertOwnerTeamToAccessTeamRequest Class
ConvertOwnerTeamToAccessTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertOwnerTeamToAccessTeamResponse Class
See Also Members
[image]

Contains the response from the ConvertOwnerTeamToAccessTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertOwnerTeamToAccessTeamResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertOwnerTeamToAccessTeamResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ConvertOwnerTeamToAccessTeamResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertOwnerTeamToAccessTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertOwnerTeamToAccessTeamRequest


ConvertOwnerTeamToAccessTeamResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ConvertOwnerTeamToAccessTeamRequest class.

The following tables list the members exposed by the ConvertOwnerTeamToAccessTeamResponse type.

Public Constructors

Name | Description
ConvertOwnerTeamToAccessTeamResponse | Initializes a new instance of the ConvertOwnerTeamToAccessTeamResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertOwnerTeamToAccessTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertOwnerTeamToAccessTeamRequest


ConvertOwnerTeamToAccessTeamResponse Constructor
[image]

Initializes a new instance of the ConvertOwnerTeamToAccessTeamResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertOwnerTeamToAccessTeamResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertOwnerTeamToAccessTeamResponse Class
ConvertOwnerTeamToAccessTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertOwnerTeamToAccessTeamResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertOwnerTeamToAccessTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertOwnerTeamToAccessTeamRequest


ConvertOwnerTeamToAccessTeamResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ConvertOwnerTeamToAccessTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertOwnerTeamToAccessTeamRequest


ConvertProductToKitRequest Class
See Also Members
[image]

Deprecated. Contains the data that is needed to convert a product to a kit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertProductToKitRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertProductToKitRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of ConvertProductToKitResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Product entity and access rights on the record specified in the ProductId property.
For a complete list of the required privileges, see ConvertProductToKit Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ConvertProductToKitRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertProductToKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertProductToKitResponse
Other Resources
Bundles and kits
Product Catalog Entities
Product Entity Messages and Methods
ConvertProductToKit Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertProductToKitRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Contains the data that is needed to convert a product to a kit.

The following tables list the members exposed by the ConvertProductToKitRequest type.

Public Constructors

Name | Description
ConvertProductToKitRequest | Initializes a new instance of the ConvertProductToKitRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertProductToKitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertProductToKitResponse

Other Resources

Bundles and kits
Product Catalog Entities
Product Entity Messages and Methods
ConvertProductToKit Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertProductToKitRequest Constructor
[image]

Initializes a new instance of the ConvertProductToKitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertProductToKitRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertProductToKitRequest Class
ConvertProductToKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertProductToKitRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertProductToKitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertProductToKitResponse

Other Resources

Bundles and kits
Product Catalog Entities
Product Entity Messages and Methods
ConvertProductToKit Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertProductToKitRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ConvertProductToKitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertProductToKitResponse

Other Resources

Bundles and kits
Product Catalog Entities
Product Entity Messages and Methods
ConvertProductToKit Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertProductToKitRequest.ProductId Property
[image]

Gets or sets the ID of the product. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ProductId As Guid

C#
public Guid ProductId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the product that corresponds to the Product.ProductId attribute, which is the primary key for the Product entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertProductToKitRequest Class
ConvertProductToKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertProductToKitResponse Class
See Also Members
[image]

Deprecated. Contains the response from the ConvertProductToKitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertProductToKitResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertProductToKitResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ConvertProductToKitResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertProductToKitResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertProductToKitRequest


ConvertProductToKitResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Contains the response from the ConvertProductToKitRequest class.

The following tables list the members exposed by the ConvertProductToKitResponse type.

Public Constructors

Name | Description
ConvertProductToKitResponse | Initializes a new instance of the ConvertProductToKitResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertProductToKitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertProductToKitRequest


ConvertProductToKitResponse Constructor
[image]

Initializes a new instance of the ConvertProductToKitResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertProductToKitResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertProductToKitResponse Class
ConvertProductToKitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertProductToKitResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertProductToKitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertProductToKitRequest


ConvertProductToKitResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ConvertProductToKitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertProductToKitRequest


ConvertQuoteToSalesOrderRequest Class
See Also Example Members
[image]

Contains the data that is needed to convert a quote to a sales order.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertQuoteToSalesOrderRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertQuoteToSalesOrderRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Define columns to be retrieved after creating the order
ColumnSet salesOrderColumns =
    new ColumnSet("salesorderid", "totalamount");

// Convert the quote to a sales order
ConvertQuoteToSalesOrderRequest convertQuoteRequest =
    new ConvertQuoteToSalesOrderRequest()
    {
        QuoteId = _quoteId,
        ColumnSet = salesOrderColumns
    };
ConvertQuoteToSalesOrderResponse convertQuoteResponse =
    (ConvertQuoteToSalesOrderResponse)_serviceProxy.Execute(convertQuoteRequest);
SalesOrder salesOrder = (SalesOrder)convertQuoteResponse.Entity;
_salesOrderId = salesOrder.Id;

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the ConvertQuoteToSalesOrderResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Quote entity and access rights on the specified record in the QuoteId property. For a complete list of the required privileges, see ConvertQuoteToSalesOrder Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ConvertQuoteToSalesOrderRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ConvertQuoteToSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertQuoteToSalesOrderResponse
Other Resources
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
ConvertQuoteToSalesOrder Privileges
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertQuoteToSalesOrderRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to convert a quote to a sales order.

The following tables list the members exposed by the ConvertQuoteToSalesOrderRequest type.

Public Constructors

Name | Description
ConvertQuoteToSalesOrderRequest | Initializes a new instance of the ConvertQuoteToSalesOrderRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve in the resulting sales order (order). Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteId | Gets or sets the ID of the quote to convert. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertQuoteToSalesOrderRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertQuoteToSalesOrderResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
ConvertQuoteToSalesOrder Privileges
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertQuoteToSalesOrderRequest Constructor
[image]

Initializes a new instance of the ConvertQuoteToSalesOrderRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertQuoteToSalesOrderRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertQuoteToSalesOrderRequest Class
ConvertQuoteToSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertQuoteToSalesOrderRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertQuoteToSalesOrderRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertQuoteToSalesOrderResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
ConvertQuoteToSalesOrder Privileges
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertQuoteToSalesOrderRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve in the resulting sales order (order). Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteId | Gets or sets the ID of the quote to convert. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ConvertQuoteToSalesOrderRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertQuoteToSalesOrderResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
ConvertQuoteToSalesOrder Privileges
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertQuoteToSalesOrderRequest.ColumnSet Property
[image]

Gets or sets the collection of attributes to retrieve in the resulting sales order (order). Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The collection of attributes to retrieve in the resulting sales order (order).

  Remarks
Assign null to this property to retrieve only the primary key. The non-null values are returned for the specified attributes in the column set. For attributes that are not included in the column set, the message response contains null values for those attributes. If the column set includes attributes where IsValidForRead is false, they are ignored, and the message response contains no data for those attributes. To learn which attributes are valid for retrieval, see the the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertQuoteToSalesOrderRequest Class
ConvertQuoteToSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertQuoteToSalesOrderRequest.QuoteId Property
[image]

Gets or sets the ID of the quote to convert. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QuoteId As Guid

C#
public Guid QuoteId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the quote to convert that corresponds to the Quote.QuoteId attribute, which is the primary key for the Quote entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertQuoteToSalesOrderRequest Class
ConvertQuoteToSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertQuoteToSalesOrderResponse Class
See Also Members
[image]

Contains the response from the ConvertQuoteToSalesOrderRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertQuoteToSalesOrderResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertQuoteToSalesOrderResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ConvertQuoteToSalesOrderResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertQuoteToSalesOrderResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertQuoteToSalesOrderRequest


ConvertQuoteToSalesOrderResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ConvertQuoteToSalesOrderRequest class.

The following tables list the members exposed by the ConvertQuoteToSalesOrderResponse type.

Public Constructors

Name | Description
ConvertQuoteToSalesOrderResponse | Initializes a new instance of the ConvertQuoteToSalesOrderResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the resulting sales order (order). Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertQuoteToSalesOrderResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertQuoteToSalesOrderRequest


ConvertQuoteToSalesOrderResponse Constructor
[image]

Initializes a new instance of the ConvertQuoteToSalesOrderResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertQuoteToSalesOrderResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertQuoteToSalesOrderResponse Class
ConvertQuoteToSalesOrderResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertQuoteToSalesOrderResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertQuoteToSalesOrderResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertQuoteToSalesOrderRequest


ConvertQuoteToSalesOrderResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the resulting sales order (order). Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ConvertQuoteToSalesOrderResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertQuoteToSalesOrderRequest


ConvertQuoteToSalesOrderResponse.Entity Property
[image]

Gets the resulting sales order (order). Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The resulting sales order (order). This is an instance of the SalesOrder class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertQuoteToSalesOrderResponse Class
ConvertQuoteToSalesOrderResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertSalesOrderToInvoiceRequest Class
See Also Example Members
[image]

Contains the data that is needed to convert a sales order to an invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertSalesOrderToInvoiceRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertSalesOrderToInvoiceRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
#region Convert SalesOrder to Invoice

// Define columns to be retrieved after creating the invoice
ColumnSet invoiceColumns =
    new ColumnSet("invoiceid", "totalamount");

// Convert the order to an invoice
ConvertSalesOrderToInvoiceRequest convertOrderRequest =
    new ConvertSalesOrderToInvoiceRequest()
    {
        SalesOrderId = _salesOrderId,
        ColumnSet = invoiceColumns
    };
ConvertSalesOrderToInvoiceResponse convertOrderResponse =
    (ConvertSalesOrderToInvoiceResponse)_serviceProxy.Execute(convertOrderRequest);
Invoice invoice = (Invoice)convertOrderResponse.Entity;
_invoiceId = invoice.Id;

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the ConvertSalesOrderToInvoiceResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the SalesOrder entity and access rights on the specified record in the SalesOrderId property. For a complete list of the required privileges, see ConvertSalesOrderToInvoice Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ConvertSalesOrderToInvoiceRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ConvertSalesOrderToInvoiceRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertSalesOrderToInvoiceResponse
Other Resources
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
ConvertSalesOrderToInvoice Privileges
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertSalesOrderToInvoiceRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to convert a sales order to an invoice.

The following tables list the members exposed by the ConvertSalesOrderToInvoiceRequest type.

Public Constructors

Name | Description
ConvertSalesOrderToInvoiceRequest | Initializes a new instance of the ConvertSalesOrderToInvoiceRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve from the resulting invoice. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SalesOrderId | Gets or sets the ID of the sales order (order) to convert. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertSalesOrderToInvoiceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertSalesOrderToInvoiceResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
ConvertSalesOrderToInvoice Privileges
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertSalesOrderToInvoiceRequest Constructor
[image]

Initializes a new instance of the ConvertSalesOrderToInvoiceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertSalesOrderToInvoiceRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertSalesOrderToInvoiceRequest Class
ConvertSalesOrderToInvoiceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertSalesOrderToInvoiceRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertSalesOrderToInvoiceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertSalesOrderToInvoiceResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
ConvertSalesOrderToInvoice Privileges
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertSalesOrderToInvoiceRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve from the resulting invoice. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SalesOrderId | Gets or sets the ID of the sales order (order) to convert. Required.

See Also

Reference

ConvertSalesOrderToInvoiceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertSalesOrderToInvoiceResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
ConvertSalesOrderToInvoice Privileges
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ConvertSalesOrderToInvoiceRequest.ColumnSet Property
[image]

Gets or sets the collection of attributes to retrieve from the resulting invoice. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The collection of attributes to retrieve from the resulting invoice.

  Remarks
Assign null to this property to retrieve only the primary key. The non-null values are returned for the specified attributes in the column set. For attributes that are not included in the column set, the message response contains null values for those attributes. If the column set includes attributes where IsValidForRead is false, they are ignored, and the message response contains no data for those attributes. To learn which attributes are valid for retrieval, see the the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertSalesOrderToInvoiceRequest Class
ConvertSalesOrderToInvoiceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertSalesOrderToInvoiceRequest.SalesOrderId Property
[image]

Gets or sets the ID of the sales order (order) to convert. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SalesOrderId As Guid

C#
public Guid SalesOrderId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the sales order (order) to convert that corresponds to the SalesOrder.SalesOrderId attribute, which is the primary key for the SalesOrder entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertSalesOrderToInvoiceRequest Class
ConvertSalesOrderToInvoiceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertSalesOrderToInvoiceResponse Class
See Also Members
[image]

Contains the response from the ConvertSalesOrderToInvoiceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ConvertSalesOrderToInvoiceResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ConvertSalesOrderToInvoiceResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ConvertSalesOrderToInvoiceResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertSalesOrderToInvoiceResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ConvertSalesOrderToInvoiceRequest


ConvertSalesOrderToInvoiceResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ConvertSalesOrderToInvoiceRequest class.

The following tables list the members exposed by the ConvertSalesOrderToInvoiceResponse type.

Public Constructors

Name | Description
ConvertSalesOrderToInvoiceResponse | Initializes a new instance of the ConvertSalesOrderToInvoiceResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the resulting invoice.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConvertSalesOrderToInvoiceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertSalesOrderToInvoiceRequest


ConvertSalesOrderToInvoiceResponse Constructor
[image]

Initializes a new instance of the ConvertSalesOrderToInvoiceResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConvertSalesOrderToInvoiceResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertSalesOrderToInvoiceResponse Class
ConvertSalesOrderToInvoiceResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ConvertSalesOrderToInvoiceResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConvertSalesOrderToInvoiceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertSalesOrderToInvoiceRequest


ConvertSalesOrderToInvoiceResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the resulting invoice.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ConvertSalesOrderToInvoiceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ConvertSalesOrderToInvoiceRequest


ConvertSalesOrderToInvoiceResponse.Entity Property
[image]

Gets the resulting invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type:Entity
The resulting invoice. This is an instance of the Invoice class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConvertSalesOrderToInvoiceResponse Class
ConvertSalesOrderToInvoiceResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopyCampaignRequest Class
See Also Example Members
[image]

Contains the data that is needed to copy a campaign.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopyCampaignRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopyCampaignRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Copy the campaign.
var campaignCopyRequest = new CopyCampaignRequest
{
    BaseCampaign = _originalCampaignId
};

var copyCampaignResponse =
    (CopyCampaignResponse)_serviceProxy.Execute(campaignCopyRequest);
_campaignId = copyCampaignResponse.CampaignCopyId;

Console.WriteLine("  Copied the campaign to new campaign with GUID \r\n\t{{{0}}}",
    _campaignId);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of CopyCampaignResponse.
Privileges and Access Rights

                        To perform this action, the caller must have privileges on the Campaign entity and access rights on the record specified in the BaseCampaign property. For a complete list of required privileges, see CopyCampaign Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CopyCampaignRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CopyCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponse
Other Resources
Campaign Entities
Sample: Distribute Campaign Activities to Qualified Marketing List
CopyCampaign Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyCampaignRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to copy a campaign.

The following tables list the members exposed by the CopyCampaignRequest type.

Public Constructors

Name | Description
CopyCampaignRequest | Initializes a new instance of the CopyCampaignRequest class.
Top

Public Properties

 | Name | Description
public property | BaseCampaign | Gets or sets the ID of the base campaign to copy from. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SaveAsTemplate | Gets or sets a value that indicates whether to save the campaign as a template. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopyCampaignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponse

Other Resources

Campaign Entities
Sample: Distribute Campaign Activities to Qualified Marketing List
CopyCampaign Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyCampaignRequest Constructor
[image]

Initializes a new instance of the CopyCampaignRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopyCampaignRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignRequest Class
CopyCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyCampaignRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopyCampaignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponse

Other Resources

Campaign Entities
Sample: Distribute Campaign Activities to Qualified Marketing List
CopyCampaign Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyCampaignRequest Properties
[image]

Public Properties

 | Name | Description
public property | BaseCampaign | Gets or sets the ID of the base campaign to copy from. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SaveAsTemplate | Gets or sets a value that indicates whether to save the campaign as a template. Required.

See Also

Reference

CopyCampaignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponse

Other Resources

Campaign Entities
Sample: Distribute Campaign Activities to Qualified Marketing List
CopyCampaign Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyCampaignRequest.BaseCampaign Property
[image]

Gets or sets the ID of the base campaign to copy from. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BaseCampaign As Guid

C#
public Guid BaseCampaign { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the base campaign to copy from that corresponds to the Campaign.CampaignId attribute, which is the primary key for the Campaign entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignRequest Class
CopyCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyCampaignRequest.SaveAsTemplate Property
[image]

Gets or sets a value that indicates whether to save the campaign as a template. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SaveAsTemplate As Boolean

C#
public bool SaveAsTemplate { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to save the campaign as a template; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignRequest Class
CopyCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyCampaignResponse Class
See Also Members
[image]

Contains the response from the CopyCampaignRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopyCampaignResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopyCampaignResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CopyCampaignResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignRequest


CopyCampaignResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CopyCampaignRequest class.

The following tables list the members exposed by the CopyCampaignResponse type.

Public Constructors

Name | Description
CopyCampaignResponse | Initializes a new instance of the CopyCampaignResponse class.
Top

Public Properties

 | Name | Description
public property | CampaignCopyId | Gets the ID of the newly created campaign.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopyCampaignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignRequest


CopyCampaignResponse Constructor
[image]

Initializes a new instance of the CopyCampaignResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopyCampaignResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignResponse Class
CopyCampaignResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopyCampaignResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopyCampaignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignRequest


CopyCampaignResponse Properties
[image]

Public Properties

 | Name | Description
public property | CampaignCopyId | Gets the ID of the newly created campaign.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CopyCampaignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignRequest


CopyCampaignResponse.CampaignCopyId Property
[image]

Gets the ID of the newly created campaign.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CampaignCopyId As Guid

C#
public Guid CampaignCopyId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the newly created campaign that corresponds to the Campaign.CampaignId attribute, which is the primary key for the Campaign entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignResponse Class
CopyCampaignResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopyCampaignResponseRequest Class
See Also Members
[image]

Contains the data that is needed to create a copy of the campaign response.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopyCampaignResponseRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopyCampaignResponseRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  CopyCampaignResponseResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the CampaignResponse entity and access rights on the record specified in the CampaignResponseId property. For a complete list of required privileges, see  CopyCampaignResponse Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CopyCampaignResponseRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignResponseRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponseResponse
Other Resources
Campaign Entities
CampaignResponse Entity Messages and Methods
CopyCampaignResponse Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyCampaignResponseRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a copy of the campaign response.

The following tables list the members exposed by the CopyCampaignResponseRequest type.

Public Constructors

Name | Description
CopyCampaignResponseRequest | Initializes a new instance of the CopyCampaignResponseRequest class.
Top

Public Properties

 | Name | Description
public property | CampaignResponseId | Gets or sets the campaign response to copy from. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopyCampaignResponseRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponseResponse

Other Resources

Campaign Entities
CampaignResponse Entity Messages and Methods
CopyCampaignResponse Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyCampaignResponseRequest Constructor
[image]

Initializes a new instance of the CopyCampaignResponseRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopyCampaignResponseRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignResponseRequest Class
CopyCampaignResponseRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyCampaignResponseRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopyCampaignResponseRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponseResponse

Other Resources

Campaign Entities
CampaignResponse Entity Messages and Methods
CopyCampaignResponse Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyCampaignResponseRequest Properties
[image]

Public Properties

 | Name | Description
public property | CampaignResponseId | Gets or sets the campaign response to copy from. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CopyCampaignResponseRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponseResponse

Other Resources

Campaign Entities
CampaignResponse Entity Messages and Methods
CopyCampaignResponse Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyCampaignResponseRequest.CampaignResponseId Property
[image]

Gets or sets the campaign response to copy from. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CampaignResponseId As EntityReference

C#
public EntityReference CampaignResponseId { get; set; }

C++

J#

JScript

Property Value
Type:EntityReference
 The campaign response to copy from.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignResponseRequest Class
CopyCampaignResponseRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyCampaignResponseResponse Class
See Also Members
[image]

Contains the response from the CopyCampaignResponseRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopyCampaignResponseResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopyCampaignResponseResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CopyCampaignResponseResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignResponseResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponseRequest


CopyCampaignResponseResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CopyCampaignResponseRequest class.

The following tables list the members exposed by the CopyCampaignResponseResponse type.

Public Constructors

Name | Description
CopyCampaignResponseResponse | Initializes a new instance of the CopyCampaignResponseResponse class.
Top

Public Properties

 | Name | Description
public property | CampaignResponseId | Gets the ID of the newly created campaign response.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopyCampaignResponseResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponseRequest


CopyCampaignResponseResponse Constructor
[image]

Initializes a new instance of the CopyCampaignResponseResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopyCampaignResponseResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignResponseResponse Class
CopyCampaignResponseResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopyCampaignResponseResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopyCampaignResponseResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponseRequest


CopyCampaignResponseResponse Properties
[image]

Public Properties

 | Name | Description
public property | CampaignResponseId | Gets the ID of the newly created campaign response.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CopyCampaignResponseResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopyCampaignResponseRequest


CopyCampaignResponseResponse.CampaignResponseId Property
[image]

Gets the ID of the newly created campaign response.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CampaignResponseId As Guid

C#
public Guid CampaignResponseId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the newly created campaign response that corresponds to the CampaignResponse.ActivityId attribute, which is the primary key for the CampaignResponse entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyCampaignResponseResponse Class
CopyCampaignResponseResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopyDynamicListToStaticRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a static list from the specified dynamic list and add the members that satisfy the dynamic list query criteria to the static list.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopyDynamicListToStaticRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopyDynamicListToStaticRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Copy the dynamic list to a static list.
CopyDynamicListToStaticRequest copyRequest =
    new CopyDynamicListToStaticRequest()
    {
        ListId = _dynamicListId
    };
CopyDynamicListToStaticResponse copyResponse =
    (CopyDynamicListToStaticResponse)_serviceProxy.Execute(copyRequest);
_staticListId = copyResponse.StaticListId;

Console.WriteLine("Copied dynamic list to a static list.");

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which will return an instance of CopyDynamicListToStaticResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the List entity and access rights on the record specified in the ListId property. For a complete list of the required privileges, see CopyDynamicListToStatic Privileges.
Notes for Callers
The newly created static list is locked. To unlock the list, set the value of the List.Lockstatus attribute to false.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CopyDynamicListToStaticRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CopyDynamicListToStaticRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CopyDynamicListToStaticResponse
Other Resources
List (Marketing List) Entity
Sample: Distribute Campaign Activities to Dynamic and Static Lists
CopyDynamicListToStatic Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyDynamicListToStaticRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a static list from the specified dynamic list and add the members that satisfy the dynamic list query criteria to the static list.

The following tables list the members exposed by the CopyDynamicListToStaticRequest type.

Public Constructors

Name | Description
CopyDynamicListToStaticRequest | Initializes a new instance of the CopyDynamicListToStaticRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the dynamic list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopyDynamicListToStaticRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyDynamicListToStaticResponse

Other Resources

List (Marketing List) Entity
Sample: Distribute Campaign Activities to Dynamic and Static Lists
CopyDynamicListToStatic Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyDynamicListToStaticRequest Constructor
[image]

Initializes a new instance of the CopyDynamicListToStaticRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopyDynamicListToStaticRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyDynamicListToStaticRequest Class
CopyDynamicListToStaticRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyDynamicListToStaticRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopyDynamicListToStaticRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyDynamicListToStaticResponse

Other Resources

List (Marketing List) Entity
Sample: Distribute Campaign Activities to Dynamic and Static Lists
CopyDynamicListToStatic Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyDynamicListToStaticRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the dynamic list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CopyDynamicListToStaticRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyDynamicListToStaticResponse

Other Resources

List (Marketing List) Entity
Sample: Distribute Campaign Activities to Dynamic and Static Lists
CopyDynamicListToStatic Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyDynamicListToStaticRequest.ListId Property
[image]

Gets or sets the ID of the dynamic list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ListId As Guid

C#
public Guid ListId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the dynamic list that corresponds to the List.ListId attribute, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyDynamicListToStaticRequest Class
CopyDynamicListToStaticRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyDynamicListToStaticResponse Class
See Also Members
[image]

Contains the response from the CopyDynamicListToStaticRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopyDynamicListToStaticResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopyDynamicListToStaticResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CopyDynamicListToStaticResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyDynamicListToStaticResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopyDynamicListToStaticResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CopyDynamicListToStaticRequest class.

The following tables list the members exposed by the CopyDynamicListToStaticResponse type.

Public Constructors

Name | Description
CopyDynamicListToStaticResponse | Initializes a new instance of the CopyDynamicListToStaticResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | StaticListId | Gets the ID of the created static list.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopyDynamicListToStaticResponse Class
Microsoft.Crm.Sdk.Messages Namespace


CopyDynamicListToStaticResponse Constructor
[image]

Initializes a new instance of the CopyDynamicListToStaticResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopyDynamicListToStaticResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyDynamicListToStaticResponse Class
CopyDynamicListToStaticResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopyDynamicListToStaticResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopyDynamicListToStaticResponse Class
Microsoft.Crm.Sdk.Messages Namespace


CopyDynamicListToStaticResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | StaticListId | Gets the ID of the created static list.

See Also

Reference

CopyDynamicListToStaticResponse Class
Microsoft.Crm.Sdk.Messages Namespace


CopyDynamicListToStaticResponse.StaticListId Property
[image]

Gets the ID of the created static list.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property StaticListId As Guid

C#
public Guid StaticListId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the created static list that corresponds to the List.ListId attribute, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyDynamicListToStaticResponse Class
CopyDynamicListToStaticResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopyMembersListRequest Class
See Also Members
[image]

Contains the data that is needed to copy the members from the source list to the target list without creating duplicates.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopyMembersListRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopyMembersListRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which will return an instance of CopyMembersListResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the List entity and access rights on the records specified in the SourceListId property and the TargetListId property. For a complete list of the required privileges, see CopyMembersList Privileges.
Notes for Callers
The type of entities contained in the source and target lists must match. The entity type is specified in the List.CreatedFromCode attribute. The OptionSet values for this attribute are Account, Contact, and Lead.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CopyMembersListRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyMembersListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CopyMembersListResponse
Other Resources
List (Marketing List) Entity
Sample: Distribute Campaign Activities to Qualified Marketing List
CopyMembersList Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyMembersListRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to copy the members from the source list to the target list without creating duplicates.

The following tables list the members exposed by the CopyMembersListRequest type.

Public Constructors

Name | Description
CopyMembersListRequest | Initializes a new instance of the CopyMembersListRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SourceListId | Gets or sets the ID of the source list. Required.
public property | TargetListId | Gets or sets the ID of the target list. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopyMembersListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyMembersListResponse

Other Resources

List (Marketing List) Entity
Sample: Distribute Campaign Activities to Qualified Marketing List
CopyMembersList Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyMembersListRequest Constructor
[image]

Initializes a new instance of the CopyMembersListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopyMembersListRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyMembersListRequest Class
CopyMembersListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyMembersListRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopyMembersListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyMembersListResponse

Other Resources

List (Marketing List) Entity
Sample: Distribute Campaign Activities to Qualified Marketing List
CopyMembersList Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyMembersListRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SourceListId | Gets or sets the ID of the source list. Required.
public property | TargetListId | Gets or sets the ID of the target list. Required.

See Also

Reference

CopyMembersListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopyMembersListResponse

Other Resources

List (Marketing List) Entity
Sample: Distribute Campaign Activities to Qualified Marketing List
CopyMembersList Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CopyMembersListRequest.SourceListId Property
[image]

Gets or sets the ID of the source list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SourceListId As Guid

C#
public Guid SourceListId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the source list that corresponds to the List.ListId attribute, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyMembersListRequest Class
CopyMembersListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyMembersListRequest.TargetListId Property
[image]

Gets or sets the ID of the target list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TargetListId As Guid

C#
public Guid TargetListId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the target list that corresponds to the List.ListId attribute, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyMembersListRequest Class
CopyMembersListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopyMembersListResponse Class
See Also Members
[image]

Contains the response from the CopyMembersListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopyMembersListResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopyMembersListResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CopyMembersListResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyMembersListResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CopyMembersListRequest


CopyMembersListResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CopyMembersListRequest class.

The following tables list the members exposed by the CopyMembersListResponse type.

Public Constructors

Name | Description
CopyMembersListResponse | Initializes a new instance of the CopyMembersListResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopyMembersListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopyMembersListRequest


CopyMembersListResponse Constructor
[image]

Initializes a new instance of the CopyMembersListResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopyMembersListResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopyMembersListResponse Class
CopyMembersListResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopyMembersListResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopyMembersListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopyMembersListRequest


CopyMembersListResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CopyMembersListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopyMembersListRequest


CopySystemFormRequest Class
See Also Members
[image]

Contains the data that is needed to create a new entity form that is based on an existing entity form.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopySystemFormRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopySystemFormRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage

                        Pass an instance of this class to the
                        Execute   method, which returns an instance of CopySystemFormResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges listed in CopySystemForm Privileges.
Notes for Callers
If the Target is not set a new SystemForm will be created based on the original.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CopySystemFormRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopySystemFormRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CopySystemFormResponse
Other Resources
Customize Entity Forms


CopySystemFormRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a new entity form that is based on an existing entity form.

The following tables list the members exposed by the CopySystemFormRequest type.

Public Constructors

Name | Description
CopySystemFormRequest | Initializes a new instance of the CopySystemFormRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SourceId | Gets or sets the ID value of the form to copy. Required.
public property | Target | Gets or sets the SystemForm that the original system form should be copied to. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopySystemFormRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopySystemFormResponse

Other Resources

Customize Entity Forms


CopySystemFormRequest Constructor
[image]

Initializes a new instance of the CopySystemFormRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopySystemFormRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopySystemFormRequest Class
CopySystemFormRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopySystemFormRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopySystemFormRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopySystemFormResponse

Other Resources

Customize Entity Forms


CopySystemFormRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SourceId | Gets or sets the ID value of the form to copy. Required.
public property | Target | Gets or sets the SystemForm that the original system form should be copied to. Optional.

See Also

Reference

CopySystemFormRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CopySystemFormResponse

Other Resources

Customize Entity Forms


CopySystemFormRequest.SourceId Property
[image]

Gets or sets the ID value of the form to copy. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SourceId As Guid

C#
public Guid SourceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID value of the form to copy. Required. This corresponds to the SystemForm. FormId attribute, which is the primary key for the SystemForm entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopySystemFormRequest Class
CopySystemFormRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CopySystemFormRequest.Target Property
[image]

Gets or sets the SystemForm that the original system form should be copied to. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Returns Entity.

  Remarks
This must be an entity reference for a system form (system dashboard) entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopySystemFormRequest Class
CopySystemFormRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
SystemForm (System Dashboard) Entity Messages and Methods


CopySystemFormResponse Class
See Also Members
[image]

Contains the response from the CopySystemFormRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CopySystemFormResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CopySystemFormResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CopySystemFormResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopySystemFormResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CopySystemFormRequest


CopySystemFormResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CopySystemFormRequest class.

The following tables list the members exposed by the CopySystemFormResponse type.

Public Constructors

Name | Description
CopySystemFormResponse | Initializes a new instance of the CopySystemFormResponse class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets the ID of the system form that the original was copied to.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CopySystemFormResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopySystemFormRequest


CopySystemFormResponse Constructor
[image]

Initializes a new instance of the CopySystemFormResponse class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CopySystemFormResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopySystemFormResponse Class
CopySystemFormResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CopySystemFormResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CopySystemFormResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopySystemFormRequest


CopySystemFormResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets the ID of the system form that the original was copied to.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CopySystemFormResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CopySystemFormRequest


CopySystemFormResponse.Id Property
[image]

Gets the ID of the system form that the original was copied to.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Id As Guid

C#
public Guid Id { get; }

C++

J#

JScript

Property Value
Type: Guid

If no Target was specified, this is the ID of the system form that the original was copied to. It corresponds to the SystemForm.FormId attribute, which is the primary key for the SystemForm entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CopySystemFormResponse Class
CopySystemFormResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a quick campaign to distribute an activity to members of a list (marketing list).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CreateActivitiesListRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CreateActivitiesListRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the CreateActivitiesListResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the List, Queue, and Template entities and on the specified entity in the Activity property. The caller must also have access rights on the specified records in the following properties: ListId, QueueId, and TemplateId. For a complete list of the required privileges, see CreateActivitiesList Privileges.
Notes for Callers
This operation distributes activities that specify a recipient: a phone call, appointment, letter, fax, or email.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CreateActivitiesListRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CreateActivitiesListResponse
Other Resources
Campaign Entities
Sample: Distribute a Quick Campaign
CreateActivitiesList Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CreateActivitiesListRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a quick campaign to distribute an activity to members of a list (marketing list).

The following tables list the members exposed by the CreateActivitiesListRequest type.

Public Constructors

Name | Description
CreateActivitiesListRequest | Initializes a new instance of the CreateActivitiesListRequest class.
Top

Public Properties

 | Name | Description
public property | Activity | Gets or sets the activity to be distributed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FriendlyName | Gets or sets a display name for the campaign. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list. Required.
public property | Owner | Gets or sets the owner for the activity. Required.
public property | OwnershipOptions | Gets or sets the propagation ownership options. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PostWorkflowEvent | Gets or sets a value that indicates whether an asynchronous job is used to distribute an activity, such as an email, fax, or letter, to the members of a list. Required.
public property | Propagate | Gets or sets a value that indicates whether the activity is both created and executed. Required.
public property | QueueId | Gets or sets the ID of the queue to which the created activities are added. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | sendEmail | Gets or sets a value that indicates whether to send an email about the new activity. Required.
public property | TemplateId | Gets or sets the ID of the email template. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateActivitiesListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateActivitiesListResponse

Other Resources

Campaign Entities
Sample: Distribute a Quick Campaign
CreateActivitiesList Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CreateActivitiesListRequest Constructor
[image]

Initializes a new instance of the CreateActivitiesListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateActivitiesListRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateActivitiesListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateActivitiesListResponse

Other Resources

Campaign Entities
Sample: Distribute a Quick Campaign
CreateActivitiesList Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CreateActivitiesListRequest Properties
[image]

Public Properties

 | Name | Description
public property | Activity | Gets or sets the activity to be distributed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FriendlyName | Gets or sets a display name for the campaign. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list. Required.
public property | Owner | Gets or sets the owner for the activity. Required.
public property | OwnershipOptions | Gets or sets the propagation ownership options. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PostWorkflowEvent | Gets or sets a value that indicates whether an asynchronous job is used to distribute an activity, such as an email, fax, or letter, to the members of a list. Required.
public property | Propagate | Gets or sets a value that indicates whether the activity is both created and executed. Required.
public property | QueueId | Gets or sets the ID of the queue to which the created activities are added. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | sendEmail | Gets or sets a value that indicates whether to send an email about the new activity. Required.
public property | TemplateId | Gets or sets the ID of the email template. Required.

See Also

Reference

CreateActivitiesListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateActivitiesListResponse

Other Resources

Campaign Entities
Sample: Distribute a Quick Campaign
CreateActivitiesList Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


CreateActivitiesListRequest.Activity Property
[image]

Gets or sets the activity to be distributed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Activity As Entity

C#
public Entity Activity { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The activity to be distributed.

  Remarks
This value must be an instance of an activity class. For this property, only use activities that specify a recipient: a phone call, appointment, letter, fax, or email.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Activity Entities


CreateActivitiesListRequest.FriendlyName Property
[image]

Gets or sets a display name for the campaign. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FriendlyName As String

C#
public string FriendlyName { get; set; }

C++

J#

JScript

Property Value
Type: String
The display name for the campaign.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest.ListId Property
[image]

Gets or sets the ID of the list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ListId As Guid

C#
public Guid ListId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the list that corresponds to the List.ListId attribute, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest.Owner Property
[image]

Gets or sets the owner for the activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Owner As EntityReference

C#
public EntityReference Owner { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The owner for the activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest.OwnershipOptions Property
[image]

Gets or sets the propagation ownership options. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OwnershipOptions As PropagationOwnershipOptions

C#
public PropagationOwnershipOptions OwnershipOptions { get; set; }

C++

J#

JScript

Property Value
Type: PropagationOwnershipOptions
The propagation ownership options.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest.PostWorkflowEvent Property
[image]

Gets or sets a value that indicates whether an asynchronous job is used to distribute an activity, such as an email, fax, or letter, to the members of a list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PostWorkflowEvent As Boolean

C#
public bool PostWorkflowEvent { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether an asynchronous job is used to distribute an activity, such as an email, fax, or letter, to the members of a list.
true if an asynchronous job is used to distribute the activity; false if mail merge is used to distribute the activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest.Propagate Property
[image]

Gets or sets a value that indicates whether the activity is both created and executed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Propagate As Boolean

C#
public bool Propagate { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether the activity is both created and executed.
true if an activity is both created and executed; false if an activity is created but not executed.

  Remarks
This property is primarily used for the email activity. For the email activity, use true if an email is created, sent, and marked as complete. Use false if an email is created but not sent.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest.QueueId Property
[image]

Gets or sets the ID of the queue to which the created activities are added. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueueId As Guid

C#
public Guid QueueId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the queue to which the created activities are added that corresponds to the Queue.QueueId attribute, which is the primary key for the Queue entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest.sendEmail Property
[image]

Gets or sets a value that indicates whether to send an email about the new activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property sendEmail As Boolean

C#
public bool sendEmail { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to send an email about the new activity.
true if you want email messages sent automatically; otherwise, false.

  Remarks
Use this property for the email activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListRequest.TemplateId Property
[image]

Gets or sets the ID of the email template. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the email template that corresponds to the Template.TemplateId attribute, which is the primary key for the Template entity.

  Remarks
Use the email template if SendEmail is true.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListRequest Class
CreateActivitiesListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListResponse Class
See Also Members
[image]

Contains the response from the CreateActivitiesListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CreateActivitiesListResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CreateActivitiesListResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CreateActivitiesListResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CreateActivitiesListRequest


CreateActivitiesListResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateActivitiesListRequest class.

The following tables list the members exposed by the CreateActivitiesListResponse type.

Public Constructors

Name | Description
CreateActivitiesListResponse | Initializes a new instance of the CreateActivitiesListResponse class.
Top

Public Properties

 | Name | Description
public property | BulkOperationId | Gets the ID of the bulk operation created to distribute the campaign activity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateActivitiesListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateActivitiesListRequest


CreateActivitiesListResponse Constructor
[image]

Initializes a new instance of the CreateActivitiesListResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateActivitiesListResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListResponse Class
CreateActivitiesListResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CreateActivitiesListResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateActivitiesListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateActivitiesListRequest


CreateActivitiesListResponse Properties
[image]

Public Properties

 | Name | Description
public property | BulkOperationId | Gets the ID of the bulk operation created to distribute the campaign activity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CreateActivitiesListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateActivitiesListRequest


CreateActivitiesListResponse.BulkOperationId Property
[image]

Gets the ID of the bulk operation created to distribute the campaign activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; }

C++

J#

JScript

Property Value
Type Guid
The ID of the bulk operation created to distribute the campaign activity that corresponds to the BulkOperation.ActivityId attribute, which is the primary key for the BulkOperation entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateActivitiesListResponse Class
CreateActivitiesListResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CreateExceptionRequest Class
See Also Members
[image]

Contains the data that is needed to create an exception for the recurring appointment instance.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CreateExceptionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CreateExceptionRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute method, which returns an instance of  the CreateExceptionResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the entity that is specified in the Target property and access rights on the specified record in the Target property. For a complete list of the required privileges, see CreateException Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CreateExceptionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateExceptionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CreateExceptionResponse
Other Resources
Update a Recurring Appointment
Create a Recurring Appointment Exception


CreateExceptionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create an exception for the recurring appointment instance.

The following tables list the members exposed by the CreateExceptionRequest type.

Public Constructors

Name | Description
CreateExceptionRequest | Initializes a new instance of the CreateExceptionRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IsDeleted | Gets or sets whether the appointment instance is deleted.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OriginalStartDate | Gets or sets the original start date of the recurring appointment.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target appointment for the exception.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateExceptionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateExceptionResponse

Other Resources

Update a Recurring Appointment
Create a Recurring Appointment Exception


CreateExceptionRequest Constructor
[image]

Initializes a new instance of the CreateExceptionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateExceptionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateExceptionRequest Class
CreateExceptionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateExceptionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateExceptionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateExceptionResponse

Other Resources

Update a Recurring Appointment
Create a Recurring Appointment Exception


CreateExceptionRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IsDeleted | Gets or sets whether the appointment instance is deleted.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OriginalStartDate | Gets or sets the original start date of the recurring appointment.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target appointment for the exception.

See Also

Reference

CreateExceptionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateExceptionResponse

Other Resources

Update a Recurring Appointment
Create a Recurring Appointment Exception


CreateExceptionRequest.IsDeleted Property
[image]

Gets or sets whether the appointment instance is deleted.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IsDeleted As Boolean

C#
public bool IsDeleted { get; set; }

C++

J#

JScript

Property Value
Type:  Boolean
Indicates if the appointment instance is deleted.
true, if deleted, otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateExceptionRequest Class
CreateExceptionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateExceptionRequest.OriginalStartDate Property
[image]

Gets or sets the original start date of the recurring appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OriginalStartDate As DateTime

C#
public DateTime OriginalStartDate { get; set; }

C++

J#

JScript

Property Value
Type:  DateTime
The original start date of the recurring appointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateExceptionRequest Class
CreateExceptionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateExceptionRequest.Target Property
[image]

Gets or sets the target appointment for the exception.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The target appointment for the exception.
This must be an entity reference for an appointment entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateExceptionRequest Class
CreateExceptionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Appointment Entity Messages and Methods


CreateExceptionResponse Class
See Also Members
[image]

Contains the response from the CreateExceptionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CreateExceptionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CreateExceptionResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CreateExceptionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateExceptionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CreateExceptionRequest


CreateExceptionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateExceptionRequest class.

The following tables list the members exposed by the CreateExceptionResponse type.

Public Constructors

Name | Description
CreateExceptionResponse | Initializes a new instance of the CreateExceptionResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Gets the ID of the exception appointment.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateExceptionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateExceptionRequest


CreateExceptionResponse Constructor
[image]

Initializes a new instance of the CreateExceptionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateExceptionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateExceptionResponse Class
CreateExceptionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CreateExceptionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateExceptionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateExceptionRequest


CreateExceptionResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Gets the ID of the exception appointment.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CreateExceptionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateExceptionRequest


CreateExceptionResponse.id Property
[image]

Gets the ID of the exception appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property id As Guid

C#
public Guid id { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the exception appointment. This corresponds to the Appointment. AppointmentId attribute, which is the primary key for the Appointment entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateExceptionResponse Class
CreateExceptionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CreateInstanceRequest Class
See Also Members
[image]

Contains the data that is needed to create future unexpanded instances for the recurring appointment master.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CreateInstanceRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CreateInstanceRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the CreateInstanceResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the appointment entity and access rights on the specified record in the Target property. For a complete list of the required privileges, see CreateInstance Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CreateInstanceRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateInstanceRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CreateInstanceResponse
Other Resources
Create a Recurring Appointment Exception
Appointment Entity Messages and Methods


CreateInstanceRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create future unexpanded instances for the recurring appointment master.

The following tables list the members exposed by the CreateInstanceRequest type.

Public Constructors

Name | Description
CreateInstanceRequest | Initializes a new instance of the CreateInstanceRequest class.
Top

Public Properties

 | Name | Description
public property | Count | Gets or sets the number of instances to be created. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target appointment instance to create. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateInstanceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateInstanceResponse

Other Resources

Create a Recurring Appointment Exception
Appointment Entity Messages and Methods


CreateInstanceRequest Constructor
[image]

Initializes a new instance of the CreateInstanceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateInstanceRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateInstanceRequest Class
CreateInstanceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateInstanceRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateInstanceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateInstanceResponse

Other Resources

Create a Recurring Appointment Exception
Appointment Entity Messages and Methods


CreateInstanceRequest Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets or sets the number of instances to be created. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target appointment instance to create. Required.

See Also

Reference

CreateInstanceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateInstanceResponse

Other Resources

Create a Recurring Appointment Exception
Appointment Entity Messages and Methods


CreateInstanceRequest.Count Property
[image]

Gets or sets the number of instances to be created. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Count As Integer

C#
public int Count { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of instances to be created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateInstanceRequest Class
CreateInstanceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateInstanceRequest.Target Property
[image]

Gets or sets the target appointment instance to create. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The target appointment instance to create. This is an instance of the Appointment class, which is a subclass of the Entity class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateInstanceRequest Class
CreateInstanceRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Appointment Entity Messages and Methods


CreateInstanceResponse Class
See Also Members
[image]

Contains the response from the CreateInstanceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CreateInstanceResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CreateInstanceResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CreateInstanceResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateInstanceResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CreateInstanceRequest


CreateInstanceResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateInstanceRequest class.

The following tables list the members exposed by the CreateInstanceResponse type.

Public Constructors

Name | Description
CreateInstanceResponse | Initializes a new instance of the CreateInstanceResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SeriesCanBeExpanded | Gets whether the series can be expanded.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateInstanceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateInstanceRequest


CreateInstanceResponse Constructor
[image]

Initializes a new instance of the CreateInstanceResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateInstanceResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateInstanceResponse Class
CreateInstanceResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CreateInstanceResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateInstanceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateInstanceRequest


CreateInstanceResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SeriesCanBeExpanded | Gets whether the series can be expanded.

See Also

Reference

CreateInstanceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateInstanceRequest


CreateInstanceResponse.SeriesCanBeExpanded Property
[image]

Gets whether the series can be expanded.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property SeriesCanBeExpanded As Boolean

C#
public bool SeriesCanBeExpanded { get; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether the series can be expanded.
true if can be expanded, otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateInstanceResponse Class
CreateInstanceResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CreateWorkflowFromTemplateRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a workflow (process) from a workflow template.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CreateWorkflowFromTemplateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CreateWorkflowFromTemplateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,
                                                     serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    OrganizationServiceContext _orgContext = new OrganizationServiceContext(_serviceProxy);

    CreateRequiredRecords();

    CreateWorkflowFromTemplateRequest request = new CreateWorkflowFromTemplateRequest()
    {
        WorkflowName = "Workflow From Template",
        WorkflowTemplateId = _processTemplateId
    };

    // Execute request.
    CreateWorkflowFromTemplateResponse response = (CreateWorkflowFromTemplateResponse)_serviceProxy.Execute(request);
    _processId = response.Id;

    // Verify success.
    // Retrieve the name of the workflow.
    ColumnSet cols = new ColumnSet("name");
    Workflow newWorkflow = (Workflow)_serviceProxy.Retrieve(Workflow.EntityLogicalName, response.Id, cols);
    if (newWorkflow.Name == "Workflow From Template")
    {
        Console.WriteLine("Created {0}.", request.WorkflowName);
    }

    DeleteRequiredRecords(promptforDelete);
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute   method, which returns an instance of  CreateWorkflowFromTemplateResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the workflow entity and access rights on the record specified in the WorkflowTemplateId property. For a complete list of the privileges required, see CreateWorkflowFromTemplate Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.CreateWorkflowFromTemplateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CreateWorkflowFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
CreateWorkflowFromTemplateResponse
Other Resources
Workflow and Process Entities
Workflow (Process) Entity Messages and Methods
Sample: Create a Process Using a Template


CreateWorkflowFromTemplateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a workflow (process) from a workflow template.

The following tables list the members exposed by the CreateWorkflowFromTemplateRequest type.

Public Constructors

Name | Description
CreateWorkflowFromTemplateRequest | Initializes a new instance of the CreateWorkflowFromTemplateRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | WorkflowName | Gets or sets the name of the new workflow. Required.
public property | WorkflowTemplateId | Gets or sets the ID of the workflow template. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateWorkflowFromTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateWorkflowFromTemplateResponse

Other Resources

Workflow and Process Entities
Workflow (Process) Entity Messages and Methods
Sample: Create a Process Using a Template


CreateWorkflowFromTemplateRequest Constructor
[image]

Initializes a new instance of the CreateWorkflowFromTemplateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateWorkflowFromTemplateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateWorkflowFromTemplateRequest Class
CreateWorkflowFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateWorkflowFromTemplateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateWorkflowFromTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateWorkflowFromTemplateResponse

Other Resources

Workflow and Process Entities
Workflow (Process) Entity Messages and Methods
Sample: Create a Process Using a Template


CreateWorkflowFromTemplateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | WorkflowName | Gets or sets the name of the new workflow. Required.
public property | WorkflowTemplateId | Gets or sets the ID of the workflow template. Required.

See Also

Reference

CreateWorkflowFromTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
CreateWorkflowFromTemplateResponse

Other Resources

Workflow and Process Entities
Workflow (Process) Entity Messages and Methods
Sample: Create a Process Using a Template


CreateWorkflowFromTemplateRequest.WorkflowName Property
[image]

Gets or sets the name of the new workflow. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property WorkflowName As String

C#
public string WorkflowName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the new workflow.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateWorkflowFromTemplateRequest Class
CreateWorkflowFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateWorkflowFromTemplateRequest.WorkflowTemplateId Property
[image]

Gets or sets the ID of the workflow template. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property WorkflowTemplateId As Guid

C#
public Guid WorkflowTemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the workflow template.

  Remarks
The WorkflowTemplateId property corresponds to the Workflow.WorkflowId property, which is the primary key for the Workflow entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateWorkflowFromTemplateRequest Class
CreateWorkflowFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


CreateWorkflowFromTemplateResponse Class
See Also Members
[image]

Contains the response from the CreateWorkflowFromTemplateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class CreateWorkflowFromTemplateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class CreateWorkflowFromTemplateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.CreateWorkflowFromTemplateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateWorkflowFromTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
CreateWorkflowFromTemplateRequest


CreateWorkflowFromTemplateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateWorkflowFromTemplateRequest class.

The following tables list the members exposed by the CreateWorkflowFromTemplateResponse type.

Public Constructors

Name | Description
CreateWorkflowFromTemplateResponse | Initializes a new instance of the CreateWorkflowFromTemplateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets or sets the ID of the new workflow.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateWorkflowFromTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateWorkflowFromTemplateRequest


CreateWorkflowFromTemplateResponse Constructor
[image]

Initializes a new instance of the CreateWorkflowFromTemplateResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateWorkflowFromTemplateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateWorkflowFromTemplateResponse Class
CreateWorkflowFromTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


CreateWorkflowFromTemplateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateWorkflowFromTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateWorkflowFromTemplateRequest


CreateWorkflowFromTemplateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets or sets the ID of the new workflow.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CreateWorkflowFromTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
CreateWorkflowFromTemplateRequest


CreateWorkflowFromTemplateResponse.Id Property
[image]

Gets or sets the ID of the new workflow.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Id As Guid

C#
public Guid Id { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the new workflow.

  Remarks
The Id property corresponds to the Workflow.WorkflowId property, which is the primary key for the Workflow entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateWorkflowFromTemplateResponse Class
CreateWorkflowFromTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteAuditDataRequest Class
See Also Example Members
[image]

Contains the data that is needed to delete all audit data records up until a specified end date.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeleteAuditDataRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeleteAuditDataRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Get the list of audit partitions.
RetrieveAuditPartitionListResponse partitionRequest =
    (RetrieveAuditPartitionListResponse)_service.Execute(new RetrieveAuditPartitionListRequest());
AuditPartitionDetailCollection partitions = partitionRequest.AuditPartitionDetailCollection;

// Create a delete request with an end date earlier than possible.
DeleteAuditDataRequest deleteRequest = new DeleteAuditDataRequest();
deleteRequest.EndDate = new DateTime(2000, 1, 1);

// Check if partitions are not supported as is the case with SQL Server Standard edition.
if (partitions.IsLogicalCollection)
{
    // Delete all audit records created up until now.
    deleteRequest.EndDate = DateTime.Now;
}

// Otherwise, delete all partitions that are older than the current partition.
// Hint: The partitions in the collection are returned in sorted order where the
// partition with the oldest end date is at index 0.
else
{
    for (int n = partitions.Count - 1; n >= 0; --n)
    {
        if (partitions[n].EndDate <= DateTime.Now && partitions[n].EndDate > deleteRequest.EndDate)
        {
            deleteRequest.EndDate = (DateTime)partitions[n].EndDate;
            break;
        }
    }
}

// Delete the audit records.
if (deleteRequest.EndDate != new DateTime(2000, 1, 1))
{
    _service.Execute(deleteRequest);
    Console.WriteLine("Audit records have been deleted.");
}
else
    Console.WriteLine("There were no audit records that could be deleted.");

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which will return an instance of DeleteAuditDataResponse.
Privileges and Access Rights
For a list of the privileges required, see DeleteAuditData Privileges.
Notes for Callers
This message behaves slightly different depending on the version of Microsoft SQL Server that is installed on the Microsoft Dynamics CRM server. See Retrieve and Delete the History of Audited Data Changes for more information.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.DeleteAuditDataRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DeleteAuditDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Audit Entity Data Changes in Microsoft Dynamics CRM
Sample: Audit Entity Data Changes


DeleteAuditDataRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete all audit data records up until a specified end date.

The following tables list the members exposed by the DeleteAuditDataRequest type.

Public Constructors

Name | Description
DeleteAuditDataRequest | Initializes a new instance of the DeleteAuditDataRequest class.
Top

Public Properties

 | Name | Description
public property | EndDate | Gets or sets the end date and time. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteAuditDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Audit Entity Data Changes in Microsoft Dynamics CRM
Sample: Audit Entity Data Changes


DeleteAuditDataRequest Constructor
[image]

Initializes a new instance of the DeleteAuditDataRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteAuditDataRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAuditDataRequest Class
DeleteAuditDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteAuditDataRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteAuditDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Audit Entity Data Changes in Microsoft Dynamics CRM
Sample: Audit Entity Data Changes


DeleteAuditDataRequest Properties
[image]

Public Properties

 | Name | Description
public property | EndDate | Gets or sets the end date and time. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

DeleteAuditDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Audit Entity Data Changes in Microsoft Dynamics CRM
Sample: Audit Entity Data Changes


DeleteAuditDataRequest.EndDate Property
[image]

Gets or sets the end date and time. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EndDate As DateTime

C#
public DateTime EndDate { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The end date and time.

  Remarks
Audit entity records created before the specified end date will be deleted when the DeleteAuditDataRequest is processed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAuditDataRequest Class
DeleteAuditDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteAuditDataResponse Class
See Also Members
[image]

Contains the response from the DeleteAuditDataRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeleteAuditDataResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeleteAuditDataResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.DeleteAuditDataResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAuditDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


DeleteAuditDataResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeleteAuditDataRequest class.

The following tables list the members exposed by the DeleteAuditDataResponse type.

Public Constructors

Name | Description
DeleteAuditDataResponse | Initializes a new instance of the DeleteAuditDataResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | PartitionsDeleted | Gets the number of deleted audit partitions or the number of deleted Audit records.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteAuditDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


DeleteAuditDataResponse Constructor
[image]

Initializes a new instance of the DeleteAuditDataResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteAuditDataResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAuditDataResponse Class
DeleteAuditDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteAuditDataResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteAuditDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


DeleteAuditDataResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | PartitionsDeleted | Gets the number of deleted audit partitions or the number of deleted Audit records.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeleteAuditDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


DeleteAuditDataResponse.PartitionsDeleted Property
[image]

Gets the number of deleted audit partitions or the number of deleted Audit records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property PartitionsDeleted As Integer

C#
public int PartitionsDeleted { get; }

C++

J#

JScript

Property Value
Type: Int32
The number of deleted audit partitions or records.

  Remarks
The returned value depends on whether the version of Microsoft SQL Server that is used by the Microsoft Dynamics CRM server supports database partitions. If it does, the number of deleted partitions is returned. Otherwise, the number of deleted Audit records is returned.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAuditDataResponse Class
DeleteAuditDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteOpenInstancesRequest Class
See Also Example Members
[image]

Contains the data that is needed to delete instances of a recurring appointment master that have an “Open” state.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeleteOpenInstancesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeleteOpenInstancesRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Retrieve a recurring appointment series
RecurringAppointmentMaster retrievedRecurringAppointmentSeries = (RecurringAppointmentMaster)_serviceProxy.Retrieve(RecurringAppointmentMaster.EntityLogicalName, _recurringAppointmentMasterId, new ColumnSet(true));

// Use the DeleteOpenInstances message to end the series to the
// last occurring past instance date w.r.t. the series end date
// (i.e., 20 days from today). Effectively, that means that the
// series will end after the third instance (day 14) as this
// instance is the last occuring past instance w.r.t the specified
// series end date (20 days from today).
// Also specify that the state of past instances (w.r.t. the series
// end date) be set to 'completed'.
DeleteOpenInstancesRequest endAppointmentSeries = new DeleteOpenInstancesRequest
{
    Target = retrievedRecurringAppointmentSeries,
    SeriesEndDate = DateTime.Today.AddDays(20),
    StateOfPastInstances = (int)AppointmentState.Completed
};
_serviceProxy.Execute(endAppointmentSeries);

Console.WriteLine("The recurring appointment series has been ended after the third occurrence.");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of DeleteOpenInstancesResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity specified in the Target property and access rights on the record specified in the Target property. For a list of the privileges required, see DeleteOpenInstances Privileges.
Notes for Callers
Using this message does the following:
  • Deletes all the “open” and “scheduled” future instances of the specified series from the date specified in the SeriesEndDate property. However, if the state of the future instances is changed to “completed” or “canceled”, they are not deleted.
  • Sets the status of the past instances to the specified value in the StateOfPastInstances property. However, the past instances are not deleted.
  • Terminates the series to the last occurring past instance date with respect to the date specified in the SeriesEndDate property, and sets the state of the series to “canceled”.
This allows you to preserve the instances of a recurring appointment series even if you have decided to end it prematurely. This is useful if you have attached notes or attachments to past instances of a recurring appointment series that contain important information about the customer or business.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.DeleteOpenInstancesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DeleteOpenInstancesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Delete or End a Recurring Appointment Series or Instance
RecurringAppointmentMaster Entity Messages and Methods
Sample: End a Recurring Appointment Series


DeleteOpenInstancesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete instances of a recurring appointment master that have an “Open” state.

The following tables list the members exposed by the DeleteOpenInstancesRequest type.

Public Constructors

Name | Description
DeleteOpenInstancesRequest | Initializes a new instance of the DeleteOpenInstancesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SeriesEndDate | Gets or sets the end date for the recurring appointment series. Required.
public property | StateOfPastInstances | Gets or sets the value to be used to set the status of appointment instances that have already passed. Required.
public property | Target | Gets or sets the target record for the operation. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteOpenInstancesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Delete or End a Recurring Appointment Series or Instance
RecurringAppointmentMaster Entity Messages and Methods
Sample: End a Recurring Appointment Series


DeleteOpenInstancesRequest Constructor
[image]

Initializes a new instance of the DeleteOpenInstancesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteOpenInstancesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOpenInstancesRequest Class
DeleteOpenInstancesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteOpenInstancesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteOpenInstancesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Delete or End a Recurring Appointment Series or Instance
RecurringAppointmentMaster Entity Messages and Methods
Sample: End a Recurring Appointment Series


DeleteOpenInstancesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SeriesEndDate | Gets or sets the end date for the recurring appointment series. Required.
public property | StateOfPastInstances | Gets or sets the value to be used to set the status of appointment instances that have already passed. Required.
public property | Target | Gets or sets the target record for the operation. Required.

See Also

Reference

DeleteOpenInstancesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Delete or End a Recurring Appointment Series or Instance
RecurringAppointmentMaster Entity Messages and Methods
Sample: End a Recurring Appointment Series


DeleteOpenInstancesRequest.SeriesEndDate Property
[image]

Gets or sets the end date for the recurring appointment series. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SeriesEndDate As DateTime

C#
public DateTime SeriesEndDate { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The end date for the appointment series.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOpenInstancesRequest Class
DeleteOpenInstancesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteOpenInstancesRequest.StateOfPastInstances Property
[image]

Gets or sets the value to be used to set the status of appointment instances that have already passed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property StateOfPastInstances As Integer

C#
public int StateOfPastInstances { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The status code. The value should be one of the option set values for the RecurringAppointmentMaster.StateCode attribute. For more information, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

  Remarks
If you are using the generated enumerations, use RecurringAppointmentMasterState to set this property. For more information about generating enumerations, see Helper Code: Enumerations for Option Sets.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOpenInstancesRequest Class
DeleteOpenInstancesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteOpenInstancesRequest.Target Property
[image]

Gets or sets the target record for the operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The record that defines the instances to delete. This must be an entity reference for a RecurringAppointmentMaster entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOpenInstancesRequest Class
DeleteOpenInstancesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteOpenInstancesResponse Class
See Also Members
[image]

Contains the response from the DeleteOpenInstancesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeleteOpenInstancesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeleteOpenInstancesResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.DeleteOpenInstancesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOpenInstancesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
DeleteOpenInstancesRequest


DeleteOpenInstancesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeleteOpenInstancesRequest class.

The following tables list the members exposed by the DeleteOpenInstancesResponse type.

Public Constructors

Name | Description
DeleteOpenInstancesResponse | Initializes a new instance of the DeleteOpenInstancesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteOpenInstancesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeleteOpenInstancesRequest


DeleteOpenInstancesResponse Constructor
[image]

Initializes a new instance of the DeleteOpenInstancesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteOpenInstancesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOpenInstancesResponse Class
DeleteOpenInstancesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DeleteOpenInstancesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteOpenInstancesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeleteOpenInstancesRequest


DeleteOpenInstancesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeleteOpenInstancesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeleteOpenInstancesRequest


DeliverIncomingEmailRequest Class
See Also Members
[image]

Contains the data that is needed to create an email activity record from an incoming email message (Track in CRM).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeliverIncomingEmailRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeliverIncomingEmailRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of DeliverIncomingEmailResponse.
Privileges and Access Rights
For a complete list of the privileges required, see DeliverIncomingEmail Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.DeliverIncomingEmailRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
DeliverIncomingEmailResponse
Other Resources
E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


DeliverIncomingEmailRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create an email activity record from an incoming email message (Track in CRM).

The following tables list the members exposed by the DeliverIncomingEmailRequest type.

Public Constructors

Name | Description
DeliverIncomingEmailRequest | Initializes a new instance of the DeliverIncomingEmailRequest class.
Top

Public Properties

 | Name | Description
public property | Attachments | Gets or sets a collection of activity mime attachment (email attachment) instances to attach to the email message. Required.
public property | Bcc | Gets or sets the addresses of the blind carbon copy (Bcc) recipients for the email message. Required.
public property | Body | Gets or sets the message body for the email. Required.
public property | Cc | Gets or sets the addresses of the carbon copy (Cc) recipients for the email message. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ExtraProperties | For internal use only.
public property | From | Gets or sets the from address for the email message. Required.
public property | Importance | Gets or sets the level of importance for the email message. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MessageId | Gets or sets the ID of the email message stored in the email header. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReceivedOn | Gets or sets the time the message was received on. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the subject line for the email message. Optional.
public property | SubmittedBy | Gets or sets the email address of the account that is creating the email activity instance. Required.
public property | To | Gets or sets the addresses of the recipients of the email message. Required.
public property | ValidateBeforeCreate | Gets or sets whether to validate before the create operation occurs.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeliverIncomingEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverIncomingEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


DeliverIncomingEmailRequest Constructor
[image]

Initializes a new instance of the DeliverIncomingEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeliverIncomingEmailRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeliverIncomingEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverIncomingEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


DeliverIncomingEmailRequest Properties
[image]

Public Properties

 | Name | Description
public property | Attachments | Gets or sets a collection of activity mime attachment (email attachment) instances to attach to the email message. Required.
public property | Bcc | Gets or sets the addresses of the blind carbon copy (Bcc) recipients for the email message. Required.
public property | Body | Gets or sets the message body for the email. Required.
public property | Cc | Gets or sets the addresses of the carbon copy (Cc) recipients for the email message. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ExtraProperties | For internal use only.
public property | From | Gets or sets the from address for the email message. Required.
public property | Importance | Gets or sets the level of importance for the email message. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MessageId | Gets or sets the ID of the email message stored in the email header. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReceivedOn | Gets or sets the time the message was received on. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the subject line for the email message. Optional.
public property | SubmittedBy | Gets or sets the email address of the account that is creating the email activity instance. Required.
public property | To | Gets or sets the addresses of the recipients of the email message. Required.
public property | ValidateBeforeCreate | Gets or sets whether to validate before the create operation occurs.

See Also

Reference

DeliverIncomingEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverIncomingEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


DeliverIncomingEmailRequest.Attachments Property
[image]

Gets or sets a collection of activity mime attachment (email attachment) instances to attach to the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Attachments As EntityCollection

C#
public EntityCollection Attachments { get; set; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of ActivityMimeAttachment records to attach to the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.Bcc Property
[image]

Gets or sets the addresses of the blind carbon copy (Bcc) recipients for the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Bcc As String

C#
public string Bcc { get; set; }

C++

J#

JScript

Property Value
Type: String
 The addresses of the blind carbon copy (Bcc) recipients for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.Body Property
[image]

Gets or sets the message body for the email. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Body As String

C#
public string Body { get; set; }

C++

J#

JScript

Property Value
Type: String
 The message body for the email.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.Cc Property
[image]

Gets or sets the addresses of the carbon copy (Cc) recipients for the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Cc As String

C#
public string Cc { get; set; }

C++

J#

JScript

Property Value
Type: String
 The addresses of the carbon copy (Cc) recipients for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.ExtraProperties Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtraProperties As Entity

C#
public Entity ExtraProperties { get; set; }

C++

J#

JScript

Property Value
Type: Entity
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.From Property
[image]

Gets or sets the from address for the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property From As String

C#
public string From { get; set; }

C++

J#

JScript

Property Value
Type: String
 The from address for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.Importance Property
[image]

Gets or sets the level of importance for the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Importance As String

C#
public string Importance { get; set; }

C++

J#

JScript

Property Value
Type: String
 The level of importance for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.MessageId Property
[image]

Gets or sets the ID of the email message stored in the email header. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MessageId As String

C#
public string MessageId { get; set; }

C++

J#

JScript

Property Value
Type: String
 The ID of the email message stored in the email header.

  Remarks
All email messages have an ID property in their headers. This is similar to a GUID and is used to identify the message and to see if a specific email message has already been promoted (added) to Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.ReceivedOn Property
[image]

Gets or sets the time the message was received on. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReceivedOn As DateTime

C#
public DateTime ReceivedOn { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
 The time the message was received on.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.Subject Property
[image]

Gets or sets the subject line for the email message. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Subject As String

C#
public string Subject { get; set; }

C++

J#

JScript

Property Value
Type: String
 The subject line for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.SubmittedBy Property
[image]

Gets or sets the email address of the account that is creating the email activity instance. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SubmittedBy As String

C#
public string SubmittedBy { get; set; }

C++

J#

JScript

Property Value
Type: String
 The email address of the account that is creating the email activity instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.To Property
[image]

Gets or sets the addresses of the recipients of the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property To As String

C#
public string To { get; set; }

C++

J#

JScript

Property Value
Type: String
 The addresses of the recipients of the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailRequest.ValidateBeforeCreate Property
[image]

Gets or sets whether to validate before the create operation occurs.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ValidateBeforeCreate As Boolean

C#
public bool ValidateBeforeCreate { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to validate before the create operation; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailRequest Class
DeliverIncomingEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailResponse Class
See Also Members
[image]

Contains the response from the DeliverIncomingEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeliverIncomingEmailResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeliverIncomingEmailResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.DeliverIncomingEmailResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace
DeliverIncomingEmailRequest


DeliverIncomingEmailResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeliverIncomingEmailRequest class.

The following tables list the members exposed by the DeliverIncomingEmailResponse type.

Public Constructors

Name | Description
DeliverIncomingEmailResponse | Initializes a new instance of the DeliverIncomingEmailResponse class.
Top

Public Properties

 | Name | Description
public property | EmailId | Gets or sets the ID of the email.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeliverIncomingEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverIncomingEmailRequest


DeliverIncomingEmailResponse Constructor
[image]

Initializes a new instance of the DeliverIncomingEmailResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeliverIncomingEmailResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailResponse Class
DeliverIncomingEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverIncomingEmailResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeliverIncomingEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverIncomingEmailRequest


DeliverIncomingEmailResponse Properties
[image]

Public Properties

 | Name | Description
public property | EmailId | Gets or sets the ID of the email.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeliverIncomingEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverIncomingEmailRequest


DeliverIncomingEmailResponse.EmailId Property
[image]

Gets or sets the ID of the email.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EmailId As Guid

C#
public Guid EmailId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the email. This corresponds to the Email.EmailId attribute, which is the primary key for the Email entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverIncomingEmailResponse Class
DeliverIncomingEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest Class
See Also Example Members
[image]

Contains the data that is needed to create an email activity record from the specified email message (Track in CRM).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeliverPromoteEmailRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeliverPromoteEmailRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Create the request.
DeliverPromoteEmailRequest deliverEmailRequest = new DeliverPromoteEmailRequest
{
    Subject = "SDK Sample Email",
    To = emailContact.EMailAddress1,
    From = emailSender.InternalEMailAddress,
    Bcc = String.Empty,
    Cc = String.Empty,
    Importance = "high",
    Body = "This message will create an email activity.",
    MessageId = Guid.NewGuid().ToString(),
    SubmittedBy = "",
    ReceivedOn = DateTime.Now
};

// We won't attach a file to the email, but the Attachments property is required.
deliverEmailRequest.Attachments = new EntityCollection(new ActivityMimeAttachment[0]);
deliverEmailRequest.Attachments.EntityName = ActivityMimeAttachment.EntityLogicalName;

// Execute the request.
DeliverPromoteEmailResponse deliverEmailResponse = (DeliverPromoteEmailResponse)_serviceProxy.Execute(deliverEmailRequest);

// Verify the success.

// Define an anonymous type to define the possible values for
// email status
var EmailStatus = new
{
    Draft = 1,
    Completed = 2,
    Sent = 3,
    Received = 3,
    Canceled = 5,
    PendingSend = 6,
    Sending = 7,
    Failed = 8,
};

// Query for the delivered email, and verify the status code is "Sent".
ColumnSet deliveredMailColumns = new ColumnSet("statuscode");
Email deliveredEmail = (Email)_serviceProxy.Retrieve(Email.EntityLogicalName, deliverEmailResponse.EmailId, deliveredMailColumns);

_emailId = deliveredEmail.ActivityId.Value;

if (deliveredEmail.StatusCode.Value == EmailStatus.Sent)
{
    Console.WriteLine("Successfully created and delivered the e-mail message.");
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  DeliverPromoteEmailResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the activity entity. For a complete list of the privileges required, see DeliverPromoteEmail Privileges.
Notes for Callers
This method is used by Microsoft Dynamics CRM for Microsoft Office Outlook.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.DeliverPromoteEmailRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
DeliverPromoteEmailResponse
Other Resources
E-mail Activity Entities
Email (E-mail) Entity Messages and Methods
Sample: Promote an E-mail Message to Microsoft Dynamics CRM


DeliverPromoteEmailRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create an email activity record from the specified email message (Track in CRM).

The following tables list the members exposed by the DeliverPromoteEmailRequest type.

Public Constructors

Name | Description
DeliverPromoteEmailRequest | Initializes a new instance of the DeliverPromoteEmailRequest class.
Top

Public Properties

 | Name | Description
public property | Attachments | Gets or sets a collection of activity mime attachment (email attachment) records to attach to the email message. Required.
public property | Bcc | Gets or sets the addresses of the blind carbon copy (Bcc) recipients for the email message. Required.
public property | Body | Gets or sets the message body for the email. Required.
public property | Cc | Gets or sets the addresses of the carbon copy (Cc) recipients for the email message. Required.
public property | EmailId | Gets or sets the ID of the email from which to create the email. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ExtraProperties | Gets or sets the extra properties for the email. Optional.
public property | From | Gets or sets the from address for the email message. Required.
public property | Importance | Gets or sets the level of importance for the email message. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MessageId | Gets or sets the ID of the email message stored in the email header. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReceivedOn | Gets or sets the time the message was received on. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the subject line for the email message. Optional.
public property | SubmittedBy | Gets or sets the email address of the account that is creating the email activity instance. Required.
public property | To | Gets or sets the addresses of the recipients of the email message. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeliverPromoteEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverPromoteEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods
Sample: Promote an E-mail Message to Microsoft Dynamics CRM


DeliverPromoteEmailRequest Constructor
[image]

Initializes a new instance of the DeliverPromoteEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeliverPromoteEmailRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeliverPromoteEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverPromoteEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods
Sample: Promote an E-mail Message to Microsoft Dynamics CRM


DeliverPromoteEmailRequest Properties
[image]

Public Properties

 | Name | Description
public property | Attachments | Gets or sets a collection of activity mime attachment (email attachment) records to attach to the email message. Required.
public property | Bcc | Gets or sets the addresses of the blind carbon copy (Bcc) recipients for the email message. Required.
public property | Body | Gets or sets the message body for the email. Required.
public property | Cc | Gets or sets the addresses of the carbon copy (Cc) recipients for the email message. Required.
public property | EmailId | Gets or sets the ID of the email from which to create the email. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ExtraProperties | Gets or sets the extra properties for the email. Optional.
public property | From | Gets or sets the from address for the email message. Required.
public property | Importance | Gets or sets the level of importance for the email message. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MessageId | Gets or sets the ID of the email message stored in the email header. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReceivedOn | Gets or sets the time the message was received on. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the subject line for the email message. Optional.
public property | SubmittedBy | Gets or sets the email address of the account that is creating the email activity instance. Required.
public property | To | Gets or sets the addresses of the recipients of the email message. Required.

See Also

Reference

DeliverPromoteEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverPromoteEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods
Sample: Promote an E-mail Message to Microsoft Dynamics CRM


DeliverPromoteEmailRequest.Attachments Property
[image]

Gets or sets a collection of activity mime attachment (email attachment) records to attach to the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Attachments As EntityCollection

C#
public EntityCollection Attachments { get; set; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of attachments, which a collection of ActivityMimeAttachment records..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.Bcc Property
[image]

Gets or sets the addresses of the blind carbon copy (Bcc) recipients for the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Bcc As String

C#
public string Bcc { get; set; }

C++

J#

JScript

Property Value
Type: String

The addresses of the BCC recipients.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.Body Property
[image]

Gets or sets the message body for the email. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Body As String

C#
public string Body { get; set; }

C++

J#

JScript

Property Value
Type: String

The message body.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.Cc Property
[image]

Gets or sets the addresses of the carbon copy (Cc) recipients for the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Cc As String

C#
public string Cc { get; set; }

C++

J#

JScript

Property Value
Type: String

The addresses of the CC recipients.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.EmailId Property
[image]

Gets or sets the ID of the email from which to create the email. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EmailId As Guid

C#
public Guid EmailId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the email, which corresponds to the Email.EmailId attribute, which is the primary key for the Email entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.ExtraProperties Property
[image]

Gets or sets the extra properties for the email. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtraProperties As Entity

C#
public Entity ExtraProperties { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The extra properties.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.From Property
[image]

Gets or sets the from address for the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property From As String

C#
public string From { get; set; }

C++

J#

JScript

Property Value
Type: String

The from address for the email.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.Importance Property
[image]

Gets or sets the level of importance for the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Importance As String

C#
public string Importance { get; set; }

C++

J#

JScript

Property Value
Type: String

The level of importance for the email.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.MessageId Property
[image]

Gets or sets the ID of the email message stored in the email header. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MessageId As String

C#
public string MessageId { get; set; }

C++

J#

JScript

Property Value
Type: String

The the ID of the email message from the email header.

  Remarks
All email messages have an ID property in their headers. This is similar to a GUID and is used to identify the message and to see if a specific email message has already been promoted (added) to Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.ReceivedOn Property
[image]

Gets or sets the time the message was received on. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReceivedOn As DateTime

C#
public DateTime ReceivedOn { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The time the message was received.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.Subject Property
[image]

Gets or sets the subject line for the email message. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Subject As String

C#
public string Subject { get; set; }

C++

J#

JScript

Property Value
Type: String

The subject line for the email.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.SubmittedBy Property
[image]

Gets or sets the email address of the account that is creating the email activity instance. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SubmittedBy As String

C#
public string SubmittedBy { get; set; }

C++

J#

JScript

Property Value
Type: String

The email address of the account that is creating the email activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailRequest.To Property
[image]

Gets or sets the addresses of the recipients of the email message. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property To As String

C#
public string To { get; set; }

C++

J#

JScript

Property Value
Type: String

The addresses of the recipients of the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailRequest Class
DeliverPromoteEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailResponse Class
See Also Members
[image]

Contains the response from the DeliverPromoteEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeliverPromoteEmailResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeliverPromoteEmailResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.DeliverPromoteEmailResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace
DeliverPromoteEmailRequest


DeliverPromoteEmailResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeliverPromoteEmailRequest class.

The following tables list the members exposed by the DeliverPromoteEmailResponse type.

Public Constructors

Name | Description
DeliverPromoteEmailResponse | Initializes a new instance of the DeliverPromoteEmailResponse class.
Top

Public Properties

 | Name | Description
public property | EmailId | Gets the ID of the newly created email activity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeliverPromoteEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverPromoteEmailRequest


DeliverPromoteEmailResponse Constructor
[image]

Initializes a new instance of the DeliverPromoteEmailResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeliverPromoteEmailResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailResponse Class
DeliverPromoteEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DeliverPromoteEmailResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeliverPromoteEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverPromoteEmailRequest


DeliverPromoteEmailResponse Properties
[image]

Public Properties

 | Name | Description
public property | EmailId | Gets the ID of the newly created email activity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeliverPromoteEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeliverPromoteEmailRequest


DeliverPromoteEmailResponse.EmailId Property
[image]

Gets the ID of the newly created email activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EmailId As Guid

C#
public Guid EmailId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the newly created email activity. This corresponds to the Email.EmailId attribute, which is the primary key for the Email entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeliverPromoteEmailResponse Class
DeliverPromoteEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DeprovisionLanguageRequest Class
See Also Members
[image]

Contains the data that is needed to deprovision a language.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeprovisionLanguageRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeprovisionLanguageRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  the DeprovisionLanguageResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in DeprovisionLanguage Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.DeprovisionLanguageRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeprovisionLanguageRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ProvisionLanguageRequest
Other Resources
Customize Labels to Support Multiple Languages


DeprovisionLanguageRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to deprovision a language.

The following tables list the members exposed by the DeprovisionLanguageRequest type.

Public Constructors

Name | Description
DeprovisionLanguageRequest | Initializes a new instance of theDeprovisionLanguageRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Language | Gets or sets the language to deprovision. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeprovisionLanguageRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ProvisionLanguageRequest

Other Resources

Customize Labels to Support Multiple Languages


DeprovisionLanguageRequest Constructor
[image]

Initializes a new instance of the DeprovisionLanguageRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeprovisionLanguageRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeprovisionLanguageRequest Class
DeprovisionLanguageRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeprovisionLanguageRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeprovisionLanguageRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ProvisionLanguageRequest

Other Resources

Customize Labels to Support Multiple Languages


DeprovisionLanguageRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Language | Gets or sets the language to deprovision. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

DeprovisionLanguageRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ProvisionLanguageRequest

Other Resources

Customize Labels to Support Multiple Languages


DeprovisionLanguageRequest.Language Property
[image]

Gets or sets the language to deprovision. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Language As Integer

C#
public int Language { get; set; }

C++

J#

JScript

Property Value
Type:  Int32
The language to deprovision. Required.

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeprovisionLanguageRequest Class
DeprovisionLanguageRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DeprovisionLanguageResponse Class
See Also Members
[image]

Contains the response from the DeprovisionLanguageRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DeprovisionLanguageResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DeprovisionLanguageResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.DeprovisionLanguageResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeprovisionLanguageResponse Members
Microsoft.Crm.Sdk.Messages Namespace
DeprovisionLanguageRequest


DeprovisionLanguageResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeprovisionLanguageRequest class.

The following tables list the members exposed by the DeprovisionLanguageResponse type.

Public Constructors

Name | Description
DeprovisionLanguageResponse | Initializes a new instance of the DeprovisionLanguageResponse class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeprovisionLanguageResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeprovisionLanguageRequest


DeprovisionLanguageResponse Constructor
[image]

Initializes a new instance of the DeprovisionLanguageResponse class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeprovisionLanguageResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeprovisionLanguageResponse Class
DeprovisionLanguageResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DeprovisionLanguageResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeprovisionLanguageResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeprovisionLanguageRequest


DeprovisionLanguageResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeprovisionLanguageResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DeprovisionLanguageRequest


DisassociateEntitiesRequest Class
See Also Members
[image]

Deprecated. Use the DisassociateRequest class. Contains the data that is needed to remove a link between two entity instances in a many-to-many relationship.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DisassociateEntitiesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DisassociateEntitiesRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.DisassociateEntitiesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
DisassociateRequest


DisassociateEntitiesRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the DisassociateRequest class. Contains the data that is needed to remove a link between two entity instances in a many-to-many relationship.

The following tables list the members exposed by the DisassociateEntitiesRequest type.

Public Constructors

Name | Description
DisassociateEntitiesRequest | Deprecated.Initializes a new instance of the DisassociateEntitiesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Moniker1 | Deprecated. Use the DisassociateRequest class and its members.
public property | Moniker2 | Deprecated. Use the DisassociateRequest class and its members.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelationshipName | Deprecated. Use the DisassociateRequest class and its members.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DisassociateEntitiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DisassociateRequest


DisassociateEntitiesRequest Constructor
[image]

Deprecated.Initializes a new instance of the DisassociateEntitiesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DisassociateEntitiesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateEntitiesRequest Class
DisassociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DisassociateEntitiesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DisassociateEntitiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DisassociateRequest


DisassociateEntitiesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Moniker1 | Deprecated. Use the DisassociateRequest class and its members.
public property | Moniker2 | Deprecated. Use the DisassociateRequest class and its members.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelationshipName | Deprecated. Use the DisassociateRequest class and its members.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

DisassociateEntitiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DisassociateRequest


DisassociateEntitiesRequest.Moniker1 Property
[image]

Deprecated. Use the DisassociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Moniker1 As EntityReference

C#
public EntityReference Moniker1 { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateEntitiesRequest Class
DisassociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DisassociateEntitiesRequest.Moniker2 Property
[image]

Deprecated. Use the DisassociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Moniker2 As EntityReference

C#
public EntityReference Moniker2 { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateEntitiesRequest Class
DisassociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DisassociateEntitiesRequest.RelationshipName Property
[image]

Deprecated. Use the DisassociateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RelationshipName As String

C#
public string RelationshipName { get; set; }

C++

J#

JScript

Property Value
Type:  String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateEntitiesRequest Class
DisassociateEntitiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DisassociateEntitiesResponse Class
See Also Members
[image]

Deprecated. Use the DisassociateRequest class and its associated response class. Contains the response from the DisassociateEntitiesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DisassociateEntitiesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DisassociateEntitiesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.DisassociateEntitiesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateEntitiesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
DisassociateEntitiesRequest


DisassociateEntitiesResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the DisassociateRequest class and its associated response class. Contains the response from the DisassociateEntitiesRequest class.

The following tables list the members exposed by the DisassociateEntitiesResponse type.

Public Constructors

Name | Description
DisassociateEntitiesResponse | Initializes a new instance of the DisassociateEntitiesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DisassociateEntitiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DisassociateEntitiesRequest


DisassociateEntitiesResponse Constructor
[image]

Initializes a new instance of the DisassociateEntitiesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DisassociateEntitiesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateEntitiesResponse Class
DisassociateEntitiesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DisassociateEntitiesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DisassociateEntitiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DisassociateEntitiesRequest


DisassociateEntitiesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DisassociateEntitiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DisassociateEntitiesRequest


DistributeCampaignActivityRequest Class
See Also Members
[image]

Contains the data that is needed to create a bulk operation that distributes a campaign activity. The appropriate activities, such as a phone call or fax, are created for the members of the list that is associated with the specified campaign activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DistributeCampaignActivityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DistributeCampaignActivityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the DistributeCampaignActivityResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the CampaignActivity, Queue, and Template entities and on the specified entity in the Activity property. You must also have access rights on the specified records in the following properties: CampaignActivityId, QueueId, and TemplateId. For a complete list of the required privileges, see DistributeCampaignActivity Privileges.
Notes for Callers
This operation distributes activities that specify a recipient: phone call, appointment, letter, letter via mail merge, fax, fax via mail merge, email, and email via mail merge.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.DistributeCampaignActivityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
DistributeCampaignActivityResponse
Other Resources
DistributeCampaignActivity Privileges
Marketing Entities (Campaign, List)
Sample: Distribute a Quick Campaign
Activity Entities
The Security Model of Microsoft Dynamics CRM


DistributeCampaignActivityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a bulk operation that distributes a campaign activity. The appropriate activities, such as a phone call or fax, are created for the members of the list that is associated with the specified campaign activity.

The following tables list the members exposed by the DistributeCampaignActivityRequest type.

Public Constructors

Name | Description
DistributeCampaignActivityRequest | Initializes a new instance of the DistributeCampaignActivityRequest class.
Top

Public Properties

 | Name | Description
public property | Activity | Gets or sets the activity to be distributed. Required.
public property | CampaignActivityId | Gets or sets the ID of the campaign activity for which the activity is distributed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Owner | Gets or sets the owner for the newly created activity. Required.
public property | OwnershipOptions | Gets or sets the ownership options for the activity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PostWorkflowEvent | Gets or sets a value that indicates whether an asynchronous job is used to distribute activities, such as an email, fax, or letter, to the members of a list. Required.
public property | Propagate | Gets or sets a value that indicates whether the activity is both created and executed. Required.
public property | QueueId | Gets or sets the ID of the queue to which the created activity is added. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SendEmail | Gets or sets a value that indicates whether to send an email about the new activity. Required.
public property | TemplateId | Gets or sets the ID of the email template. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DistributeCampaignActivityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DistributeCampaignActivityResponse

Other Resources

DistributeCampaignActivity Privileges
Marketing Entities (Campaign, List)
Sample: Distribute a Quick Campaign
Activity Entities
The Security Model of Microsoft Dynamics CRM


DistributeCampaignActivityRequest Constructor
[image]

Initializes a new instance of the DistributeCampaignActivityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DistributeCampaignActivityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DistributeCampaignActivityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DistributeCampaignActivityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DistributeCampaignActivityResponse

Other Resources

DistributeCampaignActivity Privileges
Marketing Entities (Campaign, List)
Sample: Distribute a Quick Campaign
Activity Entities
The Security Model of Microsoft Dynamics CRM


DistributeCampaignActivityRequest Properties
[image]

Public Properties

 | Name | Description
public property | Activity | Gets or sets the activity to be distributed. Required.
public property | CampaignActivityId | Gets or sets the ID of the campaign activity for which the activity is distributed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Owner | Gets or sets the owner for the newly created activity. Required.
public property | OwnershipOptions | Gets or sets the ownership options for the activity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PostWorkflowEvent | Gets or sets a value that indicates whether an asynchronous job is used to distribute activities, such as an email, fax, or letter, to the members of a list. Required.
public property | Propagate | Gets or sets a value that indicates whether the activity is both created and executed. Required.
public property | QueueId | Gets or sets the ID of the queue to which the created activity is added. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SendEmail | Gets or sets a value that indicates whether to send an email about the new activity. Required.
public property | TemplateId | Gets or sets the ID of the email template. Required.

See Also

Reference

DistributeCampaignActivityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DistributeCampaignActivityResponse

Other Resources

DistributeCampaignActivity Privileges
Marketing Entities (Campaign, List)
Sample: Distribute a Quick Campaign
Activity Entities
The Security Model of Microsoft Dynamics CRM


DistributeCampaignActivityRequest.Activity Property
[image]

Gets or sets the activity to be distributed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Activity As Entity

C#
public Entity Activity { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The activity to be distributed, which must be instance of an activity class. You can only use activities that specify a recipient: a phone call, appointment, letter, fax, or email. .

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Activity Entities


DistributeCampaignActivityRequest.CampaignActivityId Property
[image]

Gets or sets the ID of the campaign activity for which the activity is distributed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CampaignActivityId As Guid

C#
public Guid CampaignActivityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the campaign activity for which the activity is distributed. This corresponds to the CampaignActivity.ActivityId attribute, which is the primary key for the CampaignActivity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DistributeCampaignActivityRequest.Owner Property
[image]

Gets or sets the owner for the newly created activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Owner As EntityReference

C#
public EntityReference Owner { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
 The owner for the newly created activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DistributeCampaignActivityRequest.OwnershipOptions Property
[image]

Gets or sets the ownership options for the activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OwnershipOptions As PropagationOwnershipOptions

C#
public PropagationOwnershipOptions OwnershipOptions { get; set; }

C++

J#

JScript

Property Value
Type: PropagationOwnershipOptions
The ownership options for the activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DistributeCampaignActivityRequest.PostWorkflowEvent Property
[image]

Gets or sets a value that indicates whether an asynchronous job is used to distribute activities, such as an email, fax, or letter, to the members of a list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PostWorkflowEvent As Boolean

C#
public bool PostWorkflowEvent { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if an asynchronous job is used to distribute the activity; false if mail merge is used to distribute the activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DistributeCampaignActivityRequest.Propagate Property
[image]

Gets or sets a value that indicates whether the activity is both created and executed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Propagate As Boolean

C#
public bool Propagate { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether the activity is both created and executed.
true if an activity is both created and executed; false if an activity is created but not executed.

  Remarks
This property is primarily used for the email activity. For the email activity, use true if an email is created, sent, and marked as complete. Use false if an email is created but not sent.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DistributeCampaignActivityRequest.QueueId Property
[image]

Gets or sets the ID of the queue to which the created activity is added. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueueId As Guid

C#
public Guid QueueId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the queue to which the created activity is added. This corresponds to the Queue.QueueId attribute, which is the primary key for the Queue entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DistributeCampaignActivityRequest.SendEmail Property
[image]

Gets or sets a value that indicates whether to send an email about the new activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SendEmail As Boolean

C#
public bool SendEmail { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if you want emails sent automatically; otherwise, false. Use this property for the email activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DistributeCampaignActivityRequest.TemplateId Property
[image]

Gets or sets the ID of the email template. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the email template. This corresponds to the Template.TemplateId attribute, which is the primary key for the Template entity. Use the email template, if SendEmail is true.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityRequest Class
DistributeCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Template Entities


DistributeCampaignActivityResponse Class
See Also Members
[image]

Contains the response from the DistributeCampaignActivityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DistributeCampaignActivityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DistributeCampaignActivityResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.DistributeCampaignActivityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
DistributeCampaignActivityRequest


DistributeCampaignActivityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DistributeCampaignActivityRequest class.

The following tables list the members exposed by the DistributeCampaignActivityResponse type.

Public Constructors

Name | Description
DistributeCampaignActivityResponse | Initializes a new instance of the DistributeCampaignActivityResponse class.
Top

Public Properties

 | Name | Description
public property | BulkOperationId | Gets the ID of the bulk operation that is used to distribute the campaign activity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DistributeCampaignActivityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DistributeCampaignActivityRequest


DistributeCampaignActivityResponse Constructor
[image]

Initializes a new instance of the DistributeCampaignActivityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DistributeCampaignActivityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityResponse Class
DistributeCampaignActivityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DistributeCampaignActivityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DistributeCampaignActivityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DistributeCampaignActivityRequest


DistributeCampaignActivityResponse Properties
[image]

Public Properties

 | Name | Description
public property | BulkOperationId | Gets the ID of the bulk operation that is used to distribute the campaign activity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DistributeCampaignActivityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DistributeCampaignActivityRequest


DistributeCampaignActivityResponse.BulkOperationId Property
[image]

Gets the ID of the bulk operation that is used to distribute the campaign activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the bulk operation that is used to distribute the campaign activity. This corresponds to the BulkOperation.ActivityId attribute, which is the primary key for the BulkOperation entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DistributeCampaignActivityResponse Class
DistributeCampaignActivityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DownloadReportDefinitionRequest Class
See Also Example Members
[image]

Contains the data that is needed to download a report definition.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DownloadReportDefinitionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DownloadReportDefinitionRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

         // Query for an an existing report: Account Overview. This is a default report in Microsoft Dynamics CRM.
         QueryByAttribute reportQuery = new QueryByAttribute(Report.EntityLogicalName);
         reportQuery.AddAttributeValue("name", "Account Overview");
         reportQuery.ColumnSet = new ColumnSet("reportid");

// Get the report.
EntityCollection retrieveReports = _serviceProxy.RetrieveMultiple(reportQuery);

// Convert retrieved Entity to a report
Report retrievedReport = (Report)retrieveReports.Entities[0];
         Console.WriteLine("Retrieved the 'Account Overview' report.");

// Use the Download Report Definition message.
DownloadReportDefinitionRequest rdlRequest = new DownloadReportDefinitionRequest
{
             ReportId = retrievedReport.ReportId.Value
         };

DownloadReportDefinitionResponse rdlResponse = (DownloadReportDefinitionResponse)_serviceProxy.Execute(rdlRequest);

         // Get the current directory path.
         _currentDirectoryPath = Directory.GetCurrentDirectory();

// Access the xml data and save to disk
XmlTextWriter reportDefinitionFile = new XmlTextWriter( _currentDirectoryPath + "\\NewReport.rdl", System.Text.Encoding.UTF8);
reportDefinitionFile.WriteRaw(rdlResponse.BodyText);
reportDefinitionFile.Close();

         if (File.Exists(_currentDirectoryPath + "\\NewReport.rdl"))
{
             Console.WriteLine("Downloaded the report definition (NewReport.rdl) to '{0}'.", _currentDirectoryPath.ToString());
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute method, which returns an instance of  DownloadReportDefinitionResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the report entity and access rights on the record specified in the ReportId. For a complete list of the privileges required, see DownloadReportDefinition Privileges.
Notes for Callers
The response from the message is a UTF-8 encoded XML document in the form of a string that represents the entire content of the report definition (RDL) file.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.DownloadReportDefinitionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DownloadReportDefinitionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
DownloadReportDefinitionResponse
Other Resources
Report Entities
Report Entity Messages and Methods
Sample: Download Report Definition


DownloadReportDefinitionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to download a report definition.

The following tables list the members exposed by the DownloadReportDefinitionRequest type.

Public Constructors

Name | Description
DownloadReportDefinitionRequest | Initializes a new instance of the DownloadReportDefinitionRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Gets or sets the ID of the report to download.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DownloadReportDefinitionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DownloadReportDefinitionResponse

Other Resources

Report Entities
Report Entity Messages and Methods
Sample: Download Report Definition


DownloadReportDefinitionRequest Constructor
[image]

Initializes a new instance of the DownloadReportDefinitionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DownloadReportDefinitionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DownloadReportDefinitionRequest Class
DownloadReportDefinitionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DownloadReportDefinitionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DownloadReportDefinitionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DownloadReportDefinitionResponse

Other Resources

Report Entities
Report Entity Messages and Methods
Sample: Download Report Definition


DownloadReportDefinitionRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Gets or sets the ID of the report to download.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

DownloadReportDefinitionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DownloadReportDefinitionResponse

Other Resources

Report Entities
Report Entity Messages and Methods
Sample: Download Report Definition


DownloadReportDefinitionRequest.ReportId Property
[image]

Gets or sets the ID of the report to download.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReportId As Guid

C#
public Guid ReportId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the report to download. This corresponds to the Report.ReportId attribute, which is the primary key for the Report entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DownloadReportDefinitionRequest Class
DownloadReportDefinitionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


DownloadReportDefinitionResponse Class
See Also Members
[image]

Contains the response from the DownloadReportDefinitionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class DownloadReportDefinitionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class DownloadReportDefinitionResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.DownloadReportDefinitionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DownloadReportDefinitionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
DownloadReportDefinitionRequest


DownloadReportDefinitionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DownloadReportDefinitionRequest class.

The following tables list the members exposed by the DownloadReportDefinitionResponse type.

Public Constructors

Name | Description
DownloadReportDefinitionResponse | Initializes a new instance of the DownloadReportDefinitionResponse class.
Top

Public Properties

 | Name | Description
public property | BodyText | Gets the report definition.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DownloadReportDefinitionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DownloadReportDefinitionRequest


DownloadReportDefinitionResponse Constructor
[image]

Initializes a new instance of the DownloadReportDefinitionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DownloadReportDefinitionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DownloadReportDefinitionResponse Class
DownloadReportDefinitionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


DownloadReportDefinitionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DownloadReportDefinitionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DownloadReportDefinitionRequest


DownloadReportDefinitionResponse Properties
[image]

Public Properties

 | Name | Description
public property | BodyText | Gets the report definition.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DownloadReportDefinitionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
DownloadReportDefinitionRequest


DownloadReportDefinitionResponse.BodyText Property
[image]

Gets the report definition.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property BodyText As String

C#
public string BodyText { get; }

C++

J#

JScript

Property Value
Type: String
The report definition.
Contains a UTF-8 encoded XML document in the form of a string that represents the entire content of the report definition (RDL) file.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DownloadReportDefinitionResponse Class
DownloadReportDefinitionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


EntitySource Enumeration
[image]

Describes which members of a bulk operation to retrieve.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration EntitySource

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum EntitySource

C++

J#

JScript

  Members
Member name | Description
Account | Retrieve account entities. Value = 0.
All | Retrieve all entities. Value = 3.
Contact | Retrieve contact entities. Value = 1.
Lead | Retrieve lead entities. Value = 2.
  Remarks
This enumeration is used for the EntitySource property.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
BulkOperation (Quick Campaign) Entity Messages and Methods
Campaign Entities


ErrorInfo Class
See Also Members
[image]

Specifies the results of a scheduling operation using the ValidateRequest, BookRequest, or RescheduleRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ErrorInfo
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ErrorInfo : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.ErrorInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorInfo Members
Microsoft.Crm.Sdk.Messages Namespace
ValidateRequest
BookRequest
RescheduleRequest


ErrorInfo Members
See Also Constructors Methods Properties
[image]

Specifies the results of a scheduling operation using the ValidateRequest, BookRequest, or RescheduleRequest message.

The following tables list the members exposed by the ErrorInfo type.

Public Constructors

Name | Description
ErrorInfo | Overloaded. Initializes a new instance of the ErrorInfo class.
Top

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the reason for a scheduling failure.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ResourceList | Gets or sets the array of information about a resource that has a scheduling problem for an appointment.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ErrorInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRequest
BookRequest
RescheduleRequest


ErrorInfo Constructor
[image]

Initializes a new instance of the ErrorInfo class.

Overload List

Name | Description
ErrorInfo () | Initializes a new instance of the ErrorInfo class.
ErrorInfo (String, ResourceInfo[]) | Initializes a new instance of the ErrorInfo class setting the error code and resource list.

See Also

Reference

ErrorInfo Class
ErrorInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ErrorInfo Constructor ()
[image]

Initializes a new instance of the ErrorInfo class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ErrorInfo ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorInfo Class
ErrorInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ErrorInfo Constructor (String, ResourceInfo[])
[image]

Initializes a new instance of the ErrorInfo class setting the error code and resource list.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    errorCode As String, _
    resourceList As ResourceInfo() _
)

C#
public ErrorInfo (
    string errorCode,
    ResourceInfo[] resourceList
)

C++

J#

JScript

Parameters
errorCode
Type: String. The reason for a scheduling failure.
resourceList
Type: ResourceInfo[]. The array of information about a resource that has a scheduling problem for an appointment.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorInfo Class
ErrorInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ErrorInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ErrorInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRequest
BookRequest
RescheduleRequest


ErrorInfo Properties
[image]

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the reason for a scheduling failure.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ResourceList | Gets or sets the array of information about a resource that has a scheduling problem for an appointment.

See Also

Reference

ErrorInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRequest
BookRequest
RescheduleRequest


ErrorInfo.ErrorCode Property
[image]

Gets or sets the reason for a scheduling failure.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorCode As String

C#
[DataMemberAttribute]
public string ErrorCode { get; set; }

C++

J#

JScript

Property Value
Type: String
The reason for a scheduling failure.

  Remarks
This property is used in the TraceInfo class. For a list of possible error codes, see Web Service Error Codes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorInfo Class
ErrorInfo Members
Microsoft.Crm.Sdk.Messages Namespace
TraceInfo


ErrorInfo.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorInfo Class
ErrorInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ErrorInfo.ResourceList Property
[image]

Gets or sets the array of information about a resource that has a scheduling problem for an appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResourceList As ResourceInfo()

C#
[DataMemberAttribute]
public ResourceInfo[] ResourceList { get; set; }

C++

J#

JScript

Property Value
Type: ResourceInfo[]
The array of information about a resource that has a scheduling problem for an appointment.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorInfo Class
ErrorInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteByIdSavedQueryRequest Class
See Also Members
[image]

Contains the data that is needed to execute a saved query (view) that has the specified ID.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExecuteByIdSavedQueryRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExecuteByIdSavedQueryRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to theExecute  method, which returns an instance ofExecuteByIdSavedQueryResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the SavedQuery entity access rights on the record specified by the EntityIdproperty. For a complete list of the privileges required, see ExecuteByIdSavedQuery Privileges.
Notes for Callers
This message returns a String type that specifies the XML data containing the results of the query. This XML string is in the following format:
Xml    Copy Code
<resultset> + <result>result1</result><result>result2</result> + ... + </resultset>

The XML string returned from this method may contain multiple entity instances. If no instances are returned, the method simply returns an XML document for the entity type, with no data.
The XML string returned from this method does not contain elements for attributes where the value is null or contains empty strings. This improves performance by not sending more XML data than is necessary from the server to the client.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ExecuteByIdSavedQueryRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ExecuteByIdSavedQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdSavedQueryResponse
Other Resources
SavedQuery (View) Entity Messages and Methods
Sample: Work with Views


ExecuteByIdSavedQueryRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to execute a saved query (view) that has the specified ID.

The following tables list the members exposed by the ExecuteByIdSavedQueryRequest type.

Public Constructors

Name | Description
ExecuteByIdSavedQueryRequest | Initializes a new instance of the ExecuteByIdSavedQueryRequest class.
Top

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the saved query (view) to execute.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteByIdSavedQueryRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdSavedQueryResponse

Other Resources

SavedQuery (View) Entity Messages and Methods
Sample: Work with Views


ExecuteByIdSavedQueryRequest Constructor
[image]

Initializes a new instance of the ExecuteByIdSavedQueryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteByIdSavedQueryRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteByIdSavedQueryRequest Class
ExecuteByIdSavedQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteByIdSavedQueryRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteByIdSavedQueryRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdSavedQueryResponse

Other Resources

SavedQuery (View) Entity Messages and Methods
Sample: Work with Views


ExecuteByIdSavedQueryRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the saved query (view) to execute.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ExecuteByIdSavedQueryRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdSavedQueryResponse

Other Resources

SavedQuery (View) Entity Messages and Methods
Sample: Work with Views


ExecuteByIdSavedQueryRequest.EntityId Property
[image]

Gets or sets the ID of the saved query (view) to execute.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the saved query (view) to execute. This corresponds to the SavedQuery.SavedQueryId property, which is the primary key for the SavedQuery entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteByIdSavedQueryRequest Class
ExecuteByIdSavedQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteByIdSavedQueryResponse Class
See Also Members
[image]

Contains the response from the ExecuteByIdSavedQueryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExecuteByIdSavedQueryResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExecuteByIdSavedQueryResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ExecuteByIdSavedQueryResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteByIdSavedQueryResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdSavedQueryRequest


ExecuteByIdSavedQueryResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExecuteByIdSavedQueryRequest class.

The following tables list the members exposed by the ExecuteByIdSavedQueryResponse type.

Public Constructors

Name | Description
ExecuteByIdSavedQueryResponse | Initializes a new instance of the ExecuteByIdSavedQueryResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | String | Gets the results of the saved query (view).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteByIdSavedQueryResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdSavedQueryRequest


ExecuteByIdSavedQueryResponse Constructor
[image]

Initializes a new instance of the ExecuteByIdSavedQueryResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteByIdSavedQueryResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteByIdSavedQueryResponse Class
ExecuteByIdSavedQueryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteByIdSavedQueryResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteByIdSavedQueryResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdSavedQueryRequest


ExecuteByIdSavedQueryResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | String | Gets the results of the saved query (view).

See Also

Reference

ExecuteByIdSavedQueryResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdSavedQueryRequest


ExecuteByIdSavedQueryResponse.String Property
[image]

Gets the results of the saved query (view).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property String As String

C#
public string String { get; }

C++

J#

JScript

Property Value
Type: String
The the results of the saved query (view).

  Remarks
This XML string is in the following format:
Xml    Copy Code
<resultset> + <result>result1</result><result>result2</result> + ... + </resultset>

The XML string that is returned from this method may contain multiple entity instances. If no instances are returned, the method returns an XML document for the entity type, and the document contains no data.
The XML string that is returned from this method does not contain elements for attributes where the value is  null or where the value contains empty strings. This improves performance by not sending more XML data than is necessary from the server to the client.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ExecuteByIdSavedQueryResponse Class
ExecuteByIdSavedQueryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteByIdUserQueryRequest Class
See Also Members
[image]

Contains the data that is needed to execute the user query (saved view) that has the specified ID.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExecuteByIdUserQueryRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExecuteByIdUserQueryRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  ExecuteByIdUserQueryResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges and access rights on the entity specified in the EntityId property. For a list of the privileges required, see ExecuteByIdUserQuery Privileges.
Notes for Callers
This message returns a String type that specifies the XML data containing the results of the query. This XML string is in the following format:
Xml    Copy Code
<resultset> + <result>result1</result><result>result2</result> + ... + </resultset>

The XML string returned from this method may contain multiple records. If no records are returned, the method simply returns an XML document for the entity type, with no data.
The XML string returned from this method does not contain elements for attributes where the value is null or contains empty strings. This improves performance by not sending more XML data than is necessary from the server to the client.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ExecuteByIdUserQueryRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ExecuteByIdUserQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdUserQueryResponse
Other Resources
UserQuery (Saved View) Entity Messages and Methods
ExecuteByIdUserQuery Privileges


ExecuteByIdUserQueryRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to execute the user query (saved view) that has the specified ID.

The following tables list the members exposed by the ExecuteByIdUserQueryRequest type.

Public Constructors

Name | Description
ExecuteByIdUserQueryRequest | Initializes a new instance of the ExecuteByIdUserQueryRequest class.
Top

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the user query (saved view) record to be executed.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteByIdUserQueryRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdUserQueryResponse

Other Resources

UserQuery (Saved View) Entity Messages and Methods
ExecuteByIdUserQuery Privileges


ExecuteByIdUserQueryRequest Constructor
[image]

Initializes a new instance of the ExecuteByIdUserQueryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteByIdUserQueryRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteByIdUserQueryRequest Class
ExecuteByIdUserQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteByIdUserQueryRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteByIdUserQueryRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdUserQueryResponse

Other Resources

UserQuery (Saved View) Entity Messages and Methods
ExecuteByIdUserQuery Privileges


ExecuteByIdUserQueryRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the user query (saved view) record to be executed.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ExecuteByIdUserQueryRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdUserQueryResponse

Other Resources

UserQuery (Saved View) Entity Messages and Methods
ExecuteByIdUserQuery Privileges


ExecuteByIdUserQueryRequest.EntityId Property
[image]

Gets or sets the ID of the user query (saved view) record to be executed.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As EntityReference

C#
public EntityReference EntityId { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The ID of the user query (saved view) record to be executed. The ID corresponds to the UserQuery.UserQueryId property, which is the primary key for the UserQuery entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteByIdUserQueryRequest Class
ExecuteByIdUserQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteByIdUserQueryResponse Class
See Also Members
[image]

Contains the response from the ExecuteByIdUserQueryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExecuteByIdUserQueryResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExecuteByIdUserQueryResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ExecuteByIdUserQueryResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteByIdUserQueryResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdUserQueryRequest


ExecuteByIdUserQueryResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExecuteByIdUserQueryRequest class.

The following tables list the members exposed by the ExecuteByIdUserQueryResponse type.

Public Constructors

Name | Description
ExecuteByIdUserQueryResponse | Initializes a new instance of the ExecuteByIdUserQueryResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | String | Gets the results of the user query (saved view).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteByIdUserQueryResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdUserQueryRequest


ExecuteByIdUserQueryResponse Constructor
[image]

Initializes a new instance of the ExecuteByIdUserQueryResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteByIdUserQueryResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteByIdUserQueryResponse Class
ExecuteByIdUserQueryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteByIdUserQueryResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteByIdUserQueryResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdUserQueryRequest


ExecuteByIdUserQueryResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | String | Gets the results of the user query (saved view).

See Also

Reference

ExecuteByIdUserQueryResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteByIdUserQueryRequest


ExecuteByIdUserQueryResponse.String Property
[image]

Gets the results of the user query (saved view).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property String As String

C#
public string String { get; }

C++

J#

JScript

Property Value
Type: String
The results of the user query (saved view).

  Remarks
This XML string is in the following format:
Xml    Copy Code
<resultset> + <result>result1</result><result>result2</result> + ... + </resultset>

The XML string that is returned from this method may contain multiple entity instances. If no instances are returned, the method returns an XML document for the entity type, and the document contains no data.
The XML string that is returned from this method does not contain elements for attributes where the value is null or where the value contains empty strings. This improves performance by not sending more XML data than is necessary from the server to the client.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ExecuteByIdUserQueryResponse Class
ExecuteByIdUserQueryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteFetchRequest Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExecuteFetchRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExecuteFetchRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ExecuteFetchRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteFetchRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ExecuteFetchResponse
RetrieveMultipleRequest
Other Resources
ExecuteFetch Privileges


ExecuteFetchRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class.

The following tables list the members exposed by the ExecuteFetchRequest type.

Public Constructors

Name | Description
ExecuteFetchRequest | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FetchXml | Deprecated.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteFetchRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteFetchResponse
RetrieveMultipleRequest

Other Resources

ExecuteFetch Privileges


ExecuteFetchRequest Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteFetchRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteFetchRequest Class
ExecuteFetchRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteFetchRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteFetchRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteFetchResponse
RetrieveMultipleRequest

Other Resources

ExecuteFetch Privileges


ExecuteFetchRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FetchXml | Deprecated.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ExecuteFetchRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteFetchResponse
RetrieveMultipleRequest

Other Resources

ExecuteFetch Privileges


ExecuteFetchRequest.FetchXml Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FetchXml As String

C#
public string FetchXml { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteFetchRequest Class
ExecuteFetchRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteFetchResponse Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExecuteFetchResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExecuteFetchResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ExecuteFetchResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteFetchResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ExecuteFetchRequest


ExecuteFetchResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

The following tables list the members exposed by the ExecuteFetchResponse type.

Public Constructors

Name | Description
ExecuteFetchResponse | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | FetchXmlResult | Deprecated.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteFetchResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteFetchRequest


ExecuteFetchResponse Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteFetchResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteFetchResponse Class
ExecuteFetchResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteFetchResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteFetchResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteFetchRequest


ExecuteFetchResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | FetchXmlResult | Deprecated.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ExecuteFetchResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteFetchRequest


ExecuteFetchResponse.FetchXmlResult Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property FetchXmlResult As String

C#
public string FetchXmlResult { get; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteFetchResponse Class
ExecuteFetchResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteWorkflowRequest Class
See Also Example Members
[image]

Contains the data that’s needed to execute a workflow.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExecuteWorkflowRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExecuteWorkflowRequest : OrganizationRequest

C++

J#

JScript

  Example

                                The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an
                                IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create an ExecuteWorkflow request.
ExecuteWorkflowRequest request = new ExecuteWorkflowRequest()
{
    WorkflowId = _workflowId,
    EntityId = _leadId
};
Console.Write("Created ExecuteWorkflow request, ");

// Execute the workflow.
ExecuteWorkflowResponse response =
    (ExecuteWorkflowResponse)_serviceProxy.Execute(request);
Console.WriteLine("and sent request to service.");

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of ExecuteWorkflowResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Workflow entity and access rights on the record specified in the EntityId and WorkflowId properties. For a complete list of the privileges required, see ExecuteWorkflow Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ExecuteWorkflowRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ExecuteWorkflowRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ExecuteWorkflowResponse
Other Resources
Processes, Workflows, and Dialogs
Sample: Execute a Workflow


ExecuteWorkflowRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that’s needed to execute a workflow.

The following tables list the members exposed by the ExecuteWorkflowRequest type.

Public Constructors

Name | Description
ExecuteWorkflowRequest | Initializes a new instance of the ExecuteWorkflowRequest class.
Top

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the record on which the workflow executes. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InputArguments | For internal use only.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | WorkflowId | Gets or sets the ID of the workflow to execute. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteWorkflowRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteWorkflowResponse

Other Resources

Processes, Workflows, and Dialogs
Sample: Execute a Workflow


ExecuteWorkflowRequest Constructor
[image]

Initializes a new instance of the ExecuteWorkflowRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteWorkflowRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteWorkflowRequest Class
ExecuteWorkflowRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteWorkflowRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteWorkflowRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteWorkflowResponse

Other Resources

Processes, Workflows, and Dialogs
Sample: Execute a Workflow


ExecuteWorkflowRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the record on which the workflow executes. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InputArguments | For internal use only.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | WorkflowId | Gets or sets the ID of the workflow to execute. Required.

See Also

Reference

ExecuteWorkflowRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteWorkflowResponse

Other Resources

Processes, Workflows, and Dialogs
Sample: Execute a Workflow


ExecuteWorkflowRequest.EntityId Property
[image]

Gets or sets the ID of the record on which the workflow executes. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid.
The ID of the record on which the workflow executes.

  Remarks
The EntityId property corresponds to the primary key for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteWorkflowRequest Class
ExecuteWorkflowRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteWorkflowRequest.InputArguments Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property InputArguments As InputArgumentCollection

C#
public InputArgumentCollection InputArguments { get; set; }

C++

J#

JScript

Property Value
Returns InputArgumentCollection.

  Remarks
Provides the ability to pass input arguments into an executing workflow.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteWorkflowRequest Class
ExecuteWorkflowRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteWorkflowRequest.WorkflowId Property
[image]

Gets or sets the ID of the workflow to execute. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property WorkflowId As Guid

C#
public Guid WorkflowId { get; set; }

C++

J#

JScript

Property Value
Type: Guid.
The ID of the workflow to execute.

  Remarks
The WorkflowId property corresponds to the Workflow.WorkflowId property, which is the primary key for the Workflow entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteWorkflowRequest Class
ExecuteWorkflowRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteWorkflowResponse Class
See Also Members
[image]

Contains the response from the ExecuteWorkflowResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExecuteWorkflowResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExecuteWorkflowResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ExecuteWorkflowResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteWorkflowResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ExecuteWorkflowReQuest


ExecuteWorkflowResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExecuteWorkflowResponse class.

The following tables list the members exposed by the ExecuteWorkflowResponse type.

Public Constructors

Name | Description
ExecuteWorkflowResponse | Initializes a new instance of the ExecuteWorkflowResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets the ID of the asynchronous operation (system job) that was created.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteWorkflowResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteWorkflowReQuest


ExecuteWorkflowResponse Constructor
[image]

Initializes a new instance of the ExecuteWorkflowResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteWorkflowResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteWorkflowResponse Class
ExecuteWorkflowResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExecuteWorkflowResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteWorkflowResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteWorkflowReQuest


ExecuteWorkflowResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets the ID of the asynchronous operation (system job) that was created.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ExecuteWorkflowResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExecuteWorkflowReQuest


ExecuteWorkflowResponse.Id Property
[image]

Gets the ID of the asynchronous operation (system job) that was created.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Id As Guid

C#
public Guid Id { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the asynchronous operation.

  Remarks
The Id property corresponds to the AsyncOperation.AsyncOperationId property, which is the primary key for the AsyncOperation entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteWorkflowResponse Class
ExecuteWorkflowResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExpandCalendarRequest Class
See Also Members
[image]

Contains the data that is needed to convert the calendar rules to an array of available time blocks for the specified period.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExpandCalendarRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExpandCalendarRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the ExpandCalendarResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the calendar entity and access rights on the specified record in the CalendarId property. For a complete list of the required privileges, see ExpandCalendar Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ExpandCalendarRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExpandCalendarRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarResponse
Other Resources
Calendar Entities
Calendar Entity Messages and Methods
ExpandCalendar Privileges


ExpandCalendarRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to convert the calendar rules to an array of available time blocks for the specified period.

The following tables list the members exposed by the ExpandCalendarRequest type.

Public Constructors

Name | Description
ExpandCalendarRequest | Initializes a new instance of the ExpandCalendarRequest class.
Top

Public Properties

 | Name | Description
public property | CalendarId | Gets or sets the ID of the calendar.
public property | End | Gets or sets the end of the time period to expand.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Start | Gets or sets the start of the period to expand.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExpandCalendarRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarResponse

Other Resources

Calendar Entities
Calendar Entity Messages and Methods
ExpandCalendar Privileges


ExpandCalendarRequest Constructor
[image]

Initializes a new instance of the ExpandCalendarRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExpandCalendarRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExpandCalendarRequest Class
ExpandCalendarRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExpandCalendarRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExpandCalendarRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarResponse

Other Resources

Calendar Entities
Calendar Entity Messages and Methods
ExpandCalendar Privileges


ExpandCalendarRequest Properties
[image]

Public Properties

 | Name | Description
public property | CalendarId | Gets or sets the ID of the calendar.
public property | End | Gets or sets the end of the time period to expand.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Start | Gets or sets the start of the period to expand.

See Also

Reference

ExpandCalendarRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarResponse

Other Resources

Calendar Entities
Calendar Entity Messages and Methods
ExpandCalendar Privileges


ExpandCalendarRequest.CalendarId Property
[image]

Gets or sets the ID of the calendar.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CalendarId As Guid

C#
public Guid CalendarId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the calendar. This corresponds to the Calendar.CalendarId property, which is the primary key for the Calendar entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExpandCalendarRequest Class
ExpandCalendarRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExpandCalendarRequest.End Property
[image]

Gets or sets the end of the time period to expand.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property End As DateTime

C#
public DateTime End { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The end of the time period to expand.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExpandCalendarRequest Class
ExpandCalendarRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExpandCalendarRequest.Start Property
[image]

Gets or sets the start of the period to expand.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Start As DateTime

C#
public DateTime Start { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The start of the time period to expand.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExpandCalendarRequest Class
ExpandCalendarRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExpandCalendarResponse Class
See Also Members
[image]

Contains the response from the ExpandCalendarRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExpandCalendarResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExpandCalendarResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ExpandCalendarResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExpandCalendarResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarRequest


ExpandCalendarResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExpandCalendarRequest class.

The following tables list the members exposed by the ExpandCalendarResponse type.

Public Constructors

Name | Description
ExpandCalendarResponse | Initializes a new instance of the ExpandCalendarResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | result | Gets a set of time blocks with appointment information.
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExpandCalendarResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarRequest


ExpandCalendarResponse Constructor
[image]

Initializes a new instance of the ExpandCalendarResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExpandCalendarResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExpandCalendarResponse Class
ExpandCalendarResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExpandCalendarResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExpandCalendarResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarRequest


ExpandCalendarResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | result | Gets a set of time blocks with appointment information.
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ExpandCalendarResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarRequest


ExpandCalendarResponse.result Property
[image]

Gets a set of time blocks with appointment information.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property result As TimeInfo()

C#
public TimeInfo[] result { get; }

C++

J#

JScript

Property Value
Type:TimeInfo
The set of time blocks with appointment information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExpandCalendarResponse Class
ExpandCalendarResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExportFieldTranslationRequest Class
See Also Members
[image]

Contains the data that is needed to export localizable fields values to a compressed file.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExportFieldTranslationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExportFieldTranslationRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute   method, which returns an instance of ExportFieldTranslationResponse.
Privileges and Access Rights
To export the labels for specific records the user must have read privileges for those records.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ExportFieldTranslationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportFieldTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Localize product property values


ExportFieldTranslationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to export localizable fields values to a compressed file.

The following tables list the members exposed by the ExportFieldTranslationRequest type.

Public Constructors

Name | Description
ExportFieldTranslationRequest | Initializes a new instance of the ExportFieldTranslationRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExportFieldTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Localize product property values


ExportFieldTranslationRequest Constructor
[image]

Initializes a new instance of the ExportFieldTranslationRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExportFieldTranslationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportFieldTranslationRequest Class
ExportFieldTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ImportFieldTranslationRequest
Other Resources
Localize product property values


ExportFieldTranslationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExportFieldTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Localize product property values


ExportFieldTranslationRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ExportFieldTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Localize product property values


ExportFieldTranslationResponse Class
See Also Members
[image]

Contains the response from the ExportFieldTranslationRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExportFieldTranslationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExportFieldTranslationResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ExportFieldTranslationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportFieldTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ExportFieldTranslationRequest
Other Resources
Localize product property values


ExportFieldTranslationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExportFieldTranslationRequest class.

The following tables list the members exposed by the ExportFieldTranslationResponse type.

Public Constructors

Name | Description
ExportFieldTranslationResponse | Initializes a new instance of the ExportFieldTranslationResponse class.
Top

Public Properties

 | Name | Description
public property | ExportTranslationFile | Gets the compressed file that represents the exported translation file.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExportFieldTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportFieldTranslationRequest

Other Resources

Localize product property values


ExportFieldTranslationResponse Constructor
[image]

Initializes a new instance of the ExportFieldTranslationResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExportFieldTranslationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportFieldTranslationResponse Class
ExportFieldTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExportFieldTranslationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExportFieldTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportFieldTranslationRequest

Other Resources

Localize product property values


ExportFieldTranslationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExportTranslationFile | Gets the compressed file that represents the exported translation file.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ExportFieldTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportFieldTranslationRequest

Other Resources

Localize product property values


ExportFieldTranslationResponse.ExportTranslationFile Property
[image]

Gets the compressed file that represents the exported translation file.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ExportTranslationFile As Byte()

C#
public byte[] ExportTranslationFile { get; }

C++

J#

JScript

Property Value
Type: Byte[]
 The compressed file that represents the exported translation file.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportFieldTranslationResponse Class
ExportFieldTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExportMappingsImportMapRequest Class
See Also Example Members
[image]

Contains the data that is needed to export a data map as an XML formatted data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExportMappingsImportMapRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExportMappingsImportMapRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Retrieve the value for validation
var exportRequest = new ExportMappingsImportMapRequest
{
    ImportMapId = _newImportMapId.Value,
    ExportIds = true,
};

var exportResponse = (ExportMappingsImportMapResponse)_serviceProxy
    .Execute(exportRequest);

var mappingXml = exportResponse.MappingsXml;

Console.WriteLine(String.Concat("\nValidating mapping xml for : ",
    _newImportMapId.Value, ",\nMappingsXml:\n", mappingXml));

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of ExportMappingsImportMapResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the ImportMap entity and the access rights on the record specified in the ImportMapId property. For a complete list of required privileges, see ExportMappingsImportMap Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ExportMappingsImportMapRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ExportMappingsImportMapRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ExportMappingsImportMapResponse
Other Resources
Import Data in Microsoft Dynamics CRM
Create Data Maps
Add Transformation Mapping
Sample: Export and Import a Data Map
The Security Model of Microsoft Dynamics CRM


ExportMappingsImportMapRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to export a data map as an XML formatted data.

The following tables list the members exposed by the ExportMappingsImportMapRequest type.

Public Constructors

Name | Description
ExportMappingsImportMapRequest | Initializes a new instance of the ExportMappingsImportMapRequest class.
Top

Public Properties

 | Name | Description
public property | ExportIds | Gets or sets a value that indicates whether to export the entity record IDs contained in the data map. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportMapId | Gets or sets the ID of the import map (data map) to export. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExportMappingsImportMapRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExportMappingsImportMapResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Create Data Maps
Add Transformation Mapping
Sample: Export and Import a Data Map
The Security Model of Microsoft Dynamics CRM


ExportMappingsImportMapRequest Constructor
[image]

Initializes a new instance of the ExportMappingsImportMapRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExportMappingsImportMapRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportMappingsImportMapRequest Class
ExportMappingsImportMapRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportMappingsImportMapRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExportMappingsImportMapRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExportMappingsImportMapResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Create Data Maps
Add Transformation Mapping
Sample: Export and Import a Data Map
The Security Model of Microsoft Dynamics CRM


ExportMappingsImportMapRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExportIds | Gets or sets a value that indicates whether to export the entity record IDs contained in the data map. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportMapId | Gets or sets the ID of the import map (data map) to export. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ExportMappingsImportMapRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ExportMappingsImportMapResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Create Data Maps
Add Transformation Mapping
Sample: Export and Import a Data Map
The Security Model of Microsoft Dynamics CRM


ExportMappingsImportMapRequest.ExportIds Property
[image]

Gets or sets a value that indicates whether to export the entity record IDs contained in the data map. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportIds As Boolean

C#
public bool ExportIds { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to export the entity record IDs contained in the data map.
true to export the record IDs, otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportMappingsImportMapRequest Class
ExportMappingsImportMapRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportMappingsImportMapRequest.ImportMapId Property
[image]

Gets or sets the ID of the import map (data map) to export. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportMapId As Guid

C#
public Guid ImportMapId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the import map (data map) to export. This corresponds to the ImportMap.ImportMapId attribute, which is the primary key for the ImportMap entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportMappingsImportMapRequest Class
ExportMappingsImportMapRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportMappingsImportMapResponse Class
See Also Members
[image]

Contains the response from the ExportMappingsImportMapRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExportMappingsImportMapResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExportMappingsImportMapResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ExportMappingsImportMapResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportMappingsImportMapResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ExportMappingsImportMapRequest


ExportMappingsImportMapResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExportMappingsImportMapRequest class.

The following tables list the members exposed by the ExportMappingsImportMapResponse type.

Public Constructors

Name | Description
ExportMappingsImportMapResponse | Initializes a new instance of the ExportMappingsImportMapResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | MappingsXml | Gets the XML representation of the exported data map.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExportMappingsImportMapResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportMappingsImportMapRequest


ExportMappingsImportMapResponse Constructor
[image]

Initializes a new instance of the ExportMappingsImportMapResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExportMappingsImportMapResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportMappingsImportMapResponse Class
ExportMappingsImportMapResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExportMappingsImportMapResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExportMappingsImportMapResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportMappingsImportMapRequest


ExportMappingsImportMapResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | MappingsXml | Gets the XML representation of the exported data map.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ExportMappingsImportMapResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportMappingsImportMapRequest


ExportMappingsImportMapResponse.MappingsXml Property
[image]

Gets the XML representation of the exported data map.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property MappingsXml As String

C#
public string MappingsXml { get; }

C++

J#

JScript

Property Value
Type: String
The XML representation of the exported data map.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportMappingsImportMapResponse Class
ExportMappingsImportMapResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest Class
See Also Example Members
[image]

Contains the data that’s needed to export a solution.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExportSolutionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExportSolutionRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Export or package a solution
//Export an a solution

ExportSolutionRequest exportSolutionRequest = new ExportSolutionRequest();
exportSolutionRequest.Managed = false;
exportSolutionRequest.SolutionName = solution.UniqueName;

ExportSolutionResponse exportSolutionResponse = (ExportSolutionResponse)_serviceProxy.Execute(exportSolutionRequest);

byte[] exportXml = exportSolutionResponse.ExportSolutionFile;
string filename = solution.UniqueName + ".zip";
File.WriteAllBytes(outputDir + filename, exportXml);

Console.WriteLine("Solution exported to {0}.", outputDir + filename);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of ExportSolutionResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges listed in ExportSolution Privileges.
Notes for Callers
The properties of this request correspond to the options in the export solution dialog box in the application. The following table describes the settings included with each of the Export* settings.
Member | Setting | Display Name | Description
ExportAutoNumberingSettings | Organization.CampaignPrefix | Campaign Prefix | Prefix used for campaign numbering.
 | Organization.CasePrefix | Case Prefix | Prefix to use for all cases throughout Microsoft Dynamics CRM.
 | Organization.ContractPrefix | Contract Prefix | Prefix to use for all contracts throughout Microsoft Dynamics CRM.
 | Organization.InvoicePrefix | Invoice Prefix | Prefix to use for all invoice numbers throughout Microsoft Dynamics CRM.
 | Organization.KbPrefix | Article Prefix | Prefix to use for all articles in Microsoft Dynamics CRM.
 | Organization. OrderPrefix | Order Prefix | Prefix to use for all orders throughout Microsoft Dynamics CRM.
 | Organization.UniqueSpecifierLength | Unique String Length | Number of characters appended to invoice, quote, and order numbers.
ExportCalendarSettings | Organization.CalendarType | Calendar Type | Calendar type for the system. Set to Gregorian US by default.
 | Organization.DateFormatCode | Date Format Code | Information about how the date is displayed throughout Microsoft Dynamics CRM.
 | Organization.DateSeparator | Date Separator | Character used to separate the month, the day, and the year in dates throughout Microsoft Dynamics CRM.
 | Organization.MaxAppointmentDurationDays | Max Appointment Duration | Maximum number of days an appointment can last.
 | Organization.ShowWeekNumber | Show Week Number | Information that specifies whether to display the week number in calendar displays throughout Microsoft CRM.
 | Organization.TimeFormatCode | Time Format Code | Information that specifies how the time is displayed throughout Microsoft CRM.
 | Organization.WeekStartDayCode | Week Start Day Code | Designated first day of the week throughout Microsoft Dynamics CRM.
ExportCustomizationSettings | Organization.IsAppMode | Is Application Mode Enabled | Indicates whether loading of Microsoft Dynamics CRM in a browser window that does not have address, tool, and menu bars is enabled.
ExportEmailTrackingSettings | Organization.AllowUnresolvedPartiesOnEmailSend | Allow Unresolved Address E-mail Send | Indicates whether users are allowed to send e-mail to unresolved parties (parties must still have an e-mail address).
 | Organization.IgnoreInternalEmail | Ignore Internal E-mail | Indicates whether incoming e-mail sent by internal Microsoft Dynamics CRM users or queues should be tracked.
 | Organization.MaximumTrackingNumber | Max Tracking Number | Maximum tracking number before recycling takes place.
 | Organization.RenderSecureIFrameForEmail | Render Secure Frame For E-mail | Flag to render the body of e-mail in the Web form in an IFRAME with the security='restricted' attribute set. This is additional security but can cause a credentials prompt.
 | Organization.TrackingPrefix | Tracking Prefix | History list of tracking token prefixes.
 | Organization.TrackingTokenIdBase | Tracking Token Base | Base number used to provide separate tracking token identifiers to users belonging to different deployments.
 | Organization.TrackingTokenIdDigits | Tracking Token Digits | Number of digits used to represent a tracking token identifier.
ExportGeneralSettings | Organization.BlockedAttachments | Block Attachments | Prevent upload or download of certain attachment types that are considered dangerous.
 | Organization.CurrencyFormatCode | Currency Format Code | Information about how currency symbols are placed throughout Microsoft Dynamics CRM.
 | Organization.CurrencySymbol | Currency Symbol | Currency Symbol
 | Organization.FullNameConventionCode | Full Name Display Order | Order in which names are to be displayed throughout Microsoft CRM.
 | Organization.GetStartedPaneContentEnabled | Is Get Started Pane Content Enabled | Indicates whether Get Started content is enabled for this organization.
 | Organization.IsPresenceEnabled | Presence Enabled | Information on whether IM presence is enabled.
 | Organization.NegativeFormatCode | Negative Format | Information that specifies how negative numbers are displayed throughout Microsoft CRM.
 | Organization.NumberFormat | Number Format | Specification of how numbers are displayed throughout Microsoft CRM.
 | Organization.PricingDecimalPrecision | Pricing Decimal Precision | Number of decimal places that can be used for prices.
 | Organization.ShareToPreviousOwnerOnAssign | Share To Previous Owner On Assign | Information that specifies whether to share to previous owner on assign.
 | Organization.IsAutoSaveEnabled | Auto Save Enabled | Information on whether auto save is enabled.
 | Organization.GlobalHelpUrl | Global Help URL | URL for the web page global help.
 | Organization.GlobalHelpUrlEnabled | Is Customizable Global Help enabled | Indicates whether the customizable global help is enabled.
 | Organization.GlobalAppendUrlParametersEnabled | Is AppendUrl Parameters enabled | Indicates whether the append URL parameters is enabled.
 | Organization.MobileClientMashupEnabled | Is Mobile Client Mashup enabled | Indicates whether the mobile client mashup is enabled.
ExportIsvConfig | The XML representing the ISV.Config.
ExportMarketingSettings | Organization.AllowAutoResponseCreation | Allow Automatic Response Creation | Indicates whether automatic response creation is allowed.
 | Organization.AllowAutoUnsubscribe | Allow Automatic Unsubscribe | Indicates whether automatic unsubscribe is allowed.
 | Organization.AllowAutoUnsubscribeAcknowledgement | Allow Automatic Unsubscribe Acknowledgement | Indicates whether automatic unsubscribe acknowledgement e-mail is allowed to send.
 | Organization.AllowMarketingEmailExecution | Allow Marketing E-mail Execution | Indicates whether marketing e-mails execution is allowed.
ExportOutlookSynchronizationSettings | Organization.AllowAddressBookSyncs | Allow Address Book Synchronization | Indicates whether background address book synchronization in Microsoft Office Outlook is allowed.
 | Organization.AllowOfflineScheduledSyncs | Allow Offline Scheduled Synchronization | Indicates whether background offline synchronization in Microsoft Office Outlook is allowed.
 | Organization.AllowOutlookScheduledSyncs | Allow Scheduled Synchronization | Indicates whether scheduled synchronizations to Outlook are allowed.
 | Organization.EmailSendPollingPeriod | E-mail Send Polling Frequency | Normal polling frequency used for sending e-mail in Microsoft Office Outlook.
 | Organization.MinAddressBookSyncInterval | Min Address Synchronization Frequency | Normal polling frequency used for address book synchronization in Microsoft Office Outlook.
 | Organization.MinOfflineSyncInterval | Min Offline Synchronization Frequency | Normal polling frequency used for background offline synchronization in Microsoft Office Outlook.
 | Organization.MinOutlookSyncInterval | Min Synchronization Frequency | Minimum allowed time between scheduled Outlook synchronizations.
 | Organization.TagMaxAggressiveCycles | Auto-Tag Max Cycles | Maximum number of aggressive polling cycles executed for e-mail auto-tagging when a new e-mail is received.
 | Organization.TagPollingPeriod | Auto-Tag Interval | Normal polling frequency used for e-mail receive auto-tagging in outlook.
ExportSales | Organization.UseInbuiltRuleForDefaultPricelistSelection | Use Inbuilt Rule For Default Pricelist Selection | Flag indicates whether to Use Inbuilt Rule For DefaultPricelist.
 | Organization.MaxProductsInBundle | Bundle Item Limit | Restrict the maximum no of items in a bundle
 | Organization.OOBPriceCalculationEnabled | Enable OOB Price calculation | Enable OOB pricing calculation logic for Opportunity, Quote, Order and Invoice entities.
 | Organization.DiscountCalculationMethod | Discount calculation method | Discount calculation method for the QOOI product.
 | Organization.MaximumDynamicPropertiesAllowed | Product Properties Item Limit | Restrict the maximum number of product properties for a product family/bundle
 | Organization.CreateProductsWithoutParentInActiveState | Enable Active Initial Product State | Enable Initial state of newly created products to be Active instead of Draft

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ExportSolutionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


ExportSolutionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that’s needed to export a solution.

The following tables list the members exposed by the ExportSolutionRequest type.

Public Constructors

Name | Description
ExportSolutionRequest | Initializes a new instance of the ExportSolutionRequest class
Top

Public Properties

 | Name | Description
public property | ExportAutoNumberingSettings | Gets or sets whether auto numbering settings should be included in the solution being exported. Optional.
public property | ExportCalendarSettings | Gets or sets whether calendar settings should be included in the solution being exported. Optional.
public property | ExportCustomizationSettings | Gets or sets whether customization settings should be included in the solution being exported. Optional.
public property | ExportEmailTrackingSettings | Gets or sets whether email tracking settings should be included in the solution being exported. Optional.
public property | ExportGeneralSettings | Gets or sets whether general settings should be included in the solution being exported. Optional.
public property | ExportIsvConfig | Gets or sets whether ISV.Config settings should be included in the solution being exported. Optional.
public property | ExportMarketingSettings | Gets or sets whether marketing settings should be included in the solution being exported. Optional.
public property | ExportOutlookSynchronizationSettings | Gets or sets whether outlook synchronization settings should be included in the solution being exported. Optional.
public property | ExportRelationshipRoles | Gets or sets whether relationship role settings should be included in the solution being exported. Optional.
public property | ExportSales | Gets or sets whether sales settings should be included in the solution being exported. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Managed | Gets or sets whether the solution should be exported as a managed solution. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionName | Gets or sets the unique name of the solution to be exported. Required.
public property | TargetVersion | Get or set a value indicating the version that the exported solution will support.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExportSolutionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


ExportSolutionRequest Constructor
[image]

Initializes a new instance of the ExportSolutionRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExportSolutionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExportSolutionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


ExportSolutionRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExportAutoNumberingSettings | Gets or sets whether auto numbering settings should be included in the solution being exported. Optional.
public property | ExportCalendarSettings | Gets or sets whether calendar settings should be included in the solution being exported. Optional.
public property | ExportCustomizationSettings | Gets or sets whether customization settings should be included in the solution being exported. Optional.
public property | ExportEmailTrackingSettings | Gets or sets whether email tracking settings should be included in the solution being exported. Optional.
public property | ExportGeneralSettings | Gets or sets whether general settings should be included in the solution being exported. Optional.
public property | ExportIsvConfig | Gets or sets whether ISV.Config settings should be included in the solution being exported. Optional.
public property | ExportMarketingSettings | Gets or sets whether marketing settings should be included in the solution being exported. Optional.
public property | ExportOutlookSynchronizationSettings | Gets or sets whether outlook synchronization settings should be included in the solution being exported. Optional.
public property | ExportRelationshipRoles | Gets or sets whether relationship role settings should be included in the solution being exported. Optional.
public property | ExportSales | Gets or sets whether sales settings should be included in the solution being exported. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Managed | Gets or sets whether the solution should be exported as a managed solution. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionName | Gets or sets the unique name of the solution to be exported. Required.
public property | TargetVersion | Get or set a value indicating the version that the exported solution will support.

See Also

Reference

ExportSolutionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


ExportSolutionRequest.ExportAutoNumberingSettings Property
[image]

Gets or sets whether auto numbering settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportAutoNumberingSettings As Boolean

C#
public bool ExportAutoNumberingSettings { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the auto numbering settings should be included in the solution being exported; otherwise, false.

  Remarks
This setting includes the following values with the solution:
  • Organization.CampaignPrefix
  • Organization.ContractPrefix
  • Organization.CasePrefix
  • Organization.KbPrefix
  • Organization.OrderPrefix
  • Organization.InvoicePrefix
  • Organization.UniqueSpecifierLength

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.ExportCalendarSettings Property
[image]

Gets or sets whether calendar settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportCalendarSettings As Boolean

C#
public bool ExportCalendarSettings { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the calendar settings should be included in the solution being exported; otherwise, false.

  Remarks
This setting includes the following values with the solution:
  • Organization.WeekStartDayCode
  • Organization.CalendarType
  • Organization.DateFormatCode
  • Organization.DateSeparator
  • Organization.TimeFormatCode
  • Organization.ShowWeekNumber
  • Organization.MaxAppointmentDurationDays

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.ExportCustomizationSettings Property
[image]

Gets or sets whether customization settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportCustomizationSettings As Boolean

C#
public bool ExportCustomizationSettings { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the customization settings should be included in the solution being exported; otherwise, false.

  Remarks
This setting includes the following values with the solution:
  • Organization.IsAppMode

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.ExportEmailTrackingSettings Property
[image]

Gets or sets whether email tracking settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportEmailTrackingSettings As Boolean

C#
public bool ExportEmailTrackingSettings { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the email tracking settings should be included in the solution being exported; otherwise, false.

  Remarks
This setting includes the following values with the solution:
  • Organization.TrackingPrefix
  • Organization.TrackingTokenIdBase
  • Organization.TrackingTokenIdDigits
  • Organization.MaximumTrackingNumber
  • Organization.IgnoreInternalEmail
  • Organization.RenderSecureIFrameForEmail
  • Organization.AllowUnresolvedPartiesOnEmailSend

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.ExportGeneralSettings Property
[image]

Gets or sets whether general settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportGeneralSettings As Boolean

C#
public bool ExportGeneralSettings { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the general settings should be included in the solution being exported; otherwise, false.

  Remarks
This setting includes the following values with the solution:
  • Organization.FullNameConventionCode
  • Organization.NumberFormat
  • Organization.NegativeFormatCode
  • Organization.CurrencySymbol
  • Organization.CurrencyFormatCode
  • Organization.PricingDecimalPrecision
  • Organization.ShareToPreviousOwnerOnAssign
  • Organization.BlockedAttachments
  • Organization.GetStartedPaneContentEnabled
  • Organization.IsPresenceEnabled
  • Organization.IsAutoSaveEnabled
  • Organization.GlobalHelpUrl
  • Organization.GlobalHelpUrlEnabled
  • Organization.GlobalAppendUrlParametersEnabled
  • Organization.MobileClientMashupEnabled

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.ExportIsvConfig Property
[image]

Gets or sets whether ISV.Config settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportIsvConfig As Boolean

C#
public bool ExportIsvConfig { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the ISV.Config settings should be included in the solution being exported; otherwise, false.

  Remarks
This setting includes the following values with the solution:
  • The XML representing the ISV.Config.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.ExportMarketingSettings Property
[image]

Gets or sets whether marketing settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportMarketingSettings As Boolean

C#
public bool ExportMarketingSettings { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the marketing settings should be included in the solution being exported; otherwise, false.

  Remarks
This setting includes the following values with the solution:
  • Organization.AllowMarketingEmailExecution
  • Organization.AllowAutoResponseCreation
  • Organization.AllowAutoUnsubscribe
  • Organization.AllowAutoUnsubscribeAcknowledgement

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.ExportOutlookSynchronizationSettings Property
[image]

Gets or sets whether outlook synchronization settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportOutlookSynchronizationSettings As Boolean

C#
public bool ExportOutlookSynchronizationSettings { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the outlook synchronization settings should be included in the solution being exported; otherwise, false.

  Remarks
This setting includes the following values with the solution:
  • Organization.TagPollingPeriod
  • Organization.TagMaxAggressiveCycles
  • Organization.AllowOutlookScheduledSyncs
  • Organization.MinOutlookSyncInterval
  • Organization.EmailSendPollingPeriod
  • Organization.AllowOfflineScheduledSyncs
  • Organization.MinOfflineSyncInterval
  • Organization.AllowAddressBookSyncs
  • Organization.MinAddressBookSyncInterval

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.ExportRelationshipRoles Property
[image]

Gets or sets whether relationship role settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportRelationshipRoles As Boolean

C#
public bool ExportRelationshipRoles { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the relationship role settings should be included in the solution being exported; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.ExportSales Property
[image]

Gets or sets whether sales settings should be included in the solution being exported. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExportSales As Boolean

C#
public bool ExportSales { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the sales settings should be included in the solution being exported; otherwise, false.

  Remarks
This setting includes the following values with the solution:
  • Organization.UseInbuiltRuleForDefaultPricelistSelection
  • Organization.MaxProductsInBundle
  • Organization.OOBPriceCalculationEnabled
  • Organization.DiscountCalculationMethod
  • Organization.MaximumDynamicPropertiesAllowed
  • Organization.CreateProductsWithoutParentInActiveState

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.Managed Property
[image]

Gets or sets whether the solution should be exported as a managed solution. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Managed As Boolean

C#
public bool Managed { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the solution should be exported as a managed solution; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.SolutionName Property
[image]

Gets or sets the unique name of the solution to be exported. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionName As String

C#
public string SolutionName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name of the solution to be exported. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionRequest.TargetVersion Property
[image]

Get or set a value indicating the version that the exported solution will support.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TargetVersion As String

C#
public string TargetVersion { get; set; }

C++

J#

JScript

Property Value
Type: String
A value indicating the version that the exported solution will support. Optional.

  Remarks
Until updates to Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Updateare released, there is only one valid value for this property.
Valid values are:
Value | Version
7.0.0.0 | Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionRequest Class
ExportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionResponse Class
See Also Members
[image]

Contains the response from the ExportSolutionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExportSolutionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExportSolutionResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ExportSolutionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ExportSolutionRequest


ExportSolutionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExportSolutionRequest class.

The following tables list the members exposed by the ExportSolutionResponse type.

Public Constructors

Name | Description
ExportSolutionResponse | Initializes a new instance of the ExportSolutionResponse class.
Top

Public Properties

 | Name | Description
public property | ExportSolutionFile | Gets the compressed file that represents the exported solution.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExportSolutionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportSolutionRequest


ExportSolutionResponse Constructor
[image]

Initializes a new instance of the ExportSolutionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExportSolutionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionResponse Class
ExportSolutionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExportSolutionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExportSolutionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportSolutionRequest


ExportSolutionResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExportSolutionFile | Gets the compressed file that represents the exported solution.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ExportSolutionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportSolutionRequest


ExportSolutionResponse.ExportSolutionFile Property
[image]

Gets the compressed file that represents the exported solution.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ExportSolutionFile As Byte()

C#
public byte[] ExportSolutionFile { get; }

C++

J#

JScript

Property Value
Type: Byte[]
 The compressed file that represents the exported solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportSolutionResponse Class
ExportSolutionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExportTranslationRequest Class
See Also Members
[image]

Contains the data that is needed to export all translations for a specific solution to a compressed file.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExportTranslationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExportTranslationRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  ExportTranslationResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in ExportTranslation Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ExportTranslationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages


ExportTranslationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to export all translations for a specific solution to a compressed file.

The following tables list the members exposed by the ExportTranslationRequest type.

Public Constructors

Name | Description
ExportTranslationRequest | Initializes a new instance of the ExportTranslationRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionName | Gets or sets the unique name for the unmanaged solution to export translations for. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExportTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


ExportTranslationRequest Constructor
[image]

Initializes a new instance of the ExportTranslationRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExportTranslationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportTranslationRequest Class
ExportTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportTranslationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExportTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


ExportTranslationRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionName | Gets or sets the unique name for the unmanaged solution to export translations for. Required.

See Also

Reference

ExportTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


ExportTranslationRequest.SolutionName Property
[image]

Gets or sets the unique name for the unmanaged solution to export translations for. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionName As String

C#
public string SolutionName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name for the unmanaged solution to export translations for. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportTranslationRequest Class
ExportTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ExportTranslationResponse Class
See Also Members
[image]

Contains the response from the ExportTranslationRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ExportTranslationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ExportTranslationResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ExportTranslationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ExportTranslationRequest


ExportTranslationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExportTranslationRequest class.

The following tables list the members exposed by the ExportTranslationResponse type.

Public Constructors

Name | Description
ExportTranslationResponse | Initializes a new instance of the ExportTranslationResponse class
Top

Public Properties

 | Name | Description
public property | ExportTranslationFile | Gets the file that represents the data that is exported for translation.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExportTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportTranslationRequest


ExportTranslationResponse Constructor
[image]

Initializes a new instance of the ExportTranslationResponse class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExportTranslationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportTranslationResponse Class
ExportTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ExportTranslationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExportTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportTranslationRequest


ExportTranslationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExportTranslationFile | Gets the file that represents the data that is exported for translation.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ExportTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ExportTranslationRequest


ExportTranslationResponse.ExportTranslationFile Property
[image]

Gets the file that represents the data that is exported for translation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ExportTranslationFile As Byte()

C#
public byte[] ExportTranslationFile { get; }

C++

J#

JScript

Property Value
Type: Byte[]
The file that represents the data that is exported for translation.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExportTranslationResponse Class
ExportTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


FetchXmlToQueryExpressionRequest Class
See Also Example Members
[image]

Contains the data that is needed to convert a query in FetchXML to a QueryExpression.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class FetchXmlToQueryExpressionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class FetchXmlToQueryExpressionRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create a Fetch query that we will convert into a query expression.
var fetchXml =
    @"<fetch mapping='logical' version='1.0'>
     <entity name='opportunity'>
      <attribute name='name' />
      <filter>
       <condition attribute='estimatedclosedate' operator='next-x-fiscal-years' value='3' />
      </filter>
      <link-entity name='account' from='accountid' to='customerid'>
       <link-entity name='contact' from='parentcustomerid' to='accountid'>
        <attribute name='fullname' />
        <filter>
         <condition attribute='address1_city' operator='eq' value='Bellevue' />
         <condition attribute='address1_stateorprovince' operator='eq' value='WA' />
        </filter>
       </link-entity>
      </link-entity>
     </entity>
    </fetch>";

// Run the query with the FetchXML.
var fetchExpression = new FetchExpression(fetchXml);
EntityCollection fetchResult =
    _serviceProxy.RetrieveMultiple(fetchExpression);
Console.WriteLine("\nOutput for query as FetchXML:");
DisplayOpportunityQueryResults(fetchResult);

// Convert the FetchXML into a query expression.
var conversionRequest = new FetchXmlToQueryExpressionRequest
{
    FetchXml = fetchXml
};

var conversionResponse =
    (FetchXmlToQueryExpressionResponse)_serviceProxy.Execute(conversionRequest);

// Use the newly converted query expression to make a retrieve multiple
// request to Microsoft Dynamics CRM.
QueryExpression queryExpression = conversionResponse.Query;

EntityCollection result = _serviceProxy.RetrieveMultiple(queryExpression);

// Display the results.
Console.WriteLine("\nOutput for query after conversion to QueryExpression:");
DisplayOpportunityQueryResults(result);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  FetchXmlToQueryExpressionResponse.
Privileges and Access Rights
For a complete list of the required privileges, see FetchXmlToQueryExpression Privileges.
Notes for Callers
The use of the keyword Distinct in query expressions is different from the FetchXML query language. When mapping a query from Fetch to QueryExpression, results will not be consistent if the Distinct keyword is used in the FetchXML string.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.FetchXmlToQueryExpressionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
FetchXmlToQueryExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
FetchXmlToQueryExpressionResponse
Other Resources
Create Queries to Retrieve Data
FetchXML Schema
Sample: Convert Queries Between Fetch and Query Expression


FetchXmlToQueryExpressionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to convert a query in FetchXML to a QueryExpression.

The following tables list the members exposed by the FetchXmlToQueryExpressionRequest type.

Public Constructors

Name | Description
FetchXmlToQueryExpressionRequest | Initializes a new instance of the FetchXmlToQueryExpressionRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FetchXml | Gets or sets the query to convert.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

FetchXmlToQueryExpressionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
FetchXmlToQueryExpressionResponse

Other Resources

Create Queries to Retrieve Data
FetchXML Schema
Sample: Convert Queries Between Fetch and Query Expression


FetchXmlToQueryExpressionRequest Constructor
[image]

Initializes a new instance of the FetchXmlToQueryExpressionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public FetchXmlToQueryExpressionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FetchXmlToQueryExpressionRequest Class
FetchXmlToQueryExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


FetchXmlToQueryExpressionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

FetchXmlToQueryExpressionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
FetchXmlToQueryExpressionResponse

Other Resources

Create Queries to Retrieve Data
FetchXML Schema
Sample: Convert Queries Between Fetch and Query Expression


FetchXmlToQueryExpressionRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FetchXml | Gets or sets the query to convert.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

FetchXmlToQueryExpressionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
FetchXmlToQueryExpressionResponse

Other Resources

Create Queries to Retrieve Data
FetchXML Schema
Sample: Convert Queries Between Fetch and Query Expression


FetchXmlToQueryExpressionRequest.FetchXml Property
[image]

Gets or sets the query to convert.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FetchXml As String

C#
public string FetchXml { get; set; }

C++

J#

JScript

Property Value
Type: String
The query to convert. This The string must contain a query that you express in FetchXML. For more information, see FetchXML Schema.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FetchXmlToQueryExpressionRequest Class
FetchXmlToQueryExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


FetchXmlToQueryExpressionResponse Class
See Also Members
[image]

Contains the response from the FetchXmlToQueryExpressionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class FetchXmlToQueryExpressionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class FetchXmlToQueryExpressionResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.FetchXmlToQueryExpressionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FetchXmlToQueryExpressionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
FetchXmlToQueryExpressionRequest


FetchXmlToQueryExpressionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the FetchXmlToQueryExpressionRequest class.

The following tables list the members exposed by the FetchXmlToQueryExpressionResponse type.

Public Constructors

Name | Description
FetchXmlToQueryExpressionResponse | Initializes a new instance of the FetchXmlToQueryExpressionResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Query | Gets the results of the query conversion.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

FetchXmlToQueryExpressionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
FetchXmlToQueryExpressionRequest


FetchXmlToQueryExpressionResponse Constructor
[image]

Initializes a new instance of the FetchXmlToQueryExpressionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public FetchXmlToQueryExpressionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FetchXmlToQueryExpressionResponse Class
FetchXmlToQueryExpressionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


FetchXmlToQueryExpressionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

FetchXmlToQueryExpressionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
FetchXmlToQueryExpressionRequest


FetchXmlToQueryExpressionResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Query | Gets the results of the query conversion.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

FetchXmlToQueryExpressionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
FetchXmlToQueryExpressionRequest


FetchXmlToQueryExpressionResponse.Query Property
[image]

Gets the results of the query conversion.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Query As QueryExpression

C#
public QueryExpression Query { get; }

C++

J#

JScript

Property Value
Type: QueryExpression
The results of the query conversion.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FetchXmlToQueryExpressionResponse Class
FetchXmlToQueryExpressionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


FindParentResourceGroupRequest Class
See Also Members
[image]

Contains the data that is needed to find a parent resource group (scheduling group) for the specified resource groups (scheduling groups).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class FindParentResourceGroupRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class FindParentResourceGroupRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of FindParentResourceGroupResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the ResourceGroup entity and access rights on the records specified in the ParentId and ChildrenIds properties. For a complete list of the privileges required, see FindParentResourceGroup Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.FindParentResourceGroupRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FindParentResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace
FindParentResourceGroupResponse
Other Resources
Resource Entities
ResourceGroup (Scheduling  Group) Entity Messages and Methods


FindParentResourceGroupRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to find a parent resource group (scheduling group) for the specified resource groups (scheduling groups).

The following tables list the members exposed by the FindParentResourceGroupRequest type.

Public Constructors

Name | Description
FindParentResourceGroupRequest | Initializes a new instance of the FindParentResourceGroupRequest class.
Top

Public Properties

 | Name | Description
public property | ChildrenIds | Gets or sets an array of IDs of the children resource groups.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentId | Gets or sets the ID of the parent resource group.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

FindParentResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
FindParentResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


FindParentResourceGroupRequest Constructor
[image]

Initializes a new instance of the FindParentResourceGroupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public FindParentResourceGroupRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FindParentResourceGroupRequest Class
FindParentResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


FindParentResourceGroupRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

FindParentResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
FindParentResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


FindParentResourceGroupRequest Properties
[image]

Public Properties

 | Name | Description
public property | ChildrenIds | Gets or sets an array of IDs of the children resource groups.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentId | Gets or sets the ID of the parent resource group.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

FindParentResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
FindParentResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


FindParentResourceGroupRequest.ChildrenIds Property
[image]

Gets or sets an array of IDs of the children resource groups.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ChildrenIds As Guid()

C#
public Guid[] ChildrenIds { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]
The array of IDs of the children resource groups.

  Remarks
Each element of the ChildrenIds array corresponds to the  ResourceGroup.ResourceGroupId attribute, which is the primary key for the ResourceGroup entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FindParentResourceGroupRequest Class
FindParentResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


FindParentResourceGroupRequest.ParentId Property
[image]

Gets or sets the ID of the parent resource group.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ParentId As Guid

C#
public Guid ParentId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the parent resource group. This corresponds to the ResourceGroup.ResourceGroupId attribute, which is the primary key for the ResourceGroup entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FindParentResourceGroupRequest Class
FindParentResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


FindParentResourceGroupResponse Class
See Also Members
[image]

Contains the response from the FindParentResourceGroupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class FindParentResourceGroupResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class FindParentResourceGroupResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.FindParentResourceGroupResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FindParentResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace
FindParentResourceGroupRequest


FindParentResourceGroupResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the FindParentResourceGroupRequest class.

The following tables list the members exposed by the FindParentResourceGroupResponse type.

Public Constructors

Name | Description
FindParentResourceGroupResponse | Initializes a new instance of the FindParentResourceGroupResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | result | Gets a value that indicates whether the parent resource group was found.
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

FindParentResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
FindParentResourceGroupRequest


FindParentResourceGroupResponse Constructor
[image]

Initializes a new instance of the FindParentResourceGroupResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public FindParentResourceGroupResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FindParentResourceGroupResponse Class
FindParentResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace


FindParentResourceGroupResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

FindParentResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
FindParentResourceGroupRequest


FindParentResourceGroupResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | result | Gets a value that indicates whether the parent resource group was found.
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

FindParentResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
FindParentResourceGroupRequest


FindParentResourceGroupResponse.result Property
[image]

Gets a value that indicates whether the parent resource group was found.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property result As Boolean

C#
public bool result { get; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether the parent resource group was found.
true if the parent resource group was found; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FindParentResourceGroupResponse Class
FindParentResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace


FulfillSalesOrderRequest Class
See Also Example Members
[image]

Contains the data that is needed to fulfill the sales order (order).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class FulfillSalesOrderRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class FulfillSalesOrderRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Close the sales order with a status of Complete
int newStatus = (int)salesorder_statuscode.Complete;
var request = new FulfillSalesOrderRequest
{
    OrderClose = new OrderClose
    {
        SalesOrderId = new EntityReference
            { LogicalName = SalesOrder.EntityLogicalName, Id = _salesOrderId.Value }

    },
    Status = new OptionSetValue(newStatus)
};

Console.WriteLine(String.Concat("Executing FullfillSalesOrderRequest on sales order: ",
    _salesOrderId.Value, ",\n\t new status: ",
    GetLabelForStatus(SalesOrder.EntityLogicalName, "statuscode", newStatus)));

_serviceProxy.Execute(request);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of FulfillSalesOrderResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the OrderClose entity and access rights on the records specified in the OrderClose property. For a complete list of required privileges, see FulfillSalesOrder Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.FulfillSalesOrderRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
FulfillSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace
FulfillSalesOrderResponse
Other Resources
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
FulfillSalesOrder Privileges
Sample: Fulfill a Sales Order
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


FulfillSalesOrderRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to fulfill the sales order (order).

The following tables list the members exposed by the FulfillSalesOrderRequest type.

Public Constructors

Name | Description
FulfillSalesOrderRequest | Initializes a new instance of the FulfillSalesOrderRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OrderClose | Gets or sets the order close activity associated with the sales order (order) to be fulfilled. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a status of the sales order (order). Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

FulfillSalesOrderRequest Class
Microsoft.Crm.Sdk.Messages Namespace
FulfillSalesOrderResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
FulfillSalesOrder Privileges
Sample: Fulfill a Sales Order
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


FulfillSalesOrderRequest Constructor
[image]

Initializes a new instance of the FulfillSalesOrderRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public FulfillSalesOrderRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FulfillSalesOrderRequest Class
FulfillSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace


FulfillSalesOrderRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

FulfillSalesOrderRequest Class
Microsoft.Crm.Sdk.Messages Namespace
FulfillSalesOrderResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
FulfillSalesOrder Privileges
Sample: Fulfill a Sales Order
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


FulfillSalesOrderRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OrderClose | Gets or sets the order close activity associated with the sales order (order) to be fulfilled. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a status of the sales order (order). Required.

See Also

Reference

FulfillSalesOrderRequest Class
Microsoft.Crm.Sdk.Messages Namespace
FulfillSalesOrderResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
FulfillSalesOrder Privileges
Sample: Fulfill a Sales Order
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


FulfillSalesOrderRequest.OrderClose Property
[image]

Gets or sets the order close activity associated with the sales order (order) to be fulfilled. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OrderClose As Entity

C#
public Entity OrderClose { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The order close activity associated with the sales order (order) to be fulfilled, which must be an instance of the OrderClose class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FulfillSalesOrderRequest Class
FulfillSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace


FulfillSalesOrderRequest.Status Property
[image]

Gets or sets a status of the sales order (order). Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The status of the sales order (order).

  Remarks
The Status property corresponds to the SalesOrder.StatusCode attribute. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system will set the appropriate corresponding status value. For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FulfillSalesOrderRequest Class
FulfillSalesOrderRequest Members
Microsoft.Crm.Sdk.Messages Namespace


FulfillSalesOrderResponse Class
See Also Members
[image]

Contains the response from the FulfillSalesOrderRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class FulfillSalesOrderResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class FulfillSalesOrderResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.FulfillSalesOrderResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FulfillSalesOrderResponse Members
Microsoft.Crm.Sdk.Messages Namespace
FulfillSalesOrderRequest


FulfillSalesOrderResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the FulfillSalesOrderRequest class.

The following tables list the members exposed by the FulfillSalesOrderResponse type.

Public Constructors

Name | Description
FulfillSalesOrderResponse | Initializes a new instance of the FulfillSalesOrderResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

FulfillSalesOrderResponse Class
Microsoft.Crm.Sdk.Messages Namespace
FulfillSalesOrderRequest


FulfillSalesOrderResponse Constructor
[image]

Initializes a new instance of the FulfillSalesOrderResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public FulfillSalesOrderResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FulfillSalesOrderResponse Class
FulfillSalesOrderResponse Members
Microsoft.Crm.Sdk.Messages Namespace


FulfillSalesOrderResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

FulfillSalesOrderResponse Class
Microsoft.Crm.Sdk.Messages Namespace
FulfillSalesOrderRequest


FulfillSalesOrderResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

FulfillSalesOrderResponse Class
Microsoft.Crm.Sdk.Messages Namespace
FulfillSalesOrderRequest


GenerateInvoiceFromOpportunityRequest Class
See Also Members
[image]

Contains the data that is needed to generate an invoice from an opportunity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GenerateInvoiceFromOpportunityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GenerateInvoiceFromOpportunityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the GenerateInvoiceFromOpportunityResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Opportunity entity and access rights to the specified record in the OpportunityId property.
For a complete list of the required privileges, see GenerateInvoiceFromOpportunity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GenerateInvoiceFromOpportunityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateInvoiceFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityResponse
Other Resources
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
GenerateInvoiceFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateInvoiceFromOpportunityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to generate an invoice from an opportunity.

The following tables list the members exposed by the GenerateInvoiceFromOpportunityRequest type.

Public Constructors

Name | Description
GenerateInvoiceFromOpportunityRequest | Initializes a new instance of the GenerateInvoiceFromOpportunityRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve from the resulting invoice. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity to be used as the basis for the new invoice. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GenerateInvoiceFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
GenerateInvoiceFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateInvoiceFromOpportunityRequest Constructor
[image]

Initializes a new instance of the GenerateInvoiceFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GenerateInvoiceFromOpportunityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateInvoiceFromOpportunityRequest Class
GenerateInvoiceFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateInvoiceFromOpportunityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GenerateInvoiceFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
GenerateInvoiceFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateInvoiceFromOpportunityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve from the resulting invoice. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity to be used as the basis for the new invoice. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GenerateInvoiceFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
GenerateInvoiceFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateInvoiceFromOpportunityRequest.ColumnSet Property
[image]

Gets or sets the collection of attributes to retrieve from the resulting invoice. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The collection of attributes to retrieve from the resulting invoice.

  Remarks
Assign null to this property to retrieve only the primary key. The non-null values are returned for the specified attributes in the column set. The attributes that are not included in the column set contain null values. If the column set includes attributes where IsValidForRead is false, they are ignored, and the message response contains no data for those attributes. You can find this information in the metadata for your organization. See the preceding metadata browser information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateInvoiceFromOpportunityRequest Class
GenerateInvoiceFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateInvoiceFromOpportunityRequest.OpportunityId Property
[image]

Gets or sets the ID of the opportunity to be used as the basis for the new invoice. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityId As Guid

C#
public Guid OpportunityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the opportunity to be used as the basis for the new invoice. This corresponds to the Opportunity.OpportunityId attribute, which is the primary key for the Opportunity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateInvoiceFromOpportunityRequest Class
GenerateInvoiceFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateInvoiceFromOpportunityResponse Class
See Also Members
[image]

Contains the response from the GenerateInvoiceFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GenerateInvoiceFromOpportunityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GenerateInvoiceFromOpportunityResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GenerateInvoiceFromOpportunityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateInvoiceFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityRequest


GenerateInvoiceFromOpportunityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GenerateInvoiceFromOpportunityRequest class.

The following tables list the members exposed by the GenerateInvoiceFromOpportunityResponse type.

Public Constructors

Name | Description
GenerateInvoiceFromOpportunityResponse | Initializes a new instance of the GenerateInvoiceFromOpportunityResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the resulting invoice.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GenerateInvoiceFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityRequest


GenerateInvoiceFromOpportunityResponse Constructor
[image]

Initializes a new instance of the GenerateInvoiceFromOpportunityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GenerateInvoiceFromOpportunityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateInvoiceFromOpportunityResponse Class
GenerateInvoiceFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateInvoiceFromOpportunityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GenerateInvoiceFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityRequest


GenerateInvoiceFromOpportunityResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the resulting invoice.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GenerateInvoiceFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityRequest


GenerateInvoiceFromOpportunityResponse.Entity Property
[image]

Gets the resulting invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The resulting invoice, which must be an instance of the Invoice class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateInvoiceFromOpportunityResponse Class
GenerateInvoiceFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateQuoteFromOpportunityRequest Class
See Also Example Members
[image]

Contains the data that is needed to generate a quote from an opportunity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GenerateQuoteFromOpportunityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GenerateQuoteFromOpportunityRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Convert the opportunity to a quote
var genQuoteFromOppRequest = new GenerateQuoteFromOpportunityRequest
{
    OpportunityId = _opportunityId,
    ColumnSet = new ColumnSet("quoteid", "name")
};

var genQuoteFromOppResponse = (GenerateQuoteFromOpportunityResponse)
    _serviceProxy.Execute(genQuoteFromOppRequest);

Quote quote = genQuoteFromOppResponse.Entity.ToEntity<Quote>();
_quoteId = quote.Id;

Console.WriteLine("Quote generated from the Opportunity.");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the GenerateQuoteFromOpportunityResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Opportunity entity and access rights to the specified record in the OpportunityId property.
For a complete list of the required privileges, see GenerateQuoteFromOpportunity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GenerateQuoteFromOpportunityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
GenerateQuoteFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GenerateQuoteFromOpportunityResponse
Other Resources
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Process Quotes, Sales Orders and Invoices
GenerateInvoiceFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateQuoteFromOpportunityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to generate a quote from an opportunity.

The following tables list the members exposed by the GenerateQuoteFromOpportunityRequest type.

Public Constructors

Name | Description
GenerateQuoteFromOpportunityRequest | Initializes a new instance of the GenerateQuoteFromOpportunityRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve in the resulting quote. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity to be used as the basis for the new quote. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GenerateQuoteFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateQuoteFromOpportunityResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Process Quotes, Sales Orders and Invoices
GenerateInvoiceFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateQuoteFromOpportunityRequest Constructor
[image]

Initializes a new instance of the GenerateQuoteFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GenerateQuoteFromOpportunityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateQuoteFromOpportunityRequest Class
GenerateQuoteFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateQuoteFromOpportunityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GenerateQuoteFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateQuoteFromOpportunityResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Process Quotes, Sales Orders and Invoices
GenerateInvoiceFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateQuoteFromOpportunityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve in the resulting quote. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity to be used as the basis for the new quote. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GenerateQuoteFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateQuoteFromOpportunityResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Process Quotes, Sales Orders and Invoices
GenerateInvoiceFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateQuoteFromOpportunityRequest.ColumnSet Property
[image]

Gets or sets the collection of attributes to retrieve in the resulting quote. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The collection of attributes to retrieve in the resulting quote.

  Remarks
Assign null to this property to retrieve only the primary key. The non-null values are returned for the specified attributes in the column set. The attributes that are not included in the column set contain null values. If the column set includes attributes where IsValidForRead is false, they are ignored. You can find this information in the metadata for your organization. See the preceding metadata browser information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateQuoteFromOpportunityRequest Class
GenerateQuoteFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateQuoteFromOpportunityRequest.OpportunityId Property
[image]

Gets or sets the ID of the opportunity to be used as the basis for the new quote. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityId As Guid

C#
public Guid OpportunityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the opportunity to be used as the basis for the new quote. This corresponds to the Opportunity.OpportunityId attribute, which is the primary key for the Opportunity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateQuoteFromOpportunityRequest Class
GenerateQuoteFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateQuoteFromOpportunityResponse Class
See Also Members
[image]

Contains the response from the GenerateQuoteFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GenerateQuoteFromOpportunityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GenerateQuoteFromOpportunityResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GenerateQuoteFromOpportunityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateQuoteFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GenerateQuoteFromOpportunityRequest


GenerateQuoteFromOpportunityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GenerateQuoteFromOpportunityRequest class.

The following tables list the members exposed by the GenerateQuoteFromOpportunityResponse type.

Public Constructors

Name | Description
GenerateQuoteFromOpportunityResponse | Initializes a new instance of the GenerateQuoteFromOpportunityResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the resulting quote.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GenerateQuoteFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateQuoteFromOpportunityRequest


GenerateQuoteFromOpportunityResponse Constructor
[image]

Initializes a new instance of the GenerateQuoteFromOpportunityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GenerateQuoteFromOpportunityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateQuoteFromOpportunityResponse Class
GenerateQuoteFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateQuoteFromOpportunityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GenerateQuoteFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateQuoteFromOpportunityRequest


GenerateQuoteFromOpportunityResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the resulting quote.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GenerateQuoteFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateQuoteFromOpportunityRequest


GenerateQuoteFromOpportunityResponse.Entity Property
[image]

Gets the resulting quote.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The resulting quote, which must be an instance of the Quote class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateQuoteFromOpportunityResponse Class
GenerateQuoteFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateSalesOrderFromOpportunityRequest Class
See Also Members
[image]

Contains the data that is needed to generate a sales order (order) from an opportunity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GenerateSalesOrderFromOpportunityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GenerateSalesOrderFromOpportunityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the GenerateSalesOrderFromOpportunityResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Opportunity entity and access rights to the specified record in the OpportunityId property.
For a complete list of the required privileges, see GenerateSalesOrderFromOpportunity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GenerateSalesOrderFromOpportunityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSalesOrderFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityResponse
Other Resources
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
GenerateSalesOrderFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateSalesOrderFromOpportunityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to generate a sales order (order) from an opportunity.

The following tables list the members exposed by the GenerateSalesOrderFromOpportunityRequest type.

Public Constructors

Name | Description
GenerateSalesOrderFromOpportunityRequest | Initializes a new instance of the GenerateSalesOrderFromOpportunityRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve from the resulting sales order (order). Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity to be used as the basis for the new sales order (order). Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GenerateSalesOrderFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
GenerateSalesOrderFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateSalesOrderFromOpportunityRequest Constructor
[image]

Initializes a new instance of the GenerateSalesOrderFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GenerateSalesOrderFromOpportunityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSalesOrderFromOpportunityRequest Class
GenerateSalesOrderFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateSalesOrderFromOpportunityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GenerateSalesOrderFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
GenerateSalesOrderFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateSalesOrderFromOpportunityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve from the resulting sales order (order). Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity to be used as the basis for the new sales order (order). Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GenerateSalesOrderFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateInvoiceFromOpportunityResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
GenerateSalesOrderFromOpportunity Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GenerateSalesOrderFromOpportunityRequest.ColumnSet Property
[image]

Gets or sets the collection of attributes to retrieve from the resulting sales order (order). Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The collection of attributes to retrieve from the resulting sales order (order).

  Remarks
Assign null to this property to retrieve only the primary key. The non-null values are returned for the specified attributes in the column set. The attributes that are not included in the column set contain null values. If the column set includes attributes where IsValidForRead is false, they are ignored. You can find this information in the metadata for your organization. See the preceding metadata browser information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSalesOrderFromOpportunityRequest Class
GenerateSalesOrderFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateSalesOrderFromOpportunityRequest.OpportunityId Property
[image]

Gets or sets the ID of the opportunity to be used as the basis for the new sales order (order). Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityId As Guid

C#
public Guid OpportunityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the opportunity to be used as the basis for the new sales order (order). This corresponds to the Opportunity.OpportunityId attribute, which is the primary key for the Opportunity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSalesOrderFromOpportunityRequest Class
GenerateSalesOrderFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateSalesOrderFromOpportunityResponse Class
See Also Members
[image]

Contains the response from the GenerateSalesOrderFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GenerateSalesOrderFromOpportunityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GenerateSalesOrderFromOpportunityResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GenerateSalesOrderFromOpportunityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSalesOrderFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GenerateSalesOrderFromOpportunityRequest


GenerateSalesOrderFromOpportunityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GenerateSalesOrderFromOpportunityRequest class.

The following tables list the members exposed by the GenerateSalesOrderFromOpportunityResponse type.

Public Constructors

Name | Description
GenerateSalesOrderFromOpportunityResponse | Initializes a new instance of the GenerateSalesOrderFromOpportunityResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the resulting sales order (order).
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GenerateSalesOrderFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateSalesOrderFromOpportunityRequest


GenerateSalesOrderFromOpportunityResponse Constructor
[image]

Initializes a new instance of the GenerateSalesOrderFromOpportunityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GenerateSalesOrderFromOpportunityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSalesOrderFromOpportunityResponse Class
GenerateSalesOrderFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateSalesOrderFromOpportunityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GenerateSalesOrderFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateSalesOrderFromOpportunityRequest


GenerateSalesOrderFromOpportunityResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the resulting sales order (order).
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GenerateSalesOrderFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateSalesOrderFromOpportunityRequest


GenerateSalesOrderFromOpportunityResponse.Entity Property
[image]

Gets the resulting sales order (order).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The resulting sales order (order), which must be an instance of the SalesOrder class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSalesOrderFromOpportunityResponse Class
GenerateSalesOrderFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateSocialProfileRequest Class
See Also Members
[image]

Contains the data to return an existing social profile record if one exists, otherwise generates a new one and returns it.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GenerateSocialProfileRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GenerateSocialProfileRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  GenerateSocialProfileResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the SocialProfile entity and access rights on the record specified in the Entity property. For a complete list of the privileges required, see GenerateSocialProfile message privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GenerateSocialProfileRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSocialProfileRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GenerateSocialProfileResponse
Other Resources
SocialProfile entity messages and methods


GenerateSocialProfileRequest Members
See Also Constructors Methods Properties
[image]

Contains the data to return an existing social profile record if one exists, otherwise generates a new one and returns it.

The following tables list the members exposed by the GenerateSocialProfileRequest type.

Public Constructors

Name | Description
GenerateSocialProfileRequest | Initializes a new instance of the GenerateSocialProfileRequest class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets or sets the social profile instance to return or generate.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GenerateSocialProfileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateSocialProfileResponse

Other Resources

SocialProfile entity messages and methods


GenerateSocialProfileRequest Constructor
[image]

Initializes a new instance of the GenerateSocialProfileRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GenerateSocialProfileRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSocialProfileRequest Class
GenerateSocialProfileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateSocialProfileRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GenerateSocialProfileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateSocialProfileResponse

Other Resources

SocialProfile entity messages and methods


GenerateSocialProfileRequest Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets or sets the social profile instance to return or generate.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GenerateSocialProfileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateSocialProfileResponse

Other Resources

SocialProfile entity messages and methods


GenerateSocialProfileRequest.Entity Property
[image]

Gets or sets the social profile instance to return or generate.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As Entity

C#
public Entity Entity { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The social profile instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSocialProfileRequest Class
GenerateSocialProfileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateSocialProfileResponse Class
See Also Members
[image]

Contains the response from the GenerateSocialProfileRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GenerateSocialProfileResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GenerateSocialProfileResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GenerateSocialProfileResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSocialProfileResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GenerateSocialProfileRequest


GenerateSocialProfileResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GenerateSocialProfileRequest message.

The following tables list the members exposed by the GenerateSocialProfileResponse type.

Public Constructors

Name | Description
GenerateSocialProfileResponse | Initializes a new instance of the GenerateSocialProfileResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the social profile returned by the message.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GenerateSocialProfileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateSocialProfileRequest


GenerateSocialProfileResponse Constructor
[image]

Initializes a new instance of the GenerateSocialProfileResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GenerateSocialProfileResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSocialProfileResponse Class
GenerateSocialProfileResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GenerateSocialProfileResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GenerateSocialProfileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateSocialProfileRequest


GenerateSocialProfileResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the social profile returned by the message.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GenerateSocialProfileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GenerateSocialProfileRequest


GenerateSocialProfileResponse.Entity Property
[image]

Gets the social profile returned by the message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The social profile returned by the message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GenerateSocialProfileResponse Class
GenerateSocialProfileResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetAllTimeZonesWithDisplayNameRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve all the time zone definitions for the specified locale and to return only the display name attribute.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetAllTimeZonesWithDisplayNameRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetAllTimeZonesWithDisplayNameRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of  the GetAllTimeZonesWithDisplayNameResponse class.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetAllTimeZonesWithDisplayNameRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetAllTimeZonesWithDisplayNameRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetAllTimeZonesWithDisplayNameResponse
Other Resources
Time Zone Entities
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


GetAllTimeZonesWithDisplayNameRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve all the time zone definitions for the specified locale and to return only the display name attribute.

The following tables list the members exposed by the GetAllTimeZonesWithDisplayNameRequest type.

Public Constructors

Name | Description
GetAllTimeZonesWithDisplayNameRequest | Initializes a new instance of the GetAllTimeZonesWithDisplayNameRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LocaleId | Gets or sets the locale ID. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetAllTimeZonesWithDisplayNameRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetAllTimeZonesWithDisplayNameResponse

Other Resources

Time Zone Entities
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


GetAllTimeZonesWithDisplayNameRequest Constructor
[image]

Initializes a new instance of the GetAllTimeZonesWithDisplayNameRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetAllTimeZonesWithDisplayNameRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetAllTimeZonesWithDisplayNameRequest Class
GetAllTimeZonesWithDisplayNameRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetAllTimeZonesWithDisplayNameRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetAllTimeZonesWithDisplayNameRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetAllTimeZonesWithDisplayNameResponse

Other Resources

Time Zone Entities
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


GetAllTimeZonesWithDisplayNameRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LocaleId | Gets or sets the locale ID. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetAllTimeZonesWithDisplayNameRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetAllTimeZonesWithDisplayNameResponse

Other Resources

Time Zone Entities
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


GetAllTimeZonesWithDisplayNameRequest.LocaleId Property
[image]

Gets or sets the locale ID. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LocaleId As Integer

C#
public int LocaleId { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The locale ID.

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetAllTimeZonesWithDisplayNameRequest Class
GetAllTimeZonesWithDisplayNameRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetAllTimeZonesWithDisplayNameResponse Class
See Also Members
[image]

Contains the response from the GetAllTimeZonesWithDisplayNameRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetAllTimeZonesWithDisplayNameResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetAllTimeZonesWithDisplayNameResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetAllTimeZonesWithDisplayNameResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetAllTimeZonesWithDisplayNameResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetAllTimeZonesWithDisplayNameRequest


GetAllTimeZonesWithDisplayNameResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetAllTimeZonesWithDisplayNameRequest class.

The following tables list the members exposed by the GetAllTimeZonesWithDisplayNameResponse type.

Public Constructors

Name | Description
GetAllTimeZonesWithDisplayNameResponse | Initializes a new instance of the GetAllTimeZonesWithDisplayNameResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of the time zone definition (TimeZoneDefinition) records.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetAllTimeZonesWithDisplayNameResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetAllTimeZonesWithDisplayNameRequest


GetAllTimeZonesWithDisplayNameResponse Constructor
[image]

Initializes a new instance of the GetAllTimeZonesWithDisplayNameResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetAllTimeZonesWithDisplayNameResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetAllTimeZonesWithDisplayNameResponse Class
GetAllTimeZonesWithDisplayNameResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetAllTimeZonesWithDisplayNameResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetAllTimeZonesWithDisplayNameResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetAllTimeZonesWithDisplayNameRequest


GetAllTimeZonesWithDisplayNameResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of the time zone definition (TimeZoneDefinition) records.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetAllTimeZonesWithDisplayNameResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetAllTimeZonesWithDisplayNameRequest


GetAllTimeZonesWithDisplayNameResponse.EntityCollection Property
[image]

Gets the collection of the time zone definition (TimeZoneDefinition) records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of the time zone definition (TimeZoneDefinition) records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetAllTimeZonesWithDisplayNameResponse Class
GetAllTimeZonesWithDisplayNameResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetDecryptionKeyRequest Class
See Also Members
[image]

For internal use only. See RetrieveDataEncryptionKeyRequest.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetDecryptionKeyRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetDecryptionKeyRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Contains the data that is needed to obtain the key that is used to encrypt or decrypt a user's or queue's email credentials that are stored in the Microsoft Dynamics CRM database. This message was incorrectly marked as public in previous Microsoft Dynamics CRM SDK releases.
Message Availability

                        For this message to work, the caller must be connected to the server. This message is supported only for on-premises and Internet-facing deployments (IFDs).
Usage
 Pass an instance of this class to the Execute  method, which returns an instance of the GetDecryptionKeyResponse class.
Privileges and Access Rights
For a complete list of the required privileges, see GetDecryptionKey Privileges.
Notes for Callers
The caller must be a member of the Active DirectoryPrivUserGroup security group in on-premises installations or must be the root business-unit administrator in Services Provider License Agreement (SPLA) or Internet-facing deployments (IFDs). By default, this message enforces Hypertext Transfer Protocol over Secure Sockets Layer (HTTPS). If you choose to enable HTTP for this communication, it is recommended that you enforce Internet Protocol security (IPsec) on the Microsoft Dynamics CRM server and on the email router.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetDecryptionKeyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDecryptionKeyRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetDecryptionKeyResponse


GetDecryptionKeyRequest Members
See Also Constructors Methods Properties
[image]

For internal use only. See RetrieveDataEncryptionKeyRequest.

The following tables list the members exposed by the GetDecryptionKeyRequest type.

Public Constructors

Name | Description
GetDecryptionKeyRequest | Initializes a new instance of the GetDecryptionKeyRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetDecryptionKeyRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetDecryptionKeyResponse


GetDecryptionKeyRequest Constructor
[image]

Initializes a new instance of the GetDecryptionKeyRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetDecryptionKeyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDecryptionKeyRequest Class
GetDecryptionKeyRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetDecryptionKeyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetDecryptionKeyRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetDecryptionKeyResponse


GetDecryptionKeyRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetDecryptionKeyRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetDecryptionKeyResponse


GetDecryptionKeyResponse Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetDecryptionKeyResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetDecryptionKeyResponse : OrganizationResponse

C++

J#

JScript

  Remarks
Contains the response from the GetDecryptionKeyRequest class.
This message is supported only for on-premises and Internet-facing deployments (IFDs).

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetDecryptionKeyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDecryptionKeyResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetDecryptionKeyRequest


GetDecryptionKeyResponse Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the GetDecryptionKeyResponse type.

Public Constructors

Name | Description
GetDecryptionKeyResponse | Initializes a new instance of the GetDecryptionKeyResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Key | Gets the decryption key.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetDecryptionKeyResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetDecryptionKeyRequest


GetDecryptionKeyResponse Constructor
[image]

Initializes a new instance of the GetDecryptionKeyResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetDecryptionKeyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDecryptionKeyResponse Class
GetDecryptionKeyResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetDecryptionKeyRequest


GetDecryptionKeyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetDecryptionKeyResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetDecryptionKeyRequest


GetDecryptionKeyResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Key | Gets the decryption key.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetDecryptionKeyResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetDecryptionKeyRequest


GetDecryptionKeyResponse.Key Property
[image]

Gets the decryption key.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Key As String

C#
public string Key { get; }

C++

J#

JScript

Property Value
Type: String
The decryption key.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDecryptionKeyResponse Class
GetDecryptionKeyResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetDefaultPriceLevelRequest Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetDefaultPriceLevelRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetDefaultPriceLevelRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetDefaultPriceLevelRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDefaultPriceLevelRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Set default price level for opportunity, quote, order, invoice


GetDefaultPriceLevelRequest Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the GetDefaultPriceLevelRequest type.

Public Constructors

Name | Description
GetDefaultPriceLevelRequest | For internal use only.
Top

Public Properties

 | Name | Description
public property | EntityName | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetDefaultPriceLevelRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Set default price level for opportunity, quote, order, invoice


GetDefaultPriceLevelRequest Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetDefaultPriceLevelRequest ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDefaultPriceLevelRequest Class
GetDefaultPriceLevelRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetDefaultPriceLevelRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetDefaultPriceLevelRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Set default price level for opportunity, quote, order, invoice


GetDefaultPriceLevelRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityName | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetDefaultPriceLevelRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Set default price level for opportunity, quote, order, invoice


GetDefaultPriceLevelRequest.EntityName Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Returns String
The logical entity name.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDefaultPriceLevelRequest Class
GetDefaultPriceLevelRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetDefaultPriceLevelResponse Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetDefaultPriceLevelResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetDefaultPriceLevelResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetDefaultPriceLevelResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDefaultPriceLevelResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetDefaultPriceLevelResponse Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the GetDefaultPriceLevelResponse type.

Public Constructors

Name | Description
GetDefaultPriceLevelResponse | For internal use only.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | PriceLevels | For internal use only.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetDefaultPriceLevelResponse Class
Microsoft.Crm.Sdk.Messages Namespace


GetDefaultPriceLevelResponse Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetDefaultPriceLevelResponse ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDefaultPriceLevelResponse Class
GetDefaultPriceLevelResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetDefaultPriceLevelResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetDefaultPriceLevelResponse Class
Microsoft.Crm.Sdk.Messages Namespace


GetDefaultPriceLevelResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | PriceLevels | For internal use only.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetDefaultPriceLevelResponse Class
Microsoft.Crm.Sdk.Messages Namespace


GetDefaultPriceLevelResponse.PriceLevels Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property PriceLevels As EntityCollection

C#
public EntityCollection PriceLevels { get; }

C++

J#

JScript

Property Value
Returns EntityCollection
The resulting price level, which is an instance of the PriceLevel class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDefaultPriceLevelResponse Class
GetDefaultPriceLevelResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetDistinctValuesImportFileRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve distinct values from the parse table for a column in the source file that contains list values.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetDistinctValuesImportFileRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetDistinctValuesImportFileRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Retrieve the first two distinct values for column 1 from the parse table.
// NOTE: You must create the parse table first using the ParseImport message.
// The parse table is not accessible after ImportRecordsImportResponse is called.
GetDistinctValuesImportFileRequest distinctValuesRequest = new GetDistinctValuesImportFileRequest()
{
    columnNumber = 1,
    ImportFileId = importFileId,
    pageNumber = 1,
    recordsPerPage = 2,
};
GetDistinctValuesImportFileResponse distinctValuesResponse =
    (GetDistinctValuesImportFileResponse)_serviceProxy.Execute(distinctValuesRequest);

// Output the distinct values.  In this case: (column 1, row 1) and (column 1, row 2).
int cellNum = 1;
foreach (string cellValue in distinctValuesResponse.Values)
{
    Console.WriteLine("(1, " + cellNum.ToString() + "): " + cellValue);
    Console.WriteLine(cellValue);
    cellNum++;
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  GetDistinctValuesImportFileResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the ImportFile entity and access rights on the record specified in the ImportFileId property. For a complete list of the required privileges, see GetDistinctValuesImportFile Privileges.
Notes for Callers
Use this message only after you have created a parse table by using the ParseImportRequest message. Do not use this message after you use the ImportRecordsImportRequest message. You cannot access the parse table after the import job submitted by the ImportRecordsRequest message has finished running.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetDistinctValuesImportFileRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
GetDistinctValuesImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetDistinctValuesImportFileResponse
Other Resources
Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
GetDistinctValuesImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetDistinctValuesImportFileRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve distinct values from the parse table for a column in the source file that contains list values.

The following tables list the members exposed by the GetDistinctValuesImportFileRequest type.

Public Constructors

Name | Description
GetDistinctValuesImportFileRequest | Initializes a new instance of the GetDistinctValuesImportFileRequest class.
Top

Public Properties

 | Name | Description
public property | columnNumber | Gets or sets a column number in the CSV, XML Spreadsheet 2003 (.xml), or text source file for which the distinct values are returned. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportFileId | Gets or sets in ID of the import file that is associated with the source file. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | pageNumber | Gets or sets the page number in the source file. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | recordsPerPage | Gets or sets the number of data records per page in the source file. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetDistinctValuesImportFileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetDistinctValuesImportFileResponse

Other Resources

Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
GetDistinctValuesImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetDistinctValuesImportFileRequest Constructor
[image]

Initializes a new instance of the GetDistinctValuesImportFileRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetDistinctValuesImportFileRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDistinctValuesImportFileRequest Class
GetDistinctValuesImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetDistinctValuesImportFileRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetDistinctValuesImportFileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetDistinctValuesImportFileResponse

Other Resources

Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
GetDistinctValuesImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetDistinctValuesImportFileRequest Properties
[image]

Public Properties

 | Name | Description
public property | columnNumber | Gets or sets a column number in the CSV, XML Spreadsheet 2003 (.xml), or text source file for which the distinct values are returned. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportFileId | Gets or sets in ID of the import file that is associated with the source file. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | pageNumber | Gets or sets the page number in the source file. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | recordsPerPage | Gets or sets the number of data records per page in the source file. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetDistinctValuesImportFileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetDistinctValuesImportFileResponse

Other Resources

Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
GetDistinctValuesImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetDistinctValuesImportFileRequest.columnNumber Property
[image]

Gets or sets a column number in the CSV, XML Spreadsheet 2003 (.xml), or text source file for which the distinct values are returned. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property columnNumber As Integer

C#
public int columnNumber { get; set; }

C++

J#

JScript

Property Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDistinctValuesImportFileRequest Class
GetDistinctValuesImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetDistinctValuesImportFileRequest.ImportFileId Property
[image]

Gets or sets in ID of the import file that is associated with the source file. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportFileId As Guid

C#
public Guid ImportFileId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the import file that is associated with the source file. This corresponds to the ImportFile.ImportFileId attribute, which is the primary key for the ImportFile entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDistinctValuesImportFileRequest Class
GetDistinctValuesImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetDistinctValuesImportFileRequest.pageNumber Property
[image]

Gets or sets the page number in the source file. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property pageNumber As Integer

C#
public int pageNumber { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The page number in the source file.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDistinctValuesImportFileRequest Class
GetDistinctValuesImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetDistinctValuesImportFileRequest.recordsPerPage Property
[image]

Gets or sets the number of data records per page in the source file. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property recordsPerPage As Integer

C#
public int recordsPerPage { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of data records per page in the source file.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDistinctValuesImportFileRequest Class
GetDistinctValuesImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetDistinctValuesImportFileResponse Class
See Also Members
[image]

Contains the response from the GetDistinctValuesImportFileRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetDistinctValuesImportFileResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetDistinctValuesImportFileResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetDistinctValuesImportFileResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDistinctValuesImportFileResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetDistinctValuesImportFileRequest


GetDistinctValuesImportFileResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetDistinctValuesImportFileRequest class.

The following tables list the members exposed by the GetDistinctValuesImportFileResponse type.

Public Constructors

Name | Description
GetDistinctValuesImportFileResponse | Initializes a new instance of the GetDistinctValuesImportFileResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Values | Gets the distinct values for a column in the source file.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetDistinctValuesImportFileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetDistinctValuesImportFileRequest


GetDistinctValuesImportFileResponse Constructor
[image]

Initializes a new instance of the GetDistinctValuesImportFileResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetDistinctValuesImportFileResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDistinctValuesImportFileResponse Class
GetDistinctValuesImportFileResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetDistinctValuesImportFileResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetDistinctValuesImportFileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetDistinctValuesImportFileRequest


GetDistinctValuesImportFileResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Values | Gets the distinct values for a column in the source file.

See Also

Reference

GetDistinctValuesImportFileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetDistinctValuesImportFileRequest


GetDistinctValuesImportFileResponse.Values Property
[image]

Gets the distinct values for a column in the source file.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Values As String()

C#
public string[] Values { get; }

C++

J#

JScript

Property Value
Type: String
The distinct values for a column in the source file.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetDistinctValuesImportFileResponse Class
GetDistinctValuesImportFileResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetHeaderColumnsImportFileRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the source-file column headings; or retrieve the system-generated column headings if the source file does not contain column headings.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetHeaderColumnsImportFileRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetHeaderColumnsImportFileRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Retrieve the header columns used in the import file.
GetHeaderColumnsImportFileRequest headerColumnsRequest = new GetHeaderColumnsImportFileRequest()
{
    ImportFileId = importFileId
};
GetHeaderColumnsImportFileResponse headerColumnsResponse =
    (GetHeaderColumnsImportFileResponse)_serviceProxy.Execute(headerColumnsRequest);

// Output the header columns.
int columnNum = 1;
foreach (string headerName in headerColumnsResponse.Columns)
{
    Console.WriteLine("Column[" + columnNum.ToString() + "] = " + headerName);
    columnNum++;
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the GetHeaderColumnsImportFileResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the ImportFile entity and access rights on the specified record in the ImportFileId property. For a complete list of the required privileges, see GetHeaderColumnsImportFile Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetHeaderColumnsImportFileRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
GetHeaderColumnsImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetHeaderColumnsImportFileResponse
Other Resources
Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
GetHeaderColumnsImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


GetHeaderColumnsImportFileRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the source-file column headings; or retrieve the system-generated column headings if the source file does not contain column headings.

The following tables list the members exposed by the GetHeaderColumnsImportFileRequest type.

Public Constructors

Name | Description
GetHeaderColumnsImportFileRequest | Initializes a new instance of the GetHeaderColumnsImportFileRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportFileId | Gets or sets the ID of the import file that is associated with the parse table. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetHeaderColumnsImportFileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetHeaderColumnsImportFileResponse

Other Resources

Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
GetHeaderColumnsImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


GetHeaderColumnsImportFileRequest Constructor
[image]

Initializes a new instance of the GetHeaderColumnsImportFileRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetHeaderColumnsImportFileRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetHeaderColumnsImportFileRequest Class
GetHeaderColumnsImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetHeaderColumnsImportFileRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetHeaderColumnsImportFileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetHeaderColumnsImportFileResponse

Other Resources

Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
GetHeaderColumnsImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


GetHeaderColumnsImportFileRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportFileId | Gets or sets the ID of the import file that is associated with the parse table. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetHeaderColumnsImportFileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetHeaderColumnsImportFileResponse

Other Resources

Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
GetHeaderColumnsImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


GetHeaderColumnsImportFileRequest.ImportFileId Property
[image]

Gets or sets the ID of the import file that is associated with the parse table. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportFileId As Guid

C#
public Guid ImportFileId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the import file that is associated with the parse table. This corresponds to the ImportFile.ImportFileId attribute, which is the primary key for the ImportFile entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetHeaderColumnsImportFileRequest Class
GetHeaderColumnsImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetHeaderColumnsImportFileResponse Class
See Also Members
[image]

Contains the response from the GetHeaderColumnsImportFileRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetHeaderColumnsImportFileResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetHeaderColumnsImportFileResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetHeaderColumnsImportFileResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetHeaderColumnsImportFileResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetHeaderColumnsImportFileRequest


GetHeaderColumnsImportFileResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetHeaderColumnsImportFileRequest class.

The following tables list the members exposed by the GetHeaderColumnsImportFileResponse type.

Public Constructors

Name | Description
GetHeaderColumnsImportFileResponse | Initializes a new instance of the GetHeaderColumnsImportFileResponse class.
Top

Public Properties

 | Name | Description
public property | Columns | Gets the source file header columns.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetHeaderColumnsImportFileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetHeaderColumnsImportFileRequest


GetHeaderColumnsImportFileResponse Constructor
[image]

Initializes a new instance of the GetHeaderColumnsImportFileResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetHeaderColumnsImportFileResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetHeaderColumnsImportFileResponse Class
GetHeaderColumnsImportFileResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetHeaderColumnsImportFileResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetHeaderColumnsImportFileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetHeaderColumnsImportFileRequest


GetHeaderColumnsImportFileResponse Properties
[image]

Public Properties

 | Name | Description
public property | Columns | Gets the source file header columns.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetHeaderColumnsImportFileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetHeaderColumnsImportFileRequest


GetHeaderColumnsImportFileResponse.Columns Property
[image]

Gets the source file header columns.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Columns As String()

C#
public string[] Columns { get; }

C++

J#

JScript

Property Value
Type: String
The source file header columns.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetHeaderColumnsImportFileResponse Class
GetHeaderColumnsImportFileResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetInvoiceProductsFromOpportunityRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the products from an opportunity and copy them to the invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetInvoiceProductsFromOpportunityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetInvoiceProductsFromOpportunityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of  GetInvoiceProductsFromOpportunityResponse.
Privileges and Access Rights

                        To perform this action, the caller must have privileges on the Invoice and Opportunity entities and access rights on the records specified in the InvoiceId property and the OpportunityId property. For a complete list of required privileges, see GetInvoiceProductsFromOpportunity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetInvoiceProductsFromOpportunityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetInvoiceProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetInvoiceProductsFromOpportunityResponse
Other Resources
GetInvoiceProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Opportunity Entities
Invoice Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetInvoiceProductsFromOpportunityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the products from an opportunity and copy them to the invoice.

The following tables list the members exposed by the GetInvoiceProductsFromOpportunityRequest type.

Public Constructors

Name | Description
GetInvoiceProductsFromOpportunityRequest | Initializes a new instance of the GetInvoiceProductsFromOpportunityRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InvoiceId | Gets or sets the ID of the invoice.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetInvoiceProductsFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetInvoiceProductsFromOpportunityResponse

Other Resources

GetInvoiceProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Opportunity Entities
Invoice Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetInvoiceProductsFromOpportunityRequest Constructor
[image]

Initializes a new instance of the GetInvoiceProductsFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetInvoiceProductsFromOpportunityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetInvoiceProductsFromOpportunityRequest Class
GetInvoiceProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetInvoiceProductsFromOpportunityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetInvoiceProductsFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetInvoiceProductsFromOpportunityResponse

Other Resources

GetInvoiceProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Opportunity Entities
Invoice Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetInvoiceProductsFromOpportunityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InvoiceId | Gets or sets the ID of the invoice.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetInvoiceProductsFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetInvoiceProductsFromOpportunityResponse

Other Resources

GetInvoiceProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Opportunity Entities
Invoice Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetInvoiceProductsFromOpportunityRequest.InvoiceId Property
[image]

Gets or sets the ID of the invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property InvoiceId As Guid

C#
public Guid InvoiceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the invoice. This corresponds to the Invoice.InvoiceId attribute, which is the primary key for the Invoice entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetInvoiceProductsFromOpportunityRequest Class
GetInvoiceProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetInvoiceProductsFromOpportunityRequest.OpportunityId Property
[image]

Gets or sets the ID of the opportunity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityId As Guid

C#
public Guid OpportunityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the opportunity. This corresponds to the Opportunity.OpportunityId attribute, which is the primary key for the Opportunity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetInvoiceProductsFromOpportunityRequest Class
GetInvoiceProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetInvoiceProductsFromOpportunityResponse Class
See Also Members
[image]

Contains the response from the GetInvoiceProductsFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetInvoiceProductsFromOpportunityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetInvoiceProductsFromOpportunityResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetInvoiceProductsFromOpportunityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetInvoiceProductsFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetInvoiceProductsFromOpportunityRequest


GetInvoiceProductsFromOpportunityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetInvoiceProductsFromOpportunityRequest class.

The following tables list the members exposed by the GetInvoiceProductsFromOpportunityResponse type.

Public Constructors

Name | Description
GetInvoiceProductsFromOpportunityResponse | Initializes a new instance of the GetInvoiceProductsFromOpportunityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetInvoiceProductsFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetInvoiceProductsFromOpportunityRequest


GetInvoiceProductsFromOpportunityResponse Constructor
[image]

Initializes a new instance of the GetInvoiceProductsFromOpportunityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetInvoiceProductsFromOpportunityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetInvoiceProductsFromOpportunityResponse Class
GetInvoiceProductsFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetInvoiceProductsFromOpportunityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetInvoiceProductsFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetInvoiceProductsFromOpportunityRequest


GetInvoiceProductsFromOpportunityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetInvoiceProductsFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetInvoiceProductsFromOpportunityRequest


GetQuantityDecimalRequest Class
See Also Members
[image]

Contains the data that is needed to get the quantity decimal value of a product for the specified entity in the target.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetQuantityDecimalRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetQuantityDecimalRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline. For more information, see Supported Entities later in this topic.
Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the GetQuantityDecimalResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Product entity, on the UOM entity, and on the entity that is referred to in the Target property. You also need access rights on the specified records in the ProductId property and the UoMId property.
For a complete list of the required privileges, see GetQuantityDecimal Privileges.
Supported Entities
The following table shows the default entities that support this message. This message works regardless whether the caller is connected to the server or offline.

                                    Entity

invoice

opportunity

quote

salesorder

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetQuantityDecimalRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuantityDecimalRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetQuantityDecimalResponse
Other Resources
GetQuantityDecimal Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
UoM (Unit) Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetQuantityDecimalRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to get the quantity decimal value of a product for the specified entity in the target.

The following tables list the members exposed by the GetQuantityDecimalRequest type.

Public Constructors

Name | Description
GetQuantityDecimalRequest | Initializes a new instance of the GetQuantityDecimalRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for this request. Required.
public property | UoMId | Gets or sets the ID of the unit of measure (unit). Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetQuantityDecimalRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuantityDecimalResponse

Other Resources

GetQuantityDecimal Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
UoM (Unit) Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetQuantityDecimalRequest Constructor
[image]

Initializes a new instance of the GetQuantityDecimalRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetQuantityDecimalRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuantityDecimalRequest Class
GetQuantityDecimalRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuantityDecimalRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetQuantityDecimalRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuantityDecimalResponse

Other Resources

GetQuantityDecimal Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
UoM (Unit) Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetQuantityDecimalRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for this request. Required.
public property | UoMId | Gets or sets the ID of the unit of measure (unit). Required.

See Also

Reference

GetQuantityDecimalRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuantityDecimalResponse

Other Resources

GetQuantityDecimal Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
UoM (Unit) Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetQuantityDecimalRequest.ProductId Property
[image]

Gets or sets the ID of the product. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ProductId As Guid

C#
public Guid ProductId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the product. This corresponds to the Product.ProductId attribute, which is the primary key for the Product entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuantityDecimalRequest Class
GetQuantityDecimalRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuantityDecimalRequest.Target Property
[image]

Gets or sets the target record for this request. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target record for this request. This must be an entity reference for Invoice, Opportunity, Quote, or Salesorder entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuantityDecimalRequest Class
GetQuantityDecimalRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuantityDecimalRequest.UoMId Property
[image]

Gets or sets the ID of the unit of measure (unit). Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UoMId As Guid

C#
public Guid UoMId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the unit of measure (unit). This corresponds to the UoM.UoMId attribute, which is the primary key for the UoM entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuantityDecimalRequest Class
GetQuantityDecimalRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuantityDecimalResponse Class
See Also Members
[image]

Contains the response from the GetQuantityDecimalRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetQuantityDecimalResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetQuantityDecimalResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetQuantityDecimalResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuantityDecimalResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetQuantityDecimalRequest


GetQuantityDecimalResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetQuantityDecimalRequest class.

The following tables list the members exposed by the GetQuantityDecimalResponse type.

Public Constructors

Name | Description
GetQuantityDecimalResponse | Initializes a new instance of the GetQuantityDecimalResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Quantity | Gets the quantity decimal value for a product.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetQuantityDecimalResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuantityDecimalRequest


GetQuantityDecimalResponse Constructor
[image]

Initializes a new instance of the GetQuantityDecimalResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetQuantityDecimalResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuantityDecimalResponse Class
GetQuantityDecimalResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuantityDecimalResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetQuantityDecimalResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuantityDecimalRequest


GetQuantityDecimalResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Quantity | Gets the quantity decimal value for a product.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetQuantityDecimalResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuantityDecimalRequest


GetQuantityDecimalResponse.Quantity Property
[image]

Gets the quantity decimal value for a product.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Quantity As Integer

C#
public int Quantity { get; }

C++

J#

JScript

Property Value
Type: Int32
The quantity decimal value for a product.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuantityDecimalResponse Class
GetQuantityDecimalResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuoteProductsFromOpportunityRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the products from an opportunity and copy them to the quote.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetQuoteProductsFromOpportunityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetQuoteProductsFromOpportunityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of  GetQuoteProductsFromOpportunityResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Quote and Opportunity entities and access rights on the records specified in the QuoteId property and the OpportunityId property. For a complete list of required privileges, see GetQuoteProductsFromOpportunity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetQuoteProductsFromOpportunityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuoteProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetQuoteProductsFromOpportunityResponse
Other Resources
GetQuoteProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetQuoteProductsFromOpportunityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the products from an opportunity and copy them to the quote.

The following tables list the members exposed by the GetQuoteProductsFromOpportunityRequest type.

Public Constructors

Name | Description
GetQuoteProductsFromOpportunityRequest | Initializes a new instance of the GetQuoteProductsFromOpportunityRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteId | Gets or sets the ID of the quote.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetQuoteProductsFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuoteProductsFromOpportunityResponse

Other Resources

GetQuoteProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetQuoteProductsFromOpportunityRequest Constructor
[image]

Initializes a new instance of the GetQuoteProductsFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetQuoteProductsFromOpportunityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuoteProductsFromOpportunityRequest Class
GetQuoteProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuoteProductsFromOpportunityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetQuoteProductsFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuoteProductsFromOpportunityResponse

Other Resources

GetQuoteProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetQuoteProductsFromOpportunityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteId | Gets or sets the ID of the quote.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetQuoteProductsFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuoteProductsFromOpportunityResponse

Other Resources

GetQuoteProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetQuoteProductsFromOpportunityRequest.OpportunityId Property
[image]

Gets or sets the ID of the opportunity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityId As Guid

C#
public Guid OpportunityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the opportunity. This corresponds to the Opportunity.OpportunityId attribute, which is the primary key for the Opportunity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuoteProductsFromOpportunityRequest Class
GetQuoteProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuoteProductsFromOpportunityRequest.QuoteId Property
[image]

Gets or sets the ID of the quote.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QuoteId As Guid

C#
public Guid QuoteId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the quote. This corresponds to the Quote.QuoteId attribute, which is the primary key for the Quote entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuoteProductsFromOpportunityRequest Class
GetQuoteProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuoteProductsFromOpportunityResponse Class
See Also Members
[image]

Contains the response from the GetQuoteProductsFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetQuoteProductsFromOpportunityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetQuoteProductsFromOpportunityResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetQuoteProductsFromOpportunityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuoteProductsFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetQuoteProductsFromOpportunityRequest


GetQuoteProductsFromOpportunityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetQuoteProductsFromOpportunityRequest class.

The following tables list the members exposed by the GetQuoteProductsFromOpportunityResponse type.

Public Constructors

Name | Description
GetQuoteProductsFromOpportunityResponse | Initializes a new instance of the GetQuoteProductsFromOpportunityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetQuoteProductsFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuoteProductsFromOpportunityRequest


GetQuoteProductsFromOpportunityResponse Constructor
[image]

Initializes a new instance of the GetQuoteProductsFromOpportunityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetQuoteProductsFromOpportunityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetQuoteProductsFromOpportunityResponse Class
GetQuoteProductsFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetQuoteProductsFromOpportunityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetQuoteProductsFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuoteProductsFromOpportunityRequest


GetQuoteProductsFromOpportunityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetQuoteProductsFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetQuoteProductsFromOpportunityRequest


GetReportHistoryLimitRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the history limit for a report.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetReportHistoryLimitRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetReportHistoryLimitRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Query for an an existing report: Account Overview. This is a default report in Microsoft Dynamics CRM.
QueryByAttribute reportQuery = new QueryByAttribute(Report.EntityLogicalName);
reportQuery.AddAttributeValue("name", "Account Overview");
reportQuery.ColumnSet = new ColumnSet("reportid");

// Get the report.
EntityCollection retrieveReports = _serviceProxy.RetrieveMultiple(reportQuery);

// Convert retrieved Entity to a report
Report retrievedReport = (Report)retrieveReports.Entities[0];
Console.WriteLine("Retrieved the 'Account Overview' report.");

// Use the Download Report Definition message.
GetReportHistoryLimitRequest reportHistoryRequest = new GetReportHistoryLimitRequest
{
    ReportId = retrievedReport.ReportId.Value
};

GetReportHistoryLimitResponse reportHistoryResponse = (GetReportHistoryLimitResponse)_serviceProxy.Execute(reportHistoryRequest);

// Access the history limit data
int historyLimit = reportHistoryResponse.HistoryLimit;

Console.WriteLine("The report history limit is {0}.", historyLimit);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute   method, which returns an instance of  GetReportHistoryLimitResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Report entity and access rights on the record specified in the ReportIdproperty. For a complete list of the privileges required, see GetReportHistoryLimit Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetReportHistoryLimitRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
GetReportHistoryLimitRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetReportHistoryLimitResponse
Other Resources
Sample: Get Report History Limit
Create Reports for Microsoft Dynamics CRM Using SQL Server Reporting Services
Report Entity Messages and Methods
GetReportHistoryLimit Privileges


GetReportHistoryLimitRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the history limit for a report.

The following tables list the members exposed by the GetReportHistoryLimitRequest type.

Public Constructors

Name | Description
GetReportHistoryLimitRequest | Initializes a new instance of the GetReportHistoryLimitRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Gets or sets the ID of the report. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetReportHistoryLimitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetReportHistoryLimitResponse

Other Resources

Sample: Get Report History Limit
Create Reports for Microsoft Dynamics CRM Using SQL Server Reporting Services
Report Entity Messages and Methods
GetReportHistoryLimit Privileges


GetReportHistoryLimitRequest Constructor
[image]

Initializes a new instance of the GetReportHistoryLimitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetReportHistoryLimitRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetReportHistoryLimitRequest Class
GetReportHistoryLimitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetReportHistoryLimitRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetReportHistoryLimitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetReportHistoryLimitResponse

Other Resources

Sample: Get Report History Limit
Create Reports for Microsoft Dynamics CRM Using SQL Server Reporting Services
Report Entity Messages and Methods
GetReportHistoryLimit Privileges


GetReportHistoryLimitRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Gets or sets the ID of the report. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetReportHistoryLimitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetReportHistoryLimitResponse

Other Resources

Sample: Get Report History Limit
Create Reports for Microsoft Dynamics CRM Using SQL Server Reporting Services
Report Entity Messages and Methods
GetReportHistoryLimit Privileges


GetReportHistoryLimitRequest.ReportId Property
[image]

Gets or sets the ID of the report. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReportId As Guid

C#
public Guid ReportId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the report. This corresponds to the Report.ReportId property, which is the primary key for the Report entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetReportHistoryLimitRequest Class
GetReportHistoryLimitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetReportHistoryLimitResponse Class
See Also Members
[image]

Contains the response from the GetReportHistoryLimitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetReportHistoryLimitResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetReportHistoryLimitResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetReportHistoryLimitResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetReportHistoryLimitResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetReportHistoryLimitRequest


GetReportHistoryLimitResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetReportHistoryLimitRequest class.

The following tables list the members exposed by the GetReportHistoryLimitResponse type.

Public Constructors

Name | Description
GetReportHistoryLimitResponse | Initializes a new instance of the GetReportHistoryLimitResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | HistoryLimit | Gets the history limit for a report.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetReportHistoryLimitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetReportHistoryLimitRequest


GetReportHistoryLimitResponse Constructor
[image]

Initializes a new instance of the GetReportHistoryLimitResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetReportHistoryLimitResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetReportHistoryLimitResponse Class
GetReportHistoryLimitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetReportHistoryLimitResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetReportHistoryLimitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetReportHistoryLimitRequest


GetReportHistoryLimitResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | HistoryLimit | Gets the history limit for a report.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetReportHistoryLimitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetReportHistoryLimitRequest


GetReportHistoryLimitResponse.HistoryLimit Property
[image]

Gets the history limit for a report.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property HistoryLimit As Integer

C#
public int HistoryLimit { get; }

C++

J#

JScript

Property Value
Type: Int32
  Remarks
The history limit represents the number of report history snapshots that a specified report is permitted to have. The default is eight snapshots. If -1 is returned, the report is permitted to have an unlimited number of report history snapshots.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetReportHistoryLimitResponse Class
GetReportHistoryLimitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetSalesOrderProductsFromOpportunityRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the products from an opportunity and copy them to the sales order (order).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetSalesOrderProductsFromOpportunityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetSalesOrderProductsFromOpportunityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  GetSalesOrderProductsFromOpportunityResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the SalesOrder and Opportunity entities and access rights on the records specified in the SalesOrderId property and the OpportunityId property. For a complete list of required privileges, see GetSalesOrderProductsFromOpportunity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetSalesOrderProductsFromOpportunityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetSalesOrderProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetSalesOrderProductsFromOpportunityResponse
Other Resources
GetSalesOrderProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetSalesOrderProductsFromOpportunityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the products from an opportunity and copy them to the sales order (order).

The following tables list the members exposed by the GetSalesOrderProductsFromOpportunityRequest type.

Public Constructors

Name | Description
GetSalesOrderProductsFromOpportunityRequest | Initializes a new instance of the GetSalesOrderProductsFromOpportunityRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SalesOrderId | Gets or sets the ID of the sales order (order).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetSalesOrderProductsFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetSalesOrderProductsFromOpportunityResponse

Other Resources

GetSalesOrderProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetSalesOrderProductsFromOpportunityRequest Constructor
[image]

Initializes a new instance of the GetSalesOrderProductsFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetSalesOrderProductsFromOpportunityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetSalesOrderProductsFromOpportunityRequest Class
GetSalesOrderProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetSalesOrderProductsFromOpportunityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetSalesOrderProductsFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetSalesOrderProductsFromOpportunityResponse

Other Resources

GetSalesOrderProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetSalesOrderProductsFromOpportunityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityId | Gets or sets the ID of the opportunity.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SalesOrderId | Gets or sets the ID of the sales order (order).

See Also

Reference

GetSalesOrderProductsFromOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetSalesOrderProductsFromOpportunityResponse

Other Resources

GetSalesOrderProductsFromOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetSalesOrderProductsFromOpportunityRequest.OpportunityId Property
[image]

Gets or sets the ID of the opportunity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityId As Guid

C#
public Guid OpportunityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the opportunity. This corresponds to the Opportunity.OpportunityId attribute, which is the primary key for the Opportunity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetSalesOrderProductsFromOpportunityRequest Class
GetSalesOrderProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetSalesOrderProductsFromOpportunityRequest.SalesOrderId Property
[image]

Gets or sets the ID of the sales order (order).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SalesOrderId As Guid

C#
public Guid SalesOrderId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the sales order (order). This corresponds to the SalesOrder.SalesOrderId attribute, which is the primary key for the SalesOrder entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetSalesOrderProductsFromOpportunityRequest Class
GetSalesOrderProductsFromOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetSalesOrderProductsFromOpportunityResponse Class
See Also Members
[image]

Contains the response from the GetSalesOrderProductsFromOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetSalesOrderProductsFromOpportunityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetSalesOrderProductsFromOpportunityResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetSalesOrderProductsFromOpportunityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetSalesOrderProductsFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetSalesOrderProductsFromOpportunityRequest


GetSalesOrderProductsFromOpportunityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetSalesOrderProductsFromOpportunityRequest class.

The following tables list the members exposed by the GetSalesOrderProductsFromOpportunityResponse type.

Public Constructors

Name | Description
GetSalesOrderProductsFromOpportunityResponse | Initializes a new instance of the GetSalesOrderProductsFromOpportunityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetSalesOrderProductsFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetSalesOrderProductsFromOpportunityRequest


GetSalesOrderProductsFromOpportunityResponse Constructor
[image]

Initializes a new instance of the GetSalesOrderProductsFromOpportunityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetSalesOrderProductsFromOpportunityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetSalesOrderProductsFromOpportunityResponse Class
GetSalesOrderProductsFromOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetSalesOrderProductsFromOpportunityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetSalesOrderProductsFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetSalesOrderProductsFromOpportunityRequest


GetSalesOrderProductsFromOpportunityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetSalesOrderProductsFromOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetSalesOrderProductsFromOpportunityRequest


GetTimeZoneCodeByLocalizedNameRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the time zone code for the specified localized time zone name.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetTimeZoneCodeByLocalizedNameRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetTimeZoneCodeByLocalizedNameRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  GetTimeZoneCodeByLocalizedNameResponse.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetTimeZoneCodeByLocalizedNameRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTimeZoneCodeByLocalizedNameRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetTimeZoneCodeByLocalizedNameResponse
Other Resources
Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetTimeZoneCodeByLocalizedNameRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the time zone code for the specified localized time zone name.

The following tables list the members exposed by the GetTimeZoneCodeByLocalizedNameRequest type.

Public Constructors

Name | Description
GetTimeZoneCodeByLocalizedNameRequest | Initializes a new instance of the GetTimeZoneCodeByLocalizedNameRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LocaleId | Gets or sets the locale ID.
public property | LocalizedStandardName | Gets or sets the localized name to search for.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetTimeZoneCodeByLocalizedNameRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetTimeZoneCodeByLocalizedNameResponse

Other Resources

Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetTimeZoneCodeByLocalizedNameRequest Constructor
[image]

Initializes a new instance of the GetTimeZoneCodeByLocalizedNameRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetTimeZoneCodeByLocalizedNameRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTimeZoneCodeByLocalizedNameRequest Class
GetTimeZoneCodeByLocalizedNameRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetTimeZoneCodeByLocalizedNameRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetTimeZoneCodeByLocalizedNameRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetTimeZoneCodeByLocalizedNameResponse

Other Resources

Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetTimeZoneCodeByLocalizedNameRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LocaleId | Gets or sets the locale ID.
public property | LocalizedStandardName | Gets or sets the localized name to search for.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetTimeZoneCodeByLocalizedNameRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetTimeZoneCodeByLocalizedNameResponse

Other Resources

Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


GetTimeZoneCodeByLocalizedNameRequest.LocaleId Property
[image]

Gets or sets the locale ID.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LocaleId As Integer

C#
public int LocaleId { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The locale ID. Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTimeZoneCodeByLocalizedNameRequest Class
GetTimeZoneCodeByLocalizedNameRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetTimeZoneCodeByLocalizedNameRequest.LocalizedStandardName Property
[image]

Gets or sets the localized name to search for.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LocalizedStandardName As String

C#
public string LocalizedStandardName { get; set; }

C++

J#

JScript

Property Value
Type: String
The localized name to search for.

  Remarks
For example, for the Western Time Zone in the United States and Canada, specify "Pacific Standard Time" or, for summer, “Pacific Daylight Time”.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTimeZoneCodeByLocalizedNameRequest Class
GetTimeZoneCodeByLocalizedNameRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetTimeZoneCodeByLocalizedNameResponse Class
See Also Members
[image]

Contains the response from the GetTimeZoneCodeByLocalizedNameRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetTimeZoneCodeByLocalizedNameResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetTimeZoneCodeByLocalizedNameResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetTimeZoneCodeByLocalizedNameResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTimeZoneCodeByLocalizedNameResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetTimeZoneCodeByLocalizedNameRequest


GetTimeZoneCodeByLocalizedNameResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetTimeZoneCodeByLocalizedNameRequest class.

The following tables list the members exposed by the GetTimeZoneCodeByLocalizedNameResponse type.

Public Constructors

Name | Description
GetTimeZoneCodeByLocalizedNameResponse | Initializes a new instance of the GetTimeZoneCodeByLocalizedNameResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TimeZoneCode | Gets the time zone code that has the requested localized name.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetTimeZoneCodeByLocalizedNameResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetTimeZoneCodeByLocalizedNameRequest


GetTimeZoneCodeByLocalizedNameResponse Constructor
[image]

Initializes a new instance of the GetTimeZoneCodeByLocalizedNameResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetTimeZoneCodeByLocalizedNameResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTimeZoneCodeByLocalizedNameResponse Class
GetTimeZoneCodeByLocalizedNameResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetTimeZoneCodeByLocalizedNameResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetTimeZoneCodeByLocalizedNameResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetTimeZoneCodeByLocalizedNameRequest


GetTimeZoneCodeByLocalizedNameResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TimeZoneCode | Gets the time zone code that has the requested localized name.

See Also

Reference

GetTimeZoneCodeByLocalizedNameResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetTimeZoneCodeByLocalizedNameRequest


GetTimeZoneCodeByLocalizedNameResponse.TimeZoneCode Property
[image]

Gets the time zone code that has the requested localized name.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property TimeZoneCode As Integer

C#
public int TimeZoneCode { get; }

C++

J#

JScript

Property Value
Type: Int32
The time zone code that has the requested localized name.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTimeZoneCodeByLocalizedNameResponse Class
GetTimeZoneCodeByLocalizedNameResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetTrackingTokenEmailRequest Class
See Also Members
[image]

Contains the data that is needed to return a tracking token that can then be passed as a parameter to the SendEmailRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetTrackingTokenEmailRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetTrackingTokenEmailRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the GetTrackingTokenEmailResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Email entity. For a complete list of the required privileges, see GetTrackingTokenEmail Privileges.
Notes for Callers
The tracking token is used to correlate an email with a context that is specified in the Subject property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GetTrackingTokenEmailRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTrackingTokenEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GetTrackingTokenEmailResponse
Other Resources
E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


GetTrackingTokenEmailRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to return a tracking token that can then be passed as a parameter to the SendEmailRequest message.

The following tables list the members exposed by the GetTrackingTokenEmailRequest type.

Public Constructors

Name | Description
GetTrackingTokenEmailRequest | Initializes a new instance of the GetTrackingTokenEmailRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the context of the email. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetTrackingTokenEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetTrackingTokenEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


GetTrackingTokenEmailRequest Constructor
[image]

Initializes a new instance of the GetTrackingTokenEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetTrackingTokenEmailRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTrackingTokenEmailRequest Class
GetTrackingTokenEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetTrackingTokenEmailRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetTrackingTokenEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetTrackingTokenEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


GetTrackingTokenEmailRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Subject | Gets or sets the context of the email. Required.

See Also

Reference

GetTrackingTokenEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GetTrackingTokenEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


GetTrackingTokenEmailRequest.Subject Property
[image]

Gets or sets the context of the email. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Subject As String

C#
public string Subject { get; set; }

C++

J#

JScript

Property Value
Type: String
The context of the email.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTrackingTokenEmailRequest Class
GetTrackingTokenEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GetTrackingTokenEmailResponse Class
See Also Members
[image]

Contains the response from the GetTrackingTokenEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GetTrackingTokenEmailResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GetTrackingTokenEmailResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GetTrackingTokenEmailResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTrackingTokenEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GetTrackingTokenEmailRequest


GetTrackingTokenEmailResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetTrackingTokenEmailRequest class.

The following tables list the members exposed by the GetTrackingTokenEmailResponse type.

Public Constructors

Name | Description
GetTrackingTokenEmailResponse | Initializes a new instance of the GetTrackingTokenEmailResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TrackingToken | Gets the requested tracking token.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetTrackingTokenEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetTrackingTokenEmailRequest


GetTrackingTokenEmailResponse Constructor
[image]

Initializes a new instance of the GetTrackingTokenEmailResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetTrackingTokenEmailResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTrackingTokenEmailResponse Class
GetTrackingTokenEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GetTrackingTokenEmailResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetTrackingTokenEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetTrackingTokenEmailRequest


GetTrackingTokenEmailResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TrackingToken | Gets the requested tracking token.

See Also

Reference

GetTrackingTokenEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GetTrackingTokenEmailRequest


GetTrackingTokenEmailResponse.TrackingToken Property
[image]

Gets the requested tracking token.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property TrackingToken As String

C#
public string TrackingToken { get; }

C++

J#

JScript

Property Value
Type: String
The requested tracking token.
This value can be passed as a property in the SendEmailRequest message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetTrackingTokenEmailResponse Class
GetTrackingTokenEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GrantAccessRequest Class
See Also Example Members
[image]

Contains the data that is needed to grant a security principal (user or team) access to the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GrantAccessRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GrantAccessRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Grant the team read/write access to the lead.
var teamReference = new EntityReference(Team.EntityLogicalName, _teamId);
var grantAccessRequest = new GrantAccessRequest
{
    PrincipalAccess = new PrincipalAccess
    {
        AccessMask = AccessRights.ReadAccess | AccessRights.WriteAccess,
        Principal = teamReference
    },
    Target = leadReference
};

Console.WriteLine("Granting {0} to {1} ({2}) on the lead...\r\n",
    AccessRights.ReadAccess | AccessRights.WriteAccess, GetEntityReferenceString(teamReference), "Team");
_serviceProxy.Execute(grantAccessRequest);

var systemUser2Ref = new EntityReference(SystemUser.EntityLogicalName,
    _systemUserIds[1]);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute   method, which returns an instance of the GrantAccessResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the Target property and access rights on the specified record in the Target property. For a list of the required privileges, see GrantAccess Privileges.
Notes for Callers
This action applies to all child records of the target record. For all child records, if the caller does not have share privileges for those entity types, or share rights to the records, the child records are not shared. As a result, the owner of the instance, or a user who shares the instance with share rights, automatically has share rights to all child records of the target record. In this case, only the lack of privileges for a particular entity type prevents the child records from being shared.
For a description of how actions on a parent instance affect child records, see Cascading Behavior.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

Entity | Availability
Account | 0 (Server)
Annotation | 0 (Server)
Appointment | 0 (Server)
Campaign | 0 (Server)
CampaignActivity | 0 (Server)
CampaignResponse | 0 (Server)
Connection | 0 (Server)
Contact | 0 (Server)
Contract | 0 (Server)
ConvertRule | 0 (Server)
CustomerOpportunityRole | 0 (Server)
CustomerRelationship | 0 (Server)
DuplicateRule | 0 (Server)
Email | 0 (Server)
EmailServerProfile | 0 (Server)
Entitlement | 0 (Server)
Fax | 0 (Server)
Goal | 0 (Server)
GoalRollupQuery | 0 (Server)
Import | 0 (Server)
ImportFile | 0 (Server)
ImportMap | 0 (Server)
Incident | 0 (Server)
IncidentResolution | 0 (Server)
Invoice | 0 (Server)
Lead | 0 (Server)
Letter | 0 (Server)
List | 0 (Server)
Mailbox | 0 (Server)
MailMergeTemplate | 0 (Server)
msdyn_PostAlbum | 0 (Server)
msdyn_wallsavedqueryusersettings | 0 (Server)
Opportunity | 0 (Server)
OpportunityClose | 0 (Server)
OrderClose | 0 (Server)
PhoneCall | 0 (Server)
ProcessSession | 0 (Server)
Queue | 0 (Server)
Quote | 0 (Server)
QuoteClose | 0 (Server)
RecurringAppointmentMaster | 0 (Server)
Report | 0 (Server)
RoutingRule | 0 (Server)
SalesOrder | 0 (Server)
ServiceAppointment | 0 (Server)
SharePointDocumentLocation | 0 (Server)
SharePointSite | 0 (Server)
SLA | 0 (Server)
SLAKPIInstance | 0 (Server)
SocialActivity | 0 (Server)
SocialProfile | 0 (Server)
Task | 0 (Server)
Template | 0 (Server)
UserForm | 0 (Server)
UserQuery | 0 (Server)
UserQueryVisualization | 0 (Server)
Workflow | 0 (Server)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.GrantAccessRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
GrantAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace
GrantAccessResponse
Other Resources
How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


GrantAccessRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to grant a security principal (user or team) access to the specified record.

The following tables list the members exposed by the GrantAccessRequest type.

Public Constructors

Name | Description
GrantAccessRequest | Initializes a new instance of the GrantAccessRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PrincipalAccess | Gets or sets the team or user that is granted access to the specified record. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the entity that is the target of the request to grant access. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GrantAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GrantAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


GrantAccessRequest Constructor
[image]

Initializes a new instance of the GrantAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GrantAccessRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GrantAccessRequest Class
GrantAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GrantAccessRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GrantAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GrantAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


GrantAccessRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PrincipalAccess | Gets or sets the team or user that is granted access to the specified record. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the entity that is the target of the request to grant access. Required.

See Also

Reference

GrantAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
GrantAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


GrantAccessRequest.PrincipalAccess Property
[image]

Gets or sets the team or user that is granted access to the specified record. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PrincipalAccess As PrincipalAccess

C#
public PrincipalAccess PrincipalAccess { get; set; }

C++

J#

JScript

Property Value
Type: PrincipalAccess
The team or user that is granted access to the target record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GrantAccessRequest Class
GrantAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GrantAccessRequest.Target Property
[image]

Gets or sets the entity that is the target of the request to grant access. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The entity reference to the record that is the target of the request to grant access. This property value must be an entity reference for an entity that supports this message. For a list of supported entity types, see GrantAccessRequest.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GrantAccessRequest Class
GrantAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


GrantAccessResponse Class
See Also Members
[image]

Contains the response from the GrantAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class GrantAccessResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class GrantAccessResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.GrantAccessResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GrantAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace
GrantAccessRequest


GrantAccessResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GrantAccessRequest class.

The following tables list the members exposed by the GrantAccessResponse type.

Public Constructors

Name | Description
GrantAccessResponse | Initializes a new instance of the GrantAccessResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GrantAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GrantAccessRequest


GrantAccessResponse Constructor
[image]

Initializes a new instance of the GrantAccessResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GrantAccessResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GrantAccessResponse Class
GrantAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace


GrantAccessResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GrantAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GrantAccessRequest


GrantAccessResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GrantAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
GrantAccessRequest


ImportFieldTranslationRequest Class
See Also Members
[image]

Contains the data that is needed to import translations from a compressed file.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportFieldTranslationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportFieldTranslationRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute    method, which returns an instance of  ImportFieldTranslationResponse.
Privileges and Access Rights
To update the labels for specific records the user must have update privileges for those records.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ImportFieldTranslationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportFieldTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Localize product property values


ImportFieldTranslationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to import translations from a compressed file.

The following tables list the members exposed by the ImportFieldTranslationRequest type.

Public Constructors

Name | Description
ImportFieldTranslationRequest | Initializes a new instance of the ImportFieldTranslationRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TranslationFile | Gets or sets the compressed translations file. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportFieldTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Localize product property values


ImportFieldTranslationRequest Constructor
[image]

Initializes a new instance of the ImportFieldTranslationRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportFieldTranslationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportFieldTranslationRequest Class
ImportFieldTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportFieldTranslationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportFieldTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Localize product property values


ImportFieldTranslationRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TranslationFile | Gets or sets the compressed translations file. Required.

See Also

Reference

ImportFieldTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Localize product property values


ImportFieldTranslationRequest.TranslationFile Property
[image]

Gets or sets the compressed translations file. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TranslationFile As Byte()

C#
public byte[] TranslationFile { get; set; }

C++

J#

JScript

Property Value
Type: Byte[]
 The compressed translations file.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportFieldTranslationRequest Class
ImportFieldTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportFieldTranslationResponse Class
See Also Members
[image]

Contains the response from the ImportFieldTranslationRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportFieldTranslationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportFieldTranslationResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ImportFieldTranslationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportFieldTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ImportFieldTranslationRequest
Other Resources
Localize product property values


ImportFieldTranslationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ImportFieldTranslationRequest class.

The following tables list the members exposed by the ImportFieldTranslationResponse type.

Public Constructors

Name | Description
ImportFieldTranslationResponse | Initializes a new instance of the ImportFieldTranslationResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | JobId | Gets the ID of the import job that will be created to perform this import.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportFieldTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportFieldTranslationRequest

Other Resources

Localize product property values


ImportFieldTranslationResponse Constructor
[image]

Initializes a new instance of the ImportFieldTranslationResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportFieldTranslationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportFieldTranslationResponse Class
ImportFieldTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ImportFieldTranslationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportFieldTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportFieldTranslationRequest

Other Resources

Localize product property values


ImportFieldTranslationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | JobId | Gets the ID of the import job that will be created to perform this import.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ImportFieldTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportFieldTranslationRequest

Other Resources

Localize product property values


ImportFieldTranslationResponse.JobId Property
[image]

Gets the ID of the import job that will be created to perform this import.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property JobId As Guid

C#
public Guid JobId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the import job that will be created to perform this import. This corresponds to the ImportJob.ImportJobId attribute, which is the primary key for the ImportJob entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportFieldTranslationResponse Class
ImportFieldTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ImportMappingsImportMapRequest Class
See Also Example Members
[image]

Contains the data that is needed to import the XML representation of a data map and create an import map (data map) based on this data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportMappingsImportMapRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportMappingsImportMapRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create the import mapping from the XML
var request = new ImportMappingsImportMapRequest
{
    MappingsXml = _mappingXml,

    ReplaceIds = true,
};

Console.WriteLine(String.Concat("\nCreating mapping based on XML:\n",
    _mappingXml));

var response = (ImportMappingsImportMapResponse)
    _serviceProxy.Execute(request);

_newImportMapId = response.ImportMapId;

Console.WriteLine(String.Concat("\nNew import mapping created: ",
    _newImportMapId.Value));

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of ImportMappingsImportMapResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the ImportMap entity. For a complete list of required privileges, see ImportMappingsImportMap Privileges.
Notes for Callers
The XML data describing the data map must be well-formed and valid.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ImportMappingsImportMapRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ImportMappingsImportMapRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ImportMappingsImportMapResponse
Other Resources
Import Data in Microsoft Dynamics CRM
Create Data Maps
Add Transformation Mapping
Sample: Export and Import a Data Map
The Security Model of Microsoft Dynamics CRM


ImportMappingsImportMapRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to import the XML representation of a data map and create an import map (data map) based on this data.

The following tables list the members exposed by the ImportMappingsImportMapRequest type.

Public Constructors

Name | Description
ImportMappingsImportMapRequest | Initializes a new instance of the ImportMappingsImportMapRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MappingsXml | Gets or sets an XML representation of the data map. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReplaceIds | Gets or sets a value that indicates whether to import the entity record IDs contained in the XML representation of the data map. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportMappingsImportMapRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ImportMappingsImportMapResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Create Data Maps
Add Transformation Mapping
Sample: Export and Import a Data Map
The Security Model of Microsoft Dynamics CRM


ImportMappingsImportMapRequest Constructor
[image]

Initializes a new instance of the ImportMappingsImportMapRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportMappingsImportMapRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportMappingsImportMapRequest Class
ImportMappingsImportMapRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportMappingsImportMapRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportMappingsImportMapRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ImportMappingsImportMapResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Create Data Maps
Add Transformation Mapping
Sample: Export and Import a Data Map
The Security Model of Microsoft Dynamics CRM


ImportMappingsImportMapRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MappingsXml | Gets or sets an XML representation of the data map. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReplaceIds | Gets or sets a value that indicates whether to import the entity record IDs contained in the XML representation of the data map. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ImportMappingsImportMapRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ImportMappingsImportMapResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Create Data Maps
Add Transformation Mapping
Sample: Export and Import a Data Map
The Security Model of Microsoft Dynamics CRM


ImportMappingsImportMapRequest.MappingsXml Property
[image]

Gets or sets an XML representation of the data map. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MappingsXml As String

C#
public string MappingsXml { get; set; }

C++

J#

JScript

Property Value
Type: String
The XML representation of the data map.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportMappingsImportMapRequest Class
ImportMappingsImportMapRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportMappingsImportMapRequest.ReplaceIds Property
[image]

Gets or sets a value that indicates whether to import the entity record IDs contained in the XML representation of the data map. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReplaceIds As Boolean

C#
public bool ReplaceIds { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to import the entity record IDs contained in the XML representation of the data map.
false to import the entity record IDs, otherwise, true. The imported record IDs are used as primary keys for the entity records created in Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportMappingsImportMapRequest Class
ImportMappingsImportMapRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportMappingsImportMapResponse Class
See Also Members
[image]

Contains the response from the ImportMappingsImportMapRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportMappingsImportMapResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportMappingsImportMapResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ImportMappingsImportMapResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportMappingsImportMapResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ImportMappingsImportMapRequest


ImportMappingsImportMapResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ImportMappingsImportMapRequest class.

The following tables list the members exposed by the ImportMappingsImportMapResponse type.

Public Constructors

Name | Description
ImportMappingsImportMapResponse | Initializes a new instance of the ImportMappingsImportMapResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | ImportMapId | Gets the ID of the newly created import map (data map).
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportMappingsImportMapResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportMappingsImportMapRequest


ImportMappingsImportMapResponse Constructor
[image]

Initializes a new instance of the ImportMappingsImportMapResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportMappingsImportMapResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportMappingsImportMapResponse Class
ImportMappingsImportMapResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ImportMappingsImportMapResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportMappingsImportMapResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportMappingsImportMapRequest


ImportMappingsImportMapResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | ImportMapId | Gets the ID of the newly created import map (data map).
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ImportMappingsImportMapResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportMappingsImportMapRequest


ImportMappingsImportMapResponse.ImportMapId Property
[image]

Gets the ID of the newly created import map (data map).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ImportMapId As Guid

C#
public Guid ImportMapId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the newly created import map (data map). This corresponds to the ImportMap.ImportMapId attribute, which is the primary key for the ImportMap entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportMappingsImportMapResponse Class
ImportMappingsImportMapResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ImportRecordsImportRequest Class
See Also Example Members
[image]

Contains the data that is needed to submit an asynchronous job that uploads the transformed data into Microsoft Dynamics CRM.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportRecordsImportRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportRecordsImportRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Upload the records.
ImportRecordsImportRequest importRequest = new ImportRecordsImportRequest()
{
    ImportId = importId
};
ImportRecordsImportResponse importResponse =
    (ImportRecordsImportResponse)_serviceProxy.Execute(importRequest);
Console.WriteLine("Waiting for ImportRecords async job to complete");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of ImportRecordsImportResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Import entity and access rights on the record specified in the ImportId property. For a complete list of the required privileges, see ImportRecordsImport Privileges.
Notes for Callers
Pass the ID of the associated data import (import) in the ImportId property. The ID of the asynchronous job that runs in the background and uploads the data into Microsoft Dynamics CRM is returned in the AsyncOperationId property of the message response. All import files that are associated with the specified data import (import) are imported.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ImportRecordsImportRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ImportRecordsImportRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportResponse
Other Resources
Import Data in Microsoft Dynamics CRM
Import (data import) Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
ImportRecordsImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ImportRecordsImportRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to submit an asynchronous job that uploads the transformed data into Microsoft Dynamics CRM.

The following tables list the members exposed by the ImportRecordsImportRequest type.

Public Constructors

Name | Description
ImportRecordsImportRequest | Initializes a new instance of the ImportRecordsImportRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportId | Gets or sets the ID of the data import (import) that is associated with the asynchronous import records job. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportRecordsImportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Import (data import) Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
ImportRecordsImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ImportRecordsImportRequest Constructor
[image]

Initializes a new instance of the ImportRecordsImportRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportRecordsImportRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportRecordsImportRequest Class
ImportRecordsImportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportRecordsImportRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportRecordsImportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Import (data import) Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
ImportRecordsImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ImportRecordsImportRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportId | Gets or sets the ID of the data import (import) that is associated with the asynchronous import records job. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ImportRecordsImportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Import (data import) Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
ImportRecordsImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ImportRecordsImportRequest.ImportId Property
[image]

Gets or sets the ID of the data import (import) that is associated with the asynchronous import records job. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportId As Guid

C#
public Guid ImportId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the data import (import) that is associated with the asynchronous import records job. This corresponds to the Import.ImportId attribute, which is the primary key for the Import entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportRecordsImportRequest Class
ImportRecordsImportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportRecordsImportResponse Class
See Also Members
[image]

Contains the response from the ImportRecordsImportRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportRecordsImportResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportRecordsImportResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ImportRecordsImportResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportRecordsImportResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportRequest


ImportRecordsImportResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ImportRecordsImportRequest class.

The following tables list the members exposed by the ImportRecordsImportResponse type.

Public Constructors

Name | Description
ImportRecordsImportResponse | Initializes a new instance of the ImportRecordsImportResponse class.
Top

Public Properties

 | Name | Description
public property | AsyncOperationId | Gets the ID of the asynchronous import records job.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportRecordsImportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportRequest


ImportRecordsImportResponse Constructor
[image]

Initializes a new instance of the ImportRecordsImportResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportRecordsImportResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportRecordsImportResponse Class
ImportRecordsImportResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ImportRecordsImportResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportRecordsImportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportRequest


ImportRecordsImportResponse Properties
[image]

Public Properties

 | Name | Description
public property | AsyncOperationId | Gets the ID of the asynchronous import records job.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ImportRecordsImportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportRequest


ImportRecordsImportResponse.AsyncOperationId Property
[image]

Gets the ID of the asynchronous import records job.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AsyncOperationId As Guid

C#
public Guid AsyncOperationId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the asynchronous import records job.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportRecordsImportResponse Class
ImportRecordsImportResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ImportSolutionRequest Class
See Also Example Members
[image]

Contains the data that is needed to import a solution.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportSolutionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportSolutionRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Install or Upgrade a Solution

byte[] fileBytes = File.ReadAllBytes(ManagedSolutionLocation);

ImportSolutionRequest impSolReq = new ImportSolutionRequest()
{
    CustomizationFile = fileBytes
};

_serviceProxy.Execute(impSolReq);

Console.WriteLine("Imported Solution from {0}", ManagedSolutionLocation);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
This request is the only one that can be called either synchronously or asynchronously.
To use this messages synchronously, pass an instance of this class to the Execute method, which returns an instance of ImportSolutionResponse.
To use this message asynchronously, instantiate a ExecuteAsyncRequest and set the Request property to an instance of this class. Use the Execute method to return an ExecuteAsyncResponse. The Results property will contain the ImportSolutionResponse. Use the ExecuteAsyncResponse.AsyncJobId to track the success of the solution import.
Privileges and Access Rights
To perform this action, the caller must have privileges listed in ImportSolution Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ImportSolutionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ImportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


ImportSolutionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to import a solution.

The following tables list the members exposed by the ImportSolutionRequest type.

Public Constructors

Name | Description
ImportSolutionRequest | Initializes a new instance of the ImportSolutionRequest class
Top

Public Properties

 | Name | Description
public property | ConvertToManaged | Direct the system to convert any matching unmanaged customizations into your managed solution. Optional.
public property | CustomizationFile | Gets or sets the compressed solutions file to import. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportJobId | Gets or sets the ID of the import job that will be created to perform this import. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OverwriteUnmanagedCustomizations | Gets or sets whether any unmanaged customizations that have been applied over existing managed solution components should be overwritten. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PublishWorkflows | Gets or sets whether any processes (workflows) included in the solution should be activated after they are imported. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SkipProductUpdateDependencies | Gets or sets whether enforcement of dependencies related to product updates should be skipped.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportSolutionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


ImportSolutionRequest Constructor
[image]

Initializes a new instance of the ImportSolutionRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportSolutionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportSolutionRequest Class
ImportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportSolutionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportSolutionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


ImportSolutionRequest Properties
[image]

Public Properties

 | Name | Description
public property | ConvertToManaged | Direct the system to convert any matching unmanaged customizations into your managed solution. Optional.
public property | CustomizationFile | Gets or sets the compressed solutions file to import. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportJobId | Gets or sets the ID of the import job that will be created to perform this import. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OverwriteUnmanagedCustomizations | Gets or sets whether any unmanaged customizations that have been applied over existing managed solution components should be overwritten. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PublishWorkflows | Gets or sets whether any processes (workflows) included in the solution should be activated after they are imported. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SkipProductUpdateDependencies | Gets or sets whether enforcement of dependencies related to product updates should be skipped.

See Also

Reference

ImportSolutionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


ImportSolutionRequest.ConvertToManaged Property
[image]

Direct the system to convert any matching unmanaged customizations into your managed solution. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ConvertToManaged As Boolean

C#
public bool ConvertToManaged { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the system should convert any matching unmanaged customizations into your managed solution; otherwise, false.

  Remarks
This parameter is provided so that a system that is upgraded from Microsoft Dynamics CRM 4.0 and contains unmanaged customizations that should be part of a managed solution being installed.
This scenario applies to ISVs who created solutions for Microsoft Dynamics CRM 4.0 and want to use managed solutions after their customers upgrade.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportSolutionRequest Class
ImportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Plan For Solution Development


ImportSolutionRequest.CustomizationFile Property
[image]

Gets or sets the compressed solutions file to import. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CustomizationFile As Byte()

C#
public byte[] CustomizationFile { get; set; }

C++

J#

JScript

Property Value
Type: Byte[]
The compressed solutions file to import. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportSolutionRequest Class
ImportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportSolutionRequest.ImportJobId Property
[image]

Gets or sets the ID of the import job that will be created to perform this import. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportJobId As Guid

C#
public Guid ImportJobId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The the ID of the import job that will be created to perform this import. This corresponds to the ImportJob.ImportJobId attribute, which is the primary key for the ImportJob entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportSolutionRequest Class
ImportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportSolutionRequest.OverwriteUnmanagedCustomizations Property
[image]

Gets or sets whether any unmanaged customizations that have been applied over existing managed solution components should be overwritten. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OverwriteUnmanagedCustomizations As Boolean

C#
public bool OverwriteUnmanagedCustomizations { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the any unmanaged customizations that have been applied over existing managed solution components should be overwritten; otherwise, false.

  Remarks
This setting applies to scenarios where the managed solution is already installed and it is being installed again, perhaps as a newer version. When this value is false importing the solution will only update the managed solution components and any unmanaged customizations of those components will remain. By setting this property to true and importing the solution, any unmanaged customizations will be overwritten. You may want to do this as a way to re-initialize the solution.
  Note

                        To preserve any unmanaged customizations, export any unmanaged customizations before installing the update with this option set to true.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ImportSolutionRequest Class
ImportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportSolutionRequest.PublishWorkflows Property
[image]

Gets or sets whether any processes (workflows) included in the solution should be activated after they are imported. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PublishWorkflows As Boolean

C#
public bool PublishWorkflows { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the any processes (workflows) included in the solution should be activated after they are imported; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportSolutionRequest Class
ImportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportSolutionRequest.SkipProductUpdateDependencies Property
[image]

Gets or sets whether enforcement of dependencies related to product updates should be skipped.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SkipProductUpdateDependencies As Boolean

C#
public bool SkipProductUpdateDependencies { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if enforcement of dependencies related to product updates should be skipped; otherwise, false.

  Remarks
This member was added because solutions exported from a Microsoft Dynamics CRM Online organization with product updates enabled will contain dependencies on solution components that will not exist in an on-premises deployment of Microsoft Dynamics CRM 2011 or a Microsoft Dynamics CRM Online organization that has not installed the updates. This parameter allows for the installation of the solution to proceed. Any functionality in the solution that depends on missing solution components will not function as expected.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportSolutionRequest Class
ImportSolutionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportSolutionResponse Class
See Also Members
[image]

Contains the response from the ImportSolutionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportSolutionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportSolutionResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ImportSolutionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportSolutionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ImportSolutionRequest


ImportSolutionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ImportSolutionRequest class.

The following tables list the members exposed by the ImportSolutionResponse type.

Public Constructors

Name | Description
ImportSolutionResponse | Initializes a new instance of the ImportSolutionResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportSolutionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportSolutionRequest


ImportSolutionResponse Constructor
[image]

Initializes a new instance of the ImportSolutionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportSolutionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportSolutionResponse Class
ImportSolutionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ImportSolutionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportSolutionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportSolutionRequest


ImportSolutionResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ImportSolutionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportSolutionRequest


ImportTranslationRequest Class
See Also Members
[image]

Contains the data that is needed to import translations from a compressed file.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportTranslationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportTranslationRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the   Execute    method, which returns an instance of   ImportTranslationResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in ImportTranslation Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ImportTranslationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages
Extend the Metadata Model for Microsoft Dynamics CRM


ImportTranslationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to import translations from a compressed file.

The following tables list the members exposed by the ImportTranslationRequest type.

Public Constructors

Name | Description
ImportTranslationRequest | Initializes a new instance of the ImportTranslationRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportJobId | Gets or sets the ID of the import job that will be created to perform this import. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TranslationFile | Gets or sets the compressed translations file. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Extend the Metadata Model for Microsoft Dynamics CRM


ImportTranslationRequest Constructor
[image]

Initializes a new instance of the ImportTranslationRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportTranslationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportTranslationRequest Class
ImportTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportTranslationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Extend the Metadata Model for Microsoft Dynamics CRM


ImportTranslationRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportJobId | Gets or sets the ID of the import job that will be created to perform this import. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TranslationFile | Gets or sets the compressed translations file. Required.

See Also

Reference

ImportTranslationRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Extend the Metadata Model for Microsoft Dynamics CRM


ImportTranslationRequest.ImportJobId Property
[image]

Gets or sets the ID of the import job that will be created to perform this import. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportJobId As Guid

C#
public Guid ImportJobId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The the ID of the import job that will be created to perform this import. This corresponds to the ImportJob.ImportJobId attribute, which is the primary key for the ImportJob entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportTranslationRequest Class
ImportTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportTranslationRequest.TranslationFile Property
[image]

Gets or sets the compressed translations file. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TranslationFile As Byte()

C#
public byte[] TranslationFile { get; set; }

C++

J#

JScript

Property Value
Type: Byte[]
The compressed translations file. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportTranslationRequest Class
ImportTranslationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ImportTranslationResponse Class
See Also Members
[image]

Contains the response from the ImportTranslationRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ImportTranslationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ImportTranslationResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ImportTranslationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ImportTranslationRequest


ImportTranslationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ImportTranslationRequest class.

The following tables list the members exposed by the ImportTranslationResponse type.

Public Constructors

Name | Description
ImportTranslationResponse | Initializes a new instance of the T:Microsoft.Crm.Sdk.Messages.ImportTranslationResponse class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportTranslationRequest


ImportTranslationResponse Constructor
[image]

Initializes a new instance of the T:Microsoft.Crm.Sdk.Messages.ImportTranslationResponse class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportTranslationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImportTranslationResponse Class
ImportTranslationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ImportTranslationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportTranslationRequest


ImportTranslationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ImportTranslationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ImportTranslationRequest


InitializeFromRequest Class
See Also Members
[image]

Contains the data that is needed to initialize a new record from an existing record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class InitializeFromRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class InitializeFromRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the InitializeFromResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the entity that is specified in the TargetEntityName property and access rights on the record that is specified in the EntityMoniker property. For a complete list of the required privileges, see InitializeFrom Privileges.
Notes for Callers
To create a record from the result, pass the Entity value to the Create method or the CreateRequest message.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.InitializeFromRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializeFromRequest Members
Microsoft.Crm.Sdk.Messages Namespace
InitializeFromResponse
Other Resources
Account Entity Messages and Methods
BulkOperationLog (Quick Campaign Log) Entity Messages and Methods


InitializeFromRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to initialize a new record from an existing record.

The following tables list the members exposed by the InitializeFromRequest type.

Public Constructors

Name | Description
InitializeFromRequest | Initializes a new instance of the InitializeFromRequest class.
Top

Public Properties

 | Name | Description
public property | EntityMoniker | Gets or sets the record that is the source for initializing.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TargetEntityName | Gets or sets the logical name of the target entity.
public property | TargetFieldType | Gets or sets which attributes are to be initialized in the initialized instance.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InitializeFromRequest Class
Microsoft.Crm.Sdk.Messages Namespace
InitializeFromResponse

Other Resources

Account Entity Messages and Methods
BulkOperationLog (Quick Campaign Log) Entity Messages and Methods


InitializeFromRequest Constructor
[image]

Initializes a new instance of the InitializeFromRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InitializeFromRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializeFromRequest Class
InitializeFromRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InitializeFromRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InitializeFromRequest Class
Microsoft.Crm.Sdk.Messages Namespace
InitializeFromResponse

Other Resources

Account Entity Messages and Methods
BulkOperationLog (Quick Campaign Log) Entity Messages and Methods


InitializeFromRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityMoniker | Gets or sets the record that is the source for initializing.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TargetEntityName | Gets or sets the logical name of the target entity.
public property | TargetFieldType | Gets or sets which attributes are to be initialized in the initialized instance.

See Also

Reference

InitializeFromRequest Class
Microsoft.Crm.Sdk.Messages Namespace
InitializeFromResponse

Other Resources

Account Entity Messages and Methods
BulkOperationLog (Quick Campaign Log) Entity Messages and Methods


InitializeFromRequest.EntityMoniker Property
[image]

Gets or sets the record that is the source for initializing.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityMoniker As EntityReference

C#
public EntityReference EntityMoniker { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The record that is the source for initializing.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializeFromRequest Class
InitializeFromRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InitializeFromRequest.TargetEntityName Property
[image]

Gets or sets the logical name of the target entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TargetEntityName As String

C#
public string TargetEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the target entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializeFromRequest Class
InitializeFromRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InitializeFromRequest.TargetFieldType Property
[image]

Gets or sets which attributes are to be initialized in the initialized instance.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TargetFieldType As TargetFieldType

C#
public TargetFieldType TargetFieldType { get; set; }

C++

J#

JScript

Property Value
Type: TargetFieldType
Indicates which attributes are to be initialized in the initialized instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializeFromRequest Class
InitializeFromRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InitializeFromResponse Class
See Also Members
[image]

Contains the response from the InitializeFromRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class InitializeFromResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class InitializeFromResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.InitializeFromResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializeFromResponse Members
Microsoft.Crm.Sdk.Messages Namespace
InitializeFromRequest


InitializeFromResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the InitializeFromRequest class.

The following tables list the members exposed by the InitializeFromResponse type.

Public Constructors

Name | Description
InitializeFromResponse | Initializes a new instance of the InitializeFromResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the initialized instance.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InitializeFromResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InitializeFromRequest


InitializeFromResponse Constructor
[image]

Initializes a new instance of the InitializeFromResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InitializeFromResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializeFromResponse Class
InitializeFromResponse Members
Microsoft.Crm.Sdk.Messages Namespace


InitializeFromResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InitializeFromResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InitializeFromRequest


InitializeFromResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the initialized instance.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

InitializeFromResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InitializeFromRequest


InitializeFromResponse.Entity Property
[image]

Gets the initialized instance.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The initialized instance. To create a record, pass this value to the Create method or to a CreateRequest message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializeFromResponse Class
InitializeFromResponse Members
Microsoft.Crm.Sdk.Messages Namespace


InputArgument Class
See Also Members
[image]

Contains custom application data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class InputArgument
    Inherits DataCollection(Of String, Object)

C#
public sealed class InputArgument : DataCollection<string,Object>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Crm.Sdk.Messages.InputArgument
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputArgument Members
Microsoft.Crm.Sdk.Messages Namespace
InputArguments


InputArgument Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains custom application data.

The following tables list the members exposed by the InputArgument type.

Public Constructors

Name | Description
InputArgument | Initializes a new instance of the InputArgument class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

InputArgument Class
Microsoft.Crm.Sdk.Messages Namespace
InputArguments


InputArgument Constructor
[image]

Initializes a new instance of the InputArgument class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InputArgument ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputArgument Class
InputArgument Members
Microsoft.Crm.Sdk.Messages Namespace


InputArgument Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

InputArgument Class
Microsoft.Crm.Sdk.Messages Namespace
InputArguments


InputArgument Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

InputArgument Class
Microsoft.Crm.Sdk.Messages Namespace
InputArguments


InputArgumentCollection Class
See Also Members
[image]

Contains a collection of InputArgument objects.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
<DefaultMemberAttribute("Item")> _
Public NotInheritable Class InputArgumentCollection
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
[DefaultMemberAttribute("Item")]
public sealed class InputArgumentCollection : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.InputArgumentCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputArgumentCollection Members
Microsoft.Crm.Sdk.Messages Namespace


InputArgumentCollection Members
See Also Constructors Methods Properties
[image]

Contains a collection of InputArgument objects.

The following tables list the members exposed by the InputArgumentCollection type.

Public Constructors

Name | Description
InputArgumentCollection | Initializes a new instance of the InputArgumentCollection class.
Top

Public Properties

 | Name | Description
public property | Arguments | Gets or sets the InputArgument collection.
public property | Count | Indicates the number of elements in the Arguments collection.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Item | Gets or sets the element at the specified index in the collection.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Adds an input argument object to the Arguments collection.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InputArgumentCollection Class
Microsoft.Crm.Sdk.Messages Namespace


InputArgumentCollection Constructor
[image]

Initializes a new instance of the InputArgumentCollection class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InputArgumentCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputArgumentCollection Class
InputArgumentCollection Members
Microsoft.Crm.Sdk.Messages Namespace


InputArgumentCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Adds an input argument object to the Arguments collection.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InputArgumentCollection Class
Microsoft.Crm.Sdk.Messages Namespace


InputArgumentCollection.Add Method
[image]

Adds an input argument object to the Arguments collection.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Add ( _
    key As String, _
    value As Object _
)

C#
public void Add (
    string key,
    Object value
)

C++

J#

JScript

Parameters
key
Type: String. A key that uniquely identifies the input argument in the collection.
value
Type: Object. The input argument.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputArgumentCollection Class
InputArgumentCollection Members
Microsoft.Crm.Sdk.Messages Namespace


InputArgumentCollection Properties
[image]

Public Properties

 | Name | Description
public property | Arguments | Gets or sets the InputArgument collection.
public property | Count | Indicates the number of elements in the Arguments collection.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Item | Gets or sets the element at the specified index in the collection.

See Also

Reference

InputArgumentCollection Class
Microsoft.Crm.Sdk.Messages Namespace


InputArgumentCollection.Arguments Property
[image]

Gets or sets the InputArgument collection.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Arguments As InputArgument

C#
[DataMemberAttribute]
public InputArgument Arguments { get; set; }

C++

J#

JScript

Property Value
Type: InputArgument
An input argument.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputArgumentCollection Class
InputArgumentCollection Members
Microsoft.Crm.Sdk.Messages Namespace


InputArgumentCollection.Count Property
[image]

Indicates the number of elements in the Arguments collection.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Count As Integer

C#
public int Count { get; }

C++

J#

JScript

Property Value
Type: Int32
The number of elements in the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputArgumentCollection Class
InputArgumentCollection Members
Microsoft.Crm.Sdk.Messages Namespace


InputArgumentCollection.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputArgumentCollection Class
InputArgumentCollection Members
Microsoft.Crm.Sdk.Messages Namespace


InputArgumentCollection.Item Property
[image]

Gets or sets the element at the specified index in the collection.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Default Property Item ( _
    key As String _
) As Object

C#
public Object this [
    string key
] { get; set; }

C++

J#

JScript

Parameters
key
Type: String. The key used to identify a target element in the collection.
Property Value
Type: Object
The input argument. You must cast the returned object to the correct type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputArgumentCollection Class
InputArgumentCollection Members
Microsoft.Crm.Sdk.Messages Namespace


InstallSampleDataRequest Class
See Also Example Members
[image]

Contains the data that is needed to install the sample data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class InstallSampleDataRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class InstallSampleDataRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

    // Prompt user to install/uninstall sample data.
    Console.WriteLine("Would you like to:");
    Console.WriteLine("1) Install sample data for Microsoft Dynamics CRM?");
    Console.WriteLine("2) Uninstall sample data for Microsoft Dynamics CRM?");
    Console.Write("Press [1] to Install, [2] to Uninstall: ");
    String answer = Console.ReadLine();

    // Update the sample data based on the user's response.
    switch (answer)
    {
        case "1":
            Console.WriteLine("Installing sample data...");
            InstallSampleDataRequest request =
                new InstallSampleDataRequest();
            InstallSampleDataResponse response =
                (InstallSampleDataResponse)_serviceProxy.Execute(request);
            Console.WriteLine("Sample data successfully installed.");
            break;
        case "2":
            Console.WriteLine("Uninstalling sample data...");
            UninstallSampleDataRequest request2 =
                new UninstallSampleDataRequest();
            UninstallSampleDataResponse response2 =
                (UninstallSampleDataResponse)_serviceProxy.Execute(request2);
            Console.WriteLine("Sample data successfully uninstalled.");
            break;
        default:
            Console.WriteLine("Neither option was selected. No changes have been made to your records.");
            break;
    }

}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute method, which returns an instance of  InstallSampleDataResponse.
Privileges and Access Rights
For a complete list of the privileges required, see InstallSampleData Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.InstallSampleDataRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
InstallSampleDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace
UnInstallSampleDataResponse
UnInstallSampleDataRequest
Other Resources
Sample Data for Microsoft Dynamics CRM
Sample: Install or Remove Sample Data


InstallSampleDataRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to install the sample data.

The following tables list the members exposed by the InstallSampleDataRequest type.

Public Constructors

Name | Description
InstallSampleDataRequest | Initializes a new instance of the InstallSampleDataRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InstallSampleDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnInstallSampleDataResponse
UnInstallSampleDataRequest

Other Resources

Sample Data for Microsoft Dynamics CRM
Sample: Install or Remove Sample Data


InstallSampleDataRequest Constructor
[image]

Initializes a new instance of the InstallSampleDataRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InstallSampleDataRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstallSampleDataRequest Class
InstallSampleDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InstallSampleDataRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InstallSampleDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnInstallSampleDataResponse
UnInstallSampleDataRequest

Other Resources

Sample Data for Microsoft Dynamics CRM
Sample: Install or Remove Sample Data


InstallSampleDataRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

InstallSampleDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnInstallSampleDataResponse
UnInstallSampleDataRequest

Other Resources

Sample Data for Microsoft Dynamics CRM
Sample: Install or Remove Sample Data


InstallSampleDataResponse Class
See Also Members
[image]

Contains the response from the InstallSampleDataRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class InstallSampleDataResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class InstallSampleDataResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.InstallSampleDataResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstallSampleDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace
InstallSampleDataRequest


InstallSampleDataResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the InstallSampleDataRequest class.

The following tables list the members exposed by the InstallSampleDataResponse type.

Public Constructors

Name | Description
InstallSampleDataResponse | Initializes a new instance of the InstallSampleDataResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InstallSampleDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InstallSampleDataRequest


InstallSampleDataResponse Constructor
[image]

Initializes a new instance of the InstallSampleDataResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InstallSampleDataResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstallSampleDataResponse Class
InstallSampleDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace


InstallSampleDataResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InstallSampleDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InstallSampleDataRequest


InstallSampleDataResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

InstallSampleDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InstallSampleDataRequest


InstantiateFiltersRequest Class
See Also Example Members
[image]

Contains the data that is needed to instantiate a set of filters for CRM for Outlook for the specified user.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class InstantiateFiltersRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class InstantiateFiltersRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Call InstantiateFiltersRequest
Console.WriteLine("Retrieving user's ID and creating the template collection");
WhoAmIRequest whoAmI = new WhoAmIRequest();
Guid id = ((WhoAmIResponse)_serviceProxy.Execute(whoAmI)).UserId;
EntityReferenceCollection templates = new EntityReferenceCollection();
templates.Add(new EntityReference(
    SavedQuery.EntityLogicalName,
    _offlineTemplate));

Console.WriteLine("Activating the selected offline templates for this user");
InstantiateFiltersRequest request = new InstantiateFiltersRequest
{
    UserId = id,
    TemplateCollection = templates
};
InstantiateFiltersResponse response =
    (InstantiateFiltersResponse)_serviceProxy.Execute(request);
Console.WriteLine();

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage

                        Pass an instance of this class to the
                        Execute   method, which returns an instance of  InstantiateFiltersResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the UserQuery entity and access rights on the records specified in the TemplateCollection property. For a complete list of the privileges required, see InstantiateFilters Privileges.
Notes for Callers
This creates a user query record for the specified user for each filter specified in the TemplateCollection property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.InstantiateFiltersRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
InstantiateFiltersRequest Members
Microsoft.Crm.Sdk.Messages Namespace
InstantiateFiltersResponse
Other Resources
Offline and Outlook Filters and Templates
Sample: Retrieve Outlook Filters


InstantiateFiltersRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to instantiate a set of filters for CRM for Outlook for the specified user.

The following tables list the members exposed by the InstantiateFiltersRequest type.

Public Constructors

Name | Description
InstantiateFiltersRequest | Initializes a new instance of the InstantiateFiltersRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TemplateCollection | Gets or sets the set of filters to instantiate for the user.
public property | UserId | Gets or sets the ID of the user that will own the user query records created.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InstantiateFiltersRequest Class
Microsoft.Crm.Sdk.Messages Namespace
InstantiateFiltersResponse

Other Resources

Offline and Outlook Filters and Templates
Sample: Retrieve Outlook Filters


InstantiateFiltersRequest Constructor
[image]

Initializes a new instance of the InstantiateFiltersRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InstantiateFiltersRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateFiltersRequest Class
InstantiateFiltersRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InstantiateFiltersRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InstantiateFiltersRequest Class
Microsoft.Crm.Sdk.Messages Namespace
InstantiateFiltersResponse

Other Resources

Offline and Outlook Filters and Templates
Sample: Retrieve Outlook Filters


InstantiateFiltersRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TemplateCollection | Gets or sets the set of filters to instantiate for the user.
public property | UserId | Gets or sets the ID of the user that will own the user query records created.

See Also

Reference

InstantiateFiltersRequest Class
Microsoft.Crm.Sdk.Messages Namespace
InstantiateFiltersResponse

Other Resources

Offline and Outlook Filters and Templates
Sample: Retrieve Outlook Filters


InstantiateFiltersRequest.TemplateCollection Property
[image]

Gets or sets the set of filters to instantiate for the user.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateCollection As EntityReferenceCollection

C#
public EntityReferenceCollection TemplateCollection { get; set; }

C++

J#

JScript

Property Value
Type: EntityReferenceCollection
The set of filters to instantiate for the user. This must be a collection of entity references for the SavedQuery entity and the SavedQuery.Type attribute value for each must be OutlookFilters or OfflineFilters.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateFiltersRequest Class
InstantiateFiltersRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InstantiateFiltersRequest.UserId Property
[image]

Gets or sets the ID of the user that will own the user query records created.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserId As Guid

C#
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The user that will own the user query records created. This corresponds to the SystemUser.SystemUserId property, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateFiltersRequest Class
InstantiateFiltersRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InstantiateFiltersResponse Class
See Also Members
[image]

Contains the response from the InstantiateFiltersRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class InstantiateFiltersResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class InstantiateFiltersResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.InstantiateFiltersResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateFiltersResponse Members
Microsoft.Crm.Sdk.Messages Namespace
InstantiateFiltersRequest


InstantiateFiltersResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the InstantiateFiltersRequest class.

The following tables list the members exposed by the InstantiateFiltersResponse type.

Public Constructors

Name | Description
InstantiateFiltersResponse | Initializes a new instance of the InstantiateFiltersResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InstantiateFiltersResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InstantiateFiltersRequest


InstantiateFiltersResponse Constructor
[image]

Initializes a new instance of the InstantiateFiltersResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InstantiateFiltersResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateFiltersResponse Class
InstantiateFiltersResponse Members
Microsoft.Crm.Sdk.Messages Namespace


InstantiateFiltersResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InstantiateFiltersResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InstantiateFiltersRequest


InstantiateFiltersResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

InstantiateFiltersResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InstantiateFiltersRequest


InstantiateTemplateRequest Class
See Also Example Members
[image]

Contains the parameters that are needed to create an email message from a template (email template).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class InstantiateTemplateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class InstantiateTemplateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Use the InstantiateTemplate message to create an e-mail message using a template.
InstantiateTemplateRequest instTemplateReq = new InstantiateTemplateRequest
{
    TemplateId = _templateId,
    ObjectId = _accountId,
    ObjectType = Account.EntityLogicalName
};
InstantiateTemplateResponse instTemplateResp = (InstantiateTemplateResponse)_serviceProxy.Execute(instTemplateReq);

// Serialize the email message to XML, and save to a file.
XmlSerializer serializer = new XmlSerializer(typeof(InstantiateTemplateResponse));
string filename = "email-message.xml";
using (StreamWriter writer = new StreamWriter(filename))
{
    serializer.Serialize(writer, instTemplateResp);
}
Console.WriteLine("Created e-mail using the template.");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  InstantiateTemplateResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Email and  Template entities and access rights on the specified record in the TemplateId and ObjectId properties. For a complete list of the required privileges, see InstantiateTemplate Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.InstantiateTemplateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
InstantiateTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
E-mail Activity Entities
Template (E-Mail Template) Entity Messages and Methods
Template Entity Privileges
Sample: Instantiate an Email Using a Template


InstantiateTemplateRequest Members
See Also Constructors Methods Properties
[image]

Contains the parameters that are needed to create an email message from a template (email template).

The following tables list the members exposed by the InstantiateTemplateRequest type.

Public Constructors

Name | Description
InstantiateTemplateRequest | Initializes a new instance of the InstantiateTemplateRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ObjectId | Gets or sets the ID of the record that the email is regarding. Required.
public property | ObjectType | Gets or sets the type of entity that is represented by the ObjectId property. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TemplateId | Gets or sets the ID of the template. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InstantiateTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

E-mail Activity Entities
Template (E-Mail Template) Entity Messages and Methods
Template Entity Privileges
Sample: Instantiate an Email Using a Template


InstantiateTemplateRequest Constructor
[image]

Initializes a new instance of the InstantiateTemplateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InstantiateTemplateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateTemplateRequest Class
InstantiateTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InstantiateTemplateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InstantiateTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

E-mail Activity Entities
Template (E-Mail Template) Entity Messages and Methods
Template Entity Privileges
Sample: Instantiate an Email Using a Template


InstantiateTemplateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ObjectId | Gets or sets the ID of the record that the email is regarding. Required.
public property | ObjectType | Gets or sets the type of entity that is represented by the ObjectId property. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TemplateId | Gets or sets the ID of the template. Required.

See Also

Reference

InstantiateTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

E-mail Activity Entities
Template (E-Mail Template) Entity Messages and Methods
Template Entity Privileges
Sample: Instantiate an Email Using a Template


InstantiateTemplateRequest.ObjectId Property
[image]

Gets or sets the ID of the record that the email is regarding. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ObjectId As Guid

C#
public Guid ObjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the record that the email is regarding. This must be the ID of an entity that has a relationship to the ActivityPointer entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateTemplateRequest Class
InstantiateTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InstantiateTemplateRequest.ObjectType Property
[image]

Gets or sets the type of entity that is represented by the ObjectId property. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ObjectType As String

C#
public string ObjectType { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateTemplateRequest Class
InstantiateTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InstantiateTemplateRequest.TemplateId Property
[image]

Gets or sets the ID of the template. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the template that corresponds to the Template.TemplateId attribute, which is the primary key for the Template entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateTemplateRequest Class
InstantiateTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


InstantiateTemplateResponse Class
See Also Members
[image]

Contains the response from the InstantiateTemplateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class InstantiateTemplateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class InstantiateTemplateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.InstantiateTemplateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
InstantiateTemplateRequest


InstantiateTemplateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the InstantiateTemplateRequest class.

The following tables list the members exposed by the InstantiateTemplateResponse type.

Public Constructors

Name | Description
InstantiateTemplateResponse | Initializes a new instance of the InstantiateTemplateResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the instantiated email records.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InstantiateTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InstantiateTemplateRequest


InstantiateTemplateResponse Constructor
[image]

Initializes a new instance of the InstantiateTemplateResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InstantiateTemplateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateTemplateResponse Class
InstantiateTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


InstantiateTemplateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InstantiateTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InstantiateTemplateRequest


InstantiateTemplateResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the instantiated email records.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

InstantiateTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
InstantiateTemplateRequest


InstantiateTemplateResponse.EntityCollection Property
[image]

Gets the instantiated email records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of the instantiated email records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InstantiateTemplateResponse Class
InstantiateTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


IsBackOfficeInstalledRequest Class
See Also Members
[image]

Deprecated. Checks whether Microsoft Dynamics GP 9.0 is installed.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class IsBackOfficeInstalledRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class IsBackOfficeInstalledRequest : OrganizationRequest

C++

J#

JScript

  Remarks
This value is stored in Organization.IsSOPIntegrationEnabled attribute. Use the RetrieveRequest class or Retrieve method.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.IsBackOfficeInstalledRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsBackOfficeInstalledRequest Members
Microsoft.Crm.Sdk.Messages Namespace
IsBackOfficeInstalledResponse
Other Resources
IsBackOfficeInstalled Privileges


IsBackOfficeInstalledRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Checks whether Microsoft Dynamics GP 9.0 is installed.

The following tables list the members exposed by the IsBackOfficeInstalledRequest type.

Public Constructors

Name | Description
IsBackOfficeInstalledRequest | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IsBackOfficeInstalledRequest Class
Microsoft.Crm.Sdk.Messages Namespace
IsBackOfficeInstalledResponse

Other Resources

IsBackOfficeInstalled Privileges


IsBackOfficeInstalledRequest Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IsBackOfficeInstalledRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsBackOfficeInstalledRequest Class
IsBackOfficeInstalledRequest Members
Microsoft.Crm.Sdk.Messages Namespace


IsBackOfficeInstalledRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IsBackOfficeInstalledRequest Class
Microsoft.Crm.Sdk.Messages Namespace
IsBackOfficeInstalledResponse

Other Resources

IsBackOfficeInstalled Privileges


IsBackOfficeInstalledRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

IsBackOfficeInstalledRequest Class
Microsoft.Crm.Sdk.Messages Namespace
IsBackOfficeInstalledResponse

Other Resources

IsBackOfficeInstalled Privileges


IsBackOfficeInstalledResponse Class
See Also Members
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class IsBackOfficeInstalledResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class IsBackOfficeInstalledResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.IsBackOfficeInstalledResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsBackOfficeInstalledResponse Members
Microsoft.Crm.Sdk.Messages Namespace
IsBackOfficeInstalledRequest


IsBackOfficeInstalledResponse Members
See Also Constructors Methods Properties
[image]

Deprecated.

The following tables list the members exposed by the IsBackOfficeInstalledResponse type.

Public Constructors

Name | Description
IsBackOfficeInstalledResponse | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsInstalled | Deprecated.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IsBackOfficeInstalledResponse Class
Microsoft.Crm.Sdk.Messages Namespace
IsBackOfficeInstalledRequest


IsBackOfficeInstalledResponse Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IsBackOfficeInstalledResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsBackOfficeInstalledResponse Class
IsBackOfficeInstalledResponse Members
Microsoft.Crm.Sdk.Messages Namespace


IsBackOfficeInstalledResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IsBackOfficeInstalledResponse Class
Microsoft.Crm.Sdk.Messages Namespace
IsBackOfficeInstalledRequest


IsBackOfficeInstalledResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsInstalled | Deprecated.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

IsBackOfficeInstalledResponse Class
Microsoft.Crm.Sdk.Messages Namespace
IsBackOfficeInstalledRequest


IsBackOfficeInstalledResponse.IsInstalled Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsInstalled As Boolean

C#
public bool IsInstalled { get; }

C++

J#

JScript

Property Value
Type: Boolean
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsBackOfficeInstalledResponse Class
IsBackOfficeInstalledResponse Members
Microsoft.Crm.Sdk.Messages Namespace


IsComponentCustomizableRequest Class
See Also Members
[image]

Contains the data that is needed to determine whether a solution component is customizable.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class IsComponentCustomizableRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class IsComponentCustomizableRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute    method, which returns an instance of  the IsComponentCustomizableResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the privileges that are listed in IsComponentCustomizable Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.IsComponentCustomizableRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsComponentCustomizableRequest Members
Microsoft.Crm.Sdk.Messages Namespace
IsComponentCustomizableResponse
Other Resources
SolutionComponent Entity Messages and Methods


IsComponentCustomizableRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to determine whether a solution component is customizable.

The following tables list the members exposed by the IsComponentCustomizableRequest type.

Public Constructors

Name | Description
IsComponentCustomizableRequest | Initializes a new instance of the IsComponentCustomizableRequest class.
Top

Public Properties

 | Name | Description
public property | ComponentId | Gets or sets the ID of the solution component. Required.
public property | ComponentType | Gets or sets the value that represents the solution component. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IsComponentCustomizableRequest Class
Microsoft.Crm.Sdk.Messages Namespace
IsComponentCustomizableResponse

Other Resources

SolutionComponent Entity Messages and Methods


IsComponentCustomizableRequest Constructor
[image]

Initializes a new instance of the IsComponentCustomizableRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IsComponentCustomizableRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsComponentCustomizableRequest Class
IsComponentCustomizableRequest Members
Microsoft.Crm.Sdk.Messages Namespace


IsComponentCustomizableRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IsComponentCustomizableRequest Class
Microsoft.Crm.Sdk.Messages Namespace
IsComponentCustomizableResponse

Other Resources

SolutionComponent Entity Messages and Methods


IsComponentCustomizableRequest Properties
[image]

Public Properties

 | Name | Description
public property | ComponentId | Gets or sets the ID of the solution component. Required.
public property | ComponentType | Gets or sets the value that represents the solution component. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

IsComponentCustomizableRequest Class
Microsoft.Crm.Sdk.Messages Namespace
IsComponentCustomizableResponse

Other Resources

SolutionComponent Entity Messages and Methods


IsComponentCustomizableRequest.ComponentId Property
[image]

Gets or sets the ID of the solution component. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ComponentId As Guid

C#
public Guid ComponentId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the solution component. This corresponds to the SolutionComponent. SolutionComponentId attribute, which is the primary key for the SolutionComponent entity.

  Remarks
For solution components that derive from the MetadataBase class, this value is the MetadataId property.For other solution components, use the record ID value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsComponentCustomizableRequest Class
IsComponentCustomizableRequest Members
Microsoft.Crm.Sdk.Messages Namespace


IsComponentCustomizableRequest.ComponentType Property
[image]

Gets or sets the value that represents the solution component. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ComponentType As Integer

C#
public int ComponentType { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The value that represents the solution component. Required.

  Remarks
The enumeration componenttype defines the supported range of values for this property. You can access the available values by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project. These values are defined by the global option set Component Type (componenttype).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsComponentCustomizableRequest Class
IsComponentCustomizableRequest Members
Microsoft.Crm.Sdk.Messages Namespace


IsComponentCustomizableResponse Class
See Also Members
[image]

Contains the response from the IsComponentCustomizableRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class IsComponentCustomizableResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class IsComponentCustomizableResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.IsComponentCustomizableResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsComponentCustomizableResponse Members
Microsoft.Crm.Sdk.Messages Namespace
IsComponentCustomizableRequest


IsComponentCustomizableResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the IsComponentCustomizableRequest class.

The following tables list the members exposed by the IsComponentCustomizableResponse type.

Public Constructors

Name | Description
IsComponentCustomizableResponse | Initializes a new instance of the IsComponentCustomizableResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsComponentCustomizable | Gets the value that indicates whether a solution component is customizable.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IsComponentCustomizableResponse Class
Microsoft.Crm.Sdk.Messages Namespace
IsComponentCustomizableRequest


IsComponentCustomizableResponse Constructor
[image]

Initializes a new instance of the IsComponentCustomizableResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IsComponentCustomizableResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsComponentCustomizableResponse Class
IsComponentCustomizableResponse Members
Microsoft.Crm.Sdk.Messages Namespace


IsComponentCustomizableResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IsComponentCustomizableResponse Class
Microsoft.Crm.Sdk.Messages Namespace
IsComponentCustomizableRequest


IsComponentCustomizableResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsComponentCustomizable | Gets the value that indicates whether a solution component is customizable.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

IsComponentCustomizableResponse Class
Microsoft.Crm.Sdk.Messages Namespace
IsComponentCustomizableRequest


IsComponentCustomizableResponse.IsComponentCustomizable Property
[image]

Gets the value that indicates whether a solution component is customizable.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsComponentCustomizable As Boolean

C#
public bool IsComponentCustomizable { get; }

C++

J#

JScript

Property Value
Type: Boolean
the value that indicates whether a solution component is customizable.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsComponentCustomizableResponse Class
IsComponentCustomizableResponse Members
Microsoft.Crm.Sdk.Messages Namespace


IsValidStateTransitionRequest Class
See Also Example Members
[image]

Contains the data that is needed to validate the state transition.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class IsValidStateTransitionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class IsValidStateTransitionRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create an EntityReference to represent an open case
EntityReference caseReference = new EntityReference()
{
    LogicalName = Incident.EntityLogicalName,
    Id = _caseIncidentId
};

IsValidStateTransitionRequest checkState =
    new IsValidStateTransitionRequest();

// Set the transition request to an open case
checkState.Entity = caseReference;

// Check to see if a new state of "resolved" and
// a new status of "problem solved" are valid
checkState.NewState = IncidentState.Resolved.ToString();
checkState.NewStatus = (int)incident_statuscode.ProblemSolved;

// Execute the request
IsValidStateTransitionResponse checkStateResponse =
    (IsValidStateTransitionResponse)_serviceProxy.Execute(checkState);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the IsValidStateTransitionResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the Entity property and access rights on the specified record in the Entity property. For a complete list of the required privileges, see IsValidStateTransition Privileges.
Notes for Callers
If an incident (case) or opportunity is already closed or canceled, or if an incident (case) has open activities, an exception is thrown.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Incident | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.IsValidStateTransitionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IsValidStateTransitionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
IsValidStateTransitionResponse
Other Resources
Opportunity Entities
Incident (Case) Entities
IsValidStateTransition Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


IsValidStateTransitionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to validate the state transition.

The following tables list the members exposed by the IsValidStateTransitionRequest type.

Public Constructors

Name | Description
IsValidStateTransitionRequest | Initializes a new instance of the IsValidStateTransitionRequest class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets or sets the entity reference for the record whose transition state is validated.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | NewState | Gets or sets the proposed new state for the record.
public property | NewStatus | Gets or sets the proposed new status for the record.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IsValidStateTransitionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
IsValidStateTransitionResponse

Other Resources

Opportunity Entities
Incident (Case) Entities
IsValidStateTransition Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


IsValidStateTransitionRequest Constructor
[image]

Initializes a new instance of the IsValidStateTransitionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IsValidStateTransitionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsValidStateTransitionRequest Class
IsValidStateTransitionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


IsValidStateTransitionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IsValidStateTransitionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
IsValidStateTransitionResponse

Other Resources

Opportunity Entities
Incident (Case) Entities
IsValidStateTransition Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


IsValidStateTransitionRequest Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets or sets the entity reference for the record whose transition state is validated.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | NewState | Gets or sets the proposed new state for the record.
public property | NewStatus | Gets or sets the proposed new status for the record.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

IsValidStateTransitionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
IsValidStateTransitionResponse

Other Resources

Opportunity Entities
Incident (Case) Entities
IsValidStateTransition Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


IsValidStateTransitionRequest.Entity Property
[image]

Gets or sets the entity reference for the record whose transition state is validated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As EntityReference

C#
public EntityReference Entity { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The entity reference for the record whose transition state is validated.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsValidStateTransitionRequest Class
IsValidStateTransitionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


IsValidStateTransitionRequest.NewState Property
[image]

Gets or sets the proposed new state for the record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property NewState As String

C#
public string NewState { get; set; }

C++

J#

JScript

Property Value
Type: String
The proposed new state for the record.

  Remarks
This property corresponds to the Entityname.StateCode attribute. It specifies the possible states for an entity record. It is shown as the Status in the Microsoft Dynamics CRM application. For a list of the state values, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.  For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsValidStateTransitionRequest Class
IsValidStateTransitionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


IsValidStateTransitionRequest.NewStatus Property
[image]

Gets or sets the proposed new status for the record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property NewStatus As Integer

C#
public int NewStatus { get; set; }

C++

J#

JScript

Property Value
Type:  Int32
The proposed new status for the record.

  Remarks
The NewStatus property corresponds to the Entityname.StatusCode attribute. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system sets the appropriate corresponding status value. For a list of the status values, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.  For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsValidStateTransitionRequest Class
IsValidStateTransitionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


IsValidStateTransitionResponse Class
See Also Members
[image]

Contains the response from the IsValidStateTransitionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class IsValidStateTransitionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class IsValidStateTransitionResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.IsValidStateTransitionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsValidStateTransitionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
IsValidStateTransitionRequest


IsValidStateTransitionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the IsValidStateTransitionRequest class.

The following tables list the members exposed by the IsValidStateTransitionResponse type.

Public Constructors

Name | Description
IsValidStateTransitionResponse | Initializes a new instance of the IsValidStateTransitionResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsValid | Gets the value that indicates whether the state transition is valid.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IsValidStateTransitionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
IsValidStateTransitionRequest


IsValidStateTransitionResponse Constructor
[image]

Initializes a new instance of the IsValidStateTransitionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IsValidStateTransitionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsValidStateTransitionResponse Class
IsValidStateTransitionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


IsValidStateTransitionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IsValidStateTransitionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
IsValidStateTransitionRequest


IsValidStateTransitionResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsValid | Gets the value that indicates whether the state transition is valid.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

IsValidStateTransitionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
IsValidStateTransitionRequest


IsValidStateTransitionResponse.IsValid Property
[image]

Gets the value that indicates whether the state transition is valid.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsValid As Boolean

C#
public bool IsValid { get; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether the state transition is valid.

true if the state transition is valid; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsValidStateTransitionResponse Class
IsValidStateTransitionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


LocalTimeFromUtcTimeRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the local time for the specified Coordinated Universal Time (UTC).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LocalTimeFromUtcTimeRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LocalTimeFromUtcTimeRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
private void RetrieveLocalTimeFromUTCTime(DateTime utcTime)
{
    if (!_timeZoneCode.HasValue)
        return;

    var request = new LocalTimeFromUtcTimeRequest
    {
        TimeZoneCode = _timeZoneCode.Value,
        UtcTime = utcTime.ToUniversalTime()
    };

    var response = (LocalTimeFromUtcTimeResponse)_serviceProxy.Execute(request);

    Console.WriteLine(String.Concat("Calling LocalTimeFromUtcTimeRequest.  UTC time: ",
        utcTime.ToString("MM/dd/yyyy HH:mm:ss"), ". Local time: ",
        response.LocalTime.ToString("MM/dd/yyyy HH:mm:ss")));
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the LocalTimeFromUtcTimeResponse class.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.LocalTimeFromUtcTimeRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
LocalTimeFromUtcTimeRequest Members
Microsoft.Crm.Sdk.Messages Namespace
LocalTimeFromUtcTimeResponse
Other Resources
LocalTimeFromUtcTime Privileges
Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LocalTimeFromUtcTimeRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the local time for the specified Coordinated Universal Time (UTC).

The following tables list the members exposed by the LocalTimeFromUtcTimeRequest type.

Public Constructors

Name | Description
LocalTimeFromUtcTimeRequest | Initializes a new instance of the LocalTimeFromUtcTimeRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TimeZoneCode | Gets or sets the time zone code.
public property | UtcTime | Gets or sets the Coordinated Universal Time (UTC).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LocalTimeFromUtcTimeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LocalTimeFromUtcTimeResponse

Other Resources

LocalTimeFromUtcTime Privileges
Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LocalTimeFromUtcTimeRequest Constructor
[image]

Initializes a new instance of the LocalTimeFromUtcTimeRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LocalTimeFromUtcTimeRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalTimeFromUtcTimeRequest Class
LocalTimeFromUtcTimeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LocalTimeFromUtcTimeRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LocalTimeFromUtcTimeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LocalTimeFromUtcTimeResponse

Other Resources

LocalTimeFromUtcTime Privileges
Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LocalTimeFromUtcTimeRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TimeZoneCode | Gets or sets the time zone code.
public property | UtcTime | Gets or sets the Coordinated Universal Time (UTC).

See Also

Reference

LocalTimeFromUtcTimeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LocalTimeFromUtcTimeResponse

Other Resources

LocalTimeFromUtcTime Privileges
Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LocalTimeFromUtcTimeRequest.TimeZoneCode Property
[image]

Gets or sets the time zone code.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TimeZoneCode As Integer

C#
public int TimeZoneCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The time zone code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalTimeFromUtcTimeRequest Class
LocalTimeFromUtcTimeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LocalTimeFromUtcTimeRequest.UtcTime Property
[image]

Gets or sets the Coordinated Universal Time (UTC).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UtcTime As DateTime

C#
public DateTime UtcTime { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The Coordinated Universal Time (UTC).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalTimeFromUtcTimeRequest Class
LocalTimeFromUtcTimeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LocalTimeFromUtcTimeResponse Class
See Also Members
[image]

Contains the response from the LocalTimeFromUtcTimeRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LocalTimeFromUtcTimeResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LocalTimeFromUtcTimeResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.LocalTimeFromUtcTimeResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalTimeFromUtcTimeResponse Members
Microsoft.Crm.Sdk.Messages Namespace
LocalTimeFromUtcTimeRequest


LocalTimeFromUtcTimeResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the LocalTimeFromUtcTimeRequest class.

The following tables list the members exposed by the LocalTimeFromUtcTimeResponse type.

Public Constructors

Name | Description
LocalTimeFromUtcTimeResponse | Initializes a new instance of the LocalTimeFromUtcTimeResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | LocalTime | Gets the time that is represented as local time.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LocalTimeFromUtcTimeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LocalTimeFromUtcTimeRequest


LocalTimeFromUtcTimeResponse Constructor
[image]

Initializes a new instance of the LocalTimeFromUtcTimeResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LocalTimeFromUtcTimeResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalTimeFromUtcTimeResponse Class
LocalTimeFromUtcTimeResponse Members
Microsoft.Crm.Sdk.Messages Namespace


LocalTimeFromUtcTimeResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LocalTimeFromUtcTimeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LocalTimeFromUtcTimeRequest


LocalTimeFromUtcTimeResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | LocalTime | Gets the time that is represented as local time.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

LocalTimeFromUtcTimeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LocalTimeFromUtcTimeRequest


LocalTimeFromUtcTimeResponse.LocalTime Property
[image]

Gets the time that is represented as local time.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LocalTime As DateTime

C#
public DateTime LocalTime { get; }

C++

J#

JScript

Property Value
Type: DateTime
The time that is represented as local time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalTimeFromUtcTimeResponse Class
LocalTimeFromUtcTimeResponse Members
Microsoft.Crm.Sdk.Messages Namespace


LockInvoicePricingRequest Class
See Also Example Members
[image]

Contains the data that is needed to lock the total price of products and services that are specified in the invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LockInvoicePricingRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LockInvoicePricingRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Relock the invoice pricing
LockInvoicePricingRequest lockInvoiceRequest =
    new LockInvoicePricingRequest()
    {
        InvoiceId = _invoiceId
    };
_serviceProxy.Execute(lockInvoiceRequest);

Console.WriteLine("Invoice pricing relocked.");

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the LockInvoicePricingResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Invoice entity and access rights on the specified record in the InvoiceId property.
For a complete list of the required privileges, see LockInvoicePricing Privileges.
Notes for Callers
When the invoice pricing is locked, changes to underlying price lists (price levels) do not affect the prices for an invoice.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.LockInvoicePricingRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
LockInvoicePricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace
LockInvoicePricingResponse
Other Resources
LockInvoicePricing Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LockInvoicePricingRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to lock the total price of products and services that are specified in the invoice.

The following tables list the members exposed by the LockInvoicePricingRequest type.

Public Constructors

Name | Description
LockInvoicePricingRequest | Initializes a new instance of the LockInvoicePricingRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InvoiceId | Gets or sets the ID of the invoice.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LockInvoicePricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LockInvoicePricingResponse

Other Resources

LockInvoicePricing Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LockInvoicePricingRequest Constructor
[image]

Initializes a new instance of the LockInvoicePricingRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LockInvoicePricingRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockInvoicePricingRequest Class
LockInvoicePricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LockInvoicePricingRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LockInvoicePricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LockInvoicePricingResponse

Other Resources

LockInvoicePricing Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LockInvoicePricingRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InvoiceId | Gets or sets the ID of the invoice.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

LockInvoicePricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LockInvoicePricingResponse

Other Resources

LockInvoicePricing Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LockInvoicePricingRequest.InvoiceId Property
[image]

Gets or sets the ID of the invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property InvoiceId As Guid

C#
public Guid InvoiceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the invoice. This corresponds to the Invoice.InvoiceId attribute, which is the primary key for the Invoice entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockInvoicePricingRequest Class
LockInvoicePricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LockInvoicePricingResponse Class
See Also Members
[image]

Contains the response from the LockInvoicePricingRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LockInvoicePricingResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LockInvoicePricingResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.LockInvoicePricingResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockInvoicePricingResponse Members
Microsoft.Crm.Sdk.Messages Namespace
LockInvoicePricingRequest


LockInvoicePricingResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the LockInvoicePricingRequest class.

The following tables list the members exposed by the LockInvoicePricingResponse type.

Public Constructors

Name | Description
LockInvoicePricingResponse | Initializes a new instance of the LockInvoicePricingResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LockInvoicePricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LockInvoicePricingRequest


LockInvoicePricingResponse Constructor
[image]

Initializes a new instance of the LockInvoicePricingResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LockInvoicePricingResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockInvoicePricingResponse Class
LockInvoicePricingResponse Members
Microsoft.Crm.Sdk.Messages Namespace


LockInvoicePricingResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LockInvoicePricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LockInvoicePricingRequest


LockInvoicePricingResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

LockInvoicePricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LockInvoicePricingRequest


LockSalesOrderPricingRequest Class
See Also Example Members
[image]

Contains the data that is needed to lock the total price of products and services that are specified in the sales order (order).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LockSalesOrderPricingRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LockSalesOrderPricingRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Relock the order pricing
LockSalesOrderPricingRequest lockOrderRequest =
    new LockSalesOrderPricingRequest()
    {
        SalesOrderId = _salesOrderId
    };
_serviceProxy.Execute(lockOrderRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the LockSalesOrderPricingResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the SalesOrder entity and access rights on the specified record in the SalesOrderId property.
For a complete list of the required privileges, see LockSalesOrderPricing Privileges.
Notes for Callers
When the sales order pricing is locked, changes to underlying price lists (price levels) do not affect the prices for a sales order (order).

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.LockSalesOrderPricingRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
LockSalesOrderPricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace
LockSalesOrderPricingResponse
Other Resources
LockSalesOrderPricing Privileges
Quote, Order and Invoice Entities
SalesOrder (Order) Entity Messages and Methods
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LockSalesOrderPricingRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to lock the total price of products and services that are specified in the sales order (order).

The following tables list the members exposed by the LockSalesOrderPricingRequest type.

Public Constructors

Name | Description
LockSalesOrderPricingRequest | Initializes a new instance of the LockSalesOrderPricingRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SalesOrderId | Gets or sets the ID of the sales order.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LockSalesOrderPricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LockSalesOrderPricingResponse

Other Resources

LockSalesOrderPricing Privileges
Quote, Order and Invoice Entities
SalesOrder (Order) Entity Messages and Methods
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LockSalesOrderPricingRequest Constructor
[image]

Initializes a new instance of the LockSalesOrderPricingRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LockSalesOrderPricingRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockSalesOrderPricingRequest Class
LockSalesOrderPricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LockSalesOrderPricingRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LockSalesOrderPricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LockSalesOrderPricingResponse

Other Resources

LockSalesOrderPricing Privileges
Quote, Order and Invoice Entities
SalesOrder (Order) Entity Messages and Methods
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LockSalesOrderPricingRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SalesOrderId | Gets or sets the ID of the sales order.

See Also

Reference

LockSalesOrderPricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LockSalesOrderPricingResponse

Other Resources

LockSalesOrderPricing Privileges
Quote, Order and Invoice Entities
SalesOrder (Order) Entity Messages and Methods
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


LockSalesOrderPricingRequest.SalesOrderId Property
[image]

Gets or sets the ID of the sales order.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SalesOrderId As Guid

C#
public Guid SalesOrderId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the sales order. This corresponds to the SalesOrder.SalesOrderId attribute, which is the primary key for the SalesOrder entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockSalesOrderPricingRequest Class
LockSalesOrderPricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LockSalesOrderPricingResponse Class
See Also Members
[image]

Contains the response from the LockSalesOrderPricingRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LockSalesOrderPricingResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LockSalesOrderPricingResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.LockSalesOrderPricingResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockSalesOrderPricingResponse Members
Microsoft.Crm.Sdk.Messages Namespace
LockSalesOrderPricingRequest


LockSalesOrderPricingResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the LockSalesOrderPricingRequest class.

The following tables list the members exposed by the LockSalesOrderPricingResponse type.

Public Constructors

Name | Description
LockSalesOrderPricingResponse | Initializes a new instance of the LockSalesOrderPricingResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LockSalesOrderPricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LockSalesOrderPricingRequest


LockSalesOrderPricingResponse Constructor
[image]

Initializes a new instance of the LockSalesOrderPricingResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LockSalesOrderPricingResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockSalesOrderPricingResponse Class
LockSalesOrderPricingResponse Members
Microsoft.Crm.Sdk.Messages Namespace


LockSalesOrderPricingResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LockSalesOrderPricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LockSalesOrderPricingRequest


LockSalesOrderPricingResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

LockSalesOrderPricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LockSalesOrderPricingRequest


LogFailureBulkOperationRequest Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LogFailureBulkOperationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LogFailureBulkOperationRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.LogFailureBulkOperationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
LogFailureBulkOperationResponse
Other Resources
LogFailureBulkOperation Privileges


LogFailureBulkOperationRequest Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the LogFailureBulkOperationRequest type.

Public Constructors

Name | Description
LogFailureBulkOperationRequest | For internal use only.
Top

Public Properties

 | Name | Description
public property | AdditionalInfo | For internal use only.
public property | BulkOperationId | For internal use only.
public property | ErrorCode | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Message | For internal use only.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RegardingObjectId | For internal use only.
public property | RegardingObjectTypeCode | For internal use only.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LogFailureBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LogFailureBulkOperationResponse

Other Resources

LogFailureBulkOperation Privileges


LogFailureBulkOperationRequest Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LogFailureBulkOperationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationRequest Class
LogFailureBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogFailureBulkOperationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LogFailureBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LogFailureBulkOperationResponse

Other Resources

LogFailureBulkOperation Privileges


LogFailureBulkOperationRequest Properties
[image]

Public Properties

 | Name | Description
public property | AdditionalInfo | For internal use only.
public property | BulkOperationId | For internal use only.
public property | ErrorCode | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Message | For internal use only.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RegardingObjectId | For internal use only.
public property | RegardingObjectTypeCode | For internal use only.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

LogFailureBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LogFailureBulkOperationResponse

Other Resources

LogFailureBulkOperation Privileges


LogFailureBulkOperationRequest.AdditionalInfo Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AdditionalInfo As String

C#
public string AdditionalInfo { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationRequest Class
LogFailureBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogFailureBulkOperationRequest.BulkOperationId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationRequest Class
LogFailureBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogFailureBulkOperationRequest.ErrorCode Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ErrorCode As Integer

C#
public int ErrorCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationRequest Class
LogFailureBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogFailureBulkOperationRequest.Message Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Message As String

C#
public string Message { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationRequest Class
LogFailureBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogFailureBulkOperationRequest.RegardingObjectId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingObjectId As Guid

C#
public Guid RegardingObjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationRequest Class
LogFailureBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogFailureBulkOperationRequest.RegardingObjectTypeCode Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingObjectTypeCode As Integer

C#
public int RegardingObjectTypeCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationRequest Class
LogFailureBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogFailureBulkOperationResponse Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LogFailureBulkOperationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LogFailureBulkOperationResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.LogFailureBulkOperationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace
LogFailureBulkOperationRequest


LogFailureBulkOperationResponse Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the LogFailureBulkOperationResponse type.

Public Constructors

Name | Description
LogFailureBulkOperationResponse | For internal use only.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LogFailureBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LogFailureBulkOperationRequest


LogFailureBulkOperationResponse Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LogFailureBulkOperationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogFailureBulkOperationResponse Class
LogFailureBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


LogFailureBulkOperationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LogFailureBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LogFailureBulkOperationRequest


LogFailureBulkOperationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

LogFailureBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LogFailureBulkOperationRequest


LogSuccessBulkOperationRequest Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LogSuccessBulkOperationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LogSuccessBulkOperationRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.LogSuccessBulkOperationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
LogSuccessBulkOperationResponse
Other Resources
LogSuccessBulkOperation Privileges


LogSuccessBulkOperationRequest Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the LogSuccessBulkOperationRequest type.

Public Constructors

Name | Description
LogSuccessBulkOperationRequest | For internal use only.
Top

Public Properties

 | Name | Description
public property | AdditionalInfo | For internal use only.
public property | BulkOperationId | For internal use only.
public property | CreatedObjectId | For internal use only.
public property | CreatedObjectTypeCode | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RegardingObjectId | For internal use only.
public property | RegardingObjectTypeCode | For internal use only.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LogSuccessBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LogSuccessBulkOperationResponse

Other Resources

LogSuccessBulkOperation Privileges


LogSuccessBulkOperationRequest Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LogSuccessBulkOperationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationRequest Class
LogSuccessBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogSuccessBulkOperationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LogSuccessBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LogSuccessBulkOperationResponse

Other Resources

LogSuccessBulkOperation Privileges


LogSuccessBulkOperationRequest Properties
[image]

Public Properties

 | Name | Description
public property | AdditionalInfo | For internal use only.
public property | BulkOperationId | For internal use only.
public property | CreatedObjectId | For internal use only.
public property | CreatedObjectTypeCode | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RegardingObjectId | For internal use only.
public property | RegardingObjectTypeCode | For internal use only.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

LogSuccessBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LogSuccessBulkOperationResponse

Other Resources

LogSuccessBulkOperation Privileges


LogSuccessBulkOperationRequest.AdditionalInfo Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AdditionalInfo As String

C#
public string AdditionalInfo { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationRequest Class
LogSuccessBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogSuccessBulkOperationRequest.BulkOperationId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationRequest Class
LogSuccessBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogSuccessBulkOperationRequest.CreatedObjectId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CreatedObjectId As Guid

C#
public Guid CreatedObjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationRequest Class
LogSuccessBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogSuccessBulkOperationRequest.CreatedObjectTypeCode Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CreatedObjectTypeCode As Integer

C#
public int CreatedObjectTypeCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationRequest Class
LogSuccessBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogSuccessBulkOperationRequest.RegardingObjectId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingObjectId As Guid

C#
public Guid RegardingObjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationRequest Class
LogSuccessBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogSuccessBulkOperationRequest.RegardingObjectTypeCode Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingObjectTypeCode As Integer

C#
public int RegardingObjectTypeCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationRequest Class
LogSuccessBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LogSuccessBulkOperationResponse Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LogSuccessBulkOperationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LogSuccessBulkOperationResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.LogSuccessBulkOperationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace
LogSuccessBulkOperationRequest


LogSuccessBulkOperationResponse Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the LogSuccessBulkOperationResponse type.

Public Constructors

Name | Description
LogSuccessBulkOperationResponse | For internal use only.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LogSuccessBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LogSuccessBulkOperationRequest


LogSuccessBulkOperationResponse Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LogSuccessBulkOperationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LogSuccessBulkOperationResponse Class
LogSuccessBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


LogSuccessBulkOperationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LogSuccessBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LogSuccessBulkOperationRequest


LogSuccessBulkOperationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

LogSuccessBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LogSuccessBulkOperationRequest


LoseOpportunityRequest Class
See Also Example Members
[image]

Contains the data that is needed to set the state of an opportunity to Lost.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LoseOpportunityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LoseOpportunityRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
var loseOppRequest = new LoseOpportunityRequest
{
    OpportunityClose = new OpportunityClose
    {
        OpportunityId = new EntityReference
            (Opportunity.EntityLogicalName, _loseOpportunityId)
    },
    Status = new OptionSetValue((int)opportunity_statuscode.Canceled)
};

_serviceProxy.Execute(loseOppRequest);

Console.WriteLine("Opportunity closed as Lost.");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the LoseOpportunityResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the OpportunityClose entity. For a complete list of the required privileges, see LoseOpportunity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.LoseOpportunityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
LoseOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
LoseOpportunityResponse
Other Resources
LoseOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


LoseOpportunityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to set the state of an opportunity to Lost.

The following tables list the members exposed by the LoseOpportunityRequest type.

Public Constructors

Name | Description
LoseOpportunityRequest | Initializes a new instance of the LoseOpportunityRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityClose | Gets or sets the opportunity close activity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a status of the opportunity. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LoseOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LoseOpportunityResponse

Other Resources

LoseOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


LoseOpportunityRequest Constructor
[image]

Initializes a new instance of the LoseOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LoseOpportunityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LoseOpportunityRequest Class
LoseOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LoseOpportunityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LoseOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LoseOpportunityResponse

Other Resources

LoseOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


LoseOpportunityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityClose | Gets or sets the opportunity close activity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a status of the opportunity. Required.

See Also

Reference

LoseOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
LoseOpportunityResponse

Other Resources

LoseOpportunity Privileges
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


LoseOpportunityRequest.OpportunityClose Property
[image]

Gets or sets the opportunity close activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityClose As Entity

C#
public Entity OpportunityClose { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The opportunity close activity. This is an instance of the OpportunityClose class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LoseOpportunityRequest Class
LoseOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LoseOpportunityRequest.Status Property
[image]

Gets or sets a status of the opportunity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The a status of the opportunity.

  Remarks
The Status property corresponds to the Opportunity.StatusCode attribute. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system automatically sets the corresponding status value. For a list of the status values, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.  For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LoseOpportunityRequest Class
LoseOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


LoseOpportunityResponse Class
See Also Members
[image]

Contains the response from the LoseOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class LoseOpportunityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class LoseOpportunityResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.LoseOpportunityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LoseOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
LoseOpportunityRequest


LoseOpportunityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the LoseOpportunityRequest class.

The following tables list the members exposed by the LoseOpportunityResponse type.

Public Constructors

Name | Description
LoseOpportunityResponse | Initializes a new instance of the LoseOpportunityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LoseOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LoseOpportunityRequest


LoseOpportunityResponse Constructor
[image]

Initializes a new instance of the LoseOpportunityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LoseOpportunityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LoseOpportunityResponse Class
LoseOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


LoseOpportunityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LoseOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LoseOpportunityRequest


LoseOpportunityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

LoseOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
LoseOpportunityRequest


MakeAvailableToOrganizationReportRequest Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MakeAvailableToOrganizationReportRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MakeAvailableToOrganizationReportRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.MakeAvailableToOrganizationReportRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationReportRequest Members
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationReportResponse
Other Resources
MakeAvailableToOrganizationReport Privileges


MakeAvailableToOrganizationReportRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class.

The following tables list the members exposed by the MakeAvailableToOrganizationReportRequest type.

Public Constructors

Name | Description
MakeAvailableToOrganizationReportRequest | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Deprecated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MakeAvailableToOrganizationReportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationReportResponse

Other Resources

MakeAvailableToOrganizationReport Privileges


MakeAvailableToOrganizationReportRequest Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MakeAvailableToOrganizationReportRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationReportRequest Class
MakeAvailableToOrganizationReportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MakeAvailableToOrganizationReportRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MakeAvailableToOrganizationReportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationReportResponse

Other Resources

MakeAvailableToOrganizationReport Privileges


MakeAvailableToOrganizationReportRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Deprecated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

MakeAvailableToOrganizationReportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationReportResponse

Other Resources

MakeAvailableToOrganizationReport Privileges


MakeAvailableToOrganizationReportRequest.ReportId Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReportId As Guid

C#
public Guid ReportId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationReportRequest Class
MakeAvailableToOrganizationReportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MakeAvailableToOrganizationReportResponse Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MakeAvailableToOrganizationReportResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MakeAvailableToOrganizationReportResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.MakeAvailableToOrganizationReportResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationReportResponse Members
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationReportRequest


MakeAvailableToOrganizationReportResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

The following tables list the members exposed by the MakeAvailableToOrganizationReportResponse type.

Public Constructors

Name | Description
MakeAvailableToOrganizationReportResponse | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MakeAvailableToOrganizationReportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationReportRequest


MakeAvailableToOrganizationReportResponse Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MakeAvailableToOrganizationReportResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationReportResponse Class
MakeAvailableToOrganizationReportResponse Members
Microsoft.Crm.Sdk.Messages Namespace


MakeAvailableToOrganizationReportResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MakeAvailableToOrganizationReportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationReportRequest


MakeAvailableToOrganizationReportResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

MakeAvailableToOrganizationReportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationReportRequest


MakeAvailableToOrganizationTemplateRequest Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MakeAvailableToOrganizationTemplateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MakeAvailableToOrganizationTemplateRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.MakeAvailableToOrganizationTemplateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationTemplateResponse
Other Resources
MakeAvailableToOrganizationTemplate Privileges


MakeAvailableToOrganizationTemplateRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class.

The following tables list the members exposed by the MakeAvailableToOrganizationTemplateRequest type.

Public Constructors

Name | Description
MakeAvailableToOrganizationTemplateRequest | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TemplateId | Deprecated.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MakeAvailableToOrganizationTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationTemplateResponse

Other Resources

MakeAvailableToOrganizationTemplate Privileges


MakeAvailableToOrganizationTemplateRequest Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MakeAvailableToOrganizationTemplateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationTemplateRequest Class
MakeAvailableToOrganizationTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MakeAvailableToOrganizationTemplateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MakeAvailableToOrganizationTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationTemplateResponse

Other Resources

MakeAvailableToOrganizationTemplate Privileges


MakeAvailableToOrganizationTemplateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TemplateId | Deprecated.

See Also

Reference

MakeAvailableToOrganizationTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationTemplateResponse

Other Resources

MakeAvailableToOrganizationTemplate Privileges


MakeAvailableToOrganizationTemplateRequest.TemplateId Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationTemplateRequest Class
MakeAvailableToOrganizationTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MakeAvailableToOrganizationTemplateResponse Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MakeAvailableToOrganizationTemplateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MakeAvailableToOrganizationTemplateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.MakeAvailableToOrganizationTemplateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationTemplateRequest


MakeAvailableToOrganizationTemplateResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

The following tables list the members exposed by the MakeAvailableToOrganizationTemplateResponse type.

Public Constructors

Name | Description
MakeAvailableToOrganizationTemplateResponse | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MakeAvailableToOrganizationTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationTemplateRequest


MakeAvailableToOrganizationTemplateResponse Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MakeAvailableToOrganizationTemplateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeAvailableToOrganizationTemplateResponse Class
MakeAvailableToOrganizationTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


MakeAvailableToOrganizationTemplateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MakeAvailableToOrganizationTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationTemplateRequest


MakeAvailableToOrganizationTemplateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

MakeAvailableToOrganizationTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeAvailableToOrganizationTemplateRequest


MakeUnavailableToOrganizationReportRequest Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MakeUnavailableToOrganizationReportRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MakeUnavailableToOrganizationReportRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.MakeUnavailableToOrganizationReportRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationReportRequest Members
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationReportResponse
Other Resources
MakeUnavailableToOrganizationReport Privileges


MakeUnavailableToOrganizationReportRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class.

The following tables list the members exposed by the MakeUnavailableToOrganizationReportRequest type.

Public Constructors

Name | Description
MakeUnavailableToOrganizationReportRequest | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Deprecated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MakeUnavailableToOrganizationReportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationReportResponse

Other Resources

MakeUnavailableToOrganizationReport Privileges


MakeUnavailableToOrganizationReportRequest Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MakeUnavailableToOrganizationReportRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationReportRequest Class
MakeUnavailableToOrganizationReportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MakeUnavailableToOrganizationReportRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MakeUnavailableToOrganizationReportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationReportResponse

Other Resources

MakeUnavailableToOrganizationReport Privileges


MakeUnavailableToOrganizationReportRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Deprecated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

MakeUnavailableToOrganizationReportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationReportResponse

Other Resources

MakeUnavailableToOrganizationReport Privileges


MakeUnavailableToOrganizationReportRequest.ReportId Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReportId As Guid

C#
public Guid ReportId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationReportRequest Class
MakeUnavailableToOrganizationReportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MakeUnavailableToOrganizationReportResponse Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MakeUnavailableToOrganizationReportResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MakeUnavailableToOrganizationReportResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.MakeUnavailableToOrganizationReportResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationReportResponse Members
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationReportRequest


MakeUnavailableToOrganizationReportResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

The following tables list the members exposed by the MakeUnavailableToOrganizationReportResponse type.

Public Constructors

Name | Description
MakeUnavailableToOrganizationReportResponse | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MakeUnavailableToOrganizationReportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationReportRequest


MakeUnavailableToOrganizationReportResponse Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MakeUnavailableToOrganizationReportResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationReportResponse Class
MakeUnavailableToOrganizationReportResponse Members
Microsoft.Crm.Sdk.Messages Namespace


MakeUnavailableToOrganizationReportResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MakeUnavailableToOrganizationReportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationReportRequest


MakeUnavailableToOrganizationReportResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

MakeUnavailableToOrganizationReportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationReportRequest


MakeUnavailableToOrganizationTemplateRequest Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MakeUnavailableToOrganizationTemplateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MakeUnavailableToOrganizationTemplateRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.MakeUnavailableToOrganizationTemplateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationTemplateResponse
Other Resources
MakeUnavailableToOrganizationTemplate Privileges


MakeUnavailableToOrganizationTemplateRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class.

The following tables list the members exposed by the MakeUnavailableToOrganizationTemplateRequest type.

Public Constructors

Name | Description
MakeUnavailableToOrganizationTemplateRequest | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TemplateId | Deprecated.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MakeUnavailableToOrganizationTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationTemplateResponse

Other Resources

MakeUnavailableToOrganizationTemplate Privileges


MakeUnavailableToOrganizationTemplateRequest Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MakeUnavailableToOrganizationTemplateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationTemplateRequest Class
MakeUnavailableToOrganizationTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MakeUnavailableToOrganizationTemplateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MakeUnavailableToOrganizationTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationTemplateResponse

Other Resources

MakeUnavailableToOrganizationTemplate Privileges


MakeUnavailableToOrganizationTemplateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TemplateId | Deprecated.

See Also

Reference

MakeUnavailableToOrganizationTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationTemplateResponse

Other Resources

MakeUnavailableToOrganizationTemplate Privileges


MakeUnavailableToOrganizationTemplateRequest.TemplateId Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationTemplateRequest Class
MakeUnavailableToOrganizationTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MakeUnavailableToOrganizationTemplateResponse Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MakeUnavailableToOrganizationTemplateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MakeUnavailableToOrganizationTemplateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.MakeUnavailableToOrganizationTemplateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationTemplateRequest


MakeUnavailableToOrganizationTemplateResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

The following tables list the members exposed by the MakeUnavailableToOrganizationTemplateResponse type.

Public Constructors

Name | Description
MakeUnavailableToOrganizationTemplateResponse | Deprecated.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MakeUnavailableToOrganizationTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationTemplateRequest


MakeUnavailableToOrganizationTemplateResponse Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MakeUnavailableToOrganizationTemplateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MakeUnavailableToOrganizationTemplateResponse Class
MakeUnavailableToOrganizationTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


MakeUnavailableToOrganizationTemplateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MakeUnavailableToOrganizationTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationTemplateRequest


MakeUnavailableToOrganizationTemplateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

MakeUnavailableToOrganizationTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MakeUnavailableToOrganizationTemplateRequest


MergeRequest Class
See Also Example Members
[image]

Contains the data that’s needed to merge the information from two entity records of the same type.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MergeRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MergeRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
         // Create the target for the request.
EntityReference target = new EntityReference();

// Id is the GUID of the account that is being merged into.
         // LogicalName is the type of the entity being merged to, as a string
target.Id = _account1Id;
         target.LogicalName = Account.EntityLogicalName;

         // Create the request.
         MergeRequest merge = new MergeRequest();
         // SubordinateId is the GUID of the account merging.
         merge.SubordinateId = _account2Id;
         merge.Target = target;
         merge.PerformParentingChecks = false;

         Console.WriteLine("\nMerging account2 into account1 and adding " +
             "\"test\" as Address 1 Line 1");

         // Create another account to hold new data to merge into the entity.
         // If you use the subordinate account object, its data will be merged.
         Account updateContent = new Account();
         updateContent.Address1_Line1 = "test";

         // Set the content you want updated on the merged account
         merge.UpdateContent = updateContent;

         // Execute the request.
         MergeResponse merged = (MergeResponse)_serviceProxy.Execute(merge);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the MergeResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges and access rights on the specified entity in the SubordinateId property and privileges on the entity that is referred to in the Target property.
For a complete list of the required privileges, see Merge Privileges.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

                                    Entity

account

contact

lead

incident

For a description of how actions on a parent record affect child records, see Entity Relationship Behavior.
Merge incidents
The behavior of merge for incidents is different from merging accounts, contacts, or leads in the following ways:
  • The UpdateContent property is not used.
    For other entities this property may be used to transfer selected values from the subordinate record to the target record. When merging incidents the value of this property is ignored.
  • Merge is performed in the security context of the user.
    Merge operations for other entities are performed with a system user security context. Because incident merge operations are performed in the security context of the user, the user must have the security privileges to perform any of the actions, such as re-parenting related records, that are performed by the merge operation.
    If the user merging records doesn’t have privileges for all the actions contained within the merge operation, the merge operation will fail and roll back to the original state.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.MergeRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
MergeRequest Members
Microsoft.Crm.Sdk.Messages Namespace
MergeResponse
Other Resources
Merge Privileges
Sample: Merge Two Records
Customer Entities (Account, Contact)
Lead Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


MergeRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that’s needed to merge the information from two entity records of the same type.

The following tables list the members exposed by the MergeRequest type.

Public Constructors

Name | Description
MergeRequest | Initializes a new instance of the MergeRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PerformParentingChecks | Gets or sets a value that indicates whether to check if the parent information is different for the two entity records. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SubordinateId | Gets or sets the ID of the entity record from which to merge data. Required.
public property | Target | Gets or sets the target of the merge operation. Required.
public property | UpdateContent | Gets or sets additional entity attributes to be set during the merge operation for accounts, contacts, or leads. This property is not applied when merging incidents. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MergeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MergeResponse

Other Resources

Merge Privileges
Sample: Merge Two Records
Customer Entities (Account, Contact)
Lead Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


MergeRequest Constructor
[image]

Initializes a new instance of the MergeRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MergeRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MergeRequest Class
MergeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MergeRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MergeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MergeResponse

Other Resources

Merge Privileges
Sample: Merge Two Records
Customer Entities (Account, Contact)
Lead Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


MergeRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PerformParentingChecks | Gets or sets a value that indicates whether to check if the parent information is different for the two entity records. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SubordinateId | Gets or sets the ID of the entity record from which to merge data. Required.
public property | Target | Gets or sets the target of the merge operation. Required.
public property | UpdateContent | Gets or sets additional entity attributes to be set during the merge operation for accounts, contacts, or leads. This property is not applied when merging incidents. Optional.

See Also

Reference

MergeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
MergeResponse

Other Resources

Merge Privileges
Sample: Merge Two Records
Customer Entities (Account, Contact)
Lead Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


MergeRequest.PerformParentingChecks Property
[image]

Gets or sets a value that indicates whether to check if the parent information is different for the two entity records. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PerformParentingChecks As Boolean

C#
public bool PerformParentingChecks { get; set; }

C++

J#

JScript

Property Value
Type:  Boolean
Indicates whether to check if the parent information is different for the two entity records.
True to check if the parent information is different for the two entity records, otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MergeRequest Class
MergeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MergeRequest.SubordinateId Property
[image]

Gets or sets the ID of the entity record from which to merge data. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SubordinateId As Guid

C#
public Guid SubordinateId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the entity record from which to merge data.

  Remarks
The entity type of the specified record for SubordinateId must match the entity type of the specified record in the Target property. The specified record must be one of following entity types: Account, Contact, Lead or Incident.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MergeRequest Class
MergeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MergeRequest.Target Property
[image]

Gets or sets the target of the merge operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target of the merge operation.

  Remarks
A target of this operation is a record of one of following entity types: Account, Contact, Lead or Incident.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MergeRequest Class
MergeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MergeRequest.UpdateContent Property
[image]

Gets or sets additional entity attributes to be set during the merge operation for accounts, contacts, or leads. This property is not applied when merging incidents. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UpdateContent As Entity

C#
public Entity UpdateContent { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The additional entity attributes to be set during the merge operation.

  Remarks
  Note

                        This property is not applied when merging incidents.

This property value must be an instance of the same entity type as the target and subordinate records. Only the properties that contain values or that specify null are set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
MergeRequest Class
MergeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


MergeResponse Class
See Also Members
[image]

Contains the response from the MergeRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MergeResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MergeResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.MergeResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MergeResponse Members
Microsoft.Crm.Sdk.Messages Namespace
MergeRequest


MergeResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the MergeRequest class.

The following tables list the members exposed by the MergeResponse type.

Public Constructors

Name | Description
MergeResponse | Initializes a new instance of the MergeResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MergeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MergeRequest


MergeResponse Constructor
[image]

Initializes a new instance of the MergeResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MergeResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MergeResponse Class
MergeResponse Members
Microsoft.Crm.Sdk.Messages Namespace


MergeResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MergeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MergeRequest


MergeResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

MergeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
MergeRequest


MissingComponent Class
See Also Members
[image]

Contains the data to describe a solution component that is required by a solution but not found in the system.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class MissingComponent
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class MissingComponent : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.MissingComponent
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MissingComponent Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingComponentsRequest
Other Resources
Dependency Tracking for Solution Components


MissingComponent Members
See Also Constructors Methods Properties
[image]

Contains the data to describe a solution component that is required by a solution but not found in the system.

The following tables list the members exposed by the MissingComponent type.

Public Constructors

Name | Description
MissingComponent | Initializes a new instance of the MissingComponent class.
Top

Public Properties

 | Name | Description
public property | DependentComponent | Gets or sets information about the solution component in the solution file that is dependent on a missing solution component.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | RequiredComponent | Gets or sets information about the required solution component that is missing.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MissingComponent Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingComponentsRequest

Other Resources

Dependency Tracking for Solution Components


MissingComponent Constructor
[image]

Initializes a new instance of the MissingComponent class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MissingComponent ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MissingComponent Class
MissingComponent Members
Microsoft.Crm.Sdk.Messages Namespace


MissingComponent Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MissingComponent Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingComponentsRequest

Other Resources

Dependency Tracking for Solution Components


MissingComponent Properties
[image]

Public Properties

 | Name | Description
public property | DependentComponent | Gets or sets information about the solution component in the solution file that is dependent on a missing solution component.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | RequiredComponent | Gets or sets information about the required solution component that is missing.

See Also

Reference

MissingComponent Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingComponentsRequest

Other Resources

Dependency Tracking for Solution Components


MissingComponent.DependentComponent Property
[image]

Gets or sets information about the solution component in the solution file that is dependent on a missing solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DependentComponent As ComponentDetail

C#
[DataMemberAttribute]
public ComponentDetail DependentComponent { get; set; }

C++

J#

JScript

Property Value
Type: ComponentDetail
Information about the solution component in the solution file that is dependent on a missing solution component..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MissingComponent Class
MissingComponent Members
Microsoft.Crm.Sdk.Messages Namespace


MissingComponent.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MissingComponent Class
MissingComponent Members
Microsoft.Crm.Sdk.Messages Namespace


MissingComponent.RequiredComponent Property
[image]

Gets or sets information about the required solution component that is missing.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RequiredComponent As ComponentDetail

C#
[DataMemberAttribute]
public ComponentDetail RequiredComponent { get; set; }

C++

J#

JScript

Property Value
Type: ComponentDetail
Information about the required solution component that is missing..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MissingComponent Class
MissingComponent Members
Microsoft.Crm.Sdk.Messages Namespace


ModifyAccessRequest Class
See Also Example Members
[image]

Contains the data that is needed to replace the access rights on the target record for the specified security principal (user or team).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ModifyAccessRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ModifyAccessRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Grant the first user delete access to the lead.
var modifyUser1AccessReq = new ModifyAccessRequest
{
    PrincipalAccess = new PrincipalAccess
    {
        AccessMask = AccessRights.DeleteAccess,
        Principal = systemUser1Ref
    },
    Target = leadReference
};

Console.WriteLine("Granting delete access to {0} on the lead...\r\n",
    GetEntityReferenceString(systemUser1Ref));
_serviceProxy.Execute(modifyUser1AccessReq);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of the ModifyAccessResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the Target property and access rights on the record that is specified in the Target property. For a list of the required privileges, see ModifyAccess Privileges.
Notes for Callers
This action applies to all child records of the target entity record. For all child records, if the caller does not have share privileges for those entity types or share rights to the records, the child records are not shared. As a result, the owner of the entity record, or a user who shares the record that has share rights, automatically has share rights to all child records of the target entity record. In this case, only the lack of privileges to a particular entity type prevents the child records from being shared.
For a description of how actions on a parent record affect child records, see Cascading Behavior.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

Entity | Availability
Account | 0 (Server)
Annotation | 0 (Server)
Appointment | 0 (Server)
Campaign | 0 (Server)
CampaignActivity | 0 (Server)
CampaignResponse | 0 (Server)
Connection | 0 (Server)
Contact | 0 (Server)
Contract | 0 (Server)
ConvertRule | 0 (Server)
CustomerOpportunityRole | 0 (Server)
CustomerRelationship | 0 (Server)
DuplicateRule | 0 (Server)
Email | 0 (Server)
EmailServerProfile | 0 (Server)
Entitlement | 0 (Server)
Fax | 0 (Server)
Goal | 0 (Server)
GoalRollupQuery | 0 (Server)
Import | 0 (Server)
ImportFile | 0 (Server)
ImportMap | 0 (Server)
Incident | 0 (Server)
IncidentResolution | 0 (Server)
Invoice | 0 (Server)
Lead | 0 (Server)
Letter | 0 (Server)
List | 0 (Server)
Mailbox | 0 (Server)
MailMergeTemplate | 0 (Server)
msdyn_PostAlbum | 0 (Server)
msdyn_wallsavedqueryusersettings | 0 (Server)
Opportunity | 0 (Server)
OpportunityClose | 0 (Server)
OrderClose | 0 (Server)
PhoneCall | 0 (Server)
ProcessSession | 0 (Server)
Queue | 0 (Server)
Quote | 0 (Server)
QuoteClose | 0 (Server)
RecurringAppointmentMaster | 0 (Server)
Report | 0 (Server)
RoutingRule | 0 (Server)
SalesOrder | 0 (Server)
ServiceAppointment | 0 (Server)
SharePointDocumentLocation | 0 (Server)
SharePointSite | 0 (Server)
SLA | 0 (Server)
SLAKPIInstance | 0 (Server)
SocialActivity | 0 (Server)
SocialProfile | 0 (Server)
Task | 0 (Server)
Template | 0 (Server)
UserForm | 0 (Server)
UserQuery | 0 (Server)
UserQueryVisualization | 0 (Server)
Workflow | 0 (Server)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ModifyAccessRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ModifyAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ModifyAccessResponse
Other Resources
How Record-Based Security Can Be Used to Control Access to Records in Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


ModifyAccessRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to replace the access rights on the target record for the specified security principal (user or team).

The following tables list the members exposed by the ModifyAccessRequest type.

Public Constructors

Name | Description
ModifyAccessRequest | Initializes a new instance of the ModifyAccessRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PrincipalAccess | Gets or sets the team or user whose access to the specified record is modified. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the entity that is the target of the request to modify access. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ModifyAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ModifyAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records in Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


ModifyAccessRequest Constructor
[image]

Initializes a new instance of the ModifyAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ModifyAccessRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ModifyAccessRequest Class
ModifyAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ModifyAccessRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ModifyAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ModifyAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records in Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


ModifyAccessRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PrincipalAccess | Gets or sets the team or user whose access to the specified record is modified. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the entity that is the target of the request to modify access. Required.

See Also

Reference

ModifyAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ModifyAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records in Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


ModifyAccessRequest.PrincipalAccess Property
[image]

Gets or sets the team or user whose access to the specified record is modified. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PrincipalAccess As PrincipalAccess

C#
public PrincipalAccess PrincipalAccess { get; set; }

C++

J#

JScript

Property Value
Type: PrincipalAccess
The team or user whose access to the specified record is modified.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ModifyAccessRequest Class
ModifyAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ModifyAccessRequest.Target Property
[image]

Gets or sets the entity that is the target of the request to modify access. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The entity that is the target of the request to modify access. This must be an entity reference to an entity that supports this message. For a list of supported entity types, see the ModifyAccessRequest class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ModifyAccessRequest Class
ModifyAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ModifyAccessResponse Class
See Also Members
[image]

Contains the response from the ModifyAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ModifyAccessResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ModifyAccessResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ModifyAccessResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ModifyAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ModifyAccessRequest


ModifyAccessResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ModifyAccessRequest class.

The following tables list the members exposed by the ModifyAccessResponse type.

Public Constructors

Name | Description
ModifyAccessResponse | Initializes a new instance of the ModifyAccessResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ModifyAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ModifyAccessRequest


ModifyAccessResponse Constructor
[image]

Initializes a new instance of the ModifyAccessResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ModifyAccessResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ModifyAccessResponse Class
ModifyAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ModifyAccessResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ModifyAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ModifyAccessRequest


ModifyAccessResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ModifyAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ModifyAccessRequest


ObjectiveRelation Class
See Also Members
[image]

Contains the data that describes the scheduling strategy for an AppointmentRequest and that overrides the default constraints.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ObjectiveRelation
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ObjectiveRelation : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.ObjectiveRelation
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectiveRelation Members
Microsoft.Crm.Sdk.Messages Namespace
AppointmentRequest
Other Resources
Schedules in Microsoft Dynamics CRM


ObjectiveRelation Members
See Also Constructors Methods Properties
[image]

Contains the data that describes the scheduling strategy for an AppointmentRequest and that overrides the default constraints.

The following tables list the members exposed by the ObjectiveRelation type.

Public Constructors

Name | Description
ObjectiveRelation | Overloaded. Initializes a new instance of the ObjectiveRelation class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ObjectiveExpression | Gets or sets the search strategy to use in the appointment request for the SearchRequest message.
public property | ResourceSpecId | Gets or sets the ID of the resource specification.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ObjectiveRelation Class
Microsoft.Crm.Sdk.Messages Namespace
AppointmentRequest

Other Resources

Schedules in Microsoft Dynamics CRM


ObjectiveRelation Constructor
[image]

Initializes a new instance of the ObjectiveRelation class.

Overload List

Name | Description
ObjectiveRelation () | Initializes a new instance of the ObjectiveRelation class.
ObjectiveRelation (Guid, String) | Initializes a new instance of the ObjectiveRelation class.

See Also

Reference

ObjectiveRelation Class
ObjectiveRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ObjectiveRelation Constructor ()
[image]

Initializes a new instance of the ObjectiveRelation class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ObjectiveRelation ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectiveRelation Class
ObjectiveRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ObjectiveRelation Constructor (Guid, String)
[image]

Initializes a new instance of the ObjectiveRelation class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    resourceSpecId As Guid, _
    objectiveExpression As String _
)

C#
public ObjectiveRelation (
    Guid resourceSpecId,
    string objectiveExpression
)

C++

J#

JScript

Parameters
resourceSpecId
Type: Guid. The ID of the resource specification.
objectiveExpression
Type: String. The search strategy to use in the appointment request.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectiveRelation Class
ObjectiveRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ObjectiveRelation Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ObjectiveRelation Class
Microsoft.Crm.Sdk.Messages Namespace
AppointmentRequest

Other Resources

Schedules in Microsoft Dynamics CRM


ObjectiveRelation Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ObjectiveExpression | Gets or sets the search strategy to use in the appointment request for the SearchRequest message.
public property | ResourceSpecId | Gets or sets the ID of the resource specification.

See Also

Reference

ObjectiveRelation Class
Microsoft.Crm.Sdk.Messages Namespace
AppointmentRequest

Other Resources

Schedules in Microsoft Dynamics CRM


ObjectiveRelation.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectiveRelation Class
ObjectiveRelation Members
Microsoft.Crm.Sdk.Messages Namespace


ObjectiveRelation.ObjectiveExpression Property
See Also Example
[image]

Gets or sets the search strategy to use in the appointment request for the SearchRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ObjectiveExpression As String

C#
[DataMemberAttribute]
public string ObjectiveExpression { get; set; }

C++

J#

JScript

Property Value
Type: String The search strategy to use in the appointment request.

  Example
The following sample shows Most Busy.
Xml    Copy Code
<Expression>
  <Body>udf \"MostBusy\"(factory,resource,appointment,request,leftoffset,rightoffset)</Body>
  <Parameters>
    <Parameter name=\"factory\"/>
    <Parameter name=\"resource\">
    </Parameter><Parameter name=\"appointment\">
    </Parameter><Parameter name=\"request\">
    </Parameter><Parameter name=\"leftoffset\">
    </Parameter><Parameter name=\"rightoffset\"></Parameter>
  </Parameters>
  <Properties EvaluationInterval=\"P0D\" evaluationcost=\"1\"/>
</Expression>

The following sample shows Least Busy.
Xml    Copy Code
<Expression>
  <Body>udf \"LeastBusy\"(factory,resource,appointment,request,leftoffset,rightoffset)</Body>
  <Parameters>
    <Parameter name=\"factory\"/>
    <Parameter name=\"resource\">
    </Parameter><Parameter name=\"appointment\">
    </Parameter><Parameter name=\"request\">
    </Parameter><Parameter name=\"leftoffset\">
    </Parameter><Parameter name=\"rightoffset\"></Parameter>
  </Parameters>
  <Properties EvaluationInterval=\"P0D\" evaluationcost=\"1\"/>
</Expression>

                                The following sample shows
                                Random.
Xml    Copy Code
<Expression>
  <Body>udf \"Random\"(factory,resource,appointment,request,leftoffset,rightoffset)</Body>
  <Parameters>
    <Parameter name=\"factory\"/>
    <Parameter name=\"resource\">
    </Parameter><Parameter name=\"appointment\">
    </Parameter><Parameter name=\"request\">
    </Parameter><Parameter name=\"leftoffset\">
    </Parameter><Parameter name=\"rightoffset\"></Parameter>
  </Parameters>
  <Properties EvaluationInterval=\"P0D\" evaluationcost=\"0\"/>
</Expression>

  Remarks
Used in the Objectives property.
The scheduling engine supports three search strategies that are specified in the ObjectiveExpression property. A string that contains the search strategy is a parameter to the search methods. The examples show the valid values.
Least Busy - From the list of resources that can perform that specific service, choose the resource that is the least busy and is available at the requested time.
Most Busy - From the list of resources that can perform that specific service, choose the resource that is the busiest and is available at the requested time.
Random - From the list of resources that can perform that specific service, choose any resource that is available at the requested time.
The following table shows the supported values for an evaluation interval.
Value | Description
P0D | Refresh states per proposal.
PInfinity | Constantly refresh states.
P1D | Refresh states one time per day.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ObjectiveRelation Class
ObjectiveRelation Members
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest
ObjectiveRelation


ObjectiveRelation.ResourceSpecId Property
[image]

Gets or sets the ID of the resource specification.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResourceSpecId As Guid

C#
[DataMemberAttribute]
public Guid ResourceSpecId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the resource specification. The ResourceSpecId property corresponds to the ResourceSpec.ResourceSpecId property, which is the primary key for the resource specification entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectiveRelation Class
ObjectiveRelation Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
ResourceSpec (Resource Specification) Entity Messages and Methods


OrganizationResources Class
See Also Members
[image]

Contains data regarding the resources used by an organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class OrganizationResources
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class OrganizationResources : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.OrganizationResources
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesRequest


OrganizationResources Members
See Also Constructors Methods Properties
[image]

Contains data regarding the resources used by an organization.

The following tables list the members exposed by the OrganizationResources type.

Public Constructors

Name | Description
OrganizationResources | Initializes a new instance of the OrganizationResources class.
Top

Public Properties

 | Name | Description
public property | CurrentNumberOfActiveUsers | Gets the current number of active users.
public property | CurrentNumberOfCustomEntities | Gets the current number of custom entities.
public property | CurrentNumberOfNonInteractiveUsers | Gets the current number of non-interactive users.
public property | CurrentNumberOfPublishedWorkflows | Gets the current number of published workflows.
public property | CurrentStorage | Gets the current storage used by the organization.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | MaxNumberOfActiveUsers | Gets the maximum number of active users.
public property | MaxNumberOfCustomEntities | Gets the maximum number of custom entities.
public property | MaxNumberOfNonInteractiveUsers | Gets the maximum number of non-interactive users.
public property | MaxNumberOfPublishedWorkflows | Gets the maximum number of published workflows.
public property | MaxStorage | Gets the maximum storage allowed for the organization.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrganizationResources Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesRequest


OrganizationResources Constructor
[image]

Initializes a new instance of the OrganizationResources class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrganizationResources ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace


OrganizationResources Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrganizationResources Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesRequest


OrganizationResources Properties
[image]

Public Properties

 | Name | Description
public property | CurrentNumberOfActiveUsers | Gets the current number of active users.
public property | CurrentNumberOfCustomEntities | Gets the current number of custom entities.
public property | CurrentNumberOfNonInteractiveUsers | Gets the current number of non-interactive users.
public property | CurrentNumberOfPublishedWorkflows | Gets the current number of published workflows.
public property | CurrentStorage | Gets the current storage used by the organization.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | MaxNumberOfActiveUsers | Gets the maximum number of active users.
public property | MaxNumberOfCustomEntities | Gets the maximum number of custom entities.
public property | MaxNumberOfNonInteractiveUsers | Gets the maximum number of non-interactive users.
public property | MaxNumberOfPublishedWorkflows | Gets the maximum number of published workflows.
public property | MaxStorage | Gets the maximum storage allowed for the organization.

See Also

Reference

OrganizationResources Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesRequest


OrganizationResources.CurrentNumberOfActiveUsers Property
[image]

Gets the current number of active users.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CurrentNumberOfActiveUsers As Integer

C#
[DataMemberAttribute]
public int CurrentNumberOfActiveUsers { get; set; }

C++

J#

JScript

Property Value
Type: Int32
the current number of active users.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
User and Team Entities


OrganizationResources.CurrentNumberOfCustomEntities Property
[image]

Gets the current number of custom entities.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CurrentNumberOfCustomEntities As Integer

C#
[DataMemberAttribute]
public int CurrentNumberOfCustomEntities { get; set; }

C++

J#

JScript

Property Value
Type: Int32
the current number of custom entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Entity Metadata


OrganizationResources.CurrentNumberOfNonInteractiveUsers Property
[image]

Gets the current number of non-interactive users.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CurrentNumberOfNonInteractiveUsers As Integer

C#
[DataMemberAttribute]
public int CurrentNumberOfNonInteractiveUsers { get; set; }

C++

J#

JScript

Property Value
Type: Int32
the current number of non-interactive users.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
User and Team Entities


OrganizationResources.CurrentNumberOfPublishedWorkflows Property
[image]

Gets the current number of published workflows.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CurrentNumberOfPublishedWorkflows As Integer

C#
[DataMemberAttribute]
public int CurrentNumberOfPublishedWorkflows { get; set; }

C++

J#

JScript

Property Value
Type: Int32
the current number of published workflows.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Write Workflows to Automate Business Processes in Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


OrganizationResources.CurrentStorage Property
[image]

Gets the current storage used by the organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CurrentStorage As Integer

C#
[DataMemberAttribute]
public int CurrentStorage { get; set; }

C++

J#

JScript

Property Value
Type: Int32
the current storage used by the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace


OrganizationResources.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace


OrganizationResources.MaxNumberOfActiveUsers Property
[image]

Gets the maximum number of active users.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxNumberOfActiveUsers As Integer

C#
[DataMemberAttribute]
public int MaxNumberOfActiveUsers { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of active users.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
User and Team Entities


OrganizationResources.MaxNumberOfCustomEntities Property
[image]

Gets the maximum number of custom entities.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxNumberOfCustomEntities As Integer

C#
[DataMemberAttribute]
public int MaxNumberOfCustomEntities { get; set; }

C++

J#

JScript

Property Value
Type: Int32
the maximum number of custom entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Entity Metadata


OrganizationResources.MaxNumberOfNonInteractiveUsers Property
[image]

Gets the maximum number of non-interactive users.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxNumberOfNonInteractiveUsers As Integer

C#
[DataMemberAttribute]
public int MaxNumberOfNonInteractiveUsers { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of non-interactive users.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
User and Team Entities


OrganizationResources.MaxNumberOfPublishedWorkflows Property
[image]

Gets the maximum number of published workflows.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxNumberOfPublishedWorkflows As Integer

C#
[DataMemberAttribute]
public int MaxNumberOfPublishedWorkflows { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of published workflows.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Write Workflows to Automate Business Processes in Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


OrganizationResources.MaxStorage Property
[image]

Gets the maximum storage allowed for the organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxStorage As Integer

C#
[DataMemberAttribute]
public int MaxStorage { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum storage allowed for the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResources Class
OrganizationResources Members
Microsoft.Crm.Sdk.Messages Namespace


ParseImportRequest Class
See Also Example Members
[image]

Contains the data that is needed to submit an asynchronous job that parses all import files that are associated with the specified import (data import).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ParseImportRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ParseImportRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Parse the import file.
ParseImportRequest parseImportRequest = new ParseImportRequest()
{
    ImportId = importId
};
ParseImportResponse parseImportResponse =
    (ParseImportResponse)_serviceProxy.Execute(parseImportRequest);
Console.WriteLine("Waiting for Parse async job to complete");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the ParseImportResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Import entity and access rights on the specified record in the ImportId property. For a complete list of the required privileges, see ParseImport Privileges.
Notes for Callers
Pass the ID of the associated import (data import) in the ImportId property. The ID of the asynchronous job that runs in the background and performs data parsing is returned in the AsyncOperationId property of the message response.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ParseImportRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ParseImportRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ParseImportResponse
Other Resources
Import Data in Microsoft Dynamics CRM
Run Data Import
Sample: Import Data Using Complex Data Map
Import (data import) Entity Messages and Methods
ParseImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


ParseImportRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to submit an asynchronous job that parses all import files that are associated with the specified import (data import).

The following tables list the members exposed by the ParseImportRequest type.

Public Constructors

Name | Description
ParseImportRequest | Initializes a new instance of the ParseImportRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportId | Gets or sets the ID of the import (data import) that is associated with the asynchronous job that parses all import files for this import. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ParseImportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ParseImportResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Run Data Import
Sample: Import Data Using Complex Data Map
Import (data import) Entity Messages and Methods
ParseImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


ParseImportRequest Constructor
[image]

Initializes a new instance of the ParseImportRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ParseImportRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParseImportRequest Class
ParseImportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ParseImportRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ParseImportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ParseImportResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Run Data Import
Sample: Import Data Using Complex Data Map
Import (data import) Entity Messages and Methods
ParseImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


ParseImportRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportId | Gets or sets the ID of the import (data import) that is associated with the asynchronous job that parses all import files for this import. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ParseImportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ParseImportResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Run Data Import
Sample: Import Data Using Complex Data Map
Import (data import) Entity Messages and Methods
ParseImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


ParseImportRequest.ImportId Property
[image]

Gets or sets the ID of the import (data import) that is associated with the asynchronous job that parses all import files for this import. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportId As Guid

C#
public Guid ImportId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the import (data import) that is associated with the asynchronous job that parses all import files for this import. This corresponds to the Import.ImportId attribute, which is the primary key for the Import entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParseImportRequest Class
ParseImportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ParseImportResponse Class
See Also Members
[image]

Contains the response from the ParseImportRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ParseImportResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ParseImportResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ParseImportResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParseImportResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ParseImportRequest


ParseImportResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ParseImportRequest class.

The following tables list the members exposed by the ParseImportResponse type.

Public Constructors

Name | Description
ParseImportResponse | Initializes a new instance of the ParseImportResponse class.
Top

Public Properties

 | Name | Description
public property | AsyncOperationId | Gets an ID of the asynchronous job that parses the import files for this import.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ParseImportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ParseImportRequest


ParseImportResponse Constructor
[image]

Initializes a new instance of the ParseImportResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ParseImportResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParseImportResponse Class
ParseImportResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ParseImportResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ParseImportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ParseImportRequest


ParseImportResponse Properties
[image]

Public Properties

 | Name | Description
public property | AsyncOperationId | Gets an ID of the asynchronous job that parses the import files for this import.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ParseImportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ParseImportRequest


ParseImportResponse.AsyncOperationId Property
[image]

Gets an ID of the asynchronous job that parses the import files for this import.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AsyncOperationId As Guid

C#
public Guid AsyncOperationId { get; }

C++

J#

JScript

Property Value
Type: Guid
ID of the asynchronous job that parses the import files for this import.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParseImportResponse Class
ParseImportResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PickFromQueueRequest Class
See Also Members
[image]

Contains the data that is needed to assign a queue item to a user and optionally remove the queue item from the queue.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PickFromQueueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PickFromQueueRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute  method, which returns an instance of the PickFromQueueResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the QueueItem entity and access rights on the specified record in the QueueItemId property. For a complete list of the required privileges, see PickFromQueue message privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.PickFromQueueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PickFromQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace
PickFromQueueResponse
Other Resources
Queue Entities
QueueItem Entity Messages and Methods
Sample: Specify a Queue Item to Work On (Early Bound)


PickFromQueueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to assign a queue item to a user and optionally remove the queue item from the queue.

The following tables list the members exposed by the PickFromQueueRequest type.

Public Constructors

Name | Description
PickFromQueueRequest | Initializes a new instance of the PickFromQueueRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemId | Gets or sets the
public property | RemoveQueueItem | Gets or sets whether the queue item should be removed from the queue.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | WorkerId | Gets or sets the user to assign the queue item to. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PickFromQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PickFromQueueResponse

Other Resources

Queue Entities
QueueItem Entity Messages and Methods
Sample: Specify a Queue Item to Work On (Early Bound)


PickFromQueueRequest Constructor
[image]

Initializes a new instance of the PickFromQueueRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PickFromQueueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PickFromQueueRequest Class
PickFromQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PickFromQueueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PickFromQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PickFromQueueResponse

Other Resources

Queue Entities
QueueItem Entity Messages and Methods
Sample: Specify a Queue Item to Work On (Early Bound)


PickFromQueueRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemId | Gets or sets the
public property | RemoveQueueItem | Gets or sets whether the queue item should be removed from the queue.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | WorkerId | Gets or sets the user to assign the queue item to. Required.

See Also

Reference

PickFromQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PickFromQueueResponse

Other Resources

Queue Entities
QueueItem Entity Messages and Methods
Sample: Specify a Queue Item to Work On (Early Bound)


PickFromQueueRequest.QueueItemId Property
[image]

Gets or sets the

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueueItemId As Guid

C#
public Guid QueueItemId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The QueueItem. This corresponds to the QueueItem.QueueItemId attribute, which is the primary key for the QueueItem entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PickFromQueueRequest Class
PickFromQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PickFromQueueRequest.RemoveQueueItem Property
[image]

Gets or sets whether the queue item should be removed from the queue.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RemoveQueueItem As Boolean

C#
public bool RemoveQueueItem { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the queue item should be removed from the queue; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PickFromQueueRequest Class
PickFromQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PickFromQueueRequest.WorkerId Property
[image]

Gets or sets the user to assign the queue item to. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property WorkerId As Guid

C#
public Guid WorkerId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The User. This corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PickFromQueueRequest Class
PickFromQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PickFromQueueResponse Class
See Also Members
[image]

Contains the response from the PickFromQueueRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PickFromQueueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PickFromQueueResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.PickFromQueueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PickFromQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace
PickFromQueueRequest


PickFromQueueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the PickFromQueueRequest message.

The following tables list the members exposed by the PickFromQueueResponse type.

Public Constructors

Name | Description
PickFromQueueResponse | Initializes a new instance of the PickFromQueueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PickFromQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PickFromQueueRequest


PickFromQueueResponse Constructor
[image]

Initializes a new instance of the PickFromQueueResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PickFromQueueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PickFromQueueResponse Class
PickFromQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PickFromQueueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PickFromQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PickFromQueueRequest


PickFromQueueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

PickFromQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PickFromQueueRequest


PrincipalAccess Class
See Also Members
[image]

Contains access rights information for the security principal (user or team).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PrincipalAccess
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PrincipalAccess : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.PrincipalAccess
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PrincipalAccess Members
Microsoft.Crm.Sdk.Messages Namespace
PrincipalAccess
PrincipalAccess
PrincipalAccesses
RetrievePrincipalAccessRequest
RetrievePrincipalAccessResponse
Other Resources
Sample: Share a Queue (Early Bound)


PrincipalAccess Members
See Also Constructors Methods Properties
[image]

Contains access rights information for the security principal (user or team).

The following tables list the members exposed by the PrincipalAccess type.

Public Constructors

Name | Description
PrincipalAccess | Initializes a new instance of the PrincipalAccess class.
Top

Public Properties

 | Name | Description
public property | AccessMask | Gets or sets the access rights of the security principal (user or team).
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Principal | Gets or sets the security principal (user or team).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PrincipalAccess Class
Microsoft.Crm.Sdk.Messages Namespace
PrincipalAccess
PrincipalAccess
PrincipalAccesses
RetrievePrincipalAccessRequest
RetrievePrincipalAccessResponse

Other Resources

Sample: Share a Queue (Early Bound)


PrincipalAccess Constructor
[image]

Initializes a new instance of the PrincipalAccess class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PrincipalAccess ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PrincipalAccess Class
PrincipalAccess Members
Microsoft.Crm.Sdk.Messages Namespace


PrincipalAccess Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PrincipalAccess Class
Microsoft.Crm.Sdk.Messages Namespace
PrincipalAccess
PrincipalAccess
PrincipalAccesses
RetrievePrincipalAccessRequest
RetrievePrincipalAccessResponse

Other Resources

Sample: Share a Queue (Early Bound)


PrincipalAccess Properties
[image]

Public Properties

 | Name | Description
public property | AccessMask | Gets or sets the access rights of the security principal (user or team).
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Principal | Gets or sets the security principal (user or team).

See Also

Reference

PrincipalAccess Class
Microsoft.Crm.Sdk.Messages Namespace
PrincipalAccess
PrincipalAccess
PrincipalAccesses
RetrievePrincipalAccessRequest
RetrievePrincipalAccessResponse

Other Resources

Sample: Share a Queue (Early Bound)


PrincipalAccess.AccessMask Property
[image]

Gets or sets the access rights of the security principal (user or team).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AccessMask As AccessRights

C#
[DataMemberAttribute]
public AccessRights AccessMask { get; set; }

C++

J#

JScript

Property Value
Type: AccessRights
The access rights of the security principal (user or team).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PrincipalAccess Class
PrincipalAccess Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Setting Bit Flags


PrincipalAccess.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PrincipalAccess Class
PrincipalAccess Members
Microsoft.Crm.Sdk.Messages Namespace


PrincipalAccess.Principal Property
[image]

Gets or sets the security principal (user or team).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Principal As EntityReference

C#
[DataMemberAttribute]
public EntityReference Principal { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The security principal (user or team).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PrincipalAccess Class
PrincipalAccess Members
Microsoft.Crm.Sdk.Messages Namespace


PrivilegeDepth Enumeration
[image]

Contains the possible values for the depth of a privilege within a role. This enumeration is used to compare and set values in records returned from Fetch or QueryExpression queries. If you use LINQ, the privilege depth is returned as a bit mask. In this case you can use the following constants to determine the privilege depth. public const int BASIC_MASK = 0x00000001; public const int LOCAL_MASK = 0x00000002; public const int DEEP_MASK = 0x00000004; public const int GLOBAL_MASK = 0x00000008;

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration PrivilegeDepth

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum PrivilegeDepth

C++

J#

JScript

  Members
Member name | Description
Basic | Indicates basic privileges. Users who have basic privileges can only use privileges to perform actions on objects that are owned by, or shared with, the user. Value = 0.
Deep | Indicates deep privileges. Users who have deep privileges can perform actions on all objects in the user's current business units and all objects down the hierarchy of business units. Value = 2.
Global | Indicates global privileges. Users who have global privileges can perform actions on data and objects anywhere within the organization regardless of the business unit or user to which it belongs. Value = 3.
Local | Indicates local privileges. Users who have local privileges can only use privileges to perform actions on data and objects that are in the user's current business unit. Value = 1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace
RolePrivilege
Depth
Other Resources
Privilege and Role Entities


ProcessInboundEmailRequest Class
See Also Members
[image]

Contains the data that is needed to process the email responses from a marketing campaign.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ProcessInboundEmailRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ProcessInboundEmailRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of the ProcessInboundEmailResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Email entity and access rights on the specified record in the InboundEmailActivity property. For a complete list of the required privileges, see ProcessInboundEmail Privileges.
Notes for Callers
This message is used in the following scenario:
  1. A user executes a marketing campaign.
  2. Email messages are generated and sent to a list of contacts. Optionally, the messages can contain an unsubscribe link.
  3. A customer (contact) replies to the generated email.
A call to this message does the following:
  1. Creates a campaign response record.
  2. If the response is an unsubscribe reply, the contact.donotbulkemail property for the contact is set to true.
  3. If the response is an unsubscribe reply and the organization.allow property is true, an unsubscribe confirmation email is sent.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ProcessInboundEmailRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessInboundEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ProcessInboundEmailResponse
Other Resources
E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


ProcessInboundEmailRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to process the email responses from a marketing campaign.

The following tables list the members exposed by the ProcessInboundEmailRequest type.

Public Constructors

Name | Description
ProcessInboundEmailRequest | Initializes a new instance of the ProcessInboundEmailRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InboundEmailActivity | Gets or sets the ID of the inbound email activity.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ProcessInboundEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessInboundEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


ProcessInboundEmailRequest Constructor
[image]

Initializes a new instance of the ProcessInboundEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProcessInboundEmailRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessInboundEmailRequest Class
ProcessInboundEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ProcessInboundEmailRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ProcessInboundEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessInboundEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


ProcessInboundEmailRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InboundEmailActivity | Gets or sets the ID of the inbound email activity.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ProcessInboundEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessInboundEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


ProcessInboundEmailRequest.InboundEmailActivity Property
[image]

Gets or sets the ID of the inbound email activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property InboundEmailActivity As Guid

C#
public Guid InboundEmailActivity { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the inbound email activity. This corresponds to the ActivityPointer.ActivityId attribute, which is the primary key for the ActivityPointer entity. Alternatively, it can be the ActivityID for any activity entity type, including custom activity entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessInboundEmailRequest Class
ProcessInboundEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Activity Entities


ProcessInboundEmailResponse Class
See Also Members
[image]

Contains the response from the ProcessInboundEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ProcessInboundEmailResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ProcessInboundEmailResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ProcessInboundEmailResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessInboundEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ProcessInboundEmailRequest


ProcessInboundEmailResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ProcessInboundEmailRequest class.

The following tables list the members exposed by the ProcessInboundEmailResponse type.

Public Constructors

Name | Description
ProcessInboundEmailResponse | Initializes a new instance of the ProcessInboundEmailResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ProcessInboundEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessInboundEmailRequest


ProcessInboundEmailResponse Constructor
[image]

Initializes a new instance of the ProcessInboundEmailResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProcessInboundEmailResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessInboundEmailResponse Class
ProcessInboundEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ProcessInboundEmailResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ProcessInboundEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessInboundEmailRequest


ProcessInboundEmailResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ProcessInboundEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessInboundEmailRequest


ProcessOneMemberBulkOperationRequest Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ProcessOneMemberBulkOperationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ProcessOneMemberBulkOperationRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ProcessOneMemberBulkOperationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessOneMemberBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ProcessOneMemberBulkOperationResponse
Other Resources
ProcessOneMemberBulkOperation Privileges


ProcessOneMemberBulkOperationRequest Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the ProcessOneMemberBulkOperationRequest type.

Public Constructors

Name | Description
ProcessOneMemberBulkOperationRequest | For internal use only.
Top

Public Properties

 | Name | Description
public property | BulkOperationId | For internal use only.
public property | BulkOperationSource | For internal use only.
public property | Entity | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ProcessOneMemberBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessOneMemberBulkOperationResponse

Other Resources

ProcessOneMemberBulkOperation Privileges


ProcessOneMemberBulkOperationRequest Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProcessOneMemberBulkOperationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessOneMemberBulkOperationRequest Class
ProcessOneMemberBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ProcessOneMemberBulkOperationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ProcessOneMemberBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessOneMemberBulkOperationResponse

Other Resources

ProcessOneMemberBulkOperation Privileges


ProcessOneMemberBulkOperationRequest Properties
[image]

Public Properties

 | Name | Description
public property | BulkOperationId | For internal use only.
public property | BulkOperationSource | For internal use only.
public property | Entity | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ProcessOneMemberBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessOneMemberBulkOperationResponse

Other Resources

ProcessOneMemberBulkOperation Privileges


ProcessOneMemberBulkOperationRequest.BulkOperationId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessOneMemberBulkOperationRequest Class
ProcessOneMemberBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ProcessOneMemberBulkOperationRequest.BulkOperationSource Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationSource As Integer

C#
public int BulkOperationSource { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessOneMemberBulkOperationRequest Class
ProcessOneMemberBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ProcessOneMemberBulkOperationRequest.Entity Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As Entity

C#
public Entity Entity { get; set; }

C++

J#

JScript

Property Value
Type: Entity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessOneMemberBulkOperationRequest Class
ProcessOneMemberBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ProcessOneMemberBulkOperationResponse Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ProcessOneMemberBulkOperationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ProcessOneMemberBulkOperationResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ProcessOneMemberBulkOperationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessOneMemberBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ProcessOneMemberBulkOperationRequest


ProcessOneMemberBulkOperationResponse Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the ProcessOneMemberBulkOperationResponse type.

Public Constructors

Name | Description
ProcessOneMemberBulkOperationResponse | For internal use only.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ProcessResult | For internal use only.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ProcessOneMemberBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessOneMemberBulkOperationRequest


ProcessOneMemberBulkOperationResponse Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProcessOneMemberBulkOperationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessOneMemberBulkOperationResponse Class
ProcessOneMemberBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ProcessOneMemberBulkOperationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ProcessOneMemberBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessOneMemberBulkOperationRequest


ProcessOneMemberBulkOperationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ProcessResult | For internal use only.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ProcessOneMemberBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ProcessOneMemberBulkOperationRequest


ProcessOneMemberBulkOperationResponse.ProcessResult Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ProcessResult As Integer

C#
public int ProcessResult { get; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProcessOneMemberBulkOperationResponse Class
ProcessOneMemberBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a quick campaign to distribute an activity to accounts, contacts, or leads that are selected by a query.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PropagateByExpressionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PropagateByExpressionRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
/// <summary>
/// This method creates a Quick Campaign for a set of accounts selected by a query
/// </summary>
/// <param name="activityEntity">
/// An object that indicates activity type for the quick campaign and
/// contains values for each of activity that will be created
/// </param>
/// <param name="query">
/// A query that provides a list of accounts for which
/// the quick campaign is distributed.
/// </param>
/// <param name="ownershipOption">
/// Specifies who will own the activities created by the Quick Campaign
///    The PropagationOwnershipOptions enum is used to specify value for this parameter
///    </param>
/// <param name="isPropagate">
/// Specifies whether the operation is to be executed.
/// This input is often 'true' for Quick Campaign
/// </param>
/// <returns></returns>
public Guid CreateAndRetrieveQuickCampaignForQueryExpression(Entity emailActivityEntity,
    QueryExpression query, PropagationOwnershipOptions ownershipOption, bool isPropagate)
{

    // create the bulkoperation
    PropagateByExpressionRequest request = new PropagateByExpressionRequest() {
        Activity = emailActivityEntity,
        ExecuteImmediately = false, // Default value.
        FriendlyName = "Query Based Quick Campaign",
        OwnershipOptions = ownershipOption,
        QueryExpression = query,
        Owner = new EntityReference("systemuser", _currentUser),
        PostWorkflowEvent = true,
        SendEmail = false,
        TemplateId = Guid.Empty
    };

    PropagateByExpressionResponse response =
        (PropagateByExpressionResponse)_serviceProxy.Execute(request);

    Guid bulkOpId = response.BulkOperationId;
    System.Console.WriteLine(
        "Quick Campaign with following name has been created. "
        + "Please verify in Web app manually: \n"
        + request.FriendlyName + "\nPress enter to continue....");
    System.Console.ReadLine();
    return bulkOpId;

}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the PropagateByExpressionResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Queue and Template entities, and on the specified entity in the Activity property. The caller must also have access rights on the specified records in the QueueId property and the TemplateId property. For a complete list of the required privileges, see PropagateByExpression Privileges.
Notes for Callers
This operation distributes activities that specify a recipient: phone call, appointment, letter, fax, or email.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.PropagateByExpressionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
PropagateByExpressionResponse
Other Resources
Campaign Entities
Sample: Distribute a Quick Campaign
PropagateByExpression Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


PropagateByExpressionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a quick campaign to distribute an activity to accounts, contacts, or leads that are selected by a query.

The following tables list the members exposed by the PropagateByExpressionRequest type.

Public Constructors

Name | Description
PropagateByExpressionRequest | Initializes a new instance of the PropagateByExpressionRequest class.
Top

Public Properties

 | Name | Description
public property | Activity | Gets or sets the activity to be distributed. Required.
public property | ExecuteImmediately | Gets or sets a value that indicates whether the activity is both created and executed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FriendlyName | Gets or sets the user-identifiable name for the campaign. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Owner | Gets or sets the owner for the activity. Required.
public property | OwnershipOptions | Gets or sets the ownership options for propagation. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PostWorkflowEvent | Gets or sets a value that indicates whether an asynchronous job is used to distribute an activity, such as an email, fax, or letter, to the members of a list. Required.
public property | QueryExpression | Gets or sets the query criteria to select accounts, contacts, or leads for which activities are created. Required.
public property | QueueId | Gets or sets the ID of the queue to which the created activities are added. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SendEmail | Gets or sets a value that indicates whether to send an email about the new activity. Required.
public property | TemplateId | Gets or sets the ID of the email template. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PropagateByExpressionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PropagateByExpressionResponse

Other Resources

Campaign Entities
Sample: Distribute a Quick Campaign
PropagateByExpression Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


PropagateByExpressionRequest Constructor
[image]

Initializes a new instance of the PropagateByExpressionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PropagateByExpressionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PropagateByExpressionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PropagateByExpressionResponse

Other Resources

Campaign Entities
Sample: Distribute a Quick Campaign
PropagateByExpression Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


PropagateByExpressionRequest Properties
[image]

Public Properties

 | Name | Description
public property | Activity | Gets or sets the activity to be distributed. Required.
public property | ExecuteImmediately | Gets or sets a value that indicates whether the activity is both created and executed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FriendlyName | Gets or sets the user-identifiable name for the campaign. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Owner | Gets or sets the owner for the activity. Required.
public property | OwnershipOptions | Gets or sets the ownership options for propagation. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PostWorkflowEvent | Gets or sets a value that indicates whether an asynchronous job is used to distribute an activity, such as an email, fax, or letter, to the members of a list. Required.
public property | QueryExpression | Gets or sets the query criteria to select accounts, contacts, or leads for which activities are created. Required.
public property | QueueId | Gets or sets the ID of the queue to which the created activities are added. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SendEmail | Gets or sets a value that indicates whether to send an email about the new activity. Required.
public property | TemplateId | Gets or sets the ID of the email template. Required.

See Also

Reference

PropagateByExpressionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PropagateByExpressionResponse

Other Resources

Campaign Entities
Sample: Distribute a Quick Campaign
PropagateByExpression Privileges
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM


PropagateByExpressionRequest.Activity Property
[image]

Gets or sets the activity to be distributed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Activity As Entity

C#
public Entity Activity { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The activity to be distributed.

  Remarks
This property must be an instance of a class that represents a Microsoft Dynamics CRM activity. For this property, you can only use activities that specify a recipient, such as an appointment, email, fax, letter, or phone call.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Activity Entities


PropagateByExpressionRequest.ExecuteImmediately Property
[image]

Gets or sets a value that indicates whether the activity is both created and executed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExecuteImmediately As Boolean

C#
public bool ExecuteImmediately { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether the activity is both created and executed.
true if an activity is both created and executed; false if an activity is created but not executed.

  Remarks
This property is primarily used for the email activity. For the email activity, use true if an email is created, sent, and marked as complete. Use false if an email is created but not sent.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest.FriendlyName Property
[image]

Gets or sets the user-identifiable name for the campaign. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FriendlyName As String

C#
public string FriendlyName { get; set; }

C++

J#

JScript

Property Value
Type: String
The user-identifiable name for the campaign.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest.Owner Property
[image]

Gets or sets the owner for the activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Owner As EntityReference

C#
public EntityReference Owner { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The owner for the activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest.OwnershipOptions Property
[image]

Gets or sets the ownership options for propagation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OwnershipOptions As PropagationOwnershipOptions

C#
public PropagationOwnershipOptions OwnershipOptions { get; set; }

C++

J#

JScript

Property Value
Type: PropagationOwnershipOptions
The ownership options for propagation.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest.PostWorkflowEvent Property
[image]

Gets or sets a value that indicates whether an asynchronous job is used to distribute an activity, such as an email, fax, or letter, to the members of a list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PostWorkflowEvent As Boolean

C#
public bool PostWorkflowEvent { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether an asynchronous job is used to distribute an activity, such as an email, fax, or letter, to the members of a list.
true if an asynchronous job is used to distribute the activity; false if mail merge is used to distribute the activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest.QueryExpression Property
[image]

Gets or sets the query criteria to select accounts, contacts, or leads for which activities are created. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueryExpression As QueryBase

C#
public QueryBase QueryExpression { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query criteria to select accounts, contacts, or leads for which activities are created.

  Remarks
Assign an instance of the class FetchExpression, QueryExpression, or QueryByAttribute. The query must specify an entity name and column set. If the column set includes attributes where IsValidForRead is false, they are ignored and the message response contains no data for those attributes. For more information about field security, see How Field Security Can Be Used to Control Access to Field Values in Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest.QueueId Property
[image]

Gets or sets the ID of the queue to which the created activities are added. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueueId As Guid

C#
public Guid QueueId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the queue to which the created activities are added. This corresponds to the Queue.QueueId attribute, which is the primary key for the Queue entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest.SendEmail Property
[image]

Gets or sets a value that indicates whether to send an email about the new activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SendEmail As Boolean

C#
public bool SendEmail { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to send an email about the new activity.
true to automatically send email messages; otherwise, false. Primarily used for the email activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionRequest.TemplateId Property
[image]

Gets or sets the ID of the email template. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the email template. This corresponds to the Template.TemplateId attribute, which is the primary key for the Template entity. Use the email template, if SendEmail is true.Use the email template, if SendEmail is true.Use the email template, if SendEmail is true.Use the email template, if SendEmail is true.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionRequest Class
PropagateByExpressionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionResponse Class
See Also Members
[image]

Contains the response from the PropagateByExpressionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PropagateByExpressionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PropagateByExpressionResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.PropagateByExpressionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
PropagateByExpressionRequest


PropagateByExpressionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the PropagateByExpressionRequest class.

The following tables list the members exposed by the PropagateByExpressionResponse type.

Public Constructors

Name | Description
PropagateByExpressionResponse | Initializes a new instance of the PropagateByExpressionResponse class.
Top

Public Properties

 | Name | Description
public property | BulkOperationId | Gets the ID of the bulk operation that is created to distribute the campaign activity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PropagateByExpressionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PropagateByExpressionRequest


PropagateByExpressionResponse Constructor
[image]

Initializes a new instance of the PropagateByExpressionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PropagateByExpressionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionResponse Class
PropagateByExpressionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PropagateByExpressionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PropagateByExpressionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PropagateByExpressionRequest


PropagateByExpressionResponse Properties
[image]

Public Properties

 | Name | Description
public property | BulkOperationId | Gets the ID of the bulk operation that is created to distribute the campaign activity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

PropagateByExpressionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PropagateByExpressionRequest


PropagateByExpressionResponse.BulkOperationId Property
[image]

Gets the ID of the bulk operation that is created to distribute the campaign activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the bulk operation that is created to distribute the campaign activity. This corresponds to the BulkOperation.ActivityId attribute, which is the primary key for the BulkOperation entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PropagateByExpressionResponse Class
PropagateByExpressionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PropagationOwnershipOptions Enumeration
[image]

Contains the possible values for propagation ownership options.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration PropagationOwnershipOptions

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum PropagationOwnershipOptions

C++

J#

JScript

  Members
Member name | Description
Caller | All created activities are assigned to the caller of the API. Value = 1.
ListMemberOwner | Created activities are assigned to respective owners of target members. Value = 2.
None | There is no change in ownership for the created activities. Value = 0.
  Remarks
Used for the OwnershipOptions, OwnershipOptions, and OwnershipOptions properties.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace
PropagateByExpressionRequest
DistributeCampaignActivityRequest
CreateActivitiesListRequest


ProposalParty Class
See Also Members
[image]

Represents a party (user, team, or resource) that is needed for the proposed appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ProposalParty
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ProposalParty : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.ProposalParty
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace
AppointmentProposal


ProposalParty Members
See Also Constructors Methods Properties
[image]

Represents a party (user, team, or resource) that is needed for the proposed appointment.

The following tables list the members exposed by the ProposalParty type.

Public Constructors

Name | Description
ProposalParty | Overloaded. Initializes a new instance of the ProposalParty class.
Top

Public Properties

 | Name | Description
public property | DisplayName | Gets or sets the display name for the party.
public property | EffortRequired | Gets or sets the percentage of time that is required to perform the service.
public property | EntityName | Gets or sets the logical name of the type of entity that is represented by this party.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ResourceId | Gets or sets the ID of the resource that is represented by this party.
public property | ResourceSpecId | Gets or sets the ID of the resource specification that is represented by this party.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ProposalParty Class
Microsoft.Crm.Sdk.Messages Namespace
AppointmentProposal


ProposalParty Constructor
[image]

Initializes a new instance of the ProposalParty class.

Overload List

Name | Description
ProposalParty () | Initializes a new instance of the ProposalParty class.
ProposalParty (Guid, Guid, String, String, Double) | Initializes a new instance of the ProposalParty class that sets the resource and resource specification IDs, the display and entity names, and the required effort, as measured by percentage of time.

See Also

Reference

ProposalParty Class
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace


ProposalParty Constructor ()
[image]

Initializes a new instance of the ProposalParty class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProposalParty ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProposalParty Class
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace


ProposalParty Constructor (Guid, Guid, String, String, Double)
[image]

Initializes a new instance of the ProposalParty class that sets the resource and resource specification IDs, the display and entity names, and the required effort, as measured by percentage of time.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    resourceId As Guid, _
    resourceSpecId As Guid, _
    displayName As String, _
    entityName As String, _
    effortRequired As Double _
)

C#
public ProposalParty (
    Guid resourceId,
    Guid resourceSpecId,
    string displayName,
    string entityName,
    double effortRequired
)

C++

J#

JScript

Parameters
resourceId
Type: Guid. The ID of the resource that is represented by this party.
resourceSpecId
Type: Guid. The ID of the resource specification that is represented by this party.
displayName
Type: String. The display name for the party.
entityName
Type: String. The logical name of the type of entity that is represented by this party.
effortRequired
Type: Double. The percentage of time that is required to perform the service.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProposalParty Class
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace


ProposalParty Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ProposalParty Class
Microsoft.Crm.Sdk.Messages Namespace
AppointmentProposal


ProposalParty Properties
[image]

Public Properties

 | Name | Description
public property | DisplayName | Gets or sets the display name for the party.
public property | EffortRequired | Gets or sets the percentage of time that is required to perform the service.
public property | EntityName | Gets or sets the logical name of the type of entity that is represented by this party.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ResourceId | Gets or sets the ID of the resource that is represented by this party.
public property | ResourceSpecId | Gets or sets the ID of the resource specification that is represented by this party.

See Also

Reference

ProposalParty Class
Microsoft.Crm.Sdk.Messages Namespace
AppointmentProposal


ProposalParty.DisplayName Property
[image]

Gets or sets the display name for the party.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DisplayName As String

C#
[DataMemberAttribute]
public string DisplayName { get; set; }

C++

J#

JScript

Property Value
Type: String
The display name for the party.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProposalParty Class
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace


ProposalParty.EffortRequired Property
[image]

Gets or sets the percentage of time that is required to perform the service.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EffortRequired As Double

C#
[DataMemberAttribute]
public double EffortRequired { get; set; }

C++

J#

JScript

Property Value
Type: Double
The percentage of time that is required to perform the service.

  Remarks
Use this property to indicate the percentage of time that a service will take. For example, a dentist may fill only one cavity at a time; so the EffortRequired value for this service is 1. However, the dentist can schedule four simultaneous cleanings; each with a different dental hygienist. Therefore, the EffortRequired value for a single cleaning service is .25.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProposalParty Class
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace


ProposalParty.EntityName Property
[image]

Gets or sets the logical name of the type of entity that is represented by this party.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityName As String

C#
[DataMemberAttribute]
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the type of entity that is represented by this party.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProposalParty Class
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace


ProposalParty.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProposalParty Class
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace


ProposalParty.ResourceId Property
[image]

Gets or sets the ID of the resource that is represented by this party.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResourceId As Guid

C#
[DataMemberAttribute]
public Guid ResourceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the resource that is represented by this party. This corresponds to the Resource.ResourceId attribute, which is the primary key for the Resource entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProposalParty Class
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Resource Entities


ProposalParty.ResourceSpecId Property
[image]

Gets or sets the ID of the resource specification that is represented by this party.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResourceSpecId As Guid

C#
[DataMemberAttribute]
public Guid ResourceSpecId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the resource specification that is represented by this party. This corresponds to the ResourceSpec.ResourceSpecId attribute, which is the primary key for the ResourceSpec entity.

  Remarks
The ResourceSpecId property corresponds to the ResourceSpec.ResourceSpecId attribute, which is the primary key for the ResourceSpec entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProposalParty Class
ProposalParty Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Resource Entities


ProvisionLanguageRequest Class
See Also Members
[image]

Contains the data that is needed to provision a new language.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ProvisionLanguageRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ProvisionLanguageRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  ProvisionLanguageResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in ProvisionLanguage Privileges.
Notes for Callers
Before you can provision a language you must first install language packs.
If you have activity feeds enabled environment, do not use this message. Use Microsoft Dynamics CRM Web application to provision a new language.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ProvisionLanguageRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProvisionLanguageRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages
Activity Feeds Entities


ProvisionLanguageRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to provision a new language.

The following tables list the members exposed by the ProvisionLanguageRequest type.

Public Constructors

Name | Description
ProvisionLanguageRequest | Initializes a new instance of theProvisionLanguageRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Language | Gets or sets the language to provision. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ProvisionLanguageRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Activity Feeds Entities


ProvisionLanguageRequest Constructor
[image]

Initializes a new instance of the ProvisionLanguageRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProvisionLanguageRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProvisionLanguageRequest Class
ProvisionLanguageRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ProvisionLanguageRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ProvisionLanguageRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Activity Feeds Entities


ProvisionLanguageRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Language | Gets or sets the language to provision. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ProvisionLanguageRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Activity Feeds Entities


ProvisionLanguageRequest.Language Property
[image]

Gets or sets the language to provision. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Language As Integer

C#
public int Language { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The language to provision. Required.

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProvisionLanguageRequest Class
ProvisionLanguageRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ProvisionLanguageResponse Class
See Also Members
[image]

Contains the response from the ProvisionLanguageRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ProvisionLanguageResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ProvisionLanguageResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ProvisionLanguageResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProvisionLanguageResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ProvisionLanguageRequest


ProvisionLanguageResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ProvisionLanguageRequest class.

The following tables list the members exposed by the ProvisionLanguageResponse type.

Public Constructors

Name | Description
ProvisionLanguageResponse | Initializes a new instance of the ProvisionLanguageResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ProvisionLanguageResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ProvisionLanguageRequest


ProvisionLanguageResponse Constructor
[image]

Initializes a new instance of the ProvisionLanguageResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProvisionLanguageResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProvisionLanguageResponse Class
ProvisionLanguageResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ProvisionLanguageResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ProvisionLanguageResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ProvisionLanguageRequest


ProvisionLanguageResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ProvisionLanguageResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ProvisionLanguageRequest


PublishAllXmlRequest Class
See Also Example Members
[image]

Contains the data that is needed to publish all changes to solution components.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PublishAllXmlRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PublishAllXmlRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
PublishAllXmlRequest publishRequest = new PublishAllXmlRequest();
_serviceProxy.Execute(publishRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  PublishAllXmlResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in PublishAllXml Privileges.
Notes for Callers
Solution components are published automatically when they are created or deleted. You must publish changes when solution components are updated.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.PublishAllXmlRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
PublishAllXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace
PublishXmlRequest
Other Resources
Publish Customizations
Sample: Create and Update Entity Metadata


PublishAllXmlRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to publish all changes to solution components.

The following tables list the members exposed by the PublishAllXmlRequest type.

Public Constructors

Name | Description
PublishAllXmlRequest | Initializes a new instance of the PublishAllXmlRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PublishAllXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PublishXmlRequest

Other Resources

Publish Customizations
Sample: Create and Update Entity Metadata


PublishAllXmlRequest Constructor
[image]

Initializes a new instance of the PublishAllXmlRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PublishAllXmlRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishAllXmlRequest Class
PublishAllXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PublishAllXmlRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PublishAllXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PublishXmlRequest

Other Resources

Publish Customizations
Sample: Create and Update Entity Metadata


PublishAllXmlRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

PublishAllXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PublishXmlRequest

Other Resources

Publish Customizations
Sample: Create and Update Entity Metadata


PublishAllXmlResponse Class
See Also Members
[image]

Contains the response from the PublishAllXmlRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PublishAllXmlResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PublishAllXmlResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.PublishAllXmlResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishAllXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace
PublishAllXmlRequest


PublishAllXmlResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the PublishAllXmlRequest class.

The following tables list the members exposed by the PublishAllXmlResponse type.

Public Constructors

Name | Description
PublishAllXmlResponse | Initializes a new instance of the PublishAllXmlResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PublishAllXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PublishAllXmlRequest


PublishAllXmlResponse Constructor
[image]

Initializes a new instance of the PublishAllXmlResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PublishAllXmlResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishAllXmlResponse Class
PublishAllXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PublishAllXmlResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PublishAllXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PublishAllXmlRequest


PublishAllXmlResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

PublishAllXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PublishAllXmlRequest


PublishDuplicateRuleRequest Class
See Also Example Members
[image]

Contains the data that is needed to submit an asynchronous job to publish a duplicate rule.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PublishDuplicateRuleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PublishDuplicateRuleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Retrieve all rules for the entity
var rules = _serviceProxy.RetrieveMultiple(
    new QueryByAttribute(DuplicateRule.EntityLogicalName)
{
    ColumnSet = new ColumnSet("duplicateruleid"),
    Attributes = { "matchingentityname" },
    Values = { entityName }
});

List<Guid> crmAsyncOperationIds = new List<Guid>();
foreach (var item in rules.Entities)
{
    Console.WriteLine(String.Concat("Publishing duplicate rule: ", item.Id));

    // Publish each rule and get the job id since it is async
    var response = (PublishDuplicateRuleResponse)_serviceProxy.Execute(
            new PublishDuplicateRuleRequest { DuplicateRuleId = item.Id });

    crmAsyncOperationIds.Add(response.JobId);
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  PublishDuplicateRuleResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the DuplicateRule entity and access rights on the record specified in the DuplicateRuleId property.
For a complete list of the required privileges, see PublishDuplicateRule Privileges.
Notes for Callers
A duplicate rule publishing job creates a matchcode for every entity record that a duplicate detection rule applies to. The matchcode is used as a part of the process for detecting duplicates.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.PublishDuplicateRuleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
PublishDuplicateRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
PublishDuplicateRuleResponse
Other Resources
PublishDuplicateRule Privileges
Sample: Enable Duplicate Detection and Retrieve Duplicates
Detect Duplicate Data in Microsoft Dynamics CRM
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


PublishDuplicateRuleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to submit an asynchronous job to publish a duplicate rule.

The following tables list the members exposed by the PublishDuplicateRuleRequest type.

Public Constructors

Name | Description
PublishDuplicateRuleRequest | Initializes a new instance of the PublishDuplicateRuleRequest class.
Top

Public Properties

 | Name | Description
public property | DuplicateRuleId | Gets or sets the ID of the duplicate rule to be published. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PublishDuplicateRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PublishDuplicateRuleResponse

Other Resources

PublishDuplicateRule Privileges
Sample: Enable Duplicate Detection and Retrieve Duplicates
Detect Duplicate Data in Microsoft Dynamics CRM
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


PublishDuplicateRuleRequest Constructor
[image]

Initializes a new instance of the PublishDuplicateRuleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PublishDuplicateRuleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishDuplicateRuleRequest Class
PublishDuplicateRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PublishDuplicateRuleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PublishDuplicateRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PublishDuplicateRuleResponse

Other Resources

PublishDuplicateRule Privileges
Sample: Enable Duplicate Detection and Retrieve Duplicates
Detect Duplicate Data in Microsoft Dynamics CRM
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


PublishDuplicateRuleRequest Properties
[image]

Public Properties

 | Name | Description
public property | DuplicateRuleId | Gets or sets the ID of the duplicate rule to be published. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

PublishDuplicateRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PublishDuplicateRuleResponse

Other Resources

PublishDuplicateRule Privileges
Sample: Enable Duplicate Detection and Retrieve Duplicates
Detect Duplicate Data in Microsoft Dynamics CRM
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


PublishDuplicateRuleRequest.DuplicateRuleId Property
[image]

Gets or sets the ID of the duplicate rule to be published. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DuplicateRuleId As Guid

C#
public Guid DuplicateRuleId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the duplicate rule to be published. This corresponds to the DuplicateRule.DuplicateRuleId attribute, which is the primary key for the DuplicateRule entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishDuplicateRuleRequest Class
PublishDuplicateRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PublishDuplicateRuleResponse Class
See Also Members
[image]

Contains the response from the PublishDuplicateRuleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PublishDuplicateRuleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PublishDuplicateRuleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.PublishDuplicateRuleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishDuplicateRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
PublishDuplicateRuleRequest


PublishDuplicateRuleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the PublishDuplicateRuleRequest class.

The following tables list the members exposed by the PublishDuplicateRuleResponse type.

Public Constructors

Name | Description
PublishDuplicateRuleResponse | Initializes a new instance of the PublishDuplicateRuleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | JobId | Gets the ID of the asynchronous job for publishing a duplicate detection rule.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PublishDuplicateRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PublishDuplicateRuleRequest


PublishDuplicateRuleResponse Constructor
[image]

Initializes a new instance of the PublishDuplicateRuleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PublishDuplicateRuleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishDuplicateRuleResponse Class
PublishDuplicateRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PublishDuplicateRuleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PublishDuplicateRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PublishDuplicateRuleRequest


PublishDuplicateRuleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | JobId | Gets the ID of the asynchronous job for publishing a duplicate detection rule.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

PublishDuplicateRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PublishDuplicateRuleRequest


PublishDuplicateRuleResponse.JobId Property
[image]

Gets the ID of the asynchronous job for publishing a duplicate detection rule.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property JobId As Guid

C#
public Guid JobId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the asynchronous job for publishing a duplicate detection rule.

  Remarks
This property is read-only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishDuplicateRuleResponse Class
PublishDuplicateRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PublishProductHierarchyRequest Class
See Also Members
[image]

Contain the data that is needed to publish a product family record and all its child records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PublishProductHierarchyRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PublishProductHierarchyRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of PublishProductHierarchyResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Product entity and access rights on the product family record specified in the Target property.
Notes to Callers
This message will publish the entire hierarchy of child product family, product, and bundle records under the specified product family record.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.PublishProductHierarchyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishProductHierarchyRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Publish a product family, product, or bundle
Sample: Create and publish products


PublishProductHierarchyRequest Members
See Also Constructors Methods Properties
[image]

Contain the data that is needed to publish a product family record and all its child records.

The following tables list the members exposed by the PublishProductHierarchyRequest type.

Public Constructors

Name | Description
PublishProductHierarchyRequest | Initializes a new instance of the PublishProductHierarchyRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target product family record that you want to publish along with its child records.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PublishProductHierarchyRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Publish a product family, product, or bundle
Sample: Create and publish products


PublishProductHierarchyRequest Constructor
[image]

Initializes a new instance of the PublishProductHierarchyRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PublishProductHierarchyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishProductHierarchyRequest Class
PublishProductHierarchyRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PublishProductHierarchyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PublishProductHierarchyRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Publish a product family, product, or bundle
Sample: Create and publish products


PublishProductHierarchyRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target product family record that you want to publish along with its child records.

See Also

Reference

PublishProductHierarchyRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Publish a product family, product, or bundle
Sample: Create and publish products


PublishProductHierarchyRequest.Target Property
[image]

Gets or sets the target product family record that you want to publish along with its child records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type EntityReference
The target product family record that you want to publish along with its child records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishProductHierarchyRequest Class
PublishProductHierarchyRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PublishProductHierarchyResponse Class
See Also Members
[image]

Contains the response from the PublishProductHierarchyRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PublishProductHierarchyResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PublishProductHierarchyResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.PublishProductHierarchyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishProductHierarchyResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PublishProductHierarchyResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the PublishProductHierarchyRequest class.

The following tables list the members exposed by the PublishProductHierarchyResponse type.

Public Constructors

Name | Description
PublishProductHierarchyResponse | Initializes a new instance of the PublishProductHierarchyResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PublishProductHierarchyResponse Class
Microsoft.Crm.Sdk.Messages Namespace


PublishProductHierarchyResponse Constructor
[image]

Initializes a new instance of the PublishProductHierarchyResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PublishProductHierarchyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishProductHierarchyResponse Class
PublishProductHierarchyResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PublishProductHierarchyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PublishProductHierarchyResponse Class
Microsoft.Crm.Sdk.Messages Namespace


PublishProductHierarchyResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

PublishProductHierarchyResponse Class
Microsoft.Crm.Sdk.Messages Namespace


PublishXmlRequest Class
See Also Example Members
[image]

Contains the data that is needed to publish specified solution components.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PublishXmlRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PublishXmlRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic. This sample updates a global option set and then publishes just that option set.
C#    Copy Code
// Use UpdateOptionSetRequest to update the basic information of an option
// set. Updating option set values requires different messages (see below).
UpdateOptionSetRequest updateOptionSetRequest = new UpdateOptionSetRequest
{
    OptionSet = new OptionSetMetadata
    {
        DisplayName = new Label("Updated Option Set", _languageCode),
        Name = _globalOptionSetName,
        IsGlobal = true
    }
};

_serviceProxy.Execute(updateOptionSetRequest);

//Publish the OptionSet
PublishXmlRequest pxReq1 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
_serviceProxy.Execute(pxReq1);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  PublishXmlResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in PublishXml Privileges.
Notes for Callers
Use this message to publish a specified subset of solution components. See ParameterXml for details about how to specify the solution components to publish.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.PublishXmlRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
PublishXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace
PublishAllXmlRequest
Other Resources
Sample: Work with Global Option Sets
Publish Customizations
Publish Request Schema


PublishXmlRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to publish specified solution components.

The following tables list the members exposed by the PublishXmlRequest type.

Public Constructors

Name | Description
PublishXmlRequest | Initializes a new instance of the PublishXmlRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParameterXml | Gets or sets the XML that defines which solution components to publish in this request. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PublishXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PublishAllXmlRequest

Other Resources

Sample: Work with Global Option Sets
Publish Customizations
Publish Request Schema


PublishXmlRequest Constructor
[image]

Initializes a new instance of the PublishXmlRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PublishXmlRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishXmlRequest Class
PublishXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PublishXmlRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PublishXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PublishAllXmlRequest

Other Resources

Sample: Work with Global Option Sets
Publish Customizations
Publish Request Schema


PublishXmlRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParameterXml | Gets or sets the XML that defines which solution components to publish in this request. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

PublishXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
PublishAllXmlRequest

Other Resources

Sample: Work with Global Option Sets
Publish Customizations
Publish Request Schema


PublishXmlRequest.ParameterXml Property
[image]

Gets or sets the XML that defines which solution components to publish in this request. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ParameterXml As String

C#
public string ParameterXml { get; set; }

C++

J#

JScript

Property Value
Type: String
the XML that defines which solution components to publish in this request. Required.

  Remarks
Use the Publish Request Schema to compose the correct XML to pass for this parameter.
You can publish the following solution components:
Entities
Use the logical name of the entity. The following example publishes just the account entity including any attributes, ribbons or forms associated with it.
Visual Basic    Copy Code
<importexportxml>
 <entities>
  <entity>account</entity>
 </entities>
</importexportxml>

Ribbons
Publishes the Application Ribbon. You do not need to specify any value. The application ribbon will be published as long as the <ribbon> node is present.
Xml    Copy Code
<importexportxml>
 <ribbons>
  <ribbon></ribbon>
 </ribbons>
</importexportxml>

Dashboards
Publishes the SystemForm (dashboard) for the ID value passed.
Xml    Copy Code
<importexportxml>
 <dashboards>
  <dashboard>{DEDBADA0-1C50-4E0B-BC88-5CE4225D6561}</dashboard>
 </dashboards>
</importexportxml>

Option Sets
Publishes an optionset using the optionset unique name.
Xml    Copy Code
<importexportxml>
 <optionsets>
  <optionset>sample_customoptionset</optionset>
 </optionsets>
</importexportxml>

Site Map
Publishes the SiteMap. Since there is only one sitemap it is not necessary to pass a value.
Xml    Copy Code
<importexportxml>
 <sitemaps>
  <sitemap></sitemap>
 </sitemaps>
</importexportxml>

Web Resources
Publishes a Web resource using the web resource id value.
Xml    Copy Code
<importexportxml>
 <webresources>
  <webresource>{025225B2-CF33-4CDB-8ACD-C6205404191E}</webresource>
 </webresources>
</importexportxml>

The following example publishes the account and contact entity together with two Web resources.
Xml    Copy Code
<importexportxml>
 <entities>
  <entity>account</entity>
  <entity>contact</entity>
 </entities>
 <webresources>
  <webresource>{025225B2-CF33-4CDB-8ACD-C6205404191E}</webresource>
  <webresource>{6B72CB14-D27D-4197-B494-C1A06C977C41}</webresource>
 </webresources>
</importexportxml>

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
PublishXmlRequest Class
PublishXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace


PublishXmlResponse Class
See Also Members
[image]

Contains the response from the PublishXmlRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class PublishXmlResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class PublishXmlResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.PublishXmlResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace
PublishXmlRequest


PublishXmlResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the PublishXmlRequest class.

The following tables list the members exposed by the PublishXmlResponse type.

Public Constructors

Name | Description
PublishXmlResponse | Initializes a new instance of the PublishXmlResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PublishXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PublishXmlRequest


PublishXmlResponse Constructor
[image]

Initializes a new instance of the PublishXmlResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PublishXmlResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PublishXmlResponse Class
PublishXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


PublishXmlResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PublishXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PublishXmlRequest


PublishXmlResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

PublishXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
PublishXmlRequest


QualifyLeadRequest Class
See Also Example Members
[image]

Contains the data that is needed to qualify a lead and create account, contact, and opportunity records that are linked to the originating lead record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QualifyLeadRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QualifyLeadRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Qualify the first lead, creating an account and a contact from it, but
// not creating an opportunity.
var qualifyIntoAccountContactReq = new QualifyLeadRequest
{
    CreateAccount = true,
    CreateContact = true,
    LeadId = new EntityReference(Lead.EntityLogicalName, _lead1Id),
    Status = new OptionSetValue((int)lead_statuscode.Qualified)
};

var qualifyIntoAccountContactRes =
    (QualifyLeadResponse)_serviceProxy.Execute(qualifyIntoAccountContactReq);
Console.WriteLine("  The first lead was qualified.");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of the QualifyLeadResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Lead, Account, Contact, Opportunity, TransactionCurrency, and Campaign entities. The caller must also have access rights on the specified records in the following properties: LeadId, OpportunityCurrencyId, OpportunityCustomerId, and SourceCampaignId. For a complete list of required privileges, see QualifyLead Privileges.
Notes for Callers
If SharePoint integration is enabled, the document location records for the lead are copied for the newly created account, contact, and opportunity.
If you set the CreateAccount property and the CreateContact property to true, the created account becomes a parent (Contact.Parentcustomerid) of the contact and the contact becomes a primary contact (Account.PrimaryContactId) for the account.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.QualifyLeadRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace
QualifyLeadResponse
Other Resources
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Qualify a Lead
Customer Entities (Account, Contact)
TransactionCurrency (Currency) Entity
Campaign Entities
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM
QualifyLead Privileges


QualifyLeadRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to qualify a lead and create account, contact, and opportunity records that are linked to the originating lead record.

The following tables list the members exposed by the QualifyLeadRequest type.

Public Constructors

Name | Description
QualifyLeadRequest | Initializes a new instance of the QualifyLeadRequest class.
Top

Public Properties

 | Name | Description
public property | CreateAccount | Gets or sets a value that indicates whether to create an account from the originating lead. Required.
public property | CreateContact | Gets or sets a value that indicates whether to create a contact from the originating lead. Required.
public property | CreateOpportunity | Gets or sets a value that indicates whether to create an opportunity from the originating lead. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LeadId | Gets or sets the ID of the lead that is qualified. Required.
public property | OpportunityCurrencyId | Gets or sets the currency to use for this opportunity. Required.
public property | OpportunityCustomerId | Gets or set the account or contact that is associated with the opportunity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SourceCampaignId | Gets or sets the source campaign that is associated with the opportunity. Required.
public property | Status | Gets or sets the status of the lead. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QualifyLeadRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyLeadResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Qualify a Lead
Customer Entities (Account, Contact)
TransactionCurrency (Currency) Entity
Campaign Entities
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM
QualifyLead Privileges


QualifyLeadRequest Constructor
[image]

Initializes a new instance of the QualifyLeadRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QualifyLeadRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadRequest Class
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QualifyLeadRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyLeadResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Qualify a Lead
Customer Entities (Account, Contact)
TransactionCurrency (Currency) Entity
Campaign Entities
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM
QualifyLead Privileges


QualifyLeadRequest Properties
[image]

Public Properties

 | Name | Description
public property | CreateAccount | Gets or sets a value that indicates whether to create an account from the originating lead. Required.
public property | CreateContact | Gets or sets a value that indicates whether to create a contact from the originating lead. Required.
public property | CreateOpportunity | Gets or sets a value that indicates whether to create an opportunity from the originating lead. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LeadId | Gets or sets the ID of the lead that is qualified. Required.
public property | OpportunityCurrencyId | Gets or sets the currency to use for this opportunity. Required.
public property | OpportunityCustomerId | Gets or set the account or contact that is associated with the opportunity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SourceCampaignId | Gets or sets the source campaign that is associated with the opportunity. Required.
public property | Status | Gets or sets the status of the lead. Required.

See Also

Reference

QualifyLeadRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyLeadResponse

Other Resources

Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
Sample: Qualify a Lead
Customer Entities (Account, Contact)
TransactionCurrency (Currency) Entity
Campaign Entities
How Role-Based Security Can Be Used to Control Access to Entities in CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) in CRM
QualifyLead Privileges


QualifyLeadRequest.CreateAccount Property
[image]

Gets or sets a value that indicates whether to create an account from the originating lead. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CreateAccount As Boolean

C#
public bool CreateAccount { get; set; }

C++

J#

JScript

Property Value
Type:  Boolean
Indicates whether to create an account from the originating lead.
True, to create an account; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadRequest Class
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadRequest.CreateContact Property
[image]

Gets or sets a value that indicates whether to create a contact from the originating lead. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CreateContact As Boolean

C#
public bool CreateContact { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to create a contact from the originating lead.
True, to create a contact; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadRequest Class
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadRequest.CreateOpportunity Property
[image]

Gets or sets a value that indicates whether to create an opportunity from the originating lead. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CreateOpportunity As Boolean

C#
public bool CreateOpportunity { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to create an opportunity from the originating lead.
True, to create an opportunity; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadRequest Class
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadRequest.LeadId Property
[image]

Gets or sets the ID of the lead that is qualified. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LeadId As EntityReference

C#
public EntityReference LeadId { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The ID of the lead that is qualified. This corresponds to the Lead.LeadId attribute, which is the primary key for the Lead entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadRequest Class
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadRequest.OpportunityCurrencyId Property
[image]

Gets or sets the currency to use for this opportunity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityCurrencyId As EntityReference

C#
public EntityReference OpportunityCurrencyId { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The currency to use for this opportunity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadRequest Class
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadRequest.OpportunityCustomerId Property
[image]

Gets or set the account or contact that is associated with the opportunity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityCustomerId As EntityReference

C#
public EntityReference OpportunityCustomerId { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The account or contact that is associated with the opportunity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadRequest Class
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadRequest.SourceCampaignId Property
[image]

Gets or sets the source campaign that is associated with the opportunity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SourceCampaignId As EntityReference

C#
public EntityReference SourceCampaignId { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The source campaign that is associated with the opportunity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadRequest Class
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadRequest.Status Property
[image]

Gets or sets the status of the lead. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The status of the lead.

  Remarks
The Status property corresponds to the Lead.StatusCode attribute of the Lead entity. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system sets the appropriate corresponding status value. For a list of status values, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.  For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadRequest Class
QualifyLeadRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadResponse Class
See Also Members
[image]

Contains the response from the QualifyLeadRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QualifyLeadResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QualifyLeadResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.QualifyLeadResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadResponse Members
Microsoft.Crm.Sdk.Messages Namespace
QualifyLeadRequest


QualifyLeadResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the QualifyLeadRequest class.

The following tables list the members exposed by the QualifyLeadResponse type.

Public Constructors

Name | Description
QualifyLeadResponse | Initializes a new instance of the QualifyLeadResponse class.
Top

Public Properties

 | Name | Description
public property | CreatedEntities | Gets the collection of references to the newly created account, contact, and opportunity records.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QualifyLeadResponse Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyLeadRequest


QualifyLeadResponse Constructor
[image]

Initializes a new instance of the QualifyLeadResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QualifyLeadResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadResponse Class
QualifyLeadResponse Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyLeadResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QualifyLeadResponse Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyLeadRequest


QualifyLeadResponse Properties
[image]

Public Properties

 | Name | Description
public property | CreatedEntities | Gets the collection of references to the newly created account, contact, and opportunity records.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

QualifyLeadResponse Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyLeadRequest


QualifyLeadResponse.CreatedEntities Property
[image]

Gets the collection of references to the newly created account, contact, and opportunity records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CreatedEntities As EntityReferenceCollection

C#
public EntityReferenceCollection CreatedEntities { get; }

C++

J#

JScript

Property Value
Type: EntityReferenceCollection
The collection of references to the newly created account, contact, and opportunity records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyLeadResponse Class
QualifyLeadResponse Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyMemberListRequest Class
See Also Members
[image]

Contains the data that is needed to qualify the specified list and either override the list members or remove them according to the specified option.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QualifyMemberListRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QualifyMemberListRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of QualifyMemberListResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the List entity and access rights on the records specified in the ListId property and the MembersId property.
For a complete list of required privileges, see QualifyMemberList Privileges.
Notes to Callers
The list members are accounts, contacts, or leads. Qualify means to evaluate which members to keep in the list. You select members to evaluate by using a query. For example, you might search for members that are in a particular zip code. This message is invoked by using Manage Members in the web application.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.QualifyMemberListRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
QualifyMemberListResponse
Other Resources
QualifyMemberList Privileges
List (Marketing List) Entity
Sample: Distribute Campaign Activities to Qualified Marketing List
List Member Intersect Entity Metadata
Customer Entities (Account, Contact)
Lead Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


QualifyMemberListRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to qualify the specified list and either override the list members or remove them according to the specified option.

The following tables list the members exposed by the QualifyMemberListRequest type.

Public Constructors

Name | Description
QualifyMemberListRequest | Initializes a new instance of the QualifyMemberListRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list to qualify. Required.
public property | MembersId | Gets or sets an array of IDs of the members to qualify. Required.
public property | OverrideorRemove | Gets or sets a value that indicates whether to override or remove the members from the list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QualifyMemberListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyMemberListResponse

Other Resources

QualifyMemberList Privileges
List (Marketing List) Entity
Sample: Distribute Campaign Activities to Qualified Marketing List
List Member Intersect Entity Metadata
Customer Entities (Account, Contact)
Lead Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


QualifyMemberListRequest Constructor
[image]

Initializes a new instance of the QualifyMemberListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QualifyMemberListRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyMemberListRequest Class
QualifyMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyMemberListRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QualifyMemberListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyMemberListResponse

Other Resources

QualifyMemberList Privileges
List (Marketing List) Entity
Sample: Distribute Campaign Activities to Qualified Marketing List
List Member Intersect Entity Metadata
Customer Entities (Account, Contact)
Lead Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


QualifyMemberListRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list to qualify. Required.
public property | MembersId | Gets or sets an array of IDs of the members to qualify. Required.
public property | OverrideorRemove | Gets or sets a value that indicates whether to override or remove the members from the list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

QualifyMemberListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyMemberListResponse

Other Resources

QualifyMemberList Privileges
List (Marketing List) Entity
Sample: Distribute Campaign Activities to Qualified Marketing List
List Member Intersect Entity Metadata
Customer Entities (Account, Contact)
Lead Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


QualifyMemberListRequest.ListId Property
[image]

Gets or sets the ID of the list to qualify. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ListId As Guid

C#
public Guid ListId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the list to qualify. This corresponds to the List.ListId attribute, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyMemberListRequest Class
QualifyMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyMemberListRequest.MembersId Property
[image]

Gets or sets an array of IDs of the members to qualify. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MembersId As Guid()

C#
public Guid[] MembersId { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]
The array of IDs of the members to qualify.

  Remarks
The list members can be accounts, contacts, or leads. Each element of the MemberIds array corresponds to the Account.AccountId property, Contact.ContactId property, or Lead.LeadId property, which is the primary key for the corresponding entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyMemberListRequest Class
QualifyMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyMemberListRequest.OverrideorRemove Property
[image]

Gets or sets a value that indicates whether to override or remove the members from the list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OverrideorRemove As Boolean

C#
public bool OverrideorRemove { get; set; }

C++

J#

JScript

Property Value
Type:  Boolean
Indicates whether to override or remove the members from the list.
true, to override; false, to remove.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyMemberListRequest Class
QualifyMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyMemberListResponse Class
See Also Members
[image]

Contains the response from the QualifyMemberListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QualifyMemberListResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QualifyMemberListResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.QualifyMemberListResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyMemberListResponse Members
Microsoft.Crm.Sdk.Messages Namespace
QualifyMemberListRequest


QualifyMemberListResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the QualifyMemberListRequest class.

The following tables list the members exposed by the QualifyMemberListResponse type.

Public Constructors

Name | Description
QualifyMemberListResponse | Initializes a new instance of the QualifyMemberListResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QualifyMemberListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyMemberListRequest


QualifyMemberListResponse Constructor
[image]

Initializes a new instance of the QualifyMemberListResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QualifyMemberListResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QualifyMemberListResponse Class
QualifyMemberListResponse Members
Microsoft.Crm.Sdk.Messages Namespace


QualifyMemberListResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QualifyMemberListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyMemberListRequest


QualifyMemberListResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

QualifyMemberListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
QualifyMemberListRequest


QueryExpressionToFetchXmlRequest Class
See Also Example Members
[image]

Contains the data that is needed to convert a query, which is represented as a QueryExpression class, to its equivalent query, which is represented as FetchXML.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QueryExpressionToFetchXmlRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QueryExpressionToFetchXmlRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Build a query expression that we will turn into FetchXML.
var queryExpression = new QueryExpression()
{
    Distinct = false,
    EntityName = Contact.EntityLogicalName,
    ColumnSet = new ColumnSet("fullname", "address1_telephone1"),
    LinkEntities =
        {
            new LinkEntity
            {
                JoinOperator = JoinOperator.LeftOuter,
                LinkFromAttributeName = "parentcustomerid",
                LinkFromEntityName = Contact.EntityLogicalName,
                LinkToAttributeName = "accountid",
                LinkToEntityName = Account.EntityLogicalName,
                LinkCriteria =
                {
                    Conditions =
                    {
                        new ConditionExpression("name", ConditionOperator.Equal, "Litware, Inc.")
                    }
                }
            }
        },
    Criteria =
    {
        Filters =
            {
                new FilterExpression
                {
                    FilterOperator = LogicalOperator.And,
                    Conditions =
                    {
                        new ConditionExpression("address1_stateorprovince", ConditionOperator.Equal, "WA"),
                        new ConditionExpression("address1_city", ConditionOperator.In, new String[] {"Redmond", "Bellevue" , "Kirkland", "Seattle"}),
                        new ConditionExpression("createdon", ConditionOperator.LastXDays, 30),
                        new ConditionExpression("emailaddress1", ConditionOperator.NotNull)
                    },
                },
                new FilterExpression
                {
                    FilterOperator = LogicalOperator.Or,
                    Conditions =
                    {
                        new ConditionExpression("address1_telephone1", ConditionOperator.Like, "(206)%"),
                        new ConditionExpression("address1_telephone1", ConditionOperator.Like, "(425)%")
                    }
                }
            }
    }
};

// Run the query as a query expression.
EntityCollection queryExpressionResult =
    _serviceProxy.RetrieveMultiple(queryExpression);
Console.WriteLine("Output for query as QueryExpression:");
DisplayContactQueryResults(queryExpressionResult);

// Convert the query expression to FetchXML.
var conversionRequest = new QueryExpressionToFetchXmlRequest
{
    Query = queryExpression
};
var conversionResponse =
    (QueryExpressionToFetchXmlResponse)_serviceProxy.Execute(conversionRequest);

// Use the converted query to make a retrieve multiple request to Microsoft Dynamics CRM.
String fetchXml = conversionResponse.FetchXml;
var fetchQuery = new FetchExpression(fetchXml);
EntityCollection result = _serviceProxy.RetrieveMultiple(fetchQuery);

// Display the results.
Console.WriteLine("\nOutput for query after conversion to FetchXML:");
DisplayContactQueryResults(result);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the QueryExpressionToFetchXmlResponse class.
Privileges and Access Rights
For a complete list of the required privileges, see QueryExpressionToFetchXml Privileges.
Notes for Callers
Use of the keyword distinct in query expressions is different from the FetchXML query language. When you map a query from Fetch to QueryExpression, you receive inconsistent results if you use the Distinct keyword in the FetchXML string.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.QueryExpressionToFetchXmlRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
QueryExpressionToFetchXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace
QueryExpressionToFetchXmlResponse
Other Resources
Create Queries to Retrieve Data
Page Large Result Sets with Query Expression and FetchXML
Build Queries with QueryExpression
FetchXML Schema
Sample: Convert Queries Between Fetch and Query Expression


QueryExpressionToFetchXmlRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to convert a query, which is represented as a QueryExpression class, to its equivalent query, which is represented as FetchXML.

The following tables list the members exposed by the QueryExpressionToFetchXmlRequest type.

Public Constructors

Name | Description
QueryExpressionToFetchXmlRequest | Initializes a new instance of the the QueryExpressionToFetchXmlRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query to convert.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QueryExpressionToFetchXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QueryExpressionToFetchXmlResponse

Other Resources

Create Queries to Retrieve Data
Page Large Result Sets with Query Expression and FetchXML
Build Queries with QueryExpression
FetchXML Schema
Sample: Convert Queries Between Fetch and Query Expression


QueryExpressionToFetchXmlRequest Constructor
[image]

Initializes a new instance of the the QueryExpressionToFetchXmlRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QueryExpressionToFetchXmlRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpressionToFetchXmlRequest Class
QueryExpressionToFetchXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryExpressionToFetchXmlRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QueryExpressionToFetchXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QueryExpressionToFetchXmlResponse

Other Resources

Create Queries to Retrieve Data
Page Large Result Sets with Query Expression and FetchXML
Build Queries with QueryExpression
FetchXML Schema
Sample: Convert Queries Between Fetch and Query Expression


QueryExpressionToFetchXmlRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query to convert.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

QueryExpressionToFetchXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QueryExpressionToFetchXmlResponse

Other Resources

Create Queries to Retrieve Data
Page Large Result Sets with Query Expression and FetchXML
Build Queries with QueryExpression
FetchXML Schema
Sample: Convert Queries Between Fetch and Query Expression


QueryExpressionToFetchXmlRequest.Query Property
[image]

Gets or sets the query to convert.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query to convert.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpressionToFetchXmlRequest Class
QueryExpressionToFetchXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Create Queries to Retrieve Data


QueryExpressionToFetchXmlResponse Class
See Also Members
[image]

Contains the response from the QueryExpressionToFetchXmlRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QueryExpressionToFetchXmlResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QueryExpressionToFetchXmlResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.QueryExpressionToFetchXmlResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpressionToFetchXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


QueryExpressionToFetchXmlResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the QueryExpressionToFetchXmlRequest class.

The following tables list the members exposed by the QueryExpressionToFetchXmlResponse type.

Public Constructors

Name | Description
QueryExpressionToFetchXmlResponse | Initializes a new instance of the QueryExpressionToFetchXmlResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | FetchXml | Gets the results of the query conversion.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QueryExpressionToFetchXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace


QueryExpressionToFetchXmlResponse Constructor
[image]

Initializes a new instance of the QueryExpressionToFetchXmlResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QueryExpressionToFetchXmlResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpressionToFetchXmlResponse Class
QueryExpressionToFetchXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


QueryExpressionToFetchXmlResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QueryExpressionToFetchXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace


QueryExpressionToFetchXmlResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | FetchXml | Gets the results of the query conversion.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

QueryExpressionToFetchXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace


QueryExpressionToFetchXmlResponse.FetchXml Property
[image]

Gets the results of the query conversion.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property FetchXml As String

C#
public string FetchXml { get; }

C++

J#

JScript

Property Value
Type: String
The results of the query conversion. This returned value conforms to the schema for FetchXML.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpressionToFetchXmlResponse Class
QueryExpressionToFetchXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Build Queries with FetchXML
FetchXML Schema


QueryMultipleSchedulesRequest Class
See Also Example Members
[image]

Contains the data that is needed to search multiple resources for available time block that match the specified parameters.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QueryMultipleSchedulesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QueryMultipleSchedulesRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Pass an instance of this class to the  Execute method, which returns an instance of  the QueryMultipleSchedulesResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Resource entity and access rights on the specified records in the ResourceIds property. For a list of the required privileges, see QueryMultipleSchedules Privileges.
Notes for Callers
This class functions similarly to the QueryScheduleRequest class, except that this class searches for multiple resources at one time.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.QueryMultipleSchedulesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryMultipleSchedulesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
QueryMultipleSchedulesResponse
Other Resources
Schedules in Microsoft Dynamics CRM
Sample: Query the Schedules of Multiple Users


QueryMultipleSchedulesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to search multiple resources for available time block that match the specified parameters.

The following tables list the members exposed by the QueryMultipleSchedulesRequest type.

Public Constructors

Name | Description
QueryMultipleSchedulesRequest | Initializes a new instance of the QueryMultipleSchedulesRequest class.
Top

Public Properties

 | Name | Description
public property | End | Gets or sets the end time for the scheduled block of time. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceIds | Gets or sets the IDs of the resources. Required.
public property | Start | Gets or sets the start of the time slot. Required.
public property | TimeCodes | Gets or sets the time codes to look for: Available, Busy, Unavailable, or Filter, which correspond to the resource IDs. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QueryMultipleSchedulesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QueryMultipleSchedulesResponse

Other Resources

Schedules in Microsoft Dynamics CRM
Sample: Query the Schedules of Multiple Users


QueryMultipleSchedulesRequest Constructor
[image]

Initializes a new instance of the QueryMultipleSchedulesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QueryMultipleSchedulesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryMultipleSchedulesRequest Class
QueryMultipleSchedulesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QueryMultipleSchedulesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QueryMultipleSchedulesResponse

Other Resources

Schedules in Microsoft Dynamics CRM
Sample: Query the Schedules of Multiple Users


QueryMultipleSchedulesRequest Properties
[image]

Public Properties

 | Name | Description
public property | End | Gets or sets the end time for the scheduled block of time. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceIds | Gets or sets the IDs of the resources. Required.
public property | Start | Gets or sets the start of the time slot. Required.
public property | TimeCodes | Gets or sets the time codes to look for: Available, Busy, Unavailable, or Filter, which correspond to the resource IDs. Required.

See Also

Reference

QueryMultipleSchedulesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QueryMultipleSchedulesResponse

Other Resources

Schedules in Microsoft Dynamics CRM
Sample: Query the Schedules of Multiple Users


QueryMultipleSchedulesRequest.End Property
[image]

Gets or sets the end time for the scheduled block of time. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property End As DateTime

C#
public DateTime End { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The end time for the scheduled block of time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryMultipleSchedulesRequest Class
QueryMultipleSchedulesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesRequest.ResourceIds Property
[image]

Gets or sets the IDs of the resources. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ResourceIds As Guid()

C#
public Guid[] ResourceIds { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The IDs of the resources.
Each element of the ResourceIds array corresponds to the Resource.ResourceId attribute, which is the primary key for the Resource entity. The number of resource IDs and time codes must match.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryMultipleSchedulesRequest Class
QueryMultipleSchedulesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesRequest.Start Property
[image]

Gets or sets the start of the time slot. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Start As DateTime

C#
public DateTime Start { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The start of the time slot.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryMultipleSchedulesRequest Class
QueryMultipleSchedulesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesRequest.TimeCodes Property
[image]

Gets or sets the time codes to look for: Available, Busy, Unavailable, or Filter, which correspond to the resource IDs. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TimeCodes As TimeCode()

C#
public TimeCode[] TimeCodes { get; set; }

C++

J#

JScript

Property Value
Type: TimeCode
The time codes to look for: Available, Busy, Unavailable, or Filter, which correspond to the resource IDs. The number of resource IDs and time codes must match.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryMultipleSchedulesRequest Class
QueryMultipleSchedulesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesResponse Class
See Also Members
[image]

Contains the response from the QueryMultipleSchedulesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QueryMultipleSchedulesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QueryMultipleSchedulesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.QueryMultipleSchedulesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryMultipleSchedulesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the QueryMultipleSchedulesRequest class.

The following tables list the members exposed by the QueryMultipleSchedulesResponse type.

Public Constructors

Name | Description
QueryMultipleSchedulesResponse | Initializes a new instance of the QueryMultipleSchedulesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TimeInfos | Gets the results of the search, which is a set of possible time block for each resource.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QueryMultipleSchedulesResponse Class
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesResponse Constructor
[image]

Initializes a new instance of the QueryMultipleSchedulesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QueryMultipleSchedulesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryMultipleSchedulesResponse Class
QueryMultipleSchedulesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QueryMultipleSchedulesResponse Class
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TimeInfos | Gets the results of the search, which is a set of possible time block for each resource.

See Also

Reference

QueryMultipleSchedulesResponse Class
Microsoft.Crm.Sdk.Messages Namespace


QueryMultipleSchedulesResponse.TimeInfos Property
[image]

Gets the results of the search, which is a set of possible time block for each resource.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property TimeInfos As TimeInfo()()

C#
public TimeInfo[][] TimeInfos { get; }

C++

J#

JScript

Property Value
Type: TimeInfo
The results of the search. Contains an array of possible time slots for each of the specified resource IDs in the QueryMultipleSchedulesRequest class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryMultipleSchedulesResponse Class
QueryMultipleSchedulesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


QueryScheduleRequest Class
See Also Example Members
[image]

Contains the data that is needed to search the specified resource for an available time block that matches the specified parameters.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QueryScheduleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QueryScheduleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Pass an instance of this class to the  Execute method, which returns an instance of  the QueryScheduleResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Resource entity and access rights on the specified record in the ResourceId property. For a list of the required privileges, see QuerySchedule Privileges.
Notes for Callers
This request class is similar to the QueryMultipleSchedulesRequest class; however, this class searches for only one resource at a time.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.QueryScheduleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryScheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
QueryScheduleResponse
Other Resources
Schedules in Microsoft Dynamics CRM
Sample: Query the Schedule of a User


QueryScheduleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to search the specified resource for an available time block that matches the specified parameters.

The following tables list the members exposed by the QueryScheduleRequest type.

Public Constructors

Name | Description
QueryScheduleRequest | Initializes a new instance of the QueryScheduleRequest class.
Top

Public Properties

 | Name | Description
public property | End | Gets or sets the end of the time slot.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceId | Gets or sets the ID of the resource.
public property | Start | Gets or sets the start of the time slot.
public property | TimeCodes | Gets or sets the time codes to look for: Available, Busy, Unavailable, or Filter.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QueryScheduleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QueryScheduleResponse

Other Resources

Schedules in Microsoft Dynamics CRM
Sample: Query the Schedule of a User


QueryScheduleRequest Constructor
[image]

Initializes a new instance of the QueryScheduleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QueryScheduleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryScheduleRequest Class
QueryScheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryScheduleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QueryScheduleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QueryScheduleResponse

Other Resources

Schedules in Microsoft Dynamics CRM
Sample: Query the Schedule of a User


QueryScheduleRequest Properties
[image]

Public Properties

 | Name | Description
public property | End | Gets or sets the end of the time slot.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceId | Gets or sets the ID of the resource.
public property | Start | Gets or sets the start of the time slot.
public property | TimeCodes | Gets or sets the time codes to look for: Available, Busy, Unavailable, or Filter.

See Also

Reference

QueryScheduleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
QueryScheduleResponse

Other Resources

Schedules in Microsoft Dynamics CRM
Sample: Query the Schedule of a User


QueryScheduleRequest.End Property
[image]

Gets or sets the end of the time slot.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property End As DateTime

C#
public DateTime End { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The end of the time slot.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryScheduleRequest Class
QueryScheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryScheduleRequest.ResourceId Property
[image]

Gets or sets the ID of the resource.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ResourceId As Guid

C#
public Guid ResourceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the resource. This corresponds to the Resource.ResourceId attribute, which is the primary key for the Resource entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryScheduleRequest Class
QueryScheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryScheduleRequest.Start Property
[image]

Gets or sets the start of the time slot.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Start As DateTime

C#
public DateTime Start { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The start of the time slot.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryScheduleRequest Class
QueryScheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryScheduleRequest.TimeCodes Property
[image]

Gets or sets the time codes to look for: Available, Busy, Unavailable, or Filter.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TimeCodes As TimeCode()

C#
public TimeCode[] TimeCodes { get; set; }

C++

J#

JScript

Property Value
Type: TimeCode
The time codes to look for: Available, Busy, Unavailable, or Filter.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryScheduleRequest Class
QueryScheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


QueryScheduleResponse Class
See Also Members
[image]

Contains response from QueryScheduleRequest.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class QueryScheduleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class QueryScheduleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.QueryScheduleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryScheduleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
QueryScheduleRequest


QueryScheduleResponse Members
See Also Constructors Methods Properties
[image]

Contains response from QueryScheduleRequest.

The following tables list the members exposed by the QueryScheduleResponse type.

Public Constructors

Name | Description
QueryScheduleResponse | Initializes a new instance of the QueryScheduleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TimeInfos | Gets the results of the search, a set of possible time slots for the resource.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QueryScheduleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
QueryScheduleRequest


QueryScheduleResponse Constructor
[image]

Initializes a new instance of the QueryScheduleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QueryScheduleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryScheduleResponse Class
QueryScheduleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


QueryScheduleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QueryScheduleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
QueryScheduleRequest


QueryScheduleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | TimeInfos | Gets the results of the search, a set of possible time slots for the resource.

See Also

Reference

QueryScheduleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
QueryScheduleRequest


QueryScheduleResponse.TimeInfos Property
[image]

Gets the results of the search, a set of possible time slots for the resource.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property TimeInfos As TimeInfo()

C#
public TimeInfo[] TimeInfos { get; }

C++

J#

JScript

Property Value
Type: TimeInfo
The results of the search. Contains an array of possible time slots for each of the resource IDs specified in the request class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryScheduleResponse Class
QueryScheduleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ResourceIds


ReassignObjectsOwnerRequest Class
See Also Members
[image]

Contains the data that is needed to reassign all records that are owned by the security principal (user or team) to another security principal (user or team).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReassignObjectsOwnerRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReassignObjectsOwnerRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  ReassignObjectsOwnerResponse.
Privileges and Access Rights
For a complete list of the privileges required, see ReassignObjectsOwner Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ReassignObjectsOwnerRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsOwnerRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsOwnerResponse
Other Resources
Entity Ownership
User and Team Entities


ReassignObjectsOwnerRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to reassign all records that are owned by the security principal (user or team) to another security principal (user or team).

The following tables list the members exposed by the ReassignObjectsOwnerRequest type.

Public Constructors

Name | Description
ReassignObjectsOwnerRequest | Initializes a new instance of the ReassignObjectsOwnerRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FromPrincipal | Gets or sets the security principal (user or team) for which to reassign all records.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ToPrincipal | Gets or sets the security principal (user or team) that will be the new owner for the records.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReassignObjectsOwnerRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsOwnerResponse

Other Resources

Entity Ownership
User and Team Entities


ReassignObjectsOwnerRequest Constructor
[image]

Initializes a new instance of the ReassignObjectsOwnerRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReassignObjectsOwnerRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsOwnerRequest Class
ReassignObjectsOwnerRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReassignObjectsOwnerRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReassignObjectsOwnerRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsOwnerResponse

Other Resources

Entity Ownership
User and Team Entities


ReassignObjectsOwnerRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FromPrincipal | Gets or sets the security principal (user or team) for which to reassign all records.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ToPrincipal | Gets or sets the security principal (user or team) that will be the new owner for the records.

See Also

Reference

ReassignObjectsOwnerRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsOwnerResponse

Other Resources

Entity Ownership
User and Team Entities


ReassignObjectsOwnerRequest.FromPrincipal Property
[image]

Gets or sets the security principal (user or team) for which to reassign all records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FromPrincipal As EntityReference

C#
public EntityReference FromPrincipal { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The security principal (user or team) for which to reassign all records. This must be an entity reference for the SystemUser entity or Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsOwnerRequest Class
ReassignObjectsOwnerRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReassignObjectsOwnerRequest.ToPrincipal Property
[image]

Gets or sets the security principal (user or team) that will be the new owner for the records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ToPrincipal As EntityReference

C#
public EntityReference ToPrincipal { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The security principal (user or team) that will be the new owner for the records. This must be an entity reference for the SystemUser entity or Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsOwnerRequest Class
ReassignObjectsOwnerRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReassignObjectsOwnerResponse Class
See Also Members
[image]

Contains the response from the ReassignObjectsOwnerRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReassignObjectsOwnerResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReassignObjectsOwnerResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ReassignObjectsOwnerResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsOwnerResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsOwnerRequest


ReassignObjectsOwnerResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ReassignObjectsOwnerRequest class.

The following tables list the members exposed by the ReassignObjectsOwnerResponse type.

Public Constructors

Name | Description
ReassignObjectsOwnerResponse | Initializes a new instance of the ReassignObjectsOwnerResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReassignObjectsOwnerResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsOwnerRequest


ReassignObjectsOwnerResponse Constructor
[image]

Initializes a new instance of the ReassignObjectsOwnerResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReassignObjectsOwnerResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsOwnerResponse Class
ReassignObjectsOwnerResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ReassignObjectsOwnerResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReassignObjectsOwnerResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsOwnerRequest


ReassignObjectsOwnerResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ReassignObjectsOwnerResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsOwnerRequest


ReassignObjectsSystemUserRequest Class
See Also Members
[image]

Contains the data that is needed to reassign all records that are owned by a specified user to another security principal (user or team).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReassignObjectsSystemUserRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReassignObjectsSystemUserRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of the ReassignObjectsSystemUserResponse class.
Privileges and Access Rights
For a complete list of the required privileges, see ReassignObjectsSystemUser Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ReassignObjectsSystemUserRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsSystemUserResponse
Other Resources
Entity Ownership
User and Team Entities
SystemUser (User) Entity Messages and Methods


ReassignObjectsSystemUserRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to reassign all records that are owned by a specified user to another security principal (user or team).

The following tables list the members exposed by the ReassignObjectsSystemUserRequest type.

Public Constructors

Name | Description
ReassignObjectsSystemUserRequest | Initializes a new instance of the ReassignObjectsSystemUserRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReassignPrincipal | Gets or sets the security principal (user or team) that is the new owner for the records.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId | Gets or sets the ID of the user for which you want to reassign all records.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReassignObjectsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsSystemUserResponse

Other Resources

Entity Ownership
User and Team Entities
SystemUser (User) Entity Messages and Methods


ReassignObjectsSystemUserRequest Constructor
[image]

Initializes a new instance of the ReassignObjectsSystemUserRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReassignObjectsSystemUserRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsSystemUserRequest Class
ReassignObjectsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReassignObjectsSystemUserRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReassignObjectsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsSystemUserResponse

Other Resources

Entity Ownership
User and Team Entities
SystemUser (User) Entity Messages and Methods


ReassignObjectsSystemUserRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReassignPrincipal | Gets or sets the security principal (user or team) that is the new owner for the records.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId | Gets or sets the ID of the user for which you want to reassign all records.

See Also

Reference

ReassignObjectsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsSystemUserResponse

Other Resources

Entity Ownership
User and Team Entities
SystemUser (User) Entity Messages and Methods


ReassignObjectsSystemUserRequest.ReassignPrincipal Property
[image]

Gets or sets the security principal (user or team) that is the new owner for the records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReassignPrincipal As EntityReference

C#
public EntityReference ReassignPrincipal { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The security principal (user or team) that is the new owner for the records. This must be an entity reference for the SystemUser entity or Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsSystemUserRequest Class
ReassignObjectsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReassignObjectsSystemUserRequest.UserId Property
[image]

Gets or sets the ID of the user for which you want to reassign all records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserId As Guid

C#
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the user for which you want to reassign all records. This corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsSystemUserRequest Class
ReassignObjectsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReassignObjectsSystemUserResponse Class
See Also Members
[image]

Contains the response from the ReassignObjectsSystemUserRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReassignObjectsSystemUserResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReassignObjectsSystemUserResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ReassignObjectsSystemUserResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsSystemUserRequest


ReassignObjectsSystemUserResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ReassignObjectsSystemUserRequest class.

The following tables list the members exposed by the ReassignObjectsSystemUserResponse type.

Public Constructors

Name | Description
ReassignObjectsSystemUserResponse | Initializes a new instance of the ReassignObjectsSystemUserResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReassignObjectsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsSystemUserRequest


ReassignObjectsSystemUserResponse Constructor
[image]

Initializes a new instance of the ReassignObjectsSystemUserResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReassignObjectsSystemUserResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReassignObjectsSystemUserResponse Class
ReassignObjectsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ReassignObjectsSystemUserResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReassignObjectsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsSystemUserRequest


ReassignObjectsSystemUserResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ReassignObjectsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReassignObjectsSystemUserRequest


RecalculateRequest Class
See Also Example Members
[image]

Contains the data that is needed to recalculate system-computed values for rollup fields in the goal hierarchy.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RecalculateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RecalculateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Calculate roll-up of goals.
RecalculateRequest recalculateRequest = new RecalculateRequest()
{
    Target = new EntityReference(Goal.EntityLogicalName, _parentGoalId)
};
_serviceProxy.Execute(recalculateRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the RecalculateResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Goal entity and access rights on the specified record in the Target property. For a complete list of the required privileges, see Recalculate Privileges.
Notes for Callers
Regardless which goal record is a target of the recalculate operation, the rollup fields for all goals in the specified hierarchy are updated.
  Note

                        For each goal in the hierarchy, this operation recalculates the rollup field values that are specified in the associated rollup field (RollupField) entity records. The remaining goal-related rollup fields contain null values.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RecalculateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RecalculateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RecalculateResponse
Other Resources
Goal Management Entities
Sample: Roll Up Goal Data for a Custom Period Against the Target Revenue
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM
Recalculate Privileges


RecalculateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to recalculate system-computed values for rollup fields in the goal hierarchy.

The following tables list the members exposed by the RecalculateRequest type.

Public Constructors

Name | Description
RecalculateRequest | Initializes a new instance of the RecalculateRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for the recalculate operation. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RecalculateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RecalculateResponse

Other Resources

Goal Management Entities
Sample: Roll Up Goal Data for a Custom Period Against the Target Revenue
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM
Recalculate Privileges


RecalculateRequest Constructor
[image]

Initializes a new instance of the RecalculateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RecalculateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RecalculateRequest Class
RecalculateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RecalculateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RecalculateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RecalculateResponse

Other Resources

Goal Management Entities
Sample: Roll Up Goal Data for a Custom Period Against the Target Revenue
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM
Recalculate Privileges


RecalculateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for the recalculate operation. Required.

See Also

Reference

RecalculateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RecalculateResponse

Other Resources

Goal Management Entities
Sample: Roll Up Goal Data for a Custom Period Against the Target Revenue
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM
Recalculate Privileges


RecalculateRequest.Target Property
[image]

Gets or sets the target record for the recalculate operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target record for the recalculate operation. This must be an entity reference for the Goal entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RecalculateRequest Class
RecalculateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RecalculateResponse Class
See Also Members
[image]

Contains the response from the RecalculateRequest.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RecalculateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RecalculateResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RecalculateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RecalculateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RecalculateRequest


RecalculateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RecalculateRequest.

The following tables list the members exposed by the RecalculateResponse type.

Public Constructors

Name | Description
RecalculateResponse | Initializes a new instance of the RecalculateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RecalculateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RecalculateRequest


RecalculateResponse Constructor
[image]

Initializes a new instance of the RecalculateResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RecalculateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RecalculateResponse Class
RecalculateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RecalculateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RecalculateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RecalculateRequest


RecalculateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RecalculateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RecalculateRequest


RelationshipAuditDetail Class
See Also Members
[image]

Contains the audited details of a change in a relationship.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RelationshipAuditDetail
    Inherits AuditDetail

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RelationshipAuditDetail : AuditDetail

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Crm.Sdk.Messages.AuditDetail
    Microsoft.Crm.Sdk.Messages.RelationshipAuditDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


RelationshipAuditDetail Members
See Also Constructors Methods Properties
[image]

Contains the audited details of a change in a relationship.

The following tables list the members exposed by the RelationshipAuditDetail type.

Public Constructors

Name | Description
RelationshipAuditDetail | Initializes a new instance of the RelationshipAuditDetail class.
Top

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | RelationshipName | Gets or sets the relationship name before the change occurs.
public property | TargetRecords | Provides the collection of relationship records that were added or removed.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RelationshipAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace


RelationshipAuditDetail Constructor
[image]

Initializes a new instance of the RelationshipAuditDetail class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RelationshipAuditDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipAuditDetail Class
RelationshipAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


RelationshipAuditDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RelationshipAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace


RelationshipAuditDetail Properties
[image]

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | RelationshipName | Gets or sets the relationship name before the change occurs.
public property | TargetRecords | Provides the collection of relationship records that were added or removed.

See Also

Reference

RelationshipAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace


RelationshipAuditDetail.RelationshipName Property
[image]

Gets or sets the relationship name before the change occurs.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RelationshipName As String

C#
[DataMemberAttribute]
public string RelationshipName { get; set; }

C++

J#

JScript

Property Value
Type: String
The relationship name.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipAuditDetail Class
RelationshipAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


RelationshipAuditDetail.TargetRecords Property
[image]

Provides the collection of relationship records that were added or removed.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public ReadOnly Property TargetRecords As DataCollection(Of EntityReference)

C#
[DataMemberAttribute]
public DataCollection<EntityReference> TargetRecords { get; }

C++

J#

JScript

Property Value
Type: DataCollection<EntityReference>
The collection of records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipAuditDetail Class
RelationshipAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ReleaseToQueueRequest Class
See Also Members
[image]

Contains the data that is needed to assign a queue item back to the queue owner so others can pick it.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReleaseToQueueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReleaseToQueueRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the ReleaseToQueueResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the QueueItem entity and access rights on the specified record in the QueueItemId property. For a complete list of the required privileges, see ReleaseToQueue message privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ReleaseToQueueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReleaseToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ReleaseToQueueResponse
Other Resources
Sample: Release a queue item to the queue (early bound)
ReleaseToQueue message privileges
QueueItem Entity Messages and Methods
QueueItem Entity Privileges
QueueItem Entity Messages and Methods


ReleaseToQueueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to assign a queue item back to the queue owner so others can pick it.

The following tables list the members exposed by the ReleaseToQueueRequest type.

Public Constructors

Name | Description
ReleaseToQueueRequest | Initializes a new instance of the ReleaseToQueueRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemId | Gets or sets the id of the queue item. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReleaseToQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReleaseToQueueResponse

Other Resources

Sample: Release a queue item to the queue (early bound)
ReleaseToQueue message privileges
QueueItem Entity Messages and Methods
QueueItem Entity Privileges
QueueItem Entity Messages and Methods


ReleaseToQueueRequest Constructor
[image]

Initializes a new instance of the ReleaseToQueueRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReleaseToQueueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReleaseToQueueRequest Class
ReleaseToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReleaseToQueueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReleaseToQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReleaseToQueueResponse

Other Resources

Sample: Release a queue item to the queue (early bound)
ReleaseToQueue message privileges
QueueItem Entity Messages and Methods
QueueItem Entity Privileges
QueueItem Entity Messages and Methods


ReleaseToQueueRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemId | Gets or sets the id of the queue item. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ReleaseToQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReleaseToQueueResponse

Other Resources

Sample: Release a queue item to the queue (early bound)
ReleaseToQueue message privileges
QueueItem Entity Messages and Methods
QueueItem Entity Privileges
QueueItem Entity Messages and Methods


ReleaseToQueueRequest.QueueItemId Property
[image]

Gets or sets the id of the queue item. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueueItemId As Guid

C#
public Guid QueueItemId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The queue item. This corresponds to the QueueItem.QueueItemId attribute, which is the primary key for the QueueItem entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReleaseToQueueRequest Class
ReleaseToQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReleaseToQueueResponse Class
See Also Members
[image]

Contains the response from the ReleaseToQueueRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReleaseToQueueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReleaseToQueueResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ReleaseToQueueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReleaseToQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ReleaseToQueueRequest


ReleaseToQueueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ReleaseToQueueRequest message.

The following tables list the members exposed by the ReleaseToQueueResponse type.

Public Constructors

Name | Description
ReleaseToQueueResponse | Initializes a new instance of the ReleaseToQueueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReleaseToQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReleaseToQueueRequest


ReleaseToQueueResponse Constructor
[image]

Initializes a new instance of the ReleaseToQueueResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReleaseToQueueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReleaseToQueueResponse Class
ReleaseToQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ReleaseToQueueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReleaseToQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReleaseToQueueRequest


ReleaseToQueueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ReleaseToQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReleaseToQueueRequest


RemoveFromQueueRequest Class
See Also Members
[image]

Contains the data that is needed to remove a queue item from a queue.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveFromQueueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveFromQueueRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  RemoveFromQueueResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the QueueItem entity and access rights on the record specified in the QueueItemId property. For a complete list of the privileges required, see RemoveFromQueue message privileges.
Notes for Callers
This method is equivalent to deleting the queue item.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveFromQueueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveFromQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveFromQueueResponse
Other Resources
RemoveFromQueue message privileges
QueueItem Entity Messages and Methods
QueueItem Entity Privileges


RemoveFromQueueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to remove a queue item from a queue.

The following tables list the members exposed by the RemoveFromQueueRequest type.

Public Constructors

Name | Description
RemoveFromQueueRequest | Initializes a new instance of the RemoveFromQueueRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemId | Gets or sets the ID of the queue item to remove from the queue. Required.The QueueItemId property corresponds to the QueueItem.QueueItemId attribute, which is the primary key for the QueueItem entity.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveFromQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveFromQueueResponse

Other Resources

RemoveFromQueue message privileges
QueueItem Entity Messages and Methods
QueueItem Entity Privileges


RemoveFromQueueRequest Constructor
[image]

Initializes a new instance of the RemoveFromQueueRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveFromQueueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveFromQueueRequest Class
RemoveFromQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveFromQueueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveFromQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveFromQueueResponse

Other Resources

RemoveFromQueue message privileges
QueueItem Entity Messages and Methods
QueueItem Entity Privileges


RemoveFromQueueRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemId | Gets or sets the ID of the queue item to remove from the queue. Required.The QueueItemId property corresponds to the QueueItem.QueueItemId attribute, which is the primary key for the QueueItem entity.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RemoveFromQueueRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveFromQueueResponse

Other Resources

RemoveFromQueue message privileges
QueueItem Entity Messages and Methods
QueueItem Entity Privileges


RemoveFromQueueRequest.QueueItemId Property
[image]

Gets or sets the ID of the queue item to remove from the queue. Required. The QueueItemId property corresponds to the QueueItem.QueueItemId attribute, which is the primary key for the QueueItem entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueueItemId As Guid

C#
public Guid QueueItemId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The QueueItemId. This corresponds to the QueueItem.QueueItemId attribute, which is the primary key for the QueueItem entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveFromQueueRequest Class
RemoveFromQueueRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveFromQueueResponse Class
See Also Members
[image]

Contains the response from the RemoveFromQueueRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveFromQueueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveFromQueueResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveFromQueueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveFromQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveFromQueueRequest


RemoveFromQueueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemoveFromQueueRequest message.

The following tables list the members exposed by the RemoveFromQueueResponse type.

Public Constructors

Name | Description
RemoveFromQueueResponse | Initializes a new instance of the RemoveFromQueueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveFromQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveFromQueueRequest


RemoveFromQueueResponse Constructor
[image]

Initializes a new instance of the RemoveFromQueueResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveFromQueueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveFromQueueResponse Class
RemoveFromQueueResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveFromQueueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveFromQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveFromQueueRequest


RemoveFromQueueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveFromQueueResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveFromQueueRequest


RemoveItemCampaignActivityRequest Class
See Also Members
[image]

Contains the data that is needed to remove an item from a campaign activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveItemCampaignActivityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveItemCampaignActivityRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  RemoveItemCampaignActivityResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the CampaignActivity entity and access rights on the records specified in the CampaignActivityId property and the ItemId property.
For a complete list of the required privileges, see RemoveItemCampaignActivity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveItemCampaignActivityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignActivityResponse
Other Resources
RemoveItemCampaignActivity Privileges
CampaignActivityItem Intersect Entity Metadata
CampaignActivity Entity Messages and Methods
Marketing Entities (Campaign, List)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveItemCampaignActivityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to remove an item from a campaign activity.

The following tables list the members exposed by the RemoveItemCampaignActivityRequest type.

Public Constructors

Name | Description
RemoveItemCampaignActivityRequest | Initializes a new instance of the RemoveItemCampaignActivityRequest class.
Top

Public Properties

 | Name | Description
public property | CampaignActivityId | Gets or sets the ID of the campaign activity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ItemId | Gets or sets the ID of the item to be removed from the campaign activity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveItemCampaignActivityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignActivityResponse

Other Resources

RemoveItemCampaignActivity Privileges
CampaignActivityItem Intersect Entity Metadata
CampaignActivity Entity Messages and Methods
Marketing Entities (Campaign, List)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveItemCampaignActivityRequest Constructor
[image]

Initializes a new instance of the RemoveItemCampaignActivityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveItemCampaignActivityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignActivityRequest Class
RemoveItemCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveItemCampaignActivityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveItemCampaignActivityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignActivityResponse

Other Resources

RemoveItemCampaignActivity Privileges
CampaignActivityItem Intersect Entity Metadata
CampaignActivity Entity Messages and Methods
Marketing Entities (Campaign, List)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveItemCampaignActivityRequest Properties
[image]

Public Properties

 | Name | Description
public property | CampaignActivityId | Gets or sets the ID of the campaign activity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ItemId | Gets or sets the ID of the item to be removed from the campaign activity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RemoveItemCampaignActivityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignActivityResponse

Other Resources

RemoveItemCampaignActivity Privileges
CampaignActivityItem Intersect Entity Metadata
CampaignActivity Entity Messages and Methods
Marketing Entities (Campaign, List)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveItemCampaignActivityRequest.CampaignActivityId Property
[image]

Gets or sets the ID of the campaign activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CampaignActivityId As Guid

C#
public Guid CampaignActivityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the campaign activity. This corresponds to the CampaignActivity.ActivityId attribute, which is the primary key for the CamaignActivity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignActivityRequest Class
RemoveItemCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveItemCampaignActivityRequest.ItemId Property
[image]

Gets or sets the ID of the item to be removed from the campaign activity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ItemId As Guid

C#
public Guid ItemId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the item to be removed from the campaign activity. This corresponds to the CampaignActivityItem.CampaignActivityItemId property, which is the primary key for the CampaignActivityItem intersect entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignActivityRequest Class
RemoveItemCampaignActivityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
CampaignActivityItem Intersect Entity Metadata


RemoveItemCampaignActivityResponse Class
See Also Members
[image]

Contains the response from the RemoveItemCampaignActivityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveItemCampaignActivityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveItemCampaignActivityResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveItemCampaignActivityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignActivityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignActivityRequest


RemoveItemCampaignActivityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemoveItemCampaignActivityRequest class.

The following tables list the members exposed by the RemoveItemCampaignActivityResponse type.

Public Constructors

Name | Description
RemoveItemCampaignActivityResponse | Initializes a new instance of the RemoveItemCampaignActivityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveItemCampaignActivityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignActivityRequest


RemoveItemCampaignActivityResponse Constructor
[image]

Initializes a new instance of the RemoveItemCampaignActivityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveItemCampaignActivityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignActivityResponse Class
RemoveItemCampaignActivityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveItemCampaignActivityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveItemCampaignActivityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignActivityRequest


RemoveItemCampaignActivityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveItemCampaignActivityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignActivityRequest


RemoveItemCampaignRequest Class
See Also Members
[image]

Contains the data that is needed to remove an item from a campaign.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveItemCampaignRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveItemCampaignRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  RemoveItemCampaignResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Campaign entity and access rights on the records specified in the CampaignId property and the EntityId property.
For a complete list of the required privileges, see RemoveItemCampaign Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveItemCampaignRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignResponse
Other Resources
RemoveItemCampaign Privileges
CampaignItem Intersect Entity Metadata
Marketing Entities (Campaign, List)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveItemCampaignRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to remove an item from a campaign.

The following tables list the members exposed by the RemoveItemCampaignRequest type.

Public Constructors

Name | Description
RemoveItemCampaignRequest | Initializes a new instance of the RemoveItemCampaignRequest class.
Top

Public Properties

 | Name | Description
public property | CampaignId | Gets or sets the ID of the campaign. Required.
public property | EntityId | Gets or sets the ID of the item to be removed from the campaign. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveItemCampaignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignResponse

Other Resources

RemoveItemCampaign Privileges
CampaignItem Intersect Entity Metadata
Marketing Entities (Campaign, List)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveItemCampaignRequest Constructor
[image]

Initializes a new instance of the RemoveItemCampaignRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveItemCampaignRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignRequest Class
RemoveItemCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveItemCampaignRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveItemCampaignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignResponse

Other Resources

RemoveItemCampaign Privileges
CampaignItem Intersect Entity Metadata
Marketing Entities (Campaign, List)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveItemCampaignRequest Properties
[image]

Public Properties

 | Name | Description
public property | CampaignId | Gets or sets the ID of the campaign. Required.
public property | EntityId | Gets or sets the ID of the item to be removed from the campaign. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RemoveItemCampaignRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignResponse

Other Resources

RemoveItemCampaign Privileges
CampaignItem Intersect Entity Metadata
Marketing Entities (Campaign, List)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveItemCampaignRequest.CampaignId Property
[image]

Gets or sets the ID of the campaign. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CampaignId As Guid

C#
public Guid CampaignId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the campaign. This corresponds to the Campaign.CampaignId attribute, which is the primary key for the Camaign entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignRequest Class
RemoveItemCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveItemCampaignRequest.EntityId Property
[image]

Gets or sets the ID of the item to be removed from the campaign. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the item to be removed from the campaign. This corresponds to the CampaignItem.CampaignItemId property, which is the primary key for the CampaignItem intersect entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignRequest Class
RemoveItemCampaignRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
CampaignItem Intersect Entity Metadata


RemoveItemCampaignResponse Class
See Also Members
[image]

Contains the response from the RemoveItemCampaignRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveItemCampaignResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveItemCampaignResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveItemCampaignResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignRequest


RemoveItemCampaignResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemoveItemCampaignRequest class.

The following tables list the members exposed by the RemoveItemCampaignResponse type.

Public Constructors

Name | Description
RemoveItemCampaignResponse | Initializes a new instance of the RemoveItemCampaignResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveItemCampaignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignRequest


RemoveItemCampaignResponse Constructor
[image]

Initializes a new instance of the RemoveItemCampaignResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveItemCampaignResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveItemCampaignResponse Class
RemoveItemCampaignResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveItemCampaignResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveItemCampaignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignRequest


RemoveItemCampaignResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveItemCampaignResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveItemCampaignRequest


RemoveMemberListRequest Class
See Also Members
[image]

Contains the data that is needed to remove a member from a list (marketing list).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveMemberListRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveMemberListRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  RemoveMemberListResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the List entity and access rights on the records specified in the EntityId property and the ListId property.
For a complete list of the required privileges, see RemoveMemberList Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveMemberListRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveMemberListResponse
Other Resources
RemoveMemberList Privileges
List (Marketing List) Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveMemberListRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to remove a member from a list (marketing list).

The following tables list the members exposed by the RemoveMemberListRequest type.

Public Constructors

Name | Description
RemoveMemberListRequest | Initializes a new instance of the RemoveMemberListRequest class.
Top

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the member to be removed from the list. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveMemberListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMemberListResponse

Other Resources

RemoveMemberList Privileges
List (Marketing List) Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveMemberListRequest Constructor
[image]

Initializes a new instance of the RemoveMemberListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveMemberListRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMemberListRequest Class
RemoveMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveMemberListRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveMemberListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMemberListResponse

Other Resources

RemoveMemberList Privileges
List (Marketing List) Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveMemberListRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityId | Gets or sets the ID of the member to be removed from the list. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ListId | Gets or sets the ID of the list. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RemoveMemberListRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMemberListResponse

Other Resources

RemoveMemberList Privileges
List (Marketing List) Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveMemberListRequest.EntityId Property
[image]

Gets or sets the ID of the member to be removed from the list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the member to be removed from the list. This corresponds to the ListMember.ListMemberId attribute, which is the primary key for the ListMember intersect entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMemberListRequest Class
RemoveMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
List Member Intersect Entity Metadata


RemoveMemberListRequest.ListId Property
[image]

Gets or sets the ID of the list. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ListId As Guid

C#
public Guid ListId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the list. This corresponds to the List.ListId attribute, which is the primary key for the List entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMemberListRequest Class
RemoveMemberListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveMemberListResponse Class
See Also Members
[image]

Contains the response from the RemoveMemberListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveMemberListResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveMemberListResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveMemberListResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMemberListResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveMemberListRequest


RemoveMemberListResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemoveMemberListRequest class.

The following tables list the members exposed by the RemoveMemberListResponse type.

Public Constructors

Name | Description
RemoveMemberListResponse | Initializes a new instance of the RemoveMemberListResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveMemberListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMemberListRequest


RemoveMemberListResponse Constructor
[image]

Initializes a new instance of the RemoveMemberListResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveMemberListResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMemberListResponse Class
RemoveMemberListResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveMemberListResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveMemberListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMemberListRequest


RemoveMemberListResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveMemberListResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMemberListRequest


RemoveMembersTeamRequest Class
See Also Members
[image]

Contains the data that is needed to remove members from a team.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveMembersTeamRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveMembersTeamRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  RemoveMembersTeamResponse.
Privileges and Access Rights
For a complete list of the privileges required, see RemoveMembersTeam Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveMembersTeamRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveMembersTeamResponse
Other Resources
User and Team Entities
Team Entity Messages and Methods


RemoveMembersTeamRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to remove members from a team.

The following tables list the members exposed by the RemoveMembersTeamRequest type.

Public Constructors

Name | Description
RemoveMembersTeamRequest | Initializes a new instance of theRemoveMembersTeamRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MemberIds | Gets or sets an array of IDs of the users to be removed from the team.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the ID of the team.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveMembersTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMembersTeamResponse

Other Resources

User and Team Entities
Team Entity Messages and Methods


RemoveMembersTeamRequest Constructor
[image]

Initializes a new instance of the RemoveMembersTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveMembersTeamRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMembersTeamRequest Class
RemoveMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveMembersTeamRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveMembersTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMembersTeamResponse

Other Resources

User and Team Entities
Team Entity Messages and Methods


RemoveMembersTeamRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MemberIds | Gets or sets an array of IDs of the users to be removed from the team.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the ID of the team.

See Also

Reference

RemoveMembersTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMembersTeamResponse

Other Resources

User and Team Entities
Team Entity Messages and Methods


RemoveMembersTeamRequest.MemberIds Property
[image]

Gets or sets an array of IDs of the users to be removed from the team.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MemberIds As Guid()

C#
public Guid[] MemberIds { get; set; }

C++

J#

JScript

Property Value
Type:   Guid[]
The array of IDs of the users to be removed from the team.
Each element of the MemberIds array corresponds to the SystemUser.SystemUserId property, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMembersTeamRequest Class
RemoveMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveMembersTeamRequest.TeamId Property
[image]

Gets or sets the ID of the team.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TeamId As Guid

C#
public Guid TeamId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the team.
This corresponds to the Team.TeamId property, which is the primary key for the Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMembersTeamRequest Class
RemoveMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveMembersTeamResponse Class
See Also Members
[image]

Contains the response from the RemoveMembersTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveMembersTeamResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveMembersTeamResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveMembersTeamResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMembersTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveMembersTeamRequest


RemoveMembersTeamResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemoveMembersTeamRequest class.

The following tables list the members exposed by the RemoveMembersTeamResponse type.

Public Constructors

Name | Description
RemoveMembersTeamResponse | Initializes a new instance of the RemoveMembersTeamResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveMembersTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMembersTeamRequest


RemoveMembersTeamResponse Constructor
[image]

Initializes a new instance of the RemoveMembersTeamResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveMembersTeamResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveMembersTeamResponse Class
RemoveMembersTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveMembersTeamResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveMembersTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMembersTeamRequest


RemoveMembersTeamResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveMembersTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveMembersTeamRequest


RemoveParentRequest Class
See Also Members
[image]

Contains the data that is needed to remove the parent for a system user (user) record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveParentRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveParentRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  RemoveParentResponse.
Privileges and Access Rights
To perform this action, the caller must have  access rights on the role record. For a complete list of the privileges required, see RemoveParent Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveParentRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveParentRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveParentResponse
Other Resources
User and Team Entities
SystemUser (User) Entity Messages and Methods


RemoveParentRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to remove the parent for a system user (user) record.

The following tables list the members exposed by the RemoveParentRequest type.

Public Constructors

Name | Description
RemoveParentRequest | Initializes a new instance of the RemoveParentRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target systemuser (user) record for the operation.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveParentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveParentResponse

Other Resources

User and Team Entities
SystemUser (User) Entity Messages and Methods


RemoveParentRequest Constructor
[image]

Initializes a new instance of the RemoveParentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveParentRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveParentRequest Class
RemoveParentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveParentRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveParentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveParentResponse

Other Resources

User and Team Entities
SystemUser (User) Entity Messages and Methods


RemoveParentRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target systemuser (user) record for the operation.

See Also

Reference

RemoveParentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveParentResponse

Other Resources

User and Team Entities
SystemUser (User) Entity Messages and Methods


RemoveParentRequest.Target Property
[image]

Gets or sets the target systemuser (user) record for the operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target systemuser (user) record for the operation. This must be an entity reference to a systemuser (user) record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveParentRequest Class
RemoveParentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveParentResponse Class
See Also Members
[image]

Contains the response from the RemoveParentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveParentResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveParentResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveParentResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveParentResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveParentRequest


RemoveParentResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemoveParentRequest class.

The following tables list the members exposed by the RemoveParentResponse type.

Public Constructors

Name | Description
RemoveParentResponse | Initializes a new instance of the RemoveParentResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveParentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveParentRequest


RemoveParentResponse Constructor
[image]

Initializes a new instance of the RemoveParentResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveParentResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveParentResponse Class
RemoveParentResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveParentResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveParentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveParentRequest


RemoveParentResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveParentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveParentRequest


RemovePrivilegeRoleRequest Class
See Also Members
[image]

Contains the data that is needed to remove a privilege from an existing role.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemovePrivilegeRoleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemovePrivilegeRoleRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  RemovePrivilegeRoleResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the role entity and access rights on the record specified in the RoleId property. For a complete list of the privileges required, see RemovePrivilegeRole Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemovePrivilegeRoleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemovePrivilegeRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemovePrivilegeRoleResponse
Other Resources
Privilege and Role Entities


RemovePrivilegeRoleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to remove a privilege from an existing role.

The following tables list the members exposed by the RemovePrivilegeRoleRequest type.

Public Constructors

Name | Description
RemovePrivilegeRoleRequest | Initializes a new instance of the RemovePrivilegeRoleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PrivilegeId | Gets or sets the ID of the privilege that is to be removed from the existing role.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RoleId | Gets or sets the ID of the role from which the privilege is to be removed.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemovePrivilegeRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemovePrivilegeRoleResponse

Other Resources

Privilege and Role Entities


RemovePrivilegeRoleRequest Constructor
[image]

Initializes a new instance of the RemovePrivilegeRoleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemovePrivilegeRoleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemovePrivilegeRoleRequest Class
RemovePrivilegeRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemovePrivilegeRoleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemovePrivilegeRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemovePrivilegeRoleResponse

Other Resources

Privilege and Role Entities


RemovePrivilegeRoleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PrivilegeId | Gets or sets the ID of the privilege that is to be removed from the existing role.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RoleId | Gets or sets the ID of the role from which the privilege is to be removed.

See Also

Reference

RemovePrivilegeRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemovePrivilegeRoleResponse

Other Resources

Privilege and Role Entities


RemovePrivilegeRoleRequest.PrivilegeId Property
[image]

Gets or sets the ID of the privilege that is to be removed from the existing role.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PrivilegeId As Guid

C#
public Guid PrivilegeId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the privilege that is to be removed from the existing role. This corresponds to the Privilege.PrivilegeId property, which is the primary key for the Privilege entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemovePrivilegeRoleRequest Class
RemovePrivilegeRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemovePrivilegeRoleRequest.RoleId Property
[image]

Gets or sets the ID of the role from which the privilege is to be removed.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RoleId As Guid

C#
public Guid RoleId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the role from which the privilege is to be removed. This corresponds to the Role.RoleId property, which is the primary key for the Role entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemovePrivilegeRoleRequest Class
RemovePrivilegeRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemovePrivilegeRoleResponse Class
See Also Members
[image]

Contains the response from the RemovePrivilegeRoleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemovePrivilegeRoleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemovePrivilegeRoleResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemovePrivilegeRoleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemovePrivilegeRoleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemovePrivilegeRoleRequest


RemovePrivilegeRoleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemovePrivilegeRoleRequest class.

The following tables list the members exposed by the RemovePrivilegeRoleResponse type.

Public Constructors

Name | Description
RemovePrivilegeRoleResponse | Initializes a new instance of the RemovePrivilegeRoleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemovePrivilegeRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemovePrivilegeRoleRequest


RemovePrivilegeRoleResponse Constructor
[image]

Initializes a new instance of the RemovePrivilegeRoleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemovePrivilegeRoleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemovePrivilegeRoleResponse Class
RemovePrivilegeRoleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemovePrivilegeRoleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemovePrivilegeRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemovePrivilegeRoleRequest


RemovePrivilegeRoleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemovePrivilegeRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemovePrivilegeRoleRequest


RemoveProductFromKitRequest Class
See Also Members
[image]

Deprecated. Use the ProductAssociation entity. Contains the data that is needed to remove a product from a kit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveProductFromKitRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveProductFromKitRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of RemoveProductFromKitResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Product entity and access rights on the records specified in KitId and ProductId.
For a complete list of the required privileges, see RemoveProductFromKit Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveProductFromKitRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveProductFromKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveProductFromKitResponse
Other Resources
Bundles and kits
RemoveProductFromKit Privileges
Product Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveProductFromKitRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the ProductAssociation entity. Contains the data that is needed to remove a product from a kit.

The following tables list the members exposed by the RemoveProductFromKitRequest type.

Public Constructors

Name | Description
RemoveProductFromKitRequest | Initializes a new instance of the RemoveProductFromKitRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | KitId | Gets or sets the ID of the kit from which the product is to be removed.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product being removed from the kit.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveProductFromKitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveProductFromKitResponse

Other Resources

Bundles and kits
RemoveProductFromKit Privileges
Product Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveProductFromKitRequest Constructor
[image]

Initializes a new instance of the RemoveProductFromKitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveProductFromKitRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveProductFromKitRequest Class
RemoveProductFromKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveProductFromKitRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveProductFromKitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveProductFromKitResponse

Other Resources

Bundles and kits
RemoveProductFromKit Privileges
Product Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveProductFromKitRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | KitId | Gets or sets the ID of the kit from which the product is to be removed.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product being removed from the kit.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RemoveProductFromKitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveProductFromKitResponse

Other Resources

Bundles and kits
RemoveProductFromKit Privileges
Product Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveProductFromKitRequest.KitId Property
[image]

Gets or sets the ID of the kit from which the product is to be removed.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property KitId As Guid

C#
public Guid KitId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the kit from which the product is to be removed. This corresponds to the Product.ProductId attribute, which is the primary key for the Product entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveProductFromKitRequest Class
RemoveProductFromKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveProductFromKitRequest.ProductId Property
[image]

Gets or sets the ID of the product being removed from the kit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ProductId As Guid

C#
public Guid ProductId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the product being removed from the kit. This corresponds to the Product.ProductId attribute, which is the primary key for the Product entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveProductFromKitRequest Class
RemoveProductFromKitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveProductFromKitResponse Class
See Also Members
[image]

Deprecated. Use the ProductAssociation entity. Contains the response from the RemoveProductFromKitRequest.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveProductFromKitResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveProductFromKitResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveProductFromKitResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveProductFromKitResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveProductFromKitRequest
Other Resources
Bundles and kits


RemoveProductFromKitResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the ProductAssociation entity. Contains the response from the RemoveProductFromKitRequest.

The following tables list the members exposed by the RemoveProductFromKitResponse type.

Public Constructors

Name | Description
RemoveProductFromKitResponse | Initializes a new instance of the RemoveProductFromKitResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveProductFromKitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveProductFromKitRequest

Other Resources

Bundles and kits


RemoveProductFromKitResponse Constructor
[image]

Initializes a new instance of the RemoveProductFromKitResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveProductFromKitResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveProductFromKitResponse Class
RemoveProductFromKitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveProductFromKitResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveProductFromKitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveProductFromKitRequest

Other Resources

Bundles and kits


RemoveProductFromKitResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveProductFromKitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveProductFromKitRequest

Other Resources

Bundles and kits


RemoveRelatedRequest Class
See Also Members
[image]

Use the DisassociateRequest class. Contains the data that is needed to remove the relationship between the specified records for specific relationships.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveRelatedRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveRelatedRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the RemoveRelatedResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges and access rights on the records that are specified in the Target property. For a complete list of the required privileges, see RemoveRelated Privileges.
Notes for Callers
This message works for a limited set of relationships and will be deprecated in a future version. Instead, use DisassociateRequest.
Supported Relationships
The following table shows the entities and relationships that support this message.
Entity | Relationship Schema Name
Invoice | contactinvoices_association
Lead | accountleads_association contactleads_association
Opportunity | opportunity_customer_accounts opportunitycompetitors_association opportunity_customer_contacts
Product | competitorproduct_association leadproduct_association
Quote | contactquotes_association
SalesLiterature | competitorsalesliterature_association productsalesliterature_association
SalesOrder | contactorders_association

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveRelatedRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace
DisassociateRequest
RemoveRelatedResponse
Other Resources
Actions on Entity Records


RemoveRelatedRequest Members
See Also Constructors Methods Properties
[image]

Use the DisassociateRequest class. Contains the data that is needed to remove the relationship between the specified records for specific relationships.

The following tables list the members exposed by the RemoveRelatedRequest type.

Public Constructors

Name | Description
RemoveRelatedRequest | Initializes a new instance of the RemoveRelatedRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target records from which you want to remove specific related records.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveRelatedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DisassociateRequest
RemoveRelatedResponse

Other Resources

Actions on Entity Records


RemoveRelatedRequest Constructor
[image]

Initializes a new instance of the RemoveRelatedRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveRelatedRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveRelatedRequest Class
RemoveRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveRelatedRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveRelatedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DisassociateRequest
RemoveRelatedResponse

Other Resources

Actions on Entity Records


RemoveRelatedRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target records from which you want to remove specific related records.

See Also

Reference

RemoveRelatedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
DisassociateRequest
RemoveRelatedResponse

Other Resources

Actions on Entity Records


RemoveRelatedRequest.Target Property
[image]

Gets or sets the target records from which you want to remove specific related records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference()

C#
public EntityReference[] Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The the target records from which you want to remove specific related records. This array must contain a set of entity references where the entities participate in a relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveRelatedRequest Class
RemoveRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveRelatedResponse Class
See Also Members
[image]

Contains the response from the RemoveRelatedRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveRelatedResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveRelatedResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveRelatedResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveRelatedResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveRelatedRequest


RemoveRelatedResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemoveRelatedRequest class.

The following tables list the members exposed by the RemoveRelatedResponse type.

Public Constructors

Name | Description
RemoveRelatedResponse | Initializes a new instance of the RemoveRelatedResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveRelatedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveRelatedRequest


RemoveRelatedResponse Constructor
[image]

Initializes a new instance of the RemoveRelatedResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveRelatedResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveRelatedResponse Class
RemoveRelatedResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveRelatedResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveRelatedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveRelatedRequest


RemoveRelatedResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveRelatedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveRelatedRequest


RemoveSolutionComponentRequest Class
See Also Example Members
[image]

Contains the data that is needed to remove a component from an unmanaged solution.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveSolutionComponentRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveSolutionComponentRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Remove a Solution Component
//Remove the Account entity from the solution
RetrieveEntityRequest retrieveForRemoveAccountRequest = new RetrieveEntityRequest()
{
    LogicalName = Account.EntityLogicalName
};
RetrieveEntityResponse retrieveForRemoveAccountResponse = (RetrieveEntityResponse)_serviceProxy.Execute(retrieveForRemoveAccountRequest);

RemoveSolutionComponentRequest removeReq = new RemoveSolutionComponentRequest()
{
    ComponentId = (Guid)retrieveForRemoveAccountResponse.EntityMetadata.MetadataId,
    ComponentType = (int)componenttype.Entity,
    SolutionUniqueName = solution.UniqueName
};
_serviceProxy.Execute(removeReq);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RemoveSolutionComponentResponse.
Privileges and Access Rights
To perform this action, the caller must have  the privileges that are listed in RemoveSolutionComponent Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveSolutionComponentRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RemoveSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RemoveSolutionComponentRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to remove a component from an unmanaged solution.

The following tables list the members exposed by the RemoveSolutionComponentRequest type.

Public Constructors

Name | Description
RemoveSolutionComponentRequest | Initializes a new instance of the RemoveSolutionComponentRequest class.
Top

Public Properties

 | Name | Description
public property | ComponentId | Gets or sets the ID of the solution component. Required.
public property | ComponentType | Gets or sets the value that represents the solution component that you want to add. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the value of the Solution.UniqueName attribute of the solution for which you want to add the solution component. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveSolutionComponentRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RemoveSolutionComponentRequest Constructor
[image]

Initializes a new instance of the RemoveSolutionComponentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveSolutionComponentRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSolutionComponentRequest Class
RemoveSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSolutionComponentRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveSolutionComponentRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RemoveSolutionComponentRequest Properties
[image]

Public Properties

 | Name | Description
public property | ComponentId | Gets or sets the ID of the solution component. Required.
public property | ComponentType | Gets or sets the value that represents the solution component that you want to add. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the value of the Solution.UniqueName attribute of the solution for which you want to add the solution component. Required.

See Also

Reference

RemoveSolutionComponentRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work With Solutions
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RemoveSolutionComponentRequest.ComponentId Property
[image]

Gets or sets the ID of the solution component. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ComponentId As Guid

C#
public Guid ComponentId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the solution component. This corresponds to the SolutionComponent.SolutionComponentId attribute, which is the primary key for the SolutionComponent entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSolutionComponentRequest Class
RemoveSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSolutionComponentRequest.ComponentType Property
[image]

Gets or sets the value that represents the solution component that you want to add. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ComponentType As Integer

C#
public int ComponentType { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The value that represents the solution component that you want to add. Required.

  Remarks
The enumeration componenttype defines the supported range of values for this property. You can access the available values by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project. These values are defined by the global option set Component Type (componenttype).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSolutionComponentRequest Class
RemoveSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSolutionComponentRequest.SolutionUniqueName Property
[image]

Gets or sets the value of the Solution.UniqueName attribute of the solution for which you want to add the solution component. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The value of the Solution.UniqueName attribute of the solution for which you want to add the solution component. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSolutionComponentRequest Class
RemoveSolutionComponentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSolutionComponentResponse Class
See Also Members
[image]

Contains the response from the RemoveSolutionComponentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveSolutionComponentResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveSolutionComponentResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveSolutionComponentResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSolutionComponentResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveSolutionComponentRequest


RemoveSolutionComponentResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemoveSolutionComponentRequest class.

The following tables list the members exposed by the RemoveSolutionComponentResponse type.

Public Constructors

Name | Description
RemoveSolutionComponentResponse | Initializes a new instance of the RemoveSolutionComponentResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Gets the ID value of the solution component that was removed.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveSolutionComponentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveSolutionComponentRequest


RemoveSolutionComponentResponse Constructor
[image]

Initializes a new instance of the RemoveSolutionComponentResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveSolutionComponentResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSolutionComponentResponse Class
RemoveSolutionComponentResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSolutionComponentResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveSolutionComponentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveSolutionComponentRequest


RemoveSolutionComponentResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Gets the ID value of the solution component that was removed.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveSolutionComponentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveSolutionComponentRequest


RemoveSolutionComponentResponse.id Property
[image]

Gets the ID value of the solution component that was removed.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property id As Guid

C#
public Guid id { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID value of the solution component that was removed. This corresponds to the SolutionComponent.SolutionComponentId attribute, which is the primary key for the SolutionComponent entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSolutionComponentResponse Class
RemoveSolutionComponentResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSubstituteProductRequest Class
See Also Members
[image]

Deprecated. Use the ProductSubstitute entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveSubstituteProductRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveSubstituteProductRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveSubstituteProductRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSubstituteProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveSubstituteProductResponse
Other Resources
Define product relationships for enhanced suggestions during product sale
RemoveSubstituteProduct Privileges


RemoveSubstituteProductRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the ProductSubstitute entity.

The following tables list the members exposed by the RemoveSubstituteProductRequest type.

Public Constructors

Name | Description
RemoveSubstituteProductRequest | Deprecated. Use the ProductSubstitute entity.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Deprecated. Use the ProductSubstitute entity.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SubstituteId | Deprecated. Use the ProductSubstitute entity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveSubstituteProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveSubstituteProductResponse

Other Resources

Define product relationships for enhanced suggestions during product sale
RemoveSubstituteProduct Privileges


RemoveSubstituteProductRequest Constructor
[image]

Deprecated. Use the ProductSubstitute entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveSubstituteProductRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSubstituteProductRequest Class
RemoveSubstituteProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSubstituteProductRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveSubstituteProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveSubstituteProductResponse

Other Resources

Define product relationships for enhanced suggestions during product sale
RemoveSubstituteProduct Privileges


RemoveSubstituteProductRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Deprecated. Use the ProductSubstitute entity.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SubstituteId | Deprecated. Use the ProductSubstitute entity.

See Also

Reference

RemoveSubstituteProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveSubstituteProductResponse

Other Resources

Define product relationships for enhanced suggestions during product sale
RemoveSubstituteProduct Privileges


RemoveSubstituteProductRequest.ProductId Property
[image]

Deprecated. Use the ProductSubstitute entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ProductId As Guid

C#
public Guid ProductId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSubstituteProductRequest Class
RemoveSubstituteProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSubstituteProductRequest.SubstituteId Property
[image]

Deprecated. Use the ProductSubstitute entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SubstituteId As Guid

C#
public Guid SubstituteId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSubstituteProductRequest Class
RemoveSubstituteProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSubstituteProductResponse Class
See Also Members
[image]

Deprecated. Use the ProductSubstitute entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveSubstituteProductResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveSubstituteProductResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveSubstituteProductResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSubstituteProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveSubstituteProductRequest
Other Resources
Define product relationships for enhanced suggestions during product sale


RemoveSubstituteProductResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the ProductSubstitute entity.

The following tables list the members exposed by the RemoveSubstituteProductResponse type.

Public Constructors

Name | Description
RemoveSubstituteProductResponse | Deprecated. Use the ProductSubstitute entity.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveSubstituteProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveSubstituteProductRequest

Other Resources

Define product relationships for enhanced suggestions during product sale


RemoveSubstituteProductResponse Constructor
[image]

Deprecated. Use the ProductSubstitute entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveSubstituteProductResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveSubstituteProductResponse Class
RemoveSubstituteProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveSubstituteProductResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveSubstituteProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveSubstituteProductRequest

Other Resources

Define product relationships for enhanced suggestions during product sale


RemoveSubstituteProductResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveSubstituteProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveSubstituteProductRequest

Other Resources

Define product relationships for enhanced suggestions during product sale


RemoveUserFromRecordTeamRequest Class
See Also Members
[image]

Contains the data that is needed to remove a user from the auto created access team for the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveUserFromRecordTeamRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveUserFromRecordTeamRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of the RemoveUserFromRecordTeamResponse class.
Privileges and Access Rights
To perform this action, the caller must have the Share privilege on the entity specified in the Record property. The caller must also have privileges on the SystemUser entity and the TeamTemplate entity and access rights on the records specified in the SystemUserId property and the TeamTemplateId property. In addition, the caller must have access rights on the record specified in the Record property that match access rights specified in the team template. For example, if the team template specifies the Read access right on the account entity, the caller must have the Read access right on the account record, specified in the Record property. For a complete list of required privileges, see RemoveUserFromRecordTeam message privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RemoveUserFromRecordTeamRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveUserFromRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveUserFromRecordTeamResponse
Other Resources
RemoveUserFromRecordTeam message privileges
Use Teams to Collaborate and Share Information
User and Team Entities
Team Entity Messages and Methods
TeamTemplate entity messages and methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveUserFromRecordTeamRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to remove a user from the auto created access team for the specified record.

The following tables list the members exposed by the RemoveUserFromRecordTeamRequest type.

Public Constructors

Name | Description
RemoveUserFromRecordTeamRequest | Initializes a new instance of the RemoveUserFromRecordTeamRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Record | Gets or sets the record for which the access team is auto created. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SystemUserId | Gets or sets the ID of system user (user) to remove from the auto created access team. Required.
public property | TeamTemplateId | Gets or sets the ID of team template which is used to create the access team. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveUserFromRecordTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveUserFromRecordTeamResponse

Other Resources

RemoveUserFromRecordTeam message privileges
Use Teams to Collaborate and Share Information
User and Team Entities
Team Entity Messages and Methods
TeamTemplate entity messages and methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveUserFromRecordTeamRequest Constructor
[image]

Initializes a new instance of the RemoveUserFromRecordTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveUserFromRecordTeamRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveUserFromRecordTeamRequest Class
RemoveUserFromRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveUserFromRecordTeamRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveUserFromRecordTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveUserFromRecordTeamResponse

Other Resources

RemoveUserFromRecordTeam message privileges
Use Teams to Collaborate and Share Information
User and Team Entities
Team Entity Messages and Methods
TeamTemplate entity messages and methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveUserFromRecordTeamRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Record | Gets or sets the record for which the access team is auto created. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SystemUserId | Gets or sets the ID of system user (user) to remove from the auto created access team. Required.
public property | TeamTemplateId | Gets or sets the ID of team template which is used to create the access team. Required.

See Also

Reference

RemoveUserFromRecordTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveUserFromRecordTeamResponse

Other Resources

RemoveUserFromRecordTeam message privileges
Use Teams to Collaborate and Share Information
User and Team Entities
Team Entity Messages and Methods
TeamTemplate entity messages and methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RemoveUserFromRecordTeamRequest.Record Property
[image]

Gets or sets the record for which the access team is auto created. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Record As EntityReference

C#
public EntityReference Record { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The record for which the access team is auto created, which must be an entity reference for an entity that is enabled for access teams.
To enable an entity for the auto created access teams, set the AutoCreateAccessTeams attribute to true.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveUserFromRecordTeamRequest Class
RemoveUserFromRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveUserFromRecordTeamRequest.SystemUserId Property
[image]

Gets or sets the ID of system user (user) to remove from the auto created access team. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SystemUserId As Guid

C#
public Guid SystemUserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the system user (user) that corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveUserFromRecordTeamRequest Class
RemoveUserFromRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveUserFromRecordTeamRequest.TeamTemplateId Property
[image]

Gets or sets the ID of team template which is used to create the access team. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TeamTemplateId As Guid

C#
public Guid TeamTemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the team template that corresponds to the TeamTemplate.TeamTemplateId attribute, which is the primary key for the TeamTemplate entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveUserFromRecordTeamRequest Class
RemoveUserFromRecordTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveUserFromRecordTeamResponse Class
See Also Members
[image]

Contains the response from the RemoveUserFromRecordTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RemoveUserFromRecordTeamResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RemoveUserFromRecordTeamResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RemoveUserFromRecordTeamResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveUserFromRecordTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RemoveUserFromRecordTeamRequest


RemoveUserFromRecordTeamResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RemoveUserFromRecordTeamRequest class.

The following tables list the members exposed by the RemoveUserFromRecordTeamResponse type.

Public Constructors

Name | Description
RemoveUserFromRecordTeamResponse | Initializes a new instance of the RemoveUserFromRecordTeamResponse class.
Top

Public Properties

 | Name | Description
public property | AccessTeamId | Gets the ID of the auto created access team.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RemoveUserFromRecordTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveUserFromRecordTeamRequest


RemoveUserFromRecordTeamResponse Constructor
[image]

Initializes a new instance of the RemoveUserFromRecordTeamResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoveUserFromRecordTeamResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveUserFromRecordTeamResponse Class
RemoveUserFromRecordTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RemoveUserFromRecordTeamResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoveUserFromRecordTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveUserFromRecordTeamRequest


RemoveUserFromRecordTeamResponse Properties
[image]

Public Properties

 | Name | Description
public property | AccessTeamId | Gets the ID of the auto created access team.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RemoveUserFromRecordTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RemoveUserFromRecordTeamRequest


RemoveUserFromRecordTeamResponse.AccessTeamId Property
[image]

Gets the ID of the auto created access team.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AccessTeamId As Guid

C#
public Guid AccessTeamId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the auto created access team, which corresponds to the Team.TeamId attribute, which is the primary key for the Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoveUserFromRecordTeamResponse Class
RemoveUserFromRecordTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RenewContractRequest Class
See Also Members
[image]

Contains the data that is needed to renew a contract and create the contract details for a new contract.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RenewContractRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RenewContractRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of the RenewContractResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Contract entity and access rights on the specified record in the ContractId property. For a complete list of the required privileges, see RenewContract Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RenewContractRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RenewContractResponse
Other Resources
Contract Entities
RenewContract Privileges
Sample: Manage Contracts
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RenewContractRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to renew a contract and create the contract details for a new contract.

The following tables list the members exposed by the RenewContractRequest type.

Public Constructors

Name | Description
RenewContractRequest | Initializes a new instance of the RenewContractRequest class.
Top

Public Properties

 | Name | Description
public property | ContractId | Gets or sets the ID of the contract to be renewed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncludeCanceledLines | Gets or sets a value that indicates whether the canceled line items of the original contract should be included in the renewed contract. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets the status of the contract.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RenewContractRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RenewContractResponse

Other Resources

Contract Entities
RenewContract Privileges
Sample: Manage Contracts
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RenewContractRequest Constructor
[image]

Initializes a new instance of the RenewContractRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RenewContractRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewContractRequest Class
RenewContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RenewContractRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RenewContractRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RenewContractResponse

Other Resources

Contract Entities
RenewContract Privileges
Sample: Manage Contracts
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RenewContractRequest Properties
[image]

Public Properties

 | Name | Description
public property | ContractId | Gets or sets the ID of the contract to be renewed. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncludeCanceledLines | Gets or sets a value that indicates whether the canceled line items of the original contract should be included in the renewed contract. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets the status of the contract.

See Also

Reference

RenewContractRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RenewContractResponse

Other Resources

Contract Entities
RenewContract Privileges
Sample: Manage Contracts
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RenewContractRequest.ContractId Property
[image]

Gets or sets the ID of the contract to be renewed. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ContractId As Guid

C#
public Guid ContractId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the contract to be renewed. This corresponds to the Contract.ContractId attribute, which is the primary key for the Contract entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewContractRequest Class
RenewContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RenewContractRequest.IncludeCanceledLines Property
[image]

Gets or sets a value that indicates whether the canceled line items of the original contract should be included in the renewed contract. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IncludeCanceledLines As Boolean

C#
public bool IncludeCanceledLines { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether the canceled line items of the original contract should be included in the renewed contract.
true to include canceled line items; otherwise, false. The default is false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewContractRequest Class
RenewContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RenewContractRequest.Status Property
[image]

Gets or sets the status of the contract.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As Integer

C#
public int Status { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The status of the contract.

  Remarks
The Status property corresponds to the Contract.StatusCode attribute of the Contract entity. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system sets the appropriate corresponding status value. For a list of the status values, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.  For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewContractRequest Class
RenewContractRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RenewContractResponse Class
See Also Members
[image]

Contains the response from the RenewContractRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RenewContractResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RenewContractResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RenewContractResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewContractResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RenewContractRequest


RenewContractResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RenewContractRequest class.

The following tables list the members exposed by the RenewContractResponse type.

Public Constructors

Name | Description
RenewContractResponse | Initializes a new instance of the RenewContractResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the resulting contract.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RenewContractResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RenewContractRequest


RenewContractResponse Constructor
[image]

Initializes a new instance of the RenewContractResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RenewContractResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewContractResponse Class
RenewContractResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RenewContractResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RenewContractResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RenewContractRequest


RenewContractResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the resulting contract.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RenewContractResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RenewContractRequest


RenewContractResponse.Entity Property
[image]

Gets the resulting contract.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The resulting contract. This is an instance of the Contract class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewContractResponse Class
RenewContractResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RenewEntitlementRequest Class
See Also Members
[image]

Contains the data that is needed to renew an entitlement.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RenewEntitlementRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RenewEntitlementRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of the RenewEntitlementResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Entitlement entity and access rights on the specified record in the EntitlementId property. For a complete list of the required privileges, see RenewEntitlement message privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RenewEntitlementRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewEntitlementRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RenewEntitlementResponse
Other Resources
Entitlement Entities
Entitlement entity messages and methods
RenewEntitlement message privileges


RenewEntitlementRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to renew an entitlement.

The following tables list the members exposed by the RenewEntitlementRequest type.

Public Constructors

Name | Description
RenewEntitlementRequest | Initializes a new instance of the RenewEntitlementRequest class.
Top

Public Properties

 | Name | Description
public property | EntitlementId | Gets or sets the id of the entitlement to renew.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets the StatusCode value for the renewed Entitlement.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RenewEntitlementRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RenewEntitlementResponse

Other Resources

Entitlement Entities
Entitlement entity messages and methods
RenewEntitlement message privileges


RenewEntitlementRequest Constructor
[image]

Initializes a new instance of the RenewEntitlementRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RenewEntitlementRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewEntitlementRequest Class
RenewEntitlementRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RenewEntitlementRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RenewEntitlementRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RenewEntitlementResponse

Other Resources

Entitlement Entities
Entitlement entity messages and methods
RenewEntitlement message privileges


RenewEntitlementRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntitlementId | Gets or sets the id of the entitlement to renew.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets the StatusCode value for the renewed Entitlement.

See Also

Reference

RenewEntitlementRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RenewEntitlementResponse

Other Resources

Entitlement Entities
Entitlement entity messages and methods
RenewEntitlement message privileges


RenewEntitlementRequest.EntitlementId Property
[image]

Gets or sets the id of the entitlement to renew.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntitlementId As Guid

C#
public Guid EntitlementId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The Entitlement Id. This corresponds to the Entitlement.EntitlementId attribute, which is the primary key for the Entitlement entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewEntitlementRequest Class
RenewEntitlementRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RenewEntitlementRequest.Status Property
[image]

Gets or sets the StatusCode value for the renewed Entitlement.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As Integer

C#
public int Status { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The status value for the renewed Entitlement.

  Remarks
The default StatusCode values for the Entitlement entity are:
Value | Label
0 | Draft
1 | Active
2 | Cancelled
3 | Expired

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewEntitlementRequest Class
RenewEntitlementRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RenewEntitlementResponse Class
See Also Members
[image]

Contains the response from the RenewEntitlementRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RenewEntitlementResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RenewEntitlementResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RenewEntitlementResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewEntitlementResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RenewEntitlementRequest


RenewEntitlementResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RenewEntitlementRequest message.

The following tables list the members exposed by the RenewEntitlementResponse type.

Public Constructors

Name | Description
RenewEntitlementResponse | Initializes a new instance of the RenewEntitlementResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the renewed entitlement.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RenewEntitlementResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RenewEntitlementRequest


RenewEntitlementResponse Constructor
[image]

Initializes a new instance of the RenewEntitlementResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RenewEntitlementResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewEntitlementResponse Class
RenewEntitlementResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RenewEntitlementResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RenewEntitlementResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RenewEntitlementRequest


RenewEntitlementResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the renewed entitlement.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RenewEntitlementResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RenewEntitlementRequest


RenewEntitlementResponse.Entity Property
[image]

Gets the renewed entitlement.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The renewed entitlement.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RenewEntitlementResponse Class
RenewEntitlementResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ReplacePrivilegesRoleRequest Class
See Also Members
[image]

Contains the data that is needed to replace the privilege set of an existing role.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReplacePrivilegesRoleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReplacePrivilegesRoleRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the ReplacePrivilegesRoleResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Role entity and access rights on the specified record in the RoleId property. For a complete list of the required privileges, see ReplacePrivilegesRole Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ReplacePrivilegesRoleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReplacePrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ReplacePrivilegesRoleResponse
Other Resources
Privilege and Role Entities
Role Entity Messages and Methods


ReplacePrivilegesRoleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to replace the privilege set of an existing role.

The following tables list the members exposed by the ReplacePrivilegesRoleRequest type.

Public Constructors

Name | Description
ReplacePrivilegesRoleRequest | Initializes a new instance of the ReplacePrivilegesRoleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Privileges | Gets or sets an array that contains the IDs and depths of the privileges that replace the existing privileges.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RoleId | Gets or sets the ID of the role for which the privileges are to be replaced.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReplacePrivilegesRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReplacePrivilegesRoleResponse

Other Resources

Privilege and Role Entities
Role Entity Messages and Methods


ReplacePrivilegesRoleRequest Constructor
[image]

Initializes a new instance of the ReplacePrivilegesRoleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReplacePrivilegesRoleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReplacePrivilegesRoleRequest Class
ReplacePrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReplacePrivilegesRoleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReplacePrivilegesRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReplacePrivilegesRoleResponse

Other Resources

Privilege and Role Entities
Role Entity Messages and Methods


ReplacePrivilegesRoleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Privileges | Gets or sets an array that contains the IDs and depths of the privileges that replace the existing privileges.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RoleId | Gets or sets the ID of the role for which the privileges are to be replaced.

See Also

Reference

ReplacePrivilegesRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReplacePrivilegesRoleResponse

Other Resources

Privilege and Role Entities
Role Entity Messages and Methods


ReplacePrivilegesRoleRequest.Privileges Property
[image]

Gets or sets an array that contains the IDs and depths of the privileges that replace the existing privileges.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Privileges As RolePrivilege()

C#
public RolePrivilege[] Privileges { get; set; }

C++

J#

JScript

Property Value
Type: RolePrivilege
The array that contains the IDs and depths of the privileges that replace the existing privileges.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReplacePrivilegesRoleRequest Class
ReplacePrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReplacePrivilegesRoleRequest.RoleId Property
[image]

Gets or sets the ID of the role for which the privileges are to be replaced.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RoleId As Guid

C#
public Guid RoleId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the role for which the privileges are to be replaced. This corresponds to the Role.RoleId property, which is the primary key for the Role entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReplacePrivilegesRoleRequest Class
ReplacePrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReplacePrivilegesRoleResponse Class
See Also Members
[image]

Contains the response from the ReplacePrivilegesRoleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReplacePrivilegesRoleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReplacePrivilegesRoleResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ReplacePrivilegesRoleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReplacePrivilegesRoleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ReplacePrivilegesRoleRequest


ReplacePrivilegesRoleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ReplacePrivilegesRoleRequest class.

The following tables list the members exposed by the ReplacePrivilegesRoleResponse type.

Public Constructors

Name | Description
ReplacePrivilegesRoleResponse | Initializes a new instance of the ReplacePrivilegesRoleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReplacePrivilegesRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReplacePrivilegesRoleRequest


ReplacePrivilegesRoleResponse Constructor
[image]

Initializes a new instance of the ReplacePrivilegesRoleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReplacePrivilegesRoleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReplacePrivilegesRoleResponse Class
ReplacePrivilegesRoleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ReplacePrivilegesRoleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReplacePrivilegesRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReplacePrivilegesRoleRequest


ReplacePrivilegesRoleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ReplacePrivilegesRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReplacePrivilegesRoleRequest


RequiredResource Class
See Also Members
[image]

Specifies a resource that is required for a scheduling operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RequiredResource
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RequiredResource : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.RequiredResource
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RequiredResource Members
Microsoft.Crm.Sdk.Messages Namespace
RequiredResources
Other Resources
Sample: Schedule a Resource


RequiredResource Members
See Also Constructors Methods Properties
[image]

Specifies a resource that is required for a scheduling operation.

The following tables list the members exposed by the RequiredResource type.

Public Constructors

Name | Description
RequiredResource | Overloaded. Initializes a new instance of the RequiredResource class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ResourceId | Gets or sets the ID of the required resource.
public property | ResourceSpecId | Gets or sets the ID of the required resource specification.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RequiredResource Class
Microsoft.Crm.Sdk.Messages Namespace
RequiredResources

Other Resources

Sample: Schedule a Resource


RequiredResource Constructor
[image]

Initializes a new instance of the RequiredResource class.

Overload List

Name | Description
RequiredResource () | Initializes a new instance of the RequiredResource class.
RequiredResource (Guid, Guid) | Initializes a new instance of the RequiredResource class setting the resource and resource specification IDs.

See Also

Reference

RequiredResource Class
RequiredResource Members
Microsoft.Crm.Sdk.Messages Namespace


RequiredResource Constructor ()
[image]

Initializes a new instance of the RequiredResource class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RequiredResource ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RequiredResource Class
RequiredResource Members
Microsoft.Crm.Sdk.Messages Namespace


RequiredResource Constructor (Guid, Guid)
[image]

Initializes a new instance of the RequiredResource class setting the resource and resource specification IDs.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    resourceId As Guid, _
    resourceSpecId As Guid _
)

C#
public RequiredResource (
    Guid resourceId,
    Guid resourceSpecId
)

C++

J#

JScript

Parameters
resourceId
Type: Guid. The ID of the required resource.
resourceSpecId
Type: Guid. The ID of the required resource specification.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RequiredResource Class
RequiredResource Members
Microsoft.Crm.Sdk.Messages Namespace


RequiredResource Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RequiredResource Class
Microsoft.Crm.Sdk.Messages Namespace
RequiredResources

Other Resources

Sample: Schedule a Resource


RequiredResource Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ResourceId | Gets or sets the ID of the required resource.
public property | ResourceSpecId | Gets or sets the ID of the required resource specification.

See Also

Reference

RequiredResource Class
Microsoft.Crm.Sdk.Messages Namespace
RequiredResources

Other Resources

Sample: Schedule a Resource


RequiredResource.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RequiredResource Class
RequiredResource Members
Microsoft.Crm.Sdk.Messages Namespace


RequiredResource.ResourceId Property
[image]

Gets or sets the ID of the required resource.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResourceId As Guid

C#
[DataMemberAttribute]
public Guid ResourceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the required resource. This corresponds to the Resource.ResourceId attribute, which is the primary key for the Resource entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RequiredResource Class
RequiredResource Members
Microsoft.Crm.Sdk.Messages Namespace


RequiredResource.ResourceSpecId Property
[image]

Gets or sets the ID of the required resource specification.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResourceSpecId As Guid

C#
[DataMemberAttribute]
public Guid ResourceSpecId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the required resource specification. This corresponds to the ResourceSpec.ResourceSpecId attribute, which is the primary key for the ResourceSpec entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RequiredResource Class
RequiredResource Members
Microsoft.Crm.Sdk.Messages Namespace


RescheduleRequest Class
See Also Example Members
[image]

Contains the data that is needed to reschedule an appointment, recurring appointment, or service appointment (service activity).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RescheduleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RescheduleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

#region Reschedule an instance of recurring appointment

// Update the scheduled start and end dates of the appointment
// to reschedule it.
Appointment updateAppointment = new Appointment
{
    ActivityId = individualAppointments.Entities.Select(x => (Appointment)x).First().ActivityId,
    ScheduledStart = individualAppointments.Entities.Select(x => (Appointment)x).First().ScheduledStart.Value.AddHours(1),
    ScheduledEnd = individualAppointments.Entities.Select(x => (Appointment)x).First().ScheduledEnd.Value.AddHours(2)
};

RescheduleRequest reschedule = new RescheduleRequest
{
    Target = updateAppointment
};

RescheduleResponse rescheduled = (RescheduleResponse)_serviceProxy.Execute(reschedule);
Console.WriteLine("Rescheduled the second instance of the recurring appointment.");

#endregion Reschedule an instance of recurring appointment

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the RescheduleResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the Target property and access rights on the specified record in the Target property. For a list of the required privileges, see Reschedule Privileges.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

                                    Entity

Appointment

RecurringAppointmentMaster

ServiceAppointment

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RescheduleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RescheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RescheduleResponse
Other Resources
Schedule and Appointment Entities
Sample: Reschedule and Cancel a Recurring Appointment


RescheduleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to reschedule an appointment, recurring appointment, or service appointment (service activity).

The following tables list the members exposed by the RescheduleRequest type.

Public Constructors

Name | Description
RescheduleRequest | Initializes a new instance of the RescheduleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReturnNotifications | For internal use only.
public property | Target | Gets or sets the target of the reschedule operation.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RescheduleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RescheduleResponse

Other Resources

Schedule and Appointment Entities
Sample: Reschedule and Cancel a Recurring Appointment


RescheduleRequest Constructor
[image]

Initializes a new instance of the RescheduleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RescheduleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RescheduleRequest Class
RescheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RescheduleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RescheduleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RescheduleResponse

Other Resources

Schedule and Appointment Entities
Sample: Reschedule and Cancel a Recurring Appointment


RescheduleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReturnNotifications | For internal use only.
public property | Target | Gets or sets the target of the reschedule operation.

See Also

Reference

RescheduleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RescheduleResponse

Other Resources

Schedule and Appointment Entities
Sample: Reschedule and Cancel a Recurring Appointment


RescheduleRequest.ReturnNotifications Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReturnNotifications As Boolean

C#
public bool ReturnNotifications { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RescheduleRequest Class
RescheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RescheduleRequest.Target Property
[image]

Gets or sets the target of the reschedule operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The the target of the reschedule operation. This is an entity reference for an entity that supports this message. For a list of supported entity types, see RescheduleRequest.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RescheduleRequest Class
RescheduleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RescheduleResponse Class
See Also Members
[image]

Contains the response from the RescheduleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RescheduleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RescheduleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RescheduleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RescheduleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RescheduleRequest


RescheduleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RescheduleRequest class.

The following tables list the members exposed by the RescheduleResponse type.

Public Constructors

Name | Description
RescheduleResponse | Initializes a new instance of the RescheduleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Notifications | For internal use only.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ValidationResult | Gets the validation results for the appointment, recurring appointment master, or service appointment (service activity).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RescheduleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RescheduleRequest


RescheduleResponse Constructor
[image]

Initializes a new instance of the RescheduleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RescheduleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RescheduleResponse Class
RescheduleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RescheduleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RescheduleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RescheduleRequest


RescheduleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Notifications | For internal use only.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ValidationResult | Gets the validation results for the appointment, recurring appointment master, or service appointment (service activity).

See Also

Reference

RescheduleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RescheduleRequest


RescheduleResponse.Notifications Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Notifications As Object

C#
public Object Notifications { get; }

C++

J#

JScript

Property Value
Type: Object
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RescheduleResponse Class
RescheduleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RescheduleResponse.ValidationResult Property
[image]

Gets the validation results for the appointment, recurring appointment master, or service appointment (service activity).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ValidationResult As ValidationResult

C#
public ValidationResult ValidationResult { get; }

C++

J#

JScript

Property Value
Type: ValidationResult
The validation results for the appointment, recurring appointment master, or service appointment (service activity).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RescheduleResponse Class
RescheduleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ResetUserFiltersRequest Class
See Also Example Members
[image]

Contains the data that is needed to reset the offline data filters for the calling user to the default filters for the organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ResetUserFiltersRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ResetUserFiltersRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Call ResetUserFiltersRequest
Console.WriteLine("Resetting the user's offline templates to the defaults");
ResetUserFiltersRequest resetRequest = new ResetUserFiltersRequest
{
    QueryType = SavedQueryQueryType.OfflineFilters
};
ResetUserFiltersResponse resetResponse =
    (ResetUserFiltersResponse)_serviceProxy.Execute(resetRequest);
Console.WriteLine();

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute   method, which returns an instance of  ResetUserFiltersResponse.
Privileges and Access Rights
For a complete list of the privileges required, see ResetUserFilters Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ResetUserFiltersRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ResetUserFiltersRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ResetUserFiltersResponse
Other Resources
Offline and Outlook Filters and Templates
Sample: Retrieve Outlook Filters


ResetUserFiltersRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to reset the offline data filters for the calling user to the default filters for the organization.

The following tables list the members exposed by the ResetUserFiltersRequest type.

Public Constructors

Name | Description
ResetUserFiltersRequest | Initializes a new instance of the ResetUserFiltersRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryType | Gets or sets the type of filters to set. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ResetUserFiltersRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ResetUserFiltersResponse

Other Resources

Offline and Outlook Filters and Templates
Sample: Retrieve Outlook Filters


ResetUserFiltersRequest Constructor
[image]

Initializes a new instance of the ResetUserFiltersRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ResetUserFiltersRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResetUserFiltersRequest Class
ResetUserFiltersRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ResetUserFiltersRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ResetUserFiltersRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ResetUserFiltersResponse

Other Resources

Offline and Outlook Filters and Templates
Sample: Retrieve Outlook Filters


ResetUserFiltersRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryType | Gets or sets the type of filters to set. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ResetUserFiltersRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ResetUserFiltersResponse

Other Resources

Offline and Outlook Filters and Templates
Sample: Retrieve Outlook Filters


ResetUserFiltersRequest.QueryType Property
[image]

Gets or sets the type of filters to set. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueryType As Integer

C#
public int QueryType { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The type of filters to set. Use, OfflineFilters or OutlookFilters.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResetUserFiltersRequest Class
ResetUserFiltersRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ResetUserFiltersResponse Class
See Also Members
[image]

Contains the response from the ResetUserFiltersRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ResetUserFiltersResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ResetUserFiltersResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ResetUserFiltersResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResetUserFiltersResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ResetUserFiltersRequest


ResetUserFiltersResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ResetUserFiltersRequest class.

The following tables list the members exposed by the ResetUserFiltersResponse type.

Public Constructors

Name | Description
ResetUserFiltersResponse | Initializes a new instance of the ResetUserFiltersResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ResetUserFiltersResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ResetUserFiltersRequest


ResetUserFiltersResponse Constructor
[image]

Initializes a new instance of the ResetUserFiltersResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ResetUserFiltersResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResetUserFiltersResponse Class
ResetUserFiltersResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ResetUserFiltersResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ResetUserFiltersResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ResetUserFiltersRequest


ResetUserFiltersResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ResetUserFiltersResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ResetUserFiltersRequest


ResourceInfo Class
See Also Members
[image]

Contains information about a resource that has a scheduling problem for an appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ResourceInfo
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ResourceInfo : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.ResourceInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResourceInfo Members
Microsoft.Crm.Sdk.Messages Namespace
ResourceList


ResourceInfo Members
See Also Constructors Methods Properties
[image]

Contains information about a resource that has a scheduling problem for an appointment.

The following tables list the members exposed by the ResourceInfo type.

Public Constructors

Name | Description
ResourceInfo | Overloaded. Initializes a new instance of the ResourceInfo class.
Top

Public Properties

 | Name | Description
public property | DisplayName | Gets or sets the display name for the resource.
public property | EntityName | Gets or sets the logical name of the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Id | Gets or sets the ID of the record that has a scheduling problem.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ResourceInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ResourceList


ResourceInfo Constructor
[image]

Initializes a new instance of the ResourceInfo class.

Overload List

Name | Description
ResourceInfo () | Initializes a new instance of the ResourceInfo class.
ResourceInfo (Guid, String, String) | Initializes a new instance of the ResourceInfo class that sets the ID, entity name, and display name.

See Also

Reference

ResourceInfo Class
ResourceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ResourceInfo Constructor ()
[image]

Initializes a new instance of the ResourceInfo class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ResourceInfo ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResourceInfo Class
ResourceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ResourceInfo Constructor (Guid, String, String)
[image]

Initializes a new instance of the ResourceInfo class that sets the ID, entity name, and display name.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    id As Guid, _
    entityName As String, _
    name As String _
)

C#
public ResourceInfo (
    Guid id,
    string entityName,
    string name
)

C++

J#

JScript

Parameters
id
Type: Guid. The ID of the record that has a scheduling problem.
entityName
Type: String. The logical name of the entity.
name
Type: String. The display name for the resource.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResourceInfo Class
ResourceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ResourceInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ResourceInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ResourceList


ResourceInfo Properties
[image]

Public Properties

 | Name | Description
public property | DisplayName | Gets or sets the display name for the resource.
public property | EntityName | Gets or sets the logical name of the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Id | Gets or sets the ID of the record that has a scheduling problem.

See Also

Reference

ResourceInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ResourceList


ResourceInfo.DisplayName Property
[image]

Gets or sets the display name for the resource.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DisplayName As String

C#
[DataMemberAttribute]
public string DisplayName { get; set; }

C++

J#

JScript

Property Value
Type: String

The display name for the resource found in the Resource.Name attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResourceInfo Class
ResourceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ResourceInfo.EntityName Property
[image]

Gets or sets the logical name of the entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityName As String

C#
[DataMemberAttribute]
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the entity.

  Remarks
For a list of entity names see, IOrganizationService Entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResourceInfo Class
ResourceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ResourceInfo.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResourceInfo Class
ResourceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


ResourceInfo.Id Property
[image]

Gets or sets the ID of the record that has a scheduling problem.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the record that has a scheduling problem.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResourceInfo Class
ResourceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAbsoluteAndSiteCollectionUrlRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the absolute URL and the site collection URL for a SharePoint location record in Microsoft Dynamics CRM.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAbsoluteAndSiteCollectionUrlRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAbsoluteAndSiteCollectionUrlRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Retrieve the absolute URL and the Site Collection URL
// of the SharePoint document location record.
RetrieveAbsoluteAndSiteCollectionUrlRequest retrieveRequest = new RetrieveAbsoluteAndSiteCollectionUrlRequest
{
    Target = new EntityReference(SharePointDocumentLocation.EntityLogicalName, _spDocLocId)
};
RetrieveAbsoluteAndSiteCollectionUrlResponse retriveResponse = (RetrieveAbsoluteAndSiteCollectionUrlResponse)_serviceProxy.Execute(retrieveRequest);

Console.WriteLine("Absolute URL of document location record is '{0}'.", retriveResponse.AbsoluteUrl.ToString());
Console.WriteLine("Site Collection URL of document location record is '{0}'.", retriveResponse.SiteCollectionUrl.ToString());

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the RetrieveAbsoluteAndSiteCollectionUrlResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the SharepointDocumentLocation and SharepointSite entities and access rights on the specified record in the Target parameter. For a list of the required privileges, see RetrieveAbsoluteAndSiteCollectionUrl Privileges.
Notes for Callers
This message works only if your target server is SharePoint Server 2010 or 2013, and both the following conditions are true:
  • The Microsoft Dynamics CRM List Component for SharePoint Server is installed on the SharePoint site collection on the target SharePoint Server. For more information, see Microsoft Dynamics CRM list component for Microsoft SharePoint Server.
  • The location record for the parent SharePoint site collection exists in Microsoft Dynamics CRM. In addition, the SharePointSite.IsGridPresent attribute must be set to true when you create the parent location record.
Otherwise, a blank value is returned for the SiteCollectionUrl property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveAbsoluteAndSiteCollectionUrlRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveAbsoluteAndSiteCollectionUrlRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAbsoluteAndSiteCollectionUrlResponse
Other Resources
Actions on SharePoint Location Records
Sample: Retrieve Absolute URL and Site Collection URL of a Location Record
SharePointDocumentLocation Entity Messages and Methods
SharePointSite Entity Messages and Methods


RetrieveAbsoluteAndSiteCollectionUrlRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the absolute URL and the site collection URL for a SharePoint location record in Microsoft Dynamics CRM.

The following tables list the members exposed by the RetrieveAbsoluteAndSiteCollectionUrlRequest type.

Public Constructors

Name | Description
RetrieveAbsoluteAndSiteCollectionUrlRequest | Initializes a new instance of the RetrieveAbsoluteAndSiteCollectionUrlRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target for which the data is to be retrieved. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAbsoluteAndSiteCollectionUrlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAbsoluteAndSiteCollectionUrlResponse

Other Resources

Actions on SharePoint Location Records
Sample: Retrieve Absolute URL and Site Collection URL of a Location Record
SharePointDocumentLocation Entity Messages and Methods
SharePointSite Entity Messages and Methods


RetrieveAbsoluteAndSiteCollectionUrlRequest Constructor
[image]

Initializes a new instance of the RetrieveAbsoluteAndSiteCollectionUrlRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAbsoluteAndSiteCollectionUrlRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAbsoluteAndSiteCollectionUrlRequest Class
RetrieveAbsoluteAndSiteCollectionUrlRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAbsoluteAndSiteCollectionUrlRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAbsoluteAndSiteCollectionUrlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAbsoluteAndSiteCollectionUrlResponse

Other Resources

Actions on SharePoint Location Records
Sample: Retrieve Absolute URL and Site Collection URL of a Location Record
SharePointDocumentLocation Entity Messages and Methods
SharePointSite Entity Messages and Methods


RetrieveAbsoluteAndSiteCollectionUrlRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target for which the data is to be retrieved. Required.

See Also

Reference

RetrieveAbsoluteAndSiteCollectionUrlRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAbsoluteAndSiteCollectionUrlResponse

Other Resources

Actions on SharePoint Location Records
Sample: Retrieve Absolute URL and Site Collection URL of a Location Record
SharePointDocumentLocation Entity Messages and Methods
SharePointSite Entity Messages and Methods


RetrieveAbsoluteAndSiteCollectionUrlRequest.Target Property
[image]

Gets or sets the target for which the data is to be retrieved. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target for which the data is to be retrieved. This property must be a reference to a record of the SharepointDocumentLocation entity or the SharepointSite entity type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAbsoluteAndSiteCollectionUrlRequest Class
RetrieveAbsoluteAndSiteCollectionUrlRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAbsoluteAndSiteCollectionUrlResponse Class
See Also Members
[image]

Contains the response from the RetrieveAbsoluteAndSiteCollectionUrlRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAbsoluteAndSiteCollectionUrlResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAbsoluteAndSiteCollectionUrlResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveAbsoluteAndSiteCollectionUrlResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAbsoluteAndSiteCollectionUrlResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAbsoluteAndSiteCollectionUrlRequest


RetrieveAbsoluteAndSiteCollectionUrlResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAbsoluteAndSiteCollectionUrlRequest class.

The following tables list the members exposed by the RetrieveAbsoluteAndSiteCollectionUrlResponse type.

Public Constructors

Name | Description
RetrieveAbsoluteAndSiteCollectionUrlResponse | Initializes a new instance of the RetrieveAbsoluteAndSiteCollectionUrlResponse class.
Top

Public Properties

 | Name | Description
public property | AbsoluteUrl | Gets the absolute URL of the object that is specified in the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SiteCollectionUrl | Gets the SharePoint site collection URL of the object that is specified in the request.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAbsoluteAndSiteCollectionUrlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAbsoluteAndSiteCollectionUrlRequest


RetrieveAbsoluteAndSiteCollectionUrlResponse Constructor
[image]

Initializes a new instance of the RetrieveAbsoluteAndSiteCollectionUrlResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAbsoluteAndSiteCollectionUrlResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAbsoluteAndSiteCollectionUrlResponse Class
RetrieveAbsoluteAndSiteCollectionUrlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAbsoluteAndSiteCollectionUrlResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAbsoluteAndSiteCollectionUrlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAbsoluteAndSiteCollectionUrlRequest


RetrieveAbsoluteAndSiteCollectionUrlResponse Properties
[image]

Public Properties

 | Name | Description
public property | AbsoluteUrl | Gets the absolute URL of the object that is specified in the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SiteCollectionUrl | Gets the SharePoint site collection URL of the object that is specified in the request.

See Also

Reference

RetrieveAbsoluteAndSiteCollectionUrlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAbsoluteAndSiteCollectionUrlRequest


RetrieveAbsoluteAndSiteCollectionUrlResponse.AbsoluteUrl Property
[image]

Gets the absolute URL of the object that is specified in the request.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AbsoluteUrl As String

C#
public string AbsoluteUrl { get; }

C++

J#

JScript

Property Value
Type: String

The absolute URL of the object that is specified in the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAbsoluteAndSiteCollectionUrlResponse Class
RetrieveAbsoluteAndSiteCollectionUrlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAbsoluteAndSiteCollectionUrlResponse.SiteCollectionUrl Property
[image]

Gets the SharePoint site collection URL of the object that is specified in the request.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property SiteCollectionUrl As String

C#
public string SiteCollectionUrl { get; }

C++

J#

JScript

Property Value
Type: String

The SharePoint site collection URL of the object that is specified in the request.

  Remarks
For SharePoint Server 2010 or SharePoint Server 2010 Online: This property has a value only if:
  • The List Component is installed on the SharePoint site collection on the target SharePoint Server.
  • The location record for the parent SharePoint site collection exists in Microsoft Dynamics CRM. In addition, the SharePointSite. IsGridPresent attribute must be set to true you create the parent location record.
Otherwise, a blank value is returned.
For SharePoint Server 2007: A blank value is returned.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAbsoluteAndSiteCollectionUrlResponse Class
RetrieveAbsoluteAndSiteCollectionUrlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAllChildUsersSystemUserRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the collection of users that report to the specified system user (user).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAllChildUsersSystemUserRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAllChildUsersSystemUserRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of the RetrieveAllChildUsersSystemUserResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the SystemUser entity and access rights on the specified record in the EntityId property. For a complete list of the required privileges, see RetrieveAllChildUsersSystemUser Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveAllChildUsersSystemUserRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllChildUsersSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAllChildUsersSystemUserResponse
Other Resources
User and Team Entities


RetrieveAllChildUsersSystemUserRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the collection of users that report to the specified system user (user).

The following tables list the members exposed by the RetrieveAllChildUsersSystemUserRequest type.

Public Constructors

Name | Description
RetrieveAllChildUsersSystemUserRequest | Initializes a new instance of the RetrieveAllChildUsersSystemUserRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the set of attributes to retrieve. Required.
public property | EntityId | Gets or sets the ID of the system user (user).
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllChildUsersSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAllChildUsersSystemUserResponse

Other Resources

User and Team Entities


RetrieveAllChildUsersSystemUserRequest Constructor
[image]

Initializes a new instance of the RetrieveAllChildUsersSystemUserRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllChildUsersSystemUserRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllChildUsersSystemUserRequest Class
RetrieveAllChildUsersSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAllChildUsersSystemUserRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllChildUsersSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAllChildUsersSystemUserResponse

Other Resources

User and Team Entities


RetrieveAllChildUsersSystemUserRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the set of attributes to retrieve. Required.
public property | EntityId | Gets or sets the ID of the system user (user).
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveAllChildUsersSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAllChildUsersSystemUserResponse

Other Resources

User and Team Entities


RetrieveAllChildUsersSystemUserRequest.ColumnSet Property
[image]

Gets or sets the set of attributes to retrieve. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The set of attributes to retrieve.

  Remarks
Assign null to this property to retrieve only the primary key. The non-null values are returned for the attributes specified in the column set. The attributes not included in the ColumnSet will contain null values. If the ColumnSet includes attributes that are not valid for retrieve, they will be ignored. To learn which attributes are valid for retrieve, see the the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllChildUsersSystemUserRequest Class
RetrieveAllChildUsersSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAllChildUsersSystemUserRequest.EntityId Property
[image]

Gets or sets the ID of the system user (user).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the system user (user). This corresponds to the SystemUser.SystemUserId property, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllChildUsersSystemUserRequest Class
RetrieveAllChildUsersSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAllChildUsersSystemUserResponse Class
See Also Members
[image]

Contains the response from the RetrieveAllChildUsersSystemUserRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAllChildUsersSystemUserResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAllChildUsersSystemUserResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveAllChildUsersSystemUserResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllChildUsersSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAllChildUsersSystemUserRequest


RetrieveAllChildUsersSystemUserResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAllChildUsersSystemUserRequest class.

The following tables list the members exposed by the RetrieveAllChildUsersSystemUserResponse type.

Public Constructors

Name | Description
RetrieveAllChildUsersSystemUserResponse | Initializes a new instance of the RetrieveAllChildUsersSystemUserResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all users that report to the specified system user.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllChildUsersSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAllChildUsersSystemUserRequest


RetrieveAllChildUsersSystemUserResponse Constructor
[image]

Initializes a new instance of the RetrieveAllChildUsersSystemUserResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllChildUsersSystemUserResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllChildUsersSystemUserResponse Class
RetrieveAllChildUsersSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAllChildUsersSystemUserResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllChildUsersSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAllChildUsersSystemUserRequest


RetrieveAllChildUsersSystemUserResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all users that report to the specified system user.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveAllChildUsersSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAllChildUsersSystemUserRequest


RetrieveAllChildUsersSystemUserResponse.EntityCollection Property
[image]

Gets the resulting collection of all users that report to the specified system user.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The resulting collection of all users that report to the specified system user.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllChildUsersSystemUserResponse Class
RetrieveAllChildUsersSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace
EntityCollection


RetrieveApplicationRibbonRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the data that defines the content and behavior of the application ribbon.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveApplicationRibbonRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveApplicationRibbonRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
//Retrieve the Appliation Ribbon
RetrieveApplicationRibbonRequest appribReq = new RetrieveApplicationRibbonRequest();
RetrieveApplicationRibbonResponse appribResp = (RetrieveApplicationRibbonResponse)_serviceProxy.Execute(appribReq);

System.String applicationRibbonPath = Path.GetFullPath(exportFolder + "\\applicationRibbon.xml");
File.WriteAllBytes(applicationRibbonPath, unzipRibbon(appribResp.CompressedApplicationRibbonXml));

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveApplicationRibbonResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the privileges that are listed in RetrieveApplicationRibbon Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveApplicationRibbonRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveApplicationRibbonRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Export Ribbon Definitions
Customize the Ribbon for Microsoft Dynamics CRM


RetrieveApplicationRibbonRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the data that defines the content and behavior of the application ribbon.

The following tables list the members exposed by the RetrieveApplicationRibbonRequest type.

Public Constructors

Name | Description
RetrieveApplicationRibbonRequest | Initializes a new instance of the RetrieveApplicationRibbonRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveApplicationRibbonRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Export Ribbon Definitions
Customize the Ribbon for Microsoft Dynamics CRM


RetrieveApplicationRibbonRequest Constructor
[image]

Initializes a new instance of the RetrieveApplicationRibbonRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveApplicationRibbonRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveApplicationRibbonRequest Class
RetrieveApplicationRibbonRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveApplicationRibbonRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveApplicationRibbonRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Export Ribbon Definitions
Customize the Ribbon for Microsoft Dynamics CRM


RetrieveApplicationRibbonRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveApplicationRibbonRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Export Ribbon Definitions
Customize the Ribbon for Microsoft Dynamics CRM


RetrieveApplicationRibbonResponse Class
See Also Members
[image]

Contains the response from the RetrieveApplicationRibbonRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveApplicationRibbonResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveApplicationRibbonResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveApplicationRibbonResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveApplicationRibbonResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveApplicationRibbonRequest


RetrieveApplicationRibbonResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveApplicationRibbonRequest class.

The following tables list the members exposed by the RetrieveApplicationRibbonResponse type.

Public Constructors

Name | Description
RetrieveApplicationRibbonResponse | Initializes a new instance of the RetrieveApplicationRibbonResponse class.
Top

Public Properties

 | Name | Description
public property | CompressedApplicationRibbonXml | Gets a compressed file that defines the ribbon.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveApplicationRibbonResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveApplicationRibbonRequest


RetrieveApplicationRibbonResponse Constructor
[image]

Initializes a new instance of the RetrieveApplicationRibbonResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveApplicationRibbonResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveApplicationRibbonResponse Class
RetrieveApplicationRibbonResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveApplicationRibbonResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveApplicationRibbonResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveApplicationRibbonRequest


RetrieveApplicationRibbonResponse Properties
[image]

Public Properties

 | Name | Description
public property | CompressedApplicationRibbonXml | Gets a compressed file that defines the ribbon.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveApplicationRibbonResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveApplicationRibbonRequest


RetrieveApplicationRibbonResponse.CompressedApplicationRibbonXml Property
See Also Example
[image]

Gets a compressed file that defines the ribbon.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CompressedApplicationRibbonXml As Byte()

C#
public byte[] CompressedApplicationRibbonXml { get; }

C++

J#

JScript

Property Value
Type: Byte[]
a compressed file that defines the ribbon.

  Example
The following example is a helper method that is included in the SDK sample that you can find at SampleCode\CS\Client\Ribbon\ExportRibbonXml.
C#    Copy Code
/// <summary>
/// A helper method that decompresses the the Ribbon data returned
/// </summary>
/// <param name="data">The compressed ribbon data</param>
/// <returns></returns>
public byte[] unzipRibbon(byte[] data)
{
 System.IO.Packaging.ZipPackage package = null;
 MemoryStream memStream = null;

 memStream = new MemoryStream();
 memStream.Write(data, 0, data.Length);
 package = (ZipPackage)ZipPackage.Open(memStream, FileMode.Open);

 ZipPackagePart part = (ZipPackagePart)package.GetPart(new Uri("/RibbonXml.xml", UriKind.Relative));
 using (Stream strm = part.GetStream())
 {
  long len = strm.Length;
  byte[] buff = new byte[len];
  strm.Read(buff, 0, (int)len);
  return buff;
 }
}

  Remarks
To extract the XML data from the compressed file, you have to use the System.IO.Packaging.ZipPackage class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveApplicationRibbonResponse Class
RetrieveApplicationRibbonResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAttributeChangeHistoryRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve all metadata changes to a specific attribute.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAttributeChangeHistoryRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAttributeChangeHistoryRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Update the Telephone1 attribute in the Account entity record.
Account accountToUpdate = new Account();
accountToUpdate.AccountId = _newAccountId;
accountToUpdate.Telephone1 = "123-555-5555";
_serviceProxy.Update(accountToUpdate);
Console.WriteLine("Updated the Telephone1 field in the Account entity.");

// Retrieve the attribute change history.
Console.WriteLine("Retrieving the attribute change history for Telephone1.");

var attributeChangeHistoryRequest = new RetrieveAttributeChangeHistoryRequest
{
    Target = new EntityReference(
        Account.EntityLogicalName, _newAccountId),
    AttributeLogicalName = "telephone1"
};

var attributeChangeHistoryResponse =
    (RetrieveAttributeChangeHistoryResponse)_service.Execute(attributeChangeHistoryRequest);

// Display the attribute change history.
details = attributeChangeHistoryResponse.AuditDetailCollection;

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of RetrieveAttributeChangeHistoryResponse.
Privileges and Access Rights
For a complete list of the privileges required, see RetrieveAttributeChangeHistory Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveAttributeChangeHistoryRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveAttributeChangeHistoryRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Audit Entity Data Changes in Microsoft Dynamics CRM
Audit Entity Messages and Methods
Sample: Audit Entity Data Changes


RetrieveAttributeChangeHistoryRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve all metadata changes to a specific attribute.

The following tables list the members exposed by the RetrieveAttributeChangeHistoryRequest type.

Public Constructors

Name | Description
RetrieveAttributeChangeHistoryRequest | Initializes a new instance of the RetrieveAttributeChangeHistoryRequest class.
Top

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the attribute’s logical (schema) name. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PagingInfo | Gets or sets the paging information. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target audit record for which to retrieve attribute change history. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAttributeChangeHistoryRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Audit Entity Data Changes in Microsoft Dynamics CRM
Audit Entity Messages and Methods
Sample: Audit Entity Data Changes


RetrieveAttributeChangeHistoryRequest Constructor
[image]

Initializes a new instance of the RetrieveAttributeChangeHistoryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAttributeChangeHistoryRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeChangeHistoryRequest Class
RetrieveAttributeChangeHistoryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAttributeChangeHistoryRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAttributeChangeHistoryRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Audit Entity Data Changes in Microsoft Dynamics CRM
Audit Entity Messages and Methods
Sample: Audit Entity Data Changes


RetrieveAttributeChangeHistoryRequest Properties
[image]

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the attribute’s logical (schema) name. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PagingInfo | Gets or sets the paging information. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target audit record for which to retrieve attribute change history. Required.

See Also

Reference

RetrieveAttributeChangeHistoryRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Audit Entity Data Changes in Microsoft Dynamics CRM
Audit Entity Messages and Methods
Sample: Audit Entity Data Changes


RetrieveAttributeChangeHistoryRequest.AttributeLogicalName Property
[image]

Gets or sets the attribute’s logical (schema) name. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeLogicalName As String

C#
public string AttributeLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeChangeHistoryRequest Class
RetrieveAttributeChangeHistoryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAttributeChangeHistoryRequest.PagingInfo Property
[image]

Gets or sets the paging information. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PagingInfo As PagingInfo

C#
public PagingInfo PagingInfo { get; set; }

C++

J#

JScript

Property Value
Type: PagingInfo
The paging information.

  Remarks
Specifies a number of pages and a number of entity instances per page to return from the query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeChangeHistoryRequest Class
RetrieveAttributeChangeHistoryRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Page Large Result Sets with FetchXML
Page Large Result Sets with Query Expression


RetrieveAttributeChangeHistoryRequest.Target Property
[image]

Gets or sets the target audit record for which to retrieve attribute change history. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target record.

  Remarks
This must be an entity reference for an Audit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeChangeHistoryRequest Class
RetrieveAttributeChangeHistoryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAttributeChangeHistoryResponse Class
See Also Members
[image]

Contains the response from the RetrieveAttributeChangeHistoryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAttributeChangeHistoryResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAttributeChangeHistoryResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveAttributeChangeHistoryResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeChangeHistoryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAttributeChangeHistoryResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAttributeChangeHistoryRequest class.

The following tables list the members exposed by the RetrieveAttributeChangeHistoryResponse type.

Public Constructors

Name | Description
RetrieveAttributeChangeHistoryResponse | Initializes a new instance of the RetrieveAttributeChangeHistoryResponse class.
Top

Public Properties

 | Name | Description
public property | AuditDetailCollection | Gets the attribute change history that results in a collection of audit details.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAttributeChangeHistoryResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAttributeChangeHistoryResponse Constructor
[image]

Initializes a new instance of the RetrieveAttributeChangeHistoryResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAttributeChangeHistoryResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeChangeHistoryResponse Class
RetrieveAttributeChangeHistoryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAttributeChangeHistoryResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAttributeChangeHistoryResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAttributeChangeHistoryResponse Properties
[image]

Public Properties

 | Name | Description
public property | AuditDetailCollection | Gets the attribute change history that results in a collection of audit details.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveAttributeChangeHistoryResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAttributeChangeHistoryResponse.AuditDetailCollection Property
[image]

Gets the attribute change history that results in a collection of audit details.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AuditDetailCollection As AuditDetailCollection

C#
public AuditDetailCollection AuditDetailCollection { get; }

C++

J#

JScript

Property Value
Type: AuditDetailCollection
The collection of audit details.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeChangeHistoryResponse Class
RetrieveAttributeChangeHistoryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAuditDetailsRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the full audit details from an Audit record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAuditDetailsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAuditDetailsRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
Console.WriteLine("Retrieving audit details for an audit record.");

// Retrieve the audit details and display them.
var auditDetailsRequest = new RetrieveAuditDetailsRequest
{
    AuditId = auditSampleId
};

var auditDetailsResponse =
    (RetrieveAuditDetailsResponse)_service.Execute(auditDetailsRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the RetrieveAuditDetailsResponse class.
Privileges and Access Rights
For a list of the required privileges, see RetrieveAuditDetails Privileges.
Notes for Callers
Changes to entity attribute values are stored in an Audit record in a comma-separated value (.csv) file. The RetrieveAuditDetailsResponse class returns the changed data as a data collection.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveAuditDetailsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveAuditDetailsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditDetailsResponse
Other Resources
Retrieve and Delete the History of Audited Data Changes
Audit entity data changes
Sample: Audit Entity Data Changes


RetrieveAuditDetailsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the full audit details from an Audit record.

The following tables list the members exposed by the RetrieveAuditDetailsRequest type.

Public Constructors

Name | Description
RetrieveAuditDetailsRequest | Initializes a new instance of the RetrieveAuditDetailsRequest class.
Top

Public Properties

 | Name | Description
public property | AuditId | Gets or sets the ID of the Audit record to retrieve. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAuditDetailsRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditDetailsResponse

Other Resources

Retrieve and Delete the History of Audited Data Changes
Audit entity data changes
Sample: Audit Entity Data Changes


RetrieveAuditDetailsRequest Constructor
[image]

Initializes a new instance of the RetrieveAuditDetailsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAuditDetailsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAuditDetailsRequest Class
RetrieveAuditDetailsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAuditDetailsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAuditDetailsRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditDetailsResponse

Other Resources

Retrieve and Delete the History of Audited Data Changes
Audit entity data changes
Sample: Audit Entity Data Changes


RetrieveAuditDetailsRequest Properties
[image]

Public Properties

 | Name | Description
public property | AuditId | Gets or sets the ID of the Audit record to retrieve. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveAuditDetailsRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditDetailsResponse

Other Resources

Retrieve and Delete the History of Audited Data Changes
Audit entity data changes
Sample: Audit Entity Data Changes


RetrieveAuditDetailsRequest.AuditId Property
[image]

Gets or sets the ID of the Audit record to retrieve. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AuditId As Guid

C#
public Guid AuditId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the record to retrieve.

  Remarks
You can obtain the GUID of an Audit record by using the RetrieveRequest, RetrieveMultipleRequest, and RetrieveRecordChangeHistoryRequest classes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAuditDetailsRequest Class
RetrieveAuditDetailsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Audit Entity Messages and Methods


RetrieveAuditDetailsResponse Class
See Also Members
[image]

Contains the response from the RetrieveAuditDetailsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAuditDetailsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAuditDetailsResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveAuditDetailsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAuditDetailsResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditDetailsRequest
Other Resources
Retrieve and Delete the History of Audited Data Changes


RetrieveAuditDetailsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAuditDetailsRequest class.

The following tables list the members exposed by the RetrieveAuditDetailsResponse type.

Public Constructors

Name | Description
RetrieveAuditDetailsResponse | Initializes a new instance of the RetrieveAuditDetailsResponse class.
Top

Public Properties

 | Name | Description
public property | AuditDetail | Gets the details of the audited data changes.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAuditDetailsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditDetailsRequest

Other Resources

Retrieve and Delete the History of Audited Data Changes


RetrieveAuditDetailsResponse Constructor
[image]

Initializes a new instance of the RetrieveAuditDetailsResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAuditDetailsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAuditDetailsResponse Class
RetrieveAuditDetailsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAuditDetailsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAuditDetailsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditDetailsRequest

Other Resources

Retrieve and Delete the History of Audited Data Changes


RetrieveAuditDetailsResponse Properties
[image]

Public Properties

 | Name | Description
public property | AuditDetail | Gets the details of the audited data changes.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveAuditDetailsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAuditDetailsRequest

Other Resources

Retrieve and Delete the History of Audited Data Changes


RetrieveAuditDetailsResponse.AuditDetail Property
[image]

Gets the details of the audited data changes.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AuditDetail As AuditDetail

C#
public AuditDetail AuditDetail { get; }

C++

J#

JScript

Property Value
Type: AuditDetail
The audit details.

  Remarks
Cast the AuditDetail reference to the appropriate audit detail type; for example, cast to the AttributeAuditDetail class. For more information, see the AuditDetail class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAuditDetailsResponse Class
RetrieveAuditDetailsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAuditPartitionListRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the list of database partitions that are used to store audited history data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAuditPartitionListRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAuditPartitionListRequest : OrganizationRequest

C++

J#

JScript

  Example
C#    Copy Code
// Get the list of audit partitions.
RetrieveAuditPartitionListResponse partitionRequest =
    (RetrieveAuditPartitionListResponse)_service.Execute(new RetrieveAuditPartitionListRequest());
AuditPartitionDetailCollection partitions = partitionRequest.AuditPartitionDetailCollection;

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of the RetrieveAuditPartitionListResponse class.
Privileges and Access Rights
For a list of the required privileges, see RetrieveAuditPartitionList Privileges.
Notes for Callers
New partitions are automatically created by the Microsoft Dynamics CRM platform on a quarterly basis each year. Audit partitions exist only on Microsoft Dynamics CRM database servers that support partitioning. The partition list is sorted in date order and then returned.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveAuditPartitionListRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveAuditPartitionListRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveAuditPartitionListRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the list of database partitions that are used to store audited history data.

The following tables list the members exposed by the RetrieveAuditPartitionListRequest type.

Public Constructors

Name | Description
RetrieveAuditPartitionListRequest | Initializes a new instance of the RetrieveAuditPartitionListRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAuditPartitionListRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveAuditPartitionListRequest Constructor
[image]

Initializes a new instance of the RetrieveAuditPartitionListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAuditPartitionListRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAuditPartitionListRequest Class
RetrieveAuditPartitionListRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAuditPartitionListRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAuditPartitionListRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveAuditPartitionListRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveAuditPartitionListRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveAuditPartitionListResponse Class
See Also Members
[image]

Contains the response from the RetrieveAuditPartitionListRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAuditPartitionListResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAuditPartitionListResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveAuditPartitionListResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAuditPartitionListResponse Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveAuditPartitionListResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAuditPartitionListRequest class.

The following tables list the members exposed by the RetrieveAuditPartitionListResponse type.

Public Constructors

Name | Description
RetrieveAuditPartitionListResponse | Initializes a new instance of the RetrieveAuditPartitionListResponse class.
Top

Public Properties

 | Name | Description
public property | AuditPartitionDetailCollection | Gets the collection of audit partition details.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAuditPartitionListResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveAuditPartitionListResponse Constructor
[image]

Initializes a new instance of the RetrieveAuditPartitionListResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAuditPartitionListResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAuditPartitionListResponse Class
RetrieveAuditPartitionListResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAuditPartitionListResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAuditPartitionListResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveAuditPartitionListResponse Properties
[image]

Public Properties

 | Name | Description
public property | AuditPartitionDetailCollection | Gets the collection of audit partition details.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveAuditPartitionListResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveAuditPartitionListResponse.AuditPartitionDetailCollection Property
[image]

Gets the collection of audit partition details.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AuditPartitionDetailCollection As AuditPartitionDetailCollection

C#
public AuditPartitionDetailCollection AuditPartitionDetailCollection { get; }

C++

J#

JScript

Property Value
Type: AuditPartitionDetailCollection
The collection of audit partition details.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAuditPartitionListResponse Class
RetrieveAuditPartitionListResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAvailableLanguagesRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the list of language packs that are installed and enabled on the server.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAvailableLanguagesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAvailableLanguagesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute   method, which returns an instance of the RetrieveAvailableLanguagesResponse class.
Privileges and Access Rights
To perform this action, the caller must have the privileges that are listed in RetrieveAvailableLanguages Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveAvailableLanguagesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAvailableLanguagesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages


RetrieveAvailableLanguagesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the list of language packs that are installed and enabled on the server.

The following tables list the members exposed by the RetrieveAvailableLanguagesRequest type.

Public Constructors

Name | Description
RetrieveAvailableLanguagesRequest | Initializes a new instance of theRetrieveAvailableLanguagesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAvailableLanguagesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveAvailableLanguagesRequest Constructor
[image]

Initializes a new instance of the RetrieveAvailableLanguagesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAvailableLanguagesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAvailableLanguagesRequest Class
RetrieveAvailableLanguagesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAvailableLanguagesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAvailableLanguagesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveAvailableLanguagesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveAvailableLanguagesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveAvailableLanguagesResponse Class
See Also Members
[image]

Contains the response from the RetrieveAvailableLanguagesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveAvailableLanguagesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveAvailableLanguagesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveAvailableLanguagesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAvailableLanguagesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAvailableLanguagesRequest


RetrieveAvailableLanguagesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAvailableLanguagesRequest class.

The following tables list the members exposed by the RetrieveAvailableLanguagesResponse type.

Public Constructors

Name | Description
RetrieveAvailableLanguagesResponse | Initializes a new instance of the RetrieveAvailableLanguagesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | LocaleIds | Gets an array of locale ID values representing the language packs that are installed on the server.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAvailableLanguagesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAvailableLanguagesRequest


RetrieveAvailableLanguagesResponse Constructor
[image]

Initializes a new instance of the RetrieveAvailableLanguagesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAvailableLanguagesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAvailableLanguagesResponse Class
RetrieveAvailableLanguagesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveAvailableLanguagesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAvailableLanguagesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAvailableLanguagesRequest


RetrieveAvailableLanguagesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | LocaleIds | Gets an array of locale ID values representing the language packs that are installed on the server.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveAvailableLanguagesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveAvailableLanguagesRequest


RetrieveAvailableLanguagesResponse.LocaleIds Property
[image]

Gets an array of locale ID values representing the language packs that are installed on the server.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LocaleIds As Integer()

C#
public int[] LocaleIds { get; }

C++

J#

JScript

Property Value
Type: Int32[]
An array of locale id values representing the language packs that are installed on the server.

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAvailableLanguagesResponse Class
RetrieveAvailableLanguagesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveBusinessHierarchyBusinessUnitRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve all business units (including the specified business unit) from the business unit hierarchy.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveBusinessHierarchyBusinessUnitRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveBusinessHierarchyBusinessUnitRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of the RetrieveBusinessHierarchyBusinessUnitResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the BusinessUnit entity and access rights on the specified record in the EntityId property. For a complete list of the required privileges, see RetrieveBusinessHierarchyBusinessUnit Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveBusinessHierarchyBusinessUnitRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveBusinessHierarchyBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveBusinessHierarchyBusinessUnitResponse
Other Resources
BusinessUnit Entity


RetrieveBusinessHierarchyBusinessUnitRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve all business units (including the specified business unit) from the business unit hierarchy.

The following tables list the members exposed by the RetrieveBusinessHierarchyBusinessUnitRequest type.

Public Constructors

Name | Description
RetrieveBusinessHierarchyBusinessUnitRequest | Initializes a new instance of the RetrieveBusinessHierarchyBusinessUnitRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the set of attributes to retrieve. Required.
public property | EntityId | Gets or sets the ID of the business unit. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveBusinessHierarchyBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveBusinessHierarchyBusinessUnitResponse

Other Resources

BusinessUnit Entity


RetrieveBusinessHierarchyBusinessUnitRequest Constructor
[image]

Initializes a new instance of the RetrieveBusinessHierarchyBusinessUnitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveBusinessHierarchyBusinessUnitRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveBusinessHierarchyBusinessUnitRequest Class
RetrieveBusinessHierarchyBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveBusinessHierarchyBusinessUnitRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveBusinessHierarchyBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveBusinessHierarchyBusinessUnitResponse

Other Resources

BusinessUnit Entity


RetrieveBusinessHierarchyBusinessUnitRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the set of attributes to retrieve. Required.
public property | EntityId | Gets or sets the ID of the business unit. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveBusinessHierarchyBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveBusinessHierarchyBusinessUnitResponse

Other Resources

BusinessUnit Entity


RetrieveBusinessHierarchyBusinessUnitRequest.ColumnSet Property
[image]

Gets or sets the set of attributes to retrieve. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The set of attributes to retrieve.

  Remarks
Assign null to this property to retrieve only the primary key. The non-null values are returned for the attributes specified in the column set. The attributes not included in the ColumnSet will contain null values. If the ColumnSet includes attributes that are not valid for retrieve, they will be ignored. To learn which attributes are valid for retrieve, see the the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveBusinessHierarchyBusinessUnitRequest Class
RetrieveBusinessHierarchyBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveBusinessHierarchyBusinessUnitRequest.EntityId Property
[image]

Gets or sets the ID of the business unit. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the business unit. This corresponds to the BusinessUnit.BusinessUnitId property, which is the primary key for the BusinessUnit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveBusinessHierarchyBusinessUnitRequest Class
RetrieveBusinessHierarchyBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveBusinessHierarchyBusinessUnitResponse Class
See Also Members
[image]

Contains the response from the RetrieveBusinessHierarchyBusinessUnitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveBusinessHierarchyBusinessUnitResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveBusinessHierarchyBusinessUnitResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveBusinessHierarchyBusinessUnitResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveBusinessHierarchyBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveBusinessHierarchyBusinessUnitRequest


RetrieveBusinessHierarchyBusinessUnitResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveBusinessHierarchyBusinessUnitRequest class.

The following tables list the members exposed by the RetrieveBusinessHierarchyBusinessUnitResponse type.

Public Constructors

Name | Description
RetrieveBusinessHierarchyBusinessUnitResponse | Initializes a new instance of the RetrieveBusinessHierarchyBusinessUnitResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all business units in the business unit hierarchy.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveBusinessHierarchyBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveBusinessHierarchyBusinessUnitRequest


RetrieveBusinessHierarchyBusinessUnitResponse Constructor
[image]

Initializes a new instance of the RetrieveBusinessHierarchyBusinessUnitResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveBusinessHierarchyBusinessUnitResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveBusinessHierarchyBusinessUnitResponse Class
RetrieveBusinessHierarchyBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveBusinessHierarchyBusinessUnitResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveBusinessHierarchyBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveBusinessHierarchyBusinessUnitRequest


RetrieveBusinessHierarchyBusinessUnitResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all business units in the business unit hierarchy.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveBusinessHierarchyBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveBusinessHierarchyBusinessUnitRequest


RetrieveBusinessHierarchyBusinessUnitResponse.EntityCollection Property
[image]

Gets the resulting collection of all business units in the business unit hierarchy.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The the resulting collection of all business units in the business unit hierarchy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveBusinessHierarchyBusinessUnitResponse Class
RetrieveBusinessHierarchyBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace
EntityCollection


RetrieveByGroupResourceRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve all resources that are related to the specified resource group (scheduling group).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByGroupResourceRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByGroupResourceRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveByGroupResourceResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the ResourceGroup entity and access rights on the specified record in the ResourceGroupId property. For a complete list of the required privileges, see RetrieveByGroupResource Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveByGroupResourceRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByGroupResourceRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByGroupResourceResponse
Other Resources
Resource Entities
Resource Entity Messages and Methods


RetrieveByGroupResourceRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve all resources that are related to the specified resource group (scheduling group).

The following tables list the members exposed by the RetrieveByGroupResourceRequest type.

Public Constructors

Name | Description
RetrieveByGroupResourceRequest | Initializes a new instance of the RetrieveByGroupResourceRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceGroupId | Gets or sets the ID of the resource group.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByGroupResourceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByGroupResourceResponse

Other Resources

Resource Entities
Resource Entity Messages and Methods


RetrieveByGroupResourceRequest Constructor
[image]

Initializes a new instance of the RetrieveByGroupResourceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByGroupResourceRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByGroupResourceRequest Class
RetrieveByGroupResourceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByGroupResourceRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByGroupResourceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByGroupResourceResponse

Other Resources

Resource Entities
Resource Entity Messages and Methods


RetrieveByGroupResourceRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceGroupId | Gets or sets the ID of the resource group.

See Also

Reference

RetrieveByGroupResourceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByGroupResourceResponse

Other Resources

Resource Entities
Resource Entity Messages and Methods


RetrieveByGroupResourceRequest.Query Property
[image]

Gets or sets the query for the operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query for the operation.

  Remarks
The query must specify the entity name "resource" and a column set. Any other specified conditions are merged (by using the AND operator) with the conditions that are needed to retrieve the resources for the specified resource group. If the column set includes attributes where IsValidForRead is false, they are ignored and the message response contains no data for those attributes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByGroupResourceRequest Class
RetrieveByGroupResourceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByGroupResourceRequest.ResourceGroupId Property
[image]

Gets or sets the ID of the resource group.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ResourceGroupId As Guid

C#
public Guid ResourceGroupId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the resource group. This corresponds to the ResourceGroup.ResourceGroupId property, which is the primary key for the ResourceGroup entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByGroupResourceRequest Class
RetrieveByGroupResourceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByGroupResourceResponse Class
See Also Members
[image]

Contains the response from the RetrieveByGroupResourceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByGroupResourceResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByGroupResourceResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveByGroupResourceResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByGroupResourceResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByGroupResourceRequest


RetrieveByGroupResourceResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveByGroupResourceRequest class.

The following tables list the members exposed by the RetrieveByGroupResourceResponse type.

Public Constructors

Name | Description
RetrieveByGroupResourceResponse | Initializes a new instance of the RetrieveByGroupResourceResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all resources that are related to the specified resource group.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByGroupResourceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByGroupResourceRequest


RetrieveByGroupResourceResponse Constructor
[image]

Initializes a new instance of the RetrieveByGroupResourceResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByGroupResourceResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByGroupResourceResponse Class
RetrieveByGroupResourceResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByGroupResourceResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByGroupResourceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByGroupResourceRequest


RetrieveByGroupResourceResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all resources that are related to the specified resource group.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveByGroupResourceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByGroupResourceRequest


RetrieveByGroupResourceResponse.EntityCollection Property
[image]

Gets the resulting collection of all resources that are related to the specified resource group.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The resulting collection of all resources that are related to the specified resource group.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByGroupResourceResponse Class
RetrieveByGroupResourceResponse Members
Microsoft.Crm.Sdk.Messages Namespace
EntityCollection


RetrieveByResourceResourceGroupRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the resource groups (scheduling groups) that contain the specified resource.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByResourceResourceGroupRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByResourceResourceGroupRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  RetrieveByResourceResourceGroupResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Resource entity and access rights on the record that is specified in the ResourceId property. For a complete list of the required privileges, see RetrieveByResourceResourceGroup Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveByResourceResourceGroupRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourceResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourceResourceGroupResponse
Other Resources
Resource Entities
ResourceGroup (Scheduling  Group) Entity Messages and Methods


RetrieveByResourceResourceGroupRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the resource groups (scheduling groups) that contain the specified resource.

The following tables list the members exposed by the RetrieveByResourceResourceGroupRequest type.

Public Constructors

Name | Description
RetrieveByResourceResourceGroupRequest | Initializes a new instance of the RetrieveByResourceResourceGroupRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceId | Gets or sets the ID of the resource.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByResourceResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourceResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


RetrieveByResourceResourceGroupRequest Constructor
[image]

Initializes a new instance of the RetrieveByResourceResourceGroupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByResourceResourceGroupRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourceResourceGroupRequest Class
RetrieveByResourceResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByResourceResourceGroupRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByResourceResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourceResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


RetrieveByResourceResourceGroupRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceId | Gets or sets the ID of the resource.

See Also

Reference

RetrieveByResourceResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourceResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


RetrieveByResourceResourceGroupRequest.Query Property
[image]

Gets or sets the query for the operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query for the operation.

  Remarks
The query must specify the entity name "resourcegroup" and a column set. Any other specified conditions are merged (by using the AND operator) with the conditions that are needed to retrieve the resource groups for the specified resource. If the column set includes attributes where IsValidForRead is false, they are ignored and the message response contains no data for those attributes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourceResourceGroupRequest Class
RetrieveByResourceResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByResourceResourceGroupRequest.ResourceId Property
[image]

Gets or sets the ID of the resource.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ResourceId As Guid

C#
public Guid ResourceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the resource. This corresponds to the Resource.ResourceId property, which is the primary key for the Resource entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourceResourceGroupRequest Class
RetrieveByResourceResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByResourceResourceGroupResponse Class
See Also Members
[image]

Contains the response from the RetrieveByResourceResourceGroupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByResourceResourceGroupResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByResourceResourceGroupResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveByResourceResourceGroupResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourceResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourceResourceGroupRequest


RetrieveByResourceResourceGroupResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveByResourceResourceGroupRequest class.

The following tables list the members exposed by the RetrieveByResourceResourceGroupResponse type.

Public Constructors

Name | Description
RetrieveByResourceResourceGroupResponse | Initializes a new instance of the RetrieveByResourceResourceGroupResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all resource groups (scheduling groups) that contain the specified resource.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByResourceResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourceResourceGroupRequest


RetrieveByResourceResourceGroupResponse Constructor
[image]

Initializes a new instance of the RetrieveByResourceResourceGroupResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByResourceResourceGroupResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourceResourceGroupResponse Class
RetrieveByResourceResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByResourceResourceGroupResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByResourceResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourceResourceGroupRequest


RetrieveByResourceResourceGroupResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all resource groups (scheduling groups) that contain the specified resource.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveByResourceResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourceResourceGroupRequest


RetrieveByResourceResourceGroupResponse.EntityCollection Property
[image]

Gets the resulting collection of all resource groups (scheduling groups) that contain the specified resource.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The resulting collection of all resource groups (scheduling groups) that contain the specified resource.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourceResourceGroupResponse Class
RetrieveByResourceResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace
EntityCollection


RetrieveByResourcesServiceRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the collection of services that are related to the specified set of resources.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByResourcesServiceRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByResourcesServiceRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  RetrieveByResourcesServiceResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Service entity and access rights on the records that are specified in the ResourceIds property. For a complete list of the required privileges, see RetrieveByResourcesService Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveByResourcesServiceRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourcesServiceRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourcesServiceResponse
Other Resources
Service Entity
Resource Entities
Service Entity Messages and Methods


RetrieveByResourcesServiceRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the collection of services that are related to the specified set of resources.

The following tables list the members exposed by the RetrieveByResourcesServiceRequest type.

Public Constructors

Name | Description
RetrieveByResourcesServiceRequest | Initializes a new instance of the RetrieveByResourcesServiceRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceIds | Gets or sets an array of IDs for the specified set of services.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByResourcesServiceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourcesServiceResponse

Other Resources

Service Entity
Resource Entities
Service Entity Messages and Methods


RetrieveByResourcesServiceRequest Constructor
[image]

Initializes a new instance of the RetrieveByResourcesServiceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByResourcesServiceRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourcesServiceRequest Class
RetrieveByResourcesServiceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByResourcesServiceRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByResourcesServiceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourcesServiceResponse

Other Resources

Service Entity
Resource Entities
Service Entity Messages and Methods


RetrieveByResourcesServiceRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceIds | Gets or sets an array of IDs for the specified set of services.

See Also

Reference

RetrieveByResourcesServiceRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourcesServiceResponse

Other Resources

Service Entity
Resource Entities
Service Entity Messages and Methods


RetrieveByResourcesServiceRequest.Query Property
[image]

Gets or sets the query for the operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query for the operation.

  Remarks
The query must specify the entity name "service" and a column set. Any other specified conditions are merged (by using the AND operator) with the conditions that are needed to retrieve the services for the specified resources. If the column set includes attributes where IsValidForRead is false, they are ignored and the message response contains no data for those attributes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourcesServiceRequest Class
RetrieveByResourcesServiceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByResourcesServiceRequest.ResourceIds Property
[image]

Gets or sets an array of IDs for the specified set of services.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ResourceIds As Guid()

C#
public Guid[] ResourceIds { get; set; }

C++

J#

JScript

Property Value
Type:  Guid[]
The array of IDs for the specified set of services.
Each element of the ResourceIds array corresponds to the Resource.ResourceId property, which is the primary key for the Resource entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourcesServiceRequest Class
RetrieveByResourcesServiceRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByResourcesServiceResponse Class
See Also Members
[image]

Contains the response from the RetrieveByResourcesServiceRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByResourcesServiceResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByResourcesServiceResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveByResourcesServiceResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourcesServiceResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourcesServiceRequest


RetrieveByResourcesServiceResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveByResourcesServiceRequest class.

The following tables list the members exposed by the RetrieveByResourcesServiceResponse type.

Public Constructors

Name | Description
RetrieveByResourcesServiceResponse | Initializes a new instance of the RetrieveByResourcesServiceResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all related services for the specified set of services.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByResourcesServiceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourcesServiceRequest


RetrieveByResourcesServiceResponse Constructor
[image]

Initializes a new instance of the RetrieveByResourcesServiceResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByResourcesServiceResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourcesServiceResponse Class
RetrieveByResourcesServiceResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByResourcesServiceResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByResourcesServiceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourcesServiceRequest


RetrieveByResourcesServiceResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of all related services for the specified set of services.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveByResourcesServiceResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByResourcesServiceRequest


RetrieveByResourcesServiceResponse.EntityCollection Property
[image]

Gets the resulting collection of all related services for the specified set of services.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The resulting collection of all related services for the specified set of services.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByResourcesServiceResponse Class
RetrieveByResourcesServiceResponse Members
Microsoft.Crm.Sdk.Messages Namespace
EntityCollection


RetrieveByTopIncidentProductKbArticleRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the top-ten articles about a specified product from the knowledge base of articles for your organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByTopIncidentProductKbArticleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByTopIncidentProductKbArticleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// create the request
var retrieveByTopIncidentProductRequest =
    new RetrieveByTopIncidentProductKbArticleRequest()
{
    ProductId = _product.Id
};

// execute request
Console.WriteLine();
Console.WriteLine("  Searching for the top articles for product 'Sample Product'");
var retrieveByTopIncidentProductResponse = (RetrieveByTopIncidentProductKbArticleResponse)
    _context.Execute(retrieveByTopIncidentProductRequest);

// check success
articles = retrieveByTopIncidentProductResponse.EntityCollection.Entities.Select(
    (entity) => (KbArticle)entity);
Console.WriteLine("  Top articles for product 'Sample Product':");
foreach (var article in articles)
    Console.WriteLine(article.Title);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveByTopIncidentProductKbArticleResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the KbArticle and Product entities. The caller must also have access rights on the specified record in the ProductId property and on the records that are returned in the response of this message. For a complete list of required privileges, see RetrieveByTopIncidentProductKbArticle Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveByTopIncidentProductKbArticleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveByTopIncidentProductKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentProductKbArticleResponse
Other Resources
Knowledge Base Entities
Sample: Search and Retrieve Articles
RetrieveByTopIncidentProductKbArticle Privileges
Product Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveByTopIncidentProductKbArticleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the top-ten articles about a specified product from the knowledge base of articles for your organization.

The following tables list the members exposed by the RetrieveByTopIncidentProductKbArticleRequest type.

Public Constructors

Name | Description
RetrieveByTopIncidentProductKbArticleRequest | Initializes a new instance of the RetrieveByTopIncidentProductKbArticleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByTopIncidentProductKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentProductKbArticleResponse

Other Resources

Knowledge Base Entities
Sample: Search and Retrieve Articles
RetrieveByTopIncidentProductKbArticle Privileges
Product Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveByTopIncidentProductKbArticleRequest Constructor
[image]

Initializes a new instance of the RetrieveByTopIncidentProductKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByTopIncidentProductKbArticleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentProductKbArticleRequest Class
RetrieveByTopIncidentProductKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByTopIncidentProductKbArticleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByTopIncidentProductKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentProductKbArticleResponse

Other Resources

Knowledge Base Entities
Sample: Search and Retrieve Articles
RetrieveByTopIncidentProductKbArticle Privileges
Product Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveByTopIncidentProductKbArticleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProductId | Gets or sets the ID of the product. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveByTopIncidentProductKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentProductKbArticleResponse

Other Resources

Knowledge Base Entities
Sample: Search and Retrieve Articles
RetrieveByTopIncidentProductKbArticle Privileges
Product Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveByTopIncidentProductKbArticleRequest.ProductId Property
[image]

Gets or sets the ID of the product. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ProductId As Guid

C#
public Guid ProductId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the product. This corresponds to the Product.ProductId attribute, which is the primary key for the Product entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentProductKbArticleRequest Class
RetrieveByTopIncidentProductKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByTopIncidentProductKbArticleResponse Class
See Also Members
[image]

Contains the response from the RetrieveByTopIncidentProductKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByTopIncidentProductKbArticleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByTopIncidentProductKbArticleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveByTopIncidentProductKbArticleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentProductKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentProductKbArticleRequest


RetrieveByTopIncidentProductKbArticleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveByTopIncidentProductKbArticleRequest class.

The following tables list the members exposed by the RetrieveByTopIncidentProductKbArticleResponse type.

Public Constructors

Name | Description
RetrieveByTopIncidentProductKbArticleResponse | Initializes a new instance of the RetrieveByTopIncidentProductKbArticleResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of articles about the specified product from the knowledge base of articles for your organization.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByTopIncidentProductKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentProductKbArticleRequest


RetrieveByTopIncidentProductKbArticleResponse Constructor
[image]

Initializes a new instance of the RetrieveByTopIncidentProductKbArticleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByTopIncidentProductKbArticleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentProductKbArticleResponse Class
RetrieveByTopIncidentProductKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByTopIncidentProductKbArticleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByTopIncidentProductKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentProductKbArticleRequest


RetrieveByTopIncidentProductKbArticleResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of articles about the specified product from the knowledge base of articles for your organization.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveByTopIncidentProductKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentProductKbArticleRequest


RetrieveByTopIncidentProductKbArticleResponse.EntityCollection Property
[image]

Gets the resulting collection of articles about the specified product from the knowledge base of articles for your organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The resulting collection of articles about the specified product from the knowledge base of articles for your organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentProductKbArticleResponse Class
RetrieveByTopIncidentProductKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByTopIncidentSubjectKbArticleRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the top-ten articles about a specified subject from the knowledge base of articles for your organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByTopIncidentSubjectKbArticleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByTopIncidentSubjectKbArticleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// create the request
var retrieveByTopIncidentSubjectRequest =
    new RetrieveByTopIncidentSubjectKbArticleRequest()
{
    SubjectId = _subjectId
};

// execute request
Console.WriteLine();
Console.WriteLine("  Searching for the top articles in subject 'Default Subject'");
var retrieveByTopIncidentSubjectResponse = (RetrieveByTopIncidentSubjectKbArticleResponse)
    _context.Execute(retrieveByTopIncidentSubjectRequest);

// check success
var articles = retrieveByTopIncidentSubjectResponse.EntityCollection.Entities.Select(
    (entity) => (KbArticle)entity);
Console.WriteLine("  Top articles in subject 'Default Subject':");
foreach (var article in articles)
    Console.WriteLine(article.Title);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveByTopIncidentSubjectKbArticleResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the KbArticle and Subject entities. The caller must also have access rights on the specified record in the SubjectId property and on the records that are returned in the response of this message. For a complete list of the required privileges, see RetrieveByTopIncidentSubjectKbArticle Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveByTopIncidentSubjectKbArticleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveByTopIncidentSubjectKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentSubjectKbArticleResponse
Other Resources
Knowledge Base Entities
Sample: Search and Retrieve Articles
RetrieveByTopIncidentSubjectKbArticle Privileges
Subject Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveByTopIncidentSubjectKbArticleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the top-ten articles about a specified subject from the knowledge base of articles for your organization.

The following tables list the members exposed by the RetrieveByTopIncidentSubjectKbArticleRequest type.

Public Constructors

Name | Description
RetrieveByTopIncidentSubjectKbArticleRequest | Initializes a new instance of the RetrieveByTopIncidentSubjectKbArticleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SubjectId | Gets or sets the ID of the subject. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByTopIncidentSubjectKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentSubjectKbArticleResponse

Other Resources

Knowledge Base Entities
Sample: Search and Retrieve Articles
RetrieveByTopIncidentSubjectKbArticle Privileges
Subject Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveByTopIncidentSubjectKbArticleRequest Constructor
[image]

Initializes a new instance of the RetrieveByTopIncidentSubjectKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByTopIncidentSubjectKbArticleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentSubjectKbArticleRequest Class
RetrieveByTopIncidentSubjectKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByTopIncidentSubjectKbArticleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByTopIncidentSubjectKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentSubjectKbArticleResponse

Other Resources

Knowledge Base Entities
Sample: Search and Retrieve Articles
RetrieveByTopIncidentSubjectKbArticle Privileges
Subject Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveByTopIncidentSubjectKbArticleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SubjectId | Gets or sets the ID of the subject. Required.

See Also

Reference

RetrieveByTopIncidentSubjectKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentSubjectKbArticleResponse

Other Resources

Knowledge Base Entities
Sample: Search and Retrieve Articles
RetrieveByTopIncidentSubjectKbArticle Privileges
Subject Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveByTopIncidentSubjectKbArticleRequest.SubjectId Property
[image]

Gets or sets the ID of the subject. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SubjectId As Guid

C#
public Guid SubjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the subject. This corresponds to the Subject. SubjectId attribute, which is the primary key for the Subject entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentSubjectKbArticleRequest Class
RetrieveByTopIncidentSubjectKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByTopIncidentSubjectKbArticleResponse Class
See Also Members
[image]

Contains the response from the RetrieveByTopIncidentSubjectKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveByTopIncidentSubjectKbArticleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveByTopIncidentSubjectKbArticleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveByTopIncidentSubjectKbArticleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentSubjectKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentSubjectKbArticleRequest


RetrieveByTopIncidentSubjectKbArticleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveByTopIncidentSubjectKbArticleRequest class.

The following tables list the members exposed by the RetrieveByTopIncidentSubjectKbArticleResponse type.

Public Constructors

Name | Description
RetrieveByTopIncidentSubjectKbArticleResponse | Initializes a new instance of the RetrieveByTopIncidentSubjectKbArticleResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of knowledge base articles about the specified subject.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveByTopIncidentSubjectKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentSubjectKbArticleRequest


RetrieveByTopIncidentSubjectKbArticleResponse Constructor
[image]

Initializes a new instance of the RetrieveByTopIncidentSubjectKbArticleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveByTopIncidentSubjectKbArticleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentSubjectKbArticleResponse Class
RetrieveByTopIncidentSubjectKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveByTopIncidentSubjectKbArticleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveByTopIncidentSubjectKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentSubjectKbArticleRequest


RetrieveByTopIncidentSubjectKbArticleResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of knowledge base articles about the specified subject.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveByTopIncidentSubjectKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveByTopIncidentSubjectKbArticleRequest


RetrieveByTopIncidentSubjectKbArticleResponse.EntityCollection Property
[image]

Gets the resulting collection of knowledge base articles about the specified subject.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The resulting collection of knowledge base articles about the specified subject.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveByTopIncidentSubjectKbArticleResponse Class
RetrieveByTopIncidentSubjectKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveCurrentOrganizationRequest Class
See Also Members
[image]

Contains the data that’s needed to retrieve information about the current organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveCurrentOrganizationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveCurrentOrganizationRequest : OrganizationRequest

C++

J#

JScript

  Remarks
While the organization details are available from the discovery service, this message request enables you to get that same information from the organization service that your application is already connected to.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveCurrentOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveCurrentOrganizationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveCurrentOrganizationResponse
RetrieveOrganizationRequest


RetrieveCurrentOrganizationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that’s needed to retrieve information about the current organization.

The following tables list the members exposed by the RetrieveCurrentOrganizationRequest type.

Public Constructors

Name | Description
RetrieveCurrentOrganizationRequest | Initializes a new instance of the RetrieveCurrentOrganizationRequest class.
Top

Public Properties

 | Name | Description
public property | AccessType | Gets or sets the access type of the organization’s service endpoint.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveCurrentOrganizationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveCurrentOrganizationResponse
RetrieveOrganizationRequest


RetrieveCurrentOrganizationRequest Constructor
[image]

Initializes a new instance of the RetrieveCurrentOrganizationRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveCurrentOrganizationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveCurrentOrganizationRequest Class
RetrieveCurrentOrganizationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveCurrentOrganizationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveCurrentOrganizationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveCurrentOrganizationResponse
RetrieveOrganizationRequest


RetrieveCurrentOrganizationRequest Properties
[image]

Public Properties

 | Name | Description
public property | AccessType | Gets or sets the access type of the organization’s service endpoint.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveCurrentOrganizationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveCurrentOrganizationResponse
RetrieveOrganizationRequest


RetrieveCurrentOrganizationRequest.AccessType Property
[image]

Gets or sets the access type of the organization’s service endpoint.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AccessType As EndpointAccessType

C#
public EndpointAccessType AccessType { get; set; }

C++

J#

JScript

Property Value
Type:  EndpointAccessType
The access type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveCurrentOrganizationRequest Class
RetrieveCurrentOrganizationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveCurrentOrganizationResponse Class
See Also Members
[image]

Contains the response from processing RetrieveCurrentOrganizationRequest.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveCurrentOrganizationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveCurrentOrganizationResponse : OrganizationResponse

C++

J#

JScript

  Remarks
An instance of a response class is returned from the Execute method.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveCurrentOrganizationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveCurrentOrganizationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveCurrentOrganizationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from processing RetrieveCurrentOrganizationRequest.

The following tables list the members exposed by the RetrieveCurrentOrganizationResponse type.

Public Constructors

Name | Description
RetrieveCurrentOrganizationResponse | Initializes a new instance of the RetrieveCurrentOrganizationResponse class.
Top

Public Properties

 | Name | Description
public property | Detail | Gets detailed information about the current organization.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveCurrentOrganizationResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveCurrentOrganizationResponse Constructor
[image]

Initializes a new instance of the RetrieveCurrentOrganizationResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveCurrentOrganizationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveCurrentOrganizationResponse Class
RetrieveCurrentOrganizationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveCurrentOrganizationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveCurrentOrganizationResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveCurrentOrganizationResponse Properties
[image]

Public Properties

 | Name | Description
public property | Detail | Gets detailed information about the current organization.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveCurrentOrganizationResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveCurrentOrganizationResponse.Detail Property
[image]

Gets detailed information about the current organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Detail As OrganizationDetail

C#
public OrganizationDetail Detail { get; }

C++

J#

JScript

Property Value
Type: OrganizationDetail
The details about the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveCurrentOrganizationResponse Class
RetrieveCurrentOrganizationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependenciesForDeleteRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve a collection of dependency records that describe any solution components that would prevent a solution component from being deleted.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDependenciesForDeleteRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDependenciesForDeleteRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Use the RetrieveOptionSetRequest message to retrieve
// a global option set by it's name.
RetrieveOptionSetRequest retrieveOptionSetRequest =
    new RetrieveOptionSetRequest
    {
     Name = _globalOptionSetName
    };

// Execute the request.
RetrieveOptionSetResponse retrieveOptionSetResponse =
    (RetrieveOptionSetResponse)_serviceProxy.Execute(
    retrieveOptionSetRequest);
_globalOptionSetId = retrieveOptionSetResponse.OptionSetMetadata.MetadataId;
if (_globalOptionSetId != null)
{
 //Use the global OptionSet MetadataId with the appropriate componenttype
 // to call RetrieveDependenciesForDeleteRequest
 RetrieveDependenciesForDeleteRequest retrieveDependenciesForDeleteRequest = new RetrieveDependenciesForDeleteRequest
{
 ComponentType = (int)componenttype.OptionSet,
 ObjectId = (Guid)_globalOptionSetId
};

 RetrieveDependenciesForDeleteResponse retrieveDependenciesForDeleteResponse =
  (RetrieveDependenciesForDeleteResponse)_serviceProxy.Execute(retrieveDependenciesForDeleteRequest);
 Console.WriteLine("");
 foreach (Dependency d in retrieveDependenciesForDeleteResponse.EntityCollection.Entities)
 {

  if (d.DependentComponentType.Value == 2)//Just testing for Attributes
  {
   String attributeLabel = "";
   RetrieveAttributeRequest retrieveAttributeRequest = new RetrieveAttributeRequest
   {
    MetadataId = (Guid)d.DependentComponentObjectId
   };
   RetrieveAttributeResponse retrieveAttributeResponse = (RetrieveAttributeResponse)_serviceProxy.Execute(retrieveAttributeRequest);

   AttributeMetadata attmet = retrieveAttributeResponse.AttributeMetadata;

   attributeLabel = attmet.DisplayName.UserLocalizedLabel.Label;

    Console.WriteLine("An {0} named {1} will prevent deleting the {2} global option set.",
   (componenttype)d.DependentComponentType.Value,
   attributeLabel,
   _globalOptionSetName);
  }
 }
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  the RetrieveDependenciesForDeleteResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the privileges that are listed in RetrieveDependenciesForDelete Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveDependenciesForDeleteRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveDependenciesForDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Dependency Tracking for Solution Components
Work with Solutions
Sample: Detect Solution Dependencies


RetrieveDependenciesForDeleteRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a collection of dependency records that describe any solution components that would prevent a solution component from being deleted.

The following tables list the members exposed by the RetrieveDependenciesForDeleteRequest type.

Public Constructors

Name | Description
RetrieveDependenciesForDeleteRequest | Initializes a new instance of the RetrieveDependenciesForDeleteRequest class.
Top

Public Properties

 | Name | Description
public property | ComponentType | Gets or sets the value for the component type that you want to delete. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ObjectId | Gets or sets the ID of the solution component that you want to delete. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDependenciesForDeleteRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components
Work with Solutions
Sample: Detect Solution Dependencies


RetrieveDependenciesForDeleteRequest Constructor
[image]

Initializes a new instance of the RetrieveDependenciesForDeleteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDependenciesForDeleteRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForDeleteRequest Class
RetrieveDependenciesForDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependenciesForDeleteRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDependenciesForDeleteRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components
Work with Solutions
Sample: Detect Solution Dependencies


RetrieveDependenciesForDeleteRequest Properties
[image]

Public Properties

 | Name | Description
public property | ComponentType | Gets or sets the value for the component type that you want to delete. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ObjectId | Gets or sets the ID of the solution component that you want to delete. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveDependenciesForDeleteRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components
Work with Solutions
Sample: Detect Solution Dependencies


RetrieveDependenciesForDeleteRequest.ComponentType Property
[image]

Gets or sets the value for the component type that you want to delete. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ComponentType As Integer

C#
public int ComponentType { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The value for the component type that you want to delete. Required.

  Remarks
The componenttype enumeration defines the supported range of values for this property. You can access the available values by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project. These values are defined by the global option set Component Type (componenttype).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForDeleteRequest Class
RetrieveDependenciesForDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependenciesForDeleteRequest.ObjectId Property
[image]

Gets or sets the ID of the solution component that you want to delete. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ObjectId As Guid

C#
public Guid ObjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the solution component that you want to delete. This corresponds to the SolutionComponent.SolutionComponentId attribute, which is the primary key for the SolutionComponent entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForDeleteRequest Class
RetrieveDependenciesForDeleteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependenciesForDeleteResponse Class
See Also Members
[image]

Contains the response from the RetrieveDependenciesForDeleteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDependenciesForDeleteResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDependenciesForDeleteResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveDependenciesForDeleteResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForDeleteResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependenciesForDeleteRequest


RetrieveDependenciesForDeleteResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveDependenciesForDeleteRequest class.

The following tables list the members exposed by the RetrieveDependenciesForDeleteResponse type.

Public Constructors

Name | Description
RetrieveDependenciesForDeleteResponse | Initializes a new instance of the RetrieveDependenciesForDeleteResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent those components that can prevent the solution component from being deleted.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDependenciesForDeleteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependenciesForDeleteRequest


RetrieveDependenciesForDeleteResponse Constructor
[image]

Initializes a new instance of the RetrieveDependenciesForDeleteResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDependenciesForDeleteResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForDeleteResponse Class
RetrieveDependenciesForDeleteResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependenciesForDeleteResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDependenciesForDeleteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependenciesForDeleteRequest


RetrieveDependenciesForDeleteResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent those components that can prevent the solution component from being deleted.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveDependenciesForDeleteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependenciesForDeleteRequest


RetrieveDependenciesForDeleteResponse.EntityCollection Property
[image]

Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent those components that can prevent the solution component from being deleted.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent those components that can prevent the solution component from being deleted..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForDeleteResponse Class
RetrieveDependenciesForDeleteResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependenciesForUninstallRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve a list of the solution component dependencies that can prevent you from uninstalling a managed solution.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDependenciesForUninstallRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDependenciesForUninstallRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute  method, which returns an instance of  the RetrieveDependenciesForUninstallResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in RetrieveDependenciesForUninstall Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveDependenciesForUninstallRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForUninstallRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Check for Solution Component Dependencies
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveDependenciesForUninstallRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a list of the solution component dependencies that can prevent you from uninstalling a managed solution.

The following tables list the members exposed by the RetrieveDependenciesForUninstallRequest type.

Public Constructors

Name | Description
RetrieveDependenciesForUninstallRequest | Initializes a new instance of the RetrieveDependenciesForUninstallRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the managed solution. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDependenciesForUninstallRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Check for Solution Component Dependencies
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveDependenciesForUninstallRequest Constructor
[image]

Initializes a new instance of the RetrieveDependenciesForUninstallRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDependenciesForUninstallRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForUninstallRequest Class
RetrieveDependenciesForUninstallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependenciesForUninstallRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDependenciesForUninstallRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Check for Solution Component Dependencies
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveDependenciesForUninstallRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the managed solution. Required.

See Also

Reference

RetrieveDependenciesForUninstallRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Check for Solution Component Dependencies
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveDependenciesForUninstallRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the managed solution. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the managed solution. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForUninstallRequest Class
RetrieveDependenciesForUninstallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependenciesForUninstallResponse Class
See Also Members
[image]

Contains the response from the RetrieveDependenciesForUninstallRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDependenciesForUninstallResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDependenciesForUninstallResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveDependenciesForUninstallResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForUninstallResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependenciesForUninstallRequest


RetrieveDependenciesForUninstallResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveDependenciesForUninstallRequest class.

The following tables list the members exposed by the RetrieveDependenciesForUninstallResponse type.

Public Constructors

Name | Description
RetrieveDependenciesForUninstallResponse | Initializes a new instance of the RetrieveDependenciesForUninstallResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent the components that can prevent you from deleting the solution.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDependenciesForUninstallResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependenciesForUninstallRequest


RetrieveDependenciesForUninstallResponse Constructor
[image]

Initializes a new instance of the RetrieveDependenciesForUninstallResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDependenciesForUninstallResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForUninstallResponse Class
RetrieveDependenciesForUninstallResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependenciesForUninstallResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDependenciesForUninstallResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependenciesForUninstallRequest


RetrieveDependenciesForUninstallResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent the components that can prevent you from deleting the solution.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveDependenciesForUninstallResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependenciesForUninstallRequest


RetrieveDependenciesForUninstallResponse.EntityCollection Property
[image]

Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent the components that can prevent you from deleting the solution.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
A collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent the components that can prevent you from deleting the solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependenciesForUninstallResponse Class
RetrieveDependenciesForUninstallResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependentComponentsRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieves a list dependencies for solution components that directly depend on a solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDependentComponentsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDependentComponentsRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create the request to see which components have a dependency on the
// global option set.
RetrieveDependentComponentsRequest dependencyRequest =
    new RetrieveDependentComponentsRequest
    {
        ObjectId = _optionSetId,
        ComponentType = (int)componenttype.OptionSet
    };

RetrieveDependentComponentsResponse dependencyResponse =
    (RetrieveDependentComponentsResponse)_serviceProxy.Execute(
    dependencyRequest);

// Here you would check the dependencyResponse.EntityCollection property
// and act as appropriate. However, we know there is exactly one
// dependency so this example deals with it directly and deletes
// the previously created attribute.
DeleteAttributeRequest deleteAttributeRequest =
    new DeleteAttributeRequest
{
    EntityLogicalName = Contact.EntityLogicalName,
    LogicalName = "sample_examplepicklist"
};

_serviceProxy.Execute(deleteAttributeRequest);

Console.WriteLine("Referring attribute deleted.");
#endregion How to delete attribute

#region How to delete global option set

// Finally, delete the global option set. Attempting this before deleting
// the picklist above will result in an exception being thrown.
DeleteOptionSetRequest deleteRequest = new DeleteOptionSetRequest
{
    Name = _globalOptionSetName
};

_serviceProxy.Execute(deleteRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  the RetrieveDependentComponentsResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in RetrieveDependentComponents Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveDependentComponentsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveDependentComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Sample: Work with Global Option Sets
Sample: Detect Solution Dependencies
Check for Solution Component Dependencies
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveDependentComponentsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieves a list dependencies for solution components that directly depend on a solution component.

The following tables list the members exposed by the RetrieveDependentComponentsRequest type.

Public Constructors

Name | Description
RetrieveDependentComponentsRequest | Initializes a new instance of the RetrieveDependentComponentsRequest class.
Top

Public Properties

 | Name | Description
public property | ComponentType | Gets or sets the value that represents the solution component. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ObjectId | Gets or sets the ID of the solution component that you want to check. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDependentComponentsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Sample: Detect Solution Dependencies
Check for Solution Component Dependencies
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveDependentComponentsRequest Constructor
[image]

Initializes a new instance of the RetrieveDependentComponentsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDependentComponentsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependentComponentsRequest Class
RetrieveDependentComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependentComponentsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDependentComponentsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Sample: Detect Solution Dependencies
Check for Solution Component Dependencies
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveDependentComponentsRequest Properties
[image]

Public Properties

 | Name | Description
public property | ComponentType | Gets or sets the value that represents the solution component. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ObjectId | Gets or sets the ID of the solution component that you want to check. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveDependentComponentsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Sample: Detect Solution Dependencies
Check for Solution Component Dependencies
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveDependentComponentsRequest.ComponentType Property
[image]

Gets or sets the value that represents the solution component. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ComponentType As Integer

C#
public int ComponentType { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The value that represents the solution component. Required.

  Remarks
The componenttype enumeration defines the supported range of values for this property. You can access the available values by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project. These values are defined by the global option set Component Type (componenttype).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependentComponentsRequest Class
RetrieveDependentComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependentComponentsRequest.ObjectId Property
[image]

Gets or sets the ID of the solution component that you want to check. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ObjectId As Guid

C#
public Guid ObjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the solution component that you want to check. This corresponds to the SolutionComponent.SolutionComponentId attribute, which is the primary key for the SolutionComponent entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependentComponentsRequest Class
RetrieveDependentComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependentComponentsResponse Class
See Also Members
[image]

Contains the response from the RetrieveDependentComponentsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDependentComponentsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDependentComponentsResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveDependentComponentsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependentComponentsResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependentComponentsRequest


RetrieveDependentComponentsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveDependentComponentsRequest class.

The following tables list the members exposed by the RetrieveDependentComponentsResponse type.

Public Constructors

Name | Description
RetrieveDependentComponentsResponse | Initializes a new instance of the RetrieveDependentComponentsResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent the components that can prevent you from deleting the solution component.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDependentComponentsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependentComponentsRequest


RetrieveDependentComponentsResponse Constructor
[image]

Initializes a new instance of the RetrieveDependentComponentsResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDependentComponentsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependentComponentsResponse Class
RetrieveDependentComponentsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDependentComponentsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDependentComponentsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependentComponentsRequest


RetrieveDependentComponentsResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent the components that can prevent you from deleting the solution component.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveDependentComponentsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDependentComponentsRequest


RetrieveDependentComponentsResponse.EntityCollection Property
[image]

Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent the components that can prevent you from deleting the solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
A collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent the components that can prevent you from deleting the solution component.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDependentComponentsResponse Class
RetrieveDependentComponentsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDeploymentLicenseTypeRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the type of license for a deployment of Microsoft Dynamics CRM.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDeploymentLicenseTypeRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDeploymentLicenseTypeRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the RetrieveDeploymentLicenseTypeResponse class.
Privileges and Access Rights
For a complete list of the required privileges, see RetrieveDeploymentLicenseType Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveDeploymentLicenseTypeRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeploymentLicenseTypeRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeploymentLicenseTypeResponse
Other Resources
Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveDeploymentLicenseTypeRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the type of license for a deployment of Microsoft Dynamics CRM.

The following tables list the members exposed by the RetrieveDeploymentLicenseTypeRequest type.

Public Constructors

Name | Description
RetrieveDeploymentLicenseTypeRequest | Initializes a new instance of the RetrieveDeploymentLicenseTypeRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDeploymentLicenseTypeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeploymentLicenseTypeResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveDeploymentLicenseTypeRequest Constructor
[image]

Initializes a new instance of the RetrieveDeploymentLicenseTypeRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDeploymentLicenseTypeRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeploymentLicenseTypeRequest Class
RetrieveDeploymentLicenseTypeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDeploymentLicenseTypeRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDeploymentLicenseTypeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeploymentLicenseTypeResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveDeploymentLicenseTypeRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveDeploymentLicenseTypeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeploymentLicenseTypeResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveDeploymentLicenseTypeResponse Class
See Also Members
[image]

Contains the response from the RetrieveDeploymentLicenseTypeRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDeploymentLicenseTypeResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDeploymentLicenseTypeResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveDeploymentLicenseTypeResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeploymentLicenseTypeResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeploymentLicenseTypeRequest


RetrieveDeploymentLicenseTypeResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveDeploymentLicenseTypeRequest class.

The following tables list the members exposed by the RetrieveDeploymentLicenseTypeResponse type.

Public Constructors

Name | Description
RetrieveDeploymentLicenseTypeResponse | Initializes a new instance of the RetrieveDeploymentLicenseTypeResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | licenseType | Gets the license type.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDeploymentLicenseTypeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeploymentLicenseTypeRequest


RetrieveDeploymentLicenseTypeResponse Constructor
[image]

Initializes a new instance of the RetrieveDeploymentLicenseTypeResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDeploymentLicenseTypeResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeploymentLicenseTypeResponse Class
RetrieveDeploymentLicenseTypeResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDeploymentLicenseTypeResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDeploymentLicenseTypeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeploymentLicenseTypeRequest


RetrieveDeploymentLicenseTypeResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | licenseType | Gets the license type.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveDeploymentLicenseTypeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeploymentLicenseTypeRequest


RetrieveDeploymentLicenseTypeResponse.licenseType Property
[image]

Gets the license type.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property licenseType As String

C#
public string licenseType { get; }

C++

J#

JScript

Property Value
Type:  String
The license type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeploymentLicenseTypeResponse Class
RetrieveDeploymentLicenseTypeResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDeprovisionedLanguagesRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve a list of language packs that are installed on the server that have been disabled.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDeprovisionedLanguagesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDeprovisionedLanguagesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute    method, which returns an instance of  the RetrieveDeprovisionedLanguagesResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in RetrieveDeprovisionedLanguages Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveDeprovisionedLanguagesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeprovisionedLanguagesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages


RetrieveDeprovisionedLanguagesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a list of language packs that are installed on the server that have been disabled.

The following tables list the members exposed by the RetrieveDeprovisionedLanguagesRequest type.

Public Constructors

Name | Description
RetrieveDeprovisionedLanguagesRequest | Initializes a new instance of the RetrieveDeprovisionedLanguagesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDeprovisionedLanguagesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveDeprovisionedLanguagesRequest Constructor
[image]

Initializes a new instance of the RetrieveDeprovisionedLanguagesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDeprovisionedLanguagesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeprovisionedLanguagesRequest Class
RetrieveDeprovisionedLanguagesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDeprovisionedLanguagesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDeprovisionedLanguagesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveDeprovisionedLanguagesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveDeprovisionedLanguagesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveDeprovisionedLanguagesResponse Class
See Also Members
[image]

Contains the response from the RetrieveDeprovisionedLanguagesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDeprovisionedLanguagesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDeprovisionedLanguagesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveDeprovisionedLanguagesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeprovisionedLanguagesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeprovisionedLanguagesRequest


RetrieveDeprovisionedLanguagesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveDeprovisionedLanguagesRequest class.

The following tables list the members exposed by the RetrieveDeprovisionedLanguagesResponse type.

Public Constructors

Name | Description
RetrieveDeprovisionedLanguagesResponse | Initializes a new instance of the RetrieveDeprovisionedLanguagesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RetrieveDeprovisionedLanguages | Gets an array of locale ID values representing disabled language packs that are installed on the server.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDeprovisionedLanguagesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeprovisionedLanguagesRequest


RetrieveDeprovisionedLanguagesResponse Constructor
[image]

Initializes a new instance of the RetrieveDeprovisionedLanguagesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDeprovisionedLanguagesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeprovisionedLanguagesResponse Class
RetrieveDeprovisionedLanguagesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDeprovisionedLanguagesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDeprovisionedLanguagesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeprovisionedLanguagesRequest


RetrieveDeprovisionedLanguagesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RetrieveDeprovisionedLanguages | Gets an array of locale ID values representing disabled language packs that are installed on the server.

See Also

Reference

RetrieveDeprovisionedLanguagesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDeprovisionedLanguagesRequest


RetrieveDeprovisionedLanguagesResponse.RetrieveDeprovisionedLanguages Property
[image]

Gets an array of locale ID values representing disabled language packs that are installed on the server.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property RetrieveDeprovisionedLanguages As Integer()

C#
public int[] RetrieveDeprovisionedLanguages { get; }

C++

J#

JScript

Property Value
Type: Int32[]
An array of locale ID values representing disabled language packs that are installed on the server.

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDeprovisionedLanguagesResponse Class
RetrieveDeprovisionedLanguagesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDuplicatesRequest Class
See Also Example Members
[image]

Contains the data that is needed to detect and retrieve duplicates for a specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDuplicatesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDuplicatesRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
var request = new RetrieveDuplicatesRequest
{
    BusinessEntity = new Account { Name = "Microsoft" }.ToEntity<Entity>(),
    MatchingEntityName = Account.EntityLogicalName,
    PagingInfo = new PagingInfo() { PageNumber = 1, Count = 50 }
};

Console.WriteLine("Retrieving duplicates");
var response =(RetrieveDuplicatesResponse)_serviceProxy.Execute(request);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveDuplicatesResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the entities and the access rights to the specified records in the BusinessEntity property.
For a complete list of the required privileges, see RetrieveDuplicates Privileges.
Notes to Callers
This message works for all entities. Before you use this message, set the IsDuplicateDetectionEnabled attribute for an entity to true and publish all duplicate detection rules for an entity.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveDuplicatesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDuplicatesResponse
Other Resources
RetrieveDuplicates Privileges
Sample: Enable Duplicate Detection and Retrieve Duplicates
Detect Duplicate Data in Microsoft Dynamics CRM
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveDuplicatesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to detect and retrieve duplicates for a specified record.

The following tables list the members exposed by the RetrieveDuplicatesRequest type.

Public Constructors

Name | Description
RetrieveDuplicatesRequest | Initializes a new instance of the RetrieveDuplicatesRequest class.
Top

Public Properties

 | Name | Description
public property | BusinessEntity | Gets or sets a record for which the duplicates are retrieved. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MatchingEntityName | Gets or sets a name of the matching entity type. Required.
public property | PagingInfo | Gets or sets a paging information for the retrieved duplicates. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDuplicatesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDuplicatesResponse

Other Resources

RetrieveDuplicates Privileges
Sample: Enable Duplicate Detection and Retrieve Duplicates
Detect Duplicate Data in Microsoft Dynamics CRM
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveDuplicatesRequest Constructor
[image]

Initializes a new instance of the RetrieveDuplicatesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDuplicatesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDuplicatesRequest Class
RetrieveDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDuplicatesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDuplicatesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDuplicatesResponse

Other Resources

RetrieveDuplicates Privileges
Sample: Enable Duplicate Detection and Retrieve Duplicates
Detect Duplicate Data in Microsoft Dynamics CRM
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveDuplicatesRequest Properties
[image]

Public Properties

 | Name | Description
public property | BusinessEntity | Gets or sets a record for which the duplicates are retrieved. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MatchingEntityName | Gets or sets a name of the matching entity type. Required.
public property | PagingInfo | Gets or sets a paging information for the retrieved duplicates. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveDuplicatesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDuplicatesResponse

Other Resources

RetrieveDuplicates Privileges
Sample: Enable Duplicate Detection and Retrieve Duplicates
Detect Duplicate Data in Microsoft Dynamics CRM
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveDuplicatesRequest.BusinessEntity Property
[image]

Gets or sets a record for which the duplicates are retrieved. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BusinessEntity As Entity

C#
public Entity BusinessEntity { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The record for which the duplicates are retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDuplicatesRequest Class
RetrieveDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDuplicatesRequest.MatchingEntityName Property
[image]

Gets or sets a name of the matching entity type. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MatchingEntityName As String

C#
public string MatchingEntityName { get; set; }

C++

J#

JScript

Property Value
Type:  String
The name of the matching entity type.

  Remarks
A duplicate of a contact can be a lead that has the same address. The lead in this case is a matching entity type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDuplicatesRequest Class
RetrieveDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDuplicatesRequest.PagingInfo Property
[image]

Gets or sets a paging information for the retrieved duplicates. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PagingInfo As PagingInfo

C#
public PagingInfo PagingInfo { get; set; }

C++

J#

JScript

Property Value
Type: PagingInfo
The paging information for the retrieved duplicates.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDuplicatesRequest Class
RetrieveDuplicatesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDuplicatesResponse Class
See Also Members
[image]

Contains the response from the RetrieveDuplicatesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveDuplicatesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveDuplicatesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveDuplicatesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDuplicatesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDuplicatesRequest


RetrieveDuplicatesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveDuplicatesRequest class.

The following tables list the members exposed by the RetrieveDuplicatesResponse type.

Public Constructors

Name | Description
RetrieveDuplicatesResponse | Initializes a new instance of the RetrieveDuplicatesResponse class.
Top

Public Properties

 | Name | Description
public property | DuplicateCollection | Gets a collection of duplicate entity instances.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDuplicatesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDuplicatesRequest


RetrieveDuplicatesResponse Constructor
[image]

Initializes a new instance of the RetrieveDuplicatesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDuplicatesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDuplicatesResponse Class
RetrieveDuplicatesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveDuplicatesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDuplicatesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDuplicatesRequest


RetrieveDuplicatesResponse Properties
[image]

Public Properties

 | Name | Description
public property | DuplicateCollection | Gets a collection of duplicate entity instances.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveDuplicatesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveDuplicatesRequest


RetrieveDuplicatesResponse.DuplicateCollection Property
[image]

Gets a collection of duplicate entity instances.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property DuplicateCollection As EntityCollection

C#
public EntityCollection DuplicateCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of duplicate entity instances.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDuplicatesResponse Class
RetrieveDuplicatesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveEntityRibbonRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve ribbon definitions for an entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveEntityRibbonRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveEntityRibbonRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
//Retrieve system Entity Ribbons
RetrieveEntityRibbonRequest entRibReq = new RetrieveEntityRibbonRequest() { RibbonLocationFilter = RibbonLocationFilters.All };

foreach (System.String entityName in entitiesWithRibbons)
{
 entRibReq.EntityName = entityName;
 RetrieveEntityRibbonResponse entRibResp = (RetrieveEntityRibbonResponse)_serviceProxy.Execute(entRibReq);

 System.String entityRibbonPath = Path.GetFullPath(exportFolder + "\\" + entityName + "Ribbon.xml");
 File.WriteAllBytes(entityRibbonPath, unzipRibbon(entRibResp.CompressedEntityXml));
 //Write the path where the file has been saved.
 Console.WriteLine(entityRibbonPath);
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  the RetrieveEntityRibbonResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in RetrieveEntityRibbon Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveEntityRibbonRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveEntityRibbonRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Export Ribbon Definitions


RetrieveEntityRibbonRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve ribbon definitions for an entity.

The following tables list the members exposed by the RetrieveEntityRibbonRequest type.

Public Constructors

Name | Description
RetrieveEntityRibbonRequest | Initializes a new instance of the RetrieveEntityRibbonRequest class.
Top

Public Properties

 | Name | Description
public property | EntityName | Gets or sets the logical name of an entity in order to retrieve a ribbon definition. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RibbonLocationFilter | Gets or sets a filter to retrieve a specific set of ribbon definitions for an entity. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveEntityRibbonRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Export Ribbon Definitions


RetrieveEntityRibbonRequest Constructor
[image]

Initializes a new instance of the RetrieveEntityRibbonRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveEntityRibbonRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRibbonRequest Class
RetrieveEntityRibbonRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveEntityRibbonRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveEntityRibbonRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Export Ribbon Definitions


RetrieveEntityRibbonRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityName | Gets or sets the logical name of an entity in order to retrieve a ribbon definition. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RibbonLocationFilter | Gets or sets a filter to retrieve a specific set of ribbon definitions for an entity. Required.

See Also

Reference

RetrieveEntityRibbonRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Export Ribbon Definitions


RetrieveEntityRibbonRequest.EntityName Property
[image]

Gets or sets the logical name of an entity in order to retrieve a ribbon definition. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of an entity in order to retrieve a ribbon definition. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRibbonRequest Class
RetrieveEntityRibbonRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveEntityRibbonRequest.RibbonLocationFilter Property
[image]

Gets or sets a filter to retrieve a specific set of ribbon definitions for an entity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RibbonLocationFilter As RibbonLocationFilters

C#
public RibbonLocationFilters RibbonLocationFilter { get; set; }

C++

J#

JScript

Property Value
Type: RibbonLocationFilters
A filter to retrieve a specific set of ribbon definitions for an entity. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRibbonRequest Class
RetrieveEntityRibbonRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveEntityRibbonResponse Class
See Also Members
[image]

Contains the response from the RetrieveEntityRibbonRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveEntityRibbonResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveEntityRibbonResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveEntityRibbonResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRibbonResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveEntityRibbonRequest


RetrieveEntityRibbonResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveEntityRibbonRequest class.

The following tables list the members exposed by the RetrieveEntityRibbonResponse type.

Public Constructors

Name | Description
RetrieveEntityRibbonResponse | Initializes a new instance of the RetrieveEntityRibbonResponse class.
Top

Public Properties

 | Name | Description
public property | CompressedEntityXml | Gets a compressed file that contains the ribbon definitions.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveEntityRibbonResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveEntityRibbonRequest


RetrieveEntityRibbonResponse Constructor
[image]

Initializes a new instance of the RetrieveEntityRibbonResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveEntityRibbonResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRibbonResponse Class
RetrieveEntityRibbonResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveEntityRibbonResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveEntityRibbonResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveEntityRibbonRequest


RetrieveEntityRibbonResponse Properties
[image]

Public Properties

 | Name | Description
public property | CompressedEntityXml | Gets a compressed file that contains the ribbon definitions.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveEntityRibbonResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveEntityRibbonRequest


RetrieveEntityRibbonResponse.CompressedEntityXml Property
See Also Example
[image]

Gets a compressed file that contains the ribbon definitions.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CompressedEntityXml As Byte()

C#
public byte[] CompressedEntityXml { get; }

C++

J#

JScript

Property Value
Type: Byte[]
A compressed file that contains the ribbon definitions..

  Example
The following example is a helper method that is included in the SDK sample that is found at SampleCode\CS\Client\Ribbon\ExportRibbonXml.
C#    Copy Code
/// <summary>
/// A helper method that decompresses the the Ribbon data returned
/// </summary>
/// <param name="data">The compressed ribbon data</param>
/// <returns></returns>
public byte[] unzipRibbon(byte[] data)
{
 System.IO.Packaging.ZipPackage package = null;
 MemoryStream memStream = null;

 memStream = new MemoryStream();
 memStream.Write(data, 0, data.Length);
 package = (ZipPackage)ZipPackage.Open(memStream, FileMode.Open);

 ZipPackagePart part = (ZipPackagePart)package.GetPart(new Uri("/RibbonXml.xml", UriKind.Relative));
 using (Stream strm = part.GetStream())
 {
  long len = strm.Length;
  byte[] buff = new byte[len];
  strm.Read(buff, 0, (int)len);
  return buff;
 }
}

  Remarks
To extract the XML data from the compressed file, you have to use the System.IO.Packaging.ZipPackage class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveEntityRibbonResponse Class
RetrieveEntityRibbonResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveExchangeRateRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the exchange rate.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveExchangeRateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveExchangeRateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
// using the service context makes retrieving entities easier
using (_context = new ServiceContext(_serviceProxy))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    String currentOrganizatoinUniqueName = GetCurrentOrganizationName(serverConfig);

    CreateRequiredRecords();

    RetrieveExchangeRateRequest request = new RetrieveExchangeRateRequest()
    {
        TransactionCurrencyId = _currency.Id
    };
    RetrieveExchangeRateResponse response =
        (RetrieveExchangeRateResponse)_serviceProxy.Execute(request);
    Console.WriteLine("  Retrieved exchange rate for created currency");

    // get the base currency for the current org
    var baseCurrencyName =
        (from currency in _context.TransactionCurrencySet
         join org in _context.OrganizationSet
         on currency.Id equals org.BaseCurrencyId.Id
         where org.Name == currentOrganizatoinUniqueName
         select currency.CurrencyName).FirstOrDefault();
    Console.WriteLine("  This organization's base currency is {0}",
        baseCurrencyName);

    Console.WriteLine(
        "  The conversion from {0} -> {1} is {2}",
        _currency.CurrencyName,
        baseCurrencyName,
        response.ExchangeRate);

    DeleteRequiredRecords(promptforDelete);
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveExchangeRateResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the TransactionCurrency entity and access rights to the specified record in the TransactionCurrencyId property.
For a complete list of the required privileges, see RetrieveExchangeRate Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveExchangeRateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveExchangeRateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveExchangeRateResponse
Other Resources
RetrieveExchangeRate Privileges
TransactionCurrency (Currency) Entity
Sample: Retrieve Currency Exchange Rate
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveExchangeRateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the exchange rate.

The following tables list the members exposed by the RetrieveExchangeRateRequest type.

Public Constructors

Name | Description
RetrieveExchangeRateRequest | Initializes a new instance of the RetrieveExchangeRateRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TransactionCurrencyId | Gets or sets the ID of the currency. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveExchangeRateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveExchangeRateResponse

Other Resources

RetrieveExchangeRate Privileges
TransactionCurrency (Currency) Entity
Sample: Retrieve Currency Exchange Rate
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveExchangeRateRequest Constructor
[image]

Initializes a new instance of the RetrieveExchangeRateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveExchangeRateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveExchangeRateRequest Class
RetrieveExchangeRateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveExchangeRateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveExchangeRateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveExchangeRateResponse

Other Resources

RetrieveExchangeRate Privileges
TransactionCurrency (Currency) Entity
Sample: Retrieve Currency Exchange Rate
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveExchangeRateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TransactionCurrencyId | Gets or sets the ID of the currency. Required.

See Also

Reference

RetrieveExchangeRateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveExchangeRateResponse

Other Resources

RetrieveExchangeRate Privileges
TransactionCurrency (Currency) Entity
Sample: Retrieve Currency Exchange Rate
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveExchangeRateRequest.TransactionCurrencyId Property
[image]

Gets or sets the ID of the currency. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TransactionCurrencyId As Guid

C#
public Guid TransactionCurrencyId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the currency. This corresponds to the TransactionCurrency.TransactionCurrencyId attribute, which is the primary key for the TransactionCurrency entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveExchangeRateRequest Class
RetrieveExchangeRateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveExchangeRateResponse Class
See Also Members
[image]

Contains the response from the RetrieveExchangeRateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveExchangeRateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveExchangeRateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveExchangeRateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveExchangeRateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveExchangeRateRequest


RetrieveExchangeRateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveExchangeRateRequest class.

The following tables list the members exposed by the RetrieveExchangeRateResponse type.

Public Constructors

Name | Description
RetrieveExchangeRateResponse | Initializes a new instance of the RetrieveExchangeRateResponse class.
Top

Public Properties

 | Name | Description
public property | ExchangeRate | Gets the exchange rate for the currency.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveExchangeRateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveExchangeRateRequest


RetrieveExchangeRateResponse Constructor
[image]

Initializes a new instance of the RetrieveExchangeRateResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveExchangeRateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveExchangeRateResponse Class
RetrieveExchangeRateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveExchangeRateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveExchangeRateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveExchangeRateRequest


RetrieveExchangeRateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExchangeRate | Gets the exchange rate for the currency.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveExchangeRateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveExchangeRateRequest


RetrieveExchangeRateResponse.ExchangeRate Property
[image]

Gets the exchange rate for the currency.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ExchangeRate As Decimal

C#
public decimal ExchangeRate { get; }

C++

J#

JScript

Property Value
Type: Decimal
The exchange rate for the currency.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveExchangeRateResponse Class
RetrieveExchangeRateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFilteredFormsRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the entity forms that are available for a specified user.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveFilteredFormsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveFilteredFormsRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute  method, which returns an instance of the RetrieveFilteredFormsResponse class.
Privileges and Access Rights
To perform this action, the caller must have the required privileges, as listed in RetrieveFilteredForms Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveFilteredFormsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFilteredFormsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Create and design forms : Control access to forms
Customize Entity Forms in Microsoft Dynamics CRM


RetrieveFilteredFormsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the entity forms that are available for a specified user.

The following tables list the members exposed by the RetrieveFilteredFormsRequest type.

Public Constructors

Name | Description
RetrieveFilteredFormsRequest | Initializes a new instance of the RetrieveFilteredFormsRequest class.
Top

Public Properties

 | Name | Description
public property | EntityLogicalName | Gets or sets the logical name for the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FormType | Gets or sets the type of form. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SystemUserId | Gets or sets the ID of the user. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveFilteredFormsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Create and design forms : Control access to forms
Customize Entity Forms in Microsoft Dynamics CRM


RetrieveFilteredFormsRequest Constructor
[image]

Initializes a new instance of the RetrieveFilteredFormsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveFilteredFormsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFilteredFormsRequest Class
RetrieveFilteredFormsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFilteredFormsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveFilteredFormsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Create and design forms : Control access to forms
Customize Entity Forms in Microsoft Dynamics CRM


RetrieveFilteredFormsRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityLogicalName | Gets or sets the logical name for the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FormType | Gets or sets the type of form. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SystemUserId | Gets or sets the ID of the user. Required.

See Also

Reference

RetrieveFilteredFormsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Create and design forms : Control access to forms
Customize Entity Forms in Microsoft Dynamics CRM


RetrieveFilteredFormsRequest.EntityLogicalName Property
[image]

Gets or sets the logical name for the entity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityLogicalName As String

C#
public string EntityLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name for the entity. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFilteredFormsRequest Class
RetrieveFilteredFormsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFilteredFormsRequest.FormType Property
[image]

Gets or sets the type of form. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FormType As OptionSetValue

C#
public OptionSetValue FormType { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The type of form. Required.

  Remarks
The  FormType property corresponds to the SystemForm.Type attribute. It specifies the possible types of SystemForm records..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFilteredFormsRequest Class
RetrieveFilteredFormsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFilteredFormsRequest.SystemUserId Property
[image]

Gets or sets the ID of the user. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SystemUserId As Guid

C#
public Guid SystemUserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the user. This corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFilteredFormsRequest Class
RetrieveFilteredFormsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFilteredFormsResponse Class
See Also Members
[image]

Contains the response from the RetrieveFilteredFormsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveFilteredFormsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveFilteredFormsResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveFilteredFormsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFilteredFormsResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveFilteredFormsRequest


RetrieveFilteredFormsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveFilteredFormsRequest class.

The following tables list the members exposed by the RetrieveFilteredFormsResponse type.

Public Constructors

Name | Description
RetrieveFilteredFormsResponse | Initializes a new instance of the RetrieveFilteredFormsResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SystemForms | Gets a collection of SystemForm entity references.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveFilteredFormsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveFilteredFormsRequest


RetrieveFilteredFormsResponse Constructor
[image]

Initializes a new instance of the RetrieveFilteredFormsResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveFilteredFormsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFilteredFormsResponse Class
RetrieveFilteredFormsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFilteredFormsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveFilteredFormsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveFilteredFormsRequest


RetrieveFilteredFormsResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SystemForms | Gets a collection of SystemForm entity references.

See Also

Reference

RetrieveFilteredFormsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveFilteredFormsRequest


RetrieveFilteredFormsResponse.SystemForms Property
[image]

Gets a collection of SystemForm entity references.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property SystemForms As EntityReferenceCollection

C#
public EntityReferenceCollection SystemForms { get; }

C++

J#

JScript

Property Value
Type: EntityReferenceCollection
A collection of SystemForm entity references.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFilteredFormsResponse Class
RetrieveFilteredFormsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormattedImportJobResultsRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the formatted results from an import job.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveFormattedImportJobResultsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveFormattedImportJobResultsRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of the RetrieveFormattedImportJobResultsResponse class.
Privileges and Access Rights
For a list of the required privileges, see RetrieveFormattedImportJobResults Privileges.
Notes for Callers
The data is returned in Microsoft Excel format.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveFormattedImportJobResultsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormattedImportJobResultsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Work with Solutions
ImportJob Entity Messages and Methods


RetrieveFormattedImportJobResultsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the formatted results from an import job.

The following tables list the members exposed by the RetrieveFormattedImportJobResultsRequest type.

Public Constructors

Name | Description
RetrieveFormattedImportJobResultsRequest | Initializes a new instance of the RetrieveFormattedImportJobResultsRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportJobId | Gets or sets the GUID of an import job. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveFormattedImportJobResultsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Work with Solutions
ImportJob Entity Messages and Methods


RetrieveFormattedImportJobResultsRequest Constructor
[image]

Initializes a new instance of the RetrieveFormattedImportJobResultsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveFormattedImportJobResultsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormattedImportJobResultsRequest Class
RetrieveFormattedImportJobResultsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormattedImportJobResultsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveFormattedImportJobResultsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Work with Solutions
ImportJob Entity Messages and Methods


RetrieveFormattedImportJobResultsRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportJobId | Gets or sets the GUID of an import job. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveFormattedImportJobResultsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Work with Solutions
ImportJob Entity Messages and Methods


RetrieveFormattedImportJobResultsRequest.ImportJobId Property
[image]

Gets or sets the GUID of an import job. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportJobId As Guid

C#
public Guid ImportJobId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The GUID of an import job. This corresponds to the ImportJob.ImportJobId attribute, which is the primary key for the ImportJob entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormattedImportJobResultsRequest Class
RetrieveFormattedImportJobResultsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
ImportJob Entity Messages and Methods


RetrieveFormattedImportJobResultsResponse Class
See Also Members
[image]

Contains the response from the RetrieveFormattedImportJobResultsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveFormattedImportJobResultsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveFormattedImportJobResultsResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveFormattedImportJobResultsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormattedImportJobResultsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormattedImportJobResultsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveFormattedImportJobResultsRequest class.

The following tables list the members exposed by the RetrieveFormattedImportJobResultsResponse type.

Public Constructors

Name | Description
RetrieveFormattedImportJobResultsResponse | Initializes a new instance of the RetrieveFormattedImportJobResultsResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | FormattedResults | Gets the formatted results of the import job.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveFormattedImportJobResultsResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormattedImportJobResultsResponse Constructor
[image]

Initializes a new instance of the RetrieveFormattedImportJobResultsResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveFormattedImportJobResultsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormattedImportJobResultsResponse Class
RetrieveFormattedImportJobResultsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormattedImportJobResultsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveFormattedImportJobResultsResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormattedImportJobResultsResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | FormattedResults | Gets the formatted results of the import job.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveFormattedImportJobResultsResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormattedImportJobResultsResponse.FormattedResults Property
[image]

Gets the formatted results of the import job.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property FormattedResults As String

C#
public string FormattedResults { get; }

C++

J#

JScript

Property Value
Type: String
The formatted results of the import job.

  Remarks
The results are returned in Microsoft Excel format.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormattedImportJobResultsResponse Class
RetrieveFormattedImportJobResultsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormXmlRequest Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveFormXmlRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveFormXmlRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Use the SystemForm entity to retrieve FormXml for entities.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveFormXmlRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
SystemForm (System Dashboard) Entity Messages and Methods


RetrieveFormXmlRequest Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the RetrieveFormXmlRequest type.

Public Constructors

Name | Description
RetrieveFormXmlRequest | Initializes a new instance of the RetrieveFormXmlRequest class.
Top

Public Properties

 | Name | Description
public property | EntityName | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveFormXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

SystemForm (System Dashboard) Entity Messages and Methods


RetrieveFormXmlRequest Constructor
[image]

Initializes a new instance of the RetrieveFormXmlRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveFormXmlRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormXmlRequest Class
RetrieveFormXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormXmlRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveFormXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

SystemForm (System Dashboard) Entity Messages and Methods


RetrieveFormXmlRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityName | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveFormXmlRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

SystemForm (System Dashboard) Entity Messages and Methods


RetrieveFormXmlRequest.EntityName Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormXmlRequest Class
RetrieveFormXmlRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormXmlResponse Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveFormXmlResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveFormXmlResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        For internal use only.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveFormXmlResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveFormXmlRequest


RetrieveFormXmlResponse Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the RetrieveFormXmlResponse type.

Public Constructors

Name | Description
RetrieveFormXmlResponse | Initializes a new instance of the RetrieveFormXmlResponse class.
Top

Public Properties

 | Name | Description
public property | ComponentState | For internal use only.
public property | CustomizationLevel | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | FormXml | For internal use only.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SolutionId | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveFormXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveFormXmlRequest


RetrieveFormXmlResponse Constructor
[image]

Initializes a new instance of the RetrieveFormXmlResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveFormXmlResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormXmlResponse Class
RetrieveFormXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormXmlResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveFormXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveFormXmlRequest


RetrieveFormXmlResponse Properties
[image]

Public Properties

 | Name | Description
public property | ComponentState | For internal use only.
public property | CustomizationLevel | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | FormXml | For internal use only.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SolutionId | For internal use only.

See Also

Reference

RetrieveFormXmlResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveFormXmlRequest


RetrieveFormXmlResponse.ComponentState Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ComponentState As Integer

C#
public int ComponentState { get; }

C++

J#

JScript

Property Value
Type: Int32
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormXmlResponse Class
RetrieveFormXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormXmlResponse.CustomizationLevel Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CustomizationLevel As Integer

C#
public int CustomizationLevel { get; }

C++

J#

JScript

Property Value
Type: Int32
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormXmlResponse Class
RetrieveFormXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormXmlResponse.FormXml Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property FormXml As String

C#
public string FormXml { get; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormXmlResponse Class
RetrieveFormXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveFormXmlResponse.SolutionId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property SolutionId As Guid

C#
public Guid SolutionId { get; }

C++

J#

JScript

Property Value
Type: Guid
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveFormXmlResponse Class
RetrieveFormXmlResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveInstalledLanguagePacksRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the list of language packs that are installed on the server.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveInstalledLanguagePacksRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveInstalledLanguagePacksRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  the RetrieveInstalledLanguagePacksResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in RetrieveInstalledLanguagePacks Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveInstalledLanguagePacksRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePacksRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages


RetrieveInstalledLanguagePacksRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the list of language packs that are installed on the server.

The following tables list the members exposed by the RetrieveInstalledLanguagePacksRequest type.

Public Constructors

Name | Description
RetrieveInstalledLanguagePacksRequest | Initializes a new instance of theRetrieveInstalledLanguagePacksRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveInstalledLanguagePacksRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveInstalledLanguagePacksRequest Constructor
[image]

Initializes a new instance of the RetrieveInstalledLanguagePacksRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveInstalledLanguagePacksRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePacksRequest Class
RetrieveInstalledLanguagePacksRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveInstalledLanguagePacksRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveInstalledLanguagePacksRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveInstalledLanguagePacksRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveInstalledLanguagePacksRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveInstalledLanguagePacksResponse Class
See Also Members
[image]

Contains the response from the RetrieveInstalledLanguagePacksRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveInstalledLanguagePacksResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveInstalledLanguagePacksResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveInstalledLanguagePacksResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePacksResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveInstalledLanguagePacksRequest


RetrieveInstalledLanguagePacksResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveInstalledLanguagePacksRequest class.

The following tables list the members exposed by the RetrieveInstalledLanguagePacksResponse type.

Public Constructors

Name | Description
RetrieveInstalledLanguagePacksResponse | Initializes a new instance of the RetrieveInstalledLanguagePacksResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RetrieveInstalledLanguagePacks | Gets an array of locale ID values that represent the installed language packs.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveInstalledLanguagePacksResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveInstalledLanguagePacksRequest


RetrieveInstalledLanguagePacksResponse Constructor
[image]

Initializes a new instance of the RetrieveInstalledLanguagePacksResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveInstalledLanguagePacksResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePacksResponse Class
RetrieveInstalledLanguagePacksResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveInstalledLanguagePacksResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveInstalledLanguagePacksResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveInstalledLanguagePacksRequest


RetrieveInstalledLanguagePacksResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RetrieveInstalledLanguagePacks | Gets an array of locale ID values that represent the installed language packs.

See Also

Reference

RetrieveInstalledLanguagePacksResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveInstalledLanguagePacksRequest


RetrieveInstalledLanguagePacksResponse.RetrieveInstalledLanguagePacks Property
[image]

Gets an array of locale ID values that represent the installed language packs.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property RetrieveInstalledLanguagePacks As Integer()

C#
public int[] RetrieveInstalledLanguagePacks { get; }

C++

J#

JScript

Property Value
Type: Int32[]
An array of locale ID values that represent the installed language packs.

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePacksResponse Class
RetrieveInstalledLanguagePacksResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveInstalledLanguagePackVersionRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the version of an installed language pack.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveInstalledLanguagePackVersionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveInstalledLanguagePackVersionRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  the RetrieveInstalledLanguagePackVersionResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in RetrieveInstalledLanguagePackVersion Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveInstalledLanguagePackVersionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePackVersionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages


RetrieveInstalledLanguagePackVersionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the version of an installed language pack.

The following tables list the members exposed by the RetrieveInstalledLanguagePackVersionRequest type.

Public Constructors

Name | Description
RetrieveInstalledLanguagePackVersionRequest | Initializes a new instance of the RetrieveInstalledLanguagePackVersionRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Language | Gets or sets the value that represents the locale ID for the language pack. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveInstalledLanguagePackVersionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveInstalledLanguagePackVersionRequest Constructor
[image]

Initializes a new instance of the RetrieveInstalledLanguagePackVersionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveInstalledLanguagePackVersionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePackVersionRequest Class
RetrieveInstalledLanguagePackVersionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveInstalledLanguagePackVersionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveInstalledLanguagePackVersionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveInstalledLanguagePackVersionRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Language | Gets or sets the value that represents the locale ID for the language pack. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveInstalledLanguagePackVersionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveInstalledLanguagePackVersionRequest.Language Property
[image]

Gets or sets the value that represents the locale ID for the language pack. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Language As Integer

C#
public int Language { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The value that represents the locale ID for the language pack. Required.

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePackVersionRequest Class
RetrieveInstalledLanguagePackVersionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveInstalledLanguagePackVersionResponse Class
See Also Members
[image]

Contains the response from the RetrieveInstalledLanguagePackVersionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveInstalledLanguagePackVersionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveInstalledLanguagePackVersionResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveInstalledLanguagePackVersionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePackVersionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveInstalledLanguagePackVersionRequest


RetrieveInstalledLanguagePackVersionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveInstalledLanguagePackVersionRequest class.

The following tables list the members exposed by the RetrieveInstalledLanguagePackVersionResponse type.

Public Constructors

Name | Description
RetrieveInstalledLanguagePackVersionResponse | Initializes a new instance of the RetrieveInstalledLanguagePackVersionResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Version | Gets the version number of the installed language pack.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveInstalledLanguagePackVersionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveInstalledLanguagePackVersionRequest


RetrieveInstalledLanguagePackVersionResponse Constructor
[image]

Initializes a new instance of the RetrieveInstalledLanguagePackVersionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveInstalledLanguagePackVersionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePackVersionResponse Class
RetrieveInstalledLanguagePackVersionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveInstalledLanguagePackVersionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveInstalledLanguagePackVersionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveInstalledLanguagePackVersionRequest


RetrieveInstalledLanguagePackVersionResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Version | Gets the version number of the installed language pack.

See Also

Reference

RetrieveInstalledLanguagePackVersionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveInstalledLanguagePackVersionRequest


RetrieveInstalledLanguagePackVersionResponse.Version Property
[image]

Gets the version number of the installed language pack.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Version As String

C#
public string Version { get; }

C++

J#

JScript

Property Value
Type: String
The version number of the installed language pack.

  Remarks
The version information is in the format major.minor.build.revision, for example: 5.x.xxxx.x.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveInstalledLanguagePackVersionResponse Class
RetrieveInstalledLanguagePackVersionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLicenseInfoRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the number of used and available licenses for a deployment of Microsoft Dynamics CRM.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveLicenseInfoRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveLicenseInfoRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of the RetrieveLicenseInfoResponse class.
Privileges and Access Rights
For a complete list of the required privileges, see RetrieveLicenseInfo Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveLicenseInfoRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLicenseInfoRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLicenseInfoResponse
Other Resources
Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveLicenseInfoRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the number of used and available licenses for a deployment of Microsoft Dynamics CRM.

The following tables list the members exposed by the RetrieveLicenseInfoRequest type.

Public Constructors

Name | Description
RetrieveLicenseInfoRequest | Initializes a new instance of the RetrieveLicenseInfoRequest class.
Top

Public Properties

 | Name | Description
public property | AccessMode | Gets or sets the access mode for retrieving the license information.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveLicenseInfoRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLicenseInfoResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveLicenseInfoRequest Constructor
[image]

Initializes a new instance of the RetrieveLicenseInfoRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveLicenseInfoRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLicenseInfoRequest Class
RetrieveLicenseInfoRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLicenseInfoRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveLicenseInfoRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLicenseInfoResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveLicenseInfoRequest Properties
[image]

Public Properties

 | Name | Description
public property | AccessMode | Gets or sets the access mode for retrieving the license information.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveLicenseInfoRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLicenseInfoResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveLicenseInfoRequest.AccessMode Property
[image]

Gets or sets the access mode for retrieving the license information.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AccessMode As Integer

C#
public int AccessMode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The access mode for retrieving the license information. Use one of the option set values for SystemUser.AccessMode. For a list of these values, the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLicenseInfoRequest Class
RetrieveLicenseInfoRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLicenseInfoResponse Class
See Also Members
[image]

Contains the response from the RetrieveLicenseInfoRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveLicenseInfoResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveLicenseInfoResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveLicenseInfoResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLicenseInfoResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLicenseInfoRequest


RetrieveLicenseInfoResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveLicenseInfoRequest class.

The following tables list the members exposed by the RetrieveLicenseInfoResponse type.

Public Constructors

Name | Description
RetrieveLicenseInfoResponse | Initializes a new instance of the RetrieveLicenseInfoResponse class.
Top

Public Properties

 | Name | Description
public property | AvailableCount | Gets the number of unused licenses.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | GrantedLicenseCount | Gets the number of licenses that have been granted to users.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveLicenseInfoResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLicenseInfoRequest


RetrieveLicenseInfoResponse Constructor
[image]

Initializes a new instance of the RetrieveLicenseInfoResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveLicenseInfoResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLicenseInfoResponse Class
RetrieveLicenseInfoResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLicenseInfoResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveLicenseInfoResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLicenseInfoRequest


RetrieveLicenseInfoResponse Properties
[image]

Public Properties

 | Name | Description
public property | AvailableCount | Gets the number of unused licenses.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | GrantedLicenseCount | Gets the number of licenses that have been granted to users.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveLicenseInfoResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLicenseInfoRequest


RetrieveLicenseInfoResponse.AvailableCount Property
[image]

Gets the number of unused licenses.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AvailableCount As Integer

C#
public int AvailableCount { get; }

C++

J#

JScript

Property Value
Type: Int32
The number of unused licenses.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLicenseInfoResponse Class
RetrieveLicenseInfoResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLicenseInfoResponse.GrantedLicenseCount Property
[image]

Gets the number of licenses that have been granted to users.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property GrantedLicenseCount As Integer

C#
public int GrantedLicenseCount { get; }

C++

J#

JScript

Property Value
Type: Int32
The number of licenses that have been granted to users.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLicenseInfoResponse Class
RetrieveLicenseInfoResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLocLabelsRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve localized labels for a limited set of entity attributes.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveLocLabelsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveLocLabelsRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the RetrieveLocLabelsResponse class.
Privileges and Access Rights
To perform this action, the caller must have the required privileges, as listed in RetrieveLocLabels Privileges.
Notes for Callers
This message only retrieves the localized display names for specific entity attributes or localizable properties. It can’t retrieve localized labels that are used for other application user interface areas, such as the labels that are used in the ribbon or form elements.
Supported Entities
This message only supports the following entity attributes or localized property values
  • DynamicProperty.Name
  • DynamicPropertyOptionSetItem.DynamicPropertyOptionName
  • DynamicPropertyOptionSetItem.DynamicPropertyOptionDescription
  • Product.Name
  • SavedQuery.Description
  • SavedQuery.Name
  • SavedQueryVisualization.Description
  • SavedQueryVisualization.Name
  • SystemForm.Description
  • SystemForm.Name
  • TimeZoneDefinition.UserInterfaceName
  • TimeZoneDefinition.StandardName
  • TimeZoneLocalizedName.UserInterfaceName

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveLocLabelsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages
Localize product property values


RetrieveLocLabelsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve localized labels for a limited set of entity attributes.

The following tables list the members exposed by the RetrieveLocLabelsRequest type.

Public Constructors

Name | Description
RetrieveLocLabelsRequest | Initializes a new instance of the RetrieveLocLabelsRequest class.
Top

Public Properties

 | Name | Description
public property | AttributeName | Gets or sets the name of the attribute for which to retrieve the localized labels. Required.
public property | EntityMoniker | Gets or sets the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncludeUnpublished | Gets or sets whether to include unpublished labels. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveLocLabelsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Localize product property values


RetrieveLocLabelsRequest Constructor
[image]

Initializes a new instance of the RetrieveLocLabelsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveLocLabelsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLocLabelsRequest Class
RetrieveLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLocLabelsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveLocLabelsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Localize product property values


RetrieveLocLabelsRequest Properties
[image]

Public Properties

 | Name | Description
public property | AttributeName | Gets or sets the name of the attribute for which to retrieve the localized labels. Required.
public property | EntityMoniker | Gets or sets the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncludeUnpublished | Gets or sets whether to include unpublished labels. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveLocLabelsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Localize product property values


RetrieveLocLabelsRequest.AttributeName Property
[image]

Gets or sets the name of the attribute for which to retrieve the localized labels. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeName As String

C#
public string AttributeName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the attribute for which to retrieve the localized labels. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLocLabelsRequest Class
RetrieveLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLocLabelsRequest.EntityMoniker Property
[image]

Gets or sets the entity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityMoniker As EntityReference

C#
public EntityReference EntityMoniker { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The entity. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLocLabelsRequest Class
RetrieveLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLocLabelsRequest.IncludeUnpublished Property
[image]

Gets or sets whether to include unpublished labels. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IncludeUnpublished As Boolean

C#
public bool IncludeUnpublished { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if unpublished labels should be included; otherwise, false.

  Remarks
This property doesn’t apply when retrieving localized labels for localizable property values. More information:Localize product property values.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLocLabelsRequest Class
RetrieveLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLocLabelsResponse Class
See Also Members
[image]

Contains the response from the RetrieveLocLabelsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveLocLabelsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveLocLabelsResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveLocLabelsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLocLabelsResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLocLabelsRequest


RetrieveLocLabelsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveLocLabelsRequest class.

The following tables list the members exposed by the RetrieveLocLabelsResponse type.

Public Constructors

Name | Description
RetrieveLocLabelsResponse | Initializes a new instance of the RetrieveLocLabelsResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Label | Gets the label for the requested entity attribute.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveLocLabelsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLocLabelsRequest


RetrieveLocLabelsResponse Constructor
[image]

Initializes a new instance of the RetrieveLocLabelsResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveLocLabelsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLocLabelsResponse Class
RetrieveLocLabelsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveLocLabelsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveLocLabelsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLocLabelsRequest


RetrieveLocLabelsResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | Label | Gets the label for the requested entity attribute.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveLocLabelsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveLocLabelsRequest


RetrieveLocLabelsResponse.Label Property
[image]

Gets the label for the requested entity attribute.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Label As Label

C#
public Label Label { get; }

C++

J#

JScript

Property Value
Type: Label
The label for the requested entity attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveLocLabelsResponse Class
RetrieveLocLabelsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersBulkOperationRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the members of a bulk operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveMembersBulkOperationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveMembersBulkOperationRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of the RetrieveMembersBulkOperationResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the BulkOperation entity and access rights on the record that is contained in the BulkOperationId property. The caller must also have access rights on the records that are returned from the query. For a complete list of the required privileges, see RetrieveMembersBulkOperation Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveMembersBulkOperationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersBulkOperationResponse
Other Resources
RetrieveMembersBulkOperation Privileges
BulkOperation (Quick Campaign) Entity Messages and Methods
Sample: Distribute Campaign Activities to Qualified Marketing List
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveMembersBulkOperationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the members of a bulk operation.

The following tables list the members exposed by the RetrieveMembersBulkOperationRequest type.

Public Constructors

Name | Description
RetrieveMembersBulkOperationRequest | Initializes a new instance of the RetrieveMembersBulkOperationRequest class.
Top

Public Properties

 | Name | Description
public property | BulkOperationId | Gets or sets the ID of the bulk operation. Required.
public property | BulkOperationSource | Gets or sets the source for a bulk operation. Required.
public property | EntitySource | Gets or sets which members of a bulk operation to retrieve. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the retrieve operation that can be used to break up large data sets into pages. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMembersBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersBulkOperationResponse

Other Resources

RetrieveMembersBulkOperation Privileges
BulkOperation (Quick Campaign) Entity Messages and Methods
Sample: Distribute Campaign Activities to Qualified Marketing List
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveMembersBulkOperationRequest Constructor
[image]

Initializes a new instance of the RetrieveMembersBulkOperationRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMembersBulkOperationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersBulkOperationRequest Class
RetrieveMembersBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersBulkOperationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMembersBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersBulkOperationResponse

Other Resources

RetrieveMembersBulkOperation Privileges
BulkOperation (Quick Campaign) Entity Messages and Methods
Sample: Distribute Campaign Activities to Qualified Marketing List
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveMembersBulkOperationRequest Properties
[image]

Public Properties

 | Name | Description
public property | BulkOperationId | Gets or sets the ID of the bulk operation. Required.
public property | BulkOperationSource | Gets or sets the source for a bulk operation. Required.
public property | EntitySource | Gets or sets which members of a bulk operation to retrieve. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the retrieve operation that can be used to break up large data sets into pages. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveMembersBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersBulkOperationResponse

Other Resources

RetrieveMembersBulkOperation Privileges
BulkOperation (Quick Campaign) Entity Messages and Methods
Sample: Distribute Campaign Activities to Qualified Marketing List
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveMembersBulkOperationRequest.BulkOperationId Property
[image]

Gets or sets the ID of the bulk operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the bulk operation. This corresponds to the BulkOperation.BulkOperationId attribute, which is the primary key for the BulkOperation entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersBulkOperationRequest Class
RetrieveMembersBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersBulkOperationRequest.BulkOperationSource Property
[image]

Gets or sets the source for a bulk operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationSource As Integer

C#
public int BulkOperationSource { get; set; }

C++

J#

JScript

Property Value
Type:Int32
The source for a bulk operation.
 The return value for this property is a BulkOperationSource enumeration type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersBulkOperationRequest Class
RetrieveMembersBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersBulkOperationRequest.EntitySource Property
[image]

Gets or sets which members of a bulk operation to retrieve. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntitySource As Integer

C#
public int EntitySource { get; set; }

C++

J#

JScript

Property Value
Type: Int32
Describes which members of a bulk operation to retrieve. The return value for this property is an EntitySource type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersBulkOperationRequest Class
RetrieveMembersBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersBulkOperationRequest.Query Property
[image]

Gets or sets the query for the retrieve operation that can be used to break up large data sets into pages. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query for the retrieve operation that can be used to break up large data sets into pages.

  Remarks
Assign an instance of the QueryExpression,  QueryByAttribute, or FetchExpression class. The query must specify the entity name “bulkoperation” and a column set. If the column set includes attributes where IsValidForRead is false or for which you do not have access, they are ignored and the message response contains no data for those attributes. You can find this information in the metadata for your organization. See the preceding metadata browser information.
This optional property is recommended for use if you are likely to return a large number of results and want to avoid a time-out. Use the PageInfo property or PageInfo property to retrieve subsequent pages of data. For more information, see Page Large Result Sets with Query Expression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersBulkOperationRequest Class
RetrieveMembersBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Build Queries with QueryExpression


RetrieveMembersBulkOperationResponse Class
See Also Members
[image]

Contains the response from the RetrieveMembersBulkOperationRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveMembersBulkOperationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveMembersBulkOperationResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveMembersBulkOperationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersBulkOperationRequest


RetrieveMembersBulkOperationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveMembersBulkOperationRequest class.

The following tables list the members exposed by the RetrieveMembersBulkOperationResponse type.

Public Constructors

Name | Description
RetrieveMembersBulkOperationResponse | Initializes a new instance of the RetrieveMembersBulkOperationResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of members of a bulk operation.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMembersBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersBulkOperationRequest


RetrieveMembersBulkOperationResponse Constructor
[image]

Initializes a new instance of the RetrieveMembersBulkOperationResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMembersBulkOperationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersBulkOperationResponse Class
RetrieveMembersBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersBulkOperationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMembersBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersBulkOperationRequest


RetrieveMembersBulkOperationResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of members of a bulk operation.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveMembersBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersBulkOperationRequest


RetrieveMembersBulkOperationResponse.EntityCollection Property
[image]

Gets the collection of members of a bulk operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of members of a bulk operation.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersBulkOperationResponse Class
RetrieveMembersBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersTeamRequest Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveMembersTeamRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveMembersTeamRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveMembersTeamRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersTeamResponse
Other Resources
RetrieveMembersTeam Privileges


RetrieveMembersTeamRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class.

The following tables list the members exposed by the RetrieveMembersTeamRequest type.

Public Constructors

Name | Description
RetrieveMembersTeamRequest | Deprecated.
Top

Public Properties

 | Name | Description
public property | EntityId | Deprecated.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MemberColumnSet | Deprecated.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMembersTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersTeamResponse

Other Resources

RetrieveMembersTeam Privileges


RetrieveMembersTeamRequest Constructor
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMembersTeamRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersTeamRequest Class
RetrieveMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersTeamRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMembersTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersTeamResponse

Other Resources

RetrieveMembersTeam Privileges


RetrieveMembersTeamRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityId | Deprecated.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MemberColumnSet | Deprecated.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveMembersTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersTeamResponse

Other Resources

RetrieveMembersTeam Privileges


RetrieveMembersTeamRequest.EntityId Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersTeamRequest Class
RetrieveMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersTeamRequest.MemberColumnSet Property
[image]

Deprecated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MemberColumnSet As ColumnSet

C#
public ColumnSet MemberColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersTeamRequest Class
RetrieveMembersTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersTeamResponse Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class. Contains the response from the RetrieveMembersTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveMembersTeamResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveMembersTeamResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveMembersTeamResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersTeamRequest


RetrieveMembersTeamResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class. Contains the response from the RetrieveMembersTeamRequest class.

The following tables list the members exposed by the RetrieveMembersTeamResponse type.

Public Constructors

Name | Description
RetrieveMembersTeamResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMembersTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersTeamRequest


RetrieveMembersTeamResponse Constructor
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMembersTeamResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersTeamResponse Class
RetrieveMembersTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMembersTeamResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMembersTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersTeamRequest


RetrieveMembersTeamResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveMembersTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMembersTeamRequest


RetrieveMembersTeamResponse.EntityCollection Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMembersTeamResponse Class
RetrieveMembersTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMissingComponentsRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve a list of missing components in the target organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveMissingComponentsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveMissingComponentsRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  the RetrieveMissingComponentsResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in RetrieveMissingComponents Privileges.
Notes for Callers
The solution file contains a list of required components. This message uses the list in the file to query the target organization and returns any components that are not in the target organization in the RetrieveMissingComponentsResponse property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveMissingComponentsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Dependency Tracking for Solution Components


RetrieveMissingComponentsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a list of missing components in the target organization.

The following tables list the members exposed by the RetrieveMissingComponentsRequest type.

Public Constructors

Name | Description
RetrieveMissingComponentsRequest | Initializes a new instance of the RetrieveMissingComponentsRequest class.
Top

Public Properties

 | Name | Description
public property | CustomizationFile | Gets or sets a file for a solution. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMissingComponentsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components


RetrieveMissingComponentsRequest Constructor
[image]

Initializes a new instance of the RetrieveMissingComponentsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMissingComponentsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingComponentsRequest Class
RetrieveMissingComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMissingComponentsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMissingComponentsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components


RetrieveMissingComponentsRequest Properties
[image]

Public Properties

 | Name | Description
public property | CustomizationFile | Gets or sets a file for a solution. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveMissingComponentsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components


RetrieveMissingComponentsRequest.CustomizationFile Property
[image]

Gets or sets a file for a solution. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CustomizationFile As Byte()

C#
public byte[] CustomizationFile { get; set; }

C++

J#

JScript

Property Value
Type: Byte[]
A file for a solution

  Remarks
Use File.ReadAllBytes Method to convert the file from disk into a byte array.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingComponentsRequest Class
RetrieveMissingComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMissingComponentsResponse Class
See Also Members
[image]

Contains the response from the RetrieveMissingComponentsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveMissingComponentsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveMissingComponentsResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveMissingComponentsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingComponentsResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingComponentsRequest


RetrieveMissingComponentsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveMissingComponentsRequest class.

The following tables list the members exposed by the RetrieveMissingComponentsResponse type.

Public Constructors

Name | Description
RetrieveMissingComponentsResponse | Initializes a new instance of the RetrieveMissingComponentsResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | MissingComponents | Gets an array of MissingComponent records.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMissingComponentsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingComponentsRequest


RetrieveMissingComponentsResponse Constructor
[image]

Initializes a new instance of the RetrieveMissingComponentsResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMissingComponentsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingComponentsResponse Class
RetrieveMissingComponentsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMissingComponentsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMissingComponentsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingComponentsRequest


RetrieveMissingComponentsResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | MissingComponents | Gets an array of MissingComponent records.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveMissingComponentsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingComponentsRequest


RetrieveMissingComponentsResponse.MissingComponents Property
[image]

Gets an array of MissingComponent records.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property MissingComponents As MissingComponent()

C#
public MissingComponent[] MissingComponents { get; }

C++

J#

JScript

Property Value
Type: MissingComponent[]
An array of MissingComponent records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingComponentsResponse Class
RetrieveMissingComponentsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMissingDependenciesRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve any required solution components that are not included in the solution.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveMissingDependenciesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveMissingDependenciesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveMissingDependenciesResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveMissingDependencies Privileges.
Notes for Callers
Use this message before exporting a solution to determine which solution components not currently included in the solution must exist in the target organization in order to successfully import this solution.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveMissingDependenciesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingDependenciesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Dependency Tracking for Solution Components


RetrieveMissingDependenciesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve any required solution components that are not included in the solution.

The following tables list the members exposed by the RetrieveMissingDependenciesRequest type.

Public Constructors

Name | Description
RetrieveMissingDependenciesRequest | Initializes a new instance of theRetrieveMissingDependenciesRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the solution. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMissingDependenciesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components


RetrieveMissingDependenciesRequest Constructor
[image]

Initializes a new instance of the RetrieveMissingDependenciesRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMissingDependenciesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingDependenciesRequest Class
RetrieveMissingDependenciesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMissingDependenciesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMissingDependenciesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components


RetrieveMissingDependenciesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the solution. Required.

See Also

Reference

RetrieveMissingDependenciesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components


RetrieveMissingDependenciesRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the solution. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the solution. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingDependenciesRequest Class
RetrieveMissingDependenciesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMissingDependenciesResponse Class
See Also Members
[image]

Contains the response from the RetrieveMissingDependenciesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveMissingDependenciesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveMissingDependenciesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveMissingDependenciesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingDependenciesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingDependenciesRequest


RetrieveMissingDependenciesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveMissingDependenciesRequest class.

The following tables list the members exposed by the RetrieveMissingDependenciesResponse type.

Public Constructors

Name | Description
RetrieveMissingDependenciesResponse | Initializes a new instance of the RetrieveMissingDependenciesResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets an entity collection that represents the solution components that the solution requires in the target system.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMissingDependenciesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingDependenciesRequest


RetrieveMissingDependenciesResponse Constructor
[image]

Initializes a new instance of the RetrieveMissingDependenciesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMissingDependenciesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingDependenciesResponse Class
RetrieveMissingDependenciesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveMissingDependenciesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMissingDependenciesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingDependenciesRequest


RetrieveMissingDependenciesResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets an entity collection that represents the solution components that the solution requires in the target system.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveMissingDependenciesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMissingDependenciesRequest


RetrieveMissingDependenciesResponse.EntityCollection Property
[image]

Gets an entity collection that represents the solution components that the solution requires in the target system.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
An entity collection that represents the solution components that the solution requires in the target system.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMissingDependenciesResponse Class
RetrieveMissingDependenciesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveOrganizationResourcesRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the resources that are used by an organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveOrganizationResourcesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveOrganizationResourcesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveOrganizationResourcesResponse class.
Privileges and Access Rights
For a complete list of the required privileges, see RetrieveOrganizationResources Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveOrganizationResourcesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationResourcesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesResponse
Other Resources
Organization Entity Messages and Methods


RetrieveOrganizationResourcesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the resources that are used by an organization.

The following tables list the members exposed by the RetrieveOrganizationResourcesRequest type.

Public Constructors

Name | Description
RetrieveOrganizationResourcesRequest | Initializes a new instance of the RetrieveOrganizationResourcesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveOrganizationResourcesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesResponse

Other Resources

Organization Entity Messages and Methods


RetrieveOrganizationResourcesRequest Constructor
[image]

Initializes a new instance of the RetrieveOrganizationResourcesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveOrganizationResourcesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationResourcesRequest Class
RetrieveOrganizationResourcesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveOrganizationResourcesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveOrganizationResourcesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesResponse

Other Resources

Organization Entity Messages and Methods


RetrieveOrganizationResourcesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveOrganizationResourcesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesResponse

Other Resources

Organization Entity Messages and Methods


RetrieveOrganizationResourcesResponse Class
See Also Members
[image]

Contains the response from the RetrieveOrganizationResourcesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveOrganizationResourcesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveOrganizationResourcesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveOrganizationResourcesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationResourcesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesRequest


RetrieveOrganizationResourcesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveOrganizationResourcesRequest class.

The following tables list the members exposed by the RetrieveOrganizationResourcesResponse type.

Public Constructors

Name | Description
RetrieveOrganizationResourcesResponse | Initializes a new instance of the RetrieveOrganizationResourcesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OrganizationResources | Gets the data that describes the resources used by an organization.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveOrganizationResourcesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesRequest


RetrieveOrganizationResourcesResponse Constructor
[image]

Initializes a new instance of the RetrieveOrganizationResourcesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveOrganizationResourcesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationResourcesResponse Class
RetrieveOrganizationResourcesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveOrganizationResourcesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveOrganizationResourcesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesRequest


RetrieveOrganizationResourcesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OrganizationResources | Gets the data that describes the resources used by an organization.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveOrganizationResourcesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveOrganizationResourcesRequest


RetrieveOrganizationResourcesResponse.OrganizationResources Property
[image]

Gets the data that describes the resources used by an organization.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property OrganizationResources As OrganizationResources

C#
public OrganizationResources OrganizationResources { get; }

C++

J#

JScript

Property Value
Type: OrganizationResources
The data that describes the resources used by an organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationResourcesResponse Class
RetrieveOrganizationResourcesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveParentGroupsResourceGroupRequest Class
See Also Members
[image]

Contains the data needed to retrieve the collection of the parent resource groups of the specified resource group (scheduling group).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveParentGroupsResourceGroupRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveParentGroupsResourceGroupRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  RetrieveParentGroupsResourceGroupResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Resource entity and access rights on the record specified in the ResourceGroupId property. For a complete list of the privileges required, see RetrieveParentGroupsResourceGroup Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveParentGroupsResourceGroupRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParentGroupsResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParentGroupsResourceGroupResponse
Other Resources
Resource Entities
ResourceGroup (Scheduling  Group) Entity Messages and Methods


RetrieveParentGroupsResourceGroupRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to retrieve the collection of the parent resource groups of the specified resource group (scheduling group).

The following tables list the members exposed by the RetrieveParentGroupsResourceGroupRequest type.

Public Constructors

Name | Description
RetrieveParentGroupsResourceGroupRequest | Initializes a new instance of the RetrieveParentGroupsResourceGroupRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceGroupId | Gets or sets the ID of the resource group.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveParentGroupsResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParentGroupsResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


RetrieveParentGroupsResourceGroupRequest Constructor
[image]

Initializes a new instance of the RetrieveParentGroupsResourceGroupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveParentGroupsResourceGroupRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParentGroupsResourceGroupRequest Class
RetrieveParentGroupsResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveParentGroupsResourceGroupRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveParentGroupsResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParentGroupsResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


RetrieveParentGroupsResourceGroupRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceGroupId | Gets or sets the ID of the resource group.

See Also

Reference

RetrieveParentGroupsResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParentGroupsResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


RetrieveParentGroupsResourceGroupRequest.Query Property
[image]

Gets or sets the query for the operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query for the operation.

  Remarks
The query must specify the entity name "resourcegroup" and a columnset. If the column set includes attributes that are not valid for retrieve, they will be ignored.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParentGroupsResourceGroupRequest Class
RetrieveParentGroupsResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveParentGroupsResourceGroupRequest.ResourceGroupId Property
[image]

Gets or sets the ID of the resource group.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ResourceGroupId As Guid

C#
public Guid ResourceGroupId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the resource group. This corresponds to the ResourceGroup.ResourceGroupId property, which is the primary key for the ResourceGroup entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParentGroupsResourceGroupRequest Class
RetrieveParentGroupsResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveParentGroupsResourceGroupResponse Class
See Also Members
[image]

Contains the response from the RetrieveParentGroupsResourceGroupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveParentGroupsResourceGroupResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveParentGroupsResourceGroupResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveParentGroupsResourceGroupResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParentGroupsResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParentGroupsResourceGroupRequest


RetrieveParentGroupsResourceGroupResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveParentGroupsResourceGroupRequest class.

The following tables list the members exposed by the RetrieveParentGroupsResourceGroupResponse type.

Public Constructors

Name | Description
RetrieveParentGroupsResourceGroupResponse | Initializes a new instance of the RetrieveParentGroupsResourceGroupResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of parent resource groups for the specified resource group (scheduling group).
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveParentGroupsResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParentGroupsResourceGroupRequest


RetrieveParentGroupsResourceGroupResponse Constructor
[image]

Initializes a new instance of the RetrieveParentGroupsResourceGroupResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveParentGroupsResourceGroupResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParentGroupsResourceGroupResponse Class
RetrieveParentGroupsResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveParentGroupsResourceGroupResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveParentGroupsResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParentGroupsResourceGroupRequest


RetrieveParentGroupsResourceGroupResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of parent resource groups for the specified resource group (scheduling group).
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveParentGroupsResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParentGroupsResourceGroupRequest


RetrieveParentGroupsResourceGroupResponse.EntityCollection Property
[image]

Gets the resulting collection of parent resource groups for the specified resource group (scheduling group).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The resulting collection of parent resource groups for the specified resource group (scheduling group).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParentGroupsResourceGroupResponse Class
RetrieveParentGroupsResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace
EntityCollection


RetrieveParsedDataImportFileRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the data from the parse table.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveParsedDataImportFileRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveParsedDataImportFileRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Retrieve data from the parse table.
// NOTE: You must create the parse table first using the ParseImport message.
// The parse table is not accessible after ImportRecordsImportResponse is called.
RetrieveParsedDataImportFileRequest parsedDataRequest = new RetrieveParsedDataImportFileRequest()
{
    ImportFileId = importFileId,
    PagingInfo = new PagingInfo()
    {
        // Specify the number of entity instances returned per page.
        Count = 2,
        // Specify the number of pages returned from the query.
        PageNumber = 1,
        // Specify a total number of entity instances returned.
        PagingCookie = "1"
    }
};

RetrieveParsedDataImportFileResponse parsedDataResponse =
    (RetrieveParsedDataImportFileResponse)_serviceProxy.Execute(parsedDataRequest);

// Output the first two rows retrieved.
int rowCount = 1;
foreach (string[] rows in parsedDataResponse.Values)
{
    int colCount = 1;
    foreach (string column in rows)
    {
        Console.WriteLine("(" + rowCount.ToString() + "," + colCount.ToString() + ") = " + column);
        colCount++;
    }
    rowCount++;
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of RetrieveParsedDataImportFileResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the ImportFile entity and access rights on the record specified in the ImportFileId property. For a complete list of the required privileges, see RetrieveParsedDataImportFile Privileges.
Notes for Callers
The parsed data is returned in a two-dimensional array of strings in the Values property of the message response. The data is returned with the same column order as the column order in the source file.
Use this message only after you have created a parse table by using the ParseImportRequest message.
Do not use this message after you use the ImportRecordsImportRequest message. You cannot access the parse table after the import job submitted by the ImportRecordsMessage message has finished running.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveParsedDataImportFileRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveParsedDataImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParsedDataImportFileResponse
Other Resources
Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Sample: Import Data Using Complex Data Map
RetrieveParsedDataImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveParsedDataImportFileRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the data from the parse table.

The following tables list the members exposed by the RetrieveParsedDataImportFileRequest type.

Public Constructors

Name | Description
RetrieveParsedDataImportFileRequest | Initializes a new instance of the RetrieveParsedDataImportFileRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportFileId | Gets or sets the ID of the import file that is associated with the parse table. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PagingInfo | Gets or sets the paging information for the retrieved data. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveParsedDataImportFileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParsedDataImportFileResponse

Other Resources

Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Sample: Import Data Using Complex Data Map
RetrieveParsedDataImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveParsedDataImportFileRequest Constructor
[image]

Initializes a new instance of the RetrieveParsedDataImportFileRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveParsedDataImportFileRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParsedDataImportFileRequest Class
RetrieveParsedDataImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveParsedDataImportFileRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveParsedDataImportFileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParsedDataImportFileResponse

Other Resources

Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Sample: Import Data Using Complex Data Map
RetrieveParsedDataImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveParsedDataImportFileRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportFileId | Gets or sets the ID of the import file that is associated with the parse table. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PagingInfo | Gets or sets the paging information for the retrieved data. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveParsedDataImportFileRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParsedDataImportFileResponse

Other Resources

Import Data in Microsoft Dynamics CRM
ImportFile Entity Messages and Methods
Sample: Import Data Using Complex Data Map
RetrieveParsedDataImportFile Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveParsedDataImportFileRequest.ImportFileId Property
[image]

Gets or sets the ID of the import file that is associated with the parse table. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportFileId As Guid

C#
public Guid ImportFileId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the import file that is associated with the parse table. This property corresponds to the ImportFile.ImportFileId attribute, which is the primary key for the ImportFile entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParsedDataImportFileRequest Class
RetrieveParsedDataImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveParsedDataImportFileRequest.PagingInfo Property
[image]

Gets or sets the paging information for the retrieved data. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PagingInfo As PagingInfo

C#
public PagingInfo PagingInfo { get; set; }

C++

J#

JScript

Property Value
Type: PagingInfo
The paging information for the retrieved data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParsedDataImportFileRequest Class
RetrieveParsedDataImportFileRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveParsedDataImportFileResponse Class
See Also Members
[image]

Contains the response from the RetrieveParsedDataImportFileRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveParsedDataImportFileResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveParsedDataImportFileResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveParsedDataImportFileResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParsedDataImportFileResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParsedDataImportFileRequest


RetrieveParsedDataImportFileResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveParsedDataImportFileRequest class.

The following tables list the members exposed by the RetrieveParsedDataImportFileResponse type.

Public Constructors

Name | Description
RetrieveParsedDataImportFileResponse | Initializes a new instance of the RetrieveParsedDataImportFileResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Values | Gets the parsed data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveParsedDataImportFileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParsedDataImportFileRequest


RetrieveParsedDataImportFileResponse Constructor
[image]

Initializes a new instance of the RetrieveParsedDataImportFileResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveParsedDataImportFileResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParsedDataImportFileResponse Class
RetrieveParsedDataImportFileResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveParsedDataImportFileResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveParsedDataImportFileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParsedDataImportFileRequest


RetrieveParsedDataImportFileResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Values | Gets the parsed data.

See Also

Reference

RetrieveParsedDataImportFileResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveParsedDataImportFileRequest


RetrieveParsedDataImportFileResponse.Values Property
[image]

Gets the parsed data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Values As String()()

C#
public string[][] Values { get; }

C++

J#

JScript

Property Value
Type: String
The parsed data. The returned data has the same column order as the column order in the source file.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveParsedDataImportFileResponse Class
RetrieveParsedDataImportFileResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve pages of posts, including comments for each post, for all records that the calling user is following.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePersonalWallRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePersonalWallRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
private void DisplayPersonalWallPage(int pageNumber)
{
    // Retrieve the page of posts.  We'll only retrieve 5 at a time so that
    // we will have more than one page.
    var pageSize = 5;

    var personalWallPageReq = new RetrievePersonalWallRequest
    {
        CommentsPerPost = 2,
        PageNumber = pageNumber,
        PageSize = pageSize
    };
    var personalWallPageRes =
        (RetrievePersonalWallResponse)_serviceProxy.Execute(personalWallPageReq);

    Console.WriteLine("\r\n  Personal Wall Page {0} Posts:", pageNumber);
    foreach (Post post in personalWallPageRes.EntityCollection.Entities)
    {
        DisplayPost(post);
    }
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of  the RetrievePersonalWallResponse class.
Privileges and Access Rights
For a complete list of the required privileges, see RetrievePersonalWallRequest Privileges.
Notes for Callers
The posts that are retrieved for your personal wall include the following: the posts that are regarding the records that you follow; the posts that mention records that you follow; and the posts that are regarding you or that mention you. If a post is regarding a record, the Post.RegardingObjectId attribute contains the record ID. If a post mentions a record, the record ID is specified within the Post.Text attribute.
  Note

                        You can only follow records that you have Read permissions for. If you lose Read permissions on a record, a follow is automatically removed.

  Note

                        All Microsoft Dynamics CRM users automatically follow themselves.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrievePersonalWallRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrievePersonalWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePersonalWallResponse
Other Resources
RetrievePersonalWallRequest Privileges
Activity Feeds Entities
Sample: Collaborate with Activity Feeds
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrievePersonalWallRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve pages of posts, including comments for each post, for all records that the calling user is following.

The following tables list the members exposed by the RetrievePersonalWallRequest type.

Public Constructors

Name | Description
RetrievePersonalWallRequest | Initializes a new instance of the RetrievePersonalWallRequest class.
Top

Public Properties

 | Name | Description
public property | CommentsPerPost | Gets or sets, for retrieval, the number of comments per post. Required.
public property | EndDate | Gets or sets the end date and time of the posts that you want to retrieve. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PageNumber | Gets or sets, for retrieval, a specific page of posts that is designated by its page number. Required.
public property | PageSize | Gets or sets, for retrieval, the number of posts per page. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Source | Gets or sets a value that specifies the source of the post. Optional.
public property | StartDate | Gets or sets the start date and time of the posts that you want to retrieve. Optional.
public property | Type | Reserved for future use.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePersonalWallRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePersonalWallResponse

Other Resources

RetrievePersonalWallRequest Privileges
Activity Feeds Entities
Sample: Collaborate with Activity Feeds
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrievePersonalWallRequest Constructor
[image]

Initializes a new instance of the RetrievePersonalWallRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePersonalWallRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallRequest Class
RetrievePersonalWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePersonalWallRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePersonalWallResponse

Other Resources

RetrievePersonalWallRequest Privileges
Activity Feeds Entities
Sample: Collaborate with Activity Feeds
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrievePersonalWallRequest Properties
[image]

Public Properties

 | Name | Description
public property | CommentsPerPost | Gets or sets, for retrieval, the number of comments per post. Required.
public property | EndDate | Gets or sets the end date and time of the posts that you want to retrieve. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PageNumber | Gets or sets, for retrieval, a specific page of posts that is designated by its page number. Required.
public property | PageSize | Gets or sets, for retrieval, the number of posts per page. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Source | Gets or sets a value that specifies the source of the post. Optional.
public property | StartDate | Gets or sets the start date and time of the posts that you want to retrieve. Optional.
public property | Type | Reserved for future use.

See Also

Reference

RetrievePersonalWallRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePersonalWallResponse

Other Resources

RetrievePersonalWallRequest Privileges
Activity Feeds Entities
Sample: Collaborate with Activity Feeds
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrievePersonalWallRequest.CommentsPerPost Property
[image]

Gets or sets, for retrieval, the number of comments per post. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CommentsPerPost As Integer

C#
public int CommentsPerPost { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of comments per post to retrieve. The maximum number of retrieved comments, per post, is 50; the minimum number is 0.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallRequest Class
RetrievePersonalWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallRequest.EndDate Property
[image]

Gets or sets the end date and time of the posts that you want to retrieve. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EndDate As DateTime

C#
public DateTime EndDate { get; set; }

C++

J#

JScript

Property Value
Type:  DateTime
The end date and time of the posts that you want to retrieve. If specified, the posts that were created on or before the specified end date and time are retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallRequest Class
RetrievePersonalWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallRequest.PageNumber Property
[image]

Gets or sets, for retrieval, a specific page of posts that is designated by its page number. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PageNumber As Integer

C#
public int PageNumber { get; set; }

C++

J#

JScript

Property Value
Type:  Int32
The specific page of posts that is designated by its page number. The page number for the first page is 1. If you specify a value of 0, it is treated as a value of 1.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallRequest Class
RetrievePersonalWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallRequest.PageSize Property
[image]

Gets or sets, for retrieval, the number of posts per page. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PageSize As Integer

C#
public int PageSize { get; set; }

C++

J#

JScript

Property Value
Type:  Int32
The number of posts per page. The maximum number of retrieved posts, per page, is 100; the minimum number is 1.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallRequest Class
RetrievePersonalWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallRequest.Source Property
[image]

Gets or sets a value that specifies the source of the post. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Source As OptionSetValue

C#
public OptionSetValue Source { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The value that specifies the source of the post.

  Remarks
Use this property to filter the posts by their source type, such as an auto post or a manual post (user post).
The following table contains the valid values for this property.
Value | Description
1 | Auto post
2 | Manual post

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallRequest Class
RetrievePersonalWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallRequest.StartDate Property
[image]

Gets or sets the start date and time of the posts that you want to retrieve. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property StartDate As DateTime

C#
public DateTime StartDate { get; set; }

C++

J#

JScript

Property Value
Type:  DateTime
The start date and time of the posts that you want to retrieve. If specified, only the posts that were created on or after the specified date and time are retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallRequest Class
RetrievePersonalWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallRequest.Type Property
[image]

Reserved for future use.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Type As OptionSetValue

C#
public OptionSetValue Type { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallRequest Class
RetrievePersonalWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallResponse Class
See Also Members
[image]

Contains the response from the RetrievePersonalWallRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePersonalWallResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePersonalWallResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrievePersonalWallResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePersonalWallRequest


RetrievePersonalWallResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrievePersonalWallRequest class.

The following tables list the members exposed by the RetrievePersonalWallResponse type.

Public Constructors

Name | Description
RetrievePersonalWallResponse | Initializes a new instance of the RetrievePersonalWallResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of posts with their associated comments and the calculated attribute values.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePersonalWallResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePersonalWallRequest


RetrievePersonalWallResponse Constructor
[image]

Initializes a new instance of the RetrievePersonalWallResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePersonalWallResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallResponse Class
RetrievePersonalWallResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePersonalWallResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePersonalWallResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePersonalWallRequest


RetrievePersonalWallResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of posts with their associated comments and the calculated attribute values.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrievePersonalWallResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePersonalWallRequest


RetrievePersonalWallResponse.EntityCollection Property
[image]

Gets the collection of posts with their associated comments and the calculated attribute values.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of posts with their associated comments and the calculated attribute values.

  Remarks
The associated comments are returned in the RelatedEntityCollection for each post. This property returns the following calculated attributes: CommentCount (Integer), Followed (Boolean), and DeleteEnabled (Boolean) on each post; and DeleteEnabled (Boolean) on each post comment. This property also returns the MoreRecords (Boolean), which indicates whether there are more pages of posts to retrieve.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePersonalWallResponse Class
RetrievePersonalWallResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalAccessRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the access rights of the specified security principal (team or user) to the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePrincipalAccessRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePrincipalAccessRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
var principalAccessReq = new RetrievePrincipalAccessRequest
{
    Principal = principal,
    Target = leadReference
};
var principalAccessRes = (RetrievePrincipalAccessResponse)
    _serviceProxy.Execute(principalAccessReq);
Console.WriteLine("Access rights of {0} ({1}) on the lead: {2}\r\n",
    GetEntityReferenceString(principal),
    additionalIdentifier,
    principalAccessRes.AccessRights);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline. However, a few entities of this message class are exceptions to that availability. To determine which entities have a more restricted availability, see Supported Entities later in this topic.
Usage
 Pass an instance of this class to the Execute method, which returns an instance of the RetrievePrincipalAccessResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified by the Target property and access rights on the specified record in the Target property. For a complete list of the required privileges, see RetrievePrincipalAccess Privileges.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
Annotation | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
BulkOperation | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
Connection | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ConvertRule | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
DuplicateRule | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
Fax | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
Import | 2 (Both)
ImportFile | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
Invoice | 2 (Both)
Lead | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OrderClose | 2 (Both)
PhoneCall | 2 (Both)
ProcessSession | 2 (Both)
Queue | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
Report | 2 (Both)
RoutingRule | 2 (Both)
SalesOrder | 2 (Both)
ServiceAppointment | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
SLA | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialProfile | 2 (Both)
Task | 2 (Both)
Template | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
Workflow | 2 (Both)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrievePrincipalAccessRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrievePrincipalAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAccessResponse
Other Resources
How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Entity Ownership
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RetrievePrincipalAccessRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the access rights of the specified security principal (team or user) to the specified record.

The following tables list the members exposed by the RetrievePrincipalAccessRequest type.

Public Constructors

Name | Description
RetrievePrincipalAccessRequest | Initializes a new instance of the RetrievePrincipalAccessRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Principal | Gets or sets the security principal (team or user) for which to return the access rights to the specified record.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for which to retrieve access rights.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePrincipalAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Entity Ownership
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RetrievePrincipalAccessRequest Constructor
[image]

Initializes a new instance of the RetrievePrincipalAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePrincipalAccessRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAccessRequest Class
RetrievePrincipalAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalAccessRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePrincipalAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Entity Ownership
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RetrievePrincipalAccessRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Principal | Gets or sets the security principal (team or user) for which to return the access rights to the specified record.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for which to retrieve access rights.

See Also

Reference

RetrievePrincipalAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Entity Ownership
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RetrievePrincipalAccessRequest.Principal Property
[image]

Gets or sets the security principal (team or user) for which to return the access rights to the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Principal As EntityReference

C#
public EntityReference Principal { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The security principal (team or user) for which to return the access rights to the specified record. The entity reference must be a SystemUser or Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAccessRequest Class
RetrievePrincipalAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalAccessRequest.Target Property
[image]

Gets or sets the target record for which to retrieve access rights.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target record for which to retrieve access rights. This must be an entity reference for an entity that supports this message. For a list of supported entity types, see RetrievePrincipalAccessRequest.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAccessRequest Class
RetrievePrincipalAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalAccessResponse Class
See Also Members
[image]

Contains the response from the RetrievePrincipalAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePrincipalAccessResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePrincipalAccessResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrievePrincipalAccessResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAccessRequest


RetrievePrincipalAccessResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrievePrincipalAccessRequest class.

The following tables list the members exposed by the RetrievePrincipalAccessResponse type.

Public Constructors

Name | Description
RetrievePrincipalAccessResponse | Initializes a new instance of the RetrievePrincipalAccessResponse class.
Top

Public Properties

 | Name | Description
public property | AccessRights | Gets the access rights that the security principal (team or user) has to the specified record.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePrincipalAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAccessRequest


RetrievePrincipalAccessResponse Constructor
[image]

Initializes a new instance of the RetrievePrincipalAccessResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePrincipalAccessResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAccessResponse Class
RetrievePrincipalAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalAccessResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePrincipalAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAccessRequest


RetrievePrincipalAccessResponse Properties
[image]

Public Properties

 | Name | Description
public property | AccessRights | Gets the access rights that the security principal (team or user) has to the specified record.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrievePrincipalAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAccessRequest


RetrievePrincipalAccessResponse.AccessRights Property
[image]

Gets the access rights that the security principal (team or user) has to the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AccessRights As AccessRights

C#
public AccessRights AccessRights { get; }

C++

J#

JScript

Property Value
Type: AccessRights
The access rights that the security principal (team or user) has to the specified record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAccessResponse Class
RetrievePrincipalAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalAttributePrivilegesRequest Class
See Also Members
[image]

Contains the data that is needed to retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePrincipalAttributePrivilegesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePrincipalAttributePrivilegesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of RetrievePrincipalAttributePrivilegesResponse.
Privileges and Access Rights
To perform this action, the caller must have access rights on the record specified in the Principal property. For a complete list of the privileges required, see RetrievePrincipalAttributePrivileges Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrievePrincipalAttributePrivilegesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAttributePrivilegesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAttributePrivilegesResponse
Other Resources
How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM
Field Security Entities
FieldSecurityProfile Entity Messages and Methods


RetrievePrincipalAttributePrivilegesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity.

The following tables list the members exposed by the RetrievePrincipalAttributePrivilegesRequest type.

Public Constructors

Name | Description
RetrievePrincipalAttributePrivilegesRequest | Initializes a new instance of the RetrievePrincipalAttributePrivilegesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Principal | Gets or sets the security principal (user or team) for which to retrieve attribute privileges. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePrincipalAttributePrivilegesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAttributePrivilegesResponse

Other Resources

How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM
Field Security Entities
FieldSecurityProfile Entity Messages and Methods


RetrievePrincipalAttributePrivilegesRequest Constructor
[image]

Initializes a new instance of the RetrievePrincipalAttributePrivilegesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePrincipalAttributePrivilegesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAttributePrivilegesRequest Class
RetrievePrincipalAttributePrivilegesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalAttributePrivilegesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePrincipalAttributePrivilegesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAttributePrivilegesResponse

Other Resources

How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM
Field Security Entities
FieldSecurityProfile Entity Messages and Methods


RetrievePrincipalAttributePrivilegesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Principal | Gets or sets the security principal (user or team) for which to retrieve attribute privileges. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrievePrincipalAttributePrivilegesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAttributePrivilegesResponse

Other Resources

How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM
Field Security Entities
FieldSecurityProfile Entity Messages and Methods


RetrievePrincipalAttributePrivilegesRequest.Principal Property
[image]

Gets or sets the security principal (user or team) for which to retrieve attribute privileges. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Principal As EntityReference

C#
public EntityReference Principal { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The security principal (user or team) for which to retrieve attribute privileges. This must be a reference to a SystemUser or Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAttributePrivilegesRequest Class
RetrievePrincipalAttributePrivilegesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalAttributePrivilegesResponse Class
See Also Members
[image]

Contains the response from the RetrievePrincipalAttributePrivilegesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePrincipalAttributePrivilegesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePrincipalAttributePrivilegesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrievePrincipalAttributePrivilegesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAttributePrivilegesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAttributePrivilegesRequest


RetrievePrincipalAttributePrivilegesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrievePrincipalAttributePrivilegesRequest class.

The following tables list the members exposed by the RetrievePrincipalAttributePrivilegesResponse type.

Public Constructors

Name | Description
RetrievePrincipalAttributePrivilegesResponse | Initializes a new instance of the RetrievePrincipalAttributePrivilegesResponse class.
Top

Public Properties

 | Name | Description
public property | AttributePrivileges | Gets the collection of attribute privileges for the security principal (user or team).
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePrincipalAttributePrivilegesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAttributePrivilegesRequest


RetrievePrincipalAttributePrivilegesResponse Constructor
[image]

Initializes a new instance of the RetrievePrincipalAttributePrivilegesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePrincipalAttributePrivilegesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAttributePrivilegesResponse Class
RetrievePrincipalAttributePrivilegesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalAttributePrivilegesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePrincipalAttributePrivilegesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAttributePrivilegesRequest


RetrievePrincipalAttributePrivilegesResponse Properties
[image]

Public Properties

 | Name | Description
public property | AttributePrivileges | Gets the collection of attribute privileges for the security principal (user or team).
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrievePrincipalAttributePrivilegesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalAttributePrivilegesRequest


RetrievePrincipalAttributePrivilegesResponse.AttributePrivileges Property
[image]

Gets the collection of attribute privileges for the security principal (user or team).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AttributePrivileges As AttributePrivilegeCollection

C#
public AttributePrivilegeCollection AttributePrivileges { get; }

C++

J#

JScript

Property Value
Type: AttributePrivilegeCollection
The collection of attribute privileges for the security principal (user or team).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalAttributePrivilegesResponse Class
RetrievePrincipalAttributePrivilegesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalSyncAttributeMappingsRequest Class
See Also Members
[image]

This message doesn’t have any extensibility scenarios in this release.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePrincipalSyncAttributeMappingsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePrincipalSyncAttributeMappingsRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrievePrincipalSyncAttributeMappingsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalSyncAttributeMappingsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalSyncAttributeMappingsResponse


RetrievePrincipalSyncAttributeMappingsRequest Members
See Also Constructors Methods Properties
[image]

This message doesn’t have any extensibility scenarios in this release.

The following tables list the members exposed by the RetrievePrincipalSyncAttributeMappingsRequest type.

Public Constructors

Name | Description
RetrievePrincipalSyncAttributeMappingsRequest |
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Principal |
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePrincipalSyncAttributeMappingsRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalSyncAttributeMappingsResponse


RetrievePrincipalSyncAttributeMappingsRequest Constructor
[image]

Initializes a new instance of the RetrievePrincipalSyncAttributeMappingsRequest Class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePrincipalSyncAttributeMappingsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalSyncAttributeMappingsRequest Class
RetrievePrincipalSyncAttributeMappingsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalSyncAttributeMappingsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePrincipalSyncAttributeMappingsRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalSyncAttributeMappingsResponse


RetrievePrincipalSyncAttributeMappingsRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Principal |
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrievePrincipalSyncAttributeMappingsRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalSyncAttributeMappingsResponse


RetrievePrincipalSyncAttributeMappingsRequest.Principal Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic

C#

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalSyncAttributeMappingsRequest Class
RetrievePrincipalSyncAttributeMappingsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalSyncAttributeMappingsResponse Class
See Also Members
[image]

This message doesn’t have any extensibility scenarios in this release.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePrincipalSyncAttributeMappingsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePrincipalSyncAttributeMappingsResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrievePrincipalSyncAttributeMappingsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalSyncAttributeMappingsResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalSyncAttributeMappingsRequest


RetrievePrincipalSyncAttributeMappingsResponse Members
See Also Constructors Methods Properties
[image]

This message doesn’t have any extensibility scenarios in this release.

The following tables list the members exposed by the RetrievePrincipalSyncAttributeMappingsResponse type.

Public Constructors

Name | Description
RetrievePrincipalSyncAttributeMappingsResponse |
Top

Public Properties

 | Name | Description
public property | AttributeMappings |
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePrincipalSyncAttributeMappingsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalSyncAttributeMappingsRequest


RetrievePrincipalSyncAttributeMappingsResponse Constructor
[image]

Initializes a new instance of the RetrievePrincipalSyncAttributeMappingsResponse Class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePrincipalSyncAttributeMappingsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalSyncAttributeMappingsResponse Class
RetrievePrincipalSyncAttributeMappingsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrincipalSyncAttributeMappingsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePrincipalSyncAttributeMappingsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalSyncAttributeMappingsRequest


RetrievePrincipalSyncAttributeMappingsResponse Properties
[image]

Public Properties

 | Name | Description
public property | AttributeMappings |
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrievePrincipalSyncAttributeMappingsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrincipalSyncAttributeMappingsRequest


RetrievePrincipalSyncAttributeMappingsResponse.AttributeMappings Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AttributeMappings As AttributeMappingCollection

C#
public AttributeMappingCollection AttributeMappings { get; }

C++

J#

JScript

Property Value
Returns AttributeMappingCollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrincipalSyncAttributeMappingsResponse Class
RetrievePrincipalSyncAttributeMappingsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrivilegeSetRequest Class
See Also Members
[image]

Contains the data needed to retrieve the set of privileges defined in the system.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePrivilegeSetRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePrivilegeSetRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  RetrievePrivilegeSetResponse.
Privileges and Access Rights
For a complete list of the privileges required, see RetrievePrincipalAttributePrivileges Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrievePrivilegeSetRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrivilegeSetRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrivilegeSetResponse
Other Resources
How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Privilege Entity Messages and Methods


RetrievePrivilegeSetRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to retrieve the set of privileges defined in the system.

The following tables list the members exposed by the RetrievePrivilegeSetRequest type.

Public Constructors

Name | Description
RetrievePrivilegeSetRequest | Initializes a new instance of the RetrievePrivilegeSetRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePrivilegeSetRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrivilegeSetResponse

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Privilege Entity Messages and Methods


RetrievePrivilegeSetRequest Constructor
[image]

Initializes a new instance of the RetrievePrivilegeSetRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePrivilegeSetRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrivilegeSetRequest Class
RetrievePrivilegeSetRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrivilegeSetRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePrivilegeSetRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrivilegeSetResponse

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Privilege Entity Messages and Methods


RetrievePrivilegeSetRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrievePrivilegeSetRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrivilegeSetResponse

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Privilege Entity Messages and Methods


RetrievePrivilegeSetResponse Class
See Also Members
[image]

Contains the response from the RetrievePrivilegeSetRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrievePrivilegeSetResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrievePrivilegeSetResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrievePrivilegeSetResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrivilegeSetResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrivilegeSetRequest


RetrievePrivilegeSetResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrievePrivilegeSetRequest class.

The following tables list the members exposed by the RetrievePrivilegeSetResponse type.

Public Constructors

Name | Description
RetrievePrivilegeSetResponse | Initializes a new instance of the RetrievePrivilegeSetResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of privileges.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrievePrivilegeSetResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrivilegeSetRequest


RetrievePrivilegeSetResponse Constructor
[image]

Initializes a new instance of the RetrievePrivilegeSetResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrievePrivilegeSetResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrivilegeSetResponse Class
RetrievePrivilegeSetResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrievePrivilegeSetResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrievePrivilegeSetResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrivilegeSetRequest


RetrievePrivilegeSetResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of privileges.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrievePrivilegeSetResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrievePrivilegeSetRequest


RetrievePrivilegeSetResponse.EntityCollection Property
[image]

Gets the resulting collection of privileges.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The resulting collection of privileges.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrievePrivilegeSetResponse Class
RetrievePrivilegeSetResponse Members
Microsoft.Crm.Sdk.Messages Namespace
EntityCollection


RetrieveProductPropertiesRequest Class
See Also Members
[image]

Contains data that is needed to retrieve all the property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveProductPropertiesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveProductPropertiesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of RetrieveProductPropertiesResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Product, Opportunity, Quote, SalesOrder, and Invoice entities and access rights on the record specified in the ParentObject property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveProductPropertiesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProductPropertiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProductPropertiesResponse
Other Resources
DynamicPropertyInstance (property instance) methods and messages


RetrieveProductPropertiesRequest Members
See Also Constructors Methods Properties
[image]

Contains data that is needed to retrieve all the property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.

The following tables list the members exposed by the RetrieveProductPropertiesRequest type.

Public Constructors

Name | Description
RetrieveProductPropertiesRequest | Initializes a new instance of the RetrieveProductPropertiesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentObject | Gets or sets the product record for which you want to retrieve all the property instances (dynamic property instances).
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveProductPropertiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProductPropertiesResponse

Other Resources

DynamicPropertyInstance (property instance) methods and messages


RetrieveProductPropertiesRequest Constructor
[image]

Initializes a new instance of the RetrieveProductPropertiesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveProductPropertiesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProductPropertiesRequest Class
RetrieveProductPropertiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProductPropertiesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveProductPropertiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProductPropertiesResponse

Other Resources

DynamicPropertyInstance (property instance) methods and messages


RetrieveProductPropertiesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentObject | Gets or sets the product record for which you want to retrieve all the property instances (dynamic property instances).
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveProductPropertiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProductPropertiesResponse

Other Resources

DynamicPropertyInstance (property instance) methods and messages


RetrieveProductPropertiesRequest.ParentObject Property
[image]

Gets or sets the product record for which you want to retrieve all the property instances (dynamic property instances).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ParentObject As EntityReference

C#
public EntityReference ParentObject { get; set; }

C++

J#

JScript

Property Value
Type EntityReference
Product record for which you want to retrieve all the property instances (dynamic property instances).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProductPropertiesRequest Class
RetrieveProductPropertiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProductPropertiesResponse Class
See Also Members
[image]

Contains the response from the RetrieveProductPropertiesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveProductPropertiesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveProductPropertiesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveProductPropertiesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProductPropertiesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProductPropertiesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveProductPropertiesRequest class.

The following tables list the members exposed by the RetrieveProductPropertiesResponse type.

Public Constructors

Name | Description
RetrieveProductPropertiesResponse | Initializes a new instance of the RetrieveProductPropertiesResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the property instances (dynamic property instances) for a product associated to an opportunity, quote, order, and invoice.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveProductPropertiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProductPropertiesResponse Constructor
[image]

Initializes a new instance of the RetrieveProductPropertiesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveProductPropertiesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProductPropertiesResponse Class
RetrieveProductPropertiesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProductPropertiesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveProductPropertiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProductPropertiesResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the property instances (dynamic property instances) for a product associated to an opportunity, quote, order, and invoice.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveProductPropertiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProductPropertiesResponse.EntityCollection Property
[image]

Gets the property instances (dynamic property instances) for a product associated to an opportunity, quote, order, and invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type EntityCollection
Property instances (dynamic property instances) for a product associated to an opportunity, quote, order, and invoice.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProductPropertiesResponse Class
RetrieveProductPropertiesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProvisionedLanguagePackVersionRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the version of a provisioned language pack.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveProvisionedLanguagePackVersionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveProvisionedLanguagePackVersionRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveProvisionedLanguagePackVersionResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveProvisionedLanguagePackVersion Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveProvisionedLanguagePackVersionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagePackVersionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages


RetrieveProvisionedLanguagePackVersionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the version of a provisioned language pack.

The following tables list the members exposed by the RetrieveProvisionedLanguagePackVersionRequest type.

Public Constructors

Name | Description
RetrieveProvisionedLanguagePackVersionRequest | Initializes a new instance of the RetrieveProvisionedLanguagePackVersionRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Language | Gets or sets the Locale Id for the language. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveProvisionedLanguagePackVersionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveProvisionedLanguagePackVersionRequest Constructor
[image]

Initializes a new instance of the RetrieveProvisionedLanguagePackVersionRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveProvisionedLanguagePackVersionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagePackVersionRequest Class
RetrieveProvisionedLanguagePackVersionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProvisionedLanguagePackVersionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveProvisionedLanguagePackVersionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveProvisionedLanguagePackVersionRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Language | Gets or sets the Locale Id for the language. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveProvisionedLanguagePackVersionRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveProvisionedLanguagePackVersionRequest.Language Property
[image]

Gets or sets the Locale Id for the language. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Language As Integer

C#
public int Language { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The Locale Id for the language. Required.

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagePackVersionRequest Class
RetrieveProvisionedLanguagePackVersionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProvisionedLanguagePackVersionResponse Class
See Also Members
[image]

Contains the response from the RetrieveProvisionedLanguagePackVersionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveProvisionedLanguagePackVersionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveProvisionedLanguagePackVersionResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveProvisionedLanguagePackVersionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagePackVersionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProvisionedLanguagePackVersionRequest


RetrieveProvisionedLanguagePackVersionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveProvisionedLanguagePackVersionRequest class.

The following tables list the members exposed by the RetrieveProvisionedLanguagePackVersionResponse type.

Public Constructors

Name | Description
RetrieveProvisionedLanguagePackVersionResponse | Initializes a new instance of the RetrieveProvisionedLanguagePackVersionResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Version | Gets the version number of the installed language pack.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveProvisionedLanguagePackVersionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProvisionedLanguagePackVersionRequest


RetrieveProvisionedLanguagePackVersionResponse Constructor
[image]

Initializes a new instance of the RetrieveProvisionedLanguagePackVersionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveProvisionedLanguagePackVersionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagePackVersionResponse Class
RetrieveProvisionedLanguagePackVersionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProvisionedLanguagePackVersionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveProvisionedLanguagePackVersionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProvisionedLanguagePackVersionRequest


RetrieveProvisionedLanguagePackVersionResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Version | Gets the version number of the installed language pack.

See Also

Reference

RetrieveProvisionedLanguagePackVersionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProvisionedLanguagePackVersionRequest


RetrieveProvisionedLanguagePackVersionResponse.Version Property
[image]

Gets the version number of the installed language pack.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Version As String

C#
public string Version { get; }

C++

J#

JScript

Property Value
Type: String
The version number of the installed language pack.

  Remarks
The version information is in the format major.minor.build.revision, for example: 5.x.xxxx.x.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagePackVersionResponse Class
RetrieveProvisionedLanguagePackVersionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProvisionedLanguagesRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the list of provisioned languages.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveProvisionedLanguagesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveProvisionedLanguagesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveProvisionedLanguagesResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveProvisionedLanguages Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveProvisionedLanguagesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages


RetrieveProvisionedLanguagesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the list of provisioned languages.

The following tables list the members exposed by the RetrieveProvisionedLanguagesRequest type.

Public Constructors

Name | Description
RetrieveProvisionedLanguagesRequest | Initializes a new instance of the RetrieveProvisionedLanguagesRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveProvisionedLanguagesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveProvisionedLanguagesRequest Constructor
[image]

Initializes a new instance of the RetrieveProvisionedLanguagesRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveProvisionedLanguagesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagesRequest Class
RetrieveProvisionedLanguagesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProvisionedLanguagesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveProvisionedLanguagesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveProvisionedLanguagesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveProvisionedLanguagesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages


RetrieveProvisionedLanguagesResponse Class
See Also Members
[image]

Contains the response from the RetrieveProvisionedLanguagesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveProvisionedLanguagesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveProvisionedLanguagesResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveProvisionedLanguagesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProvisionedLanguagesRequest


RetrieveProvisionedLanguagesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveProvisionedLanguagesRequest class.

The following tables list the members exposed by the RetrieveProvisionedLanguagesResponse type.

Public Constructors

Name | Description
RetrieveProvisionedLanguagesResponse | Initializes a new instance of the RetrieveProvisionedLanguagesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RetrieveProvisionedLanguages | Gets an array of locale ID values that represent the provisioned languages.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveProvisionedLanguagesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProvisionedLanguagesRequest


RetrieveProvisionedLanguagesResponse Constructor
[image]

Initializes a new instance of the RetrieveProvisionedLanguagesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveProvisionedLanguagesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagesResponse Class
RetrieveProvisionedLanguagesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveProvisionedLanguagesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveProvisionedLanguagesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProvisionedLanguagesRequest


RetrieveProvisionedLanguagesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RetrieveProvisionedLanguages | Gets an array of locale ID values that represent the provisioned languages.

See Also

Reference

RetrieveProvisionedLanguagesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveProvisionedLanguagesRequest


RetrieveProvisionedLanguagesResponse.RetrieveProvisionedLanguages Property
[image]

Gets an array of locale ID values that represent the provisioned languages.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property RetrieveProvisionedLanguages As Integer()

C#
public int[] RetrieveProvisionedLanguages { get; }

C++

J#

JScript

Property Value
Type: Int32[]
An array of locale ID values that represent the provisioned languages..

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveProvisionedLanguagesResponse Class
RetrieveProvisionedLanguagesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordChangeHistoryRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve all attribute data changes for a specific entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveRecordChangeHistoryRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveRecordChangeHistoryRequest : OrganizationRequest

C++

J#

JScript

  Example
C#    Copy Code
// Retrieve the audit history for the account and display it.
RetrieveRecordChangeHistoryRequest changeRequest = new RetrieveRecordChangeHistoryRequest();
changeRequest.Target = new EntityReference(Account.EntityLogicalName, _newAccountId);

RetrieveRecordChangeHistoryResponse changeResponse =
    (RetrieveRecordChangeHistoryResponse)_service.Execute(changeRequest);

AuditDetailCollection details = changeResponse.AuditDetailCollection;

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the RetrieveRecordChangeHistoryResponse class.
Privileges and Access Rights
For a list of the required privileges, see RetrieveRecordChanges Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveRecordChangeHistoryRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveRecordChangeHistoryRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveRecordChangeHistoryRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve all attribute data changes for a specific entity.

The following tables list the members exposed by the RetrieveRecordChangeHistoryRequest type.

Public Constructors

Name | Description
RetrieveRecordChangeHistoryRequest | Initializes a new instance of the RetrieveRecordChangeHistoryRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PagingInfo | Gets or sets the paging information for the retrieved data. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target audit record. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRecordChangeHistoryRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveRecordChangeHistoryRequest Constructor
[image]

Initializes a new instance of the RetrieveRecordChangeHistoryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRecordChangeHistoryRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordChangeHistoryRequest Class
RetrieveRecordChangeHistoryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordChangeHistoryRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRecordChangeHistoryRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveRecordChangeHistoryRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PagingInfo | Gets or sets the paging information for the retrieved data. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target audit record. Required.

See Also

Reference

RetrieveRecordChangeHistoryRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Retrieve and Delete the History of Audited Data Changes
Sample: Audit Entity Data Changes


RetrieveRecordChangeHistoryRequest.PagingInfo Property
[image]

Gets or sets the paging information for the retrieved data. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PagingInfo As PagingInfo

C#
public PagingInfo PagingInfo { get; set; }

C++

J#

JScript

Property Value
Type: PagingInfo
The paging information for the retrieved data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordChangeHistoryRequest Class
RetrieveRecordChangeHistoryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordChangeHistoryRequest.Target Property
[image]

Gets or sets the target audit record. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference.

  Remarks
This value must be an entity reference for an Audit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordChangeHistoryRequest Class
RetrieveRecordChangeHistoryRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Audit Entity Messages and Methods
Page Large Result Sets with FetchXML
Page Large Result Sets with Query Expression


RetrieveRecordChangeHistoryResponse Class
See Also Members
[image]

Contains the response from the RetrieveRecordChangeHistoryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveRecordChangeHistoryResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveRecordChangeHistoryResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveRecordChangeHistoryResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordChangeHistoryResponse Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Sample: Audit Entity Data Changes


RetrieveRecordChangeHistoryResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveRecordChangeHistoryRequest class.

The following tables list the members exposed by the RetrieveRecordChangeHistoryResponse type.

Public Constructors

Name | Description
RetrieveRecordChangeHistoryResponse | Initializes a new instance of the RetrieveRecordChangeHistoryResponse class.
Top

Public Properties

 | Name | Description
public property | AuditDetailCollection | Contains the history of data changes for the target entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRecordChangeHistoryResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Audit Entity Data Changes


RetrieveRecordChangeHistoryResponse Constructor
[image]

Initializes a new instance of the RetrieveRecordChangeHistoryResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRecordChangeHistoryResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordChangeHistoryResponse Class
RetrieveRecordChangeHistoryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordChangeHistoryResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRecordChangeHistoryResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Audit Entity Data Changes


RetrieveRecordChangeHistoryResponse Properties
[image]

Public Properties

 | Name | Description
public property | AuditDetailCollection | Contains the history of data changes for the target entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveRecordChangeHistoryResponse Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Sample: Audit Entity Data Changes


RetrieveRecordChangeHistoryResponse.AuditDetailCollection Property
[image]

Contains the history of data changes for the target entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AuditDetailCollection As AuditDetailCollection

C#
public AuditDetailCollection AuditDetailCollection { get; }

C++

J#

JScript

Property Value
Type: AuditDetailCollection
The history of data changes for the target entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordChangeHistoryResponse Class
RetrieveRecordChangeHistoryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve pages of posts, including comments for each post, for a specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveRecordWallRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveRecordWallRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
private void DisplayRecordWall(Lead lead)
{
    // Display the first page of the record wall.
    var retrieveRecordWallReq = new RetrieveRecordWallRequest
    {
        Entity = lead.ToEntityReference(),
        CommentsPerPost = 2,
        PageSize = 10,
        PageNumber = 1
    };

    var retrieveRecordWallRes =
        (RetrieveRecordWallResponse)_serviceProxy.Execute(retrieveRecordWallReq);

    Console.WriteLine("\r\n  Posts for lead {0}:", lead.FullName);
    foreach (Post post in retrieveRecordWallRes.EntityCollection.Entities)
    {
        DisplayPost(post);
    }
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveRecordWallResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the privileges on the specified entity in the Entity property and the access rights on the records that the returned posts regard or mention.
For a complete list of the required privileges, see RetrieveRecordWallRequest Privileges.
Notes for Callers
The posts that are retrieved for a record wall include the posts that are regarding the record or that mention the record. For a system user (user) record wall, retrieved posts also include the posts that the user created. If a post is regarding a record, the Post.RegardingObjectId attribute contains the record ID. If a record is the system user (user) record, the Post.RegardingObjectId attribute contains the current user ID. If a post mentions a record, the record ID is specified within the Post.Text attribute.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveRecordWallRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRecordWallResponse
Other Resources
RetrieveRecordWallRequest Privileges
Activity Feeds Entities
Introduction to Activity Feeds
Sample: Collaborate with Activity Feeds
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveRecordWallRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve pages of posts, including comments for each post, for a specified record.

The following tables list the members exposed by the RetrieveRecordWallRequest type.

Public Constructors

Name | Description
RetrieveRecordWallRequest | Initializes a new instance of the RetrieveRecordWallRequest class.
Top

Public Properties

 | Name | Description
public property | CommentsPerPost | Gets or sets, for retrieval, the number of comments per post. Required.
public property | EndDate | Gets or sets the end date and time of the posts that you want to retrieve. Optional.
public property | Entity | Gets or sets the record for which to retrieve the wall. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PageNumber | Gets or sets, for retrieval, a specific page of posts that is designated by its page number. Required.
public property | PageSize | Gets or sets, for retrieval, the number of posts per page. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Source | Gets or sets a value that specifies the source of the post. Optional.
public property | StartDate | Gets or sets the start date and time of the posts that you want to retrieve. Optional.
public property | Type | Reserved for future use.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRecordWallRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRecordWallResponse

Other Resources

RetrieveRecordWallRequest Privileges
Activity Feeds Entities
Introduction to Activity Feeds
Sample: Collaborate with Activity Feeds
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveRecordWallRequest Constructor
[image]

Initializes a new instance of the RetrieveRecordWallRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRecordWallRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallRequest Class
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRecordWallRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRecordWallResponse

Other Resources

RetrieveRecordWallRequest Privileges
Activity Feeds Entities
Introduction to Activity Feeds
Sample: Collaborate with Activity Feeds
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveRecordWallRequest Properties
[image]

Public Properties

 | Name | Description
public property | CommentsPerPost | Gets or sets, for retrieval, the number of comments per post. Required.
public property | EndDate | Gets or sets the end date and time of the posts that you want to retrieve. Optional.
public property | Entity | Gets or sets the record for which to retrieve the wall. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | PageNumber | Gets or sets, for retrieval, a specific page of posts that is designated by its page number. Required.
public property | PageSize | Gets or sets, for retrieval, the number of posts per page. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Source | Gets or sets a value that specifies the source of the post. Optional.
public property | StartDate | Gets or sets the start date and time of the posts that you want to retrieve. Optional.
public property | Type | Reserved for future use.

See Also

Reference

RetrieveRecordWallRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRecordWallResponse

Other Resources

RetrieveRecordWallRequest Privileges
Activity Feeds Entities
Introduction to Activity Feeds
Sample: Collaborate with Activity Feeds
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RetrieveRecordWallRequest.CommentsPerPost Property
[image]

Gets or sets, for retrieval, the number of comments per post. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CommentsPerPost As Integer

C#
public int CommentsPerPost { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of comments per post to retrieve. The maximum number of retrieved comments, per post, is 50; the minimum number is 0.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallRequest Class
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallRequest.EndDate Property
[image]

Gets or sets the end date and time of the posts that you want to retrieve. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EndDate As DateTime

C#
public DateTime EndDate { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The end date and time of the posts that you want to retrieve. If specified, the posts that were created on or before the specified end date and time are retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallRequest Class
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallRequest.Entity Property
[image]

Gets or sets the record for which to retrieve the wall. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As EntityReference

C#
public EntityReference Entity { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The record for which to retrieve the wall. This must be an entity reference for an entity that is enabled for activity feeds.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallRequest Class
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallRequest.PageNumber Property
[image]

Gets or sets, for retrieval, a specific page of posts that is designated by its page number. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PageNumber As Integer

C#
public int PageNumber { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The specific page of posts that is designated by its page number. The page number for the first page is 1. If you specify a value of 0, it is treated as a value of 1.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallRequest Class
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallRequest.PageSize Property
[image]

Gets or sets, for retrieval, the number of posts per page. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PageSize As Integer

C#
public int PageSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of posts per page. The maximum number of retrieved posts, per page, is 100; the minimum number is 1.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallRequest Class
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallRequest.Source Property
[image]

Gets or sets a value that specifies the source of the post. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Source As OptionSetValue

C#
public OptionSetValue Source { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The value that specifies the source of the post.

  Remarks
Use this property to filter the posts by their source type, such as an auto post or a manual post (user post).
The following table contains the valid values for this property.
Value | Description
1 | Auto post
2 | Manual post

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallRequest Class
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallRequest.StartDate Property
[image]

Gets or sets the start date and time of the posts that you want to retrieve. Optional.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property StartDate As DateTime

C#
public DateTime StartDate { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The start date and time of the posts that you want to retrieve. If specified, only the posts that were created on or after the specified date and time are retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallRequest Class
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallRequest.Type Property
[image]

Reserved for future use.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Type As OptionSetValue

C#
public OptionSetValue Type { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallRequest Class
RetrieveRecordWallRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallResponse Class
See Also Members
[image]

Contains the response from the RetrieveRecordWallRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveRecordWallResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveRecordWallResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveRecordWallResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRecordWallRequest


RetrieveRecordWallResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveRecordWallRequest class.

The following tables list the members exposed by the RetrieveRecordWallResponse type.

Public Constructors

Name | Description
RetrieveRecordWallResponse | Initializes a new instance of the RetrieveRecordWallResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of posts with their associated comments and the calculated attribute values.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRecordWallResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRecordWallRequest


RetrieveRecordWallResponse Constructor
[image]

Initializes a new instance of the RetrieveRecordWallResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRecordWallResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallResponse Class
RetrieveRecordWallResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRecordWallResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRecordWallResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRecordWallRequest


RetrieveRecordWallResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of posts with their associated comments and the calculated attribute values.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveRecordWallResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRecordWallRequest


RetrieveRecordWallResponse.EntityCollection Property
[image]

Gets the collection of posts with their associated comments and the calculated attribute values.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of posts with their associated comments and the calculated attribute values.

  Remarks
The comments are returned in RelatedEntityCollection for each post. This property returns the following calculated attribute values: CommentCount (Integer), LikeCount (int) Followed (Boolean), liked (bool), and DeleteEnabled (Boolean) on each post; and DeleteEnabled (Boolean) on each post comment. This property also returns the MoreRecords (Boolean) attribute, which indicates whether there are more pages of posts to retrieve.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRecordWallResponse Class
RetrieveRecordWallResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRequiredComponentsRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve a collection of solution components that are required for a solution component.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveRequiredComponentsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveRequiredComponentsRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveRequiredComponentsResponse.
Privileges and Access Rights
To perform this action, the caller must have  the privileges that are listed in RetrieveRequiredComponents Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveRequiredComponentsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequiredComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Dependency Tracking for Solution Components
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveRequiredComponentsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a collection of solution components that are required for a solution component.

The following tables list the members exposed by the RetrieveRequiredComponentsRequest type.

Public Constructors

Name | Description
RetrieveRequiredComponentsRequest | Initializes a new instance of the RetrieveRequiredComponentsRequest class.
Top

Public Properties

 | Name | Description
public property | ComponentType | Gets or sets the value that represents the solution component. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ObjectId | Gets or sets the ID of the solution component that you want to check. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRequiredComponentsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveRequiredComponentsRequest Constructor
[image]

Initializes a new instance of the RetrieveRequiredComponentsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRequiredComponentsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequiredComponentsRequest Class
RetrieveRequiredComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRequiredComponentsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRequiredComponentsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveRequiredComponentsRequest Properties
[image]

Public Properties

 | Name | Description
public property | ComponentType | Gets or sets the value that represents the solution component. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ObjectId | Gets or sets the ID of the solution component that you want to check. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveRequiredComponentsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Dependency Tracking for Solution Components
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveRequiredComponentsRequest.ComponentType Property
[image]

Gets or sets the value that represents the solution component. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ComponentType As Integer

C#
public int ComponentType { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The value that represents the solution component. Required.

  Remarks
The componenttype enumeration defines the supported range of values for this property. You can access the available values by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project. These values are defined by the global option set Component Type (componenttype).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequiredComponentsRequest Class
RetrieveRequiredComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRequiredComponentsRequest.ObjectId Property
[image]

Gets or sets the ID of the solution component that you want to check. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ObjectId As Guid

C#
public Guid ObjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the solution component that you want to check. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequiredComponentsRequest Class
RetrieveRequiredComponentsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRequiredComponentsResponse Class
See Also Members
[image]

Contains the response from the RetrieveRequiredComponentsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveRequiredComponentsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveRequiredComponentsResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveRequiredComponentsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequiredComponentsResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRequiredComponentsRequest


RetrieveRequiredComponentsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveRequiredComponentsRequest class.

The following tables list the members exposed by the RetrieveRequiredComponentsResponse type.

Public Constructors

Name | Description
RetrieveRequiredComponentsResponse | Initializes a new instance of the RetrieveRequiredComponentsResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent those components that the solution component requires.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRequiredComponentsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRequiredComponentsRequest


RetrieveRequiredComponentsResponse Constructor
[image]

Initializes a new instance of the RetrieveRequiredComponentsResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRequiredComponentsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequiredComponentsResponse Class
RetrieveRequiredComponentsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRequiredComponentsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRequiredComponentsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRequiredComponentsRequest


RetrieveRequiredComponentsResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent those components that the solution component requires.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveRequiredComponentsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRequiredComponentsRequest


RetrieveRequiredComponentsResponse.EntityCollection Property
[image]

Gets a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent those components that the solution component requires.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
a collection of Dependency records where the DependentComponentObjectId and DependentComponentType attributes represent those components that the solution component requires.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequiredComponentsResponse Class
RetrieveRequiredComponentsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRolePrivilegesRoleRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the privileges that are assigned to the specified role.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveRolePrivilegesRoleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveRolePrivilegesRoleRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveRolePrivilegesRoleResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Privileges entity and access rights on the specified record in the RoleId property. For a complete list of the required privileges, see RetrieveRolePrivilegesRole Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveRolePrivilegesRoleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRolePrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRolePrivilegesRoleResponse
Other Resources
How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Privilege Entity Messages and Methods
Role Entity Messages and Methods


RetrieveRolePrivilegesRoleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the privileges that are assigned to the specified role.

The following tables list the members exposed by the RetrieveRolePrivilegesRoleRequest type.

Public Constructors

Name | Description
RetrieveRolePrivilegesRoleRequest | Initializes a new instance of the RetrieveRolePrivilegesRoleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RoleId | Gets or sets the ID of the role for which the privileges are to be retrieved.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRolePrivilegesRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRolePrivilegesRoleResponse

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Privilege Entity Messages and Methods
Role Entity Messages and Methods


RetrieveRolePrivilegesRoleRequest Constructor
[image]

Initializes a new instance of the RetrieveRolePrivilegesRoleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRolePrivilegesRoleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRolePrivilegesRoleRequest Class
RetrieveRolePrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRolePrivilegesRoleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRolePrivilegesRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRolePrivilegesRoleResponse

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Privilege Entity Messages and Methods
Role Entity Messages and Methods


RetrieveRolePrivilegesRoleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RoleId | Gets or sets the ID of the role for which the privileges are to be retrieved.

See Also

Reference

RetrieveRolePrivilegesRoleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRolePrivilegesRoleResponse

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Privilege Entity Messages and Methods
Role Entity Messages and Methods


RetrieveRolePrivilegesRoleRequest.RoleId Property
[image]

Gets or sets the ID of the role for which the privileges are to be retrieved.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RoleId As Guid

C#
public Guid RoleId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the role for which the privileges are to be retrieved. This corresponds to the Role.RoleId property, which is the primary key for the Role entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRolePrivilegesRoleRequest Class
RetrieveRolePrivilegesRoleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRolePrivilegesRoleResponse Class
See Also Members
[image]

Contains the response from the RetrieveRolePrivilegesRoleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveRolePrivilegesRoleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveRolePrivilegesRoleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveRolePrivilegesRoleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRolePrivilegesRoleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRolePrivilegesRoleRequest


RetrieveRolePrivilegesRoleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveRolePrivilegesRoleRequest class.

The following tables list the members exposed by the RetrieveRolePrivilegesRoleResponse type.

Public Constructors

Name | Description
RetrieveRolePrivilegesRoleResponse | Initializes a new instance of the RetrieveRolePrivilegesRoleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RolePrivileges | Gets an array that contains the IDs and depths of the privileges that are held by the specified role.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRolePrivilegesRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRolePrivilegesRoleRequest


RetrieveRolePrivilegesRoleResponse Constructor
[image]

Initializes a new instance of the RetrieveRolePrivilegesRoleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRolePrivilegesRoleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRolePrivilegesRoleResponse Class
RetrieveRolePrivilegesRoleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveRolePrivilegesRoleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRolePrivilegesRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRolePrivilegesRoleRequest


RetrieveRolePrivilegesRoleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RolePrivileges | Gets an array that contains the IDs and depths of the privileges that are held by the specified role.

See Also

Reference

RetrieveRolePrivilegesRoleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRolePrivilegesRoleRequest


RetrieveRolePrivilegesRoleResponse.RolePrivileges Property
[image]

Gets an array that contains the IDs and depths of the privileges that are held by the specified role.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property RolePrivileges As RolePrivilege()

C#
public RolePrivilege[] RolePrivileges { get; }

C++

J#

JScript

Property Value
Type: RolePrivilege
The array that contains the IDs and depths of the privileges that are held by the specified role.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRolePrivilegesRoleResponse Class
RetrieveRolePrivilegesRoleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RolePrivilege


RetrieveSharedPrincipalsAndAccessRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve all security principals (users or teams) that have access to, and access rights for, the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveSharedPrincipalsAndAccessRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveSharedPrincipalsAndAccessRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
var accessRequest = new RetrieveSharedPrincipalsAndAccessRequest
{
    Target = leadReference
};

// The RetrieveSharedPrincipalsAndAccessResponse returns an entity reference
// that has a LogicalName of "user" when returning access information for a
// "team."
var accessResponse = (RetrieveSharedPrincipalsAndAccessResponse)
    _serviceProxy.Execute(accessRequest);
Console.WriteLine("The following have the specified granted access to the lead.");
foreach (var principalAccess in accessResponse.PrincipalAccesses)
{
    Console.WriteLine("\t{0}:\r\n\t\t{1}",
        GetEntityReferenceString(principalAccess.Principal),
        principalAccess.AccessMask);
}
Console.WriteLine();

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline. However, a few entities of this message class are exceptions to that availability. To determine which entities have a more restricted availability, see Supported Entities later in this topic.
Usage

                        Pass an instance of this class to the
                        Execute   method, which returns an instance of the RetrieveSharedPrincipalsAndAccessResponse class.
Privileges and Access Rights
To perform this action, the caller must have the privileges on the specified entity in the Target property and access rights on the specified record in the Target property. For a complete list of the required privileges, see the topic RetrieveSharedPrincipalsAndAccess Privileges.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
Annotation | 2 (Both)
Appointment | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
Connection | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ConvertRule | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
DuplicateRule | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
Fax | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
Import | 2 (Both)
ImportFile | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
Invoice | 2 (Both)
Lead | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OrderClose | 2 (Both)
PhoneCall | 2 (Both)
ProcessSession | 2 (Both)
Queue | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
Report | 2 (Both)
RoutingRule | 2 (Both)
SalesOrder | 2 (Both)
ServiceAppointment | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
SLA | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialProfile | 2 (Both)
Task | 2 (Both)
Template | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
Workflow | 2 (Both)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveSharedPrincipalsAndAccessRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveSharedPrincipalsAndAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSharedPrincipalsAndAccessResponse
Other Resources
How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Entity Ownership
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RetrieveSharedPrincipalsAndAccessRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve all security principals (users or teams) that have access to, and access rights for, the specified record.

The following tables list the members exposed by the RetrieveSharedPrincipalsAndAccessRequest type.

Public Constructors

Name | Description
RetrieveSharedPrincipalsAndAccessRequest | Initializes a new instance of the RetrieveSharedPrincipalsAndAccessRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for which you want to retrieve security principals (users and teams) and their access rights.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveSharedPrincipalsAndAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSharedPrincipalsAndAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Entity Ownership
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RetrieveSharedPrincipalsAndAccessRequest Constructor
[image]

Initializes a new instance of the RetrieveSharedPrincipalsAndAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveSharedPrincipalsAndAccessRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSharedPrincipalsAndAccessRequest Class
RetrieveSharedPrincipalsAndAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSharedPrincipalsAndAccessRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveSharedPrincipalsAndAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSharedPrincipalsAndAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Entity Ownership
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RetrieveSharedPrincipalsAndAccessRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for which you want to retrieve security principals (users and teams) and their access rights.

See Also

Reference

RetrieveSharedPrincipalsAndAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSharedPrincipalsAndAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Entity Ownership
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RetrieveSharedPrincipalsAndAccessRequest.Target Property
[image]

Gets or sets the target record for which you want to retrieve security principals (users and teams) and their access rights.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target record for which you want to retrieve security principals (users and teams) and their access rights. This property must be an entity reference for an entity that supports this message. For a list of supported entity types, see the RetrieveSharedPrincipalsAndAccessRequest class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSharedPrincipalsAndAccessRequest Class
RetrieveSharedPrincipalsAndAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSharedPrincipalsAndAccessResponse Class
See Also Members
[image]

Contains the response from the RetrieveSharedPrincipalsAndAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveSharedPrincipalsAndAccessResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveSharedPrincipalsAndAccessResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveSharedPrincipalsAndAccessResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSharedPrincipalsAndAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSharedPrincipalsAndAccessRequest


RetrieveSharedPrincipalsAndAccessResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveSharedPrincipalsAndAccessRequest class.

The following tables list the members exposed by the RetrieveSharedPrincipalsAndAccessResponse type.

Public Constructors

Name | Description
RetrieveSharedPrincipalsAndAccessResponse | Initializes a new instance of the RetrieveSharedPrincipalsAndAccessResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | PrincipalAccesses | Gets the requested security principals (teams and users) for the specified record.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveSharedPrincipalsAndAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSharedPrincipalsAndAccessRequest


RetrieveSharedPrincipalsAndAccessResponse Constructor
[image]

Initializes a new instance of the RetrieveSharedPrincipalsAndAccessResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveSharedPrincipalsAndAccessResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSharedPrincipalsAndAccessResponse Class
RetrieveSharedPrincipalsAndAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSharedPrincipalsAndAccessResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveSharedPrincipalsAndAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSharedPrincipalsAndAccessRequest


RetrieveSharedPrincipalsAndAccessResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | PrincipalAccesses | Gets the requested security principals (teams and users) for the specified record.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveSharedPrincipalsAndAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSharedPrincipalsAndAccessRequest


RetrieveSharedPrincipalsAndAccessResponse.PrincipalAccesses Property
[image]

Gets the requested security principals (teams and users) for the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property PrincipalAccesses As PrincipalAccess()

C#
public PrincipalAccess[] PrincipalAccesses { get; }

C++

J#

JScript

Property Value
Type: PrincipalAccess
The requested security principals (teams and users) for the specified record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSharedPrincipalsAndAccessResponse Class
RetrieveSharedPrincipalsAndAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubGroupsResourceGroupRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the collection of child resource groups from the specified resource group (scheduling group).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveSubGroupsResourceGroupRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveSubGroupsResourceGroupRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the RetrieveSubGroupsResourceGroupResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Resource entity and access rights on the specified record in the ResourceGroupId property. For a complete list of the required privileges, see RetrieveSubGroupsResourceGroup Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveSubGroupsResourceGroupRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubGroupsResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubGroupsResourceGroupResponse
Other Resources
Resource Entities
ResourceGroup (Scheduling  Group) Entity Messages and Methods


RetrieveSubGroupsResourceGroupRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the collection of child resource groups from the specified resource group (scheduling group).

The following tables list the members exposed by the RetrieveSubGroupsResourceGroupRequest type.

Public Constructors

Name | Description
RetrieveSubGroupsResourceGroupRequest | Initializes a new instance of the RetrieveSubGroupsResourceGroupRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceGroupId | Gets or sets the ID of the resource group.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveSubGroupsResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubGroupsResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


RetrieveSubGroupsResourceGroupRequest Constructor
[image]

Initializes a new instance of the RetrieveSubGroupsResourceGroupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveSubGroupsResourceGroupRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubGroupsResourceGroupRequest Class
RetrieveSubGroupsResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubGroupsResourceGroupRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveSubGroupsResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubGroupsResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


RetrieveSubGroupsResourceGroupRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query for the operation.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ResourceGroupId | Gets or sets the ID of the resource group.

See Also

Reference

RetrieveSubGroupsResourceGroupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubGroupsResourceGroupResponse

Other Resources

Resource Entities
ResourceGroup (Scheduling Group) Entity Messages and Methods


RetrieveSubGroupsResourceGroupRequest.Query Property
[image]

Gets or sets the query for the operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query for the operation.

  Remarks
The query must specify the entity name "resourcegroup" and a column set. Any other specified conditions are merged (by using the AND operator) with the conditions that are needed to retrieve the resource groups for the specified resource. If the column set includes attributes where IsValidForRead is false, they are ignored and the message response contains no data for those attributes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubGroupsResourceGroupRequest Class
RetrieveSubGroupsResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubGroupsResourceGroupRequest.ResourceGroupId Property
[image]

Gets or sets the ID of the resource group.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ResourceGroupId As Guid

C#
public Guid ResourceGroupId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the resource group. This corresponds to the ResourceGroup.ResourceGroupId property, which is the primary key for the ResourceGroup entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubGroupsResourceGroupRequest Class
RetrieveSubGroupsResourceGroupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubGroupsResourceGroupResponse Class
See Also Members
[image]

Contains the response from the RetrieveSubGroupsResourceGroupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveSubGroupsResourceGroupResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveSubGroupsResourceGroupResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveSubGroupsResourceGroupResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubGroupsResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubGroupsResourceGroupRequest


RetrieveSubGroupsResourceGroupResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveSubGroupsResourceGroupRequest class.

The following tables list the members exposed by the RetrieveSubGroupsResourceGroupResponse type.

Public Constructors

Name | Description
RetrieveSubGroupsResourceGroupResponse | Initializes a new instance of the RetrieveSubGroupsResourceGroupResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of child resource groups for the specified resource group (scheduling group).
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveSubGroupsResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubGroupsResourceGroupRequest


RetrieveSubGroupsResourceGroupResponse Constructor
[image]

Initializes a new instance of the RetrieveSubGroupsResourceGroupResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveSubGroupsResourceGroupResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubGroupsResourceGroupResponse Class
RetrieveSubGroupsResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubGroupsResourceGroupResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveSubGroupsResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubGroupsResourceGroupRequest


RetrieveSubGroupsResourceGroupResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the resulting collection of child resource groups for the specified resource group (scheduling group).
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveSubGroupsResourceGroupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubGroupsResourceGroupRequest


RetrieveSubGroupsResourceGroupResponse.EntityCollection Property
[image]

Gets the resulting collection of child resource groups for the specified resource group (scheduling group).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The resulting collection of child resource groups for the specified resource group (scheduling group).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubGroupsResourceGroupResponse Class
RetrieveSubGroupsResourceGroupResponse Members
Microsoft.Crm.Sdk.Messages Namespace
EntityCollection


RetrieveSubsidiaryTeamsBusinessUnitRequest Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class. Contains the data needed to retrieve a collection of entity instances based on the specified query criteria.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveSubsidiaryTeamsBusinessUnitRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveSubsidiaryTeamsBusinessUnitRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveSubsidiaryTeamsBusinessUnitRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryTeamsBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryTeamsBusinessUnitResponse
Other Resources
RetrieveSubsidiaryTeamsBusinessUnit Privileges


RetrieveSubsidiaryTeamsBusinessUnitRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class.Contains the data needed to retrieve a collection of entity instances based on the specified query criteria.

The following tables list the members exposed by the RetrieveSubsidiaryTeamsBusinessUnitRequest type.

Public Constructors

Name | Description
RetrieveSubsidiaryTeamsBusinessUnitRequest | Deprecated. Use the RetrieveMultipleRequest class and its members.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | EntityId | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveSubsidiaryTeamsBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryTeamsBusinessUnitResponse

Other Resources

RetrieveSubsidiaryTeamsBusinessUnit Privileges


RetrieveSubsidiaryTeamsBusinessUnitRequest Constructor
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveSubsidiaryTeamsBusinessUnitRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryTeamsBusinessUnitRequest Class
RetrieveSubsidiaryTeamsBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubsidiaryTeamsBusinessUnitRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveSubsidiaryTeamsBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryTeamsBusinessUnitResponse

Other Resources

RetrieveSubsidiaryTeamsBusinessUnit Privileges


RetrieveSubsidiaryTeamsBusinessUnitRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | EntityId | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveSubsidiaryTeamsBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryTeamsBusinessUnitResponse

Other Resources

RetrieveSubsidiaryTeamsBusinessUnit Privileges


RetrieveSubsidiaryTeamsBusinessUnitRequest.ColumnSet Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryTeamsBusinessUnitRequest Class
RetrieveSubsidiaryTeamsBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubsidiaryTeamsBusinessUnitRequest.EntityId Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryTeamsBusinessUnitRequest Class
RetrieveSubsidiaryTeamsBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubsidiaryTeamsBusinessUnitResponse Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveSubsidiaryTeamsBusinessUnitResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveSubsidiaryTeamsBusinessUnitResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveSubsidiaryTeamsBusinessUnitResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryTeamsBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryTeamsBusinessUnitRequest


RetrieveSubsidiaryTeamsBusinessUnitResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

The following tables list the members exposed by the RetrieveSubsidiaryTeamsBusinessUnitResponse type.

Public Constructors

Name | Description
RetrieveSubsidiaryTeamsBusinessUnitResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveSubsidiaryTeamsBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryTeamsBusinessUnitRequest


RetrieveSubsidiaryTeamsBusinessUnitResponse Constructor
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveSubsidiaryTeamsBusinessUnitResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryTeamsBusinessUnitResponse Class
RetrieveSubsidiaryTeamsBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubsidiaryTeamsBusinessUnitResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveSubsidiaryTeamsBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryTeamsBusinessUnitRequest


RetrieveSubsidiaryTeamsBusinessUnitResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveSubsidiaryTeamsBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryTeamsBusinessUnitRequest


RetrieveSubsidiaryTeamsBusinessUnitResponse.EntityCollection Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryTeamsBusinessUnitResponse Class
RetrieveSubsidiaryTeamsBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubsidiaryUsersBusinessUnitRequest Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class. Contains the data needed to retrieve all user information from the child business units of the specified business unit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveSubsidiaryUsersBusinessUnitRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveSubsidiaryUsersBusinessUnitRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveSubsidiaryUsersBusinessUnitRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryUsersBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryUsersBusinessUnitResponse
Other Resources
RetrieveSubsidiaryUsersBusinessUnit Privileges


RetrieveSubsidiaryUsersBusinessUnitRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class.Contains the data needed to retrieve all user information from the child business units of the specified business unit.

The following tables list the members exposed by the RetrieveSubsidiaryUsersBusinessUnitRequest type.

Public Constructors

Name | Description
RetrieveSubsidiaryUsersBusinessUnitRequest | Deprecated. Use the RetrieveMultipleRequest class and its members.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | EntityId | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveSubsidiaryUsersBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryUsersBusinessUnitResponse

Other Resources

RetrieveSubsidiaryUsersBusinessUnit Privileges


RetrieveSubsidiaryUsersBusinessUnitRequest Constructor
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveSubsidiaryUsersBusinessUnitRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryUsersBusinessUnitRequest Class
RetrieveSubsidiaryUsersBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubsidiaryUsersBusinessUnitRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveSubsidiaryUsersBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryUsersBusinessUnitResponse

Other Resources

RetrieveSubsidiaryUsersBusinessUnit Privileges


RetrieveSubsidiaryUsersBusinessUnitRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | EntityId | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveSubsidiaryUsersBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryUsersBusinessUnitResponse

Other Resources

RetrieveSubsidiaryUsersBusinessUnit Privileges


RetrieveSubsidiaryUsersBusinessUnitRequest.ColumnSet Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryUsersBusinessUnitRequest Class
RetrieveSubsidiaryUsersBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubsidiaryUsersBusinessUnitRequest.EntityId Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryUsersBusinessUnitRequest Class
RetrieveSubsidiaryUsersBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubsidiaryUsersBusinessUnitResponse Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class. Contains the response from the RetrieveSubsidiaryUsersBusinessUnitRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveSubsidiaryUsersBusinessUnitResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveSubsidiaryUsersBusinessUnitResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveSubsidiaryUsersBusinessUnitResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryUsersBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryUsersBusinessUnitRequest


RetrieveSubsidiaryUsersBusinessUnitResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.Contains the response from the RetrieveSubsidiaryUsersBusinessUnitRequest message.

The following tables list the members exposed by the RetrieveSubsidiaryUsersBusinessUnitResponse type.

Public Constructors

Name | Description
RetrieveSubsidiaryUsersBusinessUnitResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveSubsidiaryUsersBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryUsersBusinessUnitRequest


RetrieveSubsidiaryUsersBusinessUnitResponse Constructor
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveSubsidiaryUsersBusinessUnitResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryUsersBusinessUnitResponse Class
RetrieveSubsidiaryUsersBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveSubsidiaryUsersBusinessUnitResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveSubsidiaryUsersBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryUsersBusinessUnitRequest


RetrieveSubsidiaryUsersBusinessUnitResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveSubsidiaryUsersBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveSubsidiaryUsersBusinessUnitRequest


RetrieveSubsidiaryUsersBusinessUnitResponse.EntityCollection Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveSubsidiaryUsersBusinessUnitResponse Class
RetrieveSubsidiaryUsersBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveTeamPrivilegesRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the privileges for a team.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveTeamPrivilegesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveTeamPrivilegesRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the RetrieveTeamPrivilegesResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Privileges entity and access rights on the specified record in the TeamId property. For a complete list of the required privileges, see RetrieveTeamPrivileges Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveTeamPrivilegesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamPrivilegesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamPrivilegesResponse
Other Resources
Team Entity Messages and Methods
Sample: Assign Record to Team


RetrieveTeamPrivilegesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the privileges for a team.

The following tables list the members exposed by the RetrieveTeamPrivilegesRequest type.

Public Constructors

Name | Description
RetrieveTeamPrivilegesRequest | Initializes a new instance of the RetrieveTeamPrivilegesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the team for which you want to retrieve privileges.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveTeamPrivilegesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamPrivilegesResponse

Other Resources

Team Entity Messages and Methods
Sample: Assign Record to Team


RetrieveTeamPrivilegesRequest Constructor
[image]

Initializes a new instance of the RetrieveTeamPrivilegesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveTeamPrivilegesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamPrivilegesRequest Class
RetrieveTeamPrivilegesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveTeamPrivilegesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveTeamPrivilegesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamPrivilegesResponse

Other Resources

Team Entity Messages and Methods
Sample: Assign Record to Team


RetrieveTeamPrivilegesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the team for which you want to retrieve privileges.

See Also

Reference

RetrieveTeamPrivilegesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamPrivilegesResponse

Other Resources

Team Entity Messages and Methods
Sample: Assign Record to Team


RetrieveTeamPrivilegesRequest.TeamId Property
[image]

Gets or sets the team for which you want to retrieve privileges.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TeamId As Guid

C#
public Guid TeamId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The team for which you want to retrieve privileges. This corresponds to the Team.TeamId attribute, which is the primary key for the Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamPrivilegesRequest Class
RetrieveTeamPrivilegesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveTeamPrivilegesResponse Class
See Also Members
[image]

Contains the response from the RetrieveTeamPrivilegesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveTeamPrivilegesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveTeamPrivilegesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveTeamPrivilegesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamPrivilegesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamPrivilegesRequest


RetrieveTeamPrivilegesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveTeamPrivilegesRequest class.

The following tables list the members exposed by the RetrieveTeamPrivilegesResponse type.

Public Constructors

Name | Description
RetrieveTeamPrivilegesResponse | Initializes a new instance of the RetrieveTeamPrivilegesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RolePrivileges | Gets the list of privileges that the team holds for a record.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveTeamPrivilegesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamPrivilegesRequest


RetrieveTeamPrivilegesResponse Constructor
[image]

Initializes a new instance of the RetrieveTeamPrivilegesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveTeamPrivilegesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamPrivilegesResponse Class
RetrieveTeamPrivilegesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveTeamPrivilegesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveTeamPrivilegesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamPrivilegesRequest


RetrieveTeamPrivilegesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RolePrivileges | Gets the list of privileges that the team holds for a record.

See Also

Reference

RetrieveTeamPrivilegesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamPrivilegesRequest


RetrieveTeamPrivilegesResponse.RolePrivileges Property
[image]

Gets the list of privileges that the team holds for a record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property RolePrivileges As RolePrivilege()

C#
public RolePrivilege[] RolePrivileges { get; }

C++

J#

JScript

Property Value
Type: RolePrivilege array.
The list of privileges that the team holds for a record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamPrivilegesResponse Class
RetrieveTeamPrivilegesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM


RetrieveTeamsSystemUserRequest Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class. Contains the data needed to retrieve the list of teams of which the specified user is a member.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveTeamsSystemUserRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveTeamsSystemUserRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveTeamsSystemUserRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamsSystemUserResponse
Other Resources
RetrieveTeamsSystemUser Privileges


RetrieveTeamsSystemUserRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class.Contains the data needed to retrieve the list of teams of which the specified user is a member.

The following tables list the members exposed by the RetrieveTeamsSystemUserRequest type.

Public Constructors

Name | Description
RetrieveTeamsSystemUserRequest | Deprecated. Use the RetrieveMultipleRequest class and its members.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | EntityId | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveTeamsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamsSystemUserResponse

Other Resources

RetrieveTeamsSystemUser Privileges


RetrieveTeamsSystemUserRequest Constructor
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveTeamsSystemUserRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamsSystemUserRequest Class
RetrieveTeamsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveTeamsSystemUserRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveTeamsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamsSystemUserResponse

Other Resources

RetrieveTeamsSystemUser Privileges


RetrieveTeamsSystemUserRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | EntityId | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveTeamsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamsSystemUserResponse

Other Resources

RetrieveTeamsSystemUser Privileges


RetrieveTeamsSystemUserRequest.ColumnSet Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamsSystemUserRequest Class
RetrieveTeamsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveTeamsSystemUserRequest.EntityId Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamsSystemUserRequest Class
RetrieveTeamsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveTeamsSystemUserResponse Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class. Contains the response from the RetrieveTeamsSystemUserRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveTeamsSystemUserResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveTeamsSystemUserResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveTeamsSystemUserResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamsSystemUserRequest


RetrieveTeamsSystemUserResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.Contains the response from the RetrieveTeamsSystemUserRequest message.

The following tables list the members exposed by the RetrieveTeamsSystemUserResponse type.

Public Constructors

Name | Description
RetrieveTeamsSystemUserResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveTeamsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamsSystemUserRequest


RetrieveTeamsSystemUserResponse Constructor
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveTeamsSystemUserResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamsSystemUserResponse Class
RetrieveTeamsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveTeamsSystemUserResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveTeamsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamsSystemUserRequest


RetrieveTeamsSystemUserResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveTeamsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveTeamsSystemUserRequest


RetrieveTeamsSystemUserResponse.EntityCollection Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTeamsSystemUserResponse Class
RetrieveTeamsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUnpublishedMultipleRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve a collection of unpublished organization-owned records that satisfy the specified query criteria.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUnpublishedMultipleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUnpublishedMultipleRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage

                        Pass an instance of this class to the
                        Execute   method, which returns an instance of  the RetrieveUnpublishedMultipleResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the specified entities in the  Query property and read access rights on the records that are returned from the query. For a list of the required privileges, see RetrieveUnpublishedMultiple Privileges.
Notes for Callers
This message is included to support scenarios where you are creating a program to edit these types of entity records.
These organization-owned entities can be published. This message corresponds to the RetrieveMultipleRequest message except that it returns the current unpublished version of the records. As soon as the records are published, this message and RetrieveMultipleRequest return the same data.
Because these records are automatically published when they are created or deleted, this message and RetrieveMultipleRequest always return the same number of records.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

Entity | Availability
SavedQuery | Server
SavedQueryVisualization | Server
SiteMap | Server
SystemForm | Server
WebResource | Server

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveUnpublishedMultipleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedMultipleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMultipleRequest
RetrieveUnpublishedRequest
Other Resources
Publish Customizations


RetrieveUnpublishedMultipleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a collection of unpublished organization-owned records that satisfy the specified query criteria.

The following tables list the members exposed by the RetrieveUnpublishedMultipleRequest type.

Public Constructors

Name | Description
RetrieveUnpublishedMultipleRequest | Initializes a new instance of the RetrieveUnpublishedMultipleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query criteria defining the records to retrieve.Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUnpublishedMultipleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMultipleRequest
RetrieveUnpublishedRequest

Other Resources

Publish Customizations


RetrieveUnpublishedMultipleRequest Constructor
[image]

Initializes a new instance of the RetrieveUnpublishedMultipleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUnpublishedMultipleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedMultipleRequest Class
RetrieveUnpublishedMultipleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUnpublishedMultipleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUnpublishedMultipleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMultipleRequest
RetrieveUnpublishedRequest

Other Resources

Publish Customizations


RetrieveUnpublishedMultipleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query criteria defining the records to retrieve.Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveUnpublishedMultipleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveMultipleRequest
RetrieveUnpublishedRequest

Other Resources

Publish Customizations


RetrieveUnpublishedMultipleRequest.Query Property
[image]

Gets or sets the query criteria defining the records to retrieve.Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query criteria defining the records to retrieve.

  Remarks
Assign an instance of the FetchExpression, QueryExpression, or QueryByAttribute class. The query must specify entity names and a column set. If the column set includes attributes where IsValidForRead is false or that you do not have access to, they are ignored and the message response contains no data for those attributes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedMultipleRequest Class
RetrieveUnpublishedMultipleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUnpublishedMultipleResponse Class
See Also Members
[image]

Contains the response from the RetrieveUnpublishedMultipleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUnpublishedMultipleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUnpublishedMultipleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveUnpublishedMultipleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedMultipleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUnpublishedMultipleRequest


RetrieveUnpublishedMultipleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveUnpublishedMultipleRequest class.

The following tables list the members exposed by the RetrieveUnpublishedMultipleResponse type.

Public Constructors

Name | Description
RetrieveUnpublishedMultipleResponse | Initializes a new instance of the RetrieveUnpublishedMultipleResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of records that satisfy the query in the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUnpublishedMultipleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUnpublishedMultipleRequest


RetrieveUnpublishedMultipleResponse Constructor
[image]

Initializes a new instance of the RetrieveUnpublishedMultipleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUnpublishedMultipleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedMultipleResponse Class
RetrieveUnpublishedMultipleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUnpublishedMultipleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUnpublishedMultipleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUnpublishedMultipleRequest


RetrieveUnpublishedMultipleResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of records that satisfy the query in the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveUnpublishedMultipleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUnpublishedMultipleRequest


RetrieveUnpublishedMultipleResponse.EntityCollection Property
[image]

Gets the collection of records that satisfy the query in the request.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type:  EntityCollection
The collection of records that satisfy the query in the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedMultipleResponse Class
RetrieveUnpublishedMultipleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUnpublishedRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve an unpublished record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUnpublishedRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUnpublishedRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  the RetrieveUnpublishedResponse class.
Privileges and Access Rights
To perform this action, the caller must have  read access rights on the record specified in the Target property and the privileges that are listed in RetrieveUnpublished Privileges.
Notes for Callers
This message is included to support scenarios where you are creating a program to edit these types of entity records.
These organization-owned entities can be published. This message corresponds to the RetrieveRequest class except that it returns the current unpublished version of the record. When the record is published, this method and RetrieveRequest return the same data.
Because these records are automatically published when they are created or deleted, this message and RetrieveRequest only retrieve different data when a record has been updated but not published.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

Entity | Availability
savedquery | Server
savedqueryvisualization | Server
systemform | Server
webresource | Server

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveUnpublishedRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRequest
RetrieveUnpublishedMultipleRequest
Other Resources
Publish Customizations


RetrieveUnpublishedRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve an unpublished record.

The following tables list the members exposed by the RetrieveUnpublishedRequest type.

Public Constructors

Name | Description
RetrieveUnpublishedRequest | Initializes a new instance of the RetrieveUnpublishedRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes for which non-null values are returned from a query. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for the operation. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUnpublishedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRequest
RetrieveUnpublishedMultipleRequest

Other Resources

Publish Customizations


RetrieveUnpublishedRequest Constructor
[image]

Initializes a new instance of the RetrieveUnpublishedRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUnpublishedRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedRequest Class
RetrieveUnpublishedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUnpublishedRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUnpublishedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRequest
RetrieveUnpublishedMultipleRequest

Other Resources

Publish Customizations


RetrieveUnpublishedRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes for which non-null values are returned from a query. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record for the operation. Required.

See Also

Reference

RetrieveUnpublishedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveRequest
RetrieveUnpublishedMultipleRequest

Other Resources

Publish Customizations


RetrieveUnpublishedRequest.ColumnSet Property
[image]

Gets or sets the collection of attributes for which non-null values are returned from a query. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The collection of attributes for which non-null values are returned from a query. Required..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedRequest Class
RetrieveUnpublishedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUnpublishedRequest.Target Property
[image]

Gets or sets the target record for the operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
the target record for the operation. Required.

  Remarks
This target record must be an entity reference for an entity that supports this message. For a list of supported entity types, see RetrieveUnpublishedRequest.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedRequest Class
RetrieveUnpublishedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUnpublishedResponse Class
See Also Members
[image]

Contains the response from the RetrieveUnpublishedRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUnpublishedResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUnpublishedResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveUnpublishedResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUnpublishedRequest


RetrieveUnpublishedResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveUnpublishedRequest class.

The following tables list the members exposed by the RetrieveUnpublishedResponse type.

Public Constructors

Name | Description
RetrieveUnpublishedResponse | Initializes a new instance of the RetrieveUnpublishedResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the unpublished record that is specified in the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUnpublishedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUnpublishedRequest


RetrieveUnpublishedResponse Constructor
[image]

Initializes a new instance of the RetrieveUnpublishedResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUnpublishedResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedResponse Class
RetrieveUnpublishedResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUnpublishedResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUnpublishedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUnpublishedRequest


RetrieveUnpublishedResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the unpublished record that is specified in the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveUnpublishedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUnpublishedRequest


RetrieveUnpublishedResponse.Entity Property
[image]

Gets the unpublished record that is specified in the request.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type:  Entity
The unpublished record that is specified in the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUnpublishedResponse Class
RetrieveUnpublishedResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserPrivilegesRequest Class
See Also Example Members
[image]

Contains the data needed to retrieve the privileges a system user (user) has through his or her roles in the specified business unit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUserPrivilegesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUserPrivilegesRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  RetrieveUserPrivilegesResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Privileges entity and access rights on the record specified in the UserId property. For a complete list of the privileges required, see RetrieveUserPrivileges Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveUserPrivilegesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserPrivilegesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserPrivilegesResponse
Other Resources
SystemUser (User) Entity Messages and Methods


RetrieveUserPrivilegesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to retrieve the privileges a system user (user) has through his or her roles in the specified business unit.

The following tables list the members exposed by the RetrieveUserPrivilegesRequest type.

Public Constructors

Name | Description
RetrieveUserPrivilegesRequest | Initializes a new instance of the RetrieveUserPrivilegesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId | Gets or sets the user to retrieve privileges for.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserPrivilegesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserPrivilegesResponse

Other Resources

SystemUser (User) Entity Messages and Methods


RetrieveUserPrivilegesRequest Constructor
[image]

Initializes a new instance of the RetrieveUserPrivilegesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserPrivilegesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserPrivilegesRequest Class
RetrieveUserPrivilegesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserPrivilegesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserPrivilegesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserPrivilegesResponse

Other Resources

SystemUser (User) Entity Messages and Methods


RetrieveUserPrivilegesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId | Gets or sets the user to retrieve privileges for.

See Also

Reference

RetrieveUserPrivilegesRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserPrivilegesResponse

Other Resources

SystemUser (User) Entity Messages and Methods


RetrieveUserPrivilegesRequest.UserId Property
[image]

Gets or sets the user to retrieve privileges for.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserId As Guid

C#
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The user to retrieve privileges for. This corresponds to the User.UserId attribute, which is the primary key for the User entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserPrivilegesRequest Class
RetrieveUserPrivilegesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserPrivilegesResponse Class
See Also Members
[image]

Contains the response from the RetrieveUserPrivilegesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUserPrivilegesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUserPrivilegesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveUserPrivilegesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserPrivilegesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserPrivilegesRequest


RetrieveUserPrivilegesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveUserPrivilegesRequest class.

The following tables list the members exposed by the RetrieveUserPrivilegesResponse type.

Public Constructors

Name | Description
RetrieveUserPrivilegesResponse | Initializes a new instance of the RetrieveUserPrivilegesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RolePrivileges | Gets an array of privileges that the user holds.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserPrivilegesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserPrivilegesRequest


RetrieveUserPrivilegesResponse Constructor
[image]

Initializes a new instance of the RetrieveUserPrivilegesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserPrivilegesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserPrivilegesResponse Class
RetrieveUserPrivilegesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserPrivilegesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserPrivilegesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserPrivilegesRequest


RetrieveUserPrivilegesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | RolePrivileges | Gets an array of privileges that the user holds.

See Also

Reference

RetrieveUserPrivilegesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserPrivilegesRequest


RetrieveUserPrivilegesResponse.RolePrivileges Property
[image]

Gets an array of privileges that the user holds.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property RolePrivileges As RolePrivilege()

C#
public RolePrivilege[] RolePrivileges { get; }

C++

J#

JScript

Property Value
Type: RolePrivilege array
The array of privileges that the user holds.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserPrivilegesResponse Class
RetrieveUserPrivilegesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RolePrivilege


RetrieveUserQueuesRequest Class
See Also Members
[image]

Contains the data needed to retrieve all private queues of a specified user and optionally all public queues.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUserQueuesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUserQueuesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveUserQueuesResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Queue entity and access rights on the record specified in the UserId property. For a complete list of the privileges required, see RetrieveUserQueues message privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveUserQueuesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserQueuesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Queue Entity Messages and Methods


RetrieveUserQueuesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to retrieve all private queues of a specified user and optionally all public queues.

The following tables list the members exposed by the RetrieveUserQueuesRequest type.

Public Constructors

Name | Description
RetrieveUserQueuesRequest | Initializes a new instance of the RetrieveUserQueuesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncludePublic | Gets or sets whether the response should include public queues.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserQueuesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Queue Entity Messages and Methods


RetrieveUserQueuesRequest Constructor
[image]

Initializes a new instance of the RetrieveUserQueuesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserQueuesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserQueuesRequest Class
RetrieveUserQueuesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserQueuesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserQueuesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Queue Entity Messages and Methods


RetrieveUserQueuesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IncludePublic | Gets or sets whether the response should include public queues.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId |

See Also

Reference

RetrieveUserQueuesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Queue Entity Messages and Methods


RetrieveUserQueuesRequest.IncludePublic Property
[image]

Gets or sets whether the response should include public queues.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IncludePublic As Boolean

C#
public bool IncludePublic { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the response should include public queues; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserQueuesRequest Class
RetrieveUserQueuesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserQueuesRequest.UserId Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserId As Guid

C#
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The id of the user. This corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserQueuesRequest Class
RetrieveUserQueuesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserQueuesResponse Class
See Also Members
[image]

Contains the response from the RetrieveUserQueuesRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUserQueuesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUserQueuesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveUserQueuesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserQueuesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserQueuesRequest


RetrieveUserQueuesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveUserQueuesRequest message.

The following tables list the members exposed by the RetrieveUserQueuesResponse type.

Public Constructors

Name | Description
RetrieveUserQueuesResponse | Initializes a new instance of the RetrieveUserQueuesResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of queues that match the properties of the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserQueuesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserQueuesRequest


RetrieveUserQueuesResponse Constructor
[image]

Initializes a new instance of the RetrieveUserQueuesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserQueuesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserQueuesResponse Class
RetrieveUserQueuesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserQueuesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserQueuesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserQueuesRequest


RetrieveUserQueuesResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets a collection of queues that match the properties of the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveUserQueuesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserQueuesRequest


RetrieveUserQueuesResponse.EntityCollection Property
[image]

Gets a collection of queues that match the properties of the request.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
A collection of queues that match the properties of the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserQueuesResponse Class
RetrieveUserQueuesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserSettingsSystemUserRequest Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class. Contains the data needed to retrieve the user settings for the specified system user (user).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUserSettingsSystemUserRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUserSettingsSystemUserRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveUserSettingsSystemUserRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserSettingsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserSettingsSystemUserResponse
Other Resources
RetrieveUserSettingsSystemUser Privileges


RetrieveUserSettingsSystemUserRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class.Contains the data needed to retrieve the user settings for the specified system user (user).

The following tables list the members exposed by the RetrieveUserSettingsSystemUserRequest type.

Public Constructors

Name | Description
RetrieveUserSettingsSystemUserRequest | Deprecated. Use the RetrieveMultipleRequest class and its members.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | EntityId | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserSettingsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserSettingsSystemUserResponse

Other Resources

RetrieveUserSettingsSystemUser Privileges


RetrieveUserSettingsSystemUserRequest Constructor
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserSettingsSystemUserRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserSettingsSystemUserRequest Class
RetrieveUserSettingsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserSettingsSystemUserRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserSettingsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserSettingsSystemUserResponse

Other Resources

RetrieveUserSettingsSystemUser Privileges


RetrieveUserSettingsSystemUserRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | EntityId | Deprecated. Use the RetrieveMultipleRequest class and its members.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveUserSettingsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserSettingsSystemUserResponse

Other Resources

RetrieveUserSettingsSystemUser Privileges


RetrieveUserSettingsSystemUserRequest.ColumnSet Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserSettingsSystemUserRequest Class
RetrieveUserSettingsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserSettingsSystemUserRequest.EntityId Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserSettingsSystemUserRequest Class
RetrieveUserSettingsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserSettingsSystemUserResponse Class
See Also Members
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveUserSettingsSystemUserResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveUserSettingsSystemUserResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveUserSettingsSystemUserResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserSettingsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserSettingsSystemUserRequest


RetrieveUserSettingsSystemUserResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

The following tables list the members exposed by the RetrieveUserSettingsSystemUserResponse type.

Public Constructors

Name | Description
RetrieveUserSettingsSystemUserResponse | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
Top

Public Properties

 | Name | Description
public property | Entity | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserSettingsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserSettingsSystemUserRequest


RetrieveUserSettingsSystemUserResponse Constructor
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserSettingsSystemUserResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserSettingsSystemUserResponse Class
RetrieveUserSettingsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveUserSettingsSystemUserResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserSettingsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserSettingsSystemUserRequest


RetrieveUserSettingsSystemUserResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Deprecated. Use the RetrieveMultipleRequest class and its associated response class.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveUserSettingsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveUserSettingsSystemUserRequest


RetrieveUserSettingsSystemUserResponse.Entity Property
[image]

Deprecated. Use the RetrieveMultipleRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserSettingsSystemUserResponse Class
RetrieveUserSettingsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveVersionRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the version number of the Microsoft Dynamics CRM Server.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveVersionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveVersionRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute method, which returns an instance of  the RetrieveVersionResponse class.
Privileges and Access Rights
 For a complete list of the required privileges, see RetrieveVersion Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RetrieveVersionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveVersionRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveVersionResponse
Other Resources
Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveVersionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the version number of the Microsoft Dynamics CRM Server.

The following tables list the members exposed by the RetrieveVersionRequest type.

Public Constructors

Name | Description
RetrieveVersionRequest | Initializes a new instance of the RetrieveVersionRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveVersionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveVersionResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveVersionRequest Constructor
[image]

Initializes a new instance of the RetrieveVersionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveVersionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveVersionRequest Class
RetrieveVersionRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveVersionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveVersionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveVersionResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveVersionRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveVersionRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveVersionResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


RetrieveVersionResponse Class
See Also Members
[image]

Contains the response from the RetrieveVersionRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RetrieveVersionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RetrieveVersionResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RetrieveVersionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveVersionResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RetrieveVersionRequest


RetrieveVersionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveVersionRequest class.

The following tables list the members exposed by the RetrieveVersionResponse type.

Public Constructors

Name | Description
RetrieveVersionResponse | Initializes a new instance of the RetrieveVersionResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Version | Gets the version number of the Microsoft Dynamics CRM Server.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveVersionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveVersionRequest


RetrieveVersionResponse Constructor
[image]

Initializes a new instance of the RetrieveVersionResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveVersionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveVersionResponse Class
RetrieveVersionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RetrieveVersionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveVersionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveVersionRequest


RetrieveVersionResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Version | Gets the version number of the Microsoft Dynamics CRM Server.

See Also

Reference

RetrieveVersionResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RetrieveVersionRequest


RetrieveVersionResponse.Version Property
[image]

Gets the version number of the Microsoft Dynamics CRM Server.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Version As String

C#
public string Version { get; }

C++

J#

JScript

Property Value
Type: String
The version number of the Microsoft Dynamics CRM Server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveVersionResponse Class
RetrieveVersionResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RevertProductRequest Class
See Also Members
[image]

Contains the data that is needed to revert changes done to properties of a product family, product, or bundle record, and set it back to its last published (active) state.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RevertProductRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RevertProductRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method, which returns an instance of RevertProductResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Product entity and access rights on the record specified in the Target property.
Notes to Callers
All the product property (attribute) changes done to the record since it was last published (active) will be lost.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RevertProductRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevertProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Revert a product family, product, or bundle
Product catalog entities


RevertProductRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to revert changes done to properties of a product family, product, or bundle record, and set it back to its last published (active) state.

The following tables list the members exposed by the RevertProductRequest type.

Public Constructors

Name | Description
RevertProductRequest | Initializes a new instance of the RevertProductRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target product family, product, or bundle record for which you want to revert the changes done to its properties since it was last published. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RevertProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Revert a product family, product, or bundle
Product catalog entities


RevertProductRequest Constructor
[image]

Initializes a new instance of the RevertProductRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RevertProductRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevertProductRequest Class
RevertProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RevertProductRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RevertProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Revert a product family, product, or bundle
Product catalog entities


RevertProductRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target product family, product, or bundle record for which you want to revert the changes done to its properties since it was last published. Required.

See Also

Reference

RevertProductRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Revert a product family, product, or bundle
Product catalog entities


RevertProductRequest.Target Property
[image]

Gets or sets the target product family, product, or bundle record for which you want to revert the changes done to its properties since it was last published. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type EntityReference
The target product family, product, or bundle record for which you want to revert the changes done to its properties since it was last published.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevertProductRequest Class
RevertProductRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RevertProductResponse Class
See Also Members
[image]

Contains the response from the RevertProductRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RevertProductResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RevertProductResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RevertProductResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevertProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RevertProductRequest


RevertProductResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RevertProductRequest class.

The following tables list the members exposed by the RevertProductResponse type.

Public Constructors

Name | Description
RevertProductResponse | Initializes a new instance of the RevertProductResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RevertProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RevertProductRequest


RevertProductResponse Constructor
[image]

Initializes a new instance of the RevertProductResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RevertProductResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevertProductResponse Class
RevertProductResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RevertProductResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RevertProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RevertProductRequest


RevertProductResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RevertProductResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RevertProductRequest


ReviseQuoteRequest Class
See Also Members
[image]

Contains the data that is needed to set the state of a quote to Draft.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReviseQuoteRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReviseQuoteRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the ReviseQuoteResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Quote entity and access rights to the specified record in the QuoteId property.
For a complete list of the required privileges, see ReviseQuote Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ReviseQuoteRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReviseQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ReviseQuoteResponse
Other Resources
ReviseQuote Privileges
Quote Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ReviseQuoteRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to set the state of a quote to Draft.

The following tables list the members exposed by the ReviseQuoteRequest type.

Public Constructors

Name | Description
ReviseQuoteRequest | Initializes a new instance of the ReviseQuoteRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve in the revised quote. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteId | Gets or sets the ID of the original quote. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReviseQuoteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReviseQuoteResponse

Other Resources

ReviseQuote Privileges
Quote Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ReviseQuoteRequest Constructor
[image]

Initializes a new instance of the ReviseQuoteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReviseQuoteRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReviseQuoteRequest Class
ReviseQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReviseQuoteRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReviseQuoteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReviseQuoteResponse

Other Resources

ReviseQuote Privileges
Quote Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ReviseQuoteRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes to retrieve in the revised quote. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteId | Gets or sets the ID of the original quote. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ReviseQuoteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ReviseQuoteResponse

Other Resources

ReviseQuote Privileges
Quote Entity Messages and Methods
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


ReviseQuoteRequest.ColumnSet Property
[image]

Gets or sets the collection of attributes to retrieve in the revised quote. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The the collection of attributes to retrieve in the revised quote.

  Remarks
Assign null to this property to retrieve only the primary key. The non-null values are returned for the specified attributes in the column set. The attributes that are not included in the column set contain null values. If the column set includes attributes where IsValidForRead is false, they are ignored, and the message response contains no data for those attributes. To learn which attributes are valid for retrieval, see the quote entity metadata. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReviseQuoteRequest Class
ReviseQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReviseQuoteRequest.QuoteId Property
[image]

Gets or sets the ID of the original quote. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QuoteId As Guid

C#
public Guid QuoteId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The the ID of the original quote. This corresponds to the Quote.QuoteId attribute, which is the primary key for the Quote entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReviseQuoteRequest Class
ReviseQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ReviseQuoteResponse Class
See Also Members
[image]

Contains the response from the ReviseQuoteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ReviseQuoteResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ReviseQuoteResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ReviseQuoteResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReviseQuoteResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ReviseQuoteRequest


ReviseQuoteResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ReviseQuoteRequest class.

The following tables list the members exposed by the ReviseQuoteResponse type.

Public Constructors

Name | Description
ReviseQuoteResponse | Initializes a new instance of the ReviseQuoteResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the revised quote.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReviseQuoteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReviseQuoteRequest


ReviseQuoteResponse Constructor
[image]

Initializes a new instance of the ReviseQuoteResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReviseQuoteResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReviseQuoteResponse Class
ReviseQuoteResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ReviseQuoteResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReviseQuoteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReviseQuoteRequest


ReviseQuoteResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the revised quote.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ReviseQuoteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ReviseQuoteRequest


ReviseQuoteResponse.Entity Property
[image]

Gets the revised quote.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The revised quote. This is instance of the Quote class, which is a subclass of the Entity class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReviseQuoteResponse Class
ReviseQuoteResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RevokeAccessRequest Class
See Also Example Members
[image]

Contains the data that is needed to replace the access rights on the target record for the specified security principal (user or team).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RevokeAccessRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RevokeAccessRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Revoke access to the lead for the second user.
var revokeUser2AccessReq = new RevokeAccessRequest
{
    Revokee = systemUser2Ref,
    Target = leadReference
};

Console.WriteLine("Revoking access to the lead for {0}...\r\n",
    GetEntityReferenceString(systemUser2Ref));
_serviceProxy.Execute(revokeUser2AccessReq);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of the RevokeAccessResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the Target property and access rights on the specified record in the Target property. For a list of the required privileges, see RevokeAccess Privileges.
Notes for Callers
This action also applies to all child records of the target record. However for all child records, access rights are only modified if the caller has share privileges for those entity types and share access rights to the records. As a result, the owner of the target record, or a user who shares the target record, automatically has share rights to all child records of the target record.
For a description of how actions on a parent record affect child records, see Cascading Behavior.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities, the caller must be connected to the server for this message to be available.

Entity | Availability
Account | 0 (Server)
Annotation | 0 (Server)
Appointment | 0 (Server)
Campaign | 0 (Server)
CampaignActivity | 0 (Server)
CampaignResponse | 0 (Server)
Connection | 0 (Server)
Contact | 0 (Server)
Contract | 0 (Server)
ConvertRule | 0 (Server)
CustomerOpportunityRole | 0 (Server)
CustomerRelationship | 0 (Server)
DuplicateRule | 0 (Server)
Email | 0 (Server)
EmailServerProfile | 0 (Server)
Entitlement | 0 (Server)
Fax | 0 (Server)
Goal | 0 (Server)
GoalRollupQuery | 0 (Server)
Import | 0 (Server)
ImportFile | 0 (Server)
ImportMap | 0 (Server)
Incident | 0 (Server)
IncidentResolution | 0 (Server)
Invoice | 0 (Server)
Lead | 0 (Server)
Letter | 0 (Server)
List | 0 (Server)
Mailbox | 0 (Server)
MailMergeTemplate | 0 (Server)
msdyn_PostAlbum | 0 (Server)
msdyn_wallsavedqueryusersettings | 0 (Server)
Opportunity | 0 (Server)
OpportunityClose | 0 (Server)
OrderClose | 0 (Server)
PhoneCall | 0 (Server)
ProcessSession | 0 (Server)
Queue | 0 (Server)
Quote | 0 (Server)
QuoteClose | 0 (Server)
RecurringAppointmentMaster | 0 (Server)
Report | 0 (Server)
RoutingRule | 0 (Server)
SalesOrder | 0 (Server)
ServiceAppointment | 0 (Server)
SharePointDocumentLocation | 0 (Server)
SharePointSite | 0 (Server)
SLA | 0 (Server)
SLAKPIInstance | 0 (Server)
SocialActivity | 0 (Server)
SocialProfile | 0 (Server)
Task | 0 (Server)
Template | 0 (Server)
UserForm | 0 (Server)
UserQuery | 0 (Server)
UserQueryVisualization | 0 (Server)
Workflow | 0 (Server)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RevokeAccessRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RevokeAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RevokeAccessResponse
Other Resources
How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RevokeAccessRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to replace the access rights on the target record for the specified security principal (user or team).

The following tables list the members exposed by the RevokeAccessRequest type.

Public Constructors

Name | Description
RevokeAccessRequest | Initializes a new instance of the RevokeAccessRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Revokee | Gets or sets a security principal (team or user) whose access you want to revoke. Required.
public property | Target | Gets or sets the target record for which you want to revoke access. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RevokeAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RevokeAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RevokeAccessRequest Constructor
[image]

Initializes a new instance of the RevokeAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RevokeAccessRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevokeAccessRequest Class
RevokeAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RevokeAccessRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RevokeAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RevokeAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RevokeAccessRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Revokee | Gets or sets a security principal (team or user) whose access you want to revoke. Required.
public property | Target | Gets or sets the target record for which you want to revoke access. Required.

See Also

Reference

RevokeAccessRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RevokeAccessResponse

Other Resources

How Record-Based Security Can Be Used to Control Access to Records In Microsoft Dynamics CRM
Actions on Entity Records
Sample: Share Records Using GrantAccess, ModifyAccess and RevokeAccess Messages


RevokeAccessRequest.Revokee Property
[image]

Gets or sets a security principal (team or user) whose access you want to revoke. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Revokee As EntityReference

C#
public EntityReference Revokee { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The security principal (team or user) whose access you want to revoke.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevokeAccessRequest Class
RevokeAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RevokeAccessRequest.Target Property
[image]

Gets or sets the target record for which you want to revoke access. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target record for which you want to revoke access. This property value must be an entity reference for an entity that supports this message. For a list of supported entity types, see the RevokeAccessRequest class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevokeAccessRequest Class
RevokeAccessRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RevokeAccessResponse Class
See Also Members
[image]

Contains the response from the RevokeAccessRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RevokeAccessResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RevokeAccessResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RevokeAccessResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevokeAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RevokeAccessRequest


RevokeAccessResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RevokeAccessRequest class.

The following tables list the members exposed by the RevokeAccessResponse type.

Public Constructors

Name | Description
RevokeAccessResponse | Initializes a new instance of theRevokeAccessResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RevokeAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RevokeAccessRequest


RevokeAccessResponse Constructor
[image]

Initializes a new instance of the RevokeAccessResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RevokeAccessResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RevokeAccessResponse Class
RevokeAccessResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RevokeAccessResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RevokeAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RevokeAccessRequest


RevokeAccessResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RevokeAccessResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RevokeAccessRequest


RibbonLocationFilters Enumeration
[image]

Contains the values for ribbon filters for an entity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FlagsAttribute> _
<DataContractAttribute(Name:="RibbonLocationFilters", Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration RibbonLocationFilters

C#
[FlagsAttribute]
[DataContractAttribute(Name="RibbonLocationFilters", Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum RibbonLocationFilters

C++

J#

JScript

  Members
Member name | Description
All | Retrieve all Ribbons. Equivalent to Default. Value = 7.
Default | Retrieve all Ribbons. Equivalent to All. Value = 7.
Form | Retrieve just the form ribbon. Value = 1.
HomepageGrid | Retrieve just the ribbon displayed for entity grids. Value = 2.
SubGrid | Retrieve just the ribbon displayed when the entity is displayed in a subgrid or associated view. Value = 4.
  Remarks
This enumeration is used with RetrieveEntityRibbonRequest.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilege Class
See Also Members
[image]

Contains information about a privilege.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RolePrivilege
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RolePrivilege : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.RolePrivilege
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleRequest
ReplacePrivilegesRoleRequest
Other Resources
How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Sample: Assign Record to Team


RolePrivilege Members
See Also Constructors Methods Properties
[image]

Contains information about a privilege.

The following tables list the members exposed by the RolePrivilege type.

Public Constructors

Name | Description
RolePrivilege | Overloaded. Initializes a new instance of the RolePrivilege class.
Top

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets or sets the ID of the business unit.
public property | Depth | Gets or sets the depth of the privilege.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PrivilegeId | Gets or sets the ID of the privilege.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RolePrivilege Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleRequest
ReplacePrivilegesRoleRequest

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Sample: Assign Record to Team


RolePrivilege Constructor
[image]

Initializes a new instance of the RolePrivilege class.

Overload List

Name | Description
RolePrivilege () | Initializes a new instance of the RolePrivilege class.
RolePrivilege (PrivilegeDepth, Guid, Guid) | Initializes a new instance of the RolePrivilege class by setting the depth, privilege ID, and business unit ID.
RolePrivilege (Int32, Guid) | Initializes a new instance of the RolePrivilege class by setting the depth and the privilege ID.
RolePrivilege (Int32, Guid, Guid) | Initializes a new instance of the RolePrivilege class by setting the depth (as an integer), the privilege ID, and the business unit ID.

See Also

Reference

RolePrivilege Class
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilege Constructor ()
[image]

Initializes a new instance of the RolePrivilege class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RolePrivilege ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilege Class
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilege Constructor (PrivilegeDepth, Guid, Guid)
[image]

Initializes a new instance of the RolePrivilege class by setting the depth, privilege ID, and business unit ID.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    depth As PrivilegeDepth, _
    privilegeId As Guid, _
    businessId As Guid _
)

C#
public RolePrivilege (
    PrivilegeDepth depth,
    Guid privilegeId,
    Guid businessId
)

C++

J#

JScript

Parameters
depth
Type: PrivilegeDepth. The depth of the privilege.
privilegeId
Type: Guid. The ID of the privilege.
businessId
Type: Guid. The ID of the business unit.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilege Class
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilege Constructor (Int32, Guid)
[image]

Initializes a new instance of the RolePrivilege class by setting the depth and the privilege ID.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    depth As Integer, _
    privilegeId As Guid _
)

C#
public RolePrivilege (
    int depth,
    Guid privilegeId
)

C++

J#

JScript

Parameters
depth
Type: Int32. The depth of the privilege.
privilegeId
Type: Guid. The ID of the privilege.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilege Class
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilege Constructor (Int32, Guid, Guid)
[image]

Initializes a new instance of the RolePrivilege class by setting the depth (as an integer), the privilege ID, and the business unit ID.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    depth As Integer, _
    privilegeId As Guid, _
    businessId As Guid _
)

C#
public RolePrivilege (
    int depth,
    Guid privilegeId,
    Guid businessId
)

C++

J#

JScript

Parameters
depth
Type: Int32. The depth of the privilege.
privilegeId
Type: Guid. The ID of the privilege.
businessId
Type: Guid. The ID of the business unit.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilege Class
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilege Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RolePrivilege Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleRequest
ReplacePrivilegesRoleRequest

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Sample: Assign Record to Team


RolePrivilege Properties
[image]

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets or sets the ID of the business unit.
public property | Depth | Gets or sets the depth of the privilege.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PrivilegeId | Gets or sets the ID of the privilege.

See Also

Reference

RolePrivilege Class
Microsoft.Crm.Sdk.Messages Namespace
AddPrivilegesRoleRequest
ReplacePrivilegesRoleRequest

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM
Privilege and Role Entities
Sample: Assign Record to Team


RolePrivilege.BusinessUnitId Property
[image]

Gets or sets the ID of the business unit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property BusinessUnitId As Guid

C#
[DataMemberAttribute]
public Guid BusinessUnitId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the business unit, which corresponds to the BusinessUnit.BusinessUnitID attribute, which is the primary key for the BusinessUnit entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilege Class
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilege.Depth Property
[image]

Gets or sets the depth of the privilege.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Depth As PrivilegeDepth

C#
[DataMemberAttribute]
public PrivilegeDepth Depth { get; set; }

C++

J#

JScript

Property Value
Type: PrivilegeDepth
The depth of the privilege.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilege Class
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilege.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilege Class
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilege.PrivilegeId Property
[image]

Gets or sets the ID of the privilege.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PrivilegeId As Guid

C#
[DataMemberAttribute]
public Guid PrivilegeId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the privilege, which corresponds to the Privilege.PrivilegeID attribute, which is the primary key for the Privilege entity..

  Remarks
The PrivilegeId property corresponds to the Privilege.PrivilegeID attribute, which is the primary key for the Privilege entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilege Class
RolePrivilege Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilegeAuditDetail Class
See Also Members
[image]

Represents audited changes to the privileges of a security role.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RolePrivilegeAuditDetail
    Inherits AuditDetail

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RolePrivilegeAuditDetail : AuditDetail

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Crm.Sdk.Messages.AuditDetail
    Microsoft.Crm.Sdk.Messages.RolePrivilegeAuditDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilegeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM


RolePrivilegeAuditDetail Members
See Also Constructors Methods Properties
[image]

Represents audited changes to the privileges of a security role.

The following tables list the members exposed by the RolePrivilegeAuditDetail type.

Public Constructors

Name | Description
RolePrivilegeAuditDetail | Initializes a new instance of the RolePrivilegeAuditDetail class.
Top

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | InvalidNewPrivileges | Gets the collection of invalid privileges for the role.
public property | NewRolePrivileges | Gets or sets the role’s new privileges.
public property | OldRolePrivileges | Gets or sets the role’s old privileges.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RolePrivilegeAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM


RolePrivilegeAuditDetail Constructor
[image]

Initializes a new instance of the RolePrivilegeAuditDetail class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RolePrivilegeAuditDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilegeAuditDetail Class
RolePrivilegeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilegeAuditDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RolePrivilegeAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM


RolePrivilegeAuditDetail Properties
[image]

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | InvalidNewPrivileges | Gets the collection of invalid privileges for the role.
public property | NewRolePrivileges | Gets or sets the role’s new privileges.
public property | OldRolePrivileges | Gets or sets the role’s old privileges.

See Also

Reference

RolePrivilegeAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM


RolePrivilegeAuditDetail.InvalidNewPrivileges Property
[image]

Gets the collection of invalid privileges for the role.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public ReadOnly Property InvalidNewPrivileges As DataCollection(Of Guid)

C#
[DataMemberAttribute]
public DataCollection<Guid> InvalidNewPrivileges { get; }

C++

J#

JScript

Property Value
Type: DataCollection<Guid>
The collection of invalid privileges for the role.

  Remarks
If an attempt is made to assign a set of privileges to a role, and some of those privileges cannot be assigned, the privileges that cannot be assigned will be in this InvalidNewPrivileges property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilegeAuditDetail Class
RolePrivilegeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilegeAuditDetail.NewRolePrivileges Property
[image]

Gets or sets the role’s new privileges.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property NewRolePrivileges As RolePrivilege()

C#
[DataMemberAttribute]
public RolePrivilege[] NewRolePrivileges { get; set; }

C++

J#

JScript

Property Value
Type: RolePrivilege
The new privileges for the role.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilegeAuditDetail Class
RolePrivilegeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


RolePrivilegeAuditDetail.OldRolePrivileges Property
[image]

Gets or sets the role’s old privileges.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OldRolePrivileges As RolePrivilege()

C#
[DataMemberAttribute]
public RolePrivilege[] OldRolePrivileges { get; set; }

C++

J#

JScript

Property Value
Type: RolePrivilege
The old privileges for the role.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RolePrivilegeAuditDetail Class
RolePrivilegeAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


RollupRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve all the entity records that are related to the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RollupRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RollupRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create RollupRequest
RollupRequest rollupRequest = new RollupRequest();
rollupRequest.Query = query;
rollupRequest.Target = new EntityReference("account", _accountId);
rollupRequest.RollupType = RollupType.Extended;
Console.WriteLine("Created RollupRequest.");
#endregion Create RollupRequest

#region Execute RollupRequest
// Execute RollupRequest
RollupResponse rollupResponse = (RollupResponse)_serviceProxy.Execute(rollupRequest);
Console.WriteLine("Executed RollupRequest.");

  Remarks
A rollup operation retrieves all annotations that are related to a specified account. An annotation is a note that is attached to one or more objects, including other notes.
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the RollupResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entities in the Target Query properties. The caller must also have access rights on the specified record in the Target property and read access rights on the records that are returned from the query. For a complete list of the required privileges, see Rollup Privileges.
Notes for Callers
The target entities include: account, contact, and opportunity. The rollup type (RollupType) for the supported entities depends on the target entity type.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
activitypointer | Both
annotation | Both
contract | Both
incident | Both
invoice | Both
opportunity | Both
quote | Both
salesorder | Both
Rollup Types
The following table lists the available rollup types for each supported entity depending on the target of the rollup operation.
Supported entity | Target entity | Rollup type
activitypointer | account or contact | Related, Extended
activitypointer | opportunity | None
annotation | account or contact | Related, Extended, None
annotation | opportunity | Related, Extended, None
contract | account or contact | Related, Extended
incident | account or contact | Related
invoice | account or contact | Related, Extended
opportunity | account or contact | Related, Extended
quote | account or contact | Related, Extended
salesorder | account or contact | Related, Extended

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RollupRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RollupRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RollupResponse
Other Resources
Rollup Privileges
Sample: Rollup Records Related to a Specified Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RollupRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve all the entity records that are related to the specified record.

The following tables list the members exposed by the RollupRequest type.

Public Constructors

Name | Description
RollupRequest | Initializes a new instance of the RollupRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query criteria for the rollup operation. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RollupType | Gets or sets the rollup type. Required.
public property | Target | Gets or sets the target record for the rollup operation. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RollupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RollupResponse

Other Resources

Rollup Privileges
Sample: Rollup Records Related to a Specified Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RollupRequest Constructor
[image]

Initializes a new instance of the RollupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RollupRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RollupRequest Class
RollupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RollupRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RollupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RollupResponse

Other Resources

Rollup Privileges
Sample: Rollup Records Related to a Specified Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RollupRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query criteria for the rollup operation. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RollupType | Gets or sets the rollup type. Required.
public property | Target | Gets or sets the target record for the rollup operation. Required.

See Also

Reference

RollupRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RollupResponse

Other Resources

Rollup Privileges
Sample: Rollup Records Related to a Specified Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


RollupRequest.Query Property
[image]

Gets or sets the query criteria for the rollup operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query criteria for the rollup operation.

  Remarks
The query must specify entity names and a column set. If the column set includes attributes where IsValidForRead is false, they are ignored, and the message response contains no data for those attributes. For more information about field security, see How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RollupRequest Class
RollupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RollupRequest.RollupType Property
[image]

Gets or sets the rollup type. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RollupType As RollupType

C#
public RollupType RollupType { get; set; }

C++

J#

JScript

Property Value
Type: RollupType
The the rollup type. Use the RollupType enumeration for this property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RollupRequest Class
RollupRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RollupType


RollupRequest.Target Property
[image]

Gets or sets the target record for the rollup operation. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type EntityReference
The target record for the rollup operation, which must be an entity reference for an account, contact, or opportunity entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RollupRequest Class
RollupRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RollupResponse Class
See Also Members
[image]

Contains the response from the RollupRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RollupResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RollupResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RollupResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RollupResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleRequest


RollupResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RollupRequest class.

The following tables list the members exposed by the RollupResponse type.

Public Constructors

Name | Description
RollupResponse | Initializes a new instance of the RollupResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of records that are related to the specified record.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RollupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleRequest


RollupResponse Constructor
[image]

Initializes a new instance of the RollupResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RollupResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RollupResponse Class
RollupResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RollupResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RollupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleRequest


RollupResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of records that are related to the specified record.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RollupResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleRequest


RollupResponse.EntityCollection Property
[image]

Gets the collection of records that are related to the specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type:EntityCollection
The collection of records that are related to the specified record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RollupResponse Class
RollupResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RollupType Enumeration
[image]

Contains the possible values for the RollupType property in the RollupRequest class, which you use to retrieve all the entity records for a specified record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration RollupType

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum RollupType

C++

J#

JScript

  Members
Member name | Description
Extended | A rollup record that is directly related to a parent record and to any descendent record of a parent record, for example, children, grandchildren, and great-grandchildren records. Value = 2.
None | A rollup record is not requested. This member only retrieves the records that are directly related to a parent record. Value = 0.
Related | A rollup record that is directly related to a parent record and to any direct child of a parent record. Value = 1.
  Remarks
Used in the RollupType property.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace
RollupRequest
Other Resources
Entity Relationship Behavior


RouteToRequest Class
See Also Members
[image]

Contains the data that is needed to route a queue item to a queue, a user, or a team.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RouteToRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RouteToRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of the RouteToResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the QueueItem entity and access rights on the specified record in the QueueItemId property. For a complete list of the required privileges, see QueueItem Entity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.RouteToRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RouteToRequest Members
Microsoft.Crm.Sdk.Messages Namespace
RouteToResponse
Other Resources
QueueItem Entity Messages and Methods
QueueItem Entity Privileges


RouteToRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to route a queue item to a queue, a user, or a team.

The following tables list the members exposed by the RouteToRequest type.

Public Constructors

Name | Description
RouteToRequest | Initializes a new instance of the RouteToRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemId | Gets or sets the id of the queue item to route. Required
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record to route the queue item to. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RouteToRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RouteToResponse

Other Resources

QueueItem Entity Messages and Methods
QueueItem Entity Privileges


RouteToRequest Constructor
[image]

Initializes a new instance of the RouteToRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RouteToRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RouteToRequest Class
RouteToRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RouteToRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RouteToRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RouteToResponse

Other Resources

QueueItem Entity Messages and Methods
QueueItem Entity Privileges


RouteToRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueueItemId | Gets or sets the id of the queue item to route. Required
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target record to route the queue item to. Required.

See Also

Reference

RouteToRequest Class
Microsoft.Crm.Sdk.Messages Namespace
RouteToResponse

Other Resources

QueueItem Entity Messages and Methods
QueueItem Entity Privileges


RouteToRequest.QueueItemId Property
[image]

Gets or sets the id of the queue item to route. Required

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueueItemId As Guid

C#
public Guid QueueItemId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The QueueItem id. This corresponds to the QueueItem.QueueItemId attribute, which is the primary key for the QueueItem entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RouteToRequest Class
RouteToRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RouteToRequest.Target Property
[image]

Gets or sets the target record to route the queue item to. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target record to route the queue item to.

  Remarks
Queue items may be routed to a queue, a user, or a team

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RouteToRequest Class
RouteToRequest Members
Microsoft.Crm.Sdk.Messages Namespace


RouteToResponse Class
See Also Members
[image]

Contains the response from the RouteToRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class RouteToResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class RouteToResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.RouteToResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RouteToResponse Members
Microsoft.Crm.Sdk.Messages Namespace
RouteToRequest
Other Resources
QueueItem Entity Messages and Methods


RouteToResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RouteToRequest message.

The following tables list the members exposed by the RouteToResponse type.

Public Constructors

Name | Description
RouteToResponse | Initializes a new instance of the RouteToResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RouteToResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RouteToRequest

Other Resources

QueueItem Entity Messages and Methods


RouteToResponse Constructor
[image]

Initializes a new instance of the RouteToResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RouteToResponse ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RouteToResponse Class
RouteToResponse Members
Microsoft.Crm.Sdk.Messages Namespace


RouteToResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RouteToResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RouteToRequest

Other Resources

QueueItem Entity Messages and Methods


RouteToResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RouteToResponse Class
Microsoft.Crm.Sdk.Messages Namespace
RouteToRequest

Other Resources

QueueItem Entity Messages and Methods


SearchByBodyKbArticleRequest Class
See Also Example Members
[image]

Contains the data that is needed to search for knowledge base articles that contain the specified body text.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SearchByBodyKbArticleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SearchByBodyKbArticleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Create the request
SearchByBodyKbArticleRequest searchByBodyRequest =
    new SearchByBodyKbArticleRequest()
{
    SubjectId = _subjectId,
    UseInflection = true, // allows for a different tense or
    // inflection to be substituted for the search text
    SearchText = "contained", // will also match on 'contains'
    QueryExpression = new QueryExpression()
    {
        ColumnSet = new ColumnSet("articlexml"),
        EntityName = KbArticle.EntityLogicalName
    }
};

// Execute the request
Console.WriteLine("  Searching for published article with 'contained' in the body");

SearchByBodyKbArticleResponse seachByBodyResponse =
    (SearchByBodyKbArticleResponse)_context.Execute(searchByBodyRequest);

// Check success
var retrievedArticleBodies = seachByBodyResponse.EntityCollection.Entities
    .Select((entity) => ((KbArticle)entity).ArticleXml);

if (retrievedArticleBodies.Count() == 0)
    throw new Exception("No articles found");

Console.WriteLine("  Results of search (article bodies found):");
foreach (var body in retrievedArticleBodies)
    Console.WriteLine(body);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of SearchByBodyKbArticleResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the KbArticle and Subject entities. The caller must also have access rights on the record specified in the SubjectId property and on the records returned from the query. For a complete list of required privileges, see SearchByBodyKbArticle Privileges.
Notes for Callers
This message supports queries using Query Expression and FetchXML. For more information see Creating Queries to Retrieve Data.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SearchByBodyKbArticleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
SearchByBodyKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleResponse
Other Resources
Knowledge Base Entities
Subject Entity
Sample: Search and Retrieve Articles
SearchByBodyKbArticle Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByBodyKbArticleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to search for knowledge base articles that contain the specified body text.

The following tables list the members exposed by the SearchByBodyKbArticleRequest type.

Public Constructors

Name | Description
SearchByBodyKbArticleRequest | Initializes a new instance of the SearchByBodyKbArticleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryExpression | Gets or sets the query criteria to find knowledge base articles with specified body text. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SearchText | Gets or sets the text contained in the body of the article. Required.
public property | SubjectId | Gets or sets the ID of the knowledge base article subject. Required.
public property | UseInflection | Gets or sets a value that indicates whether to use inflectional stem matching when searching for knowledge base articles with a specified body text. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SearchByBodyKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleResponse

Other Resources

Knowledge Base Entities
Subject Entity
Sample: Search and Retrieve Articles
SearchByBodyKbArticle Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByBodyKbArticleRequest Constructor
[image]

Initializes a new instance of the SearchByBodyKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SearchByBodyKbArticleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByBodyKbArticleRequest Class
SearchByBodyKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByBodyKbArticleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SearchByBodyKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleResponse

Other Resources

Knowledge Base Entities
Subject Entity
Sample: Search and Retrieve Articles
SearchByBodyKbArticle Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByBodyKbArticleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryExpression | Gets or sets the query criteria to find knowledge base articles with specified body text. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SearchText | Gets or sets the text contained in the body of the article. Required.
public property | SubjectId | Gets or sets the ID of the knowledge base article subject. Required.
public property | UseInflection | Gets or sets a value that indicates whether to use inflectional stem matching when searching for knowledge base articles with a specified body text. Required.

See Also

Reference

SearchByBodyKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleResponse

Other Resources

Knowledge Base Entities
Subject Entity
Sample: Search and Retrieve Articles
SearchByBodyKbArticle Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByBodyKbArticleRequest.QueryExpression Property
[image]

Gets or sets the query criteria to find knowledge base articles with specified body text. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueryExpression As QueryBase

C#
public QueryBase QueryExpression { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query criteria to find knowledge base articles with specified body text.

  Remarks
Assign an instance of the class FetchExpression, QueryExpression or QueryByAttribute. The query must specify the entity name “kbarticle” and a ColumnSet. If the column set includes attributes that are not valid for retrieve or for which you do not have access, they will be ignored. For more information about field security, see How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByBodyKbArticleRequest Class
SearchByBodyKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Create Queries to Retrieve Data


SearchByBodyKbArticleRequest.SearchText Property
[image]

Gets or sets the text contained in the body of the article. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SearchText As String

C#
public string SearchText { get; set; }

C++

J#

JScript

Property Value
Type: String
The text contained in the body of the article.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByBodyKbArticleRequest Class
SearchByBodyKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByBodyKbArticleRequest.SubjectId Property
[image]

Gets or sets the ID of the knowledge base article subject. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SubjectId As Guid

C#
public Guid SubjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the knowledge base article subject. This corresponds to the Subject.SubjectId attribute, which is the primary key for the Subject entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByBodyKbArticleRequest Class
SearchByBodyKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByBodyKbArticleRequest.UseInflection Property
[image]

Gets or sets a value that indicates whether to use inflectional stem matching when searching for knowledge base articles with a specified body text. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UseInflection As Boolean

C#
public bool UseInflection { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to use inflectional stem matching when searching for knowledge base articles with a specified body text.
true, to use inflectional stem matching, otherwise, false.

  Remarks
In inflectional stem matching, you can use word “write” as an inflectional stem of “‘write”, “writing”, “wrote” and “written”.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByBodyKbArticleRequest Class
SearchByBodyKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByBodyKbArticleResponse Class
See Also Members
[image]

Contains the response from the SearchByBodyKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SearchByBodyKbArticleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SearchByBodyKbArticleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SearchByBodyKbArticleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByBodyKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleRequest


SearchByBodyKbArticleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SearchByBodyKbArticleRequest class.

The following tables list the members exposed by the SearchByBodyKbArticleResponse type.

Public Constructors

Name | Description
SearchByBodyKbArticleResponse | Initializes a new instance of the SearchByBodyKbArticleResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of knowledge base articles that contain the specified body text.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SearchByBodyKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleRequest


SearchByBodyKbArticleResponse Constructor
[image]

Initializes a new instance of the SearchByBodyKbArticleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SearchByBodyKbArticleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByBodyKbArticleResponse Class
SearchByBodyKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByBodyKbArticleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SearchByBodyKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleRequest


SearchByBodyKbArticleResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of knowledge base articles that contain the specified body text.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SearchByBodyKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleRequest


SearchByBodyKbArticleResponse.EntityCollection Property
[image]

Gets the collection of knowledge base articles that contain the specified body text.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of knowledge base articles that contain the specified body text.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByBodyKbArticleResponse Class
SearchByBodyKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByKeywordsKbArticleRequest Class
See Also Example Members
[image]

Contains the data that is needed to search for knowledge base articles that contain the specified keywords.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SearchByKeywordsKbArticleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SearchByKeywordsKbArticleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Create the request
SearchByKeywordsKbArticleRequest searchByKeywordRequest =
    new SearchByKeywordsKbArticleRequest()
{
    SubjectId = _subjectId,
    UseInflection = true,
    SearchText = "Search",
    QueryExpression = new QueryExpression()
    {
        ColumnSet = new ColumnSet("keywords"),
        EntityName = KbArticle.EntityLogicalName
    }
};

// Execute the request
Console.WriteLine();
Console.WriteLine("  Searching for published article with 'search' as a keyword");
var searchByKeywordResponse =
    (SearchByKeywordsKbArticleResponse)_context.Execute(searchByKeywordRequest);

// Check success
var retrievedArticleKeywords = searchByKeywordResponse.EntityCollection.Entities
    .Select((entity) => (KbArticle)entity);

if (retrievedArticleKeywords.Count() == 0)
    throw new Exception("No articles found");

Console.WriteLine("  Results of search (keywords found):");
foreach (var article in retrievedArticleKeywords)
    Console.WriteLine(article.KeyWords);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of SearchByKeywordsKbArticleResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the KbArticle and Subject entities. The caller must also have access rights on the record specified in the SubjectId property and on the records returned from the query. For a complete list of required privileges, see SearchByKeywordsKbArticle Privileges.
Notes for Callers
This message supports queries using Query Expression and FetchXML. For more information see Creating Queries to Retrieve Data.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SearchByKeywordsKbArticleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
SearchByKeywordsKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SearchByKeywordsKbArticleResponse
Other Resources
Knowledge Base Entities
Subject Entity
Sample: Search and Retrieve Articles
SearchByKeywordsKbArticle Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByKeywordsKbArticleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to search for knowledge base articles that contain the specified keywords.

The following tables list the members exposed by the SearchByKeywordsKbArticleRequest type.

Public Constructors

Name | Description
SearchByKeywordsKbArticleRequest | Initializes a new instance of the SearchByKeywordsKbArticleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryExpression | Gets or sets the query criteria to find knowledge base articles with specified keywords. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SearchText | Gets or sets the keywords in the article. Required.
public property | SubjectId | Gets or sets the ID of the knowledge base article subject. Required.
public property | UseInflection | Gets or sets a value that indicates whether to use inflectional stem matching when searching for knowledge base articles with the specified keywords. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SearchByKeywordsKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByKeywordsKbArticleResponse

Other Resources

Knowledge Base Entities
Subject Entity
Sample: Search and Retrieve Articles
SearchByKeywordsKbArticle Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByKeywordsKbArticleRequest Constructor
[image]

Initializes a new instance of the SearchByKeywordsKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SearchByKeywordsKbArticleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByKeywordsKbArticleRequest Class
SearchByKeywordsKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByKeywordsKbArticleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SearchByKeywordsKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByKeywordsKbArticleResponse

Other Resources

Knowledge Base Entities
Subject Entity
Sample: Search and Retrieve Articles
SearchByKeywordsKbArticle Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByKeywordsKbArticleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryExpression | Gets or sets the query criteria to find knowledge base articles with specified keywords. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SearchText | Gets or sets the keywords in the article. Required.
public property | SubjectId | Gets or sets the ID of the knowledge base article subject. Required.
public property | UseInflection | Gets or sets a value that indicates whether to use inflectional stem matching when searching for knowledge base articles with the specified keywords. Required.

See Also

Reference

SearchByKeywordsKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByKeywordsKbArticleResponse

Other Resources

Knowledge Base Entities
Subject Entity
Sample: Search and Retrieve Articles
SearchByKeywordsKbArticle Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByKeywordsKbArticleRequest.QueryExpression Property
[image]

Gets or sets the query criteria to find knowledge base articles with specified keywords. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueryExpression As QueryBase

C#
public QueryBase QueryExpression { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query criteria to find knowledge base articles with specified keywords.

  Remarks
Assign an instance of the class FetchExpression, QueryExpression or QueryByAttribute. The query must specify the entity name “kbarticle” and a ColumnSet. If the column set includes attributes that are not valid for retrieve or for which you do not have access, they will be ignored. For more information about field security, see How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByKeywordsKbArticleRequest Class
SearchByKeywordsKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Create Queries to Retrieve Data


SearchByKeywordsKbArticleRequest.SearchText Property
[image]

Gets or sets the keywords in the article. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SearchText As String

C#
public string SearchText { get; set; }

C++

J#

JScript

Property Value
Type: String
The keywords in the article.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByKeywordsKbArticleRequest Class
SearchByKeywordsKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByKeywordsKbArticleRequest.SubjectId Property
[image]

Gets or sets the ID of the knowledge base article subject. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SubjectId As Guid

C#
public Guid SubjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the knowledge base article subject. This corresponds to the Subject.SubjectId attribute, which is the primary key for the Subject entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByKeywordsKbArticleRequest Class
SearchByKeywordsKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByKeywordsKbArticleRequest.UseInflection Property
[image]

Gets or sets a value that indicates whether to use inflectional stem matching when searching for knowledge base articles with the specified keywords. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UseInflection As Boolean

C#
public bool UseInflection { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to use inflectional stem matching when searching for knowledge base articles with the specified keywords.
true, to use inflectional stem matching, otherwise, false.

  Remarks
In inflectional stem matching, you can use word “write” as an inflectional stem of “write”, “writing”, “wrote” and “written”.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByKeywordsKbArticleRequest Class
SearchByKeywordsKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByKeywordsKbArticleResponse Class
See Also Members
[image]

Contains the response from the SearchByKeywordsKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SearchByKeywordsKbArticleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SearchByKeywordsKbArticleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SearchByKeywordsKbArticleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByKeywordsKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SearchByKeywordsKbArticleRequest


SearchByKeywordsKbArticleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SearchByKeywordsKbArticleRequest class.

The following tables list the members exposed by the SearchByKeywordsKbArticleResponse type.

Public Constructors

Name | Description
SearchByKeywordsKbArticleResponse | Initializes a new instance of the SearchByKeywordsKbArticleResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of knowledge base articles that contain the specified keywords.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SearchByKeywordsKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByKeywordsKbArticleRequest


SearchByKeywordsKbArticleResponse Constructor
[image]

Initializes a new instance of the SearchByKeywordsKbArticleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SearchByKeywordsKbArticleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByKeywordsKbArticleResponse Class
SearchByKeywordsKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByKeywordsKbArticleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SearchByKeywordsKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByKeywordsKbArticleRequest


SearchByKeywordsKbArticleResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of knowledge base articles that contain the specified keywords.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SearchByKeywordsKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByKeywordsKbArticleRequest


SearchByKeywordsKbArticleResponse.EntityCollection Property
[image]

Gets the collection of knowledge base articles that contain the specified keywords.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of knowledge base articles that contain the specified keywords.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByKeywordsKbArticleResponse Class
SearchByKeywordsKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByTitleKbArticleRequest Class
See Also Example Members
[image]

Contains the data that is needed to search for knowledge base articles that contain the specified title.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SearchByTitleKbArticleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SearchByTitleKbArticleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// create the request
SearchByTitleKbArticleRequest searchByTitleRequest =
    new SearchByTitleKbArticleRequest()
{
    SubjectId = _subjectId,
    UseInflection = false,
    SearchText = "code",
    QueryExpression = new QueryExpression()
    {
        ColumnSet = new ColumnSet("title"),
        EntityName = KbArticle.EntityLogicalName
    }
};

// execute the request
Console.WriteLine();
Console.WriteLine("  Searching for published articles with 'code' in the title");
var searchByTitleResponse = (SearchByTitleKbArticleResponse)
    _context.Execute(searchByTitleRequest);

// check success
var retrievedArticles = searchByTitleResponse.EntityCollection.Entities
    .Select((entity) => (KbArticle)entity);
Console.WriteLine("  Results of search (titles found):");
foreach (var article in retrievedArticles)
    Console.WriteLine(article.Title);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the SearchByTitleKbArticleResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the KbArticle and Subject entities. The caller must also have access rights on the specified record in the SubjectId property and on the records that are returned from the query. For a complete list of the required privileges, see SearchByTitleKbArticle Privileges.
Notes for Callers
This message supports queries that use a query expression and FetchXML. For more information, see Creating Queries to Retrieve Data.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SearchByTitleKbArticleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
SearchByTitleKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleResponse
Other Resources
Knowledge Base Entities
Sample: Search and Retrieve Articles
SearchByTitleKbArticle Privileges
Subject Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByTitleKbArticleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to search for knowledge base articles that contain the specified title.

The following tables list the members exposed by the SearchByTitleKbArticleRequest type.

Public Constructors

Name | Description
SearchByTitleKbArticleRequest | Initializes a new instance of the SearchByTitleKbArticleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryExpression | Gets or sets the query criteria to find knowledge base articles with the specified title. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SearchText | Gets or sets the title in the articles. Required.
public property | SubjectId | Gets or sets the ID of the subject for the knowledge base article. Required.
public property | UseInflection | Gets or sets a value that indicates whether to use inflectional stem matching when you search for knowledge base articles by a specific title. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SearchByTitleKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleResponse

Other Resources

Knowledge Base Entities
Sample: Search and Retrieve Articles
SearchByTitleKbArticle Privileges
Subject Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByTitleKbArticleRequest Constructor
[image]

Initializes a new instance of the SearchByTitleKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SearchByTitleKbArticleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByTitleKbArticleRequest Class
SearchByTitleKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByTitleKbArticleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SearchByTitleKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleResponse

Other Resources

Knowledge Base Entities
Sample: Search and Retrieve Articles
SearchByTitleKbArticle Privileges
Subject Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByTitleKbArticleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryExpression | Gets or sets the query criteria to find knowledge base articles with the specified title. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SearchText | Gets or sets the title in the articles. Required.
public property | SubjectId | Gets or sets the ID of the subject for the knowledge base article. Required.
public property | UseInflection | Gets or sets a value that indicates whether to use inflectional stem matching when you search for knowledge base articles by a specific title. Required.

See Also

Reference

SearchByTitleKbArticleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByBodyKbArticleResponse

Other Resources

Knowledge Base Entities
Sample: Search and Retrieve Articles
SearchByTitleKbArticle Privileges
Subject Entity
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SearchByTitleKbArticleRequest.QueryExpression Property
[image]

Gets or sets the query criteria to find knowledge base articles with the specified title. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueryExpression As QueryBase

C#
public QueryBase QueryExpression { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query criteria to find knowledge base articles with the specified title.

  Remarks
Assign an instance of the FetchExpression, QueryExpression, or QueryByAttribute class. The query must specify the entity name “kbarticle” and a column set. If the column set includes attributes where IsValidForRead is false or for which you do not have access, they are ignored, and the message response contains no data for those attributes. For more information about field security, see How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByTitleKbArticleRequest Class
SearchByTitleKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Create Queries to Retrieve Data


SearchByTitleKbArticleRequest.SearchText Property
[image]

Gets or sets the title in the articles. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SearchText As String

C#
public string SearchText { get; set; }

C++

J#

JScript

Property Value
Type: String
The title of the article.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByTitleKbArticleRequest Class
SearchByTitleKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByTitleKbArticleRequest.SubjectId Property
[image]

Gets or sets the ID of the subject for the knowledge base article. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SubjectId As Guid

C#
public Guid SubjectId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the knowledge base article subject. This corresponds to the Subject.SubjectId attribute, which is the primary key for the Subject entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByTitleKbArticleRequest Class
SearchByTitleKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByTitleKbArticleRequest.UseInflection Property
[image]

Gets or sets a value that indicates whether to use inflectional stem matching when you search for knowledge base articles by a specific title. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UseInflection As Boolean

C#
public bool UseInflection { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to use inflectional stem matching when searching for knowledge base articles with a specified title.
true, to use inflectional stem matching, otherwise, false.

  Remarks
In inflectional stem matching, you can use the word “write” as an inflectional stem of “write”, “writing”, “wrote”, and “written”.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByTitleKbArticleRequest Class
SearchByTitleKbArticleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByTitleKbArticleResponse Class
See Also Members
[image]

Contains the response from the SearchByTitleKbArticleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SearchByTitleKbArticleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SearchByTitleKbArticleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SearchByTitleKbArticleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByTitleKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SearchByTitleKbArticleRequest


SearchByTitleKbArticleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SearchByTitleKbArticleRequest class.

The following tables list the members exposed by the SearchByTitleKbArticleResponse type.

Public Constructors

Name | Description
SearchByTitleKbArticleResponse | Initializes a new instance of the SearchByTitleKbArticleResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of knowledge base articles that contain the specified title.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SearchByTitleKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByTitleKbArticleRequest


SearchByTitleKbArticleResponse Constructor
[image]

Initializes a new instance of the SearchByTitleKbArticleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SearchByTitleKbArticleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByTitleKbArticleResponse Class
SearchByTitleKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SearchByTitleKbArticleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SearchByTitleKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByTitleKbArticleRequest


SearchByTitleKbArticleResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of knowledge base articles that contain the specified title.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SearchByTitleKbArticleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchByTitleKbArticleRequest


SearchByTitleKbArticleResponse.EntityCollection Property
[image]

Gets the collection of knowledge base articles that contain the specified title.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of knowledge base articles that contain the specified title.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchByTitleKbArticleResponse Class
SearchByTitleKbArticleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SearchDirection Enumeration
[image]

Contains the possible values for the search direction in an appointment request.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration SearchDirection

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum SearchDirection

C++

J#

JScript

  Members
Member name | Description
Backward | Search backward in the calendar. Value = 1.
Forward | Search forward in the calendar. Value = 0.
  Remarks
This enumeration is used for the AppointmentRequest Direction property.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace


SearchRequest Class
See Also Example Members
[image]

Contains the data needed to search for available time slots that fulfill the specified appointment request.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SearchRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SearchRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create the van required resource object.
RequiredResource vanReq = new RequiredResource
{
    ResourceId = _vanId,
    ResourceSpecId = _specId
};

// Create the appointment request.
AppointmentRequest appointmentReq = new AppointmentRequest
{
    RequiredResources = new RequiredResource[] { vanReq },
    Direction = SearchDirection.Backward,
    Duration = 60,
    NumberOfResults = 10,
    ServiceId = _plumberServiceId,
    // The search window describes the time when the resouce can be scheduled.
    // It must be set.
    SearchWindowStart = DateTime.Now.ToUniversalTime(),
    SearchWindowEnd = DateTime.Now.AddDays(7).ToUniversalTime(),
    UserTimeZoneCode = 1
};

// Verify whether there are openings available to schedule the appointment using this resource
SearchRequest search = new SearchRequest
{
    AppointmentRequest = appointmentReq
};
SearchResponse searched = (SearchResponse)_serviceProxy.Execute(search);

if (searched.SearchResults.Proposals.Length > 0)
{
    Console.WriteLine("Openings are available to schedule the resource.");
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Pass an instance of this class to the Execute method, which returns an instance of  SearchResponse.
Privileges and Access Rights
For a list of the privileges required, see Search Privileges.
Notes for Callers
This message will return a set of available appointments as time blocks.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SearchRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
SearchRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SearchResponse
Other Resources
Schedules in Microsoft Dynamics CRM
Sample: Schedule a Resource
Appointment Entity Messages and Methods


SearchRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to search for available time slots that fulfill the specified appointment request.

The following tables list the members exposed by the SearchRequest type.

Public Constructors

Name | Description
SearchRequest | Initializes a new instance of the SearchRequest class.
Top

Public Properties

 | Name | Description
public property | AppointmentRequest | Gets or sets the appointment request.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SearchRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchResponse

Other Resources

Schedules in Microsoft Dynamics CRM
Sample: Schedule a Resource
Appointment Entity Messages and Methods


SearchRequest Constructor
[image]

Initializes a new instance of the SearchRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SearchRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchRequest Class
SearchRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SearchRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchResponse

Other Resources

Schedules in Microsoft Dynamics CRM
Sample: Schedule a Resource
Appointment Entity Messages and Methods


SearchRequest Properties
[image]

Public Properties

 | Name | Description
public property | AppointmentRequest | Gets or sets the appointment request.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

SearchRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SearchResponse

Other Resources

Schedules in Microsoft Dynamics CRM
Sample: Schedule a Resource
Appointment Entity Messages and Methods


SearchRequest.AppointmentRequest Property
[image]

Gets or sets the appointment request.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AppointmentRequest As AppointmentRequest

C#
public AppointmentRequest AppointmentRequest { get; set; }

C++

J#

JScript

Property Value
Type: AppointmentRequest
The appointment request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchRequest Class
SearchRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SearchResponse Class
See Also Members
[image]

Contains the response from the SearchRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SearchResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SearchResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SearchResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest


SearchResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SearchRequest class.

The following tables list the members exposed by the SearchResponse type.

Public Constructors

Name | Description
SearchResponse | Initializes a new instance of the SearchResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SearchResults | Gets the results of the search.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SearchResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest


SearchResponse Constructor
[image]

Initializes a new instance of the SearchResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SearchResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchResponse Class
SearchResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SearchResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SearchResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest


SearchResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | SearchResults | Gets the results of the search.

See Also

Reference

SearchResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SearchRequest


SearchResponse.SearchResults Property
[image]

Gets the results of the search.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property SearchResults As SearchResults

C#
public SearchResults SearchResults { get; }

C++

J#

JScript

Property Value
Type: SearchResults
The results of the search.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchResponse Class
SearchResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SearchResults Class
See Also Members
[image]

Contains the results from the SearchRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SearchResults
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SearchResults : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.SearchResults
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchResults Members
Microsoft.Crm.Sdk.Messages Namespace
SearchResults
Other Resources
Sample: Schedule a Resource


SearchResults Members
See Also Constructors Methods Properties
[image]

Contains the results from the SearchRequest message.

The following tables list the members exposed by the SearchResults type.

Public Constructors

Name | Description
SearchResults | Overloaded. Initializes a new instance of the SearchResults class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Proposals | Gets the set of proposed appointments that meet the appointment request criteria.
public property | TraceInfo | Gets information regarding the results of the search.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SearchResults Class
Microsoft.Crm.Sdk.Messages Namespace
SearchResults

Other Resources

Sample: Schedule a Resource


SearchResults Constructor
[image]

Initializes a new instance of the SearchResults class.

Overload List

Name | Description
SearchResults () | Initializes a new instance of the SearchResults class.
SearchResults (AppointmentProposal[], TraceInfo) | Initializes a new instance of the SearchResults class setting the proposals and trace info properties.

See Also

Reference

SearchResults Class
SearchResults Members
Microsoft.Crm.Sdk.Messages Namespace


SearchResults Constructor ()
[image]

Initializes a new instance of the SearchResults class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SearchResults ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchResults Class
SearchResults Members
Microsoft.Crm.Sdk.Messages Namespace


SearchResults Constructor (AppointmentProposal[], TraceInfo)
[image]

Initializes a new instance of the SearchResults class setting the proposals and trace info properties.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    proposals As AppointmentProposal(), _
    traceInfo As TraceInfo _
)

C#
public SearchResults (
    AppointmentProposal[] proposals,
    TraceInfo traceInfo
)

C++

J#

JScript

Parameters
proposals
The set of proposed appointments that meet the appointment request criteria.
traceInfo
The results of the search.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchResults Class
SearchResults Members
Microsoft.Crm.Sdk.Messages Namespace


SearchResults Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SearchResults Class
Microsoft.Crm.Sdk.Messages Namespace
SearchResults

Other Resources

Sample: Schedule a Resource


SearchResults Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Proposals | Gets the set of proposed appointments that meet the appointment request criteria.
public property | TraceInfo | Gets information regarding the results of the search.

See Also

Reference

SearchResults Class
Microsoft.Crm.Sdk.Messages Namespace
SearchResults

Other Resources

Sample: Schedule a Resource


SearchResults.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The the structure that contains extra data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchResults Class
SearchResults Members
Microsoft.Crm.Sdk.Messages Namespace


SearchResults.Proposals Property
[image]

Gets the set of proposed appointments that meet the appointment request criteria.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Proposals As AppointmentProposal()

C#
[DataMemberAttribute]
public AppointmentProposal[] Proposals { get; set; }

C++

J#

JScript

Property Value
Type: AppointmentProposal
The set of proposed appointments that meet the appointment request criteria.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchResults Class
SearchResults Members
Microsoft.Crm.Sdk.Messages Namespace


SearchResults.TraceInfo Property
[image]

Gets information regarding the results of the search.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TraceInfo As TraceInfo

C#
[DataMemberAttribute]
public TraceInfo TraceInfo { get; set; }

C++

J#

JScript

Property Value
Type: TraceInfo
The information regarding the results of the search.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SearchResults Class
SearchResults Members
Microsoft.Crm.Sdk.Messages Namespace


SendBulkMailRequest Class
See Also Members
[image]

Contains the data that is needed to send bulk email messages.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendBulkMailRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendBulkMailRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of SendBulkMailResponse.
Privileges and Access Rights

                        To perform this action, the caller must have privileges on the Template entity and access rights on the record specified in the TemplateId property. For a list of the privileges required, see SendBulkMail Privileges.
Notes for Callers
To specify the tracking parameter, set the RequestId property as follows:
    Copy Code
request.RequestId = trackingId;

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SendBulkMailRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
SendBulkMailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SendBulkMailResponse
Other Resources
E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


SendBulkMailRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to send bulk email messages.

The following tables list the members exposed by the SendBulkMailRequest type.

Public Constructors

Name | Description
SendBulkMailRequest | Initializes a new instance of theSendBulkMailRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query to retrieve the recipients for the email messages.
public property | RegardingId | Gets or sets the ID of the record with which the email messages are associated.
public property | RegardingType | Gets or sets the type of the record with which the email messages are associated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Sender | Gets or sets the sender of the email messages.
public property | TemplateId | Gets or sets the ID of the email template to use.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendBulkMailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendBulkMailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


SendBulkMailRequest Constructor
[image]

Initializes a new instance of theSendBulkMailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendBulkMailRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendBulkMailRequest Class
SendBulkMailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendBulkMailRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendBulkMailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendBulkMailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


SendBulkMailRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query to retrieve the recipients for the email messages.
public property | RegardingId | Gets or sets the ID of the record with which the email messages are associated.
public property | RegardingType | Gets or sets the type of the record with which the email messages are associated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Sender | Gets or sets the sender of the email messages.
public property | TemplateId | Gets or sets the ID of the email template to use.

See Also

Reference

SendBulkMailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendBulkMailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


SendBulkMailRequest.Query Property
[image]

Gets or sets the query to retrieve the recipients for the email messages.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query to retrieve the recipients for the email messages.

  Remarks

                        The query must specify entity names and a column set. If the column set includes attributes that are not valid for retrieve or that you do not have access to, they will be ignored.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendBulkMailRequest Class
SendBulkMailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Create Queries to Retrieve Data


SendBulkMailRequest.RegardingId Property
[image]

Gets or sets the ID of the record with which the email messages are associated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingId As Guid

C#
public Guid RegardingId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the record with which the email messages are associated.

  Remarks
The RegardingId property is the ID of record that is valid for the Email.RegardingObjectId property. The RegardingType property must contain the logical name of the entity type for this record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendBulkMailRequest Class
SendBulkMailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendBulkMailRequest.RegardingType Property
[image]

Gets or sets the type of the record with which the email messages are associated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingType As String

C#
public string RegardingType { get; set; }

C++

J#

JScript

Property Value
Type: String
The type of the record with which the email messages are associated.

  Remarks
The RegardingType property is the logical entity name of the record specified in the RegardingId property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendBulkMailRequest Class
SendBulkMailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendBulkMailRequest.Sender Property
[image]

Gets or sets the sender of the email messages.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Sender As EntityReference

C#
public EntityReference Sender { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The sender of the email messages.

  Remarks
The Sender property contains the ID of record and the logical name of an entity. This must be a system user record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendBulkMailRequest Class
SendBulkMailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendBulkMailRequest.TemplateId Property
[image]

Gets or sets the ID of the email template to use.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the email template to use. This corresponds to the Template.TemplateId attribute, which is the primary key for the Template entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendBulkMailRequest Class
SendBulkMailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendBulkMailResponse Class
See Also Members
[image]

Contains the response from the SendBulkMailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendBulkMailResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendBulkMailResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SendBulkMailResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendBulkMailResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SendBulkMailRequest


SendBulkMailResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SendBulkMailRequest class.

The following tables list the members exposed by the SendBulkMailResponse type.

Public Constructors

Name | Description
SendBulkMailResponse | Initializes a new instance of the SendBulkMailResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendBulkMailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendBulkMailRequest


SendBulkMailResponse Constructor
[image]

Initializes a new instance of the SendBulkMailResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendBulkMailResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendBulkMailResponse Class
SendBulkMailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SendBulkMailResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendBulkMailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendBulkMailRequest


SendBulkMailResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SendBulkMailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendBulkMailRequest


SendEmailFromTemplateRequest Class
See Also Example Members
[image]

Contains the data that is needed to send an email message using a template.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendEmailFromTemplateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendEmailFromTemplateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Create the 'From:' activity party for the email
ActivityParty fromParty = new ActivityParty
{
    PartyId = new EntityReference(SystemUser.EntityLogicalName, _userId)
};

// Create the 'To:' activity party for the email
ActivityParty toParty = new ActivityParty
{
    PartyId = new EntityReference(Contact.EntityLogicalName, _contactId)
};

Console.WriteLine("Created activity parties.");

// Create an e-mail message.
Email email = new Email
{
    To = new ActivityParty[] { toParty },
    From = new ActivityParty[] { fromParty },
    Subject = "SDK Sample e-mail",
    Description = "SDK Sample for SendEmailFromTemplate Message.",
    DirectionCode = true
};

//Create a query expression to get one of Email Template of type "contact"

QueryExpression queryBuildInTemplates = new QueryExpression{
    EntityName = "template",
    ColumnSet = new ColumnSet("templateid", "templatetypecode"),
    Criteria = new FilterExpression()
};
queryBuildInTemplates.Criteria.AddCondition("templatetypecode",
    ConditionOperator.Equal, "contact");
EntityCollection templateEntityCollection = _serviceProxy.RetrieveMultiple(queryBuildInTemplates);

if (templateEntityCollection.Entities.Count > 0)
{
    _templateId = (Guid)templateEntityCollection.Entities[0].Attributes["templateid"];
}
else
{
    throw new ArgumentException("Standard Email Templates are missing");
}

// Create the request
SendEmailFromTemplateRequest emailUsingTemplateReq = new SendEmailFromTemplateRequest
{
    Target = email,

    // Use a built-in Email Template of type "contact".
    TemplateId = _templateId,

    // The regarding Id is required, and must be of the same type as the Email Template.
    RegardingId = _contactId,
    RegardingType = Contact.EntityLogicalName
};

SendEmailFromTemplateResponse emailUsingTemplateResp = (SendEmailFromTemplateResponse)_serviceProxy.Execute(emailUsingTemplateReq);

// Verify that the e-mail has been created
_emailId = emailUsingTemplateResp.Id;
if (!_emailId.Equals(Guid.Empty))
{
    Console.WriteLine("Successfully sent an e-mail message using the template.");
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of SendEmailFromTemplateResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Email entity and access rights on the records specified in the Target, RegardingId and TemplateId properties. For a complete list of the privileges required, see SendEmailFromTemplate Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SendEmailFromTemplateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
SendEmailFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SendEmailFromTemplateResponse
Other Resources
E-mail Activity Entities
Email (E-mail) Entity Messages and Methods
Sample: Send an E-mail Using a Template


SendEmailFromTemplateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to send an email message using a template.

The following tables list the members exposed by the SendEmailFromTemplateRequest type.

Public Constructors

Name | Description
SendEmailFromTemplateRequest | Initializes a new instance of theSendEmailFromTemplateRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RegardingId | Gets or sets the ID of the record with which the email message is associated.
public property | RegardingType | Gets or sets the type of the record with which the email message is associated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the email record to send.
public property | TemplateId | Gets or sets the ID of the email template to use for the email.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendEmailFromTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendEmailFromTemplateResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods
Sample: Send an E-mail Using a Template


SendEmailFromTemplateRequest Constructor
[image]

Initializes a new instance of theSendEmailFromTemplateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendEmailFromTemplateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplateRequest Class
SendEmailFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailFromTemplateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendEmailFromTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendEmailFromTemplateResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods
Sample: Send an E-mail Using a Template


SendEmailFromTemplateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RegardingId | Gets or sets the ID of the record with which the email message is associated.
public property | RegardingType | Gets or sets the type of the record with which the email message is associated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the email record to send.
public property | TemplateId | Gets or sets the ID of the email template to use for the email.

See Also

Reference

SendEmailFromTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendEmailFromTemplateResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods
Sample: Send an E-mail Using a Template


SendEmailFromTemplateRequest.RegardingId Property
[image]

Gets or sets the ID of the record with which the email message is associated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingId As Guid

C#
public Guid RegardingId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the record with which the email message is associated.

  Remarks
The RegardingId property is the ID of a record that is valid for the Email.RegardingObjectId attribute. The RegardingType property must contain the logical name of the entity type for this record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplateRequest Class
SendEmailFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailFromTemplateRequest.RegardingType Property
[image]

Gets or sets the type of the record with which the email message is associated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingType As String

C#
public string RegardingType { get; set; }

C++

J#

JScript

Property Value
Type: String
The type of the record with which the email message is associated.

  Remarks
This must be the logical name of the entity represented by the RegardingId property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplateRequest Class
SendEmailFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailFromTemplateRequest.Target Property
[image]

Gets or sets the email record to send.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The the email record to send. This is an instance of an Email entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplateRequest Class
SendEmailFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailFromTemplateRequest.TemplateId Property
[image]

Gets or sets the ID of the email template to use for the email.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the email template to use for the email. This corresponds to the Template.TemplateId attribute, which is the primary key for the Template entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplateRequest Class
SendEmailFromTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailFromTemplateResponse Class
See Also Members
[image]

Contains the response from the SendEmailFromTemplateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendEmailFromTemplateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendEmailFromTemplateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SendEmailFromTemplateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SendEmailFromTemplateRequest


SendEmailFromTemplateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SendEmailFromTemplateRequest class.

The following tables list the members exposed by the SendEmailFromTemplateResponse type.

Public Constructors

Name | Description
SendEmailFromTemplateResponse | Initializes a new instance of the SendEmailFromTemplateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets the ID of the email record that was sent.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendEmailFromTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendEmailFromTemplateRequest


SendEmailFromTemplateResponse Constructor
[image]

Initializes a new instance of the SendEmailFromTemplateResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendEmailFromTemplateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplateResponse Class
SendEmailFromTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailFromTemplateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendEmailFromTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendEmailFromTemplateRequest


SendEmailFromTemplateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Id | Gets the ID of the email record that was sent.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SendEmailFromTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendEmailFromTemplateRequest


SendEmailFromTemplateResponse.Id Property
[image]

Gets the ID of the email record that was sent.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Id As Guid

C#
public Guid Id { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the email record that was sent. This corresponds to the Email.EmailId property, which is the primary key for the Email entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplateResponse Class
SendEmailFromTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailRequest Class
See Also Members
[image]

Contains the data that is needed to send an email message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendEmailRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendEmailRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of SendEmailResponse.
Privileges and Access Rights

                        To perform this action, the caller must have privileges on the Email entity and access rights on the record specified in the EmailId property.  For a list of the privileges required, see SendEmail Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SendEmailRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SendEmailResponse
Other Resources
E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


SendEmailRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to send an email message.

The following tables list the members exposed by the SendEmailRequest type.

Public Constructors

Name | Description
SendEmailRequest | Initializes a new instance of the SendEmailRequest class.
Top

Public Properties

 | Name | Description
public property | EmailId | Gets or sets the ID of the email to send.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IssueSend | Gets or sets whether to send the email, or to just record it as sent.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TrackingToken | Gets or sets the tracking token.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


SendEmailRequest Constructor
[image]

Initializes a new instance of the SendEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendEmailRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailRequest Class
SendEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


SendEmailRequest Properties
[image]

Public Properties

 | Name | Description
public property | EmailId | Gets or sets the ID of the email to send.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IssueSend | Gets or sets whether to send the email, or to just record it as sent.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TrackingToken | Gets or sets the tracking token.

See Also

Reference

SendEmailRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendEmailResponse

Other Resources

E-mail Activity Entities
Email (E-mail) Entity Messages and Methods


SendEmailRequest.EmailId Property
[image]

Gets or sets the ID of the email to send.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EmailId As Guid

C#
public Guid EmailId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the email to send, which corresponds to the Email.EmailId attribute, which is the primary key for the Email entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailRequest Class
SendEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailRequest.IssueSend Property
[image]

Gets or sets whether to send the email, or to just record it as sent.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IssueSend As Boolean

C#
public bool IssueSend { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the email should be sent; otherwise, false, just record it as sent.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailRequest Class
SendEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailRequest.TrackingToken Property
[image]

Gets or sets the tracking token.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TrackingToken As String

C#
public string TrackingToken { get; set; }

C++

J#

JScript

Property Value
Type: StringThe tracking token, which is used to correlate an email with a context.

  Remarks
You can generate a tracking token with the GetTrackingTokenEmailRequest message. If this property is unspecified it defaults to null. In this case, the SendEmailRequest message generates a tracking token automatically.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailRequest Class
SendEmailRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailResponse Class
See Also Members
[image]

Contains the response from the BackgroundSendEmailRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendEmailResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendEmailResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SendEmailResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailRequest


SendEmailResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the BackgroundSendEmailRequest class.

The following tables list the members exposed by the SendEmailResponse type.

Public Constructors

Name | Description
SendEmailResponse | Initializes a new instance of the SendEmailResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Subject | Gets the subject line for the email message.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailRequest


SendEmailResponse Constructor
[image]

Initializes a new instance of the SendEmailResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendEmailResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailResponse Class
SendEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SendEmailResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailRequest


SendEmailResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Subject | Gets the subject line for the email message.

See Also

Reference

SendEmailResponse Class
Microsoft.Crm.Sdk.Messages Namespace
BackgroundSendEmailRequest


SendEmailResponse.Subject Property
[image]

Gets the subject line for the email message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Subject As String

C#
public string Subject { get; }

C++

J#

JScript

Property Value
Type: String
The subject line for the email message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailResponse Class
SendEmailResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SendFaxRequest Class
See Also Members
[image]

Contains the data that is needed to send a fax.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendFaxRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendFaxRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute method, which returns an instance of SendFaxResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Email entity and access rights on the record specified in the FaxId property.  For a list of the privileges required, see SendFax Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SendFaxRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendFaxRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SendFaxResponse
Other Resources
E-mail Activity Entities
Fax Entity Messages and Methods


SendFaxRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to send a fax.

The following tables list the members exposed by the SendFaxRequest type.

Public Constructors

Name | Description
SendFaxRequest | Initializes a new instance of theSendFaxRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FaxId | Gets or sets the ID of the fax to send.
public property | IssueSend | Gets or sets whether to send the e-mail, or to just record it as sent.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendFaxRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendFaxResponse

Other Resources

E-mail Activity Entities
Fax Entity Messages and Methods


SendFaxRequest Constructor
[image]

Initializes a new instance of theSendFaxRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendFaxRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendFaxRequest Class
SendFaxRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendFaxRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendFaxRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendFaxResponse

Other Resources

E-mail Activity Entities
Fax Entity Messages and Methods


SendFaxRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FaxId | Gets or sets the ID of the fax to send.
public property | IssueSend | Gets or sets whether to send the e-mail, or to just record it as sent.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

SendFaxRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendFaxResponse

Other Resources

E-mail Activity Entities
Fax Entity Messages and Methods


SendFaxRequest.FaxId Property
[image]

Gets or sets the ID of the fax to send.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FaxId As Guid

C#
public Guid FaxId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the fax to send. This corresponds to the Fax.FaxId attribute, which is the primary key for the Fax entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendFaxRequest Class
SendFaxRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendFaxRequest.IssueSend Property
[image]

Gets or sets whether to send the e-mail, or to just record it as sent.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IssueSend As Boolean

C#
public bool IssueSend { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to send the e-mail, or to just record it as sent.
true, to send the e-mail, otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendFaxRequest Class
SendFaxRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendFaxResponse Class
See Also Members
[image]

Contains the response from the SendFaxRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendFaxResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendFaxResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SendFaxResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendFaxResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SendFaxRequest


SendFaxResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SendFaxRequest class.

The following tables list the members exposed by the SendFaxResponse type.

Public Constructors

Name | Description
SendFaxResponse | Initializes a new instance of the SendFaxResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendFaxResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendFaxRequest


SendFaxResponse Constructor
[image]

Initializes a new instance of the SendFaxResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendFaxResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendFaxResponse Class
SendFaxResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SendFaxResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendFaxResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendFaxRequest


SendFaxResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SendFaxResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendFaxRequest


SendTemplateRequest Class
See Also Members
[image]

Contains the data that is needed to send a bulk email message that is created from a template.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendTemplateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendTemplateRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of the SendTemplateResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Template entity and access rights on the specified record in the TemplateId property. For a list of the required privileges, see SendTemplate Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SendTemplateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SendTemplateResponse
Other Resources
E-mail Activity Entities
Template (e-mail template) Entity Messages and Methods


SendTemplateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to send a bulk email message that is created from a template.

The following tables list the members exposed by the SendTemplateRequest type.

Public Constructors

Name | Description
SendTemplateRequest | Initializes a new instance of the SendTemplateRequest class.
Top

Public Properties

 | Name | Description
public property | DeliveryPriorityCode | Gets or sets the delivery priority code for the email.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RecipientIds | Gets or sets the array that contains the list of recipients for the email. Required.
public property | RecipientType | Gets or sets the type of entity that is represented by the list of recipients. Required.
public property | RegardingId | Gets or sets the ID of a record that the email is regarding. Required.
public property | RegardingType | Gets or sets the type of entity that is represented by the regarding ID. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Sender | Gets or sets the sender of the email.
public property | TemplateId | Gets or sets the ID of the template to be used for the email. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendTemplateResponse

Other Resources

E-mail Activity Entities
Template (e-mail template) Entity Messages and Methods


SendTemplateRequest Constructor
[image]

Initializes a new instance of the SendTemplateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendTemplateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateRequest Class
SendTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendTemplateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendTemplateResponse

Other Resources

E-mail Activity Entities
Template (e-mail template) Entity Messages and Methods


SendTemplateRequest Properties
[image]

Public Properties

 | Name | Description
public property | DeliveryPriorityCode | Gets or sets the delivery priority code for the email.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RecipientIds | Gets or sets the array that contains the list of recipients for the email. Required.
public property | RecipientType | Gets or sets the type of entity that is represented by the list of recipients. Required.
public property | RegardingId | Gets or sets the ID of a record that the email is regarding. Required.
public property | RegardingType | Gets or sets the type of entity that is represented by the regarding ID. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Sender | Gets or sets the sender of the email.
public property | TemplateId | Gets or sets the ID of the template to be used for the email. Required.

See Also

Reference

SendTemplateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SendTemplateResponse

Other Resources

E-mail Activity Entities
Template (e-mail template) Entity Messages and Methods


SendTemplateRequest.DeliveryPriorityCode Property
[image]

Gets or sets the delivery priority code for the email.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DeliveryPriorityCode As OptionSetValue

C#
public OptionSetValue DeliveryPriorityCode { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
.

  Remarks
Used the same way as Email.PriorityCode, which specifies the priority so that preferred customers or critical issues are handled quickly. You can use the helper code enumeration EmailPriorityCode to get or set this value. More information:Helper Code: Enumerations for Option Sets

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateRequest Class
SendTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendTemplateRequest.RecipientIds Property
[image]

Gets or sets the array that contains the list of recipients for the email. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RecipientIds As Guid()

C#
public Guid[] RecipientIds { get; set; }

C++

J#

JScript

Property Value
Type: Guid[]

The array of recipients for the email. The recipients must be of the same entity type that is specified in the RecipientType property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateRequest Class
SendTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendTemplateRequest.RecipientType Property
[image]

Gets or sets the type of entity that is represented by the list of recipients. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RecipientType As String

C#
public string RecipientType { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the entity that is represented by the list of recipients. Set this property to the name of the entity type for the recipient list that is specified in the RecipientIds property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateRequest Class
SendTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendTemplateRequest.RegardingId Property
[image]

Gets or sets the ID of a record that the email is regarding. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingId As Guid

C#
public Guid RegardingId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of a record that the email is regarding. This property is the ID of a record that is valid for the Email.RegardingObjectId attribute. The RegardingType property must contain the logical name of the entity type for this record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateRequest Class
SendTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendTemplateRequest.RegardingType Property
[image]

Gets or sets the type of entity that is represented by the regarding ID. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegardingType As String

C#
public string RegardingType { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of entity that is represented by the regarding ID. This property is the logical entity name of the record that is specified in the RegardingId property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateRequest Class
SendTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendTemplateRequest.Sender Property
[image]

Gets or sets the sender of the email.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Sender As EntityReference

C#
public EntityReference Sender { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The sender of the email. The Sender property contains the ID of a record and an entity type. The return value of this property must be a system user.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateRequest Class
SendTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendTemplateRequest.TemplateId Property
[image]

Gets or sets the ID of the template to be used for the email. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TemplateId As Guid

C#
public Guid TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the template to be used for the email, which corresponds to the Template.TemplateId attribute, which is the primary key for the Template entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateRequest Class
SendTemplateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SendTemplateResponse Class
See Also Members
[image]

Contains the response from the SendTemplateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SendTemplateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SendTemplateResponse : OrganizationResponse

C++

J#

JScript

  Remarks
There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SendTemplateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SendTemplateRequest


SendTemplateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SendTemplateRequest class.

The following tables list the members exposed by the SendTemplateResponse type.

Public Constructors

Name | Description
SendTemplateResponse | Initializes a new instance of the SendTemplateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendTemplateRequest


SendTemplateResponse Constructor
[image]

Initializes a new instance of the SendTemplateResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendTemplateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendTemplateResponse Class
SendTemplateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SendTemplateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendTemplateRequest


SendTemplateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SendTemplateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SendTemplateRequest


SetBusinessEquipmentRequest Class
See Also Members
[image]

Contains the data that is needed to assign equipment (facility/equipment) to a specific business unit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetBusinessEquipmentRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetBusinessEquipmentRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  SetBusinessEquipmentResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Equipment entity and access rights on the records specified in the BusinessUnitId and EquipmentId properties.  For a list of the privileges required, see SetBusinessEquipment Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SetBusinessEquipmentRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessEquipmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessEquipmentResponse
Other Resources
Resource Entities
Equipment (Facility/Equipment) Entity Messages and Methods


SetBusinessEquipmentRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to assign equipment (facility/equipment) to a specific business unit.

The following tables list the members exposed by the SetBusinessEquipmentRequest type.

Public Constructors

Name | Description
SetBusinessEquipmentRequest | Initializes a new instance of the SetBusinessEquipmentRequest class.
Top

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets or sets the ID of the business unit.
public property | EquipmentId | Gets or sets the ID of the equipment (facility/equipment).
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetBusinessEquipmentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessEquipmentResponse

Other Resources

Resource Entities
Equipment (Facility/Equipment) Entity Messages and Methods


SetBusinessEquipmentRequest Constructor
[image]

Initializes a new instance of the SetBusinessEquipmentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetBusinessEquipmentRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessEquipmentRequest Class
SetBusinessEquipmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetBusinessEquipmentRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetBusinessEquipmentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessEquipmentResponse

Other Resources

Resource Entities
Equipment (Facility/Equipment) Entity Messages and Methods


SetBusinessEquipmentRequest Properties
[image]

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets or sets the ID of the business unit.
public property | EquipmentId | Gets or sets the ID of the equipment (facility/equipment).
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

SetBusinessEquipmentRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessEquipmentResponse

Other Resources

Resource Entities
Equipment (Facility/Equipment) Entity Messages and Methods


SetBusinessEquipmentRequest.BusinessUnitId Property
[image]

Gets or sets the ID of the business unit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BusinessUnitId As Guid

C#
public Guid BusinessUnitId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the business unit. This corresponds to the BusinessUnit.BusinessUnitId attribute, which is the primary key for the BusinessUnit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessEquipmentRequest Class
SetBusinessEquipmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetBusinessEquipmentRequest.EquipmentId Property
[image]

Gets or sets the ID of the equipment (facility/equipment).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EquipmentId As Guid

C#
public Guid EquipmentId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the equipment (facility/equipment). This corresponds to the Equipment.EquipmentId attribute, which is the primary key for the Equipment entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessEquipmentRequest Class
SetBusinessEquipmentRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetBusinessEquipmentResponse Class
See Also Members
[image]

Contains the response from the SetBusinessEquipmentRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetBusinessEquipmentResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetBusinessEquipmentResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SetBusinessEquipmentResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessEquipmentResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessEquipmentRequest


SetBusinessEquipmentResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SetBusinessEquipmentRequest class.

The following tables list the members exposed by the SetBusinessEquipmentResponse type.

Public Constructors

Name | Description
SetBusinessEquipmentResponse | Initializes a new instance of the SetBusinessEquipmentResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetBusinessEquipmentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessEquipmentRequest


SetBusinessEquipmentResponse Constructor
[image]

Initializes a new instance of the SetBusinessEquipmentResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetBusinessEquipmentResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessEquipmentResponse Class
SetBusinessEquipmentResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SetBusinessEquipmentResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetBusinessEquipmentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessEquipmentRequest


SetBusinessEquipmentResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetBusinessEquipmentResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessEquipmentRequest


SetBusinessSystemUserRequest Class
See Also Members
[image]

Contains the data that is needed to move a system user (user) to a different business unit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetBusinessSystemUserRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetBusinessSystemUserRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  SetBusinessSystemUserResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the SystemUser entity and access rights on the records specified in the BusinessId and UserId properties. For a list of the privileges required, see SetBusinessSystemUser Privileges.
Notes for Callers
You must specify a value for the ReassignPrincipal property. The instances of the entities that had been assigned to the user specified by the UserId property will be assigned to that security principal (user).
If any of the direct reports of the user are no longer in the new business unit hierarchy after the user is moved, these direct reports are updated to report to the previous manager of the user.
If the user has been moved out of his or her manager's business-unit hierarchy, the manager of the user is set to null. You may list the same user for both the UserId and ReassignPrincipal properties if you would like the user to retain the entities assigned.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SetBusinessSystemUserRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessSystemUserResponse
Other Resources
Administration and Security Entities (Organization, Business Unit, User, Team, Privilege, Role, Field Security)
SystemUser (User) Entity Messages and Methods


SetBusinessSystemUserRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to move a system user (user) to a different business unit.

The following tables list the members exposed by the SetBusinessSystemUserRequest type.

Public Constructors

Name | Description
SetBusinessSystemUserRequest | Initializes a new instance of the SetBusinessSystemUserRequest class.
Top

Public Properties

 | Name | Description
public property | BusinessId | Gets or sets the ID of the business unit to which the user is moved. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReassignPrincipal | Gets or sets the target security principal (user) to which the instances of entities previously owned by the user are to be assigned. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId | Gets or sets the ID of the user. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetBusinessSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessSystemUserResponse

Other Resources

Administration and Security Entities (Organization, Business Unit, User, Team, Privilege, Role, Field Security)
SystemUser (User) Entity Messages and Methods


SetBusinessSystemUserRequest Constructor
[image]

Initializes a new instance of the SetBusinessSystemUserRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetBusinessSystemUserRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessSystemUserRequest Class
SetBusinessSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetBusinessSystemUserRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetBusinessSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessSystemUserResponse

Other Resources

Administration and Security Entities (Organization, Business Unit, User, Team, Privilege, Role, Field Security)
SystemUser (User) Entity Messages and Methods


SetBusinessSystemUserRequest Properties
[image]

Public Properties

 | Name | Description
public property | BusinessId | Gets or sets the ID of the business unit to which the user is moved. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReassignPrincipal | Gets or sets the target security principal (user) to which the instances of entities previously owned by the user are to be assigned. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId | Gets or sets the ID of the user. Required.

See Also

Reference

SetBusinessSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessSystemUserResponse

Other Resources

Administration and Security Entities (Organization, Business Unit, User, Team, Privilege, Role, Field Security)
SystemUser (User) Entity Messages and Methods


SetBusinessSystemUserRequest.BusinessId Property
[image]

Gets or sets the ID of the business unit to which the user is moved. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BusinessId As Guid

C#
public Guid BusinessId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the business unit to which the user is moved. This corresponds to the BusinessUnit.BusinessUnitId attribute, which is the primary key for the BusinessUnit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessSystemUserRequest Class
SetBusinessSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetBusinessSystemUserRequest.ReassignPrincipal Property
[image]

Gets or sets the target security principal (user) to which the instances of entities previously owned by the user are to be assigned. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReassignPrincipal As EntityReference

C#
public EntityReference ReassignPrincipal { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target security principal (user) to which the instances of entities previously owned by the user are to be assigned. If this property is set to null or an empty string, an error occurs.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessSystemUserRequest Class
SetBusinessSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetBusinessSystemUserRequest.UserId Property
[image]

Gets or sets the ID of the user. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserId As Guid

C#
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The ID of the user. This corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessSystemUserRequest Class
SetBusinessSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetBusinessSystemUserResponse Class
See Also Members
[image]

Contains the response from the SetBusinessSystemUserRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetBusinessSystemUserResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetBusinessSystemUserResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SetBusinessSystemUserResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessSystemUserRequest


SetBusinessSystemUserResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SetBusinessSystemUserRequest class.

The following tables list the members exposed by the SetBusinessSystemUserResponse type.

Public Constructors

Name | Description
SetBusinessSystemUserResponse | Initializes a new instance of the SetBusinessSystemUserResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetBusinessSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessSystemUserRequest


SetBusinessSystemUserResponse Constructor
[image]

Initializes a new instance of the SetBusinessSystemUserResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetBusinessSystemUserResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetBusinessSystemUserResponse Class
SetBusinessSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SetBusinessSystemUserResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetBusinessSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessSystemUserRequest


SetBusinessSystemUserResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetBusinessSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetBusinessSystemUserRequest


SetLocLabelsRequest Class
See Also Members
[image]

Contains the data that is needed to set localized labels for a limited set of entity attributes.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetLocLabelsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetLocLabelsRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute   method, which returns an instance of SetLocLabelsResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges listed in SetLocLabels Privileges.
Notes for Callers
This message only sets the localized display names for specific entity attributes. It cannot set localized labels used for other application user interface areas such as labels used in the ribbon or form elements.
Supported Entities
This message is supported by the following entity attributes and localizable properties:
  • DynamicProperty.Name
  • DynamicPropertyOptionSetItem.DynamicPropertyOptionName
  • DynamicPropertyOptionSetItem.DynamicPropertyOptionDescription
  • Product.Name
  • SavedQuery.Description
  • SavedQuery.Name
  • SavedQueryVisualization.Description
  • SavedQueryVisualization.Name
  • SystemForm.Description
  • SystemForm.Name
  • TimeZoneDefinition.UserInterfaceName
  • TimeZoneDefinition.StandardName
  • TimeZoneLocalizedName.UserInterfaceName

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SetLocLabelsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Customize Labels to Support Multiple Languages
Localize product property values


SetLocLabelsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to set localized labels for a limited set of entity attributes.

The following tables list the members exposed by the SetLocLabelsRequest type.

Public Constructors

Name | Description
SetLocLabelsRequest | Initializes a new instance of the SetLocLabelsRequest class
Top

Public Properties

 | Name | Description
public property | AttributeName | Gets or sets the name of the attribute. Required.
public property | EntityMoniker | Gets or sets the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Labels | Gets or sets the label. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetLocLabelsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Localize product property values


SetLocLabelsRequest Constructor
[image]

Initializes a new instance of the SetLocLabelsRequest class

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetLocLabelsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetLocLabelsRequest Class
SetLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetLocLabelsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetLocLabelsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Localize product property values


SetLocLabelsRequest Properties
[image]

Public Properties

 | Name | Description
public property | AttributeName | Gets or sets the name of the attribute. Required.
public property | EntityMoniker | Gets or sets the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Labels | Gets or sets the label. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

SetLocLabelsRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Customize Labels to Support Multiple Languages
Localize product property values


SetLocLabelsRequest.AttributeName Property
[image]

Gets or sets the name of the attribute. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeName As String

C#
public string AttributeName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the attribute. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetLocLabelsRequest Class
SetLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetLocLabelsRequest.EntityMoniker Property
[image]

Gets or sets the entity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityMoniker As EntityReference

C#
public EntityReference EntityMoniker { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The entity. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetLocLabelsRequest Class
SetLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetLocLabelsRequest.Labels Property
[image]

Gets or sets the label. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Labels As LocalizedLabel()

C#
public LocalizedLabel[] Labels { get; set; }

C++

J#

JScript

Property Value
Type: LocalizedLabel
The label.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetLocLabelsRequest Class
SetLocLabelsRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetLocLabelsResponse Class
See Also Members
[image]

Contains the response from the SetLocLabelsRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetLocLabelsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetLocLabelsResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SetLocLabelsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetLocLabelsResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SetLocLabelsRequest


SetLocLabelsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SetLocLabelsRequest class.

The following tables list the members exposed by the SetLocLabelsResponse type.

Public Constructors

Name | Description
SetLocLabelsResponse | Initializes a new instance of the SetLocLabelsResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetLocLabelsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetLocLabelsRequest


SetLocLabelsResponse Constructor
[image]

Initializes a new instance of the SetLocLabelsResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetLocLabelsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetLocLabelsResponse Class
SetLocLabelsResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SetLocLabelsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetLocLabelsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetLocLabelsRequest


SetLocLabelsResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetLocLabelsResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetLocLabelsRequest


SetParentBusinessUnitRequest Class
See Also Members
[image]

Contains the data that is needed to set the parent business unit for a business unit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetParentBusinessUnitRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetParentBusinessUnitRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  SetParentBusinessUnitResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the BusinessUnit entity and access rights on the records specified in the BusinessUnitId and ParentId properties.  For a list of the privileges required, see SetParentBusinessUnit Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SetParentBusinessUnitRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SetParentBusinessUnitResponse


SetParentBusinessUnitRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to set the parent business unit for a business unit.

The following tables list the members exposed by the SetParentBusinessUnitRequest type.

Public Constructors

Name | Description
SetParentBusinessUnitRequest | Initializes a new instance of the SetParentBusinessUnitRequest class.
Top

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets or sets the ID of the business unit.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentId | Gets or sets the ID of the new parent business unit.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetParentBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentBusinessUnitResponse


SetParentBusinessUnitRequest Constructor
[image]

Initializes a new instance of the SetParentBusinessUnitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetParentBusinessUnitRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentBusinessUnitRequest Class
SetParentBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentBusinessUnitRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetParentBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentBusinessUnitResponse


SetParentBusinessUnitRequest Properties
[image]

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets or sets the ID of the business unit.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentId | Gets or sets the ID of the new parent business unit.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

SetParentBusinessUnitRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentBusinessUnitResponse


SetParentBusinessUnitRequest.BusinessUnitId Property
[image]

Gets or sets the ID of the business unit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BusinessUnitId As Guid

C#
public Guid BusinessUnitId { get; set; }

C++

J#

JScript

Property Value
Returns Guid.

  Remarks
The BusinessUnitId property corresponds to the BusinessUnit.BusinessUnitId attribute, which is the primary key for the BusinessUnit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentBusinessUnitRequest Class
SetParentBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentBusinessUnitRequest.ParentId Property
[image]

Gets or sets the ID of the new parent business unit.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ParentId As Guid

C#
public Guid ParentId { get; set; }

C++

J#

JScript

Property Value
Returns Guid.

  Remarks
The ParentId property corresponds to the BusinessUnit.BusinessUnitId attribute, which is the primary key for the BusinessUnit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentBusinessUnitRequest Class
SetParentBusinessUnitRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentBusinessUnitResponse Class
See Also Members
[image]

Contains the response from the SetParentBusinessUnitRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetParentBusinessUnitResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetParentBusinessUnitResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SetParentBusinessUnitResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SetParentBusinessUnitRequest


SetParentBusinessUnitResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SetParentBusinessUnitRequest class.

The following tables list the members exposed by the SetParentBusinessUnitResponse type.

Public Constructors

Name | Description
SetParentBusinessUnitResponse | Initializes a new instance of the SetParentBusinessUnitResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetParentBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentBusinessUnitRequest


SetParentBusinessUnitResponse Constructor
[image]

Initializes a new instance of the SetParentBusinessUnitResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetParentBusinessUnitResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentBusinessUnitResponse Class
SetParentBusinessUnitResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentBusinessUnitResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetParentBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentBusinessUnitRequest


SetParentBusinessUnitResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetParentBusinessUnitResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentBusinessUnitRequest


SetParentSystemUserRequest Class
See Also Members
[image]

Contains the data needed to set a new parent system user (user) for the specified user.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetParentSystemUserRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetParentSystemUserRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  SetParentSystemUserResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the SystemUser entity and access rights on the records specified in the ParentId and UserId properties. For a list of the privileges required, see SetParentSystemUser Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SetParentSystemUserRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SetParentSystemUserResponse
Other Resources
User and Team Entities
SystemUser (User) Entity Messages and Methods


SetParentSystemUserRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to set a new parent system user (user) for the specified user.

The following tables list the members exposed by the SetParentSystemUserRequest type.

Public Constructors

Name | Description
SetParentSystemUserRequest | Initializes a new instance of the SetParentSystemUserRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | KeepChildUsers | Gets or sets whether the child users are to be retained. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentId | Gets or sets the ID of the new parent user. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId | Gets or sets the ID of the user. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetParentSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentSystemUserResponse

Other Resources

User and Team Entities
SystemUser (User) Entity Messages and Methods


SetParentSystemUserRequest Constructor
[image]

Initializes a new instance of the SetParentSystemUserRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetParentSystemUserRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentSystemUserRequest Class
SetParentSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentSystemUserRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetParentSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentSystemUserResponse

Other Resources

User and Team Entities
SystemUser (User) Entity Messages and Methods


SetParentSystemUserRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | KeepChildUsers | Gets or sets whether the child users are to be retained. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ParentId | Gets or sets the ID of the new parent user. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | UserId | Gets or sets the ID of the user. Required.

See Also

Reference

SetParentSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentSystemUserResponse

Other Resources

User and Team Entities
SystemUser (User) Entity Messages and Methods


SetParentSystemUserRequest.KeepChildUsers Property
[image]

Gets or sets whether the child users are to be retained. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property KeepChildUsers As Boolean

C#
public bool KeepChildUsers { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether the child users are to be retained.
Use true to retain the child users reporting to the original user, otherwise, use false (default) to update the child users to report to the original manager of the user.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentSystemUserRequest Class
SetParentSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentSystemUserRequest.ParentId Property
[image]

Gets or sets the ID of the new parent user. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ParentId As Guid

C#
public Guid ParentId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the new parent user. This corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentSystemUserRequest Class
SetParentSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentSystemUserRequest.UserId Property
[image]

Gets or sets the ID of the user. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserId As Guid

C#
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the user. This corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentSystemUserRequest Class
SetParentSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentSystemUserResponse Class
See Also Members
[image]

Contains the response from the SetParentSystemUserRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetParentSystemUserResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetParentSystemUserResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SetParentSystemUserResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SetParentSystemUserRequest


SetParentSystemUserResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SetParentSystemUserRequest class.

The following tables list the members exposed by the SetParentSystemUserResponse type.

Public Constructors

Name | Description
SetParentSystemUserResponse | Initializes a new instance of the SetParentSystemUserResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetParentSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentSystemUserRequest


SetParentSystemUserResponse Constructor
[image]

Initializes a new instance of the SetParentSystemUserResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetParentSystemUserResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentSystemUserResponse Class
SetParentSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentSystemUserResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetParentSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentSystemUserRequest


SetParentSystemUserResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetParentSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentSystemUserRequest


SetParentTeamRequest Class
See Also Members
[image]

Contains the data needed to set the parent business unit of a team.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetParentTeamRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetParentTeamRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  SetParentTeamResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Team entity and access rights on the records specified in the BusinessId and TeamId properties.  For a list of the privileges required, see SetParentTeam Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SetParentTeamRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SetParentTeamResponse
Other Resources
User and Team Entities
Team Entity Messages and Methods


SetParentTeamRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to set the parent business unit of a team.

The following tables list the members exposed by the SetParentTeamRequest type.

Public Constructors

Name | Description
SetParentTeamRequest | Initializes a new instance of the SetParentTeamRequest class.
Top

Public Properties

 | Name | Description
public property | BusinessId | Gets or sets the ID of the business unit to which to move the team. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the ID of the team. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetParentTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentTeamResponse

Other Resources

User and Team Entities
Team Entity Messages and Methods


SetParentTeamRequest Constructor
[image]

Initializes a new instance of the SetParentTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetParentTeamRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentTeamRequest Class
SetParentTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentTeamRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetParentTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentTeamResponse

Other Resources

User and Team Entities
Team Entity Messages and Methods


SetParentTeamRequest Properties
[image]

Public Properties

 | Name | Description
public property | BusinessId | Gets or sets the ID of the business unit to which to move the team. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TeamId | Gets or sets the ID of the team. Required.

See Also

Reference

SetParentTeamRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentTeamResponse

Other Resources

User and Team Entities
Team Entity Messages and Methods


SetParentTeamRequest.BusinessId Property
[image]

Gets or sets the ID of the business unit to which to move the team. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BusinessId As Guid

C#
public Guid BusinessId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the business unit to which to move the team. This corresponds to the BusinessUnit.BusinessUnitId attribute, which is the primary key for the BusinessUnit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentTeamRequest Class
SetParentTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentTeamRequest.TeamId Property
[image]

Gets or sets the ID of the team. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TeamId As Guid

C#
public Guid TeamId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the team. This corresponds to the Team.TeamId attribute, which is the primary key for the Team entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentTeamRequest Class
SetParentTeamRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentTeamResponse Class
See Also Members
[image]

Contains the response from the SetParentTeamRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetParentTeamResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetParentTeamResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SetParentTeamResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SetParentTeamRequest


SetParentTeamResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SetParentTeamRequest class.

The following tables list the members exposed by the SetParentTeamResponse type.

Public Constructors

Name | Description
SetParentTeamResponse | Initializes a new instance of the SetParentTeamResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetParentTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentTeamRequest


SetParentTeamResponse Constructor
[image]

Initializes a new instance of the SetParentTeamResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetParentTeamResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetParentTeamResponse Class
SetParentTeamResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SetParentTeamResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetParentTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentTeamRequest


SetParentTeamResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetParentTeamResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetParentTeamRequest


SetRelatedRequest Class
See Also Members
[image]

Contains the data needed to create a relationship between a set of records that participate in specific relationships.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetRelatedRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetRelatedRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  SetRelatedResponse.
Privileges and Access Rights
To perform this action, the caller must have  access rights on the records specified in the Target property.  For a list of the privileges required, see SetRelated Privileges.
Notes for Callers
This message works for a limited set of relationships and will be deprecated in a future version. Use AssociateRequest instead.
Executing this message when the relationship already exists will result in an error.
Supported Relationships
The following table shows which relationships support this message.
Entity | Relationship Schema Name
Invoice | contactinvoices_association
Lead | accountleads_association contactleads_association
Opportunity | opportunity_customer_accounts opportunitycompetitors_association opportunity_customer_contacts
Product | competitorproduct_association leadproduct_association
Quote | contactquotes_association
SalesLiterature | competitorsalesliterature_association productsalesliterature_association
SalesOrder | contactorders_association

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SetRelatedRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace
AssociateRequest
SetRelatedResponse
Other Resources
Actions on Entity Records


SetRelatedRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to create a relationship between a set of records that participate in specific relationships.

The following tables list the members exposed by the SetRelatedRequest type.

Public Constructors

Name | Description
SetRelatedRequest | Initializes a new instance of the SetRelatedRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target records of the set related action. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetRelatedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AssociateRequest
SetRelatedResponse

Other Resources

Actions on Entity Records


SetRelatedRequest Constructor
[image]

Initializes a new instance of the SetRelatedRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetRelatedRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetRelatedRequest Class
SetRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetRelatedRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetRelatedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AssociateRequest
SetRelatedResponse

Other Resources

Actions on Entity Records


SetRelatedRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target records of the set related action. Required.

See Also

Reference

SetRelatedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
AssociateRequest
SetRelatedResponse

Other Resources

Actions on Entity Records


SetRelatedRequest.Target Property
[image]

Gets or sets the target records of the set related action. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference()

C#
public EntityReference[] Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target records of the set related action. This array must contain a set of entity references where the entities participate in a relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetRelatedRequest Class
SetRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetRelatedResponse Class
See Also Members
[image]

Contains the response from the SetRelatedRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetRelatedResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetRelatedResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SetRelatedResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetRelatedResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SetRelatedRequest


SetRelatedResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SetRelatedRequest class.

The following tables list the members exposed by the SetRelatedResponse type.

Public Constructors

Name | Description
SetRelatedResponse | Initializes a new instance of the SetRelatedResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetRelatedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetRelatedRequest


SetRelatedResponse Constructor
[image]

Initializes a new instance of the SetRelatedResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetRelatedResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetRelatedResponse Class
SetRelatedResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SetRelatedResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetRelatedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetRelatedRequest


SetRelatedResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetRelatedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetRelatedRequest


SetReportRelatedRequest Class
See Also Members
[image]

Contains the data needed to link an instance of a report entity to related entities.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetReportRelatedRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetReportRelatedRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
 Pass an instance of this class to theExecute  method, which returns an instance of SetReportRelatedResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Report entity and access rights on the record specified in the ReportId property. For a list of the privileges required, see SetReportRelated Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SetReportRelatedRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetReportRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SetReportRelatedResponse
Other Resources
Create Reports for Microsoft Dynamics CRM Using SQL Server Reporting Services
Report Entity Messages and Methods


SetReportRelatedRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to link an instance of a report entity to related entities.

The following tables list the members exposed by the SetReportRelatedRequest type.

Public Constructors

Name | Description
SetReportRelatedRequest | Initializes a new instance of the SetReportRelatedRequest class.
Top

Public Properties

 | Name | Description
public property | Categories | Gets or sets an array of report category codes. Required.
public property | Entities | Gets or sets an array of entity type codes for the related entities. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Gets or sets the ID of the report. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Visibility | Gets or sets an array of report visibility codes. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetReportRelatedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetReportRelatedResponse

Other Resources

Create Reports for Microsoft Dynamics CRM Using SQL Server Reporting Services
Report Entity Messages and Methods


SetReportRelatedRequest Constructor
[image]

Initializes a new instance of the SetReportRelatedRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetReportRelatedRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetReportRelatedRequest Class
SetReportRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetReportRelatedRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetReportRelatedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetReportRelatedResponse

Other Resources

Create Reports for Microsoft Dynamics CRM Using SQL Server Reporting Services
Report Entity Messages and Methods


SetReportRelatedRequest Properties
[image]

Public Properties

 | Name | Description
public property | Categories | Gets or sets an array of report category codes. Required.
public property | Entities | Gets or sets an array of entity type codes for the related entities. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReportId | Gets or sets the ID of the report. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Visibility | Gets or sets an array of report visibility codes. Required.

See Also

Reference

SetReportRelatedRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetReportRelatedResponse

Other Resources

Create Reports for Microsoft Dynamics CRM Using SQL Server Reporting Services
Report Entity Messages and Methods


SetReportRelatedRequest.Categories Property
[image]

Gets or sets an array of report category codes. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Categories As Integer()

C#
public int[] Categories { get; set; }

C++

J#

JScript

Property Value
Type: Int32[]
The array of report category codes.

  Remarks
The Categories property value is used to set the ReportCategory.CategoryCode attribute. The report category codes determine in which report categories the report is shown.
Report Category Code | Value
Sales | 1
Service | 2
Marketing | 3
Administrative | 4
The report category codes and their values can be found in the Customization area of the Web application. In the Navigation Pane, click Settings, click Customizations, and then click Customize the System. In the Default Solution page, expand Entities, and then Report Related Category (reportcategory) entity. Click Fields, and double-click the categorycode attribute. In Type, click a report category, such as Sales Reports or Service Reports, to obtain the report category code value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetReportRelatedRequest Class
SetReportRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetReportRelatedRequest.Entities Property
[image]

Gets or sets an array of entity type codes for the related entities. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entities As Integer()

C#
public int[] Entities { get; set; }

C++

J#

JScript

Property Value
Type: Int32[]
The array of entity type codes for the related entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetReportRelatedRequest Class
SetReportRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
IOrganizationService Entities


SetReportRelatedRequest.ReportId Property
[image]

Gets or sets the ID of the report. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReportId As Guid

C#
public Guid ReportId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the report. This corresponds to the Report.ReportId attribute, which is the primary key for the report entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetReportRelatedRequest Class
SetReportRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetReportRelatedRequest.Visibility Property
[image]

Gets or sets an array of report visibility codes. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Visibility As Integer()

C#
public int[] Visibility { get; set; }

C++

J#

JScript

Property Value
Type: Int32[]
The array of report visibility codes.

  Remarks
The Visibility property value is used to set the ReportVisibility.VisibilityCode attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetReportRelatedRequest Class
SetReportRelatedRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetReportRelatedResponse Class
See Also Members
[image]

Contains the response from SetReportRelatedRequest.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetReportRelatedResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetReportRelatedResponse : OrganizationResponse

C++

J#

JScript

  Remarks
There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SetReportRelatedResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetReportRelatedResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SetReportRelatedRequest


SetReportRelatedResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from SetReportRelatedRequest.

The following tables list the members exposed by the SetReportRelatedResponse type.

Public Constructors

Name | Description
SetReportRelatedResponse | Initializes a new instance of the SetReportRelatedResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetReportRelatedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetReportRelatedRequest


SetReportRelatedResponse Constructor
[image]

Initializes a new instance of the SetReportRelatedResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetReportRelatedResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetReportRelatedResponse Class
SetReportRelatedResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SetReportRelatedResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetReportRelatedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetReportRelatedRequest


SetReportRelatedResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetReportRelatedResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetReportRelatedRequest


SetStateRequest Class
See Also Example Members
[image]

Contains the data that’s needed to set the state of an entity record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetStateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetStateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create the Request Object
SetStateRequest state = new SetStateRequest();

// Set the Request Object's Properties
state.State = new OptionSetValue((int)IncidentState.Active);
state.Status =
    new OptionSetValue((int)incident_statuscode.WaitingforDetails);

// Point the Request to the case whose state is being changed
state.EntityMoniker = caseReference;

// Execute the Request
SetStateResponse stateSet = (SetStateResponse)_serviceProxy.Execute(state);

// Check if the state was successfully set
Incident incident = _serviceProxy.Retrieve(Incident.EntityLogicalName,
    _caseIncidentId, new ColumnSet(allColumns: true)).ToEntity<Incident>();

if (incident.StatusCode.Value == (int)incident_statuscode.WaitingforDetails)
{
    Console.WriteLine("Record state set successfully.");
}
else
{
    Console.WriteLine("The request to set the record state failed.");
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline. Not all entity types support this message offline. See Supported Entities later in this topic.
Usage
Pass an instance of this class to the Execute method, which returns an instance of  the SetStateResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the EntityMoniker property.
For a complete list of the required privileges, see SetState Privileges.
Valid State and Status value combinations
The valid combinations of state and status code values varies for many entities. For a list of default values for specific system entities, see Default status and status reason values.
For a list of the state and status values valid for custom entities in your organization, refer to the entity metadata.

                        To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

Supported Entities

                        The following table shows the default entities that support this message and whether the message is available when the caller is connected to the server (Server), disconnected from the server (Offline) or both (Both).

Entity | Availability
Account | 2 (Both)
Appointment | 2 (Both)
BusinessUnit | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ConvertRule | 2 (Both)
DiscountType | 2 (Both)
DynamicProperty | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
Fax | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
Invoice | 2 (Both)
KbArticle | 2 (Both)
Lead | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OrderClose | 2 (Both)
PhoneCall | 2 (Both)
Position | 2 (Both)
PriceLevel | 2 (Both)
ProcessSession | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RoutingRule | 2 (Both)
SalesOrder | 2 (Both)
SavedQuery | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
ServiceAppointment | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
SLA | 2 (Both)
SocialActivity | 2 (Both)
SocialProfile | 2 (Both)
SystemUser | 2 (Both)
Task | 2 (Both)
TransactionCurrency | 2 (Both)
UoMSchedule | 2 (Both)
UserQuery | 2 (Both)
Workflow | 2 (Both)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.SetStateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
SetStateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
SetStateResponse
Other Resources
SetState Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SetStateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that’s needed to set the state of an entity record.

The following tables list the members exposed by the SetStateRequest type.

Public Constructors

Name | Description
SetStateRequest | Initializes a new instance of the SetStateRequest class.
Top

Public Properties

 | Name | Description
public property | EntityMoniker | Gets or sets the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | State | Gets or sets the state of the entity record. Required.
public property | Status | Gets or sets the status that corresponds to the State property. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetStateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetStateResponse

Other Resources

SetState Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SetStateRequest Constructor
[image]

Initializes a new instance of the SetStateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetStateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetStateRequest Class
SetStateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetStateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetStateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetStateResponse

Other Resources

SetState Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SetStateRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityMoniker | Gets or sets the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | State | Gets or sets the state of the entity record. Required.
public property | Status | Gets or sets the status that corresponds to the State property. Required.

See Also

Reference

SetStateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
SetStateResponse

Other Resources

SetState Privileges
Sample: Validate Record State and Set State of the Record
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


SetStateRequest.EntityMoniker Property
[image]

Gets or sets the entity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityMoniker As EntityReference

C#
public EntityReference EntityMoniker { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetStateRequest Class
SetStateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetStateRequest.State Property
[image]

Gets or sets the state of the entity record. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property State As OptionSetValue

C#
public OptionSetValue State { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The state of the entity record.

  Remarks
The State property corresponds to the StateCode attribute of an entity. It specifies the possible states for an entity record. It is shown as the Status in the Microsoft Dynamics CRM application. For a list of the state values, refer to the entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.More information:Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetStateRequest Class
SetStateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetStateRequest.Status Property
[image]

Gets or sets the status that corresponds to the State property. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The status that corresponds to the State property.

  Remarks
The Status property corresponds to the StatusCode attribute of an entity. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system sets the appropriate corresponding status value. For a list of the status values, refer to the entity metadata. You can find this information in the metadata for your organization. See the preceding metadata browser information.More information:Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetStateRequest Class
SetStateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


SetStateResponse Class
See Also Members
[image]

Contains the response from the SetStateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class SetStateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class SetStateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.SetStateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetStateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
SetStateRequest


SetStateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SetStateRequest class.

The following tables list the members exposed by the SetStateResponse type.

Public Constructors

Name | Description
SetStateResponse | Initializes a new instance of the SetStateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetStateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetStateRequest


SetStateResponse Constructor
[image]

Initializes a new instance of the SetStateResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetStateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetStateResponse Class
SetStateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


SetStateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetStateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetStateRequest


SetStateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetStateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
SetStateRequest


ShareAuditDetail Class
See Also Members
[image]

Represents a shared audit detail record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ShareAuditDetail
    Inherits AuditDetail

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ShareAuditDetail : AuditDetail

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Crm.Sdk.Messages.AuditDetail
    Microsoft.Crm.Sdk.Messages.ShareAuditDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ShareAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace
AuditDetail


ShareAuditDetail Members
See Also Constructors Methods Properties
[image]

Represents a shared audit detail record.

The following tables list the members exposed by the ShareAuditDetail type.

Public Constructors

Name | Description
ShareAuditDetail | Initializes a new instance of theShareAuditDetail class.
Top

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | NewPrivileges | Gets or sets the privileges of the user after a change.
public property | OldPrivileges | Gets or sets the privileges of the user before a change.
public property | Principal | Gets or sets the security principal (user or team) that shares the audit detail record.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ShareAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace
AuditDetail


ShareAuditDetail Constructor
[image]

Initializes a new instance of the ShareAuditDetail class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ShareAuditDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ShareAuditDetail Class
ShareAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ShareAuditDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ShareAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace
AuditDetail


ShareAuditDetail Properties
[image]

Public Properties

 | Name | Description
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | NewPrivileges | Gets or sets the privileges of the user after a change.
public property | OldPrivileges | Gets or sets the privileges of the user before a change.
public property | Principal | Gets or sets the security principal (user or team) that shares the audit detail record.

See Also

Reference

ShareAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace
AuditDetail


ShareAuditDetail.NewPrivileges Property
[image]

Gets or sets the privileges of the user after a change.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property NewPrivileges As AccessRights

C#
[DataMemberAttribute]
public AccessRights NewPrivileges { get; set; }

C++

J#

JScript

Property Value
Type: AccessRights
The privileges of the user after a change.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ShareAuditDetail Class
ShareAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ShareAuditDetail.OldPrivileges Property
[image]

Gets or sets the privileges of the user before a change.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OldPrivileges As AccessRights

C#
[DataMemberAttribute]
public AccessRights OldPrivileges { get; set; }

C++

J#

JScript

Property Value
Type: AccessRights
The privileges of the user before a change.

  Remarks
Returns null in a few cases.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ShareAuditDetail Class
ShareAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


ShareAuditDetail.Principal Property
[image]

Gets or sets the security principal (user or team) that shares the audit detail record.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Principal As EntityReference

C#
[DataMemberAttribute]
public EntityReference Principal { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The user or team that shares the record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ShareAuditDetail Class
ShareAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


StatusUpdateBulkOperationRequest Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class StatusUpdateBulkOperationRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class StatusUpdateBulkOperationRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.StatusUpdateBulkOperationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusUpdateBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace
StatusUpdateBulkOperationResponse
Other Resources
StatusUpdateBulkOperation Privileges


StatusUpdateBulkOperationRequest Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the StatusUpdateBulkOperationRequest type.

Public Constructors

Name | Description
StatusUpdateBulkOperationRequest | For internal use only.
Top

Public Properties

 | Name | Description
public property | BulkOperationId | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FailureCount | For internal use only.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SuccessCount | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StatusUpdateBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
StatusUpdateBulkOperationResponse

Other Resources

StatusUpdateBulkOperation Privileges


StatusUpdateBulkOperationRequest Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StatusUpdateBulkOperationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusUpdateBulkOperationRequest Class
StatusUpdateBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


StatusUpdateBulkOperationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StatusUpdateBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
StatusUpdateBulkOperationResponse

Other Resources

StatusUpdateBulkOperation Privileges


StatusUpdateBulkOperationRequest Properties
[image]

Public Properties

 | Name | Description
public property | BulkOperationId | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FailureCount | For internal use only.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SuccessCount | For internal use only.

See Also

Reference

StatusUpdateBulkOperationRequest Class
Microsoft.Crm.Sdk.Messages Namespace
StatusUpdateBulkOperationResponse

Other Resources

StatusUpdateBulkOperation Privileges


StatusUpdateBulkOperationRequest.BulkOperationId Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BulkOperationId As Guid

C#
public Guid BulkOperationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusUpdateBulkOperationRequest Class
StatusUpdateBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


StatusUpdateBulkOperationRequest.FailureCount Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FailureCount As Integer

C#
public int FailureCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusUpdateBulkOperationRequest Class
StatusUpdateBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


StatusUpdateBulkOperationRequest.SuccessCount Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SuccessCount As Integer

C#
public int SuccessCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusUpdateBulkOperationRequest Class
StatusUpdateBulkOperationRequest Members
Microsoft.Crm.Sdk.Messages Namespace


StatusUpdateBulkOperationResponse Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class StatusUpdateBulkOperationResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class StatusUpdateBulkOperationResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.StatusUpdateBulkOperationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusUpdateBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


StatusUpdateBulkOperationResponse Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the StatusUpdateBulkOperationResponse type.

Public Constructors

Name | Description
StatusUpdateBulkOperationResponse | For internal use only.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StatusUpdateBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace


StatusUpdateBulkOperationResponse Constructor
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StatusUpdateBulkOperationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusUpdateBulkOperationResponse Class
StatusUpdateBulkOperationResponse Members
Microsoft.Crm.Sdk.Messages Namespace


StatusUpdateBulkOperationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StatusUpdateBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace


StatusUpdateBulkOperationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

StatusUpdateBulkOperationResponse Class
Microsoft.Crm.Sdk.Messages Namespace


SubCode Enumeration
[image]

Contains the possible values for a subcode, used in scheduling appointments.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration SubCode

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum SubCode

C++

J#

JScript

  Members
Member name | Description
Appointment | A block of time that is already scheduled for an appointment. Value = 7.
Break | A block of time that cannot be committed due to a scheduled break. Value = 4.
Committed | A block of time that is committed to perform an action. Value = 2.
Holiday | A block of time that cannot be scheduled due to a scheduled holiday. Value = 5.
ResourceCapacity | Specifies the capacity of a resource for the specified time interval. Value = 10.
ResourceServiceRestriction | A restriction for a resource for the specified service. Value = 9.
ResourceStartTime | Specifies to filter a resource start time. Value = 8.
Schedulable | A schedulable block of time. Value = 1.
ServiceCost | An override to the service cost for the specified time block. Value = 12.
ServiceRestriction | Specifies that a service is restricted during the specified block of time. Value = 11.
Uncommitted | A block of time that is tentatively scheduled but not committed. Value = 3.
Unspecified | Specifies free time with no specified restrictions. Value = 0.
Vacation | A block of time that cannot be scheduled due to a scheduled vacation. Value = 6.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace
SubCode
QueryScheduleResponse


TargetFieldType Enumeration
[image]

Indicates the attribute type for the target of the InitializeFromRequest message.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration TargetFieldType

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum TargetFieldType

C++

J#

JScript

  Members
Member name | Description
All | Initialize all possible attribute values. Value = 0.
ValidForCreate | Initialize the attribute values that are valid for create. Value = 1.
ValidForRead | Initialize the attribute values that are valid for read. Value = 3.
ValidForUpdate | initialize the attribute values that are valid for update. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace
InitializeFromRequest
TargetFieldType


TimeCode Enumeration
[image]

Contains the possible values for a time code, used when querying a schedule.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public Enumeration TimeCode

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public enum TimeCode

C++

J#

JScript

  Members
Member name | Description
Available | The time is available within the working hours of the resource. Value = 0.
Busy | The time is committed to an activity. Value = 1.
Filter | Use additional filters for the time block such as service cost or service start time. Value = 3.
Unavailable | The time is unavailable. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Crm.Sdk.Messages Namespace
QueryScheduleRequest
QueryMultipleSchedulesRequest
TimeInfo


TimeInfo Class
See Also Members
[image]

Specifies a set of time blocks with appointment information.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class TimeInfo
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class TimeInfo : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.TimeInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarResponse
QueryMultipleSchedulesResponse
QueryScheduleResponse


TimeInfo Members
See Also Constructors Methods Properties
[image]

Specifies a set of time blocks with appointment information.

The following tables list the members exposed by the TimeInfo type.

Public Constructors

Name | Description
TimeInfo | Initializes a new instance of theTimeInfo class.
Top

Public Properties

 | Name | Description
public property | ActivityStatusCode | Gets or sets the status of the activity.
public property | CalendarId | Gets or sets the ID of the calendar for this block of time.
public property | DisplayText | Gets or sets the display text shown in the calendar for the time block.
public property | Effort | Gets or sets the amount of effort required for this block of time.
public property | End | Gets or sets the end time for the block.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | IsActivity | Gets or sets the value that indicates whether the block of time refers to an activity.
public property | SourceId | Gets or sets the ID of the record referred to in the time block.
public property | SourceTypeCode | Gets or sets the type of entity referred to in the time block.
public property | Start | Gets or sets the start time for the block.
public property | SubCode | Gets or sets information about the time block such as whether it is an appointment, break, or holiday.
public property | TimeCode | Gets or sets the value that indicates whether the time block is available, busy, filtered or unavailable.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TimeInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarResponse
QueryMultipleSchedulesResponse
QueryScheduleResponse


TimeInfo Constructor
[image]

Initializes a new instance of theTimeInfo class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TimeInfo ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TimeInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarResponse
QueryMultipleSchedulesResponse
QueryScheduleResponse


TimeInfo Properties
[image]

Public Properties

 | Name | Description
public property | ActivityStatusCode | Gets or sets the status of the activity.
public property | CalendarId | Gets or sets the ID of the calendar for this block of time.
public property | DisplayText | Gets or sets the display text shown in the calendar for the time block.
public property | Effort | Gets or sets the amount of effort required for this block of time.
public property | End | Gets or sets the end time for the block.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | IsActivity | Gets or sets the value that indicates whether the block of time refers to an activity.
public property | SourceId | Gets or sets the ID of the record referred to in the time block.
public property | SourceTypeCode | Gets or sets the type of entity referred to in the time block.
public property | Start | Gets or sets the start time for the block.
public property | SubCode | Gets or sets information about the time block such as whether it is an appointment, break, or holiday.
public property | TimeCode | Gets or sets the value that indicates whether the time block is available, busy, filtered or unavailable.

See Also

Reference

TimeInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ExpandCalendarResponse
QueryMultipleSchedulesResponse
QueryScheduleResponse


TimeInfo.ActivityStatusCode Property
[image]

Gets or sets the status of the activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActivityStatusCode As Integer

C#
[DataMemberAttribute]
public int ActivityStatusCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The activity status code.

  Remarks
For a list of valid status codes, see the metadata for this entity. To view the entity metadata for your organization, install the Metadata Browser solution described in Browse the Metadata for Your Organization. You can also view the metadata for an uncustomized organization in the Excel file called EntityMetadata.xlsx included in the top-level folder of the SDK download.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.CalendarId Property
[image]

Gets or sets the ID of the calendar for this block of time.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CalendarId As Guid

C#
[DataMemberAttribute]
public Guid CalendarId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The the ID of the calendar for this block of time, which corresponds to the Calendar.CalendarId attribute, which is the primary key for the Calendar entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.DisplayText Property
[image]

Gets or sets the display text shown in the calendar for the time block.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DisplayText As String

C#
[DataMemberAttribute]
public string DisplayText { get; set; }

C++

J#

JScript

Property Value
Type: String
The display text shown in the calendar for the time block..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.Effort Property
[image]

Gets or sets the amount of effort required for this block of time.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Effort As Double

C#
[DataMemberAttribute]
public double Effort { get; set; }

C++

J#

JScript

Property Value
Type: Double

The amount of effort required for this block of time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.End Property
[image]

Gets or sets the end time for the block.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property End As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> End { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTime>

The end time for the block.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.IsActivity Property
[image]

Gets or sets the value that indicates whether the block of time refers to an activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsActivity As Boolean

C#
[DataMemberAttribute]
public bool IsActivity { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the block of time refers to an activity; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.SourceId Property
[image]

Gets or sets the ID of the record referred to in the time block.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SourceId As Guid

C#
[DataMemberAttribute]
public Guid SourceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the record, which corresponds to the primary key for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.SourceTypeCode Property
[image]

Gets or sets the type of entity referred to in the time block.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SourceTypeCode As Integer

C#
[DataMemberAttribute]
public int SourceTypeCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The entity type code.

  Remarks
For a list of all default entities and their type codes, see IOrganizationService Entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.Start Property
[image]

Gets or sets the start time for the block.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Start As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> Start { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTime>

The start time for the block.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.SubCode Property
[image]

Gets or sets information about the time block such as whether it is an appointment, break, or holiday.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SubCode As SubCode

C#
[DataMemberAttribute]
public SubCode SubCode { get; set; }

C++

J#

JScript

Property Value
Type: SubCode
The information about the time block.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TimeInfo.TimeCode Property
[image]

Gets or sets the value that indicates whether the time block is available, busy, filtered or unavailable.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TimeCode As TimeCode

C#
[DataMemberAttribute]
public TimeCode TimeCode { get; set; }

C++

J#

JScript

Property Value
Type: TimeCode
The time code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TimeInfo Class
TimeInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TraceInfo Class
See Also Members
[image]

Specifies the results of a scheduling operation using the ValidateRequest, BookRequest, RescheduleRequest, or SearchRequest messages.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class TraceInfo
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class TraceInfo : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.TraceInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TraceInfo Members
Microsoft.Crm.Sdk.Messages Namespace
ValidationResult
ValidationResult
ValidationResult
SearchResponse


TraceInfo Members
See Also Constructors Methods Properties
[image]

Specifies the results of a scheduling operation using the ValidateRequest, BookRequest, RescheduleRequest, or SearchRequest messages.

The following tables list the members exposed by the TraceInfo type.

Public Constructors

Name | Description
TraceInfo | Overloaded. Initializes a new instance of the TraceInfo class.
Top

Public Properties

 | Name | Description
public property | ErrorInfoList | Gets or sets the list of error information for the scheduling operation.
public property | ExtensionData | Gets or sets the structure that contains extra data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TraceInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ValidationResult
ValidationResult
ValidationResult
SearchResponse


TraceInfo Constructor
[image]

Initializes a new instance of the TraceInfo class.

Overload List

Name | Description
TraceInfo () | Initializes a new instance of the TraceInfo class.
TraceInfo (ErrorInfo[]) | Initializes a new instance of the TraceInfo class.

See Also

Reference

TraceInfo Class
TraceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TraceInfo Constructor ()
[image]

Initializes a new instance of the TraceInfo class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TraceInfo ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TraceInfo Class
TraceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TraceInfo Constructor (ErrorInfo[])
[image]

Initializes a new instance of the TraceInfo class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    errorInfo As ErrorInfo() _
)

C#
public TraceInfo (
    ErrorInfo[] errorInfo
)

C++

J#

JScript

Parameters
errorInfo
Type: ErrorInfo[]. The list of error information for the scheduling operation.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TraceInfo Class
TraceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TraceInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TraceInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ValidationResult
ValidationResult
ValidationResult
SearchResponse


TraceInfo Properties
[image]

Public Properties

 | Name | Description
public property | ErrorInfoList | Gets or sets the list of error information for the scheduling operation.
public property | ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

TraceInfo Class
Microsoft.Crm.Sdk.Messages Namespace
ValidationResult
ValidationResult
ValidationResult
SearchResponse


TraceInfo.ErrorInfoList Property
[image]

Gets or sets the list of error information for the scheduling operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorInfoList As ErrorInfo()

C#
[DataMemberAttribute]
public ErrorInfo[] ErrorInfoList { get; set; }

C++

J#

JScript

Property Value
Returns ErrorInfo[]
The the list of error information for the scheduling operation.

  Remarks
Scheduling errors occur, for example, when a resource is not available for the specified appointment time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TraceInfo Class
TraceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TraceInfo.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TraceInfo Class
TraceInfo Members
Microsoft.Crm.Sdk.Messages Namespace


TransformImportRequest Class
See Also Example Members
[image]

Contains the data that is needed to submit an asynchronous job that transforms the parsed data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class TransformImportRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class TransformImportRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Transform the import
TransformImportRequest transformImportRequest = new TransformImportRequest()
{
    ImportId = importId
};
TransformImportResponse transformImportResponse =
    (TransformImportResponse)_serviceProxy.Execute(transformImportRequest);
Console.WriteLine("Waiting for Transform async job to complete");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the TransformImportResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Import entity and access rights on the specified record in the ImportId property. For a complete list of the required privileges, see TransformImport Privileges.
Notes for Callers
Pass the ID of the associated import (data import) in the ImportId property. The ID of the asynchronous job that runs in the background and performs the transformation is returned in the AsyncOperationId property of the message response.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.TransformImportRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
TransformImportRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportResponse
Other Resources
Import Data in Microsoft Dynamics CRM
Import (data import) Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
TransformImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


TransformImportRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to submit an asynchronous job that transforms the parsed data.

The following tables list the members exposed by the TransformImportRequest type.

Public Constructors

Name | Description
TransformImportRequest | Initializes a new instance of the TransformImportRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportId | Gets or sets the ID of the import (data import) that is associated with the asynchronous job that transforms the imported data. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TransformImportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Import (data import) Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
TransformImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


TransformImportRequest Constructor
[image]

Initializes a new instance of the TransformImportRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TransformImportRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TransformImportRequest Class
TransformImportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


TransformImportRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TransformImportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Import (data import) Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
TransformImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


TransformImportRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | ImportId | Gets or sets the ID of the import (data import) that is associated with the asynchronous job that transforms the imported data. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

TransformImportRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ImportRecordsImportResponse

Other Resources

Import Data in Microsoft Dynamics CRM
Import (data import) Entity Messages and Methods
Run Data Import
Sample: Import Data Using Complex Data Map
TransformImport Privileges
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


TransformImportRequest.ImportId Property
[image]

Gets or sets the ID of the import (data import) that is associated with the asynchronous job that transforms the imported data. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportId As Guid

C#
public Guid ImportId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the import (data import) that is associated with the asynchronous job that transforms the imported data. This corresponds to the Import.ImportId attribute, which is the primary key for the Import entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TransformImportRequest Class
TransformImportRequest Members
Microsoft.Crm.Sdk.Messages Namespace


TransformImportResponse Class
See Also Members
[image]

Contains the response from the TransformImportRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class TransformImportResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class TransformImportResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.TransformImportResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TransformImportResponse Members
Microsoft.Crm.Sdk.Messages Namespace
TransformImportRequest


TransformImportResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the TransformImportRequest class.

The following tables list the members exposed by the TransformImportResponse type.

Public Constructors

Name | Description
TransformImportResponse | Initializes a new instance of the TransformImportResponse class.
Top

Public Properties

 | Name | Description
public property | AsyncOperationId | Gets the ID of the asynchronous job that transforms the parsed data for this import.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TransformImportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
TransformImportRequest


TransformImportResponse Constructor
[image]

Initializes a new instance of the TransformImportResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TransformImportResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TransformImportResponse Class
TransformImportResponse Members
Microsoft.Crm.Sdk.Messages Namespace


TransformImportResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TransformImportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
TransformImportRequest


TransformImportResponse Properties
[image]

Public Properties

 | Name | Description
public property | AsyncOperationId | Gets the ID of the asynchronous job that transforms the parsed data for this import.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

TransformImportResponse Class
Microsoft.Crm.Sdk.Messages Namespace
TransformImportRequest


TransformImportResponse.AsyncOperationId Property
[image]

Gets the ID of the asynchronous job that transforms the parsed data for this import.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AsyncOperationId As Guid

C#
public Guid AsyncOperationId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the asynchronous job that transforms the parsed data for this import.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TransformImportResponse Class
TransformImportResponse Members
Microsoft.Crm.Sdk.Messages Namespace


TriggerServiceEndpointCheckRequest Class
See Also Members
[image]

Contains the data that is needed to validate the configuration of a Microsoft Azure Service Bus solution’s service endpoint.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class TriggerServiceEndpointCheckRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class TriggerServiceEndpointCheckRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which will return an instance of TriggerServiceEndpointCheckResponse.
Privileges and Access Rights
For a list of the privileges required, see TriggerServiceEndpointCheck Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.TriggerServiceEndpointCheckRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TriggerServiceEndpointCheckRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
ServiceEndpoint Entity Messages and Methods


TriggerServiceEndpointCheckRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to validate the configuration of a Microsoft Azure Service Bus solution’s service endpoint.

The following tables list the members exposed by the TriggerServiceEndpointCheckRequest type.

Public Constructors

Name | Description
TriggerServiceEndpointCheckRequest | Initializes a new instance of the TriggerServiceEndpointCheck class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets or sets the ServiceEndpoint record that contains the configuration. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TriggerServiceEndpointCheckRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

ServiceEndpoint Entity Messages and Methods


TriggerServiceEndpointCheckRequest Constructor
[image]

Initializes a new instance of the TriggerServiceEndpointCheck class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TriggerServiceEndpointCheckRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TriggerServiceEndpointCheckRequest Class
TriggerServiceEndpointCheckRequest Members
Microsoft.Crm.Sdk.Messages Namespace


TriggerServiceEndpointCheckRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TriggerServiceEndpointCheckRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

ServiceEndpoint Entity Messages and Methods


TriggerServiceEndpointCheckRequest Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets or sets the ServiceEndpoint record that contains the configuration. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

TriggerServiceEndpointCheckRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

ServiceEndpoint Entity Messages and Methods


TriggerServiceEndpointCheckRequest.Entity Property
[image]

Gets or sets the ServiceEndpoint record that contains the configuration. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As EntityReference

C#
public EntityReference Entity { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The entity reference of the service endpoint record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TriggerServiceEndpointCheckRequest Class
TriggerServiceEndpointCheckRequest Members
Microsoft.Crm.Sdk.Messages Namespace


TriggerServiceEndpointCheckResponse Class
See Also Members
[image]

Contains the response from the TriggerServiceEndpointCheckRequest.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class TriggerServiceEndpointCheckResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class TriggerServiceEndpointCheckResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.TriggerServiceEndpointCheckResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TriggerServiceEndpointCheckResponse Members
Microsoft.Crm.Sdk.Messages Namespace


TriggerServiceEndpointCheckResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the TriggerServiceEndpointCheckRequest.

The following tables list the members exposed by the TriggerServiceEndpointCheckResponse type.

Public Constructors

Name | Description
TriggerServiceEndpointCheckResponse | Initializes a new instance of the TriggerServiceEndpointCheckResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TriggerServiceEndpointCheckResponse Class
Microsoft.Crm.Sdk.Messages Namespace


TriggerServiceEndpointCheckResponse Constructor
[image]

Initializes a new instance of the TriggerServiceEndpointCheckResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TriggerServiceEndpointCheckResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TriggerServiceEndpointCheckResponse Class
TriggerServiceEndpointCheckResponse Members
Microsoft.Crm.Sdk.Messages Namespace


TriggerServiceEndpointCheckResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TriggerServiceEndpointCheckResponse Class
Microsoft.Crm.Sdk.Messages Namespace


TriggerServiceEndpointCheckResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

TriggerServiceEndpointCheckResponse Class
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataRequest Class
See Also Members
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UninstallSampleDataRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UninstallSampleDataRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.UninstallSampleDataRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UninstallSampleDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataRequest Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the UninstallSampleDataRequest type.

Public Constructors

Name | Description
UninstallSampleDataRequest |
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UninstallSampleDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataRequest Constructor
[image]

Initializes a new instance of the UninstallSampleDataRequest Class.Initializes a new instance of the UninstallSampleDataRequest Class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UninstallSampleDataRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UninstallSampleDataRequest Class
UninstallSampleDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UninstallSampleDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

UninstallSampleDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataResponse Class
See Also Members
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UninstallSampleDataResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UninstallSampleDataResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.UninstallSampleDataResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UninstallSampleDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataResponse Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the UninstallSampleDataResponse type.

Public Constructors

Name | Description
UninstallSampleDataResponse |
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UninstallSampleDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataResponse Constructor
[image]

Initializes a new instance of the UninstallSampleDataResponse Class.Initializes a new instance of the UninstallSampleDataResponse Class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UninstallSampleDataResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UninstallSampleDataResponse Class
UninstallSampleDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UninstallSampleDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace


UninstallSampleDataResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UninstallSampleDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace


UnlockInvoicePricingRequest Class
See Also Example Members
[image]

Contains the data that is needed to unlock pricing for an invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UnlockInvoicePricingRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UnlockInvoicePricingRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Retrieve the invoice
Invoice updatedInvoice = (Invoice)_serviceProxy.Retrieve(
        Invoice.EntityLogicalName,
        _invoiceId,
        new ColumnSet("invoiceid", "totalamount")
    );

Console.WriteLine("Updated invoice retrieved.");
Console.WriteLine();

Console.WriteLine("Details after lock and update:");
Console.WriteLine("----------------");
Console.WriteLine("Current invoice total: {0}",
    updatedInvoice.TotalAmount.Value);
Console.WriteLine("Current price per item: {0}",
    priceListItem.Amount.Value);
Console.WriteLine("</End of Listing>");
Console.WriteLine();

// Unlock the invoice pricing
UnlockInvoicePricingRequest unlockInvoiceRequest =
    new UnlockInvoicePricingRequest()
    {
        InvoiceId = _invoiceId
    };
_serviceProxy.Execute(unlockInvoiceRequest);

Console.WriteLine("Invoice pricing unlocked.");

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  UnlockInvoicePricingResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the Invoice entity and access rights on the record specified in the InvoiceId property. For a complete list of required privileges, see UnlockInvoicePricing Privileges.
Notes to Callers
This message unlocks the total price of products and services specified in the invoice. When the invoice pricing is unlocked, changes to underlying price lists (price level) can affect the prices for an invoice.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.UnlockInvoicePricingRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
UnlockInvoicePricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingResponse
Other Resources
UnlockInvoicePricing Privileges
Invoice Entity Messages and Methods
Sample: Set Negative Prices in Opportunities, Quotes and Sales Orders
Sample: Process Quotes, Sales Orders and Invoices
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnlockInvoicePricingRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to unlock pricing for an invoice.

The following tables list the members exposed by the UnlockInvoicePricingRequest type.

Public Constructors

Name | Description
UnlockInvoicePricingRequest | Initializes a new instance of the UnlockInvoicePricingRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InvoiceId | Gets or sets the ID of the invoice.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UnlockInvoicePricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingResponse

Other Resources

UnlockInvoicePricing Privileges
Invoice Entity Messages and Methods
Sample: Set Negative Prices in Opportunities, Quotes and Sales Orders
Sample: Process Quotes, Sales Orders and Invoices
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnlockInvoicePricingRequest Constructor
[image]

Initializes a new instance of the UnlockInvoicePricingRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UnlockInvoicePricingRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnlockInvoicePricingRequest Class
UnlockInvoicePricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UnlockInvoicePricingRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UnlockInvoicePricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingResponse

Other Resources

UnlockInvoicePricing Privileges
Invoice Entity Messages and Methods
Sample: Set Negative Prices in Opportunities, Quotes and Sales Orders
Sample: Process Quotes, Sales Orders and Invoices
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnlockInvoicePricingRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | InvoiceId | Gets or sets the ID of the invoice.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

UnlockInvoicePricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingResponse

Other Resources

UnlockInvoicePricing Privileges
Invoice Entity Messages and Methods
Sample: Set Negative Prices in Opportunities, Quotes and Sales Orders
Sample: Process Quotes, Sales Orders and Invoices
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnlockInvoicePricingRequest.InvoiceId Property
[image]

Gets or sets the ID of the invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property InvoiceId As Guid

C#
public Guid InvoiceId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the invoice. This corresponds to the Invoice.InvoiceId attribute, which is the primary key for the Invoice entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnlockInvoicePricingRequest Class
UnlockInvoicePricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UnlockInvoicePricingResponse Class
See Also Members
[image]

Contains the response from the UnlockInvoicePricingRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UnlockInvoicePricingResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UnlockInvoicePricingResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.UnlockInvoicePricingResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnlockInvoicePricingResponse Members
Microsoft.Crm.Sdk.Messages Namespace
UnlockInvoicePricingRequest


UnlockInvoicePricingResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UnlockInvoicePricingRequest class.

The following tables list the members exposed by the UnlockInvoicePricingResponse type.

Public Constructors

Name | Description
UnlockInvoicePricingResponse | Initializes a new instance of the UnlockInvoicePricingResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UnlockInvoicePricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockInvoicePricingRequest


UnlockInvoicePricingResponse Constructor
[image]

Initializes a new instance of the UnlockInvoicePricingResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UnlockInvoicePricingResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnlockInvoicePricingResponse Class
UnlockInvoicePricingResponse Members
Microsoft.Crm.Sdk.Messages Namespace


UnlockInvoicePricingResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UnlockInvoicePricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockInvoicePricingRequest


UnlockInvoicePricingResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UnlockInvoicePricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockInvoicePricingRequest


UnlockSalesOrderPricingRequest Class
See Also Example Members
[image]

Contains the data that is needed to unlock pricing for a sales order (order).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UnlockSalesOrderPricingRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UnlockSalesOrderPricingRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Unlock the order pricing
UnlockSalesOrderPricingRequest unlockOrderRequest =
    new UnlockSalesOrderPricingRequest()
    {
        SalesOrderId = _salesOrderId
    };
_serviceProxy.Execute(unlockOrderRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  UnlockSalesOrderPricingResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the SalesOrder entity and access rights on the record specified in the SalesOrderId property. For a complete list of required privileges, see UnlockSalesOrderPricing Privileges.
Notes to Callers
This message unlocks the total price of products and services specified in the sales order (order). When the sale order pricing is unlocked, changes to underlying price lists (price level) can affect the prices for a sales order.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.UnlockSalesOrderPricingRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
UnlockSalesOrderPricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingResponse
Other Resources
UnlockSalesOrderPricing Privileges
SalesOrder (Order) Entity Messages and Methods
Sample: Set Negative Prices in Opportunities, Quotes and Sales Orders
Sample: Process Quotes, Sales Orders and Invoices
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnlockSalesOrderPricingRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to unlock pricing for a sales order (order).

The following tables list the members exposed by the UnlockSalesOrderPricingRequest type.

Public Constructors

Name | Description
UnlockSalesOrderPricingRequest | Initializes a new instance of the UnlockSalesOrderPricingRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SalesOrderId | Gets or sets the ID of the sales order (order).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UnlockSalesOrderPricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingResponse

Other Resources

UnlockSalesOrderPricing Privileges
SalesOrder (Order) Entity Messages and Methods
Sample: Set Negative Prices in Opportunities, Quotes and Sales Orders
Sample: Process Quotes, Sales Orders and Invoices
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnlockSalesOrderPricingRequest Constructor
[image]

Initializes a new instance of the UnlockSalesOrderPricingRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UnlockSalesOrderPricingRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnlockSalesOrderPricingRequest Class
UnlockSalesOrderPricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UnlockSalesOrderPricingRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UnlockSalesOrderPricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingResponse

Other Resources

UnlockSalesOrderPricing Privileges
SalesOrder (Order) Entity Messages and Methods
Sample: Set Negative Prices in Opportunities, Quotes and Sales Orders
Sample: Process Quotes, Sales Orders and Invoices
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnlockSalesOrderPricingRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SalesOrderId | Gets or sets the ID of the sales order (order).

See Also

Reference

UnlockSalesOrderPricingRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingResponse

Other Resources

UnlockSalesOrderPricing Privileges
SalesOrder (Order) Entity Messages and Methods
Sample: Set Negative Prices in Opportunities, Quotes and Sales Orders
Sample: Process Quotes, Sales Orders and Invoices
Sales Entities (Lead, Opportunity, Competitor, Quote, Order, Invoice)
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnlockSalesOrderPricingRequest.SalesOrderId Property
[image]

Gets or sets the ID of the sales order (order).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SalesOrderId As Guid

C#
public Guid SalesOrderId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the sales order (order). This corresponds to the SalesOrder.SalesOrderId attribute, which is the primary key for the SalesOrder entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnlockSalesOrderPricingRequest Class
UnlockSalesOrderPricingRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UnlockSalesOrderPricingResponse Class
See Also Members
[image]

Contains the response from the UnlockSalesOrderPricingRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UnlockSalesOrderPricingResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UnlockSalesOrderPricingResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.UnlockSalesOrderPricingResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnlockSalesOrderPricingResponse Members
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingRequest


UnlockSalesOrderPricingResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UnlockSalesOrderPricingRequest class.

The following tables list the members exposed by the UnlockSalesOrderPricingResponse type.

Public Constructors

Name | Description
UnlockSalesOrderPricingResponse | Initializes a new instance of the UnlockSalesOrderPricingResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UnlockSalesOrderPricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingRequest


UnlockSalesOrderPricingResponse Constructor
[image]

Initializes a new instance of the UnlockSalesOrderPricingResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UnlockSalesOrderPricingResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnlockSalesOrderPricingResponse Class
UnlockSalesOrderPricingResponse Members
Microsoft.Crm.Sdk.Messages Namespace


UnlockSalesOrderPricingResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UnlockSalesOrderPricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingRequest


UnlockSalesOrderPricingResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UnlockSalesOrderPricingResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UnlockSalesOrderPricingRequest


UnpublishDuplicateRuleRequest Class
See Also Members
[image]

Contains the data that is needed to submit an asynchronous job to unpublish a duplicate rule.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UnpublishDuplicateRuleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UnpublishDuplicateRuleRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  UnpublishDuplicateRuleResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the DuplicateRule entity and access rights on the record specified in the DuplicateRuleId property.
For a complete list of the required privileges, see UnpublishDuplicateRule Privileges.
Notes for Callers
This message unpublishes a duplicate rule by deleting all matchcodes that were created for this duplicate detection rule by the publishing job.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.UnpublishDuplicateRuleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnpublishDuplicateRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
UnpublishDuplicateRuleResponse
Other Resources
UnpublishDuplicateRule Privileges
Detect Duplicate Data in Microsoft Dynamics CRM
Sample: Invoke Duplicate Detection For Creating and Updating Records
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnpublishDuplicateRuleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to submit an asynchronous job to unpublish a duplicate rule.

The following tables list the members exposed by the UnpublishDuplicateRuleRequest type.

Public Constructors

Name | Description
UnpublishDuplicateRuleRequest | Initializes a new instance of the UnpublishDuplicateRuleRequest class.
Top

Public Properties

 | Name | Description
public property | DuplicateRuleId | Gets or sets the ID of the duplicate rule to be unpublished. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UnpublishDuplicateRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnpublishDuplicateRuleResponse

Other Resources

UnpublishDuplicateRule Privileges
Detect Duplicate Data in Microsoft Dynamics CRM
Sample: Invoke Duplicate Detection For Creating and Updating Records
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnpublishDuplicateRuleRequest Constructor
[image]

Initializes a new instance of the UnpublishDuplicateRuleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UnpublishDuplicateRuleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnpublishDuplicateRuleRequest Class
UnpublishDuplicateRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UnpublishDuplicateRuleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UnpublishDuplicateRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnpublishDuplicateRuleResponse

Other Resources

UnpublishDuplicateRule Privileges
Detect Duplicate Data in Microsoft Dynamics CRM
Sample: Invoke Duplicate Detection For Creating and Updating Records
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnpublishDuplicateRuleRequest Properties
[image]

Public Properties

 | Name | Description
public property | DuplicateRuleId | Gets or sets the ID of the duplicate rule to be unpublished. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

UnpublishDuplicateRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UnpublishDuplicateRuleResponse

Other Resources

UnpublishDuplicateRule Privileges
Detect Duplicate Data in Microsoft Dynamics CRM
Sample: Invoke Duplicate Detection For Creating and Updating Records
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UnpublishDuplicateRuleRequest.DuplicateRuleId Property
[image]

Gets or sets the ID of the duplicate rule to be unpublished. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DuplicateRuleId As Guid

C#
public Guid DuplicateRuleId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the duplicate rule to be unpublished. This corresponds to the DuplicateRule.DuplicateRuleId attribute, which is the primary key for the DuplicateRule entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnpublishDuplicateRuleRequest Class
UnpublishDuplicateRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UnpublishDuplicateRuleResponse Class
See Also Members
[image]

Contains the response from the UnpublishDuplicateRuleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UnpublishDuplicateRuleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UnpublishDuplicateRuleResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.UnpublishDuplicateRuleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnpublishDuplicateRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
UnpublishDuplicateRuleRequest


UnpublishDuplicateRuleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UnpublishDuplicateRuleRequest class.

The following tables list the members exposed by the UnpublishDuplicateRuleResponse type.

Public Constructors

Name | Description
UnpublishDuplicateRuleResponse | Initializes a new instance of the UnpublishDuplicateRuleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UnpublishDuplicateRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UnpublishDuplicateRuleRequest


UnpublishDuplicateRuleResponse Constructor
[image]

Initializes a new instance of the UnpublishDuplicateRuleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UnpublishDuplicateRuleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UnpublishDuplicateRuleResponse Class
UnpublishDuplicateRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


UnpublishDuplicateRuleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UnpublishDuplicateRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UnpublishDuplicateRuleRequest


UnpublishDuplicateRuleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UnpublishDuplicateRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UnpublishDuplicateRuleRequest


UpdateProductPropertiesRequest Class
See Also Members
[image]

Contains the data that is needed to update values of the property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UpdateProductPropertiesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UpdateProductPropertiesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of UpdateProductPropertiesResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Product and DynamicPropertyInstance entities and access rights on the records specified in the PropertyInstanceList property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.UpdateProductPropertiesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateProductPropertiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Define product properties (not supported through SDK)
DynamicPropertyInstance (property instance) methods and messages


UpdateProductPropertiesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update values of the property instances (dynamic property instances) for a product added to an opportunity, quote, order, or invoice.

The following tables list the members exposed by the UpdateProductPropertiesRequest type.

Public Constructors

Name | Description
UpdateProductPropertiesRequest | Initializes a new instance of the UpdateProductPropertiesRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PropertyInstanceList | Gets or sets the property instances (dynamic property instances) for a product to be updated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateProductPropertiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Define product properties (not supported through SDK)
DynamicPropertyInstance (property instance) methods and messages


UpdateProductPropertiesRequest Constructor
[image]

Initializes a new instance of the UpdateProductPropertiesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateProductPropertiesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateProductPropertiesRequest Class
UpdateProductPropertiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UpdateProductPropertiesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateProductPropertiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Define product properties (not supported through SDK)
DynamicPropertyInstance (property instance) methods and messages


UpdateProductPropertiesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PropertyInstanceList | Gets or sets the property instances (dynamic property instances) for a product to be updated.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

UpdateProductPropertiesRequest Class
Microsoft.Crm.Sdk.Messages Namespace

Other Resources

Define product properties (not supported through SDK)
DynamicPropertyInstance (property instance) methods and messages


UpdateProductPropertiesRequest.PropertyInstanceList Property
[image]

Gets or sets the property instances (dynamic property instances) for a product to be updated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PropertyInstanceList As EntityCollection

C#
public EntityCollection PropertyInstanceList { get; set; }

C++

J#

JScript

Property Value
Type: EntityCollection

The property instances (dynamic property instances) for a product to be updated.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateProductPropertiesRequest Class
UpdateProductPropertiesRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UpdateProductPropertiesResponse Class
See Also Members
[image]

Contains the response from the UpdateProductPropertiesRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UpdateProductPropertiesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UpdateProductPropertiesResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.UpdateProductPropertiesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateProductPropertiesResponse Members
Microsoft.Crm.Sdk.Messages Namespace
UpdateProductPropertiesRequest
Other Resources
DynamicPropertyInstance (property instance) methods and messages


UpdateProductPropertiesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UpdateProductPropertiesRequest class.

The following tables list the members exposed by the UpdateProductPropertiesResponse type.

Public Constructors

Name | Description
UpdateProductPropertiesResponse | Initializes a new instance of the UpdateProductPropertiesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateProductPropertiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UpdateProductPropertiesRequest

Other Resources

DynamicPropertyInstance (property instance) methods and messages


UpdateProductPropertiesResponse Constructor
[image]

Initializes a new instance of the UpdateProductPropertiesResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateProductPropertiesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateProductPropertiesResponse Class
UpdateProductPropertiesResponse Members
Microsoft.Crm.Sdk.Messages Namespace


UpdateProductPropertiesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateProductPropertiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UpdateProductPropertiesRequest

Other Resources

DynamicPropertyInstance (property instance) methods and messages


UpdateProductPropertiesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UpdateProductPropertiesResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UpdateProductPropertiesRequest

Other Resources

DynamicPropertyInstance (property instance) methods and messages


UpdateUserSettingsSystemUserRequest Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UpdateUserSettingsSystemUserRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UpdateUserSettingsSystemUserRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.UpdateUserSettingsSystemUserRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateUserSettingsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace
UpdateUserSettingsSystemUserResponse
Other Resources
UpdateUserSettingsSystemUser Privileges


UpdateUserSettingsSystemUserRequest Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class.

The following tables list the members exposed by the UpdateUserSettingsSystemUserRequest type.

Public Constructors

Name | Description
UpdateUserSettingsSystemUserRequest | Deprecated. Use the UpdateRequest class and its members.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Settings | Deprecated. Use the UpdateRequest class and its members.
public property | UserId | Deprecated. Use the UpdateRequest class and its members.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateUserSettingsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UpdateUserSettingsSystemUserResponse

Other Resources

UpdateUserSettingsSystemUser Privileges


UpdateUserSettingsSystemUserRequest Constructor
[image]

Deprecated. Use the UpdateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateUserSettingsSystemUserRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateUserSettingsSystemUserRequest Class
UpdateUserSettingsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UpdateUserSettingsSystemUserRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateUserSettingsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UpdateUserSettingsSystemUserResponse

Other Resources

UpdateUserSettingsSystemUser Privileges


UpdateUserSettingsSystemUserRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Settings | Deprecated. Use the UpdateRequest class and its members.
public property | UserId | Deprecated. Use the UpdateRequest class and its members.

See Also

Reference

UpdateUserSettingsSystemUserRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UpdateUserSettingsSystemUserResponse

Other Resources

UpdateUserSettingsSystemUser Privileges


UpdateUserSettingsSystemUserRequest.Settings Property
[image]

Deprecated. Use the UpdateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Settings As Entity

C#
public Entity Settings { get; set; }

C++

J#

JScript

Property Value
Type: Entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateUserSettingsSystemUserRequest Class
UpdateUserSettingsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UpdateUserSettingsSystemUserRequest.UserId Property
[image]

Deprecated. Use the UpdateRequest class and its members.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserId As Guid

C#
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateUserSettingsSystemUserRequest Class
UpdateUserSettingsSystemUserRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UpdateUserSettingsSystemUserResponse Class
See Also Members
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UpdateUserSettingsSystemUserResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UpdateUserSettingsSystemUserResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.UpdateUserSettingsSystemUserResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateUserSettingsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace
UpdateUserSettingsSystemUserRequest


UpdateUserSettingsSystemUserResponse Members
See Also Constructors Methods Properties
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

The following tables list the members exposed by the UpdateUserSettingsSystemUserResponse type.

Public Constructors

Name | Description
UpdateUserSettingsSystemUserResponse | Deprecated. Use the UpdateRequest class and its associated response class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateUserSettingsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UpdateUserSettingsSystemUserRequest


UpdateUserSettingsSystemUserResponse Constructor
[image]

Deprecated. Use the UpdateRequest class and its associated response class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateUserSettingsSystemUserResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateUserSettingsSystemUserResponse Class
UpdateUserSettingsSystemUserResponse Members
Microsoft.Crm.Sdk.Messages Namespace


UpdateUserSettingsSystemUserResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateUserSettingsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UpdateUserSettingsSystemUserRequest


UpdateUserSettingsSystemUserResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UpdateUserSettingsSystemUserResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UpdateUserSettingsSystemUserRequest


UserAccessAuditDetail Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UserAccessAuditDetail
    Inherits AuditDetail

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UserAccessAuditDetail : AuditDetail

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Crm.Sdk.Messages.AuditDetail
    Microsoft.Crm.Sdk.Messages.UserAccessAuditDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserAccessAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


UserAccessAuditDetail Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the UserAccessAuditDetail type.

Public Constructors

Name | Description
UserAccessAuditDetail | Initializes a new instance of the UserAccessAuditDetail class.
Top

Public Properties

 | Name | Description
public property | AccessTime | For internal use only.
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | Interval | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UserAccessAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace


UserAccessAuditDetail Constructor
[image]

Initializes a new instance of the UserAccessAuditDetail class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UserAccessAuditDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserAccessAuditDetail Class
UserAccessAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


UserAccessAuditDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UserAccessAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace


UserAccessAuditDetail Properties
[image]

Public Properties

 | Name | Description
public property | AccessTime | For internal use only.
public property | AuditRecord | Gets or sets the related Audit record that contains the change details. (inherited from AuditDetail)
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from AuditDetail)
public property | Interval | For internal use only.

See Also

Reference

UserAccessAuditDetail Class
Microsoft.Crm.Sdk.Messages Namespace


UserAccessAuditDetail.AccessTime Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AccessTime As DateTime

C#
[DataMemberAttribute]
public DateTime AccessTime { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserAccessAuditDetail Class
UserAccessAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


UserAccessAuditDetail.Interval Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Interval As Integer

C#
[DataMemberAttribute]
public int Interval { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UserAccessAuditDetail Class
UserAccessAuditDetail Members
Microsoft.Crm.Sdk.Messages Namespace


UtcTimeFromLocalTimeRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the Coordinated Universal Time (UTC) for the specified local time.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UtcTimeFromLocalTimeRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UtcTimeFromLocalTimeRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
private void RetrieveUTCTimeFromLocalTime(DateTime localTime)
{
    if (!_timeZoneCode.HasValue)
        return;

    var request = new UtcTimeFromLocalTimeRequest
    {
        TimeZoneCode = _timeZoneCode.Value,
        LocalTime = localTime
    };

    var response = (UtcTimeFromLocalTimeResponse)_serviceProxy.Execute(request);

    Console.WriteLine(String.Concat("Calling UtcTimeFromLocalTimeRequest.  Local time: ",
        localTime.ToString("MM/dd/yyyy HH:mm:ss"), ". UTC time: ",
        response.UtcTime.ToString("MM/dd/yyyy HH:mm:ss")));
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the UtcTimeFromLocalTimeResponse class.
Privileges and Access Rights
For a complete list of the required privileges, see UtcTimeFromLocalTime Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.UtcTimeFromLocalTimeRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
UtcTimeFromLocalTimeRequest Members
Microsoft.Crm.Sdk.Messages Namespace
UtcTimeFromLocalTimeResponse
Other Resources
UtcTimeFromLocalTime Privileges
Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UtcTimeFromLocalTimeRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the Coordinated Universal Time (UTC) for the specified local time.

The following tables list the members exposed by the UtcTimeFromLocalTimeRequest type.

Public Constructors

Name | Description
UtcTimeFromLocalTimeRequest | Initializes a new instance of the UtcTimeFromLocalTimeRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LocalTime | Gets or sets the local time. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TimeZoneCode | Gets or sets the time zone code. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UtcTimeFromLocalTimeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UtcTimeFromLocalTimeResponse

Other Resources

UtcTimeFromLocalTime Privileges
Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UtcTimeFromLocalTimeRequest Constructor
[image]

Initializes a new instance of the UtcTimeFromLocalTimeRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UtcTimeFromLocalTimeRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UtcTimeFromLocalTimeRequest Class
UtcTimeFromLocalTimeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UtcTimeFromLocalTimeRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UtcTimeFromLocalTimeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UtcTimeFromLocalTimeResponse

Other Resources

UtcTimeFromLocalTime Privileges
Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UtcTimeFromLocalTimeRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LocalTime | Gets or sets the local time. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | TimeZoneCode | Gets or sets the time zone code. Required.

See Also

Reference

UtcTimeFromLocalTimeRequest Class
Microsoft.Crm.Sdk.Messages Namespace
UtcTimeFromLocalTimeResponse

Other Resources

UtcTimeFromLocalTime Privileges
Time Zone Entities
Sample: Retrieve Time Zone Information
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


UtcTimeFromLocalTimeRequest.LocalTime Property
[image]

Gets or sets the local time. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LocalTime As DateTime

C#
public DateTime LocalTime { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The the local time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UtcTimeFromLocalTimeRequest Class
UtcTimeFromLocalTimeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UtcTimeFromLocalTimeRequest.TimeZoneCode Property
[image]

Gets or sets the time zone code. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TimeZoneCode As Integer

C#
public int TimeZoneCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The time zone code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UtcTimeFromLocalTimeRequest Class
UtcTimeFromLocalTimeRequest Members
Microsoft.Crm.Sdk.Messages Namespace


UtcTimeFromLocalTimeResponse Class
See Also Members
[image]

Contains the response from the UtcTimeFromLocalTimeRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class UtcTimeFromLocalTimeResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class UtcTimeFromLocalTimeResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.UtcTimeFromLocalTimeResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UtcTimeFromLocalTimeResponse Members
Microsoft.Crm.Sdk.Messages Namespace
UtcTimeFromLocalTimeRequest


UtcTimeFromLocalTimeResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UtcTimeFromLocalTimeRequest class.

The following tables list the members exposed by the UtcTimeFromLocalTimeResponse type.

Public Constructors

Name | Description
UtcTimeFromLocalTimeResponse | Initializes a new instance of the UtcTimeFromLocalTimeResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | UtcTime | Gets the local time and expresses it in Coordinated Universal Time (UTC) time.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UtcTimeFromLocalTimeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UtcTimeFromLocalTimeRequest


UtcTimeFromLocalTimeResponse Constructor
[image]

Initializes a new instance of the UtcTimeFromLocalTimeResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UtcTimeFromLocalTimeResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UtcTimeFromLocalTimeResponse Class
UtcTimeFromLocalTimeResponse Members
Microsoft.Crm.Sdk.Messages Namespace


UtcTimeFromLocalTimeResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UtcTimeFromLocalTimeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UtcTimeFromLocalTimeRequest


UtcTimeFromLocalTimeResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | UtcTime | Gets the local time and expresses it in Coordinated Universal Time (UTC) time.

See Also

Reference

UtcTimeFromLocalTimeResponse Class
Microsoft.Crm.Sdk.Messages Namespace
UtcTimeFromLocalTimeRequest


UtcTimeFromLocalTimeResponse.UtcTime Property
[image]

Gets the local time and expresses it in Coordinated Universal Time (UTC) time.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property UtcTime As DateTime

C#
public DateTime UtcTime { get; }

C++

J#

JScript

Property Value
Type: DateTime
The local time expressed as Coordinated Universal Time (UTC) time.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UtcTimeFromLocalTimeResponse Class
UtcTimeFromLocalTimeResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateRecurrenceRuleRequest Class
See Also Members
[image]

Contains the data that is needed to validate a rule for a recurring appointment.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ValidateRecurrenceRuleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ValidateRecurrenceRuleRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  ValidateRecurrenceRuleResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the RecurrenceRule entity and access rights on the record specified in the Target property. For a complete list of the privileges required, see ValidateRecurrenceRule Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ValidateRecurrenceRuleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateRecurrenceRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ValidateRecurrenceRuleResponse
Other Resources
Recurring Appointment Entities
RecurrenceRule Entity Messages and Methods


ValidateRecurrenceRuleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to validate a rule for a recurring appointment.

The following tables list the members exposed by the ValidateRecurrenceRuleRequest type.

Public Constructors

Name | Description
ValidateRecurrenceRuleRequest | Initializes a new instance of the ValidateRecurrenceRuleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the recurrence rule record to validate.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ValidateRecurrenceRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRecurrenceRuleResponse

Other Resources

Recurring Appointment Entities
RecurrenceRule Entity Messages and Methods


ValidateRecurrenceRuleRequest Constructor
[image]

Initializes a new instance of the ValidateRecurrenceRuleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ValidateRecurrenceRuleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateRecurrenceRuleRequest Class
ValidateRecurrenceRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateRecurrenceRuleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ValidateRecurrenceRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRecurrenceRuleResponse

Other Resources

Recurring Appointment Entities
RecurrenceRule Entity Messages and Methods


ValidateRecurrenceRuleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the recurrence rule record to validate.

See Also

Reference

ValidateRecurrenceRuleRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRecurrenceRuleResponse

Other Resources

Recurring Appointment Entities
RecurrenceRule Entity Messages and Methods


ValidateRecurrenceRuleRequest.Target Property
[image]

Gets or sets the recurrence rule record to validate.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The recurrence rule record to validate. This is an instance of the RecurrenceRule entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateRecurrenceRuleRequest Class
ValidateRecurrenceRuleRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateRecurrenceRuleResponse Class
See Also Members
[image]

Contains the response from the ValidateRecurrenceRuleRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ValidateRecurrenceRuleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ValidateRecurrenceRuleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ValidateRecurrenceRuleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateRecurrenceRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ValidateRecurrenceRuleRequest


ValidateRecurrenceRuleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ValidateRecurrenceRuleRequest class.

The following tables list the members exposed by the ValidateRecurrenceRuleResponse type.

Public Constructors

Name | Description
ValidateRecurrenceRuleResponse | Initializes a new instance of the ValidateRecurrenceRuleResponse class.
Top

Public Properties

 | Name | Description
public property | Description | Gets the description.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ValidateRecurrenceRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRecurrenceRuleRequest


ValidateRecurrenceRuleResponse Constructor
[image]

Initializes a new instance of the ValidateRecurrenceRuleResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ValidateRecurrenceRuleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateRecurrenceRuleResponse Class
ValidateRecurrenceRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateRecurrenceRuleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ValidateRecurrenceRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRecurrenceRuleRequest


ValidateRecurrenceRuleResponse Properties
[image]

Public Properties

 | Name | Description
public property | Description | Gets the description.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ValidateRecurrenceRuleResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRecurrenceRuleRequest


ValidateRecurrenceRuleResponse.Description Property
[image]

Gets the description.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Description As String

C#
public string Description { get; }

C++

J#

JScript

Property Value
Type:  String
The description.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateRecurrenceRuleResponse Class
ValidateRecurrenceRuleResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateRequest Class
See Also Example Members
[image]

Contains the data that is needed to verify that an appointment or service appointment (service activity) has valid available resources for the activity, duration, and site, as appropriate.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ValidateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ValidateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Retrieve the appointment to be validated
ColumnSet cols = new ColumnSet("scheduledstart", "scheduledend", "statecode", "statuscode");
Appointment retrievedAppointment = (Appointment)_serviceProxy.Retrieve(Appointment.EntityLogicalName,
                                           _appointmentId, cols);

// Use the Validate message
ValidateRequest validatedReq = new ValidateRequest();
validatedReq.Activities = new EntityCollection();
validatedReq.Activities.Entities.Add(retrievedAppointment);
validatedReq.Activities.MoreRecords = false;
validatedReq.Activities.PagingCookie = "";
validatedReq.Activities.EntityName = Appointment.EntityLogicalName;

ValidateResponse validateResp = (ValidateResponse)_serviceProxy.Execute(validatedReq);

// Verify success
if ((validateResp.Result != null) && (validateResp.Result.Length > 0))
{
    Console.WriteLine("Validated the appointment.");
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the Execute  method, which returns an instance of the ValidateResponse class.
Privileges and Access Rights
To perform this action, the caller must have access rights on the specified entities in the Activities property. For a list of the required privileges for this message, see Validate Privileges.
Notes for Callers
Each activity record in the Activities property must have a valid Guid value for Id.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ValidateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ValidateRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ValidateResponse
Other Resources
Sample: Validate an Appointment
ServiceAppointment Entity Messages and Methods


ValidateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to verify that an appointment or service appointment (service activity) has valid available resources for the activity, duration, and site, as appropriate.

The following tables list the members exposed by the ValidateRequest type.

Public Constructors

Name | Description
ValidateRequest | Initializes a new instance of the ValidateRequest class.
Top

Public Properties

 | Name | Description
public property | Activities | Gets or sets the activities to validate.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ValidateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateResponse

Other Resources

Sample: Validate an Appointment
ServiceAppointment Entity Messages and Methods


ValidateRequest Constructor
[image]

Initializes a new instance of the ValidateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ValidateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateRequest Class
ValidateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ValidateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateResponse

Other Resources

Sample: Validate an Appointment
ServiceAppointment Entity Messages and Methods


ValidateRequest Properties
[image]

Public Properties

 | Name | Description
public property | Activities | Gets or sets the activities to validate.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ValidateRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateResponse

Other Resources

Sample: Validate an Appointment
ServiceAppointment Entity Messages and Methods


ValidateRequest.Activities Property
[image]

Gets or sets the activities to validate.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Activities As EntityCollection

C#
public EntityCollection Activities { get; set; }

C++

J#

JScript

Property Value
EntityCollection
The activities to validate.

  Remarks
Each activity record in the Activities property must have a valid Guid value for Id that corresponds to the ActivityPointer.ActivityId attribute, which is the primary key for the ActivityPointer entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateRequest Class
ValidateRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateResponse Class
See Also Members
[image]

Contains the response from the ValidateRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ValidateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ValidateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ValidateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ValidateRequest


ValidateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ValidateRequest class.

The following tables list the members exposed by the ValidateResponse type.

Public Constructors

Name | Description
ValidateResponse | Initializes a new instance of the ValidateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Result | Gets the results of the validate operation.
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ValidateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRequest


ValidateResponse Constructor
[image]

Initializes a new instance of the ValidateResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ValidateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateResponse Class
ValidateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ValidateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRequest


ValidateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Result | Gets the results of the validate operation.
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ValidateResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateRequest


ValidateResponse.Result Property
[image]

Gets the results of the validate operation.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Result As ValidationResult()

C#
public ValidationResult[] Result { get; }

C++

J#

JScript

Property Value
Type: ValidationResult
The results of the validate operation.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateResponse Class
ValidateResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateSavedQueryRequest Class
See Also Members
[image]

Contains the data that is needed to validate a saved query (view).

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ValidateSavedQueryRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ValidateSavedQueryRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  ValidateSavedQueryResponse.
Privileges and Access Rights
For a complete list of the privileges required, see ValidateSavedQuery Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.ValidateSavedQueryRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateSavedQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace
ValidateSavedQueryResponse
Other Resources
Customize Entity Views in Microsoft Dynamics CRM
Offline and Outlook Filters and Templates
SavedQuery (View) Entity Messages and Methods


ValidateSavedQueryRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to validate a saved query (view).

The following tables list the members exposed by the ValidateSavedQueryRequest type.

Public Constructors

Name | Description
ValidateSavedQueryRequest | Initializes a new instance of the ValidateSavedQueryRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FetchXml | Gets or sets the FetchXML query string to be validated.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryType | Gets or sets the type of the query.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ValidateSavedQueryRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateSavedQueryResponse

Other Resources

Customize Entity Views in Microsoft Dynamics CRM
Offline and Outlook Filters and Templates
SavedQuery (View) Entity Messages and Methods


ValidateSavedQueryRequest Constructor
[image]

Initializes a new instance of the ValidateSavedQueryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ValidateSavedQueryRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateSavedQueryRequest Class
ValidateSavedQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateSavedQueryRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ValidateSavedQueryRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateSavedQueryResponse

Other Resources

Customize Entity Views in Microsoft Dynamics CRM
Offline and Outlook Filters and Templates
SavedQuery (View) Entity Messages and Methods


ValidateSavedQueryRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | FetchXml | Gets or sets the FetchXML query string to be validated.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QueryType | Gets or sets the type of the query.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ValidateSavedQueryRequest Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateSavedQueryResponse

Other Resources

Customize Entity Views in Microsoft Dynamics CRM
Offline and Outlook Filters and Templates
SavedQuery (View) Entity Messages and Methods


ValidateSavedQueryRequest.FetchXml Property
[image]

Gets or sets the FetchXML query string to be validated.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FetchXml As String

C#
public string FetchXml { get; set; }

C++

J#

JScript

Property Value
Type: String

The FetchXML query string to be validated.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateSavedQueryRequest Class
ValidateSavedQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace
Other Resources
Build Queries with FetchXML
FetchXML Schema


ValidateSavedQueryRequest.QueryType Property
[image]

Gets or sets the type of the query.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QueryType As Integer

C#
public int QueryType { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The query type, which should be one of the values in the SavedQueryQueryType class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateSavedQueryRequest Class
ValidateSavedQueryRequest Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateSavedQueryResponse Class
See Also Members
[image]

Contains the response from the ValidateSavedQueryRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ValidateSavedQueryResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ValidateSavedQueryResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.ValidateSavedQueryResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateSavedQueryResponse Members
Microsoft.Crm.Sdk.Messages Namespace
ValidateSavedQueryRequest


ValidateSavedQueryResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ValidateSavedQueryRequest class.

The following tables list the members exposed by the ValidateSavedQueryResponse type.

Public Constructors

Name | Description
ValidateSavedQueryResponse | Initializes a new instance of the ValidateSavedQueryResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ValidateSavedQueryResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateSavedQueryRequest


ValidateSavedQueryResponse Constructor
[image]

Initializes a new instance of the ValidateSavedQueryResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ValidateSavedQueryResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidateSavedQueryResponse Class
ValidateSavedQueryResponse Members
Microsoft.Crm.Sdk.Messages Namespace


ValidateSavedQueryResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ValidateSavedQueryResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateSavedQueryRequest


ValidateSavedQueryResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ValidateSavedQueryResponse Class
Microsoft.Crm.Sdk.Messages Namespace
ValidateSavedQueryRequest


ValidationResult Class
See Also Members
[image]

Contains the result from the ValidateRequest, BookRequest, or RescheduleRequest messages.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class ValidationResult
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class ValidationResult : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Crm.Sdk.Messages.ValidationResult
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidationResult Members
Microsoft.Crm.Sdk.Messages Namespace
BookRequest
BookResponse
RescheduleRequest
RescheduleResponse
ValidateRequest
ValidateResponse
Other Resources
Sample: Validate an Appointment
Sample: Book an Appointment
Sample: Reschedule and Cancel a Recurring Appointment


ValidationResult Members
See Also Constructors Methods Properties
[image]

Contains the result from the ValidateRequest, BookRequest, or RescheduleRequest messages.

The following tables list the members exposed by the ValidationResult type.

Public Constructors

Name | Description
ValidationResult | Overloaded. Initializes a new instance of the ValidationResult class.
Top

Public Properties

 | Name | Description
public property | ActivityId | Gets or sets the ID of the validated activity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | TraceInfo | Gets or sets the reasons for any scheduling failures.
public property | ValidationSuccess | Gets or sets the value that indicates whether the appointment or service appointment was validated successfully.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ValidationResult Class
Microsoft.Crm.Sdk.Messages Namespace
BookRequest
BookResponse
RescheduleRequest
RescheduleResponse
ValidateRequest
ValidateResponse

Other Resources

Sample: Validate an Appointment
Sample: Book an Appointment
Sample: Reschedule and Cancel a Recurring Appointment


ValidationResult Constructor
[image]

Initializes a new instance of the ValidationResult class.

Overload List

Name | Description
ValidationResult () | Initializes a new instance of the ValidationResult class.
ValidationResult (Boolean, TraceInfo, Guid) | Initializes a new instance of the ValidationResult class, setting the success, traceinfo and activityid properties.

See Also

Reference

ValidationResult Class
ValidationResult Members
Microsoft.Crm.Sdk.Messages Namespace


ValidationResult Constructor ()
[image]

Initializes a new instance of the ValidationResult class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ValidationResult ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidationResult Class
ValidationResult Members
Microsoft.Crm.Sdk.Messages Namespace


ValidationResult Constructor (Boolean, TraceInfo, Guid)
[image]

Initializes a new instance of the ValidationResult class, setting the success, traceinfo and activityid properties.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    success As Boolean, _
    traceInfo As TraceInfo, _
    activityId As Guid _
)

C#
public ValidationResult (
    bool success,
    TraceInfo traceInfo,
    Guid activityId
)

C++

J#

JScript

Parameters
success
Type: Boolean. The value that indicates whether the appointment or service appointment was validated successfully.
traceInfo
Type: TraceInfo. The reasons for any scheduling failures.
activityId
Type: Guid. The ID of the validated activity.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidationResult Class
ValidationResult Members
Microsoft.Crm.Sdk.Messages Namespace


ValidationResult Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ValidationResult Class
Microsoft.Crm.Sdk.Messages Namespace
BookRequest
BookResponse
RescheduleRequest
RescheduleResponse
ValidateRequest
ValidateResponse

Other Resources

Sample: Validate an Appointment
Sample: Book an Appointment
Sample: Reschedule and Cancel a Recurring Appointment


ValidationResult Properties
[image]

Public Properties

 | Name | Description
public property | ActivityId | Gets or sets the ID of the validated activity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | TraceInfo | Gets or sets the reasons for any scheduling failures.
public property | ValidationSuccess | Gets or sets the value that indicates whether the appointment or service appointment was validated successfully.

See Also

Reference

ValidationResult Class
Microsoft.Crm.Sdk.Messages Namespace
BookRequest
BookResponse
RescheduleRequest
RescheduleResponse
ValidateRequest
ValidateResponse

Other Resources

Sample: Validate an Appointment
Sample: Book an Appointment
Sample: Reschedule and Cancel a Recurring Appointment


ValidationResult.ActivityId Property
[image]

Gets or sets the ID of the validated activity.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActivityId As Guid

C#
[DataMemberAttribute]
public Guid ActivityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the validated activity. This corresponds to the ActivityPointer.ActivityPointerId attribute, which is the primary key for the ActivityPointer entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidationResult Class
ValidationResult Members
Microsoft.Crm.Sdk.Messages Namespace


ValidationResult.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidationResult Class
ValidationResult Members
Microsoft.Crm.Sdk.Messages Namespace


ValidationResult.TraceInfo Property
[image]

Gets or sets the reasons for any scheduling failures.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TraceInfo As TraceInfo

C#
[DataMemberAttribute]
public TraceInfo TraceInfo { get; set; }

C++

J#

JScript

Property Value
Type: TraceInfo
The reasons for any scheduling failures.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidationResult Class
ValidationResult Members
Microsoft.Crm.Sdk.Messages Namespace


ValidationResult.ValidationSuccess Property
[image]

Gets or sets the value that indicates whether the appointment or service appointment was validated successfully.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ValidationSuccess As Boolean

C#
[DataMemberAttribute]
public bool ValidationSuccess { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the appointment or service appointment was validated successfully; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ValidationResult Class
ValidationResult Members
Microsoft.Crm.Sdk.Messages Namespace


VerifyProcessStateDataRequest Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class VerifyProcessStateDataRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class VerifyProcessStateDataRequest : OrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.VerifyProcessStateDataRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
VerifyProcessStateDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace
VerifyProcessStateDataResponse
Other Resources
Processes, Workflows, and Dialogs
ProcessSession (Dialog Session) Entity Messages and Methods


VerifyProcessStateDataRequest Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the VerifyProcessStateDataRequest type.

Public Constructors

Name | Description
VerifyProcessStateDataRequest | Initializes a new instance of the VerifyProcessStateDataRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProcessState | For internal use only.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

VerifyProcessStateDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace
VerifyProcessStateDataResponse

Other Resources

Processes, Workflows, and Dialogs
ProcessSession (Dialog Session) Entity Messages and Methods


VerifyProcessStateDataRequest Constructor
[image]

Initializes a new instance of the VerifyProcessStateDataRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public VerifyProcessStateDataRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
VerifyProcessStateDataRequest Class
VerifyProcessStateDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace


VerifyProcessStateDataRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

VerifyProcessStateDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace
VerifyProcessStateDataResponse

Other Resources

Processes, Workflows, and Dialogs
ProcessSession (Dialog Session) Entity Messages and Methods


VerifyProcessStateDataRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ProcessState | For internal use only.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | For internal use only.

See Also

Reference

VerifyProcessStateDataRequest Class
Microsoft.Crm.Sdk.Messages Namespace
VerifyProcessStateDataResponse

Other Resources

Processes, Workflows, and Dialogs
ProcessSession (Dialog Session) Entity Messages and Methods


VerifyProcessStateDataRequest.ProcessState Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ProcessState As String

C#
public string ProcessState { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
VerifyProcessStateDataRequest Class
VerifyProcessStateDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace


VerifyProcessStateDataRequest.Target Property
[image]

For internal use only.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
VerifyProcessStateDataRequest Class
VerifyProcessStateDataRequest Members
Microsoft.Crm.Sdk.Messages Namespace


VerifyProcessStateDataResponse Class
See Also Members
[image]

Contains the response from the VerifyProcessStateDataRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class VerifyProcessStateDataResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class VerifyProcessStateDataResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.VerifyProcessStateDataResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
VerifyProcessStateDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace
VerifyProcessStateDataRequest


VerifyProcessStateDataResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the VerifyProcessStateDataRequest class.

The following tables list the members exposed by the VerifyProcessStateDataResponse type.

Public Constructors

Name | Description
VerifyProcessStateDataResponse | Initializes a new instance of the VerifyProcessStateDataResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsValid |
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

VerifyProcessStateDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace
VerifyProcessStateDataRequest


VerifyProcessStateDataResponse Constructor
[image]

Initializes a new instance of the VerifyProcessStateDataResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public VerifyProcessStateDataResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
VerifyProcessStateDataResponse Class
VerifyProcessStateDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace


VerifyProcessStateDataResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

VerifyProcessStateDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace
VerifyProcessStateDataRequest


VerifyProcessStateDataResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsValid |
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

VerifyProcessStateDataResponse Class
Microsoft.Crm.Sdk.Messages Namespace
VerifyProcessStateDataRequest


VerifyProcessStateDataResponse.IsValid Property
[image]

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsValid As Boolean

C#
public bool IsValid { get; }

C++

J#

JScript

Property Value
Type: Boolean
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
VerifyProcessStateDataResponse Class
VerifyProcessStateDataResponse Members
Microsoft.Crm.Sdk.Messages Namespace


WhoAmIRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve the system user ID for the currently logged on user or the user under whose context the code is running.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class WhoAmIRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class WhoAmIRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
Console.WriteLine("Enabling auditing on the organization and account entities.");

// Enable auditing on the organization.
// First, get the organization's ID from the system user record.
Guid orgId = ((WhoAmIResponse)_service.Execute(new WhoAmIRequest())).OrganizationId;

// Next, retrieve the organization's record.
Organization org = _service.Retrieve(Organization.EntityLogicalName, orgId,
    new ColumnSet(new string[] { "organizationid", "isauditenabled" })) as Organization;

// Finally, enable auditing on the organization.
bool organizationAuditingFlag = org.IsAuditEnabled.Value;
org.IsAuditEnabled = true;
_service.Update(org);

// Enable auditing on account entities.
bool accountAuditingFlag = EnableEntityAuditing(Account.EntityLogicalName, true);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  WhoAmIResponse.
Privileges and Access Rights
For a complete list of the privileges required, see WhoAmI Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.WhoAmIRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
WhoAmIRequest Members
Microsoft.Crm.Sdk.Messages Namespace
WhoAmIResponse
Other Resources
Organization Entities
BusinessUnit Entity
User and Team Entities
Sample: Audit Entity Data Changes


WhoAmIRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the system user ID for the currently logged on user or the user under whose context the code is running.

The following tables list the members exposed by the WhoAmIRequest type.

Public Constructors

Name | Description
WhoAmIRequest | Initializes a new instance of the WhoAmIRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WhoAmIRequest Class
Microsoft.Crm.Sdk.Messages Namespace
WhoAmIResponse

Other Resources

Organization Entities
BusinessUnit Entity
User and Team Entities
Sample: Audit Entity Data Changes


WhoAmIRequest Constructor
[image]

Initializes a new instance of the WhoAmIRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WhoAmIRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WhoAmIRequest Class
WhoAmIRequest Members
Microsoft.Crm.Sdk.Messages Namespace


WhoAmIRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WhoAmIRequest Class
Microsoft.Crm.Sdk.Messages Namespace
WhoAmIResponse

Other Resources

Organization Entities
BusinessUnit Entity
User and Team Entities
Sample: Audit Entity Data Changes


WhoAmIRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

WhoAmIRequest Class
Microsoft.Crm.Sdk.Messages Namespace
WhoAmIResponse

Other Resources

Organization Entities
BusinessUnit Entity
User and Team Entities
Sample: Audit Entity Data Changes


WhoAmIResponse Class
See Also Members
[image]

Contains the response from the WhoAmIRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class WhoAmIResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class WhoAmIResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.WhoAmIResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WhoAmIResponse Members
Microsoft.Crm.Sdk.Messages Namespace
WhoAmIRequest


WhoAmIResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the WhoAmIRequest class.

The following tables list the members exposed by the WhoAmIResponse type.

Public Constructors

Name | Description
WhoAmIResponse | Initializes a new instance of the WhoAmIResponse class.
Top

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the ID of the business to which the logged on user belongs.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OrganizationId | Gets the ID of the organization that the user belongs to.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | UserId | Gets the ID of the user who is logged on.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WhoAmIResponse Class
Microsoft.Crm.Sdk.Messages Namespace
WhoAmIRequest


WhoAmIResponse Constructor
[image]

Initializes a new instance of the WhoAmIResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WhoAmIResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WhoAmIResponse Class
WhoAmIResponse Members
Microsoft.Crm.Sdk.Messages Namespace


WhoAmIResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WhoAmIResponse Class
Microsoft.Crm.Sdk.Messages Namespace
WhoAmIRequest


WhoAmIResponse Properties
[image]

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the ID of the business to which the logged on user belongs.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OrganizationId | Gets the ID of the organization that the user belongs to.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | UserId | Gets the ID of the user who is logged on.

See Also

Reference

WhoAmIResponse Class
Microsoft.Crm.Sdk.Messages Namespace
WhoAmIRequest


WhoAmIResponse.BusinessUnitId Property
[image]

Gets the ID of the business to which the logged on user belongs.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property BusinessUnitId As Guid

C#
public Guid BusinessUnitId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the business to which the logged on user belongs. This corresponds to the BusinessUnit.BusinessUnitId attribute, which is the primary key for the BusinessUnit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WhoAmIResponse Class
WhoAmIResponse Members
Microsoft.Crm.Sdk.Messages Namespace


WhoAmIResponse.OrganizationId Property
[image]

Gets the ID of the organization that the user belongs to.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property OrganizationId As Guid

C#
public Guid OrganizationId { get; }

C++

J#

JScript

Property Value
Type: Guid
ID of the organization that the user belongs to. This corresponds to the Organization.OrganizationId attribute, which is the primary key for the Organization entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WhoAmIResponse Class
WhoAmIResponse Members
Microsoft.Crm.Sdk.Messages Namespace


WhoAmIResponse.UserId Property
[image]

Gets the ID of the user who is logged on.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property UserId As Guid

C#
public Guid UserId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the user who is currently logged on or the user under whose context the executed code is running. This corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WhoAmIResponse Class
WhoAmIResponse Members
Microsoft.Crm.Sdk.Messages Namespace


WinOpportunityRequest Class
See Also Example Members
[image]

Contains the data that is needed to set the state of an opportunity to Won.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class WinOpportunityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class WinOpportunityRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Close the opportunity as won
var winOppRequest = new WinOpportunityRequest
{
    OpportunityClose = new OpportunityClose
    {
        OpportunityId = new EntityReference
            (Opportunity.EntityLogicalName, _opportunityId)
    },
    Status = new OptionSetValue((int)opportunity_statuscode.Won),
};

_serviceProxy.Execute(winOppRequest);

Console.WriteLine("Opportunity closed as Won.");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of WinOpportunityResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Opportunity entity.
For a complete list of the required privileges, see WinOpportunity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.WinOpportunityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
WinOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace
WinOpportunityResponse
Other Resources
WinOpportunity Privileges
Opportunity Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


WinOpportunityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to set the state of an opportunity to Won.

The following tables list the members exposed by the WinOpportunityRequest type.

Public Constructors

Name | Description
WinOpportunityRequest | Initializes a new instance of the WinOpportunityRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityClose | Gets or sets the opportunity close activity associated with this state change. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a new status of the opportunity. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WinOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
WinOpportunityResponse

Other Resources

WinOpportunity Privileges
Opportunity Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


WinOpportunityRequest Constructor
[image]

Initializes a new instance of the WinOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WinOpportunityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinOpportunityRequest Class
WinOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


WinOpportunityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WinOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
WinOpportunityResponse

Other Resources

WinOpportunity Privileges
Opportunity Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


WinOpportunityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OpportunityClose | Gets or sets the opportunity close activity associated with this state change. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a new status of the opportunity. Required.

See Also

Reference

WinOpportunityRequest Class
Microsoft.Crm.Sdk.Messages Namespace
WinOpportunityResponse

Other Resources

WinOpportunity Privileges
Opportunity Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


WinOpportunityRequest.OpportunityClose Property
[image]

Gets or sets the opportunity close activity associated with this state change. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OpportunityClose As Entity

C#
public Entity OpportunityClose { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The opportunity close activity associated with this state change. This must be an instance of the OpportunityClose class, which is a subclass of the Entity class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinOpportunityRequest Class
WinOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


WinOpportunityRequest.Status Property
[image]

Gets or sets a new status of the opportunity. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The status of the opportunity.

  Remarks
The Status property corresponds to the Opportunity.StatusCode attribute. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system will set the appropriate corresponding status value. For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinOpportunityRequest Class
WinOpportunityRequest Members
Microsoft.Crm.Sdk.Messages Namespace


WinOpportunityResponse Class
See Also Members
[image]

Contains the response from the WinOpportunityRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class WinOpportunityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class WinOpportunityResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.WinOpportunityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace
WinOpportunityRequest


WinOpportunityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the WinOpportunityRequest class.

The following tables list the members exposed by the WinOpportunityResponse type.

Public Constructors

Name | Description
WinOpportunityResponse | Initializes a new instance of the WinOpportunityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WinOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
WinOpportunityRequest


WinOpportunityResponse Constructor
[image]

Initializes a new instance of the WinOpportunityResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WinOpportunityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinOpportunityResponse Class
WinOpportunityResponse Members
Microsoft.Crm.Sdk.Messages Namespace


WinOpportunityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WinOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
WinOpportunityRequest


WinOpportunityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

WinOpportunityResponse Class
Microsoft.Crm.Sdk.Messages Namespace
WinOpportunityRequest


WinQuoteRequest Class
See Also Example Members
[image]

Contains the data that is needed to set the state of a quote to Won.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class WinQuoteRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class WinQuoteRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Mark the quote as won
// Note: this is necessary in order to convert a quote into a
// SalesOrder.
WinQuoteRequest winQuoteRequest = new WinQuoteRequest()
{
    QuoteClose = new QuoteClose()
    {
        Subject = "Quote Close" + DateTime.Now.ToString(),
        QuoteId = quote.ToEntityReference()
    },
    Status = new OptionSetValue(-1)
};
_serviceProxy.Execute(winQuoteRequest);

Console.WriteLine("Quote won.");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute method, which returns an instance of WinQuoteResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges on the Quote entity.
For a complete list of the required privileges, see WinQuote Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Crm.Sdk.Messages.WinQuoteRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
WinQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace
WinQuoteResponse
Other Resources
WinQuote Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


WinQuoteRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to set the state of a quote to Won.

The following tables list the members exposed by the WinQuoteRequest type.

Public Constructors

Name | Description
WinQuoteRequest | Initializes a new instance of the WinQuoteRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteClose | Gets or sets the quote close activity associated with this state change. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a new status of the quote. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WinQuoteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
WinQuoteResponse

Other Resources

WinQuote Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


WinQuoteRequest Constructor
[image]

Initializes a new instance of the WinQuoteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WinQuoteRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinQuoteRequest Class
WinQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


WinQuoteRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WinQuoteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
WinQuoteResponse

Other Resources

WinQuote Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


WinQuoteRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | QuoteClose | Gets or sets the quote close activity associated with this state change. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Status | Gets or sets a new status of the quote. Required.

See Also

Reference

WinQuoteRequest Class
Microsoft.Crm.Sdk.Messages Namespace
WinQuoteResponse

Other Resources

WinQuote Privileges
Quote, Order and Invoice Entities
Sample: Process Quotes, Sales Orders and Invoices
How Role-Based Security Can Be Used to Control Access to Entities In CRM
How Instance-Based Security Can Be Used to Control Access to Entity Instances (Records) In CRM


WinQuoteRequest.QuoteClose Property
[image]

Gets or sets the quote close activity associated with this state change. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property QuoteClose As Entity

C#
public Entity QuoteClose { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The quote close activity associated with this state change. This must be an instance of the QuoteClose class, which is a subclass of the Entity class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinQuoteRequest Class
WinQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


WinQuoteRequest.Status Property
[image]

Gets or sets a new status of the quote. Required.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As OptionSetValue

C#
public OptionSetValue Status { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetValue
The new status of the quote.

  Remarks
The Status property corresponds to the Quote.StatusCode attribute. It is shown as the Status Reason in the Microsoft Dynamics CRM application. If you set the value of this property to -1, the system will set the appropriate corresponding status value. For more information, see Record State and Status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinQuoteRequest Class
WinQuoteRequest Members
Microsoft.Crm.Sdk.Messages Namespace


WinQuoteResponse Class
See Also Members
[image]

Contains the response from the WinQuoteRequest class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/crm/2011/Contracts")> _
Public NotInheritable Class WinQuoteResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/crm/2011/Contracts")]
public sealed class WinQuoteResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Crm.Sdk.Messages.WinQuoteResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinQuoteResponse Members
Microsoft.Crm.Sdk.Messages Namespace
WinQuoteRequest


WinQuoteResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the WinQuoteRequest class.

The following tables list the members exposed by the WinQuoteResponse type.

Public Constructors

Name | Description
WinQuoteResponse | Initializes a new instance of the WinQuoteResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WinQuoteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
WinQuoteRequest


WinQuoteResponse Constructor
[image]

Initializes a new instance of the WinQuoteResponse class.

Namespace: Microsoft.Crm.Sdk.Messages
Assembly: Microsoft.Crm.Sdk.Proxy (in Microsoft.Crm.Sdk.Proxy.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WinQuoteResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WinQuoteResponse Class
WinQuoteResponse Members
Microsoft.Crm.Sdk.Messages Namespace


WinQuoteResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WinQuoteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
WinQuoteRequest


WinQuoteResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

WinQuoteResponse Class
Microsoft.Crm.Sdk.Messages Namespace
WinQuoteRequest


Microsoft.Xrm.Sdk Namespace

Classes

Class | Description
AliasedValue | Used to return aggregate, group by, and aliased values from a query.
AttributeCollection | Provides a collection of attributes for an entity.
AttributeLogicalNameAttribute | Used by the code generation tool to create classes based on entities.
AttributeMapping | This type doesn’t have any extensibility scenarios in this release.
AttributeMappingCollection | This type doesn’t have any extensibility scenarios in this release.
AttributePrivilege | Specifies the field level security privileges allowed for an attribute.
AttributePrivilegeCollection | Specifies a collection of field level security privileges allowed for the specified attributes.
BaseServiceFault | Represents a service fault.
BooleanManagedProperty | Defines a managed property that stores a Boolean value.
CallerImpersonationScope | Identifies a user as the owner of all data changes made by calls to a Web service.
ClaimTypes | Identifies the types of claims that are supported or may be supported in a future product release.
DataCollection | Represents a strongly typed list of objects that can be accessed by index. Provides methods to search, sort, and manipulate lists. Extends Collection.
DataCollection | Represents a collection of keys and values.
DiscoveryServiceFault | Represents a discovery service fault.
Entity | Represents an instance of an entity (a record).
EntityCollection | Contains a collection of entity instances.
EntityImageCollection | Contains a collection of Entity image objects.
EntityReference | Identifies a record.
EntityReferenceCollection | Contains a collection of entity references.
ErrorDetailCollection | Contains a collection of objects that provide details on an error.
ExecuteMultipleResponseItem | Contains the response from execution of a message request.
ExecuteMultipleResponseItemCollection | Contains a collection of ExecuteMultipleResponseItem instances.
ExecuteMultipleSettings | Defines the execution behavior of ExecuteMultipleRequest.
FieldPermissionType | Defines the possible field permission types.
FormattedValueCollection | Contains a collection of formatted values for the attributes for an entity.
InvalidPluginExecutionException | Represents an exception that occurred during plug-in execution.
KnownTypesResolver | Resolves known organization message request and response types for the SDK contracts.
Label | Contains a collection of translations for a label.
LocalizedLabel | Contains a localized label, including the label string and the language code.
LocalizedLabelCollection | Defines a collection of LocalizedLabel.
ManagedProperty | Represents a strongly typed managed property.
Money | Contains the value for a money attribute.
OptionSetValue | Represents a value for an attribute that has an option set.
OrganizationRequest | Contains the data needed to execute a request and the base class for all organization requests.
OrganizationRequestCollection | Contains a collection of organization requests.
OrganizationResponse | Contains the response from a request and the base class for all organization responses.
OrganizationServiceFault | Represents an organization service fault.
ParameterCollection | Provides a collection of parameters for a request.
QuickFindConfiguration | For internal use only.
QuickFindConfigurationCollection | For internal use only.
QuickFindResult | For internal use only.
QuickFindResultCollection | For internal use only.
RelatedEntityCollection | Contains a collection of related entities.
Relationship | Represents a relationship between two entities.
RelationshipQueryCollection | Provides a collection of relationship queries.
RelationshipSchemaNameAttribute | Used by the code generation tool to create classes based on entities.
RemoteExecutionContext | Defines the contextual information sent to a remote service endpoint at run-time.
SaveChangesException | Represents an exception that occurred when saving changes to the OrganizationServiceContext.
SaveChangesResult | Contains the result of the save changes operation returned from the organization web service.
SaveChangesResultCollection | Provides a collection of results for a save changes operation.
ServiceEndpointFault | Represents a fault at a service endpoint in the cloud.

Interfaces

Interface | Description
IExecutionContext | Base interface that defines the contextual information passed to a plug-in or custom workflow activity at run-time.
IOrganizationService | Provides programmatic access to the metadata and data for an organization.
IOrganizationServiceFactory | Represents a factory for creating IOrganizationService instances.
IPlugin | Base interface for a plug-in.
IPluginExecutionContext | Defines the contextual information passed to a plug-in at run-time. Contains information that describes the run-time environment that the plug-in is executing in, information related to the execution pipeline, and entity business information.
IProxyTypesAssemblyProvider | Provides the early-bound entity types assembly that was created using the CrmSvcUtil utility.
IServiceEndpointNotificationService | Posts the plug-in execution context to the Microsoft Azure Service Bus.
IServiceEndpointPlugin | Defines a plug-in that implements the service behavior of a Microsoft Azure Service Bus listener.
ITracingService | Provides a method of logging run-time trace information for plug-ins.
ITwoWayServiceEndpointPlugin | Defines a plug-in that implements the service behavior of a Microsoft Azure Service Bus listener.
IWebHttpServiceEndpointPlugin | Defines a plug-in that implements the service behavior of a Microsoft Azure Service Bus listener.

Enumerations

Enumeration | Description
EntityRole | Contains values to indicate the role the entity plays in a relationship.
EntityState | Indicates the state of an entity as tracked by the OrganizationServiceContext and indicates to the server the operation that should be performed for a related entity.
OperationStatus | Represents the current state of an operation.


AliasedValue Class
See Also Members
[image]

Used to return aggregate, group by, and aliased values from a query.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AliasedValue", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<KnownTypeAttribute("GetKnownAliasedValueTypes")> _
Public NotInheritable Class AliasedValue
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="AliasedValue", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[KnownTypeAttribute("GetKnownAliasedValueTypes")]
public sealed class AliasedValue : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.AliasedValue
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AliasedValue Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Build Queries with FetchXML
Use FetchXML Aggregation
Sample: Use Aggregation in FetchXML


AliasedValue Members
See Also Constructors Methods Properties
[image]

Used to return aggregate, group by, and aliased values from a query.

The following tables list the members exposed by the AliasedValue type.

Public Constructors

Name | Description
AliasedValue | Overloaded. Initializes a new instance of the AliasedValue class.
Top

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets the name of the attribute on which the aggregate, group by, or select operation was performed.
public property | EntityLogicalName | Gets the name of the entity the attribute belongs to.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Value | Gets the value returned by the query.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AliasedValue Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Build Queries with FetchXML
Use FetchXML Aggregation
Sample: Use Aggregation in FetchXML


AliasedValue Constructor
[image]

Initializes a new instance of the AliasedValue class.

Overload List

Name | Description
AliasedValue () | Initializes a new instance of the AliasedValue class.
AliasedValue (String, String, Object) | Initializes a new instance of the AliasedValue class.

See Also

Reference

AliasedValue Class
AliasedValue Members
Microsoft.Xrm.Sdk Namespace


AliasedValue Constructor ()
[image]

Initializes a new instance of the AliasedValue class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AliasedValue ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AliasedValue Class
AliasedValue Members
Microsoft.Xrm.Sdk Namespace


AliasedValue Constructor (String, String, Object)
[image]

Initializes a new instance of the AliasedValue class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityLogicalName As String, _
    attributeLogicalName As String, _
    value As Object _
)

C#
public AliasedValue (
    string entityLogicalName,
    string attributeLogicalName,
    Object value
)

C++

J#

JScript

Parameters
entityLogicalName
Type: String. The name of the entity the attribute belongs to.
attributeLogicalName
Type: String. The attribute on which the aggregate, group by, or select operation was performed.
value
Type: Object. The value returned by the query.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AliasedValue Class
AliasedValue Members
Microsoft.Xrm.Sdk Namespace


AliasedValue Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AliasedValue Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Build Queries with FetchXML
Use FetchXML Aggregation
Sample: Use Aggregation in FetchXML


AliasedValue Properties
[image]

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets the name of the attribute on which the aggregate, group by, or select operation was performed.
public property | EntityLogicalName | Gets the name of the entity the attribute belongs to.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Value | Gets the value returned by the query.

See Also

Reference

AliasedValue Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Build Queries with FetchXML
Use FetchXML Aggregation
Sample: Use Aggregation in FetchXML


AliasedValue.AttributeLogicalName Property
[image]

Gets the name of the attribute on which the aggregate, group by, or select operation was performed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeLogicalName As String

C#
[DataMemberAttribute]
public string AttributeLogicalName { get; }

C++

J#

JScript

Property Value
Type: String

The name of the attribute on which the aggregate, group by, or select operation was performed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AliasedValue Class
AliasedValue Members
Microsoft.Xrm.Sdk Namespace


AliasedValue.EntityLogicalName Property
[image]

Gets the name of the entity the attribute belongs to.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityLogicalName As String

C#
[DataMemberAttribute]
public string EntityLogicalName { get; }

C++

J#

JScript

Property Value
Type: String

The name of the entity the attribute belongs to.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AliasedValue Class
AliasedValue Members
Microsoft.Xrm.Sdk Namespace


AliasedValue.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Remarks

                        Gets or sets the structure that contains extra data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AliasedValue Class
AliasedValue Members
Microsoft.Xrm.Sdk Namespace


AliasedValue.Value Property
[image]

Gets the value returned by the query.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Value As Object

C#
[DataMemberAttribute]
public Object Value { get; }

C++

J#

JScript

Property Value
Type: Object
The value returned by the query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AliasedValue Class
AliasedValue Members
Microsoft.Xrm.Sdk Namespace


AttributeCollection Class
See Also Members
[image]

Provides a collection of attributes for an entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="AttributeCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<KnownTypeAttribute("GetKnownParameterTypes")> _
Public NotInheritable Class AttributeCollection
    Inherits DataCollection(Of String, Object)

C#
[CollectionDataContractAttribute(Name="AttributeCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[KnownTypeAttribute("GetKnownParameterTypes")]
public sealed class AttributeCollection : DataCollection<string,Object>

C++

J#

JScript

  Remarks
For each attribute in the collection there is a key/value pair. The key is the logical name of the attribute as defined in the attribute metadata.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.AttributeCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeCollection Members
Microsoft.Xrm.Sdk Namespace
AttributeMetadata
Entity


AttributeCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Provides a collection of attributes for an entity.

The following tables list the members exposed by the AttributeCollection type.

Public Constructors

Name | Description
AttributeCollection | Initializes a new instance of the AttributeCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

AttributeCollection Class
Microsoft.Xrm.Sdk Namespace
AttributeMetadata
Entity


AttributeCollection Constructor
[image]

Initializes a new instance of the AttributeCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeCollection Class
AttributeCollection Members
Microsoft.Xrm.Sdk Namespace


AttributeCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

AttributeCollection Class
Microsoft.Xrm.Sdk Namespace
AttributeMetadata
Entity


AttributeCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

AttributeCollection Class
Microsoft.Xrm.Sdk Namespace
AttributeMetadata
Entity


AttributeLogicalNameAttribute Class
See Also Members
[image]

Used by the code generation tool to create classes based on entities.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public NotInheritable Class AttributeLogicalNameAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public sealed class AttributeLogicalNameAttribute : Attribute

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.AttributeLogicalNameAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeLogicalNameAttribute Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use the Early Bound Entity Classes in Code


AttributeLogicalNameAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Used by the code generation tool to create classes based on entities.

The following tables list the members exposed by the AttributeLogicalNameAttribute type.

Public Constructors

Name | Description
AttributeLogicalNameAttribute | Initializes a new instance of theAttributeLogicalNameAttribute class
Top

Public Properties

 | Name | Description
public property | LogicalName | Gets the logical name of an attribute.
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

AttributeLogicalNameAttribute Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Early Bound Entity Classes in Code


AttributeLogicalNameAttribute Constructor
[image]

Initializes a new instance of the AttributeLogicalNameAttribute class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    logicalName As String _
)

C#
public AttributeLogicalNameAttribute (
    string logicalName
)

C++

J#

JScript

Parameters
logicalName
Type: String.
The logical name of an attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeLogicalNameAttribute Class
AttributeLogicalNameAttribute Members
Microsoft.Xrm.Sdk Namespace


AttributeLogicalNameAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

AttributeLogicalNameAttribute Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Early Bound Entity Classes in Code


AttributeLogicalNameAttribute Properties
[image]

Public Properties

 | Name | Description
public property | LogicalName | Gets the logical name of an attribute.
public property | TypeId | (inherited from Attribute)

See Also

Reference

AttributeLogicalNameAttribute Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Early Bound Entity Classes in Code


AttributeLogicalNameAttribute.LogicalName Property
[image]

Gets the logical name of an attribute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LogicalName As String

C#
public string LogicalName { get; }

C++

J#

JScript

Property Value
Type: String

The logical name of an attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeLogicalNameAttribute Class
AttributeLogicalNameAttribute Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping Class
See Also Members
[image]

This type doesn’t have any extensibility scenarios in this release.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Name:="AttributeMapping", Namespace:="http://schemas.microsoft.com/xrm/2014/Contracts")> _
Public NotInheritable Class AttributeMapping
    Implements IExtensibleDataObject

C#
[SerializableAttribute]
[DataContractAttribute(Name="AttributeMapping", Namespace="http://schemas.microsoft.com/xrm/2014/Contracts")]
public sealed class AttributeMapping : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.AttributeMapping
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

This type doesn’t have any extensibility scenarios in this release.

The following tables list the members exposed by the AttributeMapping type.

Public Constructors

Name | Description
AttributeMapping | Overloaded.
Top

Public Properties

 | Name | Description
public property | AllowedSyncDirection |
public property | AttributeCrmDisplayName |
public property | AttributeCrmName |
public property | AttributeExchangeDisplayName |
public property | AttributeExchangeName |
public property | AttributeMappingId |
public property | ComputedProperties |
public property | DefaultSyncDirection |
public property | EntityTypeCode |
public property | IsComputed |
public property | MappingName |
public property | SyncDirection |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ExtensionData |
Top

See Also

Reference

AttributeMapping Class
Microsoft.Xrm.Sdk Namespace


AttributeMapping Constructor
[image]

Overload List

Name | Description
AttributeMapping () |
AttributeMapping (Guid, String, String, String, Int32, Int32, Int32, Int32, Boolean, Collection, String, String) |

See Also

Reference

AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping Constructor ()
[image]

Initializes a new instance of the AttributeMapping Class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeMapping ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping Constructor (Guid, String, String, String, Int32, Int32, Int32, Int32, Boolean, Collection, String, String)
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    attributeMappingId As Guid, _
    mappingName As String, _
    attributeCrmName As String, _
    attributeExchangeName As String, _
    entityName As Integer, _
    syncDirection As Integer, _
    defaultSyncDirection As Integer, _
    allowedSyncDirection As Integer, _
    isComputed As Boolean, _
    computedProperties As Collection(Of String), _
    attributeCrmDisplayName As String, _
    attributeExchangeDisplayName As String _
)

C#
public AttributeMapping (
    Guid attributeMappingId,
    string mappingName,
    string attributeCrmName,
    string attributeExchangeName,
    int entityName,
    int syncDirection,
    int defaultSyncDirection,
    int allowedSyncDirection,
    bool isComputed,
    Collection<string> computedProperties,
    string attributeCrmDisplayName,
    string attributeExchangeDisplayName
)

C++

J#

JScript

Parameters
attributeMappingId
mappingName
attributeCrmName
attributeExchangeName
entityTypeCode
syncDirection
defaultSyncDirection
allowedSyncDirection
isComputed
computedProperties
attributeCrmDisplayName
attributeExchangeDisplayName
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AttributeMapping Class
Microsoft.Xrm.Sdk Namespace


AttributeMapping Properties
[image]

Public Properties

 | Name | Description
public property | AllowedSyncDirection |
public property | AttributeCrmDisplayName |
public property | AttributeCrmName |
public property | AttributeExchangeDisplayName |
public property | AttributeExchangeName |
public property | AttributeMappingId |
public property | ComputedProperties |
public property | DefaultSyncDirection |
public property | EntityTypeCode |
public property | IsComputed |
public property | MappingName |
public property | SyncDirection |

Explicit Interface Implementations

Name | Description
ExtensionData |

See Also

Reference

AttributeMapping Class
Microsoft.Xrm.Sdk Namespace


AttributeMapping.AllowedSyncDirection Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AllowedSyncDirection As Integer

C#
[DataMemberAttribute]
public int AllowedSyncDirection { get; }

C++

J#

JScript

Property Value
Returns Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.AttributeCrmDisplayName Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeCrmDisplayName As String

C#
[DataMemberAttribute]
public string AttributeCrmDisplayName { get; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.AttributeCrmName Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeCrmName As String

C#
[DataMemberAttribute]
public string AttributeCrmName { get; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.AttributeExchangeDisplayName Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeExchangeDisplayName As String

C#
[DataMemberAttribute]
public string AttributeExchangeDisplayName { get; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.AttributeExchangeName Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeExchangeName As String

C#
[DataMemberAttribute]
public string AttributeExchangeName { get; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.AttributeMappingId Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeMappingId As Guid

C#
[DataMemberAttribute]
public Guid AttributeMappingId { get; }

C++

J#

JScript

Property Value
Returns Guid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.ComputedProperties Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ComputedProperties As Collection(Of String)

C#
[DataMemberAttribute]
public Collection<string> ComputedProperties { get; }

C++

J#

JScript

Property Value
Returns Collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.DefaultSyncDirection Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DefaultSyncDirection As Integer

C#
[DataMemberAttribute]
public int DefaultSyncDirection { get; }

C++

J#

JScript

Property Value
Returns Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.EntityTypeCode Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic

C#

C++

J#

JScript

Property Value
Returns Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.IsComputed Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsComputed As Boolean

C#
[DataMemberAttribute]
public bool IsComputed { get; }

C++

J#

JScript

Property Value
Returns Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.MappingName Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MappingName As String

C#
[DataMemberAttribute]
public string MappingName { get; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.SyncDirection Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SyncDirection As Integer

C#
[DataMemberAttribute]
public int SyncDirection { get; }

C++

J#

JScript

Property Value
Returns Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMapping.ExtensionData Property
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Private Property System.Runtime.Serialization.IExtensibleDataObject.ExtensionData As ExtensionDataObject Implements IExtensibleDataObject.ExtensionData

C#
ExtensionDataObject IExtensibleDataObject.ExtensionData { get; set; }

C++

J#

JScript

Property Value
Returns ExtensionDataObject.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMapping Class
AttributeMapping Members
Microsoft.Xrm.Sdk Namespace


AttributeMappingCollection Class
See Also Members
[image]

This type doesn’t have any extensibility scenarios in this release.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<CollectionDataContractAttribute(Name:="AttributeMappingCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<KnownTypeAttribute(GetType(AttributeMapping))> _
Public NotInheritable Class AttributeMappingCollection
    Inherits DataCollection(Of AttributeMapping)

C#
[SerializableAttribute]
[CollectionDataContractAttribute(Name="AttributeMappingCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[KnownTypeAttribute(typeof(AttributeMapping))]
public sealed class AttributeMappingCollection : DataCollection<AttributeMapping>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.AttributeMappingCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMappingCollection Members
Microsoft.Xrm.Sdk Namespace


AttributeMappingCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

This type doesn’t have any extensibility scenarios in this release.

The following tables list the members exposed by the AttributeMappingCollection type.

Public Constructors

Name | Description
AttributeMappingCollection | Overloaded.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

AttributeMappingCollection Class
Microsoft.Xrm.Sdk Namespace


AttributeMappingCollection Constructor
[image]

Overload List

Name | Description
AttributeMappingCollection () |
AttributeMappingCollection (IList) |

See Also

Reference

AttributeMappingCollection Class
AttributeMappingCollection Members
Microsoft.Xrm.Sdk Namespace


AttributeMappingCollection Constructor ()
[image]

Initializes a new instance of the AttributeMappingCollection Class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeMappingCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMappingCollection Class
AttributeMappingCollection Members
Microsoft.Xrm.Sdk Namespace


AttributeMappingCollection Constructor (IList)
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    list As IList(Of AttributeMapping) _
)

C#
public AttributeMappingCollection (
    IList<AttributeMapping> list
)

C++

J#

JScript

Parameters
list
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMappingCollection Class
AttributeMappingCollection Members
Microsoft.Xrm.Sdk Namespace


AttributeMappingCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

AttributeMappingCollection Class
Microsoft.Xrm.Sdk Namespace


AttributeMappingCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

AttributeMappingCollection Class
Microsoft.Xrm.Sdk Namespace


AttributePrivilege Class
See Also Members
[image]

Specifies the field level security privileges allowed for an attribute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Name:="AttributePrivilege", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class AttributePrivilege
    Implements IExtensibleDataObject

C#
[SerializableAttribute]
[DataContractAttribute(Name="AttributePrivilege", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class AttributePrivilege : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.AttributePrivilege
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilege Members
Microsoft.Xrm.Sdk Namespace
AttributePrivilegeCollection
RetrievePrincipalAttributePrivilegesResponse
Other Resources
How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM


AttributePrivilege Members
See Also Constructors Methods Properties
[image]

Specifies the field level security privileges allowed for an attribute.

The following tables list the members exposed by the AttributePrivilege type.

Public Constructors

Name | Description
AttributePrivilege | Overloaded. Initializes a new instance of the AttributePrivilege class.
Top

Public Properties

 | Name | Description
public property | AttributeId | Gets the ID of the attribute.
public property | CanCreate | Gets whether create of the attribute value is allowed.
public property | CanRead | Gets whether read of the attribute value is allowed.
public property | CanUpdate | Gets whether update of the attribute value is allowed.
public property | ExtensionData | Gets or sets the structure that contains extra data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AttributePrivilege Class
Microsoft.Xrm.Sdk Namespace
AttributePrivilegeCollection
RetrievePrincipalAttributePrivilegesResponse

Other Resources

How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM


AttributePrivilege Constructor
[image]

Initializes a new instance of the AttributePrivilege class.

Overload List

Name | Description
AttributePrivilege () | Initializes a new instance of theAttributePrivilege class.
AttributePrivilege (Guid, Int32, Int32, Int32) | Initializes a new instance of the AttributePrivilege class setting the attribute Id, and whether it is valid to create, read and update the attribute value.

See Also

Reference

AttributePrivilege Class
AttributePrivilege Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilege Constructor ()
[image]

Initializes a new instance of the AttributePrivilege class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributePrivilege ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilege Class
AttributePrivilege Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilege Constructor (Guid, Int32, Int32, Int32)
[image]

Initializes a new instance of the AttributePrivilege class setting the attribute Id, and whether it is valid to create, read and update the attribute value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    attributeId As Guid, _
    canCreate As Integer, _
    canRead As Integer, _
    canUpdate As Integer _
)

C#
public AttributePrivilege (
    Guid attributeId,
    int canCreate,
    int canRead,
    int canUpdate
)

C++

J#

JScript

Parameters
attributeId
Type: Guid. The attribute ID.
canCreate
Type: Int32. Whether the attribute value can be specified on create.
canRead
Type: Int32. Whether the attribute value can be read.
canUpdate
Type: Int32. Whether the attribute value can be updated.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilege Class
AttributePrivilege Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilege Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AttributePrivilege Class
Microsoft.Xrm.Sdk Namespace
AttributePrivilegeCollection
RetrievePrincipalAttributePrivilegesResponse

Other Resources

How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM


AttributePrivilege Properties
[image]

Public Properties

 | Name | Description
public property | AttributeId | Gets the ID of the attribute.
public property | CanCreate | Gets whether create of the attribute value is allowed.
public property | CanRead | Gets whether read of the attribute value is allowed.
public property | CanUpdate | Gets whether update of the attribute value is allowed.
public property | ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

AttributePrivilege Class
Microsoft.Xrm.Sdk Namespace
AttributePrivilegeCollection
RetrievePrincipalAttributePrivilegesResponse

Other Resources

How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM


AttributePrivilege.AttributeId Property
[image]

Gets the ID of the attribute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeId As Guid

C#
[DataMemberAttribute]
public Guid AttributeId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilege Class
AttributePrivilege Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilege.CanCreate Property
[image]

Gets whether create of the attribute value is allowed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanCreate As Integer

C#
[DataMemberAttribute]
public int CanCreate { get; }

C++

J#

JScript

Property Value
Type: Int32
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilege Class
AttributePrivilege Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilege.CanRead Property
[image]

Gets whether read of the attribute value is allowed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanRead As Integer

C#
[DataMemberAttribute]
public int CanRead { get; }

C++

J#

JScript

Property Value
Type: Int32
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilege Class
AttributePrivilege Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilege.CanUpdate Property
[image]

Gets whether update of the attribute value is allowed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanUpdate As Integer

C#
[DataMemberAttribute]
public int CanUpdate { get; }

C++

J#

JScript

Property Value
Type: Int32
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilege Class
AttributePrivilege Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilege.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject

The extension data.

  Remarks

                        Gets or sets the structure that contains extra data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilege Class
AttributePrivilege Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilegeCollection Class
See Also Members
[image]

Specifies a collection of field level security privileges allowed for the specified attributes.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<CollectionDataContractAttribute(Name:="AttributePrivilegeCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<KnownTypeAttribute(GetType(AttributePrivilege))> _
Public NotInheritable Class AttributePrivilegeCollection
    Inherits DataCollection(Of AttributePrivilege)

C#
[SerializableAttribute]
[CollectionDataContractAttribute(Name="AttributePrivilegeCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[KnownTypeAttribute(typeof(AttributePrivilege))]
public sealed class AttributePrivilegeCollection : DataCollection<AttributePrivilege>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.AttributePrivilegeCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilegeCollection Members
Microsoft.Xrm.Sdk Namespace
AttributePrivilegeCollection
RetrievePrincipalAttributePrivilegesResponse
Other Resources
How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM


AttributePrivilegeCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Specifies a collection of field level security privileges allowed for the specified attributes.

The following tables list the members exposed by the AttributePrivilegeCollection type.

Public Constructors

Name | Description
AttributePrivilegeCollection | Overloaded. Initializes a new instance of the AttributePrivilegeCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

AttributePrivilegeCollection Class
Microsoft.Xrm.Sdk Namespace
AttributePrivilegeCollection
RetrievePrincipalAttributePrivilegesResponse

Other Resources

How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM


AttributePrivilegeCollection Constructor
[image]

Initializes a new instance of the AttributePrivilegeCollection class.

Overload List

Name | Description
AttributePrivilegeCollection () | Initializes a new instance of the AttributePrivilegeCollection class.
AttributePrivilegeCollection (IList) | Initializes a new instance of the AttributePrivilegeCollection class, setting the list property.

See Also

Reference

AttributePrivilegeCollection Class
AttributePrivilegeCollection Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilegeCollection Constructor ()
[image]

Initializes a new instance of the AttributePrivilegeCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributePrivilegeCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilegeCollection Class
AttributePrivilegeCollection Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilegeCollection Constructor (IList)
[image]

Initializes a new instance of the AttributePrivilegeCollection class, setting the list property.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    list As IList(Of AttributePrivilege) _
)

C#
public AttributePrivilegeCollection (
    IList<AttributePrivilege> list
)

C++

J#

JScript

Parameters
list
Type: IList<AttributePrivilege>. The list of attribute privileges.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributePrivilegeCollection Class
AttributePrivilegeCollection Members
Microsoft.Xrm.Sdk Namespace


AttributePrivilegeCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

AttributePrivilegeCollection Class
Microsoft.Xrm.Sdk Namespace
AttributePrivilegeCollection
RetrievePrincipalAttributePrivilegesResponse

Other Resources

How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM


AttributePrivilegeCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

AttributePrivilegeCollection Class
Microsoft.Xrm.Sdk Namespace
AttributePrivilegeCollection
RetrievePrincipalAttributePrivilegesResponse

Other Resources

How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM


BaseServiceFault Class
See Also Members
[image]

Represents a service fault.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<KnownTypeAttribute(GetType(OrganizationServiceFault))> _
<KnownTypeAttribute(GetType(DiscoveryServiceFault))> _
<DataContractAttribute(Name:="BaseServiceFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public MustInherit Class BaseServiceFault
    Implements IExtensibleDataObject

C#
[SerializableAttribute]
[KnownTypeAttribute(typeof(OrganizationServiceFault))]
[KnownTypeAttribute(typeof(DiscoveryServiceFault))]
[DataContractAttribute(Name="BaseServiceFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public abstract class BaseServiceFault : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.BaseServiceFault

                Microsoft.Xrm.Sdk.DiscoveryServiceFault

                Microsoft.Xrm.Sdk.OrganizationServiceFault
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BaseServiceFault Members
Microsoft.Xrm.Sdk Namespace


BaseServiceFault Members
See Also Methods Properties Constructors
[image]

Represents a service fault.

The following tables list the members exposed by the BaseServiceFault type.

Protected Constructors

Name | Description
BaseServiceFault | Initializes a new instance of the BaseServiceFault class.
Top

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the fault error code.
public property | ErrorDetails | Gets or sets the details of the fault.
public property | ExtensionData | Gets or sets a structure that contains extra data.
public property | Message | Gets or sets the message for the fault.
public property | Timestamp | Gets or sets the date and time when the fault occurred.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BaseServiceFault Class
Microsoft.Xrm.Sdk Namespace


BaseServiceFault Constructor
[image]

Initializes a new instance of the BaseServiceFault class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected BaseServiceFault ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BaseServiceFault Class
BaseServiceFault Members
Microsoft.Xrm.Sdk Namespace


BaseServiceFault Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BaseServiceFault Class
Microsoft.Xrm.Sdk Namespace


BaseServiceFault Properties
[image]

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the fault error code.
public property | ErrorDetails | Gets or sets the details of the fault.
public property | ExtensionData | Gets or sets a structure that contains extra data.
public property | Message | Gets or sets the message for the fault.
public property | Timestamp | Gets or sets the date and time when the fault occurred.

See Also

Reference

BaseServiceFault Class
Microsoft.Xrm.Sdk Namespace


BaseServiceFault.ErrorCode Property
[image]

Gets or sets the fault error code.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorCode As Integer

C#
[DataMemberAttribute]
public int ErrorCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The fault error code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BaseServiceFault Class
BaseServiceFault Members
Microsoft.Xrm.Sdk Namespace


BaseServiceFault.ErrorDetails Property
[image]

Gets or sets the details of the fault.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorDetails As ErrorDetailCollection

C#
[DataMemberAttribute]
public ErrorDetailCollection ErrorDetails { get; set; }

C++

J#

JScript

Property Value
Type: ErrorDetailCollection
The collection of details about the fault.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BaseServiceFault Class
BaseServiceFault Members
Microsoft.Xrm.Sdk Namespace


BaseServiceFault.ExtensionData Property
[image]

Gets or sets a structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BaseServiceFault Class
BaseServiceFault Members
Microsoft.Xrm.Sdk Namespace


BaseServiceFault.Message Property
[image]

Gets or sets the message for the fault.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Message As String

C#
[DataMemberAttribute]
public string Message { get; set; }

C++

J#

JScript

Property Value
Type: String
The message for the fault.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BaseServiceFault Class
BaseServiceFault Members
Microsoft.Xrm.Sdk Namespace


BaseServiceFault.Timestamp Property
[image]

Gets or sets the date and time when the fault occurred.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Timestamp As DateTime

C#
[DataMemberAttribute]
public DateTime Timestamp { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The date and time when the fault occurred.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BaseServiceFault Class
BaseServiceFault Members
Microsoft.Xrm.Sdk Namespace


BooleanManagedProperty Class
See Also Members
[image]

Defines a managed property that stores a Boolean value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="BooleanManagedProperty", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class BooleanManagedProperty
    Inherits ManagedProperty(Of Boolean)

C#
[DataContractAttribute(Name="BooleanManagedProperty", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class BooleanManagedProperty : ManagedProperty<bool>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.ManagedProperty
    Microsoft.Xrm.Sdk.BooleanManagedProperty
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanManagedProperty Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use Managed Properties
Sample: Create and Update Entity Metadata


BooleanManagedProperty Members
See Also Constructors Methods Properties
[image]

Defines a managed property that stores a Boolean value.

The following tables list the members exposed by the BooleanManagedProperty type.

Public Constructors

Name | Description
BooleanManagedProperty | Overloaded. Initializes a new instance of theBooleanManagedProperty class
Top

Public Properties

 | Name | Description
public property | CanBeChanged | Gets or sets whether the managed property value can be changed. (inherited from ManagedProperty)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from ManagedProperty)
public property | ManagedPropertyLogicalName | Gets the logical name for the managed property. (inherited from ManagedProperty)
public property | Value | Gets or sets the value of the managed property. (inherited from ManagedProperty)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BooleanManagedProperty Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use Managed Properties
Sample: Create and Update Entity Metadata


BooleanManagedProperty Constructor
[image]

Initializes a new instance of theBooleanManagedProperty class

Overload List

Name | Description
BooleanManagedProperty () | Initializes a new instance of theBooleanManagedProperty class
BooleanManagedProperty (Boolean) | Initializes a new instance of the BooleanManagedProperty class

See Also

Reference

BooleanManagedProperty Class
BooleanManagedProperty Members
Microsoft.Xrm.Sdk Namespace


BooleanManagedProperty Constructor ()
[image]

Initializes a new instance of the BooleanManagedProperty class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BooleanManagedProperty ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanManagedProperty Class
BooleanManagedProperty Members
Microsoft.Xrm.Sdk Namespace


BooleanManagedProperty Constructor (Boolean)
[image]

Initializes a new instance of the BooleanManagedProperty class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As Boolean _
)

C#
public BooleanManagedProperty (
    bool value
)

C++

J#

JScript

Parameters
value
Type: Boolean.
true if the value is true; otherwise, false.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanManagedProperty Class
BooleanManagedProperty Members
Microsoft.Xrm.Sdk Namespace


BooleanManagedProperty Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BooleanManagedProperty Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use Managed Properties
Sample: Create and Update Entity Metadata


BooleanManagedProperty Properties
[image]

Public Properties

 | Name | Description
public property | CanBeChanged | Gets or sets whether the managed property value can be changed. (inherited from ManagedProperty)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from ManagedProperty)
public property | ManagedPropertyLogicalName | Gets the logical name for the managed property. (inherited from ManagedProperty)
public property | Value | Gets or sets the value of the managed property. (inherited from ManagedProperty)

See Also

Reference

BooleanManagedProperty Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use Managed Properties
Sample: Create and Update Entity Metadata


CallerImpersonationScope Class
See Also Members
[image]

Identifies a user as the owner of all data changes made by calls to a Web service.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CallerImpersonationScope
    Implements IDisposable

C#
public sealed class CallerImpersonationScope : IDisposable

C++

J#

JScript

  Remarks
The specified user does not have to be the same user that instantiated the service. When the CallerImpersonationScope object goes out of scope and is disposed, calls to the service are owned by the original user that instantiated the service.
C#    Copy Code
using (new CallerImpersonationScope(service, userId))
{
   // Display information about the logged on user.
   Guid effectiveUserId = ((WhoAmIResponse)service.Execute(new WhoAmIRequest())).UserId;
   SystemUser systemUser = (SystemUser)service.Retrieve("systemuser", effectiveUserId,
       new ColumnSet(new string[] {"firstname", "lastname"}));
   Console.WriteLine("Logged on user is {0} {1}.", systemUser.FirstName, systemUser.LastName);
}

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.CallerImpersonationScope
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CallerImpersonationScope Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Impersonate Another User


CallerImpersonationScope Members
See Also Constructors Methods
[image]

Identifies a user as the owner of all data changes made by calls to a Web service.

The following tables list the members exposed by the CallerImpersonationScope type.

Public Constructors

Name | Description
CallerImpersonationScope | Initializes a new instance of theCallerImpersonationScope class.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Dispose | Disposes the CallerImpersonationScope object.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CallerImpersonationScope Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Impersonate Another User


CallerImpersonationScope Constructor
[image]

Initializes a new instance of the CallerImpersonationScope class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    service As IOrganizationService, _
    callerId As Guid _
)

C#
public CallerImpersonationScope (
    IOrganizationService service,
    Guid callerId
)

C++

J#

JScript

Parameters
service
Type: IOrganizationService. Specifies an organization service object.
callerId
Type: Guid. Specifies the ID of the user that owns any data changes made by a call to the service.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CallerImpersonationScope Class
CallerImpersonationScope Members
Microsoft.Xrm.Sdk Namespace


CallerImpersonationScope Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Dispose | Disposes the CallerImpersonationScope object.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CallerImpersonationScope Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Impersonate Another User


CallerImpersonationScope.Dispose Method
[image]

Disposes the CallerImpersonationScope object.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Dispose

C#
public void Dispose ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CallerImpersonationScope Class
CallerImpersonationScope Members
Microsoft.Xrm.Sdk Namespace


ClaimTypes Class
See Also Members
[image]

Identifies the types of claims that are supported or may be supported in a future product release.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ClaimTypes

C#
public static class ClaimTypes

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.ClaimTypes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimTypes Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Additional Information About The Security (SAML) Token


ClaimTypes Members
See Also Fields
[image]

Identifies the types of claims that are supported or may be supported in a future product release.

The following tables list the members exposed by the ClaimTypes type.

Public Fields

Name | Description
EntityLogicalName | An entity logical name claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/EntityLogicalName
InitiatingUser | An initiating user claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/InitiatingUser
Organization | An organization claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/Organization
PluginAssembly | A plug-in assembly claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/PluginAssembly
PluginPublisher | A plug-in publisher claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/PluginPublisher
RequestName | A request name claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/RequestName
SecurityToken | A security token claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/SecurityToken
User | A user claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/User
Top

See Also

Reference

ClaimTypes Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Additional Information About The Security (SAML) Token


ClaimTypes Fields
[image]

Public Fields

Name | Description
EntityLogicalName | An entity logical name claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/EntityLogicalName
InitiatingUser | An initiating user claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/InitiatingUser
Organization | An organization claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/Organization
PluginAssembly | A plug-in assembly claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/PluginAssembly
PluginPublisher | A plug-in publisher claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/PluginPublisher
RequestName | A request name claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/RequestName
SecurityToken | A security token claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/SecurityToken
User | A user claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/User

See Also

Reference

ClaimTypes Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Additional Information About The Security (SAML) Token


ClaimTypes.EntityLogicalName Field
[image]

An entity logical name claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/EntityLogicalName

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly EntityLogicalName As String

C#
public static readonly string EntityLogicalName

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimTypes Class
ClaimTypes Members
Microsoft.Xrm.Sdk Namespace


ClaimTypes.InitiatingUser Field
[image]

An initiating user claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/InitiatingUser

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly InitiatingUser As String

C#
public static readonly string InitiatingUser

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimTypes Class
ClaimTypes Members
Microsoft.Xrm.Sdk Namespace


ClaimTypes.Organization Field
[image]

An organization claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/Organization

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Organization As String

C#
public static readonly string Organization

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimTypes Class
ClaimTypes Members
Microsoft.Xrm.Sdk Namespace


ClaimTypes.PluginAssembly Field
[image]

A plug-in assembly claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/PluginAssembly

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly PluginAssembly As String

C#
public static readonly string PluginAssembly

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimTypes Class
ClaimTypes Members
Microsoft.Xrm.Sdk Namespace


ClaimTypes.PluginPublisher Field
[image]

A plug-in publisher claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/PluginPublisher

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly PluginPublisher As String

C#
public static readonly string PluginPublisher

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimTypes Class
ClaimTypes Members
Microsoft.Xrm.Sdk Namespace


ClaimTypes.RequestName Field
[image]

A request name claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/RequestName

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly RequestName As String

C#
public static readonly string RequestName

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimTypes Class
ClaimTypes Members
Microsoft.Xrm.Sdk Namespace


ClaimTypes.SecurityToken Field
[image]

A security token claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/SecurityToken

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly SecurityToken As String

C#
public static readonly string SecurityToken

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimTypes Class
ClaimTypes Members
Microsoft.Xrm.Sdk Namespace


ClaimTypes.User Field
[image]

A user claim. Value = http://schemas.microsoft.com/xrm/2011/Claims/User

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly User As String

C#
public static readonly string User

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimTypes Class
ClaimTypes Members
Microsoft.Xrm.Sdk Namespace


DataCollection Generic Class
See Also Members
[image]

Represents a strongly typed list of objects that can be accessed by index. Provides methods to search, sort, and manipulate lists. Extends Collection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public Class DataCollection(Of T)
    Inherits Collection(Of T)

C#
[SerializableAttribute]
public class DataCollection<T> : Collection<T>

C++

J#

JScript

GenericParameters
T
The type of elements in the list.
  Remarks
For more information, see Collection.

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection
    Microsoft.Xrm.Sdk.DataCollection

                Derived Classes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection Members
See Also Methods Properties Explicit Interface Implementations
[image]

Represents a strongly typed list of objects that can be accessed by index. Provides methods to search, sort, and manipulate lists. Extends Collection.

The following tables list the members exposed by the DataCollection type.

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection.
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

DataCollection Class
Microsoft.Xrm.Sdk Namespace


DataCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection.
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

DataCollection Class
Microsoft.Xrm.Sdk Namespace


DataCollection.AddRange Method
[image]

Adds the elements of the specified collection to the end of the DataCollection.

This method extends the base Collection class to add List.AddRange functionality.

Overload List

Name | Description
DataCollection.AddRange (T) | Adds the elements of the specified collection to the end of the DataCollection.
DataCollection.AddRange (IEnumerable) | Adds the elements of the specified collection to the end of the DataCollection.

See Also

Reference

DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.AddRange Method (T)
[image]

Adds the elements of the specified collection to the end of the DataCollection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddRange ( _
    ParamArray items As T() _
)

C#
public void AddRange (
    params T[] items
)

C++

J#

JScript

Parameters
items
Type: T[].
The array whose elements should be added to the end of the DataCollection. The array itself cannot be null, but it can contain elements that are null, if type T is a reference type.
  Remarks
This method extends the base Collection class to add List.AddRange functionality.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.AddRange Method (IEnumerable)
[image]

Adds the elements of the specified collection to the end of the DataCollection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddRange ( _
    items As IEnumerable(Of T) _
)

C#
public void AddRange (
    IEnumerable<T> items
)

C++

J#

JScript

Parameters
items
Type: IEnumerable<T>.
The collection whose elements should be added to the end of the DataCollection. The collection itself cannot be null, but it can contain elements that are null, if type T is a reference type.
  Remarks
This method extends the base Collection class to add List.AddRange functionality.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.ToArray Method
[image]

Copies the elements of the DataCollection to a new array.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ToArray As T()

C#
public T[] ToArray ()

C++

J#

JScript

Return Value
Type: Type[]

An array containing copies of the elements of the DataCollection.

  Remarks
This method extends the base Collection class to add List.ToArray functionality.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

DataCollection Class
Microsoft.Xrm.Sdk Namespace


DataCollection Generic Class
See Also Members
[image]

Represents a collection of keys and values.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<DefaultMemberAttribute("Item")> _
Public MustInherit Class DataCollection(Of TKey, TValue)
    Implements IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable

C#
[SerializableAttribute]
[DefaultMemberAttribute("Item")]
public abstract class DataCollection<TKey,TValue> : IEnumerable<KeyValuePair<TKey,TValue>>, IEnumerable

C++

J#

JScript

GenericParameters
TKey
The type of the keys in the dictionary.
TValue
The type of the values in the dictionary.
  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.DataCollection

                Derived Classes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection Members
See Also Methods Properties Explicit Interface Implementations
[image]

Represents a collection of keys and values.

The following tables list the members exposed by the DataCollection type.

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection.
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only.
public property | Item | Gets or sets the value associated with the specified key.
public property | Keys | Gets a collection containing the keys in the DataCollection.
public property | Values | Gets a collection containing the values in the DataCollection.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary.
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection.
public method | Clear | Removes all items from the DataCollection.
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value.
public method | ContainsKey | Determines whether the DataCollection contains a specific key value.
public method | CopyTo |
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection.
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key.
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection.
Top

See Also

Reference

DataCollection Class
Microsoft.Xrm.Sdk Namespace


DataCollection Constructor
[image]

Initializes a new instance of the DataCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Sub New

C#
protected internal DataCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary.
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection.
public method | Clear | Removes all items from the DataCollection.
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value.
public method | ContainsKey | Determines whether the DataCollection contains a specific key value.
public method | CopyTo |
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection.
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key.

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection.

See Also

Reference

DataCollection Class
Microsoft.Xrm.Sdk Namespace


DataCollection.Add Method
[image]

Adds the specified key and value to the dictionary.

Overload List

Name | Description
DataCollection.Add (TKey, TValue) | Adds the specified key and value to the dictionary.
DataCollection.Add (KeyValuePair) | Adds the specified key and value to the dictionary.

See Also

Reference

DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Add Method (TKey, TValue)
[image]

Adds the specified key and value to the dictionary.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Add ( _
    key As TKey, _
    value As TValue _
)

C#
public void Add (
    TKey key,
    TValue value
)

C++

J#

JScript

Parameters
key
Type: TKey. The key of the element to add.
value
Type: TValue. The value of the element to add.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Add Method (KeyValuePair)
[image]

Adds the specified key and value to the dictionary.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Add ( _
    item As KeyValuePair(Of TKey, TValue) _
)

C#
public void Add (
    KeyValuePair<TKey,TValue> item
)

C++

J#

JScript

Parameters
item
Type: KeyValuePair<TKey, TValue>. The key and value to add.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.AddRange Method
[image]

Adds the elements of the specified collection to the end of the DataCollection.

Overload List

Name | Description
DataCollection.AddRange (IEnumerable) | Adds the elements of the specified collection to the end of the DataCollection.
DataCollection.AddRange (KeyValuePair[]) | Adds the elements of the specified collection to the end of the DataCollection.

See Also

Reference

DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.AddRange Method (IEnumerable)
[image]

Adds the elements of the specified collection to the end of the DataCollection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1006:DoNotNestGenericTypesInMemberSignatures", Justification:="Allows AddRange to be used for multiple types of enumerable items")> _
Public Sub AddRange ( _
    items As IEnumerable(Of KeyValuePair(Of TKey, TValue)) _
)

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1006:DoNotNestGenericTypesInMemberSignatures", Justification="Allows AddRange to be used for multiple types of enumerable items")]
public void AddRange (
    IEnumerable<KeyValuePair<TKey,TValue>> items
)

C++

J#

JScript

Parameters
items
Type: IEnumerable<KeyValuePair<TKey, TValue>>.
The collection whose elements should be added to the end of the DataCollection. The collection itself cannot be null, but it can contain elements that are null, if type T is a reference type.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.AddRange Method (KeyValuePair[])
[image]

Adds the elements of the specified collection to the end of the DataCollection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddRange ( _
    ParamArray items As KeyValuePair(Of TKey, TValue)() _
)

C#
public void AddRange (
    params KeyValuePair<TKey,TValue>[] items
)

C++

J#

JScript

Parameters
items
Type: KeyValuePair<TKey, TValue>[].
The array whose elements should be added to the end of the DataCollection. The array itself cannot be null, but it can contain elements that are null, if type T is a reference type.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Clear Method
[image]

Removes all items from the DataCollection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Clear

C#
public void Clear ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Contains Method
[image]

Determines whether the DataCollection contains a specific value.

Overload List

Name | Description
DataCollection.Contains (TKey) | Determines whether the DataCollection contains a specific value.
DataCollection.Contains (KeyValuePair) | Determines whether the DataCollection contains a specific value.

See Also

Reference

DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Contains Method (TKey)
[image]

Determines whether the DataCollection contains a specific value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Contains ( _
    key As TKey _
) As Boolean

C#
public bool Contains (
    TKey key
)

C++

J#

JScript

Parameters
key
Type: TKey. The key to locate in the collection.
Return Value
Type: Boolean
true if item is found in the DataCollection; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Contains Method (KeyValuePair)
[image]

Determines whether the DataCollection contains a specific value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Contains ( _
    key As KeyValuePair(Of TKey, TValue) _
) As Boolean

C#
public bool Contains (
    KeyValuePair<TKey,TValue> key
)

C++

J#

JScript

Parameters
key
Type: KeyValuePair<TKey, TValue>. The key value pair to locate in the collection.
Return Value
Type: Boolean
true if item is found in the DataCollection; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.ContainsKey Method
[image]

Determines whether the DataCollection contains a specific key value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ContainsKey ( _
    key As TKey _
) As Boolean

C#
public bool ContainsKey (
    TKey key
)

C++

J#

JScript

Parameters
key
Type: TKey. The key to locate in the collection.
Return Value
Type: Boolean
true if item is found in the DataCollection; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.CopyTo Method
[image]

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub CopyTo ( _
    array As KeyValuePair(Of TKey, TValue)(), _
    arrayIndex As Integer _
)

C#
public void CopyTo (
    KeyValuePair<TKey,TValue>[] array,
    int arrayIndex
)

C++

J#

JScript

Parameters
array
Type: KeyValuePair<TKey, TValue>[]. The
arrayIndex
Type: Int32. Copies the entire DataCollection to a compatible one-dimensional array, starting at the specified index of the target array.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.GetEnumerator Method
[image]

Returns an enumerator that iterates through a collection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))

C#
public IEnumerator<KeyValuePair<TKey,TValue>> GetEnumerator ()

C++

J#

JScript

Return Value
Type: IEnumerator<KeyValuePair<TKey, TValue>>

An IEnumerator object that can be used to iterate through the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Remove Method
[image]

Removes the first occurrence of a specific object from the DataCollection.

Overload List

Name | Description
DataCollection.Remove (TKey) | Removes the first occurrence of a specific object from the DataCollection.
DataCollection.Remove (KeyValuePair) | Removes the first occurrence of a specific object from the DataCollection.

See Also

Reference

DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Remove Method (TKey)
[image]

Removes the first occurrence of a specific object from the DataCollection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Remove ( _
    key As TKey _
) As Boolean

C#
public bool Remove (
    TKey key
)

C++

J#

JScript

Parameters
key
Type: TKey. The object to remove from the DataCollection.
Return Value
Type: Boolean
true if the object was found and removed; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Remove Method (KeyValuePair)
[image]

Removes the first occurrence of a specific object from the DataCollection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Remove ( _
    item As KeyValuePair(Of TKey, TValue) _
) As Boolean

C#
public bool Remove (
    KeyValuePair<TKey,TValue> item
)

C++

J#

JScript

Parameters
item
Type: KeyValuePair<TKey, TValue>.
The object to remove from the DataCollection.
Return Value
Type: Boolean
true if the object was found and removed; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Usage", "CA9888:DisposeObjectsCorrectly", Justification:="Returning the enumerator.")> _
Private Function System.Collections.IEnumerable.GetEnumerator As IEnumerator Implements IEnumerable.GetEnumerator

C#
[SuppressMessageAttribute("Microsoft.Usage", "CA9888:DisposeObjectsCorrectly", Justification="Returning the enumerator.")]
IEnumerator IEnumerable.GetEnumerator ()

C++

J#

JScript

Return Value
Type: IEnumerator

An IEnumerator object that can be used to iterate through the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.TryGetValue Method
[image]

Gets the value associated with the specified key.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function TryGetValue ( _
    key As TKey, _
    <OutAttribute> ByRef value As TValue _
) As Boolean

C#
public bool TryGetValue (
    TKey key,
    out TValue value
)

C++

J#

JScript

Parameters
key
Type: TKey. The key of the value to get.
value
Type: TValue%. When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.
Return Value
Type: Boolean
true if the DataCollection contains an element with the specified key; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection.
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only.
public property | Item | Gets or sets the value associated with the specified key.
public property | Keys | Gets a collection containing the keys in the DataCollection.
public property | Values | Gets a collection containing the values in the DataCollection.

See Also

Reference

DataCollection Class
Microsoft.Xrm.Sdk Namespace


DataCollection.Count Property
[image]

Gets the number of elements in the collection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Count As Integer

C#
public int Count { get; }

C++

J#

JScript

Property Value
Type: Int32

The number of elements in the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.IsReadOnly Property
[image]

Gets a value indicating whether the DataCollection is read-only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overridable Property IsReadOnly As Boolean

C#
public virtual bool IsReadOnly { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the DataCollection is read-only; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Item Property
[image]

Gets or sets the value associated with the specified key.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overridable Default Property Item ( _
    key As TKey _
) As TValue

C#
public virtual TValue this [
    TKey key
] { get; set; }

C++

J#

JScript

Parameters
key
Type: TKey. The key of the value to get or set.
Property Value
Type: TValue

The value associated with the specified key.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Keys Property
[image]

Gets a collection containing the keys in the DataCollection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Keys As ICollection(Of TKey)

C#
public ICollection<TKey> Keys { get; }

C++

J#

JScript

Property Value
Type: ICollection<TKey>

A collection containing the keys in the DataCollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection.Values Property
[image]

Gets a collection containing the values in the DataCollection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Values As ICollection(Of TValue)

C#
public ICollection<TValue> Values { get; }

C++

J#

JScript

Property Value
Type: ICollection<TValue>

A collection containing the values in the DataCollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DiscoveryServiceFault Class
See Also Members
[image]

Represents a discovery service fault.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Name:="DiscoveryServiceFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DiscoveryServiceFault
    Inherits BaseServiceFault

C#
[SerializableAttribute]
[DataContractAttribute(Name="DiscoveryServiceFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DiscoveryServiceFault : BaseServiceFault

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.BaseServiceFault
    Microsoft.Xrm.Sdk.DiscoveryServiceFault
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryServiceFault Members
Microsoft.Xrm.Sdk Namespace
IDiscoveryService


DiscoveryServiceFault Members
See Also Constructors Methods Properties
[image]

Represents a discovery service fault.

The following tables list the members exposed by the DiscoveryServiceFault type.

Public Constructors

Name | Description
DiscoveryServiceFault | Initializes a new instance of the DiscoveryServiceFault class.
Top

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the fault error code. (inherited from BaseServiceFault)
public property | ErrorDetails | Gets or sets the details of the fault. (inherited from BaseServiceFault)
public property | ExtensionData | Gets or sets a structure that contains extra data. (inherited from BaseServiceFault)
public property | InnerFault | Gets or sets the fault instance that caused the current fault.
public property | Message | Gets or sets the message for the fault. (inherited from BaseServiceFault)
public property | Timestamp | Gets or sets the date and time when the fault occurred. (inherited from BaseServiceFault)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DiscoveryServiceFault Class
Microsoft.Xrm.Sdk Namespace
IDiscoveryService


DiscoveryServiceFault Constructor
[image]

Initializes a new instance of the DiscoveryServiceFault class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DiscoveryServiceFault ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryServiceFault Class
DiscoveryServiceFault Members
Microsoft.Xrm.Sdk Namespace


DiscoveryServiceFault Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DiscoveryServiceFault Class
Microsoft.Xrm.Sdk Namespace
IDiscoveryService


DiscoveryServiceFault Properties
[image]

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the fault error code. (inherited from BaseServiceFault)
public property | ErrorDetails | Gets or sets the details of the fault. (inherited from BaseServiceFault)
public property | ExtensionData | Gets or sets a structure that contains extra data. (inherited from BaseServiceFault)
public property | InnerFault | Gets or sets the fault instance that caused the current fault.
public property | Message | Gets or sets the message for the fault. (inherited from BaseServiceFault)
public property | Timestamp | Gets or sets the date and time when the fault occurred. (inherited from BaseServiceFault)

See Also

Reference

DiscoveryServiceFault Class
Microsoft.Xrm.Sdk Namespace
IDiscoveryService


DiscoveryServiceFault.InnerFault Property
[image]

Gets or sets the fault instance that caused the current fault.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property InnerFault As DiscoveryServiceFault

C#
[DataMemberAttribute]
public DiscoveryServiceFault InnerFault { get; set; }

C++

J#

JScript

Property Value
Type: DiscoveryServiceFault
The fault instance that caused the current fault.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryServiceFault Class
DiscoveryServiceFault Members
Microsoft.Xrm.Sdk Namespace


Entity Class
See Also Members
[image]

Represents an instance of an entity (a record).

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="Entity", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<DefaultMemberAttribute("Item")> _
<SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification:="This class need to be instantiated by clients and be able to derive from it.")> _
Public Class Entity
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="Entity", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[DefaultMemberAttribute("Item")]
[SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification="This class need to be instantiated by clients and be able to derive from it.")]
public class Entity : IExtensibleDataObject

C++

J#

JScript

  Remarks
Entity is the base class for all types of entities in Microsoft Dynamics CRM. You use this class for both early and late bound programming.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Entity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use the Early Bound Entity Classes in Code
Use the Late Bound Entity Class in Code


Entity Members
See Also Constructors Methods Properties
[image]

Represents an instance of an entity (a record).

The following tables list the members exposed by the Entity type.

Public Constructors

Name | Description
Entity | Overloaded. Initializes a new instance of the Entity class.
Top

Public Properties

 | Name | Description
public property | Attributes | Gets or sets the collection of attributes for the entity.
public property | EntityState | Gets or sets the state of the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | FormattedValues | Gets of sets the collection of formatted values for the entity attributes.
public property | Id | Gets or sets the ID of the record represented by this entity instance.
public property | Item | Provides an indexer for the attribute values.
public property | LogicalName | Gets or sets the logical name of the entity.
public property | RelatedEntities | Gets or sets a collection of entity references (references to records).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Contains | Checks to see if there is a value present for the specified attribute.
public method | Equals | (inherited from Object)
public method | GetAttributeValue | Gets the value of the attribute.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToEntity | Gets the entity as the specified type.
public method | ToEntityReference | Gets an entity reference for this entity instance.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetFormattedAttributeValue | Gets the formatted value of the attribute.
protected method | GetRelatedEntities | Gets the collection of related entity instances for the specified relationship.
protected method | GetRelatedEntity | Gets the related entity instance for the specified relationship.
protected method | MemberwiseClone | (inherited from Object)
protected method | SetAttributeValue | Sets the value of an attribute.
protected method | SetRelatedEntities | Sets the collection of related entity instances for the specified relationship.
protected method | SetRelatedEntity | Sets the related entity instance for the specified relationship.
Top

See Also

Reference

Entity Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Early Bound Entity Classes in Code
Use the Late Bound Entity Class in Code


Entity Constructor
[image]

Initializes a new instance of the Entity class.

Overload List

Name | Description
Entity () | Initializes a new instance of the Entity class.
Entity (String) | Initializes a new instance of the Entity class setting the entity name.

See Also

Reference

Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity Constructor ()
[image]

Initializes a new instance of the Entity class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public Entity ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity Constructor (String)
[image]

Initializes a new instance of the Entity class setting the entity name.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String _
)

C#
public Entity (
    string entityName
)

C++

J#

JScript

Parameters
entityName
Type: String. The name of the entity.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Contains | Checks to see if there is a value present for the specified attribute.
public method | Equals | (inherited from Object)
public method | GetAttributeValue | Gets the value of the attribute.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToEntity | Gets the entity as the specified type.
public method | ToEntityReference | Gets an entity reference for this entity instance.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetFormattedAttributeValue | Gets the formatted value of the attribute.
protected method | GetRelatedEntities | Gets the collection of related entity instances for the specified relationship.
protected method | GetRelatedEntity | Gets the related entity instance for the specified relationship.
protected method | MemberwiseClone | (inherited from Object)
protected method | SetAttributeValue | Sets the value of an attribute.
protected method | SetRelatedEntities | Sets the collection of related entity instances for the specified relationship.
protected method | SetRelatedEntity | Sets the related entity instance for the specified relationship.

See Also

Reference

Entity Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Early Bound Entity Classes in Code
Use the Late Bound Entity Class in Code


Entity.Contains Method
[image]

Checks to see if there is a value present for the specified attribute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Contains ( _
    attributeName As String _
) As Boolean

C#
public bool Contains (
    string attributeName
)

C++

J#

JScript

Parameters
attributeName
Type: String. The logical name of the attribute.
Return Value
Type: Boolean
true if the Entity contains an attribute with the specified name; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.GetAttributeValue Method
See Also Example
[image]

Gets the value of the attribute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overridable Function GetAttributeValue(Of T) ( _
    attributeLogicalName As String _
) As T

C#
public virtual T GetAttributeValue<T> (
    string attributeLogicalName
)

C++

J#

JScript

GenericParameters
T
Type: Type. The type of the attribute.
Parameters
attributeLogicalName
Type: String. The logical name of the attribute.
Return Value
Type: Type

The value of the attribute.

  Example
C#    Copy Code
GetAttributeValue<EntityReference>("regardingobjectid")

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Types in the Microsoft Dynamics CRM SDK


Entity.GetFormattedAttributeValue Method
[image]

Gets the formatted value of the attribute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Function GetFormattedAttributeValue ( _
    attributeLogicalName As String _
) As String

C#
protected virtual string GetFormattedAttributeValue (
    string attributeLogicalName
)

C++

J#

JScript

Parameters
attributeLogicalName
Type: String. The logical name of the attribute.
Return Value
Type: String

The formatted value of the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Types in the Microsoft Dynamics CRM SDK


Entity.GetRelatedEntities Method
See Also Example
[image]

Gets the collection of related entity instances for the specified relationship.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Function GetRelatedEntities(Of TEntity As Entity) ( _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole) _
) As IEnumerable(Of TEntity)

C#
protected virtual IEnumerable<TEntity> GetRelatedEntities<TEntity> (
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole
) where TEntity : Entity

C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The type of the entity.
Parameters
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
The role of the primary entity in the relationship (referenced or referencing).
Return Value
Type: IEnumerable
The collection of related entity instances for the specified relationship.

  Example
C#    Copy Code
GetRelatedEntities<CampaignResponse>("activity_pointer_campaignresponse", null);

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.GetRelatedEntity Method
See Also Example
[image]

Gets the related entity instance for the specified relationship.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Function GetRelatedEntity(Of TEntity As Entity) ( _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole) _
) As TEntity

C#
protected virtual TEntity GetRelatedEntity<TEntity> (
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole
) where TEntity : Entity

C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The type of the entity.
Parameters
relationshipSchemaName
Type: String. The name of the relationship.
primaryEntityRole
Type: EntityRole. The role of the primary entity in the relationship (referenced or referencing).
Return Value
Type: Entity
The collection of related entity instances for the specified relationship.

  Example
C#    Copy Code
GetRelatedEntity<Account>("account_primary_contact", null);

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.SetAttributeValue Method
See Also Example
[image]

Sets the value of an attribute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub SetAttributeValue ( _
    attributeLogicalName As String, _
    value As Object _
)

C#
protected virtual void SetAttributeValue (
    string attributeLogicalName,
    Object value
)

C++

J#

JScript

Parameters
attributeLogicalName
Type: String. The logical name of the attribute.
value
Type: Object. The value to set.
  Example
C#    Copy Code
record.SetAttributeValue("new_recipename", "Chocolate Tart");

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.SetRelatedEntities Method
See Also Example
[image]

Sets the collection of related entity instances for the specified relationship.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub SetRelatedEntities(Of TEntity As Entity) ( _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole), _
    entities As IEnumerable(Of TEntity) _
)

C#
protected virtual void SetRelatedEntities<TEntity> (
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole,
    IEnumerable<TEntity> entities
) where TEntity : Entity

C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The type of the entity.
Parameters
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: EntityRole. The role of the primary entity in the relationship (referenced or referencing).
entities
Type: IEnumerable. The collection of entity instances to set.
  Example
C#    Copy Code
SetRelatedEntities<ActivityPointer>("Account_ActivityPointers", null, value);

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.SetRelatedEntity Method
See Also Example
[image]

Sets the related entity instance for the specified relationship.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub SetRelatedEntity(Of TEntity As Entity) ( _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole), _
    entity As TEntity _
)

C#
protected virtual void SetRelatedEntity<TEntity> (
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole,
    TEntity entity
) where TEntity : Entity

C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The type of the entity.
Parameters
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: EntityRole. The role of the primary entity in the relationship (referenced or referencing).
entity
Type: Entity. The entity instance to set.
  Example
C#    Copy Code
SetRelatedEntity<mbs_project>("mbs_project_workiem", null, value);

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.ToEntity Method
See Also Example
[image]

Gets the entity as the specified type.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ToEntity(Of T As Entity) As T

C#
public T ToEntity<T> () where T : Entity

C++

J#

JScript

GenericParameters
T
Type: Entity. The entity type to return.
Return Value
Type: Entity
The entity as the specified type.

  Example
C#    Copy Code
Account retrievedAccount = service.Retrieve(account.LogicalName, account.Id, new ColumnSet("primarycontactid")).ToEntity<Account>();

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.ToEntityReference Method
See Also Example
[image]

Gets an entity reference for this entity instance.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ToEntityReference As EntityReference

C#
public EntityReference ToEntityReference ()

C++

J#

JScript

Return Value
Type: EntityReference
The entity reference for the entity.

  Example
C#    Copy Code
RetrieveRequest request = new RetrieveRequest
{
Target = account.ToEntityReference(),
ColumnSet = new ColumnSet(),
RelatedEntitiesQuery = new RelationshipQueryCollection()
};

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity Properties
[image]

Public Properties

 | Name | Description
public property | Attributes | Gets or sets the collection of attributes for the entity.
public property | EntityState | Gets or sets the state of the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | FormattedValues | Gets of sets the collection of formatted values for the entity attributes.
public property | Id | Gets or sets the ID of the record represented by this entity instance.
public property | Item | Provides an indexer for the attribute values.
public property | LogicalName | Gets or sets the logical name of the entity.
public property | RelatedEntities | Gets or sets a collection of entity references (references to records).

See Also

Reference

Entity Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Early Bound Entity Classes in Code
Use the Late Bound Entity Class in Code


Entity.Attributes Property
[image]

Gets or sets the collection of attributes for the entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Attributes As AttributeCollection

C#
[DataMemberAttribute]
public AttributeCollection Attributes { get; set; }

C++

J#

JScript

Property Value
Type: AttributeCollection

The collection of attributes for the entity.

  Remarks
For performance and security reasons, the attribute collection will typically not contain the complete set of attributes for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.EntityState Property
See Also Example
[image]

Gets or sets the state of the entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityState As Nullable(Of EntityState)

C#
[DataMemberAttribute]
public Nullable<EntityState> EntityState { get; set; }

C++

J#

JScript

Property Value
Type: EntityState.

The state of the entity.

  Example
C#    Copy Code
lead1.EntityState = EntityState.Changed;

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
Gets or sets the structure that contains extra data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.FormattedValues Property
See Also Example
[image]

Gets of sets the collection of formatted values for the entity attributes.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FormattedValues As FormattedValueCollection

C#
[DataMemberAttribute]
public FormattedValueCollection FormattedValues { get; }

C++

J#

JScript

Property Value
Type: FormattedValueCollection

The collection of formatted values for the entity attributes.

  Example
C#    Copy Code
if (entity.FormattedValues.Contains(metadata.LogicalName))
actualValue = entity.FormattedValues[metadata.LogicalName];

  Remarks
Entity formatted values are only available on a retrieve operation, not on an update operation.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace
Attributes


Entity.Id Property
[image]

Gets or sets the ID of the record represented by this entity instance.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Overridable Property Id As Guid

C#
[DataMemberAttribute]
public virtual Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the record (entity instance).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.Item Property
[image]

Provides an indexer for the attribute values.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Default Property Item ( _
    attributeName As String _
) As Object

C#
public Object this [
    string attributeName
] { get; set; }

C++

J#

JScript

Parameters
attributeName
Type: String. The logical name of the attribute.
Property Value
Type: Object
The attribute specified by the attributeName parameter.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.LogicalName Property
[image]

Gets or sets the logical name of the entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LogicalName As String

C#
[DataMemberAttribute]
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
the logical name of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


Entity.RelatedEntities Property
[image]

Gets or sets a collection of entity references (references to records).

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Naming", "CA1721:PropertyNamesShouldNotMatchGetMethods", Justification:="Member and conflicting method differences are obvious.")> _
<DataMemberAttribute> _
Public Property RelatedEntities As RelatedEntityCollection

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1721:PropertyNamesShouldNotMatchGetMethods", Justification="Member and conflicting method differences are obvious.")]
[DataMemberAttribute]
public RelatedEntityCollection RelatedEntities { get; }

C++

J#

JScript

Property Value
Type: RelatedEntityCollection

a collection of entity references (references to records).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Entity Class
Entity Members
Microsoft.Xrm.Sdk Namespace


EntityCollection Class
See Also Members
[image]

Contains a collection of entity instances.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DefaultMemberAttribute("Item")> _
<SuppressMessageAttribute("Microsoft.Naming", "CA1711:IdentifiersShouldNotHaveIncorrectSuffix", Justification:="Class wraps a collection")> _
<DataContractAttribute(Name:="EntityCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class EntityCollection
    Implements IExtensibleDataObject

C#
[DefaultMemberAttribute("Item")]
[SuppressMessageAttribute("Microsoft.Naming", "CA1711:IdentifiersShouldNotHaveIncorrectSuffix", Justification="Class wraps a collection")]
[DataContractAttribute(Name="EntityCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class EntityCollection : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.EntityCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityCollection Members
See Also Constructors Methods Properties
[image]

Contains a collection of entity instances.

The following tables list the members exposed by the EntityCollection type.

Public Constructors

Name | Description
EntityCollection | Overloaded. Initializes a new instance of the EntityCollection class.
Top

Public Properties

 | Name | Description
public property | Entities | Gets the collection of entities.
public property | EntityName | Gets or sets the logical name of the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Item | Gets or sets an item in the collection.
public property | MinActiveRowVersion | Gets or sets the lowest active row version value.
public property | MoreRecords | Gets or sets whether there are more records available.
public property | PagingCookie | Gets or sets the current paging information.
public property | TotalRecordCount | Gets the total number of records in the collection.ReturnTotalRecordCount was true when the query was executed .
public property | TotalRecordCountLimitExceeded | Gets or sets whether the results of the query exceeds the total record count.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EntityCollection Class
Microsoft.Xrm.Sdk Namespace


EntityCollection Constructor
[image]

Initializes a new instance of the EntityCollection class.

Overload List

Name | Description
EntityCollection () | Initializes a new instance of the EntityCollection class.
EntityCollection (IList) | Initializes a new instance of the EntityCollection class setting the list of entities.

See Also

Reference

EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityCollection Constructor ()
[image]

Initializes a new instance of the EntityCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityCollection Constructor (IList)
[image]

Initializes a new instance of the EntityCollection class setting the list of entities.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    list As IList(Of Entity) _
)

C#
public EntityCollection (
    IList<Entity> list
)

C++

J#

JScript

Parameters
list
Type: IList<Entity>. A list of entities.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EntityCollection Class
Microsoft.Xrm.Sdk Namespace


EntityCollection Properties
[image]

Public Properties

 | Name | Description
public property | Entities | Gets the collection of entities.
public property | EntityName | Gets or sets the logical name of the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Item | Gets or sets an item in the collection.
public property | MinActiveRowVersion | Gets or sets the lowest active row version value.
public property | MoreRecords | Gets or sets whether there are more records available.
public property | PagingCookie | Gets or sets the current paging information.
public property | TotalRecordCount | Gets the total number of records in the collection.ReturnTotalRecordCount was true when the query was executed .
public property | TotalRecordCountLimitExceeded | Gets or sets whether the results of the query exceeds the total record count.

See Also

Reference

EntityCollection Class
Microsoft.Xrm.Sdk Namespace


EntityCollection.Entities Property
[image]

Gets the collection of entities.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Entities As DataCollection(Of Entity)

C#
[DataMemberAttribute]
public DataCollection<Entity> Entities { get; }

C++

J#

JScript

Property Value
Type: DataCollection<Entity>
The collection of entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityCollection.EntityName Property
[image]

Gets or sets the logical name of the entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityName As String

C#
[DataMemberAttribute]
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
the logical name of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace
Other Resources
IOrganizationService Entities


EntityCollection.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityCollection.Item Property
[image]

Gets or sets an item in the collection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As Entity

C#
public Entity this [
    int index
] { get; set; }

C++

J#

JScript

Parameters
index
Type: Int32. The index of the item.
Property Value
Type: Entity
The item at the specified index.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityCollection.MinActiveRowVersion Property
[image]

Gets or sets the lowest active row version value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MinActiveRowVersion As String

C#
[DataMemberAttribute]
public string MinActiveRowVersion { get; set; }

C++

J#

JScript

Property Value
Type: String
The lowest active row version value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityCollection.MoreRecords Property
[image]

Gets or sets whether there are more records available.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MoreRecords As Boolean

C#
[DataMemberAttribute]
public bool MoreRecords { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if there are more records available; otherwise, false. This is used in conjunction with the PagingCookie when working with large record sets.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityCollection.PagingCookie Property
[image]

Gets or sets the current paging information.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PagingCookie As String

C#
[DataMemberAttribute]
public string PagingCookie { get; set; }

C++

J#

JScript

Property Value
Type: String

The current paging information. This is used in conjunction with MoreRecords when working with large record sets.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Page Large Result Sets with FetchXML
Sample: Use FetchXML with a Paging Cookie


EntityCollection.TotalRecordCount Property
[image]

Gets the total number of records in the collection.ReturnTotalRecordCount was true when the query was executed .

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TotalRecordCount As Integer

C#
[DataMemberAttribute]
public int TotalRecordCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The total number of records in the collection.

  Remarks
If ReturnTotalRecordCount was false when the query was executed, the value of this property will be -1.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace
ReturnTotalRecordCount
Other Resources
Use the QueryExpression Class


EntityCollection.TotalRecordCountLimitExceeded Property
[image]

Gets or sets whether the results of the query exceeds the total record count.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TotalRecordCountLimitExceeded As Boolean

C#
[DataMemberAttribute]
public bool TotalRecordCountLimitExceeded { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the results of the query exceeds the total record count; otherwise, false..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCollection Class
EntityCollection Members
Microsoft.Xrm.Sdk Namespace


EntityImageCollection Class
See Also Members
[image]

Contains a collection of Entity image objects.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="EntityImageCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class EntityImageCollection
    Inherits DataCollection(Of String, Entity)

C#
[CollectionDataContractAttribute(Name="EntityImageCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class EntityImageCollection : DataCollection<string,Entity>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.EntityImageCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityImageCollection Members
Microsoft.Xrm.Sdk Namespace
PreEntityImages
PostEntityImages


EntityImageCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a collection of Entity image objects.

The following tables list the members exposed by the EntityImageCollection type.

Public Constructors

Name | Description
EntityImageCollection | Initializes a new instance of the EntityImageCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

EntityImageCollection Class
Microsoft.Xrm.Sdk Namespace
PreEntityImages
PostEntityImages


EntityImageCollection Constructor
[image]

Initializes a new instance of the EntityImageCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityImageCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityImageCollection Class
EntityImageCollection Members
Microsoft.Xrm.Sdk Namespace


EntityImageCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

EntityImageCollection Class
Microsoft.Xrm.Sdk Namespace
PreEntityImages
PostEntityImages


EntityImageCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

EntityImageCollection Class
Microsoft.Xrm.Sdk Namespace
PreEntityImages
PostEntityImages


EntityReference Class
See Also Members
[image]

Identifies a record.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Name:="EntityReference", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class EntityReference
    Implements IExtensibleDataObject

C#
[SerializableAttribute]
[DataContractAttribute(Name="EntityReference", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class EntityReference : IExtensibleDataObject

C++

J#

JScript

  Remarks
This class replaces the Moniker class from Microsoft Dynamics CRM 4.0.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.EntityReference
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReference Members
See Also Constructors Methods Properties
[image]

Identifies a record.

The following tables list the members exposed by the EntityReference type.

Public Constructors

Name | Description
EntityReference | Overloaded. Initializes a new instance of the EntityReference class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Id | Gets or sets the ID of the record.
public property | LogicalName | Gets or sets the logical name of the entity.
public property | Name | Gets or sets the value of the primary attribute of the entity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Serves as a hash function for this type.
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EntityReference Class
Microsoft.Xrm.Sdk Namespace


EntityReference Constructor
[image]

Initializes a new instance of the EntityReference class.

Overload List

Name | Description
EntityReference () | Initializes a new instance of the EntityReference class.
EntityReference (String, Guid) | Initializes a new instance of the EntityReference class setting the logical name and entity ID.

See Also

Reference

EntityReference Class
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReference Constructor ()
[image]

Initializes a new instance of the EntityReference class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityReference ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReference Class
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReference Constructor (String, Guid)
[image]

Initializes a new instance of the EntityReference class setting the logical name and entity ID.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    logicalName As String, _
    id As Guid _
)

C#
public EntityReference (
    string logicalName,
    Guid id
)

C++

J#

JScript

Parameters
logicalName
Type: String. The logical name of the entity.
id
Type: Guid. The ID of the record.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReference Class
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReference Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Serves as a hash function for this type.
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EntityReference Class
Microsoft.Xrm.Sdk Namespace


EntityReference.Equals Method
[image]

Determines whether two instances are equal.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

C#
public override bool Equals (
    Object obj
)

C++

J#

JScript

Parameters
obj
Type: Object. The EntityReference to compare with the current EntityReference.
Return Value
Type: Boolean
true if the specified EntityReference is equal to the EntityReference object; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReference Class
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReference.GetHashCode Method
[image]

Serves as a hash function for this type.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function GetHashCode As Integer

C#
public override int GetHashCode ()

C++

J#

JScript

Return Value
Type: Int32

The hash code for the current EntityReference.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReference Class
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReference Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Id | Gets or sets the ID of the record.
public property | LogicalName | Gets or sets the logical name of the entity.
public property | Name | Gets or sets the value of the primary attribute of the entity.

See Also

Reference

EntityReference Class
Microsoft.Xrm.Sdk Namespace


EntityReference.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReference Class
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReference.Id Property
[image]

Gets or sets the ID of the record.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReference Class
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReference.LogicalName Property
[image]

Gets or sets the logical name of the entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LogicalName As String

C#
[DataMemberAttribute]
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity.

  Remarks
For a list of the out-of-the-box entity names, see IOrganizationService Entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReference Class
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReference.Name Property
[image]

Gets or sets the value of the primary attribute of the entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Name As String

C#
[DataMemberAttribute]
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String
The value of the primary attribute of the entity.

  Remarks
This property can contain a value or null. This property is not automatically populated unless the EntityReference object has been retrieved from the server. This value is used to provide text to represent the related record in any user interface elements, such as the value in a view column.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReference Class
EntityReference Members
Microsoft.Xrm.Sdk Namespace


EntityReferenceCollection Class
See Also Members
[image]

Contains a collection of entity references.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="EntityReferenceCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class EntityReferenceCollection
    Inherits DataCollection(Of EntityReference)

C#
[CollectionDataContractAttribute(Name="EntityReferenceCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class EntityReferenceCollection : DataCollection<EntityReference>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.EntityReferenceCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReferenceCollection Members
Microsoft.Xrm.Sdk Namespace


EntityReferenceCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a collection of entity references.

The following tables list the members exposed by the EntityReferenceCollection type.

Public Constructors

Name | Description
EntityReferenceCollection | Overloaded. Initializes a new instance of the EntityReferenceCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

EntityReferenceCollection Class
Microsoft.Xrm.Sdk Namespace


EntityReferenceCollection Constructor
[image]

Initializes a new instance of the EntityReferenceCollection class.

Overload List

Name | Description
EntityReferenceCollection () | Initializes a new instance of the EntityReferenceCollection class.
EntityReferenceCollection (IList) | Initializes a new instance of the EntityReferenceCollection class setting the list of entity references.

See Also

Reference

EntityReferenceCollection Class
EntityReferenceCollection Members
Microsoft.Xrm.Sdk Namespace


EntityReferenceCollection Constructor ()
[image]

Initializes a new instance of the EntityReferenceCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityReferenceCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReferenceCollection Class
EntityReferenceCollection Members
Microsoft.Xrm.Sdk Namespace


EntityReferenceCollection Constructor (IList)
[image]

Initializes a new instance of the EntityReferenceCollection class setting the list of entity references.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    list As IList(Of EntityReference) _
)

C#
public EntityReferenceCollection (
    IList<EntityReference> list
)

C++

J#

JScript

Parameters
list
Type: IList<EntityReference>. A list of entity references.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityReferenceCollection Class
EntityReferenceCollection Members
Microsoft.Xrm.Sdk Namespace


EntityReferenceCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

EntityReferenceCollection Class
Microsoft.Xrm.Sdk Namespace


EntityReferenceCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

EntityReferenceCollection Class
Microsoft.Xrm.Sdk Namespace


EntityRole Enumeration
[image]

Contains values to indicate the role the entity plays in a relationship.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EntityRole", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Enumeration EntityRole

C#
[DataContractAttribute(Name="EntityRole", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public enum EntityRole

C++

J#

JScript

  Members
Member name | Description
Referenced | Specifies that the entity is the referenced entity. Value = 1.
Referencing | Specifies that the entity is the referencing entity. Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk Namespace
Relationship


EntityState Enumeration
[image]

Indicates the state of an entity as tracked by the OrganizationServiceContext and indicates to the server the operation that should be performed for a related entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EntityState", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Enumeration EntityState

C#
[DataContractAttribute(Name="EntityState", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public enum EntityState

C++

J#

JScript

  Members
Member name | Description
Changed | The entity was changed since the last call to SaveChanges. Value = 2.
Created | The entity was created since the last call to SaveChanges. Value = 1.
Unchanged | The entity is unchanged since the last call to SaveChanges. Value = 0.
  Remarks
The OrganizationServiceContext sets this value after the SaveChanges method is called and uses this value to track changes to entities. You can also set this value to Changed for a related entity to indicate to the service context that the related entity has been changed and that those changes need to be passed to the server. The service context sends changes to the server when the SaveChanges method is called.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk Namespace


ErrorDetailCollection Class
See Also Members
[image]

Contains a collection of objects that provide details on an error.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<CollectionDataContractAttribute(Name:="ErrorDetailCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class ErrorDetailCollection
    Inherits DataCollection(Of String, Object)

C#
[SerializableAttribute]
[CollectionDataContractAttribute(Name="ErrorDetailCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class ErrorDetailCollection : DataCollection<string,Object>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.ErrorDetailCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorDetailCollection Members
Microsoft.Xrm.Sdk Namespace


ErrorDetailCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a collection of objects that provide details on an error.

The following tables list the members exposed by the ErrorDetailCollection type.

Public Constructors

Name | Description
ErrorDetailCollection | Initializes a new instance of the ErrorDetailCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

ErrorDetailCollection Class
Microsoft.Xrm.Sdk Namespace


ErrorDetailCollection Constructor
[image]

Initializes a new instance of the ErrorDetailCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ErrorDetailCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorDetailCollection Class
ErrorDetailCollection Members
Microsoft.Xrm.Sdk Namespace


ErrorDetailCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

ErrorDetailCollection Class
Microsoft.Xrm.Sdk Namespace


ErrorDetailCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

ErrorDetailCollection Class
Microsoft.Xrm.Sdk Namespace


ExecuteMultipleResponseItem Class
See Also Members
[image]

Contains the response from execution of a message request.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ExecuteMultipleResponseItem", Namespace:="http://schemas.microsoft.com/xrm/2012/Contracts")> _
Public NotInheritable Class ExecuteMultipleResponseItem
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="ExecuteMultipleResponseItem", Namespace="http://schemas.microsoft.com/xrm/2012/Contracts")]
public sealed class ExecuteMultipleResponseItem : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.ExecuteMultipleResponseItem
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponseItem Members
Microsoft.Xrm.Sdk Namespace
Responses
ExecuteMultipleRequest


ExecuteMultipleResponseItem Members
See Also Constructors Methods Properties
[image]

Contains the response from execution of a message request.

The following tables list the members exposed by the ExecuteMultipleResponseItem type.

Public Constructors

Name | Description
ExecuteMultipleResponseItem | Initializes a new instance of the ExecuteMultipleResponseItem class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Fault | Gets or sets the organization service fault that occurred when a message request was executed.
public property | RequestIndex | Gets or sets the numerical position of a message request in a request collection.
public property | Response | Gets or sets the response that is returned from executing a message request.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteMultipleResponseItem Class
Microsoft.Xrm.Sdk Namespace
Responses
ExecuteMultipleRequest


ExecuteMultipleResponseItem Constructor
[image]

Initializes a new instance of the ExecuteMultipleResponseItem class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteMultipleResponseItem ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponseItem Class
ExecuteMultipleResponseItem Members
Microsoft.Xrm.Sdk Namespace


ExecuteMultipleResponseItem Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteMultipleResponseItem Class
Microsoft.Xrm.Sdk Namespace
Responses
ExecuteMultipleRequest


ExecuteMultipleResponseItem Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Fault | Gets or sets the organization service fault that occurred when a message request was executed.
public property | RequestIndex | Gets or sets the numerical position of a message request in a request collection.
public property | Response | Gets or sets the response that is returned from executing a message request.

See Also

Reference

ExecuteMultipleResponseItem Class
Microsoft.Xrm.Sdk Namespace
Responses
ExecuteMultipleRequest


ExecuteMultipleResponseItem.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponseItem Class
ExecuteMultipleResponseItem Members
Microsoft.Xrm.Sdk Namespace


ExecuteMultipleResponseItem.Fault Property
[image]

Gets or sets the organization service fault that occurred when a message request was executed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Fault As OrganizationServiceFault

C#
[DataMemberAttribute]
public OrganizationServiceFault Fault { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationServiceFault
The organization service fault.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponseItem Class
ExecuteMultipleResponseItem Members
Microsoft.Xrm.Sdk Namespace
IsFaulted


ExecuteMultipleResponseItem.RequestIndex Property
[image]

Gets or sets the numerical position of a message request in a request collection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RequestIndex As Integer

C#
[DataMemberAttribute]
public int RequestIndex { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The position of a message request in a request collection, starting at zero.

  Remarks
Identifies which message request in a request collection that the response item applies to.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponseItem Class
ExecuteMultipleResponseItem Members
Microsoft.Xrm.Sdk Namespace
OrganizationRequestCollection


ExecuteMultipleResponseItem.Response Property
[image]

Gets or sets the response that is returned from executing a message request.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Response As OrganizationResponse

C#
[DataMemberAttribute]
public OrganizationResponse Response { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationResponse
The message response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponseItem Class
ExecuteMultipleResponseItem Members
Microsoft.Xrm.Sdk Namespace


ExecuteMultipleResponseItemCollection Class
See Also Members
[image]

Contains a collection of ExecuteMultipleResponseItem instances.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="OrganizationResponseCollection", Namespace:="http://schemas.microsoft.com/xrm/2012/Contracts")> _
Public NotInheritable Class ExecuteMultipleResponseItemCollection
    Inherits DataCollection(Of ExecuteMultipleResponseItem)

C#
[CollectionDataContractAttribute(Name="OrganizationResponseCollection", Namespace="http://schemas.microsoft.com/xrm/2012/Contracts")]
public sealed class ExecuteMultipleResponseItemCollection : DataCollection<ExecuteMultipleResponseItem>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.ExecuteMultipleResponseItemCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponseItemCollection Members
Microsoft.Xrm.Sdk Namespace
Responses


ExecuteMultipleResponseItemCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a collection of ExecuteMultipleResponseItem instances.

The following tables list the members exposed by the ExecuteMultipleResponseItemCollection type.

Public Constructors

Name | Description
ExecuteMultipleResponseItemCollection | Initializes a new instance of the ExecuteMultipleResponseItemCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

ExecuteMultipleResponseItemCollection Class
Microsoft.Xrm.Sdk Namespace
Responses


ExecuteMultipleResponseItemCollection Constructor
[image]

Initializes a new instance of the ExecuteMultipleResponseItemCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteMultipleResponseItemCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponseItemCollection Class
ExecuteMultipleResponseItemCollection Members
Microsoft.Xrm.Sdk Namespace


ExecuteMultipleResponseItemCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

ExecuteMultipleResponseItemCollection Class
Microsoft.Xrm.Sdk Namespace
Responses


ExecuteMultipleResponseItemCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

ExecuteMultipleResponseItemCollection Class
Microsoft.Xrm.Sdk Namespace
Responses


ExecuteMultipleSettings Class
See Also Members
[image]

Defines the execution behavior of ExecuteMultipleRequest.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ExecuteMultipleSettings", Namespace:="http://schemas.microsoft.com/xrm/2012/Contracts")> _
Public NotInheritable Class ExecuteMultipleSettings
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="ExecuteMultipleSettings", Namespace="http://schemas.microsoft.com/xrm/2012/Contracts")]
public sealed class ExecuteMultipleSettings : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.ExecuteMultipleSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleSettings Members
Microsoft.Xrm.Sdk Namespace
Settings
Other Resources
Use Messages (Request and Response Classes) with the Execute Method
Sample: Execute Multiple Requests


ExecuteMultipleSettings Members
See Also Constructors Methods Properties
[image]

Defines the execution behavior of ExecuteMultipleRequest.

The following tables list the members exposed by the ExecuteMultipleSettings type.

Public Constructors

Name | Description
ExecuteMultipleSettings | Initializes a new instance of the ExecuteMultipleSettings class.
Top

Public Properties

 | Name | Description
public property | ContinueOnError | Gets or sets a value indicating whether further execution of message requests in the Requests collection should continue if a fault is returned for the current request being processed.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ReturnResponses | Gets or sets a value indicating if a response for each message request processed should be returned.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteMultipleSettings Class
Microsoft.Xrm.Sdk Namespace
Settings

Other Resources

Use Messages (Request and Response Classes) with the Execute Method
Sample: Execute Multiple Requests


ExecuteMultipleSettings Constructor
[image]

Initializes a new instance of the ExecuteMultipleSettings class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteMultipleSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleSettings Class
ExecuteMultipleSettings Members
Microsoft.Xrm.Sdk Namespace


ExecuteMultipleSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteMultipleSettings Class
Microsoft.Xrm.Sdk Namespace
Settings

Other Resources

Use Messages (Request and Response Classes) with the Execute Method
Sample: Execute Multiple Requests


ExecuteMultipleSettings Properties
[image]

Public Properties

 | Name | Description
public property | ContinueOnError | Gets or sets a value indicating whether further execution of message requests in the Requests collection should continue if a fault is returned for the current request being processed.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ReturnResponses | Gets or sets a value indicating if a response for each message request processed should be returned.

See Also

Reference

ExecuteMultipleSettings Class
Microsoft.Xrm.Sdk Namespace
Settings

Other Resources

Use Messages (Request and Response Classes) with the Execute Method
Sample: Execute Multiple Requests


ExecuteMultipleSettings.ContinueOnError Property
[image]

Gets or sets a value indicating whether further execution of message requests in the Requests collection should continue if a fault is returned for the current request being processed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ContinueOnError As Boolean

C#
[DataMemberAttribute]
public bool ContinueOnError { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if message request processing should continue; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleSettings Class
ExecuteMultipleSettings Members
Microsoft.Xrm.Sdk Namespace
IsFaulted


ExecuteMultipleSettings.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleSettings Class
ExecuteMultipleSettings Members
Microsoft.Xrm.Sdk Namespace


ExecuteMultipleSettings.ReturnResponses Property
[image]

Gets or sets a value indicating if a response for each message request processed should be returned.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ReturnResponses As Boolean

C#
[DataMemberAttribute]
public bool ReturnResponses { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if responses should be returned for each message request processed; otherwise, false.

  Remarks
If set to true and a request does not return a response, because that is its design, the ExecuteMultipleResponseItem for that request is set to null.
However, even when false, the Responses collection will not be empty if errors are returned. If errors are returned, there will be one response item in the collection for each processed request that returned a fault and Fault will be set to the actual fault that occurred.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleSettings Class
ExecuteMultipleSettings Members
Microsoft.Xrm.Sdk Namespace


FieldPermissionType Class
See Also Members
[image]

Defines the possible field permission types.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class FieldPermissionType

C#
public static class FieldPermissionType

C++

J#

JScript

  Remarks
These values are used to set the FieldPermission.CanCreate, CanRead and CanUpdate attributes.
Corresponds to the values of the A Yes or No Boolean global option set.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.FieldPermissionType
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FieldPermissionType Members
Microsoft.Xrm.Sdk Namespace


FieldPermissionType Members
See Also Fields Methods
[image]

Defines the possible field permission types.

The following tables list the members exposed by the FieldPermissionType type.

Public Fields

Name | Description
Allowed | The action is allowed. Value = 4.
NotAllowed | The action is not allowed. Value = 0.
Top

Public Methods

Name | Description
Validate | Validates the field permission value.
Top

See Also

Reference

FieldPermissionType Class
Microsoft.Xrm.Sdk Namespace


FieldPermissionType Fields
[image]

Public Fields

Name | Description
Allowed | The action is allowed. Value = 4.
NotAllowed | The action is not allowed. Value = 0.

See Also

Reference

FieldPermissionType Class
Microsoft.Xrm.Sdk Namespace


FieldPermissionType.Allowed Field
[image]

The action is allowed. Value = 4.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Allowed As Integer

C#
public const int Allowed

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FieldPermissionType Class
FieldPermissionType Members
Microsoft.Xrm.Sdk Namespace


FieldPermissionType.NotAllowed Field
[image]

The action is not allowed. Value = 0.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const NotAllowed As Integer

C#
public const int NotAllowed

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FieldPermissionType Class
FieldPermissionType Members
Microsoft.Xrm.Sdk Namespace


FieldPermissionType Methods
[image]

Public Methods

Name | Description
Validate | Validates the field permission value.

See Also

Reference

FieldPermissionType Class
Microsoft.Xrm.Sdk Namespace


FieldPermissionType.Validate Method
[image]

Validates the field permission value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub Validate ( _
    value As Integer _
)

C#
public static void Validate (
    int value
)

C++

J#

JScript

Parameters
value
Type: Int32. The value to validate.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FieldPermissionType Class
FieldPermissionType Members
Microsoft.Xrm.Sdk Namespace


FormattedValueCollection Class
See Also Members
[image]

Contains a collection of formatted values for the attributes for an entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="FormattedValueCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class FormattedValueCollection
    Inherits DataCollection(Of String, String)

C#
[CollectionDataContractAttribute(Name="FormattedValueCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class FormattedValueCollection : DataCollection<string,string>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.FormattedValueCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FormattedValueCollection Members
Microsoft.Xrm.Sdk Namespace
AttributeCollection
Entity


FormattedValueCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a collection of formatted values for the attributes for an entity.

The following tables list the members exposed by the FormattedValueCollection type.

Public Constructors

Name | Description
FormattedValueCollection | Initializes a new instance of the FormattedValueCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

FormattedValueCollection Class
Microsoft.Xrm.Sdk Namespace
AttributeCollection
Entity


FormattedValueCollection Constructor
[image]

Initializes a new instance of the FormattedValueCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public FormattedValueCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FormattedValueCollection Class
FormattedValueCollection Members
Microsoft.Xrm.Sdk Namespace


FormattedValueCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

FormattedValueCollection Class
Microsoft.Xrm.Sdk Namespace
AttributeCollection
Entity


FormattedValueCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

FormattedValueCollection Class
Microsoft.Xrm.Sdk Namespace
AttributeCollection
Entity


IExecutionContext Interface
See Also Members
[image]

Base interface that defines the contextual information passed to a plug-in or custom workflow activity at run-time.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IExecutionContext

C#
public interface IExecutionContext

C++

J#

JScript

  Remarks
Populated by the event execution pipeline in response to the processing of a message request before any plug-ins or custom workflow activities are executed.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext
IWorkflowContext
Other Resources
Event Execution Pipeline
Understand the Data Context Passed to a Plug-in


IExecutionContext Members
See Also Properties
[image]

Base interface that defines the contextual information passed to a plug-in or custom workflow activity at run-time.

The following tables list the members exposed by the IExecutionContext type.

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the GUIDGUID of the business unit that the user making the request, also known as the calling user, belongs to.
public property | CorrelationId | Gets the GUID for tracking plug-in or custom workflow activity execution.
public property | Depth | Gets the current depth of execution in the call stack.
public property | InitiatingUserId | Gets the GUID of the system user account under which the current pipeline is executing.
public property | InputParameters | Gets the parameters of the request message that triggered the event that caused the plug-in to execute.
public property | IsExecutingOffline | Gets whether the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline.
public property | IsInTransaction | Gets a value indicating if the plug-in is executing within the database transaction.
public property | IsOfflinePlayback | Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server.
public property | IsolationMode | Gets a value indicating if the plug-in is executing in the sandbox.
public property | MessageName | Gets the name of the Web service message that is being processed by the event execution pipeline.
public property | Mode | Gets the mode of plug-in execution.
public property | OperationCreatedOn | Gets the date and time that the related System Job was created.
public property | OperationId | Gets the GUID of the related System Job.
public property | OrganizationId | Gets the GUID of the organization that the entity belongs to and the plug-in executes under.
public property | OrganizationName | Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under.
public property | OutputParameters | Gets the parameters of the response message after the core platform operation has completed.
public property | OwningExtension | Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint.
public property | PostEntityImages | Gets the properties of the primary entity after the core platform operation has been completed.
public property | PreEntityImages | Gets the properties of the primary entity before the core platform operation has begins.
public property | PrimaryEntityId | Gets the GUID of the primary entity for which the pipeline is processing events.
public property | PrimaryEntityName | Gets the name of the primary entity for which the pipeline is processing events.
public property | RequestId | Gets the GUID of the request being processed by the event execution pipeline.
public property | SecondaryEntityName | Gets the name of the secondary entity that has a relationship with the primary entity.
public property | SharedVariables | Gets the custom properties that are shared between plug-ins.
public property | UserId | Gets the GUID of the system user for whom the plug-in invokes web service methods on behalf of.
Top

See Also

Reference

IExecutionContext Interface
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext
IWorkflowContext

Other Resources

Event Execution Pipeline
Understand the Data Context Passed to a Plug-in


IExecutionContext Properties
[image]

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the GUIDGUID of the business unit that the user making the request, also known as the calling user, belongs to.
public property | CorrelationId | Gets the GUID for tracking plug-in or custom workflow activity execution.
public property | Depth | Gets the current depth of execution in the call stack.
public property | InitiatingUserId | Gets the GUID of the system user account under which the current pipeline is executing.
public property | InputParameters | Gets the parameters of the request message that triggered the event that caused the plug-in to execute.
public property | IsExecutingOffline | Gets whether the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline.
public property | IsInTransaction | Gets a value indicating if the plug-in is executing within the database transaction.
public property | IsOfflinePlayback | Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server.
public property | IsolationMode | Gets a value indicating if the plug-in is executing in the sandbox.
public property | MessageName | Gets the name of the Web service message that is being processed by the event execution pipeline.
public property | Mode | Gets the mode of plug-in execution.
public property | OperationCreatedOn | Gets the date and time that the related System Job was created.
public property | OperationId | Gets the GUID of the related System Job.
public property | OrganizationId | Gets the GUID of the organization that the entity belongs to and the plug-in executes under.
public property | OrganizationName | Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under.
public property | OutputParameters | Gets the parameters of the response message after the core platform operation has completed.
public property | OwningExtension | Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint.
public property | PostEntityImages | Gets the properties of the primary entity after the core platform operation has been completed.
public property | PreEntityImages | Gets the properties of the primary entity before the core platform operation has begins.
public property | PrimaryEntityId | Gets the GUID of the primary entity for which the pipeline is processing events.
public property | PrimaryEntityName | Gets the name of the primary entity for which the pipeline is processing events.
public property | RequestId | Gets the GUID of the request being processed by the event execution pipeline.
public property | SecondaryEntityName | Gets the name of the secondary entity that has a relationship with the primary entity.
public property | SharedVariables | Gets the custom properties that are shared between plug-ins.
public property | UserId | Gets the GUID of the system user for whom the plug-in invokes web service methods on behalf of.

See Also

Reference

IExecutionContext Interface
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext
IWorkflowContext

Other Resources

Event Execution Pipeline
Understand the Data Context Passed to a Plug-in


IExecutionContext.BusinessUnitId Property
[image]

Gets the GUIDGUID of the business unit that the user making the request, also known as the calling user, belongs to.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property BusinessUnitId As Guid

C#
Guid BusinessUnitId { get; }

C++

J#

JScript

Property Value
Type: Guid
The GUID of the business unit. This property corresponds to the BusinessUnitId property, which is the primary key for the BusinessUnit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
BusinessUnit Entity


IExecutionContext.CorrelationId Property
[image]

Gets the GUID for tracking plug-in or custom workflow activity execution.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property CorrelationId As Guid

C#
Guid CorrelationId { get; }

C++

J#

JScript

Property Value
Type: Guid
The GUID for tracking plug-in or custom workflow activity execution.

  Remarks
This property is used by the platform for infinite loop prevention. In most cases, this property can be ignored.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Depth


IExecutionContext.Depth Property
[image]

Gets the current depth of execution in the call stack.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property Depth As Integer

C#
int Depth { get; }

C++

J#

JScript

Property Value
Type: Int32
T the current depth of execution in the call stack.

  Remarks
Used by the platform for infinite loop prevention. In most cases, this property can be ignored.
Every time a running plug-in or Workflow issues a message request to the Web services that triggers another plug-in or Workflow to execute, the Depth property of the execution context is increased. If the depth property increments to its maximum value within the configured time limit, the platform considers this behavior an infinite loop and further plug-in or Workflow execution is aborted.
The maximum depth (8) and time limit (one hour) are configurable by the Microsoft Dynamics CRM administrator using the PowerShell command Set-CrmSetting. The setting is WorkflowSettings.MaxDepth. For more information, see, “Administer the deployment using Windows PowerShell” in the Deploying and administering Microsoft Dynamics CRM.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
CorrelationId


IExecutionContext.InitiatingUserId Property
[image]

Gets the GUID of the system user account under which the current pipeline is executing.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property InitiatingUserId As Guid

C#
Guid InitiatingUserId { get; }

C++

J#

JScript

Property Value
Type: Guid
The GUID of the system user account under which the current pipeline is executing. This property corresponds to the SystemUserId property, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Impersonation in Plug-ins
User and Team Entities


IExecutionContext.InputParameters Property
[image]

Gets the parameters of the request message that triggered the event that caused the plug-in to execute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property InputParameters As ParameterCollection

C#
ParameterCollection InputParameters { get; }

C++

J#

JScript

Property Value
Type: ParameterCollection
The parameters of the request message that triggered the event that caused the plug-in to execute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
OutputParameters
Other Resources
Input and Output Parameters
Use Messages (Request and Response Classes) with the Execute Method


IExecutionContext.IsExecutingOffline Property
[image]

Gets whether the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property IsExecutingOffline As Boolean

C#
bool IsExecutingOffline { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
IsOfflinePlayback
Other Resources
Write a Plug-in


IExecutionContext.IsInTransaction Property
[image]

Gets a value indicating if the plug-in is executing within the database transaction.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property IsInTransaction As Boolean

C#
bool IsInTransaction { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the plug-in is executing within the database transaction; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Event Execution Pipeline


IExecutionContext.IsOfflinePlayback Property
[image]

Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property IsOfflinePlayback As Boolean

C#
bool IsOfflinePlayback { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
IsExecutingOffline


IExecutionContext.IsolationMode Property
[image]

Gets a value indicating if the plug-in is executing in the sandbox.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property IsolationMode As Integer

C#
int IsolationMode { get; }

C++

J#

JScript

Property Value
Type: Int32
Indicates if the plug-in is executing in the sandbox.

  Remarks
Allowable values are defined in the PluginAssemblyIsolationMode enumeration defined in SampleCode\CS\HelperCode\OptionSets.cs and SampleCode\VB\HelperCode\OptionSets.vb of the SDK download.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Plug-in Isolation, Trust, and Statistics


IExecutionContext.MessageName Property
[image]

Gets the name of the Web service message that is being processed by the event execution pipeline.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property MessageName As String

C#
string MessageName { get; }

C++

J#

JScript

Property Value
Type: String
The name of the Web service message being processed by the event execution pipeline.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Supported Messages and Entities for Plug-ins


IExecutionContext.Mode Property
[image]

Gets the mode of plug-in execution.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property Mode As Integer

C#
int Mode { get; }

C++

J#

JScript

Property Value
Type: Int32
The mode of plug-in execution.

  Remarks
Allowable values are defined in the SdkMessageProcessingStepMode enumeration defined in SampleCode\CS\HelperCode\OptionSets.cs and SampleCode\VB\HelperCode\OptionSets.vb of the SDK download.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Event Execution Pipeline


IExecutionContext.OperationCreatedOn Property
[image]

Gets the date and time that the related System Job was created.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property OperationCreatedOn As DateTime

C#
DateTime OperationCreatedOn { get; }

C++

J#

JScript

Property Value
Type: DateTime
The date and time that the related System Job was created.

  Remarks
This property is used for the Microsoft Dynamics CRM to Microsoft Azure integration feature. It contains the same date and time value as the CreatedOn property of the related System Job entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
OperationId
Other Resources
AsyncOperation (System Job) Entity
Introduction to Windows Azure Integration with Microsoft Dynamics CRM


IExecutionContext.OperationId Property
[image]

Gets the GUID of the related System Job.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property OperationId As Guid

C#
Guid OperationId { get; }

C++

J#

JScript

Property Value
Type: Guid
The GUID of the related System Job. This corresponds to the AsyncOperationId attribute, which is the primary key for the System Job entity.

  Remarks
This property is used for the Microsoft Dynamics CRM to Microsoft Azure integration feature.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
OperationCreatedOn
Other Resources
AsyncOperation (System Job) Entity
Introduction to Windows Azure Integration with Microsoft Dynamics CRM


IExecutionContext.OrganizationId Property
[image]

Gets the GUID of the organization that the entity belongs to and the plug-in executes under.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property OrganizationId As Guid

C#
Guid OrganizationId { get; }

C++

J#

JScript

Property Value
Type: Guid
The GUID of the organization that the entity belongs to and the plug-in executes under. This corresponds to the OrganizationId attribute, which is the primary key for the Organization entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Organization Entities


IExecutionContext.OrganizationName Property
[image]

Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property OrganizationName As String

C#
string OrganizationName { get; }

C++

J#

JScript

Property Value
Type: String
The unique name of the organization that the entity currently being processed belongs to and the plug-in executes under.

  Remarks
See the Name attribute of the Organization entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Organization Entities


IExecutionContext.OutputParameters Property
[image]

Gets the parameters of the response message after the core platform operation has completed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property OutputParameters As ParameterCollection

C#
ParameterCollection OutputParameters { get; }

C++

J#

JScript

Property Value
Type: ParameterCollection
The parameters of the response message after the core platform operation has completed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
InputParameters
Other Resources
Input and Output Parameters
Use Messages (Request and Response Classes) with the Execute Method


IExecutionContext.OwningExtension Property
[image]

Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property OwningExtension As EntityReference

C#
EntityReference OwningExtension { get; }

C++

J#

JScript

Property Value
Type: EntityReference
A reference to the related SdkMessageProcessingingStep or ServiceEndpoint.entity.

  Remarks
An SdkMessageProcessingingStep entity is used for plug-in registration and a ServiceEndpoint entity is used for Microsoft Azure integration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Plug-in Registration Entities
ServiceEndpoint Entity Messages and Methods
Send Microsoft Dynamics CRM Data over the AppFabric Service Bus


IExecutionContext.PostEntityImages Property
[image]

Gets the properties of the primary entity after the core platform operation has been completed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property PostEntityImages As EntityImageCollection

C#
EntityImageCollection PostEntityImages { get; }

C++

J#

JScript

Property Value
Type: EntityImageCollection
The properties of the primary entity after the core platform operation has been completed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
PreEntityImages
Other Resources
Pre and Post Entity Images


IExecutionContext.PreEntityImages Property
[image]

Gets the properties of the primary entity before the core platform operation has begins.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property PreEntityImages As EntityImageCollection

C#
EntityImageCollection PreEntityImages { get; }

C++

J#

JScript

Property Value
Type: EntityImageCollection
The properties of the primary entity before the core platform operation has begins.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
PostEntityImages
Other Resources
Pre and Post Entity Images


IExecutionContext.PrimaryEntityId Property
[image]

Gets the GUID of the primary entity for which the pipeline is processing events.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property PrimaryEntityId As Guid

C#
Guid PrimaryEntityId { get; }

C++

J#

JScript

Property Value
Type: Guid
The GUID of the primary entity for which the pipeline is processing events. For example, if the event pipeline is processing an account, this corresponds to the AccountId attribute, which is the primary key for the Account entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Event Execution Pipeline


IExecutionContext.PrimaryEntityName Property
[image]

Gets the name of the primary entity for which the pipeline is processing events.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property PrimaryEntityName As String

C#
string PrimaryEntityName { get; }

C++

J#

JScript

Property Value
Type: String
The name of the primary entity for which the pipeline is processing events.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
SecondaryEntityName
Other Resources
Event Execution Pipeline


IExecutionContext.RequestId Property
[image]

Gets the GUID of the request being processed by the event execution pipeline.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property RequestId As Nullable(Of Guid)

C#
Nullable<Guid> RequestId { get; }

C++

J#

JScript

Property Value
Type: Nullable<Guid>
The GUID of the request being processed by the event execution pipeline. This corresponds to the RequestId property, which is the primary key for the OrganizationRequest class from which specialized request classes are derived.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use Messages (Request and Response Classes) with the Execute Method
Event Execution Pipeline


IExecutionContext.SecondaryEntityName Property
[image]

Gets the name of the secondary entity that has a relationship with the primary entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property SecondaryEntityName As String

C#
string SecondaryEntityName { get; }

C++

J#

JScript

Property Value
Type: String
The name of the secondary entity that has a relationship with the primary entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
PrimaryEntityName


IExecutionContext.SharedVariables Property
[image]

Gets the custom properties that are shared between plug-ins.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property SharedVariables As ParameterCollection

C#
ParameterCollection SharedVariables { get; }

C++

J#

JScript

Property Value
Type: ParameterCollection
The custom properties that are shared between plug-ins.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Pass Data Between Plug-ins


IExecutionContext.UserId Property
[image]

Gets the GUID of the system user for whom the plug-in invokes web service methods on behalf of.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property UserId As Guid

C#
Guid UserId { get; }

C++

J#

JScript

Property Value
Type: Guid
The GUID of the system user for whom the plug-in invokes web service methods on behalf of. This property corresponds to the SystemUserId property, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExecutionContext Interface
IExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
User and Team Entities


InvalidPluginExecutionException Class
See Also Members
[image]

Represents an exception that occurred during plug-in execution.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class InvalidPluginExecutionException
    Inherits Exception
    Implements ISerializable

C#
[SerializableAttribute]
public sealed class InvalidPluginExecutionException : Exception, ISerializable

C++

J#

JScript

  Remarks
When thrown by a plug-in, the Microsoft Dynamics CRM platform displays the exception message in a dialog of the Web application.

  Inheritance Hierarchy
System.Object

                System.Exception
    Microsoft.Xrm.Sdk.InvalidPluginExecutionException
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Handle Exceptions in Plug-ins


InvalidPluginExecutionException Members
See Also Constructors Methods Properties Events
[image]

Represents an exception that occurred during plug-in execution.

The following tables list the members exposed by the InvalidPluginExecutionException type.

Public Constructors

Name | Description
InvalidPluginExecutionException | Overloaded. Initializes a new instance of the InvalidPluginExecutionException class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Data | (inherited from Exception)
public property | ErrorCode | Gets the numeric code that identifies a specific error condition.
public property | HelpLink | (inherited from Exception)
public property | InnerException | (inherited from Exception)
public property | Message | (inherited from Exception)
public property | Source | (inherited from Exception)
public property | StackTrace | (inherited from Exception)
public property | Status | Gets the status of the plug-in exception.
public property | TargetSite | (inherited from Exception)
Top

Protected Properties

 | Name | Description
protected property | HResult | (inherited from Exception)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetBaseException | (inherited from Exception)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | Overridden. Sets the SerializationInfo with information about the exception.
public method | GetType | (inherited from Exception)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Protected Events

 | Name | Description
protected event | SerializeObjectState | (inherited from Exception)
Top

See Also

Reference

InvalidPluginExecutionException Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Handle Exceptions in Plug-ins


InvalidPluginExecutionException Constructor
[image]

Initializes a new instance of the InvalidPluginExecutionException class.

Overload List

Name | Description
InvalidPluginExecutionException () | Initializes a new instance of the InvalidPluginExecutionException class.
InvalidPluginExecutionException (OperationStatus) | Initializes a new instance of the InvalidPluginExecutionException class with an operation status.
InvalidPluginExecutionException (OperationStatus, Int32, String) | Initializes a new instance of the InvalidPluginExecutionException class with an operation status, an error code, and an error message.
InvalidPluginExecutionException (OperationStatus, String) | Initializes a new instance of the InvalidPluginExecutionException class with an operation status and an error message.
InvalidPluginExecutionException (String) | Initializes a new instance of the InvalidPluginExecutionException class with an error message.
InvalidPluginExecutionException (String, Exception) | Initializes a new instance of the InvalidPluginExecutionException class with a reference to the inner exception that is the cause of this exception.

See Also

Reference

InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace


InvalidPluginExecutionException Constructor ()
[image]

Initializes a new instance of the InvalidPluginExecutionException class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InvalidPluginExecutionException ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace


InvalidPluginExecutionException Constructor (OperationStatus)
[image]

Initializes a new instance of the InvalidPluginExecutionException class with an operation status.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    status As OperationStatus _
)

C#
public InvalidPluginExecutionException (
    OperationStatus status
)

C++

J#

JScript

Parameters
status
Type: OperationStatus. The status of the operation.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace


InvalidPluginExecutionException Constructor (OperationStatus, Int32, String)
[image]

Initializes a new instance of the InvalidPluginExecutionException class with an operation status, an error code, and an error message.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    status As OperationStatus, _
    errorCode As Integer, _
    message As String _
)

C#
public InvalidPluginExecutionException (
    OperationStatus status,
    int errorCode,
    string message
)

C++

J#

JScript

Parameters
status
Type: OperationStatus. The status of the operation.
errorCode
Type: Int32. The error code that identifies the specific error.
message
Type: String. The error message that explains the reason for the exception.
  Remarks
See the ErrorCodes.cs file in the SampleCode\CS\HelperCode folder of the SDK download for a list of Microsoft Dynamics CRM specific error codes.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Web Service Error Codes


InvalidPluginExecutionException Constructor (OperationStatus, String)
[image]

Initializes a new instance of the InvalidPluginExecutionException class with an operation status and an error message.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    status As OperationStatus, _
    message As String _
)

C#
public InvalidPluginExecutionException (
    OperationStatus status,
    string message
)

C++

J#

JScript

Parameters
status
Type: OperationStatus. The status of the operation.
message
Type: String. The error message that explains the reason for the exception.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace


InvalidPluginExecutionException Constructor (String)
[image]

Initializes a new instance of the InvalidPluginExecutionException class with an error message.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String _
)

C#
public InvalidPluginExecutionException (
    string message
)

C++

J#

JScript

Parameters
message
Type: String. The error message that explains the reason for the exception.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace


InvalidPluginExecutionException Constructor (String, Exception)
[image]

Initializes a new instance of the InvalidPluginExecutionException class with a reference to the inner exception that is the cause of this exception.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String, _
    exception As Exception _
)

C#
public InvalidPluginExecutionException (
    string message,
    Exception exception
)

C++

J#

JScript

Parameters
message
Type: String. The error message that explains the reason for the exception.
exception
Type: Exception. The inner exception that is the cause of this exception.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace


InvalidPluginExecutionException Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetBaseException | (inherited from Exception)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | Overridden. Sets the SerializationInfo with information about the exception.
public method | GetType | (inherited from Exception)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InvalidPluginExecutionException Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Handle Exceptions in Plug-ins


InvalidPluginExecutionException.GetObjectData Method
[image]

Sets the SerializationInfo with information about the exception.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecurityCriticalAttribute> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

C#
[SecurityCriticalAttribute]
public override void GetObjectData (
    SerializationInfo info,
    StreamingContext context
)

C++

J#

JScript

Parameters
info
Type:  SerializationInfo. The serialized object data about the exception being thrown.
context
Type: StreamingContext. The contextual information about the source or destination.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace


InvalidPluginExecutionException Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Data | (inherited from Exception)
public property | ErrorCode | Gets the numeric code that identifies a specific error condition.
public property | HelpLink | (inherited from Exception)
public property | InnerException | (inherited from Exception)
public property | Message | (inherited from Exception)
public property | Source | (inherited from Exception)
public property | StackTrace | (inherited from Exception)
public property | Status | Gets the status of the plug-in exception.
public property | TargetSite | (inherited from Exception)

Protected Properties

 | Name | Description
protected property | HResult | (inherited from Exception)

See Also

Reference

InvalidPluginExecutionException Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Handle Exceptions in Plug-ins


InvalidPluginExecutionException.ErrorCode Property
[image]

Gets the numeric code that identifies a specific error condition.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ErrorCode As Integer

C#
public int ErrorCode { get; }

C++

J#

JScript

Property Value
Type: Int32
The error code.

  Remarks
See the ErrorCodes.cs file in the SampleCode\CS\HelperCode folder of the SDK download for a list of Microsoft Dynamics CRM specific error codes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Web Service Error Codes


InvalidPluginExecutionException.Status Property
[image]

Gets the status of the plug-in exception.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Status As OperationStatus

C#
public OperationStatus Status { get; }

C++

J#

JScript

Property Value
Type: OperationStatus
The status of the plug-in exception.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InvalidPluginExecutionException Class
InvalidPluginExecutionException Members
Microsoft.Xrm.Sdk Namespace


InvalidPluginExecutionException Events
[image]

Protected Events

 | Name | Description
protected event | SerializeObjectState | (inherited from Exception)

See Also

Reference

InvalidPluginExecutionException Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Handle Exceptions in Plug-ins


IOrganizationService Interface
See Also Members
[image]

Provides programmatic access to the metadata and data for an organization.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<ServiceContractAttribute(Name:="IOrganizationService", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Services")> _
Public Interface IOrganizationService

C#
[ServiceContractAttribute(Name="IOrganizationService", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Services")]
public interface IOrganizationService

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationService Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Read and Write Data and Metadata using the IOrganizationService Web Service
Use the IOrganization Web Service in a Custom Workflow Activity
Sample: Create, Retrieve, Update and Delete Records (Early Bound)
Troubleshooting and Error Handling


IOrganizationService Members
See Also Methods
[image]

Provides programmatic access to the metadata and data for an organization.

The following tables list the members exposed by the IOrganizationService type.

Public Methods

 | Name | Description
public method | Associate | Creates a link between records.
public method | Create | Creates a record.
public method | Delete | Deletes a record.
public method | Disassociate | Deletes a link between records.
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | Retrieve | Retrieves a record.
public method | RetrieveMultiple | Retrieves a collection of records.
public method | Update | Updates an existing record.
Top

See Also

Reference

IOrganizationService Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Read and Write Data and Metadata using the IOrganizationService Web Service
Use the IOrganization Web Service in a Custom Workflow Activity
Sample: Create, Retrieve, Update and Delete Records (Early Bound)
Troubleshooting and Error Handling


IOrganizationService Methods
[image]

Public Methods

 | Name | Description
public method | Associate | Creates a link between records.
public method | Create | Creates a record.
public method | Delete | Deletes a record.
public method | Disassociate | Deletes a link between records.
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | Retrieve | Retrieves a record.
public method | RetrieveMultiple | Retrieves a collection of records.
public method | Update | Updates an existing record.

See Also

Reference

IOrganizationService Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Read and Write Data and Metadata using the IOrganizationService Web Service
Use the IOrganization Web Service in a Custom Workflow Activity
Sample: Create, Retrieve, Update and Delete Records (Early Bound)
Troubleshooting and Error Handling


IOrganizationService.Associate Method
See Also Example
[image]

Creates a link between records.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FaultContractAttribute(GetType(OrganizationServiceFault))> _
<OperationContractAttribute> _
Sub Associate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
[FaultContractAttribute(typeof(OrganizationServiceFault))]
[OperationContractAttribute]
void Associate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity that is specified in the entityId parameter.
entityId
Type: Guid. The ID of the record to which the related records are associated.
relationship
Type: Relationship. The name of the relationship to be used to create the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be associated.
  Example
The following example shows how to use the Associate method to create an association or link between records. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\LateBound\AssociateDisassociateDE.cs.
  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter and access rights on the record that is specified in the entityId parameter. For a list of the required privileges, see Associate Privileges.
Notes for Callers
This method creates multiple associations in one transaction between the record that is specified by the entityId parameter and each record in the relatedEntities parameter for the specified relationship in the relationship parameter.
For a one-to-many relationship, this method sets the ReferencingAttribute in the related record to the value of the entityId.
For a many-to-many relationship, this method creates a record in the intersect table for the relationship, which contains the ID of both the referenced and referencing records. The intersect table name is defined in the IntersectEntityName property for the relationship. You need this when you query for the records. However, you need the relationship name to set the Relationship property. This name is defined in the SchemaName property for the relationship.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities
You can use this method to associate any records that participate in a relationship, including records for custom entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationService Interface
IOrganizationService Members
Microsoft.Xrm.Sdk Namespace
AssociateRequest
AssociateResponse
Other Resources
Entity Metadata
Customize Entity Relationship Metadata
Sample: Associate  (Early Bound)
Handle Exceptions in Your Code
Troubleshooting and Error Handling
Assign


IOrganizationService.Create Method
See Also Example
[image]

Creates a record.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<OperationContractAttribute> _
<FaultContractAttribute(GetType(OrganizationServiceFault))> _
Function Create ( _
    entity As Entity _
) As Guid

C#
[OperationContractAttribute]
[FaultContractAttribute(typeof(OrganizationServiceFault))]
Guid Create (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that contains the properties to set in the newly created record.
Return Value
Type:Guid

The ID of the newly created record.

  Example
The following example shows how to use the Create method to create an account record (early bound). For this sample to work correctly, you must be connected to the server to instantiate an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\EarlyBound\CRUDOperations.cs.
C#    Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Instantiate an account object.
    // See the Entity Metadata topic in the SDK documentation to determine
    // which attributes must be set for each entity.
    Account account = new Account { Name = "Fourth Coffee" };

    // Create an account record named Fourth Coffee.
    _accountId = _serviceProxy.Create(account);
    Console.Write("{0} {1} created, ", account.LogicalName, account.Name);

    // Retrieve the account containing several of its attributes.
    ColumnSet cols = new ColumnSet(
        new String[] { "name", "address1_postalcode", "lastusedincampaign", "versionnumber" });

    Account retrievedAccount = (Account)_serviceProxy.Retrieve("account", _accountId, cols);
    Console.Write("retrieved ");

    // Retrieve version number of the account. Shows BigInt attribute usage.
    long? versionNumber = retrievedAccount.VersionNumber;

    if (versionNumber != null)
        Console.WriteLine("version # {0}, ", versionNumber);

    // Update the postal code attribute.
    retrievedAccount.Address1_PostalCode = "98052";

    // The address 2 postal code was set accidentally, so set it to null.
    retrievedAccount.Address2_PostalCode = null;

    // Shows usage of option set (picklist) enumerations defined in OptionSets.cs.
    retrievedAccount.Address1_AddressTypeCode = new OptionSetValue((int)AccountAddress1_AddressTypeCode.Primary);
    retrievedAccount.Address1_ShippingMethodCode = new OptionSetValue((int)AccountAddress1_ShippingMethodCode.DHL);
    retrievedAccount.IndustryCode = new OptionSetValue((int)AccountIndustryCode.AgricultureandNonpetrolNaturalResourceExtraction);

    // Shows use of a Money value.
    retrievedAccount.Revenue = new Money(5000000);

    // Shows use of a Boolean value.
    retrievedAccount.CreditOnHold = false;

    // Shows use of EntityReference.
    retrievedAccount.ParentAccountId = new EntityReference(Account.EntityLogicalName, _parentAccountId);

    // Shows use of Memo attribute.
    retrievedAccount.Description = "Account for Fourth Coffee.";

    // Update the account record.
    _serviceProxy.Update(retrievedAccount);
    Console.WriteLine("and updated.");

    _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
    _serviceProxy.Delete(Account.EntityLogicalName, _parentAccountId);
    Console.WriteLine("Entity records have been deleted.");
}

The following example shows how to use the Create method to create an account record (late bound). For this sample to work correctly, you must be connected to the server to instantiate an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\LateBound\CRUDOperationsDE.cs.
C#    Copy Code
// Instaniate an account object.
Entity account = new Entity("account");

// Set the required attributes. For account, only the name is required.
// See the Entity Metadata topic in the SDK documentatio to determine
// which attributes must be set for each entity.
account["name"] = "Fourth Coffee";

// Create an account record named Fourth Coffee.
_accountId = _service.Create(account);

Console.Write("{0} {1} created, ", account.LogicalName, account.Attributes["name"]);

// Create a column set to define which attributes should be retrieved.
ColumnSet attributes = new ColumnSet(new string[] { "name", "ownerid" });

// Retrieve the account and its name and ownerid attributes.
account = _service.Retrieve(account.LogicalName, _accountId, attributes);
Console.Write("retrieved, ");

// Update the postal code attribute.
account["address1_postalcode"] = "98052";

// The address 2 postal code was set accidentally, so set it to null.
account["address2_postalcode"] = null;

// Shows use of Money.
account["revenue"] = new Money(5000000);

// Shows use of boolean.
account["creditonhold"] = false;

// Update the account.
_service.Update(account);
Console.WriteLine("and updated.");

// Delete the account.
bool deleteRecords = true;

if (promptForDelete)
{
    Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
    String answer = Console.ReadLine();

    deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
}

if (deleteRecords)
{
    _service.Delete("account", _accountId);

    Console.WriteLine("Entity record(s) have been deleted.");
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entity parameter. For a list of the required privileges, see Create Privileges.
Notes for Callers
This method creates one record in a transaction. To create a record that has related records in a transaction, use CreateRequest.
By default the caller becomes the owner for the new record. However, for the caller to own the new record, it must have both Create and Read privileges for the entity. For more information, see Privileges by Entity. Alternatively, you can set the ownerid property to the ID of another user.
The entity instance that is specified as a parameter must contain values for all the attributes where the RequiredLevel is set to SystemRequired. You can see this in the metadata topic for the entity. If the entity instance includes properties where IsValidForCreate is false, the values are ignored. You can find this information in the metadata for your organization. See the preceding metadata browser information.

                        For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities
You can use this method to create any record of an entity that supports the Create message, including custom entities.

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
ActivityMimeAttachment | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
AttributeMap | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
ColumnMapping | 2 (Both)
Competitor | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConnectionRoleObjectTypeCode | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
HierarchySecurityConfiguration | 2 (Both)
Import | 2 (Both)
ImportEntityMapping | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
LookUpMapping | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
OrganizationUI | 2 (Both)
OwnerMapping | 2 (Both)
PhoneCall | 2 (Both)
PickListMapping | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
Position | 2 (Both)
Post | 2 (Both)
PostComment | 2 (Both)
PostFollow | 2 (Both)
PostLike | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
ProcessSession | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportVisibility | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointDocument | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
Subject | 2 (Both)
SystemForm | 2 (Both)
SystemUser | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TraceLog | 2 (Both)
TransactionCurrency | 2 (Both)
TransformationMapping | 2 (Both)
TransformationParameterMapping | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IOrganizationService Interface
IOrganizationService Members
Microsoft.Xrm.Sdk Namespace
CreateRequest
CreateResponse
Other Resources
Sample: Create, Retrieve, Update and Delete (Early Bound)
Sample: Create, Retrieve, Update and Delete a Dashboard
Handle Exceptions in Your Code
Troubleshooting and Error Handling
Create


IOrganizationService.Delete Method
See Also Example
[image]

Deletes a record.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<OperationContractAttribute> _
<FaultContractAttribute(GetType(OrganizationServiceFault))> _
Sub Delete ( _
    entityName As String, _
    id As Guid _
)

C#
[OperationContractAttribute]
[FaultContractAttribute(typeof(OrganizationServiceFault))]
void Delete (
    string entityName,
    Guid id
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity that is specified in the entityId parameter.
id
Type: Guid. The ID of the record that you want to delete.
  Example
The following example shows how to use the Delete method to delete an account record (early bound). For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\EarlyBound\CRUDOperations.cs.
C#    Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Instantiate an account object.
    // See the Entity Metadata topic in the SDK documentation to determine
    // which attributes must be set for each entity.
    Account account = new Account { Name = "Fourth Coffee" };

    // Create an account record named Fourth Coffee.
    _accountId = _serviceProxy.Create(account);
    Console.Write("{0} {1} created, ", account.LogicalName, account.Name);

    // Retrieve the account containing several of its attributes.
    ColumnSet cols = new ColumnSet(
        new String[] { "name", "address1_postalcode", "lastusedincampaign", "versionnumber" });

    Account retrievedAccount = (Account)_serviceProxy.Retrieve("account", _accountId, cols);
    Console.Write("retrieved ");

    // Retrieve version number of the account. Shows BigInt attribute usage.
    long? versionNumber = retrievedAccount.VersionNumber;

    if (versionNumber != null)
        Console.WriteLine("version # {0}, ", versionNumber);

    // Update the postal code attribute.
    retrievedAccount.Address1_PostalCode = "98052";

    // The address 2 postal code was set accidentally, so set it to null.
    retrievedAccount.Address2_PostalCode = null;

    // Shows usage of option set (picklist) enumerations defined in OptionSets.cs.
    retrievedAccount.Address1_AddressTypeCode = new OptionSetValue((int)AccountAddress1_AddressTypeCode.Primary);
    retrievedAccount.Address1_ShippingMethodCode = new OptionSetValue((int)AccountAddress1_ShippingMethodCode.DHL);
    retrievedAccount.IndustryCode = new OptionSetValue((int)AccountIndustryCode.AgricultureandNonpetrolNaturalResourceExtraction);

    // Shows use of a Money value.
    retrievedAccount.Revenue = new Money(5000000);

    // Shows use of a Boolean value.
    retrievedAccount.CreditOnHold = false;

    // Shows use of EntityReference.
    retrievedAccount.ParentAccountId = new EntityReference(Account.EntityLogicalName, _parentAccountId);

    // Shows use of Memo attribute.
    retrievedAccount.Description = "Account for Fourth Coffee.";

    // Update the account record.
    _serviceProxy.Update(retrievedAccount);
    Console.WriteLine("and updated.");

    _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
    _serviceProxy.Delete(Account.EntityLogicalName, _parentAccountId);
    Console.WriteLine("Entity records have been deleted.");
}

The following example shows how to use the Delete method to delete an account record (late bound). For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\LateBound\CRUDOperationsDE.cs.
C#    Copy Code
// Instaniate an account object.
Entity account = new Entity("account");

// Set the required attributes. For account, only the name is required.
// See the Entity Metadata topic in the SDK documentatio to determine
// which attributes must be set for each entity.
account["name"] = "Fourth Coffee";

// Create an account record named Fourth Coffee.
_accountId = _service.Create(account);

Console.Write("{0} {1} created, ", account.LogicalName, account.Attributes["name"]);

// Create a column set to define which attributes should be retrieved.
ColumnSet attributes = new ColumnSet(new string[] { "name", "ownerid" });

// Retrieve the account and its name and ownerid attributes.
account = _service.Retrieve(account.LogicalName, _accountId, attributes);
Console.Write("retrieved, ");

// Update the postal code attribute.
account["address1_postalcode"] = "98052";

// The address 2 postal code was set accidentally, so set it to null.
account["address2_postalcode"] = null;

// Shows use of Money.
account["revenue"] = new Money(5000000);

// Shows use of boolean.
account["creditonhold"] = false;

// Update the account.
_service.Update(account);
Console.WriteLine("and updated.");

// Delete the account.
bool deleteRecords = true;

if (promptForDelete)
{
    Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
    String answer = Console.ReadLine();

    deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
}

if (deleteRecords)
{
    _service.Delete("account", _accountId);

    Console.WriteLine("Entity record(s) have been deleted.");
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter and access rights on the record that is specified in the id parameter. For a list of the required privileges, see Delete Privileges. When a record is deleted, all child records are also deleted. The entire deletion fails if the caller does not have the delete privilege or access rights for any of these records.
Notes for Callers
This method may cascade to related records according to the cascade configuration for each entity relationship. For a description of how actions on a parent record affect related records, see Cascading behavior.
Typically, you should only delete records that you entered by mistake. For some record types, you can deactivate or close the record instead.
You can use this method to delete any record of an entity that supports the Delete message, including records from custom entities.
For more information about the exceptions that can be thrown when you call this method, see Handle Exceptions in Your Code.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
ActivityMimeAttachment | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
AttributeMap | 2 (Both)
BulkDeleteOperation | 2 (Both)
BulkOperation | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
ColumnMapping | 2 (Both)
Competitor | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConnectionRoleObjectTypeCode | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
HierarchySecurityConfiguration | 2 (Both)
Import | 2 (Both)
ImportEntityMapping | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
LookUpMapping | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
OwnerMapping | 2 (Both)
PhoneCall | 2 (Both)
PickListMapping | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
Position | 2 (Both)
Post | 2 (Both)
PostComment | 2 (Both)
PostFollow | 2 (Both)
PostLike | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
ProcessSession | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportVisibility | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointDocument | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
Subject | 2 (Both)
SystemForm | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TraceLog | 2 (Both)
TransactionCurrency | 2 (Both)
TransformationMapping | 2 (Both)
TransformationParameterMapping | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IOrganizationService Interface
IOrganizationService Members
Microsoft.Xrm.Sdk Namespace
DeleteRequest
DeleteResponse
Other Resources
Handle Exceptions in Your Code
Troubleshooting and Error Handling
Delete


IOrganizationService.Disassociate Method
See Also Example
[image]

Deletes a link between records.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FaultContractAttribute(GetType(OrganizationServiceFault))> _
<OperationContractAttribute> _
Sub Disassociate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
[FaultContractAttribute(typeof(OrganizationServiceFault))]
[OperationContractAttribute]
void Disassociate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity that is specified in the entityId parameter.
entityId
Type: Guid. The ID of the record from which the related records are disassociated.
relationship
Type: Relationship. The name of the relationship to be used to remove the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be disassociated.
  Example
The following example demonstrates how to use the Disassociate method to remove an association or link between records (early bound).
C#    Copy Code
// Associate the accounts to the contact record.

// Create a collection of the entities that will be
// associated to the contact.
EntityReferenceCollection relatedEntities = new EntityReferenceCollection();
relatedEntities.Add(new EntityReference(Account.EntityLogicalName, _account1Id));
relatedEntities.Add(new EntityReference(Account.EntityLogicalName, _account2Id));
relatedEntities.Add(new EntityReference(Account.EntityLogicalName, _account3Id));

// Create an object that defines the relationship between the contact and account.
Relationship relationship = new Relationship("account_primary_contact");

//Associate the contact with the 3 accounts.
_service.Associate(Contact.EntityLogicalName, _contactId, relationship,
    relatedEntities);

Console.WriteLine("The entities have been associated.");

//Disassociate the records.
_service.Disassociate(Contact.EntityLogicalName, _contactId, relationship,
    relatedEntities);

The following example demonstrates how to use the Disassociate method to remove an association or link between records (late bound).
C#    Copy Code
// The account ID would typically be passed in as an argument or determined by a query.
// The contact ID would typically be passed in as an argument or determined by a query.
// Associate the accounts to the contact record.

//Create a collection of the entity ids that will be associated to the contact.
EntityReferenceCollection relatedEntities = new EntityReferenceCollection();
relatedEntities.Add(new EntityReference("account", _account1Id));
relatedEntities.Add(new EntityReference("account", _account2Id));
relatedEntities.Add(new EntityReference("account", _account3Id));

// Create an object that defines the relationship between the contact and account.
Relationship relationship = new Relationship("account_primary_contact");

//Associate the contact with the 3 accounts.
_service.Associate("contact", _contactId, relationship, relatedEntities);

Console.WriteLine("The entities have been associated.");

//Disassociate the records.
_service.Disassociate("contact", _contactId, relationship, relatedEntities);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter and access rights on the records that are specified in the entityId and relatedEntities parameters. For a list of the required privileges, see Disassociate Privileges.
Notes for Callers
This method removes multiple associations in one transaction between the record that is specified by the entityId parameter and each record in the relatedEntities parameter for the relationship that is specified in the relationship parameter.
For a one-to-many relationship, this method clears the ReferencingAttribute in the related record to the value of entityId.
For a many-to-many relationship, this method deletes a record in the intersect table for the relationship. The intersect table name is defined in the IntersectEntityName property for the relationship. You need this when you query for the records. However, you need the relationship name to set the Relationship property. This name is defined in the SchemaName property for the relationship.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities
You can use this method to disassociate any records that participate in a relationship, including records for custom entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IOrganizationService Interface
IOrganizationService Members
Microsoft.Xrm.Sdk Namespace
DisassociateRequest
DisassociateResponse
Other Resources
Sample: Associate  (Early Bound)
Entity Metadata
Customize Entity Relationship Metadata
Handle Exceptions in Your Code
Troubleshooting and Error Handling
Disassociate


IOrganizationService.Execute Method
See Also Example
[image]

Executes a message in the form of a request, and returns a response.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<OperationContractAttribute> _
<FaultContractAttribute(GetType(OrganizationServiceFault))> _
Function Execute ( _
    request As OrganizationRequest _
) As OrganizationResponse

C#
[OperationContractAttribute]
[FaultContractAttribute(typeof(OrganizationServiceFault))]
OrganizationResponse Execute (
    OrganizationRequest request
)

C++

J#

JScript

Parameters
request
Type: OrganizationRequest. A request instance that defines the action to be performed.
Return Value
Type: OrganizationResponse
The response from the request. You must cast the return value of this method to the specific instance of the response that corresponds to the Request parameter.

  Example
The following example shows how to use the Execute method to assign a queue to a team (early bound). For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\BusinessDataModel\BusinessManagement\AssignRecordToTeam.cs.
The following example shows how to use the Execute method to assign a queue to a team (late bound). For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\LateBound\AssignQueueToTeamDE.cs.
  Remarks
Privileges and Access Rights
To execute the message, the caller must have the necessary privileges to the entity type that is specified in the request class. The caller must also have access rights on the specified records in the request class. For more information, see the Request class for the action you want to execute. For example, see AssignRequest.
Notes for Callers

                        For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Method Availability
This method works regardless whether the caller is connected to the server or offline.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationService Interface
IOrganizationService Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use Messages (Request and Response Classes) with the Execute Method
The Security Model of Dynamics CRM
Privileges by Message
Privileges by Entity
Handle Exceptions in Your Code
Troubleshooting and Error Handling


IOrganizationService.Retrieve Method
See Also Example
[image]

Retrieves a record.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FaultContractAttribute(GetType(OrganizationServiceFault))> _
<OperationContractAttribute> _
Function Retrieve ( _
    entityName As String, _
    id As Guid, _
    columnSet As ColumnSet _
) As Entity

C#
[FaultContractAttribute(typeof(OrganizationServiceFault))]
[OperationContractAttribute]
Entity Retrieve (
    string entityName,
    Guid id,
    ColumnSet columnSet
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity that is specified in the entityId parameter.
id
Type: Guid. The ID of the record that you want to retrieve.
columnSet
Type: ColumnSet. A query that specifies the set of columns, or attributes, to retrieve.
Return Value
Type: Entity

The requested entity.

  Example
The following example shows how to use the Retrieve method to retrieve an account record (early bound). For this sample to work correctly, you must be connected to the server to instantiate an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\EarlyBound\CRUDOperations.cs.
C#    Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Instantiate an account object.
    // See the Entity Metadata topic in the SDK documentation to determine
    // which attributes must be set for each entity.
    Account account = new Account { Name = "Fourth Coffee" };

    // Create an account record named Fourth Coffee.
    _accountId = _serviceProxy.Create(account);
    Console.Write("{0} {1} created, ", account.LogicalName, account.Name);

    // Retrieve the account containing several of its attributes.
    ColumnSet cols = new ColumnSet(
        new String[] { "name", "address1_postalcode", "lastusedincampaign", "versionnumber" });

    Account retrievedAccount = (Account)_serviceProxy.Retrieve("account", _accountId, cols);
    Console.Write("retrieved ");

    // Retrieve version number of the account. Shows BigInt attribute usage.
    long? versionNumber = retrievedAccount.VersionNumber;

    if (versionNumber != null)
        Console.WriteLine("version # {0}, ", versionNumber);

    // Update the postal code attribute.
    retrievedAccount.Address1_PostalCode = "98052";

    // The address 2 postal code was set accidentally, so set it to null.
    retrievedAccount.Address2_PostalCode = null;

    // Shows usage of option set (picklist) enumerations defined in OptionSets.cs.
    retrievedAccount.Address1_AddressTypeCode = new OptionSetValue((int)AccountAddress1_AddressTypeCode.Primary);
    retrievedAccount.Address1_ShippingMethodCode = new OptionSetValue((int)AccountAddress1_ShippingMethodCode.DHL);
    retrievedAccount.IndustryCode = new OptionSetValue((int)AccountIndustryCode.AgricultureandNonpetrolNaturalResourceExtraction);

    // Shows use of a Money value.
    retrievedAccount.Revenue = new Money(5000000);

    // Shows use of a Boolean value.
    retrievedAccount.CreditOnHold = false;

    // Shows use of EntityReference.
    retrievedAccount.ParentAccountId = new EntityReference(Account.EntityLogicalName, _parentAccountId);

    // Shows use of Memo attribute.
    retrievedAccount.Description = "Account for Fourth Coffee.";

    // Update the account record.
    _serviceProxy.Update(retrievedAccount);
    Console.WriteLine("and updated.");

    _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
    _serviceProxy.Delete(Account.EntityLogicalName, _parentAccountId);
    Console.WriteLine("Entity records have been deleted.");
}

The following example shows how to use the Retrieve method to retrieve an account record (late bound). For this sample to work correctly, you must be connected to the server to instantiate an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\LateBound\CRUDOperationsDE.cs.
C#    Copy Code
// Instaniate an account object.
Entity account = new Entity("account");

// Set the required attributes. For account, only the name is required.
// See the Entity Metadata topic in the SDK documentatio to determine
// which attributes must be set for each entity.
account["name"] = "Fourth Coffee";

// Create an account record named Fourth Coffee.
_accountId = _service.Create(account);

Console.Write("{0} {1} created, ", account.LogicalName, account.Attributes["name"]);

// Create a column set to define which attributes should be retrieved.
ColumnSet attributes = new ColumnSet(new string[] { "name", "ownerid" });

// Retrieve the account and its name and ownerid attributes.
account = _service.Retrieve(account.LogicalName, _accountId, attributes);
Console.Write("retrieved, ");

// Update the postal code attribute.
account["address1_postalcode"] = "98052";

// The address 2 postal code was set accidentally, so set it to null.
account["address2_postalcode"] = null;

// Shows use of Money.
account["revenue"] = new Money(5000000);

// Shows use of boolean.
account["creditonhold"] = false;

// Update the account.
_service.Update(account);
Console.WriteLine("and updated.");

// Delete the account.
bool deleteRecords = true;

if (promptForDelete)
{
    Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
    String answer = Console.ReadLine();

    deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
}

if (deleteRecords)
{
    _service.Delete("account", _accountId);

    Console.WriteLine("Entity record(s) have been deleted.");
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights

                        To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter and access rights on the record that is specified in the id parameter. For a list of the required privileges, see Retrieve Privileges.
Notes for Callers
The returned record contains values for the specified properties in the columnSet parameter for which the calling user has access rights. Any other property values are not returned. For more information, see The Security Model of Microsoft Dynamics CRM.
Pass null for the columnSet parameter to retrieve only the primary key. If the columnSet includes attributes where IsValidForRead is false, they are ignored. You can find this information in the metadata for your organization. See the preceding metadata browser information.
To retrieve a record and its related records in a single transaction, use the RetrieveRequest class.
You can use this method to retrieve any record of an entity that supports the Retrieve message, including custom entities.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
ActivityMimeAttachment | 2 (Both)
ActivityPointer | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
AttributeMap | 2 (Both)
Audit | 2 (Both)
BulkDeleteFailure | 2 (Both)
BulkDeleteOperation | 2 (Both)
BulkOperation | 2 (Both)
BulkOperationLog | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
ColumnMapping | 2 (Both)
Competitor | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConnectionRoleObjectTypeCode | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Dependency | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DisplayString | 2 (Both)
DuplicateRecord | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
EntityMap | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
Import | 2 (Both)
ImportEntityMapping | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportLog | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
InvalidDependency | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
LeadAddress | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
LookUpMapping | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
Organization | 2 (Both)
OrganizationUI | 2 (Both)
OwnerMapping | 2 (Both)
PhoneCall | 2 (Both)
PickListMapping | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
PluginTypeStatistic | 2 (Both)
Position | 2 (Both)
Post | 2 (Both)
PostComment | 2 (Both)
PostFollow | 2 (Both)
PostLike | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
Privilege | 2 (Both)
ProcessSession | 2 (Both)
ProcessStage | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportLink | 2 (Both)
ReportVisibility | 2 (Both)
Resource | 2 (Both)
ResourceGroup | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessage | 2 (Both)
SdkMessageFilter | 2 (Both)
SdkMessagePair | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SdkMessageRequest | 2 (Both)
SdkMessageRequestField | 2 (Both)
SdkMessageResponse | 2 (Both)
SdkMessageResponseField | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointData | 2 (Both)
SharePointDocument | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SiteMap | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
SolutionComponent | 2 (Both)
Subject | 2 (Both)
SystemForm | 2 (Both)
SystemUser | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TimeZoneDefinition | 2 (Both)
TimeZoneLocalizedName | 2 (Both)
TimeZoneRule | 2 (Both)
TraceLog | 2 (Both)
TransactionCurrency | 2 (Both)
TransformationMapping | 2 (Both)
TransformationParameterMapping | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
UserSettings | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IOrganizationService Interface
IOrganizationService Members
Microsoft.Xrm.Sdk Namespace
RetrieveResponse
RetrieveRequest
Other Resources
Handle Exceptions in Your Code
Troubleshooting and Error Handling
Retrieve


IOrganizationService.RetrieveMultiple Method
See Also Example
[image]

Retrieves a collection of records.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<OperationContractAttribute> _
<FaultContractAttribute(GetType(OrganizationServiceFault))> _
Function RetrieveMultiple ( _
    query As QueryBase _
) As EntityCollection

C#
[OperationContractAttribute]
[FaultContractAttribute(typeof(OrganizationServiceFault))]
EntityCollection RetrieveMultiple (
    QueryBase query
)

C++

J#

JScript

Parameters
query
Type: QueryBase. A query that determines the set of records to retrieve.
Return Value
Type: EntityCollection
The collection of entities returned from the query.

  Example
The following example shows how to use the RetrieveMultiple method. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\BusinessDataModel\BusinessManagement\RetrieveOpportunity.cs.
C#    Copy Code
// Retrieve Opportunity record.
Opportunity checkOpportunity = (Opportunity)_serviceProxy.Retrieve(
    Opportunity.EntityLogicalName,
    _opportunityId,
    new ColumnSet("name"));

Console.WriteLine("Retrieved {0}", checkOpportunity.Name);

// Retrieve the related opportunity products
QueryExpression opportunityProductsQuery = new QueryExpression
{
    EntityName = OpportunityProduct.EntityLogicalName,
    ColumnSet = new ColumnSet("opportunityproductid", "volumediscountamount"),
    Criteria = new FilterExpression
    {
        Conditions =
    {
        new ConditionExpression
        {
            AttributeName = "opportunityid",
            Operator = ConditionOperator.Equal,
            Values = { _opportunityId }
        }
    }
    }
};

DataCollection<Entity> opportunityProducts = _serviceProxy.RetrieveMultiple(
    opportunityProductsQuery).Entities;

foreach (Entity entity in opportunityProducts)
{
    OpportunityProduct opportunityProduct = (OpportunityProduct)entity;
    Console.WriteLine("Retrieved Opportunity Product {0}",
        opportunityProduct.OpportunityProductId.Value);
}

The following example shows how to use the RetrieveMultiple method. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\BusinessDataModel\Templates\GetEmailTemplateAttachments.cs.
C#    Copy Code

//Create a query to retrieve attachments.
QueryExpression query = new QueryExpression
{
    EntityName = ActivityMimeAttachment.EntityLogicalName,
    ColumnSet = new ColumnSet("filename"),

    //Define the conditions for each attachment.
    Criteria =
    {
        FilterOperator = LogicalOperator.And,
        Conditions =
    {
        //The ObjectTypeCode must be specified, or else the query
        //defaults to "email" instead of "template".
        new ConditionExpression
        {
            AttributeName = "objecttypecode",
            Operator = ConditionOperator.Equal,
            Values = {Template.EntityTypeCode}
        },
        //Specify which template we need.
        new ConditionExpression
        {
            AttributeName = "objectid",
            Operator = ConditionOperator.Equal,
            Values = {_emailTemplateId}
        }
    }
    }
};

//Write out the filename of each attachment retrieved.
foreach (ActivityMimeAttachment attachment in _serviceProxy.RetrieveMultiple(query).Entities)
{
    Console.WriteLine("Retrieved attachment {0}", attachment.FileName);
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter. For a list of the required privileges, see RetrieveMultiple Privileges. This method only returns the records for which the calling user has access rights.
Notes for Callers
The collection of returned records contains the values for the properties that are specified in the ColumnSet parameter for which the calling user has access rights. Any other property values are not returned.
Pass null for the columnSet parameter to retrieve only the primary key. If the columnSet includes attributes that are not valid for retrieval, they are ignored. This is where IsValidForRead is false. You can find this information in the metadata for your organization. See the preceding metadata browser information.
You can use this method to retrieve records of an entity that supports the RetrieveMultiple message, including records from custom entities.

                        For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
AccountLeads | 2 (Both)
ActivityMimeAttachment | 2 (Both)
ActivityParty | 2 (Both)
ActivityPointer | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
AttributeMap | 2 (Both)
Audit | 2 (Both)
BulkDeleteFailure | 2 (Both)
BulkDeleteOperation | 2 (Both)
BulkOperation | 2 (Both)
BulkOperationLog | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignActivityItem | 2 (Both)
CampaignItem | 2 (Both)
CampaignResponse | 2 (Both)
ColumnMapping | 2 (Both)
Competitor | 2 (Both)
CompetitorProduct | 2 (Both)
CompetitorSalesLiterature | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConnectionRoleAssociation | 2 (Both)
ConnectionRoleObjectTypeCode | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
ContactInvoices | 2 (Both)
ContactLeads | 2 (Both)
ContactOrders | 2 (Both)
ContactQuotes | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Dependency | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DisplayString | 2 (Both)
DuplicateRecord | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementContacts | 2 (Both)
EntitlementProducts | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
EntitlementTemplateProducts | 2 (Both)
EntityMap | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
HierarchySecurityConfiguration | 2 (Both)
Import | 2 (Both)
ImportEntityMapping | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportLog | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
InvalidDependency | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
LeadAddress | 2 (Both)
LeadCompetitors | 2 (Both)
LeadProduct | 2 (Both)
Letter | 2 (Both)
License | 2 (Both)
List | 2 (Both)
ListMember | 2 (Both)
LookUpMapping | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityCompetitors | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
Organization | 2 (Both)
OrganizationUI | 2 (Both)
OwnerMapping | 2 (Both)
PhoneCall | 2 (Both)
PickListMapping | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
PluginTypeStatistic | 2 (Both)
Position | 2 (Both)
Post | 2 (Both)
PostComment | 2 (Both)
PostFollow | 2 (Both)
PostLike | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
Privilege | 2 (Both)
ProcessSession | 2 (Both)
ProcessStage | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSalesLiterature | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
QueueMembership | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportLink | 2 (Both)
ReportVisibility | 2 (Both)
Resource | 2 (Both)
ResourceGroup | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RolePrivileges | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessage | 2 (Both)
SdkMessageFilter | 2 (Both)
SdkMessagePair | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SdkMessageRequest | 2 (Both)
SdkMessageRequestField | 2 (Both)
SdkMessageResponse | 2 (Both)
SdkMessageResponseField | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceContractContacts | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointData | 2 (Both)
SharePointDocument | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SiteMap | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
SolutionComponent | 2 (Both)
Subject | 2 (Both)
SubscriptionTrackingDeletedObject | 2 (Both)
SystemForm | 2 (Both)
SystemUser | 2 (Both)
SystemUserLicenses | 2 (Both)
SystemUserProfiles | 2 (Both)
SystemUserRoles | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamMembership | 2 (Both)
TeamProfiles | 2 (Both)
TeamRoles | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TimeZoneDefinition | 2 (Both)
TimeZoneLocalizedName | 2 (Both)
TimeZoneRule | 2 (Both)
TraceLog | 2 (Both)
TransactionCurrency | 2 (Both)
TransformationMapping | 2 (Both)
TransformationParameterMapping | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
UserSettings | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IOrganizationService Interface
IOrganizationService Members
Microsoft.Xrm.Sdk Namespace
RetrieveMultipleRequest
RetrieveMultipleResponse
Other Resources
Creating Queries to Retrieve Data
How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM
Handle Exceptions in Your Code
Troubleshooting and Error Handling
Retrieve Multiple


IOrganizationService.Update Method
See Also Example
[image]

Updates an existing record.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<OperationContractAttribute> _
<FaultContractAttribute(GetType(OrganizationServiceFault))> _
Sub Update ( _
    entity As Entity _
)

C#
[OperationContractAttribute]
[FaultContractAttribute(typeof(OrganizationServiceFault))]
void Update (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that has one or more properties set to be updated in the record.
  Example
The following example shows how to use the Update method to update an account record (early bound). For this sample to work correctly, you must be connected to the server to instantiate an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\EarlyBound\CRUDOperations.cs.
C#    Copy Code
// Connect to the Organization service.
// The using statement assures that the service proxy will be properly disposed.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // This statement is required to enable early-bound type support.
    _serviceProxy.EnableProxyTypes();

    CreateRequiredRecords();

    // Instantiate an account object.
    // See the Entity Metadata topic in the SDK documentation to determine
    // which attributes must be set for each entity.
    Account account = new Account { Name = "Fourth Coffee" };

    // Create an account record named Fourth Coffee.
    _accountId = _serviceProxy.Create(account);
    Console.Write("{0} {1} created, ", account.LogicalName, account.Name);

    // Retrieve the account containing several of its attributes.
    ColumnSet cols = new ColumnSet(
        new String[] { "name", "address1_postalcode", "lastusedincampaign", "versionnumber" });

    Account retrievedAccount = (Account)_serviceProxy.Retrieve("account", _accountId, cols);
    Console.Write("retrieved ");

    // Retrieve version number of the account. Shows BigInt attribute usage.
    long? versionNumber = retrievedAccount.VersionNumber;

    if (versionNumber != null)
        Console.WriteLine("version # {0}, ", versionNumber);

    // Update the postal code attribute.
    retrievedAccount.Address1_PostalCode = "98052";

    // The address 2 postal code was set accidentally, so set it to null.
    retrievedAccount.Address2_PostalCode = null;

    // Shows usage of option set (picklist) enumerations defined in OptionSets.cs.
    retrievedAccount.Address1_AddressTypeCode = new OptionSetValue((int)AccountAddress1_AddressTypeCode.Primary);
    retrievedAccount.Address1_ShippingMethodCode = new OptionSetValue((int)AccountAddress1_ShippingMethodCode.DHL);
    retrievedAccount.IndustryCode = new OptionSetValue((int)AccountIndustryCode.AgricultureandNonpetrolNaturalResourceExtraction);

    // Shows use of a Money value.
    retrievedAccount.Revenue = new Money(5000000);

    // Shows use of a Boolean value.
    retrievedAccount.CreditOnHold = false;

    // Shows use of EntityReference.
    retrievedAccount.ParentAccountId = new EntityReference(Account.EntityLogicalName, _parentAccountId);

    // Shows use of Memo attribute.
    retrievedAccount.Description = "Account for Fourth Coffee.";

    // Update the account record.
    _serviceProxy.Update(retrievedAccount);
    Console.WriteLine("and updated.");

    _serviceProxy.Delete(Account.EntityLogicalName, _accountId);
    _serviceProxy.Delete(Account.EntityLogicalName, _parentAccountId);
    Console.WriteLine("Entity records have been deleted.");
}

The following example shows how to use the Update method to update an account record (late bound). For this sample to work correctly, you must be connected to the server to instantiate an IOrganizationService interface. You can find the complete sample in the sample code package in the folder SampleCode\CS\GeneralProgramming\LateBound\CRUDOperationsDE.cs.
C#    Copy Code
// Instaniate an account object.
Entity account = new Entity("account");

// Set the required attributes. For account, only the name is required.
// See the Entity Metadata topic in the SDK documentatio to determine
// which attributes must be set for each entity.
account["name"] = "Fourth Coffee";

// Create an account record named Fourth Coffee.
_accountId = _service.Create(account);

Console.Write("{0} {1} created, ", account.LogicalName, account.Attributes["name"]);

// Create a column set to define which attributes should be retrieved.
ColumnSet attributes = new ColumnSet(new string[] { "name", "ownerid" });

// Retrieve the account and its name and ownerid attributes.
account = _service.Retrieve(account.LogicalName, _accountId, attributes);
Console.Write("retrieved, ");

// Update the postal code attribute.
account["address1_postalcode"] = "98052";

// The address 2 postal code was set accidentally, so set it to null.
account["address2_postalcode"] = null;

// Shows use of Money.
account["revenue"] = new Money(5000000);

// Shows use of boolean.
account["creditonhold"] = false;

// Update the account.
_service.Update(account);
Console.WriteLine("and updated.");

// Delete the account.
bool deleteRecords = true;

if (promptForDelete)
{
    Console.WriteLine("\nDo you want these entity records deleted? (y/n) [y]: ");
    String answer = Console.ReadLine();

    deleteRecords = (answer.StartsWith("y") || answer.StartsWith("Y") || answer == String.Empty);
}

if (deleteRecords)
{
    _service.Delete("account", _accountId);

    Console.WriteLine("Entity record(s) have been deleted.");
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity and access rights on the record specified in the Update parameter.. For a list of the required privileges, see Update Privileges.
Notes for Callers
If the entity instance includes properties that are not valid for update, they are ignored. You can find this information in the metadata for your organization. See the preceding metadata browser information.
You can use this method to update any record of an entity that supports the Update message, including custom entities.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
ActivityMimeAttachment | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
Competitor | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DisplayString | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
Import | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
Organization | 2 (Both)
OrganizationUI | 2 (Both)
PhoneCall | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
Position | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
ProcessSession | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportVisibility | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointData | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SiteMap | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
Subject | 2 (Both)
SystemForm | 2 (Both)
SystemUser | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TransactionCurrency | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
UserSettings | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IOrganizationService Interface
IOrganizationService Members
Microsoft.Xrm.Sdk Namespace
UpdateRequest
UpdateResponse
Other Resources
Handle Exceptions in Your Code
Troubleshooting and Error Handling
Update


IOrganizationServiceFactory Interface
See Also Members
[image]

Represents a factory for creating IOrganizationService instances.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IOrganizationServiceFactory

C#
public interface IOrganizationServiceFactory

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceFactory Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Exploring the Factory Design Pattern


IOrganizationServiceFactory Members
See Also Methods
[image]

Represents a factory for creating IOrganizationService instances.

The following tables list the members exposed by the IOrganizationServiceFactory type.

Public Methods

 | Name | Description
public method | CreateOrganizationService | Returns an IOrganizationService instance for the organization that the specified user is a member of.
Top

See Also

Reference

IOrganizationServiceFactory Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Exploring the Factory Design Pattern


IOrganizationServiceFactory Methods
[image]

Public Methods

 | Name | Description
public method | CreateOrganizationService | Returns an IOrganizationService instance for the organization that the specified user is a member of.

See Also

Reference

IOrganizationServiceFactory Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Exploring the Factory Design Pattern


IOrganizationServiceFactory.CreateOrganizationService Method
[image]

Returns an IOrganizationService instance for the organization that the specified user is a member of.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function CreateOrganizationService ( _
    userId As Nullable(Of Guid) _
) As IOrganizationService

C#
IOrganizationService CreateOrganizationService (
    Nullable<Guid> userId
)

C++

J#

JScript

Parameters
userId
Type: Nullable<Guid>. Specifies the system user that calls to the service are made for.  A null value indicates the SYSTEM user. When called in a plug-in, a Guid.Empty value indicates the same user as IPluginExecutionContext. UserId. When called in a custom workflow activity, a  Guid.Empty value indicates the same user as IWorkflowExecutionContext.UserId. Any other value indicates a specific system user.
Return Value
Type: IOrganizationService
An organization service factory object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceFactory Interface
IOrganizationServiceFactory Members
Microsoft.Xrm.Sdk Namespace


IPlugin Interface
See Also Members
[image]

Base interface for a plug-in.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IPlugin

C#
public interface IPlugin

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IPlugin Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Write a Plug-in
Plug-ins for Extending Microsoft Dynamics CRM


IPlugin Members
See Also Methods
[image]

Base interface for a plug-in.

The following tables list the members exposed by the IPlugin type.

Public Methods

 | Name | Description
public method | Execute | Executes plug-in code in response to an event.
Top

See Also

Reference

IPlugin Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Write a Plug-in
Plug-ins for Extending Microsoft Dynamics CRM


IPlugin Methods
[image]

Public Methods

 | Name | Description
public method | Execute | Executes plug-in code in response to an event.

See Also

Reference

IPlugin Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Write a Plug-in
Plug-ins for Extending Microsoft Dynamics CRM


IPlugin.Execute Method
[image]

Executes plug-in code in response to an event.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Sub Execute ( _
    serviceProvider As IServiceProvider _
)

C#
void Execute (
    IServiceProvider serviceProvider
)

C++

J#

JScript

Parameters
serviceProvider
Type: IService_Provider. A container for service objects. Contains references to the plug-in execution context (IPluginExecutionContext), tracing service (ITracingService), organization service (IOrganizationServiceFactory), and notification service (IServiceEndpointNotificationService).
  Remarks
Called by the event execution pipeline during processing of a message request for which the plug-in was registered. For more information, see the IServiceProvider Interface. The notification service is only provided for asynchronous registered plug-ins.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IPlugin Interface
IPlugin Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Write a Plug-in
Event Execution Pipeline
Plug-ins for Extending Microsoft Dynamics CRM


IPluginExecutionContext Interface
See Also Members
[image]

Defines the contextual information passed to a plug-in at run-time. Contains information that describes the run-time environment that the plug-in is executing in, information related to the execution pipeline, and entity business information.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IPluginExecutionContext
    Inherits IExecutionContext

C#
public interface IPluginExecutionContext : IExecutionContext

C++

J#

JScript

  Remarks
The execution context is passed to a plug-in at run time in the System.IServiceProvider parameter of the Execute method. You can obtain the context from the service provider as shown in the following plug-in code.
C#    Copy Code
// Obtain the execution context from the service provider.
IPluginExecutionContext context = (IPluginExecutionContext)
    serviceProvider.GetService(typeof(IPluginExecutionContext));

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IPluginExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Understand the Data Context Passed to a Plug-in
Plug-ins for Extending Microsoft Dynamics CRM


IPluginExecutionContext Members
See Also Properties
[image]

Defines the contextual information passed to a plug-in at run-time. Contains information that describes the run-time environment that the plug-in is executing in, information related to the execution pipeline, and entity business information.

The following tables list the members exposed by the IPluginExecutionContext type.

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the GUIDGUID of the business unit that the user making the request, also known as the calling user, belongs to. (inherited from IExecutionContext)
public property | CorrelationId | Gets the GUID for tracking plug-in or custom workflow activity execution. (inherited from IExecutionContext)
public property | Depth | Gets the current depth of execution in the call stack. (inherited from IExecutionContext)
public property | InitiatingUserId | Gets the GUID of the system user account under which the current pipeline is executing. (inherited from IExecutionContext)
public property | InputParameters | Gets the parameters of the request message that triggered the event that caused the plug-in to execute. (inherited from IExecutionContext)
public property | IsExecutingOffline | Gets whether the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline. (inherited from IExecutionContext)
public property | IsInTransaction | Gets a value indicating if the plug-in is executing within the database transaction. (inherited from IExecutionContext)
public property | IsOfflinePlayback | Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server. (inherited from IExecutionContext)
public property | IsolationMode | Gets a value indicating if the plug-in is executing in the sandbox. (inherited from IExecutionContext)
public property | MessageName | Gets the name of the Web service message that is being processed by the event execution pipeline. (inherited from IExecutionContext)
public property | Mode | Gets the mode of plug-in execution. (inherited from IExecutionContext)
public property | OperationCreatedOn | Gets the date and time that the related System Job was created. (inherited from IExecutionContext)
public property | OperationId | Gets the GUID of the related System Job. (inherited from IExecutionContext)
public property | OrganizationId | Gets the GUID of the organization that the entity belongs to and the plug-in executes under. (inherited from IExecutionContext)
public property | OrganizationName | Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under. (inherited from IExecutionContext)
public property | OutputParameters | Gets the parameters of the response message after the core platform operation has completed. (inherited from IExecutionContext)
public property | OwningExtension | Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint. (inherited from IExecutionContext)
public property | ParentContext | Gets the execution context from the parent pipeline operation.
public property | PostEntityImages | Gets the properties of the primary entity after the core platform operation has been completed. (inherited from IExecutionContext)
public property | PreEntityImages | Gets the properties of the primary entity before the core platform operation has begins. (inherited from IExecutionContext)
public property | PrimaryEntityId | Gets the GUID of the primary entity for which the pipeline is processing events. (inherited from IExecutionContext)
public property | PrimaryEntityName | Gets the name of the primary entity for which the pipeline is processing events. (inherited from IExecutionContext)
public property | RequestId | Gets the GUID of the request being processed by the event execution pipeline. (inherited from IExecutionContext)
public property | SecondaryEntityName | Gets the name of the secondary entity that has a relationship with the primary entity. (inherited from IExecutionContext)
public property | SharedVariables | Gets the custom properties that are shared between plug-ins. (inherited from IExecutionContext)
public property | Stage | Gets the stage in the execution pipeline that a synchronous plug-in is registered for.
public property | UserId | Gets the GUID of the system user for whom the plug-in invokes web service methods on behalf of. (inherited from IExecutionContext)
Top

See Also

Reference

IPluginExecutionContext Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Understand the Data Context Passed to a Plug-in
Plug-ins for Extending Microsoft Dynamics CRM


IPluginExecutionContext Properties
[image]

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the GUIDGUID of the business unit that the user making the request, also known as the calling user, belongs to. (inherited from IExecutionContext)
public property | CorrelationId | Gets the GUID for tracking plug-in or custom workflow activity execution. (inherited from IExecutionContext)
public property | Depth | Gets the current depth of execution in the call stack. (inherited from IExecutionContext)
public property | InitiatingUserId | Gets the GUID of the system user account under which the current pipeline is executing. (inherited from IExecutionContext)
public property | InputParameters | Gets the parameters of the request message that triggered the event that caused the plug-in to execute. (inherited from IExecutionContext)
public property | IsExecutingOffline | Gets whether the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline. (inherited from IExecutionContext)
public property | IsInTransaction | Gets a value indicating if the plug-in is executing within the database transaction. (inherited from IExecutionContext)
public property | IsOfflinePlayback | Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server. (inherited from IExecutionContext)
public property | IsolationMode | Gets a value indicating if the plug-in is executing in the sandbox. (inherited from IExecutionContext)
public property | MessageName | Gets the name of the Web service message that is being processed by the event execution pipeline. (inherited from IExecutionContext)
public property | Mode | Gets the mode of plug-in execution. (inherited from IExecutionContext)
public property | OperationCreatedOn | Gets the date and time that the related System Job was created. (inherited from IExecutionContext)
public property | OperationId | Gets the GUID of the related System Job. (inherited from IExecutionContext)
public property | OrganizationId | Gets the GUID of the organization that the entity belongs to and the plug-in executes under. (inherited from IExecutionContext)
public property | OrganizationName | Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under. (inherited from IExecutionContext)
public property | OutputParameters | Gets the parameters of the response message after the core platform operation has completed. (inherited from IExecutionContext)
public property | OwningExtension | Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint. (inherited from IExecutionContext)
public property | ParentContext | Gets the execution context from the parent pipeline operation.
public property | PostEntityImages | Gets the properties of the primary entity after the core platform operation has been completed. (inherited from IExecutionContext)
public property | PreEntityImages | Gets the properties of the primary entity before the core platform operation has begins. (inherited from IExecutionContext)
public property | PrimaryEntityId | Gets the GUID of the primary entity for which the pipeline is processing events. (inherited from IExecutionContext)
public property | PrimaryEntityName | Gets the name of the primary entity for which the pipeline is processing events. (inherited from IExecutionContext)
public property | RequestId | Gets the GUID of the request being processed by the event execution pipeline. (inherited from IExecutionContext)
public property | SecondaryEntityName | Gets the name of the secondary entity that has a relationship with the primary entity. (inherited from IExecutionContext)
public property | SharedVariables | Gets the custom properties that are shared between plug-ins. (inherited from IExecutionContext)
public property | Stage | Gets the stage in the execution pipeline that a synchronous plug-in is registered for.
public property | UserId | Gets the GUID of the system user for whom the plug-in invokes web service methods on behalf of. (inherited from IExecutionContext)

See Also

Reference

IPluginExecutionContext Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Understand the Data Context Passed to a Plug-in
Plug-ins for Extending Microsoft Dynamics CRM


IPluginExecutionContext.ParentContext Property
[image]

Gets the execution context from the parent pipeline operation.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property ParentContext As IPluginExecutionContext

C#
IPluginExecutionContext ParentContext { get; }

C++

J#

JScript

Property Value
Type: IPluginExecutionContext
The execution context from the parent pipeline operation.

  Remarks
This property may be populated for a plug-in registered in stage 20 or 40 when a Create, Update, Delete, or RetrieveExchangeRate request is processed by the execution pipeline.
Certain message requests require the platform to internally generate another message request, and hence another execution pipeline, to complete processing of the original request. For example, pipeline execution of the AssignRequest results in the internal generation of an UpdateRequest. Any plug-in registered in stage 20 or 40 for an update request will have the ParentContext property set to the execution context of the original assign request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IPluginExecutionContext Interface
IPluginExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Event Execution Pipeline
Pass Data Between Plug-ins


IPluginExecutionContext.Stage Property
[image]

Gets the stage in the execution pipeline that a synchronous plug-in is registered for.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property Stage As Integer

C#
int Stage { get; }

C++

J#

JScript

Property Value
Type: Int32.
 Valid values are 10 (pre-validation), 20 (pre-operation), 40 (post-operation), and 50 (post-operation, deprecated).

  Remarks
A stage identifies when a registered synchronous plug-in is to execute during the processing of a message request. Plug-ins can be further ordered within a stage using the SdkMessageProcessingStep.Rank attribute.
An enumeration named SdkMessageProcessingStepStage that defines the supported range of values for this property is available by including the file SampleCode\CS\HelperCode\OptionSets.cs or SampleCode\VB\HelperCode\OptionSets.vb in your project.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IPluginExecutionContext Interface
IPluginExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Plug-in Registration Entities
Event Execution Pipeline


IProxyTypesAssemblyProvider Interface
See Also Members
[image]

Provides the early-bound entity types assembly that was created using the CrmSvcUtil utility.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IProxyTypesAssemblyProvider

C#
public interface IProxyTypesAssemblyProvider

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IProxyTypesAssemblyProvider Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


IProxyTypesAssemblyProvider Members
See Also Properties
[image]

Provides the early-bound entity types assembly that was created using the CrmSvcUtil utility.

The following tables list the members exposed by the IProxyTypesAssemblyProvider type.

Public Properties

 | Name | Description
public property | ProxyTypesAssembly | Gets or sets the assembly that contains the early-bound entity types.
Top

See Also

Reference

IProxyTypesAssemblyProvider Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


IProxyTypesAssemblyProvider Properties
[image]

Public Properties

 | Name | Description
public property | ProxyTypesAssembly | Gets or sets the assembly that contains the early-bound entity types.

See Also

Reference

IProxyTypesAssemblyProvider Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


IProxyTypesAssemblyProvider.ProxyTypesAssembly Property
[image]

Gets or sets the assembly that contains the early-bound entity types.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Property ProxyTypesAssembly As Assembly

C#
Assembly ProxyTypesAssembly { get; set; }

C++

J#

JScript

Property Value
Type: Assembly
The assembly.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IProxyTypesAssemblyProvider Interface
IProxyTypesAssemblyProvider Members
Microsoft.Xrm.Sdk Namespace


IServiceEndpointNotificationService Interface
See Also Members
[image]

Posts the plug-in execution context to the Microsoft Azure Service Bus.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IServiceEndpointNotificationService

C#
public interface IServiceEndpointNotificationService

C++

J#

JScript

  Remarks
Both the Microsoft Azure Service Bus and Microsoft Dynamics CRM must be properly configured before using this service.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceEndpointNotificationService Members
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext
Other Resources
Configure Windows Azure Integration with Microsoft Dynamics CRM
Write a Custom Azure-aware Plug-in


IServiceEndpointNotificationService Members
See Also Methods
[image]

Posts the plug-in execution context to the Microsoft Azure Service Bus.

The following tables list the members exposed by the IServiceEndpointNotificationService type.

Public Methods

 | Name | Description
public method | Execute | Posts the execution context to the specified service endpoint in the cloud.
Top

See Also

Reference

IServiceEndpointNotificationService Interface
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext

Other Resources

Configure Windows Azure Integration with Microsoft Dynamics CRM
Write a Custom Azure-aware Plug-in


IServiceEndpointNotificationService Methods
[image]

Public Methods

 | Name | Description
public method | Execute | Posts the execution context to the specified service endpoint in the cloud.

See Also

Reference

IServiceEndpointNotificationService Interface
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext

Other Resources

Configure Windows Azure Integration with Microsoft Dynamics CRM
Write a Custom Azure-aware Plug-in


IServiceEndpointNotificationService.Execute Method
[image]

Posts the execution context to the specified service endpoint in the cloud.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function Execute ( _
    serviceEndpoint As EntityReference, _
    context As IExecutionContext _
) As String

C#
string Execute (
    EntityReference serviceEndpoint,
    IExecutionContext context
)

C++

J#

JScript

Parameters
serviceEndpoint
Type: EntityReference. The service endpoint to post to in the cloud.
context
Type: IExecutionContext. The event execution context.
Return Value
Type: String
The result. Only a two-way or REST listener will return a string back to the caller.

  Remarks
If the post fails, the IServiceEndpointNotificationService will continue to attempt the post for a pre-defined length of time. After all attempts to post have failed, the related asynchronous operation (system job) will be set to an error status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceEndpointNotificationService Interface
IServiceEndpointNotificationService Members
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext
Other Resources
Management and Notification of Run-time Errors
Write a One-way, Two-way, or REST Listener


IServiceEndpointPlugin Interface
See Also Members
[image]

Defines a plug-in that implements the service behavior of a Microsoft Azure Service Bus listener.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<ServiceContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Interface IServiceEndpointPlugin

C#
[ServiceContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public interface IServiceEndpointPlugin

C++

J#

JScript

  Remarks
This interface implements a one-way listener contract.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceEndpointPlugin Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Write a Listener for a Windows Azure Solution


IServiceEndpointPlugin Members
See Also Methods
[image]

Defines a plug-in that implements the service behavior of a Microsoft Azure Service Bus listener.

The following tables list the members exposed by the IServiceEndpointPlugin type.

Public Methods

 | Name | Description
public method | Execute | Executes plug-in code in response to an event.
Top

See Also

Reference

IServiceEndpointPlugin Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Write a Listener for a Windows Azure Solution


IServiceEndpointPlugin Methods
[image]

Public Methods

 | Name | Description
public method | Execute | Executes plug-in code in response to an event.

See Also

Reference

IServiceEndpointPlugin Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Write a Listener for a Windows Azure Solution


IServiceEndpointPlugin.Execute Method
[image]

Executes plug-in code in response to an event.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<OperationContractAttribute(IsOneWay:=True)> _
Sub Execute ( _
    executionContext As RemoteExecutionContext _
)

C#
[OperationContractAttribute(IsOneWay=true)]
void Execute (
    RemoteExecutionContext executionContext
)

C++

J#

JScript

Parameters
executionContext
Type: RemoteExecutionContext. Defines the contextual information passed to a plug-in at run-time.
  Remarks
The execution context is posted on the Microsoft Azure Service Bus by Microsoft Dynamics CRM and made available to the listener in the execution context parameter.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceEndpointPlugin Interface
IServiceEndpointPlugin Members
Microsoft.Xrm.Sdk Namespace


ITracingService Interface
See Also Members
[image]

Provides a method of logging run-time trace information for plug-ins.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface ITracingService

C#
public interface ITracingService

C++

J#

JScript

  Remarks
A reference to a tracing service implementation can be obtained from the service provider passed to plug-in’s Execute method.
The ITracingService interface provides a way to log plug-in run-time information.  This method of logging information is especially useful for sandboxed plug-ins registered with Microsoft Dynamics CRM Online that cannot otherwise be debugged using a debugger.
The tracing information is displayed in a dialog of the Microsoft Dynamics CRM Web application only if an exception is passed from a plug-in back to the platform.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ITracingService Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Debug a Plug-in
Sample: Web Access from a Sandboxed Plug-in
Plug-in Isolation, Trust, and Statistics


ITracingService Members
See Also Methods
[image]

Provides a method of logging run-time trace information for plug-ins.

The following tables list the members exposed by the ITracingService type.

Public Methods

 | Name | Description
public method | Trace | Logs trace information.
Top

See Also

Reference

ITracingService Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Debug a Plug-in
Sample: Web Access from a Sandboxed Plug-in
Plug-in Isolation, Trust, and Statistics


ITracingService Methods
[image]

Public Methods

 | Name | Description
public method | Trace | Logs trace information.

See Also

Reference

ITracingService Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Debug a Plug-in
Sample: Web Access from a Sandboxed Plug-in
Plug-in Isolation, Trust, and Statistics


ITracingService.Trace Method
[image]

Logs trace information.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Sub Trace ( _
    format As String, _
    ParamArray args As Object() _
)

C#
void Trace (
    string format,
    params Object[] args
)

C++

J#

JScript

Parameters
format
Type: String. Information to be logged.
args
Type: Object[]. Not documented at this time.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ITracingService Interface
ITracingService Members
Microsoft.Xrm.Sdk Namespace


ITwoWayServiceEndpointPlugin Interface
See Also Members
[image]

Defines a plug-in that implements the service behavior of a Microsoft Azure Service Bus listener.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<ServiceContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Interface ITwoWayServiceEndpointPlugin

C#
[ServiceContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public interface ITwoWayServiceEndpointPlugin

C++

J#

JScript

  Remarks
This interface implements a two-way listener contract.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ITwoWayServiceEndpointPlugin Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Write a Listener for a Windows Azure Solution


ITwoWayServiceEndpointPlugin Members
See Also Methods
[image]

Defines a plug-in that implements the service behavior of a Microsoft Azure Service Bus listener.

The following tables list the members exposed by the ITwoWayServiceEndpointPlugin type.

Public Methods

 | Name | Description
public method | Execute | Executes plug-in code in response to an event.
Top

See Also

Reference

ITwoWayServiceEndpointPlugin Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Write a Listener for a Windows Azure Solution


ITwoWayServiceEndpointPlugin Methods
[image]

Public Methods

 | Name | Description
public method | Execute | Executes plug-in code in response to an event.

See Also

Reference

ITwoWayServiceEndpointPlugin Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Write a Listener for a Windows Azure Solution


ITwoWayServiceEndpointPlugin.Execute Method
[image]

Executes plug-in code in response to an event.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FaultContractAttribute(GetType(ServiceEndpointFault))> _
<OperationContractAttribute> _
Function Execute ( _
    executionContext As RemoteExecutionContext _
) As String

C#
[FaultContractAttribute(typeof(ServiceEndpointFault))]
[OperationContractAttribute]
string Execute (
    RemoteExecutionContext executionContext
)

C++

J#

JScript

Parameters
executionContext
Type: RemoteExecutionContext. Defines the contextual information passed to a plug-in at run-time.
Return Value
Type: String
 The response from the request.

  Remarks
The return value is sent back to Microsoft Dynamics CRM over the service bus and received by the plug-in that initiated the original service bus post.
The execution context is posted on the Microsoft Azure Service Bus by Microsoft Dynamics CRM and made available to the listener in the execution context parameter.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ITwoWayServiceEndpointPlugin Interface
ITwoWayServiceEndpointPlugin Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Introduction to Windows Azure Integration with Microsoft Dynamics CRM


IWebHttpServiceEndpointPlugin Interface
See Also Members
[image]

Defines a plug-in that implements the service behavior of a Microsoft Azure Service Bus listener.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<ServiceContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Interface IWebHttpServiceEndpointPlugin

C#
[ServiceContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public interface IWebHttpServiceEndpointPlugin

C++

J#

JScript

  Remarks
This interface implements a REST listener contract.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWebHttpServiceEndpointPlugin Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Write a Listener for a Windows Azure Solution


IWebHttpServiceEndpointPlugin Members
See Also Methods
[image]

Defines a plug-in that implements the service behavior of a Microsoft Azure Service Bus listener.

The following tables list the members exposed by the IWebHttpServiceEndpointPlugin type.

Public Methods

 | Name | Description
public method | Execute | Executes plug-in code in response to an event.
Top

See Also

Reference

IWebHttpServiceEndpointPlugin Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Write a Listener for a Windows Azure Solution


IWebHttpServiceEndpointPlugin Methods
[image]

Public Methods

 | Name | Description
public method | Execute | Executes plug-in code in response to an event.

See Also

Reference

IWebHttpServiceEndpointPlugin Interface
Microsoft.Xrm.Sdk Namespace

Other Resources

Write a Listener for a Windows Azure Solution


IWebHttpServiceEndpointPlugin.Execute Method
[image]

Executes plug-in code in response to an event.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<WebInvokeAttribute(Method:="POST")> _
<FaultContractAttribute(GetType(ServiceEndpointFault))> _
<OperationContractAttribute> _
Function Execute ( _
    executionContext As RemoteExecutionContext _
) As String

C#
[WebInvokeAttribute(Method="POST")]
[FaultContractAttribute(typeof(ServiceEndpointFault))]
[OperationContractAttribute]
string Execute (
    RemoteExecutionContext executionContext
)

C++

J#

JScript

Parameters
executionContext
Type: RemoteExecutionContext. Defines the contextual information passed to a plug-in at run-time.
Return Value
Type: String
 The response from the request.

  Remarks
The return value is sent back to Microsoft Dynamics CRM over the service bus and received by the plug-in that initiated the original service bus post.
The execution context is posted on the Microsoft Azure Service Bus by Microsoft Dynamics CRM and made available to the listener in the execution context parameter.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWebHttpServiceEndpointPlugin Interface
IWebHttpServiceEndpointPlugin Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Introduction to Windows Azure Integration with Microsoft Dynamics CRM


KnownTypesResolver Class
See Also Members
[image]

Resolves known organization message request and response types for the SDK contracts.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class KnownTypesResolver
    Inherits DataContractResolver

C#
public sealed class KnownTypesResolver : DataContractResolver

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Runtime.Serialization.DataContractResolver
    Microsoft.Xrm.Sdk.KnownTypesResolver
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KnownTypesResolver Members
Microsoft.Xrm.Sdk Namespace


KnownTypesResolver Members
See Also Constructors Methods
[image]

Resolves known organization message request and response types for the SDK contracts.

The following tables list the members exposed by the KnownTypesResolver type.

Public Constructors

Name | Description
KnownTypesResolver | Initializes a new instance of the KnownTypesResolver class.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ResolveName | Overridden. Enables users to map a xsi:type name to any type.
public method | ToString | (inherited from Object)
public method | TryResolveType | Overridden. Maps any type to a new xsi:type representation.
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

KnownTypesResolver Class
Microsoft.Xrm.Sdk Namespace


KnownTypesResolver Constructor
[image]

Initializes a new instance of the KnownTypesResolver class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public KnownTypesResolver ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KnownTypesResolver Class
KnownTypesResolver Members
Microsoft.Xrm.Sdk Namespace


KnownTypesResolver Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ResolveName | Overridden. Enables users to map a xsi:type name to any type.
public method | ToString | (inherited from Object)
public method | TryResolveType | Overridden. Maps any type to a new xsi:type representation.

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

KnownTypesResolver Class
Microsoft.Xrm.Sdk Namespace


KnownTypesResolver.ResolveName Method
[image]

Enables users to map a xsi:type name to any type.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function ResolveName ( _
    typeName As String, _
    typeNamespace As String, _
    declaredType As Type, _
    knownTypeResolver As DataContractResolver _
) As Type

C#
public override Type ResolveName (
    string typeName,
    string typeNamespace,
    Type declaredType,
    DataContractResolver knownTypeResolver
)

C++

J#

JScript

Parameters
typeName
String. The xsi:type name to map.
typeNamespace
String. The xsi:type namespace to map.
declaredType
Type. The type declared in the data contract.
knownTypeResolver
System.Runtime.Serialization.DataContractResolver. The known type resolver.
Return Value
Type: Type

The type the xsi:type name and namespace is mapped to.

  Remarks
For information on this method, refer to the DataContractResolver class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KnownTypesResolver Class
KnownTypesResolver Members
Microsoft.Xrm.Sdk Namespace


KnownTypesResolver.TryResolveType Method
[image]

Maps any type to a new xsi:type representation.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function TryResolveType ( _
    type As Type, _
    declaredType As Type, _
    knownTypeResolver As DataContractResolver, _
    <OutAttribute> ByRef typeName As XmlDictionaryString, _
    <OutAttribute> ByRef typeNamespace As XmlDictionaryString _
) As Boolean

C#
public override bool TryResolveType (
    Type type,
    Type declaredType,
    DataContractResolver knownTypeResolver,
    out XmlDictionaryString typeName,
    out XmlDictionaryString typeNamespace
)

C++

J#

JScript

Parameters
type
Type. The type to map.
declaredType
Type. The type declared in the data contract.
knownTypeResolver
System.Runtime.Serialization.DataContractResolver. The known type resolver.
typeName
System.Xml.XmlDictionaryString. The xsi:type name.
typeNamespace
System.Xml.XmlDictionaryString. The xsi:type namespace.
Return Value
 Type: Boolean
true if mapping succeeded; otherwise, false.

  Remarks
For information on this method, refer to the DataContractResolver class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KnownTypesResolver Class
KnownTypesResolver Members
Microsoft.Xrm.Sdk Namespace


Label Class
See Also Members
[image]

Contains a collection of translations for a label.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="Label", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class Label
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="Label", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class Label : IExtensibleDataObject

C++

J#

JScript

  Remarks
You can only set a localized label for a language that is installed on the server.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Label
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Label Members
Microsoft.Xrm.Sdk Namespace


Label Members
See Also Constructors Methods Properties
[image]

Contains a collection of translations for a label.

The following tables list the members exposed by the Label type.

Public Constructors

Name | Description
Label | Overloaded. Initializes a new instance of the Label class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | LocalizedLabels | Gets the collection of localized labels.
public property | UserLocalizedLabel | Gets or set the label for the language of the current user.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Label Class
Microsoft.Xrm.Sdk Namespace


Label Constructor
[image]

Initializes a new instance of the Label class.

Overload List

Name | Description
Label () | Initializes a new instance of the Label class.
Label (LocalizedLabel, LocalizedLabel[]) | Initializes a new instance of the Label class.
Label (String, Int32) | Initializes a new instance of the Label class.

See Also

Reference

Label Class
Label Members
Microsoft.Xrm.Sdk Namespace


Label Constructor ()
[image]

Initializes a new instance of the Label class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public Label ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Label Class
Label Members
Microsoft.Xrm.Sdk Namespace


Label Constructor (LocalizedLabel, LocalizedLabel[])
[image]

Initializes a new instance of the Label class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    userLocalizedLabel As LocalizedLabel, _
    labels As LocalizedLabel() _
)

C#
public Label (
    LocalizedLabel userLocalizedLabel,
    LocalizedLabel[] labels
)

C++

J#

JScript

Parameters
userLocalizedLabel
Type: LocalizedLabel. The label for the language of the current user.
labels
Type: LocalizedLabel[]. An array of localized labels.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Label Class
Label Members
Microsoft.Xrm.Sdk Namespace


Label Constructor (String, Int32)
[image]

Initializes a new instance of the Label class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    label As String, _
    languageCode As Integer _
)

C#
public Label (
    string label,
    int languageCode
)

C++

J#

JScript

Parameters
label
Type: String. The string for the user localized label.
languageCode
Type: Int32. The language code for the label.
  Remarks

                        Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart).

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Label Class
Label Members
Microsoft.Xrm.Sdk Namespace


Label Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Label Class
Microsoft.Xrm.Sdk Namespace


Label Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | LocalizedLabels | Gets the collection of localized labels.
public property | UserLocalizedLabel | Gets or set the label for the language of the current user.

See Also

Reference

Label Class
Microsoft.Xrm.Sdk Namespace


Label.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Label Class
Label Members
Microsoft.Xrm.Sdk Namespace


Label.LocalizedLabels Property
[image]

Gets the collection of localized labels.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LocalizedLabels As LocalizedLabelCollection

C#
[DataMemberAttribute]
public LocalizedLabelCollection LocalizedLabels { get; }

C++

J#

JScript

Property Value
Type: LocalizedLabelCollection
 The collection of localized labels.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Label Class
Label Members
Microsoft.Xrm.Sdk Namespace


Label.UserLocalizedLabel Property
[image]

Gets or set the label for the language of the current user.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UserLocalizedLabel As LocalizedLabel

C#
[DataMemberAttribute]
public LocalizedLabel UserLocalizedLabel { get; set; }

C++

J#

JScript

Property Value
Type: LocalizedLabel
The label for the language of the current user.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Label Class
Label Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabel Class
See Also Members
[image]

Contains a localized label, including the label string and the language code.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="LocalizedLabel", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class LocalizedLabel
    Inherits MetadataBase

C#
[DataContractAttribute(Name="LocalizedLabel", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class LocalizedLabel : MetadataBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase
    Microsoft.Xrm.Sdk.LocalizedLabel
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalizedLabel Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabel Members
See Also Constructors Methods Properties
[image]

Contains a localized label, including the label string and the language code.

The following tables list the members exposed by the LocalizedLabel type.

Public Constructors

Name | Description
LocalizedLabel | Overloaded. Initializes a new instance of the LocalizedLabel class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IsManaged | Gets or sets whether the label is managed.
public property | Label | Gets or sets the localized label string.
public property | LanguageCode | Gets or sets the language code for the label.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LocalizedLabel Class
Microsoft.Xrm.Sdk Namespace


LocalizedLabel Constructor
[image]

Initializes a new instance of the LocalizedLabel class.

Overload List

Name | Description
LocalizedLabel () | Initializes a new instance of the LocalizedLabel class.
LocalizedLabel (String, Int32) | Initializes a new instance of the LocalizedLabel class setting the label string and the language code.

See Also

Reference

LocalizedLabel Class
LocalizedLabel Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabel Constructor ()
[image]

Initializes a new instance of the LocalizedLabel class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LocalizedLabel ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalizedLabel Class
LocalizedLabel Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabel Constructor (String, Int32)
[image]

Initializes a new instance of the LocalizedLabel class setting the label string and the language code.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    label As String, _
    languageCode As Integer _
)

C#
public LocalizedLabel (
    string label,
    int languageCode
)

C++

J#

JScript

Parameters
label
Type: String
The localized label string..
languageCode
Type: Int32
The language code for the label.
  Remarks

                        Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart).

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalizedLabel Class
LocalizedLabel Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabel Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LocalizedLabel Class
Microsoft.Xrm.Sdk Namespace


LocalizedLabel Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IsManaged | Gets or sets whether the label is managed.
public property | Label | Gets or sets the localized label string.
public property | LanguageCode | Gets or sets the language code for the label.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)

See Also

Reference

LocalizedLabel Class
Microsoft.Xrm.Sdk Namespace


LocalizedLabel.IsManaged Property
[image]

Gets or sets whether the label is managed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsManaged As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsManaged { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the label is managed; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalizedLabel Class
LocalizedLabel Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabel.Label Property
[image]

Gets or sets the localized label string.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Label As String

C#
[DataMemberAttribute]
public string Label { get; set; }

C++

J#

JScript

Property Value
Type: String

The localized label string..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalizedLabel Class
LocalizedLabel Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabel.LanguageCode Property
[image]

Gets or sets the language code for the label.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LanguageCode As Integer

C#
[DataMemberAttribute]
public int LanguageCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The language code for the label..

  Remarks

                        Valid locale ID values can be found at Locale ID (LCID) Chart.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalizedLabel Class
LocalizedLabel Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabelCollection Class
See Also Members
[image]

Defines a collection of LocalizedLabel.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="LocalizedLabelCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class LocalizedLabelCollection
    Inherits DataCollection(Of LocalizedLabel)

C#
[CollectionDataContractAttribute(Name="LocalizedLabelCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class LocalizedLabelCollection : DataCollection<LocalizedLabel>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.LocalizedLabelCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalizedLabelCollection Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Customize Labels to Support Multiple Languages


LocalizedLabelCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Defines a collection of LocalizedLabel.

The following tables list the members exposed by the LocalizedLabelCollection type.

Public Constructors

Name | Description
LocalizedLabelCollection | Overloaded. Initializes a new instance of the LocalizedLabelCollection class
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

LocalizedLabelCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Customize Labels to Support Multiple Languages


LocalizedLabelCollection Constructor
[image]

Initializes a new instance of the LocalizedLabelCollection class

Overload List

Name | Description
LocalizedLabelCollection () | Initializes a new instance of the LocalizedLabelCollection class
LocalizedLabelCollection (IList) | Initializes a new instance of the LocalizedLabelCollection class

See Also

Reference

LocalizedLabelCollection Class
LocalizedLabelCollection Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabelCollection Constructor ()
[image]

Initializes a new instance of the LocalizedLabelCollection class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LocalizedLabelCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalizedLabelCollection Class
LocalizedLabelCollection Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabelCollection Constructor (IList)
[image]

Initializes a new instance of the LocalizedLabelCollection class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    list As IList(Of LocalizedLabel) _
)

C#
public LocalizedLabelCollection (
    IList<LocalizedLabel> list
)

C++

J#

JScript

Parameters
list
Type: IList<LocalizedLabel>. Sets a list of localized labels.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalizedLabelCollection Class
LocalizedLabelCollection Members
Microsoft.Xrm.Sdk Namespace


LocalizedLabelCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

LocalizedLabelCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Customize Labels to Support Multiple Languages


LocalizedLabelCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

LocalizedLabelCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Customize Labels to Support Multiple Languages


ManagedProperty Generic Class
See Also Members
[image]

Represents a strongly typed managed property.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ManagedProperty{0}", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<KnownTypeAttribute(GetType(BooleanManagedProperty))> _
<KnownTypeAttribute(GetType(AttributeRequiredLevel))> _
Public MustInherit Class ManagedProperty(Of T)
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="ManagedProperty{0}", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[KnownTypeAttribute(typeof(BooleanManagedProperty))]
[KnownTypeAttribute(typeof(AttributeRequiredLevel))]
public abstract class ManagedProperty<T> : IExtensibleDataObject

C++

J#

JScript

GenericParameters
T
Type: Type. The type of managed property.
  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.ManagedProperty

                Microsoft.Xrm.Sdk.BooleanManagedProperty

                Microsoft.Xrm.Sdk.Metadata.AttributeRequiredLevelManagedProperty
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedProperty Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use Managed Properties


ManagedProperty Members
See Also Methods Properties Constructors
[image]

Represents a strongly typed managed property.

The following tables list the members exposed by the ManagedProperty type.

Protected Constructors

Name | Description
ManagedProperty | Overloaded. Initializes a new instance of the ManagedProperty class
Top

Public Properties

 | Name | Description
public property | CanBeChanged | Gets or sets whether the managed property value can be changed.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ManagedPropertyLogicalName | Gets the logical name for the managed property.
public property | Value | Gets or sets the value of the managed property.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ManagedProperty Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use Managed Properties


ManagedProperty Constructor
[image]

Initializes a new instance of the ManagedProperty class

Overload List

Name | Description
ManagedProperty () | Initializes a new instance of the ManagedProperty class
ManagedProperty (String) | Initializes a new instance of the ManagedProperty class

See Also

Reference

ManagedProperty Class
ManagedProperty Members
Microsoft.Xrm.Sdk Namespace


ManagedProperty Constructor ()
[image]

Initializes a new instance of the ManagedProperty class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected ManagedProperty ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedProperty Class
ManagedProperty Members
Microsoft.Xrm.Sdk Namespace


ManagedProperty Constructor (String)
[image]

Initializes a new instance of the ManagedProperty class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    managedPropertyLogicalName As String _
)

C#
protected ManagedProperty (
    string managedPropertyLogicalName
)

C++

J#

JScript

Parameters
managedPropertyLogicalName
Type: String. The logical name for the managed property.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedProperty Class
ManagedProperty Members
Microsoft.Xrm.Sdk Namespace


ManagedProperty Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ManagedProperty Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use Managed Properties


ManagedProperty Properties
[image]

Public Properties

 | Name | Description
public property | CanBeChanged | Gets or sets whether the managed property value can be changed.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | ManagedPropertyLogicalName | Gets the logical name for the managed property.
public property | Value | Gets or sets the value of the managed property.

See Also

Reference

ManagedProperty Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use Managed Properties


ManagedProperty.CanBeChanged Property
[image]

Gets or sets whether the managed property value can be changed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeChanged As Boolean

C#
[DataMemberAttribute]
public bool CanBeChanged { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the managed property value can be changed; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedProperty Class
ManagedProperty Members
Microsoft.Xrm.Sdk Namespace


ManagedProperty.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedProperty Class
ManagedProperty Members
Microsoft.Xrm.Sdk Namespace


ManagedProperty.ManagedPropertyLogicalName Property
[image]

Gets the logical name for the managed property.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ManagedPropertyLogicalName As String

C#
[DataMemberAttribute]
public string ManagedPropertyLogicalName { get; }

C++

J#

JScript

Property Value
Type: String

The logical name for the managed property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedProperty Class
ManagedProperty Members
Microsoft.Xrm.Sdk Namespace


ManagedProperty.Value Property
[image]

Gets or sets the value of the managed property.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Value As T

C#
[DataMemberAttribute]
public T Value { get; set; }

C++

J#

JScript

Property Value
Type: String

The value of the managed property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedProperty Class
ManagedProperty Members
Microsoft.Xrm.Sdk Namespace


Money Class
See Also Members
[image]

Contains the value for a money attribute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="Money", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class Money
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="Money", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class Money : IExtensibleDataObject

C++

J#

JScript

  Remarks
This corresponds to the CrmMoney class from Microsoft Dynamics CRM 4.0.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Money
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Money Members
Microsoft.Xrm.Sdk Namespace


Money Members
See Also Constructors Methods Properties
[image]

Contains the value for a money attribute.

The following tables list the members exposed by the Money type.

Public Constructors

Name | Description
Money | Overloaded. Initializes a new instance of the Money class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Value | Gets or sets the value of the attribute.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Returns a hash code value for this type.
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Money Class
Microsoft.Xrm.Sdk Namespace


Money Constructor
[image]

Initializes a new instance of the Money class.

Overload List

Name | Description
Money () | Initializes a new instance of the Money class.
Money (Decimal) | Initializes a new instance of the Money class setting the value.

See Also

Reference

Money Class
Money Members
Microsoft.Xrm.Sdk Namespace


Money Constructor ()
[image]

Initializes a new instance of the Money class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public Money ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Money Class
Money Members
Microsoft.Xrm.Sdk Namespace


Money Constructor (Decimal)
[image]

Initializes a new instance of the Money class setting the value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As Decimal _
)

C#
public Money (
    decimal value
)

C++

J#

JScript

Parameters
value
Type: Decimal. The value of the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Money Class
Money Members
Microsoft.Xrm.Sdk Namespace


Money Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Returns a hash code value for this type.
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Money Class
Microsoft.Xrm.Sdk Namespace


Money.Equals Method
[image]

Determines whether two instances are equal.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

C#
public override bool Equals (
    Object obj
)

C++

J#

JScript

Parameters
obj
Type: Object. The Money to compare with the current Money.
Return Value
Type: Boolean
true if the specified Money is equal to the Money object; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Money Class
Money Members
Microsoft.Xrm.Sdk Namespace


Money.GetHashCode Method
[image]

Returns a hash code value for this type.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function GetHashCode As Integer

C#
public override int GetHashCode ()

C++

J#

JScript

Return Value
Type: Int32

The hash code for the current Money.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Money Class
Money Members
Microsoft.Xrm.Sdk Namespace


Money Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Value | Gets or sets the value of the attribute.

See Also

Reference

Money Class
Microsoft.Xrm.Sdk Namespace


Money.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Money Class
Money Members
Microsoft.Xrm.Sdk Namespace


Money.Value Property
[image]

Gets or sets the value of the attribute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Value As Decimal

C#
[DataMemberAttribute]
public decimal Value { get; set; }

C++

J#

JScript

Property Value
Type: Decimal
The value of the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Money Class
Money Members
Microsoft.Xrm.Sdk Namespace


OperationStatus Enumeration
[image]

Represents the current state of an operation.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration OperationStatus

C#
public enum OperationStatus

C++

J#

JScript

  Members
Member name | Description
Canceled | The operation has been canceled. Value = 1.
Failed | The operation has failed. Value = 0.
Retry | The operation is being retried. Value = 2.
Succeeded | The operation has succeeded. Value = 4.
Suspended | The operation has been suspended. Value = 3.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk Namespace


OptionSetValue Class
See Also Members
[image]

Represents a value for an attribute that has an option set.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OptionSetValue", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class OptionSetValue
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="OptionSetValue", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class OptionSetValue : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.OptionSetValue
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetValue Members
Microsoft.Xrm.Sdk Namespace


OptionSetValue Members
See Also Constructors Methods Properties
[image]

Represents a value for an attribute that has an option set.

The following tables list the members exposed by the OptionSetValue type.

Public Constructors

Name | Description
OptionSetValue | Overloaded. Initializes a new instance of the OptionSetValue class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Value | Gets or sets the current value.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Returns true if the specified OptionSetValue is equal to this OptionSetValue value, otherwise returns false.
public method | GetHashCode | Overridden. Gets a hash code for the value.
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OptionSetValue Class
Microsoft.Xrm.Sdk Namespace


OptionSetValue Constructor
[image]

Initializes a new instance of the OptionSetValue class

Overload List

Name | Description
OptionSetValue () | Initializes a new instance of the OptionSetValue class
OptionSetValue (Int32) | Initializes a new instance of the OptionSetValue class

See Also

Reference

OptionSetValue Class
OptionSetValue Members
Microsoft.Xrm.Sdk Namespace


OptionSetValue Constructor ()
[image]

Initializes a new instance of the OptionSetValue class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OptionSetValue ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetValue Class
OptionSetValue Members
Microsoft.Xrm.Sdk Namespace


OptionSetValue Constructor (Int32)
[image]

Initializes a new instance of the OptionSetValue class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As Integer _
)

C#
public OptionSetValue (
    int value
)

C++

J#

JScript

Parameters
value
Type: Int32. The option set value.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetValue Class
OptionSetValue Members
Microsoft.Xrm.Sdk Namespace


OptionSetValue Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Returns true if the specified OptionSetValue is equal to this OptionSetValue value, otherwise returns false.
public method | GetHashCode | Overridden. Gets a hash code for the value.
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OptionSetValue Class
Microsoft.Xrm.Sdk Namespace


OptionSetValue.Equals Method
[image]

Returns true if the specified OptionSetValue is equal to this OptionSetValue value, otherwise returns false.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

C#
public override bool Equals (
    Object obj
)

C++

J#

JScript

Parameters
obj
Type: OptionSetValue, The OptionSetValue to compare.
Return Value
Type: Boolean
true if the specified OptionSetValue is equal to this OptionSetValue value; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetValue Class
OptionSetValue Members
Microsoft.Xrm.Sdk Namespace


OptionSetValue.GetHashCode Method
[image]

Gets a hash code for the value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function GetHashCode As Integer

C#
public override int GetHashCode ()

C++

J#

JScript

Return Value
Type: Int32

The hash code for the value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetValue Class
OptionSetValue Members
Microsoft.Xrm.Sdk Namespace


OptionSetValue Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Value | Gets or sets the current value.

See Also

Reference

OptionSetValue Class
Microsoft.Xrm.Sdk Namespace


OptionSetValue.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Remarks

                        Gets or sets the structure that contains extra data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetValue Class
OptionSetValue Members
Microsoft.Xrm.Sdk Namespace


OptionSetValue.Value Property
[image]

Gets or sets the current value.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Value As Integer

C#
[DataMemberAttribute]
public int Value { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The current value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetValue Class
OptionSetValue Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequest Class
See Also Members
[image]

Contains the data needed to execute a request and the base class for all organization requests.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification:="This class need to be instantiated by clients and be able to derive from it.")> _
<DataContractAttribute(Name:="OrganizationRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<DefaultMemberAttribute("Item")> _
Public Class OrganizationRequest
    Implements IExtensibleDataObject

C#
[SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification="This class need to be instantiated by clients and be able to derive from it.")]
[DataContractAttribute(Name="OrganizationRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[DefaultMemberAttribute("Item")]
public class OrganizationRequest : IExtensibleDataObject

C++

J#

JScript

  Remarks
This is the base class for all organization Web service requests.  Pass an instance of a request class to the Execute method.
You can use this class, specifying the parameter collection. However, when you use the derived class, the parameter collection is created for you.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.OrganizationRequest

                Derived Classes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace
OrganizationResponse
Other Resources
Use Messages (Request and Response Classes) with the Execute Method


OrganizationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to execute a request and the base class for all organization requests.

The following tables list the members exposed by the OrganizationRequest type.

Public Constructors

Name | Description
OrganizationRequest | Overloaded. Initializes a new instance of the OrganizationRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional.
public property | Item | Gets or sets the indexer for the Parameters collection.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional.
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrganizationRequest Class
Microsoft.Xrm.Sdk Namespace
OrganizationResponse

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


OrganizationRequest Constructor
[image]

Initializes a new instance of the OrganizationRequest class.

Overload List

Name | Description
OrganizationRequest () | Initializes a new instance of the OrganizationRequest class.
OrganizationRequest (String) | Initializes a new instance of the OrganizationRequest class setting the request name parameter.

See Also

Reference

OrganizationRequest Class
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequest Constructor ()
[image]

Initializes a new instance of the OrganizationRequest class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrganizationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequest Class
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequest Constructor (String)
[image]

Initializes a new instance of the OrganizationRequest class setting the request name parameter.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    requestName As String _
)

C#
public OrganizationRequest (
    string requestName
)

C++

J#

JScript

Parameters
requestName
Type: String. The name of the request.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequest Class
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrganizationRequest Class
Microsoft.Xrm.Sdk Namespace
OrganizationResponse

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


OrganizationRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional.
public property | Item | Gets or sets the indexer for the Parameters collection.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional.
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes.

See Also

Reference

OrganizationRequest Class
Microsoft.Xrm.Sdk Namespace
OrganizationResponse

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


OrganizationRequest.ExtensionData Property
[image]

Gets or sets the structure that contains extra data. Optional.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject

The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequest Class
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequest.Item Property
[image]

Gets or sets the indexer for the Parameters collection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Default Property Item ( _
    parameterName As String _
) As Object

C#
public Object this [
    string parameterName
] { get; set; }

C++

J#

JScript

Parameters
parameterName
Type: String. The name of the parameter.
Property Value
Type: Object

The indexer for the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequest Class
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequest.Parameters Property
[image]

Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Parameters As ParameterCollection

C#
[DataMemberAttribute]
public ParameterCollection Parameters { get; set; }

C++

J#

JScript

Property Value
Type: ParameterCollection
The collection of parameters for the request. Required, but is supplied by derived classes.

  Remarks
The parameters collection is populated automatically if you are using a derived message class such as AssignRequest. Otherwise you must populate the collection with the parameters required for the message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequest Class
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequest.RequestId Property
[image]

Gets or sets the ID of an asynchronous operation (system job). Optional.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RequestId As Nullable(Of Guid)

C#
[DataMemberAttribute]
public Nullable<Guid> RequestId { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Guid>
The ID of an asynchronous operation (system job).

  Remarks
You can pass an optional parameter into any message by setting this property. For any message that can be used in an asynchronous operation, set this to the value of AsyncOperation.RequestId.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequest Class
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequest.RequestName Property
[image]

Gets or sets the name of the request. Required, but is supplied by derived classes.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RequestName As String

C#
[DataMemberAttribute]
public string RequestName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the request.

  Remarks
Message request names can be found in the SDK Message entity. The following is a list of valid message names that have been retrieved from the SDK Message entity and whether they can be used online (connected to the server), offline (disconnected) or both.
Sdk message request name | Sdk message filter availability
AddItemCampaignActivity | Both
AddItemCampaign | Both
AddListMembersList | Online
AddMemberList | Online
AddMembersTeam | Online
AddPrivilegesRole | Online
AddProductToKit | Both
AddRecurrence | Both
AddSolutionComponent | Online
AddSubstituteProduct | Both
AddToQueue | Both
Assign | Online
Associate | Both
AssociateEntities | Both
AutoMapEntity | Online
BackgroundSendEmail | Both
Book | Online
BulkDelete | Online
BulkDetectDuplicates | Online
SendBulkMail | Online
BulkOperationStatusClose | Both
CalculateActualValueOpportunity | Both
CalculateTotalTimeIncident | Both
CanBeReferenced | Online
CanBeReferencing | Online
CancelSalesOrder | Both
CancelContract | Both
CanManyToMany | Online
CheckIncomingEmail | Both
CheckPromoteEmail | Both
CleanUpBulkOperation | Both
CloneContract | Both
CloseQuote | Both
CloseIncident | Both
CompoundCreate | Both
CompoundUpdate | Both
CompoundUpdateDuplicateDetectionRule | Online
ConvertKitToProduct | Online
ConvertProductToKit | Online
ConvertQuoteToSalesOrder | Both
ConvertSalesOrderToInvoice | Online
CopyCampaign | Online
CopyCampaignResponse | Both
CopyDynamicListToStatic | Online
CopyMembersList | Online
CopySystemForm | Online
Create | Online
CreateActivitiesList | Online
CreateAttribute | Online
CreateEntity | Online
CreateException | Both
CreateInstance | Online
CreateManyToMany | Online
CreateOneToMany | Online
CreateOptionSet | Online
CreateWorkflowFromTemplate | Online
Delete | Online
DeleteAttribute | Online
DeleteAuditData | Online
DeleteEntity | Online
DeleteOpenInstances | Both
DeleteOptionSet | Online
DeleteOptionValue | Online
DeleteRelationship | Online
DeliverIncomingEmail | Online
DeliverPromoteEmail | Both
DeprovisionLanguage | Online
Disassociate | Both
DisassociateEntities | Both
DistributeCampaignActivity | Online
DownloadReportDefinition | Online
QueryExpressionToFetchXml | Both
ExecuteFetch | Online
ExecuteByIdSavedQuery | Both
ExecuteByIdUserQuery | Both
ExecuteWorkflow | Online
ExpandCalendar | Both
ExportMappingsImportMap | Online
ExportSolution | Online
ExportTranslation | Online
FetchXmlToQueryExpression | Both
FindParentResourceGroup | Both
FulfillSalesOrder | Both
GenerateInvoiceFromOpportunity | Both
GenerateQuoteFromOpportunity | Both
GenerateSalesOrderFromOpportunity | Both
GetAllTimeZonesWithDisplayName | Both
GetDecryptionKey | Online
GetDistinctValuesImportFile | Both
GetHeaderColumnsImportFile | Both
GetInvoiceProductsFromOpportunity | Both
GetQuantityDecimal | Both
GetQuoteProductsFromOpportunity | Both
GetReportHistoryLimit | Online
GetSalesOrderProductsFromOpportunity | Both
GetTimeZoneCodeByLocalizedName | Both
GetTrackingTokenEmail | Both
GetValidManyToMany | Online
GetValidReferencedEntities | Both
GetValidReferencingEntities | Online
GrantAccess | Online
ImportMappingsImportMap | Online
ImportRecordsImport | Both
ImportSolution | Online
ImportTranslation | Online
InitializeFrom | Both
InsertOptionValue | Online
InsertStatusValue | Online
InstallSampleData | Online
InstantiateTemplate | Both
InstantiateFilters | Online
IsBackOfficeInstalled | Both
IsComponentCustomizable | Both
IsValidStateTransition | Both
LocalTimeFromUtcTime | Both
LockInvoicePricing | Online
LockSalesOrderPricing | Online
LogFailureBulkOperation | Both
LogSuccessBulkOperation | Both
LoseOpportunity | Both
MakeAvailableToOrganizationReport | Online
MakeAvailableToOrganizationTemplate | Online
MakeUnavailableToOrganizationReport | Online
MakeUnavailableToOrganizationTemplate | Online
Merge | Online
ModifyAccess | Online
OrderOption | Online
ParseImport | Both
ProcessInboundEmail | Online
ProcessOneMemberBulkOperation | Both
PropagateByExpression | Both
ProvisionLanguage | Online
PublishXml | Online
PublishDuplicateRule | Online
PublishAllXml | Online
QualifyLead | Both
QualifyMemberList | Both
QuerySchedule | Both
QueryMultipleSchedules | Both
ReassignObjectsSystemUser | Online
ReassignObjectsOwner | Online
Recalculate | Online
RemoveItemCampaign | Both
RemoveItemCampaignActivity | Both
RemoveMemberList | Online
RemoveMembersTeam | Online
RemoveParent | Online
RemovePrivilegeRole | Online
RemoveProductFromKit | Both
RemoveRelated | Both
RemoveSolutionComponent | Online
RemoveSubstituteProduct | Both
RenewContract | Both
ReplacePrivilegesRole | Online
Reschedule | Online
ResetUserFilters | Both
Retrieve | Online
RetrieveAbsoluteAndSiteCollectionUrl | Online
RetrieveAllChildUsersSystemUser | Both
RetrieveAllEntities | Both
RetrieveAllManagedProperties | Both
RetrieveAllOptionSets | Both
RetrieveApplicationRibbon | Online
RetrieveAttribute | Both
RetrieveAttributeChangeHistory | Online
RetrieveAuditDetails | Online
RetrieveAuditPartitionList | Online
RetrieveAvailableLanguages | Both
RetrieveBusinessHierarchyBusinessUnit | Online
RetrieveByGroupResource | Both
RetrieveByResourceResourceGroup | Both
RetrieveByResourcesService | Both
RetrieveByTopIncidentProductKbArticle | Both
RetrieveByTopIncidentSubjectKbArticle | Both
RetrieveDependenciesForDelete | Online
RetrieveDependenciesForUninstall | Online
RetrieveDependentComponents | Online
RetrieveDeploymentLicenseType | Online
RetrieveDeprovisionedLanguages | Online
RetrieveDuplicates | Online
RetrieveEntity | Both
RetrieveEntityRibbon | Online
RetrieveExchangeRate | Both
RetrieveFilteredForms | Both
RetrieveFormattedImportJobResults | Online
RetrieveFormXml | Both
RetrieveInstalledLanguagePacks | Online
RetrieveInstalledLanguagePackVersion | Online
RetrieveLicenseInfo | Online
RetrieveLocLabels | Both
RetrieveManagedProperty | Both
RetrieveMembersTeam | Both
RetrieveMembersBulkOperation | Both
RetrieveMissingComponents | Online
RetrieveMissingDependencies | Online
RetrieveMultiple | Both
RetrieveOptionSet | Both
RetrieveOrganizationResources | Online
RetrieveParentGroupsResourceGroup | Both
RetrieveParsedDataImportFile | Both
RetrievePrincipalAccess | Both
RetrievePrincipalAttributePrivileges | Both
RetrievePrivilegeSet | Both
RetrieveProvisionedLanguagePackVersion | Online
RetrieveProvisionedLanguages | Online
RetrieveRecordChangeHistory | Online
RetrieveRelationship | Both
RetrieveRequiredComponents | Online
RetrieveRolePrivilegesRole | Both
RetrieveSharedPrincipalsAndAccess | Both
RetrieveSubGroupsResourceGroup | Both
RetrieveSubsidiaryTeamsBusinessUnit | Both
RetrieveSubsidiaryUsersBusinessUnit | Both
RetrieveTeamPrivileges | Both
RetrieveTeamsSystemUser | Both
RetrieveTimestamp | Both
RetrieveUnpublished | Online
RetrieveUnpublishedMultiple | Online
RetrieveUserPrivileges | Both
RetrieveUserSettingsSystemUser | Both
RetrieveVersion | Both
ReviseQuote | Both
RevokeAccess | Online
Rollup | Both
Search | Online
SearchByBodyKbArticle | Both
SearchByKeywordsKbArticle | Both
SearchByTitleKbArticle | Both
SendTemplate | Both
SendFax | Both
SendEmail | Both
SendEmailFromTemplate | Online
SetBusinessSystemUser | Online
SetBusinessEquipment | Online
SetLocLabels | Online
SetParentBusinessUnit | Online
SetParentSystemUser | Online
SetParentTeam | Online
SetRelated | Both
SetReportRelated | Online
SetState | Both
StatusUpdateBulkOperation | Both
TransformImport | Both
TriggerServiceEndpointCheck | Online
UninstallSampleData | Online
UnlockInvoicePricing | Online
UnlockSalesOrderPricing | Online
UnpublishDuplicateRule | Online
Update | Online
UpdateAttribute | Online
UpdateEntity | Online
UpdateOptionSet | Online
UpdateOptionValue | Online
UpdateRelationship | Online
UpdateStateValue | Online
UpdateUserSettingsSystemUser | Both
UtcTimeFromLocalTime | Both
ValidateSavedQuery | Both
Validate | Both
ValidateRecurrenceRule | Both
VerifyProcessStateData | Online
WhoAmI | Both
WinOpportunity | Both
WinQuote | Both

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequest Class
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequestCollection Class
See Also Members
[image]

Contains a collection of organization requests.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="OrganizationRequestCollection", Namespace:="http://schemas.microsoft.com/xrm/2012/Contracts")> _
Public NotInheritable Class OrganizationRequestCollection
    Inherits DataCollection(Of OrganizationRequest)

C#
[CollectionDataContractAttribute(Name="OrganizationRequestCollection", Namespace="http://schemas.microsoft.com/xrm/2012/Contracts")]
public sealed class OrganizationRequestCollection : DataCollection<OrganizationRequest>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.OrganizationRequestCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequestCollection Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use ExecuteMultiple to Improve Performance for Bulk Data Load


OrganizationRequestCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a collection of organization requests.

The following tables list the members exposed by the OrganizationRequestCollection type.

Public Constructors

Name | Description
OrganizationRequestCollection | Initializes a new instance of the OrganizationRequestCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

OrganizationRequestCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use ExecuteMultiple to Improve Performance for Bulk Data Load


OrganizationRequestCollection Constructor
[image]

Initializes a new instance of the OrganizationRequestCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrganizationRequestCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationRequestCollection Class
OrganizationRequestCollection Members
Microsoft.Xrm.Sdk Namespace


OrganizationRequestCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

OrganizationRequestCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use ExecuteMultiple to Improve Performance for Bulk Data Load


OrganizationRequestCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

OrganizationRequestCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use ExecuteMultiple to Improve Performance for Bulk Data Load


OrganizationResponse Class
See Also Members
[image]

Contains the response from a request and the base class for all organization responses.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification:="This class need to be instantiated by clients and be able to derive from it.")> _
<DefaultMemberAttribute("Item")> _
<DataContractAttribute(Name:="OrganizationResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Class OrganizationResponse
    Implements IExtensibleDataObject

C#
[SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification="This class need to be instantiated by clients and be able to derive from it.")]
[DefaultMemberAttribute("Item")]
[DataContractAttribute(Name="OrganizationResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public class OrganizationResponse : IExtensibleDataObject

C++

J#

JScript

  Remarks
This is the base class for all organization Web service responses. An instance of a response class is returned from the Execute method.
Some messages do not have a return value. In those classes the Results collection will be empty.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.OrganizationResponse

                Derived Classes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResponse Members
Microsoft.Xrm.Sdk Namespace
OrganizationRequest
Other Resources
Use Messages (Request and Response Classes) with the Execute Method


OrganizationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from a request and the base class for all organization responses.

The following tables list the members exposed by the OrganizationResponse type.

Public Constructors

Name | Description
OrganizationResponse | Initializes a new instance of the OrganizationResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Item | Gets an indexer for the Results collection.
public property | ResponseName | Gets or sets the name of the response.
public property | Results | Gets the results of the request that was performed.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrganizationResponse Class
Microsoft.Xrm.Sdk Namespace
OrganizationRequest

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


OrganizationResponse Constructor
[image]

Initializes a new instance of the OrganizationResponse class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrganizationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResponse Class
OrganizationResponse Members
Microsoft.Xrm.Sdk Namespace


OrganizationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrganizationResponse Class
Microsoft.Xrm.Sdk Namespace
OrganizationRequest

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


OrganizationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Item | Gets an indexer for the Results collection.
public property | ResponseName | Gets or sets the name of the response.
public property | Results | Gets the results of the request that was performed.

See Also

Reference

OrganizationResponse Class
Microsoft.Xrm.Sdk Namespace
OrganizationRequest

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


OrganizationResponse.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResponse Class
OrganizationResponse Members
Microsoft.Xrm.Sdk Namespace


OrganizationResponse.Item Property
[image]

Gets an indexer for the Results collection.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Default Property Item ( _
    parameterName As String _
) As Object

C#
public Object this [
    string parameterName
] { get; set; }

C++

J#

JScript

Parameters
parameterName
Type: String. The name of the parameter.
Property Value
Type: Object
The indexer for the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResponse Class
OrganizationResponse Members
Microsoft.Xrm.Sdk Namespace


OrganizationResponse.ResponseName Property
[image]

Gets or sets the name of the response.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResponseName As String

C#
[DataMemberAttribute]
public string ResponseName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the response.

  Remarks
The response name is the same as the request name. For more information, see RequestName

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResponse Class
OrganizationResponse Members
Microsoft.Xrm.Sdk Namespace


OrganizationResponse.Results Property
[image]

Gets the results of the request that was performed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Results As ParameterCollection

C#
[DataMemberAttribute]
public ParameterCollection Results { get; set; }

C++

J#

JScript

Property Value
Type: ParameterCollection
The results of the request that was performed.

  Remarks
If you are using a derived message class such as AssignResponse, the contents of this parameter collection are populated automatically to the properties of the response class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationResponse Class
OrganizationResponse Members
Microsoft.Xrm.Sdk Namespace


OrganizationServiceFault Class
See Also Members
[image]

Represents an organization service fault.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Name:="OrganizationServiceFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class OrganizationServiceFault
    Inherits BaseServiceFault

C#
[SerializableAttribute]
[DataContractAttribute(Name="OrganizationServiceFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class OrganizationServiceFault : BaseServiceFault

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.BaseServiceFault
    Microsoft.Xrm.Sdk.OrganizationServiceFault
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceFault Members
Microsoft.Xrm.Sdk Namespace
IOrganizationService


OrganizationServiceFault Members
See Also Constructors Methods Properties
[image]

Represents an organization service fault.

The following tables list the members exposed by the OrganizationServiceFault type.

Public Constructors

Name | Description
OrganizationServiceFault | Initializes a new instance of the OrganizationServiceFault class.
Top

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the fault error code. (inherited from BaseServiceFault)
public property | ErrorDetails | Gets or sets the details of the fault. (inherited from BaseServiceFault)
public property | ExtensionData | Gets or sets a structure that contains extra data. (inherited from BaseServiceFault)
public property | InnerFault | Gets the fault instance that caused the current fault.
public property | Message | Gets or sets the message for the fault. (inherited from BaseServiceFault)
public property | Timestamp | Gets or sets the date and time when the fault occurred. (inherited from BaseServiceFault)
public property | TraceText | Gets the text of the fault trace.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrganizationServiceFault Class
Microsoft.Xrm.Sdk Namespace
IOrganizationService


OrganizationServiceFault Constructor
[image]

Initializes a new instance of the OrganizationServiceFault class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrganizationServiceFault ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceFault Class
OrganizationServiceFault Members
Microsoft.Xrm.Sdk Namespace


OrganizationServiceFault Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrganizationServiceFault Class
Microsoft.Xrm.Sdk Namespace
IOrganizationService


OrganizationServiceFault Properties
[image]

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the fault error code. (inherited from BaseServiceFault)
public property | ErrorDetails | Gets or sets the details of the fault. (inherited from BaseServiceFault)
public property | ExtensionData | Gets or sets a structure that contains extra data. (inherited from BaseServiceFault)
public property | InnerFault | Gets the fault instance that caused the current fault.
public property | Message | Gets or sets the message for the fault. (inherited from BaseServiceFault)
public property | Timestamp | Gets or sets the date and time when the fault occurred. (inherited from BaseServiceFault)
public property | TraceText | Gets the text of the fault trace.

See Also

Reference

OrganizationServiceFault Class
Microsoft.Xrm.Sdk Namespace
IOrganizationService


OrganizationServiceFault.InnerFault Property
[image]

Gets the fault instance that caused the current fault.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property InnerFault As OrganizationServiceFault

C#
[DataMemberAttribute]
public OrganizationServiceFault InnerFault { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationServiceFault
The fault instance that caused the current fault.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceFault Class
OrganizationServiceFault Members
Microsoft.Xrm.Sdk Namespace


OrganizationServiceFault.TraceText Property
[image]

Gets the text of the fault trace.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TraceText As String

C#
[DataMemberAttribute]
public string TraceText { get; set; }

C++

J#

JScript

Property Value
Type: String
The text of the fault trace.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceFault Class
OrganizationServiceFault Members
Microsoft.Xrm.Sdk Namespace


ParameterCollection Class
See Also Members
[image]

Provides a collection of parameters for a request.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="ParameterCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<KnownTypeAttribute("GetKnownParameterTypes")> _
Public NotInheritable Class ParameterCollection
    Inherits DataCollection(Of String, Object)

C#
[CollectionDataContractAttribute(Name="ParameterCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[KnownTypeAttribute("GetKnownParameterTypes")]
public sealed class ParameterCollection : DataCollection<string,Object>

C++

J#

JScript

  Remarks
For each parameter in the collection there is a key/value pair. The key is the name of the request parameter as defined in the message.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.ParameterCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterCollection Members
Microsoft.Xrm.Sdk Namespace
Other Resources
SdkMessage Entity Messages and Methods


ParameterCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Provides a collection of parameters for a request.

The following tables list the members exposed by the ParameterCollection type.

Public Constructors

Name | Description
ParameterCollection | Initializes a new instance of the ParameterCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

ParameterCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

SdkMessage Entity Messages and Methods


ParameterCollection Constructor
[image]

Initializes a new instance of the ParameterCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ParameterCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterCollection Class
ParameterCollection Members
Microsoft.Xrm.Sdk Namespace


ParameterCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

ParameterCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

SdkMessage Entity Messages and Methods


ParameterCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

ParameterCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

SdkMessage Entity Messages and Methods


QuickFindConfiguration Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class QuickFindConfiguration

C#
public sealed class QuickFindConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.QuickFindConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindConfiguration Members
Microsoft.Xrm.Sdk Namespace


QuickFindConfiguration Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the QuickFindConfiguration type.

Public Constructors

Name | Description
QuickFindConfiguration | Overloaded. For internal use only.
Top

Public Properties

 | Name | Description
public property | EntityName | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QuickFindConfiguration Class
Microsoft.Xrm.Sdk Namespace


QuickFindConfiguration Constructor
[image]

For internal use only.

Overload List

Name | Description
QuickFindConfiguration () | For internal use only.
QuickFindConfiguration (String) | For internal use only.

See Also

Reference

QuickFindConfiguration Class
QuickFindConfiguration Members
Microsoft.Xrm.Sdk Namespace


QuickFindConfiguration Constructor ()
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QuickFindConfiguration ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindConfiguration Class
QuickFindConfiguration Members
Microsoft.Xrm.Sdk Namespace


QuickFindConfiguration Constructor (String)
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String _
)

C#
public QuickFindConfiguration (
    string entityName
)

C++

J#

JScript

Parameters
entityName
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindConfiguration Class
QuickFindConfiguration Members
Microsoft.Xrm.Sdk Namespace


QuickFindConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QuickFindConfiguration Class
Microsoft.Xrm.Sdk Namespace


QuickFindConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | EntityName | For internal use only.

See Also

Reference

QuickFindConfiguration Class
Microsoft.Xrm.Sdk Namespace


QuickFindConfiguration.EntityName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindConfiguration Class
QuickFindConfiguration Members
Microsoft.Xrm.Sdk Namespace


QuickFindConfigurationCollection Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class QuickFindConfigurationCollection
    Inherits DataCollection(Of QuickFindConfiguration)

C#
public sealed class QuickFindConfigurationCollection : DataCollection<QuickFindConfiguration>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.QuickFindConfigurationCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindConfigurationCollection Members
Microsoft.Xrm.Sdk Namespace


QuickFindConfigurationCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

For internal use only.

The following tables list the members exposed by the QuickFindConfigurationCollection type.

Public Constructors

Name | Description
QuickFindConfigurationCollection | For internal use only.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

QuickFindConfigurationCollection Class
Microsoft.Xrm.Sdk Namespace


QuickFindConfigurationCollection Constructor
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QuickFindConfigurationCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindConfigurationCollection Class
QuickFindConfigurationCollection Members
Microsoft.Xrm.Sdk Namespace


QuickFindConfigurationCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

QuickFindConfigurationCollection Class
Microsoft.Xrm.Sdk Namespace


QuickFindConfigurationCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

QuickFindConfigurationCollection Class
Microsoft.Xrm.Sdk Namespace


QuickFindResult Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="QuickFindResult", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class QuickFindResult
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="QuickFindResult", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class QuickFindResult : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.QuickFindResult
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResult Members
Microsoft.Xrm.Sdk Namespace


QuickFindResult Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the QuickFindResult type.

Public Constructors

Name | Description
QuickFindResult | Overloaded. For internal use only.
Top

Public Properties

 | Name | Description
public property | Data | For internal use only.
public property | ErrorCode | For internal use only.
public property | ExtensionData | For internal use only.
public property | QueryColumnSet | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QuickFindResult Class
Microsoft.Xrm.Sdk Namespace


QuickFindResult Constructor
[image]

For internal use only.

Overload List

Name | Description
QuickFindResult () | For internal use only.
QuickFindResult (Int32, EntityCollection) | For internal use only.
QuickFindResult (Int32, EntityCollection, DataCollection) | For internal use only.

See Also

Reference

QuickFindResult Class
QuickFindResult Members
Microsoft.Xrm.Sdk Namespace


QuickFindResult Constructor ()
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QuickFindResult ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResult Class
QuickFindResult Members
Microsoft.Xrm.Sdk Namespace


QuickFindResult Constructor (Int32, EntityCollection)
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    error As Integer, _
    entities As EntityCollection _
)

C#
public QuickFindResult (
    int error,
    EntityCollection entities
)

C++

J#

JScript

Parameters
error
entities
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResult Class
QuickFindResult Members
Microsoft.Xrm.Sdk Namespace


QuickFindResult Constructor (Int32, EntityCollection, DataCollection)
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    error As Integer, _
    entities As EntityCollection, _
    queryColumns As DataCollection(Of String) _
)

C#
public QuickFindResult (
    int error,
    EntityCollection entities,
    DataCollection<string> queryColumns
)

C++

J#

JScript

Parameters
error
entities
queryColumns
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResult Class
QuickFindResult Members
Microsoft.Xrm.Sdk Namespace


QuickFindResult Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QuickFindResult Class
Microsoft.Xrm.Sdk Namespace


QuickFindResult Properties
[image]

Public Properties

 | Name | Description
public property | Data | For internal use only.
public property | ErrorCode | For internal use only.
public property | ExtensionData | For internal use only.
public property | QueryColumnSet | For internal use only.

See Also

Reference

QuickFindResult Class
Microsoft.Xrm.Sdk Namespace


QuickFindResult.Data Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Data As EntityCollection

C#
[DataMemberAttribute]
public EntityCollection Data { get; set; }

C++

J#

JScript

Property Value
Type: EntityCollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResult Class
QuickFindResult Members
Microsoft.Xrm.Sdk Namespace


QuickFindResult.ErrorCode Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorCode As Integer

C#
[DataMemberAttribute]
public int ErrorCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResult Class
QuickFindResult Members
Microsoft.Xrm.Sdk Namespace


QuickFindResult.ExtensionData Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResult Class
QuickFindResult Members
Microsoft.Xrm.Sdk Namespace


QuickFindResult.QueryColumnSet Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
<SuppressMessageAttribute("Microsoft.Usage", "CA2227:CollectionPropertiesShouldBeReadOnly", Justification:="Collection properties should be read only")> _
Public Property QueryColumnSet As DataCollection(Of String)

C#
[DataMemberAttribute]
[SuppressMessageAttribute("Microsoft.Usage", "CA2227:CollectionPropertiesShouldBeReadOnly", Justification="Collection properties should be read only")]
public DataCollection<string> QueryColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: DataCollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResult Class
QuickFindResult Members
Microsoft.Xrm.Sdk Namespace


QuickFindResultCollection Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Naming", "CA1704")> _
<CollectionDataContractAttribute(Name:="QuickFindResultCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class QuickFindResultCollection
    Inherits DataCollection(Of QuickFindResult)

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1704")]
[CollectionDataContractAttribute(Name="QuickFindResultCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class QuickFindResultCollection : DataCollection<QuickFindResult>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.QuickFindResultCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResultCollection Members
Microsoft.Xrm.Sdk Namespace


QuickFindResultCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

For internal use only.

The following tables list the members exposed by the QuickFindResultCollection type.

Public Constructors

Name | Description
QuickFindResultCollection | For internal use only.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

QuickFindResultCollection Class
Microsoft.Xrm.Sdk Namespace


QuickFindResultCollection Constructor
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QuickFindResultCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QuickFindResultCollection Class
QuickFindResultCollection Members
Microsoft.Xrm.Sdk Namespace


QuickFindResultCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

QuickFindResultCollection Class
Microsoft.Xrm.Sdk Namespace


QuickFindResultCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

QuickFindResultCollection Class
Microsoft.Xrm.Sdk Namespace


RelatedEntityCollection Class
See Also Members
[image]

Contains a collection of related entities.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="RelatedEntityCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RelatedEntityCollection
    Inherits DataCollection(Of Relationship, EntityCollection)

C#
[CollectionDataContractAttribute(Name="RelatedEntityCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RelatedEntityCollection : DataCollection<Relationship,EntityCollection>

C++

J#

JScript

  Remarks
For each related entity in the collection there is a key/value pair.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.RelatedEntityCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelatedEntityCollection Members
Microsoft.Xrm.Sdk Namespace


RelatedEntityCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a collection of related entities.

The following tables list the members exposed by the RelatedEntityCollection type.

Public Constructors

Name | Description
RelatedEntityCollection | Initializes a new instance of the RelatedEntityCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Overridden. Gets a value indicating whether the RelatedEntityCollection is read-only.
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

RelatedEntityCollection Class
Microsoft.Xrm.Sdk Namespace


RelatedEntityCollection Constructor
[image]

Initializes a new instance of the RelatedEntityCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RelatedEntityCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelatedEntityCollection Class
RelatedEntityCollection Members
Microsoft.Xrm.Sdk Namespace


RelatedEntityCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

RelatedEntityCollection Class
Microsoft.Xrm.Sdk Namespace


RelatedEntityCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Overridden. Gets a value indicating whether the RelatedEntityCollection is read-only.
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

RelatedEntityCollection Class
Microsoft.Xrm.Sdk Namespace


RelatedEntityCollection.IsReadOnly Property
[image]

Gets a value indicating whether the RelatedEntityCollection is read-only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Property IsReadOnly As Boolean

C#
public override bool IsReadOnly { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the RelatedEntityCollection is read-only; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelatedEntityCollection Class
RelatedEntityCollection Members
Microsoft.Xrm.Sdk Namespace


Relationship Class
See Also Members
[image]

Represents a relationship between two entities.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="Relationship", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class Relationship
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="Relationship", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class Relationship : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Relationship
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Relationship Members
Microsoft.Xrm.Sdk Namespace
RelationshipMetadataBase
OneToManyRelationshipMetadata
ManyToManyRelationshipMetadata
Other Resources
Customize Entity Relationship Metadata


Relationship Members
See Also Constructors Methods Properties
[image]

Represents a relationship between two entities.

The following tables list the members exposed by the Relationship type.

Public Constructors

Name | Description
Relationship | Overloaded. Initializes a new instance of the Relationship class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PrimaryEntityRole | Gets or sets the entity role: referenced or referencing.
public property | SchemaName | Gets or sets the name of the relationship.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Serves as a hash function for this type.
public method | GetType | (inherited from Object)
public method | ToString | Overridden. Returns a String that represents the current Relationship.
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Relationship Class
Microsoft.Xrm.Sdk Namespace
RelationshipMetadataBase
OneToManyRelationshipMetadata
ManyToManyRelationshipMetadata

Other Resources

Customize Entity Relationship Metadata


Relationship Constructor
[image]

Initializes a new instance of the Relationship class.

Overload List

Name | Description
Relationship () | Initializes a new instance of the Relationship class.
Relationship (String) | Initializes a new instance of the Relationship class setting the schema name property.

See Also

Reference

Relationship Class
Relationship Members
Microsoft.Xrm.Sdk Namespace


Relationship Constructor ()
[image]

Initializes a new instance of the Relationship class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public Relationship ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Relationship Class
Relationship Members
Microsoft.Xrm.Sdk Namespace


Relationship Constructor (String)
[image]

Initializes a new instance of the Relationship class setting the schema name property.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public Relationship (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String. The name of the relationship.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Relationship Class
Relationship Members
Microsoft.Xrm.Sdk Namespace


Relationship Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Serves as a hash function for this type.
public method | GetType | (inherited from Object)
public method | ToString | Overridden. Returns a String that represents the current Relationship.

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Relationship Class
Microsoft.Xrm.Sdk Namespace
RelationshipMetadataBase
OneToManyRelationshipMetadata
ManyToManyRelationshipMetadata

Other Resources

Customize Entity Relationship Metadata


Relationship.Equals Method
[image]

Determines whether two instances are equal.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

C#
public override bool Equals (
    Object obj
)

C++

J#

JScript

Parameters
obj
Type: Object. The Relationship to compare with the current Relationship.
Return Value
Type: Boolean
true if the specified Relationship is equal to the Relationship Object; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Relationship Class
Relationship Members
Microsoft.Xrm.Sdk Namespace


Relationship.GetHashCode Method
[image]

Serves as a hash function for this type.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function GetHashCode As Integer

C#
public override int GetHashCode ()

C++

J#

JScript

Return Value
Type: Int32

The hash code for the current Relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Relationship Class
Relationship Members
Microsoft.Xrm.Sdk Namespace


Relationship.ToString Method
[image]

Returns a String that represents the current Relationship.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function ToString As String

C#
public override string ToString ()

C++

J#

JScript

Return Value
Type: String

The name of the current Relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Relationship Class
Relationship Members
Microsoft.Xrm.Sdk Namespace


Relationship Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PrimaryEntityRole | Gets or sets the entity role: referenced or referencing.
public property | SchemaName | Gets or sets the name of the relationship.

See Also

Reference

Relationship Class
Microsoft.Xrm.Sdk Namespace
RelationshipMetadataBase
OneToManyRelationshipMetadata
ManyToManyRelationshipMetadata

Other Resources

Customize Entity Relationship Metadata


Relationship.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject

The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Relationship Class
Relationship Members
Microsoft.Xrm.Sdk Namespace


Relationship.PrimaryEntityRole Property
[image]

Gets or sets the entity role: referenced or referencing.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PrimaryEntityRole As Nullable(Of EntityRole)

C#
[DataMemberAttribute]
public Nullable<EntityRole> PrimaryEntityRole { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<EntityRole>

The entity role.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Relationship Class
Relationship Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Types of Entity Relationships


Relationship.SchemaName Property
[image]

Gets or sets the name of the relationship.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SchemaName As String

C#
[DataMemberAttribute]
public string SchemaName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the relationship as defined defined in the SchemaName property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Relationship Class
Relationship Members
Microsoft.Xrm.Sdk Namespace


RelationshipQueryCollection Class
See Also Members
[image]

Provides a collection of relationship queries.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="RelationshipQueryCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RelationshipQueryCollection
    Inherits DataCollection(Of Relationship, QueryBase)

C#
[CollectionDataContractAttribute(Name="RelationshipQueryCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RelationshipQueryCollection : DataCollection<Relationship,QueryBase>

C++

J#

JScript

  Remarks
For each relationship query in the collection there is a key/value pair. The key is the logical name of the relationship.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.RelationshipQueryCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipQueryCollection Members
Microsoft.Xrm.Sdk Namespace
RelatedEntitiesQuery


RelationshipQueryCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Provides a collection of relationship queries.

The following tables list the members exposed by the RelationshipQueryCollection type.

Public Constructors

Name | Description
RelationshipQueryCollection | Initializes a new instance of the RelationshipQueryCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

RelationshipQueryCollection Class
Microsoft.Xrm.Sdk Namespace
RelatedEntitiesQuery


RelationshipQueryCollection Constructor
[image]

Initializes a new instance of the RelationshipQueryCollection class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RelationshipQueryCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipQueryCollection Class
RelationshipQueryCollection Members
Microsoft.Xrm.Sdk Namespace


RelationshipQueryCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

RelationshipQueryCollection Class
Microsoft.Xrm.Sdk Namespace
RelatedEntitiesQuery


RelationshipQueryCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

RelationshipQueryCollection Class
Microsoft.Xrm.Sdk Namespace
RelatedEntitiesQuery


RelationshipSchemaNameAttribute Class
See Also Members
[image]

Used by the code generation tool to create classes based on entities.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Property)> _
<SuppressMessageAttribute("Microsoft.Design", "CA1019:DefineAccessorsForAttributeArguments", Justification:="Nullable arguments cause issues for compiler.")> _
Public NotInheritable Class RelationshipSchemaNameAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Property)]
[SuppressMessageAttribute("Microsoft.Design", "CA1019:DefineAccessorsForAttributeArguments", Justification="Nullable arguments cause issues for compiler.")]
public sealed class RelationshipSchemaNameAttribute : Attribute

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.RelationshipSchemaNameAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipSchemaNameAttribute Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use the Early Bound Entity Classes in Code


RelationshipSchemaNameAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Used by the code generation tool to create classes based on entities.

The following tables list the members exposed by the RelationshipSchemaNameAttribute type.

Public Constructors

Name | Description
RelationshipSchemaNameAttribute | Overloaded. Initializes a new instance of the RelationshipSchemaNameAttribute class
Top

Public Properties

 | Name | Description
public property | PrimaryEntityRole | Gets the entity role for the entity.
public property | SchemaName | Gets the schema name for the entity relationship.
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

RelationshipSchemaNameAttribute Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Early Bound Entity Classes in Code


RelationshipSchemaNameAttribute Constructor
[image]

Initializes a new instance of the RelationshipSchemaNameAttribute class

Overload List

Name | Description
RelationshipSchemaNameAttribute (String) | Initializes a new instance of the RelationshipSchemaNameAttribute class
RelationshipSchemaNameAttribute (String, EntityRole) | Initializes a new instance of the RelationshipSchemaNameAttribute class

See Also

Reference

RelationshipSchemaNameAttribute Class
RelationshipSchemaNameAttribute Members
Microsoft.Xrm.Sdk Namespace


RelationshipSchemaNameAttribute Constructor (String)
[image]

Initializes a new instance of the RelationshipSchemaNameAttribute class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public RelationshipSchemaNameAttribute (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name for the entity relationship.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipSchemaNameAttribute Class
RelationshipSchemaNameAttribute Members
Microsoft.Xrm.Sdk Namespace


RelationshipSchemaNameAttribute Constructor (String, EntityRole)
[image]

Initializes a new instance of the RelationshipSchemaNameAttribute class

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String, _
    primaryEntityRole As EntityRole _
)

C#
public RelationshipSchemaNameAttribute (
    string schemaName,
    EntityRole primaryEntityRole
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name for the entity relationship.
primaryEntityRole
Type: EntityRoleThe entity role for the entity.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipSchemaNameAttribute Class
RelationshipSchemaNameAttribute Members
Microsoft.Xrm.Sdk Namespace


RelationshipSchemaNameAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

RelationshipSchemaNameAttribute Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Early Bound Entity Classes in Code


RelationshipSchemaNameAttribute Properties
[image]

Public Properties

 | Name | Description
public property | PrimaryEntityRole | Gets the entity role for the entity.
public property | SchemaName | Gets the schema name for the entity relationship.
public property | TypeId | (inherited from Attribute)

See Also

Reference

RelationshipSchemaNameAttribute Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Early Bound Entity Classes in Code


RelationshipSchemaNameAttribute.PrimaryEntityRole Property
[image]

Gets the entity role for the entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property PrimaryEntityRole As Nullable(Of EntityRole)

C#
public Nullable<EntityRole> PrimaryEntityRole { get; }

C++

J#

JScript

Property Value
Type: EntityRole
The entity role for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipSchemaNameAttribute Class
RelationshipSchemaNameAttribute Members
Microsoft.Xrm.Sdk Namespace


RelationshipSchemaNameAttribute.SchemaName Property
[image]

Gets the schema name for the entity relationship.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property SchemaName As String

C#
public string SchemaName { get; }

C++

J#

JScript

Property Value
Type: String

The schema name for the entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipSchemaNameAttribute Class
RelationshipSchemaNameAttribute Members
Microsoft.Xrm.Sdk Namespace


RemoteExecutionContext Class
See Also Members
[image]

Defines the contextual information sent to a remote service endpoint at run-time.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<KnownTypeAttribute("GetKnownParameterTypes")> _
Public NotInheritable Class RemoteExecutionContext
    Implements IPluginExecutionContext, IExecutionContext, IExtensibleDataObject

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[KnownTypeAttribute("GetKnownParameterTypes")]
public sealed class RemoteExecutionContext : IPluginExecutionContext, IExecutionContext, IExtensibleDataObject

C++

J#

JScript

  Remarks
A populated RemoteExecutionContext instance is passed from Microsoft Dynamics CRM to a Microsoft Azure Service Bus solution listener. The remote execution context contains the same information that is passed to an asynchronous registered Microsoft Dynamics CRM plug-in plus some additional information.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.RemoteExecutionContext
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext
Other Resources
Write a Listener for a Windows Azure Solution


RemoteExecutionContext Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Defines the contextual information sent to a remote service endpoint at run-time.

The following tables list the members exposed by the RemoteExecutionContext type.

Public Constructors

Name | Description
RemoteExecutionContext | Initializes a new instance of the RemoteExecutionContext class.
Top

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the global unique identifier of the business unit that the entity currently being processed by the event execution pipeline belongs to.
public property | CorrelationId | Gets the global unique identifier for tracking plug-in execution.
public property | Depth | Gets the current depth of execution in the call stack.
public property | ExtensionData | A structure that contains extra data.
public property | InitiatingUserId | Gets the global unique identifier of the system user account under which the current pipeline is executing.
public property | InputParameters | Gets the parameters of the request message that triggered the event that caused the plug-in to execute.
public property | IsExecutingOffline | Gets a value indicating if the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline.
public property | IsInTransaction | Gets a value indicating if the plug-in is executing within the database transaction.
public property | IsOfflinePlayback | Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server.
public property | IsolationMode | Gets a value indicating if the plug-in is executing in the sandbox.
public property | MessageName | Gets the name of the Web service message that is being processed by the event execution pipeline.
public property | Mode | Gets the mode of plug-in execution.
public property | OperationCreatedOn | Gets the date and time that the related System Job was created.
public property | OperationId | Gets the global unique identifier of the related System Job.
public property | OrganizationId | Gets the global unique identifier of the organization that the entity belongs to and the plug-in executes under.
public property | OrganizationName | Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under.
public property | OutputParameters | Gets the parameters of the response message after the core platform operation has completed.
public property | OwningExtension | Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint.
public property | ParentContext | Gets the remote execution context from the parent operation.
public property | PostEntityImages | Gets the properties of the primary entity after the core platform operation has been completed.
public property | PreEntityImages | Gets the properties of the primary entity before the core platform operation has begins.
public property | PrimaryEntityId | Gets the global unique identifier of the primary entity for which the pipeline is processing events.
public property | PrimaryEntityName | Gets the name of the primary entity for which the pipeline is processing events.
public property | RequestId | Gets the global unique identifier of the request being processed by the event execution pipeline.
public property | SecondaryEntityName | Gets the name of the secondary entity that has a relationship with the primary entity.
public property | SharedVariables | Gets the custom properties that are shared between plug-ins.
public property | Stage | Gets the stage in the execution pipeline that a synchronous plug-in is registered for.
public property | UserId | Gets the global unique identifier of the system user for whom the plug-in invokes Web service methods on behalf of.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ParentContext | For internal use only.
Top

See Also

Reference

RemoteExecutionContext Class
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext

Other Resources

Write a Listener for a Windows Azure Solution


RemoteExecutionContext Constructor
[image]

Initializes a new instance of the RemoteExecutionContext class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RemoteExecutionContext ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace


RemoteExecutionContext Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RemoteExecutionContext Class
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext

Other Resources

Write a Listener for a Windows Azure Solution


RemoteExecutionContext Properties
[image]

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the global unique identifier of the business unit that the entity currently being processed by the event execution pipeline belongs to.
public property | CorrelationId | Gets the global unique identifier for tracking plug-in execution.
public property | Depth | Gets the current depth of execution in the call stack.
public property | ExtensionData | A structure that contains extra data.
public property | InitiatingUserId | Gets the global unique identifier of the system user account under which the current pipeline is executing.
public property | InputParameters | Gets the parameters of the request message that triggered the event that caused the plug-in to execute.
public property | IsExecutingOffline | Gets a value indicating if the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline.
public property | IsInTransaction | Gets a value indicating if the plug-in is executing within the database transaction.
public property | IsOfflinePlayback | Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server.
public property | IsolationMode | Gets a value indicating if the plug-in is executing in the sandbox.
public property | MessageName | Gets the name of the Web service message that is being processed by the event execution pipeline.
public property | Mode | Gets the mode of plug-in execution.
public property | OperationCreatedOn | Gets the date and time that the related System Job was created.
public property | OperationId | Gets the global unique identifier of the related System Job.
public property | OrganizationId | Gets the global unique identifier of the organization that the entity belongs to and the plug-in executes under.
public property | OrganizationName | Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under.
public property | OutputParameters | Gets the parameters of the response message after the core platform operation has completed.
public property | OwningExtension | Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint.
public property | ParentContext | Gets the remote execution context from the parent operation.
public property | PostEntityImages | Gets the properties of the primary entity after the core platform operation has been completed.
public property | PreEntityImages | Gets the properties of the primary entity before the core platform operation has begins.
public property | PrimaryEntityId | Gets the global unique identifier of the primary entity for which the pipeline is processing events.
public property | PrimaryEntityName | Gets the name of the primary entity for which the pipeline is processing events.
public property | RequestId | Gets the global unique identifier of the request being processed by the event execution pipeline.
public property | SecondaryEntityName | Gets the name of the secondary entity that has a relationship with the primary entity.
public property | SharedVariables | Gets the custom properties that are shared between plug-ins.
public property | Stage | Gets the stage in the execution pipeline that a synchronous plug-in is registered for.
public property | UserId | Gets the global unique identifier of the system user for whom the plug-in invokes Web service methods on behalf of.

Explicit Interface Implementations

Name | Description
ParentContext | For internal use only.

See Also

Reference

RemoteExecutionContext Class
Microsoft.Xrm.Sdk Namespace
IPluginExecutionContext

Other Resources

Write a Listener for a Windows Azure Solution


RemoteExecutionContext.BusinessUnitId Property
[image]

Gets the global unique identifier of the business unit that the entity currently being processed by the event execution pipeline belongs to.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property BusinessUnitId As Guid

C#
[DataMemberAttribute]
public Guid BusinessUnitId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The global unique identifier of the business unit.

  Remarks
This property corresponds to the BusinessUnitId property, which is the primary key for the BusinessUnit entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
BusinessUnit Entity


RemoteExecutionContext.CorrelationId Property
[image]

Gets the global unique identifier for tracking plug-in execution.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CorrelationId As Guid

C#
[DataMemberAttribute]
public Guid CorrelationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The global unique identifier for tracking plug-in execution.

  Remarks
This property is used by the platform for infinite loop prevention. In most cases, this property can be ignored.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Depth


RemoteExecutionContext.Depth Property
[image]

Gets the current depth of execution in the call stack.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Depth As Integer

C#
[DataMemberAttribute]
public int Depth { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The current depth of execution in the call stack.

  Remarks
Used by the platform for infinite loop prevention. In most cases, this property can be ignored.
Every time a running plug-in or Workflow issues a message request to the Web services that triggers another plug-in or Workflow to execute, the Depth property of the execution context is increased. If the depth property increments to its maximum value within the configured time limit, the platform considers this behavior an infinite loop and further plug-in or Workflow execution is aborted. The maximum depth (8) and time limit (one hour) are configurable by the Microsoft Dynamics CRM administrator.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace


RemoteExecutionContext.ExtensionData Property
[image]

A structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
A structure that contains extra data.

  Remarks
Extra data that is stored in the OrganizationRequest and OrganizationResponse as they are processed by the event execution pipeline.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
ExtensionData
ExtensionData
Other Resources
Use Messages (Request and Response Classes) with the Execute Method


RemoteExecutionContext.InitiatingUserId Property
[image]

Gets the global unique identifier of the system user account under which the current pipeline is executing.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property InitiatingUserId As Guid

C#
[DataMemberAttribute]
public Guid InitiatingUserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The global unique identifier of the system user account.

  Remarks
This property corresponds to the SystemUserId property, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Impersonation in Plug-ins
User and Team Entities


RemoteExecutionContext.InputParameters Property
[image]

Gets the parameters of the request message that triggered the event that caused the plug-in to execute.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public ReadOnly Property InputParameters As ParameterCollection

C#
[DataMemberAttribute]
public ParameterCollection InputParameters { get; }

C++

J#

JScript

Property Value
Type: ParameterCollection
 The parameters of the request message that triggered the event.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
OutputParameters
Other Resources
Understand the Data Context Passed to a Plug-in
Use Messages (Request and Response Classes) with the Execute Method


RemoteExecutionContext.IsExecutingOffline Property
[image]

Gets a value indicating if the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsExecutingOffline As Boolean

C#
[DataMemberAttribute]
public bool IsExecutingOffline { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the client is offline; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
IsOfflinePlayback
Other Resources
Write a Plug-in


RemoteExecutionContext.IsInTransaction Property
[image]

Gets a value indicating if the plug-in is executing within the database transaction.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsInTransaction As Boolean

C#
[DataMemberAttribute]
public bool IsInTransaction { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the plug-in is executing within the database transaction; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Event Execution Pipeline


RemoteExecutionContext.IsOfflinePlayback Property
[image]

Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsOfflinePlayback As Boolean

C#
[DataMemberAttribute]
public bool IsOfflinePlayback { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the plug-in is executing as a result of the client synchronizing with the Microsoft Dynamics CRM server; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
IsExecutingOffline


RemoteExecutionContext.IsolationMode Property
[image]

Gets a value indicating if the plug-in is executing in the sandbox.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsolationMode As Integer

C#
[DataMemberAttribute]
public int IsolationMode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
A value indicating if the plug-in is executing in the sandbox. Valid values are 1 (none) or 2 (sandbox).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Plug-in Isolation, Trust, and Statistics


RemoteExecutionContext.MessageName Property
[image]

Gets the name of the Web service message that is being processed by the event execution pipeline.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MessageName As String

C#
[DataMemberAttribute]
public string MessageName { get; set; }

C++

J#

JScript

Property Value
Type:  String
The name of the Web service message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Supported Messages and Entities for Plug-ins


RemoteExecutionContext.ParentContext Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Private ReadOnly Property Microsoft.Xrm.Sdk.IPluginExecutionContext.ParentContext As IPluginExecutionContext Implements IPluginExecutionContext.ParentContext

C#
IPluginExecutionContext IPluginExecutionContext.ParentContext { get; }

C++

J#

JScript

Property Value
Type: IPluginExecutionContext
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace


RemoteExecutionContext.Mode Property
[image]

Gets the mode of plug-in execution.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Mode As Integer

C#
[DataMemberAttribute]
public int Mode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The mode of plug-in execution. Valid values are 0 (synchronous) and 1 (asynchronous).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Event Execution Pipeline


RemoteExecutionContext.OperationCreatedOn Property
[image]

Gets the date and time that the related System Job was created.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OperationCreatedOn As DateTime

C#
[DataMemberAttribute]
public DateTime OperationCreatedOn { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The date and time the related System Job was created.

  Remarks
This property is used for the Microsoft Dynamics CRM to Windows Azure integration feature. It contains the same date and time value as the CreatedOn property of the related System Job entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
OperationId
Other Resources
AsyncOperation (System Job) Entity
Introduction to Windows Azure Integration with Microsoft Dynamics CRM


RemoteExecutionContext.OperationId Property
[image]

Gets the global unique identifier of the related System Job.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OperationId As Guid

C#
[DataMemberAttribute]
public Guid OperationId { get; set; }

C++

J#

JScript

Property Value
Type:  Guid
The global unique identifier of the related System Job.

  Remarks
This property is used for the Microsoft Dynamics CRM to Windows Azure integration feature. It contains the same ID as the AsyncOperationId property of the related System Job entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
OperationCreatedOn
Other Resources
AsyncOperation (System Job) Entity
Introduction to Windows Azure Integration with Microsoft Dynamics CRM


RemoteExecutionContext.OrganizationId Property
[image]

Gets the global unique identifier of the organization that the entity belongs to and the plug-in executes under.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrganizationId As Guid

C#
[DataMemberAttribute]
public Guid OrganizationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The global unique identifier of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Organization Entities


RemoteExecutionContext.OrganizationName Property
[image]

Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrganizationName As String

C#
[DataMemberAttribute]
public string OrganizationName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name of the organization.

  Remarks
See the Organization.Name attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Organization Entities


RemoteExecutionContext.OutputParameters Property
[image]

Gets the parameters of the response message after the core platform operation has completed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public ReadOnly Property OutputParameters As ParameterCollection

C#
[DataMemberAttribute]
public ParameterCollection OutputParameters { get; }

C++

J#

JScript

Property Value
Type: ParameterCollection
The parameters of the response message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
InputParameters
Other Resources
Understand the Data Context Passed to a Plug-in
Use Messages (Request and Response Classes) with the Execute Method


RemoteExecutionContext.OwningExtension Property
[image]

Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OwningExtension As EntityReference

C#
[DataMemberAttribute]
public EntityReference OwningExtension { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The reference to the related SdkMessageProcessingingStep or ServiceEndpoint.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Plug-in Registration Entities
Send Microsoft Dynamics CRM Data over the AppFabric Service Bus


RemoteExecutionContext.ParentContext Property
[image]

Gets the remote execution context from the parent operation.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ParentContext As RemoteExecutionContext

C#
[DataMemberAttribute]
public RemoteExecutionContext ParentContext { get; set; }

C++

J#

JScript

Property Value
Type: RemoteExecutionContext
The remote execution context from the parent operation.

  Remarks
This property may be populated for a plug-in registered in stage 20 or 40 when a Create, Update, Delete, or RetrieveExchangeRate request is processed by the execution pipeline.
Certain message requests require the platform to internally generate another message request, and hence another execution pipeline, to complete processing of the original request. For example, pipeline execution of the AssignRequest results in the internal generation of an UpdateRequest. Any plug-in registered in stage 20 or 40 for an update request will have the ParentContext property set to the remote execution context of the original assign request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Event Execution Pipeline
Pass Data Between Plug-ins


RemoteExecutionContext.PostEntityImages Property
[image]

Gets the properties of the primary entity after the core platform operation has been completed.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public ReadOnly Property PostEntityImages As EntityImageCollection

C#
[DataMemberAttribute]
public EntityImageCollection PostEntityImages { get; }

C++

J#

JScript

Property Value
Type: EntityImageCollection
The properties of the primary entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
PreEntityImages
Other Resources
Understand the Data Context Passed to a Plug-in


RemoteExecutionContext.PreEntityImages Property
[image]

Gets the properties of the primary entity before the core platform operation has begins.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public ReadOnly Property PreEntityImages As EntityImageCollection

C#
[DataMemberAttribute]
public EntityImageCollection PreEntityImages { get; }

C++

J#

JScript

Property Value
Type: EntityImageCollection
The properties of the primary entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
PostEntityImages
Other Resources
Understand the Data Context Passed to a Plug-in


RemoteExecutionContext.PrimaryEntityId Property
[image]

Gets the global unique identifier of the primary entity for which the pipeline is processing events.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PrimaryEntityId As Guid

C#
[DataMemberAttribute]
public Guid PrimaryEntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The global unique identifier of the primary entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Event Execution Pipeline


RemoteExecutionContext.PrimaryEntityName Property
[image]

Gets the name of the primary entity for which the pipeline is processing events.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PrimaryEntityName As String

C#
[DataMemberAttribute]
public string PrimaryEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the primary entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
SecondaryEntityName
Other Resources
Event Execution Pipeline


RemoteExecutionContext.RequestId Property
[image]

Gets the global unique identifier of the request being processed by the event execution pipeline.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RequestId As Nullable(Of Guid)

C#
[DataMemberAttribute]
public Nullable<Guid> RequestId { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Guid
>
The global unique identifier of the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use Messages (Request and Response Classes) with the Execute Method
Event Execution Pipeline


RemoteExecutionContext.SecondaryEntityName Property
[image]

Gets the name of the secondary entity that has a relationship with the primary entity.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SecondaryEntityName As String

C#
[DataMemberAttribute]
public string SecondaryEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the secondary entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
PrimaryEntityName


RemoteExecutionContext.SharedVariables Property
[image]

Gets the custom properties that are shared between plug-ins.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public ReadOnly Property SharedVariables As ParameterCollection

C#
[DataMemberAttribute]
public ParameterCollection SharedVariables { get; }

C++

J#

JScript

Property Value
Type: ParameterCollection
The custom properties that are shared between plug-ins.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Pass Data Between Plug-ins


RemoteExecutionContext.Stage Property
[image]

Gets the stage in the execution pipeline that a synchronous plug-in is registered for.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Stage As Integer

C#
[DataMemberAttribute]
public int Stage { get; set; }

C++

J#

JScript

Property Value
Type: Int32
. Valid values are 10, 20, 40, and 50The stage in the execution pipeline that a synchronous plug-in is registered for.

  Remarks
A stage identifies when a registered synchronous plug-in is to execute during the processing of a message request. Plug-ins can be further ordered within a stage using the SdkMessageProcessingStep.Rank attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Plug-in Registration Entities
Event Execution Pipeline


RemoteExecutionContext.UserId Property
[image]

Gets the global unique identifier of the system user for whom the plug-in invokes Web service methods on behalf of.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UserId As Guid

C#
[DataMemberAttribute]
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The global unique identifier of the system user.

  Remarks
This property corresponds to the SystemUserId property, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RemoteExecutionContext Class
RemoteExecutionContext Members
Microsoft.Xrm.Sdk Namespace
Other Resources
User and Team Entities


SaveChangesException Class
See Also Members
[image]

Represents an exception that occurred when saving changes to the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class SaveChangesException
    Inherits Exception

C#
[SerializableAttribute]
public sealed class SaveChangesException : Exception

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Exception
    Microsoft.Xrm.Sdk.SaveChangesException
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace
SaveChanges


SaveChangesException Members
See Also Constructors Methods Properties Events
[image]

Represents an exception that occurred when saving changes to the OrganizationServiceContext.

The following tables list the members exposed by the SaveChangesException type.

Public Constructors

Name | Description
SaveChangesException | Overloaded. Overloaded constructor that initializes a new instance of the SaveChangesException class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Data | (inherited from Exception)
public property | HelpLink | (inherited from Exception)
public property | InnerException | (inherited from Exception)
public property | Message | (inherited from Exception)
public property | Results | Gets the results from a SaveChanges method call.
public property | Source | (inherited from Exception)
public property | StackTrace | (inherited from Exception)
public property | TargetSite | (inherited from Exception)
Top

Protected Properties

 | Name | Description
protected property | HResult | (inherited from Exception)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetBaseException | (inherited from Exception)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | Overridden. Sets the SerializationInfo with information about the exception.
public method | GetType | (inherited from Exception)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Protected Events

 | Name | Description
protected event | SerializeObjectState | (inherited from Exception)
Top

See Also

Reference

SaveChangesException Class
Microsoft.Xrm.Sdk Namespace
SaveChanges


SaveChangesException Constructor
[image]

Overloaded constructor that initializes a new instance of the SaveChangesException class.

Overload List

Name | Description
SaveChangesException () | Initializes a new instance of the SaveChangesException class.
SaveChangesException (SaveChangesResultCollection) | Initializes a new instance of the SaveChangesException class using SaveChanges method call results.
SaveChangesException (Exception, SaveChangesResultCollection) | Initializes a new instance of the SaveChangesException class using an inner exception and SaveChanges method call results.
SaveChangesException (String) | Initializes a new instance of the SaveChangesException class with an error message.
SaveChangesException (String, SaveChangesResultCollection) | Initializes a new instance of the SaveChangesException class using an error message and SaveChanges method call results.
SaveChangesException (String, Exception) | Initializes a new instance of the SaveChangesException class with and error message and an inner exception.
SaveChangesException (String, Exception, SaveChangesResultCollection) | Initializes a new instance of the SaveChangesException class with and error message, an inner exception, and SaveChanges method call results.

See Also

Reference

SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Constructor ()
[image]

Initializes a new instance of the SaveChangesException class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SaveChangesException ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Constructor (SaveChangesResultCollection)
[image]

Initializes a new instance of the SaveChangesException class using SaveChanges method call results.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    results As SaveChangesResultCollection _
)

C#
public SaveChangesException (
    SaveChangesResultCollection results
)

C++

J#

JScript

Parameters
results
Type: SaveChangesResultCollection. The results returned from a SaveChanges call.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Constructor (Exception, SaveChangesResultCollection)
[image]

Initializes a new instance of the SaveChangesException class using an inner exception and SaveChanges method call results.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    innerException As Exception, _
    results As SaveChangesResultCollection _
)

C#
public SaveChangesException (
    Exception innerException,
    SaveChangesResultCollection results
)

C++

J#

JScript

Parameters
innerException
Type: Exception. The inner exception that is the cause of this exception.
results
Type: SaveChangesResultCollection. The results returned from a SaveChanges call.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Constructor (String)
[image]

Initializes a new instance of the SaveChangesException class with an error message.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String _
)

C#
public SaveChangesException (
    string message
)

C++

J#

JScript

Parameters
message
Type: String. The error message that explains the reason for the exception.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Constructor (String, SaveChangesResultCollection)
[image]

Initializes a new instance of the SaveChangesException class using an error message and SaveChanges method call results.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String, _
    results As SaveChangesResultCollection _
)

C#
public SaveChangesException (
    string message,
    SaveChangesResultCollection results
)

C++

J#

JScript

Parameters
message
Type: String. The error message that explains the reason for the exception.
results
Type: SaveChangesResultCollection. The results returned from a SaveChanges call.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Constructor (String, Exception)
[image]

Initializes a new instance of the SaveChangesException class with and error message and an inner exception.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String, _
    exception As Exception _
)

C#
public SaveChangesException (
    string message,
    Exception exception
)

C++

J#

JScript

Parameters
message
Type: String. The error message that explains the reason for the exception.
exception
Type: Exception. The inner exception that is the cause of this exception.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Constructor (String, Exception, SaveChangesResultCollection)
[image]

Initializes a new instance of the SaveChangesException class with and error message, an inner exception, and SaveChanges method call results.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception, _
    results As SaveChangesResultCollection _
)

C#
public SaveChangesException (
    string message,
    Exception innerException,
    SaveChangesResultCollection results
)

C++

J#

JScript

Parameters
message
Type: String. The error message that explains the reason for the exception.
innerException
Type: Exception. The inner exception that is the cause of this exception.
results
Type: SaveChangesResultCollection. The results returned from a SaveChanges call.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetBaseException | (inherited from Exception)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | Overridden. Sets the SerializationInfo with information about the exception.
public method | GetType | (inherited from Exception)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SaveChangesException Class
Microsoft.Xrm.Sdk Namespace
SaveChanges


SaveChangesException.GetObjectData Method
[image]

Sets the SerializationInfo with information about the exception.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecurityCriticalAttribute> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

C#
[SecurityCriticalAttribute]
public override void GetObjectData (
    SerializationInfo info,
    StreamingContext context
)

C++

J#

JScript

Parameters
info
Type: SerializationInfo. The serialized object data about the exception being thrown.
context
Type: StreamingContext. The contextual information about the source or destination.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Data | (inherited from Exception)
public property | HelpLink | (inherited from Exception)
public property | InnerException | (inherited from Exception)
public property | Message | (inherited from Exception)
public property | Results | Gets the results from a SaveChanges method call.
public property | Source | (inherited from Exception)
public property | StackTrace | (inherited from Exception)
public property | TargetSite | (inherited from Exception)

Protected Properties

 | Name | Description
protected property | HResult | (inherited from Exception)

See Also

Reference

SaveChangesException Class
Microsoft.Xrm.Sdk Namespace
SaveChanges


SaveChangesException.Results Property
[image]

Gets the results from a SaveChanges method call.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Results As SaveChangesResultCollection

C#
public SaveChangesResultCollection Results { get; }

C++

J#

JScript

Property Value
Type: SaveChangesResultCollection
The collection of results.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesException Class
SaveChangesException Members
Microsoft.Xrm.Sdk Namespace


SaveChangesException Events
[image]

Protected Events

 | Name | Description
protected event | SerializeObjectState | (inherited from Exception)

See Also

Reference

SaveChangesException Class
Microsoft.Xrm.Sdk Namespace
SaveChanges


SaveChangesResult Class
See Also Members
[image]

Contains the result of the save changes operation returned from the organization web service.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SaveChangesResult

C#
public sealed class SaveChangesResult

C++

J#

JScript

  Remarks
This class is only used in conjunction with OrganizationServiceContext. An instance of this class is returned when SaveChanges is called.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.SaveChangesResult
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesResult Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use the Organization Service Context Class


SaveChangesResult Members
See Also Methods Properties
[image]

Contains the result of the save changes operation returned from the organization web service.

The following tables list the members exposed by the SaveChangesResult type.

Public Properties

 | Name | Description
public property | Error | Gets the exception that occurred when a message request was processed by the organization web service.
public property | Request | Gets the message request that was submitted to the organization web service.
public property | Response | Gets the result of a successful operation against the organization web server.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SaveChangesResult Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Organization Service Context Class


SaveChangesResult Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SaveChangesResult Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Organization Service Context Class


SaveChangesResult Properties
[image]

Public Properties

 | Name | Description
public property | Error | Gets the exception that occurred when a message request was processed by the organization web service.
public property | Request | Gets the message request that was submitted to the organization web service.
public property | Response | Gets the result of a successful operation against the organization web server.

See Also

Reference

SaveChangesResult Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Organization Service Context Class


SaveChangesResult.Error Property
[image]

Gets the exception that occurred when a message request was processed by the organization web service.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Error As Exception

C#
public Exception Error { get; }

C++

J#

JScript

Property Value
Type: Exception
The exception that occurred.

  Remarks
This property is only set when an exception occurs.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesResult Class
SaveChangesResult Members
Microsoft.Xrm.Sdk Namespace


SaveChangesResult.Request Property
[image]

Gets the message request that was submitted to the organization web service.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Request As OrganizationRequest

C#
public OrganizationRequest Request { get; }

C++

J#

JScript

Property Value
Type: OrganizationRequest
The request instance that was submitted.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesResult Class
SaveChangesResult Members
Microsoft.Xrm.Sdk Namespace


SaveChangesResult.Response Property
[image]

Gets the result of a successful operation against the organization web server.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Response As OrganizationResponse

C#
public OrganizationResponse Response { get; }

C++

J#

JScript

Property Value
Type: OrganizationResponse
The response to the request.

  Remarks
This property is set to a null value when the Error property is set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesResult Class
SaveChangesResult Members
Microsoft.Xrm.Sdk Namespace


SaveChangesResultCollection Class
See Also Members
[image]

Provides a collection of results for a save changes operation.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SaveChangesResultCollection
    Inherits Collection(Of SaveChangesResult)

C#
public sealed class SaveChangesResultCollection : Collection<SaveChangesResult>

C++

J#

JScript

  Remarks
Returned from these methods:  OnSaveChanges, SaveChanges

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection
    Microsoft.Xrm.Sdk.SaveChangesResultCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesResultCollection Members
Microsoft.Xrm.Sdk Namespace
Other Resources
Use the Organization Service Context Class
Sample: Use the Organization Service Context


SaveChangesResultCollection Members
See Also Methods Properties Explicit Interface Implementations
[image]

Provides a collection of results for a save changes operation.

The following tables list the members exposed by the SaveChangesResultCollection type.

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | HasError | Gets whether there is an error.
public property | Item | (inherited from Collection)
public property | Options | Gets how the SaveChanges(SaveChangesOptions) method behaves when an error occurs.
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

SaveChangesResultCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Organization Service Context Class
Sample: Use the Organization Service Context


SaveChangesResultCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

SaveChangesResultCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Organization Service Context Class
Sample: Use the Organization Service Context


SaveChangesResultCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | HasError | Gets whether there is an error.
public property | Item | (inherited from Collection)
public property | Options | Gets how the SaveChanges(SaveChangesOptions) method behaves when an error occurs.

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

SaveChangesResultCollection Class
Microsoft.Xrm.Sdk Namespace

Other Resources

Use the Organization Service Context Class
Sample: Use the Organization Service Context


SaveChangesResultCollection.HasError Property
[image]

Gets whether there is an error.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property HasError As Boolean

C#
public bool HasError { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if there is an error; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesResultCollection Class
SaveChangesResultCollection Members
Microsoft.Xrm.Sdk Namespace


SaveChangesResultCollection.Options Property
[image]

Gets how the SaveChanges(SaveChangesOptions) method behaves when an error occurs.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Options As SaveChangesOptions

C#
public SaveChangesOptions Options { get; }

C++

J#

JScript

Property Value
Type: SaveChangesOptions

The option that describes the save changes behavior.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SaveChangesResultCollection Class
SaveChangesResultCollection Members
Microsoft.Xrm.Sdk Namespace


ServiceEndpointFault Class
See Also Members
[image]

Represents a fault at a service endpoint in the cloud.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Name:="ServiceEndpointFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class ServiceEndpointFault
    Implements IExtensibleDataObject

C#
[SerializableAttribute]
[DataContractAttribute(Name="ServiceEndpointFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class ServiceEndpointFault : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.ServiceEndpointFault
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointFault Members
Microsoft.Xrm.Sdk Namespace


ServiceEndpointFault Members
See Also Constructors Methods Properties
[image]

Represents a fault at a service endpoint in the cloud.

The following tables list the members exposed by the ServiceEndpointFault type.

Public Constructors

Name | Description
ServiceEndpointFault | Overloaded. Overloaded constructor for initializing a new instance of the ServiceEndpointFault class.
Top

Public Properties

 | Name | Description
public property | ErrorDetails | Gets the details of the fault.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Message | Gets the message for the fault.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ServiceEndpointFault Class
Microsoft.Xrm.Sdk Namespace


ServiceEndpointFault Constructor
[image]

Overloaded constructor for initializing a new instance of the ServiceEndpointFault class.

Overload List

Name | Description
ServiceEndpointFault () | Initializes a new instance of the ServiceEndpointFault class.
ServiceEndpointFault (String) | Initializes a new instance of the ServiceEndpointFault class with the specified fault reason.

See Also

Reference

ServiceEndpointFault Class
ServiceEndpointFault Members
Microsoft.Xrm.Sdk Namespace


ServiceEndpointFault Constructor ()
[image]

Initializes a new instance of the ServiceEndpointFault class.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ServiceEndpointFault ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointFault Class
ServiceEndpointFault Members
Microsoft.Xrm.Sdk Namespace


ServiceEndpointFault Constructor (String)
[image]

Initializes a new instance of the ServiceEndpointFault class with the specified fault reason.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String _
)

C#
public ServiceEndpointFault (
    string message
)

C++

J#

JScript

Parameters
message
Type: String. The reason for the fault.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointFault Class
ServiceEndpointFault Members
Microsoft.Xrm.Sdk Namespace


ServiceEndpointFault Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ServiceEndpointFault Class
Microsoft.Xrm.Sdk Namespace


ServiceEndpointFault Properties
[image]

Public Properties

 | Name | Description
public property | ErrorDetails | Gets the details of the fault.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Message | Gets the message for the fault.

See Also

Reference

ServiceEndpointFault Class
Microsoft.Xrm.Sdk Namespace


ServiceEndpointFault.ErrorDetails Property
[image]

Gets the details of the fault.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorDetails As ErrorDetailCollection

C#
[DataMemberAttribute]
public ErrorDetailCollection ErrorDetails { get; set; }

C++

J#

JScript

Property Value
Type: ErrorDetailCollection
The details of the fault.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointFault Class
ServiceEndpointFault Members
Microsoft.Xrm.Sdk Namespace


ServiceEndpointFault.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointFault Class
ServiceEndpointFault Members
Microsoft.Xrm.Sdk Namespace
ExtensionData


ServiceEndpointFault.Message Property
[image]

Gets the message for the fault.

Namespace: Microsoft.Xrm.Sdk
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Message As String

C#
[DataMemberAttribute]
public string Message { get; set; }

C++

J#

JScript

Property Value
Type: String
The message for the fault.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointFault Class
ServiceEndpointFault Members
Microsoft.Xrm.Sdk Namespace


Microsoft.Xrm.Sdk.Client Namespace

Classes

Class | Description
AuthenticationCredentials | Represents client-side user logon credentials.
AuthenticationHelpers | For internal use only.
CancelEventArgs | Contains arguments for a cancel event.
ChannelEventArgs | Contains arguments for a WCF channel event.
ChannelFaultedEventArgs | Contains arguments for a faulted WCF channel event.
ClaimsPolicyConfiguration | Contains a policy configuration that identifies a Secure Token Service for use with claims authentication.
CrossRealmIssuerEndpointCollection | Contains a collection of IssuerEndpointDictionary objects.
DiscoveryServiceProxy | Implements IDiscoveryService and provides an authenticated WCF channel to the discovery service endpoint.
EndpointSwitchEventArgs | Identifies the new and previous service endpoint URL’s for an organization.
EntityLogicalNameAttribute | Identifies the logical name of an entity.
IdentityProvider | Represents an identity provider.
IdentityProviderDictionary | A collection of identity providers.
IdentityProviderTrustConfiguration | Contains the configuration information required to use an identity provider.
IdentityProviderTypeDictionary | Contains the available identity providers for a Microsoft Dynamics CRM service.
IssuerEndpoint | Represents an issuer endpoint.
IssuerEndpointDictionary | Contains a dictionary of IssuerEndpoint objects.
LiveIdentityProviderTrustConfiguration | Contains identity provider configuration information specific to Microsoft account.
LiveIdPolicyConfiguration | Contains a policy configuration that identifies a Secure Token Service for use with Microsoft account authentication.
LocalIdentityProvider | Represents an Active Directory Federation Services (ADFS) based identity provider.
OnlineFederationPolicyConfiguration | Contains Microsoft Online Services specific information for connecting to the Microsoft Dynamics CRM Online server.
OnlineIdentityProvider | Represents a Microsoft Online Services based identity provider.
OnlinePolicyConfiguration | Contains general information used when connecting to Microsoft Dynamics CRM Online.
OrganizationServiceContext | Represents the runtime context of the data service that is used to track Microsoft Dynamics CRM entities and that sends and receives entities from the server.
OrganizationServiceProxy | Implements IOrganizationService and provides an authenticated WCF channel to the organization service.
OrgIdentityProviderTrustConfiguration | Contains identity provider configuration information specific to Microsoft Online Services ID.
PolicyConfiguration | Contains a policy configuration that identifies a Secure Token Service (STS).
ProxyTypesAssemblyAttribute | Indicates that the assembly contains early-bound types generated by the CrmSvcUtil utility.
ProxyTypesBehavior | Enables early-bound entity types on a service proxy.
RealmInfo | For internal use only.
RequestProxyAttribute | Indicates the name of the message request, represented by the SdkMessageRequest entity, to which the request corresponds.
ResponseProxyAttribute | Indicates the name of the message response, represented by the SdkMessageResponse entity, to which the response corresponds.
SecurityTokenResponse | Contains a security token response.
ServiceChannel | Represents a communication channel to a Microsoft Dynamics CRM service.
ServiceConfigurationFactory | Represents a client factory for creating service configurations.
ServiceEndpointDictionary | Contains a dictionary of ServiceEndpoint objects.
ServiceEndpointMetadata | Container class for metadata information about a service.
ServiceProxy | Provides an abstract base class to encapsulate service connection operations and user authentication management.
ServiceUrls | Contains the primary and alternate endpoints of an organization.
WindowsPolicyConfiguration | Contains a policy configuration that identifies an Active Directory provider.
XrmBinding | For internal use only.

Interfaces

Interface | Description
IEndpointSwitch | Represents the switching of a web service endpoint for an organization from a primary URL to an alternate URL.
IServiceConfiguration | Represents a configured Microsoft Dynamics CRM service.
IServiceManagement | An interface which provides a simpler authentication experience.

Enumerations

Enumeration | Description
AuthenticationProviderType | Identifies the type of identity provider used for authentication.
ClientAuthenticationType | Specifies the type of authentication used by a client application.
IdentityProviderType | Specifies the supported types of identity providers.
MergeOption | Describes the synchronization option for sending or receiving entity data to or from a data service using the OrganizationServiceContext.
SaveChangesOptions | Describes how the SaveChanges method behaves when an error occurs while updating data in Microsoft Dynamics CRM.
TokenServiceCredentialType | Defines the kinds of credentials accepted by a security token service.


AuthenticationCredentials Class
See Also Members
[image]

Represents client-side user logon credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class AuthenticationCredentials

C#
public sealed class AuthenticationCredentials

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.AuthenticationCredentials
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationCredentials Members
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationCredentials Members
See Also Constructors Methods Properties
[image]

Represents client-side user logon credentials.

The following tables list the members exposed by the AuthenticationCredentials type.

Public Constructors

Name | Description
AuthenticationCredentials | Initializes a new instance of the AuthenticationCredentials class.
Top

Public Properties

 | Name | Description
public property | AppliesTo | Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification.
public property | ClientCredentials | Gets or sets the service credential authentication settings for use on the client side of communication.
public property | HomeRealm | Gets or sets the identity provider address.
public property | SecurityTokenResponse | Gets or sets the security token response.
public property | SupportingCredentials | Gets or sets additional credentials required by the site.
public property | UserPrincipalName | Gets or sets the UPN that is an internet-style login name for a user based on the Internet standard RFC 822.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AuthenticationCredentials Class
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationCredentials Constructor
[image]

Initializes a new instance of the AuthenticationCredentials class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AuthenticationCredentials ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationCredentials Class
AuthenticationCredentials Members
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationCredentials Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AuthenticationCredentials Class
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationCredentials Properties
[image]

Public Properties

 | Name | Description
public property | AppliesTo | Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification.
public property | ClientCredentials | Gets or sets the service credential authentication settings for use on the client side of communication.
public property | HomeRealm | Gets or sets the identity provider address.
public property | SecurityTokenResponse | Gets or sets the security token response.
public property | SupportingCredentials | Gets or sets additional credentials required by the site.
public property | UserPrincipalName | Gets or sets the UPN that is an internet-style login name for a user based on the Internet standard RFC 822.

See Also

Reference

AuthenticationCredentials Class
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationCredentials.AppliesTo Property
[image]

Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AppliesTo As Uri

C#
public Uri AppliesTo { get; set; }

C++

J#

JScript

Property Value
Type: URI
 The scope that a security token request applies to.

  Remarks
This property is optional. For Microsoft Dynamics CRM Online, this property value is automatically determined.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationCredentials Class
AuthenticationCredentials Members
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationCredentials.ClientCredentials Property
[image]

Gets or sets the service credential authentication settings for use on the client side of communication.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ClientCredentials As ClientCredentials

C#
public ClientCredentials ClientCredentials { get; set; }

C++

J#

JScript

Property Value
Type: ClientCredentials
 The service credential authentication settings.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationCredentials Class
AuthenticationCredentials Members
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationCredentials.HomeRealm Property
[image]

Gets or sets the identity provider address.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HomeRealm As Uri

C#
public Uri HomeRealm { get; set; }

C++

J#

JScript

Property Value
Type: URI
 The identity provider address.

  Remarks
This property is optional. For Microsoft Dynamics CRM Online, this value is automatically determined based on credentials or UPN.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationCredentials Class
AuthenticationCredentials Members
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationCredentials.SecurityTokenResponse Property
[image]

Gets or sets the security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SecurityTokenResponse As SecurityTokenResponse

C#
public SecurityTokenResponse SecurityTokenResponse { get; set; }

C++

J#

JScript

Property Value
Type: SecurityTokenResponseThe security token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationCredentials Class
AuthenticationCredentials Members
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationCredentials.SupportingCredentials Property
[image]

Gets or sets additional credentials required by the site.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SupportingCredentials As AuthenticationCredentials

C#
public AuthenticationCredentials SupportingCredentials { get; set; }

C++

J#

JScript

Property Value
Type: AuthenticationCredentialsThe additional credentials required by the site.

  Remarks
For Microsoft Dynamics CRM Online (Live ID), specify the device credentials as the value of ClientCredentials.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationCredentials Class
AuthenticationCredentials Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Active Directory and Claims-Based Authentication


AuthenticationCredentials.UserPrincipalName Property
[image]

Gets or sets the UPN that is an internet-style login name for a user based on the Internet standard RFC 822.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserPrincipalName As String

C#
public string UserPrincipalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The UPN.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationCredentials Class
AuthenticationCredentials Members
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationHelpers Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class AuthenticationHelpers

C#
[ExtensionAttribute]
public static class AuthenticationHelpers

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.AuthenticationHelpers
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationHelpers Members
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationHelpers Members
[image]

For internal use only.

The following tables list the members exposed by the AuthenticationHelpers type.

See Also

Reference

AuthenticationHelpers Class
Microsoft.Xrm.Sdk.Client Namespace


AuthenticationProviderType Enumeration
[image]

Identifies the type of identity provider used for authentication.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration AuthenticationProviderType

C#
public enum AuthenticationProviderType

C++

J#

JScript

  Members
Member name | Description
ActiveDirectory | An Active Directory identity provider. Value = 1.
Federation | A federated claims identity provider. Value = 2.
LiveId | A Microsoft account identity provider. Value = 3.
None | No identity provider. Value = 0.
OnlineFederation | An online (Office 365) federated identity provider. Value = 4.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Client Namespace


CancelEventArgs Class
See Also Members
[image]

Contains arguments for a cancel event.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustInherit Class CancelEventArgs
    Inherits EventArgs

C#
public abstract class CancelEventArgs : EventArgs

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs
    Microsoft.Xrm.Sdk.Client.CancelEventArgs

                Microsoft.Xrm.Sdk.Client.ChannelFaultedEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


CancelEventArgs Members
See Also Methods Properties Constructors
[image]

Contains arguments for a cancel event.

The following tables list the members exposed by the CancelEventArgs type.

Protected Constructors

Name | Description
CancelEventArgs | Initializes a new instance of the CancelEventArgs class.
Top

Public Properties

 | Name | Description
public property | Cancel | Gets or sets whether the event is cancelled.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CancelEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace


CancelEventArgs Constructor
[image]

Initializes a new instance of the CancelEventArgs class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected CancelEventArgs ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelEventArgs Class
CancelEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


CancelEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CancelEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace


CancelEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | Cancel | Gets or sets whether the event is cancelled.

See Also

Reference

CancelEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace


CancelEventArgs.Cancel Property
[image]

Gets or sets whether the event is cancelled.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Cancel As Boolean

C#
public bool Cancel { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the event is cancelled, otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CancelEventArgs Class
CancelEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ChannelEventArgs Class
See Also Members
[image]

Contains arguments for a WCF channel event.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ChannelEventArgs
    Inherits EventArgs

C#
public sealed class ChannelEventArgs : EventArgs

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs
    Microsoft.Xrm.Sdk.Client.ChannelEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChannelEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ChannelEventArgs Members
See Also Constructors Methods Properties
[image]

Contains arguments for a WCF channel event.

The following tables list the members exposed by the ChannelEventArgs type.

Public Constructors

Name | Description
ChannelEventArgs | Initializes a new instance of the ChannelEventArgs class using a message.
Top

Public Properties

 | Name | Description
public property | Message | Gets the message describing the event.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ChannelEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace


ChannelEventArgs Constructor
[image]

Initializes a new instance of the ChannelEventArgs class using a message.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String _
)

C#
public ChannelEventArgs (
    string message
)

C++

J#

JScript

Parameters
message
Type: String. The message describing the event.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChannelEventArgs Class
ChannelEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ChannelEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ChannelEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace


ChannelEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | Message | Gets the message describing the event.

See Also

Reference

ChannelEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace


ChannelEventArgs.Message Property
[image]

Gets the message describing the event.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Message As String

C#
public string Message { get; }

C++

J#

JScript

Property Value
Type: String
The message describing the event.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChannelEventArgs Class
ChannelEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ChannelFaultedEventArgs Class
See Also Members
[image]

Contains arguments for a faulted WCF channel event.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ChannelFaultedEventArgs
    Inherits CancelEventArgs

C#
public sealed class ChannelFaultedEventArgs : CancelEventArgs

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs

                Microsoft.Xrm.Sdk.Client.CancelEventArgs
      Microsoft.Xrm.Sdk.Client.ChannelFaultedEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChannelFaultedEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ChannelFaultedEventArgs Members
See Also Constructors Methods Properties
[image]

Contains arguments for a faulted WCF channel event.

The following tables list the members exposed by the ChannelFaultedEventArgs type.

Public Constructors

Name | Description
ChannelFaultedEventArgs | Overloaded.
Top

Public Properties

 | Name | Description
public property | Cancel | Gets or sets whether the event is cancelled. (inherited from CancelEventArgs)
public property | Exception | Gets the exception related to the event.
public property | Message | Gets the message describing the event.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ChannelFaultedEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace


ChannelFaultedEventArgs Constructor
[image]

Overload List

Name | Description
ChannelFaultedEventArgs (Exception) | Initializes a new instance of the ChannelFaultedEventArgs class using an exception.
ChannelFaultedEventArgs (String, Exception) | Initializes a new instance of the ChannelFaultedEventArgs class using message and an exception.

See Also

Reference

ChannelFaultedEventArgs Class
ChannelFaultedEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ChannelFaultedEventArgs Constructor (Exception)
[image]

Initializes a new instance of the ChannelFaultedEventArgs class using an exception.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    exception As Exception _
)

C#
public ChannelFaultedEventArgs (
    Exception exception
)

C++

J#

JScript

Parameters
exception
Type: Exception. An exception or null.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChannelFaultedEventArgs Class
ChannelFaultedEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ChannelFaultedEventArgs Constructor (String, Exception)
[image]

Initializes a new instance of the ChannelFaultedEventArgs class using message and an exception.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String, _
    exception As Exception _
)

C#
public ChannelFaultedEventArgs (
    string message,
    Exception exception
)

C++

J#

JScript

Parameters
message
Type: String. A message describing the event.
exception
Type: Exception. An exception or null.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChannelFaultedEventArgs Class
ChannelFaultedEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ChannelFaultedEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ChannelFaultedEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace


ChannelFaultedEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | Cancel | Gets or sets whether the event is cancelled. (inherited from CancelEventArgs)
public property | Exception | Gets the exception related to the event.
public property | Message | Gets the message describing the event.

See Also

Reference

ChannelFaultedEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace


ChannelFaultedEventArgs.Exception Property
[image]

Gets the exception related to the event.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Exception As Exception

C#
public Exception Exception { get; }

C++

J#

JScript

Property Value
Type: Exception
the exception related to the event.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChannelFaultedEventArgs Class
ChannelFaultedEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ChannelFaultedEventArgs.Message Property
[image]

Gets the message describing the event.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Message As String

C#
public string Message { get; }

C++

J#

JScript

Property Value
Type: String
The message describing the event.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChannelFaultedEventArgs Class
ChannelFaultedEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


ClaimsPolicyConfiguration Class
See Also Members
[image]

Contains a policy configuration that identifies a Secure Token Service for use with claims authentication.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ClaimsPolicyConfiguration
    Inherits PolicyConfiguration

C#
public sealed class ClaimsPolicyConfiguration : PolicyConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.PolicyConfiguration
    Microsoft.Xrm.Sdk.Client.ClaimsPolicyConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClaimsPolicyConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


ClaimsPolicyConfiguration Members
See Also Methods Properties
[image]

Contains a policy configuration that identifies a Secure Token Service for use with claims authentication.

The following tables list the members exposed by the ClaimsPolicyConfiguration type.

Public Properties

 | Name | Description
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ClaimsPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


ClaimsPolicyConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ClaimsPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


ClaimsPolicyConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)

See Also

Reference

ClaimsPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


ClientAuthenticationType Enumeration
[image]

Specifies the type of authentication used by a client application.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration ClientAuthenticationType

C#
public enum ClientAuthenticationType

C++

J#

JScript

  Members
Member name | Description
Kerberos | Kerberos authentication. Value = 0.
SecurityToken | A security token for use with claims authentication. Value = 1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Client Namespace


CrossRealmIssuerEndpointCollection Class
See Also Members
[image]

Contains a collection of IssuerEndpointDictionary objects.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DefaultMemberAttribute("Item")> _
Public NotInheritable Class CrossRealmIssuerEndpointCollection
    Inherits DataCollection(Of Uri, IssuerEndpointDictionary)

C#
[DefaultMemberAttribute("Item")]
public sealed class CrossRealmIssuerEndpointCollection : DataCollection<Uri,IssuerEndpointDictionary>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.Client.CrossRealmIssuerEndpointCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrossRealmIssuerEndpointCollection Members
Microsoft.Xrm.Sdk.Client Namespace


CrossRealmIssuerEndpointCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a collection of IssuerEndpointDictionary objects.

The following tables list the members exposed by the CrossRealmIssuerEndpointCollection type.

Public Constructors

Name | Description
CrossRealmIssuerEndpointCollection | Initializes a new instance of theCrossRealmIssuerEndpointCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Overridden. Gets or sets the issuer endpoint dictionary.
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

CrossRealmIssuerEndpointCollection Class
Microsoft.Xrm.Sdk.Client Namespace


CrossRealmIssuerEndpointCollection Constructor
[image]

Initializes a new instance of the CrossRealmIssuerEndpointCollection class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrossRealmIssuerEndpointCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrossRealmIssuerEndpointCollection Class
CrossRealmIssuerEndpointCollection Members
Microsoft.Xrm.Sdk.Client Namespace


CrossRealmIssuerEndpointCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

CrossRealmIssuerEndpointCollection Class
Microsoft.Xrm.Sdk.Client Namespace


CrossRealmIssuerEndpointCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Overridden. Gets or sets the issuer endpoint dictionary.
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

CrossRealmIssuerEndpointCollection Class
Microsoft.Xrm.Sdk.Client Namespace


CrossRealmIssuerEndpointCollection.Item Property
[image]

Gets or sets the issuer endpoint dictionary.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1043:UseIntegralOrStringArgumentForIndexers", Scope:="member")> _
Public Overrides Default Property Item ( _
    key As Uri _
) As IssuerEndpointDictionary

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1043:UseIntegralOrStringArgumentForIndexers", Scope="member")]
public override IssuerEndpointDictionary this [
    Uri key
] { get; set; }

C++

J#

JScript

Parameters
key
Type: URI. Specifies the key used to retrieve a IssuerEndpointDictionary object from  the collection.
Property Value
Returns IssuerEndpointDictionary.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrossRealmIssuerEndpointCollection Class
CrossRealmIssuerEndpointCollection Members
Microsoft.Xrm.Sdk.Client Namespace
CrossRealmIssuerEndpoints
CrossRealmIssuerEndpoints


DiscoveryServiceProxy Class
See Also Members
[image]

Implements IDiscoveryService and provides an authenticated WCF channel to the discovery service endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification:="This class need to be instantiated by clients and be able to derive from it.")> _
Public Class DiscoveryServiceProxy
    Inherits ServiceProxy(Of IDiscoveryService)
    Implements IDiscoveryService

C#
[SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification="This class need to be instantiated by clients and be able to derive from it.")]
public class DiscoveryServiceProxy : ServiceProxy<IDiscoveryService>, IDiscoveryService

C++

J#

JScript

  Remarks
You can make SDK calls using the IDiscoveryService interface by casting the proxy instance to a IDiscoveryService type.
  Important

                        This class is not thread safe. Microsoft Dynamics CRM Online authentication using the Microsoft Online Services environment identity provider, including Microsoft Office 365, is supported.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.ServiceProxy
    Microsoft.Xrm.Sdk.Client.DiscoveryServiceProxy
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DiscoveryServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Sample: Access the Discovery Service
Helper Code: ServerConnection Class


DiscoveryServiceProxy Members
See Also Constructors Events Methods Properties
[image]

Implements IDiscoveryService and provides an authenticated WCF channel to the discovery service endpoint.

The following tables list the members exposed by the DiscoveryServiceProxy type.

Public Constructors

Name | Description
DiscoveryServiceProxy | Overloaded. Initializes a new instance of the DiscoveryServiceProxy class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ClientCredentials | Gets the login credentials of the client. (inherited from ServiceProxy)
public property | DeviceCredentials | Gets the Windows Live credentials of a registered device. (inherited from ServiceProxy)
public property | EndpointAutoSwitchEnabled | Gets or sets a value that enables automatic switching from the organization’s current endpoint to an alternate endpoint. (inherited from ServiceProxy)
public property | EndpointSwitch | Gets the endpoint switch information from the web service configuration. (inherited from ServiceProxy)
public property | HomeRealmSecurityTokenResponse | Gets the security token response of the home realm. (inherited from ServiceProxy)
public property | HomeRealmUri | Gets the home realm URI. (inherited from ServiceProxy)
public property | IsAuthenticated | Gets a value indicating if the WCF channel has been authenticated. (inherited from ServiceProxy)
public property | SecurityTokenResponse | Gets the security token response. (inherited from ServiceProxy)
public property | ServiceChannel | Gets the communication channel used to access a Microsoft Dynamics CRM service. (inherited from ServiceProxy)
public property | ServiceConfiguration | Gets a service configuration. (inherited from ServiceProxy)
public property | ServiceManagement | Gets a service management. (inherited from ServiceProxy)
public property | Timeout | Gets or sets the maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding. (inherited from ServiceProxy)
public property | UserPrincipalName | Gets or sets the UPN that is an Internet-style login name for a user based on the Internet standard RFC 822. (inherited from ServiceProxy)
Top

Protected Properties

 | Name | Description
protected property | ChannelFactory | Gets a WCF channel factory that manages a single channel instance. (inherited from ServiceProxy)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Authenticate | Closes the service channel and channel factory if they are open, and then invokes AuthenticateCore. (inherited from ServiceProxy)
public method | AuthenticateCrossRealm | Invokes AuthenticateCrossRealmCore. (inherited from ServiceProxy)
public method | AuthenticateDevice | Invokes AuthenticateDeviceCore. (inherited from ServiceProxy)
public method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources. (inherited from ServiceProxy)
public method | Equals | (inherited from Object)
public method | Execute | See IDiscoveryService.Execute
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | SwitchToAlternateEndpoint | Switches the organization’s current endpoint to an alternate endpoint, if one is available. (inherited from ServiceProxy)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | AuthenticateCore | Authenticates the client with a service. (inherited from ServiceProxy)
protected method | AuthenticateCrossRealmCore | Authenticates a user in a realm other than the realm that the Microsoft Dynamics CRM server is located in. (inherited from ServiceProxy)
protected method | AuthenticateDeviceCore | Authenticates a device with Windows Live. (inherited from ServiceProxy)
protected method | CloseChannel | Closes a validated service channel. (inherited from ServiceProxy)
protected method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources. (inherited from ServiceProxy)
protected method | Finalize | Overridden. Implicitly frees allocated service channel and service factory resources. (inherited from Object)
protected method | HandleFailover | Overloaded. For internal use only. (inherited from ServiceProxy)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnFactoryClosed | Event handler virtual method for a channel factory that is in a closed state. (inherited from ServiceProxy)
protected method | OnFactoryFaulted | Event handler virtual method for a channel factory that is in a faulted state. (inherited from ServiceProxy)
protected method | OnFactoryOpened | Event handler virtual method for a channel factory that is in an opened state. (inherited from ServiceProxy)
protected method | ShouldRetry | Checks a message security exception to determine if a service call should be attempted again. (inherited from ServiceProxy)
protected method | ValidateAuthentication | Authenticates the client and creates a new service channel. (inherited from ServiceProxy)
Top

Public Events

 | Name | Description
public event | EndpointSwitched | Occurs when a failover recovery has completed and the organization’s current endpoint has been switched to an alternate endpoint. (inherited from ServiceProxy)
public event | EndpointSwitchRequired | Occurs when a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required. (inherited from ServiceProxy)
public event | FactoryClosed | Occurs when a channel factory is closed. (inherited from ServiceProxy)
public event | FactoryFaulted | Occurs when a channel factory is faulted. (inherited from ServiceProxy)
public event | FactoryOpened | Occurs when a channel factory is opened. (inherited from ServiceProxy)
Top

See Also

Reference

DiscoveryServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Sample: Access the Discovery Service
Helper Code: ServerConnection Class


DiscoveryServiceProxy Constructor
[image]

Initializes a new instance of the DiscoveryServiceProxy class.

Overload List

Name | Description
DiscoveryServiceProxy (IServiceConfiguration, SecurityTokenResponse) | Initializes a new instance of the DiscoveryServiceProxy class using a service configuration and a security token response.
DiscoveryServiceProxy (IServiceConfiguration, ClientCredentials) | Initializes a new instance of the DiscoveryServiceProxy class using a service configuration and client credentials.
DiscoveryServiceProxy (IServiceManagement, SecurityTokenResponse) | Initializes a new instance of the DiscoveryServiceProxy class using a service management and a security token response.
DiscoveryServiceProxy (IServiceManagement, ClientCredentials) | Initializes a new instance of the DiscoveryServiceProxy class using a service management and client credentials.
DiscoveryServiceProxy (Uri, Uri, ClientCredentials, ClientCredentials) | Initializes a new instance of the DiscoveryServiceProxy class using a discovery service URI, home realm URI, and client and device credentials.

See Also

Reference

DiscoveryServiceProxy Class
DiscoveryServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
AuthenticateCrossRealm
AuthenticateDevice


DiscoveryServiceProxy Constructor (IServiceConfiguration, SecurityTokenResponse)
[image]

Initializes a new instance of the DiscoveryServiceProxy class using a service configuration and a security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceConfiguration As IServiceConfiguration(Of IDiscoveryService), _
    securityTokenResponse As SecurityTokenResponse _
)

C#
public DiscoveryServiceProxy (
    IServiceConfiguration<IDiscoveryService> serviceConfiguration,
    SecurityTokenResponse securityTokenResponse
)

C++

J#

JScript

Parameters
serviceConfiguration
Type: IServiceConfiguration. A service configuration.
securityTokenResponse
Type: SecurityTokenResponse. A security token response.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryServiceProxy Class
DiscoveryServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
AuthenticateCrossRealm
AuthenticateDevice


DiscoveryServiceProxy Constructor (IServiceConfiguration, ClientCredentials)
[image]

Initializes a new instance of the DiscoveryServiceProxy class using a service configuration and client credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceConfiguration As IServiceConfiguration(Of IDiscoveryService), _
    clientCredentials As ClientCredentials _
)

C#
public DiscoveryServiceProxy (
    IServiceConfiguration<IDiscoveryService> serviceConfiguration,
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
serviceConfiguration
Type: IServiceConfiguration. A service configuration.
clientCredentials
Type: ClientCredentials. The logon credentials of the client.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryServiceProxy Class
DiscoveryServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
ClientCredentials Class


DiscoveryServiceProxy Constructor (IServiceManagement, SecurityTokenResponse)
[image]

Initializes a new instance of the DiscoveryServiceProxy class using a service management and a security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceManagement As IServiceManagement(Of IDiscoveryService), _
    securityTokenResponse As SecurityTokenResponse _
)

C#
public DiscoveryServiceProxy (
    IServiceManagement<IDiscoveryService> serviceManagement,
    SecurityTokenResponse securityTokenResponse
)

C++

J#

JScript

Parameters
serviceManagement
Type: IServiceConfiguration. A service management.
securityTokenResponse
Type: SecurityTokenResponse. A security token response.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryServiceProxy Class
DiscoveryServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


DiscoveryServiceProxy Constructor (IServiceManagement, ClientCredentials)
[image]

Initializes a new instance of the DiscoveryServiceProxy class using a service management and client credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceManagement As IServiceManagement(Of IDiscoveryService), _
    clientCredentials As ClientCredentials _
)

C#
public DiscoveryServiceProxy (
    IServiceManagement<IDiscoveryService> serviceManagement,
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
serviceManagement
Type: IServiceConfiguration. A service management.
clientCredentials
Type: ClientCredentials. The logon credentials of the client.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryServiceProxy Class
DiscoveryServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
ClientCredentials Class


DiscoveryServiceProxy Constructor (Uri, Uri, ClientCredentials, ClientCredentials)
[image]

Initializes a new instance of the DiscoveryServiceProxy class using a discovery service URI, home realm URI, and client and device credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    uri As Uri, _
    homeRealmUri As Uri, _
    clientCredentials As ClientCredentials, _
    deviceCredentials As ClientCredentials _
)

C#
public DiscoveryServiceProxy (
    Uri uri,
    Uri homeRealmUri,
    ClientCredentials clientCredentials,
    ClientCredentials deviceCredentials
)

C++

J#

JScript

Parameters
uri
Type: URI. The URI of the discovery service.
homeRealmUri
Type: URI. This parameter is set to a non-null value when a second ADFS instance is configured as an identity provider to the ADFS instance that Microsoft Dynamics CRM 2011 has been configured with for claims authentication. The parameter value is the URI of the WS-Trust metadata endpoint of the second ADFS instance.
clientCredentials
Type: ClientCredentials. The logon credentials of the client.
deviceCredentials
Type: ClientCredentials. The  Microsoft account device credentials.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryServiceProxy Class
DiscoveryServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
ClientCredentials Class
Helper Code: DeviceIdManager Class


DiscoveryServiceProxy Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Authenticate | Closes the service channel and channel factory if they are open, and then invokes AuthenticateCore. (inherited from ServiceProxy)
public method | AuthenticateCrossRealm | Invokes AuthenticateCrossRealmCore. (inherited from ServiceProxy)
public method | AuthenticateDevice | Invokes AuthenticateDeviceCore. (inherited from ServiceProxy)
public method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources. (inherited from ServiceProxy)
public method | Equals | (inherited from Object)
public method | Execute | See IDiscoveryService.Execute
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | SwitchToAlternateEndpoint | Switches the organization’s current endpoint to an alternate endpoint, if one is available. (inherited from ServiceProxy)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | AuthenticateCore | Authenticates the client with a service. (inherited from ServiceProxy)
protected method | AuthenticateCrossRealmCore | Authenticates a user in a realm other than the realm that the Microsoft Dynamics CRM server is located in. (inherited from ServiceProxy)
protected method | AuthenticateDeviceCore | Authenticates a device with Windows Live. (inherited from ServiceProxy)
protected method | CloseChannel | Closes a validated service channel. (inherited from ServiceProxy)
protected method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources. (inherited from ServiceProxy)
protected method | Finalize | Overridden. Implicitly frees allocated service channel and service factory resources. (inherited from Object)
protected method | HandleFailover | Overloaded. For internal use only. (inherited from ServiceProxy)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnFactoryClosed | Event handler virtual method for a channel factory that is in a closed state. (inherited from ServiceProxy)
protected method | OnFactoryFaulted | Event handler virtual method for a channel factory that is in a faulted state. (inherited from ServiceProxy)
protected method | OnFactoryOpened | Event handler virtual method for a channel factory that is in an opened state. (inherited from ServiceProxy)
protected method | ShouldRetry | Checks a message security exception to determine if a service call should be attempted again. (inherited from ServiceProxy)
protected method | ValidateAuthentication | Authenticates the client and creates a new service channel. (inherited from ServiceProxy)

See Also

Reference

DiscoveryServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Sample: Access the Discovery Service
Helper Code: ServerConnection Class


DiscoveryServiceProxy.Execute Method
[image]

See IDiscoveryService.Execute

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Execute ( _
    request As DiscoveryRequest _
) As DiscoveryResponse

C#
public DiscoveryResponse Execute (
    DiscoveryRequest request
)

C++

J#

JScript

Parameters
request
Type: DiscoveryRequest. A discovery service request.
Return Value
Type: DiscoveryResponse
The response from executing the discovery service request.

  Remarks
For more information about the exceptions that can be thrown when calling the Execute method, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryServiceProxy Class
DiscoveryServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


DiscoveryServiceProxy Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ClientCredentials | Gets the login credentials of the client. (inherited from ServiceProxy)
public property | DeviceCredentials | Gets the Windows Live credentials of a registered device. (inherited from ServiceProxy)
public property | EndpointAutoSwitchEnabled | Gets or sets a value that enables automatic switching from the organization’s current endpoint to an alternate endpoint. (inherited from ServiceProxy)
public property | EndpointSwitch | Gets the endpoint switch information from the web service configuration. (inherited from ServiceProxy)
public property | HomeRealmSecurityTokenResponse | Gets the security token response of the home realm. (inherited from ServiceProxy)
public property | HomeRealmUri | Gets the home realm URI. (inherited from ServiceProxy)
public property | IsAuthenticated | Gets a value indicating if the WCF channel has been authenticated. (inherited from ServiceProxy)
public property | SecurityTokenResponse | Gets the security token response. (inherited from ServiceProxy)
public property | ServiceChannel | Gets the communication channel used to access a Microsoft Dynamics CRM service. (inherited from ServiceProxy)
public property | ServiceConfiguration | Gets a service configuration. (inherited from ServiceProxy)
public property | ServiceManagement | Gets a service management. (inherited from ServiceProxy)
public property | Timeout | Gets or sets the maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding. (inherited from ServiceProxy)
public property | UserPrincipalName | Gets or sets the UPN that is an Internet-style login name for a user based on the Internet standard RFC 822. (inherited from ServiceProxy)

Protected Properties

 | Name | Description
protected property | ChannelFactory | Gets a WCF channel factory that manages a single channel instance. (inherited from ServiceProxy)

See Also

Reference

DiscoveryServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Sample: Access the Discovery Service
Helper Code: ServerConnection Class


DiscoveryServiceProxy Events
[image]

Public Events

 | Name | Description
public event | EndpointSwitched | Occurs when a failover recovery has completed and the organization’s current endpoint has been switched to an alternate endpoint.(inherited from ServiceProxy)
public event | EndpointSwitchRequired | Occurs when a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required.(inherited from ServiceProxy)
public event | FactoryClosed | Occurs when a channel factory is closed. (inherited from ServiceProxy)
public event | FactoryFaulted | Occurs when a channel factory is faulted.(inherited from ServiceProxy)
public event | FactoryOpened | Occurs when a channel factory is opened.(inherited from ServiceProxy)

See Also

Reference

DiscoveryServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Sample: Access the Discovery Service
Helper Code: ServerConnection Class


EndpointSwitchEventArgs Class
See Also Members
[image]

Identifies the new and previous service endpoint URL’s for an organization.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class EndpointSwitchEventArgs
    Inherits EventArgs

C#
public sealed class EndpointSwitchEventArgs : EventArgs

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs
    Microsoft.Xrm.Sdk.Client.EndpointSwitchEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EndpointSwitchEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace
SwitchToAlternateEndpoint
EndpointSwitched
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


EndpointSwitchEventArgs Members
See Also Methods Properties
[image]

Identifies the new and previous service endpoint URL’s for an organization.

The following tables list the members exposed by the EndpointSwitchEventArgs type.

Public Properties

 | Name | Description
public property | NewUrl | Gets the new service endpoint URL for an organization.
public property | PreviousUrl | Gets the previous service endpoint URL for an organization.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EndpointSwitchEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace
SwitchToAlternateEndpoint
EndpointSwitched

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


EndpointSwitchEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EndpointSwitchEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace
SwitchToAlternateEndpoint
EndpointSwitched

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


EndpointSwitchEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | NewUrl | Gets the new service endpoint URL for an organization.
public property | PreviousUrl | Gets the previous service endpoint URL for an organization.

See Also

Reference

EndpointSwitchEventArgs Class
Microsoft.Xrm.Sdk.Client Namespace
SwitchToAlternateEndpoint
EndpointSwitched

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


EndpointSwitchEventArgs.NewUrl Property
[image]

Gets the new service endpoint URL for an organization.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property NewUrl As Uri

C#
public Uri NewUrl { get; }

C++

J#

JScript

Property Value
Type: URI
 The new service endpoint URL for an organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EndpointSwitchEventArgs Class
EndpointSwitchEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


EndpointSwitchEventArgs.PreviousUrl Property
[image]

Gets the previous service endpoint URL for an organization.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PreviousUrl As Uri

C#
public Uri PreviousUrl { get; }

C++

J#

JScript

Property Value
Type: URI
 The previous service endpoint URL for an organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EndpointSwitchEventArgs Class
EndpointSwitchEventArgs Members
Microsoft.Xrm.Sdk.Client Namespace


EntityLogicalNameAttribute Class
See Also Members
[image]

Identifies the logical name of an entity.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public NotInheritable Class EntityLogicalNameAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public sealed class EntityLogicalNameAttribute : Attribute

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Client.EntityLogicalNameAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityLogicalNameAttribute Members
Microsoft.Xrm.Sdk.Client Namespace


EntityLogicalNameAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Identifies the logical name of an entity.

The following tables list the members exposed by the EntityLogicalNameAttribute type.

Public Constructors

Name | Description
EntityLogicalNameAttribute | Initializes a new instance of the EntityLogicalNameAttribute class.
Top

Public Properties

 | Name | Description
public property | LogicalName | Gets the logical name of the entity.
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

EntityLogicalNameAttribute Class
Microsoft.Xrm.Sdk.Client Namespace


EntityLogicalNameAttribute Constructor
[image]

Initializes a new instance of the EntityLogicalNameAttribute class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    logicalName As String _
)

C#
public EntityLogicalNameAttribute (
    string logicalName
)

C++

J#

JScript

Parameters
logicalName
Type: String. The logical name of the entity
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityLogicalNameAttribute Class
EntityLogicalNameAttribute Members
Microsoft.Xrm.Sdk.Client Namespace


EntityLogicalNameAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

EntityLogicalNameAttribute Class
Microsoft.Xrm.Sdk.Client Namespace


EntityLogicalNameAttribute Properties
[image]

Public Properties

 | Name | Description
public property | LogicalName | Gets the logical name of the entity.
public property | TypeId | (inherited from Attribute)

See Also

Reference

EntityLogicalNameAttribute Class
Microsoft.Xrm.Sdk.Client Namespace


EntityLogicalNameAttribute.LogicalName Property
[image]

Gets the logical name of the entity.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LogicalName As String

C#
public string LogicalName { get; }

C++

J#

JScript

Property Value
Type: String
 The logical name of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityLogicalNameAttribute Class
EntityLogicalNameAttribute Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProvider Class
See Also Members
[image]

Represents an identity provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustInherit Class IdentityProvider

C#
public abstract class IdentityProvider

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.IdentityProvider

                Microsoft.Xrm.Sdk.Client.LocalIdentityProvider

                Microsoft.Xrm.Sdk.Client.OnlineIdentityProvider
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProvider Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProvider Members
See Also Methods Properties Constructors
[image]

Represents an identity provider.

The following tables list the members exposed by the IdentityProvider type.

Protected Constructors

Name | Description
IdentityProvider | Initializes a new instance of the IdentityProvider class.
Top

Public Properties

 | Name | Description
public property | IdentityProviderType | The type of identity provider used by an endpoint.
public property | ServiceUrl | Specifies the URL of the identity provider service.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IdentityProvider Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProvider Constructor
[image]

Initializes a new instance of the IdentityProvider class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected IdentityProvider ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProvider Class
IdentityProvider Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProvider Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IdentityProvider Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProvider Properties
[image]

Public Properties

 | Name | Description
public property | IdentityProviderType | The type of identity provider used by an endpoint.
public property | ServiceUrl | Specifies the URL of the identity provider service.

See Also

Reference

IdentityProvider Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProvider.IdentityProviderType Property
[image]

The type of identity provider used by an endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IdentityProviderType As IdentityProviderType

C#
public IdentityProviderType IdentityProviderType { get; set; }

C++

J#

JScript

Property Value
Type: IdentityProviderType
The identity provider type. Value = 0 (ADFS), 1 (LiveId), 2 (OrgId).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProvider Class
IdentityProvider Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProvider.ServiceUrl Property
[image]

Specifies the URL of the identity provider service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ServiceUrl As Uri

C#
public Uri ServiceUrl { get; set; }

C++

J#

JScript

Property Value
Type: URI
 The URL of the identity provider service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProvider Class
IdentityProvider Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderDictionary Class
See Also Members
[image]

A collection of identity providers.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class IdentityProviderDictionary
    Inherits Dictionary(Of String, IdentityProvider)

C#
[SerializableAttribute]
public sealed class IdentityProviderDictionary : Dictionary<string,IdentityProvider>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.Generic.Dictionary
    Microsoft.Xrm.Sdk.Client.IdentityProviderDictionary
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProviderDictionary Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderDictionary Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

A collection of identity providers.

The following tables list the members exposed by the IdentityProviderDictionary type.

Public Constructors

Name | Description
IdentityProviderDictionary | Initializes an instance of the IdentityProviderDictionary class.
Top

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Top

See Also

Reference

IdentityProviderDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderDictionary Constructor
[image]

Initializes an instance of the IdentityProviderDictionary class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IdentityProviderDictionary ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProviderDictionary Class
IdentityProviderDictionary Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderDictionary Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)

See Also

Reference

IdentityProviderDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderDictionary Properties
[image]

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)

See Also

Reference

IdentityProviderDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTrustConfiguration Class
See Also Members
[image]

Contains the configuration information required to use an identity provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecuritySafeCriticalAttribute> _
<SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted:=True)> _
Public MustInherit Class IdentityProviderTrustConfiguration

C#
[SecuritySafeCriticalAttribute]
[SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted=true)]
public abstract class IdentityProviderTrustConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.IdentityProviderTrustConfiguration

                Microsoft.Xrm.Sdk.Client.LiveIdentityProviderTrustConfiguration

                Microsoft.Xrm.Sdk.Client.OrgIdentityProviderTrustConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTrustConfiguration Members
See Also Methods Properties
[image]

Contains the configuration information required to use an identity provider.

The following tables list the members exposed by the IdentityProviderTrustConfiguration type.

Public Properties

 | Name | Description
public property | AppliesTo | Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification.
public property | Endpoint | Gets the endpoint of the identity provider.
public property | LiveIdAppliesTo | Gets or sets the scope that a Microsoft account security token request applies to, as defined in the WS-Trust specification.
public property | Policy | Gets or sets a policy configuration that identifies a Secure Token Service (STS).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IdentityProviderTrustConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTrustConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IdentityProviderTrustConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTrustConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | AppliesTo | Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification.
public property | Endpoint | Gets the endpoint of the identity provider.
public property | LiveIdAppliesTo | Gets or sets the scope that a Microsoft account security token request applies to, as defined in the WS-Trust specification.
public property | Policy | Gets or sets a policy configuration that identifies a Secure Token Service (STS).

See Also

Reference

IdentityProviderTrustConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTrustConfiguration.AppliesTo Property
[image]

Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AppliesTo As String

C#
public string AppliesTo { get; set; }

C++

J#

JScript

Property Value
Type: String
The scope that a security token request applies to, as defined in the WS-Trust specification.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProviderTrustConfiguration Class
IdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTrustConfiguration.Endpoint Property
[image]

Gets the endpoint of the identity provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride ReadOnly Property Endpoint As Uri

C#
public abstract Uri Endpoint { get; }

C++

J#

JScript

Property Value
Type: URI
 The endpoint of the identity provider.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProviderTrustConfiguration Class
IdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTrustConfiguration.LiveIdAppliesTo Property
[image]

Gets or sets the scope that a Microsoft account security token request applies to, as defined in the WS-Trust specification.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LiveIdAppliesTo As String

C#
public string LiveIdAppliesTo { get; set; }

C++

J#

JScript

Property Value
Type: String
 The scope that a Microsoft account security token request applies to, as defined in the WS-Trust specification.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProviderTrustConfiguration Class
IdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTrustConfiguration.Policy Property
[image]

Gets or sets a policy configuration that identifies a Secure Token Service (STS).

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Policy As String

C#
public string Policy { get; set; }

C++

J#

JScript

Property Value
Type: String
 The policy configuration that identifies a Secure Token Service (STS).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProviderTrustConfiguration Class
IdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderType Enumeration
[image]

Specifies the supported types of identity providers.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration IdentityProviderType

C#
public enum IdentityProviderType

C++

J#

JScript

  Members
Member name | Description
ADFS | Active Directory Federation Services. Value = 0.
LiveId | Windows Live ID. Value = 1.
OrgId | OrgId, also known as User Id. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTypeDictionary Class
See Also Members
[image]

Contains the available identity providers for a Microsoft Dynamics CRM service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class IdentityProviderTypeDictionary
    Inherits Dictionary(Of Uri, IdentityProviderTrustConfiguration)

C#
[SerializableAttribute]
public sealed class IdentityProviderTypeDictionary : Dictionary<Uri,IdentityProviderTrustConfiguration>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.Generic.Dictionary
    Microsoft.Xrm.Sdk.Client.IdentityProviderTypeDictionary
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProviderTypeDictionary Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTypeDictionary Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains the available identity providers for a Microsoft Dynamics CRM service.

The following tables list the members exposed by the IdentityProviderTypeDictionary type.

Public Constructors

Name | Description
IdentityProviderTypeDictionary | Initializes a new instance of the IdentityProviderTypeDictionary class.
Top

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Top

See Also

Reference

IdentityProviderTypeDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTypeDictionary Constructor
[image]

Initializes a new instance of the IdentityProviderTypeDictionary class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IdentityProviderTypeDictionary ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IdentityProviderTypeDictionary Class
IdentityProviderTypeDictionary Members
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTypeDictionary Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)

See Also

Reference

IdentityProviderTypeDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


IdentityProviderTypeDictionary Properties
[image]

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)

See Also

Reference

IdentityProviderTypeDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


IEndpointSwitch Interface
See Also Members
[image]

Represents the switching of a web service endpoint for an organization from a primary URL to an alternate URL.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IEndpointSwitch

C#
public interface IEndpointSwitch

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


IEndpointSwitch Members
See Also Events Methods Properties
[image]

Represents the switching of a web service endpoint for an organization from a primary URL to an alternate URL.

The following tables list the members exposed by the IEndpointSwitch type.

Public Properties

 | Name | Description
public property | AlternateEndpoint | Gets the alternate web service endpoint for accessing an organization, if one exists.
public property | EndpointAutoSwitchEnabled | Gets or sets whether automatic switching from the current endpoint of the web service to an alternate endpoint is enabled.
public property | IsPrimaryEndpoint | Gets whether the organization’s current endpoint is the primary endpoint.
public property | PrimaryEndpoint | Gets the primary web service endpoint for accessing an organization.
Top

Public Methods

 | Name | Description
public method | CanSwitch | Checks if the specified endpoint URI is different from the organization’s alternate endpoint URI.
public method | HandleEndpointSwitch | Fires the EndpointSwitchRequired event, then if EndpointAutoSwitchEnabled is true, switches the organization’s endpoints by calling SwitchEndpoint.
public method | SwitchEndpoint | Switches the organization’s current endpoint to an alternate endpoint.
Top

Public Events

 | Name | Description
public event | EndpointSwitched | Notification event that a failover has completed and the organization’s current endpoint has been switched to an alternate endpoint.
public event | EndpointSwitchRequired | Notification event that a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required.
Top

See Also

Reference

IEndpointSwitch Interface
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


IEndpointSwitch Methods
[image]

Public Methods

 | Name | Description
public method | CanSwitch | Checks if the specified endpoint URI is different from the organization’s alternate endpoint URI.
public method | HandleEndpointSwitch | Fires the EndpointSwitchRequired event, then if EndpointAutoSwitchEnabled is true, switches the organization’s endpoints by calling SwitchEndpoint.
public method | SwitchEndpoint | Switches the organization’s current endpoint to an alternate endpoint.

See Also

Reference

IEndpointSwitch Interface
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


IEndpointSwitch.CanSwitch Method
[image]

Checks if the specified endpoint URI is different from the organization’s alternate endpoint URI.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function CanSwitch ( _
    currentUri As Uri _
) As Boolean

C#
bool CanSwitch (
    Uri currentUri
)

C++

J#

JScript

Parameters
currentUri
Type: URI. Specifies an endpoint URI.
Return Value
Type: Boolean
true if the two URIs are different and an endpoint switch can be attempted, otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Interface
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
AlternateEndpoint
AlternateEndpoint


IEndpointSwitch.HandleEndpointSwitch Method
[image]

Fires the EndpointSwitchRequired event, then if EndpointAutoSwitchEnabled is true, switches the organization’s endpoints by calling SwitchEndpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function HandleEndpointSwitch As Boolean

C#
bool HandleEndpointSwitch ()

C++

J#

JScript

Return Value
Type: Boolean
true if the endpoint switch was successful, otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Interface
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
ServiceUrls


IEndpointSwitch.SwitchEndpoint Method
[image]

Switches the organization’s current endpoint to an alternate endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Sub SwitchEndpoint

C#
void SwitchEndpoint ()

C++

J#

JScript

  Remarks
When an organization is provisioned for disaster recovery failover, that organization has a primary endpoint and an alternate endpoint. If the current endpoint in use for the organization is the primary endpoint, calling SwitchEndpoint switches the current endpoint to the alternate endpoint. Conversely, if the current endpoint for the organization is the alternate endpoint, calling SwitchEndpoint switches the current endpoint to the primary endpoint.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Interface
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
HandleEndpointSwitch
ServiceUrls


IEndpointSwitch Properties
[image]

Public Properties

 | Name | Description
public property | AlternateEndpoint | Gets the alternate web service endpoint for accessing an organization, if one exists.
public property | EndpointAutoSwitchEnabled | Gets or sets whether automatic switching from the current endpoint of the web service to an alternate endpoint is enabled.
public property | IsPrimaryEndpoint | Gets whether the organization’s current endpoint is the primary endpoint.
public property | PrimaryEndpoint | Gets the primary web service endpoint for accessing an organization.

See Also

Reference

IEndpointSwitch Interface
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


IEndpointSwitch.AlternateEndpoint Property
[image]

Gets the alternate web service endpoint for accessing an organization, if one exists.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property AlternateEndpoint As Uri

C#
Uri AlternateEndpoint { get; }

C++

J#

JScript

Property Value
Type: URI
The alternate web service endpoint.

  Remarks
Set when constructing IServiceConfiguration or IServiceManagement.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Interface
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
PrimaryEndpoint
ServiceUrls


IEndpointSwitch.EndpointAutoSwitchEnabled Property
[image]

Gets or sets whether automatic switching from the current endpoint of the web service to an alternate endpoint is enabled.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Property EndpointAutoSwitchEnabled As Boolean

C#
bool EndpointAutoSwitchEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the automatic switching is enabled; otherwise, false.

  Remarks
Set to true by default for organizations that support disaster recover where an alternate endpoint is available. This property relates only to what the client-side SDK classes do, for example OrganizationServiceProxy, and does not alter the Microsoft Dynamics CRM server functionality in any way. Setting this property to false for an organization that is disaster failover enabled causes the client SDK classes to not attempt switching the endpoints if a failover is required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Interface
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


IEndpointSwitch.IsPrimaryEndpoint Property
[image]

Gets whether the organization’s current endpoint is the primary endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property IsPrimaryEndpoint As Boolean

C#
bool IsPrimaryEndpoint { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the current endpoint is the primary endpoint; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Interface
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
PrimaryEndpoint


IEndpointSwitch.PrimaryEndpoint Property
[image]

Gets the primary web service endpoint for accessing an organization.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property PrimaryEndpoint As Uri

C#
Uri PrimaryEndpoint { get; }

C++

J#

JScript

Property Value
Type: URI
The primary web service endpoint.

  Remarks
Set when constructing IServiceConfiguration or IServiceManagement.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Interface
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
AlternateEndpoint
ServiceUrls


IEndpointSwitch Events
[image]

Public Events

 | Name | Description
public event | EndpointSwitched | Notification event that a failover has completed and the organization’s current endpoint has been switched to an alternate endpoint.
public event | EndpointSwitchRequired | Notification event that a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required.

See Also

Reference

IEndpointSwitch Interface
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


IEndpointSwitch.EndpointSwitched Event
[image]

Notification event that a failover has completed and the organization’s current endpoint has been switched to an alternate endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Event EndpointSwitched As EventHandler(Of EndpointSwitchEventArgs)

C#
event EventHandler<EndpointSwitchEventArgs> EndpointSwitched

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Interface
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


IEndpointSwitch.EndpointSwitchRequired Event
[image]

Notification event that a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Event EndpointSwitchRequired As EventHandler(Of EndpointSwitchEventArgs)

C#
event EventHandler<EndpointSwitchEventArgs> EndpointSwitchRequired

C++

J#

JScript

  Remarks
This event is fired during execution of a web service call and only if an alternate endpoint exists.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IEndpointSwitch Interface
IEndpointSwitch Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


IServiceConfiguration Generic Interface
See Also Members
[image]

Represents a configured Microsoft Dynamics CRM service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IServiceConfiguration(Of TService)

C#
public interface IServiceConfiguration<TService>

C++

J#

JScript

GenericParameters
TService
Type: Type. The type of service.
  Remarks
Instances of the IServiceConfiguration and IServiceManagement interfaces are basically interchangeable, the only real difference being that the IServiceManagement interface exposes support for the AuthenticationCredentials class and a single Authenticate call that covers most scenarios.
For best performance, create an instance of the IServiceConfiguration interface only one time per client session and re-use that instance as necessary.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration Members
See Also Methods Properties
[image]

Represents a configured Microsoft Dynamics CRM service.

The following tables list the members exposed by the IServiceConfiguration type.

Public Properties

 | Name | Description
public property | AuthenticationType | Gets the type of authentication in use by the identity provider of the service.
public property | CrossRealmIssuerEndpoints | Gets the available endpoints of the user’s home realm identity provider.
public property | CurrentIssuer | Gets or sets the endpoint used by the Secure Token Service (STS) to issue the trusted token.
public property | CurrentServiceEndpoint | Gets or sets the current endpoint in use by a service.
public property | IssuerEndpoints | Gets the available endpoints of the security token service (STS).
public property | PolicyConfiguration | Gets the policy configuration that identifies a Secure Token Service (STS).
public property | ServiceEndpoints | Gets the available endpoints of the service.
Top

Public Methods

 | Name | Description
public method | Authenticate | Overloaded. Authenticates against the trusted Microsoft Dynamics CRM Secure Token Service.
public method | AuthenticateCrossRealm | Overloaded. Authenticates against a remote Secure Token Service(STS).
public method | AuthenticateDevice | Authenticates a registered device against Microsoft account.
public method | CreateChannelFactory | Overloaded. Creates a client factory.
public method | GetIdentityProvider | Returns the identity provider used for a specified user when accessing a service.
Top

See Also

Reference

IServiceConfiguration Interface
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration Methods
[image]

Public Methods

 | Name | Description
public method | Authenticate | Overloaded. Authenticates against the trusted Microsoft Dynamics CRM Secure Token Service.
public method | AuthenticateCrossRealm | Overloaded. Authenticates against a remote Secure Token Service(STS).
public method | AuthenticateDevice | Authenticates a registered device against Microsoft account.
public method | CreateChannelFactory | Overloaded. Creates a client factory.
public method | GetIdentityProvider | Returns the identity provider used for a specified user when accessing a service.

See Also

Reference

IServiceConfiguration Interface
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.Authenticate Method
[image]

Authenticates against the trusted Microsoft Dynamics CRM Secure Token Service.

Overload List

Name | Description
IServiceConfiguration.Authenticate (SecurityToken) | Authenticates against the trusted Microsoft Dynamics CRM Secure Token Service using a security token.
IServiceConfiguration.Authenticate (ClientCredentials) | Authenticates against the trusted Microsoft Dynamics CRM Secure Token Service using client credentials.
IServiceConfiguration.Authenticate (ClientCredentials, SecurityTokenResponse) | Authenticates against Microsoft account using client credentials and a security token response.

See Also

Reference

IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.Authenticate Method (SecurityToken)
[image]

Authenticates against the trusted Microsoft Dynamics CRM Secure Token Service using a security token.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function Authenticate ( _
    securityToken As SecurityToken _
) As SecurityTokenResponse

C#
SecurityTokenResponse Authenticate (
    SecurityToken securityToken
)

C++

J#

JScript

Parameters
securityToken
Type: SecurityToken. A security token retrieved from an identity provider other than the trusted Microsoft Dynamics CRM Secure Token Service (when in federation mode).
Return Value
Type: SecurityTokenResponse
The security token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.Authenticate Method (ClientCredentials)
[image]

Authenticates against the trusted Microsoft Dynamics CRM Secure Token Service using client credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function Authenticate ( _
    clientCredentials As ClientCredentials _
) As SecurityTokenResponse

C#
SecurityTokenResponse Authenticate (
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
clientCredentials
Type: ClientCredentials. Specifies a client credential instance containing either Windows credentials or UserName credentials.
Return Value
Type: SecurityTokenResponse
The security token response.

  Remarks
Returns null when the service is in Active Directory mode. A non-null value is returned when in federated mode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.Authenticate Method (ClientCredentials, SecurityTokenResponse)
[image]

Authenticates against Microsoft account using client credentials and a security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function Authenticate ( _
    clientCredentials As ClientCredentials, _
    deviceSecurityToken As SecurityTokenResponse _
) As SecurityTokenResponse

C#
SecurityTokenResponse Authenticate (
    ClientCredentials clientCredentials,
    SecurityTokenResponse deviceSecurityToken
)

C++

J#

JScript

Parameters
clientCredentials
Type: ClientCredentials. Specifies a client credential instance containing UserName credentials where the UserName and Password properties are set.
deviceSecurityToken
Type: SecurityTokenResponse. A security token response received from authenticating the user's device with Microsoft account.
Return Value
Type: SecurityTokenResponse
The security token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.AuthenticateCrossRealm Method
[image]

Authenticates against a remote Secure Token Service(STS).

Overload List

Name | Description
IServiceConfiguration.AuthenticateCrossRealm (SecurityToken, String, Uri) | Authenticates against a remote Secure Token Service (STS) using a security token retrieved from an identity provider (when in federation mode).
IServiceConfiguration.AuthenticateCrossRealm (ClientCredentials, String, Uri) | Authenticates against a remote Secure Token Service (STS) using client credentials.

See Also

Reference

IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.AuthenticateCrossRealm Method (SecurityToken, String, Uri)
[image]

Authenticates against a remote Secure Token Service (STS) using a security token retrieved from an identity provider (when in federation mode).

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function AuthenticateCrossRealm ( _
    securityToken As SecurityToken, _
    appliesTo As String, _
    crossRealmSts As Uri _
) As SecurityTokenResponse

C#
SecurityTokenResponse AuthenticateCrossRealm (
    SecurityToken securityToken,
    string appliesTo,
    Uri crossRealmSts
)

C++

J#

JScript

Parameters
securityToken
Type: SecurityToken. Specifies a security token issued from an identity provider.
appliesTo
Type: String. Specifies the identifier of the STS to authenticate on behalf of.
crossRealmSts
Type: URI. Specifies the URI of the cross realm STS metadata endpoint.
Return Value
Type: SecurityTokenResponse

The security token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.AuthenticateCrossRealm Method (ClientCredentials, String, Uri)
[image]

Authenticates against a remote Secure Token Service (STS) using client credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function AuthenticateCrossRealm ( _
    clientCredentials As ClientCredentials, _
    appliesTo As String, _
    crossRealmSts As Uri _
) As SecurityTokenResponse

C#
SecurityTokenResponse AuthenticateCrossRealm (
    ClientCredentials clientCredentials,
    string appliesTo,
    Uri crossRealmSts
)

C++

J#

JScript

Parameters
clientCredentials
Type: ClientCredentials. Specifies a client credentials instance with the Windows  credentials or the UserName (.UserName and .Password) set.
appliesTo
Type: String. Specifies the identifier of the STS to authenticate on behalf of.
crossRealmSts
Type: URI. Specifies the URI of the cross realm STS metadata endpoint.
Return Value
Type: SecurityTokenResponse
The security token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.AuthenticateDevice Method
[image]

Authenticates a registered device against Microsoft account.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function AuthenticateDevice ( _
    clientCredentials As ClientCredentials _
) As SecurityTokenResponse

C#
SecurityTokenResponse AuthenticateDevice (
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
clientCredentials
Type: ClientCredentials. Specifies a client credential instance.
Return Value
Type: SecurityTokenResponse

The security token response.

  Remarks
The UserName.UserName and UserName.Password properties of the credential must be populated with a device name and password.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Helper Code: DeviceIdManager Class


IServiceConfiguration.CreateChannelFactory Method
[image]

Creates a client factory.

Overload List

Name | Description
IServiceConfiguration.CreateChannelFactory () | Creates a client factory that uses the default Kerberos credentials.
IServiceConfiguration.CreateChannelFactory (ClientAuthenticationType) | Creates a WCF channel factory with a specified type of authentication.
IServiceConfiguration.CreateChannelFactory (TokenServiceCredentialType) | For internal use only.
IServiceConfiguration.CreateChannelFactory (ClientCredentials) | Creates a WCF channel factory that supports passing the client credentials, regardless of whether in federation authentication mode or not.

See Also

Reference

IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.CreateChannelFactory Method ()
[image]

Creates a client factory that uses the default Kerberos credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function CreateChannelFactory As ChannelFactory(Of TService)

C#
ChannelFactory<TService> CreateChannelFactory ()

C++

J#

JScript

Return Value
Type: ChannelFactory<TService>
The channel factory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.CreateChannelFactory Method (ClientAuthenticationType)
[image]

Creates a WCF channel factory with a specified type of authentication.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function CreateChannelFactory ( _
    clientAuthenticationType As ClientAuthenticationType _
) As ChannelFactory(Of TService)

C#
ChannelFactory<TService> CreateChannelFactory (
    ClientAuthenticationType clientAuthenticationType
)

C++

J#

JScript

Parameters
clientAuthenticationType
Type: ClientAuthenticationType. Specifies the type of authentication.
Return Value
Type: ChannelFactory<TService>
The channel factory.

  Remarks
When SecurityToken is specified, you can later call the following method when creating a channel.
C#    Copy Code
channelFactory.CreateChannelWithIssuedToken(SecurityToken)

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.CreateChannelFactory Method (TokenServiceCredentialType)
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic

C#

C++

J#

JScript

Parameters
endpointType
Return Value
Type: ChannelFactory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.CreateChannelFactory Method (ClientCredentials)
[image]

Creates a WCF channel factory that supports passing the client credentials, regardless of whether in federation authentication mode or not.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function CreateChannelFactory ( _
    clientCredentials As ClientCredentials _
) As ChannelFactory(Of TService)

C#
ChannelFactory<TService> CreateChannelFactory (
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
clientCredentials
Type: ClientCredentials. Specifies client authentication credentials.
Return Value
Type: ChannelFactory< TService>
The channel factory.

  Remarks
Windows and UserName credentials are currently supported.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.GetIdentityProvider Method
[image]

Returns the identity provider used for a specified user when accessing a service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function GetIdentityProvider ( _
    userPrincipalName As String _
) As IdentityProvider

C#
IdentityProvider GetIdentityProvider (
    string userPrincipalName
)

C++

J#

JScript

Parameters
userPrincipalName
Type: String. Specifies a user principal name (UPN).
Return Value
Type: IdentityProvider
The identity provider.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | AuthenticationType | Gets the type of authentication in use by the identity provider of the service.
public property | CrossRealmIssuerEndpoints | Gets the available endpoints of the user’s home realm identity provider.
public property | CurrentIssuer | Gets or sets the endpoint used by the Secure Token Service (STS) to issue the trusted token.
public property | CurrentServiceEndpoint | Gets or sets the current endpoint in use by a service.
public property | IssuerEndpoints | Gets the available endpoints of the security token service (STS).
public property | PolicyConfiguration | Gets the policy configuration that identifies a Secure Token Service (STS).
public property | ServiceEndpoints | Gets the available endpoints of the service.

See Also

Reference

IServiceConfiguration Interface
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.AuthenticationType Property
[image]

Gets the type of authentication in use by the identity provider of the service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property AuthenticationType As AuthenticationProviderType

C#
AuthenticationProviderType AuthenticationType { get; }

C++

J#

JScript

Property Value
Type: AuthenticationProviderType
Thee type of authentication being used.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.CrossRealmIssuerEndpoints Property
[image]

Gets the available endpoints of the user’s home realm identity provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property CrossRealmIssuerEndpoints As CrossRealmIssuerEndpointCollection

C#
CrossRealmIssuerEndpointCollection CrossRealmIssuerEndpoints { get; }

C++

J#

JScript

Property Value
Type: CrossRealmIssuerEndpointCollection
The available endpoints.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.CurrentIssuer Property
[image]

Gets or sets the endpoint used by the Secure Token Service (STS) to issue the trusted token.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Property CurrentIssuer As IssuerEndpoint

C#
IssuerEndpoint CurrentIssuer { get; set; }

C++

J#

JScript

Property Value
Type: IssuerEndpoint
The endpoint used by the Secure Token Service (STS) to issue the trusted token.

  Remarks
The CurrentServiceEndpoint must be set and the service configured for federated claims.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.CurrentServiceEndpoint Property
[image]

Gets or sets the current endpoint in use by a service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Property CurrentServiceEndpoint As ServiceEndpoint

C#
ServiceEndpoint CurrentServiceEndpoint { get; set; }

C++

J#

JScript

Property Value
Type: ServiceEndpoint
The current endpoint in use by a service.

  Remarks
Defaults to the first available endpoint in the ServiceEndpoints dictionary if this property has not already been set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.IssuerEndpoints Property
[image]

Gets the available endpoints of the security token service (STS).

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property IssuerEndpoints As IssuerEndpointDictionary

C#
IssuerEndpointDictionary IssuerEndpoints { get; }

C++

J#

JScript

Property Value
Type: IssuerEndpointDictionary
The available endpoints of the security token service (STS).

  Remarks
The available endpoints can vary, depending on how the administrator of the STS has configured the server, but may include the following authentication methods: username and password, Kerberos, certificate, asymmetric token, or symmetric token.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.PolicyConfiguration Property
[image]

Gets the policy configuration that identifies a Secure Token Service (STS).

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property PolicyConfiguration As PolicyConfiguration

C#
PolicyConfiguration PolicyConfiguration { get; }

C++

J#

JScript

Property Value
Type: PolicyConfiguration
The policy configuration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceConfiguration.ServiceEndpoints Property
[image]

Gets the available endpoints of the service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property ServiceEndpoints As ServiceEndpointDictionary

C#
ServiceEndpointDictionary ServiceEndpoints { get; }

C++

J#

JScript

Property Value
Type: ServiceEndpointDictionary
The available endpoints of the service.

  Remarks
Contains the list of URLs and binding information required to make a call to a WCF service.  If the service is configured for on-premises use only, the endpoint(s) contained within will not require the use of an issuer endpoint on the binding.
If the service is configured to use federated claims, the binding on the service endpoint must be configured to use the appropriate issuer endpoint – for example: username/password, Kerberos, etc.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceConfiguration Interface
IServiceConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement Generic Interface
See Also Members
[image]

An interface which provides a simpler authentication experience.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IServiceManagement(Of TService)

C#
public interface IServiceManagement<TService>

C++

J#

JScript

GenericParameters
TService
Type: IDiscoveryService or IOrganizationService. Specifies a service type.
  Remarks
Instances of the IServiceConfiguration and IServiceManagement interfaces are basically interchangeable, the only real difference being that the IServiceManagement interface exposes support for the AuthenticationCredentials class and a single Authenticate call that covers most scenarios.
For best performance, create an instance of this interface only one time per client session and re-use that instance as necessary.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Sample: Authenticate Users with Microsoft Dynamics CRM Web Services
Improve Service Channel Allocation Performance


IServiceManagement Members
See Also Methods Properties
[image]

An interface which provides a simpler authentication experience.

The following tables list the members exposed by the IServiceManagement type.

Public Properties

 | Name | Description
public property | AuthenticationType | Gets the type of authentication in use by the identity provider of the service.
public property | CrossRealmIssuerEndpoints | Gets the available endpoints of the user’s home realm identity provider.
public property | CurrentServiceEndpoint | Gets or sets the current endpoint in use by a service.
public property | IssuerEndpoints | Gets the available endpoints of the security token service (STS).
public property | PolicyConfiguration | Gets the policy configuration that identifies a Secure Token Service (STS).
Top

Public Methods

 | Name | Description
public method | Authenticate | Authenticates the logged on user with the service.
public method | CreateChannelFactory | Overloaded. Creates a channel factory.
public method | GetIdentityProvider | Returns the identity provider used for a specified user when accessing a service.
Top

See Also

Reference

IServiceManagement Interface
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Sample: Authenticate Users with Microsoft Dynamics CRM Web Services
Improve Service Channel Allocation Performance


IServiceManagement Methods
[image]

Public Methods

 | Name | Description
public method | Authenticate | Authenticates the logged on user with the service.
public method | CreateChannelFactory | Overloaded. Creates a channel factory.
public method | GetIdentityProvider | Returns the identity provider used for a specified user when accessing a service.

See Also

Reference

IServiceManagement Interface
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Sample: Authenticate Users with Microsoft Dynamics CRM Web Services
Improve Service Channel Allocation Performance


IServiceManagement.Authenticate Method
[image]

Authenticates the logged on user with the service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function Authenticate ( _
    authenticationCredentials As AuthenticationCredentials _
) As AuthenticationCredentials

C#
AuthenticationCredentials Authenticate (
    AuthenticationCredentials authenticationCredentials
)

C++

J#

JScript

Parameters
authenticationCredentials
Type: AuthenticationCredentials. Specifies the user’s logon credentials.
Return Value
Type: AuthenticationCredentials
The user’s authentication credentials, including the final security token.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.CreateChannelFactory Method
[image]

Creates a channel factory.

Overload List

Name | Description
IServiceManagement.CreateChannelFactory () | Creates a WCF channel factory that uses the default Kerberos credentials.
IServiceManagement.CreateChannelFactory (ClientAuthenticationType) | Creates a WCF channel factory with a specified type of authentication.
IServiceManagement.CreateChannelFactory (TokenServiceCredentialType) | For internal use only.
IServiceManagement.CreateChannelFactory (ClientCredentials) | Creates a WCF channel factory using specified client credentials.

See Also

Reference

IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.CreateChannelFactory Method ()
[image]

Creates a WCF channel factory that uses the default Kerberos credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function CreateChannelFactory As ChannelFactory(Of TService)

C#
ChannelFactory<TService> CreateChannelFactory ()

C++

J#

JScript

Return Value
Type: ChannelFactory<TService> where TService: IDiscoveryService or IOrganizationService
The WCF channel factory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.CreateChannelFactory Method (ClientAuthenticationType)
[image]

Creates a WCF channel factory with a specified type of authentication.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function CreateChannelFactory ( _
    clientAuthenticationType As ClientAuthenticationType _
) As ChannelFactory(Of TService)

C#
ChannelFactory<TService> CreateChannelFactory (
    ClientAuthenticationType clientAuthenticationType
)

C++

J#

JScript

Parameters
clientAuthenticationType
Type: ClientAuthenticationType. Specifies the type of authentication.
Return Value
Type: ChannelFactory<TService> where TService: IDiscoveryService or IOrganizationService
The WCF channel factory.

  Remarks
When SecurityToken is specified, you can later call the following method when creating a channel.
C#    Copy Code
channelFactory.CreateChannelWithIssuedToken(SecurityToken)

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.CreateChannelFactory Method (TokenServiceCredentialType)
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic

C#

C++

J#

JScript

Parameters
endpointType
Return Value
Type: ChannelFactory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.CreateChannelFactory Method (ClientCredentials)
[image]

Creates a WCF channel factory using specified client credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function CreateChannelFactory ( _
    clientCredentials As ClientCredentials _
) As ChannelFactory(Of TService)

C#
ChannelFactory<TService> CreateChannelFactory (
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
clientCredentials
Type: ClientCredentials. Specifies the client credentials to use.
Return Value
Type: ChannelFactory<TService> where TService: IDiscoveryService or IOrganizationService
The WCF channel factory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.GetIdentityProvider Method
[image]

Returns the identity provider used for a specified user when accessing a service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function GetIdentityProvider ( _
    userPrincipalName As String _
) As IdentityProvider

C#
IdentityProvider GetIdentityProvider (
    string userPrincipalName
)

C++

J#

JScript

Parameters
userPrincipalName
Type: String. Specifies a user principal name (UPN).
Return Value
Type: IdentityProvider
The identity provider used for a specified user when accessing a service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement Properties
[image]

Public Properties

 | Name | Description
public property | AuthenticationType | Gets the type of authentication in use by the identity provider of the service.
public property | CrossRealmIssuerEndpoints | Gets the available endpoints of the user’s home realm identity provider.
public property | CurrentServiceEndpoint | Gets or sets the current endpoint in use by a service.
public property | IssuerEndpoints | Gets the available endpoints of the security token service (STS).
public property | PolicyConfiguration | Gets the policy configuration that identifies a Secure Token Service (STS).

See Also

Reference

IServiceManagement Interface
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Sample: Authenticate Users with Microsoft Dynamics CRM Web Services
Improve Service Channel Allocation Performance


IServiceManagement.AuthenticationType Property
[image]

Gets the type of authentication in use by the identity provider of the service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property AuthenticationType As AuthenticationProviderType

C#
AuthenticationProviderType AuthenticationType { get; }

C++

J#

JScript

Property Value
Type: AuthenticationProviderType
The type of authentication used by the  identity provider.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.CrossRealmIssuerEndpoints Property
[image]

Gets the available endpoints of the user’s home realm identity provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property CrossRealmIssuerEndpoints As CrossRealmIssuerEndpointCollection

C#
CrossRealmIssuerEndpointCollection CrossRealmIssuerEndpoints { get; }

C++

J#

JScript

Property Value
Type: CrossRealmIssuerEndpointCollection
The available endpoints of the user’s home realm identity provider.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.CurrentServiceEndpoint Property
[image]

Gets or sets the current endpoint in use by a service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Property CurrentServiceEndpoint As ServiceEndpoint

C#
ServiceEndpoint CurrentServiceEndpoint { get; set; }

C++

J#

JScript

Property Value
Type: ServiceEndpoint
The current endpoint in use by a service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.IssuerEndpoints Property
[image]

Gets the available endpoints of the security token service (STS).

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property IssuerEndpoints As IssuerEndpointDictionary

C#
IssuerEndpointDictionary IssuerEndpoints { get; }

C++

J#

JScript

Property Value
Type: IssuerEndpointDictionary
The available endpoints of the security token service (STS).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IServiceManagement.PolicyConfiguration Property
[image]

Gets the policy configuration that identifies a Secure Token Service (STS).

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property PolicyConfiguration As PolicyConfiguration

C#
PolicyConfiguration PolicyConfiguration { get; }

C++

J#

JScript

Property Value
Type: PolicyConfiguration
The policy configuration that identifies a Secure Token Service (STS).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IServiceManagement Interface
IServiceManagement Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint Class
See Also Members
[image]

Represents an issuer endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class IssuerEndpoint

C#
public sealed class IssuerEndpoint

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.IssuerEndpoint
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpoint Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint Members
See Also Constructors Methods Properties
[image]

Represents an issuer endpoint.

The following tables list the members exposed by the IssuerEndpoint type.

Public Constructors

Name | Description
IssuerEndpoint | Initializes a new instance of the IssuerEndpoint class.
Top

Public Properties

 | Name | Description
public property | CredentialType | Gets or sets the type of credentials the endpoint supports.
public property | IssuerAddress | Gets or sets the actual URL that provides authentication for a particular credential type.
public property | IssuerBinding | Gets or sets the binding information used to construct a channel to the issuer endpoint from a client.
public property | IssuerMetadataAddress | Gets or sets the URL that provides metadata about the set of issuer endpoints hosted by a Secure Token Service (STS).
public property | TrustVersion | Gets or sets the WS-Trust standard, either 1.3 or 2005, that is supported on the endpoint.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IssuerEndpoint Class
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint Constructor
[image]

Initializes a new instance of the IssuerEndpoint class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IssuerEndpoint ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpoint Class
IssuerEndpoint Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IssuerEndpoint Class
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint Properties
[image]

Public Properties

 | Name | Description
public property | CredentialType | Gets or sets the type of credentials the endpoint supports.
public property | IssuerAddress | Gets or sets the actual URL that provides authentication for a particular credential type.
public property | IssuerBinding | Gets or sets the binding information used to construct a channel to the issuer endpoint from a client.
public property | IssuerMetadataAddress | Gets or sets the URL that provides metadata about the set of issuer endpoints hosted by a Secure Token Service (STS).
public property | TrustVersion | Gets or sets the WS-Trust standard, either 1.3 or 2005, that is supported on the endpoint.

See Also

Reference

IssuerEndpoint Class
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint.CredentialType Property
[image]

Gets or sets the type of credentials the endpoint supports.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CredentialType As TokenServiceCredentialType

C#
public TokenServiceCredentialType CredentialType { get; set; }

C++

J#

JScript

Property Value
Type: TokenServiceCredentialType
The type of credentials the endpoint supports.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpoint Class
IssuerEndpoint Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint.IssuerAddress Property
[image]

Gets or sets the actual URL that provides authentication for a particular credential type.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IssuerAddress As EndpointAddress

C#
public EndpointAddress IssuerAddress { get; set; }

C++

J#

JScript

Property Value
Type: EndpointAddress
 The actual URL that provides authentication for a particular credential type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpoint Class
IssuerEndpoint Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint.IssuerBinding Property
[image]

Gets or sets the binding information used to construct a channel to the issuer endpoint from a client.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IssuerBinding As Binding

C#
public Binding IssuerBinding { get; set; }

C++

J#

JScript

Property Value
Type: Binding
 The binding information used to construct a channel to the issuer endpoint from a client.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpoint Class
IssuerEndpoint Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint.IssuerMetadataAddress Property
[image]

Gets or sets the URL that provides metadata about the set of issuer endpoints hosted by a Secure Token Service (STS).

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IssuerMetadataAddress As EndpointAddress

C#
public EndpointAddress IssuerMetadataAddress { get; set; }

C++

J#

JScript

Property Value
Type: EndpointAddress
 The URL that provides metadata about the set of issuer endpoints hosted by a Secure Token Service (STS).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpoint Class
IssuerEndpoint Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpoint.TrustVersion Property
[image]

Gets or sets the WS-Trust standard, either 1.3 or 2005, that is supported on the endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TrustVersion As TrustVersion

C#
public TrustVersion TrustVersion { get; set; }

C++

J#

JScript

Property Value
Type:  TrustVersion
The WS-Trust standard, either 1.3 or 2005, that is supported on the endpoint.

  Remarks
WS-Trust 1.3 is supported for issuers other than Microsoft account. For a Microsoft account issuer, WS-Trust 2005 is supported.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpoint Class
IssuerEndpoint Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpointDictionary Class
See Also Members
[image]

Contains a dictionary of IssuerEndpoint objects.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class IssuerEndpointDictionary
    Inherits Dictionary(Of String, IssuerEndpoint)

C#
[SerializableAttribute]
public sealed class IssuerEndpointDictionary : Dictionary<string,IssuerEndpoint>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.Generic.Dictionary
    Microsoft.Xrm.Sdk.Client.IssuerEndpointDictionary
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpointDictionary Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpointDictionary Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a dictionary of IssuerEndpoint objects.

The following tables list the members exposed by the IssuerEndpointDictionary type.

Public Constructors

Name | Description
IssuerEndpointDictionary | Initializes a new instance of the IssuerEndpointDictionary class.
Top

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetIssuerEndpoint | Obtains the issuer endpoint from a Secure Token Service.
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Top

See Also

Reference

IssuerEndpointDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpointDictionary Constructor
[image]

Initializes a new instance of the IssuerEndpointDictionary class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IssuerEndpointDictionary ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpointDictionary Class
IssuerEndpointDictionary Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpointDictionary Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetIssuerEndpoint | Obtains the issuer endpoint from a Secure Token Service.
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)

See Also

Reference

IssuerEndpointDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpointDictionary.GetIssuerEndpoint Method
[image]

Obtains the issuer endpoint from a Secure Token Service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetIssuerEndpoint ( _
    credentialType As TokenServiceCredentialType _
) As IssuerEndpoint

C#
public IssuerEndpoint GetIssuerEndpoint (
    TokenServiceCredentialType credentialType
)

C++

J#

JScript

Parameters
credentialType
Type: TokenServiceCredentialType. Specifies the credential type used by the issuer endpoint.
Return Value
Type: IssuerEndpoint
The issuer endpoint from a Secure Token Service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IssuerEndpointDictionary Class
IssuerEndpointDictionary Members
Microsoft.Xrm.Sdk.Client Namespace


IssuerEndpointDictionary Properties
[image]

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)

See Also

Reference

IssuerEndpointDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


LiveIdentityProviderTrustConfiguration Class
See Also Members
[image]

Contains identity provider configuration information specific to Microsoft account.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecuritySafeCriticalAttribute> _
<SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted:=True)> _
Public NotInheritable Class LiveIdentityProviderTrustConfiguration
    Inherits IdentityProviderTrustConfiguration

C#
[SecuritySafeCriticalAttribute]
[SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted=true)]
public sealed class LiveIdentityProviderTrustConfiguration : IdentityProviderTrustConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.IdentityProviderTrustConfiguration
    Microsoft.Xrm.Sdk.Client.LiveIdentityProviderTrustConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LiveIdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


LiveIdentityProviderTrustConfiguration Members
See Also Methods Properties
[image]

Contains identity provider configuration information specific to Microsoft account.

The following tables list the members exposed by the LiveIdentityProviderTrustConfiguration type.

Public Properties

 | Name | Description
public property | AppliesTo | Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification. (inherited from IdentityProviderTrustConfiguration)
public property | Endpoint | Overridden. Gets the endpoint of the Microsoft account identity provider.
public property | LiveIdAppliesTo | Gets or sets the scope that a Microsoft account security token request applies to, as defined in the WS-Trust specification. (inherited from IdentityProviderTrustConfiguration)
public property | Policy | Gets or sets a policy configuration that identifies a Secure Token Service (STS). (inherited from IdentityProviderTrustConfiguration)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LiveIdentityProviderTrustConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


LiveIdentityProviderTrustConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LiveIdentityProviderTrustConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


LiveIdentityProviderTrustConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | AppliesTo | Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification. (inherited from IdentityProviderTrustConfiguration)
public property | Endpoint | Overridden. Gets the endpoint of the Microsoft account identity provider.
public property | LiveIdAppliesTo | Gets or sets the scope that a Microsoft account security token request applies to, as defined in the WS-Trust specification. (inherited from IdentityProviderTrustConfiguration)
public property | Policy | Gets or sets a policy configuration that identifies a Secure Token Service (STS). (inherited from IdentityProviderTrustConfiguration)

See Also

Reference

LiveIdentityProviderTrustConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


LiveIdentityProviderTrustConfiguration.Endpoint Property
[image]

Gets the endpoint of the Microsoft account identity provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides ReadOnly Property Endpoint As Uri

C#
public override Uri Endpoint { get; }

C++

J#

JScript

Property Value
Type: URI
 The endpoint of the Microsoft account identity provider.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LiveIdentityProviderTrustConfiguration Class
LiveIdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


LiveIdPolicyConfiguration Class
See Also Members
[image]

Contains a policy configuration that identifies a Secure Token Service for use with Microsoft account authentication.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecuritySafeCriticalAttribute> _
<SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted:=True)> _
Public NotInheritable Class LiveIdPolicyConfiguration
    Inherits OnlinePolicyConfiguration

C#
[SecuritySafeCriticalAttribute]
[SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted=true)]
public sealed class LiveIdPolicyConfiguration : OnlinePolicyConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.PolicyConfiguration

                Microsoft.Xrm.Sdk.Client.OnlinePolicyConfiguration
      Microsoft.Xrm.Sdk.Client.LiveIdPolicyConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LiveIdPolicyConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


LiveIdPolicyConfiguration Members
See Also Methods Properties
[image]

Contains a policy configuration that identifies a Secure Token Service for use with Microsoft account authentication.

The following tables list the members exposed by the LiveIdPolicyConfiguration type.

Public Properties

 | Name | Description
public property | OnlineProviders | Contains the available identity providers for the Microsoft Dynamics CRM Online service. (inherited from OnlinePolicyConfiguration)
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LiveIdPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


LiveIdPolicyConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LiveIdPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


LiveIdPolicyConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | OnlineProviders | Contains the available identity providers for the Microsoft Dynamics CRM Online service. (inherited from OnlinePolicyConfiguration)
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)

See Also

Reference

LiveIdPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


LocalIdentityProvider Class
See Also Members
[image]

Represents an Active Directory Federation Services (ADFS) based identity provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class LocalIdentityProvider
    Inherits IdentityProvider

C#
public sealed class LocalIdentityProvider : IdentityProvider

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.IdentityProvider
    Microsoft.Xrm.Sdk.Client.LocalIdentityProvider
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalIdentityProvider Members
Microsoft.Xrm.Sdk.Client Namespace


LocalIdentityProvider Members
See Also Constructors Methods Properties
[image]

Represents an Active Directory Federation Services (ADFS) based identity provider.

The following tables list the members exposed by the LocalIdentityProvider type.

Public Constructors

Name | Description
LocalIdentityProvider | Initializes a new instance of the LocalIdentityProvider class.
Top

Public Properties

 | Name | Description
public property | IdentityProviderType | The type of identity provider used by an endpoint. (inherited from IdentityProvider)
public property | ServiceUrl | Specifies the URL of the identity provider service. (inherited from IdentityProvider)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LocalIdentityProvider Class
Microsoft.Xrm.Sdk.Client Namespace


LocalIdentityProvider Constructor
[image]

Initializes a new instance of the LocalIdentityProvider class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LocalIdentityProvider ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalIdentityProvider Class
LocalIdentityProvider Members
Microsoft.Xrm.Sdk.Client Namespace


LocalIdentityProvider Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LocalIdentityProvider Class
Microsoft.Xrm.Sdk.Client Namespace


LocalIdentityProvider Properties
[image]

Public Properties

 | Name | Description
public property | IdentityProviderType | The type of identity provider used by an endpoint. (inherited from IdentityProvider)
public property | ServiceUrl | Specifies the URL of the identity provider service. (inherited from IdentityProvider)

See Also

Reference

LocalIdentityProvider Class
Microsoft.Xrm.Sdk.Client Namespace


MergeOption Enumeration
[image]

Describes the synchronization option for sending or receiving entity data to or from a data service using the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration MergeOption

C#
public enum MergeOption

C++

J#

JScript

  Members
Member name | Description
AppendOnly | New Microsoft Dynamics CRM entities are appended. Existing entities or their original values are not be modified. No client-side changes are lost in this merge. This is the default behavior. Value = 0.
NoTracking | Microsoft Dynamics CRM entities are always loaded from persisted storage. Any attribute changes made to entities in the OrganizationServiceContext are overwritten by the data source values. Value = 3.
OverwriteChanges | All current values on the client are overwritten with current values from the Web service regardless of whether they have been changed on the client. Value = 1.
PreserveChanges | Current values that have been changed on the client are not modified, but any unchanged values are updated with current values from the Web service. No client-side changes are lost in this merge. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Client Namespace


OnlineFederationPolicyConfiguration Class
See Also Members
[image]

Contains Microsoft Online Services specific information for connecting to the Microsoft Dynamics CRM Online server.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecuritySafeCriticalAttribute> _
<SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted:=True)> _
Public NotInheritable Class OnlineFederationPolicyConfiguration
    Inherits OnlinePolicyConfiguration

C#
[SecuritySafeCriticalAttribute]
[SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted=true)]
public sealed class OnlineFederationPolicyConfiguration : OnlinePolicyConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.PolicyConfiguration

                Microsoft.Xrm.Sdk.Client.OnlinePolicyConfiguration
      Microsoft.Xrm.Sdk.Client.OnlineFederationPolicyConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OnlineFederationPolicyConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


OnlineFederationPolicyConfiguration Members
See Also Methods Properties
[image]

Contains Microsoft Online Services specific information for connecting to the Microsoft Dynamics CRM Online server.

The following tables list the members exposed by the OnlineFederationPolicyConfiguration type.

Public Properties

 | Name | Description
public property | OnlineProviders | Contains the available identity providers for the Microsoft Dynamics CRM Online service. (inherited from OnlinePolicyConfiguration)
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OnlineFederationPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


OnlineFederationPolicyConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OnlineFederationPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


OnlineFederationPolicyConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | OnlineProviders | Contains the available identity providers for the Microsoft Dynamics CRM Online service. (inherited from OnlinePolicyConfiguration)
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)

See Also

Reference

OnlineFederationPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


OnlineIdentityProvider Class
See Also Members
[image]

Represents a Microsoft Online Services based identity provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class OnlineIdentityProvider
    Inherits IdentityProvider

C#
public sealed class OnlineIdentityProvider : IdentityProvider

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.IdentityProvider
    Microsoft.Xrm.Sdk.Client.OnlineIdentityProvider
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OnlineIdentityProvider Members
Microsoft.Xrm.Sdk.Client Namespace


OnlineIdentityProvider Members
See Also Constructors Methods Properties
[image]

Represents a Microsoft Online Services based identity provider.

The following tables list the members exposed by the OnlineIdentityProvider type.

Public Constructors

Name | Description
OnlineIdentityProvider | Initializes a new instance of the OnlineIdentityProvider class.
Top

Public Properties

 | Name | Description
public property | IdentityProviderType | The type of identity provider used by an endpoint. (inherited from IdentityProvider)
public property | ServiceUrl | Specifies the URL of the identity provider service. (inherited from IdentityProvider)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OnlineIdentityProvider Class
Microsoft.Xrm.Sdk.Client Namespace


OnlineIdentityProvider Constructor
[image]

Initializes a new instance of the OnlineIdentityProvider class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OnlineIdentityProvider ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OnlineIdentityProvider Class
OnlineIdentityProvider Members
Microsoft.Xrm.Sdk.Client Namespace


OnlineIdentityProvider Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OnlineIdentityProvider Class
Microsoft.Xrm.Sdk.Client Namespace


OnlineIdentityProvider Properties
[image]

Public Properties

 | Name | Description
public property | IdentityProviderType | The type of identity provider used by an endpoint. (inherited from IdentityProvider)
public property | ServiceUrl | Specifies the URL of the identity provider service. (inherited from IdentityProvider)

See Also

Reference

OnlineIdentityProvider Class
Microsoft.Xrm.Sdk.Client Namespace


OnlinePolicyConfiguration Class
See Also Members
[image]

Contains general information used when connecting to Microsoft Dynamics CRM Online.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecuritySafeCriticalAttribute> _
<SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted:=True)> _
Public MustInherit Class OnlinePolicyConfiguration
    Inherits PolicyConfiguration

C#
[SecuritySafeCriticalAttribute]
[SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted=true)]
public abstract class OnlinePolicyConfiguration : PolicyConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.PolicyConfiguration
    Microsoft.Xrm.Sdk.Client.OnlinePolicyConfiguration

                Microsoft.Xrm.Sdk.Client.LiveIdPolicyConfiguration

                Microsoft.Xrm.Sdk.Client.OnlineFederationPolicyConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OnlinePolicyConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


OnlinePolicyConfiguration Members
See Also Methods Properties
[image]

Contains general information used when connecting to Microsoft Dynamics CRM Online.

The following tables list the members exposed by the OnlinePolicyConfiguration type.

Public Properties

 | Name | Description
public property | OnlineProviders | Contains the available identity providers for the Microsoft Dynamics CRM Online service.
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OnlinePolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


OnlinePolicyConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OnlinePolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


OnlinePolicyConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | OnlineProviders | Contains the available identity providers for the Microsoft Dynamics CRM Online service.
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)

See Also

Reference

OnlinePolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


OnlinePolicyConfiguration.OnlineProviders Property
[image]

Contains the available identity providers for the Microsoft Dynamics CRM Online service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property OnlineProviders As IdentityProviderTypeDictionary

C#
public IdentityProviderTypeDictionary OnlineProviders { get; }

C++

J#

JScript

Property Value
Type: IdentityProviderTypeDictionaryThe available identity providers for the Microsoft Dynamics CRM Online service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OnlinePolicyConfiguration Class
OnlinePolicyConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext Class
See Also Members
[image]

Represents the runtime context of the data service that is used to track Microsoft Dynamics CRM entities and that sends and receives entities from the server.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Maintainability", "CA1506:AvoidExcessiveClassCoupling")> _
<SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification:="This class is used as base by crmsvcutil")> _
Public Class OrganizationServiceContext
    Implements IDisposable

C#
[SuppressMessageAttribute("Microsoft.Maintainability", "CA1506:AvoidExcessiveClassCoupling")]
[SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification="This class is used as base by crmsvcutil")]
public class OrganizationServiceContext : IDisposable

C++

J#

JScript

  Remarks
The organization service context class maintains state on the client between interactions with the Microsoft Dynamics CRM Web service to support features such as change management. This class also manages identities and tracks changes to Microsoft Dynamics CRM data. The organization service context class implements the IQueryable interface and a .NET Language-Integrated Query (LINQ) query provider so you can write LINQ queries against Microsoft Dynamics CRM data.
Objects tracked by the organization service context are instances of entity types that represent data in Microsoft Dynamics CRM. You can designate actions to be performed on these objects and the service context tracks the changes. When the SaveChanges method is called, the service context instructs Microsoft Dynamics CRM to generate commands to create, update or delete the entities the tracked objects represent.
The code generation tool (CrmSvcUtil.exe) can be used to create a custom instance of the OrganizationServiceContext class. This class includes customizations and provides helper properties and methods for working with entities.
Several enumerations are used with the OrganizationServiceContext class. The MergeOption enumeration indicates how changes are applied to Microsoft Dynamics CRM data. The SaveChangesOptions enumeration determines how changes are managed by the service context if an error occurs.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.OrganizationServiceContext
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)
Use the Early Bound Entity Classes for Create, Update, and Delete
Use the Early Bound Entity Classes to Add or Update Associations Between Related Records
Sample: Use the Organization Service Context


OrganizationServiceContext Members
See Also Constructors Methods Properties
[image]

Represents the runtime context of the data service that is used to track Microsoft Dynamics CRM entities and that sends and receives entities from the server.

The following tables list the members exposed by the OrganizationServiceContext type.

Public Constructors

Name | Description
OrganizationServiceContext | Creates a new instance of the OrganizationServiceContext class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | MergeOption | Gets or sets the synchronization option for receiving entities from the Web service.
public property | SaveChangesDefaultOptions | Gets or sets the SaveChangesOptions values that are used by the SaveChanges(SaveChangesOptions) method.
Top

Protected Properties

 | Name | Description
protected property | QueryProvider | Gets the query provider.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddLink | Adds the specified link to the set of objects the OrganizationServiceContext is tracking.
public method | AddObject | Adds the specified entity to the set of entities that the OrganizationServiceContext is tracking.
public method | AddRelatedObject | Adds a related entity to the OrganizationServiceContext and creates the link that defines the relationship between the two entities in a single request.
public method | Attach | Notifies the OrganizationServiceContext to start tracking the specified entity.
public method | AttachLink | Notifies the OrganizationServiceContext to start tracking the specified link that defines a relationship between entity objects.
public method | ClearChanges | Clears all tracking of entities by the OrganizationServiceContext.
public method | CreateQuery | Overloaded. Creates a web service .NET Language-Integrated Query (LINQ) query for the specified entity.
public method | DeleteLink | Changes the state of the link to deleted in the list of links being tracked by the OrganizationServiceContext.
public method | DeleteObject | Overloaded. Changes the state of the specified entity to be deleted in the OrganizationServiceContext.
public method | Detach | Overloaded. Removes the entity from the set of entities that the OrganizationServiceContext is tracking.
public method | DetachLink | Removes the specified link from the list of links being tracked by the OrganizationServiceContext.
public method | Dispose | Overloaded. Disposes of the service context.
public method | Equals | (inherited from Object)
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | GetAttachedEntities | Gets an enumerable collection of the entities attached to the OrganizationServiceContext.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsAttached | Overloaded. Determines whether an entity or an entity relationship is attached and therefore being tracked by the OrganizationServiceContext.
public method | IsDeleted | Overloaded. Determines whether an entity or an entity relationship has been deleted.
public method | LoadProperty | Overloaded. Loads deferred content for a specified property from the web service.
public method | SaveChanges | Overloaded. Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.
public method | ToString | (inherited from Object)
public method | UpdateObject | Overloaded. Changes the state of the specified entity in the OrganizationServiceContext to Modified.
Top

Protected Methods

 | Name | Description
protected method | CreateQuery | Overloaded. Creates a web service .NET Language-Integrated Query (LINQ) query for the specified entity.
protected method | Dispose | Overloaded. Disposes of the service context.
protected method | Finalize | Overridden. Destructor for the OrganizationServiceContext class.
protected method | MemberwiseClone | (inherited from Object)
protected method | OnBeginEntityTracking | Virtual (Overridable) method called when entity tracking begins.
protected method | OnBeginLinkTracking | Virtual (Overridable) method called when link tracking begins.
protected method | OnEndEntityTracking | Virtual (Overridable) method called after entity tracking ends.
protected method | OnEndLinkTracking | Virtual (Overridable) method called after link tracking ends.
protected method | OnExecute | Overloaded. Virtual (Overridable) methods called after Execute is called.
protected method | OnExecuting | Virtual (Overridable) method called before Execute is called.
protected method | OnSaveChanges | Virtual (Overridable) method called after an attempt to save data changes.
protected method | OnSavingChanges | Virtual (Overridable) method called before an attempt to save changes is performed.
Top

See Also

Reference

OrganizationServiceContext Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)
Use the Early Bound Entity Classes for Create, Update, and Delete
Use the Early Bound Entity Classes to Add or Update Associations Between Related Records
Sample: Use the Organization Service Context


OrganizationServiceContext Constructor
[image]

Creates a new instance of the OrganizationServiceContext class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    service As IOrganizationService _
)

C#
public OrganizationServiceContext (
    IOrganizationService service
)

C++

J#

JScript

Parameters
service
Type: IOrganizationService. The service that provides access to organization data.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddLink | Adds the specified link to the set of objects the OrganizationServiceContext is tracking.
public method | AddObject | Adds the specified entity to the set of entities that the OrganizationServiceContext is tracking.
public method | AddRelatedObject | Adds a related entity to the OrganizationServiceContext and creates the link that defines the relationship between the two entities in a single request.
public method | Attach | Notifies the OrganizationServiceContext to start tracking the specified entity.
public method | AttachLink | Notifies the OrganizationServiceContext to start tracking the specified link that defines a relationship between entity objects.
public method | ClearChanges | Clears all tracking of entities by the OrganizationServiceContext.
public method | CreateQuery | Overloaded. Creates a web service .NET Language-Integrated Query (LINQ) query for the specified entity.
public method | DeleteLink | Changes the state of the link to deleted in the list of links being tracked by the OrganizationServiceContext.
public method | DeleteObject | Overloaded. Changes the state of the specified entity to be deleted in the OrganizationServiceContext.
public method | Detach | Overloaded. Removes the entity from the set of entities that the OrganizationServiceContext is tracking.
public method | DetachLink | Removes the specified link from the list of links being tracked by the OrganizationServiceContext.
public method | Dispose | Overloaded. Disposes of the service context.
public method | Equals | (inherited from Object)
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | GetAttachedEntities | Gets an enumerable collection of the entities attached to the OrganizationServiceContext.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsAttached | Overloaded. Determines whether an entity or an entity relationship is attached and therefore being tracked by the OrganizationServiceContext.
public method | IsDeleted | Overloaded. Determines whether an entity or an entity relationship has been deleted.
public method | LoadProperty | Overloaded. Loads deferred content for a specified property from the web service.
public method | SaveChanges | Overloaded. Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.
public method | ToString | (inherited from Object)
public method | UpdateObject | Overloaded. Changes the state of the specified entity in the OrganizationServiceContext to Modified.

Protected Methods

 | Name | Description
protected method | CreateQuery | Overloaded. Creates a web service .NET Language-Integrated Query (LINQ) query for the specified entity.
protected method | Dispose | Overloaded. Disposes of the service context.
protected method | Finalize | Overridden. Destructor for the OrganizationServiceContext class.
protected method | MemberwiseClone | (inherited from Object)
protected method | OnBeginEntityTracking | Virtual (Overridable) method called when entity tracking begins.
protected method | OnBeginLinkTracking | Virtual (Overridable) method called when link tracking begins.
protected method | OnEndEntityTracking | Virtual (Overridable) method called after entity tracking ends.
protected method | OnEndLinkTracking | Virtual (Overridable) method called after link tracking ends.
protected method | OnExecute | Overloaded. Virtual (Overridable) methods called after Execute is called.
protected method | OnExecuting | Virtual (Overridable) method called before Execute is called.
protected method | OnSaveChanges | Virtual (Overridable) method called after an attempt to save data changes.
protected method | OnSavingChanges | Virtual (Overridable) method called before an attempt to save changes is performed.

See Also

Reference

OrganizationServiceContext Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)
Use the Early Bound Entity Classes for Create, Update, and Delete
Use the Early Bound Entity Classes to Add or Update Associations Between Related Records
Sample: Use the Organization Service Context


OrganizationServiceContext.AddLink Method
[image]

Adds the specified link to the set of objects the OrganizationServiceContext is tracking.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddLink ( _
    source As Entity, _
    relationship As Relationship, _
    target As Entity _
)

C#
public void AddLink (
    Entity source,
    Relationship relationship,
    Entity target
)

C++

J#

JScript

Parameters
source
Type: Entity. The source entity for the new link.
relationship
Type: Relationship. The navigation property or attribute on the source object that returns the related object.
target
Type: Entity. The entity related to the source entity by the new link.
  Remarks
Notifies the OrganizationServiceContext that a new link exists between the related source and target objects and that the link is represented by the specified entity attribute or navigation property. The OrganizationServiceContext adds this link to the set of newly created links that are sent to the Web service on the next call to SaveChanges method.Links are one-way relationships. Because associations are bi-directional, in a one-to-one association you must call AddLink again to create the reverse link.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.AddObject Method
[image]

Adds the specified entity to the set of entities that the OrganizationServiceContext is tracking.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddObject ( _
    entity As Entity _
)

C#
public void AddObject (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity to be tracked by the OrganizationServiceContext.
  Remarks
The entity is put into the tracking set of the OrganizationServiceContext in the Added state. The OrganizationServiceContext will attempt to insert the entity into the CRM on the next call to the SaveChanges. This method does not add entities related to the specified entity to the OrganizationServiceContext. Each object must be added through a separate call to AddObject.
The method does not validate that the entity set specified is in the Web service associated with the OrganizationServiceContext or that the added entity has the required attributes needed to be added to the specified entity set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.AddRelatedObject Method
[image]

Adds a related entity to the OrganizationServiceContext and creates the link that defines the relationship between the two entities in a single request.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddRelatedObject ( _
    source As Entity, _
    relationship As Relationship, _
    target As Entity _
)

C#
public void AddRelatedObject (
    Entity source,
    Relationship relationship,
    Entity target
)

C++

J#

JScript

Parameters
source
Type: Entity. The parent entity that is being tracked by the context.
relationship
Type: Relationship. The name of the attribute or navigation property that returns the related object based on an association between the two entities.
target
Type: Entity. The related object that is being added.
  Remarks
This method essentially works by calling AddObject and AddLink.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.Attach Method
[image]

Notifies the OrganizationServiceContext to start tracking the specified entity.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Attach ( _
    entity As Entity _
)

C#
public void Attach (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity to be tracked.
  Remarks
If the entity is part of an object graph, this operation does not traverse the graph to add related objects. It is a shallow operation.The method does not validate whether the specified entity set occurs in the Web service associated with the OrganizationServiceContext.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.AttachLink Method
[image]

Notifies the OrganizationServiceContext to start tracking the specified link that defines a relationship between entity objects.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AttachLink ( _
    source As Entity, _
    relationship As Relationship, _
    target As Entity _
)

C#
public void AttachLink (
    Entity source,
    Relationship relationship,
    Entity target
)

C++

J#

JScript

Parameters
source
Type: Entity. The source entity in the new link.
relationship
Type: Relationship. The name of the attribute or navigation property on the source object that represents the link between the source and target object.
target
Type: Entity. The target entity in the link that is bound to the source entity specified in this call.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.ClearChanges Method
[image]

Clears all tracking of entities by the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub ClearChanges

C#
public void ClearChanges ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.CreateQuery Method
[image]

Creates a web service .NET Language-Integrated Query (LINQ) query for the specified entity.

Overload List

Name | Description
OrganizationServiceContext.CreateQuery (String) | Creates a web service .NET Language-Integrated Query (LINQ) query for the specified entity.
OrganizationServiceContext.CreateQuery () | Creates a Web service .NET Language-Integrated Query (LINQ) query for the specified entity.
OrganizationServiceContext.CreateQuery (IQueryProvider, String) | Creates a web service .NET Language-Integrated Query (LINQ) query for the specified entity.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.CreateQuery Method (String)
[image]

Creates a web service .NET Language-Integrated Query (LINQ) query for the specified entity.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CreateQuery ( _
    entityLogicalName As String _
) As IQueryable(Of Entity)

C#
public IQueryable<Entity> CreateQuery (
    string entityLogicalName
)

C++

J#

JScript

Parameters
entityLogicalName
Type: String. The logical name of the entity to be queried.
Return Value
Type:  IQueryable<Entity>.
The query of the specified entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.CreateQuery Method ()
[image]

Creates a Web service .NET Language-Integrated Query (LINQ) query for the specified entity.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CreateQuery(Of TEntity As Entity) As IQueryable(Of TEntity)

C#
public IQueryable<TEntity> CreateQuery<TEntity> () where TEntity : Entity

C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The entity to be queried.
Return Value
Type:  IQueryable<Entity>
The query of the specified entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.CreateQuery Method (IQueryProvider, String)
[image]

Creates a web service .NET Language-Integrated Query (LINQ) query for the specified entity.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Function CreateQuery(Of TEntity) ( _
    provider As IQueryProvider, _
    entityLogicalName As String _
) As IQueryable(Of TEntity)

C#
protected virtual IQueryable<TEntity> CreateQuery<TEntity> (
    IQueryProvider provider,
    string entityLogicalName
)

C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The entity to be queried.
Parameters
provider
Type: IQueryProvider. The provider of the Web service.
entityLogicalName
Type: String. The logical name of the entity to be queried.
Return Value
Type:  IQueryable<Entity>
The query of the specified entity type..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.DeleteLink Method
[image]

Changes the state of the link to deleted in the list of links being tracked by the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub DeleteLink ( _
    source As Entity, _
    relationship As Relationship, _
    target As Entity _
)

C#
public void DeleteLink (
    Entity source,
    Relationship relationship,
    Entity target
)

C++

J#

JScript

Parameters
source
Type: Entity. The source entity in the link to be marked for deletion.
relationship
Type: Relationship. The name of the attribute or navigation property on the source entity that is used to access the target entity.
target
Type: Entity. The target entity involved in the link that is bound to the source entity.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.DeleteObject Method
[image]

Changes the state of the specified entity to be deleted in the OrganizationServiceContext.

Overload List

Name | Description
OrganizationServiceContext.DeleteObject (Entity) | Changes the state of the specified entity to be deleted in the OrganizationServiceContext.
OrganizationServiceContext.DeleteObject (Entity, Boolean) | Changes the state of the specified entity to be deleted in the OrganizationServiceContext.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.DeleteObject Method (Entity)
[image]

Changes the state of the specified entity to be deleted in the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub DeleteObject ( _
    entity As Entity _
)

C#
public void DeleteObject (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. The tracked entity to be changed to the deleted state.
  Remarks
All links to the specified entity are also marked deleted.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.DeleteObject Method (Entity, Boolean)
[image]

Changes the state of the specified entity to be deleted in the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub DeleteObject ( _
    entity As Entity, _
    recursive As Boolean _
)

C#
public void DeleteObject (
    Entity entity,
    bool recursive
)

C++

J#

JScript

Parameters
entity
Type: Entity. The tracked entity to be changed to the deleted state.
recursive
Type: Boolean. true to specify entities to be deleted recursively, otherwise false.
  Remarks
All links to the specified entity are also marked deleted.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.Detach Method
[image]

Removes the entity from the set of entities that the OrganizationServiceContext is tracking.

Overload List

Name | Description
OrganizationServiceContext.Detach (Entity) | Removes the entity from the set of entities that the OrganizationServiceContext is tracking.
OrganizationServiceContext.Detach (Entity, Boolean) | Removes the entity from the set of entities that the OrganizationServiceContext is tracking.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.Detach Method (Entity)
[image]

Removes the entity from the set of entities that the OrganizationServiceContext is tracking.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Detach ( _
    entity As Entity _
) As Boolean

C#
public bool Detach (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity to be removed from the set of entities that the OrganizationServiceContext is tracking.
Return Value
Type:  Boolean.
true if the specified entity was detached; otherwise false.

  Remarks
Once an object is detached, it is no longer tracked by the OrganizationServiceContext. The Detach method can be called to detach any object, regardless of its state in the context.After detaching the specified entity, this method also detaches any links related to the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.Detach Method (Entity, Boolean)
[image]

Removes the entity from the set of entities that the OrganizationServiceContext is tracking.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Detach ( _
    entity As Entity, _
    recursive As Boolean _
) As Boolean

C#
public bool Detach (
    Entity entity,
    bool recursive
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity to be removed from the set of entities that the OrganizationServiceContext is tracking.
recursive
Type: Boolean. true to specify entities to be detached recursively, otherwise false.
Return Value
Type:  Boolean.
Returns true if the specified entity was detached; otherwise false.

  Remarks
Once an object is detached, it is no longer tracked by the OrganizationServiceContext. The Detach method can be called to detach any object, regardless of its state in the context. After detaching the specified entity, this method also detaches any links related to the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.DetachLink Method
[image]

Removes the specified link from the list of links being tracked by the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function DetachLink ( _
    source As Entity, _
    relationship As Relationship, _
    target As Entity _
) As Boolean

C#
public bool DetachLink (
    Entity source,
    Relationship relationship,
    Entity target
)

C++

J#

JScript

Parameters
source
Type: Entity. The source entity participating in the link to be marked for deletion.
relationship
Type: Relationship. The name of the attribute or navigation property on the source entity that represents the source in the link between the source and the target.
target
Type: Entity. The target entity involved in the link that is bound to the source object.
Return Value
Type:  Boolean.
true if the specified entity was detached; otherwise false.

  Remarks
Any link being tracked by the OrganizationServiceContext, regardless of its current state, can be detached.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.Dispose Method
[image]

Disposes of the service context.

Overload List

Name | Description
OrganizationServiceContext.Dispose () | Disposes of the service context.
OrganizationServiceContext.Dispose (Boolean) | Disposes of the service context.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

IDisposable.Dispose Method


OrganizationServiceContext.Dispose Method ()
[image]

Disposes of the service context.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Dispose

C#
public void Dispose ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
IDisposable.Dispose Method


OrganizationServiceContext.Dispose Method (Boolean)
[image]

Disposes of the service context.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

C#
protected virtual void Dispose (
    bool disposing
)

C++

J#

JScript

Parameters
disposing
Type: Boolean.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
IDisposable.Dispose Method


OrganizationServiceContext.Execute Method
[image]

Executes a message in the form of a request, and returns a response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Execute ( _
    request As OrganizationRequest _
) As OrganizationResponse

C#
public OrganizationResponse Execute (
    OrganizationRequest request
)

C++

J#

JScript

Parameters
request
Type: OrganizationResponse. The request to be sent.
Return Value
Type:  OrganizationResponse.
The response returned from processing the organization request.

  Remarks
For more information see the Execute method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Use Messages (Request and Response Classes) with the Execute Method


OrganizationServiceContext.Finalize Method
[image]

Destructor for the OrganizationServiceContext class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Sub Finalize

C#
~OrganizationServiceContext()

C++

J#

JScript

  Remarks
Refer to the .NET Object.Finalize method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Object.Finalize Method


OrganizationServiceContext.GetAttachedEntities Method
[image]

Gets an enumerable collection of the entities attached to the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1024:UsePropertiesWhereAppropriate", Justification:="Method is appropriate.")> _
Public Function GetAttachedEntities As IEnumerable(Of Entity)

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1024:UsePropertiesWhereAppropriate", Justification="Method is appropriate.")]
public IEnumerable<Entity> GetAttachedEntities ()

C++

J#

JScript

Return Value
Type:  IEnumerable<Entity>.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.IsAttached Method
[image]

Determines whether an entity or an entity relationship is attached and therefore being tracked by the OrganizationServiceContext.

Overload List

Name | Description
OrganizationServiceContext.IsAttached (Entity) | Determines whether an entity is attached and therefore being tracked by the OrganizationServiceContext.
OrganizationServiceContext.IsAttached (Entity, Relationship, Entity) | Determines whether an entity relationship is attached and therefore being tracked by the OrganizationServiceContext.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.IsAttached Method (Entity)
[image]

Determines whether an entity is attached and therefore being tracked by the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function IsAttached ( _
    entity As Entity _
) As Boolean

C#
public bool IsAttached (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity to be determined if it is attached.
Return Value
Type:  Boolean.
true if the specified entity is attached to the OrganizationServiceContext; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.IsAttached Method (Entity, Relationship, Entity)
[image]

Determines whether an entity relationship is attached and therefore being tracked by the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function IsAttached ( _
    source As Entity, _
    relationship As Relationship, _
    target As Entity _
) As Boolean

C#
public bool IsAttached (
    Entity source,
    Relationship relationship,
    Entity target
)

C++

J#

JScript

Parameters
source
Type: Entity. The source entity in the link.
relationship
Type: Relationship. The name of the attribute or navigation property on the source entity that represents the link between the source and target entity.
target
Type: Entity. The target entity in the link.
Return Value
Type:  Boolean.
true if the specified entity is attached to the OrganizationServiceContext; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.IsDeleted Method
[image]

Determines whether an entity or an entity relationship has been deleted.

Overload List

Name | Description
OrganizationServiceContext.IsDeleted (Entity) | Determines whether an entity has been deleted.
OrganizationServiceContext.IsDeleted (Entity, Relationship, Entity) | Determines whether a relationship has been deleted.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.IsDeleted Method (Entity)
[image]

Determines whether an entity has been deleted.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function IsDeleted ( _
    entity As Entity _
) As Boolean

C#
public bool IsDeleted (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity to be determined if it is deleted.
Return Value
Type:  Boolean.
true if the specified entity is deleted; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.IsDeleted Method (Entity, Relationship, Entity)
[image]

Determines whether a relationship has been deleted.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function IsDeleted ( _
    source As Entity, _
    relationship As Relationship, _
    target As Entity _
) As Boolean

C#
public bool IsDeleted (
    Entity source,
    Relationship relationship,
    Entity target
)

C++

J#

JScript

Parameters
source
Type: Entity. The source entity in the link.
relationship
Type: Relationship. The name of the attribute or navigation property on the source entity that represents the link between the source and target entity.
target
Type: Entity. The target entity in the link.
Return Value
Type:  Boolean.
true if the specified entity is deleted; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.LoadProperty Method
[image]

Loads deferred content for a specified property from the web service.

Calling this method invokes a network operation to retrieve the property value. The property specified may be any one of the properties on the entity, including properties that represent associations or links.If the property represents an association, link or deferred property, calling this method provides the client a way to lazily load related resources. If the entity is in the unchanged or modified state, the property value loads the related entities and marks them unchanged with unchanged links. If the property is already loaded, calling this method lets you refresh the value of the property.

Overload List

Name | Description
OrganizationServiceContext.LoadProperty (Entity, Relationship) | Loads the related entity collection for the specified relationshp.
OrganizationServiceContext.LoadProperty (Entity, String) | Loads deferred content for a specified property from the Web service.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.LoadProperty Method (Entity, Relationship)
[image]

Loads the related entity collection for the specified relationshp.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub LoadProperty ( _
    entity As Entity, _
    relationship As Relationship _
)

C#
public void LoadProperty (
    Entity entity,
    Relationship relationship
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity with the relationship to be loaded.
relationship
Type: Relationship. The name of the attribute or navigation property on the entity that represents the relationship to be retrieved.
  Remarks
Calling this method invokes a network operation to retrieve the property value. The property specified may be any one of the properties on the entity, including properties that represent associations or links.If the property represents an association, link or deferred property, calling this method provides the client a way to lazily load related resources. If the entity is in the unchanged or modified state, the property value loads the related entities and marks them unchanged with unchanged links. If the property is already loaded, calling this method lets you refresh the value of the property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.LoadProperty Method (Entity, String)
[image]

Loads deferred content for a specified property from the Web service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub LoadProperty ( _
    entity As Entity, _
    propertyName As String _
)

C#
public void LoadProperty (
    Entity entity,
    string propertyName
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity that contains the property to load.
propertyName
Type: String. The name of the property of the specified entity to load.
  Remarks
Calling this method invokes a network operation to retrieve the property value. The property specified may be any one of the properties on the entity, including properties that represent associations or links.If the property represents an association, link or deferred property, calling this method provides the client a way to lazily load related resources. If the entity is in the unchanged or modified state, the property value loads the related entities and marks them unchanged with unchanged links. If the property is already loaded, calling this method lets you refresh the value of the property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.OnBeginEntityTracking Method
[image]

Virtual (Overridable) method called when entity tracking begins.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnBeginEntityTracking ( _
    entity As Entity _
)

C#
protected virtual void OnBeginEntityTracking (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity to be tracked by the OrganizationServiceContext.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace
OrganizationServiceContext


OrganizationServiceContext.OnBeginLinkTracking Method
[image]

Virtual (Overridable) method called when link tracking begins.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnBeginLinkTracking ( _
    source As Entity, _
    relationship As Relationship, _
    target As Entity _
)

C#
protected virtual void OnBeginLinkTracking (
    Entity source,
    Relationship relationship,
    Entity target
)

C++

J#

JScript

Parameters
source
Type: Relationship. The navigation property or attribute on the source object that returns the related object.
relationship
Type: Relationship. The name of the attribute or navigation property on the source object that represents the link between the source and target object.
target
Type: Entity. The target entity in the link that is bound to the source entity specified in this call.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.OnEndEntityTracking Method
[image]

Virtual (Overridable) method called after entity tracking ends.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnEndEntityTracking ( _
    entity As Entity _
)

C#
protected virtual void OnEndEntityTracking (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. The entity to be tracked by the OrganizationServiceContext.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.OnEndLinkTracking Method
[image]

Virtual (Overridable) method called after link tracking ends.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnEndLinkTracking ( _
    entity As Entity, _
    relationship As Relationship, _
    target As Entity _
)

C#
protected virtual void OnEndLinkTracking (
    Entity entity,
    Relationship relationship,
    Entity target
)

C++

J#

JScript

Parameters
entity
Type: Relationship. The navigation property or attribute on the source object that returns the related object.
relationship
Type: Relationship. The name of the attribute or navigation property on the source object that represents the link between the source and target object.
target
Type: Entity. The target entity in the link that is bound to the source entity specified in this call.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.OnExecute Method
[image]

Virtual (Overridable) methods called after Execute is called.

Overload List

Name | Description
OrganizationServiceContext.OnExecute (OrganizationRequest, OrganizationResponse) | Virtual (Overridable) method called after Execute is called and before a response is returned.
OrganizationServiceContext.OnExecute (OrganizationRequest, Exception) | Virtual (Overridable) method called after Execute is called and before an exception is re-thrown.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.OnExecute Method (OrganizationRequest, OrganizationResponse)
[image]

Virtual (Overridable) method called after Execute is called and before a response is returned.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnExecute ( _
    request As OrganizationRequest, _
    response As OrganizationResponse _
)

C#
protected virtual void OnExecute (
    OrganizationRequest request,
    OrganizationResponse response
)

C++

J#

JScript

Parameters
request
Type: OrganizationRequest. The request being processed.
response
Type: OrganizationResponse. The response that is to be returned from processing the request.
  Remarks
Execute is called by Execute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.OnExecute Method (OrganizationRequest, Exception)
[image]

Virtual (Overridable) method called after Execute is called and before an exception is re-thrown.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnExecute ( _
    request As OrganizationRequest, _
    exception As Exception _
)

C#
protected virtual void OnExecute (
    OrganizationRequest request,
    Exception exception
)

C++

J#

JScript

Parameters
request
Type: OrganizationRequest. The request being processed.
exception
Type: Exception. The exception thrown from processing the request.
  Remarks
Execute is called by Execute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.OnExecuting Method
[image]

Virtual (Overridable) method called before Execute is called.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnExecuting ( _
    request As OrganizationRequest _
)

C#
protected virtual void OnExecuting (
    OrganizationRequest request
)

C++

J#

JScript

Parameters
request
Type: OrganizationRequest. The request being processed.
  Remarks
Execute is called by Execute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.OnSaveChanges Method
[image]

Virtual (Overridable) method called after an attempt to save data changes.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnSaveChanges ( _
    results As SaveChangesResultCollection _
)

C#
protected virtual void OnSaveChanges (
    SaveChangesResultCollection results
)

C++

J#

JScript

Parameters
results
Type: SaveChangesResultCollection. The results of the save changes operation.
  Remarks
If saving of changes fails, this method is called before an exception is thrown.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.OnSavingChanges Method
[image]

Virtual (Overridable) method called before an attempt to save changes is performed.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnSavingChanges ( _
    options As SaveChangesOptions _
)

C#
protected virtual void OnSavingChanges (
    SaveChangesOptions options
)

C++

J#

JScript

Parameters
options
Type: SaveChangesOptions. Save changes options.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.SaveChanges Method
[image]

Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.Use the Organization Service Context Class Use the Early Bound Entity Classes for Create, Update, and Delete Sample: Use the Organization Service Context

Overload List

Name | Description
OrganizationServiceContext.SaveChanges () | Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.
OrganizationServiceContext.SaveChanges (SaveChangesOptions) | Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Use the Organization Service Context Class
Use the Early Bound Entity Classes for Create, Update, and Delete
Sample: Use the Organization Service Context


OrganizationServiceContext.SaveChanges Method ()
[image]

Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1002:DoNotExposeGenericLists", Justification:="Choosing performance over flexibility. Also changing result collection does not need to be tracked.")> _
Public Function SaveChanges As SaveChangesResultCollection

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1002:DoNotExposeGenericLists", Justification="Choosing performance over flexibility. Also changing result collection does not need to be tracked.")]
public SaveChangesResultCollection SaveChanges ()

C++

J#

JScript

Return Value
Type:  SaveChangesResultCollection
A SaveChangesResultCollection that contains status, headers, and errors that result from the call to SaveChanges.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Use the Organization Service Context Class
Use the Early Bound Entity Classes for Create, Update, and Delete
Sample: Use the Organization Service Context


OrganizationServiceContext.SaveChanges Method (SaveChangesOptions)
[image]

Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1002:DoNotExposeGenericLists", Justification:="Choosing performance over flexibility. Also changing result collection does not need to be tracked.")> _
Public Function SaveChanges ( _
    options As SaveChangesOptions _
) As SaveChangesResultCollection

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1002:DoNotExposeGenericLists", Justification="Choosing performance over flexibility. Also changing result collection does not need to be tracked.")]
public SaveChangesResultCollection SaveChanges (
    SaveChangesOptions options
)

C++

J#

JScript

Parameters
options
Type:  SaveChangesOptions. Indicates how changes are saved.
Return Value
Type:  SaveChangesResultCollection
A SaveChangesResultCollection that contains status, headers, and errors that result from the call to SaveChanges.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.UpdateObject Method
[image]

Changes the state of the specified entity in the OrganizationServiceContext to Modified.

Overload List

Name | Description
OrganizationServiceContext.UpdateObject (Entity) | Changes the state of the specified entity in the OrganizationServiceContext to Modified.
OrganizationServiceContext.UpdateObject (Entity, Boolean) | Changes the state of the specified entity in the OrganizationServiceContext to Modified.

See Also

Reference

OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.UpdateObject Method (Entity)
[image]

Changes the state of the specified entity in the OrganizationServiceContext to Modified.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub UpdateObject ( _
    entity As Entity _
)

C#
public void UpdateObject (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. The tracked entity to be assigned to the Modified state.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.UpdateObject Method (Entity, Boolean)
[image]

Changes the state of the specified entity in the OrganizationServiceContext to Modified.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub UpdateObject ( _
    entity As Entity, _
    recursive As Boolean _
)

C#
public void UpdateObject (
    Entity entity,
    bool recursive
)

C++

J#

JScript

Parameters
entity
Type: Entity. The tracked entity to be assigned to the Modified state.
recursive
Type: Boolean. true if operation should be recursive; otherwise false.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | MergeOption | Gets or sets the synchronization option for receiving entities from the Web service.
public property | SaveChangesDefaultOptions | Gets or sets the SaveChangesOptions values that are used by the SaveChanges(SaveChangesOptions) method.

Protected Properties

 | Name | Description
protected property | QueryProvider | Gets the query provider.

See Also

Reference

OrganizationServiceContext Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)
Use the Early Bound Entity Classes for Create, Update, and Delete
Use the Early Bound Entity Classes to Add or Update Associations Between Related Records
Sample: Use the Organization Service Context


OrganizationServiceContext.MergeOption Property
[image]

Gets or sets the synchronization option for receiving entities from the Web service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MergeOption As MergeOption

C#
public MergeOption MergeOption { get; set; }

C++

J#

JScript

Property Value
Type:  MergeOption
The synchronization option for receiving entities from the Web service.

  Remarks
This value is read by the deserialization component of the client before materializing objects. Set this property to the appropriate materialization option before executing any queries or updates to the data service. The default value is AppendOnly.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.QueryProvider Property
[image]

Gets the query provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Property QueryProvider As IQueryProvider

C#
protected virtual IQueryProvider QueryProvider { get; }

C++

J#

JScript

Property Value
Type:  IQueryProvider
The query provider.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceContext.SaveChangesDefaultOptions Property
[image]

Gets or sets the SaveChangesOptions values that are used by the SaveChanges(SaveChangesOptions) method.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SaveChangesDefaultOptions As SaveChangesOptions

C#
public SaveChangesOptions SaveChangesDefaultOptions { get; set; }

C++

J#

JScript

Property Value
Type:  SaveChangesOptions
The SaveChangesOptions values that are used by the SaveChanges(SaveChangesOptions) method.

  Remarks
This property is provided so that options such as merge and replace semantics can be set one time for the OrganizationServiceContext and then overridden as needed by calling SaveChanges(SaveChangesOptions).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContext Class
OrganizationServiceContext Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy Class
See Also Members
[image]

Implements IOrganizationService and provides an authenticated WCF channel to the organization service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification:="This class need to be instantiated by clients and be able to derive from it.")> _
Public Class OrganizationServiceProxy
    Inherits ServiceProxy(Of IOrganizationService)
    Implements IOrganizationService

C#
[SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification="This class need to be instantiated by clients and be able to derive from it.")]
public class OrganizationServiceProxy : ServiceProxy<IOrganizationService>, IOrganizationService

C++

J#

JScript

  Remarks
  To call the Microsoft Dynamics CRM web service using the IOrganizationService interface, cast the proxy instance to an IOrganizationService type.
  Important

                        This class is not thread safe. Microsoft Dynamics CRM Online authentication using the Microsoft Online Services environment identity provider, including Microsoft Office 365, is supported.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.ServiceProxy
    Microsoft.Xrm.Sdk.Client.OrganizationServiceProxy
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Active Directory and Claims-Based Authentication
Sample: Authenticate Users with Microsoft Dynamics CRM Web Services
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationServiceProxy Members
See Also Constructors Events Methods Properties
[image]

Implements IOrganizationService and provides an authenticated WCF channel to the organization service.

The following tables list the members exposed by the OrganizationServiceProxy type.

Public Constructors

Name | Description
OrganizationServiceProxy | Overloaded. Initializes a new instance of the OrganizationServiceProxy class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | CallerId | Gets or sets the ID of the user for whom SDK calls are made on behalf of.
public property | ClientCredentials | Gets the login credentials of the client. (inherited from ServiceProxy)
public property | DeviceCredentials | Gets the Windows Live credentials of a registered device. (inherited from ServiceProxy)
public property | EndpointAutoSwitchEnabled | Gets or sets a value that enables automatic switching from the organization’s current endpoint to an alternate endpoint. (inherited from ServiceProxy)
public property | EndpointSwitch | Gets the endpoint switch information from the web service configuration. (inherited from ServiceProxy)
public property | HomeRealmSecurityTokenResponse | Gets the security token response of the home realm. (inherited from ServiceProxy)
public property | HomeRealmUri | Gets the home realm URI. (inherited from ServiceProxy)
public property | IsAuthenticated | Gets a value indicating if the WCF channel has been authenticated. (inherited from ServiceProxy)
public property | SdkClientVersion | Gets or sets the version of the client.
public property | SecurityTokenResponse | Gets the security token response. (inherited from ServiceProxy)
public property | ServiceChannel | Gets the communication channel used to access a Microsoft Dynamics CRM service. (inherited from ServiceProxy)
public property | ServiceConfiguration | Gets a service configuration. (inherited from ServiceProxy)
public property | ServiceManagement | Gets a service management. (inherited from ServiceProxy)
public property | SyncOperationType | For internal use only.
public property | Timeout | Gets or sets the maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding. (inherited from ServiceProxy)
public property | UserPrincipalName | Gets or sets the UPN that is an Internet-style login name for a user based on the Internet standard RFC 822. (inherited from ServiceProxy)
Top

Protected Properties

 | Name | Description
protected property | ChannelFactory | Gets a WCF channel factory that manages a single channel instance. (inherited from ServiceProxy)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Associate | Creates a link between records.
public method | Authenticate | Closes the service channel and channel factory if they are open, and then invokes AuthenticateCore. (inherited from ServiceProxy)
public method | AuthenticateCrossRealm | Invokes AuthenticateCrossRealmCore. (inherited from ServiceProxy)
public method | AuthenticateDevice | Invokes AuthenticateDeviceCore. (inherited from ServiceProxy)
public method | Create | Creates a record.
public method | Delete | Deletes a record.
public method | Disassociate | Deletes a link between records.
public method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources. (inherited from ServiceProxy)
public method | EnableProxyTypes | Overloaded. Enables support for the early-bound entity types.
public method | Equals | (inherited from Object)
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Retrieve | Retrieves a record.
public method | RetrieveMultiple | Retrieves a collection of records.
public method | SwitchToAlternateEndpoint | Switches the organization’s current endpoint to an alternate endpoint, if one is available. (inherited from ServiceProxy)
public method | ToString | (inherited from Object)
public method | Update | Updates an existing record.
Top

Protected Methods

 | Name | Description
protected method | AuthenticateCore | Authenticates the client with a service. (inherited from ServiceProxy)
protected method | AuthenticateCrossRealmCore | Authenticates a user in a realm other than the realm that the Microsoft Dynamics CRM server is located in. (inherited from ServiceProxy)
protected method | AuthenticateDeviceCore | Authenticates a device with Windows Live. (inherited from ServiceProxy)
protected method | CloseChannel | Closes a validated service channel. (inherited from ServiceProxy)
protected method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources. (inherited from ServiceProxy)
protected method | Finalize | Overridden. Implicitly frees allocated service channel and service factory resources. (inherited from Object)
protected method | HandleFailover | Overloaded. For internal use only. (inherited from ServiceProxy)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnFactoryClosed | Event handler virtual method for a channel factory that is in a closed state. (inherited from ServiceProxy)
protected method | OnFactoryFaulted | Event handler virtual method for a channel factory that is in a faulted state. (inherited from ServiceProxy)
protected method | OnFactoryOpened | Event handler virtual method for a channel factory that is in an opened state. (inherited from ServiceProxy)
protected method | ShouldRetry | Checks a message security exception to determine if a service call should be attempted again. (inherited from ServiceProxy)
protected method | ValidateAuthentication | Authenticates the client and creates a new service channel. (inherited from ServiceProxy)
Top

Public Events

 | Name | Description
public event | EndpointSwitched | Occurs when a failover recovery has completed and the organization’s current endpoint has been switched to an alternate endpoint. (inherited from ServiceProxy)
public event | EndpointSwitchRequired | Occurs when a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required. (inherited from ServiceProxy)
public event | FactoryClosed | Occurs when a channel factory is closed. (inherited from ServiceProxy)
public event | FactoryFaulted | Occurs when a channel factory is faulted. (inherited from ServiceProxy)
public event | FactoryOpened | Occurs when a channel factory is opened. (inherited from ServiceProxy)
Top

See Also

Reference

OrganizationServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Active Directory and Claims-Based Authentication
Sample: Authenticate Users with Microsoft Dynamics CRM Web Services
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationServiceProxy Constructor
[image]

Initializes a new instance of the OrganizationServiceProxy class.

Overload List

Name | Description
OrganizationServiceProxy (IServiceConfiguration, SecurityTokenResponse) | Initializes a new instance of the OrganizationServiceProxy class using a service configuration and a security token response.
OrganizationServiceProxy (IServiceConfiguration, ClientCredentials) | Initializes a new instance of the OrganizationServiceProxy class using a service configuration and client credentials.
OrganizationServiceProxy (IServiceManagement, SecurityTokenResponse) | Initializes a new instance of the OrganizationServiceProxy class using a service management and a security token response.
OrganizationServiceProxy (IServiceManagement, ClientCredentials) | Initializes a new instance of the OrganizationServiceProxy class using a service configuration and client credentials.
OrganizationServiceProxy (Uri, Uri, ClientCredentials, ClientCredentials) | Initializes a new instance of the OrganizationServiceProxy class using a organization service URI, home realm URI, and client and device credentials.

See Also

Reference

OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
AuthenticateCrossRealm
AuthenticateDevice


OrganizationServiceProxy Constructor (IServiceConfiguration, SecurityTokenResponse)
[image]

Initializes a new instance of the OrganizationServiceProxy class using a service configuration and a security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceConfiguration As IServiceConfiguration(Of IOrganizationService), _
    securityTokenResponse As SecurityTokenResponse _
)

C#
public OrganizationServiceProxy (
    IServiceConfiguration<IOrganizationService> serviceConfiguration,
    SecurityTokenResponse securityTokenResponse
)

C++

J#

JScript

Parameters
serviceConfiguration
Type: IServiceConfiguration<IOrganizationService>. A service configuration.
securityTokenResponse
Type: SecurityTokenResponse. A security token response.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
AuthenticateCrossRealm
AuthenticateDevice


OrganizationServiceProxy Constructor (IServiceConfiguration, ClientCredentials)
[image]

Initializes a new instance of the OrganizationServiceProxy class using a service configuration and client credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceConfiguration As IServiceConfiguration(Of IOrganizationService), _
    clientCredentials As ClientCredentials _
)

C#
public OrganizationServiceProxy (
    IServiceConfiguration<IOrganizationService> serviceConfiguration,
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
serviceConfiguration
Type: IServiceConfiguration<IOrganizationService>. A service configuration.
clientCredentials
Type: ClientCredentials. The logon credentials of the client.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy Constructor (IServiceManagement, SecurityTokenResponse)
[image]

Initializes a new instance of the OrganizationServiceProxy class using a service management and a security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceManagement As IServiceManagement(Of IOrganizationService), _
    securityTokenResponse As SecurityTokenResponse _
)

C#
public OrganizationServiceProxy (
    IServiceManagement<IOrganizationService> serviceManagement,
    SecurityTokenResponse securityTokenResponse
)

C++

J#

JScript

Parameters
serviceManagement
Type: IServiceManagement<IOrganizationService>. A service management.
securityTokenResponse
Type: SecurityTokenResponse. A security token response.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy Constructor (IServiceManagement, ClientCredentials)
[image]

Initializes a new instance of the OrganizationServiceProxy class using a service configuration and client credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceManagement As IServiceManagement(Of IOrganizationService), _
    clientCredentials As ClientCredentials _
)

C#
public OrganizationServiceProxy (
    IServiceManagement<IOrganizationService> serviceManagement,
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
serviceManagement
Type: IServiceManagement<IOrganizationService>. A service management.
clientCredentials
Type: ClientCredentials. The logon credentials of the client.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy Constructor (Uri, Uri, ClientCredentials, ClientCredentials)
[image]

Initializes a new instance of the OrganizationServiceProxy class using a organization service URI, home realm URI, and client and device credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    uri As Uri, _
    homeRealmUri As Uri, _
    clientCredentials As ClientCredentials, _
    deviceCredentials As ClientCredentials _
)

C#
public OrganizationServiceProxy (
    Uri uri,
    Uri homeRealmUri,
    ClientCredentials clientCredentials,
    ClientCredentials deviceCredentials
)

C++

J#

JScript

Parameters
uri
Type: URI. The URI of the organization service.
homeRealmUri
Type: URI. This parameter is set to a non-null value when a second ADFS instance is configured as an identity provider to the ADFS instance that Microsoft Dynamics CRM 2011 has been configured with for claims authentication. The parameter value is the URI of the WS-Trust metadata endpoint of the second ADFS instance.
clientCredentials
Type: ClientCredentials. The logon credentials of the client.
deviceCredentials
Type: ClientCredentials. The Windows Live ID device credentials.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Helper Code: DeviceIdManager Class


OrganizationServiceProxy Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Associate | Creates a link between records.
public method | Authenticate | Closes the service channel and channel factory if they are open, and then invokes AuthenticateCore. (inherited from ServiceProxy)
public method | AuthenticateCrossRealm | Invokes AuthenticateCrossRealmCore. (inherited from ServiceProxy)
public method | AuthenticateDevice | Invokes AuthenticateDeviceCore. (inherited from ServiceProxy)
public method | Create | Creates a record.
public method | Delete | Deletes a record.
public method | Disassociate | Deletes a link between records.
public method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources. (inherited from ServiceProxy)
public method | EnableProxyTypes | Overloaded. Enables support for the early-bound entity types.
public method | Equals | (inherited from Object)
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Retrieve | Retrieves a record.
public method | RetrieveMultiple | Retrieves a collection of records.
public method | SwitchToAlternateEndpoint | Switches the organization’s current endpoint to an alternate endpoint, if one is available. (inherited from ServiceProxy)
public method | ToString | (inherited from Object)
public method | Update | Updates an existing record.

Protected Methods

 | Name | Description
protected method | AuthenticateCore | Authenticates the client with a service. (inherited from ServiceProxy)
protected method | AuthenticateCrossRealmCore | Authenticates a user in a realm other than the realm that the Microsoft Dynamics CRM server is located in. (inherited from ServiceProxy)
protected method | AuthenticateDeviceCore | Authenticates a device with Windows Live. (inherited from ServiceProxy)
protected method | CloseChannel | Closes a validated service channel. (inherited from ServiceProxy)
protected method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources. (inherited from ServiceProxy)
protected method | Finalize | Overridden. Implicitly frees allocated service channel and service factory resources. (inherited from Object)
protected method | HandleFailover | Overloaded. For internal use only. (inherited from ServiceProxy)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnFactoryClosed | Event handler virtual method for a channel factory that is in a closed state. (inherited from ServiceProxy)
protected method | OnFactoryFaulted | Event handler virtual method for a channel factory that is in a faulted state. (inherited from ServiceProxy)
protected method | OnFactoryOpened | Event handler virtual method for a channel factory that is in an opened state. (inherited from ServiceProxy)
protected method | ShouldRetry | Checks a message security exception to determine if a service call should be attempted again. (inherited from ServiceProxy)
protected method | ValidateAuthentication | Authenticates the client and creates a new service channel. (inherited from ServiceProxy)

See Also

Reference

OrganizationServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Active Directory and Claims-Based Authentication
Sample: Authenticate Users with Microsoft Dynamics CRM Web Services
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationServiceProxy.Associate Method
[image]

Creates a link between records.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Associate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
public void Associate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
entityId
Type: Guid. The ID of the record to which the related records will be associated.
relationship
Type: Relationship. The name of the relationship to be used to create the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be associated.
  Remarks
The core implementation of the Associate method. For more information, see IOrganizationService.Associate.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service
Entity Metadata
Customize Entity Relationship Metadata


OrganizationServiceProxy.AssociateCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Sub AssociateCore ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
protected internal virtual void AssociateCore (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
entityId
relationship
relatedEntities
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.Create Method
[image]

Creates a record.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Create ( _
    entity As Entity _
) As Guid

C#
public Guid Create (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that contains the properties to set in the newly created record.
Return Value
Type: Guid
The ID of the created entity.

  Remarks
The core implementation of the Create method. For more information, see IOrganizationService.Create.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationServiceProxy.CreateCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Function CreateCore ( _
    entity As Entity _
) As Guid

C#
protected internal virtual Guid CreateCore (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Return Value
Type: Guid
The ID of the created entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.Delete Method
[image]

Deletes a record.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Delete ( _
    entityName As String, _
    id As Guid _
)

C#
public void Delete (
    string entityName,
    Guid id
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
id
Type: Guid. The ID of the record of the record to delete.
  Remarks
The core implementation of the Delete method. For more information, see IOrganizationService.Delete.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationServiceProxy.DeleteCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Sub DeleteCore ( _
    entityName As String, _
    id As Guid _
)

C#
protected internal virtual void DeleteCore (
    string entityName,
    Guid id
)

C++

J#

JScript

Parameters
entityName
id
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.Disassociate Method
[image]

Deletes a link between records.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Disassociate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
public void Disassociate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
entityId
Type: Guid. The ID of the record from which the related records will be disassociated.
relationship
Type: Relationship. The name of the relationship to be used to remove the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be disassociated.
  Remarks
The core implementation of the Disassociate method. For more information, see IOrganizationService.Disassociate.

                        For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationServiceProxy.DisassociateCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Sub DisassociateCore ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
protected internal virtual void DisassociateCore (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
entityId
relationship
relatedEntities
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.EnableProxyTypes Method
[image]

Enables support for the early-bound entity types.

Overload List

Name | Description
OrganizationServiceProxy.EnableProxyTypes () | Enables support for the early-bound entity types.
OrganizationServiceProxy.EnableProxyTypes (Assembly) | Enables support for the early-bound entity types exposed in a specified assembly.

See Also

Reference

OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.EnableProxyTypes Method ()
[image]

Enables support for the early-bound entity types.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub EnableProxyTypes

C#
public void EnableProxyTypes ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.EnableProxyTypes Method (Assembly)
[image]

Enables support for the early-bound entity types exposed in a specified assembly.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub EnableProxyTypes ( _
    assembly As Assembly _
)

C#
public void EnableProxyTypes (
    Assembly assembly
)

C++

J#

JScript

Parameters
assembly
Type: Assembly. An assembly containing early-bound entity types.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.Execute Method
[image]

Executes a message in the form of a request, and returns a response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Execute ( _
    request As OrganizationRequest _
) As OrganizationResponse

C#
public OrganizationResponse Execute (
    OrganizationRequest request
)

C++

J#

JScript

Parameters
request
Type: OrganizationRequest. An instance of a request class that defines the action to be performed.
Return Value
Type: OrganizationResponse.
You must cast the return value of this method to the specific instance of the response that corresponds to the Request parameter.

  Remarks
The core implementation of the Execute method. For more information, see IOrganizationService.Execute.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service
Use Messages (Request and Response Classes) with the Execute Method


OrganizationServiceProxy.ExecuteCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Function ExecuteCore ( _
    request As OrganizationRequest _
) As OrganizationResponse

C#
protected internal virtual OrganizationResponse ExecuteCore (
    OrganizationRequest request
)

C++

J#

JScript

Parameters
request
Return Value
Type: OrganizationResponse.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.Retrieve Method
[image]

Retrieves a record.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Retrieve ( _
    entityName As String, _
    id As Guid, _
    columnSet As ColumnSet _
) As Entity

C#
public Entity Retrieve (
    string entityName,
    Guid id,
    ColumnSet columnSet
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
id
Type: Guid. The ID of the record you want to retrieve.
columnSet
Type: ColumnSet. A query that specifies the set of columns, or attributes, to retrieve.
Return Value
Type: Entity.
The requested entity.

  Remarks
The core implementation of the Retrieve method. For more information, see IOrganizationService.Retrieve.

                        For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationServiceProxy.RetrieveCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Function RetrieveCore ( _
    entityName As String, _
    id As Guid, _
    columnSet As ColumnSet _
) As Entity

C#
protected internal virtual Entity RetrieveCore (
    string entityName,
    Guid id,
    ColumnSet columnSet
)

C++

J#

JScript

Parameters
entityName
id
columnSet
Return Value
Type:  Entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.RetrieveMultiple Method
[image]

Retrieves a collection of records.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function RetrieveMultiple ( _
    query As QueryBase _
) As EntityCollection

C#
public EntityCollection RetrieveMultiple (
    QueryBase query
)

C++

J#

JScript

Parameters
query
Type: QueryBase. A query that determines the set of records to retrieve.
Return Value
Type:  EntityCollection.
A collection of entity records.

  Remarks
The core implementation of the RetrieveMultiple method. For more information, see IOrganizationService.RetrieveMultiple.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service
Create Queries to Retrieve Data


OrganizationServiceProxy.RetrieveMultipleCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Function RetrieveMultipleCore ( _
    query As QueryBase _
) As EntityCollection

C#
protected internal virtual EntityCollection RetrieveMultipleCore (
    QueryBase query
)

C++

J#

JScript

Parameters
query
Return Value
Type:  EntityCollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.Update Method
[image]

Updates an existing record.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Update ( _
    entity As Entity _
)

C#
public void Update (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that has one or more properties set to be updated in the record.
  Remarks
The core implementation of the Update method. For more information, see IOrganizationService.Update.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationServiceProxy.UpdateCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Sub UpdateCore ( _
    entity As Entity _
)

C#
protected internal virtual void UpdateCore (
    Entity entity
)

C++

J#

JScript

Parameters
entity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | CallerId | Gets or sets the ID of the user for whom SDK calls are made on behalf of.
public property | ClientCredentials | Gets the login credentials of the client. (inherited from ServiceProxy)
public property | DeviceCredentials | Gets the Windows Live credentials of a registered device. (inherited from ServiceProxy)
public property | EndpointAutoSwitchEnabled | Gets or sets a value that enables automatic switching from the organization’s current endpoint to an alternate endpoint. (inherited from ServiceProxy)
public property | EndpointSwitch | Gets the endpoint switch information from the web service configuration. (inherited from ServiceProxy)
public property | HomeRealmSecurityTokenResponse | Gets the security token response of the home realm. (inherited from ServiceProxy)
public property | HomeRealmUri | Gets the home realm URI. (inherited from ServiceProxy)
public property | IsAuthenticated | Gets a value indicating if the WCF channel has been authenticated. (inherited from ServiceProxy)
public property | SdkClientVersion | Gets or sets the version of the client.
public property | SecurityTokenResponse | Gets the security token response. (inherited from ServiceProxy)
public property | ServiceChannel | Gets the communication channel used to access a Microsoft Dynamics CRM service. (inherited from ServiceProxy)
public property | ServiceConfiguration | Gets a service configuration. (inherited from ServiceProxy)
public property | ServiceManagement | Gets a service management. (inherited from ServiceProxy)
public property | SyncOperationType | For internal use only.
public property | Timeout | Gets or sets the maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding. (inherited from ServiceProxy)
public property | UserPrincipalName | Gets or sets the UPN that is an Internet-style login name for a user based on the Internet standard RFC 822. (inherited from ServiceProxy)

Protected Properties

 | Name | Description
protected property | ChannelFactory | Gets a WCF channel factory that manages a single channel instance. (inherited from ServiceProxy)

See Also

Reference

OrganizationServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Active Directory and Claims-Based Authentication
Sample: Authenticate Users with Microsoft Dynamics CRM Web Services
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationServiceProxy.CallerId Property
[image]

Gets or sets the ID of the user for whom SDK calls are made on behalf of.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CallerId As Guid

C#
public Guid CallerId { get; set; }

C++

J#

JScript

Property Value
Type: Guid.
The ID of the user for whom SDK calls are made on behalf of.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Impersonate Another User
Sample: Impersonate Using the ActOnBehalfOf Privilege


OrganizationServiceProxy.SdkClientVersion Property
[image]

Gets or sets the version of the client.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SdkClientVersion As String

C#
public string SdkClientVersion { get; set; }

C++

J#

JScript

Property Value
Type: String.
The version of the client.

  Remarks
.NET clients using the current assemblies will pass the value ‘6.0.0.0’ or higher to indicate the client version. .NET clients using assemblies for earlier versions will not pass a value. This difference allows for messages that retrieve attribute metadata for the appropriate version. This applies to the following messages:
  • RetrieveAllEntitiesRequest
  • RetrieveAttributeRequest
  • RetrieveEntityRequest
  • RetrieveMetadataChangesRequest

                        Microsoft Dynamics CRM 2013 and Microsoft Dynamics CRM Online introduced a new attribute type: ImageAttributeMetadata. .NET assemblies for previous versions do not recognize this type and an error occurs attempting to deserialize them. When attribute metadata is retrieved, if the assembly does not pass a SdkClientVersion value ImageAttributeMetadata attributes will not be returned.
Clients that do not use .NET assemblies need to include SdkClientVersion with a value of ‘6.0.0.0’ or higher in order to receive ImageAttributeMetadata attributes.
For JavaScript, this value can be added to the SOAP header as shown in the following code snippet taken from the SDK.MetaData.js library described in Sample: Retrieve Entity Metadata Using JavaScript.
JavaScript    Copy Code
<soapenv:Header><a:SdkClientVersion xmlns:a=\"http://schemas.microsoft.com/xrm/2011/Contracts\">6.0</a:SdkClientVersion></soapenv:Header>

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy.SyncOperationType Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SyncOperationType As String

C#
public string SyncOperationType { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceProxy Class
OrganizationServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


OrganizationServiceProxy Events
[image]

Public Events

 | Name | Description
public event | EndpointSwitched | Occurs when a failover recovery has completed and the organization’s current endpoint has been switched to an alternate endpoint.(inherited from ServiceProxy)
public event | EndpointSwitchRequired | Occurs when a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required.(inherited from ServiceProxy)
public event | FactoryClosed | Occurs when a channel factory is closed. (inherited from ServiceProxy)
public event | FactoryFaulted | Occurs when a channel factory is faulted.(inherited from ServiceProxy)
public event | FactoryOpened | Occurs when a channel factory is opened.(inherited from ServiceProxy)

See Also

Reference

OrganizationServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Active Directory and Claims-Based Authentication
Sample: Authenticate Users with Microsoft Dynamics CRM Web Services
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrgIdentityProviderTrustConfiguration Class
See Also Members
[image]

Contains identity provider configuration information specific to Microsoft Online Services ID.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecuritySafeCriticalAttribute> _
<SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted:=True)> _
Public NotInheritable Class OrgIdentityProviderTrustConfiguration
    Inherits IdentityProviderTrustConfiguration

C#
[SecuritySafeCriticalAttribute]
[SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted=true)]
public sealed class OrgIdentityProviderTrustConfiguration : IdentityProviderTrustConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.IdentityProviderTrustConfiguration
    Microsoft.Xrm.Sdk.Client.OrgIdentityProviderTrustConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrgIdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


OrgIdentityProviderTrustConfiguration Members
See Also Methods Properties
[image]

Contains identity provider configuration information specific to Microsoft Online Services ID.

The following tables list the members exposed by the OrgIdentityProviderTrustConfiguration type.

Public Properties

 | Name | Description
public property | AppliesTo | Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification. (inherited from IdentityProviderTrustConfiguration)
public property | Endpoint | Overridden. Gets the endpoint of the User ID identity provider.
public property | Identifier | Gets the name of the identity service.
public property | LiveIdAppliesTo | Gets or sets the scope that a Microsoft account security token request applies to, as defined in the WS-Trust specification. (inherited from IdentityProviderTrustConfiguration)
public property | LivePartnerIdentifier | The Windows Live ID provider that has a trust relationship with the OrgId provider. This is related to the transition of Windows Live ID organizations to the Microsoft Online Services environment.
public property | Policy | Gets or sets a policy configuration that identifies a Secure Token Service (STS). (inherited from IdentityProviderTrustConfiguration)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrgIdentityProviderTrustConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


OrgIdentityProviderTrustConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrgIdentityProviderTrustConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


OrgIdentityProviderTrustConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | AppliesTo | Gets or sets the scope that a security token request applies to, as defined in the WS-Trust specification. (inherited from IdentityProviderTrustConfiguration)
public property | Endpoint | Overridden. Gets the endpoint of the User ID identity provider.
public property | Identifier | Gets the name of the identity service.
public property | LiveIdAppliesTo | Gets or sets the scope that a Microsoft account security token request applies to, as defined in the WS-Trust specification. (inherited from IdentityProviderTrustConfiguration)
public property | LivePartnerIdentifier | The Windows Live ID provider that has a trust relationship with the OrgId provider. This is related to the transition of Windows Live ID organizations to the Microsoft Online Services environment.
public property | Policy | Gets or sets a policy configuration that identifies a Secure Token Service (STS). (inherited from IdentityProviderTrustConfiguration)

See Also

Reference

OrgIdentityProviderTrustConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


OrgIdentityProviderTrustConfiguration.Endpoint Property
[image]

Gets the endpoint of the User ID identity provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides ReadOnly Property Endpoint As Uri

C#
public override Uri Endpoint { get; }

C++

J#

JScript

Property Value
Type: URI
 The endpoint of the User ID identity provider.

  Remarks
User ID was previously called Microsoft Online Services ID.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrgIdentityProviderTrustConfiguration Class
OrgIdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


OrgIdentityProviderTrustConfiguration.Identifier Property
[image]

Gets the name of the identity service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Identifier As Uri

C#
public Uri Identifier { get; }

C++

J#

JScript

Property Value
Type:  URI
The name of the identity service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrgIdentityProviderTrustConfiguration Class
OrgIdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


OrgIdentityProviderTrustConfiguration.LivePartnerIdentifier Property
[image]

The Windows Live ID provider that has a trust relationship with the OrgId provider. This is related to the transition of Windows Live ID organizations to the Microsoft Online Services environment.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LivePartnerIdentifier As String

C#
public string LivePartnerIdentifier { get; }

C++

J#

JScript

Property Value
Type: String
The identifier of the Windows Live provider.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrgIdentityProviderTrustConfiguration Class
OrgIdentityProviderTrustConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


PolicyConfiguration Class
See Also Members
[image]

Contains a policy configuration that identifies a Secure Token Service (STS).

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustInherit Class PolicyConfiguration

C#
public abstract class PolicyConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.PolicyConfiguration

                Microsoft.Xrm.Sdk.Client.ClaimsPolicyConfiguration

                Microsoft.Xrm.Sdk.Client.OnlinePolicyConfiguration

                Microsoft.Xrm.Sdk.Client.WindowsPolicyConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PolicyConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


PolicyConfiguration Members
See Also Methods Properties
[image]

Contains a policy configuration that identifies a Secure Token Service (STS).

The following tables list the members exposed by the PolicyConfiguration type.

Public Properties

 | Name | Description
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


PolicyConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


PolicyConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider.

See Also

Reference

PolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


PolicyConfiguration.SecureTokenServiceIdentifier Property
[image]

Gets an identifier of a Secure Token Service (STS) provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SecureTokenServiceIdentifier As String

C#
public string SecureTokenServiceIdentifier { get; }

C++

J#

JScript

Property Value
Type:  String
The identifier of a Secure Token Service (STS) provider.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PolicyConfiguration Class
PolicyConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


ProxyTypesAssemblyAttribute Class
See Also Members
[image]

Indicates that the assembly contains early-bound types generated by the CrmSvcUtil utility.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Assembly)> _
Public NotInheritable Class ProxyTypesAssemblyAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Assembly)]
public sealed class ProxyTypesAssemblyAttribute : Attribute

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Client.ProxyTypesAssemblyAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyTypesAssemblyAttribute Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ProxyTypesAssemblyAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Indicates that the assembly contains early-bound types generated by the CrmSvcUtil utility.

The following tables list the members exposed by the ProxyTypesAssemblyAttribute type.

Public Constructors

Name | Description
ProxyTypesAssemblyAttribute | Initializes a new instance of the ProxyTypesAssemblyAttribute class.
Top

Public Properties

 | Name | Description
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

ProxyTypesAssemblyAttribute Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ProxyTypesAssemblyAttribute Constructor
[image]

Initializes a new instance of the ProxyTypesAssemblyAttribute class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProxyTypesAssemblyAttribute ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyTypesAssemblyAttribute Class
ProxyTypesAssemblyAttribute Members
Microsoft.Xrm.Sdk.Client Namespace


ProxyTypesAssemblyAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

ProxyTypesAssemblyAttribute Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ProxyTypesAssemblyAttribute Properties
[image]

Public Properties

 | Name | Description
public property | TypeId | (inherited from Attribute)

See Also

Reference

ProxyTypesAssemblyAttribute Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ProxyTypesBehavior Class
See Also Members
[image]

Enables early-bound entity types on a service proxy.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ProxyTypesBehavior
    Implements IEndpointBehavior

C#
public sealed class ProxyTypesBehavior : IEndpointBehavior

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.ProxyTypesBehavior
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyTypesBehavior Members
Microsoft.Xrm.Sdk.Client Namespace
DiscoveryServiceProxy
OrganizationServiceProxy


ProxyTypesBehavior Members
See Also Constructors Methods Explicit Interface Implementations
[image]

Enables early-bound entity types on a service proxy.

The following tables list the members exposed by the ProxyTypesBehavior type.

Public Constructors

Name | Description
ProxyTypesBehavior | Overloaded.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AddBindingParameters | Refer to the IEndpointBehavior Interface.
ApplyClientBehavior | Refer to the IEndpointBehavior Interface.
ApplyDispatchBehavior | Refer to the IEndpointBehavior Interface.
Validate | Refer to the IEndpointBehavior Interface.
Top

See Also

Reference

ProxyTypesBehavior Class
Microsoft.Xrm.Sdk.Client Namespace
DiscoveryServiceProxy
OrganizationServiceProxy


ProxyTypesBehavior Constructor
[image]

Overload List

Name | Description
ProxyTypesBehavior () | Initializes a new instance of the ProxyTypesBehavior class.
ProxyTypesBehavior (Assembly) | Initializes a new instance of the ProxyTypesBehavior class using an assembly containing proxy types generated by the CrmSvcUtil utility.

See Also

Reference

ProxyTypesBehavior Class
ProxyTypesBehavior Members
Microsoft.Xrm.Sdk.Client Namespace


ProxyTypesBehavior Constructor ()
[image]

Initializes a new instance of the ProxyTypesBehavior class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProxyTypesBehavior ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyTypesBehavior Class
ProxyTypesBehavior Members
Microsoft.Xrm.Sdk.Client Namespace


ProxyTypesBehavior Constructor (Assembly)
[image]

Initializes a new instance of the ProxyTypesBehavior class using an assembly containing proxy types generated by the CrmSvcUtil utility.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    proxyTypesAssembly As Assembly _
)

C#
public ProxyTypesBehavior (
    Assembly proxyTypesAssembly
)

C++

J#

JScript

Parameters
proxyTypesAssembly
Type: Assembly. An assembly containing proxy types.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyTypesBehavior Class
ProxyTypesBehavior Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ProxyTypesBehavior Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
AddBindingParameters | Refer to the IEndpointBehavior Interface.
ApplyClientBehavior | Refer to the IEndpointBehavior Interface.
ApplyDispatchBehavior | Refer to the IEndpointBehavior Interface.
Validate | Refer to the IEndpointBehavior Interface.

See Also

Reference

ProxyTypesBehavior Class
Microsoft.Xrm.Sdk.Client Namespace
DiscoveryServiceProxy
OrganizationServiceProxy


ProxyTypesBehavior.AddBindingParameters Method
[image]

Refer to the IEndpointBehavior Interface.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Private Sub System.ServiceModel.Description.IEndpointBehavior.AddBindingParameters ( _
    serviceEndpoint As ServiceEndpoint, _
    bindingParameters As BindingParameterCollection _
) Implements IEndpointBehavior.AddBindingParameters

C#
void IEndpointBehavior.AddBindingParameters (
    ServiceEndpoint serviceEndpoint,
    BindingParameterCollection bindingParameters
)

C++

J#

JScript

Parameters
serviceEndpoint
Type: ServiceEndpoint. A service endpoint.
bindingParameters
Type: BindingParameterCollection. A collection of binding parameters that store information used by binding elements to build factories.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyTypesBehavior Class
ProxyTypesBehavior Members
Microsoft.Xrm.Sdk.Client Namespace


ProxyTypesBehavior.ApplyClientBehavior Method
[image]

Refer to the IEndpointBehavior Interface.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Private Sub System.ServiceModel.Description.IEndpointBehavior.ApplyClientBehavior ( _
    serviceEndpoint As ServiceEndpoint, _
    behavior As ClientRuntime _
) Implements IEndpointBehavior.ApplyClientBehavior

C#
void IEndpointBehavior.ApplyClientBehavior (
    ServiceEndpoint serviceEndpoint,
    ClientRuntime behavior
)

C++

J#

JScript

Parameters
serviceEndpoint
Type: ServiceEndpoint. A service endpoint.
behavior
Type: ClientRuntime. The insertion point for classes that extend the functionality of Windows Communication Foundation (WCF) client objects.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyTypesBehavior Class
ProxyTypesBehavior Members
Microsoft.Xrm.Sdk.Client Namespace


ProxyTypesBehavior.ApplyDispatchBehavior Method
[image]

Refer to the IEndpointBehavior Interface.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Private Sub System.ServiceModel.Description.IEndpointBehavior.ApplyDispatchBehavior ( _
    serviceEndpoint As ServiceEndpoint, _
    endpointDispatcher As EndpointDispatcher _
) Implements IEndpointBehavior.ApplyDispatchBehavior

C#
void IEndpointBehavior.ApplyDispatchBehavior (
    ServiceEndpoint serviceEndpoint,
    EndpointDispatcher endpointDispatcher
)

C++

J#

JScript

Parameters
serviceEndpoint
Type: ServiceEndpoint. A service endpoint.
endpointDispatcher
Type: EndpointDispatcher. The run-time object that exposes properties that enable the insertion of run-time extensions or modifications for messages in service applications.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyTypesBehavior Class
ProxyTypesBehavior Members
Microsoft.Xrm.Sdk.Client Namespace


ProxyTypesBehavior.Validate Method
[image]

Refer to the IEndpointBehavior Interface.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Private Sub System.ServiceModel.Description.IEndpointBehavior.Validate ( _
    serviceEndpoint As ServiceEndpoint _
) Implements IEndpointBehavior.Validate

C#
void IEndpointBehavior.Validate (
    ServiceEndpoint serviceEndpoint
)

C++

J#

JScript

Parameters
serviceEndpoint
Type: ServiceEndpoint. A service endpoint.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyTypesBehavior Class
ProxyTypesBehavior Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class RealmInfo

C#
public sealed class RealmInfo

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.RealmInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the RealmInfo type.

Public Constructors

Name | Description
RealmInfo | For internal use only.
Top

Public Properties

 | Name | Description
public property | AllowFedUsersLiveIdSignIn | For internal use only.
public property | AuthorizationUrl | For internal use only.
public property | Certificate | For internal use only.
public property | DomainName | For internal use only.
public property | EduDomains | For internal use only.
public property | FederationBrandName | For internal use only.
public property | FederationGlobalVersion | For internal use only.
public property | FederationTier | For internal use only.
public property | IsFederatedNamespace | For internal use only.
public property | LogOn | For internal use only.
public property | MetadataUrl | For internal use only.
public property | NamespaceType |
public property | PreferredProtocol | For internal use only.
public property | SamlAuthUrl | For internal use only.
public property | State | For internal use only.
public property | TokenServiceAuthenticationUrl | For internal use only.
public property | UserState | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RealmInfo Class
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo Constructor
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RealmInfo ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RealmInfo Class
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo Properties
[image]

Public Properties

 | Name | Description
public property | AllowFedUsersLiveIdSignIn | For internal use only.
public property | AuthorizationUrl | For internal use only.
public property | Certificate | For internal use only.
public property | DomainName | For internal use only.
public property | EduDomains | For internal use only.
public property | FederationBrandName | For internal use only.
public property | FederationGlobalVersion | For internal use only.
public property | FederationTier | For internal use only.
public property | IsFederatedNamespace | For internal use only.
public property | LogOn | For internal use only.
public property | MetadataUrl | For internal use only.
public property | NamespaceType |
public property | PreferredProtocol | For internal use only.
public property | SamlAuthUrl | For internal use only.
public property | State | For internal use only.
public property | TokenServiceAuthenticationUrl | For internal use only.
public property | UserState | For internal use only.

See Also

Reference

RealmInfo Class
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.AllowFedUsersLiveIdSignIn Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("AllowFedUsersWLIDSignIn")> _
Public Property AllowFedUsersLiveIdSignIn As Boolean

C#
[XmlElementAttribute("AllowFedUsersWLIDSignIn")]
public bool AllowFedUsersLiveIdSignIn { get; set; }

C++

J#

JScript

Property Value
Type: Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.AuthorizationUrl Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification:="Uri is not XmlSerializable, and the name of the property is dictated by the spec", MessageId:="")> _
<XmlElementAttribute("AuthURL")> _
Public Property AuthorizationUrl As String

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification="Uri is not XmlSerializable, and the name of the property is dictated by the spec", MessageId="")]
[XmlElementAttribute("AuthURL")]
public string AuthorizationUrl { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.Certificate Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Certificate As String

C#
public string Certificate { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.DomainName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DomainName As String

C#
public string DomainName { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.EduDomains Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlIgnoreAttribute> _
<XmlElementAttribute("EDUDomainFlags")> _
Public Property EduDomains As Integer

C#
[XmlIgnoreAttribute]
[XmlElementAttribute("EDUDomainFlags")]
public int EduDomains { get; set; }

C++

J#

JScript

Property Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.FederationBrandName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FederationBrandName As String

C#
public string FederationBrandName { get; set; }

C++

J#

JScript

Property Value
Type:  String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.FederationGlobalVersion Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FederationGlobalVersion As String

C#
public string FederationGlobalVersion { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.FederationTier Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FederationTier As Integer

C#
public int FederationTier { get; set; }

C++

J#

JScript

Property Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.IsFederatedNamespace Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("IsFederatedNS")> _
Public Property IsFederatedNamespace As Boolean

C#
[XmlElementAttribute("IsFederatedNS")]
public bool IsFederatedNamespace { get; set; }

C++

J#

JScript

Property Value
Type: Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.LogOn Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LogOn As String

C#
public string LogOn { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.MetadataUrl Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification:="Uri is not XmlSerializable, and the name of the property is dictated by the spec", MessageId:="")> _
<XmlElementAttribute("MEXURL")> _
Public Property MetadataUrl As String

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification="Uri is not XmlSerializable, and the name of the property is dictated by the spec", MessageId="")]
[XmlElementAttribute("MEXURL")]
public string MetadataUrl { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.NamespaceType Property
[image]

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("NameSpaceType")> _
Public Property NamespaceType As String

C#
[XmlElementAttribute("NameSpaceType")]
public string NamespaceType { get; set; }

C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.PreferredProtocol Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PreferredProtocol As Integer

C#
public int PreferredProtocol { get; set; }

C++

J#

JScript

Property Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.SamlAuthUrl Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("SAML_AuthURL")> _
<SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification:="Uri is not XmlSerializable, and the name of the property is dictated by the spec", MessageId:="")> _
Public Property SamlAuthUrl As String

C#
[XmlElementAttribute("SAML_AuthURL")]
[SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification="Uri is not XmlSerializable, and the name of the property is dictated by the spec", MessageId="")]
public string SamlAuthUrl { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.State Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property State As String

C#
public string State { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.TokenServiceAuthenticationUrl Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification:="Uri is not XmlSerializable, and the name of the property is dictated by the spec", MessageId:="")> _
<XmlElementAttribute("STSAuthURL")> _
Public Property TokenServiceAuthenticationUrl As String

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification="Uri is not XmlSerializable, and the name of the property is dictated by the spec", MessageId="")]
[XmlElementAttribute("STSAuthURL")]
public string TokenServiceAuthenticationUrl { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RealmInfo.UserState Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserState As String

C#
public string UserState { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RealmInfo Class
RealmInfo Members
Microsoft.Xrm.Sdk.Client Namespace


RequestProxyAttribute Class
See Also Members
[image]

Indicates the name of the message request, represented by the SdkMessageRequest entity, to which the request corresponds.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public NotInheritable Class RequestProxyAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public sealed class RequestProxyAttribute : Attribute

C++

J#

JScript

  Remarks
This type is only created when the CrmSvcUtil program generates a request, which is turned off by default.

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Client.RequestProxyAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RequestProxyAttribute Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


RequestProxyAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Indicates the name of the message request, represented by the SdkMessageRequest entity, to which the request corresponds.

The following tables list the members exposed by the RequestProxyAttribute type.

Public Constructors

Name | Description
RequestProxyAttribute | Initializes a new instance of the RequestProxyAttribute class.
Top

Public Properties

 | Name | Description
public property | Name | Gets the name of the message request.
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

RequestProxyAttribute Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


RequestProxyAttribute Constructor
[image]

Initializes a new instance of the RequestProxyAttribute class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    name As String _
)

C#
public RequestProxyAttribute (
    string name
)

C++

J#

JScript

Parameters
name
Type: String. Specifies the name of the message request.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RequestProxyAttribute Class
RequestProxyAttribute Members
Microsoft.Xrm.Sdk.Client Namespace


RequestProxyAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

RequestProxyAttribute Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


RequestProxyAttribute Properties
[image]

Public Properties

 | Name | Description
public property | Name | Gets the name of the message request.
public property | TypeId | (inherited from Attribute)

See Also

Reference

RequestProxyAttribute Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


RequestProxyAttribute.Name Property
[image]

Gets the name of the message request.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Name As String

C#
public string Name { get; }

C++

J#

JScript

Property Value
Type: String
 The name of the message request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RequestProxyAttribute Class
RequestProxyAttribute Members
Microsoft.Xrm.Sdk.Client Namespace


ResponseProxyAttribute Class
See Also Members
[image]

Indicates the name of the message response, represented by the SdkMessageResponse entity, to which the response corresponds.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public NotInheritable Class ResponseProxyAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public sealed class ResponseProxyAttribute : Attribute

C++

J#

JScript

  Remarks
This type is only created when the CrmSvcUtil program generates a response, which is turned off by default.

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Client.ResponseProxyAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResponseProxyAttribute Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ResponseProxyAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Indicates the name of the message response, represented by the SdkMessageResponse entity, to which the response corresponds.

The following tables list the members exposed by the ResponseProxyAttribute type.

Public Constructors

Name | Description
ResponseProxyAttribute | Initializes a new instance of the ResponseProxyAttribute class.
Top

Public Properties

 | Name | Description
public property | Name | Gets the name of the message response.
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

ResponseProxyAttribute Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ResponseProxyAttribute Constructor
[image]

Initializes a new instance of the ResponseProxyAttribute class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    name As String _
)

C#
public ResponseProxyAttribute (
    string name
)

C++

J#

JScript

Parameters
name
Type: String. Specifies the name of the message response.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResponseProxyAttribute Class
ResponseProxyAttribute Members
Microsoft.Xrm.Sdk.Client Namespace


ResponseProxyAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

ResponseProxyAttribute Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ResponseProxyAttribute Properties
[image]

Public Properties

 | Name | Description
public property | Name | Gets the name of the message response.
public property | TypeId | (inherited from Attribute)

See Also

Reference

ResponseProxyAttribute Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Create Early-Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ResponseProxyAttribute.Name Property
[image]

Gets the name of the message response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Name As String

C#
public string Name { get; }

C++

J#

JScript

Property Value
Type: String
 The name of the message response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ResponseProxyAttribute Class
ResponseProxyAttribute Members
Microsoft.Xrm.Sdk.Client Namespace


SaveChangesOptions Enumeration
[image]

Describes how the SaveChanges method behaves when an error occurs while updating data in Microsoft Dynamics CRM.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FlagsAttribute> _
Public Enumeration SaveChangesOptions

C#
[FlagsAttribute]
public enum SaveChangesOptions

C++

J#

JScript

  Members
Member name | Description
ContinueOnError | The SaveChanges method should continue applying changes to tracked entities in Microsoft Dynamics CRM even if an action fails. Value = 1.
None | The SaveChanges method should throw an exception when an error occurs while updating data in Microsoft Dynamics CRM. Value = 0.
  Remarks
The SaveChanges method applies changes to tracked entities in Microsoft Dynamics CRM. If an error occurs while performing these updates, this enumeration indicates to the OrganizationServiceContext how it should handle errors. If the value is set to None and an error occurs, an exception is thrown with the SaveChangesResultCollection attached.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Client Namespace


SecurityTokenResponse Class
See Also Members
[image]

Contains a security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SecurityTokenResponse

C#
public sealed class SecurityTokenResponse

C++

J#

JScript

  Remarks
This class is a wrapper containing a security token request response and a security token.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.SecurityTokenResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityTokenResponse Members
Microsoft.Xrm.Sdk.Client Namespace


SecurityTokenResponse Members
See Also Constructors Methods Properties
[image]

Contains a security token response.

The following tables list the members exposed by the SecurityTokenResponse type.

Public Constructors

Name | Description
SecurityTokenResponse | Initializes a new instance of the SecurityTokenResponse class.
Top

Public Properties

 | Name | Description
public property | EndpointType | Gets or sets the type of endpoint that the security token applies to.
public property | Response | Gets or sets the security token request response.
public property | Token | Gets or sets the security token.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SecurityTokenResponse Class
Microsoft.Xrm.Sdk.Client Namespace


SecurityTokenResponse Constructor
[image]

Initializes a new instance of the SecurityTokenResponse class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SecurityTokenResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityTokenResponse Class
SecurityTokenResponse Members
Microsoft.Xrm.Sdk.Client Namespace


SecurityTokenResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SecurityTokenResponse Class
Microsoft.Xrm.Sdk.Client Namespace


SecurityTokenResponse Properties
[image]

Public Properties

 | Name | Description
public property | EndpointType | Gets or sets the type of endpoint that the security token applies to.
public property | Response | Gets or sets the security token request response.
public property | Token | Gets or sets the security token.

See Also

Reference

SecurityTokenResponse Class
Microsoft.Xrm.Sdk.Client Namespace


SecurityTokenResponse.EndpointType Property
[image]

Gets or sets the type of endpoint that the security token applies to.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic

C#

C++

J#

JScript

Property Value
Type:  TokenServiceCredentialType
The endpoint type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityTokenResponse Class
SecurityTokenResponse Members
Microsoft.Xrm.Sdk.Client Namespace


SecurityTokenResponse.Response Property
[image]

Gets or sets the security token request response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Response As RequestSecurityTokenResponse

C#
public RequestSecurityTokenResponse Response { get; set; }

C++

J#

JScript

Property Value
Type:   RequestSecurityTokenResponse
The security token request response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityTokenResponse Class
SecurityTokenResponse Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
RequestSecurityTokenResponse Class


SecurityTokenResponse.Token Property
[image]

Gets or sets the security token.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Token As SecurityToken

C#
public SecurityToken Token { get; set; }

C++

J#

JScript

Property Value
Type: SecurityToken
The security token.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityTokenResponse Class
SecurityTokenResponse Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
SecurityToken Class


ServiceChannel Generic Class
See Also Members
[image]

Represents a communication channel to a Microsoft Dynamics CRM service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecuritySafeCriticalAttribute> _
<SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted:=True)> _
Public Class ServiceChannel(Of TChannel)
    Implements IDisposable

C#
[SecuritySafeCriticalAttribute]
[SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted=true)]
public class ServiceChannel<TChannel> : IDisposable

C++

J#

JScript

GenericParameters
TChannel
Type: IOutputChannel or IRequestChannel. The type of channel produced by a channel factory.
  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.ServiceChannel
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
ChannelFactory(TChannel) Class


ServiceChannel Members
See Also Constructors Events Methods Properties
[image]

Represents a communication channel to a Microsoft Dynamics CRM service.

The following tables list the members exposed by the ServiceChannel type.

Public Constructors

Name | Description
ServiceChannel | Initializes a new instance of the ServiceChannel class using a channel factory. For internal use only.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Channel | Gets the WCF channel that is associated with the service channel.
Top

Protected Properties

 | Name | Description
protected property | CommunicationObject | Gets the communication object that is associated with the service channel.
protected property | Factory | Gets the channel factory associated with the service channel.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | Causes a service channel to transition immediately from its current state into the closing state.
public method | Close | Causes a service channel to transition from its current state into the closed state.
public method | Dispose | Disposes the service channel.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | Causes a service channel to transition from the created state into the opened state.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CreateChannel | Creates a new WCF channel.
protected method | Finalize | Overridden. Finalizes the service channel.
protected method | MemberwiseClone | (inherited from Object)
protected method | OnChannelClosed | Inserts processing on a service channel after it transitions to the closing state due to the invocation of a synchronous close operation.
protected method | OnChannelFaulted | Inserts processing on a service channel after it transitions to the faulted state due to the invocation of a synchronous operation.
protected method | OnChannelOpened | Inserts processing on a service channel after it transitions into the opening state which must complete within a specified interval of time.
Top

Public Events

 | Name | Description
public event | ChannelClosed | Occurs when a service channel transitions into the closed state.
public event | ChannelFaulted | Occurs when a service channel transitions into the faulted state.
public event | ChannelOpened | Occurs when a service channel transitions into the opened state.
Top

See Also

Reference

ServiceChannel Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

ChannelFactory(TChannel) Class


ServiceChannel Constructor
[image]

Initializes a new instance of the ServiceChannel class using a channel factory. For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    factory As ChannelFactory(Of TChannel) _
)

C#
public ServiceChannel (
    ChannelFactory<TChannel> factory
)

C++

J#

JScript

Parameters
factory
Type: ChannelFactory. A channel factory.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | Causes a service channel to transition immediately from its current state into the closing state.
public method | Close | Causes a service channel to transition from its current state into the closed state.
public method | Dispose | Disposes the service channel.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | Causes a service channel to transition from the created state into the opened state.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | CreateChannel | Creates a new WCF channel.
protected method | Finalize | Overridden. Finalizes the service channel.
protected method | MemberwiseClone | (inherited from Object)
protected method | OnChannelClosed | Inserts processing on a service channel after it transitions to the closing state due to the invocation of a synchronous close operation.
protected method | OnChannelFaulted | Inserts processing on a service channel after it transitions to the faulted state due to the invocation of a synchronous operation.
protected method | OnChannelOpened | Inserts processing on a service channel after it transitions into the opening state which must complete within a specified interval of time.

See Also

Reference

ServiceChannel Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

ChannelFactory(TChannel) Class


ServiceChannel.Abort Method
[image]

Causes a service channel to transition immediately from its current state into the closing state.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Abort

C#
public void Abort ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.Close Method
[image]

Causes a service channel to transition from its current state into the closed state.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Close

C#
public void Close ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.CreateChannel Method
[image]

Creates a new WCF channel.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SecuritySafeCriticalAttribute> _
<SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted:=True)> _
Protected Overridable Function CreateChannel As TChannel

C#
[SecuritySafeCriticalAttribute]
[SecurityPermissionAttribute(SecurityAction.Demand, Unrestricted=true)]
protected virtual TChannel CreateChannel ()

C++

J#

JScript

Return Value
Type: IOutputChannel or IRequestChannel
The new WCF channel associated with the service channel.

  Remarks
The new channel is in the created state.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace
Open


ServiceChannel.Dispose Method
[image]

Disposes the service channel.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Dispose

C#
public void Dispose ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.Finalize Method
[image]

Finalizes the service channel.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Sub Finalize

C#
~ServiceChannel()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.OnChannelClosed Method
[image]

Inserts processing on a service channel after it transitions to the closing state due to the invocation of a synchronous close operation.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnChannelClosed ( _
    args As ChannelEventArgs _
)

C#
protected virtual void OnChannelClosed (
    ChannelEventArgs args
)

C++

J#

JScript

Parameters
args
Type: ChannelEventArgs. Channel event arguments.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.OnChannelFaulted Method
[image]

Inserts processing on a service channel after it transitions to the faulted state due to the invocation of a synchronous operation.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnChannelFaulted ( _
    args As ChannelFaultedEventArgs _
)

C#
protected virtual void OnChannelFaulted (
    ChannelFaultedEventArgs args
)

C++

J#

JScript

Parameters
args
Type: ChannelFaultedEventArgs. Channel faulted event arguments.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.OnChannelOpened Method
[image]

Inserts processing on a service channel after it transitions into the opening state which must complete within a specified interval of time.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnChannelOpened ( _
    args As ChannelEventArgs _
)

C#
protected virtual void OnChannelOpened (
    ChannelEventArgs args
)

C++

J#

JScript

Parameters
args
Type: ChannelEventArgs. Channel event arguments.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.Open Method
[image]

Causes a service channel to transition from the created state into the opened state.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Open

C#
public void Open ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Channel | Gets the WCF channel that is associated with the service channel.

Protected Properties

 | Name | Description
protected property | CommunicationObject | Gets the communication object that is associated with the service channel.
protected property | Factory | Gets the channel factory associated with the service channel.

See Also

Reference

ServiceChannel Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

ChannelFactory(TChannel) Class


ServiceChannel.Channel Property
[image]

Gets the WCF channel that is associated with the service channel.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Channel As TChannel

C#
public TChannel Channel { get; }

C++

J#

JScript

Property Value
Type: IOutputChannel or IRequestChannel
 The WCF channel associated with the service channel.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.CommunicationObject Property
[image]

Gets the communication object that is associated with the service channel.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected ReadOnly Property CommunicationObject As ICommunicationObject

C#
protected ICommunicationObject CommunicationObject { get; }

C++

J#

JScript

Property Value
Type: ICommunicationObject
The communication object associated with the service channel.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.Factory Property
[image]

Gets the channel factory associated with the service channel.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Property Factory As ChannelFactory(Of TChannel)

C#
protected ChannelFactory<TChannel> Factory { get; }

C++

J#

JScript

Property Value
Type: ChannelFactory
The channel factory associated with the service channel.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel Events
[image]

Public Events

 | Name | Description
public event | ChannelClosed | Occurs when a service channel transitions into the closed state.
public event | ChannelFaulted | Occurs when a service channel transitions into the faulted state.
public event | ChannelOpened | Occurs when a service channel transitions into the opened state.

See Also

Reference

ServiceChannel Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

ChannelFactory(TChannel) Class


ServiceChannel.ChannelClosed Event
[image]

Occurs when a service channel transitions into the closed state.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ChannelClosed As EventHandler(Of ChannelEventArgs)

C#
public event EventHandler<ChannelEventArgs> ChannelClosed

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.ChannelFaulted Event
[image]

Occurs when a service channel transitions into the faulted state.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ChannelFaulted As EventHandler(Of ChannelFaultedEventArgs)

C#
public event EventHandler<ChannelFaultedEventArgs> ChannelFaulted

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceChannel.ChannelOpened Event
[image]

Occurs when a service channel transitions into the opened state.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ChannelOpened As EventHandler(Of ChannelEventArgs)

C#
public event EventHandler<ChannelEventArgs> ChannelOpened

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceChannel Class
ServiceChannel Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceConfigurationFactory Class
See Also Members
[image]

Represents a client factory for creating service configurations.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ServiceConfigurationFactory

C#
public static class ServiceConfigurationFactory

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.ServiceConfigurationFactory
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceConfigurationFactory Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceConfigurationFactory Members
See Also Methods
[image]

Represents a client factory for creating service configurations.

The following tables list the members exposed by the ServiceConfigurationFactory type.

Public Methods

Name | Description
CreateConfiguration | Overloaded.
CreateManagement | Overloaded.
Top

See Also

Reference

ServiceConfigurationFactory Class
Microsoft.Xrm.Sdk.Client Namespace


ServiceConfigurationFactory Methods
[image]

Public Methods

Name | Description
CreateConfiguration | Overloaded.
CreateManagement | Overloaded.

See Also

Reference

ServiceConfigurationFactory Class
Microsoft.Xrm.Sdk.Client Namespace


ServiceConfigurationFactory.CreateConfiguration Method
[image]

Overload List

Name | Description
ServiceConfigurationFactory.CreateConfiguration (Uri) | Creates a service configuration.
ServiceConfigurationFactory.CreateConfiguration (Uri, Boolean, Assembly) | Creates a service configuration

See Also

Reference

ServiceConfigurationFactory Class
ServiceConfigurationFactory Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceConfigurationFactory.CreateConfiguration Method (Uri)
[image]

Creates a service configuration.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateConfiguration(Of TService) ( _
    serviceUri As Uri _
) As IServiceConfiguration(Of TService)

C#
public static IServiceConfiguration<TService> CreateConfiguration<TService> (
    Uri serviceUri
)

C++

J#

JScript

GenericParameters
TService
Specifies a Microsoft Dynamics CRM service type: IDiscoveryService or IOrganizationService.
Parameters
serviceUri
Specifies the service’s URI.
Return Value
Type:  IServiceConfiguration
A service configuration object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceConfigurationFactory Class
ServiceConfigurationFactory Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceConfigurationFactory.CreateConfiguration Method (Uri, Boolean, Assembly)
[image]

Creates a service configuration

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateConfiguration(Of TService) ( _
    serviceUri As Uri, _
    enableProxyTypes As Boolean, _
    assembly As Assembly _
) As IServiceConfiguration(Of TService)

C#
public static IServiceConfiguration<TService> CreateConfiguration<TService> (
    Uri serviceUri,
    bool enableProxyTypes,
    Assembly assembly
)

C++

J#

JScript

GenericParameters
TService
Specifies a Microsoft Dynamics CRM service type: IDiscoveryService or IOrganizationService.
Parameters
serviceUri
Specifies the web service’s URI.
enableProxyTypes
True to enable proxy types; otherwise, False.
assembly
An assembly containing proxy types.
Return Value
Type: IServiceConfiguration
A service configuration object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceConfigurationFactory Class
ServiceConfigurationFactory Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Create Early Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ServiceConfigurationFactory.CreateManagement Method
[image]

Overload List

Name | Description
ServiceConfigurationFactory.CreateManagement (Uri) | Creates a service management.
ServiceConfigurationFactory.CreateManagement (Uri, Boolean, Assembly) | Creates a service management.

See Also

Reference

ServiceConfigurationFactory Class
ServiceConfigurationFactory Members
Microsoft.Xrm.Sdk.Client Namespace
IServiceManagement


ServiceConfigurationFactory.CreateManagement Method (Uri)
[image]

Creates a service management.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateManagement(Of TService) ( _
    serviceUri As Uri _
) As IServiceManagement(Of TService)

C#
public static IServiceManagement<TService> CreateManagement<TService> (
    Uri serviceUri
)

C++

J#

JScript

GenericParameters
TService
Specifies a Microsoft Dynamics CRM service type: IDiscoveryService or IOrganizationService.
Parameters
serviceUri
Specifies the service’s URI.
Return Value
Type:  IServiceManagement
A service management object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceConfigurationFactory Class
ServiceConfigurationFactory Members
Microsoft.Xrm.Sdk.Client Namespace
IServiceManagement


ServiceConfigurationFactory.CreateManagement Method (Uri, Boolean, Assembly)
[image]

Creates a service management.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateManagement(Of TService) ( _
    serviceUri As Uri, _
    enableProxyTypes As Boolean, _
    assembly As Assembly _
) As IServiceManagement(Of TService)

C#
public static IServiceManagement<TService> CreateManagement<TService> (
    Uri serviceUri,
    bool enableProxyTypes,
    Assembly assembly
)

C++

J#

JScript

GenericParameters
TService
Specifies a Microsoft Dynamics CRM service type: IDiscoveryService or IOrganizationService.
Parameters
serviceUri
Specifies the service’s URI.
enableProxyTypes
True to enable proxy types; otherwise, False.
assembly
An assembly containing proxy types.
Return Value
Type:  IServiceManagement
A service management object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceConfigurationFactory Class
ServiceConfigurationFactory Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Create Early Bound Entity Classes with the Code Generation Tool (CrmSvcUtil.exe)


ServiceEndpointDictionary Class
See Also Members
[image]

Contains a dictionary of ServiceEndpoint objects.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class ServiceEndpointDictionary
    Inherits Dictionary(Of String, ServiceEndpoint)

C#
[SerializableAttribute]
public sealed class ServiceEndpointDictionary : Dictionary<string,ServiceEndpoint>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.Generic.Dictionary
    Microsoft.Xrm.Sdk.Client.ServiceEndpointDictionary
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointDictionary Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointDictionary Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a dictionary of ServiceEndpoint objects.

The following tables list the members exposed by the ServiceEndpointDictionary type.

Public Constructors

Name | Description
ServiceEndpointDictionary | Initializes a new instance of theServiceEndpointDictionary class.
Top

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Top

See Also

Reference

ServiceEndpointDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointDictionary Constructor
[image]

Initializes a new instance of the ServiceEndpointDictionary class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ServiceEndpointDictionary ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointDictionary Class
ServiceEndpointDictionary Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointDictionary Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)

See Also

Reference

ServiceEndpointDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointDictionary Properties
[image]

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)

See Also

Reference

ServiceEndpointDictionary Class
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointMetadata Class
See Also Members
[image]

Container class for metadata information about a service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ServiceEndpointMetadata

C#
public sealed class ServiceEndpointMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.ServiceEndpointMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointMetadata Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointMetadata Members
See Also Constructors Methods Properties
[image]

Container class for metadata information about a service.

The following tables list the members exposed by the ServiceEndpointMetadata type.

Public Constructors

Name | Description
ServiceEndpointMetadata | Initializes a new instance of the ServiceEndpointMetadata class.
Top

Public Properties

 | Name | Description
public property | MetadataConversionErrors | Gets the errors that occurred during metadata retrieval from the service.
public property | ServiceEndpoints | Gets the service endpoint URIs.
public property | ServiceMetadata | Gets the WSDL metadata for the service.
public property | ServiceUrls | Gets the primary and alternate URLs for the service.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ServiceEndpointMetadata Class
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointMetadata Constructor
[image]

Initializes a new instance of the ServiceEndpointMetadata class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ServiceEndpointMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointMetadata Class
ServiceEndpointMetadata Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ServiceEndpointMetadata Class
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointMetadata Properties
[image]

Public Properties

 | Name | Description
public property | MetadataConversionErrors | Gets the errors that occurred during metadata retrieval from the service.
public property | ServiceEndpoints | Gets the service endpoint URIs.
public property | ServiceMetadata | Gets the WSDL metadata for the service.
public property | ServiceUrls | Gets the primary and alternate URLs for the service.

See Also

Reference

ServiceEndpointMetadata Class
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointMetadata.MetadataConversionErrors Property
[image]

Gets the errors that occurred during metadata retrieval from the service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property MetadataConversionErrors As Collection(Of MetadataConversionError)

C#
public Collection<MetadataConversionError> MetadataConversionErrors { get; }

C++

J#

JScript

Property Value
Type: Collection
  The errors that occurred during metadata retrieval from the service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointMetadata Class
ServiceEndpointMetadata Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointMetadata.ServiceEndpoints Property
[image]

Gets the service endpoint URIs.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ServiceEndpoints As ServiceEndpointDictionary

C#
public ServiceEndpointDictionary ServiceEndpoints { get; }

C++

J#

JScript

Property Value
Type:  ServiceEndpointDictionary
The service endpoint URIs.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointMetadata Class
ServiceEndpointMetadata Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointMetadata.ServiceMetadata Property
[image]

Gets the WSDL metadata for the service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ServiceMetadata As MetadataSet

C#
public MetadataSet ServiceMetadata { get; set; }

C++

J#

JScript

Property Value
Type:  MetadataSet
The WSDL metadata for the service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointMetadata Class
ServiceEndpointMetadata Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceEndpointMetadata.ServiceUrls Property
[image]

Gets the primary and alternate URLs for the service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ServiceUrls As ServiceUrls

C#
public ServiceUrls ServiceUrls { get; }

C++

J#

JScript

Property Value
Type: ServiceUrls
The primary and alternate URLs for the service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceEndpointMetadata Class
ServiceEndpointMetadata Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


ServiceProxy Generic Class
See Also Members
[image]

Provides an abstract base class to encapsulate service connection operations and user authentication management.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustInherit Class ServiceProxy(Of TService)
    Implements IDisposable

C#
public abstract class ServiceProxy<TService> : IDisposable

C++

J#

JScript

GenericParameters
TService
Type: IDiscoveryService or IOrganizationService. A service that an instance of this class can access.
  Remarks
The two commonly used derived classes are DiscoveryServiceProxy and OrganizationServiceProxy.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.ServiceProxy

                Microsoft.Xrm.Sdk.Client.DiscoveryServiceProxy

                Microsoft.Xrm.Sdk.Client.OrganizationServiceProxy
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Active Directory and Claims-Based Authentication


ServiceProxy Members
See Also Events Methods Properties Constructors
[image]

Provides an abstract base class to encapsulate service connection operations and user authentication management.

The following tables list the members exposed by the ServiceProxy type.

Protected Constructors

Name | Description
ServiceProxy | Overloaded. Initializes a new instance of the ServiceProxy class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ClientCredentials | Gets the login credentials of the client.
public property | DeviceCredentials | Gets the Windows Live credentials of a registered device.
public property | EndpointAutoSwitchEnabled | Gets or sets a value that enables automatic switching from the organization’s current endpoint to an alternate endpoint.
public property | EndpointSwitch | Gets the endpoint switch information from the web service configuration.
public property | HomeRealmSecurityTokenResponse | Gets the security token response of the home realm.
public property | HomeRealmUri | Gets the home realm URI.
public property | IsAuthenticated | Gets a value indicating if the WCF channel has been authenticated.
public property | SecurityTokenResponse | Gets the security token response.
public property | ServiceChannel | Gets the communication channel used to access a Microsoft Dynamics CRM service.
public property | ServiceConfiguration | Gets a service configuration.
public property | ServiceManagement | Gets a service management.
public property | Timeout | Gets or sets the maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
public property | UserPrincipalName | Gets or sets the UPN that is an Internet-style login name for a user based on the Internet standard RFC 822.
Top

Protected Properties

 | Name | Description
protected property | ChannelFactory | Gets a WCF channel factory that manages a single channel instance.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Authenticate | Closes the service channel and channel factory if they are open, and then invokes AuthenticateCore.
public method | AuthenticateCrossRealm | Invokes AuthenticateCrossRealmCore.
public method | AuthenticateDevice | Invokes AuthenticateDeviceCore.
public method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | SwitchToAlternateEndpoint | Switches the organization’s current endpoint to an alternate endpoint, if one is available.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | AuthenticateCore | Authenticates the client with a service.
protected method | AuthenticateCrossRealmCore | Authenticates a user in a realm other than the realm that the Microsoft Dynamics CRM server is located in.
protected method | AuthenticateDeviceCore | Authenticates a device with Windows Live.
protected method | CloseChannel | Closes a validated service channel.
protected method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources.
protected method | Finalize | Overridden. Implicitly frees allocated service channel and service factory resources.
protected method | HandleFailover | Overloaded. For internal use only.
protected method | MemberwiseClone | (inherited from Object)
protected method | OnFactoryClosed | Event handler virtual method for a channel factory that is in a closed state.
protected method | OnFactoryFaulted | Event handler virtual method for a channel factory that is in a faulted state.
protected method | OnFactoryOpened | Event handler virtual method for a channel factory that is in an opened state.
 | SetBindingTimeout | The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
protected method | ShouldRetry | Checks a message security exception to determine if a service call should be attempted again.
protected method | ValidateAuthentication | Authenticates the client and creates a new service channel.
Top

Public Events

 | Name | Description
public event | EndpointSwitched | Occurs when a failover recovery has completed and the organization’s current endpoint has been switched to an alternate endpoint.
public event | EndpointSwitchRequired | Occurs when a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required.
public event | FactoryClosed | Occurs when a channel factory is closed.
public event | FactoryFaulted | Occurs when a channel factory is faulted.
public event | FactoryOpened | Occurs when a channel factory is opened.
Top

See Also

Reference

ServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Active Directory and Claims-Based Authentication


ServiceProxy Constructor
[image]

Initializes a new instance of the ServiceProxy class.

Overload List

Name | Description
ServiceProxy (IServiceConfiguration, SecurityTokenResponse) | Initializes a new instance of the ServiceProxy class using a service configuration and security token response.
ServiceProxy (IServiceConfiguration, ClientCredentials) | Initializes a new instance of the ServiceProxy class using a service configuration and client logon credentials.
ServiceProxy (IServiceManagement, SecurityTokenResponse) | Initializes a new instance of the ServiceProxy class using a service management and security token response.
ServiceProxy (IServiceManagement, ClientCredentials) | Initializes a new instance of theServiceProxy class using a service management and client logon credentials.
ServiceProxy (Uri, Uri, ClientCredentials, ClientCredentials) | Initializes a new instance of the ServiceProxy class using a service URI, a home realm URI, client logon credentials, and Windows Live device credentials.

See Also

Reference

ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy Constructor (IServiceConfiguration, SecurityTokenResponse)
[image]

Initializes a new instance of the ServiceProxy class using a service configuration and security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    serviceConfiguration As IServiceConfiguration(Of TService), _
    securityTokenResponse As SecurityTokenResponse _
)

C#
protected ServiceProxy (
    IServiceConfiguration<TService> serviceConfiguration,
    SecurityTokenResponse securityTokenResponse
)

C++

J#

JScript

Parameters
serviceConfiguration
Type: IServiceConfiguration. A service configuration.
securityTokenResponse
Type: SecurityTokenResponse. A security token response.
  Remarks
Use this constructor when the service configuration and security token have been acquired externally and only when claims-based authentication is configured.
Do not call the Authenticate method after instantiating a ServiceProxy derived object using this constructor.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy Constructor (IServiceConfiguration, ClientCredentials)
[image]

Initializes a new instance of the ServiceProxy class using a service configuration and client logon credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    serviceConfiguration As IServiceConfiguration(Of TService), _
    clientCredentials As ClientCredentials _
)

C#
protected ServiceProxy (
    IServiceConfiguration<TService> serviceConfiguration,
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
serviceConfiguration
Type: IServiceConfiguration. A service configuration.
clientCredentials
Type: ClientCredentials. The logon credentials of the client.
  Remarks
Use this constructor when the service configuration has been acquired externally, and Windows-based authentication is in use.
Do not call the Authenticate method after instantiating a ServiceProxy derived object using this constructor.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy Constructor (IServiceManagement, SecurityTokenResponse)
[image]

Initializes a new instance of the ServiceProxy class using a service management and security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    serviceManagement As IServiceManagement(Of TService), _
    securityTokenResponse As SecurityTokenResponse _
)

C#
protected ServiceProxy (
    IServiceManagement<TService> serviceManagement,
    SecurityTokenResponse securityTokenResponse
)

C++

J#

JScript

Parameters
serviceManagement
Type: IServiceManagement. A service management.
securityTokenResponse
Type: SecurityTokenResponse. A security token response.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy Constructor (IServiceManagement, ClientCredentials)
[image]

Initializes a new instance of the ServiceProxy class using a service management and client logon credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    serviceManagement As IServiceManagement(Of TService), _
    clientCredentials As ClientCredentials _
)

C#
protected ServiceProxy (
    IServiceManagement<TService> serviceManagement,
    ClientCredentials clientCredentials
)

C++

J#

JScript

Parameters
serviceManagement
Type: IServiceManagement. A service management.
clientCredentials
Type: ClientCredentials. The logon credentials of the client.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy Constructor (Uri, Uri, ClientCredentials, ClientCredentials)
[image]

Initializes a new instance of the ServiceProxy class using a service URI, a home realm URI, client logon credentials, and Windows Live device credentials.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    uri As Uri, _
    homeRealmUri As Uri, _
    clientCredentials As ClientCredentials, _
    deviceCredentials As ClientCredentials _
)

C#
protected ServiceProxy (
    Uri uri,
    Uri homeRealmUri,
    ClientCredentials clientCredentials,
    ClientCredentials deviceCredentials
)

C++

J#

JScript

Parameters
uri
Type: URI. The URI of the service.
homeRealmUri
Type: URI. The URI of the WS-Trust metadata endpoint of a second ADFS instance.
clientCredentials
Type: ClientCredentials. The client’s logon credentials.
deviceCredentials
Type: ClientCredentials. The credentials of a device registered with Windows Live. Only required when authenticating with Microsoft Dynamics CRM Online, otherwise use null.
  Remarks
The home realm parameter is set to a non-null value when a second ADFS instance is configured as an identity provider to the ADFS instance that Microsoft Dynamics CRM 2011 has been configured with for claims authentication.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Helper Code: DeviceIdManager Class


ServiceProxy Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Authenticate | Closes the service channel and channel factory if they are open, and then invokes AuthenticateCore.
public method | AuthenticateCrossRealm | Invokes AuthenticateCrossRealmCore.
public method | AuthenticateDevice | Invokes AuthenticateDeviceCore.
public method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | SwitchToAlternateEndpoint | Switches the organization’s current endpoint to an alternate endpoint, if one is available.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | AuthenticateCore | Authenticates the client with a service.
protected method | AuthenticateCrossRealmCore | Authenticates a user in a realm other than the realm that the Microsoft Dynamics CRM server is located in.
protected method | AuthenticateDeviceCore | Authenticates a device with Windows Live.
protected method | CloseChannel | Closes a validated service channel.
protected method | Dispose | Overloaded. Methods that explicitly free allocated service channel resources.
protected method | Finalize | Overridden. Implicitly frees allocated service channel and service factory resources.
protected method | HandleFailover | Overloaded. For internal use only.
protected method | MemberwiseClone | (inherited from Object)
protected method | OnFactoryClosed | Event handler virtual method for a channel factory that is in a closed state.
protected method | OnFactoryFaulted | Event handler virtual method for a channel factory that is in a faulted state.
protected method | OnFactoryOpened | Event handler virtual method for a channel factory that is in an opened state.
 | SetBindingTimeout | The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
protected method | ShouldRetry | Checks a message security exception to determine if a service call should be attempted again.
protected method | ValidateAuthentication | Authenticates the client and creates a new service channel.

See Also

Reference

ServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Active Directory and Claims-Based Authentication


ServiceProxy.Authenticate Method
[image]

Closes the service channel and channel factory if they are open, and then invokes AuthenticateCore.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Authenticate

C#
public void Authenticate ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.AuthenticateCore Method
[image]

Authenticates the client with a service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub AuthenticateCore

C#
protected virtual void AuthenticateCore ()

C++

J#

JScript

  Remarks
When using claims-based authentication, a new security token is requested by this method invocation. The ServiceConfiguration must be set prior to calling this method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.AuthenticateCrossRealm Method
[image]

Invokes AuthenticateCrossRealmCore.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function AuthenticateCrossRealm As SecurityTokenResponse

C#
public SecurityTokenResponse AuthenticateCrossRealm ()

C++

J#

JScript

Return Value
Type: SecurityTokenResponse
A security token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.AuthenticateCrossRealmCore Method
[image]

Authenticates a user in a realm other than the realm that the Microsoft Dynamics CRM server is located in.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Function AuthenticateCrossRealmCore As SecurityTokenResponse

C#
protected virtual SecurityTokenResponse AuthenticateCrossRealmCore ()

C++

J#

JScript

Return Value
Type: SecurityTokenResponse
A security token response.

  Remarks
This method will attempt to authenticate the home realm, then use the corresponding security token to authenticate to the Microsoft Dynamics CRM realm STS (Security Token Service).  In addition to the normal client credential requirements, the homeRealmUri constructor parameter is expected to be set in the call to the constructor.
The returned SecurityTokenResponse should be the security token that can be used to authenticate against the Microsoft Dynamics CRM server realm STS.
This method may be overridden in the case that home realm authentication requires multiple hops, which is not supported by this call.
ServiceConfigurationand HomeRealmUri must be set prior to calling this method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.AuthenticateDevice Method
[image]

Invokes AuthenticateDeviceCore.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function AuthenticateDevice As SecurityTokenResponse

C#
public SecurityTokenResponse AuthenticateDevice ()

C++

J#

JScript

Return Value
Type: SecurityTokenResponse
A security token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.AuthenticateDeviceCore Method
[image]

Authenticates a device with Windows Live.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Function AuthenticateDeviceCore As SecurityTokenResponse

C#
protected virtual SecurityTokenResponse AuthenticateDeviceCore ()

C++

J#

JScript

Return Value
Type: SecurityTokenResponse
A security token response.

  Remarks
The DeviceCredentials must be set prior to this method being called.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.CloseChannel Method
[image]

Closes a validated service channel.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub CloseChannel ( _
    forceClose As Boolean _
)

C#
protected virtual void CloseChannel (
    bool forceClose
)

C++

J#

JScript

Parameters
forceClose
Type: Boolean.  true if the  service channel should be forced to close; otherwise, false.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.Dispose Method
[image]

Methods that explicitly free allocated service channel resources.

Overload List

Name | Description
ServiceProxy.Dispose () | Custom implementation of Dispose that disposes the service channel and channel factory.
ServiceProxy.Dispose (Boolean) | Custom implementation of Dispose that disposes the service channel and channel factory.

See Also

Reference

ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

IDisposable.Dispose Method


ServiceProxy.Dispose Method ()
[image]

Custom implementation of Dispose that disposes the service channel and channel factory.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Dispose

C#
public void Dispose ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
IDisposable.Dispose Method


ServiceProxy.Dispose Method (Boolean)
[image]

Custom implementation of Dispose that disposes the service channel and channel factory.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

C#
protected virtual void Dispose (
    bool disposing
)

C++

J#

JScript

Parameters
disposing
Type: Boolean.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
IDisposable.Dispose Method


ServiceProxy.Finalize Method
[image]

Implicitly frees allocated service channel and service factory resources.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Sub Finalize

C#
~ServiceProxy()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Object.Finalize Method


ServiceProxy.HandleFailover Method
[image]

For internal use only.

Overload List

Name | Description
ServiceProxy.HandleFailover (BaseServiceFault, Nullable) | For internal use only.
ServiceProxy.HandleFailover (Nullable) | For internal use only.

See Also

Reference

ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.HandleFailover Method (BaseServiceFault, Nullable)
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Function HandleFailover ( _
    fault As BaseServiceFault, _
    retry As Nullable(Of Boolean) _
) As Nullable(Of Boolean)

C#
protected Nullable<bool> HandleFailover (
    BaseServiceFault fault,
    Nullable<bool> retry
)

C++

J#

JScript

Parameters
fault
retry
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.HandleFailover Method (Nullable)
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Function HandleFailover ( _
    retry As Nullable(Of Boolean) _
) As Boolean

C#
protected bool HandleFailover (
    Nullable<bool> retry
)

C++

J#

JScript

Parameters
retry
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.OnFactoryClosed Method
[image]

Event handler virtual method for a channel factory that is in a closed state.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnFactoryClosed ( _
    args As ChannelEventArgs _
)

C#
protected virtual void OnFactoryClosed (
    ChannelEventArgs args
)

C++

J#

JScript

Parameters
args
Type: ChannelEventArgs. Channel events arguments.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.OnFactoryFaulted Method
[image]

Event handler virtual method for a channel factory that is in a faulted state.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnFactoryFaulted ( _
    args As ChannelFaultedEventArgs _
)

C#
protected virtual void OnFactoryFaulted (
    ChannelFaultedEventArgs args
)

C++

J#

JScript

Parameters
args
Type: ChannelFaultedEventArgs. Faulted channel event arguments.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.OnFactoryOpened Method
[image]

Event handler virtual method for a channel factory that is in an opened state.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnFactoryOpened ( _
    args As ChannelEventArgs _
)

C#
protected virtual void OnFactoryOpened (
    ChannelEventArgs args
)

C++

J#

JScript

Parameters
args
Type: ChannelEventArgs. Channel event arguments.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.SetBindingTimeout Method
[image]

The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Shared Sub SetBindingTimeout ( _
    binding As Binding, _
    sendTimeout As TimeSpan, _
    openTimeout As TimeSpan, _
    closeTimeout As TimeSpan _
)

C#
protected static void SetBindingTimeout (
    Binding binding,
    TimeSpan sendTimeout,
    TimeSpan openTimeout,
    TimeSpan closeTimeout
)

C++

J#

JScript

Parameters
binding
Type: Binding. The target channel binding.
sendTimeout
Type: TimeSpan.A send operation timespan.
openTimeout
Type: TimeSpan. An open operation timespan.
closeTimeout
Type: TimeSpan.A close operation timespan.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.ShouldRetry Method
[image]

Checks a message security exception to determine if a service call should be attempted again.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters", Justification:="We want to explicitly call out that we only handle this exception.")> _
Protected Function ShouldRetry ( _
    messageSecurityException As MessageSecurityException, _
    retry As Nullable(Of Boolean) _
) As Nullable(Of Boolean)

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1011:ConsiderPassingBaseTypesAsParameters", Justification="We want to explicitly call out that we only handle this exception.")]
protected Nullable<bool> ShouldRetry (
    MessageSecurityException messageSecurityException,
    Nullable<bool> retry
)

C++

J#

JScript

Parameters
messageSecurityException
Type: MessageSecurityException. The exception to check.
retry
Type: Nullable<Boolean>. null if this is the first time the check is performed; otherwise, this is the second time and a retry should not be performed.
Return Value
Type: Nullable<Boolean>
true if the service call should be tried again; otherwise, false or null.

  Remarks
This particular type of exception occurs in Active Directory environments or sometimes when Internet Information Services (IIS) is reset.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.SwitchToAlternateEndpoint Method
[image]

Switches the organization’s current endpoint to an alternate endpoint, if one is available.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function SwitchToAlternateEndpoint As Boolean

C#
public bool SwitchToAlternateEndpoint ()

C++

J#

JScript

Return Value
Type: Boolean
true if the switch was successful; otherwise, false.

  Remarks
When an organization is provisioned for disaster recovery failover, that organization has a primary endpoint and an alternate endpoint. If the current endpoint in use for the organization is the primary endpoint, calling SwitchToAlternateEndpoint switches the current endpoint to the alternate endpoint. Conversely, if the current endpoint for the organization is the alternate endpoint, calling SwitchToAlternateEndpoint switches the current endpoint to the primary endpoint.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
ServiceUrls
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


ServiceProxy.ValidateAuthentication Method
[image]

Authenticates the client and creates a new service channel.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub ValidateAuthentication

C#
protected virtual void ValidateAuthentication ()

C++

J#

JScript

  Remarks
If the IsAuthenticated property is set to false, the Authenticate method is invoked. If the ServiceChannel property is set to null, a new service channel is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ClientCredentials | Gets the login credentials of the client.
public property | DeviceCredentials | Gets the Windows Live credentials of a registered device.
public property | EndpointAutoSwitchEnabled | Gets or sets a value that enables automatic switching from the organization’s current endpoint to an alternate endpoint.
public property | EndpointSwitch | Gets the endpoint switch information from the web service configuration.
public property | HomeRealmSecurityTokenResponse | Gets the security token response of the home realm.
public property | HomeRealmUri | Gets the home realm URI.
public property | IsAuthenticated | Gets a value indicating if the WCF channel has been authenticated.
public property | SecurityTokenResponse | Gets the security token response.
public property | ServiceChannel | Gets the communication channel used to access a Microsoft Dynamics CRM service.
public property | ServiceConfiguration | Gets a service configuration.
public property | ServiceManagement | Gets a service management.
public property | Timeout | Gets or sets the maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
public property | UserPrincipalName | Gets or sets the UPN that is an Internet-style login name for a user based on the Internet standard RFC 822.

Protected Properties

 | Name | Description
protected property | ChannelFactory | Gets a WCF channel factory that manages a single channel instance.

See Also

Reference

ServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Active Directory and Claims-Based Authentication


ServiceProxy.ChannelFactory Property
[image]

Gets a WCF channel factory that manages a single channel instance.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected ReadOnly Property ChannelFactory As ChannelFactory(Of TService)

C#
protected ChannelFactory<TService> ChannelFactory { get; }

C++

J#

JScript

Property Value
Type: ChannelFactory
A WCF channel factory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.ClientCredentials Property
[image]

Gets the login credentials of the client.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ClientCredentials As ClientCredentials

C#
public ClientCredentials ClientCredentials { get; }

C++

J#

JScript

Property Value
Type: ClientCredentials
The login credentials of the client.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.DeviceCredentials Property
[image]

Gets the Windows Live credentials of a registered device.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DeviceCredentials As ClientCredentials

C#
public ClientCredentials DeviceCredentials { get; }

C++

J#

JScript

Property Value
Type: ClientCredentials
The Windows Live credentials of a registered device..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Helper Code: DeviceIdManager Class


ServiceProxy.EndpointAutoSwitchEnabled Property
[image]

Gets or sets a value that enables automatic switching from the organization’s current endpoint to an alternate endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EndpointAutoSwitchEnabled As Boolean

C#
public bool EndpointAutoSwitchEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to enable automatic switching from the organization’s current endpoint to an alternate endpoint; otherwise, false.

  Remarks
Set to true by default for organizations that support disaster recover failover where an alternate endpoint is available.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


ServiceProxy.EndpointSwitch Property
[image]

Gets the endpoint switch information from the web service configuration.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EndpointSwitch As IEndpointSwitch

C#
public IEndpointSwitch EndpointSwitch { get; }

C++

J#

JScript

Property Value
Type: IEndpointSwitch
The endpoint switch information from the web service configuration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
ServiceConfiguration
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


ServiceProxy.HomeRealmSecurityTokenResponse Property
[image]

Gets the security token response of the home realm.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HomeRealmSecurityTokenResponse As SecurityTokenResponse

C#
public SecurityTokenResponse HomeRealmSecurityTokenResponse { get; protected set; }

C++

J#

JScript

Property Value
Type: SecurityTokenResponse
The security token response of the home realm.

  Remarks
For more information, refer to the ServiceProxy constructor that supports a home realm URI parameter.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.HomeRealmUri Property
[image]

Gets the home realm URI.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HomeRealmUri As Uri

C#
public Uri HomeRealmUri { get; }

C++

J#

JScript

Property Value
Type: URI
The home realm URI.

  Remarks
For more information, refer to the ServiceProxy constructor that supports a home realm URI parameter.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.IsAuthenticated Property
[image]

Gets a value indicating if the WCF channel has been authenticated.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IsAuthenticated As Boolean

C#
public bool IsAuthenticated { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the created WCF channel has been authenticated, otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.SecurityTokenResponse Property
[image]

Gets the security token response.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SecurityTokenResponse As SecurityTokenResponse

C#
public SecurityTokenResponse SecurityTokenResponse { get; protected set; }

C++

J#

JScript

Property Value
Type: SecurityTokenResponse
The security token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.ServiceChannel Property
[image]

Gets the communication channel used to access a Microsoft Dynamics CRM service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ServiceChannel As ServiceChannel(Of TService)

C#
public ServiceChannel<TService> ServiceChannel { get; }

C++

J#

JScript

Property Value
Type: ServiceChannel
The communication channel used to access a Microsoft Dynamics CRM service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.ServiceConfiguration Property
[image]

Gets a service configuration.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ServiceConfiguration As IServiceConfiguration(Of TService)

C#
public IServiceConfiguration<TService> ServiceConfiguration { get; }

C++

J#

JScript

Property Value
Type: IServiceConfiguration
A service configuration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.ServiceManagement Property
[image]

Gets a service management.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ServiceManagement As IServiceManagement(Of TService)

C#
public IServiceManagement<TService> ServiceManagement { get; }

C++

J#

JScript

Property Value
Type: IServiceManagement
A service management.

  Remarks
Manages a Microsoft Dynamics CRM web service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.Timeout Property
[image]

Gets or sets the maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Timeout As TimeSpan

C#
public TimeSpan Timeout { get; set; }

C++

J#

JScript

Property Value
Type: TimeSpan
The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.UserPrincipalName Property
[image]

Gets or sets the UPN that is an Internet-style login name for a user based on the Internet standard RFC 822.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserPrincipalName As String

C#
public string UserPrincipalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The UPN that is an Internet-style login name for a user based on the Internet standard RFC 822.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy Events
[image]

Public Events

 | Name | Description
public event | EndpointSwitched | Occurs when a failover recovery has completed and the organization’s current endpoint has been switched to an alternate endpoint.
public event | EndpointSwitchRequired | Occurs when a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required.
public event | FactoryClosed | Occurs when a channel factory is closed.
public event | FactoryFaulted | Occurs when a channel factory is faulted.
public event | FactoryOpened | Occurs when a channel factory is opened.

See Also

Reference

ServiceProxy Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Active Directory and Claims-Based Authentication


ServiceProxy.EndpointSwitched Event
See Also Example
[image]

Occurs when a failover recovery has completed and the organization’s current endpoint has been switched to an alternate endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event EndpointSwitched As EventHandler(Of EndpointSwitchEventArgs)

C#
public event EventHandler<EndpointSwitchEventArgs> EndpointSwitched

C++

J#

JScript

  Example
C#    Copy Code
public event EventHandler<EndpointSwitchEventArgs> EndpointSwitched

Visual Basic    Copy Code
Public Event EndpointSwitched As EventHandler<EndpointSwitchEventArgs>

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


ServiceProxy.EndpointSwitchRequired Event
[image]

Occurs when a failover has occurred and a switch from the organization’s current endpoint to an alternate endpoint is required.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event EndpointSwitchRequired As EventHandler(Of EndpointSwitchEventArgs)

C#
public event EventHandler<EndpointSwitchEventArgs> EndpointSwitchRequired

C++

J#

JScript

  Remarks
This event is fired during execution of a web service call and only if an alternate endpoint exists.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


ServiceProxy.FactoryClosed Event
[image]

Occurs when a channel factory is closed.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event FactoryClosed As EventHandler(Of ChannelEventArgs)

C#
public event EventHandler<ChannelEventArgs> FactoryClosed

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.FactoryFaulted Event
[image]

Occurs when a channel factory is faulted.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event FactoryFaulted As EventHandler(Of ChannelFaultedEventArgs)

C#
public event EventHandler<ChannelFaultedEventArgs> FactoryFaulted

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceProxy.FactoryOpened Event
[image]

Occurs when a channel factory is opened.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event FactoryOpened As EventHandler(Of ChannelEventArgs)

C#
public event EventHandler<ChannelEventArgs> FactoryOpened

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceProxy Class
ServiceProxy Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceUrls Class
See Also Members
[image]

Contains the primary and alternate endpoints of an organization.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ServiceUrls

C#
public sealed class ServiceUrls

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Client.ServiceUrls
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceUrls Members
Microsoft.Xrm.Sdk.Client Namespace
Other Resources
Disaster Recovery in Microsoft Dynamics CRM Online


ServiceUrls Members
See Also Constructors Methods Properties
[image]

Contains the primary and alternate endpoints of an organization.

The following tables list the members exposed by the ServiceUrls type.

Public Constructors

Name | Description
ServiceUrls | Initializes a new instance of the ServiceUrls class.
Top

Public Properties

 | Name | Description
public property | AlternateEndpoint | Gets or sets the alternate endpoint of an organization.
public property | GeneratedFromAlternate | Gets a value that indicates if the primary endpoint was generated from the alternate endpoint.
public property | PrimaryEndpoint | Gets or sets the primary endpoint of an organization.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ServiceUrls Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


ServiceUrls Constructor
[image]

Initializes a new instance of the ServiceUrls class.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ServiceUrls ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceUrls Class
ServiceUrls Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceUrls Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ServiceUrls Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


ServiceUrls Properties
[image]

Public Properties

 | Name | Description
public property | AlternateEndpoint | Gets or sets the alternate endpoint of an organization.
public property | GeneratedFromAlternate | Gets a value that indicates if the primary endpoint was generated from the alternate endpoint.
public property | PrimaryEndpoint | Gets or sets the primary endpoint of an organization.

See Also

Reference

ServiceUrls Class
Microsoft.Xrm.Sdk.Client Namespace

Other Resources

Disaster Recovery in Microsoft Dynamics CRM Online


ServiceUrls.AlternateEndpoint Property
[image]

Gets or sets the alternate endpoint of an organization.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AlternateEndpoint As Uri

C#
public Uri AlternateEndpoint { get; set; }

C++

J#

JScript

Property Value
Type: URI
 The alternate endpoint of an organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceUrls Class
ServiceUrls Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceUrls.GeneratedFromAlternate Property
[image]

Gets a value that indicates if the primary endpoint was generated from the alternate endpoint.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property GeneratedFromAlternate As Boolean

C#
public bool GeneratedFromAlternate { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the the primary endpoint was generated from the alternate endpoint; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceUrls Class
ServiceUrls Members
Microsoft.Xrm.Sdk.Client Namespace


ServiceUrls.PrimaryEndpoint Property
[image]

Gets or sets the primary endpoint of an organization.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PrimaryEndpoint As Uri

C#
public Uri PrimaryEndpoint { get; set; }

C++

J#

JScript

Property Value
Type:  URI
The primary endpoint of an organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ServiceUrls Class
ServiceUrls Members
Microsoft.Xrm.Sdk.Client Namespace


TokenServiceCredentialType Enumeration
[image]

Defines the kinds of credentials accepted by a security token service.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration TokenServiceCredentialType

C#
public enum TokenServiceCredentialType

C++

J#

JScript

  Members
Member name | Description
AsymmetricToken | An asymmetric credential token. Value =4.
Bearer | A bearer token. Value = 7.
Certificate | A certificate configured for user identification. Value = 5.
Kerberos | A Kerberos credential. Value = 2.
None | No credential endpoint is found. Value = 0.
SymmetricToken | A symmetric credential token. Value = 3.
Username | A username and password credential. Value = 1.
Windows | An integrated Windows authentication credential. Value = 6.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Client Namespace


WindowsPolicyConfiguration Class
See Also Members
[image]

Contains a policy configuration that identifies an Active Directory provider.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class WindowsPolicyConfiguration
    Inherits PolicyConfiguration

C#
public sealed class WindowsPolicyConfiguration : PolicyConfiguration

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.PolicyConfiguration
    Microsoft.Xrm.Sdk.Client.WindowsPolicyConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WindowsPolicyConfiguration Members
Microsoft.Xrm.Sdk.Client Namespace


WindowsPolicyConfiguration Members
See Also Methods Properties
[image]

Contains a policy configuration that identifies an Active Directory provider.

The following tables list the members exposed by the WindowsPolicyConfiguration type.

Public Properties

 | Name | Description
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WindowsPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


WindowsPolicyConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WindowsPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


WindowsPolicyConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | SecureTokenServiceIdentifier | Gets an identifier of a Secure Token Service (STS) provider. (inherited from PolicyConfiguration)

See Also

Reference

WindowsPolicyConfiguration Class
Microsoft.Xrm.Sdk.Client Namespace


XrmBinding Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class XrmBinding
    Inherits CustomBinding

C#
public sealed class XrmBinding : CustomBinding

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.ServiceModel.Channels.Binding

                System.ServiceModel.Channels.CustomBinding
      Microsoft.Xrm.Sdk.Client.XrmBinding
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmBinding Members
Microsoft.Xrm.Sdk.Client Namespace


XrmBinding Members
See Also Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the XrmBinding type.

Public Properties

 | Name | Description
public property | CloseTimeout | (inherited from Binding)
public property | Elements | (inherited from CustomBinding)
public property | MaxBufferSize |
public property | MaxReceivedMessageSize |
public property | MessageVersion | (inherited from Binding)
public property | Name | (inherited from Binding)
public property | Namespace | (inherited from Binding)
public property | OpenTimeout | (inherited from Binding)
public property | ReaderQuotas |
public property | ReceiveTimeout | (inherited from Binding)
public property | Scheme | Overridden.
public property | SendTimeout | (inherited from Binding)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | BuildChannelFactory | (inherited from Binding)
public method | BuildChannelFactory | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | CanBuildChannelFactory | (inherited from Binding)
public method | CanBuildChannelFactory | (inherited from Binding)
public method | CanBuildChannelListener | (inherited from Binding)
public method | CanBuildChannelListener | (inherited from Binding)
public method | CreateBindingElements | Overridden. (inherited from Binding)
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetProperty | (inherited from Binding)
public method | GetType | (inherited from Object)
public method | ShouldSerializeName | (inherited from Binding)
public method | ShouldSerializeNamespace | (inherited from Binding)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

XrmBinding Class
Microsoft.Xrm.Sdk.Client Namespace


XrmBinding Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | BuildChannelFactory | (inherited from Binding)
public method | BuildChannelFactory | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | CanBuildChannelFactory | (inherited from Binding)
public method | CanBuildChannelFactory | (inherited from Binding)
public method | CanBuildChannelListener | (inherited from Binding)
public method | CanBuildChannelListener | (inherited from Binding)
public method | CreateBindingElements | Overridden. (inherited from Binding)
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetProperty | (inherited from Binding)
public method | GetType | (inherited from Object)
public method | ShouldSerializeName | (inherited from Binding)
public method | ShouldSerializeNamespace | (inherited from Binding)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

XrmBinding Class
Microsoft.Xrm.Sdk.Client Namespace


XrmBinding Properties
[image]

Public Properties

 | Name | Description
public property | CloseTimeout | (inherited from Binding)
public property | Elements | (inherited from CustomBinding)
public property | MaxBufferSize |
public property | MaxReceivedMessageSize |
public property | MessageVersion | (inherited from Binding)
public property | Name | (inherited from Binding)
public property | Namespace | (inherited from Binding)
public property | OpenTimeout | (inherited from Binding)
public property | ReaderQuotas |
public property | ReceiveTimeout | (inherited from Binding)
public property | Scheme | Overridden.
public property | SendTimeout | (inherited from Binding)

See Also

Reference

XrmBinding Class
Microsoft.Xrm.Sdk.Client Namespace


XrmBinding.MaxBufferSize Property
[image]

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MaxBufferSize As Integer

C#
public int MaxBufferSize { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmBinding Class
XrmBinding Members
Microsoft.Xrm.Sdk.Client Namespace


XrmBinding.MaxReceivedMessageSize Property
[image]

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MaxReceivedMessageSize As Long

C#
public long MaxReceivedMessageSize { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmBinding Class
XrmBinding Members
Microsoft.Xrm.Sdk.Client Namespace


XrmBinding.ReaderQuotas Property
[image]

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReaderQuotas As XmlDictionaryReaderQuotas

C#
public XmlDictionaryReaderQuotas ReaderQuotas { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmBinding Class
XrmBinding Members
Microsoft.Xrm.Sdk.Client Namespace


XrmBinding.Scheme Property
[image]

Namespace: Microsoft.Xrm.Sdk.Client
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides ReadOnly Property Scheme As String

C#
public override string Scheme { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmBinding Class
XrmBinding Members
Microsoft.Xrm.Sdk.Client Namespace


Microsoft.Xrm.Sdk.Deployment Namespace

Classes

Class | Description
AddCrmDatabaseRequest | Contains the data that is needed to add a Microsoft Dynamics CRM organization database to your deployment from a database backup or from a detached database.
AddCrmDatabaseResponse | Contains the response from AddCrmDatabaseRequest.
AddDeploymentAdministratorRequest | Contains the data that is needed to add a deployment administrator. The user must already exist in Active Directory.
AddDeploymentAdministratorResponse | Contains the response from the AddDeploymentAdministratorRequest.
AsyncSettings | Contains setting values that can be changed to tune a Microsoft Dynamics CRM deployment.
AttributeCollection | Contains a collection of attributes.
BaseData | For internal use only.
BeginCreateOrganizationRequest | Contains the data that is needed to initiate the asynchronous operation to create an organization.
BeginCreateOrganizationResponse | Contains the response from theBeginCreateOrganizationRequest.
BeginImportOrganizationRequest | Contains the data that is needed to begin the asynchronous operation to import an organization.
BeginImportOrganizationResponse | Contains the response from the BeginImportOrganizationRequest.
BeginUpdateOrganizationRequest | Contains the data that is needed to begin the asynchronous operation to update an organization.
BeginUpdateOrganizationResponse | Contains the response from theBeginUpdateOrganizationRequest.
BeginUpgradeOrganizationRequest | Contains the data that is needed to begin the asynchronous operation to upgrade an organization.
BeginUpgradeOrganizationResponse | Contains the response from theBeginUpgradeOrganizationRequest.
Certificate | Contains information about a certificate.
ClaimsSettings | Contains the settings for claims based authentication using Active Directory Federation Services 2.0 (AD FS 2.0).
ClaimsSettingsBase | Base class for claims settings types.
ConfigurationEntity | Contains attributes for a specific table in the configuration database.
CustomCodeSettings | Server level settings that control use of custom code.
DashboardSettings | Server level dashboard settings.
DeferredOperationError | Contains information about an error that occurred with a deferred operation.
DeferredOperationRequest | Base class for all asynchronous requests for the deployment Web service.
DeferredOperationResponse | Base class for all asynchronous responses for the deployment Web service.
DeferredOperationStatus | Contains information about the status of a deferred operation.
DeleteOrganizationRequest | Contains the data that is needed to delete a Microsoft Dynamics CRM organization.
DeleteOrganizationResponse | Contains the response from DeleteOrganizationRequest.
DeleteRequest | Contains the data that is needed to delete a deployment record.
DeleteResponse | Contains the response from the DeleteRequest.
DeploymentAdministrator | Contains information about a deployment administrator in a Microsoft Dynamics CRM deployment.
DeploymentConfigSettings | Base class for configuration settings entities.
DeploymentEntity | Base class for deployment entities.
DeploymentObject | Base class for deployment Web service entities and settings.
DeploymentServiceClient | Implements IDeploymentService interface and provides an authenticated WCF channel to the deployment service..
DeploymentServiceFault | Represents a deployment service fault.
DeploymentServiceRequest | Contains the data that is needed to execute a request and the base class for all deployment service requests.
DeploymentServiceResponse | Contains the response from the request and the base class for all deployment Web service responses.
DupSettings | Contains duplicate detection settings that can be used to tune a deployment.
EntityInstanceId | Contains the information needed to identify a deployment entity record: deployment entity type and ID.
ErrorDetailCollection | Contains the collection of error details.
EtmSettings | Contains Enterprise Transaction Monitor (ETM) settings.
IfdSettings | Contains settings for configuring Internet-facing deployments (IFDs).
ImportSettings | Contains settings that can be changed to tune data import.
LicenseProperties | Contains information about a license for Microsoft Dynamics CRM 2011.
MarketplaceSettings | Contains settings for the Microsoft Dynamics Marketplace.
MonitoringResultData | Contains information about the result of a test run by the Microsoft Dynamics CRM monitoring service.
MonitoringSettings | Contains settings used to manage or configure the monitoring service and the tests executed by the service.
MultiEntityQuickFindSettings | Contains settings for multi-entity quick find (finds records of different types).
OAuthClaimsSettings | Contains the settings for claims based OAuth authentication.
Organization | Contains information about an organization in a Microsoft Dynamics CRM deployment.
OrganizationUserInfo | Contains information about a user in an organization.
QuickFindSettings | Contains settings for quick find (finds records of one type).
RequestCheckResult | For internal use only.
RetrieveAdvancedSettingsRequest | Contains the data that is needed to retrieve advanced settings from the configuration database. For internal use only.
RetrieveAdvancedSettingsResponse | Contains the response from the RetrieveAdvancedSettingsRequest.
RetrieveAllRequest | Contains the data that is needed to retrieve all deployment records of the specified deployment entity type.
RetrieveAllResponse | Contains the response from the RetrieveAllRequest.
RetrieveMonitoringResultsRequest | Contains the data that is required to retrieve results from the monitoring service operation tests for your Microsoft Dynamics CRM deployment.
RetrieveMonitoringResultsResponse | Contains the response from RetrieveMonitoringResultsRequest.
RetrieveRequest | Contains the data that is needed to retrieve a deployment entity or configuration settings record.
RetrieveResponse | Contains the response from the RetrieveRequest.
RetrieveUserMappingRequest | Contains the data needed to retrieve mapping information of existing users in a Microsoft Dynamics CRM organization.
RetrieveUserMappingResponse | Contains the response from RetrieveUserMappingRequest.
Server | Contains information about a server in a Microsoft Dynamics CRM deployment.
ServerSideSyncACTSettings |
ServerSideSyncEmailSettings |
ServerSideSyncQueueSettings |
SqmSettings | Contains settings about the Microsoft customer experience improvement program.
TeamSettings | Contains settings for the auto created (system-managed) access teams.
ThrottleSettings | Contains information about service throttling.
TraceSettings | Contains trace settings for a deployment.
TrackLicenseRequest | Contains the data that is needed to track the licenses for a deployment.
TrackLicenseResponse | Contains the response from theTrackLicenseRequest.
UpdateAdvancedSettingsRequest | Contains the data that is needed to update advanced settings from the configuration database. For internal use only.
UpdateAdvancedSettingsResponse | Contains the response from theUpdateAdvancedSettingsRequest.
UpdateProductKeyRequest | Contains the data that is needed to update a product key.
UpdateProductKeyResponse | Contains the response from the UpdateProductKeyRequest.
UpdateRequest | Contains the data that is needed to update a deployment record.
UpdateResponse | Contains the response from theUpdateRequest.
WebAddressSettings | Contains deployment specific root domain address values.
WorkflowSettings | Contains workflow setting values which can be changed to tune a Microsoft Dynamics CRM deployment.
YammerSettings | Contains settings for Yammer.

Interfaces

Interface | Description
IDeploymentService | Provides programmatic access to deployment information.
IDeploymentServiceChannel | Interface for the deployment web service channel.

Enumerations

Enumeration | Description
AddressScheme | The address scheme: http or https.
DeferredOperationState | Describes the possible states for an asynchronous operation.
DeploymentEntityType | Describes the type of deployment entity.
DeploymentErrorLevel | Contains information about an error with the deployment web service.
ImportUserMappingMethod | Defines the possible methods for mapping users when importing an organization.
LicenseType | Indicates the type of license.
OrganizationState | Describes the state of the organization.
ServerRoles | Describes specific server functionality, components, and services.
ServerState | Describes the state of a server.
ServiceHealthStatus | Describes the deployment service health status.
TestStatus | Indicates the result of a monitoring service operation test.
TrackingLicenseType | Describes the type of license.


AddCrmDatabaseRequest Class
See Also Members
[image]

Contains the data that is needed to add a Microsoft Dynamics CRM organization database to your deployment from a database backup or from a detached database.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AddCrmDatabaseRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class AddCrmDatabaseRequest
    Inherits DeploymentServiceRequest

C#
[DataContractAttribute(Name="AddCrmDatabaseRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class AddCrmDatabaseRequest : DeploymentServiceRequest

C++

J#

JScript

  Remarks
Usage
Pass an instance of this class to the Execute method, which returns an instance of the AddCrmDatabaseResponse class.
Notes for Callers
You can also use the Add-CrmDatabaseWindows PowerShell command. For more information, see Microsoft Dynamics CRM PowerShell Reference.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.AddCrmDatabaseRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddCrmDatabaseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
AddCrmDatabaseResponse
Other Resources
Deployment Web Service Messages
Add-CrmDatabase


AddCrmDatabaseRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add a Microsoft Dynamics CRM organization database to your deployment from a database backup or from a detached database.

The following tables list the members exposed by the AddCrmDatabaseRequest type.

Public Constructors

Name | Description
AddCrmDatabaseRequest | Initializes a new instance of the AddCrmDatabaseRequest class.
Top

Public Properties

 | Name | Description
public property | DatabaseBackupFileName | Gets or sets the name of the SQL Server database backup file.
public property | DatabaseLogFileName | Gets or sets the name of the SQL Server database log file (.ldf).
public property | DatabaseMetadataFileName | Gets or sets the name of the SQL Server database metadata file (.mdf).
public property | DatabaseName | Gets or sets the name of the CRM organization database to import.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | SqlServerName | Gets or sets the name of the SQL Server instance where you want to add the CRM organization database.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddCrmDatabaseRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
AddCrmDatabaseResponse

Other Resources

Deployment Web Service Messages
Add-CrmDatabase


AddCrmDatabaseRequest Constructor
[image]

Initializes a new instance of the AddCrmDatabaseRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddCrmDatabaseRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddCrmDatabaseRequest Class
AddCrmDatabaseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddCrmDatabaseRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
AddCrmDatabaseResponse

Other Resources

Deployment Web Service Messages
Add-CrmDatabase


AddCrmDatabaseRequest Properties
[image]

Public Properties

 | Name | Description
public property | DatabaseBackupFileName | Gets or sets the name of the SQL Server database backup file.
public property | DatabaseLogFileName | Gets or sets the name of the SQL Server database log file (.ldf).
public property | DatabaseMetadataFileName | Gets or sets the name of the SQL Server database metadata file (.mdf).
public property | DatabaseName | Gets or sets the name of the CRM organization database to import.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | SqlServerName | Gets or sets the name of the SQL Server instance where you want to add the CRM organization database.

See Also

Reference

AddCrmDatabaseRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
AddCrmDatabaseResponse

Other Resources

Deployment Web Service Messages
Add-CrmDatabase


AddCrmDatabaseRequest.DatabaseBackupFileName Property
[image]

Gets or sets the name of the SQL Server database backup file.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DatabaseBackupFileName As String

C#
[DataMemberAttribute]
public string DatabaseBackupFileName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the SQL Server database backup file. This should be a full backup file of the source Microsoft Dynamics CRM database. This file must be accessible from SQL Server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddCrmDatabaseRequest Class
AddCrmDatabaseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseRequest.DatabaseLogFileName Property
[image]

Gets or sets the name of the SQL Server database log file (.ldf).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DatabaseLogFileName As String

C#
[DataMemberAttribute]
public string DatabaseLogFileName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the SQL Server database log file (.ldf). This file must be accessible from SQL Server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddCrmDatabaseRequest Class
AddCrmDatabaseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseRequest.DatabaseMetadataFileName Property
[image]

Gets or sets the name of the SQL Server database metadata file (.mdf).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DatabaseMetadataFileName As String

C#
[DataMemberAttribute]
public string DatabaseMetadataFileName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the SQL Server database metadata file (.mdf). This file must be accessible from SQL Server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddCrmDatabaseRequest Class
AddCrmDatabaseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseRequest.DatabaseName Property
[image]

Gets or sets the name of the CRM organization database to import.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property DatabaseName As String

C#
[DataMemberAttribute(IsRequired=true)]
public string DatabaseName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the CRM organization database to import.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddCrmDatabaseRequest Class
AddCrmDatabaseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseRequest.SqlServerName Property
[image]

Gets or sets the name of the SQL Server instance where you want to add the CRM organization database.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property SqlServerName As String

C#
[DataMemberAttribute(IsRequired=true)]
public string SqlServerName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the SQL Server instance where you want to add the CRM organization database.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddCrmDatabaseRequest Class
AddCrmDatabaseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseResponse Class
See Also Members
[image]

Contains the response from AddCrmDatabaseRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="AddCrmDatabaseResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class AddCrmDatabaseResponse
    Inherits DeploymentServiceResponse

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="AddCrmDatabaseResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class AddCrmDatabaseResponse : DeploymentServiceResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.AddCrmDatabaseResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddCrmDatabaseResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from AddCrmDatabaseRequest.

The following tables list the members exposed by the AddCrmDatabaseResponse type.

Public Constructors

Name | Description
AddCrmDatabaseResponse | Initializes a new instance of the AddCrmDatabaseResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddCrmDatabaseResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseResponse Constructor
[image]

Initializes a new instance of the AddCrmDatabaseResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddCrmDatabaseResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddCrmDatabaseResponse Class
AddCrmDatabaseResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddCrmDatabaseResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


AddCrmDatabaseResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)

See Also

Reference

AddCrmDatabaseResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


AddDeploymentAdministratorRequest Class
See Also Example Members
[image]

Contains the data that is needed to add a deployment administrator. The user must already exist in Active Directory.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="AddDeploymentAdministratorRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class AddDeploymentAdministratorRequest
    Inherits DeploymentServiceRequest

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="AddDeploymentAdministratorRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class AddDeploymentAdministratorRequest : DeploymentServiceRequest

C++

J#

JScript

  Example
    Copy Code
// The user must already exist in AD.
AddDeploymentAdministratorRequest request = new AddDeploymentAdministratorRequest();
request.Name = Config.AdminDomain + "\\" + userName;

_deploymentService.Execute(request);

  Remarks
Usage
Pass an instance of this class to the Execute method, which returns an instance of AddDeploymentAdministratorResponse.
Notes for Callers
You can also use the New-CrmDeploymentAdministratorWindows PowerShell command. For more information, see Administer the deployment using Windows PowerShell.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.AddDeploymentAdministratorRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
AddDeploymentAdministratorRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
AddDeploymentAdministratorResponse
Other Resources
Deployment Web Service Messages
New-CrmDeploymentAdministrator


AddDeploymentAdministratorRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to add a deployment administrator. The user must already exist in Active Directory.

The following tables list the members exposed by the AddDeploymentAdministratorRequest type.

Public Constructors

Name | Description
AddDeploymentAdministratorRequest | Initializes a new instance of the AddDeploymentAdministratorRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Name | Gets or sets the name of the deployment administrator to be added. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddDeploymentAdministratorRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
AddDeploymentAdministratorResponse

Other Resources

Deployment Web Service Messages
New-CrmDeploymentAdministrator


AddDeploymentAdministratorRequest Constructor
[image]

Initializes a new instance of the AddDeploymentAdministratorRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddDeploymentAdministratorRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddDeploymentAdministratorRequest Class
AddDeploymentAdministratorRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddDeploymentAdministratorRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddDeploymentAdministratorRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
AddDeploymentAdministratorResponse

Other Resources

Deployment Web Service Messages
New-CrmDeploymentAdministrator


AddDeploymentAdministratorRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Name | Gets or sets the name of the deployment administrator to be added. Required.

See Also

Reference

AddDeploymentAdministratorRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
AddDeploymentAdministratorResponse

Other Resources

Deployment Web Service Messages
New-CrmDeploymentAdministrator


AddDeploymentAdministratorRequest.Name Property
[image]

Gets or sets the name of the deployment administrator to be added. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Name As String

C#
[DataMemberAttribute]
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the deployment administrator to be added, which string must be in the format domain\userid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddDeploymentAdministratorRequest Class
AddDeploymentAdministratorRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddDeploymentAdministratorResponse Class
See Also Members
[image]

Contains the response from the AddDeploymentAdministratorRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AddDeploymentAdministratorResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class AddDeploymentAdministratorResponse
    Inherits DeploymentServiceResponse

C#
[DataContractAttribute(Name="AddDeploymentAdministratorResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class AddDeploymentAdministratorResponse : DeploymentServiceResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.AddDeploymentAdministratorResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddDeploymentAdministratorResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
AddDeploymentAdministratorRequest


AddDeploymentAdministratorResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AddDeploymentAdministratorRequest.

The following tables list the members exposed by the AddDeploymentAdministratorResponse type.

Public Constructors

Name | Description
AddDeploymentAdministratorResponse | Initializes a new instance of the AddDeploymentAdministratorResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AddDeploymentAdministratorResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
AddDeploymentAdministratorRequest


AddDeploymentAdministratorResponse Constructor
[image]

Initializes a new instance of the AddDeploymentAdministratorResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AddDeploymentAdministratorResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AddDeploymentAdministratorResponse Class
AddDeploymentAdministratorResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


AddDeploymentAdministratorResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AddDeploymentAdministratorResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
AddDeploymentAdministratorRequest


AddDeploymentAdministratorResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)

See Also

Reference

AddDeploymentAdministratorResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
AddDeploymentAdministratorRequest


AddressScheme Enumeration
[image]

The address scheme: http or https.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AddressScheme", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Enumeration AddressScheme

C#
[DataContractAttribute(Name="AddressScheme", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public enum AddressScheme

C++

J#

JScript

  Members
Member name | Description
http | The address scheme is hypertext transfer protocol.
https | The address scheme is secure hypertext transfer protocol.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace
RootDomainScheme


AsyncSettings Class
See Also Members
[image]

Contains setting values that can be changed to tune a Microsoft Dynamics CRM deployment.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="AsyncSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class AsyncSettings
    Inherits DeploymentConfigSettings

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="AsyncSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class AsyncSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
You can also use Windows PowerShell to retrieve or update these settings.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.AsyncSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


AsyncSettings Members
See Also Constructors Methods Properties
[image]

Contains setting values that can be changed to tune a Microsoft Dynamics CRM deployment.

The following tables list the members exposed by the AsyncSettings type.

Public Constructors

Name | Description
AsyncSettings | Initializes a new instance of the AsyncSettings class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | JobTimeoutLockedInterval | Gets or sets the interval used to query to see if there are any organization maintenance jobs that have timed out.
public property | MaxJobExecutionTime | Gets or sets a value used for organization maintenance jobs to determine if a job has timed out.
public property | MaxRetries | Gets or sets the number of times an asynchronous job will retry before it fails or suspends.
public property | MaxStateStatusUpdateMaxRetryCount | Gets or sets the maximum number of times a database operation will be attempted before failure.
public property | OrgDatabaseMaintenanceJobInterval | Gets or sets the interval used to query to see if there is a pending organization maintenance job.
public property | RetryInterval | Gets or sets the default rate of retries for failed asynchronous operations.
public property | SdkRootDomain | Gets or sets the root domain used for calls into the Microsoft Dynamics CRM service from the asynchronous service.
public property | SelectInterval | Gets or sets the interval used to determine if new asynchronous operations should be loaded into memory.
public property | ThrottlingConfiguration | Gets or sets the throttling configuration.
public property | TimeoutLockedInterval | Gets or sets the interval used to query to see if there are any asynchronous operations that have timed out.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AsyncSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


AsyncSettings Constructor
[image]

Initializes a new instance of the AsyncSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AsyncSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AsyncSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


AsyncSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | JobTimeoutLockedInterval | Gets or sets the interval used to query to see if there are any organization maintenance jobs that have timed out.
public property | MaxJobExecutionTime | Gets or sets a value used for organization maintenance jobs to determine if a job has timed out.
public property | MaxRetries | Gets or sets the number of times an asynchronous job will retry before it fails or suspends.
public property | MaxStateStatusUpdateMaxRetryCount | Gets or sets the maximum number of times a database operation will be attempted before failure.
public property | OrgDatabaseMaintenanceJobInterval | Gets or sets the interval used to query to see if there is a pending organization maintenance job.
public property | RetryInterval | Gets or sets the default rate of retries for failed asynchronous operations.
public property | SdkRootDomain | Gets or sets the root domain used for calls into the Microsoft Dynamics CRM service from the asynchronous service.
public property | SelectInterval | Gets or sets the interval used to determine if new asynchronous operations should be loaded into memory.
public property | ThrottlingConfiguration | Gets or sets the throttling configuration.
public property | TimeoutLockedInterval | Gets or sets the interval used to query to see if there are any asynchronous operations that have timed out.

See Also

Reference

AsyncSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


AsyncSettings.JobTimeoutLockedInterval Property
[image]

Gets or sets the interval used to query to see if there are any organization maintenance jobs that have timed out.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property JobTimeoutLockedInterval As Integer

C#
[DataMemberAttribute]
public int JobTimeoutLockedInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The interval at which the service will determine if any job has been running longer than MaxJobExecutionTime.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings.MaxJobExecutionTime Property
[image]

Gets or sets a value used for organization maintenance jobs to determine if a job has timed out.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxJobExecutionTime As Integer

C#
[DataMemberAttribute]
public int MaxJobExecutionTime { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The timeout value for organization maintenance jobs.

  Remarks
At each JobTimeoutLockedInterval, the service will query to determine if a job has been running longer than the MaxJobExecutionTime value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings.MaxRetries Property
[image]

Gets or sets the number of times an asynchronous job will retry before it fails or suspends.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxRetries As Integer

C#
[DataMemberAttribute]
public int MaxRetries { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The number of retries for an asynchronous job.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings.MaxStateStatusUpdateMaxRetryCount Property
[image]

Gets or sets the maximum number of times a database operation will be attempted before failure.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxStateStatusUpdateMaxRetryCount As Integer

C#
[DataMemberAttribute]
public int MaxStateStatusUpdateMaxRetryCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The number of retries for a database operation.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings.OrgDatabaseMaintenanceJobInterval Property
[image]

Gets or sets the interval used to query to see if there is a pending organization maintenance job.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrgDatabaseMaintenanceJobInterval As Integer

C#
[DataMemberAttribute]
public int OrgDatabaseMaintenanceJobInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The query interval for organization maintenance jobs.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings.RetryInterval Property
[image]

Gets or sets the default rate of retries for failed asynchronous operations.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RetryInterval As Integer

C#
[DataMemberAttribute]
public int RetryInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The retry rate for failed asynchronous operations.

  Remarks
This setting should be used in conjunction with the MaxRetries property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings.SdkRootDomain Property
[image]

Gets or sets the root domain used for calls into the Microsoft Dynamics CRM service from the asynchronous service.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SdkRootDomain As String

C#
[DataMemberAttribute]
public string SdkRootDomain { get; set; }

C++

J#

JScript

Property Value
Type: String

The root domain.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings.SelectInterval Property
[image]

Gets or sets the interval used to determine if new asynchronous operations should be loaded into memory.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SelectInterval As Integer

C#
[DataMemberAttribute]
public int SelectInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The interval for loading asynchronous operations into memory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings.ThrottlingConfiguration Property
[image]

Gets or sets the throttling configuration.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ThrottlingConfiguration As String

C#
[DataMemberAttribute]
public string ThrottlingConfiguration { get; set; }

C++

J#

JScript

Property Value
Type: String

The throttling configuration. Example: "BulkDelete=15;Workflow=1;Event=1".

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AsyncSettings.TimeoutLockedInterval Property
[image]

Gets or sets the interval used to query to see if there are any asynchronous operations that have timed out.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TimeoutLockedInterval As Integer

C#
[DataMemberAttribute]
public int TimeoutLockedInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The query interval.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AsyncSettings Class
AsyncSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


AttributeCollection Class
See Also Members
[image]

Contains a collection of attributes.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
<CollectionDataContractAttribute(Name:="AttributeCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment", ItemName:="KeyValuePairOfstringanyType")> _
Public Class AttributeCollection
    Inherits DataCollection(Of KeyValuePair(Of String, Object))

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
[CollectionDataContractAttribute(Name="AttributeCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment", ItemName="KeyValuePairOfstringanyType")]
public class AttributeCollection : DataCollection<KeyValuePair<string,Object>>

C++

J#

JScript

  Remarks
Used in the ConfigurationEntity class to hold a set of configuration attributes.

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.Deployment.AttributeCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeCollection Members
Microsoft.Xrm.Sdk.Deployment Namespace


AttributeCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a collection of attributes.

The following tables list the members exposed by the AttributeCollection type.

Public Constructors

Name | Description
AttributeCollection | Initializes a new instance of the AttributeCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

AttributeCollection Class
Microsoft.Xrm.Sdk.Deployment Namespace


AttributeCollection Constructor
[image]

Initializes a new instance of the AttributeCollection class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeCollection Class
AttributeCollection Members
Microsoft.Xrm.Sdk.Deployment Namespace


AttributeCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

AttributeCollection Class
Microsoft.Xrm.Sdk.Deployment Namespace


AttributeCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

AttributeCollection Class
Microsoft.Xrm.Sdk.Deployment Namespace


BaseData Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<KnownTypeAttribute(GetType(MonitoringResultData))> _
<DataContractAttribute(Name:="BaseData", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class BaseData
    Implements IExtensibleDataObject

C#
[DebuggerStepThroughAttribute]
[KnownTypeAttribute(typeof(MonitoringResultData))]
[DataContractAttribute(Name="BaseData", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class BaseData : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Deployment.BaseData

                Microsoft.Xrm.Sdk.Deployment.MonitoringResultData
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BaseData Members
Microsoft.Xrm.Sdk.Deployment Namespace


BaseData Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the BaseData type.

Public Constructors

Name | Description
BaseData |
Top

Public Properties

 | Name | Description
public property | ExtensionData | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BaseData Class
Microsoft.Xrm.Sdk.Deployment Namespace


BaseData Constructor
[image]

Initializes a new instance of the BaseData Class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BaseData ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BaseData Class
BaseData Members
Microsoft.Xrm.Sdk.Deployment Namespace


BaseData Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BaseData Class
Microsoft.Xrm.Sdk.Deployment Namespace


BaseData Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | For internal use only.

See Also

Reference

BaseData Class
Microsoft.Xrm.Sdk.Deployment Namespace


BaseData.ExtensionData Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Returns ExtensionDataObject.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BaseData Class
BaseData Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginCreateOrganizationRequest Class
See Also Example Members
[image]

Contains the data that is needed to initiate the asynchronous operation to create an organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="BeginCreateOrganizationRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class BeginCreateOrganizationRequest
    Inherits DeferredOperationRequest

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="BeginCreateOrganizationRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class BeginCreateOrganizationRequest : DeferredOperationRequest

C++

J#

JScript

  Example
    Copy Code
Guid operationId = Guid.Empty;
            // instantiating the DeploymentServiceClient in a using statement ensures that the client
            // communication channel is closed and the object is disposed when falling out of scope.

            // CustomBinding_IDeploymenService is the name of the configuration setting for the CustomBinding
            using (DeploymentServiceClient client = new DeploymentServiceClient("CustomBinding_IDeploymentService"))
            {
                // Set properties for the new organization
                Organization organization = new Organization
                {
                    BaseCurrencyCode = "USD",
                    BaseCurrencyName = "US Dollar",
                    BaseCurrencyPrecision = 2,
                    BaseCurrencySymbol = "$",
                    BaseLanguageCode = 1033,
                    FriendlyName = "Alpine Ski House",
                    UniqueName = "AlpineSkiHouse",
                    SqlCollation = "Latin1_General_CI_AI",
                    SqlServerName = "CRM01",
                    SrsUrl = "http://CRM01/ReportServer",
                    SqmIsEnabled = false
                };

                // Create a request for the deployment service
                BeginCreateOrganizationRequest request = new BeginCreateOrganizationRequest();
                request.Organization = organization;

                // Execute the request
                BeginCreateOrganizationResponse response = (BeginCreateOrganizationResponse)client.Execute(request);

                // The operation is asynchronous, so the response object contains a unique identifier
                // for the operation
                operationId = response.OperationId;

            }

  Remarks
Usage
Pass an instance of this class to the Execute method, which returns an instance of BeginCreateOrganizationResponse.
Notes for Callers
You can also use the New-CrmOrganizationWindows PowerShell command. For more information, see Administer the deployment using Windows PowerShell.
You can use the Get-CrmOperationStatusWindows PowerShell command to check the status of this asynchronous request. Or, you can use the RetrieveRequest message using the OperationId property to set the InstanceTag property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest

                Microsoft.Xrm.Sdk.Deployment.DeferredOperationRequest
      Microsoft.Xrm.Sdk.Deployment.BeginCreateOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
BeginCreateOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationResponse
Other Resources
New-CrmOrganization
Get-CrmOperationStatus


BeginCreateOrganizationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to initiate the asynchronous operation to create an organization.

The following tables list the members exposed by the BeginCreateOrganizationRequest type.

Public Constructors

Name | Description
BeginCreateOrganizationRequest | Initializes a new instance of the BeginCreateOrganizationRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Organization | Gets or sets the organization instance to be created. Required.
public property | SysAdminName | Gets or sets the name of the system administrator for the new organization. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BeginCreateOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationResponse

Other Resources

New-CrmOrganization
Get-CrmOperationStatus


BeginCreateOrganizationRequest Constructor
[image]

Initializes a new instance of the BeginCreateOrganizationRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BeginCreateOrganizationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginCreateOrganizationRequest Class
BeginCreateOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginCreateOrganizationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BeginCreateOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationResponse

Other Resources

New-CrmOrganization
Get-CrmOperationStatus


BeginCreateOrganizationRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Organization | Gets or sets the organization instance to be created. Required.
public property | SysAdminName | Gets or sets the name of the system administrator for the new organization. Required.

See Also

Reference

BeginCreateOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationResponse

Other Resources

New-CrmOrganization
Get-CrmOperationStatus


BeginCreateOrganizationRequest.Organization Property
[image]

Gets or sets the organization instance to be created. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property Organization As Organization

C#
[DataMemberAttribute(IsRequired=true)]
public Organization Organization { get; set; }

C++

J#

JScript

Property Value
Type: Organization
The organization instance to be created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginCreateOrganizationRequest Class
BeginCreateOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginCreateOrganizationRequest.SysAdminName Property
[image]

Gets or sets the name of the system administrator for the new organization. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SysAdminName As String

C#
[DataMemberAttribute]
public string SysAdminName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the system administrator for the new organization.

  Remarks
The format of this string is domain\userid. The user must exist in Active Directory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginCreateOrganizationRequest Class
BeginCreateOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginCreateOrganizationResponse Class
See Also Members
[image]

Contains the response from theBeginCreateOrganizationRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="BeginCreateOrganizationResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class BeginCreateOrganizationResponse
    Inherits DeferredOperationResponse

C#
[DataContractAttribute(Name="BeginCreateOrganizationResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class BeginCreateOrganizationResponse : DeferredOperationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse

                Microsoft.Xrm.Sdk.Deployment.DeferredOperationResponse
      Microsoft.Xrm.Sdk.Deployment.BeginCreateOrganizationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginCreateOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationRequest


BeginCreateOrganizationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from theBeginCreateOrganizationRequest.

The following tables list the members exposed by the BeginCreateOrganizationResponse type.

Public Constructors

Name | Description
BeginCreateOrganizationResponse | Initializes a new instance of the BeginCreateOrganizationResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request. (inherited from DeferredOperationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BeginCreateOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationRequest


BeginCreateOrganizationResponse Constructor
[image]

Initializes a new instance of the BeginCreateOrganizationResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BeginCreateOrganizationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginCreateOrganizationResponse Class
BeginCreateOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginCreateOrganizationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BeginCreateOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationRequest


BeginCreateOrganizationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request. (inherited from DeferredOperationResponse)

See Also

Reference

BeginCreateOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationRequest


BeginImportOrganizationRequest Class
See Also Example Members
[image]

Contains the data that is needed to begin the asynchronous operation to import an organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="BeginImportOrganizationRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class BeginImportOrganizationRequest
    Inherits DeferredOperationRequest

C#
[DataContractAttribute(Name="BeginImportOrganizationRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class BeginImportOrganizationRequest : DeferredOperationRequest

C++

J#

JScript

  Example
    Copy Code
BeginImportOrganizationRequest request = new BeginImportOrganizationRequest();
request.DatabaseName = "MyOrgName" + "_MSCRM";
request.SqlServerName = Config.SetupSqlServer;
request.SrsUrl = "http://" + Config.SetupSqlServer + "/reportserver";

Guid operationId = ((BeginImportOrganizationResponse)_deploymentService.Execute(request)).OperationId;

DeferredOperationStatus importOrgOperationStatus = WaitForAsyncOperationAndReturnStatus(operationId);

If (importOrgOperationStatus.State == DeferredOperationState.Completed)
   //Do something

  Remarks
Usage
Pass an instance of this class to the Execute method, which returns an instance of BeginImportOrganizationResponse.
Notes for Callers
You can also use the Import-CrmOrganizationWindows PowerShell command. For more information, see Administer the deployment using Windows PowerShell.
You can use the Get-CrmOperationStatusWindows PowerShell command to check the status of this asynchronous request. Or, you can use the RetrieveRequest message using the OperationId property to set the InstanceTag property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest

                Microsoft.Xrm.Sdk.Deployment.DeferredOperationRequest
      Microsoft.Xrm.Sdk.Deployment.BeginImportOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
BeginImportOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationResponse
Other Resources
Import-CrmOrganization
Get-CrmOperationStatus


BeginImportOrganizationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to begin the asynchronous operation to import an organization.

The following tables list the members exposed by the BeginImportOrganizationRequest type.

Public Constructors

Name | Description
BeginImportOrganizationRequest | Initializes a new instance of the BeginImportOrganizationRequest class.
Top

Public Properties

 | Name | Description
public property | DatabaseName | Gets or sets the database name for the organization. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | FriendlyName | Gets or sets the sets display name, or long name, of the organization database. Optional.
public property | SqlServerName | Gets or sets the name of the Microsoft SQL Server where the Microsoft Dynamics CRM organization database is located. Required.
public property | SrsUrl | Gets or sets the URL of the Microsoft SQL Server on which the Microsoft Dynamics CRM Connector for SQL Server Reporting Services is installed. Required.
public property | UniqueName | Gets or sets the unique name for the organization. Optional.
public property | UserMappingMethod | Gets or sets the mapping method to use to map user accounts from the original server to the new server. Optional.
public property | UserMappingXml | Gets or sets the XML user account mapping rules. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BeginImportOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationResponse

Other Resources

Import-CrmOrganization
Get-CrmOperationStatus


BeginImportOrganizationRequest Constructor
[image]

Initializes a new instance of the BeginImportOrganizationRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BeginImportOrganizationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationRequest Class
BeginImportOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginImportOrganizationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BeginImportOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationResponse

Other Resources

Import-CrmOrganization
Get-CrmOperationStatus


BeginImportOrganizationRequest Properties
[image]

Public Properties

 | Name | Description
public property | DatabaseName | Gets or sets the database name for the organization. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | FriendlyName | Gets or sets the sets display name, or long name, of the organization database. Optional.
public property | SqlServerName | Gets or sets the name of the Microsoft SQL Server where the Microsoft Dynamics CRM organization database is located. Required.
public property | SrsUrl | Gets or sets the URL of the Microsoft SQL Server on which the Microsoft Dynamics CRM Connector for SQL Server Reporting Services is installed. Required.
public property | UniqueName | Gets or sets the unique name for the organization. Optional.
public property | UserMappingMethod | Gets or sets the mapping method to use to map user accounts from the original server to the new server. Optional.
public property | UserMappingXml | Gets or sets the XML user account mapping rules. Optional.

See Also

Reference

BeginImportOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationResponse

Other Resources

Import-CrmOrganization
Get-CrmOperationStatus


BeginImportOrganizationRequest.DatabaseName Property
[image]

Gets or sets the database name for the organization. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property DatabaseName As String

C#
[DataMemberAttribute(IsRequired=true)]
public string DatabaseName { get; set; }

C++

J#

JScript

Property Value
Type: String
The database name for the organization.

  Remarks
This property cannot be updated after the organization is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationRequest Class
BeginImportOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginImportOrganizationRequest.FriendlyName Property
[image]

Gets or sets the sets display name, or long name, of the organization database. Optional.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FriendlyName As String

C#
[DataMemberAttribute]
public string FriendlyName { get; set; }

C++

J#

JScript

Property Value
Type: String
The sets display name, or long name, of the organization database.

  Remarks
This will default to the existing friendly name in the organization database.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationRequest Class
BeginImportOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginImportOrganizationRequest.SqlServerName Property
[image]

Gets or sets the name of the Microsoft SQL Server where the Microsoft Dynamics CRM organization database is located. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property SqlServerName As String

C#
[DataMemberAttribute(IsRequired=true)]
public string SqlServerName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the Microsoft SQL Server where the Microsoft Dynamics CRM organization database is located.

  Remarks
This property is required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationRequest Class
BeginImportOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginImportOrganizationRequest.SrsUrl Property
[image]

Gets or sets the URL of the Microsoft SQL Server on which the Microsoft Dynamics CRM Connector for SQL Server Reporting Services is installed. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property SrsUrl As String

C#
[DataMemberAttribute(IsRequired=true)]
public string SrsUrl { get; set; }

C++

J#

JScript

Property Value
Type: String
The URL of the Microsoft SQL Server on which the Microsoft Dynamics CRM Connector for SQL Server Reporting Services is installed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationRequest Class
BeginImportOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginImportOrganizationRequest.UniqueName Property
[image]

Gets or sets the unique name for the organization. Optional.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UniqueName As String

C#
[DataMemberAttribute]
public string UniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name for the organization.

  Remarks
This will default to a unique version of the friendly name. For information about invalid unique names, see UniqueName.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationRequest Class
BeginImportOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginImportOrganizationRequest.UserMappingMethod Property
[image]

Gets or sets the mapping method to use to map user accounts from the original server to the new server. Optional.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property UserMappingMethod As ImportUserMappingMethod

C#
[DataMemberAttribute(IsRequired=true)]
public ImportUserMappingMethod UserMappingMethod { get; set; }

C++

J#

JScript

Property Value
Type: ImportUserMappingMethod
The mapping method to use to map user accounts from the original server to the new server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationRequest Class
BeginImportOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginImportOrganizationRequest.UserMappingXml Property
[image]

Gets or sets the XML user account mapping rules. Optional.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UserMappingXml As String

C#
[DataMemberAttribute]
public string UserMappingXml { get; set; }

C++

J#

JScript

Property Value
Type: String
The XML user account mapping rules.

  Remarks
If you have specified ByMappingXml for the UserMappingMethod property, you must provide this value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationRequest Class
BeginImportOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginImportOrganizationResponse Class
See Also Members
[image]

Contains the response from the BeginImportOrganizationRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="BeginImportOrganizationResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class BeginImportOrganizationResponse
    Inherits DeferredOperationResponse

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="BeginImportOrganizationResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class BeginImportOrganizationResponse : DeferredOperationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse

                Microsoft.Xrm.Sdk.Deployment.DeferredOperationResponse
      Microsoft.Xrm.Sdk.Deployment.BeginImportOrganizationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationRequest


BeginImportOrganizationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the BeginImportOrganizationRequest.

The following tables list the members exposed by the BeginImportOrganizationResponse type.

Public Constructors

Name | Description
BeginImportOrganizationResponse | Initializes a new instance of the BeginImportOrganizationResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request. (inherited from DeferredOperationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BeginImportOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationRequest


BeginImportOrganizationResponse Constructor
[image]

Initializes a new instance of the BeginImportOrganizationResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BeginImportOrganizationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginImportOrganizationResponse Class
BeginImportOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginImportOrganizationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BeginImportOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationRequest


BeginImportOrganizationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request. (inherited from DeferredOperationResponse)

See Also

Reference

BeginImportOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationRequest


BeginUpdateOrganizationRequest Class
See Also Members
[image]

Contains the data that is needed to begin the asynchronous operation to update an organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="BeginUpdateOrganizationRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class BeginUpdateOrganizationRequest
    Inherits DeferredOperationRequest

C#
[DataContractAttribute(Name="BeginUpdateOrganizationRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class BeginUpdateOrganizationRequest : DeferredOperationRequest

C++

J#

JScript

  Remarks
Pass an instance of this class to the Execute method, which returns an instance of BeginUpdateOrganizationRequest.
You can also use the Update-CrmOrganizationWindows PowerShell command. For more information, see Administer the deployment using Windows PowerShell.
You can use the Get-CrmOperationStatus Windows PowerShell command to check the status of this asynchronous request. Or, you can use the RetrieveRequest message using the OperationId property to set the InstanceTag property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest

                Microsoft.Xrm.Sdk.Deployment.DeferredOperationRequest
      Microsoft.Xrm.Sdk.Deployment.BeginUpdateOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpdateOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpdateOrganizationResponse
Other Resources
Deployment Web Service Messages
Update-CrmOrganization
Get-CrmOperationStatus


BeginUpdateOrganizationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to begin the asynchronous operation to update an organization.

The following tables list the members exposed by the BeginUpdateOrganizationRequest type.

Public Constructors

Name | Description
BeginUpdateOrganizationRequest | Initializes a new instance of the BeginUpdateOrganizationRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Tag | Gets or sets the ID or instance tag of the organization to update. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BeginUpdateOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpdateOrganizationResponse

Other Resources

Deployment Web Service Messages
Update-CrmOrganization
Get-CrmOperationStatus


BeginUpdateOrganizationRequest Constructor
[image]

Initializes a new instance of the BeginUpdateOrganizationRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BeginUpdateOrganizationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpdateOrganizationRequest Class
BeginUpdateOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginUpdateOrganizationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BeginUpdateOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpdateOrganizationResponse

Other Resources

Deployment Web Service Messages
Update-CrmOrganization
Get-CrmOperationStatus


BeginUpdateOrganizationRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Tag | Gets or sets the ID or instance tag of the organization to update. Required.

See Also

Reference

BeginUpdateOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpdateOrganizationResponse

Other Resources

Deployment Web Service Messages
Update-CrmOrganization
Get-CrmOperationStatus


BeginUpdateOrganizationRequest.Tag Property
[image]

Gets or sets the ID or instance tag of the organization to update. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property Tag As EntityInstanceId

C#
[DataMemberAttribute(IsRequired=true)]
public EntityInstanceId Tag { get; set; }

C++

J#

JScript

Property Value
Type: EntityInstanceId

The ID or instance tag of the organization to update.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpdateOrganizationRequest Class
BeginUpdateOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginUpdateOrganizationResponse Class
See Also Members
[image]

Contains the response from theBeginUpdateOrganizationRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="BeginUpdateOrganizationResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class BeginUpdateOrganizationResponse
    Inherits DeferredOperationResponse

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="BeginUpdateOrganizationResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class BeginUpdateOrganizationResponse : DeferredOperationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse

                Microsoft.Xrm.Sdk.Deployment.DeferredOperationResponse
      Microsoft.Xrm.Sdk.Deployment.BeginUpdateOrganizationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpdateOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpdateOrganizationRequest


BeginUpdateOrganizationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from theBeginUpdateOrganizationRequest.

The following tables list the members exposed by the BeginUpdateOrganizationResponse type.

Public Constructors

Name | Description
BeginUpdateOrganizationResponse | Initializes a new instance of the BeginUpdateOrganizationResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request. (inherited from DeferredOperationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BeginUpdateOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpdateOrganizationRequest


BeginUpdateOrganizationResponse Constructor
[image]

Initializes a new instance of the BeginUpdateOrganizationResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BeginUpdateOrganizationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpdateOrganizationResponse Class
BeginUpdateOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginUpdateOrganizationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BeginUpdateOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpdateOrganizationRequest


BeginUpdateOrganizationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request. (inherited from DeferredOperationResponse)

See Also

Reference

BeginUpdateOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpdateOrganizationRequest


BeginUpgradeOrganizationRequest Class
See Also Members
[image]

Contains the data that is needed to begin the asynchronous operation to upgrade an organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="BeginUpgradeOrganizationRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class BeginUpgradeOrganizationRequest
    Inherits DeferredOperationRequest

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="BeginUpgradeOrganizationRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class BeginUpgradeOrganizationRequest : DeferredOperationRequest

C++

J#

JScript

  Remarks
Pass an instance of this class to the Execute method, which returns an instance of BeginUpgradeOrganizationResponse.
You can use the Get-CrmOperationStatusWindows PowerShell command to check the status of this asynchronous request. Or, you can use the RetrieveRequest message using the OperationId property to set the InstanceTag property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest

                Microsoft.Xrm.Sdk.Deployment.DeferredOperationRequest
      Microsoft.Xrm.Sdk.Deployment.BeginUpgradeOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpgradeOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpgradeOrganizationResponse
Other Resources
Get-CrmOperationStatus


BeginUpgradeOrganizationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to begin the asynchronous operation to upgrade an organization.

The following tables list the members exposed by the BeginUpgradeOrganizationRequest type.

Public Constructors

Name | Description
BeginUpgradeOrganizationRequest | Initializes a new instance of the BeginUpgradeOrganizationRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Tag | Gets or sets the ID or the instance tag of the organization to upgrade. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BeginUpgradeOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpgradeOrganizationResponse

Other Resources

Get-CrmOperationStatus


BeginUpgradeOrganizationRequest Constructor
[image]

Initializes a new instance of the BeginUpgradeOrganizationRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BeginUpgradeOrganizationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpgradeOrganizationRequest Class
BeginUpgradeOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginUpgradeOrganizationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BeginUpgradeOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpgradeOrganizationResponse

Other Resources

Get-CrmOperationStatus


BeginUpgradeOrganizationRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Tag | Gets or sets the ID or the instance tag of the organization to upgrade. Required.

See Also

Reference

BeginUpgradeOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpgradeOrganizationResponse

Other Resources

Get-CrmOperationStatus


BeginUpgradeOrganizationRequest.Tag Property
[image]

Gets or sets the ID or the instance tag of the organization to upgrade. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property Tag As EntityInstanceId

C#
[DataMemberAttribute(IsRequired=true)]
public EntityInstanceId Tag { get; set; }

C++

J#

JScript

Property Value
Type: EntityInstanceId

The ID or the instance tag of the organization to upgrade.

  Remarks
You can get this value by retrieving the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpgradeOrganizationRequest Class
BeginUpgradeOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
InstanceTags


BeginUpgradeOrganizationResponse Class
See Also Members
[image]

Contains the response from theBeginUpgradeOrganizationRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="BeginUpgradeOrganizationResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class BeginUpgradeOrganizationResponse
    Inherits DeferredOperationResponse

C#
[DataContractAttribute(Name="BeginUpgradeOrganizationResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class BeginUpgradeOrganizationResponse : DeferredOperationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse

                Microsoft.Xrm.Sdk.Deployment.DeferredOperationResponse
      Microsoft.Xrm.Sdk.Deployment.BeginUpgradeOrganizationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpgradeOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpgradeOrganizationRequest


BeginUpgradeOrganizationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from theBeginUpgradeOrganizationRequest.

The following tables list the members exposed by the BeginUpgradeOrganizationResponse type.

Public Constructors

Name | Description
BeginUpgradeOrganizationResponse | Initializes a new instance of the BeginUpgradeOrganizationResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request. (inherited from DeferredOperationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BeginUpgradeOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpgradeOrganizationRequest


BeginUpgradeOrganizationResponse Constructor
[image]

Initializes a new instance of the BeginUpgradeOrganizationResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BeginUpgradeOrganizationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BeginUpgradeOrganizationResponse Class
BeginUpgradeOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


BeginUpgradeOrganizationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BeginUpgradeOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpgradeOrganizationRequest


BeginUpgradeOrganizationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request. (inherited from DeferredOperationResponse)

See Also

Reference

BeginUpgradeOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginUpgradeOrganizationRequest


Certificate Class
See Also Members
[image]

Contains information about a certificate.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="Certificate", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class Certificate
    Inherits DeploymentEntity

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="Certificate", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class Certificate : DeploymentEntity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentEntity
      Microsoft.Xrm.Sdk.Deployment.Certificate
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Certificate Members
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate Members
See Also Constructors Methods Properties
[image]

Contains information about a certificate.

The following tables list the members exposed by the Certificate type.

Public Constructors

Name | Description
Certificate | Initializes a new instance of the Certificate class.
Top

Public Properties

 | Name | Description
public property | CertificateType | Gets or sets the certificate type.
public property | Data | Gets or sets the certificate data.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | Id | Gets or sets the certificate ID.
public property | Name | Gets or sets the certificate name.
public property | StoreFindType | Gets or sets the store find type.
public property | StoreLocation | Gets or sets the store location.
public property | StoreName | Gets or sets the store name.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Certificate Class
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate Constructor
[image]

Initializes a new instance of the Certificate class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public Certificate ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Certificate Class
Certificate Members
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Certificate Class
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate Properties
[image]

Public Properties

 | Name | Description
public property | CertificateType | Gets or sets the certificate type.
public property | Data | Gets or sets the certificate data.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | Id | Gets or sets the certificate ID.
public property | Name | Gets or sets the certificate name.
public property | StoreFindType | Gets or sets the store find type.
public property | StoreLocation | Gets or sets the store location.
public property | StoreName | Gets or sets the store name.

See Also

Reference

Certificate Class
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate.CertificateType Property
[image]

Gets or sets the certificate type.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CertificateType As String

C#
[DataMemberAttribute]
public string CertificateType { get; set; }

C++

J#

JScript

Property Value
Type: String
The certificate type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Certificate Class
Certificate Members
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate.Data Property
[image]

Gets or sets the certificate data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Data As String

C#
[DataMemberAttribute]
public string Data { get; set; }

C++

J#

JScript

Property Value
Type: String
The certificate data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Certificate Class
Certificate Members
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate.Id Property
[image]

Gets or sets the certificate ID.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The certificate ID.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Certificate Class
Certificate Members
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate.Name Property
[image]

Gets or sets the certificate name.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Name As String

C#
[DataMemberAttribute]
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String
The certificate name.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Certificate Class
Certificate Members
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate.StoreFindType Property
[image]

Gets or sets the store find type.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property StoreFindType As String

C#
[DataMemberAttribute]
public string StoreFindType { get; set; }

C++

J#

JScript

Property Value
Type: String
The store find type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Certificate Class
Certificate Members
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate.StoreLocation Property
[image]

Gets or sets the store location.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property StoreLocation As String

C#
[DataMemberAttribute]
public string StoreLocation { get; set; }

C++

J#

JScript

Property Value
Type: String
The store location.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Certificate Class
Certificate Members
Microsoft.Xrm.Sdk.Deployment Namespace


Certificate.StoreName Property
[image]

Gets or sets the store name.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property StoreName As String

C#
[DataMemberAttribute]
public string StoreName { get; set; }

C++

J#

JScript

Property Value
Type: String
The store name.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Certificate Class
Certificate Members
Microsoft.Xrm.Sdk.Deployment Namespace


ClaimsSettings Class
See Also Example Members
[image]

Contains the settings for claims based authentication using Active Directory Federation Services 2.0 (AD FS 2.0).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="ClaimsSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class ClaimsSettings
    Inherits ClaimsSettingsBase

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="ClaimsSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class ClaimsSettings : ClaimsSettingsBase

C++

J#

JScript

  Example
    Copy Code
ClaimsSettings claimsSettings =
    (ClaimsSettings)deploymentService.Retrieve(DeploymentEntityType.ClaimsSettings, null);

//Disable Claims using SDK
claimsSettings.Enabled = false;
deploymentService.Update(claimsSettings);

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings

                Microsoft.Xrm.Sdk.Deployment.ClaimsSettingsBase
        Microsoft.Xrm.Sdk.Deployment.ClaimsSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
ClaimsSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use Deployment Entities and Deployment Configuration Settings
Active Directory and Claims-Based Authentication


ClaimsSettings Members
See Also Constructors Methods Properties
[image]

Contains the settings for claims based authentication using Active Directory Federation Services 2.0 (AD FS 2.0).

The following tables list the members exposed by the ClaimsSettings type.

Public Constructors

Name | Description
ClaimsSettings | Initializes a new instance of the ClaimsSettings class.
Top

Public Properties

 | Name | Description
public property | Enabled | Gets or sets whether the setting is enabled. (inherited from ClaimsSettingsBase)
public property | EncryptionCertificate | Gets or sets the encryption certificate. (inherited from ClaimsSettingsBase)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FederationMetadataUrl | Gets or sets the federation metadata URL. (inherited from ClaimsSettingsBase)
public property | FederationProviderType | Gets or sets the federation provider type. (inherited from ClaimsSettingsBase)
public property | SessionSecurityTokenLifetimeInHours | Gets or sets the session security token lifetime. (inherited from ClaimsSettingsBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ClaimsSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Active Directory and Claims-Based Authentication


ClaimsSettings Constructor
[image]

Initializes a new instance of the ClaimsSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ClaimsSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsSettings Class
ClaimsSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ClaimsSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ClaimsSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Active Directory and Claims-Based Authentication


ClaimsSettings Properties
[image]

Public Properties

 | Name | Description
public property | Enabled | Gets or sets whether the setting is enabled. (inherited from ClaimsSettingsBase)
public property | EncryptionCertificate | Gets or sets the encryption certificate. (inherited from ClaimsSettingsBase)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FederationMetadataUrl | Gets or sets the federation metadata URL. (inherited from ClaimsSettingsBase)
public property | FederationProviderType | Gets or sets the federation provider type. (inherited from ClaimsSettingsBase)
public property | SessionSecurityTokenLifetimeInHours | Gets or sets the session security token lifetime. (inherited from ClaimsSettingsBase)

See Also

Reference

ClaimsSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Active Directory and Claims-Based Authentication


ClaimsSettingsBase Class
See Also Members
[image]

Base class for claims settings types.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<KnownTypeAttribute(GetType(ClaimsSettings))> _
<DataContractAttribute(Name:="ClaimsSettingsBase", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<KnownTypeAttribute(GetType(OAuthClaimsSettings))> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class ClaimsSettingsBase
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[KnownTypeAttribute(typeof(ClaimsSettings))]
[DataContractAttribute(Name="ClaimsSettingsBase", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[KnownTypeAttribute(typeof(OAuthClaimsSettings))]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class ClaimsSettingsBase : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.ClaimsSettingsBase

                Microsoft.Xrm.Sdk.Deployment.ClaimsSettings

                Microsoft.Xrm.Sdk.Deployment.OAuthClaimsSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsSettingsBase Members
Microsoft.Xrm.Sdk.Deployment Namespace
OAuthClaimsSettings
Other Resources
Deployment Entities and Deployment Configuration Settings


ClaimsSettingsBase Members
See Also Constructors Methods Properties
[image]

Base class for claims settings types.

The following tables list the members exposed by the ClaimsSettingsBase type.

Public Constructors

Name | Description
ClaimsSettingsBase | Initializes a new instance of the ClaimsSettingsBase class.
Top

Public Properties

 | Name | Description
public property | Enabled | Gets or sets whether the setting is enabled.
public property | EncryptionCertificate | Gets or sets the encryption certificate.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FederationMetadataUrl | Gets or sets the federation metadata URL.
public property | FederationProviderType | Gets or sets the federation provider type.
public property | SessionSecurityTokenLifetimeInHours | Gets or sets the session security token lifetime.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ClaimsSettingsBase Class
Microsoft.Xrm.Sdk.Deployment Namespace
OAuthClaimsSettings

Other Resources

Deployment Entities and Deployment Configuration Settings


ClaimsSettingsBase Constructor
[image]

Initializes a new instance of the ClaimsSettingsBase class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ClaimsSettingsBase ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsSettingsBase Class
ClaimsSettingsBase Members
Microsoft.Xrm.Sdk.Deployment Namespace


ClaimsSettingsBase Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ClaimsSettingsBase Class
Microsoft.Xrm.Sdk.Deployment Namespace
OAuthClaimsSettings

Other Resources

Deployment Entities and Deployment Configuration Settings


ClaimsSettingsBase Properties
[image]

Public Properties

 | Name | Description
public property | Enabled | Gets or sets whether the setting is enabled.
public property | EncryptionCertificate | Gets or sets the encryption certificate.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FederationMetadataUrl | Gets or sets the federation metadata URL.
public property | FederationProviderType | Gets or sets the federation provider type.
public property | SessionSecurityTokenLifetimeInHours | Gets or sets the session security token lifetime.

See Also

Reference

ClaimsSettingsBase Class
Microsoft.Xrm.Sdk.Deployment Namespace
OAuthClaimsSettings

Other Resources

Deployment Entities and Deployment Configuration Settings


ClaimsSettingsBase.Enabled Property
[image]

Gets or sets whether the setting is enabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Enabled As Boolean

C#
[DataMemberAttribute]
public bool Enabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the setting is enabled; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsSettingsBase Class
ClaimsSettingsBase Members
Microsoft.Xrm.Sdk.Deployment Namespace


ClaimsSettingsBase.EncryptionCertificate Property
[image]

Gets or sets the encryption certificate.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EncryptionCertificate As String

C#
[DataMemberAttribute]
public string EncryptionCertificate { get; set; }

C++

J#

JScript

Property Value
Type: String
The encryption certificate.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsSettingsBase Class
ClaimsSettingsBase Members
Microsoft.Xrm.Sdk.Deployment Namespace


ClaimsSettingsBase.FederationMetadataUrl Property
[image]

Gets or sets the federation metadata URL.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FederationMetadataUrl As String

C#
[DataMemberAttribute]
public string FederationMetadataUrl { get; set; }

C++

J#

JScript

Property Value
Type: String
The federation metadata URL.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsSettingsBase Class
ClaimsSettingsBase Members
Microsoft.Xrm.Sdk.Deployment Namespace


ClaimsSettingsBase.FederationProviderType Property
[image]

Gets or sets the federation provider type.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FederationProviderType As Integer

C#
[DataMemberAttribute]
public int FederationProviderType { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The federation provider type: 0 = regular claims, 1 = OAuth.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsSettingsBase Class
ClaimsSettingsBase Members
Microsoft.Xrm.Sdk.Deployment Namespace


ClaimsSettingsBase.SessionSecurityTokenLifetimeInHours Property
[image]

Gets or sets the session security token lifetime.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SessionSecurityTokenLifetimeInHours As Integer

C#
[DataMemberAttribute]
public int SessionSecurityTokenLifetimeInHours { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The session security token lifetime. Specified as the number of hours since the security token was created..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsSettingsBase Class
ClaimsSettingsBase Members
Microsoft.Xrm.Sdk.Deployment Namespace


ConfigurationEntity Class
See Also Members
[image]

Contains attributes for a specific table in the configuration database.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ConfigurationEntity", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class ConfigurationEntity
    Inherits DeploymentObject

C#
[DataContractAttribute(Name="ConfigurationEntity", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class ConfigurationEntity : DeploymentObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject
    Microsoft.Xrm.Sdk.Deployment.ConfigurationEntity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConfigurationEntity Members
Microsoft.Xrm.Sdk.Deployment Namespace


ConfigurationEntity Members
See Also Constructors Methods Properties
[image]

Contains attributes for a specific table in the configuration database.

The following tables list the members exposed by the ConfigurationEntity type.

Public Constructors

Name | Description
ConfigurationEntity | Initializes a new instance of the ConfigurationEntity class.
Top

Public Properties

 | Name | Description
public property | Attributes | Gets or sets the collection of attribute values.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | Id | Gets or sets the ID of the configuration entity.
public property | LogicalName | Gets or sets the logical name of the configuration entity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConfigurationEntity Class
Microsoft.Xrm.Sdk.Deployment Namespace


ConfigurationEntity Constructor
[image]

Initializes a new instance of the ConfigurationEntity class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConfigurationEntity ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConfigurationEntity Class
ConfigurationEntity Members
Microsoft.Xrm.Sdk.Deployment Namespace


ConfigurationEntity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConfigurationEntity Class
Microsoft.Xrm.Sdk.Deployment Namespace


ConfigurationEntity Properties
[image]

Public Properties

 | Name | Description
public property | Attributes | Gets or sets the collection of attribute values.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | Id | Gets or sets the ID of the configuration entity.
public property | LogicalName | Gets or sets the logical name of the configuration entity.

See Also

Reference

ConfigurationEntity Class
Microsoft.Xrm.Sdk.Deployment Namespace


ConfigurationEntity.Attributes Property
[image]

Gets or sets the collection of attribute values.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property Attributes As AttributeCollection

C#
[DataMemberAttribute(IsRequired=true)]
public AttributeCollection Attributes { get; set; }

C++

J#

JScript

Property Value
Type: AttributeCollection
The collection of attribute values.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConfigurationEntity Class
ConfigurationEntity Members
Microsoft.Xrm.Sdk.Deployment Namespace


ConfigurationEntity.Id Property
[image]

Gets or sets the ID of the configuration entity.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the configuration entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConfigurationEntity Class
ConfigurationEntity Members
Microsoft.Xrm.Sdk.Deployment Namespace


ConfigurationEntity.LogicalName Property
[image]

Gets or sets the logical name of the configuration entity.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property LogicalName As String

C#
[DataMemberAttribute(IsRequired=true)]
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the configuration entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConfigurationEntity Class
ConfigurationEntity Members
Microsoft.Xrm.Sdk.Deployment Namespace


CustomCodeSettings Class
See Also Members
[image]

Server level settings that control use of custom code.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="CustomCodeSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class CustomCodeSettings
    Inherits DeploymentConfigSettings

C#
[DataContractAttribute(Name="CustomCodeSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class CustomCodeSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.CustomCodeSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CustomCodeSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use Deployment Entities and Deployment Configuration Settings


CustomCodeSettings Members
See Also Constructors Methods Properties
[image]

Server level settings that control use of custom code.

The following tables list the members exposed by the CustomCodeSettings type.

Public Constructors

Name | Description
CustomCodeSettings | Initializes a new instance of theCustomCodeSettings class.
Top

Public Properties

 | Name | Description
public property | AllowDeclarativeWorkflows | Gets or sets whether XAML workflows are allowed on the server.
public property | AllowExternalCode | Gets or sets whether plug-ins and custom workflow activities can be registered on the server.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CustomCodeSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


CustomCodeSettings Constructor
[image]

Initializes a new instance of the CustomCodeSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CustomCodeSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CustomCodeSettings Class
CustomCodeSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


CustomCodeSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CustomCodeSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


CustomCodeSettings Properties
[image]

Public Properties

 | Name | Description
public property | AllowDeclarativeWorkflows | Gets or sets whether XAML workflows are allowed on the server.
public property | AllowExternalCode | Gets or sets whether plug-ins and custom workflow activities can be registered on the server.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)

See Also

Reference

CustomCodeSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


CustomCodeSettings.AllowDeclarativeWorkflows Property
[image]

Gets or sets whether XAML workflows are allowed on the server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AllowDeclarativeWorkflows As Boolean

C#
[DataMemberAttribute]
public bool AllowDeclarativeWorkflows { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if XAML workflows are allowed on the server; otherwise, false.

  Remarks
You can also use Windows PowerShell to set this. For more information, see Enable or Disable XAML Workflows.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CustomCodeSettings Class
CustomCodeSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Custom XAML Workflows


CustomCodeSettings.AllowExternalCode Property
[image]

Gets or sets whether plug-ins and custom workflow activities can be registered on the server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AllowExternalCode As Boolean

C#
[DataMemberAttribute]
public bool AllowExternalCode { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the plug-ins and custom workflow activities can be registered on the server; otherwise, false.

  Remarks
You can also use Windows PowerShell to set this. For more information, see Enable or Disable Custom Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CustomCodeSettings Class
CustomCodeSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Custom Workflow Activities (Workflow Assemblies)


DashboardSettings Class
See Also Members
[image]

Server level dashboard settings.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="DashboardSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class DashboardSettings
    Inherits DeploymentConfigSettings

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="DashboardSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class DashboardSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
You can also use Windows PowerShell to get or set this value. For more information, see Set the Number of Dashboard Controls.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.DashboardSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DashboardSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Analyze Data with Dashboards


DashboardSettings Members
See Also Constructors Methods Properties
[image]

Server level dashboard settings.

The following tables list the members exposed by the DashboardSettings type.

Public Constructors

Name | Description
DashboardSettings | Initializes a new instance of the DashboardSettings class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MaximumControlsLimit | Gets or sets the maximum number of controls allowed on dashboards for the server.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DashboardSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Analyze Data with Dashboards


DashboardSettings Constructor
[image]

Initializes a new instance of the DashboardSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DashboardSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DashboardSettings Class
DashboardSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


DashboardSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DashboardSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Analyze Data with Dashboards


DashboardSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MaximumControlsLimit | Gets or sets the maximum number of controls allowed on dashboards for the server.

See Also

Reference

DashboardSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Analyze Data with Dashboards


DashboardSettings.MaximumControlsLimit Property
[image]

Gets or sets the maximum number of controls allowed on dashboards for the server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaximumControlsLimit As Integer

C#
[DataMemberAttribute]
public int MaximumControlsLimit { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The maximum number of controls allowed on dashboards for the server.

  Remarks
The maximum value is 20.
You can also use Windows PowerShell to get or set this value. For more information, see Set the Number of Dashboard Controls.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DashboardSettings Class
DashboardSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationError Class
See Also Members
[image]

Contains information about an error that occurred with a deferred operation.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DeferredOperationError", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class DeferredOperationError
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="DeferredOperationError", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class DeferredOperationError : IExtensibleDataObject

C++

J#

JScript

  Remarks
Used in the ProcessingError property.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Deployment.DeferredOperationError
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationError Members
Microsoft.Xrm.Sdk.Deployment Namespace
DeferredOperationStatus
BeginCreateOrganizationResponse
BeginUpdateOrganizationResponse


DeferredOperationError Members
See Also Constructors Methods Properties
[image]

Contains information about an error that occurred with a deferred operation.

The following tables list the members exposed by the DeferredOperationError type.

Public Constructors

Name | Description
DeferredOperationError | Initializes a new instance of the DeferredOperationError class.
Top

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the error code.
public property | ErrorDetails | Gets or sets the detailed error information.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Message | Gets or sets the error message.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeferredOperationError Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeferredOperationStatus
BeginCreateOrganizationResponse
BeginUpdateOrganizationResponse


DeferredOperationError Constructor
[image]

Initializes a new instance of the DeferredOperationError class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeferredOperationError ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationError Class
DeferredOperationError Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationError Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeferredOperationError Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeferredOperationStatus
BeginCreateOrganizationResponse
BeginUpdateOrganizationResponse


DeferredOperationError Properties
[image]

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the error code.
public property | ErrorDetails | Gets or sets the detailed error information.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Message | Gets or sets the error message.

See Also

Reference

DeferredOperationError Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeferredOperationStatus
BeginCreateOrganizationResponse
BeginUpdateOrganizationResponse


DeferredOperationError.ErrorCode Property
[image]

Gets or sets the error code.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorCode As Integer

C#
[DataMemberAttribute]
public int ErrorCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The error code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationError Class
DeferredOperationError Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationError.ErrorDetails Property
[image]

Gets or sets the detailed error information.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorDetails As ErrorDetailCollection

C#
[DataMemberAttribute]
public ErrorDetailCollection ErrorDetails { get; set; }

C++

J#

JScript

Property Value
Type: ErrorDetailCollection
The collection of error information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationError Class
DeferredOperationError Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationError.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationError Class
DeferredOperationError Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationError.Message Property
[image]

Gets or sets the error message.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Message As String

C#
[DataMemberAttribute]
public string Message { get; set; }

C++

J#

JScript

Property Value
Type: String
The error message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationError Class
DeferredOperationError Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationRequest Class
See Also Members
[image]

Base class for all asynchronous requests for the deployment Web service.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="DeferredOperationRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<KnownTypeAttribute(GetType(BeginImportOrganizationRequest))> _
<KnownTypeAttribute(GetType(BeginUpgradeOrganizationRequest))> _
<KnownTypeAttribute(GetType(BeginCreateOrganizationRequest))> _
<KnownTypeAttribute(GetType(BeginUpdateOrganizationRequest))> _
Public Class DeferredOperationRequest
    Inherits DeploymentServiceRequest

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="DeferredOperationRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[KnownTypeAttribute(typeof(BeginImportOrganizationRequest))]
[KnownTypeAttribute(typeof(BeginUpgradeOrganizationRequest))]
[KnownTypeAttribute(typeof(BeginCreateOrganizationRequest))]
[KnownTypeAttribute(typeof(BeginUpdateOrganizationRequest))]
public class DeferredOperationRequest : DeploymentServiceRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.DeferredOperationRequest

                Microsoft.Xrm.Sdk.Deployment.BeginCreateOrganizationRequest

                Microsoft.Xrm.Sdk.Deployment.BeginImportOrganizationRequest

                Microsoft.Xrm.Sdk.Deployment.BeginUpdateOrganizationRequest

                Microsoft.Xrm.Sdk.Deployment.BeginUpgradeOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationRequest
BeginUpdateOrganizationRequest
Other Resources
Deployment Web Service Messages


DeferredOperationRequest Members
See Also Constructors Methods Properties
[image]

Base class for all asynchronous requests for the deployment Web service.

The following tables list the members exposed by the DeferredOperationRequest type.

Public Constructors

Name | Description
DeferredOperationRequest | Initializes a new instance of theDeferredOperationRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeferredOperationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationRequest
BeginUpdateOrganizationRequest

Other Resources

Deployment Web Service Messages


DeferredOperationRequest Constructor
[image]

Initializes a new instance of the DeferredOperationRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeferredOperationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationRequest Class
DeferredOperationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeferredOperationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationRequest
BeginUpdateOrganizationRequest

Other Resources

Deployment Web Service Messages


DeferredOperationRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)

See Also

Reference

DeferredOperationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginCreateOrganizationRequest
BeginUpdateOrganizationRequest

Other Resources

Deployment Web Service Messages


DeferredOperationResponse Class
See Also Members
[image]

Base class for all asynchronous responses for the deployment Web service.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(BeginCreateOrganizationResponse))> _
<KnownTypeAttribute(GetType(BeginImportOrganizationResponse))> _
<KnownTypeAttribute(GetType(BeginUpdateOrganizationResponse))> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="DeferredOperationResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<KnownTypeAttribute(GetType(BeginUpgradeOrganizationResponse))> _
Public Class DeferredOperationResponse
    Inherits DeploymentServiceResponse

C#
[KnownTypeAttribute(typeof(BeginCreateOrganizationResponse))]
[KnownTypeAttribute(typeof(BeginImportOrganizationResponse))]
[KnownTypeAttribute(typeof(BeginUpdateOrganizationResponse))]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="DeferredOperationResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[KnownTypeAttribute(typeof(BeginUpgradeOrganizationResponse))]
public class DeferredOperationResponse : DeploymentServiceResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.DeferredOperationResponse

                Microsoft.Xrm.Sdk.Deployment.BeginCreateOrganizationResponse

                Microsoft.Xrm.Sdk.Deployment.BeginImportOrganizationResponse

                Microsoft.Xrm.Sdk.Deployment.BeginUpdateOrganizationResponse

                Microsoft.Xrm.Sdk.Deployment.BeginUpgradeOrganizationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages


DeferredOperationResponse Members
See Also Constructors Methods Properties
[image]

Base class for all asynchronous responses for the deployment Web service.

The following tables list the members exposed by the DeferredOperationResponse type.

Public Constructors

Name | Description
DeferredOperationResponse | Initializes a new instance of the DeferredOperationResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeferredOperationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages


DeferredOperationResponse Constructor
[image]

Initializes a new instance of the DeferredOperationResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeferredOperationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationResponse Class
DeferredOperationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeferredOperationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages


DeferredOperationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | OperationId | Gets the ID of the asynchronous request.

See Also

Reference

DeferredOperationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages


DeferredOperationResponse.OperationId Property
[image]

Gets the ID of the asynchronous request.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OperationId As Guid

C#
[DataMemberAttribute]
public Guid OperationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the asynchronous request.

  Remarks
You can use the Get-CrmOperationStatusWindows PowerShell command to check the status of this asynchronous request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationResponse Class
DeferredOperationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationState Enumeration
[image]

Describes the possible states for an asynchronous operation.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="DeferredOperationState", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Enumeration DeferredOperationState

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="DeferredOperationState", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public enum DeferredOperationState

C++

J#

JScript

  Members
Member name | Description
Completed | Specifies that the operation has completed. Value = 3.
Failed | Specifies that the operation has failed. Value = 4.
Processing | Specifies that the operation is in progress. Value = 2.
Queued | Specifies that the operation is queued but has not been started. Value = 1.
Unknown | Specifies that the operation state is unknown. Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace
State
Other Resources
Deployment Web Service Messages


DeferredOperationStatus Class
See Also Members
[image]

Contains information about the status of a deferred operation.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DeferredOperationStatus", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class DeferredOperationStatus
    Inherits DeploymentObject

C#
[DataContractAttribute(Name="DeferredOperationStatus", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class DeferredOperationStatus : DeploymentObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject
    Microsoft.Xrm.Sdk.Deployment.DeferredOperationStatus
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationStatus Members
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationRequest


DeferredOperationStatus Members
See Also Constructors Methods Properties
[image]

Contains information about the status of a deferred operation.

The following tables list the members exposed by the DeferredOperationStatus type.

Public Constructors

Name | Description
DeferredOperationStatus | Initializes a new instance of the DeferredOperationStatus class.
Top

Public Properties

 | Name | Description
public property | AssociatedEntityInstance | Gets or sets the ID of the deployment entity instance associated with this deferred operation.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | ProcessingCompletedTime | Gets or sets the time that the deferred operation processing completed.
public property | ProcessingError | Gets or sets the error information for the deferred operation.
public property | ProcessingStartTime | Gets or sets the time that the deferred operation processing started.
public property | State | Gets or sets the current state of the deferred operation.
public property | SubmissionTime | Gets or sets the time that the deferred operation processing was submitted.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeferredOperationStatus Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationRequest


DeferredOperationStatus Constructor
[image]

Initializes a new instance of the DeferredOperationStatus class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeferredOperationStatus ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationStatus Class
DeferredOperationStatus Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationStatus Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeferredOperationStatus Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationRequest


DeferredOperationStatus Properties
[image]

Public Properties

 | Name | Description
public property | AssociatedEntityInstance | Gets or sets the ID of the deployment entity instance associated with this deferred operation.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | ProcessingCompletedTime | Gets or sets the time that the deferred operation processing completed.
public property | ProcessingError | Gets or sets the error information for the deferred operation.
public property | ProcessingStartTime | Gets or sets the time that the deferred operation processing started.
public property | State | Gets or sets the current state of the deferred operation.
public property | SubmissionTime | Gets or sets the time that the deferred operation processing was submitted.

See Also

Reference

DeferredOperationStatus Class
Microsoft.Xrm.Sdk.Deployment Namespace
BeginImportOrganizationRequest


DeferredOperationStatus.AssociatedEntityInstance Property
[image]

Gets or sets the ID of the deployment entity instance associated with this deferred operation.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AssociatedEntityInstance As EntityInstanceId

C#
[DataMemberAttribute]
public EntityInstanceId AssociatedEntityInstance { get; set; }

C++

J#

JScript

Property Value
Type: EntityInstanceId
The ID of the deployment entity instance associated with this deferred operation.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationStatus Class
DeferredOperationStatus Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationStatus.ProcessingCompletedTime Property
[image]

Gets or sets the time that the deferred operation processing completed.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ProcessingCompletedTime As DateTime

C#
[DataMemberAttribute]
public DateTime ProcessingCompletedTime { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The time that the deferred operation processing completed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationStatus Class
DeferredOperationStatus Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationStatus.ProcessingError Property
[image]

Gets or sets the error information for the deferred operation.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ProcessingError As DeferredOperationError

C#
[DataMemberAttribute]
public DeferredOperationError ProcessingError { get; set; }

C++

J#

JScript

Property Value
Type: DeferredOperationError
The error information for the deferred operation.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationStatus Class
DeferredOperationStatus Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationStatus.ProcessingStartTime Property
[image]

Gets or sets the time that the deferred operation processing started.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ProcessingStartTime As DateTime

C#
[DataMemberAttribute]
public DateTime ProcessingStartTime { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The time that the deferred operation processing started.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationStatus Class
DeferredOperationStatus Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationStatus.State Property
[image]

Gets or sets the current state of the deferred operation.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property State As DeferredOperationState

C#
[DataMemberAttribute]
public DeferredOperationState State { get; set; }

C++

J#

JScript

Property Value
Type: DeferredOperationState
The current state of the deferred operation.

  Remarks
Check this value to see the current state of the process.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationStatus Class
DeferredOperationStatus Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeferredOperationStatus.SubmissionTime Property
[image]

Gets or sets the time that the deferred operation processing was submitted.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SubmissionTime As DateTime

C#
[DataMemberAttribute]
public DateTime SubmissionTime { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The time that the deferred operation processing was submitted.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeferredOperationStatus Class
DeferredOperationStatus Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteOrganizationRequest Class
See Also Members
[image]

Contains the data that is needed to delete a Microsoft Dynamics CRM organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DeleteOrganizationRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class DeleteOrganizationRequest
    Inherits DeleteRequest

C#
[DataContractAttribute(Name="DeleteOrganizationRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class DeleteOrganizationRequest : DeleteRequest

C++

J#

JScript

  Remarks
Usage
Pass an instance of this class to the Execute method, which returns an instance of the DeleteOrganizationResponse class.
Notes for Callers
You can also use the Remove-CrmOrganizationWindows PowerShell command. For more information, see Administer the deployment using Windows PowerShell.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest

                Microsoft.Xrm.Sdk.Deployment.DeleteRequest
      Microsoft.Xrm.Sdk.Deployment.DeleteOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteOrganizationResponse
Other Resources
Remove-CrmOrganization


DeleteOrganizationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete a Microsoft Dynamics CRM organization.

The following tables list the members exposed by the DeleteOrganizationRequest type.

Public Constructors

Name | Description
DeleteOrganizationRequest | Initializes a new instance of the DeleteOrganizationRequest class.
Top

Public Properties

 | Name | Description
public property | DetachDatabase | Gets or sets a value that indicates whether to detach the CRM database from the SQL Server instance.
public property | EntityType | Gets or sets the type of deployment entity to be deleted. (inherited from DeleteRequest)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | InstanceTag | Gets or sets the ID or the instance tag for the deployment record to be deleted. (inherited from DeleteRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteOrganizationResponse

Other Resources

Remove-CrmOrganization


DeleteOrganizationRequest Constructor
[image]

Initializes a new instance of the DeleteOrganizationRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteOrganizationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteOrganizationRequest Class
DeleteOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteOrganizationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteOrganizationResponse

Other Resources

Remove-CrmOrganization


DeleteOrganizationRequest Properties
[image]

Public Properties

 | Name | Description
public property | DetachDatabase | Gets or sets a value that indicates whether to detach the CRM database from the SQL Server instance.
public property | EntityType | Gets or sets the type of deployment entity to be deleted. (inherited from DeleteRequest)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | InstanceTag | Gets or sets the ID or the instance tag for the deployment record to be deleted. (inherited from DeleteRequest)

See Also

Reference

DeleteOrganizationRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteOrganizationResponse

Other Resources

Remove-CrmOrganization


DeleteOrganizationRequest.DetachDatabase Property
[image]

Gets or sets a value that indicates whether to detach the CRM database from the SQL Server instance.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DetachDatabase As Boolean

C#
[DataMemberAttribute]
public bool DetachDatabase { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Indicates whether to detach the CRM database from the SQL Server instance.
true to detach the database, otherwise, false.

  Remarks
This only removes the database from your deployment; it does not delete the physical database on the server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteOrganizationRequest Class
DeleteOrganizationRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteOrganizationResponse Class
See Also Members
[image]

Contains the response from DeleteOrganizationRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DeleteOrganizationResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class DeleteOrganizationResponse
    Inherits DeleteResponse

C#
[DataContractAttribute(Name="DeleteOrganizationResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class DeleteOrganizationResponse : DeleteResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse

                Microsoft.Xrm.Sdk.Deployment.DeleteResponse
      Microsoft.Xrm.Sdk.Deployment.DeleteOrganizationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteOrganizationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from DeleteOrganizationRequest.

The following tables list the members exposed by the DeleteOrganizationResponse type.

Public Constructors

Name | Description
DeleteOrganizationResponse | Initializes a new instance of the DeleteOrganizationResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteOrganizationResponse Constructor
[image]

Initializes a new instance of the DeleteOrganizationResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteOrganizationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteOrganizationResponse Class
DeleteOrganizationResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteOrganizationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteOrganizationResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)

See Also

Reference

DeleteOrganizationResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteRequest Class
See Also Example Members
[image]

Contains the data that is needed to delete a deployment record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="DeleteRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<KnownTypeAttribute(GetType(DeleteOrganizationRequest))> _
<DebuggerStepThroughAttribute> _
Public Class DeleteRequest
    Inherits DeploymentServiceRequest

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="DeleteRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[KnownTypeAttribute(typeof(DeleteOrganizationRequest))]
[DebuggerStepThroughAttribute]
public class DeleteRequest : DeploymentServiceRequest

C++

J#

JScript

  Example
The following code shows how to delete an organization.
    Copy Code
using (DeploymentServiceClient client = new DeploymentServiceClient("CustomBinding_IDeploymentService"))
{
    EntityInstanceId id = new EntityInstanceId
    {
        Name = "AlpineSkiHouse2"
    };

    // disable the organization
    Organization organization = (Organization)client.Retrieve(DeploymentEntityType.Organization, id);
    organization.State = OrganizationState.Disabled;
    client.Update(organization);

    // delete the organization
    DeleteRequest request = new DeleteRequest
    {
        EntityType = DeploymentEntityType.Organization,
        InstanceTag = id
    };
    DeleteResponse response = (DeleteResponse)client.Execute(request);

    client.Close();
}

  Remarks
Pass an instance of this class to the  Execute method, which returns an instance of  DeleteResponse.
Note that this is the Deployment Web Service. To delete organization data records in Microsoft Dynamics CRM, use DeleteRequest.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.DeleteRequest

                Microsoft.Xrm.Sdk.Deployment.DeleteOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
DeleteRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteResponse
Other Resources
Introduction to the Deployment Web Service


DeleteRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete a deployment record.

The following tables list the members exposed by the DeleteRequest type.

Public Constructors

Name | Description
DeleteRequest | Initializes a new instance of the DeleteRequest class.
Top

Public Properties

 | Name | Description
public property | EntityType | Gets or sets the type of deployment entity to be deleted.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | InstanceTag | Gets or sets the ID or the instance tag for the deployment record to be deleted.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteResponse

Other Resources

Introduction to the Deployment Web Service


DeleteRequest Constructor
[image]

Initializes a new instance of the DeleteRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteRequest Class
DeleteRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteResponse

Other Resources

Introduction to the Deployment Web Service


DeleteRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityType | Gets or sets the type of deployment entity to be deleted.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | InstanceTag | Gets or sets the ID or the instance tag for the deployment record to be deleted.

See Also

Reference

DeleteRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteResponse

Other Resources

Introduction to the Deployment Web Service


DeleteRequest.EntityType Property
[image]

Gets or sets the type of deployment entity to be deleted.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property EntityType As DeploymentEntityType

C#
[DataMemberAttribute(IsRequired=true)]
public DeploymentEntityType EntityType { get; set; }

C++

J#

JScript

Property Value
Type: DeploymentEntityType
the type of deployment entity to be deleted.

  Remarks
The deployment type must match the record specified by the InstanceTag property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteRequest Class
DeleteRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteRequest.InstanceTag Property
[image]

Gets or sets the ID or the instance tag for the deployment record to be deleted.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property InstanceTag As EntityInstanceId

C#
[DataMemberAttribute]
public EntityInstanceId InstanceTag { get; set; }

C++

J#

JScript

Property Value
Type: EntityInstanceId
The ID or the instance tag for the deployment record to be deleted.

  Remarks
The deployment type specified by the EntityType property must match the entity type for this record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteRequest Class
DeleteRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteResponse Class
See Also Members
[image]

Contains the response from the DeleteRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(DeleteOrganizationResponse))> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="DeleteResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class DeleteResponse
    Inherits DeploymentServiceResponse

C#
[KnownTypeAttribute(typeof(DeleteOrganizationResponse))]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="DeleteResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class DeleteResponse : DeploymentServiceResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.DeleteResponse

                Microsoft.Xrm.Sdk.Deployment.DeleteOrganizationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteRequest


DeleteResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeleteRequest.

The following tables list the members exposed by the DeleteResponse type.

Public Constructors

Name | Description
DeleteResponse | Initializes a new instance of the DeleteResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteRequest


DeleteResponse Constructor
[image]

Initializes a new instance of the DeleteResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeleteResponse Class
DeleteResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeleteResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteRequest


DeleteResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)

See Also

Reference

DeleteResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteRequest


DeploymentAdministrator Class
See Also Members
[image]

Contains information about a deployment administrator in a Microsoft Dynamics CRM deployment.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DeploymentAdministrator", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class DeploymentAdministrator
    Inherits DeploymentEntity

C#
[DataContractAttribute(Name="DeploymentAdministrator", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class DeploymentAdministrator : DeploymentEntity

C++

J#

JScript

  Remarks
There can be multiple deployment administrators per deployment. You can also use Windows PowerShell to access the deployment administrator information.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentEntity
      Microsoft.Xrm.Sdk.Deployment.DeploymentAdministrator
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentAdministrator Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


DeploymentAdministrator Members
See Also Constructors Methods Properties
[image]

Contains information about a deployment administrator in a Microsoft Dynamics CRM deployment.

The following tables list the members exposed by the DeploymentAdministrator type.

Public Constructors

Name | Description
DeploymentAdministrator | Initializes a new instance of the DeploymentAdministrator class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | Id | Gets the ID of the deployment administrator.
public property | Name | Gets or sets the domain name and user ID of the deployment administrator.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeploymentAdministrator Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


DeploymentAdministrator Constructor
[image]

Initializes a new instance of the DeploymentAdministrator class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeploymentAdministrator ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentAdministrator Class
DeploymentAdministrator Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentAdministrator Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeploymentAdministrator Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


DeploymentAdministrator Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | Id | Gets the ID of the deployment administrator.
public property | Name | Gets or sets the domain name and user ID of the deployment administrator.

See Also

Reference

DeploymentAdministrator Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


DeploymentAdministrator.Id Property
[image]

Gets the ID of the deployment administrator.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the deployment administrator.

  Remarks
This property is assigned a value when the record is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentAdministrator Class
DeploymentAdministrator Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentAdministrator.Name Property
[image]

Gets or sets the domain name and user ID of the deployment administrator.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Name As String

C#
[DataMemberAttribute]
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String

The domain name and user ID of the deployment administrator.

  Remarks
The format of this string is domain\userid. The user must exist in Active Directory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentAdministrator Class
DeploymentAdministrator Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentConfigSettings Class
See Also Members
[image]

Base class for configuration settings entities.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(MonitoringSettings))> _
<KnownTypeAttribute(GetType(ServerSideSyncQueueSettings))> _
<KnownTypeAttribute(GetType(TraceSettings))> _
<KnownTypeAttribute(GetType(MarketplaceSettings))> _
<KnownTypeAttribute(GetType(CustomCodeSettings))> _
<KnownTypeAttribute(GetType(YammerSettings))> _
<KnownTypeAttribute(GetType(TeamSettings))> _
<KnownTypeAttribute(GetType(MultiEntityQuickFindSettings))> _
<KnownTypeAttribute(GetType(AsyncSettings))> _
<KnownTypeAttribute(GetType(ClaimsSettingsBase))> _
<KnownTypeAttribute(GetType(ClaimsSettings))> _
<KnownTypeAttribute(GetType(OAuthClaimsSettings))> _
<KnownTypeAttribute(GetType(ThrottleSettings))> _
<KnownTypeAttribute(GetType(WorkflowSettings))> _
<KnownTypeAttribute(GetType(IfdSettings))> _
<KnownTypeAttribute(GetType(DashboardSettings))> _
<KnownTypeAttribute(GetType(DupSettings))> _
<KnownTypeAttribute(GetType(EtmSettings))> _
<KnownTypeAttribute(GetType(ImportSettings))> _
<KnownTypeAttribute(GetType(ServerSideSyncACTSettings))> _
<KnownTypeAttribute(GetType(ServerSideSyncEmailSettings))> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="DeploymentConfigSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<KnownTypeAttribute(GetType(QuickFindSettings))> _
<KnownTypeAttribute(GetType(WebAddressSettings))> _
<KnownTypeAttribute(GetType(SqmSettings))> _
Public Class DeploymentConfigSettings
    Inherits DeploymentObject

C#
[KnownTypeAttribute(typeof(MonitoringSettings))]
[KnownTypeAttribute(typeof(ServerSideSyncQueueSettings))]
[KnownTypeAttribute(typeof(TraceSettings))]
[KnownTypeAttribute(typeof(MarketplaceSettings))]
[KnownTypeAttribute(typeof(CustomCodeSettings))]
[KnownTypeAttribute(typeof(YammerSettings))]
[KnownTypeAttribute(typeof(TeamSettings))]
[KnownTypeAttribute(typeof(MultiEntityQuickFindSettings))]
[KnownTypeAttribute(typeof(AsyncSettings))]
[KnownTypeAttribute(typeof(ClaimsSettingsBase))]
[KnownTypeAttribute(typeof(ClaimsSettings))]
[KnownTypeAttribute(typeof(OAuthClaimsSettings))]
[KnownTypeAttribute(typeof(ThrottleSettings))]
[KnownTypeAttribute(typeof(WorkflowSettings))]
[KnownTypeAttribute(typeof(IfdSettings))]
[KnownTypeAttribute(typeof(DashboardSettings))]
[KnownTypeAttribute(typeof(DupSettings))]
[KnownTypeAttribute(typeof(EtmSettings))]
[KnownTypeAttribute(typeof(ImportSettings))]
[KnownTypeAttribute(typeof(ServerSideSyncACTSettings))]
[KnownTypeAttribute(typeof(ServerSideSyncEmailSettings))]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="DeploymentConfigSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[KnownTypeAttribute(typeof(QuickFindSettings))]
[KnownTypeAttribute(typeof(WebAddressSettings))]
[KnownTypeAttribute(typeof(SqmSettings))]
public class DeploymentConfigSettings : DeploymentObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject
    Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings

                Derived Classes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentConfigSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use Deployment Entities and Deployment Configuration Settings


DeploymentConfigSettings Members
See Also Constructors Methods Properties
[image]

Base class for configuration settings entities.

The following tables list the members exposed by the DeploymentConfigSettings type.

Public Constructors

Name | Description
DeploymentConfigSettings | Initializes a new instance of theDeploymentConfigSettings class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeploymentConfigSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


DeploymentConfigSettings Constructor
[image]

Initializes a new instance of the DeploymentConfigSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeploymentConfigSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentConfigSettings Class
DeploymentConfigSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentConfigSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeploymentConfigSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


DeploymentConfigSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)

See Also

Reference

DeploymentConfigSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


DeploymentEntity Class
See Also Members
[image]

Base class for deployment entities.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(Certificate))> _
<KnownTypeAttribute(GetType(DeploymentAdministrator))> _
<DataContractAttribute(Name:="DeploymentEntity", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<KnownTypeAttribute(GetType(LicenseProperties))> _
<KnownTypeAttribute(GetType(Server))> _
<KnownTypeAttribute(GetType(Organization))> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class DeploymentEntity
    Inherits DeploymentObject

C#
[KnownTypeAttribute(typeof(Certificate))]
[KnownTypeAttribute(typeof(DeploymentAdministrator))]
[DataContractAttribute(Name="DeploymentEntity", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[KnownTypeAttribute(typeof(LicenseProperties))]
[KnownTypeAttribute(typeof(Server))]
[KnownTypeAttribute(typeof(Organization))]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class DeploymentEntity : DeploymentObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject
    Microsoft.Xrm.Sdk.Deployment.DeploymentEntity

                Microsoft.Xrm.Sdk.Deployment.Certificate

                Microsoft.Xrm.Sdk.Deployment.DeploymentAdministrator

                Microsoft.Xrm.Sdk.Deployment.LicenseProperties

                Microsoft.Xrm.Sdk.Deployment.Organization

                Microsoft.Xrm.Sdk.Deployment.Server
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentEntity Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use Deployment Entities and Deployment Configuration Settings


DeploymentEntity Members
See Also Constructors Methods Properties
[image]

Base class for deployment entities.

The following tables list the members exposed by the DeploymentEntity type.

Public Constructors

Name | Description
DeploymentEntity | Initializes a new instance of the DeploymentEntity class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeploymentEntity Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


DeploymentEntity Constructor
[image]

Initializes a new instance of the DeploymentEntity class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeploymentEntity ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentEntity Class
DeploymentEntity Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentEntity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeploymentEntity Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


DeploymentEntity Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)

See Also

Reference

DeploymentEntity Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


DeploymentEntityType Enumeration
[image]

Describes the type of deployment entity.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DeploymentEntityType", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Enumeration DeploymentEntityType

C#
[DataContractAttribute(Name="DeploymentEntityType", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public enum DeploymentEntityType

C++

J#

JScript

  Members
Member name | Description
AsyncSettings | The asynchronous settings entity. Value = 0.
Certificate | The certificate entity. Value = 18.
ClaimsSettings | The claims settings entity. Value = 1.
CustomCodeSettings | The custom code settings entity. Value = 14.
DashboardSettings | The dashboard settings entity. Value = 3.
DeferredOperationStatus | The deferred operation status entity. Value = 23.
DeploymentAdministrator | The deployment administrator entity. Value = 19.
DupSettings | The duplicate detection settings entity. Value = 4.
EtmSettings | The ETM settings entity. Value = 5.
IfdSettings | The Internet-facing deployment (IFD) settings entity. Value = 6.
ImportSettings | The data import settings entity. Value = 7.
LicenseProperties | The license properties entity. Value = 22.
MarketplaceSettings | The marketplace settings entity. Value = 13.
MonitoringSettings | The monitoring settings entity. Value = 24.
MultiEntityQuickFindSettings | The multi-entity quick find settings entity. Value = 16.
OAuthClaimsSettings | The OAuth claims settings entity. Value = 2.
Organization | The organization entity. Value = 21.
QuickFindSettings | The quick find settings entity. Value = 17.
Server | The server entity. Value = 20.
ServerSideSyncACTSettings | The server side synchronization ACT settings entity. Value = 28.
ServerSideSyncEmailSettings | The server side synchronization email settings entity. Value = 26.
ServerSideSyncQueueSettings | The server side synchronization queue settings entity. Value = 27.
SqmSettings | The service quality metrics (SQM) settings entity. Value = 12.
TeamSettings | The team settings entity. Value = 15.
ThrottleSettings | The throttle settings entity. Value = 8.
TraceSettings | The trace settings entity. Value = 9.
WebAddressSettings | The web address settings entity. Value = 10.
WorkflowSettings | The workflow settings entity. Value = 11.
YammerSettings | The Yammer settings entity. Value = 25.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace
Retrieve
Delete
RetrieveAll
EntityType
EntityType
EntityType


DeploymentErrorLevel Enumeration
[image]

Contains information about an error with the deployment web service.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="DeploymentErrorLevel", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Enumeration DeploymentErrorLevel

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="DeploymentErrorLevel", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public enum DeploymentErrorLevel

C++

J#

JScript

  Members
Member name | Description
Error | An error occurred. Value = 4.
Info | Information about the operation. Value = 1.
Skipped | An operation was skipped. Value = 2.
Success | The operation succeeded. Value = 0.
Warning | A warning about the operation. Value = 3.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentObject Class
See Also Members
[image]

Base class for deployment Web service entities and settings.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(MultiEntityQuickFindSettings))> _
<KnownTypeAttribute(GetType(QuickFindSettings))> _
<KnownTypeAttribute(GetType(WebAddressSettings))> _
<KnownTypeAttribute(GetType(SqmSettings))> _
<KnownTypeAttribute(GetType(DeploymentConfigSettings))> _
<KnownTypeAttribute(GetType(ServerSideSyncQueueSettings))> _
<KnownTypeAttribute(GetType(ServerSideSyncACTSettings))> _
<KnownTypeAttribute(GetType(TraceSettings))> _
<KnownTypeAttribute(GetType(MonitoringSettings))> _
<KnownTypeAttribute(GetType(CustomCodeSettings))> _
<KnownTypeAttribute(GetType(YammerSettings))> _
<KnownTypeAttribute(GetType(TeamSettings))> _
<KnownTypeAttribute(GetType(AsyncSettings))> _
<KnownTypeAttribute(GetType(ClaimsSettingsBase))> _
<KnownTypeAttribute(GetType(DeploymentAdministrator))> _
<KnownTypeAttribute(GetType(OAuthClaimsSettings))> _
<KnownTypeAttribute(GetType(ThrottleSettings))> _
<KnownTypeAttribute(GetType(WorkflowSettings))> _
<KnownTypeAttribute(GetType(ServerSideSyncEmailSettings))> _
<KnownTypeAttribute(GetType(MarketplaceSettings))> _
<KnownTypeAttribute(GetType(DashboardSettings))> _
<KnownTypeAttribute(GetType(DupSettings))> _
<KnownTypeAttribute(GetType(EtmSettings))> _
<KnownTypeAttribute(GetType(ImportSettings))> _
<KnownTypeAttribute(GetType(DeferredOperationStatus))> _
<KnownTypeAttribute(GetType(IfdSettings))> _
<KnownTypeAttribute(GetType(ClaimsSettings))> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="DeploymentObject", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<KnownTypeAttribute(GetType(RequestCheckResult))> _
<KnownTypeAttribute(GetType(ConfigurationEntity))> _
<KnownTypeAttribute(GetType(DeploymentEntity))> _
<KnownTypeAttribute(GetType(Certificate))> _
<KnownTypeAttribute(GetType(Organization))> _
<KnownTypeAttribute(GetType(LicenseProperties))> _
<KnownTypeAttribute(GetType(Server))> _
Public Class DeploymentObject
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute(typeof(MultiEntityQuickFindSettings))]
[KnownTypeAttribute(typeof(QuickFindSettings))]
[KnownTypeAttribute(typeof(WebAddressSettings))]
[KnownTypeAttribute(typeof(SqmSettings))]
[KnownTypeAttribute(typeof(DeploymentConfigSettings))]
[KnownTypeAttribute(typeof(ServerSideSyncQueueSettings))]
[KnownTypeAttribute(typeof(ServerSideSyncACTSettings))]
[KnownTypeAttribute(typeof(TraceSettings))]
[KnownTypeAttribute(typeof(MonitoringSettings))]
[KnownTypeAttribute(typeof(CustomCodeSettings))]
[KnownTypeAttribute(typeof(YammerSettings))]
[KnownTypeAttribute(typeof(TeamSettings))]
[KnownTypeAttribute(typeof(AsyncSettings))]
[KnownTypeAttribute(typeof(ClaimsSettingsBase))]
[KnownTypeAttribute(typeof(DeploymentAdministrator))]
[KnownTypeAttribute(typeof(OAuthClaimsSettings))]
[KnownTypeAttribute(typeof(ThrottleSettings))]
[KnownTypeAttribute(typeof(WorkflowSettings))]
[KnownTypeAttribute(typeof(ServerSideSyncEmailSettings))]
[KnownTypeAttribute(typeof(MarketplaceSettings))]
[KnownTypeAttribute(typeof(DashboardSettings))]
[KnownTypeAttribute(typeof(DupSettings))]
[KnownTypeAttribute(typeof(EtmSettings))]
[KnownTypeAttribute(typeof(ImportSettings))]
[KnownTypeAttribute(typeof(DeferredOperationStatus))]
[KnownTypeAttribute(typeof(IfdSettings))]
[KnownTypeAttribute(typeof(ClaimsSettings))]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="DeploymentObject", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[KnownTypeAttribute(typeof(RequestCheckResult))]
[KnownTypeAttribute(typeof(ConfigurationEntity))]
[KnownTypeAttribute(typeof(DeploymentEntity))]
[KnownTypeAttribute(typeof(Certificate))]
[KnownTypeAttribute(typeof(Organization))]
[KnownTypeAttribute(typeof(LicenseProperties))]
[KnownTypeAttribute(typeof(Server))]
public class DeploymentObject : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.ConfigurationEntity

                Microsoft.Xrm.Sdk.Deployment.DeferredOperationStatus

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings

                Microsoft.Xrm.Sdk.Deployment.DeploymentEntity

                Microsoft.Xrm.Sdk.Deployment.RequestCheckResult
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentObject Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentObject Members
See Also Constructors Methods Properties
[image]

Base class for deployment Web service entities and settings.

The following tables list the members exposed by the DeploymentObject type.

Public Constructors

Name | Description
DeploymentObject | Initializes a new instance of the DeploymentObject class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeploymentObject Class
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentObject Constructor
[image]

Initializes a new instance of the DeploymentObject class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeploymentObject ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentObject Class
DeploymentObject Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentObject Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeploymentObject Class
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentObject Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

DeploymentObject Class
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentObject.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
DeploymentObject
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentObject Class
DeploymentObject Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceClient Class
See Also Members
[image]

Implements IDeploymentService interface and provides an authenticated WCF channel to the deployment service..

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.ServiceModel", "4.0.0.0")> _
Public Class DeploymentServiceClient
    Inherits ClientBase(Of IDeploymentService)
    Implements IDeploymentService

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.ServiceModel", "4.0.0.0")]
public class DeploymentServiceClient : ClientBase<IDeploymentService>, IDeploymentService

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.ServiceModel.ClientBase
    Microsoft.Xrm.Sdk.Deployment.DeploymentServiceClient
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace
IDeploymentService
Other Resources
Introduction to the Deployment Web Service


DeploymentServiceClient Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Implements IDeploymentService interface and provides an authenticated WCF channel to the deployment service..

The following tables list the members exposed by the DeploymentServiceClient type.

Public Constructors

Name | Description
DeploymentServiceClient | Overloaded. Initializes a new instance of the DeploymentServiceClient class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ChannelFactory | (inherited from ClientBase)
public property | ClientCredentials | (inherited from ClientBase)
public property | Endpoint | (inherited from ClientBase)
public property | InnerChannel | (inherited from ClientBase)
public property | State | (inherited from ClientBase)
Top

Protected Properties

 | Name | Description
protected property | Channel | (inherited from ClientBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | (inherited from ClientBase)
public method | Close | (inherited from ClientBase)
public method | Delete | Deletes a deployment record.
public method | DisplayInitializationUI | (inherited from ClientBase)
public method | Equals | (inherited from Object)
public method | Execute | Executes a deployment service message in the form of a request, and returns a response.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | (inherited from ClientBase)
public method | Retrieve | Retrieves a deployment record.
public method | RetrieveAll | Retrieves all deployment records for the specified deployment entity type.
public method | ToString | (inherited from Object)
public method | Update | Updates a deployment record.
Top

Protected Methods

 | Name | Description
protected method | CreateChannel | (inherited from ClientBase)
protected method | Finalize | (inherited from Object)
protected method | GetDefaultValueForInitialization | (inherited from ClientBase)
protected method | InvokeAsync | (inherited from ClientBase)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Dispose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
Close | (inherited from ClientBase)
EndClose | (inherited from ClientBase)
EndOpen | (inherited from ClientBase)
Open | (inherited from ClientBase)
Closed | (inherited from ClientBase)
Closing | (inherited from ClientBase)
Faulted | (inherited from ClientBase)
Opened | (inherited from ClientBase)
Opening | (inherited from ClientBase)
Top

See Also

Reference

DeploymentServiceClient Class
Microsoft.Xrm.Sdk.Deployment Namespace
IDeploymentService

Other Resources

Introduction to the Deployment Web Service


DeploymentServiceClient Constructor
[image]

Initializes a new instance of the DeploymentServiceClient class.

Overload List

Name | Description
DeploymentServiceClient () | Initializes a new instance of the DeploymentServiceClient class.
DeploymentServiceClient (Binding, EndpointAddress) | Initializes a new instance of the DeploymentServiceClient class.
DeploymentServiceClient (String) | Initializes a new instance of the DeploymentServiceClient class.
DeploymentServiceClient (String, EndpointAddress) | Initializes a new instance of the DeploymentServiceClient class.
DeploymentServiceClient (String, String) | Initializes a new instance of the DeploymentServiceClient class.

See Also

Reference

DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceClient Constructor ()
[image]

Initializes a new instance of the DeploymentServiceClient class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeploymentServiceClient ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceClient Constructor (Binding, EndpointAddress)
[image]

Initializes a new instance of the DeploymentServiceClient class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    binding As Binding, _
    remoteAddress As EndpointAddress _
)

C#
public DeploymentServiceClient (
    Binding binding,
    EndpointAddress remoteAddress
)

C++

J#

JScript

Parameters
binding
Type: Binding. The binding.
remoteAddress
Type: EndpointAddress. The address of the remote endpoint.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceClient Constructor (String)
[image]

Initializes a new instance of the DeploymentServiceClient class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    endpointConfigurationName As String _
)

C#
public DeploymentServiceClient (
    string endpointConfigurationName
)

C++

J#

JScript

Parameters
endpointConfigurationName
Type: String. The name of the endpoint configuration.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceClient Constructor (String, EndpointAddress)
[image]

Initializes a new instance of the DeploymentServiceClient class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As EndpointAddress _
)

C#
public DeploymentServiceClient (
    string endpointConfigurationName,
    EndpointAddress remoteAddress
)

C++

J#

JScript

Parameters
endpointConfigurationName
Type: String. The name of the endpoint configuration.
remoteAddress
Type: EndpointAddress. The address of the remote endpoint.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceClient Constructor (String, String)
[image]

Initializes a new instance of the DeploymentServiceClient class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As String _
)

C#
public DeploymentServiceClient (
    string endpointConfigurationName,
    string remoteAddress
)

C++

J#

JScript

Parameters
endpointConfigurationName
Type: String. The name of the endpoint configuration.
remoteAddress
Type: String. The address of the remote endpoint.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceClient Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | (inherited from ClientBase)
public method | Close | (inherited from ClientBase)
public method | Delete | Deletes a deployment record.
public method | DisplayInitializationUI | (inherited from ClientBase)
public method | Equals | (inherited from Object)
public method | Execute | Executes a deployment service message in the form of a request, and returns a response.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | (inherited from ClientBase)
public method | Retrieve | Retrieves a deployment record.
public method | RetrieveAll | Retrieves all deployment records for the specified deployment entity type.
public method | ToString | (inherited from Object)
public method | Update | Updates a deployment record.

Protected Methods

 | Name | Description
protected method | CreateChannel | (inherited from ClientBase)
protected method | Finalize | (inherited from Object)
protected method | GetDefaultValueForInitialization | (inherited from ClientBase)
protected method | InvokeAsync | (inherited from ClientBase)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
Dispose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
Close | (inherited from ClientBase)
EndClose | (inherited from ClientBase)
EndOpen | (inherited from ClientBase)
Open | (inherited from ClientBase)

See Also

Reference

DeploymentServiceClient Class
Microsoft.Xrm.Sdk.Deployment Namespace
IDeploymentService

Other Resources

Introduction to the Deployment Web Service


DeploymentServiceClient.Delete Method
[image]

Deletes a deployment record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Delete ( _
    entityType As DeploymentEntityType, _
    id As EntityInstanceId _
)

C#
public void Delete (
    DeploymentEntityType entityType,
    EntityInstanceId id
)

C++

J#

JScript

Parameters
entityType
Type: DeploymentEntityType. The type of deployment entity specified by the id parameter.
id
Type: EntityInstanceId. The ID of the deployment record to delete.
  Remarks
The ID of a deployment record is also referred to as an instance tag.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace
Delete
DeleteRequest
DeploymentEntityType
Other Resources
Use Deployment Entities and Deployment Configuration Settings


DeploymentServiceClient.Execute Method
[image]

Executes a deployment service message in the form of a request, and returns a response.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Execute ( _
    request As DeploymentServiceRequest _
) As DeploymentServiceResponse

C#
public DeploymentServiceResponse Execute (
    DeploymentServiceRequest request
)

C++

J#

JScript

Parameters
request
Type: DeploymentServiceRequest. A request instance that defines the action to be performed.
Return Value
Type: DeploymentServiceResponse

The response from the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use Deployment Entities and Deployment Configuration Settings


DeploymentServiceClient.Retrieve Method
[image]

Retrieves a deployment record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Retrieve ( _
    entityType As DeploymentEntityType, _
    id As EntityInstanceId _
) As DeploymentObject

C#
public DeploymentObject Retrieve (
    DeploymentEntityType entityType,
    EntityInstanceId id
)

C++

J#

JScript

Parameters
entityType
Type: DeploymentEntityType. The type of deployment entity specified by the id parameter.
id
Type: EntityInstanceId. The ID of the deployment record to retrieve.
Return Value
Type: DeploymentObject
The deployment record.

  Remarks
The ID of a deployment record is also referred to as an instance tag.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace
Retrieve
RetrieveRequest
DeploymentEntityType
Other Resources
Use Deployment Entities and Deployment Configuration Settings


DeploymentServiceClient.RetrieveAll Method
[image]

Retrieves all deployment records for the specified deployment entity type.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function RetrieveAll ( _
    entityType As DeploymentEntityType _
) As DataCollection(Of EntityInstanceId)

C#
public DataCollection<EntityInstanceId> RetrieveAll (
    DeploymentEntityType entityType
)

C++

J#

JScript

Parameters
entityType
Type: DeploymentEntityType. The type of deployment entity for which to retrieve all records.
Return Value
Type: DataCollection<EntityInstanceId>
The collection of all deployment records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllRequest
DeploymentEntityType
Other Resources
Use Deployment Entities and Deployment Configuration Settings


DeploymentServiceClient.Update Method
[image]

Updates a deployment record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Update ( _
    deploymentObject As DeploymentObject _
)

C#
public void Update (
    DeploymentObject deploymentObject
)

C++

J#

JScript

Parameters
deploymentObject
Type: DeploymentObject. An instance of a deployment record with all values populated. See Remarks.
  Remarks
Before calling this method you should call Retrieve to get the deployment entity instance. Unlike the IOrganizationService, this update method will use all attribute values in the deploymentObject instance to update the record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceClient Class
DeploymentServiceClient Members
Microsoft.Xrm.Sdk.Deployment Namespace
Update
UpdateRequest
DeploymentEntityType
Other Resources
Use Deployment Entities and Deployment Configuration Settings


DeploymentServiceClient Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ChannelFactory | (inherited from ClientBase)
public property | ClientCredentials | (inherited from ClientBase)
public property | Endpoint | (inherited from ClientBase)
public property | InnerChannel | (inherited from ClientBase)
public property | State | (inherited from ClientBase)

Protected Properties

 | Name | Description
protected property | Channel | (inherited from ClientBase)

See Also

Reference

DeploymentServiceClient Class
Microsoft.Xrm.Sdk.Deployment Namespace
IDeploymentService

Other Resources

Introduction to the Deployment Web Service


DeploymentServiceClient Events
[image]

Explicit Interface Implementations

Name | Description
Closed | (inherited from ClientBase)
Closing | (inherited from ClientBase)
Faulted | (inherited from ClientBase)
Opened | (inherited from ClientBase)
Opening | (inherited from ClientBase)

See Also

Reference

DeploymentServiceClient Class
Microsoft.Xrm.Sdk.Deployment Namespace
IDeploymentService

Other Resources

Introduction to the Deployment Web Service


DeploymentServiceFault Class
See Also Members
[image]

Represents a deployment service fault.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DeploymentServiceFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class DeploymentServiceFault
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="DeploymentServiceFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class DeploymentServiceFault : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Deployment.DeploymentServiceFault
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceFault Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault Members
See Also Constructors Methods Properties
[image]

Represents a deployment service fault.

The following tables list the members exposed by the DeploymentServiceFault type.

Public Constructors

Name | Description
DeploymentServiceFault | Initializes a new instance of the the DeploymentServiceFault class.
Top

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the error code.
public property | ErrorDetails | Gets or sets the collection of detailed information about the error.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | InnerFault | Gets or sets the fault instance that caused the current fault.
public property | Message | Gets or sets the error message.
public property | Timestamp | Gets or sets the date/time value when the error occurred.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeploymentServiceFault Class
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault Constructor
[image]

Initializes a new instance of the the DeploymentServiceFault class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeploymentServiceFault ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceFault Class
DeploymentServiceFault Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeploymentServiceFault Class
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault Properties
[image]

Public Properties

 | Name | Description
public property | ErrorCode | Gets or sets the error code.
public property | ErrorDetails | Gets or sets the collection of detailed information about the error.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | InnerFault | Gets or sets the fault instance that caused the current fault.
public property | Message | Gets or sets the error message.
public property | Timestamp | Gets or sets the date/time value when the error occurred.

See Also

Reference

DeploymentServiceFault Class
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault.ErrorCode Property
[image]

Gets or sets the error code.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorCode As Integer

C#
[DataMemberAttribute]
public int ErrorCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The error code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceFault Class
DeploymentServiceFault Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault.ErrorDetails Property
[image]

Gets or sets the collection of detailed information about the error.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorDetails As ErrorDetailCollection

C#
[DataMemberAttribute]
public ErrorDetailCollection ErrorDetails { get; set; }

C++

J#

JScript

Property Value
Type: ErrorDetailCollection
The collection of error information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceFault Class
DeploymentServiceFault Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type:  ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceFault Class
DeploymentServiceFault Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault.InnerFault Property
[image]

Gets or sets the fault instance that caused the current fault.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property InnerFault As DeploymentServiceFault

C#
[DataMemberAttribute]
public DeploymentServiceFault InnerFault { get; set; }

C++

J#

JScript

Property Value
Type: DeploymentServiceFault
The fault instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceFault Class
DeploymentServiceFault Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault.Message Property
[image]

Gets or sets the error message.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Message As String

C#
[DataMemberAttribute]
public string Message { get; set; }

C++

J#

JScript

Property Value
Type: String
The error message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceFault Class
DeploymentServiceFault Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceFault.Timestamp Property
[image]

Gets or sets the date/time value when the error occurred.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Timestamp As DateTime

C#
[DataMemberAttribute]
public DateTime Timestamp { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The date/time of the error.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceFault Class
DeploymentServiceFault Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceRequest Class
See Also Members
[image]

Contains the data that is needed to execute a request and the base class for all deployment service requests.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(BeginUpdateOrganizationRequest))> _
<KnownTypeAttribute(GetType(RetrieveAllRequest))> _
<DebuggerStepThroughAttribute> _
<KnownTypeAttribute(GetType(AddDeploymentAdministratorRequest))> _
<DataContractAttribute(Name:="DeploymentServiceRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<KnownTypeAttribute(GetType(DeferredOperationRequest))> _
<KnownTypeAttribute(GetType(BeginImportOrganizationRequest))> _
<KnownTypeAttribute(GetType(BeginUpgradeOrganizationRequest))> _
<KnownTypeAttribute(GetType(BeginCreateOrganizationRequest))> _
<KnownTypeAttribute(GetType(UpdateAdvancedSettingsRequest))> _
<KnownTypeAttribute(GetType(RetrieveMonitoringResultsRequest))> _
<KnownTypeAttribute(GetType(AddCrmDatabaseRequest))> _
<KnownTypeAttribute(GetType(DeleteRequest))> _
<KnownTypeAttribute(GetType(DeleteOrganizationRequest))> _
<KnownTypeAttribute(GetType(RetrieveRequest))> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<KnownTypeAttribute(GetType(UpdateRequest))> _
<KnownTypeAttribute(GetType(UpdateProductKeyRequest))> _
<KnownTypeAttribute(GetType(TrackLicenseRequest))> _
<KnownTypeAttribute(GetType(RetrieveUserMappingRequest))> _
<KnownTypeAttribute(GetType(RetrieveAdvancedSettingsRequest))> _
Public Class DeploymentServiceRequest
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute(typeof(BeginUpdateOrganizationRequest))]
[KnownTypeAttribute(typeof(RetrieveAllRequest))]
[DebuggerStepThroughAttribute]
[KnownTypeAttribute(typeof(AddDeploymentAdministratorRequest))]
[DataContractAttribute(Name="DeploymentServiceRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[KnownTypeAttribute(typeof(DeferredOperationRequest))]
[KnownTypeAttribute(typeof(BeginImportOrganizationRequest))]
[KnownTypeAttribute(typeof(BeginUpgradeOrganizationRequest))]
[KnownTypeAttribute(typeof(BeginCreateOrganizationRequest))]
[KnownTypeAttribute(typeof(UpdateAdvancedSettingsRequest))]
[KnownTypeAttribute(typeof(RetrieveMonitoringResultsRequest))]
[KnownTypeAttribute(typeof(AddCrmDatabaseRequest))]
[KnownTypeAttribute(typeof(DeleteRequest))]
[KnownTypeAttribute(typeof(DeleteOrganizationRequest))]
[KnownTypeAttribute(typeof(RetrieveRequest))]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[KnownTypeAttribute(typeof(UpdateRequest))]
[KnownTypeAttribute(typeof(UpdateProductKeyRequest))]
[KnownTypeAttribute(typeof(TrackLicenseRequest))]
[KnownTypeAttribute(typeof(RetrieveUserMappingRequest))]
[KnownTypeAttribute(typeof(RetrieveAdvancedSettingsRequest))]
public class DeploymentServiceRequest : IExtensibleDataObject

C++

J#

JScript

  Remarks
This is the base class for all deployment Web service requests. Pass an instance of a request class to the Execute method.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest

                Derived Classes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
DeploymentServiceResponse
Other Resources
Introduction to the Deployment Web Service
Deployment Web Service Messages


DeploymentServiceRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to execute a request and the base class for all deployment service requests.

The following tables list the members exposed by the DeploymentServiceRequest type.

Public Constructors

Name | Description
DeploymentServiceRequest | Initializes a new instance of theDeploymentServiceRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeploymentServiceRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeploymentServiceResponse

Other Resources

Introduction to the Deployment Web Service
Deployment Web Service Messages


DeploymentServiceRequest Constructor
[image]

Initializes a new instance of the DeploymentServiceRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeploymentServiceRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceRequest Class
DeploymentServiceRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeploymentServiceRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeploymentServiceResponse

Other Resources

Introduction to the Deployment Web Service
Deployment Web Service Messages


DeploymentServiceRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

DeploymentServiceRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
DeploymentServiceResponse

Other Resources

Introduction to the Deployment Web Service
Deployment Web Service Messages


DeploymentServiceRequest.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceRequest Class
DeploymentServiceRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceResponse Class
See Also Members
[image]

Contains the response from the request and the base class for all deployment Web service responses.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(DeleteOrganizationResponse))> _
<KnownTypeAttribute(GetType(UpdateResponse))> _
<KnownTypeAttribute(GetType(UpdateProductKeyResponse))> _
<KnownTypeAttribute(GetType(TrackLicenseResponse))> _
<KnownTypeAttribute(GetType(RetrieveMonitoringResultsResponse))> _
<KnownTypeAttribute(GetType(AddCrmDatabaseResponse))> _
<KnownTypeAttribute(GetType(RetrieveResponse))> _
<KnownTypeAttribute(GetType(DeferredOperationResponse))> _
<KnownTypeAttribute(GetType(BeginCreateOrganizationResponse))> _
<KnownTypeAttribute(GetType(BeginUpgradeOrganizationResponse))> _
<KnownTypeAttribute(GetType(BeginImportOrganizationResponse))> _
<KnownTypeAttribute(GetType(BeginUpdateOrganizationResponse))> _
<KnownTypeAttribute(GetType(RetrieveAdvancedSettingsResponse))> _
<KnownTypeAttribute(GetType(UpdateAdvancedSettingsResponse))> _
<KnownTypeAttribute(GetType(AddDeploymentAdministratorResponse))> _
<KnownTypeAttribute(GetType(RetrieveUserMappingResponse))> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="DeploymentServiceResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<KnownTypeAttribute(GetType(RetrieveAllResponse))> _
<KnownTypeAttribute(GetType(DeleteResponse))> _
Public Class DeploymentServiceResponse
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute(typeof(DeleteOrganizationResponse))]
[KnownTypeAttribute(typeof(UpdateResponse))]
[KnownTypeAttribute(typeof(UpdateProductKeyResponse))]
[KnownTypeAttribute(typeof(TrackLicenseResponse))]
[KnownTypeAttribute(typeof(RetrieveMonitoringResultsResponse))]
[KnownTypeAttribute(typeof(AddCrmDatabaseResponse))]
[KnownTypeAttribute(typeof(RetrieveResponse))]
[KnownTypeAttribute(typeof(DeferredOperationResponse))]
[KnownTypeAttribute(typeof(BeginCreateOrganizationResponse))]
[KnownTypeAttribute(typeof(BeginUpgradeOrganizationResponse))]
[KnownTypeAttribute(typeof(BeginImportOrganizationResponse))]
[KnownTypeAttribute(typeof(BeginUpdateOrganizationResponse))]
[KnownTypeAttribute(typeof(RetrieveAdvancedSettingsResponse))]
[KnownTypeAttribute(typeof(UpdateAdvancedSettingsResponse))]
[KnownTypeAttribute(typeof(AddDeploymentAdministratorResponse))]
[KnownTypeAttribute(typeof(RetrieveUserMappingResponse))]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="DeploymentServiceResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[KnownTypeAttribute(typeof(RetrieveAllResponse))]
[KnownTypeAttribute(typeof(DeleteResponse))]
public class DeploymentServiceResponse : IExtensibleDataObject

C++

J#

JScript

  Remarks
This is the base class for all deployment Web service responses. An instance of a response class is returned from the Execute method.
Some messages do not have a return value.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse

                Derived Classes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages


DeploymentServiceResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the request and the base class for all deployment Web service responses.

The following tables list the members exposed by the DeploymentServiceResponse type.

Public Constructors

Name | Description
DeploymentServiceResponse | Initializes a new instance of the DeploymentServiceResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeploymentServiceResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages


DeploymentServiceResponse Constructor
[image]

Initializes a new instance of the DeploymentServiceResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeploymentServiceResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceResponse Class
DeploymentServiceResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


DeploymentServiceResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeploymentServiceResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages


DeploymentServiceResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

DeploymentServiceResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages


DeploymentServiceResponse.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeploymentServiceResponse Class
DeploymentServiceResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


DupSettings Class
See Also Members
[image]

Contains duplicate detection settings that can be used to tune a deployment.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DupSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class DupSettings
    Inherits DeploymentConfigSettings

C#
[DataContractAttribute(Name="DupSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class DupSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
You can also use Windows PowerShell to retrieve or update these settings.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.DupSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DupSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


DupSettings Members
See Also Constructors Methods Properties
[image]

Contains duplicate detection settings that can be used to tune a deployment.

The following tables list the members exposed by the DupSettings type.

Public Constructors

Name | Description
DupSettings | Initializes a new instance of the DupSettings class.
Top

Public Properties

 | Name | Description
public property | BulkDetectBatchSize | Gets or sets the bulk duplicate detection batch size.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MatchcodeLength | Gets or sets the length of the match code.
public property | MatchcodePersistenceInterval | Gets or sets the persistence interval for the match code.
public property | MaxPublishedRules | Gets or sets the maximum number of published rules.
public property | PublishAsyncPollingInterval | Gets or sets the polling interval for the asynchronous job.
public property | PublishPageSize | Gets or sets the page size for results.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DupSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


DupSettings Constructor
[image]

Initializes a new instance of the DupSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DupSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DupSettings Class
DupSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


DupSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DupSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


DupSettings Properties
[image]

Public Properties

 | Name | Description
public property | BulkDetectBatchSize | Gets or sets the bulk duplicate detection batch size.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MatchcodeLength | Gets or sets the length of the match code.
public property | MatchcodePersistenceInterval | Gets or sets the persistence interval for the match code.
public property | MaxPublishedRules | Gets or sets the maximum number of published rules.
public property | PublishAsyncPollingInterval | Gets or sets the polling interval for the asynchronous job.
public property | PublishPageSize | Gets or sets the page size for results.

See Also

Reference

DupSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


DupSettings.BulkDetectBatchSize Property
[image]

Gets or sets the bulk duplicate detection batch size.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property BulkDetectBatchSize As Integer

C#
[DataMemberAttribute]
public int BulkDetectBatchSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The batch size.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DupSettings Class
DupSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


DupSettings.MatchcodeLength Property
[image]

Gets or sets the length of the match code.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MatchcodeLength As Integer

C#
[DataMemberAttribute]
public int MatchcodeLength { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The length of the match code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DupSettings Class
DupSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


DupSettings.MatchcodePersistenceInterval Property
[image]

Gets or sets the persistence interval for the match code.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MatchcodePersistenceInterval As Integer

C#
[DataMemberAttribute]
public int MatchcodePersistenceInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The persistence interval.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DupSettings Class
DupSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


DupSettings.MaxPublishedRules Property
[image]

Gets or sets the maximum number of published rules.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxPublishedRules As Integer

C#
[DataMemberAttribute]
public int MaxPublishedRules { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The maximum number of published rules.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DupSettings Class
DupSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


DupSettings.PublishAsyncPollingInterval Property
[image]

Gets or sets the polling interval for the asynchronous job.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PublishAsyncPollingInterval As Integer

C#
[DataMemberAttribute]
public int PublishAsyncPollingInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The polling interval.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DupSettings Class
DupSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


DupSettings.PublishPageSize Property
[image]

Gets or sets the page size for results.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PublishPageSize As Integer

C#
[DataMemberAttribute]
public int PublishPageSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The page size.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DupSettings Class
DupSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


EntityInstanceId Class
See Also Members
[image]

Contains the information needed to identify a deployment entity record: deployment entity type and ID.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EntityInstanceId", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class EntityInstanceId
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="EntityInstanceId", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class EntityInstanceId : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Deployment.EntityInstanceId
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EntityInstanceId Members
Microsoft.Xrm.Sdk.Deployment Namespace


EntityInstanceId Members
See Also Constructors Methods Properties
[image]

Contains the information needed to identify a deployment entity record: deployment entity type and ID.

The following tables list the members exposed by the EntityInstanceId type.

Public Constructors

Name | Description
EntityInstanceId | Initializes a new instance of the EntityInstanceId class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Id | Gets or sets the ID of the record.
public property | Name | Gets or sets the name of the deployment entity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EntityInstanceId Class
Microsoft.Xrm.Sdk.Deployment Namespace


EntityInstanceId Constructor
[image]

Initializes a new instance of the EntityInstanceId class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityInstanceId ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EntityInstanceId Class
EntityInstanceId Members
Microsoft.Xrm.Sdk.Deployment Namespace


EntityInstanceId Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EntityInstanceId Class
Microsoft.Xrm.Sdk.Deployment Namespace


EntityInstanceId Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Id | Gets or sets the ID of the record.
public property | Name | Gets or sets the name of the deployment entity.

See Also

Reference

EntityInstanceId Class
Microsoft.Xrm.Sdk.Deployment Namespace


EntityInstanceId.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EntityInstanceId Class
EntityInstanceId Members
Microsoft.Xrm.Sdk.Deployment Namespace


EntityInstanceId.Id Property
[image]

Gets or sets the ID of the record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid

The ID of the record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EntityInstanceId Class
EntityInstanceId Members
Microsoft.Xrm.Sdk.Deployment Namespace


EntityInstanceId.Name Property
[image]

Gets or sets the name of the deployment entity.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Name As String

C#
[DataMemberAttribute]
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the deployment entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EntityInstanceId Class
EntityInstanceId Members
Microsoft.Xrm.Sdk.Deployment Namespace


ErrorDetailCollection Class
See Also Members
[image]

Contains the collection of error details.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<CollectionDataContractAttribute(Name:="ErrorDetailCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts", ItemName:="KeyValuePairOfstringanyType")> _
<DebuggerStepThroughAttribute> _
Public Class ErrorDetailCollection
    Inherits DataCollection(Of KeyValuePair(Of String, Object))

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[CollectionDataContractAttribute(Name="ErrorDetailCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts", ItemName="KeyValuePairOfstringanyType")]
[DebuggerStepThroughAttribute]
public class ErrorDetailCollection : DataCollection<KeyValuePair<string,Object>>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.Deployment.ErrorDetailCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorDetailCollection Members
Microsoft.Xrm.Sdk.Deployment Namespace
ErrorDetails
ErrorDetails


ErrorDetailCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains the collection of error details.

The following tables list the members exposed by the ErrorDetailCollection type.

Public Constructors

Name | Description
ErrorDetailCollection | Initializes a new instance of the ErrorDetailCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

ErrorDetailCollection Class
Microsoft.Xrm.Sdk.Deployment Namespace
ErrorDetails
ErrorDetails


ErrorDetailCollection Constructor
[image]

Initializes a new instance of the ErrorDetailCollection class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ErrorDetailCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorDetailCollection Class
ErrorDetailCollection Members
Microsoft.Xrm.Sdk.Deployment Namespace


ErrorDetailCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

ErrorDetailCollection Class
Microsoft.Xrm.Sdk.Deployment Namespace
ErrorDetails
ErrorDetails


ErrorDetailCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

ErrorDetailCollection Class
Microsoft.Xrm.Sdk.Deployment Namespace
ErrorDetails
ErrorDetails


EtmSettings Class
See Also Members
[image]

Contains Enterprise Transaction Monitor (ETM) settings.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EtmSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class EtmSettings
    Inherits DeploymentConfigSettings

C#
[DataContractAttribute(Name="EtmSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class EtmSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.EtmSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EtmSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


EtmSettings Members
See Also Constructors Methods Properties
[image]

Contains Enterprise Transaction Monitor (ETM) settings.

The following tables list the members exposed by the EtmSettings type.

Public Constructors

Name | Description
EtmSettings | Initializes a new instance of the EtmSettings class.
Top

Public Properties

 | Name | Description
public property | Enabled | Gets or sets whether Enterprise Transaction Monitor (ETM) is enabled.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | ThrottlingEnabled | Gets or sets whether Enterprise Transaction Monitor (ETM) throttling is enabled.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EtmSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


EtmSettings Constructor
[image]

Initializes a new instance of the EtmSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EtmSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EtmSettings Class
EtmSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


EtmSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EtmSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


EtmSettings Properties
[image]

Public Properties

 | Name | Description
public property | Enabled | Gets or sets whether Enterprise Transaction Monitor (ETM) is enabled.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | ThrottlingEnabled | Gets or sets whether Enterprise Transaction Monitor (ETM) throttling is enabled.

See Also

Reference

EtmSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


EtmSettings.Enabled Property
[image]

Gets or sets whether Enterprise Transaction Monitor (ETM) is enabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Enabled As Boolean

C#
[DataMemberAttribute]
public bool Enabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Flag indicating whether Enterprise Transaction Monitor (ETM) is enabled.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EtmSettings Class
EtmSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


EtmSettings.ThrottlingEnabled Property
[image]

Gets or sets whether Enterprise Transaction Monitor (ETM) throttling is enabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ThrottlingEnabled As Boolean

C#
[DataMemberAttribute]
public bool ThrottlingEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
Flag indicating whether Enterprise Transaction Monitor (ETM) throttling is enabled.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EtmSettings Class
EtmSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


IDeploymentService Interface
See Also Members
[image]

Provides programmatic access to deployment information.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.ServiceModel", "4.0.0.0")> _
<ServiceContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Services", ConfigurationName:="Microsoft.Xrm.Sdk.Deployment.IDeploymentService")> _
Public Interface IDeploymentService

C#
[GeneratedCodeAttribute("System.ServiceModel", "4.0.0.0")]
[ServiceContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Services", ConfigurationName="Microsoft.Xrm.Sdk.Deployment.IDeploymentService")]
public interface IDeploymentService

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IDeploymentService Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Introduction to the Deployment Web Service


IDeploymentService Members
See Also Methods
[image]

Provides programmatic access to deployment information.

The following tables list the members exposed by the IDeploymentService type.

Public Methods

 | Name | Description
public method | Delete | Deletes a deployment record.
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | Retrieve | Retrieves a deployment record.
public method | RetrieveAll | Retrieves all deployment records for the specified deployment entity type.
public method | Update | Updates a deployment record.
Top

See Also

Reference

IDeploymentService Interface
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Introduction to the Deployment Web Service


IDeploymentService Methods
[image]

Public Methods

 | Name | Description
public method | Delete | Deletes a deployment record.
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | Retrieve | Retrieves a deployment record.
public method | RetrieveAll | Retrieves all deployment records for the specified deployment entity type.
public method | Update | Updates a deployment record.

See Also

Reference

IDeploymentService Interface
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Introduction to the Deployment Web Service


IDeploymentService.Delete Method
[image]

Deletes a deployment record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<OperationContractAttribute(Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/Delete", ReplyAction:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/DeleteResponse")> _
<FaultContractAttribute(GetType(DeploymentServiceFault), Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/DeleteDeploymentServiceFaultFault", Name:="DeploymentServiceFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Sub Delete ( _
    entityType As DeploymentEntityType, _
    id As EntityInstanceId _
)

C#
[OperationContractAttribute(Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/Delete", ReplyAction="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/DeleteResponse")]
[FaultContractAttribute(typeof(DeploymentServiceFault), Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/DeleteDeploymentServiceFaultFault", Name="DeploymentServiceFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
void Delete (
    DeploymentEntityType entityType,
    EntityInstanceId id
)

C++

J#

JScript

Parameters
entityType
Type: DeploymentEntityType. The type of deployment entity specified by the id parameter.
id
Type: EntityInstanceId. The ID of the deployment record to delete. See Remarks.
  Remarks
The ID of a deployment record is also referred to as an instance tag.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IDeploymentService Interface
IDeploymentService Members
Microsoft.Xrm.Sdk.Deployment Namespace
DeleteRequest
DeploymentEntityType
Other Resources
Use Deployment Entities and Deployment Configuration Settings


IDeploymentService.Execute Method
[image]

Executes a message in the form of a request, and returns a response.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<OperationContractAttribute(Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/Execute", ReplyAction:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/ExecuteResponse")> _
<FaultContractAttribute(GetType(DeploymentServiceFault), Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/ExecuteDeploymentServiceFaultFault", Name:="DeploymentServiceFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Function Execute ( _
    request As DeploymentServiceRequest _
) As DeploymentServiceResponse

C#
[OperationContractAttribute(Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/Execute", ReplyAction="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/ExecuteResponse")]
[FaultContractAttribute(typeof(DeploymentServiceFault), Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/ExecuteDeploymentServiceFaultFault", Name="DeploymentServiceFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
DeploymentServiceResponse Execute (
    DeploymentServiceRequest request
)

C++

J#

JScript

Parameters
request
Type: DeploymentServiceRequest. A request instance that defines the action to be performed.
Return Value
Type: DeploymentServiceResponse
The response from the request. You must cast the return value of this method to the specific instance of the response that corresponds to the Request parameter

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IDeploymentService Interface
IDeploymentService Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use Deployment Entities and Deployment Configuration Settings


IDeploymentService.Retrieve Method
[image]

Retrieves a deployment record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FaultContractAttribute(GetType(DeploymentServiceFault), Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveDeploymentServiceFaultFault", Name:="DeploymentServiceFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<OperationContractAttribute(Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/Retrieve", ReplyAction:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveResponse")> _
Function Retrieve ( _
    entityType As DeploymentEntityType, _
    id As EntityInstanceId _
) As DeploymentObject

C#
[FaultContractAttribute(typeof(DeploymentServiceFault), Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveDeploymentServiceFaultFault", Name="DeploymentServiceFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[OperationContractAttribute(Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/Retrieve", ReplyAction="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveResponse")]
DeploymentObject Retrieve (
    DeploymentEntityType entityType,
    EntityInstanceId id
)

C++

J#

JScript

Parameters
entityType
Type: DeploymentEntityType. The type of deployment entity specified by the id parameter.
id
Type: EntityInstanceId. The ID of the deployment record to retrieve. See Remarks.
Return Value
Type: DeploymentObject
The deployment record.

  Remarks
The ID of a deployment record is also referred to as an instance tag.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IDeploymentService Interface
IDeploymentService Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveRequest
DeploymentEntityType
Other Resources
Use Deployment Entities and Deployment Configuration Settings


IDeploymentService.RetrieveAll Method
[image]

Retrieves all deployment records for the specified deployment entity type.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FaultContractAttribute(GetType(DeploymentServiceFault), Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveAllDeploymentServiceFaultFault", Name:="DeploymentServiceFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<OperationContractAttribute(Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveAll", ReplyAction:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveAllResponse")> _
Function RetrieveAll ( _
    entityType As DeploymentEntityType _
) As DataCollection(Of EntityInstanceId)

C#
[FaultContractAttribute(typeof(DeploymentServiceFault), Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveAllDeploymentServiceFaultFault", Name="DeploymentServiceFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[OperationContractAttribute(Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveAll", ReplyAction="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/RetrieveAllResponse")]
DataCollection<EntityInstanceId> RetrieveAll (
    DeploymentEntityType entityType
)

C++

J#

JScript

Parameters
entityType
Type: DeploymentEntityType. The type of deployment entity for which to retrieve all records.
Return Value
Type: DataCollection<EntityInstanceId>
The collection of all deployment records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IDeploymentService Interface
IDeploymentService Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllRequest
DeploymentEntityType
Other Resources
Use Deployment Entities and Deployment Configuration Settings


IDeploymentService.Update Method
[image]

Updates a deployment record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FaultContractAttribute(GetType(DeploymentServiceFault), Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/UpdateDeploymentServiceFaultFault", Name:="DeploymentServiceFault", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<OperationContractAttribute(Action:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/Update", ReplyAction:="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/UpdateResponse")> _
Sub Update ( _
    deploymentObject As DeploymentObject _
)

C#
[FaultContractAttribute(typeof(DeploymentServiceFault), Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/UpdateDeploymentServiceFaultFault", Name="DeploymentServiceFault", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[OperationContractAttribute(Action="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/Update", ReplyAction="http://schemas.microsoft.com/xrm/2011/Contracts/Services/IDeploymentService/UpdateResponse")]
void Update (
    DeploymentObject deploymentObject
)

C++

J#

JScript

Parameters
deploymentObject
Type: DeploymentObject. An instance of a deployment record with all values populated. See Remarks.
  Remarks
Before calling this method you should call Retrieve to get the deployment entity instance. Unlike the IOrganizationService, this update method will use all attribute values in the deploymentObject instance to update the record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IDeploymentService Interface
IDeploymentService Members
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateRequest
DeploymentEntityType
Other Resources
Use Deployment Entities and Deployment Configuration Settings


IDeploymentServiceChannel Interface
See Also Members
[image]

Interface for the deployment web service channel.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.ServiceModel", "4.0.0.0")> _
Public Interface IDeploymentServiceChannel
    Inherits IDeploymentService, IClientChannel, IContextChannel, IChannel, _
    ICommunicationObject, IExtensibleObject(Of IContextChannel), IDisposable

C#
[GeneratedCodeAttribute("System.ServiceModel", "4.0.0.0")]
public interface IDeploymentServiceChannel : IDeploymentService, IClientChannel, IContextChannel,
    IChannel, ICommunicationObject, IExtensibleObject<IContextChannel>, IDisposable

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IDeploymentServiceChannel Members
Microsoft.Xrm.Sdk.Deployment Namespace


IDeploymentServiceChannel Members
See Also Methods
[image]

Interface for the deployment web service channel.

The following tables list the members exposed by the IDeploymentServiceChannel type.

Public Methods

 | Name | Description
public method | Delete | Deletes a deployment record. (inherited from IDeploymentService)
public method | Execute | Executes a message in the form of a request, and returns a response. (inherited from IDeploymentService)
public method | Retrieve | Retrieves a deployment record. (inherited from IDeploymentService)
public method | RetrieveAll | Retrieves all deployment records for the specified deployment entity type. (inherited from IDeploymentService)
public method | Update | Updates a deployment record. (inherited from IDeploymentService)
Top

See Also

Reference

IDeploymentServiceChannel Interface
Microsoft.Xrm.Sdk.Deployment Namespace


IDeploymentServiceChannel Methods
[image]

Public Methods

 | Name | Description
public method | Delete | Deletes a deployment record. (inherited from IDeploymentService)
public method | Execute | Executes a message in the form of a request, and returns a response. (inherited from IDeploymentService)
public method | Retrieve | Retrieves a deployment record. (inherited from IDeploymentService)
public method | RetrieveAll | Retrieves all deployment records for the specified deployment entity type. (inherited from IDeploymentService)
public method | Update | Updates a deployment record. (inherited from IDeploymentService)

See Also

Reference

IDeploymentServiceChannel Interface
Microsoft.Xrm.Sdk.Deployment Namespace


IfdSettings Class
See Also Members
[image]

Contains settings for configuring Internet-facing deployments (IFDs).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="IfdSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class IfdSettings
    Inherits DeploymentConfigSettings

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="IfdSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class IfdSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.IfdSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IfdSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use Deployment Entities and Deployment Configuration Settings


IfdSettings Members
See Also Constructors Methods Properties
[image]

Contains settings for configuring Internet-facing deployments (IFDs).

The following tables list the members exposed by the IfdSettings type.

Public Constructors

Name | Description
IfdSettings | Initializes a new instance of the IfdSettings class.
Top

Public Properties

 | Name | Description
public property | DiscoveryWebServiceRootDomain | Gets or sets the discovery web service domain.
public property | Enabled | Gets or sets a value that indicates whether Internet-facing deployment (IFD) is enabled.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | ExternalDomain | Gets or sets the external domain value for Internet-facing deployment (IFD).
public property | IntranetAccessEnabled | Gets or sets a value that indicates whether intranet access is enabled.
public property | OrganizationWebServiceRootDomain | Gets or sets the organization web service domain.
public property | WebApplicationRootDomain | Gets or sets the web application server domain.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IfdSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


IfdSettings Constructor
[image]

Initializes a new instance of the IfdSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IfdSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IfdSettings Class
IfdSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


IfdSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IfdSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


IfdSettings Properties
[image]

Public Properties

 | Name | Description
public property | DiscoveryWebServiceRootDomain | Gets or sets the discovery web service domain.
public property | Enabled | Gets or sets a value that indicates whether Internet-facing deployment (IFD) is enabled.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | ExternalDomain | Gets or sets the external domain value for Internet-facing deployment (IFD).
public property | IntranetAccessEnabled | Gets or sets a value that indicates whether intranet access is enabled.
public property | OrganizationWebServiceRootDomain | Gets or sets the organization web service domain.
public property | WebApplicationRootDomain | Gets or sets the web application server domain.

See Also

Reference

IfdSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


IfdSettings.DiscoveryWebServiceRootDomain Property
[image]

Gets or sets the discovery web service domain.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DiscoveryWebServiceRootDomain As String

C#
[DataMemberAttribute]
public string DiscoveryWebServiceRootDomain { get; set; }

C++

J#

JScript

Property Value
Type: String

The discovery web service domain.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IfdSettings Class
IfdSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


IfdSettings.Enabled Property
[image]

Gets or sets a value that indicates whether Internet-facing deployment (IFD) is enabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Enabled As Boolean

C#
[DataMemberAttribute]
public bool Enabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if Internet-facing deployment (IFD) is enabled; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IfdSettings Class
IfdSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


IfdSettings.ExternalDomain Property
[image]

Gets or sets the external domain value for Internet-facing deployment (IFD).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ExternalDomain As String

C#
[DataMemberAttribute]
public string ExternalDomain { get; set; }

C++

J#

JScript

Property Value
Type: String

The external domain value for IFD.

  Remarks
Use of SSL is assumed so it is not necessary to specify https://.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IfdSettings Class
IfdSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


IfdSettings.IntranetAccessEnabled Property
[image]

Gets or sets a value that indicates whether intranet access is enabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IntranetAccessEnabled As Boolean

C#
[DataMemberAttribute]
public bool IntranetAccessEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if intranet access is enabled; otherwise, false.

  Remarks
If true, allows intranet URLs to be returned over Internet discovery requests.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IfdSettings Class
IfdSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


IfdSettings.OrganizationWebServiceRootDomain Property
[image]

Gets or sets the organization web service domain.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrganizationWebServiceRootDomain As String

C#
[DataMemberAttribute]
public string OrganizationWebServiceRootDomain { get; set; }

C++

J#

JScript

Property Value
Type: String

The organization web service domain.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IfdSettings Class
IfdSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


IfdSettings.WebApplicationRootDomain Property
[image]

Gets or sets the web application server domain.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property WebApplicationRootDomain As String

C#
[DataMemberAttribute]
public string WebApplicationRootDomain { get; set; }

C++

J#

JScript

Property Value
Type: String

The web application server domain.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IfdSettings Class
IfdSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ImportSettings Class
See Also Members
[image]

Contains settings that can be changed to tune data import.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ImportSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class ImportSettings
    Inherits DeploymentConfigSettings

C#
[DataContractAttribute(Name="ImportSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class ImportSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
You can also use Windows PowerShell to retrieve or update these settings.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.ImportSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Import Data in Microsoft Dynamics CRM


ImportSettings Members
See Also Constructors Methods Properties
[image]

Contains settings that can be changed to tune data import.

The following tables list the members exposed by the ImportSettings type.

Public Constructors

Name | Description
ImportSettings | Initializes a new instance of the ImportSettings class.
Top

Public Properties

 | Name | Description
public property | BatchSize | Gets or sets the number of items to process in a batch.
public property | ContentBufferSize | Gets or sets the size of the content buffer.
public property | CountUpdateBatchSize | Gets or sets the batch size for import count updates.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MaxColumnsAllowed | Gets or sets the maximum number of columns in an import file.
public property | MaxDataTruncationRetryCount | Gets or sets the maximum number or retries.
public property | ParsedColumnDefaultSize | Gets or sets the default size of the parsed column.
public property | PickListBatchSize | Gets or sets the batch size for picklist import.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Import Data in Microsoft Dynamics CRM


ImportSettings Constructor
[image]

Initializes a new instance of the ImportSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportSettings Class
ImportSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ImportSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Import Data in Microsoft Dynamics CRM


ImportSettings Properties
[image]

Public Properties

 | Name | Description
public property | BatchSize | Gets or sets the number of items to process in a batch.
public property | ContentBufferSize | Gets or sets the size of the content buffer.
public property | CountUpdateBatchSize | Gets or sets the batch size for import count updates.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MaxColumnsAllowed | Gets or sets the maximum number of columns in an import file.
public property | MaxDataTruncationRetryCount | Gets or sets the maximum number or retries.
public property | ParsedColumnDefaultSize | Gets or sets the default size of the parsed column.
public property | PickListBatchSize | Gets or sets the batch size for picklist import.

See Also

Reference

ImportSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Import Data in Microsoft Dynamics CRM


ImportSettings.BatchSize Property
[image]

Gets or sets the number of items to process in a batch.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property BatchSize As Integer

C#
[DataMemberAttribute]
public int BatchSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of items to process in a batch.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportSettings Class
ImportSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ImportSettings.ContentBufferSize Property
[image]

Gets or sets the size of the content buffer.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ContentBufferSize As Integer

C#
[DataMemberAttribute]
public int ContentBufferSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The size of the content buffer.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportSettings Class
ImportSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ImportSettings.CountUpdateBatchSize Property
[image]

Gets or sets the batch size for import count updates.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CountUpdateBatchSize As Integer

C#
[DataMemberAttribute]
public int CountUpdateBatchSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The batch size for import count updates.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportSettings Class
ImportSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ImportSettings.MaxColumnsAllowed Property
[image]

Gets or sets the maximum number of columns in an import file.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxColumnsAllowed As Integer

C#
[DataMemberAttribute]
public int MaxColumnsAllowed { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of columns in an import file.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportSettings Class
ImportSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ImportSettings.MaxDataTruncationRetryCount Property
[image]

Gets or sets the maximum number or retries.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxDataTruncationRetryCount As Integer

C#
[DataMemberAttribute]
public int MaxDataTruncationRetryCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number or retries.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportSettings Class
ImportSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ImportSettings.ParsedColumnDefaultSize Property
[image]

Gets or sets the default size of the parsed column.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ParsedColumnDefaultSize As Integer

C#
[DataMemberAttribute]
public int ParsedColumnDefaultSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The default size of the parsed column.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportSettings Class
ImportSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ImportSettings.PickListBatchSize Property
[image]

Gets or sets the batch size for picklist import.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PickListBatchSize As Integer

C#
[DataMemberAttribute]
public int PickListBatchSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The batch size for picklist import.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportSettings Class
ImportSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ImportUserMappingMethod Enumeration
[image]

Defines the possible methods for mapping users when importing an organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ImportUserMappingMethod", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Enumeration ImportUserMappingMethod

C#
[DataContractAttribute(Name="ImportUserMappingMethod", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public enum ImportUserMappingMethod

C++

J#

JScript

  Members
Member name | Description
ByAccount | Specifies to automatically map the users' Active Directory account names to Microsoft Dynamics CRM accounts. Value = 1.
ByFullName | Specifies to look up Active Directory users in the new domain by using the user’s display name . Value = 3.
ByMappingXml | Specifies custom user account matching options in an XML string. Value = 2.
ByMappingXmlFile | Specifies to map users with a mapping file. Value = 4.
KeepExisting | Specifies to keep the existing user mappings in the organization database. Typically, you select this option if you’re importing an organization database that is located in the same Active Directory domain as the Microsoft Dynamics CRM server where the organization is to be imported. For users external to the Active Directory domain, who were added with their UPN, the user information will be mapped across without any changes or validation. Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


LicenseProperties Class
See Also Members
[image]

Contains information about a license for Microsoft Dynamics CRM 2011.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="LicenseProperties", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class LicenseProperties
    Inherits DeploymentEntity

C#
[DataContractAttribute(Name="LicenseProperties", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class LicenseProperties : DeploymentEntity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentEntity
      Microsoft.Xrm.Sdk.Deployment.LicenseProperties
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LicenseProperties Members
Microsoft.Xrm.Sdk.Deployment Namespace


LicenseProperties Members
See Also Constructors Methods Properties
[image]

Contains information about a license for Microsoft Dynamics CRM 2011.

The following tables list the members exposed by the LicenseProperties type.

Public Constructors

Name | Description
LicenseProperties | Initializes a new instance of the LicenseProperties class.
Top

Public Properties

 | Name | Description
public property | Edition | Gets or sets the edition of Microsoft Dynamics CRM 2011 for this license.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | ProductId | Gets or sets the ID of the product.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LicenseProperties Class
Microsoft.Xrm.Sdk.Deployment Namespace


LicenseProperties Constructor
[image]

Initializes a new instance of the LicenseProperties class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LicenseProperties ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LicenseProperties Class
LicenseProperties Members
Microsoft.Xrm.Sdk.Deployment Namespace


LicenseProperties Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LicenseProperties Class
Microsoft.Xrm.Sdk.Deployment Namespace


LicenseProperties Properties
[image]

Public Properties

 | Name | Description
public property | Edition | Gets or sets the edition of Microsoft Dynamics CRM 2011 for this license.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | ProductId | Gets or sets the ID of the product.

See Also

Reference

LicenseProperties Class
Microsoft.Xrm.Sdk.Deployment Namespace


LicenseProperties.Edition Property
[image]

Gets or sets the edition of Microsoft Dynamics CRM 2011 for this license.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Edition As LicenseType

C#
[DataMemberAttribute]
public LicenseType Edition { get; set; }

C++

J#

JScript

Property Value
Type: LicenseType
The edition of Microsoft Dynamics CRM 2011 for this license.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LicenseProperties Class
LicenseProperties Members
Microsoft.Xrm.Sdk.Deployment Namespace


LicenseProperties.ProductId Property
[image]

Gets or sets the ID of the product.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ProductId As String

C#
[DataMemberAttribute]
public string ProductId { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The ID of the product.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LicenseProperties Class
LicenseProperties Members
Microsoft.Xrm.Sdk.Deployment Namespace


LicenseType Enumeration
[image]

Indicates the type of license.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="LicenseType", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Enumeration LicenseType

C#
[DataContractAttribute(Name="LicenseType", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public enum LicenseType

C++

J#

JScript

  Members
Member name | Description
Enterprise | Microsoft Dynamics CRM Enterprise Edition. Value = 2.
Live | Microsoft Dynamics CRM Online Edition. Value = 4.
Professional | Microsoft Dynamics CRM Professional Edition. Value = 1.
SmallBusiness | Microsoft Dynamics CRM Small Business Edition. Value = 0.
Spla | Microsoft Dynamics Partner Hosted CRM Edition. Value = 3.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace


MarketplaceSettings Class
See Also Members
[image]

Contains settings for the Microsoft Dynamics Marketplace.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="MarketplaceSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class MarketplaceSettings
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="MarketplaceSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class MarketplaceSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.MarketplaceSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MarketplaceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Microsoft Dynamics CRM Marketplace


MarketplaceSettings Members
See Also Constructors Methods Properties
[image]

Contains settings for the Microsoft Dynamics Marketplace.

The following tables list the members exposed by the MarketplaceSettings type.

Public Constructors

Name | Description
MarketplaceSettings | Initializes a new instance of the MarketplaceSettings class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | InternetConnectionProxyEndpoint | Gets or sets the proxy server and port used for outgoing internet requests.
public property | SolutionsMarketplaceEnabled | Gets or sets whether the solutions marketplace is enabled.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MarketplaceSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Microsoft Dynamics CRM Marketplace


MarketplaceSettings Constructor
[image]

Initializes a new instance of the MarketplaceSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MarketplaceSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MarketplaceSettings Class
MarketplaceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MarketplaceSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MarketplaceSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Microsoft Dynamics CRM Marketplace


MarketplaceSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | InternetConnectionProxyEndpoint | Gets or sets the proxy server and port used for outgoing internet requests.
public property | SolutionsMarketplaceEnabled | Gets or sets whether the solutions marketplace is enabled.

See Also

Reference

MarketplaceSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Microsoft Dynamics CRM Marketplace


MarketplaceSettings.InternetConnectionProxyEndpoint Property
[image]

Gets or sets the proxy server and port used for outgoing internet requests.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property InternetConnectionProxyEndpoint As String

C#
[DataMemberAttribute]
public string InternetConnectionProxyEndpoint { get; set; }

C++

J#

JScript

Property Value
Type: String
The proxy server and port.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MarketplaceSettings Class
MarketplaceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MarketplaceSettings.SolutionsMarketplaceEnabled Property
[image]

Gets or sets whether the solutions marketplace is enabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SolutionsMarketplaceEnabled As Boolean

C#
[DataMemberAttribute]
public bool SolutionsMarketplaceEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MarketplaceSettings Class
MarketplaceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData Class
See Also Members
[image]

Contains information about the result of a test run by the Microsoft Dynamics CRM monitoring service.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="MonitoringResultData", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")> _
Public Class MonitoringResultData
    Inherits BaseData

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="MonitoringResultData", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")]
public class MonitoringResultData : BaseData

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.BaseData
    Microsoft.Xrm.Sdk.Deployment.MonitoringResultData
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData Members
See Also Constructors Methods Properties
[image]

Contains information about the result of a test run by the Microsoft Dynamics CRM monitoring service.

The following tables list the members exposed by the MonitoringResultData type.

Public Constructors

Name | Description
MonitoringResultData | Initializes a new instance of the MonitoringResultData class.
Top

Public Properties

 | Name | Description
public property | EndTime | Gets or sets the time when monitoring test ended.
public property | ExtensionData | For internal use only. (inherited from BaseData)
public property | Id | Gets or sets the ID of the monitoring test.
public property | Role | Gets or sets the CRM role for which the monitoring test was run.
public property | Server | Gets or sets the CRM server name where the test was run.
public property | StartTime | Gets or sets the time when monitoring test started.
public property | Status | Gets or sets the status of the test.
public property | StatusDetail | Gets or sets the information about the test status.
public property | TestName | Gets or sets the name of the test.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MonitoringResultData Class
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData Constructor
[image]

Initializes a new instance of the MonitoringResultData class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MonitoringResultData ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Class
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MonitoringResultData Class
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData Properties
[image]

Public Properties

 | Name | Description
public property | EndTime | Gets or sets the time when monitoring test ended.
public property | ExtensionData | For internal use only. (inherited from BaseData)
public property | Id | Gets or sets the ID of the monitoring test.
public property | Role | Gets or sets the CRM role for which the monitoring test was run.
public property | Server | Gets or sets the CRM server name where the test was run.
public property | StartTime | Gets or sets the time when monitoring test started.
public property | Status | Gets or sets the status of the test.
public property | StatusDetail | Gets or sets the information about the test status.
public property | TestName | Gets or sets the name of the test.

See Also

Reference

MonitoringResultData Class
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData.EndTime Property
[image]

Gets or sets the time when monitoring test ended.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EndTime As DateTime

C#
[DataMemberAttribute]
public DateTime EndTime { get; set; }

C++

J#

JScript

Property Value
Type DateTime
Time to filter test results that were reported earlier than the specified time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Class
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData.Id Property
[image]

Gets or sets the ID of the monitoring test.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type Guid
 ID of the monitoring test.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Class
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData.Role Property
[image]

Gets or sets the CRM role for which the monitoring test was run.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Role As ServerRoles

C#
[DataMemberAttribute]
public ServerRoles Role { get; set; }

C++

J#

JScript

Property Value
Type ServerRoles
role for which the monitoring test was run.

  Remarks
Monitoring test results are run for the following roles: AppServer, AsyncService, SrsDataConnector, DiscoveryService, EmailService, WebService, SqlServer, ApiServer, HelpServer, DeploymentService, SrsSqlServer, SandboxServer, and DeploymentManagementTools.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Class
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData.Server Property
[image]

Gets or sets the CRM server name where the test was run.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Server As String

C#
[DataMemberAttribute]
public string Server { get; set; }

C++

J#

JScript

Property Value
Type String
The CRM server name where the test was run.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Class
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData.StartTime Property
[image]

Gets or sets the time when monitoring test started.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property StartTime As DateTime

C#
[DataMemberAttribute]
public DateTime StartTime { get; set; }

C++

J#

JScript

Property Value
Type DateTime
The time when the test started.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Class
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData.Status Property
[image]

Gets or sets the status of the test.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Status As TestStatus

C#
[DataMemberAttribute]
public TestStatus Status { get; set; }

C++

J#

JScript

Property Value
Type TestStatus
Status of the test.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Class
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData.StatusDetail Property
[image]

Gets or sets the information about the test status.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property StatusDetail As String

C#
[DataMemberAttribute]
public string StatusDetail { get; set; }

C++

J#

JScript

Property Value
Type String
Information about the test status.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Class
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringResultData.TestName Property
[image]

Gets or sets the name of the test.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TestName As String

C#
[DataMemberAttribute]
public string TestName { get; set; }

C++

J#

JScript

Property Value
Type String
Name of the test.

  Remarks
A test result name can have one of the following values: VerifyAsyncServiceMaintenanceRunning, VerifyAsyncServiceRunning, VerifySandboxServiceIsRunning, VerifyUnZipServiceIsRunning, VerifyVSSWriterServiceIsRunning, VerifyWebsiteIsRunning, VerifyApplicationAppPoolIsRunning, VerifyDeploymentWebServiceAppPoolIsRunning, CheckApiServer, CheckWebApp, VerifyActiveCrmKeys, VerifyAsyncBacklogTest, VerifyHelpContent, CheckReportServer, CheckCrmReporting, CheckReportServerFromSrsDataConnector, and CheckFetchBasedReport.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringResultData Class
MonitoringResultData Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringSettings Class
See Also Members
[image]

Contains settings used to manage or configure the monitoring service and the tests executed by the service.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="MonitoringSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class MonitoringSettings
    Inherits DeploymentConfigSettings

C#
[DataContractAttribute(Name="MonitoringSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class MonitoringSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
At this time, the only tests run are those that monitor the remaining life for certificates installed for Microsoft Dynamics CRM.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.MonitoringSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


MonitoringSettings Members
See Also Constructors Methods Properties
[image]

Contains settings used to manage or configure the monitoring service and the tests executed by the service.

The following tables list the members exposed by the MonitoringSettings type.

Public Constructors

Name | Description
MonitoringSettings | Initializes a new instance of the MonitoringSettings class.
Top

Public Properties

 | Name | Description
public property | CertificateLifetimeNotificationThreshold | Gets or sets the threshold of the certificate lifetime remaining at which to begin reporting expiration notifications.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MonitoringOrganizationUniqueName | Gets or sets the unique name of the organization that is being monitored.
public property | MonitoringOrganizationUserAccount | Gets or sets the user account to be used when monitoring the organization.
public property | MonitoringOrganizationUserPassword | Gets or sets the user account password to be used when monitoring the organization.
public property | ResultsToKeep | Gets or sets the number of monitoring results to keep.
public property | ResultsToKeepInDatabase | Gets or sets the number of monitoring results to keep in the database.
public property | StoreResultsInDatabase | Gets or sets whether monitoring results should be kept in the database.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MonitoringSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


MonitoringSettings Constructor
[image]

Initializes a new instance of the MonitoringSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MonitoringSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringSettings Class
MonitoringSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MonitoringSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


MonitoringSettings Properties
[image]

Public Properties

 | Name | Description
public property | CertificateLifetimeNotificationThreshold | Gets or sets the threshold of the certificate lifetime remaining at which to begin reporting expiration notifications.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MonitoringOrganizationUniqueName | Gets or sets the unique name of the organization that is being monitored.
public property | MonitoringOrganizationUserAccount | Gets or sets the user account to be used when monitoring the organization.
public property | MonitoringOrganizationUserPassword | Gets or sets the user account password to be used when monitoring the organization.
public property | ResultsToKeep | Gets or sets the number of monitoring results to keep.
public property | ResultsToKeepInDatabase | Gets or sets the number of monitoring results to keep in the database.
public property | StoreResultsInDatabase | Gets or sets whether monitoring results should be kept in the database.

See Also

Reference

MonitoringSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


MonitoringSettings.CertificateLifetimeNotificationThreshold Property
[image]

Gets or sets the threshold of the certificate lifetime remaining at which to begin reporting expiration notifications.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CertificateLifetimeNotificationThreshold As Integer

C#
[DataMemberAttribute]
public int CertificateLifetimeNotificationThreshold { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The threshold of the certificate lifetime remaining at which to begin reporting expiration notifications. Specified as an integral percentage.

  Remarks
If at the time the monitoring test runs the remaining time to expiration of the certificate is less than the threshold value, a warning is written into the event log along with details about the certificate.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringSettings Class
MonitoringSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringSettings.MonitoringOrganizationUniqueName Property
[image]

Gets or sets the unique name of the organization that is being monitored.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MonitoringOrganizationUniqueName As String

C#
[DataMemberAttribute]
public string MonitoringOrganizationUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringSettings Class
MonitoringSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringSettings.MonitoringOrganizationUserAccount Property
[image]

Gets or sets the user account to be used when monitoring the organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MonitoringOrganizationUserAccount As String

C#
[DataMemberAttribute]
public string MonitoringOrganizationUserAccount { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of a user account.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringSettings Class
MonitoringSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringSettings.MonitoringOrganizationUserPassword Property
[image]

Gets or sets the user account password to be used when monitoring the organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MonitoringOrganizationUserPassword As String

C#
[DataMemberAttribute]
public string MonitoringOrganizationUserPassword { get; set; }

C++

J#

JScript

Property Value
Type: String
The password for the user account.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringSettings Class
MonitoringSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringSettings.ResultsToKeep Property
[image]

Gets or sets the number of monitoring results to keep.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResultsToKeep As Integer

C#
[DataMemberAttribute]
public int ResultsToKeep { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of results to keep.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringSettings Class
MonitoringSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringSettings.ResultsToKeepInDatabase Property
[image]

Gets or sets the number of monitoring results to keep in the database.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ResultsToKeepInDatabase As Integer

C#
[DataMemberAttribute]
public int ResultsToKeepInDatabase { get; set; }

C++

J#

JScript

Property Value
Type: Int32
Number of monitoring results to keep in the database.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringSettings Class
MonitoringSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MonitoringSettings.StoreResultsInDatabase Property
[image]

Gets or sets whether monitoring results should be kept in the database.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property StoreResultsInDatabase As Boolean

C#
[DataMemberAttribute]
public bool StoreResultsInDatabase { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if results should be kept in the database; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MonitoringSettings Class
MonitoringSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MultiEntityQuickFindSettings Class
See Also Members
[image]

Contains settings for multi-entity quick find (finds records of different types).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="MultiEntityQuickFindSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class MultiEntityQuickFindSettings
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="MultiEntityQuickFindSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class MultiEntityQuickFindSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
You can use Windows PowerShell to retrieve or update these settings.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.MultiEntityQuickFindSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MultiEntityQuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


MultiEntityQuickFindSettings Members
See Also Constructors Methods Properties
[image]

Contains settings for multi-entity quick find (finds records of different types).

The following tables list the members exposed by the MultiEntityQuickFindSettings type.

Public Constructors

Name | Description
MultiEntityQuickFindSettings | Initializes a new instance of the MultiEntityQuickFindSettings class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MultiEntityQuickFindDegreeOfParallelism | Gets or sets the maximum degree of parallelism for multi-entity search queries. Required.
public property | MultiEntityQuickFindEntityLimit | Gets or sets the upper limit for the number of entities that can participate in a multi-entity search query. Required.
public property | MultiEntityQuickFindMaxRequestsPerOrgPerServer | Gets or sets the maximum number of concurrent ExecuteQuickFind requests per organization per server. Required.
public property | MultiEntityQuickFindMaxRequestsPerServer | Gets or sets the maximum number of concurrent ExecuteQuickFind requests per server. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MultiEntityQuickFindSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


MultiEntityQuickFindSettings Constructor
[image]

Initializes a new instance of the MultiEntityQuickFindSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MultiEntityQuickFindSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MultiEntityQuickFindSettings Class
MultiEntityQuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MultiEntityQuickFindSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MultiEntityQuickFindSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


MultiEntityQuickFindSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MultiEntityQuickFindDegreeOfParallelism | Gets or sets the maximum degree of parallelism for multi-entity search queries. Required.
public property | MultiEntityQuickFindEntityLimit | Gets or sets the upper limit for the number of entities that can participate in a multi-entity search query. Required.
public property | MultiEntityQuickFindMaxRequestsPerOrgPerServer | Gets or sets the maximum number of concurrent ExecuteQuickFind requests per organization per server. Required.
public property | MultiEntityQuickFindMaxRequestsPerServer | Gets or sets the maximum number of concurrent ExecuteQuickFind requests per server. Required.

See Also

Reference

MultiEntityQuickFindSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


MultiEntityQuickFindSettings.MultiEntityQuickFindDegreeOfParallelism Property
[image]

Gets or sets the maximum degree of parallelism for multi-entity search queries. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MultiEntityQuickFindDegreeOfParallelism As Integer

C#
[DataMemberAttribute]
public int MultiEntityQuickFindDegreeOfParallelism { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum degree of parallelism for multi-entity search queries.
The default value for this setting is 5.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MultiEntityQuickFindSettings Class
MultiEntityQuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MultiEntityQuickFindSettings.MultiEntityQuickFindEntityLimit Property
[image]

Gets or sets the upper limit for the number of entities that can participate in a multi-entity search query. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MultiEntityQuickFindEntityLimit As Integer

C#
[DataMemberAttribute]
public int MultiEntityQuickFindEntityLimit { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The upper limit for the number of entities that can participate in a multi-entity search query.
The default value for this setting is 10.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MultiEntityQuickFindSettings Class
MultiEntityQuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MultiEntityQuickFindSettings.MultiEntityQuickFindMaxRequestsPerOrgPerServer Property
[image]

Gets or sets the maximum number of concurrent ExecuteQuickFind requests per organization per server. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MultiEntityQuickFindMaxRequestsPerOrgPerServer As Integer

C#
[DataMemberAttribute]
public int MultiEntityQuickFindMaxRequestsPerOrgPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of concurrent ExecuteQuickFind requests per organization per server.
The default value is -1, which means that the requests are not throttled.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MultiEntityQuickFindSettings Class
MultiEntityQuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


MultiEntityQuickFindSettings.MultiEntityQuickFindMaxRequestsPerServer Property
[image]

Gets or sets the maximum number of concurrent ExecuteQuickFind requests per server. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MultiEntityQuickFindMaxRequestsPerServer As Integer

C#
[DataMemberAttribute]
public int MultiEntityQuickFindMaxRequestsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of concurrent ExecuteQuickFind requests per server.
The default value is -1, which means that the requests are not throttled.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MultiEntityQuickFindSettings Class
MultiEntityQuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


OAuthClaimsSettings Class
See Also Members
[image]

Contains the settings for claims based OAuth authentication.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OAuthClaimsSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class OAuthClaimsSettings
    Inherits ClaimsSettingsBase

C#
[DataContractAttribute(Name="OAuthClaimsSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class OAuthClaimsSettings : ClaimsSettingsBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings

                Microsoft.Xrm.Sdk.Deployment.ClaimsSettingsBase
        Microsoft.Xrm.Sdk.Deployment.OAuthClaimsSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OAuthClaimsSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
ClaimsSettings
Other Resources
OAuth 2.0


OAuthClaimsSettings Members
See Also Constructors Methods Properties
[image]

Contains the settings for claims based OAuth authentication.

The following tables list the members exposed by the OAuthClaimsSettings type.

Public Constructors

Name | Description
OAuthClaimsSettings | Initializes a new instance of the OAuthClaimsSettings class.
Top

Public Properties

 | Name | Description
public property | Enabled | Gets or sets whether the setting is enabled. (inherited from ClaimsSettingsBase)
public property | EncryptionCertificate | Gets or sets the encryption certificate. (inherited from ClaimsSettingsBase)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FederationMetadataUrl | Gets or sets the federation metadata URL. (inherited from ClaimsSettingsBase)
public property | FederationProviderType | Gets or sets the federation provider type. (inherited from ClaimsSettingsBase)
public property | SessionSecurityTokenLifetimeInHours | Gets or sets the session security token lifetime. (inherited from ClaimsSettingsBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OAuthClaimsSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace
ClaimsSettings

Other Resources

OAuth 2.0


OAuthClaimsSettings Constructor
[image]

Initializes a new instance of the OAuthClaimsSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OAuthClaimsSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OAuthClaimsSettings Class
OAuthClaimsSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


OAuthClaimsSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OAuthClaimsSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace
ClaimsSettings

Other Resources

OAuth 2.0


OAuthClaimsSettings Properties
[image]

Public Properties

 | Name | Description
public property | Enabled | Gets or sets whether the setting is enabled. (inherited from ClaimsSettingsBase)
public property | EncryptionCertificate | Gets or sets the encryption certificate. (inherited from ClaimsSettingsBase)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FederationMetadataUrl | Gets or sets the federation metadata URL. (inherited from ClaimsSettingsBase)
public property | FederationProviderType | Gets or sets the federation provider type. (inherited from ClaimsSettingsBase)
public property | SessionSecurityTokenLifetimeInHours | Gets or sets the session security token lifetime. (inherited from ClaimsSettingsBase)

See Also

Reference

OAuthClaimsSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace
ClaimsSettings

Other Resources

OAuth 2.0


Organization Class
See Also Members
[image]

Contains information about an organization in a Microsoft Dynamics CRM deployment.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="Organization", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class Organization
    Inherits DeploymentEntity

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="Organization", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class Organization : DeploymentEntity

C++

J#

JScript

  Remarks
The properties for an organization are set when the organization is created. Most of the properties can’t be updated after the fact. You can also use Windows PowerShell to access the same organization information.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentEntity
      Microsoft.Xrm.Sdk.Deployment.Organization
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


Organization Members
See Also Constructors Methods Properties
[image]

Contains information about an organization in a Microsoft Dynamics CRM deployment.

The following tables list the members exposed by the Organization type.

Public Constructors

Name | Description
Organization | Initializes a new instance of the Organization class.
Top

Public Properties

 | Name | Description
public property | BaseCurrencyCode | Gets or sets the base currency code for the organization.
public property | BaseCurrencyName | Gets or sets the base currency name for the organization.
public property | BaseCurrencyPrecision | Gets or sets the number of decimal places that can be used for the base currency.
public property | BaseCurrencySymbol | Gets or sets the base currency symbol for the organization.
public property | BaseLanguageCode | Gets or sets the base language code for the organization.
public property | DatabaseName | Gets or sets the database name for the organization.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FriendlyName | Gets or sets the display name, or long name, of the organization database.
public property | Id | Gets the organization ID.
public property | SqlCollation | Gets or sets the SQL collation property that the organization will use to sort and compare data characters.
public property | SqlServerName | Gets or sets the name of the SQL server on which the organization database is installed.
public property | SqmIsEnabled | Gets or sets whether information is being collected for the customer experience improvement program.
public property | SrsUrl | Gets or sets the URL of the Microsoft SQL Server on which the Microsoft Dynamics CRM Connector for SQL Server Reporting Services is installed.
public property | State | Gets or sets the organization state.
public property | UniqueName | Gets or sets the unique name for the organization.
public property | Version | Gets the current updated version of organization.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Organization Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


Organization Constructor
[image]

Initializes a new instance of the Organization class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public Organization ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Organization Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


Organization Properties
[image]

Public Properties

 | Name | Description
public property | BaseCurrencyCode | Gets or sets the base currency code for the organization.
public property | BaseCurrencyName | Gets or sets the base currency name for the organization.
public property | BaseCurrencyPrecision | Gets or sets the number of decimal places that can be used for the base currency.
public property | BaseCurrencySymbol | Gets or sets the base currency symbol for the organization.
public property | BaseLanguageCode | Gets or sets the base language code for the organization.
public property | DatabaseName | Gets or sets the database name for the organization.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FriendlyName | Gets or sets the display name, or long name, of the organization database.
public property | Id | Gets the organization ID.
public property | SqlCollation | Gets or sets the SQL collation property that the organization will use to sort and compare data characters.
public property | SqlServerName | Gets or sets the name of the SQL server on which the organization database is installed.
public property | SqmIsEnabled | Gets or sets whether information is being collected for the customer experience improvement program.
public property | SrsUrl | Gets or sets the URL of the Microsoft SQL Server on which the Microsoft Dynamics CRM Connector for SQL Server Reporting Services is installed.
public property | State | Gets or sets the organization state.
public property | UniqueName | Gets or sets the unique name for the organization.
public property | Version | Gets the current updated version of organization.

See Also

Reference

Organization Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


Organization.BaseCurrencyCode Property
[image]

Gets or sets the base currency code for the organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property BaseCurrencyCode As String

C#
[DataMemberAttribute]
public string BaseCurrencyCode { get; set; }

C++

J#

JScript

Property Value
Type: String

The base currency code for the organization.

  Remarks
This property is required when using the BeginCreateOrganizationRequest class. This property cannot be updated after the organization is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.BaseCurrencyName Property
[image]

Gets or sets the base currency name for the organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property BaseCurrencyName As String

C#
[DataMemberAttribute]
public string BaseCurrencyName { get; set; }

C++

J#

JScript

Property Value
Type: String

The base currency name for the organization.

  Remarks
This property is optional when using the BeginCreateOrganizationRequest class. If not specified the default will be generated based on the base currency code. This property cannot be updated after the organization is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.BaseCurrencyPrecision Property
[image]

Gets or sets the number of decimal places that can be used for the base currency.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property BaseCurrencyPrecision As Integer

C#
[DataMemberAttribute]
public int BaseCurrencyPrecision { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The number of decimal places for the currency for the organization.

  Remarks
This property is optional when using the BeginCreateOrganizationRequest class. If not specified the default will be generated based on the base currency code. This property cannot be updated after the organization is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.BaseCurrencySymbol Property
[image]

Gets or sets the base currency symbol for the organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property BaseCurrencySymbol As String

C#
[DataMemberAttribute]
public string BaseCurrencySymbol { get; set; }

C++

J#

JScript

Property Value
Type: String

The base currency symbol for the organization.

  Remarks
This property is optional when using the BeginCreateOrganizationRequest class. If not specified the default will be generated based on the base currency code. This property cannot be updated after the organization is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.BaseLanguageCode Property
[image]

Gets or sets the base language code for the organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property BaseLanguageCode As Integer

C#
[DataMemberAttribute]
public int BaseLanguageCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The base language code for the organization.

  Remarks
This property is required when using the BeginCreateOrganizationRequest class. This property cannot be updated after the organization is created. For more information about language packs, see the Installation Guide: Language Pack Installation Instructions.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.DatabaseName Property
[image]

Gets or sets the database name for the organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DatabaseName As String

C#
[DataMemberAttribute]
public string DatabaseName { get; set; }

C++

J#

JScript

Property Value
Type: String

The database name for the organization.

  Remarks
This property is required when using the BeginCreateOrganizationRequest class. This property cannot be updated after the organization is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.FriendlyName Property
[image]

Gets or sets the display name, or long name, of the organization database.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FriendlyName As String

C#
[DataMemberAttribute]
public string FriendlyName { get; set; }

C++

J#

JScript

Property Value
Type: String

The display name, or long name, of the organization database.

  Remarks
This property is required when using the BeginCreateOrganizationRequest class. It is optional when using the BeginUpdateOrganizationRequest class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.Id Property
[image]

Gets the organization ID.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The organization ID.

  Remarks
This property is assigned a value when the organization is created. This property is required when using the BeginUpdateOrganizationRequest class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.SqlCollation Property
[image]

Gets or sets the SQL collation property that the organization will use to sort and compare data characters.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SqlCollation As String

C#
[DataMemberAttribute]
public string SqlCollation { get; set; }

C++

J#

JScript

Property Value
Type: String

The SQL collation property that the organization will use to sort and compare data characters.

  Remarks
This property is required when using the BeginCreateOrganizationRequest class. This property cannot be updated after the organization is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Collation and Unicode Support


Organization.SqlServerName Property
[image]

Gets or sets the name of the SQL server on which the organization database is installed.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SqlServerName As String

C#
[DataMemberAttribute]
public string SqlServerName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the SQL server on which the organization database is installed.

  Remarks
This property is required when using the BeginCreateOrganizationRequest class. This property is optional when using the BeginUpdateOrganizationRequest class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.SqmIsEnabled Property
[image]

Gets or sets whether information is being collected for the customer experience improvement program.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SqmIsEnabled As Boolean

C#
[DataMemberAttribute]
public bool SqmIsEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if information is being collected for the customer experience improvement program; otherwise, false.

  Remarks
This property is optional when using the BeginCreateOrganizationRequest class. If not specified the value is false. This property cannot be updated after the organization is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Microsoft Customer Experience Improvement Program


Organization.SrsUrl Property
[image]

Gets or sets the URL of the Microsoft SQL Server on which the Microsoft Dynamics CRM Connector for SQL Server Reporting Services is installed.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SrsUrl As String

C#
[DataMemberAttribute]
public string SrsUrl { get; set; }

C++

J#

JScript

Property Value
Type: String

The URL of the Microsoft SQL Server on which the Microsoft Dynamics CRM Connector for SQL Server Reporting Services is installed.

  Remarks
This property is required when using the BeginCreateOrganizationRequest class. This property is optional when using the BeginUpdateOrganizationRequest class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.State Property
[image]

Gets or sets the organization state.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property State As OrganizationState

C#
[DataMemberAttribute]
public OrganizationState State { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationState
The organization state.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.UniqueName Property
[image]

Gets or sets the unique name for the organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UniqueName As String

C#
[DataMemberAttribute]
public string UniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String

The unique name for the organization.

  Remarks
This property is optional when using the BeginCreateOrganizationRequest class. If not specified a unique name is generated using the friendly name. This property cannot be updated after the organization is created. The maximum length is 30 characters. Spaces and extended characters are not allowed
The following words are a partial list of invalid unique names. Also included in this lists are offensive words, not listed here.

                                    Invalid name

About

Activities

AdvancedFind

api

AppWebServices

aspnet_client

bi

bin

Biz

Calendar

Condition

CRMReports

CS

dev

Help

Home

Import

MA

MSCRMServices

Notes

Products

rc

Reports

ReportServer

ResourceCenter

Sdk

SFA

signin

SM

support

Tools

tsweb

UnitTests

UserDefined

Workplace

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


Organization.Version Property
[image]

Gets the current updated version of organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Version As String

C#
[DataMemberAttribute]
public string Version { get; set; }

C++

J#

JScript

Property Value
Type: String

The current updated version of organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Organization Class
Organization Members
Microsoft.Xrm.Sdk.Deployment Namespace


OrganizationState Enumeration
[image]

Describes the state of the organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OrganizationState", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Crm")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Enumeration OrganizationState

C#
[DataContractAttribute(Name="OrganizationState", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Crm")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public enum OrganizationState

C++

J#

JScript

  Members
Member name | Description
Disabled | Specifies that the organization is disabled. Value = 0.
Enabled | Specifies that the organization is enabled. Value = 1.
Failed | Specifies that the organization is in a failure state. Value = 3.
Maintenance | Specifies that the organization is undergoing maintenance. Value = 4.
Pending | Specifies that the organization is pending. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace


OrganizationUserInfo Class
See Also Members
[image]

Contains information about a user in an organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="OrganizationUserInfo", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")> _
<DebuggerStepThroughAttribute> _
Public Class OrganizationUserInfo
    Implements IExtensibleDataObject

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="OrganizationUserInfo", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")]
[DebuggerStepThroughAttribute]
public class OrganizationUserInfo : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Deployment.OrganizationUserInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationUserInfo Members
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseResponse


OrganizationUserInfo Members
See Also Constructors Methods Properties
[image]

Contains information about a user in an organization.

The following tables list the members exposed by the OrganizationUserInfo type.

Public Constructors

Name | Description
OrganizationUserInfo | Initializes a new instance of theOrganizationUserInfo class.
Top

Public Properties

 | Name | Description
public property | CalType | Gets or sets the type of client access license for the user.
public property | DomainName | Gets or sets the domain name for the user.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | FullName | Gets or sets the full name of the user.
public property | LastAccessServer | Gets or sets the date the server was accessed by the user.
public property | LastAccessTime | Gets or sets the time the server was accessed by the user.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrganizationUserInfo Class
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseResponse


OrganizationUserInfo Constructor
[image]

Initializes a new instance of the OrganizationUserInfo class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrganizationUserInfo ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationUserInfo Class
OrganizationUserInfo Members
Microsoft.Xrm.Sdk.Deployment Namespace


OrganizationUserInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrganizationUserInfo Class
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseResponse


OrganizationUserInfo Properties
[image]

Public Properties

 | Name | Description
public property | CalType | Gets or sets the type of client access license for the user.
public property | DomainName | Gets or sets the domain name for the user.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | FullName | Gets or sets the full name of the user.
public property | LastAccessServer | Gets or sets the date the server was accessed by the user.
public property | LastAccessTime | Gets or sets the time the server was accessed by the user.

See Also

Reference

OrganizationUserInfo Class
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseResponse


OrganizationUserInfo.CalType Property
[image]

Gets or sets the type of client access license for the user.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CalType As Integer

C#
[DataMemberAttribute]
public int CalType { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The license type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationUserInfo Class
OrganizationUserInfo Members
Microsoft.Xrm.Sdk.Deployment Namespace
LicenseType


OrganizationUserInfo.DomainName Property
[image]

Gets or sets the domain name for the user.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DomainName As String

C#
[DataMemberAttribute]
public string DomainName { get; set; }

C++

J#

JScript

Property Value
Type: String
The domain name.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationUserInfo Class
OrganizationUserInfo Members
Microsoft.Xrm.Sdk.Deployment Namespace


OrganizationUserInfo.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationUserInfo Class
OrganizationUserInfo Members
Microsoft.Xrm.Sdk.Deployment Namespace


OrganizationUserInfo.FullName Property
[image]

Gets or sets the full name of the user.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FullName As String

C#
[DataMemberAttribute]
public string FullName { get; set; }

C++

J#

JScript

Property Value
Type:  Int32
The user’s full name.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationUserInfo Class
OrganizationUserInfo Members
Microsoft.Xrm.Sdk.Deployment Namespace


OrganizationUserInfo.LastAccessServer Property
[image]

Gets or sets the date the server was accessed by the user.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LastAccessServer As String

C#
[DataMemberAttribute]
public string LastAccessServer { get; set; }

C++

J#

JScript

Property Value
Type:  String
A string containing the date of the last server access.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationUserInfo Class
OrganizationUserInfo Members
Microsoft.Xrm.Sdk.Deployment Namespace


OrganizationUserInfo.LastAccessTime Property
[image]

Gets or sets the time the server was accessed by the user.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LastAccessTime As DateTime

C#
[DataMemberAttribute]
public DateTime LastAccessTime { get; set; }

C++

J#

JScript

Property Value
Type:  DateTime
Contains the time of the last server access.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationUserInfo Class
OrganizationUserInfo Members
Microsoft.Xrm.Sdk.Deployment Namespace


QuickFindSettings Class
See Also Members
[image]

Contains settings for quick find (finds records of one type).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="QuickFindSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class QuickFindSettings
    Inherits DeploymentConfigSettings

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="QuickFindSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class QuickFindSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
You can use Windows PowerShell to retrieve or update these settings.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.QuickFindSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
QuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


QuickFindSettings Members
See Also Constructors Methods Properties
[image]

Contains settings for quick find (finds records of one type).

The following tables list the members exposed by the QuickFindSettings type.

Public Constructors

Name | Description
QuickFindSettings | Initializes a new instance of the QuickFindSettings class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | QuickFindEntityIndexLimit | Gets or sets the maximum number of the attributes used in the quick find search query, after which the QuickFind indexes are not created. Required.
public property | QuickFindRecordLimit | Gets or sets the maximum number of records that match the quick find query criteria before an exception error is thrown. This is needed for faster execution of the quick find searches. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QuickFindSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


QuickFindSettings Constructor
[image]

Initializes a new instance of the QuickFindSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QuickFindSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
QuickFindSettings Class
QuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


QuickFindSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QuickFindSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


QuickFindSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | QuickFindEntityIndexLimit | Gets or sets the maximum number of the attributes used in the quick find search query, after which the QuickFind indexes are not created. Required.
public property | QuickFindRecordLimit | Gets or sets the maximum number of records that match the quick find query criteria before an exception error is thrown. This is needed for faster execution of the quick find searches. Required.

See Also

Reference

QuickFindSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


QuickFindSettings.QuickFindEntityIndexLimit Property
[image]

Gets or sets the maximum number of the attributes used in the quick find search query, after which the QuickFind indexes are not created. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property QuickFindEntityIndexLimit As Integer

C#
[DataMemberAttribute]
public int QuickFindEntityIndexLimit { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of the attributes used in the quick find search query, after which the QuickFind indexes are not created.
The default value for this setting is 20.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
QuickFindSettings Class
QuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


QuickFindSettings.QuickFindRecordLimit Property
[image]

Gets or sets the maximum number of records that match the quick find query criteria before an exception error is thrown. This is needed for faster execution of the quick find searches. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property QuickFindRecordLimit As Integer

C#
[DataMemberAttribute]
public int QuickFindRecordLimit { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of records that match the quick find query criteria before an exception error is thrown.
The default value for this setting is 10000.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
QuickFindSettings Class
QuickFindSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


RequestCheckResult Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="RequestCheckResult", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")> _
Public Class RequestCheckResult
    Inherits DeploymentObject

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="RequestCheckResult", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")]
public class RequestCheckResult : DeploymentObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject
    Microsoft.Xrm.Sdk.Deployment.RequestCheckResult
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestCheckResult Members
Microsoft.Xrm.Sdk.Deployment Namespace


RequestCheckResult Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the RequestCheckResult type.

Public Constructors

Name | Description
RequestCheckResult | Initializes a new instance of the RequestCheckResult class.
Top

Public Properties

 | Name | Description
public property | Description | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | Level | For internal use only.
public property | Tag | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RequestCheckResult Class
Microsoft.Xrm.Sdk.Deployment Namespace


RequestCheckResult Constructor
[image]

Initializes a new instance of the RequestCheckResult class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RequestCheckResult ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestCheckResult Class
RequestCheckResult Members
Microsoft.Xrm.Sdk.Deployment Namespace


RequestCheckResult Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RequestCheckResult Class
Microsoft.Xrm.Sdk.Deployment Namespace


RequestCheckResult Properties
[image]

Public Properties

 | Name | Description
public property | Description | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | Level | For internal use only.
public property | Tag | For internal use only.

See Also

Reference

RequestCheckResult Class
Microsoft.Xrm.Sdk.Deployment Namespace


RequestCheckResult.Description Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Description As String

C#
[DataMemberAttribute]
public string Description { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestCheckResult Class
RequestCheckResult Members
Microsoft.Xrm.Sdk.Deployment Namespace


RequestCheckResult.Level Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Level As DeploymentErrorLevel

C#
[DataMemberAttribute]
public DeploymentErrorLevel Level { get; set; }

C++

J#

JScript

Property Value
Type: DeploymentErrorLevel
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestCheckResult Class
RequestCheckResult Members
Microsoft.Xrm.Sdk.Deployment Namespace


RequestCheckResult.Tag Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Tag As String

C#
[DataMemberAttribute]
public string Tag { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestCheckResult Class
RequestCheckResult Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveAdvancedSettingsRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve advanced settings from the configuration database. For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="RetrieveAdvancedSettingsRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class RetrieveAdvancedSettingsRequest
    Inherits DeploymentServiceRequest

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="RetrieveAdvancedSettingsRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class RetrieveAdvancedSettingsRequest : DeploymentServiceRequest

C++

J#

JScript

  Remarks
Pass an instance of this class to the Execute method, which returns an instance of RetrieveAdvancedSettingsResponse.
You can also use the Get-CrmAdvancedSettingWindows PowerShell command. For more information, see Administer the deployment using Windows PowerShell. Note that only the settings that are writable are documented in the SDK.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.RetrieveAdvancedSettingsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAdvancedSettingsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAdvancedSettingsResponse
Other Resources
Get-CrmAdvancedSetting


RetrieveAdvancedSettingsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve advanced settings from the configuration database. For internal use only.

The following tables list the members exposed by the RetrieveAdvancedSettingsRequest type.

Public Constructors

Name | Description
RetrieveAdvancedSettingsRequest | Initializes a new instance of the RetrieveAdvancedSettingsRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the set of columns or attributes to be retrieved.
public property | ConfigurationEntityName | Gets of sets the name of the configuration entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Id | Gets or sets the ID of the record to be retrieved.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAdvancedSettingsRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAdvancedSettingsResponse

Other Resources

Get-CrmAdvancedSetting


RetrieveAdvancedSettingsRequest Constructor
[image]

Initializes a new instance of the RetrieveAdvancedSettingsRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAdvancedSettingsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAdvancedSettingsRequest Class
RetrieveAdvancedSettingsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveAdvancedSettingsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAdvancedSettingsRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAdvancedSettingsResponse

Other Resources

Get-CrmAdvancedSetting


RetrieveAdvancedSettingsRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the set of columns or attributes to be retrieved.
public property | ConfigurationEntityName | Gets of sets the name of the configuration entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Id | Gets or sets the ID of the record to be retrieved.

See Also

Reference

RetrieveAdvancedSettingsRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAdvancedSettingsResponse

Other Resources

Get-CrmAdvancedSetting


RetrieveAdvancedSettingsRequest.ColumnSet Property
[image]

Gets or sets the set of columns or attributes to be retrieved.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property ColumnSet As ColumnSet

C#
[DataMemberAttribute(IsRequired=true)]
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The set of columns or attributes to be retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAdvancedSettingsRequest Class
RetrieveAdvancedSettingsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveAdvancedSettingsRequest.ConfigurationEntityName Property
[image]

Gets of sets the name of the configuration entity.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property ConfigurationEntityName As String

C#
[DataMemberAttribute(IsRequired=true)]
public string ConfigurationEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the configuration entity.

  Remarks
This is the configuration database table name.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAdvancedSettingsRequest Class
RetrieveAdvancedSettingsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveAdvancedSettingsRequest.Id Property
[image]

Gets or sets the ID of the record to be retrieved.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the record to be retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAdvancedSettingsRequest Class
RetrieveAdvancedSettingsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveAdvancedSettingsResponse Class
See Also Members
[image]

Contains the response from the RetrieveAdvancedSettingsRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="RetrieveAdvancedSettingsResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class RetrieveAdvancedSettingsResponse
    Inherits DeploymentServiceResponse

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="RetrieveAdvancedSettingsResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class RetrieveAdvancedSettingsResponse : DeploymentServiceResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.RetrieveAdvancedSettingsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAdvancedSettingsResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAdvancedSettingsRequest


RetrieveAdvancedSettingsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAdvancedSettingsRequest.

The following tables list the members exposed by the RetrieveAdvancedSettingsResponse type.

Public Constructors

Name | Description
RetrieveAdvancedSettingsResponse | Initializes a new instance of the RetrieveAdvancedSettingsResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets or sets the configuration entity that was retrieved.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAdvancedSettingsResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAdvancedSettingsRequest


RetrieveAdvancedSettingsResponse Constructor
[image]

Initializes a new instance of the RetrieveAdvancedSettingsResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAdvancedSettingsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAdvancedSettingsResponse Class
RetrieveAdvancedSettingsResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveAdvancedSettingsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAdvancedSettingsResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAdvancedSettingsRequest


RetrieveAdvancedSettingsResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets or sets the configuration entity that was retrieved.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)

See Also

Reference

RetrieveAdvancedSettingsResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAdvancedSettingsRequest


RetrieveAdvancedSettingsResponse.Entity Property
[image]

Gets or sets the configuration entity that was retrieved.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Entity As ConfigurationEntity

C#
[DataMemberAttribute]
public ConfigurationEntity Entity { get; set; }

C++

J#

JScript

Property Value
Returns ConfigurationEntity
The configuration entity that was retrieved.

  Remarks
The configuration entity retrieved contains an collection of attribute values.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAdvancedSettingsResponse Class
RetrieveAdvancedSettingsResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveAllRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve all deployment records of the specified deployment entity type.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="RetrieveAllRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class RetrieveAllRequest
    Inherits DeploymentServiceRequest

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="RetrieveAllRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class RetrieveAllRequest : DeploymentServiceRequest

C++

J#

JScript

  Remarks
Pass an instance of this class to the Execute method, which returns an instance of RetrieveAllResponse.
You can also use the corresponding Windows PowerShell command for the deployment entity you want to retrieve. For example, Get-CrmOrganization or Get-CrmSetting. For more information, see Administer the deployment using Windows PowerShell.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.RetrieveAllRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAllRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllResponse
Other Resources
Administer the deployment using Windows PowerShell


RetrieveAllRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve all deployment records of the specified deployment entity type.

The following tables list the members exposed by the RetrieveAllRequest type.

Public Constructors

Name | Description
RetrieveAllRequest | Initializes a new instance of the RetrieveAllRequest class.
Top

Public Properties

 | Name | Description
public property | EntityType | Gets or sets the type of deployment entity to be retrieved.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllResponse

Other Resources

Administer the deployment using Windows PowerShell


RetrieveAllRequest Constructor
[image]

Initializes a new instance of the RetrieveAllRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAllRequest Class
RetrieveAllRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveAllRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllResponse

Other Resources

Administer the deployment using Windows PowerShell


RetrieveAllRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityType | Gets or sets the type of deployment entity to be retrieved.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)

See Also

Reference

RetrieveAllRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllResponse

Other Resources

Administer the deployment using Windows PowerShell


RetrieveAllRequest.EntityType Property
[image]

Gets or sets the type of deployment entity to be retrieved.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityType As DeploymentEntityType

C#
[DataMemberAttribute]
public DeploymentEntityType EntityType { get; set; }

C++

J#

JScript

Property Value
Type: DeploymentEntityType
The type of deployment entity to be retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAllRequest Class
RetrieveAllRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use Deployment Entities and Deployment Configuration Settings


RetrieveAllResponse Class
See Also Members
[image]

Contains the response from the RetrieveAllRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveAllResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class RetrieveAllResponse
    Inherits DeploymentServiceResponse

C#
[DataContractAttribute(Name="RetrieveAllResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class RetrieveAllResponse : DeploymentServiceResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.RetrieveAllResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAllResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllRequest


RetrieveAllResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAllRequest.

The following tables list the members exposed by the RetrieveAllResponse type.

Public Constructors

Name | Description
RetrieveAllResponse | Initializes a new instance of the RetrieveAllResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | InstanceTags | Gets or sets the collection of IDs or instance tags for all the deployment records retrieved.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllRequest


RetrieveAllResponse Constructor
[image]

Initializes a new instance of the RetrieveAllResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAllResponse Class
RetrieveAllResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveAllResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllRequest


RetrieveAllResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | InstanceTags | Gets or sets the collection of IDs or instance tags for all the deployment records retrieved.

See Also

Reference

RetrieveAllResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveAllRequest


RetrieveAllResponse.InstanceTags Property
[image]

Gets or sets the collection of IDs or instance tags for all the deployment records retrieved.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property InstanceTags As DataCollection(Of EntityInstanceId)

C#
[DataMemberAttribute]
public DataCollection<EntityInstanceId> InstanceTags { get; set; }

C++

J#

JScript

Property Value
Type: DataCollection<EntityInstanceId>
The collection of IDs or instance tags for all the deployment records retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveAllResponse Class
RetrieveAllResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsRequest Class
See Also Members
[image]

Contains the data that is required to retrieve results from the monitoring service operation tests for your Microsoft Dynamics CRM deployment.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveMonitoringResultsRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class RetrieveMonitoringResultsRequest
    Inherits DeploymentServiceRequest

C#
[DataContractAttribute(Name="RetrieveMonitoringResultsRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class RetrieveMonitoringResultsRequest : DeploymentServiceRequest

C++

J#

JScript

  Remarks
Usage
Pass an instance of this class to the Execute method, which returns an instance of the RetrieveMonitoringResultsResponse class.
Notes for Callers
You can also use the Get-CrmMonitoringResultWindows PowerShell command. For more information, see Microsoft Dynamics CRM PowerShell Reference.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.RetrieveMonitoringResultsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveMonitoringResultsResponse
Other Resources
Deployment Web Service Messages
Get-CrmMonitoringResult


RetrieveMonitoringResultsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is required to retrieve results from the monitoring service operation tests for your Microsoft Dynamics CRM deployment.

The following tables list the members exposed by the RetrieveMonitoringResultsRequest type.

Public Constructors

Name | Description
RetrieveMonitoringResultsRequest | Initializes a new instance of the RetrieveMonitoringResultsRequest class.
Top

Public Properties

 | Name | Description
public property | EndTime | Gets or sets the time to filter test results that were reported earlier than the specified time.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Roles | Gets or sets the CRM roles to filter the test result data.
public property | Servers | Gets or sets the server name to filter the test result data.
public property | ServiceHealth | Gets or sets a value that indicates whether to filter test results data on the deployment service health status.
public property | StartTime | Gets or sets the time to filter test results that were reported later than the specified time.
public property | Status | Gets or sets the test status to filter the test result data.
public property | TestName | Gets or sets the name of the test to filter the test result data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMonitoringResultsRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveMonitoringResultsResponse

Other Resources

Deployment Web Service Messages
Get-CrmMonitoringResult


RetrieveMonitoringResultsRequest Constructor
[image]

Initializes a new instance of the RetrieveMonitoringResultsRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMonitoringResultsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsRequest Class
RetrieveMonitoringResultsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMonitoringResultsRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveMonitoringResultsResponse

Other Resources

Deployment Web Service Messages
Get-CrmMonitoringResult


RetrieveMonitoringResultsRequest Properties
[image]

Public Properties

 | Name | Description
public property | EndTime | Gets or sets the time to filter test results that were reported earlier than the specified time.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | Roles | Gets or sets the CRM roles to filter the test result data.
public property | Servers | Gets or sets the server name to filter the test result data.
public property | ServiceHealth | Gets or sets a value that indicates whether to filter test results data on the deployment service health status.
public property | StartTime | Gets or sets the time to filter test results that were reported later than the specified time.
public property | Status | Gets or sets the test status to filter the test result data.
public property | TestName | Gets or sets the name of the test to filter the test result data.

See Also

Reference

RetrieveMonitoringResultsRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveMonitoringResultsResponse

Other Resources

Deployment Web Service Messages
Get-CrmMonitoringResult


RetrieveMonitoringResultsRequest.EndTime Property
[image]

Gets or sets the time to filter test results that were reported earlier than the specified time.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EndTime As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> EndTime { get; set; }

C++

J#

JScript

Property Value
Type DateTime
Time to filter test results that were reported earlier than the specified time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsRequest Class
RetrieveMonitoringResultsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsRequest.Roles Property
[image]

Gets or sets the CRM roles to filter the test result data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Roles As String

C#
[DataMemberAttribute]
public string Roles { get; set; }

C++

J#

JScript

Property Value
Type String
Roles to filter the test results.

  Remarks
Roles that can be specified for filtering the results are: AppServer, AsyncService, SrsDataConnector, DiscoveryService, EmailService, WebService, SqlServer, ApiServer, HelpServer, DeploymentService, SrsSqlServer, SandboxServer, and DeploymentManagementTools.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsRequest Class
RetrieveMonitoringResultsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsRequest.Servers Property
[image]

Gets or sets the server name to filter the test result data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Servers As String

C#
[DataMemberAttribute]
public string Servers { get; set; }

C++

J#

JScript

Property Value
Type String
Server name to filter the test results.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsRequest Class
RetrieveMonitoringResultsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsRequest.ServiceHealth Property
[image]

Gets or sets a value that indicates whether to filter test results data on the deployment service health status.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ServiceHealth As Boolean

C#
[DataMemberAttribute]
public bool ServiceHealth { get; set; }

C++

J#

JScript

Property Value
Type Boolean
Indicates whether to filter test results data on the deployment service health status.

  Remarks
Service health status can have one of the values as specified in the ServiceHealthStatus.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsRequest Class
RetrieveMonitoringResultsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsRequest.StartTime Property
[image]

Gets or sets the time to filter test results that were reported later than the specified time.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property StartTime As Nullable(Of DateTime)

C#
[DataMemberAttribute]
public Nullable<DateTime> StartTime { get; set; }

C++

J#

JScript

Property Value
Type DateTime
Time to filter test results that were reported later than the specified time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsRequest Class
RetrieveMonitoringResultsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsRequest.Status Property
[image]

Gets or sets the test status to filter the test result data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Status As String

C#
[DataMemberAttribute]
public string Status { get; set; }

C++

J#

JScript

Property Value
Type String
Test status to filter the test result data.

  Remarks
You can use the test status values as specified in TestStatus.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsRequest Class
RetrieveMonitoringResultsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsRequest.TestName Property
[image]

Gets or sets the name of the test to filter the test result data.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TestName As String

C#
[DataMemberAttribute]
public string TestName { get; set; }

C++

J#

JScript

Property Value
Type String
Name of the test to filter the test result data.

  Remarks
You can specify one of the following test names to filter your test result data: VerifyAsyncServiceMaintenanceRunning, VerifyAsyncServiceRunning, VerifySandboxServiceIsRunning, VerifyUnZipServiceIsRunning, VerifyVSSWriterServiceIsRunning, VerifyWebsiteIsRunning, VerifyApplicationAppPoolIsRunning, VerifyDeploymentWebServiceAppPoolIsRunning, CheckApiServer, CheckWebApp, VerifyActiveCrmKeys, VerifyAsyncBacklogTest, VerifyHelpContent, CheckReportServer, CheckCrmReporting, CheckReportServerFromSrsDataConnector, and CheckFetchBasedReport.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsRequest Class
RetrieveMonitoringResultsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsResponse Class
See Also Members
[image]

Contains the response from RetrieveMonitoringResultsRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="RetrieveMonitoringResultsResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class RetrieveMonitoringResultsResponse
    Inherits DeploymentServiceResponse

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="RetrieveMonitoringResultsResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class RetrieveMonitoringResultsResponse : DeploymentServiceResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.RetrieveMonitoringResultsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from RetrieveMonitoringResultsRequest.

The following tables list the members exposed by the RetrieveMonitoringResultsResponse type.

Public Constructors

Name | Description
RetrieveMonitoringResultsResponse | Initializes a new instance of the RetrieveMonitoringResultsResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | MonitoringResults | Gets or sets the retrieved monitoring results.
public property | ServiceHealth | Gets or sets the retrieved service health status.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMonitoringResultsResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsResponse Constructor
[image]

Initializes a new instance of the RetrieveMonitoringResultsResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMonitoringResultsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsResponse Class
RetrieveMonitoringResultsResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMonitoringResultsResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | MonitoringResults | Gets or sets the retrieved monitoring results.
public property | ServiceHealth | Gets or sets the retrieved service health status.

See Also

Reference

RetrieveMonitoringResultsResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsResponse.MonitoringResults Property
[image]

Gets or sets the retrieved monitoring results.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MonitoringResults As DataCollection(Of MonitoringResultData)

C#
[DataMemberAttribute]
public DataCollection<MonitoringResultData> MonitoringResults { get; set; }

C++

J#

JScript

Property Value
Type DataCollection
Retrieved monitoring results.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsResponse Class
RetrieveMonitoringResultsResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveMonitoringResultsResponse.ServiceHealth Property
[image]

Gets or sets the retrieved service health status.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ServiceHealth As ServiceHealthStatus

C#
[DataMemberAttribute]
public ServiceHealthStatus ServiceHealth { get; set; }

C++

J#

JScript

Property Value
Type ServiceHealthStatus
Retrieved service health status.

  Remarks
Service health status can be one of the values as specified in ServiceHealthStatus.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveMonitoringResultsResponse Class
RetrieveMonitoringResultsResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve a deployment entity or configuration settings record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class RetrieveRequest
    Inherits DeploymentServiceRequest

C#
[DataContractAttribute(Name="RetrieveRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class RetrieveRequest : DeploymentServiceRequest

C++

J#

JScript

  Example
C#    Copy Code
// By instantiating the DeploymentServiceClient in a using statement you ensure that the client
// communication channel is closed and the object is disposed when it goes out of scope.

// CustomBinding_IDeploymenService is the name of the configuration setting for the CustomBinding

using (DeploymentServiceClient client = new DeploymentServiceClient("CustomBinding_IDeploymentService"))
{

    //The EntityIstanceId class is used to identify the object you want to
    // retrieve. You have the option of using name or ID.
    EntityInstanceId id = new EntityInstanceId
    {
        Name = "AlpineSkiHouse"
    };
    //Retrieve the organization
    Organization organization = (Organization)client.Retrieve(DeploymentEntityType.Organization, id);

    client.Close();
}

The following is an example of an Organization class instance serialized to XML:
<?xml version="1.0" encoding="utf-8"?>
<Organization xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <ExtensionData />
  <BaseCurrencyCode>USD</BaseCurrencyCode>
  <BaseCurrencyName>US Dollar</BaseCurrencyName>
  <BaseCurrencyPrecision>2</BaseCurrencyPrecision>
  <BaseCurrencySymbol>$</BaseCurrencySymbol>
  <BaseLanguageCode>1033</BaseLanguageCode>
  <DatabaseName>AlpineSkiHouse_MSCRM</DatabaseName>
  <FriendlyName>Alpine Ski House</FriendlyName>
  <Id>273c0010-5973-43d4-b666-8d899ca8c6ab</Id>
  <SqlCollation>Latin1_General_CI_AI</SqlCollation>
  <SqlServerName>CRM01</SqlServerName>
  <SqmIsEnabled>false</SqmIsEnabled>
  <SrsUrl>http://crm01/reportserver</SrsUrl>
  <State>Pending</State>
  <UniqueName>AlpineSkiHouse</UniqueName>

  Remarks
Pass an instance of this class to the Execute method, which returns an instance of RetrieveResponse.
You can use this message to retrieve any of the valid entity types as specified by the DeploymentEntityType enumeration.
An organization deployment object has five possible states as defined by the OrganizationState enumeration.
You can also use the corresponding Windows PowerShell command for the deployment entity you want to retrieve, for example, Get-CrmOrganization or Get-CrmSetting. For more information, see Administer the deployment using Windows PowerShell.
Note that this is for the Deployment Web service. To retrieve organization data records, use RetrieveRequest.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.RetrieveRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
RetrieveRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveResponse
Other Resources
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


RetrieveRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a deployment entity or configuration settings record.

The following tables list the members exposed by the RetrieveRequest type.

Public Constructors

Name | Description
RetrieveRequest | Initializes a new instance of the RetrieveRequest class.
Top

Public Properties

 | Name | Description
public property | EntityType | Gets or sets the type of deployment entity to be retrieved.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | InstanceTag | Gets or sets the ID or instance tag of the deployment record to be retrieved.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveResponse

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


RetrieveRequest Constructor
[image]

Initializes a new instance of the RetrieveRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveRequest Class
RetrieveRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveResponse

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


RetrieveRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityType | Gets or sets the type of deployment entity to be retrieved.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | InstanceTag | Gets or sets the ID or instance tag of the deployment record to be retrieved.

See Also

Reference

RetrieveRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveResponse

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


RetrieveRequest.EntityType Property
[image]

Gets or sets the type of deployment entity to be retrieved.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property EntityType As DeploymentEntityType

C#
[DataMemberAttribute(IsRequired=true)]
public DeploymentEntityType EntityType { get; set; }

C++

J#

JScript

Property Value
Type: DeploymentEntityType
The type of deployment entity to be retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveRequest Class
RetrieveRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveRequest.InstanceTag Property
[image]

Gets or sets the ID or instance tag of the deployment record to be retrieved.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property InstanceTag As EntityInstanceId

C#
[DataMemberAttribute]
public EntityInstanceId InstanceTag { get; set; }

C++

J#

JScript

Property Value
Type: EntityInstanceId
The ID or instance tag of the deployment record to be retrieved.

  Remarks
To retrieve the status of an asynchronous operation, use the OperationId property to set the value of this property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveRequest Class
RetrieveRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveResponse Class
See Also Members
[image]

Contains the response from the RetrieveRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="RetrieveResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class RetrieveResponse
    Inherits DeploymentServiceResponse

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="RetrieveResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class RetrieveResponse : DeploymentServiceResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.RetrieveResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveRequest


RetrieveResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveRequest.

The following tables list the members exposed by the RetrieveResponse type.

Public Constructors

Name | Description
RetrieveResponse | Initializes a new instance of the RetrieveResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets or sets the record that was retrieved.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveRequest


RetrieveResponse Constructor
[image]

Initializes a new instance of the RetrieveResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveResponse Class
RetrieveResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveRequest


RetrieveResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets or sets the record that was retrieved.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)

See Also

Reference

RetrieveResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveRequest


RetrieveResponse.Entity Property
[image]

Gets or sets the record that was retrieved.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Entity As DeploymentObject

C#
[DataMemberAttribute]
public DeploymentObject Entity { get; set; }

C++

J#

JScript

Property Value
Type: DeploymentObject
The record that was retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveResponse Class
RetrieveResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Object Model


RetrieveUserMappingRequest Class
See Also Members
[image]

Contains the data needed to retrieve mapping information of existing users in a Microsoft Dynamics CRM organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="RetrieveUserMappingRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class RetrieveUserMappingRequest
    Inherits DeploymentServiceRequest

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="RetrieveUserMappingRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class RetrieveUserMappingRequest : DeploymentServiceRequest

C++

J#

JScript

  Remarks
Usage
Pass an instance of this class to the Execute method, which returns an instance of the RetrieveUserMappingResponse class.
Notes for Callers
You can also use the Get-CrmOrganizationUserMapWindows PowerShell command. For more information, see Administer the deployment using Windows PowerShell.
The retrieved information is in an XML format, which can be used to map the existing users from the current organization in the target deployment.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.RetrieveUserMappingRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveUserMappingRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveUserMappingResponse
Other Resources
Get-CrmOrganizationUserMap


RetrieveUserMappingRequest Members
See Also Constructors Methods Properties
[image]

Contains the data needed to retrieve mapping information of existing users in a Microsoft Dynamics CRM organization.

The following tables list the members exposed by the RetrieveUserMappingRequest type.

Public Constructors

Name | Description
RetrieveUserMappingRequest | Initializes a new instance of the RetrieveUserMappingRequest class.
Top

Public Properties

 | Name | Description
public property | DatabaseName | Gets or sets the name of the CRM database to import from.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | SqlServerName | Gets or sets the name of the Microsoft SQL Server instance that hosts the CRM database from where you want to import.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserMappingRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveUserMappingResponse

Other Resources

Get-CrmOrganizationUserMap


RetrieveUserMappingRequest Constructor
[image]

Initializes a new instance of the RetrieveUserMappingRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserMappingRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveUserMappingRequest Class
RetrieveUserMappingRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveUserMappingRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserMappingRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveUserMappingResponse

Other Resources

Get-CrmOrganizationUserMap


RetrieveUserMappingRequest Properties
[image]

Public Properties

 | Name | Description
public property | DatabaseName | Gets or sets the name of the CRM database to import from.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | SqlServerName | Gets or sets the name of the Microsoft SQL Server instance that hosts the CRM database from where you want to import.

See Also

Reference

RetrieveUserMappingRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
RetrieveUserMappingResponse

Other Resources

Get-CrmOrganizationUserMap


RetrieveUserMappingRequest.DatabaseName Property
[image]

Gets or sets the name of the CRM database to import from.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property DatabaseName As String

C#
[DataMemberAttribute(IsRequired=true)]
public string DatabaseName { get; set; }

C++

J#

JScript

Property Value
Type String
Name of the CRM database to import from.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveUserMappingRequest Class
RetrieveUserMappingRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveUserMappingRequest.SqlServerName Property
[image]

Gets or sets the name of the Microsoft SQL Server instance that hosts the CRM database from where you want to import.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property SqlServerName As String

C#
[DataMemberAttribute(IsRequired=true)]
public string SqlServerName { get; set; }

C++

J#

JScript

Property Value
Type String
Name of the Microsoft SQL Server instance that hosts the CRM database from where you want to import.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveUserMappingRequest Class
RetrieveUserMappingRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveUserMappingResponse Class
See Also Members
[image]

Contains the response from RetrieveUserMappingRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveUserMappingResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class RetrieveUserMappingResponse
    Inherits DeploymentServiceResponse

C#
[DataContractAttribute(Name="RetrieveUserMappingResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class RetrieveUserMappingResponse : DeploymentServiceResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.RetrieveUserMappingResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveUserMappingResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveUserMappingResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from RetrieveUserMappingRequest.

The following tables list the members exposed by the RetrieveUserMappingResponse type.

Public Constructors

Name | Description
RetrieveUserMappingResponse | Initializes a new instance of the RetrieveUserMappingResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | UserMapping | Gets or sets the retrieved user mapping information.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserMappingResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveUserMappingResponse Constructor
[image]

Initializes a new instance of the RetrieveUserMappingResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserMappingResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveUserMappingResponse Class
RetrieveUserMappingResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveUserMappingResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserMappingResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveUserMappingResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | UserMapping | Gets or sets the retrieved user mapping information.

See Also

Reference

RetrieveUserMappingResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace


RetrieveUserMappingResponse.UserMapping Property
[image]

Gets or sets the retrieved user mapping information.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UserMapping As String

C#
[DataMemberAttribute]
public string UserMapping { get; set; }

C++

J#

JScript

Property Value
Type String
Retrieved user mapping information.

  Remarks
The information is returned in an XML format that can be used for mapping the users in the target system.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RetrieveUserMappingResponse Class
RetrieveUserMappingResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


Server Class
See Also Members
[image]

Contains information about a server in a Microsoft Dynamics CRM deployment.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="Server", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class Server
    Inherits DeploymentEntity

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="Server", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class Server : DeploymentEntity

C++

J#

JScript

  Remarks
The properties for a server are set when the server is created. Most cannot be updated after the fact. You can also use Windows PowerShell to access the same organization information.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentEntity
      Microsoft.Xrm.Sdk.Deployment.Server
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Server Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


Server Members
See Also Constructors Methods Properties
[image]

Contains information about a server in a Microsoft Dynamics CRM deployment.

The following tables list the members exposed by the Server type.

Public Constructors

Name | Description
Server | Initializes a new instance of the Server class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FullName | Gets or sets the full name of the server.
public property | Id | Gets the organization ID.
public property | Name | Gets the name of the server.
public property | Roles | Gets the set of roles configured for the server.
public property | State | Gets or sets the state of the server.
public property | Version | Gets the version number of the server.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Server Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


Server Constructor
[image]

Initializes a new instance of the Server class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public Server ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Server Class
Server Members
Microsoft.Xrm.Sdk.Deployment Namespace


Server Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Server Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


Server Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FullName | Gets or sets the full name of the server.
public property | Id | Gets the organization ID.
public property | Name | Gets the name of the server.
public property | Roles | Gets the set of roles configured for the server.
public property | State | Gets or sets the state of the server.
public property | Version | Gets the version number of the server.

See Also

Reference

Server Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


Server.FullName Property
[image]

Gets or sets the full name of the server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FullName As String

C#
[DataMemberAttribute]
public string FullName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Server Class
Server Members
Microsoft.Xrm.Sdk.Deployment Namespace


Server.Id Property
[image]

Gets the organization ID.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Id As Guid

C#
[DataMemberAttribute]
public Guid Id { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The organization ID.

  Remarks
This property is assigned a value when the server is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Server Class
Server Members
Microsoft.Xrm.Sdk.Deployment Namespace


Server.Name Property
[image]

Gets the name of the server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Name As String

C#
[DataMemberAttribute]
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Server Class
Server Members
Microsoft.Xrm.Sdk.Deployment Namespace


Server.Roles Property
[image]

Gets the set of roles configured for the server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Roles As ServerRoles

C#
[DataMemberAttribute]
public ServerRoles Roles { get; set; }

C++

J#

JScript

Property Value
Type: ServerRoles
The set of roles configured for the server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Server Class
Server Members
Microsoft.Xrm.Sdk.Deployment Namespace


Server.State Property
[image]

Gets or sets the state of the server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property State As ServerState

C#
[DataMemberAttribute]
public ServerState State { get; set; }

C++

J#

JScript

Property Value
Type: ServerState
The state of the server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Server Class
Server Members
Microsoft.Xrm.Sdk.Deployment Namespace


Server.Version Property
[image]

Gets the version number of the server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Version As String

C#
[DataMemberAttribute]
public string Version { get; set; }

C++

J#

JScript

Property Value
Type: String

The version number of the server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Server Class
Server Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerRoles Enumeration
[image]

Describes specific server functionality, components, and services.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FlagsAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="ServerRoles", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Crm")> _
Public Enumeration ServerRoles

C#
[FlagsAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="ServerRoles", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Crm")]
public enum ServerRoles

C++

J#

JScript

  Members
Member name | Description
AdminWebService | For internal use only.. Value = 0x2000.
ApiServer | The role that allows programmatic access to the organization Web service. Value = 0x8000.
AppServer | The role that runs the Web application server that is used to connect users to Microsoft Dynamics CRM data. Value = 1.
AsyncService | The role that allows processing of queued asynchronous events, such as workflows, asynchronous plug-ins, bulk e-mail, or data import. Value = 2.
ConfigSqlServer | For internal use only.. Value = 0x10000.
ConfigWitnessServer | For internal use only.. Value = 0x20000.
DeploymentManagementTools | The role that allows the use of the Deployment Manager and Windows PowerShell cmdlets. Microsoft Dynamics CRM administrators can use the Windows PowerShell cmdlets to automate Deployment Manager tasks. Deployment Manager is a Microsoft Management Console (MMC) snap-in that system administrators can use to manage organizations, servers, and licenses for deployments of Microsoft Dynamics CRM. Value = 0x4000000.
DeploymentService | The role that allows programmatic access to deployment management. Value = 0x200000.
DiscoveryService | The role that allows discovery of organizations. Value = 8.
Dns | For internal use only.. Value = 0x4000.
EmailConnector | The role for the email connector. Value = 0x40000000.
EmailService | For internal use only.. Value = 0x10.
GeoSqlServer | For internal use only.. Value = 0x100000.
HelpServer | The role that makes Microsoft Dynamics CRM help available to users. Value = 0x40000.
LivePlatform | For internal use only.. Value = 0x800.
None | Indicates no roles. Value = 0.
OnlineAnalyticsServer | For internal use only.. Value = 0x8000000.
OnlineAnalyticsSqlServer | For internal use only.. Value = 0x10000000.
OpsServer | For internal use only.. Value = 0x40.
Portal | For internal use only.. Value = 0x200.
Provisioning | For internal use only.. Value = 0x400.
SandboxServer | The role that enables an isolated environment for the execution of custom code, such as plug-ins. This isolated environment reduces the possibility of custom code affecting the operation of the organizations. Value = 0x1000000.
ScaleGroupProvisioning | For internal use only.. Value = 0x800000.
SiteSqlServer | For internal use only.. Value = 0x400000.
SqlServer | The role that installs the configuration database (MSCRM_CONFIG) on the SQL Server. Value = 0x100.
SrsDataConnector | The role that provides reporting functionality by interfacing with the Microsoft Dynamics CRM system and Microsoft SQL Server Reporting Services. Value = 4.
StatsSqlServer | For internal use only.. Value = 0x80000.
Support | For internal use only.. Value = 0x1000.
VssWriter | For internal use only.. Value = 0x20000000.
WebService | Obsolete. Value = 0x20.
WitnessServer | For internal use only.. Value = 0x80.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Blog: Making Sense of Server Roles


ServerSideSyncACTSettings Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ServerSideSyncACTSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class ServerSideSyncACTSettings
    Inherits DeploymentConfigSettings

C#
[DataContractAttribute(Name="ServerSideSyncACTSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class ServerSideSyncACTSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.ServerSideSyncACTSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the ServerSideSyncACTSettings type.

Public Constructors

Name | Description
ServerSideSyncACTSettings | Initializes the ServerSideSyncACTSettings class.
Top

Public Properties

 | Name | Description
public property | ActiveMailboxMaximumBackoffForACT | Defines the maximum duration, in seconds, after which the service checks an active mailbox for appointments, contacts, or tasks.
public property | ActiveMailboxMinimumBackoffForACT | Defines the minimum duration, in seconds, after which the service checks an active mailbox for appointments, contacts, or tasks.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | IdleMailboxMaximumBackoffForACT | Defines the maximum duration, in seconds, after which the service checks an idle mailbox for appointments, contacts, or tasks.
public property | IdleMailboxMinimumBackoffForACT | Defines the minimum duration, in seconds, after which the service checks an idle mailbox for appointments, contacts, or tasks.
public property | MailboxBackoffOnTimeoutForACT | Defines the duration, in seconds, to postpone synchronizing appointments, contacts, or tasks for a mailbox on an Exchange server request time-out.
public property | MailboxBackoffOnTransientErrorForACT | Defines the duration, in seconds, to postpone synchronizing appointments, contacts, or tasks for a mailbox after encountering a transient error.
public property | MaximumItemsPerCycleForACT | Defines the maximum number of appointments, contacts, or tasks processed by an Exchange server in a cycle.
public property | MaximumMailboxTransientFailuresForACT | Defines the maximum number of transient failures that can occur before a mailbox is disabled for synchronizing appointments, contacts, or tasks.
public property | MaximumSynchronizationAttemptsForACT | Defines the maximum number of attempts allowed to synchronize an appointment, contact, or task.
public property | RetrievalBatchSizeForACT | Defines the batch size for retrieving appointments, contacts, tasks from an Exchange server.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ServerSideSyncACTSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings Constructor
[image]

Initializes the ServerSideSyncACTSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ServerSideSyncACTSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ServerSideSyncACTSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings Properties
[image]

Public Properties

 | Name | Description
public property | ActiveMailboxMaximumBackoffForACT | Defines the maximum duration, in seconds, after which the service checks an active mailbox for appointments, contacts, or tasks.
public property | ActiveMailboxMinimumBackoffForACT | Defines the minimum duration, in seconds, after which the service checks an active mailbox for appointments, contacts, or tasks.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | IdleMailboxMaximumBackoffForACT | Defines the maximum duration, in seconds, after which the service checks an idle mailbox for appointments, contacts, or tasks.
public property | IdleMailboxMinimumBackoffForACT | Defines the minimum duration, in seconds, after which the service checks an idle mailbox for appointments, contacts, or tasks.
public property | MailboxBackoffOnTimeoutForACT | Defines the duration, in seconds, to postpone synchronizing appointments, contacts, or tasks for a mailbox on an Exchange server request time-out.
public property | MailboxBackoffOnTransientErrorForACT | Defines the duration, in seconds, to postpone synchronizing appointments, contacts, or tasks for a mailbox after encountering a transient error.
public property | MaximumItemsPerCycleForACT | Defines the maximum number of appointments, contacts, or tasks processed by an Exchange server in a cycle.
public property | MaximumMailboxTransientFailuresForACT | Defines the maximum number of transient failures that can occur before a mailbox is disabled for synchronizing appointments, contacts, or tasks.
public property | MaximumSynchronizationAttemptsForACT | Defines the maximum number of attempts allowed to synchronize an appointment, contact, or task.
public property | RetrievalBatchSizeForACT | Defines the batch size for retrieving appointments, contacts, tasks from an Exchange server.

See Also

Reference

ServerSideSyncACTSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.ActiveMailboxMaximumBackoffForACT Property
[image]

Defines the maximum duration, in seconds, after which the service checks an active mailbox for appointments, contacts, or tasks.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActiveMailboxMaximumBackoffForACT As Integer

C#
[DataMemberAttribute]
public int ActiveMailboxMaximumBackoffForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum duration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.ActiveMailboxMinimumBackoffForACT Property
[image]

Defines the minimum duration, in seconds, after which the service checks an active mailbox for appointments, contacts, or tasks.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActiveMailboxMinimumBackoffForACT As Integer

C#
[DataMemberAttribute]
public int ActiveMailboxMinimumBackoffForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The minimum duration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.IdleMailboxMaximumBackoffForACT Property
[image]

Defines the maximum duration, in seconds, after which the service checks an idle mailbox for appointments, contacts, or tasks.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IdleMailboxMaximumBackoffForACT As Integer

C#
[DataMemberAttribute]
public int IdleMailboxMaximumBackoffForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum duration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.IdleMailboxMinimumBackoffForACT Property
[image]

Defines the minimum duration, in seconds, after which the service checks an idle mailbox for appointments, contacts, or tasks.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IdleMailboxMinimumBackoffForACT As Integer

C#
[DataMemberAttribute]
public int IdleMailboxMinimumBackoffForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The minimum duration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.MailboxBackoffOnTimeoutForACT Property
[image]

Defines the duration, in seconds, to postpone synchronizing appointments, contacts, or tasks for a mailbox on an Exchange server request time-out.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxBackoffOnTimeoutForACT As Integer

C#
[DataMemberAttribute]
public int MailboxBackoffOnTimeoutForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The duration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.MailboxBackoffOnTransientErrorForACT Property
[image]

Defines the duration, in seconds, to postpone synchronizing appointments, contacts, or tasks for a mailbox after encountering a transient error.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxBackoffOnTransientErrorForACT As Integer

C#
[DataMemberAttribute]
public int MailboxBackoffOnTransientErrorForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The duration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.MaximumItemsPerCycleForACT Property
[image]

Defines the maximum number of appointments, contacts, or tasks processed by an Exchange server in a cycle.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaximumItemsPerCycleForACT As Integer

C#
[DataMemberAttribute]
public int MaximumItemsPerCycleForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.MaximumMailboxTransientFailuresForACT Property
[image]

Defines the maximum number of transient failures that can occur before a mailbox is disabled for synchronizing appointments, contacts, or tasks.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaximumMailboxTransientFailuresForACT As Integer

C#
[DataMemberAttribute]
public int MaximumMailboxTransientFailuresForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.MaximumSynchronizationAttemptsForACT Property
[image]

Defines the maximum number of attempts allowed to synchronize an appointment, contact, or task.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaximumSynchronizationAttemptsForACT As Integer

C#
[DataMemberAttribute]
public int MaximumSynchronizationAttemptsForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncACTSettings.RetrievalBatchSizeForACT Property
[image]

Defines the batch size for retrieving appointments, contacts, tasks from an Exchange server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RetrievalBatchSizeForACT As Integer

C#
[DataMemberAttribute]
public int RetrievalBatchSizeForACT { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The batch size.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncACTSettings Class
ServerSideSyncACTSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="ServerSideSyncEmailSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class ServerSideSyncEmailSettings
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="ServerSideSyncEmailSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class ServerSideSyncEmailSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.ServerSideSyncEmailSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the ServerSideSyncEmailSettings type.

Public Constructors

Name | Description
ServerSideSyncEmailSettings |
Top

Public Properties

 | Name | Description
public property | ActiveMailboxMaximumBackoff | Defines the maximum duration, in seconds, after which the service checks an active mailbox for the user’s email.
public property | ActiveMailboxMinimumBackoff | Defines the minimum duration, in seconds, after which the service checks an active mailbox for the user’s email.
public property | AllowADBasedAuthenticationProtocols | Specifies whether to allow Active Directory based authentication to connect with email servers.
public property | AllowBasicAuthenticationOnNonSecureChannel | Specifies whether Microsoft Dynamics CRM is allowed to connect to an email server on a non-secure channel using Basic/Clear Text authentication, for both outgoing and incoming email.
public property | AllowCredentialsEntryViaNonSecureChannels | Specifies to allow entering the user credentials via a non-secure channel.
public property | AllowNonSSLEmail | Specifies whether Microsoft Dynamics CRM is allowed to connect to an email server on a non-secure channel, for both outgoing and incoming email.
public property | EmailRouterMigrationMaxParallelRuns | Defines the maximum number of parallel migration processes on the server for an organization. Any migration request exceeding this value is rejected.
public property | ExchangeAutoDiscoverBulkDiscoveryBatchSize | Defines the maximum batch size for discovering Exchange web services URL in a single request.
public property | ExchangeAutoDiscoverMaxRedirects | Defines the maximum redirects honored in an Exchange Web Services auto-discover request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | IdleMailboxMaximumBackoff | Defines the maximum duration, in seconds, after which the service checks an idle mailbox for the user’s email.
public property | IdleMailboxMinimumBackoff | Defines the minimum duration, in seconds, after which the service checks an idle mailbox for the user’s email.
public property | IncomingEmailExchangeEmailRetrievalBatchSize | Defines the email retrieval batch size of the Exchange server.
public property | IncomingEmailMaximumSizeLimit | Defines the maximum limit, in bytes, for the incoming message size. This settings applies to email received from an Exchange or POP3 email server type.
public property | IncomingMaximumEmailsPerCycle | Defines the maximum number of messages that an incoming provider can process in a cycle.
public property | LogEwsResponseHttpHeaders | Specifies to enable logging of Exchange web services response headers in Microsoft Dynamics CRM traces.
public property | MailboxBackoffOnTimeout | Defines the duration, in seconds, that sending or receiving email is postponed for a mailbox when a request to the email server times out.
public property | MailboxBackoffOnTransientError | Defines the duration, in seconds, to postpone sending or receiving email for a mailbox after a transient error occurs.
public property | MailboxSendBackoffOnSubmissionQuotaExceeded | Defines the duration, in minutes, that sending email from a mailbox is postponed when the Exchange submission quota is exceeded.
public property | MaximumEmailDeliveryAttempts | Defines the maximum number of attempts that can be made to send an email.
public property | MaximumExchangeWebResponseSize | Defines the maximum size of response, in KB, from Exchange using Exchange web services.
public property | MaxMailboxTransientFailures | Defines the number of transient failures that can occur before the mailbox is automatically disabled.
public property | MessageIDCacheCapacity | Defines the capacity of the message ID cache for server-side synchronization.
public property | MessageIDCacheRetentionTime | Defines the time, in minutes, that the email message ID is retained in the cache.
public property | PendingEmailsRetryInterval | Defines the interval in minutes after which an email in pending send status is picked up for retry.
public property | ProcessEmailSinceMaximumDaysAllowed | Defines the maximum number of days before the current date or time that server-side synchronization can be configured to process email. This information is provided in an email server profile record in Microsoft Dynamics CRM.
public property | SendingEmailsRetryInterval | Defines the interval, in minutes, after which an email in sending status is picked up for retry.
public property | TestEmailConfigurationRetryInterval | Defines the interval, in minutes, to attempt the email test configuration again.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ServerSideSyncEmailSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings Constructor
[image]

Initializes a new instance of the ServerSideSyncEmailSettings Class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ServerSideSyncEmailSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ServerSideSyncEmailSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings Properties
[image]

Public Properties

 | Name | Description
public property | ActiveMailboxMaximumBackoff | Defines the maximum duration, in seconds, after which the service checks an active mailbox for the user’s email.
public property | ActiveMailboxMinimumBackoff | Defines the minimum duration, in seconds, after which the service checks an active mailbox for the user’s email.
public property | AllowADBasedAuthenticationProtocols | Specifies whether to allow Active Directory based authentication to connect with email servers.
public property | AllowBasicAuthenticationOnNonSecureChannel | Specifies whether Microsoft Dynamics CRM is allowed to connect to an email server on a non-secure channel using Basic/Clear Text authentication, for both outgoing and incoming email.
public property | AllowCredentialsEntryViaNonSecureChannels | Specifies to allow entering the user credentials via a non-secure channel.
public property | AllowNonSSLEmail | Specifies whether Microsoft Dynamics CRM is allowed to connect to an email server on a non-secure channel, for both outgoing and incoming email.
public property | EmailRouterMigrationMaxParallelRuns | Defines the maximum number of parallel migration processes on the server for an organization. Any migration request exceeding this value is rejected.
public property | ExchangeAutoDiscoverBulkDiscoveryBatchSize | Defines the maximum batch size for discovering Exchange web services URL in a single request.
public property | ExchangeAutoDiscoverMaxRedirects | Defines the maximum redirects honored in an Exchange Web Services auto-discover request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | IdleMailboxMaximumBackoff | Defines the maximum duration, in seconds, after which the service checks an idle mailbox for the user’s email.
public property | IdleMailboxMinimumBackoff | Defines the minimum duration, in seconds, after which the service checks an idle mailbox for the user’s email.
public property | IncomingEmailExchangeEmailRetrievalBatchSize | Defines the email retrieval batch size of the Exchange server.
public property | IncomingEmailMaximumSizeLimit | Defines the maximum limit, in bytes, for the incoming message size. This settings applies to email received from an Exchange or POP3 email server type.
public property | IncomingMaximumEmailsPerCycle | Defines the maximum number of messages that an incoming provider can process in a cycle.
public property | LogEwsResponseHttpHeaders | Specifies to enable logging of Exchange web services response headers in Microsoft Dynamics CRM traces.
public property | MailboxBackoffOnTimeout | Defines the duration, in seconds, that sending or receiving email is postponed for a mailbox when a request to the email server times out.
public property | MailboxBackoffOnTransientError | Defines the duration, in seconds, to postpone sending or receiving email for a mailbox after a transient error occurs.
public property | MailboxSendBackoffOnSubmissionQuotaExceeded | Defines the duration, in minutes, that sending email from a mailbox is postponed when the Exchange submission quota is exceeded.
public property | MaximumEmailDeliveryAttempts | Defines the maximum number of attempts that can be made to send an email.
public property | MaximumExchangeWebResponseSize | Defines the maximum size of response, in KB, from Exchange using Exchange web services.
public property | MaxMailboxTransientFailures | Defines the number of transient failures that can occur before the mailbox is automatically disabled.
public property | MessageIDCacheCapacity | Defines the capacity of the message ID cache for server-side synchronization.
public property | MessageIDCacheRetentionTime | Defines the time, in minutes, that the email message ID is retained in the cache.
public property | PendingEmailsRetryInterval | Defines the interval in minutes after which an email in pending send status is picked up for retry.
public property | ProcessEmailSinceMaximumDaysAllowed | Defines the maximum number of days before the current date or time that server-side synchronization can be configured to process email. This information is provided in an email server profile record in Microsoft Dynamics CRM.
public property | SendingEmailsRetryInterval | Defines the interval, in minutes, after which an email in sending status is picked up for retry.
public property | TestEmailConfigurationRetryInterval | Defines the interval, in minutes, to attempt the email test configuration again.

See Also

Reference

ServerSideSyncEmailSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.ActiveMailboxMaximumBackoff Property
[image]

Defines the maximum duration, in seconds, after which the service checks an active mailbox for the user’s email.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActiveMailboxMaximumBackoff As Integer

C#
[DataMemberAttribute]
public int ActiveMailboxMaximumBackoff { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum duration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.ActiveMailboxMinimumBackoff Property
[image]

Defines the minimum duration, in seconds, after which the service checks an active mailbox for the user’s email.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActiveMailboxMinimumBackoff As Integer

C#
[DataMemberAttribute]
public int ActiveMailboxMinimumBackoff { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The minimum duration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.AllowADBasedAuthenticationProtocols Property
[image]

Specifies whether to allow Active Directory based authentication to connect with email servers.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AllowADBasedAuthenticationProtocols As Boolean

C#
[DataMemberAttribute]
public bool AllowADBasedAuthenticationProtocols { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to allow Active Directory authentication; otherwise, false.

  Remarks
The default value for Microsoft Dynamics CRM Online is false, and for Microsoft Dynamics CRM on premises the default value is true.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.AllowBasicAuthenticationOnNonSecureChannel Property
[image]

Specifies whether Microsoft Dynamics CRM is allowed to connect to an email server on a non-secure channel using Basic/Clear Text authentication, for both outgoing and incoming email.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AllowBasicAuthenticationOnNonSecureChannel As Boolean

C#
[DataMemberAttribute]
public bool AllowBasicAuthenticationOnNonSecureChannel { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to allow basic authentication; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.AllowCredentialsEntryViaNonSecureChannels Property
[image]

Specifies to allow entering the user credentials via a non-secure channel.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AllowCredentialsEntryViaNonSecureChannels As Boolean

C#
[DataMemberAttribute]
public bool AllowCredentialsEntryViaNonSecureChannels { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to allow un-secure authentication; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.AllowNonSSLEmail Property
[image]

Specifies whether Microsoft Dynamics CRM is allowed to connect to an email server on a non-secure channel, for both outgoing and incoming email.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AllowNonSSLEmail As Boolean

C#
[DataMemberAttribute]
public bool AllowNonSSLEmail { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to allow unsecure email; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.EmailRouterMigrationMaxParallelRuns Property
[image]

Defines the maximum number of parallel migration processes on the server for an organization. Any migration request exceeding this value is rejected.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EmailRouterMigrationMaxParallelRuns As Integer

C#
[DataMemberAttribute]
public int EmailRouterMigrationMaxParallelRuns { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of parallel migration processes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.ExchangeAutoDiscoverBulkDiscoveryBatchSize Property
[image]

Defines the maximum batch size for discovering Exchange web services URL in a single request.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ExchangeAutoDiscoverBulkDiscoveryBatchSize As Integer

C#
[DataMemberAttribute]
public int ExchangeAutoDiscoverBulkDiscoveryBatchSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The batch size.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.ExchangeAutoDiscoverMaxRedirects Property
[image]

Defines the maximum redirects honored in an Exchange Web Services auto-discover request.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ExchangeAutoDiscoverMaxRedirects As Integer

C#
[DataMemberAttribute]
public int ExchangeAutoDiscoverMaxRedirects { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of redirects.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.IdleMailboxMaximumBackoff Property
[image]

Defines the maximum duration, in seconds, after which the service checks an idle mailbox for the user’s email.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IdleMailboxMaximumBackoff As Integer

C#
[DataMemberAttribute]
public int IdleMailboxMaximumBackoff { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum duration, in seconds.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.IdleMailboxMinimumBackoff Property
[image]

Defines the minimum duration, in seconds, after which the service checks an idle mailbox for the user’s email.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IdleMailboxMinimumBackoff As Integer

C#
[DataMemberAttribute]
public int IdleMailboxMinimumBackoff { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The minimum duration, in seconds.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.IncomingEmailExchangeEmailRetrievalBatchSize Property
[image]

Defines the email retrieval batch size of the Exchange server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IncomingEmailExchangeEmailRetrievalBatchSize As Integer

C#
[DataMemberAttribute]
public int IncomingEmailExchangeEmailRetrievalBatchSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The email retrieval batch size.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.IncomingEmailMaximumSizeLimit Property
[image]

Defines the maximum limit, in bytes, for the incoming message size. This settings applies to email received from an Exchange or POP3 email server type.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IncomingEmailMaximumSizeLimit As Integer

C#
[DataMemberAttribute]
public int IncomingEmailMaximumSizeLimit { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum email size limit.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.IncomingMaximumEmailsPerCycle Property
[image]

Defines the maximum number of messages that an incoming provider can process in a cycle.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IncomingMaximumEmailsPerCycle As Integer

C#
[DataMemberAttribute]
public int IncomingMaximumEmailsPerCycle { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of messages.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.LogEwsResponseHttpHeaders Property
[image]

Specifies to enable logging of Exchange web services response headers in Microsoft Dynamics CRM traces.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LogEwsResponseHttpHeaders As Boolean

C#
[DataMemberAttribute]
public bool LogEwsResponseHttpHeaders { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if logging is enabled; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.MailboxBackoffOnTimeout Property
[image]

Defines the duration, in seconds, that sending or receiving email is postponed for a mailbox when a request to the email server times out.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxBackoffOnTimeout As Integer

C#
[DataMemberAttribute]
public int MailboxBackoffOnTimeout { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum duration, in seconds.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.MailboxBackoffOnTransientError Property
[image]

Defines the duration, in seconds, to postpone sending or receiving email for a mailbox after a transient error occurs.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxBackoffOnTransientError As Integer

C#
[DataMemberAttribute]
public int MailboxBackoffOnTransientError { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum duration, in seconds.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.MailboxSendBackoffOnSubmissionQuotaExceeded Property
[image]

Defines the duration, in minutes, that sending email from a mailbox is postponed when the Exchange submission quota is exceeded.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxSendBackoffOnSubmissionQuotaExceeded As Integer

C#
[DataMemberAttribute]
public int MailboxSendBackoffOnSubmissionQuotaExceeded { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum duration, in seconds.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.MaximumEmailDeliveryAttempts Property
[image]

Defines the maximum number of attempts that can be made to send an email.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaximumEmailDeliveryAttempts As Integer

C#
[DataMemberAttribute]
public int MaximumEmailDeliveryAttempts { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of attempts.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.MaximumExchangeWebResponseSize Property
[image]

Defines the maximum size of response, in KB, from Exchange using Exchange web services.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaximumExchangeWebResponseSize As Integer

C#
[DataMemberAttribute]
public int MaximumExchangeWebResponseSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum reponse size in KB.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.MaxMailboxTransientFailures Property
[image]

Defines the number of transient failures that can occur before the mailbox is automatically disabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxMailboxTransientFailures As Integer

C#
[DataMemberAttribute]
public int MaxMailboxTransientFailures { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of failures.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.MessageIDCacheCapacity Property
[image]

Defines the capacity of the message ID cache for server-side synchronization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MessageIDCacheCapacity As Integer

C#
[DataMemberAttribute]
public int MessageIDCacheCapacity { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The cache capacity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.MessageIDCacheRetentionTime Property
[image]

Defines the time, in minutes, that the email message ID is retained in the cache.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MessageIDCacheRetentionTime As Integer

C#
[DataMemberAttribute]
public int MessageIDCacheRetentionTime { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum time, in minutes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.PendingEmailsRetryInterval Property
[image]

Defines the interval in minutes after which an email in pending send status is picked up for retry.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PendingEmailsRetryInterval As Integer

C#
[DataMemberAttribute]
public int PendingEmailsRetryInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum interval, in minutes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.ProcessEmailSinceMaximumDaysAllowed Property
[image]

Defines the maximum number of days before the current date or time that server-side synchronization can be configured to process email. This information is provided in an email server profile record in Microsoft Dynamics CRM.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ProcessEmailSinceMaximumDaysAllowed As Integer

C#
[DataMemberAttribute]
public int ProcessEmailSinceMaximumDaysAllowed { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of days.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.SendingEmailsRetryInterval Property
[image]

Defines the interval, in minutes, after which an email in sending status is picked up for retry.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SendingEmailsRetryInterval As Integer

C#
[DataMemberAttribute]
public int SendingEmailsRetryInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum interval, in minutes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncEmailSettings.TestEmailConfigurationRetryInterval Property
[image]

Defines the interval, in minutes, to attempt the email test configuration again.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TestEmailConfigurationRetryInterval As Integer

C#
[DataMemberAttribute]
public int TestEmailConfigurationRetryInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum interval, in minutes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncEmailSettings Class
ServerSideSyncEmailSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="ServerSideSyncQueueSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class ServerSideSyncQueueSettings
    Inherits DeploymentConfigSettings

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="ServerSideSyncQueueSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class ServerSideSyncQueueSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.ServerSideSyncQueueSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the ServerSideSyncQueueSettings type.

Public Constructors

Name | Description
ServerSideSyncQueueSettings | Initializes a new instance of the ServerSideSyncQueueSettings class.
Top

Public Properties

 | Name | Description
public property | ActivitiesDequedPerEvent | Gets or sets the number of activities to be removed from a queue per asynchronous event.
public property | ActivityQueueItemsInMemoryHigh | Defines the upper limit of the number of activity batches held in memory at any point of time.
public property | ActivityQueueItemsInMemoryLow | Defines the lower limit beyond which the service will stop removing activity batches held in memory from the queue.
public property | ActivityQueueMaximumThreadsPercent | Defines the maximum percentage of worker threads to be used for running asynchronous operations.
public property | ActivityQueueMaximumThreadsPerCPU | Defines the maximum number of threads per CPU to be used for running asynchronous operations.
public property | ActivityQueueSelectInterval | Defines how frequently to poll the organization database activity pointer table to check for any new outgoing emails that have to be sent.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MailboxesDequedPerEvent | Controls the number of mailboxes to be removed from a queue per asynchronous event.
public property | MailboxQueueItemsInMemoryHigh | Gets or sets the upper limit on the number of mailbox batches held in memory, beyond which the service will stop removing mailboxes from the queue.
public property | MailboxQueueItemsInMemoryLow | Gest or sets the lower limit on the number of mailbox batches held in memory, beyond which the service will stop removing mailboxes from the queue.
public property | MailboxQueueMaximumThreadsPercent | Defines the maximum percentage of worker threads for running asynchronous operations.
public property | MailboxQueueMaximumThreadsPerCPU | Defines the maximum number of threads per CPU for running asynchronous operations.
public property | MailboxQueueSelectInterval | Defines the recurrence period, in seconds, of removing mailboxes from the queue in the database.
public property | MailboxRetryDelay | Defines the number of minutes after which a locked mailbox record is checked again for incoming email processing in case of a service crash.
public property | MaximumActivitiesPerSelect | Controls the maximum number of activities that can be removed from the queue for an organization per select interval.
public property | WaitingOperationTimeout | Defines the maximum time allowed for any call to the email server to complete. If a response isn’t received from the email server within this time period, the request is aborted. This setting applies to both Exchange and POP3/SMTP.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ServerSideSyncQueueSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings Constructor
[image]

Initializes a new instance of the ServerSideSyncQueueSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ServerSideSyncQueueSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ServerSideSyncQueueSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings Properties
[image]

Public Properties

 | Name | Description
public property | ActivitiesDequedPerEvent | Gets or sets the number of activities to be removed from a queue per asynchronous event.
public property | ActivityQueueItemsInMemoryHigh | Defines the upper limit of the number of activity batches held in memory at any point of time.
public property | ActivityQueueItemsInMemoryLow | Defines the lower limit beyond which the service will stop removing activity batches held in memory from the queue.
public property | ActivityQueueMaximumThreadsPercent | Defines the maximum percentage of worker threads to be used for running asynchronous operations.
public property | ActivityQueueMaximumThreadsPerCPU | Defines the maximum number of threads per CPU to be used for running asynchronous operations.
public property | ActivityQueueSelectInterval | Defines how frequently to poll the organization database activity pointer table to check for any new outgoing emails that have to be sent.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MailboxesDequedPerEvent | Controls the number of mailboxes to be removed from a queue per asynchronous event.
public property | MailboxQueueItemsInMemoryHigh | Gets or sets the upper limit on the number of mailbox batches held in memory, beyond which the service will stop removing mailboxes from the queue.
public property | MailboxQueueItemsInMemoryLow | Gest or sets the lower limit on the number of mailbox batches held in memory, beyond which the service will stop removing mailboxes from the queue.
public property | MailboxQueueMaximumThreadsPercent | Defines the maximum percentage of worker threads for running asynchronous operations.
public property | MailboxQueueMaximumThreadsPerCPU | Defines the maximum number of threads per CPU for running asynchronous operations.
public property | MailboxQueueSelectInterval | Defines the recurrence period, in seconds, of removing mailboxes from the queue in the database.
public property | MailboxRetryDelay | Defines the number of minutes after which a locked mailbox record is checked again for incoming email processing in case of a service crash.
public property | MaximumActivitiesPerSelect | Controls the maximum number of activities that can be removed from the queue for an organization per select interval.
public property | WaitingOperationTimeout | Defines the maximum time allowed for any call to the email server to complete. If a response isn’t received from the email server within this time period, the request is aborted. This setting applies to both Exchange and POP3/SMTP.

See Also

Reference

ServerSideSyncQueueSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.ActivitiesDequedPerEvent Property
[image]

Gets or sets the number of activities to be removed from a queue per asynchronous event.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActivitiesDequedPerEvent As Integer

C#
[DataMemberAttribute]
public int ActivitiesDequedPerEvent { get; set; }

C++

J#

JScript

Property Value
Type: Int32
 The number of activities to be removed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.ActivityQueueItemsInMemoryHigh Property
[image]

Defines the upper limit of the number of activity batches held in memory at any point of time.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActivityQueueItemsInMemoryHigh As Integer

C#
[DataMemberAttribute]
public int ActivityQueueItemsInMemoryHigh { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of items held in memory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.ActivityQueueItemsInMemoryLow Property
[image]

Defines the lower limit beyond which the service will stop removing activity batches held in memory from the queue.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActivityQueueItemsInMemoryLow As Integer

C#
[DataMemberAttribute]
public int ActivityQueueItemsInMemoryLow { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The minimum number of items held in memory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.ActivityQueueMaximumThreadsPercent Property
[image]

Defines the maximum percentage of worker threads to be used for running asynchronous operations.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActivityQueueMaximumThreadsPercent As Double

C#
[DataMemberAttribute]
public double ActivityQueueMaximumThreadsPercent { get; set; }

C++

J#

JScript

Property Value
Type: Double
The maximum percentage of threads.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.ActivityQueueMaximumThreadsPerCPU Property
[image]

Defines the maximum number of threads per CPU to be used for running asynchronous operations.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActivityQueueMaximumThreadsPerCPU As Integer

C#
[DataMemberAttribute]
public int ActivityQueueMaximumThreadsPerCPU { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of threads.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.ActivityQueueSelectInterval Property
[image]

Defines how frequently to poll the organization database activity pointer table to check for any new outgoing emails that have to be sent.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActivityQueueSelectInterval As Integer

C#
[DataMemberAttribute]
public int ActivityQueueSelectInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The polling interval, in seconds.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.MailboxesDequedPerEvent Property
[image]

Controls the number of mailboxes to be removed from a queue per asynchronous event.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxesDequedPerEvent As Integer

C#
[DataMemberAttribute]
public int MailboxesDequedPerEvent { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of mailboxes removed from a queue.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.MailboxQueueItemsInMemoryHigh Property
[image]

Gets or sets the upper limit on the number of mailbox batches held in memory, beyond which the service will stop removing mailboxes from the queue.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxQueueItemsInMemoryHigh As Integer

C#
[DataMemberAttribute]
public int MailboxQueueItemsInMemoryHigh { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of mailbox batches to be held in memory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.MailboxQueueItemsInMemoryLow Property
[image]

Gest or sets the lower limit on the number of mailbox batches held in memory, beyond which the service will stop removing mailboxes from the queue.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxQueueItemsInMemoryLow As Integer

C#
[DataMemberAttribute]
public int MailboxQueueItemsInMemoryLow { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The minimum number of mailbox batches to be held in memory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.MailboxQueueMaximumThreadsPercent Property
[image]

Defines the maximum percentage of worker threads for running asynchronous operations.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxQueueMaximumThreadsPercent As Double

C#
[DataMemberAttribute]
public double MailboxQueueMaximumThreadsPercent { get; set; }

C++

J#

JScript

Property Value
Type: Double
The maximum percentage of threads.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.MailboxQueueMaximumThreadsPerCPU Property
[image]

Defines the maximum number of threads per CPU for running asynchronous operations.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxQueueMaximumThreadsPerCPU As Integer

C#
[DataMemberAttribute]
public int MailboxQueueMaximumThreadsPerCPU { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of threads.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.MailboxQueueSelectInterval Property
[image]

Defines the recurrence period, in seconds, of removing mailboxes from the queue in the database.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxQueueSelectInterval As Integer

C#
[DataMemberAttribute]
public int MailboxQueueSelectInterval { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The recurrence period, in seconds.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.MailboxRetryDelay Property
[image]

Defines the number of minutes after which a locked mailbox record is checked again for incoming email processing in case of a service crash.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MailboxRetryDelay As Integer

C#
[DataMemberAttribute]
public int MailboxRetryDelay { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The retry delay, in minutes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.MaximumActivitiesPerSelect Property
[image]

Controls the maximum number of activities that can be removed from the queue for an organization per select interval.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaximumActivitiesPerSelect As Integer

C#
[DataMemberAttribute]
public int MaximumActivitiesPerSelect { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number per interval.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerSideSyncQueueSettings.WaitingOperationTimeout Property
[image]

Defines the maximum time allowed for any call to the email server to complete. If a response isn’t received from the email server within this time period, the request is aborted. This setting applies to both Exchange and POP3/SMTP.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property WaitingOperationTimeout As Integer

C#
[DataMemberAttribute]
public int WaitingOperationTimeout { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The waiting operation timeout.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerSideSyncQueueSettings Class
ServerSideSyncQueueSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ServerState Enumeration
[image]

Describes the state of a server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="ServerState", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")> _
Public Enumeration ServerState

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="ServerState", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Admin.AdminService")]
public enum ServerState

C++

J#

JScript

  Members
Member name | Description
Disabled | Specifies that the server is disabled. Value = 0.
Enabled | Specifies that the server is enabled. Value = 1.
None | Specifies that no server state. Value = -1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace


ServiceHealthStatus Enumeration
[image]

Describes the deployment service health status.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ServiceHealthStatus", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Enumeration ServiceHealthStatus

C#
[DataContractAttribute(Name="ServiceHealthStatus", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public enum ServiceHealthStatus

C++

J#

JScript

  Members
Member name | Description
Healthy | Tests passed successfully.
HealthyServiceVerificationOnly | Tests that didn’t require a test organization passed successfully.
NoData | No tests have been run.
NotHealthy | Tests failed.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace


SqmSettings Class
See Also Members
[image]

Contains settings about the Microsoft customer experience improvement program.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="SqmSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class SqmSettings
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="SqmSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class SqmSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.SqmSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SqmSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
SqmIsEnabled
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


SqmSettings Members
See Also Constructors Methods Properties
[image]

Contains settings about the Microsoft customer experience improvement program.

The following tables list the members exposed by the SqmSettings type.

Public Constructors

Name | Description
SqmSettings | Initializes a new instance of the SqmSettings class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | SqmEnabled | Gets or sets the value that indicates whether collection of information for the customer experience improvement program is enabled.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SqmSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace
SqmIsEnabled

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


SqmSettings Constructor
[image]

Initializes a new instance of the SqmSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SqmSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SqmSettings Class
SqmSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


SqmSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SqmSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace
SqmIsEnabled

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


SqmSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | SqmEnabled | Gets or sets the value that indicates whether collection of information for the customer experience improvement program is enabled.

See Also

Reference

SqmSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace
SqmIsEnabled

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


SqmSettings.SqmEnabled Property
[image]

Gets or sets the value that indicates whether collection of information for the customer experience improvement program is enabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SqmEnabled As Boolean

C#
[DataMemberAttribute]
public bool SqmEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the information collection for the customer experience program is enabled; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SqmSettings Class
SqmSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TeamSettings Class
See Also Members
[image]

Contains settings for the auto created (system-managed) access teams.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="TeamSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class TeamSettings
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="TeamSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class TeamSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
You can use Windows PowerShell to retrieve or update these settings.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.TeamSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TeamSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


TeamSettings Members
See Also Constructors Methods Properties
[image]

Contains settings for the auto created (system-managed) access teams.

The following tables list the members exposed by the TeamSettings type.

Public Constructors

Name | Description
TeamSettings | Initializes a new instance of the TeamSettings class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MaxAutoCreatedAccessTeamsPerEntity | Gets or sets the maximum number of auto created (system-managed) access teams per entity. Required.
public property | MaxEntitiesEnabledForAutoCreatedAccessTeams | Gets or sets the maximum number of entities that can be enabled for auto created (system-managed) access teams. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TeamSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


TeamSettings Constructor
[image]

Initializes a new instance of the TeamSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TeamSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TeamSettings Class
TeamSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TeamSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TeamSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


TeamSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MaxAutoCreatedAccessTeamsPerEntity | Gets or sets the maximum number of auto created (system-managed) access teams per entity. Required.
public property | MaxEntitiesEnabledForAutoCreatedAccessTeams | Gets or sets the maximum number of entities that can be enabled for auto created (system-managed) access teams. Required.

See Also

Reference

TeamSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


TeamSettings.MaxAutoCreatedAccessTeamsPerEntity Property
[image]

Gets or sets the maximum number of auto created (system-managed) access teams per entity. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxAutoCreatedAccessTeamsPerEntity As Integer

C#
[DataMemberAttribute]
public int MaxAutoCreatedAccessTeamsPerEntity { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of auto created (system-managed) access teams per entity.
The default value for this setting is 2.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TeamSettings Class
TeamSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TeamSettings.MaxEntitiesEnabledForAutoCreatedAccessTeams Property
[image]

Gets or sets the maximum number of entities that can be enabled for auto created (system-managed) access teams. Required.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxEntitiesEnabledForAutoCreatedAccessTeams As Integer

C#
[DataMemberAttribute]
public int MaxEntitiesEnabledForAutoCreatedAccessTeams { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of entities that can be enabled for auto created (system-managed) access teams.
The default value for this setting is 5.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TeamSettings Class
TeamSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TestStatus Enumeration
[image]

Indicates the result of a monitoring service operation test.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="TestStatus", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Monitoring")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Enumeration TestStatus

C#
[DataContractAttribute(Name="TestStatus", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Crm.Monitoring")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public enum TestStatus

C++

J#

JScript

  Members
Member name | Description
Failed | Test failed.
NotExecuted | Test hasn’t run yet.
Succeed | Test succeeded.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings Class
See Also Members
[image]

Contains information about service throttling.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="ThrottleSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class ThrottleSettings
    Inherits DeploymentConfigSettings

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="ThrottleSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class ThrottleSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.ThrottleSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Import Data in Microsoft Dynamics CRM


ThrottleSettings Members
See Also Constructors Methods Properties
[image]

Contains information about service throttling.

The following tables list the members exposed by the ThrottleSettings type.

Public Constructors

Name | Description
ThrottleSettings | Initializes a new instance of the ThrottleSettings class.
Top

Public Properties

 | Name | Description
public property | ExecuteAsyncMaxConnectionsPerServer | Gets or sets the maximum number of concurrent asynchronous execute operations per organization.
public property | ExecuteAsyncPerOrgMaxConnectionsPerServer | Gets or sets the maximum number of concurrent execute multiple operations per organization per server.
public property | ExecuteMultipleMaxConnectionsPerServer | Gets or sets the maximum number of concurrent execute multiple operations per organization.
public property | ExecuteMultiplePerOrgMaxConnectionsPerServer | Gets or sets the maximum number of concurrent execute multiple operations per organization per server.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FollowInYammerMaxConnectionsPerServer | For internal use only.
public property | FollowInYammerPerOrgMaxConnectionsPerServer | For internal use only.
public property | MapiSyncMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of MAPI sync operations.
public property | MapiSyncPerOrgMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of MAPI sync operations per organization.
public property | MaxBackgroundSendEmailRequestsPerOrgPerServer | Gets or sets the Server setting to control the maximum number of background email send operations per organization.
public property | MaxBackgroundSendEmailRequestsPerServer | Gets or sets the server setting to control the maximum number of background email send operations.
public property | MaxSharepointThreadsperOrganisation | Gets or sets the maximum number of Microsoft SharePoint threads allowed per organization.
public property | MaxSharepointThreadsperUser | Gets or sets the maximum number of Microsoft SharePoint threads allowed per user.
public property | OfflineSyncMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of offline sync operations.
public property | OfflineSyncPerOrgMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of offline sync operations per organization.
public property | OutlookSyncMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of CRM for Outlook sync operations.
public property | OutlookSyncPerOrgMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of CRM for Outlook sync operations per organization.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ThrottleSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Import Data in Microsoft Dynamics CRM


ThrottleSettings Constructor
[image]

Initializes a new instance of the ThrottleSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ThrottleSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ThrottleSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Import Data in Microsoft Dynamics CRM


ThrottleSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExecuteAsyncMaxConnectionsPerServer | Gets or sets the maximum number of concurrent asynchronous execute operations per organization.
public property | ExecuteAsyncPerOrgMaxConnectionsPerServer | Gets or sets the maximum number of concurrent execute multiple operations per organization per server.
public property | ExecuteMultipleMaxConnectionsPerServer | Gets or sets the maximum number of concurrent execute multiple operations per organization.
public property | ExecuteMultiplePerOrgMaxConnectionsPerServer | Gets or sets the maximum number of concurrent execute multiple operations per organization per server.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FollowInYammerMaxConnectionsPerServer | For internal use only.
public property | FollowInYammerPerOrgMaxConnectionsPerServer | For internal use only.
public property | MapiSyncMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of MAPI sync operations.
public property | MapiSyncPerOrgMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of MAPI sync operations per organization.
public property | MaxBackgroundSendEmailRequestsPerOrgPerServer | Gets or sets the Server setting to control the maximum number of background email send operations per organization.
public property | MaxBackgroundSendEmailRequestsPerServer | Gets or sets the server setting to control the maximum number of background email send operations.
public property | MaxSharepointThreadsperOrganisation | Gets or sets the maximum number of Microsoft SharePoint threads allowed per organization.
public property | MaxSharepointThreadsperUser | Gets or sets the maximum number of Microsoft SharePoint threads allowed per user.
public property | OfflineSyncMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of offline sync operations.
public property | OfflineSyncPerOrgMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of offline sync operations per organization.
public property | OutlookSyncMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of CRM for Outlook sync operations.
public property | OutlookSyncPerOrgMaxConnectionsPerServer | Gets or sets the server setting to control the maximum number of CRM for Outlook sync operations per organization.

See Also

Reference

ThrottleSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel
Import Data in Microsoft Dynamics CRM


ThrottleSettings.ExecuteAsyncMaxConnectionsPerServer Property
[image]

Gets or sets the maximum number of concurrent asynchronous execute operations per organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ExecuteAsyncMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int ExecuteAsyncMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Execute messages in the background (asynchronously)


ThrottleSettings.ExecuteAsyncPerOrgMaxConnectionsPerServer Property
[image]

Gets or sets the maximum number of concurrent execute multiple operations per organization per server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ExecuteAsyncPerOrgMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int ExecuteAsyncPerOrgMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Execute messages in the background (asynchronously)


ThrottleSettings.ExecuteMultipleMaxConnectionsPerServer Property
[image]

Gets or sets the maximum number of concurrent execute multiple operations per organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ExecuteMultipleMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int ExecuteMultipleMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of concurrent execute multiple operations per organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use ExecuteMultiple to Improve Performance for Bulk Data Load


ThrottleSettings.ExecuteMultiplePerOrgMaxConnectionsPerServer Property
[image]

Gets or sets the maximum number of concurrent execute multiple operations per organization per server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ExecuteMultiplePerOrgMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int ExecuteMultiplePerOrgMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of concurrent execute multiple operations per organization per server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Use ExecuteMultiple to Improve Performance for Bulk Data Load


ThrottleSettings.FollowInYammerMaxConnectionsPerServer Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FollowInYammerMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int FollowInYammerMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.FollowInYammerPerOrgMaxConnectionsPerServer Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FollowInYammerPerOrgMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int FollowInYammerPerOrgMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.MapiSyncMaxConnectionsPerServer Property
[image]

Gets or sets the server setting to control the maximum number of MAPI sync operations.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MapiSyncMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int MapiSyncMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of MAPI sync operations.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.MapiSyncPerOrgMaxConnectionsPerServer Property
[image]

Gets or sets the server setting to control the maximum number of MAPI sync operations per organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MapiSyncPerOrgMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int MapiSyncPerOrgMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of MAPI sync operations per organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.MaxBackgroundSendEmailRequestsPerOrgPerServer Property
[image]

Gets or sets the Server setting to control the maximum number of background email send operations per organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxBackgroundSendEmailRequestsPerOrgPerServer As Integer

C#
[DataMemberAttribute]
public int MaxBackgroundSendEmailRequestsPerOrgPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of background email send operations per organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.MaxBackgroundSendEmailRequestsPerServer Property
[image]

Gets or sets the server setting to control the maximum number of background email send operations.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxBackgroundSendEmailRequestsPerServer As Integer

C#
[DataMemberAttribute]
public int MaxBackgroundSendEmailRequestsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of background email send operations.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.MaxSharepointThreadsperOrganisation Property
[image]

Gets or sets the maximum number of Microsoft SharePoint threads allowed per organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxSharepointThreadsperOrganisation As Integer

C#
[DataMemberAttribute]
public int MaxSharepointThreadsperOrganisation { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of threads allowed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.MaxSharepointThreadsperUser Property
[image]

Gets or sets the maximum number of Microsoft SharePoint threads allowed per user.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxSharepointThreadsperUser As Integer

C#
[DataMemberAttribute]
public int MaxSharepointThreadsperUser { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of threads allowed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.OfflineSyncMaxConnectionsPerServer Property
[image]

Gets or sets the server setting to control the maximum number of offline sync operations.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OfflineSyncMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int OfflineSyncMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
Gets or sets the server setting to control the maximum number of offline sync operations.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.OfflineSyncPerOrgMaxConnectionsPerServer Property
[image]

Gets or sets the server setting to control the maximum number of offline sync operations per organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OfflineSyncPerOrgMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int OfflineSyncPerOrgMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of offline sync operations per organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.OutlookSyncMaxConnectionsPerServer Property
[image]

Gets or sets the server setting to control the maximum number of CRM for Outlook sync operations.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OutlookSyncMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int OutlookSyncMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of sync operations.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


ThrottleSettings.OutlookSyncPerOrgMaxConnectionsPerServer Property
[image]

Gets or sets the server setting to control the maximum number of CRM for Outlook sync operations per organization.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OutlookSyncPerOrgMaxConnectionsPerServer As Integer

C#
[DataMemberAttribute]
public int OutlookSyncPerOrgMaxConnectionsPerServer { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of sync operations per organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ThrottleSettings Class
ThrottleSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TraceSettings Class
See Also Members
[image]

Contains trace settings for a deployment.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="TraceSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class TraceSettings
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="TraceSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class TraceSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
You can also use Windows PowerShell to retrieve or update these settings.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.TraceSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


TraceSettings Members
See Also Constructors Methods Properties
[image]

Contains trace settings for a deployment.

The following tables list the members exposed by the TraceSettings type.

Public Constructors

Name | Description
TraceSettings | Initializes a new instance of the TraceSettings class.
Top

Public Properties

 | Name | Description
public property | CallStack | Gets or sets whether to save the call stack.
public property | Categories | Gets or sets the categories to trace.
public property | Directory | Gets or sets the directory for the trace files.
public property | Enabled | Gets or sets whether tracing is enabled.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FileSize | Gets or sets the trace file size limit (MB).
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TraceSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


TraceSettings Constructor
[image]

Initializes a new instance of the TraceSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TraceSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceSettings Class
TraceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TraceSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TraceSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


TraceSettings Properties
[image]

Public Properties

 | Name | Description
public property | CallStack | Gets or sets whether to save the call stack.
public property | Categories | Gets or sets the categories to trace.
public property | Directory | Gets or sets the directory for the trace files.
public property | Enabled | Gets or sets whether tracing is enabled.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | FileSize | Gets or sets the trace file size limit (MB).

See Also

Reference

TraceSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


TraceSettings.CallStack Property
[image]

Gets or sets whether to save the call stack.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CallStack As Boolean

C#
[DataMemberAttribute]
public bool CallStack { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if saving the call stack is enabled; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceSettings Class
TraceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TraceSettings.Categories Property
[image]

Gets or sets the categories to trace.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Categories As String

C#
[DataMemberAttribute]
public string Categories { get; set; }

C++

J#

JScript

Property Value
Type: String

The categories to trace.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceSettings Class
TraceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TraceSettings.Directory Property
[image]

Gets or sets the directory for the trace files.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Directory As String

C#
[DataMemberAttribute]
public string Directory { get; set; }

C++

J#

JScript

Property Value
Type: String

The directory for the trace files.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceSettings Class
TraceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TraceSettings.Enabled Property
[image]

Gets or sets whether tracing is enabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Enabled As Boolean

C#
[DataMemberAttribute]
public bool Enabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if tracing is enabled; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceSettings Class
TraceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TraceSettings.FileSize Property
[image]

Gets or sets the trace file size limit (MB).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FileSize As Integer

C#
[DataMemberAttribute]
public int FileSize { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The size limit of the trace file in MB.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceSettings Class
TraceSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


TrackingLicenseType Enumeration
[image]

Describes the type of license.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="TrackingLicenseType", Namespace:="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Enumeration TrackingLicenseType

C#
[DataContractAttribute(Name="TrackingLicenseType", Namespace="http://schemas.datacontract.org/2004/07/Microsoft.Xrm.Sdk.Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public enum TrackingLicenseType

C++

J#

JScript

  Members
Member name | Description
AdministrativeCal | An administrative client access license (CAL). Value = 2.
BasicCal | A basic client access license (CAL). Value = 3.
DeviceBasicCal | A device basic client access license (CAL). Value = 5.
DeviceEnterpriseCal | A device enterprise client access license (CAL). Value = 6.
DeviceEssentialCal | A device essential client access license (CAL). Value = 13.
DeviceProfessionalCal | A device professional client access license (CAL). Value = 4.
EnterpriseCal | An enterprise client access license (CAL). Value = 12.
EnterpriseServer | An enterprise client access license (CAL). Value = 9.
EssentialCal | An essential client access license (CAL). Value = 1.
OnlineServer | An online server client access license (CAL). Value =11 .
ProfessionalCal | A professional client access license (CAL). Value = 0.
ProfessionalServer | A professional server client access license (CAL). Value = 8.
SplaServer | A service provider licensing agreement (SPLA) client access license (CAL). Value = 10.
WorkgroupServer | A workgroup server client access license (CAL). Value = 7.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Deployment Namespace


TrackLicenseRequest Class
See Also Members
[image]

Contains the data that is needed to track the licenses for a deployment.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="TrackLicenseRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class TrackLicenseRequest
    Inherits DeploymentServiceRequest

C#
[DataContractAttribute(Name="TrackLicenseRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class TrackLicenseRequest : DeploymentServiceRequest

C++

J#

JScript

  Remarks
Pass an instance of this class to the Execute method, which returns an instance of TrackLicenseResponse.
Notes for Callers
You can also use the Get-CrmAccessLicenseWindows PowerShell command to retrieve license information. For more information, see Administer the deployment using Windows PowerShell.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.TrackLicenseRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TrackLicenseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseResponse
Other Resources
Use Deployment Entities and Deployment Configuration Settings
Get-CrmAccessLicense


TrackLicenseRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to track the licenses for a deployment.

The following tables list the members exposed by the TrackLicenseRequest type.

Public Constructors

Name | Description
TrackLicenseRequest | Initializes a new instance of theTrackLicenseRequest class.
Top

Public Properties

 | Name | Description
public property | EndDate | Gets or sets the end date for the license.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | LicenseType | Gets or sets the type of license.
public property | StartDate | Gets or sets the start date for the license.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TrackLicenseRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseResponse

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Get-CrmAccessLicense


TrackLicenseRequest Constructor
[image]

Initializes a new instance of the TrackLicenseRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TrackLicenseRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TrackLicenseRequest Class
TrackLicenseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


TrackLicenseRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TrackLicenseRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseResponse

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Get-CrmAccessLicense


TrackLicenseRequest Properties
[image]

Public Properties

 | Name | Description
public property | EndDate | Gets or sets the end date for the license.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | LicenseType | Gets or sets the type of license.
public property | StartDate | Gets or sets the start date for the license.

See Also

Reference

TrackLicenseRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseResponse

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Get-CrmAccessLicense


TrackLicenseRequest.EndDate Property
[image]

Gets or sets the end date for the license.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EndDate As DateTime

C#
[DataMemberAttribute]
public DateTime EndDate { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The end date.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TrackLicenseRequest Class
TrackLicenseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


TrackLicenseRequest.LicenseType Property
[image]

Gets or sets the type of license.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property LicenseType As TrackingLicenseType

C#
[DataMemberAttribute(IsRequired=true)]
public TrackingLicenseType LicenseType { get; set; }

C++

J#

JScript

Property Value
Type: TrackingLicenseType
The type of license.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TrackLicenseRequest Class
TrackLicenseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


TrackLicenseRequest.StartDate Property
[image]

Gets or sets the start date for the license.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property StartDate As DateTime

C#
[DataMemberAttribute]
public DateTime StartDate { get; set; }

C++

J#

JScript

Property Value
Type: DateTime
The start date.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TrackLicenseRequest Class
TrackLicenseRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


TrackLicenseResponse Class
See Also Members
[image]

Contains the response from theTrackLicenseRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="TrackLicenseResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class TrackLicenseResponse
    Inherits DeploymentServiceResponse

C#
[DataContractAttribute(Name="TrackLicenseResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class TrackLicenseResponse : DeploymentServiceResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.TrackLicenseResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TrackLicenseResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseRequest


TrackLicenseResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from theTrackLicenseRequest.

The following tables list the members exposed by the TrackLicenseResponse type.

Public Constructors

Name | Description
TrackLicenseResponse | Initializes a new instance of the TrackLicenseResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | Servers | Gets the servers returned from the license request.
public property | Users | Gets the users returned from the license request.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TrackLicenseResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseRequest


TrackLicenseResponse Constructor
[image]

Initializes a new instance of the TrackLicenseResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TrackLicenseResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TrackLicenseResponse Class
TrackLicenseResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


TrackLicenseResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TrackLicenseResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseRequest


TrackLicenseResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
public property | Servers | Gets the servers returned from the license request.
public property | Users | Gets the users returned from the license request.

See Also

Reference

TrackLicenseResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
TrackLicenseRequest


TrackLicenseResponse.Servers Property
[image]

Gets the servers returned from the license request.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Servers As DataCollection(Of String)

C#
[DataMemberAttribute]
public DataCollection<string> Servers { get; set; }

C++

J#

JScript

Property Value
Type:  DataCollection<String>
The collection of servers.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TrackLicenseResponse Class
TrackLicenseResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


TrackLicenseResponse.Users Property
[image]

Gets the users returned from the license request.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Users As DataCollection(Of OrganizationUserInfo)

C#
[DataMemberAttribute]
public DataCollection<OrganizationUserInfo> Users { get; set; }

C++

J#

JScript

Property Value
Type:DataCollection<OrganizationUserInfo>
The collection of users.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TrackLicenseResponse Class
TrackLicenseResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateAdvancedSettingsRequest Class
See Also Members
[image]

Contains the data that is needed to update advanced settings from the configuration database. For internal use only.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="UpdateAdvancedSettingsRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class UpdateAdvancedSettingsRequest
    Inherits DeploymentServiceRequest

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="UpdateAdvancedSettingsRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class UpdateAdvancedSettingsRequest : DeploymentServiceRequest

C++

J#

JScript

  Remarks
Pass an instance of this class to the Execute method, which returns an instance of UpdateAdvancedSettingsResponse.
You can also use the Set-CrmAdvancedSettingWindows PowerShell command. For more information, see Administer the deployment using Windows PowerShell. Note that only the settings that are writable are documented in the SDK.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.UpdateAdvancedSettingsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateAdvancedSettingsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateAdvancedSettingsResponse
Other Resources
Set-CrmAdvancedSetting


UpdateAdvancedSettingsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update advanced settings from the configuration database. For internal use only.

The following tables list the members exposed by the UpdateAdvancedSettingsRequest type.

Public Constructors

Name | Description
UpdateAdvancedSettingsRequest | Initializes a new instance of the UpdateAdvancedSettingsRequest class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets or sets the configuration entity to be updated.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateAdvancedSettingsRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateAdvancedSettingsResponse

Other Resources

Set-CrmAdvancedSetting


UpdateAdvancedSettingsRequest Constructor
[image]

Initializes a new instance of the UpdateAdvancedSettingsRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateAdvancedSettingsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateAdvancedSettingsRequest Class
UpdateAdvancedSettingsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateAdvancedSettingsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateAdvancedSettingsRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateAdvancedSettingsResponse

Other Resources

Set-CrmAdvancedSetting


UpdateAdvancedSettingsRequest Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets or sets the configuration entity to be updated.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)

See Also

Reference

UpdateAdvancedSettingsRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateAdvancedSettingsResponse

Other Resources

Set-CrmAdvancedSetting


UpdateAdvancedSettingsRequest.Entity Property
[image]

Gets or sets the configuration entity to be updated.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property Entity As ConfigurationEntity

C#
[DataMemberAttribute(IsRequired=true)]
public ConfigurationEntity Entity { get; set; }

C++

J#

JScript

Property Value
Type: ConfigurationEntity
The configuration entity to be updated.

  Remarks
You must use the RetrieveAdvancedSettingsRequest message to retrieve the entity before using this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateAdvancedSettingsRequest Class
UpdateAdvancedSettingsRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateAdvancedSettingsResponse Class
See Also Members
[image]

Contains the response from theUpdateAdvancedSettingsRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="UpdateAdvancedSettingsResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
Public Class UpdateAdvancedSettingsResponse
    Inherits DeploymentServiceResponse

C#
[DataContractAttribute(Name="UpdateAdvancedSettingsResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
public class UpdateAdvancedSettingsResponse : DeploymentServiceResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.UpdateAdvancedSettingsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateAdvancedSettingsResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateAdvancedSettingsRequest


UpdateAdvancedSettingsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from theUpdateAdvancedSettingsRequest.

The following tables list the members exposed by the UpdateAdvancedSettingsResponse type.

Public Constructors

Name | Description
UpdateAdvancedSettingsResponse | Initializes a new instance of the UpdateAdvancedSettingsResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateAdvancedSettingsResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateAdvancedSettingsRequest


UpdateAdvancedSettingsResponse Constructor
[image]

Initializes a new instance of the UpdateAdvancedSettingsResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateAdvancedSettingsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateAdvancedSettingsResponse Class
UpdateAdvancedSettingsResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateAdvancedSettingsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateAdvancedSettingsResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateAdvancedSettingsRequest


UpdateAdvancedSettingsResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)

See Also

Reference

UpdateAdvancedSettingsResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateAdvancedSettingsRequest


UpdateProductKeyRequest Class
See Also Members
[image]

Contains the data that is needed to update a product key.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="UpdateProductKeyRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class UpdateProductKeyRequest
    Inherits DeploymentServiceRequest

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="UpdateProductKeyRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class UpdateProductKeyRequest : DeploymentServiceRequest

C++

J#

JScript

  Remarks
Pass an instance of this class to the Execute method, which returns an instance of UpdateProductKeyResponse.
Notes for Callers
You can also use the Set-CrmProductKeyWindows PowerShell command. For more information, see Administer the deployment using Windows PowerShell.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.UpdateProductKeyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateProductKeyRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateProductKeyResponse
Other Resources
Introduction to the Deployment Web Service
Set-CrmProductKey


UpdateProductKeyRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update a product key.

The following tables list the members exposed by the UpdateProductKeyRequest type.

Public Constructors

Name | Description
UpdateProductKeyRequest | Initializes a new instance of the UpdateProductKeyRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | ProductKey | Gets or sets the product key to update.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateProductKeyRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateProductKeyResponse

Other Resources

Introduction to the Deployment Web Service
Set-CrmProductKey


UpdateProductKeyRequest Constructor
[image]

Initializes a new instance of the UpdateProductKeyRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateProductKeyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateProductKeyRequest Class
UpdateProductKeyRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateProductKeyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateProductKeyRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateProductKeyResponse

Other Resources

Introduction to the Deployment Web Service
Set-CrmProductKey


UpdateProductKeyRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
public property | ProductKey | Gets or sets the product key to update.

See Also

Reference

UpdateProductKeyRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateProductKeyResponse

Other Resources

Introduction to the Deployment Web Service
Set-CrmProductKey


UpdateProductKeyRequest.ProductKey Property
[image]

Gets or sets the product key to update.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property ProductKey As String

C#
[DataMemberAttribute(IsRequired=true)]
public string ProductKey { get; set; }

C++

J#

JScript

Property Value
Type: String
The product key to update.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateProductKeyRequest Class
UpdateProductKeyRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateProductKeyResponse Class
See Also Members
[image]

Contains the response from the UpdateProductKeyRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="UpdateProductKeyResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
Public Class UpdateProductKeyResponse
    Inherits DeploymentServiceResponse

C#
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="UpdateProductKeyResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
public class UpdateProductKeyResponse : DeploymentServiceResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.UpdateProductKeyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateProductKeyResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateProductKeyRequest


UpdateProductKeyResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UpdateProductKeyRequest.

The following tables list the members exposed by the UpdateProductKeyResponse type.

Public Constructors

Name | Description
UpdateProductKeyResponse | Initializes a new instance of the UpdateProductKeyResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateProductKeyResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateProductKeyRequest


UpdateProductKeyResponse Constructor
[image]

Initializes a new instance of the UpdateProductKeyResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateProductKeyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateProductKeyResponse Class
UpdateProductKeyResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateProductKeyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateProductKeyResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateProductKeyRequest


UpdateProductKeyResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)

See Also

Reference

UpdateProductKeyResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateProductKeyRequest


UpdateRequest Class
See Also Example Members
[image]

Contains the data that is needed to update a deployment record.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="UpdateRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class UpdateRequest
    Inherits DeploymentServiceRequest

C#
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="UpdateRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class UpdateRequest : DeploymentServiceRequest

C++

J#

JScript

  Example
The following code shows how to disable an organization.
C#    Copy Code
using (DeploymentServiceClient client = new DeploymentServiceClient("CustomBinding_IDeploymentService"))
{
    EntityInstanceId id = new EntityInstanceId
    {
        Name = "AlpineSkiHouse"
    };

    Organization organization = (Organization)client.Retrieve(DeploymentEntityType.Organization, id);
    organization.State = OrganizationState.Disabled;
    client.Update(organization);

    client.Close();
}

The following code shows how to enable an organization.
C#    Copy Code
using (DeploymentServiceClient client = new DeploymentServiceClient("CustomBinding_IDeploymentService"))
{
    EntityInstanceId id = new EntityInstanceId
    {
        Name = "AlpineSkiHouse"
    };

    Organization organization = (Organization)client.Retrieve(DeploymentEntityType.Organization, id);
    organization.State = OrganizationState.Enabled;
    client.Update(organization);

    client.Close();
}

  Remarks
Pass an instance of this class to the Execute method, which returns an instance of UpdateResponse.
You can also use the corresponding Windows PowerShell command for the deployment entity you want to update. For example, Set-CrmProductKey or Set-CrmSetting. For more information, see Administer the deployment using Windows PowerShell.
Note that this is for the Deployment Web service. To update organization data records use UpdateRequest.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest
    Microsoft.Xrm.Sdk.Deployment.UpdateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
UpdateRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateResponse
Other Resources
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


UpdateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update a deployment record.

The following tables list the members exposed by the UpdateRequest type.

Public Constructors

Name | Description
UpdateRequest | Initializes a new instance of the UpdateRequest class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets or sets the configuration entity to be updated.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateResponse

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


UpdateRequest Constructor
[image]

Initializes a new instance of the UpdateRequest class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateRequest Class
UpdateRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateResponse

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


UpdateRequest Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets or sets the configuration entity to be updated.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceRequest)

See Also

Reference

UpdateRequest Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateResponse

Other Resources

Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


UpdateRequest.Entity Property
[image]

Gets or sets the configuration entity to be updated.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=True)> _
Public Property Entity As DeploymentObject

C#
[DataMemberAttribute(IsRequired=true)]
public DeploymentObject Entity { get; set; }

C++

J#

JScript

Property Value
Type: DeploymentObject
The configuration entity to be updated.

  Remarks
You must use the RetrieveRequest message to retrieve the entity before using this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateRequest Class
UpdateRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateResponse Class
See Also Members
[image]

Contains the response from theUpdateRequest.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="UpdateResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class UpdateResponse
    Inherits DeploymentServiceResponse

C#
[DataContractAttribute(Name="UpdateResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class UpdateResponse : DeploymentServiceResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse
    Microsoft.Xrm.Sdk.Deployment.UpdateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateRequest


UpdateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from theUpdateRequest.

The following tables list the members exposed by the UpdateResponse type.

Public Constructors

Name | Description
UpdateResponse | Initializes a new instance of the UpdateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateRequest


UpdateResponse Constructor
[image]

Initializes a new instance of the UpdateResponse class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
UpdateResponse Class
UpdateResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace


UpdateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateRequest


UpdateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentServiceResponse)

See Also

Reference

UpdateResponse Class
Microsoft.Xrm.Sdk.Deployment Namespace
UpdateRequest


WebAddressSettings Class
See Also Members
[image]

Contains deployment specific root domain address values.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="WebAddressSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class WebAddressSettings
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="WebAddressSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class WebAddressSettings : DeploymentConfigSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.WebAddressSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


WebAddressSettings Members
See Also Constructors Methods Properties
[image]

Contains deployment specific root domain address values.

The following tables list the members exposed by the WebAddressSettings type.

Public Constructors

Name | Description
WebAddressSettings | Initializes a new instance of the WebAddressSettings class.
Top

Public Properties

 | Name | Description
public property | DeploymentSdkRootDomain | Gets or sets the root domain for the deployment Web service (SDK).
public property | DiscoveryRootDomain | Gets or sets the root domain for the discovery Web service.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | HelpServerUrl | Gets or sets the URL for help content server.
public property | NlbEnabled | Gets or sets whether network load balancing (NLB) is enabled.
public property | RootDomainScheme | Gets or sets the root domain scheme: http or https.
public property | SdkRootDomain | Gets or sets the root domain for the organization Web service (SDK).
public property | SslHeader | Gets or sets the secured sockets layer (SSL) header.
public property | WebAppRootDomain | Gets or sets the root domain for the Web application.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WebAddressSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


WebAddressSettings Constructor
[image]

Initializes a new instance of the WebAddressSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WebAddressSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Class
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WebAddressSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WebAddressSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


WebAddressSettings Properties
[image]

Public Properties

 | Name | Description
public property | DeploymentSdkRootDomain | Gets or sets the root domain for the deployment Web service (SDK).
public property | DiscoveryRootDomain | Gets or sets the root domain for the discovery Web service.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | HelpServerUrl | Gets or sets the URL for help content server.
public property | NlbEnabled | Gets or sets whether network load balancing (NLB) is enabled.
public property | RootDomainScheme | Gets or sets the root domain scheme: http or https.
public property | SdkRootDomain | Gets or sets the root domain for the organization Web service (SDK).
public property | SslHeader | Gets or sets the secured sockets layer (SSL) header.
public property | WebAppRootDomain | Gets or sets the root domain for the Web application.

See Also

Reference

WebAddressSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


WebAddressSettings.DeploymentSdkRootDomain Property
[image]

Gets or sets the root domain for the deployment Web service (SDK).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DeploymentSdkRootDomain As String

C#
[DataMemberAttribute]
public string DeploymentSdkRootDomain { get; set; }

C++

J#

JScript

Property Value
Type: String
The root domain for the deployment Web service (SDK).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Class
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WebAddressSettings.DiscoveryRootDomain Property
[image]

Gets or sets the root domain for the discovery Web service.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DiscoveryRootDomain As String

C#
[DataMemberAttribute]
public string DiscoveryRootDomain { get; set; }

C++

J#

JScript

Property Value
Type: String
The root domain for the discovery Web service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Class
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WebAddressSettings.HelpServerUrl Property
[image]

Gets or sets the URL for help content server.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property HelpServerUrl As String

C#
[DataMemberAttribute]
public string HelpServerUrl { get; set; }

C++

J#

JScript

Property Value
Type: String
The URL for help content server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Class
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WebAddressSettings.NlbEnabled Property
[image]

Gets or sets whether network load balancing (NLB) is enabled.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property NlbEnabled As Boolean

C#
[DataMemberAttribute]
public bool NlbEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if network load balancing (NLB) is enabled; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Class
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WebAddressSettings.RootDomainScheme Property
[image]

Gets or sets the root domain scheme: http or https.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RootDomainScheme As AddressScheme

C#
[DataMemberAttribute]
public AddressScheme RootDomainScheme { get; set; }

C++

J#

JScript

Property Value
Type: AddressScheme
The root domain scheme: http or https.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Class
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WebAddressSettings.SdkRootDomain Property
[image]

Gets or sets the root domain for the organization Web service (SDK).

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SdkRootDomain As String

C#
[DataMemberAttribute]
public string SdkRootDomain { get; set; }

C++

J#

JScript

Property Value
Type: String
The root domain for the organization Web service (SDK).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Class
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WebAddressSettings.SslHeader Property
[image]

Gets or sets the secured sockets layer (SSL) header.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SslHeader As String

C#
[DataMemberAttribute]
public string SslHeader { get; set; }

C++

J#

JScript

Property Value
Type: String
The secured sockets layer (SSL) header.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Class
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WebAddressSettings.WebAppRootDomain Property
[image]

Gets or sets the root domain for the Web application.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property WebAppRootDomain As String

C#
[DataMemberAttribute]
public string WebAppRootDomain { get; set; }

C++

J#

JScript

Property Value
Type: String
The root domain for the Web application.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebAddressSettings Class
WebAddressSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WorkflowSettings Class
See Also Members
[image]

Contains workflow setting values which can be changed to tune a Microsoft Dynamics CRM deployment.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
<DataContractAttribute(Name:="WorkflowSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
Public Class WorkflowSettings
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
[DataContractAttribute(Name="WorkflowSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
public class WorkflowSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
You can also use Windows PowerShell to retrieve or update these settings.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.WorkflowSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WorkflowSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


WorkflowSettings Members
See Also Constructors Methods Properties
[image]

Contains workflow setting values which can be changed to tune a Microsoft Dynamics CRM deployment.

The following tables list the members exposed by the WorkflowSettings type.

Public Constructors

Name | Description
WorkflowSettings | Initializes a new instance of the WorkflowSettings class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MaxDepth | Gets or sets the maximum depth for a workflow.
public property | MinInactiveSeconds | Gets or sets the maximum number of seconds a workflow can be inactive.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WorkflowSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


WorkflowSettings Constructor
[image]

Initializes a new instance of the WorkflowSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WorkflowSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WorkflowSettings Class
WorkflowSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WorkflowSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WorkflowSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


WorkflowSettings Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
public property | MaxDepth | Gets or sets the maximum depth for a workflow.
public property | MinInactiveSeconds | Gets or sets the maximum number of seconds a workflow can be inactive.

See Also

Reference

WorkflowSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShel


WorkflowSettings.MaxDepth Property
[image]

Gets or sets the maximum depth for a workflow.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxDepth As Integer

C#
[DataMemberAttribute]
public int MaxDepth { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum depth for a workflow.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WorkflowSettings Class
WorkflowSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


WorkflowSettings.MinInactiveSeconds Property
[image]

Gets or sets the maximum number of seconds a workflow can be inactive.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MinInactiveSeconds As Integer

C#
[DataMemberAttribute]
public int MinInactiveSeconds { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The maximum number of seconds a workflow can be inactive.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WorkflowSettings Class
WorkflowSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


YammerSettings Class
See Also Members
[image]

Contains settings for Yammer.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerStepThroughAttribute> _
<DataContractAttribute(Name:="YammerSettings", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")> _
Public Class YammerSettings
    Inherits DeploymentConfigSettings

C#
[DebuggerStepThroughAttribute]
[DataContractAttribute(Name="YammerSettings", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Deployment")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "4.0.0.0")]
public class YammerSettings : DeploymentConfigSettings

C++

J#

JScript

  Remarks
The application Id and the application secret are passed to Yammer when you make an API call from Microsoft Dynamics CRM to Yammer. Yammer verifies that the API call is coming from the registered CRM application. If the application Id and application secret passed in the API call don’t match the application Id and application secret in the Yammer database, the API call is rejected. For the API call to be acknowledged, both values must match.
You can use Windows PowerShell to retrieve or update these settings.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Deployment.DeploymentObject

                Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings
      Microsoft.Xrm.Sdk.Deployment.YammerSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
YammerSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace
Other Resources
Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


YammerSettings Members
See Also Constructors Methods Properties
[image]

Contains settings for Yammer.

The following tables list the members exposed by the YammerSettings type.

Public Constructors

Name | Description
YammerSettings | Initializes a new instance of the YammerSettings class.
Top

Public Properties

 | Name | Description
public property | ApplicationId | Gets or sets the application ID.
public property | ApplicationSecret | Gets or sets the application secret.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

YammerSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


YammerSettings Constructor
[image]

Initializes a new instance of the YammerSettings class.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public YammerSettings ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
YammerSettings Class
YammerSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


YammerSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

YammerSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


YammerSettings Properties
[image]

Public Properties

 | Name | Description
public property | ApplicationId | Gets or sets the application ID.
public property | ApplicationSecret | Gets or sets the application secret.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DeploymentObject)

See Also

Reference

YammerSettings Class
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages
Use Deployment Entities and Deployment Configuration Settings
Administer the deployment using Windows PowerShell


YammerSettings.ApplicationId Property
[image]

Gets or sets the application ID.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ApplicationId As String

C#
[DataMemberAttribute]
public string ApplicationId { get; set; }

C++

J#

JScript

Property Value
Type: String
The application ID.
The application ID is retrieved from yammer.com when you register your application on Yammer.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
YammerSettings Class
YammerSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


YammerSettings.ApplicationSecret Property
[image]

Gets or sets the application secret.

Namespace: Microsoft.Xrm.Sdk.Deployment
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ApplicationSecret As String

C#
[DataMemberAttribute]
public string ApplicationSecret { get; set; }

C++

J#

JScript

Property Value
Type: String
The application secret.
The application secret is provided by yammer.com when you register your application on Yammer.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
YammerSettings Class
YammerSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace


Microsoft.Xrm.Sdk.Deployment.Proxy Namespace

Classes

Class | Description
ProxyClientHelper | Provides helper methods to create a deployment service client class.


ProxyClientHelper Class
See Also Example Members
[image]

Provides helper methods to create a deployment service client class.

Namespace: Microsoft.Xrm.Sdk.Deployment.Proxy
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ProxyClientHelper

C#
public static class ProxyClientHelper

C++

J#

JScript

  Example
C#    Copy Code
DeploymentServiceClient service = Microsoft.Xrm.Sdk.Deployment.Proxy.ProxyClientHelper.CreateClient(new Uri("http://MyServerName/XRMDeployment/2011/Deployment.svc"));

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Deployment.Proxy.ProxyClientHelper
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ProxyClientHelper Members
Microsoft.Xrm.Sdk.Deployment.Proxy Namespace
Other Resources
Introduction to the Deployment Web Service


ProxyClientHelper Members
See Also Fields Methods
[image]

Provides helper methods to create a deployment service client class.

The following tables list the members exposed by the ProxyClientHelper type.

Public Fields

Name | Description
DefaultSendTimeout | Gets the timeout for sending requsts to the web service.
Top

Public Methods

Name | Description
CreateClient | Overloaded. Creates a deployment web service client.
Top

See Also

Reference

ProxyClientHelper Class
Microsoft.Xrm.Sdk.Deployment.Proxy Namespace

Other Resources

Introduction to the Deployment Web Service


ProxyClientHelper Fields
[image]

Public Fields

Name | Description
DefaultSendTimeout | Gets the timeout for sending requsts to the web service.

See Also

Reference

ProxyClientHelper Class
Microsoft.Xrm.Sdk.Deployment.Proxy Namespace

Other Resources

Introduction to the Deployment Web Service


ProxyClientHelper.DefaultSendTimeout Field
[image]

Gets the timeout for sending requsts to the web service.

Namespace: Microsoft.Xrm.Sdk.Deployment.Proxy
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared DefaultSendTimeout As TimeSpan

C#
public static TimeSpan DefaultSendTimeout

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProxyClientHelper Class
ProxyClientHelper Members
Microsoft.Xrm.Sdk.Deployment.Proxy Namespace


ProxyClientHelper Methods
[image]

Public Methods

Name | Description
CreateClient | Overloaded. Creates a deployment web service client.

See Also

Reference

ProxyClientHelper Class
Microsoft.Xrm.Sdk.Deployment.Proxy Namespace

Other Resources

Introduction to the Deployment Web Service


ProxyClientHelper.CreateClient Method
[image]

Creates a deployment web service client.

Overload List

Name | Description
ProxyClientHelper.CreateClient (Uri) | Creates a deployment web service client, setting the URL.
ProxyClientHelper.CreateClient (Uri, TimeSpan) | Creates a deployment web service client, setting the URL and the timeout.

See Also

Reference

ProxyClientHelper Class
ProxyClientHelper Members
Microsoft.Xrm.Sdk.Deployment.Proxy Namespace


ProxyClientHelper.CreateClient Method (Uri)
[image]

Creates a deployment web service client, setting the URL.

Namespace: Microsoft.Xrm.Sdk.Deployment.Proxy
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateClient ( _
    serverAddress As Uri _
) As DeploymentServiceClient

C#
public static DeploymentServiceClient CreateClient (
    Uri serverAddress
)

C++

J#

JScript

Parameters
serverAddress
Type: URI. The URL for the deployment Web service.
Return Value
Returns DeploymentServiceClient.

  Remarks
Use the following URL, replacing myservername with the name of your Microsoft Dynamics CRM server.
    Copy Code
http:// myservername/xrmdeployment/2011/deployment.svc

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ProxyClientHelper Class
ProxyClientHelper Members
Microsoft.Xrm.Sdk.Deployment.Proxy Namespace


ProxyClientHelper.CreateClient Method (Uri, TimeSpan)
[image]

Creates a deployment web service client, setting the URL and the timeout.

Namespace: Microsoft.Xrm.Sdk.Deployment.Proxy
Assembly: Microsoft.Xrm.Sdk.Deployment (in Microsoft.Xrm.Sdk.Deployment.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateClient ( _
    serverAddress As Uri, _
    sendTimeout As TimeSpan _
) As DeploymentServiceClient

C#
public static DeploymentServiceClient CreateClient (
    Uri serverAddress,
    TimeSpan sendTimeout
)

C++

J#

JScript

Parameters
serverAddress
Type: URI. The URL for the deployment Web service.
sendTimeout
Type: TimeSpan. The timeout value.
Return Value
Returns DeploymentServiceClient.

  Remarks
Use the following URL, replacing myservername with the name of your Microsoft Dynamics CRM server.
    Copy Code
http:// myservername/xrmdeployment/2011/deployment.svc

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ProxyClientHelper Class
ProxyClientHelper Members
Microsoft.Xrm.Sdk.Deployment.Proxy Namespace


Microsoft.Xrm.Sdk.Discovery Namespace

Classes

Class | Description
ClientInfo | For internal use only.
ClientPatchInfo | For internal use only.
DiscoveryRequest | Contains the data that is needed to execute a request and the base class for all discovery service requests.
DiscoveryResponse | Contains the response from the request and is the base class for all discovery service responses.
EndpointCollection | A collection of service endpoints.
OrganizationDetail | Provides detailed information on an organization.
OrganizationDetailCollection | Provides a collection of OrganizationDetail instances.
RetrieveOrganizationRequest | Contains the data that is needed to retrieve information about an organization.
RetrieveOrganizationResponse | Contains the response from processing RetrieveOrganizationRequest.
RetrieveOrganizationsRequest | Contains the data that is needed to retrieve information on all organizations that the logged on user belongs to.
RetrieveOrganizationsResponse | Contains the response from processing RetrieveOrganizationsRequest.
RetrieveUserIdByExternalIdRequest | Contains the data that is needed to retrieve the Microsoft Dynamics CRM or Microsoft Dynamics CRM Online system user ID that is associated with a given identity provider ID.
RetrieveUserIdByExternalIdResponse | Contains the response from processing RetrieveUserIdByExternalIdRequest.

Interfaces

Interface | Description
IDiscoveryService | Provides programmatic access to organization and user information.

Enumerations

Enumeration | Description
ClientTypes | For internal use only.
EndpointAccessType | Indicates the type of network access an endpoint has.
EndpointType | Identifies the type of service available at an endpoint.
EndUserNotificationClient | For internal use only.
OrganizationRelease | Describes the release of an organization.
OrganizationState | Describes the current state of an organization.


ClientInfo Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ClientInfo

C#
public sealed class ClientInfo

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Discovery.ClientInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the ClientInfo type.

Public Constructors

Name | Description
ClientInfo | Initializes a new instance of the ClientInfo class.
Top

Public Properties

 | Name | Description
public property | ClientType | Gets or sets the type of client that is querying for patches.
public property | CrmVersion | Gets or sets the Microsoft Dynamics CRM version that the client is running.
public property | LanguageCode | Gets or sets the language code for which the client has been configured.
public property | OfficeVersion | Gets or sets the version of Microsoft Office installed on the client machine.
public property | OrganizationId | Gets or sets the ID of the organization for which the client has been configured.
public property | OSVersion | Gets or sets the operating system version that the client is running.
public property | PatchIds | Gets or sets the list of patches that the client has installed.
public property | UserId | Gets or sets the Microsoft Dynamics CRM system user ID of the client.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ClientInfo Class
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo Constructor
[image]

Initializes a new instance of the ClientInfo class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ClientInfo ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Class
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ClientInfo Class
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo Properties
[image]

Public Properties

 | Name | Description
public property | ClientType | Gets or sets the type of client that is querying for patches.
public property | CrmVersion | Gets or sets the Microsoft Dynamics CRM version that the client is running.
public property | LanguageCode | Gets or sets the language code for which the client has been configured.
public property | OfficeVersion | Gets or sets the version of Microsoft Office installed on the client machine.
public property | OrganizationId | Gets or sets the ID of the organization for which the client has been configured.
public property | OSVersion | Gets or sets the operating system version that the client is running.
public property | PatchIds | Gets or sets the list of patches that the client has installed.
public property | UserId | Gets or sets the Microsoft Dynamics CRM system user ID of the client.

See Also

Reference

ClientInfo Class
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo.ClientType Property
[image]

Gets or sets the type of client that is querying for patches.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ClientType As ClientTypes

C#
public ClientTypes ClientType { get; set; }

C++

J#

JScript

Property Value
Type: ClientTypes
The type of client that is querying for patches.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Class
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo.CrmVersion Property
[image]

Gets or sets the Microsoft Dynamics CRM version that the client is running.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CrmVersion As String

C#
public string CrmVersion { get; set; }

C++

J#

JScript

Property Value
Type: String
The version.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Class
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo.LanguageCode Property
[image]

Gets or sets the language code for which the client has been configured.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LanguageCode As Integer

C#
public int LanguageCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The language code.

  Remarks

                        Language codes are four-digit or five-digit locale IDs. Valid locale ID values can be found at Locale ID (LCID) Chart).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Class
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo.OfficeVersion Property
[image]

Gets or sets the version of Microsoft Office installed on the client machine.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OfficeVersion As String

C#
public string OfficeVersion { get; set; }

C++

J#

JScript

Property Value
Type: String
The Microsoft Office version.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Class
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo.OrganizationId Property
[image]

Gets or sets the ID of the organization for which the client has been configured.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OrganizationId As Guid

C#
public Guid OrganizationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Class
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo.OSVersion Property
[image]

Gets or sets the operating system version that the client is running.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OSVersion As String

C#
public string OSVersion { get; set; }

C++

J#

JScript

Property Value
Type: String
The version of the operating system.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Class
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo.PatchIds Property
[image]

Gets or sets the list of patches that the client has installed.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays", Justification:="Need to pass in a list via SOAP which only supports arrays")> _
Public Property PatchIds As Guid()

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays", Justification="Need to pass in a list via SOAP which only supports arrays")]
public Guid[] PatchIds { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The list of patched applied.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Class
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientInfo.UserId Property
[image]

Gets or sets the Microsoft Dynamics CRM system user ID of the client.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserId As Guid

C#
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the user.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientInfo Class
ClientInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ClientPatchInfo

C#
public sealed class ClientPatchInfo

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Discovery.ClientPatchInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientPatchInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the ClientPatchInfo type.

Public Constructors

Name | Description
ClientPatchInfo | Initializes a new instance of the ClientPatchInfo class.
Top

Public Properties

 | Name | Description
public property | Depth |
public property | Description |
public property | IsMandatory |
public property | LinkId |
public property | PatchId |
public property | Title |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ClientPatchInfo Class
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo Constructor
[image]

Initializes a new instance of the ClientPatchInfo class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ClientPatchInfo ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientPatchInfo Class
ClientPatchInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ClientPatchInfo Class
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo Properties
[image]

Public Properties

 | Name | Description
public property | Depth |
public property | Description |
public property | IsMandatory |
public property | LinkId |
public property | PatchId |
public property | Title |

See Also

Reference

ClientPatchInfo Class
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo.Depth Property
[image]

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Depth As Integer

C#
public int Depth { get; set; }

C++

J#

JScript

Property Value
Type: Int32
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientPatchInfo Class
ClientPatchInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo.Description Property
[image]

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Description As String

C#
public string Description { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientPatchInfo Class
ClientPatchInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo.IsMandatory Property
[image]

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IsMandatory As Boolean

C#
public bool IsMandatory { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientPatchInfo Class
ClientPatchInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo.LinkId Property
[image]

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LinkId As String

C#
public string LinkId { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientPatchInfo Class
ClientPatchInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo.PatchId Property
[image]

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PatchId As Guid

C#
public Guid PatchId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientPatchInfo Class
ClientPatchInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientPatchInfo.Title Property
[image]

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Title As String

C#
public string Title { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ClientPatchInfo Class
ClientPatchInfo Members
Microsoft.Xrm.Sdk.Discovery Namespace


ClientTypes Enumeration
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FlagsAttribute> _
Public Enumeration ClientTypes

C#
[FlagsAttribute]
public enum ClientTypes

C++

J#

JScript

  Members
Member name | Description
DataMigration | For internal use only.
DataMigrationConfiguration | For internal use only.
OutlookConfiguration | For internal use only.
OutlookDesktop | For internal use only.
OutlookLaptop | For internal use only.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Discovery Namespace


DiscoveryRequest Class
See Also Members
[image]

Contains the data that is needed to execute a request and the base class for all discovery service requests.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DiscoveryRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
<KnownTypeAttribute(GetType(RetrieveOrganizationRequest))> _
<KnownTypeAttribute(GetType(RetrieveOrganizationsRequest))> _
<KnownTypeAttribute(GetType(RetrieveUserIdByExternalIdRequest))> _
Public MustInherit Class DiscoveryRequest
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="DiscoveryRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
[KnownTypeAttribute(typeof(RetrieveOrganizationRequest))]
[KnownTypeAttribute(typeof(RetrieveOrganizationsRequest))]
[KnownTypeAttribute(typeof(RetrieveUserIdByExternalIdRequest))]
public abstract class DiscoveryRequest : IExtensibleDataObject

C++

J#

JScript

  Remarks
This is the base class for all discovery Web service requests. Pass an instance of a request class to the Execute method.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Discovery.DiscoveryRequest

                Microsoft.Xrm.Sdk.Discovery.RetrieveOrganizationRequest

                Microsoft.Xrm.Sdk.Discovery.RetrieveOrganizationsRequest

                Microsoft.Xrm.Sdk.Discovery.RetrieveUserIdByExternalIdRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryResponse
Other Resources
Discovery Service Messages (Request and Response Classes)


DiscoveryRequest Members
See Also Methods Properties Constructors
[image]

Contains the data that is needed to execute a request and the base class for all discovery service requests.

The following tables list the members exposed by the DiscoveryRequest type.

Protected Constructors

Name | Description
DiscoveryRequest | Initializes a new instance of the DiscoveryRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DiscoveryRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryResponse

Other Resources

Discovery Service Messages (Request and Response Classes)


DiscoveryRequest Constructor
[image]

Initializes a new instance of the DiscoveryRequest class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected DiscoveryRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryRequest Class
DiscoveryRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


DiscoveryRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DiscoveryRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryResponse

Other Resources

Discovery Service Messages (Request and Response Classes)


DiscoveryRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional.

See Also

Reference

DiscoveryRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryResponse

Other Resources

Discovery Service Messages (Request and Response Classes)


DiscoveryRequest.ExtensionData Property
[image]

Gets or sets the structure that contains extra data. Optional.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryRequest Class
DiscoveryRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


DiscoveryResponse Class
See Also Members
[image]

Contains the response from the request and is the base class for all discovery service responses.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(RetrieveOrganizationResponse))> _
<KnownTypeAttribute(GetType(RetrieveUserIdByExternalIdResponse))> _
<DataContractAttribute(Name:="DiscoveryResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
<KnownTypeAttribute(GetType(RetrieveOrganizationsResponse))> _
Public MustInherit Class DiscoveryResponse
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute(typeof(RetrieveOrganizationResponse))]
[KnownTypeAttribute(typeof(RetrieveUserIdByExternalIdResponse))]
[DataContractAttribute(Name="DiscoveryResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
[KnownTypeAttribute(typeof(RetrieveOrganizationsResponse))]
public abstract class DiscoveryResponse : IExtensibleDataObject

C++

J#

JScript

  Remarks
This is the base class for all discovery Web service responses. An instance of a response class is returned from the Execute method.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Discovery.DiscoveryResponse

                Microsoft.Xrm.Sdk.Discovery.RetrieveOrganizationResponse

                Microsoft.Xrm.Sdk.Discovery.RetrieveOrganizationsResponse

                Microsoft.Xrm.Sdk.Discovery.RetrieveUserIdByExternalIdResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryRequest
Other Resources
Discovery Service Messages (Request and Response Classes)


DiscoveryResponse Members
See Also Methods Properties Constructors
[image]

Contains the response from the request and is the base class for all discovery service responses.

The following tables list the members exposed by the DiscoveryResponse type.

Protected Constructors

Name | Description
DiscoveryResponse | Initializes a new instance of the DiscoveryResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DiscoveryResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryRequest

Other Resources

Discovery Service Messages (Request and Response Classes)


DiscoveryResponse Constructor
[image]

Initializes a new instance of the DiscoveryResponse class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected DiscoveryResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryResponse Class
DiscoveryResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace


DiscoveryResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DiscoveryResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryRequest

Other Resources

Discovery Service Messages (Request and Response Classes)


DiscoveryResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

DiscoveryResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryRequest

Other Resources

Discovery Service Messages (Request and Response Classes)


DiscoveryResponse.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryResponse Class
DiscoveryResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace


EndpointAccessType Enumeration
[image]

Indicates the type of network access an endpoint has.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EndpointAccessType", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public Enumeration EndpointAccessType

C#
[DataContractAttribute(Name="EndpointAccessType", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public enum EndpointAccessType

C++

J#

JScript

  Members
Member name | Description
Default | Default access. The actual access is determined by the endpoint URL. Value = 0.
Internet | Internet access. Value = 1.
Intranet | Intranet access. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Discovery Namespace
Other Resources
Sample: Access the Discovery Service


EndpointCollection Class
See Also Members
[image]

A collection of service endpoints.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="EndpointCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public NotInheritable Class EndpointCollection
    Inherits DataCollection(Of EndpointType, String)

C#
[CollectionDataContractAttribute(Name="EndpointCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public sealed class EndpointCollection : DataCollection<EndpointType,string>

C++

J#

JScript

  Remarks
Typically used to identify each available service, and the service address, for an organization.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.Discovery.EndpointCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EndpointCollection Members
Microsoft.Xrm.Sdk.Discovery Namespace
Endpoints
EndpointType
Other Resources
Helper Code: ServerConnection Class


EndpointCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

A collection of service endpoints.

The following tables list the members exposed by the EndpointCollection type.

Public Constructors

Name | Description
EndpointCollection | Initializes a new instance of the EndpointCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

EndpointCollection Class
Microsoft.Xrm.Sdk.Discovery Namespace
Endpoints
EndpointType

Other Resources

Helper Code: ServerConnection Class


EndpointCollection Constructor
[image]

Initializes a new instance of the EndpointCollection class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EndpointCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EndpointCollection Class
EndpointCollection Members
Microsoft.Xrm.Sdk.Discovery Namespace


EndpointCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

EndpointCollection Class
Microsoft.Xrm.Sdk.Discovery Namespace
Endpoints
EndpointType

Other Resources

Helper Code: ServerConnection Class


EndpointCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

EndpointCollection Class
Microsoft.Xrm.Sdk.Discovery Namespace
Endpoints
EndpointType

Other Resources

Helper Code: ServerConnection Class


EndpointType Enumeration
[image]

Identifies the type of service available at an endpoint.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EndpointType", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public Enumeration EndpointType

C#
[DataContractAttribute(Name="EndpointType", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public enum EndpointType

C++

J#

JScript

  Members
Member name | Description
OrganizationDataService | The organization data service. Value = 1.
OrganizationService | The organization service. Value = 0.
WebApplication | The Web application service. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Discovery Namespace
Other Resources
Helper Code: ServerConnection Class


EndUserNotificationClient Enumeration
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration EndUserNotificationClient

C#
public enum EndUserNotificationClient

C++

J#

JScript

  Members
Member name | Description
Email | For internal use only.
None | For internal use only.
Outlook | For internal use only.
Portal | For internal use only.
WebApplication | For internal use only.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Discovery Namespace


IDiscoveryService Interface
See Also Members
[image]

Provides programmatic access to organization and user information.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<ServiceContractAttribute(Name:="IDiscoveryService", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
<ServiceKnownTypeAttribute(GetType(DiscoveryServiceFault))> _
Public Interface IDiscoveryService

C#
[ServiceContractAttribute(Name="IDiscoveryService", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
[ServiceKnownTypeAttribute(typeof(DiscoveryServiceFault))]
public interface IDiscoveryService

C++

J#

JScript

  Remarks
Refer to DiscoveryServiceProxy for an implementation of this interface.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IDiscoveryService Members
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryServiceProxy
Other Resources
Discover the URL for Your Organization With IDiscoveryService Web Service
Sample: Access the Discovery Service


IDiscoveryService Members
See Also Methods
[image]

Provides programmatic access to organization and user information.

The following tables list the members exposed by the IDiscoveryService type.

Public Methods

 | Name | Description
public method | Execute | Executes a discovery service message in the form of a request, and returns a response.
Top

See Also

Reference

IDiscoveryService Interface
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryServiceProxy

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Sample: Access the Discovery Service


IDiscoveryService Methods
[image]

Public Methods

 | Name | Description
public method | Execute | Executes a discovery service message in the form of a request, and returns a response.

See Also

Reference

IDiscoveryService Interface
Microsoft.Xrm.Sdk.Discovery Namespace
DiscoveryServiceProxy

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Sample: Access the Discovery Service


IDiscoveryService.Execute Method
[image]

Executes a discovery service message in the form of a request, and returns a response.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<OperationContractAttribute> _
<FaultContractAttribute(GetType(DiscoveryServiceFault))> _
Function Execute ( _
    request As DiscoveryRequest _
) As DiscoveryResponse

C#
[OperationContractAttribute]
[FaultContractAttribute(typeof(DiscoveryServiceFault))]
DiscoveryResponse Execute (
    DiscoveryRequest request
)

C++

J#

JScript

Parameters
request
Type: DiscoveryRequest. A request instance that defines the action to be performed.
Return Value
Type: DiscoveryResponse.
The response from processing the request. You must cast the return value of this method to the specific instance of the response that corresponds to the Request parameter.

  Remarks
Privileges and Access Rights
To execute a message, the caller must have a system user account on the Microsoft Dynamics CRM server.
Method Availability
This method works only when connected to the server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IDiscoveryService Interface
IDiscoveryService Members
Microsoft.Xrm.Sdk.Discovery Namespace
Other Resources
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service
Handle Exceptions in Your Code


OrganizationDetail Class
See Also Members
[image]

Provides detailed information on an organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OrganizationDetail", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public NotInheritable Class OrganizationDetail
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="OrganizationDetail", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public sealed class OrganizationDetail : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Discovery.OrganizationDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationResponse
Other Resources
Helper Code: ServerConnection Class


OrganizationDetail Members
See Also Constructors Methods Properties
[image]

Provides detailed information on an organization.

The following tables list the members exposed by the OrganizationDetail type.

Public Constructors

Name | Description
OrganizationDetail | Initializes a new instance of the OrganizationDetail class.
Top

Public Properties

 | Name | Description
public property | Endpoints | Gets a collection that identifies the service type and address for each endpoint of the organization.
public property | ExtensionData | Gets or sets extra data of the organization.
public property | FriendlyName | Gets or sets the friendly name of the organization.
public property | OrganizationId | Gets or sets global unique identifier of the organization.
public property | OrganizationVersion | Gets or sets the version of the organization.
public property | State | Gets or sets the state of the organization.
public property | UniqueName | Gets or sets the unique name of the organization.
public property | UrlName | Gets or sets the organization name used in the URL for the organization Web service.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrganizationDetail Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationResponse

Other Resources

Helper Code: ServerConnection Class


OrganizationDetail Constructor
[image]

Initializes a new instance of the OrganizationDetail class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrganizationDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrganizationDetail Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationResponse

Other Resources

Helper Code: ServerConnection Class


OrganizationDetail Properties
[image]

Public Properties

 | Name | Description
public property | Endpoints | Gets a collection that identifies the service type and address for each endpoint of the organization.
public property | ExtensionData | Gets or sets extra data of the organization.
public property | FriendlyName | Gets or sets the friendly name of the organization.
public property | OrganizationId | Gets or sets global unique identifier of the organization.
public property | OrganizationVersion | Gets or sets the version of the organization.
public property | State | Gets or sets the state of the organization.
public property | UniqueName | Gets or sets the unique name of the organization.
public property | UrlName | Gets or sets the organization name used in the URL for the organization Web service.

See Also

Reference

OrganizationDetail Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationResponse

Other Resources

Helper Code: ServerConnection Class


OrganizationDetail.Endpoints Property
[image]

Gets a collection that identifies the service type and address for each endpoint of the organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Endpoints As EndpointCollection

C#
[DataMemberAttribute]
public EndpointCollection Endpoints { get; }

C++

J#

JScript

Property Value
Type: EndpointCollection
The collection that identifies the service type and address for each endpoint of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetail.ExtensionData Property
[image]

Gets or sets extra data of the organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
 Extra data of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetail.FriendlyName Property
[image]

Gets or sets the friendly name of the organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FriendlyName As String

C#
[DataMemberAttribute]
public string FriendlyName { get; set; }

C++

J#

JScript

Property Value
Type: String
 The friendly name of the organization.

  Remarks
The friendly name was defined when the organization was provisioned.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetail.OrganizationId Property
[image]

Gets or sets global unique identifier of the organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrganizationId As Guid

C#
[DataMemberAttribute]
public Guid OrganizationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The global unique identifier of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetail.OrganizationVersion Property
[image]

Gets or sets the version of the organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrganizationVersion As String

C#
[DataMemberAttribute]
public string OrganizationVersion { get; set; }

C++

J#

JScript

Property Value
Type: String
 The version of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetail.State Property
[image]

Gets or sets the state of the organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property State As OrganizationState

C#
[DataMemberAttribute]
public OrganizationState State { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationState
The state of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetail.UniqueName Property
[image]

Gets or sets the unique name of the organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UniqueName As String

C#
[DataMemberAttribute]
public string UniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name of the organization.

  Remarks
The unique name is not necessarily similar to the friendly name.
The organization unique name was defined when the organization was created. To determine the organization unique name using the Microsoft Dynamics CRM Web application, first select Settings, next select Customizations, finally click Developer Resources.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetail.UrlName Property
[image]

Gets or sets the organization name used in the URL for the organization Web service.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification:="Returned as string for compatibility")> _
<DataMemberAttribute> _
Public Property UrlName As String

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification="Returned as string for compatibility")]
[DataMemberAttribute]
public string UrlName { get; set; }

C++

J#

JScript

Property Value
Type: String
 The organization name used in the URL for the organization Web service.

  Remarks
The organization URL name is AdventureWorksCycle in the following Web service URL example:
http://localhost/AdventureWorksCycle/xrmservices/2011/Organization.svc

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetailCollection Class
See Also Members
[image]

Provides a collection of OrganizationDetail instances.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="OrganizationDetailCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public NotInheritable Class OrganizationDetailCollection
    Inherits DataCollection(Of OrganizationDetail)

C#
[CollectionDataContractAttribute(Name="OrganizationDetailCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public sealed class OrganizationDetailCollection : DataCollection<OrganizationDetail>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.Discovery.OrganizationDetailCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetailCollection Members
Microsoft.Xrm.Sdk.Discovery Namespace
Details
Other Resources
Helper Code: ServerConnection Class


OrganizationDetailCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Provides a collection of OrganizationDetail instances.

The following tables list the members exposed by the OrganizationDetailCollection type.

Public Constructors

Name | Description
OrganizationDetailCollection | Initializes a new instance of the OrganizationDetailCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

OrganizationDetailCollection Class
Microsoft.Xrm.Sdk.Discovery Namespace
Details

Other Resources

Helper Code: ServerConnection Class


OrganizationDetailCollection Constructor
[image]

Initializes a new instance of the OrganizationDetailCollection class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrganizationDetailCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationDetailCollection Class
OrganizationDetailCollection Members
Microsoft.Xrm.Sdk.Discovery Namespace


OrganizationDetailCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

OrganizationDetailCollection Class
Microsoft.Xrm.Sdk.Discovery Namespace
Details

Other Resources

Helper Code: ServerConnection Class


OrganizationDetailCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

OrganizationDetailCollection Class
Microsoft.Xrm.Sdk.Discovery Namespace
Details

Other Resources

Helper Code: ServerConnection Class


OrganizationRelease Enumeration
[image]

Describes the release of an organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OrganizationRelease", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public Enumeration OrganizationRelease

C#
[DataContractAttribute(Name="OrganizationRelease", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public enum OrganizationRelease

C++

J#

JScript

  Members
Member name | Description
Current | The current release. Value = 0.
V5 | The Microsoft Dynamics CRM 2011 release. Value = 1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Discovery Namespace
Release
Other Resources
Sample: Access the Discovery Service


OrganizationState Enumeration
[image]

Describes the current state of an organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OrganizationState", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public Enumeration OrganizationState

C#
[DataContractAttribute(Name="OrganizationState", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public enum OrganizationState

C++

J#

JScript

  Members
Member name | Description
Disabled | The organization is disabled. Value = 1.
Enabled | The organization is enabled. Value = 0.
  Remarks
Related to organization provisioning and maintenance.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Discovery Namespace
State


RetrieveOrganizationRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve information about an organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveOrganizationRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public NotInheritable Class RetrieveOrganizationRequest
    Inherits DiscoveryRequest

C#
[DataContractAttribute(Name="RetrieveOrganizationRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public sealed class RetrieveOrganizationRequest : DiscoveryRequest

C++

J#

JScript

  Example
C#    Copy Code
// Retrieve details about a single organization discoverable via the Discovery service.
//
RetrieveOrganizationRequest orgRequest =
    new RetrieveOrganizationRequest()
    {
        UniqueName = organizations.Details[organizations.Details.Count -1].UniqueName,
        AccessType = EndpointAccessType.Default,
        Release = OrganizationRelease.Current
    };
RetrieveOrganizationResponse org =
    (RetrieveOrganizationResponse)service.Execute(orgRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method.
Privileges and Access Rights
To perform this action, the caller must have  a system user account in Microsoft Dynamics CRM.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Discovery.DiscoveryRequest
    Microsoft.Xrm.Sdk.Discovery.RetrieveOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveOrganizationRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationResponse
Other Resources
Discover the URL for Your Organization With IDiscoveryService Web Service
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve information about an organization.

The following tables list the members exposed by the RetrieveOrganizationRequest type.

Public Constructors

Name | Description
RetrieveOrganizationRequest | Initializes a new instance of the RetrieveOrganizationRequest class.
Top

Public Properties

 | Name | Description
public property | AccessType | Gets or sets the access type of the organization’s service endpoint.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from DiscoveryRequest)
public property | Release | Indicates the applicable version of Microsoft Dynamics CRM.
public property | UniqueName | Gets or sets the unique name of the organization.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveOrganizationRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationResponse

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationRequest Constructor
[image]

Initializes a new instance of the RetrieveOrganizationRequest class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveOrganizationRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationRequest Class
RetrieveOrganizationRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveOrganizationRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationResponse

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationRequest Properties
[image]

Public Properties

 | Name | Description
public property | AccessType | Gets or sets the access type of the organization’s service endpoint.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from DiscoveryRequest)
public property | Release | Indicates the applicable version of Microsoft Dynamics CRM.
public property | UniqueName | Gets or sets the unique name of the organization.

See Also

Reference

RetrieveOrganizationRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationResponse

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationRequest.AccessType Property
[image]

Gets or sets the access type of the organization’s service endpoint.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=False)> _
Public Property AccessType As EndpointAccessType

C#
[DataMemberAttribute(IsRequired=false)]
public EndpointAccessType AccessType { get; set; }

C++

J#

JScript

Property Value
Type: EndpointAccessType
The access type.

  Remarks
Identifies the access type of the organization to retrieve.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationRequest Class
RetrieveOrganizationRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationRequest.Release Property
[image]

Indicates the applicable version of Microsoft Dynamics CRM.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=False)> _
Public Property Release As OrganizationRelease

C#
[DataMemberAttribute(IsRequired=false)]
public OrganizationRelease Release { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationRelease
The release to retrieve.

  Remarks
Identifies the release of the organization to retrieve.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationRequest Class
RetrieveOrganizationRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationRequest.UniqueName Property
[image]

Gets or sets the unique name of the organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UniqueName As String

C#
[DataMemberAttribute]
public string UniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The organization unique name.

  Remarks
Identifies the name of the organization to retrieve.
The organization unique name was defined when the organization was created. To determine the organization unique name using the Microsoft Dynamics CRM Web application, first select Settings, next select Customizations, finally click Developer Resources.
You can retrieve information, including the unique name, on all organizations that the logged on user belongs to using RetrieveOrganizationsRequest.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationRequest Class
RetrieveOrganizationRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationResponse Class
See Also Members
[image]

Contains the response from processing RetrieveOrganizationRequest.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveOrganizationResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public NotInheritable Class RetrieveOrganizationResponse
    Inherits DiscoveryResponse

C#
[DataContractAttribute(Name="RetrieveOrganizationResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public sealed class RetrieveOrganizationResponse : DiscoveryResponse

C++

J#

JScript

  Remarks
An instance of a response class is returned from the Execute method.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Discovery.DiscoveryResponse
    Microsoft.Xrm.Sdk.Discovery.RetrieveOrganizationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace
Other Resources
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from processing RetrieveOrganizationRequest.

The following tables list the members exposed by the RetrieveOrganizationResponse type.

Public Constructors

Name | Description
RetrieveOrganizationResponse | Initializes a new instance of the RetrieveOrganizationResponse class.
Top

Public Properties

 | Name | Description
public property | Detail | Contains detailed information about the target organization.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DiscoveryResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveOrganizationResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace

Other Resources

Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationResponse Constructor
[image]

Initializes a new instance of the RetrieveOrganizationResponse class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveOrganizationResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationResponse Class
RetrieveOrganizationResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveOrganizationResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace

Other Resources

Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationResponse Properties
[image]

Public Properties

 | Name | Description
public property | Detail | Contains detailed information about the target organization.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DiscoveryResponse)

See Also

Reference

RetrieveOrganizationResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace

Other Resources

Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationResponse.Detail Property
[image]

Contains detailed information about the target organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Detail As OrganizationDetail

C#
[DataMemberAttribute]
public OrganizationDetail Detail { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationDetail
The details about the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationResponse Class
RetrieveOrganizationResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationsRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve information on all organizations that the logged on user belongs to.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveOrganizationsRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public NotInheritable Class RetrieveOrganizationsRequest
    Inherits DiscoveryRequest

C#
[DataContractAttribute(Name="RetrieveOrganizationsRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public sealed class RetrieveOrganizationsRequest : DiscoveryRequest

C++

J#

JScript

  Example
C#    Copy Code
// Retrieve details about all organizations discoverable via the
// Discovery service.
RetrieveOrganizationsRequest orgsRequest =
    new RetrieveOrganizationsRequest()
    {
        AccessType = EndpointAccessType.Default,
        Release = OrganizationRelease.Current
    };
RetrieveOrganizationsResponse organizations =
    (RetrieveOrganizationsResponse)service.Execute(orgsRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method.
Privileges and Access Rights
To perform this action, the caller must have a system user account in Microsoft Dynamics CRM.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Discovery.DiscoveryRequest
    Microsoft.Xrm.Sdk.Discovery.RetrieveOrganizationsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveOrganizationsRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationsResponse
Other Resources
Discover the URL for Your Organization With IDiscoveryService Web Service
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve information on all organizations that the logged on user belongs to.

The following tables list the members exposed by the RetrieveOrganizationsRequest type.

Public Constructors

Name | Description
RetrieveOrganizationsRequest | Initializes a new instance of the RetrieveOrganizationsRequest class.
Top

Public Properties

 | Name | Description
public property | AccessType | Gets or sets the access type of the organizations’ service endpoint.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from DiscoveryRequest)
public property | IsInternalCrossGeoServerRequest | For internal use only.
public property | Release | Get or sets the release version of a Microsoft Dynamics CRM organization.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveOrganizationsRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationsResponse

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationsRequest Constructor
[image]

Initializes a new instance of the RetrieveOrganizationsRequest class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveOrganizationsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationsRequest Class
RetrieveOrganizationsRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveOrganizationsRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationsResponse

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationsRequest Properties
[image]

Public Properties

 | Name | Description
public property | AccessType | Gets or sets the access type of the organizations’ service endpoint.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from DiscoveryRequest)
public property | IsInternalCrossGeoServerRequest | For internal use only.
public property | Release | Get or sets the release version of a Microsoft Dynamics CRM organization.

See Also

Reference

RetrieveOrganizationsRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveOrganizationsResponse

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationsRequest.AccessType Property
[image]

Gets or sets the access type of the organizations’ service endpoint.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=False)> _
Public Property AccessType As EndpointAccessType

C#
[DataMemberAttribute(IsRequired=false)]
public EndpointAccessType AccessType { get; set; }

C++

J#

JScript

Property Value
Type: EndpointAccessType
The access type of the organizations’ service endpoint.

  Remarks
Indicates the type of network access an endpoint has.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationsRequest Class
RetrieveOrganizationsRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationsRequest.IsInternalCrossGeoServerRequest Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=False)> _
Public Property IsInternalCrossGeoServerRequest As Boolean

C#
[DataMemberAttribute(IsRequired=false)]
public bool IsInternalCrossGeoServerRequest { get; set; }

C++

J#

JScript

Property Value
Type:Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationsRequest Class
RetrieveOrganizationsRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationsRequest.Release Property
[image]

Get or sets the release version of a Microsoft Dynamics CRM organization.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(IsRequired:=False)> _
Public Property Release As OrganizationRelease

C#
[DataMemberAttribute(IsRequired=false)]
public OrganizationRelease Release { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationRelease
The organizations’ release version.

  Remarks
Organizations have a release version and can be upgraded to a newer release. This property can be used to identify if your organization is on a Microsoft Dynamics CRM 2011 release or not.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationsRequest Class
RetrieveOrganizationsRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationsResponse Class
See Also Members
[image]

Contains the response from processing RetrieveOrganizationsRequest.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveOrganizationsResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public NotInheritable Class RetrieveOrganizationsResponse
    Inherits DiscoveryResponse

C#
[DataContractAttribute(Name="RetrieveOrganizationsResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public sealed class RetrieveOrganizationsResponse : DiscoveryResponse

C++

J#

JScript

  Remarks
An instance of a response class is returned from the Execute method.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Discovery.DiscoveryResponse
    Microsoft.Xrm.Sdk.Discovery.RetrieveOrganizationsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationsResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace
Other Resources
Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from processing RetrieveOrganizationsRequest.

The following tables list the members exposed by the RetrieveOrganizationsResponse type.

Public Constructors

Name | Description
RetrieveOrganizationsResponse | Initializes a new instance of the RetrieveOrganizationsResponse class.
Top

Public Properties

 | Name | Description
public property | Details | Contains detailed information about the target organizations.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DiscoveryResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveOrganizationsResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace

Other Resources

Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationsResponse Constructor
[image]

Initializes a new instance of the RetrieveOrganizationsResponse class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveOrganizationsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationsResponse Class
RetrieveOrganizationsResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveOrganizationsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveOrganizationsResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace

Other Resources

Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationsResponse Properties
[image]

Public Properties

 | Name | Description
public property | Details | Contains detailed information about the target organizations.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DiscoveryResponse)

See Also

Reference

RetrieveOrganizationsResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace

Other Resources

Discovery Service Messages (Request and Response Classes)
Sample: Access the Discovery Service


RetrieveOrganizationsResponse.Details Property
[image]

Contains detailed information about the target organizations.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Details As OrganizationDetailCollection

C#
[DataMemberAttribute]
public OrganizationDetailCollection Details { get; }

C++

J#

JScript

Property Value
Type: OrganizationDetailCollection
The details about the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOrganizationsResponse Class
RetrieveOrganizationsResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveUserIdByExternalIdRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the Microsoft Dynamics CRM or Microsoft Dynamics CRM Online system user ID that is associated with a given identity provider ID.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveUserIdByExternalIdRequest", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public NotInheritable Class RetrieveUserIdByExternalIdRequest
    Inherits DiscoveryRequest

C#
[DataContractAttribute(Name="RetrieveUserIdByExternalIdRequest", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public sealed class RetrieveUserIdByExternalIdRequest : DiscoveryRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the Execute method.
Privileges and Access Rights
To perform this action, the caller must have a system user account in Microsoft Dynamics CRM.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Discovery.DiscoveryRequest
    Microsoft.Xrm.Sdk.Discovery.RetrieveUserIdByExternalIdRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserIdByExternalIdRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveUserIdByExternalIdResponse
Other Resources
Discovery Service Messages (Request and Response Classes)


RetrieveUserIdByExternalIdRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the Microsoft Dynamics CRM or Microsoft Dynamics CRM Online system user ID that is associated with a given identity provider ID.

The following tables list the members exposed by the RetrieveUserIdByExternalIdRequest type.

Public Constructors

Name | Description
RetrieveUserIdByExternalIdRequest | Initializes a new instance of the RetrieveUserIdByExternalIdRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from DiscoveryRequest)
public property | ExternalId | Gets or sets the ID of the target user.
public property | OrganizationId | Gets or sets the ID of the organization that the target system user is a member of.
public property | OrganizationName | Gets or sets the unique name of the organization that the target system user is a member of.
public property | Release | Gets or sets the release version of the Microsoft Dynamics CRM product.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserIdByExternalIdRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveUserIdByExternalIdResponse

Other Resources

Discovery Service Messages (Request and Response Classes)


RetrieveUserIdByExternalIdRequest Constructor
[image]

Initializes a new instance of the RetrieveUserIdByExternalIdRequest class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserIdByExternalIdRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserIdByExternalIdRequest Class
RetrieveUserIdByExternalIdRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveUserIdByExternalIdRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserIdByExternalIdRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveUserIdByExternalIdResponse

Other Resources

Discovery Service Messages (Request and Response Classes)


RetrieveUserIdByExternalIdRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from DiscoveryRequest)
public property | ExternalId | Gets or sets the ID of the target user.
public property | OrganizationId | Gets or sets the ID of the organization that the target system user is a member of.
public property | OrganizationName | Gets or sets the unique name of the organization that the target system user is a member of.
public property | Release | Gets or sets the release version of the Microsoft Dynamics CRM product.

See Also

Reference

RetrieveUserIdByExternalIdRequest Class
Microsoft.Xrm.Sdk.Discovery Namespace
RetrieveUserIdByExternalIdResponse

Other Resources

Discovery Service Messages (Request and Response Classes)


RetrieveUserIdByExternalIdRequest.ExternalId Property
[image]

Gets or sets the ID of the target user.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ExternalId As String

C#
[DataMemberAttribute]
public string ExternalId { get; set; }

C++

J#

JScript

Property Value
Type: String
The external ID of the user to retrieve.

  Remarks
For Microsoft Dynamics CRM (IFD), the identity provider is typically Active Directory Federation Services 2.0 (ADFS). For Microsoft Dynamics CRM Online, the identity provider is typically Microsoft Online Services, but Microsoft account is still possible in some cases.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserIdByExternalIdRequest Class
RetrieveUserIdByExternalIdRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveUserIdByExternalIdRequest.OrganizationId Property
[image]

Gets or sets the ID of the organization that the target system user is a member of.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrganizationId As Guid

C#
[DataMemberAttribute]
public Guid OrganizationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the organization that the target system user is a member of.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserIdByExternalIdRequest Class
RetrieveUserIdByExternalIdRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveUserIdByExternalIdRequest.OrganizationName Property
[image]

Gets or sets the unique name of the organization that the target system user is a member of.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrganizationName As String

C#
[DataMemberAttribute]
public string OrganizationName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name of the organization that the target system user is a member of.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserIdByExternalIdRequest Class
RetrieveUserIdByExternalIdRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveUserIdByExternalIdRequest.Release Property
[image]

Gets or sets the release version of the Microsoft Dynamics CRM product.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Release As String

C#
[DataMemberAttribute]
public string Release { get; set; }

C++

J#

JScript

Property Value
Type: String
The release version of the Microsoft Dynamics CRM product.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserIdByExternalIdRequest Class
RetrieveUserIdByExternalIdRequest Members
Microsoft.Xrm.Sdk.Discovery Namespace
OrganizationRelease


RetrieveUserIdByExternalIdResponse Class
See Also Members
[image]

Contains the response from processing RetrieveUserIdByExternalIdRequest.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RetrieveUserIdByExternalIdResponse", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")> _
Public NotInheritable Class RetrieveUserIdByExternalIdResponse
    Inherits DiscoveryResponse

C#
[DataContractAttribute(Name="RetrieveUserIdByExternalIdResponse", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts/Discovery")]
public sealed class RetrieveUserIdByExternalIdResponse : DiscoveryResponse

C++

J#

JScript

  Remarks
An instance of a response class is returned from the Execute method.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Discovery.DiscoveryResponse
    Microsoft.Xrm.Sdk.Discovery.RetrieveUserIdByExternalIdResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserIdByExternalIdResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace
Other Resources
Discovery Service Messages (Request and Response Classes)


RetrieveUserIdByExternalIdResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from processing RetrieveUserIdByExternalIdRequest.

The following tables list the members exposed by the RetrieveUserIdByExternalIdResponse type.

Public Constructors

Name | Description
RetrieveUserIdByExternalIdResponse | Initializes a new instance of the RetrieveUserIdByExternalIdResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DiscoveryResponse)
public property | UserId | Gets or sets the ID of the Microsoft Dynamics CRM Online system user.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveUserIdByExternalIdResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace

Other Resources

Discovery Service Messages (Request and Response Classes)


RetrieveUserIdByExternalIdResponse Constructor
[image]

Initializes a new instance of the RetrieveUserIdByExternalIdResponse class.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveUserIdByExternalIdResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserIdByExternalIdResponse Class
RetrieveUserIdByExternalIdResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace


RetrieveUserIdByExternalIdResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveUserIdByExternalIdResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace

Other Resources

Discovery Service Messages (Request and Response Classes)


RetrieveUserIdByExternalIdResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from DiscoveryResponse)
public property | UserId | Gets or sets the ID of the Microsoft Dynamics CRM Online system user.

See Also

Reference

RetrieveUserIdByExternalIdResponse Class
Microsoft.Xrm.Sdk.Discovery Namespace

Other Resources

Discovery Service Messages (Request and Response Classes)


RetrieveUserIdByExternalIdResponse.UserId Property
[image]

Gets or sets the ID of the Microsoft Dynamics CRM Online system user.

Namespace: Microsoft.Xrm.Sdk.Discovery
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UserId As Guid

C#
[DataMemberAttribute]
public Guid UserId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the user.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveUserIdByExternalIdResponse Class
RetrieveUserIdByExternalIdResponse Members
Microsoft.Xrm.Sdk.Discovery Namespace


Microsoft.Xrm.Sdk.Messages Namespace

Classes

Class | Description
AssociateRequest | Contains the data that is needed to create a link between records.
AssociateResponse | Contains the response from the AssociateRequest class.
CanBeReferencedRequest | Contains the data that is needed to check whether the specified entity can be the primary entity (one) in a one-to-many relationship.
CanBeReferencedResponse | Contains the response from the CanBeReferencedRequest class.
CanBeReferencingRequest | Contains the data that is needed to check whether an entity can be the referencing entity in a one-to-many relationship.
CanBeReferencingResponse | Contains the response from the CanBeReferencingRequest class.
CanManyToManyRequest | Contains the data that is needed to check whether an entity can participate in a many-to-many relationship.
CanManyToManyResponse | Contains the response from the CanManyToManyRequest class.
CreateAttributeRequest | Contains the data that is needed to create a new attribute, and optionally, to add it to a specified unmanaged solution.
CreateAttributeResponse | Contains the response from the CreateAttributeRequest class.
CreateEntityRequest | Contains the data that is needed to create a custom entity, and optionally, to add it to a specified unmanaged solution.
CreateEntityResponse | Contains the response from the CreateEntityRequest class.
CreateManyToManyRequest | Contains the data that is needed to create a new Many-to-Many (N:N) entity relationship.
CreateManyToManyResponse | Contains the response from the CreateManyToManyRequest class.
CreateOneToManyRequest | Contains the data that is needed to create a new One-to-Many (1:N) entity relationship.
CreateOneToManyResponse | Contains the response from the CreateOneToManyRequest class.
CreateOptionSetRequest | Contains the data that is needed to create a new global option set.
CreateOptionSetResponse | Contains the response from the CreateOptionSetRequest class.
CreateRequest | Contains the data that is needed to create a record.
CreateResponse | Contains the response from the CreateRequest class.
DeleteAttributeRequest | Contains the data that is needed to delete an attribute.
DeleteAttributeResponse | Contains the response from the DeleteAttributeRequest class.
DeleteEntityRequest | Contains the data that is needed to delete an entity.
DeleteEntityResponse | Contains the response from the DeleteEntityRequest class.
DeleteOptionSetRequest | Contains the data that is needed to delete a global option set.
DeleteOptionSetResponse | Contains the response from the DeleteOptionSetRequest class.
DeleteOptionValueRequest | Contains the data that is needed to delete an option value in a global or local option set.
DeleteOptionValueResponse | Contains the response from the DeleteOptionValueRequest class.
DeleteRelationshipRequest | Contains the data that is needed to delete an entity relationship.
DeleteRelationshipResponse | Contains the response from the DeleteRelationshipRequest class.
DeleteRequest | Contains the data that is needed to delete a record.
DeleteResponse | Contains the response from the DeleteRequest class.
DisassociateRequest | Contains the data that is needed to delete a link between records.
DisassociateResponse | Contains the response from the DisassociateRequest class.
ExecuteAsyncRequest | Contains the data that is needed to execute a message asynchronously.
ExecuteAsyncResponse | Contains the response from the ExecuteAsyncRequest class.
ExecuteMultipleRequest | Contains the data that is needed to execute one or more message requests as a single batch operation, and optionally return a collection of results.
ExecuteMultipleResponse | Contains the response from the ExecuteMultipleRequest class.
GetValidManyToManyRequest | Contains the data that is needed to retrieve a list of all the entities that can participate in a Many-to-Many entity relationship.
GetValidManyToManyResponse | Contains the response from the GetValidManyToManyRequest class.
GetValidReferencedEntitiesRequest | Contains the data that is needed to retrieve a list of entity logical names that are valid as the primary entity (one) from the specified entity in a one-to-many relationship.
GetValidReferencedEntitiesResponse | Contains the response from the GetValidReferencedEntitiesRequest class.
GetValidReferencingEntitiesRequest | Contains the data that is needed to retrieve the set of entities that are valid as the related entity (many) to the specified entity in a one-to-many relationship.
GetValidReferencingEntitiesResponse | Contains the response from the GetValidReferencingEntitiesRequest class.
InsertOptionValueRequest | Contains the data that is needed to insert a new option value for a global or local option set.
InsertOptionValueResponse | Contains the response from the InsertOptionValueRequest class.
InsertStatusValueRequest | Contains the data that is needed to insert a new option into a StatusAttributeMetadata attribute.
InsertStatusValueResponse | Contains the response from the InsertStatusValueRequest class.
IsDataEncryptionActiveRequest | Contains the data that is needed to check if data encryption is currently running (active or inactive).
IsDataEncryptionActiveResponse | Contains the response from the IsDataEncryptionActiveRequest class.
OrderOptionRequest | Contains the data that is needed to set the order for an option set.
OrderOptionResponse | Contains the response from the OrderOptionRequest class.
RetrieveAllEntitiesRequest | Contains the data that is needed to retrieve metadata information about all the entities.
RetrieveAllEntitiesResponse | Contains the response from the RetrieveAllEntitiesRequest class.
RetrieveAllManagedPropertiesRequest | Contains the data that is needed to retrieve all managed property definitions
RetrieveAllManagedPropertiesResponse | Contains the response from the RetrieveAllManagedPropertiesRequest class.
RetrieveAllOptionSetsRequest | Contains the data that is needed to retrieve information about all global option sets.
RetrieveAllOptionSetsResponse | Contains the response from the RetrieveAllOptionSetsRequest class.
RetrieveAttributeRequest | Contains the data that is needed to retrieve attribute metadata.
RetrieveAttributeResponse | Contains the response from the RetrieveAttributeRequest class.
RetrieveDataEncryptionKeyRequest | Contains the data that is needed to retrieve the data encryption key value.
RetrieveDataEncryptionKeyResponse | Contains the response from the RetrieveDataEncryptionKeyResponse class.
RetrieveEntityRequest | Contains the data that is needed to retrieve entity metadata.
RetrieveEntityResponse | Contains the response from the RetrieveEntityRequest class.
RetrieveManagedPropertyRequest | Contains the data that is needed to retrieve a managed property definition.
RetrieveManagedPropertyResponse | Contains the response from the RetrieveManagedPropertyRequest class.
RetrieveMetadataChangesRequest | Contains the data that is needed to to retrieve a collection of metadata records that satisfy the specified criteria. The RetrieveMetadataChangesResponse returns a timestamp value that can be used with this request at a later time to return information about how metadata has changed since the last request.
RetrieveMetadataChangesResponse | Contains the response from the RetrieveMetadataChangesRequest message.
RetrieveMultipleRequest | Contains the data that is needed to retrieve a collection of records that satisfy the specified query criteria.
RetrieveMultipleResponse | Contains the response from the RetrieveMultipleRequest class.
RetrieveOptionSetRequest | Contains the data that is needed to retrieve a global option set.
RetrieveOptionSetResponse | Contains the response from the RetrieveOptionSetRequest class.
RetrieveRelationshipRequest | Contains the data that is needed to retrieve entity relationship metadata.
RetrieveRelationshipResponse | Contains the response from the RetrieveRelationshipRequest class.
RetrieveRequest | Contains the data that is needed to retrieve a record.
RetrieveResponse | Contains the response from the RetrieveRequest class.
RetrieveTimestampRequest | Contains the data that is needed to retrieves a time stamp for the metadata.
RetrieveTimestampResponse | Contains the response from the RetrieveTimestampRequest class.
SetDataEncryptionKeyRequest | Contains the data that is needed to set or restore the data encryption key.
SetDataEncryptionKeyResponse | Contains the response from the SetDataEncryptionKeyRequest class.
UpdateAttributeRequest | Contains the data that is needed to update the definition of an attribute.
UpdateAttributeResponse | Contains the response from the UpdateAttributeRequest class.
UpdateEntityRequest | Contains the data that is needed to update the definition of an entity.
UpdateEntityResponse | Contains the response from the UpdateEntityRequest class.
UpdateOptionSetRequest | Contains the data that is needed to update the definition of a global option set.
UpdateOptionSetResponse | Contains the response from the UpdateOptionSetRequest class.
UpdateOptionValueRequest | Contains the data that is needed to update an option value in a global or local option set.
UpdateOptionValueResponse | Contains the response from the UpdateOptionValueRequest class.
UpdateRelationshipRequest | Contains the data that is needed to update the definition of an entity relationship.
UpdateRelationshipResponse | Contains the response from the UpdateRelationshipRequest class.
UpdateRequest | Contains the data that is needed to update an existing record.
UpdateResponse | Contains the response from the UpdateRequest class.
UpdateStateValueRequest | Contains the data that is needed to update an option set value in for a StateAttributeMetadata attribute.
UpdateStateValueResponse | Contains the response from the UpdateStateValueRequest class.


AssociateRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a link between records.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class AssociateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class AssociateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following sample shows how to execute the AssociateRequest message.
C#    Copy Code
// Create the request object and set the monikers with the
// teamprofiles_association relationship.
AssociateRequest teamToProfile = new AssociateRequest
{
    Target = new EntityReference(FieldSecurityProfile.EntityLogicalName, _profileId),
    RelatedEntities = new EntityReferenceCollection
    {
        new EntityReference(Team.EntityLogicalName, _teamId)
    },
    Relationship = new Relationship("teamprofiles_association")
};

// Execute the request.
_serviceProxy.Execute(teamToProfile);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the AssociateResponse class.
Privileges and Access Rights
To perform this action, the caller must have  privileges on the specified entity in the Target property and access rights on the specified records in the Target and RelatedEntities properties. For a list of the required privileges, see Associate Privileges.
Notes for Callers
This message uses a single transaction to create multiple associations between the record that is specified by the Id in the Target property and each record in the RelatedEntities property. The associations are created for the specified relationship in the Relationship property.
You can also use the Associate method to perform the same action.
For a one-to-many relationship, this message sets the ReferencingAttribute property in the related record to the value of the Id in the Target.
For a many-to-many relationship, this message creates a record in the intersect table for the relationship, which contains the ID of both the referenced and referencing records. The intersect table name is defined in the IntersectEntityName property for the relationship. You need this when you query for the records. However, you need the relationship name to set the Relationship property. This name is defined in the SchemaName property for the relationship.
Supported Entities
You can use this message to associate records of any two entities (includes records for custom entities) that participate in a relationship. To find a list of the default relationships, see the Entity Metadata topic for each entity.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.AssociateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AssociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
AssociateResponse
Associate
Other Resources
Entity Metadata
Entity Relationship Behavior
Customize Entity Relationship Metadata
Sample: Retrieve Field Permissions
Associate Privileges


AssociateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a link between records.

The following tables list the members exposed by the AssociateRequest type.

Public Constructors

Name | Description
AssociateRequest | Initializes a new instance of the AssociateRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelatedEntities | Gets or sets the collection of entity references (references to records) to be associated. Required.
public property | Relationship | Get or sets the relationship name to be used for an association. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target that is the record to which the related records are associated. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AssociateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
AssociateResponse
Associate

Other Resources

Entity Metadata
Entity Relationship Behavior
Customize Entity Relationship Metadata
Sample: Retrieve Field Permissions
Associate Privileges


AssociateRequest Constructor
[image]

Initializes a new instance of the AssociateRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AssociateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateRequest Class
AssociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


AssociateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AssociateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
AssociateResponse
Associate

Other Resources

Entity Metadata
Entity Relationship Behavior
Customize Entity Relationship Metadata
Sample: Retrieve Field Permissions
Associate Privileges


AssociateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelatedEntities | Gets or sets the collection of entity references (references to records) to be associated. Required.
public property | Relationship | Get or sets the relationship name to be used for an association. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target that is the record to which the related records are associated. Required.

See Also

Reference

AssociateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
AssociateResponse
Associate

Other Resources

Entity Metadata
Entity Relationship Behavior
Customize Entity Relationship Metadata
Sample: Retrieve Field Permissions
Associate Privileges


AssociateRequest.RelatedEntities Property
[image]

Gets or sets the collection of entity references (references to records) to be associated. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RelatedEntities As EntityReferenceCollection

C#
public EntityReferenceCollection RelatedEntities { get; set; }

C++

J#

JScript

Property Value
Type: EntityReferenceCollection

The collection of entity references (references to records) to be associated.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateRequest Class
AssociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


AssociateRequest.Relationship Property
[image]

Get or sets the relationship name to be used for an association. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Relationship As Relationship

C#
public Relationship Relationship { get; set; }

C++

J#

JScript

Property Value
Type: Relationship
The relationship name to be used for an association.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateRequest Class
AssociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


AssociateRequest.Target Property
[image]

Gets or sets the target that is the record to which the related records are associated. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference

The target that is the record to which the related records are associated.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateRequest Class
AssociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


AssociateResponse Class
See Also Members
[image]

Contains the response from the AssociateRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class AssociateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class AssociateResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.AssociateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
AssociateRequest
Associate


AssociateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the AssociateRequest class.

The following tables list the members exposed by the AssociateResponse type.

Public Constructors

Name | Description
AssociateResponse | Initializes a new instance of the AssociateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AssociateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
AssociateRequest
Associate


AssociateResponse Constructor
[image]

Initializes a new instance of the AssociateResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AssociateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociateResponse Class
AssociateResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


AssociateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AssociateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
AssociateRequest
Associate


AssociateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

AssociateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
AssociateRequest
Associate


CanBeReferencedRequest Class
See Also Example Members
[image]

Contains the data that is needed to check whether the specified entity can be the primary entity (one) in a one-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CanBeReferencedRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CanBeReferencedRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
/// <summary>
/// Determines whether two entities are eligible to participate in a relationship
/// </summary>
/// <param name="referencedEntity">Primary Entity</param>
/// <param name="referencingEntity">Referencing Entity</param>
/// <returns></returns>
public bool EligibleCreateOneToManyRelationship(string referencedEntity,
    string referencingEntity)
{
    //Checks whether the specified entity can be the primary entity in one-to-many
    //relationship.
    CanBeReferencedRequest canBeReferencedRequest = new CanBeReferencedRequest
    {
        EntityName = referencedEntity
    };

    CanBeReferencedResponse canBeReferencedResponse =
        (CanBeReferencedResponse)_serviceProxy.Execute(canBeReferencedRequest);

    if (!canBeReferencedResponse.CanBeReferenced)
    {
        Console.WriteLine(
            "Entity {0} can't be the primary entity in this one-to-many relationship",
            referencedEntity);
    }

    //Checks whether the specified entity can be the referencing entity in one-to-many
    //relationship.
    CanBeReferencingRequest canBereferencingRequest = new CanBeReferencingRequest
    {
        EntityName = referencingEntity
    };

    CanBeReferencingResponse canBeReferencingResponse =
        (CanBeReferencingResponse)_serviceProxy.Execute(canBereferencingRequest);

    if (!canBeReferencingResponse.CanBeReferencing)
    {
        Console.WriteLine(
            "Entity {0} can't be the referencing entity in this one-to-many relationship",
            referencingEntity);
    }

    if (canBeReferencedResponse.CanBeReferenced == true
        && canBeReferencingResponse.CanBeReferencing == true)
    {
        return true;
    }
    else
    {
        return false;
    }
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute  method, which returns an instance of  the CanBeReferencedResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in CanBeReferenced Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.CanBeReferencedRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CanBeReferencedRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencedResponse
Other Resources
Sample: Create and Retrieve Entity Relationships
EligibleCreateOneToManyRelationship
Entity Relationship Eligibility
CanBeReferenced Privileges


CanBeReferencedRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to check whether the specified entity can be the primary entity (one) in a one-to-many relationship.

The following tables list the members exposed by the CanBeReferencedRequest type.

Public Constructors

Name | Description
CanBeReferencedRequest | Initializes a new instance of the CanBeReferencedRequest class.
Top

Public Properties

 | Name | Description
public property | EntityName | Gets or sets the logical entity name to check whether it can be the primary entity in a one-to-many relationship. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CanBeReferencedRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencedResponse

Other Resources

Sample: Create and Retrieve Entity Relationships
EligibleCreateOneToManyRelationship
Entity Relationship Eligibility
CanBeReferenced Privileges


CanBeReferencedRequest Constructor
[image]

Initializes a new instance of the CanBeReferencedRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CanBeReferencedRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencedRequest Class
CanBeReferencedRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CanBeReferencedRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CanBeReferencedRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencedResponse

Other Resources

Sample: Create and Retrieve Entity Relationships
EligibleCreateOneToManyRelationship
Entity Relationship Eligibility
CanBeReferenced Privileges


CanBeReferencedRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityName | Gets or sets the logical entity name to check whether it can be the primary entity in a one-to-many relationship. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CanBeReferencedRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencedResponse

Other Resources

Sample: Create and Retrieve Entity Relationships
EligibleCreateOneToManyRelationship
Entity Relationship Eligibility
CanBeReferenced Privileges


CanBeReferencedRequest.EntityName Property
[image]

Gets or sets the logical entity name to check whether it can be the primary entity in a one-to-many relationship. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical entity name to check whether it can be the primary entity in a one-to-many relationship. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencedRequest Class
CanBeReferencedRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CanBeReferencedResponse Class
See Also Members
[image]

Contains the response from the CanBeReferencedRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CanBeReferencedResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CanBeReferencedResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.CanBeReferencedResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencedResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencedRequest


CanBeReferencedResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CanBeReferencedRequest class.

The following tables list the members exposed by the CanBeReferencedResponse type.

Public Constructors

Name | Description
CanBeReferencedResponse | Initializes a new instance of the CanBeReferencedResponse class.
Top

Public Properties

 | Name | Description
public property | CanBeReferenced | Gets the result of the request to see whether the entity can be the primary entity (one) in a one-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CanBeReferencedResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencedRequest


CanBeReferencedResponse Constructor
[image]

Initializes a new instance of the CanBeReferencedResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CanBeReferencedResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencedResponse Class
CanBeReferencedResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CanBeReferencedResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CanBeReferencedResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencedRequest


CanBeReferencedResponse Properties
[image]

Public Properties

 | Name | Description
public property | CanBeReferenced | Gets the result of the request to see whether the entity can be the primary entity (one) in a one-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CanBeReferencedResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencedRequest


CanBeReferencedResponse.CanBeReferenced Property
[image]

Gets the result of the request to see whether the entity can be the primary entity (one) in a one-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CanBeReferenced As Boolean

C#
public bool CanBeReferenced { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the entity can be the primary entity (one) in a one-to-many relationship; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencedResponse Class
CanBeReferencedResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CanBeReferencingRequest Class
See Also Example Members
[image]

Contains the data that is needed to check whether an entity can be the referencing entity in a one-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CanBeReferencingRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CanBeReferencingRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
/// <summary>
/// Determines whether two entities are eligible to participate in a relationship
/// </summary>
/// <param name="referencedEntity">Primary Entity</param>
/// <param name="referencingEntity">Referencing Entity</param>
/// <returns></returns>
public bool EligibleCreateOneToManyRelationship(string referencedEntity,
    string referencingEntity)
{
    //Checks whether the specified entity can be the primary entity in one-to-many
    //relationship.
    CanBeReferencedRequest canBeReferencedRequest = new CanBeReferencedRequest
    {
        EntityName = referencedEntity
    };

    CanBeReferencedResponse canBeReferencedResponse =
        (CanBeReferencedResponse)_serviceProxy.Execute(canBeReferencedRequest);

    if (!canBeReferencedResponse.CanBeReferenced)
    {
        Console.WriteLine(
            "Entity {0} can't be the primary entity in this one-to-many relationship",
            referencedEntity);
    }

    //Checks whether the specified entity can be the referencing entity in one-to-many
    //relationship.
    CanBeReferencingRequest canBereferencingRequest = new CanBeReferencingRequest
    {
        EntityName = referencingEntity
    };

    CanBeReferencingResponse canBeReferencingResponse =
        (CanBeReferencingResponse)_serviceProxy.Execute(canBereferencingRequest);

    if (!canBeReferencingResponse.CanBeReferencing)
    {
        Console.WriteLine(
            "Entity {0} can't be the referencing entity in this one-to-many relationship",
            referencingEntity);
    }

    if (canBeReferencedResponse.CanBeReferenced == true
        && canBeReferencingResponse.CanBeReferencing == true)
    {
        return true;
    }
    else
    {
        return false;
    }
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the CanBeReferencingResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in CanBeReferencing Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.CanBeReferencingRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CanBeReferencingRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencingResponse
Other Resources
CanBeReferencing Privileges
Sample: Create and Retrieve Entity Relationships
EligibleCreateOneToManyRelationship


CanBeReferencingRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to check whether an entity can be the referencing entity in a one-to-many relationship.

The following tables list the members exposed by the CanBeReferencingRequest type.

Public Constructors

Name | Description
CanBeReferencingRequest | Initializes a new instance of the CanBeReferencingRequest class.
Top

Public Properties

 | Name | Description
public property | EntityName | Gets or sets the logical entity name. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CanBeReferencingRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencingResponse

Other Resources

CanBeReferencing Privileges
Sample: Create and Retrieve Entity Relationships
EligibleCreateOneToManyRelationship


CanBeReferencingRequest Constructor
[image]

Initializes a new instance of the CanBeReferencingRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CanBeReferencingRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencingRequest Class
CanBeReferencingRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CanBeReferencingRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CanBeReferencingRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencingResponse

Other Resources

CanBeReferencing Privileges
Sample: Create and Retrieve Entity Relationships
EligibleCreateOneToManyRelationship


CanBeReferencingRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityName | Gets or sets the logical entity name. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CanBeReferencingRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencingResponse

Other Resources

CanBeReferencing Privileges
Sample: Create and Retrieve Entity Relationships
EligibleCreateOneToManyRelationship


CanBeReferencingRequest.EntityName Property
[image]

Gets or sets the logical entity name. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String

The the logical entity name. Required..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencingRequest Class
CanBeReferencingRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CanBeReferencingResponse Class
See Also Members
[image]

Contains the response from the CanBeReferencingRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CanBeReferencingResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CanBeReferencingResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.CanBeReferencingResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencingResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencingRequest


CanBeReferencingResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CanBeReferencingRequest class.

The following tables list the members exposed by the CanBeReferencingResponse type.

Public Constructors

Name | Description
CanBeReferencingResponse | Initializes a new instance of the CanBeReferencingResponse class.
Top

Public Properties

 | Name | Description
public property | CanBeReferencing | Gets the result of the request to see whether the entity can be the referencing entity (many) in a one-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CanBeReferencingResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencingRequest


CanBeReferencingResponse Constructor
[image]

Initializes a new instance of the CanBeReferencingResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CanBeReferencingResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencingResponse Class
CanBeReferencingResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CanBeReferencingResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CanBeReferencingResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencingRequest


CanBeReferencingResponse Properties
[image]

Public Properties

 | Name | Description
public property | CanBeReferencing | Gets the result of the request to see whether the entity can be the referencing entity (many) in a one-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CanBeReferencingResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CanBeReferencingRequest


CanBeReferencingResponse.CanBeReferencing Property
[image]

Gets the result of the request to see whether the entity can be the referencing entity (many) in a one-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CanBeReferencing As Boolean

C#
public bool CanBeReferencing { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the entity can be the referencing entity (many) in a one-to-many relationship.; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanBeReferencingResponse Class
CanBeReferencingResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CanManyToManyRequest Class
See Also Example Members
[image]

Contains the data that is needed to check whether an entity can participate in a many-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CanManyToManyRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CanManyToManyRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
/// <summary>
/// Determines whether the entity can participate in a many-to-many relationship.
/// </summary>
/// <param name="entity">Entity</param>
/// <returns></returns>
public bool EligibleCreateManyToManyRelationship(string entity)
{
    CanManyToManyRequest canManyToManyRequest = new CanManyToManyRequest
    {
        EntityName = entity
    };

    CanManyToManyResponse canManyToManyResponse =
        (CanManyToManyResponse)_serviceProxy.Execute(canManyToManyRequest);

    if (!canManyToManyResponse.CanManyToMany)
    {
        Console.WriteLine(
            "Entity {0} can't participate in a many-to-many relationship.",
            entity);
    }

    return canManyToManyResponse.CanManyToMany;
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage

                        Pass an instance of this class to the
                        Execute  method, which returns an instance of  the CanManyToManyResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in CanManyToMany Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.CanManyToManyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CanManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
CanManyToManyResponse
Other Resources
Sample: Create and Retrieve Entity Relationships
EligibleCreateManyToManyRelationship
Customize Entity Relationship Metadata
CanManyToMany Privileges


CanManyToManyRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to check whether an entity can participate in a many-to-many relationship.

The following tables list the members exposed by the CanManyToManyRequest type.

Public Constructors

Name | Description
CanManyToManyRequest | Initializes a new instance of the CanManyToManyRequest class.
Top

Public Properties

 | Name | Description
public property | EntityName | Gets or sets the logical entity name. Required
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CanManyToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CanManyToManyResponse

Other Resources

Sample: Create and Retrieve Entity Relationships
EligibleCreateManyToManyRelationship
Customize Entity Relationship Metadata
CanManyToMany Privileges


CanManyToManyRequest Constructor
[image]

Initializes a new instance of the CanManyToManyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CanManyToManyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanManyToManyRequest Class
CanManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CanManyToManyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CanManyToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CanManyToManyResponse

Other Resources

Sample: Create and Retrieve Entity Relationships
EligibleCreateManyToManyRelationship
Customize Entity Relationship Metadata
CanManyToMany Privileges


CanManyToManyRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityName | Gets or sets the logical entity name. Required
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

CanManyToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CanManyToManyResponse

Other Resources

Sample: Create and Retrieve Entity Relationships
EligibleCreateManyToManyRelationship
Customize Entity Relationship Metadata
CanManyToMany Privileges


CanManyToManyRequest.EntityName Property
[image]

Gets or sets the logical entity name. Required

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical entity name. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanManyToManyRequest Class
CanManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CanManyToManyResponse Class
See Also Members
[image]

Contains the response from the CanManyToManyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CanManyToManyResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CanManyToManyResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.CanManyToManyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanManyToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
CanManyToManyRequest


CanManyToManyResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CanManyToManyRequest class.

The following tables list the members exposed by the CanManyToManyResponse type.

Public Constructors

Name | Description
CanManyToManyResponse | Initializes a new instance of the CanManyToManyResponse class.
Top

Public Properties

 | Name | Description
public property | CanManyToMany | Gets the result of the request to see whether the entity can participate in a many-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CanManyToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CanManyToManyRequest


CanManyToManyResponse Constructor
[image]

Initializes a new instance of the CanManyToManyResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CanManyToManyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanManyToManyResponse Class
CanManyToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CanManyToManyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CanManyToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CanManyToManyRequest


CanManyToManyResponse Properties
[image]

Public Properties

 | Name | Description
public property | CanManyToMany | Gets the result of the request to see whether the entity can participate in a many-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CanManyToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CanManyToManyRequest


CanManyToManyResponse.CanManyToMany Property
[image]

Gets the result of the request to see whether the entity can participate in a many-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CanManyToMany As Boolean

C#
public bool CanManyToMany { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the the entity can participate in a many-to-many relationship.; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CanManyToManyResponse Class
CanManyToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateAttributeRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a new attribute, and optionally, to add it to a specified unmanaged solution.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateAttributeRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateAttributeRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
This code defines the AttributeMetadata for a number of different types of attributes and adds them to a List<AttributeMetadata>. At the end of the code, the CreateAttributeRequest class prepares the request, and the attribute is created by using the Execute method.
This code sample assumes that the current customization prefix is ‘new’ because that is the default customization prefix for the organization solution publisher. You should use the customization prefix for the solution publisher that makes sense for the solution context in which you work.
C#    Copy Code
// Create storage for new attributes being created
addedAttributes = new List<AttributeMetadata>();

// Create a boolean attribute
BooleanAttributeMetadata boolAttribute = new BooleanAttributeMetadata
{
    // Set base properties
    SchemaName = "new_boolean",
    DisplayName = new Label("Sample Boolean", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Boolean Attribute", _languageCode),
    // Set extended properties
    OptionSet = new BooleanOptionSetMetadata(
        new OptionMetadata(new Label("True", _languageCode), 1),
        new OptionMetadata(new Label("False", _languageCode), 0)
        )
};

// Add to list
addedAttributes.Add(boolAttribute);

// Create a date time attribute
DateTimeAttributeMetadata dtAttribute = new DateTimeAttributeMetadata
{
    // Set base properties
    SchemaName = "new_datetime",
    DisplayName = new Label("Sample DateTime", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("DateTime Attribute", _languageCode),
    // Set extended properties
    Format = DateTimeFormat.DateOnly,
    ImeMode = ImeMode.Disabled
};

// Add to list
addedAttributes.Add(dtAttribute);

// Create a decimal attribute
DecimalAttributeMetadata decimalAttribute = new DecimalAttributeMetadata
{
    // Set base properties
    SchemaName = "new_decimal",
    DisplayName = new Label("Sample Decimal", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Decimal Attribute", _languageCode),
    // Set extended properties
    MaxValue = 100,
    MinValue = 0,
    Precision = 1
};

// Add to list
addedAttributes.Add(decimalAttribute);

// Create a integer attribute
IntegerAttributeMetadata integerAttribute = new IntegerAttributeMetadata
{
    // Set base properties
    SchemaName = "new_integer",
    DisplayName = new Label("Sample Integer", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Integer Attribute", _languageCode),
    // Set extended properties
    Format = IntegerFormat.None,
    MaxValue = 100,
    MinValue = 0
};

// Add to list
addedAttributes.Add(integerAttribute);

// Create a memo attribute
MemoAttributeMetadata memoAttribute = new MemoAttributeMetadata
{
    // Set base properties
    SchemaName = "new_memo",
    DisplayName = new Label("Sample Memo", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Memo Attribute", _languageCode),
    // Set extended properties
    Format = StringFormat.TextArea,
    ImeMode = ImeMode.Disabled,
    MaxLength = 500
};

// Add to list
addedAttributes.Add(memoAttribute);

// Create a money attribute
MoneyAttributeMetadata moneyAttribute = new MoneyAttributeMetadata
{
    // Set base properties
    SchemaName = "new_money",
    DisplayName = new Label("Money Picklist", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Money Attribue", _languageCode),
    // Set extended properties
    MaxValue = 1000.00,
    MinValue = 0.00,
    Precision = 1,
    PrecisionSource = 1,
    ImeMode = ImeMode.Disabled
};

// Add to list
addedAttributes.Add(moneyAttribute);

// Create a picklist attribute
PicklistAttributeMetadata pickListAttribute =
    new PicklistAttributeMetadata
{
    // Set base properties
    SchemaName = "new_picklist",
    DisplayName = new Label("Sample Picklist", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("Picklist Attribute", _languageCode),
    // Set extended properties
    // Build local picklist options
    OptionSet = new OptionSetMetadata
        {
            IsGlobal = false,
            OptionSetType = OptionSetType.Picklist,
            Options =
        {
            new OptionMetadata(
                new Label("Created", _languageCode), null),
            new OptionMetadata(
                new Label("Updated", _languageCode), null),
            new OptionMetadata(
                new Label("Deleted", _languageCode), null)
        }
        }
};

// Add to list
addedAttributes.Add(pickListAttribute);

// Create a string attribute
StringAttributeMetadata stringAttribute = new StringAttributeMetadata
{
    // Set base properties
    SchemaName = "new_string",
    DisplayName = new Label("Sample String", _languageCode),
    RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
    Description = new Label("String Attribute", _languageCode),
    // Set extended properties
    MaxLength = 100
};

// Add to list
addedAttributes.Add(stringAttribute);

// NOTE: LookupAttributeMetadata cannot be created outside the context of a relationship.
// Refer to the WorkWithRelationships.cs reference SDK sample for an example of this attribute type.

// NOTE: StateAttributeMetadata and StatusAttributeMetadata cannot be created via the SDK.

foreach (AttributeMetadata anAttribute in addedAttributes)
{
    // Create the request.
    CreateAttributeRequest createAttributeRequest = new CreateAttributeRequest
    {
        EntityName = Contact.EntityLogicalName,
        Attribute = anAttribute
    };

    // Execute the request.
    _serviceProxy.Execute(createAttributeRequest);

    Console.WriteLine("Created the attribute {0}.", anAttribute.SchemaName);
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the CreateAttributeResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in CreateAttribute Privileges.
Notes for Callers
This message cannot be used to create a LookupAttributeMetadata attribute. Use the CreateOneToManyRequest message to create an entity relationship that includes the lookup attribute.
Supported Entities
You can only add attributes to customizable entities where the managed property CanCreateAttributes is true.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.CreateAttributeRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CreateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateAttributeResponse
Other Resources
Customize Entity Attribute Metadata
Entity Attribute Metadata Messages
Sample: Create and Update Entity Metadata
CreateAttribute Privileges
Introduction to Solutions


CreateAttributeRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a new attribute, and optionally, to add it to a specified unmanaged solution.

The following tables list the members exposed by the CreateAttributeRequest type.

Public Constructors

Name | Description
CreateAttributeRequest | Initializes a new instance of the CreateAttributeRequest class.
Top

Public Properties

 | Name | Description
public property | Attribute | Gets or sets the definition of the attribute type that you want to create. Required.
public property | EntityName | Gets or sets the name of the entity for which you want to create an attribute. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution to which you want to add this attribute. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateAttributeResponse

Other Resources

Customize Entity Attribute Metadata
Entity Attribute Metadata Messages
Sample: Create and Update Entity Metadata
CreateAttribute Privileges
Introduction to Solutions


CreateAttributeRequest Constructor
[image]

Initializes a new instance of the CreateAttributeRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateAttributeRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateAttributeRequest Class
CreateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateAttributeRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateAttributeResponse

Other Resources

Customize Entity Attribute Metadata
Entity Attribute Metadata Messages
Sample: Create and Update Entity Metadata
CreateAttribute Privileges
Introduction to Solutions


CreateAttributeRequest Properties
[image]

Public Properties

 | Name | Description
public property | Attribute | Gets or sets the definition of the attribute type that you want to create. Required.
public property | EntityName | Gets or sets the name of the entity for which you want to create an attribute. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution to which you want to add this attribute. Optional.

See Also

Reference

CreateAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateAttributeResponse

Other Resources

Customize Entity Attribute Metadata
Entity Attribute Metadata Messages
Sample: Create and Update Entity Metadata
CreateAttribute Privileges
Introduction to Solutions


CreateAttributeRequest.Attribute Property
[image]

Gets or sets the definition of the attribute type that you want to create. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Attribute As AttributeMetadata

C#
public AttributeMetadata Attribute { get; set; }

C++

J#

JScript

Property Value
Type:  AttributeMetadata
The definition of the attribute type that you want to create. Required.

  Remarks
Use one of the following classes to specify the type of attribute that you want to create:
  • BooleanAttributeMetadata
  • DateTimeAttributeMetadata
  • DecimalAttributeMetadata
  • DoubleAttributeMetadata
  • IntegerAttributeMetadata
  • MemoAttributeMetadata
  • MoneyAttributeMetadata
  • PicklistAttributeMetadata
  • StringAttributeMetadata

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateAttributeRequest Class
CreateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateAttributeRequest.EntityName Property
[image]

Gets or sets the name of the entity for which you want to create an attribute. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the entity for which you want to create an attribute. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateAttributeRequest Class
CreateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateAttributeRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the unmanaged solution to which you want to add this attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the unmanaged solution to which you want to add this attribute. Optional.

  Remarks
All entities are added to the default solution. When you use this optional property, you also add this attribute as a solution component to the specified unmanaged solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateAttributeRequest Class
CreateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateAttributeResponse Class
See Also Members
[image]

Contains the response from the CreateAttributeRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateAttributeResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateAttributeResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.CreateAttributeResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateAttributeRequest


CreateAttributeResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateAttributeRequest class.

The following tables list the members exposed by the CreateAttributeResponse type.

Public Constructors

Name | Description
CreateAttributeResponse | Initializes a new instance of the CreateAttributeResponse class.
Top

Public Properties

 | Name | Description
public property | AttributeId | Gets the MetadataId of the attribute that is created.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateAttributeRequest


CreateAttributeResponse Constructor
[image]

Initializes a new instance of the CreateAttributeResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateAttributeResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateAttributeResponse Class
CreateAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateAttributeResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateAttributeRequest


CreateAttributeResponse Properties
[image]

Public Properties

 | Name | Description
public property | AttributeId | Gets the MetadataId of the attribute that is created.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CreateAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateAttributeRequest


CreateAttributeResponse.AttributeId Property
[image]

Gets the MetadataId of the attribute that is created.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AttributeId As Guid

C#
public Guid AttributeId { get; }

C++

J#

JScript

Property Value
Type: Guid

The MetadataId of the attribute that is created. This is the unique identifier of the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateAttributeResponse Class
CreateAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateEntityRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a custom entity, and optionally, to add it to a specified unmanaged solution.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateEntityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateEntityRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
The _customEntityName value is “new_BankAccount”.
C#    Copy Code
CreateEntityRequest createrequest = new CreateEntityRequest
{

 //Define the entity
 Entity = new EntityMetadata
 {
  SchemaName = _customEntityName,
  DisplayName = new Label("Bank Account", 1033),
  DisplayCollectionName = new Label("Bank Accounts", 1033),
  Description = new Label("An entity to store information about customer bank accounts", 1033),
  OwnershipType = OwnershipTypes.UserOwned,
  IsActivity = false,

 },

 // Define the primary attribute for the entity
 PrimaryAttribute = new StringAttributeMetadata
 {
  SchemaName = "new_accountname",
  RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
  MaxLength = 100,
  FormatName = StringFormatName.Text,
  DisplayName = new Label("Account Name", 1033),
  Description = new Label("The primary attribute for the Bank Account entity.", 1033)
 }

};
_serviceProxy.Execute(createrequest);
Console.WriteLine("The bank account entity has been created.");

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  the CreateEntityResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in CreateEntity Privileges.
Notes for Callers
When you programmatically create a custom entity, it does not appear in the application navigation pane unless you edit the SiteMap to display the entity in the location where you want it displayed. Alternatively, in the application edit the entity properties to set Areas that display this entity to the location where you want the entity displayed. For more information, see Change Application Navigation Using the SiteMap.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.CreateEntityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CreateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateEntityResponse
Other Resources
CreateEntity Privileges
Sample: Create and Update Entity Metadata
Introduction to Solutions


CreateEntityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a custom entity, and optionally, to add it to a specified unmanaged solution.

The following tables list the members exposed by the CreateEntityRequest type.

Public Constructors

Name | Description
CreateEntityRequest | Initializes a new instance of the CreateEntityRequest class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets or sets the metadata for the custom entity that you want to create. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | HasActivities | Gets or sets whether a custom entity is created that has a special relationship to activity entities and is a valid regarding object for the activity. Optional.
public property | HasNotes | Gets or sets whether the custom entity that is created has a special relationship to the annotation entity. Optional.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PrimaryAttribute | Gets or sets the metadata for the primary attribute for the new entity. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution to which you want to add this custom entity. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateEntityResponse

Other Resources

CreateEntity Privileges
Sample: Create and Update Entity Metadata
Introduction to Solutions


CreateEntityRequest Constructor
[image]

Initializes a new instance of the CreateEntityRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateEntityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityRequest Class
CreateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateEntityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateEntityResponse

Other Resources

CreateEntity Privileges
Sample: Create and Update Entity Metadata
Introduction to Solutions


CreateEntityRequest Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets or sets the metadata for the custom entity that you want to create. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | HasActivities | Gets or sets whether a custom entity is created that has a special relationship to activity entities and is a valid regarding object for the activity. Optional.
public property | HasNotes | Gets or sets whether the custom entity that is created has a special relationship to the annotation entity. Optional.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | PrimaryAttribute | Gets or sets the metadata for the primary attribute for the new entity. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution to which you want to add this custom entity. Optional.

See Also

Reference

CreateEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateEntityResponse

Other Resources

CreateEntity Privileges
Sample: Create and Update Entity Metadata
Introduction to Solutions


CreateEntityRequest.Entity Property
[image]

Gets or sets the metadata for the custom entity that you want to create. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As EntityMetadata

C#
public EntityMetadata Entity { get; set; }

C++

J#

JScript

Property Value
Type EntityMetadata
The metadata for the custom entity that you want to create. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityRequest Class
CreateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateEntityRequest.HasActivities Property
[image]

Gets or sets whether a custom entity is created that has a special relationship to activity entities and is a valid regarding object for the activity. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HasActivities As Boolean

C#
public bool HasActivities { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the custom entity that you create has a special relationship to activity entities; otherwise, false. The default is false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityRequest Class
CreateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateEntityRequest.HasNotes Property
[image]

Gets or sets whether the custom entity that is created has a special relationship to the annotation entity. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HasNotes As Boolean

C#
public bool HasNotes { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the custom entity that is created has a special relationship to the annotation entity; otherwise, false. The default is false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityRequest Class
CreateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateEntityRequest.PrimaryAttribute Property
[image]

Gets or sets the metadata for the primary attribute for the new entity. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PrimaryAttribute As StringAttributeMetadata

C#
public StringAttributeMetadata PrimaryAttribute { get; set; }

C++

J#

JScript

Property Value
Type: StringAttributeMetadata
The metadata for the primary attribute for the new entity. Required..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityRequest Class
CreateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateEntityRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the unmanaged solution to which you want to add this custom entity. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the unmanaged solution to which you want to add this custom entity. Optional.

  Remarks
All custom entities are automatically added to the default solution. However, when you use this optional property, you also add the custom entity as a solution component to the specified unmanaged solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityRequest Class
CreateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateEntityResponse Class
See Also Members
[image]

Contains the response from the CreateEntityRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateEntityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateEntityResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.CreateEntityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateEntityRequest


CreateEntityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateEntityRequest class.

The following tables list the members exposed by the CreateEntityResponse type.

Public Constructors

Name | Description
CreateEntityResponse | Initializes a new instance of the CreateEntityResponse class.
Top

Public Properties

 | Name | Description
public property | AttributeId | Gets the MetadataId of the primary attribute for the newly created entity.
public property | EntityId | Gets the MetadataId of the newly created entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateEntityRequest


CreateEntityResponse Constructor
[image]

Initializes a new instance of the CreateEntityResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateEntityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityResponse Class
CreateEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateEntityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateEntityRequest


CreateEntityResponse Properties
[image]

Public Properties

 | Name | Description
public property | AttributeId | Gets the MetadataId of the primary attribute for the newly created entity.
public property | EntityId | Gets the MetadataId of the newly created entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CreateEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateEntityRequest


CreateEntityResponse.AttributeId Property
[image]

Gets the MetadataId of the primary attribute for the newly created entity.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AttributeId As Guid

C#
public Guid AttributeId { get; }

C++

J#

JScript

Property Value
Type: Guid

The MetadataId of the primary attribute for the newly created entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityResponse Class
CreateEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateEntityResponse.EntityId Property
[image]

Gets the MetadataId of the newly created entity.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityId As Guid

C#
public Guid EntityId { get; }

C++

J#

JScript

Property Value
Type: Guid

The MetadataId of the newly created entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntityResponse Class
CreateEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateManyToManyRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a new Many-to-Many (N:N) entity relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateManyToManyRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateManyToManyRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic. . This sample creates the entity relationship between the Account and Contact entities by using CreateManyToManyRequest.
C#    Copy Code

bool accountEligibleParticipate =
    EligibleCreateManyToManyRelationship("account");
bool campaignEligibleParticipate =
    EligibleCreateManyToManyRelationship("campaign");

if (accountEligibleParticipate && campaignEligibleParticipate)
{

    CreateManyToManyRequest createManyToManyRelationshipRequest =
        new CreateManyToManyRequest
    {
        IntersectEntitySchemaName = "new_accounts_campaigns",
        ManyToManyRelationship = new ManyToManyRelationshipMetadata
        {
            SchemaName = "new_accounts_campaigns",
            Entity1LogicalName = "account",
            Entity1AssociatedMenuConfiguration =
            new AssociatedMenuConfiguration
            {
                Behavior = AssociatedMenuBehavior.UseLabel,
                Group = AssociatedMenuGroup.Details,
                Label = new Label("Account", 1033),
                Order = 10000
            },
            Entity2LogicalName = "campaign",
            Entity2AssociatedMenuConfiguration =
            new AssociatedMenuConfiguration
            {
                Behavior = AssociatedMenuBehavior.UseLabel,
                Group = AssociatedMenuGroup.Details,
                Label = new Label("Campaign", 1033),
                Order = 10000
            }
        }
    };

    CreateManyToManyResponse createManytoManyRelationshipResponse =
        (CreateManyToManyResponse)_serviceProxy.Execute(
        createManyToManyRelationshipRequest);

    _manyToManyRelationshipId =
        createManytoManyRelationshipResponse.ManyToManyRelationshipId;
    _manyToManyRelationshipName =
        createManyToManyRelationshipRequest.ManyToManyRelationship.SchemaName;

    Console.WriteLine(
        "The many-to-many relationship has been created between {0} and {1}.",
        "account", "campaign");
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  CreateManyToManyResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in CreateManyToMany Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.CreateManyToManyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CreateManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateManyToManyResponse
CanManyToManyRequest
Other Resources
Create Entity Relationships
Sample: Create Entity Relationships


CreateManyToManyRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a new Many-to-Many (N:N) entity relationship.

The following tables list the members exposed by the CreateManyToManyRequest type.

Public Constructors

Name | Description
CreateManyToManyRequest | Initializes a new instance of the CreateManyToManyRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IntersectEntitySchemaName | Gets or sets the name of the intersect entity to be created for this entity relationship. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ManyToManyRelationship | Gets or sets the definition of the Many-to-Many entity relationship to be created. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution you want to add this many-to-many entity relationship to. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateManyToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateManyToManyResponse
CanManyToManyRequest

Other Resources

Create Entity Relationships
Sample: Create Entity Relationships


CreateManyToManyRequest Constructor
[image]

Initializes a new instance of the CreateManyToManyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateManyToManyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateManyToManyRequest Class
CreateManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateManyToManyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateManyToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateManyToManyResponse
CanManyToManyRequest

Other Resources

Create Entity Relationships
Sample: Create Entity Relationships


CreateManyToManyRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | IntersectEntitySchemaName | Gets or sets the name of the intersect entity to be created for this entity relationship. Required.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | ManyToManyRelationship | Gets or sets the definition of the Many-to-Many entity relationship to be created. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution you want to add this many-to-many entity relationship to. Optional.

See Also

Reference

CreateManyToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateManyToManyResponse
CanManyToManyRequest

Other Resources

Create Entity Relationships
Sample: Create Entity Relationships


CreateManyToManyRequest.IntersectEntitySchemaName Property
[image]

Gets or sets the name of the intersect entity to be created for this entity relationship. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IntersectEntitySchemaName As String

C#
public string IntersectEntitySchemaName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the intersect entity to be created for this entity relationship. Required.

  Remarks
This property is required. This property must begin with a valid customization prefix. We recommend that you use a consistent naming convention. This is usually: <customization prefix>_<entity 1 logical name + “s”>_<entity 2 logical name +”s”>.   For example “new_accounts_campaigns”.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateManyToManyRequest Class
CreateManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateManyToManyRequest.ManyToManyRelationship Property
[image]

Gets or sets the definition of the Many-to-Many entity relationship to be created. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ManyToManyRelationship As ManyToManyRelationshipMetadata

C#
public ManyToManyRelationshipMetadata ManyToManyRelationship { get; set; }

C++

J#

JScript

Property Value
Type: ManyToManyRelationshipMetadata
The definition of the Many-to-Many entity relationship to be created. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateManyToManyRequest Class
CreateManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateManyToManyRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the unmanaged solution you want to add this many-to-many entity relationship to. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the unmanaged solution you want to add this many-to-many entity relationship to. Optional.

  Remarks
This property is optional. All entity relationships are added to the default solution. Using this optional property will also add this entity as a solution component to the specified unmanaged solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateManyToManyRequest Class
CreateManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Add a New Solution Component


CreateManyToManyResponse Class
See Also Members
[image]

Contains the response from the CreateManyToManyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateManyToManyResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateManyToManyResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.CreateManyToManyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateManyToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateManyToManyRequest


CreateManyToManyResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateManyToManyRequest class.

The following tables list the members exposed by the CreateManyToManyResponse type.

Public Constructors

Name | Description
CreateManyToManyResponse | Initializes a new instance of the CreateManyToManyResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ManyToManyRelationshipId | Gets the ID of the many-to-many entity relationship that is created.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateManyToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateManyToManyRequest


CreateManyToManyResponse Constructor
[image]

Initializes a new instance of the CreateManyToManyResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateManyToManyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateManyToManyResponse Class
CreateManyToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateManyToManyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateManyToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateManyToManyRequest


CreateManyToManyResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ManyToManyRelationshipId | Gets the ID of the many-to-many entity relationship that is created.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CreateManyToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateManyToManyRequest


CreateManyToManyResponse.ManyToManyRelationshipId Property
[image]

Gets the ID of the many-to-many entity relationship that is created.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ManyToManyRelationshipId As Guid

C#
public Guid ManyToManyRelationshipId { get; }

C++

J#

JScript

Property Value
Type: Guid
 The ID of the many-to-many entity relationship that is created. This corresponds to the MetadataId.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateManyToManyResponse Class
CreateManyToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOneToManyRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a new One-to-Many (1:N) entity relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateOneToManyRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateOneToManyRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic. This sample creates an entity relationship between Account and Campaign entities by using CreateOneToManyRequest.
C#    Copy Code

bool eligibleCreateOneToManyRelationship =
    EligibleCreateOneToManyRelationship("account", "campaign");

if (eligibleCreateOneToManyRelationship)
{
    CreateOneToManyRequest createOneToManyRelationshipRequest =
        new CreateOneToManyRequest
    {
        OneToManyRelationship =
        new OneToManyRelationshipMetadata
        {
            ReferencedEntity = "account",
            ReferencingEntity = "campaign",
            SchemaName = "new_account_campaign",
            AssociatedMenuConfiguration = new AssociatedMenuConfiguration
            {
                Behavior = AssociatedMenuBehavior.UseLabel,
                Group = AssociatedMenuGroup.Details,
                Label = new Label("Account", 1033),
                Order = 10000
            },
            CascadeConfiguration = new CascadeConfiguration
            {
                Assign = CascadeType.NoCascade,
                Delete = CascadeType.RemoveLink,
                Merge = CascadeType.NoCascade,
                Reparent = CascadeType.NoCascade,
                Share = CascadeType.NoCascade,
                Unshare = CascadeType.NoCascade
            }
        },
        Lookup = new LookupAttributeMetadata
        {
            SchemaName = "new_parent_accountid",
            DisplayName = new Label("Account Lookup", 1033),
            RequiredLevel = new AttributeRequiredLevelManagedProperty(AttributeRequiredLevel.None),
            Description = new Label("Sample Lookup", 1033)
        }
    };

    CreateOneToManyResponse createOneToManyRelationshipResponse =
        (CreateOneToManyResponse)_serviceProxy.Execute(
        createOneToManyRelationshipRequest);

    _oneToManyRelationshipId =
        createOneToManyRelationshipResponse.RelationshipId;
    _oneToManyRelationshipName =
        createOneToManyRelationshipRequest.OneToManyRelationship.SchemaName;

    Console.WriteLine(
        "The one-to-many relationship has been created between {0} and {1}.",
        "account", "campaign");
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  CreateOneToManyResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in CreateOneToMany Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.CreateOneToManyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CreateOneToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateOneToManyResponse
Other Resources
Entity Relationship Eligibility
Create Entity Relationships
Customize Entity Relationship Metadata
Entity Relationship Behavior
Sample: Create Entity Relationships
Sample: Dump Entity Relationship Informtion to a File


CreateOneToManyRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a new One-to-Many (1:N) entity relationship.

The following tables list the members exposed by the CreateOneToManyRequest type.

Public Constructors

Name | Description
CreateOneToManyRequest | Initializes a new instance of the CreateOneToManyRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Lookup | Gets or sets the metadata for the lookup field used to store the ID of the related record. Required.
public property | OneToManyRelationship | Gets or sets the metadata for the relationship. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution you want to add this one-to-Many entity relationship to. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateOneToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateOneToManyResponse

Other Resources

Entity Relationship Eligibility
Create Entity Relationships
Customize Entity Relationship Metadata
Entity Relationship Behavior
Sample: Create Entity Relationships
Sample: Dump Entity Relationship Informtion to a File


CreateOneToManyRequest Constructor
[image]

Initializes a new instance of the CreateOneToManyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateOneToManyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOneToManyRequest Class
CreateOneToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOneToManyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateOneToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateOneToManyResponse

Other Resources

Entity Relationship Eligibility
Create Entity Relationships
Customize Entity Relationship Metadata
Entity Relationship Behavior
Sample: Create Entity Relationships
Sample: Dump Entity Relationship Informtion to a File


CreateOneToManyRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Lookup | Gets or sets the metadata for the lookup field used to store the ID of the related record. Required.
public property | OneToManyRelationship | Gets or sets the metadata for the relationship. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution you want to add this one-to-Many entity relationship to. Optional.

See Also

Reference

CreateOneToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateOneToManyResponse

Other Resources

Entity Relationship Eligibility
Create Entity Relationships
Customize Entity Relationship Metadata
Entity Relationship Behavior
Sample: Create Entity Relationships
Sample: Dump Entity Relationship Informtion to a File


CreateOneToManyRequest.Lookup Property
[image]

Gets or sets the metadata for the lookup field used to store the ID of the related record. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Lookup As LookupAttributeMetadata

C#
public LookupAttributeMetadata Lookup { get; set; }

C++

J#

JScript

Property Value
Type: LookupAttributeMetadata
The metadata for the lookup field used to store the ID of the related record. Required.

  Remarks
This attribute is added to the referencing entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOneToManyRequest Class
CreateOneToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOneToManyRequest.OneToManyRelationship Property
[image]

Gets or sets the metadata for the relationship. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OneToManyRelationship As OneToManyRelationshipMetadata

C#
public OneToManyRelationshipMetadata OneToManyRelationship { get; set; }

C++

J#

JScript

Property Value
Type: OneToManyRelationshipMetadata
The metadata for the relationship. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOneToManyRequest Class
CreateOneToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOneToManyRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the unmanaged solution you want to add this one-to-Many entity relationship to. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the unmanaged solution you want to add this one-to-Many entity relationship to. Optional..

  Remarks
This property is optional. All entity relationships are added to the default solution. Using this optional property will also add this entity relationship as a solution component to the specified unmanaged solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOneToManyRequest Class
CreateOneToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Add a New Solution Component


CreateOneToManyResponse Class
See Also Members
[image]

Contains the response from the CreateOneToManyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateOneToManyResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateOneToManyResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.CreateOneToManyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOneToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateOneToManyRequest


CreateOneToManyResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateOneToManyRequest class.

The following tables list the members exposed by the CreateOneToManyResponse type.

Public Constructors

Name | Description
CreateOneToManyResponse | Initializes a new instance of the CreateOneToManyResponse class.
Top

Public Properties

 | Name | Description
public property | AttributeId | Gets the MetadataId of the LookupAttributeMetadata that is created.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | RelationshipId | Gets the MetadataId of the OneToManyRelationshipMetadatathat is created.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateOneToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateOneToManyRequest


CreateOneToManyResponse Constructor
[image]

Initializes a new instance of the CreateOneToManyResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateOneToManyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOneToManyResponse Class
CreateOneToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOneToManyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateOneToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateOneToManyRequest


CreateOneToManyResponse Properties
[image]

Public Properties

 | Name | Description
public property | AttributeId | Gets the MetadataId of the LookupAttributeMetadata that is created.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | RelationshipId | Gets the MetadataId of the OneToManyRelationshipMetadatathat is created.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CreateOneToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateOneToManyRequest


CreateOneToManyResponse.AttributeId Property
[image]

Gets the MetadataId of the LookupAttributeMetadata that is created.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AttributeId As Guid

C#
public Guid AttributeId { get; }

C++

J#

JScript

Property Value
Type: Guid
The MetadataId of the LookupAttributeMetadata that is created..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOneToManyResponse Class
CreateOneToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOneToManyResponse.RelationshipId Property
[image]

Gets the MetadataId of the OneToManyRelationshipMetadatathat is created.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property RelationshipId As Guid

C#
public Guid RelationshipId { get; }

C++

J#

JScript

Property Value
Type: Guid
The MetadataId of the OneToManyRelationshipMetadata that is created..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOneToManyResponse Class
CreateOneToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOptionSetRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a new global option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateOptionSetRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateOptionSetRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
#region How to create global option set
// Define the request object and pass to the service.
CreateOptionSetRequest createOptionSetRequest = new CreateOptionSetRequest
{
    // Create a global option set (OptionSetMetadata).
    OptionSet = new OptionSetMetadata
    {
        Name = _globalOptionSetName,
        DisplayName = new Label("Example Option Set", _languageCode),
        IsGlobal = true,
        OptionSetType = OptionSetType.Picklist,
        Options =
    {
        new OptionMetadata(new Label("Open", _languageCode), null),
        new OptionMetadata(new Label("Suspended", _languageCode), null),
        new OptionMetadata(new Label("Cancelled", _languageCode), null),
        new OptionMetadata(new Label("Closed", _languageCode), null)
    }
    }
};

// Execute the request.
CreateOptionSetResponse optionsResp =
    (CreateOptionSetResponse)_serviceProxy.Execute(createOptionSetRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  CreateOptionSetResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in CreateOptionSet Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.CreateOptionSetRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CreateOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Create Global Option Set
Customize Global Option Sets in Microsoft Dynamics CRM


CreateOptionSetRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a new global option set.

The following tables list the members exposed by the CreateOptionSetRequest type.

Public Constructors

Name | Description
CreateOptionSetRequest | Initializes a new instance of the CreateOptionSetRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OptionSet | Gets or sets the definition of the global option set. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution you want to add this global option set to. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create Global Option Set
Customize Global Option Sets in Microsoft Dynamics CRM


CreateOptionSetRequest Constructor
[image]

Initializes a new instance of the CreateOptionSetRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateOptionSetRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOptionSetRequest Class
CreateOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOptionSetRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create Global Option Set
Customize Global Option Sets in Microsoft Dynamics CRM


CreateOptionSetRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OptionSet | Gets or sets the definition of the global option set. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution you want to add this global option set to. Optional.

See Also

Reference

CreateOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create Global Option Set
Customize Global Option Sets in Microsoft Dynamics CRM


CreateOptionSetRequest.OptionSet Property
[image]

Gets or sets the definition of the global option set. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OptionSet As OptionSetMetadataBase

C#
public OptionSetMetadataBase OptionSet { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetMetadata
The definition of the global option set. Required.

  Remarks
The IsGlobal property must be true.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOptionSetRequest Class
CreateOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOptionSetRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the unmanaged solution you want to add this global option set to. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the unmanaged solution you want to add this global option set to. Optional.

  Remarks
This property is optional. All global option sets are added to the default solution. Using this optional property will also add this global option set as a solution component to the specified unmanaged solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOptionSetRequest Class
CreateOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Add a New Solution Component


CreateOptionSetResponse Class
See Also Members
[image]

Contains the response from the CreateOptionSetRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateOptionSetResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateOptionSetResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.CreateOptionSetResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateOptionSetRequest


CreateOptionSetResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateOptionSetRequest class.

The following tables list the members exposed by the CreateOptionSetResponse type.

Public Constructors

Name | Description
CreateOptionSetResponse | Initializes a new instance of the CreateOptionSetResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OptionSetId | Gets the MetadataId of the newly created OptionSetMetadata.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateOptionSetRequest


CreateOptionSetResponse Constructor
[image]

Initializes a new instance of the CreateOptionSetResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateOptionSetResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOptionSetResponse Class
CreateOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateOptionSetResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateOptionSetRequest


CreateOptionSetResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OptionSetId | Gets the MetadataId of the newly created OptionSetMetadata.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CreateOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateOptionSetRequest


CreateOptionSetResponse.OptionSetId Property
[image]

Gets the MetadataId of the newly created OptionSetMetadata.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property OptionSetId As Guid

C#
public Guid OptionSetId { get; }

C++

J#

JScript

Property Value
Type: Guid
The MetadataId of the newly created OptionSetMetadata.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateOptionSetResponse Class
CreateOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateRequest Class
See Also Example Members
[image]

Contains the data that is needed to create a record.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
//Set the Web Resource properties
WebResource wr = new WebResource
{
    Content = getEncodedFileContents(@"../../" + webResource.path),
    DisplayName = webResource.displayName,
    Description = webResource.description,
    Name = _customizationPrefix + webResource.name,
    LogicalName = WebResource.EntityLogicalName,
    WebResourceType = new OptionSetValue(Int32.Parse(webResource.type))
};

// Using CreateRequest because we want to add an optional parameter
CreateRequest cr = new CreateRequest
{
    Target = wr
};
//Set the SolutionUniqueName optional parameter so the Web Resources will be
// created in the context of a specific solution.
cr.Parameters.Add("SolutionUniqueName", _ImportWebResourcesSolutionUniqueName);

CreateResponse cresp = (CreateResponse)_serviceProxy.Execute(cr);

  Remarks
Message Availability
Not all entity types support this message offline. For some supported entities, this message works regardless whether the caller is connected to the server or offline. For other entities, the caller must be connected to the server before the message works. For more information, see Supported Entities later in this topic.
Usage

                        Pass an instance of this class to the
                        Execute method, which returns an instance of the CreateResponse class.

                        This message supports one or more optional parameters. For more information, see Pass Optional Parameters in Messages.

Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the entity parameter. For a list of the required privileges, see Create Privileges.
Notes for Callers
This message creates a record with related records in one transaction. For a less complex method that creates a single record, use the Create method.
By default, the caller becomes the owner for the new record. For this message to work, the caller must have both Create and Read privileges for the entity. For more information, see Privileges by Entity. Or you can set the ownerid attribute for the record to the ID of another user.
Supported Entities
You can use this method to create any record of an entity (includes custom entities) that supports the CreateRequest message.

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
ActivityMimeAttachment | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
AttributeMap | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
ColumnMapping | 2 (Both)
Competitor | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConnectionRoleObjectTypeCode | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
HierarchySecurityConfiguration | 2 (Both)
Import | 2 (Both)
ImportEntityMapping | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
LookUpMapping | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
OrganizationUI | 2 (Both)
OwnerMapping | 2 (Both)
PhoneCall | 2 (Both)
PickListMapping | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
Position | 2 (Both)
Post | 2 (Both)
PostComment | 2 (Both)
PostFollow | 2 (Both)
PostLike | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
ProcessSession | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportVisibility | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointDocument | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
Subject | 2 (Both)
SystemForm | 2 (Both)
SystemUser | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TraceLog | 2 (Both)
TransactionCurrency | 2 (Both)
TransformationMapping | 2 (Both)
TransformationParameterMapping | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.CreateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
CreateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateResponse
Create
Other Resources
Sample: Importing Files as Web Resources
Privileges by Entity
Create a New Entity Record Using the Early-bound Entity Classes and the Organization Service Context


CreateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to create a record.

The following tables list the members exposed by the CreateRequest type.

Public Constructors

Name | Description
CreateRequest | Initializes a new instance of the CreateRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets an instance of an entity that you can use to create a new record. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateResponse
Create

Other Resources

Sample: Importing Files as Web Resources
Privileges by Entity
Create a New Entity Record Using the Early-bound Entity Classes and the Organization Service Context


CreateRequest Constructor
[image]

Initializes a new instance of the CreateRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateRequest Class
CreateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateResponse
Create

Other Resources

Sample: Importing Files as Web Resources
Privileges by Entity
Create a New Entity Record Using the Early-bound Entity Classes and the Organization Service Context


CreateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets an instance of an entity that you can use to create a new record. Required.

See Also

Reference

CreateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateResponse
Create

Other Resources

Sample: Importing Files as Web Resources
Privileges by Entity
Create a New Entity Record Using the Early-bound Entity Classes and the Organization Service Context


CreateRequest.Target Property
[image]

Gets or sets an instance of an entity that you can use to create a new record. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type: Entity

The entity instance.

  Remarks
The specified target record must contain values for all the attributes where the RequiredLevel is set to SystemRequired. You can see the required level value for each entity in the Entity Metadata topic for the entity. If the entity instance includes properties where IsValidForCreate is false, the values are ignored. You can find this information in the metadata for your organization. See the preceding metadata browser information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateRequest Class
CreateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateResponse Class
See Also Members
[image]

Contains the response from the CreateRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CreateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CreateResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.CreateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
CreateRequest
Create


CreateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the CreateRequest class.

The following tables list the members exposed by the CreateResponse type.

Public Constructors

Name | Description
CreateResponse | Initializes a new instance of the CreateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Gets the ID of the newly created record.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateRequest
Create


CreateResponse Constructor
[image]

Initializes a new instance of the CreateResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateResponse Class
CreateResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


CreateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateRequest
Create


CreateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | id | Gets the ID of the newly created record.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

CreateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
CreateRequest
Create


CreateResponse.id Property
[image]

Gets the ID of the newly created record.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property id As Guid

C#
public Guid id { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the newly created record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateResponse Class
CreateResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteAttributeRequest Class
See Also Example Members
[image]

Contains the data that is needed to delete an attribute.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteAttributeRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteAttributeRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Delete all attributes created for this sample.
foreach (AttributeMetadata anAttribute in addedAttributes)
{
    // Create the request object
    DeleteAttributeRequest deleteAttribute = new DeleteAttributeRequest
    {
        // Set the request properties
        EntityLogicalName = Contact.EntityLogicalName,
        LogicalName = anAttribute.SchemaName
    };
    // Execute the request
    _serviceProxy.Execute(deleteAttribute);
}

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  DeleteAttributeResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in DeleteAttribute Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.DeleteAttributeRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DeleteAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Attributes


DeleteAttributeRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete an attribute.

The following tables list the members exposed by the DeleteAttributeRequest type.

Public Constructors

Name | Description
DeleteAttributeRequest | Initializes a new instance of the DeleteAttributeRequest class
Top

Public Properties

 | Name | Description
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the logical name of the attribute to delete. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes


DeleteAttributeRequest Constructor
[image]

Initializes a new instance of the DeleteAttributeRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteAttributeRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAttributeRequest Class
DeleteAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteAttributeRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes


DeleteAttributeRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the logical name of the attribute to delete. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

DeleteAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes


DeleteAttributeRequest.EntityLogicalName Property
[image]

Gets or sets the logical name of the entity that contains the attribute. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityLogicalName As String

C#
public string EntityLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity that contains the attribute. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAttributeRequest Class
DeleteAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteAttributeRequest.LogicalName Property
[image]

Gets or sets the logical name of the attribute to delete. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LogicalName As String

C#
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the attribute to delete. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAttributeRequest Class
DeleteAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteAttributeResponse Class
See Also Members
[image]

Contains the response from the DeleteAttributeRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteAttributeResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteAttributeResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.DeleteAttributeResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
DeleteAttributeRequest


DeleteAttributeResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeleteAttributeRequest class.

The following tables list the members exposed by the DeleteAttributeResponse type.

Public Constructors

Name | Description
DeleteAttributeResponse | Initializes a new instance of the DeleteAttributeResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteAttributeRequest


DeleteAttributeResponse Constructor
[image]

Initializes a new instance of the DeleteAttributeResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteAttributeResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteAttributeResponse Class
DeleteAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteAttributeResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteAttributeRequest


DeleteAttributeResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeleteAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteAttributeRequest


DeleteEntityRequest Class
See Also Example Members
[image]

Contains the data that is needed to delete an entity.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteEntityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteEntityRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
DeleteEntityRequest request = new DeleteEntityRequest()
{
 LogicalName = _customEntityName,
};
_serviceProxy.Execute(request);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  the DeleteEntityResponse class.
Privileges and Access Rights

                        To perform this action, the caller must have the required privileges, as listed in DeleteEntity Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.DeleteEntityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DeleteEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
DeleteEntityResponse
Other Resources
Delete a Custom Entity
Sample: Create and Update Entity Metadata
Customize Entity Metadata
DeleteEntity Privileges


DeleteEntityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete an entity.

The following tables list the members exposed by the DeleteEntityRequest type.

Public Constructors

Name | Description
DeleteEntityRequest | Initializes a new instance of the DeleteEntityRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the logical name of the entity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteEntityResponse

Other Resources

Delete a Custom Entity
Sample: Create and Update Entity Metadata
Customize Entity Metadata
DeleteEntity Privileges


DeleteEntityRequest Constructor
[image]

Initializes a new instance of the DeleteEntityRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteEntityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteEntityRequest Class
DeleteEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteEntityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteEntityResponse

Other Resources

Delete a Custom Entity
Sample: Create and Update Entity Metadata
Customize Entity Metadata
DeleteEntity Privileges


DeleteEntityRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the logical name of the entity. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

DeleteEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteEntityResponse

Other Resources

Delete a Custom Entity
Sample: Create and Update Entity Metadata
Customize Entity Metadata
DeleteEntity Privileges


DeleteEntityRequest.LogicalName Property
[image]

Gets or sets the logical name of the entity. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LogicalName As String

C#
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteEntityRequest Class
DeleteEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteEntityResponse Class
See Also Members
[image]

Contains the response from the DeleteEntityRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteEntityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteEntityResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.DeleteEntityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
DeleteEntityRequest


DeleteEntityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeleteEntityRequest class.

The following tables list the members exposed by the DeleteEntityResponse type.

Public Constructors

Name | Description
DeleteEntityResponse | Initializes a new instance of the DeleteEntityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteEntityRequest


DeleteEntityResponse Constructor
[image]

Initializes a new instance of the DeleteEntityResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteEntityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteEntityResponse Class
DeleteEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteEntityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteEntityRequest


DeleteEntityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeleteEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteEntityRequest


DeleteOptionSetRequest Class
See Also Example Members
[image]

Contains the data that is needed to delete a global option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteOptionSetRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteOptionSetRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
DeleteOptionSetRequest deleteRequest = new DeleteOptionSetRequest
{
    Name = _globalOptionSetName
};

_serviceProxy.Execute(deleteRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  DeleteOptionSetResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in DeleteOptionSet Privileges.
Notes for Callers
You cannot delete a global option set that is used by a picklist attribute. Use RetrieveDependentComponentsRequest to determine whether the global option set has any dependencies.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.DeleteOptionSetRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DeleteOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Global Option Sets


DeleteOptionSetRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete a global option set.

The following tables list the members exposed by the DeleteOptionSetRequest type.

Public Constructors

Name | Description
DeleteOptionSetRequest | Initializes a new instance of the DeleteOptionSetRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Name | Gets or sets the name of the global option set to delete. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets


DeleteOptionSetRequest Constructor
[image]

Initializes a new instance of the DeleteOptionSetRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteOptionSetRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionSetRequest Class
DeleteOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionSetRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets


DeleteOptionSetRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Name | Gets or sets the name of the global option set to delete. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

DeleteOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets


DeleteOptionSetRequest.Name Property
[image]

Gets or sets the name of the global option set to delete. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Name As String

C#
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the global option set to delete. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionSetRequest Class
DeleteOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionSetResponse Class
See Also Members
[image]

Contains the response from the DeleteOptionSetRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteOptionSetResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteOptionSetResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.DeleteOptionSetResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
DeleteOptionSetRequest


DeleteOptionSetResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeleteOptionSetRequest class.

The following tables list the members exposed by the DeleteOptionSetResponse type.

Public Constructors

Name | Description
DeleteOptionSetResponse | Initializes a new instance of the DeleteOptionSetResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteOptionSetRequest


DeleteOptionSetResponse Constructor
[image]

Initializes a new instance of the DeleteOptionSetResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteOptionSetResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionSetResponse Class
DeleteOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionSetResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteOptionSetRequest


DeleteOptionSetResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeleteOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteOptionSetRequest


DeleteOptionValueRequest Class
See Also Example Members
[image]

Contains the data that is needed to delete an option value in a global or local option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteOptionValueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteOptionValueRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Use the DeleteOptionValueRequest message
// to remove the newly inserted label.
DeleteOptionValueRequest deleteOptionValueRequest =
    new DeleteOptionValueRequest
{
    OptionSetName = _globalOptionSetName,
    Value = _insertedOptionValue
};

// Execute the request.
_serviceProxy.Execute(deleteOptionValueRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  DeleteOptionValueResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in DeleteOptionValue Privileges.
Notes for Callers
Use the OptionSetName property when working with global option sets. For local option sets in a picklist attribute, use the EntityLogicalName and AttributeLogicalName properties.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.DeleteOptionValueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DeleteOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Global Option Sets
Insert, Update, Delete, and Order Global Option Set Options
Customize Global Option Sets in Microsoft Dynamics CRM


DeleteOptionValueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete an option value in a global or local option set.

The following tables list the members exposed by the DeleteOptionValueRequest type.

Public Constructors

Name | Description
DeleteOptionValueRequest | Initializes a new instance of theDeleteOptionValueRequest class
Top

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the logical name of the attribute from which to delete the option value. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OptionSetName | Gets or sets the name of the option set that contains the value. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the solution name associated with this option value. Optional.
public property | Value | Gets or sets the value of the option to delete. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteOptionValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Insert, Update, Delete, and Order Global Option Set Options
Customize Global Option Sets in Microsoft Dynamics CRM


DeleteOptionValueRequest Constructor
[image]

Initializes a new instance of the DeleteOptionValueRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteOptionValueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionValueRequest Class
DeleteOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionValueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteOptionValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Insert, Update, Delete, and Order Global Option Set Options
Customize Global Option Sets in Microsoft Dynamics CRM


DeleteOptionValueRequest Properties
[image]

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the logical name of the attribute from which to delete the option value. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OptionSetName | Gets or sets the name of the option set that contains the value. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the solution name associated with this option value. Optional.
public property | Value | Gets or sets the value of the option to delete. Required.

See Also

Reference

DeleteOptionValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Insert, Update, Delete, and Order Global Option Set Options
Customize Global Option Sets in Microsoft Dynamics CRM


DeleteOptionValueRequest.AttributeLogicalName Property
[image]

Gets or sets the logical name of the attribute from which to delete the option value. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeLogicalName As String

C#
public string AttributeLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the attribute from which to delete the option value. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionValueRequest Class
DeleteOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionValueRequest.EntityLogicalName Property
[image]

Gets or sets the logical name of the entity that contains the attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityLogicalName As String

C#
public string EntityLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity that contains the attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionValueRequest Class
DeleteOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionValueRequest.OptionSetName Property
[image]

Gets or sets the name of the option set that contains the value. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OptionSetName As String

C#
public string OptionSetName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the option set that contains the value. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionValueRequest Class
DeleteOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionValueRequest.SolutionUniqueName Property
[image]

Gets or sets the solution name associated with this option value. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The solution name associated with this option value. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionValueRequest Class
DeleteOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionValueRequest.Value Property
[image]

Gets or sets the value of the option to delete. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As Integer

C#
public int Value { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The value of the option to delete. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionValueRequest Class
DeleteOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionValueResponse Class
See Also Members
[image]

Contains the response from the DeleteOptionValueRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteOptionValueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteOptionValueResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.DeleteOptionValueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
DeleteOptionValueRequest


DeleteOptionValueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeleteOptionValueRequest class.

The following tables list the members exposed by the DeleteOptionValueResponse type.

Public Constructors

Name | Description
DeleteOptionValueResponse | Initializes a new instance of the DeleteOptionValueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteOptionValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteOptionValueRequest


DeleteOptionValueResponse Constructor
[image]

Initializes a new instance of the DeleteOptionValueResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteOptionValueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteOptionValueResponse Class
DeleteOptionValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteOptionValueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteOptionValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteOptionValueRequest


DeleteOptionValueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeleteOptionValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteOptionValueRequest


DeleteRelationshipRequest Class
See Also Example Members
[image]

Contains the data that is needed to delete an entity relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteRelationshipRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteRelationshipRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
DeleteRelationshipRequest deleteOneToManyRelationshipRequest =
    new DeleteRelationshipRequest
{
    Name = "new_account_campaign"
};

_serviceProxy.Execute(deleteOneToManyRelationshipRequest);

DeleteRelationshipRequest deleteManyToManyRelationshipRequest =
    new DeleteRelationshipRequest
{
    Name = "new_accounts_campaigns"
};

_serviceProxy.Execute(deleteManyToManyRelationshipRequest);

Console.WriteLine("Entity Relationships have been deleted.");

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute  method, which returns an instance of  DeleteRelationshipResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in DeleteRelationship Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.DeleteRelationshipRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
DeleteRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Create and Retrieve Entity Relationships
Customize Entity Relationship Metadata


DeleteRelationshipRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete an entity relationship.

The following tables list the members exposed by the DeleteRelationshipRequest type.

Public Constructors

Name | Description
DeleteRelationshipRequest | Initializes a new instance of the DeleteRelationshipRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Name | Gets or sets the name of the relationship to delete. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteRelationshipRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create and Retrieve Entity Relationships
Customize Entity Relationship Metadata


DeleteRelationshipRequest Constructor
[image]

Initializes a new instance of the DeleteRelationshipRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteRelationshipRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteRelationshipRequest Class
DeleteRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteRelationshipRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteRelationshipRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create and Retrieve Entity Relationships
Customize Entity Relationship Metadata


DeleteRelationshipRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Name | Gets or sets the name of the relationship to delete. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

DeleteRelationshipRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create and Retrieve Entity Relationships
Customize Entity Relationship Metadata


DeleteRelationshipRequest.Name Property
[image]

Gets or sets the name of the relationship to delete. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Name As String

C#
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the relationship to delete. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteRelationshipRequest Class
DeleteRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteRelationshipResponse Class
See Also Members
[image]

Contains the response from the DeleteRelationshipRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteRelationshipResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteRelationshipResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.DeleteRelationshipResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteRelationshipResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
DeleteRelationshipRequest


DeleteRelationshipResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeleteRelationshipRequest class.

The following tables list the members exposed by the DeleteRelationshipResponse type.

Public Constructors

Name | Description
DeleteRelationshipResponse | Initializes a new instance of the DeleteRelationshipResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteRelationshipResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteRelationshipRequest


DeleteRelationshipResponse Constructor
[image]

Initializes a new instance of the DeleteRelationshipResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteRelationshipResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteRelationshipResponse Class
DeleteRelationshipResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteRelationshipResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteRelationshipResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteRelationshipRequest


DeleteRelationshipResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeleteRelationshipResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteRelationshipRequest


DeleteRequest Class
See Also Members
[image]

Contains the data that is needed to delete a record.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability
Not all entity types support this message offline. For some supported entities, this message works regardless whether the caller is connected to the server or offline. For other entities, the caller must be connected to the server before the message works. For more information, see Supported Entities later in this topic.
Usage
Pass an instance of this class to the  Execute  method, which returns an instance of the DeleteResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the Target property and access rights on the specified record in the Target property. For a list of the required privileges, see Delete Privileges.
Notes for Callers
This message deletes a record and its related records in one transaction. For a less complex method that deletes a single record, use the Delete method.
When a record is deleted, all child records are also deleted. The entire deletion fails if the caller does not have the delete privilege or access rights for any of these records. This method may cascade to related records according to the cascade configuration for each entity relationship. For a description of how actions on a parent record affect related records, see Cascading Behavior.
Typically, you should only delete records that you entered by mistake. For some record types, you can deactivate or close the record instead.
Supported Entities
You can use this method to delete any record of an entity (includes custom entities) that supports the DeleteRequest message.

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
ActivityMimeAttachment | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
AttributeMap | 2 (Both)
BulkDeleteOperation | 2 (Both)
BulkOperation | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
ColumnMapping | 2 (Both)
Competitor | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConnectionRoleObjectTypeCode | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
HierarchySecurityConfiguration | 2 (Both)
Import | 2 (Both)
ImportEntityMapping | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
LookUpMapping | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
OwnerMapping | 2 (Both)
PhoneCall | 2 (Both)
PickListMapping | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
Position | 2 (Both)
Post | 2 (Both)
PostComment | 2 (Both)
PostFollow | 2 (Both)
PostLike | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
ProcessSession | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportVisibility | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointDocument | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
Subject | 2 (Both)
SystemForm | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TraceLog | 2 (Both)
TransactionCurrency | 2 (Both)
TransformationMapping | 2 (Both)
TransformationParameterMapping | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.DeleteRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
DeleteResponse
Delete
Other Resources
Delete Privileges
Use the Early Bound Entity Classes for Create, Update, and Delete


DeleteRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete a record.

The following tables list the members exposed by the DeleteRequest type.

Public Constructors

Name | Description
DeleteRequest | Initializes a new instance of the DeleteRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the reference to the record that you want to delete. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteResponse
Delete

Other Resources

Delete Privileges
Use the Early Bound Entity Classes for Create, Update, and Delete


DeleteRequest Constructor
[image]

Initializes a new instance of the DeleteRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteRequest Class
DeleteRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteResponse
Delete

Other Resources

Delete Privileges
Use the Early Bound Entity Classes for Create, Update, and Delete


DeleteRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the reference to the record that you want to delete. Required.

See Also

Reference

DeleteRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteResponse
Delete

Other Resources

Delete Privileges
Use the Early Bound Entity Classes for Create, Update, and Delete


DeleteRequest.Target Property
[image]

Gets or sets the reference to the record that you want to delete. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference

The reference to the record that you want to delete.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteRequest Class
DeleteRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteResponse Class
See Also Members
[image]

Contains the response from the DeleteRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DeleteResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DeleteResponse : OrganizationResponse

C++

J#

JScript

  Remarks
There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.DeleteResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
DeleteRequest
Delete


DeleteResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DeleteRequest class.

The following tables list the members exposed by the DeleteResponse type.

Public Constructors

Name | Description
DeleteResponse | Initializes a new instance of the DeleteResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeleteResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteRequest
Delete


DeleteResponse Constructor
[image]

Initializes a new instance of the DeleteResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeleteResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeleteResponse Class
DeleteResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


DeleteResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeleteResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteRequest
Delete


DeleteResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DeleteResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DeleteRequest
Delete


DisassociateRequest Class
See Also Members
[image]

Contains the data that is needed to delete a link between records.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DisassociateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DisassociateRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute  method, which returns an instance of  DisassociateResponse.
Privileges and Access Rights

                        To perform this action, the caller must have privileges on the entity specified in the entityName parameter and access rights on the records specified in the entityId and relatedEntities parameters. For a list of the privileges required, see Disassociate Privileges.
Notes for Callers
This method removes multiple associations in one transaction between the record specified by the entityId parameter and each record in the relatedEntities parameter for the relationship specified in the relationship parameter.
For a one-to-many relationship, this method clears the ReferencingAttribute in the related record to the value of entityId.
For a many-to-many relationship, this method deletes a record in the intersect table for the relationship. The intersect table name is defined in the IntersectEntityName property for the relationship. You need this when you query for the records. However, you need the relationship name to set the Relationship property. This name is defined in the SchemaName property for the relationship.
Supported Entities
You can use this method to disassociate any records that participate in a relationship, including records for custom entities. You can find the default relationships listed in the Entity Metadata topic for each entity.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.DisassociateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
DisassociateResponse
Disassociate
Other Resources
Entity Metadata
Entity Relationship Behavior
Customize Entity Relationship Metadata


DisassociateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to delete a link between records.

The following tables list the members exposed by the DisassociateRequest type.

Public Constructors

Name | Description
DisassociateRequest | Initializes a new instance of the DisassociateRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelatedEntities | Gets or sets the collection of entity references (references to records) to be disassociated. Required.
public property | Relationship | Get or sets the name of the relationship to be used for the disassociation. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target, which is the record from which the related records will be disassociated. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DisassociateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
DisassociateResponse
Disassociate

Other Resources

Entity Metadata
Entity Relationship Behavior
Customize Entity Relationship Metadata


DisassociateRequest Constructor
[image]

Initializes a new instance of the DisassociateRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DisassociateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateRequest Class
DisassociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DisassociateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DisassociateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
DisassociateResponse
Disassociate

Other Resources

Entity Metadata
Entity Relationship Behavior
Customize Entity Relationship Metadata


DisassociateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelatedEntities | Gets or sets the collection of entity references (references to records) to be disassociated. Required.
public property | Relationship | Get or sets the name of the relationship to be used for the disassociation. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target, which is the record from which the related records will be disassociated. Required.

See Also

Reference

DisassociateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
DisassociateResponse
Disassociate

Other Resources

Entity Metadata
Entity Relationship Behavior
Customize Entity Relationship Metadata


DisassociateRequest.RelatedEntities Property
[image]

Gets or sets the collection of entity references (references to records) to be disassociated. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RelatedEntities As EntityReferenceCollection

C#
public EntityReferenceCollection RelatedEntities { get; set; }

C++

J#

JScript

Property Value
Type: EntityReferenceCollection

The collection of entity references (references to records) to be disassociated.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateRequest Class
DisassociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DisassociateRequest.Relationship Property
[image]

Get or sets the name of the relationship to be used for the disassociation. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Relationship As Relationship

C#
public Relationship Relationship { get; set; }

C++

J#

JScript

Property Value
Type: Relationship

The name of the relationship to be used for the disassociation.

  Remarks
The relationship name can be found in the SchemaName property in the metadata.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateRequest Class
DisassociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DisassociateRequest.Target Property
[image]

Gets or sets the target, which is the record from which the related records will be disassociated. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference

The target, which is the record from which the related records will be disassociated.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateRequest Class
DisassociateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


DisassociateResponse Class
See Also Members
[image]

Contains the response from the DisassociateRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class DisassociateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class DisassociateResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.DisassociateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
DisassociateRequest
Disassociate


DisassociateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the DisassociateRequest class.

The following tables list the members exposed by the DisassociateResponse type.

Public Constructors

Name | Description
DisassociateResponse | Initializes a new instance of the DisassociateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DisassociateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DisassociateRequest
Disassociate


DisassociateResponse Constructor
[image]

Initializes a new instance of the DisassociateResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DisassociateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DisassociateResponse Class
DisassociateResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


DisassociateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DisassociateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DisassociateRequest
Disassociate


DisassociateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

DisassociateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
DisassociateRequest
Disassociate


ExecuteAsyncRequest Class
See Also Members
[image]

Contains the data that is needed to execute a message asynchronously.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class ExecuteAsyncRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class ExecuteAsyncRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute   method, which returns an instance of ExecuteAsyncResponse.
Privileges and Access Rights
To perform this action, the caller must havethe privileges needed for the message passed in the Request parameter.
Notes for Callers
None

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.ExecuteAsyncRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteAsyncRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteAsyncResponse
Other Resources
Execute messages in the background (asynchronously)


ExecuteAsyncRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to execute a message asynchronously.

The following tables list the members exposed by the ExecuteAsyncRequest type.

Public Constructors

Name | Description
ExecuteAsyncRequest | Initializes a new instance of the ExecuteAsyncRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Request | Gets or sets the request to execute asynchronously.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteAsyncRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteAsyncResponse

Other Resources

Execute messages in the background (asynchronously)


ExecuteAsyncRequest Constructor
[image]

Initializes a new instance of the ExecuteAsyncRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteAsyncRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteAsyncRequest Class
ExecuteAsyncRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


ExecuteAsyncRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteAsyncRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteAsyncResponse

Other Resources

Execute messages in the background (asynchronously)


ExecuteAsyncRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Request | Gets or sets the request to execute asynchronously.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

ExecuteAsyncRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteAsyncResponse

Other Resources

Execute messages in the background (asynchronously)


ExecuteAsyncRequest.Request Property
[image]

Gets or sets the request to execute asynchronously.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Request As OrganizationRequest

C#
public OrganizationRequest Request { get; set; }

C++

J#

JScript

Property Value
Returns OrganizationRequest
The request to execute asynchronously.

  Remarks
Currently this only supports the ImportSolutionRequest message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteAsyncRequest Class
ExecuteAsyncRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


ExecuteAsyncResponse Class
See Also Members
[image]

Contains the response from the ExecuteAsyncRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class ExecuteAsyncResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class ExecuteAsyncResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.ExecuteAsyncResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteAsyncResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteAsyncRequest
Other Resources
Field Level Data Encryption


ExecuteAsyncResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExecuteAsyncRequest class.

The following tables list the members exposed by the ExecuteAsyncResponse type.

Public Constructors

Name | Description
ExecuteAsyncResponse | Initializes a new instance of the ExecuteAsyncResponse class.
Top

Public Properties

 | Name | Description
public property | AsyncJobId | Gets or sets the ID of the asynchronous job that was started from processing the ExecuteAsyncRequest.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteAsyncResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteAsyncRequest

Other Resources

Field Level Data Encryption


ExecuteAsyncResponse Constructor
[image]

Initializes a new instance of the ExecuteAsyncResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteAsyncResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteAsyncResponse Class
ExecuteAsyncResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


ExecuteAsyncResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteAsyncResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteAsyncRequest

Other Resources

Field Level Data Encryption


ExecuteAsyncResponse Properties
[image]

Public Properties

 | Name | Description
public property | AsyncJobId | Gets or sets the ID of the asynchronous job that was started from processing the ExecuteAsyncRequest.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ExecuteAsyncResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteAsyncRequest

Other Resources

Field Level Data Encryption


ExecuteAsyncResponse.AsyncJobId Property
[image]

Gets or sets the ID of the asynchronous job that was started from processing the ExecuteAsyncRequest.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AsyncJobId As Guid

C#
public Guid AsyncJobId { get; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the asynchronous job.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteAsyncResponse Class
ExecuteAsyncResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


ExecuteMultipleRequest Class
See Also Example Members
[image]

Contains the data that is needed to execute one or more message requests as a single batch operation, and optionally return a collection of results.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class ExecuteMultipleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class ExecuteMultipleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following sample shows how to execute the ExecuteMultipleRequest message.
C#    Copy Code
// Get a reference to the organization service.
using (_serviceProxy = new OrganizationServiceProxy(serverConfig.OrganizationUri, serverConfig.HomeRealmUri,serverConfig.Credentials, serverConfig.DeviceCredentials))
{
    // Enable early-bound type support to add/update entity records required for this sample.
    _serviceProxy.EnableProxyTypes();

    #region Execute Multiple with Results
    // Create an ExecuteMultipleRequest object.
    requestWithResults = new ExecuteMultipleRequest()
    {
        // Assign settings that define execution behavior: continue on error, return responses.
        Settings = new ExecuteMultipleSettings()
        {
            ContinueOnError = false,
            ReturnResponses = true
        },
        // Create an empty organization request collection.
        Requests = new OrganizationRequestCollection()
    };

    // Create several (local, in memory) entities in a collection.
    EntityCollection input = GetCollectionOfEntitiesToCreate();

    // Add a CreateRequest for each entity to the request collection.
    foreach (var entity in input.Entities)
    {
        CreateRequest createRequest = new CreateRequest { Target = entity };
        requestWithResults.Requests.Add(createRequest);
    }

    // Execute all the requests in the request collection using a single web method call.
    ExecuteMultipleResponse responseWithResults =
        (ExecuteMultipleResponse)_serviceProxy.Execute(requestWithResults);

    // Display the results returned in the responses.
    foreach (var responseItem in responseWithResults.Responses)
    {
        // A valid response.
        if (responseItem.Response != null)
            DisplayResponse(requestWithResults.Requests[responseItem.RequestIndex], responseItem.Response);

        // An error has occurred.
        else if (responseItem.Fault != null)
            DisplayFault(requestWithResults.Requests[responseItem.RequestIndex],
                responseItem.RequestIndex, responseItem.Fault);
    }

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
 Pass an instance of this class to the  Execute  method, which returns an instance of  the ExecuteMultipleResponse class.
Privileges and Access Rights
There are no specific privileges required for this request. Refer to the required privileges and access rights of each message request you add to the Requests collection. Refer to Privileges by Message.
Notes for Callers
CallerId is honored for each message request. See the related topics for throttling limitations.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.ExecuteMultipleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ExecuteMultipleRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteMultipleSettings
ExecuteMultiplePerOrgMaxConnectionsPerServer
ExecuteMultipleMaxConnectionsPerServer
Other Resources
Use Messages (Request and Response Classes) with the Execute Method
Sample: Execute Multiple Requests


ExecuteMultipleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to execute one or more message requests as a single batch operation, and optionally return a collection of results.

The following tables list the members exposed by the ExecuteMultipleRequest type.

Public Constructors

Name | Description
ExecuteMultipleRequest | Initializes a new instance of the ExecuteMultipleRequest.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Requests | Gets or sets the collection of message requests to execute.
public property | Settings | Gets or sets the settings that define whether execution should continue if an error occurs and if responses for each message request processed are to be returned.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteMultipleRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteMultipleSettings
ExecuteMultiplePerOrgMaxConnectionsPerServer
ExecuteMultipleMaxConnectionsPerServer

Other Resources

Use Messages (Request and Response Classes) with the Execute Method
Sample: Execute Multiple Requests


ExecuteMultipleRequest Constructor
[image]

Initializes a new instance of the ExecuteMultipleRequest.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteMultipleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleRequest Class
ExecuteMultipleRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


ExecuteMultipleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteMultipleRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteMultipleSettings
ExecuteMultiplePerOrgMaxConnectionsPerServer
ExecuteMultipleMaxConnectionsPerServer

Other Resources

Use Messages (Request and Response Classes) with the Execute Method
Sample: Execute Multiple Requests


ExecuteMultipleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Requests | Gets or sets the collection of message requests to execute.
public property | Settings | Gets or sets the settings that define whether execution should continue if an error occurs and if responses for each message request processed are to be returned.

See Also

Reference

ExecuteMultipleRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
ExecuteMultipleSettings
ExecuteMultiplePerOrgMaxConnectionsPerServer
ExecuteMultipleMaxConnectionsPerServer

Other Resources

Use Messages (Request and Response Classes) with the Execute Method
Sample: Execute Multiple Requests


ExecuteMultipleRequest.Requests Property
[image]

Gets or sets the collection of message requests to execute.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Requests As OrganizationRequestCollection

C#
public OrganizationRequestCollection Requests { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationRequestCollection
The collection of message requests to execute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleRequest Class
ExecuteMultipleRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


ExecuteMultipleRequest.Settings Property
[image]

Gets or sets the settings that define whether execution should continue if an error occurs and if responses for each message request processed are to be returned.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Settings As ExecuteMultipleSettings

C#
public ExecuteMultipleSettings Settings { get; set; }

C++

J#

JScript

Property Value
Type: ExecuteMultipleSettings
Settings that define whether execution should continue if an error occurs and if responses are to be returned.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleRequest Class
ExecuteMultipleRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


ExecuteMultipleResponse Class
See Also Members
[image]

Contains the response from the ExecuteMultipleRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class ExecuteMultipleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class ExecuteMultipleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.ExecuteMultipleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Use Messages (Request and Response Classes) with the Execute Method


ExecuteMultipleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the ExecuteMultipleRequest class.

The following tables list the members exposed by the ExecuteMultipleResponse type.

Public Constructors

Name | Description
ExecuteMultipleResponse | Initializes a new instance of the ExecuteMultipleResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsFaulted | Gets a value that indicates if processing at least one of the individual message requests resulted in a fault.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Responses | Gets the collection of responses.
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ExecuteMultipleResponse Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


ExecuteMultipleResponse Constructor
[image]

Initializes a new instance of the ExecuteMultipleResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ExecuteMultipleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponse Class
ExecuteMultipleResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


ExecuteMultipleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ExecuteMultipleResponse Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


ExecuteMultipleResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsFaulted | Gets a value that indicates if processing at least one of the individual message requests resulted in a fault.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Responses | Gets the collection of responses.
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

ExecuteMultipleResponse Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


ExecuteMultipleResponse.IsFaulted Property
[image]

Gets a value that indicates if processing at least one of the individual message requests resulted in a fault.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsFaulted As Boolean

C#
public bool IsFaulted { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if at least one of the individual message requests resulted in a fault; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponse Class
ExecuteMultipleResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


ExecuteMultipleResponse.Responses Property
[image]

Gets the collection of responses.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Responses As ExecuteMultipleResponseItemCollection

C#
public ExecuteMultipleResponseItemCollection Responses { get; }

C++

J#

JScript

Property Value
Type: ExecuteMultipleResponseItemCollection
The collection of responses.

  Remarks
Whether responses are returned or not is configured by Settings.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ExecuteMultipleResponse Class
ExecuteMultipleResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
Settings


GetValidManyToManyRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve a list of all the entities that can participate in a Many-to-Many entity relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class GetValidManyToManyRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class GetValidManyToManyRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  GetValidManyToManyResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in GetValidManyToMany Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.GetValidManyToManyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Entity Relationship Eligibility
Customize Entity Relationship Metadata


GetValidManyToManyRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a list of all the entities that can participate in a Many-to-Many entity relationship.

The following tables list the members exposed by the GetValidManyToManyRequest type.

Public Constructors

Name | Description
GetValidManyToManyRequest | Initializes a new instance of the GetValidManyToManyRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetValidManyToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Entity Relationship Eligibility
Customize Entity Relationship Metadata


GetValidManyToManyRequest Constructor
[image]

Initializes a new instance of the GetValidManyToManyRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetValidManyToManyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidManyToManyRequest Class
GetValidManyToManyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidManyToManyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetValidManyToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Entity Relationship Eligibility
Customize Entity Relationship Metadata


GetValidManyToManyRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetValidManyToManyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Entity Relationship Eligibility
Customize Entity Relationship Metadata


GetValidManyToManyResponse Class
See Also Members
[image]

Contains the response from the GetValidManyToManyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class GetValidManyToManyResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class GetValidManyToManyResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.GetValidManyToManyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidManyToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
GetValidManyToManyRequest


GetValidManyToManyResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetValidManyToManyRequest class.

The following tables list the members exposed by the GetValidManyToManyResponse type.

Public Constructors

Name | Description
GetValidManyToManyResponse | Initializes a new instance of the GetValidManyToManyResponse class.
Top

Public Properties

 | Name | Description
public property | EntityNames | Gets an array of logical entity names that can have many-to-many entity relationships.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetValidManyToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
GetValidManyToManyRequest


GetValidManyToManyResponse Constructor
[image]

Initializes a new instance of the GetValidManyToManyResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetValidManyToManyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidManyToManyResponse Class
GetValidManyToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidManyToManyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetValidManyToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
GetValidManyToManyRequest


GetValidManyToManyResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityNames | Gets an array of logical entity names that can have many-to-many entity relationships.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetValidManyToManyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
GetValidManyToManyRequest


GetValidManyToManyResponse.EntityNames Property
[image]

Gets an array of logical entity names that can have many-to-many entity relationships.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityNames As String()

C#
public string[] EntityNames { get; }

C++

J#

JScript

Property Value
Type: String[]
An array of logical entity names that can have many-to-many entity relationships.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidManyToManyResponse Class
GetValidManyToManyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidReferencedEntitiesRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve a list of entity logical names that are valid as the primary entity (one) from the specified entity in a one-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class GetValidReferencedEntitiesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class GetValidReferencedEntitiesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  GetValidReferencedEntitiesResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in GetValidReferencedEntities Privileges.
Notes for Callers
If no entity is specified, this message returns all entities that can be the primary entity in a one-to-many relationship.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.GetValidReferencedEntitiesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencedEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Customize Entity Relationship Metadata
Entity Relationship Eligibility


GetValidReferencedEntitiesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a list of entity logical names that are valid as the primary entity (one) from the specified entity in a one-to-many relationship.

The following tables list the members exposed by the GetValidReferencedEntitiesRequest type.

Public Constructors

Name | Description
GetValidReferencedEntitiesRequest | Initializes a new instance of theGetValidReferencedEntitiesRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReferencingEntityName | Gets or sets the logical name of the entity to get valid referenced entities. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetValidReferencedEntitiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Customize Entity Relationship Metadata
Entity Relationship Eligibility


GetValidReferencedEntitiesRequest Constructor
[image]

Initializes a new instance of the GetValidReferencedEntitiesRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetValidReferencedEntitiesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencedEntitiesRequest Class
GetValidReferencedEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidReferencedEntitiesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetValidReferencedEntitiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Customize Entity Relationship Metadata
Entity Relationship Eligibility


GetValidReferencedEntitiesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReferencingEntityName | Gets or sets the logical name of the entity to get valid referenced entities. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetValidReferencedEntitiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Customize Entity Relationship Metadata
Entity Relationship Eligibility


GetValidReferencedEntitiesRequest.ReferencingEntityName Property
[image]

Gets or sets the logical name of the entity to get valid referenced entities. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReferencingEntityName As String

C#
public string ReferencingEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity to get valid referenced entities. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencedEntitiesRequest Class
GetValidReferencedEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidReferencedEntitiesResponse Class
See Also Members
[image]

Contains the response from the GetValidReferencedEntitiesRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class GetValidReferencedEntitiesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class GetValidReferencedEntitiesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.GetValidReferencedEntitiesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencedEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
GetValidReferencedEntitiesRequest


GetValidReferencedEntitiesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetValidReferencedEntitiesRequest class.

The following tables list the members exposed by the GetValidReferencedEntitiesResponse type.

Public Constructors

Name | Description
GetValidReferencedEntitiesResponse | Initializes a new instance of the GetValidReferencedEntitiesResponse class.
Top

Public Properties

 | Name | Description
public property | EntityNames | Gets the array of valid entity names that can be the primary entity in a many-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetValidReferencedEntitiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
GetValidReferencedEntitiesRequest


GetValidReferencedEntitiesResponse Constructor
[image]

Initializes a new instance of the GetValidReferencedEntitiesResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetValidReferencedEntitiesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencedEntitiesResponse Class
GetValidReferencedEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidReferencedEntitiesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetValidReferencedEntitiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
GetValidReferencedEntitiesRequest


GetValidReferencedEntitiesResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityNames | Gets the array of valid entity names that can be the primary entity in a many-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetValidReferencedEntitiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
GetValidReferencedEntitiesRequest


GetValidReferencedEntitiesResponse.EntityNames Property
[image]

Gets the array of valid entity names that can be the primary entity in a many-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityNames As String()

C#
public string[] EntityNames { get; }

C++

J#

JScript

Property Value
Type: String[]
The array of valid entity names that can be the primary entity in a many-to-many relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencedEntitiesResponse Class
GetValidReferencedEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidReferencingEntitiesRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the set of entities that are valid as the related entity (many) to the specified entity in a one-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class GetValidReferencingEntitiesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class GetValidReferencingEntitiesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  GetValidReferencingEntitiesResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in GetValidReferencingEntities Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.GetValidReferencingEntitiesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencingEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Entity Relationship Eligibility
Customize Entity Relationship Metadata


GetValidReferencingEntitiesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the set of entities that are valid as the related entity (many) to the specified entity in a one-to-many relationship.

The following tables list the members exposed by the GetValidReferencingEntitiesRequest type.

Public Constructors

Name | Description
GetValidReferencingEntitiesRequest | Initializes a new instance of the GetValidReferencingEntitiesRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReferencedEntityName | Gets or sets the name of the entity that would be the primary entity in the relationship. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetValidReferencingEntitiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Entity Relationship Eligibility
Customize Entity Relationship Metadata


GetValidReferencingEntitiesRequest Constructor
[image]

Initializes a new instance of the GetValidReferencingEntitiesRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetValidReferencingEntitiesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencingEntitiesRequest Class
GetValidReferencingEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidReferencingEntitiesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetValidReferencingEntitiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Entity Relationship Eligibility
Customize Entity Relationship Metadata


GetValidReferencingEntitiesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | ReferencedEntityName | Gets or sets the name of the entity that would be the primary entity in the relationship. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

GetValidReferencingEntitiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Entity Relationship Eligibility
Customize Entity Relationship Metadata


GetValidReferencingEntitiesRequest.ReferencedEntityName Property
[image]

Gets or sets the name of the entity that would be the primary entity in the relationship. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReferencedEntityName As String

C#
public string ReferencedEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the entity that would be the primary entity in the relationship. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencingEntitiesRequest Class
GetValidReferencingEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidReferencingEntitiesResponse Class
See Also Members
[image]

Contains the response from the GetValidReferencingEntitiesRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class GetValidReferencingEntitiesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class GetValidReferencingEntitiesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.GetValidReferencingEntitiesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencingEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
GetValidReferencingEntitiesRequest


GetValidReferencingEntitiesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the GetValidReferencingEntitiesRequest class.

The following tables list the members exposed by the GetValidReferencingEntitiesResponse type.

Public Constructors

Name | Description
GetValidReferencingEntitiesResponse | Initializes a new instance of the GetValidReferencingEntitiesResponse class.
Top

Public Properties

 | Name | Description
public property | EntityNames | Gets the array of valid entity names that can be the related entity in a many-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetValidReferencingEntitiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
GetValidReferencingEntitiesRequest


GetValidReferencingEntitiesResponse Constructor
[image]

Initializes a new instance of the GetValidReferencingEntitiesResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetValidReferencingEntitiesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencingEntitiesResponse Class
GetValidReferencingEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


GetValidReferencingEntitiesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetValidReferencingEntitiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
GetValidReferencingEntitiesRequest


GetValidReferencingEntitiesResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityNames | Gets the array of valid entity names that can be the related entity in a many-to-many relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

GetValidReferencingEntitiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
GetValidReferencingEntitiesRequest


GetValidReferencingEntitiesResponse.EntityNames Property
[image]

Gets the array of valid entity names that can be the related entity in a many-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityNames As String()

C#
public string[] EntityNames { get; }

C++

J#

JScript

Property Value
Type: String[]
The array of valid entity names that can be the related entity in a many-to-many relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetValidReferencingEntitiesResponse Class
GetValidReferencingEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertOptionValueRequest Class
See Also Example Members
[image]

Contains the data that is needed to insert a new option value for a global or local option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class InsertOptionValueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class InsertOptionValueRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create a request.
InsertOptionValueRequest insertOptionValueRequest =
    new InsertOptionValueRequest
{
    AttributeLogicalName = "new_picklist",
    EntityLogicalName = Contact.EntityLogicalName,
    Label = new Label("New Picklist Label", _languageCode)
};

// Execute the request.
int insertOptionValue = ((InsertOptionValueResponse)_serviceProxy.Execute(
    insertOptionValueRequest)).NewOptionValue;

Console.WriteLine("Created {0} with the value of {1}.",
    insertOptionValueRequest.Label.LocalizedLabels[0].Label,
    insertOptionValue);

The following example shows how to insert a new option into a global option set.
C#    Copy Code
// Use InsertOptionValueRequest to insert a new option into a
// global option set.
InsertOptionValueRequest insertOptionValueRequest =
    new InsertOptionValueRequest
    {
        OptionSetName = _globalOptionSetName,
        Label = new Label("New Picklist Label", _languageCode)
    };

// Execute the request and store the newly inserted option value
// for cleanup, used in the later part of this sample.
_insertedOptionValue = ((InsertOptionValueResponse)_serviceProxy.Execute(
    insertOptionValueRequest)).NewOptionValue;

//Publish the OptionSet
PublishXmlRequest pxReq2 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
_serviceProxy.Execute(pxReq2);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  InsertOptionValueResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in InsertOptionValue Privileges.
Notes for Callers
Use this message to update global option sets or local option sets within picklist attributes.
When you update a global option set only Label and OptionSetName are required.
When you update a local option set only AttributeLogicalName, EntityLogicalName, and Label are required.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.InsertOptionValueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
InsertOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Attributes
Sample: Work with Global Option Sets


InsertOptionValueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to insert a new option value for a global or local option set.

The following tables list the members exposed by the InsertOptionValueRequest type.

Public Constructors

Name | Description
InsertOptionValueRequest | Initializes a new instance of the InsertOptionValueRequest class
Top

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the name of the attribute when updating a local option set in a picklist attribute. Optional.
public property | Description | Gets or sets a description for the option. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity when updating the local option set in a picklist attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Label | Gets or sets the label for the option. Required.
public property | OptionSetName | Gets or sets the name of the global option set. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the unique name of the unmanaged solution when updating a global option set. Optional.
public property | Value | Gets or sets the value for the option. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InsertOptionValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Sample: Work with Global Option Sets


InsertOptionValueRequest Constructor
[image]

Initializes a new instance of the InsertOptionValueRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InsertOptionValueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueRequest Class
InsertOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertOptionValueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InsertOptionValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Sample: Work with Global Option Sets


InsertOptionValueRequest Properties
[image]

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the name of the attribute when updating a local option set in a picklist attribute. Optional.
public property | Description | Gets or sets a description for the option. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity when updating the local option set in a picklist attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Label | Gets or sets the label for the option. Required.
public property | OptionSetName | Gets or sets the name of the global option set. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the unique name of the unmanaged solution when updating a global option set. Optional.
public property | Value | Gets or sets the value for the option. Optional.

See Also

Reference

InsertOptionValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Sample: Work with Global Option Sets


InsertOptionValueRequest.AttributeLogicalName Property
[image]

Gets or sets the name of the attribute when updating a local option set in a picklist attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeLogicalName As String

C#
public string AttributeLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the attribute when updating a local option set in a picklist attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueRequest Class
InsertOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertOptionValueRequest.Description Property
[image]

Gets or sets a description for the option. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Description As Label

C#
public Label Description { get; set; }

C++

J#

JScript

Property Value
Type: Label
A description for the option.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueRequest Class
InsertOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertOptionValueRequest.EntityLogicalName Property
[image]

Gets or sets the logical name of the entity when updating the local option set in a picklist attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityLogicalName As String

C#
public string EntityLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity when updating the local option set in a picklist attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueRequest Class
InsertOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertOptionValueRequest.Label Property
[image]

Gets or sets the label for the option. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Label As Label

C#
public Label Label { get; set; }

C++

J#

JScript

Property Value
Type: Label
The label for the option. Required..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueRequest Class
InsertOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertOptionValueRequest.OptionSetName Property
[image]

Gets or sets the name of the global option set. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OptionSetName As String

C#
public string OptionSetName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the global option set. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueRequest Class
InsertOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertOptionValueRequest.SolutionUniqueName Property
[image]

Gets or sets the unique name of the unmanaged solution when updating a global option set. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name of the unmanaged solution when updating a global option set. Optional.

  Remarks
Setting this value will add the global option set to the specified unmanaged solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueRequest Class
InsertOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertOptionValueRequest.Value Property
[image]

Gets or sets the value for the option. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As Nullable(Of Integer)

C#
public Nullable<int> Value { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The value for the option. Optional.

  Remarks
We recommend that you do not specify an option and instead allow the system to auto-generate one for you. This will help make sure that the option value prefix for your solution is applied and the value will be more likely to be unique when the solution is installed in another organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueRequest Class
InsertOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Merge Option Set Options


InsertOptionValueResponse Class
See Also Members
[image]

Contains the response from the InsertOptionValueRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class InsertOptionValueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class InsertOptionValueResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.InsertOptionValueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
InsertOptionValueRequest


InsertOptionValueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the InsertOptionValueRequest class.

The following tables list the members exposed by the InsertOptionValueResponse type.

Public Constructors

Name | Description
InsertOptionValueResponse | Initializes a new instance of the InsertOptionValueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | NewOptionValue | Gets the option value for the new option.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InsertOptionValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
InsertOptionValueRequest


InsertOptionValueResponse Constructor
[image]

Initializes a new instance of the InsertOptionValueResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InsertOptionValueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueResponse Class
InsertOptionValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertOptionValueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InsertOptionValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
InsertOptionValueRequest


InsertOptionValueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | NewOptionValue | Gets the option value for the new option.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

InsertOptionValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
InsertOptionValueRequest


InsertOptionValueResponse.NewOptionValue Property
[image]

Gets the option value for the new option.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property NewOptionValue As Integer

C#
public int NewOptionValue { get; }

C++

J#

JScript

Property Value
Type: Int32
The option value for the new option.

  Remarks
If you do not specify an option value, a value is automatically generated for you.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertOptionValueResponse Class
InsertOptionValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueRequest Class
See Also Example Members
[image]

Contains the data that is needed to insert a new option into a StatusAttributeMetadata attribute.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class InsertStatusValueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class InsertStatusValueRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Use InsertStatusValueRequest message to insert a new status
// in an existing status attribute.
// Create the request.
InsertStatusValueRequest insertStatusValueRequest =
    new InsertStatusValueRequest
{
    AttributeLogicalName = "statuscode",
    EntityLogicalName = Contact.EntityLogicalName,
    Label = new Label("Dormant", _languageCode),
    StateCode = 0
};

// Execute the request and store newly inserted value
// for cleanup, used later part of this sample.
_insertedStatusValue = ((InsertStatusValueResponse)_serviceProxy.Execute(
    insertStatusValueRequest)).NewOptionValue;

Console.WriteLine("Created {0} with the value of {1}.",
    insertStatusValueRequest.Label.LocalizedLabels[0].Label,
    _insertedStatusValue);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute    method, which returns an instance of  InsertStatusValueResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in InsertStatusValue Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.InsertStatusValueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Attributes
Customize Entity Attribute Metadata
Entity Attribute Metadata Messages


InsertStatusValueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to insert a new option into a StatusAttributeMetadata attribute.

The following tables list the members exposed by the InsertStatusValueRequest type.

Public Constructors

Name | Description
InsertStatusValueRequest | Initializes a new instance of the InsertStatusValueRequest class
Top

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the logical name of the status attribute. Optional.
public property | Description | Gets or sets a description for the option. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Label | Gets or sets the label for the new status. Required.
public property | OptionSetName | Reserved for future use. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the solution that this attribute should be added to. Optional.
public property | StateCode | Gets or sets the state code for the new status. Required.
public property | Value | Gets or sets the value for the new status. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InsertStatusValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata
Entity Attribute Metadata Messages


InsertStatusValueRequest Constructor
[image]

Initializes a new instance of the InsertStatusValueRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InsertStatusValueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueRequest Class
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InsertStatusValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata
Entity Attribute Metadata Messages


InsertStatusValueRequest Properties
[image]

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the logical name of the status attribute. Optional.
public property | Description | Gets or sets a description for the option. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Label | Gets or sets the label for the new status. Required.
public property | OptionSetName | Reserved for future use. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the solution that this attribute should be added to. Optional.
public property | StateCode | Gets or sets the state code for the new status. Required.
public property | Value | Gets or sets the value for the new status. Optional.

See Also

Reference

InsertStatusValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata
Entity Attribute Metadata Messages


InsertStatusValueRequest.AttributeLogicalName Property
[image]

Gets or sets the logical name of the status attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeLogicalName As String

C#
public string AttributeLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the status attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueRequest Class
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueRequest.Description Property
[image]

Gets or sets a description for the option. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Description As Label

C#
public Label Description { get; set; }

C++

J#

JScript

Property Value
Type:  Label
The description for the option. Optional.

  Remarks
While this data can be set for the option the application does not provide a place where this description can be viewed or edited.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueRequest Class
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueRequest.EntityLogicalName Property
[image]

Gets or sets the logical name of the entity that contains the attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityLogicalName As String

C#
public string EntityLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity that contains the attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueRequest Class
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueRequest.Label Property
[image]

Gets or sets the label for the new status. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Label As Label

C#
public Label Label { get; set; }

C++

J#

JScript

Property Value
Type:  Label
The label for the new status. Required..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueRequest Class
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueRequest.OptionSetName Property
[image]

Reserved for future use. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OptionSetName As String

C#
public string OptionSetName { get; set; }

C++

J#

JScript

Property Value
Type: String
Reserved for future use. Optional.

  Remarks
StatusAttributeMetadata attributes always use local option sets.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueRequest Class
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueRequest.SolutionUniqueName Property
[image]

Gets or sets the solution that this attribute should be added to. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The solution that this attribute should be added to. Optional.

  Remarks
When you update an attribute you have the option to add the attribute to a specific solution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueRequest Class
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueRequest.StateCode Property
[image]

Gets or sets the state code for the new status. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property StateCode As Integer

C#
public int StateCode { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The state code for the new status. Required.

  Remarks
The value must represent a valid option in the StateAttributeMetadata attribute in the same entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueRequest Class
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueRequest.Value Property
[image]

Gets or sets the value for the new status. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As Nullable(Of Integer)

C#
public Nullable<int> Value { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
the value for the new status. Optional.

  Remarks
Passing a null value is recommended. If a null value is passed the system will generate a new value. The new value will include the option value prefix that will help make the value more unique and facilitate correct merging of custom options.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueRequest Class
InsertStatusValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Merge Option Set Options


InsertStatusValueResponse Class
See Also Members
[image]

Contains the response from the InsertStatusValueRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class InsertStatusValueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class InsertStatusValueResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.InsertStatusValueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
InsertStatusValueRequest


InsertStatusValueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the InsertStatusValueRequest class.

The following tables list the members exposed by the InsertStatusValueResponse type.

Public Constructors

Name | Description
InsertStatusValueResponse | Initializes a new instance of the InsertStatusValueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | NewOptionValue | Gets the option value for the new option.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

InsertStatusValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
InsertStatusValueRequest


InsertStatusValueResponse Constructor
[image]

Initializes a new instance of the InsertStatusValueResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public InsertStatusValueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueResponse Class
InsertStatusValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


InsertStatusValueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

InsertStatusValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
InsertStatusValueRequest


InsertStatusValueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | NewOptionValue | Gets the option value for the new option.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

InsertStatusValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
InsertStatusValueRequest


InsertStatusValueResponse.NewOptionValue Property
[image]

Gets the option value for the new option.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property NewOptionValue As Integer

C#
public int NewOptionValue { get; }

C++

J#

JScript

Property Value
Type: Int32
The option value for the new option.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InsertStatusValueResponse Class
InsertStatusValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


IsDataEncryptionActiveRequest Class
See Also Members
[image]

Contains the data that is needed to check if data encryption is currently running (active or inactive).

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class IsDataEncryptionActiveRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class IsDataEncryptionActiveRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute   method, which returns an instance of IsDataEncryptionActiveResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges listed in IsDataEncryptionActive message privileges.
Notes for Callers
None

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.IsDataEncryptionActiveRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsDataEncryptionActiveRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
IsDataEncryptionActiveResponse
Other Resources
Field Level Data Encryption


IsDataEncryptionActiveRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to check if data encryption is currently running (active or inactive).

The following tables list the members exposed by the IsDataEncryptionActiveRequest type.

Public Constructors

Name | Description
IsDataEncryptionActiveRequest | Initializes a new instance of the RetrieveTimestampResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IsDataEncryptionActiveRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
IsDataEncryptionActiveResponse

Other Resources

Field Level Data Encryption


IsDataEncryptionActiveRequest Constructor
[image]

Initializes a new instance of the RetrieveTimestampResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IsDataEncryptionActiveRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsDataEncryptionActiveRequest Class
IsDataEncryptionActiveRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


IsDataEncryptionActiveRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IsDataEncryptionActiveRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
IsDataEncryptionActiveResponse

Other Resources

Field Level Data Encryption


IsDataEncryptionActiveRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

IsDataEncryptionActiveRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
IsDataEncryptionActiveResponse

Other Resources

Field Level Data Encryption


IsDataEncryptionActiveResponse Class
See Also Members
[image]

Contains the response from the IsDataEncryptionActiveRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class IsDataEncryptionActiveResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class IsDataEncryptionActiveResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.IsDataEncryptionActiveResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsDataEncryptionActiveResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
IsDataEncryptionActiveRequest
Other Resources
Field Level Data Encryption


IsDataEncryptionActiveResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the IsDataEncryptionActiveRequest class.

The following tables list the members exposed by the IsDataEncryptionActiveResponse type.

Public Constructors

Name | Description
IsDataEncryptionActiveResponse | Initializes a new instance of the IsDataEncryptionActiveResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsActive | Gets whether data encryption is active or not.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IsDataEncryptionActiveResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
IsDataEncryptionActiveRequest

Other Resources

Field Level Data Encryption


IsDataEncryptionActiveResponse Constructor
[image]

Initializes a new instance of the IsDataEncryptionActiveResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IsDataEncryptionActiveResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsDataEncryptionActiveResponse Class
IsDataEncryptionActiveResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


IsDataEncryptionActiveResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IsDataEncryptionActiveResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
IsDataEncryptionActiveRequest

Other Resources

Field Level Data Encryption


IsDataEncryptionActiveResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | IsActive | Gets whether data encryption is active or not.
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

IsDataEncryptionActiveResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
IsDataEncryptionActiveRequest

Other Resources

Field Level Data Encryption


IsDataEncryptionActiveResponse.IsActive Property
[image]

Gets whether data encryption is active or not.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsActive As Boolean

C#
public bool IsActive { get; }

C++

J#

JScript

Property Value
Type: String
true if data encryption is active; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IsDataEncryptionActiveResponse Class
IsDataEncryptionActiveResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


OrderOptionRequest Class
See Also Example Members
[image]

Contains the data that is needed to set the order for an option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class OrderOptionRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class OrderOptionRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationServiceinterface. For the complete sample, see the link later in this topic.
This sample shows how to change the order of options in a local option set. The following sample retrieves a custom PicklistAttributeMetadata attribute and changes the order of the original options using the OrderBy LINQ function to sort items in ascending order by the label text. Then it uses OrderOptionRequest to set the new order of the options for the attribute.
Use the OrderByDecending LINQ function to order the items in descending order.
C#    Copy Code
// Use the RetrieveAttributeRequest message to retrieve
// a attribute by it's logical name.
RetrieveAttributeRequest retrieveAttributeRequest =
    new RetrieveAttributeRequest
{
    EntityLogicalName = Contact.EntityLogicalName,
    LogicalName = "new_picklist",
    RetrieveAsIfPublished = true
};

// Execute the request.
RetrieveAttributeResponse retrieveAttributeResponse =
    (RetrieveAttributeResponse)_serviceProxy.Execute(
    retrieveAttributeRequest);

// Access the retrieved attribute.
PicklistAttributeMetadata retrievedPicklistAttributeMetadata =
    (PicklistAttributeMetadata)
    retrieveAttributeResponse.AttributeMetadata;

// Get the current options list for the retrieved attribute.
OptionMetadata[] optionList =
    retrievedPicklistAttributeMetadata.OptionSet.Options.ToArray();

// Change the order of the original option's list.
// Use the OrderBy (OrderByDescending) linq function to sort options in
// ascending (descending) order according to label text.
// For ascending order use this:
var updateOptionList =
    optionList.OrderBy(x => x.Label.LocalizedLabels[0].Label).ToList();

// For descending order use this:
// var updateOptionList =
//      optionList.OrderByDescending(
//      x => x.Label.LocalizedLabels[0].Label).ToList();

// Create the request.
OrderOptionRequest orderOptionRequest = new OrderOptionRequest
{
    // Set the properties for the request.
    AttributeLogicalName = "new_picklist",
    EntityLogicalName = Contact.EntityLogicalName,
    // Set the changed order using Select linq function
    // to get only values in an array from the changed option list.
    Values = updateOptionList.Select(x => x.Value.Value).ToArray()
};

// Execute the request
_serviceProxy.Execute(orderOptionRequest);

Console.WriteLine("Option Set option order changed");

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  OrderOptionResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in OrderOption Privileges.
Notes for Callers
You can use this message to edit options for global option sets or local option sets inside a PicklistAttributeMetadata attribute. For global option sets use the OptionSetName property. For local option sets specify the EntityLogicalName and the AttributeLogicalName.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.OrderOptionRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
OrderOptionRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Attributes
Customize Entity Attribute Metadata


OrderOptionRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to set the order for an option set.

The following tables list the members exposed by the OrderOptionRequest type.

Public Constructors

Name | Description
OrderOptionRequest | Initializes a new instance of the OrderOptionRequest class
Top

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the logical name of the PicklistAttributeMetadata attribute. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OptionSetName | Gets or sets the name of the global option set you want to edit options for. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the solution you want to add the solution component to. Optional.
public property | Values | Gets or sets the array of option values in the wanted order. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrderOptionRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata


OrderOptionRequest Constructor
[image]

Initializes a new instance of the OrderOptionRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrderOptionRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderOptionRequest Class
OrderOptionRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


OrderOptionRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrderOptionRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata


OrderOptionRequest Properties
[image]

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the logical name of the PicklistAttributeMetadata attribute. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | OptionSetName | Gets or sets the name of the global option set you want to edit options for. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the solution you want to add the solution component to. Optional.
public property | Values | Gets or sets the array of option values in the wanted order. Required.

See Also

Reference

OrderOptionRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata


OrderOptionRequest.AttributeLogicalName Property
[image]

Gets or sets the logical name of the PicklistAttributeMetadata attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeLogicalName As String

C#
public string AttributeLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the PicklistAttributeMetadata attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderOptionRequest Class
OrderOptionRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


OrderOptionRequest.EntityLogicalName Property
[image]

Gets or sets the logical name of the entity that contains the attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityLogicalName As String

C#
public string EntityLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity that contains the attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderOptionRequest Class
OrderOptionRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


OrderOptionRequest.OptionSetName Property
[image]

Gets or sets the name of the global option set you want to edit options for. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OptionSetName As String

C#
public string OptionSetName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the global option set you want to edit options for. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderOptionRequest Class
OrderOptionRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


OrderOptionRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the solution you want to add the solution component to. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the solution you want to add the solution component to. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderOptionRequest Class
OrderOptionRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


OrderOptionRequest.Values Property
[image]

Gets or sets the array of option values in the wanted order. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Values As Integer()

C#
public int[] Values { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The array of option values in the wanted order. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderOptionRequest Class
OrderOptionRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


OrderOptionResponse Class
See Also Members
[image]

Contains the response from the OrderOptionRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class OrderOptionResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class OrderOptionResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.OrderOptionResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderOptionResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
OrderOptionRequest


OrderOptionResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the OrderOptionRequest class.

The following tables list the members exposed by the OrderOptionResponse type.

Public Constructors

Name | Description
OrderOptionResponse | Initializes a new instance of the OrderOptionResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrderOptionResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
OrderOptionRequest


OrderOptionResponse Constructor
[image]

Initializes a new instance of the OrderOptionResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrderOptionResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderOptionResponse Class
OrderOptionResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


OrderOptionResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrderOptionResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
OrderOptionRequest


OrderOptionResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

OrderOptionResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
OrderOptionRequest


RetrieveAllEntitiesRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve metadata information about all the entities.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveAllEntitiesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveAllEntitiesRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
              RetrieveAllEntitiesRequest request = new RetrieveAllEntitiesRequest()
              {
                  EntityFilters = EntityFilters.Entity,
                  RetrieveAsIfPublished = true
              };

              // Retrieve the MetaData.
              RetrieveAllEntitiesResponse response = (RetrieveAllEntitiesResponse)_serviceProxy.Execute(request);

              // Create an instance of StreamWriter to write text to a file.
              // The using statement also closes the StreamWriter.
// To view this file, right click the file and choose open with Excel.
// Excel will figure out the schema and display the information in columns.

              String filename = String.Concat("EntityInfo.xml");
              using (StreamWriter sw = new StreamWriter(filename))
              {
                  // Create Xml Writer.
                  XmlTextWriter metadataWriter = new XmlTextWriter(sw);

                  // Start Xml File.
                  metadataWriter.WriteStartDocument();

                  // Metadata Xml Node.
                  metadataWriter.WriteStartElement("Metadata");

                  foreach (EntityMetadata currentEntity in response.EntityMetadata)
                  {
                      //if (currentEntity.IsIntersect.Value == false)
                      if (true)
                      {
                          // Start Entity Node
                          metadataWriter.WriteStartElement("Entity");

                          // Write the Entity's Information.
                          metadataWriter.WriteElementString("EntitySchemaName", currentEntity.SchemaName);
                          metadataWriter.WriteElementString("OTC", currentEntity.ObjectTypeCode.ToString());
                          metadataWriter.WriteElementString("OwnershipType", currentEntity.OwnershipType.Value.ToString());
                          if (currentEntity.DisplayName.UserLocalizedLabel != null)
                              metadataWriter.WriteElementString("DisplayName", currentEntity.DisplayName.UserLocalizedLabel.Label);
                          if (currentEntity.DisplayCollectionName.UserLocalizedLabel != null)
                              metadataWriter.WriteElementString("DisplayCollectionName", currentEntity.DisplayCollectionName.UserLocalizedLabel.Label);

                          metadataWriter.WriteElementString("AutoRouteToOwnerQueue", currentEntity.AutoRouteToOwnerQueue.ToString());
                          metadataWriter.WriteElementString("CanBeInManyToMany", currentEntity.CanBeInManyToMany.Value.ToString());
                          metadataWriter.WriteElementString("CanBePrimaryEntityInRelationship", currentEntity.CanBePrimaryEntityInRelationship.Value.ToString());
                          metadataWriter.WriteElementString("CanBeRelatedEntityInRelationship", currentEntity.CanBeRelatedEntityInRelationship.Value.ToString());
                          metadataWriter.WriteElementString("CanCreateAttributes", currentEntity.CanCreateAttributes.Value.ToString());
                          metadataWriter.WriteElementString("CanCreateCharts", currentEntity.CanCreateCharts.Value.ToString());
                          metadataWriter.WriteElementString("CanCreateForms", currentEntity.CanCreateForms.Value.ToString());
                          metadataWriter.WriteElementString("CanCreateViews", currentEntity.CanCreateViews.Value.ToString());
                          metadataWriter.WriteElementString("CanModifyAdditionalSettings", currentEntity.CanModifyAdditionalSettings.Value.ToString());
                          metadataWriter.WriteElementString("CanTriggerWorkflow", currentEntity.CanTriggerWorkflow.Value.ToString());

                          metadataWriter.WriteElementString("IsActivity", currentEntity.IsActivity.Value.ToString());
                          //metadataWriter.WriteElementString("ActivityTypeMask", currentEntity.ActivityTypeMask.ToString());

                          metadataWriter.WriteElementString("IsActivityParty", currentEntity.IsActivityParty.Value.ToString());

                          metadataWriter.WriteElementString("IsAuditEnabled", currentEntity.IsAuditEnabled.Value.ToString());
                          metadataWriter.WriteElementString("IsAvailableOffline", currentEntity.IsAvailableOffline.ToString());
                          metadataWriter.WriteElementString("IsChildEntity", currentEntity.IsChildEntity.ToString());
                          metadataWriter.WriteElementString("IsConnectionsEnabled", currentEntity.IsConnectionsEnabled.ManagedPropertyLogicalName.ToString());
                          metadataWriter.WriteElementString("IsCustomEntity", currentEntity.IsCustomEntity.Value.ToString());
                          metadataWriter.WriteElementString("IsCustomizable", currentEntity.IsCustomizable.Value.ToString());

                          metadataWriter.WriteElementString("IsDocumentManagementEnabled", currentEntity.IsDocumentManagementEnabled.Value.ToString());
                          metadataWriter.WriteElementString("IsDuplicateDetectionEnabled", currentEntity.IsDuplicateDetectionEnabled.Value.ToString());
                          if (currentEntity.IsEnabledForCharts != null)
                              metadataWriter.WriteElementString("IsEnabledForCharts", currentEntity.IsEnabledForCharts.Value.ToString());
                          metadataWriter.WriteElementString("IsImportable", currentEntity.IsImportable.Value.ToString());
                          metadataWriter.WriteElementString("IsIntersect", currentEntity.IsIntersect.Value.ToString());

                          metadataWriter.WriteElementString("IsMailMergeEnabled", currentEntity.IsMailMergeEnabled.Value.ToString());
                          metadataWriter.WriteElementString("IsManaged", currentEntity.IsManaged.Value.ToString());
                          metadataWriter.WriteElementString("IsMappable", currentEntity.IsMappable.Value.ToString());

                          metadataWriter.WriteElementString("IsReadingPaneEnabled", currentEntity.IsReadingPaneEnabled.Value.ToString());
                          metadataWriter.WriteElementString("IsRenameable", currentEntity.IsRenameable.Value.ToString());
                          metadataWriter.WriteElementString("IsValidForAdvancedFind", currentEntity.IsValidForAdvancedFind.Value.ToString());
                          metadataWriter.WriteElementString("IsValidForQueue", currentEntity.IsValidForQueue.Value.ToString());
                          metadataWriter.WriteElementString("IsVisibleInMobile", currentEntity.IsVisibleInMobile.Value.ToString());

                          metadataWriter.WriteElementString("PrimaryIdAttribute", currentEntity.PrimaryIdAttribute);
                          metadataWriter.WriteElementString("PrimaryNameAttribute", currentEntity.PrimaryNameAttribute);
                          metadataWriter.WriteElementString("ReportViewName", currentEntity.ReportViewName);
                          metadataWriter.WriteElementString("RecurrenceBaseEntityLogicalName", currentEntity.RecurrenceBaseEntityLogicalName);
                          if (currentEntity.Description.UserLocalizedLabel != null)
                              metadataWriter.WriteElementString("Description", currentEntity.Description.UserLocalizedLabel.Label);

                          // End Entity Node
                          metadataWriter.WriteEndElement();
                      }
                  }

                  // End Metadata Xml Node
                  metadataWriter.WriteEndElement();
                  metadataWriter.WriteEndDocument();

                  // Close xml writer.
                  metadataWriter.Close();
              }

             Console.WriteLine("Done.");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute   method, which returns an instance of RetrieveAllEntitiesResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges listed in RetrieveAllEntities Privileges.
Notes for Callers
This request returns a large amount of data and may take significant time to return all the data. When there are a large number of customizations it is possible that this request could fail due to time limitations using Microsoft Dynamics CRM Online.
Use the RetrieveMetadataChangesRequest to request just the metadata you need. Otherwise, use EntityFilters.Entity as the EntityFilters parameter to minimize the amount of data retrieved. Then, using the LogicalName returned for each entity, use the RetrieveEntityRequest class to for each entity that you need metadata for. Splitting up the requests can reduce the chance that your request will time out.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveAllEntitiesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveAllEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Dump Entity Metadata to a File
Sample: Dump Entity Relationship Information to a File
Sample: Dump Entity Privilege Information to a File
Query and Capture Changes to Metadata
Customize Entity Metadata


RetrieveAllEntitiesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve metadata information about all the entities.

The following tables list the members exposed by the RetrieveAllEntitiesRequest type.

Public Constructors

Name | Description
RetrieveAllEntitiesRequest | Initializes a new instance of the RetrieveAllEntitiesRequest class
Top

Public Properties

 | Name | Description
public property | EntityFilters | Gets or sets a filter to control how much data for each entity is retrieved. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllEntitiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Dump Entity Metadata to a File
Sample: Dump Entity Relationship Information to a File
Sample: Dump Entity Privilege Information to a File
Query and Capture Changes to Metadata
Customize Entity Metadata


RetrieveAllEntitiesRequest Constructor
[image]

Initializes a new instance of the RetrieveAllEntitiesRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllEntitiesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllEntitiesRequest Class
RetrieveAllEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllEntitiesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllEntitiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Dump Entity Metadata to a File
Sample: Dump Entity Relationship Information to a File
Sample: Dump Entity Privilege Information to a File
Query and Capture Changes to Metadata
Customize Entity Metadata


RetrieveAllEntitiesRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityFilters | Gets or sets a filter to control how much data for each entity is retrieved. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.

See Also

Reference

RetrieveAllEntitiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Dump Entity Metadata to a File
Sample: Dump Entity Relationship Information to a File
Sample: Dump Entity Privilege Information to a File
Query and Capture Changes to Metadata
Customize Entity Metadata


RetrieveAllEntitiesRequest.EntityFilters Property
[image]

Gets or sets a filter to control how much data for each entity is retrieved. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityFilters As EntityFilters

C#
public EntityFilters EntityFilters { get; set; }

C++

J#

JScript

Property Value
Type: EntityFilters
A filter to control how much data for each entity is retrieved. Required.

  Remarks
To improve performance use the appropriate entity filter to provide just the data you need.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllEntitiesRequest Class
RetrieveAllEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllEntitiesRequest.RetrieveAsIfPublished Property
[image]

Gets or sets whether to retrieve the metadata that has not been published. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RetrieveAsIfPublished As Boolean

C#
public bool RetrieveAsIfPublished { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the metadata that has not been published should be retrieved; otherwise, false.

  Remarks
If you are creating an entity editor you will need to retrieve entity data that has been saved but not published. For other scenarios you will want to only retrieve published metadata.
  • Set this value to true to include unpublished changes, as it would look if you called publish.
  • Set this value to false to include only the currently published changes, ignoring the changes that haven't yet been published.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllEntitiesRequest Class
RetrieveAllEntitiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllEntitiesResponse Class
See Also Members
[image]

Contains the response from the RetrieveAllEntitiesRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveAllEntitiesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveAllEntitiesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveAllEntitiesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllEntitiesRequest


RetrieveAllEntitiesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAllEntitiesRequest class.

The following tables list the members exposed by the RetrieveAllEntitiesResponse type.

Public Constructors

Name | Description
RetrieveAllEntitiesResponse | Initializes a new instance of the RetrieveAllEntitiesResponse class.
Top

Public Properties

 | Name | Description
public property | EntityMetadata | Gets an array of EntityMetadata instances.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Timestamp | Gets a time stamp that represents the time when the data was retrieved.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllEntitiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllEntitiesRequest


RetrieveAllEntitiesResponse Constructor
[image]

Initializes a new instance of the RetrieveAllEntitiesResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllEntitiesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllEntitiesResponse Class
RetrieveAllEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllEntitiesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllEntitiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllEntitiesRequest


RetrieveAllEntitiesResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityMetadata | Gets an array of EntityMetadata instances.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Timestamp | Gets a time stamp that represents the time when the data was retrieved.

See Also

Reference

RetrieveAllEntitiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllEntitiesRequest


RetrieveAllEntitiesResponse.EntityMetadata Property
[image]

Gets an array of EntityMetadata instances.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityMetadata As EntityMetadata()

C#
public EntityMetadata[] EntityMetadata { get; }

C++

J#

JScript

Property Value
Type:  EntityMetadata[]
an array of EntityMetadata instances..

  Remarks
The data that is included in each EntityMetadata instance varies based on the EntityFilters parameter that is passed to the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllEntitiesResponse Class
RetrieveAllEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllEntitiesResponse.Timestamp Property
[image]

Gets a time stamp that represents the time when the data was retrieved.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Timestamp As String

C#
public string Timestamp { get; }

C++

J#

JScript

Property Value
Type: String
A time stamp that represents the time when the data was retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllEntitiesResponse Class
RetrieveAllEntitiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllManagedPropertiesRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve all managed property definitions

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveAllManagedPropertiesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveAllManagedPropertiesRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveAllManagedPropertiesResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveAllManagedProperties Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveAllManagedPropertiesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllManagedPropertiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Use Managed Properties
Plan For Solution Development
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveAllManagedPropertiesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve all managed property definitions

The following tables list the members exposed by the RetrieveAllManagedPropertiesRequest type.

Public Constructors

Name | Description
RetrieveAllManagedPropertiesRequest | Initializes a new instance of the RetrieveAllManagedPropertiesRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllManagedPropertiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Use Managed Properties
Plan For Solution Development
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveAllManagedPropertiesRequest Constructor
[image]

Initializes a new instance of the RetrieveAllManagedPropertiesRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllManagedPropertiesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllManagedPropertiesRequest Class
RetrieveAllManagedPropertiesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllManagedPropertiesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllManagedPropertiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Use Managed Properties
Plan For Solution Development
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveAllManagedPropertiesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveAllManagedPropertiesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Use Managed Properties
Plan For Solution Development
Package and Distribute Extensions with Microsoft Dynamics CRM Solutions


RetrieveAllManagedPropertiesResponse Class
See Also Members
[image]

Contains the response from the RetrieveAllManagedPropertiesRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveAllManagedPropertiesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveAllManagedPropertiesResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveAllManagedPropertiesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllManagedPropertiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllManagedPropertiesRequest


RetrieveAllManagedPropertiesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAllManagedPropertiesRequest class.

The following tables list the members exposed by the RetrieveAllManagedPropertiesResponse type.

Public Constructors

Name | Description
RetrieveAllManagedPropertiesResponse | Initializes a new instance of the RetrieveAllManagedPropertiesResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ManagedPropertyMetadata | Gets an array of managed property definitions.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllManagedPropertiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllManagedPropertiesRequest


RetrieveAllManagedPropertiesResponse Constructor
[image]

Initializes a new instance of the RetrieveAllManagedPropertiesResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllManagedPropertiesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllManagedPropertiesResponse Class
RetrieveAllManagedPropertiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllManagedPropertiesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllManagedPropertiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllManagedPropertiesRequest


RetrieveAllManagedPropertiesResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ManagedPropertyMetadata | Gets an array of managed property definitions.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveAllManagedPropertiesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllManagedPropertiesRequest


RetrieveAllManagedPropertiesResponse.ManagedPropertyMetadata Property
[image]

Gets an array of managed property definitions.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ManagedPropertyMetadata As ManagedPropertyMetadata()

C#
public ManagedPropertyMetadata[] ManagedPropertyMetadata { get; }

C++

J#

JScript

Property Value
Type: ManagedPropertyMetadata[]
An array of managed property definitions.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllManagedPropertiesResponse Class
RetrieveAllManagedPropertiesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllOptionSetsRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve information about all global option sets.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveAllOptionSetsRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveAllOptionSetsRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Use RetrieveAllOptionSetsRequest to retrieve all global option sets.
// Create the request.
RetrieveAllOptionSetsRequest retrieveAllOptionSetsRequest =
    new RetrieveAllOptionSetsRequest();

// Execute the request
RetrieveAllOptionSetsResponse retrieveAllOptionSetsResponse =
    (RetrieveAllOptionSetsResponse)_serviceProxy.Execute(
    retrieveAllOptionSetsRequest);

// Now you can use RetrieveAllOptionSetsResponse.OptionSetMetadata property to
// work with all retrieved option sets.
if (retrieveAllOptionSetsResponse.OptionSetMetadata.Count() > 0)
{
    Console.WriteLine("All the global option sets retrieved as below:");
    int count = 1;
    foreach (OptionSetMetadataBase optionSetMetadata in
        retrieveAllOptionSetsResponse.OptionSetMetadata)
    {
        Console.WriteLine("{0} {1}", count++,
            (optionSetMetadata.DisplayName.LocalizedLabels.Count >0)? optionSetMetadata.DisplayName.LocalizedLabels[0].Label : String.Empty);
    }
}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveAllOptionSetsResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveAllOptionSets Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveAllOptionSetsRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveAllOptionSetsRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Retrieve all Global Option Sets
Sample: Dump Global Option Set Information to a File
Customize Global Option Sets in Microsoft Dynamics CRM


RetrieveAllOptionSetsRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve information about all global option sets.

The following tables list the members exposed by the RetrieveAllOptionSetsRequest type.

Public Constructors

Name | Description
RetrieveAllOptionSetsRequest | Initializes a new instance of the RetrieveAllOptionSetsRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllOptionSetsRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Retrieve all Global Option Sets
Sample: Dump Global Option Set Information to a File
Customize Global Option Sets in Microsoft Dynamics CRM


RetrieveAllOptionSetsRequest Constructor
[image]

Initializes a new instance of the RetrieveAllOptionSetsRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllOptionSetsRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllOptionSetsRequest Class
RetrieveAllOptionSetsRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllOptionSetsRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllOptionSetsRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Retrieve all Global Option Sets
Sample: Dump Global Option Set Information to a File
Customize Global Option Sets in Microsoft Dynamics CRM


RetrieveAllOptionSetsRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.

See Also

Reference

RetrieveAllOptionSetsRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Retrieve all Global Option Sets
Sample: Dump Global Option Set Information to a File
Customize Global Option Sets in Microsoft Dynamics CRM


RetrieveAllOptionSetsRequest.RetrieveAsIfPublished Property
[image]

Gets or sets whether to retrieve the metadata that has not been published. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RetrieveAsIfPublished As Boolean

C#
public bool RetrieveAsIfPublished { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the metadata that has not been published should be retrieved; otherwise, false.

  Remarks
If you are creating a global optionset editor you will need to retrieve entity data that has been saved but not published. For other scenarios you will want to only retrieve published metadata.
  • Set this value to true to include unpublished changes, as it would look if you called publish.
  • Set this value to false to include only the currently published changes, ignoring the changes that haven't yet been published.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllOptionSetsRequest Class
RetrieveAllOptionSetsRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllOptionSetsResponse Class
See Also Members
[image]

Contains the response from the RetrieveAllOptionSetsRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveAllOptionSetsResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveAllOptionSetsResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveAllOptionSetsResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllOptionSetsResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllOptionSetsRequest


RetrieveAllOptionSetsResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAllOptionSetsRequest class.

The following tables list the members exposed by the RetrieveAllOptionSetsResponse type.

Public Constructors

Name | Description
RetrieveAllOptionSetsResponse | Initializes a new instance of the RetrieveAllOptionSetsResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OptionSetMetadata | Gets an array of definitions for each global option set.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAllOptionSetsResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllOptionSetsRequest


RetrieveAllOptionSetsResponse Constructor
[image]

Initializes a new instance of the RetrieveAllOptionSetsResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAllOptionSetsResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllOptionSetsResponse Class
RetrieveAllOptionSetsResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAllOptionSetsResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAllOptionSetsResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllOptionSetsRequest


RetrieveAllOptionSetsResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OptionSetMetadata | Gets an array of definitions for each global option set.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveAllOptionSetsResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAllOptionSetsRequest


RetrieveAllOptionSetsResponse.OptionSetMetadata Property
[image]

Gets an array of definitions for each global option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property OptionSetMetadata As OptionSetMetadataBase()

C#
public OptionSetMetadataBase[] OptionSetMetadata { get; }

C++

J#

JScript

Property Value
Type: OptionSetMetadataBase[]
An array of definitions for each global option set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAllOptionSetsResponse Class
RetrieveAllOptionSetsResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAttributeRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve attribute metadata.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveAttributeRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveAttributeRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Create the request
RetrieveAttributeRequest attributeRequest = new RetrieveAttributeRequest
{
    EntityLogicalName = Contact.EntityLogicalName,
    LogicalName = "new_string",
    RetrieveAsIfPublished = true
};

// Execute the request
RetrieveAttributeResponse attributeResponse =
    (RetrieveAttributeResponse)_serviceProxy.Execute(attributeRequest);

Console.WriteLine("Retrieved the attribute {0}.",
    attributeResponse.AttributeMetadata.SchemaName);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute   method, which returns an instance of RetrieveAttributeResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges listed in RetrieveAttribute Privileges.
Notes for Callers
You can use either the LogicalName or the MetadataId to specify the attribute you want to retrieve.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveAttributeRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Attributes
Customize Entity Attribute Metadata


RetrieveAttributeRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve attribute metadata.

The following tables list the members exposed by the RetrieveAttributeRequest type.

Public Constructors

Name | Description
RetrieveAttributeRequest | Initializes a new instance of the RetrieveAttributeRequest class
Top

Public Properties

 | Name | Description
public property | ColumnNumber | Gets or sets a column number value to identify an attribute from the Audit.AttributeMask property. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the logical name of the attribute to be retrieved. Optional.
public property | MetadataId | The unique identifier for the attribute. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata


RetrieveAttributeRequest Constructor
[image]

Initializes a new instance of the RetrieveAttributeRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAttributeRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeRequest Class
RetrieveAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAttributeRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata


RetrieveAttributeRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnNumber | Gets or sets a column number value to identify an attribute from the Audit.AttributeMask property. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity that contains the attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the logical name of the attribute to be retrieved. Optional.
public property | MetadataId | The unique identifier for the attribute. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.

See Also

Reference

RetrieveAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata


RetrieveAttributeRequest.ColumnNumber Property
[image]

Gets or sets a column number value to identify an attribute from the Audit.AttributeMask property. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnNumber As Integer

C#
public int ColumnNumber { get; set; }

C++

J#

JScript

Property Value
Type: Int32
A column number value to identify an attribute from the Audit.AttributeMask property. Optional.

  Remarks
This property can be used in place of the LogicalName when querying Audit entity records. The AttributeMask property contains a column delimited list of column number values representing the attributes modified when the record was updated. You can use these values to retrieve the metadata for the attribute that was changed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeRequest Class
RetrieveAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Audit Entity Data Changes in Microsoft Dynamics CRM
Audit Entity Messages and Methods


RetrieveAttributeRequest.EntityLogicalName Property
[image]

Gets or sets the logical name of the entity that contains the attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityLogicalName As String

C#
public string EntityLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity that contains the attribute. Optional.

  Remarks
The LogicalName and the EntityLogicalName are required if the MetadataId is not provided.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeRequest Class
RetrieveAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAttributeRequest.LogicalName Property
[image]

Gets or sets the logical name of the attribute to be retrieved. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LogicalName As String

C#
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the attribute to be retrieved. Optional.

  Remarks
The LogicalName and the EntityLogicalName are required if the MetadataId is not provided.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeRequest Class
RetrieveAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAttributeRequest.MetadataId Property
[image]

The unique identifier for the attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MetadataId As Guid

C#
public Guid MetadataId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The unique identifier for the attribute. This corresponds to the MetadataBase.MetadataId.

  Remarks
The MetadataId is required if the EntityLogicalName and the LogicalName iiis not provided.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeRequest Class
RetrieveAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAttributeRequest.RetrieveAsIfPublished Property
[image]

Gets or sets whether to retrieve the metadata that has not been published. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RetrieveAsIfPublished As Boolean

C#
public bool RetrieveAsIfPublished { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the metadata that has not been published should be retrieved; otherwise, false.

  Remarks
If you are creating an attribute editor you will need to retrieve entity data that has been saved but not published. For other scenarios you will want to only retrieve published metadata.
  • Set this value to true to include unpublished changes, as it would look if you called publish.
  • Set this value to false to include only the currently published changes, ignoring the changes that haven't yet been published.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeRequest Class
RetrieveAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAttributeResponse Class
See Also Members
[image]

Contains the response from the RetrieveAttributeRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveAttributeResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveAttributeResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveAttributeResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAttributeRequest


RetrieveAttributeResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveAttributeRequest class.

The following tables list the members exposed by the RetrieveAttributeResponse type.

Public Constructors

Name | Description
RetrieveAttributeResponse | Initializes a new instance of the RetrieveAttributeResponse class.
Top

Public Properties

 | Name | Description
public property | AttributeMetadata | Gets the metadata for the requested attribute.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAttributeRequest


RetrieveAttributeResponse Constructor
[image]

Initializes a new instance of the RetrieveAttributeResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveAttributeResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeResponse Class
RetrieveAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveAttributeResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAttributeRequest


RetrieveAttributeResponse Properties
[image]

Public Properties

 | Name | Description
public property | AttributeMetadata | Gets the metadata for the requested attribute.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveAttributeRequest


RetrieveAttributeResponse.AttributeMetadata Property
[image]

Gets the metadata for the requested attribute.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AttributeMetadata As AttributeMetadata

C#
public AttributeMetadata AttributeMetadata { get; }

C++

J#

JScript

Property Value
Type: AttributeMetadata
The metadata for the requested attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveAttributeResponse Class
RetrieveAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveDataEncryptionKeyRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve the data encryption key value.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveDataEncryptionKeyRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveDataEncryptionKeyRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute   method, which returns an instance of RetrieveDataEncryptionKeyResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges listed in RetrieveDataEncryptionKey message privileges.
Notes for Callers
None

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveDataEncryptionKeyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDataEncryptionKeyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveDataEncryptionKeyResponse
Other Resources
Field Level Data Encryption


RetrieveDataEncryptionKeyRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve the data encryption key value.

The following tables list the members exposed by the RetrieveDataEncryptionKeyRequest type.

Public Constructors

Name | Description
RetrieveDataEncryptionKeyRequest | Initializes a new instance of the RetrieveDataEncryptionKeyRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDataEncryptionKeyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveDataEncryptionKeyResponse

Other Resources

Field Level Data Encryption


RetrieveDataEncryptionKeyRequest Constructor
[image]

Initializes a new instance of the RetrieveDataEncryptionKeyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDataEncryptionKeyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDataEncryptionKeyRequest Class
RetrieveDataEncryptionKeyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveDataEncryptionKeyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDataEncryptionKeyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveDataEncryptionKeyResponse

Other Resources

Field Level Data Encryption


RetrieveDataEncryptionKeyRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveDataEncryptionKeyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveDataEncryptionKeyResponse

Other Resources

Field Level Data Encryption


RetrieveDataEncryptionKeyResponse Class
See Also Members
[image]

Contains the response from the RetrieveDataEncryptionKeyResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveDataEncryptionKeyResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveDataEncryptionKeyResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveDataEncryptionKeyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDataEncryptionKeyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveDataEncryptionKeyRequest
Other Resources
Field Level Data Encryption


RetrieveDataEncryptionKeyResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveDataEncryptionKeyResponse class.

The following tables list the members exposed by the RetrieveDataEncryptionKeyResponse type.

Public Constructors

Name | Description
RetrieveDataEncryptionKeyResponse | Initializes a new instance of the RetrieveDataEncryptionKeyResponse class.
Top

Public Properties

 | Name | Description
public property | EncryptionKey | Gets or sets the encryption key.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveDataEncryptionKeyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveDataEncryptionKeyRequest

Other Resources

Field Level Data Encryption


RetrieveDataEncryptionKeyResponse Constructor
[image]

Initializes a new instance of the RetrieveDataEncryptionKeyResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveDataEncryptionKeyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDataEncryptionKeyResponse Class
RetrieveDataEncryptionKeyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveDataEncryptionKeyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveDataEncryptionKeyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveDataEncryptionKeyRequest

Other Resources

Field Level Data Encryption


RetrieveDataEncryptionKeyResponse Properties
[image]

Public Properties

 | Name | Description
public property | EncryptionKey | Gets or sets the encryption key.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveDataEncryptionKeyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveDataEncryptionKeyRequest

Other Resources

Field Level Data Encryption


RetrieveDataEncryptionKeyResponse.EncryptionKey Property
[image]

Gets or sets the encryption key.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EncryptionKey As String

C#
public string EncryptionKey { get; }

C++

J#

JScript

Property Value
Type: String
. The value returned is the decrypted data encryption key.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveDataEncryptionKeyResponse Class
RetrieveDataEncryptionKeyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveEntityRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve entity metadata.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveEntityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveEntityRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
RetrieveEntityRequest retrieveBankAccountEntityRequest = new RetrieveEntityRequest
{
 EntityFilters = EntityFilters.Entity,
 LogicalName = _customEntityName
};
RetrieveEntityResponse retrieveBankAccountEntityResponse = (RetrieveEntityResponse)_serviceProxy.Execute(retrieveBankAccountEntityRequest);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveEntityResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveEntity Privileges.
Notes for Callers
You can use either the LogicalName or the MetadataId to specify the entity you want to retrieve.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveEntityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Create and Update Entity Metadata
Customize Entity Metadata


RetrieveEntityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve entity metadata.

The following tables list the members exposed by the RetrieveEntityRequest type.

Public Constructors

Name | Description
RetrieveEntityRequest | Initializes a new instance of the RetrieveEntityRequest class.
Top

Public Properties

 | Name | Description
public property | EntityFilters | Gets or sets a filter to control how much data for the entity is retrieved. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the logical name of the entity to be retrieved. Optional.
public property | MetadataId | A unique identifier for the entity. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create and Update Entity Metadata
Customize Entity Metadata


RetrieveEntityRequest Constructor
[image]

Initializes a new instance of the RetrieveEntityRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveEntityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRequest Class
RetrieveEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveEntityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create and Update Entity Metadata
Customize Entity Metadata


RetrieveEntityRequest Properties
[image]

Public Properties

 | Name | Description
public property | EntityFilters | Gets or sets a filter to control how much data for the entity is retrieved. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the logical name of the entity to be retrieved. Optional.
public property | MetadataId | A unique identifier for the entity. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.

See Also

Reference

RetrieveEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create and Update Entity Metadata
Customize Entity Metadata


RetrieveEntityRequest.EntityFilters Property
[image]

Gets or sets a filter to control how much data for the entity is retrieved. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityFilters As EntityFilters

C#
public EntityFilters EntityFilters { get; set; }

C++

J#

JScript

Property Value
Type: EntityFilters
a filter to control how much data for the entity is retrieved. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRequest Class
RetrieveEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveEntityRequest.LogicalName Property
[image]

Gets or sets the logical name of the entity to be retrieved. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LogicalName As String

C#
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity to be retrieved. Optional.

  Remarks
The LogicalName is required if the MetadataId is not provided.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRequest Class
RetrieveEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveEntityRequest.MetadataId Property
[image]

A unique identifier for the entity. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MetadataId As Guid

C#
public Guid MetadataId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The A unique identifier for the entity. This corresponds to the MetadataBase. MetadataId for the entity.

  Remarks
The MetadataId is required if the LogicalName is not provided.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRequest Class
RetrieveEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveEntityRequest.RetrieveAsIfPublished Property
[image]

Gets or sets whether to retrieve the metadata that has not been published. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RetrieveAsIfPublished As Boolean

C#
public bool RetrieveAsIfPublished { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the metadata that has not been published should be retrieved; otherwise, false.

  Remarks
If you are creating an entity editor you will need to retrieve entity data that has been saved but not published. For other scenarios you will want to only retrieve published metadata.
  • Set this value to true to include unpublished changes, as it would look if you called publish.
  • Set this value to false to include only the currently published changes, ignoring the changes that haven't yet been published.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityRequest Class
RetrieveEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveEntityResponse Class
See Also Members
[image]

Contains the response from the RetrieveEntityRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveEntityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveEntityResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveEntityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveEntityRequest


RetrieveEntityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveEntityRequest class.

The following tables list the members exposed by the RetrieveEntityResponse type.

Public Constructors

Name | Description
RetrieveEntityResponse | Initializes a new instance of the RetrieveEntityResponse class.
Top

Public Properties

 | Name | Description
public property | EntityMetadata | Gets the metadata for the requested entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveEntityRequest


RetrieveEntityResponse Constructor
[image]

Initializes a new instance of the RetrieveEntityResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveEntityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityResponse Class
RetrieveEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveEntityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveEntityRequest


RetrieveEntityResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityMetadata | Gets the metadata for the requested entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveEntityRequest


RetrieveEntityResponse.EntityMetadata Property
[image]

Gets the metadata for the requested entity.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityMetadata As EntityMetadata

C#
public EntityMetadata EntityMetadata { get; }

C++

J#

JScript

Property Value
Type: EntityMetadata
The metadata for the requested entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntityResponse Class
RetrieveEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveManagedPropertyRequest Class
See Also Members
[image]

Contains the data that is needed to retrieve a managed property definition.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveManagedPropertyRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveManagedPropertyRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveManagedPropertyResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveManagedProperty Privileges.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveManagedPropertyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveManagedPropertyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Use Managed Properties


RetrieveManagedPropertyRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a managed property definition.

The following tables list the members exposed by the RetrieveManagedPropertyRequest type.

Public Constructors

Name | Description
RetrieveManagedPropertyRequest | Initializes a new instance of the RetrieveManagedPropertyRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the name of the managed property. Optional.
public property | MetadataId | Gets or sets the ID of the managed property. Required,
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveManagedPropertyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Use Managed Properties


RetrieveManagedPropertyRequest Constructor
[image]

Initializes a new instance of the RetrieveManagedPropertyRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveManagedPropertyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveManagedPropertyRequest Class
RetrieveManagedPropertyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveManagedPropertyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveManagedPropertyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Use Managed Properties


RetrieveManagedPropertyRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | LogicalName | Gets or sets the name of the managed property. Optional.
public property | MetadataId | Gets or sets the ID of the managed property. Required,
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveManagedPropertyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Use Managed Properties


RetrieveManagedPropertyRequest.LogicalName Property
[image]

Gets or sets the name of the managed property. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property LogicalName As String

C#
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the managed property. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveManagedPropertyRequest Class
RetrieveManagedPropertyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveManagedPropertyRequest.MetadataId Property
[image]

Gets or sets the ID of the managed property. Required,

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MetadataId As Guid

C#
public Guid MetadataId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the managed property. This corresponds to the MetadataBase.MetadataId for the managed property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveManagedPropertyRequest Class
RetrieveManagedPropertyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveManagedPropertyResponse Class
See Also Members
[image]

Contains the response from the RetrieveManagedPropertyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveManagedPropertyResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveManagedPropertyResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveManagedPropertyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveManagedPropertyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveManagedPropertyRequest


RetrieveManagedPropertyResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveManagedPropertyRequest class.

The following tables list the members exposed by the RetrieveManagedPropertyResponse type.

Public Constructors

Name | Description
RetrieveManagedPropertyResponse | Initializes a new instance of the RetrieveManagedPropertyResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ManagedPropertyMetadata | Gets the definition of the managed property.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveManagedPropertyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveManagedPropertyRequest


RetrieveManagedPropertyResponse Constructor
[image]

Initializes a new instance of the RetrieveManagedPropertyResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveManagedPropertyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveManagedPropertyResponse Class
RetrieveManagedPropertyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveManagedPropertyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveManagedPropertyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveManagedPropertyRequest


RetrieveManagedPropertyResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ManagedPropertyMetadata | Gets the definition of the managed property.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveManagedPropertyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveManagedPropertyRequest


RetrieveManagedPropertyResponse.ManagedPropertyMetadata Property
[image]

Gets the definition of the managed property.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ManagedPropertyMetadata As ManagedPropertyMetadata

C#
public ManagedPropertyMetadata ManagedPropertyMetadata { get; }

C++

J#

JScript

Property Value
Type: ManagedPropertyMetadata
The definition of the managed property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveManagedPropertyResponse Class
RetrieveManagedPropertyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMetadataChangesRequest Class
See Also Example Members
[image]

Contains the data that is needed to to retrieve a collection of metadata records that satisfy the specified criteria. The RetrieveMetadataChangesResponse returns a timestamp value that can be used with this request at a later time to return information about how metadata has changed since the last request.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveMetadataChangesRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveMetadataChangesRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
protected RetrieveMetadataChangesResponse getMetadataChanges(
 EntityQueryExpression entityQueryExpression,
 String clientVersionStamp,
 DeletedMetadataFilters deletedMetadataFilter)
{
 RetrieveMetadataChangesRequest retrieveMetadataChangesRequest = new RetrieveMetadataChangesRequest()
 {
  Query = entityQueryExpression,
  ClientVersionStamp = clientVersionStamp,
  DeletedMetadataFilters = deletedMetadataFilter
 };

 return (RetrieveMetadataChangesResponse)_service.Execute(retrieveMetadataChangesRequest);

}

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute method, which returns an instance of  RetrieveMetadataChangesResponse.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveMetadataChangesRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveMetadataChangesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes
Customize Entity Metadata
Customize Entity Attribute Metadata
Customize Entity Relationship Metadata


RetrieveMetadataChangesRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to to retrieve a collection of metadata records that satisfy the specified criteria. The RetrieveMetadataChangesResponse returns a timestamp value that can be used with this request at a later time to return information about how metadata has changed since the last request.

The following tables list the members exposed by the RetrieveMetadataChangesRequest type.

Public Constructors

Name | Description
RetrieveMetadataChangesRequest | Initializes a new instance of the RetrieveMetadataChangesRequest class.
Top

Public Properties

 | Name | Description
public property | ClientVersionStamp | Gets or sets a timestamp value representing when the last request was made.
public property | DeletedMetadataFilters | Gets or sets a value to filter what deleted metadata items will be returned.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query representing the metadata to return.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMetadataChangesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes
Customize Entity Metadata
Customize Entity Attribute Metadata
Customize Entity Relationship Metadata


RetrieveMetadataChangesRequest Constructor
[image]

Initializes a new instance of the RetrieveMetadataChangesRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMetadataChangesRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMetadataChangesRequest Class
RetrieveMetadataChangesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMetadataChangesRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMetadataChangesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes
Customize Entity Metadata
Customize Entity Attribute Metadata
Customize Entity Relationship Metadata


RetrieveMetadataChangesRequest Properties
[image]

Public Properties

 | Name | Description
public property | ClientVersionStamp | Gets or sets a timestamp value representing when the last request was made.
public property | DeletedMetadataFilters | Gets or sets a value to filter what deleted metadata items will be returned.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query representing the metadata to return.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveMetadataChangesRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes
Customize Entity Metadata
Customize Entity Attribute Metadata
Customize Entity Relationship Metadata


RetrieveMetadataChangesRequest.ClientVersionStamp Property
[image]

Gets or sets a timestamp value representing when the last request was made.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ClientVersionStamp As String

C#
public string ClientVersionStamp { get; set; }

C++

J#

JScript

Property Value
Type: String

A timestamp value representing when the last request was made.

  Remarks
Set this using a ServerVersionStamp value from a previous request and you will retrieve only the metadata changes, including deleted metadata. Set this value to null and you will retrieve all the metadata defined in the query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMetadataChangesRequest Class
RetrieveMetadataChangesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMetadataChangesRequest.DeletedMetadataFilters Property
[image]

Gets or sets a value to filter what deleted metadata items will be returned.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DeletedMetadataFilters As DeletedMetadataFilters

C#
public DeletedMetadataFilters DeletedMetadataFilters { get; set; }

C++

J#

JScript

Property Value
Type: DeletedMetadataFilters
A value to filter what deleted metadata items will be returned.

  Remarks
Both the ClientVersionStamp and this parameter must be included for any deleted metadata to be returned.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMetadataChangesRequest Class
RetrieveMetadataChangesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMetadataChangesRequest.Query Property
[image]

Gets or sets the query representing the metadata to return.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As EntityQueryExpression

C#
public EntityQueryExpression Query { get; set; }

C++

J#

JScript

Property Value
Type:EntityQueryExpression
The query representing the metadata to return.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMetadataChangesRequest Class
RetrieveMetadataChangesRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMetadataChangesResponse Class
See Also Example Members
[image]

Contains the response from the RetrieveMetadataChangesRequest message.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveMetadataChangesResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveMetadataChangesResponse : OrganizationResponse

C++

J#

JScript

  Example
The following code snippets from Sample: Query Metadata and Detect Changes show the use of RetrieveMetadataChangesResponse DeletedMetadata and EntityMetadata properties.
C#    Copy Code
protected String updateOptionLabelList(EntityQueryExpression entityQueryExpression, String clientVersionStamp)
{
 //Retrieve metadata changes and add them to the cache
 RetrieveMetadataChangesResponse updateResponse;
 try
 {
  updateResponse = getMetadataChanges(entityQueryExpression, clientVersionStamp, DeletedMetadataFilters.OptionSet);
  addOptionLabelsToCache(updateResponse.EntityMetadata, true);
  removeOptionLabelsFromCache(updateResponse.DeletedMetadata, true);

 }
 catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
 {
  // Check for ErrorCodes.ExpiredVersionStamp (0x80044352)
  // Will occur when the timestamp exceeds the Organization.ExpireSubscriptionsInDays value, which is 90 by default.
  if (ex.Detail.ErrorCode == unchecked((int)0x80044352))
  {
   //reinitialize cache
   _optionLabelList.Clear();

   updateResponse = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);
   //Add them to the cache and display the changes
   addOptionLabelsToCache(updateResponse.EntityMetadata, true);

  }
  else
  {
   throw ex;
  }

 }
 return updateResponse.ServerVersionStamp;
}

   ...

protected void addOptionLabelsToCache(EntityMetadataCollection entityMetadataCollection, Boolean showChanges)
{

 List<OptionSetOption> changes = new List<OptionSetOption>();

 foreach (EntityMetadata em in entityMetadataCollection)
 {
  foreach (AttributeMetadata am in em.Attributes)
  {
   switch (am.AttributeType)
   {
    case AttributeTypeCode.Boolean:
     BooleanAttributeMetadata booleanAttribute = (BooleanAttributeMetadata)am;
     //Labels will not be included if they aren't new
     if (booleanAttribute.OptionSet.FalseOption.Label.UserLocalizedLabel != null)
     {
      changes.Add(new OptionSetOption(
      (Guid)booleanAttribute.OptionSet.MetadataId,
      0,
      booleanAttribute.OptionSet.FalseOption.Label.UserLocalizedLabel.Label)
      );
     }
     //Labels will not be included if they aren't new
     if (booleanAttribute.OptionSet.TrueOption.Label.UserLocalizedLabel != null)
     {
      changes.Add(new OptionSetOption(
      (Guid)booleanAttribute.OptionSet.MetadataId,
      1,
      booleanAttribute.OptionSet.TrueOption.Label.UserLocalizedLabel.Label));
     }
     break;
    default:
     EnumAttributeMetadata optionsetAttribute = (EnumAttributeMetadata)am;
     foreach (OptionMetadata option in optionsetAttribute.OptionSet.Options)
     {
      //Labels will not be included if they aren't new
      if (option.Label.UserLocalizedLabel != null)
      {
       changes.Add(new OptionSetOption(
        (Guid)optionsetAttribute.OptionSet.MetadataId,
       (int)option.Value,
       option.Label.UserLocalizedLabel.Label));
      }
     }
     break;
   }
  }
 }

 _optionLabelList.AddRange(changes);

 if (showChanges)
 {

  if (changes.Count > 0)
  {
   Console.WriteLine("{0} option labels for {1} entities were added to the cache.", changes.Count, entityMetadataCollection.Count);
   Console.WriteLine("{0} Option Labels cached", _optionLabelList.Count);
  }
  else
  { Console.WriteLine("No option labels were added to the cache."); }

 }
}

   ...

protected void removeOptionLabelsFromCache(DeletedMetadataCollection DeletedMetadata, Boolean showChanges)
{
 List<OptionSetOption> optionSetOptionsToRemove = new List<OptionSetOption>();

 if (DeletedMetadata.Keys.Contains(DeletedMetadataFilters.OptionSet))
 {
  DataCollection<Guid> optionsetmetadataids = (DataCollection<Guid>)DeletedMetadata[DeletedMetadataFilters.OptionSet];
  foreach (Guid metadataid in optionsetmetadataids)
  {
   foreach (OptionSetOption oso in _optionLabelList)
   {
    if (metadataid == oso.optionsetId)
    {
     optionSetOptionsToRemove.Add(oso);
    }
   }
  }
 }
 foreach (OptionSetOption option in optionSetOptionsToRemove)
 {
  _optionLabelList.Remove(option);
 }
 if (showChanges)
 {
  if (optionSetOptionsToRemove.Count > 0)
  {
   Console.WriteLine("{0} Option Labels removed", optionSetOptionsToRemove.Count);
   Console.WriteLine("{0} Total Option Labels currently cached", _optionLabelList.Count);
   Console.WriteLine("");
  }
  else
  {
   Console.WriteLine("No Option Labels removed.");
   Console.WriteLine("");
  }

 }
}

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveMetadataChangesResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveMetadataChangesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMetadataChangesRequest
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


RetrieveMetadataChangesResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveMetadataChangesRequest message.

The following tables list the members exposed by the RetrieveMetadataChangesResponse type.

Public Constructors

Name | Description
RetrieveMetadataChangesResponse | Initializes a new instance of the RetrieveMetadataChangesResponse class.
Top

Public Properties

 | Name | Description
public property | DeletedMetadata | Gets the deleted metadata since the last request.
public property | EntityMetadata | Gets the metadata defined by the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ServerVersionStamp | Gets a timestamp identifier for the metadata retrieved.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMetadataChangesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMetadataChangesRequest

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


RetrieveMetadataChangesResponse Constructor
[image]

Initializes a new instance of the RetrieveMetadataChangesResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMetadataChangesResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMetadataChangesResponse Class
RetrieveMetadataChangesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMetadataChangesResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMetadataChangesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMetadataChangesRequest

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


RetrieveMetadataChangesResponse Properties
[image]

Public Properties

 | Name | Description
public property | DeletedMetadata | Gets the deleted metadata since the last request.
public property | EntityMetadata | Gets the metadata defined by the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | ServerVersionStamp | Gets a timestamp identifier for the metadata retrieved.

See Also

Reference

RetrieveMetadataChangesResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMetadataChangesRequest

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


RetrieveMetadataChangesResponse.DeletedMetadata Property
[image]

Gets the deleted metadata since the last request.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property DeletedMetadata As DeletedMetadataCollection

C#
public DeletedMetadataCollection DeletedMetadata { get; }

C++

J#

JScript

Property Value
Type: DeletedMetadataCollection
The deleted metadata since the last request.

  Remarks
Deleted metadata is only returned when a valid ClientVersionStamp is included in a request.
This collection is a dictionary of GUID values using a DeletedMetadataFilters as a key. The GUID values represent MetadataId values of the metadata items.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMetadataChangesResponse Class
RetrieveMetadataChangesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMetadataChangesResponse.EntityMetadata Property
[image]

Gets the metadata defined by the request.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityMetadata As EntityMetadataCollection

C#
public EntityMetadataCollection EntityMetadata { get; }

C++

J#

JScript

Property Value
Type: EntityMetadataCollection
The metadata defined by the request.

  Remarks
This is a collection of EntityMetadata where the entities match the RetrieveMetadataChangesRequest.Query.Criteria. The properties within the entities that match the RetrieveMetadataChangesRequest.Query.Properties will contain values. Any properties that do not match the requested properties will be null.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMetadataChangesResponse Class
RetrieveMetadataChangesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMetadataChangesResponse.ServerVersionStamp Property
[image]

Gets a timestamp identifier for the metadata retrieved.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ServerVersionStamp As String

C#
public string ServerVersionStamp { get; }

C++

J#

JScript

Property Value
Type: String

A timestamp identifier for the metadata retrieved..

  Remarks
Use this as a RetrieveMetadataChangesRequest.ClientVersionStamp in a later request to retrieve just the metadata changes since the intial request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMetadataChangesResponse Class
RetrieveMetadataChangesResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMultipleRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve a collection of records that satisfy the specified query criteria.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveMultipleRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveMultipleRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
#region Retrieve records from an intersect table via QueryExpression

//Create Query Expression.
QueryExpression query = new QueryExpression()
{
    EntityName = "role",
    ColumnSet = new ColumnSet("name"),
    LinkEntities =
    {
        new LinkEntity
        {
            LinkFromEntityName = Role.EntityLogicalName,
            LinkFromAttributeName = "roleid",
            LinkToEntityName = SystemUserRoles.EntityLogicalName,
            LinkToAttributeName = "roleid",
            LinkCriteria = new FilterExpression
            {
                FilterOperator = LogicalOperator.And,
                Conditions =
                {
                    new ConditionExpression
                    {
                        AttributeName = "systemuserid",
                        Operator = ConditionOperator.Equal,
                        Values = { _userId }
                    }
                }
            }
        }
    }
};

// Obtain results from the query expression.
EntityCollection ec = _serviceProxy.RetrieveMultiple(query);

// Display results.
for (int i = 0; i < ec.Entities.Count; i++)
{
    Console.WriteLine("Query Expression Retrieved: {0}", ((Role)ec.Entities[i]).Name);
}

#endregion

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline. However, a few entities of this message class are exceptions to that availability. To determine which entities have a more restricted availability, see Supported Entities later in this topic.
Usage
Pass an instance of this class to the Execute method, which returns an instance of the RetrieveMultipleResponse class.
Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entities in the Query property and read access rights on the records that are returned from the query. For a list of the required privileges, see RetrieveMultiple Privileges.
Notes for Callers
This message supports queries that use Query Expression and FetchXML. For more information, see Creating Queries to Retrieve Data. You can also use the RetrieveMultiple method.
The collection of returned records from this message contains only the records for which the caller has read access. The returned records contain values for specified properties in the ColumnSet parameter that are valid for retrieval and for which the calling user has access rights. Any other property values are not returned. For more information about field security, see How Field Security Can Be Used to Control Access to Field Values In CRM.
Supported Entities
You can use this method to retrieve any records for entities that support the RetrieveMultiple message, including custom entities.

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
AccountLeads | 2 (Both)
ActivityMimeAttachment | 2 (Both)
ActivityParty | 2 (Both)
ActivityPointer | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
AttributeMap | 2 (Both)
Audit | 2 (Both)
BulkDeleteFailure | 2 (Both)
BulkDeleteOperation | 2 (Both)
BulkOperation | 2 (Both)
BulkOperationLog | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignActivityItem | 2 (Both)
CampaignItem | 2 (Both)
CampaignResponse | 2 (Both)
ColumnMapping | 2 (Both)
Competitor | 2 (Both)
CompetitorProduct | 2 (Both)
CompetitorSalesLiterature | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConnectionRoleAssociation | 2 (Both)
ConnectionRoleObjectTypeCode | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
ContactInvoices | 2 (Both)
ContactLeads | 2 (Both)
ContactOrders | 2 (Both)
ContactQuotes | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Dependency | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DisplayString | 2 (Both)
DuplicateRecord | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementContacts | 2 (Both)
EntitlementProducts | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
EntitlementTemplateProducts | 2 (Both)
EntityMap | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
HierarchySecurityConfiguration | 2 (Both)
Import | 2 (Both)
ImportEntityMapping | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportLog | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
InvalidDependency | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
LeadAddress | 2 (Both)
LeadCompetitors | 2 (Both)
LeadProduct | 2 (Both)
Letter | 2 (Both)
License | 2 (Both)
List | 2 (Both)
ListMember | 2 (Both)
LookUpMapping | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityCompetitors | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
Organization | 2 (Both)
OrganizationUI | 2 (Both)
OwnerMapping | 2 (Both)
PhoneCall | 2 (Both)
PickListMapping | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
PluginTypeStatistic | 2 (Both)
Position | 2 (Both)
Post | 2 (Both)
PostComment | 2 (Both)
PostFollow | 2 (Both)
PostLike | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
Privilege | 2 (Both)
ProcessSession | 2 (Both)
ProcessStage | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSalesLiterature | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
QueueMembership | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportLink | 2 (Both)
ReportVisibility | 2 (Both)
Resource | 2 (Both)
ResourceGroup | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RolePrivileges | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessage | 2 (Both)
SdkMessageFilter | 2 (Both)
SdkMessagePair | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SdkMessageRequest | 2 (Both)
SdkMessageRequestField | 2 (Both)
SdkMessageResponse | 2 (Both)
SdkMessageResponseField | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceContractContacts | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointData | 2 (Both)
SharePointDocument | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SiteMap | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
SolutionComponent | 2 (Both)
Subject | 2 (Both)
SubscriptionTrackingDeletedObject | 2 (Both)
SystemForm | 2 (Both)
SystemUser | 2 (Both)
SystemUserLicenses | 2 (Both)
SystemUserProfiles | 2 (Both)
SystemUserRoles | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamMembership | 2 (Both)
TeamProfiles | 2 (Both)
TeamRoles | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TimeZoneDefinition | 2 (Both)
TimeZoneLocalizedName | 2 (Both)
TimeZoneRule | 2 (Both)
TraceLog | 2 (Both)
TransactionCurrency | 2 (Both)
TransformationMapping | 2 (Both)
TransformationParameterMapping | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
UserSettings | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveMultipleRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveMultipleRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMultipleResponse
Other Resources
Create Queries to Retrieve Data
Build Queries with QueryExpression
Build Queries with FetchXML
Retrieve Records for Many-To-Many Relationships using Intersect Entities
Sample: Retrieve Records from an Intersect Table


RetrieveMultipleRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a collection of records that satisfy the specified query criteria.

The following tables list the members exposed by the RetrieveMultipleRequest type.

Public Constructors

Name | Description
RetrieveMultipleRequest | Initializes a new instance of the RetrieveMultipleRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query criteria for the retrieval. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMultipleRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMultipleResponse

Other Resources

Create Queries to Retrieve Data
Build Queries with QueryExpression
Build Queries with FetchXML
Retrieve Records for Many-To-Many Relationships using Intersect Entities
Sample: Retrieve Records from an Intersect Table


RetrieveMultipleRequest Constructor
[image]

Initializes a new instance of the RetrieveMultipleRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMultipleRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMultipleRequest Class
RetrieveMultipleRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMultipleRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMultipleRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMultipleResponse

Other Resources

Create Queries to Retrieve Data
Build Queries with QueryExpression
Build Queries with FetchXML
Retrieve Records for Many-To-Many Relationships using Intersect Entities
Sample: Retrieve Records from an Intersect Table


RetrieveMultipleRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Query | Gets or sets the query criteria for the retrieval. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveMultipleRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMultipleResponse

Other Resources

Create Queries to Retrieve Data
Build Queries with QueryExpression
Build Queries with FetchXML
Retrieve Records for Many-To-Many Relationships using Intersect Entities
Sample: Retrieve Records from an Intersect Table


RetrieveMultipleRequest.Query Property
[image]

Gets or sets the query criteria for the retrieval. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Query As QueryBase

C#
public QueryBase Query { get; set; }

C++

J#

JScript

Property Value
Type: QueryBase
The query criteria for the retrieval.

  Remarks
Assign an instance of the FetchExpression, QueryExpression, or QueryByAttribute class. The query must specify entity names and a column set. If the column set includes attributes where IsValidForRead is false, they are ignored, and the message response contains no data for those attributes. You can find this information in the metadata for your organization. See the preceding metadata browser information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMultipleRequest Class
RetrieveMultipleRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMultipleResponse Class
See Also Members
[image]

Contains the response from the RetrieveMultipleRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveMultipleResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveMultipleResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveMultipleResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMultipleResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMultipleRequest
RetrieveMultiple


RetrieveMultipleResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveMultipleRequest class.

The following tables list the members exposed by the RetrieveMultipleResponse type.

Public Constructors

Name | Description
RetrieveMultipleResponse | Initializes a new instance of the RetrieveMultipleResponse class.
Top

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of records that satisfy the query in the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveMultipleResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMultipleRequest
RetrieveMultiple


RetrieveMultipleResponse Constructor
[image]

Initializes a new instance of the RetrieveMultipleResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveMultipleResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMultipleResponse Class
RetrieveMultipleResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveMultipleResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveMultipleResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMultipleRequest
RetrieveMultiple


RetrieveMultipleResponse Properties
[image]

Public Properties

 | Name | Description
public property | EntityCollection | Gets the collection of records that satisfy the query in the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveMultipleResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveMultipleRequest
RetrieveMultiple


RetrieveMultipleResponse.EntityCollection Property
[image]

Gets the collection of records that satisfy the query in the request.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityCollection As EntityCollection

C#
public EntityCollection EntityCollection { get; }

C++

J#

JScript

Property Value
Type: EntityCollection
The collection of records that satisfy the query in the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveMultipleResponse Class
RetrieveMultipleResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveOptionSetRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve a global option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveOptionSetRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveOptionSetRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Use the RetrieveOptionSetRequest message to retrieve
// a global option set by it's name.
RetrieveOptionSetRequest retrieveOptionSetRequest =
    new RetrieveOptionSetRequest
    {
        Name = _globalOptionSetName
    };

// Execute the request.
RetrieveOptionSetResponse retrieveOptionSetResponse =
    (RetrieveOptionSetResponse)_serviceProxy.Execute(
    retrieveOptionSetRequest);

Console.WriteLine("Retrieved {0}.",
    retrieveOptionSetRequest.Name);

// Access the retrieved OptionSetMetadata.
OptionSetMetadata retrievedOptionSetMetadata =
    (OptionSetMetadata)retrieveOptionSetResponse.OptionSetMetadata;

// Get the current options list for the retrieved attribute.
OptionMetadata[] optionList =
    retrievedOptionSetMetadata.Options.ToArray();

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveOptionSetResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveOptionSet Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveOptionSetRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Global Option Sets
Customize Global Option Sets in Microsoft Dynamics CRM


RetrieveOptionSetRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a global option set.

The following tables list the members exposed by the RetrieveOptionSetRequest type.

Public Constructors

Name | Description
RetrieveOptionSetRequest | Initializes a new instance of the RetrieveOptionSetRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MetadataId | Gets or sets the MetadataId of the OptionSetMetadata to be retrieved. Optional.
public property | Name | Gets or sets the name for the global option set to be retrieved. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Customize Global Option Sets in Microsoft Dynamics CRM


RetrieveOptionSetRequest Constructor
[image]

Initializes a new instance of the RetrieveOptionSetRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveOptionSetRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOptionSetRequest Class
RetrieveOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveOptionSetRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Customize Global Option Sets in Microsoft Dynamics CRM


RetrieveOptionSetRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MetadataId | Gets or sets the MetadataId of the OptionSetMetadata to be retrieved. Optional.
public property | Name | Gets or sets the name for the global option set to be retrieved. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.

See Also

Reference

RetrieveOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Customize Global Option Sets in Microsoft Dynamics CRM


RetrieveOptionSetRequest.MetadataId Property
[image]

Gets or sets the MetadataId of the OptionSetMetadata to be retrieved. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MetadataId As Guid

C#
public Guid MetadataId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The MetadataId of the  OptionSetMetadata to be retrieved. Optional.

  Remarks
If the MetadataId is not set the Name muuust be set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOptionSetRequest Class
RetrieveOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveOptionSetRequest.Name Property
[image]

Gets or sets the name for the global option set to be retrieved. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Name As String

C#
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String The name for the global option set to be retrieved.. Optional..

  Remarks
If the Name is not set the MetadataId must be set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOptionSetRequest Class
RetrieveOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveOptionSetRequest.RetrieveAsIfPublished Property
[image]

Gets or sets whether to retrieve the metadata that has not been published. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RetrieveAsIfPublished As Boolean

C#
public bool RetrieveAsIfPublished { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the the unpublished metadata should be retrieved; otherwise, false..

  Remarks
If you are creating a global option set editor you will need to retrieve data that has been saved but not published. For other scenarios you will want to only retrieve published metadata.
  • Set this value to true to include unpublished changes, as it would look if you called publish.
  • Set this value to false to include only the currently published changes, ignoring the changes that haven't yet been published.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOptionSetRequest Class
RetrieveOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveOptionSetResponse Class
See Also Members
[image]

Contains the response from the RetrieveOptionSetRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveOptionSetResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveOptionSetResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveOptionSetResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveOptionSetRequest


RetrieveOptionSetResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveOptionSetRequest class.

The following tables list the members exposed by the RetrieveOptionSetResponse type.

Public Constructors

Name | Description
RetrieveOptionSetResponse | Initializes a new instance of the RetrieveOptionSetResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OptionSetMetadata | Gets the metadata for the global option set.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveOptionSetRequest


RetrieveOptionSetResponse Constructor
[image]

Initializes a new instance of the RetrieveOptionSetResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveOptionSetResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOptionSetResponse Class
RetrieveOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveOptionSetResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveOptionSetRequest


RetrieveOptionSetResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | OptionSetMetadata | Gets the metadata for the global option set.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveOptionSetRequest


RetrieveOptionSetResponse.OptionSetMetadata Property
[image]

Gets the metadata for the global option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property OptionSetMetadata As OptionSetMetadataBase

C#
public OptionSetMetadataBase OptionSetMetadata { get; }

C++

J#

JScript

Property Value
Type: OptionSetMetadataBase
 The metadata for the global option set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveOptionSetResponse Class
RetrieveOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRelationshipRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve entity relationship metadata.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveRelationshipRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveRelationshipRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

//You can use either the Name or the MetadataId of the relationship.

//Retrieve the One-to-many relationship using the MetadataId.
RetrieveRelationshipRequest retrieveOneToManyRequest =
    new RetrieveRelationshipRequest { MetadataId = _oneToManyRelationshipId };
RetrieveRelationshipResponse retrieveOneToManyResponse =
    (RetrieveRelationshipResponse)_serviceProxy.Execute(retrieveOneToManyRequest);

Console.WriteLine("Retrieved {0} One-to-many relationship by id", retrieveOneToManyResponse.RelationshipMetadata.SchemaName);

//Retrieve the Many-to-many relationship using the Name.
RetrieveRelationshipRequest retrieveManyToManyRequest =
    new RetrieveRelationshipRequest { Name = _manyToManyRelationshipName};
RetrieveRelationshipResponse retrieveManyToManyResponse =
    (RetrieveRelationshipResponse)_serviceProxy.Execute(retrieveManyToManyRequest);

Console.WriteLine("Retrieved {0} Many-to-Many relationship by Name", retrieveManyToManyResponse.RelationshipMetadata.MetadataId);

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute  method, which returns an instance of  RetrieveRelationshipResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveRelationship Privileges.
Notes for Callers
You can use either the Name or the MetadataId of the relationship.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveRelationshipRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
RetrieveRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Create Entity Relationships
Customize Entity Relationship Metadata


RetrieveRelationshipRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve entity relationship metadata.

The following tables list the members exposed by the RetrieveRelationshipRequest type.

Public Constructors

Name | Description
RetrieveRelationshipRequest | Initializes a new instance of the RetrieveRelationshipRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MetadataId | Gets or sets the MetadataId of the RelationshipMetadataBase to be retrieved. Optional.
public property | Name | Gets or sets the unique name for the entity relationship to be retrieved. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRelationshipRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create Entity Relationships
Customize Entity Relationship Metadata


RetrieveRelationshipRequest Constructor
[image]

Initializes a new instance of the RetrieveRelationshipRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRelationshipRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRelationshipRequest Class
RetrieveRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRelationshipRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRelationshipRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create Entity Relationships
Customize Entity Relationship Metadata


RetrieveRelationshipRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MetadataId | Gets or sets the MetadataId of the RelationshipMetadataBase to be retrieved. Optional.
public property | Name | Gets or sets the unique name for the entity relationship to be retrieved. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RetrieveAsIfPublished | Gets or sets whether to retrieve the metadata that has not been published. Required.

See Also

Reference

RetrieveRelationshipRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create Entity Relationships
Customize Entity Relationship Metadata


RetrieveRelationshipRequest.MetadataId Property
[image]

Gets or sets the MetadataId of the RelationshipMetadataBase to be retrieved. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MetadataId As Guid

C#
public Guid MetadataId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
 The MetadataId of the RelationshipMetadataBase to be retrieved. Optional.

  Remarks
If the MetadataId is not set the Name must be set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRelationshipRequest Class
RetrieveRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRelationshipRequest.Name Property
[image]

Gets or sets the unique name for the entity relationship to be retrieved. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Name As String

C#
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name for the entity relationship to be retrieved. Optional..

  Remarks
If the Name is not set the MetadataId must be set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRelationshipRequest Class
RetrieveRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRelationshipRequest.RetrieveAsIfPublished Property
[image]

Gets or sets whether to retrieve the metadata that has not been published. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RetrieveAsIfPublished As Boolean

C#
public bool RetrieveAsIfPublished { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the unpublished metadata should be retrieved; otherwise, false.

  Remarks
If you are creating an entity relationship editor, you will need to retrieve data that has been saved but not published. For other scenarios, you will want to only retrieve published metadata.
  • Set this value to true to include unpublished changes.
  • Set this value to false to include only the currently published changes, ignoring the changes that have not yet been published.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRelationshipRequest Class
RetrieveRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRelationshipResponse Class
See Also Members
[image]

Contains the response from the RetrieveRelationshipRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveRelationshipResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveRelationshipResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveRelationshipResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRelationshipResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveRelationshipRequest


RetrieveRelationshipResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveRelationshipRequest class.

The following tables list the members exposed by the RetrieveRelationshipResponse type.

Public Constructors

Name | Description
RetrieveRelationshipResponse | Initializes a new instance of the RetrieveRelationshipResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | RelationshipMetadata | Gets the metadata for the entity relationship.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRelationshipResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveRelationshipRequest


RetrieveRelationshipResponse Constructor
[image]

Initializes a new instance of the RetrieveRelationshipResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRelationshipResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRelationshipResponse Class
RetrieveRelationshipResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRelationshipResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRelationshipResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveRelationshipRequest


RetrieveRelationshipResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | RelationshipMetadata | Gets the metadata for the entity relationship.
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveRelationshipResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveRelationshipRequest


RetrieveRelationshipResponse.RelationshipMetadata Property
[image]

Gets the metadata for the entity relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property RelationshipMetadata As RelationshipMetadataBase

C#
public RelationshipMetadataBase RelationshipMetadata { get; }

C++

J#

JScript

Property Value
Type: RelationshipMetadataBase
The metadata for the entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRelationshipResponse Class
RetrieveRelationshipResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRequest Class
See Also Example Members
[image]

Contains the data that is needed to retrieve a record.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline. However, a few entities of this message class are exceptions to that availability. To determine which entities have a more restricted availability, see Supported Entities later in this topic.
Usage
Pass an instance of this class to the Execute method, which returns an instance of the RetrieveResponse class.
Privileges and Access Rights
To perform this action, the caller must have access rights on the specified records in the Target property. For a list of the required privileges, see Retrieve Privileges.
Notes for Callers
The returned record contains the values for the properties that are specified in the ColumnSet property for which the calling user has access rights. No other property values are returned. For more information about field security, see How Field Security Can Be Used to Control Access to Field Values In CRM.
Supported Entities
You can use this method to retrieve any records for entities (includes custom entities) that support the Retrieve message.

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
ActivityMimeAttachment | 2 (Both)
ActivityPointer | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
AttributeMap | 2 (Both)
Audit | 2 (Both)
BulkDeleteFailure | 2 (Both)
BulkDeleteOperation | 2 (Both)
BulkOperation | 2 (Both)
BulkOperationLog | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
ColumnMapping | 2 (Both)
Competitor | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConnectionRoleObjectTypeCode | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Dependency | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DisplayString | 2 (Both)
DuplicateRecord | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
EntityMap | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
Import | 2 (Both)
ImportEntityMapping | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportLog | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
InvalidDependency | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
LeadAddress | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
LookUpMapping | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
Organization | 2 (Both)
OrganizationUI | 2 (Both)
OwnerMapping | 2 (Both)
PhoneCall | 2 (Both)
PickListMapping | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
PluginTypeStatistic | 2 (Both)
Position | 2 (Both)
Post | 2 (Both)
PostComment | 2 (Both)
PostFollow | 2 (Both)
PostLike | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
Privilege | 2 (Both)
ProcessSession | 2 (Both)
ProcessStage | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportLink | 2 (Both)
ReportVisibility | 2 (Both)
Resource | 2 (Both)
ResourceGroup | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessage | 2 (Both)
SdkMessageFilter | 2 (Both)
SdkMessagePair | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SdkMessageRequest | 2 (Both)
SdkMessageRequestField | 2 (Both)
SdkMessageResponse | 2 (Both)
SdkMessageResponseField | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointData | 2 (Both)
SharePointDocument | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SiteMap | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
SolutionComponent | 2 (Both)
Subject | 2 (Both)
SystemForm | 2 (Both)
SystemUser | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TimeZoneDefinition | 2 (Both)
TimeZoneLocalizedName | 2 (Both)
TimeZoneRule | 2 (Both)
TraceLog | 2 (Both)
TransactionCurrency | 2 (Both)
TransformationMapping | 2 (Both)
TransformationParameterMapping | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
UserSettings | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveResponse
Other Resources
Build Queries with QueryExpression
Build Queries with FetchXML
Sample: Update Next Birthday Using a Custom Workflow Activity
Retrieve Privileges


RetrieveRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieve a record.

The following tables list the members exposed by the RetrieveRequest type.

Public Constructors

Name | Description
RetrieveRequest | Initializes a new instance of the RetrieveRequest class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes for which non-null values are returned from a query. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelatedEntitiesQuery | Gets or sets the query that describes the related records to be retrieved. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target, which is the record to be retrieved. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveResponse

Other Resources

Build Queries with QueryExpression
Build Queries with FetchXML
Sample: Update Next Birthday Using a Custom Workflow Activity
Retrieve Privileges


RetrieveRequest Constructor
[image]

Initializes a new instance of the RetrieveRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequest Class
RetrieveRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveResponse

Other Resources

Build Queries with QueryExpression
Build Queries with FetchXML
Sample: Update Next Birthday Using a Custom Workflow Activity
Retrieve Privileges


RetrieveRequest Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the collection of attributes for which non-null values are returned from a query. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RelatedEntitiesQuery | Gets or sets the query that describes the related records to be retrieved. Optional.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets the target, which is the record to be retrieved. Required.

See Also

Reference

RetrieveRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveResponse

Other Resources

Build Queries with QueryExpression
Build Queries with FetchXML
Sample: Update Next Birthday Using a Custom Workflow Activity
Retrieve Privileges


RetrieveRequest.ColumnSet Property
[image]

Gets or sets the collection of attributes for which non-null values are returned from a query. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ColumnSet As ColumnSet

C#
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The collection of attributes for which non-null values are returned from a query.

  Remarks
Assign null to this property to retrieve only the primary key. The query returns non-null values for the specified attributes in the column set. The attributes that are not included in the column set contain null values. If the column set includes attributes where IsValidForRead is false, they are ignored and the message response contains no data for those attributes. You can find this information in the metadata for your organization. See the preceding metadata browser information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequest Class
RetrieveRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRequest.RelatedEntitiesQuery Property
[image]

Gets or sets the query that describes the related records to be retrieved. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RelatedEntitiesQuery As RelationshipQueryCollection

C#
public RelationshipQueryCollection RelatedEntitiesQuery { get; set; }

C++

J#

JScript

Property Value
Type: RelationshipQueryCollection
The query that describes the related records to be retrieved.

  Remarks
This property value is a collection of link-entity/query pairs. For each relationship between the Target entity and another entity, you can specify a query for the records that are related to the Target record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequest Class
RetrieveRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveRequest.Target Property
[image]

Gets or sets the target, which is the record to be retrieved. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As EntityReference

C#
public EntityReference Target { get; set; }

C++

J#

JScript

Property Value
Type: EntityReference
The target, which is the record to be retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveRequest Class
RetrieveRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveResponse Class
See Also Members
[image]

Contains the response from the RetrieveRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveRequest
Retrieve


RetrieveResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveRequest class.

The following tables list the members exposed by the RetrieveResponse type.

Public Constructors

Name | Description
RetrieveResponse | Initializes a new instance of the RetrieveResponse class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the specified record from the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveRequest
Retrieve


RetrieveResponse Constructor
[image]

Initializes a new instance of the RetrieveResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveResponse Class
RetrieveResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveRequest
Retrieve


RetrieveResponse Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the specified record from the request.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

RetrieveResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveRequest
Retrieve


RetrieveResponse.Entity Property
[image]

Gets the specified record from the request.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Entity As Entity

C#
public Entity Entity { get; }

C++

J#

JScript

Property Value
Type: Entity
The specified record from the request.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveResponse Class
RetrieveResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveTimestampRequest Class
See Also Members
[image]

Contains the data that is needed to retrieves a time stamp for the metadata.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveTimestampRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveTimestampRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  RetrieveTimestampResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in RetrieveTimestamp Privileges.
Notes for Callers
Execute this message before you retrieve metadata. You can repeat this process later to see if the metadata has changed in the intervening time. If the value is the same, the metadata has not changed. If the value is different, you retrieve the metadata again to get the updated values.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.RetrieveTimestampRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTimestampRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Extend the Metadata Model for Microsoft Dynamics CRM


RetrieveTimestampRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to retrieves a time stamp for the metadata.

The following tables list the members exposed by the RetrieveTimestampRequest type.

Public Constructors

Name | Description
RetrieveTimestampRequest | Initializes a new instance of the RetrieveTimestampRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveTimestampRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Extend the Metadata Model for Microsoft Dynamics CRM


RetrieveTimestampRequest Constructor
[image]

Initializes a new instance of the RetrieveTimestampRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveTimestampRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTimestampRequest Class
RetrieveTimestampRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveTimestampRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveTimestampRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Extend the Metadata Model for Microsoft Dynamics CRM


RetrieveTimestampRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

RetrieveTimestampRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Extend the Metadata Model for Microsoft Dynamics CRM


RetrieveTimestampResponse Class
See Also Members
[image]

Contains the response from the RetrieveTimestampRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class RetrieveTimestampResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class RetrieveTimestampResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.RetrieveTimestampResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTimestampResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveTimestampRequest


RetrieveTimestampResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the RetrieveTimestampRequest class.

The following tables list the members exposed by the RetrieveTimestampResponse type.

Public Constructors

Name | Description
RetrieveTimestampResponse | Initializes a new instance of the RetrieveTimestampResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Timestamp | Gets the time stamp of the metadata.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveTimestampResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveTimestampRequest


RetrieveTimestampResponse Constructor
[image]

Initializes a new instance of the RetrieveTimestampResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveTimestampResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTimestampResponse Class
RetrieveTimestampResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


RetrieveTimestampResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveTimestampResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveTimestampRequest


RetrieveTimestampResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
public property | Timestamp | Gets the time stamp of the metadata.

See Also

Reference

RetrieveTimestampResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
RetrieveTimestampRequest


RetrieveTimestampResponse.Timestamp Property
[image]

Gets the time stamp of the metadata.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Timestamp As String

C#
public string Timestamp { get; }

C++

J#

JScript

Property Value
Type: String
The time stamp of the metadata.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveTimestampResponse Class
RetrieveTimestampResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


SetDataEncryptionKeyRequest Class
See Also Members
[image]

Contains the data that is needed to set or restore the data encryption key.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class SetDataEncryptionKeyRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class SetDataEncryptionKeyRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Usage
Pass an instance of this class to the Execute   method, which returns an instance of SetDataEncryptionKeyResponse.
Privileges and Access Rights
To perform this action, the caller must have privileges listed in SetDataEncryptionKey message privileges.
Notes for Callers
None

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.SetDataEncryptionKeyRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetDataEncryptionKeyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
SetDataEncryptionKeyResponse
Other Resources
Field Level Data Encryption


SetDataEncryptionKeyRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to set or restore the data encryption key.

The following tables list the members exposed by the SetDataEncryptionKeyRequest type.

Public Constructors

Name | Description
SetDataEncryptionKeyRequest | Initializes a new instance of the SetDataEncryptionKeyRequest class.
Top

Public Properties

 | Name | Description
public property | ChangeEncryptionKey | Gets or sets the operation to perform with the data encryption key.
public property | EncryptionKey | Gets or sets the value of the data encryption key.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetDataEncryptionKeyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
SetDataEncryptionKeyResponse

Other Resources

Field Level Data Encryption


SetDataEncryptionKeyRequest Constructor
[image]

Initializes a new instance of the SetDataEncryptionKeyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetDataEncryptionKeyRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetDataEncryptionKeyRequest Class
SetDataEncryptionKeyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


SetDataEncryptionKeyRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetDataEncryptionKeyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
SetDataEncryptionKeyResponse

Other Resources

Field Level Data Encryption


SetDataEncryptionKeyRequest Properties
[image]

Public Properties

 | Name | Description
public property | ChangeEncryptionKey | Gets or sets the operation to perform with the data encryption key.
public property | EncryptionKey | Gets or sets the value of the data encryption key.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)

See Also

Reference

SetDataEncryptionKeyRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
SetDataEncryptionKeyResponse

Other Resources

Field Level Data Encryption


SetDataEncryptionKeyRequest.ChangeEncryptionKey Property
[image]

Gets or sets the operation to perform with the data encryption key.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ChangeEncryptionKey As Boolean

C#
public bool ChangeEncryptionKey { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true indicates to set (change) the data encryption key; otherwise, false indicates to restore the data encryption key.

  Remarks
When performing a restore, the new key is saved in the MS_CONFIG database. When performing a change, all fields that were encrypted using the old key are first decrypted, and then encrypted using the new key. The new key is then stored in the MS_CONFIG database.
No more than one SetDataEncryptionKeyRequest can be processed at a time for an organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetDataEncryptionKeyRequest Class
SetDataEncryptionKeyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


SetDataEncryptionKeyRequest.EncryptionKey Property
[image]

Gets or sets the value of the data encryption key.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EncryptionKey As String

C#
public string EncryptionKey { get; set; }

C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetDataEncryptionKeyRequest Class
SetDataEncryptionKeyRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


SetDataEncryptionKeyResponse Class
See Also Members
[image]

Contains the response from the SetDataEncryptionKeyRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class SetDataEncryptionKeyResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class SetDataEncryptionKeyResponse : OrganizationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.SetDataEncryptionKeyResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetDataEncryptionKeyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
SetDataEncryptionKeyRequest
Other Resources
Field Level Data Encryption


SetDataEncryptionKeyResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the SetDataEncryptionKeyRequest class.

The following tables list the members exposed by the SetDataEncryptionKeyResponse type.

Public Constructors

Name | Description
SetDataEncryptionKeyResponse | Initializes a new instance of the SetDataEncryptionKeyResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetDataEncryptionKeyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
SetDataEncryptionKeyRequest

Other Resources

Field Level Data Encryption


SetDataEncryptionKeyResponse Constructor
[image]

Initializes a new instance of the SetDataEncryptionKeyResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetDataEncryptionKeyResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetDataEncryptionKeyResponse Class
SetDataEncryptionKeyResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


SetDataEncryptionKeyResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetDataEncryptionKeyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
SetDataEncryptionKeyRequest

Other Resources

Field Level Data Encryption


SetDataEncryptionKeyResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

SetDataEncryptionKeyResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
SetDataEncryptionKeyRequest

Other Resources

Field Level Data Encryption


UpdateAttributeRequest Class
See Also Example Members
[image]

Contains the data that is needed to update the definition of an attribute.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateAttributeRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateAttributeRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Modify the retrieved attribute
AttributeMetadata retrievedAttributeMetadata =
    attributeResponse.AttributeMetadata;
retrievedAttributeMetadata.DisplayName =
    new Label("Update String Attribute", _languageCode);

// Update an attribute retrieved via RetrieveAttributeRequest
UpdateAttributeRequest updateRequest = new UpdateAttributeRequest
{
    Attribute = retrievedAttributeMetadata,
    EntityName = Contact.EntityLogicalName,
    MergeLabels = false
};

// Execute the request
_serviceProxy.Execute(updateRequest);

Console.WriteLine("Updated the attribute {0}.",
    retrievedAttributeMetadata.SchemaName);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  UpdateAttributeResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in UpdateAttribute Privileges.
Notes for Callers
You must publish the changes to the metadata before this change will be visible in the application. For more information, see Publish Customizations

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.UpdateAttributeRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
UpdateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Attributes
Customize Entity Attribute Metadata
Extend the Metadata Model for Microsoft Dynamics CRM


UpdateAttributeRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update the definition of an attribute.

The following tables list the members exposed by the UpdateAttributeRequest type.

Public Constructors

Name | Description
UpdateAttributeRequest | Initializes a new instance of the UpdateAttributeRequest class
Top

Public Properties

 | Name | Description
public property | Attribute | Gets or sets the attribute metadata to be updated. Required.
public property | EntityName | Gets or sets the logical name of the entity to which the attribute belongs. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MergeLabels | Gets or sets whether the label metadata will be merged or overwritten. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the solution to associate the entity with. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata
Extend the Metadata Model for Microsoft Dynamics CRM


UpdateAttributeRequest Constructor
[image]

Initializes a new instance of the UpdateAttributeRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateAttributeRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateAttributeRequest Class
UpdateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateAttributeRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata
Extend the Metadata Model for Microsoft Dynamics CRM


UpdateAttributeRequest Properties
[image]

Public Properties

 | Name | Description
public property | Attribute | Gets or sets the attribute metadata to be updated. Required.
public property | EntityName | Gets or sets the logical name of the entity to which the attribute belongs. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MergeLabels | Gets or sets whether the label metadata will be merged or overwritten. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the solution to associate the entity with. Optional.

See Also

Reference

UpdateAttributeRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Attributes
Customize Entity Attribute Metadata
Extend the Metadata Model for Microsoft Dynamics CRM


UpdateAttributeRequest.Attribute Property
[image]

Gets or sets the attribute metadata to be updated. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Attribute As AttributeMetadata

C#
public AttributeMetadata Attribute { get; set; }

C++

J#

JScript

Property Value
Type: AttributeMetadata
The attribute metadata to be updated. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateAttributeRequest Class
UpdateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateAttributeRequest.EntityName Property
[image]

Gets or sets the logical name of the entity to which the attribute belongs. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity to which the attribute belongs. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateAttributeRequest Class
UpdateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateAttributeRequest.MergeLabels Property
[image]

Gets or sets whether the label metadata will be merged or overwritten. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MergeLabels As Boolean

C#
public bool MergeLabels { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the label metadata will be merged or overwritten; otherwise, false.

  Remarks
A Label is a collection of localized labels, each containing a string and a language code. If a label for an item already has labels for other languages and you update it with a label that contains only one label for a specific language the MergeLabels parameter provides the option to overwrite the existing labels or merge your new label with any existing language labels. With MergeLabels set to true, any new labels defined will only overwrite existing labels when the languagecode matches.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateAttributeRequest Class
UpdateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateAttributeRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the solution to associate the entity with. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the solution to associate the entity with. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateAttributeRequest Class
UpdateAttributeRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateAttributeResponse Class
See Also Members
[image]

Contains the response from the UpdateAttributeRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateAttributeResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateAttributeResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.UpdateAttributeResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
UpdateAttributeRequest


UpdateAttributeResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UpdateAttributeRequest class.

The following tables list the members exposed by the UpdateAttributeResponse type.

Public Constructors

Name | Description
UpdateAttributeResponse | Initializes a new instance of the UpdateAttributeResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateAttributeRequest


UpdateAttributeResponse Constructor
[image]

Initializes a new instance of the UpdateAttributeResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateAttributeResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateAttributeResponse Class
UpdateAttributeResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateAttributeResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateAttributeRequest


UpdateAttributeResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UpdateAttributeResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateAttributeRequest


UpdateEntityRequest Class
See Also Example Members
[image]

Contains the data that is needed to update the definition of an entity.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateEntityRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateEntityRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
EntityMetadata BankAccountEntity = retrieveBankAccountEntityResponse.EntityMetadata;

// Disable Mail merge
BankAccountEntity.IsMailMergeEnabled = new BooleanManagedProperty(false);
// Enable Notes
UpdateEntityRequest updateBankAccountRequest = new UpdateEntityRequest
{
 Entity = BankAccountEntity,
 HasNotes = true
};

_serviceProxy.Execute(updateBankAccountRequest);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  UpdateEntityResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in UpdateEntity Privileges.
Notes for Callers
You must publish the changes to the metadata before this change will be visible in the application. For more information, see Publish Customizations

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.UpdateEntityRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
UpdateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Create and Update Entity Metadata
Retrieve, Update and Delete Entities
Customize Entity Metadata


UpdateEntityRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update the definition of an entity.

The following tables list the members exposed by the UpdateEntityRequest type.

Public Constructors

Name | Description
UpdateEntityRequest | Initializes a new instance of the UpdateEntityRequest class
Top

Public Properties

 | Name | Description
public property | Entity | Gets or sets the metadata for the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | HasActivities | Gets or sets whether the entity will have a special relationship to activity entities and is a valid regarding object for the activity. Optional.
public property | HasNotes | Gets or sets whether the entity will have a special relationship to the annotation entity. Optional.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MergeLabels | Gets or sets whether to merge the new labels with any existing labels. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the unique name of the unmanaged solution that this entity should be associated with. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create and Update Entity Metadata
Retrieve, Update and Delete Entities
Customize Entity Metadata


UpdateEntityRequest Constructor
[image]

Initializes a new instance of the UpdateEntityRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateEntityRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntityRequest Class
UpdateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateEntityRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create and Update Entity Metadata
Retrieve, Update and Delete Entities
Customize Entity Metadata


UpdateEntityRequest Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets or sets the metadata for the entity. Required.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | HasActivities | Gets or sets whether the entity will have a special relationship to activity entities and is a valid regarding object for the activity. Optional.
public property | HasNotes | Gets or sets whether the entity will have a special relationship to the annotation entity. Optional.
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MergeLabels | Gets or sets whether to merge the new labels with any existing labels. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the unique name of the unmanaged solution that this entity should be associated with. Optional.

See Also

Reference

UpdateEntityRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Create and Update Entity Metadata
Retrieve, Update and Delete Entities
Customize Entity Metadata


UpdateEntityRequest.Entity Property
[image]

Gets or sets the metadata for the entity. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Entity As EntityMetadata

C#
public EntityMetadata Entity { get; set; }

C++

J#

JScript

Property Value
Type: EntityMetadata
the metadata for the entity. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntityRequest Class
UpdateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateEntityRequest.HasActivities Property
[image]

Gets or sets whether the entity will have a special relationship to activity entities and is a valid regarding object for the activity. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HasActivities As Nullable(Of Boolean)

C#
public Nullable<bool> HasActivities { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity will have a special relationship to activity entities and is a valid regarding object for the activity; otherwise, false.

  Remarks
This capability can only be enabled once. After it is enabled it cannot be disabled.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntityRequest Class
UpdateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateEntityRequest.HasNotes Property
[image]

Gets or sets whether the entity will have a special relationship to the annotation entity. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HasNotes As Nullable(Of Boolean)

C#
public Nullable<bool> HasNotes { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity will have a special relationship to the annotation entity; otherwise, false.

  Remarks
This capability can only be enabled once. After it is enabled it cannot be disabled.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntityRequest Class
UpdateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateEntityRequest.MergeLabels Property
[image]

Gets or sets whether to merge the new labels with any existing labels. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MergeLabels As Boolean

C#
public bool MergeLabels { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the new labels should be merged with any existing labels; otherwise, false.

  Remarks
A Label is a collection of localized labels, each containing a string and a language code. If a label for an item already has labels for other languages and you update it with a label that contains only one label for a specific language the MergeLabels parameter provides the option to overwrite the existing labels or merge your new label with any existing language labels. With MergeLabels set to true, any new labels defined will only overwrite existing labels when the languagecode matches.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntityRequest Class
UpdateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateEntityRequest.SolutionUniqueName Property
[image]

Gets or sets the unique name of the unmanaged solution that this entity should be associated with. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name of the unmanaged solution that this entity should be associated with. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntityRequest Class
UpdateEntityRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateEntityResponse Class
See Also Members
[image]

Contains the response from the UpdateEntityRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateEntityResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateEntityResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.UpdateEntityResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
UpdateEntityRequest


UpdateEntityResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UpdateEntityRequest class.

The following tables list the members exposed by the UpdateEntityResponse type.

Public Constructors

Name | Description
UpdateEntityResponse | Initializes a new instance of the UpdateEntityResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateEntityRequest


UpdateEntityResponse Constructor
[image]

Initializes a new instance of the UpdateEntityResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateEntityResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntityResponse Class
UpdateEntityResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateEntityResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateEntityRequest


UpdateEntityResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UpdateEntityResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateEntityRequest


UpdateOptionSetRequest Class
See Also Example Members
[image]

Contains the data that is needed to update the definition of a global option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateOptionSetRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateOptionSetRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Use UpdateOptionSetRequest to update the basic information of an option
// set. Updating option set values requires different messages (see below).
UpdateOptionSetRequest updateOptionSetRequest = new UpdateOptionSetRequest
{
    OptionSet = new OptionSetMetadata
    {
        DisplayName = new Label("Updated Option Set", _languageCode),
        Name = _globalOptionSetName,
        IsGlobal = true
    }
};

_serviceProxy.Execute(updateOptionSetRequest);

//Publish the OptionSet
PublishXmlRequest pxReq1 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
_serviceProxy.Execute(pxReq1);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  UpdateOptionSetResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in UpdateOptionSet Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.UpdateOptionSetRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
UpdateOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Sample: Work with Global Option Sets
Update a Global Option Set
Customize Global Option Sets in Microsoft Dynamics CRM


UpdateOptionSetRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update the definition of a global option set.

The following tables list the members exposed by the UpdateOptionSetRequest type.

Public Constructors

Name | Description
UpdateOptionSetRequest | Initializes a new instance of the UpdateOptionSetRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MergeLabels | Gets or sets whether the label metadata will be merged or overwritten. Required.
public property | OptionSet | Gets or sets the metadata for the global option set. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of a solution to associate the global option set with. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Update a Global Option Set
Customize Global Option Sets in Microsoft Dynamics CRM


UpdateOptionSetRequest Constructor
[image]

Initializes a new instance of the UpdateOptionSetRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateOptionSetRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionSetRequest Class
UpdateOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionSetRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Update a Global Option Set
Customize Global Option Sets in Microsoft Dynamics CRM


UpdateOptionSetRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MergeLabels | Gets or sets whether the label metadata will be merged or overwritten. Required.
public property | OptionSet | Gets or sets the metadata for the global option set. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of a solution to associate the global option set with. Optional.

See Also

Reference

UpdateOptionSetRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Sample: Work with Global Option Sets
Update a Global Option Set
Customize Global Option Sets in Microsoft Dynamics CRM


UpdateOptionSetRequest.MergeLabels Property
[image]

Gets or sets whether the label metadata will be merged or overwritten. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MergeLabels As Boolean

C#
public bool MergeLabels { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the label metadata will be merged or overwritten; otherwise, false.

  Remarks
A Label is a collection of localized labels, each containing a string and a language code. If a label for an item already has labels for other languages and you update it with a label that contains only one label for a specific language the MergeLabels parameter provides the option to overwrite the existing labels or merge your new label with any existing language labels. With MergeLabels set to true, any new labels defined will only overwrite existing labels when the languagecode matches.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionSetRequest Class
UpdateOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionSetRequest.OptionSet Property
[image]

Gets or sets the metadata for the global option set. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OptionSet As OptionSetMetadataBase

C#
public OptionSetMetadataBase OptionSet { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetMetadataBase
the metadata for the global option set. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionSetRequest Class
UpdateOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionSetRequest.SolutionUniqueName Property
[image]

Gets or sets the name of a solution to associate the global option set with. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of a solution to associate the global option set with. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionSetRequest Class
UpdateOptionSetRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionSetResponse Class
See Also Members
[image]

Contains the response from the UpdateOptionSetRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateOptionSetResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateOptionSetResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.UpdateOptionSetResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
UpdateOptionSetRequest


UpdateOptionSetResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UpdateOptionSetRequest class.

The following tables list the members exposed by the UpdateOptionSetResponse type.

Public Constructors

Name | Description
UpdateOptionSetResponse | Initializes a new instance of the UpdateOptionSetResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateOptionSetRequest


UpdateOptionSetResponse Constructor
[image]

Initializes a new instance of the UpdateOptionSetResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateOptionSetResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionSetResponse Class
UpdateOptionSetResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionSetResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateOptionSetRequest


UpdateOptionSetResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UpdateOptionSetResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateOptionSetRequest


UpdateOptionValueRequest Class
See Also Example Members
[image]

Contains the data that is needed to update an option value in a global or local option set.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateOptionValueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateOptionValueRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// In order to change labels on option set values (or delete) option set
// values, you must use UpdateOptionValueRequest
// (or DeleteOptionValueRequest).
UpdateOptionValueRequest updateOptionValueRequest =
    new UpdateOptionValueRequest
    {
        OptionSetName = _globalOptionSetName,
        // Update the second option value.
        Value = optionList[1].Value.Value,
        Label = new Label("Updated Option 1", _languageCode)
    };

_serviceProxy.Execute(updateOptionValueRequest);

//Publish the OptionSet
PublishXmlRequest pxReq3 = new PublishXmlRequest { ParameterXml = String.Format("<importexportxml><optionsets><optionset>{0}</optionset></optionsets></importexportxml>", _globalOptionSetName) };
_serviceProxy.Execute(pxReq3);

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  UpdateOptionValueResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in UpdateOptionValue Privileges.
Notes for Callers

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.UpdateOptionValueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Customize Global Option Sets in Microsoft Dynamics CRM
Sample: Work with Global Option Sets


UpdateOptionValueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update an option value in a global or local option set.

The following tables list the members exposed by the UpdateOptionValueRequest type.

Public Constructors

Name | Description
UpdateOptionValueRequest | Initializes a new instance of the UpdateOptionValueRequest class
Top

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the name of the attribute when updating a local option set in a picklist attribute. Optional.
public property | Description | Gets or sets a description for the option. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity when updating the local option set in a picklist attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Label | Gets or sets the label for the option. Optional.
public property | MergeLabels | Gets or sets whether to keep text defined for languages not included in the Label. Required.
public property | OptionSetName | Gets or sets the name of the global option set. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution that this global option set should be associated with. Optional.
public property | Value | Gets or sets the value for the option. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateOptionValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM
Sample: Work with Global Option Sets


UpdateOptionValueRequest Constructor
[image]

Initializes a new instance of the UpdateOptionValueRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateOptionValueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueRequest Class
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateOptionValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM
Sample: Work with Global Option Sets


UpdateOptionValueRequest Properties
[image]

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the name of the attribute when updating a local option set in a picklist attribute. Optional.
public property | Description | Gets or sets a description for the option. Optional.
public property | EntityLogicalName | Gets or sets the logical name of the entity when updating the local option set in a picklist attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Label | Gets or sets the label for the option. Optional.
public property | MergeLabels | Gets or sets whether to keep text defined for languages not included in the Label. Required.
public property | OptionSetName | Gets or sets the name of the global option set. Optional.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the name of the unmanaged solution that this global option set should be associated with. Optional.
public property | Value | Gets or sets the value for the option. Required.

See Also

Reference

UpdateOptionValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM
Sample: Work with Global Option Sets


UpdateOptionValueRequest.AttributeLogicalName Property
[image]

Gets or sets the name of the attribute when updating a local option set in a picklist attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeLogicalName As String

C#
public string AttributeLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the attribute when updating a local option set in a picklist attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueRequest Class
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueRequest.Description Property
[image]

Gets or sets a description for the option. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Description As Label

C#
public Label Description { get; set; }

C++

J#

JScript

Property Value
Type:Label
The description for the option. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueRequest Class
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueRequest.EntityLogicalName Property
[image]

Gets or sets the logical name of the entity when updating the local option set in a picklist attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityLogicalName As String

C#
public string EntityLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity when updating the local option set in a picklist attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueRequest Class
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueRequest.Label Property
[image]

Gets or sets the label for the option. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Label As Label

C#
public Label Label { get; set; }

C++

J#

JScript

Property Value
Type:  Label
The label for the option. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueRequest Class
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueRequest.MergeLabels Property
[image]

Gets or sets whether to keep text defined for languages not included in the Label. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MergeLabels As Boolean

C#
public bool MergeLabels { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the text defined for languages not included in the Label is kept; otherwise, false.

  Remarks
A Label contains a LocalizedLabels property that contains a LocalizedLabelCollection. Each contains a string and a LanguageCode. When you specify a new Label this property provides you the option to preserve any label text for languages not included in the new label. Set this value to false if you want to remove text for languages not included in the label.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueRequest Class
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueRequest.OptionSetName Property
[image]

Gets or sets the name of the global option set. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OptionSetName As String

C#
public string OptionSetName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the global option set. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueRequest Class
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueRequest.SolutionUniqueName Property
[image]

Gets or sets the name of the unmanaged solution that this global option set should be associated with. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the unmanaged solution that this global option set should be associated with. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueRequest Class
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueRequest.Value Property
[image]

Gets or sets the value for the option. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As Integer

C#
public int Value { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The value for the option. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueRequest Class
UpdateOptionValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueResponse Class
See Also Members
[image]

Contains the response from the UpdateOptionValueRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateOptionValueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateOptionValueResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.UpdateOptionValueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
UpdateOptionValueRequest


UpdateOptionValueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UpdateOptionValueRequest class.

The following tables list the members exposed by the UpdateOptionValueResponse type.

Public Constructors

Name | Description
UpdateOptionValueResponse | Initializes a new instance of the UpdateOptionValueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateOptionValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateOptionValueRequest


UpdateOptionValueResponse Constructor
[image]

Initializes a new instance of the UpdateOptionValueResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateOptionValueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateOptionValueResponse Class
UpdateOptionValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateOptionValueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateOptionValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateOptionValueRequest


UpdateOptionValueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UpdateOptionValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateOptionValueRequest


UpdateRelationshipRequest Class
See Also Members
[image]

Contains the data that is needed to update the definition of an entity relationship.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateRelationshipRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateRelationshipRequest : OrganizationRequest

C++

J#

JScript

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute   method, which returns an instance of  UpdateRelationshipResponse.
Privileges and Access Rights
To perform this action, the caller must have  privileges listed in UpdateRelationship Privileges.
Notes for Callers
You must publish the changes to the metadata before this change will be visible in the application. For more information, see Publish Customizations

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.UpdateRelationshipRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Customize Entity Relationship Metadata


UpdateRelationshipRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update the definition of an entity relationship.

The following tables list the members exposed by the UpdateRelationshipRequest type.

Public Constructors

Name | Description
UpdateRelationshipRequest | Initializes a new instance of the UpdateRelationshipRequest class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MergeLabels | Gets or sets whether to merge the new labels with any existing labels. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Relationship | Gets or sets the relationship metadata to be updated. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the unique name of the unmanaged solution that this entity relationship should be associated with. Optional.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateRelationshipRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Customize Entity Relationship Metadata


UpdateRelationshipRequest Constructor
[image]

Initializes a new instance of the UpdateRelationshipRequest class

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateRelationshipRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateRelationshipRequest Class
UpdateRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateRelationshipRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateRelationshipRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Customize Entity Relationship Metadata


UpdateRelationshipRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | MergeLabels | Gets or sets whether to merge the new labels with any existing labels. Required.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Relationship | Gets or sets the relationship metadata to be updated. Required.
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | SolutionUniqueName | Gets or sets the unique name of the unmanaged solution that this entity relationship should be associated with. Optional.

See Also

Reference

UpdateRelationshipRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Customize Entity Relationship Metadata


UpdateRelationshipRequest.MergeLabels Property
[image]

Gets or sets whether to merge the new labels with any existing labels. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MergeLabels As Boolean

C#
public bool MergeLabels { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the new labels will be merged with any existing labels; otherwise, false.

  Remarks
A Label is a collection of localized labels, each containing a string and a language code. If a label for an item already has labels for other languages and you update it with a label that contains only one label for a specific language the MergeLabels parameter provides the option to overwrite the existing labels or merge your new label with any existing language labels. With MergeLabels set to true, any new labels defined will only overwrite existing labels when the languagecode matches.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateRelationshipRequest Class
UpdateRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateRelationshipRequest.Relationship Property
[image]

Gets or sets the relationship metadata to be updated. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Relationship As RelationshipMetadataBase

C#
public RelationshipMetadataBase Relationship { get; set; }

C++

J#

JScript

Property Value
Type: RelationshipMetadataBase
The relationship metadata to be updated. Required..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateRelationshipRequest Class
UpdateRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateRelationshipRequest.SolutionUniqueName Property
[image]

Gets or sets the unique name of the unmanaged solution that this entity relationship should be associated with. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SolutionUniqueName As String

C#
public string SolutionUniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name of the unmanaged solution that this entity relationship should be associated with. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateRelationshipRequest Class
UpdateRelationshipRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateRelationshipResponse Class
See Also Members
[image]

Contains the response from the UpdateRelationshipRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateRelationshipResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateRelationshipResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.UpdateRelationshipResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateRelationshipResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
UpdateRelationshipRequest


UpdateRelationshipResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UpdateRelationshipRequest class.

The following tables list the members exposed by the UpdateRelationshipResponse type.

Public Constructors

Name | Description
UpdateRelationshipResponse | Initializes a new instance of the UpdateRelationshipResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateRelationshipResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateRelationshipRequest


UpdateRelationshipResponse Constructor
[image]

Initializes a new instance of the UpdateRelationshipResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateRelationshipResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateRelationshipResponse Class
UpdateRelationshipResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateRelationshipResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateRelationshipResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateRelationshipRequest


UpdateRelationshipResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UpdateRelationshipResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateRelationshipRequest


UpdateRequest Class
See Also Example Members
[image]

Contains the data that is needed to update an existing record.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code

// Retrieve current price list
ProductPriceLevel priceListItem =
    (ProductPriceLevel)_serviceProxy.Retrieve(
        ProductPriceLevel.EntityLogicalName,
        _priceListItemId,
        new ColumnSet("productpricelevelid", "amount")
    );

Console.WriteLine("Current price list retrieved.");
Console.WriteLine();

Console.WriteLine("Details before update:");
Console.WriteLine("----------------");
Console.WriteLine("Current order total: {0}",
    salesOrder.TotalAmount.Value);
Console.WriteLine("Current price per item: {0}",
    priceListItem.Amount.Value);
Console.WriteLine("</End of Listing>");
Console.WriteLine();

// Update the price list
priceListItem.Amount = new Money(30.0M);

UpdateRequest updatePriceListItem = new UpdateRequest()
{
    Target = priceListItem,
};
_serviceProxy.Execute(updatePriceListItem);

Console.WriteLine("Price list updated.");

  Remarks
Message Availability

                        This message works regardless whether the caller is connected to the server or offline. Not all entity types support this message offline. For more information, see Supported Entities later in this topic.
Usage
Pass an instance of this class to the Execute method, which returns an instance of the UpdateResponse class.

                        This message supports one or more optional parameters. For more information, see Pass Optional Parameters in Messages.

Privileges and Access Rights
To perform this action, the caller must have privileges on the specified entity in the entity parameter. For a list of the required privileges, see Update Privileges.
Notes for Callers
This message updates a record and its related records in one transaction. For a less complex method that updates a single record, use the Update method.
If the entity instance that is specified in the Target parameter includes attributes that are not valid for update, they are ignored.
Supported Entities
You can use this method to update any record of an entity that supports the Update message, including custom entities.

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
Account | 2 (Both)
ActivityMimeAttachment | 2 (Both)
Annotation | 2 (Both)
AnnualFiscalCalendar | 2 (Both)
Appointment | 2 (Both)
AsyncOperation | 2 (Both)
BusinessUnit | 2 (Both)
BusinessUnitNewsArticle | 2 (Both)
Calendar | 2 (Both)
Campaign | 2 (Both)
CampaignActivity | 2 (Both)
CampaignResponse | 2 (Both)
Competitor | 2 (Both)
Connection | 2 (Both)
ConnectionRole | 2 (Both)
ConstraintBasedGroup | 2 (Both)
Contact | 2 (Both)
Contract | 2 (Both)
ContractDetail | 2 (Both)
ContractTemplate | 2 (Both)
ConvertRule | 2 (Both)
ConvertRuleItem | 2 (Both)
CustomerAddress | 2 (Both)
CustomerOpportunityRole | 2 (Both)
CustomerRelationship | 2 (Both)
Discount | 2 (Both)
DiscountType | 2 (Both)
DisplayString | 2 (Both)
DuplicateRule | 2 (Both)
DuplicateRuleCondition | 2 (Both)
DynamicProperty | 2 (Both)
DynamicPropertyAssociation | 2 (Both)
DynamicPropertyInstance | 2 (Both)
DynamicPropertyOptionSetItem | 2 (Both)
Email | 2 (Both)
EmailServerProfile | 2 (Both)
Entitlement | 2 (Both)
EntitlementChannel | 2 (Both)
EntitlementTemplate | 2 (Both)
EntitlementTemplateChannel | 2 (Both)
Equipment | 2 (Both)
ExchangeSyncIdMapping | 2 (Both)
Fax | 2 (Both)
FieldPermission | 2 (Both)
FieldSecurityProfile | 2 (Both)
FixedMonthlyFiscalCalendar | 2 (Both)
Goal | 2 (Both)
GoalRollupQuery | 2 (Both)
HierarchyRule | 2 (Both)
Import | 2 (Both)
ImportFile | 2 (Both)
ImportJob | 2 (Both)
ImportMap | 2 (Both)
Incident | 2 (Both)
IncidentResolution | 2 (Both)
Invoice | 2 (Both)
InvoiceDetail | 2 (Both)
IsvConfig | 2 (Both)
KbArticle | 2 (Both)
KbArticleComment | 2 (Both)
KbArticleTemplate | 2 (Both)
Lead | 2 (Both)
Letter | 2 (Both)
List | 2 (Both)
Mailbox | 2 (Both)
MailMergeTemplate | 2 (Both)
Metric | 2 (Both)
MonthlyFiscalCalendar | 2 (Both)
msdyn_PostAlbum | 2 (Both)
msdyn_PostConfig | 2 (Both)
msdyn_PostRuleConfig | 2 (Both)
msdyn_wallsavedquery | 2 (Both)
msdyn_wallsavedqueryusersettings | 2 (Both)
Opportunity | 2 (Both)
OpportunityClose | 2 (Both)
OpportunityProduct | 2 (Both)
OrderClose | 2 (Both)
Organization | 2 (Both)
OrganizationUI | 2 (Both)
PhoneCall | 2 (Both)
PluginAssembly | 2 (Both)
PluginType | 2 (Both)
Position | 2 (Both)
PriceLevel | 2 (Both)
PrincipalObjectAttributeAccess | 2 (Both)
ProcessSession | 2 (Both)
ProcessTrigger | 2 (Both)
Product | 2 (Both)
ProductAssociation | 2 (Both)
ProductPriceLevel | 2 (Both)
ProductSubstitute | 2 (Both)
Publisher | 2 (Both)
PublisherAddress | 2 (Both)
QuarterlyFiscalCalendar | 2 (Both)
Queue | 2 (Both)
QueueItem | 2 (Both)
Quote | 2 (Both)
QuoteClose | 2 (Both)
QuoteDetail | 2 (Both)
RecurrenceRule | 2 (Both)
RecurringAppointmentMaster | 2 (Both)
RelationshipRole | 2 (Both)
RelationshipRoleMap | 2 (Both)
Report | 2 (Both)
ReportCategory | 2 (Both)
ReportEntity | 2 (Both)
ReportVisibility | 2 (Both)
ResourceSpec | 2 (Both)
Role | 2 (Both)
RollupField | 2 (Both)
RoutingRule | 2 (Both)
RoutingRuleItem | 2 (Both)
SalesLiterature | 2 (Both)
SalesLiteratureItem | 2 (Both)
SalesOrder | 2 (Both)
SalesOrderDetail | 2 (Both)
SavedQuery | 2 (Both)
SavedQueryVisualization | 2 (Both)
SdkMessageProcessingStep | 2 (Both)
SdkMessageProcessingStepImage | 2 (Both)
SdkMessageProcessingStepSecureConfig | 2 (Both)
SemiAnnualFiscalCalendar | 2 (Both)
Service | 2 (Both)
ServiceAppointment | 2 (Both)
ServiceEndpoint | 2 (Both)
SharePointData | 2 (Both)
SharePointDocumentLocation | 2 (Both)
SharePointSite | 2 (Both)
Site | 2 (Both)
SiteMap | 2 (Both)
SLA | 2 (Both)
SLAItem | 2 (Both)
SLAKPIInstance | 2 (Both)
SocialActivity | 2 (Both)
SocialInsightsConfiguration | 2 (Both)
SocialProfile | 2 (Both)
Solution | 2 (Both)
Subject | 2 (Both)
SystemForm | 2 (Both)
SystemUser | 2 (Both)
Task | 2 (Both)
Team | 2 (Both)
TeamTemplate | 2 (Both)
Template | 2 (Both)
Territory | 2 (Both)
TransactionCurrency | 2 (Both)
UoM | 2 (Both)
UoMSchedule | 2 (Both)
UserEntityInstanceData | 2 (Both)
UserEntityUISettings | 2 (Both)
UserForm | 2 (Both)
UserQuery | 2 (Both)
UserQueryVisualization | 2 (Both)
UserSettings | 2 (Both)
WebResource | 2 (Both)
Workflow | 2 (Both)
WorkflowDependency | 2 (Both)
WorkflowLog | 2 (Both)

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.UpdateRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
UpdateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
Other Resources
Write Code for Microsoft Dynamics CRM (Web Services)
Sample: Process Quotes, Sales Orders and Invoices


UpdateRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update an existing record.

The following tables list the members exposed by the UpdateRequest type.

Public Constructors

Name | Description
UpdateRequest | Initializes a new instance of the UpdateRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets an instance of an entity that is used to update a record. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Write Code for Microsoft Dynamics CRM (Web Services)
Sample: Process Quotes, Sales Orders and Invoices


UpdateRequest Constructor
[image]

Initializes a new instance of the UpdateRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateRequest Class
UpdateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Write Code for Microsoft Dynamics CRM (Web Services)
Sample: Process Quotes, Sales Orders and Invoices


UpdateRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Target | Gets or sets an instance of an entity that is used to update a record. Required.

See Also

Reference

UpdateRequest Class
Microsoft.Xrm.Sdk.Messages Namespace

Other Resources

Write Code for Microsoft Dynamics CRM (Web Services)
Sample: Process Quotes, Sales Orders and Invoices


UpdateRequest.Target Property
[image]

Gets or sets an instance of an entity that is used to update a record. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Entity

C#
public Entity Target { get; set; }

C++

J#

JScript

Property Value
Type: Entity
The entity instance used to update the record.

  Remarks
If the target contains values for attributes that are not valid for update, they are ignored. This is where IsValidForUpdate is false. You can find this information in the metadata for your organization. See the preceding metadata browser information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateRequest Class
UpdateRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateResponse Class
See Also Members
[image]

Contains the response from the UpdateRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.UpdateResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
UpdateRequest
Update


UpdateResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UpdateRequest class.

The following tables list the members exposed by the UpdateResponse type.

Public Constructors

Name | Description
UpdateResponse | Initializes a new instance of the UpdateResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateRequest
Update


UpdateResponse Constructor
[image]

Initializes a new instance of the UpdateResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateResponse Class
UpdateResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateRequest
Update


UpdateResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UpdateResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateRequest
Update


UpdateStateValueRequest Class
See Also Example Members
[image]

Contains the data that is needed to update an option set value in for a StateAttributeMetadata attribute.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateStateValueRequest
    Inherits OrganizationRequest

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateStateValueRequest : OrganizationRequest

C++

J#

JScript

  Example
The following example shows how to use this message. For this sample to work correctly, you must be connected to the server to get an IOrganizationService interface. For the complete sample, see the link later in this topic.
C#    Copy Code
// Modify the state value label from Active to Open.
// Create the request.
UpdateStateValueRequest updateStateValue = new UpdateStateValueRequest
{
    AttributeLogicalName = "statecode",
    EntityLogicalName = Contact.EntityLogicalName,
    Value = 1,
    Label = new Label("Open", _languageCode)
};

// Execute the request.
_serviceProxy.Execute(updateStateValue);

Console.WriteLine(
    "Updated {0} state attribute of {1} entity from 'Active' to '{2}'.",
    updateStateValue.AttributeLogicalName,
    updateStateValue.EntityLogicalName,
    updateStateValue.Label.LocalizedLabels[0].Label
    );

  Remarks
Message Availability

                        For this message to work, the caller must be connected to the server.

Usage
Pass an instance of this class to the  Execute  method, which returns an instance of  the UpdateStateValueResponse class.
Privileges and Access Rights
To perform this action, the caller must have  the required privileges, as listed in UpdateAttribute Privileges.
Supported Attributes
You can use this method to update any unmanaged attribute of type State.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Sdk.Messages.UpdateStateValueRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace
UpdateStateValueResponse
StateAttributeMetadata
Other Resources
Update a State Value
Sample: Work with Attributes
UpdateAttribute Privileges


UpdateStateValueRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to update an option set value in for a StateAttributeMetadata attribute.

The following tables list the members exposed by the UpdateStateValueRequest type.

Public Constructors

Name | Description
UpdateStateValueRequest | Initializes a new instance of the UpdateStateValueRequest class.
Top

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the logical name of the attribute. Optional.
public property | DefaultStatusCode | Gets or sets the default value for the statuscode (status reason) attribute when this statecode value is set. Optional.
public property | Description | Gets or sets the description label for the statecode option that is specified in the Value property. Optional.
public property | EntityLogicalName | Gets or sets the name of the entity that has this statecode attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Label | Gets or sets the display label for this statecode option that is specified by the Value property. Optional.
public property | MergeLabels | Gets or sets whether to merge the current label with any existing labels that are already specified for this attribute. Required.
public property | OptionSetName | For internal use only.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Value | Gets or sets the statecode attribute options to update. Required.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateStateValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateStateValueResponse
StateAttributeMetadata

Other Resources

Update a State Value
Sample: Work with Attributes
UpdateAttribute Privileges


UpdateStateValueRequest Constructor
[image]

Initializes a new instance of the UpdateStateValueRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateStateValueRequest ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueRequest Class
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateStateValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateStateValueResponse
StateAttributeMetadata

Other Resources

Update a State Value
Sample: Work with Attributes
UpdateAttribute Privileges


UpdateStateValueRequest Properties
[image]

Public Properties

 | Name | Description
public property | AttributeLogicalName | Gets or sets the logical name of the attribute. Optional.
public property | DefaultStatusCode | Gets or sets the default value for the statuscode (status reason) attribute when this statecode value is set. Optional.
public property | Description | Gets or sets the description label for the statecode option that is specified in the Value property. Optional.
public property | EntityLogicalName | Gets or sets the name of the entity that has this statecode attribute. Optional.
public property | ExtensionData | Gets or sets the structure that contains extra data. Optional. (inherited from OrganizationRequest)
public property | Item | Gets or sets the indexer for the Parameters collection. (inherited from OrganizationRequest)
public property | Label | Gets or sets the display label for this statecode option that is specified by the Value property. Optional.
public property | MergeLabels | Gets or sets whether to merge the current label with any existing labels that are already specified for this attribute. Required.
public property | OptionSetName | For internal use only.
public property | Parameters | Gets or sets the collection of parameters for the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | RequestId | Gets or sets the ID of an asynchronous operation (system job). Optional. (inherited from OrganizationRequest)
public property | RequestName | Gets or sets the name of the request. Required, but is supplied by derived classes. (inherited from OrganizationRequest)
public property | Value | Gets or sets the statecode attribute options to update. Required.

See Also

Reference

UpdateStateValueRequest Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateStateValueResponse
StateAttributeMetadata

Other Resources

Update a State Value
Sample: Work with Attributes
UpdateAttribute Privileges


UpdateStateValueRequest.AttributeLogicalName Property
[image]

Gets or sets the logical name of the attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeLogicalName As String

C#
public string AttributeLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the attribute. Optional.

  Remarks
The logical name of the state attribute is always statecode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueRequest Class
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueRequest.DefaultStatusCode Property
[image]

Gets or sets the default value for the statuscode (status reason) attribute when this statecode value is set. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DefaultStatusCode As Nullable(Of Integer)

C#
public Nullable<int> DefaultStatusCode { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The default value for the statuscode (status reason) attribute when this statecode value is set. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueRequest Class
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueRequest.Description Property
[image]

Gets or sets the description label for the statecode option that is specified in the Value property. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Description As Label

C#
public Label Description { get; set; }

C++

J#

JScript

Property Value
Type: Label
the description label for the statecode option that is specified in the Value property. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueRequest Class
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueRequest.EntityLogicalName Property
[image]

Gets or sets the name of the entity that has this statecode attribute. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityLogicalName As String

C#
public string EntityLogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the entity that has this statecode attribute. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueRequest Class
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueRequest.Label Property
[image]

Gets or sets the display label for this statecode option that is specified by the Value property. Optional.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Label As Label

C#
public Label Label { get; set; }

C++

J#

JScript

Property Value
Type: Label
The display label for this statecode option that is specified by the Value property. Optional.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueRequest Class
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueRequest.MergeLabels Property
[image]

Gets or sets whether to merge the current label with any existing labels that are already specified for this attribute. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MergeLabels As Boolean

C#
public bool MergeLabels { get; set; }

C++

J#

JScript

Property Value
Type:  Boolean
true if any newly defined labels should only overwrite existing labels when their language code matches; otherwise, false.

  Remarks
A Label is a collection of localized labels where each collection contains a string and a language code. If a label for an item already has labels for other languages and you update it with a label that contains only one label for a specific language, the MergeLabels property provides the option to overwrite the existing labels or merge your new label with any existing labels. If you set MergeLabels to true, any newly defined labels only overwrite existing labels when their language code matches.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueRequest Class
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueRequest.OptionSetName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OptionSetName As String

C#
public string OptionSetName { get; set; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueRequest Class
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueRequest.Value Property
[image]

Gets or sets the statecode attribute options to update. Required.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As Integer

C#
public int Value { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The statecode attribute options to update. Required.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueRequest Class
UpdateStateValueRequest Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueResponse Class
See Also Members
[image]

Contains the response from the UpdateStateValueRequest class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class UpdateStateValueResponse
    Inherits OrganizationResponse

C#
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class UpdateStateValueResponse : OrganizationResponse

C++

J#

JScript

  Remarks

                        There is no return value from this operation.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationResponse
    Microsoft.Xrm.Sdk.Messages.UpdateStateValueResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace
UpdateStateValueRequest


UpdateStateValueResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from the UpdateStateValueRequest class.

The following tables list the members exposed by the UpdateStateValueResponse type.

Public Constructors

Name | Description
UpdateStateValueResponse | Initializes a new instance of the UpdateStateValueResponse class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateStateValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateStateValueRequest


UpdateStateValueResponse Constructor
[image]

Initializes a new instance of the UpdateStateValueResponse class.

Namespace: Microsoft.Xrm.Sdk.Messages
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateStateValueResponse ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateStateValueResponse Class
UpdateStateValueResponse Members
Microsoft.Xrm.Sdk.Messages Namespace


UpdateStateValueResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateStateValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateStateValueRequest


UpdateStateValueResponse Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from OrganizationResponse)
public property | Item | Gets an indexer for the Results collection. (inherited from OrganizationResponse)
public property | ResponseName | Gets or sets the name of the response. (inherited from OrganizationResponse)
public property | Results | Gets the results of the request that was performed. (inherited from OrganizationResponse)

See Also

Reference

UpdateStateValueResponse Class
Microsoft.Xrm.Sdk.Messages Namespace
UpdateStateValueRequest


Microsoft.Xrm.Sdk.Metadata Namespace

Classes

Class | Description
AssociatedMenuConfiguration | Defines how the associated records are displayed for an entity relationship.
AttributeMetadata | Contains all the metadata for an entity attribute.
AttributeRequiredLevelManagedProperty | Represents the data to define a RequiredLevel property for an attribute.
AttributeTypeDisplayName | Provides a list of types of attributes used by AttributeMetadata.AttributeTypeName
BigIntAttributeMetadata | Contains the metadata for an attribute type BigInt.
BooleanAttributeMetadata | Contains the metadata for an attribute type Boolean.
BooleanOptionSetMetadata | Contains the metadata for an attribute of type Boolean.
CascadeConfiguration | Contains properties representing actions that may be performed on the referenced entity in a one-to-many entity relationship.
ConstantsBase | A base class for static classes whose properties represent constants
DateTimeAttributeMetadata | Contains the metadata for an attribute of type DateTime.
DecimalAttributeMetadata | Contains the metadata for an attribute type Decimal.
DoubleAttributeMetadata | Contains the metadata for an attribute type Double.
EntityMetadata | Contains the metadata for an entity.
EntityMetadataCollection | Defines a collection of EntityMetadata
EntityNameAttributeMetadata | Contains the metadata for an attribute that references an entity.
EnumAttributeMetadata | Contains the data for an attribute that provides options.
ImageAttributeMetadata | Contains the metadata for an attribute type Image.
IntegerAttributeMetadata | Contains the metadata for an attribute type Integer.
LookupAttributeMetadata | Contains the metadata for an attribute of type lookup.
ManagedPropertyAttributeMetadata | For internal use only.
ManagedPropertyMetadata | For internal use only.
ManyToManyRelationshipMetadata | Contains the metadata for a many-to-many entity relationship.
MemoAttributeMetadata | Contains the metadata for the attribute type Memo.
MetadataBase | Specifies the base class for classes that contains metadata information.
MoneyAttributeMetadata | Contains the metadata for an attribute type Money.
OneToManyRelationshipMetadata | Contains the metadata for a one-to-many entity relationship.
OptionMetadata | Contains metadata representing an option within an Option set.
OptionMetadataCollection | Contains the options in for the OptionSetMetadata.Options class.
OptionSetMetadata | Contains metadata that defines a set of options.
OptionSetMetadataBase | Contains data that defines a set of options.
PicklistAttributeMetadata | Contains the metadata for an attribute type Picklist.
RelationshipMetadataBase | Contains the metadata for an entity relationship.
SecurityPrivilegeMetadata | Contains the metadata that describes a security privilege for access to an entity.
StateAttributeMetadata | Contains the metadata for an attribute of type State.
StateOptionMetadata | Contains data to define an option for the options in a State attribute.
StatusAttributeMetadata | Contains the metadata for an attribute of type Status.
StatusOptionMetadata | Contains one of the possible values for an attribute of type Status.
StringAttributeMetadata | Contains the metadata for an attribute of type String.
StringFormatName | Specifies the format of a StringAttributeMetadata attribute using the FormatName property.

Enumerations

Enumeration | Description
AssociatedMenuBehavior | Describes the behavior of the associated menu for a one-to-many relationship.
AssociatedMenuGroup | Describes the group in which to display the associated menu for an entity relationship
AttributeRequiredLevel | Describes the requirement level for an attribute.
AttributeTypeCode | Describes the type of an attribute.
CascadeType | Describes the type of behavior for a specific action applied to the referenced entity in a one-to-many entity relationship.
DateTimeFormat | Describes the formatting of a DateTimeAttributeMetadata attribute.
EntityFilters | Describes the type of entity metadata to retrieve.
ImeMode | Describes the input method editor mode
IntegerFormat | Describes the formatting of an integer attribute.
ManagedPropertyEvaluationPriority | For internal use only.
ManagedPropertyOperation | For internal use only.
ManagedPropertyType | For internal use only.
OptionSetType | Indicates the type of option set.
OwnershipTypes | Specifies the type of ownership for an entity.
PrivilegeType | Describes the type of operation for the privilege
RelationshipType | Specifies the type of entity relationship.
SecurityTypes | Describes the security type for the relationship.
StringFormat | Deprecated. Describes the formatting of a string attribute for the StringAttributeMetadata.Format property.


AssociatedMenuBehavior Enumeration
[image]

Describes the behavior of the associated menu for a one-to-many relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AssociatedMenuBehavior", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration AssociatedMenuBehavior

C#
[DataContractAttribute(Name="AssociatedMenuBehavior", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum AssociatedMenuBehavior

C++

J#

JScript

  Members
Member name | Description
DoNotDisplay | Do not show the associated menu. Value = 2.
UseCollectionName | Use the collection name for the associated menu. Value = 0.
UseLabel | Use the label for the associated menu. Value = 1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Create Entity Relationships
Customize Entity Relationship Metadata


AssociatedMenuConfiguration Class
See Also Members
[image]

Defines how the associated records are displayed for an entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AssociatedMenuConfiguration", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class AssociatedMenuConfiguration
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="AssociatedMenuConfiguration", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class AssociatedMenuConfiguration : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Metadata.AssociatedMenuConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociatedMenuConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Configuring Associated Menus


AssociatedMenuConfiguration Members
See Also Constructors Methods Properties
[image]

Defines how the associated records are displayed for an entity relationship.

The following tables list the members exposed by the AssociatedMenuConfiguration type.

Public Constructors

Name | Description
AssociatedMenuConfiguration | Initializes a new instance of theAssociatedMenuConfiguration class.
Top

Public Properties

 | Name | Description
public property | Behavior | Gets or sets the behavior of the associated menu for an entity relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Group | Gets or sets the group for the associated menu for an entity relationship.
public property | Label | Gets or sets the label for the associated menu.
public property | Order | Gets or sets the order for the associated menu.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AssociatedMenuConfiguration Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Configuring Associated Menus


AssociatedMenuConfiguration Constructor
[image]

Initializes a new instance of the AssociatedMenuConfiguration class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AssociatedMenuConfiguration ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociatedMenuConfiguration Class
AssociatedMenuConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


AssociatedMenuConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AssociatedMenuConfiguration Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Configuring Associated Menus


AssociatedMenuConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | Behavior | Gets or sets the behavior of the associated menu for an entity relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Group | Gets or sets the group for the associated menu for an entity relationship.
public property | Label | Gets or sets the label for the associated menu.
public property | Order | Gets or sets the order for the associated menu.

See Also

Reference

AssociatedMenuConfiguration Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Configuring Associated Menus


AssociatedMenuConfiguration.Behavior Property
[image]

Gets or sets the behavior of the associated menu for an entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Behavior As Nullable(Of AssociatedMenuBehavior)

C#
[DataMemberAttribute]
public Nullable<AssociatedMenuBehavior> Behavior { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<AssociatedMenuBehavior>

One of the enumeration values that specify the behavior of the associated menu for a one-to-many relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociatedMenuConfiguration Class
AssociatedMenuConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


AssociatedMenuConfiguration.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociatedMenuConfiguration Class
AssociatedMenuConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


AssociatedMenuConfiguration.Group Property
[image]

Gets or sets the group for the associated menu for an entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Group As Nullable(Of AssociatedMenuGroup)

C#
[DataMemberAttribute]
public Nullable<AssociatedMenuGroup> Group { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<AssociatedMenuGroup>

One of the enumeration values that specify the group in which to display the associated menu for an entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociatedMenuConfiguration Class
AssociatedMenuConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


AssociatedMenuConfiguration.Label Property
[image]

Gets or sets the label for the associated menu.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Label As Label

C#
[DataMemberAttribute]
public Label Label { get; set; }

C++

J#

JScript

Property Value
Type: Label

A string that contains the menu label.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociatedMenuConfiguration Class
AssociatedMenuConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


AssociatedMenuConfiguration.Order Property
[image]

Gets or sets the order for the associated menu.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Order As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> Order { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<int>

An integer that controls the relative position of navigation items in the group.

  Remarks
The lower the integer value, the higher the item appears relative to the values of other items in the group.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssociatedMenuConfiguration Class
AssociatedMenuConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


AssociatedMenuGroup Enumeration
[image]

Describes the group in which to display the associated menu for an entity relationship

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AssociatedMenuGroup", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration AssociatedMenuGroup

C#
[DataContractAttribute(Name="AssociatedMenuGroup", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum AssociatedMenuGroup

C++

J#

JScript

  Members
Member name | Description
Details | Show the associated menu in the details group. Value = 0.
Marketing | Show the associated menu in the marketing group. Value = 3.
Sales | Show the associated menu in the sales group. Value = 1.
Service | Show the associated menu in the service group. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
AssociatedMenuConfiguration
Other Resources
Customize Entity Relationship Metadata


AttributeMetadata Class
See Also Members
[image]

Contains all the metadata for an entity attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(DateTimeAttributeMetadata))> _
<KnownTypeAttribute(GetType(StateAttributeMetadata))> _
<KnownTypeAttribute(GetType(StatusAttributeMetadata))> _
<KnownTypeAttribute(GetType(MemoAttributeMetadata))> _
<KnownTypeAttribute(GetType(BooleanAttributeMetadata))> _
<KnownTypeAttribute(GetType(DecimalAttributeMetadata))> _
<KnownTypeAttribute(GetType(DoubleAttributeMetadata))> _
<KnownTypeAttribute(GetType(EntityNameAttributeMetadata))> _
<KnownTypeAttribute(GetType(ManagedPropertyAttributeMetadata))> _
<KnownTypeAttribute(GetType(IntegerAttributeMetadata))> _
<KnownTypeAttribute(GetType(BigIntAttributeMetadata))> _
<KnownTypeAttribute(GetType(LookupAttributeMetadata))> _
<KnownTypeAttribute(GetType(ImageAttributeMetadata))> _
<KnownTypeAttribute(GetType(MoneyAttributeMetadata))> _
<KnownTypeAttribute(GetType(PicklistAttributeMetadata))> _
<DataContractAttribute(Name:="AttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
<KnownTypeAttribute(GetType(StringAttributeMetadata))> _
Public Class AttributeMetadata
    Inherits MetadataBase

C#
[KnownTypeAttribute(typeof(DateTimeAttributeMetadata))]
[KnownTypeAttribute(typeof(StateAttributeMetadata))]
[KnownTypeAttribute(typeof(StatusAttributeMetadata))]
[KnownTypeAttribute(typeof(MemoAttributeMetadata))]
[KnownTypeAttribute(typeof(BooleanAttributeMetadata))]
[KnownTypeAttribute(typeof(DecimalAttributeMetadata))]
[KnownTypeAttribute(typeof(DoubleAttributeMetadata))]
[KnownTypeAttribute(typeof(EntityNameAttributeMetadata))]
[KnownTypeAttribute(typeof(ManagedPropertyAttributeMetadata))]
[KnownTypeAttribute(typeof(IntegerAttributeMetadata))]
[KnownTypeAttribute(typeof(BigIntAttributeMetadata))]
[KnownTypeAttribute(typeof(LookupAttributeMetadata))]
[KnownTypeAttribute(typeof(ImageAttributeMetadata))]
[KnownTypeAttribute(typeof(MoneyAttributeMetadata))]
[KnownTypeAttribute(typeof(PicklistAttributeMetadata))]
[DataContractAttribute(Name="AttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
[KnownTypeAttribute(typeof(StringAttributeMetadata))]
public class AttributeMetadata : MetadataBase

C++

J#

JScript

  Remarks
This class is returned in the RetrieveAttributeResponse.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase
    Microsoft.Xrm.Sdk.Metadata.AttributeMetadata

                Derived Classes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata
Sample: Dump Attribute Metadata to a File
Sample: Work with Attributes
Sample: Retrieve Entity Metadata Using JavaScript


AttributeMetadata Members
See Also Constructors Methods Properties
[image]

Contains all the metadata for an entity attribute.

The following tables list the members exposed by the AttributeMetadata type.

Public Constructors (see also Protected Constructors)

Name | Description
AttributeMetadata | Overloaded. Initializes a new instance of the AttributeMetadata class.
Top

Protected Constructors

Name | Description
AttributeMetadata | Overloaded. Initializes a new instance of the AttributeMetadata class.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends.
public property | AttributeType | Gets the type for the attribute.
public property | AttributeTypeName | Gets the name of the type for the attribute.
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute.
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute.
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute.
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed.
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing.
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in.
public property | Description | Gets or sets the description of the attribute.
public property | DisplayName | Gets or sets the display name for the attribute.
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing.
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute.
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization.
public property | IsLogical | Gets whether the attribute is a logical attribute.
public property | IsManaged | Gets whether the attribute is part of a managed solution.
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record.
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity.
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed.
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security.
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find.
public property | IsValidForCreate | Gets whether the value can be set when a record is created.
public property | IsValidForRead | Gets whether the value can be retrieved.
public property | IsValidForUpdate | Gets whether the value can be updated.
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments.
public property | LogicalName | Gets or sets the logical name for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute.
public property | SchemaName | Gets or sets the schema name for the attribute.
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Sample: Dump Attribute Metadata to a File
Sample: Work with Attributes
Sample: Retrieve Entity Metadata Using JavaScript


AttributeMetadata Constructor
[image]

Initializes a new instance of the AttributeMetadata class.

Overload List

Name | Description
AttributeMetadata () | Initializes a new instance of the AttributeMetadata class.
AttributeMetadata (AttributeTypeCode) | Initializes a new instance of the AttributeMetadata class.
AttributeMetadata (AttributeTypeCode, String) | Initializes a new instance of the AttributeMetadata class.

See Also

Reference

AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata Constructor ()
[image]

Initializes a new instance of the AttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata Constructor (AttributeTypeCode)
[image]

Initializes a new instance of the AttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    attributeType As AttributeTypeCode _
)

C#
protected AttributeMetadata (
    AttributeTypeCode attributeType
)

C++

J#

JScript

Parameters
attributeType
Type: AttributeTypeCode. Sets the type for the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata Constructor (AttributeTypeCode, String)
[image]

Initializes a new instance of the AttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    attributeType As AttributeTypeCode, _
    schemaName As String _
)

C#
protected AttributeMetadata (
    AttributeTypeCode attributeType,
    string schemaName
)

C++

J#

JScript

Parameters
attributeType
Type: AttributeTypeCode. Sets the type for the attribute.
schemaName
Type: String. Sets the schema name of the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Sample: Dump Attribute Metadata to a File
Sample: Work with Attributes
Sample: Retrieve Entity Metadata Using JavaScript


AttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends.
public property | AttributeType | Gets the type for the attribute.
public property | AttributeTypeName | Gets the name of the type for the attribute.
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute.
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute.
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute.
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed.
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing.
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in.
public property | Description | Gets or sets the description of the attribute.
public property | DisplayName | Gets or sets the display name for the attribute.
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing.
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute.
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization.
public property | IsLogical | Gets whether the attribute is a logical attribute.
public property | IsManaged | Gets whether the attribute is part of a managed solution.
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record.
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity.
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed.
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security.
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find.
public property | IsValidForCreate | Gets whether the value can be set when a record is created.
public property | IsValidForRead | Gets whether the value can be retrieved.
public property | IsValidForUpdate | Gets whether the value can be updated.
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments.
public property | LogicalName | Gets or sets the logical name for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute.
public property | SchemaName | Gets or sets the schema name for the attribute.
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute.

See Also

Reference

AttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Sample: Dump Attribute Metadata to a File
Sample: Work with Attributes
Sample: Retrieve Entity Metadata Using JavaScript


AttributeMetadata.AttributeOf Property
[image]

Gets the name of the attribute that this attribute extends.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeOf As String

C#
[DataMemberAttribute]
public string AttributeOf { get; }

C++

J#

JScript

Property Value
Type: String

The attribute name.

  Remarks
This property is read-only. This property will be set if the metadata attribute describes an attribute of another attribute. If this property contains a value, the attribute is for internal use only and won’t appear in the customization user interface (UI) in the web application.
If you retrieve the metadata for the lead entity, there are three attributes that extend the accountid attribute. They are accountidname,  accountiddsc and accountidyominame. For each of these three attributes, the value of the AttributeOf property is "accountid".

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.AttributeType Property
[image]

Gets the type for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeType As Nullable(Of AttributeTypeCode)

C#
[DataMemberAttribute]
public Nullable<AttributeTypeCode> AttributeType { get; }

C++

J#

JScript

Property Value
Type:  Nullable<AttributeTypeCode>

The attribute type.

  Remarks
This property is read-only it is set based on the type of Attribute passed to the CreateAttributeRequest message.
  Note

                        For ImageAttributeMetadata this value will return Virtual. Use AttributeTypeName to get a value that is correct for all types.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.AttributeTypeName Property
[image]

Gets the name of the type for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property AttributeTypeName As AttributeTypeDisplayName

C#
[DataMemberAttribute(Order=60)]
public AttributeTypeDisplayName AttributeTypeName { get; }

C++

J#

JScript

Property Value
Type:  AttributeTypeDisplayName

The name of the attribute type.

  Remarks
This property is read-only. It is set based on the type of Attribute passed to the CreateAttributeRequest message,
  Note

                        Use this property rather than AttributeType to get a valid value for all types.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.CanBeSecuredForCreate Property
[image]

Gets whether field-level security can be applied to prevent a user from adding data to this attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeSecuredForCreate As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> CanBeSecuredForCreate { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the field-level security can be applied; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM
Field Security Entities


AttributeMetadata.CanBeSecuredForRead Property
[image]

Gets whether field-level security can be applied to prevent a user from viewing data from this attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeSecuredForRead As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> CanBeSecuredForRead { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if field-level security can be applied; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM
Field Security Entities


AttributeMetadata.CanBeSecuredForUpdate Property
[image]

Gets whether field-level security can be applied to prevent a user from updating data for this attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeSecuredForUpdate As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> CanBeSecuredForUpdate { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if field-level security can be applied; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM
Field Security Entities


AttributeMetadata.CanModifyAdditionalSettings Property
[image]

Gets or sets the property that determines whether any settings not controlled by managed properties can be changed.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanModifyAdditionalSettings As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty CanModifyAdditionalSettings { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether any settings not controlled by managed properties can be changed.

  Remarks
The properties that this setting controls varies depending on the type of attribute as shown in the following table.

                                    Property

                                    Description

DefaultFormValue

  • Applies to PicklistAttributeMetadata, StateAttributeMetadata, and StatusAttributeMetadata attributes.
  • Specifies which form value will be the default value.

Format

  • Applies to DateTimeAttributeMetadata attributes only.
  • Specifies whether a time is displayed with the date.

ImeMode

  • Applies to MemoAttributeMetadata, DecimalAttributeMetadata, StringAttributeMetadata, MoneyAttributeMetadata, DateTimeAttributeMetadata, and DoubleAttributeMetadata attributes
  • Specifies whether the Input method editor mode can be changed.

MaxLength

  • Applies to StringAttributeMetadata and MemoAttributeMetadataattributes.
  • Specifies the maximum allowed length of string data that the attribute can store.

Precision

  • Applies to the DecimalAttributeMetadata, DoubleAttributeMetadata, and MoneyAttributeMetadataattributes.
  • Specifies the level of precision for data stored in these attributes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.ColumnNumber Property
[image]

Gets an organization-specific ID for the attribute used for auditing.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ColumnNumber As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> ColumnNumber { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The organization-specific ID for the attribute used for auditing.

  Remarks
This ID isn’t consistent between organizations. Use LogicalName as the unique identifier for an attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.DeprecatedVersion Property
[image]

Gets the Microsoft Dynamics CRM version that the attribute was deprecated in.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DeprecatedVersion As String

C#
[DataMemberAttribute]
public string DeprecatedVersion { get; }

C++

J#

JScript

Property Value
Type: String

The Microsoft Dynamics CRM version that the attribute was deprecated in.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.Description Property
[image]

Gets or sets the description of the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Description As Label

C#
[DataMemberAttribute]
public Label Description { get; set; }

C++

J#

JScript

Property Value
Type:  Label
The description of the attribute.

  Remarks
This property can be specified for both CreateAttributeRequest and UpdateAttributeRequest messages.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.DisplayName Property
[image]

Gets or sets the display name for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DisplayName As Label

C#
[DataMemberAttribute]
public Label DisplayName { get; set; }

C++

J#

JScript

Property Value
Type:  Label
The display name of the attribute.

  Remarks
This property is required for the CreateAttributeRequest message. It can be specified for the UpdateAttributeRequest message.This property must always have value set for the base language.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.EntityLogicalName Property
[image]

Gets the logical name of the entity that contains the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityLogicalName As String

C#
[DataMemberAttribute]
public string EntityLogicalName { get; }

C++

J#

JScript

Property Value
Type: String

The logical name of the entity that contains the attribute.

  Remarks
This property is read-only. It is set when the attribute is created, using the value from the CreateAttributeRequest. EntityName property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IntroducedVersion Property
[image]

Gets a string identifying the solution version that the solution component was added in.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property IntroducedVersion As String

C#
[DataMemberAttribute(Order=60)]
public string IntroducedVersion { get; }

C++

J#

JScript

Property Value
Type: String

The solution version number when the attribute was created.

  Remarks

                        This identifies the major and minor versions of the solution that added this metadata item. For metadata that existed in Microsoft Dynamics CRM 2011 the value will be 5.0.0.0 and for metadata added with Microsoft Dynamics CRM 2013 the value will be 6.0.0.0. If new metadata is added in updates or future releases the version number will be incremented to the corresponding version. For metadata added by custom solutions the version of the solution that the item was created it is used.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsAuditEnabled Property
[image]

Gets or sets the property that determines whether the attribute is enabled for auditing.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsAuditEnabled As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsAuditEnabled { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty

The property that determines whether the attribute is enabled for auditing.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Configure Entities and Attributes for Auditing


AttributeMetadata.IsCustomAttribute Property
[image]

Gets whether the attribute is a custom attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsCustomAttribute As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsCustomAttribute { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the attribute is a custom attribute; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsCustomizable Property
[image]

Gets or sets the property that determines whether the attribute allows customization.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsCustomizable As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsCustomizable { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the attribute allows customization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsLogical Property
[image]

Gets whether the attribute is a logical attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic

C#

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the attribute a logical attribute; otherwise, false.

  Remarks
Logical attributes contain values which are stored in different database tables than other attributes in the entity. In most cases this internal implementation is not relevant to working with Microsoft Dynamics CRM. When you use logical attributes as sources for a calculated field the values in the calculated field cannot be sorted.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Logical attributes


AttributeMetadata.IsManaged Property
[image]

Gets whether the attribute is part of a managed solution.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsManaged As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsManaged { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the attribute is part of a managed solution; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsPrimaryId Property
[image]

Gets whether the attribute represents the unique identifier for the record.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsPrimaryId As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsPrimaryId { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the attribute is the unique identifier for the record; otherwise, false.

  Remarks
Entities that contain an address may have more than one attribute where isPrimaryId is true.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsPrimaryName Property
[image]

Gets or sets whether the attribute represents the primary attribute for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsPrimaryName As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsPrimaryName { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the attribute is primary attribute for the entity; otherwise, false.

  Remarks
If the value of this property is true, the value of the attribute is what will be displayed in lookup fields in the application.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsRenameable Property
[image]

Gets or sets the property that determines whether the attribute display name can be changed.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsRenameable As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsRenameable { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the attribute display name can be changed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsSecured Property
[image]

Gets or sets whether the attribute is secured for field-level security.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsSecured As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsSecured { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the attribute is secured for field-level security; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
How Field Security Can Be Used to Control Access to Field Values In Microsoft Dynamics CRM
Field Security Entities


AttributeMetadata.IsValidForAdvancedFind Property
[image]

Gets or sets the property that determines whether the attribute appears in Advanced Find.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsValidForAdvancedFind As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsValidForAdvancedFind { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the attribute appears in Advanced Find.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsValidForCreate Property
[image]

Gets whether the value can be set when a record is created.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsValidForCreate As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsValidForCreate { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the value can be set when a record is created; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsValidForRead Property
[image]

Gets whether the value can be retrieved.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsValidForRead As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsValidForRead { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the value can be retrieved; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.IsValidForUpdate Property
[image]

Gets whether the value can be updated.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsValidForUpdate As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsValidForUpdate { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the value can be updated; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.LinkedAttributeId Property
[image]

Gets or sets an attribute that is linked between appointments and recurring appointments.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LinkedAttributeId As Nullable(Of Guid)

C#
[DataMemberAttribute]
public Nullable<Guid> LinkedAttributeId { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Guid>

The attribute ID that is linked between appointments and recurring appointments.

  Remarks
Link Custom Attributes of the Recurring Appointment Master (series) and Appointment Entities

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.LogicalName Property
[image]

Gets or sets the logical name for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LogicalName As String

C#
[DataMemberAttribute]
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name for the attribute.

  Remarks
This property is read-only. The logical name is created by the system when an attribute is created. The logical name is an all lowercase version of the SchemaName property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Options Available When Creating a Custom Entity


AttributeMetadata.RequiredLevel Property
[image]

Gets or sets the property that determines the data entry requirement level enforced for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RequiredLevel As AttributeRequiredLevelManagedProperty

C#
[DataMemberAttribute]
public AttributeRequiredLevelManagedProperty RequiredLevel { get; set; }

C++

J#

JScript

Property Value
Type: AttributeRequiredLevelManagedProperty
The property that determines the data entry requirement level enforced for the attribute.

  Remarks
This property is required for the CreateAttributeRequest message. It can be specified for the UpdateAttributeRequest message.The following values are valid when you create an attribute.
None

Recommended

ApplicationRequired

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeMetadata.SchemaName Property
[image]

Gets or sets the schema name for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SchemaName As String

C#
[DataMemberAttribute]
public string SchemaName { get; set; }

C++

J#

JScript

Property Value
Type: String

The schema name for the attribute.

  Remarks
This property is read-only except when you create an attribute. For the CreateAttributeRequest method, it is required and must be unique. This name has different length requirements depending on its use.
The value of the SchemaName property should be in Pascal case. It is converted to all lowercase for the LogicalName property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Options Available When Creating a Custom Entity


AttributeMetadata.SourceType Property
[image]

Gets or sets the value that indicates the source type for a calculated or rollup attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property SourceType As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=70)]
public Nullable<int> SourceType { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The value that indicates the source type for a calculated or rollup attribute.

  Remarks
The following table contains the valid values for this attribute.
Value | Source Type
null | Simple
1 | Calculated
2 | Rollup

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes


AttributeRequiredLevel Enumeration
[image]

Describes the requirement level for an attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AttributeRequiredLevel", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration AttributeRequiredLevel

C#
[DataContractAttribute(Name="AttributeRequiredLevel", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum AttributeRequiredLevel

C++

J#

JScript

  Members
Member name | Description
ApplicationRequired | The attribute is required to have a value. Value = 2.
None | No requirements are specified. Value = 0.
Recommended | It is recommended that the attribute has a value. Value = 3.
SystemRequired | The attribute is required to have a value. Value = 1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


AttributeRequiredLevelManagedProperty Class
See Also Members
[image]

Represents the data to define a RequiredLevel property for an attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AttributeRequiredLevelManagedProperty", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class AttributeRequiredLevelManagedProperty
    Inherits ManagedProperty(Of AttributeRequiredLevel)

C#
[DataContractAttribute(Name="AttributeRequiredLevelManagedProperty", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class AttributeRequiredLevelManagedProperty : ManagedProperty<AttributeRequiredLevel>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.ManagedProperty
    Microsoft.Xrm.Sdk.Metadata.AttributeRequiredLevelManagedProperty
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeRequiredLevelManagedProperty Members
Microsoft.Xrm.Sdk.Metadata Namespace
CreateAttributeRequest
Other Resources
Customize Entity Attribute Metadata
Work with Attributes
Sample: Create and Update Entity Metadata


AttributeRequiredLevelManagedProperty Members
See Also Constructors Methods Properties
[image]

Represents the data to define a RequiredLevel property for an attribute.

The following tables list the members exposed by the AttributeRequiredLevelManagedProperty type.

Public Constructors

Name | Description
AttributeRequiredLevelManagedProperty | Initializes a new instance of the AttributeRequiredLevelManagedProperty class.
Top

Public Properties

 | Name | Description
public property | CanBeChanged | Gets or sets whether the managed property value can be changed. (inherited from ManagedProperty)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from ManagedProperty)
public property | ManagedPropertyLogicalName | Gets the logical name for the managed property. (inherited from ManagedProperty)
public property | Value | Gets or sets the value of the managed property. (inherited from ManagedProperty)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AttributeRequiredLevelManagedProperty Class
Microsoft.Xrm.Sdk.Metadata Namespace
CreateAttributeRequest

Other Resources

Customize Entity Attribute Metadata
Work with Attributes
Sample: Create and Update Entity Metadata


AttributeRequiredLevelManagedProperty Constructor
[image]

Initializes a new instance of the AttributeRequiredLevelManagedProperty class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As AttributeRequiredLevel _
)

C#
public AttributeRequiredLevelManagedProperty (
    AttributeRequiredLevel value
)

C++

J#

JScript

Parameters
value
Type:  AttributeRequiredLevel.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeRequiredLevelManagedProperty Class
AttributeRequiredLevelManagedProperty Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeRequiredLevelManagedProperty Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AttributeRequiredLevelManagedProperty Class
Microsoft.Xrm.Sdk.Metadata Namespace
CreateAttributeRequest

Other Resources

Customize Entity Attribute Metadata
Work with Attributes
Sample: Create and Update Entity Metadata


AttributeRequiredLevelManagedProperty Properties
[image]

Public Properties

 | Name | Description
public property | CanBeChanged | Gets or sets whether the managed property value can be changed. (inherited from ManagedProperty)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from ManagedProperty)
public property | ManagedPropertyLogicalName | Gets the logical name for the managed property. (inherited from ManagedProperty)
public property | Value | Gets or sets the value of the managed property. (inherited from ManagedProperty)

See Also

Reference

AttributeRequiredLevelManagedProperty Class
Microsoft.Xrm.Sdk.Metadata Namespace
CreateAttributeRequest

Other Resources

Customize Entity Attribute Metadata
Work with Attributes
Sample: Create and Update Entity Metadata


AttributeTypeCode Enumeration
[image]

Describes the type of an attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AttributeTypeCode", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration AttributeTypeCode

C#
[DataContractAttribute(Name="AttributeTypeCode", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum AttributeTypeCode

C++

J#

JScript

  Members
Member name | Description
BigInt | A big integer attribute. Value = 0x12.
Boolean | A Boolean attribute. Value = 0.
CalendarRules | An attribute that contains calendar rules. Value = 0x10.
Customer | An attribute that represents a customer. Value = 1.
DateTime | A date/time attribute. Value = 2.
Decimal | A decimal attribute. Value = 3.
Double | A double attribute. Value = 4.
EntityName | An entity name attribute. Value = 20.
Integer | An integer attribute. Value = 5.
Lookup | A lookup attribute. Value = 6.
ManagedProperty | A managed property attribute. Value = 0x13.
Memo | A memo attribute. Value = 7.
Money | A money attribute. Value = 8.
Owner | An owner attribute. Value = 9.
PartyList | A partylist attribute. Value = 10.
Picklist | A picklist attribute. Value = 11.
State | A state attribute. Value = 12.
Status | A status attribute. Value = 13.
String | A string attribute. Value = 14.
Uniqueidentifier | An attribute that is an ID. Value = 15.
Virtual | An attribute that is created by the system at run time. Value = 0x11.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


AttributeTypeDisplayName Class
See Also Members
[image]

Provides a list of types of attributes used by AttributeMetadata.AttributeTypeName

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AttributeTypeDisplayName", Namespace:="http://schemas.microsoft.com/xrm/2013/Metadata")> _
Public NotInheritable Class AttributeTypeDisplayName
    Inherits ConstantsBase(Of String)

C#
[DataContractAttribute(Name="AttributeTypeDisplayName", Namespace="http://schemas.microsoft.com/xrm/2013/Metadata")]
public sealed class AttributeTypeDisplayName : ConstantsBase<string>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.ConstantsBase
    Microsoft.Xrm.Sdk.Metadata.AttributeTypeDisplayName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName Members
See Also Constructors Fields Methods Properties
[image]

Provides a list of types of attributes used by AttributeMetadata.AttributeTypeName

The following tables list the members exposed by the AttributeTypeDisplayName type.

Public Constructors

Name | Description
AttributeTypeDisplayName | Initializes a new instance of the AttributeTypeDisplayName class.
Top

Public Fields

Name | Description
BigIntType | An attribute type that stores a Long value
BooleanType | An attribute type that stores a Boolean value
CalendarRulesType | An attribute type that stores an EntityCollection or CalendarRules[] value
CustomerType | An attribute type that stores an EntityReference to either an Account or Contact.
DateTimeType | An attribute type that stores a System.DateTime value
DecimalType | An attribute type that stores a Decimal value
DoubleType | An attribute type that stores a Double value
EntityNameType | An attribute type that stores a reference to a logical entity name value.
ImageType | An attribute type that enables access to a specific image for an entity instance.
IntegerType | An attribute type that stores an Integer value
LookupType | An attribute type that stores an EntityReference value.
ManagedPropertyType | An attribute type that stores a BooleanManagedProperty value.
MemoType | An attribute type that stores a String value formatted for multiple lines of text.
MoneyType | An attribute type that stores a Money value
OwnerType | An attribute type that stores an EntityReference value to a Team or SystemUser record.
PartyListType | An attribute type that stores an EntityCollection or ActivityParty[] value
PicklistType | An attribute type that stores an OptionSetValue.
StateType | An attribute type that stores an OptionSetValue representing the valid statecode values for an entity.
StatusType | An attribute type that stores an OptionSetValue representing the valid statuscode values for an entity.
StringType | An attribute type that stores a String value
UniqueidentifierType | An attribute type that stores a System.Guid value.
VirtualType | An attribute type that represents a value not included within records.
Top

Public Properties

 | Name | Description
public property | ExtensionData | (inherited from ConstantsBase)
public property | Value | (inherited from ConstantsBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Returns a hash code value for this type.
public method | GetType | (inherited from Object)
 | Equality | Indicates whether two AttributeTypeDisplayName instances are the same.
 | Implicit | Converts a string into a AttributeTypeDisplayName
 | Inequality | Indicates whether two AttributeTypeDisplayName instances are different.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | ValueExistsInList | Indicates whether a value exists in the list. (inherited from ConstantsBase)
Top

See Also

Reference

AttributeTypeDisplayName Class
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName Fields
[image]

Public Fields

Name | Description
BigIntType | An attribute type that stores a Long value
BooleanType | An attribute type that stores a Boolean value
CalendarRulesType | An attribute type that stores an EntityCollection or CalendarRules[] value
CustomerType | An attribute type that stores an EntityReference to either an Account or Contact.
DateTimeType | An attribute type that stores a System.DateTime value
DecimalType | An attribute type that stores a Decimal value
DoubleType | An attribute type that stores a Double value
EntityNameType | An attribute type that stores a reference to a logical entity name value.
ImageType | An attribute type that enables access to a specific image for an entity instance.
IntegerType | An attribute type that stores an Integer value
LookupType | An attribute type that stores an EntityReference value.
ManagedPropertyType | An attribute type that stores a BooleanManagedProperty value.
MemoType | An attribute type that stores a String value formatted for multiple lines of text.
MoneyType | An attribute type that stores a Money value
OwnerType | An attribute type that stores an EntityReference value to a Team or SystemUser record.
PartyListType | An attribute type that stores an EntityCollection or ActivityParty[] value
PicklistType | An attribute type that stores an OptionSetValue.
StateType | An attribute type that stores an OptionSetValue representing the valid statecode values for an entity.
StatusType | An attribute type that stores an OptionSetValue representing the valid statuscode values for an entity.
StringType | An attribute type that stores a String value
UniqueidentifierType | An attribute type that stores a System.Guid value.
VirtualType | An attribute type that represents a value not included within records.

See Also

Reference

AttributeTypeDisplayName Class
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.BigIntType Field
[image]

An attribute type that stores a Long value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly BigIntType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName BigIntType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.BooleanType Field
[image]

An attribute type that stores a Boolean value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly BooleanType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName BooleanType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.CalendarRulesType Field
[image]

An attribute type that stores an EntityCollection or CalendarRules[] value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly CalendarRulesType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName CalendarRulesType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.CustomerType Field
[image]

An attribute type that stores an EntityReference to either an Account or Contact.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly CustomerType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName CustomerType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.DateTimeType Field
[image]

An attribute type that stores a System.DateTime value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly DateTimeType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName DateTimeType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.DecimalType Field
[image]

An attribute type that stores a Decimal value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly DecimalType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName DecimalType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.DoubleType Field
[image]

An attribute type that stores a Double value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly DoubleType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName DoubleType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.EntityNameType Field
[image]

An attribute type that stores a reference to a logical entity name value.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly EntityNameType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName EntityNameType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.ImageType Field
[image]

An attribute type that enables access to a specific image for an entity instance.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly ImageType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName ImageType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.IntegerType Field
[image]

An attribute type that stores an Integer value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly IntegerType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName IntegerType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.LookupType Field
[image]

An attribute type that stores an EntityReference value.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly LookupType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName LookupType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.ManagedPropertyType Field
[image]

An attribute type that stores a BooleanManagedProperty value.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly ManagedPropertyType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName ManagedPropertyType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.MemoType Field
[image]

An attribute type that stores a String value formatted for multiple lines of text.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly MemoType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName MemoType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.MoneyType Field
[image]

An attribute type that stores a Money value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly MoneyType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName MoneyType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.OwnerType Field
[image]

An attribute type that stores an EntityReference value to a Team or SystemUser record.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly OwnerType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName OwnerType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.PartyListType Field
[image]

An attribute type that stores an EntityCollection or ActivityParty[] value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly PartyListType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName PartyListType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.PicklistType Field
[image]

An attribute type that stores an OptionSetValue.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly PicklistType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName PicklistType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.StateType Field
[image]

An attribute type that stores an OptionSetValue representing the valid statecode values for an entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly StateType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName StateType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.StatusType Field
[image]

An attribute type that stores an OptionSetValue representing the valid statuscode values for an entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly StatusType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName StatusType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.StringType Field
[image]

An attribute type that stores a String value

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly StringType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName StringType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.UniqueidentifierType Field
[image]

An attribute type that stores a System.Guid value.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly UniqueidentifierType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName UniqueidentifierType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.VirtualType Field
[image]

An attribute type that represents a value not included within records.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="AttributeTypeDisplayName is immutable")> _
Public Shared ReadOnly VirtualType As AttributeTypeDisplayName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="AttributeTypeDisplayName is immutable")]
public static readonly AttributeTypeDisplayName VirtualType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName Constructor
[image]

Initializes a new instance of the AttributeTypeDisplayName class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeTypeDisplayName ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Returns a hash code value for this type.
public method | GetType | (inherited from Object)
 | Equality | Indicates whether two AttributeTypeDisplayName instances are the same.
 | Implicit | Converts a string into a AttributeTypeDisplayName
 | Inequality | Indicates whether two AttributeTypeDisplayName instances are different.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | ValueExistsInList | Indicates whether a value exists in the list. (inherited from ConstantsBase)

See Also

Reference

AttributeTypeDisplayName Class
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.Equals Method
[image]

Determines whether two instances are equal.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

C#
public override bool Equals (
    Object obj
)

C++

J#

JScript

Parameters
obj
Type: Object. The AttributeTypeDisplayName to compare with the current AttributeTypeDisplayName.
Return Value
Type: Boolean
true if the specified AttributeTypeDisplayName is equal to the AttributeTypeDisplayName object; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.GetHashCode Method
[image]

Returns a hash code value for this type.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function GetHashCode As Integer

C#
public override int GetHashCode ()

C++

J#

JScript

Return Value
Type: Int32

The hash code for the current AttributeTypeDisplayName.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.Equality Method
[image]

Indicates whether two AttributeTypeDisplayName instances are the same.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Operator = ( _
    attributeTypeDisplayNameA As AttributeTypeDisplayName, _
    attributeTypeDisplayNameB As AttributeTypeDisplayName _
) As Boolean

C#
public static bool operator == (
    AttributeTypeDisplayName attributeTypeDisplayNameA,
    AttributeTypeDisplayName attributeTypeDisplayNameB
)

C++

J#

JScript

Parameters
attributeTypeDisplayNameA
Type: AttributeTypeDisplayName. Specifies a AttributeTypeDisplayName.
attributeTypeDisplayNameB
Type: AttributeTypeDisplayName. Specifies a AttributeTypeDisplayName.
Return Value
Type: Boolean
true if the values of attributeTypeDisplayNameA and attributeTypeDisplayNameB are the same; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.Implicit Method
[image]

Converts a string into a AttributeTypeDisplayName

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Widening Operator CType ( _
    attributeTypeDisplayName As String _
) As AttributeTypeDisplayName

C#
public static implicit operator AttributeTypeDisplayName (
    string attributeTypeDisplayName
)

C++

J#

JScript

Parameters
attributeTypeDisplayName
Type: String. Specifies a AttributeTypeDisplayName.
Return Value
Type: AttributeTypeDisplayName
A AttributeTypeDisplayName that represents the converted String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName.Inequality Method
[image]

Indicates whether two AttributeTypeDisplayName instances are different.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Operator <> ( _
    attributeTypeDisplayNameA As AttributeTypeDisplayName, _
    attributeTypeDisplayNameB As AttributeTypeDisplayName _
) As Boolean

C#
public static bool operator != (
    AttributeTypeDisplayName attributeTypeDisplayNameA,
    AttributeTypeDisplayName attributeTypeDisplayNameB
)

C++

J#

JScript

Parameters
attributeTypeDisplayNameA
Type: AttributeTypeDisplayName. Specifies a AttributeTypeDisplayName.
attributeTypeDisplayNameB
Type: AttributeTypeDisplayName. Specifies a AttributeTypeDisplayName.
Return Value
Type: Boolean
true if the values of attributeTypeDisplayNameA and attributeTypeDisplayNameB are different; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTypeDisplayName Class
AttributeTypeDisplayName Members
Microsoft.Xrm.Sdk.Metadata Namespace


AttributeTypeDisplayName Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | (inherited from ConstantsBase)
public property | Value | (inherited from ConstantsBase)

See Also

Reference

AttributeTypeDisplayName Class
Microsoft.Xrm.Sdk.Metadata Namespace


BigIntAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute type BigInt.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="BigIntAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class BigIntAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="BigIntAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class BigIntAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.BigIntAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BigIntAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


BigIntAttributeMetadata Members
See Also Constructors Fields Methods Properties
[image]

Contains the metadata for an attribute type BigInt.

The following tables list the members exposed by the BigIntAttributeMetadata type.

Public Constructors

Name | Description
BigIntAttributeMetadata | Overloaded. Initializes a new instance of the BigIntAttributeMetadata class
Top

Public Fields

Name | Description
MaxSupportedValue | The maximum supported value for this attribute is 9223372036854775807.
MinSupportedValue | The minimum supported value for this attribute is -9223372036854775808.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BigIntAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


BigIntAttributeMetadata Fields
[image]

Public Fields

Name | Description
MaxSupportedValue | The maximum supported value for this attribute is 9223372036854775807.
MinSupportedValue | The minimum supported value for this attribute is -9223372036854775808.

See Also

Reference

BigIntAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


BigIntAttributeMetadata.MaxSupportedValue Field
[image]

The maximum supported value for this attribute is 9223372036854775807.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedValue As Long

C#
public const long MaxSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BigIntAttributeMetadata Class
BigIntAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BigIntAttributeMetadata.MinSupportedValue Field
[image]

The minimum supported value for this attribute is -9223372036854775808.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedValue As Long

C#
public const long MinSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BigIntAttributeMetadata Class
BigIntAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BigIntAttributeMetadata Constructor
[image]

Initializes a new instance of the BigIntAttributeMetadata class

Overload List

Name | Description
BigIntAttributeMetadata () | Initializes a new instance of the BigIntAttributeMetadata class
BigIntAttributeMetadata (String) | Initializes a new instance of the BigIntAttributeMetadata class

See Also

Reference

BigIntAttributeMetadata Class
BigIntAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BigIntAttributeMetadata Constructor ()
[image]

Initializes a new instance of the BigIntAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BigIntAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BigIntAttributeMetadata Class
BigIntAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BigIntAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the BigIntAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public BigIntAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The Schema Name for the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BigIntAttributeMetadata Class
BigIntAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BigIntAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BigIntAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


BigIntAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)

See Also

Reference

BigIntAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


BigIntAttributeMetadata.MaxValue Property
[image]

Gets or sets the maximum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxValue As Nullable(Of Long)

C#
[DataMemberAttribute]
public Nullable<long> MaxValue { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int64>

The maximum value for the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BigIntAttributeMetadata Class
BigIntAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BigIntAttributeMetadata.MinValue Property
[image]

Gets or sets the minimum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MinValue As Nullable(Of Long)

C#
[DataMemberAttribute]
public Nullable<long> MinValue { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int64>

The minimum value for the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BigIntAttributeMetadata Class
BigIntAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute type Boolean.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="BooleanAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class BooleanAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="BooleanAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class BooleanAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.BooleanAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata
Work with Attributes


BooleanAttributeMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an attribute type Boolean.

The following tables list the members exposed by the BooleanAttributeMetadata type.

Public Constructors

Name | Description
BooleanAttributeMetadata | Overloaded. Initializes a new instance of theBooleanAttributeMetadata class.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultValue | Gets or sets the default value for a Boolean option set.
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the options for a boolean attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BooleanAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


BooleanAttributeMetadata Constructor
[image]

Initializes a new instance of theBooleanAttributeMetadata class.

Overload List

Name | Description
BooleanAttributeMetadata () | Initializes a new instance of the BooleanAttributeMetadata class
BooleanAttributeMetadata (BooleanOptionSetMetadata) | Initializes a new instance of the BooleanAttributeMetadata class
BooleanAttributeMetadata (String) | Initializes a new instance of the BooleanAttributeMetadata class
BooleanAttributeMetadata (String, BooleanOptionSetMetadata) | Initializes a new instance of the BooleanAttributeMetadata class

See Also

Reference

BooleanAttributeMetadata Class
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanAttributeMetadata Constructor ()
[image]

Initializes a new instance of the BooleanAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BooleanAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanAttributeMetadata Class
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanAttributeMetadata Constructor (BooleanOptionSetMetadata)
[image]

Initializes a new instance of the BooleanAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    optionSet As BooleanOptionSetMetadata _
)

C#
public BooleanAttributeMetadata (
    BooleanOptionSetMetadata optionSet
)

C++

J#

JScript

Parameters
optionSet
Type: BooleanOptionSetMetadata The definition of the options
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanAttributeMetadata Class
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the BooleanAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public BooleanAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name of the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanAttributeMetadata Class
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanAttributeMetadata Constructor (String, BooleanOptionSetMetadata)
[image]

Initializes a new instance of the BooleanAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String, _
    optionSet As BooleanOptionSetMetadata _
)

C#
public BooleanAttributeMetadata (
    string schemaName,
    BooleanOptionSetMetadata optionSet
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name of the attribute.
optionSet
Type: BooleanOptionSetMetadata The definition of the options
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanAttributeMetadata Class
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BooleanAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


BooleanAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultValue | Gets or sets the default value for a Boolean option set.
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the options for a boolean attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

See Also

Reference

BooleanAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


BooleanAttributeMetadata.DefaultValue Property
[image]

Gets or sets the default value for a Boolean option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DefaultValue As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> DefaultValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>

The default value for a Boolean option set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanAttributeMetadata Class
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanAttributeMetadata.FormulaDefinition Property
[image]

Gets or sets the formula definition for calculated and rollup attributes.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property FormulaDefinition As String

C#
[DataMemberAttribute(Order=70)]
public string FormulaDefinition { get; set; }

C++

J#

JScript

Property Value
Type: String
The formula definition for calculated and rollup attributes.

  Remarks
To edit this property, you must use the formula editor in the application. More information:Customization Guide: Define Calculated Fields and Customization Guide: Define Rollup Fields.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanAttributeMetadata Class
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes


BooleanAttributeMetadata.OptionSet Property
[image]

Gets or sets the options for a boolean attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OptionSet As BooleanOptionSetMetadata

C#
[DataMemberAttribute]
public BooleanOptionSetMetadata OptionSet { get; set; }

C++

J#

JScript

Property Value
Type: BooleanOptionSetMetadata
 The definition of the options.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanAttributeMetadata Class
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanAttributeMetadata.SourceTypeMask Property
[image]

Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property SourceTypeMask As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=70)]
public Nullable<int> SourceTypeMask { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The value that indicates the source of data for a calculated or rollup attribute.

  Remarks
The following table contains the valid values for this attribute.
Value | Description
0 | Undefined: The default value for simple and rollup attributes.
1 | Simple: The calculated attribute refers to an attribute in the same record.
2 | Related: The calculated attribute refers to an attribute in a related record.
4 | Logical: The calculated attribute refers to an attribute in the same record that is actually stored in a different database table. More information:Logical attributes
8 | Calculated: The calculated attribute refers to another calculated attribute.
16 | Rollup: The calculated attribute refers to a rollup attribute.
32 | Invalid: The calculated or rollup attribute is invalid. Typically this would be where a field refers to an attribute that no longer exists.
The SourceTypeMasks enumeration is useful when performing bitwise operations to check whether specific values are present in this bitmask value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanAttributeMetadata Class
BooleanAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes
SourceTypeMasks enumeration
Logical attributes


BooleanOptionSetMetadata Class
See Also Members
[image]

Contains the metadata for an attribute of type Boolean.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="BooleanOptionSetMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class BooleanOptionSetMetadata
    Inherits OptionSetMetadataBase

C#
[DataContractAttribute(Name="BooleanOptionSetMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class BooleanOptionSetMetadata : OptionSetMetadataBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.OptionSetMetadataBase
      Microsoft.Xrm.Sdk.Metadata.BooleanOptionSetMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanOptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata
Work with Attributes


BooleanOptionSetMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an attribute of type Boolean.

The following tables list the members exposed by the BooleanOptionSetMetadata type.

Public Constructors

Name | Description
BooleanOptionSetMetadata | Overloaded. Initializes a new instance of the BooleanOptionSetMetadata class
Top

Public Properties

 | Name | Description
public property | Description | Gets or sets a description for the option set. (inherited from OptionSetMetadataBase)
public property | DisplayName | Gets or sets a display name for a global option set. (inherited from OptionSetMetadataBase)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FalseOption | Gets or sets option displayed when the attribute is false.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from OptionSetMetadataBase)
public property | IsCustomizable | Gets or sets a property that determines whether the option set is customizable. (inherited from OptionSetMetadataBase)
public property | IsCustomOptionSet | Gets or sets whether the option set is a custom option set. (inherited from OptionSetMetadataBase)
public property | IsGlobal | Gets or sets whether the option set is a global option set. (inherited from OptionSetMetadataBase)
public property | IsManaged | Gets or sets whether the option set is part of a managed solution. (inherited from OptionSetMetadataBase)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Name | Gets or sets the name of a global option set. (inherited from OptionSetMetadataBase)
public property | OptionSetType | Gets or sets the type of option set. (inherited from OptionSetMetadataBase)
public property | TrueOption | Gets or sets option displayed when the attribute is true.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BooleanOptionSetMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


BooleanOptionSetMetadata Constructor
[image]

Initializes a new instance of the BooleanOptionSetMetadata class

Overload List

Name | Description
BooleanOptionSetMetadata () | Initializes a new instance of the BooleanOptionSetMetadata class
BooleanOptionSetMetadata (OptionMetadata, OptionMetadata) | Initializes a new instance of the BooleanOptionSetMetadata class

See Also

Reference

BooleanOptionSetMetadata Class
BooleanOptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanOptionSetMetadata Constructor ()
[image]

Initializes a new instance of the BooleanOptionSetMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BooleanOptionSetMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanOptionSetMetadata Class
BooleanOptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanOptionSetMetadata Constructor (OptionMetadata, OptionMetadata)
[image]

Initializes a new instance of the BooleanOptionSetMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    trueOption As OptionMetadata, _
    falseOption As OptionMetadata _
)

C#
public BooleanOptionSetMetadata (
    OptionMetadata trueOption,
    OptionMetadata falseOption
)

C++

J#

JScript

Parameters
trueOption
Type: OptionMetadata The option metadata for the true option.
falseOption
Type: OptionMetadata The option metadata for the false option.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanOptionSetMetadata Class
BooleanOptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanOptionSetMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BooleanOptionSetMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


BooleanOptionSetMetadata Properties
[image]

Public Properties

 | Name | Description
public property | Description | Gets or sets a description for the option set. (inherited from OptionSetMetadataBase)
public property | DisplayName | Gets or sets a display name for a global option set. (inherited from OptionSetMetadataBase)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FalseOption | Gets or sets option displayed when the attribute is false.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from OptionSetMetadataBase)
public property | IsCustomizable | Gets or sets a property that determines whether the option set is customizable. (inherited from OptionSetMetadataBase)
public property | IsCustomOptionSet | Gets or sets whether the option set is a custom option set. (inherited from OptionSetMetadataBase)
public property | IsGlobal | Gets or sets whether the option set is a global option set. (inherited from OptionSetMetadataBase)
public property | IsManaged | Gets or sets whether the option set is part of a managed solution. (inherited from OptionSetMetadataBase)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Name | Gets or sets the name of a global option set. (inherited from OptionSetMetadataBase)
public property | OptionSetType | Gets or sets the type of option set. (inherited from OptionSetMetadataBase)
public property | TrueOption | Gets or sets option displayed when the attribute is true.

See Also

Reference

BooleanOptionSetMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


BooleanOptionSetMetadata.FalseOption Property
[image]

Gets or sets option displayed when the attribute is false.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FalseOption As OptionMetadata

C#
[DataMemberAttribute]
public OptionMetadata FalseOption { get; set; }

C++

J#

JScript

Property Value
Type: OptionMetadata
The option metadata for the false option..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanOptionSetMetadata Class
BooleanOptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


BooleanOptionSetMetadata.TrueOption Property
[image]

Gets or sets option displayed when the attribute is true.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TrueOption As OptionMetadata

C#
[DataMemberAttribute]
public OptionMetadata TrueOption { get; set; }

C++

J#

JScript

Property Value
Type: OptionMetadata
The option metadata for the true option..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
BooleanOptionSetMetadata Class
BooleanOptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


CascadeConfiguration Class
See Also Members
[image]

Contains properties representing actions that may be performed on the referenced entity in a one-to-many entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="CascadeConfiguration", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class CascadeConfiguration
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="CascadeConfiguration", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class CascadeConfiguration : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Metadata.CascadeConfiguration
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CascadeConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace
CreateOneToManyRequest
Other Resources
Entity Relationship Behavior
One-To-Many Relationships
Create a Lookup Attribute
Create and Retrieve Entity Relationships


CascadeConfiguration Members
See Also Constructors Methods Properties
[image]

Contains properties representing actions that may be performed on the referenced entity in a one-to-many entity relationship.

The following tables list the members exposed by the CascadeConfiguration type.

Public Constructors

Name | Description
CascadeConfiguration | Initializes a new instance of theCascadeConfiguration class
Top

Public Properties

 | Name | Description
public property | Assign | The referenced entity record owner is changed.
public property | Delete | The referenced entity record is deleted.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Merge | The record is merged with another record.
public property | Reparent | The value of the referencing attribute in a parental relationship changes. changes.
public property | Share | The referenced entity record is shared with another user.
public property | Unshare | Sharing is removed for the referenced entity record.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CascadeConfiguration Class
Microsoft.Xrm.Sdk.Metadata Namespace
CreateOneToManyRequest

Other Resources

Entity Relationship Behavior
One-To-Many Relationships
Create a Lookup Attribute
Create and Retrieve Entity Relationships


CascadeConfiguration Constructor
[image]

Initializes a new instance of the CascadeConfiguration class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CascadeConfiguration ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CascadeConfiguration Class
CascadeConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


CascadeConfiguration Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CascadeConfiguration Class
Microsoft.Xrm.Sdk.Metadata Namespace
CreateOneToManyRequest

Other Resources

Entity Relationship Behavior
One-To-Many Relationships
Create a Lookup Attribute
Create and Retrieve Entity Relationships


CascadeConfiguration Properties
[image]

Public Properties

 | Name | Description
public property | Assign | The referenced entity record owner is changed.
public property | Delete | The referenced entity record is deleted.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Merge | The record is merged with another record.
public property | Reparent | The value of the referencing attribute in a parental relationship changes. changes.
public property | Share | The referenced entity record is shared with another user.
public property | Unshare | Sharing is removed for the referenced entity record.

See Also

Reference

CascadeConfiguration Class
Microsoft.Xrm.Sdk.Metadata Namespace
CreateOneToManyRequest

Other Resources

Entity Relationship Behavior
One-To-Many Relationships
Create a Lookup Attribute
Create and Retrieve Entity Relationships


CascadeConfiguration.Assign Property
[image]

The referenced entity record owner is changed.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Assign As Nullable(Of CascadeType)

C#
[DataMemberAttribute]
public Nullable<CascadeType> Assign { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<CascadeType>

The referenced entity record owner is changed.

  Remarks
Valid options for the Assign property are:
  • CascadeType.Active
  • CascadeType.Cascade
  • CascadeType.NoCascade
  • CascadeType.UserOwned

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CascadeConfiguration Class
CascadeConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


CascadeConfiguration.Delete Property
[image]

The referenced entity record is deleted.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Delete As Nullable(Of CascadeType)

C#
[DataMemberAttribute]
public Nullable<CascadeType> Delete { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<CascadeType>

The referenced entity record is deleted.

  Remarks
Valid options for the Delete property are:
  • CascadeType.Cascade
  • CascadeType.RemoveLink
  • CascadeType.Restrict

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CascadeConfiguration Class
CascadeConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


CascadeConfiguration.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Remarks

                        Gets or sets the structure that contains extra data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CascadeConfiguration Class
CascadeConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


CascadeConfiguration.Merge Property
[image]

The record is merged with another record.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Merge As Nullable(Of CascadeType)

C#
[DataMemberAttribute]
public Nullable<CascadeType> Merge { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<CascadeType>

The record is merged with another record..

  Remarks
Valid options for the Merge property are:
  • CascadeType.Cascade
  • CascadeType.NoCascade

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CascadeConfiguration Class
CascadeConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


CascadeConfiguration.Reparent Property
[image]

The value of the referencing attribute in a parental relationship changes. changes.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Reparent As Nullable(Of CascadeType)

C#
[DataMemberAttribute]
public Nullable<CascadeType> Reparent { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<CascadeType>

The value of the referencing attribute in a parental relationship changes. changes.

  Remarks
Valid options for the Reparent property are:
  • CascadeType.Active
  • CascadeType.Cascade
  • CascadeType.NoCascade
  • CascadeType.UserOwned

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CascadeConfiguration Class
CascadeConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
The Reparent Action


CascadeConfiguration.Share Property
[image]

The referenced entity record is shared with another user.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Share As Nullable(Of CascadeType)

C#
[DataMemberAttribute]
public Nullable<CascadeType> Share { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<CascadeType>

The referenced entity record is shared with another user.

  Remarks
Valid options for the Share property are:
  • CascadeType.Active
  • CascadeType.Cascade
  • CascadeType.NoCascade
  • CascadeType.UserOwned

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CascadeConfiguration Class
CascadeConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


CascadeConfiguration.Unshare Property
[image]

Sharing is removed for the referenced entity record.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Unshare As Nullable(Of CascadeType)

C#
[DataMemberAttribute]
public Nullable<CascadeType> Unshare { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<CascadeType>

Sharing is removed for the referenced entity record.

  Remarks
Valid options for the Unshare property are:
  • CascadeType.Active
  • CascadeType.Cascade
  • CascadeType.NoCascade
  • CascadeType.UserOwned

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CascadeConfiguration Class
CascadeConfiguration Members
Microsoft.Xrm.Sdk.Metadata Namespace


CascadeType Enumeration
[image]

Describes the type of behavior for a specific action applied to the referenced entity in a one-to-many entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="CascadeType", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration CascadeType

C#
[DataContractAttribute(Name="CascadeType", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum CascadeType

C++

J#

JScript

  Members
Member name | Description
Active | Perform the action on all active referencing entity records associated with the referenced entity record. Value = 2.
Cascade | Perform the action on all referencing entity records associated with the referenced entity record. Value = 1.
NoCascade | Do nothing. Value = 0.
RemoveLink | Remove the value of the referencing attribute for all referencing entity records associated with the referenced entity record. Value = 4.
Restrict | Prevent the Referenced entity record from being deleted when referencing entities exist. Value = 5.
UserOwned | Perform the action on all referencing entity records owned by the same user as the referenced entity record. Value = 3.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase Generic Class
See Also Members
[image]

A base class for static classes whose properties represent constants

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(StringFormatName))> _
<KnownTypeAttribute(GetType(AttributeTypeDisplayName))> _
<DataContractAttribute(Name:="ConstantsBase", Namespace:="http://schemas.microsoft.com/xrm/2013/Metadata")> _
Public MustInherit Class ConstantsBase(Of T)
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute(typeof(StringFormatName))]
[KnownTypeAttribute(typeof(AttributeTypeDisplayName))]
[DataContractAttribute(Name="ConstantsBase", Namespace="http://schemas.microsoft.com/xrm/2013/Metadata")]
public abstract class ConstantsBase<T> : IExtensibleDataObject

C++

J#

JScript

GenericParameters
T
  Remarks
There are two derived classes: AttributeTypeDisplayName and StringFormatName.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Metadata.ConstantsBase

                Microsoft.Xrm.Sdk.Metadata.AttributeTypeDisplayName

                Microsoft.Xrm.Sdk.Metadata.StringFormatName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstantsBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase Members
See Also Methods Properties Constructors Fields
[image]

A base class for static classes whose properties represent constants

The following tables list the members exposed by the ConstantsBase type.

Protected Constructors

Name | Description
ConstantsBase |
Top

Protected Fields

Name | Description
ValidValues |
Top

Public Properties

 | Name | Description
public property | ExtensionData |
public property | Value |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
 | Add |
 | Create |
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | ValueExistsInList | Indicates whether a value exists in the list.
Top

See Also

Reference

ConstantsBase Class
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase Fields
[image]

Protected Fields

Name | Description
ValidValues |

See Also

Reference

ConstantsBase Class
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase.ValidValues Field
[image]

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="The underlying value of the reference type is string which is immutable")> _
Protected Shared ReadOnly ValidValues As IList(Of T)

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="The underlying value of the reference type is string which is immutable")]
protected static readonly IList<T> ValidValues

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstantsBase Class
ConstantsBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase Constructor
[image]

Initializes a new instance of the ConstantsBase Class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected ConstantsBase ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstantsBase Class
ConstantsBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
 | Add |
 | Create |
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | ValueExistsInList | Indicates whether a value exists in the list.

See Also

Reference

ConstantsBase Class
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase.Add Method
[image]

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Shared Function Add(Of T2 As ConstantsBase(Of T)) ( _
    value As T _
) As T2

C#
protected static T2 Add<T2> (
    T value
) where T2 : ConstantsBase<T>

C++

J#

JScript

GenericParameters
T2
Parameters
value
Return Value
Returns IList.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstantsBase Class
ConstantsBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase.Create Method
[image]

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Shared Function Create(Of T2 As ConstantsBase(Of T)) ( _
    value As T _
) As T2

C#
protected static T2 Create<T2> (
    T value
) where T2 : ConstantsBase<T>

C++

J#

JScript

GenericParameters
T2
Parameters
value
Return Value
Returns IList.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstantsBase Class
ConstantsBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase.ValueExistsInList Method
[image]

Indicates whether a value exists in the list.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected MustOverride Function ValueExistsInList ( _
    value As T _
) As Boolean

C#
protected abstract bool ValueExistsInList (
    T value
)

C++

J#

JScript

Parameters
value
Return Value
Type: Boolean Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstantsBase Class
ConstantsBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData |
public property | Value |

See Also

Reference

ConstantsBase Class
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase.ExtensionData Property
[image]

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Returns ExtensionDataObject.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstantsBase Class
ConstantsBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


ConstantsBase.Value Property
[image]

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Value As T

C#
[DataMemberAttribute]
public T Value { get; set; }

C++

J#

JScript

Property Value
Returns ExtensionDataObject.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConstantsBase Class
ConstantsBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


DateTimeAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute of type DateTime.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DateTimeAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class DateTimeAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="DateTimeAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class DateTimeAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Remarks
A date and time attribute. You can format the attribute to show only the date or the date and the time.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.DateTimeAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata
Work with Attributes


DateTimeAttributeMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an attribute of type DateTime.

The following tables list the members exposed by the DateTimeAttributeMetadata type.

Public Constructors

Name | Description
DateTimeAttributeMetadata | Overloaded. Initializes a new instance of the DateTimeAttributeMetadata class
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | Format | Gets or sets the date/time display format.
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the input method editor (IME) mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
 | MaxSupportedValue | Gets the maximum supported value for this attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
 | MinSupportedValue | Gets the minimum supported value for this attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DateTimeAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


DateTimeAttributeMetadata Constructor
[image]

Initializes a new instance of the DateTimeAttributeMetadata class

Overload List

Name | Description
DateTimeAttributeMetadata () | Initializes a new instance of the DateTimeAttributeMetadata class
DateTimeAttributeMetadata (Nullable) | Initializes a new instance of the DateTimeAttributeMetadata class
DateTimeAttributeMetadata (Nullable, String) | Initializes a new instance of the DateTimeAttributeMetadata class

See Also

Reference

DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DateTimeAttributeMetadata Constructor ()
[image]

Initializes a new instance of the DateTimeAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DateTimeAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DateTimeAttributeMetadata Constructor (Nullable)
[image]

Initializes a new instance of the DateTimeAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    format As Nullable(Of DateTimeFormat) _
)

C#
public DateTimeAttributeMetadata (
    Nullable<DateTimeFormat> format
)

C++

J#

JScript

Parameters
format
Type: Nullable<DateTimeFormat>.
The date/time display format.
If this property is not assigned a value, it defaults to DateOnly.
  Remarks
Use the DateTimeFormat enumeration to set the format.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DateTimeAttributeMetadata Constructor (Nullable, String)
[image]

Initializes a new instance of the DateTimeAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    format As Nullable(Of DateTimeFormat), _
    schemaName As String _
)

C#
public DateTimeAttributeMetadata (
    Nullable<DateTimeFormat> format,
    string schemaName
)

C++

J#

JScript

Parameters
format
Type: Nullable<DateTimeFormat>.
The date/time display format.
If this property is not assigned a value, it defaults to DateOnly.
schemaName
Type: String.
The schema name of the attribute.
  Remarks
Use the DateTimeFormat enumeration to set the format.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DateTimeAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DateTimeAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


DateTimeAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | Format | Gets or sets the date/time display format.
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the input method editor (IME) mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
 | MaxSupportedValue | Gets the maximum supported value for this attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
 | MinSupportedValue | Gets the minimum supported value for this attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

See Also

Reference

DateTimeAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


DateTimeAttributeMetadata.Format Property
[image]

Gets or sets the date/time display format.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Format As Nullable(Of DateTimeFormat)

C#
[DataMemberAttribute]
public Nullable<DateTimeFormat> Format { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<DateTimeFormat>

The date/time display format.

  Remarks
If this property is not assigned a value, it defaults to DateOnly.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DateTimeAttributeMetadata.FormulaDefinition Property
[image]

Gets or sets the formula definition for calculated and rollup attributes.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property FormulaDefinition As String

C#
[DataMemberAttribute(Order=70)]
public string FormulaDefinition { get; set; }

C++

J#

JScript

Property Value
Type: String
The formula definition for calculated and rollup attributes.

  Remarks
To edit this property, you must use the formula editor in the application. More information:Customization Guide: Define Calculated Fields and Customization Guide: Define Rollup Fields.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes


DateTimeAttributeMetadata.ImeMode Property
[image]

Gets or sets the input method editor (IME) mode for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ImeMode As Nullable(Of ImeMode)

C#
[DataMemberAttribute]
public Nullable<ImeMode> ImeMode { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<ImeMode>

The input method editor mode for the attribute.

  Remarks
If this property is not assigned a value, it defaults to Inactive.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DateTimeAttributeMetadata.MaxSupportedValue Property
[image]

Gets the maximum supported value for this attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property MaxSupportedValue As DateTime

C#
public static DateTime MaxSupportedValue { get; }

C++

J#

JScript

Property Value
Type: DateTime
The maximum supported date for this attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DateTimeAttributeMetadata.MinSupportedValue Property
[image]

Gets the minimum supported value for this attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property MinSupportedValue As DateTime

C#
public static DateTime MinSupportedValue { get; }

C++

J#

JScript

Property Value
Type: DateTime
The minimum supported date for this attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DateTimeAttributeMetadata.SourceTypeMask Property
[image]

Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property SourceTypeMask As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=70)]
public Nullable<int> SourceTypeMask { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The value that indicates the source of data for a calculated or rollup attribute.

  Remarks
The following table contains the valid values for this attribute.
Value | Description
0 | Undefined: The default value for simple and rollup attributes.
1 | Simple: The calculated attribute refers to an attribute in the same record.
2 | Related: The calculated attribute refers to an attribute in a related record.
4 | Logical: The calculated attribute refers to an attribute in the same record that is actually stored in a different database table. More information:Logical attributes.
8 | Calculated: The calculated attribute refers to another calculated attribute.
16 | Rollup: The calculated attribute refers a rollup attribute.
32 | Invalid: The calculated or rollup attribute is invalid. Typically this would be where a field refers to an attribute that no longer exists.
The SourceTypeMasks enumeration is useful when performing bitwise operations to check whether specific values are present in this bitmask value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeAttributeMetadata Class
DateTimeAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes
SourceTypeMasks enumeration
Logical attributes


DateTimeFormat Enumeration
[image]

Describes the formatting of a DateTimeAttributeMetadata attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DateTimeFormat", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration DateTimeFormat

C#
[DataContractAttribute(Name="DateTimeFormat", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum DateTimeFormat

C++

J#

JScript

  Members
Member name | Description
DateAndTime | Display the date and time. Value = 1.
DateOnly | Display the date only. Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


DecimalAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute type Decimal.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DecimalAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class DecimalAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="DecimalAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class DecimalAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.DecimalAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata
Work with Attributes


DecimalAttributeMetadata Members
See Also Constructors Fields Methods Properties
[image]

Contains the metadata for an attribute type Decimal.

The following tables list the members exposed by the DecimalAttributeMetadata type.

Public Constructors

Name | Description
DecimalAttributeMetadata | Overloaded. Initializes a new instance of the DecimalAttributeMetadata class
Top

Public Fields

Name | Description
MaxSupportedPrecision | The maximum supported value for Precision is 10.
MaxSupportedValue | The maximum supported value is 100 Billion.
MinSupportedPrecision | The minimum supported value for Precision is 0.
MinSupportedValue | The minimum supported value is -100 Billion.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the input method editor (IME) mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | Precision | Gets or sets the precision for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DecimalAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


DecimalAttributeMetadata Fields
[image]

Public Fields

Name | Description
MaxSupportedPrecision | The maximum supported value for Precision is 10.
MaxSupportedValue | The maximum supported value is 100 Billion.
MinSupportedPrecision | The minimum supported value for Precision is 0.
MinSupportedValue | The minimum supported value is -100 Billion.

See Also

Reference

DecimalAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


DecimalAttributeMetadata.MaxSupportedPrecision Field
[image]

The maximum supported value for Precision is 10.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedPrecision As Integer

C#
public const int MaxSupportedPrecision

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata.MaxSupportedValue Field
[image]

The maximum supported value is 100 Billion.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedValue As Double

C#
public const double MaxSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata.MinSupportedPrecision Field
[image]

The minimum supported value for Precision is 0.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedPrecision As Integer

C#
public const int MinSupportedPrecision

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata.MinSupportedValue Field
[image]

The minimum supported value is -100 Billion.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedValue As Double

C#
public const double MinSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata Constructor
[image]

Initializes a new instance of the DecimalAttributeMetadata class

Overload List

Name | Description
DecimalAttributeMetadata () | Initializes a new instance of the DecimalAttributeMetadata class
DecimalAttributeMetadata (String) | Initializes a new instance of the DecimalAttributeMetadata class

See Also

Reference

DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata Constructor ()
[image]

Initializes a new instance of the DecimalAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DecimalAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the DecimalAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public DecimalAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name of the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DecimalAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


DecimalAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the input method editor (IME) mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | Precision | Gets or sets the precision for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

See Also

Reference

DecimalAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


DecimalAttributeMetadata.FormulaDefinition Property
[image]

Gets or sets the formula definition for calculated and rollup attributes.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property FormulaDefinition As String

C#
[DataMemberAttribute(Order=70)]
public string FormulaDefinition { get; set; }

C++

J#

JScript

Property Value
Type: String
The formula definition for calculated and rollup attributes.

  Remarks
To edit this property, you must use the formula editor in the application. More information:Customization Guide: Define Calculated Fields and Customization Guide: Define Rollup Fields.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes


DecimalAttributeMetadata.ImeMode Property
[image]

Gets or sets the input method editor (IME) mode for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ImeMode As Nullable(Of ImeMode)

C#
[DataMemberAttribute]
public Nullable<ImeMode> ImeMode { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<ImeMode>

The input method editor (IME) mode for the attribute..

  Remarks
If this property is not assigned a value, it defaults to Disabled

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata.MaxValue Property
[image]

Gets or sets the maximum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxValue As Nullable(Of Decimal)

C#
[DataMemberAttribute]
public Nullable<decimal> MaxValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Decimal>

The maximum value for the attribute.

  Remarks
Possible values are -100 billion to  100 billion.
If this property is not assigned a value, it defaults to 1000000000.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata.MinValue Property
[image]

Gets or sets the minimum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MinValue As Nullable(Of Decimal)

C#
[DataMemberAttribute]
public Nullable<decimal> MinValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Decimal>

The minimum value for the attribute.

  Remarks
Possible values are -100 billion to  100 billion.

                        If this property is not assigned a value, it defaults to 0.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata.Precision Property
[image]

Gets or sets the precision for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Precision As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> Precision { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The precision for the attribute.

  Remarks
Possible values are 1-10.

                        If this property is not assigned a value, it defaults to 2.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DecimalAttributeMetadata.SourceTypeMask Property
[image]

Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property SourceTypeMask As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=70)]
public Nullable<int> SourceTypeMask { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The value that indicates the source of data for a calculated or rollup attribute.

  Remarks
The following table contains the valid values for this attribute.
Value | Description
0 | Undefined: The default value for simple and rollup attributes.
1 | Simple: The calculated attribute refers to an attribute in the same record.
2 | Related: The calculated attribute refers to an attribute in a related record.
4 | Logical: The calculated attribute refers to an attribute in the same record that is actually stored in a different database table. More information:Logical attributes.
8 | Calculated: The calculated attribute refers to another calculated attribute.
16 | Rollup: The calculated attribute refers a rollup attribute.
32 | Invalid: The calculated or rollup attribute is invalid. Typically this would be where a field refers to an attribute that no longer exists.
The SourceTypeMasks enumeration is useful when performing bitwise operations to check whether specific values are present in this bitmask value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DecimalAttributeMetadata Class
DecimalAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes
SourceTypeMasks enumeration
Logical attributes


DoubleAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute type Double.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="DoubleAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class DoubleAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="DoubleAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class DoubleAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.DoubleAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata Members
See Also Constructors Fields Methods Properties
[image]

Contains the metadata for an attribute type Double.

The following tables list the members exposed by the DoubleAttributeMetadata type.

Public Constructors

Name | Description
DoubleAttributeMetadata | Overloaded. Initializes a new instance of the DoubleAttributeMetadata class
Top

Public Fields

Name | Description
MaxSupportedPrecision | The maximum supported value for Precision is 5.
MaxSupportedValue | The maximum supported value is 100 billion.
MinSupportedPrecision | The minimum supported value for Precision is 0.
MinSupportedValue | The minimum supported value is -100 billion.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the input method editor (IME) mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | Precision | Gets or sets the precision for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DoubleAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata Fields
[image]

Public Fields

Name | Description
MaxSupportedPrecision | The maximum supported value for Precision is 5.
MaxSupportedValue | The maximum supported value is 100 billion.
MinSupportedPrecision | The minimum supported value for Precision is 0.
MinSupportedValue | The minimum supported value is -100 billion.

See Also

Reference

DoubleAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata.MaxSupportedPrecision Field
[image]

The maximum supported value for Precision is 5.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedPrecision As Integer

C#
public const int MaxSupportedPrecision

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata.MaxSupportedValue Field
[image]

The maximum supported value is 100 billion.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedValue As Double

C#
public const double MaxSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata.MinSupportedPrecision Field
[image]

The minimum supported value for Precision is 0.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedPrecision As Integer

C#
public const int MinSupportedPrecision

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata.MinSupportedValue Field
[image]

The minimum supported value is -100 billion.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedValue As Double

C#
public const double MinSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata Constructor
[image]

Initializes a new instance of the DoubleAttributeMetadata class

Overload List

Name | Description
DoubleAttributeMetadata () | Initializes a new instance of the DoubleAttributeMetadata class
DoubleAttributeMetadata (String) | Initializes a new instance of the DoubleAttributeMetadata class

See Also

Reference

DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata Constructor ()
[image]

Initializes a new instance of the DoubleAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DoubleAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the DoubleAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public DoubleAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name for the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DoubleAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the input method editor (IME) mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | Precision | Gets or sets the precision for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)

See Also

Reference

DoubleAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata.ImeMode Property
[image]

Gets or sets the input method editor (IME) mode for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ImeMode As Nullable(Of ImeMode)

C#
[DataMemberAttribute]
public Nullable<ImeMode> ImeMode { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<ImeMode>

The input method editor (IME) mode for the attribute..

  Remarks
If this property is not assigned a value, it defaults to Disabled

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata.MaxValue Property
[image]

Gets or sets the maximum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxValue As Nullable(Of Double)

C#
[DataMemberAttribute]
public Nullable<double> MaxValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Double>

The maximum value for the attribute.

  Remarks
If this property is not assigned a value, it defaults to 1000000000

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata.MinValue Property
[image]

Gets or sets the minimum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MinValue As Nullable(Of Double)

C#
[DataMemberAttribute]
public Nullable<double> MinValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Double>

The minimum value for the attribute.

  Remarks
If this property is not assigned a value, it defaults to 0.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


DoubleAttributeMetadata.Precision Property
[image]

Gets or sets the precision for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Precision As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> Precision { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The precision for the attribute.

  Remarks

                        If this property is not assigned a value, it defaults to2.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DoubleAttributeMetadata Class
DoubleAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityFilters Enumeration
[image]

Describes the type of entity metadata to retrieve.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FlagsAttribute> _
<DataContractAttribute(Name:="EntityFilters", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration EntityFilters

C#
[FlagsAttribute]
[DataContractAttribute(Name="EntityFilters", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum EntityFilters

C++

J#

JScript

  Members
Member name | Description
All | Use this to retrieve all data for an entity. Value = 15.
Attributes | Use this to retrieve entity information plus attributes for the entity. Value = 2.
Default | Use this to retrieve only entity information. Equivalent to EntityFilters.Entity. Value = 1.
Entity | Use this to retrieve only entity information. Equivalent to EntityFilters.Default. Value = 1.
Privileges | Use this to retrieve entity information plus privileges for the entity. Value = 4.
Relationships | Use this to retrieve entity information plus entity relationships for the entity. Value = 8.
  Remarks
Use this enumeration with RetrieveAllEntitiesRequest and RetrieveEntityRequest.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Sample: Dump Entity Metadata to a File


EntityMetadata Class
See Also Members
[image]

Contains the metadata for an entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EntityMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class EntityMetadata
    Inherits MetadataBase

C#
[DataContractAttribute(Name="EntityMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class EntityMetadata : MetadataBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase
    Microsoft.Xrm.Sdk.Metadata.EntityMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Metadata
Sample: Create and Update Entity Metadata
Sample: Dump Entity Metadata to a File
Sample: Retrieve Entity Metadata Using JavaScript


EntityMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an entity.

The following tables list the members exposed by the EntityMetadata type.

Public Constructors

Name | Description
EntityMetadata | Initializes a new instance of the EntityMetadata class
Top

Public Properties

 | Name | Description
public property | ActivityTypeMask | Gets or sets whether a custom activity should appear in the activity menus in the Web application.
public property | Attributes | Gets the array of attribute metadata for the entity.
public property | AutoCreateAccessTeams | Gets or sets whether the entity is enabled for auto created access teams.
public property | AutoRouteToOwnerQueue | Gets or sets whether to automatically move records to the owner’s default queue when a record of this type is created or assigned.
public property | CanBeInManyToMany | Gets the property that determines whether the entity can be in a Many-to-Many entity relationship.
public property | CanBePrimaryEntityInRelationship | Gets the property that determines whether the entity can be the referenced entity in a One-to-Many entity relationship.
public property | CanBeRelatedEntityInRelationship | Gets the property that determines whether the entity can be the referencing entity in a One-to-Many entity relationship.
public property | CanChangeHierarchicalRelationship | Gets or sets whether the hierarchical state of entity relationships included in your managed solutions can be changed.
public property | CanCreateAttributes | Gets or sets the property that determines whether additional attributes can be added to the entity.
public property | CanCreateCharts | Gets or sets the property that determines whether new charts can be created for the entity.
public property | CanCreateForms | Gets or sets the property that determines whether new forms can be created for the entity.
public property | CanCreateViews | Gets or sets the property that determines whether new views can be created for the entity.
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any other entity properties not represented by a managed property can be changed.
public property | CanTriggerWorkflow | Gets whether the entity can trigger a workflow process.
public property | Description | Gets or sets the label containing the description for the entity.
public property | DisplayCollectionName | Gets or sets the label containing the plural display name for the entity.
public property | DisplayName | Gets or sets the label containing the display name for the entity.
public property | EnforceStateTransitions | Gets whether the entity will enforce custom state transitions.
public property | EntityHelpUrl | Gets or sets the URL of the resource to display help content for this entity
public property | EntityHelpUrlEnabled | Gets or sets whether the entity supports custom help content.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IconLargeName | Gets or sets the name of the image web resource for the large icon for the entity.
public property | IconMediumName | Gets or sets the name of the image web resource for the medium icon for the entity.
public property | IconSmallName | Gets or sets the name of the image web resource for the small icon for the entity.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsActivity | Gets or sets whether the entity is an activity.
public property | IsActivityParty | Gets or sets whether the email messages can be sent to an email address stored in a record of this type.
public property | IsAIRUpdated | Gets whether the entity uses the updated user interface.
public property | IsAuditEnabled | Gets or sets the property that determines whether auditing has been enabled for the entity.
public property | IsAvailableOffline | Gets or sets whether the entity is available offline.
public property | IsBusinessProcessEnabled | Gets whether the entity is enabled for business process flows.
public property | IsChildEntity | Gets whether the entity is a child entity.
public property | IsConnectionsEnabled | Gets or sets the property that determines whether connections are enabled for this entity.
public property | IsCustomEntity | Gets whether the entity is a custom entity.
public property | IsCustomizable | Gets or sets the property that determines whether the entity is customizable.
public property | IsDocumentManagementEnabled | Gets or sets the property that determines whether document management is enabled.
public property | IsDuplicateDetectionEnabled | Gets or sets the property that determines whether duplicate detection is enabled.
public property | IsEnabledForCharts | Gets whether charts are enabled.
public property | IsEnabledForTrace | For internal use only.
public property | IsImportable | Gets whether the entity can be imported using the Import Wizard.
public property | IsIntersect | Gets whether the entity is an intersection table for two other entities.
public property | IsMailMergeEnabled | Gets or sets the property that determines whether mail merge is enabled for this entity.
public property | IsManaged | Gets whether the entity is part of a managed solution.
public property | IsMappable | Gets or sets the property that determines whether entity mapping is available for the entity.
public property | IsQuickCreateEnabled | Gets or sets the value indicating if the entity is enabled for quick create forms.
public property | IsReadingPaneEnabled | For internal use only.
public property | IsReadOnlyInMobileClient | Gets or sets the property that determines whether Microsoft Dynamics CRM for tablets users can update data for this entity.
public property | IsRenameable | Gets or sets the property that determines whether the entity DisplayName and DisplayCollectionName can be changed by editing the entity in the application.
public property | IsStateModelAware | Gets whether the entity supports setting custom state transitions.
public property | IsValidForAdvancedFind | Gets or sets whether the entity is will be shown in Advanced Find.
public property | IsValidForQueue | Gets or sets the property that determines whether the entity is enabled for queues.
public property | IsVisibleInMobile | Gets or sets the property that determines whether Microsoft Dynamics CRM for phones users can see data for this entity.
public property | IsVisibleInMobileClient | Gets or sets the property that determines whether Microsoft Dynamics CRM for tablets users can see data for this entity.
public property | LogicalName | Gets or sets the logical name for the entity.
public property | ManyToManyRelationships | Gets the array of many-to-many relationships for the entity.
public property | ManyToOneRelationships | Gets the array of many-to-one relationships for the entity.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | ObjectTypeCode | Gets the entity type code.
public property | OneToManyRelationships | Gets the array of one-to-many relationships for the entity.
public property | OwnershipType | Gets or sets the ownership type for the entity.
public property | PrimaryIdAttribute | Gets the name of the attribute that is the primary id for the entity.
public property | PrimaryImageAttribute | Gets the name of the primary image attribute for an entity.
public property | PrimaryNameAttribute | Gets the name of the primary attribute for an entity.
public property | Privileges | Gets the privilege metadata for the entity.
public property | RecurrenceBaseEntityLogicalName | Gets the name of the entity that is recurring.
public property | ReportViewName | Gets the name of the report view for the entity.
public property | SchemaName | Gets or sets the schema name for the entity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EntityMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Metadata
Sample: Create and Update Entity Metadata
Sample: Dump Entity Metadata to a File
Sample: Retrieve Entity Metadata Using JavaScript


EntityMetadata Constructor
[image]

Initializes a new instance of the EntityMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EntityMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Metadata
Sample: Create and Update Entity Metadata
Sample: Dump Entity Metadata to a File
Sample: Retrieve Entity Metadata Using JavaScript


EntityMetadata Properties
[image]

Public Properties

 | Name | Description
public property | ActivityTypeMask | Gets or sets whether a custom activity should appear in the activity menus in the Web application.
public property | Attributes | Gets the array of attribute metadata for the entity.
public property | AutoCreateAccessTeams | Gets or sets whether the entity is enabled for auto created access teams.
public property | AutoRouteToOwnerQueue | Gets or sets whether to automatically move records to the owner’s default queue when a record of this type is created or assigned.
public property | CanBeInManyToMany | Gets the property that determines whether the entity can be in a Many-to-Many entity relationship.
public property | CanBePrimaryEntityInRelationship | Gets the property that determines whether the entity can be the referenced entity in a One-to-Many entity relationship.
public property | CanBeRelatedEntityInRelationship | Gets the property that determines whether the entity can be the referencing entity in a One-to-Many entity relationship.
public property | CanChangeHierarchicalRelationship | Gets or sets whether the hierarchical state of entity relationships included in your managed solutions can be changed.
public property | CanCreateAttributes | Gets or sets the property that determines whether additional attributes can be added to the entity.
public property | CanCreateCharts | Gets or sets the property that determines whether new charts can be created for the entity.
public property | CanCreateForms | Gets or sets the property that determines whether new forms can be created for the entity.
public property | CanCreateViews | Gets or sets the property that determines whether new views can be created for the entity.
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any other entity properties not represented by a managed property can be changed.
public property | CanTriggerWorkflow | Gets whether the entity can trigger a workflow process.
public property | Description | Gets or sets the label containing the description for the entity.
public property | DisplayCollectionName | Gets or sets the label containing the plural display name for the entity.
public property | DisplayName | Gets or sets the label containing the display name for the entity.
public property | EnforceStateTransitions | Gets whether the entity will enforce custom state transitions.
public property | EntityHelpUrl | Gets or sets the URL of the resource to display help content for this entity
public property | EntityHelpUrlEnabled | Gets or sets whether the entity supports custom help content.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IconLargeName | Gets or sets the name of the image web resource for the large icon for the entity.
public property | IconMediumName | Gets or sets the name of the image web resource for the medium icon for the entity.
public property | IconSmallName | Gets or sets the name of the image web resource for the small icon for the entity.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsActivity | Gets or sets whether the entity is an activity.
public property | IsActivityParty | Gets or sets whether the email messages can be sent to an email address stored in a record of this type.
public property | IsAIRUpdated | Gets whether the entity uses the updated user interface.
public property | IsAuditEnabled | Gets or sets the property that determines whether auditing has been enabled for the entity.
public property | IsAvailableOffline | Gets or sets whether the entity is available offline.
public property | IsBusinessProcessEnabled | Gets whether the entity is enabled for business process flows.
public property | IsChildEntity | Gets whether the entity is a child entity.
public property | IsConnectionsEnabled | Gets or sets the property that determines whether connections are enabled for this entity.
public property | IsCustomEntity | Gets whether the entity is a custom entity.
public property | IsCustomizable | Gets or sets the property that determines whether the entity is customizable.
public property | IsDocumentManagementEnabled | Gets or sets the property that determines whether document management is enabled.
public property | IsDuplicateDetectionEnabled | Gets or sets the property that determines whether duplicate detection is enabled.
public property | IsEnabledForCharts | Gets whether charts are enabled.
public property | IsEnabledForTrace | For internal use only.
public property | IsImportable | Gets whether the entity can be imported using the Import Wizard.
public property | IsIntersect | Gets whether the entity is an intersection table for two other entities.
public property | IsMailMergeEnabled | Gets or sets the property that determines whether mail merge is enabled for this entity.
public property | IsManaged | Gets whether the entity is part of a managed solution.
public property | IsMappable | Gets or sets the property that determines whether entity mapping is available for the entity.
public property | IsQuickCreateEnabled | Gets or sets the value indicating if the entity is enabled for quick create forms.
public property | IsReadingPaneEnabled | For internal use only.
public property | IsReadOnlyInMobileClient | Gets or sets the property that determines whether Microsoft Dynamics CRM for tablets users can update data for this entity.
public property | IsRenameable | Gets or sets the property that determines whether the entity DisplayName and DisplayCollectionName can be changed by editing the entity in the application.
public property | IsStateModelAware | Gets whether the entity supports setting custom state transitions.
public property | IsValidForAdvancedFind | Gets or sets whether the entity is will be shown in Advanced Find.
public property | IsValidForQueue | Gets or sets the property that determines whether the entity is enabled for queues.
public property | IsVisibleInMobile | Gets or sets the property that determines whether Microsoft Dynamics CRM for phones users can see data for this entity.
public property | IsVisibleInMobileClient | Gets or sets the property that determines whether Microsoft Dynamics CRM for tablets users can see data for this entity.
public property | LogicalName | Gets or sets the logical name for the entity.
public property | ManyToManyRelationships | Gets the array of many-to-many relationships for the entity.
public property | ManyToOneRelationships | Gets the array of many-to-one relationships for the entity.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | ObjectTypeCode | Gets the entity type code.
public property | OneToManyRelationships | Gets the array of one-to-many relationships for the entity.
public property | OwnershipType | Gets or sets the ownership type for the entity.
public property | PrimaryIdAttribute | Gets the name of the attribute that is the primary id for the entity.
public property | PrimaryImageAttribute | Gets the name of the primary image attribute for an entity.
public property | PrimaryNameAttribute | Gets the name of the primary attribute for an entity.
public property | Privileges | Gets the privilege metadata for the entity.
public property | RecurrenceBaseEntityLogicalName | Gets the name of the entity that is recurring.
public property | ReportViewName | Gets the name of the report view for the entity.
public property | SchemaName | Gets or sets the schema name for the entity.

See Also

Reference

EntityMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Metadata
Sample: Create and Update Entity Metadata
Sample: Dump Entity Metadata to a File
Sample: Retrieve Entity Metadata Using JavaScript


EntityMetadata.ActivityTypeMask Property
[image]

Gets or sets whether a custom activity should appear in the activity menus in the Web application.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ActivityTypeMask As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> ActivityTypeMask { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The value indicates whether a custom activity should appear in the activity menus in the Web application.

  Remarks
For a custom activity the default value is 1. This means that the custom activity is available in activity menus. Set this property to 0 at the creation of a custom activity to prevent displaying it in the activity menus. This value cannot be updated after the custom activity is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Custom Activities in Microsoft Dynamics CRM
Sample: Create a Custom Activity Entity


EntityMetadata.Attributes Property
[image]

Gets the array of attribute metadata for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")> _
Public Property Attributes As AttributeMetadata()

C#
[DataMemberAttribute]
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")]
public AttributeMetadata[] Attributes { get; }

C++

J#

JScript

Property Value
Type: AttributeMetadata[]
The array of attribute metadata for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.AutoCreateAccessTeams Property
[image]

Gets or sets whether the entity is enabled for auto created access teams.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AutoCreateAccessTeams As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> AutoCreateAccessTeams { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity will be enabled for auto created access teams; otherwise, false.

  Remarks
For more information about access teams, see Use Teams to Collaborate and Share Information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.AutoRouteToOwnerQueue Property
[image]

Gets or sets whether to automatically move records to the owner’s default queue when a record of this type is created or assigned.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AutoRouteToOwnerQueue As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> AutoRouteToOwnerQueue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the record will automatically move to the owner’s default queue when a record of this type is created or assigned; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.CanBeInManyToMany Property
[image]

Gets the property that determines whether the entity can be in a Many-to-Many entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeInManyToMany As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty CanBeInManyToMany { get; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the entity can be in a Many-to-Many entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.CanBePrimaryEntityInRelationship Property
[image]

Gets the property that determines whether the entity can be the referenced entity in a One-to-Many entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBePrimaryEntityInRelationship As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty CanBePrimaryEntityInRelationship { get; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the entity can be the referenced entity in a One-to-Many entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.CanBeRelatedEntityInRelationship Property
[image]

Gets the property that determines whether the entity can be the referencing entity in a One-to-Many entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeRelatedEntityInRelationship As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty CanBeRelatedEntityInRelationship { get; }

C++

J#

JScript

Property Value
Type: BooleanManagedPropertyThe property that determines whether the entity can be the referencing entity in a One-to-Many entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.CanChangeHierarchicalRelationship Property
[image]

Gets or sets whether the hierarchical state of entity relationships included in your managed solutions can be changed.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property CanChangeHierarchicalRelationship As BooleanManagedProperty

C#
[DataMemberAttribute(Order=70)]
public BooleanManagedProperty CanChangeHierarchicalRelationship { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the hierarchical state of entity relationships included in your managed solutions can be changed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.CanCreateAttributes Property
[image]

Gets or sets the property that determines whether additional attributes can be added to the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanCreateAttributes As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty CanCreateAttributes { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether additional attributes can be added to the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.CanCreateCharts Property
[image]

Gets or sets the property that determines whether new charts can be created for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanCreateCharts As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty CanCreateCharts { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether new charts can be created for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.CanCreateForms Property
[image]

Gets or sets the property that determines whether new forms can be created for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanCreateForms As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty CanCreateForms { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether new forms can be created for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.CanCreateViews Property
[image]

Gets or sets the property that determines whether new views can be created for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanCreateViews As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty CanCreateViews { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether new views can be created for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.CanModifyAdditionalSettings Property
[image]

Gets or sets the property that determines whether any other entity properties not represented by a managed property can be changed.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanModifyAdditionalSettings As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty CanModifyAdditionalSettings { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether any other entity properties not represented by a managed property can be changed.

  Remarks
Set this property to false if you want to prevent changes to the following properties when the Entity is added as part of a managed solution.
Property | Description
HasActivities | This is a property of the CreateEntityRequest and UpdateEntityRequest that creates a special entity relationship with the ActivityPointer (Activity) Entity that allows activities to be associated with the entity.
HasNotes | This is a property of the CreateEntityRequest and UpdateEntityRequest that creates a special entity relationship to the Annotation (Note) Entity that allows notes to be associated with the entity.
IsAvailableOffline | This property allows users of Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access to access entity records while offline.
IsDocumentManagementEnabled | This property allows documents in an organization with an integrated Sharepoint instance to be associated with this entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.CanTriggerWorkflow Property
[image]

Gets whether the entity can trigger a workflow process.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanTriggerWorkflow As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> CanTriggerWorkflow { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity can trigger a workflow process; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.Description Property
[image]

Gets or sets the label containing the description for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Description As Label

C#
[DataMemberAttribute]
public Label Description { get; set; }

C++

J#

JScript

Property Value
Type: Label
The label containing the description for the entity.

  Remarks
Sample: Create and Update Entity Metadata

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.DisplayCollectionName Property
[image]

Gets or sets the label containing the plural display name for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DisplayCollectionName As Label

C#
[DataMemberAttribute]
public Label DisplayCollectionName { get; set; }

C++

J#

JScript

Property Value
Type: Label
The label containing the plural display name for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.DisplayName Property
[image]

Gets or sets the label containing the display name for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DisplayName As Label

C#
[DataMemberAttribute]
public Label DisplayName { get; set; }

C++

J#

JScript

Property Value
Type Label
The label containing the display name for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.EnforceStateTransitions Property
[image]

Gets whether the entity will enforce custom state transitions.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EnforceStateTransitions As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> EnforceStateTransitions { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity supports custom status transitions.; otherwise, false.

  Remarks
This property can only be set using the application. More information:Define custom state model transitions.
Incident (case) is the only system entity that supports custom state transitions. Custom entities may also support custom state transitions. The definitions for the allowed transitions are stored in the StatusOptionMetadata.TransitionData property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.EntityHelpUrl Property
[image]

Gets or sets the URL of the resource to display help content for this entity

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
<SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification:="This url string will be saved in database")> _
Public Property EntityHelpUrl As String

C#
[DataMemberAttribute(Order=70)]
[SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification="This url string will be saved in database")]
public string EntityHelpUrl { get; set; }

C++

J#

JScript

Property Value
Type: String

The URL of the resource to display help content for this entity

  Remarks

                        More information:
                        Add custom help content.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.EntityHelpUrlEnabled Property
[image]

Gets or sets whether the entity supports custom help content.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property EntityHelpUrlEnabled As Nullable(Of Boolean)

C#
[DataMemberAttribute(Order=70)]
public Nullable<bool> EntityHelpUrlEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity supports custom help content.; otherwise, false.

  Remarks

                        More information:
                        Add custom help content.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IconLargeName Property
[image]

Gets or sets the name of the image web resource for the large icon for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IconLargeName As String

C#
[DataMemberAttribute]
public string IconLargeName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the image web resource for the large icon for the entity..

  Remarks
This size icon is not currently used by the application.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Modify Icons for an Entity


EntityMetadata.IconMediumName Property
[image]

Gets or sets the name of the image web resource for the medium icon for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IconMediumName As String

C#
[DataMemberAttribute]
public string IconMediumName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the image web resource for the medium icon for the entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Modify Icons for an Entity


EntityMetadata.IconSmallName Property
[image]

Gets or sets the name of the image web resource for the small icon for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IconSmallName As String

C#
[DataMemberAttribute]
public string IconSmallName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the image web resource for the small icon for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Modify Icons for an Entity


EntityMetadata.IntroducedVersion Property
[image]

Gets a string identifying the solution version that the solution component was added in.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property IntroducedVersion As String

C#
[DataMemberAttribute(Order=60)]
public string IntroducedVersion { get; }

C++

J#

JScript

Property Value
Type: String

A string identifying the solution version that the solution component was added in.

  Remarks

                        This identifies the major and minor versions of the solution that added this metadata item. For metadata that existed in Microsoft Dynamics CRM 2011 the value will be 5.0.0.0 and for metadata added with Microsoft Dynamics CRM 2013 the value will be 6.0.0.0. If new metadata is added in updates or future releases the version number will be incremented to the corresponding version. For metadata added by custom solutions the version of the solution that the item was created it is used.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsActivity Property
[image]

Gets or sets whether the entity is an activity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsActivity As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsActivity { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity is an activity; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsActivityParty Property
[image]

Gets or sets whether the email messages can be sent to an email address stored in a record of this type.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsActivityParty As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsActivityParty { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if emails can be sent to an email address stored in a record of this type; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Create and Update an Emailable Entity


EntityMetadata.IsAIRUpdated Property
[image]

Gets whether the entity uses the updated user interface.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
<SuppressMessageAttribute("Microsoft.Naming", "CA1709:IdentifiersShouldBeCasedCorrectly", MessageId:="", Justification:="AIR is abbrevation so should be upper cased")> _
Public Property IsAIRUpdated As Nullable(Of Boolean)

C#
[DataMemberAttribute]
[SuppressMessageAttribute("Microsoft.Naming", "CA1709:IdentifiersShouldBeCasedCorrectly", MessageId="", Justification="AIR is abbrevation so should be upper cased")]
public Nullable<bool> IsAIRUpdated { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity uses the updated user interface; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsAuditEnabled Property
[image]

Gets or sets the property that determines whether auditing has been enabled for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsAuditEnabled As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsAuditEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<BooleanManagedProperty>
The property that determines whether auditing has been enabled for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Configure Entities and Attributes for Auditing


EntityMetadata.IsAvailableOffline Property
[image]

Gets or sets whether the entity is available offline.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsAvailableOffline As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsAvailableOffline { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity is available offline; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsBusinessProcessEnabled Property
[image]

Gets whether the entity is enabled for business process flows.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsBusinessProcessEnabled As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsBusinessProcessEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if; the entity is enabled for business process flows otherwise, false.

  Remarks
See Model business process flows for more information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsChildEntity Property
[image]

Gets whether the entity is a child entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsChildEntity As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsChildEntity { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity is a child entity; otherwise, false.

  Remarks
A child entity is an entity that inherits security from a parent. There are no privileges associated with child entities. For example InvoiceDetail is a child entity of Invoice. If you can create Invoice records you can create InvoiceDetail records. Most child entities represent line items for the parent. The following table contains the child entities in Microsoft Dynamics CRM 2011.
activityparty | annualfiscalcalendar | bulkdeletefailure
bulkdeleteoperation | bulkoperationlog | calendarrule
connectionroleobjecttypecode | contractdetail | discount
duplicaterecord | duplicaterulecondition | emailhash
fieldpermission | fixedmonthlyfiscalcalendar | invoicedetail
kbarticlecomment | monthlyfiscalcalendar | opportunityproduct
productpricelevel | quarterlyfiscalcalendar | queueitem
quotedetail | relationshiprolemap | reportcategory
reportentity | reportlink | reportvisibility
rollupfield | salesliteratureitem | salesorderdetail
semiannualfiscalcalendar | uom | userfiscalcalendar
workflowdependency | workflowwaitsubscription |

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsConnectionsEnabled Property
[image]

Gets or sets the property that determines whether connections are enabled for this entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsConnectionsEnabled As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsConnectionsEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<BooleanManagedProperty>
The property that determines whether connections are enabled for this entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Connection Entities


EntityMetadata.IsCustomEntity Property
[image]

Gets whether the entity is a custom entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsCustomEntity As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsCustomEntity { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity is a custom entity; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsCustomizable Property
[image]

Gets or sets the property that determines whether the entity is customizable.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsCustomizable As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsCustomizable { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the entity is customizable.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.IsDocumentManagementEnabled Property
[image]

Gets or sets the property that determines whether document management is enabled.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsDocumentManagementEnabled As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsDocumentManagementEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
The property that determines whether document management is enabled..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Enable Document Management for Entities


EntityMetadata.IsDuplicateDetectionEnabled Property
[image]

Gets or sets the property that determines whether duplicate detection is enabled.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsDuplicateDetectionEnabled As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsDuplicateDetectionEnabled { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether duplicate detection is enabled..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Detect Duplicate Data in Microsoft Dynamics CRM


EntityMetadata.IsEnabledForCharts Property
[image]

Gets whether charts are enabled.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsEnabledForCharts As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsEnabledForCharts { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if charts are enabled; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsEnabledForTrace Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsEnabledForTrace As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsEnabledForTrace { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsImportable Property
[image]

Gets whether the entity can be imported using the Import Wizard.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsImportable As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsImportable { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity can be imported using the Import Wizard; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Import Data in Microsoft Dynamics CRM


EntityMetadata.IsIntersect Property
[image]

Gets whether the entity is an intersection table for two other entities.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsIntersect As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsIntersect { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity is an intersection table for two other entities.; otherwise, false
  Remarks
Sample: Create and Retrieve Entity Relationships

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsMailMergeEnabled Property
[image]

Gets or sets the property that determines whether mail merge is enabled for this entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsMailMergeEnabled As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsMailMergeEnabled { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether mail merge is enabled for this entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsManaged Property
[image]

Gets whether the entity is part of a managed solution.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsManaged As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsManaged { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity is part of a managed solution; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Unmanaged and Managed Solutions


EntityMetadata.IsMappable Property
[image]

Gets or sets the property that determines whether entity mapping is available for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsMappable As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsMappable { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether entity mapping is available for the entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity and Attribute Mappings
Use Managed Properties


EntityMetadata.IsQuickCreateEnabled Property
[image]

Gets or sets the value indicating if the entity is enabled for quick create forms.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsQuickCreateEnabled As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsQuickCreateEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity is enabled for quick create forms ; otherwise, false.

  Remarks
For activity entities or any system entities where IsAIRUpdated is false, setting this value to true will not enable quick create forms.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsReadingPaneEnabled Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsReadingPaneEnabled As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsReadingPaneEnabled { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsReadOnlyInMobileClient Property
[image]

Gets or sets the property that determines whether Microsoft Dynamics CRM for tablets users can update data for this entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsReadOnlyInMobileClient As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsReadOnlyInMobileClient { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether Microsoft Dynamics CRM for tablets users can update data for this entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.IsRenameable Property
[image]

Gets or sets the property that determines whether the entity DisplayName and DisplayCollectionName can be changed by editing the entity in the application.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsRenameable As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsRenameable { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the entity DisplayName and DisplayCollectionName can be changed by editing the entity in the application.

  Remarks
The labels for the display names can be updated programmatically even when this property is set to false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.IsStateModelAware Property
[image]

Gets whether the entity supports setting custom state transitions.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsStateModelAware As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsStateModelAware { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity supports custom status transitions.; otherwise, false.

  Remarks
The incident (case) entity is the only system entity that supports custom status transitions. Custom entities are also state model aware. More information:Define custom state model transitions.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsValidForAdvancedFind Property
[image]

Gets or sets whether the entity is will be shown in Advanced Find.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsValidForAdvancedFind As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsValidForAdvancedFind { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity is will be shown in Advanced Find.; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.IsValidForQueue Property
[image]

Gets or sets the property that determines whether the entity is enabled for queues.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsValidForQueue As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsValidForQueue { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the entity is enabled for queues.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties
Enabling Entities for Queues


EntityMetadata.IsVisibleInMobile Property
[image]

Gets or sets the property that determines whether Microsoft Dynamics CRM for phones users can see data for this entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsVisibleInMobile As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsVisibleInMobile { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether Microsoft Dynamics CRM for phones users can see data for this entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.IsVisibleInMobileClient Property
[image]

Gets or sets the property that determines whether Microsoft Dynamics CRM for tablets users can see data for this entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsVisibleInMobileClient As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsVisibleInMobileClient { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether Microsoft Dynamics CRM for tablets users can see data for this entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


EntityMetadata.LogicalName Property
[image]

Gets or sets the logical name for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LogicalName As String

C#
[DataMemberAttribute]
public string LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.ManyToManyRelationships Property
[image]

Gets the array of many-to-many relationships for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")> _
<DataMemberAttribute> _
Public Property ManyToManyRelationships As ManyToManyRelationshipMetadata()

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")]
[DataMemberAttribute]
public ManyToManyRelationshipMetadata[] ManyToManyRelationships { get; }

C++

J#

JScript

Property Value
Type: ManyToManyRelationshipMetadata[]
the array of many-to-many relationships for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.ManyToOneRelationships Property
[image]

Gets the array of many-to-one relationships for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")> _
<DataMemberAttribute> _
Public Property ManyToOneRelationships As OneToManyRelationshipMetadata()

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")]
[DataMemberAttribute]
public OneToManyRelationshipMetadata[] ManyToOneRelationships { get; }

C++

J#

JScript

Property Value
Returns OneToManyRelationshipMetadata[].

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.ObjectTypeCode Property
[image]

Gets the entity type code.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ObjectTypeCode As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> ObjectTypeCode { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The entity type code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.OneToManyRelationships Property
[image]

Gets the array of one-to-many relationships for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")> _
<DataMemberAttribute> _
Public Property OneToManyRelationships As OneToManyRelationshipMetadata()

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")]
[DataMemberAttribute]
public OneToManyRelationshipMetadata[] OneToManyRelationships { get; }

C++

J#

JScript

Property Value
Type :OneToManyRelationshipMetadata[]
The array of one-to-many relationships for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.OwnershipType Property
[image]

Gets or sets the ownership type for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OwnershipType As Nullable(Of OwnershipTypes)

C#
[DataMemberAttribute]
public Nullable<OwnershipTypes> OwnershipType { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<OwnershipTypes>

The ownership type for the entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Entity Ownership


EntityMetadata.PrimaryIdAttribute Property
[image]

Gets the name of the attribute that is the primary id for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PrimaryIdAttribute As String

C#
[DataMemberAttribute]
public string PrimaryIdAttribute { get; }

C++

J#

JScript

Property Value
Type: String

The name of the attribute that is the primary id for the entity.

  Remarks
The value is usually <entity logical name> + “id”.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.PrimaryImageAttribute Property
[image]

Gets the name of the primary image attribute for an entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property PrimaryImageAttribute As String

C#
[DataMemberAttribute(Order=60)]
public string PrimaryImageAttribute { get; }

C++

J#

JScript

Property Value
Type: String

The name of the primary image attribute for an entity.

  Remarks
When an entity contains a ImageAttributeMetadata attribute this value will be the name of the attribute containing the image used in the application. Each entity can have only one image attribute and the logical name of that attribute is always entityimage. This property has been added to prepare for a future release in which entities may support multiple image attributes and there may be need to change which image is used as the primary image for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.PrimaryNameAttribute Property
[image]

Gets the name of the primary attribute for an entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PrimaryNameAttribute As String

C#
[DataMemberAttribute]
public string PrimaryNameAttribute { get; }

C++

J#

JScript

Property Value
Type: String

The name of the primary attribute for an entity..

  Remarks
Each entity that contains records that can appear in the application will have a primary attribute. Each custom entity will have a primary attribute. The default name for the primary attribute is ‘name’ and this is the most common value for PrimaryNameAttribute. The value in the corresponding attribute is the value that will appear in a lookup attribute when that record is selected. Many entities do not appear in the application and do not have a value set for PrimaryNameAttribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.Privileges Property
[image]

Gets the privilege metadata for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")> _
<DataMemberAttribute> _
Public Property Privileges As SecurityPrivilegeMetadata()

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")]
[DataMemberAttribute]
public SecurityPrivilegeMetadata[] Privileges { get; }

C++

J#

JScript

Property Value
Returns SecurityPrivilegeMetadata[]
The privilege metadata for the entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.RecurrenceBaseEntityLogicalName Property
[image]

Gets the name of the entity that is recurring.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RecurrenceBaseEntityLogicalName As String

C#
[DataMemberAttribute]
public string RecurrenceBaseEntityLogicalName { get; }

C++

J#

JScript

Property Value
Type: String

The name of the entity that is recurring.

  Remarks
Only the recurringappointmentmaster entity contains a value for this attribute, and that value is ‘appointment’ to indicate that appointments are the types of records created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.ReportViewName Property
[image]

Gets the name of the report view for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ReportViewName As String

C#
[DataMemberAttribute]
public string ReportViewName { get; }

C++

J#

JScript

Property Value
Type: String

The name of the report view for the entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadata.SchemaName Property
[image]

Gets or sets the schema name for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SchemaName As String

C#
[DataMemberAttribute]
public string SchemaName { get; set; }

C++

J#

JScript

Property Value
Type: String

The schema name for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadata Class
EntityMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadataCollection Class
See Also Members
[image]

Defines a collection of EntityMetadata

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="EntityMetadataCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class EntityMetadataCollection
    Inherits DataCollection(Of EntityMetadata)

C#
[CollectionDataContractAttribute(Name="EntityMetadataCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class EntityMetadataCollection : DataCollection<EntityMetadata>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.Metadata.EntityMetadataCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadataCollection Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadataCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Defines a collection of EntityMetadata

The following tables list the members exposed by the EntityMetadataCollection type.

Public Constructors

Name | Description
EntityMetadataCollection | Initializes a new instance of the EntityMetadataCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

EntityMetadataCollection Class
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadataCollection Constructor
[image]

Initializes a new instance of the EntityMetadataCollection class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityMetadataCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityMetadataCollection Class
EntityMetadataCollection Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadataCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

EntityMetadataCollection Class
Microsoft.Xrm.Sdk.Metadata Namespace


EntityMetadataCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

EntityMetadataCollection Class
Microsoft.Xrm.Sdk.Metadata Namespace


EntityNameAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute that references an entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EntityNameAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class EntityNameAttributeMetadata
    Inherits EnumAttributeMetadata

C#
[DataContractAttribute(Name="EntityNameAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class EntityNameAttributeMetadata : EnumAttributeMetadata

C++

J#

JScript

  Remarks
You cannot create this type of attribute.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata

                Microsoft.Xrm.Sdk.Metadata.EnumAttributeMetadata
        Microsoft.Xrm.Sdk.Metadata.EntityNameAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityNameAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Sample: Dump Entity Metadata to a File


EntityNameAttributeMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an attribute that references an entity.

The following tables list the members exposed by the EntityNameAttributeMetadata type.

Public Constructors

Name | Description
EntityNameAttributeMetadata | Overloaded. Initializes a new instance of the EntityNameAttributeMetadata class
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute. (inherited from EnumAttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute. (inherited from EnumAttributeMetadata)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EntityNameAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Sample: Dump Entity Metadata to a File


EntityNameAttributeMetadata Constructor
[image]

Initializes a new instance of the EntityNameAttributeMetadata class

Overload List

Name | Description
EntityNameAttributeMetadata () | Initializes a new instance of the EntityNameAttributeMetadata class
EntityNameAttributeMetadata (String) | Initializes a new instance of the EntityNameAttributeMetadata class

See Also

Reference

EntityNameAttributeMetadata Class
EntityNameAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityNameAttributeMetadata Constructor ()
[image]

Initializes a new instance of the EntityNameAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityNameAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityNameAttributeMetadata Class
EntityNameAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityNameAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the EntityNameAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public EntityNameAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name of the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityNameAttributeMetadata Class
EntityNameAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EntityNameAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EntityNameAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Sample: Dump Entity Metadata to a File


EntityNameAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute. (inherited from EnumAttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute. (inherited from EnumAttributeMetadata)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)

See Also

Reference

EntityNameAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Sample: Dump Entity Metadata to a File


EnumAttributeMetadata Class
See Also Members
[image]

Contains the data for an attribute that provides options.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(EntityNameAttributeMetadata))> _
<KnownTypeAttribute(GetType(PicklistAttributeMetadata))> _
<KnownTypeAttribute(GetType(StateAttributeMetadata))> _
<KnownTypeAttribute(GetType(StatusAttributeMetadata))> _
<DataContractAttribute(Name:="EnumAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public MustInherit Class EnumAttributeMetadata
    Inherits AttributeMetadata

C#
[KnownTypeAttribute(typeof(EntityNameAttributeMetadata))]
[KnownTypeAttribute(typeof(PicklistAttributeMetadata))]
[KnownTypeAttribute(typeof(StateAttributeMetadata))]
[KnownTypeAttribute(typeof(StatusAttributeMetadata))]
[DataContractAttribute(Name="EnumAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public abstract class EnumAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.EnumAttributeMetadata

                Microsoft.Xrm.Sdk.Metadata.EntityNameAttributeMetadata

                Microsoft.Xrm.Sdk.Metadata.PicklistAttributeMetadata

                Microsoft.Xrm.Sdk.Metadata.StateAttributeMetadata

                Microsoft.Xrm.Sdk.Metadata.StatusAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


EnumAttributeMetadata Members
See Also Methods Properties Constructors
[image]

Contains the data for an attribute that provides options.

The following tables list the members exposed by the EnumAttributeMetadata type.

Protected Constructors

Name | Description
EnumAttributeMetadata | Overloaded. Initializes a new instance of the EnumAttributeMetadata class.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute.
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EnumAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


EnumAttributeMetadata Constructor
[image]

Initializes a new instance of the EnumAttributeMetadata class.

Overload List

Name | Description
EnumAttributeMetadata () | Initializes a new instance of the EnumAttributeMetadata class.
EnumAttributeMetadata (AttributeTypeCode, String) | Initializes a new instance of the EnumAttributeMetadata class.

See Also

Reference

EnumAttributeMetadata Class
EnumAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EnumAttributeMetadata Constructor ()
[image]

Initializes a new instance of the EnumAttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected EnumAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumAttributeMetadata Class
EnumAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EnumAttributeMetadata Constructor (AttributeTypeCode, String)
[image]

Initializes a new instance of the EnumAttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    attributeType As AttributeTypeCode, _
    schemaName As String _
)

C#
protected EnumAttributeMetadata (
    AttributeTypeCode attributeType,
    string schemaName
)

C++

J#

JScript

Parameters
attributeType
Type: AttributeTypeCode The attribute type code.
schemaName
Type: String
The schema name for the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumAttributeMetadata Class
EnumAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EnumAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EnumAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


EnumAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute.
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)

See Also

Reference

EnumAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


EnumAttributeMetadata.DefaultFormValue Property
[image]

Gets or sets the default form value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DefaultFormValue As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> DefaultFormValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The default form value for the attribute..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumAttributeMetadata Class
EnumAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


EnumAttributeMetadata.OptionSet Property
[image]

Gets or sets the available options for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OptionSet As OptionSetMetadata

C#
[DataMemberAttribute]
public OptionSetMetadata OptionSet { get; set; }

C++

J#

JScript

Property Value
Type: OptionSetMetadata
The available options for the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumAttributeMetadata Class
EnumAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute type Image.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ImageAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2013/Metadata")> _
Public NotInheritable Class ImageAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="ImageAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2013/Metadata")]
public sealed class ImageAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Remarks
To retrieve attributes of this type you must use current .NET assemblies or include a valid OrganizationServiceProxy.SdkClientVersion value with your request. More information:SdkClientVersion and Sample: Retrieve Entity Metadata Using JavaScript.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.ImageAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImageAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an attribute type Image.

The following tables list the members exposed by the ImageAttributeMetadata type.

Public Constructors

Name | Description
ImageAttributeMetadata | Overloaded. Initializes a new instance of the ImageAttributeMetadata class.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryImage | Gets or sets whether the attribute is the primary image for the entity.
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxHeight | Gets the maximum height of the image.
public property | MaxWidth | Gets the maximum width of the image.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImageAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata Constructor
[image]

Initializes a new instance of the ImageAttributeMetadata class.

Overload List

Name | Description
ImageAttributeMetadata () | Initializes a new instance of the ImageAttributeMetadata class.
ImageAttributeMetadata (String) | Initializes a new instance of the ImageAttributeMetadata class.

See Also

Reference

ImageAttributeMetadata Class
ImageAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata Constructor ()
[image]

Initializes a new instance of the ImageAttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImageAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImageAttributeMetadata Class
ImageAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the ImageAttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public ImageAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name for the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImageAttributeMetadata Class
ImageAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImageAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryImage | Gets or sets whether the attribute is the primary image for the entity.
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxHeight | Gets the maximum height of the image.
public property | MaxWidth | Gets the maximum width of the image.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)

See Also

Reference

ImageAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata.IsPrimaryImage Property
[image]

Gets or sets whether the attribute is the primary image for the entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsPrimaryImage As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsPrimaryImage { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the attribute is the primary image for the entity; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImageAttributeMetadata Class
ImageAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata.MaxHeight Property
[image]

Gets the maximum height of the image.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxHeight As Nullable(Of Short)

C#
[DataMemberAttribute]
public Nullable<short> MaxHeight { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int16>

The maximum height for the image.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImageAttributeMetadata Class
ImageAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ImageAttributeMetadata.MaxWidth Property
[image]

Gets the maximum width of the image.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxWidth As Nullable(Of Short)

C#
[DataMemberAttribute]
public Nullable<short> MaxWidth { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int16>

The maximum width for the image.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ImageAttributeMetadata Class
ImageAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ImeMode Enumeration
[image]

Describes the input method editor mode

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ImeMode", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration ImeMode

C#
[DataContractAttribute(Name="ImeMode", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum ImeMode

C++

J#

JScript

  Members
Member name | Description
Active | Specifies that the IME mode is active. Value = 2.
Auto | Specifies that the IME mode is chosen automatically. Value =0.
Disabled | Specifies that the IME mode is disabled. Value = 3.
Inactive | Specifies that the IME mode is inactive. Value = 1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Far Eastern Input Method Editors


IntegerAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute type Integer.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="IntegerAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class IntegerAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="IntegerAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class IntegerAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.IntegerAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


IntegerAttributeMetadata Members
See Also Constructors Fields Methods Properties
[image]

Contains the metadata for an attribute type Integer.

The following tables list the members exposed by the IntegerAttributeMetadata type.

Public Constructors

Name | Description
IntegerAttributeMetadata | Overloaded. Initializes a new instance of the IntegerAttributeMetadata class
Top

Public Fields

Name | Description
MaxSupportedValue | The maximum supported value is 2147483647.
MinSupportedValue | The minimum supported value is -2147483648.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | Format | Gets or sets the format options for the integer attribute.
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

IntegerAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


IntegerAttributeMetadata Fields
[image]

Public Fields

Name | Description
MaxSupportedValue | The maximum supported value is 2147483647.
MinSupportedValue | The minimum supported value is -2147483648.

See Also

Reference

IntegerAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


IntegerAttributeMetadata.MaxSupportedValue Field
[image]

The maximum supported value is 2147483647.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedValue As Integer

C#
public const int MaxSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


IntegerAttributeMetadata.MinSupportedValue Field
[image]

The minimum supported value is -2147483648.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedValue As Integer

C#
public const int MinSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


IntegerAttributeMetadata Constructor
[image]

Initializes a new instance of the IntegerAttributeMetadata class

Overload List

Name | Description
IntegerAttributeMetadata () | Initializes a new instance of the IntegerAttributeMetadata class
IntegerAttributeMetadata (String) | Initializes a new instance of the IntegerAttributeMetadata class

See Also

Reference

IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


IntegerAttributeMetadata Constructor ()
[image]

Initializes a new instance of the IntegerAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public IntegerAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


IntegerAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the IntegerAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public IntegerAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name for the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


IntegerAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

IntegerAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


IntegerAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | Format | Gets or sets the format options for the integer attribute.
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

See Also

Reference

IntegerAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


IntegerAttributeMetadata.Format Property
[image]

Gets or sets the format options for the integer attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Format As Nullable(Of IntegerFormat)

C#
[DataMemberAttribute]
public Nullable<IntegerFormat> Format { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<IntegerFormat>

The format options for the integer attribute.

  Remarks
If this property is not assigned a value, it defaults toNone

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


IntegerAttributeMetadata.FormulaDefinition Property
[image]

Gets or sets the formula definition for calculated and rollup attributes.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property FormulaDefinition As String

C#
[DataMemberAttribute(Order=70)]
public string FormulaDefinition { get; set; }

C++

J#

JScript

Property Value
Type: String
The formula definition for calculated and rollup attributes.

  Remarks
To edit this property, you must use the formula editor in the application. More information:Customization Guide: Define Calculated Fields and Customization Guide: Define Rollup Fields.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes


IntegerAttributeMetadata.MaxValue Property
[image]

Gets or sets the maximum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxValue As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> MaxValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The maximum value for the attribute.

  Remarks
If this property is not assigned a value, it defaults to2147483647
Possible values are -2147483648 to 2147483647.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


IntegerAttributeMetadata.MinValue Property
[image]

Gets or sets the minimum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MinValue As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> MinValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The minimum value for the attribute.

  Remarks
If this property is not assigned a value, it defaults to-2147483648
Possible values are -2147483648 to 2147483647.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


IntegerAttributeMetadata.SourceTypeMask Property
[image]

Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property SourceTypeMask As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=70)]
public Nullable<int> SourceTypeMask { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The value that indicates the source of data for a calculated or rollup attribute.

  Remarks
The following table contains the valid values for this attribute.
Value | Description
0 | Undefined: The default value for simple and rollup attributes.
1 | Simple: The calculated attribute refers to an attribute in the same record.
2 | Related: The calculated attribute refers to an attribute in a related record.
4 | Logical: The calculated attribute refers to an attribute in the same record that is actually stored in a different database table. More information:Logical attributes.
8 | Calculated: The calculated attribute refers to another calculated attribute.
16 | Rollup: The calculated attribute refers a rollup attribute.
32 | Invalid: The calculated or rollup attribute is invalid. Typically this would be where a field refers to an attribute that no longer exists.
The SourceTypeMasks enumeration is useful when performing bitwise operations to check whether specific values are present in this bitmask value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IntegerAttributeMetadata Class
IntegerAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes
SourceTypeMasks enumeration
Logical attributes


IntegerFormat Enumeration
[image]

Describes the formatting of an integer attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="IntegerFormat", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration IntegerFormat

C#
[DataContractAttribute(Name="IntegerFormat", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum IntegerFormat

C++

J#

JScript

  Members
Member name | Description
Duration | Specifies to display the integer as a drop down list of durations. Value = 1.
Language | Specifies the display the integer as a drop down list of installed languages. Value = 3.
Locale | Specifies a locale. Value = 4.
None | Specifies to display an edit field for an integer. Value = 0.
TimeZone | Specifies to display the integer as a drop down list of time zones. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
IntegerAttributeMetadata


LookupAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute of type lookup.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="LookupAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class LookupAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="LookupAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class LookupAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.LookupAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LookupAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata
Work with Attributes
Create a Lookup Attribute


LookupAttributeMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an attribute of type lookup.

The following tables list the members exposed by the LookupAttributeMetadata type.

Public Constructors

Name | Description
LookupAttributeMetadata | Initializes a new instance of the LookupAttributeMetadata class
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | Targets | Gets or sets the target entity types for the lookup.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LookupAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes
Create a Lookup Attribute


LookupAttributeMetadata Constructor
[image]

Initializes a new instance of the LookupAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LookupAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LookupAttributeMetadata Class
LookupAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


LookupAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LookupAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes
Create a Lookup Attribute


LookupAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | Targets | Gets or sets the target entity types for the lookup.

See Also

Reference

LookupAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes
Create a Lookup Attribute


LookupAttributeMetadata.Targets Property
[image]

Gets or sets the target entity types for the lookup.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
<SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")> _
Public Property Targets As String()

C#
[DataMemberAttribute]
[SuppressMessageAttribute("Microsoft.Performance", "CA1819:PropertiesShouldNotReturnArrays")]
public string[] Targets { get; set; }

C++

J#

JScript

Property Value
Type: String[]

The array of target entity types for the lookup.

  Remarks
The value contains an array of entity logical names. If this value is not null, the lookup can only reference the entities contained in the array. If the value is null, use of the of the lookup attribute is not supported.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LookupAttributeMetadata Class
LookupAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ManagedPropertyAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class ManagedPropertyAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="ManagedPropertyAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class ManagedPropertyAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.ManagedPropertyAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata Members
See Also Constructors Fields Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the ManagedPropertyAttributeMetadata type.

Public Constructors

Name | Description
ManagedPropertyAttributeMetadata | Overloaded. Initializes a new instance of the ManagedPropertyAttributeMetadata class
Top

Public Fields

Name | Description
EmptyParentComponentType | For internal use only.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | ManagedPropertyLogicalName | For internal use only.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | ParentAttributeName | For internal use only.
public property | ParentComponentType | For internal use only.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | ValueAttributeTypeCode | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ManagedPropertyAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata Fields
[image]

Public Fields

Name | Description
EmptyParentComponentType | For internal use only.

See Also

Reference

ManagedPropertyAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata.EmptyParentComponentType Field
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const EmptyParentComponentType As Integer

C#
public const int EmptyParentComponentType

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyAttributeMetadata Class
ManagedPropertyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata Constructor
[image]

Initializes a new instance of the ManagedPropertyAttributeMetadata class

Overload List

Name | Description
ManagedPropertyAttributeMetadata () | Initializes a new instance of the ManagedPropertyAttributeMetadata class
ManagedPropertyAttributeMetadata (String) | Initializes a new instance of the ManagedPropertyAttributeMetadata class

See Also

Reference

ManagedPropertyAttributeMetadata Class
ManagedPropertyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata Constructor ()
[image]

Initializes a new instance of the ManagedPropertyAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ManagedPropertyAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyAttributeMetadata Class
ManagedPropertyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the ManagedPropertyAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public ManagedPropertyAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
For internal use only.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyAttributeMetadata Class
ManagedPropertyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ManagedPropertyAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | ManagedPropertyLogicalName | For internal use only.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | ParentAttributeName | For internal use only.
public property | ParentComponentType | For internal use only.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | ValueAttributeTypeCode | For internal use only.

See Also

Reference

ManagedPropertyAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata.ManagedPropertyLogicalName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ManagedPropertyLogicalName As String

C#
[DataMemberAttribute]
public string ManagedPropertyLogicalName { get; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyAttributeMetadata Class
ManagedPropertyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata.ParentAttributeName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ParentAttributeName As String

C#
[DataMemberAttribute]
public string ParentAttributeName { get; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyAttributeMetadata Class
ManagedPropertyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata.ParentComponentType Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ParentComponentType As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> ParentComponentType { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyAttributeMetadata Class
ManagedPropertyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyAttributeMetadata.ValueAttributeTypeCode Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ValueAttributeTypeCode As AttributeTypeCode

C#
[DataMemberAttribute]
public AttributeTypeCode ValueAttributeTypeCode { get; }

C++

J#

JScript

Property Value
Type: AttributeTypeCode
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyAttributeMetadata Class
ManagedPropertyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyEvaluationPriority Enumeration
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ManagedPropertyEvaluationPriority", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration ManagedPropertyEvaluationPriority

C#
[DataContractAttribute(Name="ManagedPropertyEvaluationPriority", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum ManagedPropertyEvaluationPriority

C++

J#

JScript

  Members
Member name | Description
Essential | For internal use only.
High | For internal use only.
Low | For internal use only.
None | For internal use only.
Normal | For internal use only.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ManagedPropertyMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class ManagedPropertyMetadata
    Inherits MetadataBase

C#
[DataContractAttribute(Name="ManagedPropertyMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class ManagedPropertyMetadata : MetadataBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase
    Microsoft.Xrm.Sdk.Metadata.ManagedPropertyMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the ManagedPropertyMetadata type.

Public Constructors

Name | Description
ManagedPropertyMetadata | Initializes a new instance of the ManagedPropertyMetadata class
Top

Public Properties

 | Name | Description
public property | Description | For internal use only.
public property | DisplayName | For internal use only.
public property | EnablesAttributeName | For internal use only.
public property | EnablesEntityName | For internal use only.
public property | ErrorCode | For internal use only.
public property | EvaluationPriority | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsGlobalForOperation | For internal use only.
public property | IsPrivate | For internal use only.
public property | LogicalName | For internal use only.
public property | ManagedPropertyType | For internal use only.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Operation | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ManagedPropertyMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata Constructor
[image]

Initializes a new instance of the ManagedPropertyMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ManagedPropertyMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ManagedPropertyMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata Properties
[image]

Public Properties

 | Name | Description
public property | Description | For internal use only.
public property | DisplayName | For internal use only.
public property | EnablesAttributeName | For internal use only.
public property | EnablesEntityName | For internal use only.
public property | ErrorCode | For internal use only.
public property | EvaluationPriority | For internal use only.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsGlobalForOperation | For internal use only.
public property | IsPrivate | For internal use only.
public property | LogicalName | For internal use only.
public property | ManagedPropertyType | For internal use only.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Operation | For internal use only.

See Also

Reference

ManagedPropertyMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.Description Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Description As Label

C#
[DataMemberAttribute]
public Label Description { get; }

C++

J#

JScript

Property Value
Type: Label
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.DisplayName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DisplayName As Label

C#
[DataMemberAttribute]
public Label DisplayName { get; }

C++

J#

JScript

Property Value
Type: Label
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.EnablesAttributeName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EnablesAttributeName As String

C#
[DataMemberAttribute]
public string EnablesAttributeName { get; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.EnablesEntityName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EnablesEntityName As String

C#
[DataMemberAttribute]
public string EnablesEntityName { get; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.ErrorCode Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ErrorCode As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> ErrorCode { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.EvaluationPriority Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EvaluationPriority As Nullable(Of ManagedPropertyEvaluationPriority)

C#
[DataMemberAttribute]
public Nullable<ManagedPropertyEvaluationPriority> EvaluationPriority { get; }

C++

J#

JScript

Property Value
Type: Nullable<ManagedPropertyEvaluationPriority>
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.IntroducedVersion Property
[image]

Gets a string identifying the solution version that the solution component was added in.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property IntroducedVersion As String

C#
[DataMemberAttribute(Order=60)]
public string IntroducedVersion { get; }

C++

J#

JScript

Property Value
Type: String

A string identifying the solution version that the solution component was added in.

  Remarks

                        This identifies the major and minor versions of the solution that added this metadata item. For metadata that existed in Microsoft Dynamics CRM 2011 the value will be 5.0.0.0 and for metadata added with Microsoft Dynamics CRM 2013 the value will be 6.0.0.0. If new metadata is added in updates or future releases the version number will be incremented to the corresponding version. For metadata added by custom solutions the version of the solution that the item was created it is used.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.IsGlobalForOperation Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsGlobalForOperation As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsGlobalForOperation { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.IsPrivate Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsPrivate As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsPrivate { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.LogicalName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LogicalName As String

C#
[DataMemberAttribute]
public string LogicalName { get; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.ManagedPropertyType Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ManagedPropertyType As Nullable(Of ManagedPropertyType)

C#
[DataMemberAttribute]
public Nullable<ManagedPropertyType> ManagedPropertyType { get; }

C++

J#

JScript

Property Value
Type: Nullable<ManagedPropertyType>
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyMetadata.Operation Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Operation As Nullable(Of ManagedPropertyOperation)

C#
[DataMemberAttribute]
public Nullable<ManagedPropertyOperation> Operation { get; }

C++

J#

JScript

Property Value
Type: Nullable<ManagedPropertyOperation>
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManagedPropertyMetadata Class
ManagedPropertyMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyOperation Enumeration
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1027:MarkEnumsWithFlags", Justification:="Working around back-compat issues with enums in WCF")> _
<DataContractAttribute(Name:="ManagedPropertyOperation", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration ManagedPropertyOperation

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1027:MarkEnumsWithFlags", Justification="Working around back-compat issues with enums in WCF")]
[DataContractAttribute(Name="ManagedPropertyOperation", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum ManagedPropertyOperation

C++

J#

JScript

  Members
Member name | Description
All | For internal use only.
Create | For internal use only.
CreateUpdate | For internal use only.
Delete | For internal use only.
None | For internal use only.
Update | For internal use only.
UpdateDelete | For internal use only.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace


ManagedPropertyType Enumeration
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ManagedPropertyType", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration ManagedPropertyType

C#
[DataContractAttribute(Name="ManagedPropertyType", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum ManagedPropertyType

C++

J#

JScript

  Members
Member name | Description
Attribute | For internal use only.
Custom | For internal use only.
CustomEvaluator | For internal use only.
Operation | For internal use only.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace


ManyToManyRelationshipMetadata Class
See Also Members
[image]

Contains the metadata for a many-to-many entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ManyToManyRelationshipMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class ManyToManyRelationshipMetadata
    Inherits RelationshipMetadataBase

C#
[DataContractAttribute(Name="ManyToManyRelationshipMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class ManyToManyRelationshipMetadata : RelationshipMetadataBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.RelationshipMetadataBase
      Microsoft.Xrm.Sdk.Metadata.ManyToManyRelationshipMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManyToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Relationship Metadata


ManyToManyRelationshipMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for a many-to-many entity relationship.

The following tables list the members exposed by the ManyToManyRelationshipMetadata type.

Public Constructors

Name | Description
ManyToManyRelationshipMetadata | Initializes a new instance of theManyToManyRelationshipMetadata class
Top

Public Properties

 | Name | Description
public property | Entity1AssociatedMenuConfiguration | Gets or sets the associated menu configuration for the first entity.
public property | Entity1IntersectAttribute | Gets or sets the attribute that defines the relationship in the first entity.
public property | Entity1LogicalName | Gets or sets the logical name of the first entity in the relationship.
public property | Entity2AssociatedMenuConfiguration | Gets or sets the associated menu configuration for the second entity.
public property | Entity2IntersectAttribute | Gets or sets the attribute that defines the relationship in the second entity.
public property | Entity2LogicalName | Gets or sets the logical name of the second entity in the relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntersectEntityName | Gets or sets the name of the intersect entity for the relationship.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from RelationshipMetadataBase)
public property | IsCustomizable | Gets or sets whether the entity relationship is customizable. (inherited from RelationshipMetadataBase)
public property | IsCustomRelationship | Gets whether the relationship is a custom relationship. (inherited from RelationshipMetadataBase)
public property | IsManaged | Gets whether the entity relationship is part of a managed solution. (inherited from RelationshipMetadataBase)
public property | IsValidForAdvancedFind | Gets or sets whether the entity relationship should be shown in Advanced Find. (inherited from RelationshipMetadataBase)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RelationshipType | Gets the type of relationship. (inherited from RelationshipMetadataBase)
public property | SchemaName | Gets or sets the schema name for the entity relationship. (inherited from RelationshipMetadataBase)
public property | SecurityTypes | Gets or sets the security type for the relationship. (inherited from RelationshipMetadataBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ManyToManyRelationshipMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Relationship Metadata


ManyToManyRelationshipMetadata Constructor
[image]

Initializes a new instance of the ManyToManyRelationshipMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ManyToManyRelationshipMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManyToManyRelationshipMetadata Class
ManyToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManyToManyRelationshipMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ManyToManyRelationshipMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Relationship Metadata


ManyToManyRelationshipMetadata Properties
[image]

Public Properties

 | Name | Description
public property | Entity1AssociatedMenuConfiguration | Gets or sets the associated menu configuration for the first entity.
public property | Entity1IntersectAttribute | Gets or sets the attribute that defines the relationship in the first entity.
public property | Entity1LogicalName | Gets or sets the logical name of the first entity in the relationship.
public property | Entity2AssociatedMenuConfiguration | Gets or sets the associated menu configuration for the second entity.
public property | Entity2IntersectAttribute | Gets or sets the attribute that defines the relationship in the second entity.
public property | Entity2LogicalName | Gets or sets the logical name of the second entity in the relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntersectEntityName | Gets or sets the name of the intersect entity for the relationship.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from RelationshipMetadataBase)
public property | IsCustomizable | Gets or sets whether the entity relationship is customizable. (inherited from RelationshipMetadataBase)
public property | IsCustomRelationship | Gets whether the relationship is a custom relationship. (inherited from RelationshipMetadataBase)
public property | IsManaged | Gets whether the entity relationship is part of a managed solution. (inherited from RelationshipMetadataBase)
public property | IsValidForAdvancedFind | Gets or sets whether the entity relationship should be shown in Advanced Find. (inherited from RelationshipMetadataBase)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RelationshipType | Gets the type of relationship. (inherited from RelationshipMetadataBase)
public property | SchemaName | Gets or sets the schema name for the entity relationship. (inherited from RelationshipMetadataBase)
public property | SecurityTypes | Gets or sets the security type for the relationship. (inherited from RelationshipMetadataBase)

See Also

Reference

ManyToManyRelationshipMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Relationship Metadata


ManyToManyRelationshipMetadata.Entity1AssociatedMenuConfiguration Property
[image]

Gets or sets the associated menu configuration for the first entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Entity1AssociatedMenuConfiguration As AssociatedMenuConfiguration

C#
[DataMemberAttribute]
public AssociatedMenuConfiguration Entity1AssociatedMenuConfiguration { get; set; }

C++

J#

JScript

Property Value
Type: AssociatedMenuConfiguration
The associated menu configuration for the first entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManyToManyRelationshipMetadata Class
ManyToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManyToManyRelationshipMetadata.Entity1IntersectAttribute Property
[image]

Gets or sets the attribute that defines the relationship in the first entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Entity1IntersectAttribute As String

C#
[DataMemberAttribute]
public string Entity1IntersectAttribute { get; set; }

C++

J#

JScript

Property Value
Type: String

The attribute that defines the relationship in the first entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManyToManyRelationshipMetadata Class
ManyToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManyToManyRelationshipMetadata.Entity1LogicalName Property
[image]

Gets or sets the logical name of the first entity in the relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Entity1LogicalName As String

C#
[DataMemberAttribute]
public string Entity1LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the first entity in the relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManyToManyRelationshipMetadata Class
ManyToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManyToManyRelationshipMetadata.Entity2AssociatedMenuConfiguration Property
[image]

Gets or sets the associated menu configuration for the second entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Entity2AssociatedMenuConfiguration As AssociatedMenuConfiguration

C#
[DataMemberAttribute]
public AssociatedMenuConfiguration Entity2AssociatedMenuConfiguration { get; set; }

C++

J#

JScript

Property Value
Type: AssociatedMenuConfiguration
The associated menu configuration for the second entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManyToManyRelationshipMetadata Class
ManyToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManyToManyRelationshipMetadata.Entity2IntersectAttribute Property
[image]

Gets or sets the attribute that defines the relationship in the second entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Entity2IntersectAttribute As String

C#
[DataMemberAttribute]
public string Entity2IntersectAttribute { get; set; }

C++

J#

JScript

Property Value
Type: String

The attribute that defines the relationship in the second entity..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManyToManyRelationshipMetadata Class
ManyToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManyToManyRelationshipMetadata.Entity2LogicalName Property
[image]

Gets or sets the logical name of the second entity in the relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Entity2LogicalName As String

C#
[DataMemberAttribute]
public string Entity2LogicalName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the second entity in the relationship..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManyToManyRelationshipMetadata Class
ManyToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


ManyToManyRelationshipMetadata.IntersectEntityName Property
[image]

Gets or sets the name of the intersect entity for the relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IntersectEntityName As String

C#
[DataMemberAttribute]
public string IntersectEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the intersect entity for the relationship..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ManyToManyRelationshipMetadata Class
ManyToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MemoAttributeMetadata Class
See Also Members
[image]

Contains the metadata for the attribute type Memo.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="MemoAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class MemoAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="MemoAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class MemoAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.MemoAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


MemoAttributeMetadata Members
See Also Constructors Fields Methods Properties
[image]

Contains the metadata for the attribute type Memo.

The following tables list the members exposed by the MemoAttributeMetadata type.

Public Constructors

Name | Description
MemoAttributeMetadata | Overloaded. Initializes a new instance of the MemoAttributeMetadata class.
Top

Public Fields

Name | Description
MaxSupportedLength | The maximum supported length is 1048576.
MinSupportedLength | The minimum supported length is 1.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | Format | Gets or sets the format options for the memo attribute.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the value for the input method editor mode.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLocalizable | Gets whether the attribute supports localizable values.
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxLength | Gets or sets the maximum length for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MemoAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


MemoAttributeMetadata Fields
[image]

Public Fields

Name | Description
MaxSupportedLength | The maximum supported length is 1048576.
MinSupportedLength | The minimum supported length is 1.

See Also

Reference

MemoAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


MemoAttributeMetadata.MaxSupportedLength Field
[image]

The maximum supported length is 1048576.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedLength As Integer

C#
public const int MaxSupportedLength

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MemoAttributeMetadata Class
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MemoAttributeMetadata.MinSupportedLength Field
[image]

The minimum supported length is 1.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedLength As Integer

C#
public const int MinSupportedLength

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MemoAttributeMetadata Class
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MemoAttributeMetadata Constructor
[image]

Initializes a new instance of the MemoAttributeMetadata class.

Overload List

Name | Description
MemoAttributeMetadata () | Initializes a new instance of the MemoAttributeMetadata class.
MemoAttributeMetadata (String) | Initializes a new instance of the MemoAttributeMetadata class

See Also

Reference

MemoAttributeMetadata Class
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MemoAttributeMetadata Constructor ()
[image]

Initializes a new instance of the MemoAttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MemoAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MemoAttributeMetadata Class
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MemoAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the MemoAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public MemoAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name of the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MemoAttributeMetadata Class
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MemoAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MemoAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


MemoAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | Format | Gets or sets the format options for the memo attribute.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the value for the input method editor mode.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLocalizable | Gets whether the attribute supports localizable values.
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxLength | Gets or sets the maximum length for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)

See Also

Reference

MemoAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


MemoAttributeMetadata.Format Property
[image]

Gets or sets the format options for the memo attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Format As Nullable(Of StringFormat)

C#
[DataMemberAttribute]
public Nullable<StringFormat> Format { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<StringFormat>

The format options for the memo attribute.

  Remarks
Optional for Create.If this property is not assigned a value, it defaults toTextArea.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MemoAttributeMetadata Class
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MemoAttributeMetadata.ImeMode Property
[image]

Gets or sets the value for the input method editor mode.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ImeMode As Nullable(Of ImeMode)

C#
[DataMemberAttribute]
public Nullable<ImeMode> ImeMode { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<ImeMode>

The value for the input method editor mode..

  Remarks
Optional for Create. If this property is not assigned a value, it defaults toAuto

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MemoAttributeMetadata Class
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MemoAttributeMetadata.IsLocalizable Property
[image]

Gets whether the attribute supports localizable values.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property IsLocalizable As Nullable(Of Boolean)

C#
[DataMemberAttribute(Order=70)]
public Nullable<bool> IsLocalizable { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the attribute supports localizable values; otherwise, false.

  Remarks
The value is false for all but a few system entities that support this capability. More information:Attributes that support localized property values.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MemoAttributeMetadata Class
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MemoAttributeMetadata.MaxLength Property
[image]

Gets or sets the maximum length for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxLength As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> MaxLength { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The maximum length for the attribute.

  Remarks
Required for Create. Possible values are between 1 and 1048576.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MemoAttributeMetadata Class
MemoAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MetadataBase Class
See Also Members
[image]

Specifies the base class for classes that contains metadata information.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(RelationshipMetadataBase))> _
<DataContractAttribute(Name:="MetadataBase", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
<KnownTypeAttribute(GetType(AttributeMetadata))> _
<KnownTypeAttribute(GetType(EntityMetadata))> _
<KnownTypeAttribute(GetType(OptionSetMetadata))> _
Public MustInherit Class MetadataBase
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute(typeof(RelationshipMetadataBase))]
[DataContractAttribute(Name="MetadataBase", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
[KnownTypeAttribute(typeof(AttributeMetadata))]
[KnownTypeAttribute(typeof(EntityMetadata))]
[KnownTypeAttribute(typeof(OptionSetMetadata))]
public abstract class MetadataBase : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Derived Classes
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Extend the Metadata Model for Microsoft Dynamics CRM


MetadataBase Members
See Also Methods Properties Constructors
[image]

Specifies the base class for classes that contains metadata information.

The following tables list the members exposed by the MetadataBase type.

Protected Constructors

Name | Description
MetadataBase | Initializes a new instance of theMetadataBase class
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | HasChanged | Gets whether the item of metadata has changed.
public property | MetadataId | Gets or sets a unique identifier for the metadata item.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MetadataBase Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Extend the Metadata Model for Microsoft Dynamics CRM


MetadataBase Constructor
[image]

Initializes a new instance of the MetadataBase class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected MetadataBase ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MetadataBase Class
MetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


MetadataBase Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MetadataBase Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Extend the Metadata Model for Microsoft Dynamics CRM


MetadataBase Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | HasChanged | Gets whether the item of metadata has changed.
public property | MetadataId | Gets or sets a unique identifier for the metadata item.

See Also

Reference

MetadataBase Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Extend the Metadata Model for Microsoft Dynamics CRM


MetadataBase.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MetadataBase Class
MetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


MetadataBase.HasChanged Property
[image]

Gets whether the item of metadata has changed.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property HasChanged As Nullable(Of Boolean)

C#
[DataMemberAttribute(Order=60)]
public Nullable<bool> HasChanged { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if metadata item has changed since the last query; otherwise, false.

  Remarks
When metadata is retrieved using RetrieveMetadataChangesRequest, with a valid ClientVersionStamp parameter, the RetrieveMetadataChangesResponse. EntityMetadata property contains an EntityMetadataCollection of all the changed metadata. When a child item has changed but a parent item has not, the HasChanged property of the child will be true but for the parent it will be false.
It is not valid to use this attribute as part of a query because the value is calculated. The value will be null except in the results of a query that returns information about changes from a previous query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MetadataBase Class
MetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


MetadataBase.MetadataId Property
[image]

Gets or sets a unique identifier for the metadata item.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MetadataId As Nullable(Of Guid)

C#
[DataMemberAttribute]
public Nullable<Guid> MetadataId { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Guid>

The unique identifier for the metadata item.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MetadataBase Class
MetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute type Money.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="MoneyAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class MoneyAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="MoneyAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class MoneyAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.MoneyAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


MoneyAttributeMetadata Members
See Also Constructors Fields Methods Properties
[image]

Contains the metadata for an attribute type Money.

The following tables list the members exposed by the MoneyAttributeMetadata type.

Public Constructors

Name | Description
MoneyAttributeMetadata | Overloaded. Initializes a new instance of theMoneyAttributeMetadata class
Top

Public Fields

Name | Description
MaxSupportedPrecision | The maximum supported precision for this attribute is 4.
MaxSupportedValue | The maximum supported value for this attribute is 922337000000000.
MinSupportedPrecision | The minimum supported precision for this attribute is 0.
MinSupportedValue | The minimum supported value for this attribute is -922337000000000.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CalculationOf | For internal use only.
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the input method editor (IME) mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsBaseCurrency | Gets whether the attribute represents the base currency or the transaction currency.
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | Precision | Gets or sets the precision for the attribute.
public property | PrecisionSource | Gets or sets the precision source for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or indicates whether the data sources are invalid.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MoneyAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


MoneyAttributeMetadata Fields
[image]

Public Fields

Name | Description
MaxSupportedPrecision | The maximum supported precision for this attribute is 4.
MaxSupportedValue | The maximum supported value for this attribute is 922337000000000.
MinSupportedPrecision | The minimum supported precision for this attribute is 0.
MinSupportedValue | The minimum supported value for this attribute is -922337000000000.

See Also

Reference

MoneyAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


MoneyAttributeMetadata.MaxSupportedPrecision Field
[image]

The maximum supported precision for this attribute is 4.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedPrecision As Integer

C#
public const int MaxSupportedPrecision

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.MaxSupportedValue Field
[image]

The maximum supported value for this attribute is 922337000000000.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedValue As Double

C#
public const double MaxSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.MinSupportedPrecision Field
[image]

The minimum supported precision for this attribute is 0.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedPrecision As Integer

C#
public const int MinSupportedPrecision

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.MinSupportedValue Field
[image]

The minimum supported value for this attribute is -922337000000000.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedValue As Double

C#
public const double MinSupportedValue

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata Constructor
[image]

Initializes a new instance of theMoneyAttributeMetadata class

Overload List

Name | Description
MoneyAttributeMetadata () | Initializes a new instance of theMoneyAttributeMetadata class
MoneyAttributeMetadata (String) | Initializes a new instance of theMoneyAttributeMetadata class

See Also

Reference

MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata Constructor ()
[image]

Initializes a new instance of theMoneyAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MoneyAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata Constructor (String)
[image]

Initializes a new instance of theMoneyAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public MoneyAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String.
The schema name of the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MoneyAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


MoneyAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CalculationOf | For internal use only.
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the input method editor (IME) mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsBaseCurrency | Gets whether the attribute represents the base currency or the transaction currency.
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxValue | Gets or sets the maximum value for the attribute.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | MinValue | Gets or sets the minimum value for the attribute.
public property | Precision | Gets or sets the precision for the attribute.
public property | PrecisionSource | Gets or sets the precision source for the attribute.
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or indicates whether the data sources are invalid.

See Also

Reference

MoneyAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


MoneyAttributeMetadata.CalculationOf Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CalculationOf As String

C#
[DataMemberAttribute]
public string CalculationOf { get; set; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Remarks
If this property is not assigned a value, it defaults to null.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.FormulaDefinition Property
[image]

Gets or sets the formula definition for calculated and rollup attributes.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property FormulaDefinition As String

C#
[DataMemberAttribute(Order=70)]
public string FormulaDefinition { get; set; }

C++

J#

JScript

Property Value
Type: String
The formula definition for calculated and rollup attributes.

  Remarks
If you want to edit the value of this property, you have to use the formula editor in the application. More information:Customization Guide: Define Calculated Fields and Customization Guide: Define Rollup Fields.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes


MoneyAttributeMetadata.ImeMode Property
[image]

Gets or sets the input method editor (IME) mode for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ImeMode As Nullable(Of ImeMode)

C#
[DataMemberAttribute]
public Nullable<ImeMode> ImeMode { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<ImeMode>

The input method editor (IME) mode for the attribute..

  Remarks
If this property is not assigned a value, it defaults to Disabled.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.IsBaseCurrency Property
[image]

Gets whether the attribute represents the base currency or the transaction currency.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property IsBaseCurrency As Nullable(Of Boolean)

C#
[DataMemberAttribute(Order=70)]
public Nullable<bool> IsBaseCurrency { get; }

C++

J#

JScript

Property Value
Type : Nullable<Boolean>
true if the attribute is the base currency; otherwise, false.

  Remarks
Each transaction currency money attribute in an entity will have a corresponding base currency money attribute that uses the following naming convention: <money attribute name>_Base. This property identifies whether the attribute is the base currency money attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.MaxValue Property
[image]

Gets or sets the maximum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxValue As Nullable(Of Double)

C#
[DataMemberAttribute]
public Nullable<double> MaxValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Double>

The maximum value for the attribute.

  Remarks
If this property is not assigned a value, it defaults to 1000000000.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.MinValue Property
[image]

Gets or sets the minimum value for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MinValue As Nullable(Of Double)

C#
[DataMemberAttribute]
public Nullable<double> MinValue { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Double>

The minimum value for the attribute.

  Remarks
If this property is not assigned a value, it defaults to 0.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.Precision Property
[image]

Gets or sets the precision for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Precision As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> Precision { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The precision for the attribute.

  Remarks
If this property is not assigned a value, it defaults to 2.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.PrecisionSource Property
[image]

Gets or sets the precision source for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PrecisionSource As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> PrecisionSource { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The precision source for the attribute.

  Remarks
If this property is not assigned a value, it defaults to 2.
For most money fields the precision comes from the Precision property. However, for money fields related to price, the precision come from the organization.pricingdecimalprecision. For money fields which use another currency the TransactionCurrency. CurrencyPrecision may be used.
Valid values for this property are:
Value | Description
0 | Precision specified in the MoneyAttributeMetadata. Precision property should be used.
1 | Precision specified in Organization. PricingDecimalPrecision attribute should be used.
2 | Precision specified in the TransactionCurrency. CurrencyPrecision property of the transaction currency that is associated the current record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


MoneyAttributeMetadata.SourceTypeMask Property
[image]

Gets the bitmask value that describes the sources of data used in a calculated attribute or indicates whether the data sources are invalid.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property SourceTypeMask As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=70)]
public Nullable<int> SourceTypeMask { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The value that indicates the source of data for a calculated or rollup attribute.

  Remarks
The following table contains the valid values for this attribute:
Value | Description
0 | Undefined: The default value for simple and rollup attributes.
1 | Simple: The calculated attribute refers to an attribute in the same record.
2 | Related: The calculated attribute refers to an attribute in a related record.
4 | Logical: The calculated attribute refers to an attribute in the same record that is actually stored in a different database table. More information:Logical attributes.
8 | Calculated: The calculated attribute refers to another calculated attribute.
16 | Rollup: The calculated attribute refers a rollup attribute.
32 | Invalid: The calculated or rollup attribute is invalid. Typically this would be where a field refers to an attribute that no longer exists.
The SourceTypeMasks enumeration is useful when performing bitwise operations to check whether specific values are present in this bitmask value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MoneyAttributeMetadata Class
MoneyAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes
SourceTypeMasks enumeration
Logical attributes


OneToManyRelationshipMetadata Class
See Also Members
[image]

Contains the metadata for a one-to-many entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OneToManyRelationshipMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class OneToManyRelationshipMetadata
    Inherits RelationshipMetadataBase

C#
[DataContractAttribute(Name="OneToManyRelationshipMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class OneToManyRelationshipMetadata : RelationshipMetadataBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.RelationshipMetadataBase
      Microsoft.Xrm.Sdk.Metadata.OneToManyRelationshipMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OneToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Relationship Metadata


OneToManyRelationshipMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for a one-to-many entity relationship.

The following tables list the members exposed by the OneToManyRelationshipMetadata type.

Public Constructors

Name | Description
OneToManyRelationshipMetadata | Initializes a new instance of theOneToManyRelationshipMetadata class
Top

Public Properties

 | Name | Description
public property | AssociatedMenuConfiguration | Gets or sets the associated menu configuration.
public property | CascadeConfiguration | Gets or sets cascading behaviors for the entity relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from RelationshipMetadataBase)
public property | IsCustomizable | Gets or sets whether the entity relationship is customizable. (inherited from RelationshipMetadataBase)
public property | IsCustomRelationship | Gets whether the relationship is a custom relationship. (inherited from RelationshipMetadataBase)
public property | IsHierarchical | Gets or sets whether this relationship is the designated hierarchical self-referential relationship for this entity.
public property | IsManaged | Gets whether the entity relationship is part of a managed solution. (inherited from RelationshipMetadataBase)
public property | IsValidForAdvancedFind | Gets or sets whether the entity relationship should be shown in Advanced Find. (inherited from RelationshipMetadataBase)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | ReferencedAttribute | Get or set the name of primary attribute for the referenced entity.
public property | ReferencedEntity | Get or set the name of the referenced entity.
public property | ReferencingAttribute | Get or set the name of the referencing attribute.
public property | ReferencingEntity | Gets or sets the name of the referencing entity.
public property | RelationshipType | Gets the type of relationship. (inherited from RelationshipMetadataBase)
public property | SchemaName | Gets or sets the schema name for the entity relationship. (inherited from RelationshipMetadataBase)
public property | SecurityTypes | Gets or sets the security type for the relationship. (inherited from RelationshipMetadataBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OneToManyRelationshipMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Relationship Metadata


OneToManyRelationshipMetadata Constructor
[image]

Initializes a new instance of the OneToManyRelationshipMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OneToManyRelationshipMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OneToManyRelationshipMetadata Class
OneToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OneToManyRelationshipMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OneToManyRelationshipMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Relationship Metadata


OneToManyRelationshipMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AssociatedMenuConfiguration | Gets or sets the associated menu configuration.
public property | CascadeConfiguration | Gets or sets cascading behaviors for the entity relationship.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from RelationshipMetadataBase)
public property | IsCustomizable | Gets or sets whether the entity relationship is customizable. (inherited from RelationshipMetadataBase)
public property | IsCustomRelationship | Gets whether the relationship is a custom relationship. (inherited from RelationshipMetadataBase)
public property | IsHierarchical | Gets or sets whether this relationship is the designated hierarchical self-referential relationship for this entity.
public property | IsManaged | Gets whether the entity relationship is part of a managed solution. (inherited from RelationshipMetadataBase)
public property | IsValidForAdvancedFind | Gets or sets whether the entity relationship should be shown in Advanced Find. (inherited from RelationshipMetadataBase)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | ReferencedAttribute | Get or set the name of primary attribute for the referenced entity.
public property | ReferencedEntity | Get or set the name of the referenced entity.
public property | ReferencingAttribute | Get or set the name of the referencing attribute.
public property | ReferencingEntity | Gets or sets the name of the referencing entity.
public property | RelationshipType | Gets the type of relationship. (inherited from RelationshipMetadataBase)
public property | SchemaName | Gets or sets the schema name for the entity relationship. (inherited from RelationshipMetadataBase)
public property | SecurityTypes | Gets or sets the security type for the relationship. (inherited from RelationshipMetadataBase)

See Also

Reference

OneToManyRelationshipMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Relationship Metadata


OneToManyRelationshipMetadata.AssociatedMenuConfiguration Property
[image]

Gets or sets the associated menu configuration.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AssociatedMenuConfiguration As AssociatedMenuConfiguration

C#
[DataMemberAttribute]
public AssociatedMenuConfiguration AssociatedMenuConfiguration { get; set; }

C++

J#

JScript

Property Value
Type: AssociatedMenuConfiguration
The associated menu configuration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OneToManyRelationshipMetadata Class
OneToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OneToManyRelationshipMetadata.CascadeConfiguration Property
[image]

Gets or sets cascading behaviors for the entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CascadeConfiguration As CascadeConfiguration

C#
[DataMemberAttribute]
public CascadeConfiguration CascadeConfiguration { get; set; }

C++

J#

JScript

Property Value
Type: CascadeConfiguration
The cascading behaviors for the entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OneToManyRelationshipMetadata Class
OneToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Configuring Entity Relationship Behavior


OneToManyRelationshipMetadata.IsHierarchical Property
[image]

Gets or sets whether this relationship is the designated hierarchical self-referential relationship for this entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsHierarchical As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsHierarchical { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if this relationships is the designated hierarchical self-referential relationship for this entity; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OneToManyRelationshipMetadata Class
OneToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Hierarchical one-to-many entity relationships
Query hierarchical data


OneToManyRelationshipMetadata.ReferencedAttribute Property
[image]

Get or set the name of primary attribute for the referenced entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ReferencedAttribute As String

C#
[DataMemberAttribute]
public string ReferencedAttribute { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of primary attribute for the referenced entity..

  Remarks
For example, if Account is the referenced entity the referenced attribute would be accountid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OneToManyRelationshipMetadata Class
OneToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OneToManyRelationshipMetadata.ReferencedEntity Property
[image]

Get or set the name of the referenced entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ReferencedEntity As String

C#
[DataMemberAttribute]
public string ReferencedEntity { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the referenced entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OneToManyRelationshipMetadata Class
OneToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OneToManyRelationshipMetadata.ReferencingAttribute Property
[image]

Get or set the name of the referencing attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ReferencingAttribute As String

C#
[DataMemberAttribute]
public string ReferencingAttribute { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the referencing attribute.

  Remarks
The referencing attribute is a lookup attribute created on the referencing entity when the one-to-many entity relationship is created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OneToManyRelationshipMetadata Class
OneToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OneToManyRelationshipMetadata.ReferencingEntity Property
[image]

Gets or sets the name of the referencing entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ReferencingEntity As String

C#
[DataMemberAttribute]
public string ReferencingEntity { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the referencing entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OneToManyRelationshipMetadata Class
OneToManyRelationshipMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadata Class
See Also Members
[image]

Contains metadata representing an option within an Option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(StatusOptionMetadata))> _
<DataContractAttribute(Name:="OptionMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
<KnownTypeAttribute(GetType(StateOptionMetadata))> _
Public Class OptionMetadata
    Inherits MetadataBase

C#
[KnownTypeAttribute(typeof(StatusOptionMetadata))]
[DataContractAttribute(Name="OptionMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
[KnownTypeAttribute(typeof(StateOptionMetadata))]
public class OptionMetadata : MetadataBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase
    Microsoft.Xrm.Sdk.Metadata.OptionMetadata

                Microsoft.Xrm.Sdk.Metadata.StateOptionMetadata

                Microsoft.Xrm.Sdk.Metadata.StatusOptionMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Global Option Sets in Microsoft Dynamics CRM


OptionMetadata Members
See Also Constructors Methods Properties
[image]

Contains metadata representing an option within an Option set.

The following tables list the members exposed by the OptionMetadata type.

Public Constructors

Name | Description
OptionMetadata | Overloaded. Initializes a new instance of the OptionMetadata class
Top

Public Properties

 | Name | Description
public property | Description | Gets or sets the label containing the description for the option.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IsManaged | Gets whether the option is part of a managed solution.
public property | Label | Gets or sets the label containing the text for the option.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Value | Gets or sets the value of the option.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OptionMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionMetadata Constructor
[image]

Initializes a new instance of the OptionMetadata class

Overload List

Name | Description
OptionMetadata () | Initializes a new instance of theOptionMetadata class
OptionMetadata (Label, Nullable) | Initializes a new instance of the OptionMetadata class
OptionMetadata (Int32) | Initializes a new instance of the OptionMetadata class

See Also

Reference

OptionMetadata Class
OptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadata Constructor ()
[image]

Initializes a new instance of the OptionMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OptionMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadata Class
OptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadata Constructor (Label, Nullable)
[image]

Initializes a new instance of the OptionMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    label As Label, _
    value As Nullable(Of Integer) _
)

C#
public OptionMetadata (
    Label label,
    Nullable<int> value
)

C++

J#

JScript

Parameters
label
Type: LabelThe label containing the text for the option..
value
Type: Nullable<Int32>
The value of the option.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadata Class
OptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadata Constructor (Int32)
[image]

Initializes a new instance of the OptionMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As Integer _
)

C#
public OptionMetadata (
    int value
)

C++

J#

JScript

Parameters
value
Type: Nullable<Int32>
The value of the option.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadata Class
OptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OptionMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionMetadata Properties
[image]

Public Properties

 | Name | Description
public property | Description | Gets or sets the label containing the description for the option.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IsManaged | Gets whether the option is part of a managed solution.
public property | Label | Gets or sets the label containing the text for the option.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Value | Gets or sets the value of the option.

See Also

Reference

OptionMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionMetadata.Description Property
[image]

Gets or sets the label containing the description for the option.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Description As Label

C#
[DataMemberAttribute]
public Label Description { get; set; }

C++

J#

JScript

Property Value
Type: Label
The label containing the description for the option..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadata Class
OptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadata.IsManaged Property
[image]

Gets whether the option is part of a managed solution.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsManaged As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsManaged { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the option is part of a managed solution.; otherwise, false
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadata Class
OptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadata.Label Property
[image]

Gets or sets the label containing the text for the option.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Label As Label

C#
[DataMemberAttribute]
public Label Label { get; set; }

C++

J#

JScript

Property Value
Type: Label
The label containing the text for the option..

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadata Class
OptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadata.Value Property
[image]

Gets or sets the value of the option.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Value As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> Value { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The value of the option.

  Remarks
It is recommended that you do not set the value. Leave it null when you create the option and allow the system to generate a unique value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadata Class
OptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Merge Option Set Options


OptionMetadataCollection Class
See Also Members
[image]

Contains the options in for the OptionSetMetadata.Options class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class OptionMetadataCollection
    Inherits DataCollection(Of OptionMetadata)

C#
public sealed class OptionMetadataCollection : DataCollection<OptionMetadata>

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.ObjectModel.Collection

                Microsoft.Xrm.Sdk.DataCollection
      Microsoft.Xrm.Sdk.Metadata.OptionMetadataCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadataCollection Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Global Option Sets in Microsoft Dynamics CRM


OptionMetadataCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains the options in for the OptionSetMetadata.Options class.

The following tables list the members exposed by the OptionMetadataCollection type.

Public Constructors

Name | Description
OptionMetadataCollection | Overloaded. Initializes a new instance of the OptionMetadataCollection class
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)
Top

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)
Top

See Also

Reference

OptionMetadataCollection Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionMetadataCollection Constructor
[image]

Initializes a new instance of the OptionMetadataCollection class

Overload List

Name | Description
OptionMetadataCollection () | Initializes a new instance of the OptionMetadataCollection class
OptionMetadataCollection (IList) | Initializes a new instance of the OptionMetadataCollection class

See Also

Reference

OptionMetadataCollection Class
OptionMetadataCollection Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadataCollection Constructor ()
[image]

Initializes a new instance of the OptionMetadataCollection class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OptionMetadataCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadataCollection Class
OptionMetadataCollection Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadataCollection Constructor (IList)
[image]

Initializes a new instance of the OptionMetadataCollection class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    list As IList(Of OptionMetadata) _
)

C#
public OptionMetadataCollection (
    IList<OptionMetadata> list
)

C++

J#

JScript

Parameters
list
Type: IList<OptionMetadata>. Sets the options for the collection.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionMetadataCollection Class
OptionMetadataCollection Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionMetadataCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Collection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | (inherited from Collection)
public method | Contains | (inherited from Collection)
public method | CopyTo | (inherited from Collection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Collection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | IndexOf | (inherited from Collection)
public method | Insert | (inherited from Collection)
public method | Remove | (inherited from Collection)
public method | RemoveAt | (inherited from Collection)
public method | ToArray | Copies the elements of the DataCollection to a new array. (inherited from DataCollection)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | ClearItems | (inherited from Collection)
protected method | Finalize | (inherited from Object)
protected method | InsertItem | (inherited from Collection)
protected method | MemberwiseClone | (inherited from Object)
protected method | RemoveItem | (inherited from Collection)
protected method | SetItem | (inherited from Collection)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from Collection)
GetEnumerator | (inherited from Collection)
Add | (inherited from Collection)
Contains | (inherited from Collection)
IndexOf | (inherited from Collection)
Insert | (inherited from Collection)
Remove | (inherited from Collection)

See Also

Reference

OptionMetadataCollection Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionMetadataCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Count | (inherited from Collection)
public property | Item | (inherited from Collection)

Protected Properties

 | Name | Description
protected property | Items | (inherited from Collection)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Collection)
IsSynchronized | (inherited from Collection)
SyncRoot | (inherited from Collection)
IsFixedSize | (inherited from Collection)
IsReadOnly | (inherited from Collection)
Item | (inherited from Collection)

See Also

Reference

OptionMetadataCollection Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionSetMetadata Class
See Also Members
[image]

Contains metadata that defines a set of options.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OptionSetMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class OptionSetMetadata
    Inherits OptionSetMetadataBase

C#
[DataContractAttribute(Name="OptionSetMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class OptionSetMetadata : OptionSetMetadataBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.OptionSetMetadataBase
      Microsoft.Xrm.Sdk.Metadata.OptionSetMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Global Option Sets in Microsoft Dynamics CRM


OptionSetMetadata Members
See Also Constructors Methods Properties
[image]

Contains metadata that defines a set of options.

The following tables list the members exposed by the OptionSetMetadata type.

Public Constructors

Name | Description
OptionSetMetadata | Overloaded. Initializes a new instance of the OptionSetMetadata class
Top

Public Properties

 | Name | Description
public property | Description | Gets or sets a description for the option set. (inherited from OptionSetMetadataBase)
public property | DisplayName | Gets or sets a display name for a global option set. (inherited from OptionSetMetadataBase)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from OptionSetMetadataBase)
public property | IsCustomizable | Gets or sets a property that determines whether the option set is customizable. (inherited from OptionSetMetadataBase)
public property | IsCustomOptionSet | Gets or sets whether the option set is a custom option set. (inherited from OptionSetMetadataBase)
public property | IsGlobal | Gets or sets whether the option set is a global option set. (inherited from OptionSetMetadataBase)
public property | IsManaged | Gets or sets whether the option set is part of a managed solution. (inherited from OptionSetMetadataBase)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Name | Gets or sets the name of a global option set. (inherited from OptionSetMetadataBase)
public property | Options | Gets the options available in the option set.
public property | OptionSetType | Gets or sets the type of option set. (inherited from OptionSetMetadataBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OptionSetMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionSetMetadata Constructor
[image]

Initializes a new instance of the OptionSetMetadata class

Overload List

Name | Description
OptionSetMetadata () | Initializes a new instance of theOptionSetMetadata class
OptionSetMetadata (OptionMetadataCollection) | Initializes a new instance of the OptionSetMetadata class

See Also

Reference

OptionSetMetadata Class
OptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadata Constructor ()
[image]

Initializes a new instance of the OptionSetMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OptionSetMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadata Class
OptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadata Constructor (OptionMetadataCollection)
[image]

Initializes a new instance of the OptionSetMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    options As OptionMetadataCollection _
)

C#
public OptionSetMetadata (
    OptionMetadataCollection options
)

C++

J#

JScript

Parameters
options
Type: OptionMetadataCollectionThe options available in the option set.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadata Class
OptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OptionSetMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionSetMetadata Properties
[image]

Public Properties

 | Name | Description
public property | Description | Gets or sets a description for the option set. (inherited from OptionSetMetadataBase)
public property | DisplayName | Gets or sets a display name for a global option set. (inherited from OptionSetMetadataBase)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from OptionSetMetadataBase)
public property | IsCustomizable | Gets or sets a property that determines whether the option set is customizable. (inherited from OptionSetMetadataBase)
public property | IsCustomOptionSet | Gets or sets whether the option set is a custom option set. (inherited from OptionSetMetadataBase)
public property | IsGlobal | Gets or sets whether the option set is a global option set. (inherited from OptionSetMetadataBase)
public property | IsManaged | Gets or sets whether the option set is part of a managed solution. (inherited from OptionSetMetadataBase)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Name | Gets or sets the name of a global option set. (inherited from OptionSetMetadataBase)
public property | Options | Gets the options available in the option set.
public property | OptionSetType | Gets or sets the type of option set. (inherited from OptionSetMetadataBase)

See Also

Reference

OptionSetMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionSetMetadata.Options Property
[image]

Gets the options available in the option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Options As OptionMetadataCollection

C#
[DataMemberAttribute]
public OptionMetadataCollection Options { get; }

C++

J#

JScript

Property Value
Type: OptionMetadataCollection
The options available in the option set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadata Class
OptionSetMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase Class
See Also Members
[image]

Contains data that defines a set of options.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(BooleanOptionSetMetadata))> _
<KnownTypeAttribute(GetType(OptionSetMetadata))> _
<DataContractAttribute(Name:="OptionSetMetadataBase", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public MustInherit Class OptionSetMetadataBase
    Inherits MetadataBase

C#
[KnownTypeAttribute(typeof(BooleanOptionSetMetadata))]
[KnownTypeAttribute(typeof(OptionSetMetadata))]
[DataContractAttribute(Name="OptionSetMetadataBase", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public abstract class OptionSetMetadataBase : MetadataBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase
    Microsoft.Xrm.Sdk.Metadata.OptionSetMetadataBase

                Microsoft.Xrm.Sdk.Metadata.BooleanOptionSetMetadata

                Microsoft.Xrm.Sdk.Metadata.OptionSetMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Global Option Sets in Microsoft Dynamics CRM


OptionSetMetadataBase Members
See Also Methods Properties Constructors
[image]

Contains data that defines a set of options.

The following tables list the members exposed by the OptionSetMetadataBase type.

Protected Constructors

Name | Description
OptionSetMetadataBase | Initializes a new instance of the OptionSetMetadataBase class
Top

Public Properties

 | Name | Description
public property | Description | Gets or sets a description for the option set.
public property | DisplayName | Gets or sets a display name for a global option set.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsCustomizable | Gets or sets a property that determines whether the option set is customizable.
public property | IsCustomOptionSet | Gets or sets whether the option set is a custom option set.
public property | IsGlobal | Gets or sets whether the option set is a global option set.
public property | IsManaged | Gets or sets whether the option set is part of a managed solution.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Name | Gets or sets the name of a global option set.
public property | OptionSetType | Gets or sets the type of option set.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OptionSetMetadataBase Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionSetMetadataBase Constructor
[image]

Initializes a new instance of the OptionSetMetadataBase class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected OptionSetMetadataBase ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OptionSetMetadataBase Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionSetMetadataBase Properties
[image]

Public Properties

 | Name | Description
public property | Description | Gets or sets a description for the option set.
public property | DisplayName | Gets or sets a display name for a global option set.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsCustomizable | Gets or sets a property that determines whether the option set is customizable.
public property | IsCustomOptionSet | Gets or sets whether the option set is a custom option set.
public property | IsGlobal | Gets or sets whether the option set is a global option set.
public property | IsManaged | Gets or sets whether the option set is part of a managed solution.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Name | Gets or sets the name of a global option set.
public property | OptionSetType | Gets or sets the type of option set.

See Also

Reference

OptionSetMetadataBase Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Global Option Sets in Microsoft Dynamics CRM


OptionSetMetadataBase.Description Property
[image]

Gets or sets a description for the option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Description As Label

C#
[DataMemberAttribute]
public Label Description { get; set; }

C++

J#

JScript

Property Value
Type: Label
The description for the option set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase.DisplayName Property
[image]

Gets or sets a display name for a global option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DisplayName As Label

C#
[DataMemberAttribute]
public Label DisplayName { get; set; }

C++

J#

JScript

Property Value
Type: Label
The display name for a global option set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase.IntroducedVersion Property
[image]

Gets a string identifying the solution version that the solution component was added in.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property IntroducedVersion As String

C#
[DataMemberAttribute(Order=60)]
public string IntroducedVersion { get; }

C++

J#

JScript

Property Value
Type: String

A string identifying the solution version that the solution component was added in.

  Remarks

                        This identifies the major and minor versions of the solution that added this metadata item. For metadata that existed in Microsoft Dynamics CRM 2011 the value will be 5.0.0.0 and for metadata added with Microsoft Dynamics CRM 2013 the value will be 6.0.0.0. If new metadata is added in updates or future releases the version number will be incremented to the corresponding version. For metadata added by custom solutions the version of the solution that the item was created it is used.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase.IsCustomizable Property
[image]

Gets or sets a property that determines whether the option set is customizable.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsCustomizable As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsCustomizable { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
The property that determines whether the option set is customizable.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase.IsCustomOptionSet Property
[image]

Gets or sets whether the option set is a custom option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsCustomOptionSet As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsCustomOptionSet { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the option set is a custom option set; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase.IsGlobal Property
[image]

Gets or sets whether the option set is a global option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsGlobal As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsGlobal { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the option set is a global option set; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase.IsManaged Property
[image]

Gets or sets whether the option set is part of a managed solution.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsManaged As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsManaged { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the option set is part of a managed solution; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase.Name Property
[image]

Gets or sets the name of a global option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Name As String

C#
[DataMemberAttribute]
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of a global option set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetMetadataBase.OptionSetType Property
[image]

Gets or sets the type of option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OptionSetType As Nullable(Of OptionSetType)

C#
[DataMemberAttribute]
public Nullable<OptionSetType> OptionSetType { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<OptionSetType>

The type of option set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OptionSetMetadataBase Class
OptionSetMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


OptionSetType Enumeration
[image]

Indicates the type of option set.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OptionSetType", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration OptionSetType

C#
[DataContractAttribute(Name="OptionSetType", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum OptionSetType

C++

J#

JScript

  Members
Member name | Description
Boolean | The option set provides two options for a BooleanAttributeMetadata attribute. Value = 3.
Picklist | The option set provides a list of options. Value = 0.
State | The option set represents state options for a StateAttributeMetadata attribute. Value = 1.
Status | The option set represents status options for a StatusAttributeMetadata attribute. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace


OwnershipTypes Enumeration
[image]

Specifies the type of ownership for an entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FlagsAttribute> _
<DataContractAttribute(Name:="OwnershipTypes", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration OwnershipTypes

C#
[FlagsAttribute]
[DataContractAttribute(Name="OwnershipTypes", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum OwnershipTypes

C++

J#

JScript

  Members
Member name | Description
BusinessOwned | The entity is owned by a business unit. For internal use only. Value = 4.
BusinessParented | The entity is parented by a business unit. For internal use only. Value = 16.
None | The entity does not have an owner. For internal use only. Value = 0.
OrganizationOwned | The entity is owned by an organization. Value = 8.
TeamOwned | The entity is owned by a team. For internal use only.Value = 2.
UserOwned | The entity is owned by a system user. Value = 1.
  Remarks
The only valid values for custom entities are OrgOwned or UserOwned. For Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online, all UserOwned entities can be assigned to teams.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
OwnershipType
Other Resources
Entity Ownership
Options Available When Creating a Custom Entity


PicklistAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute type Picklist.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="PicklistAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class PicklistAttributeMetadata
    Inherits EnumAttributeMetadata

C#
[DataContractAttribute(Name="PicklistAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class PicklistAttributeMetadata : EnumAttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata

                Microsoft.Xrm.Sdk.Metadata.EnumAttributeMetadata
        Microsoft.Xrm.Sdk.Metadata.PicklistAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PicklistAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata
Work with Attributes


PicklistAttributeMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an attribute type Picklist.

The following tables list the members exposed by the PicklistAttributeMetadata type.

Public Constructors

Name | Description
PicklistAttributeMetadata | Overloaded. Initializes a new instance of the PicklistAttributeMetadata class.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute. (inherited from EnumAttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute. (inherited from EnumAttributeMetadata)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PicklistAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


PicklistAttributeMetadata Constructor
[image]

Initializes a new instance of the PicklistAttributeMetadata class.

Overload List

Name | Description
PicklistAttributeMetadata () | Initializes a new instance of the PicklistAttributeMetadata class.
PicklistAttributeMetadata (String) | Initializes a new instance of the PicklistAttributeMetadata class.

See Also

Reference

PicklistAttributeMetadata Class
PicklistAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


PicklistAttributeMetadata Constructor ()
[image]

Initializes a new instance of the PicklistAttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PicklistAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PicklistAttributeMetadata Class
PicklistAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


PicklistAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the PicklistAttributeMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public PicklistAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String
The schema name of the attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PicklistAttributeMetadata Class
PicklistAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


PicklistAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PicklistAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


PicklistAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute. (inherited from EnumAttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute. (inherited from EnumAttributeMetadata)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

See Also

Reference

PicklistAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Work with Attributes


PicklistAttributeMetadata.FormulaDefinition Property
[image]

Gets or sets the formula definition for calculated and rollup attributes.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property FormulaDefinition As String

C#
[DataMemberAttribute(Order=70)]
public string FormulaDefinition { get; set; }

C++

J#

JScript

Property Value
Type: String
The formula definition for calculated and rollup attributes.

  Remarks
To edit this property, you must use the formula editor in the application. More information:Customization Guide: Define Calculated Fields and Customization Guide: Define Rollup Fields.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PicklistAttributeMetadata Class
PicklistAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes


PicklistAttributeMetadata.SourceTypeMask Property
[image]

Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property SourceTypeMask As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=70)]
public Nullable<int> SourceTypeMask { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The value that indicates the source of data for a calculated or rollup attribute.

  Remarks
The following table contains the valid values for this attribute.
Value | Description
0 | Undefined: The default value for simple and rollup attributes.
1 | Simple: The calculated attribute refers to an attribute in the same record.
2 | Related: The calculated attribute refers to an attribute in a related record.
4 | Logical: The calculated attribute refers to an attribute in the same record that is actually stored in a different database table. More information:Logical attributes.
8 | Calculated: The calculated attribute refers to another calculated attribute.
16 | Rollup: The calculated attribute refers a rollup attribute.
32 | Invalid: The calculated or rollup attribute is invalid. Typically this would be where a field refers to an attribute that no longer exists.
The SourceTypeMasks enumeration is useful when performing bitwise operations to check whether specific values are present in this bitmask value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PicklistAttributeMetadata Class
PicklistAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes
SourceTypeMasks enumeration
Logical attributes


PrivilegeType Enumeration
[image]

Describes the type of operation for the privilege

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="PrivilegeType", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration PrivilegeType

C#
[DataContractAttribute(Name="PrivilegeType", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum PrivilegeType

C++

J#

JScript

  Members
Member name | Description
Append | The append privilege. Value = 7.
AppendTo | The append to privilege. Value = 8.
Assign | The assign privilege. Value = 5.
Create | The create privilege. Value = 1.
Delete | The delete privilege. Value = 4.
None | Specifies no privilege. Value = 0.
Read | The read privilege. Value = 2.
Share | The share privilege. Value = 6.
Write | The write privilege. Value = 3.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
How Role-Based Security Can Be Used to Control Access to Entities In Microsoft Dynamics CRM


RelationshipMetadataBase Class
See Also Members
[image]

Contains the metadata for an entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RelationshipMetadataBase", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
<KnownTypeAttribute(GetType(OneToManyRelationshipMetadata))> _
<KnownTypeAttribute(GetType(ManyToManyRelationshipMetadata))> _
Public MustInherit Class RelationshipMetadataBase
    Inherits MetadataBase

C#
[DataContractAttribute(Name="RelationshipMetadataBase", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
[KnownTypeAttribute(typeof(OneToManyRelationshipMetadata))]
[KnownTypeAttribute(typeof(ManyToManyRelationshipMetadata))]
public abstract class RelationshipMetadataBase : MetadataBase

C++

J#

JScript

  Remarks
This is the base class used by OneToManyRelationshipMetadata and ManyToManyRelationshipMetadata.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase
    Microsoft.Xrm.Sdk.Metadata.RelationshipMetadataBase

                Microsoft.Xrm.Sdk.Metadata.ManyToManyRelationshipMetadata

                Microsoft.Xrm.Sdk.Metadata.OneToManyRelationshipMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Relationship Metadata


RelationshipMetadataBase Members
See Also Methods Properties Constructors
[image]

Contains the metadata for an entity relationship.

The following tables list the members exposed by the RelationshipMetadataBase type.

Protected Constructors

Name | Description
RelationshipMetadataBase | Overloaded.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsCustomizable | Gets or sets whether the entity relationship is customizable.
public property | IsCustomRelationship | Gets whether the relationship is a custom relationship.
public property | IsManaged | Gets whether the entity relationship is part of a managed solution.
public property | IsValidForAdvancedFind | Gets or sets whether the entity relationship should be shown in Advanced Find.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RelationshipType | Gets the type of relationship.
public property | SchemaName | Gets or sets the schema name for the entity relationship.
public property | SecurityTypes | Gets or sets the security type for the relationship.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RelationshipMetadataBase Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Relationship Metadata


RelationshipMetadataBase Constructor
[image]

Overload List

Name | Description
RelationshipMetadataBase () | Initializes a new instance of the RelationshipMetadataBase class
RelationshipMetadataBase (RelationshipType) | Initializes a new instance of the RelationshipMetadataBase class

See Also

Reference

RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipMetadataBase Constructor ()
[image]

Initializes a new instance of the RelationshipMetadataBase class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected RelationshipMetadataBase ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipMetadataBase Constructor (RelationshipType)
[image]

Initializes a new instance of the RelationshipMetadataBase class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    type As RelationshipType _
)

C#
protected RelationshipMetadataBase (
    RelationshipType type
)

C++

J#

JScript

Parameters
type
Type: RelationshipType
The type of relationship.
  Remarks

                        For internal use only.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipMetadataBase Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RelationshipMetadataBase Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Relationship Metadata


RelationshipMetadataBase Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in.
public property | IsCustomizable | Gets or sets whether the entity relationship is customizable.
public property | IsCustomRelationship | Gets whether the relationship is a custom relationship.
public property | IsManaged | Gets whether the entity relationship is part of a managed solution.
public property | IsValidForAdvancedFind | Gets or sets whether the entity relationship should be shown in Advanced Find.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RelationshipType | Gets the type of relationship.
public property | SchemaName | Gets or sets the schema name for the entity relationship.
public property | SecurityTypes | Gets or sets the security type for the relationship.

See Also

Reference

RelationshipMetadataBase Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Relationship Metadata


RelationshipMetadataBase.IntroducedVersion Property
[image]

Gets a string identifying the solution version that the solution component was added in.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property IntroducedVersion As String

C#
[DataMemberAttribute(Order=60)]
public string IntroducedVersion { get; }

C++

J#

JScript

Property Value
Type: String

A string identifying the solution version that the solution component was added in.

  Remarks

                        This identifies the major and minor versions of the solution that added this metadata item. For metadata that existed in Microsoft Dynamics CRM 2011 the value will be 5.0.0.0 and for metadata added with Microsoft Dynamics CRM 2013 the value will be 6.0.0.0. If new metadata is added in updates or future releases the version number will be incremented to the corresponding version. For metadata added by custom solutions the version of the solution that the item was created it is used.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipMetadataBase.IsCustomizable Property
[image]

Gets or sets whether the entity relationship is customizable.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsCustomizable As BooleanManagedProperty

C#
[DataMemberAttribute]
public BooleanManagedProperty IsCustomizable { get; set; }

C++

J#

JScript

Property Value
Type: BooleanManagedProperty
Whether the entity relationship is customizable.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Use Managed Properties


RelationshipMetadataBase.IsCustomRelationship Property
[image]

Gets whether the relationship is a custom relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsCustomRelationship As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsCustomRelationship { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the relationship is a custom relationship; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipMetadataBase.IsManaged Property
[image]

Gets whether the entity relationship is part of a managed solution.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsManaged As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsManaged { get; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity relationships is part of a managed solution; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipMetadataBase.IsValidForAdvancedFind Property
[image]

Gets or sets whether the entity relationship should be shown in Advanced Find.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property IsValidForAdvancedFind As Nullable(Of Boolean)

C#
[DataMemberAttribute]
public Nullable<bool> IsValidForAdvancedFind { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the entity relationship should be shown in Advanced Find; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipMetadataBase.RelationshipType Property
[image]

Gets the type of relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property RelationshipType As RelationshipType

C#
[DataMemberAttribute(Order=60)]
public RelationshipType RelationshipType { get; }

C++

J#

JScript

Property Value
Type:RelationshipType.

  Remarks
This attribute provides a way for a RelationshipQueryExpression to differentiate between ManyToMany relationships and OneToMany relationships.
This value will be set by the system. You should not set this value when you create an entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipMetadataBase.SchemaName Property
[image]

Gets or sets the schema name for the entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SchemaName As String

C#
[DataMemberAttribute]
public string SchemaName { get; set; }

C++

J#

JScript

Property Value
Type: String

The schema name for the entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipMetadataBase.SecurityTypes Property
[image]

Gets or sets the security type for the relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property SecurityTypes As Nullable(Of SecurityTypes)

C#
[DataMemberAttribute]
public Nullable<SecurityTypes> SecurityTypes { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<SecurityTypes>

The security type for the relationship.

  Remarks
This value will be set by the system. You should not set this value when you create an entity relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipMetadataBase Class
RelationshipMetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace


RelationshipType Enumeration
[image]

Specifies the type of entity relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RelationshipType", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration RelationshipType

C#
[DataContractAttribute(Name="RelationshipType", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum RelationshipType

C++

J#

JScript

  Members
Member name | Description
Default | The default value. Equivalent to OneToManyRelationship. Value = 0.
ManyToManyRelationship | The entity relationship is a Many-to-Many relationship. Value = 1.
OneToManyRelationship | The entity relationship is a One-to-Many relationship. Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata Class
See Also Members
[image]

Contains the metadata that describes a security privilege for access to an entity.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="SecurityPrivilegeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class SecurityPrivilegeMetadata
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="SecurityPrivilegeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class SecurityPrivilegeMetadata : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Metadata.SecurityPrivilegeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityPrivilegeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata Members
See Also Methods Properties
[image]

Contains the metadata that describes a security privilege for access to an entity.

The following tables list the members exposed by the SecurityPrivilegeMetadata type.

Public Properties

 | Name | Description
public property | CanBeBasic | Gets whether the privilege can be basic access level.
public property | CanBeDeep | Gets whether the privilege can be deep access level.
public property | CanBeGlobal | Gets whether the privilege can be global access level.
public property | CanBeLocal | Gets whether the privilege can be local access level.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Name | Gets the name of the privilege.
public property | PrivilegeId | Gets the ID of the privilege.
public property | PrivilegeType | Gets the type of the privilege.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SecurityPrivilegeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SecurityPrivilegeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | CanBeBasic | Gets whether the privilege can be basic access level.
public property | CanBeDeep | Gets whether the privilege can be deep access level.
public property | CanBeGlobal | Gets whether the privilege can be global access level.
public property | CanBeLocal | Gets whether the privilege can be local access level.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Name | Gets the name of the privilege.
public property | PrivilegeId | Gets the ID of the privilege.
public property | PrivilegeType | Gets the type of the privilege.

See Also

Reference

SecurityPrivilegeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata.CanBeBasic Property
[image]

Gets whether the privilege can be basic access level.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeBasic As Boolean

C#
[DataMemberAttribute]
public bool CanBeBasic { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the privilege can be basic access level.; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityPrivilegeMetadata Class
SecurityPrivilegeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata.CanBeDeep Property
[image]

Gets whether the privilege can be deep access level.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeDeep As Boolean

C#
[DataMemberAttribute]
public bool CanBeDeep { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the privilege can be deep access level; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityPrivilegeMetadata Class
SecurityPrivilegeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata.CanBeGlobal Property
[image]

Gets whether the privilege can be global access level.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeGlobal As Boolean

C#
[DataMemberAttribute]
public bool CanBeGlobal { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the privilege can be global access level; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityPrivilegeMetadata Class
SecurityPrivilegeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata.CanBeLocal Property
[image]

Gets whether the privilege can be local access level.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property CanBeLocal As Boolean

C#
[DataMemberAttribute]
public bool CanBeLocal { get; }

C++

J#

JScript

Property Value
Type: Boolean
true if the privilege can be local access level; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityPrivilegeMetadata Class
SecurityPrivilegeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityPrivilegeMetadata Class
SecurityPrivilegeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata.Name Property
[image]

Gets the name of the privilege.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Name As String

C#
[DataMemberAttribute]
public string Name { get; }

C++

J#

JScript

Property Value
Type: String

The name of the privilege.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityPrivilegeMetadata Class
SecurityPrivilegeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata.PrivilegeId Property
[image]

Gets the ID of the privilege.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PrivilegeId As Guid

C#
[DataMemberAttribute]
public Guid PrivilegeId { get; }

C++

J#

JScript

Property Value
Type: Guid
 The ID of the privilege.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityPrivilegeMetadata Class
SecurityPrivilegeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityPrivilegeMetadata.PrivilegeType Property
[image]

Gets the type of the privilege.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PrivilegeType As PrivilegeType

C#
[DataMemberAttribute]
public PrivilegeType PrivilegeType { get; }

C++

J#

JScript

Property Value
Type: PrivilegeType
The type of the privilege.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SecurityPrivilegeMetadata Class
SecurityPrivilegeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


SecurityTypes Enumeration
[image]

Describes the security type for the relationship.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FlagsAttribute> _
<DataContractAttribute(Name:="SecurityTypes", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration SecurityTypes

C#
[FlagsAttribute]
[DataContractAttribute(Name="SecurityTypes", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum SecurityTypes

C++

J#

JScript

  Members
Member name | Description
Append | The Append and AppendTo privileges are checked for create or update operations. Value = 1.
Inheritance | The referencing entity record inherits security from the referenced security record. Value = 8.
None | No security privileges are checked during create or update operations. Value = 0.
ParentChild | Security for the referencing entity record is derived from the referenced entity record. Value = 2.
Pointer | Security for the referencing entity record is derived from a pointer record. Value = 4.
  Remarks
This enumeration is used for the RelationshipMetadataBase.SecurityTypes property. This value is set by the system. You should not set this value.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
RelationshipMetadataBase
SecurityTypes
Other Resources
Customize Entity Relationship Metadata


StateAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute of type State.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="StateAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class StateAttributeMetadata
    Inherits EnumAttributeMetadata

C#
[DataContractAttribute(Name="StateAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class StateAttributeMetadata : EnumAttributeMetadata

C++

J#

JScript

  Remarks
This type of attribute has the label Status in the application. The options available for this attribute are read-only.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata

                Microsoft.Xrm.Sdk.Metadata.EnumAttributeMetadata
        Microsoft.Xrm.Sdk.Metadata.StateAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StateAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


StateAttributeMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an attribute of type State.

The following tables list the members exposed by the StateAttributeMetadata type.

Public Constructors

Name | Description
StateAttributeMetadata | Initializes a new instance of the StateAttributeMetadata class
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute. (inherited from EnumAttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute. (inherited from EnumAttributeMetadata)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StateAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StateAttributeMetadata Constructor
[image]

Initializes a new instance of the StateAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StateAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StateAttributeMetadata Class
StateAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StateAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StateAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StateAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute. (inherited from EnumAttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute. (inherited from EnumAttributeMetadata)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)

See Also

Reference

StateAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StateOptionMetadata Class
See Also Members
[image]

Contains data to define an option for the options in a State attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="StateOptionMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class StateOptionMetadata
    Inherits OptionMetadata

C#
[DataContractAttribute(Name="StateOptionMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class StateOptionMetadata : OptionMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.OptionMetadata
      Microsoft.Xrm.Sdk.Metadata.StateOptionMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StateOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


StateOptionMetadata Members
See Also Constructors Methods Properties
[image]

Contains data to define an option for the options in a State attribute.

The following tables list the members exposed by the StateOptionMetadata type.

Public Constructors

Name | Description
StateOptionMetadata | Initializes a new instance of the StateOptionMetadata class
Top

Public Properties

 | Name | Description
public property | DefaultStatus | Gets or sets the default status value associated with this state.
public property | Description | Gets or sets the label containing the description for the option. (inherited from OptionMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | InvariantName | Gets or sets the name of the state that does not change.
public property | IsManaged | Gets whether the option is part of a managed solution. (inherited from OptionMetadata)
public property | Label | Gets or sets the label containing the text for the option. (inherited from OptionMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Value | Gets or sets the value of the option. (inherited from OptionMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StateOptionMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StateOptionMetadata Constructor
[image]

Initializes a new instance of the StateOptionMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StateOptionMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StateOptionMetadata Class
StateOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StateOptionMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StateOptionMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StateOptionMetadata Properties
[image]

Public Properties

 | Name | Description
public property | DefaultStatus | Gets or sets the default status value associated with this state.
public property | Description | Gets or sets the label containing the description for the option. (inherited from OptionMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | InvariantName | Gets or sets the name of the state that does not change.
public property | IsManaged | Gets whether the option is part of a managed solution. (inherited from OptionMetadata)
public property | Label | Gets or sets the label containing the text for the option. (inherited from OptionMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | Value | Gets or sets the value of the option. (inherited from OptionMetadata)

See Also

Reference

StateOptionMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StateOptionMetadata.DefaultStatus Property
[image]

Gets or sets the default status value associated with this state.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property DefaultStatus As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> DefaultStatus { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The default status value associated with this state.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StateOptionMetadata Class
StateOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StateOptionMetadata.InvariantName Property
[image]

Gets or sets the name of the state that does not change.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property InvariantName As String

C#
[DataMemberAttribute]
public string InvariantName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the state that does not change.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StateOptionMetadata Class
StateOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StatusAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute of type Status.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="StatusAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class StatusAttributeMetadata
    Inherits EnumAttributeMetadata

C#
[DataContractAttribute(Name="StatusAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class StatusAttributeMetadata : EnumAttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata

                Microsoft.Xrm.Sdk.Metadata.EnumAttributeMetadata
        Microsoft.Xrm.Sdk.Metadata.StatusAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


StatusAttributeMetadata Members
See Also Constructors Methods Properties
[image]

Contains the metadata for an attribute of type Status.

The following tables list the members exposed by the StatusAttributeMetadata type.

Public Constructors

Name | Description
StatusAttributeMetadata | Initializes a new instance of the StatusAttributeMetadata class
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute. (inherited from EnumAttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute. (inherited from EnumAttributeMetadata)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StatusAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StatusAttributeMetadata Constructor
[image]

Initializes a new instance of the StatusAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StatusAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusAttributeMetadata Class
StatusAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StatusAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StatusAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StatusAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DefaultFormValue | Gets or sets the default form value for the attribute. (inherited from EnumAttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | OptionSet | Gets or sets the available options for the attribute. (inherited from EnumAttributeMetadata)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)

See Also

Reference

StatusAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StatusOptionMetadata Class
See Also Members
[image]

Contains one of the possible values for an attribute of type Status.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="StatusOptionMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class StatusOptionMetadata
    Inherits OptionMetadata

C#
[DataContractAttribute(Name="StatusOptionMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class StatusOptionMetadata : OptionMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.OptionMetadata
      Microsoft.Xrm.Sdk.Metadata.StatusOptionMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


StatusOptionMetadata Members
See Also Constructors Methods Properties
[image]

Contains one of the possible values for an attribute of type Status.

The following tables list the members exposed by the StatusOptionMetadata type.

Public Constructors

Name | Description
StatusOptionMetadata | Overloaded. Initializes a new instance of the StatusOptionMetadata class.
Top

Public Properties

 | Name | Description
public property | Description | Gets or sets the label containing the description for the option. (inherited from OptionMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IsManaged | Gets whether the option is part of a managed solution. (inherited from OptionMetadata)
public property | Label | Gets or sets the label containing the text for the option. (inherited from OptionMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | State | Gets or sets the state that this status is associated with.
public property | TransitionData | Gets or sets the status transitions allowed for this status.
public property | Value | Gets or sets the value of the option. (inherited from OptionMetadata)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StatusOptionMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StatusOptionMetadata Constructor
[image]

Initializes a new instance of the StatusOptionMetadata class.

Overload List

Name | Description
StatusOptionMetadata () | Initializes a new instance of the StatusOptionMetadata class.
StatusOptionMetadata (Int32, Nullable) | Initializes a new instance of the StatusOptionMetadata class.

See Also

Reference

StatusOptionMetadata Class
StatusOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StatusOptionMetadata Constructor ()
[image]

Initializes a new instance of the StatusOptionMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StatusOptionMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusOptionMetadata Class
StatusOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StatusOptionMetadata Constructor (Int32, Nullable)
[image]

Initializes a new instance of the StatusOptionMetadata class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As Integer, _
    state As Nullable(Of Integer) _
)

C#
public StatusOptionMetadata (
    int value,
    Nullable<int> state
)

C++

J#

JScript

Parameters
value
Type: Int32.
The value of the option.
state
Type: Nullable<Int32>.
The state of the option.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusOptionMetadata Class
StatusOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StatusOptionMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StatusOptionMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StatusOptionMetadata Properties
[image]

Public Properties

 | Name | Description
public property | Description | Gets or sets the label containing the description for the option. (inherited from OptionMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | IsManaged | Gets whether the option is part of a managed solution. (inherited from OptionMetadata)
public property | Label | Gets or sets the label containing the text for the option. (inherited from OptionMetadata)
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | State | Gets or sets the state that this status is associated with.
public property | TransitionData | Gets or sets the status transitions allowed for this status.
public property | Value | Gets or sets the value of the option. (inherited from OptionMetadata)

See Also

Reference

StatusOptionMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StatusOptionMetadata.State Property
[image]

Gets or sets the state that this status is associated with.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property State As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> State { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>

The state that this status is associated with.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StatusOptionMetadata Class
StatusOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StatusOptionMetadata.TransitionData Property
[image]

Gets or sets the status transitions allowed for this status.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property TransitionData As String

C#
[DataMemberAttribute]
public string TransitionData { get; set; }

C++

J#

JScript

Property Value
Type: String

The encoded XML document that defines the allowed transitions.

  Remarks
When the EntityMetadata.EnforceTransitions property is true, the data in this property defines which status changes are allowed. The document defines both the current status sourcestatusid and the allowed status values tostatusid.
Xml    Copy Code
&lt;allowedtransitions xmlns="http://schemas.microsoft.com/crm/2009/WebServices"&gt;
&lt;allowedtransition sourcestatusid="1" tostatusid="6" /&gt;
&lt;/allowedtransitions&gt;

Information about the statecode value that corresponds to the allowed status values is available by querying the StatusOptionMetadata.State property of the option with the StatusOptionMetadata.Value that corresponds to the tostatusid value.

                        More information:
                        Define custom state model transitions

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
StatusOptionMetadata Class
StatusOptionMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata Class
See Also Members
[image]

Contains the metadata for an attribute of type String.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="StringAttributeMetadata", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public NotInheritable Class StringAttributeMetadata
    Inherits AttributeMetadata

C#
[DataContractAttribute(Name="StringAttributeMetadata", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public sealed class StringAttributeMetadata : AttributeMetadata

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.MetadataBase

                Microsoft.Xrm.Sdk.Metadata.AttributeMetadata
      Microsoft.Xrm.Sdk.Metadata.StringAttributeMetadata
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


StringAttributeMetadata Members
See Also Constructors Fields Methods Properties
[image]

Contains the metadata for an attribute of type String.

The following tables list the members exposed by the StringAttributeMetadata type.

Public Constructors

Name | Description
StringAttributeMetadata | Overloaded. Initializes a new instance of the StringAttributeMetadata class
Top

Public Fields

Name | Description
MaxSupportedLength | The maximum supported length is 4000 characters.
MinSupportedLength | The minimum supported length is 1 character.
Top

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | Format | Gets or sets the format for the string
public property | FormatName | Gets or sets the format for the string.
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the IME mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLocalizable | Gets whether the attribute supports localizable values.
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxLength | Gets or sets the maximum length for the string.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.
public property | YomiOf | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StringAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StringAttributeMetadata Fields
[image]

Public Fields

Name | Description
MaxSupportedLength | The maximum supported length is 4000 characters.
MinSupportedLength | The minimum supported length is 1 character.

See Also

Reference

StringAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StringAttributeMetadata.MaxSupportedLength Field
[image]

The maximum supported length is 4000 characters.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxSupportedLength As Integer

C#
public const int MaxSupportedLength

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata.MinSupportedLength Field
[image]

The minimum supported length is 1 character.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MinSupportedLength As Integer

C#
public const int MinSupportedLength

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata Constructor
[image]

Initializes a new instance of the StringAttributeMetadata class

Overload List

Name | Description
StringAttributeMetadata () | Initializes a new instance of the StringAttributeMetadata class
StringAttributeMetadata (String) | Initializes a new instance of the StringAttributeMetadata class

See Also

Reference

StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata Constructor ()
[image]

Initializes a new instance of the StringAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StringAttributeMetadata ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata Constructor (String)
[image]

Initializes a new instance of the StringAttributeMetadata class

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    schemaName As String _
)

C#
public StringAttributeMetadata (
    string schemaName
)

C++

J#

JScript

Parameters
schemaName
Type: String.
The schema name of the attribute to create.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StringAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StringAttributeMetadata Properties
[image]

Public Properties

 | Name | Description
public property | AttributeOf | Gets the name of the attribute that this attribute extends. (inherited from AttributeMetadata)
public property | AttributeType | Gets the type for the attribute. (inherited from AttributeMetadata)
public property | AttributeTypeName | Gets the name of the type for the attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForCreate | Gets whether field-level security can be applied to prevent a user from adding data to this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForRead | Gets whether field-level security can be applied to prevent a user from viewing data from this attribute. (inherited from AttributeMetadata)
public property | CanBeSecuredForUpdate | Gets whether field-level security can be applied to prevent a user from updating data for this attribute. (inherited from AttributeMetadata)
public property | CanModifyAdditionalSettings | Gets or sets the property that determines whether any settings not controlled by managed properties can be changed. (inherited from AttributeMetadata)
public property | ColumnNumber | Gets an organization-specific ID for the attribute used for auditing. (inherited from AttributeMetadata)
public property | DeprecatedVersion | Gets the Microsoft Dynamics CRM version that the attribute was deprecated in. (inherited from AttributeMetadata)
public property | Description | Gets or sets the description of the attribute. (inherited from AttributeMetadata)
public property | DisplayName | Gets or sets the display name for the attribute. (inherited from AttributeMetadata)
public property | EntityLogicalName | Gets the logical name of the entity that contains the attribute. (inherited from AttributeMetadata)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataBase)
public property | Format | Gets or sets the format for the string
public property | FormatName | Gets or sets the format for the string.
public property | FormulaDefinition | Gets or sets the formula definition for calculated and rollup attributes.
public property | HasChanged | Gets whether the item of metadata has changed. (inherited from MetadataBase)
public property | ImeMode | Gets or sets the IME mode for the attribute.
public property | IntroducedVersion | Gets a string identifying the solution version that the solution component was added in. (inherited from AttributeMetadata)
public property | IsAuditEnabled | Gets or sets the property that determines whether the attribute is enabled for auditing. (inherited from AttributeMetadata)
public property | IsCustomAttribute | Gets whether the attribute is a custom attribute. (inherited from AttributeMetadata)
public property | IsCustomizable | Gets or sets the property that determines whether the attribute allows customization. (inherited from AttributeMetadata)
public property | IsLocalizable | Gets whether the attribute supports localizable values.
public property | IsLogical | Gets whether the attribute is a logical attribute. (inherited from AttributeMetadata)
public property | IsManaged | Gets whether the attribute is part of a managed solution. (inherited from AttributeMetadata)
public property | IsPrimaryId | Gets whether the attribute represents the unique identifier for the record. (inherited from AttributeMetadata)
public property | IsPrimaryName | Gets or sets whether the attribute represents the primary attribute for the entity. (inherited from AttributeMetadata)
public property | IsRenameable | Gets or sets the property that determines whether the attribute display name can be changed. (inherited from AttributeMetadata)
public property | IsSecured | Gets or sets whether the attribute is secured for field-level security. (inherited from AttributeMetadata)
public property | IsValidForAdvancedFind | Gets or sets the property that determines whether the attribute appears in Advanced Find. (inherited from AttributeMetadata)
public property | IsValidForCreate | Gets whether the value can be set when a record is created. (inherited from AttributeMetadata)
public property | IsValidForRead | Gets whether the value can be retrieved. (inherited from AttributeMetadata)
public property | IsValidForUpdate | Gets whether the value can be updated. (inherited from AttributeMetadata)
public property | LinkedAttributeId | Gets or sets an attribute that is linked between appointments and recurring appointments. (inherited from AttributeMetadata)
public property | LogicalName | Gets or sets the logical name for the attribute. (inherited from AttributeMetadata)
public property | MaxLength | Gets or sets the maximum length for the string.
public property | MetadataId | Gets or sets a unique identifier for the metadata item. (inherited from MetadataBase)
public property | RequiredLevel | Gets or sets the property that determines the data entry requirement level enforced for the attribute. (inherited from AttributeMetadata)
public property | SchemaName | Gets or sets the schema name for the attribute. (inherited from AttributeMetadata)
public property | SourceType | Gets or sets the value that indicates the source type for a calculated or rollup attribute. (inherited from AttributeMetadata)
public property | SourceTypeMask | Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.
public property | YomiOf | For internal use only.

See Also

Reference

StringAttributeMetadata Class
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata


StringAttributeMetadata.Format Property
[image]

Gets or sets the format for the string

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Format As Nullable(Of StringFormat)

C#
[DataMemberAttribute]
public Nullable<StringFormat> Format { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<StringFormat>

The format of the string attribute.

  Remarks
If this property is not assigned a value, and FormatName is also not assigned a value, it defaults to Text.
  Note

                        Use FormatName instead of this property to set the format. The StringFormat enumeration is deprecated. If both properties are set the FormatName value will be used.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata.FormatName Property
[image]

Gets or sets the format for the string.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property FormatName As StringFormatName

C#
[DataMemberAttribute(Order=60)]
public StringFormatName FormatName { get; set; }

C++

J#

JScript

Property Value
Type: StringFormatName
The format for the string attribute.

  Remarks
If this property is not set and Format is not set it defaults to Text.
  Note

                        Use this property rather than Format. If both properties are set, this property will be used.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata.FormulaDefinition Property
[image]

Gets or sets the formula definition for calculated and rollup attributes.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property FormulaDefinition As String

C#
[DataMemberAttribute(Order=70)]
public string FormulaDefinition { get; set; }

C++

J#

JScript

Property Value
Type: String
The formula definition for calculated and rollup attributes.

  Remarks
To edit this property, you must use the formula editor in the application. More information:Customization Guide: Define Calculated Fields and Customization Guide: Define Rollup Fields.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes


StringAttributeMetadata.ImeMode Property
[image]

Gets or sets the IME mode for the attribute.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ImeMode As Nullable(Of ImeMode)

C#
[DataMemberAttribute]
public Nullable<ImeMode> ImeMode { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<ImeMode>

The input method editor mode.

  Remarks
If this property is not assigned a value, it defaults to Auto

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata.IsLocalizable Property
[image]

Gets whether the attribute supports localizable values.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property IsLocalizable As Nullable(Of Boolean)

C#
[DataMemberAttribute(Order=70)]
public Nullable<bool> IsLocalizable { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<Boolean>
true if the attribute supports localizable values; otherwise, false.

  Remarks
The value is false for all but a few system entities that support this capability. More information:Attributes that support localized property values.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata.MaxLength Property
[image]

Gets or sets the maximum length for the string.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property MaxLength As Nullable(Of Integer)

C#
[DataMemberAttribute]
public Nullable<int> MaxLength { get; set; }

C++

J#

JScript

Property Value
Type: Nullable<int>

The maximum length.

  Remarks
Required For Create.
Increasing the maximum length of an attribute that is the source field for an attribute mapping may cause truncation of data or errors when a solution containing these attributes is imported into another system. When you increase the MaxLength of an attribute, check whether any other attributes are mapped to it and ensure that the maximum length of any attributes that are the target in the mapping are an equal or longer length. For more information, see Using Entity and Attribute Mapping Data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringAttributeMetadata.SourceTypeMask Property
[image]

Gets the bitmask value that describes the sources of data used in a calculated attribute or whether the data sources are invalid.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=70)> _
Public Property SourceTypeMask As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=70)]
public Nullable<int> SourceTypeMask { get; }

C++

J#

JScript

Property Value
Type: Nullable<Int32>
The value that indicates the source of data for a calculated or rollup attribute.

  Remarks
The following table contains the valid values for this attribute.
Value | Description
0 | Undefined: The default value for simple and rollup attributes.
1 | Simple: The calculated attribute refers to an attribute in the same record.
2 | Related: The calculated attribute refers to an attribute in a related record.
4 | Logical: The calculated attribute refers to an attribute in the same record that is actually stored in a different database table. More information:Logical attributes.
8 | Calculated: The calculated attribute refers to another calculated attribute.
16 | Rollup: The calculated attribute refers a rollup attribute.
32 | Invalid: The calculated or rollup attribute is invalid. Typically this would be where a field refers to an attribute that no longer exists.
The SourceTypeMasks enumeration is useful when performing bitwise operations to check whether specific values are present in this bitmask value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Calculated and Rollup Attributes
SourceTypeMasks enumeration
Logical attributes


StringAttributeMetadata.YomiOf Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property YomiOf As String

C#
[DataMemberAttribute]
public string YomiOf { get; set; }

C++

J#

JScript

Property Value
Type: String
For internal use only.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringAttributeMetadata Class
StringAttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormat Enumeration
[image]

Deprecated. Describes the formatting of a string attribute for the StringAttributeMetadata.Format property.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="StringFormat", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata")> _
Public Enumeration StringFormat

C#
[DataContractAttribute(Name="StringFormat", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata")]
public enum StringFormat

C++

J#

JScript

  Members
Member name | Description
Email | Specifies to display the string as an e-mail. Value = 0.
Phone | For internal use only.
PhoneticGuide | Specifies to display the string as a phonetic guide. Value = 5.
Text | Specifies to display the string as text. Value = 1.
TextArea | Specifies to display the string as a text area. Value = 2.
TickerSymbol | Specifies to display the string as a ticker symbol. Value = 4.
Url | Specifies to display the string as a URL. Value = 3.
VersionNumber | Specifies to display the string as a version number. Value = 6.
  Remarks
Use the StringAttributeMetadata.FormatName property instead. This property uses StringFormatName values rather than this enumeration.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata Namespace
Other Resources
Customize Entity Attribute Metadata


StringFormatName Class
See Also Members
[image]

Specifies the format of a StringAttributeMetadata attribute using the FormatName property.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="StringFormatName", Namespace:="http://schemas.microsoft.com/xrm/2013/Metadata")> _
Public NotInheritable Class StringFormatName
    Inherits ConstantsBase(Of String)

C#
[DataContractAttribute(Name="StringFormatName", Namespace="http://schemas.microsoft.com/xrm/2013/Metadata")]
public sealed class StringFormatName : ConstantsBase<string>

C++

J#

JScript

  Remarks
This class replaces the deprecated StringFormat enumeration used to set the StringAttributeMetadata.Format property.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.ConstantsBase
    Microsoft.Xrm.Sdk.Metadata.StringFormatName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName Members
See Also Constructors Fields Methods Properties
[image]

Specifies the format of a StringAttributeMetadata attribute using the FormatName property.

The following tables list the members exposed by the StringFormatName type.

Public Constructors

Name | Description
StringFormatName | Initializes a new instance of the StringFormatName class.
Top

Public Fields

Name | Description
Email | Specifies to display the StringAttributeMetadata as an email address.
Phone | Specifies to display the StringAttributeMetadata as an phone number.
PhoneticGuide | Specifies to display the StringAttributeMetadata as an phonetic guide.
Text | Specifies to display the StringAttributeMetadata as text.
TextArea | Specifies to display the StringAttributeMetadata as a text area.
TickerSymbol | Specifies to display the StringAttributeMetadata as a ticker symbol.
Url | Specifies to display the StringAttributeMetadata as a URL.
VersionNumber | Specifies to display the StringAttributeMetadata as a version number.
Top

Public Properties

 | Name | Description
public property | ExtensionData | (inherited from ConstantsBase)
public property | Value | (inherited from ConstantsBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Returns a hash code value for this type.
public method | GetType | (inherited from Object)
 | Equality | Indicates whether two StringFormatName instances are the same.
 | Implicit | Converts a string into a StringFormatName
 | Inequality | Indicates whether two StringFormatName instances are different.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | ValueExistsInList | Indicates whether a value exists in the list. (inherited from ConstantsBase)
Top

See Also

Reference

StringFormatName Class
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName Fields
[image]

Public Fields

Name | Description
Email | Specifies to display the StringAttributeMetadata as an email address.
Phone | Specifies to display the StringAttributeMetadata as an phone number.
PhoneticGuide | Specifies to display the StringAttributeMetadata as an phonetic guide.
Text | Specifies to display the StringAttributeMetadata as text.
TextArea | Specifies to display the StringAttributeMetadata as a text area.
TickerSymbol | Specifies to display the StringAttributeMetadata as a ticker symbol.
Url | Specifies to display the StringAttributeMetadata as a URL.
VersionNumber | Specifies to display the StringAttributeMetadata as a version number.

See Also

Reference

StringFormatName Class
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.Email Field
[image]

Specifies to display the StringAttributeMetadata as an email address.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="StringFormatName is immutable")> _
Public Shared ReadOnly Email As StringFormatName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="StringFormatName is immutable")]
public static readonly StringFormatName Email

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.Phone Field
[image]

Specifies to display the StringAttributeMetadata as an phone number.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="StringFormatName is immutable")> _
Public Shared ReadOnly Phone As StringFormatName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="StringFormatName is immutable")]
public static readonly StringFormatName Phone

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.PhoneticGuide Field
[image]

Specifies to display the StringAttributeMetadata as an phonetic guide.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="StringFormatName is immutable")> _
Public Shared ReadOnly PhoneticGuide As StringFormatName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="StringFormatName is immutable")]
public static readonly StringFormatName PhoneticGuide

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.Text Field
[image]

Specifies to display the StringAttributeMetadata as text.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="StringFormatName is immutable")> _
Public Shared ReadOnly Text As StringFormatName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="StringFormatName is immutable")]
public static readonly StringFormatName Text

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.TextArea Field
[image]

Specifies to display the StringAttributeMetadata as a text area.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="StringFormatName is immutable")> _
Public Shared ReadOnly TextArea As StringFormatName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="StringFormatName is immutable")]
public static readonly StringFormatName TextArea

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.TickerSymbol Field
[image]

Specifies to display the StringAttributeMetadata as a ticker symbol.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="StringFormatName is immutable")> _
Public Shared ReadOnly TickerSymbol As StringFormatName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="StringFormatName is immutable")]
public static readonly StringFormatName TickerSymbol

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.Url Field
[image]

Specifies to display the StringAttributeMetadata as a URL.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="StringFormatName is immutable")> _
Public Shared ReadOnly Url As StringFormatName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="StringFormatName is immutable")]
public static readonly StringFormatName Url

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.VersionNumber Field
[image]

Specifies to display the StringAttributeMetadata as a version number.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification:="StringFormatName is immutable")> _
Public Shared ReadOnly VersionNumber As StringFormatName

C#
[SuppressMessageAttribute("Microsoft.Security", "CA2104:DoNotDeclareReadOnlyMutableReferenceTypes", Justification="StringFormatName is immutable")]
public static readonly StringFormatName VersionNumber

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName Constructor
[image]

Initializes a new instance of the StringFormatName class.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StringFormatName ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines whether two instances are equal.
public method | GetHashCode | Overridden. Returns a hash code value for this type.
public method | GetType | (inherited from Object)
 | Equality | Indicates whether two StringFormatName instances are the same.
 | Implicit | Converts a string into a StringFormatName
 | Inequality | Indicates whether two StringFormatName instances are different.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | ValueExistsInList | Indicates whether a value exists in the list. (inherited from ConstantsBase)

See Also

Reference

StringFormatName Class
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.Equals Method
[image]

Determines whether two instances are equal.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

C#
public override bool Equals (
    Object obj
)

C++

J#

JScript

Parameters
obj
Type: Object. The StringFormatName to compare with the current StringFormatName.
Return Value
Type: Boolean
true if the specified StringFormatName is equal to the StringFormatName object; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.GetHashCode Method
[image]

Returns a hash code value for this type.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function GetHashCode As Integer

C#
public override int GetHashCode ()

C++

J#

JScript

Return Value
Type: Int32

The hash code for the current StringFormatName.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.Equality Method
[image]

Indicates whether two StringFormatName instances are the same.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Operator = ( _
    stringFormatA As StringFormatName, _
    stringFormatB As StringFormatName _
) As Boolean

C#
public static bool operator == (
    StringFormatName stringFormatA,
    StringFormatName stringFormatB
)

C++

J#

JScript

Parameters
stringFormatA
Type: StringFormatName. Specifies a StringFormatName.
stringFormatB
Type: StringFormatName. Specifies a StringFormatName.
Return Value
Type: Boolean
true if the values of stringFormatA and stringFormatB are the same; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.Implicit Method
[image]

Converts a string into a StringFormatName

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Widening Operator CType ( _
    formatName As String _
) As StringFormatName

C#
public static implicit operator StringFormatName (
    string formatName
)

C++

J#

JScript

Parameters
formatName
Type: String. Specifies a StringFormatName.
Return Value
Type: StringFormatName
A StringFormatName that represents the converted String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName.Inequality Method
[image]

Indicates whether two StringFormatName instances are different.

Namespace: Microsoft.Xrm.Sdk.Metadata
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Operator <> ( _
    stringFormatA As StringFormatName, _
    stringFormatB As StringFormatName _
) As Boolean

C#
public static bool operator != (
    StringFormatName stringFormatA,
    StringFormatName stringFormatB
)

C++

J#

JScript

Parameters
stringFormatA
Type: StringFormatName. Specifies a StringFormatName.
stringFormatB
Type: StringFormatName. Specifies a StringFormatName.
Return Value
Type: Boolean
true if the values of stringFormatA and stringFormatB are different; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringFormatName Class
StringFormatName Members
Microsoft.Xrm.Sdk.Metadata Namespace


StringFormatName Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | (inherited from ConstantsBase)
public property | Value | (inherited from ConstantsBase)

See Also

Reference

StringFormatName Class
Microsoft.Xrm.Sdk.Metadata Namespace


Microsoft.Xrm.Sdk.Metadata.Query Namespace

Classes

Class | Description
AttributeQueryExpression | Defines a complex query to retrieve attribute metadata for entities retrieved using an EntityQueryExpression
DeletedMetadataCollection | The structure used to return deleted metadata.
EntityQueryExpression | Defines a complex query to retrieve entity metadata.
LabelQueryExpression | Defines the languages for the labels to be retrieved for metadata items that have labels.
MetadataConditionExpression | Contains a condition expression used to filter the results of the metadata query.
MetadataFilterExpression | Specifies complex condition and logical filter expressions used for filtering the results of a metadata query.
MetadataPropertiesExpression | Specifies the properties for which non-null values are returned from a query.
MetadataQueryBase | Represents the abstract base class for constructing a metadata query.
MetadataQueryExpression | Represents the abstract base class for constructing a metadata query.
RelationshipQueryExpression | Defines a complex query to retrieve entity relationship metadata for entities retrieved using an EntityQueryExpression

Enumerations

Enumeration | Description
DeletedMetadataFilters | An enumeration that specifies the type of deleted metadata to retrieve.
MetadataConditionOperator | Describes the type of comparison for two values in a metadata condition expression.


AttributeQueryExpression Class
See Also Members
[image]

Defines a complex query to retrieve attribute metadata for entities retrieved using an EntityQueryExpression

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="AttributeQueryExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public NotInheritable Class AttributeQueryExpression
    Inherits MetadataQueryExpression

C#
[DataContractAttribute(Name="AttributeQueryExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public sealed class AttributeQueryExpression : MetadataQueryExpression

C++

J#

JScript

  Remarks
The following example shows the use of an AttributeQueryExpression to retrieve entity metadata.
C#    Copy Code
//A condition expresson to return optionset attributes
MetadataConditionExpression[] optionsetAttributeTypes = new MetadataConditionExpression[] {
new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Picklist),
new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.State),
new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Status),
new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Boolean)
};

//A filter expression to apply the optionsetAttributeTypes condition expression
MetadataFilterExpression AttributeFilter = new MetadataFilterExpression(LogicalOperator.Or);
AttributeFilter.Conditions.AddRange(optionsetAttributeTypes);

//A Properties expression to limit the properties to be included with attributes
MetadataPropertiesExpression AttributeProperties = new MetadataPropertiesExpression() { AllProperties = false };
AttributeProperties.PropertyNames.Add("OptionSet");
AttributeProperties.PropertyNames.Add("AttributeType");

   ...

//An entity query expression to combine the filter expressions and property expressions for the query.
EntityQueryExpression entityQueryExpression = new EntityQueryExpression()
{

 Criteria = EntityFilter,
 Properties = EntityProperties,
 AttributeQuery = new AttributeQueryExpression()
 {
  Criteria = AttributeFilter,
  Properties = AttributeProperties
 },
 LabelQuery = labelQuery

};

//Retrieve the metadata for the query without a ClientVersionStamp
RetrieveMetadataChangesResponse initialRequest = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryBase

                Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryExpression
      Microsoft.Xrm.Sdk.Metadata.Query.AttributeQueryExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
AttributeQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


AttributeQueryExpression Members
See Also Constructors Methods Properties
[image]

Defines a complex query to retrieve attribute metadata for entities retrieved using an EntityQueryExpression

The following tables list the members exposed by the AttributeQueryExpression type.

Public Constructors

Name | Description
AttributeQueryExpression | Initializes a new instance of the AttributeQueryExpression class.
Top

Public Properties

 | Name | Description
public property | Criteria | Gets or sets the filter criteria for the metadata query. (inherited from MetadataQueryExpression)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | Properties | Gets or sets the properties to be returned by the query. (inherited from MetadataQueryExpression)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AttributeQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


AttributeQueryExpression Constructor
[image]

Initializes a new instance of the AttributeQueryExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeQueryExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeQueryExpression Class
AttributeQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


AttributeQueryExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AttributeQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


AttributeQueryExpression Properties
[image]

Public Properties

 | Name | Description
public property | Criteria | Gets or sets the filter criteria for the metadata query. (inherited from MetadataQueryExpression)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | Properties | Gets or sets the properties to be returned by the query. (inherited from MetadataQueryExpression)

See Also

Reference

AttributeQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


DeletedMetadataCollection Class
See Also Members
[image]

The structure used to return deleted metadata.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="DeletedMetadataCollection", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public NotInheritable Class DeletedMetadataCollection
    Inherits DataCollection(Of DeletedMetadataFilters, DataCollection(Of Guid))

C#
[CollectionDataContractAttribute(Name="DeletedMetadataCollection", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public sealed class DeletedMetadataCollection : DataCollection<DeletedMetadataFilters,DataCollection<Guid>>

C++

J#

JScript

  Remarks
This is the collection returned as the RetrieveMetadataChangesResponse.DeletedMetadata property when the RetrieveMetadataChangesRequest has values set for the ClientVersionStamp and DeletedMetadataFilters properties.
The following code snippets taken from Sample: Query Metadata and Detect Changes show how the DeletedMetadataCollectioncan be used to detect deleted OptionSetMetadata.
C#    Copy Code
protected String updateOptionLabelList(EntityQueryExpression entityQueryExpression, String clientVersionStamp)
{
 //Retrieve metadata changes and add them to the cache
 RetrieveMetadataChangesResponse updateResponse;
 try
 {
  updateResponse = getMetadataChanges(entityQueryExpression, clientVersionStamp, DeletedMetadataFilters.OptionSet);
  addOptionLabelsToCache(updateResponse.EntityMetadata, true);
  removeOptionLabelsFromCache(updateResponse.DeletedMetadata, true);

 }
 catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
 {
  // Check for ErrorCodes.ExpiredVersionStamp (0x80044352)
  // Will occur when the timestamp exceeds the Organization.ExpireSubscriptionsInDays value, which is 90 by default.
  if (ex.Detail.ErrorCode == unchecked((int)0x80044352))
  {
   //reinitialize cache
   _optionLabelList.Clear();

   updateResponse = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);
   //Add them to the cache and display the changes
   addOptionLabelsToCache(updateResponse.EntityMetadata, true);

  }
  else
  {
   throw ex;
  }

 }
 return updateResponse.ServerVersionStamp;
}

   ...

protected void removeOptionLabelsFromCache(DeletedMetadataCollection DeletedMetadata, Boolean showChanges)
{
 List<OptionSetOption> optionSetOptionsToRemove = new List<OptionSetOption>();

 if (DeletedMetadata.Keys.Contains(DeletedMetadataFilters.OptionSet))
 {
  DataCollection<Guid> optionsetmetadataids = (DataCollection<Guid>)DeletedMetadata[DeletedMetadataFilters.OptionSet];
  foreach (Guid metadataid in optionsetmetadataids)
  {
   foreach (OptionSetOption oso in _optionLabelList)
   {
    if (metadataid == oso.optionsetId)
    {
     optionSetOptionsToRemove.Add(oso);
    }
   }
  }
 }
 foreach (OptionSetOption option in optionSetOptionsToRemove)
 {
  _optionLabelList.Remove(option);
 }
 if (showChanges)
 {
  if (optionSetOptionsToRemove.Count > 0)
  {
   Console.WriteLine("{0} Option Labels removed", optionSetOptionsToRemove.Count);
   Console.WriteLine("{0} Total Option Labels currently cached", _optionLabelList.Count);
   Console.WriteLine("");
  }
  else
  {
   Console.WriteLine("No Option Labels removed.");
   Console.WriteLine("");
  }

 }
}

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.Metadata.Query.DeletedMetadataCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
DeletedMetadataCollection Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Retrieve Information about Deleted Metadata
Sample: Query Metadata and Detect Changes


DeletedMetadataCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

The structure used to return deleted metadata.

The following tables list the members exposed by the DeletedMetadataCollection type.

Public Constructors

Name | Description
DeletedMetadataCollection | Initializes a new instance of the DeletedMetadataCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

DeletedMetadataCollection Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Retrieve Information about Deleted Metadata
Sample: Query Metadata and Detect Changes


DeletedMetadataCollection Constructor
[image]

Initializes a new instance of the DeletedMetadataCollection class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeletedMetadataCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeletedMetadataCollection Class
DeletedMetadataCollection Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


DeletedMetadataCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

DeletedMetadataCollection Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Retrieve Information about Deleted Metadata
Sample: Query Metadata and Detect Changes


DeletedMetadataCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

DeletedMetadataCollection Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Retrieve Information about Deleted Metadata
Sample: Query Metadata and Detect Changes


DeletedMetadataFilters Enumeration
[image]

An enumeration that specifies the type of deleted metadata to retrieve.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<FlagsAttribute> _
<DataContractAttribute(Name:="DeletedMetadataFilters", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public Enumeration DeletedMetadataFilters

C#
[FlagsAttribute]
[DataContractAttribute(Name="DeletedMetadataFilters", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public enum DeletedMetadataFilters

C++

J#

JScript

  Members
Member name | Description
All | All deleted metadata. Value = 31.
Attribute | Deleted Attribute metadata. Value = 2.
Default | The value used if not set. Equals Entity
Entity | Deleted Entity metadata. Value = 1.
Label | Deleted Label metadata. Value = 8.
OptionSet | Deleted OptionSet metadata. Value = 16.
Relationship | Deleted Relationship metadata. Value = 4.
  Remarks
The DeletedMetadataFilters enumeration can also be used as a key to access a subset of deleted metadata included in a DeletedMetadataCollection. The following code snippets show usage of DeletedMetadataFilters in Sample: Query Metadata and Detect Changes.
C#    Copy Code
protected RetrieveMetadataChangesResponse getMetadataChanges(
 EntityQueryExpression entityQueryExpression,
 String clientVersionStamp,
 DeletedMetadataFilters deletedMetadataFilter)
{
 RetrieveMetadataChangesRequest retrieveMetadataChangesRequest = new RetrieveMetadataChangesRequest()
 {
  Query = entityQueryExpression,
  ClientVersionStamp = clientVersionStamp,
  DeletedMetadataFilters = deletedMetadataFilter
 };

 return (RetrieveMetadataChangesResponse)_service.Execute(retrieveMetadataChangesRequest);

}

   ...

protected String updateOptionLabelList(EntityQueryExpression entityQueryExpression, String clientVersionStamp)
{
 //Retrieve metadata changes and add them to the cache
 RetrieveMetadataChangesResponse updateResponse;
 try
 {
  updateResponse = getMetadataChanges(entityQueryExpression, clientVersionStamp, DeletedMetadataFilters.OptionSet);
  addOptionLabelsToCache(updateResponse.EntityMetadata, true);
  removeOptionLabelsFromCache(updateResponse.DeletedMetadata, true);

 }
 catch (FaultException<Microsoft.Xrm.Sdk.OrganizationServiceFault> ex)
 {
  // Check for ErrorCodes.ExpiredVersionStamp (0x80044352)
  // Will occur when the timestamp exceeds the Organization.ExpireSubscriptionsInDays value, which is 90 by default.
  if (ex.Detail.ErrorCode == unchecked((int)0x80044352))
  {
   //reinitialize cache
   _optionLabelList.Clear();

   updateResponse = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);
   //Add them to the cache and display the changes
   addOptionLabelsToCache(updateResponse.EntityMetadata, true);

  }
  else
  {
   throw ex;
  }

 }
 return updateResponse.ServerVersionStamp;
}

   ...

protected void removeOptionLabelsFromCache(DeletedMetadataCollection DeletedMetadata, Boolean showChanges)
{
 List<OptionSetOption> optionSetOptionsToRemove = new List<OptionSetOption>();

 if (DeletedMetadata.Keys.Contains(DeletedMetadataFilters.OptionSet))
 {
  DataCollection<Guid> optionsetmetadataids = (DataCollection<Guid>)DeletedMetadata[DeletedMetadataFilters.OptionSet];
  foreach (Guid metadataid in optionsetmetadataids)
  {
   foreach (OptionSetOption oso in _optionLabelList)
   {
    if (metadataid == oso.optionsetId)
    {
     optionSetOptionsToRemove.Add(oso);
    }
   }
  }
 }
 foreach (OptionSetOption option in optionSetOptionsToRemove)
 {
  _optionLabelList.Remove(option);
 }
 if (showChanges)
 {
  if (optionSetOptionsToRemove.Count > 0)
  {
   Console.WriteLine("{0} Option Labels removed", optionSetOptionsToRemove.Count);
   Console.WriteLine("{0} Total Option Labels currently cached", _optionLabelList.Count);
   Console.WriteLine("");
  }
  else
  {
   Console.WriteLine("No Option Labels removed.");
   Console.WriteLine("");
  }

 }
}

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


EntityQueryExpression Class
See Also Members
[image]

Defines a complex query to retrieve entity metadata.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EntityQueryExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public NotInheritable Class EntityQueryExpression
    Inherits MetadataQueryExpression

C#
[DataContractAttribute(Name="EntityQueryExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public sealed class EntityQueryExpression : MetadataQueryExpression

C++

J#

JScript

  Remarks
The following example shows the use of an EntityQueryExpression to retrieve entity metadata.
C#    Copy Code
//An entity query expression to combine the filter expressions and property expressions for the query.
EntityQueryExpression entityQueryExpression = new EntityQueryExpression()
{

 Criteria = EntityFilter,
 Properties = EntityProperties,
 AttributeQuery = new AttributeQueryExpression()
 {
  Criteria = AttributeFilter,
  Properties = AttributeProperties
 },
 LabelQuery = labelQuery

};

//Retrieve the metadata for the query without a ClientVersionStamp
RetrieveMetadataChangesResponse initialRequest = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);

   ...

protected RetrieveMetadataChangesResponse getMetadataChanges(
 EntityQueryExpression entityQueryExpression,
 String clientVersionStamp,
 DeletedMetadataFilters deletedMetadataFilter)
{
 RetrieveMetadataChangesRequest retrieveMetadataChangesRequest = new RetrieveMetadataChangesRequest()
 {
  Query = entityQueryExpression,
  ClientVersionStamp = clientVersionStamp,
  DeletedMetadataFilters = deletedMetadataFilter
 };

 return (RetrieveMetadataChangesResponse)_service.Execute(retrieveMetadataChangesRequest);

}

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryBase

                Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryExpression
      Microsoft.Xrm.Sdk.Metadata.Query.EntityQueryExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
EntityQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


EntityQueryExpression Members
See Also Constructors Methods Properties
[image]

Defines a complex query to retrieve entity metadata.

The following tables list the members exposed by the EntityQueryExpression type.

Public Constructors

Name | Description
EntityQueryExpression | Initializes a new instance of the EntityQueryExpression class.
Top

Public Properties

 | Name | Description
public property | AttributeQuery | Gets or sets a query expression for the entity attribute metadata to return.
public property | Criteria | Gets or sets the filter criteria for the metadata query. (inherited from MetadataQueryExpression)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | LabelQuery | Gets or sets a query expression for the labels to return.
public property | Properties | Gets or sets the properties to be returned by the query. (inherited from MetadataQueryExpression)
public property | RelationshipQuery | Gets or sets a query expression for the entity relationship metadata to return.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EntityQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


EntityQueryExpression Constructor
[image]

Initializes a new instance of the EntityQueryExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityQueryExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EntityQueryExpression Class
EntityQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


EntityQueryExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EntityQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


EntityQueryExpression Properties
[image]

Public Properties

 | Name | Description
public property | AttributeQuery | Gets or sets a query expression for the entity attribute metadata to return.
public property | Criteria | Gets or sets the filter criteria for the metadata query. (inherited from MetadataQueryExpression)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | LabelQuery | Gets or sets a query expression for the labels to return.
public property | Properties | Gets or sets the properties to be returned by the query. (inherited from MetadataQueryExpression)
public property | RelationshipQuery | Gets or sets a query expression for the entity relationship metadata to return.

See Also

Reference

EntityQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


EntityQueryExpression.AttributeQuery Property
[image]

Gets or sets a query expression for the entity attribute metadata to return.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeQuery As AttributeQueryExpression

C#
[DataMemberAttribute]
public AttributeQueryExpression AttributeQuery { get; set; }

C++

J#

JScript

Property Value
Type: AttributeQueryExpression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EntityQueryExpression Class
EntityQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


EntityQueryExpression.LabelQuery Property
[image]

Gets or sets a query expression for the labels to return.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LabelQuery As LabelQueryExpression

C#
[DataMemberAttribute]
public LabelQueryExpression LabelQuery { get; set; }

C++

J#

JScript

Property Value
Type:LabelQueryExpression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EntityQueryExpression Class
EntityQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


EntityQueryExpression.RelationshipQuery Property
[image]

Gets or sets a query expression for the entity relationship metadata to return.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property RelationshipQuery As RelationshipQueryExpression

C#
[DataMemberAttribute]
public RelationshipQueryExpression RelationshipQuery { get; set; }

C++

J#

JScript

Property Value
Type:RelationshipQueryExpression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EntityQueryExpression Class
EntityQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


LabelQueryExpression Class
See Also Members
[image]

Defines the languages for the labels to be retrieved for metadata items that have labels.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="LabelQueryExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public NotInheritable Class LabelQueryExpression
    Inherits MetadataQueryBase

C#
[DataContractAttribute(Name="LabelQueryExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public sealed class LabelQueryExpression : MetadataQueryBase

C++

J#

JScript

  Remarks
The number of labels returned for each item depends on the number of language packs installed by the organization. If no additional language packs are installed, there will only be labels for the organization base language. For best performance when additional language packs are installed you can limit labels to those that correspond to the user’s language preference. These preferences can be determined using the values returned by the client-side context getUserLcid function or by querying the UserSettings.UILanguageId value.
The following example shows those portions of the Sample: Query Metadata and Detect Changes which deal with setting the LabelQueryExpression.
C#    Copy Code
private Guid _userId;
private int _languageCode;

   ...

_userId = ((WhoAmIResponse)_service.Execute(new WhoAmIRequest())).UserId;
_languageCode = RetrieveUserUILanguageCode(_userId);

   ...

protected int RetrieveUserUILanguageCode(Guid userId)
{
 QueryExpression userSettingsQuery = new QueryExpression("usersettings");
 userSettingsQuery.ColumnSet.AddColumns("uilanguageid", "systemuserid");
 userSettingsQuery.Criteria.AddCondition("systemuserid", ConditionOperator.Equal, userId);
 EntityCollection userSettings = _service.RetrieveMultiple(userSettingsQuery);
 if (userSettings.Entities.Count > 0)
 {
  return (int)userSettings.Entities[0]["uilanguageid"];
 }
 return 0;
}

   ...

//A label query expression to limit the labels returned to only those for the user's preferred language
LabelQueryExpression labelQuery = new LabelQueryExpression();
labelQuery.FilterLanguages.Add(_languageCode);

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryBase
    Microsoft.Xrm.Sdk.Metadata.Query.LabelQueryExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
LabelQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Customize Labels to Support Multiple Languages
Sample: Query Metadata and Detect Changes


LabelQueryExpression Members
See Also Constructors Methods Properties
[image]

Defines the languages for the labels to be retrieved for metadata items that have labels.

The following tables list the members exposed by the LabelQueryExpression type.

Public Constructors

Name | Description
LabelQueryExpression | Initializes a new instance of theLabelQueryExpression class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | FilterLanguages | Gets the LCID values for localized labels to be retrieved for metadata items.
public property | MissingLabelBehavior | When this optional parameter is set to 1, the query will include labels for the base language if the label for the requested language is not there.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LabelQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Customize Labels to Support Multiple Languages
Sample: Query Metadata and Detect Changes


LabelQueryExpression Constructor
[image]

Initializes a new instance of theLabelQueryExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LabelQueryExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LabelQueryExpression Class
LabelQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


LabelQueryExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LabelQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Customize Labels to Support Multiple Languages
Sample: Query Metadata and Detect Changes


LabelQueryExpression Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | FilterLanguages | Gets the LCID values for localized labels to be retrieved for metadata items.
public property | MissingLabelBehavior | When this optional parameter is set to 1, the query will include labels for the base language if the label for the requested language is not there.

See Also

Reference

LabelQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Customize Labels to Support Multiple Languages
Sample: Query Metadata and Detect Changes


LabelQueryExpression.FilterLanguages Property
[image]

Gets the LCID values for localized labels to be retrieved for metadata items.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FilterLanguages As DataCollection(Of Integer)

C#
[DataMemberAttribute]
public DataCollection<int> FilterLanguages { get; }

C++

J#

JScript

Property Value
Type DataCollection<Int32>
The LCID values for localized labels to be retrieved for metadata items.

  Remarks
This value is read-only. Use the DataCollection methods to set the values.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LabelQueryExpression Class
LabelQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


LabelQueryExpression.MissingLabelBehavior Property
[image]

When this optional parameter is set to 1, the query will include labels for the base language if the label for the requested language is not there.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property MissingLabelBehavior As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=60)]
public Nullable<int> MissingLabelBehavior { get; set; }

C++

J#

JScript

Property Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LabelQueryExpression Class
LabelQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataConditionExpression Class
See Also Members
[image]

Contains a condition expression used to filter the results of the metadata query.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute("GetKnownConditionValueTypes")> _
<DataContractAttribute(Name:="MetadataConditionExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public NotInheritable Class MetadataConditionExpression
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute("GetKnownConditionValueTypes")]
[DataContractAttribute(Name="MetadataConditionExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public sealed class MetadataConditionExpression : IExtensibleDataObject

C++

J#

JScript

  Remarks
The following code snippet from Sample: Query Metadata and Detect Changes shows the use of MetadataConditionExpression to set conditions for Entities and Attributes to return.
C#    Copy Code

     // An array SchemaName values for non-intersect, user-owned entities that should not be returned.
     String[] excludedEntities = {
"WorkflowLog",
"Template",
"CustomerOpportunityRole",
"Import",
"UserQueryVisualization",
"UserEntityInstanceData",
"ImportLog",
"RecurrenceRule",
"QuoteClose",
"UserForm",
"SharePointDocumentLocation",
"Queue",
"DuplicateRule",
"OpportunityClose",
"Workflow",
"RecurringAppointmentMaster",
"CustomerRelationship",
"Annotation",
"SharePointSite",
"ImportData",
"ImportFile",
"OrderClose",
"Contract",
"BulkOperation",
"CampaignResponse",
"Connection",
"Report",
"CampaignActivity",
"UserEntityUISettings",
"IncidentResolution",
"GoalRollupQuery",
"MailMergeTemplate",
"Campaign",
"PostFollow",
"ImportMap",
"Goal",
"AsyncOperation",
"ProcessSession",
"UserQuery",
"ActivityPointer",
"List",
"ServiceAppointment"};

     //A filter expression to limit entities returned to non-intersect, user-owned entities not found in the list of excluded entities.
     MetadataFilterExpression EntityFilter = new MetadataFilterExpression(LogicalOperator.And);
     EntityFilter.Conditions.Add(new MetadataConditionExpression("IsIntersect", MetadataConditionOperator.Equals, false));
     EntityFilter.Conditions.Add(new MetadataConditionExpression("OwnershipType", MetadataConditionOperator.Equals, OwnershipTypes.UserOwned));
     EntityFilter.Conditions.Add(new MetadataConditionExpression("SchemaName", MetadataConditionOperator.NotIn, excludedEntities));
     MetadataConditionExpression isVisibileInMobileTrue = new MetadataConditionExpression("IsVisibleInMobile", MetadataConditionOperator.Equals, true);
     EntityFilter.Conditions.Add(isVisibileInMobileTrue);

    ...

 //A condition expresson to return optionset attributes
 MetadataConditionExpression[] optionsetAttributeTypes = new MetadataConditionExpression[] {
 new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Picklist),
 new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.State),
 new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Status),
 new MetadataConditionExpression("AttributeType", MetadataConditionOperator.Equals, AttributeTypeCode.Boolean)
 };

 //A filter expression to apply the optionsetAttributeTypes condition expression
 MetadataFilterExpression AttributeFilter = new MetadataFilterExpression(LogicalOperator.Or);
 AttributeFilter.Conditions.AddRange(optionsetAttributeTypes);

 //A Properties expression to limit the properties to be included with attributes
 MetadataPropertiesExpression AttributeProperties = new MetadataPropertiesExpression() { AllProperties = false };
 AttributeProperties.PropertyNames.Add("OptionSet");
 AttributeProperties.PropertyNames.Add("AttributeType");

    ...

 //An entity query expression to combine the filter expressions and property expressions for the query.
 EntityQueryExpression entityQueryExpression = new EntityQueryExpression()
 {

  Criteria = EntityFilter,
  Properties = EntityProperties,
  AttributeQuery = new AttributeQueryExpression()
  {
   Criteria = AttributeFilter,
   Properties = AttributeProperties
  },
  LabelQuery = labelQuery

 };

 //Retrieve the metadata for the query without a ClientVersionStamp
 RetrieveMetadataChangesResponse initialRequest = getMetadataChanges(entityQueryExpression, null, DeletedMetadataFilters.OptionSet);

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Metadata.Query.MetadataConditionExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
MetadataConditionExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataConditionExpression Members
See Also Constructors Methods Properties
[image]

Contains a condition expression used to filter the results of the metadata query.

The following tables list the members exposed by the MetadataConditionExpression type.

Public Constructors

Name | Description
MetadataConditionExpression | Overloaded. Initializes a new instance of the MetadataConditionExpression class.
Top

Public Properties

 | Name | Description
public property | ConditionOperator | Gets or sets the condition operator.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PropertyName | Gets or sets the name of the metadata property in the condition expression.
public property | Value | Gets or sets the value for the metadata property.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MetadataConditionExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataConditionExpression Constructor
[image]

Initializes a new instance of the MetadataConditionExpression class.

Overload List

Name | Description
MetadataConditionExpression () | Initializes a new instance of the MetadataConditionExpression class.
MetadataConditionExpression (String, MetadataConditionOperator, Object) | Initializes a new instance of the MetadataConditionExpression class.

See Also

Reference

MetadataConditionExpression Class
MetadataConditionExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataConditionExpression Constructor ()
[image]

Initializes a new instance of the MetadataConditionExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MetadataConditionExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataConditionExpression Class
MetadataConditionExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataConditionExpression Constructor (String, MetadataConditionOperator, Object)
[image]

Initializes a new instance of the MetadataConditionExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    propertyName As String, _
    conditionOperator As MetadataConditionOperator, _
    value As Object _
)

C#
public MetadataConditionExpression (
    string propertyName,
    MetadataConditionOperator conditionOperator,
    Object value
)

C++

J#

JScript

Parameters
propertyName
Type: String. The name of the metadata property in the condition expression.
conditionOperator
Type: MetadataConditionOperator. The condition operator.
value
Type: Object The value for the metadata property.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataConditionExpression Class
MetadataConditionExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataConditionExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MetadataConditionExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataConditionExpression Properties
[image]

Public Properties

 | Name | Description
public property | ConditionOperator | Gets or sets the condition operator.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PropertyName | Gets or sets the name of the metadata property in the condition expression.
public property | Value | Gets or sets the value for the metadata property.

See Also

Reference

MetadataConditionExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataConditionExpression.ConditionOperator Property
[image]

Gets or sets the condition operator.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ConditionOperator As MetadataConditionOperator

C#
[DataMemberAttribute]
public MetadataConditionOperator ConditionOperator { get; set; }

C++

J#

JScript

Property Value
Type: MetadataConditionOperator.
 The condition operator.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataConditionExpression Class
MetadataConditionExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataConditionExpression.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataConditionExpression Class
MetadataConditionExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataConditionExpression.PropertyName Property
[image]

Gets or sets the name of the metadata property in the condition expression.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PropertyName As String

C#
[DataMemberAttribute]
public string PropertyName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the metadata property in the condition expression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataConditionExpression Class
MetadataConditionExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataConditionExpression.Value Property
[image]

Gets or sets the value for the metadata property.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Value As Object

C#
[DataMemberAttribute]
public Object Value { get; set; }

C++

J#

JScript

Property Value
Type: Object
 The value for the metadata property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataConditionExpression Class
MetadataConditionExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataConditionOperator Enumeration
[image]

Describes the type of comparison for two values in a metadata condition expression.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="MetadataConditionOperator", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public Enumeration MetadataConditionOperator

C#
[DataContractAttribute(Name="MetadataConditionOperator", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public enum MetadataConditionOperator

C++

J#

JScript

  Members
Member name | Description
Equals | The values are compared for equality. Value = 0.
GreaterThan | The value is greater than the compared value. Value = 4.
In | The value exists in a list of values. Value = 2.
LessThan | The value is less than the compared value. Value = 5.
NotEquals | The two values are not equal. Value = 1.
NotIn | The given value is not matched to a value in a list. Value = 3.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataFilterExpression Class
See Also Members
[image]

Specifies complex condition and logical filter expressions used for filtering the results of a metadata query.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="MetadataFilterExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public NotInheritable Class MetadataFilterExpression
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="MetadataFilterExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public sealed class MetadataFilterExpression : IExtensibleDataObject

C++

J#

JScript

  Remarks
The following example shows the use of a MetadataFilterExpression to return non-intersect, user-owned entities not found in a list of excluded entities.
C#    Copy Code

     // An array SchemaName values for non-intersect, user-owned entities that should not be returned.
     String[] excludedEntities = {
"WorkflowLog",
"Template",
"CustomerOpportunityRole",
"Import",
"UserQueryVisualization",
"UserEntityInstanceData",
"ImportLog",
"RecurrenceRule",
"QuoteClose",
"UserForm",
"SharePointDocumentLocation",
"Queue",
"DuplicateRule",
"OpportunityClose",
"Workflow",
"RecurringAppointmentMaster",
"CustomerRelationship",
"Annotation",
"SharePointSite",
"ImportData",
"ImportFile",
"OrderClose",
"Contract",
"BulkOperation",
"CampaignResponse",
"Connection",
"Report",
"CampaignActivity",
"UserEntityUISettings",
"IncidentResolution",
"GoalRollupQuery",
"MailMergeTemplate",
"Campaign",
"PostFollow",
"ImportMap",
"Goal",
"AsyncOperation",
"ProcessSession",
"UserQuery",
"ActivityPointer",
"List",
"ServiceAppointment"};

     //A filter expression to limit entities returned to non-intersect, user-owned entities not found in the list of excluded entities.
     MetadataFilterExpression EntityFilter = new MetadataFilterExpression(LogicalOperator.And);
     EntityFilter.Conditions.Add(new MetadataConditionExpression("IsIntersect", MetadataConditionOperator.Equals, false));
     EntityFilter.Conditions.Add(new MetadataConditionExpression("OwnershipType", MetadataConditionOperator.Equals, OwnershipTypes.UserOwned));
     EntityFilter.Conditions.Add(new MetadataConditionExpression("SchemaName", MetadataConditionOperator.NotIn, excludedEntities));
     MetadataConditionExpression isVisibileInMobileTrue = new MetadataConditionExpression("IsVisibleInMobile", MetadataConditionOperator.Equals, true);
     EntityFilter.Conditions.Add(isVisibileInMobileTrue);

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Metadata.Query.MetadataFilterExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  Change History
  See Also
Reference
MetadataFilterExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataFilterExpression Members
See Also Constructors Methods Properties
[image]

Specifies complex condition and logical filter expressions used for filtering the results of a metadata query.

The following tables list the members exposed by the MetadataFilterExpression type.

Public Constructors

Name | Description
MetadataFilterExpression | Overloaded. Initializes a new instance of the MetadataFilterExpression class.
Top

Public Properties

 | Name | Description
public property | Conditions | Gets condition expressions that include metadata properties, condition operators and values.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | FilterOperator | Gets or sets the logical AND/OR filter operator.
public property | Filters | Gets a collection of logical filter expressions that filter the results of the metadata query.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MetadataFilterExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataFilterExpression Constructor
[image]

Initializes a new instance of the MetadataFilterExpression class.

Overload List

Name | Description
MetadataFilterExpression () | Initializes a new instance of the MetadataFilterExpression class.
MetadataFilterExpression (LogicalOperator) | Initializes a new instance of the MetadataFilterExpression class.

See Also

Reference

MetadataFilterExpression Class
MetadataFilterExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataFilterExpression Constructor ()
[image]

Initializes a new instance of the MetadataFilterExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MetadataFilterExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataFilterExpression Class
MetadataFilterExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataFilterExpression Constructor (LogicalOperator)
[image]

Initializes a new instance of the MetadataFilterExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    filterOperator As LogicalOperator _
)

C#
public MetadataFilterExpression (
    LogicalOperator filterOperator
)

C++

J#

JScript

Parameters
filterOperator
Type: LogicalOperator. The filter operator
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataFilterExpression Class
MetadataFilterExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataFilterExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MetadataFilterExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataFilterExpression Properties
[image]

Public Properties

 | Name | Description
public property | Conditions | Gets condition expressions that include metadata properties, condition operators and values.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | FilterOperator | Gets or sets the logical AND/OR filter operator.
public property | Filters | Gets a collection of logical filter expressions that filter the results of the metadata query.

See Also

Reference

MetadataFilterExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataFilterExpression.Conditions Property
[image]

Gets condition expressions that include metadata properties, condition operators and values.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Conditions As DataCollection(Of MetadataConditionExpression)

C#
[DataMemberAttribute]
public DataCollection<MetadataConditionExpression> Conditions { get; }

C++

J#

JScript

Property Value
Type: DataCollection<MetadataConditionExpression>
The collection of metadata condition expressions.

  Remarks
This property is read-only. Use the DataCollection methods to manipulate the condition expressions.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataFilterExpression Class
MetadataFilterExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataFilterExpression.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataFilterExpression Class
MetadataFilterExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataFilterExpression.FilterOperator Property
[image]

Gets or sets the logical AND/OR filter operator.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FilterOperator As LogicalOperator

C#
[DataMemberAttribute]
public LogicalOperator FilterOperator { get; set; }

C++

J#

JScript

Property Value
Type: LogicalOperator
The filter operator.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataFilterExpression Class
MetadataFilterExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataFilterExpression.Filters Property
[image]

Gets a collection of logical filter expressions that filter the results of the metadata query.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Filters As DataCollection(Of MetadataFilterExpression)

C#
[DataMemberAttribute]
public DataCollection<MetadataFilterExpression> Filters { get; }

C++

J#

JScript

Property Value
Type: DataCollection<MetadataFilterExpression>.
  Remarks
This property is read-only. Use the DataCollection methods to manipulate the filters.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataFilterExpression Class
MetadataFilterExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataPropertiesExpression Class
See Also Members
[image]

Specifies the properties for which non-null values are returned from a query.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="MetadataPropertiesExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public NotInheritable Class MetadataPropertiesExpression
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="MetadataPropertiesExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public sealed class MetadataPropertiesExpression : IExtensibleDataObject

C++

J#

JScript

  Remarks
When the metadata object is instantiated all properties are included but any properties not specified by the MetadataPropertiesExpression will contain null values.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Metadata.Query.MetadataPropertiesExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataPropertiesExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataPropertiesExpression Members
See Also Constructors Methods Properties
[image]

Specifies the properties for which non-null values are returned from a query.

The following tables list the members exposed by the MetadataPropertiesExpression type.

Public Constructors

Name | Description
MetadataPropertiesExpression | Overloaded.
Top

Public Properties

 | Name | Description
public property | AllProperties | Gets or sets whether to retrieve all the properties of a metadata object.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PropertyNames | Gets or sets a collection of strings representing the metadata properties to retrieve.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MetadataPropertiesExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataPropertiesExpression Constructor
[image]

Overload List

Name | Description
MetadataPropertiesExpression () | Initializes a new instance of the MetadataPropertiesExpression class.
MetadataPropertiesExpression (String[]) | Initializes a new instance of the MetadataPropertiesExpression class.

See Also

Reference

MetadataPropertiesExpression Class
MetadataPropertiesExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataPropertiesExpression Constructor ()
[image]

Initializes a new instance of the MetadataPropertiesExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MetadataPropertiesExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataPropertiesExpression Class
MetadataPropertiesExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataPropertiesExpression Constructor (String[])
[image]

Initializes a new instance of the MetadataPropertiesExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    ParamArray propertyNames As String() _
)

C#
public MetadataPropertiesExpression (
    params string[] propertyNames
)

C++

J#

JScript

Parameters
propertyNames
Type: String[]. The strings representing the metadata properties to retrieve.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataPropertiesExpression Class
MetadataPropertiesExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataPropertiesExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MetadataPropertiesExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataPropertiesExpression Properties
[image]

Public Properties

 | Name | Description
public property | AllProperties | Gets or sets whether to retrieve all the properties of a metadata object.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PropertyNames | Gets or sets a collection of strings representing the metadata properties to retrieve.

See Also

Reference

MetadataPropertiesExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataPropertiesExpression.AllProperties Property
[image]

Gets or sets whether to retrieve all the properties of a metadata object.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AllProperties As Boolean

C#
[DataMemberAttribute]
public bool AllProperties { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to specify to retrieve all metadata object properties; false to retrieve only specified metadata object properties.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataPropertiesExpression Class
MetadataPropertiesExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataPropertiesExpression.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataPropertiesExpression Class
MetadataPropertiesExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataPropertiesExpression.PropertyNames Property
[image]

Gets or sets a collection of strings representing the metadata properties to retrieve.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Usage", "CA2227:CollectionPropertiesShouldBeReadOnly", Justification:="The requirement is to allow callers to change this collection property's value")> _
<DataMemberAttribute> _
Public Property PropertyNames As DataCollection(Of String)

C#
[SuppressMessageAttribute("Microsoft.Usage", "CA2227:CollectionPropertiesShouldBeReadOnly", Justification="The requirement is to allow callers to change this collection property\'s value")]
[DataMemberAttribute]
public DataCollection<string> PropertyNames { get; }

C++

J#

JScript

Property Value
Type: DataCollection<String>
 The collection of strings representing the metadata properties to retrieve.

  Remarks
Use the DataCollection methods to manipulate the property names.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataPropertiesExpression Class
MetadataPropertiesExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataQueryBase Class
See Also Members
[image]

Represents the abstract base class for constructing a metadata query.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(MetadataQueryExpression))> _
<DataContractAttribute(Name:="MetadataQueryBase", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public MustInherit Class MetadataQueryBase
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute(typeof(MetadataQueryExpression))]
[DataContractAttribute(Name="MetadataQueryBase", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public abstract class MetadataQueryBase : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryBase

                Microsoft.Xrm.Sdk.Metadata.Query.LabelQueryExpression

                Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataQueryBase Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataQueryBase Members
See Also Methods Properties Constructors
[image]

Represents the abstract base class for constructing a metadata query.

The following tables list the members exposed by the MetadataQueryBase type.

Protected Constructors

Name | Description
MetadataQueryBase | Initializes a new instance of the MetadataQueryBase class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MetadataQueryBase Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataQueryBase Constructor
[image]

Initializes a new instance of the MetadataQueryBase class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected MetadataQueryBase ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataQueryBase Class
MetadataQueryBase Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataQueryBase Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MetadataQueryBase Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataQueryBase Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

MetadataQueryBase Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataQueryBase.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataQueryBase Class
MetadataQueryBase Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataQueryExpression Class
See Also Members
[image]

Represents the abstract base class for constructing a metadata query.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(LabelQueryExpression))> _
<DataContractAttribute(Name:="MetadataQueryExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
<KnownTypeAttribute(GetType(EntityQueryExpression))> _
<KnownTypeAttribute(GetType(AttributeQueryExpression))> _
<KnownTypeAttribute(GetType(RelationshipQueryExpression))> _
Public MustInherit Class MetadataQueryExpression
    Inherits MetadataQueryBase

C#
[KnownTypeAttribute(typeof(LabelQueryExpression))]
[DataContractAttribute(Name="MetadataQueryExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
[KnownTypeAttribute(typeof(EntityQueryExpression))]
[KnownTypeAttribute(typeof(AttributeQueryExpression))]
[KnownTypeAttribute(typeof(RelationshipQueryExpression))]
public abstract class MetadataQueryExpression : MetadataQueryBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryBase
    Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryExpression

                Microsoft.Xrm.Sdk.Metadata.Query.AttributeQueryExpression

                Microsoft.Xrm.Sdk.Metadata.Query.EntityQueryExpression

                Microsoft.Xrm.Sdk.Metadata.Query.RelationshipQueryExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataQueryExpression Members
See Also Methods Properties Constructors
[image]

Represents the abstract base class for constructing a metadata query.

The following tables list the members exposed by the MetadataQueryExpression type.

Protected Constructors

Name | Description
MetadataQueryExpression | Initializes a new instance of the MetadataQueryExpression class.
Top

Public Properties

 | Name | Description
public property | Criteria | Gets or sets the filter criteria for the metadata query.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | Properties | Gets or sets the properties to be returned by the query.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

MetadataQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataQueryExpression Constructor
[image]

Initializes a new instance of the MetadataQueryExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected MetadataQueryExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataQueryExpression Class
MetadataQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataQueryExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MetadataQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataQueryExpression Properties
[image]

Public Properties

 | Name | Description
public property | Criteria | Gets or sets the filter criteria for the metadata query.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | Properties | Gets or sets the properties to be returned by the query.

See Also

Reference

MetadataQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


MetadataQueryExpression.Criteria Property
[image]

Gets or sets the filter criteria for the metadata query.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Criteria As MetadataFilterExpression

C#
[DataMemberAttribute]
public MetadataFilterExpression Criteria { get; set; }

C++

J#

JScript

Property Value
Returns MetadataFilterExpression
The filter criteria for the metadata query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataQueryExpression Class
MetadataQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


MetadataQueryExpression.Properties Property
[image]

Gets or sets the properties to be returned by the query.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Properties As MetadataPropertiesExpression

C#
[DataMemberAttribute]
public MetadataPropertiesExpression Properties { get; set; }

C++

J#

JScript

Property Value
Returns MetadataPropertiesExpression
The properties to be returned by the query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MetadataQueryExpression Class
MetadataQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


RelationshipQueryExpression Class
See Also Members
[image]

Defines a complex query to retrieve entity relationship metadata for entities retrieved using an EntityQueryExpression

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="RelationshipQueryExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Metadata/Query")> _
Public NotInheritable Class RelationshipQueryExpression
    Inherits MetadataQueryExpression

C#
[DataContractAttribute(Name="RelationshipQueryExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Metadata/Query")]
public sealed class RelationshipQueryExpression : MetadataQueryExpression

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryBase

                Microsoft.Xrm.Sdk.Metadata.Query.MetadataQueryExpression
      Microsoft.Xrm.Sdk.Metadata.Query.RelationshipQueryExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RelationshipQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace
Other Resources
Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


RelationshipQueryExpression Members
See Also Constructors Methods Properties
[image]

Defines a complex query to retrieve entity relationship metadata for entities retrieved using an EntityQueryExpression

The following tables list the members exposed by the RelationshipQueryExpression type.

Public Constructors

Name | Description
RelationshipQueryExpression | Initializes a new instance of the RelationshipQueryExpression class.
Top

Public Properties

 | Name | Description
public property | Criteria | Gets or sets the filter criteria for the metadata query. (inherited from MetadataQueryExpression)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | Properties | Gets or sets the properties to be returned by the query. (inherited from MetadataQueryExpression)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RelationshipQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


RelationshipQueryExpression Constructor
[image]

Initializes a new instance of the RelationshipQueryExpression class.

Namespace: Microsoft.Xrm.Sdk.Metadata.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RelationshipQueryExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RelationshipQueryExpression Class
RelationshipQueryExpression Members
Microsoft.Xrm.Sdk.Metadata.Query Namespace


RelationshipQueryExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RelationshipQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


RelationshipQueryExpression Properties
[image]

Public Properties

 | Name | Description
public property | Criteria | Gets or sets the filter criteria for the metadata query. (inherited from MetadataQueryExpression)
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from MetadataQueryBase)
public property | Properties | Gets or sets the properties to be returned by the query. (inherited from MetadataQueryExpression)

See Also

Reference

RelationshipQueryExpression Class
Microsoft.Xrm.Sdk.Metadata.Query Namespace

Other Resources

Query and Capture Changes to Metadata
Sample: Query Metadata and Detect Changes


Microsoft.Xrm.Sdk.Organization Namespace

Classes

Class | Description
EndpointCollection | A collection of service endpoints.
OrganizationDetail | Provides detailed information on an organization.

Enumerations

Enumeration | Description
EndpointAccessType | Indicates the type of network access an endpoint has.
EndpointType | Identifies the type of service available at an endpoint.
OrganizationState | Describes the current state of an organization.


EndpointAccessType Enumeration
[image]

Indicates the type of network access an endpoint has.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EndpointAccessType", Namespace:="http://schemas.microsoft.com/xrm/2014/Contracts")> _
Public Enumeration EndpointAccessType

C#
[DataContractAttribute(Name="EndpointAccessType", Namespace="http://schemas.microsoft.com/xrm/2014/Contracts")]
public enum EndpointAccessType

C++

J#

JScript

  Members
Member name | Description
Default | Default access. The actual access is determined by the endpoint URL. Value = 0.
Internet | Internet access. Value = 1.
Intranet | Intranet access. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Organization Namespace
Other Resources
Sample: Access the Discovery Service


EndpointCollection Class
See Also Members
[image]

A collection of service endpoints.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<CollectionDataContractAttribute(Name:="EndpointCollection", Namespace:="http://schemas.microsoft.com/xrm/2014/Contracts")> _
Public NotInheritable Class EndpointCollection
    Inherits DataCollection(Of EndpointType, String)

C#
[CollectionDataContractAttribute(Name="EndpointCollection", Namespace="http://schemas.microsoft.com/xrm/2014/Contracts")]
public sealed class EndpointCollection : DataCollection<EndpointType,string>

C++

J#

JScript

  Remarks
Typically used to identify each available service, and the service address, for an organization.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.DataCollection
    Microsoft.Xrm.Sdk.Organization.EndpointCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EndpointCollection Members
Microsoft.Xrm.Sdk.Organization Namespace


EndpointCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

A collection of service endpoints.

The following tables list the members exposed by the EndpointCollection type.

Public Constructors

Name | Description
EndpointCollection | Initializes a new instance of the EndpointCollection class.
Top

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
 | FromDiscovery | Produces a populated Microsoft.Xrm.Sdk.Organization. EndpointCollection from a Microsoft.Xrm.Sdk.Discovery. EndpointCollection.
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)
Top

See Also

Reference

EndpointCollection Class
Microsoft.Xrm.Sdk.Organization Namespace


EndpointCollection Constructor
[image]

Initializes a new instance of the EndpointCollection class.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EndpointCollection ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EndpointCollection Class
EndpointCollection Members
Microsoft.Xrm.Sdk.Organization Namespace


EndpointCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Overloaded. Adds the specified key and value to the dictionary. (inherited from DataCollection)
public method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the DataCollection. (inherited from DataCollection)
public method | Clear | Removes all items from the DataCollection. (inherited from DataCollection)
public method | Contains | Overloaded. Determines whether the DataCollection contains a specific value. (inherited from DataCollection)
public method | ContainsKey | Determines whether the DataCollection contains a specific key value. (inherited from DataCollection)
public method | CopyTo | (inherited from DataCollection)
public method | Equals | (inherited from Object)
 | FromDiscovery | Produces a populated Microsoft.Xrm.Sdk.Organization. EndpointCollection from a Microsoft.Xrm.Sdk.Discovery. EndpointCollection.
public method | GetEnumerator | Returns an enumerator that iterates through a collection. (inherited from DataCollection)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Remove | Overloaded. Removes the first occurrence of a specific object from the DataCollection. (inherited from DataCollection)
public method | ToString | (inherited from Object)
public method | TryGetValue | Gets the value associated with the specified key. (inherited from DataCollection)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from DataCollection)

See Also

Reference

EndpointCollection Class
Microsoft.Xrm.Sdk.Organization Namespace


EndpointCollection.FromDiscovery Method
[image]

Produces a populated Microsoft.Xrm.Sdk.Organization. EndpointCollection from a Microsoft.Xrm.Sdk.Discovery. EndpointCollection.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function FromDiscovery ( _
    collection As EndpointCollection _
) As EndpointCollection

C#
public static EndpointCollection FromDiscovery (
    EndpointCollection collection
)

C++

J#

JScript

Parameters
collection
Type: EndpointCollection. An endpoint collection.
Return Value
Type:  EndpointCollection
The populated endpoint collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
EndpointCollection Class
EndpointCollection Members
Microsoft.Xrm.Sdk.Organization Namespace


EndpointCollection Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets the number of elements in the collection. (inherited from DataCollection)
public property | IsReadOnly | Gets a value indicating whether the DataCollection is read-only. (inherited from DataCollection)
public property | Item | Gets or sets the value associated with the specified key. (inherited from DataCollection)
public property | Keys | Gets a collection containing the keys in the DataCollection. (inherited from DataCollection)
public property | Values | Gets a collection containing the values in the DataCollection. (inherited from DataCollection)

See Also

Reference

EndpointCollection Class
Microsoft.Xrm.Sdk.Organization Namespace


EndpointType Enumeration
[image]

Identifies the type of service available at an endpoint.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="EndpointType", Namespace:="http://schemas.microsoft.com/xrm/2014/Contracts")> _
Public Enumeration EndpointType

C#
[DataContractAttribute(Name="EndpointType", Namespace="http://schemas.microsoft.com/xrm/2014/Contracts")]
public enum EndpointType

C++

J#

JScript

  Members
Member name | Description
OrganizationDataService | The organization data service. Value = 1.
OrganizationService | The organization service. Value = 0.
WebApplication | The web application service. Value = 2.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail Class
See Also Members
[image]

Provides detailed information on an organization.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OrganizationDetail", Namespace:="http://schemas.microsoft.com/xrm/2014/Contracts")> _
Public NotInheritable Class OrganizationDetail
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="OrganizationDetail", Namespace="http://schemas.microsoft.com/xrm/2014/Contracts")]
public sealed class OrganizationDetail : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Organization.OrganizationDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace
RetrieveCurrentOrganizationResponse


OrganizationDetail Members
See Also Constructors Methods Properties
[image]

Provides detailed information on an organization.

The following tables list the members exposed by the OrganizationDetail type.

Public Constructors

Name | Description
OrganizationDetail | Initializes a new instance of the OrganizationDetail class.
Top

Public Properties

 | Name | Description
public property | Endpoints | Gets a collection that identifies the service type and address for each endpoint of the organization.
public property | ExtensionData | Gets or sets extra data of the organization.
public property | FriendlyName | Gets or sets the friendly name of the organization.
public property | OrganizationId | Gets or sets the global unique identifier of the organization.
public property | OrganizationVersion | Gets or sets the version of the organization.
public property | State | Gets or sets the state of the organization.
public property | UniqueName | Gets or sets the unique name of the organization.
public property | UrlName | Gets or sets the organization name used in the URL for the organization web service.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
 | FromDiscovery | Populates a Microsoft.Xrm.Sdk.Organization.OrganizationDetail from a Microsoft.Xrm.Sdk.Discovery.OrganizationDetail object.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrganizationDetail Class
Microsoft.Xrm.Sdk.Organization Namespace
RetrieveCurrentOrganizationResponse


OrganizationDetail Constructor
[image]

Initializes a new instance of the OrganizationDetail class.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrganizationDetail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
 | FromDiscovery | Populates a Microsoft.Xrm.Sdk.Organization.OrganizationDetail from a Microsoft.Xrm.Sdk.Discovery.OrganizationDetail object.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrganizationDetail Class
Microsoft.Xrm.Sdk.Organization Namespace
RetrieveCurrentOrganizationResponse


OrganizationDetail.FromDiscovery Method
[image]

Populates a Microsoft.Xrm.Sdk.Organization.OrganizationDetail from a Microsoft.Xrm.Sdk.Discovery.OrganizationDetail object.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function FromDiscovery ( _
    detail As OrganizationDetail _
) As OrganizationDetail

C#
public static OrganizationDetail FromDiscovery (
    OrganizationDetail detail
)

C++

J#

JScript

Parameters
detail
Type: OrganizationDetail. An organization detail of the Discovery namespace.
Return Value
Type: OrganizationDetailA populated organization detail of the Organization namespace.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail Properties
[image]

Public Properties

 | Name | Description
public property | Endpoints | Gets a collection that identifies the service type and address for each endpoint of the organization.
public property | ExtensionData | Gets or sets extra data of the organization.
public property | FriendlyName | Gets or sets the friendly name of the organization.
public property | OrganizationId | Gets or sets the global unique identifier of the organization.
public property | OrganizationVersion | Gets or sets the version of the organization.
public property | State | Gets or sets the state of the organization.
public property | UniqueName | Gets or sets the unique name of the organization.
public property | UrlName | Gets or sets the organization name used in the URL for the organization web service.

See Also

Reference

OrganizationDetail Class
Microsoft.Xrm.Sdk.Organization Namespace
RetrieveCurrentOrganizationResponse


OrganizationDetail.Endpoints Property
[image]

Gets a collection that identifies the service type and address for each endpoint of the organization.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Endpoints As EndpointCollection

C#
[DataMemberAttribute]
public EndpointCollection Endpoints { get; }

C++

J#

JScript

Property Value
Type: EndpointCollection
The collection that identifies the service type and address for each endpoint of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail.ExtensionData Property
[image]

Gets or sets extra data of the organization.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
Extra data of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail.FriendlyName Property
[image]

Gets or sets the friendly name of the organization.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FriendlyName As String

C#
[DataMemberAttribute]
public string FriendlyName { get; set; }

C++

J#

JScript

Property Value
Type: String
The friendly name of the organization.

  Remarks
The friendly name was defined when the organization was provisioned.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail.OrganizationId Property
[image]

Gets or sets the global unique identifier of the organization.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrganizationId As Guid

C#
[DataMemberAttribute]
public Guid OrganizationId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The global unique identifier of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail.OrganizationVersion Property
[image]

Gets or sets the version of the organization.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrganizationVersion As String

C#
[DataMemberAttribute]
public string OrganizationVersion { get; set; }

C++

J#

JScript

Property Value
Type: String
The version of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail.State Property
[image]

Gets or sets the state of the organization.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property State As OrganizationState

C#
[DataMemberAttribute]
public OrganizationState State { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationStateThe state of the organization.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail.UniqueName Property
[image]

Gets or sets the unique name of the organization.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property UniqueName As String

C#
[DataMemberAttribute]
public string UniqueName { get; set; }

C++

J#

JScript

Property Value
Type: String
The unique name of the organization.

  Remarks
The unique name isn’t necessarily similar to the friendly name.
The organization unique name was defined when the organization was created. To determine the organization unique name using the Microsoft Dynamics CRM web application, go to Settings > Customizations > Developer Resources.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationDetail.UrlName Property
[image]

Gets or sets the organization name used in the URL for the organization web service.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
<SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification:="Returned as string for compatibility")> _
Public Property UrlName As String

C#
[DataMemberAttribute]
[SuppressMessageAttribute("Microsoft.Design", "CA1056:UriPropertiesShouldNotBeStrings", Justification="Returned as string for compatibility")]
public string UrlName { get; set; }

C++

J#

JScript

Property Value
Type: String
 The organization name used in the URL for the organization web service.

  Remarks
The organization URL name is AdventureWorksCycle in the following web service URL example.
http://localhost/AdventureWorksCycle/xrmservices/2011/Organization.svc

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationDetail Class
OrganizationDetail Members
Microsoft.Xrm.Sdk.Organization Namespace


OrganizationState Enumeration
[image]

Describes the current state of an organization.

Namespace: Microsoft.Xrm.Sdk.Organization
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OrganizationState", Namespace:="http://schemas.microsoft.com/xrm/2014/Contracts")> _
Public Enumeration OrganizationState

C#
[DataContractAttribute(Name="OrganizationState", Namespace="http://schemas.microsoft.com/xrm/2014/Contracts")]
public enum OrganizationState

C++

J#

JScript

  Members
Member name | Description
Disabled | The organization is disabled. Value = 1.
Enabled | The organization is enabled. Value = 0.
  Remarks
Related to organization provisioning and maintenance.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Sdk.Organization Namespace
OrganizationDetail


Microsoft.Xrm.Sdk.Query Namespace

Classes

Class | Description
ColumnSet | Specifies the attributes for which non-null values are returned from a query.
ConditionExpression | Contains a condition expression used to filter the results of the query.
FetchExpression | Contains a query expressed in FetchXML.
FilterExpression | Specifies complex condition and logical filter expressions used for filtering the results of the query.
LinkEntity | Specifies the links between multiple entity types used in creating complex queries.
OrderExpression | Sets the order in which the entity instances are returned from the query.
PagingInfo | Specifies a number of pages and a number of entity instances per page to return from the query.
QueryBase | Represents the abstract base class for constructing a query.
QueryByAttribute | Contains a query that is expressed as a set of attribute and value pairs.
QueryExpression | Contains a complex query expressed in a hierarchy of expressions.

Enumerations

Enumeration | Description
ConditionOperator | Describes the type of comparison for two values (or expressions) in a condition expression.
JoinOperator | Contains the possible values for a join operator in a LinkEntity.
LogicalOperator | Contains the possible values for an operator in a FilterExpression.
OrderType | Contains the possible values for the order type in an OrderExpression.


ColumnSet Class
See Also Members
[image]

Specifies the attributes for which non-null values are returned from a query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ColumnSet", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class ColumnSet
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="ColumnSet", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class ColumnSet : IExtensibleDataObject

C++

J#

JScript

  Remarks
The ColumnSet class is used with methods and messages that retrieve one or more records from the database. The query returns non-null values for the attributes that are contained in the Columns property. The attributes not included in the ColumnSet will contain null values. If the column set includes attributes that are not valid for retrieve, they will be ignored and no values will be returned for those attributes.
The primary key is always returned and contains a non-null value.
Attributes are specified by name. For more information, see SchemaName.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Query.ColumnSet
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace
ConvertQuoteToSalesOrderRequest
ConvertSalesOrderToInvoiceRequest
GenerateInvoiceFromOpportunityRequest
GenerateQuoteFromOpportunityRequest
GenerateSalesOrderFromOpportunityRequest
Retrieve
QueryByAttribute
QueryExpression
RetrieveAllChildUsersSystemUserRequest
RetrieveBusinessHierarchyBusinessUnitRequest
RetrieveMembersTeamRequest
RetrieveRequest
RetrieveSubsidiaryTeamsBusinessUnitRequest
RetrieveSubsidiaryUsersBusinessUnitRequest
RetrieveTeamsSystemUserRequest
RetrieveUnpublishedRequest
RetrieveUserSettingsSystemUserRequest
ReviseQuoteRequest
SearchByBodyKbArticleRequest
Other Resources
Using the ColumnSet Class
Using the QueryByAttribute Class
Using the QueryExpression Class


ColumnSet Members
See Also Constructors Methods Properties
[image]

Specifies the attributes for which non-null values are returned from a query.

The following tables list the members exposed by the ColumnSet type.

Public Constructors

Name | Description
ColumnSet | Overloaded. Initializes a new instance of the ColumnSet class.
Top

Public Properties

 | Name | Description
public property | AllColumns | Gets or sets whether to retrieve all the attributes of a record.
public property | Columns | Gets the collection of Strings containing the names of the attributes to be retrieved from a query.
public property | ExtensionData | Gets or sets the structure that contains extra data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddColumn | Adds the specified attribute to the column set.
public method | AddColumns | Adds the specified attribute to the column set.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ColumnSet Class
Microsoft.Xrm.Sdk.Query Namespace
ConvertQuoteToSalesOrderRequest
ConvertSalesOrderToInvoiceRequest
GenerateInvoiceFromOpportunityRequest
GenerateQuoteFromOpportunityRequest
GenerateSalesOrderFromOpportunityRequest
Retrieve
QueryByAttribute
QueryExpression
RetrieveAllChildUsersSystemUserRequest
RetrieveBusinessHierarchyBusinessUnitRequest
RetrieveMembersTeamRequest
RetrieveRequest
RetrieveSubsidiaryTeamsBusinessUnitRequest
RetrieveSubsidiaryUsersBusinessUnitRequest
RetrieveTeamsSystemUserRequest
RetrieveUnpublishedRequest
RetrieveUserSettingsSystemUserRequest
ReviseQuoteRequest
SearchByBodyKbArticleRequest

Other Resources

Using the ColumnSet Class
Using the QueryByAttribute Class
Using the QueryExpression Class


ColumnSet Constructor
[image]

Initializes a new instance of the ColumnSet class.

Overload List

Name | Description
ColumnSet () | Initializes a new instance of the ColumnSet class.
ColumnSet (Boolean) | Initializes a new instance of the ColumnSet class setting the AllColumns property.
ColumnSet (String[]) | Initializes a new instance of the ColumnSet class setting the Columns property.

See Also

Reference

ColumnSet Class
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace


ColumnSet Constructor ()
[image]

Initializes a new instance of the ColumnSet class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ColumnSet ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ColumnSet Class
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace


ColumnSet Constructor (Boolean)
[image]

Initializes a new instance of the ColumnSet class setting the AllColumns property.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    allColumns As Boolean _
)

C#
public ColumnSet (
    bool allColumns
)

C++

J#

JScript

Parameters
allColumns
Type: Boolean. A Boolean that specifies whether to retrieve all attributes of a record.
  Remarks
  Important

                        You should avoid retrieving all columns in a query result because of the impact on a subsequent update of records. In an update, this will set all field values, even if they are unchanged, and often triggers cascaded updates to child records.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ColumnSet Class
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace


ColumnSet Constructor (String[])
[image]

Initializes a new instance of the ColumnSet class setting the Columns property.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    ParamArray columns As String() _
)

C#
public ColumnSet (
    params string[] columns
)

C++

J#

JScript

Parameters
columns
Type: String[]. Specifies an array of Strings containing the names of the attributes.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ColumnSet Class
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace


ColumnSet Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddColumn | Adds the specified attribute to the column set.
public method | AddColumns | Adds the specified attribute to the column set.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ColumnSet Class
Microsoft.Xrm.Sdk.Query Namespace
ConvertQuoteToSalesOrderRequest
ConvertSalesOrderToInvoiceRequest
GenerateInvoiceFromOpportunityRequest
GenerateQuoteFromOpportunityRequest
GenerateSalesOrderFromOpportunityRequest
Retrieve
QueryByAttribute
QueryExpression
RetrieveAllChildUsersSystemUserRequest
RetrieveBusinessHierarchyBusinessUnitRequest
RetrieveMembersTeamRequest
RetrieveRequest
RetrieveSubsidiaryTeamsBusinessUnitRequest
RetrieveSubsidiaryUsersBusinessUnitRequest
RetrieveTeamsSystemUserRequest
RetrieveUnpublishedRequest
RetrieveUserSettingsSystemUserRequest
ReviseQuoteRequest
SearchByBodyKbArticleRequest

Other Resources

Using the ColumnSet Class
Using the QueryByAttribute Class
Using the QueryExpression Class


ColumnSet.AddColumn Method
[image]

Adds the specified attribute to the column set.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddColumn ( _
    column As String _
)

C#
public void AddColumn (
    string column
)

C++

J#

JScript

Parameters
column
Type: String. Specifies a String containing the name of the attribute.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ColumnSet Class
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace


ColumnSet.AddColumns Method
[image]

Adds the specified attribute to the column set.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddColumns ( _
    ParamArray columns As String() _
)

C#
public void AddColumns (
    params string[] columns
)

C++

J#

JScript

Parameters
columns
Type: String[]. Specifies an array of Strings containing the names of the attributes.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ColumnSet Class
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace


ColumnSet Properties
[image]

Public Properties

 | Name | Description
public property | AllColumns | Gets or sets whether to retrieve all the attributes of a record.
public property | Columns | Gets the collection of Strings containing the names of the attributes to be retrieved from a query.
public property | ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

ColumnSet Class
Microsoft.Xrm.Sdk.Query Namespace
ConvertQuoteToSalesOrderRequest
ConvertSalesOrderToInvoiceRequest
GenerateInvoiceFromOpportunityRequest
GenerateQuoteFromOpportunityRequest
GenerateSalesOrderFromOpportunityRequest
Retrieve
QueryByAttribute
QueryExpression
RetrieveAllChildUsersSystemUserRequest
RetrieveBusinessHierarchyBusinessUnitRequest
RetrieveMembersTeamRequest
RetrieveRequest
RetrieveSubsidiaryTeamsBusinessUnitRequest
RetrieveSubsidiaryUsersBusinessUnitRequest
RetrieveTeamsSystemUserRequest
RetrieveUnpublishedRequest
RetrieveUserSettingsSystemUserRequest
ReviseQuoteRequest
SearchByBodyKbArticleRequest

Other Resources

Using the ColumnSet Class
Using the QueryByAttribute Class
Using the QueryExpression Class


ColumnSet.AllColumns Property
[image]

Gets or sets whether to retrieve all the attributes of a record.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AllColumns As Boolean

C#
[DataMemberAttribute]
public bool AllColumns { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true to specify to retrieve all attributes; false to to retrieve only specified attributes.

  Remarks
  Important

                        You should avoid retrieving all columns in a query result because of the impact on a subsequent update of records. In an update, this will set all field values, even if they are unchanged, and often triggers cascaded updates to child records.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
ColumnSet Class
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace


ColumnSet.Columns Property
[image]

Gets the collection of Strings containing the names of the attributes to be retrieved from a query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public ReadOnly Property Columns As DataCollection(Of String)

C#
[DataMemberAttribute]
public DataCollection<string> Columns { get; }

C++

J#

JScript

Property Value
Type: ICollection

The collection of attribute names to return from a query.

  Remarks
Use AddColumns to set the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ColumnSet Class
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace


ColumnSet.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ColumnSet Class
ColumnSet Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Class
See Also Members
[image]

Contains a condition expression used to filter the results of the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ConditionExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class ConditionExpression
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="ConditionExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class ConditionExpression : IExtensibleDataObject

C++

J#

JScript

  Remarks
For more information, see Use the ConditionExpression Class.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Query.ConditionExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Conditions
Other Resources
Build Queries with QueryExpression


ConditionExpression Members
See Also Constructors Methods Properties
[image]

Contains a condition expression used to filter the results of the query.

The following tables list the members exposed by the ConditionExpression type.

Public Constructors

Name | Description
ConditionExpression | Overloaded. Initializes a new instance of the ConditionExpression class.
Top

Public Properties

 | Name | Description
public property | AttributeName | Gets or sets the logical name of the attribute in the condition expression.
public property | EntityName | Gets or sets the entity name for the condition.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Operator | Gets or sets the condition operator.
public property | Values | Gets or sets the values for the attribute.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConditionExpression Class
Microsoft.Xrm.Sdk.Query Namespace
Conditions

Other Resources

Build Queries with QueryExpression


ConditionExpression Constructor
[image]

Initializes a new instance of the ConditionExpression class.

Overload List

Name | Description
ConditionExpression () | Initializes a new instance of the ConditionExpression class.
ConditionExpression (String, ConditionOperator) | Initializes a new instance of the ConditionExpression class setting the attribute name and condition operator.
ConditionExpression (String, ConditionOperator, ICollection) | Initializes a new instance of the ConditionExpression class setting the attribute name, condition operator and a collection of values.
ConditionExpression (String, ConditionOperator, Object) | Initializes a new instance of the ConditionExpression class setting the attribute name, condition operator and value object.
ConditionExpression (String, ConditionOperator, Object[]) | Initializes a new instance of the ConditionExpression class setting the attribute name, condition operator and an array of value objects.
ConditionExpression (String, String, ConditionOperator) | Initializes a new instance of the ConditionExpression class.
ConditionExpression (String, String, ConditionOperator, Object) | Initializes a new instance of the ConditionExpression class.
ConditionExpression (String, String, ConditionOperator, Object[]) | Initializes a new instance of the ConditionExpression class.

See Also

Reference

ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Constructor ()
[image]

Initializes a new instance of the ConditionExpression class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConditionExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Constructor (String, ConditionOperator)
[image]

Initializes a new instance of the ConditionExpression class setting the attribute name and condition operator.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    attributeName As String, _
    conditionOperator As ConditionOperator _
)

C#
public ConditionExpression (
    string attributeName,
    ConditionOperator conditionOperator
)

C++

J#

JScript

Parameters
attributeName
Type: String. The logical name of the attribute in the condition expression.
conditionOperator
Type: ConditionOperator. The condition operator.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Constructor (String, ConditionOperator, ICollection)
[image]

Initializes a new instance of the ConditionExpression class setting the attribute name, condition operator and a collection of values.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    attributeName As String, _
    conditionOperator As ConditionOperator, _
    values As ICollection _
)

C#
public ConditionExpression (
    string attributeName,
    ConditionOperator conditionOperator,
    ICollection values
)

C++

J#

JScript

Parameters
attributeName
Type: String. The logical name of the attribute in the condition expression.
conditionOperator
Type: ConditionOperator. The condition operator.
values
Type: ICollection. The collection of attribute values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Constructor (String, ConditionOperator, Object)
[image]

Initializes a new instance of the ConditionExpression class setting the attribute name, condition operator and value object.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    attributeName As String, _
    conditionOperator As ConditionOperator, _
    value As Object _
)

C#
public ConditionExpression (
    string attributeName,
    ConditionOperator conditionOperator,
    Object value
)

C++

J#

JScript

Parameters
attributeName
Type: String. The logical name of the attribute in the condition expression.
conditionOperator
Type: ConditionOperator. The condition operator.
value
Type: Object. The attribute value.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Constructor (String, ConditionOperator, Object[])
[image]

Initializes a new instance of the ConditionExpression class setting the attribute name, condition operator and an array of value objects.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    attributeName As String, _
    conditionOperator As ConditionOperator, _
    ParamArray values As Object() _
)

C#
public ConditionExpression (
    string attributeName,
    ConditionOperator conditionOperator,
    params Object[] values
)

C++

J#

JScript

Parameters
attributeName
Type: String. The logical name of the attribute in the condition expression.
conditionOperator
Type: ConditionOperator. The condition operator.
values
Type: Object[]. The array of attribute values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Constructor (String, String, ConditionOperator)
[image]

Initializes a new instance of the ConditionExpression class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String, _
    attributeName As String, _
    conditionOperator As ConditionOperator _
)

C#
public ConditionExpression (
    string entityName,
    string attributeName,
    ConditionOperator conditionOperator
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity in the condition expression.
attributeName
Type: String. The logical name of the attribute in the condition expression.
conditionOperator
Type: ConditionOperator. The condition operator.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Constructor (String, String, ConditionOperator, Object)
[image]

Initializes a new instance of the ConditionExpression class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String, _
    attributeName As String, _
    conditionOperator As ConditionOperator, _
    value As Object _
)

C#
public ConditionExpression (
    string entityName,
    string attributeName,
    ConditionOperator conditionOperator,
    Object value
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity in the condition expression.
attributeName
Type: String. The logical name of the attribute in the condition expression.
conditionOperator
Type: ConditionOperator. The condition operator.
value
Type: Object. The attribute value.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Constructor (String, String, ConditionOperator, Object[])
[image]

Initializes a new instance of the ConditionExpression class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String, _
    attributeName As String, _
    conditionOperator As ConditionOperator, _
    ParamArray values As Object() _
)

C#
public ConditionExpression (
    string entityName,
    string attributeName,
    ConditionOperator conditionOperator,
    params Object[] values
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity in the condition expression.
attributeName
Type: String. The logical name of the attribute in the condition expression.
conditionOperator
Type: ConditionOperator. The condition operator.
values
Type: Object[]. The array of attribute values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConditionExpression Class
Microsoft.Xrm.Sdk.Query Namespace
Conditions

Other Resources

Build Queries with QueryExpression


ConditionExpression Properties
[image]

Public Properties

 | Name | Description
public property | AttributeName | Gets or sets the logical name of the attribute in the condition expression.
public property | EntityName | Gets or sets the entity name for the condition.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | Operator | Gets or sets the condition operator.
public property | Values | Gets or sets the values for the attribute.

See Also

Reference

ConditionExpression Class
Microsoft.Xrm.Sdk.Query Namespace
Conditions

Other Resources

Build Queries with QueryExpression


ConditionExpression.AttributeName Property
[image]

Gets or sets the logical name of the attribute in the condition expression.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeName As String

C#
[DataMemberAttribute]
public string AttributeName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the attribute in the condition expression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression.EntityName Property
[image]

Gets or sets the entity name for the condition.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=60)> _
Public Property EntityName As String

C#
[DataMemberAttribute(Order=60)]
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The name of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression.Operator Property
[image]

Gets or sets the condition operator.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Operator As ConditionOperator

C#
[DataMemberAttribute]
public ConditionOperator Operator { get; set; }

C++

J#

JScript

Property Value
Type: ConditionOperator

The condition operator.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionExpression.Values Property
[image]

Gets or sets the values for the attribute.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Values As DataCollection(Of Object)

C#
[DataMemberAttribute]
public DataCollection<Object> Values { get; }

C++

J#

JScript

Property Value
Type: DataCollection<Object>
The attribute values.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConditionExpression Class
ConditionExpression Members
Microsoft.Xrm.Sdk.Query Namespace


ConditionOperator Enumeration
See Also Example
[image]

Describes the type of comparison for two values (or expressions) in a condition expression.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="ConditionOperator", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Enumeration ConditionOperator

C#
[DataContractAttribute(Name="ConditionOperator", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public enum ConditionOperator

C++

J#

JScript

  Members
Member name | Description
Above | Returns all records in referenced record's hierarchical ancestry line. Value = 75.
AboveOrEqual | Returns the referenced record and all records above it in the hierarchy. Value = 78.
BeginsWith | The string occurs at the beginning of another string. Value = 54.
Between | The value is between two values. Value = 10.
ChildOf | For internal use only.
Contains | The string contains another string. Value = 49.You must use the Contains operator for only those attributes that are enabled for full-text indexing. Otherwise, you will receive a generic SQL error message while retrieving data. In a Microsoft Dynamics CRM default installation, only the attributes of the KBArticle (article) entity are enabled for full-text indexing.
DoesNotBeginWith | The string does not begin with another string. Value = 55.
DoesNotContain | The string does not contain another string. Value = 50.
DoesNotEndWith | The string does not end with another string. Value = 57.
EndsWith | The string ends with another string. Value = 56.
Equal | The values are compared for equality. Value = 0.
EqualBusinessId | The value is equal to the specified business ID. Value = 43.
EqualUserId | The value is equal to the specified user ID. Value = 41.
EqualUserLanguage | The value is equal to the language for the user. Value = 51.
EqualUserOrUserHierarchy | When hierarchical security models are used, Equals current user or their reporting hierarchy. Value = 80.
EqualUserOrUserHierarchyAndTeams | When hierarchical security models are used, Equals current user and his teams or their reporting hierarchy and their teams. Value = 81.
EqualUserOrUserTeams | The record is owned by a user or teams that the user is a member of. Value = 74.
EqualUserTeams | The record is owned by teams that the user is a member of. Value = 73.
GreaterEqual | The value is greater than or equal to the compared value. Value = 4.
GreaterThan | The value is greater than the compared value. Value = 2.
In | TheThe value exists in a list of values. Value = 8.
InFiscalPeriod | The value is within the specified fiscal period. Value = 69.
InFiscalPeriodAndYear | The value is within the specified fiscal period and year. Value = 70.
InFiscalYear | The value is within the specified year. Value = 68.
InOrAfterFiscalPeriodAndYear | The value is within or after the specified fiscal period and year. Value = 72.
InOrBeforeFiscalPeriodAndYear | The value is within or before the specified fiscal period and year. Value = 71.
Last7Days | The value is within the last seven days including today. Value = 17.
LastFiscalPeriod | The value is within the last fiscal period. Value = 63.
LastFiscalYear | The value is within the last fiscal year. Value = 62.
LastMonth | The value is within the last month including first day of the last month and last day of the last month. Value = 22.
LastWeek | The value is within the previous week including Sunday through Saturday. Value = 19.
LastXDays | The value is within last X days. Value = 33.
LastXFiscalPeriods | The value is within the last X (specified value) fiscal periods. Value = 65.
LastXFiscalYears | The value is within the last X (specified value) fiscal periods. Value = 0x40.
LastXHours | The value is within the last X hours. Value =31.
LastXMonths | The value is within the last X (specified value) months. Value = 37.
LastXWeeks | The value is within the last X (specified value) weeks. Value = 35.
LastXYears | The value is within the last X years. Value = 39.
LastYear | The value is within the previous year. Value = 28.
LessEqual | The value is less than or equal to the compared value. Value = 5.
LessThan | The value is less than the compared value. Value = 3.
Like | The character string is matched to the specified pattern. Value = 6.
Mask | The value is found in the specified bit-mask value. Value = 46.
MasksSelect | For internal use only. Value = 48.
Next7Days | The value is within the next seven days. Value = 18.
NextFiscalPeriod | The value is within the next fiscal period. Value = 61.
NextFiscalYear | The value is within the next fiscal year. Value = 60.
NextMonth | The value is within the next month. Value = 24.
NextWeek | The value is within the next week. Value = 21.
NextXDays | The value is within the next X (specified value) days. Value = 34.
NextXFiscalPeriods | The value is within the next X (specified value) fiscal period. Value = 67.
NextXFiscalYears | The value is within the next X (specified value) fiscal years. Value = 66.
NextXHours | The value is within the next X (specified value) hours. Value = 32.
NextXMonths | The value is within the next X (specified value) months. Value = 38.
NextXWeeks | The value is within the next X weeks. Value = 36.
NextXYears | The value is within the next X years. Value = 40.
NextYear | The value is within the next year. Value = 30.
NotBetween | The value is not between two values. Value = 11.
NotEqual | The two values are not equal. Value = 1.
NotEqualBusinessId | The value is not equal to the specified business ID. Value = 44.
NotEqualUserId | The value is not equal to the specified user ID. Value = 42.
NotIn | The given value is not matched to a value in a subquery or a list. Value = 9.
NotLike | The character string does not match the specified pattern. Value = 7.
NotMask | The value is not found in the specified bit-mask value. Value = 47.
NotNull | The value is not null. Value = 13.
NotOn | The value is not on the specified date. Value = 52.
NotUnder | Returns all records not below the referenced record in the hierarchy. Value = 77.
Null | The value is null. Value = 12.
OlderThanXMonths | The value is older than the specified number of months. Value = 53.
On | The value is on a specified date. Value = 25.
OnOrAfter | The value is on or after a specified date. Value = 27.
OnOrBefore | The value is on or before a specified date. Value = 26.
ThisFiscalPeriod | The value is within the current fiscal period. Value = 59.
ThisFiscalYear | The value is within the current fiscal year . Value = 58.
ThisMonth | The value is within the current month. Value = 23.
ThisWeek | The value is within the current week. Value = 20.
ThisYear | The value is within the current year. Value = 29.
Today | The value equals today’s date. Value = 15.
Tomorrow | The value equals tomorrow’s date. Value = 16.
Under | Returns all child records below the referenced record in the hierarchy. Value = 76.
UnderOrEqual | Returns the referenced record and all child records below it in the hierarchy. Value = 79.
Yesterday | The value equals yesterday’s date. Value = 14.
  Example
C#    Copy Code
filter.AddCondition("accountid", ConditionOperator.Equal, _accountIdArray[j]);

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
Microsoft.Xrm.Sdk.Query Namespace
Operator


FetchExpression Class
See Also Members
[image]

Contains a query expressed in FetchXML.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="FetchExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class FetchExpression
    Inherits QueryBase

C#
[DataContractAttribute(Name="FetchExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class FetchExpression : QueryBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Query.QueryBase
    Microsoft.Xrm.Sdk.Query.FetchExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FetchExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Build Queries with FetchXML
FetchXML Schema


FetchExpression Members
See Also Constructors Methods Properties
[image]

Contains a query expressed in FetchXML.

The following tables list the members exposed by the FetchExpression type.

Public Constructors

Name | Description
FetchExpression | Initializes a new instance of the FetchExpression class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from QueryBase)
public property | Query | Gets or sets the FetchXML query string.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

FetchExpression Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with FetchXML
FetchXML Schema


FetchExpression Constructor
[image]

Initializes a new instance of the FetchExpression class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    query As String _
)

C#
public FetchExpression (
    string query
)

C++

J#

JScript

Parameters
query
Type: String. The FetchXML query string.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FetchExpression Class
FetchExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FetchExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

FetchExpression Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with FetchXML
FetchXML Schema


FetchExpression Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from QueryBase)
public property | Query | Gets or sets the FetchXML query string.

See Also

Reference

FetchExpression Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with FetchXML
FetchXML Schema


FetchExpression.Query Property
[image]

Gets or sets the FetchXML query string.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Query As String

C#
[DataMemberAttribute]
public string Query { get; set; }

C++

J#

JScript

Property Value
Type: String
The FetchXML query string.

  Remarks

                        The query must specify entity names and a column set. If the column set includes attributes that are not valid for retrieve or that you do not have access to, they will be ignored.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FetchExpression Class
FetchExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Build Queries with FetchXML
FetchXML Schema


FilterExpression Class
See Also Members
[image]

Specifies complex condition and logical filter expressions used for filtering the results of the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="FilterExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class FilterExpression
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="FilterExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class FilterExpression : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Query.FilterExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Criteria
LinkCriteria
Other Resources
Use the FilterExpression Class
Sample: Query Connection Roles by Entity Type Code (Early Bound)
Sample: Clean Up History for a Queue (Early Bound)
Sample: Retrieve an Opportunity (Early Bound)
Sample: Retrieve Records from an Intersect Table


FilterExpression Members
See Also Constructors Methods Properties
[image]

Specifies complex condition and logical filter expressions used for filtering the results of the query.

The following tables list the members exposed by the FilterExpression type.

Public Constructors

Name | Description
FilterExpression | Overloaded. Initializes a new instance of the FilterExpression class.
Top

Public Properties

 | Name | Description
public property | Conditions | Gets condition expressions that include attributes, condition operators, and attribute values.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | FilterOperator | Gets or sets the logical AND/OR filter operator.
public property | Filters | Gets a collection of condition and logical filter expressions that filter the results of the query.
public property | IsQuickFindFilter | Gets or sets whether the expression is part of a quick find query.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddCondition | Overloaded. Adds a condition to the filter expression.
public method | AddFilter | Overloaded. Adds a child filter to the filter expression.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

FilterExpression Class
Microsoft.Xrm.Sdk.Query Namespace
Criteria
LinkCriteria

Other Resources

Use the FilterExpression Class
Sample: Query Connection Roles by Entity Type Code (Early Bound)
Sample: Clean Up History for a Queue (Early Bound)
Sample: Retrieve an Opportunity (Early Bound)
Sample: Retrieve Records from an Intersect Table


FilterExpression Constructor
[image]

Initializes a new instance of the FilterExpression class.

Overload List

Name | Description
FilterExpression () | Initializes a new instance of the FilterExpression class.
FilterExpression (LogicalOperator) | Initializes a new instance of the FilterExpression class.

See Also

Reference

FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression Constructor ()
[image]

Initializes a new instance of the FilterExpression class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public FilterExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression Constructor (LogicalOperator)
[image]

Initializes a new instance of the FilterExpression class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    filterOperator As LogicalOperator _
)

C#
public FilterExpression (
    LogicalOperator filterOperator
)

C++

J#

JScript

Parameters
filterOperator
Type: LogicalOperator. The filter operator.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddCondition | Overloaded. Adds a condition to the filter expression.
public method | AddFilter | Overloaded. Adds a child filter to the filter expression.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

FilterExpression Class
Microsoft.Xrm.Sdk.Query Namespace
Criteria
LinkCriteria

Other Resources

Use the FilterExpression Class
Sample: Query Connection Roles by Entity Type Code (Early Bound)
Sample: Clean Up History for a Queue (Early Bound)
Sample: Retrieve an Opportunity (Early Bound)
Sample: Retrieve Records from an Intersect Table


FilterExpression.AddCondition Method
[image]

Adds a condition to the filter expression.

Overload List

Name | Description
FilterExpression.AddCondition (ConditionExpression) | Adds a condition to the filter expression setting the condition expression.
FilterExpression.AddCondition (String, ConditionOperator, Object[]) | Adds a condition to the filter expression setting the attribute name, condition operator, and value array.
FilterExpression.AddCondition (String, String, ConditionOperator, Object[]) | Adds a condition to the filter expression setting the entity name, attribute name, condition operator, and value array.

See Also

Reference

FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.AddCondition Method (ConditionExpression)
[image]

Adds a condition to the filter expression setting the condition expression.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddCondition ( _
    condition As ConditionExpression _
)

C#
public void AddCondition (
    ConditionExpression condition
)

C++

J#

JScript

Parameters
condition
Type: ConditionExpression. Specifies the condition expression to be added.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.AddCondition Method (String, ConditionOperator, Object[])
[image]

Adds a condition to the filter expression setting the attribute name, condition operator, and value array.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddCondition ( _
    attributeName As String, _
    conditionOperator As ConditionOperator, _
    ParamArray values As Object() _
)

C#
public void AddCondition (
    string attributeName,
    ConditionOperator conditionOperator,
    params Object[] values
)

C++

J#

JScript

Parameters
attributeName
Type: String. The name of the attribute.
conditionOperator
Type: ConditionOperator. The enumeration type.
values
Type: Object[]. The array of values to add.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.AddCondition Method (String, String, ConditionOperator, Object[])
[image]

Adds a condition to the filter expression setting the entity name, attribute name, condition operator, and value array.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddCondition ( _
    entityName As String, _
    attributeName As String, _
    conditionOperator As ConditionOperator, _
    ParamArray values As Object() _
)

C#
public void AddCondition (
    string entityName,
    string attributeName,
    ConditionOperator conditionOperator,
    params Object[] values
)

C++

J#

JScript

Parameters
entityName
Type: String. The name of the entity.
attributeName
Type: String. The name of the attribute.
conditionOperator
Type: ConditionOperator. The enumeration type.
values
Type: Object[]. The array of values to add.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.AddFilter Method
[image]

Adds a child filter to the filter expression.

Overload List

Name | Description
FilterExpression.AddFilter (FilterExpression) | Adds a child filter to the filter expression.
FilterExpression.AddFilter (LogicalOperator) | Adds a child filter to the filter expression setting the logical operator.

See Also

Reference

FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.AddFilter Method (FilterExpression)
[image]

Adds a child filter to the filter expression.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddFilter ( _
    childFilter As FilterExpression _
)

C#
public void AddFilter (
    FilterExpression childFilter
)

C++

J#

JScript

Parameters
childFilter
Type: FilterExpression. The filter to be added.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.AddFilter Method (LogicalOperator)
[image]

Adds a child filter to the filter expression setting the logical operator.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function AddFilter ( _
    logicalOperator As LogicalOperator _
) As FilterExpression

C#
public FilterExpression AddFilter (
    LogicalOperator logicalOperator
)

C++

J#

JScript

Parameters
logicalOperator
Type: LogicalOperator. The enumeration type.
Return Value
Type: FilterExpression

The new filter expression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression Properties
[image]

Public Properties

 | Name | Description
public property | Conditions | Gets condition expressions that include attributes, condition operators, and attribute values.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | FilterOperator | Gets or sets the logical AND/OR filter operator.
public property | Filters | Gets a collection of condition and logical filter expressions that filter the results of the query.
public property | IsQuickFindFilter | Gets or sets whether the expression is part of a quick find query.

See Also

Reference

FilterExpression Class
Microsoft.Xrm.Sdk.Query Namespace
Criteria
LinkCriteria

Other Resources

Use the FilterExpression Class
Sample: Query Connection Roles by Entity Type Code (Early Bound)
Sample: Clean Up History for a Queue (Early Bound)
Sample: Retrieve an Opportunity (Early Bound)
Sample: Retrieve Records from an Intersect Table


FilterExpression.Conditions Property
[image]

Gets condition expressions that include attributes, condition operators, and attribute values.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Conditions As DataCollection(Of ConditionExpression)

C#
[DataMemberAttribute]
public DataCollection<ConditionExpression> Conditions { get; }

C++

J#

JScript

Property Value
Type: DataCollection<ConditionExpression>

The collection of condition expressions.

  Remarks
This property is read-only. Use the AddCondition(ConditionExpression) method to change the contents of the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.FilterOperator Property
[image]

Gets or sets the logical AND/OR filter operator.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property FilterOperator As LogicalOperator

C#
[DataMemberAttribute]
public LogicalOperator FilterOperator { get; set; }

C++

J#

JScript

Property Value
Type: LogicalOperator
The filter operator.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.Filters Property
[image]

Gets a collection of condition and logical filter expressions that filter the results of the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Filters As DataCollection(Of FilterExpression)

C#
[DataMemberAttribute]
public DataCollection<FilterExpression> Filters { get; }

C++

J#

JScript

Property Value
Type: DataCollection<FilterExpression>
The collection of filters.

  Remarks
This property is read only. Use the AddFilter(FilterExpression) method to change the contents of the array list.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace


FilterExpression.IsQuickFindFilter Property
[image]

Gets or sets whether the expression is part of a quick find query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=51, EmitDefaultValue:=False)> _
Public Property IsQuickFindFilter As Boolean

C#
[DataMemberAttribute(Order=51, EmitDefaultValue=false)]
public bool IsQuickFindFilter { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the filter is part of a quick find query; otherwise, false.

  Remarks
For more information, see Performance Improvements with the IsQuickFindFilter Property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
FilterExpression Class
FilterExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Use the FilterExpression Class


JoinOperator Enumeration
[image]

Contains the possible values for a join operator in a LinkEntity.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="JoinOperator", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Enumeration JoinOperator

C#
[DataContractAttribute(Name="JoinOperator", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public enum JoinOperator

C++

J#

JScript

  Members
Member name | Description
Inner | The values in the attributes being joined are compared using a comparison operator. Value = 0.
LeftOuter | All instances of the entity in the FROM clause are returned if they meet WHERE or HAVING search conditions. Value = 1.
Natural | Only one value of the two joined attributes is returned if an equal-join operation is performed and the two values are identical. Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Sample: Query Connections by Reciprocal Roles (Early Bound)
Sample: Retrieve Multiple with Query Expression


LinkEntity Class
See Also Example Members
[image]

Specifies the links between multiple entity types used in creating complex queries.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="LinkEntity", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class LinkEntity
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="LinkEntity", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class LinkEntity : IExtensibleDataObject

C++

J#

JScript

  Example
    Copy Code
q = new QueryExpression();
q.EntityName = "account";
q.ColumnSet = new ColumnSet();
q.ColumnSet.Columns.Add("name");

q.LinkEntities.Add(new LinkEntity("account", "contact", "primarycontactid", "contactid", JoinOperator.Inner));
q.LinkEntities[0].Columns.AddColumns("firstname", "lastname");
q.LinkEntities[0].EntityAlias = "temp";

q.Criteria = new FilterExpression();
q.Criteria.AddCondition("accountnumber", ConditionOperator.Equal, accountNumber);
q.Orders.Add(new OrderExpression("name", OrderType.Descending));
q.Distinct = true;
EntityCollection ec = this.Context.Proxy.RetrieveMultiple(q);

Log.Assert(ec.Entities.Count == 3, "Expected 3 entities, received {0}", ec.Entities.Count);
Log.Assert((string)ec.Entities[0]["name"] == "SdkAccount3", "First Entity should be SdkAccount3");
Log.Assert((string)ec.Entities[1]["name"] == "SdkAccount2", "First Entity should be SdkAccount2");
Log.Assert((string)ec.Entities[2]["name"] == "SdkAccount1", "First Entity should be SdkAccount1");
Log.Assert((string)((AliasedValue)ec.Entities[0]["temp.firstname"]).Value == (string)contact["firstname"], "Expected {0} Got {1}", contact["firstname"], ec.Entities[0]["temp.firstname"]);
Log.Assert((string)((AliasedValue)ec.Entities[1]["temp.lastname"]).Value == (string)contact["lastname"], "Expected {0} Got {1}", contact["lastname"], ec.Entities[1]["temp.lastname"]);

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Query.LinkEntity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace
LinkEntities


LinkEntity Members
See Also Constructors Methods Properties
[image]

Specifies the links between multiple entity types used in creating complex queries.

The following tables list the members exposed by the LinkEntity type.

Public Constructors

Name | Description
LinkEntity | Overloaded. Initializes a new instance of the LinkEntity class.
Top

Public Properties

 | Name | Description
public property | Columns | Gets or sets the column set.
public property | EntityAlias | Gets or sets the alias for the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | JoinOperator | Gets or sets the join operator.
public property | LinkCriteria | Gets or sets the complex condition and logical filter expressions that filter the results of the query.
public property | LinkEntities | Gets the links between multiple entity types.
public property | LinkFromAttributeName | Gets or sets the logical name of the attribute of the entity that you are linking from.
public property | LinkFromEntityName | Gets or sets the logical name of the entity that you are linking from.
public property | LinkToAttributeName | Gets or sets the logical name of the attribute of the entity that you are linking to.
public property | LinkToEntityName | Gets or sets the logical name of the entity that you are linking to.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddLink | Overloaded. Adds a link.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LinkEntity Class
Microsoft.Xrm.Sdk.Query Namespace
LinkEntities


LinkEntity Constructor
[image]

Initializes a new instance of the LinkEntity class.

Overload List

Name | Description
LinkEntity () | Initializes a new instance of the LinkEntity class.
LinkEntity (String, String, String, String, JoinOperator) | Initializes a new instance of the LinkEntity class setting the required properties.

See Also

Reference

LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity Constructor ()
[image]

Initializes a new instance of the LinkEntity class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LinkEntity ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity Constructor (String, String, String, String, JoinOperator)
[image]

Initializes a new instance of the LinkEntity class setting the required properties.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    linkFromEntityName As String, _
    linkToEntityName As String, _
    linkFromAttributeName As String, _
    linkToAttributeName As String, _
    joinOperator As JoinOperator _
)

C#
public LinkEntity (
    string linkFromEntityName,
    string linkToEntityName,
    string linkFromAttributeName,
    string linkToAttributeName,
    JoinOperator joinOperator
)

C++

J#

JScript

Parameters
linkFromEntityName
Type: String. The logical name of the entity to link from.
linkToEntityName
Type: String. The logical name of the entity to link to.
linkFromAttributeName
Type: String. The name of the attribute to link from.
linkToAttributeName
Type: String. The name of the attribute to link to.
joinOperator
Type: JoinOperator. The join operator.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddLink | Overloaded. Adds a link.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LinkEntity Class
Microsoft.Xrm.Sdk.Query Namespace
LinkEntities


LinkEntity.AddLink Method
[image]

Adds a link.

Overload List

Name | Description
LinkEntity.AddLink (String, String, String) | Adds a link, setting the link to entity name, the link from attribute name and the link to attribute name.
LinkEntity.AddLink (String, String, String, JoinOperator) | Adds a link setting the link to entity name, the link from attribute name, the link to attribute name, and the join operator.

See Also

Reference

LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.AddLink Method (String, String, String)
[image]

Adds a link, setting the link to entity name, the link from attribute name and the link to attribute name.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function AddLink ( _
    linkToEntityName As String, _
    linkFromAttributeName As String, _
    linkToAttributeName As String _
) As LinkEntity

C#
public LinkEntity AddLink (
    string linkToEntityName,
    string linkFromAttributeName,
    string linkToAttributeName
)

C++

J#

JScript

Parameters
linkToEntityName
Type: String. The name of the entity to link to.
linkFromAttributeName
Type: String. The name of the attribute to link from.
linkToAttributeName
Type: String. The name of the attribute to link to.
Return Value
Type: LinkEntity
The link entity that was created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.AddLink Method (String, String, String, JoinOperator)
[image]

Adds a link setting the link to entity name, the link from attribute name, the link to attribute name, and the join operator.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function AddLink ( _
    linkToEntityName As String, _
    linkFromAttributeName As String, _
    linkToAttributeName As String, _
    joinOperator As JoinOperator _
) As LinkEntity

C#
public LinkEntity AddLink (
    string linkToEntityName,
    string linkFromAttributeName,
    string linkToAttributeName,
    JoinOperator joinOperator
)

C++

J#

JScript

Parameters
linkToEntityName
Type: String. The name of the entity to link to.
linkFromAttributeName
Type: String. The name of the attribute to link from.
linkToAttributeName
Type: String. The name of the attribute to link to.
joinOperator
Type: JoinOperator. The join operator.
Return Value
Type: LinkEntity
The link entity that was created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity Properties
[image]

Public Properties

 | Name | Description
public property | Columns | Gets or sets the column set.
public property | EntityAlias | Gets or sets the alias for the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | JoinOperator | Gets or sets the join operator.
public property | LinkCriteria | Gets or sets the complex condition and logical filter expressions that filter the results of the query.
public property | LinkEntities | Gets the links between multiple entity types.
public property | LinkFromAttributeName | Gets or sets the logical name of the attribute of the entity that you are linking from.
public property | LinkFromEntityName | Gets or sets the logical name of the entity that you are linking from.
public property | LinkToAttributeName | Gets or sets the logical name of the attribute of the entity that you are linking to.
public property | LinkToEntityName | Gets or sets the logical name of the entity that you are linking to.

See Also

Reference

LinkEntity Class
Microsoft.Xrm.Sdk.Query Namespace
LinkEntities


LinkEntity.Columns Property
[image]

Gets or sets the column set.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Columns As ColumnSet

C#
[DataMemberAttribute]
public ColumnSet Columns { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The set of columns (fields) to be returned for the query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.EntityAlias Property
[image]

Gets or sets the alias for the entity.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityAlias As String

C#
[DataMemberAttribute]
public string EntityAlias { get; set; }

C++

J#

JScript

Property Value
Type: String

The alias for the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.JoinOperator Property
[image]

Gets or sets the join operator.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property JoinOperator As JoinOperator

C#
[DataMemberAttribute]
public JoinOperator JoinOperator { get; set; }

C++

J#

JScript

Property Value
Type: JoinOperator
The join operator.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.LinkCriteria Property
[image]

Gets or sets the complex condition and logical filter expressions that filter the results of the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LinkCriteria As FilterExpression

C#
[DataMemberAttribute]
public FilterExpression LinkCriteria { get; set; }

C++

J#

JScript

Property Value
Type: FilterExpression
The complex condition and logical filter expressions that filter the results of the query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.LinkEntities Property
[image]

Gets the links between multiple entity types.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LinkEntities As DataCollection(Of LinkEntity)

C#
[DataMemberAttribute]
public DataCollection<LinkEntity> LinkEntities { get; }

C++

J#

JScript

Property Value
Type: DataCollection<LinkEntity>
The collection of links between entities.

  Remarks
This property is read-only. Use the AddLink(String,String,String) or  AddLink(String,String,String,JoinOperator) method to add a link.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.LinkFromAttributeName Property
[image]

Gets or sets the logical name of the attribute of the entity that you are linking from.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LinkFromAttributeName As String

C#
[DataMemberAttribute]
public string LinkFromAttributeName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the attribute of the entity that you are linking from.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.LinkFromEntityName Property
[image]

Gets or sets the logical name of the entity that you are linking from.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LinkFromEntityName As String

C#
[DataMemberAttribute]
public string LinkFromEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the entity that you are linking from.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.LinkToAttributeName Property
[image]

Gets or sets the logical name of the attribute of the entity that you are linking to.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LinkToAttributeName As String

C#
[DataMemberAttribute]
public string LinkToAttributeName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the attribute of the entity that you are linking to.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LinkEntity.LinkToEntityName Property
[image]

Gets or sets the logical name of the entity that you are linking to.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LinkToEntityName As String

C#
[DataMemberAttribute]
public string LinkToEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the entity that you are linking to.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LinkEntity Class
LinkEntity Members
Microsoft.Xrm.Sdk.Query Namespace


LogicalOperator Enumeration
[image]

Contains the possible values for an operator in a FilterExpression.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="LogicalOperator", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Enumeration LogicalOperator

C#
[DataContractAttribute(Name="LogicalOperator", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public enum LogicalOperator

C++

J#

JScript

  Members
Member name | Description
And | A logical AND operation is performed. Value = 0.
Or | A logical OR operation is performed. Value = 1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Test for a Null Value
Use the FilterExpression Class
Sample: Query Connections by Reciprocal Roles (Early Bound)
Sample: Retrieve Records from an Intersect Table


OrderExpression Class
See Also Members
[image]

Sets the order in which the entity instances are returned from the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OrderExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class OrderExpression
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="OrderExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class OrderExpression : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Query.OrderExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Sample: Page Large Result Sets with Query Expression and FetchXML


OrderExpression Members
See Also Constructors Methods Properties
[image]

Sets the order in which the entity instances are returned from the query.

The following tables list the members exposed by the OrderExpression type.

Public Constructors

Name | Description
OrderExpression | Overloaded. Initializes a new instance of the OrderExpression class.
Top

Public Properties

 | Name | Description
public property | AttributeName | Gets or sets the name of the attribute in the order expression.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | OrderType | Gets or sets the order, ascending or descending.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrderExpression Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Sample: Page Large Result Sets with Query Expression and FetchXML


OrderExpression Constructor
[image]

Initializes a new instance of the OrderExpression class.

Overload List

Name | Description
OrderExpression () | Initializes a new instance of the OrderExpression class.
OrderExpression (String, OrderType) | Initializes a new instance of the OrderExpression class setting the attribute name and the order type.

See Also

Reference

OrderExpression Class
OrderExpression Members
Microsoft.Xrm.Sdk.Query Namespace


OrderExpression Constructor ()
[image]

Initializes a new instance of the OrderExpression class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrderExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderExpression Class
OrderExpression Members
Microsoft.Xrm.Sdk.Query Namespace


OrderExpression Constructor (String, OrderType)
[image]

Initializes a new instance of the OrderExpression class setting the attribute name and the order type.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    attributeName As String, _
    orderType As OrderType _
)

C#
public OrderExpression (
    string attributeName,
    OrderType orderType
)

C++

J#

JScript

Parameters
attributeName
Type: String. The name of the attribute.
orderType
Type: OrderType. The order, ascending or descending.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderExpression Class
OrderExpression Members
Microsoft.Xrm.Sdk.Query Namespace


OrderExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrderExpression Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Sample: Page Large Result Sets with Query Expression and FetchXML


OrderExpression Properties
[image]

Public Properties

 | Name | Description
public property | AttributeName | Gets or sets the name of the attribute in the order expression.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | OrderType | Gets or sets the order, ascending or descending.

See Also

Reference

OrderExpression Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Sample: Page Large Result Sets with Query Expression and FetchXML


OrderExpression.AttributeName Property
[image]

Gets or sets the name of the attribute in the order expression.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property AttributeName As String

C#
[DataMemberAttribute]
public string AttributeName { get; set; }

C++

J#

JScript

Property Value
Type: String

The name of the attribute in the order expression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderExpression Class
OrderExpression Members
Microsoft.Xrm.Sdk.Query Namespace


OrderExpression.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderExpression Class
OrderExpression Members
Microsoft.Xrm.Sdk.Query Namespace


OrderExpression.OrderType Property
[image]

Gets or sets the order, ascending or descending.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property OrderType As OrderType

C#
[DataMemberAttribute]
public OrderType OrderType { get; set; }

C++

J#

JScript

Property Value
Returns OrderType
The order, ascending or descending.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrderExpression Class
OrderExpression Members
Microsoft.Xrm.Sdk.Query Namespace


OrderType Enumeration
[image]

Contains the possible values for the order type in an OrderExpression.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="OrderType", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Enumeration OrderType

C#
[DataContractAttribute(Name="OrderType", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public enum OrderType

C++

J#

JScript

  Members
Member name | Description
Ascending | The values of the specified attribute should be sorted in ascending order, from lowest to highest. Value = 0.
Descending | The values of the specified attribute should be sorted in descending order, from highest to lowest. Value = 1.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Sample: Page Large Result Sets with Query Expression and FetchXML
Sample: Update With Related Actions (Early Bound)


PagingInfo Class
See Also Members
[image]

Specifies a number of pages and a number of entity instances per page to return from the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="PagingInfo", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class PagingInfo
    Implements IExtensibleDataObject

C#
[DataContractAttribute(Name="PagingInfo", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class PagingInfo : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Query.PagingInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PagingInfo Members
Microsoft.Xrm.Sdk.Query Namespace
PagingInfo
Other Resources
Page Large Result Sets with Query Expression and FetchXML
Sample: Use FetchXML with a Paging Cookie


PagingInfo Members
See Also Constructors Methods Properties
[image]

Specifies a number of pages and a number of entity instances per page to return from the query.

The following tables list the members exposed by the PagingInfo type.

Public Constructors

Name | Description
PagingInfo | Initializes a new instance of the PagingInfo class.
Top

Public Properties

 | Name | Description
public property | Count | Gets or sets the number of entity instances returned per page.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PageNumber | Gets or sets the number of pages returned from the query.
public property | PagingCookie | Gets or sets the info used to page large result sets.
public property | ReturnTotalRecordCount | Sets whether the total number of records should be returned from the query.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PagingInfo Class
Microsoft.Xrm.Sdk.Query Namespace
PagingInfo

Other Resources

Page Large Result Sets with Query Expression and FetchXML
Sample: Use FetchXML with a Paging Cookie


PagingInfo Constructor
[image]

Initializes a new instance of the PagingInfo class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PagingInfo ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PagingInfo Class
PagingInfo Members
Microsoft.Xrm.Sdk.Query Namespace


PagingInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PagingInfo Class
Microsoft.Xrm.Sdk.Query Namespace
PagingInfo

Other Resources

Page Large Result Sets with Query Expression and FetchXML
Sample: Use FetchXML with a Paging Cookie


PagingInfo Properties
[image]

Public Properties

 | Name | Description
public property | Count | Gets or sets the number of entity instances returned per page.
public property | ExtensionData | Gets or sets the structure that contains extra data.
public property | PageNumber | Gets or sets the number of pages returned from the query.
public property | PagingCookie | Gets or sets the info used to page large result sets.
public property | ReturnTotalRecordCount | Sets whether the total number of records should be returned from the query.

See Also

Reference

PagingInfo Class
Microsoft.Xrm.Sdk.Query Namespace
PagingInfo

Other Resources

Page Large Result Sets with Query Expression and FetchXML
Sample: Use FetchXML with a Paging Cookie


PagingInfo.Count Property
[image]

Gets or sets the number of entity instances returned per page.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Count As Integer

C#
[DataMemberAttribute]
public int Count { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The number of entity instances returned per page.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PagingInfo Class
PagingInfo Members
Microsoft.Xrm.Sdk.Query Namespace


PagingInfo.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PagingInfo Class
PagingInfo Members
Microsoft.Xrm.Sdk.Query Namespace


PagingInfo.PageNumber Property
[image]

Gets or sets the number of pages returned from the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PageNumber As Integer

C#
[DataMemberAttribute]
public int PageNumber { get; set; }

C++

J#

JScript

Property Value
Type: Int32

The number of pages returned from the query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PagingInfo Class
PagingInfo Members
Microsoft.Xrm.Sdk.Query Namespace


PagingInfo.PagingCookie Property
[image]

Gets or sets the info used to page large result sets.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PagingCookie As String

C#
[DataMemberAttribute]
public string PagingCookie { get; set; }

C++

J#

JScript

Property Value
Type: String

The info used to page large result sets.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PagingInfo Class
PagingInfo Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Page Large Result Sets with Query Expression
Page Large Result Sets with FetchXML
Page Large Result Sets with LINQ


PagingInfo.ReturnTotalRecordCount Property
[image]

Sets whether the total number of records should be returned from the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ReturnTotalRecordCount As Boolean

C#
[DataMemberAttribute]
public bool ReturnTotalRecordCount { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the TotalRecordCount should be set when the query is executed; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PagingInfo Class
PagingInfo Members
Microsoft.Xrm.Sdk.Query Namespace
TotalRecordCount
Other Resources
Use the QueryExpression Class


QueryBase Class
See Also Members
[image]

Represents the abstract base class for constructing a query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<KnownTypeAttribute(GetType(QueryExpression))> _
<KnownTypeAttribute(GetType(QueryByAttribute))> _
<KnownTypeAttribute(GetType(FetchExpression))> _
<DataContractAttribute(Name:="QueryBase", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public MustInherit Class QueryBase
    Implements IExtensibleDataObject

C#
[KnownTypeAttribute(typeof(QueryExpression))]
[KnownTypeAttribute(typeof(QueryByAttribute))]
[KnownTypeAttribute(typeof(FetchExpression))]
[DataContractAttribute(Name="QueryBase", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public abstract class QueryBase : IExtensibleDataObject

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Query.QueryBase

                Microsoft.Xrm.Sdk.Query.FetchExpression

                Microsoft.Xrm.Sdk.Query.QueryByAttribute

                Microsoft.Xrm.Sdk.Query.QueryExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryBase Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Build Queries with QueryExpression


QueryBase Members
See Also Methods Properties Constructors
[image]

Represents the abstract base class for constructing a query.

The following tables list the members exposed by the QueryBase type.

Protected Constructors

Name | Description
QueryBase | Initializes a new instance of the QueryBase class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QueryBase Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with QueryExpression


QueryBase Constructor
[image]

Initializes a new instance of the QueryBase class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected QueryBase ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryBase Class
QueryBase Members
Microsoft.Xrm.Sdk.Query Namespace


QueryBase Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QueryBase Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with QueryExpression


QueryBase Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

QueryBase Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with QueryExpression


QueryBase.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ExtensionData As ExtensionDataObject

C#
public ExtensionDataObject ExtensionData { get; set; }

C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryBase Class
QueryBase Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute Class
See Also Example Members
[image]

Contains a query that is expressed as a set of attribute and value pairs.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="QueryByAttribute", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<SuppressMessageAttribute("Microsoft.Naming", "CA1711:IdentifiersShouldNotHaveIncorrectSuffix", Justification:="Suffix is correct")> _
Public NotInheritable Class QueryByAttribute
    Inherits QueryBase

C#
[DataContractAttribute(Name="QueryByAttribute", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[SuppressMessageAttribute("Microsoft.Naming", "CA1711:IdentifiersShouldNotHaveIncorrectSuffix", Justification="Suffix is correct")]
public sealed class QueryByAttribute : QueryBase

C++

J#

JScript

  Example
C#    Copy Code
//  Create query using QueryByAttribute.
QueryByAttribute querybyattribute = new QueryByAttribute("account") {
   ColumnSet = new ColumnSet("name", "address1_city", "emailaddress1"),
   Attributes.AddRange("address1_city"),
   Values.AddRange("Redmond")
};

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Query.QueryBase
    Microsoft.Xrm.Sdk.Query.QueryByAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Build Queries with QueryExpression
Sample: Retrieve Multiple with Query By Attribute


QueryByAttribute Members
See Also Constructors Methods Properties
[image]

Contains a query that is expressed as a set of attribute and value pairs.

The following tables list the members exposed by the QueryByAttribute type.

Public Constructors

Name | Description
QueryByAttribute | Overloaded. Initializes a new instance of the QueryByAttribute class.
Top

Public Properties

 | Name | Description
public property | Attributes | Gets the set of attributes selected in the query.
public property | ColumnSet | Gets or sets the column set.
public property | EntityName | Gets or sets the logical name of the entity to query.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from QueryBase)
public property | Orders | Gets the order in which the entity instances are returned from the query.
public property | PageInfo | Gets or sets the number of pages and the number of entity instances per page returned from the query.
public property | TopCount | Gets or sets the number of rows to be returned.
public property | Values | Gets the attribute values to look for when the query is executed.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddAttributeValue | Adds an attribute value to the attributes collection.
public method | AddOrder | Adds an order to the orders collection.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QueryByAttribute Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with QueryExpression
Sample: Retrieve Multiple with Query By Attribute


QueryByAttribute Constructor
[image]

Initializes a new instance of the QueryByAttribute class.

Overload List

Name | Description
QueryByAttribute () | Initializes a new instance of the QueryByAttribute class.
QueryByAttribute (String) | Initializes a new instance of the QueryByAttribute class.

See Also

Reference

QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute Constructor ()
[image]

Initializes a new instance of the QueryByAttribute class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QueryByAttribute ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute Constructor (String)
[image]

Initializes a new instance of the QueryByAttribute class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String _
)

C#
public QueryByAttribute (
    string entityName
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity to query.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddAttributeValue | Adds an attribute value to the attributes collection.
public method | AddOrder | Adds an order to the orders collection.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QueryByAttribute Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with QueryExpression
Sample: Retrieve Multiple with Query By Attribute


QueryByAttribute.AddAttributeValue Method
[image]

Adds an attribute value to the attributes collection.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddAttributeValue ( _
    attributeName As String, _
    value As Object _
)

C#
public void AddAttributeValue (
    string attributeName,
    Object value
)

C++

J#

JScript

Parameters
attributeName
Type: String. The logical name of the attribute.
value
Type: Object. The attribute value.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute.AddOrder Method
[image]

Adds an order to the orders collection.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddOrder ( _
    attributeName As String, _
    orderType As OrderType _
)

C#
public void AddOrder (
    string attributeName,
    OrderType orderType
)

C++

J#

JScript

Parameters
attributeName
Type: String. The logical name of the attribute.
orderType
Type: OrderType. The order for that attribute.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute Properties
[image]

Public Properties

 | Name | Description
public property | Attributes | Gets the set of attributes selected in the query.
public property | ColumnSet | Gets or sets the column set.
public property | EntityName | Gets or sets the logical name of the entity to query.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from QueryBase)
public property | Orders | Gets the order in which the entity instances are returned from the query.
public property | PageInfo | Gets or sets the number of pages and the number of entity instances per page returned from the query.
public property | TopCount | Gets or sets the number of rows to be returned.
public property | Values | Gets the attribute values to look for when the query is executed.

See Also

Reference

QueryByAttribute Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with QueryExpression
Sample: Retrieve Multiple with Query By Attribute


QueryByAttribute.Attributes Property
[image]

Gets the set of attributes selected in the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Attributes As DataCollection(Of String)

C#
[DataMemberAttribute]
public DataCollection<string> Attributes { get; }

C++

J#

JScript

Property Value
Type: DataCollection<String>

The collection of attributes selected in the query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute.ColumnSet Property
[image]

Gets or sets the column set.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ColumnSet As ColumnSet

C#
[DataMemberAttribute]
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The set of columns (fields) to be returned, used Attributes collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute.EntityName Property
[image]

Gets or sets the logical name of the entity to query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityName As String

C#
[DataMemberAttribute]
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
IOrganizationService Entities


QueryByAttribute.Orders Property
[image]

Gets the order in which the entity instances are returned from the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Orders As DataCollection(Of OrderExpression)

C#
[DataMemberAttribute]
public DataCollection<OrderExpression> Orders { get; }

C++

J#

JScript

Property Value
Type: DataCollection<OrderExpression>
A collection that defines the order in which the entity instances are returned from the query.

  Remarks
Use AddOrder to add to this collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute.PageInfo Property
[image]

Gets or sets the number of pages and the number of entity instances per page returned from the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PageInfo As PagingInfo

C#
[DataMemberAttribute]
public PagingInfo PageInfo { get; set; }

C++

J#

JScript

Property Value
Type: PagingInfo
The number of pages and the number of entity instances per page returned from the query.

A query can contain either PageInfo or TopCount property values. If both are specified, an error will be thrown.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Using a Paging Cookie with Query Expression


QueryByAttribute.TopCount Property
See Also Example
[image]

Gets or sets the number of rows to be returned.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=50)> _
Public Property TopCount As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=50)]
public Nullable<int> TopCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of rows to be returned.

  Example
C#    Copy Code
public void TestQueryByAttributeWithTopCount()
{
         QueryByAttribute query = new QueryByAttribute();
         query.EntityName = "Account";
         query.ColumnSet = new Microsoft.Xrm.Sdk.Query.ColumnSet(new string[] { "name" });
         query.AddAttributeValue("address1_city", "seattle");
         query.TopCount = 3;
}

  Remarks
When specified, this limits the number rows returned in a query result set to the specified number of rows.
A query can contain either PageInfo or TopCount property values. If both are specified, an error will be thrown.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryByAttribute.Values Property
[image]

Gets the attribute values to look for when the query is executed.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Values As DataCollection(Of Object)

C#
[DataMemberAttribute]
public DataCollection<Object> Values { get; }

C++

J#

JScript

Property Value
Type: DataCollection<Object>
A collection that defines the attribute values to look for when the query is executed.

  Remarks
Use AddAttributeValue to add to this collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryByAttribute Class
QueryByAttribute Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression Class
See Also Example Members
[image]

Contains a complex query expressed in a hierarchy of expressions.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataContractAttribute(Name:="QueryExpression", Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class QueryExpression
    Inherits QueryBase

C#
[DataContractAttribute(Name="QueryExpression", Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class QueryExpression : QueryBase

C++

J#

JScript

  Example
C#    Copy Code
// Build the following SQL query using QueryExpression:
//
//        SELECT contact.fullname, contact.address1_telephone1
//        FROM contact
//            LEFT OUTER JOIN account
//                ON contact.parentcustomerid = account.accountid
//                AND
//                account.name = 'Litware, Inc.'
//        WHERE (contact.address1_stateorprovince = 'WA'
//        AND
//            contact.address1_city in ('Redmond', 'Bellevue', 'Kirkland', 'Seattle')
//        AND
//            contact.address1_telephone1 like '(206)%'
//            OR
//            contact.address1_telephone1 like '(425)%'
//        AND
//            DATEDIFF(DAY, contact.createdon, GETDATE()) > 0
//        AND
//            DATEDIFF(DAY, contact.createdon, GETDATE()) < 30
//        AND
//            contact.emailaddress1 Not NULL
//               )

String fetchXml = @"<fetch mapping=""logical"" count=""50"" version=""1.0"">
                        <entity name=""contact"">
                            <attribute name=""address1_telephone1"" />
                            <attribute name=""contactid"" />
                            <attribute name=""firstname"" />
                            <attribute name=""lastname"" />
                            <filter>
                                <condition attribute=""address1_stateorprovince"" operator=""eq"" value=""WA"" />
                                <condition attribute=""address1_city"" operator=""in"">
                                    <value>Redmond</value>
                                    <value>Bellevue</value>
                                    <value>Kirkland</value>
                                    <value>Seattle</value>
                                </condition>
                                <condition attribute=""createdon"" operator=""last-x-days"" value=""30"" />
                                <condition attribute=""emailaddress1"" operator=""not-null"" />
                                <filter type=""or"">
                                    <condition attribute=""address1_telephone1"" operator=""like"" value=""(206)%"" />
                                    <condition attribute=""address1_telephone1"" operator=""like"" value=""(425)%"" />
                                </filter>
                            </filter>
                            <link-entity name=""account"" from=""accountid"" to=""parentcustomerid"">
                                <filter>
                                    <condition attribute=""name"" operator=""eq"" value=""Litware, Inc."" />
                                </filter>
                            </link-entity>
                        </entity>
                    </fetch>";

// Build fetch request and obtain results.
RetrieveMultipleRequest efr = new RetrieveMultipleRequest()
{
    Query = new FetchExpression(fetchXml)
};

EntityCollection entityResults = ((RetrieveMultipleResponse)_service.Execute(efr)).EntityCollection;

// Display the results.
Console.WriteLine("List all contacts matching specified parameters");
Console.WriteLine("===============================================");
foreach (var e in entityResults.Entities)
{
    Console.WriteLine("Contact ID: {0}", e.Id);
}

Console.WriteLine("<End of Listing>");
Console.WriteLine();

C#    Copy Code
// Build the following SQL query using QueryExpression:
//
//        SELECT contact.fullname, contact.address1_telephone1
//        FROM contact
//            LEFT OUTER JOIN account
//                ON contact.parentcustomerid = account.accountid
//                AND
//                account.name = 'Litware, Inc.'
//        WHERE (contact.address1_stateorprovince = 'WA'
//        AND
//            contact.address1_city in ('Redmond', 'Bellevue', 'Kirkland', 'Seattle')
//        AND
//            contact.address1_telephone1 like '(206)%'
//            OR
//            contact.address1_telephone1 like '(425)%'
//        AND
//            DATEDIFF(DAY, contact.createdon, GETDATE()) > 0
//        AND
//            DATEDIFF(DAY, contact.createdon, GETDATE()) < 30
//        AND
//            contact.emailaddress1 Not NULL
//               )

QueryExpression query = new QueryExpression()
{
    Distinct = false,
    EntityName = Contact.EntityLogicalName,
    ColumnSet = new ColumnSet("fullname", "address1_telephone1"),
    LinkEntities =
    {
        new LinkEntity
        {
            JoinOperator = JoinOperator.LeftOuter,
            LinkFromAttributeName = "parentcustomerid",
            LinkFromEntityName = Contact.EntityLogicalName,
            LinkToAttributeName = "accountid",
            LinkToEntityName = Account.EntityLogicalName,
            LinkCriteria =
            {
                Conditions =
                {
                    new ConditionExpression("name", ConditionOperator.Equal, "Litware, Inc.")
                }
            }
        }
    },
    Criteria =
    {
        Filters =
        {
            new FilterExpression
            {
                FilterOperator = LogicalOperator.And,
                Conditions =
                {
                    new ConditionExpression("address1_stateorprovince", ConditionOperator.Equal, "WA"),
                    new ConditionExpression("address1_city", ConditionOperator.In, new String[] {"Redmond", "Bellevue" , "Kirkland", "Seattle"}),
                    new ConditionExpression("createdon", ConditionOperator.LastXDays, 30),
                    new ConditionExpression("emailaddress1", ConditionOperator.NotNull)
                },
            },
            new FilterExpression
            {
                FilterOperator = LogicalOperator.Or,
                Conditions =
                {
                    new ConditionExpression("address1_telephone1", ConditionOperator.Like, "(206)%"),
                    new ConditionExpression("address1_telephone1", ConditionOperator.Like, "(425)%")
                }
            }
        }
    }
};

DataCollection<Entity> entityCollection = _service.RetrieveMultiple(query).Entities;

// Display the results.
Console.WriteLine("List all contacts matching specified parameters");
Console.WriteLine("===============================================");
foreach (Contact contact in entityCollection)
{
    Console.WriteLine("Contact ID: {0}", contact.Id);
    Console.WriteLine("Contact Name: {0}", contact.FullName);
    Console.WriteLine("Contact Phone: {0}", contact.Address1_Telephone1);
}
Console.WriteLine("<End of Listing>");
Console.WriteLine();

  Remarks
A query expression can be expressed as FetchXML or as a hierarchy of expressions.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Query.QueryBase
    Microsoft.Xrm.Sdk.Query.QueryExpression
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  Change History
  See Also
Reference
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Build Queries with QueryExpression
Sample: Retrieve Multiple with Query Expression
Sample: Query Connection Roles by Entity Type Code (Early Bound)


QueryExpression Members
See Also Constructors Methods Properties
[image]

Contains a complex query expressed in a hierarchy of expressions.

The following tables list the members exposed by the QueryExpression type.

Public Constructors

Name | Description
QueryExpression | Overloaded. Initializes a new instance of the QueryExpression class.
Top

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the columns to include.
public property | Criteria | Gets or sets the complex condition and logical filter expressions that filter the results of the query.
public property | Distinct | Gets or sets whether the results of the query contain duplicate entity instances.
public property | EntityName | Gets or sets the logical name of the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from QueryBase)
public property | LinkEntities | Gets a collection of the links between multiple entity types.
public property | NoLock | Gets or sets a value that indicates that no shared locks are issued against the data that would prohibit other transactions from modifying the data in the records returned from the query.
public property | Orders | Gets the order in which the entity instances are returned from the query.
public property | PageInfo | Gets or sets the number of pages and the number of entity instances per page returned from the query.
public property | TopCount | Gets or sets the number of rows to be returned.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddLink | Overloaded. Adds the specified link to the query expression.
public method | AddOrder | Adds the specified order expression to the query expression.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

QueryExpression Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with QueryExpression
Sample: Retrieve Multiple with Query Expression
Sample: Query Connection Roles by Entity Type Code (Early Bound)


QueryExpression Constructor
[image]

Initializes a new instance of the QueryExpression class.

Overload List

Name | Description
QueryExpression () | Initializes a new instance of the QueryExpression class.
QueryExpression (String) | Initializes a new instance of the QueryExpression class setting the entity name.

See Also

Reference

QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression Constructor ()
[image]

Initializes a new instance of the QueryExpression class.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public QueryExpression ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression Constructor (String)
[image]

Initializes a new instance of the QueryExpression class setting the entity name.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String _
)

C#
public QueryExpression (
    string entityName
)

C++

J#

JScript

Parameters
entityName
Type: String. The name of the entity.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
IOrganizationService Entities


QueryExpression Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddLink | Overloaded. Adds the specified link to the query expression.
public method | AddOrder | Adds the specified order expression to the query expression.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

QueryExpression Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with QueryExpression
Sample: Retrieve Multiple with Query Expression
Sample: Query Connection Roles by Entity Type Code (Early Bound)


QueryExpression.AddLink Method
[image]

Adds the specified link to the query expression.

Overload List

Name | Description
QueryExpression.AddLink (String, String, String) | Adds the specified link to the query expression setting the entity name to link to, the attribute name to link from and the attribute name to link to.
QueryExpression.AddLink (String, String, String, JoinOperator) | Adds the specified link to the query expression setting the entity name to link to, the attribute name to link from and the attribute name to link to.

See Also

Reference

QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression.AddLink Method (String, String, String)
[image]

Adds the specified link to the query expression setting the entity name to link to, the attribute name to link from and the attribute name to link to.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function AddLink ( _
    linkToEntityName As String, _
    linkFromAttributeName As String, _
    linkToAttributeName As String _
) As LinkEntity

C#
public LinkEntity AddLink (
    string linkToEntityName,
    string linkFromAttributeName,
    string linkToAttributeName
)

C++

J#

JScript

Parameters
linkToEntityName
Type: String. The name of entity to link from.
linkFromAttributeName
Type: String. The name of the attribute to link from.
linkToAttributeName
Type: String. The name of the attribute to link to.
Return Value
Type: LinkEntity
The link entity instance created and added to the query expression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression.AddLink Method (String, String, String, JoinOperator)
[image]

Adds the specified link to the query expression setting the entity name to link to, the attribute name to link from and the attribute name to link to.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function AddLink ( _
    linkToEntityName As String, _
    linkFromAttributeName As String, _
    linkToAttributeName As String, _
    joinOperator As JoinOperator _
) As LinkEntity

C#
public LinkEntity AddLink (
    string linkToEntityName,
    string linkFromAttributeName,
    string linkToAttributeName,
    JoinOperator joinOperator
)

C++

J#

JScript

Parameters
linkToEntityName
Type: String. The name of entity to link from.
linkFromAttributeName
Type: String. The name of the attribute to link from.
linkToAttributeName
Type: String. The name of the attribute to link to.
joinOperator
Type: JoinOperator. The join operator.
Return Value
Type: LinkEntity
The link entity instance created and added to the query expression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression.AddOrder Method
[image]

Adds the specified order expression to the query expression.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AddOrder ( _
    attributeName As String, _
    orderType As OrderType _
)

C#
public void AddOrder (
    string attributeName,
    OrderType orderType
)

C++

J#

JScript

Parameters
attributeName
Type: String. The name of the attribute.
orderType
Type: OrderType. The order type.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression Properties
[image]

Public Properties

 | Name | Description
public property | ColumnSet | Gets or sets the columns to include.
public property | Criteria | Gets or sets the complex condition and logical filter expressions that filter the results of the query.
public property | Distinct | Gets or sets whether the results of the query contain duplicate entity instances.
public property | EntityName | Gets or sets the logical name of the entity.
public property | ExtensionData | Gets or sets the structure that contains extra data. (inherited from QueryBase)
public property | LinkEntities | Gets a collection of the links between multiple entity types.
public property | NoLock | Gets or sets a value that indicates that no shared locks are issued against the data that would prohibit other transactions from modifying the data in the records returned from the query.
public property | Orders | Gets the order in which the entity instances are returned from the query.
public property | PageInfo | Gets or sets the number of pages and the number of entity instances per page returned from the query.
public property | TopCount | Gets or sets the number of rows to be returned.

See Also

Reference

QueryExpression Class
Microsoft.Xrm.Sdk.Query Namespace

Other Resources

Build Queries with QueryExpression
Sample: Retrieve Multiple with Query Expression
Sample: Query Connection Roles by Entity Type Code (Early Bound)


QueryExpression.ColumnSet Property
[image]

Gets or sets the columns to include.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property ColumnSet As ColumnSet

C#
[DataMemberAttribute]
public ColumnSet ColumnSet { get; set; }

C++

J#

JScript

Property Value
Type: ColumnSet
The set of columns to return in the query results.

  Remarks
For more information, see ColumnSet.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression.Criteria Property
[image]

Gets or sets the complex condition and logical filter expressions that filter the results of the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Criteria As FilterExpression

C#
[DataMemberAttribute]
public FilterExpression Criteria { get; set; }

C++

J#

JScript

Property Value
Type: FilterExpression
The query condition and filter criteria.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression.Distinct Property
[image]

Gets or sets whether the results of the query contain duplicate entity instances.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Distinct As Boolean

C#
[DataMemberAttribute]
public bool Distinct { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the results of the query contain duplicate entity instances; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression.EntityName Property
[image]

Gets or sets the logical name of the entity.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property EntityName As String

C#
[DataMemberAttribute]
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String

The logical name of the primary entity for the query.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
IOrganizationService Entities


QueryExpression.LinkEntities Property
[image]

Gets a collection of the links between multiple entity types.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property LinkEntities As DataCollection(Of LinkEntity)

C#
[DataMemberAttribute]
public DataCollection<LinkEntity> LinkEntities { get; }

C++

J#

JScript

Property Value
Type: DataCollection<LinkEntity>
The collection of links between entities for the query.

  Remarks
This property is read-only. Use the AddLink(String,String,String) or AddLink(String,String,String,JoinOperator) method to change the contents of the array list.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression.NoLock Property
[image]

Gets or sets a value that indicates that no shared locks are issued against the data that would prohibit other transactions from modifying the data in the records returned from the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=50)> _
Public Property NoLock As Boolean

C#
[DataMemberAttribute(Order=50)]
public bool NoLock { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if there are no shared locks are issued against the data that would prohibit other transactions from modifying the data in the records returned from the query; otherwise, false.

  Remarks
The benefit of setting NoLock to true is that it allows you to keep the system from issuing locks against the entities in your queries; this increases concurrency and performance because the database engine does not have to maintain the shared locks involved. The downside is that, because no locks are issued against the records being read, some "dirty” or uncommitted data could potentially be read. A "dirty" read is one in which the data being read is involved in a transaction from another connection. If that transaction rolls back its work, the data read from the query using NoLock will have read uncommitted data. This type of read makes processing inconsistent and can lead to problems.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression.Orders Property
[image]

Gets the order in which the entity instances are returned from the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property Orders As DataCollection(Of OrderExpression)

C#
[DataMemberAttribute]
public DataCollection<OrderExpression> Orders { get; }

C++

J#

JScript

Property Value
Type: DataCollection<OrderExpression>
The order expression that defines the order in which the entity instances are returned from the query.

  Remarks
This property is read only. Use the AddOrder method to change the contents of the array list.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


QueryExpression.PageInfo Property
[image]

Gets or sets the number of pages and the number of entity instances per page returned from the query.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute> _
Public Property PageInfo As PagingInfo

C#
[DataMemberAttribute]
public PagingInfo PageInfo { get; set; }

C++

J#

JScript

Property Value
Type: PagingInfo
The number of pages and the number of entity instances per page returned from the query.

A query can contain either PageInfo or TopCount property values. If both are specified, an error will be thrown.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace
Other Resources
Page Large Result Sets with Query Expression and FetchXML


QueryExpression.TopCount Property
[image]

Gets or sets the number of rows to be returned.

Namespace: Microsoft.Xrm.Sdk.Query
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DataMemberAttribute(Order:=50, EmitDefaultValue:=False)> _
Public Property TopCount As Nullable(Of Integer)

C#
[DataMemberAttribute(Order=50, EmitDefaultValue=false)]
public Nullable<int> TopCount { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of rows to be returned.

  Remarks
When specified, this limits the number rows returned in a query result set to the specified number of rows.
A query can contain either PageInfo or TopCount property values. If both are specified, an error will be thrown.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
QueryExpression Class
QueryExpression Members
Microsoft.Xrm.Sdk.Query Namespace


Microsoft.Xrm.Sdk.WebServiceClient Namespace

Classes

Class | Description
DiscoveryWebProxyClient | Implements IDiscoveryService and provides an authenticated connection to the Discovery.svc/web endpoint. This /web endpoint is also used by web resources.
OrganizationWebProxyClient | Implements IOrganizationService and provides an authenticated connection to the Organization.svc/web endpoint. This /web endpoint is also used by web resources.
WebProxyClient | A base class that creates an authenticated web service endpoint on a WCF channel.
WebProxyClientContextInitializer | Ensures that the access token and other header values are added to every outbound service call.


DiscoveryWebProxyClient Class
See Also Members
[image]

Implements IDiscoveryService and provides an authenticated connection to the Discovery.svc/web endpoint. This /web endpoint is also used by web resources.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification:="This class need to be instantiated by clients and be able to derive from it.")> _
Public Class DiscoveryWebProxyClient
    Inherits WebProxyClient(Of IDiscoveryService)
    Implements IDiscoveryService

C#
[SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification="This class need to be instantiated by clients and be able to derive from it.")]
public class DiscoveryWebProxyClient : WebProxyClient<IDiscoveryService>, IDiscoveryService

C++

J#

JScript

  Remarks
You must set the HeaderToken and SdkClientVersion property values before using the proxy object to make service calls.
To call the Discovery web service using the IDiscoveryService interface, cast the proxy instance to an IDiscoveryService type.

  Inheritance Hierarchy
System.Object

                System.ServiceModel.ClientBase

                Microsoft.Xrm.Sdk.WebServiceClient.WebProxyClient
      Microsoft.Xrm.Sdk.WebServiceClient.DiscoveryWebProxyClient
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DiscoveryWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Discover the URL for Your Organization With IDiscoveryService Web Service
Authenticate the user with the web services


DiscoveryWebProxyClient Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Implements IDiscoveryService and provides an authenticated connection to the Discovery.svc/web endpoint. This /web endpoint is also used by web resources.

The following tables list the members exposed by the DiscoveryWebProxyClient type.

Public Constructors

Name | Description
DiscoveryWebProxyClient | Overloaded.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ChannelFactory | (inherited from ClientBase)
public property | ClientCredentials | (inherited from ClientBase)
public property | Endpoint | (inherited from ClientBase)
public property | HeaderToken | The access token returned from OAuth authentication. (inherited from WebProxyClient)
public property | InnerChannel | (inherited from ClientBase)
public property | SdkClientVersion | The version of your client application. (inherited from WebProxyClient)
public property | State | (inherited from ClientBase)
Top

Protected Properties

 | Name | Description
protected property | Channel | (inherited from ClientBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | (inherited from ClientBase)
public method | Close | (inherited from ClientBase)
public method | DisplayInitializationUI | (inherited from ClientBase)
public method | Dispose | Overloaded. (inherited from WebProxyClient)
public method | Equals | (inherited from Object)
public method | Execute |
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | (inherited from ClientBase)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CreateChannel | (inherited from ClientBase)
protected method | CreateNewInitializer | Overridden. Creates the WCF proxy client initializer which gets invoked on every SDK method call. This method makes sure that the access token and other header values are added to the outbound call.
protected method | Dispose | Overloaded. (inherited from WebProxyClient)
protected method | Finalize | Overridden. Destructor for the WebProxyClient class. (inherited from Object)
protected method | GetDefaultValueForInitialization | (inherited from ClientBase)
protected method | InvokeAsync | (inherited from ClientBase)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Dispose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
Close | (inherited from ClientBase)
EndClose | (inherited from ClientBase)
EndOpen | (inherited from ClientBase)
Open | (inherited from ClientBase)
Closed | (inherited from ClientBase)
Closing | (inherited from ClientBase)
Faulted | (inherited from ClientBase)
Opened | (inherited from ClientBase)
Opening | (inherited from ClientBase)
Top

See Also

Reference

DiscoveryWebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Authenticate the user with the web services


DiscoveryWebProxyClient Constructor
[image]

Overload List

Name | Description
DiscoveryWebProxyClient (Uri) | Initializes a new instance of theDiscoveryWebProxyClient class using a Discovery service URL.
DiscoveryWebProxyClient (Uri, TimeSpan) | Initializes a new instance of theDiscoveryWebProxyClient class using a Discovery service URL and a time span.

See Also

Reference

DiscoveryWebProxyClient Class
DiscoveryWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion

Other Resources

Discover the OAuth endpoint URL


DiscoveryWebProxyClient Constructor (Uri)
[image]

Initializes a new instance of the DiscoveryWebProxyClient class using a Discovery service URL.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceUrl As Uri _
)

C#
public DiscoveryWebProxyClient (
    Uri serviceUrl
)

C++

J#

JScript

Parameters
serviceUrl
The URL of the Discovery web service.
  Remarks
The URL must contain the SDK client version. For example:
https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc/web?SdkClientVersion=7.0.0.0

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DiscoveryWebProxyClient Class
DiscoveryWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion
Other Resources
Discover the OAuth endpoint URL


DiscoveryWebProxyClient Constructor (Uri, TimeSpan)
[image]

Initializes a new instance of the DiscoveryWebProxyClient class using a Discovery service URL and a time span.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceUrl As Uri, _
    timeout As TimeSpan _
)

C#
public DiscoveryWebProxyClient (
    Uri serviceUrl,
    TimeSpan timeout
)

C++

J#

JScript

Parameters
serviceUrl
The URL of the Discovery web service.
timeout
The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
  Remarks
The URL must contain the SDK client version. For example:
https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc/web?SdkClientVersion=7.0.0.0

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DiscoveryWebProxyClient Class
DiscoveryWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion
Other Resources
Discover the OAuth endpoint URL


DiscoveryWebProxyClient Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | (inherited from ClientBase)
public method | Close | (inherited from ClientBase)
public method | DisplayInitializationUI | (inherited from ClientBase)
public method | Dispose | Overloaded. (inherited from WebProxyClient)
public method | Equals | (inherited from Object)
public method | Execute |
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | (inherited from ClientBase)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | CreateChannel | (inherited from ClientBase)
protected method | CreateNewInitializer | Overridden. Creates the WCF proxy client initializer which gets invoked on every SDK method call. This method makes sure that the access token and other header values are added to the outbound call.
protected method | Dispose | Overloaded. (inherited from WebProxyClient)
protected method | Finalize | Overridden. Destructor for the WebProxyClient class. (inherited from Object)
protected method | GetDefaultValueForInitialization | (inherited from ClientBase)
protected method | InvokeAsync | (inherited from ClientBase)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
Dispose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
Close | (inherited from ClientBase)
EndClose | (inherited from ClientBase)
EndOpen | (inherited from ClientBase)
Open | (inherited from ClientBase)

See Also

Reference

DiscoveryWebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Authenticate the user with the web services


DiscoveryWebProxyClient.CreateNewInitializer Method
[image]

Creates the WCF proxy client initializer which gets invoked on every SDK method call. This method makes sure that the access token and other header values are added to the outbound call.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Function CreateNewInitializer As WebProxyClientContextInitializer(Of IDiscoveryService)

C#
protected override WebProxyClientContextInitializer<IDiscoveryService> CreateNewInitializer ()

C++

J#

JScript

Return Value
Type: WebProxyClientContextInitializer
A web proxy client context initializer.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DiscoveryWebProxyClient Class
DiscoveryWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


DiscoveryWebProxyClient.Execute Method
[image]

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Execute ( _
    request As DiscoveryRequest _
) As DiscoveryResponse

C#
public DiscoveryResponse Execute (
    DiscoveryRequest request
)

C++

J#

JScript

Parameters
request
A request instance that defines the action to be performed.
Return Value
Type: DiscoveryResponse
The response from processing the request. You must cast the return value of this method to the specific instance of the response that corresponds to the request parameter.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DiscoveryWebProxyClient Class
DiscoveryWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Discovery Service Messages (Request and Response Classes)


DiscoveryWebProxyClient.ExecuteCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Function ExecuteCore ( _
    request As DiscoveryRequest _
) As DiscoveryResponse

C#
protected internal virtual DiscoveryResponse ExecuteCore (
    DiscoveryRequest request
)

C++

J#

JScript

Parameters
request
Return Value
Type: DiscoveryResponse.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DiscoveryWebProxyClient Class
DiscoveryWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


DiscoveryWebProxyClient Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ChannelFactory | (inherited from ClientBase)
public property | ClientCredentials | (inherited from ClientBase)
public property | Endpoint | (inherited from ClientBase)
public property | HeaderToken | The access token returned from OAuth authentication. (inherited from WebProxyClient)
public property | InnerChannel | (inherited from ClientBase)
public property | SdkClientVersion | The version of your client application. (inherited from WebProxyClient)
public property | State | (inherited from ClientBase)

Protected Properties

 | Name | Description
protected property | Channel | (inherited from ClientBase)

See Also

Reference

DiscoveryWebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Authenticate the user with the web services


DiscoveryWebProxyClient Events
[image]

Explicit Interface Implementations

Name | Description
Closed | (inherited from ClientBase)
Closing | (inherited from ClientBase)
Faulted | (inherited from ClientBase)
Opened | (inherited from ClientBase)
Opening | (inherited from ClientBase)

See Also

Reference

DiscoveryWebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Discover the URL for Your Organization With IDiscoveryService Web Service
Authenticate the user with the web services


OrganizationWebProxyClient Class
See Also Members
[image]

Implements IOrganizationService and provides an authenticated connection to the Organization.svc/web endpoint. This /web endpoint is also used by web resources.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification:="This class need to be instantiated by clients and be able to derive from it.")> _
Public Class OrganizationWebProxyClient
    Inherits WebProxyClient(Of IOrganizationService)
    Implements IOrganizationService

C#
[SuppressMessageAttribute("Microsoft.Security", "CA9881:ClassesShouldBeSealed", Justification="This class need to be instantiated by clients and be able to derive from it.")]
public class OrganizationWebProxyClient : WebProxyClient<IOrganizationService>, IOrganizationService

C++

J#

JScript

  Remarks
You must set the HeaderToken and SdkClientVersion property values before using the proxy object to make service calls.
To call the Organization web service using the IOrganizationService interface, cast the proxy instance to an IOrganizationService type.

  Inheritance Hierarchy
System.Object

                System.ServiceModel.ClientBase

                Microsoft.Xrm.Sdk.WebServiceClient.WebProxyClient
      Microsoft.Xrm.Sdk.WebServiceClient.OrganizationWebProxyClient
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Use the IOrganizationService Web Service to Read and Write Data or Metadata
Authenticate the user with the web services


OrganizationWebProxyClient Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Implements IOrganizationService and provides an authenticated connection to the Organization.svc/web endpoint. This /web endpoint is also used by web resources.

The following tables list the members exposed by the OrganizationWebProxyClient type.

Public Constructors

Name | Description
OrganizationWebProxyClient | Overloaded.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | CallerId | Gets or sets the ID of the user for whom SDK calls are made on behalf of.
public property | ChannelFactory | (inherited from ClientBase)
public property | ClientCredentials | (inherited from ClientBase)
public property | Endpoint | (inherited from ClientBase)
public property | HeaderToken | The access token returned from OAuth authentication. (inherited from WebProxyClient)
public property | InnerChannel | (inherited from ClientBase)
public property | SdkClientVersion | The version of your client application. (inherited from WebProxyClient)
public property | State | (inherited from ClientBase)
public property | SyncOperationType | For internal use only.
Top

Protected Properties

 | Name | Description
protected property | Channel | (inherited from ClientBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | (inherited from ClientBase)
public method | Associate | Creates a link between records.
public method | Close | (inherited from ClientBase)
public method | Create | Creates a record.
public method | Delete | Deletes a record.
public method | Disassociate | Deletes a link between records.
public method | DisplayInitializationUI | (inherited from ClientBase)
public method | Dispose | Overloaded. (inherited from WebProxyClient)
public method | Equals | (inherited from Object)
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | (inherited from ClientBase)
public method | Retrieve | Retrieves a record.
public method | RetrieveMultiple | Retrieves a collection of records.
public method | ToString | (inherited from Object)
public method | Update | Updates an existing record.
Top

Protected Methods

 | Name | Description
protected method | CreateChannel | (inherited from ClientBase)
protected method | CreateNewInitializer | Overridden. Creates the WCF proxy client initializer which gets invoked on every SDK method call. This method makes sure that the access token and other header values are added to the outbound call.
protected method | Dispose | Overloaded. (inherited from WebProxyClient)
protected method | Finalize | Overridden. Destructor for the WebProxyClient class. (inherited from Object)
protected method | GetDefaultValueForInitialization | (inherited from ClientBase)
protected method | InvokeAsync | (inherited from ClientBase)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Dispose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
Close | (inherited from ClientBase)
EndClose | (inherited from ClientBase)
EndOpen | (inherited from ClientBase)
Open | (inherited from ClientBase)
Closed | (inherited from ClientBase)
Closing | (inherited from ClientBase)
Faulted | (inherited from ClientBase)
Opened | (inherited from ClientBase)
Opening | (inherited from ClientBase)
Top

See Also

Reference

OrganizationWebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Use the IOrganizationService Web Service to Read and Write Data or Metadata
Authenticate the user with the web services


OrganizationWebProxyClient Constructor
[image]

Overload List

Name | Description
OrganizationWebProxyClient (Uri, Boolean) | Initializes a new instance of theOrganizationWebProxyClient class using an Organization service URL.
OrganizationWebProxyClient (Uri, Assembly) | Initializes a new instance of theOrganizationWebProxyClient class using an Organization service URL and an assembly.
OrganizationWebProxyClient (Uri, TimeSpan, Boolean) | Initializes a new instance of theOrganizationWebProxyClient class using an Organization service URL and time span.
OrganizationWebProxyClient (Uri, TimeSpan, Assembly) | Initializes a new instance of theOrganizationWebProxyClient class using an Organization service URL, a time span, and an assembly.

See Also

Reference

OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


OrganizationWebProxyClient Constructor (Uri, Boolean)
[image]

Initializes a new instance of the OrganizationWebProxyClient class using an Organization service URL.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceUrl As Uri, _
    useStrongTypes As Boolean _
)

C#
public OrganizationWebProxyClient (
    Uri serviceUrl,
    bool useStrongTypes
)

C++

J#

JScript

Parameters
serviceUrl
Type: URI. The URL of the Organization web service.
useStrongTypes
Type: Boolean. When true, use early-bound types; otherwise, false.
  Remarks
The URL must contain the SDK client version. The client version is set to the version of the SDK assemblies that the client application was linked to. For example:
https://myorg.crm.dynamics.com/XRMServices/2011/Organization.svc/web?SdkClientVersion=7.0.0.0

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


OrganizationWebProxyClient Constructor (Uri, Assembly)
[image]

Initializes a new instance of the OrganizationWebProxyClient class using an Organization service URL and an assembly.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceUrl As Uri, _
    strongTypeAssembly As Assembly _
)

C#
public OrganizationWebProxyClient (
    Uri serviceUrl,
    Assembly strongTypeAssembly
)

C++

J#

JScript

Parameters
serviceUrl
Type: URI. The URL of the Organization web service.
strongTypeAssembly
Type: Assembly. An assembly containing early-bound types.
  Remarks
The URL must contain the SDK client version. The client version is set to the version of the SDK assemblies that the client application was linked to. For example:
https://myorg.crm.dynamics.com/XRMServices/2011/Organization.svc/web?SdkClientVersion=7.0.0.0

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


OrganizationWebProxyClient Constructor (Uri, TimeSpan, Boolean)
[image]

Initializes a new instance of the OrganizationWebProxyClient class using an Organization service URL and time span.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    serviceUrl As Uri, _
    timeout As TimeSpan, _
    useStrongTypes As Boolean _
)

C#
public OrganizationWebProxyClient (
    Uri serviceUrl,
    TimeSpan timeout,
    bool useStrongTypes
)

C++

J#

JScript

Parameters
serviceUrl
Type: URI. The URL of the Organization web service.
timeout
Type: TimeSpan. The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
useStrongTypes
Type: Boolean. When true, use early-bound types; otherwise, false.
  Remarks
The URL must contain the SDK client version. The client version is set to the version of the SDK assemblies that the client application was linked to. For example:
https://myorg.crm.dynamics.com/XRMServices/2011/Organization.svc/web?SdkClientVersion=7.0.0.0

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


OrganizationWebProxyClient Constructor (Uri, TimeSpan, Assembly)
[image]

Initializes a new instance of the OrganizationWebProxyClient class using an Organization service URL, a time span, and an assembly.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    uri As Uri, _
    timeout As TimeSpan, _
    strongTypeAssembly As Assembly _
)

C#
public OrganizationWebProxyClient (
    Uri uri,
    TimeSpan timeout,
    Assembly strongTypeAssembly
)

C++

J#

JScript

Parameters
uri
Type: URI. The URL of the Organization web service.
timeout
Type: TimeSpan. The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
strongTypeAssembly
Type: Assembly. An assembly containing early-bound types.
  Remarks
The URL must contain the SDK client version. The client version is set to the version of the SDK assemblies that the client application was linked to. For example:
https://myorg.crm.dynamics.com/XRMServices/2011/Organization.svc/web?SdkClientVersion=7.0.0.0

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


OrganizationWebProxyClient Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | (inherited from ClientBase)
public method | Associate | Creates a link between records.
public method | Close | (inherited from ClientBase)
public method | Create | Creates a record.
public method | Delete | Deletes a record.
public method | Disassociate | Deletes a link between records.
public method | DisplayInitializationUI | (inherited from ClientBase)
public method | Dispose | Overloaded. (inherited from WebProxyClient)
public method | Equals | (inherited from Object)
public method | Execute | Executes a message in the form of a request, and returns a response.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | (inherited from ClientBase)
public method | Retrieve | Retrieves a record.
public method | RetrieveMultiple | Retrieves a collection of records.
public method | ToString | (inherited from Object)
public method | Update | Updates an existing record.

Protected Methods

 | Name | Description
protected method | CreateChannel | (inherited from ClientBase)
protected method | CreateNewInitializer | Overridden. Creates the WCF proxy client initializer which gets invoked on every SDK method call. This method makes sure that the access token and other header values are added to the outbound call.
protected method | Dispose | Overloaded. (inherited from WebProxyClient)
protected method | Finalize | Overridden. Destructor for the WebProxyClient class. (inherited from Object)
protected method | GetDefaultValueForInitialization | (inherited from ClientBase)
protected method | InvokeAsync | (inherited from ClientBase)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
Dispose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
Close | (inherited from ClientBase)
EndClose | (inherited from ClientBase)
EndOpen | (inherited from ClientBase)
Open | (inherited from ClientBase)

See Also

Reference

OrganizationWebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Use the IOrganizationService Web Service to Read and Write Data or Metadata
Authenticate the user with the web services


OrganizationWebProxyClient.Associate Method
[image]

Creates a link between records.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Associate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
public void Associate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
entityId
Type: Guid. The ID of the record to which the related records will be associated.
relationship
Type: Relationship. The name of the relationship to be used to create the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be associated.
  Remarks
The core implementation of the Associate method. For more information, see IOrganizationService.Associate.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient.AssociateCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Sub AssociateCore ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
protected internal virtual void AssociateCore (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
entityId
relationship
relatedEntities
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient.Create Method
[image]

Creates a record.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Create ( _
    entity As Entity _
) As Guid

C#
public Guid Create (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that contains the properties to set in the newly created record.
Return Value
Type: Guid
The ID of the created entity.

  Remarks
The core implementation of the Create method. For more information, see IOrganizationService.Create.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationWebProxyClient.CreateCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Function CreateCore ( _
    entity As Entity _
) As Guid

C#
protected internal virtual Guid CreateCore (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Return Value
Returns Guid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient.CreateNewInitializer Method
[image]

Creates the WCF proxy client initializer which gets invoked on every SDK method call. This method makes sure that the access token and other header values are added to the outbound call.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Function CreateNewInitializer As WebProxyClientContextInitializer(Of IOrganizationService)

C#
protected override WebProxyClientContextInitializer<IOrganizationService> CreateNewInitializer ()

C++

J#

JScript

Return Value
Type: WebProxyClientContextInitializer
A web proxy client context initializer.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient.Delete Method
[image]

Deletes a record.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Delete ( _
    entityName As String, _
    id As Guid _
)

C#
public void Delete (
    string entityName,
    Guid id
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
id
Type: Guid. The ID of the record of the record to delete.
  Remarks
The core implementation of the Delete method. For more information, see IOrganizationService.Delete.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationWebProxyClient.DeleteCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Sub DeleteCore ( _
    entityName As String, _
    id As Guid _
)

C#
protected internal virtual void DeleteCore (
    string entityName,
    Guid id
)

C++

J#

JScript

Parameters
entityName
id
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient.Disassociate Method
[image]

Deletes a link between records.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Disassociate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
public void Disassociate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
entityId
Type: Guid. The ID of the record from which the related records will be disassociated.
relationship
Type: Relationship. The name of the relationship to be used to remove the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be disassociated.
  Remarks
The core implementation of the Disassociate method. For more information, see IOrganizationService.Disassociate.

                        For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationWebProxyClient.DisassociateCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Sub DisassociateCore ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)

C#
protected internal virtual void DisassociateCore (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)

C++

J#

JScript

Parameters
entityName
entityId
relationship
relatedEntities
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient.Execute Method
[image]

Executes a message in the form of a request, and returns a response.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Execute ( _
    request As OrganizationRequest _
) As OrganizationResponse

C#
public OrganizationResponse Execute (
    OrganizationRequest request
)

C++

J#

JScript

Parameters
request
Type: OrganizationRequest. An instance of a request class that defines the action to be performed.
Return Value
Type: OrganizationResponse.
You must cast the return value of this method to the specific instance of the response that corresponds to the Request parameter.

  Remarks
The core implementation of the Execute method. For more information, see IOrganizationService.Execute.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service
Use Messages (Request and Response Classes) with the Execute Method


OrganizationWebProxyClient.ExecuteCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Function ExecuteCore ( _
    request As OrganizationRequest _
) As OrganizationResponse

C#
protected internal virtual OrganizationResponse ExecuteCore (
    OrganizationRequest request
)

C++

J#

JScript

Parameters
request
Return Value
Returns OrganizationResponse.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient.Retrieve Method
[image]

Retrieves a record.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Retrieve ( _
    entityName As String, _
    id As Guid, _
    columnSet As ColumnSet _
) As Entity

C#
public Entity Retrieve (
    string entityName,
    Guid id,
    ColumnSet columnSet
)

C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
id
Type: Guid. The ID of the record you want to retrieve.
columnSet
Type: ColumnSet. A query that specifies the set of columns, or attributes, to retrieve.
Return Value
Type: Entity.
The requested entity.

  Remarks
The core implementation of the Retrieve method. For more information, see IOrganizationService.Retrieve.

                        For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationWebProxyClient.RetrieveCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Function RetrieveCore ( _
    entityName As String, _
    id As Guid, _
    columnSet As ColumnSet _
) As Entity

C#
protected internal virtual Entity RetrieveCore (
    string entityName,
    Guid id,
    ColumnSet columnSet
)

C++

J#

JScript

Parameters
entityName
id
columnSet
Return Value
Returns Entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient.RetrieveMultiple Method
[image]

Retrieves a collection of records.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function RetrieveMultiple ( _
    query As QueryBase _
) As EntityCollection

C#
public EntityCollection RetrieveMultiple (
    QueryBase query
)

C++

J#

JScript

Parameters
query
Type: QueryBase. A query that determines the set of records to retrieve.
Return Value
Type:  EntityCollection.
A collection of entity records.

  Remarks
The core implementation of the RetrieveMultiple method. For more information, see IOrganizationService.RetrieveMultiple.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service
Create Queries to Retrieve Data


OrganizationWebProxyClient.RetrieveMultipleCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Function RetrieveMultipleCore ( _
    query As QueryBase _
) As EntityCollection

C#
protected internal virtual EntityCollection RetrieveMultipleCore (
    QueryBase query
)

C++

J#

JScript

Parameters
query
Return Value
Returns EntityCollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient.Update Method
[image]

Updates an existing record.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Update ( _
    entity As Entity _
)

C#
public void Update (
    Entity entity
)

C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that has one or more properties set to be updated in the record.
  Remarks
The core implementation of the Update method. For more information, see IOrganizationService.Update.
For more information about the exceptions that can be thrown when calling OrganizationServiceProxy methods, see Handle Exceptions in Your Code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Troubleshooting and Error Handling
Read and Write Data and Metadata using the IOrganizationService Web Service


OrganizationWebProxyClient.UpdateCore Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Friend Overridable Sub UpdateCore ( _
    entity As Entity _
)

C#
protected internal virtual void UpdateCore (
    Entity entity
)

C++

J#

JScript

Parameters
entity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | CallerId | Gets or sets the ID of the user for whom SDK calls are made on behalf of.
public property | ChannelFactory | (inherited from ClientBase)
public property | ClientCredentials | (inherited from ClientBase)
public property | Endpoint | (inherited from ClientBase)
public property | HeaderToken | The access token returned from OAuth authentication. (inherited from WebProxyClient)
public property | InnerChannel | (inherited from ClientBase)
public property | SdkClientVersion | The version of your client application. (inherited from WebProxyClient)
public property | State | (inherited from ClientBase)
public property | SyncOperationType | For internal use only.

Protected Properties

 | Name | Description
protected property | Channel | (inherited from ClientBase)

See Also

Reference

OrganizationWebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Use the IOrganizationService Web Service to Read and Write Data or Metadata
Authenticate the user with the web services


OrganizationWebProxyClient.CallerId Property
[image]

Gets or sets the ID of the user for whom SDK calls are made on behalf of.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CallerId As Guid

C#
public Guid CallerId { get; set; }

C++

J#

JScript

Property Value
Type: Guid
The ID of the user for whom SDK calls are made on behalf of.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Impersonate Another User


OrganizationWebProxyClient.SyncOperationType Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SyncOperationType As String

C#
public string SyncOperationType { get; set; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationWebProxyClient Class
OrganizationWebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


OrganizationWebProxyClient Events
[image]

Explicit Interface Implementations

Name | Description
Closed | (inherited from ClientBase)
Closing | (inherited from ClientBase)
Faulted | (inherited from ClientBase)
Opened | (inherited from ClientBase)
Opening | (inherited from ClientBase)

See Also

Reference

OrganizationWebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Use the IOrganizationService Web Service to Read and Write Data or Metadata
Authenticate the user with the web services


WebProxyClient Generic Class
See Also Members
[image]

A base class that creates an authenticated web service endpoint on a WCF channel.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustInherit Class WebProxyClient(Of TService)
    Inherits ClientBase(Of TService)
    Implements IDisposable

C#
public abstract class WebProxyClient<TService> : ClientBase<TService>, IDisposable

C++

J#

JScript

GenericParameters
TService
A type of web service.
  Inheritance Hierarchy
System.Object

                System.ServiceModel.ClientBase
    Microsoft.Xrm.Sdk.WebServiceClient.WebProxyClient

                Microsoft.Xrm.Sdk.WebServiceClient.DiscoveryWebProxyClient

                Microsoft.Xrm.Sdk.WebServiceClient.OrganizationWebProxyClient
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
DiscoveryWebProxyClient
OrganizationWebProxyClient


WebProxyClient Members
See Also Methods Properties Constructors Explicit Interface Implementations
[image]

A base class that creates an authenticated web service endpoint on a WCF channel.

The following tables list the members exposed by the WebProxyClient type.

Protected Constructors

Name | Description
WebProxyClient | Overloaded.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ChannelFactory | (inherited from ClientBase)
public property | ClientCredentials | (inherited from ClientBase)
public property | Endpoint | (inherited from ClientBase)
public property | HeaderToken | The access token returned from OAuth authentication.
public property | InnerChannel | (inherited from ClientBase)
public property | SdkClientVersion | The version of your client application.
public property | State | (inherited from ClientBase)
Top

Protected Properties

 | Name | Description
protected property | Channel | (inherited from ClientBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | (inherited from ClientBase)
public method | Close | (inherited from ClientBase)
public method | DisplayInitializationUI | (inherited from ClientBase)
public method | Dispose | Overloaded.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | (inherited from ClientBase)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CreateChannel | (inherited from ClientBase)
protected method | CreateNewInitializer | Creates the WCF proxy client initializer which gets invoked on every SDK method call. This method makes sure that the access token and other header values are added to the outbound call.
 | CreateServiceEndpoint | Creates the service endpoint required for the proxy and adds support for early-bound types in the provided assembly.
protected method | Dispose | Overloaded.
protected method | Finalize | Overridden. Destructor for the WebProxyClient class.
 | GetBinding | Returns the default BasicHttpBinding that the proxy classes will use.
protected method | GetDefaultValueForInitialization | (inherited from ClientBase)
protected method | InvokeAsync | (inherited from ClientBase)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Dispose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
Close | (inherited from ClientBase)
EndClose | (inherited from ClientBase)
EndOpen | (inherited from ClientBase)
Open | (inherited from ClientBase)
Closed | (inherited from ClientBase)
Closing | (inherited from ClientBase)
Faulted | (inherited from ClientBase)
Opened | (inherited from ClientBase)
Opening | (inherited from ClientBase)
Top

See Also

Reference

WebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace
DiscoveryWebProxyClient
OrganizationWebProxyClient


WebProxyClient Constructor
[image]

Overload List

Name | Description
WebProxyClient (Uri, Boolean) | Initializes a new instance of theWebProxyClient class using an Organization service URL.
WebProxyClient (Uri, Assembly) | Initializes a new instance of theWebProxyClient class using an Organization service URL and an assembly.
WebProxyClient (Uri, TimeSpan, Boolean) | Initializes a new instance of theWebProxyClient class using an Organization service URL and time span.
WebProxyClient (Uri, TimeSpan, Assembly) | Initializes a new instance of theWebProxyClient class using an Organization service URL, a time span, and an assembly.

See Also

Reference

WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


WebProxyClient Constructor (Uri, Boolean)
[image]

Initializes a new instance of the WebProxyClient class using an Organization service URL.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    serviceUrl As Uri, _
    useStrongTypes As Boolean _
)

C#
protected WebProxyClient (
    Uri serviceUrl,
    bool useStrongTypes
)

C++

J#

JScript

Parameters
serviceUrl
Type: URI. The URL of the Organization web service.
useStrongTypes
Type: Boolean. When true, use early-bound types; otherwise, false.
  Remarks
The URL must contain the SDK client version. The client version is set to the version of the SDK assemblies that the client application was linked to. For example:
https://myorg.crm.dynamics.com/XRMServices/2011/Organization.svc/web?SdkClientVersion=7.0.0.0

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


WebProxyClient Constructor (Uri, Assembly)
[image]

Initializes a new instance of the WebProxyClient class using an Organization service URL and an assembly.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    serviceUrl As Uri, _
    strongTypeAssembly As Assembly _
)

C#
protected WebProxyClient (
    Uri serviceUrl,
    Assembly strongTypeAssembly
)

C++

J#

JScript

Parameters
serviceUrl
Type: URI. The URL of the Organization web service.
strongTypeAssembly
Type: Assembly. An assembly containing early-bound types.
  Remarks
The URL must contain the SDK client version. The client version is set to the version of the SDK assemblies that the client application was linked to. For example:
https://myorg.crm.dynamics.com/XRMServices/2011/Organization.svc/web?SdkClientVersion=7.0.0.0

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


WebProxyClient Constructor (Uri, TimeSpan, Boolean)
[image]

Initializes a new instance of the WebProxyClient class using an Organization service URL and time span.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    serviceUrl As Uri, _
    timeout As TimeSpan, _
    useStrongTypes As Boolean _
)

C#
protected WebProxyClient (
    Uri serviceUrl,
    TimeSpan timeout,
    bool useStrongTypes
)

C++

J#

JScript

Parameters
serviceUrl
Type: URI. The URL of the Organization web service.
timeout
Type: TimeSpan. The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
useStrongTypes
Type: Boolean. When true, use early-bound types; otherwise, false.
  Remarks
The URL must contain the SDK client version. The client version is set to the version of the SDK assemblies that the client application was linked to. For example:
https://myorg.crm.dynamics.com/XRMServices/2011/Organization.svc/web?SdkClientVersion=7.0.0.0
The timeout is passed to the SendTimeout, ReceiveTimeout, and OpenTimeout properties on the WCF channel binding.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


WebProxyClient Constructor (Uri, TimeSpan, Assembly)
[image]

Initializes a new instance of the WebProxyClient class using an Organization service URL, a time span, and an assembly.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    serviceUrl As Uri, _
    timeout As TimeSpan, _
    strongTypeAssembly As Assembly _
)

C#
protected WebProxyClient (
    Uri serviceUrl,
    TimeSpan timeout,
    Assembly strongTypeAssembly
)

C++

J#

JScript

Parameters
serviceUrl
Type: URI. The URL of the Organization web service.
timeout
Type: TimeSpan. The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
strongTypeAssembly
Type: Assembly. An assembly containing early-bound types.
  Remarks
The URL must contain the SDK client version. The client version is set to the version of the SDK assemblies that the client application was linked to. For example:
https://myorg.crm.dynamics.com/XRMServices/2011/Organization.svc/web?SdkClientVersion=7.0.0.0
The timeout is passed to the SendTimeout, ReceiveTimeout, and OpenTimeout properties on the WCF channel binding.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
SdkClientVersion


WebProxyClient Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Abort | (inherited from ClientBase)
public method | Close | (inherited from ClientBase)
public method | DisplayInitializationUI | (inherited from ClientBase)
public method | Dispose | Overloaded.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Open | (inherited from ClientBase)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | CreateChannel | (inherited from ClientBase)
protected method | CreateNewInitializer | Creates the WCF proxy client initializer which gets invoked on every SDK method call. This method makes sure that the access token and other header values are added to the outbound call.
 | CreateServiceEndpoint | Creates the service endpoint required for the proxy and adds support for early-bound types in the provided assembly.
protected method | Dispose | Overloaded.
protected method | Finalize | Overridden. Destructor for the WebProxyClient class.
 | GetBinding | Returns the default BasicHttpBinding that the proxy classes will use.
protected method | GetDefaultValueForInitialization | (inherited from ClientBase)
protected method | InvokeAsync | (inherited from ClientBase)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
Dispose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginClose | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
BeginOpen | (inherited from ClientBase)
Close | (inherited from ClientBase)
EndClose | (inherited from ClientBase)
EndOpen | (inherited from ClientBase)
Open | (inherited from ClientBase)

See Also

Reference

WebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace
DiscoveryWebProxyClient
OrganizationWebProxyClient


WebProxyClient.CreateNewInitializer Method
[image]

Creates the WCF proxy client initializer which gets invoked on every SDK method call. This method makes sure that the access token and other header values are added to the outbound call.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected MustOverride Function CreateNewInitializer As WebProxyClientContextInitializer(Of TService)

C#
protected abstract WebProxyClientContextInitializer<TService> CreateNewInitializer ()

C++

J#

JScript

Return Value
Type: WebProxyClientContextInitializer
A web proxy client context initializer.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClient.CreateServiceEndpoint Method
[image]

Creates the service endpoint required for the proxy and adds support for early-bound types in the provided assembly.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Shared Function CreateServiceEndpoint ( _
    serviceUrl As Uri, _
    useStrongTypes As Boolean, _
    timeout As TimeSpan, _
    strongTypeAssembly As Assembly _
) As ServiceEndpoint

C#
protected static ServiceEndpoint CreateServiceEndpoint (
    Uri serviceUrl,
    bool useStrongTypes,
    TimeSpan timeout,
    Assembly strongTypeAssembly
)

C++

J#

JScript

Parameters
serviceUrl
Type: URI. The URL of the web service.
useStrongTypes
Type: Boolean. When true, use early-bound types; otherwise, false.
timeout
Type: TimeSpan. The maximum amount of time a single channel operation has to complete before a timeout fault is raised on a service channel binding.
strongTypeAssembly
Type: Assembly. An assembly containing early-bound types.
Return Value
Type: ServiceEndpoint
A web service endpoint.

  Remarks
The timeout is passed to the SendTimeout, ReceiveTimeout, and OpenTimeout properties on the WCF channel binding.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClient.Dispose Method
[image]

Overload List

Name | Description
WebProxyClient.Dispose () | Disposes the web proxy client object.
WebProxyClient.Dispose (Boolean) | Disposes the web proxy client object.

See Also

Reference

WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Implementing a Dispose Method


WebProxyClient.Dispose Method ()
[image]

Disposes the web proxy client object.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Dispose

C#
public void Dispose ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Implementing a Dispose Method


WebProxyClient.Dispose Method (Boolean)
[image]

Disposes the web proxy client object.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

C#
protected virtual void Dispose (
    bool disposing
)

C++

J#

JScript

Parameters
disposing
Type: Boolean.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Implementing a Dispose Method


WebProxyClient.Finalize Method
[image]

Destructor for the WebProxyClient class.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Sub Finalize

C#
~WebProxyClient()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Object.Finalize Method


WebProxyClient.GetBinding Method
[image]

Returns the default BasicHttpBinding that the proxy classes will use.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Shared Function GetBinding ( _
    serviceUrl As Uri, _
    timeout As TimeSpan _
) As Binding

C#
protected static Binding GetBinding (
    Uri serviceUrl,
    TimeSpan timeout
)

C++

J#

JScript

Parameters
serviceUrl
Type: URI. The URL of the web service.
timeout
Type: TimeSpan. The maximum amount of time an operation has to complete before a timeout fault is raised on a service channel binding.
Return Value
Type: Binding
The WCF channel binding.

  Remarks
The timeout is passed to the SendTimeout, ReceiveTimeout, and OpenTimeout properties on the WCF channel binding.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClient Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ChannelFactory | (inherited from ClientBase)
public property | ClientCredentials | (inherited from ClientBase)
public property | Endpoint | (inherited from ClientBase)
public property | HeaderToken | The access token returned from OAuth authentication.
public property | InnerChannel | (inherited from ClientBase)
public property | SdkClientVersion | The version of your client application.
public property | State | (inherited from ClientBase)

Protected Properties

 | Name | Description
protected property | Channel | (inherited from ClientBase)

See Also

Reference

WebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace
DiscoveryWebProxyClient
OrganizationWebProxyClient


WebProxyClient.HeaderToken Property
[image]

The access token returned from OAuth authentication.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HeaderToken As String

C#
public string HeaderToken { get; set; }

C++

J#

JScript

Property Value
Type: String
Gets or sets the the access token.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Authenticate the user with the web services
Sample: Windows 8 desktop modern OData app
RFC 6749 - The OAuth 2.0 Authorization Framework
Azure Active Directory Authentication Libraries
Active Directory Authentication Library


WebProxyClient.SdkClientVersion Property
[image]

The version of your client application.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SdkClientVersion As String

C#
public string SdkClientVersion { get; set; }

C++

J#

JScript

Property Value
Type: String
The client application version.

  Remarks
The value can be any version number than has at least one decimal point and is greater than 6.0.0002.0000. It’s recommended that the property value be set to the product build version of the CRM SDK assemblies that were linked to the client application.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClient Class
WebProxyClient Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClient Events
[image]

Explicit Interface Implementations

Name | Description
Closed | (inherited from ClientBase)
Closing | (inherited from ClientBase)
Faulted | (inherited from ClientBase)
Opened | (inherited from ClientBase)
Opening | (inherited from ClientBase)

See Also

Reference

WebProxyClient Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace
DiscoveryWebProxyClient
OrganizationWebProxyClient


WebProxyClientContextInitializer Generic Class
See Also Members
[image]

Ensures that the access token and other header values are added to every outbound service call.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustInherit Class WebProxyClientContextInitializer(Of TService)
    Implements IDisposable

C#
public abstract class WebProxyClientContextInitializer<TService> : IDisposable

C++

J#

JScript

GenericParameters
TService
A web service.
  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.WebServiceClient.WebProxyClientContextInitializer
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClientContextInitializer Members
See Also Methods Properties Constructors
[image]

Ensures that the access token and other header values are added to every outbound service call.

The following tables list the members exposed by the WebProxyClientContextInitializer type.

Protected Constructors

Name | Description
WebProxyClientContextInitializer | Initializes a new instance of theWebProxyClientContextInitializer class using a web proxy client.
Top

Public Properties

 | Name | Description
public property | ServiceProxy | Gets the web proxy client for the service.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Dispose | Overloaded.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | AddCommonHeaders | Adds common and required headers to the outbound service call.
protected method | AddTokenToHeaders | Adds the access token to the Authorization header of the outbound service call.
protected method | Dispose | Overloaded.
protected method | Finalize | Overridden. Destructor for WebProxyClient objects.
protected method | Initialize | Initializes the WebProxyClientContextInitializer object using a client base object.
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WebProxyClientContextInitializer Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClientContextInitializer Constructor
[image]

Initializes a new instance of the WebProxyClientContextInitializer class using a web proxy client.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    proxy As WebProxyClient(Of TService) _
)

C#
protected WebProxyClientContextInitializer (
    WebProxyClient<TService> proxy
)

C++

J#

JScript

Parameters
proxy
Type: WebProxyClient<TService>. A web proxy client for a service.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClientContextInitializer Class
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClientContextInitializer Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Dispose | Overloaded.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | AddCommonHeaders | Adds common and required headers to the outbound service call.
protected method | AddTokenToHeaders | Adds the access token to the Authorization header of the outbound service call.
protected method | Dispose | Overloaded.
protected method | Finalize | Overridden. Destructor for WebProxyClient objects.
protected method | Initialize | Initializes the WebProxyClientContextInitializer object using a client base object.
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WebProxyClientContextInitializer Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClientContextInitializer.AddCommonHeaders Method
[image]

Adds common and required headers to the outbound service call.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub AddCommonHeaders

C#
protected void AddCommonHeaders ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClientContextInitializer Class
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClientContextInitializer.AddTokenToHeaders Method
[image]

Adds the access token to the Authorization header of the outbound service call.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub AddTokenToHeaders

C#
protected void AddTokenToHeaders ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClientContextInitializer Class
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClientContextInitializer.Dispose Method
[image]

Overload List

Name | Description
WebProxyClientContextInitializer.Dispose () | Disposes the web proxy client context initializer object.
WebProxyClientContextInitializer.Dispose (Boolean) | Disposes the web proxy client context initializer object.

See Also

Reference

WebProxyClientContextInitializer Class
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace

Other Resources

Implementing a Dispose Method


WebProxyClientContextInitializer.Dispose Method ()
[image]

Disposes the web proxy client context initializer object.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Dispose

C#
public void Dispose ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClientContextInitializer Class
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Implementing a Dispose Method


WebProxyClientContextInitializer.Dispose Method (Boolean)
[image]

Disposes the web proxy client context initializer object.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

C#
protected virtual void Dispose (
    bool disposing
)

C++

J#

JScript

Parameters
disposing
Type: Boolean.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClientContextInitializer Class
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Implementing a Dispose Method


WebProxyClientContextInitializer.Finalize Method
[image]

Destructor for WebProxyClient objects.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Sub Finalize

C#
~WebProxyClientContextInitializer()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClientContextInitializer Class
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace
Other Resources
Object.Finalize Method


WebProxyClientContextInitializer.Initialize Method
[image]

Initializes the WebProxyClientContextInitializer object using a client base object.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub Initialize ( _
    proxy As ClientBase(Of TService) _
)

C#
protected void Initialize (
    ClientBase<TService> proxy
)

C++

J#

JScript

Parameters
proxy
Type: ClientBase<TService>. A client base object.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClientContextInitializer Class
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClientContextInitializer Properties
[image]

Public Properties

 | Name | Description
public property | ServiceProxy | Gets the web proxy client for the service.

See Also

Reference

WebProxyClientContextInitializer Class
Microsoft.Xrm.Sdk.WebServiceClient Namespace


WebProxyClientContextInitializer.ServiceProxy Property
[image]

Gets the web proxy client for the service.

Namespace: Microsoft.Xrm.Sdk.WebServiceClient
Assembly: Microsoft.Xrm.Sdk (in Microsoft.Xrm.Sdk.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ServiceProxy As WebProxyClient(Of TService)

C#
public WebProxyClient<TService> ServiceProxy { get; }

C++

J#

JScript

Property Value
Type: WebProxyClient
The web proxy client for the service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
WebProxyClientContextInitializer Class
WebProxyClientContextInitializer Members
Microsoft.Xrm.Sdk.WebServiceClient Namespace


Microsoft.Xrm.Sdk.Workflow Namespace

Classes

Class | Description
ArgumentDescriptionAttribute | Specifies a description for the argument.
ArgumentDirectionAttribute | Specifies the direction, either input or output, for an action argument.
ArgumentEntityAttribute | Identifies the argument is an entity to be passed to the workflow at run-time.
ArgumentRequiredAttribute | Specifies that the argument is required.
ArgumentTargetAttribute | Identifies the argument is the primary entity for which the workflow is run.
AttributeDependency | Obsolete.
AttributeTargetAttribute | Contains a required attribute of a parameter picklist or status parameter types.
CustomEntityDependency | Obsolete.
DefaultAttribute | Specifies an optional default value that is assigned to a parameter.
EntityCreatedByDependency | Obsolete.
EntityDependencyBase | Obsolete.
InputAttribute | Specifies an input parameter.
LocalParameterDependency | Obsolete.
OutputAttribute | Specifies an output parameter.
ParameterAttribute | Specifies the abstract base class used for attributes.
ParameterDependencyBase | Obsolete.
PreImageDependency | Obsolete.
PrimaryEntityDependency | Obsolete.
ReferenceTargetAttribute | Specifies the required attribute of a parameter for lookup, customer or owner parameter types.
RelatedEntityDependency | Obsolete.
WaitSubscription | For internal use only.
WorkflowArgument | An argument to be passed to a workflow at run-time.
WorkflowDependencyType | Contains the integer flags to set the WorkflowDependency.Type attribute.
WorkflowStepActivityStatus | Contains values for the workflow step activity status.

Interfaces

Interface | Description
IStorageService | For internal use only.
IWaitNotificationService | For internal use only.
IWorkflowArgument | Represents an argument to be supplied to a workflow at run-time.
IWorkflowContext | Provides access to the data associated with the process instance.

Structures

Structure | Description
XrmTimeSpan | Represents a time interval.

Enumerations

Enumeration | Description
ArgumentDirection | Contains values for the argument data flow direction.
WorkflowPropertyType | Contains values for the property types supported by workflows.


ArgumentDescriptionAttribute Class
See Also Members
[image]

Specifies a description for the argument.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<AttributeUsageAttribute(AttributeTargets.All)> _
Public NotInheritable Class ArgumentDescriptionAttribute
    Inherits Attribute
    Implements IWorkflowArgument

C#
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets.All)]
public sealed class ArgumentDescriptionAttribute : Attribute, IWorkflowArgument

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Workflow.ArgumentDescriptionAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDescriptionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDescriptionAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Specifies a description for the argument.

The following tables list the members exposed by the ArgumentDescriptionAttribute type.

Public Constructors

Name | Description
ArgumentDescriptionAttribute | Overloaded. Initializes an instance of the ArgumentDescriptionAttribute class.
Top

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the description of the argument.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets or sets the argument’s description.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

ArgumentDescriptionAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDescriptionAttribute Constructor
[image]

Initializes an instance of the ArgumentDescriptionAttribute class.

Overload List

Name | Description
ArgumentDescriptionAttribute () | Initializes an instance of the ArgumentDescriptionAttribute class.
ArgumentDescriptionAttribute (String) | Initializes an instance of the ArgumentDescriptionAttribute class setting the Value property.

See Also

Reference

ArgumentDescriptionAttribute Class
ArgumentDescriptionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDescriptionAttribute Constructor ()
[image]

Initializes an instance of the ArgumentDescriptionAttribute class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ArgumentDescriptionAttribute ()

C++

J#

JScript

  Remarks
The Value property defaults to an empty string.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDescriptionAttribute Class
ArgumentDescriptionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDescriptionAttribute Constructor (String)
[image]

Initializes an instance of the ArgumentDescriptionAttribute class setting the Value property.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As String _
)

C#
public ArgumentDescriptionAttribute (
    string value
)

C++

J#

JScript

Parameters
value
Type: String. A description of the argument.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDescriptionAttribute Class
ArgumentDescriptionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDescriptionAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

ArgumentDescriptionAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDescriptionAttribute Properties
[image]

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the description of the argument.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets or sets the argument’s description.

See Also

Reference

ArgumentDescriptionAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDescriptionAttribute.ArgumentValue Property
[image]

Gets the description of the argument.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ArgumentValue As Object

C#
public Object ArgumentValue { get; }

C++

J#

JScript

Property Value
Type: Object
The description of the argument.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDescriptionAttribute Class
ArgumentDescriptionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDescriptionAttribute.Value Property
[image]

Gets or sets the argument’s description.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As String

C#
public string Value { get; set; }

C++

J#

JScript

Property Value
Type: String
The argument’s description.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDescriptionAttribute Class
ArgumentDescriptionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDirection Enumeration
[image]

Contains values for the argument data flow direction.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration ArgumentDirection

C#
public enum ArgumentDirection

C++

J#

JScript

  Members
Member name | Description
Input | Indicates the argument is a property of a message request.
Output | Indicates the argument is a property of a message response.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Create your own actions


ArgumentDirectionAttribute Class
See Also Members
[image]

Specifies the direction, either input or output, for an action argument.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<AttributeUsageAttribute(AttributeTargets.All)> _
Public NotInheritable Class ArgumentDirectionAttribute
    Inherits Attribute
    Implements IWorkflowArgument

C#
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets.All)]
public sealed class ArgumentDirectionAttribute : Attribute, IWorkflowArgument

C++

J#

JScript

  Remarks
An input argument becomes a custom property on the message request of an action. An output argument becomes a custom property on the message response of an action.

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Workflow.ArgumentDirectionAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDirectionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Create your own actions


ArgumentDirectionAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Specifies the direction, either input or output, for an action argument.

The following tables list the members exposed by the ArgumentDirectionAttribute type.

Public Constructors

Name | Description
ArgumentDirectionAttribute | Overloaded. Initializes an instance of the ArgumentDirectionAttribute class.
Top

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the argument’s value.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets or sets the data direction of a custom attribute for an action.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

ArgumentDirectionAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Create your own actions


ArgumentDirectionAttribute Constructor
[image]

Initializes an instance of the ArgumentDirectionAttribute class.

Overload List

Name | Description
ArgumentDirectionAttribute () |
ArgumentDirectionAttribute (ArgumentDirection) | Initializes an instance of the ArgumentDirectionAttribute class using an argument direction.

See Also

Reference

ArgumentDirectionAttribute Class
ArgumentDirectionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDirectionAttribute Constructor ()
[image]

Initializes a new instance of the ArgumentDirectionAttribute Class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ArgumentDirectionAttribute ()

C++

J#

JScript

  Remarks
Initializes an instance of the ArgumentDirectionAttribute class.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDirectionAttribute Class
ArgumentDirectionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDirectionAttribute Constructor (ArgumentDirection)
[image]

Initializes an instance of the ArgumentDirectionAttribute class using an argument direction.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As ArgumentDirection _
)

C#
public ArgumentDirectionAttribute (
    ArgumentDirection value
)

C++

J#

JScript

Parameters
value
Type: ArgumentDirection. The argument direction.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDirectionAttribute Class
ArgumentDirectionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDirectionAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

ArgumentDirectionAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Create your own actions


ArgumentDirectionAttribute Properties
[image]

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the argument’s value.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets or sets the data direction of a custom attribute for an action.

See Also

Reference

ArgumentDirectionAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Create your own actions


ArgumentDirectionAttribute.ArgumentValue Property
[image]

Gets the argument’s value.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ArgumentValue As Object

C#
public Object ArgumentValue { get; }

C++

J#

JScript

Property Value
Type: Object
The argument’s value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDirectionAttribute Class
ArgumentDirectionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentDirectionAttribute.Value Property
[image]

Gets or sets the data direction of a custom attribute for an action.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As ArgumentDirection

C#
public ArgumentDirection Value { get; set; }

C++

J#

JScript

Property Value
Type: ArgumentDirection
The data direction of a custom attribute. Value=0 (input), or 1 (output).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDirectionAttribute Class
ArgumentDirectionAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
ArgumentDirection


ArgumentEntityAttribute Class
See Also Members
[image]

Identifies the argument is an entity to be passed to the workflow at run-time.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<AttributeUsageAttribute(AttributeTargets.All)> _
Public NotInheritable Class ArgumentEntityAttribute
    Inherits Attribute
    Implements IWorkflowArgument

C#
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets.All)]
public sealed class ArgumentEntityAttribute : Attribute, IWorkflowArgument

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Workflow.ArgumentEntityAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentEntityAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentEntityAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Identifies the argument is an entity to be passed to the workflow at run-time.

The following tables list the members exposed by the ArgumentEntityAttribute type.

Public Constructors

Name | Description
ArgumentEntityAttribute | Overloaded. Initializes an instance of the ArgumentEntityAttribute class.
Top

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the entity value.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets or sets the entity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

ArgumentEntityAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentEntityAttribute Constructor
[image]

Initializes an instance of the ArgumentEntityAttribute class.

Overload List

Name | Description
ArgumentEntityAttribute () | Initializes an instance of the ArgumentEntityAttribute class.
ArgumentEntityAttribute (String) | Initializes an instance of the ArgumentEntityAttribute class with the provided serialized entity record value.

See Also

Reference

ArgumentEntityAttribute Class
ArgumentEntityAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentEntityAttribute Constructor ()
[image]

Initializes an instance of the ArgumentEntityAttribute class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ArgumentEntityAttribute ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentEntityAttribute Class
ArgumentEntityAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentEntityAttribute Constructor (String)
[image]

Initializes an instance of the ArgumentEntityAttribute class with the provided serialized entity record value.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As String _
)

C#
public ArgumentEntityAttribute (
    string value
)

C++

J#

JScript

Parameters
value
Type: String. The serialized entity record.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentEntityAttribute Class
ArgumentEntityAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentEntityAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

ArgumentEntityAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentEntityAttribute Properties
[image]

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the entity value.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets or sets the entity.

See Also

Reference

ArgumentEntityAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentEntityAttribute.ArgumentValue Property
[image]

Gets the entity value.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ArgumentValue As Object

C#
public Object ArgumentValue { get; }

C++

J#

JScript

Property Value
Type: Object
An entity that is passed to the workflow at run-time.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentEntityAttribute Class
ArgumentEntityAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentEntityAttribute.Value Property
[image]

Gets or sets the entity.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As String

C#
public string Value { get; set; }

C++

J#

JScript

Property Value
Type: String
The serialized entity record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentEntityAttribute Class
ArgumentEntityAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentRequiredAttribute Class
See Also Members
[image]

Specifies that the argument is required.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<AttributeUsageAttribute(AttributeTargets.All)> _
Public NotInheritable Class ArgumentRequiredAttribute
    Inherits Attribute
    Implements IWorkflowArgument

C#
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets.All)]
public sealed class ArgumentRequiredAttribute : Attribute, IWorkflowArgument

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Workflow.ArgumentRequiredAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentRequiredAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Create your own actions


ArgumentRequiredAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Specifies that the argument is required.

The following tables list the members exposed by the ArgumentRequiredAttribute type.

Public Constructors

Name | Description
ArgumentRequiredAttribute | Overloaded. Initializes an instance of the ArgumentRequiredAttribute class.
Top

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the argument value.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets or sets the argument value.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

ArgumentRequiredAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Create your own actions


ArgumentRequiredAttribute Constructor
[image]

Initializes an instance of the ArgumentRequiredAttribute class.

Overload List

Name | Description
ArgumentRequiredAttribute () | Initializes an instance of the ArgumentRequiredAttribute class.
ArgumentRequiredAttribute (Boolean) | Initializes an instance of the ArgumentRequiredAttribute class with the passed value.

See Also

Reference

ArgumentRequiredAttribute Class
ArgumentRequiredAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentRequiredAttribute Constructor ()
[image]

Initializes an instance of the ArgumentRequiredAttribute class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ArgumentRequiredAttribute ()

C++

J#

JScript

  Remarks
By default, the argument is not required.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentRequiredAttribute Class
ArgumentRequiredAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentRequiredAttribute Constructor (Boolean)
[image]

Initializes an instance of the ArgumentRequiredAttribute class with the passed value.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As Boolean _
)

C#
public ArgumentRequiredAttribute (
    bool value
)

C++

J#

JScript

Parameters
value
Type: Boolean. Set to true if the argument is required; otherwise, false
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentRequiredAttribute Class
ArgumentRequiredAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentRequiredAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

ArgumentRequiredAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Create your own actions


ArgumentRequiredAttribute Properties
[image]

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the argument value.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets or sets the argument value.

See Also

Reference

ArgumentRequiredAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Create your own actions


ArgumentRequiredAttribute.ArgumentValue Property
[image]

Gets the argument value.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ArgumentValue As Object

C#
public Object ArgumentValue { get; }

C++

J#

JScript

Property Value
Type: Object
The argument value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentRequiredAttribute Class
ArgumentRequiredAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentRequiredAttribute.Value Property
[image]

Gets or sets the argument value.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As Boolean

C#
public bool Value { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
True if the argument is required; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentRequiredAttribute Class
ArgumentRequiredAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentTargetAttribute Class
See Also Members
[image]

Identifies the argument is the primary entity for which the workflow is run.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<AttributeUsageAttribute(AttributeTargets.All)> _
Public NotInheritable Class ArgumentTargetAttribute
    Inherits Attribute
    Implements IWorkflowArgument

C#
[SerializableAttribute]
[AttributeUsageAttribute(AttributeTargets.All)]
public sealed class ArgumentTargetAttribute : Attribute, IWorkflowArgument

C++

J#

JScript

  Remarks
This attribute is automatically generated or added and is optional for global actions.

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Workflow.ArgumentTargetAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Create your own actions


ArgumentTargetAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Identifies the argument is the primary entity for which the workflow is run.

The following tables list the members exposed by the ArgumentTargetAttribute type.

Public Constructors

Name | Description
ArgumentTargetAttribute | Overloaded. Initializes an instance of the ArgumentTargetAttribute class.
Top

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the primary entity for which the workflow is run.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets a value indicating the argument is the primary entity for which the workflow is run.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

ArgumentTargetAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Create your own actions


ArgumentTargetAttribute Constructor
[image]

Initializes an instance of the ArgumentTargetAttribute class.

Overload List

Name | Description
ArgumentTargetAttribute () | Initializes an instance of the ArgumentTargetAttribute class.
ArgumentTargetAttribute (Boolean) | Initializes an instance of the ArgumentTargetAttribute class setting the Value property .

See Also

Reference

ArgumentTargetAttribute Class
ArgumentTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentTargetAttribute Constructor ()
[image]

Initializes an instance of the ArgumentTargetAttribute class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ArgumentTargetAttribute ()

C++

J#

JScript

  Remarks
The Value property is set to false by default.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentTargetAttribute Class
ArgumentTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentTargetAttribute Constructor (Boolean)
[image]

Initializes an instance of the ArgumentTargetAttribute class setting the Value property .

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As Boolean _
)

C#
public ArgumentTargetAttribute (
    bool value
)

C++

J#

JScript

Parameters
value
Type: Boolean. When true, the argument indicates the primary entity; otherwise, false
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentTargetAttribute Class
ArgumentTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentTargetAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

ArgumentTargetAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Create your own actions


ArgumentTargetAttribute Properties
[image]

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the primary entity for which the workflow is run.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets a value indicating the argument is the primary entity for which the workflow is run.

See Also

Reference

ArgumentTargetAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Create your own actions


ArgumentTargetAttribute.ArgumentValue Property
[image]

Gets the primary entity for which the workflow is run.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ArgumentValue As Object

C#
public Object ArgumentValue { get; }

C++

J#

JScript

Property Value
Type: Object
The primary entity for which the workflow is run.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentTargetAttribute Class
ArgumentTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ArgumentTargetAttribute.Value Property
[image]

Gets a value indicating the argument is the primary entity for which the workflow is run.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As Boolean

C#
public bool Value { get; set; }

C++

J#

JScript

Property Value
Type: BooleanWhen true, the argument is the primary entity for the workflow; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentTargetAttribute Class
ArgumentTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


AttributeDependency Class
See Also Members
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class AttributeDependency
    Inherits ParameterDependencyBase

C#
public sealed class AttributeDependency : ParameterDependencyBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Workflow.ParameterDependencyBase
    Microsoft.Xrm.Sdk.Workflow.AttributeDependency
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace
Microsoft.Xrm.Sdk.Workflow
Other Resources
Adding Metadata to the Custom Workflow Activity


AttributeDependency Members
See Also Constructors Methods Properties
[image]

Obsolete.

The following tables list the members exposed by the AttributeDependency type.

Public Constructors

Name | Description
AttributeDependency | Overloaded. Obsolete.
Top

Public Properties

 | Name | Description
public property | DependentAttributeName | Obsolete.
public property | DependentEntityName | Obsolete.
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AttributeDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace
Microsoft.Xrm.Sdk.Workflow

Other Resources

Adding Metadata to the Custom Workflow Activity


AttributeDependency Constructor
[image]

Obsolete.

Overload List

Name | Description
AttributeDependency () | Obsolete.
AttributeDependency (String, String, String) | Obsolete.

See Also

Reference

AttributeDependency Class
AttributeDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


AttributeDependency Constructor ()
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeDependency ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeDependency Class
AttributeDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


AttributeDependency Constructor (String, String, String)
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    parameterName As String, _
    dependentEntityName As String, _
    dependentAttributeName As String _
)

C#
public AttributeDependency (
    string parameterName,
    string dependentEntityName,
    string dependentAttributeName
)

C++

J#

JScript

Parameters
parameterName
Type: String
dependentEntityName
Type: String
dependentAttributeName
Type: String
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeDependency Class
AttributeDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


AttributeDependency Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AttributeDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace
Microsoft.Xrm.Sdk.Workflow

Other Resources

Adding Metadata to the Custom Workflow Activity


AttributeDependency Properties
[image]

Public Properties

 | Name | Description
public property | DependentAttributeName | Obsolete.
public property | DependentEntityName | Obsolete.
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete.

See Also

Reference

AttributeDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace
Microsoft.Xrm.Sdk.Workflow

Other Resources

Adding Metadata to the Custom Workflow Activity


AttributeDependency.DependentAttributeName Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property DependentAttributeName As String

C#
public string DependentAttributeName { get; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeDependency Class
AttributeDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


AttributeDependency.DependentEntityName Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property DependentEntityName As String

C#
public string DependentEntityName { get; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeDependency Class
AttributeDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


AttributeDependency.ParameterType Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides ReadOnly Property ParameterType As Type

C#
public override Type ParameterType { get; }

C++

J#

JScript

Property Value
Type: Type
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeDependency Class
AttributeDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


AttributeTargetAttribute Class
See Also Members
[image]

Contains a required attribute of a parameter picklist or status parameter types.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public NotInheritable Class AttributeTargetAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public sealed class AttributeTargetAttribute : Attribute

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Workflow.AttributeTargetAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Process Classes, Attributes, and Microsoft Dynamics CRM Types


AttributeTargetAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a required attribute of a parameter picklist or status parameter types.

The following tables list the members exposed by the AttributeTargetAttribute type.

Public Constructors

Name | Description
AttributeTargetAttribute | Initializes a new instance of the AttributeTargetAttribute class.
Top

Public Properties

 | Name | Description
public property | AttributeName | Gets the logical name of the target attribute.
public property | EntityName | Gets the logical name of the entity.
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

AttributeTargetAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


AttributeTargetAttribute Constructor
[image]

Initializes a new instance of the AttributeTargetAttribute class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String, _
    attributeName As String _
)

C#
public AttributeTargetAttribute (
    string entityName,
    string attributeName
)

C++

J#

JScript

Parameters
entityName
Specifies a String containing the logical name of the entity. See Remarks.
attributeName
Specifies a String containing the logical name of the attribute.
  Remarks
The name of an entity is always lowercase, for example, account or new_bankaccount.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTargetAttribute Class
AttributeTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


AttributeTargetAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

AttributeTargetAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


AttributeTargetAttribute Properties
[image]

Public Properties

 | Name | Description
public property | AttributeName | Gets the logical name of the target attribute.
public property | EntityName | Gets the logical name of the entity.
public property | TypeId | (inherited from Attribute)

See Also

Reference

AttributeTargetAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


AttributeTargetAttribute.AttributeName Property
[image]

Gets the logical name of the target attribute.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property AttributeName As String

C#
public string AttributeName { get; }

C++

J#

JScript

Property Value
Type: String
The logical name of the target attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTargetAttribute Class
AttributeTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


AttributeTargetAttribute.EntityName Property
[image]

Gets the logical name of the entity.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityName As String

C#
public string EntityName { get; }

C++

J#

JScript

Property Value
Type: String
The logical name of the entity.

  Remarks
The name of an entity is always lowercase, for example, account or new_bankaccount.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeTargetAttribute Class
AttributeTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


CustomEntityDependency Class
See Also Members
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CustomEntityDependency
    Inherits ParameterDependencyBase

C#
public sealed class CustomEntityDependency : ParameterDependencyBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Workflow.ParameterDependencyBase
    Microsoft.Xrm.Sdk.Workflow.CustomEntityDependency
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CustomEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


CustomEntityDependency Members
See Also Constructors Methods Properties
[image]

Obsolete.

The following tables list the members exposed by the CustomEntityDependency type.

Public Constructors

Name | Description
CustomEntityDependency | Overloaded. Obsolete.
Top

Public Properties

 | Name | Description
public property | CustomEntityName | Obsolete.
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CustomEntityDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


CustomEntityDependency Constructor
[image]

Obsolete.

Overload List

Name | Description
CustomEntityDependency () | Obsolete.
CustomEntityDependency (String, String) | Obsolete.

See Also

Reference

CustomEntityDependency Class
CustomEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


CustomEntityDependency Constructor ()
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CustomEntityDependency ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CustomEntityDependency Class
CustomEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


CustomEntityDependency Constructor (String, String)
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    parameterName As String, _
    customEntityName As String _
)

C#
public CustomEntityDependency (
    string parameterName,
    string customEntityName
)

C++

J#

JScript

Parameters
parameterName
Type: String.
customEntityName
Type: String.
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CustomEntityDependency Class
CustomEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


CustomEntityDependency Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CustomEntityDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


CustomEntityDependency Properties
[image]

Public Properties

 | Name | Description
public property | CustomEntityName | Obsolete.
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete.

See Also

Reference

CustomEntityDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


CustomEntityDependency.CustomEntityName Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CustomEntityName As String

C#
public string CustomEntityName { get; }

C++

J#

JScript

Property Value
Type: String .

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CustomEntityDependency Class
CustomEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


CustomEntityDependency.ParameterType Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides ReadOnly Property ParameterType As Type

C#
public override Type ParameterType { get; }

C++

J#

JScript

Property Value
Type: Type .

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CustomEntityDependency Class
CustomEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


DefaultAttribute Class
See Also Members
[image]

Specifies an optional default value that is assigned to a parameter.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public NotInheritable Class DefaultAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public sealed class DefaultAttribute : Attribute

C++

J#

JScript

  Remarks
This attribute is optional.

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Workflow.DefaultAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DefaultAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Process Classes, Attributes, and Microsoft Dynamics CRM Types


DefaultAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Specifies an optional default value that is assigned to a parameter.

The following tables list the members exposed by the DefaultAttribute type.

Public Constructors

Name | Description
DefaultAttribute | Overloaded. Initializes a new instance of the DefaultAttribute class.
Top

Public Properties

 | Name | Description
public property | EntityName | Gets the entity name for a value of type lookup, a customer or an owner.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets the default value.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

DefaultAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


DefaultAttribute Constructor
[image]

Initializes a new instance of the DefaultAttribute class.

Overload List

Name | Description
DefaultAttribute (String) | Initializes a new instance of the DefaultAttribute class setting the value property.
DefaultAttribute (String, String) | Initializes a new instance of the DefaultAttribute class setting the value and entity name properties.

See Also

Reference

DefaultAttribute Class
DefaultAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


DefaultAttribute Constructor (String)
[image]

Initializes a new instance of the DefaultAttribute class setting the value property.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As String _
)

C#
public DefaultAttribute (
    string value
)

C++

J#

JScript

Parameters
value
Type: String. Specifies a String containing the attribute value.
  Remarks
If the default value is for an attribute of type lookup, a customer or an owner, then you must use the DefaultAttribute Constructor (String, String) constructor and supply the entity name.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DefaultAttribute Class
DefaultAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


DefaultAttribute Constructor (String, String)
[image]

Initializes a new instance of the DefaultAttribute class setting the value and entity name properties.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As String, _
    entityName As String _
)

C#
public DefaultAttribute (
    string value,
    string entityName
)

C++

J#

JScript

Parameters
value
Type: String. Specifies a String containing the attribute value.
entityName
Type: String. Specifies a String containing the name of the entity.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DefaultAttribute Class
DefaultAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


DefaultAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

DefaultAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


DefaultAttribute Properties
[image]

Public Properties

 | Name | Description
public property | EntityName | Gets the entity name for a value of type lookup, a customer or an owner.
public property | TypeId | (inherited from Attribute)
public property | Value | Gets the default value.

See Also

Reference

DefaultAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


DefaultAttribute.EntityName Property
[image]

Gets the entity name for a value of type lookup, a customer or an owner.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityName As String

C#
public string EntityName { get; }

C++

J#

JScript

Property Value
Type: String
 The entity name for a value of type lookup, a customer or an owner.

  Remarks
The name of an entity is always lowercase, for example, account or new_bankaccount.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DefaultAttribute Class
DefaultAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


DefaultAttribute.Value Property
[image]

Gets the default value.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Value As String

C#
public string Value { get; }

C++

J#

JScript

Property Value
Type: String
 The default value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DefaultAttribute Class
DefaultAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityCreatedByDependency Class
See Also Members
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class EntityCreatedByDependency
    Inherits EntityDependencyBase

C#
public sealed class EntityCreatedByDependency : EntityDependencyBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Workflow.ParameterDependencyBase

                Microsoft.Xrm.Sdk.Workflow.EntityDependencyBase
      Microsoft.Xrm.Sdk.Workflow.EntityCreatedByDependency
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCreatedByDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityCreatedByDependency Members
See Also Constructors Methods Properties
[image]

Obsolete.

The following tables list the members exposed by the EntityCreatedByDependency type.

Public Constructors

Name | Description
EntityCreatedByDependency | Overloaded. Obsolete.
Top

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete. (inherited from EntityDependencyBase)
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete. (inherited from ParameterDependencyBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EntityCreatedByDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


EntityCreatedByDependency Constructor
[image]

Obsolete.

Overload List

Name | Description
EntityCreatedByDependency () | Obsolete.
EntityCreatedByDependency (String, String) | Obsolete.

See Also

Reference

EntityCreatedByDependency Class
EntityCreatedByDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityCreatedByDependency Constructor ()
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public EntityCreatedByDependency ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCreatedByDependency Class
EntityCreatedByDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityCreatedByDependency Constructor (String, String)
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    parameterName As String, _
    entityAttributes As String _
)

C#
public EntityCreatedByDependency (
    string parameterName,
    string entityAttributes
)

C++

J#

JScript

Parameters
parameterName
entityAttributes
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityCreatedByDependency Class
EntityCreatedByDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityCreatedByDependency Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EntityCreatedByDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


EntityCreatedByDependency Properties
[image]

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete. (inherited from EntityDependencyBase)
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete. (inherited from ParameterDependencyBase)

See Also

Reference

EntityCreatedByDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


EntityDependencyBase Class
See Also Members
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlIncludeAttribute(GetType(RelatedEntityDependency))> _
<XmlIncludeAttribute(GetType(EntityCreatedByDependency))> _
<XmlIncludeAttribute(GetType(PrimaryEntityDependency))> _
Public MustInherit Class EntityDependencyBase
    Inherits ParameterDependencyBase

C#
[XmlIncludeAttribute(typeof(RelatedEntityDependency))]
[XmlIncludeAttribute(typeof(EntityCreatedByDependency))]
[XmlIncludeAttribute(typeof(PrimaryEntityDependency))]
public abstract class EntityDependencyBase : ParameterDependencyBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Workflow.ParameterDependencyBase
    Microsoft.Xrm.Sdk.Workflow.EntityDependencyBase

                Microsoft.Xrm.Sdk.Workflow.EntityCreatedByDependency

                Microsoft.Xrm.Sdk.Workflow.PreImageDependency

                Microsoft.Xrm.Sdk.Workflow.PrimaryEntityDependency

                Microsoft.Xrm.Sdk.Workflow.RelatedEntityDependency
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityDependencyBase Members
See Also Methods Properties Constructors
[image]

Obsolete.

The following tables list the members exposed by the EntityDependencyBase type.

Protected Constructors

Name | Description
EntityDependencyBase | Overloaded. Obsolete.
Top

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete.
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

EntityDependencyBase Class
Microsoft.Xrm.Sdk.Workflow Namespace


EntityDependencyBase Constructor
[image]

Obsolete.

Overload List

Name | Description
EntityDependencyBase () | Obsolete.
EntityDependencyBase (String, String) | Obsolete.

See Also

Reference

EntityDependencyBase Class
EntityDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityDependencyBase Constructor ()
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected EntityDependencyBase ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityDependencyBase Class
EntityDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityDependencyBase Constructor (String, String)
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    parameterName As String, _
    entityAttributes As String _
)

C#
protected EntityDependencyBase (
    string parameterName,
    string entityAttributes
)

C++

J#

JScript

Parameters
parameterName
entityAttributes
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityDependencyBase Class
EntityDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityDependencyBase Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

EntityDependencyBase Class
Microsoft.Xrm.Sdk.Workflow Namespace


EntityDependencyBase Properties
[image]

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete.
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete.

See Also

Reference

EntityDependencyBase Class
Microsoft.Xrm.Sdk.Workflow Namespace


EntityDependencyBase.EntityAttributes Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityAttributes As String

C#
public string EntityAttributes { get; set; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityDependencyBase Class
EntityDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


EntityDependencyBase.ParameterType Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides ReadOnly Property ParameterType As Type

C#
public override Type ParameterType { get; }

C++

J#

JScript

Property Value
Returns Type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityDependencyBase Class
EntityDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


InputAttribute Class
See Also Members
[image]

Specifies an input parameter.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public NotInheritable Class InputAttribute
    Inherits ParameterAttribute

C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public sealed class InputAttribute : ParameterAttribute

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute

                Microsoft.Xrm.Sdk.Workflow.ParameterAttribute
      Microsoft.Xrm.Sdk.Workflow.InputAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Process Classes, Attributes, and Microsoft Dynamics CRM Types


InputAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Specifies an input parameter.

The following tables list the members exposed by the InputAttribute type.

Public Constructors

Name | Description
InputAttribute | Initializes a new instance of the InputAttribute class setting the name property.
Top

Public Properties

 | Name | Description
public property | Name | Gets the name of the parameter that will appear in the process designer UI. (inherited from ParameterAttribute)
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

InputAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


InputAttribute Constructor
[image]

Initializes a new instance of the InputAttribute class setting the name property.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    name As String _
)

C#
public InputAttribute (
    string name
)

C++

J#

JScript

Parameters
name
Type: String. Specifies a String containing the name of the parameter that will appears in the workflow designer UI.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InputAttribute Class
InputAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


InputAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

InputAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


InputAttribute Properties
[image]

Public Properties

 | Name | Description
public property | Name | Gets the name of the parameter that will appear in the process designer UI. (inherited from ParameterAttribute)
public property | TypeId | (inherited from Attribute)

See Also

Reference

InputAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


IStorageService Interface
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IStorageService

C#
public interface IStorageService

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IStorageService Members
Microsoft.Xrm.Sdk.Workflow Namespace


IStorageService Members
See Also Methods
[image]

For internal use only.

The following tables list the members exposed by the IStorageService type.

Public Methods

 | Name | Description
public method | RetrieveData | For internal use only.
public method | SaveData | For internal use only.
Top

See Also

Reference

IStorageService Interface
Microsoft.Xrm.Sdk.Workflow Namespace


IStorageService Methods
[image]

Public Methods

 | Name | Description
public method | RetrieveData | For internal use only.
public method | SaveData | For internal use only.

See Also

Reference

IStorageService Interface
Microsoft.Xrm.Sdk.Workflow Namespace


IStorageService.RetrieveData Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function RetrieveData ( _
    dataId As Guid _
) As Object

C#
Object RetrieveData (
    Guid dataId
)

C++

J#

JScript

Parameters
dataId
Type: Guid.
Return Value
Type: Object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IStorageService Interface
IStorageService Members
Microsoft.Xrm.Sdk.Workflow Namespace


IStorageService.SaveData Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function SaveData ( _
    dataId As Guid, _
    data As Object _
) As Guid

C#
Guid SaveData (
    Guid dataId,
    Object data
)

C++

J#

JScript

Parameters
dataId
Type: Guid.
data
Type: Object.
Return Value
Type: Guid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IStorageService Interface
IStorageService Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWaitNotificationService Interface
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IWaitNotificationService

C#
public interface IWaitNotificationService

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWaitNotificationService Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWaitNotificationService Members
See Also Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the IWaitNotificationService type.

Public Properties

 | Name | Description
public property | SubscriptionToRegister | For internal use only.
Top

Public Methods

 | Name | Description
public method | RegisterListener | For internal use only.
public method | UnregisterAllListeners | For internal use only.
public method | UnregisterListener | For internal use only.
Top

See Also

Reference

IWaitNotificationService Interface
Microsoft.Xrm.Sdk.Workflow Namespace


IWaitNotificationService Methods
[image]

Public Methods

 | Name | Description
public method | RegisterListener | For internal use only.
public method | UnregisterAllListeners | For internal use only.
public method | UnregisterListener | For internal use only.

See Also

Reference

IWaitNotificationService Interface
Microsoft.Xrm.Sdk.Workflow Namespace


IWaitNotificationService.RegisterListener Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function RegisterListener ( _
    queueId As Guid, _
    entityName As String, _
    entityId As Guid, _
    attributeName As String _
) As Guid

C#
Guid RegisterListener (
    Guid queueId,
    string entityName,
    Guid entityId,
    string attributeName
)

C++

J#

JScript

Parameters
queueId
Type: Guid.
entityName
Type: String.
entityId
Type: Guid.
attributeName
Type: String.
Return Value
Type: Guid .

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWaitNotificationService Interface
IWaitNotificationService Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWaitNotificationService.UnregisterAllListeners Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Sub UnregisterAllListeners

C#
void UnregisterAllListeners ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWaitNotificationService Interface
IWaitNotificationService Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWaitNotificationService.UnregisterListener Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Sub UnregisterListener ( _
    subscriptionId As Guid _
)

C#
void UnregisterListener (
    Guid subscriptionId
)

C++

J#

JScript

Parameters
subscriptionId
Type: Guid.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWaitNotificationService Interface
IWaitNotificationService Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWaitNotificationService Properties
[image]

Public Properties

 | Name | Description
public property | SubscriptionToRegister | For internal use only.

See Also

Reference

IWaitNotificationService Interface
Microsoft.Xrm.Sdk.Workflow Namespace


IWaitNotificationService.SubscriptionToRegister Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Property SubscriptionToRegister As WaitSubscription

C#
WaitSubscription SubscriptionToRegister { get; set; }

C++

J#

JScript

Property Value
Type: WaitSubscription.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWaitNotificationService Interface
IWaitNotificationService Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWorkflowArgument Interface
See Also Members
[image]

Represents an argument to be supplied to a workflow at run-time.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IWorkflowArgument

C#
public interface IWorkflowArgument

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWorkflowArgument Members
See Also Properties
[image]

Represents an argument to be supplied to a workflow at run-time.

The following tables list the members exposed by the IWorkflowArgument type.

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the argument’s value.
Top

See Also

Reference

IWorkflowArgument Interface
Microsoft.Xrm.Sdk.Workflow Namespace


IWorkflowArgument Properties
[image]

Public Properties

 | Name | Description
public property | ArgumentValue | Gets the argument’s value.

See Also

Reference

IWorkflowArgument Interface
Microsoft.Xrm.Sdk.Workflow Namespace


IWorkflowArgument.ArgumentValue Property
[image]

Gets the argument’s value.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property ArgumentValue As Object

C#
Object ArgumentValue { get; }

C++

J#

JScript

Property Value
Returns Object
The arguments value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWorkflowArgument Interface
IWorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWorkflowContext Interface
See Also Members
[image]

Provides access to the data associated with the process instance.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IWorkflowContext
    Inherits IExecutionContext

C#
public interface IWorkflowContext : IExecutionContext

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWorkflowContext Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Use the IOrganization Web Service in a Custom Workflow Activity
Sample: Azure Aware Custom Workflow Activity
Sample: Create a Custom Activity
Sample: Update Next Birthday Using a Custom Workflow Activity


IWorkflowContext Members
See Also Properties
[image]

Provides access to the data associated with the process instance.

The following tables list the members exposed by the IWorkflowContext type.

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the GUIDGUID of the business unit that the user making the request, also known as the calling user, belongs to. (inherited from IExecutionContext)
public property | CorrelationId | Gets the GUID for tracking plug-in or custom workflow activity execution. (inherited from IExecutionContext)
public property | Depth | Gets the current depth of execution in the call stack. (inherited from IExecutionContext)
public property | InitiatingUserId | Gets the GUID of the system user account under which the current pipeline is executing. (inherited from IExecutionContext)
public property | InputParameters | Gets the parameters of the request message that triggered the event that caused the plug-in to execute. (inherited from IExecutionContext)
public property | IsExecutingOffline | Gets whether the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline. (inherited from IExecutionContext)
public property | IsInTransaction | Gets a value indicating if the plug-in is executing within the database transaction. (inherited from IExecutionContext)
public property | IsOfflinePlayback | Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server. (inherited from IExecutionContext)
public property | IsolationMode | Gets a value indicating if the plug-in is executing in the sandbox. (inherited from IExecutionContext)
public property | MessageName | Gets the name of the Web service message that is being processed by the event execution pipeline. (inherited from IExecutionContext)
public property | Mode | Gets the mode of plug-in execution. (inherited from IExecutionContext)
public property | OperationCreatedOn | Gets the date and time that the related System Job was created. (inherited from IExecutionContext)
public property | OperationId | Gets the GUID of the related System Job. (inherited from IExecutionContext)
public property | OrganizationId | Gets the GUID of the organization that the entity belongs to and the plug-in executes under. (inherited from IExecutionContext)
public property | OrganizationName | Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under. (inherited from IExecutionContext)
public property | OutputParameters | Gets the parameters of the response message after the core platform operation has completed. (inherited from IExecutionContext)
public property | OwningExtension | Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint. (inherited from IExecutionContext)
public property | ParentContext | Gets the parent context.
public property | PostEntityImages | Gets the properties of the primary entity after the core platform operation has been completed. (inherited from IExecutionContext)
public property | PreEntityImages | Gets the properties of the primary entity before the core platform operation has begins. (inherited from IExecutionContext)
public property | PrimaryEntityId | Gets the GUID of the primary entity for which the pipeline is processing events. (inherited from IExecutionContext)
public property | PrimaryEntityName | Gets the name of the primary entity for which the pipeline is processing events. (inherited from IExecutionContext)
public property | RequestId | Gets the GUID of the request being processed by the event execution pipeline. (inherited from IExecutionContext)
public property | SecondaryEntityName | Gets the name of the secondary entity that has a relationship with the primary entity. (inherited from IExecutionContext)
public property | SharedVariables | Gets the custom properties that are shared between plug-ins. (inherited from IExecutionContext)
public property | StageName | Gets the stage information of the process instance.
public property | UserId | Gets the GUID of the system user for whom the plug-in invokes web service methods on behalf of. (inherited from IExecutionContext)
public property | WorkflowCategory | Gets the process category information of the process instance: workflow or dialog.
public property | WorkflowMode | Indicates how the workflow is to be executed.
Top

See Also

Reference

IWorkflowContext Interface
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Use the IOrganization Web Service in a Custom Workflow Activity
Sample: Azure Aware Custom Workflow Activity
Sample: Create a Custom Activity
Sample: Update Next Birthday Using a Custom Workflow Activity


IWorkflowContext Properties
[image]

Public Properties

 | Name | Description
public property | BusinessUnitId | Gets the GUIDGUID of the business unit that the user making the request, also known as the calling user, belongs to. (inherited from IExecutionContext)
public property | CorrelationId | Gets the GUID for tracking plug-in or custom workflow activity execution. (inherited from IExecutionContext)
public property | Depth | Gets the current depth of execution in the call stack. (inherited from IExecutionContext)
public property | InitiatingUserId | Gets the GUID of the system user account under which the current pipeline is executing. (inherited from IExecutionContext)
public property | InputParameters | Gets the parameters of the request message that triggered the event that caused the plug-in to execute. (inherited from IExecutionContext)
public property | IsExecutingOffline | Gets whether the plug-in is executing from the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client while it is offline. (inherited from IExecutionContext)
public property | IsInTransaction | Gets a value indicating if the plug-in is executing within the database transaction. (inherited from IExecutionContext)
public property | IsOfflinePlayback | Gets a value indicating if the plug-in is executing as a result of the Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access client transitioning from offline to online and synchronizing with the Microsoft Dynamics CRM server. (inherited from IExecutionContext)
public property | IsolationMode | Gets a value indicating if the plug-in is executing in the sandbox. (inherited from IExecutionContext)
public property | MessageName | Gets the name of the Web service message that is being processed by the event execution pipeline. (inherited from IExecutionContext)
public property | Mode | Gets the mode of plug-in execution. (inherited from IExecutionContext)
public property | OperationCreatedOn | Gets the date and time that the related System Job was created. (inherited from IExecutionContext)
public property | OperationId | Gets the GUID of the related System Job. (inherited from IExecutionContext)
public property | OrganizationId | Gets the GUID of the organization that the entity belongs to and the plug-in executes under. (inherited from IExecutionContext)
public property | OrganizationName | Gets the unique name of the organization that the entity currently being processed belongs to and the plug-in executes under. (inherited from IExecutionContext)
public property | OutputParameters | Gets the parameters of the response message after the core platform operation has completed. (inherited from IExecutionContext)
public property | OwningExtension | Gets a reference to the related SdkMessageProcessingingStep or ServiceEndpoint. (inherited from IExecutionContext)
public property | ParentContext | Gets the parent context.
public property | PostEntityImages | Gets the properties of the primary entity after the core platform operation has been completed. (inherited from IExecutionContext)
public property | PreEntityImages | Gets the properties of the primary entity before the core platform operation has begins. (inherited from IExecutionContext)
public property | PrimaryEntityId | Gets the GUID of the primary entity for which the pipeline is processing events. (inherited from IExecutionContext)
public property | PrimaryEntityName | Gets the name of the primary entity for which the pipeline is processing events. (inherited from IExecutionContext)
public property | RequestId | Gets the GUID of the request being processed by the event execution pipeline. (inherited from IExecutionContext)
public property | SecondaryEntityName | Gets the name of the secondary entity that has a relationship with the primary entity. (inherited from IExecutionContext)
public property | SharedVariables | Gets the custom properties that are shared between plug-ins. (inherited from IExecutionContext)
public property | StageName | Gets the stage information of the process instance.
public property | UserId | Gets the GUID of the system user for whom the plug-in invokes web service methods on behalf of. (inherited from IExecutionContext)
public property | WorkflowCategory | Gets the process category information of the process instance: workflow or dialog.
public property | WorkflowMode | Indicates how the workflow is to be executed.

See Also

Reference

IWorkflowContext Interface
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Use the IOrganization Web Service in a Custom Workflow Activity
Sample: Azure Aware Custom Workflow Activity
Sample: Create a Custom Activity
Sample: Update Next Birthday Using a Custom Workflow Activity


IWorkflowContext.ParentContext Property
[image]

Gets the parent context.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property ParentContext As IWorkflowContext

C#
IWorkflowContext ParentContext { get; }

C++

J#

JScript

Property Value
Type:  IWorkflowContext
The parent context.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWorkflowContext Interface
IWorkflowContext Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWorkflowContext.StageName Property
[image]

Gets the stage information of the process instance.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property StageName As String

C#
string StageName { get; }

C++

J#

JScript

Property Value
Type: String
The stage information of the process instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWorkflowContext Interface
IWorkflowContext Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWorkflowContext.WorkflowCategory Property
[image]

Gets the process category information of the process instance: workflow or dialog.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property WorkflowCategory As Integer

C#
int WorkflowCategory { get; }

C++

J#

JScript

Property Value
Type: Int32
 The process category information of the process instance: workflow or dialog.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWorkflowContext Interface
IWorkflowContext Members
Microsoft.Xrm.Sdk.Workflow Namespace


IWorkflowContext.WorkflowMode Property
[image]

Indicates how the workflow is to be executed.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property WorkflowMode As Integer

C#
int WorkflowMode { get; }

C++

J#

JScript

Property Value
Type: Int32
Value = 0 (background/asynchronous), 1 (real-time).

  Remarks
This property is obsolete.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IWorkflowContext Interface
IWorkflowContext Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Create real-time workflows


LocalParameterDependency Class
See Also Members
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class LocalParameterDependency
    Inherits ParameterDependencyBase

C#
public sealed class LocalParameterDependency : ParameterDependencyBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Workflow.ParameterDependencyBase
    Microsoft.Xrm.Sdk.Workflow.LocalParameterDependency
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalParameterDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


LocalParameterDependency Members
See Also Constructors Methods Properties
[image]

Obsolete.

The following tables list the members exposed by the LocalParameterDependency type.

Public Constructors

Name | Description
LocalParameterDependency | Obsolete.
Top

Public Properties

 | Name | Description
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LocalParameterDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


LocalParameterDependency Constructor
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    parameterName As String, _
    parameterType As Type _
)

C#
public LocalParameterDependency (
    string parameterName,
    Type parameterType
)

C++

J#

JScript

Parameters
parameterName
Type: String.
parameterType
Type: Type.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalParameterDependency Class
LocalParameterDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


LocalParameterDependency Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LocalParameterDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


LocalParameterDependency Properties
[image]

Public Properties

 | Name | Description
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete.

See Also

Reference

LocalParameterDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


LocalParameterDependency.ParameterType Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides ReadOnly Property ParameterType As Type

C#
public override Type ParameterType { get; }

C++

J#

JScript

Property Value
Type: Type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LocalParameterDependency Class
LocalParameterDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


OutputAttribute Class
See Also Members
[image]

Specifies an output parameter.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public NotInheritable Class OutputAttribute
    Inherits ParameterAttribute

C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public sealed class OutputAttribute : ParameterAttribute

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute

                Microsoft.Xrm.Sdk.Workflow.ParameterAttribute
      Microsoft.Xrm.Sdk.Workflow.OutputAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OutputAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Process Classes, Attributes, and Microsoft Dynamics CRM Types


OutputAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Specifies an output parameter.

The following tables list the members exposed by the OutputAttribute type.

Public Constructors

Name | Description
OutputAttribute | Initializes a new instance of the OutputAttribute class.
Top

Public Properties

 | Name | Description
public property | Name | Gets the name of the parameter that will appear in the process designer UI. (inherited from ParameterAttribute)
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

OutputAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


OutputAttribute Constructor
[image]

Initializes a new instance of the OutputAttribute class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    name As String _
)

C#
public OutputAttribute (
    string name
)

C++

J#

JScript

Parameters
name
Type: String. Specifies a String containing the name of the parameter that will appears in the process designer UI.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OutputAttribute Class
OutputAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


OutputAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

OutputAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


OutputAttribute Properties
[image]

Public Properties

 | Name | Description
public property | Name | Gets the name of the parameter that will appear in the process designer UI. (inherited from ParameterAttribute)
public property | TypeId | (inherited from Attribute)

See Also

Reference

OutputAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


ParameterAttribute Class
See Also Members
[image]

Specifies the abstract base class used for attributes.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public MustInherit Class ParameterAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public abstract class ParameterAttribute : Attribute

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Workflow.ParameterAttribute

                Microsoft.Xrm.Sdk.Workflow.InputAttribute

                Microsoft.Xrm.Sdk.Workflow.OutputAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Process Classes, Attributes, and Microsoft Dynamics CRM Types


ParameterAttribute Members
See Also Methods Properties Constructors Explicit Interface Implementations
[image]

Specifies the abstract base class used for attributes.

The following tables list the members exposed by the ParameterAttribute type.

Protected Constructors

Name | Description
ParameterAttribute | Initializes a new instance of the ParameterAttribute class.
Top

Public Properties

 | Name | Description
public property | Name | Gets the name of the parameter that will appear in the process designer UI.
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

ParameterAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


ParameterAttribute Constructor
[image]

Initializes a new instance of the ParameterAttribute class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    name As String _
)

C#
protected ParameterAttribute (
    string name
)

C++

J#

JScript

Parameters
name
Type: String. The name of the parameter that will appear in the process designer UI.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterAttribute Class
ParameterAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

ParameterAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


ParameterAttribute Properties
[image]

Public Properties

 | Name | Description
public property | Name | Gets the name of the parameter that will appear in the process designer UI.
public property | TypeId | (inherited from Attribute)

See Also

Reference

ParameterAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


ParameterAttribute.Name Property
[image]

Gets the name of the parameter that will appear in the process designer UI.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Name As String

C#
public string Name { get; }

C++

J#

JScript

Property Value
Type: String
 The name of the parameter that will appear in the process designer UI.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterAttribute Class
ParameterAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterDependencyBase Class
See Also Members
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustInherit Class ParameterDependencyBase

C#
public abstract class ParameterDependencyBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Workflow.ParameterDependencyBase

                Microsoft.Xrm.Sdk.Workflow.AttributeDependency

                Microsoft.Xrm.Sdk.Workflow.CustomEntityDependency

                Microsoft.Xrm.Sdk.Workflow.EntityDependencyBase

                Microsoft.Xrm.Sdk.Workflow.LocalParameterDependency
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterDependencyBase Members
See Also Methods Properties Constructors
[image]

Obsolete.

The following tables list the members exposed by the ParameterDependencyBase type.

Protected Constructors

Name | Description
ParameterDependencyBase | Overloaded. Obsolete.
Top

Public Properties

 | Name | Description
public property | ParameterName | Obsolete.
public property | ParameterType | Obsolete.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ParameterDependencyBase Class
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterDependencyBase Constructor
[image]

Obsolete.

Overload List

Name | Description
ParameterDependencyBase () | Obsolete.
ParameterDependencyBase (String) | Obsolete.

See Also

Reference

ParameterDependencyBase Class
ParameterDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterDependencyBase Constructor ()
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected ParameterDependencyBase ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterDependencyBase Class
ParameterDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterDependencyBase Constructor (String)
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New ( _
    parameterName As String _
)

C#
protected ParameterDependencyBase (
    string parameterName
)

C++

J#

JScript

Parameters
parameterName
Type: String.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterDependencyBase Class
ParameterDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterDependencyBase Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ParameterDependencyBase Class
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterDependencyBase Properties
[image]

Public Properties

 | Name | Description
public property | ParameterName | Obsolete.
public property | ParameterType | Obsolete.

See Also

Reference

ParameterDependencyBase Class
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterDependencyBase.ParameterName Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ParameterName As String

C#
public string ParameterName { get; set; }

C++

J#

JScript

Property Value
Type: String .

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterDependencyBase Class
ParameterDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


ParameterDependencyBase.ParameterType Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride ReadOnly Property ParameterType As Type

C#
public abstract Type ParameterType { get; }

C++

J#

JScript

Property Value
Type: Type .

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ParameterDependencyBase Class
ParameterDependencyBase Members
Microsoft.Xrm.Sdk.Workflow Namespace


PreImageDependency Class
See Also Members
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class PreImageDependency
    Inherits EntityDependencyBase

C#
public sealed class PreImageDependency : EntityDependencyBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Workflow.ParameterDependencyBase

                Microsoft.Xrm.Sdk.Workflow.EntityDependencyBase
      Microsoft.Xrm.Sdk.Workflow.PreImageDependency
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PreImageDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


PreImageDependency Members
See Also Constructors Methods Properties
[image]

Obsolete.

The following tables list the members exposed by the PreImageDependency type.

Public Constructors

Name | Description
PreImageDependency | Overloaded. Obsolete.
Top

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete. (inherited from EntityDependencyBase)
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete. (inherited from ParameterDependencyBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PreImageDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


PreImageDependency Constructor
[image]

Obsolete.

Overload List

Name | Description
PreImageDependency () | Obsolete.
PreImageDependency (String, String) | Obsolete.

See Also

Reference

PreImageDependency Class
PreImageDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


PreImageDependency Constructor ()
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PreImageDependency ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PreImageDependency Class
PreImageDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


PreImageDependency Constructor (String, String)
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    parameterName As String, _
    entityAttributes As String _
)

C#
public PreImageDependency (
    string parameterName,
    string entityAttributes
)

C++

J#

JScript

Parameters
parameterName
Type: String.
entityAttributes
Type: String.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PreImageDependency Class
PreImageDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


PreImageDependency Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PreImageDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


PreImageDependency Properties
[image]

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete. (inherited from EntityDependencyBase)
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete. (inherited from ParameterDependencyBase)

See Also

Reference

PreImageDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace


PrimaryEntityDependency Class
See Also Members
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class PrimaryEntityDependency
    Inherits EntityDependencyBase

C#
public sealed class PrimaryEntityDependency : EntityDependencyBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Workflow.ParameterDependencyBase

                Microsoft.Xrm.Sdk.Workflow.EntityDependencyBase
      Microsoft.Xrm.Sdk.Workflow.PrimaryEntityDependency
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PrimaryEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Adding Metadata to the Custom Workflow Activity


PrimaryEntityDependency Members
See Also Constructors Methods Properties
[image]

Obsolete.

The following tables list the members exposed by the PrimaryEntityDependency type.

Public Constructors

Name | Description
PrimaryEntityDependency | Overloaded. Obsolete.
Top

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete. (inherited from EntityDependencyBase)
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete. (inherited from ParameterDependencyBase)
public property | Type | Obsolete.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PrimaryEntityDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Adding Metadata to the Custom Workflow Activity


PrimaryEntityDependency Constructor
[image]

Obsolete.

Overload List

Name | Description
PrimaryEntityDependency () | Obsolete.
PrimaryEntityDependency (String, String, Int32) | Obsolete.

See Also

Reference

PrimaryEntityDependency Class
PrimaryEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


PrimaryEntityDependency Constructor ()
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PrimaryEntityDependency ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PrimaryEntityDependency Class
PrimaryEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


PrimaryEntityDependency Constructor (String, String, Int32)
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    parameterName As String, _
    entityAttributes As String, _
    type As Integer _
)

C#
public PrimaryEntityDependency (
    string parameterName,
    string entityAttributes,
    int type
)

C++

J#

JScript

Parameters
parameterName
Type: String.
entityAttributes
Type: String.
type
Type: Int32.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PrimaryEntityDependency Class
PrimaryEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


PrimaryEntityDependency Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PrimaryEntityDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Adding Metadata to the Custom Workflow Activity


PrimaryEntityDependency Properties
[image]

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete. (inherited from EntityDependencyBase)
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete. (inherited from ParameterDependencyBase)
public property | Type | Obsolete.

See Also

Reference

PrimaryEntityDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Adding Metadata to the Custom Workflow Activity


PrimaryEntityDependency.Type Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Type As Integer

C#
public int Type { get; set; }

C++

J#

JScript

Property Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
PrimaryEntityDependency Class
PrimaryEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


ReferenceTargetAttribute Class
See Also Members
[image]

Specifies the required attribute of a parameter for lookup, customer or owner parameter types.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public NotInheritable Class ReferenceTargetAttribute
    Inherits Attribute

C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public sealed class ReferenceTargetAttribute : Attribute

C++

J#

JScript

  Remarks
Note that only a single instance of this attribute can be added.

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Sdk.Workflow.ReferenceTargetAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Process Classes, Attributes, and Microsoft Dynamics CRM Types


ReferenceTargetAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Specifies the required attribute of a parameter for lookup, customer or owner parameter types.

The following tables list the members exposed by the ReferenceTargetAttribute type.

Public Constructors

Name | Description
ReferenceTargetAttribute | Initializes a new instance of the ReferenceTargetAttribute class.
Top

Public Properties

 | Name | Description
public property | EntityName | Gets the name of the entity for the attribute.
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

ReferenceTargetAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


ReferenceTargetAttribute Constructor
[image]

Initializes a new instance of the ReferenceTargetAttribute class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String _
)

C#
public ReferenceTargetAttribute (
    string entityName
)

C++

J#

JScript

Parameters
entityName
Type: String. Specifies a String containing the name of the entity.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceTargetAttribute Class
ReferenceTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


ReferenceTargetAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

ReferenceTargetAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


ReferenceTargetAttribute Properties
[image]

Public Properties

 | Name | Description
public property | EntityName | Gets the name of the entity for the attribute.
public property | TypeId | (inherited from Attribute)

See Also

Reference

ReferenceTargetAttribute Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Process Classes, Attributes, and Microsoft Dynamics CRM Types


ReferenceTargetAttribute.EntityName Property
[image]

Gets the name of the entity for the attribute.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property EntityName As String

C#
public string EntityName { get; }

C++

J#

JScript

Property Value
Type: String
 The name of the entity for the attribute.

  Remarks
The name of an entity is always lowercase, for example, account or new_bankaccount. For system entity names, you can use the EntityNameenumeration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceTargetAttribute Class
ReferenceTargetAttribute Members
Microsoft.Xrm.Sdk.Workflow Namespace


RelatedEntityDependency Class
See Also Members
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class RelatedEntityDependency
    Inherits EntityDependencyBase

C#
public sealed class RelatedEntityDependency : EntityDependencyBase

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Workflow.ParameterDependencyBase

                Microsoft.Xrm.Sdk.Workflow.EntityDependencyBase
      Microsoft.Xrm.Sdk.Workflow.RelatedEntityDependency
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelatedEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Adding Metadata to the Custom Workflow Activity


RelatedEntityDependency Members
See Also Constructors Methods Properties
[image]

Obsolete.

The following tables list the members exposed by the RelatedEntityDependency type.

Public Constructors

Name | Description
RelatedEntityDependency | Overloaded. Obsolete.
Top

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete. (inherited from EntityDependencyBase)
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete. (inherited from ParameterDependencyBase)
public property | RelatedAttributeName | Obsolete.
public property | RelatedEntityName | Obsolete.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RelatedEntityDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Adding Metadata to the Custom Workflow Activity


RelatedEntityDependency Constructor
[image]

Obsolete.

Overload List

Name | Description
RelatedEntityDependency () | Obsolete.
RelatedEntityDependency (String, String, String, String) | Obsolete.

See Also

Reference

RelatedEntityDependency Class
RelatedEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


RelatedEntityDependency Constructor ()
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RelatedEntityDependency ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelatedEntityDependency Class
RelatedEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


RelatedEntityDependency Constructor (String, String, String, String)
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    parameterName As String, _
    entityAttributes As String, _
    relatedAttributeName As String, _
    relatedEntityName As String _
)

C#
public RelatedEntityDependency (
    string parameterName,
    string entityAttributes,
    string relatedAttributeName,
    string relatedEntityName
)

C++

J#

JScript

Parameters
parameterName
Type: String.
entityAttributes
Type: String.
relatedAttributeName
Type: String.
relatedEntityName
Type: String.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelatedEntityDependency Class
RelatedEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


RelatedEntityDependency Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RelatedEntityDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Adding Metadata to the Custom Workflow Activity


RelatedEntityDependency Properties
[image]

Public Properties

 | Name | Description
public property | EntityAttributes | Obsolete. (inherited from EntityDependencyBase)
public property | ParameterName | Obsolete. (inherited from ParameterDependencyBase)
public property | ParameterType | Overridden. Obsolete. (inherited from ParameterDependencyBase)
public property | RelatedAttributeName | Obsolete.
public property | RelatedEntityName | Obsolete.

See Also

Reference

RelatedEntityDependency Class
Microsoft.Xrm.Sdk.Workflow Namespace

Other Resources

Adding Metadata to the Custom Workflow Activity


RelatedEntityDependency.RelatedAttributeName Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RelatedAttributeName As String

C#
public string RelatedAttributeName { get; set; }

C++

J#

JScript

Property Value
Type: String .

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelatedEntityDependency Class
RelatedEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


RelatedEntityDependency.RelatedEntityName Property
[image]

Obsolete.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RelatedEntityName As String

C#
public string RelatedEntityName { get; set; }

C++

J#

JScript

Property Value
Type: String .

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelatedEntityDependency Class
RelatedEntityDependency Members
Microsoft.Xrm.Sdk.Workflow Namespace


WaitSubscription Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class WaitSubscription

C#
public sealed class WaitSubscription

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Workflow.WaitSubscription
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WaitSubscription Members
Microsoft.Xrm.Sdk.Workflow Namespace


WaitSubscription Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the WaitSubscription type.

Public Constructors

Name | Description
WaitSubscription | Initializes a new instance of theWaitSubscription class.
Top

Public Properties

 | Name | Description
public property | AttributeName | For internal use only.
public property | EntityId | For internal use only.
public property | EntityName | For internal use only.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WaitSubscription Class
Microsoft.Xrm.Sdk.Workflow Namespace


WaitSubscription Constructor
[image]

Initializes a new instance of the WaitSubscription class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    entityName As String, _
    entityId As Guid, _
    attributeName As String _
)

C#
public WaitSubscription (
    string entityName,
    Guid entityId,
    string attributeName
)

C++

J#

JScript

Parameters
entityName
Type: String.
entityId
Type: Guid.
attributeName
Type: String.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WaitSubscription Class
WaitSubscription Members
Microsoft.Xrm.Sdk.Workflow Namespace


WaitSubscription Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WaitSubscription Class
Microsoft.Xrm.Sdk.Workflow Namespace


WaitSubscription Properties
[image]

Public Properties

 | Name | Description
public property | AttributeName | For internal use only.
public property | EntityId | For internal use only.
public property | EntityName | For internal use only.

See Also

Reference

WaitSubscription Class
Microsoft.Xrm.Sdk.Workflow Namespace


WaitSubscription.AttributeName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeName As String

C#
public string AttributeName { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WaitSubscription Class
WaitSubscription Members
Microsoft.Xrm.Sdk.Workflow Namespace


WaitSubscription.EntityId Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityId As Guid

C#
public Guid EntityId { get; set; }

C++

J#

JScript

Property Value
Type: Guid .

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WaitSubscription Class
WaitSubscription Members
Microsoft.Xrm.Sdk.Workflow Namespace


WaitSubscription.EntityName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WaitSubscription Class
WaitSubscription Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument Class
See Also Members
[image]

An argument to be passed to a workflow at run-time.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class WorkflowArgument

C#
[SerializableAttribute]
public sealed class WorkflowArgument

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Workflow.WorkflowArgument
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument Members
See Also Constructors Methods Properties
[image]

An argument to be passed to a workflow at run-time.

The following tables list the members exposed by the WorkflowArgument type.

Public Constructors

Name | Description
WorkflowArgument | Initializes an instance of the WorkflowArgument class.
Top

Public Properties

 | Name | Description
public property | ArgumentType | Gets or sets the data type of the workflow argument.
public property | ContainerType | Gets or sets the collection type that can contain the workflow argument.
public property | Description | Gets or sets a description of the workflow argument.
public property | Direction | Gets or sets the data direction of the workflow argument.
public property | EntityName | Gets or sets the logical name of the primary entity that the workflow is executing for.
public property | Name | Gets or sets a name for the workflow argument.
public property | Required | Gets or sets if the workflow argument is required.
public property | Target | Gets or sets whether the argument is the primary entity being supplied to the workflow.
public property | Value | Gets or sets the value of the workflow argument.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

WorkflowArgument Class
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument Constructor
[image]

Initializes an instance of the WorkflowArgument class.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WorkflowArgument ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

WorkflowArgument Class
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument Properties
[image]

Public Properties

 | Name | Description
public property | ArgumentType | Gets or sets the data type of the workflow argument.
public property | ContainerType | Gets or sets the collection type that can contain the workflow argument.
public property | Description | Gets or sets a description of the workflow argument.
public property | Direction | Gets or sets the data direction of the workflow argument.
public property | EntityName | Gets or sets the logical name of the primary entity that the workflow is executing for.
public property | Name | Gets or sets a name for the workflow argument.
public property | Required | Gets or sets if the workflow argument is required.
public property | Target | Gets or sets whether the argument is the primary entity being supplied to the workflow.
public property | Value | Gets or sets the value of the workflow argument.

See Also

Reference

WorkflowArgument Class
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument.ArgumentType Property
[image]

Gets or sets the data type of the workflow argument.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ArgumentType As Type

C#
public Type ArgumentType { get; set; }

C++

J#

JScript

Property Value
Type: Type
The data type of the workflow argument.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument.ContainerType Property
[image]

Gets or sets the collection type that can contain the workflow argument.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ContainerType As Type

C#
public Type ContainerType { get; set; }

C++

J#

JScript

Property Value
Type: Type
The collection type that can contain the workflow argument.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument.Description Property
[image]

Gets or sets a description of the workflow argument.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Description As String

C#
public string Description { get; set; }

C++

J#

JScript

Property Value
Type: String
A description of the workflow argument.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument.Direction Property
[image]

Gets or sets the data direction of the workflow argument.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Direction As ArgumentDirection

C#
public ArgumentDirection Direction { get; set; }

C++

J#

JScript

Property Value
Type: ArgumentDirection
Specifies if the argument is input to or output from the workflow.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument.EntityName Property
[image]

Gets or sets the logical name of the primary entity that the workflow is executing for.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EntityName As String

C#
public string EntityName { get; set; }

C++

J#

JScript

Property Value
Type: String
The logical name of the primary entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument.Name Property
[image]

Gets or sets a name for the workflow argument.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Name As String

C#
public string Name { get; set; }

C++

J#

JScript

Property Value
Type: String
A name for the workflow argument.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument.Required Property
[image]

Gets or sets if the workflow argument is required.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Required As Boolean

C#
public bool Required { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the argument is required; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument.Target Property
[image]

Gets or sets whether the argument is the primary entity being supplied to the workflow.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Target As Boolean

C#
public bool Target { get; set; }

C++

J#

JScript

Property Value
Type: Boolean
true if the argument is the primary entity; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowArgument.Value Property
[image]

Gets or sets the value of the workflow argument.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As Object

C#
public Object Value { get; set; }

C++

J#

JScript

Property Value
Type: Object
The value of the workflow argument.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowArgument Class
WorkflowArgument Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType Class
See Also Members
[image]

Contains the integer flags to set the WorkflowDependency.Type attribute.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class WorkflowDependencyType

C#
public static class WorkflowDependencyType

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Workflow.WorkflowDependencyType
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType Members
See Also Fields
[image]

Contains the integer flags to set the WorkflowDependency.Type attribute.

The following tables list the members exposed by the WorkflowDependencyType type.

Public Fields

Name | Description
ArgumentEntityImage | A dependency on an argument entity image. Value = 9.
AttributeDefinition | A dependency on an attribute definition. Value = 8.
CustomEntityDefinition | A dependency on a custom entity definition. Value = 7.
LocalParameter | A dependency on a local parameter. Value = 2.
PrimaryEntityImage | A dependency on a primary entity image. Value = 3.
PrimaryEntityPostImage | A dependency on a primary entity post image. Value = 5.
PrimaryEntityPreImage | A dependency on a primary entity pre image. Value = 4.
RelatedEntityImage | A dependency on a related entity image. Value = 6.
SdkAssociation | A dependency on an SDK association. Value = 1.
Top

See Also

Reference

WorkflowDependencyType Class
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType Fields
[image]

Public Fields

Name | Description
ArgumentEntityImage | A dependency on an argument entity image. Value = 9.
AttributeDefinition | A dependency on an attribute definition. Value = 8.
CustomEntityDefinition | A dependency on a custom entity definition. Value = 7.
LocalParameter | A dependency on a local parameter. Value = 2.
PrimaryEntityImage | A dependency on a primary entity image. Value = 3.
PrimaryEntityPostImage | A dependency on a primary entity post image. Value = 5.
PrimaryEntityPreImage | A dependency on a primary entity pre image. Value = 4.
RelatedEntityImage | A dependency on a related entity image. Value = 6.
SdkAssociation | A dependency on an SDK association. Value = 1.

See Also

Reference

WorkflowDependencyType Class
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType.ArgumentEntityImage Field
[image]

A dependency on an argument entity image. Value = 9.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const ArgumentEntityImage As Integer

C#
public const int ArgumentEntityImage

C++

J#

JScript

  Remarks
This type value is obsolete.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Class
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType.AttributeDefinition Field
[image]

A dependency on an attribute definition. Value = 8.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const AttributeDefinition As Integer

C#
public const int AttributeDefinition

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Class
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType.CustomEntityDefinition Field
[image]

A dependency on a custom entity definition. Value = 7.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const CustomEntityDefinition As Integer

C#
public const int CustomEntityDefinition

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Class
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType.LocalParameter Field
[image]

A dependency on a local parameter. Value = 2.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const LocalParameter As Integer

C#
public const int LocalParameter

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Class
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType.PrimaryEntityImage Field
[image]

A dependency on a primary entity image. Value = 3.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const PrimaryEntityImage As Integer

C#
public const int PrimaryEntityImage

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Class
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType.PrimaryEntityPostImage Field
[image]

A dependency on a primary entity post image. Value = 5.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const PrimaryEntityPostImage As Integer

C#
public const int PrimaryEntityPostImage

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Class
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType.PrimaryEntityPreImage Field
[image]

A dependency on a primary entity pre image. Value = 4.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const PrimaryEntityPreImage As Integer

C#
public const int PrimaryEntityPreImage

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Class
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType.RelatedEntityImage Field
[image]

A dependency on a related entity image. Value = 6.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const RelatedEntityImage As Integer

C#
public const int RelatedEntityImage

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Class
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowDependencyType.SdkAssociation Field
[image]

A dependency on an SDK association. Value = 1.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SdkAssociation As Integer

C#
public const int SdkAssociation

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDependencyType Class
WorkflowDependencyType Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowPropertyType Enumeration
[image]

Contains values for the property types supported by workflows.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration WorkflowPropertyType

C#
public enum WorkflowPropertyType

C++

J#

JScript

  Members
Member name | Description
Boolean | A Boolean property. Value = 0.
DateTime | A DateTime property. Value = 1.
Decimal | A Decimal property. Value = 2.
EntityReference | An EntityReference property. Value = 5.
Float | A Float property. Value = 3.
Guid | A Guid property. Value = 9.
Integer | An Integer property. Value = 4.
Money | A Money property. Value = 6.
OptionSetValue | An OptionSetValue property. Value = 8.
PartyList | A PartyList property. Value = 7.
String | A String property. Value = 10.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Sdk.Workflow Namespace
Other Resources
Sample: Create a Process Using a Template
Sample: Execute a Workflow


WorkflowStepActivityStatus Class
See Also Members
[image]

Contains values for the workflow step activity status.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class WorkflowStepActivityStatus

C#
public static class WorkflowStepActivityStatus

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Sdk.Workflow.WorkflowStepActivityStatus
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowStepActivityStatus Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowStepActivityStatus Members
See Also Fields
[image]

Contains values for the workflow step activity status.

The following tables list the members exposed by the WorkflowStepActivityStatus type.

Public Fields

Name | Description
Canceled | Indicates the step has been canceled. Value = 4.
Failed | The step has failed. Value = 3.
InProgress | The step is in progress. Value = 1.
SuccessfullyCompleted | The step has successfully completed. Value = 2.
Waiting | Indicates the step is waiting. Value = 5.
Top

See Also

Reference

WorkflowStepActivityStatus Class
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowStepActivityStatus Fields
[image]

Public Fields

Name | Description
Canceled | Indicates the step has been canceled. Value = 4.
Failed | The step has failed. Value = 3.
InProgress | The step is in progress. Value = 1.
SuccessfullyCompleted | The step has successfully completed. Value = 2.
Waiting | Indicates the step is waiting. Value = 5.

See Also

Reference

WorkflowStepActivityStatus Class
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowStepActivityStatus.Canceled Field
[image]

Indicates the step has been canceled. Value = 4.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Canceled As Integer

C#
public const int Canceled

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowStepActivityStatus Class
WorkflowStepActivityStatus Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowStepActivityStatus.Failed Field
[image]

The step has failed. Value = 3.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Failed As Integer

C#
public const int Failed

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowStepActivityStatus Class
WorkflowStepActivityStatus Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowStepActivityStatus.InProgress Field
[image]

The step is in progress. Value = 1.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const InProgress As Integer

C#
public const int InProgress

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowStepActivityStatus Class
WorkflowStepActivityStatus Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowStepActivityStatus.SuccessfullyCompleted Field
[image]

The step has successfully completed. Value = 2.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const SuccessfullyCompleted As Integer

C#
public const int SuccessfullyCompleted

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowStepActivityStatus Class
WorkflowStepActivityStatus Members
Microsoft.Xrm.Sdk.Workflow Namespace


WorkflowStepActivityStatus.Waiting Field
[image]

Indicates the step is waiting. Value = 5.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const Waiting As Integer

C#
public const int Waiting

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowStepActivityStatus Class
WorkflowStepActivityStatus Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan Structure
See Also Members
[image]

Represents a time interval.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public Structure XrmTimeSpan

C#
[SerializableAttribute]
public struct XrmTimeSpan

C++

J#

JScript

  Remarks
This is similar to System.TimeSpan but with added support for month and year.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan Members
See Also Constructors Fields Methods Properties
[image]

Represents a time interval.

The following tables list the members exposed by the XrmTimeSpan type.

Public Constructors

Name | Description
XrmTimeSpan | Overloaded. Initializes a new instance of the XrmTimeSpan class.
Top

Public Fields

Name | Description
Zero | Represents the zero XrmTimeSpan value. This field is read-only.
Top

Public Properties

 | Name | Description
public property | Days | Gets the number of whole days represented by the current XrmTimeSpan structure.
public property | Hours | Gets the number of whole hours represented by the current XrmTimeSpan structure.
public property | Minutes | Gets the number of whole minutes represented by the current XrmTimeSpan structure.
public property | Months | Gets the number of whole months represented by the current XrmTimeSpan structure.
public property | Years | Gets the number of whole years represented by the current XrmTimeSpan structure.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Adds the specified date/time value to this instance.
 | CreateXrmTimeSpan | Overloaded. Creates an instance of a XrmTimeSpan class.
public method | Equals | Overloaded. Overloaded. Returns a value indicating whether two instances of XrmTimeSpan are equal.
public method | GetHashCode | Overridden. Returns a hash code for this instance.
public method | GetType | (inherited from Object)
 | Equality | Indicates whether two XrmTimeSpan instances are equal.
 | Inequality | Indicates whether two XrmTimeSpan instances are not equal.
public method | Subtract | Subtracts the specified XrmTimeSpan from this instance.
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

XrmTimeSpan Structure
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan Fields
[image]

Public Fields

Name | Description
Zero | Represents the zero XrmTimeSpan value. This field is read-only.

See Also

Reference

XrmTimeSpan Structure
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Zero Field
[image]

Represents the zero XrmTimeSpan value. This field is read-only.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Zero As XrmTimeSpan

C#
public static readonly XrmTimeSpan Zero

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan Constructor
[image]

Initializes a new instance of the XrmTimeSpan class.

Overload List

Name | Description
XrmTimeSpan (Int32, Int32, Int32) | Initializes a new instance of the XrmTimeSpan class setting the days, hours and minutes.
XrmTimeSpan (Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the XrmTimeSpan class setting the years, months, days, hours and minutes.
XrmTimeSpan (TimeSpan) | Initializes a new instance of the CrmTimeSpan class setting the time span.

See Also

Reference

XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan Constructor (Int32, Int32, Int32)
[image]

Initializes a new instance of the XrmTimeSpan class setting the days, hours and minutes.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    days As Integer, _
    hours As Integer, _
    minutes As Integer _
)

C#
public XrmTimeSpan (
    int days,
    int hours,
    int minutes
)

C++

J#

JScript

Parameters
days
Type: Int32. Specifies the days for the time span.
hours
Type: Int32. Specifies the hours for the time span.
minutes
Type: Int32. Specifies the minutes for the time span.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan Constructor (Int32, Int32, Int32, Int32, Int32)
[image]

Initializes a new instance of the XrmTimeSpan class setting the years, months, days, hours and minutes.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    years As Integer, _
    months As Integer, _
    days As Integer, _
    hours As Integer, _
    minutes As Integer _
)

C#
public XrmTimeSpan (
    int years,
    int months,
    int days,
    int hours,
    int minutes
)

C++

J#

JScript

Parameters
years
Type: Int32. Specifies the years for the time span.
months
Type: Int32. Specifies the months for the time span.
days
Type: Int32. Specifies the days for the time span.
hours
Type: Int32. Specifies the hours for the time span.
minutes
Type: Int32. Specifies the minutes for the time span.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan Constructor (TimeSpan)
[image]

Initializes a new instance of the CrmTimeSpan class setting the time span.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As TimeSpan _
)

C#
public XrmTimeSpan (
    TimeSpan value
)

C++

J#

JScript

Parameters
value
Type: TimeSpan. Specifies the time span.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | Adds the specified date/time value to this instance.
 | CreateXrmTimeSpan | Overloaded. Creates an instance of a XrmTimeSpan class.
public method | Equals | Overloaded. Overloaded. Returns a value indicating whether two instances of XrmTimeSpan are equal.
public method | GetHashCode | Overridden. Returns a hash code for this instance.
public method | GetType | (inherited from Object)
 | Equality | Indicates whether two XrmTimeSpan instances are equal.
 | Inequality | Indicates whether two XrmTimeSpan instances are not equal.
public method | Subtract | Subtracts the specified XrmTimeSpan from this instance.
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

XrmTimeSpan Structure
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Add Method
[image]

Adds the specified date/time value to this instance.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Add ( _
    value As DateTime _
) As DateTime

C#
public DateTime Add (
    DateTime value
)

C++

J#

JScript

Parameters
value
Type: DateTime. A date/time value to add to the current instance value.
Return Value
Type: DateTime
 The resultant date and time value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.CreateXrmTimeSpan Method
[image]

Creates an instance of a XrmTimeSpan class.

Overload List

Name | Description
XrmTimeSpan.CreateXrmTimeSpan (XrmTimeSpan) | Creates an instance of a XrmTimeSpan class setting the time span members.
XrmTimeSpan.CreateXrmTimeSpan (Int32, Int32, Int32) | Creates an instance of a XrmTimeSpan class setting the days, hours and minutes.
XrmTimeSpan.CreateXrmTimeSpan (Int32, Int32, Int32, Int32, Int32) | Creates an instance of a XrmTimeSpan class setting the years, months, days, hours and minutes.

See Also

Reference

XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.CreateXrmTimeSpan Method (XrmTimeSpan)
[image]

Creates an instance of a XrmTimeSpan class setting the time span members.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXrmTimeSpan ( _
    cts As XrmTimeSpan _
) As XrmTimeSpan

C#
public static XrmTimeSpan CreateXrmTimeSpan (
    XrmTimeSpan cts
)

C++

J#

JScript

Parameters
cts
Type: XrmTimeSpan. Specifies the time span.
Return Value
Type: XrmTimeSpan
The instance of a XrmTimeSpan class where the time span members are set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.CreateXrmTimeSpan Method (Int32, Int32, Int32)
[image]

Creates an instance of a XrmTimeSpan class setting the days, hours and minutes.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXrmTimeSpan ( _
    days As Integer, _
    hours As Integer, _
    minutes As Integer _
) As XrmTimeSpan

C#
public static XrmTimeSpan CreateXrmTimeSpan (
    int days,
    int hours,
    int minutes
)

C++

J#

JScript

Parameters
days
Type: Int32. Specifies the days for the time span.
hours
Type: Int32. Specifies the hours for the time span.
minutes
Type: Int32. Specifies the minutes for the time span.
Return Value
Type: XrmTimeSpan
The instance of a XrmTimeSpan class where the days, hours, and minutes are set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.CreateXrmTimeSpan Method (Int32, Int32, Int32, Int32, Int32)
[image]

Creates an instance of a XrmTimeSpan class setting the years, months, days, hours and minutes.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXrmTimeSpan ( _
    years As Integer, _
    months As Integer, _
    days As Integer, _
    hours As Integer, _
    minutes As Integer _
) As XrmTimeSpan

C#
public static XrmTimeSpan CreateXrmTimeSpan (
    int years,
    int months,
    int days,
    int hours,
    int minutes
)

C++

J#

JScript

Parameters
years
Type: Int32. Specifies the years for the time span.
months
Type: Int32. Specifies the months for the time span.
days
Type: Int32. Specifies the days for the time span.
hours
Type: Int32. Specifies the hours for the time span.
minutes
Type: Int32. Specifies the minutes for the time span.
Return Value
Type: XrmTimeSpan
The instance of a XrmTimeSpan class where the years, months, days, hours, and minutes are set.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Equals Method
[image]

Overloaded. Returns a value indicating whether two instances of XrmTimeSpan are equal.

Overload List

Name | Description
XrmTimeSpan.Equals (XrmTimeSpan) | Returns a value indicating whether this instance is equal to a specified XrmTimeSpan object.
XrmTimeSpan.Equals (Object) | Returns a value indicating whether this instance is equal to a specified object.

See Also

Reference

XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Equals Method (XrmTimeSpan)
[image]

Returns a value indicating whether this instance is equal to a specified XrmTimeSpan object.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Equals ( _
    value As XrmTimeSpan _
) As Boolean

C#
public bool Equals (
    XrmTimeSpan value
)

C++

J#

JScript

Parameters
value
Type: XrmTimeSpan. Specifies the XrmTimeSpan instance to test for equality with the current instance.
Return Value
Type: Boolean
true if the value represents the same time interval as the current XrmTimeSpan structure; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Equals Method (Object)
[image]

Returns a value indicating whether this instance is equal to a specified object.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

C#
public override bool Equals (
    Object obj
)

C++

J#

JScript

Parameters
obj
Type: Object. Specifies the object to test for equality with the current instance.
Return Value
Type: Boolean
true if value is a XrmTimeSpan object that represents the same time interval as the current XrmTimeSpan structure; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.GetHashCode Method
[image]

Returns a hash code for this instance.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function GetHashCode As Integer

C#
public override int GetHashCode ()

C++

J#

JScript

Return Value
Type: Int32
 The hash code for this instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Equality Method
[image]

Indicates whether two XrmTimeSpan instances are equal.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Operator = ( _
    span1 As XrmTimeSpan, _
    span2 As XrmTimeSpan _
) As Boolean

C#
public static bool operator == (
    XrmTimeSpan span1,
    XrmTimeSpan span2
)

C++

J#

JScript

Parameters
span1
Type: XrmTimeSpan. Specifies a XrmTimeSpan.
span2
Type: XrmTimeSpan. Specifies a XrmTimeSpan.
Return Value
Type: Boolean
true if the values of span1 and span2 are equal; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Inequality Method
[image]

Indicates whether two XrmTimeSpan instances are not equal.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Operator <> ( _
    span1 As XrmTimeSpan, _
    span2 As XrmTimeSpan _
) As Boolean

C#
public static bool operator != (
    XrmTimeSpan span1,
    XrmTimeSpan span2
)

C++

J#

JScript

Parameters
span1
Type: XrmTimeSpan. Specifies a XrmTimeSpan.
span2
Type: XrmTimeSpan. Specifies a XrmTimeSpan.
Return Value
Type: Boolean
true if the values of span1 and span2 are not equal; otherwise, false.

  Remarks
Returns a Boolean type. true of the values of span1 and span2 are not equal; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Subtract Method
[image]

Subtracts the specified XrmTimeSpan from this instance.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Subtract ( _
    value As DateTime _
) As DateTime

C#
public DateTime Subtract (
    DateTime value
)

C++

J#

JScript

Parameters
value
Type: DateTime. Specifies a date/time value to subtract.
Return Value
Type: DateTime
 The value resulting when the passed value is subtracted from this instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan Properties
[image]

Public Properties

 | Name | Description
public property | Days | Gets the number of whole days represented by the current XrmTimeSpan structure.
public property | Hours | Gets the number of whole hours represented by the current XrmTimeSpan structure.
public property | Minutes | Gets the number of whole minutes represented by the current XrmTimeSpan structure.
public property | Months | Gets the number of whole months represented by the current XrmTimeSpan structure.
public property | Years | Gets the number of whole years represented by the current XrmTimeSpan structure.

See Also

Reference

XrmTimeSpan Structure
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Days Property
[image]

Gets the number of whole days represented by the current XrmTimeSpan structure.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Days As Integer

C#
public int Days { get; set; }

C++

J#

JScript

Property Value
Type: Int32
 The number of whole days represented by the current XrmTimeSpan structure.

  Remarks
The value of this property is an Int32 type that is the day component of this instance. The return value can be positive or negative.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Hours Property
[image]

Gets the number of whole hours represented by the current XrmTimeSpan structure.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Hours As Integer

C#
public int Hours { get; set; }

C++

J#

JScript

Property Value
Type: Int32
The number of whole hours represented by the current XrmTimeSpan structure.

  Remarks
The value of this property is an Int32 type that is the hours component of this instance. The return value ranges from -23 through 23.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Minutes Property
[image]

Gets the number of whole minutes represented by the current XrmTimeSpan structure.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Minutes As Integer

C#
public int Minutes { get; set; }

C++

J#

JScript

Property Value
Type: Int32
 The number of whole minutes represented by the current XrmTimeSpan structure.

  Remarks
The value of this property is an Int32 type that is the minutes component of this instance. The return value ranges from -59 through 59.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Months Property
[image]

Gets the number of whole months represented by the current XrmTimeSpan structure.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Months As Integer

C#
public int Months { get; set; }

C++

J#

JScript

Property Value
Type: Int32
 The number of whole months represented by the current XrmTimeSpan structure.

  Remarks
The value of this property is an Int32 type that is the months component of this instance. The return value ranges from -12 through 12.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


XrmTimeSpan.Years Property
[image]

Gets the number of whole years represented by the current XrmTimeSpan structure.

Namespace: Microsoft.Xrm.Sdk.Workflow
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Years As Integer

C#
public int Years { get; set; }

C++

J#

JScript

Property Value
Type: Int32
 The number of whole years represented by the current XrmTimeSpan structure.

  Remarks
The value of this property is an Int32 type that is the years component of this instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
XrmTimeSpan Structure
XrmTimeSpan Members
Microsoft.Xrm.Sdk.Workflow Namespace


Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Classes

Class | Description
ActivityReference | For internal use only.
AssignEntity | Activity used to assign a record to a new owner or routes it to a queue.
CreateEntity | Creates an record.
GetEntityProperty | Retrieves the value of an entity attribute and converts the value to the specified type.
GetPrimaryEntity | Retrieves an entity reference for the primary entity for the workflow instance.
Postpone | Suspends the workflow until the specified date and time.
ReferenceLiteral | For internal use only.
RetrieveEntity | Retrieves a record.
SendEmail | Sends an e-mail message.
SendEmailFromTemplate | Sends an e-mail message to a recipient using an e-mail template.
SetEntityProperty | Sets a property (attribute) of an entity record.
SetState | Sets the state and status of a record.
StartChildWorkflow | Starts a child workflow.
UpdateEntity | Updates a record.
Workflow | The base class for all workflows in Microsoft Dynamics CRM.


ActivityReference Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ActivityReference
    Inherits NativeActivity

C#
public sealed class ActivityReference : NativeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.NativeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.ActivityReference
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ActivityReference Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ActivityReference Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the ActivityReference type.

Public Constructors

Name | Description
ActivityReference | Initializes a new instance of the ActivityReference class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Arguments | For internal use only.
public property | AssemblyQualifiedName | For internal use only.
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | Properties | For internal use only.
Top

Protected Properties

 | Name | Description
protected property | CanInduceIdle | (inherited from NativeActivity)
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Abort | (inherited from NativeActivity)
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from NativeActivity)
protected method | Cancel | (inherited from NativeActivity)
protected method | Execute | (inherited from NativeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ActivityReference Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ActivityReference Constructor
[image]

Initializes a new instance of the ActivityReference class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ActivityReference ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ActivityReference Class
ActivityReference Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ActivityReference Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | Abort | (inherited from NativeActivity)
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from NativeActivity)
protected method | Cancel | (inherited from NativeActivity)
protected method | Execute | (inherited from NativeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ActivityReference Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ActivityReference Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Arguments | For internal use only.
public property | AssemblyQualifiedName | For internal use only.
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | Properties | For internal use only.

Protected Properties

 | Name | Description
protected property | CanInduceIdle | (inherited from NativeActivity)
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

ActivityReference Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ActivityReference.Arguments Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Arguments As Dictionary(Of String, Argument)

C#
public Dictionary<string,Argument> Arguments { get; }

C++

J#

JScript

Property Value
Returns Dictionary.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ActivityReference Class
ActivityReference Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ActivityReference.AssemblyQualifiedName Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AssemblyQualifiedName As String

C#
public string AssemblyQualifiedName { get; set; }

C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ActivityReference Class
ActivityReference Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ActivityReference.Properties Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property Properties As Dictionary(Of String, Object)

C#
public Dictionary<string,Object> Properties { get; }

C++

J#

JScript

Property Value
Returns Dictionary.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ActivityReference Class
ActivityReference Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


AssignEntity Class
See Also Members
[image]

Activity used to assign a record to a new owner or routes it to a queue.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class AssignEntity
    Inherits CodeActivity

C#
public sealed class AssignEntity : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.AssignEntity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


AssignEntity Members
See Also Constructors Methods Properties
[image]

Activity used to assign a record to a new owner or routes it to a queue.

The following tables list the members exposed by the AssignEntity type.

Public Constructors

Name | Description
AssignEntity | Initializes a new instance of the AssignEntity class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets the resulting record following the assignment to a new owner.
public property | EntityId | Sets the ID of the record to assign.
public property | EntityName | Set the logical name of the entity specified by the EntityId property.
public property | Id | (inherited from Activity)
public property | Owner | Sets the new owner for the record.
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AssignEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


AssignEntity Constructor
[image]

Initializes a new instance of the AssignEntity class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AssignEntity ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignEntity Class
AssignEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


AssignEntity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AssignEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


AssignEntity Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets the resulting record following the assignment to a new owner.
public property | EntityId | Sets the ID of the record to assign.
public property | EntityName | Set the logical name of the entity specified by the EntityId property.
public property | Id | (inherited from Activity)
public property | Owner | Sets the new owner for the record.

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

AssignEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


AssignEntity.Entity Property
[image]

Gets the resulting record following the assignment to a new owner.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DescriptionAttribute("Entity updated after the assign operation.")> _
Public Property Entity As OutArgument(Of Entity)

C#
[RequiredArgumentAttribute]
[DescriptionAttribute("Entity updated after the assign operation.")]
public OutArgument<Entity> Entity { get; set; }

C++

J#

JScript

Property Value
Type: OutArgument<Entity>
The resulting record following the assignment to a new owner.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignEntity Class
AssignEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


AssignEntity.EntityId Property
[image]

Sets the ID of the record to assign.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Guid of the entity created.")> _
Public Property EntityId As InArgument(Of Guid)

C#
[DescriptionAttribute("Guid of the entity created.")]
public InArgument<Guid> EntityId { get; set; }

C++

J#

JScript

Property Value
Type: InArgument<Guid>
The ID of the record to assign.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignEntity Class
AssignEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


AssignEntity.EntityName Property
[image]

Set the logical name of the entity specified by the EntityId property.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Name of the entity created, used for creating workflow dependencies.")> _
<RequiredArgumentAttribute> _
Public Property EntityName As InArgument(Of String)

C#
[DescriptionAttribute("Name of the entity created, used for creating workflow dependencies.")]
[RequiredArgumentAttribute]
public InArgument<string> EntityName { get; set; }

C++

J#

JScript

Property Value
Type: InArgument<String>
The the logical name of the entity.

  Remarks
A workflow dependency for this entity will be added.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignEntity Class
AssignEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


AssignEntity.Owner Property
[image]

Sets the new owner for the record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Id of the step this activity corresponds to.")> _
Public Property Owner As InArgument(Of EntityReference)

C#
[DescriptionAttribute("Id of the step this activity corresponds to.")]
public InArgument<EntityReference> Owner { get; set; }

C++

J#

JScript

Property Value
Type: InArgument<EntityReference>
The ID of the record to assign.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AssignEntity Class
AssignEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


CreateEntity Class
See Also Members
[image]

Creates an record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CreateEntity
    Inherits CodeActivity

C#
public sealed class CreateEntity : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.CreateEntity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


CreateEntity Members
See Also Constructors Methods Properties
[image]

Creates an record.

The following tables list the members exposed by the CreateEntity type.

Public Constructors

Name | Description
CreateEntity | Initializes a new instance of the CreateEntity class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the entity instance (record).
public property | EntityId | Gets the ID of the record that was created.
public property | EntityName | Sets the logical entity name of the record to create.
public property | Id | (inherited from Activity)
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CreateEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


CreateEntity Constructor
[image]

Initializes a new instance of the CreateEntity class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CreateEntity ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntity Class
CreateEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


CreateEntity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CreateEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


CreateEntity Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the entity instance (record).
public property | EntityId | Gets the ID of the record that was created.
public property | EntityName | Sets the logical entity name of the record to create.
public property | Id | (inherited from Activity)

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

CreateEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


CreateEntity.Entity Property
[image]

Gets or sets the entity instance (record).

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DescriptionAttribute("Entity to be created.")> _
Public Property Entity As InOutArgument(Of Entity)

C#
[RequiredArgumentAttribute]
[DescriptionAttribute("Entity to be created.")]
public InOutArgument<Entity> Entity { get; set; }

C++

J#

JScript

Property Value
Type: InOutArgument<Entity>
The entity instance (record).

  Remarks
This is an entity instance of the type specified by the EntityName property. On input, the attribute values that have been set will be used to create the record. Only attribute values for attributes that are valid for create and that the user has access to create will be used, all others will be ignored.
On output, this the entity instance that was created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntity Class
CreateEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


CreateEntity.EntityId Property
[image]

Gets the ID of the record that was created.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Guid of the entity created.")> _
Public Property EntityId As OutArgument(Of Guid)

C#
[DescriptionAttribute("Guid of the entity created.")]
public OutArgument<Guid> EntityId { get; set; }

C++

J#

JScript

Property Value
Type: OutArgument<Guid>
The ID of the record that was created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntity Class
CreateEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


CreateEntity.EntityName Property
[image]

Sets the logical entity name of the record to create.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DescriptionAttribute("Name of the entity created, used for creating workflow dependencies.")> _
Public Property EntityName As InArgument(Of String)

C#
[RequiredArgumentAttribute]
[DescriptionAttribute("Name of the entity created, used for creating workflow dependencies.")]
public InArgument<string> EntityName { get; set; }

C++

J#

JScript

Property Value
Type: InArgument<String>
The logical entity name of the record to create.

  Remarks
This must be the entity name of the record specified in the Entity property.
A workflow dependency for this entity will be added.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CreateEntity Class
CreateEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


GetEntityProperty Class
See Also Members
[image]

Retrieves the value of an entity attribute and converts the value to the specified type.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class GetEntityProperty
    Inherits CodeActivity

C#
public sealed class GetEntityProperty : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.GetEntityProperty
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


GetEntityProperty Members
See Also Constructors Methods Properties
[image]

Retrieves the value of an entity attribute and converts the value to the specified type.

The following tables list the members exposed by the GetEntityProperty type.

Public Constructors

Name | Description
GetEntityProperty | Initializes a new instance of theGetEntityProperty class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Attribute | Gets or sets the logical name of the attribute.
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the entity record from which to get the attribute value.
public property | EntityName | Gets or sets the logical name of the entity.
public property | Id | (inherited from Activity)
public property | TargetType | Gets or sets the type of the value to be retrieved.
public property | Value | Gets the value of the specified entity attribute.
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetEntityProperty Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


GetEntityProperty Constructor
[image]

Initializes a new instance of the GetEntityProperty class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetEntityProperty ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetEntityProperty Class
GetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


GetEntityProperty Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetEntityProperty Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


GetEntityProperty Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Attribute | Gets or sets the logical name of the attribute.
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the entity record from which to get the attribute value.
public property | EntityName | Gets or sets the logical name of the entity.
public property | Id | (inherited from Activity)
public property | TargetType | Gets or sets the type of the value to be retrieved.
public property | Value | Gets the value of the specified entity attribute.

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

GetEntityProperty Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


GetEntityProperty.Attribute Property
[image]

Gets or sets the logical name of the attribute.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Attribute to retrieve.")> _
<RequiredArgumentAttribute> _
Public Property Attribute As InArgument(Of String)

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Attribute to retrieve.")]
[RequiredArgumentAttribute]
public InArgument<string> Attribute { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The logical name of the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetEntityProperty Class
GetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


GetEntityProperty.Entity Property
[image]

Gets or sets the entity record from which to get the attribute value.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Entity from which to get the property.")> _
<RequiredArgumentAttribute> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public Property Entity As InArgument(Of Entity)

C#
[DescriptionAttribute("Entity from which to get the property.")]
[RequiredArgumentAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public InArgument<Entity> Entity { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The entity record from which to get the attribute value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetEntityProperty Class
GetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


GetEntityProperty.EntityName Property
[image]

Gets or sets the logical name of the entity.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Entity name. If specified, a workflow dependency for this entity will be added.")> _
<RequiredArgumentAttribute> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public Property EntityName As InArgument(Of String)

C#
[DescriptionAttribute("Entity name. If specified, a workflow dependency for this entity will be added.")]
[RequiredArgumentAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public InArgument<string> EntityName { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The logical name of the entity.

  Remarks
If specified, a workflow dependency for this entity will be added.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetEntityProperty Class
GetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


GetEntityProperty.TargetType Property
[image]

Gets or sets the type of the value to be retrieved.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Target type if the Value parameter needs to be converted to the entity property type")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public Property TargetType As InArgument(Of Type)

C#
[DescriptionAttribute("Target type if the Value parameter needs to be converted to the entity property type")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public InArgument<Type> TargetType { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The type of the value to be retrieved.

  Remarks
If no type is specified, the value is returned in it’s native type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetEntityProperty Class
GetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


GetEntityProperty.Value Property
[image]

Gets the value of the specified entity attribute.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Value of the specified entity property.")> _
<RequiredArgumentAttribute> _
Public Property Value As OutArgument(Of Object)

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Value of the specified entity property.")]
[RequiredArgumentAttribute]
public OutArgument<Object> Value { get; set; }

C++

J#

JScript

Property Value
Type: OutArgument
 The value of the specified entity attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetEntityProperty Class
GetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


GetPrimaryEntity Class
See Also Members
[image]

Retrieves an entity reference for the primary entity for the workflow instance.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class GetPrimaryEntity
    Inherits CodeActivity

C#
public sealed class GetPrimaryEntity : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.GetPrimaryEntity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetPrimaryEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


GetPrimaryEntity Members
See Also Constructors Methods Properties
[image]

Retrieves an entity reference for the primary entity for the workflow instance.

The following tables list the members exposed by the GetPrimaryEntity type.

Public Constructors

Name | Description
GetPrimaryEntity | Initializes a new instance of the GetPrimaryEntity class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | PrimaryEntityReference | Gets the entity reference for the primary entity.
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

GetPrimaryEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


GetPrimaryEntity Constructor
[image]

Initializes a new instance of the GetPrimaryEntity class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public GetPrimaryEntity ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetPrimaryEntity Class
GetPrimaryEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


GetPrimaryEntity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

GetPrimaryEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


GetPrimaryEntity Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | PrimaryEntityReference | Gets the entity reference for the primary entity.

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

GetPrimaryEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


GetPrimaryEntity.PrimaryEntityReference Property
[image]

Gets the entity reference for the primary entity.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("EntityReference to the primary entity of the workflow instance.")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public Property PrimaryEntityReference As OutArgument(Of EntityReference)

C#
[DescriptionAttribute("EntityReference to the primary entity of the workflow instance.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public OutArgument<EntityReference> PrimaryEntityReference { get; set; }

C++

J#

JScript

Property Value
Type: OutArgument
The entity reference for the primary entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
GetPrimaryEntity Class
GetPrimaryEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Postpone Class
See Also Members
[image]

Suspends the workflow until the specified date and time.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class Postpone
    Inherits NativeActivity

C#
public sealed class Postpone : NativeActivity

C++

J#

JScript

  Remarks
Use this activity type instead of the Windows Workflow FoundationDelay activity.

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.NativeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.Postpone
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Postpone Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


Postpone Members
See Also Constructors Methods Properties
[image]

Suspends the workflow until the specified date and time.

The following tables list the members exposed by the Postpone type.

Public Constructors

Name | Description
Postpone | Initializes a new instance of the Postpone class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | BlockExecution | Sets whether the workflow execution should be suspended.
public property | BookmarkCallback | Gest the callback method used when workflow execution is resumed.
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | PostponeUntil | Sets the date and time the workflow execution will resume.
Top

Protected Properties

 | Name | Description
protected property | CanInduceIdle | (inherited from NativeActivity)
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Abort | (inherited from NativeActivity)
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from NativeActivity)
protected method | Cancel | (inherited from NativeActivity)
protected method | Execute | (inherited from NativeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Postpone Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


Postpone Constructor
[image]

Initializes a new instance of the Postpone class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public Postpone ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Postpone Class
Postpone Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Postpone Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | Abort | (inherited from NativeActivity)
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from NativeActivity)
protected method | Cancel | (inherited from NativeActivity)
protected method | Execute | (inherited from NativeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Postpone Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


Postpone Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | BlockExecution | Sets whether the workflow execution should be suspended.
public property | BookmarkCallback | Gest the callback method used when workflow execution is resumed.
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | PostponeUntil | Sets the date and time the workflow execution will resume.

Protected Properties

 | Name | Description
protected property | CanInduceIdle | (inherited from NativeActivity)
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

Postpone Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


Postpone.BlockExecution Property
[image]

Sets whether the workflow execution should be suspended.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("If set to true, the workflow execution will suspend.")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public Property BlockExecution As InArgument(Of Boolean)

C#
[DescriptionAttribute("If set to true, the workflow execution will suspend.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public InArgument<bool> BlockExecution { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 Indicates whether the workflow execution should be suspended.

  Remarks
If true, workflow execution will be suspended.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Postpone Class
Postpone Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Postpone.BookmarkCallback Property
[image]

Gest the callback method used when workflow execution is resumed.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Bookmark callback method called when a bookmark is resumed.")> _
Public ReadOnly Property BookmarkCallback As BookmarkCallback

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Bookmark callback method called when a bookmark is resumed.")]
public BookmarkCallback BookmarkCallback { get; }

C++

J#

JScript

Property Value
Type: BookmarkCallback
The callback method used when workflow execution is resumed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Postpone Class
Postpone Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Postpone.PostponeUntil Property
[image]

Sets the date and time the workflow execution will resume.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Time until which the activity execution should be delayed.")> _
<RequiredArgumentAttribute> _
Public Property PostponeUntil As InArgument(Of DateTime)

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Time until which the activity execution should be delayed.")]
[RequiredArgumentAttribute]
public InArgument<DateTime> PostponeUntil { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The date and time the workflow execution will resume.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Postpone Class
Postpone Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral Generic Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<ContentPropertyAttribute("Value")> _
Public NotInheritable Class ReferenceLiteral(Of T)
    Inherits CodeActivity(Of T)
    Implements IValueSerializableExpression

C#
[ContentPropertyAttribute("Value")]
public sealed class ReferenceLiteral<T> : CodeActivity<T>, IValueSerializableExpression

C++

J#

JScript

GenericParameters
T
  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.ActivityWithResult

                System.Activities.Activity

                System.Activities.CodeActivity
          Microsoft.Xrm.Sdk.Workflow.Activities.ReferenceLiteral
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceLiteral Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral Members
See Also Constructors Methods Properties
[image]

For internal use only.

The following tables list the members exposed by the ReferenceLiteral type.

Public Constructors

Name | Description
ReferenceLiteral | Overloaded. For internal use only.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | Result | (inherited from Activity)
public property | ResultType | (inherited from ActivityWithResult)
public property | Value | For internal use only.
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | CanConvertToString | For internal use only.
public method | ConvertToString | For internal use only.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ShouldSerializeValue | For internal use only.
public method | ToString | Overridden. For internal use only.
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ReferenceLiteral Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral Constructor
[image]

For internal use only.

Overload List

Name | Description
ReferenceLiteral () | For internal use only.
ReferenceLiteral (T) | For internal use only.

See Also

Reference

ReferenceLiteral Class
ReferenceLiteral Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral Constructor ()
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ReferenceLiteral ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceLiteral Class
ReferenceLiteral Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral Constructor (T)
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    value As T _
)

C#
public ReferenceLiteral (
    T value
)

C++

J#

JScript

Parameters
value
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceLiteral Class
ReferenceLiteral Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | CanConvertToString | For internal use only.
public method | ConvertToString | For internal use only.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ShouldSerializeValue | For internal use only.
public method | ToString | Overridden. For internal use only.

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ReferenceLiteral Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral.CanConvertToString Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CanConvertToString ( _
    context As IValueSerializerContext _
) As Boolean

C#
public bool CanConvertToString (
    IValueSerializerContext context
)

C++

J#

JScript

Parameters
context
Return Value
Type: Boolean
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceLiteral Class
ReferenceLiteral Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral.ConvertToString Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ConvertToString ( _
    context As IValueSerializerContext _
) As String

C#
public string ConvertToString (
    IValueSerializerContext context
)

C++

J#

JScript

Parameters
context
Return Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceLiteral Class
ReferenceLiteral Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral.ShouldSerializeValue Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Function ShouldSerializeValue As Boolean

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool ShouldSerializeValue ()

C++

J#

JScript

Return Value
Type: Boolean
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceLiteral Class
ReferenceLiteral Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral.ToString Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Function ToString As String

C#
public override string ToString ()

C++

J#

JScript

Return Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceLiteral Class
ReferenceLiteral Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | Result | (inherited from Activity)
public property | ResultType | (inherited from ActivityWithResult)
public property | Value | For internal use only.

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

ReferenceLiteral Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


ReferenceLiteral.Value Property
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As T

C#
public T Value { get; set; }

C++

J#

JScript

Property Value
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ReferenceLiteral Class
ReferenceLiteral Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


RetrieveEntity Class
See Also Members
[image]

Retrieves a record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class RetrieveEntity
    Inherits CodeActivity

C#
public sealed class RetrieveEntity : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.RetrieveEntity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


RetrieveEntity Members
See Also Constructors Methods Properties
[image]

Retrieves a record.

The following tables list the members exposed by the RetrieveEntity type.

Public Constructors

Name | Description
RetrieveEntity | Initializes a new instance of the RetrieveEntity class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Attributes | Sets the collection of logical names of the attributes to be retrieved.
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets the retrieved entity record.
public property | EntityId | Sets the ID of the entity record to be retrieved.
public property | EntityName | Set the logical name of the entity specified by the EntityId property.
public property | Id | (inherited from Activity)
public property | ThrowIfNotExists | Sets whether the workflow should throw an exception if the entity record does not exist.
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RetrieveEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


RetrieveEntity Constructor
[image]

Initializes a new instance of the RetrieveEntity class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public RetrieveEntity ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntity Class
RetrieveEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


RetrieveEntity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RetrieveEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


RetrieveEntity Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Attributes | Sets the collection of logical names of the attributes to be retrieved.
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets the retrieved entity record.
public property | EntityId | Sets the ID of the entity record to be retrieved.
public property | EntityName | Set the logical name of the entity specified by the EntityId property.
public property | Id | (inherited from Activity)
public property | ThrowIfNotExists | Sets whether the workflow should throw an exception if the entity record does not exist.

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

RetrieveEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


RetrieveEntity.Attributes Property
[image]

Sets the collection of logical names of the attributes to be retrieved.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Attributes to retrieve.")> _
Public Property Attributes As InArgument(Of String())

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Attributes to retrieve.")]
public InArgument<string[]> Attributes { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The collection of logical names of the attributes to be retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntity Class
RetrieveEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


RetrieveEntity.Entity Property
[image]

Gets the retrieved entity record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Retrieved entity.")> _
Public Property Entity As OutArgument(Of Entity)

C#
[RequiredArgumentAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Retrieved entity.")]
public OutArgument<Entity> Entity { get; set; }

C++

J#

JScript

Property Value
Type: OutArgument
 The retrieved entity record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntity Class
RetrieveEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


RetrieveEntity.EntityId Property
[image]

Sets the ID of the entity record to be retrieved.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DescriptionAttribute("Id of entity to retrieve.")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public Property EntityId As InArgument(Of Guid)

C#
[RequiredArgumentAttribute]
[DescriptionAttribute("Id of entity to retrieve.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public InArgument<Guid> EntityId { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The ID of the entity record to be retrieved.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntity Class
RetrieveEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


RetrieveEntity.EntityName Property
[image]

Set the logical name of the entity specified by the EntityId property.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Name of entity to retrieve.")> _
<RequiredArgumentAttribute> _
Public Property EntityName As InArgument(Of String)

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Name of entity to retrieve.")]
[RequiredArgumentAttribute]
public InArgument<string> EntityName { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The logical name of the entity specified by the EntityId property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntity Class
RetrieveEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


RetrieveEntity.ThrowIfNotExists Property
[image]

Sets whether the workflow should throw an exception if the entity record does not exist.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Whether the activity will throw if the given entity does not exists. True by default.")> _
<RequiredArgumentAttribute> _
Public Property ThrowIfNotExists As InArgument(Of Boolean)

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Whether the activity will throw if the given entity does not exists. True by default.")]
[RequiredArgumentAttribute]
public InArgument<bool> ThrowIfNotExists { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 Indicates whether the workflow should throw an exception if the entity record does not exist.

  Remarks
If not specified, this property is true by default.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RetrieveEntity Class
RetrieveEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SendEmail Class
See Also Members
[image]

Sends an e-mail message.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SendEmail
    Inherits CodeActivity

C#
public sealed class SendEmail : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.SendEmail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmail Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


SendEmail Members
See Also Constructors Methods Properties
[image]

Sends an e-mail message.

The following tables list the members exposed by the SendEmail type.

Public Constructors

Name | Description
SendEmail | Initializes a new instance of the SendEmail class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the e-mail record.
public property | EntityId | Gets or sets the ID of the resulting e-mail record.
public property | Id | (inherited from Activity)
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendEmail Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SendEmail Constructor
[image]

Initializes a new instance of the SendEmail class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendEmail ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmail Class
SendEmail Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SendEmail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendEmail Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SendEmail Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the e-mail record.
public property | EntityId | Gets or sets the ID of the resulting e-mail record.
public property | Id | (inherited from Activity)

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

SendEmail Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SendEmail.Entity Property
[image]

Gets or sets the e-mail record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Email entity.")> _
<RequiredArgumentAttribute> _
Public Property Entity As InOutArgument(Of Entity)

C#
[DescriptionAttribute("Email entity.")]
[RequiredArgumentAttribute]
public InOutArgument<Entity> Entity { get; set; }

C++

J#

JScript

Property Value
Type: InOutArgument
The e-mail record.

  Remarks
On input, this is an Email record that will be used to create the e-mail message.
On output, this the email record that was created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmail Class
SendEmail Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SendEmail.EntityId Property
[image]

Gets or sets the ID of the resulting e-mail record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Email Entity Id.")> _
Public Property EntityId As OutArgument(Of Guid)

C#
[DescriptionAttribute("Email Entity Id.")]
public OutArgument<Guid> EntityId { get; set; }

C++

J#

JScript

Property Value
Type: OutArgument
The ID of the resulting e-mail record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmail Class
SendEmail Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SendEmailFromTemplate Class
See Also Members
[image]

Sends an e-mail message to a recipient using an e-mail template.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SendEmailFromTemplate
    Inherits CodeActivity

C#
public sealed class SendEmailFromTemplate : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.SendEmailFromTemplate
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplate Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


SendEmailFromTemplate Members
See Also Constructors Methods Properties
[image]

Sends an e-mail message to a recipient using an e-mail template.

The following tables list the members exposed by the SendEmailFromTemplate type.

Public Constructors

Name | Description
SendEmailFromTemplate | Initializes a new instance of theSendEmailFromTemplate class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the e-mail record.
public property | EntityId | Gets or sets the ID of the resulting e-mail.
public property | Id | (inherited from Activity)
public property | RegardingId | Gets or sets the ID of the entity record with which the e-mail message is associated.
public property | RegardingType | Gets or sets the logical entity name of the entity represented by the RegardingdId property.
public property | TemplateId | Gets or sets the ID of the e-mail template to use.
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SendEmailFromTemplate Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SendEmailFromTemplate Constructor
[image]

Initializes a new instance of the SendEmailFromTemplate class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SendEmailFromTemplate ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplate Class
SendEmailFromTemplate Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SendEmailFromTemplate Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SendEmailFromTemplate Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SendEmailFromTemplate Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the e-mail record.
public property | EntityId | Gets or sets the ID of the resulting e-mail.
public property | Id | (inherited from Activity)
public property | RegardingId | Gets or sets the ID of the entity record with which the e-mail message is associated.
public property | RegardingType | Gets or sets the logical entity name of the entity represented by the RegardingdId property.
public property | TemplateId | Gets or sets the ID of the e-mail template to use.

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

SendEmailFromTemplate Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SendEmailFromTemplate.Entity Property
[image]

Gets or sets the e-mail record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Email entity.")> _
<RequiredArgumentAttribute> _
Public Property Entity As InOutArgument(Of Entity)

C#
[DescriptionAttribute("Email entity.")]
[RequiredArgumentAttribute]
public InOutArgument<Entity> Entity { get; set; }

C++

J#

JScript

Property Value
Type: InOutArgument
The e-mail record.

  Remarks
On input, this is an Email entity record that will be used to create the e-mail message.
On output, this the email entity instance that was created.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplate Class
SendEmailFromTemplate Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SendEmailFromTemplate.EntityId Property
[image]

Gets or sets the ID of the resulting e-mail.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Email Entity Id.")> _
Public Property EntityId As OutArgument(Of Guid)

C#
[DescriptionAttribute("Email Entity Id.")]
public OutArgument<Guid> EntityId { get; set; }

C++

J#

JScript

Property Value
Type: OutArgument
The ID of the resulting e-mail.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplate Class
SendEmailFromTemplate Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SendEmailFromTemplate.RegardingId Property
[image]

Gets or sets the ID of the entity record with which the e-mail message is associated.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Id of entity to instantiate email from.")> _
<RequiredArgumentAttribute> _
Public Property RegardingId As InArgument(Of Guid)

C#
[DescriptionAttribute("Id of entity to instantiate email from.")]
[RequiredArgumentAttribute]
public InArgument<Guid> RegardingId { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
The ID of the entity record with which the e-mail message is associated.

  Remarks
The RegardingId property is the ID of an entity record that is valid for the Email.RegardingObjectId attribute. The RegardingType property must contain the logical name of the entity type for this entity record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplate Class
SendEmailFromTemplate Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SendEmailFromTemplate.RegardingType Property
[image]

Gets or sets the logical entity name of the entity represented by the RegardingdId property.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Id of entity to instantiate email from.")> _
<RequiredArgumentAttribute> _
Public Property RegardingType As InArgument(Of String)

C#
[DescriptionAttribute("Id of entity to instantiate email from.")]
[RequiredArgumentAttribute]
public InArgument<string> RegardingType { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
The logical entity name of the entity represented by the RegardingdId property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplate Class
SendEmailFromTemplate Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SendEmailFromTemplate.TemplateId Property
[image]

Gets or sets the ID of the e-mail template to use.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DescriptionAttribute("Id of email template.")> _
Public Property TemplateId As InArgument(Of Guid)

C#
[RequiredArgumentAttribute]
[DescriptionAttribute("Id of email template.")]
public InArgument<Guid> TemplateId { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
The ID of the e-mail template to use.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SendEmailFromTemplate Class
SendEmailFromTemplate Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetEntityProperty Class
See Also Members
[image]

Sets a property (attribute) of an entity record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SetEntityProperty
    Inherits CodeActivity

C#
public sealed class SetEntityProperty : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.SetEntityProperty
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


SetEntityProperty Members
See Also Constructors Methods Properties
[image]

Sets a property (attribute) of an entity record.

The following tables list the members exposed by the SetEntityProperty type.

Public Constructors

Name | Description
SetEntityProperty | Initializes a new instance of theSetEntityProperty class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Attribute | Sets the logical name of the attribute.
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the entity record.
public property | EntityName | Sets the logical entity name of the record specified in the Entity property.
public property | Id | (inherited from Activity)
public property | TargetType | Sets the type for the value to be converted to.
public property | Value | Sets the value for the attribute specified in the Attribute property.
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetEntityProperty Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SetEntityProperty Constructor
[image]

Initializes a new instance of the SetEntityProperty class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetEntityProperty ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetEntityProperty Class
SetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetEntityProperty Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetEntityProperty Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SetEntityProperty Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Attribute | Sets the logical name of the attribute.
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the entity record.
public property | EntityName | Sets the logical entity name of the record specified in the Entity property.
public property | Id | (inherited from Activity)
public property | TargetType | Sets the type for the value to be converted to.
public property | Value | Sets the value for the attribute specified in the Attribute property.

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

SetEntityProperty Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SetEntityProperty.Attribute Property
[image]

Sets the logical name of the attribute.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<RequiredArgumentAttribute> _
<DescriptionAttribute("Attribute to be updated.")> _
Public Property Attribute As InArgument(Of String)

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[RequiredArgumentAttribute]
[DescriptionAttribute("Attribute to be updated.")]
public InArgument<string> Attribute { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The logical name of the attribute.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetEntityProperty Class
SetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetEntityProperty.Entity Property
[image]

Gets or sets the entity record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Entity to be updated.")> _
Public Property Entity As InOutArgument(Of Entity)

C#
[RequiredArgumentAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Entity to be updated.")]
public InOutArgument<Entity> Entity { get; set; }

C++

J#

JScript

Property Value
Type: InOutArgument
 The entity record.

  Remarks
This is a record of the type specified by the EntityName property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetEntityProperty Class
SetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetEntityProperty.EntityName Property
[image]

Sets the logical entity name of the record specified in the Entity property.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Entity name. If specified, a workflow dependency for this entity will be added.")> _
<RequiredArgumentAttribute> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public Property EntityName As InArgument(Of String)

C#
[DescriptionAttribute("Entity name. If specified, a workflow dependency for this entity will be added.")]
[RequiredArgumentAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public InArgument<string> EntityName { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The logical entity name of the record specified in the Entity property.

  Remarks
If specified, a workflow dependency for this entity will be added.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetEntityProperty Class
SetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetEntityProperty.TargetType Property
[image]

Sets the type for the value to be converted to.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Target type if the Value parameter needs to be converted to the entity property type")> _
Public Property TargetType As InArgument(Of Type)

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Target type if the Value parameter needs to be converted to the entity property type")]
public InArgument<Type> TargetType { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The type for the value to be converted to.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetEntityProperty Class
SetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetEntityProperty.Value Property
[image]

Sets the value for the attribute specified in the Attribute property.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("New value for the entity attribute.")> _
<RequiredArgumentAttribute> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public Property Value As InArgument(Of Object)

C#
[DescriptionAttribute("New value for the entity attribute.")]
[RequiredArgumentAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public InArgument<Object> Value { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The value for the attribute specified in the Attribute property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetEntityProperty Class
SetEntityProperty Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetState Class
See Also Members
[image]

Sets the state and status of a record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SetState
    Inherits CodeActivity

C#
public sealed class SetState : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.SetState
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetState Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


SetState Members
See Also Constructors Methods Properties
[image]

Sets the state and status of a record.

The following tables list the members exposed by the SetState type.

Public Constructors

Name | Description
SetState | Initializes a new instance of the SetState class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets the resulting entity record following the update.
public property | EntityId | Sets the ID of the entity record to update.
public property | EntityName | Set the logical name of the entity specified by the EntityId property.
public property | Id | (inherited from Activity)
public property | State | Sets the new state for the entity record.
public property | Status | Sets the new status that corresponds to the State property.
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SetState Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SetState Constructor
[image]

Initializes a new instance of the SetState class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SetState ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetState Class
SetState Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetState Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SetState Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SetState Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets the resulting entity record following the update.
public property | EntityId | Sets the ID of the entity record to update.
public property | EntityName | Set the logical name of the entity specified by the EntityId property.
public property | Id | (inherited from Activity)
public property | State | Sets the new state for the entity record.
public property | Status | Sets the new status that corresponds to the State property.

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

SetState Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


SetState.Entity Property
[image]

Gets the resulting entity record following the update.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Entity after the new state and status have been set.")> _
Public Property Entity As OutArgument(Of Entity)

C#
[DescriptionAttribute("Entity after the new state and status have been set.")]
public OutArgument<Entity> Entity { get; set; }

C++

J#

JScript

Property Value
Type: OutArgument
 The resulting entity record following the update.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetState Class
SetState Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetState.EntityId Property
[image]

Sets the ID of the entity record to update.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DescriptionAttribute("Guid of the entity created.")> _
Public Property EntityId As InArgument(Of Guid)

C#
[RequiredArgumentAttribute]
[DescriptionAttribute("Guid of the entity created.")]
public InArgument<Guid> EntityId { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The ID of the entity record to update.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetState Class
SetState Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetState.EntityName Property
[image]

Set the logical name of the entity specified by the EntityId property.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Name of the entity to be updated")> _
<RequiredArgumentAttribute> _
Public Property EntityName As InArgument(Of String)

C#
[DescriptionAttribute("Name of the entity to be updated")]
[RequiredArgumentAttribute]
public InArgument<string> EntityName { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The logical name of the entity specified by the EntityId property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetState Class
SetState Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


SetState.State Property
[image]

Sets the new state for the entity record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DescriptionAttribute("State to set.")> _
Public Property State As InArgument(Of OptionSetValue)

C#
[RequiredArgumentAttribute]
[DescriptionAttribute("State to set.")]
public InArgument<OptionSetValue> State { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The new state for the entity record.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetState Class
SetState Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Record State and Status


SetState.Status Property
[image]

Sets the new status that corresponds to the State property.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Status that is valid for a specified State.")> _
<RequiredArgumentAttribute> _
Public Property Status As InArgument(Of OptionSetValue)

C#
[DescriptionAttribute("Status that is valid for a specified State.")]
[RequiredArgumentAttribute]
public InArgument<OptionSetValue> Status { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The new status that corresponds to the State property.

  Remarks
Must be a valid status for the specified state.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
SetState Class
SetState Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Record State and Status


StartChildWorkflow Class
See Also Members
[image]

Starts a child workflow.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class StartChildWorkflow
    Inherits CodeActivity

C#
public sealed class StartChildWorkflow : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.StartChildWorkflow
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StartChildWorkflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


StartChildWorkflow Members
See Also Constructors Methods Properties
[image]

Starts a child workflow.

The following tables list the members exposed by the StartChildWorkflow type.

Public Constructors

Name | Description
StartChildWorkflow | Initializes a new instance of the StartChildWorkflow class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | EntityId | Sets the ID of the primary entity for the child workflow.
public property | EntityName | Sets the logical name of the entity specified by the EntityId property.
public property | Id | (inherited from Activity)
public property | InputParameters | Gets or sets the input parameters.
public property | WorkflowId | Sets the ID of the workflow to be started.
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StartChildWorkflow Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


StartChildWorkflow Constructor
[image]

Initializes a new instance of the StartChildWorkflow class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StartChildWorkflow ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StartChildWorkflow Class
StartChildWorkflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


StartChildWorkflow Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StartChildWorkflow Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


StartChildWorkflow Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | EntityId | Sets the ID of the primary entity for the child workflow.
public property | EntityName | Sets the logical name of the entity specified by the EntityId property.
public property | Id | (inherited from Activity)
public property | InputParameters | Gets or sets the input parameters.
public property | WorkflowId | Sets the ID of the workflow to be started.

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

StartChildWorkflow Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


StartChildWorkflow.EntityId Property
[image]

Sets the ID of the primary entity for the child workflow.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Id of the primary entity for the child workflow.")> _
<RequiredArgumentAttribute> _
Public Property EntityId As InArgument(Of Guid)

C#
[DescriptionAttribute("Id of the primary entity for the child workflow.")]
[RequiredArgumentAttribute]
public InArgument<Guid> EntityId { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The ID of the primary entity for the child workflow.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StartChildWorkflow Class
StartChildWorkflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


StartChildWorkflow.EntityName Property
[image]

Sets the logical name of the entity specified by the EntityId property.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DescriptionAttribute("Name of the primary entity for the child workflow.")> _
Public Property EntityName As InArgument(Of String)

C#
[RequiredArgumentAttribute]
[DescriptionAttribute("Name of the primary entity for the child workflow.")]
public InArgument<string> EntityName { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The logical name of the entity specified by the EntityId property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StartChildWorkflow Class
StartChildWorkflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


StartChildWorkflow.InputParameters Property
[image]

Gets or sets the input parameters.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Input parameters of the child workflow.")> _
Public Property InputParameters As InArgument(Of Dictionary(Of String, Object))

C#
[DescriptionAttribute("Input parameters of the child workflow.")]
public InArgument<Dictionary<string,Object>> InputParameters { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
The input parameters.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StartChildWorkflow Class
StartChildWorkflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


StartChildWorkflow.WorkflowId Property
[image]

Sets the ID of the workflow to be started.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DescriptionAttribute("Id of the child workflow.")> _
Public Property WorkflowId As InArgument(Of Guid)

C#
[RequiredArgumentAttribute]
[DescriptionAttribute("Id of the child workflow.")]
public InArgument<Guid> WorkflowId { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The ID of the workflow to be started.

  Remarks
The WorfklowId property corresponds to the Workflow.WorkflowId attribute which is the primary key for the Workflow entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StartChildWorkflow Class
StartChildWorkflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


UpdateEntity Class
See Also Members
[image]

Updates a record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class UpdateEntity
    Inherits CodeActivity

C#
public sealed class UpdateEntity : CodeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.CodeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.UpdateEntity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


UpdateEntity Members
See Also Constructors Methods Properties
[image]

Updates a record.

The following tables list the members exposed by the UpdateEntity type.

Public Constructors

Name | Description
UpdateEntity | Initializes a new instance of the UpdateEntity class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the record.
public property | EntityName | Sets the logical entity name of the record to update.
public property | Id | (inherited from Activity)
Top

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

UpdateEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


UpdateEntity Constructor
[image]

Initializes a new instance of the UpdateEntity class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public UpdateEntity ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntity Class
UpdateEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


UpdateEntity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from CodeActivity)
protected method | Execute | (inherited from CodeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

UpdateEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


UpdateEntity Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | DisplayName | (inherited from Activity)
public property | Entity | Gets or sets the record.
public property | EntityName | Sets the logical entity name of the record to update.
public property | Id | (inherited from Activity)

Protected Properties

 | Name | Description
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

UpdateEntity Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


UpdateEntity.Entity Property
[image]

Gets or sets the record.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Entity to be updated.")> _
Public Property Entity As InOutArgument(Of Entity)

C#
[RequiredArgumentAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Entity to be updated.")]
public InOutArgument<Entity> Entity { get; set; }

C++

J#

JScript

Property Value
Type: InOutArgument
 The record to update.

  Remarks
This is an entity instance of the type specified by the EntityName property. On input, the attribute values that have been set will be used update the record. Only attribute values for attributes that are valid for update and that the user has access to update will be used, all others will be ignored.
On output, this is the record that was updated.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntity Class
UpdateEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


UpdateEntity.EntityName Property
[image]

Sets the logical entity name of the record to update.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<RequiredArgumentAttribute> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Name of entity to update. If specified, it will be added to the workflow dependencies.")> _
Public Property EntityName As InArgument(Of String)

C#
[RequiredArgumentAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Name of entity to update. If specified, it will be added to the workflow dependencies.")]
public InArgument<string> EntityName { get; set; }

C++

J#

JScript

Property Value
Type: InArgument
 The logical entity name of the record to update.

  Remarks
This must be the name of the record specified in the Entity property.
If specified, it will be added to the workflow dependencies.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
UpdateEntity Class
UpdateEntity Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Workflow Class
See Also Members
[image]

The base class for all workflows in Microsoft Dynamics CRM.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<ContentPropertyAttribute("Activities")> _
<DesignerAttribute(GetType(WorkflowDesigner))> _
Public NotInheritable Class Workflow
    Inherits NativeActivity

C#
[ContentPropertyAttribute("Activities")]
[DesignerAttribute(typeof(WorkflowDesigner))]
public sealed class Workflow : NativeActivity

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Activities.Activity

                System.Activities.NativeActivity
      Microsoft.Xrm.Sdk.Workflow.Activities.Workflow
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Workflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace
Other Resources
Custom XAML Workflows


Workflow Members
See Also Constructors Methods Properties
[image]

The base class for all workflows in Microsoft Dynamics CRM.

The following tables list the members exposed by the Workflow type.

Public Constructors

Name | Description
Workflow | Initializes a new instance of the Workflow class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Activities | Gets the collection of activities for this workflow.
public property | BookmarkCallback | Gets the callback method called when the workflow is resumed.
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | OnChildComplete | Gets the callback method called when a child of this sequence completes execution.
public property | Variables | Gets the collection of workflow variables.
Top

Protected Properties

 | Name | Description
protected property | CanInduceIdle | (inherited from NativeActivity)
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Abort | (inherited from NativeActivity)
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from NativeActivity)
protected method | Cancel | (inherited from NativeActivity)
protected method | Execute | (inherited from NativeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Workflow Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


Workflow Constructor
[image]

Initializes a new instance of the Workflow class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public Workflow ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Workflow Class
Workflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Workflow Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ShouldSerializeDisplayName | (inherited from Activity)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | Abort | (inherited from NativeActivity)
protected method | CacheMetadata | Overridden. (inherited from Activity)
protected method | CacheMetadata | (inherited from NativeActivity)
protected method | Cancel | (inherited from NativeActivity)
protected method | Execute | (inherited from NativeActivity)
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Workflow Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


Workflow Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Activities | Gets the collection of activities for this workflow.
public property | BookmarkCallback | Gets the callback method called when the workflow is resumed.
public property | DisplayName | (inherited from Activity)
public property | Id | (inherited from Activity)
public property | OnChildComplete | Gets the callback method called when a child of this sequence completes execution.
public property | Variables | Gets the collection of workflow variables.

Protected Properties

 | Name | Description
protected property | CanInduceIdle | (inherited from NativeActivity)
protected property | Constraints | (inherited from Activity)
protected property | Implementation | Overridden. (inherited from Activity)

See Also

Reference

Workflow Class
Microsoft.Xrm.Sdk.Workflow.Activities Namespace

Other Resources

Custom XAML Workflows


Workflow.Activities Property
[image]

Gets the collection of activities for this workflow.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
<DescriptionAttribute("Child activities.")> _
Public ReadOnly Property Activities As Collection(Of Activity)

C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[DescriptionAttribute("Child activities.")]
public Collection<Activity> Activities { get; }

C++

J#

JScript

Property Value
Type: Collection
 The collection of activities for this workflow.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Workflow Class
Workflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Workflow.BookmarkCallback Property
[image]

Gets the callback method called when the workflow is resumed.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Bookmark callback method called when a bookmark is resumed.")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public ReadOnly Property BookmarkCallback As BookmarkCallback

C#
[DescriptionAttribute("Bookmark callback method called when a bookmark is resumed.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public BookmarkCallback BookmarkCallback { get; }

C++

J#

JScript

Property Value
Type: BookmarkCallback
The callback method called when the workflow is resumed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Workflow Class
Workflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Workflow.OnChildComplete Property
[image]

Gets the callback method called when a child of this sequence completes execution.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Completion callback method called when a child of this sequence completes execution.")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public ReadOnly Property OnChildComplete As CompletionCallback

C#
[DescriptionAttribute("Completion callback method called when a child of this sequence completes execution.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public CompletionCallback OnChildComplete { get; }

C++

J#

JScript

Property Value
Type: CompletionCallback
The callback method called when a child of this sequence completes execution.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Workflow Class
Workflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Workflow.Variables Property
[image]

Gets the collection of workflow variables.

Namespace: Microsoft.Xrm.Sdk.Workflow.Activities
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Workflow variables.")> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)> _
Public ReadOnly Property Variables As Collection(Of Variable)

C#
[DescriptionAttribute("Workflow variables.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public Collection<Variable> Variables { get; }

C++

J#

JScript

Property Value
Type: Collection
 The collection of workflow variables.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Workflow Class
Workflow Members
Microsoft.Xrm.Sdk.Workflow.Activities Namespace


Microsoft.Xrm.Sdk.Workflow.Designers Namespace

Classes

Class | Description
WorkflowDesigner | For internal use only.


WorkflowDesigner Class
See Also Members
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Designers
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Public NotInheritable Class WorkflowDesigner
    Inherits ActivityDesigner
    Implements IComponentConnector

C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
public sealed class WorkflowDesigner : ActivityDesigner, IComponentConnector

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Control

                System.Windows.Controls.ContentControl

                System.Activities.Presentation.WorkflowViewElement

                System.Activities.Presentation.ActivityDesigner
                    Microsoft.Xrm.Sdk.Workflow.Designers.WorkflowDesigner
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDesigner Members
Microsoft.Xrm.Sdk.Workflow.Designers Namespace


WorkflowDesigner Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

For internal use only.

The following tables list the members exposed by the WorkflowDesigner type.

Public Constructors

Name | Description
WorkflowDesigner | Initializes a new instance of the WorkflowDesigner class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | Collapsible | (inherited from WorkflowViewElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | Context | (inherited from WorkflowViewElement)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | ExpandState | (inherited from WorkflowViewElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from ActivityDesigner)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsRootDesigner | (inherited from WorkflowViewElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | ModelItem | (inherited from WorkflowViewElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | PinState | (inherited from WorkflowViewElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowExpanded | (inherited from WorkflowViewElement)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
Top

Protected Properties

 | Name | Description
protected property | CompositeViews | (inherited from WorkflowViewElement)
protected property | DefaultCompositeView | (inherited from WorkflowViewElement)
protected property | IsEnabledCore | (inherited from UIElement)
protected property | IsReadOnly | (inherited from WorkflowViewElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent | For internal use only.
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | Overridden. (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterCompositeView | (inherited from WorkflowViewElement)
public method | RegisterDefaultCompositeView | (inherited from WorkflowViewElement)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterCompositeView | (inherited from WorkflowViewElement)
public method | UnregisterDefaultCompositeView | (inherited from WorkflowViewElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetAutomationHelpText | Overridden. (inherited from WorkflowViewElement)
protected method | GetAutomationIdMemberName | Overridden. (inherited from WorkflowViewElement)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContentChanged | (inherited from ContentControl)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuLoaded | (inherited from WorkflowViewElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDragEnter | Overridden. (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | Overridden. (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | Overridden. (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | Overridden. (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnModelItemChanged | (inherited from WorkflowViewElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | Overridden. (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | Overridden. (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | Overridden. (inherited from WorkflowViewElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | Overridden. (inherited from UIElement)
protected method | OnPreviewDragLeave | Overridden. (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | Overridden. (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | Overridden. (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnReadOnlyChanged | (inherited from WorkflowViewElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnShowExpandedChanged | (inherited from WorkflowViewElement)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
Top

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

WorkflowDesigner Class
Microsoft.Xrm.Sdk.Workflow.Designers Namespace


WorkflowDesigner Constructor
[image]

Initializes a new instance of the WorkflowDesigner class.

Namespace: Microsoft.Xrm.Sdk.Workflow.Designers
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public WorkflowDesigner ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDesigner Class
WorkflowDesigner Members
Microsoft.Xrm.Sdk.Workflow.Designers Namespace


WorkflowDesigner Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent | For internal use only.
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | Overridden. (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterCompositeView | (inherited from WorkflowViewElement)
public method | RegisterDefaultCompositeView | (inherited from WorkflowViewElement)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterCompositeView | (inherited from WorkflowViewElement)
public method | UnregisterDefaultCompositeView | (inherited from WorkflowViewElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetAutomationHelpText | Overridden. (inherited from WorkflowViewElement)
protected method | GetAutomationIdMemberName | Overridden. (inherited from WorkflowViewElement)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContentChanged | (inherited from ContentControl)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuLoaded | (inherited from WorkflowViewElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDragEnter | Overridden. (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | Overridden. (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | Overridden. (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | Overridden. (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnModelItemChanged | (inherited from WorkflowViewElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | Overridden. (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | Overridden. (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | Overridden. (inherited from WorkflowViewElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | Overridden. (inherited from UIElement)
protected method | OnPreviewDragLeave | Overridden. (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | Overridden. (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | Overridden. (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnReadOnlyChanged | (inherited from WorkflowViewElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnShowExpandedChanged | (inherited from WorkflowViewElement)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

WorkflowDesigner Class
Microsoft.Xrm.Sdk.Workflow.Designers Namespace


WorkflowDesigner.InitializeComponent Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Designers
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent

C#
[DebuggerNonUserCodeAttribute]
public void InitializeComponent ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDesigner Class
WorkflowDesigner Members
Microsoft.Xrm.Sdk.Workflow.Designers Namespace


WorkflowDesigner.Connect Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Sdk.Workflow.Designers
Assembly: Microsoft.Xrm.Sdk.Workflow (in Microsoft.Xrm.Sdk.Workflow.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerNonUserCodeAttribute> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect

C#
[DebuggerNonUserCodeAttribute]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)

C++

J#

JScript

Parameters
connectionId
Type: Int32.
target
Type: Object.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
WorkflowDesigner Class
WorkflowDesigner Members
Microsoft.Xrm.Sdk.Workflow.Designers Namespace


WorkflowDesigner Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | Collapsible | (inherited from WorkflowViewElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | Context | (inherited from WorkflowViewElement)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | ExpandState | (inherited from WorkflowViewElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from ActivityDesigner)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsRootDesigner | (inherited from WorkflowViewElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | ModelItem | (inherited from WorkflowViewElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | PinState | (inherited from WorkflowViewElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowExpanded | (inherited from WorkflowViewElement)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)

Protected Properties

 | Name | Description
protected property | CompositeViews | (inherited from WorkflowViewElement)
protected property | DefaultCompositeView | (inherited from WorkflowViewElement)
protected property | IsEnabledCore | (inherited from UIElement)
protected property | IsReadOnly | (inherited from WorkflowViewElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

WorkflowDesigner Class
Microsoft.Xrm.Sdk.Workflow.Designers Namespace


WorkflowDesigner Events
[image]

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

WorkflowDesigner Class
Microsoft.Xrm.Sdk.Workflow.Designers Namespace


Microsoft.Xrm.Tooling.Connector Namespace

Classes

Class | Description
AttributeData | Summary description for AttributeData
BatchItemOrganizationRequest | Request object.
BooleanAttributeData |
CrmDataTypeWrapper | Contains a variable definition.
crmMessageInspector |
CrmServiceClient | Provides the low-level interaction and wrapper methods to connect to Microsoft Dynamics CRM and execute actions.
CrmFilterConditionItem | CRM Filter item.
CrmSearchFilter | Crm Filter class.
ImportFileItem | Describes an Individual Import Item.
ImportRequest | Describes an import request for CRM
PickListItem | PickList Item
PickListMetaElement | PickList data
DeviceIdManager | Management utility for the Device Id
DeviceRegistrationAuthentication | Internal Use only
DeviceRegistrationClientInfo | Internal Use only
DeviceRegistrationFailedException | Indicates that Device Registration failed
DeviceRegistrationRequest | Internal Use only
DeviceRegistrationResponse | Internal Use only
DeviceRegistrationResponseError | Internal Use only
DeviceUserName | Internal Use only
DynamicsFileLogTraceListener |
LiveDevice | Internal Use only
PicklistAttributeData |
RequestBatch | Container class for Batches.
StringAttributeData |
TraceControlSettings | This class provides an override for the default trace settings. These settings must be set before the components in the control are used for them to be effective.
XmlUtil |

Enumerations

Enumeration | Description
AuthenticationType | Decision switch for the sort of Auth to login to CRM with
BatchStatus | Status of the batch.
CrmFieldType | Allowed typelist of entities
FormTypeId | Used with GetFormIdsForEntity Call
DataDelimiterCode | Key used to delimit data in the import file
FieldDelimiterCode | Key used to delimit fields in the import file
FileTypeCode | Type if file described in the FileContentToImport
ImportMode | Mode of the Import, Update or Create
ImportStatus | ImportStatus Reasons
LogicalSearchOperator | Logical Search Pram to apply to over all search.
LogicalSortOrder | Logical Search Pram to apply to over all search.
DeviceRegistrationErrorCode | Indicates an error during registration


AttributeData Class
See Also Members
[image]

Summary description for AttributeData

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class AttributeData

C#
public class AttributeData

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.AttributeData

                Microsoft.Xrm.Tooling.Connector.BooleanAttributeData

                Microsoft.Xrm.Tooling.Connector.PicklistAttributeData

                Microsoft.Xrm.Tooling.Connector.StringAttributeData
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData Members
See Also Constructors Methods Properties
[image]

Summary description for AttributeData

The following tables list the members exposed by the AttributeData type.

Public Constructors

Name | Description
AttributeData | Initializes an instance of the AttributeData class.
Top

Public Properties

 | Name | Description
public property | ActualValue | Gets or sets the actual value for the attribute.
public property | AttributeLabel | Gets or sets the label for the attribute.
public property | AttributeType | Gets or sets the type for the attribute.
public property | DisplayValue | Gets or sets the display value for the attribute.
public property | IsUnsupported |
public property | SchemaName |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

AttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData Constructor
[image]

Initializes an instance of the AttributeData class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public AttributeData ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeData Class
AttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

AttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData Properties
[image]

Public Properties

 | Name | Description
public property | ActualValue | Gets or sets the actual value for the attribute.
public property | AttributeLabel | Gets or sets the label for the attribute.
public property | AttributeType | Gets or sets the type for the attribute.
public property | DisplayValue | Gets or sets the display value for the attribute.
public property | IsUnsupported |
public property | SchemaName |

See Also

Reference

AttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData.ActualValue Property
[image]

Gets or sets the actual value for the attribute.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ActualValue As Object

C#
public Object ActualValue { get; set; }

C++

J#

JScript

Property Value
Type: Object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeData Class
AttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData.AttributeLabel Property
[image]

Gets or sets the label for the attribute.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeLabel As String

C#
public string AttributeLabel { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeData Class
AttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData.AttributeType Property
[image]

Gets or sets the type for the attribute.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property AttributeType As AttributeTypeCode

C#
public AttributeTypeCode AttributeType { get; set; }

C++

J#

JScript

Property Value
Type: AttributeTypeCode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeData Class
AttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData.DisplayValue Property
[image]

Gets or sets the display value for the attribute.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DisplayValue As String

C#
public string DisplayValue { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeData Class
AttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData.IsUnsupported Property
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IsUnsupported As Boolean

C#
public bool IsUnsupported { get; set; }

C++

J#

JScript

Property Value
Type: Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeData Class
AttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


AttributeData.SchemaName Property
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SchemaName As String

C#
public string SchemaName { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
AttributeData Class
AttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


AuthenticationType Enumeration
[image]

Decision switch for the sort of Auth to login to CRM with

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration AuthenticationType

C#
public enum AuthenticationType

C++

J#

JScript

  Members
Member name | Description
AD | Active Directory Auth
Claims | CLAIMS based Auth
IFD | SPLA Auth
Live | Live Auth
Office365 | Office365 base login process
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector Namespace


BatchItemOrganizationRequest Class
See Also Members
[image]

Request object.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class BatchItemOrganizationRequest

C#
public sealed class BatchItemOrganizationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.BatchItemOrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BatchItemOrganizationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


BatchItemOrganizationRequest Members
See Also Constructors Methods Properties
[image]

Request object.

The following tables list the members exposed by the BatchItemOrganizationRequest type.

Public Constructors

Name | Description
BatchItemOrganizationRequest |
Top

Public Properties

 | Name | Description
public property | Request | Organization Service request for the batch
public property | RequestDebugMessage | Request debug Message.
public property | RequestReferenceNumber | Reference Correlation ID
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BatchItemOrganizationRequest Class
Microsoft.Xrm.Tooling.Connector Namespace


BatchItemOrganizationRequest Constructor
[image]

Initializes a new instance of the BatchItemOrganizationRequest Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BatchItemOrganizationRequest ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BatchItemOrganizationRequest Class
BatchItemOrganizationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


BatchItemOrganizationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BatchItemOrganizationRequest Class
Microsoft.Xrm.Tooling.Connector Namespace


BatchItemOrganizationRequest Properties
[image]

Public Properties

 | Name | Description
public property | Request | Organization Service request for the batch
public property | RequestDebugMessage | Request debug Message.
public property | RequestReferenceNumber | Reference Correlation ID

See Also

Reference

BatchItemOrganizationRequest Class
Microsoft.Xrm.Tooling.Connector Namespace


BatchItemOrganizationRequest.Request Property
[image]

Organization Service request for the batch

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Request As OrganizationRequest

C#
public OrganizationRequest Request { get; set; }

C++

J#

JScript

Property Value
Type: OrganizationRequest.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BatchItemOrganizationRequest Class
BatchItemOrganizationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


BatchItemOrganizationRequest.RequestDebugMessage Property
[image]

Request debug Message.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RequestDebugMessage As String

C#
public string RequestDebugMessage { get; set; }

C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BatchItemOrganizationRequest Class
BatchItemOrganizationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


BatchItemOrganizationRequest.RequestReferenceNumber Property
[image]

Reference Correlation ID

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RequestReferenceNumber As Guid

C#
public Guid RequestReferenceNumber { get; set; }

C++

J#

JScript

Property Value
Type: Guid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BatchItemOrganizationRequest Class
BatchItemOrganizationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


BatchStatus Enumeration
[image]

Status of the batch.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration BatchStatus

C#
public enum BatchStatus

C++

J#

JScript

  Members
Member name | Description
Complete | Batch has completed.
Running | Batch is currently executing
Waiting | Batch is waiting to be run
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector Namespace


BooleanAttributeData Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class BooleanAttributeData
    Inherits AttributeData

C#
public sealed class BooleanAttributeData : AttributeData

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Tooling.Connector.AttributeData
    Microsoft.Xrm.Tooling.Connector.BooleanAttributeData
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BooleanAttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


BooleanAttributeData Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the BooleanAttributeData type.

Public Constructors

Name | Description
BooleanAttributeData |
Top

Public Properties

 | Name | Description
public property | ActualValue | Gets or sets the actual value for the attribute. (inherited from AttributeData)
public property | AttributeLabel | Gets or sets the label for the attribute. (inherited from AttributeData)
public property | AttributeType | Gets or sets the type for the attribute. (inherited from AttributeData)
public property | BooleanOptions |
public property | DisplayValue | Gets or sets the display value for the attribute. (inherited from AttributeData)
public property | IsUnsupported | (inherited from AttributeData)
public property | SchemaName | (inherited from AttributeData)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

BooleanAttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


BooleanAttributeData Constructor
[image]

Initializes a new instance of the BooleanAttributeData Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public BooleanAttributeData ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BooleanAttributeData Class
BooleanAttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


BooleanAttributeData Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

BooleanAttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


BooleanAttributeData Properties
[image]

Public Properties

 | Name | Description
public property | ActualValue | Gets or sets the actual value for the attribute. (inherited from AttributeData)
public property | AttributeLabel | Gets or sets the label for the attribute. (inherited from AttributeData)
public property | AttributeType | Gets or sets the type for the attribute. (inherited from AttributeData)
public property | BooleanOptions |
public property | DisplayValue | Gets or sets the display value for the attribute. (inherited from AttributeData)
public property | IsUnsupported | (inherited from AttributeData)
public property | SchemaName | (inherited from AttributeData)

See Also

Reference

BooleanAttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


BooleanAttributeData.BooleanOptions Property
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BooleanOptions As OptionMetadata()

C#
public OptionMetadata[] BooleanOptions { get; set; }

C++

J#

JScript

Property Value
Type: OptionMetadata.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
BooleanAttributeData Class
BooleanAttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper Class
See Also Members
[image]

Contains a variable definition.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class CrmDataTypeWrapper

C#
public class CrmDataTypeWrapper

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.CrmDataTypeWrapper
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmDataTypeWrapper Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper Members
See Also Constructors Methods Properties
[image]

Contains a variable definition.

The following tables list the members exposed by the CrmDataTypeWrapper type.

Public Constructors

Name | Description
CrmDataTypeWrapper | Overloaded.
Top

Public Properties

 | Name | Description
public property | ReferencedEntity | Gets or sets the name of the referenced entity.
public property | Type | Value Type.
public property | Value | Gets or sets the value to set.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CrmDataTypeWrapper Class
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper Constructor
[image]

Overload List

Name | Description
CrmDataTypeWrapper () | Initializes a new instance of the CrmDataTypeWrapper class.
CrmDataTypeWrapper (Object, CrmFieldType) | Initializes a new instance of the CrmDataTypeWrapper class using the type of data to set.
CrmDataTypeWrapper (Object, CrmFieldType, String) | Initializes a new instance of the CrmDataTypeWrapper class using the type of data and the related entity name.

See Also

Reference

CrmDataTypeWrapper Class
CrmDataTypeWrapper Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper Constructor ()
[image]

Initializes a new instance of the CrmDataTypeWrapper class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmDataTypeWrapper ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmDataTypeWrapper Class
CrmDataTypeWrapper Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper Constructor (Object, CrmFieldType)
[image]

Initializes a new instance of the CrmDataTypeWrapper class using the type of data to set.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    data As Object, _
    crmFieldType As CrmFieldType _
)

C#
public CrmDataTypeWrapper (
    Object data,
    CrmFieldType crmFieldType
)

C++

J#

JScript

Parameters
data
Indicates the data to set
crmFieldType
Type of data to set.
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmDataTypeWrapper Class
CrmDataTypeWrapper Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper Constructor (Object, CrmFieldType, String)
[image]

Initializes a new instance of the CrmDataTypeWrapper class using the type of data and the related entity name.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    data As Object, _
    crmFieldType As CrmFieldType, _
    relatedEntityName As String _
)

C#
public CrmDataTypeWrapper (
    Object data,
    CrmFieldType crmFieldType,
    string relatedEntityName
)

C++

J#

JScript

Parameters
data
Indicates the data to set.
crmFieldType
Type of data to set.
relatedEntityName
Gets or sets the name of the related entity; applies to the Field Types: Customer and Lookup.
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmDataTypeWrapper Class
CrmDataTypeWrapper Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmDataTypeWrapper Class
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper Properties
[image]

Public Properties

 | Name | Description
public property | ReferencedEntity | Gets or sets the name of the referenced entity.
public property | Type | Value Type.
public property | Value | Gets or sets the value to set.

See Also

Reference

CrmDataTypeWrapper Class
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper.ReferencedEntity Property
[image]

Gets or sets the name of the referenced entity.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReferencedEntity As String

C#
public string ReferencedEntity { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmDataTypeWrapper Class
CrmDataTypeWrapper Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper.Type Property
[image]

Value Type.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Type As CrmFieldType

C#
public CrmFieldType Type { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmDataTypeWrapper Class
CrmDataTypeWrapper Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmDataTypeWrapper.Value Property
[image]

Gets or sets the value to set.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Value As Object

C#
public Object Value { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmDataTypeWrapper Class
CrmDataTypeWrapper Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmFieldType Enumeration
[image]

Allowed typelist of entities

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration CrmFieldType

C#
public enum CrmFieldType

C++

J#

JScript

  Members
Member name | Description
CrmBoolean | Bool - Converts from bool
CrmDateTime | DateTime - Converts from a DataTime Object
CrmDecimal | Decimal, for money, use CrmMoney - Converts from a decimal type
CrmFloat | Double type, while CRM calls this a float, it is actually a double for money, use CrmMoney - Converts from a double type
CrmMoney | Money Type - Converts from a decimal type
CrmNumber | CRM whole number - Converts from a Int type
Customer | Ref Type for CRM, Creates an EntityReference You need to provide a Guid as a value, and a the name of an entity for the lookup key
Key | Primary Key - Converts from a Guid Type
Lookup | Ref Type for CRM, Creates an EntityReference You need to provide a Guid as a value, and a the name of an entity for the lookup key
Picklist | Pick List value - Converts from a Int type
Raw | User Specified type... will be appended directly. This type must be one of the valid CRM 2011 types
String | String type - Converts from a string type.
UniqueIdentifier | Guid Type - Converts from a Guid Type
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector Namespace


crmMessageInspector Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class crmMessageInspector
    Implements IClientMessageInspector

C#
public class crmMessageInspector : IClientMessageInspector

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.crmMessageInspector
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
crmMessageInspector Members
Microsoft.Xrm.Tooling.Connector Namespace


crmMessageInspector Members
See Also Constructors Methods
[image]

The following tables list the members exposed by the crmMessageInspector type.

Public Constructors

Name | Description
crmMessageInspector |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AfterReceiveReply |
public method | BeforeSendRequest |
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

crmMessageInspector Class
Microsoft.Xrm.Tooling.Connector Namespace


crmMessageInspector Constructor
[image]

Initializes a new instance of the crmMessageInspector Class.Initializes a new instance of the crmMessageInspector Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public crmMessageInspector ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
crmMessageInspector Class
crmMessageInspector Members
Microsoft.Xrm.Tooling.Connector Namespace


crmMessageInspector Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AfterReceiveReply |
public method | BeforeSendRequest |
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

crmMessageInspector Class
Microsoft.Xrm.Tooling.Connector Namespace


crmMessageInspector.AfterReceiveReply Method
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub AfterReceiveReply ( _
    ByRef reply As Message, _
    correlationState As Object _
)

C#
public void AfterReceiveReply (
    ref Message reply,
    Object correlationState
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
crmMessageInspector Class
crmMessageInspector Members
Microsoft.Xrm.Tooling.Connector Namespace


crmMessageInspector.BeforeSendRequest Method
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function BeforeSendRequest ( _
    ByRef request As Message, _
    channel As IClientChannel _
) As Object

C#
public Object BeforeSendRequest (
    ref Message request,
    IClientChannel channel
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
crmMessageInspector Class
crmMessageInspector Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient Class
See Also Members
[image]

Provides the low-level interaction and wrapper methods to connect to Microsoft Dynamics CRM and execute actions.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CrmServiceClient

C#
public sealed class CrmServiceClient

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.CrmServiceClient
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace
Other Resources
Build windows client applications using the XRM tools


CrmServiceClient Members
See Also Constructors Methods Properties
[image]

Provides the low-level interaction and wrapper methods to connect to Microsoft Dynamics CRM and execute actions.

The following tables list the members exposed by the CrmServiceClient type.

Public Constructors

Name | Description
CrmServiceClient | Overloaded.
Top

Public Properties

 | Name | Description
public property | ConnectedOrgFriendlyName | Gets the friendly name of the organization that you are connected to.
public property | ConnectedOrgPublishedEndpoints | Gets the endpoint collection for the organization you are connected to.
public property | ConnectedOrgUniqueName | Get the unique name of the organization you are connected to.
public property | ConnectedOrgVersion | Gets the version number of the organization you are connected to. If accessed before you are connected to an organization, null or 0.0 is returned.
public property | ConnectionLockObject | Gets the connection lock object that is used to control connection access for various threads. This should be used to lock the connection if you are using the Microsoft Dynamics CRM queries via LINQ.
public property | CrmConnectOrgUriActual | Gets the actual URI used to connect to Microsoft Dynamics CRM. This URI could be influenced by user defined variables.
public property | IsBatchOperationsAvailable | Gets information about the availability of batch operation. If true, batch operations are available.
public property | IsReady | Gets the service connection status. If true, the service is ready to accept requests.
public property | LastCrmError | Gets the last error that occurred while attempting to connect to Microsoft Dynamics CRM.
public property | LastCrmException | Gets the last exception that occurred while attempting to connect to Microsoft Dynamics CRM.
public property | OrganizationServiceProxy | Gets the native Microsoft Dynamics CRM organization service.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddEntityToQueue | Route an entity to a public queue.
public method | AssignEntityToUser | Assign an Entity to the specified user ID
public method | CancelSalesOrder | Cancel Sales order
public method | CloseActivity | Closes the Activity type specified. The Activity Entity type supports fax , letter , and phonecall*Note: This will default to using English names for Status. if you need to use Non-English, you should populate the names for completed for the status and state.
public method | CloseIncident | Closes an Incident request in CRM, this special handling is necessary to support CRM Built In Object.
public method | CloseOpportunity | This will close an opportunity as either Won or lost in CRM
public method | CloseQuote | Closes a quote as won or lost, Revise is not supported via this method
public method | CloseTroubleTicket | Closes a Trouble ticket by ID
public method | CreateAnnotation | This creates a annotation [note] entry, related to a an existing entityRequired Properties in the fieldListnotetext (string) = Text of the note,subject (string) = this is the title of the note
public method | CreateBatchOperationRequest | Create a Batch Request for executing batch operations. This returns an ID that will be used to identify a request as a batch request vs a "normal" request.
public method | CreateEntityAssociation | Associates one Entity to another where an M2M Relationship Exists.
public method | CreateMultiEntityAssociation | Associates multiple entities of the same time to a single entity
public method | CreateNewActivityEntry | Creates a new activity against the target entity type
public method | CreateNewRecord | Uses the dynamic entity patter to create a new entity
public method | CreateOrUpdatePickListElement | Adds an option to a pick list on an entity.
public method | DeleteEntity | Deletes an entity from the CRM
public method | DeleteEntityAssociation | Removes the Association between 2 entity items where an M2M Relationship Exists.
 | DiscoverOrganizations | Overloaded.
public method | Equals | (inherited from Object)
public method | ExecuteBatch | Begins running the Batch command.
public method | ExecuteCrmEntityDeleteRequest | Executes a row level delete on a CRM entity ( thread safe ) and returns true or false. Also adds metrics for logging support.
public method | ExecuteCrmOrganizationRequest | Executes a CRM Organization Request (thread safe) and returns the organization response object. Also adds metrics for logging support.
public method | ExecuteWorkflowOnEntity | Executes a named workflow on an object.
public method | GetActivitiesBy | Overloaded.
public method | GetAllAttributesForEntity | Returns all attributes on a entity
public method | GetAllEntityMetadata | Returns a list of entities with basic data from CRM
public method | GetBatchById | TEMP
public method | GetBatchOperationIdRequestByName | Returns the batch id for a given batch name.
public method | GetBatchRequestAtPosition | Returns the organization request at a give position
public method | GetDataByKeyFromResultsSet | This function gets data from a Dictionary object, where "string" identifies the field name, and Object contains the data, this method then attempts to cast the result to the Type requested, if it cannot be cast an empty object is returned.
public method | GetEntityAttributeMetadataForAttribute | Gets metadata for a specific entity's attribute.
public method | GetEntityDataByFetchSearch | Overloaded.
public method | GetEntityDataByFetchSearchEC | Overloaded.
public method | GetEntityDataById | Gets a List of variables from the account based on the list of field specified in the Fields List
public method | GetEntityDataByLinkedSearch | Overloaded.
public method | GetEntityDataByRollup | Overloaded.
public method | GetEntityDataBySearchParams | Overloaded.
public method | GetEntityDisplayName | Gets an Entity Name by Logical name or Type code.
public method | GetEntityDisplayNamePlural | Gets an Entity Name by Logical name or Type code.
public method | GetEntityFormIdListByType | Returns the Form Entity References for a given form type.
public method | GetEntityMetadata | Returns the Metadata for an entity from CRM, defaults to basic data only.
public method | GetEntityName | Returns the Entity name for the given Type code
public method | GetEntityTypeCode | Gets the typecode of an entity by name.
public method | GetGlobalOptionSetMetadata | Gets a global option set from CRM.
public method | GetHashCode | (inherited from Object)
public method | GetMyCrmUserId | Gets the user ID of the currently logged in user.
public method | GetPickListElementFromMetadataEntity | Gets a PickList, Status List or StateList from the metadata of an attribute
public method | GetType | (inherited from Object)
public method | ImportDataMapToCrm | Used to upload a data map to the CRM
public method | ImportSolutionToCrm | Imports a CRM solution to the CRM Server currently connected.*** Note: this is a blocking call and will take time to Import to CRM ***
public method | InstallSampleDataToCrm | Request CRM to install sample data shipped with CRM. Note this is process will take a few moments to execute.This method will return once the request has been submitted.
public method | IsSampleDataInstalled | Determines if the CRM sample data has been installed
 | MakeSecureString | Makes a secure string
public method | PublishEntity | Publishes an entity to the production system, used in conjunction with the Metadata services.
public method | ReleaseBatchInfoById | Release a batch from the stack Once you have completed using a batch, you must release it from the system.
public method | ResetLocalMetadataCache | This will clear the Metadata cache for either all entities or the specified entity
public method | RetrieveBatchResponse |
public method | SendSingleEmail | Sends an email.
public method | SubmitImportRequest | Starts an Import request for CRM.Supports a single file per Import request.
public method | ToString | (inherited from Object)
public method | UninstallSampleDataFromCrm | Request CRM to remove sample data shipped with CRM. Note this is process will take a few moments to execute. This method will return once the request has been submitted.
public method | UpdateEntity | Generic update entity
public method | UpdateStateAndStatusForEntity | Overloaded.
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CrmServiceClient Class
Microsoft.Xrm.Tooling.Connector Namespace

Other Resources

Build windows client applications using the XRM tools


CrmServiceClient Constructor
[image]

Overload List

Name | Description
CrmServiceClient (OrganizationServiceProxy) | Initializes a new instance of the CrmServiceClient class using the Organization service proxy provided by the user.
CrmServiceClient (NetworkCredential, AuthenticationType, String, String, String, Boolean, Boolean, OrganizationDetail) | Initializes a new instance of the CrmServiceClient class using the specified network credentials and authentication type as AD or SPLA.
CrmServiceClient (NetworkCredential, String, String, String, Boolean, Boolean, OrganizationDetail) | Initializes a new instance of the CrmServiceClient class using the specified network credentials and Active Directory authentication.
CrmServiceClient (String, SecureString, String, String, Boolean, Boolean, OrganizationDetail, Boolean) | Initializes a new instance of the CrmServiceClient class using the specified network credentials and authentication type as Windows Live or Office 365.
CrmServiceClient (String, SecureString, String, String, String, String, String, Boolean, Boolean, OrganizationDetail) | Initializes a new instance of the CrmServiceClient class using the specified network credentials and claims-based authentication.

See Also

Reference

CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient Constructor (OrganizationServiceProxy)
[image]

Initializes a new instance of the CrmServiceClient class using the Organization service proxy provided by the user.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    externalOrgServiceProxy As OrganizationServiceProxy _
)

C#
public CrmServiceClient (
    OrganizationServiceProxy externalOrgServiceProxy
)

C++

J#

JScript

Parameters
externalOrgServiceProxy
Organization service proxy provided by the user.
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient Constructor (NetworkCredential, AuthenticationType, String, String, String, Boolean, Boolean, OrganizationDetail)
[image]

Initializes a new instance of the CrmServiceClient class using the specified network credentials and authentication type as AD or SPLA.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    credential As NetworkCredential, _
    authType As AuthenticationType, _
    hostName As String, _
    port As String, _
    orgName As String, _
    <OptionalAttribute> Optional useUniqueInstance As Boolean = False, _
    <OptionalAttribute> Optional useSsl As Boolean = False, _
    <OptionalAttribute> Optional orgDetail As OrganizationDetail = Nothing _
)

C#
public CrmServiceClient (
    NetworkCredential credential,
    AuthenticationType authType,
    string hostName,
    string port,
    string orgName,
    [OptionalAttribute] bool useUniqueInstance,
    [OptionalAttribute] bool useSsl,
    [OptionalAttribute] OrganizationDetail orgDetail
)

C++

J#

JScript

Parameters
credential
Initialized network credential object to sign in to Microsoft Dynamics CRM.
authType
Authentication type requested. Supported values are: AD or SPLA.
hostName
Name of the server that hosts the Microsoft Dynamics CRM web or discovery service.
port
Port number on the server that hosts the Microsoft Dynamics CRM web or discovery service (usually 5555).
orgName
Organization name that you want to connect to.
useUniqueInstance
Optional. Indicates whether to reuse an existing connection, if recalled while the connection is still active. Default is false. If set to true, will force the system to create a unique connection.
orgDetail
Optional. Defaults to null. If set, this is returned from a query to the Discovery service, and is generally used as the second leg of an organization selection process.
useSsl
Optional. Indicates whether to use SSL to connect to Microsoft Dynamics CRM. Defaults to false, that is, uses http://. If set to true, uses https://.
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace
Other Resources
Use XRM Tooling API to connect to CRM


CrmServiceClient Constructor (NetworkCredential, String, String, String, Boolean, Boolean, OrganizationDetail)
[image]

Initializes a new instance of the CrmServiceClient class using the specified network credentials and Active Directory authentication.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    credential As NetworkCredential, _
    hostName As String, _
    port As String, _
    orgName As String, _
    <OptionalAttribute> Optional useUniqueInstance As Boolean = False, _
    <OptionalAttribute> Optional useSsl As Boolean = False, _
    <OptionalAttribute> Optional orgDetail As OrganizationDetail = Nothing _
)

C#
public CrmServiceClient (
    NetworkCredential credential,
    string hostName,
    string port,
    string orgName,
    [OptionalAttribute] bool useUniqueInstance,
    [OptionalAttribute] bool useSsl,
    [OptionalAttribute] OrganizationDetail orgDetail
)

C++

J#

JScript

Parameters
credential
Initialized network credential object to sign in to Microsoft Dynamics CRM.
hostName
Name of the server that hosts the Microsoft Dynamics CRM web service.
port
Port number on the server that hosts the Microsoft Dynamics CRM web service.
orgName
Organization name that you want to connect to.
useUniqueInstance
Optional. Indicates whether to reuse an existing connection, if recalled while the connection is still active. Default is false. If set to true, will force the system to create a unique connection.
orgDetail
Optional. Defaults to null. If set, this is returned from a query to the Discovery service, and is generally used as the second leg of an organization selection process.
useSsl
Optional. Indicates whether to use SSL to connect to Microsoft Dynamics CRM. Defaults to false, that is, uses http://. If set to true, uses https://.
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient Constructor (String, SecureString, String, String, Boolean, Boolean, OrganizationDetail, Boolean)
[image]

Initializes a new instance of the CrmServiceClient class using the specified network credentials and authentication type as Windows Live or Office 365.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    crmUserId As String, _
    crmPassword As SecureString, _
    crmRegion As String, _
    orgName As String, _
    <OptionalAttribute> Optional useUniqueInstance As Boolean = False, _
    <OptionalAttribute> Optional useSsl As Boolean = False, _
    <OptionalAttribute> Optional orgDetail As OrganizationDetail = Nothing, _
    <OptionalAttribute> Optional isOffice365 As Boolean = False _
)

C#
public CrmServiceClient (
    string crmUserId,
    SecureString crmPassword,
    string crmRegion,
    string orgName,
    [OptionalAttribute] bool useUniqueInstance,
    [OptionalAttribute] bool useSsl,
    [OptionalAttribute] OrganizationDetail orgDetail,
    [OptionalAttribute] bool isOffice365
)

C++

J#

JScript

Parameters
crmUserId
User name for Live or Office 365.
crmPassword
Password for Live or Office 365.
crmRegion
Region for the CRM Online or office 365 server. Valid values are NorthAmerica, EMEA, APAC, and SouthAmerica. If empty, search will be run for servers in all the regions.
orgName
Organization name that you want to connect to.
useUniqueInstance
Optional. Indicates whether to reuse an existing connection, if recalled while the connection is still active. Default is false. If set to true, will force the system to create a unique connection.
useSsl
Optional. Indicates whether to use SSL to connect to Microsoft Dynamics CRM. Defaults to false, that is, uses http://. If set to true, uses https://.
orgDetail
Optional. Defaults to null. If set, this is returned from a query to the Discovery service, and is generally used as the second leg of an organization selection process.
isOffice365
Indicates whether to use Office 365 authentication. If true, uses office 365 authentication.
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace
Other Resources
Build windows client applications using the XRM tools


CrmServiceClient Constructor (String, SecureString, String, String, String, String, String, Boolean, Boolean, OrganizationDetail)
[image]

Initializes a new instance of the CrmServiceClient class using the specified network credentials and claims-based authentication.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    userId As String, _
    password As SecureString, _
    domain As String, _
    homeRealm As String, _
    hostName As String, _
    port As String, _
    orgName As String, _
    <OptionalAttribute> Optional useUniqueInstance As Boolean = False, _
    <OptionalAttribute> Optional useSsl As Boolean = False, _
    <OptionalAttribute> Optional orgDetail As OrganizationDetail = Nothing _
)

C#
public CrmServiceClient (
    string userId,
    SecureString password,
    string domain,
    string homeRealm,
    string hostName,
    string port,
    string orgName,
    [OptionalAttribute] bool useUniqueInstance,
    [OptionalAttribute] bool useSsl,
    [OptionalAttribute] OrganizationDetail orgDetail
)

C++

J#

JScript

Parameters
userId
User ID to sign in.
password
Password to sign in.
domain
Domain name to use for signing in.
homeRealm
Home realm of the user.
hostName
Name of the server that hosts the Microsoft Dynamics CRM web or discovery service.
port
Port number on the server that hosts the Microsoft Dynamics CRM web or discovery service (usually 5555).
orgName
Organization name that you want to connect to.
useUniqueInstance
Optional. Indicates whether to reuse an existing connection, if recalled while the connection is still active. Default is false. If set to true, will force the system to create a unique connection.
useSsl
Optional. Indicates whether to use SSL to connect to Microsoft Dynamics CRM. Defaults to false, that is, uses http://. If set to true, uses https://.
orgDetail
Optional. Defaults to null. If set, this is returned from a query to the Discovery service, and is generally used as the second leg of an organization selection process.
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace
Other Resources
Build windows client applications using the XRM tools


CrmServiceClient Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddEntityToQueue | Route an entity to a public queue.
public method | AssignEntityToUser | Assign an Entity to the specified user ID
public method | CancelSalesOrder | Cancel Sales order
public method | CloseActivity | Closes the Activity type specified. The Activity Entity type supports fax , letter , and phonecall*Note: This will default to using English names for Status. if you need to use Non-English, you should populate the names for completed for the status and state.
public method | CloseIncident | Closes an Incident request in CRM, this special handling is necessary to support CRM Built In Object.
public method | CloseOpportunity | This will close an opportunity as either Won or lost in CRM
public method | CloseQuote | Closes a quote as won or lost, Revise is not supported via this method
public method | CloseTroubleTicket | Closes a Trouble ticket by ID
public method | CreateAnnotation | This creates a annotation [note] entry, related to a an existing entityRequired Properties in the fieldListnotetext (string) = Text of the note,subject (string) = this is the title of the note
public method | CreateBatchOperationRequest | Create a Batch Request for executing batch operations. This returns an ID that will be used to identify a request as a batch request vs a "normal" request.
public method | CreateEntityAssociation | Associates one Entity to another where an M2M Relationship Exists.
public method | CreateMultiEntityAssociation | Associates multiple entities of the same time to a single entity
public method | CreateNewActivityEntry | Creates a new activity against the target entity type
public method | CreateNewRecord | Uses the dynamic entity patter to create a new entity
public method | CreateOrUpdatePickListElement | Adds an option to a pick list on an entity.
public method | DeleteEntity | Deletes an entity from the CRM
public method | DeleteEntityAssociation | Removes the Association between 2 entity items where an M2M Relationship Exists.
 | DiscoverOrganizations | Overloaded.
public method | Equals | (inherited from Object)
public method | ExecuteBatch | Begins running the Batch command.
public method | ExecuteCrmEntityDeleteRequest | Executes a row level delete on a CRM entity ( thread safe ) and returns true or false. Also adds metrics for logging support.
public method | ExecuteCrmOrganizationRequest | Executes a CRM Organization Request (thread safe) and returns the organization response object. Also adds metrics for logging support.
public method | ExecuteWorkflowOnEntity | Executes a named workflow on an object.
public method | GetActivitiesBy | Overloaded.
public method | GetAllAttributesForEntity | Returns all attributes on a entity
public method | GetAllEntityMetadata | Returns a list of entities with basic data from CRM
public method | GetBatchById | TEMP
public method | GetBatchOperationIdRequestByName | Returns the batch id for a given batch name.
public method | GetBatchRequestAtPosition | Returns the organization request at a give position
public method | GetDataByKeyFromResultsSet | This function gets data from a Dictionary object, where "string" identifies the field name, and Object contains the data, this method then attempts to cast the result to the Type requested, if it cannot be cast an empty object is returned.
public method | GetEntityAttributeMetadataForAttribute | Gets metadata for a specific entity's attribute.
public method | GetEntityDataByFetchSearch | Overloaded.
public method | GetEntityDataByFetchSearchEC | Overloaded.
public method | GetEntityDataById | Gets a List of variables from the account based on the list of field specified in the Fields List
public method | GetEntityDataByLinkedSearch | Overloaded.
public method | GetEntityDataByRollup | Overloaded.
public method | GetEntityDataBySearchParams | Overloaded.
public method | GetEntityDisplayName | Gets an Entity Name by Logical name or Type code.
public method | GetEntityDisplayNamePlural | Gets an Entity Name by Logical name or Type code.
public method | GetEntityFormIdListByType | Returns the Form Entity References for a given form type.
public method | GetEntityMetadata | Returns the Metadata for an entity from CRM, defaults to basic data only.
public method | GetEntityName | Returns the Entity name for the given Type code
public method | GetEntityTypeCode | Gets the typecode of an entity by name.
public method | GetGlobalOptionSetMetadata | Gets a global option set from CRM.
public method | GetHashCode | (inherited from Object)
public method | GetMyCrmUserId | Gets the user ID of the currently logged in user.
public method | GetPickListElementFromMetadataEntity | Gets a PickList, Status List or StateList from the metadata of an attribute
public method | GetType | (inherited from Object)
public method | ImportDataMapToCrm | Used to upload a data map to the CRM
public method | ImportSolutionToCrm | Imports a CRM solution to the CRM Server currently connected.*** Note: this is a blocking call and will take time to Import to CRM ***
public method | InstallSampleDataToCrm | Request CRM to install sample data shipped with CRM. Note this is process will take a few moments to execute.This method will return once the request has been submitted.
public method | IsSampleDataInstalled | Determines if the CRM sample data has been installed
 | MakeSecureString | Makes a secure string
public method | PublishEntity | Publishes an entity to the production system, used in conjunction with the Metadata services.
public method | ReleaseBatchInfoById | Release a batch from the stack Once you have completed using a batch, you must release it from the system.
public method | ResetLocalMetadataCache | This will clear the Metadata cache for either all entities or the specified entity
public method | RetrieveBatchResponse |
public method | SendSingleEmail | Sends an email.
public method | SubmitImportRequest | Starts an Import request for CRM.Supports a single file per Import request.
public method | ToString | (inherited from Object)
public method | UninstallSampleDataFromCrm | Request CRM to remove sample data shipped with CRM. Note this is process will take a few moments to execute. This method will return once the request has been submitted.
public method | UpdateEntity | Generic update entity
public method | UpdateStateAndStatusForEntity | Overloaded.

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmServiceClient Class
Microsoft.Xrm.Tooling.Connector Namespace

Other Resources

Build windows client applications using the XRM tools


CrmServiceClient.AddEntityToQueue Method
[image]

Route an entity to a public queue.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function AddEntityToQueue ( _
    entityId As Guid, _
    entityName As String, _
    queueName As String, _
    workingUserId As Guid, _
    <OptionalAttribute> Optional setWorkingByUser As Boolean = False, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool AddEntityToQueue (
    Guid entityId,
    string entityName,
    string queueName,
    Guid workingUserId,
    [OptionalAttribute] bool setWorkingByUser,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entityId
ID of the entity to route.
entityName
Name of the entity for the specified ID.
queueName
Name of the queue to route the entity to.
workingUserId
ID of the user to set as the working system user.
setWorkingByUser
if true Set the worked by when doing the assign
batchId
Optional. If set to a valid GUID (generated by CreateBatchOperationRequest), will assign the request to the batch for later execution. Otherwise, runs the request immediately.
Return Value
true on success. Otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.AssignEntityToUser Method
[image]

Assign an Entity to the specified user ID

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function AssignEntityToUser ( _
    userId As Guid, _
    entityName As String, _
    entityId As Guid, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool AssignEntityToUser (
    Guid userId,
    string entityName,
    Guid entityId,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
userId
User ID to assign too
entityName
Target entity Name
entityId
Target entity id
batchId
Batch ID of to use, Optional
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CancelSalesOrder Method
[image]

Cancel Sales order

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CancelSalesOrder ( _
    salesOrderId As Guid, _
    fieldList As Dictionary(Of String, CrmDataTypeWrapper), _
    <OptionalAttribute> Optional orderStatusCode As Integer = 4, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Guid

C#
public Guid CancelSalesOrder (
    Guid salesOrderId,
    Dictionary<string,CrmDataTypeWrapper> fieldList,
    [OptionalAttribute] int orderStatusCode,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
salesOrderId
Sales order id to close
fieldList
List of fields to add
orderStatusCode
Status code of the order
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CloseActivity Method
[image]

Closes the Activity type specified. The Activity Entity type supports fax , letter , and phonecall *Note: This will default to using English names for Status. if you need to use Non-English, you should populate the names for completed for the status and state.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CloseActivity ( _
    activityEntityType As String, _
    activityId As Guid, _
    <OptionalAttribute> Optional stateCode As String = "completed", _
    <OptionalAttribute> Optional statusCode As String = "completed", _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool CloseActivity (
    string activityEntityType,
    Guid activityId,
    [OptionalAttribute] string stateCode,
    [OptionalAttribute] string statusCode,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
activityEntityType
Type of Activity you would like to close.. Supports fax, letter, phonecall
activityId
ID of the Activity you want to close
stateCode
State Code configured on the activity
statusCode
Status code on the activity
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
true if success false if not.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CloseIncident Method
[image]

Closes an Incident request in CRM, this special handling is necessary to support CRM Built In Object.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CloseIncident ( _
    incidentId As Guid, _
    fieldList As Dictionary(Of String, CrmDataTypeWrapper), _
    <OptionalAttribute> Optional incidentStatusCode As Integer = 5, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Guid

C#
public Guid CloseIncident (
    Guid incidentId,
    Dictionary<string,CrmDataTypeWrapper> fieldList,
    [OptionalAttribute] int incidentStatusCode,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
incidentId
ID of the CRM Incident to close
fieldList
List of data items to add to the request, By default, subject is required.
incidentStatusCode
Status code to close the incident with, defaults to resolved
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
Guid of the Activity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CloseOpportunity Method
[image]

This will close an opportunity as either Won or lost in CRM

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CloseOpportunity ( _
    opportunityId As Guid, _
    fieldList As Dictionary(Of String, CrmDataTypeWrapper), _
    <OptionalAttribute> Optional opportunityStatusCode As Integer = 3, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Guid

C#
public Guid CloseOpportunity (
    Guid opportunityId,
    Dictionary<string,CrmDataTypeWrapper> fieldList,
    [OptionalAttribute] int opportunityStatusCode,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
opportunityId
ID of the opportunity to close
fieldList
List of fields for the Opportunity Close Entity
opportunityStatusCode
Status code of Opportunity, Should be either 1 or 2, defaults to 1 ( won )
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CloseQuote Method
[image]

Closes a quote as won or lost, Revise is not supported via this method

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CloseQuote ( _
    quoteId As Guid, _
    fieldList As Dictionary(Of String, CrmDataTypeWrapper), _
    <OptionalAttribute> Optional quoteStatusCode As Integer = 3, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Guid

C#
public Guid CloseQuote (
    Guid quoteId,
    Dictionary<string,CrmDataTypeWrapper> fieldList,
    [OptionalAttribute] int quoteStatusCode,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
quoteId
ID of the quote to close
fieldList
List of fields that need to be updated
quoteStatusCode
Status id of the quote, must be greater then 3 but not 7
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CloseTroubleTicket Method
[image]

Closes a Trouble ticket by ID

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CloseTroubleTicket ( _
    ticketId As Guid, _
    subject As String, _
    description As String, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Guid

C#
public Guid CloseTroubleTicket (
    Guid ticketId,
    string subject,
    string description,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
ticketId
ID of the Ticket to close
subject
Title of the close ticket record
description
Description of the closed ticket
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
Returns the ID of the closed ticket

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CreateAnnotation Method
[image]

This creates a annotation [note] entry, related to a an existing entity Required Properties in the fieldList notetext (string) = Text of the note, subject (string) = this is the title of the note

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CreateAnnotation ( _
    targetEntityTypeName As String, _
    targetEntityId As Guid, _
    fieldList As Dictionary(Of String, CrmDataTypeWrapper), _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Guid

C#
public Guid CreateAnnotation (
    string targetEntityTypeName,
    Guid targetEntityId,
    Dictionary<string,CrmDataTypeWrapper> fieldList,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
targetEntityTypeName
Target Entity TypeID
targetEntityId
Target Entity ID
fieldList
Fields to populate
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CreateBatchOperationRequest Method
[image]

Create a Batch Request for executing batch operations. This returns an ID that will be used to identify a request as a batch request vs a "normal" request.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CreateBatchOperationRequest ( _
    batchName As String, _
    <OptionalAttribute> Optional returnResults As Boolean = True, _
    <OptionalAttribute> Optional continueOnError As Boolean = False _
) As Guid

C#
public Guid CreateBatchOperationRequest (
    string batchName,
    [OptionalAttribute] bool returnResults,
    [OptionalAttribute] bool continueOnError
)

C++

J#

JScript

Parameters
batchName
Name of the Batch
returnResults
Should Results be returned
continueOnError
Should the process continue on an error.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CreateEntityAssociation Method
[image]

Associates one Entity to another where an M2M Relationship Exists.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CreateEntityAssociation ( _
    entityName1 As String, _
    entity1Id As Guid, _
    entityName2 As String, _
    entity2Id As Guid, _
    relationshipName As String, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool CreateEntityAssociation (
    string entityName1,
    Guid entity1Id,
    string entityName2,
    Guid entity2Id,
    string relationshipName,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entityName1
Entity on one side of the relationship
entity1Id
The Id of the record on the first side of the relationship
entityName2
Entity on the second side of the relationship
entity2Id
The Id of the record on the second side of the relationship
relationshipName
Relationship name between the 2 entities
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
true on success, false on fail

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CreateMultiEntityAssociation Method
[image]

Associates multiple entities of the same time to a single entity

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CreateMultiEntityAssociation ( _
    targetEntity As String, _
    targetEntity1Id As Guid, _
    sourceEntityName As String, _
    sourceEntitieIds As List(Of Guid), _
    relationshipName As String, _
    <OptionalAttribute> Optional batchId As Guid = Nothing, _
    <OptionalAttribute> Optional isReflexiveRelationship As Boolean = False _
) As Boolean

C#
public bool CreateMultiEntityAssociation (
    string targetEntity,
    Guid targetEntity1Id,
    string sourceEntityName,
    List<Guid> sourceEntitieIds,
    string relationshipName,
    [OptionalAttribute] Guid batchId,
    [OptionalAttribute] bool isReflexiveRelationship
)

C++

J#

JScript

Parameters
targetEntity
Entity that things will be related too.
targetEntity1Id
ID of entity that things will be related too
sourceEntityName
Entity that you are relating from
sourceEntitieIds
ID's of the entities you are relating from
relationshipName
Name of the relationship between the target and the source entities.
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
isReflexiveRelationship
Optional: if set to true, indicates that this is a N:N using a reflexive relationship
Return Value
true on success, false on fail

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CreateNewActivityEntry Method
[image]

Creates a new activity against the target entity type

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CreateNewActivityEntry ( _
    activityEntityTypeName As String, _
    regardingEntityTypeName As String, _
    regardingId As Guid, _
    subject As String, _
    description As String, _
    creatingUserId As String, _
    <OptionalAttribute> Optional fieldList As Dictionary(Of String, CrmDataTypeWrapper) = Nothing, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Guid

C#
public Guid CreateNewActivityEntry (
    string activityEntityTypeName,
    string regardingEntityTypeName,
    Guid regardingId,
    string subject,
    string description,
    string creatingUserId,
    [OptionalAttribute] Dictionary<string,CrmDataTypeWrapper> fieldList,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
activityEntityTypeName
Type of Activity you would like to create
regardingEntityTypeName
Entity type of the Entity you want to associate with.
subject
Subject Line of the Activity
description
Description Text of the Activity
regardingId
ID of the Entity to associate the Activity too
creatingUserId
User ID that Created the Activity *Calling user must have necessary permissions to assign to another user
fieldList
Additional fields to add as part of the activity creation
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
Guid of Activity ID or Guid.empty

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CreateNewRecord Method
[image]

Uses the dynamic entity patter to create a new entity

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CreateNewRecord ( _
    entityName As String, _
    valueArray As Dictionary(Of String, CrmDataTypeWrapper), _
    <OptionalAttribute> Optional applyToSolution As String = "", _
    <OptionalAttribute> Optional enabledDuplicateDetection As Boolean = False, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Guid

C#
public Guid CreateNewRecord (
    string entityName,
    Dictionary<string,CrmDataTypeWrapper> valueArray,
    [OptionalAttribute] string applyToSolution,
    [OptionalAttribute] bool enabledDuplicateDetection,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entityName
Name of Entity To create
valueArray
Initial Values
applyToSolution
Optional: Applies the update with a solution by Unique name
enabledDuplicateDetection
Optional: if true, enabled CRM onboard duplicate detection
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
Guid on Success, Guid.Empty on fail

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CreateOrUpdatePickListElement Method
[image]

Adds an option to a pick list on an entity.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function CreateOrUpdatePickListElement ( _
    targetEntity As String, _
    attribName As String, _
    locLabelList As List(Of LocalizedLabel), _
    valueData As Integer, _
    publishOnComplete As Boolean _
) As Boolean

C#
public bool CreateOrUpdatePickListElement (
    string targetEntity,
    string attribName,
    List<LocalizedLabel> locLabelList,
    int valueData,
    bool publishOnComplete
)

C++

J#

JScript

Parameters
targetEntity
Entity Name to Target
attribName
Attribute Name on the Entity
locLabelList
List of Localized Labels
valueData
integer Value
publishOnComplete
Publishes the Update to the Live system.. note this is a time consuming process.. if you are doing a batch up updates, call PublishEntity Separately when you are finished.
Return Value
true on success, on fail check last error.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.DeleteEntity Method
[image]

Deletes an entity from the CRM

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function DeleteEntity ( _
    entityType As String, _
    entityId As Guid, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool DeleteEntity (
    string entityType,
    Guid entityId,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entityType
entity type name
entityId
entity id
batchId
Optional : Batch ID to attach this request too.
Return Value
true on success, false on failure

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.DeleteEntityAssociation Method
[image]

Removes the Association between 2 entity items where an M2M Relationship Exists.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function DeleteEntityAssociation ( _
    entityName1 As String, _
    entity1Id As Guid, _
    entityName2 As String, _
    entity2Id As Guid, _
    relationshipName As String, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool DeleteEntityAssociation (
    string entityName1,
    Guid entity1Id,
    string entityName2,
    Guid entity2Id,
    string relationshipName,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entityName1
Entity on one side of the relationship
entity1Id
The Id of the record on the first side of the relationship
entityName2
Entity on the second side of the relationship
entity2Id
The Id of the record on the second side of the relationship
relationshipName
Relationship name between the 2 entities
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
true on success, false on fail

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.DiscoverOrganizations Method
[image]

Overload List

Name | Description
CrmServiceClient.DiscoverOrganizations (Uri, Uri, NetworkCredential) | Discovers the organizations.
CrmServiceClient.DiscoverOrganizations (Uri, Uri, ClientCredentials, ClientCredentials) | Discovers the organizations.

See Also

Reference

CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.DiscoverOrganizations Method (Uri, Uri, NetworkCredential)
[image]

Discovers the organizations.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function DiscoverOrganizations ( _
    discoveryServiceUri As Uri, _
    homeRealmUri As Uri, _
    networkCredential As NetworkCredential _
) As OrganizationDetailCollection

C#
public static OrganizationDetailCollection DiscoverOrganizations (
    Uri discoveryServiceUri,
    Uri homeRealmUri,
    NetworkCredential networkCredential
)

C++

J#

JScript

Parameters
discoveryServiceUri
The discovery service URI.
homeRealmUri
The home realm URI. Not null for federation authentication.
networkCredential
The network credential. When given null value, uses the current user network credentials.
Return Value
A collection of organizations.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.DiscoverOrganizations Method (Uri, Uri, ClientCredentials, ClientCredentials)
[image]

Discovers the organizations.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function DiscoverOrganizations ( _
    discoveryServiceUri As Uri, _
    homeRealmUri As Uri, _
    clientCredentials As ClientCredentials, _
    deviceCredentials As ClientCredentials _
) As OrganizationDetailCollection

C#
public static OrganizationDetailCollection DiscoverOrganizations (
    Uri discoveryServiceUri,
    Uri homeRealmUri,
    ClientCredentials clientCredentials,
    ClientCredentials deviceCredentials
)

C++

J#

JScript

Parameters
discoveryServiceUri
The discovery service URI.
homeRealmUri
The home realm URI. Not null for federation authentication.
clientCredentials
The client credentials.
deviceCredentials
The device credentials.
Return Value
A collection of organizations.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ExecuteBatch Method
[image]

Begins running the Batch command.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ExecuteBatch ( _
    batchId As Guid _
) As ExecuteMultipleResponse

C#
public ExecuteMultipleResponse ExecuteBatch (
    Guid batchId
)

C++

J#

JScript

Parameters
batchId
ID of the batch to run
Return Value
true if the batch begins, false if not.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ExecuteCrmEntityDeleteRequest Method
[image]

Executes a row level delete on a CRM entity ( thread safe ) and returns true or false. Also adds metrics for logging support.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ExecuteCrmEntityDeleteRequest ( _
    entName As String, _
    entId As Guid, _
    <OptionalAttribute> Optional logMessageTag As String = "User Defined" _
) As Boolean

C#
public bool ExecuteCrmEntityDeleteRequest (
    string entName,
    Guid entId,
    [OptionalAttribute] string logMessageTag
)

C++

J#

JScript

Parameters
entName
Name of the Entity to delete from
entId
ID of the row to delete
logMessageTag
Message identifying what this request in logging
Return Value
True on success, False on fail.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ExecuteCrmOrganizationRequest Method
[image]

Executes a CRM Organization Request (thread safe) and returns the organization response object. Also adds metrics for logging support.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ExecuteCrmOrganizationRequest ( _
    req As OrganizationRequest, _
    <OptionalAttribute> Optional logMessageTag As String = "User Defined" _
) As OrganizationResponse

C#
public OrganizationResponse ExecuteCrmOrganizationRequest (
    OrganizationRequest req,
    [OptionalAttribute] string logMessageTag
)

C++

J#

JScript

Parameters
req
Organization Request to run
logMessageTag
Message identifying what this request in logging.
Return Value
Result of request or null.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ExecuteWorkflowOnEntity Method
[image]

Executes a named workflow on an object.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ExecuteWorkflowOnEntity ( _
    workflowName As String, _
    id As Guid, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Guid

C#
public Guid ExecuteWorkflowOnEntity (
    string workflowName,
    Guid id,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
workflowName
name of the workflow to run
id
ID to exec against
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
Async Op ID of the WF or Guid.Empty

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetActivitiesBy Method
[image]

Overload List

Name | Description
CrmServiceClient.GetActivitiesBy (String, Guid, List, LogicalSearchOperator, Dictionary, Dictionary, Int32, Int32, String, String, Boolean, Guid) | Returns all Activities Related to a given Entity ID. Only Account, Contact and Opportunity entities are supported.
CrmServiceClient.GetActivitiesBy (String, Guid, List, LogicalSearchOperator, List, Dictionary, Int32, Int32, String, String, Boolean, Guid) | Returns all Activities Related to a given Entity ID. Only Account, Contact and Opportunity entities are supported.

See Also

Reference

CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetActivitiesBy Method (String, Guid, List, LogicalSearchOperator, Dictionary, Dictionary, Int32, Int32, String, String, Boolean, Guid)
[image]

Returns all Activities Related to a given Entity ID. Only Account, Contact and Opportunity entities are supported.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetActivitiesBy ( _
    searchEntity As String, _
    entityId As Guid, _
    fieldList As List(Of String), _
    searchOperator As LogicalSearchOperator, _
    searchParameters As Dictionary(Of String, String), _
    sortParameters As Dictionary(Of String, LogicalSortOrder), _
    pageCount As Integer, _
    pageNumber As Integer, _
    pageCookie As String, _
    <OutAttribute> ByRef outPageCookie As String, _
    <OutAttribute> ByRef isMoreRecords As Boolean, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetActivitiesBy (
    string searchEntity,
    Guid entityId,
    List<string> fieldList,
    LogicalSearchOperator searchOperator,
    Dictionary<string,string> searchParameters,
    Dictionary<string,LogicalSortOrder> sortParameters,
    int pageCount,
    int pageNumber,
    string pageCookie,
    out string outPageCookie,
    out bool isMoreRecords,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
searchEntity
Type of Entity to search against
entityId
ID of the entity to search against.
fieldList
List of Field to return for the entity , null indicates all fields.
searchOperator
Search Operator to use
searchParameters
Filters responses based on search prams.
sortParameters
Sort order
pageCount
Number of Pages
pageNumber
Current Page number
pageCookie
inbound place holder cookie
outPageCookie
outbound place holder cookie
isMoreRecords
is there more records or not
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
Array of Activities

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetActivitiesBy Method (String, Guid, List, LogicalSearchOperator, List, Dictionary, Int32, Int32, String, String, Boolean, Guid)
[image]

Returns all Activities Related to a given Entity ID. Only Account, Contact and Opportunity entities are supported.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetActivitiesBy ( _
    searchEntity As String, _
    entityId As Guid, _
    fieldList As List(Of String), _
    searchOperator As LogicalSearchOperator, _
    searchParameters As List(Of CrmSearchFilter), _
    sortParameters As Dictionary(Of String, LogicalSortOrder), _
    pageCount As Integer, _
    pageNumber As Integer, _
    pageCookie As String, _
    <OutAttribute> ByRef outPageCookie As String, _
    <OutAttribute> ByRef isMoreRecords As Boolean, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetActivitiesBy (
    string searchEntity,
    Guid entityId,
    List<string> fieldList,
    LogicalSearchOperator searchOperator,
    List<CrmSearchFilter> searchParameters,
    Dictionary<string,LogicalSortOrder> sortParameters,
    int pageCount,
    int pageNumber,
    string pageCookie,
    out string outPageCookie,
    out bool isMoreRecords,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
searchEntity
Type of Entity to search against
entityId
ID of the entity to search against.
fieldList
List of Field to return for the entity , null indicates all fields.
searchOperator
Search Operator to use
searchParameters
Filters responses based on search prams.
sortParameters
Sort order
pageCount
Number of Pages
pageNumber
Current Page number
pageCookie
inbound place holder cookie
outPageCookie
outbound place holder cookie
isMoreRecords
is there more records or not
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
Array of Activities

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetAllAttributesForEntity Method
[image]

Returns all attributes on a entity

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetAllAttributesForEntity ( _
    entityLogicalname As String _
) As List(Of AttributeMetadata)

C#
public List<AttributeMetadata> GetAllAttributesForEntity (
    string entityLogicalname
)

C++

J#

JScript

Parameters
entityLogicalname
returns all attributes on a entity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetAllEntityMetadata Method
[image]

Returns a list of entities with basic data from CRM

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetAllEntityMetadata ( _
    <OptionalAttribute> Optional onlyPublished As Boolean = True, _
    <OptionalAttribute> Optional filter As EntityFilters = EntityFilters.Entity _
) As List(Of EntityMetadata)

C#
public List<EntityMetadata> GetAllEntityMetadata (
    [OptionalAttribute] bool onlyPublished,
    [OptionalAttribute] EntityFilters filter
)

C++

J#

JScript

Parameters
onlyPublished
defaults to true, will only return published information
filter
EntityFilter to apply to this request, note that filters other then Default will consume more time.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetBatchById Method
[image]

TEMP

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetBatchById ( _
    batchId As Guid _
) As RequestBatch

C#
public RequestBatch GetBatchById (
    Guid batchId
)

C++

J#

JScript

Parameters
batchId
ID of the batch
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetBatchOperationIdRequestByName Method
[image]

Returns the batch id for a given batch name.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetBatchOperationIdRequestByName ( _
    batchName As String _
) As Guid

C#
public Guid GetBatchOperationIdRequestByName (
    string batchName
)

C++

J#

JScript

Parameters
batchName
Name of Batch
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetBatchRequestAtPosition Method
[image]

Returns the organization request at a give position

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetBatchRequestAtPosition ( _
    batchId As Guid, _
    position As Integer _
) As OrganizationRequest

C#
public OrganizationRequest GetBatchRequestAtPosition (
    Guid batchId,
    int position
)

C++

J#

JScript

Parameters
batchId
ID of the batch
position
Position
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetDataByKeyFromResultsSet Method
[image]

This function gets data from a Dictionary object, where "string" identifies the field name, and Object contains the data, this method then attempts to cast the result to the Type requested, if it cannot be cast an empty object is returned.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetDataByKeyFromResultsSet(Of T) ( _
    results As Dictionary(Of String, Object), _
    key As String _
) As T

C#
public T GetDataByKeyFromResultsSet<T> (
    Dictionary<string,Object> results,
    string key
)

C++

J#

JScript

GenericParameters
T
Type if object to return
Parameters
results
Results from the query
key
key name you want
Return Value
object

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityAttributeMetadataForAttribute Method
[image]

Gets metadata for a specific entity's attribute.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityAttributeMetadataForAttribute ( _
    entityLogicalname As String, _
    attribName As String _
) As AttributeMetadata

C#
public AttributeMetadata GetEntityAttributeMetadataForAttribute (
    string entityLogicalname,
    string attribName
)

C++

J#

JScript

Parameters
entityLogicalname
Name of the entity
attribName
Attribute Name
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByFetchSearch Method
[image]

Overload List

Name | Description
CrmServiceClient.GetEntityDataByFetchSearch (String, Guid) | Searches for data based on a FetchXML query
CrmServiceClient.GetEntityDataByFetchSearch (String, Int32, Int32, String, String, Boolean, Guid) | Searches for data based on a FetchXML query

See Also

Reference

CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByFetchSearch Method (String, Guid)
[image]

Searches for data based on a FetchXML query

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataByFetchSearch ( _
    fetchXml As String, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetEntityDataByFetchSearch (
    string fetchXml,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
fetchXml
Fetch XML query data.
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
results or null

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByFetchSearch Method (String, Int32, Int32, String, String, Boolean, Guid)
[image]

Searches for data based on a FetchXML query

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataByFetchSearch ( _
    fetchXml As String, _
    pageCount As Integer, _
    pageNumber As Integer, _
    pageCookie As String, _
    <OutAttribute> ByRef outPageCookie As String, _
    <OutAttribute> ByRef isMoreRecords As Boolean, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetEntityDataByFetchSearch (
    string fetchXml,
    int pageCount,
    int pageNumber,
    string pageCookie,
    out string outPageCookie,
    out bool isMoreRecords,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
fetchXml
Fetch XML query data.
pageCount
Number records per Page
pageNumber
Current Page number
pageCookie
inbound place holder cookie
outPageCookie
outbound place holder cookie
isMoreRecords
is there more records or not
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
results or null

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByFetchSearchEC Method
[image]

Overload List

Name | Description
CrmServiceClient.GetEntityDataByFetchSearchEC (String, Guid) | Searches for data based on a FetchXML query
CrmServiceClient.GetEntityDataByFetchSearchEC (String, Int32, Int32, String, String, Boolean, Guid) | Searches for data based on a FetchXML query

See Also

Reference

CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByFetchSearchEC Method (String, Guid)
[image]

Searches for data based on a FetchXML query

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataByFetchSearchEC ( _
    fetchXml As String, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As EntityCollection

C#
public EntityCollection GetEntityDataByFetchSearchEC (
    string fetchXml,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
fetchXml
Fetch XML query data.
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
results as an entity collection or null

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByFetchSearchEC Method (String, Int32, Int32, String, String, Boolean, Guid)
[image]

Searches for data based on a FetchXML query

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataByFetchSearchEC ( _
    fetchXml As String, _
    pageCount As Integer, _
    pageNumber As Integer, _
    pageCookie As String, _
    <OutAttribute> ByRef outPageCookie As String, _
    <OutAttribute> ByRef isMoreRecords As Boolean, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As EntityCollection

C#
public EntityCollection GetEntityDataByFetchSearchEC (
    string fetchXml,
    int pageCount,
    int pageNumber,
    string pageCookie,
    out string outPageCookie,
    out bool isMoreRecords,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
fetchXml
Fetch XML query data.
pageCount
Number records per Page
pageNumber
Current Page number
pageCookie
inbound place holder cookie
outPageCookie
outbound place holder cookie
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
isMoreRecords
is there more records or not
Return Value
results as an Entity Collection or null

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataById Method
[image]

Gets a List of variables from the account based on the list of field specified in the Fields List

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataById ( _
    searchEntity As String, _
    entityId As Guid, _
    fieldList As List(Of String), _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Object)

C#
public Dictionary<string,Object> GetEntityDataById (
    string searchEntity,
    Guid entityId,
    List<string> fieldList,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
searchEntity
The entity to be searched.
entityId
ID of Entity to query
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
fieldList
Populated Array of Key value pairs with the Results of the Search
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByLinkedSearch Method
[image]

Overload List

Name | Description
CrmServiceClient.GetEntityDataByLinkedSearch (String, Dictionary, String, Dictionary, String, String, String, LogicalSearchOperator, List, Guid) | Queries an Object via a M to M Link
CrmServiceClient.GetEntityDataByLinkedSearch (String, List, String, List, String, String, String, LogicalSearchOperator, List, Guid, Boolean) | Queries an Object via a M to M Link

See Also

Reference

CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByLinkedSearch Method (String, Dictionary, String, Dictionary, String, String, String, LogicalSearchOperator, List, Guid)
[image]

Queries an Object via a M to M Link

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataByLinkedSearch ( _
    returnEntityName As String, _
    primarySearchParameters As Dictionary(Of String, String), _
    linkedEntityName As String, _
    linkedSearchParameters As Dictionary(Of String, String), _
    linkedEntityLinkAttribName As String, _
    m2MEntityName As String, _
    returnEntityPrimaryId As String, _
    searchOperator As LogicalSearchOperator, _
    fieldList As List(Of String), _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetEntityDataByLinkedSearch (
    string returnEntityName,
    Dictionary<string,string> primarySearchParameters,
    string linkedEntityName,
    Dictionary<string,string> linkedSearchParameters,
    string linkedEntityLinkAttribName,
    string m2MEntityName,
    string returnEntityPrimaryId,
    LogicalSearchOperator searchOperator,
    List<string> fieldList,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
returnEntityName
Name of the entity you want return data from
primarySearchParameters
Search Prams for the Return Entity
linkedEntityName
Name of the entity you are linking too
linkedSearchParameters
Search Prams for the Entity you are linking too
linkedEntityLinkAttribName
Key field on the Entity you are linking too
m2MEntityName
CRM Name of the Relationship
returnEntityPrimaryId
Key field on the Entity you want to return data from
searchOperator
Search Operator to apply
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
fieldList
List of Fields from the Returned Entity you want
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByLinkedSearch Method (String, List, String, List, String, String, String, LogicalSearchOperator, List, Guid, Boolean)
[image]

Queries an Object via a M to M Link

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataByLinkedSearch ( _
    returnEntityName As String, _
    primarySearchParameters As List(Of CrmSearchFilter), _
    linkedEntityName As String, _
    linkedSearchParameters As List(Of CrmSearchFilter), _
    linkedEntityLinkAttribName As String, _
    m2MEntityName As String, _
    returnEntityPrimaryId As String, _
    searchOperator As LogicalSearchOperator, _
    fieldList As List(Of String), _
    <OptionalAttribute> Optional batchId As Guid = Nothing, _
    <OptionalAttribute> Optional isReflexiveRelationship As Boolean = False _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetEntityDataByLinkedSearch (
    string returnEntityName,
    List<CrmSearchFilter> primarySearchParameters,
    string linkedEntityName,
    List<CrmSearchFilter> linkedSearchParameters,
    string linkedEntityLinkAttribName,
    string m2MEntityName,
    string returnEntityPrimaryId,
    LogicalSearchOperator searchOperator,
    List<string> fieldList,
    [OptionalAttribute] Guid batchId,
    [OptionalAttribute] bool isReflexiveRelationship
)

C++

J#

JScript

Parameters
returnEntityName
Name of the entity you want return data from
primarySearchParameters
Search Prams for the Return Entity
linkedEntityName
Name of the entity you are linking too
linkedSearchParameters
Search Prams for the Entity you are linking too
linkedEntityLinkAttribName
Key field on the Entity you are linking too
m2MEntityName
CRM Name of the Relationship
returnEntityPrimaryId
Key field on the Entity you want to return data from
searchOperator
Search Operator to apply
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
fieldList
List of Fields from the Returned Entity you want
isReflexiveRelationship
If the relationship is defined as Entity:Entity or Account N:N Account, this parameter should be set to true
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByRollup Method
[image]

Overload List

Name | Description
CrmServiceClient.GetEntityDataByRollup (String, Guid, String, List, LogicalSearchOperator, Dictionary, Dictionary, Guid) | Returns all Activities Related to a given Entity ID. Only Account, Contact and Opportunity entities are supported.
CrmServiceClient.GetEntityDataByRollup (String, Guid, String, List, LogicalSearchOperator, List, Dictionary, Int32, Int32, String, String, Boolean, Guid) | Returns all Activities Related to a given Entity ID. Only Account, Contact and Opportunity entities are supported.

See Also

Reference

CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByRollup Method (String, Guid, String, List, LogicalSearchOperator, Dictionary, Dictionary, Guid)
[image]

Returns all Activities Related to a given Entity ID. Only Account, Contact and Opportunity entities are supported.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataByRollup ( _
    searchEntity As String, _
    entityId As Guid, _
    rollupfromEntity As String, _
    fieldList As List(Of String), _
    searchOperator As LogicalSearchOperator, _
    searchParameters As Dictionary(Of String, String), _
    sortParameters As Dictionary(Of String, LogicalSortOrder), _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetEntityDataByRollup (
    string searchEntity,
    Guid entityId,
    string rollupfromEntity,
    List<string> fieldList,
    LogicalSearchOperator searchOperator,
    Dictionary<string,string> searchParameters,
    Dictionary<string,LogicalSortOrder> sortParameters,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
searchEntity
Type of Entity to search against
entityId
ID of the entity to search against.
fieldList
List of Field to return for the entity , null indicates all fields.
searchOperator
searchParameters
Filters responses based on search prams.
sortParameters
Sort Order
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
rollupfromEntity
Entity to Rollup from
Return Value
Array of Activities

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataByRollup Method (String, Guid, String, List, LogicalSearchOperator, List, Dictionary, Int32, Int32, String, String, Boolean, Guid)
[image]

Returns all Activities Related to a given Entity ID. Only Account, Contact and Opportunity entities are supported.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataByRollup ( _
    searchEntity As String, _
    entityId As Guid, _
    rollupfromEntity As String, _
    fieldList As List(Of String), _
    searchOperator As LogicalSearchOperator, _
    searchParameters As List(Of CrmSearchFilter), _
    sortParameters As Dictionary(Of String, LogicalSortOrder), _
    pageCount As Integer, _
    pageNumber As Integer, _
    pageCookie As String, _
    <OutAttribute> ByRef outPageCookie As String, _
    <OutAttribute> ByRef isMoreRecords As Boolean, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetEntityDataByRollup (
    string searchEntity,
    Guid entityId,
    string rollupfromEntity,
    List<string> fieldList,
    LogicalSearchOperator searchOperator,
    List<CrmSearchFilter> searchParameters,
    Dictionary<string,LogicalSortOrder> sortParameters,
    int pageCount,
    int pageNumber,
    string pageCookie,
    out string outPageCookie,
    out bool isMoreRecords,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
searchEntity
Type of Entity to search against
entityId
ID of the entity to search against.
fieldList
List of Field to return for the entity , null indicates all fields.
rollupfromEntity
Entity to Rollup from
searchOperator
Search Operator to user
searchParameters
CRM Filter list to apply
sortParameters
Sort by
pageCount
Number of Pages
pageNumber
Current Page number
pageCookie
inbound place holder cookie
outPageCookie
outbound place holder cookie
isMoreRecords
is there more records or not
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataBySearchParams Method
[image]

Overload List

Name | Description
CrmServiceClient.GetEntityDataBySearchParams (String, Dictionary, LogicalSearchOperator, List, Guid) | Gets a list of accounts based on the search parameters.
CrmServiceClient.GetEntityDataBySearchParams (String, List, LogicalSearchOperator, List, Dictionary, Int32, Int32, String, String, Boolean, Guid) | Searches for data from an entity based on the search parameters.
CrmServiceClient.GetEntityDataBySearchParams (String, List, LogicalSearchOperator, List, Guid) | Gets a list of accounts based on the search parameters.

See Also

Reference

CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataBySearchParams Method (String, Dictionary, LogicalSearchOperator, List, Guid)
[image]

Gets a list of accounts based on the search parameters.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataBySearchParams ( _
    entityName As String, _
    searchParameters As Dictionary(Of String, String), _
    searchOperator As LogicalSearchOperator, _
    fieldList As List(Of String), _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetEntityDataBySearchParams (
    string entityName,
    Dictionary<string,string> searchParameters,
    LogicalSearchOperator searchOperator,
    List<string> fieldList,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entityName
CRM Entity Type Name to search
searchParameters
Array of Search Parameters
fieldList
List of fields to retrieve, Null indicates all Fields
searchOperator
Logical Search Operator
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
List of matching Entity Types.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataBySearchParams Method (String, List, LogicalSearchOperator, List, Dictionary, Int32, Int32, String, String, Boolean, Guid)
[image]

Searches for data from an entity based on the search parameters.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataBySearchParams ( _
    entityName As String, _
    searchParameters As List(Of CrmSearchFilter), _
    searchOperator As LogicalSearchOperator, _
    fieldList As List(Of String), _
    sortParameters As Dictionary(Of String, LogicalSortOrder), _
    pageCount As Integer, _
    pageNumber As Integer, _
    pageCookie As String, _
    <OutAttribute> ByRef outPageCookie As String, _
    <OutAttribute> ByRef isMoreRecords As Boolean, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetEntityDataBySearchParams (
    string entityName,
    List<CrmSearchFilter> searchParameters,
    LogicalSearchOperator searchOperator,
    List<string> fieldList,
    Dictionary<string,LogicalSortOrder> sortParameters,
    int pageCount,
    int pageNumber,
    string pageCookie,
    out string outPageCookie,
    out bool isMoreRecords,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entityName
Name of the entity to search
searchParameters
Array of Search Parameters
fieldList
List of fields to retrieve, Null indicates all Fields
searchOperator
Logical Search Operator
pageCount
Number records per Page
pageNumber
Current Page number
pageCookie
inbound place holder cookie
outPageCookie
outbound place holder cookie
isMoreRecords
is there more records or not
sortParameters
Sort order
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
List of matching Entity Types.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDataBySearchParams Method (String, List, LogicalSearchOperator, List, Guid)
[image]

Gets a list of accounts based on the search parameters.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDataBySearchParams ( _
    entityName As String, _
    searchParameters As List(Of CrmSearchFilter), _
    searchOperator As LogicalSearchOperator, _
    fieldList As List(Of String), _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Dictionary(Of String, Dictionary(Of String, Object))

C#
public Dictionary<string,Dictionary<string,Object>> GetEntityDataBySearchParams (
    string entityName,
    List<CrmSearchFilter> searchParameters,
    LogicalSearchOperator searchOperator,
    List<string> fieldList,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entityName
CRM Entity Type Name to search
searchParameters
Array of Search Parameters
fieldList
List of fields to retrieve, Null indicates all Fields
searchOperator
Logical Search Operator
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
List of matching Entity Types.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDisplayName Method
[image]

Gets an Entity Name by Logical name or Type code.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDisplayName ( _
    entityName As String, _
    <OptionalAttribute> Optional entityTypeCode As Integer = -1 _
) As String

C#
public string GetEntityDisplayName (
    string entityName,
    [OptionalAttribute] int entityTypeCode
)

C++

J#

JScript

Parameters
entityName
logical name of the entity
entityTypeCode
Type code for the entity
Return Value
Localized name for the entity in the current users language

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityDisplayNamePlural Method
[image]

Gets an Entity Name by Logical name or Type code.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityDisplayNamePlural ( _
    entityName As String, _
    <OptionalAttribute> Optional entityTypeCode As Integer = -1 _
) As String

C#
public string GetEntityDisplayNamePlural (
    string entityName,
    [OptionalAttribute] int entityTypeCode
)

C++

J#

JScript

Parameters
entityName
logical name of the entity
entityTypeCode
Type code for the entity
Return Value
Localized plural name for the entity in the current users language

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityFormIdListByType Method
[image]

Returns the Form Entity References for a given form type.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityFormIdListByType ( _
    entityLogicalname As String, _
    formTypeId As FormTypeId _
) As List(Of EntityReference)

C#
public List<EntityReference> GetEntityFormIdListByType (
    string entityLogicalname,
    FormTypeId formTypeId
)

C++

J#

JScript

Parameters
entityLogicalname
logical name of the entity you are querying for form data.
formTypeId
Form Type you want
Return Value
List of Entity References for the form type requested.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityMetadata Method
[image]

Returns the Metadata for an entity from CRM, defaults to basic data only.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityMetadata ( _
    entityLogicalname As String, _
    <OptionalAttribute> Optional queryFilter As EntityFilters = EntityFilters.Entity _
) As EntityMetadata

C#
public EntityMetadata GetEntityMetadata (
    string entityLogicalname,
    [OptionalAttribute] EntityFilters queryFilter
)

C++

J#

JScript

Parameters
entityLogicalname
Logical name of the entity
queryFilter
filter to apply to the query, defaults to default entity data.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityName Method
[image]

Returns the Entity name for the given Type code

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityName ( _
    entityTypeCode As Integer _
) As String

C#
public string GetEntityName (
    int entityTypeCode
)

C++

J#

JScript

Parameters
entityTypeCode
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetEntityTypeCode Method
[image]

Gets the typecode of an entity by name.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetEntityTypeCode ( _
    entityName As String _
) As String

C#
public string GetEntityTypeCode (
    string entityName
)

C++

J#

JScript

Parameters
entityName
name of the entity to get the type code on
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetGlobalOptionSetMetadata Method
[image]

Gets a global option set from CRM.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetGlobalOptionSetMetadata ( _
    globalOptionSetName As String _
) As OptionSetMetadata

C#
public OptionSetMetadata GetGlobalOptionSetMetadata (
    string globalOptionSetName
)

C++

J#

JScript

Parameters
globalOptionSetName
Name of the Option Set To get
Return Value
OptionSetMetadata or null

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetMyCrmUserId Method
[image]

Gets the user ID of the currently logged in user.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetMyCrmUserId As Guid

C#
public Guid GetMyCrmUserId ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.GetPickListElementFromMetadataEntity Method
[image]

Gets a PickList, Status List or StateList from the metadata of an attribute

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetPickListElementFromMetadataEntity ( _
    targetEntity As String, _
    attribName As String _
) As PickListMetaElement

C#
public PickListMetaElement GetPickListElementFromMetadataEntity (
    string targetEntity,
    string attribName
)

C++

J#

JScript

Parameters
targetEntity
text name of the entity to query
attribName
name of the attribute to query
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ImportDataMapToCrm Method
[image]

Used to upload a data map to the CRM

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ImportDataMapToCrm ( _
    dataMapXml As String, _
    <OptionalAttribute> Optional replaceIds As Boolean = True, _
    <OptionalAttribute> Optional dataMapXmlIsFilePath As Boolean = False _
) As Guid

C#
public Guid ImportDataMapToCrm (
    string dataMapXml,
    [OptionalAttribute] bool replaceIds,
    [OptionalAttribute] bool dataMapXmlIsFilePath
)

C++

J#

JScript

Parameters
dataMapXml
XML of the datamap in string form
replaceIds
True to have CRM replace ID's on inbound data, False to have inbound data retain its ID's
dataMapXmlIsFilePath
if true, dataMapXml is expected to be a File name and path to load.
Return Value
Returns ID of the datamap or Guid.Empty

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ImportSolutionToCrm Method
[image]

Imports a CRM solution to the CRM Server currently connected. *** Note: this is a blocking call and will take time to Import to CRM ***

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ImportSolutionToCrm ( _
    solutionPath As String, _
    <OutAttribute> ByRef importId As Guid, _
    <OptionalAttribute> Optional activatePlugIns As Boolean = True, _
    <OptionalAttribute> Optional overwriteUnManagedCustomizations As Boolean = False, _
    <OptionalAttribute> Optional skipDependancyOnProductUpdateCheckOnInstall As Boolean = False _
) As Guid

C#
public Guid ImportSolutionToCrm (
    string solutionPath,
    out Guid importId,
    [OptionalAttribute] bool activatePlugIns,
    [OptionalAttribute] bool overwriteUnManagedCustomizations,
    [OptionalAttribute] bool skipDependancyOnProductUpdateCheckOnInstall
)

C++

J#

JScript

Parameters
solutionPath
Path to the Solution File
activatePlugIns
Activate Plugin's and workflows on the Solution
importId
This will populate with the Import ID even if the request failed.
            You can use this ID to request status on the import via a request to the ImportJob entity.
overwriteUnManagedCustomizations
Forces an overwrite of unmanaged customizations of the managed solution you are installing, defaults to false
skipDependancyOnProductUpdateCheckOnInstall
Skips dependency against dependencies flagged as product update, defaults to false
Return Value
Returns the Import Solution Job ID. To find the status of the job, query the ImportJob Entity using GetEntityDataByID using the returned value of this method

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.InstallSampleDataToCrm Method
[image]

Request CRM to install sample data shipped with CRM. Note this is process will take a few moments to execute. This method will return once the request has been submitted.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function InstallSampleDataToCrm As Guid

C#
public Guid InstallSampleDataToCrm ()

C++

J#

JScript

Return Value
ID of the Async job executing the request

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.IsSampleDataInstalled Method
[image]

Determines if the CRM sample data has been installed

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function IsSampleDataInstalled As ImportStatus

C#
public ImportStatus IsSampleDataInstalled ()

C++

J#

JScript

Return Value
True if the sample data is installed, False if not.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.MakeSecureString Method
[image]

Makes a secure string

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function MakeSecureString ( _
    pass As String _
) As SecureString

C#
public static SecureString MakeSecureString (
    string pass
)

C++

J#

JScript

Parameters
pass
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.PublishEntity Method
[image]

Publishes an entity to the production system, used in conjunction with the Metadata services.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function PublishEntity ( _
    entityName As String _
) As Boolean

C#
public bool PublishEntity (
    string entityName
)

C++

J#

JScript

Parameters
entityName
Name of the entity to publish
Return Value
True on success

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ReleaseBatchInfoById Method
[image]

Release a batch from the stack Once you have completed using a batch, you must release it from the system.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub ReleaseBatchInfoById ( _
    batchId As Guid _
)

C#
public void ReleaseBatchInfoById (
    Guid batchId
)

C++

J#

JScript

Parameters
batchId
ID of the batch
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ResetLocalMetadataCache Method
[image]

This will clear the Metadata cache for either all entities or the specified entity

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub ResetLocalMetadataCache ( _
    <OptionalAttribute> Optional entityName As String = "" _
)

C#
public void ResetLocalMetadataCache (
    [OptionalAttribute] string entityName
)

C++

J#

JScript

Parameters
entityName
Optional: name of the entity to clear cached info for
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.RetrieveBatchResponse Method
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function RetrieveBatchResponse ( _
    batchId As Guid _
) As List(Of Dictionary(Of String, Dictionary(Of String, Object)))

C#
public List<Dictionary<string,Dictionary<string,Object>>> RetrieveBatchResponse (
    Guid batchId
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.SendSingleEmail Method
[image]

Sends an email.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function SendSingleEmail ( _
    emailid As Guid, _
    token As String, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool SendSingleEmail (
    Guid emailid,
    string token,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
emailid
ID of the Email activity.
token
Tracking Token or Null.
batchId
Optional. If set to a valid GUID (generated by CreateBatchOperationRequest), will assign the request to the batch for later execution. Otherwise, runs the request immediately.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.SubmitImportRequest Method
[image]

Starts an Import request for CRM. Supports a single file per Import request.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function SubmitImportRequest ( _
    importRequest As ImportRequest, _
    delayUntil As DateTime _
) As Guid

C#
public Guid SubmitImportRequest (
    ImportRequest importRequest,
    DateTime delayUntil
)

C++

J#

JScript

Parameters
delayUntil
Delays the import jobs till specified time - Use DateTime.MinValue to Run immediately
importRequest
Import Data Request
Return Value
Guid of the Import Request, or Guid.Empty. If Guid.Empty then request failed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.UninstallSampleDataFromCrm Method
[image]

Request CRM to remove sample data shipped with CRM. Note this is process will take a few moments to execute. This method will return once the request has been submitted.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function UninstallSampleDataFromCrm As Guid

C#
public Guid UninstallSampleDataFromCrm ()

C++

J#

JScript

Return Value
ID of the Async job executing the request

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.UpdateEntity Method
[image]

Generic update entity

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function UpdateEntity ( _
    entityName As String, _
    keyFieldName As String, _
    id As Guid, _
    fieldList As Dictionary(Of String, CrmDataTypeWrapper), _
    <OptionalAttribute> Optional applyToSolution As String = "", _
    <OptionalAttribute> Optional enabledDuplicateDetection As Boolean = False, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool UpdateEntity (
    string entityName,
    string keyFieldName,
    Guid id,
    Dictionary<string,CrmDataTypeWrapper> fieldList,
    [OptionalAttribute] string applyToSolution,
    [OptionalAttribute] bool enabledDuplicateDetection,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entityName
String version of the entity name
keyFieldName
Key fieldname of the entity
id
Guid ID of the entity to update
fieldList
Fields to update
applyToSolution
Optional: Applies the update with a solution by Unique name
enabledDuplicateDetection
Optional: if true, enabled CRM onboard duplicate detection
batchId
Optional: if set to a valid GUID, generated by the Create Batch Request Method, will assigned the request to the batch for later execution, on fail, runs the request immediately
Return Value
true on success, false on fail

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.UpdateStateAndStatusForEntity Method
[image]

Overload List

Name | Description
CrmServiceClient.UpdateStateAndStatusForEntity (String, Guid, Int32, Int32, Guid) | Updates the State and Status of the Entity passed in.
CrmServiceClient.UpdateStateAndStatusForEntity (String, Guid, String, String, Guid) | Updates the State and Status of the Entity passed in.

See Also

Reference

CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.UpdateStateAndStatusForEntity Method (String, Guid, Int32, Int32, Guid)
[image]

Updates the State and Status of the Entity passed in.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function UpdateStateAndStatusForEntity ( _
    entName As String, _
    id As Guid, _
    stateCode As Integer, _
    statusCode As Integer, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool UpdateStateAndStatusForEntity (
    string entName,
    Guid id,
    int stateCode,
    int statusCode,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entName
Name of the entity
id
Guid ID of the entity you are updating
stateCode
Int version of the new state
statusCode
Int Version of the new status
batchId
Optional : Batch ID to attach this request too.
Return Value
true on success.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.UpdateStateAndStatusForEntity Method (String, Guid, String, String, Guid)
[image]

Updates the State and Status of the Entity passed in.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function UpdateStateAndStatusForEntity ( _
    entName As String, _
    id As Guid, _
    stateCode As String, _
    statusCode As String, _
    <OptionalAttribute> Optional batchId As Guid = Nothing _
) As Boolean

C#
public bool UpdateStateAndStatusForEntity (
    string entName,
    Guid id,
    string stateCode,
    string statusCode,
    [OptionalAttribute] Guid batchId
)

C++

J#

JScript

Parameters
entName
Name of the entity
id
Guid ID of the entity you are updating
stateCode
String version of the new state
statusCode
String Version of the new status
batchId
Optional : Batch ID to attach this request too.
Return Value
true on success.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient Properties
[image]

Public Properties

 | Name | Description
public property | ConnectedOrgFriendlyName | Gets the friendly name of the organization that you are connected to.
public property | ConnectedOrgPublishedEndpoints | Gets the endpoint collection for the organization you are connected to.
public property | ConnectedOrgUniqueName | Get the unique name of the organization you are connected to.
public property | ConnectedOrgVersion | Gets the version number of the organization you are connected to. If accessed before you are connected to an organization, null or 0.0 is returned.
public property | ConnectionLockObject | Gets the connection lock object that is used to control connection access for various threads. This should be used to lock the connection if you are using the Microsoft Dynamics CRM queries via LINQ.
public property | CrmConnectOrgUriActual | Gets the actual URI used to connect to Microsoft Dynamics CRM. This URI could be influenced by user defined variables.
public property | IsBatchOperationsAvailable | Gets information about the availability of batch operation. If true, batch operations are available.
public property | IsReady | Gets the service connection status. If true, the service is ready to accept requests.
public property | LastCrmError | Gets the last error that occurred while attempting to connect to Microsoft Dynamics CRM.
public property | LastCrmException | Gets the last exception that occurred while attempting to connect to Microsoft Dynamics CRM.
public property | OrganizationServiceProxy | Gets the native Microsoft Dynamics CRM organization service.

See Also

Reference

CrmServiceClient Class
Microsoft.Xrm.Tooling.Connector Namespace

Other Resources

Build windows client applications using the XRM tools


CrmServiceClient.ConnectedOrgFriendlyName Property
[image]

Gets the friendly name of the organization that you are connected to.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ConnectedOrgFriendlyName As String

C#
public string ConnectedOrgFriendlyName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ConnectedOrgPublishedEndpoints Property
[image]

Gets the endpoint collection for the organization you are connected to.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ConnectedOrgPublishedEndpoints As EndpointCollection

C#
public EndpointCollection ConnectedOrgPublishedEndpoints { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ConnectedOrgUniqueName Property
[image]

Get the unique name of the organization you are connected to.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ConnectedOrgUniqueName As String

C#
public string ConnectedOrgUniqueName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ConnectedOrgVersion Property
[image]

Gets the version number of the organization you are connected to. If accessed before you are connected to an organization, null or 0.0 is returned.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ConnectedOrgVersion As Version

C#
public Version ConnectedOrgVersion { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.ConnectionLockObject Property
[image]

Gets the connection lock object that is used to control connection access for various threads. This should be used to lock the connection if you are using the Microsoft Dynamics CRM queries via LINQ.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property ConnectionLockObject As Object

C#
public Object ConnectionLockObject { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.CrmConnectOrgUriActual Property
[image]

Gets the actual URI used to connect to Microsoft Dynamics CRM. This URI could be influenced by user defined variables.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CrmConnectOrgUriActual As Uri

C#
public Uri CrmConnectOrgUriActual { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.IsBatchOperationsAvailable Property
[image]

Gets information about the availability of batch operation. If true, batch operations are available.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property IsBatchOperationsAvailable As Boolean

C#
public bool IsBatchOperationsAvailable { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.IsReady Property
[image]

Gets the service connection status. If true, the service is ready to accept requests.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IsReady As Boolean

C#
public bool IsReady { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.LastCrmError Property
[image]

Gets the last error that occurred while attempting to connect to Microsoft Dynamics CRM.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LastCrmError As String

C#
public string LastCrmError { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.LastCrmException Property
[image]

Gets the last exception that occurred while attempting to connect to Microsoft Dynamics CRM.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LastCrmException As Exception

C#
public Exception LastCrmException { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmServiceClient.OrganizationServiceProxy Property
[image]

Gets the native Microsoft Dynamics CRM organization service.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property OrganizationServiceProxy As OrganizationServiceProxy

C#
public OrganizationServiceProxy OrganizationServiceProxy { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServiceClient Class
CrmServiceClient Members
Microsoft.Xrm.Tooling.Connector Namespace


CrmFilterConditionItem Class
See Also Members
[image]

CRM Filter item.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CrmFilterConditionItem

C#
public sealed class CrmFilterConditionItem

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.CrmServiceClient.CrmFilterConditionItem
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmFilterConditionItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmFilterConditionItem Members
See Also Constructors Methods Properties
[image]

CRM Filter item.

The following tables list the members exposed by the CrmFilterConditionItem type.

Public Constructors

Name | Description
CrmFilterConditionItem |
Top

Public Properties

 | Name | Description
public property | FieldName | CRM Field name to Filter on
public property | FieldOperator | CRM Operator to apply
public property | FieldValue | Value to use for the Filter
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CrmFilterConditionItem Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmFilterConditionItem Constructor
[image]

Initializes a new instance of the CrmFilterConditionItem Class.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmFilterConditionItem ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmFilterConditionItem Class
CrmFilterConditionItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmFilterConditionItem Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmFilterConditionItem Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmFilterConditionItem Properties
[image]

Public Properties

 | Name | Description
public property | FieldName | CRM Field name to Filter on
public property | FieldOperator | CRM Operator to apply
public property | FieldValue | Value to use for the Filter

See Also

Reference

CrmFilterConditionItem Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmFilterConditionItem.FieldName Property
[image]

CRM Field name to Filter on

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FieldName As String

C#
public string FieldName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmFilterConditionItem Class
CrmFilterConditionItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmFilterConditionItem.FieldOperator Property
[image]

CRM Operator to apply

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FieldOperator As ConditionOperator

C#
public ConditionOperator FieldOperator { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmFilterConditionItem Class
CrmFilterConditionItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmFilterConditionItem.FieldValue Property
[image]

Value to use for the Filter

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FieldValue As Object

C#
public Object FieldValue { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmFilterConditionItem Class
CrmFilterConditionItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmSearchFilter Class
See Also Members
[image]

Crm Filter class.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CrmSearchFilter

C#
public sealed class CrmSearchFilter

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.CrmServiceClient.CrmSearchFilter
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmSearchFilter Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmSearchFilter Members
See Also Constructors Methods Properties
[image]

Crm Filter class.

The following tables list the members exposed by the CrmSearchFilter type.

Public Constructors

Name | Description
CrmSearchFilter | Creates an empty CRM Search Filter.
Top

Public Properties

 | Name | Description
public property | FilterOperator | CRM Filter Operator
public property | SearchConditions | List of CRM Filter conditions
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

CrmSearchFilter Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmSearchFilter Constructor
[image]

Creates an empty CRM Search Filter.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmSearchFilter ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmSearchFilter Class
CrmSearchFilter Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmSearchFilter Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmSearchFilter Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmSearchFilter Properties
[image]

Public Properties

 | Name | Description
public property | FilterOperator | CRM Filter Operator
public property | SearchConditions | List of CRM Filter conditions

See Also

Reference

CrmSearchFilter Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmSearchFilter.FilterOperator Property
[image]

CRM Filter Operator

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FilterOperator As LogicalOperator

C#
public LogicalOperator FilterOperator { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmSearchFilter Class
CrmSearchFilter Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


CrmSearchFilter.SearchConditions Property
[image]

List of CRM Filter conditions

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SearchConditions As List(Of CrmFilterConditionItem)

C#
public List<CrmFilterConditionItem> SearchConditions { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmSearchFilter Class
CrmSearchFilter Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


FormTypeId Enumeration
[image]

Used with GetFormIdsForEntity Call

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration FormTypeId

C#
public enum FormTypeId

C++

J#

JScript

  Members
Member name | Description
AppointmentBook | Appointment book, for service requests.
Dashboard | Dashboard form
Main | Main or default form
Mobile | Mobile default form
Other | User defined forms
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem Class
See Also Members
[image]

Describes an Individual Import Item.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ImportFileItem

C#
public class ImportFileItem

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportFileItem
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem Members
See Also Constructors Methods Properties
[image]

Describes an Individual Import Item.

The following tables list the members exposed by the ImportFileItem type.

Public Constructors

Name | Description
ImportFileItem |
Top

Public Properties

 | Name | Description
public property | DataDelimiter | This is the delimiter for the Data,
public property | EnableDuplicateDetection | This enabled duplicate detection rules
public property | FieldDelimiter | this is the field separator
public property | FileContentToImport | This is the CSV file you wish to import,
public property | FileName | File Name of Individual file
public property | FileType | Type of Import file.. XML or CSV
public property | IsFirstRowHeader | Is the first row of the CSV the RowHeader?
public property | IsRecordOwnerATeam | Set true if the Record Owner is a Team
public property | RecordOwner | UserID or Team ID of the Record Owner ( from systemuser )
public property | SourceEntityName | Name of the entity that Originated the data.
public property | TargetEntityName | Name of the entity that Target Entity the data.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportFileItem Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem Constructor
[image]

Initializes a new instance of the ImportFileItem Class.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportFileItem ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportFileItem Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem Properties
[image]

Public Properties

 | Name | Description
public property | DataDelimiter | This is the delimiter for the Data,
public property | EnableDuplicateDetection | This enabled duplicate detection rules
public property | FieldDelimiter | this is the field separator
public property | FileContentToImport | This is the CSV file you wish to import,
public property | FileName | File Name of Individual file
public property | FileType | Type of Import file.. XML or CSV
public property | IsFirstRowHeader | Is the first row of the CSV the RowHeader?
public property | IsRecordOwnerATeam | Set true if the Record Owner is a Team
public property | RecordOwner | UserID or Team ID of the Record Owner ( from systemuser )
public property | SourceEntityName | Name of the entity that Originated the data.
public property | TargetEntityName | Name of the entity that Target Entity the data.

See Also

Reference

ImportFileItem Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.DataDelimiter Property
[image]

This is the delimiter for the Data,

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DataDelimiter As DataDelimiterCode

C#
public DataDelimiterCode DataDelimiter { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.EnableDuplicateDetection Property
[image]

This enabled duplicate detection rules

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property EnableDuplicateDetection As Boolean

C#
public bool EnableDuplicateDetection { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.FieldDelimiter Property
[image]

this is the field separator

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FieldDelimiter As FieldDelimiterCode

C#
public FieldDelimiterCode FieldDelimiter { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.FileContentToImport Property
[image]

This is the CSV file you wish to import,

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FileContentToImport As String

C#
public string FileContentToImport { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.FileName Property
[image]

File Name of Individual file

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FileName As String

C#
public string FileName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.FileType Property
[image]

Type of Import file.. XML or CSV

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property FileType As FileTypeCode

C#
public FileTypeCode FileType { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.IsFirstRowHeader Property
[image]

Is the first row of the CSV the RowHeader?

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IsFirstRowHeader As Boolean

C#
public bool IsFirstRowHeader { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.IsRecordOwnerATeam Property
[image]

Set true if the Record Owner is a Team

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IsRecordOwnerATeam As Boolean

C#
public bool IsRecordOwnerATeam { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.RecordOwner Property
[image]

UserID or Team ID of the Record Owner ( from systemuser )

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RecordOwner As Guid

C#
public Guid RecordOwner { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.SourceEntityName Property
[image]

Name of the entity that Originated the data.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property SourceEntityName As String

C#
public string SourceEntityName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportFileItem.TargetEntityName Property
[image]

Name of the entity that Target Entity the data.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TargetEntityName As String

C#
public string TargetEntityName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportFileItem Class
ImportFileItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


DataDelimiterCode Enumeration
[image]

Key used to delimit data in the import file

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportFileItem
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration DataDelimiterCode

C#
public enum DataDelimiterCode

C++

J#

JScript

  Members
Member name | Description
DoubleQuotes | Specifies "
None | Specifies no delimiter
SingleQuote | Specifies '
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportFileItem Namespace


FieldDelimiterCode Enumeration
[image]

Key used to delimit fields in the import file

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportFileItem
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration FieldDelimiterCode

C#
public enum FieldDelimiterCode

C++

J#

JScript

  Members
Member name | Description
Colon | Specifies :
Comma | Specifies ,
SingleQuote | Specifies '
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportFileItem Namespace


FileTypeCode Enumeration
[image]

Type if file described in the FileContentToImport

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportFileItem
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration FileTypeCode

C#
public enum FileTypeCode

C++

J#

JScript

  Members
Member name | Description
CSV | CSV File Type
XML | XML File type
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportFileItem Namespace


ImportRequest Class
See Also Members
[image]

Describes an import request for CRM

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class ImportRequest

C#
public sealed class ImportRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportRequest Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest Members
See Also Constructors Methods Properties
[image]

Describes an import request for CRM

The following tables list the members exposed by the ImportRequest type.

Public Constructors

Name | Description
ImportRequest | Default constructor
Top

Public Properties

 | Name | Description
public property | DataMapFileId | ID of the DataMap to use
public property | DataMapFileName | Name of the DataMap File to use ID or Name is required
public property | Files | List of files to import in this job, there must be at least one.
public property | ImportName | Name of the Import Request. this Name will appear in CRM
public property | Mode | Sets or gets the Import Mode.
public property | UseSystemMap | if True, infers the map from the type of entity requested..
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportRequest Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest Constructor
[image]

Default constructor

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportRequest ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportRequest Class
ImportRequest Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportRequest Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest Properties
[image]

Public Properties

 | Name | Description
public property | DataMapFileId | ID of the DataMap to use
public property | DataMapFileName | Name of the DataMap File to use ID or Name is required
public property | Files | List of files to import in this job, there must be at least one.
public property | ImportName | Name of the Import Request. this Name will appear in CRM
public property | Mode | Sets or gets the Import Mode.
public property | UseSystemMap | if True, infers the map from the type of entity requested..

See Also

Reference

ImportRequest Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest.DataMapFileId Property
[image]

ID of the DataMap to use

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DataMapFileId As Guid

C#
public Guid DataMapFileId { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportRequest Class
ImportRequest Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest.DataMapFileName Property
[image]

Name of the DataMap File to use ID or Name is required

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DataMapFileName As String

C#
public string DataMapFileName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportRequest Class
ImportRequest Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest.Files Property
[image]

List of files to import in this job, there must be at least one.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Files As List(Of ImportFileItem)

C#
public List<ImportFileItem> Files { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportRequest Class
ImportRequest Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest.ImportName Property
[image]

Name of the Import Request. this Name will appear in CRM

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ImportName As String

C#
public string ImportName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportRequest Class
ImportRequest Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest.Mode Property
[image]

Sets or gets the Import Mode.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Mode As ImportMode

C#
public ImportMode Mode { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportRequest Class
ImportRequest Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportRequest.UseSystemMap Property
[image]

if True, infers the map from the type of entity requested..

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UseSystemMap As Boolean

C#
public bool UseSystemMap { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportRequest Class
ImportRequest Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


ImportMode Enumeration
[image]

Mode of the Import, Update or Create

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportRequest
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration ImportMode

C#
public enum ImportMode

C++

J#

JScript

  Members
Member name | Description
Create | Create a new Import
Update | Update to Imported Items
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector.CrmServiceClient.ImportRequest Namespace


ImportStatus Enumeration
[image]

ImportStatus Reasons

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration ImportStatus

C#
public enum ImportStatus

C++

J#

JScript

  Members
Member name | Description
Completed | Import has Completed
Failed | Import has Failed
InProgress | Import is in Progress
NotImported | Not Yet Imported
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


LogicalSearchOperator Enumeration
[image]

Logical Search Pram to apply to over all search.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration LogicalSearchOperator

C#
public enum LogicalSearchOperator

C++

J#

JScript

  Members
Member name | Description
And | And Search
None | Do not apply the Search Operator
Or | Or Search
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


LogicalSortOrder Enumeration
[image]

Logical Search Pram to apply to over all search.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration LogicalSortOrder

C#
public enum LogicalSortOrder

C++

J#

JScript

  Members
Member name | Description
Ascending | Sort in Ascending
Descending | Sort in Descending
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListItem Class
See Also Members
[image]

PickList Item

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class PickListItem

C#
public sealed class PickListItem

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.CrmServiceClient.PickListItem
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListItem Members
See Also Constructors Methods Properties
[image]

PickList Item

The following tables list the members exposed by the PickListItem type.

Public Constructors

Name | Description
PickListItem | Overloaded.
Top

Public Properties

 | Name | Description
public property | DisplayLabel | Display label for the PickList Item
public property | PickListItemId | ID of the picklist item
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PickListItem Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListItem Constructor
[image]

Overload List

Name | Description
PickListItem () | Default Constructor
PickListItem (String, Int32) | Constructor with data.

See Also

Reference

PickListItem Class
PickListItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListItem Constructor ()
[image]

Default Constructor

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PickListItem ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListItem Class
PickListItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListItem Constructor (String, Int32)
[image]

Constructor with data.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    label As String, _
    id As Integer _
)

C#
public PickListItem (
    string label,
    int id
)

C++

J#

JScript

Parameters
label
id
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListItem Class
PickListItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListItem Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PickListItem Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListItem Properties
[image]

Public Properties

 | Name | Description
public property | DisplayLabel | Display label for the PickList Item
public property | PickListItemId | ID of the picklist item

See Also

Reference

PickListItem Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListItem.DisplayLabel Property
[image]

Display label for the PickList Item

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DisplayLabel As String

C#
public string DisplayLabel { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListItem Class
PickListItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListItem.PickListItemId Property
[image]

ID of the picklist item

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PickListItemId As Integer

C#
public int PickListItemId { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListItem Class
PickListItem Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement Class
See Also Members
[image]

PickList data

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class PickListMetaElement

C#
public sealed class PickListMetaElement

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.CrmServiceClient.PickListMetaElement
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListMetaElement Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement Members
See Also Constructors Methods Properties
[image]

PickList data

The following tables list the members exposed by the PickListMetaElement type.

Public Constructors

Name | Description
PickListMetaElement | Overloaded.
Top

Public Properties

 | Name | Description
public property | ActualValue | Current value of the PickList Item
public property | DisplayValue | Displayed value for the PickList
public property | Items | Array of Potential Pick List Items.
public property | PickListLabel | Displayed Label
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PickListMetaElement Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement Constructor
[image]

Overload List

Name | Description
PickListMetaElement () | Default Constructor
PickListMetaElement (String, String, String) | Constructs a PickList item with data.

See Also

Reference

PickListMetaElement Class
PickListMetaElement Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement Constructor ()
[image]

Default Constructor

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PickListMetaElement ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListMetaElement Class
PickListMetaElement Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement Constructor (String, String, String)
[image]

Constructs a PickList item with data.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    actualValue As String, _
    displayValue As String, _
    pickListLabel As String _
)

C#
public PickListMetaElement (
    string actualValue,
    string displayValue,
    string pickListLabel
)

C++

J#

JScript

Parameters
actualValue
displayValue
pickListLabel
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListMetaElement Class
PickListMetaElement Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PickListMetaElement Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement Properties
[image]

Public Properties

 | Name | Description
public property | ActualValue | Current value of the PickList Item
public property | DisplayValue | Displayed value for the PickList
public property | Items | Array of Potential Pick List Items.
public property | PickListLabel | Displayed Label

See Also

Reference

PickListMetaElement Class
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement.ActualValue Property
[image]

Current value of the PickList Item

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ActualValue As String

C#
public string ActualValue { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListMetaElement Class
PickListMetaElement Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement.DisplayValue Property
[image]

Displayed value for the PickList

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DisplayValue As String

C#
public string DisplayValue { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListMetaElement Class
PickListMetaElement Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement.Items Property
[image]

Array of Potential Pick List Items.

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Items As List(Of PickListItem)

C#
public List<PickListItem> Items { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListMetaElement Class
PickListMetaElement Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


PickListMetaElement.PickListLabel Property
[image]

Displayed Label

Namespace: Microsoft.Xrm.Tooling.Connector.CrmServiceClient
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PickListLabel As String

C#
public string PickListLabel { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PickListMetaElement Class
PickListMetaElement Members
Microsoft.Xrm.Tooling.Connector.CrmServiceClient Namespace


DeviceIdManager Class
See Also Members
[image]

Management utility for the Device Id

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class DeviceIdManager

C#
public static class DeviceIdManager

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.DeviceIdManager
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager Members
See Also Fields Methods Properties
[image]

Management utility for the Device Id

The following tables list the members exposed by the DeviceIdManager type.

Public Fields

Name | Description
MaxDeviceNameLength | Internal Use only
MaxDevicePasswordLength | Internal Use only
Top

Public Properties

Name | Description
PersistIfDeviceAlreadyExists | Indicates that the credentials should be persisted to the disk if registration fails with DeviceAlreadyExists.
PersistToFile | Indicates whether the registered device credentials should be persisted to the database
Top

Public Methods

Name | Description
DiscoverEnvironment | Discovers the Windows Live environment based on the Token Issuer
LoadDeviceCredentials | Overloaded.
LoadOrRegisterDevice | Overloaded.
RegisterDevice | Overloaded.
Top

See Also

Reference

DeviceIdManager Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager Fields
[image]

Public Fields

Name | Description
MaxDeviceNameLength | Internal Use only
MaxDevicePasswordLength | Internal Use only

See Also

Reference

DeviceIdManager Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.MaxDeviceNameLength Field
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxDeviceNameLength As Integer

C#
public const int MaxDeviceNameLength

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.MaxDevicePasswordLength Field
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const MaxDevicePasswordLength As Integer

C#
public const int MaxDevicePasswordLength

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager Methods
[image]

Public Methods

Name | Description
DiscoverEnvironment | Discovers the Windows Live environment based on the Token Issuer
LoadDeviceCredentials | Overloaded.
LoadOrRegisterDevice | Overloaded.
RegisterDevice | Overloaded.

See Also

Reference

DeviceIdManager Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.DiscoverEnvironment Method
[image]

Discovers the Windows Live environment based on the Token Issuer

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function DiscoverEnvironment ( _
    issuerUri As Uri _
) As String

C#
public static string DiscoverEnvironment (
    Uri issuerUri
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.LoadDeviceCredentials Method
[image]

Overload List

Name | Description
DeviceIdManager.LoadDeviceCredentials () | Loads the device's credentials from the file system
DeviceIdManager.LoadDeviceCredentials (Uri) | Loads the device's credentials from the file system

See Also

Reference

DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.LoadDeviceCredentials Method ()
[image]

Loads the device's credentials from the file system

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function LoadDeviceCredentials As ClientCredentials

C#
public static ClientCredentials LoadDeviceCredentials ()

C++

J#

JScript

Return Value
Device Credentials (if set) or null

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.LoadDeviceCredentials Method (Uri)
[image]

Loads the device's credentials from the file system

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function LoadDeviceCredentials ( _
    issuerUri As Uri _
) As ClientCredentials

C#
public static ClientCredentials LoadDeviceCredentials (
    Uri issuerUri
)

C++

J#

JScript

Parameters
issuerUri
URL for the current token issuer
Return Value
Device Credentials (if set) or null

  Remarks
The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.LoadOrRegisterDevice Method
[image]

Overload List

Name | Description
DeviceIdManager.LoadOrRegisterDevice () | Loads the device credentials (if they exist).
DeviceIdManager.LoadOrRegisterDevice (String, String) | Loads the device credentials (if they exist).
DeviceIdManager.LoadOrRegisterDevice (Uri) | Loads the device credentials (if they exist).
DeviceIdManager.LoadOrRegisterDevice (Uri, String, String) | Loads the device credentials (if they exist).

See Also

Reference

DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.LoadOrRegisterDevice Method ()
[image]

Loads the device credentials (if they exist).

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function LoadOrRegisterDevice As ClientCredentials

C#
public static ClientCredentials LoadOrRegisterDevice ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.LoadOrRegisterDevice Method (String, String)
[image]

Loads the device credentials (if they exist).

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function LoadOrRegisterDevice ( _
    deviceName As String, _
    devicePassword As String _
) As ClientCredentials

C#
public static ClientCredentials LoadOrRegisterDevice (
    string deviceName,
    string devicePassword
)

C++

J#

JScript

Parameters
deviceName
Device name that should be registered
devicePassword
Device password that should be registered
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.LoadOrRegisterDevice Method (Uri)
[image]

Loads the device credentials (if they exist).

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function LoadOrRegisterDevice ( _
    issuerUri As Uri _
) As ClientCredentials

C#
public static ClientCredentials LoadOrRegisterDevice (
    Uri issuerUri
)

C++

J#

JScript

Parameters
issuerUri
URL for the current token issuer
  Remarks
The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.LoadOrRegisterDevice Method (Uri, String, String)
[image]

Loads the device credentials (if they exist).

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function LoadOrRegisterDevice ( _
    issuerUri As Uri, _
    deviceName As String, _
    devicePassword As String _
) As ClientCredentials

C#
public static ClientCredentials LoadOrRegisterDevice (
    Uri issuerUri,
    string deviceName,
    string devicePassword
)

C++

J#

JScript

Parameters
issuerUri
URL for the current token issuer
deviceName
Device name that should be registered
devicePassword
Device password that should be registered
  Remarks
The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.RegisterDevice Method
[image]

Overload List

Name | Description
DeviceIdManager.RegisterDevice () | Registers the given device with Live ID with a random application ID
DeviceIdManager.RegisterDevice (Guid) | Registers the given device with Live ID
DeviceIdManager.RegisterDevice (Guid, String, String) | Registers the given device with Live ID
DeviceIdManager.RegisterDevice (Guid, Uri) | Registers the given device with Live ID
DeviceIdManager.RegisterDevice (Guid, Uri, String, String) | Registers the given device with Live ID

See Also

Reference

DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.RegisterDevice Method ()
[image]

Registers the given device with Live ID with a random application ID

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function RegisterDevice As ClientCredentials

C#
public static ClientCredentials RegisterDevice ()

C++

J#

JScript

Return Value
ClientCredentials that were registered

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.RegisterDevice Method (Guid)
[image]

Registers the given device with Live ID

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function RegisterDevice ( _
    applicationId As Guid _
) As ClientCredentials

C#
public static ClientCredentials RegisterDevice (
    Guid applicationId
)

C++

J#

JScript

Parameters
applicationId
ID for the application
Return Value
ClientCredentials that were registered

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.RegisterDevice Method (Guid, String, String)
[image]

Registers the given device with Live ID

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function RegisterDevice ( _
    applicationId As Guid, _
    deviceName As String, _
    devicePassword As String _
) As ClientCredentials

C#
public static ClientCredentials RegisterDevice (
    Guid applicationId,
    string deviceName,
    string devicePassword
)

C++

J#

JScript

Parameters
applicationId
ID for the application
deviceName
Device name that should be registered
devicePassword
Device password that should be registered
Return Value
ClientCredentials that were registered

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.RegisterDevice Method (Guid, Uri)
[image]

Registers the given device with Live ID

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function RegisterDevice ( _
    applicationId As Guid, _
    issuerUri As Uri _
) As ClientCredentials

C#
public static ClientCredentials RegisterDevice (
    Guid applicationId,
    Uri issuerUri
)

C++

J#

JScript

Parameters
applicationId
ID for the application
issuerUri
URL for the current token issuer
Return Value
ClientCredentials that were registered

  Remarks
The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.RegisterDevice Method (Guid, Uri, String, String)
[image]

Registers the given device with Live ID

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function RegisterDevice ( _
    applicationId As Guid, _
    issuerUri As Uri, _
    deviceName As String, _
    devicePassword As String _
) As ClientCredentials

C#
public static ClientCredentials RegisterDevice (
    Guid applicationId,
    Uri issuerUri,
    string deviceName,
    string devicePassword
)

C++

J#

JScript

Parameters
applicationId
ID for the application
issuerUri
URL for the current token issuer
deviceName
Device name that should be registered
devicePassword
Device password that should be registered
Return Value
ClientCredentials that were registered

  Remarks
The issuerUri can be retrieved from the IServiceConfiguration interface's CurrentIssuer property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager Properties
[image]

Public Properties

Name | Description
PersistIfDeviceAlreadyExists | Indicates that the credentials should be persisted to the disk if registration fails with DeviceAlreadyExists.
PersistToFile | Indicates whether the registered device credentials should be persisted to the database

See Also

Reference

DeviceIdManager Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.PersistIfDeviceAlreadyExists Property
[image]

Indicates that the credentials should be persisted to the disk if registration fails with DeviceAlreadyExists.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Property PersistIfDeviceAlreadyExists As Boolean

C#
public static bool PersistIfDeviceAlreadyExists { get; set; }

C++

J#

JScript

  Remarks
If the device already exists, there is a possibility that the credentials are the same as the current credentials that are being registered. This is especially true in automated environments where the same credentials are used continually (to avoid registering spurious device credentials.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceIdManager.PersistToFile Property
[image]

Indicates whether the registered device credentials should be persisted to the database

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Property PersistToFile As Boolean

C#
public static bool PersistToFile { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceIdManager Class
DeviceIdManager Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationAuthentication Class
See Also Members
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlRootAttribute("Authentication")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public NotInheritable Class DeviceRegistrationAuthentication

C#
[XmlRootAttribute("Authentication")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public sealed class DeviceRegistrationAuthentication

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.DeviceRegistrationAuthentication
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationAuthentication Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationAuthentication Members
See Also Constructors Methods Properties
[image]

Internal Use only

The following tables list the members exposed by the DeviceRegistrationAuthentication type.

Public Constructors

Name | Description
DeviceRegistrationAuthentication |
Top

Public Properties

 | Name | Description
public property | MemberName | Internal Use only
public property | Password | Internal Use only
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeviceRegistrationAuthentication Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationAuthentication Constructor
[image]

Initializes a new instance of the DeviceRegistrationAuthentication Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeviceRegistrationAuthentication ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationAuthentication Class
DeviceRegistrationAuthentication Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationAuthentication Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeviceRegistrationAuthentication Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationAuthentication Properties
[image]

Public Properties

 | Name | Description
public property | MemberName | Internal Use only
public property | Password | Internal Use only

See Also

Reference

DeviceRegistrationAuthentication Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationAuthentication.MemberName Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("Membername")> _
Public Property MemberName As String

C#
[XmlElementAttribute("Membername")]
public string MemberName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationAuthentication Class
DeviceRegistrationAuthentication Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationAuthentication.Password Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("Password")> _
Public Property Password As String

C#
[XmlElementAttribute("Password")]
public string Password { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationAuthentication Class
DeviceRegistrationAuthentication Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationClientInfo Class
See Also Members
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<XmlRootAttribute("ClientInfo")> _
Public NotInheritable Class DeviceRegistrationClientInfo

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[XmlRootAttribute("ClientInfo")]
public sealed class DeviceRegistrationClientInfo

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.DeviceRegistrationClientInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationClientInfo Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationClientInfo Members
See Also Constructors Methods Properties
[image]

Internal Use only

The following tables list the members exposed by the DeviceRegistrationClientInfo type.

Public Constructors

Name | Description
DeviceRegistrationClientInfo |
Top

Public Properties

 | Name | Description
public property | ApplicationId | Internal Use only
public property | Version | Internal Use only
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeviceRegistrationClientInfo Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationClientInfo Constructor
[image]

Initializes a new instance of the DeviceRegistrationClientInfo Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeviceRegistrationClientInfo ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationClientInfo Class
DeviceRegistrationClientInfo Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationClientInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeviceRegistrationClientInfo Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationClientInfo Properties
[image]

Public Properties

 | Name | Description
public property | ApplicationId | Internal Use only
public property | Version | Internal Use only

See Also

Reference

DeviceRegistrationClientInfo Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationClientInfo.ApplicationId Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlAttributeAttribute("name")> _
Public Property ApplicationId As Guid

C#
[XmlAttributeAttribute("name")]
public Guid ApplicationId { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationClientInfo Class
DeviceRegistrationClientInfo Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationClientInfo.Version Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlAttributeAttribute("version")> _
Public Property Version As String

C#
[XmlAttributeAttribute("version")]
public string Version { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationClientInfo Class
DeviceRegistrationClientInfo Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationErrorCode Enumeration
[image]

Indicates an error during registration

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration DeviceRegistrationErrorCode

C#
public enum DeviceRegistrationErrorCode

C++

J#

JScript

  Members
Member name | Description
BlankPassword | Blank Password
DeviceAlreadyExists | Device Already Exists
InterfaceDisabled | Interface Disabled
InternalError | Internal Error
InvalidCharactersInCredentials | Invalid Characters are used in the device credentials.
InvalidParameterSyntax | Invalid Parameter Syntax
InvalidRequestFormat | Invalid Request Format
MissingDeviceUserNameOrPassword | Missing Device User Name or Password
Unknown | Unspecified or Unknown Error occurred
UnknownClientVersion | Unknown Client Version
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Class
See Also Members
[image]

Indicates that Device Registration failed

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class DeviceRegistrationFailedException
    Inherits Exception

C#
[SerializableAttribute]
public sealed class DeviceRegistrationFailedException : Exception

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Exception
    Microsoft.Xrm.Tooling.Connector.DeviceRegistrationFailedException
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Members
See Also Constructors Methods Properties Events
[image]

Indicates that Device Registration failed

The following tables list the members exposed by the DeviceRegistrationFailedException type.

Public Constructors

Name | Description
DeviceRegistrationFailedException | Overloaded.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Data | (inherited from Exception)
public property | HelpLink | (inherited from Exception)
public property | InnerException | (inherited from Exception)
public property | Message | (inherited from Exception)
public property | RegistrationErrorCode | Error code that occurred during registration
public property | Source | (inherited from Exception)
public property | StackTrace | (inherited from Exception)
public property | TargetSite | (inherited from Exception)
Top

Protected Properties

 | Name | Description
protected property | HResult | (inherited from Exception)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetBaseException | (inherited from Exception)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | Overridden. Internal Use only
public method | GetType | (inherited from Exception)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Protected Events

 | Name | Description
protected event | SerializeObjectState | (inherited from Exception)
Top

See Also

Reference

DeviceRegistrationFailedException Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Constructor
[image]

Overload List

Name | Description
DeviceRegistrationFailedException () | Construct an instance of the DeviceRegistrationFailedException class
DeviceRegistrationFailedException (DeviceRegistrationErrorCode, String) | Construct an instance of the DeviceRegistrationFailedException class
DeviceRegistrationFailedException (DeviceRegistrationErrorCode, String, Exception) | Construct an instance of the DeviceRegistrationFailedException class
DeviceRegistrationFailedException (String) | Construct an instance of the DeviceRegistrationFailedException class
DeviceRegistrationFailedException (String, Exception) | Construct an instance of the DeviceRegistrationFailedException class

See Also

Reference

DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Constructor ()
[image]

Construct an instance of the DeviceRegistrationFailedException class

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeviceRegistrationFailedException ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Constructor (DeviceRegistrationErrorCode, String)
[image]

Construct an instance of the DeviceRegistrationFailedException class

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    code As DeviceRegistrationErrorCode, _
    subCode As String _
)

C#
public DeviceRegistrationFailedException (
    DeviceRegistrationErrorCode code,
    string subCode
)

C++

J#

JScript

Parameters
code
Error code that occurred
subCode
Subcode that occurred
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Constructor (DeviceRegistrationErrorCode, String, Exception)
[image]

Construct an instance of the DeviceRegistrationFailedException class

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    code As DeviceRegistrationErrorCode, _
    subCode As String, _
    innerException As Exception _
)

C#
public DeviceRegistrationFailedException (
    DeviceRegistrationErrorCode code,
    string subCode,
    Exception innerException
)

C++

J#

JScript

Parameters
code
Error code that occurred
subCode
Subcode that occurred
innerException
Inner exception
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Constructor (String)
[image]

Construct an instance of the DeviceRegistrationFailedException class

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String _
)

C#
public DeviceRegistrationFailedException (
    string message
)

C++

J#

JScript

Parameters
message
Message to pass
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Constructor (String, Exception)
[image]

Construct an instance of the DeviceRegistrationFailedException class

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)

C#
public DeviceRegistrationFailedException (
    string message,
    Exception innerException
)

C++

J#

JScript

Parameters
message
Message to pass
innerException
Exception to include
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetBaseException | (inherited from Exception)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | Overridden. Internal Use only
public method | GetType | (inherited from Exception)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeviceRegistrationFailedException Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException.GetObjectData Method
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

C#
public override void GetObjectData (
    SerializationInfo info,
    StreamingContext context
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Data | (inherited from Exception)
public property | HelpLink | (inherited from Exception)
public property | InnerException | (inherited from Exception)
public property | Message | (inherited from Exception)
public property | RegistrationErrorCode | Error code that occurred during registration
public property | Source | (inherited from Exception)
public property | StackTrace | (inherited from Exception)
public property | TargetSite | (inherited from Exception)

Protected Properties

 | Name | Description
protected property | HResult | (inherited from Exception)

See Also

Reference

DeviceRegistrationFailedException Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException.RegistrationErrorCode Property
[image]

Error code that occurred during registration

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RegistrationErrorCode As DeviceRegistrationErrorCode

C#
public DeviceRegistrationErrorCode RegistrationErrorCode { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationFailedException Events
[image]

Protected Events

 | Name | Description
protected event | SerializeObjectState | (inherited from Exception)

See Also

Reference

DeviceRegistrationFailedException Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationRequest Class
See Also Members
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlRootAttribute("DeviceAddRequest")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public NotInheritable Class DeviceRegistrationRequest

C#
[XmlRootAttribute("DeviceAddRequest")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public sealed class DeviceRegistrationRequest

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.DeviceRegistrationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationRequest Members
See Also Constructors Methods Properties
[image]

Internal Use only

The following tables list the members exposed by the DeviceRegistrationRequest type.

Public Constructors

Name | Description
DeviceRegistrationRequest | Overloaded.
Top

Public Properties

 | Name | Description
public property | Authentication | Internal Use only
public property | ClientInfo | Internal Use only
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeviceRegistrationRequest Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationRequest Constructor
[image]

Overload List

Name | Description
DeviceRegistrationRequest () | Internal Use only
DeviceRegistrationRequest (Guid, LiveDevice) | Internal Use only

See Also

Reference

DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationRequest Constructor ()
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeviceRegistrationRequest ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationRequest Constructor (Guid, LiveDevice)
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    applicationId As Guid, _
    device As LiveDevice _
)

C#
public DeviceRegistrationRequest (
    Guid applicationId,
    LiveDevice device
)

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeviceRegistrationRequest Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationRequest Properties
[image]

Public Properties

 | Name | Description
public property | Authentication | Internal Use only
public property | ClientInfo | Internal Use only

See Also

Reference

DeviceRegistrationRequest Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationRequest.Authentication Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("Authentication")> _
Public Property Authentication As DeviceRegistrationAuthentication

C#
[XmlElementAttribute("Authentication")]
public DeviceRegistrationAuthentication Authentication { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationRequest.ClientInfo Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("ClientInfo")> _
Public Property ClientInfo As DeviceRegistrationClientInfo

C#
[XmlElementAttribute("ClientInfo")]
public DeviceRegistrationClientInfo ClientInfo { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponse Class
See Also Members
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlRootAttribute("DeviceAddResponse")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public NotInheritable Class DeviceRegistrationResponse

C#
[XmlRootAttribute("DeviceAddResponse")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public sealed class DeviceRegistrationResponse

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.DeviceRegistrationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponse Members
See Also Constructors Methods Properties
[image]

Internal Use only

The following tables list the members exposed by the DeviceRegistrationResponse type.

Public Constructors

Name | Description
DeviceRegistrationResponse |
Top

Public Properties

 | Name | Description
public property | Error | Internal Use only
public property | ErrorSubCode | Internal Use only
public property | IsSuccess | Internal Use only
public property | Puid | Internal Use only
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeviceRegistrationResponse Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponse Constructor
[image]

Initializes a new instance of the DeviceRegistrationResponse Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeviceRegistrationResponse ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeviceRegistrationResponse Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponse Properties
[image]

Public Properties

 | Name | Description
public property | Error | Internal Use only
public property | ErrorSubCode | Internal Use only
public property | IsSuccess | Internal Use only
public property | Puid | Internal Use only

See Also

Reference

DeviceRegistrationResponse Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponse.Error Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("Error")> _
Public Property Error As DeviceRegistrationResponseError

C#
[XmlElementAttribute("Error")]
public DeviceRegistrationResponseError Error { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponse.ErrorSubCode Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("ErrorSubcode")> _
Public Property ErrorSubCode As String

C#
[XmlElementAttribute("ErrorSubcode")]
public string ErrorSubCode { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponse.IsSuccess Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("success")> _
Public Property IsSuccess As Boolean

C#
[XmlElementAttribute("success")]
public bool IsSuccess { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponse.Puid Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("puid")> _
Public Property Puid As String

C#
[XmlElementAttribute("puid")]
public string Puid { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponseError Class
See Also Members
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<XmlRootAttribute("Error")> _
Public NotInheritable Class DeviceRegistrationResponseError

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[XmlRootAttribute("Error")]
public sealed class DeviceRegistrationResponseError

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.DeviceRegistrationResponseError
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponseError Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponseError Members
See Also Constructors Methods Properties
[image]

Internal Use only

The following tables list the members exposed by the DeviceRegistrationResponseError type.

Public Constructors

Name | Description
DeviceRegistrationResponseError |
Top

Public Properties

 | Name | Description
public property | Code | Internal Use only
public property | RegistrationErrorCode | Internal Use only
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeviceRegistrationResponseError Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponseError Constructor
[image]

Initializes a new instance of the DeviceRegistrationResponseError Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeviceRegistrationResponseError ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponseError Class
DeviceRegistrationResponseError Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponseError Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeviceRegistrationResponseError Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponseError Properties
[image]

Public Properties

 | Name | Description
public property | Code | Internal Use only
public property | RegistrationErrorCode | Internal Use only

See Also

Reference

DeviceRegistrationResponseError Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponseError.Code Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlAttributeAttribute("Code")> _
Public Property Code As String

C#
[XmlAttributeAttribute("Code")]
public string Code { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponseError Class
DeviceRegistrationResponseError Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceRegistrationResponseError.RegistrationErrorCode Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlIgnoreAttribute> _
Public Property RegistrationErrorCode As DeviceRegistrationErrorCode

C#
[XmlIgnoreAttribute]
public DeviceRegistrationErrorCode RegistrationErrorCode { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponseError Class
DeviceRegistrationResponseError Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName Class
See Also Members
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public NotInheritable Class DeviceUserName

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public sealed class DeviceUserName

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.DeviceUserName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName Members
See Also Constructors Methods Properties
[image]

Internal Use only

The following tables list the members exposed by the DeviceUserName type.

Public Constructors

Name | Description
DeviceUserName | Internal Use only
Top

Public Properties

 | Name | Description
public property | DecryptedPassword | Internal Use only
public property | DeviceId | Internal Use only
public property | DeviceName | Internal Use only
public property | EncryptedPassword | Internal Use only
public property | UserNameType | Internal Use only
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToClientCredentials | Internal Use only
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

DeviceUserName Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName Constructor
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DeviceUserName ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToClientCredentials | Internal Use only
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

DeviceUserName Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName.ToClientCredentials Method
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ToClientCredentials As ClientCredentials

C#
public ClientCredentials ToClientCredentials ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName Properties
[image]

Public Properties

 | Name | Description
public property | DecryptedPassword | Internal Use only
public property | DeviceId | Internal Use only
public property | DeviceName | Internal Use only
public property | EncryptedPassword | Internal Use only
public property | UserNameType | Internal Use only

See Also

Reference

DeviceUserName Class
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName.DecryptedPassword Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlIgnoreAttribute> _
Public Property DecryptedPassword As String

C#
[XmlIgnoreAttribute]
public string DecryptedPassword { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName.DeviceId Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property DeviceId As String

C#
public string DeviceId { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName.DeviceName Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlAttributeAttribute("username")> _
Public Property DeviceName As String

C#
[XmlAttributeAttribute("username")]
public string DeviceName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName.EncryptedPassword Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("Pwd")> _
Public Property EncryptedPassword As String

C#
[XmlElementAttribute("Pwd")]
public string EncryptedPassword { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Tooling.Connector Namespace


DeviceUserName.UserNameType Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlAttributeAttribute("type")> _
Public Property UserNameType As String

C#
[XmlAttributeAttribute("type")]
public string UserNameType { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class DynamicsFileLogTraceListener
    Inherits FileLogTraceListener

C#
public class DynamicsFileLogTraceListener : FileLogTraceListener

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.MarshalByRefObject

                System.Diagnostics.TraceListener

                Microsoft.VisualBasic.Logging.FileLogTraceListener
        Microsoft.Xrm.Tooling.Connector.DynamicsFileLogTraceListener
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DynamicsFileLogTraceListener Members
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the DynamicsFileLogTraceListener type.

Public Constructors

Name | Description
DynamicsFileLogTraceListener | Overloaded.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Append | (inherited from FileLogTraceListener)
public property | Attributes | (inherited from TraceListener)
public property | AutoFlush | (inherited from FileLogTraceListener)
public property | BaseFileName | (inherited from FileLogTraceListener)
public property | CustomLocation | (inherited from FileLogTraceListener)
public property | Delimiter | (inherited from FileLogTraceListener)
public property | DiskSpaceExhaustedBehavior | (inherited from FileLogTraceListener)
public property | Encoding | (inherited from FileLogTraceListener)
public property | Filter | (inherited from TraceListener)
public property | FullLogFileName | (inherited from FileLogTraceListener)
public property | IncludeHostName | (inherited from FileLogTraceListener)
public property | IndentLevel | (inherited from TraceListener)
public property | IndentSize | (inherited from TraceListener)
public property | IsThreadSafe | (inherited from TraceListener)
public property | Location | (inherited from FileLogTraceListener)
public property | LogFileCreationSchedule | (inherited from FileLogTraceListener)
public property | MaxFileSize | (inherited from FileLogTraceListener)
public property | Name | (inherited from TraceListener)
public property | ReserveDiskSpace | (inherited from FileLogTraceListener)
public property | TraceOutputOptions | (inherited from TraceListener)
Top

Protected Properties

 | Name | Description
protected property | NeedIndent | (inherited from TraceListener)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Close | Overridden. (inherited from TraceListener)
public method | CreateObjRef | (inherited from MarshalByRefObject)
public method | Dispose | (inherited from TraceListener)
public method | Equals | (inherited from Object)
public method | Fail | (inherited from TraceListener)
public method | Fail | (inherited from TraceListener)
public method | Flush | Overridden. (inherited from TraceListener)
public method | GetHashCode | (inherited from Object)
public method | GetLifetimeService | (inherited from MarshalByRefObject)
public method | GetType | (inherited from Object)
public method | InitializeLifetimeService | (inherited from MarshalByRefObject)
public method | ToString | (inherited from Object)
public method | TraceData | Overridden. (inherited from TraceListener)
public method | TraceData | Overridden. (inherited from TraceListener)
public method | TraceEvent | Overloaded. Overridden.
public method | TraceEvent | (inherited from TraceListener)
public method | TraceTransfer | (inherited from TraceListener)
public method | Write | Overridden. (inherited from TraceListener)
public method | Write | (inherited from TraceListener)
public method | Write | (inherited from TraceListener)
public method | Write | (inherited from TraceListener)
public method | WriteLine | Overridden. (inherited from TraceListener)
public method | WriteLine | (inherited from TraceListener)
public method | WriteLine | (inherited from TraceListener)
public method | WriteLine | (inherited from TraceListener)
Top

Protected Methods

 | Name | Description
protected method | Dispose | Overridden. (inherited from TraceListener)
protected method | Finalize | (inherited from Object)
protected method | GetSupportedAttributes | Overridden. (inherited from TraceListener)
 | IsWritePermitted |
protected method | MemberwiseClone | (inherited from MarshalByRefObject)
protected method | MemberwiseClone | (inherited from Object)
protected method | WriteIndent | (inherited from TraceListener)
Top

See Also

Reference

DynamicsFileLogTraceListener Class
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener Constructor
[image]

Overload List

Name | Description
DynamicsFileLogTraceListener () |
DynamicsFileLogTraceListener (String) |

See Also

Reference

DynamicsFileLogTraceListener Class
DynamicsFileLogTraceListener Members
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener Constructor ()
[image]

Initializes a new instance of the DynamicsFileLogTraceListener Class.Initializes a new instance of the DynamicsFileLogTraceListener Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public DynamicsFileLogTraceListener ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DynamicsFileLogTraceListener Class
DynamicsFileLogTraceListener Members
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener Constructor (String)
[image]

Initializes a new instance of the DynamicsFileLogTraceListener Class.Initializes a new instance of the DynamicsFileLogTraceListener Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    name As String _
)

C#
public DynamicsFileLogTraceListener (
    string name
)

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DynamicsFileLogTraceListener Class
DynamicsFileLogTraceListener Members
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Close | Overridden. (inherited from TraceListener)
public method | CreateObjRef | (inherited from MarshalByRefObject)
public method | Dispose | (inherited from TraceListener)
public method | Equals | (inherited from Object)
public method | Fail | (inherited from TraceListener)
public method | Fail | (inherited from TraceListener)
public method | Flush | Overridden. (inherited from TraceListener)
public method | GetHashCode | (inherited from Object)
public method | GetLifetimeService | (inherited from MarshalByRefObject)
public method | GetType | (inherited from Object)
public method | InitializeLifetimeService | (inherited from MarshalByRefObject)
public method | ToString | (inherited from Object)
public method | TraceData | Overridden. (inherited from TraceListener)
public method | TraceData | Overridden. (inherited from TraceListener)
public method | TraceEvent | Overloaded. Overridden.
public method | TraceEvent | (inherited from TraceListener)
public method | TraceTransfer | (inherited from TraceListener)
public method | Write | Overridden. (inherited from TraceListener)
public method | Write | (inherited from TraceListener)
public method | Write | (inherited from TraceListener)
public method | Write | (inherited from TraceListener)
public method | WriteLine | Overridden. (inherited from TraceListener)
public method | WriteLine | (inherited from TraceListener)
public method | WriteLine | (inherited from TraceListener)
public method | WriteLine | (inherited from TraceListener)

Protected Methods

 | Name | Description
protected method | Dispose | Overridden. (inherited from TraceListener)
protected method | Finalize | (inherited from Object)
protected method | GetSupportedAttributes | Overridden. (inherited from TraceListener)
 | IsWritePermitted |
protected method | MemberwiseClone | (inherited from MarshalByRefObject)
protected method | MemberwiseClone | (inherited from Object)
protected method | WriteIndent | (inherited from TraceListener)

See Also

Reference

DynamicsFileLogTraceListener Class
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener.IsWritePermitted Method
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Shared Function IsWritePermitted ( _
    Location As String _
) As Boolean

C#
protected static bool IsWritePermitted (
    string Location
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DynamicsFileLogTraceListener Class
DynamicsFileLogTraceListener Members
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener.TraceEvent Method
[image]

Overload List

Name | Description
DynamicsFileLogTraceListener.TraceEvent (TraceEventCache, String, TraceEventType, Int32, String) |
DynamicsFileLogTraceListener.TraceEvent (TraceEventCache, String, TraceEventType, Int32, String, Object[]) |

See Also

Reference

DynamicsFileLogTraceListener Class
DynamicsFileLogTraceListener Members
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener.TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Sub TraceEvent ( _
    eventCache As TraceEventCache, _
    source As String, _
    eventType As TraceEventType, _
    id As Integer, _
    message As String _
)

C#
public override void TraceEvent (
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    string message
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DynamicsFileLogTraceListener Class
DynamicsFileLogTraceListener Members
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener.TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String, Object[])
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overrides Sub TraceEvent ( _
    eventCache As TraceEventCache, _
    source As String, _
    eventType As TraceEventType, _
    id As Integer, _
    format As String, _
    ParamArray args As Object() _
)

C#
public override void TraceEvent (
    TraceEventCache eventCache,
    string source,
    TraceEventType eventType,
    int id,
    string format,
    params Object[] args
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DynamicsFileLogTraceListener Class
DynamicsFileLogTraceListener Members
Microsoft.Xrm.Tooling.Connector Namespace


DynamicsFileLogTraceListener Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Append | (inherited from FileLogTraceListener)
public property | Attributes | (inherited from TraceListener)
public property | AutoFlush | (inherited from FileLogTraceListener)
public property | BaseFileName | (inherited from FileLogTraceListener)
public property | CustomLocation | (inherited from FileLogTraceListener)
public property | Delimiter | (inherited from FileLogTraceListener)
public property | DiskSpaceExhaustedBehavior | (inherited from FileLogTraceListener)
public property | Encoding | (inherited from FileLogTraceListener)
public property | Filter | (inherited from TraceListener)
public property | FullLogFileName | (inherited from FileLogTraceListener)
public property | IncludeHostName | (inherited from FileLogTraceListener)
public property | IndentLevel | (inherited from TraceListener)
public property | IndentSize | (inherited from TraceListener)
public property | IsThreadSafe | (inherited from TraceListener)
public property | Location | (inherited from FileLogTraceListener)
public property | LogFileCreationSchedule | (inherited from FileLogTraceListener)
public property | MaxFileSize | (inherited from FileLogTraceListener)
public property | Name | (inherited from TraceListener)
public property | ReserveDiskSpace | (inherited from FileLogTraceListener)
public property | TraceOutputOptions | (inherited from TraceListener)

Protected Properties

 | Name | Description
protected property | NeedIndent | (inherited from TraceListener)

See Also

Reference

DynamicsFileLogTraceListener Class
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice Class
See Also Members
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<XmlRootAttribute("Data")> _
Public NotInheritable Class LiveDevice

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[XmlRootAttribute("Data")]
public sealed class LiveDevice

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.LiveDevice
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Members
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice Members
See Also Constructors Methods Properties
[image]

Internal Use only

The following tables list the members exposed by the LiveDevice type.

Public Constructors

Name | Description
LiveDevice |
Top

Public Properties

 | Name | Description
public property | ClockSkew | Internal Use only
public property | Expiry | Internal Use only
public property | Token | Internal Use only
public property | User | Internal Use only
public property | Version | Internal Use only
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

LiveDevice Class
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice Constructor
[image]

Initializes a new instance of the LiveDevice Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public LiveDevice ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

LiveDevice Class
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice Properties
[image]

Public Properties

 | Name | Description
public property | ClockSkew | Internal Use only
public property | Expiry | Internal Use only
public property | Token | Internal Use only
public property | User | Internal Use only
public property | Version | Internal Use only

See Also

Reference

LiveDevice Class
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice.ClockSkew Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("ClockSkew")> _
Public Property ClockSkew As String

C#
[XmlElementAttribute("ClockSkew")]
public string ClockSkew { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice.Expiry Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("Expiry")> _
Public Property Expiry As String

C#
[XmlElementAttribute("Expiry")]
public string Expiry { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice.Token Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("Token")> _
Public Property Token As XmlNode

C#
[XmlElementAttribute("Token")]
public XmlNode Token { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice.User Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("User")> _
Public Property User As DeviceUserName

C#
[XmlElementAttribute("User")]
public DeviceUserName User { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Tooling.Connector Namespace


LiveDevice.Version Property
[image]

Internal Use only

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlAttributeAttribute("version")> _
Public Property Version As Integer

C#
[XmlAttributeAttribute("version")]
public int Version { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Tooling.Connector Namespace


PicklistAttributeData Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class PicklistAttributeData
    Inherits AttributeData

C#
public sealed class PicklistAttributeData : AttributeData

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Tooling.Connector.AttributeData
    Microsoft.Xrm.Tooling.Connector.PicklistAttributeData
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PicklistAttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


PicklistAttributeData Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the PicklistAttributeData type.

Public Constructors

Name | Description
PicklistAttributeData |
Top

Public Properties

 | Name | Description
public property | ActualValue | Gets or sets the actual value for the attribute. (inherited from AttributeData)
public property | AttributeLabel | Gets or sets the label for the attribute. (inherited from AttributeData)
public property | AttributeType | Gets or sets the type for the attribute. (inherited from AttributeData)
public property | DisplayValue | Gets or sets the display value for the attribute. (inherited from AttributeData)
public property | IsUnsupported | (inherited from AttributeData)
public property | PicklistOptions |
public property | SchemaName | (inherited from AttributeData)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

PicklistAttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


PicklistAttributeData Constructor
[image]

Initializes a new instance of the PicklistAttributeData Class.Initializes a new instance of the PicklistAttributeData Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PicklistAttributeData ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PicklistAttributeData Class
PicklistAttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


PicklistAttributeData Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

PicklistAttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


PicklistAttributeData Properties
[image]

Public Properties

 | Name | Description
public property | ActualValue | Gets or sets the actual value for the attribute. (inherited from AttributeData)
public property | AttributeLabel | Gets or sets the label for the attribute. (inherited from AttributeData)
public property | AttributeType | Gets or sets the type for the attribute. (inherited from AttributeData)
public property | DisplayValue | Gets or sets the display value for the attribute. (inherited from AttributeData)
public property | IsUnsupported | (inherited from AttributeData)
public property | PicklistOptions |
public property | SchemaName | (inherited from AttributeData)

See Also

Reference

PicklistAttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


PicklistAttributeData.PicklistOptions Property
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property PicklistOptions As OptionMetadata()

C#
public OptionMetadata[] PicklistOptions { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PicklistAttributeData Class
PicklistAttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch Class
See Also Members
[image]

Container class for Batches.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class RequestBatch

C#
public sealed class RequestBatch

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.RequestBatch
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestBatch Members
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch Members
See Also Constructors Methods Properties
[image]

Container class for Batches.

The following tables list the members exposed by the RequestBatch type.

Public Constructors

Name | Description
RequestBatch | Default constructor
Top

Public Properties

 | Name | Description
public property | BatchId | ID of the batch.
public property | BatchItems | Items to execute
public property | BatchName | DisplayName of the batch.
public property | BatchRequestSettings | Settings for this Execute Multiple Request.
public property | BatchResults | Results from the Batch.
public property | Status | Status of the batch.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

RequestBatch Class
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch Constructor
[image]

Default constructor

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    <OptionalAttribute> Optional batchName As String = "", _
    <OptionalAttribute> Optional returnResponses As Boolean = True, _
    <OptionalAttribute> Optional continueOnError As Boolean = False _
)

C#
public RequestBatch (
    [OptionalAttribute] string batchName,
    [OptionalAttribute] bool returnResponses,
    [OptionalAttribute] bool continueOnError
)

C++

J#

JScript

Parameters
returnResponses
True to return responses, False to not return responses
continueOnError
True to continue if anyone item trips an error, False to stop on the first error.
batchName
String name of the batch, if blank, a GUID is used
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestBatch Class
RequestBatch Members
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

RequestBatch Class
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch Properties
[image]

Public Properties

 | Name | Description
public property | BatchId | ID of the batch.
public property | BatchItems | Items to execute
public property | BatchName | DisplayName of the batch.
public property | BatchRequestSettings | Settings for this Execute Multiple Request.
public property | BatchResults | Results from the Batch.
public property | Status | Status of the batch.

See Also

Reference

RequestBatch Class
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch.BatchId Property
[image]

ID of the batch.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BatchId As Guid

C#
public Guid BatchId { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestBatch Class
RequestBatch Members
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch.BatchItems Property
[image]

Items to execute

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BatchItems As List(Of BatchItemOrganizationRequest)

C#
public List<BatchItemOrganizationRequest> BatchItems { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestBatch Class
RequestBatch Members
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch.BatchName Property
[image]

DisplayName of the batch.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BatchName As String

C#
public string BatchName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestBatch Class
RequestBatch Members
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch.BatchRequestSettings Property
[image]

Settings for this Execute Multiple Request.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BatchRequestSettings As ExecuteMultipleSettings

C#
public ExecuteMultipleSettings BatchRequestSettings { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestBatch Class
RequestBatch Members
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch.BatchResults Property
[image]

Results from the Batch.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property BatchResults As ExecuteMultipleResponse

C#
public ExecuteMultipleResponse BatchResults { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestBatch Class
RequestBatch Members
Microsoft.Xrm.Tooling.Connector Namespace


RequestBatch.Status Property
[image]

Status of the batch.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As BatchStatus

C#
public BatchStatus Status { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
RequestBatch Class
RequestBatch Members
Microsoft.Xrm.Tooling.Connector Namespace


StringAttributeData Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class StringAttributeData
    Inherits AttributeData

C#
public sealed class StringAttributeData : AttributeData

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Tooling.Connector.AttributeData
    Microsoft.Xrm.Tooling.Connector.StringAttributeData
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
StringAttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


StringAttributeData Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the StringAttributeData type.

Public Constructors

Name | Description
StringAttributeData |
Top

Public Properties

 | Name | Description
public property | ActualValue | Gets or sets the actual value for the attribute. (inherited from AttributeData)
public property | AttributeLabel | Gets or sets the label for the attribute. (inherited from AttributeData)
public property | AttributeType | Gets or sets the type for the attribute. (inherited from AttributeData)
public property | DisplayValue | Gets or sets the display value for the attribute. (inherited from AttributeData)
public property | IsUnsupported | (inherited from AttributeData)
public property | MaxLength |
public property | SchemaName | (inherited from AttributeData)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StringAttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


StringAttributeData Constructor
[image]

Initializes a new instance of the StringAttributeData Class.Initializes a new instance of the StringAttributeData Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StringAttributeData ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
StringAttributeData Class
StringAttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


StringAttributeData Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StringAttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


StringAttributeData Properties
[image]

Public Properties

 | Name | Description
public property | ActualValue | Gets or sets the actual value for the attribute. (inherited from AttributeData)
public property | AttributeLabel | Gets or sets the label for the attribute. (inherited from AttributeData)
public property | AttributeType | Gets or sets the type for the attribute. (inherited from AttributeData)
public property | DisplayValue | Gets or sets the display value for the attribute. (inherited from AttributeData)
public property | IsUnsupported | (inherited from AttributeData)
public property | MaxLength |
public property | SchemaName | (inherited from AttributeData)

See Also

Reference

StringAttributeData Class
Microsoft.Xrm.Tooling.Connector Namespace


StringAttributeData.MaxLength Property
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MaxLength As Integer

C#
public int MaxLength { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
StringAttributeData Class
StringAttributeData Members
Microsoft.Xrm.Tooling.Connector Namespace


TraceControlSettings Class
See Also Members
[image]

This class provides an override for the default trace settings. These settings must be set before the components in the control are used for them to be effective.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class TraceControlSettings

C#
public class TraceControlSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.TraceControlSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Members
Microsoft.Xrm.Tooling.Connector Namespace


TraceControlSettings Members
See Also Constructors Methods Properties
[image]

This class provides an override for the default trace settings. These settings must be set before the components in the control are used for them to be effective.

The following tables list the members exposed by the TraceControlSettings type.

Public Constructors

Name | Description
TraceControlSettings |
Top

Public Properties

Name | Description
TraceLevel | Override Trace Level setting.
Top

Public Methods (see also Protected Methods)

 | Name | Description
 | AddTraceListener | Adds a listener to the trace listen array
 | CloseListeners | Closes any trace listeners that were configured
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TraceControlSettings Class
Microsoft.Xrm.Tooling.Connector Namespace


TraceControlSettings Constructor
[image]

Initializes a new instance of the TraceControlSettings Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TraceControlSettings ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.Connector Namespace


TraceControlSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
 | AddTraceListener | Adds a listener to the trace listen array
 | CloseListeners | Closes any trace listeners that were configured
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TraceControlSettings Class
Microsoft.Xrm.Tooling.Connector Namespace


TraceControlSettings.AddTraceListener Method
[image]

Adds a listener to the trace listen array

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function AddTraceListener ( _
    listenerToAdd As TraceListener _
) As Boolean

C#
public static bool AddTraceListener (
    TraceListener listenerToAdd
)

C++

J#

JScript

Parameters
listenerToAdd
Trace Listener you wish to add
Return Value
true on success, false on fail.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.Connector Namespace


TraceControlSettings.CloseListeners Method
[image]

Closes any trace listeners that were configured

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub CloseListeners

C#
public static void CloseListeners ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.Connector Namespace


TraceControlSettings Properties
[image]

Public Properties

Name | Description
TraceLevel | Override Trace Level setting.

See Also

Reference

TraceControlSettings Class
Microsoft.Xrm.Tooling.Connector Namespace


TraceControlSettings.TraceLevel Property
[image]

Override Trace Level setting.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Property TraceLevel As SourceLevels

C#
public static SourceLevels TraceLevel { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class XmlUtil

C#
public class XmlUtil

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.XmlUtil
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil Members
See Also Methods Constructors
[image]

The following tables list the members exposed by the XmlUtil type.

Protected Constructors

Name | Description
XmlUtil |
Top

Public Methods (see also Protected Methods)

 | Name | Description
 | CreateXmlDocument | Overloaded.
 | CreateXmlReader | Overloaded.
 | CreateXmlWriter | Overloaded.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

XmlUtil Class
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil Constructor
[image]

Initializes a new instance of the XmlUtil Class.Initializes a new instance of the XmlUtil Class.

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected XmlUtil ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
 | CreateXmlDocument | Overloaded.
 | CreateXmlReader | Overloaded.
 | CreateXmlWriter | Overloaded.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

XmlUtil Class
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlDocument Method
[image]

Overload List

Name | Description
XmlUtil.CreateXmlDocument () |
XmlUtil.CreateXmlDocument (Stream) |
XmlUtil.CreateXmlDocument (String) |
XmlUtil.CreateXmlDocument (String, Boolean) |
XmlUtil.CreateXmlDocument (XmlReader) |

See Also

Reference

XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlDocument Method ()
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlDocument As XmlDocument

C#
public static XmlDocument CreateXmlDocument ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlDocument Method (Stream)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlDocument ( _
    input As Stream _
) As XmlDocument

C#
public static XmlDocument CreateXmlDocument (
    Stream input
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlDocument Method (String)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlDocument ( _
    xml As String _
) As XmlDocument

C#
public static XmlDocument CreateXmlDocument (
    string xml
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlDocument Method (String, Boolean)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlDocument ( _
    xml As String, _
    preserveWhiteSpace As Boolean _
) As XmlDocument

C#
public static XmlDocument CreateXmlDocument (
    string xml,
    bool preserveWhiteSpace
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlDocument Method (XmlReader)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlDocument ( _
    reader As XmlReader _
) As XmlDocument

C#
public static XmlDocument CreateXmlDocument (
    XmlReader reader
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlReader Method
[image]

Overload List

Name | Description
XmlUtil.CreateXmlReader (Stream) |
XmlUtil.CreateXmlReader (String) |
XmlUtil.CreateXmlReader (String, Boolean) |

See Also

Reference

XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlReader Method (Stream)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlReader ( _
    xmlStream As Stream _
) As XmlReader

C#
public static XmlReader CreateXmlReader (
    Stream xmlStream
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlReader Method (String)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlReader ( _
    xml As String _
) As XmlReader

C#
public static XmlReader CreateXmlReader (
    string xml
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlReader Method (String, Boolean)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlReader ( _
    xml As String, _
    preserveWhiteSpace As Boolean _
) As XmlReader

C#
public static XmlReader CreateXmlReader (
    string xml,
    bool preserveWhiteSpace
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlWriter Method
[image]

Overload List

Name | Description
XmlUtil.CreateXmlWriter (TextWriter, Boolean) |
XmlUtil.CreateXmlWriter (String, Encoding, Boolean) |

See Also

Reference

XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlWriter Method (TextWriter, Boolean)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlWriter ( _
    textWriter As TextWriter, _
    indented As Boolean _
) As XmlWriter

C#
public static XmlWriter CreateXmlWriter (
    TextWriter textWriter,
    bool indented
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


XmlUtil.CreateXmlWriter Method (String, Encoding, Boolean)
[image]

Namespace: Microsoft.Xrm.Tooling.Connector
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function CreateXmlWriter ( _
    fileName As String, _
    encoding As Encoding, _
    indented As Boolean _
) As XmlWriter

C#
public static XmlWriter CreateXmlWriter (
    string fileName,
    Encoding encoding,
    bool indented
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlUtil Class
XmlUtil Members
Microsoft.Xrm.Tooling.Connector Namespace


Microsoft.Xrm.Tooling.Connector.Model Namespace

Classes

Class | Description
CrmOrgByServer | Describes a Single Organization returned from a CRM Discovery server
CrmOrgList | Describes the Collection of Orgs that a user may select from. This is used to display the list to the user


CrmOrgByServer Class
See Also Members
[image]

Describes a Single Organization returned from a CRM Discovery server

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CrmOrgByServer
    Implements INotifyPropertyChanged

C#
public sealed class CrmOrgByServer : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.Model.CrmOrgByServer
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer Members
See Also Constructors Events Methods Properties
[image]

Describes a Single Organization returned from a CRM Discovery server

The following tables list the members exposed by the CrmOrgByServer type.

Public Constructors

Name | Description
CrmOrgByServer |
Top

Public Properties

 | Name | Description
public property | DiscoveryServer | This is the URI needed to connect to the Organization
public property | DiscoveryServerName | This is the name assigned to the Discovery Server, this is used to visual separate organizations returned by Discovery server used, or Premise solutions.
public property | FriendlyName | This is the display name for the organization that a user sees when working in CRM
public property | OrgDetail | This is the details of the Organization, returned directly from CRM
public property | UniqueOrgName | This is the actual name for the organization in CRM, and is required to connect to CRM
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | PropertyChanged | WCF EVENT hook
Top

See Also

Reference

CrmOrgByServer Class
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer Constructor
[image]

Initializes a new instance of the CrmOrgByServer Class.

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmOrgByServer ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmOrgByServer Class
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer Properties
[image]

Public Properties

 | Name | Description
public property | DiscoveryServer | This is the URI needed to connect to the Organization
public property | DiscoveryServerName | This is the name assigned to the Discovery Server, this is used to visual separate organizations returned by Discovery server used, or Premise solutions.
public property | FriendlyName | This is the display name for the organization that a user sees when working in CRM
public property | OrgDetail | This is the details of the Organization, returned directly from CRM
public property | UniqueOrgName | This is the actual name for the organization in CRM, and is required to connect to CRM

See Also

Reference

CrmOrgByServer Class
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer.DiscoveryServer Property
[image]

This is the URI needed to connect to the Organization

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property DiscoveryServer As Uri

C#
public Uri DiscoveryServer { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer.DiscoveryServerName Property
[image]

This is the name assigned to the Discovery Server, this is used to visual separate organizations returned by Discovery server used, or Premise solutions.

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DiscoveryServerName As String

C#
public string DiscoveryServerName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer.FriendlyName Property
[image]

This is the display name for the organization that a user sees when working in CRM

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property FriendlyName As String

C#
public string FriendlyName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer.OrgDetail Property
[image]

This is the details of the Organization, returned directly from CRM

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OrgDetail As OrganizationDetail

C#
public OrganizationDetail OrgDetail { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer.UniqueOrgName Property
[image]

This is the actual name for the organization in CRM, and is required to connect to CRM

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property UniqueOrgName As String

C#
public string UniqueOrgName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged | WCF EVENT hook

See Also

Reference

CrmOrgByServer Class
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgByServer.PropertyChanged Event
[image]

WCF EVENT hook

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgList Class
See Also Members
[image]

Describes the Collection of Orgs that a user may select from. This is used to display the list to the user

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CrmOrgList
    Implements INotifyPropertyChanged

C#
public sealed class CrmOrgList : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.Connector.Model.CrmOrgList
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgList Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgList Members
See Also Constructors Events Methods Properties
[image]

Describes the Collection of Orgs that a user may select from. This is used to display the list to the user

The following tables list the members exposed by the CrmOrgList type.

Public Constructors

Name | Description
CrmOrgList | Container for CRM Orgs List.
Top

Public Properties

 | Name | Description
public property | OrgsList | List of Orgs
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | PropertyChanged | WPF EVENT HOOK
Top

See Also

Reference

CrmOrgList Class
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgList Constructor
[image]

Container for CRM Orgs List.

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmOrgList ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgList Class
CrmOrgList Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgList Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmOrgList Class
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgList Properties
[image]

Public Properties

 | Name | Description
public property | OrgsList | List of Orgs

See Also

Reference

CrmOrgList Class
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgList.OrgsList Property
[image]

List of Orgs

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OrgsList As ObservableCollection(Of CrmOrgByServer)

C#
public ObservableCollection<CrmOrgByServer> OrgsList { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgList Class
CrmOrgList Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgList Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged | WPF EVENT HOOK

See Also

Reference

CrmOrgList Class
Microsoft.Xrm.Tooling.Connector.Model Namespace


CrmOrgList.PropertyChanged Event
[image]

WPF EVENT HOOK

Namespace: Microsoft.Xrm.Tooling.Connector.Model
Assembly: Microsoft.Xrm.Tooling.Connector (in Microsoft.Xrm.Tooling.Connector.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgList Class
CrmOrgList Members
Microsoft.Xrm.Tooling.Connector.Model Namespace


Microsoft.Xrm.Tooling.CrmConnectControl Namespace

Classes

Class | Description
ConnectErrorEventArgs | Data Payload for the Connection Error Events
ConnectStatusEventArgs | Data Payload for the Connection status events
CrmConnectionManager | Provides Connection logic and error handling for connecting to CRM2011. This class is designed to operate in the background, off the primary user UI thread. This class raises events that can be used to update the user with progress reports.
CrmServerLoginConfigControl | This control provides the UI components and interaction logic with the CrmConnectionManager Class.
CrmServerLoginControl | This control provides the UI components and interaction logic with the CrmConnectionManager Class.
ErrorWindow | Interaction logic for ErrorWindow.xaml
PendulumDots | Interaction logic for PendulumDots.xaml
SelectOrgDlg | Provides a UI to allow users to select an Organization to login into, if the user has more than one organization available to login to.
ServerConnectStatusEventArgs | Event Raised when the Server Validate Connection Command operates.
ServerLoginConfig_ViewModel |
SortAdorner | Creates a Adorner to indicate sort direction. This class was taken from http://www.switchonthecode.com/tutorials/wpf-tutorial-using-the-listview-part-2-sorting

Enumerations

Enumeration | Description
ServerLoginConfigCtrlMode | Config Mode to run this control in.


ConnectErrorEventArgs Class
See Also Members
[image]

Data Payload for the Connection Error Events

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ConnectErrorEventArgs
    Inherits EventArgs

C#
public class ConnectErrorEventArgs : EventArgs

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs
    Microsoft.Xrm.Tooling.CrmConnectControl.ConnectErrorEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConnectErrorEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectErrorEventArgs Members
See Also Constructors Methods Properties
[image]

Data Payload for the Connection Error Events

The following tables list the members exposed by the ConnectErrorEventArgs type.

Public Constructors

Name | Description
ConnectErrorEventArgs |
Top

Public Properties

 | Name | Description
public property | ErrorMessage | Error message
public property | Ex |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConnectErrorEventArgs Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectErrorEventArgs Constructor
[image]

Initializes a new instance of the ConnectErrorEventArgs Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConnectErrorEventArgs ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConnectErrorEventArgs Class
ConnectErrorEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectErrorEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConnectErrorEventArgs Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectErrorEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | ErrorMessage | Error message
public property | Ex |

See Also

Reference

ConnectErrorEventArgs Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectErrorEventArgs.ErrorMessage Property
[image]

Error message

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ErrorMessage As String

C#
public string ErrorMessage { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConnectErrorEventArgs Class
ConnectErrorEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectErrorEventArgs.Ex Property
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Ex As Exception

C#
public Exception Ex { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConnectErrorEventArgs Class
ConnectErrorEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectStatusEventArgs Class
See Also Members
[image]

Data Payload for the Connection status events

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ConnectStatusEventArgs
    Inherits EventArgs

C#
public class ConnectStatusEventArgs : EventArgs

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs
    Microsoft.Xrm.Tooling.CrmConnectControl.ConnectStatusEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectStatusEventArgs Members
See Also Constructors Methods Properties
[image]

Data Payload for the Connection status events

The following tables list the members exposed by the ConnectStatusEventArgs type.

Public Constructors

Name | Description
ConnectStatusEventArgs | Overloaded.
Top

Public Properties

 | Name | Description
public property | ConnectSucceeded | Flag indicating connection state.
public property | Status | Status of the connection process
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ConnectStatusEventArgs Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectStatusEventArgs Constructor
[image]

Overload List

Name | Description
ConnectStatusEventArgs () |
ConnectStatusEventArgs (Boolean) |

See Also

Reference

ConnectStatusEventArgs Class
ConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectStatusEventArgs Constructor ()
[image]

Initializes a new instance of the ConnectStatusEventArgs Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ConnectStatusEventArgs ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConnectStatusEventArgs Class
ConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectStatusEventArgs Constructor (Boolean)
[image]

Initializes a new instance of the ConnectStatusEventArgs Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    bConnected As Boolean _
)

C#
public ConnectStatusEventArgs (
    bool bConnected
)

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConnectStatusEventArgs Class
ConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectStatusEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ConnectStatusEventArgs Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectStatusEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | ConnectSucceeded | Flag indicating connection state.
public property | Status | Status of the connection process

See Also

Reference

ConnectStatusEventArgs Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectStatusEventArgs.ConnectSucceeded Property
[image]

Flag indicating connection state.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ConnectSucceeded As Boolean

C#
public bool ConnectSucceeded { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConnectStatusEventArgs Class
ConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ConnectStatusEventArgs.Status Property
[image]

Status of the connection process

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Status As String

C#
public string Status { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ConnectStatusEventArgs Class
ConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager Class
See Also Members
[image]

Provides Connection logic and error handling for connecting to CRM2011. This class is designed to operate in the background, off the primary user UI thread. This class raises events that can be used to update the user with progress reports.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class CrmConnectionManager

C#
public class CrmConnectionManager

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.CrmConnectionManager
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager Members
See Also Constructors Events Methods Properties
[image]

Provides Connection logic and error handling for connecting to CRM2011. This class is designed to operate in the background, off the primary user UI thread. This class raises events that can be used to update the user with progress reports.

The following tables list the members exposed by the CrmConnectionManager type.

Public Constructors

Name | Description
CrmConnectionManager | Default constructor.
Top

Public Properties

 | Name | Description
public property | ConnectedOrgFriendlyName | Returns the friendly name of the connected org.
public property | ConnectedOrgPublishedEndpoints | Returns the endpoint collection for the connected org.
public property | ConnectedOrgUniqueName | Returns the unique name for the org that has been connected.
public property | CrmOnlineDiscoveryServerList | Collection of CRM Discovery Servers if a server list has not been submitted to this property, and get is called, a new instance of the CrmOnlineDiscoveryServers is created.
public property | CrmOrgsFoundForUser | List of Organizations that have been requested by the user.
public property | CrmSvc | CRM Connection Object.
public property | HomeRealmServersList | Collection of HomeRealms Loaded by Configuration
public property | HostApplicatioNameOveride | Used in conjunction with the UseUserLocalDirecotryForConfigStore, Allows you to set a name for the config application to use. This is used when the host application cannot provide a proper AppDomain.Current.FriendlyName
public property | LastError | last error from the connection manager
public property | LastException | Last Exception from the connection manager.
public property | ParentControl | This the parent control that invoked me.
public property | ProfileName | Profile name to use for this login process.
public property | UseUserLocalDirectoryForConfigStore | Tells the system to store the user config in the users local app directory instead of the Exe directory.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | CancelConnectToServerCheck | Cancel Connection process.
public method | ConnectToServerCheck | Overloaded.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | LoadConfigFromFile | Loads the Configuration key's from file b/c some things are missing
public method | RemoveUserLocalDirectoryConfigFile | Will remove the user connection data settings from the users app config directory, useable only when the UseUserLocalDirectoryForConfigStore is set to true. this should be called after the connection has been established, or before the connect attempt in order to be effective.
public method | RequireUserLogin | This will check the configuration to determine if a user login is required. and if so, return true.
public method | SaveConfigToFile | Save the configuration Keys to the configuration file.
public method | SetConfigKeyInformation | Sets the current connection information for the server.this can be used to pass in a preconfigured list of keys
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | Overridden. Clean up background worker on exit.
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | ConnectionCheckComplete | Raised when the connection process completes
public event | ServerConnectionStatusUpdate | Raised when a status is updated
Top

See Also

Reference

CrmConnectionManager Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager Constructor
[image]

Default constructor.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmConnectionManager ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | CancelConnectToServerCheck | Cancel Connection process.
public method | ConnectToServerCheck | Overloaded.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | LoadConfigFromFile | Loads the Configuration key's from file b/c some things are missing
public method | RemoveUserLocalDirectoryConfigFile | Will remove the user connection data settings from the users app config directory, useable only when the UseUserLocalDirectoryForConfigStore is set to true. this should be called after the connection has been established, or before the connect attempt in order to be effective.
public method | RequireUserLogin | This will check the configuration to determine if a user login is required. and if so, return true.
public method | SaveConfigToFile | Save the configuration Keys to the configuration file.
public method | SetConfigKeyInformation | Sets the current connection information for the server.this can be used to pass in a preconfigured list of keys
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | Overridden. Clean up background worker on exit.
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmConnectionManager Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.CancelConnectToServerCheck Method
[image]

Cancel Connection process.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub CancelConnectToServerCheck

C#
public void CancelConnectToServerCheck ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ConnectToServerCheck Method
[image]

Overload List

Name | Description
CrmConnectionManager.ConnectToServerCheck () | Begins the authentication process for CRM.
CrmConnectionManager.ConnectToServerCheck (CrmOrgByServer) | Begin Connect check to server

See Also

Reference

CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ConnectToServerCheck Method ()
[image]

Begins the authentication process for CRM.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub ConnectToServerCheck

C#
public void ConnectToServerCheck ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ConnectToServerCheck Method (CrmOrgByServer)
[image]

Begin Connect check to server

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub ConnectToServerCheck ( _
    selectedOrgToConnectTo As CrmOrgByServer _
)

C#
public void ConnectToServerCheck (
    CrmOrgByServer selectedOrgToConnectTo
)

C++

J#

JScript

Parameters
selectedOrgToConnectTo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.Finalize Method
[image]

Clean up background worker on exit.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Sub Finalize

C#
~CrmConnectionManager()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.LoadConfigFromFile Method
[image]

Loads the Configuration key's from file b/c some things are missing

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function LoadConfigFromFile ( _
    <OptionalAttribute> Optional readLocalFirst As Boolean = False _
) As Dictionary(Of Dynamics_ConfigFileServerKeys, Object)

C#
public Dictionary<Dynamics_ConfigFileServerKeys,Object> LoadConfigFromFile (
    [OptionalAttribute] bool readLocalFirst
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.RemoveUserLocalDirectoryConfigFile Method
[image]

Will remove the user connection data settings from the users app config directory, useable only when the UseUserLocalDirectoryForConfigStore is set to true. this should be called after the connection has been established, or before the connect attempt in order to be effective.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function RemoveUserLocalDirectoryConfigFile As Boolean

C#
public bool RemoveUserLocalDirectoryConfigFile ()

C++

J#

JScript

Return Value
true on success, false on fail.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.RequireUserLogin Method
[image]

This will check the configuration to determine if a user login is required. and if so, return true.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function RequireUserLogin As Boolean

C#
public bool RequireUserLogin ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.SaveConfigToFile Method
[image]

Save the configuration Keys to the configuration file.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function SaveConfigToFile ( _
    configToSave As Dictionary(Of Dynamics_ConfigFileServerKeys, Object) _
) As Boolean

C#
public bool SaveConfigToFile (
    Dictionary<Dynamics_ConfigFileServerKeys,Object> configToSave
)

C++

J#

JScript

Parameters
configToSave
Config key dictionary
Return Value
true on success

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.SetConfigKeyInformation Method
[image]

Sets the current connection information for the server. this can be used to pass in a preconfigured list of keys

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub SetConfigKeyInformation ( _
    configKeys As Dictionary(Of Dynamics_ConfigFileServerKeys, Object) _
)

C#
public void SetConfigKeyInformation (
    Dictionary<Dynamics_ConfigFileServerKeys,Object> configKeys
)

C++

J#

JScript

Parameters
configKeys
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager Properties
[image]

Public Properties

 | Name | Description
public property | ConnectedOrgFriendlyName | Returns the friendly name of the connected org.
public property | ConnectedOrgPublishedEndpoints | Returns the endpoint collection for the connected org.
public property | ConnectedOrgUniqueName | Returns the unique name for the org that has been connected.
public property | CrmOnlineDiscoveryServerList | Collection of CRM Discovery Servers if a server list has not been submitted to this property, and get is called, a new instance of the CrmOnlineDiscoveryServers is created.
public property | CrmOrgsFoundForUser | List of Organizations that have been requested by the user.
public property | CrmSvc | CRM Connection Object.
public property | HomeRealmServersList | Collection of HomeRealms Loaded by Configuration
public property | HostApplicatioNameOveride | Used in conjunction with the UseUserLocalDirecotryForConfigStore, Allows you to set a name for the config application to use. This is used when the host application cannot provide a proper AppDomain.Current.FriendlyName
public property | LastError | last error from the connection manager
public property | LastException | Last Exception from the connection manager.
public property | ParentControl | This the parent control that invoked me.
public property | ProfileName | Profile name to use for this login process.
public property | UseUserLocalDirectoryForConfigStore | Tells the system to store the user config in the users local app directory instead of the Exe directory.

See Also

Reference

CrmConnectionManager Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ConnectedOrgFriendlyName Property
[image]

Returns the friendly name of the connected org.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ConnectedOrgFriendlyName As String

C#
public string ConnectedOrgFriendlyName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ConnectedOrgPublishedEndpoints Property
[image]

Returns the endpoint collection for the connected org.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ConnectedOrgPublishedEndpoints As EndpointCollection

C#
public EndpointCollection ConnectedOrgPublishedEndpoints { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ConnectedOrgUniqueName Property
[image]

Returns the unique name for the org that has been connected.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ConnectedOrgUniqueName As String

C#
public string ConnectedOrgUniqueName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.CrmOnlineDiscoveryServerList Property
[image]

Collection of CRM Discovery Servers if a server list has not been submitted to this property, and get is called, a new instance of the CrmOnlineDiscoveryServers is created.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CrmOnlineDiscoveryServerList As CrmOnlineDiscoveryServers

C#
public CrmOnlineDiscoveryServers CrmOnlineDiscoveryServerList { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.CrmOrgsFoundForUser Property
[image]

List of Organizations that have been requested by the user.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CrmOrgsFoundForUser As CrmOrgList

C#
public CrmOrgList CrmOrgsFoundForUser { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.CrmSvc Property
[image]

CRM Connection Object.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CrmSvc As CrmServiceClient

C#
public CrmServiceClient CrmSvc { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.HomeRealmServersList Property
[image]

Collection of HomeRealms Loaded by Configuration

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HomeRealmServersList As ClaimsHomeRealmOptions

C#
public ClaimsHomeRealmOptions HomeRealmServersList { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.HostApplicatioNameOveride Property
[image]

Used in conjunction with the UseUserLocalDirecotryForConfigStore, Allows you to set a name for the config application to use. This is used when the host application cannot provide a proper AppDomain.Current.FriendlyName

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property HostApplicatioNameOveride As String

C#
public string HostApplicatioNameOveride { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.LastError Property
[image]

last error from the connection manager

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LastError As String

C#
public string LastError { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.LastException Property
[image]

Last Exception from the connection manager.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LastException As Exception

C#
public Exception LastException { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ParentControl Property
[image]

This the parent control that invoked me.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ParentControl As UserControl

C#
public UserControl ParentControl { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ProfileName Property
[image]

Profile name to use for this login process.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ProfileName As String

C#
public string ProfileName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.UseUserLocalDirectoryForConfigStore Property
[image]

Tells the system to store the user config in the users local app directory instead of the Exe directory.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UseUserLocalDirectoryForConfigStore As Boolean

C#
public bool UseUserLocalDirectoryForConfigStore { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager Events
[image]

Public Events

 | Name | Description
public event | ConnectionCheckComplete | Raised when the connection process completes
public event | ServerConnectionStatusUpdate | Raised when a status is updated

See Also

Reference

CrmConnectionManager Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ConnectionCheckComplete Event
[image]

Raised when the connection process completes

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ConnectionCheckComplete As EventHandler(Of ServerConnectStatusEventArgs)

C#
public event EventHandler<ServerConnectStatusEventArgs> ConnectionCheckComplete

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmConnectionManager.ServerConnectionStatusUpdate Event
[image]

Raised when a status is updated

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ServerConnectionStatusUpdate As EventHandler(Of ServerConnectStatusEventArgs)

C#
public event EventHandler<ServerConnectStatusEventArgs> ServerConnectionStatusUpdate

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmConnectionManager Class
CrmConnectionManager Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl Class
See Also Members
[image]

This control provides the UI components and interaction logic with the CrmConnectionManager Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class CrmServerLoginConfigControl
    Inherits UserControl
    Implements IComponentConnector

C#
public class CrmServerLoginConfigControl : UserControl, IComponentConnector

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Control

                System.Windows.Controls.ContentControl

                System.Windows.Controls.UserControl
                  Microsoft.Xrm.Tooling.CrmConnectControl.CrmServerLoginConfigControl
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

This control provides the UI components and interaction logic with the CrmConnectionManager Class.

The following tables list the members exposed by the CrmServerLoginConfigControl type.

Public Constructors

Name | Description
CrmServerLoginConfigControl | Default constructor
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | GetConnectedOrgName | Returns the Friendly name of the connected org.
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetControlMode | Sets the Mode of the control..
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetGlobalStoreAccess | Sets the Server storage pointer.
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | StartConnectCheck | Starts the connect check process
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContentChanged | (inherited from ContentControl)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
Top

Public Events

 | Name | Description
public event | ConnectErrorEvent | Raised when there is an error
public event | ConnectionCheckBegining | Raised when the connection process has begun
public event | ConnectionStatusEvent | Raised when a Status event is raised
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
public event | UserCancelClicked | Raised when the user clicked cancel.
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

CrmServerLoginConfigControl Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl Constructor
[image]

Default constructor

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmServerLoginConfigControl ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetControlMode | Sets the Mode of the control..
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetGlobalStoreAccess | Sets the Server storage pointer.
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | StartConnectCheck | Starts the connect check process
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContentChanged | (inherited from ContentControl)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

CrmServerLoginConfigControl Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.InitializeComponent Method
[image]

InitializeComponent

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Public Sub InitializeComponent

C#
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
public void InitializeComponent ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.SetControlMode Method
[image]

Sets the Mode of the control..

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub SetControlMode ( _
    mode As ServerLoginConfigCtrlMode _
)

C#
public void SetControlMode (
    ServerLoginConfigCtrlMode mode
)

C++

J#

JScript

Parameters
mode
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.SetGlobalStoreAccess Method
[image]

Sets the Server storage pointer.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub SetGlobalStoreAccess ( _
    globalStore As CrmConnectionManager _
)

C#
public void SetGlobalStoreAccess (
    CrmConnectionManager globalStore
)

C++

J#

JScript

Parameters
globalStore
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.StartConnectCheck Method
[image]

Starts the connect check process

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub StartConnectCheck

C#
public void StartConnectCheck ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.Connect Method
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<DebuggerNonUserCodeAttribute> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect

C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DebuggerNonUserCodeAttribute]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | GetConnectedOrgName | Returns the Friendly name of the connected org.
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

CrmServerLoginConfigControl Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.GetConnectedOrgName Property
[image]

Returns the Friendly name of the connected org.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property GetConnectedOrgName As String

C#
public string GetConnectedOrgName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl Events
[image]

Public Events

 | Name | Description
public event | ConnectErrorEvent | Raised when there is an error
public event | ConnectionCheckBegining | Raised when the connection process has begun
public event | ConnectionStatusEvent | Raised when a Status event is raised
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
public event | UserCancelClicked | Raised when the user clicked cancel.

See Also

Reference

CrmServerLoginConfigControl Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.ConnectErrorEvent Event
[image]

Raised when there is an error

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ConnectErrorEvent As EventHandler(Of ConnectErrorEventArgs)

C#
public event EventHandler<ConnectErrorEventArgs> ConnectErrorEvent

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.ConnectionCheckBegining Event
[image]

Raised when the connection process has begun

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ConnectionCheckBegining As EventHandler

C#
public event EventHandler ConnectionCheckBegining

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.ConnectionStatusEvent Event
[image]

Raised when a Status event is raised

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ConnectionStatusEvent As EventHandler(Of ConnectStatusEventArgs)

C#
public event EventHandler<ConnectStatusEventArgs> ConnectionStatusEvent

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginConfigControl.UserCancelClicked Event
[image]

Raised when the user clicked cancel.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event UserCancelClicked As EventHandler

C#
public event EventHandler UserCancelClicked

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginConfigControl Class
CrmServerLoginConfigControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl Class
See Also Members
[image]

This control provides the UI components and interaction logic with the CrmConnectionManager Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class CrmServerLoginControl
    Inherits UserControl
    Implements IComponentConnector

C#
public class CrmServerLoginControl : UserControl, IComponentConnector

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Control

                System.Windows.Controls.ContentControl

                System.Windows.Controls.UserControl
                  Microsoft.Xrm.Tooling.CrmConnectControl.CrmServerLoginControl
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

This control provides the UI components and interaction logic with the CrmConnectionManager Class.

The following tables list the members exposed by the CrmServerLoginControl type.

Public Constructors

Name | Description
CrmServerLoginControl | Default constructor
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | GetConnectedOrgName | Returns the Friendly name of the connected org.
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HideCancel | Show Cancel Button or Not
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsConnected | Complete Connect Check
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowTitle | Show Title or Not
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | GoBackToLogin | API Called when Client wants to go back to login and cancel connect.
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | IsOrgSelect | Returns true if orgeselect grid visible
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetControlMode | Sets the Mode of the control..
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetGlobalStoreAccess | Sets the Server storage pointer.
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShowMessageGrid | Called when the client wants to show the message grid.
public method | StartCancelSave | API Called when Client wants to cancel connect.
public method | StartConnectCheck | Starts the connect check process
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContentChanged | (inherited from ContentControl)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
Top

Public Events

 | Name | Description
public event | ConnectErrorEvent | Raised when there is an error
public event | ConnectionCheckBegining | Raised when the connection process has begun
public event | ConnectionStatusEvent | Raised when a Status event is raised
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
public event | UserCancelClicked | Raised when the user clicked cancel.
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

CrmServerLoginControl Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl Constructor
[image]

Default constructor

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmServerLoginControl ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | GoBackToLogin | API Called when Client wants to go back to login and cancel connect.
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | IsOrgSelect | Returns true if orgeselect grid visible
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetControlMode | Sets the Mode of the control..
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetGlobalStoreAccess | Sets the Server storage pointer.
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShowMessageGrid | Called when the client wants to show the message grid.
public method | StartCancelSave | API Called when Client wants to cancel connect.
public method | StartConnectCheck | Starts the connect check process
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContentChanged | (inherited from ContentControl)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

CrmServerLoginControl Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.GoBackToLogin Method
[image]

API Called when Client wants to go back to login and cancel connect.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub GoBackToLogin

C#
public void GoBackToLogin ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.InitializeComponent Method
[image]

InitializeComponent

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Public Sub InitializeComponent

C#
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
public void InitializeComponent ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.IsOrgSelect Method
[image]

Returns true if orgeselect grid visible

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function IsOrgSelect As Visibility

C#
public Visibility IsOrgSelect ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.SetControlMode Method
[image]

Sets the Mode of the control..

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub SetControlMode ( _
    mode As ServerLoginConfigCtrlMode _
)

C#
public void SetControlMode (
    ServerLoginConfigCtrlMode mode
)

C++

J#

JScript

Parameters
mode
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.SetGlobalStoreAccess Method
[image]

Sets the Server storage pointer.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub SetGlobalStoreAccess ( _
    globalStore As CrmConnectionManager _
)

C#
public void SetGlobalStoreAccess (
    CrmConnectionManager globalStore
)

C++

J#

JScript

Parameters
globalStore
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.ShowMessageGrid Method
[image]

Called when the client wants to show the message grid.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub ShowMessageGrid

C#
public void ShowMessageGrid ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.StartCancelSave Method
[image]

API Called when Client wants to cancel connect.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub StartCancelSave

C#
public void StartCancelSave ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.StartConnectCheck Method
[image]

Starts the connect check process

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub StartConnectCheck

C#
public void StartConnectCheck ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.Connect Method
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerNonUserCodeAttribute> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect

C#
[DebuggerNonUserCodeAttribute]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | GetConnectedOrgName | Returns the Friendly name of the connected org.
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HideCancel | Show Cancel Button or Not
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsConnected | Complete Connect Check
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowTitle | Show Title or Not
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

CrmServerLoginControl Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.GetConnectedOrgName Property
[image]

Returns the Friendly name of the connected org.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property GetConnectedOrgName As String

C#
public string GetConnectedOrgName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.HideCancel Property
[image]

Show Cancel Button or Not

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Hide Cancel Button")> _
<CategoryAttribute("Common Properties")> _
Public Property HideCancel As Boolean

C#
[DescriptionAttribute("Hide Cancel Button")]
[CategoryAttribute("Common Properties")]
public bool HideCancel { get; set; }

C++

J#

JScript

  Remarks
The flag is specified in XAML as a bool.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.IsConnected Property
[image]

Complete Connect Check

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property IsConnected As Boolean

C#
public bool IsConnected { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.ShowTitle Property
[image]

Show Title or Not

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DescriptionAttribute("Show Title")> _
<CategoryAttribute("Common Properties")> _
Public Property ShowTitle As Boolean

C#
[DescriptionAttribute("Show Title")]
[CategoryAttribute("Common Properties")]
public bool ShowTitle { get; set; }

C++

J#

JScript

  Remarks
The flag is specified in XAML as a bool.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl Events
[image]

Public Events

 | Name | Description
public event | ConnectErrorEvent | Raised when there is an error
public event | ConnectionCheckBegining | Raised when the connection process has begun
public event | ConnectionStatusEvent | Raised when a Status event is raised
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
public event | UserCancelClicked | Raised when the user clicked cancel.

See Also

Reference

CrmServerLoginControl Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.ConnectErrorEvent Event
[image]

Raised when there is an error

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ConnectErrorEvent As EventHandler(Of ConnectErrorEventArgs)

C#
public event EventHandler<ConnectErrorEventArgs> ConnectErrorEvent

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.ConnectionCheckBegining Event
[image]

Raised when the connection process has begun

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ConnectionCheckBegining As EventHandler

C#
public event EventHandler ConnectionCheckBegining

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.ConnectionStatusEvent Event
[image]

Raised when a Status event is raised

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event ConnectionStatusEvent As EventHandler(Of ConnectStatusEventArgs)

C#
public event EventHandler<ConnectStatusEventArgs> ConnectionStatusEvent

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


CrmServerLoginControl.UserCancelClicked Event
[image]

Raised when the user clicked cancel.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event UserCancelClicked As EventHandler

C#
public event EventHandler UserCancelClicked

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmServerLoginControl Class
CrmServerLoginControl Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow Class
See Also Members
[image]

Interaction logic for ErrorWindow.xaml

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ErrorWindow
    Inherits Window
    Implements IComponentConnector

C#
public class ErrorWindow : Window, IComponentConnector

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Control

                System.Windows.Controls.ContentControl

                System.Windows.Window
                  Microsoft.Xrm.Tooling.CrmConnectControl.ErrorWindow
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorWindow Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

Interaction logic for ErrorWindow.xaml

The following tables list the members exposed by the ErrorWindow type.

Public Constructors

Name | Description
ErrorWindow | Overloaded.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AllowsTransparency | (inherited from Window)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | DialogResult | (inherited from Window)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from Window)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsActive | (inherited from Window)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Left | (inherited from Window)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | OwnedWindows | (inherited from Window)
public property | Owner | (inherited from Window)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | ResizeMode | (inherited from Window)
public property | Resources | (inherited from FrameworkElement)
public property | RestoreBounds | (inherited from Window)
public property | ShowActivated | (inherited from Window)
public property | ShowInTaskbar | (inherited from Window)
public property | SizeToContent | (inherited from Window)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | TaskbarItemInfo | (inherited from Window)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Window)
public property | ToolTip | (inherited from FrameworkElement)
public property | Top | (inherited from Window)
public property | Topmost | (inherited from Window)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowStartupLocation | (inherited from Window)
public property | WindowState | (inherited from Window)
public property | WindowStyle | (inherited from Window)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Activate | (inherited from Window)
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | Close | (inherited from Window)
public method | CoerceValue | (inherited from DependencyObject)
public method | DragMove | (inherited from Window)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | Hide | (inherited from Window)
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | Show | (inherited from Window)
public method | ShowDialog | (inherited from Window)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from Control)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from Control)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnActivated | (inherited from Window)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnClosed | (inherited from Window)
protected method | OnClosing | (inherited from Window)
protected method | OnContentChanged | Overridden. (inherited from ContentControl)
protected method | OnContentRendered | (inherited from Window)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDeactivated | (inherited from Window)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLocationChanged | (inherited from Window)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | Overridden. (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnSourceInitialized | (inherited from Window)
protected method | OnStateChanged | (inherited from Window)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
Top

Public Events

 | Name | Description
public event | Activated | (inherited from Window)
public event | Closed | (inherited from Window)
public event | Closing | (inherited from Window)
public event | ContentRendered | (inherited from Window)
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | Deactivated | (inherited from Window)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LocationChanged | (inherited from Window)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceInitialized | (inherited from Window)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StateChanged | (inherited from Window)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

ErrorWindow Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow Constructor
[image]

Overload List

Name | Description
ErrorWindow (Exception) | Error window constructor
ErrorWindow (String, String) | Error window constructor
ErrorWindow (Uri) | Error window constructor

See Also

Reference

ErrorWindow Class
ErrorWindow Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow Constructor (Exception)
[image]

Error window constructor

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    e As Exception _
)

C#
public ErrorWindow (
    Exception e
)

C++

J#

JScript

Parameters
e
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorWindow Class
ErrorWindow Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow Constructor (String, String)
[image]

Error window constructor

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    message As String, _
    details As String _
)

C#
public ErrorWindow (
    string message,
    string details
)

C++

J#

JScript

Parameters
message
details
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorWindow Class
ErrorWindow Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow Constructor (Uri)
[image]

Error window constructor

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    uri As Uri _
)

C#
public ErrorWindow (
    Uri uri
)

C++

J#

JScript

Parameters
uri
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorWindow Class
ErrorWindow Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Activate | (inherited from Window)
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | Close | (inherited from Window)
public method | CoerceValue | (inherited from DependencyObject)
public method | DragMove | (inherited from Window)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | Hide | (inherited from Window)
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | Show | (inherited from Window)
public method | ShowDialog | (inherited from Window)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from Control)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from Control)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnActivated | (inherited from Window)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnClosed | (inherited from Window)
protected method | OnClosing | (inherited from Window)
protected method | OnContentChanged | Overridden. (inherited from ContentControl)
protected method | OnContentRendered | (inherited from Window)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDeactivated | (inherited from Window)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLocationChanged | (inherited from Window)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | Overridden. (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnSourceInitialized | (inherited from Window)
protected method | OnStateChanged | (inherited from Window)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

ErrorWindow Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow.InitializeComponent Method
[image]

InitializeComponent

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent

C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
public void InitializeComponent ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorWindow Class
ErrorWindow Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow.Connect Method
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorWindow Class
ErrorWindow Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AllowsTransparency | (inherited from Window)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | DialogResult | (inherited from Window)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from Window)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsActive | (inherited from Window)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Left | (inherited from Window)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | OwnedWindows | (inherited from Window)
public property | Owner | (inherited from Window)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | ResizeMode | (inherited from Window)
public property | Resources | (inherited from FrameworkElement)
public property | RestoreBounds | (inherited from Window)
public property | ShowActivated | (inherited from Window)
public property | ShowInTaskbar | (inherited from Window)
public property | SizeToContent | (inherited from Window)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | TaskbarItemInfo | (inherited from Window)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Window)
public property | ToolTip | (inherited from FrameworkElement)
public property | Top | (inherited from Window)
public property | Topmost | (inherited from Window)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowStartupLocation | (inherited from Window)
public property | WindowState | (inherited from Window)
public property | WindowStyle | (inherited from Window)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

ErrorWindow Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ErrorWindow Events
[image]

Public Events

 | Name | Description
public event | Activated | (inherited from Window)
public event | Closed | (inherited from Window)
public event | Closing | (inherited from Window)
public event | ContentRendered | (inherited from Window)
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | Deactivated | (inherited from Window)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LocationChanged | (inherited from Window)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceInitialized | (inherited from Window)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StateChanged | (inherited from Window)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

ErrorWindow Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots Class
See Also Members
[image]

Interaction logic for PendulumDots.xaml

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class PendulumDots
    Inherits UserControl
    Implements IDisposable, IComponentConnector

C#
public class PendulumDots : UserControl, IDisposable, IComponentConnector

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Control

                System.Windows.Controls.ContentControl

                System.Windows.Controls.UserControl
                  Microsoft.Xrm.Tooling.CrmConnectControl.PendulumDots
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots Members
See Also Constructors Events Fields Methods Properties Explicit Interface Implementations
[image]

Interaction logic for PendulumDots.xaml

The following tables list the members exposed by the PendulumDots type.

Public Constructors

Name | Description
PendulumDots | Ctor
Top

Public Fields

Name | Description
DelayProperty | Delay Dependency Property
DotHeightProperty | DotHeight Dependency Property
DotRadiusXProperty | DotRadiusX Dependency Property
DotRadiusYProperty | DotRadiusY Dependency Property
DotWidthProperty | DotWidth Dependency Property
DurationAProperty | DurationA Dependency Property
DurationBProperty | DurationB Dependency Property
DurationCProperty | DurationC Dependency Property
KeyFrameAProperty | KeyFrameA Dependency Property
KeyFrameBProperty | KeyFrameB Dependency Property
ReverseDurationProperty | ReverseDuration Dependency Property
TotalDurationProperty | TotalDuration Dependency Property
UnlikeWPProperty | UnlikeWP Dependency Property
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | Delay | Gets or sets the Delay property. This dependency property indicates the delay between adjacent animation timelines.
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | DotHeight | Gets or sets the DotHeight property. This dependency property indicates the height of each of the dots.
public property | DotRadiusX | Gets or sets the DotRadiusX property. This dependency property indicates the corner radius width of each of the dot.
public property | DotRadiusY | Gets or sets the DotRadiusY property. This dependency property indicates the corner height of each of the dots.
public property | DotWidth | Gets or sets the DotWidth property. This dependency property indicates the width of each of the dots.
public property | DurationA | Gets or sets the DurationA property. This dependency property indicates the duration of the animation from the start point till KeyFrameA.
public property | DurationB | Gets or sets the DurationB property. This dependency property indicates the duration of the animation from the KeyFrameA till KeyFrameB.
public property | DurationC | Gets or sets the DurationC property. This dependency property indicates the duration of the animation from KeyFrameB till the end point.
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | KeyFrameA | Gets or sets the KeyFrameA property. This dependency property indicates the first KeyFrame position after the initial keyframe.
public property | KeyFrameB | Gets or sets the KeyFrameB property. This dependency property indicates the second KeyFrame position after the initial keyframe.
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ReverseDuration | Gets or sets the ReverseDuration property. This dependency property indicates the duration of the total animation in reverse.
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TotalDuration | Gets or sets the TotalDuration property. This dependency property indicates the duration of the complete animation.
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UnlikeWP | Gets or sets the UnlikeWP property. This dependency property indicates whether the animation should UnlikeWP.
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | Dispose | Overloaded.
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Dispose | Overloaded.
protected method | Finalize | Overridden. Releases unmanaged resources before an instance of the PendulumDots class is reclaimed by garbage collection.
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContentChanged | (inherited from ContentControl)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDelayChanged | Provides derived classes an opportunity to handle changes to the Delay property.
protected method | OnDotHeightChanged | Provides derived classes an opportunity to handle changes to the DotHeight property.
protected method | OnDotRadiusXChanged | Provides derived classes an opportunity to handle changes to the DotRadiusX property.
protected method | OnDotRadiusYChanged | Provides derived classes an opportunity to handle changes to the DotRadiusY property.
protected method | OnDotWidthChanged | Provides derived classes an opportunity to handle changes to the DotWidth property.
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnDurationAChanged | Provides derived classes an opportunity to handle changes to the DurationA property.
protected method | OnDurationBChanged | Provides derived classes an opportunity to handle changes to the DurationB property.
protected method | OnDurationCChanged | Provides derived classes an opportunity to handle changes to the DurationC property.
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyFrameAChanged | Provides derived classes an opportunity to handle changes to the KeyFrameA property.
protected method | OnKeyFrameBChanged | Provides derived classes an opportunity to handle changes to the KeyFrameB property.
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReverseDurationChanged | Provides derived classes an opportunity to handle changes to the ReverseDuration property.
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTotalDurationChanged | Provides derived classes an opportunity to handle changes to the TotalDuration property.
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | OnUnlikeWPChanged | Provides derived classes an opportunity to handle changes to the UnlikeWP property.
protected method | RemoveVisualChild | (inherited from Visual)
Top

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

PendulumDots Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots Fields
[image]

Public Fields

Name | Description
DelayProperty | Delay Dependency Property
DotHeightProperty | DotHeight Dependency Property
DotRadiusXProperty | DotRadiusX Dependency Property
DotRadiusYProperty | DotRadiusY Dependency Property
DotWidthProperty | DotWidth Dependency Property
DurationAProperty | DurationA Dependency Property
DurationBProperty | DurationB Dependency Property
DurationCProperty | DurationC Dependency Property
KeyFrameAProperty | KeyFrameA Dependency Property
KeyFrameBProperty | KeyFrameB Dependency Property
ReverseDurationProperty | ReverseDuration Dependency Property
TotalDurationProperty | TotalDuration Dependency Property
UnlikeWPProperty | UnlikeWP Dependency Property

See Also

Reference

PendulumDots Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DelayProperty Field
[image]

Delay Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly DelayProperty As DependencyProperty

C#
public static readonly DependencyProperty DelayProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DotHeightProperty Field
[image]

DotHeight Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly DotHeightProperty As DependencyProperty

C#
public static readonly DependencyProperty DotHeightProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DotRadiusXProperty Field
[image]

DotRadiusX Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly DotRadiusXProperty As DependencyProperty

C#
public static readonly DependencyProperty DotRadiusXProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DotRadiusYProperty Field
[image]

DotRadiusY Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly DotRadiusYProperty As DependencyProperty

C#
public static readonly DependencyProperty DotRadiusYProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DotWidthProperty Field
[image]

DotWidth Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly DotWidthProperty As DependencyProperty

C#
public static readonly DependencyProperty DotWidthProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DurationAProperty Field
[image]

DurationA Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly DurationAProperty As DependencyProperty

C#
public static readonly DependencyProperty DurationAProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DurationBProperty Field
[image]

DurationB Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly DurationBProperty As DependencyProperty

C#
public static readonly DependencyProperty DurationBProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DurationCProperty Field
[image]

DurationC Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly DurationCProperty As DependencyProperty

C#
public static readonly DependencyProperty DurationCProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.KeyFrameAProperty Field
[image]

KeyFrameA Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly KeyFrameAProperty As DependencyProperty

C#
public static readonly DependencyProperty KeyFrameAProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.KeyFrameBProperty Field
[image]

KeyFrameB Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly KeyFrameBProperty As DependencyProperty

C#
public static readonly DependencyProperty KeyFrameBProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.ReverseDurationProperty Field
[image]

ReverseDuration Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly ReverseDurationProperty As DependencyProperty

C#
public static readonly DependencyProperty ReverseDurationProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.TotalDurationProperty Field
[image]

TotalDuration Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly TotalDurationProperty As DependencyProperty

C#
public static readonly DependencyProperty TotalDurationProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.UnlikeWPProperty Field
[image]

UnlikeWP Dependency Property

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly UnlikeWPProperty As DependencyProperty

C#
public static readonly DependencyProperty UnlikeWPProperty

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots Constructor
[image]

Ctor

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public PendulumDots ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | Dispose | Overloaded.
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Dispose | Overloaded.
protected method | Finalize | Overridden. Releases unmanaged resources before an instance of the PendulumDots class is reclaimed by garbage collection.
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContentChanged | (inherited from ContentControl)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDelayChanged | Provides derived classes an opportunity to handle changes to the Delay property.
protected method | OnDotHeightChanged | Provides derived classes an opportunity to handle changes to the DotHeight property.
protected method | OnDotRadiusXChanged | Provides derived classes an opportunity to handle changes to the DotRadiusX property.
protected method | OnDotRadiusYChanged | Provides derived classes an opportunity to handle changes to the DotRadiusY property.
protected method | OnDotWidthChanged | Provides derived classes an opportunity to handle changes to the DotWidth property.
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnDurationAChanged | Provides derived classes an opportunity to handle changes to the DurationA property.
protected method | OnDurationBChanged | Provides derived classes an opportunity to handle changes to the DurationB property.
protected method | OnDurationCChanged | Provides derived classes an opportunity to handle changes to the DurationC property.
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyFrameAChanged | Provides derived classes an opportunity to handle changes to the KeyFrameA property.
protected method | OnKeyFrameBChanged | Provides derived classes an opportunity to handle changes to the KeyFrameB property.
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReverseDurationChanged | Provides derived classes an opportunity to handle changes to the ReverseDuration property.
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTotalDurationChanged | Provides derived classes an opportunity to handle changes to the TotalDuration property.
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | OnUnlikeWPChanged | Provides derived classes an opportunity to handle changes to the UnlikeWP property.
protected method | RemoveVisualChild | (inherited from Visual)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

PendulumDots Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.Dispose Method
[image]

Overload List

Name | Description
PendulumDots.Dispose () | Releases all resources used by an instance of the PendulumDots class.
PendulumDots.Dispose (Boolean) | Releases the unmanaged resources used by an instance of the PendulumDots class and optionally releases the managed resources.

See Also

Reference

PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.Dispose Method ()
[image]

Releases all resources used by an instance of the PendulumDots class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Dispose

C#
public void Dispose ()

C++

J#

JScript

  Remarks
This method calls the virtual Dispose(bool) method, passing in 'true', and then suppresses finalization of the instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.Dispose Method (Boolean)
[image]

Releases the unmanaged resources used by an instance of the PendulumDots class and optionally releases the managed resources.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

C#
protected virtual void Dispose (
    bool disposing
)

C++

J#

JScript

Parameters
disposing
'true' to release both managed and unmanaged resources; 'false' to release only unmanaged resources.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.Finalize Method
[image]

Releases unmanaged resources before an instance of the PendulumDots class is reclaimed by garbage collection.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Sub Finalize

C#
~PendulumDots()

C++

J#

JScript

  Remarks
NOTE: Leave out the finalizer altogether if this class doesn't own unmanaged resources itself, but leave the other methods exactly as they are. This method releases unmanaged resources by calling the virtual Dispose(bool), passing in 'false'.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.InitializeComponent Method
[image]

InitializeComponent

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Public Sub InitializeComponent

C#
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
public void InitializeComponent ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnDelayChanged Method
[image]

Provides derived classes an opportunity to handle changes to the Delay property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnDelayChanged ( _
    oldDelay As Duration, _
    newDelay As Duration _
)

C#
protected virtual void OnDelayChanged (
    Duration oldDelay,
    Duration newDelay
)

C++

J#

JScript

Parameters
oldDelay
Old Value
newDelay
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnDotHeightChanged Method
[image]

Provides derived classes an opportunity to handle changes to the DotHeight property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnDotHeightChanged ( _
    oldDotHeight As Double, _
    newDotHeight As Double _
)

C#
protected virtual void OnDotHeightChanged (
    double oldDotHeight,
    double newDotHeight
)

C++

J#

JScript

Parameters
oldDotHeight
Old Value
newDotHeight
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnDotRadiusXChanged Method
[image]

Provides derived classes an opportunity to handle changes to the DotRadiusX property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnDotRadiusXChanged ( _
    oldDotRadiusX As Double, _
    newDotRadiusX As Double _
)

C#
protected virtual void OnDotRadiusXChanged (
    double oldDotRadiusX,
    double newDotRadiusX
)

C++

J#

JScript

Parameters
oldDotRadiusX
Old Value
newDotRadiusX
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnDotRadiusYChanged Method
[image]

Provides derived classes an opportunity to handle changes to the DotRadiusY property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnDotRadiusYChanged ( _
    oldDotRadiusY As Double, _
    newDotRadiusY As Double _
)

C#
protected virtual void OnDotRadiusYChanged (
    double oldDotRadiusY,
    double newDotRadiusY
)

C++

J#

JScript

Parameters
oldDotRadiusY
Old Value
newDotRadiusY
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnDotWidthChanged Method
[image]

Provides derived classes an opportunity to handle changes to the DotWidth property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnDotWidthChanged ( _
    oldDotWidth As Double, _
    newDotWidth As Double _
)

C#
protected virtual void OnDotWidthChanged (
    double oldDotWidth,
    double newDotWidth
)

C++

J#

JScript

Parameters
oldDotWidth
Old Value
newDotWidth
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnDurationAChanged Method
[image]

Provides derived classes an opportunity to handle changes to the DurationA property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnDurationAChanged ( _
    oldDurationA As Duration, _
    newDurationA As Duration _
)

C#
protected virtual void OnDurationAChanged (
    Duration oldDurationA,
    Duration newDurationA
)

C++

J#

JScript

Parameters
oldDurationA
Old Value
newDurationA
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnDurationBChanged Method
[image]

Provides derived classes an opportunity to handle changes to the DurationB property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnDurationBChanged ( _
    oldDurationB As Duration, _
    newDurationB As Duration _
)

C#
protected virtual void OnDurationBChanged (
    Duration oldDurationB,
    Duration newDurationB
)

C++

J#

JScript

Parameters
oldDurationB
Old Value
newDurationB
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnDurationCChanged Method
[image]

Provides derived classes an opportunity to handle changes to the DurationC property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnDurationCChanged ( _
    oldDurationC As Duration, _
    newDurationC As Duration _
)

C#
protected virtual void OnDurationCChanged (
    Duration oldDurationC,
    Duration newDurationC
)

C++

J#

JScript

Parameters
oldDurationC
Old Value
newDurationC
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnKeyFrameAChanged Method
[image]

Provides derived classes an opportunity to handle changes to the KeyFrameA property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnKeyFrameAChanged ( _
    oldKeyFrameA As Double, _
    newKeyFrameA As Double _
)

C#
protected virtual void OnKeyFrameAChanged (
    double oldKeyFrameA,
    double newKeyFrameA
)

C++

J#

JScript

Parameters
oldKeyFrameA
Old Value
newKeyFrameA
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnKeyFrameBChanged Method
[image]

Provides derived classes an opportunity to handle changes to the KeyFrameB property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnKeyFrameBChanged ( _
    oldKeyFrameB As Double, _
    newKeyFrameB As Double _
)

C#
protected virtual void OnKeyFrameBChanged (
    double oldKeyFrameB,
    double newKeyFrameB
)

C++

J#

JScript

Parameters
oldKeyFrameB
Old Value
newKeyFrameB
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnReverseDurationChanged Method
[image]

Provides derived classes an opportunity to handle changes to the ReverseDuration property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnReverseDurationChanged ( _
    oldReverseDuration As Duration, _
    newReverseDuration As Duration _
)

C#
protected virtual void OnReverseDurationChanged (
    Duration oldReverseDuration,
    Duration newReverseDuration
)

C++

J#

JScript

Parameters
oldReverseDuration
Old Value
newReverseDuration
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnTotalDurationChanged Method
[image]

Provides derived classes an opportunity to handle changes to the TotalDuration property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnTotalDurationChanged ( _
    oldTotalDuration As Duration, _
    newTotalDuration As Duration _
)

C#
protected virtual void OnTotalDurationChanged (
    Duration oldTotalDuration,
    Duration newTotalDuration
)

C++

J#

JScript

Parameters
oldTotalDuration
Old Value
newTotalDuration
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.OnUnlikeWPChanged Method
[image]

Provides derived classes an opportunity to handle changes to the UnlikeWP property.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overridable Sub OnUnlikeWPChanged ( _
    oldUnlikeWP As Boolean, _
    newUnlikeWP As Boolean _
)

C#
protected virtual void OnUnlikeWPChanged (
    bool oldUnlikeWP,
    bool newUnlikeWP
)

C++

J#

JScript

Parameters
oldUnlikeWP
Old Value
newUnlikeWP
New Value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.Connect Method
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | Delay | Gets or sets the Delay property. This dependency property indicates the delay between adjacent animation timelines.
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | DotHeight | Gets or sets the DotHeight property. This dependency property indicates the height of each of the dots.
public property | DotRadiusX | Gets or sets the DotRadiusX property. This dependency property indicates the corner radius width of each of the dot.
public property | DotRadiusY | Gets or sets the DotRadiusY property. This dependency property indicates the corner height of each of the dots.
public property | DotWidth | Gets or sets the DotWidth property. This dependency property indicates the width of each of the dots.
public property | DurationA | Gets or sets the DurationA property. This dependency property indicates the duration of the animation from the start point till KeyFrameA.
public property | DurationB | Gets or sets the DurationB property. This dependency property indicates the duration of the animation from the KeyFrameA till KeyFrameB.
public property | DurationC | Gets or sets the DurationC property. This dependency property indicates the duration of the animation from KeyFrameB till the end point.
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | KeyFrameA | Gets or sets the KeyFrameA property. This dependency property indicates the first KeyFrame position after the initial keyframe.
public property | KeyFrameB | Gets or sets the KeyFrameB property. This dependency property indicates the second KeyFrame position after the initial keyframe.
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ReverseDuration | Gets or sets the ReverseDuration property. This dependency property indicates the duration of the total animation in reverse.
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TotalDuration | Gets or sets the TotalDuration property. This dependency property indicates the duration of the complete animation.
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UnlikeWP | Gets or sets the UnlikeWP property. This dependency property indicates whether the animation should UnlikeWP.
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

PendulumDots Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.Delay Property
[image]

Gets or sets the Delay property. This dependency property indicates the delay between adjacent animation timelines.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Delay As Duration

C#
public Duration Delay { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DotHeight Property
[image]

Gets or sets the DotHeight property. This dependency property indicates the height of each of the dots.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DotHeight As Double

C#
public double DotHeight { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DotRadiusX Property
[image]

Gets or sets the DotRadiusX property. This dependency property indicates the corner radius width of each of the dot.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DotRadiusX As Double

C#
public double DotRadiusX { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DotRadiusY Property
[image]

Gets or sets the DotRadiusY property. This dependency property indicates the corner height of each of the dots.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DotRadiusY As Double

C#
public double DotRadiusY { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DotWidth Property
[image]

Gets or sets the DotWidth property. This dependency property indicates the width of each of the dots.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DotWidth As Double

C#
public double DotWidth { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DurationA Property
[image]

Gets or sets the DurationA property. This dependency property indicates the duration of the animation from the start point till KeyFrameA.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DurationA As Duration

C#
public Duration DurationA { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DurationB Property
[image]

Gets or sets the DurationB property. This dependency property indicates the duration of the animation from the KeyFrameA till KeyFrameB.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DurationB As Duration

C#
public Duration DurationB { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.DurationC Property
[image]

Gets or sets the DurationC property. This dependency property indicates the duration of the animation from KeyFrameB till the end point.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DurationC As Duration

C#
public Duration DurationC { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.KeyFrameA Property
[image]

Gets or sets the KeyFrameA property. This dependency property indicates the first KeyFrame position after the initial keyframe.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property KeyFrameA As Double

C#
public double KeyFrameA { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.KeyFrameB Property
[image]

Gets or sets the KeyFrameB property. This dependency property indicates the second KeyFrame position after the initial keyframe.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property KeyFrameB As Double

C#
public double KeyFrameB { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.ReverseDuration Property
[image]

Gets or sets the ReverseDuration property. This dependency property indicates the duration of the total animation in reverse.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ReverseDuration As Duration

C#
public Duration ReverseDuration { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.TotalDuration Property
[image]

Gets or sets the TotalDuration property. This dependency property indicates the duration of the complete animation.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property TotalDuration As Duration

C#
public Duration TotalDuration { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots.UnlikeWP Property
[image]

Gets or sets the UnlikeWP property. This dependency property indicates whether the animation should UnlikeWP.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UnlikeWP As Boolean

C#
public bool UnlikeWP { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PendulumDots Class
PendulumDots Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


PendulumDots Events
[image]

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

PendulumDots Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SelectOrgDlg Class
See Also Members
[image]

Provides a UI to allow users to select an Organization to login into, if the user has more than one organization available to login to.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class SelectOrgDlg
    Inherits Window
    Implements IComponentConnector

C#
public class SelectOrgDlg : Window, IComponentConnector

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Control

                System.Windows.Controls.ContentControl

                System.Windows.Window
                  Microsoft.Xrm.Tooling.CrmConnectControl.SelectOrgDlg
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SelectOrgDlg Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SelectOrgDlg Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

Provides a UI to allow users to select an Organization to login into, if the user has more than one organization available to login to.

The following tables list the members exposed by the SelectOrgDlg type.

Public Constructors

Name | Description
SelectOrgDlg | Constructor
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AllowsTransparency | (inherited from Window)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | DialogResult | (inherited from Window)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | GetSelectedCrmOrg | returns the user selected CrmOrganization
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from Window)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsActive | (inherited from Window)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Left | (inherited from Window)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | OwnedWindows | (inherited from Window)
public property | Owner | (inherited from Window)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | ResizeMode | (inherited from Window)
public property | Resources | (inherited from FrameworkElement)
public property | RestoreBounds | (inherited from Window)
public property | ShowActivated | (inherited from Window)
public property | ShowInTaskbar | (inherited from Window)
public property | SizeToContent | (inherited from Window)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | TaskbarItemInfo | (inherited from Window)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Window)
public property | ToolTip | (inherited from FrameworkElement)
public property | Top | (inherited from Window)
public property | Topmost | (inherited from Window)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowStartupLocation | (inherited from Window)
public property | WindowState | (inherited from Window)
public property | WindowStyle | (inherited from Window)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Activate | (inherited from Window)
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | Close | (inherited from Window)
public method | CoerceValue | (inherited from DependencyObject)
public method | DragMove | (inherited from Window)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | Hide | (inherited from Window)
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | Show | (inherited from Window)
public method | ShowDialog | (inherited from Window)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from Control)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from Control)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnActivated | (inherited from Window)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnClosed | (inherited from Window)
protected method | OnClosing | (inherited from Window)
protected method | OnContentChanged | Overridden. (inherited from ContentControl)
protected method | OnContentRendered | (inherited from Window)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDeactivated | (inherited from Window)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLocationChanged | (inherited from Window)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | Overridden. (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnSourceInitialized | (inherited from Window)
protected method | OnStateChanged | (inherited from Window)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
Top

Public Events

 | Name | Description
public event | Activated | (inherited from Window)
public event | Closed | (inherited from Window)
public event | Closing | (inherited from Window)
public event | ContentRendered | (inherited from Window)
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | Deactivated | (inherited from Window)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LocationChanged | (inherited from Window)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceInitialized | (inherited from Window)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StateChanged | (inherited from Window)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

SelectOrgDlg Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SelectOrgDlg Constructor
[image]

Constructor

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SelectOrgDlg ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SelectOrgDlg Class
SelectOrgDlg Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SelectOrgDlg Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Activate | (inherited from Window)
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | Close | (inherited from Window)
public method | CoerceValue | (inherited from DependencyObject)
public method | DragMove | (inherited from Window)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | Hide | (inherited from Window)
public method | InitializeComponent | InitializeComponent
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | Show | (inherited from Window)
public method | ShowDialog | (inherited from Window)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from Control)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from Control)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnActivated | (inherited from Window)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnClosed | (inherited from Window)
protected method | OnClosing | (inherited from Window)
protected method | OnContentChanged | Overridden. (inherited from ContentControl)
protected method | OnContentRendered | (inherited from Window)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDeactivated | (inherited from Window)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLocationChanged | (inherited from Window)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | Overridden. (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnSourceInitialized | (inherited from Window)
protected method | OnStateChanged | (inherited from Window)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect |
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

SelectOrgDlg Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SelectOrgDlg.InitializeComponent Method
[image]

InitializeComponent

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent

C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
public void InitializeComponent ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SelectOrgDlg Class
SelectOrgDlg Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SelectOrgDlg.Connect Method
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerNonUserCodeAttribute> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect

C#
[DebuggerNonUserCodeAttribute]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SelectOrgDlg Class
SelectOrgDlg Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SelectOrgDlg Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AllowsTransparency | (inherited from Window)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | DialogResult | (inherited from Window)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | GetSelectedCrmOrg | returns the user selected CrmOrganization
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from Window)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsActive | (inherited from Window)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Left | (inherited from Window)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | OwnedWindows | (inherited from Window)
public property | Owner | (inherited from Window)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | ResizeMode | (inherited from Window)
public property | Resources | (inherited from FrameworkElement)
public property | RestoreBounds | (inherited from Window)
public property | ShowActivated | (inherited from Window)
public property | ShowInTaskbar | (inherited from Window)
public property | SizeToContent | (inherited from Window)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | TaskbarItemInfo | (inherited from Window)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Window)
public property | ToolTip | (inherited from FrameworkElement)
public property | Top | (inherited from Window)
public property | Topmost | (inherited from Window)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowStartupLocation | (inherited from Window)
public property | WindowState | (inherited from Window)
public property | WindowStyle | (inherited from Window)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

SelectOrgDlg Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SelectOrgDlg.GetSelectedCrmOrg Property
[image]

returns the user selected CrmOrganization

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property GetSelectedCrmOrg As CrmOrgByServer

C#
public CrmOrgByServer GetSelectedCrmOrg { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SelectOrgDlg Class
SelectOrgDlg Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SelectOrgDlg Events
[image]

Public Events

 | Name | Description
public event | Activated | (inherited from Window)
public event | Closed | (inherited from Window)
public event | Closing | (inherited from Window)
public event | ContentRendered | (inherited from Window)
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | Deactivated | (inherited from Window)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LocationChanged | (inherited from Window)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceInitialized | (inherited from Window)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StateChanged | (inherited from Window)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

SelectOrgDlg Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Class
See Also Members
[image]

Event Raised when the Server Validate Connection Command operates.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ServerConnectStatusEventArgs
    Inherits EventArgs

C#
public class ServerConnectStatusEventArgs : EventArgs

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs
    Microsoft.Xrm.Tooling.CrmConnectControl.ServerConnectStatusEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Members
See Also Constructors Methods Properties
[image]

Event Raised when the Server Validate Connection Command operates.

The following tables list the members exposed by the ServerConnectStatusEventArgs type.

Public Constructors

Name | Description
ServerConnectStatusEventArgs | Overloaded.
Top

Public Properties

 | Name | Description
public property | Connected | if true, connected to CRM, else not connected to CRM
public property | ErrorMessage | Error Message from the originating source
public property | exEvent | Exception that goes with the error message
public property | MultiOrgsFound | If true, there were multiple organizations found, the user will need to select the correct org and re logon.
public property | StatusMessage | Text status message, usually communicating the current state of the login process.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ServerConnectStatusEventArgs Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Constructor
[image]

Overload List

Name | Description
ServerConnectStatusEventArgs () |
ServerConnectStatusEventArgs (String) |
ServerConnectStatusEventArgs (String, Boolean) |
ServerConnectStatusEventArgs (String, Boolean, Boolean) |
ServerConnectStatusEventArgs (String, Boolean, Exception) |

See Also

Reference

ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Constructor ()
[image]

Initializes a new instance of the ServerConnectStatusEventArgs Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ServerConnectStatusEventArgs ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Constructor (String)
[image]

Initializes a new instance of the ServerConnectStatusEventArgs Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    statusMsg As String _
)

C#
public ServerConnectStatusEventArgs (
    string statusMsg
)

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Constructor (String, Boolean)
[image]

Initializes a new instance of the ServerConnectStatusEventArgs Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    errMsg As String, _
    connected As Boolean _
)

C#
public ServerConnectStatusEventArgs (
    string errMsg,
    bool connected
)

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Constructor (String, Boolean, Boolean)
[image]

Initializes a new instance of the ServerConnectStatusEventArgs Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    errMsg As String, _
    connected As Boolean, _
    multiOrgFound As Boolean _
)

C#
public ServerConnectStatusEventArgs (
    string errMsg,
    bool connected,
    bool multiOrgFound
)

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Constructor (String, Boolean, Exception)
[image]

Initializes a new instance of the ServerConnectStatusEventArgs Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    errMsg As String, _
    connected As Boolean, _
    except As Exception _
)

C#
public ServerConnectStatusEventArgs (
    string errMsg,
    bool connected,
    Exception except
)

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ServerConnectStatusEventArgs Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | Connected | if true, connected to CRM, else not connected to CRM
public property | ErrorMessage | Error Message from the originating source
public property | exEvent | Exception that goes with the error message
public property | MultiOrgsFound | If true, there were multiple organizations found, the user will need to select the correct org and re logon.
public property | StatusMessage | Text status message, usually communicating the current state of the login process.

See Also

Reference

ServerConnectStatusEventArgs Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs.Connected Property
[image]

if true, connected to CRM, else not connected to CRM

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Connected As Boolean

C#
public bool Connected { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs.ErrorMessage Property
[image]

Error Message from the originating source

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ErrorMessage As String

C#
public string ErrorMessage { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs.exEvent Property
[image]

Exception that goes with the error message

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property exEvent As Exception

C#
public Exception exEvent { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs.MultiOrgsFound Property
[image]

If true, there were multiple organizations found, the user will need to select the correct org and re logon.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property MultiOrgsFound As Boolean

C#
public bool MultiOrgsFound { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerConnectStatusEventArgs.StatusMessage Property
[image]

Text status message, usually communicating the current state of the login process.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property StatusMessage As String

C#
public string StatusMessage { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerConnectStatusEventArgs Class
ServerConnectStatusEventArgs Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerLoginConfig_ViewModel Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ServerLoginConfig_ViewModel
    Implements INotifyPropertyChanged

C#
public class ServerLoginConfig_ViewModel : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.ServerLoginConfig_ViewModel
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerLoginConfig_ViewModel Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerLoginConfig_ViewModel Members
See Also Constructors Events Methods
[image]

The following tables list the members exposed by the ServerLoginConfig_ViewModel type.

Public Constructors

Name | Description
ServerLoginConfig_ViewModel |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | PropertyChanged |
Top

See Also

Reference

ServerLoginConfig_ViewModel Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerLoginConfig_ViewModel Constructor
[image]

Initializes a new instance of the ServerLoginConfig_ViewModel Class.Initializes a new instance of the ServerLoginConfig_ViewModel Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ServerLoginConfig_ViewModel ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerLoginConfig_ViewModel Class
ServerLoginConfig_ViewModel Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerLoginConfig_ViewModel Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ServerLoginConfig_ViewModel Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerLoginConfig_ViewModel Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged |

See Also

Reference

ServerLoginConfig_ViewModel Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerLoginConfig_ViewModel.PropertyChanged Event
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ServerLoginConfig_ViewModel Class
ServerLoginConfig_ViewModel Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


ServerLoginConfigCtrlMode Enumeration
[image]

Config Mode to run this control in.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration ServerLoginConfigCtrlMode

C#
public enum ServerLoginConfigCtrlMode

C++

J#

JScript

  Members
Member name | Description
ConfigPanel | Hide the Cancel button and Show the Org Select UI.
FullLoginPanel | Show the Cancel button
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SortAdorner Class
See Also Members
[image]

Creates a Adorner to indicate sort direction. This class was taken from http://www.switchonthecode.com/tutorials/wpf-tutorial-using-the-listview-part-2-sorting

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class SortAdorner
    Inherits Adorner

C#
public class SortAdorner : Adorner

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Documents.Adorner
              Microsoft.Xrm.Tooling.CrmConnectControl.SortAdorner
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SortAdorner Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SortAdorner Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

Creates a Adorner to indicate sort direction. This class was taken from http://www.switchonthecode.com/tutorials/wpf-tutorial-using-the-listview-part-2-sorting

The following tables list the members exposed by the SortAdorner type.

Public Constructors

Name | Description
SortAdorner |
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AdornedElement | (inherited from Adorner)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Direction |
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | ForceCursor | (inherited from FrameworkElement)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsClipEnabled | (inherited from Adorner)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetDesiredTransform | (inherited from Adorner)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from FrameworkElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | Overridden.
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
Top

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

SortAdorner Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SortAdorner Constructor
[image]

Initializes a new instance of the SortAdorner Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    element As UIElement, _
    dir As ListSortDirection _
)

C#
public SortAdorner (
    UIElement element,
    ListSortDirection dir
)

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SortAdorner Class
SortAdorner Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SortAdorner Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetDesiredTransform | (inherited from Adorner)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from FrameworkElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | Overridden.
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)

Explicit Interface Implementations

Name | Description
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

SortAdorner Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SortAdorner.OnRender Method
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Overrides Sub OnRender ( _
    drawingContext As DrawingContext _
)

C#
protected override void OnRender (
    DrawingContext drawingContext
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SortAdorner Class
SortAdorner Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SortAdorner Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AdornedElement | (inherited from Adorner)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Direction |
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | ForceCursor | (inherited from FrameworkElement)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsClipEnabled | (inherited from Adorner)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

SortAdorner Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SortAdorner.Direction Property
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Direction As ListSortDirection

C#
public ListSortDirection Direction { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SortAdorner Class
SortAdorner Members
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


SortAdorner Events
[image]

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

SortAdorner Class
Microsoft.Xrm.Tooling.CrmConnectControl Namespace


Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace

Classes

Class | Description
ClaimsHomeRealmOptions |
ClaimsHomeRealmOptionsHomeRealm |
CrmOnlineDiscoveryServer | Describes a discovery server that can be used to determine what organizations a user is a member of.
CrmOnlineDiscoveryServers | CRM online Discovery server enumeration This is accurate at the time of release of the CRM 2011 Online system. This may changed in the future. Check the CRM SDK for the most current list.
CrmOrgByServer | Describes a Single Organization returned from a CRM Discovery server
CrmOrgList | Describes the Collection of Orgs that a user may select from. This is used to display the list to the user


ClaimsHomeRealmOptions Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<DesignerCategoryAttribute("code")> _
<XmlRootAttribute(Namespace:="", IsNullable:=False)> _
<GeneratedCodeAttribute("xsd", "4.0.30319.1")> _
<DebuggerStepThroughAttribute> _
<XmlTypeAttribute(AnonymousType:=True)> _
Public Class ClaimsHomeRealmOptions
    Implements INotifyPropertyChanged

C#
[SerializableAttribute]
[DesignerCategoryAttribute("code")]
[XmlRootAttribute(Namespace="", IsNullable=false)]
[GeneratedCodeAttribute("xsd", "4.0.30319.1")]
[DebuggerStepThroughAttribute]
[XmlTypeAttribute(AnonymousType=true)]
public class ClaimsHomeRealmOptions : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Model.ClaimsHomeRealmOptions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptions Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptions Members
See Also Constructors Events Methods Properties
[image]

The following tables list the members exposed by the ClaimsHomeRealmOptions type.

Public Constructors

Name | Description
ClaimsHomeRealmOptions |
Top

Public Properties

 | Name | Description
public property | Items |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetServerByDisplayName | Finds the Home Realm information for the Display Name
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | RaisePropertyChanged | Raised when a property changes
Top

Public Events

 | Name | Description
public event | PropertyChanged | Default Propertly changed event.
Top

See Also

Reference

ClaimsHomeRealmOptions Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptions Constructor
[image]

Initializes a new instance of the ClaimsHomeRealmOptions Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ClaimsHomeRealmOptions ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptions Class
ClaimsHomeRealmOptions Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptions Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetServerByDisplayName | Finds the Home Realm information for the Display Name
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | RaisePropertyChanged | Raised when a property changes

See Also

Reference

ClaimsHomeRealmOptions Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptions.GetServerByDisplayName Method
[image]

Finds the Home Realm information for the Display Name

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetServerByDisplayName ( _
    shortName As String _
) As ClaimsHomeRealmOptionsHomeRealm

C#
public ClaimsHomeRealmOptionsHomeRealm GetServerByDisplayName (
    string shortName
)

C++

J#

JScript

Parameters
shortName
Display Name of the server you are looking for
Return Value
ClaimsHomeRealmOptionsHomeRealm Data or Null

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptions Class
ClaimsHomeRealmOptions Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptions.RaisePropertyChanged Method
[image]

Raised when a property changes

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)

C#
protected void RaisePropertyChanged (
    string propertyName
)

C++

J#

JScript

Parameters
propertyName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptions Class
ClaimsHomeRealmOptions Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptions Properties
[image]

Public Properties

 | Name | Description
public property | Items |

See Also

Reference

ClaimsHomeRealmOptions Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptions.Items Property
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlElementAttribute("HomeRealm", Form:=XmlSchemaForm.Unqualified)> _
Public Property Items As ObservableCollection(Of ClaimsHomeRealmOptionsHomeRealm)

C#
[XmlElementAttribute("HomeRealm", Form=XmlSchemaForm.Unqualified)]
public ObservableCollection<ClaimsHomeRealmOptionsHomeRealm> Items { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptions Class
ClaimsHomeRealmOptions Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptions Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged | Default Propertly changed event.

See Also

Reference

ClaimsHomeRealmOptions Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptions.PropertyChanged Event
[image]

Default Propertly changed event.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptions Class
ClaimsHomeRealmOptions Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<SerializableAttribute> _
<XmlTypeAttribute(AnonymousType:=True)> _
<DesignerCategoryAttribute("code")> _
<GeneratedCodeAttribute("xsd", "4.0.30319.1")> _
<DebuggerStepThroughAttribute> _
Public Class ClaimsHomeRealmOptionsHomeRealm
    Implements INotifyPropertyChanged

C#
[SerializableAttribute]
[XmlTypeAttribute(AnonymousType=true)]
[DesignerCategoryAttribute("code")]
[GeneratedCodeAttribute("xsd", "4.0.30319.1")]
[DebuggerStepThroughAttribute]
public class ClaimsHomeRealmOptionsHomeRealm : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Model.ClaimsHomeRealmOptionsHomeRealm
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptionsHomeRealm Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm Members
See Also Constructors Events Methods Properties
[image]

The following tables list the members exposed by the ClaimsHomeRealmOptionsHomeRealm type.

Public Constructors

Name | Description
ClaimsHomeRealmOptionsHomeRealm |
Top

Public Properties

 | Name | Description
public property | DisplayName |
public property | Uri |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | RaisePropertyChanged |
Top

Public Events

 | Name | Description
public event | PropertyChanged |
Top

See Also

Reference

ClaimsHomeRealmOptionsHomeRealm Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm Constructor
[image]

Initializes a new instance of the ClaimsHomeRealmOptionsHomeRealm Class.Initializes a new instance of the ClaimsHomeRealmOptionsHomeRealm Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ClaimsHomeRealmOptionsHomeRealm ()

C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptionsHomeRealm Class
ClaimsHomeRealmOptionsHomeRealm Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | RaisePropertyChanged |

See Also

Reference

ClaimsHomeRealmOptionsHomeRealm Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm.RaisePropertyChanged Method
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)

C#
protected void RaisePropertyChanged (
    string propertyName
)

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptionsHomeRealm Class
ClaimsHomeRealmOptionsHomeRealm Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm Properties
[image]

Public Properties

 | Name | Description
public property | DisplayName |
public property | Uri |

See Also

Reference

ClaimsHomeRealmOptionsHomeRealm Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm.DisplayName Property
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlAttributeAttribute> _
Public Property DisplayName As String

C#
[XmlAttributeAttribute]
public string DisplayName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptionsHomeRealm Class
ClaimsHomeRealmOptionsHomeRealm Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm.Uri Property
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<XmlAttributeAttribute> _
Public Property Uri As String

C#
[XmlAttributeAttribute]
public string Uri { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptionsHomeRealm Class
ClaimsHomeRealmOptionsHomeRealm Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged |

See Also

Reference

ClaimsHomeRealmOptionsHomeRealm Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


ClaimsHomeRealmOptionsHomeRealm.PropertyChanged Event
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ClaimsHomeRealmOptionsHomeRealm Class
ClaimsHomeRealmOptionsHomeRealm Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer Class
See Also Members
[image]

Describes a discovery server that can be used to determine what organizations a user is a member of.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class CrmOnlineDiscoveryServer
    Implements INotifyPropertyChanged

C#
public class CrmOnlineDiscoveryServer : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Model.CrmOnlineDiscoveryServer
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer Members
See Also Constructors Events Methods Properties
[image]

Describes a discovery server that can be used to determine what organizations a user is a member of.

The following tables list the members exposed by the CrmOnlineDiscoveryServer type.

Public Constructors

Name | Description
CrmOnlineDiscoveryServer |
Top

Public Properties

 | Name | Description
public property | DiscoveryServer | Discovery server Uri, this is the URI necessary to connect to the Discovery server
public property | DisplayName | Display name of the Discovery Server
public property | ShortName | Short name of the Discovery Server, this is used to store the server in the users config for later use.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | PropertyChanged |
Top

See Also

Reference

CrmOnlineDiscoveryServer Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer Constructor
[image]

Initializes a new instance of the CrmOnlineDiscoveryServer Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmOnlineDiscoveryServer ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServer Class
CrmOnlineDiscoveryServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmOnlineDiscoveryServer Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer Properties
[image]

Public Properties

 | Name | Description
public property | DiscoveryServer | Discovery server Uri, this is the URI necessary to connect to the Discovery server
public property | DisplayName | Display name of the Discovery Server
public property | ShortName | Short name of the Discovery Server, this is used to store the server in the users config for later use.

See Also

Reference

CrmOnlineDiscoveryServer Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer.DiscoveryServer Property
[image]

Discovery server Uri, this is the URI necessary to connect to the Discovery server

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DiscoveryServer As Uri

C#
public Uri DiscoveryServer { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServer Class
CrmOnlineDiscoveryServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer.DisplayName Property
[image]

Display name of the Discovery Server

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DisplayName As String

C#
public string DisplayName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServer Class
CrmOnlineDiscoveryServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer.ShortName Property
[image]

Short name of the Discovery Server, this is used to store the server in the users config for later use.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ShortName As String

C#
public string ShortName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServer Class
CrmOnlineDiscoveryServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged |

See Also

Reference

CrmOnlineDiscoveryServer Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServer.PropertyChanged Event
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServer Class
CrmOnlineDiscoveryServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers Class
See Also Members
[image]

CRM online Discovery server enumeration This is accurate at the time of release of the CRM 2011 Online system. This may changed in the future. Check the CRM SDK for the most current list.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class CrmOnlineDiscoveryServers
    Implements INotifyPropertyChanged

C#
public class CrmOnlineDiscoveryServers : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Model.CrmOnlineDiscoveryServers
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServers Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers Members
See Also Constructors Events Methods Properties
[image]

CRM online Discovery server enumeration This is accurate at the time of release of the CRM 2011 Online system. This may changed in the future. Check the CRM SDK for the most current list.

The following tables list the members exposed by the CrmOnlineDiscoveryServers type.

Public Constructors

Name | Description
CrmOnlineDiscoveryServers | Default constructor, Builds baseline data for the Servers.
Top

Public Properties

 | Name | Description
public property | OSDPServers | Public Property to Access Office 365 discovery servers
public property | Servers | Public Property to Access the Servers available.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetServerByShortName | Finds a Server by Name in the List or return null.
public method | GetServerShortNameByDisplayName | Finds the server short name by server Uri
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | PropertyChanged |
Top

See Also

Reference

CrmOnlineDiscoveryServers Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers Constructor
[image]

Default constructor, Builds baseline data for the Servers.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmOnlineDiscoveryServers ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServers Class
CrmOnlineDiscoveryServers Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetServerByShortName | Finds a Server by Name in the List or return null.
public method | GetServerShortNameByDisplayName | Finds the server short name by server Uri
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmOnlineDiscoveryServers Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers.GetServerByShortName Method
[image]

Finds a Server by Name in the List or return null.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetServerByShortName ( _
    shortName As String, _
    <OptionalAttribute> Optional isO365 As Boolean = False _
) As CrmOnlineDiscoveryServer

C#
public CrmOnlineDiscoveryServer GetServerByShortName (
    string shortName,
    [OptionalAttribute] bool isO365
)

C++

J#

JScript

Parameters
shortName
Short Name of the server you are looking for
isO365
if set, uses the office 365 server list.
Return Value
CrmOnlineDiscoveryServer Data or Null

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServers Class
CrmOnlineDiscoveryServers Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers.GetServerShortNameByDisplayName Method
[image]

Finds the server short name by server Uri

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetServerShortNameByDisplayName ( _
    serverDisplayName As String, _
    <OptionalAttribute> Optional isO365 As Boolean = False _
) As String

C#
public string GetServerShortNameByDisplayName (
    string serverDisplayName,
    [OptionalAttribute] bool isO365
)

C++

J#

JScript

Parameters
serverDisplayName
Name of the Server to find
isO365
if set, uses the office 365 server list.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServers Class
CrmOnlineDiscoveryServers Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers Properties
[image]

Public Properties

 | Name | Description
public property | OSDPServers | Public Property to Access Office 365 discovery servers
public property | Servers | Public Property to Access the Servers available.

See Also

Reference

CrmOnlineDiscoveryServers Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers.OSDPServers Property
[image]

Public Property to Access Office 365 discovery servers

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OSDPServers As ObservableCollection(Of CrmOnlineDiscoveryServer)

C#
public ObservableCollection<CrmOnlineDiscoveryServer> OSDPServers { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServers Class
CrmOnlineDiscoveryServers Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers.Servers Property
[image]

Public Property to Access the Servers available.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Servers As ObservableCollection(Of CrmOnlineDiscoveryServer)

C#
public ObservableCollection<CrmOnlineDiscoveryServer> Servers { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServers Class
CrmOnlineDiscoveryServers Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged |

See Also

Reference

CrmOnlineDiscoveryServers Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOnlineDiscoveryServers.PropertyChanged Event
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOnlineDiscoveryServers Class
CrmOnlineDiscoveryServers Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer Class
See Also Members
[image]

Describes a Single Organization returned from a CRM Discovery server

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class CrmOrgByServer
    Implements INotifyPropertyChanged

C#
public class CrmOrgByServer : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Model.CrmOrgByServer
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer Members
See Also Constructors Events Methods Properties
[image]

Describes a Single Organization returned from a CRM Discovery server

The following tables list the members exposed by the CrmOrgByServer type.

Public Constructors

Name | Description
CrmOrgByServer |
Top

Public Properties

 | Name | Description
public property | DiscoveryServer | This is the URI needed to connect to the Organization
public property | DiscoveryServerName | This is the name assigned to the Discovery Server, this is used to visual separate organizations returned by Discovery server used, or Premise solutions.
public property | FriendlyName | This is the display name for the organization that a user sees when working in CRM
public property | OrdDetail | This is the details of the Organization, returned directly from CRM
public property | UniqueOrdName | This is the actual name for the organization in CRM, and is required to connect to CRM
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | PropertyChanged |
Top

See Also

Reference

CrmOrgByServer Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer Constructor
[image]

Initializes a new instance of the CrmOrgByServer Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmOrgByServer ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmOrgByServer Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer Properties
[image]

Public Properties

 | Name | Description
public property | DiscoveryServer | This is the URI needed to connect to the Organization
public property | DiscoveryServerName | This is the name assigned to the Discovery Server, this is used to visual separate organizations returned by Discovery server used, or Premise solutions.
public property | FriendlyName | This is the display name for the organization that a user sees when working in CRM
public property | OrdDetail | This is the details of the Organization, returned directly from CRM
public property | UniqueOrdName | This is the actual name for the organization in CRM, and is required to connect to CRM

See Also

Reference

CrmOrgByServer Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer.DiscoveryServer Property
[image]

This is the URI needed to connect to the Organization

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property DiscoveryServer As Uri

C#
public Uri DiscoveryServer { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer.DiscoveryServerName Property
[image]

This is the name assigned to the Discovery Server, this is used to visual separate organizations returned by Discovery server used, or Premise solutions.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property DiscoveryServerName As String

C#
public string DiscoveryServerName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer.FriendlyName Property
[image]

This is the display name for the organization that a user sees when working in CRM

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property FriendlyName As String

C#
public string FriendlyName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer.OrdDetail Property
[image]

This is the details of the Organization, returned directly from CRM

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OrdDetail As OrganizationDetail

C#
public OrganizationDetail OrdDetail { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer.UniqueOrdName Property
[image]

This is the actual name for the organization in CRM, and is required to connect to CRM

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property UniqueOrdName As String

C#
public string UniqueOrdName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged |

See Also

Reference

CrmOrgByServer Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgByServer.PropertyChanged Event
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgByServer Class
CrmOrgByServer Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgList Class
See Also Members
[image]

Describes the Collection of Orgs that a user may select from. This is used to display the list to the user

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class CrmOrgList
    Implements INotifyPropertyChanged

C#
public class CrmOrgList : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Model.CrmOrgList
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgList Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgList Members
See Also Constructors Events Methods Properties
[image]

Describes the Collection of Orgs that a user may select from. This is used to display the list to the user

The following tables list the members exposed by the CrmOrgList type.

Public Constructors

Name | Description
CrmOrgList | Dictionary of Orgs.
Top

Public Properties

 | Name | Description
public property | OrgsList | List of Orgs
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | PropertyChanged |
Top

See Also

Reference

CrmOrgList Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgList Constructor
[image]

Dictionary of Orgs.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public CrmOrgList ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgList Class
CrmOrgList Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgList Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

CrmOrgList Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgList Properties
[image]

Public Properties

 | Name | Description
public property | OrgsList | List of Orgs

See Also

Reference

CrmOrgList Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgList.OrgsList Property
[image]

List of Orgs

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property OrgsList As ObservableCollection(Of CrmOrgByServer)

C#
public ObservableCollection<CrmOrgByServer> OrgsList { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgList Class
CrmOrgList Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgList Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged |

See Also

Reference

CrmOrgList Class
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


CrmOrgList.PropertyChanged Event
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Model
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CrmOrgList Class
CrmOrgList Members
Microsoft.Xrm.Tooling.CrmConnectControl.Model Namespace


Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace

Classes

Class | Description
Resources | A strongly-typed resource class, for looking up localized strings, etc.


Resources Class
See Also Members
[image]

A strongly-typed resource class, for looking up localized strings, etc.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<DebuggerNonUserCodeAttribute> _
<CompilerGeneratedAttribute> _
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder", "4.0.0.0")> _
Public Class Resources

C#
[DebuggerNonUserCodeAttribute]
[CompilerGeneratedAttribute]
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder", "4.0.0.0")]
public class Resources

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Properties.Resources
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources Members
See Also Methods Properties
[image]

A strongly-typed resource class, for looking up localized strings, etc.

The following tables list the members exposed by the Resources type.

Public Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
ERROR_DETAILS | Looks up a localized string similar to Error details.
ERROR_LOGIN_REQUEST | Looks up a localized string similar to An Error occured processing the login request..
LOGIN_FRM_ASK_FOR_ORG | Looks up a localized string similar to Always display list of available orgs.
LOGIN_FRM_AUTHTYPE_AD | Looks up a localized string similar to Active Directory.
LOGIN_FRM_AUTHTYPE_CONFIG_FILE_NAME | Looks up a localized string similar to HomeRealmsStore.xml.
LOGIN_FRM_AUTHTYPE_IFD | Looks up a localized string similar to Internet-facing deployment(IFD).
LOGIN_FRM_CANCEL_BTN | Looks up a localized string similar to Cancel.
LOGIN_FRM_CONNECTSTATUS | Looks up a localized string similar to Connection Status.
LOGIN_FRM_CRM_AUTH_SOURCE | Looks up a localized string similar to Auth Source.
LOGIN_FRM_CRM_PREM_NAME | Looks up a localized string similar to On-premises.
LOGIN_FRM_DEPLOYMENT_O365 | Looks up a localized string similar to Office 365.
LOGIN_FRM_DEPLOYMENT_ONLINE | Looks up a localized string similar to Online.
LOGIN_FRM_DEPLOYMENT_PREM | Looks up a localized string similar to On-premises.
LOGIN_FRM_DEPLOYMENT_TYPE | Looks up a localized string similar to Deployment Type.
LOGIN_FRM_DOMAIN | Looks up a localized string similar to Domain.
LOGIN_FRM_ERR_FIRST | Looks up a localized string similar to An Error occurred while processing the login request. .
LOGIN_FRM_ERR_SECOND | Looks up a localized string similar to View Error Log.
LOGIN_FRM_GROUP_TITLE | Looks up a localized string similar to Agent Desktop Logon.
LOGIN_FRM_LOGIN_BTN | Looks up a localized string similar to Log On.
LOGIN_FRM_LOGIN_LBL | Looks up a localized string similar to Login.
LOGIN_FRM_MULT_ORG | Looks up a localized string similar to Multiple CRM Organizations are available to you. Please choose the CRM Organization you would like to connect to..
LOGIN_FRM_ONLINE_REGION | Looks up a localized string similar to Online Region.
LOGIN_FRM_ORG_HEADER | Looks up a localized string similar to Organization Name.
LOGIN_FRM_PASSWORD | Looks up a localized string similar to Password.
LOGIN_FRM_REG_HEADER | Looks up a localized string similar to CRM Region.
LOGIN_FRM_RETRIEVE | Looks up a localized string similar to Retrieving Organizations from CRM.
LOGIN_FRM_RETRIEVE_DEF | Looks up a localized string similar to Log in to Default Organization ({0}).
LOGIN_FRM_SERVERNAME | Looks up a localized string similar to Server.
LOGIN_FRM_SERVERORG | Looks up a localized string similar to CRM Organization.
LOGIN_FRM_SERVERPORT | Looks up a localized string similar to Port.
LOGIN_FRM_TITLE | Looks up a localized string similar to Uii Agent Desktop Logon.
LOGIN_FRM_USE_DEF_CREDS | Looks up a localized string similar to Use Default Credentials.
LOGIN_FRM_USE_SSL | Looks up a localized string similar to Use SSL.
LOGIN_FRM_USERNAME | Looks up a localized string similar to User Name.
ResourceManager | Returns the cached ResourceManager instance used by this class.
TITLE |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Resources Class
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Resources Class
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources Properties
[image]

Public Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
ERROR_DETAILS | Looks up a localized string similar to Error details.
ERROR_LOGIN_REQUEST | Looks up a localized string similar to An Error occured processing the login request..
LOGIN_FRM_ASK_FOR_ORG | Looks up a localized string similar to Always display list of available orgs.
LOGIN_FRM_AUTHTYPE_AD | Looks up a localized string similar to Active Directory.
LOGIN_FRM_AUTHTYPE_CONFIG_FILE_NAME | Looks up a localized string similar to HomeRealmsStore.xml.
LOGIN_FRM_AUTHTYPE_IFD | Looks up a localized string similar to Internet-facing deployment(IFD).
LOGIN_FRM_CANCEL_BTN | Looks up a localized string similar to Cancel.
LOGIN_FRM_CONNECTSTATUS | Looks up a localized string similar to Connection Status.
LOGIN_FRM_CRM_AUTH_SOURCE | Looks up a localized string similar to Auth Source.
LOGIN_FRM_CRM_PREM_NAME | Looks up a localized string similar to On-premises.
LOGIN_FRM_DEPLOYMENT_O365 | Looks up a localized string similar to Office 365.
LOGIN_FRM_DEPLOYMENT_ONLINE | Looks up a localized string similar to Online.
LOGIN_FRM_DEPLOYMENT_PREM | Looks up a localized string similar to On-premises.
LOGIN_FRM_DEPLOYMENT_TYPE | Looks up a localized string similar to Deployment Type.
LOGIN_FRM_DOMAIN | Looks up a localized string similar to Domain.
LOGIN_FRM_ERR_FIRST | Looks up a localized string similar to An Error occurred while processing the login request. .
LOGIN_FRM_ERR_SECOND | Looks up a localized string similar to View Error Log.
LOGIN_FRM_GROUP_TITLE | Looks up a localized string similar to Agent Desktop Logon.
LOGIN_FRM_LOGIN_BTN | Looks up a localized string similar to Log On.
LOGIN_FRM_LOGIN_LBL | Looks up a localized string similar to Login.
LOGIN_FRM_MULT_ORG | Looks up a localized string similar to Multiple CRM Organizations are available to you. Please choose the CRM Organization you would like to connect to..
LOGIN_FRM_ONLINE_REGION | Looks up a localized string similar to Online Region.
LOGIN_FRM_ORG_HEADER | Looks up a localized string similar to Organization Name.
LOGIN_FRM_PASSWORD | Looks up a localized string similar to Password.
LOGIN_FRM_REG_HEADER | Looks up a localized string similar to CRM Region.
LOGIN_FRM_RETRIEVE | Looks up a localized string similar to Retrieving Organizations from CRM.
LOGIN_FRM_RETRIEVE_DEF | Looks up a localized string similar to Log in to Default Organization ({0}).
LOGIN_FRM_SERVERNAME | Looks up a localized string similar to Server.
LOGIN_FRM_SERVERORG | Looks up a localized string similar to CRM Organization.
LOGIN_FRM_SERVERPORT | Looks up a localized string similar to Port.
LOGIN_FRM_TITLE | Looks up a localized string similar to Uii Agent Desktop Logon.
LOGIN_FRM_USE_DEF_CREDS | Looks up a localized string similar to Use Default Credentials.
LOGIN_FRM_USE_SSL | Looks up a localized string similar to Use SSL.
LOGIN_FRM_USERNAME | Looks up a localized string similar to User Name.
ResourceManager | Returns the cached ResourceManager instance used by this class.
TITLE |

See Also

Reference

Resources Class
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.Culture Property
[image]

Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.ERROR_DETAILS Property
[image]

Looks up a localized string similar to Error details.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property ERROR_DETAILS As String

C#
public static string ERROR_DETAILS { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.ERROR_LOGIN_REQUEST Property
[image]

Looks up a localized string similar to An Error occured processing the login request..

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property ERROR_LOGIN_REQUEST As String

C#
public static string ERROR_LOGIN_REQUEST { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_ASK_FOR_ORG Property
[image]

Looks up a localized string similar to Always display list of available orgs.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_ASK_FOR_ORG As String

C#
public static string LOGIN_FRM_ASK_FOR_ORG { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_AUTHTYPE_AD Property
[image]

Looks up a localized string similar to Active Directory.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_AUTHTYPE_AD As String

C#
public static string LOGIN_FRM_AUTHTYPE_AD { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_AUTHTYPE_CONFIG_FILE_NAME Property
[image]

Looks up a localized string similar to HomeRealmsStore.xml.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_AUTHTYPE_CONFIG_FILE_NAME As String

C#
public static string LOGIN_FRM_AUTHTYPE_CONFIG_FILE_NAME { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_AUTHTYPE_IFD Property
[image]

Looks up a localized string similar to Internet-facing deployment(IFD).

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_AUTHTYPE_IFD As String

C#
public static string LOGIN_FRM_AUTHTYPE_IFD { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_CANCEL_BTN Property
[image]

Looks up a localized string similar to Cancel.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_CANCEL_BTN As String

C#
public static string LOGIN_FRM_CANCEL_BTN { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_CONNECTSTATUS Property
[image]

Looks up a localized string similar to Connection Status.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_CONNECTSTATUS As String

C#
public static string LOGIN_FRM_CONNECTSTATUS { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_CRM_AUTH_SOURCE Property
[image]

Looks up a localized string similar to Auth Source.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_CRM_AUTH_SOURCE As String

C#
public static string LOGIN_FRM_CRM_AUTH_SOURCE { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_CRM_PREM_NAME Property
[image]

Looks up a localized string similar to On-premises.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_CRM_PREM_NAME As String

C#
public static string LOGIN_FRM_CRM_PREM_NAME { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_DEPLOYMENT_O365 Property
[image]

Looks up a localized string similar to Office 365.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_DEPLOYMENT_O365 As String

C#
public static string LOGIN_FRM_DEPLOYMENT_O365 { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_DEPLOYMENT_ONLINE Property
[image]

Looks up a localized string similar to Online.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_DEPLOYMENT_ONLINE As String

C#
public static string LOGIN_FRM_DEPLOYMENT_ONLINE { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_DEPLOYMENT_PREM Property
[image]

Looks up a localized string similar to On-premises.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_DEPLOYMENT_PREM As String

C#
public static string LOGIN_FRM_DEPLOYMENT_PREM { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_DEPLOYMENT_TYPE Property
[image]

Looks up a localized string similar to Deployment Type.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_DEPLOYMENT_TYPE As String

C#
public static string LOGIN_FRM_DEPLOYMENT_TYPE { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_DOMAIN Property
[image]

Looks up a localized string similar to Domain.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_DOMAIN As String

C#
public static string LOGIN_FRM_DOMAIN { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_ERR_FIRST Property
[image]

Looks up a localized string similar to An Error occurred while processing the login request. .

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_ERR_FIRST As String

C#
public static string LOGIN_FRM_ERR_FIRST { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_ERR_SECOND Property
[image]

Looks up a localized string similar to View Error Log.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_ERR_SECOND As String

C#
public static string LOGIN_FRM_ERR_SECOND { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_GROUP_TITLE Property
[image]

Looks up a localized string similar to Agent Desktop Logon.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_GROUP_TITLE As String

C#
public static string LOGIN_FRM_GROUP_TITLE { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_LOGIN_BTN Property
[image]

Looks up a localized string similar to Log On.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_LOGIN_BTN As String

C#
public static string LOGIN_FRM_LOGIN_BTN { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_LOGIN_LBL Property
[image]

Looks up a localized string similar to Login.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_LOGIN_LBL As String

C#
public static string LOGIN_FRM_LOGIN_LBL { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_MULT_ORG Property
[image]

Looks up a localized string similar to Multiple CRM Organizations are available to you. Please choose the CRM Organization you would like to connect to..

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_MULT_ORG As String

C#
public static string LOGIN_FRM_MULT_ORG { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_ONLINE_REGION Property
[image]

Looks up a localized string similar to Online Region.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_ONLINE_REGION As String

C#
public static string LOGIN_FRM_ONLINE_REGION { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_ORG_HEADER Property
[image]

Looks up a localized string similar to Organization Name.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_ORG_HEADER As String

C#
public static string LOGIN_FRM_ORG_HEADER { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_PASSWORD Property
[image]

Looks up a localized string similar to Password.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_PASSWORD As String

C#
public static string LOGIN_FRM_PASSWORD { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_REG_HEADER Property
[image]

Looks up a localized string similar to CRM Region.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_REG_HEADER As String

C#
public static string LOGIN_FRM_REG_HEADER { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_RETRIEVE Property
[image]

Looks up a localized string similar to Retrieving Organizations from CRM.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_RETRIEVE As String

C#
public static string LOGIN_FRM_RETRIEVE { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_RETRIEVE_DEF Property
[image]

Looks up a localized string similar to Log in to Default Organization ({0}).

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_RETRIEVE_DEF As String

C#
public static string LOGIN_FRM_RETRIEVE_DEF { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_SERVERNAME Property
[image]

Looks up a localized string similar to Server.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_SERVERNAME As String

C#
public static string LOGIN_FRM_SERVERNAME { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_SERVERORG Property
[image]

Looks up a localized string similar to CRM Organization.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_SERVERORG As String

C#
public static string LOGIN_FRM_SERVERORG { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_SERVERPORT Property
[image]

Looks up a localized string similar to Port.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_SERVERPORT As String

C#
public static string LOGIN_FRM_SERVERPORT { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_TITLE Property
[image]

Looks up a localized string similar to Uii Agent Desktop Logon.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_TITLE As String

C#
public static string LOGIN_FRM_TITLE { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_USE_DEF_CREDS Property
[image]

Looks up a localized string similar to Use Default Credentials.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_USE_DEF_CREDS As String

C#
public static string LOGIN_FRM_USE_DEF_CREDS { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_USE_SSL Property
[image]

Looks up a localized string similar to Use SSL.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_USE_SSL As String

C#
public static string LOGIN_FRM_USE_SSL { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.LOGIN_FRM_USERNAME Property
[image]

Looks up a localized string similar to User Name.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property LOGIN_FRM_USERNAME As String

C#
public static string LOGIN_FRM_USERNAME { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.ResourceManager Property
[image]

Returns the cached ResourceManager instance used by this class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Resources.TITLE Property
[image]

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Properties
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared ReadOnly Property TITLE As String

C#
public static string TITLE { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Resources Class
Resources Members
Microsoft.Xrm.Tooling.CrmConnectControl.Properties Namespace


Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace

Classes

Class | Description
CredentialManager | This class exposes methods to read, write and delete user credentials
ErrorLogger | Used to log errors to disk as part of connection logic for debugging or reporting an error concerning connecting to CRM
OrgNameFormater | Formats the org name for to append the Unique Name to the List View.
SavedCredentials | Represents a credential stored in credential manager
StorageUtils | Provides utility services for accessing, loading and describing configuration entries used by the CrmConnect classes.
TraceControlSettings | This class provides an override for the default trace settings. These settings must be set before the components in the control are used for them to be effective.

Enumerations

Enumeration | Description
CrmDeploymentType | This identifies the authentication type used.
Dynamics_ConfigFileServerKeys | Enum for CrmConnection Configuration Keys in the app.config.


CredentialManager Class
See Also Members
[image]

This class exposes methods to read, write and delete user credentials

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class CredentialManager

C#
public static class CredentialManager

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Utility.CredentialManager
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager Members
See Also Fields Methods
[image]

This class exposes methods to read, write and delete user credentials

The following tables list the members exposed by the CredentialManager type.

Public Fields

Name | Description
CrmTargetPrefix | Target Name against which all credentials are stored on the disk.
Top

Public Methods

Name | Description
DeleteCredentials | Overloaded.
GetCredentialTarget | Retrieves the URI (for a given target URI) that will be present in the saved credentials
ReadCredentials | Overloaded.
WriteCredentials | Overloaded.
Top

See Also

Reference

CredentialManager Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager Fields
[image]

Public Fields

Name | Description
CrmTargetPrefix | Target Name against which all credentials are stored on the disk.

See Also

Reference

CredentialManager Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.CrmTargetPrefix Field
[image]

Target Name against which all credentials are stored on the disk.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Const CrmTargetPrefix As String

C#
public const string CrmTargetPrefix

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager Methods
[image]

Public Methods

Name | Description
DeleteCredentials | Overloaded.
GetCredentialTarget | Retrieves the URI (for a given target URI) that will be present in the saved credentials
ReadCredentials | Overloaded.
WriteCredentials | Overloaded.

See Also

Reference

CredentialManager Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.DeleteCredentials Method
[image]

Overload List

Name | Description
CredentialManager.DeleteCredentials (String, Boolean) | Deletes the credentials.
CredentialManager.DeleteCredentials (Uri, Boolean) | Deletes the credentials.

See Also

Reference

CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.DeleteCredentials Method (String, Boolean)
[image]

Deletes the credentials.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub DeleteCredentials ( _
    target As String, _
    deletePasswordOnly As Boolean _
)

C#
public static void DeleteCredentials (
    string target,
    bool deletePasswordOnly
)

C++

J#

JScript

Parameters
target
Target is the key with which associated credentials can be fetched
deletePasswordOnly
Indicates that the password should be overwritten, but the credential should not be removed from the credential cache.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.DeleteCredentials Method (Uri, Boolean)
[image]

Deletes the credentials.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub DeleteCredentials ( _
    target As Uri, _
    deletePasswordOnly As Boolean _
)

C#
public static void DeleteCredentials (
    Uri target,
    bool deletePasswordOnly
)

C++

J#

JScript

Parameters
target
Target is the key with which associated credentials can be fetched
deletePasswordOnly
Indicates that the password should be overwritten, but the credential should not be removed from the credential cache.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.GetCredentialTarget Method
[image]

Retrieves the URI (for a given target URI) that will be present in the saved credentials

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function GetCredentialTarget ( _
    target As Uri _
) As Uri

C#
public static Uri GetCredentialTarget (
    Uri target
)

C++

J#

JScript

Parameters
target
Target to be read
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.ReadCredentials Method
[image]

Overload List

Name | Description
CredentialManager.ReadCredentials (String) | Reads the saved credentials for a given target
CredentialManager.ReadCredentials (Uri) | Reads the credentials for the given target URI

See Also

Reference

CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.ReadCredentials Method (String)
[image]

Reads the saved credentials for a given target

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function ReadCredentials ( _
    target As String _
) As SavedCredentials

C#
public static SavedCredentials ReadCredentials (
    string target
)

C++

J#

JScript

Parameters
target
Target that is persisted
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.ReadCredentials Method (Uri)
[image]

Reads the credentials for the given target URI

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function ReadCredentials ( _
    target As Uri _
) As SavedCredentials

C#
public static SavedCredentials ReadCredentials (
    Uri target
)

C++

J#

JScript

Parameters
target
URI for the target
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.WriteCredentials Method
[image]

Overload List

Name | Description
CredentialManager.WriteCredentials (String, SavedCredentials, Boolean) | Writes the credentials.
CredentialManager.WriteCredentials (Uri, SavedCredentials, Boolean) | Writes the credentials.

See Also

Reference

CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.WriteCredentials Method (String, SavedCredentials, Boolean)
[image]

Writes the credentials.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub WriteCredentials ( _
    target As String, _
    userCredentials As SavedCredentials, _
    storePasswordInCredentialCache As Boolean _
)

C#
public static void WriteCredentials (
    string target,
    SavedCredentials userCredentials,
    bool storePasswordInCredentialCache
)

C++

J#

JScript

Parameters
target
Target is the key with which associated credentials can be fetched
userCredentials
It is the in parameter which contains the username and password
storePasswordInCredentialCache
Indicates that the password should be persisted to the credential cache
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CredentialManager.WriteCredentials Method (Uri, SavedCredentials, Boolean)
[image]

Writes the credentials.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub WriteCredentials ( _
    target As Uri, _
    userCredentials As SavedCredentials, _
    storePasswordInCredentialCache As Boolean _
)

C#
public static void WriteCredentials (
    Uri target,
    SavedCredentials userCredentials,
    bool storePasswordInCredentialCache
)

C++

J#

JScript

Parameters
target
Target is the key with which associated credentials can be fetched
userCredentials
It is the in parameter which contains the username and password
storePasswordInCredentialCache
Indicates that the password should be persisted to the credential cache
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
CredentialManager Class
CredentialManager Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


CrmDeploymentType Enumeration
[image]

This identifies the authentication type used.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration CrmDeploymentType

C#
public enum CrmDeploymentType

C++

J#

JScript

  Members
Member name | Description
O365 | Using Office365
Online | Using CRM Online
Prem | Using Premise
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


Dynamics_ConfigFileServerKeys Enumeration
[image]

Enum for CrmConnection Configuration Keys in the app.config.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration Dynamics_ConfigFileServerKeys

C#
public enum Dynamics_ConfigFileServerKeys

C++

J#

JScript

  Members
Member name | Description
AskForOrg | Use the system ask for the org each login.
AuthHomeRealm | what Home Realm to use
CacheCredentials | Flag, encrypt and hold creds.
CrmDeploymentType | Type of CRM deployment used indicating where CRM is running used to be UiiCrmUseOnPrem
CrmDomain | Domain used when connecting to CRM
CrmOnlineRegion | What CRM online Region to use
CrmOrg | CRM Org Connecting too.
CrmPassword | Password used when connecting to CRM
CrmPort | Port CRM server is listening on
CrmServerName | CRM Server name
CrmUserName | User name to connect to CRM with
CrmUseSSL | Use SSL ?
UseDefaultCreds | Use Default Credentials.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


ErrorLogger Class
See Also Members
[image]

Used to log errors to disk as part of connection logic for debugging or reporting an error concerning connecting to CRM

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ErrorLogger

C#
public class ErrorLogger

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Utility.ErrorLogger
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorLogger Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


ErrorLogger Members
See Also Constructors Methods Properties
[image]

Used to log errors to disk as part of connection logic for debugging or reporting an error concerning connecting to CRM

The following tables list the members exposed by the ErrorLogger type.

Public Constructors

Name | Description
ErrorLogger |
Top

Public Properties

Name | Description
LogfileDirectoryOverride | If Set, the directory requested here is used to set the
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
 | LaunchLogFile | Loads the log file in Notepad
public method | ToString | (inherited from Object)
 | WriteToFile | Writes a Exception to the log file.
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ErrorLogger Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


ErrorLogger Constructor
[image]

Initializes a new instance of the ErrorLogger Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ErrorLogger ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorLogger Class
ErrorLogger Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


ErrorLogger Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
 | LaunchLogFile | Loads the log file in Notepad
public method | ToString | (inherited from Object)
 | WriteToFile | Writes a Exception to the log file.

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ErrorLogger Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


ErrorLogger.LaunchLogFile Method
[image]

Loads the log file in Notepad

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub LaunchLogFile

C#
public static void LaunchLogFile ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorLogger Class
ErrorLogger Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


ErrorLogger.WriteToFile Method
[image]

Writes a Exception to the log file.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub WriteToFile ( _
    objException As Exception _
)

C#
public static void WriteToFile (
    Exception objException
)

C++

J#

JScript

Parameters
objException
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorLogger Class
ErrorLogger Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


ErrorLogger Properties
[image]

Public Properties

Name | Description
LogfileDirectoryOverride | If Set, the directory requested here is used to set the

See Also

Reference

ErrorLogger Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


ErrorLogger.LogfileDirectoryOverride Property
[image]

If Set, the directory requested here is used to set the

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Property LogfileDirectoryOverride As String

C#
public static string LogfileDirectoryOverride { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ErrorLogger Class
ErrorLogger Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


OrgNameFormater Class
See Also Members
[image]

Formats the org name for to append the Unique Name to the List View.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class OrgNameFormater
    Implements IMultiValueConverter

C#
public class OrgNameFormater : IMultiValueConverter

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Utility.OrgNameFormater
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrgNameFormater Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


OrgNameFormater Members
See Also Constructors Methods
[image]

Formats the org name for to append the Unique Name to the List View.

The following tables list the members exposed by the OrgNameFormater type.

Public Constructors

Name | Description
OrgNameFormater |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Convert | Convert an In value to a string
public method | ConvertBack | Not used.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrgNameFormater Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


OrgNameFormater Constructor
[image]

Initializes a new instance of the OrgNameFormater Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public OrgNameFormater ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrgNameFormater Class
OrgNameFormater Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


OrgNameFormater Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Convert | Convert an In value to a string
public method | ConvertBack | Not used.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrgNameFormater Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


OrgNameFormater.Convert Method
[image]

Convert an In value to a string

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

C#
public Object Convert (
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)

C++

J#

JScript

Parameters
values
targetType
parameter
culture
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrgNameFormater Class
OrgNameFormater Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


OrgNameFormater.ConvertBack Method
[image]

Not used.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

C#
public Object[] ConvertBack (
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)

C++

J#

JScript

Parameters
value
targetTypes
parameter
culture
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrgNameFormater Class
OrgNameFormater Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


SavedCredentials Class
See Also Members
[image]

Represents a credential stored in credential manager

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public NotInheritable Class SavedCredentials

C#
public sealed class SavedCredentials

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Utility.SavedCredentials
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SavedCredentials Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


SavedCredentials Members
See Also Constructors Methods Properties
[image]

Represents a credential stored in credential manager

The following tables list the members exposed by the SavedCredentials type.

Public Constructors

Name | Description
SavedCredentials | Overloaded.
Top

Public Properties

 | Name | Description
public property | Password | Password
public property | UserName | Username
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

SavedCredentials Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


SavedCredentials Constructor
[image]

Overload List

Name | Description
SavedCredentials () | Instantiates an instance of the SavedCredentials class
SavedCredentials (String, SecureString) | Instantiates an instance of the SavedCredentials class

See Also

Reference

SavedCredentials Class
SavedCredentials Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


SavedCredentials Constructor ()
[image]

Instantiates an instance of the SavedCredentials class

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public SavedCredentials ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SavedCredentials Class
SavedCredentials Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


SavedCredentials Constructor (String, SecureString)
[image]

Instantiates an instance of the SavedCredentials class

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    userName As String, _
    password As SecureString _
)

C#
public SavedCredentials (
    string userName,
    SecureString password
)

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SavedCredentials Class
SavedCredentials Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


SavedCredentials Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

SavedCredentials Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


SavedCredentials Properties
[image]

Public Properties

 | Name | Description
public property | Password | Password
public property | UserName | Username

See Also

Reference

SavedCredentials Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


SavedCredentials.Password Property
[image]

Password

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property Password As SecureString

C#
public SecureString Password { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SavedCredentials Class
SavedCredentials Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


SavedCredentials.UserName Property
[image]

Username

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property UserName As String

C#
public string UserName { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
SavedCredentials Class
SavedCredentials Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


StorageUtils Class
See Also Members
[image]

Provides utility services for accessing, loading and describing configuration entries used by the CrmConnect classes.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class StorageUtils

C#
public class StorageUtils

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Utility.StorageUtils
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
StorageUtils Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


StorageUtils Members
See Also Constructors Methods
[image]

Provides utility services for accessing, loading and describing configuration entries used by the CrmConnect classes.

The following tables list the members exposed by the StorageUtils type.

Public Constructors

Name | Description
StorageUtils |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
 | GetConfigKey | Gets a key from the Server config Keys
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
 | ReadHomeRealmConfigFile | Reads the HomeRealmsStore.xml file and loads the results into an HomeRealmOptions class.
 | SetConfigKey | Set a key in the server config keys list.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

StorageUtils Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


StorageUtils Constructor
[image]

Initializes a new instance of the StorageUtils Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public StorageUtils ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
StorageUtils Class
StorageUtils Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


StorageUtils Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
 | GetConfigKey | Gets a key from the Server config Keys
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
 | ReadHomeRealmConfigFile | Reads the HomeRealmsStore.xml file and loads the results into an HomeRealmOptions class.
 | SetConfigKey | Set a key in the server config keys list.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

StorageUtils Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


StorageUtils.GetConfigKey Method
[image]

Gets a key from the Server config Keys

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function GetConfigKey(Of T) ( _
    ServerConfigKeys As Dictionary(Of Dynamics_ConfigFileServerKeys, Object), _
    key As Dynamics_ConfigFileServerKeys _
) As T

C#
public static T GetConfigKey<T> (
    Dictionary<Dynamics_ConfigFileServerKeys,Object> ServerConfigKeys,
    Dynamics_ConfigFileServerKeys key
)

C++

J#

JScript

Parameters
ServerConfigKeys
key
Key to get
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
StorageUtils Class
StorageUtils Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


StorageUtils.ReadHomeRealmConfigFile Method
[image]

Reads the HomeRealmsStore.xml file and loads the results into an HomeRealmOptions class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function ReadHomeRealmConfigFile As ClaimsHomeRealmOptions

C#
public static ClaimsHomeRealmOptions ReadHomeRealmConfigFile ()

C++

J#

JScript

  Remarks
Populated HomeRealmOptionsObject or Null

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
StorageUtils Class
StorageUtils Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


StorageUtils.SetConfigKey Method
[image]

Set a key in the server config keys list.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub SetConfigKey(Of T) ( _
    ServerConfigKeys As Dictionary(Of Dynamics_ConfigFileServerKeys, Object), _
    key As Dynamics_ConfigFileServerKeys, _
    value As T _
)

C#
public static void SetConfigKey<T> (
    Dictionary<Dynamics_ConfigFileServerKeys,Object> ServerConfigKeys,
    Dynamics_ConfigFileServerKeys key,
    T value
)

C++

J#

JScript

Parameters
ServerConfigKeys
key
value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
StorageUtils Class
StorageUtils Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


TraceControlSettings Class
See Also Members
[image]

This class provides an override for the default trace settings. These settings must be set before the components in the control are used for them to be effective.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class TraceControlSettings

C#
public class TraceControlSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.CrmConnectControl.Utility.TraceControlSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


TraceControlSettings Members
See Also Constructors Methods Properties
[image]

This class provides an override for the default trace settings. These settings must be set before the components in the control are used for them to be effective.

The following tables list the members exposed by the TraceControlSettings type.

Public Constructors

Name | Description
TraceControlSettings |
Top

Public Properties

Name | Description
TraceLevel | Override Trace Level setting.
Top

Public Methods (see also Protected Methods)

 | Name | Description
 | AddTraceListener | Adds a listener to the trace listen array
 | CloseListeners | Closes any trace listeners that were configured
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TraceControlSettings Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


TraceControlSettings Constructor
[image]

Initializes a new instance of the TraceControlSettings Class.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TraceControlSettings ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


TraceControlSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
 | AddTraceListener | Adds a listener to the trace listen array
 | CloseListeners | Closes any trace listeners that were configured
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TraceControlSettings Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


TraceControlSettings.AddTraceListener Method
[image]

Adds a listener to the trace listen array

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function AddTraceListener ( _
    listenerToAdd As TraceListener _
) As Boolean

C#
public static bool AddTraceListener (
    TraceListener listenerToAdd
)

C++

J#

JScript

Parameters
listenerToAdd
Trace Listener you wish to add
Return Value
true on success, false on fail.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


TraceControlSettings.CloseListeners Method
[image]

Closes any trace listeners that were configured

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub CloseListeners

C#
public static void CloseListeners ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


TraceControlSettings Properties
[image]

Public Properties

Name | Description
TraceLevel | Override Trace Level setting.

See Also

Reference

TraceControlSettings Class
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


TraceControlSettings.TraceLevel Property
[image]

Override Trace Level setting.

Namespace: Microsoft.Xrm.Tooling.CrmConnectControl.Utility
Assembly: Microsoft.Xrm.Tooling.CrmConnectControl (in Microsoft.Xrm.Tooling.CrmConnectControl.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Property TraceLevel As SourceLevels

C#
public static SourceLevels TraceLevel { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.CrmConnectControl.Utility Namespace


Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace

Classes

Class | Description
ImportExtension | Extension for package setup import activities.
ImportProgressStatus | Class for import progress status.
MyNotifyProps | WPF Helper class.
ProdgressDataItemEventArgs | Event args class for Progress data Item.
ProgressDataItem | Class for progress panel data items.
TraceLogger | Class for Trace logger.

Interfaces

Interface | Description
IImportExtensions | Describes the interface that an Import plugin must implement.

Enumerations

Enumeration | Description
ProgressPanelItemStatus | Progress panel item status.


IImportExtensions Interface
See Also Members
[image]

Describes the interface that an Import plugin must implement.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Interface IImportExtensions

C#
public interface IImportExtensions

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions Members
See Also Events Methods Properties
[image]

Describes the interface that an Import plugin must implement.

The following tables list the members exposed by the IImportExtensions type.

Public Properties

 | Name | Description
public property | CrmSvc | Pointer to the CRM service connection.
public property | GetExtraProgramLaunchLinkText | Returns the launch link text shown on the last page of the package deployer.
public property | GetImportLongName | Returns the long name of the import.
public property | GetImportPackageDescription | Retuns the description of the import package.
public property | GetImportPackageFolderName | Returns the folder name where the import package lives.
public property | RootControlDispatcher | Parent dispatcher for displaying UI elements.
Top

Public Methods

 | Name | Description
public method | GetImportName | Gets the import name.
public method | InitializeExtension | Initialize extension functionality.
public method | PerApplicationRecordImport | Called for each application that is about to be imported.
public method | PostImport | Called as part of the post Import process.
public method | PreImport | Called during the preImport Process.
public method | RunSolutionUpgradeMigrationStep | Is called during a solution upgrade when both solutions, old and Holding, are present in the system.
Top

Public Events

 | Name | Description
public event | AddNewProgressItem | Describes an event for new progress item.
public event | UpdateProgressItem | Describes an event for update progress item.
Top

See Also

Reference

IImportExtensions Interface
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions Methods
[image]

Public Methods

 | Name | Description
public method | GetImportName | Gets the import name.
public method | InitializeExtension | Initialize extension functionality.
public method | PerApplicationRecordImport | Called for each application that is about to be imported.
public method | PostImport | Called as part of the post Import process.
public method | PreImport | Called during the preImport Process.
public method | RunSolutionUpgradeMigrationStep | Is called during a solution upgrade when both solutions, old and Holding, are present in the system.

See Also

Reference

IImportExtensions Interface
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.GetImportName Method
[image]

Gets the import name.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function GetImportName ( _
    <OptionalAttribute> Optional plural As Boolean = False _
) As String

C#
string GetImportName (
    [OptionalAttribute] bool plural
)

C++

J#

JScript

Parameters
plural
Returns the plural version of the name.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.InitializeExtension Method
[image]

Initialize extension functionality.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Sub InitializeExtension

C#
void InitializeExtension ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.PerApplicationRecordImport Method
[image]

Called for each application that is about to be imported.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function PerApplicationRecordImport ( _
    app As ApplicationRecord _
) As ApplicationRecord

C#
ApplicationRecord PerApplicationRecordImport (
    ApplicationRecord app
)

C++

J#

JScript

Parameters
app
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.PostImport Method
[image]

Called as part of the post Import process.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function PostImport As Boolean

C#
bool PostImport ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.PreImport Method
[image]

Called during the preImport Process.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Function PreImport As Boolean

C#
bool PreImport ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.RunSolutionUpgradeMigrationStep Method
[image]

Is called during a solution upgrade when both solutions, old and Holding, are present in the system.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Sub RunSolutionUpgradeMigrationStep ( _
    solutionName As String, _
    oldVersion As String, _
    newVersion As String, _
    oldSolutionId As Guid, _
    newSolutionId As Guid _
)

C#
void RunSolutionUpgradeMigrationStep (
    string solutionName,
    string oldVersion,
    string newVersion,
    Guid oldSolutionId,
    Guid newSolutionId
)

C++

J#

JScript

Parameters
solutionName
Name of the solution.
oldVersion
Old version number.
newVersion
New version number.
oldSolutionId
Old solution id.
newSolutionId
New solution id.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions Properties
[image]

Public Properties

 | Name | Description
public property | CrmSvc | Pointer to the CRM service connection.
public property | GetExtraProgramLaunchLinkText | Returns the launch link text shown on the last page of the package deployer.
public property | GetImportLongName | Returns the long name of the import.
public property | GetImportPackageDescription | Retuns the description of the import package.
public property | GetImportPackageFolderName | Returns the folder name where the import package lives.
public property | RootControlDispatcher | Parent dispatcher for displaying UI elements.

See Also

Reference

IImportExtensions Interface
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.CrmSvc Property
[image]

Pointer to the CRM service connection.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Property CrmSvc As CrmServiceClient

C#
CrmServiceClient CrmSvc { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.GetExtraProgramLaunchLinkText Property
[image]

Returns the launch link text shown on the last page of the package deployer.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property GetExtraProgramLaunchLinkText As String

C#
string GetExtraProgramLaunchLinkText { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.GetImportLongName Property
[image]

Returns the long name of the import.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property GetImportLongName As String

C#
string GetImportLongName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.GetImportPackageDescription Property
[image]

Retuns the description of the import package.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property GetImportPackageDescription As String

C#
string GetImportPackageDescription { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.GetImportPackageFolderName Property
[image]

Returns the folder name where the import package lives.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
ReadOnly Property GetImportPackageFolderName As String

C#
string GetImportPackageFolderName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.RootControlDispatcher Property
[image]

Parent dispatcher for displaying UI elements.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Property RootControlDispatcher As Dispatcher

C#
Dispatcher RootControlDispatcher { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions Events
[image]

Public Events

 | Name | Description
public event | AddNewProgressItem | Describes an event for new progress item.
public event | UpdateProgressItem | Describes an event for update progress item.

See Also

Reference

IImportExtensions Interface
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.AddNewProgressItem Event
[image]

Describes an event for new progress item.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Event AddNewProgressItem As EventHandler(Of ProdgressDataItemEventArgs)

C#
event EventHandler<ProdgressDataItemEventArgs> AddNewProgressItem

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


IImportExtensions.UpdateProgressItem Event
[image]

Describes an event for update progress item.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Event UpdateProgressItem As EventHandler(Of ProdgressDataItemEventArgs)

C#
event EventHandler<ProdgressDataItemEventArgs> UpdateProgressItem

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
IImportExtensions Interface
IImportExtensions Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension Class
See Also Members
[image]

Extension for package setup import activities.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustInherit Class ImportExtension
    Implements IImportExtensions

C#
public abstract class ImportExtension : IImportExtensions

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.ImportExtension
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension Members
See Also Events Fields Methods Properties Constructors
[image]

Extension for package setup import activities.

The following tables list the members exposed by the ImportExtension type.

Protected Constructors

Name | Description
ImportExtension |
Top

Public Fields

 | Name | Description
public field | PackageLog | Logging Interface.
Top

Public Properties

 | Name | Description
public property | CrmSvc | Returns a pointer to the CRM instance.
public property | GetExtraProgramLaunchLinkText | Returns the Title Link Text that is show on the completed page.
public property | GetImportLongName | Returns the long name of the import process.
public property | GetImportPackageDataFolderName | Returns the name of the Import package data folder.
public property | GetImportPackageDescription | Gets package description import.
public property | GetImportPackageDescriptionText | Description of the import package.
public property | GetImportPackageFolderName | Returns the folder name of the import.
public property | GetLongNameOfImport | Returns the long name of the import process.
public property | RootControlDispatcher | Parent dispatcher for displaying UI elements.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AfterPrimaryImport | Called After all Import steps are complete, allowing for final customizations or tweaking of the CRM instance.
public method | BeforeApplicationRecordImport | Called Before each application record is imported.
public method | BeforeImportStage | Called before the Main Import process begins, after solutions and data.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetImportName | Returns the Name of the import project.
public method | GetNameOfImport | Returns the Name of the Import project.
public method | GetType | (inherited from Object)
public method | InitializeCustomExtension | Called to Initialize any functions in the Custom Extension.
public method | InitializeExtension | Initialize extension functionality.
public method | PerApplicationRecordImport | Internal Use..&amp;gt; Do not call.
public method | PostImport | Internal Use..&amp;gt; Do not call.
public method | PreImport | Internal Use..&amp;gt; Do not call.
public method | RunSolutionUpgradeMigrationStep | Is called during a solution upgrade when both solutions, old and Holding, are present in the system.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CreateProgressItem | Create and add new progress item.
protected method | Finalize | (inherited from Object)
protected method | GetProcessId | Gets the Id for a Dialog by Name.
protected method | IsRoleAssoicatedWithTeam | Checks to see if the Team is already associated to the requested security role.
protected method | IsWorkflowActive | Is a Workflow Active.
protected method | MemberwiseClone | (inherited from Object)
protected method | RaiseFailEvent | Raised a failed event to the caller.
protected method | RaiseUpdateEvent | Raise a Status updated event.
Top

Public Events

 | Name | Description
public event | AddNewProgressItem | Describes an event for new progress item.
public event | UpdateProgressItem | Describes an event for update progress item.
Top

See Also

Reference

ImportExtension Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension Fields
[image]

Public Fields

 | Name | Description
public field | PackageLog | Logging Interface.

See Also

Reference

ImportExtension Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.PackageLog Field
[image]

Logging Interface.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public PackageLog As TraceLogger

C#
public TraceLogger PackageLog

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension Constructor
[image]

Initializes a new instance of the ImportExtension Class.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub New

C#
protected ImportExtension ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AfterPrimaryImport | Called After all Import steps are complete, allowing for final customizations or tweaking of the CRM instance.
public method | BeforeApplicationRecordImport | Called Before each application record is imported.
public method | BeforeImportStage | Called before the Main Import process begins, after solutions and data.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetImportName | Returns the Name of the import project.
public method | GetNameOfImport | Returns the Name of the Import project.
public method | GetType | (inherited from Object)
public method | InitializeCustomExtension | Called to Initialize any functions in the Custom Extension.
public method | InitializeExtension | Initialize extension functionality.
public method | PerApplicationRecordImport | Internal Use..&amp;gt; Do not call.
public method | PostImport | Internal Use..&amp;gt; Do not call.
public method | PreImport | Internal Use..&amp;gt; Do not call.
public method | RunSolutionUpgradeMigrationStep | Is called during a solution upgrade when both solutions, old and Holding, are present in the system.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | CreateProgressItem | Create and add new progress item.
protected method | Finalize | (inherited from Object)
protected method | GetProcessId | Gets the Id for a Dialog by Name.
protected method | IsRoleAssoicatedWithTeam | Checks to see if the Team is already associated to the requested security role.
protected method | IsWorkflowActive | Is a Workflow Active.
protected method | MemberwiseClone | (inherited from Object)
protected method | RaiseFailEvent | Raised a failed event to the caller.
protected method | RaiseUpdateEvent | Raise a Status updated event.

See Also

Reference

ImportExtension Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.AfterPrimaryImport Method
[image]

Called After all Import steps are complete, allowing for final customizations or tweaking of the CRM instance.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride Function AfterPrimaryImport As Boolean

C#
public abstract bool AfterPrimaryImport ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.BeforeApplicationRecordImport Method
[image]

Called Before each application record is imported.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride Function BeforeApplicationRecordImport ( _
    app As ApplicationRecord _
) As ApplicationRecord

C#
public abstract ApplicationRecord BeforeApplicationRecordImport (
    ApplicationRecord app
)

C++

J#

JScript

Parameters
app
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.BeforeImportStage Method
[image]

Called before the Main Import process begins, after solutions and data.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride Function BeforeImportStage As Boolean

C#
public abstract bool BeforeImportStage ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.CreateProgressItem Method
[image]

Create and add new progress item.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub CreateProgressItem ( _
    message As String _
)

C#
protected void CreateProgressItem (
    string message
)

C++

J#

JScript

Parameters
message
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetImportName Method
[image]

Returns the Name of the import project.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetImportName ( _
    <OptionalAttribute> Optional plural As Boolean = False _
) As String

C#
public string GetImportName (
    [OptionalAttribute] bool plural
)

C++

J#

JScript

Parameters
plural
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetNameOfImport Method
[image]

Returns the Name of the Import project.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride Function GetNameOfImport ( _
    plural As Boolean _
) As String

C#
public abstract string GetNameOfImport (
    bool plural
)

C++

J#

JScript

Parameters
plural
if true, return the plural name of the import project
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetProcessId Method
[image]

Gets the Id for a Dialog by Name.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Function GetProcessId ( _
    name As String, _
    isDialog As Boolean _
) As Guid

C#
protected Guid GetProcessId (
    string name,
    bool isDialog
)

C++

J#

JScript

Parameters
name
Dialog name
isDialog
Verify is it dailog or not.
Return Value
Process id.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.InitializeCustomExtension Method
[image]

Called to Initialize any functions in the Custom Extension.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride Sub InitializeCustomExtension

C#
public abstract void InitializeCustomExtension ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.InitializeExtension Method
[image]

Initialize extension functionality.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub InitializeExtension

C#
public void InitializeExtension ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.IsRoleAssoicatedWithTeam Method
[image]

Checks to see if the Team is already associated to the requested security role.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Function IsRoleAssoicatedWithTeam ( _
    guTeamId As Guid, _
    guRoleId As Guid _
) As Boolean

C#
protected bool IsRoleAssoicatedWithTeam (
    Guid guTeamId,
    Guid guRoleId
)

C++

J#

JScript

Parameters
guTeamId
guRoleId
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.IsWorkflowActive Method
[image]

Is a Workflow Active.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Function IsWorkflowActive ( _
    wfId As Guid _
) As Boolean

C#
protected bool IsWorkflowActive (
    Guid wfId
)

C++

J#

JScript

Parameters
wfId
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.PerApplicationRecordImport Method
[image]

Internal Use..&amp;gt; Do not call.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function PerApplicationRecordImport ( _
    app As ApplicationRecord _
) As ApplicationRecord

C#
public ApplicationRecord PerApplicationRecordImport (
    ApplicationRecord app
)

C++

J#

JScript

Parameters
app
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.PostImport Method
[image]

Internal Use..&amp;gt; Do not call.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function PostImport As Boolean

C#
public bool PostImport ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.PreImport Method
[image]

Internal Use..&amp;gt; Do not call.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function PreImport As Boolean

C#
public bool PreImport ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.RaiseFailEvent Method
[image]

Raised a failed event to the caller.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub RaiseFailEvent ( _
    message As String, _
    Ex As Exception _
)

C#
protected void RaiseFailEvent (
    string message,
    Exception Ex
)

C++

J#

JScript

Parameters
message
Ex
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.RaiseUpdateEvent Method
[image]

Raise a Status updated event.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Protected Sub RaiseUpdateEvent ( _
    message As String, _
    status As ProgressPanelItemStatus _
)

C#
protected void RaiseUpdateEvent (
    string message,
    ProgressPanelItemStatus status
)

C++

J#

JScript

Parameters
message
status
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.RunSolutionUpgradeMigrationStep Method
[image]

Is called during a solution upgrade when both solutions, old and Holding, are present in the system.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overridable Sub RunSolutionUpgradeMigrationStep ( _
    solutionName As String, _
    oldVersion As String, _
    newVersion As String, _
    oldSolutionId As Guid, _
    newSolutionId As Guid _
)

C#
public virtual void RunSolutionUpgradeMigrationStep (
    string solutionName,
    string oldVersion,
    string newVersion,
    Guid oldSolutionId,
    Guid newSolutionId
)

C++

J#

JScript

Parameters
solutionName
Name of the solution.
oldVersion
Old version number.
newVersion
New version number.
oldSolutionId
Old solution id.
newSolutionId
New solution id.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension Properties
[image]

Public Properties

 | Name | Description
public property | CrmSvc | Returns a pointer to the CRM instance.
public property | GetExtraProgramLaunchLinkText | Returns the Title Link Text that is show on the completed page.
public property | GetImportLongName | Returns the long name of the import process.
public property | GetImportPackageDataFolderName | Returns the name of the Import package data folder.
public property | GetImportPackageDescription | Gets package description import.
public property | GetImportPackageDescriptionText | Description of the import package.
public property | GetImportPackageFolderName | Returns the folder name of the import.
public property | GetLongNameOfImport | Returns the long name of the import process.
public property | RootControlDispatcher | Parent dispatcher for displaying UI elements.

See Also

Reference

ImportExtension Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.CrmSvc Property
[image]

Returns a pointer to the CRM instance.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property CrmSvc As CrmServiceClient

C#
public CrmServiceClient CrmSvc { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetExtraProgramLaunchLinkText Property
[image]

Returns the Title Link Text that is show on the completed page.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Overridable ReadOnly Property GetExtraProgramLaunchLinkText As String

C#
public virtual string GetExtraProgramLaunchLinkText { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetImportLongName Property
[image]

Returns the long name of the import process.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property GetImportLongName As String

C#
public string GetImportLongName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetImportPackageDataFolderName Property
[image]

Returns the name of the Import package data folder.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride ReadOnly Property GetImportPackageDataFolderName As String

C#
public abstract string GetImportPackageDataFolderName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetImportPackageDescription Property
[image]

Gets package description import.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property GetImportPackageDescription As String

C#
public string GetImportPackageDescription { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetImportPackageDescriptionText Property
[image]

Description of the import package.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride ReadOnly Property GetImportPackageDescriptionText As String

C#
public abstract string GetImportPackageDescriptionText { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetImportPackageFolderName Property
[image]

Returns the folder name of the import.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property GetImportPackageFolderName As String

C#
public string GetImportPackageFolderName { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.GetLongNameOfImport Property
[image]

Returns the long name of the import process.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public MustOverride ReadOnly Property GetLongNameOfImport As String

C#
public abstract string GetLongNameOfImport { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.RootControlDispatcher Property
[image]

Parent dispatcher for displaying UI elements.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property RootControlDispatcher As Dispatcher

C#
public Dispatcher RootControlDispatcher { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension Events
[image]

Public Events

 | Name | Description
public event | AddNewProgressItem | Describes an event for new progress item.
public event | UpdateProgressItem | Describes an event for update progress item.

See Also

Reference

ImportExtension Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.AddNewProgressItem Event
[image]

Describes an event for new progress item.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event AddNewProgressItem As EventHandler(Of ProdgressDataItemEventArgs)

C#
public event EventHandler<ProdgressDataItemEventArgs> AddNewProgressItem

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportExtension.UpdateProgressItem Event
[image]

Describes an event for update progress item.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event UpdateProgressItem As EventHandler(Of ProdgressDataItemEventArgs)

C#
public event EventHandler<ProdgressDataItemEventArgs> UpdateProgressItem

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportExtension Class
ImportExtension Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportProgressStatus Class
See Also Members
[image]

Class for import progress status.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ImportProgressStatus
    Inherits EventArgs

C#
public class ImportProgressStatus : EventArgs

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs
    Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.ImportProgressStatus
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportProgressStatus Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportProgressStatus Members
See Also Constructors Methods Properties
[image]

Class for import progress status.

The following tables list the members exposed by the ImportProgressStatus type.

Public Constructors

Name | Description
ImportProgressStatus |
Top

Public Properties

 | Name | Description
public property | isCompleted | Gets or Sets status completed or not.
public property | StatusMessage | Gets or Sets message status.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImportProgressStatus Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportProgressStatus Constructor
[image]

Initializes a new instance of the ImportProgressStatus Class.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ImportProgressStatus ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportProgressStatus Class
ImportProgressStatus Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportProgressStatus Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImportProgressStatus Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportProgressStatus Properties
[image]

Public Properties

 | Name | Description
public property | isCompleted | Gets or Sets status completed or not.
public property | StatusMessage | Gets or Sets message status.

See Also

Reference

ImportProgressStatus Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportProgressStatus.isCompleted Property
[image]

Gets or Sets status completed or not.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property isCompleted As Boolean

C#
public bool isCompleted { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportProgressStatus Class
ImportProgressStatus Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ImportProgressStatus.StatusMessage Property
[image]

Gets or Sets message status.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property StatusMessage As String

C#
public string StatusMessage { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImportProgressStatus Class
ImportProgressStatus Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


MyNotifyProps Class
See Also Members
[image]

WPF Helper class.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class MyNotifyProps
    Implements INotifyPropertyChanged

C#
public class MyNotifyProps : INotifyPropertyChanged

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.MyNotifyProps

                Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.ProgressDataItem
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MyNotifyProps Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


MyNotifyProps Members
See Also Constructors Events Methods
[image]

WPF Helper class.

The following tables list the members exposed by the MyNotifyProps type.

Public Constructors

Name | Description
MyNotifyProps |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | SetProperty | Set property template for My Notify props.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | PropertyChanged | Default Event Hook for INotifyPropertyChanged.
Top

See Also

Reference

MyNotifyProps Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


MyNotifyProps Constructor
[image]

Initializes a new instance of the MyNotifyProps Class.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public MyNotifyProps ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MyNotifyProps Class
MyNotifyProps Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


MyNotifyProps Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | SetProperty | Set property template for My Notify props.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

MyNotifyProps Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


MyNotifyProps.SetProperty Method
[image]

Set property template for My Notify props.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub SetProperty(Of T) ( _
    ByRef field As T, _
    value As T, _
    name As String _
)

C#
public void SetProperty<T> (
    ref T field,
    T value,
    string name
)

C++

J#

JScript

GenericParameters
T
Parameters
field
ref
value
value
name
string
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MyNotifyProps Class
MyNotifyProps Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


MyNotifyProps Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged | Default Event Hook for INotifyPropertyChanged.

See Also

Reference

MyNotifyProps Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


MyNotifyProps.PropertyChanged Event
[image]

Default Event Hook for INotifyPropertyChanged.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

C#
public event PropertyChangedEventHandler PropertyChanged

C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
MyNotifyProps Class
MyNotifyProps Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProdgressDataItemEventArgs Class
See Also Members
[image]

Event args class for Progress data Item.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ProdgressDataItemEventArgs
    Inherits EventArgs

C#
public class ProdgressDataItemEventArgs : EventArgs

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs
    Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.ProdgressDataItemEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ProdgressDataItemEventArgs Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProdgressDataItemEventArgs Members
See Also Constructors Methods Properties
[image]

Event args class for Progress data Item.

The following tables list the members exposed by the ProdgressDataItemEventArgs type.

Public Constructors

Name | Description
ProdgressDataItemEventArgs |
Top

Public Properties

 | Name | Description
public property | progressItem | Gets or Sets Item Progress.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ProdgressDataItemEventArgs Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProdgressDataItemEventArgs Constructor
[image]

Initializes a new instance of the ProdgressDataItemEventArgs Class.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProdgressDataItemEventArgs ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ProdgressDataItemEventArgs Class
ProdgressDataItemEventArgs Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProdgressDataItemEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ProdgressDataItemEventArgs Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProdgressDataItemEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | progressItem | Gets or Sets Item Progress.

See Also

Reference

ProdgressDataItemEventArgs Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProdgressDataItemEventArgs.progressItem Property
[image]

Gets or Sets Item Progress.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property progressItem As ProgressDataItem

C#
public ProgressDataItem progressItem { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ProdgressDataItemEventArgs Class
ProdgressDataItemEventArgs Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProgressDataItem Class
See Also Members
[image]

Class for progress panel data items.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ProgressDataItem
    Inherits MyNotifyProps

C#
public class ProgressDataItem : MyNotifyProps

C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.MyNotifyProps
    Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.ProgressDataItem
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ProgressDataItem Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProgressDataItem Members
See Also Constructors Events Methods Properties
[image]

Class for progress panel data items.

The following tables list the members exposed by the ProgressDataItem type.

Public Constructors

Name | Description
ProgressDataItem |
Top

Public Properties

 | Name | Description
public property | ItemStatus | Gets or Sets progress panel item status.
public property | ItemText | Gets or Sets Item Text.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | SetProperty | Set property template for My Notify props. (inherited from MyNotifyProps)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Public Events

 | Name | Description
public event | PropertyChanged | Default Event Hook for INotifyPropertyChanged. (inherited from MyNotifyProps)
Top

See Also

Reference

ProgressDataItem Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProgressDataItem Constructor
[image]

Initializes a new instance of the ProgressDataItem Class.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public ProgressDataItem ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ProgressDataItem Class
ProgressDataItem Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProgressDataItem Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | SetProperty | Set property template for My Notify props. (inherited from MyNotifyProps)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ProgressDataItem Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProgressDataItem Properties
[image]

Public Properties

 | Name | Description
public property | ItemStatus | Gets or Sets progress panel item status.
public property | ItemText | Gets or Sets Item Text.

See Also

Reference

ProgressDataItem Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProgressDataItem.ItemStatus Property
[image]

Gets or Sets progress panel item status.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ItemStatus As ProgressPanelItemStatus

C#
public ProgressPanelItemStatus ItemStatus { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ProgressDataItem Class
ProgressDataItem Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProgressDataItem.ItemText Property
[image]

Gets or Sets Item Text.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Property ItemText As String

C#
public string ItemText { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ProgressDataItem Class
ProgressDataItem Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProgressDataItem Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged | Default Event Hook for INotifyPropertyChanged.(inherited from MyNotifyProps)

See Also

Reference

ProgressDataItem Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


ProgressPanelItemStatus Enumeration
[image]

Progress panel item status.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration ProgressPanelItemStatus

C#
public enum ProgressPanelItemStatus

C++

J#

JScript

  Members
Member name | Description
Complete | Describes complete status.
Failed | Describes failed status.
Unknown | Describes unknown status.
Warning | Describes warning status.
Working | Describes working status.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger Class
See Also Members
[image]

Class for Trace logger.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class TraceLogger

C#
public class TraceLogger

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.TraceLogger
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger Members
See Also Constructors Methods Properties
[image]

Class for Trace logger.

The following tables list the members exposed by the TraceLogger type.

Public Constructors

Name | Description
TraceLogger | Constructor.
Top

Public Properties

 | Name | Description
public property | CurrentTraceLevel | Returns the trace source level for the current logger.
public property | LastError | Last Error from CRM.
public property | LastException | Last Exception from CRM .
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Log | Overloaded.
public method | ResetLastError | Last error reset.
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TraceLogger Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger Constructor
[image]

Constructor.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    traceSourceName As String _
)

C#
public TraceLogger (
    string traceSourceName
)

C++

J#

JScript

Parameters
traceSourceName
trace source name
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Log | Overloaded.
public method | ResetLastError | Last error reset.
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TraceLogger Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger.Log Method
[image]

Overload List

Name | Description
TraceLogger.Log (Exception) | Log an error with an Exception.
TraceLogger.Log (String) | Log a Message.
TraceLogger.Log (String, TraceEventType) | Log a Trace event.
TraceLogger.Log (String, TraceEventType, Exception) | Log a Trace event.

See Also

Reference

TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger.Log Method (Exception)
[image]

Log an error with an Exception.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Log ( _
    exception As Exception _
)

C#
public void Log (
    Exception exception
)

C++

J#

JScript

Parameters
exception
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger.Log Method (String)
[image]

Log a Message.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Log ( _
    message As String _
)

C#
public void Log (
    string message
)

C++

J#

JScript

Parameters
message
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger.Log Method (String, TraceEventType)
[image]

Log a Trace event.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Log ( _
    message As String, _
    eventType As TraceEventType _
)

C#
public void Log (
    string message,
    TraceEventType eventType
)

C++

J#

JScript

Parameters
message
eventType
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger.Log Method (String, TraceEventType, Exception)
[image]

Log a Trace event.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Log ( _
    message As String, _
    eventType As TraceEventType, _
    exception As Exception _
)

C#
public void Log (
    string message,
    TraceEventType eventType,
    Exception exception
)

C++

J#

JScript

Parameters
message
Error Message
eventType
Trace Event type Information
exception
Exception object
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger.ResetLastError Method
[image]

Last error reset.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub ResetLastError

C#
public void ResetLastError ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger Properties
[image]

Public Properties

 | Name | Description
public property | CurrentTraceLevel | Returns the trace source level for the current logger.
public property | LastError | Last Error from CRM.
public property | LastException | Last Exception from CRM .

See Also

Reference

TraceLogger Class
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger.CurrentTraceLevel Property
[image]

Returns the trace source level for the current logger.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property CurrentTraceLevel As SourceLevels

C#
public SourceLevels CurrentTraceLevel { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger.LastError Property
[image]

Last Error from CRM.

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LastError As String

C#
public string LastError { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


TraceLogger.LastException Property
[image]

Last Exception from CRM .

Namespace: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase
Assembly: Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase (in Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LastException As Exception

C#
public Exception LastException { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.PackageDeployment.CrmPackageExtentionBase Namespace


Microsoft.Xrm.Tooling.WebResourceUtility Namespace

Classes

Class | Description
ImageResources | Web Resource actions for dealing with Image Resources.
TraceControlSettings | This class provides an override for the default trace settings. These settings must be set before the components in the control are used for them to be effective.
TraceLogger |
XmlResources | This class is used to access and retrieve web

Enumerations

Enumeration | Description
WebResourceWebResourceType | Format of the WebResource


ImageResources Class
See Also Members
[image]

Web Resource actions for dealing with Image Resources.

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class ImageResources

C#
public class ImageResources

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.WebResourceUtility.ImageResources
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImageResources Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


ImageResources Members
See Also Constructors Methods
[image]

Web Resource actions for dealing with Image Resources.

The following tables list the members exposed by the ImageResources type.

Public Constructors

Name | Description
ImageResources | Constructs a class used to retrieve image resources from CRM..
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetImageFromCRMWebResource | Returns BitMap Image Resource from CRM
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ImageResources Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


ImageResources Constructor
[image]

Constructs a class used to retrieve image resources from CRM..

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    crmServiceConnection As CrmServiceClient _
)

C#
public ImageResources (
    CrmServiceClient crmServiceConnection
)

C++

J#

JScript

Parameters
crmServiceConnection
Initialized copy of a CrmServiceClient object
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImageResources Class
ImageResources Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


ImageResources Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetImageFromCRMWebResource | Returns BitMap Image Resource from CRM
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ImageResources Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


ImageResources.GetImageFromCRMWebResource Method
[image]

Returns BitMap Image Resource from CRM

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetImageFromCRMWebResource ( _
    webResourceName As String _
) As BitmapImage

C#
public BitmapImage GetImageFromCRMWebResource (
    string webResourceName
)

C++

J#

JScript

Parameters
webResourceName
Image Resource Name requested
Return Value
Returns Null if the Image is not found, or the resource type is not an Image.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
ImageResources Class
ImageResources Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceControlSettings Class
See Also Members
[image]

This class provides an override for the default trace settings. These settings must be set before the components in the control are used for them to be effective.

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class TraceControlSettings

C#
public class TraceControlSettings

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.WebResourceUtility.TraceControlSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceControlSettings Members
See Also Constructors Methods Properties
[image]

This class provides an override for the default trace settings. These settings must be set before the components in the control are used for them to be effective.

The following tables list the members exposed by the TraceControlSettings type.

Public Constructors

Name | Description
TraceControlSettings |
Top

Public Properties

Name | Description
TraceLevel | Override Trace Level setting.
Top

Public Methods (see also Protected Methods)

 | Name | Description
 | AddTraceListener | Adds a listener to the trace listen array
 | CloseListeners | Closes any trace listeners that were configured
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TraceControlSettings Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceControlSettings Constructor
[image]

Initializes a new instance of the TraceControlSettings Class.

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New

C#
public TraceControlSettings ()

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceControlSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
 | AddTraceListener | Adds a listener to the trace listen array
 | CloseListeners | Closes any trace listeners that were configured
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TraceControlSettings Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceControlSettings.AddTraceListener Method
[image]

Adds a listener to the trace listen array

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Function AddTraceListener ( _
    listenerToAdd As TraceListener _
) As Boolean

C#
public static bool AddTraceListener (
    TraceListener listenerToAdd
)

C++

J#

JScript

Parameters
listenerToAdd
Trace Listener you wish to add
Return Value
true on success, false on fail.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceControlSettings.CloseListeners Method
[image]

Closes any trace listeners that were configured

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Sub CloseListeners

C#
public static void CloseListeners ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceControlSettings Properties
[image]

Public Properties

Name | Description
TraceLevel | Override Trace Level setting.

See Also

Reference

TraceControlSettings Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceControlSettings.TraceLevel Property
[image]

Override Trace Level setting.

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Shared Property TraceLevel As SourceLevels

C#
public static SourceLevels TraceLevel { get; set; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceControlSettings Class
TraceControlSettings Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger Class
See Also Members
[image]

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class TraceLogger

C#
public class TraceLogger

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.WebResourceUtility.TraceLogger
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the TraceLogger type.

Public Constructors

Name | Description
TraceLogger |
Top

Public Properties

 | Name | Description
public property | LastError | Last Error from CRM
public property | LastException | Last Exception from CRM
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Log | Overloaded.
public method | ResetLastError |
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

TraceLogger Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger Constructor
[image]

Initializes a new instance of the TraceLogger Class.

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    <OptionalAttribute> Optional traceSourceName As String = "Microsoft.Xrm.Tooling.WebResourceUtility" _
)

C#
public TraceLogger (
    [OptionalAttribute] string traceSourceName
)

C++

J#

JScript

  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Log | Overloaded.
public method | ResetLastError |
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

TraceLogger Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger.Log Method
[image]

Overload List

Name | Description
TraceLogger.Log (Exception) | Log an error with an Exception
TraceLogger.Log (String) | Log a Message
TraceLogger.Log (String, TraceEventType) | Log a Trace event
TraceLogger.Log (String, TraceEventType, Exception) | Log a Trace event

See Also

Reference

TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger.Log Method (Exception)
[image]

Log an error with an Exception

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Log ( _
    exception As Exception _
)

C#
public void Log (
    Exception exception
)

C++

J#

JScript

Parameters
exception
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger.Log Method (String)
[image]

Log a Message

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Log ( _
    message As String _
)

C#
public void Log (
    string message
)

C++

J#

JScript

Parameters
message
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger.Log Method (String, TraceEventType)
[image]

Log a Trace event

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Log ( _
    message As String, _
    eventType As TraceEventType _
)

C#
public void Log (
    string message,
    TraceEventType eventType
)

C++

J#

JScript

Parameters
message
eventType
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger.Log Method (String, TraceEventType, Exception)
[image]

Log a Trace event

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub Log ( _
    message As String, _
    eventType As TraceEventType, _
    exception As Exception _
)

C#
public void Log (
    string message,
    TraceEventType eventType,
    Exception exception
)

C++

J#

JScript

Parameters
message
eventType
exception
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger.ResetLastError Method
[image]

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub ResetLastError

C#
public void ResetLastError ()

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger Properties
[image]

Public Properties

 | Name | Description
public property | LastError | Last Error from CRM
public property | LastException | Last Exception from CRM

See Also

Reference

TraceLogger Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger.LastError Property
[image]

Last Error from CRM

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LastError As String

C#
public string LastError { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


TraceLogger.LastException Property
[image]

Last Exception from CRM

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public ReadOnly Property LastException As Exception

C#
public Exception LastException { get; }

C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
TraceLogger Class
TraceLogger Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


WebResourceWebResourceType Enumeration
[image]

Format of the WebResource

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Enumeration WebResourceWebResourceType

C#
public enum WebResourceWebResourceType

C++

J#

JScript

  Members
Member name | Description
Data_XML | XML
GIFformat | GIF
ICOformat | ICO
JPGformat | JPG
PNGformat | PNG
Script_JScript | JScript
Silverlight_XAP | XAP
StyleSheet_CSS | CSS
StyleSheet_XSL | XSL
Webpage_HTML | Html type
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


XmlResources Class
See Also Members
[image]

This class is used to access and retrieve web

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Class XmlResources

C#
public class XmlResources

C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Tooling.WebResourceUtility.XmlResources
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlResources Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


XmlResources Members
See Also Constructors Methods
[image]

This class is used to access and retrieve web

The following tables list the members exposed by the XmlResources type.

Public Constructors

Name | Description
XmlResources | Constructs a class used to retrieve an XML resources from CRM..
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | GetXmlFromCRMWebResource | Returns Xml Resource from CRM
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

XmlResources Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


XmlResources Constructor
[image]

Constructs a class used to retrieve an XML resources from CRM..

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Sub New ( _
    crmServiceConnection As CrmServiceClient _
)

C#
public XmlResources (
    CrmServiceClient crmServiceConnection
)

C++

J#

JScript

Parameters
crmServiceConnection
Initialized copy of a CrmServiceClient object
  Remarks

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlResources Class
XmlResources Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


XmlResources Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | GetXmlFromCRMWebResource | Returns Xml Resource from CRM
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

XmlResources Class
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


XmlResources.GetXmlFromCRMWebResource Method
[image]

Returns Xml Resource from CRM

Namespace: Microsoft.Xrm.Tooling.WebResourceUtility
Assembly: Microsoft.Xrm.Tooling.WebResourceUtility (in Microsoft.Xrm.Tooling.WebResourceUtility.dll)

Usage

Visual Basic

  Syntax
Visual Basic
Public Function GetXmlFromCRMWebResource ( _
    webResourceName As String _
) As String

C#
public string GetXmlFromCRMWebResource (
    string webResourceName
)

C++

J#

JScript

Parameters
webResourceName
Xml Resource Name requested
Return Value
Returns Null if the Xml is not found, or Xml document as text.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
XmlResources Class
XmlResources Members
Microsoft.Xrm.Tooling.WebResourceUtility Namespace


Web Service and Assembly Reference for Microsoft Dynamics CRM

This topic is intentionally left blank.

Please go to the Web Service and Assembly Reference for Microsoft Dynamics CRM topic above in the table of contents or view this topic online at Web Service and Assembly Reference for Microsoft Dynamics CRM.

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Security role and privilege reference

This topic provides detailed information about the roles and privileges used to control access to entities and access to system functionality inMicrosoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

In This Section

Security role UI to privilege mapping

Default privileges for a role

Privileges not associated with an entity

Privileges by entity

Privileges by message

Related Sections

Customization XML reference

Schemas used in Microsoft Dynamics CRM

The security model of Microsoft Dynamics CRM

Privilege and role entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Security role UI to privilege mapping

This topic provides a mapping of the security role user interface to the privilege names. Each section in this topic corresponds to a tab in the user interface (UI). A blank cell means that there is no privilege for that combination of entity and action.

In This Topic

Core Records tab

Marketing tab

Sales tab

Service tab

Business Management tab

Service Management tab

Customization tab

Custom Entities tab

Core Records tab

The following table lists the privileges shown in the security role editor core records tab.

Entity | Privilege documentation | Create | Read | Write | Delete | Append | Append To | Assign | Share
Account | Account entity privileges | prvCreateAccount | prvReadAccount | prvWriteAccount | prvDeleteAccount | prvAppendAccount | prvAppendToAccount | prvAssignAccount | prvShareAccount
Activity | ActivityPointer (activity) entity privileges | prvCreateActivity | prvReadActivity | prvWriteActivity | prvDeleteActivity | prvAppendActivity | prvAppendToActivity | prvAssignActivity | prvShareActivity
Announcement | BusinessUnitNewsArticle (announcement) entity privileges | prvCreateNewsArticle | prvReadNewsArticle | prvWriteNewsArticle | prvDeleteNewsArticle |  | prvAppendToNewsArticle |  |
Application File | ApplicationFile entity privileges | prvCreateApplicationFile | prvReadApplicationFile | prvWriteApplicationFile | prvDeleteApplicationFile |  |  |  |
Connection | Connection entity privileges | prvCreateConnection | prvReadConnection | prvWriteConnection | prvDeleteConnection | prvAppendConnection | prvAppendToConnection | prvAssignConnection | prvShareConnection
Connection Role | ConnectionRole entity privileges | prvCreateConnectionRole | prvReadConnectionRole | prvWriteConnectionRole | prvDeleteConnectionRole | prvAppendConnectionRole | prvAppendToConnectionRole |  |
Contact | Contact entity privileges | prvCreateContact | prvReadContact | prvWriteContact | prvDeleteContact | prvAppendContact | prvAppendToContact | prvAssignContact | prvShareContact
Customer Relationship | CustomerRelationship entity privileges | prvCreateCustomerRelationship | prvReadCustomerRelationship | prvWriteCustomerRelationship | prvDeleteCustomerRelationship | prvAppendCustomerRelationship | prvAppendToCustomerRelationship | prvAssignCustomerRelationship | prvShareCustomerRelationship
Data Import | Import (data import) entity privileges | prvCreateImport | prvReadImport | prvWriteImport | prvDeleteImport | prvAppendImport | prvAppendToImport | prvAssignImport | prvShareImport
Data Map | ImportMap (data map) entity privileges | prvCreateImportMap | prvReadImportMap | prvWriteImportMap | prvDeleteImportMap | prvAppendImportMap | prvAppendToImportMap | prvAssignImportMap | prvShareImportMap
Document Location | SharePointDocumentLocation (document location) entity privileges | prvCreateSharePointDocumentLocation | prvReadSharePointDocumentLocation | prvWriteSharePointDocumentLocation | prvDeleteSharePointDocumentLocation | prvAppendSharePointDocumentLocation | prvAppendToSharePointDocumentLocation | prvAssignSharePointDocumentLocation | prvShareSharePointDocumentLocation
Duplicated Detection Rule | DuplicateRule (duplicate detection rule) entity privileges | prvCreateDuplicateRule | prvReadDuplicateRule | prvWriteDuplicateRule | prvDeleteDuplicateRule | prvAppendDuplicateRule | prvAppendToDuplicateRule | prvAssignDuplicateRule | prvShareDuplicateRule
Email Template | Template (email template) entity privileges | prvCreateEmailTemplate | prvReadEmailTemplate | prvWriteEmailTemplate | prvDeleteEmailTemplate | prvAppendEmailTemplate | prvAppendToEmailTemplate | prvAssignEmailTemplate | prvShareEmailTemplate
Follow | PostFollow (follow) entity privileges | prvCreatePostFollow | prvReadPostFollow |  | prvDeletePostFollow | prvAppendPostFollow |  |  |
Import Source File | ImportFile (import source file) entity privileges | prvCreateImportFile | prvReadImportFile | prvWriteImportFile | prvDeleteImportFile | prvAppendImportFile | prvAppendToImportFile | prvAssignImportFile | prvShareImportFile
Lead | Lead entity privileges | prvCreateLead | prvReadLead | prvWriteLead | prvDeleteLead | prvAppendLead | prvAppendToLead | prvAssignLead | prvShareLead
Mail Merge Template | MailMergeTemplate entity privileges | prvCreateMailMergeTemplate | prvReadMailMergeTemplate | prvWriteMailMergeTemplate | prvDeleteMailMergeTemplate | prvAppendMailMergeTemplate | prvAppendToMailMergeTemplate | prvAssignMailMergeTemplate | prvShareMailMergeTemplate
Note | Annotation (note) entity privileges | prvCreateNote | prvReadNote | prvWriteNote | prvDeleteNote | prvAppendNote | prvAppendToNote | prvAssignNote | prvShareNote
Opportunity | Opportunity entity privileges | prvCreateOpportunity | prvReadOpportunity | prvWriteOpportunity | prvDeleteOpportunity | prvAppendOpportunity | prvAppendToOpportunity | prvAssignOpportunity | prvShareOpportunity
Opportunity Relationship | CustomerOpportunityRole (opportunity relationship) entity privileges | prvCreateCustomerOpportunityRole | prvReadCustomerOpportunityRole | prvWriteCustomerOpportunityRole | prvDeleteCustomerOpportunityRole | prvAppendCustomerOpportunityRole | prvAppendToCustomerOpportunityRole | prvAssignCustomerOpportunityRole | prvShareCustomerOpportunityRole
Post | Post entity privileges | prvCreatePost | prvReadPost |  | prvDeleteAnyPost | prvAppendPost | prvAppendToPost |  |
Queue | Queue entity privileges | prvCreateQueue | prvReadQueue | prvWriteQueue | prvDeleteQueue | prvAppendQueue | prvAppendToQueue | prvAssignQueue | prvShareQueue
Relationship Role | RelationshipRole entity privileges | prvCreateRelationshipRole | prvReadRelationshipRole | prvWriteRelationshipRole | prvDeleteRelationshipRole | prvAppendRelationshipRole | prvAppendToRelationshipRole |  |
Report | Report entity privileges | prvCreateReport | prvReadReport | prvWriteReport | prvDeleteReport | prvAppendReport | prvAppendToReport | prvAssignReport | prvShareReport
Saved View | UserQuery (saved view) entity privileges | prvCreateUserQuery | prvReadUserQuery | prvWriteUserQuery | prvDeleteUserQuery |  |  | prvAssignUserQuery | prvShareUserQuery
SharePoint Site | SharePointSite entity privileges | prvCreateSharePointSite | prvReadSharePointSite | prvWriteSharePointSite | prvDeleteSharePointSite | prvAppendSharePointSite | prvAppendToSharePointSite | prvAssignSharePointSite | prvShareSharePointSite
Social Profile | SocialProfile entity privileges | prvCreateSocialProfile | prvReadSocialProfile | prvWriteSocialProfile | prvDeleteSocialProfile | prvAppendSocialProfile | prvAppendToSocialProfile | prvAssignSocialProfile | prvShareSocialProfile
Subject | Subject entity privileges | prvCreateSubject | prvReadSubject | prvWriteSubject | prvDeleteSubject | prvAppendSubject | prvAppendToSubject |  |
Trace | TraceLog entity privileges | prvCreateTraceLog | prvReadTraceLog |  | prvDeleteTraceLog | prvAppendTraceLog | prvAppendToTraceLog |  |
User Chart | UserQueryVisualization (user chart) entity privileges | prvCreateUserQueryVisualizations | prvReadUserQueryVisualizations | prvWriteUserQueryVisualizations | prvDeleteUserQueryVisualizations |  |  | prvAssignUserQueryVisualizations | prvShareUserQueryVisualizations
User Dashboard | UserForm (user dashboard) entity privileges | prvCreateUserForm | prvReadUserForm | prvWriteUserForm | prvDeleteUserForm |  |  | prvAssignUserForm | prvShareUserForm
User Entity UI Settings | UserEntityUISettings entity privileges | prvCreateUserEntityUISettings | prvReadUserEntityUISettings | prvWriteUserEntityUISettings | prvDeleteUserEntityUISettings |  |  | prvAssignUserEntityUISettings | prvShareUserEntityUISettings
User Entity Instance Data | UserEntityInstanceData entity privileges | prvCreateUserEntityInstanceData | prvReadUserEntityInstanceData | prvWriteUserEntityInstanceData | prvDeleteUserEntityInstanceData |  |  | prvAssignUserEntityInstanceData | prvShareUserEntityInstanceData
Web Wizard | WebWizard entity privileges | prvCreateWebWizard | prvReadWebWizard | prvWriteWebWizard | prvDeleteWebWizard |  |  |  |
Web Wizard Access Privileges | WizardAccessPrivilege (web wizard access privilege) entity privileges | prvCreateWizardAccessPrivilege | prvReadWizardAccessPrivilege | prvWriteWizardAccessPrivilege | prvDeleteWizardAccessPrivilege |  |  |  |
Wizard Page | WizardPage entity privileges | prvCreateWizardPage | prvReadWizardPage | prvWriteWizardPage | prvDeleteWizardPage |  |  |  |

Miscellaneous Privileges

The following table lists the privileges shown in the security role editor miscellaneous privileges section on the core records tab.

Miscellaneous Privileges | Privilege name | More information
Add Reporting Services Reports | prvPublishRSReport | Publish reports
Bulk Delete | prvBulkDelete | BulkDelete message privileges
Delete Audit Partitions | prvDeleteAuditPartitions | DeleteAuditData message privileges
Manage Data Encryption key - Activate | prvRestoreSqlEncryptionKey | Field-level data encryption
Manage Data Encryption key - Change | prvChangeSqlEncryptionKey | Field-level data encryption
Manage Data Encryption key - Read | prvReadSqlEncryptionKey | Field-level data encryption
Manage User Synchronization Filters | prvAdminFilter | Offline and Outlook filters and templates
Publish Duplicate Detection Rules | prvPublishDuplicateRule | PublishDuplicateRule message privileges
Publish Email Templates | prvCreateOrgEmailTemplates | MakeAvailableToOrganizationTemplate message privileges MakeUnavailableToOrganizationTemplate message privileges
Publish Mail Merge Templates to Organization | prvPublishOrgMailMergeTemplate | MailMergeTemplate entity privileges
Publish Reports | prvPublishOrgReport | MakeAvailableToOrganizationReport message privileges MakeUnavailableToOrganizationReport message privileges
View Audit History | prvReadRecordAuditHistory | RetrieveAttributeChangeHistory message privileges RetrieveRecordChangeHistory message privileges
View Audit Partitions | prvReadAuditPartitions | RetrieveAttributeChangeHistory message privileges RetrieveAuditDetails message privileges RetrieveAuditPartitionList message privileges
View Audit Summary | prvReadAuditSummary | RetrieveAttributeChangeHistory message privileges RetrieveAuditDetails message privileges

Marketing Tab

The following table lists the privileges shown in the security role editor marketing tab.

Entity | Privilege documentation | Create | Read | Write | Delete | Append | Append To | Assign | Share
Campaign | Campaign entity privileges | prvCreateCampaign | prvReadCampaign | prvWriteCampaign | prvDeleteCampaign | prvAppendCampaign | prvAppendToCampaign | prvAssignCampaign | prvShareCampaign
Marketing List | List (marketing list) entity privileges | prvCreateList | prvReadList | prvWriteList | prvDeleteList | prvAppendList | prvAppendToList | prvAssignList | prvShareList

Miscellaneous Privileges

The following table lists the privileges shown in the security role editor miscellaneous privileges section on the marketing tab.

Miscellaneous Privileges | Privilege Name | More information
Configure Internet Marketing module | prvConfigureInternetMarketing | Campaign entity privileges
Create Quick Campaign | prvAllowQuickCampaign | PropagateByExpression message privileges
Use internet marketing module | prvUseInternetMarketing | Campaign entity privileges

Sales Tab

The following table lists the privileges shown in the security role editor sales tab.

Entity | Privilege documentation | Create | Read | Write | Delete | Append | Append To | Assign | Share
Competitor | Competitor entity privileges | prvCreateCompetitor | prvReadCompetitor | prvWriteCompetitor | prvDeleteCompetitor | prvAppendCompetitor | prvAppendToCompetitor |  |
Invoice | Invoice entity privileges | prvCreateInvoice | prvReadInvoice | prvWriteInvoice | prvDeleteInvoice | prvAppendInvoice | prvAppendToInvoice | prvAssignInvoice | prvShareInvoice
Order | SalesOrder (order) entity privileges | prvCreateOrder | prvReadOrder | prvWriteOrder | prvDeleteOrder | prvAppendOrder | prvAppendToOrder | prvAssignOrder | prvShareOrder
Product | Product entity privileges | prvCreateProduct | prvReadProduct | prvWriteProduct | prvDeleteProduct | prvAppendProduct | prvAppendToProduct |  |
Property | For internal use only. | prvCreateDynamicProperty | prvReadDynamicProperty | prvWriteDynamicProperty | prvDeleteDynamicProperty | prvAppendDynamicProperty | prvAppendToDynamicProperty |  |
Property Association | For internal use only. | prvCreateDynamicPropertyAssociation | prvReadDynamicPropertyAssociation | prvWriteDynamicPropertyAssociation | prvDeleteDynamicPropertyAssociation | prvAppendDynamicPropertyAssociation | prvAppendToDynamicPropertyAssociation |  |
Property Instance | DynamicPropertyInstance entity privileges | prvCreateDynamicPropertyInstance | prvReadDynamicPropertyInstance | prvWriteDynamicPropertyInstance | prvDeleteDynamicPropertyInstance | prvAppendDynamicPropertyInstance | prvAppendToDynamicPropertyInstance | prvAssignDynamicPropertyInstance | prvShareDynamicPropertyInstance
Property OptionSetItem | For internal use only. | prvCreateDynamicPropertyOptionSetItem | prvReadDynamicPropertyOptionSetItem | prvWriteDynamicPropertyOptionSetItem | prvDeleteDynamicPropertyOptionSetItem | prvAppendDynamicPropertyOptionSetItem | prvAppendToDynamicPropertyOptionSetItem |  |
Quote | Quote entity privileges | prvCreateQuote | prvReadQuote | prvWriteQuote | prvDeleteQuote | prvAppendQuote | prvAppendToQuote | prvAssignQuote | prvShareQuote
Sales Literature | SalesLiterature entity privileges | prvCreateSalesLiterature | prvReadSalesLiterature | prvWriteSalesLiterature | prvDeleteSalesLiterature | prvAppendSalesLiterature | prvAppendToSalesLiterature |  |
Territory | Territory entity privileges | prvCreateTerritory | prvReadTerritory | prvWriteTerritory | prvDeleteTerritory | prvAppendTerritory | prvAppendToTerritory |  |

Miscellaneous Privileges

The following table lists the privileges shown in the security role editor miscellaneous privileges section on the sales tab.

Miscellaneous Privileges | Privilege Name | More information
Override Invoice Pricing | prvOverridePriceEngineInvoice | Invoice entity privileges
Override Opportunity Pricing | prvOverridePriceEngineOpportunity | Opportunity entity privileges
Override Order Pricing | prvOverridePriceEngineOrder | SalesOrder (order) entity privileges
Override Quote Order Invoice Delete | prvQOIOverrideDelete | Privileges not associated with an entity
Override Quote Pricing | prvOverridePriceEngineQuote | Quote entity privileges

Service Tab

The following table lists the privileges shown in the security role editor service tab.

Entity | Privilege documentation | Create | Read | Write | Delete | Append | Append To | Assign | Share
Article | KbArticle (article) entity privileges | prvCreateArticle | prvReadArticle | prvWriteArticle | prvDeleteArticle | prvAppendArticle | prvAppendToArticle |  |
Article Template | KbArticleTemplate (article template) entity privileges | prvCreateArticleTemplate | prvReadArticleTemplate | prvWriteArticleTemplate | prvDeleteArticleTemplate |  | prvAppendToArticleTemplate |  |
Case | Incident (Case) entity privileges | prvCreateIncident | prvReadIncident | prvWriteIncident | prvDeleteIncident | prvAppendIncident | prvAppendToIncident | prvAssignIncident | prvShareIncident
Contract | Contract entity privileges | prvCreateContract | prvReadContract | prvWriteContract | prvDeleteContract | prvAppendContract | prvAppendToContract | prvAssignContract | prvShareContract
Contract Template | ContractTemplate entity privileges | prvCreateContractTemplate | prvReadContractTemplate | prvWriteContractTemplate | prvDeleteContractTemplate |  | prvAppendToContractTemplate |  |

Miscellaneous Privileges

The following table lists the privileges shown in the security role editor miscellaneous privileges section on the service tab.

Miscellaneous Privileges | Privilege Name | More information
Publish Articles | prvPublishArticle | KbArticle (article) entity privileges

Business Management Tab

The following table lists the privileges shown in the security role editor business management tab.

Entity | Privilege documentation | Create | Read | Write | Delete | Append | Append To | Assign | Share
Business Unit | BusinessUnit entity privileges | prvCreateBusinessUnit | prvReadBusinessUnit | prvWriteBusinessUnit | prvDeleteBusinessUnit | prvAppendBusinessUnit | prvAppendToBusinessUnit |  |
Currency | TransactionCurrency (currency) entity privileges | prvCreateTransactionCurrency | prvReadTransactionCurrency | prvWriteTransactionCurrency | prvDeleteTransactionCurrency | prvAppendTransactionCurrency | prvAppendToTransactionCurrency |  |
Email Server Profile | EmailServerProfile entity privileges | prvCreateEmailServerProfile | prvReadEmailServerProfile | prvWriteEmailServerProfile | prvDeleteEmailServerProfile | prvAppendEmailServerProfile | prvAppendToEmailServerProfile | prvAssignEmailServerProfile | prvShareEmailServerProfile
Field Security Profile | FieldSecurityProfile entity privileges | prvCreateFieldSecurityProfile | prvReadFieldSecurityProfile | prvWriteFieldSecurityProfile | prvDeleteFieldSecurityProfile | prvAppendFieldSecurityProfile | prvAppendToFieldSecurityProfile |  |
Field Sharing | PrincipalObjectAttributeAccess (field sharing) entity privileges | prvCreatePrincipalObjectAttributeAccess | prvReadPrincipalObjectAttributeAccess | prvWritePrincipalObjectAttributeAccess | prvDeletePrincipalObjectAttributeAccess | prvAppendPrincipalObjectAttributeAccess | prvAppendToPrincipalObjectAttributeAccess |  |
Goal | Goal entity privileges | prvCreateGoal | prvReadGoal | prvWriteGoal | prvDeleteGoal | prvAppendGoal | prvAppendToGoal | prvAssignGoal | prvShareGoal
Goal Metric | Metric (goal metric) entity privileges | prvCreateMetric | prvReadMetric | prvWriteMetric | prvDeleteMetric | prvAppendMetric | prvAppendToMetric |  |
Mailbox | Mailbox entity privileges | prvCreateMailbox | prvReadMailbox | prvWriteMailbox | prvDeleteMailbox | prvAppendMailbox | prvAppendToMailbox | prvAssignMailbox | prvShareMailbox
Organization | Organization entity privileges |  | prvReadOrganization | prvWriteOrganization |  |  | prvAppendToOrganization |  |
Position | Position entity privileges | prvCreatePosition | prvReadPosition | prvWritePosition | prvDeletePosition | prvAppendPosition | prvAppendToPosition |  |
Principal Sync Attribute Map | PrincipalSyncAttributeMap entity privileges |  |  | prvWritePrincipalSynAttributeMap |  |  |  |  |
Rollup Query | GoalRollupQuery (rollup query) entity privileges | prvCreateGoalRollupQuery | prvReadGoalRollupQuery | prvWriteGoalRollupQuery | prvDeleteGoalRollupQuery | prvAppendGoalRollupQuery | prvAppendToGoalRollupQuery | prvAssignGoalRollupQuery | prvShareGoalRollupQuery
Security Role | Role (security role) entity privileges | prvCreateRole | prvReadRole | prvWriteRole | prvDeleteRole | prvAppendRole | prvAppendToRole | prvAssignRole |
Sync Attribute Mapping Profile | SyncAttributeMapping entity privileges |  |  | prvWritePrincipalSynAttributeMapProfile |  |  | prvAppendToPrincipalSynAttributeMapProfile |  |
Team | Team entity privileges | prvCreateTeam | prvReadTeam | prvWriteTeam | prvDeleteTeam | prvAppendTeam | prvAppendToTeam |  |
User | SystemUser (user) entity privileges | prvCreateUser | prvReadUser | prvWriteUser |  | prvAppendUser | prvAppendToUser |  |
User Settings | UserSettings entity privileges | prvCreateUserSettings | prvReadUserSettings | prvWriteUserSettings | prvDeleteUserSettings |  | prvAppendToUserSettings |  |

Privacy-related privileges

The following table lists the privileges shown in the security role editor privacy related privileges section on the business management tab.

Privacy Related Privileges | Privilege Name
CRM for phones | prvGoMobile
Export to Excel | prvExportToExcel
Go Offline in Outlook | prvGoOffline
Mail Merge | prvMailMerge
Print | prvPrint
Sync to Outlook | prvSyncToOutlook
Use CRM for tablets | prvUseTabletApp

Miscellaneous Privileges

The following table lists the privileges shown in the security role editor miscellaneous privileges section on the business management tab.

Miscellaneous Privileges | Privilege Name | More information
Act on Behalf of Another User | prvActOnBehalfOfAnotherUser | Impersonate another user
Approve Email Addresses for Users or Queues | prvApproveRejectEmailAddress | Configure email for incoming messages
Assign manager for a user | prvAssignManager | SystemUser (user) entity privileges
Assign position for a user | prvAssignPosition | Position entity privileges
Assign Territory to User | prvAssignTerritory | SystemUser (user) entity privileges
Bulk Edit | prvBulkEdit |
Change Hierarchy Security Settings | prvWriteHierarchicalSecurityConfiguration | Hierarchical security (position) entity
CRM Address Book | prvAddressBook |
Enable or Disable a Business Unit | prvDisableBusinessUnit | BusinessUnit entity privileges
Enable or Disable User | prvDisableUser | SystemUser (user) entity privileges
Language Settings | prvLanguageSettings |
Merge | prvMerge | Merge message privileges
Override Created on or Created by for Records during Data Import | prvOverrideCreatedOnCreatedBy | Run data import
Perform in sync rollups on goals | prvRollupGoal | Recalculate message privileges
Read License info | prvReadLicense | RetrieveLicenseInfo message privileges
Reparent Business Unit | prvReparentBusinessUnit | SetParentBusinessUnit message privileges
Reparent team | prvReparentTeam | Team entity privileges
Reparent user | prvReparentUser | SystemUser (user) entity privileges
Send Email as Another User | prvSendAsUser | Email entity privileges
Send Invitation | prvSendInviteForLive |
Update Business Closures | prvWriteBusinessClosureCalendar |
Web Mail Merge | prvWebMailMerge | MailMergeTemplate entity privileges

Service Management Tab

The following table lists the privileges shown in the security role editor service management tab.

Entity | Privilege documentation | Create | Read | Write | Delete | Append | Append To | Assign | Share
Calendar | Calendar entity privileges | prvCreateCalendar | prvReadCalendar | prvWriteCalendar | prvDeleteCalendar | prvAppendCalendar | prvAppendToCalendar |  |
Case Creation Rule |  | prvCreateConvertRule | prvReadConvertRule | prvWriteConvertRule | prvDeleteConvertRule | prvAppendConvertRule | prvAppendToConvertRule | prvAssignConvertRule | prvShareConvertRule
Entitlement | Entitlement entity privileges | prvCreateEntitlement | prvReadEntitlement | prvWriteEntitlement | prvDeleteEntitlement | prvAppendEntitlement | prvCreateEntitlement | prvAssignEntitlement | prvShareEntitlement
Entitlement Template | EntitlementTemplate entity privileges | prvCreateEntitlementTemplate | prvReadEntitlementTemplate | prvWriteEntitlementTemplate | prvDeleteEntitlementTemplate | prvAppendEntitlementTemplate | prvAppendToEntitlementTemplate |  |
Facility/Equipment | Equipment (facility/equipment) entity privileges | prvCreateEquipment | prvReadEquipment | prvWriteEquipment | prvDeleteEquipment | prvAppendEquipment | prvAppendToEquipment |  |
Routing Rule Set | RoutingRuleSet entity privileges | prvCreateRoutingRule | prvReadRoutingRule | prvWriteRoutingRule | prvDeleteRoutingRule | prvAppendRoutingRule | prvAppendToRoutingRule | prvAssignRoutingRule | prvShareRoutingRule
Service | Service entity privileges | prvCreateService | prvReadService | prvWriteService | prvDeleteService | prvAppendService | prvAppendToService |  |
Site | Site entity privileges | prvCreateSite | prvReadSite | prvWriteSite | prvDeleteSite |  | prvAppendToSite |  |
SLA | SLA (service level agreement) entity privileges | prvCreateSLA | prvReadSLA | prvWriteSLA | prvDeleteSLA | prvAppendSLA | prvAppendToSLA | prvAssignSLA | prvShareSLA
SLA KPI Instance | SLAKPIInstance (SLA KPI instance) entity privileges | prvCreateSLAKPAInstance | prvReadSLAKPAInstance | prvWriteSLAKPAInstance | prvDeleteSLAKPAInstance | prvAppendSLAKPAInstance | prvAppendToSLAKPAInstance | prvAssignSLAKPAInstance | prvShareSLAKPAInstance

Miscellaneous Privileges

The following table lists the privileges shown in the security role editor miscellaneous privileges section on the service management tab.

Miscellaneous Privileges | Privilege Name | More information
Browse Availability | prvBrowseAvailability | QueryMultipleSchedules message privileges QuerySchedule message privileges
Create own calendar | prvCreateOwnCalendar |
Delete own calendar | prvDeleteOwnCalendar |
Read own calendar | prvReadOwnCalendar |
Search Availability | prvSearchAvailability | Book message privileges Reschedule message privileges Search message privileges Validate message privileges
Update Holiday Schedule | prvWriteHolidayScheduleCalendar |
Write own calendar | prvWriteOwnCalendar |

Customization Tab

The following table lists the privileges shown in the security role editor customization tab.

Entity | Privilege documentation | Create | Read | Write | Delete | Append | Append To | Assign | Share
AttributeMap | AttributeMap entity privileges | prvCreateAttributeMap | prvReadAttributeMap | prvWriteAttributeMap | prvDeleteAttributeMap | prvAppendAttributeMap | prvAppendToAttributeMap |  |
Customizations |  | prvCreateCustomization | prvReadCustomization | prvWriteCustomization | prvDeleteCustomization |  |  |  |
Entity |  | prvCreateEntity | prvReadEntity | prvWriteEntity | prvDeleteEntity |  |  |  |
Entity Map | EntityMap Entity Privileges | prvCreateEntityMap | prvReadEntityMap | prvWriteEntityMap | prvDeleteEntityMap |  | prvAppendToEntityMap |  |
Field |  | prvCreateAttribute | prvReadAttribute | prvWriteAttribute | prvDeleteAttribute |  |  |  |
Hierarchy Rule |  |  |  |  |  |  |  |  |
Import Job | ImportJob entity privileges |  | prvReadImportJob | prvWriteImportJob | prvDeleteImportJob |  |  |  |
Option Set |  | prvCreateOptionSet | prvReadOptionSet | prvWriteOptionSet | prvDeleteOptionSet |  |  |  |
Plug-in Assembly | PluginAssembly entity privileges | prvCreatePluginAssembly | prvReadPluginAssembly | prvWritePluginAssembly | prvDeletePluginAssembly |  |  |  |
Plug-in Type | PluginType entity privileges | prvCreatePluginType | prvReadPluginType | prvWritePluginType | prvDeletePluginType |  |  |  |
Process | Workflow (process) entity privileges | prvCreateWorkflow | prvReadWorkflow | prvWriteWorkflow | prvDeleteWorkflow | prvAppendWorkflow | prvAppendToWorkflow | prvAssignWorkflow | prvShareWorkflow
Process Configuration | ComplexControl entity privileges | prvCreateComplexControl | prvReadComplexControl | prvWriteComplexControl |  |  |  |  |
Process Session | ProcessSession entity privileges | prvCreateWorkflowSession | prvReadWorkflowSession | prvWriteWorkflowSession | prvDeleteWorkflowSession | prvAppendWorkflowSession | prvAppendToWorkflowSession | prvAssignWorkflowSession | prvShareWorkflowSession
Publisher | Publisher entity privileges | prvCreatePublisher | prvReadPublisher | prvWritePublisher | prvDeletePublisher | prvAppendPublisher | prvAppendToPublisher |  |
Relationship |  | prvCreateRelationship | prvReadRelationship | prvWriteRelationship | prvDeleteRelationship |  |  |  |
Sdk Message | SdkMessage entity privileges | prvCreateSdkMessage | prvReadSdkMessage | prvWriteSdkMessage | prvDeleteSdkMessage |  |  |  |
Sdk Message Processing Step | SdkMessageProcessingStep entity privileges | prvCreateSdkMessageProcessingStep | prvReadSdkMessageProcessingStep | prvWriteSdkMessageProcessingStep | prvDeleteSdkMessageProcessingStep |  |  |  |
Sdk Message Processing Step Image | SdkMessageProcessingStepImage entity privileges | prvCreateSdkMessageProcessingStepImage | prvReadSdkMessageProcessingStepImage | prvWriteSdkMessageProcessingStepImage | prvDeleteSdkMessageProcessingStepImage |  |  |  |
Sdk Message Processing Step Secure Configuration | SdkMessageProcessingStepSecureConfig entity privileges | prvCreateSdkMessageProcessingStepSecureConfig | prvReadSdkMessageProcessingStepSecureConfig | prvWriteSdkMessageProcessingStepSecureConfig | prvDeleteSdkMessageProcessingStepSecureConfig |  |  |  |
Service Endpoint | Service entity privileges | prvCreateServiceEndpoint | prvReadServiceEndpoint | prvWriteServiceEndpoint | prvDeleteServiceEndpoint |  |  |  |
Solution | Solution entity privileges | prvCreateSolution | prvReadSolution | prvWriteSolution | prvDeleteSolution | prvAppendSolution | prvAppendToSolution |  |
System Application Metadata | For internal use only. Used by Microsoft Dynamics CRM for tablets. | prvCreateSystemApplicationMetadata | prvReadSystemApplicationMetadata | prvWriteSystemApplicationMetadata | prvDeleteSystemApplicationMetadata |  |  |  |
System Chart | SavedQueryVisualization (system chart) entity privileges | prvCreateSavedQueryVisualizations | prvReadSavedQueryVisualizations | prvWriteSavedQueryVisualizations | prvDeleteSavedQueryVisualizations |  |  |  |
System Form | SystemForm entity privileges | prvCreateSystemForm | prvReadSystemForm | prvWriteSystemForm | prvDeleteSystemForm |  |  |  |
System Job | AsyncOperation (system job) entity privileges | prvCreateAsyncOperation | prvReadAsyncOperation | prvWriteAsyncOperation | prvDeleteAsyncOperation | prvAppendAsyncOperation | prvAppendToAsyncOperation | prvAssignAsyncOperation | prvShareAsyncOperation
User Application Metadata | For internal use only. Used by Microsoft Dynamics CRM for tablets. | prvCreateUserApplicationMetadata | prvReadUserApplicationMetadata | prvWriteUserApplicationMetadata | prvDeleteUserApplicationMetadata |  |  |  |
View | SavedQuery (view) entity privileges | prvCreateQuery | prvReadQuery | prvWriteQuery | prvDeleteQuery |  |  |  |
Web Resource | WebResource entity privileges | prvCreateWebResource | prvReadWebResource | prvWriteWebResource | prvDeleteWebResource |  |  |  |

Miscellaneous Privileges

The following table lists the privileges shown in the security role editor miscellaneous privileges section on the customization tab.

Miscellaneous Privileges | Privilege Name | More information
Activate Business Process Flows | prvActivateBusinessProcessFlow | Model business process flows
Activate Business Rules | prvActivateBusinessRule | Model business process flows
Activate Real-time Processes | prvActivateSynchronousWorkflow | Model business process flows
Configure Yammer | prvConfigureYammer | Model business process flows
Execute Workflow Job | prvWorkflowExecution | ExecuteWorkflow message privileges
Export Customizations | prvExportCustomization | ExportSolution message privileges
Import Customizations | prvImportCustomization | ImportSolution message privileges
ISV Extensions | prvISVExtensions | Not currently in use.
Modify Customization constraints | prvAppendConstraint | Not currently in use.
Publish Customizations | prvPublishCustomization | PublishXml message privileges PublishAllXml message privileges
Retrieve Multiple Social Insights | prvRetrieveMultipleSocialInsights |

Custom Entities Tab

The following table lists the privileges shown in the security role editor custom entities tab. Note that there will be one row added for each custom entity.

Entity | Privilege documentation | Create | Read | Write | Delete | Append | Append To | Assign | Share
User Owned Entity | Actions on Entity Records | prvCreateEntityName | prvReadEntityName | prvWriteEntityName | prvDeleteEntityName | prvAppendEntityName | prvAppendToEntityName | prvAssignEntityName | prvShareEntityName
Organization Owned Entity | Actions on Entity Records | prvCreateEntityName | prvReadEntityName | prvWriteEntityName | prvDeleteEntityName | prvAppendEntityName | prvAppendToEntityName |  |
Post Configuration | msdyn_PostConfig (post configuration) entity privileges | prvCreatemsdyn_PostConfig | prvReadmsdyn_PostConfig | prvWritemsdyn_PostConfig | prvDeletemsdyn_PostConfig | prvAppendmsdyn_PostConfig | prvAppendTomsdyn_PostConfig |  |
Post Rule Configuration | msdyn_PostRuleConfig (post rule configuration) entity privileges | prvCreatemsdyn_PostRuleConfig | prvReadmsdyn_PostRuleConfig | prvWritemsdyn_PostRuleConfig | prvDeletemsdyn_PostRuleConfig | prvAppendmsdyn_PostRuleConfig | prvAppendTomsdyn_PostRuleConfig |  |
Profile Album | msdyn_PostAlbum (profile album) entity privileges | prvCreatemsdyn_PostAlbum | prvReadmsdyn_PostAlbum | prvWritemsdyn_PostAlbum | prvDeletemsdyn_PostAlbum | prvAppendmsdyn_PostAlbum | prvAppendTomsdyn_PostAlbum | prvAssignmsdyn_PostAlbum | prvSharemsdyn_PostAlbum

See Also

Reference

Default privileges for a role

Other Resources

Security role and privilege reference
The security model of Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Default privileges for a role

InMicrosoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, when you create a new role, there is a set of privileges added to that role by default. The same set of privileges is added whether you create the role by using the UI or by calling the Create method or the CreateRequest message. The following table lists the default privileges.

Privilege name

prvReadPluginAssembly

prvReadPluginType

prvReadSdkMessage

prvReadSdkMessageProcessingStep

prvReadSdkMessageProcessingStepImage

See Also

Other Resources

Security role and privilege reference
The security model of Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Privileges not associated with an entity

The following table lists the privileges that are not related to a specific entity.

Display name in Security Role UI | Privilege name | GUID | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
Act on Behalf of Another User | prvActOnBehalfOfAnotherUser | {AE5C41F0-E823-4cb9-B25A-8EF020201973} |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  |  | G |  | x | x | x | x | x | x
Activate Business Process Flows | prvActivateBusinessProcessFlow | {91F7F37A-1429-40AB-88B0-E816EDDF62C3} |  |  |  | x |  | G | G | G |  |  | G |  | G |  | G | G |  | G |  |  | x | x | x | x | x | x
Activate Business Rules | prvActivateBusinessRule | {BA9320A1-C6A6-4AD3-8565-4A206B402B14} |  |  |  | x |  |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Activate Real-time Processes | prvActivateSynchronousWorkflow | {DD55297D-5AAA-4645-8EF5-A2348EAB3460} | x | x | x | x |  | G | G | G | B | B | G | B | G | G | G | G |  | B | G |  | x | x | x | x | x | x
Add Reporting Services Reports | prvPublishRSReport | {6C835796-0A87-4790-A6BA-E72651427EC1} |  |  |  | x | NONE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Approve Email Addresses for Users and Queues | prvApproveRejectEmailAddress | {54E8C67E-9CC2-441B-802F-788F93E977D6} |  | x | x | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
Browse Availability | prvBrowseAvailability | {6A1EC3DF-8499-4D68-87E3-2DF1DD5C00EE} |  |  |  | x | READ | G | G | G |  |  |  |  | G | G | G | G | G |  |  |  |  | x | x | x | x | x
Bulk Delete | prvBulkDelete | {B75A726F-E7AA-44ae-9282-F8776D913BBB} |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
Bulk Edit | prvBulkEdit | {04BC1454-E9A4-4DB8-8499-064E9452176E} |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  |  |  |  | x | x | x | x | x | x
Configure Internet Marketing module | prvConfigureInternetMarketing | {0452A809-CEAF-4ae9-AAB5-C74D42BB5773} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  | G |  |  |  |  |  | x | x | x | x | x
Configure Yammer | prvConfigureYammer | {79C8BB80-8C98-4B4B-907E-B82CC1F1EE6E} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
Create Entity | prvCreateEntity | {341E3EBF-74B8-4335-84F3-7F617BB7D081} |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Create Field | prvCreateAttribute | {210DFCD8-6B62-423E-AA40-A5A003DEDD57} |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Create Option Set | prvCreateOptionSet | {E62439F6-3666-4c0a-A732-BDE205D8E938} |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Create own calendar | prvCreateOwnCalendar | {2D1C11DA-219E-4A6A-A8EC-C75FDB6AA6ED} |  |  |  | x | CREATE | G | G | G | G | G | G | G | G |  | G | G |  | G |  |  |  | x | x | x | x | x
Create Quick Campaign | prvAllowQuickCampaign | {5677ECB3-A34D-4ac5-99CE-9E2DBF2B3246} |  |  |  | x | CREATE | G | G | G | G |  |  | G | G |  | G | G |  |  |  |  | x | x | x | x | x | x
Create Relationship | prvCreateRelationship | {3D0EE664-5A08-419E-AE62-C473C68B089D} |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
CRM Address Book | prvAddressBook | {98626BA2-D256-40BA-9729-ADA88ACC9D10} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  | x | x | x | x | x | x
Delete Audit Partitions | prvDeleteAuditPartitions | {1AE83C2F-82D2-474d-91B2-5C77B2BB86CD} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
Delete Entity | prvDeleteEntity | {4FC61517-8B33-463E-90BB-061B3655D3AE} |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Delete Field | prvDeleteAttribute | {0B74C137-D835-422D-A170-846E43E64F80} |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Delete Option Set | prvDeleteOptionSet | {F36FF7E9-72B9-4882-AFB6-F947DE984F72} |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Delete own calendar | prvDeleteOwnCalendar | {2C6D0819-62DA-4A2D-8DD7-66DA14677252} |  |  |  | x | DELETE | G | G | G | G | G | G | G | G |  | G | G |  | G |  |  |  | x | x | x | x | x
Delete Relationship | prvDeleteRelationship | {F6091AE5-DC57-4B87-86D0-151C7EB022E3} |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Execute Workflow Job | prvWorkflowExecution | {B56C6B1D-EFB6-49C3-A18C-97A8B59E10BF} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  | x | x | x | x | x | x
Export Customizations | prvExportCustomization | {A8AACFE1-0FB0-4a29-B2D9-4D38220FEADE} |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  | G |  | G | x | x | x | x | x | x
Export to Excel | prvExportToExcel | {1EAD6FEA-946C-4D28-9374-2FA637D71BCC} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  | x | x | x | x | x | x
Go Mobile | prvGoMobile | {47026B10-D864-4F96-8E1E-43083B9621F5} |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | G |  | G | x | x | x | x | x | x
Go Offline | prvGoOffline | {38162BD3-4B5E-4434-89B3-FE9DF1F5F43A} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  | x | x | x | x | x
Import Customizations | prvImportCustomization | {42B6CF1E-9B5A-4e30-9AC9-9D928564190D} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
ISV Extensions | prvISVExtensions | {D337DD0C-26D3-45A3-9F84-3B6FC1482DE2} |  |  |  | x | READ | G | G | G |  |  | G |  | G |  | G | G |  | G |  |  | x | x | x | x | x | x
Language Settings | prvLanguageSettings | {4717A50B-A7F7-4a1f-A7FD-ED9DFE8A3F09} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  | G | x | x | x | x | x | x
Mail Merge | prvMailMerge | {9293EEB5-1EFA-48C2-AE83-56FB180539EE} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  | x | x | x | x | x | x
Manage User Synchronization Filters | prvAdminFilter | {A43380C1-F71D-4ac6-B050-5F67A706B520} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Merge | prvMerge | {1091144B-3E20-4B68-B107-EB597E963CD9} |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  |  |  |  | x | x | x | x | x | x
Not shown in UI | prvPromoteToAdmin | {1877be10-41c1-4187-aaf4-e0c12bd11a9f} |  |  |  | x | READ |  |  |  |  |  |  |  |  |  |  |  |  |  |  | G | x | x | x | x | x | x
Not shown in UI | prvTurnDevErrorsOnOff | {ace2496f-3e7b-4293-ac3f-c0fee0c9b05e} |  |  |  | x | READ |  |  |  |  |  |  |  |  |  |  |  |  |  |  | G | x | x | x | x | x | x
Override Created on or Created by for Records during Data Import 1 | prvOverrideCreatedOnCreatedBy | {D48CF22F-F8C2-4e16-89EB-49F8281DE4EA} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
Override Quote Order Invoice Delete | prvQOIOverrideDelete | {80DF41D9-C44C-44A1-A6A6-26DF453B274C} |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  |  | x | x | x | x | x
Print | prvPrint | {4DB9FAAE-7B17-4BAD-A284-68D4C3831C13} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  | x | x | x | x | x | x
Publish Customizations | prvPublishCustomization | {B5360D1D-733E-4127-A267-0559E098380D} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Publish Reports | prvPublishOrgReport | {7497D08B-CB4C-49ae-A1F0-47F21CACA6B8} |  |  |  | x | NONE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  |  | x | x | x | x | x
Read Entity | prvReadEntity | {A3311F47-2134-44EE-A258-6774018D4BC3} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
Read Field | prvReadAttribute | {B8CAEA5D-F379-4295-AA59-38ADEB73E853} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
Read License info | prvReadLicense | {B93E1FC6-E58C-4f0f-B0C8-59161EDF0455} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
Read Option Set | prvReadOptionSet | {E3F45B8E-4872-4bb5-8B84-01EE8F9C9DA1} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
Read own calendar | prvReadOwnCalendar | {499485BC-A445-423B-B5F6-1519042EBF33} |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | G |  |  |  | x | x | x | x | x
Read Relationship | prvReadRelationship | {AA38BF03-556F-418E-AE55-A3E8FBBC0F2D} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
Search Availability | prvSearchAvailability | {F1249A6E-33E2-45FE-903B-F4C50810EE58} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  |  | x | x | x | x | x
Send E-mail as Another User | prvSendAsUser | {6FD3EB4F-66E3-4587-B4AB-C064F03AD783} |  | x | x | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
Send Invitation | prvSendInviteForLive | {B5C6CE9F-6ED4-4330-BF1E-24B146573CAE} |  |  |  | x | READ | G | G | G |  |  | G |  | G |  | G | G |  |  |  |  | x | x | x | x | x | x
Sync to Outlook | prvSyncToOutlook | {DAAAB59C-0D93-492E-B25E-C9A2E19497ED} |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  |  |  |  | x | x | x | x | x | x
Update Business Closures | prvWriteBusinessClosureCalendar | {A0D4FB1E-96CB-4ED6-9FE2-675DDDDA8378} |  |  |  | x | READ | G |  |  |  |  |  |  | G | G |  |  | G |  |  |  |  | x | x | x | x | x
Update Holiday Schedule | prvWriteHolidayScheduleCalendar |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
Use Internet marketing module | prvUseInternetMarketing | {3D1DDB18-3709-4a30-93DE-51C95C28D00C} |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | G |  | G |  | x | x | x | x | x
View Audit History | prvReadRecordAuditHistory | {1CD608FD-160C-45E5-9AEE-52E8066E9EF6} |  |  |  | x | READ | G | G | G |  |  | G |  | G |  | G | G |  |  |  |  | x | x | x | x | x | x
View Audit Partitions | prvReadAuditPartitions | {06709AF3-4AEC-442c-94E3-7998BBF1835B} |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
View Audit Summary | prvReadAuditSummary | {C2CBE3DB-62C8-4661-9AC5-7691C83242F5} |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
Web Mail Merge | prvWebMailMerge | {50D9FDD3-8CC6-4774-A661-79822061BFEF} |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  | x | x | x | x | x | x
Write Entity | prvWriteEntity | {2A4E96D7-7BF9-4578-9D4E-1E494C33C1BF} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Write Field | prvWriteAttribute | {6FA055D5-E524-4EED-A48E-8AF713F83FF4} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Write Option Set | prvWriteOptionSet | {2493B394-F9D7-4604-A6CB-13E1F240450D} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
Write own calendar | prvWriteOwnCalendar | {D0A7B73E-425C-472E-9DA0-56EC580C65A9} |  |  |  | x | WRITE | G | G | G | G | G | G | G | G |  | G | G |  | G |  |  |  | x | x | x | x | x
Write Relationship | prvWriteRelationship | {92C5F167-3B51-40FE-BFDF-DBF9FD94706D} |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

1 The display name implies that you can override the createdby attribute during data import. However, this capability is not currently available.

See Also

Reference

Default privileges for a role

Concepts

Security role UI to privilege mapping

Other Resources

Security role and privilege reference
Privileges by entity
Privileges by message

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Privileges by entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online ship with a set of predefined roles that reflect common user roles with access levels defined to match the security best-practice goal of providing access to the minimum amount of business data required for the job. You can also create custom roles. Each role is associated with a set of privileges that determines the user's access to information within the company. These privileges determine what actions a user with that security role can perform on entities. For more information, see How role-based security can be used to control access to entities in Microsoft Dynamics CRM and How record-based security can be used to control access to records in Microsoft Dynamics CRM.

The following table lists the types of privileges that are referred to from the following entity/privilege reference.

Privilege | Description
Create | Create a record.
Read | View a record.
Write | Make changes to a record.
Delete | Delete a record.
Append | Associate a record to another record.
Append To | Associate entity record to this record.
Assign | Transfer record ownership to another user.
Share | Give access to a record to another user while keeping your own access.
Reparent | Assign a different parent to entity record.

These topics list the privileges available for each entity. For a list of privileges that are not entity based, see Privileges not associated with an entity.

In This Section

Account entity privileges

ActivityMimeAttachment (email attachment) entity privileges

ActivityParty entity privileges

ActivityPointer (activity) entity privileges

Annotation (note) entity privileges

AnnualFiscalCalendar entity privileges

ApplicationFile entity privileges

Appointment entity privileges

AsyncOperation (system job) entity privileges

AttributeMap entity privileges

Audit (auditing) entity privileges

BulkDeleteFailure entity privileges

BulkDeleteOperation entity privileges

BulkOperation (quick campaign) entity privileges

BulkOperationLog entity privileges

BusinessUnit entity privileges

BusinessUnitNewsArticle (announcement) entity privileges

Calendar entity privileges

Campaign entity privileges

CampaignActivity entity privileges

CampaignResponse entity privileges

ColumnMapping entity privileges

Competitor entity privileges

ComplexControl entity privileges

Connection entity privileges

ConnectionRole entity privileges

ConnectionRoleObjectTypeCode entity privileges

ConstraintBasedGroup (resource group) entity privileges

Contact entity privileges

Contract entity privileges

ContractDetail (contract line) entity privileges

ContractTemplate entity privileges

CustomerAddress (address) entity privileges

CustomerOpportunityRole (opportunity relationship) entity privileges

CustomerRelationship entity privileges

Dependency entity privileges

Discount entity privileges

DiscountType entity (discount list) privileges

DisplayString entity privileges

DuplicateRecord entity privileges

DuplicateRule (duplicate detection rule) entity privileges

DuplicateRuleCondition entity privileges

DynamicPropertyInstance entity privileges

Email entity privileges

EmailServerProfile entity privileges

Entitlement entity privileges

EntitlementTemplate entity privileges

EntityMap Entity Privileges

Equipment (facility/equipment) entity privileges

ExchangeSyncIdMapping entity privileges

Fax entity privileges

FieldPermission entity privileges

FieldSecurityProfile entity privileges

FixedMonthlyFiscalCalendar entity privileges

Goal entity privileges

GoalRollupQuery (rollup query) entity privileges

Import (data import) entity privileges

ImportFile (import source file) entity privileges

ImportJob entity privileges

ImportLog entity privileges

ImportMap (data map) entity privileges

Incident (Case) entity privileges

IncidentResolution (case resolution) entity privileges

InvalidDependency entity privileges

Invoice entity privileges

InvoiceDetail entity privileges

IsvConfig entity privileges

KbArticle (article) entity privileges

KbArticleComment (article comment) entity privileges

KbArticleTemplate (article template) entity privileges

Lead entity privileges

Letter entity privileges

License entity privileges

List (marketing list) entity privileges

LookUpMapping entity privileges

Mailbox entity privileges

MailMergeTemplate entity privileges

Metric (goal metric) entity privileges

MonthlyFiscalCalendar entity privileges

msdyn_PostAlbum (profile album) entity privileges

msdyn_PostConfig (post configuration) entity privileges

msdyn_PostRuleConfig (post rule configuration) entity privileges

Opportunity entity privileges

OpportunityClose entity privileges

OpportunityProduct entity privileges

OrderClose entity privileges

Organization entity privileges

OwnerMapping entity privileges

PhoneCall entity privileges

PickListMapping (list value mapping) entity privileges

PluginAssembly entity privileges

PluginType entity privileges

PluginTypeStatistic entity privileges

Position entity privileges

Post entity privileges

PostComment (comment) entity privileges

PostFollow (follow) entity privileges

PriceLevel (price list) entity privileges

PrincipalObjectAttributeAccess (field sharing) entity privileges

PrincipalSyncAttributeMap entity privileges

Privilege entity privileges

ProcessSession entity privileges

ProcessTrigger entity privileges

Product entity privileges

ProductPriceLevel (price list item) entity privileges

Publisher entity privileges

PublisherAddress entity privileges

QuarterlyFiscalCalendar entity privileges

Queue entity privileges

QueueItem entity privileges

Quote entity privileges

QuoteClose entity privileges

QuoteDetail (quote product) entity privileges

RecurrenceRule entity privileges

RecurringAppointmentMaster entity privileges

RelationshipRole entity privileges

RelationshipRoleMap entity privileges

Report entity privileges

ReportCategory (report related category) entity privileges

ReportEntity (report related entity) entity privileges

ReportLink entity privileges

ReportVisibility entity privileges

Resource entity privileges

ResourceGroup (scheduling group) entity privileges

ResourceSpec (resource specification) entity privileges

Role (security role) entity privileges

RollupField entity privileges

SalesLiterature entity privileges

SalesLiteratureItem (sales attachment) entity privileges

SalesOrder (order) entity privileges

SalesOrderDetail (order product) entity privileges

SavedQuery (view) entity privileges

SavedQueryVisualization (system chart) entity privileges

SdkMessage entity privileges

SdkMessageFilter entity privileges

SdkMessageProcessingStep entity privileges

SdkMessageProcessingStepSecureConfig entity privileges

SdkMessageProcessingStepImage entity privileges

SemiAnnualFiscalCalendar entity privileges

Service entity privileges

ServiceAppointment (service activity) entity privileges

ServiceEndpoint entity privileges

SharePointDocumentLocation (document location) entity privileges

SharePointSite entity privileges

Site entity privileges

SLAKPIInstance (SLA KPI instance) entity privileges

SocialProfile entity privileges

Solution entity privileges

SolutionComponent entity privileges

Subject entity privileges

SyncAttributeMapping entity privileges

SyncAttributeMappingProfile entity privileges

SystemForm entity privileges

SystemUser (user) entity privileges

SystemUserSyncMappingProfiles entity privileges

Task entity privileges

Team entity privileges

TeamSyncAttributeMappingProfiles entity privileges

TeamTemplate entity privileges

Template (email template) entity privileges

Territory entity privileges

TimeZoneDefinition entity privileges

TimeZoneLocalizedName entity privileges

TimeZoneRule entity privileges

TraceLog entity privileges

TransactionCurrency (currency) entity privileges

TransformationMapping entity privileges

TransformationParameterMapping entity privileges

UoM (unit) entity privileges

UoMSchedule (unit group) entity privileges

UserEntityInstanceData entity privileges

UserEntityUISettings entity privileges

UserForm (user dashboard) entity privileges

UserQuery (saved view) entity privileges

UserQueryVisualization (user chart) entity privileges

UserSettings entity privileges

WebResource entity privileges

WebWizard entity privileges

WizardAccessPrivilege (web wizard access privilege) entity privileges

WizardPage entity privileges

Workflow (process) entity privileges

WorkflowLog (process log) entity privileges

Related Sections

The security model of Microsoft Dynamics CRM

Security role UI to privilege mapping

Default privileges for a role

Privileges not associated with an entity

Privileges by message

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Account entity privileges

The following table lists the default privileges for each security role for the Account entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateAccount | {D26FE964-230B-42DD-AD93-5CC879DE411E} | 1;1071 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G | D | D | L | D | B |  |  |  | x | x | x | x | x
prvReadAccount | {886B280C-6396-4D56-A0A3-2C1B0A50CEB0} | 1;1071 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B |  | x | x | x | x | x
prvWriteAccount | {7863E80F-0AB2-4D67-A641-37D9F342C7E3} | 1;1071 | x | x | x | x | WRITE | G | G | G | G | G | G | G | G | G | G | G | D | B |  |  |  | x | x | x | x | x
prvDeleteAccount | {CA6C7690-C935-46B3-BFD2-ABB306C2ACC0} | 1;1071 | x | x | x | x | DELETE | G | D | L | B | B | B | B | G | D | D | L | D | B |  |  |  | x | x | x | x | x
prvShareAccount | {39B15DFD-09BA-4F30-A390-CAC64B635850} | 1;1071 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x
prvAssignAccount | {0791AB31-E811-4FDE-974B-E7C5102B09EB} | 1;1071 | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvAppendAccount | {4E163B38-EA45-49AE-B3DA-4C9DC1C77D8D} | 1;1071 | x | x | x | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x
prvAppendToAccount | {3D6E93A2-B58E-4A4A-B642-374E4A25A6BD} | 1;1071 | x | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Account entity messages and methods

Other Resources

Security role and privilege reference
Customer entities (account, contact)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ActivityMimeAttachment (email attachment) entity privileges

There are no entity specific privileges for the ActivityMimeAttachment entity.

See Also

Reference

Access Levels

Concepts

ActivityMimeAttachment (email attachment) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ActivityParty entity privileges

There are no entity specific privileges for the ActivityParty entity.

See Also

Reference

Access Levels

Concepts

ActivityParty entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ActivityPointer (activity) entity privileges

The following table lists the default privileges for each security role for all activity entities.

Privilege Name | Privilege GUID | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateActivity | {091DF793-FE5E-44D4-B4CA-7E3F580C4664} | 4200;4201;4202;4204;4206;4207;4208;4209;4210;4211;4212;4214;4401;4402;4406;4250;4251 | x | x | x | x | CREATE | G | D | L | B | B | L | B | G | G | D | L | D | B |  |  |  | x | x | x | x | x
prvReadActivity | {650C14FE-3521-45FE-A000-84138688E45D} | 4200;4201;4202;4204;4206;4207;4208;4209;4210;4211;4212;4214;4401;4402;4406;4250;4251 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B |  | x | x | x | x | x
prvWriteActivity | {0DC8F72C-57D5-4B4D-8892-FE6AAC0E4B81} | 4200;4201;4202;4204;4206;4207;4208;4209;4210;4211;4212;4214;4401;4402;4406;4250;4251 | x | x | x | x | WRITE | G | L | L | L | L | D | L | G | G | L | L | D | B |  |  |  | x | x | x | x | x
prvDeleteActivity | {BB4457F2-9B45-4482-A95A-7ADEF25F388A} | 4200;4201;4202;4204;4206;4207;4208;4209;4210;4211;4212;4214;4401;4402;4406;4250;4251 | x | x | x | x | DELETE | G | D | L | B | L | D | B | G | G | D | L | D | B |  |  |  | x | x | x | x | x
prvShareActivity | {B5F2EE06-D359-4495-BBDA-312AAE1C6B1E} | 4200;4201;4202;4204;4206;4207;4208;4209;4210;4211;4212;4214;4401;4402;4406;4250;4251 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x
prvAssignActivity | {8B99344E-EBBF-4F84-8438-E1E34D194DE9} | 4200;4201;4202;4204;4206;4207;4208;4209;4210;4211;4212;4214;4401;4402;4406;4250;4251 | x | x | x | x | ASSIGN | G | D | L | B | D | D | B | G | G | D | L | D | B |  |  |  | x | x | x | x | x
prvAppendActivity | {78777C10-09AB-4326-B4C8-CF5729702937} | 4200;4201;4202;4204;4206;4207;4208;4209;4210;4211;4212;4214;4401;4402;4406;4250;4251 | x | x | x | x | APPEND | G | D | L | L | L | D | L | G | G | D | L | D | B |  |  |  | x | x | x | x | x
prvAppendToActivity | {6EC8E901-D770-44C0-8F12-D07425F638BD} | 4200;4201;4202;4204;4206;4207;4208;4209;4210;4211;4212;4214;4401;4402;4406;4250;4251 | x | x | x | x | APPENDTO | G | D | L | L | L | D | L | G | G | D | L | G | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

ActivityPointer (activity) entity messages and methods

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Annotation (note) entity privileges

The following table lists the default privileges for each security role for the Annotation (Note) entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateNote | {DD78A732-386C-442a-BE37-C9353C34C997} | 5 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G | D | D | L | D | B |  |  |  | x | x | x | x | x
prvReadNote | {3260AD79-203D-41fd-BF2C-F853A5D93483} | 5 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B |  | x | x | x | x | x
prvWriteNote | {ED854F7D-286D-4c8b-A716-C70A0106D5A5} | 5 | x | x | x | x | WRITE | G | B | B | B | B | B | B | G | D | B | B | D | B |  |  |  | x | x | x | x | x
prvDeleteNote | {395587E4-E212-43ef-A85E-0F0FD53B35E3} | 5 | x | x | x | x | DELETE | G | D | L | B | B | D | B | G | D | D | L | D | B |  |  |  | x | x | x | x | x
prvShareNote | {5906D1C0-A3E9-4cb4-BC7D-6A122DA12092} | 5 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x
prvAssignNote | {2F29007F-7948-446b-A294-10D9F722CAB3} | 5 | x | x | x | x | ASSIGN | G | D | L | B | B | D | B | G | D | D | L | D | B |  |  |  | x | x | x | x | x
prvAppendNote | {5C270B76-3087-4f97-BBCE-678ECC588FBA} | 5 | x | x | x | x | APPEND | G | D | L | L | L | D | L | G | D | D | L | D | B |  |  |  | x | x | x | x | x
prvAppendToNote | {ECA34A9E-F50D-487e-AB69-BD06BA6EE1A1} | 5 | x | x | x | x | APPENDTO | G | D | L | L | L | D | L | G | G | D | L | G | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Annotation (note) entity messages and methods

Other Resources

Security role and privilege reference
Annotation (note) entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AnnualFiscalCalendar entity privileges

There are no entity specific privileges for the AnnualFiscalCalendar entity.

See Also

Reference

Access Levels

Concepts

AnnualFiscalCalendar entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ApplicationFile entity privileges

For internal use only.

See Also

Other Resources

Privileges by entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Appointment entity privileges

The Appointment entity uses the same privileges as all activity entities. For more information, see ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

Appointment entity messages and methods

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AsyncOperation (system job) entity privileges

The following table lists the default privileges for each security role for the AsyncOperation entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateAsyncOperation | {EBA97FF0-C3E4-47E2-A064-84ACD680092F} | 4700;32;4706 | x | x | x | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvReadAsyncOperation | {E84ACC8F-0C61-43E3-A716-20964A483BDF} | 4700;32;4706 | x | x | x | x | READ | G | D | L | B | B | L | B | G | L | D | L | B | G |  | G | x | x | x | x | x | x
prvWriteAsyncOperation | {4440769E-8D79-41FC-AE45-CD65480FFDBA} | 4700;32;4706 | x | x | x | x | WRITE | G | D | L | B | B | L | B | G | L | D | L | B | G |  |  | x | x | x | x | x | x
prvDeleteAsyncOperation | {6AD0B110-C4D5-4DBA-9A04-37528EF5DF7D} | 4700;32;4706 | x | x | x | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvShareAsyncOperation | {B367742D-E25D-4223-8691-E055BCBE3D98} | 4700;32;4706 | x | x | x | x | SHARE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvAssignAsyncOperation | {003D8A0F-C230-411C-A993-CC0A8AEAAC96} | 4700;32;4706 | x | x | x | x | ASSIGN | G | D | L | B | B | L | B | G | L | D | L | B | G |  |  | x | x | x | x | x | x
prvAppendAsyncOperation | {25523F7C-7B1D-4844-8D2D-50767D6FAA94} | 4700;32;4706 | x | x | x | x | APPEND |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvAppendToAsyncOperation | {A7C82854-36CE-4616-B7C2-84EC619D3378} | 4700;32;4706 | x | x | x | x | APPENDTO | G | D | L | B | B | L | B | G | L | D | L | B | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

AsyncOperation (system job) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AttributeMap entity privileges

The following table lists the default privileges for each security role for the AttributeMap entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateAttributeMap | {EE9C4874-14A6-4f47-B72D-F6AACC65C554} | 4601 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadAttributeMap | {0A40E638-2D3A-4d44-BE3A-64F601F76734} | 4601 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
prvWriteAttributeMap | {F96E1B75-8A54-4eac-823B-AE6F1CA465EF} | 4601 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvDeleteAttributeMap | {D0F7B7C2-8891-400d-B6EC-848603001D0C} | 4601 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvAppendAttributeMap | {78969DB5-5F70-4782-8299-F9258E4449C8} | 4601 |  |  |  | x | APPEND |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvAppendToAttributeMap | 84B19140-92BB-4341-BED1-2AC5E0B1DD38 | 4601 |  |  |  | x | APPENDTO |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

AttributeMap entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Audit (auditing) entity privileges

There are no specific privileges for the Audit entity. The following table shows privileges that are related to auditing, but not specific to the auditing entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvDeleteAuditPartitions | {1AE83C2F-82D2-474d-91B2-5C77B2BB86CD} | 0 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadAuditPartitions | {06709AF3-4AEC-442c-94E3-7998BBF1835B} | 0 |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadAuditSummary | {C2CBE3DB-62C8-4661-9AC5-7691C83242F5} | 0 |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

Audit entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkDeleteFailure entity privileges

There are no specific privileges for the BulkDeleteFailure entity. The following table lists privileges related to bulk delete operations.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvBulkDelete | {B75A726F-E7AA-44ae-9282-F8776D913BBB} | 0 |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

BulkDeleteFailure entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkDeleteOperation entity privileges

There are no specific privileges for the BulkDeleteFailure entity. The following table lists privileges related to bulk delete operations.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvBulkDelete | {B75A726F-E7AA-44ae-9282-F8776D913BBB} | 0 |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

BulkDeleteOperation entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkOperation (quick campaign) entity privileges

The BulkOperation entity uses the privileges for the ActivityPointer entity. See ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

BulkOperation (quick campaign) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkOperationLog entity privileges

There are no specific privileges for the BulkOperationLog entity.

See Also

Reference

Access Levels

Concepts

BulkOperationLog (quick campaign log) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BusinessUnit entity privileges

The following table lists the default privileges for each security role for the BusinessUnit entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateBusinessUnit | {EB20684E-925F-4EBE-A277-699C910EF635} | 10 |  |  | x | x | CREATE | G |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvReadBusinessUnit | {487CDBAF-59F9-4DB3-B648-4EED351FF00B} | 10 |  | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
prvWriteBusinessUnit | {FCEE0FAA-07DC-42AC-A1F3-E1D63CA29AE7} | 10 |  | x | x | x | WRITE | G |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvDeleteBusinessUnit | {648BE51F-6EB2-4660-A564-A5FB555406A0} | 10 |  |  | x | x | DELETE | G |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvDisableBusinessUnit | {1C29D21F-C8A6-427B-B470-26E282BC47E7} | 10 |  |  |  | x | NONE | G |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvReparentBusinessUnit | {9C8710DB-5260-4DFE-91A3-983B81F1B4D6} | 10 |  |  |  | x | NONE | G |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvAppendBusinessUnit | {CF716BA0-04E5-4438-AE87-0B8729CC5219} | 10 |  | x | x | x | APPEND | G |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvAppendToBusinessUnit | {F0A87077-39FB-4317-93A2-6696641C57C4} | 10 |  | x | x | x | APPENDTO | G | L |  |  |  | L |  | G | L | L |  |  |  |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

BusinessUnit entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BusinessUnitNewsArticle (announcement) entity privileges

The following table lists the default privileges for each security role for the BusinessUnitNewsArticle entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateNewsArticle | {3B9A9A49-F645-4c95-BAD9-BD179057C278} | 132 |  |  |  | x | CREATE | G | G | G |  |  | G |  | G | G | G | G | G |  |  |  | x | x | x | x | x | x
prvReadNewsArticle | {6CBB06B6-2651-4fe5-AFAD-36E1967E70EF} | 132 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G |  |  | G | x | x | x | x | x | x
prvWriteNewsArticle | {738A3EC5-3159-426a-8DAA-A7F185F7E0BE} | 132 |  |  |  | x | WRITE | G | G | G |  |  | G |  | G | G | G | G | G |  |  |  | x | x | x | x | x | x
prvDeleteNewsArticle | {501BE170-72CB-4fb0-9D82-381F3CF03079} | 132 |  |  |  | x | DELETE | G | G | G |  |  | G |  | G | G | G | G | G |  |  |  | x | x | x | x | x | x
prvAppendToNewsArticle | {BEFB58AE-8619-4774-B093-6A0C1458A584} | 132 |  |  |  | x | APPENDTO | G | G | G |  |  | G |  | G | G | G | G | G |  |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

BusinessUnitNewsArticle (announcement) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Calendar entity privileges

The following table lists the default privileges for each security role for the Calendar entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateCalendar | {D28808E3-D14D-49eb-8F67-30E3D8E322BC} | 4003 |  | x | x | x | CREATE | G | D | L |  |  | L |  | G | G | D | L | D |  |  |  |  | x | x | x | x | x
prvReadCalendar | {DD33F286-FBC2-455b-BFB2-A1D8C3E420FC} | 4003 |  | x | x | x | READ | G | D | L |  |  | L |  | G | G | D | L | D |  |  | G | x | x | x | x | x | x
prvWriteCalendar | {6C21BD41-8A34-4a01-AD17-4F706DDF6F70} | 4003 |  | x | x | x | WRITE | G | D | L |  |  | L |  | G | G | D | L | D |  |  |  | x | x | x | x | x | x
prvDeleteCalendar | {09DE2CA3-16F1-415f-A04E-45CB7E238A19} | 4003 |  | x | x | x | DELETE | G | D | L |  |  | L |  | G | G | D | L | D |  |  |  |  | x | x | x | x | x
prvAppendCalendar | {AAAD8C54-0B28-4B86-A0F3-A72E89EE9BEF} | 4003 |  | x | x | x | APPEND | G | D | L | L | L | L | L | G | G | D | L | D |  |  |  |  | x | x | x | x | x
prvAppendToCalendar | {3F2072AA-57A6-4bda-810A-5D567F4D4E12} | 4003 |  | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Calendar entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Campaign entity privileges

The following table lists the default privileges for each security role for the Campaign entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateCampaign | {A31C6B1B-D2E9-4F91-82F0-4677C13B0AD6} | 4400 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvReadCampaign | {A083D738-777B-4F53-B863-018489F30D46} | 4400 | x | x | x | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | B |  | B |  | x | x | x | x | x
prvWriteCampaign | {F775FA77-1D19-4C1D-B82B-6B32D0883F48} | 4400 | x | x | x | x | WRITE | G | D | L | L | L | L | L | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvDeleteCampaign | {6E1A5DFD-F266-401D-AFEA-CF8E2679E20B} | 4400 | x | x | x | x | DELETE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvAssignCampaign | {C86AE72B-EF85-4E91-9BAB-6680BF1CE91D} | 4400 | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvShareCampaign | {E828DADE-817E-4FA8-81B2-AFF9F491C89F} | 4400 | x | x | x | x | SHARE | G | D | D | D | D | D | D | G |  | D | D |  | B |  |  |  | x | x | x | x | x
prvAppendCampaign | {424922CF-2AF8-4207-80F1-36E32D5161F9} | 4400 | x | x | x | x | APPEND | G | D | L | L | L | L | L | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvAppendToCampaign | {1D75AED6-94CD-4E3B-B9AE-2A62F2C37190} | 4400 | x | x | x | x | APPENDTO | G | D | L | L | L | L | L | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvConfigureInternetMarketing | {0452A809-CEAF-4ae9-AAB5-C74D42BB5773} | 4400 | x | x | x | x | NONE | G | D | L | L | L | L | L | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvUseInternetMarketing | {3D1DDB18-3709-4a30-93DE-51C95C28D00C} | 4400 | x | x | x | x | NONE | G | G | G | G | G | G | G | G |  | G | G |  | B |  | B |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Campaign entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CampaignActivity entity privileges

The CampaignActivity entity uses the privileges for the ActivityPointer entity. See ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

CampaignActivity entity messages and methods

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CampaignResponse entity privileges

The CampaignResponse entity uses the privileges for the ActivityPointer entity. See ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

CampaignResponse entity messages and methods

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ColumnMapping entity privileges

There are no specific privileges for the ColumnMapping entity.

See Also

Reference

Access Levels

Concepts

ColumnMapping entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Competitor entity privileges

The following table lists the default privileges for each security role for the Competitor entity.

Privilege name | Privilege GUID | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateCompetitor | {8CB63518-5632-4448-9DA5-453C0E096170} | 123 |  |  |  | x | CREATE | G | G | G | G |  |  |  | G |  | G | G |  |  |  |  |  | x | x | x | x | x
prvReadCompetitor | {36ABB6E0-E112-4e60-A5DB-D550F9672176} | 123 |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | G |  | G |  | x | x | x | x | x
prvWriteCompetitor | {9797DCF9-F100-4598-B67A-72A061702626} | 123 |  |  |  | x | WRITE | G | G | G |  |  |  |  | G |  | G | G |  | G |  |  |  | x | x | x | x | x
prvDeleteCompetitor | {7C6F6D68-70FA-480e-8D17-8D6C3140D191} | 123 |  |  |  | x | DELETE | G | G | G |  |  |  |  | G |  | G | G |  |  |  |  |  | x | x | x | x | x
prvAppendToCompetitor | {5B0A8DAB-0659-4ce1-8442-3E5D078242FD} | 123 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G |  | G | G |  | G |  | G |  | x | x | x | x | x
prvAppendCompetitor | {055485B1-EDAC-4e48-A646-CB831562C9FD} | 123 |  |  |  | x | APPEND | G | G | G | G |  |  |  | G |  | G | G |  |  |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Competitor entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ComplexControl entity privileges

The following table lists the default privileges for each security role for the ComplexControl entity. This entity is for internal use only. However, users need read access to this entity in order to see the updated experience for lead and opportunity forms.

Privilege name | Privilege GUID | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateComplexControl | {32399D5A-7CE9-481B-823A-3538D4F8BCC8} | 9650 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadComplexControl | {A4736385-9763-4A64-A44B-CD5933EDC631} | 9650 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
prvWriteComplexControl | {9A8E6B32-C415-47F8-AECF-C5616C6763C4} | 9650 |  |  |  | x | WRITE | G | G | G |  |  | G |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Connection entity privileges

The following table lists the default privileges for each security role for the Connection entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateConnection | {7C48A95B-D237-4852-93FB-EC420B2EC17F} | 3234 | x | x | x | x | CREATE | G | D | L | B | B | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvReadConnection | {919F6DF3-97BF-4897-82F1-9D67749EAB3A} | 3234 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | B |  | x | x | x | x | x
prvWriteConnection | {1E589EBE-AAD1-44B5-813E-BC2574F8D365} | 3234 | x | x | x | x | WRITE | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  | x | x | x | x | x
prvDeleteConnection | {3DABAAE2-A83F-42AB-B314-C92439B8B6F4} | 3234 | x | x | x | x | DELETE | G | D | L | B | B | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvShareConnection | {2D264BEF-3A39-42F0-BD9B-FC88F44FC926} | 3234 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  |  | x | x | x | x | x
prvAssignConnection | {BE208969-4EF2-4522-840F-5904F39F97AB} | 3234 | x | x | x | x | ASSIGN | G | D | L | B | B | L | B | G | L | D | L | B |  |  |  |  | x | x | x | x | x
prvAppendConnection | {2C220358-DF94-468C-B6E6-4E499F9C0186} | 3234 | x | x | x | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x
prvAppendToConnection | {06E60CDE-B77F-45F7-B4DB-F21BC40C91D1} | 3234 | x | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Connection entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConnectionRole entity privileges

The following table lists the default privileges for each security role for the ConnectionRole entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateConnectionRole | {48DC99C2-CB65-49E5-87EF-A792132F161C} | 3231 |  |  |  | x | CREATE | G | G |  |  |  |  |  | G |  | G |  |  | G |  |  | x | x | x | x | x | x
prvReadConnectionRole | {59916A03-13B2-4D03-9493-E030FB5B18DE} | 3231 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
prvWriteConnectionRole | {D8551D81-B5F5-42A0-B16A-BE927ED04AA9} | 3231 |  |  |  | x | WRITE | G | G |  |  |  |  |  | G |  | G |  |  | G |  |  | x | x | x | x | x | x
prvDeleteConnectionRole | {8892D63A-CC87-40AB-8E7C-C902937969E3} | 3231 |  |  |  | x | DELETE | G | G |  |  |  |  |  | G |  | G |  |  | G |  |  | x | x | x | x | x | x
prvAppendConnectionRole | {85B52F8F-38B1-443F-AA30-8F40B2293DF6} | 3231 |  |  |  | x | APPEND | G | G |  |  |  |  |  | G |  | G |  |  | G |  |  | x | x | x | x | x | x
prvAppendToConnectionRole | {6A97393C-2AF0-45DC-BA0A-949F2F96E94E} | 3231 |  |  |  | x | APPENDTO | G | G |  |  |  |  |  | G |  | G |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

ConnectionRole entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConnectionRoleObjectTypeCode entity privileges

There are no specific privileges for the ConnectionRoleObjectTypeCode entity.

See Also

Reference

Access Levels

Concepts

ConnectionRoleObjectTypeCode entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConstraintBasedGroup (resource group) entity privileges

The following table lists the default privileges for each security role for the ConstraintBasedGroup entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateService | {8E28F1E3-F63E-4a02-B0C8-9F130EC5B3FF} | 4001;4002;4006;4005;4007 |  |  |  | x | CREATE | G |  |  |  |  |  |  | G | G |  |  |  |  |  |  |  | x | x | x | x | x
prvReadService | {CA4A3B9F-6887-4b5d-90F4-E918ED17E175} | 4001;4002;4006;4005;4007 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G |  | x | x | x | x | x
prvWriteService | {4AB2E389-ECA5-42b9-AD4B-7893867BA1DE} | 4001;4002;4006;4005;4007 |  |  |  | x | WRITE | G |  |  |  |  |  |  | G | G |  |  |  | G |  |  |  | x | x | x | x | x
prvDeleteService | {72D802A8-97BF-4b01-B5BF-EDEEDE5AB71C} | 4001;4002;4006;4005;4007 |  |  |  | x | DELETE | G |  |  |  |  |  |  | G | G |  |  |  |  |  |  |  | x | x | x | x | x
prvAppendService | {6DF05F16-C7CD-4C24-A306-C5D43311D189} | 4001 |  |  |  | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  |  | x | x | x | x | x
prvAppendToService | {39BDC280-2F57-4387-9F7A-D1D05527A705} | 4001;4002;4006;4005;4007 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

ConstraintBasedGroup (resource group) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Contact entity privileges

The following table lists the default privileges for each security role for the Contact entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateContact | {A8BFF87F-0DF0-41D4-BABD-F093FAF1E32C} | 2 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G | D | D | L | D | B |  |  |  | x | x | x | x | x
prvReadContact | {BA09EC92-12C4-4312-BA16-5715C2CBD6DA} | 2 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B |  | x | x | x | x | x
prvWriteContact | {65C22075-4E09-4F39-BAEC-E4BC3A950686} | 2 | x | x | x | x | WRITE | G | G | G | G | G | G | G | G | G | G | G | D | B |  |  |  | x | x | x | x | x
prvDeleteContact | {2DDDED47-7488-4039-B9FF-81DEFE81FDD3} | 2 | x | x | x | x | DELETE | G | D | L | B | B | B | B | G | D | D | L | D | B |  |  |  | x | x | x | x | x
prvShareContact | {AE756940-61FF-4BD3-BFBB-F2B0D542C608} | 2 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x
prvAssignContact | {43C63782-C7C6-471C-BD9C-24F79BF8C2A1} | 2 | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvAppendContact | {2B16BA12-6AB4-4AD2-B7C0-8641D2D6DFF2} | 2 | x | x | x | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x
prvAppendToContact | {158327B5-F4C1-448E-93D1-5F135126665B} | 2 | x | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Contact entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Contract entity privileges

The following table lists the default privileges for each security role for the Contract entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateContract | {789B28F6-E8E6-4827-A7E9-30D69D8D4929} | 1010 | x | x | x | x | CREATE | G | D | L | L | L | L | L | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvReadContract | {8022A167-EA97-4c91-A41C-B77C083F7113} | 1010 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B |  | x | x | x | x | x
prvWriteContract | {7B269B20-F381-41b2-96FB-912786FC398F} | 1010 | x | x | x | x | WRITE | G | G | G | G | G | G | G | G |  | G | G |  | B |  |  |  | x | x | x | x | x
prvDeleteContract | {FE42DBBC-5804-4034-9B3E-B0A9B6C7F564} | 1010 | x | x | x | x | DELETE | G |  |  |  |  |  |  | G |  |  |  |  | B |  |  |  | x | x | x | x | x
prvShareContract | {AF754EDD-7D79-42ef-B31F-7008662F301B} | 1010 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G |  | G | G |  | B |  |  |  | x | x | x | x | x
prvAssignContract | {0DDDB95F-986B-48c2-9ED5-DE5F9A4A0344} | 1010 | x | x | x | x | ASSIGN | G | D | L | B | L | D | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvAppendContract | {36A31103-A2DD-4fea-98C9-824124E7CCDE} | 1010 | x | x | x | x | APPEND | G | D | L | L | L | D | L | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvAppendToContract | {164E417A-54A6-4180-B772-08F221E751C8} | 1010 | x | x | x | x | APPENDTO | G | D | L | L | L | D | L | G | G | D | L | G | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Contract entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ContractDetail (contract line) entity privileges

The ContractDetail entity uses the privileges for the Contract entity. See Contract entity privileges.

See Also

Reference

Access Levels

Concepts

ContractDetail (contract line) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ContractTemplate entity privileges

The following table lists the default privileges for each security role for the ContractTemplate entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateContractTemplate | {D6CD0451-BCA1-42b0-9FFD-5596A3B9A8F9} | 2011 |  |  |  | x | CREATE | G | G | G |  |  | G |  | G |  | G | G |  | G |  |  | x | x | x | x | x | x
prvReadContractTemplate | {E438BAE3-55FF-472c-8EA2-6CE5C7348141} | 2011 |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | G |  | G | x | x | x | x | x | x
prvWriteContractTemplate | {37219212-8A79-4733-8A4D-FDC79489EE93} | 2011 |  |  |  | x | WRITE | G | G | G |  |  |  |  | G |  | G | G |  | G |  |  | x | x | x | x | x | x
prvDeleteContractTemplate | {3BCD985F-1DA0-4173-9756-31F1C458E962} | 2011 |  |  |  | x | DELETE | G | G | G |  |  |  |  | G |  | G | G |  | G |  |  | x | x | x | x | x | x
prvAppendToContractTemplate | {38EDDFD6-705C-4cb1-A569-412909EAA576} | 2011 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G |  | G | G |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

ContractTemplate entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CustomerAddress (address) entity privileges

There are no specific privileges for the CustomerAddress entity.

See Also

Reference

Access Levels

Concepts

CustomerAddress (address) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CustomerOpportunityRole (opportunity relationship) entity privileges

Deprecated. The following table lists the default privileges for each security role for the CustomerOpportunityRole entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateCustomerOpportunityRole | {EEF13216-2158-4DA0-84FB-54ECB2B40B7B} | 4503 | x | x | x | x | CREATE | G | D | L | B | B | L | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvReadCustomerOpportunityRole | {DB84E2EA-44FE-44FF-B01C-BD1B3D3D07AE} | 4503 | x | x | x | x | READ | G | G | G | G | G | G | G | G | B | G | G | B | B |  | B | x | x | x | x | x | x
prvWriteCustomerOpportunityRole | {2CEE7919-EDE9-410B-B75F-CE166849D752} | 4503 | x | x | x | x | WRITE | G | D | L | B | B | L | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvDeleteCustomerOpportunityRole | {9AA38629-D3EC-42EB-BEF9-DA2FC7CCEDA7} | 4503 | x | x | x | x | DELETE | G | D | L | B | B | L | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvShareCustomerOpportunityRole | {959BD4B6-0AB9-43E3-8829-1B8605729BEF} | 4503 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G |  | G | G |  |  |  |  |  | x | x | x | x | x
prvAssignCustomerOpportunityRole | {803BE1E5-48CB-44F6-AC25-E64C7F1E9E36} | 4503 | x | x | x | x | ASSIGN | G | D | L | B | B | L | B | G |  | D | L |  |  |  |  |  | x | x | x | x | x
prvAppendCustomerOpportunityRole | {071ED935-F58C-46CE-8CA8-292E8DEC16AB} | 4503 | x | x | x | x | APPEND | G | G | G | G | G | G | G | G |  | G | G |  | B |  |  |  | x | x | x | x | x
prvAppendToCustomerOpportunityRole | {368AFF3B-95B1-45C1-BF73-01A7BECDEDC5} | 4503 | x | x | x | x | APPENDTO | G | G | G | G | G | G | G | G |  | G | G |  |  |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CustomerRelationship entity privileges

Deprecated. The following table lists the default privileges for each security role for the CustomerRelationship entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateCustomerRelationship | {19851D34-4E73-4843-BC05-7E52FC490071} | 4502 | x | x | x | x | CREATE | G | D | L | B | B | L | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvReadCustomerRelationship | {E75B7037-291C-4AB4-848A-05A78A557FAE} | 4502 | x | x | x | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | B |  | B |  | x | x | x | x | x
prvWriteCustomerRelationship | {9008F389-74FC-4B64-B4A4-A7ABDC2AC28F} | 4502 | x | x | x | x | WRITE | G | D | L | B | B | L | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvDeleteCustomerRelationship | {D1A8FF91-4529-49A9-B2D8-86051440FE39} | 4502 | x | x | x | x | DELETE | G | D | L | B | B | L | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvShareCustomerRelationship | {B4C58955-80FE-4F48-8578-CCE42D94FE0F} | 4502 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G |  | G | G |  |  |  |  |  | x | x | x | x | x
prvAssignCustomerRelationship | {465D9001-87EB-4567-B7C5-FDBDC61024C1} | 4502 | x | x | x | x | ASSIGN | G | D | L | B | B | L | B | G |  | D | L |  |  |  |  |  | x | x | x | x | x
prvAppendCustomerRelationship | {1390883C-8774-4B02-BD50-0F5454668200} | 4502 | x | x | x | x | APPEND | G | G | G | G | G | G | G | G |  | G | G |  | B |  |  |  | x | x | x | x | x
prvAppendToCustomerRelationship | {5B6C67ED-7B05-4545-9A6D-ADF07FDDE7A1} | 4502 | x | x | x | x | APPENDTO | G | G | G | G | G | G | G | G |  | G | G |  | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Dependency entity privileges

There are no specific privileges for the Dependency entity.

See Also

Reference

Access Levels

Concepts

Dependency entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Discount entity privileges

There are no privileges for the Discount entity.

See Also

Reference

Access Levels

Concepts

Discount entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DiscountType entity (discount list) privileges

There are no specific privileges for the DiscountType entity.

See Also

Reference

Access Levels

Concepts

DiscountType (discount list) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DisplayString entity privileges

There are no specific privileges for the DisplayString entity.

See Also

Reference

Access Levels

Concepts

DisplayString entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DuplicateRecord entity privileges

There are no specific privileges for the DuplicateRecord entity.

See Also

Reference

Access Levels

Concepts

DuplicateRecord entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DuplicateRule (duplicate detection rule) entity privileges

The following table lists the default privileges for each security role for the DuplicateRule entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateDuplicateRule | {aab24464-d8c3-4dc0-86c8-ca701f1e14c4} | 4414 | x | x | x | x | CREATE | G | D | L |  |  |  |  | G |  | D | L |  | G |  |  |  | x | x | x | x | x
prvReadDuplicateRule | {7d6d18a7-304d-454b-ab2f-403f03d98797} | 4414 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | B |  | x | x | x | x | x
prvWriteDuplicateRule | {0f74d23e-fb44-4eeb-beed-940b407b423c} | 4414 | x | x | x | x | WRITE | G | D | L |  |  |  |  | G |  | D | L |  | G |  |  |  | x | x | x | x | x
prvDeleteDuplicateRule | {1f7329c1-8ae0-400f-be71-99cd1d221adf} | 4414 | x | x | x | x | DELETE | G | D | L |  |  |  |  | G |  | D | L |  | G |  |  |  | x | x | x | x | x
prvShareDuplicateRule | {5a793e36-3354-4099-a3b0-7c92818684a8} | 4414 | x | x | x | x | SHARE | G | D | L |  |  |  |  | G |  | D | L |  | G |  |  |  | x | x | x | x | x
prvAssignDuplicateRule | {4275412f-0a1d-4f43-94b7-446207eda3df} | 4414 | x | x | x | x | ASSIGN | G | D | L |  |  |  |  | G |  | D | L |  | G |  |  |  | x | x | x | x | x
prvAppendDuplicateRule | {6cb28c7c-4689-475e-8c67-7e5abddf8f94} | 4414 | x | x | x | x | APPEND | G | D | L |  |  |  |  | G |  | D | L |  | G |  |  |  | x | x | x | x | x
prvAppendToDuplicateRule | {8be24e9a-157d-46bc-921f-ad3fac02d4eb} | 4414 | x | x | x | x | APPENDTO | G | D | L |  |  |  |  | G |  | D | L |  | G |  |  |  | x | x | x | x | x
prvPublishDuplicateRule | {5A9F6284-E81F-4294-9C63-D68052189B87} | 4414 | x | x | x | x | NONE | G |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

DuplicateRule entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DuplicateRuleCondition entity privileges

There are no specific privileges for the DuplicateRuleCondition entity.

See Also

Reference

Access Levels

Concepts

DuplicateRuleCondition entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DynamicPropertyInstance entity privileges

The following table lists the default privileges for each security role for the DynamicPropertyInstance (property instance) entity.

Privilege Name | GUID | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateDynamicPropertyInstance | {341d195d-6dd9-47db-96de-fa23989e0fcf} | x | x | x | x | CREATE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvReadDynamicPropertyInstance | {fc9c9e61-95e3-4cb3-9b46-4d810156f9e4} | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B |  | x | x | x | x | x
prvWriteDynamicPropertyInstance | {eb9e7c35-b242-45e7-b9dc-3705f31b6607} | x | x | x | x | WRITE | G | G | G | G | B | B | G | G |  | G | G |  | B |  |  |  | x | x | x | x | x
prvDeleteDynamicPropertyInstance | {09967ce4-42d6-4c53-86eb-029ae5cf671f} | x | x | x | x | DELETE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvShareDynamicPropertyInstance | {bffc7d85-996c-4fea-9c49-84b54ae2a584} | x | x | x | x | SHARE | G | G | G | G | G | G | G | G |  | G | G |  | B |  |  |  | x | x | x | x | x
prvAssignDynamicPropertyInstance | {3ce2f66e-20b8-404d-9a6e-a780c5761c86} | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G |  | D | L |  | B |  |  |  | x | x | x | x | x
prvAppendDynamicPropertyInstance | {2c21cd08-1ce8-4cf9-a336-94323133fe76} | x | x | x | x | APPEND | G | G | G | G | B | B | G | G |  | G | G |  | B |  |  |  | x | x | x | x | x
prvAppendToDynamicPropertyInstance | {b72e8386-30ad-4a6f-ad5b-8f23fb26ae50} | x | x | x | x | APPENDTO | G | G | G | G | B | B | G | G | G | G | G | G | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

DynamicPropertyInstance (property instance) methods and messages

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Email entity privileges

The Email entity uses the same privileges as all activity entities. For more information see ActivityPointer (activity) entity privileges.

The following table lists privileges that are specific to e-mail operations.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvApproveRejectEmailAddress | {54E8C67E-9CC2-441B-802F-788F93E977D6} | 0 |  | x | x | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x
prvSendAsUser | {6FD3EB4F-66E3-4587-B4AB-C064F03AD783} | 0 |  | x | x | x | READ |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Email entity messages and methods
Email activity entities

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


EmailServerProfile entity privileges

The following table lists the privileges for the EmailServerProfile entity.

privilegeName | prvCreateEmailServerProfile | prvReadEmailServerProfile | prvWriteEmailServerProfile | prvDeleteEmailServerProfile | prvAppendEmailServerProfile | prvAppendToEmailServerProfile | prvShareEmailServerProfile | prvAssignEmailServerProfile
GUID | {D8F211ED-D12C-40FE-895F-44B4F08AD8DE} | {EDEBE6F6-CF2E-4520-B635-AE0615D41E34} | {0F0B441F-A7E4-498E-86FE-0E94E049F975} | {ABC41907-C40E-4A1B-BF45-2F23945EE5BA} | {E68C2627-D425-46D7-A691-EF76F6A335DB} | {35566b4f-c72f-44c9-acdf-159ca7edfb96} | {35437ba1-2c10-4a96-bc18-dc287a27878b} | {aaf235cd-c070-49c0-9efb-f9758334ccbb}
Basic depth (B) |  |  |  |  |  |  |  |
Local depth (L) |  |  |  |  |  |  |  |
Deep depth (D) |  |  |  |  |  |  |  |
Global Depth (G) | x | x | x | x | x | x | x | x
Corresponding Access Right | CREATE | READ | WRITE | DELETE | APPEND | APPENDTO | SHARE | ASSIGN
CEO-Business Manager | G |  |  |  | G |  |  |
Vice President of Sales | G |  |  |  | G |  |  |
Sales Manager | G |  |  |  | G |  |  |
Salesperson | G |  |  |  | G |  |  |
Customer Service Representative | G |  |  |  | G |  |  |
CSR Manager | G |  |  |  | G |  |  |
Marketing Professional | G |  |  |  | G |  |  |
System Administrator | G | G | G | G | G | G | G | G
Schedule Manager | G |  |  |  | G |  |  |
Vice President of Marketing | G |  |  |  | G |  |  |
Marketing Manager | G |  |  |  | G |  |  |
Scheduler | G |  |  |  | G |  |  |
System Customizer | G | G | G | G | G | G | G | G
Delegate |  |  |  |  |  |  |  |
Support User | G |  |  |  |  |  |  |
Admin Only License | x | x | x | x | x | x | x | x
On-premise - Small Business | x | x | x | x | x | x | x | x
On-premise - Professional | x | x | x | x | x | x | x | x
On-premise - Enterprise | x | x | x | x | x | x | x | x
Live | x | x | x | x | x | x | x | x
Spla | x | x | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

EmailServerProfile entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Entitlement entity privileges

The following table lists the default privileges for each security role for the Entitlement entity.

PrivilegeName | Id | Type | CanBeBasic | CanBeDeep | CanBeGlobal | CanBeLocal
prvAppendEntitlement | 4236af0c-9aaf-491a-8768-4c46b465d39b | Append | True | True | True | True
prvAppendToEntitlement | 9ea7d660-0ee7-4fe7-aac4-a51664832f0f | AppendTo | True | True | True | True
prvAssignEntitlement | 4e6a93ff-0661-4712-9994-7756062778d8 | Assign | True | True | True | True
prvCreateEntitlement | 65a8822c-28b7-409c-8833-fe5f2c24c611 | Create | True | True | True | True
prvDeleteEntitlement | fb73c782-cf9e-4fe1-85c2-02d956f27c7b | Delete | True | True | True | True
prvReadEntitlement | 0925bd85-61f1-485c-b34f-240504216bd1 | Read | True | True | True | True
prvShareEntitlement | 4188c471-5513-4f60-a69b-ec41608f8969 | Share | True | True | True | True
prvWriteEntitlement | 6cd4193b-e381-4e9c-99a7-b7a85eee8ed1 | Write | True | True | True | True

See Also

Reference

Access Levels

Concepts

Entitlement entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


EntitlementTemplate entity privileges

The following table lists the default privileges for each security role for the EntitlementTemplate entity.

Privilege Name | GUID | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateEntitlementTemplate | 0510B6E3-2841-471C-8F93-EC8892D7C2A4 |  |  |  | x | CREATE |  |  |  |  |  | G |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadEntitlementTemplate | 80A84D6E-86E2-4932-99EB-152B9F3BD473 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvWriteEntitlementTemplate | E0B27BD1-B4E8-46B0-9E50-E5674CBF5B19 |  |  |  | x | WRITE |  |  |  |  |  | G |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvDeleteEntitlementTemplate | 400898C8-4A1F-4551-B3B5-5538B173939B |  |  |  | x | DELETE |  |  |  |  |  | G |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvAppendEntitlementTemplate | D61833AB-93BC-4EBB-8DBA-A5D259624473 |  |  |  | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvAppendToEntitlementTemplate | B96E9F2C-5F80-44DB-8491-58F591134795 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

EntitlementTemplate entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


EntityMap Entity Privileges

The following table lists the default privileges for the EntityMap entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateEntityMap | {03FA6BCF-30F3-4c07-88C3-5B02E5713701} | 4600 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadEntityMap | {2D331A5B-4D6C-42be-BF0A-D2C0FACD97C8} | 4600 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
prvWriteEntityMap | {F435A3D6-E4A2-4212-81D4-919DF326C95E} | 4600 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvDeleteEntityMap | {24B20DD9-F2D7-4ecf-865D-F4CBF82C1A92} | 4600 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvAppendToEntityMap | {2055B892-9068-4B43-854E-814671E53E8C} | 4600 |  |  |  | x | APPENDTO |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

EntityMap entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Equipment (facility/equipment) entity privileges

The following table lists the default privileges for the Equipment entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateEquipment | {0380B082-80D5-4B45-B38C-31625149BAD7} | 4000 |  | x | x | x | CREATE | G |  |  |  |  |  |  | G | G |  |  |  |  |  |  |  | x | x | x | x | x
prvReadEquipment | {B41900AB-96E1-45D5-86F5-7B10DFC9E366} | 4000 |  | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | L |  | G |  | x | x | x | x | x
prvWriteEquipment | {D9A299E8-AD17-46B1-B3DB-389EF2E7B6DD} | 4000 |  | x | x | x | WRITE | G |  |  |  |  |  |  | G | G |  |  |  | L |  |  |  | x | x | x | x | x
prvDeleteEquipment | {9C2C1307-3EFE-4B91-AA7D-7FCDC1E11105} | 4000 |  | x | x | x | DELETE | G |  |  |  |  |  |  | G | G |  |  |  |  |  |  |  | x | x | x | x | x
prvAppendEquipment | {2B55317B-BA10-4a75-893C-BAFA93A796FF} | 4000 |  | x | x | x | APPEND | G |  |  |  |  |  |  | G | G |  |  |  |  |  |  |  | x | x | x | x | x
prvAppendToEquipment | {DEA50329-23C7-43d5-A6D0-4B66FE48FCED} | 4000 |  | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Equipment (facility/equipment) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExchangeSyncIdMapping entity privileges

The following table lists the default privileges for each security role for the ExchangeSyncIdMapping entity.

Privilege name | prvCreateExchangeSyncIdMapping | prvReadExchangeSyncIdMapping | prvWriteExchangeSyncIdMapping | prvDeleteExchangeSyncIdMapping
GUID | {0A348445-968D-4E2F-8EA1-D24A5CCDBC41} | {7fc3fe04-cb8e-4723-85c2-169db5555885} | {267fcb01-6985-4bd2-9f56-87cf42d03eb5} | {e29b3809-3bf1-4d65-9971-3a16eb651fea}
Basic depth (B) | x | x | x | x
Local depth (L) |  |  |  |
Deep depth (D) |  |  |  |
Global Depth (G) |  |  |  |
Corresponding Access Right | CREATE | READ | WRITE | DELETE
CEO-Business Manager | B | B | B | B
Vice President of Sales | B | B | B | B
Sales Manager | B | B | B | B
Salesperson | B | B | B | B
Customer Service Representative | B | B | B | B
CSR Manager | B | B | B | B
Marketing Professional | B | B | B | B
System Administrator | B | B | B | B
Schedule Manager | B | B | B | B
Vice President of Marketing | B | B | B | B
Marketing Manager | B | B | B | B
Scheduler | B | B | B | B
System Customizer | B | B | B | B
Delegate |  |  |  |
Support User |  |  |  |
Admin Only License | x | x | x | x
On-premise - Small Business | x | x | x | x
On-premise - Professional | x | x | x | x
On-premise - Enterprise | x | x | x | x
Live | x | x | x | x
Spla | x | x | x | x

See Also

Reference

Access Levels

Concepts

ExchangeSyncIdMapping messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Fax entity privileges

The Fax entity uses the same privileges as all activity entities. For more information, see ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

Fax entity messages and methods
Task, fax, phone call, and letter activity entities

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FieldPermission entity privileges

There are no specific privileges for the FieldPermission entity.

See Also

Reference

Access Levels

Concepts

FieldPermission entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FieldSecurityProfile entity privileges

The following table lists the default privileges for the FieldSecurityProfile entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateFieldSecurityProfile | {E87592E3-7A2E-4318-9E0F-3DAA3820C101} | 1200 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadFieldSecurityProfile | {4EC4CBA6-2140-4481-8680-BB824F74F265} | 1200 |  |  |  | x | READ | G | G | G |  |  | G |  | G | G | G | G |  | G |  | G | x | x | x | x | x | x
prvWriteFieldSecurityProfile | {CA8168C8-0595-4166-9F20-43E7DB9ABCCF} | 1200 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvDeleteFieldSecurityProfile | {26D15421-634A-4CDE-9192-8D51CD16ECBB} | 1200 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvAppendFieldSecurityProfile | {DB71B287-E4D1-43D7-9ED4-7CBD3737700A} | 1200 |  |  |  | x | APPEND |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvAppendToFieldSecurityProfile | {75EDD484-B2A9-490D-B031-03E4B9F1E032} | 1200 |  |  |  | x | APPENDTO |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

FieldSecurityProfile entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FixedMonthlyFiscalCalendar entity privileges

There are no specific privileges for the FixedMonthlyFiscalCalendar entity.

See Also

Reference

Access Levels

Concepts

FixedMonthlyFiscalCalendar entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Goal entity privileges

The following table lists the default privileges for the Goal entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateGoal | {04A912BB-A73A-49EF-B725-5B3D35B6024C} | 9600 | x | x | x | x | CREATE | G | B | B |  |  | B |  | G | B | B | B |  | B |  |  |  | x | x | x | x | x
prvReadGoal | {55295613-92EC-435E-BCC4-A265B031CFD4} | 9600 | x | x | x | x | READ | B | B | B | B | B | B | B | G | B | B | B | B | B |  | B |  | x | x | x | x | x
prvWriteGoal | {97652230-B9BB-42FC-9323-92B6871E5F5D} | 9600 | x | x | x | x | WRITE | G | B | B |  |  | B |  | G | B | B | B |  | B |  |  |  | x | x | x | x | x
prvDeleteGoal | {2297138D-4BFC-4E71-BDC1-351AA5698DDB} | 9600 | x | x | x | x | DELETE | G | B | B |  |  | B |  | G | B | B | B |  | B |  |  |  | x | x | x | x | x
prvShareGoal | {38A7B8E9-6934-413D-BAA3-BBCB2837B8E4} | 9600 | x | x | x | x | SHARE | G | B | B |  |  | B |  | G | B | B | B |  | B |  |  |  | x | x | x | x | x
prvAssignGoal | {D440FB1F-B019-46A4-9ECE-E626E8282368} | 9600 | x | x | x | x | ASSIGN | G | D | L |  |  | L |  | G | B | D | L |  | B |  |  |  | x | x | x | x | x
prvAppendGoal | {4E4F1E2B-660D-43C2-811D-5ADDBD6450FC} | 9600 | x | x | x | x | APPEND | G | B | B |  |  | B |  | G | B | B | B |  | B |  |  |  | x | x | x | x | x
prvAppendToGoal | {AAF78C30-40F3-4FB7-B49F-FCC415980759} | 9600 | x | x | x | x | APPENDTO | G | B | B |  |  | B |  | G | B | B | B |  | B |  |  |  | x | x | x | x | x
prvRollupGoal | {EF70AE80-3A6E-405A-8BB2-1619CED3D9C4} | 9600 |  |  |  | x | NONE | G | G | G |  |  | G |  | G | G | G | G |  | G |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Goal entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GoalRollupQuery (rollup query) entity privileges

The following table lists the default privileges for the GoalRollupQuery entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendGoalRollupQuery | {602CE2CB-5C6A-46C2-B3E5-241D079B849C} | 9602 | x | x | x | x | APPEND | G | B | B |  |  | B |  | G | B | B | B |  | G |  |
prvAppendToGoalRollupQuery | {5C253E65-9797-4A32-BA5C-BF26F8F830A0} | 9602 | x | x | x | x | APPENDTO | G | B | B |  |  | B |  | G | B | B | B |  | G |  |
prvAssignGoalRollupQuery | {33077769-D457-4ba0-98DD-00A675EFA60C} | 9602 | x | x | x | x | ASSIGN | G | B | B |  |  | B |  | G | B | B | B |  | G |  |
prvCreateGoalRollupQuery | {D4BFC391-5633-4BD7-8DF6-CD07F11EC821} | 9602 | x | x | x | x | CREATE | G | B | B |  |  | B |  | G | B | B | B |  | G |  |
prvDeleteGoalRollupQuery | {341398EC-3880-4005-8110-180015D5BD72} | 9602 | x | x | x | x | DELETE | G | B | B |  |  | B |  | G | B | B | B |  | G |  |
prvReadGoalRollupQuery | {17F045D9-6163-42BA-8CC2-813204B24390} | 9602 | x | x | x | x | READ | G | B | B | B | B | B | B | G | B | B | B | B | G |  | B
prvShareGoalRollupQuery | {BFEEC477-1862-4ce6-BA6F-8F8EEBDFFADD} | 9602 | x | x | x | x | SHARE | G | B | B |  |  | B |  | G | B | B | B |  | G |  |
prvWriteGoalRollupQuery | {F5FB874B-AB75-4773-B38A-76412AB9E5BE} | 9602 | x | x | x | x | WRITE | G | B | B |  |  | B |  | G | B | B | B |  | G |  |

See Also

Reference

Access Levels

Concepts

GoalRollupQuery entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Import (data import) entity privileges

The following table lists the default privileges for the Import entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateImport | {9FEFD2F4-7169-44af-8709-F86EE83EC4BE} | 4410 | x | x | x | x | CREATE | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvReadImport | {A7AFCF54-754A-4b0b-9329-08CF54E36244} | 4410 | x | x | x | x | READ | G | D | L | B | L | L | B | G | L | D | L | B | B |  | B |  | x | x | x | x | x
prvWriteImport | {83B7C89B-B58C-455d-B140-B4D469811F9F} | 4410 | x | x | x | x | WRITE | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvDeleteImport | {32CC1DCC-A43B-4af0-A898-750AB80552F9} | 4410 | x | x | x | x | DELETE | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvShareImport | {38378A04-2EE9-470c-AA7E-A57AB8DE288C} | 4410 | x | x | x | x | SHARE | G | D | D | D | D | D | D | G | D | D | D | D | B |  |  |  | x | x | x | x | x
prvAssignImport | {DFF030BF-D8D5-45c8-A013-55E7E51A35C7} | 4410 | x | x | x | x | ASSIGN | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvAppendImport | {CDF7E78F-3BC5-44a0-ACBF-65D4E34B07D7} | 4410 | x | x | x | x | APPEND | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvAppendToImport | {0B43FF39-E162-4a0c-9192-449982CB5830} | 4410 | x | x | x | x | APPENDTO | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Import (data import) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportFile (import source file) entity privileges

The following table lists the default privileges for the ImportFile entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateImportFile | {8E345875-F67B-40f7-9AA6-2A35DE1BF224} | 4412;4413;4423 | x | x | x | x | CREATE | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvReadImportFile | {FE46D775-CA5C-4a09-AF93-99A133455306} | 4412;4413;4423 | x | x | x | x | READ | G | D | L | B | L | L | B | G | L | D | L | B | B |  | B |  | x | x | x | x | x
prvWriteImportFile | {FF22FD34-E58B-455f-988B-2909C28E7E18} | 4412;4413;4423 | x | x | x | x | WRITE | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvDeleteImportFile | {BDD834D8-8B0B-430c-A1D8-ADD2FCEBD854} | 4412;4413;4423 | x | x | x | x | DELETE | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvShareImportFile | {B9BCAE9F-C539-4739-B894-363796CDFCEB} | 4412;4413;4423 | x | x | x | x | SHARE | G | D | D | D | D | D | D | G | D | D | D | D | B |  |  |  | x | x | x | x | x
prvAssignImportFile | {BF70DC31-6132-4ac0-8C9D-2A741657C6F0} | 4412;4413;4423 | x | x | x | x | ASSIGN | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvAppendImportFile | {F8E6D056-0FC6-4562-9293-E2ACEA5E2FB4} | 4412;4413;4423 | x | x | x | x | APPEND | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x
prvAppendToImportFile | {2BBCCEE3-EEA8-418d-8543-22CD66554DD7} | 4412;4413;4423 | x | x | x | x | APPENDTO | G | D | L | B | L | L | B | G | L | D | L | B | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

ImportFile entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportJob entity privileges

The following table lists the default privileges for the ImportJob entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvReadImportJob | {99358D38-74BF-4657-9B71-96EF6AB383C7} | 9107 |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvWriteImportJob | {C0A3BAF0-6DB6-4EA6-A3B0-712BB58EC440} | 9107 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvDeleteImportJob | {E98ECE6F-4157-4456-85B8-54C4C07FD89F} | 9107 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

ImportJob entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportLog entity privileges

The ImportLog entity uses the default privileges for the ImportFile entity. See ImportFile (import source file) entity privileges.

See Also

Reference

Access Levels

Concepts

ImportLog entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportMap (data map) entity privileges

The following table lists the default privileges for the ImportMap entity.

Privilege Name | Privilege GUID | Entity Object type Code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Online | Spla
prvCreateImportMap | {99D3D16F-587E-4007-91E1-4D873E1C7262} | 4411 | x | x | x | x | CREATE | G | D | L | L | L | L | L | G | L | D | L | L | L |  |  |  | x | x | x | x | x
prvReadImportMap | {81D17FEE-35FF-43a6-8C0A-9B1D2C1EABBF} | 4411 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | B |  | x | x | x | x | x
prvWriteImportMap | {8CCEFD04-E6BE-4231-B527-B613549BBD3D} | 4411 | x | x | x | x | WRITE | G | D | L | L | L | L | L | G | L | D | L | L | L |  |  |  | x | x | x | x | x
prvDeleteImportMap | {D51453CC-2B4B-476f-B9C5-93CA79EC1BA6} | 4411 | x | x | x | x | DELETE | G | D | L | L | L | L | L | G | L | D | L | L | L |  |  |  | x | x | x | x | x
prvShareImportMap | {EB21C061-EFCB-4334-B70D-8147D1BAFCB1} | 4411 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  | x | x | x | x | x
prvAssignImportMap | {5A8C2794-7863-4a83-81D1-02E2F8E09D44} | 4411 | x | x | x | x | ASSIGN | G | D | L | L | L | L | L | G | L | D | L | L | L |  |  |  | x | x | x | x | x
prvAppendImportMap | {630A24B8-D395-4e97-ADA8-FBE706184724} | 4411 | x | x | x | x | APPEND | G | D | L | L | L | L | L | G | L | D | L | L | L |  |  |  | x | x | x | x | x
prvAppendToImportMap | {A35EF949-9464-45fb-9ACA-552AD1B82318} | 4411 | x | x | x | x | APPENDTO | G | D | L | L | L | L | L | G | L | D | L | L | L |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

ImportMap (data map) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Incident (Case) entity privileges

The following table lists the default privileges for the Incident entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendIncident | {694CFD50-F68A-4D3B-A4A1-5D4A47104359} | 112 | x | x | x | x | APPEND | G | L | L | L | G | G | L | G | G | L | L | G | B |  |
prvAppendToIncident | {0546C535-A7EA-4E79-9047-395BF1D240FF} | 112 | x | x | x | x | APPENDTO | G | D | L | L | G | G | L | G | G | D | L | G | B |  |
prvAssignIncident | {F8EFFB69-527F-4265-8D63-CC35DEE7B9D2} | 112 | x | x | x | x | ASSIGN | G |  |  |  | G | G |  | G | D |  |  | D | B |  |
prvCreateIncident | {6CF9442B-E690-4CAD-8B0A-E60464960B93} | 112 | x | x | x | x | CREATE | G |  |  |  | B | L |  | G | D |  |  | D | B |  |
prvDeleteIncident | {7E1CDC99-5379-429B-A8D2-AB6FE15F862B} | 112 | x | x | x | x | DELETE | G |  |  |  |  | D |  | G | D |  |  | D | B |  |
prvReadIncident | {C2AFF40C-6E68-4437-A631-488A354A1860} | 112 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B
prvShareIncident | {287E74D0-926A-4922-B732-0CE03C26471B} | 112 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | B |  |
prvWriteIncident | {7B26693F-1C0C-4E87-8918-F4CC7D219D70} | 112 | x | x | x | x | WRITE | G |  |  |  | G | G |  | G | D |  |  | D | B |  |

See Also

Reference

Access Levels

Concepts

Incident (case) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


IncidentResolution (case resolution) entity privileges

The IncidentResolution entity uses the privileges for the ActivityPointer entity. For more information, see ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

IncidentResolution (case resolution) entity messages and methods

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InvalidDependency entity privileges

There are no specific privileges for the InvalidDependency entity.

See Also

Reference

Access Levels

Concepts

InvalidDependency entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Invoice entity privileges

The following table lists the default privileges for the Invoice entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendInvoice | {A3360786-E99F-4ee9-965C-A24ED6BD9BE7} | 1090 | x | x | x | x | APPEND | G | D | L | L | L | L | L | G |  | D | L |  | B |  |
prvAppendToInvoice | {6CF5EBF1-A6DA-4522-B51D-86F54AD13FA3} | 1090 | x | x | x | x | APPENDTO | G | D | L | L | L | L | L | G | G | D | L | G | B |  |
prvAssignInvoice | {17A4E6CE-9815-404a-86F5-925C2CE4AE49} | 1090 | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvCreateInvoice | {0B005177-7E27-4f91-909E-17CFF6476023} | 1090 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvDeleteInvoice | {3E14A3C0-F07D-49a8-8691-ECA43F2DD173} | 1090 | x | x | x | x | DELETE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvOverridePriceEngineInvoice | {748F74BF-055C-4fd3-835F-A9ECB7449315} | 1090 | x | x | x | x | NONE | G | G | L |  |  |  |  | G |  | G | L |  | B |  |
prvReadInvoice | {824B86C8-7851-4abe-9D99-E281E8F1D504} | 1090 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B
prvShareInvoice | {12289BC7-B3FF-4846-8FB6-50CEC63F5B7B} | 1090 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G |  | G | G |  | B |  |
prvWriteInvoice | {31AB0AC9-7A6C-4a9e-B982-5065863F142E} | 1090 | x | x | x | x | WRITE | G | D | L | L | L | L | L | G |  | D | L |  | B |  |

See Also

Reference

Access Levels

Concepts

Invoice entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InvoiceDetail entity privileges

There are no specific privileges for the InvoiceDetail entity.

See Also

Reference

Access Levels

Concepts

InvoiceDetail (invoice product) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


IsvConfig entity privileges

There are no specific privileges for the IsvConfig entity.

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


KbArticle (article) entity privileges

The following table lists the default privileges for the KBArticle (article) entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendArticle | {F7466AA7-6D39-400d-89C9-DDB6A25CBEA8} | 127 |  |  |  | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvAppendToArticle | {D6478086-F814-4c83-A347-D9E4D4A15F80} | 127 |  |  |  | x | APPENDTO | G | G | G |  | G | G |  | G | G | G | G | G |  |  |
prvCreateArticle | {AF39DB82-2283-4cb2-8381-9D10A0963501} | 127 |  |  |  | x | CREATE | G | G | G |  | G | G |  | G |  | G | G |  |  |  |
prvDeleteArticle | {78197094-97C9-4dc7-A95B-B46947F3378F} | 127 |  |  |  | x | DELETE | G | G |  |  | G | G |  | G |  | G |  |  |  |  |
prvPublishArticle | {4EA4A25D-D0B9-427d-BC53-C82A0E983C7F} | 127 |  |  |  | x | NONE | G |  |  |  |  | G |  | G |  |  |  |  |  |  |
prvReadArticle | {437C1F0E-7D06-42fb-94B9-631805033DAA} | 127 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G |  |  | G
prvWriteArticle | {4E90F305-3EEC-4c50-AC7C-B2868E6E9D7F} | 127 |  |  |  | x | WRITE | G | G | G | G | G | G | G | G |  | G | G |  |  |  |

See Also

Reference

Access Levels

Concepts

KbArticle (article) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


KbArticleComment (article comment) entity privileges

There are no specific privileges for the KBArticleComment entity.

See Also

Reference

Access Levels

Concepts

KbArticleComment (article comment) entity messages and methods

Other Resources

Security role and privilege reference
14b2c18b-a550-4015-9efa-6580fa23cada

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


KbArticleTemplate (article template) entity privileges

The following table lists the default privileges for the KBArticleComment entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendToArticleTemplate | {4EAA39E7-B495-415a-8F7D-C2E8DBD6C346} | 1016 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G |  | G | G |  | G |  |
prvCreateArticleTemplate | {AEBCA654-F04F-423f-AF54-13274D317226} | 1016 |  |  |  | x | CREATE | G | G | G |  |  | G |  | G |  | G | G |  | G |  |
prvDeleteArticleTemplate | {0C5A65E5-4B38-49b4-9D58-81EE4575BA5D} | 1016 |  |  |  | x | DELETE | G | G |  |  |  | G |  | G |  | G |  |  | G |  |
prvReadArticleTemplate | {A794CF4A-169A-44d7-8C90-CBC5D97A1CDF} | 1016 |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | G |  | G
prvWriteArticleTemplate | {B34521DD-86C5-4586-B296-59F20FE2525C} | 1016 |  |  |  | x | WRITE | G | G | G |  |  | G |  | G |  | G | G |  | G |  |

See Also

Reference

Access Levels

Concepts

KbArticleTemplate entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Lead entity privileges

The following table lists the default privileges for the Lead entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendLead | {387D6489-CFCC-47D7-98AF-5B7946D7691D} | 4 | x | x | x | x | APPEND | G | G | G | G | B | B | G | G |  | G | G |  | B |  |
prvAppendToLead | {5E8D193D-184D-44BE-92D8-0F3845D7A9EB} | 4 | x | x | x | x | APPENDTO | G | G | G | G | B | B | G | G | G | G | G | G | B |  |
prvAssignLead | {7755E1BC-6F11-465E-8ED0-A1616C5D32C4} | 4 | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvCreateLead | {A41F965B-2619-4C73-8625-DA31945CCCC7} | 4 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvDeleteLead | {B42D2F65-8929-455D-ABE7-B4EC8367A8E1} | 4 | x | x | x | x | DELETE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvReadLead | {A8ECAC53-09E8-4A13-B598-8D8C87BC3D33} | 4 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B
prvShareLead | {9805EBD7-4A57-4558-A7EF-C0BA93D28C68} | 4 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G |  | G | G |  | B |  |
prvWriteLead | {CB4B339F-2B45-447E-BDD3-0BF4BBEBC294} | 4 | x | x | x | x | WRITE | G | G | G | G | B | B | G | G |  | G | G |  | B |  |

See Also

Reference

Access Levels

Concepts

Lead entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Letter entity privileges

The Letter entity uses the same privileges as all activity entities. For more information see ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

Letter entity messages and methods
Task, fax, phone call, and letter activity entities

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


License entity privileges

The following table lists the default privileges for the License entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvReadLicense | {B93E1FC6-E58C-4f0f-B0C8-59161EDF0455} | 0 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


List (marketing list) entity privileges

The following table lists the default privileges for the List entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendList | {06A4CEA4-E379-4CA0-860D-E443ED5B6261} | 4300 | x | x | x | x | APPEND | G | G | D | D | D | D | D | G |  | G | D |  | B |  |
prvAppendToList | {1492D666-BBB8-42EF-8307-094E66297052} | 4300 | x | x | x | x | APPENDTO | G | G | D | D | D | D | D | G |  | G | D |  | B |  |
prvAssignList | {53E41D96-89CE-4413-BEF3-B1F79870BAE1} | 4300 | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvCreateList | {42B303E4-B680-4C22-86B8-E139FDC09E55} | 4300 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvDeleteList | {10C05A11-2835-4707-AC3F-D88268EE44E1} | 4300 | x | x | x | x | DELETE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvReadList | {A9D76F12-3BE0-4616-B831-B84A514A4462} | 4300 | x | x | x | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | B |  | B
prvShareList | {E836A377-47B7-4BC8-8952-C61445F34CD9} | 4300 | x | x | x | x | SHARE | G | G | D | D | D | D | D | G |  | G | D |  | B |  |
prvWriteList | {2967396E-AB97-4E10-9584-16839EB2A7F0} | 4300 | x | x | x | x | WRITE | G | G | D | D | D | D | D | G |  | G | D |  | B |  |

See Also

Reference

Access Levels

Concepts

List (marketing list) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


LookUpMapping entity privileges

There are no specific privileges for the LookupMapping entity.

See Also

Reference

Access Levels

Concepts

LookupMapping entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Mailbox entity privileges

The following table lists the privileges for the Mailbox entity.

Privilege name | prvCreateMailbox | prvReadMailbox | prvWriteMailbox | prvDeleteMailbox | prvAppendMailbox | prvAppendToMailbox | prvShareMailbox | prvAssignMailbox
GUID | {2b404847-af4a-49ac-8389-a7c96a0305a3} | {8e17de3a-5a69-479c-9535-1f7be75b2987} | {1d79f9f9-4a93-4cf7-ade4-39fbe10b1494} | {1e24e27d-60e9-4a63-a1ed-44d77702425f} | {1518e693-c382-43e8-97ca-d2dfe03427e3} | {15b16455-4fd8-4c52-9e39-bc973d3b0181} | {dd66949c-77c5-4b63-a2ef-0a45ac4e28a1} | {0fddefbe-ec48-416b-b794-35f48828e71f}
Basic depth (B) | x | x | x | x | x | x | x | x
Local depth (L) | x | x | x | x | x | x | x | x
Deep depth (D) | x | x | x | x | x | x | x | x
Global Depth (G) | x | x | x | x | x | x | x | x
Corresponding Access Right | CREATE | READ | WRITE | DELETE | APPEND | APPENDTO | SHARE | ASSIGN
CEO-Business Manager | B | B |  | B |  |  |  |
Vice President of Sales | B | B |  | B |  |  |  |
Sales Manager |  | B | B |  | B |  |  |
Salesperson |  | B | B |  | B |  |  |
Customer Service Representative | B | B |  | B |  |  |  |
CSR Manager |  | B | B |  | B |  |  |
Marketing Professional | B | B |  | B |  |  |  |
System Administrator | G | G | G | G | G | G | G | G
Schedule Manager | B | B |  | B |  |  |  |
Vice President of Marketing | B | B |  | B |  |  |  |
Marketing Manager | B | B |  | B |  |  |  |
Scheduler |  | B | B |  | B |  |  |
System Customizer | B | B |  | G | G | G | G |
Delegate |  |  |  |  |  |  |  |
Support User |  | B | B |  | B |  |  |
Admin Only License | x | x | x | x | x | x |  |
On-premise - Small Business | x | x | x | x | x | x | x | x
On-premise - Professional | x | x | x | x | x | x | x | x
On-premise - Enterprise | x | x | x | x | x | x | x | x
Live | x | x | x | x | x | x | x | x
Spla | x | x | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Mailbox entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


MailMergeTemplate entity privileges

The following table lists the default privileges for the MailMergeTemplate entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvMailMerge | {9293EEB5-1EFA-48C2-AE83-56FB180539EE} | 0 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  |
prvWebMailMerge | {50D9FDD3-8CC6-4774-A661-79822061BFEF} | 0 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  |
prvAppendMailMergeTemplate | {422187BB-AAA0-4539-B8A5-BE9D68291776} | 9106 | x | x | x | x | APPEND | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvAppendToMailMergeTemplate | {947F72B5-8E18-47B4-ACAA-9638CCC5EA3C} | 9106 | x | x | x | x | APPENDTO | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvAssignMailMergeTemplate | {94080062-E5BE-4A4E-AD41-6295A881FE9D} | 9106 | x | x | x | x | ASSIGN | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvCreateMailMergeTemplate | {88EC96CE-3A2B-4822-9375-E016A4127FC2} | 9106 | x | x | x | x | CREATE | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvDeleteMailMergeTemplate | {5978156A-B329-434D-94CF-E77AB08356D1} | 9106 | x | x | x | x | DELETE | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvPublishOrgMailMergeTemplate | {AC3CC10E-F735-4F34-95E4-097EC2AB478B} | 9106 |  |  |  | x | NONE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvReadMailMergeTemplate | {933BABB9-6E0B-4B63-8196-C2ACC272DC7F} | 9106 | x | x | x | x | READ | B | B | B | B | B | B | B | G | B | B | B | B | G |  | B
prvShareMailMergeTemplate | {297D73AE-8278-4D60-B3B3-227950B2E6C6} | 9106 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | G |  |
prvWriteMailMergeTemplate | {2E3A99AB-EC46-4A22-8DAC-726E58A1D0F4} | 9106 | x | x | x | x | WRITE | B | B | B | B | B | B | B | G | B | B | B | B | G |  |

See Also

Reference

Access Levels

Concepts

MailMergeTemplate entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Metric (goal metric) entity privileges

The following table lists the default privileges for the Metric entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendMetric | {9FE30EB5-8C24-45D1-A43C-C17B0A6CBD4E} | 9603 |  |  |  | x | APPEND | G | G | G |  |  | G |  | G |  | G |  |  | G |  |
prvAppendToMetric | {8314D177-1D29-4B72-B03B-A1B6EA56959C} | 9603 |  |  |  | x | APPENDTO | G | G | G |  |  | G |  | G | G | G | G |  | G |  |
prvCreateMetric | {0514CE4A-757D-4E71-9154-EF7600F493B2} | 9603 |  |  |  | x | CREATE | G | G | G |  |  | G |  | G |  | G |  |  | G |  |
prvDeleteMetric | {3C3E821A-9748-455C-8358-E03515ACF2F0} | 9603 |  |  |  | x | DELETE | G | G | G |  |  | G |  | G |  | G |  |  | G |  |
prvReadMetric | {BC212780-E5E5-4251-92FE-EF8B0AAB36E6} | 9603 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteMetric | {7981FAEC-B32E-4FD3-8150-9098BC59CBC8} | 9603 |  |  |  | x | WRITE | G | G | G |  |  | G |  | G |  | G |  |  | G |  |

See Also

Reference

Access Levels

Concepts

Metric (goal metric) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


MonthlyFiscalCalendar entity privileges

There are no specific privileges for the MonthlyFiscalCalendar entity.

See Also

Reference

Access Levels

Concepts

MonthlyFiscalCalendar entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


msdyn_PostAlbum (profile album) entity privileges

The following table lists the default privileges for each security role for the msdyn_PostAlbum (Profile Album) entity.

Privilege name | Corresponding Access Right | Activity Feeds | System Customizer | System Administrator | All other security roles
prvCreatemsdyn_PostAlbum | CREATE | Basic | Global | Global | None
prvReadmsdyn_PostAlbum | READ | Global | Global | Global | None
prvWritemsdyn_PostAlbum | WRITE | Basic | Global | Global | None
prvDeletemsdyn_PostAlbum | DELETE | Basic | Global | Global | None
prvSharemsdyn_PostAlbum | SHARE | None | Global | Global | None
prvAssignmsdyn_PostAlbum | ASSIGN | None | Global | Global | None
prvAppendmsdyn_PostAlbum | APPEND | Basic | Global | Global |
prvAppendTomsdyn_PostAlbum | APPENDTO | Basic | Global | Global |

See Also

Reference

Access Levels

Concepts

msdyn_PostAlbum (profile album) entity messages and methods

Other Resources

Security role and privilege reference
Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


msdyn_PostRuleConfig (post rule configuration) entity privileges

The following table lists the default privileges for each security role for the msdyn_PostRuleConfig (Post Rule Configuration) entity.

Privilege name | Corresponding Access Right | Activity Feeds | System Customizer | System Administrator | All other security roles
prvCreatemsdyn_PostAlbum | CREATE | None | Global | Global | None
prvReadmsdyn_PostAlbum | READ | Global | Global | Global | None
prvWritemsdyn_PostAlbum | WRITE | None | Global | Global | None
prvDeletemsdyn_PostAlbum | DELETE | None | Global | Global | None
prvAppendmsdyn_PostAlbum | APPEND | None | Global | Global |
prvAppendTomsdyn_PostAlbum | APPENDTO | None | Global | Global |

See Also

Reference

Access Levels

Concepts

msdyn_PostRuleConfig (post rule configuration) entity messages and methods

Other Resources

Security role and privilege reference
Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


msdyn_PostConfig (post configuration) entity privileges

The following table lists the default privileges for each security role for the msdyn_PostConfig (Post Configuration) entity.

Privilege name | Corresponding Access Right | Activity Feeds | System Customizer | System Administrator | All other security roles
prvCreatemsdyn_PostAlbum | CREATE | None | Global | Global | None
prvReadmsdyn_PostAlbum | READ | Global | Global | Global | None
prvWritemsdyn_PostAlbum | WRITE | None | Global | Global | None
prvDeletemsdyn_PostAlbum | DELETE | None | Global | Global | None
prvAppendmsdyn_PostAlbum | APPEND | None | Global | Global |
prvAppendTomsdyn_PostAlbum | APPENDTO | None | Global | Global |

See Also

Reference

Access Levels

Concepts

msdyn_PostConfig (post configuration) entity messages and methods

Other Resources

Security role and privilege reference
Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Opportunity entity privileges

The following table lists the default privileges for the Opportunity entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendOpportunity | {A2420282-24DE-424B-8997-8D316091E310} | 3 | x | x | x | x | APPEND | G | G | G | G | B | B | G | G |  | G | G |  | B |  |
prvAppendToOpportunity | {DAE65DA8-E481-410D-BFCC-16C37F894604} | 3 | x | x | x | x | APPENDTO | G | G | G | G | B | B | G | G | G | G | G | G | B |  |
prvAssignOpportunity | {8A4862A1-C88A-4BE9-9A60-1E6D9258FA52} | 3 | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvCreateOpportunity | {6B882C27-9ED7-467F-BE0F-213A605E0A13} | 3 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvDeleteOpportunity | {EC005BA2-AD88-4B96-962C-23BBEB41D2E1} | 3 | x | x | x | x | DELETE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvOverridePriceEngineOpportunity | {0FE2F754-3531-4670-8A8D-B3D7EB49321E} | 3 | x | x | x | x | NONE | G | G | L |  |  |  |  | G |  | G | L |  | B |  |
prvReadOpportunity | {F7767F74-628D-48B3-A79F-9C6E24FEDB69} | 3 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B
prvShareOpportunity | {240EDD9B-83E1-46B4-AA25-576AD3C75186} | 3 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G |  | G | G |  | B |  |
prvWriteOpportunity | {EEEB5856-3F80-4886-8AE2-456AD9141244} | 3 | x | x | x | x | WRITE | G | G | G | G | B | B | G | G |  | G | G |  | B |  |

See Also

Reference

Access Levels

Concepts

Opportunity entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OpportunityClose entity privileges

The OpportunityClose entity uses the privileges for the ActivityPointer entity. See ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

OpportunityClose activity entity messages and methods

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OpportunityProduct entity privileges

There are no specific privileges for the OpportunityProduct entity.

See Also

Reference

Access Levels

Concepts

OpportunityProduct entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OrderClose entity privileges

The OrderClose entity uses the privileges for the ActivityPointer entity. For more information, see ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

OrderClose activity entity messages and methods

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Organization entity privileges

The following table lists the default privileges for the Organization entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendToOrganization | {E7753B34-17F3-400e-8396-88E24B8DC519} | 1019 |  |  |  | x | APPENDTO |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadOrganization | {DBD3AD17-B6BD-46c8-8DB7-179FEC82C937} | 1019 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteOrganization | {9F7B7E89-E5F6-41fd-8390-F06A7EC66D25} | 1019 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |

See Also

Reference

Access Levels

Concepts

Organization entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OwnerMapping entity privileges

There are no specific privileges for the OwnerMapping entity.

See Also

Reference

Access Levels

Concepts

OwnerMapping entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PhoneCall entity privileges

The PhoneCall entity uses the same privileges as all activity entities. For more information, see ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

PhoneCall entity messages and methods
Task, fax, phone call, and letter activity entities

Other Resources

Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PickListMapping (list value mapping) entity privileges

There are no specific privileges for the PickListMapping entity.

See Also

Reference

Access Levels

Concepts

PicklistMapping (list value mapping) entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PluginAssembly entity privileges

The following table lists the default privileges for the PluginAssembly entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreatePluginAssembly | {C81A03BB-4BFC-45a6-9184-E899CE26811A} | 4605 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvDeletePluginAssembly | {3FA24EFF-E413-4224-8CF2-BD29193F8ADF} | 4605 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadPluginAssembly | {F5B50296-A212-488a-BE92-CBCCA8971717} | 4605 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWritePluginAssembly | {37009C66-2E53-49f0-B857-62252EAA6412} | 4605 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

PluginAssembly entity messages and methods

Other Resources

Security role and privilege reference
Plug-in development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PluginType entity privileges

The following table lists the default privileges for the PluginType entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreatePluginType | {592CB518-880D-492F-BD3C-3558413B8CED} | 4602;4603 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvDeletePluginType | {5E1C5422-9A12-4D3E-9960-51A812A005E2} | 4602;4603 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadPluginType | {9365005C-4703-473B-8D3C-D073CFD8670C} | 4602;4603 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWritePluginType | {C70843E8-D617-4873-9D05-8A8D4A68EE58} | 4602;4603 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

PluginType entity messages and methods

Other Resources

Security role and privilege reference
Plug-in development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PluginTypeStatistic entity privileges

There are no specific privileges for the PluginTypeStatistic entity.

See Also

Reference

Access Levels

Concepts

PluginTypeStatistic entity messages and methods

Other Resources

Security role and privilege reference
Plug-in development

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Position entity privileges

The following table lists the default privileges for each security role for the Position (property instance) entity.

Content coming soon.

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Post entity privileges

The following table shows the default privileges for the Post entity.

Privilege Name | GUID | Entity Name | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreatePost | {8D518C07-BD0D-4274-BA75-809A7B24B37E} | Post |  |  |  | x | CREATE | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  | x | x | x | x | x
prvReadPost | {9D00A0F3-870B-46F8-A4B7-C43186C21B2D} | Post |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G |  | x | x | x | x | x
prvAppendPost | {50182AEE-1B0A-44DB-88FD-45214AB70FA5} | Post |  |  |  | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  | x | x | x | x | x
prvAppendToPost | {F6F1932D-5A75-4D83-91D2-CFB6E2FE3F35} | Post |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G |  |  |  | x | x | x | x | x
prvDeleteAnyPost | {2562777C-ACE0-45DE-94C0-57FD71787250} | Post |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

Post entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference
Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PostComment (comment) entity privileges

There are no specific privileges for the PostComment entity.

See Also

Reference

Access Levels

Concepts

PostComment (comment) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference
Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PostFollow (follow) entity privileges

The following table lists the default privileges for the PostFollow entity.

Privilege Name | GUID | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreatePostFollow | {2208583E-626B-11E0-834F-1CC1DE634CFE} | x | x | x | x | CREATE | B | B | B | B | B | B | B | G | B | B | B | B | B |  |  |  | x | x | x | x | x
prvAppendPostFollow | {02206A87-51A5-4811-AACA-203CFC5F15B3} | x | x | x | x | APPEND | B | B | B | B | B | B | B | G | B | B | B | B | B |  |  |  | x | x | x | x | x
prvReadPostFollow | {2208583F-626B-11E0-834F-1CC1DE634CFE} | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G |  | x | x | x | x | x
prvDeletePostFollow | {22085841-626B-11E0-834F-1CC1DE634CFE} | x | x | x | x | DELETE | B | B | B | B | B | B | B | G | B | B | B | B | B |  |  |  | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

PostFollow (follow) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference
Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PostLike (like) entity privileges

There are no specific privileges for the PostFollow entity.

See Also

Reference

Access Levels

Concepts

PostLike (like) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference
Activity feeds entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PriceLevel (price list) entity privileges

There are no specific privileges for the PriceLevel (price list) entity.

See Also

Reference

Access Levels

Concepts

PriceLevel (price list) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PrincipalObjectAttributeAccess (field sharing) entity privileges

The following table lists the default privileges for the PrincipalObjectAttributeAccess (field sharing) entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendPrincipalObjectAttributeAccess | {2ba6ddbf-2d8a-11df-8176-00137299e1c2} | 44 |  |  |  | x | APPEND |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvAppendToPrincipalObjectAttributeAccess | {2ba6ddbe-2d8a-11df-8176-00137299e1c2} | 44 |  |  |  | x | APPENDTO |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvCreatePrincipalObjectAttributeAccess | {68564CD6-2B2E-11DF-80A6-00137299E1C2} | 44 |  |  |  | x | CREATE | G | G | G |  |  | G |  | G | G | G | G |  | G |  |
prvDeletePrincipalObjectAttributeAccess | {68564CD3-2B2E-11DF-80A6-00137299E1C2} | 44 |  |  |  | x | DELETE | G | G | G |  |  | G |  | G | G | G | G |  | G |  |
prvReadPrincipalObjectAttributeAccess | {68564CD5-2B2E-11DF-80A6-00137299E1C2} | 44 |  |  |  | x | READ | G | G | G |  |  | G |  | G | G | G | G |  | G |  |
prvWritePrincipalObjectAttributeAccess | {68564CD4-2B2E-11DF-80A6-00137299E1C2} | 44 |  |  |  | x | WRITE | G | G | G |  |  | G |  | G | G | G | G |  | G |  |

See Also

Reference

Access Levels

Concepts

PrincipalObjectAttributeAccess (field sharing) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PrincipalSyncAttributeMap entity privileges

The following table lists the default privileges for each security role for the PrincipalSyncAttributeMap entity.

Content coming soon.

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Privilege entity privileges

There are no specific privileges for the Privilege entity.

See Also

Reference

Access Levels

Concepts

Privilege entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProcessSession entity privileges

There are no specific privileges for the ProcessSession entity.

See Also

Reference

Access Levels

Concepts

ProcessSession entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProcessTrigger entity privileges

There are no specific privileges for the ProcessTrigger entity.

See Also

Reference

Access Levels
Access Levels

Concepts

ProcessTrigger entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Product entity privileges

The following table lists the default privileges for the Product entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendProduct | {D589F1A0-E1E1-4585-86C4-6B6DC33E8F65} | 1024;1022;1056;1080 |  |  |  | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | G |  |
prvAppendToProduct | {CC345E3D-927F-4aa2-9BE5-6A79E2DB3577} | 1024;1022;1056;1080 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G |  |  |
prvCreateProduct | {5F873211-084E-4eb2-94B8-98F068440DC2} | 1024;1022;1056;1080 |  |  |  | x | CREATE | G | G | G |  |  | G |  | G |  | G | G |  |  |  |
prvDeleteProduct | {CC04CB55-CC00-4315-A100-0DAFD1F1CABA} | 1024;1022;1056;1080 |  |  |  | x | DELETE | G | G | G |  |  | G |  | G |  | G | G |  |  |  |
prvReadProduct | {60D420CA-7A88-4c0d-8286-C425B527FA98} | 1024;1022;1056;1080 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteProduct | {4F86580F-D0AD-473a-91E2-E3FC7B7D5D0C} | 1024;1022;1056;1080 |  |  |  | x | WRITE | G | G | G |  |  | G |  | G |  | G | G |  | G |  |

See Also

Reference

Access Levels

Concepts

Product entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProductPriceLevel (price list item) entity privileges

There are no specific privileges for the ProductPriceLevel (price list item) entity.

See Also

Reference

Access Levels

Concepts

ProductPriceLevel (price list item) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Publisher entity privileges

The following table lists the default privileges for the Publisher entity.

Privilege name | GUID | entity | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendPublisher | {FC283683-5D20-4e4e-AA35-A79B876279DC} | Publisher | 7101;7102 |  | x | x | x | APPEND |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvAppendToPublisher | {B37F6920-E7B4-44d1-AF9F-A6166B6A59B9} | Publisher | 7101;7102 |  | x | x | x | APPENDTO |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvCreatePublisher | {B4611D30-E2D5-4886-9929-48FDE38DC4EE} | Publisher | 7101;7102 |  | x | x | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvDeletePublisher | {82C9358D-3E88-43d0-802A-730212B9B372} | Publisher | 7101;7102 |  | x | x | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvReadPublisher | {8CDEBADE-6187-440d-B041-5B3F3D84DB53} | Publisher | 7101;7102 |  | x | x | x | READ |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvWritePublisher | {835DA693-9268-4c1c-95E0-B2F4B802F142} | Publisher | 7101;7102 |  | x | x | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |

See Also

Reference

Access Levels

Concepts

Publisher entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PublisherAddress entity privileges

There are no specific privileges for the PublisherAddress entity.

See Also

Reference

Access Levels

Concepts

PublisherAddress entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QuarterlyFiscalCalendar entity privileges

There are no specific privileges for the QuarterlyFiscalCalendar entity.

See Also

Reference

Access Levels

Concepts

QuarterlyFiscalCalendar entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Queue entity privileges

The following table lists the default privileges for the Queue entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendQueue | {7D827946-147E-4292-A385-CCB34DC96525} | 2020 | x | x | x | x | APPEND | G |  |  |  | B | D |  | G | D |  |  | B | G |  |
prvAppendToQueue | {041FDB4C-BBB8-4792-90DB-51C19D067CA2} | 2020 | x | x | x | x | APPENDTO | G | B | B | B | L | D | B | G | D | B | B | L | G |  | B
prvAssignQueue | {9FBC6F47-0777-4FD8-87C6-15B627AA286A} | 2020 | x | x | x | x | ASSIGN | G |  |  |  | B | D |  | G | D |  |  | B | G |  |
prvCreateQueue | {FA14449F-B8D3-4ded-AE4E-3D2738D2A634} | 2020 | x | x | x | x | CREATE | G |  |  |  | B | D |  | G | D |  |  | B | G |  |
prvDeleteQueue | {150B7E82-179F-4f88-AF25-D305EEA01D8E} | 2020 | x | x | x | x | DELETE | G |  |  |  | B | D |  | G | D |  |  | B | G |  |
prvReadQueue | {B140E729-DFEB-4ba1-A33F-39FF830BAC90} | 2020 | x | x | x | x | READ | G | B | B | B | L | D | B | G | D | B | B | L | G |  | B
prvShareQueue | {CF4C8571-E022-46A7-BD67-B19198BDA9DC} | 2020 | x | x | x | x | SHARE | G |  |  |  | B | D |  | G | D |  |  | B | G |  |
prvWriteQueue | {28C10364-C205-48fa-A956-FBCEC1A23053} | 2020 | x | x | x | x | WRITE | G |  |  |  | B | D |  | G | D |  |  | B | G |  |

See Also

Reference

Access Levels

Concepts

Queue entity messages and methods
Queue entities

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QueueItem entity privileges

The QueueItem entity uses the same privileges as the queue entity. For more information, see Queue entity privileges.

See Also

Reference

Access Levels

Concepts

QueueItem entity messages and methods
Queue entities

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Quote entity privileges

The following table lists the default privileges for the Quote entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendQuote | {3027B0B3-192E-432d-851B-ACC5DC8EB953} | 1084 | x | x | x | x | APPEND | G | D | L | L | L | L | L | G |  | D | L |  | B |  |
prvAppendToQuote | {41035DF9-7AD8-4af1-8E78-F44672FF1ADB} | 1084 | x | x | x | x | APPENDTO | G | D | L | L | L | L | L | G | G | D | L | G | B |  |
prvAssignQuote | {01F1FC93-B5B0-4c43-8196-96AB0D0113E6} | 1084 | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvCreateQuote | {477DFD23-A640-4ebd-981A-183737963D7F} | 1084 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvDeleteQuote | {DCC1D522-DFD6-46fc-BC6C-B90A097BA309} | 1084 | x | x | x | x | DELETE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvOverridePriceEngineQuote | {45C781DA-DB3E-439b-9EFE-D1B5484B832F} | 1084 | x | x | x | x | NONE | G | G | L |  |  |  |  | G |  | G | L |  | B |  |
prvReadQuote | {00A8D04E-EDE7-4884-AE18-09C6E55344CA} | 1084 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B
prvShareQuote | {FA072959-EC94-4631-B419-91EBD45562D3} | 1084 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G |  | G | G |  | B |  |
prvWriteQuote | {356F5577-C5C3-44c4-93D9-442B282FA8DF} | 1084 | x | x | x | x | WRITE | G | D | L | L | L | L | L | G |  | D | L |  | B |  |

See Also

Reference

Access Levels

Concepts

Quote entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QuoteClose entity privileges

The QuoteClose entity uses the privileges for the ActivityPointer entity. For more information, see ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

QuoteClose activity entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QuoteDetail (quote product) entity privileges

There are no specific privileges for the QuoteDetail (quote product) entity.

See Also

Reference

Access Levels

Concepts

QuoteDetail (quote product) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RecurrenceRule entity privileges

There are no specific privileges for the RecurrenceRule entity.

See Also

Reference

Access Levels

Concepts

RecurrenceRule entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RecurringAppointmentMaster entity privileges

There are no specific privileges for the RecurringAppointmentMaster entity.

See Also

Reference

Access Levels

Concepts

RecurringAppointmentMaster entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RelationshipRole entity privileges

The following table lists the default privileges for the RelationshipRole entity. Deprecated.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendRelationshipRole | {E5A70735-50C1-4E1A-A512-780B2E4456F3} | 4500 |  |  |  | x | APPEND | G | G |  |  |  |  |  | G |  | G |  |  | G |  |
prvAppendToRelationshipRole | {46792F9A-83E1-4E72-BBBB-D31BACDE7365} | 4500 |  |  |  | x | APPENDTO | G | G |  |  |  |  |  | G |  | G |  |  | G |  |
prvCreateRelationshipRole | {6C9B6722-135E-4847-B4CF-256033F3FE47} | 4500 |  |  |  | x | CREATE | G | G |  |  |  |  |  | G |  | G |  |  | G |  |
prvDeleteRelationshipRole | {8B80FBBA-BB3C-4F11-8EEF-8CDBCC6476DA} | 4500 |  |  |  | x | DELETE | G | G |  |  |  |  |  | G |  | G |  |  | G |  |
prvReadRelationshipRole | {3C223CBD-7309-4A1A-901E-9BA78BC41EC8} | 4500 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteRelationshipRole | {1AFFAB32-4BF0-4484-AE6B-4F2B6F3D5CB9} | 4500 |  |  |  | x | WRITE | G | G |  |  |  |  |  | G |  | G |  |  | G |  |

See Also

Reference

Access Levels

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RelationshipRoleMap entity privileges

There are no specific privileges for the RelationshipRoleMap entity. Deprecated.

See Also

Reference

Access Levels

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Report entity privileges

The following table lists the default privileges for the Report entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendReport | {A622E2FD-45F2-4f8b-8B8A-97D91DF22D66} | 9100 | x | x | x | x | APPEND | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvAppendToReport | {871B9012-A118-4d40-89D6-32564AE9EFB6} | 9100 | x | x | x | x | APPENDTO | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvAssignReport | {7304BDBE-C652-454d-AE19-A5D6070D34AB} | 9100 | x | x | x | x | ASSIGN | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvCreateReport | {F8F5BC13-9976-4acd-BD45-195CB314194E} | 9100 | x | x | x | x | CREATE | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvDeleteReport | {9EC19565-92CE-4376-AB8B-8071172F5F86} | 9100 | x | x | x | x | DELETE | B | B | B | B | B | B | B | G | B | B | B | B | G |  |
prvReadReport | {71AD2527-8494-4654-968D-FE61E9A6A9DF} | 9100 | x | x | x | x | READ | B | B | B | B | B | B | B | G | B | B | B | B | G |  | G
prvShareReport | {9DD87A06-3E84-4b6e-B69E-5DD931AA8A0F} | 9100 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | G |  |
prvWriteReport | {158B7EEA-002D-4653-9936-4091DEA1FE6E} | 9100 | x | x | x | x | WRITE | B | B | B | B | B | B | B | G | B | B | B | B | G |  |

See Also

Reference

Access Levels

Concepts

Report entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference
Report entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReportCategory (report related category) entity privileges

There are no specific privileges for the ReportCategory entity.

See Also

Reference

Access Levels

Concepts

ReportCategory (report related category) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReportEntity (report related entity) entity privileges

There are no specific privileges for the ReportEntity entity.

See Also

Reference

Access Levels

Concepts

ReportEntity (report related) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReportLink entity privileges

There are no specific privileges for the ReportLink entity.

See Also

Reference

Access Levels

Concepts

ReportLink entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReportVisibility entity privileges

There are no specific privileges for the ReportVisibility entity.

See Also

Reference

Access Levels

Concepts

ReportVisibility entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Resource entity privileges

There are no specific privileges for the Resource entity.

See Also

Reference

Access Levels

Concepts

Resource entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ResourceGroup (scheduling group) entity privileges

There are no specific privileges for the ResourceGroup entity.

See Also

Reference

Access Levels

Concepts

ResourceGroup (scheduling group) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ResourceSpec (resource specification) entity privileges

There are no specific privileges for the ResourceSpec entity.

See Also

Reference

Access Levels

Concepts

ResourceSpec (resource specification) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Role (security role) entity privileges

The following table lists the default privileges for the Role entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendRole | {8FDEEA95-80AB-47dc-974B-52D71B88C8AF} | 1036 |  | x | x | x | APPEND | G | G |  |  |  |  |  | G |  | G |  |  |  |  |
prvAppendToRole | {EAA02B5B-DC56-4aa3-A889-718F25AA0075} | 1036 |  | x | x | x | APPENDTO | G | G |  |  |  |  |  | G |  | G |  |  |  |  |
prvAssignRole | {836D6C7B-CF1D-47f0-8021-8E41091C489C} | 1036 |  | x | x | x | ASSIGN | G | D | L |  |  | L |  | G |  | D | L |  |  |  |
prvCreateRole | {7398C78C-29A5-4982-9ADA-73390F64FE99} | 1036 |  | x | x | x | CREATE | G | D |  |  |  |  |  | G |  | D |  |  |  |  |
prvDeleteRole | {34ABE1B8-E9BC-4be0-9EF3-09459CA7AE57} | 1036 |  | x | x | x | DELETE | G |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadRole | {222A920A-2778-4564-85CB-E78DDE8E4276} | 1036 |  | x | x | x | READ | G | G | G | L | L | G | L | G | L | G | G | L | G |  | G
prvWriteRole | {BD123E14-17BA-40f6-8D8B-18F4BFFA7E50} | 1036 |  | x | x | x | WRITE | G | D |  |  |  |  |  | G |  | D |  |  |  |  |

See Also

Reference

Access Levels

Concepts

Role (security role) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RollupField entity privileges

There are no specific privileges for the RollupField entity.

See Also

Reference

Access Levels

Concepts

RollupField entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RoutingRuleSet entity privileges

The following table lists the default privileges for each security role for the RoutingRuleSet entity. For internal use only.

Privilege Name | Privilege Guid | Entity Name | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateRoutingRule | {53b3320a-8185-4a77-86db-b18efd08b8e1} | RoutingRule | 8181 | x | x | x | x | CREATE |  |  |  |  |  | L |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadRoutingRule | {151d85cf-dc0f-441c-9b81-8e413964138f} | RoutingRule | 8181 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvWriteRoutingRule | {0a7a71c9-d2a5-4346-88a8-5dbdf5b7a477} | RoutingRule | 8181 | x | x | x | x | WRITE |  |  |  |  |  | G |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvAppendRoutingRule | {13d88c80-0fe7-49e9-9f0a-e32a1586aacd} | RoutingRule | 8181 | x | x | x | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvAppendToRoutingRule | {5fe45578-07bd-49ae-9d4c-b0599fa8e4e9} | RoutingRule | 8181 | x | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvDeleteRoutingRule | {c6693e0e-4e9c-4e7b-ba3d-9027b7a8a42c} | RoutingRule | 8181 | x | x | x | x | DELETE |  |  |  |  |  | D |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvShareRoutingRule | {230ae2d3-9963-4784-b652-4ddb7d7af4ea} | RoutingRule | 8181 | x | x | x | x | SHARE | B | B | B | B | B | G | B | G | B | B | B | B | G | B | B | x | x | x | x | x | x
prvAssignRoutingRule | {10ecd243-3efc-4b76-be1f-75f66ee6cf3a} | RoutingRule | 8181 | x | x | x | x | ASSIGN | B | B | B | B | B | G | B | G | B | B | B | B | G | B | B | x | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SalesLiterature entity privileges

The following table lists the default privileges for the SalesLiterature entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendSalesLiterature | {CAB32FE6-2A53-4a29-BF47-9D2B7CA4356C} | 1038 |  |  |  | x | APPEND | G | G | G | G | G | G | G | G |  | G | G |  |  |  |
prvAppendToSalesLiterature | {0039D6AA-0500-44c9-A99C-8A7BC1BDB36B} | 1038 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G |  | G | G |  |  |  |
prvCreateSalesLiterature | {5D076EA0-354B-41cf-8BA8-EA38C93F4DC2} | 1038 |  |  |  | x | CREATE | G | G | G |  |  |  |  | G |  | G | G |  |  |  |
prvDeleteSalesLiterature | {7FFAF8D7-8266-4816-B6F8-1D436E7DD95A} | 1038 |  |  |  | x | DELETE | G | G | G |  |  |  |  | G |  | G | G |  |  |  |
prvReadSalesLiterature | {9DD55B66-8ADE-4326-BF0F-0BDE6A9E4964} | 1038 |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | G |  | G
prvWriteSalesLiterature | {8F4E3B25-FC7E-4ea9-866D-B24071EE4ECE} | 1038 |  |  |  | x | WRITE | G | G | G |  |  |  |  | G |  | G | G |  | G |  |

See Also

Reference

Access Levels

Concepts

SalesLiteratureItem (sales attachment) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SalesLiteratureItem (sales attachment) entity privileges

There are no specific privileges for the SalesLiteratureItem entity.

See Also

Reference

Access Levels

Concepts

SalesLiteratureItem (sales attachment) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SalesOrder (order) entity privileges

The following table lists the default privileges for the SalesOrder (Order) entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendOrder | {1DCF75FE-3540-4f93-84BB-D1E8EEC6C8D9} | 1088 | x | x | x | x | APPEND | G | D | L | L | L | L | L | G |  | D | L |  | B |  |
prvAppendToOrder | {45B189D7-ADB7-474b-857B-98783812F7F6} | 1088 | x | x | x | x | APPENDTO | G | D | L | L | L | L | L | G | G | D | L | G | B |  |
prvAssignOrder | {F9388C46-82AC-455c-8FCF-628351169404} | 1088 | x | x | x | x | ASSIGN | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvCreateOrder | {83F518E2-F311-4bb4-894F-A7EE55E558A7} | 1088 | x | x | x | x | CREATE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvDeleteOrder | {CEB5CFAE-F745-4a60-8023-B5B203C72E34} | 1088 | x | x | x | x | DELETE | G | D | L | B | B | B | B | G |  | D | L |  | B |  |
prvOverridePriceEngineOrder | {0186F903-2B6A-4230-9838-0B64080A7568} | 1088 | x | x | x | x | NONE | G | G | L |  |  |  |  | G |  | G | L |  | B |  |
prvReadOrder | {6F81B089-36D1-476e-8519-33DF34AEFE11} | 1088 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | B
prvShareOrder | {7BB2363E-AEAE-44c9-ADC9-D1F13FC355C1} | 1088 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G |  | G | G |  | B |  |
prvWriteOrder | {13121F22-3211-44d5-AB17-ADCF699CF0EB} | 1088 | x | x | x | x | WRITE | G | D | L | L | L | L | L | G |  | D | L |  | B |  |

See Also

Reference

Access Levels

Concepts

SalesOrder (order) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SalesOrderDetail (order product) entity privileges

There are no specific privileges for the SalesOrderDetail (order product) entity.

See Also

Reference

Access Levels

Concepts

SalesOrderDetail (order product) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SavedQuery (view) entity privileges

The following table lists the default privileges for the SavedQuery entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreateQuery | {371F85F8-0D1B-4177-A790-550D371E91EC} | 1039 |  |  |  | x | CREATE | G | G | G |  |  | G | G | G |  | G | G |  | G |  |
prvDeleteQuery | {7389889C-4149-4f74-86F6-12C2A9CC577B} | 1039 |  |  |  | x | DELETE | G | G | G |  |  | G |  | G |  | G | G |  | G |  |
prvReadQuery | {902D70D3-2FF8-4d93-92F9-8EFDCF889AF8} | 1039 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteQuery | {ECE4C21D-060A-4e86-982B-F97410CA5F71} | 1039 |  |  |  | x | WRITE | G | G | G |  |  | G | G | G |  | G | G |  | G |  |

See Also

Reference

Access Levels

Concepts

SavedQuery (view) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SavedQueryVisualization (system chart) entity privileges

The following table lists the default privileges for the SavedQueryVisualization entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreateSavedQueryVisualizations | {9A9FD681-A0D5-432c-910D-F2B2C80EA6D0} | 1111 |  |  |  | x | CREATE | G | G | G |  |  | G | G | G |  | G | G |  | G |  |
prvDeleteSavedQueryVisualizations | {D0930E05-6240-4fb4-BD62-3846F80AC112} | 1111 |  |  |  | x | DELETE | G | G | G |  |  | G |  | G |  | G | G |  | G |  |
prvReadSavedQueryVisualizations | {575B9A8F-46DA-4fb5-B014-51A689B003F0} | 1111 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteSavedQueryVisualizations | {B901446B-B31B-4dbc-A23B-E812517FFDDC} | 1111 |  |  |  | x | WRITE | G | G | G |  |  | G | G | G |  | G | G |  | G |  |

See Also

Reference

Access Levels

Concepts

SavedQueryVisualization (system chart) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessage entity privileges

The following table lists the default privileges for the SdkMessage entity.

Privilege name | GUID | entity | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreateSdkMessage | {303DEF1C-947C-4af3-A63B-406A7ABC72DE} | SdkMessage | 4606;4607;4609;4610;4611;4613;4614 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvDeleteSdkMessage | {8F9B0745-2842-45b6-A306-EAB47F138C7A} | SdkMessage | 4606;4607;4609;4610;4611;4613;4614 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvReadSdkMessage | {94C3AC2C-EB23-41cb-A903-4E2E49E910B4} | SdkMessage | 4606;4607;4609;4610;4611;4613;4614 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteSdkMessage | {6EBC7C4C-FDE7-424c-842E-11651498A9B3} | SdkMessage | 4606;4607;4609;4610;4611;4613;4614 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |

See Also

Reference

Access Levels

Concepts

SdkMessage entity messages and methods
Plug-in registration entities

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessageFilter entity privileges

There are no specific privileges for the SdkMessageFilter entity.

See Also

Reference

Access Levels

Concepts

SdkMessageFilter entity messages and methods
Plug-in registration entities

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessageProcessingStep entity privileges

The following table lists the default privileges SdkMessageProcessingStep entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreateSdkMessageProcessingStep | {998329E9-5CE5-4538-99B1-983191899A8B} | 4608 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvDeleteSdkMessageProcessingStep | {25CA2AFD-E85D-4a14-BB81-C368CD59BF5B} | 4608 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadSdkMessageProcessingStep | {DB10A828-EC49-4035-8B7E-C58EFAF169EC} | 4608 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteSdkMessageProcessingStep | {072AEE35-581D-4488-85B1-AF09926FDA70} | 4608 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

SdkMessageProcessingStep entity messages and methods
Plug-in registration entities

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessageProcessingStepSecureConfig entity privileges

The following table lists the default privileges for the SdkMessageProcessingStepSecureConfig entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreateSdkMessageProcessingStepSecureConfig | {1BD35330-06E3-4495-8C8D-BAABF5F0208A} | 4616 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvDeleteSdkMessageProcessingStepSecureConfig | {E63E21E5-C2AF-4807-B5CA-78F257FC007F} | 4616 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadSdkMessageProcessingStepSecureConfig | {A629BCA1-FEFB-4b4c-A4E2-3401EFF833D4} | 4616 |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  | G |  | G
prvWriteSdkMessageProcessingStepSecureConfig | {51AA61B6-C2F7-4bd7-BE1E-5EA0F3AF463F} | 4616 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

SdkMessageProcessingStepSecureConfiguration entity messages and methods
Plug-in registration entities

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SdkMessageProcessingStepImage entity privileges

The following table lists the default privileges for the SdkMessageProcessingStepImage entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreateSdkMessageProcessingStepImage | {65171D1B-1581-4FBB-96A3-95D14B5723CB} | 4615 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvDeleteSdkMessageProcessingStepImage | {5EBF516C-E769-47DF-AD46-458B4B23603F} | 4615 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadSdkMessageProcessingStepImage | {122E085F-8C52-47E8-8415-875DEE1C961E} | 4615 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteSdkMessageProcessingStepImage | {11954A66-B7AD-4DD9-B845-225D1B4C9FFE} | 4615 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

SdkMessageProcessingStepImage entity messages and methods
Plug-in registration entities

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SemiAnnualFiscalCalendar entity privileges

There are no specific privileges for the SemiAnnualFiscalCalendar entity.

See Also

Reference

Access Levels

Concepts

SemiAnnualFiscalCalendar entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Service entity privileges

The following table lists the default privileges for the Service entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendService | {6DF05F16-C7CD-4C24-A306-C5D43311D189} | 4001 |  |  |  | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G |  |  |
prvAppendToService | {39BDC280-2F57-4387-9F7A-D1D05527A705} | 4001;4002;4006;4005;4007 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G |  |
prvCreateService | {8E28F1E3-F63E-4a02-B0C8-9F130EC5B3FF} | 4001;4002;4006;4005;4007 |  |  |  | x | CREATE | G |  |  |  |  |  |  | G | G |  |  |  |  |  |
prvDeleteService | {72D802A8-97BF-4b01-B5BF-EDEEDE5AB71C} | 4001;4002;4006;4005;4007 |  |  |  | x | DELETE | G |  |  |  |  |  |  | G | G |  |  |  |  |  |
prvReadService | {CA4A3B9F-6887-4b5d-90F4-E918ED17E175} | 4001;4002;4006;4005;4007 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteService | {4AB2E389-ECA5-42b9-AD4B-7893867BA1DE} | 4001;4002;4006;4005;4007 |  |  |  | x | WRITE | G |  |  |  |  |  |  | G | G |  |  |  | G |  |

See Also

Reference

Access Levels

Concepts

Service entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ServiceAppointment (service activity) entity privileges

The ServiceAppointment entity uses the same privileges as all activity entities. For more information, see ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

ServiceAppointment entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ServiceEndpoint entity privileges

The following table lists the default privileges for the ServiceEndpoint entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreateServiceEndpoint | {C8F9248E-3C2D-42FB-B43C-C02EF857F4C0} | 4618 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvDeleteServiceEndpoint | {72CFF9A3-4772-4E16-8760-A29937521192} | 4618 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |
prvReadServiceEndpoint | {D86523D6-5946-4DDB-8176-4778116F8213} | 4618 |  |  |  | x | READ |  |  |  |  |  |  |  | G |  |  |  |  | G |  | G
prvWriteServiceEndpoint | {AD0EDD87-A785-4352-94C1-00C555E49696} | 4618 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

ServiceEndpoint entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SharePointDocumentLocation (document location) entity privileges

The following table lists the default privileges for the SharePointDocumentLocation entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendSharePointDocumentLocation | {DF5728A1-5711-42f3-A53A-EF67A78A8EDB} | 9508 |  |  |  | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvAppendToSharePointDocumentLocation | {9C24B468-D34B-4775-8CEA-0F686DBE254F} | 9508 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvAssignSharePointDocumentLocation | {0C2BC1AF-0AF7-4c66-A58D-40F445A9B304} | 9508 | x | x | x | x | ASSIGN | G | G | G | G | G | G | G | G | G | G | G | G | B |  |
prvCreateSharePointDocumentLocation | {ADF73427-A7E1-439e-B123-2E9BF47397AF} | 9508 |  |  |  | x | CREATE | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvDeleteSharePointDocumentLocation | {11B84628-1082-414a-B2F3-D3FEE69F7A73} | 9508 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvReadSharePointDocumentLocation | {0BE92B57-E93B-418e-B60D-73812C930F9B} | 9508 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvShareSharePointDocumentLocation | {272AA047-34F9-4EB8-B006-CE01ACCE46C9} | 9508 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | B |  |
prvWriteSharePointDocumentLocation | {65D13D58-C084-49c6-838D-292605744D7A} | 9508 |  |  |  | x | WRITE | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G

See Also

Reference

Access Levels

Concepts

SharePointDocumentLocation entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SharePointSite entity privileges

The following table lists the default privileges for the SharePointSite entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendSharePointSite | {3EB82A81-00AD-4f57-827B-EB98FFE3E1F5} | 9502 |  | x | x | x | APPEND |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvAppendToSharePointSite | {FAC6EA8E-DE45-41d0-A4E5-EA080A21F844} | 9502 |  | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvAssignSharePointSite | {A55F7336-B1A7-4c4a-B0E6-EE0225E0FDF6} | 9502 | x | x | x | x | ASSIGN | G | G | G | G | G | G | G | G | G | G | G | G | B |  |
prvCreateSharePointSite | {A4E95DF4-9C6B-44f6-AA6A-888B7EF12737} | 9502 |  | x | x | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvDeleteSharePointSite | {90B9EB7A-480B-45ff-BC9C-5354540D5834} | 9502 |  | x | x | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvReadSharePointSite | {93CAFD0D-DBE1-4cb9-BB7B-E9F3A0C0464A} | 9502 |  | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvShareSharePointSite | {1A17ED0E-4434-4B98-BB1E-6D1DF6952720} | 9502 | x | x | x | x | SHARE | G | G | G | G | G | G | G | G | G | G | G | G | B |  |
prvWriteSharePointSite | {967BA66E-6067-42e8-917F-34E8E798D08E} | 9502 |  | x | x | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |

See Also

Reference

Access Levels

Concepts

SharePointSite entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Site entity privileges

The following table lists the default privileges for the Site entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendToSite | {B7A1F52A-B8A9-11D8-84AB-0007E9E100CC} | 4009 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G |  |  |
prvCreateSite | {655E4282-B8A9-11D8-84AB-0007E9E100CC} | 4009 |  |  |  | x | CREATE | G |  |  |  |  |  |  | G | G |  |  |  |  |  |
prvDeleteSite | {AE81F6CA-B8A9-11D8-84AB-0007E9E100CC} | 4009 |  |  |  | x | DELETE | G |  |  |  |  |  |  | G | G |  |  |  |  |  |
prvReadSite | {98B5CCB2-B8A9-11D8-84AB-0007E9E100CC} | 4009 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteSite | {A46088CA-B8A9-11D8-84AB-0007E9E100CC} | 4009 |  |  |  | x | WRITE | G |  |  |  |  |  |  | G | G |  |  |  | G |  |

See Also

Reference

Access Levels

Concepts

Site entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SLA (service level agreement) entity privileges

The following table lists the default privileges for each security role for the SLA entity. For internal use only.

Privilege Name | Privilege Guid | Entity Name | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateSLA | {51072020-9ef9-4ce7-a041-551133380aa0} | SLA | 9750 | x | x | x | x | CREATE |  |  |  |  |  | L |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadSLA | {9a06070d-af1d-4971-90c9-f64487eeeaac} | SLA | 9750 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvWriteSLA | {18cb6e9a-c172-4477-bf76-35700bdaf6f3} | SLA | 9750 | x | x | x | x | WRITE |  |  |  |  |  | G |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvAppendSLA | {542c4b91-2184-4d97-b54d-fc3a75b309f3} | SLA | 9750 | x | x | x | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvAppendToSLA | {efb9cb61-11ab-49cc-a783-14ce53bef3a7} | SLA | 9750 | x | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvDeleteSLA | {8e52032e-6bc6-482f-849c-02b0715dda2d} | SLA | 9750 | x | x | x | x | DELETE |  |  |  |  |  | D |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvShareSLA | {f3dea36a-1c40-4901-94e2-119491ad7563} | SLA | 9750 | x | x | x | x | SHARE | B | B | B | B | B | G | B | G | B | B | B | B | G | B | B | x | x | x | x | x | x
prvAssignSLA | {14763ebb-b31c-475d-b841-210b301ecdf8} | SLA | 9750 | x | x | x | x | ASSIGN | B | B | B | B | B | G | B | G | B | B | B | B | G | B | B | x | x | x | x | x | x

See Also

Reference

Access Levels

Concepts

SocialProfile entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SLAKPIInstance (SLA KPI instance) entity privileges

The following table lists the default privileges for each security role for the SLAKPIInstance entity.

Privilege Name | GUID | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateSLAKPIInstance | {9ECD69F9-9ECF-4621-A9C4-CC381D33D6EC} | x | x | x | x | CREATE |  |  |  |  |  | L |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadSLAKPIInstance | {0CC19B7E-5AA8-4A21-854D-8160FD04F723} | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvWriteSLAKPIInstance | {A88B8013-8208-4EA4-A298-B3125F423F5F} | x | x | x | x | WRITE |  |  |  |  |  | G |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvAppendSLAKPIInstance | {96A5B102-5364-441C-B019-202150DEFB5F} | x | x | x | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvAppendToSLAKPIInstance | {2BF2B3C3-FD63-4FFA-970B-BD9888DE6079} | x | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G | G | G | x | x | x | x | x | x
prvDeleteSLAKPIInstance | {E45E3DD7-F10D-4EA4-8C08-36F17D4DE3FC} | x | x | x | x | DELETE |  |  |  |  |  | L |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvShareSLAKPIInstance | {7B76DAE5-C35B-4205-94BC-F9160996F729} | x | x | x | x | SHARE | B | B | B | B | B | G | B | G | B | B | B | B | G | B | B | x | x | x | x | x | x
prvAssignSLAKPIInstance | {82169890-53A4-43BA-BD9A-448F2BEA7D61} | x | x | x | x | ASSIGN | B | B | B | B | B | G | B | G | B | B | B | B | G | B | B | x | x | x | x | x | x

See Also

Concepts

SLAKPIInstance (SLA KPI instance) entity messages and methods

Other Resources

Service entities (contract, incident, knowledge base, queue, calendar, entitlement, slakpiinstance)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SocialActivity entity privileges

The following table lists the default privileges for each security role for the SLA entity. For internal use only.

Content coming soon.

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SocialProfile entity privileges

The following table lists the default privileges for each security role for the SocialProfile entity.

PrivilegeName | Id | Type | CanBeBasic | CanBeDeep | CanBeGlobal | CanBeLocal
prvAppendSocialProfile | a343b99a-160e-4f00-9f75-ebebde049b00 | Append | True | True | True | True
prvAppendToSocialProfile | 23c1ea81-3af2-49f8-a6a2-34daa820d5c9 | AppendTo | True | True | True | True
prvAssignSocialProfile | 59437112-29f5-44f0-9a66-fd49d342f85d | Assign | True | True | True | True
prvCreateSocialProfile | d7189248-4087-451b-9caa-b832895b00c4 | Create | True | True | True | True
prvDeleteSocialProfile | f882cf1d-53e5-4151-8913-f4e8f31c8a33 | Delete | True | True | True | True
prvReadSocialProfile | d854952c-89df-431d-8a5c-cc0b653fd395 | Read | True | True | True | True
prvShareSocialProfile | 7a9ea0ea-23df-4ef1-a5a2-cd295e7a6397 | Share | True | True | True | True
prvWriteSocialProfile | 859a99c3-2966-47b4-aeb9-0895c0e2532d | Write | True | True | True | True

See Also

Reference

Access Levels

Concepts

SocialProfile entity messages and methods

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Solution entity privileges

The following table lists the default privileges for the Solution entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendSolution | {CCEA7FF5-5E26-4aed-94A4-FCC2D9733F3A} | 7100;7103 |  | x | x | x | APPEND |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvAppendToSolution | {A264EAAE-0C71-4370-99D9-4986B33BAB60} | 7100;7103 |  | x | x | x | APPENDTO |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvCreateSolution | {14DD992D-2858-4547-91E9-139CA92D3932} | 7100;7103 |  | x | x | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvDeleteSolution | {9EF73297-F404-4630-AD16-7340265C6D08} | 7100;7103 |  | x | x | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvReadSolution | {B64E92C8-5D2A-4052-A026-1B73EFF9CEBF} | 7100;7103 |  | x | x | x | READ |  |  |  |  |  |  |  | G |  |  |  |  | G |  | G
prvWriteSolution | {BFAB24A8-3987-40ec-9828-8CFA938EE756} | 7100;7103 |  | x | x | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |

See Also

Reference

Access Levels

Concepts

Solution entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SolutionComponent entity privileges

There are no specific privileges for the SolutionComponent entity.

See Also

Reference

Access Levels

Concepts

SolutionComponent entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Subject entity privileges

The following table lists the default privileges for the Subject entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendSubject | {828E7127-7F95-4cf6-9541-F95C79163E30} | 129 |  |  |  | x | APPEND | G | G |  |  |  | G |  | G | G | G |  | G |  |  |
prvAppendToSubject | {63A357A1-D923-467d-828E-9204E3E30F95} | 129 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvCreateSubject | {8668262A-942F-4089-AF7E-6EA2DEB6A80B} | 129 |  |  |  | x | CREATE | G | G |  |  |  | G |  | G | G | G |  | G |  |  |
prvDeleteSubject | {94D54374-1CA7-47a3-A0C8-73EC80434EE0} | 129 |  |  |  | x | DELETE | G | G |  |  |  | G |  | G | G | G |  | G |  |  |
prvReadSubject | {D5D40A46-B459-438b-941E-D55691BF0827} | 129 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteSubject | {DAE584F9-D69B-4b8b-AA38-E15E908D4FD2} | 129 |  |  |  | x | WRITE | G | G |  |  |  | G |  | G | G | G |  | G | G |  |

See Also

Reference

Access Levels

Concepts

Subject entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SyncAttributeMapping entity privileges

The following table lists the default privileges for each security role for the SyncAttributeMapping entity.

Content coming soon.

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SyncAttributeMappingProfile entity privileges

The following table lists the default privileges for each security role for the SyncAttributeMappingProfile entity.

Content coming soon.

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SystemForm entity privileges

The following table lists the default privileges for the SystemForm entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreateSystemForm | {1F7A9E8B-EE94-4eb6-8A57-435DBE8273CA} | 1030 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvDeleteSystemForm | {6F48CE3C-8A32-464c-9CD8-27287AD203E7} | 1030 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvReadSystemForm | {B9C59CEF-F5D1-46b4-8C3B-8A38906C8C0E} | 1030 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteSystemForm | {B849EFAC-ED24-4307-B797-AF057583CA67} | 1030 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |

See Also

Reference

Access Levels

Concepts

SystemForm (system dashboard) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SystemUser (user) entity privileges

The following table lists the default privileges for the SystemUser (user) entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendToUser | {3399E6D2-DD3C-4a14-8433-39C1ECA27AAA} | 8 |  | x | x | x | APPENDTO | G | D | D | L | L | D | L | G | G | D | D | G | L |  |
prvAppendUser | {84D66926-87D4-4489-B21A-451B01EC0C41} | 8 |  | x | x | x | APPEND | G | D | D | L | L | D | L | G | G | D | D | G | L |  |
prvAssignManager | {28C3A786-82A5-4ff6-8D54-4876DB4BA2F8} | 8 |  | x | x | x | NONE | G | D | D |  |  | D |  | G |  | D | D |  |  |  |
prvAssignTerritory | {D5B32FC2-2F74-486b-A2D5-7A2506D1E580} | 8 |  | x | x | x | NONE | G | D | D |  |  | D |  | G |  | D | D |  |  |  |
prvCreateUser | {0A3D4421-AF6D-42ED-B3C2-B51DEB73D1D5} | 8 |  | x | x | x | CREATE | G | D | L |  |  | L |  | G |  | D | L |  |  |  |
prvDisableUser | {095860D1-42DE-4EFC-8D53-4B60E74D3D26} | 8 |  | x | x | x | NONE | G | D | D |  |  | D |  | G |  | D | D |  |  |  |
prvReadUser | {76FAAD15-BC44-4F4D-84DC-DD1E1DDA74D9} | 8 |  | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvReparentUser | {2759A407-C37F-4955-AA64-05F44BB88402} | 8 |  | x | x | x | NONE | G | D | D |  |  | D |  | G |  | D | D |  |  |  |
prvWriteUser | {DBB088D1-C7B7-40E7-8728-FDEDB539319C} | 8 |  | x | x | x | WRITE | G | D | D |  |  | D |  | G | G | D | D |  | L |  |

See Also

Reference

Access Levels

Concepts

SystemUser (user) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SystemUserSyncMappingProfiles entity privileges

The following table lists the default privileges for each security role for the SystemUserSyncMappingProfiles entity.

Content coming soon.

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Task entity privileges

The Task entity uses the same privileges as all activity entities. For more information see ActivityPointer (activity) entity privileges.

See Also

Reference

Access Levels

Concepts

Task entity messages and methods
Task, fax, phone call, and letter activity entities

Other Resources

Privileges by entity
Security role and privilege reference
Activity entities

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Team entity privileges

The following table lists the privileges for the Team entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendTeam | {4E8A9D81-5A8B-4870-96C1-938FF19221B9} | 9 |  | x | x | x | APPEND | G | G | G |  |  | G |  | G | G | G | G |  |  |  |
prvAppendToTeam | {3CE923F7-8F8E-4288-A4BF-B96FD6A67436} | 9 |  | x | x | x | APPENDTO | G | G | G |  |  | G |  | G | G | G | G |  |  |  |
prvCreateTeam | {4807B998-6B4F-4D57-9CF6-515F50E43D79} | 9 |  | x | x | x | CREATE | G | D | L |  |  | L |  | G |  | D | L |  |  |  |
prvDeleteTeam | {A3AC3B6F-6D09-4230-9221-C8B9AB0ABF06} | 9 |  | x | x | x | DELETE | G | G | G |  |  | G |  | G |  | G | G |  |  |  |
prvReadTeam | {663D1920-56E1-4166-89F0-47F3330923A8} | 9 |  | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvReparentTeam | {E6672D30-ED9E-4A1D-847D-7B1D05CD12E2} | 9 |  | x | x | x | NONE | G | G | G |  |  | G |  | G |  | G | G |  |  |  |
prvWriteTeam | {5ADFB065-B9A6-4481-91D1-9D91F78BB30A} | 9 |  | x | x | x | WRITE | G | G | G |  |  | G |  | G |  | G | G |  |  |  |

See Also

Reference

Access Levels

Concepts

Team entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TeamSyncAttributeMappingProfiles entity privileges

The following table lists the default privileges for each security role for the TeamSyncAttributeMappingProfiles entity.

Content coming soon.

See Also

Reference

Access Levels

Other Resources

Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TeamTemplate entity privileges

There are no specific privileges for the TeamTemplate entity.

See Also

Reference

Access Levels

Concepts

TeamTemplate entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Template (email template) entity privileges

The following table lists the default privileges for the Template entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendEmailTemplate | {57444774-B24C-4684-A514-DFCAB252C331} | 2010 | x | x | x | x | APPEND | G | G | D | L | L | L | L | G | G | G | D | D | G |  |
prvAppendToEmailTemplate | {C7057B81-25B8-4940-9CED-EED842B712A5} | 2010 | x | x | x | x | APPENDTO | G | G | G |  |  | G |  | G | G | G | G | G | G |  |
prvAssignEmailTemplate | {17B31E5E-BC94-4967-B83F-C7049EB483DA} | 2010 | x | x | x | x | ASSIGN | G | G | D | L | L | L | L | G | G | G | D |  | B |  |
prvCreateEmailTemplate | {921DAC3C-3DC0-4f66-83C1-F4E6EA427A45} | 2010 | x | x | x | x | CREATE | G | D | L | B | B | L | B | G | G | D | L | D | G |  |
prvCreateOrgEmailTemplates | {01750F14-3320-49cc-A7D1-52502CDCD16D} | 2010 |  |  |  | x | NONE | G | G | G |  |  | G | G | G | G | G | G | G | G |  |
prvDeleteEmailTemplate | {FFE4299B-7978-4b50-A724-2317DB0D3949} | 2010 | x | x | x | x | DELETE | G | G | G | B | B | G | B | G | G | G | G | D | G |  |
prvReadEmailTemplate | {6C619DCA-E165-4baa-BA16-EF6F820A0E01} | 2010 | x | x | x | x | READ | G | G | G | G | L | G | G | G | G | G | G | G | G |  | G
prvShareEmailTemplate | {DF6A99AF-703C-47cb-80C6-74EB519AD453} | 2010 | x | x | x | x | SHARE | G | G | D | L |  |  | L | G | G | G | D |  | B |  |
prvWriteEmailTemplate | {F2CC25B1-BFCC-4f7c-A6C3-9A5FC386391A} | 2010 | x | x | x | x | WRITE | G | G | G | B | B | G | B | G | G | G | G | D | G |  |

See Also

Reference

Access Levels

Concepts

SolutionComponent entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Territory entity privileges

The following table lists the default privileges for the Territory entity.

Privilege name | GUID | entity | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendTerritory | {6B2C2C22-E876-4fee-B885-46DDA9AB5234} | Territory | 2013 |  |  |  | x | APPEND | G | G | G |  |  |  |  | G |  | G | G |  |  |  |
prvAppendToTerritory | {B9BB73F7-C659-4c9d-944A-F2AF1784D56A} | Territory | 2013 |  |  |  | x | APPENDTO | G | G | G |  |  |  |  | G |  | G | G |  |  |  |
prvCreateTerritory | {00DAF56C-9520-4777-98FF-DB27E5DAE5C4} | Territory | 2013 |  |  |  | x | CREATE | G | G | G |  |  |  |  | G |  | G | G |  |  |  |
prvDeleteTerritory | {5051AE4A-F1EA-412e-ACE1-F72FA7247C87} | Territory | 2013 |  |  |  | x | DELETE | G | G | G |  |  |  |  | G |  | G | G |  |  |  |
prvReadTerritory | {D2409739-F135-422e-966D-129351AA0CE7} | Territory | 2013 |  |  |  | x | READ | G | G | G | G | G | G | G | G |  | G | G |  | G |  | G
prvWriteTerritory | {D0C30FFD-AF29-427e-87AB-546C813E1D20} | Territory | 2013 |  |  |  | x | WRITE | G | G | G |  |  |  |  | G |  | G | G |  | G |  |

See Also

Reference

Access Levels

Concepts

Territory entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TimeZoneDefinition entity privileges

There are no specific privileges for the TimeZoneDefinition entity.

See Also

Reference

Access Levels

Concepts

TimeZoneDefinition entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TimeZoneLocalizedName entity privileges

There are no specific privileges for the TimeZoneLocalizedName entity.

See Also

Reference

Access Levels

Concepts

TimeZoneLocalizedName entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TimeZoneRule entity privileges

There are no specific privileges for the TimeZoneRule entity.

See Also

Reference

Access Levels

Concepts

TimeZoneRule entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TraceLog entity privileges

The following table lists the default privileges for each security role for the TraceLog entity. For internal use only.

Privilege name | prvCreateTraceLog | prvReadTraceLog | prvAppendTraceLog | prvAppendToTraceLog | prvDeleteTraceLog
GUID | {4C469BB2-F911-4099-A85F-D0976514A57A} | {6EA323AB-2E1E-414E-88F5-1F975B3069FD} | {66D74708-436A-43A9-933A-C762279063A1} | {4BC3F2C8-B4C5-47BE-99D8-AF008B6A7DAC} | {F74F757A-14A9-40CA-BB4C-DDE31C7F9D4F}
Basic depth (B) |  |  |  |  |
Local depth (L) |  |  |  |  |
Deep depth (D) |  |  |  |  |
Global Depth (G) | x | x | x | x | x
Corresponding Access Right | CREATE | READ | APPEND | APPENDTO | DELETE
CEO-Business Manager | G | G | G | G |
Vice President of Sales | G | G | G | G |
Sales Manager | G | G | G | G |
Salesperson | G | G | G | G |
Customer Service Representative | G | G | G | G |
CSR Manager | G | G | G | G |
Marketing Professional | G | G | G | G |
System Administrator | G | G | G | G | G
Schedule Manager | G | G | G | G |
Vice President of Marketing | G | G | G | G |
Marketing Manager | G | G | G | G |
Scheduler | G | G | G | G |
System Customizer | G | G | G | G |
Delegate |  |  |  |  |
Support User |  | G |  |  |
Admin Only License |  |  |  |  |
On-premise - Small Business | x | x | x | x | x
On-premise - Professional | x | x | x | x | x
On-premise - Enterprise | x | x | x | x | x
Live | x | x | x | x | x
Spla | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TransactionCurrency (currency) entity privileges

The following table lists the privileges for the TransactionCurrency entity.

Privilege name | GUID | entity | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendToTransactionCurrency | {516AE7ED-8EA7-4f6c-8B32-801BD09A4AAA} | TransactionCurrency | 9105 |  |  |  | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvAppendTransactionCurrency | {9CDB8389-B874-4d9a-AF5C-CE83CB44B838} | TransactionCurrency | 9105 |  |  |  | x | APPEND | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvCreateTransactionCurrency | {ACD42358-FFB6-40b1-9E95-4793BCE61EF3} | TransactionCurrency | 9105 |  |  |  | x | CREATE | G | G | G |  |  |  |  | G |  |  |  |  |  |  |
prvDeleteTransactionCurrency | {B7D32698-080E-4ecf-B1C9-E24A3B22C39D} | TransactionCurrency | 9105 |  |  |  | x | DELETE | G | G | G |  |  |  |  | G |  |  |  |  |  |  |
prvReadTransactionCurrency | {A84B6EB5-87EC-4574-B8C5-02C880AE3472} | TransactionCurrency | 9105 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteTransactionCurrency | {754AA1B0-8C77-47e9-B043-16CC496E38DA} | TransactionCurrency | 9105 |  |  |  | x | WRITE | G | G | G |  |  |  |  | G |  |  |  |  |  |  |

See Also

Reference

Access Levels

Concepts

TransactionCurrency (currency) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TransformationMapping entity privileges

There are no specific privileges for the TransformationMapping entity.

See Also

Reference

Access Levels

Concepts

TransformationMapping entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TransformationParameterMapping entity privileges

There are no specific privileges for the TransformationParameterMapping entity.

See Also

Reference

Access Levels

Concepts

TransformationParameterMapping entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UoM (unit) entity privileges

There are no specific privileges for the UoM (unit) entity.

See Also

Reference

Access Levels

Concepts

UoM (unit) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UoMSchedule (unit group) entity privileges

There are no specific privileges for the UoMSchedule (unit group) entity.

See Also

Reference

Access Levels

Concepts

UoMSchedule (unit group) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserEntityInstanceData entity privileges

The following table lists the privileges for the UserEntityInstanceData entity.

Privilege name | GUID | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateUserEntityInstanceData | {BB2D4DCB-AC8C-4d1a-A85B-E5B8D3FB968C} | 2501 | x |  |  |  | CREATE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |  | x | x | x | x | x | x
prvReadUserEntityInstanceData | {BB2D4DCB-BC8C-4d1a-A85B-E5B8D3FB968C} | 2501 | x |  |  |  | READ | B | B | B | B | B | B | B | B | B | B | B | B | B |  | B | x | x | x | x | x | x
prvWriteUserEntityInstanceData | {BB2D4DCB-CC8C-4d1a-A85B-E5B8D3FB968C} | 2501 | x |  |  |  | WRITE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |  | x | x | x | x | x | x
prvDeleteUserEntityInstanceData | {BB2D4DCB-DC8C-4d1a-A85B-E5B8D3FB968C} | 2501 | x |  |  |  | DELETE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |  | x | x | x | x | x | x
prvShareUserEntityInstanceData | {BB2D4DCB-EC8C-4d1a-A85B-E5B8D3FB968C} | 2501 | x |  |  |  | SHARE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |  | x | x | x | x | x | x
prvAssignUserEntityInstanceData | {BB2D4DCB-FC8C-4d1a-A85B-E5B8D3FB968C} | 2501 | x |  |  |  | ASSIGN | B | B | B | B | B | B | B | B | B | B | B | B | B |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Privileges by entity
Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserEntityUISettings entity privileges

The following table lists the privileges for the UserEntityUISettings entity.

Privilege name | GUID | Entity Name | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateUserEntityUISettings | {8D2AA266-8FEE-43a4-85E7-2AA1AAAB5259} | UserEntityUISettings | 2500 | x |  |  |  | CREATE | B | B | B | B | B | B | B | B | B | B | B | B | B |  | B | x | x | x | x | x | x
prvReadUserEntityUISettings | {8D2AA266-8FEE-43a4-85E7-2AA1AAAB525A} | UserEntityUISettings | 2500 | x |  |  |  | READ | B | B | B | B | B | B | B | B | B | B | B | B | B |  | B | x | x | x | x | x | x
prvWriteUserEntityUISettings | {8D2AA266-8FEE-43a4-85E7-2AA1AAAB525B} | UserEntityUISettings | 2500 | x |  |  |  | WRITE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |  | x | x | x | x | x | x
prvDeleteUserEntityUISettings | {8D2AA266-8FEE-43a4-85E7-2AA1AAAB525C} | UserEntityUISettings | 2500 | x |  |  |  | DELETE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |  | x | x | x | x | x | x
prvShareUserEntityUISettings | {8D2AA266-8FEE-43a4-85E7-2AA1AAAB525D} | UserEntityUISettings | 2500 | x |  |  |  | SHARE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |  | x | x | x | x | x | x
prvAssignUserEntityUISettings | {8D2AA266-8FEE-43a4-85E7-2AA1AAAB525E} | UserEntityUISettings | 2500 | x |  |  |  | ASSIGN | B | B | B | B | B | B | B | B | B | B | B | B | B |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserForm (user dashboard) entity privileges

The following table lists the privileges for the UserForm entity.

Privilege name | GUID | entity | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAssignUserForm | {CD6A8C1E-857D-461e-AD0B-303D5324582D} | UserForm | 1031 | x |  |  |  | ASSIGN | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvCreateUserForm | {16948710-D204-4d55-8CE0-66D84CD375FF} | UserForm | 1031 | x |  |  |  | CREATE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvDeleteUserForm | {748B62AE-B314-4c89-B417-16B85873697B} | UserForm | 1031 | x |  |  |  | DELETE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvReadUserForm | {F13B70C2-70A3-4f3b-BB50-986B475C003E} | UserForm | 1031 | x |  |  |  | READ | B | B | B | B | B | B | B | B | B | B | B | B | B |  | B
prvShareUserForm | {2D69E8C1-5B8D-49b7-8B3C-07B016D02A4B} | UserForm | 1031 | x |  |  |  | SHARE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvWriteUserForm | {37F82CE8-A228-4de2-8B89-A7165FAD6B96} | UserForm | 1031 | x |  |  |  | WRITE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |

See Also

Reference

Access Levels

Concepts

UserForm (user dashboard) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserQuery (saved view) entity privileges

The following table lists the privileges for the UserQuery (saved view) entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAssignUserQuery | {D2A1330E-6EEF-4c7a-8074-11636D728915} | 4230 | x |  |  |  | ASSIGN | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvCreateUserQuery | {6EC3C27F-73FD-40a2-8E42-CDD129A59845} | 4230 | x |  |  |  | CREATE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvDeleteUserQuery | {9F128840-94D4-4b7d-A592-98365E3F4987} | 4230 | x |  |  |  | DELETE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvReadUserQuery | {F3B782A2-E6D5-4b86-9B7D-33F627FE5C5D} | 4230 | x |  |  |  | READ | B | B | B | B | B | B | B | B | B | B | B | B | B |  | B
prvShareUserQuery | {0437CA80-43DF-4fdb-ACC5-6B5B24618586} | 4230 | x |  |  |  | SHARE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvWriteUserQuery | {F4875CDF-C281-484b-BB7D-7E2ABFFCF3C9} | 4230 | x |  |  |  | WRITE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |

See Also

Reference

Access Levels

Concepts

UserQuery (saved view) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserQueryVisualization (user chart) entity privileges

The following table lists the privileges for the UserQueryVisualization (user chart) entity.

Privilege name | GUID | entity | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAssignUserQueryVisualizations | {96567926-A9D7-42f8-9AEE-F4E325D1A143} | UserQueryVisualizations | 1112 | x |  |  |  | ASSIGN | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvCreateUserQueryVisualizations | {183EE0BD-3D03-498f-839B-338EB3CA2CC8} | UserQueryVisualizations | 1112 | x |  |  |  | CREATE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvDeleteUserQueryVisualizations | {C3C3314F-077B-4d49-9519-CDB6CA7BE092} | UserQueryVisualizations | 1112 | x |  |  |  | DELETE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvReadUserQueryVisualizations | {D68CB29D-2243-41d1-B5A8-EE24DC885140} | UserQueryVisualizations | 1112 | x |  |  |  | READ | B | B | B | B | B | B | B | B | B | B | B | B | B |  | B
prvShareUserQueryVisualizations | {6FB5FF08-C339-47ca-B027-CC9FEB6151DC} | UserQueryVisualizations | 1112 | x |  |  |  | SHARE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |
prvWriteUserQueryVisualizations | {85F4EBC1-4B11-4809-AD5E-FC874262BDE4} | UserQueryVisualizations | 1112 | x |  |  |  | WRITE | B | B | B | B | B | B | B | B | B | B | B | B | B |  |

See Also

Reference

Access Levels

Concepts

UserQueryVisualization (user chart) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UserSettings entity privileges

The following table lists the privileges for the UserSettings entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendToUserSettings | {600DA2B2-8FCB-437f-8632-2DAC9B5F64E8} | 150 | x | x | x | x | APPENDTO | G | D | L | B | B | L | B | G | B | D | L | B |  |  |
prvCreateUserSettings | {E3AF716C-2B32-4e53-9554-24C36AA0A3AD} | 150 | x | x | x | x | CREATE | G | D | L | L | L | L | L | G | L | D | L | L | B |  |
prvDeleteUserSettings | {00BCB198-F3D8-4451-98A1-36642A084B8F} | 150 | x | x | x | x | DELETE | G | D | L | B | B | L | B | G | B | D | L | B |  |  |
prvReadUserSettings | {8437FA7C-3681-4fc7-BFD8-53A23FDECD65} | 150 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | B |  | G
prvWriteUserSettings | {588725DD-C878-41c5-A4C3-5EFC93CD3FFD} | 150 | x | x | x | x | WRITE | G | D | L | B | B | L | B | G | B | D | L | B | B |  |

See Also

Reference

Access Levels

Concepts

UserSettings entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WebResource entity privileges

The following table lists the privileges for the WebResource entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvCreateWebResource | {bd57cfa5-8495-4b3e-b358-da246ba797b5} | 9333 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvDeleteWebResource | {dcabe8b5-a6ab-4752-8fb9-c4d79dc2f393} | 9333 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |
prvReadWebResource | {4156db68-93e2-4a83-8cbb-5bb344ebaf47} | 9333 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvWriteWebResource | {04ae7442-d9a2-4f7c-9e5a-94219abbcb67} | 9333 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |

See Also

Reference

Access Levels

Concepts

WebResource entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WebWizard entity privileges

The following table lists the privileges for the WebWizard entity. For internal use only.

Privilege name | GUID | Entity Name | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateWebWizard | {9BAEF8E0-76F8-42aa-8D48-DA0582A0D7E7} | WebWizard | 4800 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadWebWizard | {D55D6EB9-D1E7-4ee9-A492-775015CF2F1F} | WebWizard | 4800 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
prvWriteWebWizard | {AFA371AC-1D2C-4b43-8026-A2055683E2D0} | WebWizard | 4800 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvDeleteWebWizard | {EEBF0DDC-D4F3-4f22-A19A-A158868D3FA6} | WebWizard | 4800 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WizardAccessPrivilege (web wizard access privilege) entity privileges

The following table lists the privileges for the WizardAccessPrivilege entity. For internal use only.

Privilege name | GUID | Entity Name | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateWizardAccessPrivilege | {FC0435ED-332A-459c-B1DD-4D037A560E94} | WizardAccessPrivilege | 4803 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadWizardAccessPrivilege | {6B4A9461-0105-4f4a-A047-FE1B4FEF02E7} | WizardAccessPrivilege | 4803 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
prvWriteWizardAccessPrivilege | {32CAC4BD-93BA-4db0-B3D8-7B2A96ADFF52} | WizardAccessPrivilege | 4803 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvDeleteWizardAccessPrivilege | {17A5FE9C-5981-48fb-81DB-F896BF113D15} | WizardAccessPrivilege | 4803 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WizardPage entity privileges

The following table lists the privileges for the WizardPage entity. For internal use only.

Privilege Name | GUID | Entity Name | Entity Object type code | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User | Admin Only License | On-premise - Small Business | On-premise - Professional | On-premise - Enterprise | Live | Spla
prvCreateWizardPage | {DC2393EA-4536-4da0-8BD3-A02DF9CDB3E6} | WizardPage | 4802 |  |  |  | x | CREATE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvReadWizardPage | {024CA4FF-65BD-4381-84A5-A531285E9CE1} | WizardPage | 4802 |  |  |  | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G | x | x | x | x | x | x
prvWriteWizardPage | {4E016DC5-719E-4f11-ABAA-3A131A3B18A2} | WizardPage | 4802 |  |  |  | x | WRITE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x
prvDeleteWizardPage | {828BD698-5B7D-47e4-A53D-5551CE989A7A} | WizardPage | 4802 |  |  |  | x | DELETE |  |  |  |  |  |  |  | G |  |  |  |  | G |  |  | x | x | x | x | x | x

See Also

Reference

Access Levels

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Workflow (process) entity privileges

The following table lists the privileges for the Workflow entity.

Privilege name | GUID | Entity type code(s) | Basic depth (B) | Local depth (L) | Deep depth (D) | Global Depth (G) | Corresponding Access Right | CEO-Business Manager | Vice President of Sales | Sales Manager | Salesperson | Customer Service Representative | CSR Manager | Marketing Professional | System Administrator | Schedule Manager | Vice President of Marketing | Marketing Manager | Scheduler | System Customizer | Delegate | Support User
prvAppendToWorkflow | {6F54CEA3-5B92-4507-952C-1E2430B7B1F9} | 4703 | x | x | x | x | APPENDTO | G | G | G | G | G | G | G | G | G | G | G | G | G |  |
prvAppendWorkflow | {71B53683-E781-471F-B9C4-CDCAF62A0CC5} | 4703 | x | x | x | x | APPEND | G | D | L | B | B | L | B | G | L | D | L | B | G |  |
prvAssignWorkflow | {D0CD3EA7-83CD-4769-9EF7-35398D2E1243} | 4703 | x | x | x | x | ASSIGN | G | D | L | B | B | L | B | G | L | D | L | B | G |  |
prvCreateWorkflow | {356F7A5A-5F9B-4A55-8398-B5732F6A08E5} | 4703 | x | x | x | x | CREATE | G | D | L | B | B | L | B | G | L | D | L | B | G |  |
prvDeleteWorkflow | {ED7E875D-9536-4D2C-A2F3-939A9D84F72C} | 4703 | x | x | x | x | DELETE | G | D | L | B | B | L | B | G | L | D | L | B | G |  |
prvReadWorkflow | {9D5E4741-3403-42D2-90B4-A561B3F94F52} | 4703 | x | x | x | x | READ | G | G | G | G | G | G | G | G | G | G | G | G | G |  | G
prvShareWorkflow | {501786BC-F127-4C56-A4DC-02CC0325117D} | 4703 | x | x | x | x | SHARE | G | D | L | B | B | L | B | G | L | D | L | B | G |  |
prvWriteWorkflow | {5F19703E-0B4A-451E-91E8-968929927820} | 4703 | x | x | x | x | WRITE | G | D | L | B | B | L | B | G | L | D | L | B | G |  |

See Also

Reference

Access Levels

Concepts

Workflow (process) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WorkflowLog (process log) entity privileges

There are no specific privileges for the WorkflowLog entity.

See Also

Reference

Access Levels

Concepts

WorkflowLog (process log) entity messages and methods

Other Resources

Privileges by entity
Security role and privilege reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Privileges by message

The following pages enumerate the maximum set of privileges needed for each message in the SDK. Note that for some messages the exact set of privileges needed depends on the entity types specified in the request. For more information about privileges and security in Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update, see The security model of Microsoft Dynamics CRM.

In This Section

AddItemCampaign message privileges

AddItemCampaignActivity message privileges

AddListMembersList message privileges

AddMemberList message privileges

AddMembersTeam message privileges

AddPrincipalToQueue message privileges

AddPrivilegesRole message privileges

AddProductToKit message privileges

AddRecurrence message privileges

AddSolutionComponent message privileges

AddSubstituteProduct message privileges

AddToQueue message privileges

AddUserToRecordTeam message privileges

ApplyRoutingRule message privileges

Assign message privileges

Associate message privileges

AutoMapEntity message privileges

BackgroundSendEmail message privileges

Book message privileges

BulkDelete message privileges

BulkDetectDuplicates message privileges

BulkOperationStatusClose message privileges

CalculateActualValueOpportunity message privileges

CalculateTotalTimeIncident message privileges

CanBeReferenced message privileges

CanBeReferencing message privileges

CancelContract message privileges

CancelSalesOrder message privileges

CanManyToMany message privileges

CheckIncomingEmail message privileges

CheckPromoteEmail message privileges

CleanUpBulkOperation message privileges

CloneContract message privileges

CloseIncident message privileges

CloseQuote message privileges

CompoundCreate message privileges

CompoundUpdate message privileges

CompoundUpdateDuplicateDetectionRule message privileges

ConvertKitToProduct message privileges

ConvertOwnerTeamToAccessTeam message privileges

ConvertProductToKit message privileges

ConvertQuoteToSalesOrder message privileges

ConvertSalesOrderToInvoice message privileges

CopyCampaign message privileges

CopyCampaignResponse message privileges

CopyDynamicListToStatic message privileges

CopyMembersList message privileges

CopySystemForm message privileges

Create message privileges

CreateActivitiesList message privileges

CreateAttribute message privileges

CreateEntity message privileges

CreateException message privileges

CreateInstance message privileges

CreateManyToMany message privileges

CreateOneToMany message privileges

CreateOptionSet message privileges

CreateWorkflowFromTemplate message privileges

Delete message privileges

DeleteAttribute message privileges

DeleteAuditData message privileges

DeleteEntity message privileges

DeleteOpenInstances message privileges

DeleteOptionSet message privileges

DeleteOptionValue message privileges

DeleteRelationship message privileges

DeliverIncomingEmail message privileges

DeliverPromoteEmail message privileges

DeprovisionLanguage message privileges

Disassociate message privileges

DistributeCampaignActivity message privileges

DownloadReportDefinition message privileges

ExecuteAsync message privileges

ExecuteByIdSavedQuery message privileges

ExecuteByIdUserQuery message privileges

ExecuteFetch message privileges

ExecuteWorkflow message privileges

ExpandCalendar message privileges

ExportMappingsImportMap message privileges

ExportSolution message privileges

ExportTranslation message privileges

FetchXmlToQueryExpression message privileges

FindParentResourceGroup message privileges

FulfillSalesOrder message privileges

GenerateInvoiceFromOpportunity message privileges

GenerateQuoteFromOpportunity message privileges

GenerateSalesOrderFromOpportunity message privileges

GenerateSocialProfile message privileges

GetAllTimeZonesWithDisplayName message privileges

GetDecryptionKey message privileges

GetDistinctValuesImportFile message privileges

GetHeaderColumnsImportFile message privileges

GetInvoiceProductsFromOpportunity message privileges

GetQuantityDecimal message privileges

GetQuoteProductsFromOpportunity message privileges

GetReportHistoryLimit message privileges

GetSalesOrderProductsFromOpportunity message privileges

GetTimeZoneCodeByLocalizedName message privileges

GetTrackingTokenEmail message privileges

GetValidManyToMany message privileges

GetValidReferencedEntities message privileges

GetValidReferencingEntities message privileges

GrantAccess message privileges

ImportMappingsImportMap message privileges

ImportRecordsImport message privileges

ImportSolution message privileges

ImportTranslation message privileges

InitializeFrom message privileges

InsertOptionValue message privileges

InsertStatusValue message privileges

InstallSampleData message privileges

InstantiateFilters message privileges

InstantiateTemplate message privileges

IsBackOfficeInstalled message privileges

IsComponentCustomizable message privileges

IsDataEncryptionActive message privileges

IsValidStateTransition message privileges

LocalTimeFromUtcTime message privileges

LockInvoicePricing message privileges

LockSalesOrderPricing message privileges

LogFailureBulkOperation message privileges

LogSuccessBulkOperation message privileges

LoseOpportunity message privileges

MakeAvailableToOrganizationReport message privileges

MakeAvailableToOrganizationTemplate message privileges

MakeUnavailableToOrganizationReport message privileges

MakeUnavailableToOrganizationTemplate message privileges

Merge message privileges

ModifyAccess message privileges

OrderOption message privileges

ParseImport message privileges

PickFromQueue message privileges

ProcessInboundEmail message privileges

ProcessOneMemberBulkOperation message privileges

PropagateByExpression message privileges

ProvisionLanguage message privileges

PublishAllXml message privileges

PublishDuplicateRule message privileges

PublishXml message privileges

QualifyLead message privileges

QualifyMemberList message privileges

QueryExpressionToFetchXml message privileges

QueryMultipleSchedules message privileges

QuerySchedule message privileges

ReassignObjectsOwner message privileges

ReassignObjectsSystemUser message privileges

Recalculate message privileges

ReleaseToQueue message privileges

RemoveFromQueue message privileges

RemoveItemCampaign message privileges

RemoveItemCampaignActivity message privileges

RemoveMemberList message privileges

RemoveMembersTeam message privileges

RemoveParent message privileges

RemovePrivilegeRole message privileges

RemoveProductFromKit message privileges

RemoveRelated message privileges

RemoveSolutionComponent message privileges

RemoveSubstituteProduct message privileges

RemoveUserFromRecordTeam message privileges

RenewContract message privileges

RenewEntitlement message privileges

ReplacePrivilegesRole message privileges

Reschedule message privileges

ResetUserFilters message privileges

Retrieve message privileges

RetrieveAbsoluteAndSiteCollectionUrl message privileges

RetrieveAllChildUsersSystemUser message privileges

RetrieveAllEntities message privileges

RetrieveAllManagedProperties message privileges

RetrieveAllOptionSets message privileges

RetrieveApplicationRibbon message privileges

RetrieveAttribute message privileges

RetrieveAttributeChangeHistory message privileges

RetrieveAuditDetails message privileges

RetrieveAuditPartitionList message privileges

RetrieveAvailableLanguages message privileges

RetrieveBusinessHierarchyBusinessUnit message privileges

RetrieveByGroupResource message privileges

RetrieveByResourceResourceGroup message privileges

RetrieveByResourcesService message privileges

RetrieveByTopIncidentProductKbArticle message privileges

RetrieveByTopIncidentSubjectKbArticle message privileges

RetrieveDependenciesForDelete message privileges

RetrieveDependenciesForUninstall message privileges

RetrieveDependentComponents message privileges

RetrieveDeploymentLicenseType message privileges

RetrieveDeprovisionedLanguages message privileges

RetrieveDuplicates message privileges

RetrieveEntity message privileges

RetrieveEntityRibbon message privileges

RetrieveExchangeRate message privileges

RetrieveFilteredForms message privileges

RetrieveFormattedImportJobResults message privileges

RetrieveFormXml message privileges

RetrieveInstalledLanguagePacks message privileges

RetrieveInstalledLanguagePackVersion message privileges

RetrieveLicenseInfo message privileges

RetrieveLocLabels message privileges

RetrieveManagedProperty message privileges

RetrieveMembersBulkOperation message privileges

RetrieveMembersTeam message privileges

RetrieveMissingComponents message privileges

RetrieveMissingDependencies message privileges

RetrieveMultiple message privileges

RetrieveOptionSet message privileges

RetrieveOrganizationResources message privileges

RetrieveParentGroupsResourceGroup message privileges

RetrieveParsedDataImportFile message privileges

RetrievePersonalWall message privileges

RetrievePrincipalAccess message privileges

RetrievePrincipalAttributePrivileges message privileges

RetrievePrivilegeSet message privileges

RetrieveProvisionedLanguagePackVersion message privileges

RetrieveProvisionedLanguages message privileges

RetrieveRecordChangeHistory message privileges

RetrieveRecordWall message privileges

RetrieveRelationship message privileges

RetrieveRequiredComponents message privileges

RetrieveRolePrivilegesRole message privileges

RetrieveSharedPrincipalsAndAccess message privileges

RetrieveDataEncryptionKey message privileges

RetrieveSubGroupsResourceGroup message privileges

RetrieveSubsidiaryTeamsBusinessUnit message privileges

RetrieveSubsidiaryUsersBusinessUnit message privileges

RetrieveTeamPrivileges message privileges

RetrieveTeamsSystemUser message privileges

RetrieveTimestamp message privileges

RetrieveUnpublished message privileges

RetrieveUnpublishedMultiple message privileges

RetrieveUserPrivileges message privileges

RetrieveUserQueues message privileges

RetrieveUserSettingsSystemUser message privileges

RetrieveVersion message privileges

ReviseQuote message privileges

RevokeAccess message privileges

Rollup message privileges

RouteTo message privileges

Search message privileges

SearchByBodyKbArticle message privileges

SearchByKeywordsKbArticle message privileges

SearchByTitleKbArticle message privileges

SendBulkMail message privileges

SendEmail message privileges

SendEmailFromTemplate message privileges

SendFax message privileges

SendTemplate message privileges

SetBusinessEquipment message privileges

SetBusinessSystemUser message privileges

SetLocLabels message privileges

SetParentBusinessUnit message privileges

SetParentSystemUser message privileges

SetParentTeam message privileges

SetRelated message privileges

SetReportRelated message privileges

SetDataEncryptionKey message privileges

SetState message privileges

StatusUpdateBulkOperation message privileges

TransformImport message privileges

TriggerServiceEndpointCheck message privileges

UninstallSampleData message privileges

UnlockInvoicePricing message privileges

UnlockSalesOrderPricing message privileges

UnpublishDuplicateRule message privileges

Update message privileges

UpdateAttribute message privileges

UpdateEntity message privileges

UpdateOptionSet message privileges

UpdateOptionValue message privileges

UpdateRelationship Privileges

UpdateStateValue message privileges

UpdateUserSettingsSystemUser message privileges

UtcTimeFromLocalTime message privileges

Validate message privileges

ValidateRecurrenceRule message privileges

ValidateSavedQuery message privileges

VerifyProcessStateData message privileges

WhoAmI message privileges

WinOpportunity message privileges

WinQuote message privileges

Related Sections

The security model of Microsoft Dynamics CRM

Security role UI to privilege mapping

Default privileges for a role

Privileges not associated with an entity

Privileges by entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddItemCampaign message privileges

The following table lists the privileges needed for the AddItemCampaignRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
campaign | prvAppendCampaign prvAppendList prvAppendProduct prvAppendSalesLiterature prvAppendToCampaign prvReadCampaign prvReadList prvReadProduct prvReadSalesLiterature

See Also

Concepts

List (marketing list) entity privileges
Campaign entity privileges

Other Resources

Privileges by message
AddItemCampaignRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddItemCampaignActivity message privileges

The following table lists the privileges needed for the AddItemCampaignActivityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
campaignactivity | prvAppendList prvAppendSalesLiterature prvAppendToActivity prvReadActivity prvReadList prvReadSalesLiterature

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

List (marketing list) entity privileges

Other Resources

Privileges by message
AddItemCampaignActivityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddListMembersList message privileges

The following table lists the privileges needed for the AddListMembersListRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
list | prvReadList prvReadContact prvAppendToList prvAppendContact

See Also

Concepts

List (marketing list) entity privileges
Contact entity privileges

Other Resources

Privileges by message
AddListMembersListRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddMemberList message privileges

The following table lists the privileges needed for the AddMemberListRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
list | prvAppendAccount prvAppendContact prvAppendLead prvAppendToList prvReadAccount prvReadContact prvReadLead prvReadList

See Also

Concepts

List (marketing list) entity privileges
Campaign entity privileges

Other Resources

Privileges by message
AddMemberListRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddMembersTeam message privileges

The following table lists the privileges needed for the AddMembersTeamRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
team | prvWriteTeam

See Also

Concepts

Team entity privileges

Other Resources

Privileges by message
AddMembersTeamRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddPrincipalToQueue message privileges

The following table lists the privileges needed for the AddPrincipalToQueueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
queue | prvWriteQueue

See Also

Concepts

Queue entity privileges
Queue entity messages and methods

Other Resources

Privileges by message
AddPrincipalToQueueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddPrivilegesRole message privileges

The following table lists the privileges needed for the AddPrivilegesRoleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
role | prvReadUser prvReadOrganization prvWriteRole prvReadRole

See Also

Concepts

SystemUser (user) entity privileges
Organization entity privileges
Role (security role) entity privileges

Other Resources

Privileges by message
AddPrivilegesRoleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddProductToKit message privileges

The following table lists the privileges needed for the AddProductToKitRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
product | prvAppendProduct prvAppendToProduct

See Also

Concepts

Product entity privileges

Other Resources

Privileges by message
AddProductToKitRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddRecurrence message privileges

The following table lists the privileges needed for the AddRecurrenceRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
recurringappointmentmaster | prvReadActivity prvCreateActivity prvShareActivity prvReadNote prvDeleteActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
AddRecurrenceRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddSolutionComponent message privileges

The following table lists the privileges needed for the AddSolutionComponentRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
solutioncomponent | prvReadSystemForm

See Also

Concepts

SystemForm entity privileges

Other Resources

Privileges by message
AddSolutionComponentRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddSubstituteProduct message privileges

The following table lists the privileges needed for the AddSubstituteProductRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
product | prvAppendProduct prvAppendToProduct

See Also

Concepts

Product entity privileges

Other Resources

Privileges by message
AddSubstituteProductRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddToQueue message privileges

The following table lists the privileges needed for the AddToQueueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
queueitem | prvAppendToQueue

See Also

Concepts

Queue entity privileges

Other Resources

Privileges by message
AddToQueueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AddUserToRecordTeam message privileges

The following table lists the privileges needed for the AddUserToRecordTeamRequest message. The exact set of privileges needed depends on the entity types specified in the request.

See Also

Other Resources

Privileges by message
Privileges by entity
AddUserToRecordTeamRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ApplyRoutingRule message privileges

The following table lists the privileges needed for the ApplyRoutingRuleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
incident | prvWriteIncident

See Also

Reference

RoutingRuleSet entity privileges

Concepts

Incident (case) entity messages and methods

Other Resources

Privileges by message
ApplyRoutingRuleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Assign message privileges

The following table lists the privileges needed for the AssignRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvAssignAccount
annotation | prvAssignNote
appointment | prvReadActivity
appointment | prvAssignActivity
campaign | prvAssignCampaign
campaignactivity | prvAssignActivity
campaignresponse | prvAssignActivity
connection | prvAssignConnection
contact | prvAssignContact
contract | prvAssignContract
customeropportunityrole | prvAssignCustomerOpportunityRole
customerrelationship | prvAssignCustomerRelationship
duplicaterule | prvAssignDuplicateRule
email | prvAssignActivity
fax | prvAssignActivity
goal | prvAssignGoal
goalrollupquery | prvAssignGoalRollupQuery
importmap | prvAssignImportMap
incident | prvAssignIncident
incidentresolution | prvAssignActivity
invoice | prvAssignInvoice
lead | prvAssignLead
letter | prvAssignActivity
list | prvAssignList
mailmergetemplate | prvAssignMailMergeTemplate
opportunity | prvAssignOpportunity
opportunityclose | prvAssignActivity
orderclose | prvAssignActivity
phonecall | prvAssignActivity
processsession | prvAssignWorkflowSession
queue | prvAssignQueue
quote | prvAssignQuote
quoteclose | prvAssignActivity
recurringappointmentmaster | prvAssignActivity
report | prvAssignReport
salesorder | prvAssignOrder
serviceappointment | prvAssignActivity
sharepointdocumentlocation | prvAssignSharePointDocumentLocation
sharepointsite | prvAssignSharePointSite
task | prvAssignActivity
template | prvAssignEmailTemplate
userform | prvAssignUserForm
userquery | prvAssignUserQuery
userqueryvisualization | prvAssignUserQueryVisualizations
workflow | prvReadWorkflow
workflow | prvAssignWorkflow

See Also

Other Resources

Privileges by message
Privileges by entity
AssignRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AssignUserRolesRole message privileges

Deprecated. For more information, see AssignUserRolesRole Privileges.

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Associate message privileges

The following table lists the privileges needed for the AssociateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Secondary Entity | Privilege
Any entity that is entity 1 in a many-to-many relationship. | Any entity that is entity 2 in a many-to-many relationship. | prvWritePrimaryEntity prvAppendPrimaryEntity prvSecondaryEntity

See Also

Other Resources

Privileges by message
AssociateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


AutoMapEntity message privileges

The following table lists the default privileges needed for the AutoMapEntityRequest message.

Privilege

prvReadEntityMap

prvReadAttributeMap

prvWriteRelationship

See Also

Reference

EntityMap Entity Privileges
AttributeMap entity privileges

Other Resources

Privileges by message
AutoMapEntityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BackgroundSendEmail message privileges

The following table lists the privileges needed for the BackgroundSendEmailRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
email | prvReadActivity
email | prvWriteActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
BackgroundSendEmailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Book message privileges

The following table lists the privileges needed for the BookRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
appointment | prvSearchAvailability
appointment | prvCreateActivity
appointment | prvShareActivity
recurringappointmentmaster | prvCreateActivity
recurringappointmentmaster | prvShareActivity
recurringappointmentmaster | prvSearchAvailability
serviceappointment | prvSearchAvailability

See Also

Reference

ActivityPointer (activity) entity privileges
Privileges not associated with an entity

Other Resources

Privileges by message
BookRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkDelete message privileges

The following table lists the privileges needed for the BulkDeleteRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvBulkDelete

prvDeleteEntity_Type_Being_Deleted

See Also

Reference

Privileges not associated with an entity

Other Resources

Privileges by message
Privileges by entity
BulkDeleteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkDetectDuplicates message privileges

The following table lists the privileges needed for the BulkDetectDuplicatesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvReadEntity_Type_Being_Detected

See Also

Other Resources

Privileges by message
Privileges by entity
BulkDetectDuplicatesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


BulkOperationStatusClose message privileges

The following table lists the privileges needed for the BulkOperationStatusCloseRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
bulkoperation | Content coming soon.

See Also

Reference

BulkOperation (quick campaign) entity privileges

Other Resources

Privileges by message
Privileges by entity
BulkOperationStatusCloseRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CalculateActualValueOpportunity message privileges

The following table lists privileges needed for the CalculateActualValueOpportunityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
opportunity | prvReadQuote

See Also

Concepts

Quote entity privileges

Other Resources

Privileges by message
Privileges by entity
CalculateActualValueOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CalculateTotalTimeIncident message privileges

The following table lists the privileges needed for the CalculateTotalTimeIncidentRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
incident | prvReadActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
CalculateTotalTimeIncidentRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CanBeReferenced message privileges

The following table lists the privileges needed for the CanBeReferencedRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvReadEntity_Type_Being_Used

See Also

Other Resources

Privileges by message
Privileges by entity
CanBeReferencedRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CanBeReferencing message privileges

The following table lists the privileges needed for the CanBeReferencingRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvReadEntity_Type_Being_Used

See Also

Other Resources

Privileges by message
Privileges by entity
CanBeReferencingRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CancelContract message privileges

The following table lists the privileges needed for the CancelContractRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
contract | prvReadContract prvWriteContract

See Also

Concepts

Contract entity privileges

Other Resources

Privileges by message
Privileges by entity
BulkDeleteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CancelSalesOrder message privileges

The following table lists the privileges needed for the CancelSalesOrderRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
salesorder | prvCreateActivity prvAppendToOrder prvAppendActivity prvWriteOrder

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

Contract entity privileges
SalesOrder (order) entity privileges

Other Resources

Privileges by message
Privileges by entity
CancelSalesOrderRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CanManyToMany message privileges

The following table lists the privileges needed for the CanManyToManyRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvReadEntity_Type_Being_Used

See Also

Other Resources

Privileges by message
Privileges by entity
CanManyToManyRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CheckIncomingEmail message privileges

The following table lists the privileges needed for the CheckIncomingEmailRequest message. The exact set of privileges needed depends on the entity types specified in the request.

PrimaryEntity | Privilege
email | prvReadActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
CheckIncomingEmailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CheckPromoteEmail message privileges

The following table lists the privileges needed for the CheckPromoteEmailRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
email | prvReadActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
CheckIncomingEmailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CleanUpBulkOperation message privileges

The following table lists the privileges needed for the CleanUpBulkOperationRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
bulkoperation | prvReadActivity prvReadCampaign prvWriteActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

Campaign entity privileges

Other Resources

Privileges by message
Privileges by entity
CleanUpBulkOperationRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CloneContract message privileges

The following table lists the default privileges needed for the CloneContractRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
contract | prvReadContract prvCreateContract prvAppendToContact prvAppendToContractTemplate prvAppendContract prvAppendToAccount prvAppendToContact prvWriteContract

See Also

Concepts

Contract entity privileges
ContractTemplate entity privileges

Other Resources

Privileges by message
Privileges by entity
CloneContractRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CloseIncident message privileges

The following table lists the privileges needed for the CloseIncidentRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
incident | prvCreateActivity prvAppendToIncident prvAppendActivity prvWriteIncident prvDeleteQueueItem prvReadActivity prvWriteActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

Incident (Case) entity privileges

Other Resources

Privileges by message
Privileges by entity
CloseIncidentRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CloseQuote message privileges

The following table lists the privileges needed for the CloseQuoteRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
quote | prvCreateActivity prvAppendToQuote prvAppendActivity prvWriteQuote

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

Quote entity privileges

Other Resources

Privileges by message
Privileges by entity
CloseQuoteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CompoundCreate message privileges

The following table lists the privileges needed for the CompoundCreateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
duplicaterule | prvAppendToDuplicateRule prvCreateDuplicateRule prvReadDuplicateRule
invoice | prvAppendInvoice prvAppendToAccount prvAppendToContact prvAppendToInvoice prvAppendToProduct prvCreateInvoice prvReadInvoice
quote | prvAppendQuote prvAppendToAccount prvAppendToProduct prvAppendToQuote prvCreateQuote prvReadQuote
salesorder | prvAppendOrder prvAppendToAccount prvAppendToContact prvAppendToOrder prvAppendToProduct prvCreateOrder

See Also

Reference

Account entity privileges

Concepts

Quote entity privileges
Product entity privileges
Invoice entity privileges
SalesOrder (order) entity privileges

Other Resources

Privileges by message
Privileges by entity
CompoundCreateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CompoundUpdate message privileges

The following table lists the privileges needed for the CompoundUpdateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
duplicaterule | prvAppendToDuplicateRule prvCreateDuplicateRule prvReadDuplicateRule prvWriteDuplicateRule
invoice | prvAppendInvoice prvAppendToAccount prvAppendToContact prvAppendToInvoice prvCreateInvoice prvReadInvoice prvWriteInvoice
quote | prvAppendQuote prvAppendToAccount prvAppendToContact prvAppendToQuote prvCreateQuote prvReadQuote prvWriteQuote
salesorder | prvAppendOrder prvAppendToAccount prvAppendToContact prvAppendToOrder prvCreateOrder prvReadOrder prvWriteOrder

See Also

Other Resources

Privileges by message
Privileges by entity
BulkDeleteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CompoundUpdateDuplicateDetectionRule message privileges

The following table lists the privileges needed for the CompoundUpdateDuplicateDetectionRuleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
duplicaterule | prvAppendToDuplicateRule prvCreateDuplicateRule prvReadDuplicateRule prvWriteDuplicateRule

See Also

Concepts

DuplicateRule (duplicate detection rule) entity privileges

Other Resources

Privileges by message
Privileges by entity
CompoundUpdateDuplicateDetectionRuleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConvertKitToProduct message privileges

The following table lists the privileges needed for the ConvertKitToProductRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
product | prvWriteProduct

See Also

Concepts

Product entity privileges

Other Resources

Privileges by message
Privileges by entity
ConvertKitToProductRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConvertOwnerTeamToAccessTeam message privileges

The following table lists the privileges needed for the ConvertOwnerTeamToAccessTeamRequest message. The exact set of privileges needed depends on the entity types specified in the request.

See Also

Other Resources

Privileges by message
Privileges by entity
ConvertOwnerTeamToAccessTeamRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConvertProductToKit message privileges

The following table lists the privileges needed for the ConvertProductToKitRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
product | prvWriteProduct

See Also

Concepts

Product entity privileges

Other Resources

Privileges by message
Privileges by entity
ConvertProductToKitRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConvertQuoteToSalesOrder message privileges

The following table lists the privileges needed for the ConvertQuoteToSalesOrderRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
quote | prvAppendOrder prvAppendToContact prvAppendToProduct prvAppendToQuote prvCreateOrder prvReadAttributeMap prvReadEntityMap prvReadOrder prvReadQuote

See Also

Concepts

Quote entity privileges
SalesOrder (order) entity privileges

Other Resources

Privileges by message
Privileges by entity
ConvertQuoteToSalesOrderRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ConvertSalesOrderToInvoice message privileges

The following table lists the privileges needed for the ConvertSalesOrderToInvoiceRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
salesorder | prvAppendInvoice prvAppendToAccount prvAppendToContact prvAppendToOrder prvAppendToProduct prvCreateInvoice prvReadInvoice prvReadOrder

See Also

Concepts

SalesOrder (order) entity privileges
Invoice entity privileges

Other Resources

Privileges by message
Privileges by entity
ConvertSalesOrderToInvoiceRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CopyCampaign message privileges

The following table lists the privileges needed for the CopyCampaignRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
campaign | prvAppendActivity prvAppendQueueItem prvAppendToAccount prvAppendToActivity prvAppendToCampaign prvAppendToContact prvCreateActivity prvCreateCampaign prvCreateQueueItem prvReadAccount prvReadActivity prvReadCampaign prvReadContact prvReadList prvReadProduct prvReadSalesLiterature

See Also

Concepts

Product entity privileges

Other Resources

Privileges by message
Privileges by entity
CopyCampaignRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CopyCampaignResponse message privileges

The following table lists the privileges needed for the CopyCampaignResponseRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
campaign | prvAppendActivity prvAppendToAccount prvAppendToActivity prvAppendToCampaign prvCreateActivity prvReadActivity

See Also

Concepts

Campaign entity privileges

Other Resources

Privileges by message
Privileges by entity
CopyCampaignResponseRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CopyDynamicListToStatic message privileges

The following table lists the privileges needed for the CopyDynamicListToStaticRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
list | Content coming soon.

See Also

Concepts

List (marketing list) entity privileges

Other Resources

Privileges by message
Privileges by entity
CopyDynamicListToStaticRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CopyMembersList message privileges

The following table lists the privileges needed for the CopyMembersListRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
list | prvAppendAccount prvAppendContact prvAppendLead prvAppendToList prvReadAccount prvReadContact prvReadLead prvReadList

See Also

Concepts

List (marketing list) entity privileges

Other Resources

Privileges by message
Privileges by entity
CopyMembersListRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CopySystemForm message privileges

The following table lists the privileges needed for the CopySystemFormRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
systemform | prvReadSystemForm

See Also

Concepts

SystemForm entity privileges

Other Resources

Privileges by message
Privileges by entity
CopySystemFormRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Create message privileges

The following table lists the privileges needed for the CreateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvCreateAccount prvOverrideCreatedOnCreatedBy
activitymimeattachment | prvReadActivity prvWriteActivity
activitypointer |
annotation | prvAppendNote prvAppendToList prvCreateNote
annualfiscalcalendar |
appointment | prvAppendActivity prvAppendToActivity prvCreateActivity prvShareActivity
asyncoperation | prvCreateAsyncOperation prvReadPluginAssembly prvReadPluginType prvReadSdkMessage prvReadSdkMessageProcessingStep prvReadSdkMessageProcessingStepImage
attributemap | prvReadAttributeMap prvReadEntityMap prvWriteRelationship
bulkoperation |
businessunit | prvAppendBusinessUnit prvAppendToBusinessUnit prvCreateBusinessUnit
businessunitnewsarticle | prvCreateNewsArticle
calendar | prvCreateCalendar
campaign | prvCreateCampaign
campaignactivity | prvAppendActivity prvAppendToCampaign prvCreateActivity prvReadCampaign
campaignresponse | prvAppendActivity prvAppendToCampaign prvCreateActivity
columnmapping | prvAppendToImportMap prvCreateImportMap
competitor | prvCreateCompetitor
connection | prvCreateConnection prvReadAccount prvReadContact prvWriteConnection
connectionrole | prvCreateConnectionRole
connectionroleobjecttypecode | prvAppendToConnectionRole prvCreateConnectionRole prvReadConnectionRole
constraintbasedgroup | prvCreateService
contact | prvCreateContact
contract | prvAppendContract prvAppendToContact prvAppendToContractTemplate prvCreateContract
contractdetail | prvAppendToContract prvCreateContract
contractdetail |
contracttemplate | prvCreateContractTemplate
customeraddress | prvReadAccount prvReadContact prvWriteAccount
customeropportunityrole | prvAppendCustomerOpportunityRole prvAppendToContact prvAppendToOpportunity prvCreateCustomerOpportunityRole prvReadCustomerOpportunityRole
customerrelationship | prvAppendCustomerRelationship prvAppendToAccount prvCreateCustomerRelationship prvWriteCustomerRelationship
discount | prvAppendToProduct prvCreateProduct prvReadProduct
discounttype | prvCreateProduct
displaystring |
duplicaterule | prvCreateDuplicateRule
duplicaterulecondition | prvAppendToDuplicateRule prvCreateDuplicateRule prvReadDuplicateRule
email | prvAppendActivity prvAppendToAccount prvAppendToActivity prvCreateActivity prvReadAccount prvReadUser
equipment | prvAppendEquipment prvAppendToCalendar prvCreateEquipment
fax | prvCreateActivity
fieldpermission | prvAppendToFieldSecurityProfile prvCreateFieldSecurityProfile
fieldpermission | prvReadFieldSecurityProfile
fieldsecurityprofile | prvCreateFieldSecurityProfile
fixedmonthlyfiscalcalendar |
goal | prvAppendGoal prvAppendToMetric prvAppendToUser prvCreateGoal
goalrollupquery | prvCreateGoalRollupQuery
import | prvCreateImport
importdata |
importentitymapping | prvAppendToImportMap prvCreateImportMap
importentitymapping |
importfile | prvAppendImportFile prvAppendToImport prvCreateImport prvReadUser
importjob |
importlog |
importmap | prvCreateImportMap
incident | prvAppendIncident prvAppendToAccount prvCreateIncident
incidentresolution | prvAppendActivity prvAppendToIncident prvCreateActivity
invoice | prvAppendInvoice prvAppendToAccount prvAppendToProduct prvCreateInvoice
invoicedetail | prvAppendToInvoice prvCreateInvoice
invoicedetail |
kbarticle | prvAppendToArticleTemplate prvAppendToSubject prvCreateArticle
kbarticlecomment | prvAppendToArticle prvCreateArticle prvCreateArticleTemplate
lead | prvCreateLead prvOverrideCreatedOnCreatedBy
letter | prvAppendActivity prvAppendToActivity prvCreateActivity
list | prvCreateList
lookupmapping | prvAppendToImportMap prvCreateImportMap
mailmergetemplate | prvCreateMailMergeTemplate prvPublishOrgMailMergeTemplate
metric | prvCreateMetric
monthlyfiscalcalendar |
opportunity | prvAppendOpportunity prvAppendToContact prvCreateOpportunity
opportunityclose | prvAppendActivity prvAppendToOpportunity prvCreateActivity
opportunityproduct | prvAppendToOpportunity prvCreateOpportunity
orderclose | prvAppendActivity prvAppendToOrder prvCreateActivity
ownermapping | prvAppendToImportMap prvCreateImportMap
phonecall | prvAppendActivity prvAppendToActivity prvAppendToLead prvCreateActivity
picklistmapping | prvAppendToImportMap prvCreateImportMap
pluginassembly | prvCreatePluginAssembly prvReadPluginAssembly prvReadUser
plugintype | prvCreatePluginType prvReadPluginAssembly prvReadPluginType
pricelevel | prvCreateProduct
principalobjectattributeaccess | prvAppendPrincipalObjectAttributeAccess prvAppendToContact prvAppendToUser prvCreatePrincipalObjectAttributeAccess
processsession | prvAppendToWorkflow prvAppendWorkflowSession prvCreateWorkflowSession prvReadAccount prvReadWorkflow
product | prvAppendProduct prvAppendToProduct prvCreateProduct
productpricelevel | prvAppendToProduct prvCreateProduct
publisher | prvCreatePublisher prvReadPublisher prvWritePublisher
quarterlyfiscalcalendar |
queue | prvCreateQueue
queueitem | prvAppendToQueue prvOverrideCreatedOnCreatedBy
quote | prvAppendQuote prvAppendToAccount prvAppendToProduct prvCreateQuote
quoteclose | prvAppendActivity prvAppendToQuote prvCreateActivity
quotedetail | prvAppendToQuote prvCreateQuote
quotedetail |
recurrencerule | prvCreateActivity
recurringappointmentmaster | prvAppendActivity prvAppendToActivity prvCreateActivity prvShareActivity
relationshiprole | prvCreateRelationshipRole
relationshiprolemap | prvAppendToRelationshipRole prvCreateRelationshipRole
relationshiprolemap |
report | prvCreateReport
reportcategory | prvAppendToReport prvCreateReport
reportcategory |
reportentity | prvAppendToReport prvCreateReport
reportentity |
reportlink |
reportvisibility | prvAppendToReport prvCreateReport
reportvisibility |
resourcespec | prvCreateService prvReadService
resourcespec |
role | prvCreateRole
rollupfield | prvAppendToMetric prvCreateMetric
rollupfield |
salesliterature | prvAppendSalesLiterature prvAppendToSubject prvCreateSalesLiterature
salesliteratureitem | prvAppendToSalesLiterature prvCreateSalesLiterature
salesliteratureitem |
salesorder | prvAppendOrder prvAppendToContact prvAppendToProduct prvCreateOrder
salesorderdetail | prvAppendToOrder prvCreateOrder
salesorderdetail |
savedquery | prvCreateQuery
savedqueryvisualization | prvCreateSavedQueryVisualizations prvReadSavedQueryVisualizations prvWriteSavedQueryVisualizations
sdkmessageprocessingstep | prvCreateSdkMessageProcessingStep prvReadPluginAssembly prvReadPluginType prvReadSdkMessage
sdkmessageprocessingstepimage | prvCreateSdkMessageProcessingStepImage prvReadSdkMessage prvReadSdkMessageProcessingStep
sdkmessageprocessingstepsecureconfig | prvCreateSdkMessageProcessingStepSecureConfig
semiannualfiscalcalendar |
service | prvAppendService prvAppendToService prvCreateService
serviceappointment | prvAppendActivity prvAppendToService prvCreateActivity prvShareActivity
serviceendpoint | prvCreateServiceEndpoint
sharepointdocumentlocation | prvReadSharePointSite
sharepointsite | prvCreateSharePointSite
site | prvCreateSite
sitemap |
solution | prvCreateSolution prvReadPublisher prvReadSolution prvWriteSolution
subject | prvCreateSubject
subscription |
systemform | prvCreateSystemForm prvReadCustomization prvReadSystemForm prvWriteSystemForm
systemuser | prvCreateUser prvCreateUserSettings prvReadBusinessUnit prvReadUser prvReadUserSettings
task | prvAppendActivity prvAppendToAccount prvCreateActivity
team | prvCreateTeam
template | prvCreateEmailTemplate prvCreateOrgEmailTemplates
territory | prvCreateTerritory
transactioncurrency | prvCreateTransactionCurrency
transformationmapping | prvAppendToImportMap prvCreateImportMap
transformationparametermapping | prvCreateImportMap
uom | prvAppendToProduct prvCreateProduct
uomschedule | prvAppendToProduct prvCreateProduct
userentityinstancedata | prvCreateUserEntityInstanceData
userentityuisettings | prvCreateUserEntityUISettings
userform | prvCreateUserForm
userquery | prvCreateUserQuery
userqueryvisualization | prvCreateUserQueryVisualizations
webresource | prvCreateWebResource prvReadWebResource
webwizard | prvCreateWebWizard
wizardaccessprivilege | prvCreateWizardAccessPrivilege
wizardpage | prvCreateWizardPage
workflow | prvCreateWorkflow
workflowdependency | prvAppendToWorkflow prvCreateWorkflow prvReadWorkflow
workflowlog | prvCreateAsyncOperation prvReadPluginAssembly prvReadPluginType prvReadSdkMessage prvReadSdkMessageProcessingStep prvReadSdkMessageProcessingStepImage

See Also

Concepts

Product entity privileges

Other Resources

Privileges by message
Privileges by entity
CreateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CreateActivitiesList message privileges

The following table lists the privileges needed for the CreateActivitiesListRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
list | prvAppendActivity prvAppendToList prvCreateActivity prvReadList

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

List (marketing list) entity privileges

Other Resources

Privileges by message
Privileges by entity
CreateActivitiesListRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CreateAttribute message privileges

The following table lists the privileges needed for the CreateAttributeRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvCreateAttribute

See Also

Other Resources

Privileges by message
Privileges by entity
CreateAttributeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CreateEntity message privileges

The following table lists the privileges needed for the CreateEntityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvCreateEntity

prvCreateQuery

prvCreateSdkMessage

prvCreateSdkMessageProcessingStep

prvCreateSystemForm

prvReadCustomization

prvReadPluginType

prvReadQuery

prvReadSdkMessage

prvReadSystemForm

prvWriteQuery

prvWriteSystemForm

See Also

Other Resources

Privileges by message
Privileges by entity
CreateEntityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CreateException message privileges

The following table lists the privileges needed for the CreateExceptionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
appointment | prvReadActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

RecurringAppointmentMaster entity privileges

Other Resources

Privileges by message
Privileges by entity
CreateExceptionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CreateInstance message privileges

The following table lists the privileges needed for the CreateInstanceRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
recurringappointmentmaster | prvReadActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
CreateInstanceRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CreateManyToMany message privileges

The following table lists the privileges needed for the CreateManyToManyRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvReadQuery

See Also

Other Resources

Privileges by message
Privileges by entity
CreateManyToManyRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CreateOneToMany message privileges

The following table lists the privileges needed for the CreateOneToManyRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvCreateRelationship

prvReadEntityMap

prvReadQuery

prvWriteRelationship

See Also

Other Resources

Privileges by message
Privileges by entity
CreateOneToManyRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CreateOptionSet message privileges

The following table lists the privileges needed for the CreateOptionSetRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvCreateOptionSet

See Also

Other Resources

Privileges by message
Privileges by entity
CreateOptionSetRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CreateWorkflowFromTemplate message privileges

The following table lists the privileges needed for the CreateWorkflowFromTemplateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
workflow | prvCreateWorkflow prvReadWorkflow

See Also

Concepts

Workflow (process) entity privileges

Other Resources

Privileges by message
CreateWorkflowFromTemplateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Delete message privileges

The following table lists the privileges needed for the DeleteRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvDeleteAccount
activitymimeattachment | prvReadActivity prvAppendToActivity
annotation | prvDeleteNote
appointment | prvDeleteActivity prvReadActivity
asyncoperation | prvDeleteAsyncOperation prvReadAsyncOperation
attributemap | prvReadAttributeMap
bulkoperation | prvDeleteActivity
businessunit | prvDeleteBusinessUnit
businessunitnewsarticle | prvDeleteNewsArticle
calendar | prvDeleteCalendar prvReadOrganization
campaign | prvDeleteCampaign
campaignactivity | prvDeleteActivity
campaignresponse | prvDeleteActivity
columnmapping | prvAppendToImportMap
competitor | prvDeleteCompetitor
connection | prvDeleteConnection
connectionrole | prvDeleteConnectionRole
connectionroleobjecttypecode | prvAppendToConnectionRole prvReadConnectionRole
constraintbasedgroup | prvDeleteService
contact | prvDeleteContact
contract | prvDeleteContract
contractdetail | prvAppendToContract
contracttemplate | prvDeleteContractTemplate
customeraddress | prvDeleteAccount prvReadAccount
customeropportunityrole | prvDeleteCustomerOpportunityRole
customerrelationship | prvDeleteCustomerRelationship
discount | prvAppendToProduct
discounttype | prvDeleteProduct
displaystring |
duplicaterule | prvAppendToDuplicateRule prvDeleteDuplicateRule prvPublishDuplicateRule prvReadDuplicateRule
duplicaterulecondition | prvReadDuplicateRule
email | prvDeleteActivity prvReadActivity
equipment | prvDeleteEquipment
fax | prvDeleteActivity
fieldpermission | prvAppendToFieldSecurityProfile prvReadFieldSecurityProfile
fieldsecurityprofile | prvDeleteFieldSecurityProfile
goal | prvDeleteGoal
goalrollupquery | prvDeleteGoalRollupQuery
import | prvDeleteImport
importfile | prvAppendToImport prvDeleteImport
importjob | prvDeleteImportJob
importmap | prvDeleteImportMap
incident | prvDeleteIncident
incidentresolution | prvDeleteActivity
invoice | prvDeleteInvoice
invoicedetail | prvAppendToInvoice
kbarticle | prvDeleteArticle
kbarticlecomment | prvAppendToArticle
kbarticletemplate | prvDeleteArticleTemplate
lead | prvDeleteLead
letter | prvDeleteActivity
list | prvDeleteList
lookupmapping | prvAppendToImportMap
mailmergetemplate | prvDeleteMailMergeTemplate
metric | prvDeleteMetric
opportunity | prvDeleteOpportunity
opportunityclose | prvDeleteActivity
opportunityproduct | prvAppendToOpportunity
orderclose | prvDeleteActivity
ownermapping | prvAppendToImportMap
phonecall | prvDeleteActivity
picklistmapping | prvAppendToImportMap
pluginassembly | prvDeletePluginAssembly prvReadPluginAssembly prvReadUser
plugintype | prvDeletePluginType prvReadPluginType
pricelevel | prvDeleteProduct
principalobjectattributeaccess | prvDeletePrincipalObjectAttributeAccess
processsession | prvDeleteWorkflowSession
product | prvDeleteProduct
productpricelevel | prvAppendToProduct
publisher | prvDeletePublisher
queue | prvDeleteQueue
quote | prvDeleteQuote
quoteclose | prvDeleteActivity
quotedetail | prvAppendToQuote
recurrencerule | prvDeleteActivity prvReadActivity
recurringappointmentmaster | prvDeleteActivity prvReadActivity
relationshiprole | prvDeleteRelationshipRole
relationshiprolemap | prvAppendToRelationshipRole
report | prvDeleteReport
reportcategory | prvAppendToReport
reportentity | prvAppendToReport
reportvisibility | prvAppendToReport
resourcespec | prvDeleteService
role | prvDeleteRole
role | prvReadRole
rollupfield | prvAppendToMetric prvReadMetric
salesliterature | prvDeleteSalesLiterature
salesliteratureitem | prvAppendToSalesLiterature
salesorder | prvDeleteOrder
salesorderdetail | prvAppendToOrder
savedquery | prvDeleteQuery prvReadQuery prvWriteQuery
savedqueryvisualization | prvDeleteSavedQueryVisualizations prvReadSavedQueryVisualizations prvWriteSavedQueryVisualizations
sdkmessageprocessingstep | prvDeleteSdkMessageProcessingStep prvReadSdkMessageProcessingStep
sdkmessageprocessingstepimage | prvDeleteSdkMessageProcessingStepImage
sdkmessageprocessingstepsecureconfig | prvDeleteSdkMessageProcessingStepSecureConfig
service | prvDeleteService
serviceappointment | prvDeleteActivity
serviceendpoint | prvDeleteServiceEndpoint
sharepointdocumentlocation | prvDeleteSharePointDocumentLocation
sharepointsite | prvDeleteSharePointSite
site | prvDeleteSite
sitemap |
solution | prvDeleteSolution
subject | prvDeleteSubject
systemform | prvDeleteSystemForm prvReadCustomization prvReadSystemForm prvWriteSystemForm
task | prvDeleteActivity
team | prvDeleteTeam
team | prvReadUser
template | prvDeleteEmailTemplate prvReadEmailTemplate
template |
territory | prvDeleteTerritory
transactioncurrency | prvDeleteTransactionCurrency
transformationmapping | prvAppendToImportMap
transformationparametermapping | prvAppendToImportMap
uom | prvAppendToProduct
uomschedule | prvDeleteProduct
userform | prvDeleteUserForm
userquery | prvDeleteUserQuery
userqueryvisualization | prvDeleteUserQueryVisualizations
webresource | prvDeleteWebResource prvReadWebResource prvWriteWebResource
webwizard | prvDeleteWebWizard
wizardpage | prvDeleteWizardPage
workflow | prvDeleteWorkflow prvReadWorkflow
workflow |

See Also

Other Resources

Privileges by message
Privileges by entity
DeleteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeleteAttribute message privileges

The following table lists the privileges needed for the DeleteAttributeRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | prvDeleteAttribute

See Also

Other Resources

Privileges by message
DeleteAttributeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeleteAuditData message privileges

The following table lists the privileges needed for the DeleteAuditDataRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
audit | prvDeleteAuditPartitions

See Also

Reference

Audit (auditing) entity privileges

Other Resources

Privileges by message
Privileges by entity
DeleteAuditDataRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeleteEntity message privileges

The following table lists the privileges needed for the DeleteEntityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
Privileges by entity
DeleteEntityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeleteOpenInstances message privileges

The following table lists the privileges needed for the DeleteOpenInstancesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
recurringappointmentmaster | prvReadActivity prvWriteActivity

See Also

Concepts

RecurringAppointmentMaster entity privileges

Other Resources

Privileges by message
Privileges by entity
DeleteOpenInstancesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeleteOptionSet message privileges

The following table lists the privileges needed for the DeleteOptionSetRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
DeleteOptionSetRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeleteOptionValue message privileges

The following table lists the privileges needed for the DeleteOptionValueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
DeleteOptionValueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeleteRelationship message privileges

The following table lists the privileges needed for the DeleteRelationshipRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
DeleteRelationshipRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeliverIncomingEmail message privileges

The following table lists the privileges needed for the DeliverIncomingEmailRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
email | prvAppendActivity prvCreateActivity prvWriteActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
DeliverIncomingEmailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeliverPromoteEmail message privileges

The following table lists the privileges needed for the DeliverPromoteEmailRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
email | prvAppendActivity prvCreateActivity prvReadActivity prvShareActivity prvWriteActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
DeliverPromoteEmailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DeprovisionLanguage message privileges

The following table lists the privileges needed for the DeprovisionLanguageRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
DeprovisionLanguageRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Disassociate message privileges

The following table lists the privileges needed for the DisassociateEntitiesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Secondary Entity | Privilege
Any entity that is entity 1 in a many-to-many relationship. | Any entity that is entity 2 in a many-to-many relationship. | prvWritePrimaryEntity prvAppendPrimaryEntity prvSecondaryEntity

See Also

Other Resources

Privileges by message
Privileges by entity
DisassociateEntitiesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DistributeCampaignActivity message privileges

The following table lists the privileges needed for the DistributeCampaignActivityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
campaignactivity | prvAppendActivity prvAppendToActivity prvCreateActivity prvReadActivity prvWriteActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
DistributeCampaignActivityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DownloadReportDefinition message privileges

The following table lists the privileges needed for the DownloadReportDefinitionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
report | prvReadReport

See Also

Concepts

Report entity privileges

Other Resources

Privileges by message
Privileges by entity
DownloadReportDefinitionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExecuteAsync message privileges

The following table lists the privileges needed for the ExecuteAsyncRequest message. The exact set of privileges needed depends on the entity types specified in the request.

See Also

Other Resources

Privileges by message
Privileges by entity
ExecuteAsyncRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExecuteByIdSavedQuery message privileges

The following table lists the privileges needed for the ExecuteByIdSavedQueryRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
Savedquery | prvReadArticle prvReadQuery

See Also

Concepts

SavedQuery (view) entity privileges

Other Resources

Privileges by message
Privileges by entity
ExecuteByIdSavedQueryRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExecuteByIdUserQuery message privileges

The following table lists the privileges needed for the ExecuteByIdUserQueryRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
userquery | prvReadArticle

See Also

Concepts

UserQuery (saved view) entity privileges

Other Resources

Privileges by message
Privileges by entity
ExecuteByIdUserQueryRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExecuteFetch message privileges

The following table lists the privileges needed for the ExecuteFetchRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
ExecuteFetchRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExecuteWorkflow message privileges

The following table lists the privileges needed for the ExecuteWorkflowRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
workflow | prvReadWorkflow prvRead<entity> - read privileges on the primary entity for the workflow.

See Also

Concepts

Workflow (process) entity privileges

Other Resources

Privileges by message
Privileges by entity
ExecuteWorkflowRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExpandCalendar message privileges

The following table lists the privileges needed for the ExpandCalendarRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
calendar | None

See Also

Concepts

Calendar entity privileges

Other Resources

Privileges by message
Privileges by entity
ExpandCalendarRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExportMappingsImportMap message privileges

The following table lists the privileges needed for the ExportMappingsImportMapRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
importmap | prvReadImportMap

See Also

Concepts

ImportMap (data map) entity privileges

Other Resources

Privileges by message
Privileges by entity
ExportMappingsImportMapRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExportSolution message privileges

The following table lists the privileges needed for the ExportSolutionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvReadArticleTemplate

prvReadAttributeMap

prvReadBusinessUnit

prvReadConnectionRole

prvReadContractTemplate

prvReadCustomization

prvReadEmailTemplate

prvReadEntityMap

prvReadFieldSecurityProfile

prvReadMailMergeTemplate

prvReadOrganization

prvReadPluginAssembly

prvReadPublisher

prvReadQuery

prvReadReport

prvReadRole

prvReadSavedQueryVisualizations

prvReadSdkMessageProcessingStep

prvReadSolution

prvReadSystemForm

prvReadVisualizationModule

prvReadWebResource

prvReadWorkflow

See Also

Concepts

Solution entity privileges

Other Resources

Privileges by message
Privileges by entity
ExportSolutionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ExportTranslation message privileges

The following table lists the privileges needed for the ExportTranslationRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvReadCustomization

prvReadPublisher

prvReadQuery

prvReadSavedQueryVisualizations

prvReadSolution

prvReadSystemForm

prvReadWebResource

See Also

Other Resources

Privileges by message
Privileges by entity
ExportTranslationRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FetchXmlToQueryExpression message privileges

The following table lists the privileges needed for the FetchXmlToQueryExpressionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
FetchXmlToQueryExpressionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FindParentResourceGroup message privileges

The following table lists the privileges needed for the FindParentResourceGroupRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
resourcegroup | prvReadService

See Also

Concepts

ResourceGroup (scheduling group) entity privileges

Other Resources

Privileges by message
Privileges by entity
FindParentResourceGroupRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


FulfillSalesOrder message privileges

The following table lists the privileges needed for the FulfillSalesOrderRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
salesorder | prvAppendActivity prvAppendToOrder prvCreateActivity prvWriteOrder

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

SalesOrder (order) entity privileges

Other Resources

Privileges by message
Privileges by entity
FulfillSalesOrderRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GenerateInvoiceFromOpportunity message privileges

The following table lists the privileges needed for the GenerateInvoiceFromOpportunityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
invoice | prvAppendInvoice prvAppendToAccount prvAppendToContact prvAppendToInvoice prvAppendToOpportunity prvCreateInvoice prvReadAttributeMap prvReadEntityMap prvReadInvoice prvReadOpportunity

See Also

Concepts

Invoice entity privileges
Opportunity entity privileges

Other Resources

Privileges by message
Privileges by entity
GenerateInvoiceFromOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GenerateQuoteFromOpportunity message privileges

The following table lists the privileges needed for the GenerateQuoteFromOpportunityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
quote | prvAppendQuote prvAppendToAccount prvAppendToContact prvAppendToOpportunity prvAppendToProduct prvAppendToQuote prvCreateQuote prvReadAttributeMap prvReadEntityMap prvReadOpportunity prvReadQuote

See Also

Concepts

Quote entity privileges
Opportunity entity privileges

Other Resources

Privileges by message
Privileges by entity
GenerateQuoteFromOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GenerateSalesOrderFromOpportunity message privileges

The following table lists the privileges needed for the GenerateSalesOrderFromOpportunityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
salesorder | prvAppendOrder prvAppendToContact prvAppendToOpportunity prvAppendToOrder prvAppendToProduct prvCreateOrder prvReadAttributeMap prvReadEntityMap prvReadOpportunity prvReadOrder

See Also

Concepts

SalesOrder (order) entity privileges
Opportunity entity privileges

Other Resources

Privileges by message
Privileges by entity
GenerateSalesOrderFromOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetAllTimeZonesWithDisplayName message privileges

The following table lists the privileges needed for the GetAllTimeZonesWithDisplayNameRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
GetAllTimeZonesWithDisplayNameRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetDecryptionKey message privileges

The following table lists the privileges needed for the GetDecryptionKeyRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
GetDecryptionKeyRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetDistinctValuesImportFile message privileges

The following table lists the privileges needed for the GetDistinctValuesImportFileRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
importfile | prvReadImportFile

See Also

Concepts

ImportFile (import source file) entity privileges

Other Resources

Privileges by message
Privileges by entity
GetDistinctValuesImportFileRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetHeaderColumnsImportFile message privileges

The following table lists the privileges needed for the GetHeaderColumnsImportFileRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
importfile | prvReadImportFile

See Also

Concepts

ImportFile (import source file) entity privileges

Other Resources

Privileges by message
Privileges by entity
GetHeaderColumnsImportFileRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetInvoiceProductsFromOpportunity message privileges

The following table lists the privileges needed for the GetInvoiceProductsFromOpportunityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
invoice | prvAppendToInvoice prvCreateInvoice prvReadAttributeMap prvReadEntityMap prvReadInvoice prvReadOpportunity

See Also

Concepts

Invoice entity privileges

Other Resources

Privileges by message
Privileges by entity
GetInvoiceProductsFromOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetQuantityDecimal message privileges

The following table lists the privileges needed for the GetQuantityDecimalRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
invoice | prvReadInvoice prvReadProduct
opportunity | prvReadOpportunity prvReadProduct
quote | prvReadQuote prvReadProduct
salesorder | prvReadOrder prvReadProduct

See Also

Concepts

Invoice entity privileges
Opportunity entity privileges
Quote entity privileges
SalesOrder (order) entity privileges
Product entity privileges

Other Resources

Privileges by message
Privileges by entity
GetQuantityDecimalRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetQuoteProductsFromOpportunity message privileges

The following table lists the privileges needed for the GetQuoteProductsFromOpportunityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
quote | prvAppendToQuote prvCreateQuote prvReadAttributeMap prvReadEntityMap prvReadOpportunity

See Also

Concepts

Quote entity privileges

Other Resources

Privileges by message
Privileges by entity
GetQuoteProductsFromOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetReportHistoryLimit message privileges

The following table lists the privileges needed for the GetReportHistoryLimitRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
report | prvReadReport

See Also

Concepts

Report entity privileges

Other Resources

Privileges by message
Privileges by entity
GetReportHistoryLimitRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetSalesOrderProductsFromOpportunity message privileges

The following table lists the privileges needed for the GetSalesOrderProductsFromOpportunityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
salesorder | prvAppendToOrder prvCreateOrder prvReadAttributeMap prvReadEntityMap prvReadOpportunity prvReadOrder

See Also

Concepts

SalesOrder (order) entity privileges

Other Resources

Privileges by message
Privileges by entity
GetSalesOrderProductsFromOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GenerateSocialProfile message privileges

The following table lists the privileges needed for the GenerateSocialProfileRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
SocialProfile | prvReadSocialProfile

See Also

Reference

SocialProfile entity privileges

Other Resources

Privileges by message
GenerateSocialProfileRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetTimeZoneCodeByLocalizedName message privileges

The following table lists the privileges needed for the GetTimeZoneCodeByLocalizedNameRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Other Resources

Privileges by message
GetTimeZoneCodeByLocalizedNameRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetTrackingTokenEmail message privileges

The following table lists the privileges needed for the GetTrackingTokenEmailRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
email | prvWriteActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
GetTrackingTokenEmailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetValidManyToMany message privileges

The following table lists the privileges needed for the GetValidManyToManyRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | prvReadQuery

See Also

Other Resources

Privileges by message
GetValidManyToManyRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetValidReferencedEntities message privileges

The following table lists the privileges needed for the GetValidReferencedEntitiesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | prvReadQuery

See Also

Other Resources

Privileges by message
GetValidReferencedEntitiesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GetValidReferencingEntities message privileges

The following table lists the privileges needed for the GetValidReferencingEntitiesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | prvReadQuery

See Also

Other Resources

Privileges by message
GetValidReferencingEntitiesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


GrantAccess message privileges

The following table lists the privileges needed for the GrantAccessRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvShareAccount
annotation | prvShareNote
appointment | prvShareActivity
campaign | prvShareCampaign
campaignactivity | prvShareActivity
campaignresponse | prvShareActivity
connection | prvShareConnection
contact | prvShareContact
contract | prvShareContract
customeropportunityrole | prvShareCustomerOpportunityRole
customerrelationship | prvShareCustomerRelationship
duplicaterule | prvShareDuplicateRule
email | prvShareActivity
fax | prvShareActivity
import | prvShareImport
importmap | prvShareImportMap
incident | prvShareIncident
incidentresolution | prvShareActivity
invoice | prvShareInvoice
lead | prvShareLead
letter | prvShareActivity
list | prvShareList
mailmergetemplate | prvShareMailMergeTemplate
opportunity | prvShareOpportunity
opportunityclose | prvShareActivity
orderclose | prvShareActivity
phonecall | prvShareActivity
processsession | prvShareWorkflowSession
queue | prvShareQueue
quote | prvShareQuote
quoteclose | prvShareActivity
recurringappointmentmaster | prvShareActivity
report | prvShareReport
salesorder | prvShareOrder
serviceappointment | prvShareActivity
task | prvShareActivity
template | prvShareEmailTemplate
userform | prvShareUserForm
userquery | prvShareUserQuery
userqueryvisualization | prvShareUserQueryVisualizations
workflow | prvReadWorkflow
workflow | prvShareWorkflow

See Also

Other Resources

Privileges by message
Privileges by entity
GrantAccessRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportMappingsImportMap message privileges

The following table lists the privileges needed for the ImportMappingsImportMapRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
importmap | prvCreateImportMap

See Also

Concepts

ImportMap (data map) entity privileges

Other Resources

Privileges by message
Privileges by entity
ImportMappingsImportMapRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportRecordsImport message privileges

The following table lists the privileges needed for the ImportRecordsImportRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
import | prvCreateImport prvReadAsyncOperation prvReadImport prvReadImportFile

See Also

Concepts

Import (data import) entity privileges

Other Resources

Privileges by message
Privileges by entity
ImportRecordsImportRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportSolution message privileges

The following table lists the privileges needed for the ImportSolutionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvCreateCustomization

prvReadArticleTemplate

prvReadBusinessUnit

prvReadConnectionRole

prvReadContractTemplate

prvReadCustomization

prvReadEmailTemplate

prvReadEntityMap

prvReadFieldSecurityProfile

prvReadMailMergeTemplate

prvReadPluginAssembly

prvReadQuery

prvReadReport

prvReadRole

prvReadSdkMessageProcessingStep

prvReadSolution

prvReadSystemForm

prvReadWebResource

prvWriteArticleTemplate

prvWriteConnectionRole

prvWriteContractTemplate

prvWriteCustomization

prvWriteOrganization

prvWriteQuery

prvWriteSolution

prvWriteSystemForm

See Also

Concepts

Solution entity privileges

Other Resources

Privileges by message
Privileges by entity
ImportSolutionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ImportTranslation message privileges

The following table lists the privileges needed for the ImportTranslationRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
ImportTranslationRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InitializeFrom message privileges

The following table lists the privileges needed for the InitializeFromRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvReadAttributeMap

prvReadEntityMap

prvRead<EntityPassedToRequest>

See Also

Other Resources

Privileges by message
Privileges by entity
InitializeFromRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InsertOptionValue message privileges

The following table lists the privileges needed for the InsertOptionValueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvWriteOptionSet

See Also

Other Resources

Privileges by message
Privileges by entity
InsertOptionValueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InsertStatusValue message privileges

The following table lists the privileges needed for the InsertStatusValueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privilege

prvWriteOptionSet

See Also

Other Resources

Privileges by message
Privileges by entity
InsertStatusValueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InstallSampleData message privileges

The following table lists the privileges needed for the InstallSampleDataRequest message.

Primary Entity | Privilege
importmap | prvAppendToImportMap prvCreateImportMap prvDeleteImportMap prvReadImportMap prvWriteImportMap
importfile | prvCreateImportFile prvDeleteImportFile prvReadImportFile prvWriteImportFile
import | prvCreateImport prvDeleteImport prvReadImport prvWriteImport

See Also

Other Resources

Privileges by message
Privileges by entity
InstallSampleDataRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InstantiateFilters message privileges

The following table lists the privileges needed for the InstantiateFiltersRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Concepts

SavedQuery (view) entity privileges

Other Resources

Privileges by message
Privileges by entity
InstantiateFiltersRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


InstantiateTemplate message privileges

The following table lists the privileges needed for the InstantiateTemplateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
template | prvReadContact prvReadEmailTemplate prvReadUser

See Also

Concepts

Template (email template) entity privileges

Other Resources

Privileges by message
Privileges by entity
InstantiateTemplateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


IsBackOfficeInstalled message privileges

The following table lists the privileges needed for the IsBackOfficeInstalledRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
Privileges by entity
IsBackOfficeInstalledRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


IsComponentCustomizable message privileges

The following table lists the privileges needed for the IsComponentCustomizableRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
solutioncomponent | None

See Also

Concepts

SolutionComponent entity privileges

Other Resources

Privileges by message
Privileges by entity
IsComponentCustomizableRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


IsDataEncryptionActive message privileges

The following table lists the privileges needed for the IsSqlEncryptionActiveRequest message. The exact set of privileges needed depends on the entity types specified in the request.

See Also

Reference

IsSqlEncryptionActiveRequest

Other Resources

Privileges by message
Privileges by entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


IsValidStateTransition message privileges

The following table lists the privileges needed for the IsValidStateTransitionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
Any activity entity | prvReadActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
IsValidStateTransitionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


LocalTimeFromUtcTime message privileges

The following table lists the privileges needed for the LocalTimeFromUtcTimeRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
timezonedefinition | None

See Also

Concepts

TimeZoneDefinition entity privileges

Other Resources

Privileges by message
Privileges by entity
LocalTimeFromUtcTimeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


LockInvoicePricing message privileges

The following table lists the privileges needed for the LockInvoicePricingRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
invoice | prvReadInvoice prvWriteInvoice

See Also

Concepts

Invoice entity privileges

Other Resources

Privileges by message
Privileges by entity
LockInvoicePricingRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


LockSalesOrderPricing message privileges

The following table lists the privileges needed for the LockSalesOrderPricingRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
salesorder | prvReadOrder prvWriteOrder

See Also

Concepts

SalesOrder (order) entity privileges

Other Resources

Privileges by message
Privileges by entity
LockSalesOrderPricingRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


LogFailureBulkOperation message privileges

The following table lists the privileges needed for the LogFailureBulkOperationRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
LogFailureBulkOperationRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


LogSuccessBulkOperation message privileges

The following table lists the privileges needed for the LogSuccessBulkOperationRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
LogSuccessBulkOperationRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


LoseOpportunity message privileges

The following table lists the privileges needed for the LoseOpportunityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
opportunity | prvAppendActivity prvAppendToOpportunity prvCreateActivity prvWriteOpportunity

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

Opportunity entity privileges

Other Resources

Privileges by message
Privileges by entity
LoseOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


MakeAvailableToOrganizationReport message privileges

The following table lists the privileges needed for the MakeAvailableToOrganizationReportRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
report | prvPublishOrgReport prvWriteReport

See Also

Concepts

Report entity privileges

Other Resources

Privileges by message
Privileges by entity
MakeAvailableToOrganizationReportRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


MakeAvailableToOrganizationTemplate message privileges

The following table lists the privileges needed for the MakeAvailableToOrganizationTemplateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
template | prvCreateOrgEmailTemplates prvReadEmailTemplate prvWriteEmailTemplate

See Also

Concepts

Template (email template) entity privileges

Other Resources

Privileges by message
Privileges by entity
MakeAvailableToOrganizationTemplateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


MakeUnavailableToOrganizationReport message privileges

The following table lists the privileges needed for the MakeUnavailableToOrganizationReportRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
report | prvPublishOrgReport prvWriteReport

See Also

Concepts

Report entity privileges

Other Resources

Privileges by message
Privileges by entity
MakeUnavailableToOrganizationReportRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


MakeUnavailableToOrganizationTemplate message privileges

The following table lists the privileges needed for the MakeUnavailableToOrganizationTemplateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
template | prvCreateOrgEmailTemplates prvReadEmailTemplate prvWriteEmailTemplate

See Also

Concepts

Template (email template) entity privileges

Other Resources

Privileges by message
Privileges by entity
MakeUnavailableToOrganizationTemplateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Merge message privileges

The following table lists the privileges needed for the MergeRequest message. The exact set of privileges needed depends on the entity types specified in the request.

The capability to merge Incidents was added in the CRM Online Spring ’14 and CRM 2015 Service Pack 1 (on-premises) release.

Entity | Privileges
account | prvAppendAccount prvAppendActivity prvAppendToAccount prvMerge prvReadAccount prvShareAccount prvWriteAccount prvWriteActivity
contact | prvAppendActivity prvAppendContact prvAppendToContact prvMerge prvReadContact prvShareContact prvWriteActivity prvWriteContact
lead | prvAppendActivity prvAppendLead prvAppendToLead prvMerge prvReadLead prvShareLead prvWriteActivity prvWriteLead
incident | prvAppendActivity prvAppendIncident prvAppendToIncident prvMerge prvReadIncident prvShareIncident prvWriteActivity prvWriteIncident

See Also

Reference

Account entity privileges
ActivityPointer (activity) entity privileges

Concepts

Contact entity privileges
Lead entity privileges

Other Resources

Privileges by message
Privileges by entity
MergeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ModifyAccess message privileges

The following table lists the privileges needed for the ModifyAccessRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvShareAccount
annotation | prvShareNote
appointment | prvShareActivity
campaign | prvShareCampaign
campaignactivity | prvShareActivity
campaignresponse | prvShareActivity
connection | prvShareConnection
contact | prvShareContact
contract | prvShareContract
customeropportunityrole | prvShareCustomerOpportunityRole
customerrelationship | prvShareCustomerRelationship
duplicaterule | prvShareDuplicateRule
email | prvShareActivity
fax | prvShareActivity
importmap | prvShareImportMap
incident | prvShareIncident
incidentresolution | prvShareActivity
invoice | prvShareInvoice
lead | prvShareLead
letter | prvShareActivity
list | prvShareList
opportunity | prvShareOpportunity
opportunityclose | prvShareActivity
orderclose | prvShareActivity
phonecall | prvShareActivity
processsession | prvShareWorkflowSession
queue | prvShareQueue
quote | prvShareQuote
quoteclose | prvShareActivity
recurringappointmentmaster | prvShareActivity
report | prvShareReport
salesorder | prvShareOrder
serviceappointment | prvShareActivity
task | prvShareActivity
template | prvShareEmailTemplate
userform | prvShareUserForm
userquery | prvShareUserQuery
workflow | prvShareWorkflow

See Also

Other Resources

Privileges by message
Privileges by entity
ModifyAccessRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


OrderOption message privileges

The following table lists the privileges needed for the OrderOptionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
OrderOptionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ParseImport message privileges

The following table lists the privileges needed for the ParseImportRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
import | prvCreateImport prvReadAsyncOperation prvReadImport prvReadImportFile

See Also

Concepts

Import (data import) entity privileges

Other Resources

Privileges by message
Privileges by entity
ParseImportRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PickFromQueue message privileges

The following table lists the privileges needed for the PickFromQueueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
queue | prvWriteQueue

See Also

Concepts

Queue entity privileges
QueueItem entity privileges
QueueItem entity messages and methods

Other Resources

Privileges by message
PickFromQueueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProcessInboundEmail message privileges

The following table lists the privileges needed for the ProcessInboundEmailRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Concepts

Email entity privileges

Other Resources

Privileges by message
Privileges by entity
ProcessInboundEmailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProcessOneMemberBulkOperation message privileges

The following table lists the privileges needed for the ProcessOneMemberBulkOperationRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
bulkoperation | prvAppendActivity prvAppendToAccount prvAppendToActivity prvCreateActivity prvReadActivity prvReadCampaign

See Also

Reference

BulkOperation (quick campaign) entity privileges

Other Resources

Privileges by message
Privileges by entity
ProcessOneMemberBulkOperationRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PropagateByExpression message privileges

The following table lists the privileges needed for the PropagateByExpressionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
email | prvAllowQuickCampaign prvCreateActivity prvReadAccount prvReadActivity

See Also

Concepts

Email entity privileges

Other Resources

Privileges by message
Privileges by entity
PropagateByExpressionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ProvisionLanguage message privileges

The following table lists the privileges needed for the ProvisionLanguageRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
ProvisionLanguageRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PublishAllXml message privileges

The following table lists the privileges needed for the PublishAllXmlRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | prvReadCustomization prvReadQuery prvReadSavedQueryVisualizations prvReadSystemForm prvReadWebResource prvWriteQuery

See Also

Other Resources

Privileges by message
Privileges by entity
PublishAllXmlRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PublishDuplicateRule message privileges

The following table lists the privileges needed for the PublishDuplicateRuleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
duplicaterule | prvPublishDuplicateRule prvReadDuplicateRule

See Also

Concepts

DuplicateRule (duplicate detection rule) entity privileges

Other Resources

Privileges by message
Privileges by entity
PublishDuplicateRuleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


PublishXml message privileges

The following table lists the privileges needed for the PublishXmlRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | prvReadCustomization prvReadQuery prvReadSavedQueryVisualizations prvReadSystemForm

See Also

Other Resources

Privileges by message
Privileges by entity
PublishXmlRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QualifyLead message privileges

The following table lists the privileges needed for the QualifyLeadRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
lead | Content coming soon.

See Also

Concepts

Lead entity privileges

Other Resources

Privileges by message
Privileges by entity
QualifyLeadRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QualifyMemberList message privileges

The following table lists the privileges needed for the QualifyMemberListRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
list | Content coming soon.

See Also

Concepts

List (marketing list) entity privileges

Other Resources

Privileges by message
Privileges by entity
QualifyMemberListRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QueryExpressionToFetchXml message privileges

The following table lists the privileges needed for the QueryExpressionToFetchXmlRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
QueryExpressionToFetchXmlRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QueryMultipleSchedules message privileges

The following table lists the privileges needed for the QueryMultipleSchedulesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | prvBrowseAvailability

See Also

Other Resources

Privileges by message
QueryMultipleSchedulesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


QuerySchedule message privileges

The following table lists the privileges needed for the QueryMultipleSchedulesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | prvBrowseAvailability

See Also

Other Resources

Privileges by message
QueryMultipleSchedulesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReassignObjectsOwner message privileges

The following table lists the privileges needed for the ReassignObjectsOwnerRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
systemuser | prvWriteUser

See Also

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
ReassignObjectsOwnerRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReassignObjectsSystemUser message privileges

The following table lists the privileges needed for the ReassignObjectsSystemUserRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
systemuser | prvWriteUser prvAssignAccount prvAssignActivity prvAssignCampaign prvAssignContact prvAssignContract prvAssignInvoice prvAssignLead prvAssignList prvAssignNote prvAssignOpportunity prvAssignOrder prvAssignQuote prvAssignUserQuery prvReadAccount prvReadActivity prvReadCampaign prvReadContact prvReadContract prvReadInvoice prvReadLead prvReadList prvReadNote prvReadOpportunity prvReadOrder prvReadQuote prvReadUser prvReadUserQuery prvWriteUser

See Also

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
ReassignObjectsSystemUserRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Recalculate message privileges

The following table lists the privileges needed for the RecalculateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
goal | prvReadAccount prvRollupGoal

See Also

Concepts

Goal entity privileges

Other Resources

Privileges by message
Privileges by entity
RecalculateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReleaseToQueue message privileges

The following table lists the privileges needed for the ReleaseToQueueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
queue | prvWriteQueue

See Also

Concepts

Queue entity privileges
QueueItem entity privileges
QueueItem entity messages and methods

Other Resources

Privileges by message
ReleaseToQueueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveFromQueue message privileges

The following table lists the privileges needed for the RemoveFromQueueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
queue | prvWriteQueue

See Also

Concepts

Queue entity privileges
QueueItem entity privileges
QueueItem entity messages and methods

Other Resources

Privileges by message
RemoveFromQueueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveItemCampaignActivity message privileges

The following table lists the privileges needed for the RemoveItemCampaignActivityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
campaignactivity | prvAppendToActivity prvReadActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

CampaignActivity entity privileges

Other Resources

Privileges by message
Privileges by entity
RemoveItemCampaignActivityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveItemCampaign message privileges

The following table lists the privileges needed for the RemoveItemCampaignRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
campaign | prvAppendToCampaign prvReadActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Concepts

Campaign entity privileges

Other Resources

Privileges by message
Privileges by entity
RemoveItemCampaignRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveMemberList message privileges

The following table lists the privileges needed for the RemoveMemberListRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
list | prvAppendToList prvReadList

See Also

Concepts

List (marketing list) entity privileges

Other Resources

Privileges by message
Privileges by entity
RemoveMemberListRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveMembersTeam message privileges

The following table lists the privileges needed for the RemoveMembersTeamRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
team | prvWriteTeam

See Also

Concepts

Team entity privileges

Other Resources

Privileges by message
Privileges by entity
RemoveMembersTeamRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveParent message privileges

The following table lists the privileges needed for the RemoveParentRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
systemuser | prvWriteUser

See Also

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
RemoveParentRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemovePrivilegeRole message privileges

The following table lists the privileges needed for the RemovePrivilegeRoleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
role | prvReadOrganization prvReadRole prvReadUser prvWriteRole

See Also

Concepts

Role (security role) entity privileges
Privilege entity privileges

Other Resources

Privileges by message
Privileges by entity
RemovePrivilegeRoleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveProductFromKit message privileges

The following table lists the privileges needed for the RemoveProductFromKitRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
product | prvAppendProduct prvAppendToProduct

See Also

Concepts

Product entity privileges

Other Resources

Privileges by message
Privileges by entity
RemoveProductFromKitRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveRelated message privileges

The following table lists the privileges needed for the RemoveRelatedRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
invoice | prvAppendInvoice prvAppendToContact
lead | prvAppendToAccount prvAppendLead prvAppendToContact
opportunity | prvReadCustomerOpportunityRole prvAppendOpportunity prvAppendToCompetitor prvReadCustomerOpportunityRole
product | prvAppendProduct prvAppendToCompetitor prvAppendProduct prvAppendToLead
quote | prvAppendQuote prvAppendToContact
salesliterature | prvAppendSalesLiterature prvAppendToCompetitor prvAppendSalesLiterature prvAppendToProduct
salesorder | prvAppendOrder prvAppendToContact

See Also

Other Resources

Privileges by message
Privileges by entity
RemoveRelatedRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveSolutionComponent message privileges

The following table lists the privileges needed for the RemoveSolutionComponentRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
solutioncomponent | None

See Also

Concepts

SolutionComponent entity privileges

Other Resources

Privileges by message
Privileges by entity
RemoveSolutionComponentRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveSubstituteProduct message privileges

The following table lists the privileges needed for the RemoveSubstituteProductRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
product | prvAppendProduct prvAppendToProduct

See Also

Concepts

Product entity privileges

Other Resources

Privileges by message
Privileges by entity
RemoveSubstituteProductRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RemoveUserFromRecordTeam message privileges

The following table lists the privileges needed for the RemoveUserFromRecordTeamRequest message. The exact set of privileges needed depends on the entity types specified in the request.

See Also

Other Resources

Privileges by message
Privileges by entity
RemoveUserFromRecordTeamRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RenewContract message privileges

The following table lists the privileges needed for the RenewContractRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
contract | prvAppendContract prvAppendToContact prvAppendToContract prvAppendToContractTemplate prvCreateContract prvReadContract prvWriteContract

See Also

Concepts

Contract entity privileges

Other Resources

Privileges by message
Privileges by entity
RenewContractRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RenewEntitlement message privileges

The following table lists the privileges needed for the RenewEntitlementRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
entitlement | prvWriteEntitlement

See Also

Reference

Entitlement entity privileges

Concepts

Entitlement entity messages and methods

Other Resources

Privileges by message
RenewEntitlementRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReplacePrivilegesRole message privileges

The following table lists the privileges needed for the ReplacePrivilegesRoleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
role | prvReadOrganization prvReadRole prvReadUser prvWriteRole

See Also

Concepts

Privilege entity privileges
Role (security role) entity privileges

Other Resources

Privileges by message
Privileges by entity
ReplacePrivilegesRoleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Reschedule message privileges

The following table lists the privileges needed for the RescheduleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
appointment | prvAppendActivity prvAppendToAccount prvAppendToActivity prvAppendToIncident prvAppendToOpportunity prvCreateActivity prvReadAccount prvReadActivity prvSearchAvailability prvWriteActivity
serviceappointment | prvAppendActivity prvAppendToAccount prvAppendToEquipment prvAppendToService prvCreateEquipment prvCreateService prvReadActivity prvSearchAvailability prvWriteActivity

See Also

Reference

ActivityPointer (activity) entity privileges

Other Resources

Privileges by message
Privileges by entity
RescheduleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ResetUserFilters message privileges

The following table lists the privileges needed for the ResetUserFiltersRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
ResetUserFiltersRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Retrieve message privileges

The following table lists the privileges needed for the RetrieveRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvReadAccount
activitymimeattachment | prvReadActivity
activitypointer | prvReadActivity
annotation | prvReadNote
appointment | prvReadActivity
asyncoperation | prvReadAsyncOperation
attributemap | prvReadAttributeMap
audit | prvReadContact
bulkoperation | prvReadActivity
businessunit | prvReadBusinessUnit
businessunitnewsarticle | prvReadNewsArticle
calendar | prvReadOrganization
campaign | prvReadCampaign
campaignactivity | prvReadActivity
campaignresponse | prvReadActivity
columnmapping | prvReadImportMap
competitor | prvReadCompetitor
connection | prvReadConnection
connectionrole | prvReadConnectionRole
constraintbasedgroup | prvReadService
contact | prvReadContact
contract | prvReadContract
contractdetail | prvReadContract
contracttemplate | prvReadContractTemplate
customeraddress | prvReadAccount
customeropportunityrole | prvReadCustomerOpportunityRole
customerrelationship | prvReadCustomerRelationship
discount | prvReadProduct
discounttype | prvReadProduct
displaystring | prvReadCustomization
duplicaterecord | prvReadAsyncOperation
duplicaterule | prvReadDuplicateRule
duplicaterulecondition | prvReadDuplicateRule
email | prvReadActivity
entitymap | prvReadEntityMap
equipment | prvReadEquipment
fax | prvReadActivity
fieldpermission | prvReadFieldSecurityProfile
fieldsecurityprofile | prvReadFieldSecurityProfile
goal | prvReadGoal
goalrollupquery | prvReadGoalRollupQuery
import | prvReadImport
importfile | prvReadImport
importjob | prvReadImportJob
importlog | prvReadImport
importmap | prvReadImportMap
incident | prvReadIncident
incidentresolution | prvReadActivity
invaliddependency |
invoice | prvReadInvoice
invoicedetail | prvReadInvoice
kbarticle | prvReadArticle
kbarticlecomment | prvReadArticle
kbarticletemplate | prvReadArticleTemplate
lead | prvReadLead
letter | prvReadActivity
list | prvReadList
lookupmapping | prvReadImportMap
mailmergetemplate | prvReadMailMergeTemplate
metric | prvReadMetric
opportunity | prvReadOpportunity
opportunityclose | prvReadActivity
opportunityproduct | prvReadOpportunity
orderclose | prvReadActivity
organization | prvReadOrganization
ownermapping | prvReadImportMap
phonecall | prvReadActivity
picklistmapping | prvReadImportMap
pluginassembly | prvReadPluginAssembly
plugintype | prvReadPluginType
pricelevel | prvReadProduct
principalobjectattributeaccess | prvReadPrincipalObjectAttributeAccess
privilege |
processsession | prvReadWorkflowSession
product | prvReadProduct
productpricelevel | prvReadProduct
publisher | prvReadPublisher
queue | prvReadQueue
queueitem | prvReadQueue
quote | prvReadQuote
quoteclose | prvReadActivity
quotedetail | prvReadQuote
recurrencerule | prvReadActivity
recurringappointmentmaster | prvReadActivity
recurringappointmentmaster | prvReadSdkMessage
recurringappointmentmaster | prvReadSdkMessageProcessingStep
recurringappointmentmaster | prvReadSdkMessageProcessingStepImage
relationshiprole | prvReadRelationshipRole
relationshiprolemap | prvReadRelationshipRole
report | prvReadReport
reportcategory | prvReadReport
reportentity | prvReadReport
reportvisibility | prvReadReport
resource | prvReadService
resourcegroup | prvReadService
resourcespec | prvReadService
role | prvReadRole
salesliterature | prvReadSalesLiterature
salesliteratureitem | prvReadSalesLiterature
salesorder | prvReadOrder
salesorderdetail | prvReadOrder
savedquery | prvReadQuery
savedqueryvisualization | prvReadSavedQueryVisualizations
sdkmessageprocessingstep | prvReadSdkMessageProcessingStep
sdkmessageprocessingstepsecureconfig | prvReadSdkMessageProcessingStepSecureConfig
service | prvReadService
serviceappointment | prvReadActivity
serviceendpoint | prvReadPluginAssembly
serviceendpoint | prvReadPluginType
serviceendpoint | prvReadSdkMessage
serviceendpoint | prvReadSdkMessageProcessingStep
serviceendpoint | prvReadSdkMessageProcessingStepImage
serviceendpoint | prvReadServiceEndpoint
sharepointdocumentlocation | prvReadSharePointDocumentLocation
sharepointsite | prvReadSharePointSite
site | prvReadSite
sitemap | prvReadCustomization
solution | prvReadSolution
solutioncomponent |
subject | prvReadSubject
systemform | prvReadSystemForm
systemuser | prvReadSdkMessage
systemuser | prvReadSdkMessageProcessingStep
systemuser | prvReadSdkMessageProcessingStepImage
systemuser | prvReadUser
task | prvReadActivity
team | prvReadTeam
template | prvReadEmailTemplate
territory | prvReadTerritory
timezonedefinition |
transactioncurrency | prvReadTransactionCurrency
transformationmapping | prvReadImportMap
transformationparametermapping | prvReadImportMap
uom | prvReadProduct
uomschedule | prvReadProduct
userentityinstancedata | prvReadUserEntityInstanceData
userform | prvReadUserForm
userquery | prvReadUserQuery
userqueryvisualization | prvReadUserQueryVisualizations
usersettings | prvReadUserSettings
webresource | prvReadWebResource
webwizard | prvReadWebWizard
wizardpage | prvReadWizardPage
workflow | prvReadPluginType
workflow | prvReadSdkMessage
workflow | prvReadSdkMessageProcessingStep
workflow | prvReadSdkMessageProcessingStepImage
workflow | prvReadWorkflow
workflowlog | prvReadAsyncOperation

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAbsoluteAndSiteCollectionUrl message privileges

The following table lists the privileges needed for the RetrieveAbsoluteAndSiteCollectionUrlRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveAbsoluteAndSiteCollectionUrlRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAllChildUsersSystemUser message privileges

The following table lists the privileges needed for the RetrieveAllChildUsersSystemUserRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
systemuser | prvReadUser

See Also

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveAllChildUsersSystemUserRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAllEntities message privileges

The following table lists the privileges needed for the RetrieveAllEntitiesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
RetrieveAllEntitiesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAllManagedProperties message privileges

The following table lists the privileges needed for the RetrieveAllManagedPropertiesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
RetrieveAllManagedPropertiesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAllOptionSets message privileges

The following table lists the privileges needed for the RetrieveAllOptionSetsRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
RetrieveAllOptionSetsRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveApplicationRibbon message privileges

The following table lists the privileges needed for the RetrieveApplicationRibbonRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
ribboncustomization | prvReadCustomization

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveApplicationRibbonRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAttribute message privileges

The following table lists the privileges needed for the RetrieveAttributeRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
RetrieveAttributeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAttributeChangeHistory message privileges

The following table lists the privileges needed for the RetrieveAttributeChangeHistoryRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
audit | prvReadRecordAuditHistory prvReadAuditPartitions prvReadAuditSummary

See Also

Reference

Audit (auditing) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveAttributeChangeHistoryRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAuditDetails message privileges

The following table lists the privileges needed for the RetrieveAuditDetailsRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
audit | prvReadRecordAuditHistory prvReadAuditPartitions prvReadAuditSummary

See Also

Reference

Audit (auditing) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveAuditDetailsRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAuditPartitionList message privileges

The following table lists the privileges needed for the RetrieveAuditPartitionListRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
audit | prvReadAuditPartitions

See Also

Reference

Audit (auditing) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveAuditPartitionListRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveAvailableLanguages message privileges

The following table lists the privileges needed for the RetrieveAvailableLanguagesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
RetrieveAvailableLanguagesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveBusinessHierarchyBusinessUnit message privileges

The following table lists the privileges needed for the RetrieveBusinessHierarchyBusinessUnitRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
businessunit | prvReadBusinessUnit

See Also

Reference

BusinessUnit entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveBusinessHierarchyBusinessUnitRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveByGroupResource message privileges

The following table lists the privileges needed for the RetrieveByGroupResourceRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
resource | prvReadService prvReadEquipment prvReadTeam prvReadUser

See Also

Concepts

Resource entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveByGroupResourceRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveByResourceResourceGroup message privileges

The following table lists the privileges needed for the RetrieveByResourceResourceGroupRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
resourcegroup | prvReadEquipment prvReadService prvReadTeam prvReadUser

See Also

Concepts

ResourceGroup (scheduling group) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveByResourceResourceGroupRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveByResourcesService message privileges

The following table lists the privileges needed for the RetrieveByResourcesServiceRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
service | prvReadEquipment prvReadService prvReadTeam prvReadUser

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveByResourcesServiceRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveByTopIncidentProductKbArticle message privileges

The following table lists the privileges needed for the RetrieveByTopIncidentProductKbArticleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
kbarticle | None

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveByTopIncidentProductKbArticleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveByTopIncidentSubjectKbArticle message privileges

The following table lists the privileges needed for the RetrieveByTopIncidentSubjectKbArticleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
kbarticle | None

See Also

Concepts

KbArticle (article) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveByTopIncidentSubjectKbArticleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveDataEncryptionKey message privileges

The following table lists the privileges needed for the RetrieveSqlEncryptionKeyRequest message. The exact set of privileges needed depends on the entity types specified in the request.

See Also

Reference

RetrieveSqlEncryptionKeyRequest

Other Resources

Privileges by message
Privileges by entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveDependenciesForDelete message privileges

The following table lists the privileges needed for the RetrieveDependenciesForDeleteRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
dependency | None

See Also

Concepts

Solution entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveDependenciesForDeleteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveDependenciesForUninstall message privileges

The following table lists the privileges needed for the RetrieveDependenciesForUninstallRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
dependency | None

See Also

Concepts

Dependency entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveDependenciesForUninstallRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveDependentComponents message privileges

The following table lists the privileges needed for the RetrieveDependentComponentsRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
dependency | None

See Also

Concepts

Dependency entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveDependentComponentsRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveDeploymentLicenseType message privileges

The following table lists the privileges needed for the RetrieveDeploymentLicenseTypeRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
N/A | prvReadLicense

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveDeploymentLicenseTypeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveDeprovisionedLanguages message privileges

The following table lists the privileges needed for the RetrieveDeprovisionedLanguagesRequestmessage. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
 | Content coming soon.

See Also

Other Resources

Privileges by message
RetrieveDeprovisionedLanguagesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveDuplicates message privileges

The following table lists the privileges needed for the RetrieveDuplicatesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveDuplicatesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveEntity message privileges

The following table lists the privileges needed for the RetrieveEntityRequestmessage. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveEntityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveEntityRibbon message privileges

The following table lists the privileges needed for the RetrieveEntityRibbonRequestmessage. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
RetrieveEntityRibbonRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveExchangeRate message privileges

The following table lists the privileges needed for the RetrieveExchangeRateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
 | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveExchangeRateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveFilteredForms message privileges

The following table lists the privileges needed for the RetrieveFilteredFormsRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
systemform | prvReadSystemForm

See Also

Concepts

SystemForm entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveFilteredFormsRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveFormattedImportJobResults message privileges

The following table lists the privileges needed for the RetrieveFormattedImportJobResultsRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
importjob | None

See Also

Concepts

ImportJob entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveFormattedImportJobResultsRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveFormXml message privileges

The following table lists the privileges needed for the RetrieveFormXmlRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
 | Content coming soon.

See Also

Concepts

SystemForm entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveFormXmlRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveInstalledLanguagePacks message privileges

The following table lists the privileges needed for the RetrieveInstalledLanguagePacksRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
RetrieveInstalledLanguagePacksRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveInstalledLanguagePackVersion message privileges

The following table lists the privileges needed for the RetrieveInstalledLanguagePackVersionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
RetrieveInstalledLanguagePackVersionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveLicenseInfo message privileges

The following table lists the privileges needed for the RetrieveLicenseInfoRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privileges

prvReadLicense

See Also

Other Resources

Privileges by message
RetrieveLicenseInfoRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveLocLabels message privileges

The following table lists the privileges needed for the RetrieveLocLabelsRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | prvReadQuery

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveLocLabelsRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveManagedProperty message privileges

The following table lists the privileges needed for the RetrieveManagedPropertyRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
RetrieveManagedPropertyRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveMembersBulkOperation message privileges

The following table lists the privileges needed for the RetrieveMembersBulkOperationRequestmessage. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
bulkoperation | prvReadAccount prvReadActivity prvReadCampaign prvReadContact prvReadLead prvReadList

See Also

Reference

BulkOperation (quick campaign) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveMembersBulkOperationRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveMembersTeam message privileges

The following table lists the privileges needed for the RetrieveMembersTeamRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
team | prvReadUser

See Also

Concepts

Team entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveMembersTeamRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveMissingComponents message privileges

The following table lists the privileges needed for the RetrieveMissingComponentsRequestmessage. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
dependency | prvReadSolution

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveMissingComponentsRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveMissingDependencies message privileges

The following table lists the privileges needed for the RetrieveMissingDependenciesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
dependency | prvReadSolution

See Also

Concepts

Dependency entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveMissingDependenciesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveMultiple message privileges

The following table lists the privileges needed for the RetrieveMultipleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvReadAccount
activitymimeattachment | prvReadActivity
activityparty |
activitypointer | prvReadActivity
annotation | prvReadNote
annualfiscalcalendar | prvReadUser
applicationfile | prvReadApplicationFile
appointment | prvReadActivity
asyncoperation | prvReadAsyncOperation
asyncoperation | prvReadPluginType
asyncoperation | prvReadSdkMessage
asyncoperation | prvReadSdkMessageProcessingStep
asyncoperation | prvReadSdkMessageProcessingStepImage
attachment |
attributemap | prvReadAttributeMap
audit | prvReadList
bulkdeletefailure | prvReadAsyncOperation
bulkdeleteoperation | prvReadAsyncOperation
bulkoperation | prvReadActivity
bulkoperationlog | prvReadActivity
businessunit | prvReadBusinessUnit
businessunitnewsarticle | prvReadNewsArticle
calendar | prvReadCalendar
calendar | prvReadOrganization
campaign | prvReadCampaign
campaignactivity | prvReadActivity
campaignresponse | prvReadActivity
columnmapping | prvReadImportMap
competitor | prvReadCompetitor
competitor | prvReadProduct
connection | prvReadConnection
connectionrole | prvReadConnectionRole
connectionroleobjecttypecode | prvReadConnectionRole
constraintbasedgroup | prvReadService
contact | prvReadContact
contract | prvReadContract
contractdetail | prvReadContract
contracttemplate | prvReadContractTemplate
customeraddress | prvReadAccount
customeraddress | prvReadContact
customeropportunityrole | prvReadCustomerOpportunityRole
customerrelationship | prvReadCustomerRelationship
dependency |
dependencynode |
discount | prvReadProduct
discounttype | prvReadProduct
displaystring | prvReadCustomization
displaystringmap |
documentindex |
duplicaterecord | prvReadAsyncOperation
duplicaterule | prvReadDuplicateRule
duplicaterulecondition | prvReadDuplicateRule
email | prvReadActivity
emailhash | prvReadActivity
emailsearch |
entitymap | prvReadEntityMap
equipment | prvReadEquipment
fax | prvReadActivity
fieldpermission | prvReadFieldSecurityProfile
fieldsecurityprofile | prvReadFieldSecurityProfile
fieldsecurityprofile | prvReadUser
filtertemplate |
fixedmonthlyfiscalcalendar | prvReadUser
goal | prvReadGoal
goal | prvReadMetric
goal | prvReadPluginAssembly
goal | prvReadPluginType
goal | prvReadSdkMessage
goal | prvReadSdkMessageProcessingStep
goal | prvReadSdkMessageProcessingStepImage
goalrollupquery | prvReadGoalRollupQuery
import | prvReadImport
importdata | prvReadImport
importdata | prvReadImportData
importdata | prvReadImportFile
importentitymapping | prvReadImportMap
importfile | prvReadImport
importfile | prvReadImportFile
importjob | prvReadImportJob
importlog | prvReadImport
importlog | prvReadImportFile
importlog | prvReadImportLog
importmap | prvReadImportMap
incident | prvReadIncident
incidentresolution | prvReadActivity
invoice | prvReadInvoice
invoicedetail | prvReadInvoice
isvconfig | prvReadCustomization
kbarticle | prvReadArticle
kbarticlecomment | prvReadArticle
kbarticletemplate | prvReadArticleTemplate
lead | prvReadLead
letter | prvReadActivity
list | prvReadList
lookupmapping | prvReadImportMap
mailmergetemplate | prvReadMailMergeTemplate
metric | prvReadMetric
monthlyfiscalcalendar | prvReadUser
opportunity | prvReadOpportunity
opportunityclose | prvReadActivity
opportunityproduct | prvReadOpportunity
orderclose | prvReadActivity
organization | prvReadOrganization
ownermapping | prvReadImportMap
phonecall | prvReadActivity
picklistmapping | prvReadImportMap
pluginassembly | prvReadPluginAssembly
plugintype | prvReadPluginType
plugintypestatistic | prvReadPluginType
pricelevel | prvReadProduct
principalobjectattributeaccess | prvReadPrincipalObjectAttributeAccess
privilege |
processsession | prvReadWorkflowSession
product | prvReadProduct
productpricelevel | prvReadProduct
publisher | prvReadPublisher
quarterlyfiscalcalendar | prvReadUser
queue | prvReadQueue
queueitem | prvReadQueue
quote | prvReadAccount
quote | prvReadQuote
quoteclose | prvReadActivity
quotedetail | prvReadQuote
recurrencerule | prvReadActivity
recurringappointmentmaster | prvReadActivity
recurringappointmentmaster | prvReadSdkMessage
recurringappointmentmaster | prvReadSdkMessageProcessingStep
recurringappointmentmaster | prvReadSdkMessageProcessingStepImage
relationshiprole | prvReadRelationshipRole
relationshiprolemap | prvReadRelationshipRole
report | prvReadReport
reportcategory | prvReadReport
reportentity | prvReadReport
reportlink | prvReadReport
reportvisibility | prvReadReport
resource | prvReadService
resourcegroup |
resourcespec | prvReadService
ribboncommand | prvReadCustomization
ribboncontextgroup | prvReadCustomization
ribboncustomization | prvReadCustomization
ribbondiff | prvReadCustomization
ribbonrule | prvReadCustomization
ribbontabtocommandmap | prvReadCustomization
role | prvReadRole
rollupfield | prvReadMetric
rollupfield | prvReadSdkMessage
rollupfield | prvReadSdkMessageProcessingStep
rollupfield | prvReadSdkMessageProcessingStepImage
salesliterature | prvReadSalesLiterature
salesliteratureitem | prvReadSalesLiterature
salesorder | prvReadOrder
salesorderdetail | prvReadOrder
salesprocessinstance | prvReadAsyncOperation
savedquery | prvReadQuery
savedqueryvisualization | prvReadSavedQueryVisualizations
savedqueryvisualization | prvReadVisualizationModule
sdkmessage | prvReadSdkMessage
sdkmessagefilter | prvReadSdkMessage
sdkmessagepair | prvReadSdkMessage
sdkmessageprocessingstep | prvReadSdkMessageProcessingStep
sdkmessageprocessingstepimage | prvReadSdkMessageProcessingStepImage
sdkmessageprocessingstepsecureconfig | prvReadSdkMessageProcessingStepSecureConfig
sdkmessagerequest | prvReadSdkMessage
sdkmessagerequestfield | prvReadSdkMessage
sdkmessageresponse | prvReadSdkMessage
sdkmessageresponsefield | prvReadSdkMessage
semiannualfiscalcalendar | prvReadUser
service | prvReadService
serviceappointment | prvReadActivity
serviceendpoint | prvReadServiceEndpoint
sharepointdocumentlocation | prvReadSharePointDocumentLocation
sharepointsite | prvReadSharePointSite
site | prvReadSite
sitemap | prvReadCustomization
solution | prvReadSolution
solutioncomponent |
statusmap |
stringmap |
subject | prvReadSubject
subscriptionmanuallytrackedobject |
systemform | prvReadSystemForm
systemuser | prvReadUser
task | prvReadActivity
team | prvReadTeam
template | prvReadEmailTemplate
territory | prvReadOrganization
territory | prvReadTerritory
timezonedefinition |
timezonelocalizedname |
timezonerule |
transactioncurrency | prvReadTransactionCurrency
transformationmapping | prvReadImportMap
transformationparametermapping | prvReadImportMap
uom | prvReadProduct
uomschedule | prvReadProduct
userentityinstancedata | prvReadUserEntityInstanceData
userentityuisettings | prvReadUserEntityUISettings
userfiscalcalendar | prvReadUser
userform | prvReadUserForm
userquery | prvReadUserQuery
userqueryvisualization | prvReadUserQueryVisualizations
usersettings | prvReadUserSettings
webresource | prvReadWebResource
webwizard | prvReadWebWizard
wizardaccessprivilege | prvReadWizardAccessPrivilege
wizardpage | prvReadWizardPage
workflow | prvReadWorkflow
workflowdependency | prvReadSdkMessage
workflowdependency | prvReadSdkMessageProcessingStep
workflowdependency | prvReadSdkMessageProcessingStepImage
workflowdependency | prvReadWorkflow
workflowlog | prvReadAsyncOperation

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveMultipleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveOptionSet message privileges

The following table lists the privileges needed for the RetrieveOptionSetRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
RetrieveOptionSetRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveOrganizationResources message privileges

The following table lists the privileges needed for the RetrieveOrganizationResourcesRequestmessage. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveOrganizationResourcesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveParentGroupsResourceGroup message privileges

The following table lists the privileges needed for the RetrieveParentGroupsResourceGroupRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
resourcegroup | prvReadService

See Also

Concepts

ResourceGroup (scheduling group) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveParentGroupsResourceGroupRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveParsedDataImportFile message privileges

The following table lists the privileges needed for the RetrieveParsedDataImportFileRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
importfile | prvReadImport

See Also

Concepts

ImportFile (import source file) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveParsedDataImportFileRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrievePersonalWall message privileges

The following table lists the privileges needed for the RetrievePersonalWallRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
Post | prvReadPost

See Also

Reference

Post entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrievePersonalWallRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrievePrincipalAccess message privileges

The following table lists the privileges needed for the RetrievePrincipalAccessRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvReadAccount
annotation | prvReadNote
appointment | prvReadActivity
bulkoperation | prvReadActivity
campaign | prvReadCampaign
campaignactivity | prvReadActivity
campaignresponse | prvReadActivity
connection | prvReadConnection
contact | prvReadContact
contract | prvReadContract
customeropportunityrole | prvReadCustomerOpportunityRole
customerrelationship | prvReadCustomerRelationship
duplicaterule | prvReadDuplicateRule
email | prvReadActivity
fax | prvReadActivity
importmap | prvReadImportMap
incident | prvReadIncident
incidentresolution | prvReadActivity
invoice | prvReadInvoice
lead | prvReadLead
letter | prvReadActivity
list | prvReadList
mailmergetemplate | prvReadMailMergeTemplate
opportunity | prvReadOpportunity
opportunityclose | prvReadActivity
orderclose | prvReadActivity
phonecall | prvReadActivity
processsession | prvReadWorkflowSession
quote | prvReadQuote
quoteclose | prvReadActivity
recurringappointmentmaster | prvReadActivity
report | prvReadReport
salesorder | prvReadOrder
serviceappointment | prvReadActivity
task | prvReadActivity
template | prvReadEmailTemplate
userform | prvReadUserForm
userquery | prvReadUserQuery
workflow | prvReadWorkflow

See Also

Other Resources

Privileges by message
Privileges by entity
RetrievePrincipalAccessRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrievePrincipalAttributePrivileges message privileges

The following table lists the privileges needed for the RetrievePrincipalAttributePrivilegesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Privileges

prvReadUser

See Also

Other Resources

Privileges by message
Privileges by entity
RetrievePrincipalAttributePrivilegesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrievePrivilegeSet message privileges

The following table lists the privileges needed for the RetrievePrivilegeSetRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
None | None

See Also

Concepts

Privilege entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrievePrivilegeSetRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveProvisionedLanguages message privileges

The following table lists the privileges needed for the RetrieveProvisionedLanguagesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
RetrieveProvisionedLanguagesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveProvisionedLanguagePackVersion message privileges

The following table lists the privileges needed for the RetrieveProvisionedLanguagePackVersionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
RetrieveProvisionedLanguagePackVersionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveRecordChangeHistory message privileges

The following table lists the privileges needed for the RetrieveRecordChangeHistoryRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
audit | prvReadRecordAuditHistory

See Also

Reference

Audit (auditing) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveRecordChangeHistoryRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveRecordWall message privileges

The following table lists the privileges needed for the RetrieveRecordWallRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
Post | prvReadPost

See Also

Reference

Post entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveRecordWallRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveRelationship message privileges

The following table lists the privileges needed for the RetrieveRelationshipRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
RetrieveRelationshipRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveRequiredComponents message privileges

The following table lists the privileges needed for the RetrieveRequiredComponentsRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
dependency | None

See Also

Concepts

Dependency entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveRequiredComponentsRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveRolePrivilegesRole message privileges

The following table lists the privileges needed for the RetrieveRolePrivilegesRoleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
role | prvReadRole

See Also

Concepts

Role (security role) entity privileges
Privilege entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveRolePrivilegesRoleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveSharedPrincipalsAndAccess message privileges

The following table lists the privileges needed for the RetrieveSharedPrincipalsAndAccessRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvReadAccount
annotation | prvReadNote
appointment | prvReadActivity
campaign | prvReadCampaign
campaignactivity | prvReadActivity
campaignresponse | prvReadActivity
contact | prvReadContact
contract | prvReadContract
customeropportunityrole | prvReadCustomerOpportunityRole
customerrelationship | prvReadCustomerRelationship
duplicaterule | prvReadDuplicateRule
email | prvReadActivity
fax | prvReadActivity
importmap | prvReadImportMap
incident | prvReadIncident
incidentresolution | prvReadActivity
invoice | prvReadInvoice
lead | prvReadLead
letter | prvReadActivity
list | prvReadList
mailmergetemplate | prvReadMailMergeTemplate
opportunity | prvReadOpportunity
opportunityclose | prvReadActivity
orderclose | prvReadActivity
phonecall | prvReadActivity
processsession | prvReadWorkflowSession
queue | prvReadQueue
quote | prvReadQuote
quoteclose | prvReadActivity
recurringappointmentmaster | prvReadActivity
report | prvReadReport
salesorder | prvReadOrder
serviceappointment | prvReadActivity
task | prvReadActivity
template | prvReadEmailTemplate
userform | prvReadUserForm
userquery | prvReadUserQuery
workflow | prvReadWorkflow

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveSharedPrincipalsAndAccessRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveSubGroupsResourceGroup message privileges

The following table lists the privileges needed for the RetrieveSubGroupsResourceGroupRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
resourcegroup | prvReadService

See Also

Concepts

ResourceGroup (scheduling group) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveSubGroupsResourceGroupRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveSubsidiaryTeamsBusinessUnit message privileges

The following table lists the privileges needed for the RetrieveSubsidiaryTeamsBusinessUnitRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
businessunit | prvReadTeam

See Also

Reference

BusinessUnit entity privileges

Concepts

Team entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveSubsidiaryTeamsBusinessUnitRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveSubsidiaryUsersBusinessUnit message privileges

The following table lists the privileges needed for the RetrieveSubsidiaryUsersBusinessUnitRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
businessunit | prvReadUser

See Also

Reference

BusinessUnit entity privileges

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveSubsidiaryUsersBusinessUnitRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveTeamPrivileges message privileges

The following table lists the privileges needed for the RetrieveTeamPrivilegesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
team | prvReadTeam

See Also

Concepts

Team entity privileges
Privilege entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveTeamPrivilegesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveTeamsSystemUser message privileges

The following table lists the privileges needed for the RetrieveTeamsSystemUserRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
systemuser | prvReadTeam

See Also

Concepts

SystemUser (user) entity privileges
Team entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveTeamsSystemUserRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveTimestamp message privileges

The following table lists the privileges needed for the RetrieveTimestampRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveTimestampRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveUnpublished message privileges

The following table lists the privileges needed for the RetrieveUnpublishedRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
savedquery | prvReadQuery
systemform | prvReadSystemForm
webresource | prvReadWebResource

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveUnpublishedRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveUnpublishedMultiple message privileges

The following table lists the privileges needed for the RetrieveUnpublishedMultipleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
savedqueryvisualization | prvReadQuery prvReadSavedQueryVisualizations
sitemap | prvReadCustomization
systemform | prvReadSystemForm
webresource | prvReadWebResource

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveUnpublishedMultipleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveUserPrivileges message privileges

The following table lists the privileges needed for the RetrieveUserPrivilegesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
systemuser | prvReadOrganization prvReadUser

See Also

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveUserPrivilegesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveUserQueues message privileges

The following table lists the privileges needed for the RetrieveUserQueuesRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
Queue | prvReadQueue

See Also

Concepts

Queue entity privileges
Queue entity messages and methods

Other Resources

Privileges by message
RetrieveUserQueuesRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveUserSettingsSystemUser message privileges

The following table lists the privileges needed for the RetrieveUserSettingsSystemUserRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
systemuser | prvReadUserSettings

See Also

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
RetrieveUserSettingsSystemUserRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RetrieveVersion message privileges

The following table lists the privileges needed for the RetrieveVersionRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | None

See Also

Other Resources

Privileges by message
Privileges by entity
RetrieveVersionRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ReviseQuote message privileges

The following table lists the privileges needed for the ReviseQuoteRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
quote | prvAppendQuote prvAppendToAccount prvAppendToProduct prvCreateQuote prvReadQuote

See Also

Concepts

Quote entity privileges

Other Resources

Privileges by message
Privileges by entity
ReviseQuoteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RevokeAccess message privileges

The following table lists the privileges needed for the RevokeAccessRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvShareAccount
annotation | prvShareNote
appointment | prvShareActivity
campaign | prvShareCampaign
campaignactivity | prvShareActivity
campaignresponse | prvShareActivity
connection | prvShareConnection
contact | prvShareContact
contract | prvShareContract
customeropportunityrole | prvShareCustomerOpportunityRole
customerrelationship | prvShareCustomerRelationship
duplicaterule | prvShareDuplicateRule
email | prvShareActivity
fax | prvShareActivity
importmap | prvShareImportMap
incident | prvShareIncident
incidentresolution | prvShareActivity
invoice | prvShareInvoice
lead | prvShareLead
letter | prvShareActivity
list | prvShareList
mailmergetemplate | prvShareMailMergeTemplate
opportunity | prvShareOpportunity
opportunityclose | prvShareActivity
orderclose | prvShareActivity
phonecall | prvShareActivity
processsession | prvShareWorkflowSession
queue | prvShareQueue
quote | prvShareQuote
quoteclose | prvShareActivity
recurringappointmentmaster | prvShareActivity
report | prvShareReport
salesorder | prvShareOrder
serviceappointment | prvShareActivity
task | prvShareActivity
template | prvShareEmailTemplate
userform | prvShareUserForm
userquery | prvShareUserQuery
workflow | prvShareWorkflow

See Also

Other Resources

Privileges by message
Privileges by entity
RevokeAccessRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Rollup message privileges

The following table lists the privileges needed for the RollupRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Secondary Entity | Privilege
activitypointer | account contact opportunity | prvReadActivity
annotation | account contact opportunity | prvReadNote
contract | account contact | prvReadContract
incident | account contact | prvReadIncident
invoice | account contact | prvReadInvoice
opportunity | account contact | prvReadOpportunity
quote | account contact | prvReadQuote
salesorder | account | prvReadOrder

See Also

Other Resources

Privileges by message
Privileges by entity
RollupRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


RouteTo message privileges

The following table lists the privileges needed for the RouteToRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
queue |

See Also

Concepts

Queue entity privileges
QueueItem entity privileges
QueueItem entity messages and methods

Other Resources

Privileges by message
RouteToRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SearchByBodyKbArticle message privileges

The following table lists the privileges needed for the SearchByBodyKbArticleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | None

See Also

Concepts

KbArticle (article) entity privileges

Other Resources

Privileges by message
Privileges by entity
SearchByBodyKbArticleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SearchByKeywordsKbArticle message privileges

The following table lists the privileges needed for the SearchByKeywordsKbArticleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
None | None

See Also

Concepts

KbArticle (article) entity privileges

Other Resources

Privileges by message
Privileges by entity
SearchByKeywordsKbArticleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SearchByTitleKbArticle message privileges

The following table lists the privileges needed for the SearchByTitleKbArticleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | None

See Also

Concepts

KbArticle (article) entity privileges

Other Resources

Privileges by message
Privileges by entity
SearchByTitleKbArticleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Search message privileges

The following table lists the privileges needed for the SearchRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
 | prvSearchAvailability prvReadService

See Also

Other Resources

Privileges by message
Privileges by entity
SearchRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SendBulkMail message privileges

The following table lists the privileges needed for the SendBulkMailRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
email | prvReadActivity prvReadUser prvWriteActivity

See Also

Concepts

Email entity privileges

Other Resources

Privileges by message
Privileges by entity
SendBulkMailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SendEmailFromTemplate message privileges

The following table lists the privileges needed for the SendEmailFromTemplateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
template | prvReadActivity prvReadUser prvWriteActivity

See Also

Concepts

Template (email template) entity privileges

Other Resources

Privileges by message
Privileges by entity
SendEmailFromTemplateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SendEmail message privileges

The following table lists the privileges needed for the SendBulkMailRequestmessage. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
email | prvReadActivity prvReadUser prvWriteActivity

See Also

Concepts

Email entity privileges

Other Resources

Privileges by message
Privileges by entity
SendBulkMailRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SendFax message privileges

The following table lists the privileges needed for the SendFaxRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
fax | prvReadActivity prvWriteActivity

See Also

Concepts

Fax entity privileges

Other Resources

Privileges by message
Privileges by entity
SendFaxRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SendTemplate message privileges

The following table lists the privileges needed for the SendEmailFromTemplateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
template | prvReadActivity prvReadTemplate prvWriteActivity

See Also

Concepts

Template (email template) entity privileges

Other Resources

Privileges by message
Privileges by entity
SendEmailFromTemplateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetBusinessEquipment message privileges

The following table lists the privileges needed for the SetBusinessEquipmentRequestmessage. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
equipment | prvReadEquipment

See Also

Concepts

Equipment (facility/equipment) entity privileges

Other Resources

Privileges by message
Privileges by entity
SetBusinessEquipmentRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetBusinessSystemUser message privileges

The following table lists the privileges needed for the SetBusinessSystemUserRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
systemuser | prvReadBusinessUnit prvReadUser prvWriteUser

See Also

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
SetBusinessSystemUserRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetDataEncryptionKey message privileges

The following table lists the privileges needed for the SetSqlEncryptionKeyRequest message. The exact set of privileges needed depends on the entity types specified in the request.

See Also

Reference

SetSqlEncryptionKeyRequest

Other Resources

Privileges by message
Privileges by entity

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetLocLabels message privileges

The following table lists the privileges needed for the SetLocLabelsRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
None | prvWriteQuery

See Also

Other Resources

Privileges by message
Privileges by entity
SetLocLabelsRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetParentBusinessUnit message privileges

The following table lists the privileges needed for the SetParentBusinessUnitRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
businessunit | prvReadBusinessUnit prvReparentBusinessUnit prvWriteBusinessUnit

See Also

Reference

BusinessUnit entity privileges

Other Resources

Privileges by message
Privileges by entity
SetParentBusinessUnitRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetParentSystemUser message privileges

The following table lists the privileges needed for the SetParentSystemUserRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
systemuser | prvReadUser prvWriteUser

See Also

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
SetParentSystemUserRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetParentTeam message privileges

The following table lists the privileges needed for the SetParentTeamRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Entity | Privileges
team | prvWriteTeam

See Also

Concepts

Team entity privileges

Other Resources

Privileges by message
Privileges by entity
SetParentTeamRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetRelated message privileges

The following table lists the privileges needed for the SetRelatedRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Secondary Entity | Privilege
invoice | contact | prvAppendInvoice prvAppendToContact
lead | account | prvAppendLead prvAppendToAccount
lead | contact | prvAppendToContact
opportunity | account | prvAppendCustomerOpportunityRole prvAppendToAccount prvAppendToOpportunity prvCreateCustomerOpportunityRole prvReadCustomerOpportunityRole
opportunity | competitor | prvAppendToCompetitor
opportunity | contact | prvAppendCustomerOpportunityRole prvAppendToContact prvAppendToOpportunity prvCreateCustomerOpportunityRole prvReadCustomerOpportunityRole
product | competitor | prvAppendProduct prvAppendToCompetitor
product | lead | prvAppendProduct prvAppendToLead
quote | contact | prvAppendQuote prvAppendToContact
salesliterature | competitor | prvAppendSalesLiterature prvAppendToCompetitor
salesliterature | product | prvAppendSalesLiterature prvAppendToProduct
salesorder | contact | prvAppendOrder prvAppendToContact

See Also

Other Resources

Privileges by message
Privileges by entity
SetRelatedRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetReportRelated message privileges

The following table lists the privileges needed for the SetReportRelatedRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privileges
report | prvAppendToReport prvCreateReport

See Also

Concepts

Report entity privileges

Other Resources

Privileges by message
Privileges by entity
SetReportRelatedRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SetState message privileges

The following table lists the privileges needed for the SetStateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvWriteAccount
appointment | prvWriteActivity
businessunit | prvDisableBusinessUnit
campaign | prvWriteCampaign
campaignactivity | prvWriteActivity
campaignresponse | prvWriteActivity
connection | prvWriteConnection
contact | prvWriteContact
contract | prvReadContract prvWriteContract
contractdetail | prvReadContract prvWriteContract
discounttype | prvWriteProduct
email | prvWriteActivity
fax | prvWriteActivity
goal | prvWriteGoal
incident | prvWriteIncident
incidentresolution | prvWriteActivity
invoice | prvWriteInvoice
kbarticle | prvWriteArticle
lead | prvReadLead prvWriteLead
list | prvWriteList
mailmergetemplate | prvWriteMailMergeTemplate
opportunity | prvReadActivity
opportunityclose | prvWriteActivity
orderclose | prvWriteActivity
phonecall | prvWriteActivity
pricelevel | prvWriteProduct
product | prvWriteProduct
quote | prvWriteQuote
quoteclose | prvWriteActivity
recurringappointmentmaster | prvWriteActivity
relationshiprole | prvWriteRelationshipRole
salesorder | prvWriteOrder
savedquery | prvReadQuery
sdkmessageprocessingstep | prvReadSdkMessageProcessingStep prvWriteSdkMessageProcessingStep
serviceappointment | prvReadActivity prvWriteActivity
systemuser | prvDisableUser
task | prvWriteActivity
userquery | prvReadUserQuery prvWriteUserQuery
workflow | prvAppendToWorkflow prvCreateWorkflow prvReadNote prvReadPluginAssembly prvReadPluginType prvReadSdkMessage prvReadSdkMessageProcessingStep prvReadWorkflow prvWriteWorkflow

See Also

Other Resources

Privileges by message
Privileges by entity
SetStateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


StatusUpdateBulkOperation message privileges

The following table lists the privileges needed for the StatusUpdateBulkOperationRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
bulkoperation | prvReadActivity prvWriteActivity

See Also

Reference

BulkOperation (quick campaign) entity privileges

Other Resources

Privileges by message
Privileges by entity
StatusUpdateBulkOperationRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TransformImport message privileges

The following table lists the privileges needed for the TransformImportRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
import | prvCreateImport prvReadAsyncOperation prvReadImport prvReadImportFile

See Also

Concepts

Import (data import) entity privileges

Other Resources

Privileges by message
Privileges by entity
TransformImportRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


TriggerServiceEndpointCheck message privileges

The following table lists the privileges needed for the TriggerServiceEndpointCheckRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | Content coming soon.

See Also

Other Resources

Privileges by message
Privileges by entity
TriggerServiceEndpointCheckRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UninstallSampleData message privileges

The following table lists the privileges needed for the UnInstallSampleDataRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
organization | prvBulkDelete prvDeleteAccount prvDeleteActivity prvDeleteArticle prvDeleteCampaign prvDeleteContact prvDeleteGoal prvDeleteImport prvDeleteIncident prvDeleteLead prvDeleteOpportunity prvDeleteSubject prvReadImport prvReadImportFile prvReadOrganization prvWriteOrganization

See Also

Other Resources

Privileges by message
Privileges by entity
UnInstallSampleDataRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UnlockInvoicePricing message privileges

The following table lists the privileges needed for the UnlockInvoicePricingRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
invoice | prvReadInvoice prvWriteInvoice

See Also

Concepts

Invoice entity privileges

Other Resources

Privileges by message
Privileges by entity
UnlockInvoicePricingRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UnlockSalesOrderPricing message privileges

The following table lists the privileges needed for the UnlockSalesOrderPricingRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
salesorder | prvReadOrder prvWriteOrder

See Also

Concepts

SalesOrder (order) entity privileges

Other Resources

Privileges by message
Privileges by entity
UnlockSalesOrderPricingRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UnpublishDuplicateRule message privileges

The following table lists the privileges needed for the UnpublishDuplicateRuleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
duplicaterule | prvPublishDuplicateRule prvReadDuplicateRule

See Also

Concepts

DuplicateRule (duplicate detection rule) entity privileges

Other Resources

Privileges by message
Privileges by entity
UnpublishDuplicateRuleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Update message privileges

The following table lists the privileges needed for the UpdateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
account | prvWriteAccount
activitymimeattachment | prvReadActivity prvWriteActivity
annotation | prvWriteNote
appointment | prvReadActivity
asyncoperation | prvReadAsyncOperation prvWriteAsyncOperation
bulkoperation |
businessunit | prvWriteBusinessUnit
businessunitnewsarticle | prvWriteNewsArticle
calendar | prvReadOrganization prvReadService prvWriteCalendar
campaign | prvReadCampaign prvWriteCampaign
campaignactivity | prvReadActivity prvWriteActivity
campaignresponse | prvReadActivity prvWriteActivity
competitor | prvWriteCompetitor
connection | prvReadConnection
connectionrole | prvWriteConnectionRole
constraintbasedgroup | prvWriteService
contact | prvReadContact prvWriteContact
contract | prvAppendContract prvAppendToAccount prvAppendToContact prvAppendToContractTemplate prvReadContract prvReadContractTemplate prvWriteContract
contractdetail | prvReadContract prvWriteContract
contracttemplate | prvWriteContractTemplate
customeraddress | prvReadAccount prvWriteAccount
customeropportunityrole | prvAppendCustomerOpportunityRole prvAppendToAccount prvReadCustomerOpportunityRole prvWriteCustomerOpportunityRole
customerrelationship | prvAppendCustomerRelationship prvAppendToAccount prvReadCustomerRelationship prvWriteCustomerRelationship
discount | prvReadProduct prvWriteProduct
discounttype | prvReadProduct prvWriteProduct
displaystring | prvReadCustomization prvWriteCustomization
duplicaterule | prvReadDuplicateRule prvWriteDuplicateRule
duplicaterulecondition | prvReadDuplicateRule prvWriteDuplicateRule
email | prvAppendActivity prvReadAccount prvReadActivity prvReadUser prvWriteActivity
equipment | prvWriteEquipment
fax | prvReadActivity
fieldpermission | prvReadFieldSecurityProfile prvWriteFieldSecurityProfile
fieldsecurityprofile | prvWriteFieldSecurityProfile
goal | prvAppendGoal prvAppendToGoalRollupQuery prvAppendToMetric prvAppendToUser prvReadGoal prvWriteGoal
goalrollupquery | prvWriteGoalRollupQuery
import | prvWriteImport
importfile | prvReadImport prvWriteImport
importjob | prvWriteImportJob
importmap | prvWriteImportMap
incident | prvAppendIncident prvAppendToAccount prvReadIncident prvWriteIncident
incidentresolution | prvReadActivity
invoice | prvWriteInvoice
invoicedetail | prvWriteInvoice
kbarticle | prvAppendToSubject prvReadArticle prvWriteArticle
kbarticlecomment | prvWriteArticle
kbarticletemplate | prvWriteArticleTemplate
lead | prvReadLead prvWriteLead
letter | prvReadActivity
list | prvReadList prvWriteList
mailmergetemplate | prvWriteMailMergeTemplate
metric | prvWriteMetric
opportunity | prvWriteOpportunity
opportunityclose | prvReadActivity
opportunityproduct | prvWriteOpportunity
orderclose | prvReadActivity
organization | prvWriteOrganization
phonecall | prvReadActivity prvWriteActivity
pluginassembly | prvReadPluginAssembly prvReadPluginType prvReadSdkMessage prvReadSdkMessageProcessingStep prvReadSdkMessageProcessingStepImage prvReadUser
plugintype | prvReadPluginAssembly prvReadPluginType
pricelevel | prvWriteProduct
principalobjectattributeaccess | prvWritePrincipalObjectAttributeAccess
product | prvWriteProduct
productpricelevel | prvWriteProduct
publisher | prvReadPublisher prvReadSolution prvWritePublisher
queue | prvReadQueue prvReadRole prvWriteQueue
quote | prvWriteQuote
quoteclose | prvReadActivity
quotedetail | prvWriteQuote
recurrencerule | prvReadActivity
recurringappointmentmaster | prvReadActivity
relationshiprole | prvWriteRelationshipRole
relationshiprolemap | prvWriteRelationshipRole
report | prvWriteReport
reportcategory | prvWriteReport
reportentity | prvWriteReport
reportvisibility | prvWriteReport
resourcespec | prvWriteService
role | prvReadRole prvWriteRole
salesliterature | prvWriteSalesLiterature
salesliteratureitem | prvWriteSalesLiterature
salesorder | prvAppendOrder prvAppendToContact prvAppendToProduct prvReadOrder prvWriteOrder
salesorderdetail | prvWriteOrder
savedquery | prvWriteQuery
savedqueryvisualization | prvWriteSavedQueryVisualizations
sdkmessageprocessingstep | prvReadPluginType prvReadSdkMessage prvReadSdkMessageProcessingStep prvWriteSdkMessageProcessingStep
service | prvWriteService
serviceappointment | prvReadActivity prvWriteActivity
serviceendpoint | prvReadServiceEndpoint prvWriteServiceEndpoint
sharepointdocumentlocation | prvReadSharePointDocumentLocation prvWriteSharePointDocumentLocation
sharepointsite | prvReadSharePointSite
site | prvWriteSite
sitemap | prvWriteCustomization
solution | prvReadPublisher prvWriteSolution
subject | prvWriteSubject
systemform | prvReadCustomization prvWriteSystemForm
systemuser | prvReadRole prvReadUser prvWriteUser
task | prvAppendActivity prvAppendToContact prvReadActivity prvWriteActivity
team | prvWriteTeam
template | prvReadEmailTemplate prvWriteEmailTemplate
territory | prvWriteTerritory
transactioncurrency | prvWriteTransactionCurrency
uom | prvWriteProduct
uomschedule | prvWriteProduct
userentityinstancedata | prvWriteUserEntityInstanceData
userentityuisettings | prvWriteUserEntityUISettings
userform |
userquery | prvWriteUserQuery
userqueryvisualization | prvWriteUserQueryVisualizations
usersettings | prvWriteUserSettings
webresource | prvWriteWebResource
workflow | prvReadUser prvReadWorkflow prvWriteWorkflow
workflowlog | prvReadSdkMessage prvReadSdkMessageProcessingStep prvReadSdkMessageProcessingStepImage prvWriteAsyncOperation

See Also

Other Resources

Privileges by message
Privileges by entity
UpdateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UpdateAttribute message privileges

The following table lists the privileges needed for the UpdateAttributeRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
UpdateAttributeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UpdateEntity message privileges

The following table lists the privileges needed for the UpdateEntityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
UpdateEntityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UpdateOptionSet message privileges

The following table lists the privileges needed for the UpdateOptionSetRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
UpdateOptionSetRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UpdateOptionValue message privileges

The following table lists the privileges needed for the UpdateOptionValueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
UpdateOptionValueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UpdateRelationship Privileges

The following table lists the privileges needed for the UpdateRelationshipRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
UpdateRelationshipRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UpdateStateValue message privileges

The following table lists the privileges needed for the UpdateStateValueRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
UpdateStateValueRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UpdateUserSettingsSystemUser message privileges

The following table lists the privileges needed for the UpdateUserSettingsSystemUserRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
systemuser | prvWriteUserSettings

See Also

Concepts

SystemUser (user) entity privileges

Other Resources

Privileges by message
Privileges by entity
UpdateUserSettingsSystemUserRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


UtcTimeFromLocalTime message privileges

The following table lists the privileges needed for the UtcTimeFromLocalTimeRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
timezonedefinition | None

See Also

Concepts

TimeZoneDefinition entity privileges

Other Resources

Privileges by message
Privileges by entity
UtcTimeFromLocalTimeRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Validate message privileges

The following table lists the privileges needed for the ValidateRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
 | prvSearchAvailability

See Also

Other Resources

Privileges by message
Privileges by entity
ValidateRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ValidateRecurrenceRule message privileges

The following table lists the privileges needed for the ValidateRecurrenceRuleRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege

See Also

Other Resources

Privileges by message
Privileges by entity
ValidateRecurrenceRuleRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ValidateSavedQuery message privileges

The following table lists the privileges needed for the ValidateSavedQueryRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
savedquery | None

See Also

Concepts

SavedQuery (view) entity privileges

Other Resources

Privileges by message
Privileges by entity
ValidateSavedQueryRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


VerifyProcessStateData message privileges

The following table lists the privileges needed for the VerifyProcessStateDataRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege

See Also

Other Resources

Privileges by message
Privileges by entity
VerifyProcessStateDataRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WhoAmI message privileges

The following table lists the privileges needed for the WhoAmIRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
None | None

See Also

Other Resources

Privileges by message
Privileges by entity
WhoAmIRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WinOpportunity message privileges

The following table lists the privileges needed for the WinOpportunityRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
opportunity | prvAppendActivity prvAppendToOpportunity prvCreateActivity prvWriteOpportunity

See Also

Concepts

Opportunity entity privileges

Other Resources

Privileges by message
Privileges by entity
WinOpportunityRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


WinQuote message privileges

The following table lists the privileges needed for the WinQuoteRequest message. The exact set of privileges needed depends on the entity types specified in the request.

Primary Entity | Privilege
quote | prvAppendActivity prvAppendToQuote prvCreateActivity prvWriteQuote

See Also

Concepts

Quote entity privileges

Other Resources

Privileges by message
Privileges by entity
WinQuoteRequest

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Customization XML reference

The customizations.xml file is one of the files included in an exported unmanaged solution. The file contains all or selected portions of the customizations and configurations for your system.

The solutions file is exported as a compressed .zip file. The contents of the unmanaged solutions file must be extracted before the customizations file can be edited. All the files of the unmanaged solution must be added to a compressed .zip file before it can be re-imported.

Note
  • Editing a managed solution file is not supported.
  • Not all elements of the customizations.xml file can be edited. More information: When to edit the customizations file

In This Section

Ribbon XML reference

SiteMap XML reference

Form XML reference

Saved query XML reference

Related Sections

Security role and privilege reference

Schemas used in Microsoft Dynamics CRM

When to edit the customizations file

Edit the customizations XML file with schema validation

Customize commands and the ribbon

Change application navigation using the SiteMap

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Schemas used in Microsoft Dynamics CRM

This topic contains the schemas needed for features described in the SDK documentation. You can find all schemas in the SDK\Schemas folder in the SDK package. Download the Microsoft Dynamics CRM SDK package.

If you’re developing Microsoft BizTalk applications to access Microsoft Dynamics CRM, use the schema files located in the SDK\Schemas\CRMBizTalkIntegration folder. For more information, see this video that discusses connecting BizTalk with Dynamics CRM.

In This Section

Programming reference

Customization solutions file schema

Form XML schema

FetchXML schema

Visualization data description schema

ISV configuration file schema

Ribbon core schema

Ribbon types schema

Ribbon WSS schema

SiteMap schema

Publish request schema

Report configuration file schema

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


SDK extensions for Microsoft Dynamics CRM

This section is devoted to extensions to the core Microsoft Dynamics CRM SDK that offer additional capabilities and a different developer experience. More extensions will be added as they become available.

In This Section

Developer extensions for Microsoft Dynamics CRM

Learn about extensions to the code generation tool that will improve your development experience.

Portal developer guide for Microsoft Dynamics CRM

Discover how to use the portal toolkit to create portal Web pages that interact with Microsoft Dynamics CRM.

Programming reference for extensions to Microsoft Dynamics CRM

Read the reference documentation for the assemblies provided for these extensions.

Related Sections

Software Development Kit for Microsoft Dynamics CRM

Explore the core SDK, which is provided for developers writing server side code, custom business logic, integration modules, workflow assemblies, plug-ins and much more.

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Developer extensions for Microsoft Dynamics CRM

Developer Extensions for Microsoft Dynamics CRM 2015 is a set of tools included in this SDK that simplifies and accelerates the development of applications that interact with Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. This set of tools extends the functionality of the core Microsoft Dynamics CRM SDK specifically around the use of the OrganizationServiceContext class. Developer extensions provide the following capabilities:

  • Simplified connection to CRM servers provided by the CrmConnection class (Microsoft.Xrm.Client)
  • Code generation of strong types provided by customizations to the code generation tool (CrmSvcUtil.exe)
  • App.config and Web.config configurability for enabling custom extensions provided by the CrmConfigurationManager class (Microsoft.Xrm.Client)
  • Performance enhancements through caching of service results provided by the CachedOrganizationService class (Microsoft.Xrm.Client)

The Portal developer guide for Microsoft Dynamics CRM enables you to build a web portal for CRM. This guide provides the following capabilities:

  • Security Management (Microsoft.Xrm.Portal)
  • Cache Management (Microsoft.Xrm.Portal)
  • Content Management (Microsoft.Xrm.Portal, Microsoft.Xrm.Portal.Files, WebSiteCopy.exe)

Developer Extensions for Microsoft Dynamics CRM supports deployment for CRM on-premises and CRM Online. However, plug-ins that run in the sandbox on CRM Online shouldn’t make use of any classes or methods in Microsoft.Xrm.Client because certain functionality in that assembly isn’t supported in the sandbox.

In This Section

Simplified connection to Microsoft Dynamics CRM

Generate code with the code generation tool extensions

Developer extensions context object model

Portal walkthroughs

Plug-in isolation, trusts, and statistics

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Simplified connection to Microsoft Dynamics CRM

Developer Extensions for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update uses the concept of a connection string to connect to the Microsoft Dynamics CRM server. This is similar to the concept of connection strings used with Microsoft SQL Server. Connection strings are a natural part of the ADO.NET framework and also have native support in configuration files, including the ability to encrypt the configuration sections for maximum security. This encourages you to use a robust model in which Microsoft Dynamics CRM connections are configured at deployment time, and aren’t hard coded in your application. As such, all APIs in Developer Extensions for Microsoft Dynamics CRM work with a CrmConnection object, used internally by the CrmOrganizationServiceContext class as shown in this topic, which uses a connection string to connect to the server.

You supply this connection string in the app.config or web.config file for your project, as shown in the following example.

Xml Copy Code
<connectionStrings>
  <add name="Crm" connectionString="Url=http://crm.contoso.com/xrmContoso;"/>
</connectionStrings>

Security Note
If you add any sensitive information to the app.config or web.config file, for example an account password, be sure to take appropriate security precautions to protect the information.

In This Topic

Create a connection string

Connection string parameters

Connection string examples

Create a connection string

The connection string is used to instantiate a CrmConnection object, which in turn can be used to instantiate an OrganizationService object or a CrmOrganizationServiceContext object.

C# Copy Code
//Use the Microsoft Dynamics CRM Online connection string from the app.config file named "CRMOnline".
var connection = new CrmConnection("CRMOnline");
var service = new OrganizationService(connection);
var context = new CrmOrganizationServiceContext(connection);

A CrmConnection can also be created independently of the app.config file and constructed inline as follows.

C# Copy Code
var connection = CrmConnection.Parse("Url=http://crm.contoso.com/xrmContoso; Domain=CONTOSO; Username=jsmith; Password=passcode;");

Connection string parameters

The basic format of the connection string is the same as an OLEDB connection string. It’s a series of name/value pairs separated by semicolons. The following table lists supported parameters, which can be entered in any order.

Parameter name | Description
Server, Url, or Service Uri | Specifies the URL to the Microsoft Dynamics CRM server. The URL can be http or https and the port is optional if it is http over port 80 or https over port 443. The server URL is typically in the format of http:// crm-server: port/organization-name or for Microsoft Dynamics CRM Online https:// organization-name.crm.dynamics.com. The organization name is required.
Domain | Specifies the domain that will verify user credentials.
Username or User ID | Specifies the user's identification name associated with the credentials.
Password | Specifies the password for the user name associated with the credentials.
Device ID or Device User Name | Specifies the user-defined Microsoft account device identifier. It can be any non-empty string. This device ID will be registered with the device password the first time an authentication is run. If the device ID and password don’t match the previously registered values, the authentication will fail. The device ID applies only to CRM Online.
Device Password | Specifies the user-defined Microsoft account device password. It must be at least six characters in length. This password will be registered with the device ID the first time an authentication is run. If the device ID and password don’t match the previously registerd values, the authentication will fail. The device password applies only to CRM Online.
Timeout | Gets passed to the Timeout property of the OrganizationServiceProxy class.
Home Realm Uri | Gets passed to the HomeRealmUri property of the OrganizationServiceProxy class.
Proxy Types Enabled | True by default, this parameter enables the OrganizationService to return proxy types instead of just the base Entity type.
Proxy Types Assembly | Specifies the assembly that contains the proxy types from Microsoft Dynamics CRM, generated using the CrmSvcUtil.exe tool, with the Microsoft.Xrm.Client.CodeGeneration extension.
Caller ID | Gets passed to the CallerId property of the OrganizationServiceProxy class.
Service Configuration Instance Mode | Can be set to Static, PerName, PerRequest, or PerInstance. PerName is default; this optimizes the number of times an IServiceConfiguration`1 will be created for an OrganizationService, so that only one is created for each connection string. For more information about other possible values, see Specify the instanceMode Attribute.
User Token Expiry Window | Specifies a TimeSpan, formatted hh:mm:ss, used as an offset for when a new user token is retrieved. For example, if this parameter is set to "00:10:00", a new user token will be retrieved 10 minutes before the token actually expires.

Connection string examples

The following example shows the connection string using integrated on-premises authentication.

Copy Code
Url=http://crm.contoso.com/xrmContoso;

The following example shows the connection string using Active Directory authentication.

Copy Code
Url=http://crm.contoso.com/xrmContoso; Domain=CONTOSO; Username=jsmith; Password=passcode

The following example shows the connection string using Microsoft account to connect to Microsoft Dynamics CRM Online…

Copy Code
Url=https://contoso.crm.dynamics.com; Username=jsmith@live-int.com; Password=passcode; DeviceID=contoso-ba9f6b7b2e6d; DevicePassword=passcode

The following example shows the connection string using Microsoft Online Services to connect to Microsoft Dynamics CRM Online.

Copy Code
Url=https://contoso.crm.dynamics.com; Username=jsmith@contoso.onmicrosoft.com; Password=passcode;

See Also

Concepts

Generate code with the code generation tool extensions

Other Resources

Sample: Simplified connection quick start using Microsoft Dynamics CRM
Developer extensions for Microsoft Dynamics CRM
Portal walkthroughs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Generate code with the code generation tool extensions

Developer Extensions for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update provides an extension library for the CrmSvcUtil.exe code generation tool that is used to generate a data context class and data transfer objects (DTOs) for all Microsoft Dynamics CRM entities. This mechanism follows the same design pattern that SqlMetal implements in the entity framework. The data context class is responsible for all data operations and provides IQueryable interfaces for all entities in Microsoft Dynamics CRM. You can retrieve data by executing a LINQ query against the IQueryable entity set properties. You can change data by using the AddObject, DeleteObject, UpdateObject, and SaveChanges methods.

The Microsoft.Xrm.Client.CodeGeneration extension for the CrmSvcUtil.exe code generation tool provides the following capabilities:

  • Generates statically typed entity classes.
  • Generates many-to-many relationship classes.
  • Generates class names and property names based on Microsoft Dynamics CRM schema names.
  • Generates a WCF Data Services (Astoria/OData) compatible data context class for managing entities.

In This Topic

Entity classes

Data context classes

Entity classes

The entity classes generated by the code-generation tool provide the following features:

  • Support for WCF Data Services (Astoria/OData) annotation attributes.
  • Strongly typed entity attribute accessors, which provide the following:
    • Mapping of Microsoft Dynamics CRM data-types into standard CLR data-types.
    • Accessors for many-to-one relationships including:
      • Lazy loading of the related entity.
      • Accessors for the foreign key IDs.
    • Many-to-many relationship accessors, which provide lazy loading of the related entity set.

Data context classes

The data context classes generated by CrmSvcUtil.exe with the Microsoft.Xrm.Client.CodeGeneration extension use the WCF Data Services IUpdatable and IExpandProvider Interface interfaces as a consequence of inheriting the CrmOrganizationServiceContext class. For more information, see the following .NET documentation: IUpdatable Interface and IExpandProvider Interface. These interfaces include the following features:

  • Provides read, create, update, and delete operations for managing entities.
  • Provides set-link, add-link, and remove-link operations for managing relationships (1-to-N, N-to-1, and N-to-N).
  • Supports the DataServiceHostFactory for exposing Web services and REST services.
  • Provides a LINQ query provider for statically or dynamically typed queries.
  • Dynamic queries do not require code-generation
  • Handles caching in the background.

A single context class is generated to provide statically typed entity set accessors. In addition, several sub-classes are generated to provide richer portal capabilities using the query and change interceptor features of WCF Data Services.

See Also

Reference

Use the Generated Class Files
AddObject
DeleteObject
UpdateObject
SaveChanges

Concepts

Developer extensions context object model
CrmSvcUtil.exe extension usage and command-line parameters

Other Resources

Developer extensions for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


CrmSvcUtil.exe extension usage and command-line parameters

Developer Extensions for Microsoft Dynamics CRM 2015 provides an extension to the CrmSvcUtil.exe command-line tool, called the Microsoft.Xrm.Client.CodeGeneration extension, which you can use to generate the data context and data transfer object classes for your Microsoft Dynamics CRM organization.

In This Topic

Use the code generation tool with extensions

Command line parameters

Use the generated class files

Use the code generation tool with extensions

To use the code generation tool with Developer Extensions for Microsoft Dynamics CRM, you specify the codeCustomization parameter as follows:

Copy Code
CrmSvcUtil.exe /codeCustomization:"Microsoft.Xrm.Client.CodeGeneration.CodeCustomization,Microsoft.Xrm.Client.CodeGeneration"
/url:https://crm-org-name.crm.dynamics.com/org-id
/username:user-wlid-email
/password:user-wlid-pwd
/deviceid:user-defined-deviceid
/devicepassword:user-defined-devicepwd"
/out:"Xrm.cs"
/namespace:Xrm

The code customization class is in Microsoft.Xrm.Client.CodeGeneration.dll, and since /codeCustomization takes a type name, CrmSvcUtil needs to be able to find the assembly, which is in the same folder as the tool.

Command line parameters

The following table lists valid command line parameters for the extensions to CrmSvcUtil.exe.

Parameter | Shortcut | Description | Required
deviceid | di | Device ID used when you connect to the online server for authentication. | False
devicepassword | dp | Device password that is used when you connect to the online server for authentication. | False
domain | d | The domain to authenticate against when you connect to the server. | False
url |  | The URL for the Organization service. | True
out | o | The file name for the generated code. | True
language | l | The language to generate the code in. This can be either '”CS” or ”VB”. Default value is ”CS”. | False
namespace | n | The namespace for the generated code. Default namespace is the global namespace. | False
username | u | The user name to use when you connect to the server for authentication. | False
password | p | The password to use when you connect to the server for authentication. | False
servicecontextname |  | The name of the generated organization service context class. If no value is supplied, no service context is created. | False
help | ? | Show usage information. | False
nologo |  | Suppress the banner at runtime. | False

Use the generated class files

The classes that are output by the CrmSvcUtil.exe code generation tool are designed to be built into a class library that can be referenced by your projects that use pn_microsoftcrm. This is the recommended approach. After you have generated classes for your organization using CrmSvcUtil.exe, you should move the files to the folder for your Microsoft Visual Studio project and then add them to your solution.

To work with the classes you will also need a reference to Microsoft Dynamics CRM and .NET assemblies. The following table lists the assemblies and assembly locations.

Add references to these assemblies | Assembly location
Microsoft.Xrm.Sdk.dll | From the SDK\Bin folder.
Microsoft.Xrm.Client Microsoft.Xrm.Portal | From the SDK\Bin folder.
System System.Core System.Data.Services System.Data.Services.Client System.Runtime.Serialization | From the .NET tab.

See Also

Concepts

Generate code with the code generation tool extensions
Create early bound entity classes with the code generation tool (CrmSvcUtil.exe)

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Developer extensions context object model

Developer Extensions for Microsoft Dynamics CRM 2015 provides a set of inter-dependent classes that minimize the work needed to get up and running. The most basic program only requires the connection string (or the name of a connection string in the app.config) and a data context created by CrmSvcUtil.exe as shown in the following example:

C# Copy Code
var connection = CrmConnection.Parse("Url=http://crm.contoso.com/xrmContoso");

using (var context = new XrmServiceContext(connection))
{
var accounts = context.AccountSet;

foreach (var account in accounts)
Console.WriteLine(account.Name);
}

Under the hood there are nested objects that handle lower level operations. The data context is the composition of all of these objects and, therefore, the behavior of the data context is dependent on the objects. These dependencies can be exposed through use of specific constructors. When expanded, the default object composition looks like the following example:

C# Copy Code
var myConnection = CrmConnection.Parse("Url=http://crm.contoso.com/xrmContoso");
var myObjectCache = MemoryCache.Default;
var myServiceCache = new OrganizationServiceCache(myObjectCache, myConnection);
using (var myService = new CachedOrganizationService(myConnection, myServiceCache))
using (var myContext = new XrmServiceContext(myService))
{
}

Dependencies

The following table lists available dependencies and their behaviors.

Interface | Base Class | Default Type | Description | Configuration Element
 | CrmConnection | CrmConnection | The connection details in the form of a connection string. | <connectionStrings>
 | ObjectCache | MemoryCache | The raw data caching service that is independent of the other components of the SDK. | <objectCache>
IOrganizationServiceCache | OrganizationServiceCache | OrganizationServiceCache | A further abstracted data caching service that caches the results of IOrganizationService operations. Automatically sets up cache item dependencies and performing update operations invalidates dependent cache items. | <serviceCache>
IOrganizationService | OrganizationService | CachedOrganizationService | A wrapper class around the IOrganizationService that manages the details of setting up an OrganizationServiceProxy or other arbitrary IOrganizationService objects. When paired with an OrganizationServiceCache object, becomes a cached service. | <services>
 | OrganizationServiceContext |  | The OData and LINQ capable data context. Needs to be specifically declared or configured so no default type exists. | <contexts>
IDiscoveryService | DiscoveryService |  | A wrapper class around the IDiscoveryService that manages the details of setting up a DiscoveryServiceProxy or other arbitrary IDiscoveryService objects. No caching implementations exist for this and cannot be configured in app.config. |

Implementing the interfaces, inheriting the available base classes, or simply rearranging the object nesting can be done to modify the final behavior. For example, one way to disable caching functionality is to omit the cache related objects and prefer the raw base classes.

C# Copy Code
var myConnection = CrmConnection.Parse("Url=http://crm.contoso.com/xrmContoso");
using (var myService = new OrganizationService(myConnection))
using (var myContext = new XrmServiceContext(myService))
{
}

To remove the dependency on code generated by CrmSvcUtil.exe in favor of dynamic code, use the CrmOrganizationServiceContext class. Another scenario is to omit the data context entirely and just invoke the IOrganizationService directly. This is also the approach to invoking the IDiscoveryService.

C# Copy Code
var myConnection = CrmConnection.Parse("Url=http://crm.contoso.com/xrmContoso");
using (var myContext = new CrmOrganizationServiceContext(myConnection))
{
}
using (var myService = new OrganizationService(myConnection))
{
var response = myService.Execute(new WhoAmIRequest()));
}
var discoveryConnection = CrmConnection.Parse("Url=http://crm.contoso.com");
using (var myDiscoveryService = new DiscoveryService(discoveryConnection))
{
var response = myDiscoveryService.Execute(new RetrieveOrganizationsRequest()));
}

Context enhancements

The most significant difference between the CrmOrganizationServiceContext, which is the direct base class of XrmServiceContext, of Developer Extensions for Microsoft Dynamics CRM and the base OrganizationServiceContext in the core SDK, is the implementation of the IUpdatable and IExpandProvider interfaces. This custom implementation allows the generated data context and the entity objects produced by the data context to participate in the WCF Data Services framework. To serve the data context as an OData endpoint, add a new WCF Data Service endpoint (.svc) to an existing Web application.

C# Copy Code
<%@ ServiceHost Language="C#" Factory="System.Data.Services.DataServiceHostFactory, System.Data.Services, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" Service="MySite.MyContext" %>

Here is an example service endpoint code-behind (.svc.cs) that can be used for development. Specify the XrmServiceContext as the generic type parameter of the DataService<T> class.

C# Copy Code
using System.Data.Services;
using System.Data.Services.Common;
using System.ServiceModel;
using Xrm;

namespace MySite
{
[ServiceBehavior(IncludeExceptionDetailInFaults = true)]
public class MyContext : DataService<XrmServiceContext>
{
// This method is called only once to initialize service-wide policies.
public static void InitializeService(DataServiceConfiguration config)
{
// Set rules to indicate which entity sets and service operations are visible, updatable, etc.
config.UseVerboseErrors = true;
config.SetEntitySetAccessRule("*", EntitySetRights.All);
config.SetServiceOperationAccessRule("*", ServiceOperationRights.All);
config.DataServiceBehavior.MaxProtocolVersion = DataServiceProtocolVersion.V2;
}
}
}

See Also

Concepts

Configure the context with the configuration file
Access entity relationships
Attach entities to the context

Other Resources

Developer extensions for Microsoft Dynamics CRM
Portal walkthroughs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Configure the context with the configuration file

When using Developer Extensions forMicrosoft Dynamics CRM 2015, rather than programmatically adjusting the dependency composition, it is possible to influence the default object types by modifying the application configuration file. The minimum configuration provides just the connection string and data context. The default dependency objects are created under the hood just as in the programmatic case.

In This Topic

Overview

Configuration rules

Specify the instanceMode attribute

Default configuration

Overview

The following shows part of the of default configuration file:

Xml Copy Code
<configuration>

 <configSections>
  <section name="microsoft.xrm.client" type="Microsoft.Xrm.Client.Configuration.CrmSection, Microsoft.Xrm.Client"/>
 </configSections>

 <connectionStrings>
  <add name="Xrm" connectionString="Url=http://crm.contoso.com/xrmContoso"/>
 </connectionStrings>

 <microsoft.xrm.client>
  <contexts>
   <add name="Xrm" type="Xrm.XrmServiceContext, Xrm"/>
  </contexts>
 </microsoft.xrm.client>

</configuration>

The CrmConfigurationManager is used to surface the configuration into actual code. The CreateContext method takes the name of the context configuration element that should be used to instantiate the data context.

C# Copy Code
var contextName = "Xrm";
using (var context = CrmConfigurationManager.CreateContext(contextName) as XrmServiceContext)
{
}

Passing null takes the default context configuration element, which is the first element in the collection. In addition, it is possible to override this with an explicit default element. The following code obtains the same results as shown in the preceding example.

C# Copy Code
using (var context = CrmConfigurationManager.CreateContext() as XrmServiceContext)
{
}

The context configuration element is responsible for specifying the connection string and, by default, it looks for a connection string name with the same name as the context configuration element name. The above example matches on the name "Xrm". The connection string name can be specified explicitly to highlight and isolate this relationship, as shown here.

Xml Copy Code
 <connectionStrings>
  <add name="MyCRM" connectionString="Url=http://crm.contoso.com/xrmContoso"/>
 </connectionStrings>

 <microsoft.xrm.client>
  <contexts>
   <add name="Xrm" type="Xrm.XrmServiceContext, Xrm" connectionStringName="MyCRM"/>
  </contexts>
 </microsoft.xrm.client>

The nested dependencies can be specified and linked together, as shown in this example:

Xml Copy Code
 <microsoft.xrm.client>
  <contexts>
   <add name="Xrm" type="Xrm.XrmServiceContext, Xrm" serviceName="MyService"/>
  </contexts>
  <services>
   <add name="MyService" type="Microsoft.Xrm.Client.Services.CachedOrganizationService, Microsoft.Xrm.Client" serviceCacheName="MyServiceCache"/>
  </services>
  <serviceCache>
   <add name="MyServiceCache" type="Microsoft.Xrm.Client.Services.OrganizationServiceCache, Microsoft.Xrm.Client" objectCacheName="MyObjectCache"/>
  </serviceCache>
  <objectCache>
   <add name="MyObjectCache" type="System.Runtime.Caching.MemoryCache, System.Runtime.Caching, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
  </objectCache>
 </microsoft.xrm.client>

The following shows how to disable caching:

Xml Copy Code
<microsoft.xrm.client>
  <contexts>
   <add name="Xrm" type="Xrm.XrmServiceContext, Xrm" serviceName="Xrm"/>
  </contexts>
  <services>
   <add name="Xrm" type="Microsoft.Xrm.Client.Services.OrganizationService, Microsoft.Xrm.Client"/>
  </services>
</microsoft.xrm.client>

Configuration rules

The following lists the rules for configuring the context.

  • Specify the <context> element - A default type class does not exist for the OrganizationServiceContext dependency so specifying the <context/> element is required, unless you are working solely with the dynamic CrmOrganizationServiceContext and without code generation.
  • Optionally specify the dependency name - The default dependency name attribute (such as name="Xrm") is optional. When omitted, the first <add/> element under the configuration collection is the default.
  • Specify the linking attribute – It is common to specify the linking attribute such as serviceName="Xrm", serviceCacheName="Xrm", and objectCacheName="Xrm". However, when a linking attribute is omitted, the CrmConfigurationManager tries to link to the sub-dependency with the same name as the parent dependency.

Any of the dependencies from the configuration can be instantiated with the CrmConfigurationManager along with the appropriate static method. The resulting object can be casted to the known type or referenced as the base type without casting.

C# Copy Code
var name = "Xrm";
var connection = new CrmConnection(name);
var objectCache = CrmConfigurationManager.CreateObjectCache(name) as MemoryCache;
var serviceCache = CrmConfigurationManager.CreateServiceCache(name, connection) as OrganizationServiceCache;
var service = CrmConfigurationManager.CreateService(connection, name) as CachedOrganizationService;
var context = CrmConfigurationManager.CreateContext(name) as XrmServiceContext;

Specify the instanceMode attribute

If a configuration element specifies an InstanceMode attribute, the CrmConfigurationManager will adjust its instantiation behavior accordingly.

  • Static – always returns the same static instance.
  • PerName– returns a single instance for each configuration element specified.
  • PerRequest – returns the same first instance in the context of a Web request, for example. one instance for each HttpContext instance.
  • PerInstance – returns a new instance on each call.

Default configuration

The full configuration with default values:

Xml Copy Code
<configuration>

 <configSections>
  <section name="microsoft.xrm.client" type="Microsoft.Xrm.Client.Configuration.CrmSection, Microsoft.Xrm.Client"/>
 </configSections>

 <connectionStrings>
  <add name="Xrm" connectionString="ServiceUri=...; Domain=...; Username=...; Password=..."/>
 </connectionStrings>

 <microsoft.xrm.client>
  <contexts default="Xrm">
   <add name="Xrm" type="Xrm.XrmServiceContext, Xrm" connectionStringName="Xrm" serviceName="Xrm"/>
  </contexts>
  <services default="Xrm">
   <add
    name="Xrm"
    type="Microsoft.Xrm.Client.Services.CachedOrganizationService, Microsoft.Xrm.Client"
    serviceCacheName="Xrm"
    instanceMode="PerRequest" [Static | PerName | PerRequest | PerInstance]
   />
  </services>
  <serviceCache default="Xrm">
   <add
    name="Xrm"
    type="Microsoft.Xrm.Client.Services.OrganizationServiceCache, Microsoft.Xrm.Client"
    objectCacheName="Xrm"
    cacheMode="LookupAndInsert" [LookupAndInsert | InsertOnly | Disabled]
    returnMode="Cloned" [Shared | Cloned]
    queryHashingEnabled="false" [false | true]
   />
  </serviceCache>
  <objectCache default="Xrm">
   <add
    name="Xrm"
    type="System.Runtime.Caching.MemoryCache, System.Runtime.Caching, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
    instanceMode="PerName" [Static | PerName | PerInstance]
    absoluteExpiration=""
    slidingExpiration="00:00:00" [HH:MM:SS]
    duration="00:00:00" [HH:MM:SS]
    priority="Default" [Default | NotRemovable]
    outputCacheProfileName="Xrm"
   />
  </objectCache>
 </microsoft.xrm.client>

 <system.runtime.caching>
  <memoryCache>
   <namedCaches>
    <add name="Xrm"
     cacheMemoryLimitMegabytes="0"
     physicalMemoryLimitPercentage="0"
     pollingInterval="00:00:00" />
    </namedCaches>
   </memoryCache>
 </system.runtime.caching>

 <system.web>
  <caching>
   <outputCacheSettings>
    <outputCacheProfiles>
     <add name="Xrm" enabled="true" duration="-1"/>
    </outputCacheProfiles>
   </outputCacheSettings>
  </caching>
 </system.web>

</configuration>

See Also

Concepts

Developer extensions context object model
Access entity relationships
Attach entities to the context

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Access entity relationships

Developer Extensions for Microsoft Dynamics CRM also provides helper methods for retrieving related entities. The standard behavior of the OrganizationServiceContext requires entity relationship members to be explicitly loaded before the related entities can be accessed as shown in this example.

C# Copy Code
var connection = CrmConnection.Parse("Url=http://crm.contoso.com/xrmContoso; ProxyTypesAssembly=Xrm;");

using (var service = new OrganizationService(connection))
using (var context = new OrganizationServiceContext(service))
{
var contact = context.CreateQuery<Contact>().First(c => c.FirstName == "Bob");

var currencyEmpty = contact.GetRelatedEntity<Entity>("transactioncurrency_contact");
var currencyEmptyStatic = contact.transactioncurrency_contact;

// currency is always null until after calling LoadProperty

Console.WriteLine(currencyEmpty == null);
Console.WriteLine(currencyEmptyStatic == null);

context.LoadProperty(contact, "transactioncurrency_contact");

// read related entity dynamically
var currency = contact.GetRelatedEntity<Entity>("transactioncurrency_contact");
Console.WriteLine(currency.GetAttributeValue<string>("currencyname"));

// read related entity statically
var currencyStatic = contact.transactioncurrency_contact;
Console.WriteLine(currencyStatic.CurrencyName);
}

For those who prefer to work with statically typed members rather than string-based relationship and attribute names, there is a set of helper methods that take relationship arguments as static expressions. The expression takes the form of a lambda expression with a single Entity parameter. Helper overloads exist for all the OrganizationServiceContext relationship methods including the following:
LoadProperty
GetRelatedEntity
GetRelatedEntities
AttachLink
DetachLink
AddLink
DeleteLink
AddRelatedObject

Use of the LoadProperty helper method is shown in the following example.

C# Copy Code
using Microsoft.Xrm.Client;

using (var service = new OrganizationService(connection))
using (var context = new OrganizationServiceContext(service))
{
var contact = context.CreateQuery<Contact>().First(c => c.FirstName == "Bob");
context.LoadProperty(contact, c => c.transactioncurrency_contact);
var currency = contact.transactioncurrency_contact;
Console.WriteLine(currency.CurrencyName);
}

Another set of helpers calls the LoadProperty method implicitly and takes an OrganizationServiceContext reference as the first parameter. This applies to the GetRelatedEntity and GetRelatedEntities methods as shown here.

C# Copy Code
using (var service = new OrganizationService(connection))
using (var context = new OrganizationServiceContext(service))
{
// use helper method that calls LoadProperty implicitly
var contact = context.CreateQuery<Contact>().First(c => c.FirstName == "Bob");
var currency = contact.GetRelatedEntity(context, "transactioncurrency_contact");
Console.WriteLine(currency.GetAttributeValue<string>("currencyname"));
}

using (var service = new OrganizationService(connection))
using (var context = new OrganizationServiceContext(service))
{
// use helper method that calls LoadProperty implicitly and maintains static typing
var contact = context.CreateQuery<Contact>().First(c => c.FirstName == "Bob");
var currency = contact.GetRelatedEntity(context, c => c.transactioncurrency_contact);
Console.WriteLine(currency.CurrencyName);
}

By using the CrmOrganizationServiceContext, or the generated XrmServiceContext, you have the most concise code for accessing relationships. This context allows automatic lazy loading of related entities by tracking the context reference internally and calling LoadProperty implicitly, as shown here.

C# Copy Code
using (var service = new OrganizationService(connection))
using (var context = new CrmOrganizationServiceContext(service))
{
// this context manages the context reference internally
var contact = context.CreateQuery<Contact>().First(c => c.FirstName == "Bob");
var currency = contact.transactioncurrency_contact;
Console.WriteLine(currency.CurrencyName);
}

See Also

Reference

Context Enhancements

Concepts

Developer extensions context object model
Configure the context with the configuration file
Attach entities to the context

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Attach entities to the context

For the OrganizationServiceContext to properly track its changes to entities and relationships, the entities and relationships need to be attached to the data context. When you follow the typical pattern of querying for entities, updating the entities, and saving the changes, it is not necessary to explicitly control the attaching and detaching of entities. That is, entities are automatically attached to the context when they are retrieved. One behavior to be aware of is that all entities are detached by the OrganizationServiceContext after calling the SaveChanges method. To continue using the data context against previously retrieved entities, the entities need to be reattached. This can be accomplished by re-querying a new set of entities or by explicitly calling the Attach method on the entities. Developer Extensions for Microsoft Dynamics CRM 2015 provides a ReAttach method that ensures that the entities are in the correct state when reattached. This is shown in the following example.

C# Copy Code
using Microsoft.Xrm.Client;

using (var service = new OrganizationService(connection))
using (var context = new OrganizationServiceContext(service))
{
var contact = context.CreateQuery<Contact>().First(c => c.FirstName == "Bob");
contact.JobTitle = "Developer";
context.UpdateObject(contact);
context.SaveChanges();

// contact is no longer attached at this point so reattach it
context.Reattach(contact);

contact.EMailAddress1 = "bob@contoso.com";
context.UpdateObject(contact);
context.SaveChanges();
}

The preference is to apply all modifications under a single call to SaveChanges, and then dispose the context, to avoid the need to reattach.

The CrmOrganizationServiceContext simplifies this scenario by automatically reattaching entities after calling SaveChanges. Note that only the entities that are used as input parameters of an AddObject or UpdateObject operation are flagged to be reattached.

C# Copy Code
using (var service = new OrganizationService(connection))
using (var context = new CrmOrganizationServiceContext(service))
{
var contact = context.CreateQuery<Contact>().First(c => c.FirstName == "Bob");
contact.JobTitle = "Developer";
context.UpdateObject(contact);
context.SaveChanges();
contact.EMailAddress1 = "bob@contoso.com";
context.UpdateObject(contact);
context.SaveChanges();
}

Multiple Data Contexts

Another scenario that requires careful management of entity tracking is having multiple data contexts handling a common entity object. An example is having one context retrieve an entity and having a second context update the entity. Before the entity can be modified by the second context, it needs to be attached to it. Because an entity can only be attached to a single context, it is necessary to detach the entity from the source context before attaching to the second context.

C# Copy Code
using (var service = new OrganizationService(connection))
using (var context1 = new OrganizationServiceContext(service))
{
var contact = context1.CreateQuery<Contact>().First(c => c.FirstName == "Bob");

using (var context2 = new OrganizationServiceContext(service))
{
context1.Detach(contact);
context2.Attach(contact);

contact.EMailAddress1 = "bob@contoso.com";
context2.UpdateObject(contact);
context2.SaveChanges();
}
}

Detach an Entity from the Context

Sometimes it is undesirable to detach the entity from the original context because it may already be involved in a complex graph of changes that would be broken when detached. A safer approach is to have the second context simply re-retrieve a distinct instance of the entity and leave the original entity untouched. A variation of this approach is to deep clone the original entity and to attach the cloned entity to the second context. The AttachClone and MergeClone helper methods take the latter approach, where MergeClone performs extra checks to ensure the entity is not already attached to the target context.

C# Copy Code
using (var service = new OrganizationService(connection))
using (var context1 = new OrganizationServiceContext(service))
{
var contact = context1.CreateQuery<Contact>().First(c => c.FirstName == "Bob");

using (var context2 = new OrganizationServiceContext(service))
{
var contact2 = context2.MergeClone(contact);

contact2.EMailAddress1 = "bob@contoso.com";
context2.UpdateObject(contact2);
context2.SaveChanges();
}
}

See Also

Reference

Attach
AddObject
UpdateObject

Concepts

Developer extensions context object model
Configure the context with the configuration file
Access entity relationships

Other Resources

SaveChanges

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Portal developer guide for Microsoft Dynamics CRM

Building a web portal that is tightly integrated with Microsoft Dynamics CRM 2015 helps organizations maximize the value of their Microsoft Dynamics CRM investment. Developer Extensions for Microsoft Dynamics CRM 2015 and the portal toolkit make it easy for developers to build an agile, integrated CRM web solution.

There is clean and full separation between the source code that works with the Microsoft Dynamics CRM web services and the web portal code itself. You can hand off the web portal code to a website designer with no impact to the CRM code underneath. This can reduce the time to project completion because the website designer works in parallel with the developer.

The Customer Portal and Partner Relationship Management (PRM) Portal solutions for Microsoft Dynamics CRM 2015 will be available from the Microsoft Dynamics Marketplace soon.

Note
All portal solutions now require, at a minimum, Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update. Any custom code that links to the portal or client assemblies must target Microsoft .NET Framework 4.5.2.

In This Section

Prepare for portal development

ASP.NET web forms and data binding

Manage portal content

Portal authentication

Use the Website Copy tool

Portal walkthroughs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Prepare for portal development

This topic begins with background information and best practices for portal development using Developer Extensions for Microsoft Dynamics CRM 2015 and the portal developer’s toolkit, and then walks through the installation and setup needed to begin.

In This Topic

Best practices for portal development

Install the base portal solution

Generate early bound types

Best practices for portal development

The following is a set of guidelines that you should investigate to determine the right approach for your organization. Note that this list is by no means exhaustive but represents the bare minimum of what you should consider when deploying a web portal that connects to your Microsoft Dynamics CRM system.

Deployment recommendation Description and more information

Deploy your portal under SSL

It is imperative for organizations to be able to conduct private, tamper-proof communication with known parties. To ensure this, organizations should build a secure infrastructure based on public-key cryptography by using digital certificates with technologies such as Secure Sockets Layer (SSL).

Useful References:

How to implement SSL in IIS

Security Guidance for IIS

Security in IIS 6.0

Managing SSL Certificates in Azure

Review your anti-phishing approach

For any website that offers services that involve potentially sensitive customer and product data, your customers need to know that that they are interacting with your portal and not a phishing website. Before you set up any portal that connects to your Microsoft Dynamics CRM system, consider how your customers can identify your portal as authentic. More information: http://wikipedia.org/wiki/Phishing

Privacy recommendations

For any portal services you develop that work with Microsoft Dynamics CRM and that access, collect, or disclose information about you, your customers, your employees, or your computer over the Internet, you should implement a consent capture mechanism and make available a clear and conspicuous notice regarding the uses of information recorded and exchanged through the portal.

Microsoft provides a number of guides on Internet security and privacy practices. You are strongly urged to review these resources before deploying any Internet portal that integrates with your Microsoft Dynamics CRM system. More information: Internet Security and Privacy

Restrict the use of the portal integration account

When you set up the portal you nominate an account that will be used by the portal to connect to Microsoft Dynamics CRM and perform create, read, update, and delete transactions. It is vital that this account is used solely for this purpose. Don’t use the account for other CRM system uses and make sure that if you are using a Microsoft account that this account is not used for any other websites or applications.

When you set up the Microsoft Dynamics CRM account, ensure that you assign it a security role that only performs the functions exposed by the portal. For example, if your portal reads campaign information and writes campaign responses, ensure that the CRM account used for this purpose only has those privileges. This helps minimize the potential damage if this account is compromised. It is important that you do not, under any circumstances, set the account up with System Administrator privileges.

Install the base portal solution

To begin you must install the base portal solution into your instance of Microsoft Dynamics CRM.

Import the customizations file

  1. Ensure that Pop-up Blocker does not cause errors during the import process. In Internet Explorer either turn off Pop-up Blocker (go to Tools -> Pop-up Blocker -> Turn Off Pop-up Blocker) or add your CRM site to the allowed sites (go to Tools -> Pop-up Blocker -> Pop-up Blocker Settings).

  2. Go into Settings -> Solutions -> Import

  3. Select the sdk\Solutions\PortalBase\MicrosoftXrmPortals_managed.zip solution package and review the package details.

  4. Select the check box to enable post import actions.

  5. While still under Settings -> Solutions, click Publish All Customizations.

  6. After the import process is completed, refresh your browser. For more information on the entities installed with this solution, see Manage portal content.

Generate early bound types

To prepare for developing a web portal, you must first use the code generation tool with the Microsoft.Xrm.Client.CodeGeneration extension. More information: CrmSvcUtil.exe extension usage and command-line parameters. In addition, read Best Practices for Portal Development.

The following examples use the CrmSvcUtil.exe tool, with the Microsoft.Xrm.Client.CodeGeneration extension to generate the classes in the Xrm namespace and XrmServiceContext is specified as the service context name. Note that Microsoft.Xrm.Client.CodeGeneration.dll must be in the same directory as CrmSvcUtil.exe, or in the system global assembly cache, when you run this command.

SQL Copy Code
CrmSvcUtil.exe /codeCustomization:"Microsoft.Xrm.Client.CodeGeneration.CodeCustomization, Microsoft.Xrm.Client.CodeGeneration" /out:Xrm\Xrm.cs /url:http://Crm/Contoso/XRMServices/2011/Organization.svc /domain:CONTOSO /username:administrator /password:pass@word1 /namespace:Xrm /serviceContextName:XrmServiceContext /serviceContextPrefix:Xrm

Your portal will need the following minimum required configuration.

Xml Copy Code
<configuration>
  <configSections>
    <section name="microsoft.xrm.client" type="Microsoft.Xrm.Client.Configuration.CrmSection, Microsoft.Xrm.Client"/>
    <section name="microsoft.xrm.portal" type="Microsoft.Xrm.Portal.Configuration.PortalCrmSection, Microsoft.Xrm.Portal"/>
  </configSections>
  <connectionStrings>
    <add name="Xrm" connectionString="ServiceUri=...; Domain=...; Username=...; Password=..."/>
  </connectionStrings>
  <microsoft.xrm.client>
    <contexts>
      <add name="Xrm" type="Xrm.XrmServiceContext, Xrm"/>
    </contexts>
  </microsoft.xrm.client>
  <microsoft.xrm.portal>
    <portals>
      <add name="My Portal"/>
    </portals>
  </microsoft.xrm.portal>
  <location path="Services/Cms.svc">
    <system.web>
      <authorization>
        <allow roles="My Portal Administrators"/>
        <deny users="*"/>
      </authorization>
    </system.web>
  </location>
</configuration>

See Also

Concepts

ASP.NET web forms and data binding
Manage portal content
Portal authentication
Use the Website Copy tool

Other Resources

Portal developer guide for Microsoft Dynamics CRM
Portal walkthroughs
Blog: Announcing the Customer and Partner Relationship Management Portals

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


ASP.NET web forms and data binding

One of the most popular web programming technologies is ASP.NET web forms, which binds data to controls. Developer Extensions for Microsoft Dynamics CRM 2015 has a number of mechanisms that make it easy to build an ASP.NET web form that binds to Microsoft Dynamics CRM data.

In This Topic

Use the CrmService context and LinqDataSource control

Use CrmDataSource control and FetchXML

Use CrmMetadataDataSource control

Use cde-behind data binding

Use saved queries in a portal

Use the CrmService context and LinqDataSource control

The recommended practice for using Developer Extensions for Microsoft Dynamics CRM 2015 is to run the CrmSvcUtil.exe code generation tool, with the Microsoft.Xrm.Client.CodeGeneration extension, to generate the service context and data transfer object classes that match your Microsoft Dynamics CRM entity model. The service context class includes an IQueryable interface for every CRM entity in your solution. The service context class can easily be used with the ASP.NET LinqDataSource control to facilitate declarative data-binding that doesn’t need any code-behind. You set the ContextTypeName attribute of the LinqDataSource control to the type name of your service context and set the TableName attribute to the property name of the entity that you want to query. After the Microsoft Dynamics CRM data is bound to the data source control, you can use any ASP.NET data bound control to extract and display the data including repeaters and the GridView control.

The following code uses a LinqDataSource control to bind to the CRM contacts and display them with a GridView. This same example can be seen in Walkthrough: Build a web application that connects to Microsoft Dynamics CRM using developer extensions.

Xml Copy Code
<?xml version="1.0" encoding="utf-8"?>
<!--This example lists all contacts from the Microsoft Dynamics CRM system. -->
<asp:LinqDataSource ID="Contacts" ContextTypeName="Xrm.XrmServiceContext" TableName="ContactSet" runat="server" />
<asp:GridView DataSourceID="Contacts" AutoGenerateColumns="false" runat="server">
  <Columns>
    <asp:TemplateField HeaderText="First Name">
      <ItemTemplate>
        <asp:Label Text=''
        <%# Eval("firstname")%>' runat="server" />
      </ItemTemplate>
    </asp:TemplateField>
    <asp:TemplateField HeaderText="Last Name">
      <ItemTemplate>
        <asp:Label Text=''
        <%# Eval("lastname")%>' runat="server" />
      </ItemTemplate>
    </asp:TemplateField>
    <asp:TemplateField HeaderText="City">
      <ItemTemplate>
        <asp:Label Text=''
        <%#Eval("address1_city") %>' runat="server" />
      </ItemTemplate>
    </asp:TemplateField>
  </Columns>
</asp:GridView>

This shows the following results in HTML.

Use CrmDataSource control and FetchXML

If you don’t want to use the CrmSvcUtil.exe tool to generate a domain context and data transfer object, you can use the Microsoft.Xrm.Client.CrmOrganizationServiceContext.

The following example uses FetchXml to query Microsoft Dynamics CRM and the CrmDataSource control to bind to CRM data. The results are displayed in a GridView control. Note that the DataItem in the grid view is of type Entity. To bind to columns in the results, you can either cast the Container.DataItem to a Entity class or you can bind to the properties in the default indexer by using Eval("[attribute-logical-name]").

Xml Copy Code
<crm:CrmDataSource ID="Contacts" runat="server">
  <FetchXml>
    <fetch>
      <entity name="contact" />
    </fetch>
  </FetchXml>
</crm:CrmDataSource>
<asp:GridView DataSourceID="Contacts" AutoGenerateColumns="false" runat="server">
  <Columns>
    <asp:TemplateField HeaderText="Full Name">
      <ItemTemplate>
        <asp:Label Text=''
        <%# Eval("[fullname]") %>' runat="server" />
      </ItemTemplate>
    </asp:TemplateField>
    <asp:TemplateField HeaderText="Created On">
      <ItemTemplate>
        <asp:Label Text=''
        <%# Eval("[createdon]") %>' runat="server" />
      </ItemTemplate>
    </asp:TemplateField>
    <asp:TemplateField HeaderText="Last Modified">
      <ItemTemplate>
        <asp:Label Text=''
        <%# Eval("[modifiedon]") %>' runat="server" />
      </ItemTemplate>
    </asp:TemplateField>
  </Columns>
</asp:GridView>
<crm:CrmDataSource ID="Contacts" runat="server">
  <FetchXml>
    <fetch>
      <entity name="contact" />
    </fetch>
  </FetchXml>
</crm:CrmDataSource>

This shows the following results in HTML.

Use CrmMetadataDataSource control

The CrmMetadataDataSource control allows for data binding to Microsoft Dynamics CRM metadata. The most useful purpose is to bind a drop-down list to a CRM option set that you use in a data form that is collecting data to store in CRM.

The following example demonstrates using the CrmMetadataDataSource control to bind to three separate option sets in the CRM case (incident) entity.

Xml Copy Code
<h2>Incident Picklists</h2>
<h3>Priority</h3>
<crm:CrmMetadataDataSource ID="PriorityCodes" runat="server"
    EntityName="incident"
    AttributeName="prioritycode" />
<asp:DropDownList runat="server"
    DataSourceID="PriorityCodes"
    DataTextField="OptionLabel"
    DataValueField="OptionValue" />
<h3>Satisfaction Rating</h3>
<crm:CrmMetadataDataSource ID="SatisfactionCodes" runat="server"
    EntityName="incident"
    AttributeName="customersatisfactioncode" />
<asp:DropDownList runat="server"
    DataSourceID="SatisfactionCodes"
    DataTextField="OptionLabel"
    DataValueField="OptionValue" />

This shows the following results in HTML.

Use code-behind data binding

The previous examples used specific data source controls that implement declarative data binding. The XrmServiceContext class can also be used with data binding using code-behind techniques. The service context that is generated by the CrmSvcUtil.exe tool (with the Microsoft.Xrm.Client.CodeGeneration extension) has IQueryable properties for all CRM entities. You can write standard .NET Language-Integrated Query (LINQ) queries or use expressions with these properties and bind them directly to your repeaters or DataGrid controls.

More information: Walkthrough: Build a web application that connects to Microsoft Dynamics CRM using developer extensions

Use saved queries in a portal

Microsoft Dynamics CRM has the ability to allow the customer to save a query or a view for later retrieval. The view has column order and definitions, sorting order, and filter options. It is a convenient technique to allow users to configure a view in CRM and then a developer can use the SavedQueryDataSource control to bind to that view and use a GridView control with AutoGenerateColumns property turned on. This allows a developer to drop a CRM view directly into a webpage and have the view contents be managed in Microsoft Dynamics CRM. Business users can then change the contents of the view without having to work through a developer to make a webpage change and promote a new version of the website to the production server.

For an example of this, as well as an example of how to generate a data entry form from a saved query using the CrmEntityFormView control, see Walkthrough: Build a web application that connects to Microsoft Dynamics CRM using developer extensions.

See Also

Concepts

Prepare for portal development
Manage portal content
Portal authentication
Use the Website Copy tool

Other Resources

Portal developer guide for Microsoft Dynamics CRM
Portal walkthroughs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Manage portal content

Developer Extensions for Microsoft Dynamics CRM 2015 provide content management capabilities for portal applications. Microsoft Dynamics CRM stores all relevant content for the web portal in custom CRM entities, and this content is managed, supplied, and cached by the Developer Extension binaries referenced in your portal code. The base portal solution must be installed to see these entities in CRM. More information: Install the Base Portal Solution

Entities installed in the base portal solution

The following table lists the Microsoft Dynamics CRM data entities that are used for content management.

Entity name | Purpose
adx_website | Stores key information about the websites to be managed through Developer Extensions for Microsoft Dynamics CRM.
adx_webpage | Defines all webpages in a website, including the navigation structure of the website.
adx_weblinkset | Defines specific navigation sets that consist of groups of individual web links.
adx_weblink | Defines a specific link to a URL.
adx_webfile | Specifies a storage point for graphics, documents, and other files that the portal exposes to users.
adx_sitemarker | Defines the “breadcrumbs” for the navigation to get to a specific page.
adx_sitesetting | Provides a mechanism to store configuration values, specific styles, and colors for the portal.
adx_pagetemplate | Allows you to designate specific .aspx pages as templates that can be reused to create new inherited pages. Page templates can cover page content layouts as well as specific ASP.NET controls that can be exposed to users.
adx_contentsnippet | Indicates an individual segment of content. This might be a heading, field label, or block of text. Webpages store the specific content snippets that are displayed.

See Also

Concepts

Manually create a new website using developer extensions
Set up cache invalidation to refresh changes on the website
Prepare for portal development
ASP.NET web forms and data binding
Portal authentication
Use the Website Copy tool

Other Resources

Portal developer guide for Microsoft Dynamics CRM
Portal walkthroughs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Manually create a new website using developer extensions

These instructions explain how to set up a new website in Microsoft Dynamics CRM 2015 using Developer Extensions and the portal toolkit. The Basic Portal Solution must be installed. More information: Prepare for portal development.

Create a new website

  1. In Microsoft Dynamics CRM, select the Content Management menu. Under the Website tab, select Websites.

  2. Click or tap New.

  3. Enter a name for your website.

  4. Click or tap Save.

Add the home page for the website

  1. In your website, select Web Pages.

  2. Select New Web Page.

  3. Add a home page

    1. Name the page “Home”.

    2. Leave Parent Page empty. This is the root of the website so it doesn’t need a Parent Page.

    3. In Partial Url type "/". This is because it is the root of the site.

    4. In PageTemplate type “Home”.

    5. You need to create a new PageTemplate. Click or tap the Lookup button beside PageTemplate.

    6. Click or tap New.

    7. Name the template “Home”.

    8. Click or tap New.

    9. Set the Rewrite Url to “/Pages/Home.aspx”, or the relative path to your page template.

    10. Click or tap Save and Close.

    11. Select the Home template and click or tap OK.

    12. Enter a Title, Summary, and some Copy text.

    13. Click or tap Save.

The next step is to create other webpages. We will start with an “About Us” page for the website.

Create other webpages

  1. On your Home page, select Child Pages.

  2. Click or tap New Web Page.

  3. Enter “About” as the Name of the page.

  4. Type your website name or look it up.

  5. Set the Partial Url to “about”.

  6. Set the PageTemplate to “Page”.

  7. You need to create a new template again so select the Lookup button and click New.

  8. Name the template” Page”.

  9. Set the Website to your Website.

  10. Set the Rewrite Url to “/Pages/Pages.aspx” (or the relative path to your page template).

  11. Click or tap Save and Close.

  12. Select the template and click OK.

  13. Click or tap Save and Close to close the About Us Web page.

You can repeat this for as many different webpages as you need.

See Also

Concepts

Manage portal content
Set up cache invalidation to refresh changes on the website

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Set up cache invalidation to refresh changes on the website

Websites developed using Developer Extensions for Microsoft Dynamics CRM 2015 make heavy use of caching. As a result, changes made to Microsoft Dynamics CRM entities in the web application or in Microsoft Dynamics CRM Online may not immediately show up on the website. To resolve this, you can set up cache invalidation to happen automatically with the use of the web notification plug-ins and web notification URLs.

If the web notification plug-ins are installed, ensure that they are enabled for the solution.

Enable Web notification plug-ins

The web notification plug-in assembly is contained within portal managed solutions and is installed by importing one of those solutions. The “base” solution is included with Microsoft Dynamics CRM SDK. Solutions with additional customizations are included with the Customer Portal and Partner Portal. For links to these solutions, see Portal developer guide for Microsoft Dynamics CRM.

Next, create a new web notification URL (from the Settings menu) that goes to the cache invalidation handler of your website. The URL to your cache invalidation will be http(s)://your-website-domain/Cache.axd.

Web notification URL

Now, when entities are created, updated, or deleted, the cache invalidation handler for your website will be notified and will invalidate the necessary cache depending on what has changed.

Cache can also be invalidated manually by recycling the application pool, rebuilding the website in Microsoft Visual Studio, saving the web.config file, or by adding a browser toolbar button that will hit the cache invalidation handler. This will refresh the website with the Microsoft Dynamics CRM changes.

The toolbar script is a link or shortcut that is added into your browser favorites with the value for its URL as shown here.

In Internet Explorer, use this script:

JScript Copy Code
javascript:var sURL=document.location.protocol + '//' +document.location.host;var oHttp=new ActiveXObject("Msxml2.XMLHTTP.6.0"); oHttp.Open('GET',sURL+'/Cache.axd?Message=InvalidateAll&d=' + (new Date()).valueOf(),false);oHttp.Send();window.location.reload(true);

In Firefox, use this script:

JScript Copy Code
javascript:var%20url%20=%20document.location.protocol%20+%20'//'%20+%20document.location.host%20+%20'/Cache.axd?Message=InvalidateAll&d='%20+%20(new%20Date()).valueOf();%20var%20req%20=%20new%20XMLHttpRequest();%20req.open('GET',%20url,%20false);%20req.send(null);window.location.reload(true);

To use the script, just open the website you want to refresh and then click your favorite that you set previously. The cache for that website will be invalidated and you should see the changes you made.

See Also

Concepts

Manage portal content
Manually create a new website using developer extensions

Other Resources

Portal developer guide for Microsoft Dynamics CRM

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Portal authentication

Microsoft account allows users to be authenticated on your website without having to create your own security providers. This topic shows how use Microsoft account authentication with your Website using Developer Extensions for Microsoft Dynamics CRM 2015 and the portal tooklit.

In This Topic

Register Your Website with Microsoft Account

Add the LiveIdLoginStatus Control

Add the Membership Provider and Handler Service

Force Registration

Register Your Website with Microsoft Account

To begin, you need to register your Website with Microsoft account:

Copy Code
https://account.live.com/developers/applications

When registering your site, you need to provide your full domain name, for example, “yoursite.yourdomain.com”, not just “yourdomain.com”.

You also need to provide a URL that directs Microsoft account requests back to when they have finished signing in. This will be to your Handler Service, which you can read about later in this document, but, by default, the URL to enter is:

Copy Code
http://yoursite.yourdomain.com/liveid.axd.

After you have registered your Website, it provides you with an application ID and a secret that you will use to plug in to your web.config so that the site can be hooked up to the Microsoft account.

Here are some things to note:

Your domain names cannot include strings such as localhost, 127.0.0.1, or anything with the word "live" in it.

You cannot share the management of the Website with other users.

You cannot change your domain name after you have registered it.

Add the LiveIdLoginStatus Control

The last step is to add the LiveIdLoginStatus control, which works like the LoginStatus control. It displays a log in link for users who are not authenticated and a log out link for users who are authenticated.

When anonymous, the link takes the user to Windows Live or optionally (using LoginNavigateUrl) to a specified landing page that lets the user know they are going to Windows Live.

When authenticated, the log out link resets the current user's identity to be an anonymous user.

Xml Copy Code
<crm:LiveIdLoginStatus runat="server" />

This assumes that the "crm" tag prefix has been registered to "Microsoft.Xrm.Portal.Web.UI.WebControls".

Add the Membership Provider and Handler Service

The Membership Provider handles the user login information. Using Microsoft account requires the use of the Microsoft account Membership Provider:

Xml Copy Code
<membership defaultProvider="CrmMembershipProvider">
    <providers>
        <add name="CrmMembershipProvider" type="Microsoft.Xrm.Portal.Web.Security.LiveIdMembershipProvider, Microsoft.Xrm.Portal" liveIdConnectionStringName="Live"/>
    </providers>
</membership>

The Handler Service validates whether the authenticated user has been registered on your Website. If you are running an Internet Information Services (IIS) 7 site in Integrated Mode, you will need to ensure that the following is added in your <handlers> section:

Xml Copy Code
<add name="LiveId" verb="*" path="LiveID.axd" preCondition="integratedMode" type="Microsoft.Xrm.Portal.Web.Handlers.LiveIdWebAuthenticationHandler, Microsoft.Xrm.Portal" />

If you are running in Classic Pipeline Mode or IIS6, the Handler Service is configured under the <httpHandlers> section of your Web.config file.

Xml Copy Code
<add verb="*" path="LiveID.axd" type="Microsoft.Xrm.Portal.Web.Handlers.LiveIdWebAuthenticationHandler, Microsoft.Xrm.Portal"/>

Force Registration

When using Microsoft account for authentication, only the Passport Unique Identifier (PUID) is known. If you want additional information about the user (such as a display name or email) you will need to collect this from the user. Two common ways to do this are:

  • Set up a page for them to fill in their information at their own convenience when they are logged in.
  • Collect information before they can be authenticated on your site.

To do the second way, your Microsoft account setup will need some special handling.

  1. As part of a user registration, Microsoft Dynamics CRM needs to know the PUID of the user so that it can link this to the user’s Microsoft Dynamics CRM contact information. In other words, you need to have the user log in using Microsoft account and then send the user to your registration page. This is done by adding the RegistrationUrl attribute on the LiveIdLoginStatus control.
    Xml Copy Code
    <crm:LiveIdLoginStatus runat="server" RegistrationUrl="/CreateUser" />
  2. In the code behind of your registration page, you need to add code to keep the Microsoft account token and create the new user once you have collected the information you want.
    C# Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
  if (InvitationCode == null || InvitedContact == null)
  {
    var page = SiteContext.Current.Website.GetPageBySiteMarkerName("Home");
    Response.Redirect(page.GetUrl());
  }

  // Add the Live ID variables that come from the authentication handler to hidden
  // script variables.
  if (Request["live-id-action"] == "register")
  {
    Page.ClientScript.RegisterHiddenField("live-id-token",
      Request["live-id- token"]);
    Page.ClientScript.RegisterHiddenField("live-id-action",
      Request["live-id-action"]);
  }
}

See Also

Concepts

Prepare for portal development
ASP.NET web forms and data binding
Manage portal content

Other Resources

Portal developer guide for Microsoft Dynamics CRM
Portal walkthroughs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Use the Website Copy tool

The Website Copy tool (Websitecopy.exe), which is provided with the Microsoft Dynamics CRM SDK, creates an exact copy of an existing Microsoft Dynamics CRM website, including all webpages, files, site markers, page templates, settings, and so on. Note that you must first import the base portal CRM customizations into the destination CRM system before you run this application. This tool can be found in the SDK in the SDK\Tools\WebSiteCopy folder. Download the Microsoft Dynamics CRM SDK package.

The Website Copy tool can be used to copy an existing website from Microsoft Dynamics CRM to a newly created website, or it can export the website to an XML file. You can then use the tool to upload the XML file into CRM.

Running the tool opens a wizard that walks you through the steps to copy or back up a website in CRM. Alternatively, you can use the command line to run the tool. For a complete list of the command-line parameters for Websitecopy.exe, run “websitecopy.exe /?”.

See Also

Other Resources

Portal developer guide for Microsoft Dynamics CRM
Portal walkthroughs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Portal walkthroughs

The following walkthroughs are available for learning how to use the portal developer’s toolkit for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

In This Section

Walkthrough: Build a console application that connects to Microsoft Dynamics CRM using developer extensions

Walkthrough: Build a web application that connects to Microsoft Dynamics CRM using developer extensions

Related Sections

Portal developer guide for Microsoft Dynamics CRM

Prepare for portal development

ASP.NET web forms and data binding

Manage portal content

Portal authentication

Use the Website Copy tool

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Walkthrough: Build a console application that connects to Microsoft Dynamics CRM using developer extensions

This walkthrough demonstrates how to write a simple console application that connects to Microsoft Dynamics CRM 2015 using Developer Extensions and creates a contact record.

You can find the sample code that this walkthrough produces in the Walkthroughs\Portal\ConsoleAppWalkthrough folder.

In This Topic

Generate early bound types

Create a new console application project in Visual Studio

Generate early bound types

  1. Run the CrmSvcUtil.exe tool, with the “Microsoft.Xrm.Client.CodeGeneration” extension, to generate your entity classes and service contexts. The following is an example command to create a file called Xrm.cs that points at an instance of Microsoft Dynamics CRM. Note that the Microsoft.Xrm.Client.CodeGeneration.dll file must be in the same directory as the CrmSvcUtil.exe file, or in the system global assembly cache, when you run this command. The first command shown is for an on-premises organization. The second command is for a CRM Online organization. Both commands should be executed as a single command line with no line breaks.

    Copy Code
    CrmSvcUtil.exe
/codeCustomization:"Microsoft.Xrm.Client.CodeGeneration.CodeCustomization, Microsoft.Xrm.Client.CodeGeneration"/out:Xrm.cs /url:http://<myserver>/<myorg>/XRMServices/2011/Organization.svc
/domain:<mydomain> /username:<myusername> /password:<mypassword> /namespace:Xrm /serviceContextName:XrmServiceContext
    Copy Code
    CrmSvcUtil.exe
/codeCustomization:"Microsoft.Xrm.Client.CodeGeneration.CodeCustomization, Microsoft.Xrm.Client.CodeGeneration"
/out:Xrm.cs /url:https://<mydomain>.api.crm.dynamics.com/XRMServices/2011/Organization.svc
/username:<myusername>@<mydomain>.onmicrosoft.com /password:<mypassword> /namespace:Xrm /serviceContextName:XrmServiceContext
    Tip
    The CrmSvcUtil tool is available in the Bin folder of the SDK download or by installing the Microsoft.CrmSdk.CoreTools NuGet package.

Create a new console application project in Visual Studio

  1. Create a new console application named “ConsoleAppWalkthrough”. If you don’t already have the .NET Framework 4.5.2 installed, you can obtain the Developer Pack from Installing the .NET Framework.

    Create a project in Visual Studio

  2. Add the following references from the SDK\bin folder. You can skip this step and the next by simply installing the Microsoft.CrmSdk.Extensions NuGet package.

    • AntiXSSLibrary.dll
    • Microsoft.Crm.Sdk.Proxy.dll
    • Microsoft.Xrm.Client.dll
    • Microsoft.Xrm.Portal.dll
    • Microsoft.Xrm.Portal.Files.dll
    • Microsoft.Xrm.Sdk.dll

  3. Add the following references from .NET.

    • System.IdentityModel.dll
    • Microsoft.ServiceBus.dll
    • System.Data.Services.dll
    • System.Data.Services.Client.dll
    • System.Runtime.Serialization.dll

  4. Make sure the console project specifies .NET Framework 4.5.2 as the target framework and not .NET Framework 4.5.2 Client Profile. Check the properties of the project by selecting the ConsoleAppWalkthrough project in Solution Explorer and clicking Alt-Enter.

    Set target framework

  5. Right-click the project in Visual Studio, click Add, and then click Existing Item.

  6. Select the “xrm.cs” file that you created when you generated the early bound types.

  7. Right-click your project again, click Add, and then click New Item.

  8. Select Application Configuration File from the options and then click Add.

  9. Edit the App.config configuration file with your specific connection string.

    Xml Copy Code
    <?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="microsoft.xrm.client" type="Microsoft.Xrm.Client.Configuration.CrmSection, Microsoft.Xrm.Client"/>
  </configSections>
  <connectionStrings>   <add name="Xrm" connectionString="Server=http://crmserver/contoso; Domain=CONTOSO; Username=Administrator;Password=pass@word1"/></connectionStrings>
  <microsoft.xrm.client>
    <contexts default="Xrm">
      <add name="Xrm" type="Xrm.XrmServiceContext, Xrm" connectionStringName="Xrm"/>
    </contexts>
  </microsoft.xrm.client>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5.2"/>
  </startup>
</configuration>

  10. Add a using statement to the namespace that you used in Step 1 when you created the project (for this example “Xrm”).

  11. Add the following code to your program class:

    C# Copy Code
    static void Main(string[] args)
{
    var xrm = new XrmServiceContext("Xrm");

    WriteExampleContacts(xrm);

    //Create a new contact called Allison Brown.
    var allisonBrown = new Xrm.Contact
    {
        FirstName = "Allison",
        LastName = "Brown",
        Address1_Line1 = "23 Market St.",
        Address1_City = "Sammamish",
        Address1_StateOrProvince = "MT",
        Address1_PostalCode = "99999",
        Telephone1 = "12345678",
        EMailAddress1 = "allison.brown@example.com"
    };

    xrm.AddObject(allisonBrown);
    xrm.SaveChanges();

    WriteExampleContacts(xrm);

    Console.WriteLine("Press any key to exit.");
    Console.ReadKey();
}

/// <summary>
/// Use all contacts where the email address ends in @example.com.
/// </summary>
private static void WriteExampleContacts(XrmServiceContext xrm)
{
    var exampleContacts = xrm.ContactSet
        .Where(c => c.EMailAddress1.EndsWith("@example.com"));

    //Write the example contacts.
    foreach (var contact in exampleContacts)
    {
        Console.WriteLine(contact.FullName);
    }
}

  12. Debug and test the solution. This will create a contact in your CRM organization.

See Also

Concepts

Walkthrough: Build a web application that connects to Microsoft Dynamics CRM using developer extensions

Other Resources

Portal developer guide for Microsoft Dynamics CRM
Portal walkthroughs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Walkthrough: Build a web application that connects to Microsoft Dynamics CRM using developer extensions

This walkthrough demonstrates how to write a simple web application that connects to Microsoft Dynamics CRM 2015 and performs a basic create contact transaction.

You can find the sample code that this walkthrough produces in the Sdk\Walkthroughs\Portal\WebAppWalkthrough folder.

In This Topic

Generate early bound types

Set up your web application project in Visual Studio

Create a webpage

Create another webpage

Create a WCF data service

Create a webpage

Create another webpage

Generate early bound types

  1. Run the CrmSvcUtil.exe tool, with the Microsoft.Xrm.Client.CodeGeneration extension, to generate your entity classes and service contexts. The following example command creates a file called “Xrm.cs” that points at an instance of Microsoft Dynamics CRM. Note that the Microsoft.Xrm.Client.CodeGeneration.dll file must be in the same directory as the CrmSvcUtil.exe file, or in the system global assembly cache, when you run this command. The first command shown here is for an on-premises organization while the second command is for a CRM Online organization. Both commands should be executed as a single command line with no line breaks.

    Copy Code
    CrmSvcUtil.exe
/codeCustomization:"Microsoft.Xrm.Client.CodeGeneration.CodeCustomization, Microsoft.Xrm.Client.CodeGeneration"
/out:Xrm\Xrm.cs
/url:http://Crm/Contoso/XRMServices/2011/Organization.svc
/domain:CONTOSO
/username:administrator
/password:pass@word1
/namespace:Xrm
/serviceContextName:XrmServiceContext
    Copy Code
    CrmSvcUtil.exe
/codeCustomization:"Microsoft.Xrm.Client.CodeGeneration.CodeCustomization, Microsoft.Xrm.Client.CodeGeneration"
/out:Xrm.cs /url:https://<mydomain>.api.crm.dynamics.com/XRMServices/2011/Organization.svc
/username:<myusername>@<mydomain>.onmicrosoft.com /password:<mypassword> /namespace:Xrm /serviceContextName:XrmServiceContext
    Tip
    The CrmSvcUtil tool is available in the Bin folder of the SDK download or by installing the Microsoft.CrmSdk.CoreTools NuGet package.

Set up your web application project in Visual Studio

  1. Create a new ASP.NET web application project in Microsoft Visual Studio. This sample uses “WebAppWalkthrough” as the project name.

    Create Web application in Visual Studio

  2. Add the following references from the SDK\bin folder. You can skip this step and the next by simply installing the Microsoft.CrmSdk.Extensions NuGet package.

    • AntiXSSLibrary.dll
    • Microsoft.Crm.Sdk.Proxy.dll
    • Microsoft.Xrm.Client.dll
    • Microsoft.Xrm.Portal.dll
    • Microsoft.Xrm.Portal.Files.dll
    • Microsoft.Xrm.Sdk.dll

  3. Add the following references from .NET.

    • System.IdentityModel.dll
    • Microsoft.Data.Entity.dll
    • System.Data.Services.dll
    • System.Data.Services.Client.dll
    • System.Runtime.Caching.dll
    • System.Runtime.Serialization.dll

  4. Right-click the project in Visual Studio, click Add, and then click Existing Item.

  5. Select the “xrm.cs” file that you created when you generated the early bound types.

  6. Edit the web.config file to register the <microsoft.xrm.client> section. You’ll need to add a section into the configSections node of the configuration as shown here.

    Xml Copy Code
    <configuration>
  <configSections>
    <section name="microsoft.xrm.client"
      type="Microsoft.Xrm.Client.Configuration.CrmSection, Microsoft.Xrm.Client" />

  7. Edit the web.config file with your specific connection string and context. For the connection string, set the name to “Xrm”. In the <microsoft.xrm.client> section add a context with the name “Xrm” and set the type to the namespace and service context name you provided in Step 1 when you set up the web application project. In the following example it is Xrm.XrmServiceContext and the assembly part of the type is the name of your web application, “WebAppWalkthrough”.

    Xml Copy Code
    <connectionStrings>
  <add name="Xrm" connectionString="Server=http://crm/contoso; Domain=CONTOSO; Username=Administrator; Password=pass@word1" />
</connectionStrings>
<microsoft.xrm.client>
  <contexts>
    <add name="Xrm" type="Xrm.XrmServiceContext, WebAppWalkthrough" />
  </contexts>
</microsoft.xrm.client>

  8. Add the following to the <controls> section of the web.config file to register the Microsoft.Xrm.Portal controls with this Web application.

    Xml Copy Code
       <system.web>
     <pages>
       <controls>
         <add tagPrefix="crm" namespace="Microsoft.Xrm.Portal.Web.UI.WebControls" assembly="Microsoft.Xrm.Portal" />

Create a webpage – Contact Grid 1

Create a basic webpage that displays all contacts in your CRM system in an ASP.NET data grid.

  1. Right-click your project and add a new web form called “WebForm_LinqDataSource.aspx”.

  2. Add the following to the new aspx page:

    Xml Copy Code
    <!--This example lists all contacts from the Microsoft Dynamics CRM system. -->
<asp:LinqDataSource ID="Contacts" ContextTypeName="Xrm.XrmServiceContext" TableName="ContactSet" runat="server" />
<asp:GridView DataSourceID="Contacts" AutoGenerateColumns="false" runat="server">
    <Columns>
        <asp:TemplateField HeaderText="First Name">
            <ItemTemplate>
                <asp:Label Text='<%# Eval("firstname")%>' runat="server" />
            </ItemTemplate>
        </asp:TemplateField>
        <asp:TemplateField HeaderText="Last Name">
            <ItemTemplate>
                <asp:Label Text='<%# Eval("lastname")%>' runat="server" />
            </ItemTemplate>
        </asp:TemplateField>
        <asp:TemplateField HeaderText="City">
            <ItemTemplate>
                <asp:Label Text='<%#Eval("address1_city") %>' runat="server" />
            </ItemTemplate>
        </asp:TemplateField>
    </Columns>
</asp:GridView>

  3. Build the project.

  4. Right-click the aspx page and select View in Browser. The results should look something like this:

    View in browser

Create another webpage – Contact Grid 2

Create a webpage that displays contacts in your CRM system in an ASP.NET data grid based on a CRM view definition.

  1. Right-click your project and add a new web form called “WebForm_SavedQueryDataSource.aspx”.

  2. Add the following to the new aspx page.

    Xml Copy Code
    <crm:SavedQueryDataSource ID="ActiveContacts" SavedQueryName="Active Contacts" runat="server" />
<asp:GridView DataSourceID="ActiveContacts" runat="server" />

  3. Build the project.

  4. Right-click the aspx page and select View in Browser. This page will use the view definition “Active Contacts” to return the records and display the attributes of the view in an ASP.NET GridView control. The results should look something like this:

    View in browser

Create a WCF data service

Create a WCF Data Service for Microsoft Dynamics CRM.

  1. Right-click your project and add a new WCF Data Service called “CrmData.svc”:

    Create data service

  2. You need to point the WCF data service at the XrmServiceContext created at the beginning of the walkthrough. Edit the CrmData.svc.cs file as follows:

    C# Copy Code
    namespace WebAppWalkthrough
{
    public class CrmData : DataService<Xrm.XrmServiceContext>
    {
        // This method is called only once to initialize service-wide policies.
        public static void InitializeService(DataServiceConfiguration config)
        {
            config.SetEntitySetAccessRule("*", EntitySetRights.AllRead);
            config.SetServiceOperationAccessRule("*", ServiceOperationRights.All);
            config.DataServiceBehavior.MaxProtocolVersion = DataServiceProtocolVersion.V2;
        }
    }
}

Create a webpage – Contact Form 1

Create a webpage that renders a contact data entry form based on a Microsoft Dynamics CRM view definition:

  1. In CRM, go to Settings, Customizations, and Customize the System. Create a new view for the contact entity called “Create Contact Webform”.

    Create a Web page

  2. Add columns to the view that you want to have appear as fields in the generated form.

  3. Click Save and Publish.

  4. Right-click your web project in Microsoft Visual Studio and add a new web form called “WebForm_FromSavedQuery.aspx”.

  5. Add the following code to the new aspx page:

    Xml Copy Code
    <asp:ScriptManager runat="server" />
<crm:CrmDataSource ID="Contacts" runat="server" />
<crm:CrmEntityFormView DataSourceID="Contacts" EntityName="contact" SavedQueryName="Create Contact Web Form" runat="server" />

  6. Build the project.

  7. Right-click the aspx page and click View in Browser. The results should look something like this:

    View in browser

Create another webpage – Contact Grid 3

Create a webpage that uses code behind to connect a Microsoft Dynamics CRM data source to an ASP.NET GridView control.

  1. Right-click your project and add a new webpage called “WebForm_CodeBehindDataSource.aspx”.

  2. Add the following code to the new aspx page.

    Xml Copy Code
    <asp:GridView ID="ContactsGridView" AutoGenerateColumns="false" runat="server">
    <Columns>
        <asp:TemplateField HeaderText="First Name">
            <ItemTemplate>
                <asp:Label Text='<%# Eval("firstname")%>' runat="server" />
            </ItemTemplate>
        </asp:TemplateField>
        <asp:TemplateField HeaderText="Last Name">
            <ItemTemplate>
                <asp:Label Text='<%# Eval("lastname") %>' runat="server" />
            </ItemTemplate>
        </asp:TemplateField>
        <asp:TemplateField HeaderText="City">
            <ItemTemplate>
                <asp:Label Text='<%# Eval("address1_city") %>' runat="server" />
            </ItemTemplate>
        </asp:TemplateField>
    </Columns>
</asp:GridView>

  3. Edit the code-behind file WebForm_CodeBehind.aspx.cs as follows:

    C# Copy Code
    using System;
using System.Linq;
using Xrm;

namespace WebAppWalkthrough
{
    public partial class WebForm_CodeBehind : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            var xrm = new XrmServiceContext("Xrm");

            //Use all contacts where the email address ends in @example.com.
            var exampleContacts = xrm.ContactSet
                .Where(c => c.EMailAddress1.EndsWith("@example.com"));

            ContactsGrid_CodeBehind.DataSource = exampleContacts;
            ContactsGrid_CodeBehind.DataBind();
        }
    }
}

  4. Build the project.

  5. Right-click the aspx page and click View in Browser. The results should look something like this:

    View in browser

See Also

Other Resources

Portal developer guide for Microsoft Dynamics CRM
Portal walkthroughs

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Programming reference for extensions to Microsoft Dynamics CRM

This section contains reference documentation for the public assemblies that are included in SDK extensions for Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online 2015 Update.

In This Section

SDK Extension Web Service and Assembly Reference

Related Sections

Developer extensions for Microsoft Dynamics CRM

Portal developer guide for Microsoft Dynamics CRM

Core SDK Web Service and Assembly Reference

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Class Library

Namespaces

Namespace
Microsoft.Xrm.Client
Microsoft.Xrm.Client.Caching
Microsoft.Xrm.Client.Collections.Generic
Microsoft.Xrm.Client.Configuration
Microsoft.Xrm.Client.Diagnostics
Microsoft.Xrm.Client.Messages
Microsoft.Xrm.Client.Metadata
Microsoft.Xrm.Client.Runtime.Serialization
Microsoft.Xrm.Client.Security
Microsoft.Xrm.Client.Services
Microsoft.Xrm.Client.Services.Messages
Microsoft.Xrm.Client.Services.Samples
Microsoft.Xrm.Client.Threading
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog


Microsoft.Xrm.Client Namespace

Classes

Class | Description
CrmConnection | Provides a connection to the server using a connection string. (Developer Extensions)
CrmEntity | Extensions to the core Microsoft.Xrm.Sdk.Entity class. (Developer Extensions)
CrmEntityReference | Contains a reference to a specific record (entity instance). (Developer Extensions)
CrmOrganizationServiceContext | Extensions to the core OrganizationServiceContext class. (Developer Extensions)
DateTimeExtensions | Extensions to the date/time class. (Developer Extensions)
EntityExtensions | Extensions to the core Entity class. (Developer Extensions)
OrganizationServiceContextExtensions | Extensions to the core OrganizationServiceContext class. (Developer Extensions)
OrganizationServiceContextUtility | Contains utility methods. (Developer Extensions)
RelationshipExtensions | Extensions for working with relationships. (Developer Extensions)
StringExtensions | Extensions for working with string values. (Developer Extensions)
TypeExtensions | Extensions to help working with types. (Developer Extensions)

Interfaces

Interface | Description
IOrganizationServiceContainer | Interface that returns the service. (Developer Extensions)

Enumerations

Enumeration | Description
RoundTo | Enumerations used for rounding date/time values. (Developer Extensions)
ServiceConfigurationInstanceMode | Enumeration values for the server configuration instance mode. (Developer Extensions)


CrmConnection Class
See Also Members
[image]

Provides a connection to the server using a connection string. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection

Syntax

Visual Basic
Public Class CrmConnection
C#
public class CrmConnection
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.CrmConnection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Simplified Connection to Microsoft Dynamics CRM


CrmConnection Members
See Also Constructors Methods Properties
[image]

Provides a connection to the server using a connection string. (Developer Extensions)

The following tables list the members exposed by the CrmConnection type.

Public Constructors

Name | Description
CrmConnection | Overloaded. Initializes a new instance of the CrmConnection class.
Top

Public Properties

 | Name | Description
public property | CallerId | Gets or sets the GUID of the user for whom SDK calls are made on behalf of.
public property | ClientCredentials | Gets or sets the user credentials.
public property | DeviceCredentials | Gets the Windows Live ID device credentials.
public property | HomeRealmUri | Gets or sets the URI of the cross realm STS metadata endpoint.
public property | ProxyTypesAssembly | Gets or sets the assembly containing the strong proxy types.
public property | ProxyTypesEnabled | Gets or sets whether the strong proxy types should be returned by the service.
public property | ServiceConfigurationInstanceMode | Gets or sets the mode for instantiating the service configuration.
public property | ServiceUri | Gets or set the organization service URL.
public property | Timeout | Gets or sets the service timeout value.
public property | UserTokenExpiryWindow | Gets or sets the time offset prior to the user token expiration when the user token should be refreshed.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetConnectionId | Gets or sets the text value that is unique to the connection values.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
 | Parse | Parses a string in the DbConnectionStringBuilder format.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

CrmConnection Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Simplified Connection to Microsoft Dynamics CRM


CrmConnection Constructor
[image]

Initializes a new instance of the CrmConnection class.

Overload List

Name | Description
CrmConnection () | Initializes a new instance of the CrmConnection class.
CrmConnection (ConnectionStringSettings) | Initializes a new instance of the CrmConnection class , setting the connection string.
CrmConnection (String) | Initializes a new instance of the CrmConnection class , setting the connection string name.

See Also

Reference

CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConnection Constructor ()
[image]

Initializes a new instance of the CrmConnection class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New CrmConnection

Syntax

Visual Basic
Public Sub New
C#
public CrmConnection ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection Constructor (ConnectionStringSettings)
[image]

Initializes a new instance of the CrmConnection class , setting the connection string.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionString As ConnectionStringSettings

Dim instance As New CrmConnection(connectionString)

Syntax

Visual Basic
Public Sub New ( _
    connectionString As ConnectionStringSettings _
)
C#
public CrmConnection (
    ConnectionStringSettings connectionString
)
C++

J#

JScript

Parameters
connectionString
Type: ConnectionStringSettings. The connection string.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection Constructor (String)
[image]

Initializes a new instance of the CrmConnection class , setting the connection string name.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionStringName As String

Dim instance As New CrmConnection(connectionStringName)

Syntax

Visual Basic
Public Sub New ( _
    connectionStringName As String _
)
C#
public CrmConnection (
    string connectionStringName
)
C++

J#

JScript

Parameters
connectionStringName
Type: Int32. The connection string name.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetConnectionId | Gets or sets the text value that is unique to the connection values.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
 | Parse | Parses a string in the DbConnectionStringBuilder format.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CrmConnection Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Simplified Connection to Microsoft Dynamics CRM


CrmConnection.GetConnectionId Method
[image]

Gets or sets the text value that is unique to the connection values.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim returnValue As String

returnValue = instance.GetConnectionId

Syntax

Visual Basic
Public Function GetConnectionId As String
C#
public string GetConnectionId ()
C++

J#

JScript

Return Value
Type: String
The unique connection ID.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.Parse Method
[image]

Parses a string in the DbConnectionStringBuilder format.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionString As String
Dim returnValue As CrmConnection

returnValue = CrmConnection.Parse(connectionString)

Syntax

Visual Basic
Public Shared Function Parse ( _
    connectionString As String _
) As CrmConnection
C#
public static CrmConnection Parse (
    string connectionString
)
C++

J#

JScript

Parameters
connectionString
Type: String. The connection string to parse.
Return Value
Type: CrmConnection
.

  Remarks
For more information, see DbConnectionStringBuilder.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection Properties
[image]

Public Properties

 | Name | Description
public property | CallerId | Gets or sets the GUID of the user for whom SDK calls are made on behalf of.
public property | ClientCredentials | Gets or sets the user credentials.
public property | DeviceCredentials | Gets the Windows Live ID device credentials.
public property | HomeRealmUri | Gets or sets the URI of the cross realm STS metadata endpoint.
public property | ProxyTypesAssembly | Gets or sets the assembly containing the strong proxy types.
public property | ProxyTypesEnabled | Gets or sets whether the strong proxy types should be returned by the service.
public property | ServiceConfigurationInstanceMode | Gets or sets the mode for instantiating the service configuration.
public property | ServiceUri | Gets or set the organization service URL.
public property | Timeout | Gets or sets the service timeout value.
public property | UserTokenExpiryWindow | Gets or sets the time offset prior to the user token expiration when the user token should be refreshed.

See Also

Reference

CrmConnection Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Simplified Connection to Microsoft Dynamics CRM


CrmConnection.CallerId Property
[image]

Gets or sets the GUID of the user for whom SDK calls are made on behalf of.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As Nullable(Of Guid)

value = instance.CallerId

instance.CallerId = value

Syntax

Visual Basic
Public Property CallerId As Nullable(Of Guid)
C#
public Nullable<Guid> CallerId { get; set; }
C++

J#

JScript

Property Value
Type: Nullable<Guid>

The GUID of the user for whom SDK calls are made on behalf of. This corresponds to the SystemUser.SystemUserId attribute, which is the primary key for the SystemUser entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.ClientCredentials Property
[image]

Gets or sets the user credentials.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As ClientCredentials

value = instance.ClientCredentials

instance.ClientCredentials = value

Syntax

Visual Basic
Public Property ClientCredentials As ClientCredentials
C#
public ClientCredentials ClientCredentials { get; set; }
C++

J#

JScript

Property Value
Type: ClientCredentials
The user credentials.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.DeviceCredentials Property
[image]

Gets the Windows Live ID device credentials.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As ClientCredentials

value = instance.DeviceCredentials

instance.DeviceCredentials = value

Syntax

Visual Basic
Public Property DeviceCredentials As ClientCredentials
C#
public ClientCredentials DeviceCredentials { get; set; }
C++

J#

JScript

Property Value
Type: ClientCredentials
The Windows Live ID device credentials.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.HomeRealmUri Property
[image]

Gets or sets the URI of the cross realm STS metadata endpoint.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As Uri

value = instance.HomeRealmUri

instance.HomeRealmUri = value

Syntax

Visual Basic
Public Property HomeRealmUri As Uri
C#
public Uri HomeRealmUri { get; set; }
C++

J#

JScript

Property Value
Type: URI
The URI of the cross realm STS metadata endpoint.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.ProxyTypesAssembly Property
[image]

Gets or sets the assembly containing the strong proxy types.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As Assembly

value = instance.ProxyTypesAssembly

instance.ProxyTypesAssembly = value

Syntax

Visual Basic
Public Property ProxyTypesAssembly As Assembly
C#
public Assembly ProxyTypesAssembly { get; set; }
C++

J#

JScript

Property Value
Type: Assembly
The assembly containing the strong proxy types.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.ProxyTypesEnabled Property
[image]

Gets or sets whether the strong proxy types should be returned by the service.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As Boolean

value = instance.ProxyTypesEnabled

instance.ProxyTypesEnabled = value

Syntax

Visual Basic
Public Property ProxyTypesEnabled As Boolean
C#
public bool ProxyTypesEnabled { get; set; }
C++

J#

JScript

Property Value
Type: Boolean
true if the strong proxy types should be returned by the service; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.ServiceConfigurationInstanceMode Property
[image]

Gets or sets the mode for instantiating the service configuration.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As ServiceConfigurationInstanceMode

value = instance.ServiceConfigurationInstanceMode

instance.ServiceConfigurationInstanceMode = value

Syntax

Visual Basic
Public Property ServiceConfigurationInstanceMode As ServiceConfigurationInstanceMode
C#
public ServiceConfigurationInstanceMode ServiceConfigurationInstanceMode { get; set; }
C++

J#

JScript

Property Value
Type: ServiceConfigurationInstanceMode
The mode for instantiating the service configuration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.ServiceUri Property
[image]

Gets or set the organization service URL.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As Uri

value = instance.ServiceUri

instance.ServiceUri = value

Syntax

Visual Basic
Public Property ServiceUri As Uri
C#
public Uri ServiceUri { get; set; }
C++

J#

JScript

Property Value
Type: URI
The organization service URL.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.Timeout Property
[image]

Gets or sets the service timeout value.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As Nullable(Of TimeSpan)

value = instance.Timeout

instance.Timeout = value

Syntax

Visual Basic
Public Property Timeout As Nullable(Of TimeSpan)
C#
public Nullable<TimeSpan> Timeout { get; set; }
C++

J#

JScript

Property Value
Type: TimeSpan
The service timeout value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnection.UserTokenExpiryWindow Property
[image]

Gets or sets the time offset prior to the user token expiration when the user token should be refreshed.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnection
Dim value As Nullable(Of TimeSpan)

value = instance.UserTokenExpiryWindow

instance.UserTokenExpiryWindow = value

Syntax

Visual Basic
Public Property UserTokenExpiryWindow As Nullable(Of TimeSpan)
C#
public Nullable<TimeSpan> UserTokenExpiryWindow { get; set; }
C++

J#

JScript

Property Value
Type: Nullable<TimeSpan>
The time offset prior to the user token expiration when the user token should be refreshed.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnection Class
CrmConnection Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity Class
See Also Members
[image]

Extensions to the core Microsoft.Xrm.Sdk.Entity class. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntity

Syntax

Visual Basic
<IgnorePropertiesAttribute(System.String[])> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<DataServiceKeyAttribute("Id")> _
Public Class CrmEntity
    Inherits Entity
    Implements INotifyPropertyChanging, INotifyPropertyChanged
C#
[IgnorePropertiesAttribute(System.String[])]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[DataServiceKeyAttribute("Id")]
public class CrmEntity : Entity, INotifyPropertyChanging, INotifyPropertyChanged
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Entity
    Microsoft.Xrm.Client.CrmEntity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Members
Microsoft.Xrm.Client Namespace
Entity
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity Members
See Also Constructors Events Methods Properties
[image]

Extensions to the core Microsoft.Xrm.Sdk.Entity class. (Developer Extensions)

The following tables list the members exposed by the CrmEntity type.

Public Constructors

Name | Description
CrmEntity | Initializes a new instance of the CrmEntity class.
Top

Public Properties

 | Name | Description
public property | Attributes | (inherited from Entity)
public property | EntityState | (inherited from Entity)
public property | ExtensionData | (inherited from Entity)
public property | FormattedValues | (inherited from Entity)
public property | Id | (inherited from Entity)
public property | Item | (inherited from Entity)
public property | LogicalName | (inherited from Entity)
public property | RelatedEntities | (inherited from Entity)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Contains | (inherited from Entity)
public method | Equals | (inherited from Object)
public method | GetAttributeCollectionValue | Retrieves the value of a sequence attribute.
public method | GetAttributeValue | Overridden. Retrieves the value of an attribute.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToEntity | (inherited from Entity)
public method | ToEntityReference | (inherited from Entity)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetFormattedAttributeValue | (inherited from Entity)
protected method | GetRelatedEntities | Overridden. Gets the collection of related entity instances for the specified relationship.
protected method | GetRelatedEntity | Overridden. Gets the related entity instance for the specified relationship.
protected method | MemberwiseClone | (inherited from Object)
protected method | SetAttributeCollectionValue | Modifies the value of a sequence attribute.
protected method | SetAttributeValue | (inherited from Entity)
protected method | SetAttributeValue | Overloaded.
protected method | SetPrimaryIdAttributeValue | Modifies the value of a primary key attribute.
protected method | SetRelatedEntities | Overloaded.
protected method | SetRelatedEntities | (inherited from Entity)
protected method | SetRelatedEntity | Overloaded.
protected method | SetRelatedEntity | (inherited from Entity)
Top

Extension Methods

 | Name | Description
public extension method | AssertEntityName | Verifies that the logical name of an entity is the expected name. (Defined by EntityExtensions.)
public extension method | Clone | Overloaded. Deep clones an instance of the Entity class. (Defined by EntityExtensions.)
public extension method | GetAttributeValue | Overloaded. Retrieves the value of an attribute. (Defined by EntityExtensions.)
public extension method | GetEntityReferenceValue | Retrieves attribute values for EntityReference attributes. (Defined by EntityExtensions.)
public extension method | GetRelatedEntities | Overloaded. Retrieves the collection of related entities for a specific relationship. (Defined by EntityExtensions.)
public extension method | GetRelatedEntity | Overloaded. Retrieves the related entity for a specific relationship. (Defined by EntityExtensions.)
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
public extension method | SetAttributeCollectionValue | Modifies the value of a sequence attribute. (Defined by EntityExtensions.)
public extension method | SetAttributeValue | Overloaded. (Defined by EntityExtensions.)
public extension method | SetRelatedEntities | Overloaded.
public extension method | SetRelatedEntities | Overloaded. (Defined by EntityExtensions.)
public extension method | SetRelatedEntity | Overloaded.
public extension method | SetRelatedEntity | Overloaded. (Defined by EntityExtensions.)
Top

Public Events

 | Name | Description
public event | PropertyChanged | Occurs when an attribute or relationship is set.
public event | PropertyChanging | Occurs when an attribute or relationship is set.
Top

See Also

Reference

CrmEntity Class
Microsoft.Xrm.Client Namespace
Entity

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntity Constructor
[image]

Initializes a new instance of the CrmEntity class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entityName As String

Dim instance As New CrmEntity(entityName)

Syntax

Visual Basic
Public Sub New ( _
    entityName As String _
)
C#
public CrmEntity (
    string entityName
)
C++

J#

JScript

Parameters
entityName
Type: String. The name of the entity.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Contains | (inherited from Entity)
public method | Equals | (inherited from Object)
public method | GetAttributeCollectionValue | Retrieves the value of a sequence attribute.
public method | GetAttributeValue | Overridden. Retrieves the value of an attribute.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToEntity | (inherited from Entity)
public method | ToEntityReference | (inherited from Entity)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetFormattedAttributeValue | (inherited from Entity)
protected method | GetRelatedEntities | Overridden. Gets the collection of related entity instances for the specified relationship.
protected method | GetRelatedEntity | Overridden. Gets the related entity instance for the specified relationship.
protected method | MemberwiseClone | (inherited from Object)
protected method | SetAttributeCollectionValue | Modifies the value of a sequence attribute.
protected method | SetAttributeValue | (inherited from Entity)
protected method | SetAttributeValue | Overloaded.
protected method | SetPrimaryIdAttributeValue | Modifies the value of a primary key attribute.
protected method | SetRelatedEntities | Overloaded.
protected method | SetRelatedEntities | (inherited from Entity)
protected method | SetRelatedEntity | Overloaded.
protected method | SetRelatedEntity | (inherited from Entity)

Extension Methods

 | Name | Description
public extension method | AssertEntityName | Verifies that the logical name of an entity is the expected name. (Defined by EntityExtensions.)
public extension method | Clone | Overloaded. Deep clones an instance of the Entity class. (Defined by EntityExtensions.)
public extension method | GetAttributeValue | Overloaded. Retrieves the value of an attribute. (Defined by EntityExtensions.)
public extension method | GetEntityReferenceValue | Retrieves attribute values for EntityReference attributes. (Defined by EntityExtensions.)
public extension method | GetRelatedEntities | Overloaded. Retrieves the collection of related entities for a specific relationship. (Defined by EntityExtensions.)
public extension method | GetRelatedEntity | Overloaded. Retrieves the related entity for a specific relationship. (Defined by EntityExtensions.)
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
public extension method | SetAttributeCollectionValue | Modifies the value of a sequence attribute. (Defined by EntityExtensions.)
public extension method | SetAttributeValue | Overloaded. (Defined by EntityExtensions.)
public extension method | SetRelatedEntities | Overloaded.
public extension method | SetRelatedEntities | Overloaded. (Defined by EntityExtensions.)
public extension method | SetRelatedEntity | Overloaded.
public extension method | SetRelatedEntity | Overloaded. (Defined by EntityExtensions.)

See Also

Reference

CrmEntity Class
Microsoft.Xrm.Client Namespace
Entity

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntity.GetAttributeCollectionValue Method
[image]

Retrieves the value of a sequence attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntity
Dim attributeLogicalName As String
Dim returnValue As IEnumerable(Of T)

returnValue = instance.GetAttributeCollectionValue(attributeLogicalName)

Syntax

Visual Basic
Public Overridable Function GetAttributeCollectionValue(Of T As Entity) ( _
    attributeLogicalName As String _
) As IEnumerable(Of T)
C#
public virtual IEnumerable<T> GetAttributeCollectionValue<T> (
    string attributeLogicalName
) where T : Entity
C++

J#

JScript

GenericParameters
T
Type: Entity. The entity that contains the attribute.
Parameters
attributeLogicalName
Type: String. The logical name of the attribute.
Return Value
Type: IEnumerable<T>
Returns an enumerable collection where T is an Entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity.GetAttributeValue Method
[image]

Retrieves the value of an attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntity
Dim attributeLogicalName As String
Dim returnValue As T

returnValue = instance.GetAttributeValue(attributeLogicalName)

Syntax

Visual Basic
Public Overridable Function GetAttributeValue(Of T) ( _
    attributeLogicalName As String _
) As T
C#
public virtual T GetAttributeValue<T> (
    string attributeLogicalName
)
C++

J#

JScript

GenericParameters
T
Type: Entity. The entity that contains the attribute.
Parameters
attributeLogicalName
Type: String. The logical name of the attribute.
Return Value
Type: IEnumerable<T>
Returns an enumerable collection where T is an Entity.

  Remarks
Extends the core GetAttributeValue method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity.GetRelatedEntities Method
[image]

Gets the collection of related entity instances for the specified relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim returnValue As IEnumerable(Of TEntity)

returnValue = Me.GetRelatedEntities(relationshipSchemaName, primaryEntityRole)

Syntax

Visual Basic
Protected Overridable Function GetRelatedEntities(Of TEntity As Entity) ( _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole) _
) As IEnumerable(Of TEntity)
C#
protected virtual IEnumerable<TEntity> GetRelatedEntities<TEntity> (
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The entity.
Parameters
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
Return Value
Type: IEnumerable<TEntity>
Returns an enumerable collection where TEntity is an Entity.

  Remarks
Extends the core GetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity.GetRelatedEntity Method
[image]

Gets the related entity instance for the specified relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim returnValue As TEntity

returnValue = Me.GetRelatedEntity(relationshipSchemaName, primaryEntityRole)

Syntax

Visual Basic
Protected Overridable Function GetRelatedEntity(Of TEntity As Entity) ( _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole) _
) As TEntity
C#
protected virtual TEntity GetRelatedEntity<TEntity> (
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The entity.
Parameters
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
Return Value
Type: TEntity
The related entity instance for the specified relationship where TEntity is an Entity.

  Remarks
Extends the core GetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity.SetAttributeCollectionValue Method
[image]

Modifies the value of a sequence attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String
Dim attributeLogicalName As String
Dim value As IEnumerable(Of T)

Me.SetAttributeCollectionValue(propertyName, attributeLogicalName, value)

Syntax

Visual Basic
Protected Overridable Sub SetAttributeCollectionValue(Of T As Entity) ( _
    propertyName As String, _
    attributeLogicalName As String, _
    value As IEnumerable(Of T) _
)
C#
protected virtual void SetAttributeCollectionValue<T> (
    string propertyName,
    string attributeLogicalName,
    IEnumerable<T> value
) where T : Entity
C++

J#

JScript

GenericParameters
T
Type: Entity. The entity.
Parameters
propertyName
Type: String. The name of the property to set.
attributeLogicalName
Type: String. The logical name of the attribute.
value
Type: IEnumerable<T>. The value of the property.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity.SetAttributeValue Method
[image]

Overload List

Name | Description
CrmEntity.SetAttributeValue (String, String, Object) | Modifies the value of an attribute.
CrmEntity.SetAttributeValue (String, String, String, Object) | Modifies the value of an attribute.

See Also

Reference

CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace


CrmEntity.SetAttributeValue Method (String, String, Object)
[image]

Modifies the value of an attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String
Dim attributeLogicalName As String
Dim value As Object

Me.SetAttributeValue(propertyName, attributeLogicalName, value)

Syntax

Visual Basic
Protected Overridable Sub SetAttributeValue(Of T) ( _
    propertyName As String, _
    attributeLogicalName As String, _
    value As Object _
)
C#
protected virtual void SetAttributeValue<T> (
    string propertyName,
    string attributeLogicalName,
    Object value
)
C++

J#

JScript

GenericParameters
T
Type: Entity. The entity.
Parameters
propertyName
Type: String. The name of the property to set.
attributeLogicalName
Type: String. The logical name of the attribute.
value
Type: Object. The attribute value.
  Remarks
Extends the core SetAttributeValue method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace


CrmEntity.SetAttributeValue Method (String, String, String, Object)
[image]

Modifies the value of an attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String
Dim attributeLogicalName As String
Dim entityLogicalName As String
Dim value As Object

Me.SetAttributeValue(propertyName, attributeLogicalName, entityLogicalName, value)

Syntax

Visual Basic
Protected Overridable Sub SetAttributeValue(Of T) ( _
    propertyName As String, _
    attributeLogicalName As String, _
    entityLogicalName As String, _
    value As Object _
)
C#
protected virtual void SetAttributeValue<T> (
    string propertyName,
    string attributeLogicalName,
    string entityLogicalName,
    Object value
)
C++

J#

JScript

GenericParameters
T
Type: Entity. The entity.
Parameters
propertyName
Type: String. The name of the property to set.
attributeLogicalName
Type: String. The logical name of the attribute.
entityLogicalName
Type: String. The logical name of the entity.
value
Type: Object. The attribute value.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace


CrmEntity.SetPrimaryIdAttributeValue Method
[image]

Modifies the value of a primary key attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String
Dim attributeLogicalName As String
Dim value As Object

Me.SetPrimaryIdAttributeValue(propertyName, attributeLogicalName, value)

Syntax

Visual Basic
Protected Overridable Sub SetPrimaryIdAttributeValue(Of T) ( _
    propertyName As String, _
    attributeLogicalName As String, _
    value As Object _
)
C#
protected virtual void SetPrimaryIdAttributeValue<T> (
    string propertyName,
    string attributeLogicalName,
    Object value
)
C++

J#

JScript

GenericParameters
T
Type: Entity. The entity.
Parameters
propertyName
Type: String. The name of the property to set.
attributeLogicalName
Type: String. The logical name of the attribute.
value
Type: Object. The value of the property.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity.SetRelatedEntities Method
[image]

Overload List

Name | Description
CrmEntity.SetRelatedEntities (String, String, IEnumerable) | Sets the collection of related entity instances for the specified relationship.
CrmEntity.SetRelatedEntities (String, String, Nullable, IEnumerable) | Sets the collection of related entity instances for the specified relationship.

See Also

Reference

CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace


CrmEntity.SetRelatedEntities Method (String, String, IEnumerable)
[image]

Sets the collection of related entity instances for the specified relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String
Dim relationshipSchemaName As String
Dim entities As IEnumerable(Of TEntity)

Me.SetRelatedEntities(propertyName, relationshipSchemaName, entities)

Syntax

Visual Basic
Protected Overridable Sub SetRelatedEntities(Of TEntity As Entity) ( _
    propertyName As String, _
    relationshipSchemaName As String, _
    entities As IEnumerable(Of TEntity) _
)
C#
protected virtual void SetRelatedEntities<TEntity> (
    string propertyName,
    string relationshipSchemaName,
    IEnumerable<TEntity> entities
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The entity to which the entities are to be related.
Parameters
propertyName
Type: String. The name of the property.
relationshipSchemaName
Type: String. The schema name of the relationship.
entities
Type: IEnumerable<TEntity>. The set of entities to be related.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace


CrmEntity.SetRelatedEntities Method (String, String, Nullable, IEnumerable)
[image]

Sets the collection of related entity instances for the specified relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim entities As IEnumerable(Of TEntity)

Me.SetRelatedEntities(propertyName, relationshipSchemaName, primaryEntityRole, entities)

Syntax

Visual Basic
Protected Overridable Sub SetRelatedEntities(Of TEntity As Entity) ( _
    propertyName As String, _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole), _
    entities As IEnumerable(Of TEntity) _
)
C#
protected virtual void SetRelatedEntities<TEntity> (
    string propertyName,
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole,
    IEnumerable<TEntity> entities
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The entity to which the entities are to be related.
Parameters
propertyName
Type: String. The name of the property.
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
entities
Type: IEnumerable<TEntity>. The set of entities to be related.
  Remarks
Extends the core SetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace


CrmEntity.SetRelatedEntity Method
[image]

Overload List

Name | Description
CrmEntity.SetRelatedEntity (String, String, TEntity) | Sets the related entity for a specific relationship.
CrmEntity.SetRelatedEntity (String, String, Nullable, TEntity) | Sets the related entity for a specific relationship.

See Also

Reference

CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace


CrmEntity.SetRelatedEntity Method (String, String, TEntity)
[image]

Sets the related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String
Dim relationshipSchemaName As String
Dim entity As TEntity

Me.SetRelatedEntity(propertyName, relationshipSchemaName, entity)

Syntax

Visual Basic
Protected Overridable Sub SetRelatedEntity(Of TEntity As Entity) ( _
    propertyName As String, _
    relationshipSchemaName As String, _
    entity As TEntity _
)
C#
protected virtual void SetRelatedEntity<TEntity> (
    string propertyName,
    string relationshipSchemaName,
    TEntity entity
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The entity to which the entity is to be related.
Parameters
propertyName
Type: String. The name of the property.
relationshipSchemaName
Type: String. The schema name of the relationship.
entity
Type: IEnumerable<TEntity>. The entity to be related.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace


CrmEntity.SetRelatedEntity Method (String, String, Nullable, TEntity)
[image]

Sets the related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim entity As TEntity

Me.SetRelatedEntity(propertyName, relationshipSchemaName, primaryEntityRole, entity)

Syntax

Visual Basic
Protected Overridable Sub SetRelatedEntity(Of TEntity As Entity) ( _
    propertyName As String, _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole), _
    entity As TEntity _
)
C#
protected virtual void SetRelatedEntity<TEntity> (
    string propertyName,
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole,
    TEntity entity
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
Type: Entity. The entity to which the entity is to be related.
Parameters
propertyName
Type: String. The name of the property.
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
entity
Type: IEnumerable<TEntity>. The entity to be related.
  Remarks
Extends the core SetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace


CrmEntity Properties
[image]

Public Properties

 | Name | Description
public property | Attributes | (inherited from Entity)
public property | EntityState | (inherited from Entity)
public property | ExtensionData | (inherited from Entity)
public property | FormattedValues | (inherited from Entity)
public property | Id | (inherited from Entity)
public property | Item | (inherited from Entity)
public property | LogicalName | (inherited from Entity)
public property | RelatedEntities | (inherited from Entity)

See Also

Reference

CrmEntity Class
Microsoft.Xrm.Client Namespace
Entity

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntity Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged | Occurs when an attribute or relationship is set.
public event | PropertyChanging | Occurs when an attribute or relationship is set.

See Also

Reference

CrmEntity Class
Microsoft.Xrm.Client Namespace
Entity

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntity.PropertyChanged Event
[image]

Occurs when an attribute or relationship is set.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntity
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler

Syntax

Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntity.PropertyChanging Event
[image]

Occurs when an attribute or relationship is set.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntity
Dim handler As PropertyChangingEventHandler

AddHandler instance.PropertyChanging, handler

Syntax

Visual Basic
Public Event PropertyChanging As PropertyChangingEventHandler
C#
public event PropertyChangingEventHandler PropertyChanging
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntity Class
CrmEntity Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference Class
See Also Members
[image]

Contains a reference to a specific record (entity instance). (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntityReference

Syntax

Visual Basic
Public NotInheritable Class CrmEntityReference
    Implements IExtensibleDataObject
C#
public sealed class CrmEntityReference : IExtensibleDataObject
C++

J#

JScript

  Remarks
Extends the core EntityReference class.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.CrmEntityReference
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Contains a reference to a specific record (entity instance). (Developer Extensions)

The following tables list the members exposed by the CrmEntityReference type.

Public Constructors

Name | Description
CrmEntityReference | Overloaded. Initializes an instance of the CrmEntityReference class.
Top

Public Properties

 | Name | Description
public property | Id | Gets or sets the ID of the record (entity instance).
public property | LogicalName | Gets or sets the logical name of the entity.
public property | Name | Gets or sets the name of the entity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines if the specified object is equal to this entity reference.
public method | GetHashCode | Overridden. Gets the hash value for this type.
public method | GetType | (inherited from Object)
 | Implicit | Overloaded. Converts between entity reference types.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
ExtensionData | Gets or sets the structure that contains extra data.
Top

See Also

Reference

CrmEntityReference Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference Constructor
[image]

Initializes an instance of the CrmEntityReference class.

Overload List

Name | Description
CrmEntityReference () | Initializes an instance of the CrmEntityReference class.
CrmEntityReference (String, Guid) | Initializes an instance of the CrmEntityReference class.

See Also

Reference

CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference Constructor ()
[image]

Initializes an instance of the CrmEntityReference class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New CrmEntityReference

Syntax

Visual Basic
Public Sub New
C#
public CrmEntityReference ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference Constructor (String, Guid)
[image]

Initializes an instance of the CrmEntityReference class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim logicalName As String
Dim id As Guid

Dim instance As New CrmEntityReference(logicalName, id)

Syntax

Visual Basic
Public Sub New ( _
    logicalName As String, _
    id As Guid _
)
C#
public CrmEntityReference (
    string logicalName,
    Guid id
)
C++

J#

JScript

Parameters
logicalName
Type: String. The logical name of the entity.
id
Type: Guid. The ID of the record (entity instance).
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. Determines if the specified object is equal to this entity reference.
public method | GetHashCode | Overridden. Gets the hash value for this type.
public method | GetType | (inherited from Object)
 | Implicit | Overloaded. Converts between entity reference types.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CrmEntityReference Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference.Equals Method
[image]

Determines if the specified object is equal to this entity reference.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntityReference
Dim obj As Object
Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Syntax

Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals (
    Object obj
)
C++

J#

JScript

Parameters
obj
The entity reference to compare.
Return Value
Type: Boolean
true if the specified object is equal to this entity reference; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference.GetHashCode Method
[image]

Gets the hash value for this type.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntityReference
Dim returnValue As Integer

returnValue = instance.GetHashCode

Syntax

Visual Basic
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode ()
C++

J#

JScript

Return Value
Type: Int32

The hash value for this type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference.Implicit Method
[image]

Converts between entity reference types.

Overload List

Name | Description
CrmEntityReference.Implicit (CrmEntityReference) | Converts between entity reference types.
CrmEntityReference.Implicit (EntityReference) | Converts between entity reference types.

See Also

Reference

CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference.Implicit Method (CrmEntityReference)
[image]

Converts between entity reference types.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim input As CrmEntityReference
Dim output As EntityReference

output = CType(input, EntityReference)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    reference As CrmEntityReference _
) As EntityReference
C#
public static implicit operator EntityReference (
    CrmEntityReference reference
)
C++

J#

JScript

Parameters
reference
Type: CrmEntityReference. The entity reference to convert.
Return Value
Type: EntityReference
The converted entity reference.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference.Implicit Method (EntityReference)
[image]

Converts between entity reference types.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim input As EntityReference
Dim output As CrmEntityReference

output = CType(input, CrmEntityReference)

Syntax

Visual Basic
Public Shared Widening Operator CType ( _
    reference As EntityReference _
) As CrmEntityReference
C#
public static implicit operator CrmEntityReference (
    EntityReference reference
)
C++

J#

JScript

Parameters
reference
Type: EntityReference. The entity reference to convert.
Return Value
Type: CrmEntityReference
The converted entity reference.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference Properties
[image]

Public Properties

 | Name | Description
public property | Id | Gets or sets the ID of the record (entity instance).
public property | LogicalName | Gets or sets the logical name of the entity.
public property | Name | Gets or sets the name of the entity.

Explicit Interface Implementations

Name | Description
ExtensionData | Gets or sets the structure that contains extra data.

See Also

Reference

CrmEntityReference Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference.Id Property
[image]

Gets or sets the ID of the record (entity instance).

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntityReference
Dim value As Guid

value = instance.Id

instance.Id = value

Syntax

Visual Basic
Public Property Id As Guid
C#
public Guid Id { get; set; }
C++

J#

JScript

Property Value
Type: Guid
The ID of the record (entity instance).

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference.LogicalName Property
[image]

Gets or sets the logical name of the entity.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntityReference
Dim value As String

value = instance.LogicalName

instance.LogicalName = value

Syntax

Visual Basic
Public Property LogicalName As String
C#
public string LogicalName { get; set; }
C++

J#

JScript

Property Value
Type: Int32

The logical name of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference.Name Property
[image]

Gets or sets the name of the entity.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntityReference
Dim value As String

value = instance.Name

instance.Name = value

Syntax

Visual Basic
Public Property Name As String
C#
public string Name { get; set; }
C++

J#

JScript

Property Value
Type: Int32

The name of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntityReference.ExtensionData Property
[image]

Gets or sets the structure that contains extra data.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntityReference
Dim value As ExtensionDataObject

value = CType(instance, IExtensibleDataObject).ExtensionData

CType(instance, IExtensibleDataObject).ExtensionData = value

Syntax

Visual Basic
Private Property System.Runtime.Serialization.IExtensibleDataObject.ExtensionData As ExtensionDataObject Implements IExtensibleDataObject.ExtensionData
C#
ExtensionDataObject IExtensibleDataObject.ExtensionData { get; set; }
C++

J#

JScript

Property Value
Type: ExtensionDataObject
The extension data.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntityReference Class
CrmEntityReference Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmOrganizationServiceContext Class
See Also Members
[image]

Extensions to the core OrganizationServiceContext class. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext

Syntax

Visual Basic
Public Class CrmOrganizationServiceContext
    Inherits OrganizationServiceContext
    Implements IInitializable, IOrganizationService, IUpdatable, IExpandProvider, _
    IOrganizationServiceContainer
C#
public class CrmOrganizationServiceContext : OrganizationServiceContext, IInitializable, IOrganizationService, IUpdatable,
    IExpandProvider, IOrganizationServiceContainer
C++

J#

JScript

  Remarks
The Developer Extensions for Microsoft Dynamics CRM version of the runtime context of the data service that is used to track Microsoft Dynamics CRM entities and that sends and receives entities from the server.

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.Client.OrganizationServiceContext
    Microsoft.Xrm.Client.CrmOrganizationServiceContext
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Simplified Connection to Microsoft Dynamics CRM
Developer Extensions Context Object Model
Access Entity Relationships
Attach Entities to the Context
Developer Extensions for Microsoft Dynamics CRM


CrmOrganizationServiceContext Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Extensions to the core OrganizationServiceContext class. (Developer Extensions)

The following tables list the members exposed by the CrmOrganizationServiceContext type.

Public Constructors

Name | Description
CrmOrganizationServiceContext | Overloaded. Initializes a new instance of the CrmOrganizationServiceContext class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | MergeOption | (inherited from OrganizationServiceContext)
public property | SaveChangesDefaultOptions | (inherited from OrganizationServiceContext)
Top

Protected Properties

 | Name | Description
protected property | QueryProvider | (inherited from OrganizationServiceContext)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddLink | (inherited from OrganizationServiceContext)
public method | AddObject | (inherited from OrganizationServiceContext)
public method | AddRelatedObject | (inherited from OrganizationServiceContext)
public method | Associate | Creates a link between records (entity instances). (Developer Extensions)
public method | Attach | (inherited from OrganizationServiceContext)
public method | AttachLink | (inherited from OrganizationServiceContext)
public method | ClearChanges | (inherited from OrganizationServiceContext)
public method | Create | Creates a record. (Developer Extensions)
public method | CreateQuery | (inherited from OrganizationServiceContext)
public method | CreateQuery | (inherited from OrganizationServiceContext)
public method | Delete | Deletes a record. (Developer Extensions)
public method | DeleteLink | (inherited from OrganizationServiceContext)
public method | DeleteObject | (inherited from OrganizationServiceContext)
public method | DeleteObject | (inherited from OrganizationServiceContext)
public method | Detach | (inherited from OrganizationServiceContext)
public method | Detach | (inherited from OrganizationServiceContext)
public method | DetachLink | (inherited from OrganizationServiceContext)
public method | Disassociate | Deletes a link between records. (Developer Extensions)
public method | Dispose | (inherited from OrganizationServiceContext)
public method | Equals | (inherited from Object)
public method | Execute | (inherited from OrganizationServiceContext)
public method | GetAttachedEntities | (inherited from OrganizationServiceContext)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | Initializes custom settings.
public method | IsAttached | (inherited from OrganizationServiceContext)
public method | IsAttached | (inherited from OrganizationServiceContext)
public method | IsDeleted | (inherited from OrganizationServiceContext)
public method | IsDeleted | (inherited from OrganizationServiceContext)
public method | LoadProperty | (inherited from OrganizationServiceContext)
public method | LoadProperty | (inherited from OrganizationServiceContext)
public method | Retrieve | Retrieves a record. (Developer Extensions)
public method | RetrieveMultiple | Retrieves a collection of records. (Developer Extensions)
public method | SaveChanges | (inherited from OrganizationServiceContext)
public method | SaveChanges | (inherited from OrganizationServiceContext)
public method | ToString | (inherited from Object)
public method | Update | Updates an existing record. (Developer Extensions)
public method | UpdateObject | (inherited from OrganizationServiceContext)
public method | UpdateObject | (inherited from OrganizationServiceContext)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateQuery | (inherited from OrganizationServiceContext)
protected method | Dispose | Overridden. Disposes the service context. (Developer Extensions)
protected method | Finalize | Overridden. (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnBeginEntityTracking | Overridden. Method called when entity tracking begins. (Developer Extensions)
protected method | OnBeginLinkTracking | (inherited from OrganizationServiceContext)
protected method | OnEndEntityTracking | Overridden. Method called when entity tracking ends. (Developer Extensions)
protected method | OnEndLinkTracking | (inherited from OrganizationServiceContext)
protected method | OnExecute | (inherited from OrganizationServiceContext)
protected method | OnExecute | (inherited from OrganizationServiceContext)
protected method | OnExecuting | (inherited from OrganizationServiceContext)
protected method | OnSaveChanges | Overridden. Method called after an attempt to save data changes. (Developer Extensions)
protected method | OnSavingChanges | (inherited from OrganizationServiceContext)
Top

Extension Methods

 | Name | Description
public extension method | AddItemCampaign | Adds an item to a campaign. The item added must be one of the following entity types: campaign, list, product, or salesliterature. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddItemCampaignActivity | Adds an item to a campaign activity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddLink | Overloaded. Adds the specified link to the set of objects the OrganizationServiceContext is tracking. (Defined by OrganizationServiceContextExtensions.)
public extension method | AddListMembersList | Adds a list of members to a list. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddMemberList | Adds a member to a list. The member added must be one of the following entity types: account, contact, or lead. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddMembersTeam | Adds members to a team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddPrivilegesRole | Adds a set of existing privileges to an existing role. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddProductToKit | Adds a product to a kit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddRecurrence | Adds recurrence information to an existing appointment to make it a recurring appointment master. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddRelatedObject | Overloaded. (Defined by OrganizationServiceContextExtensions.)
public extension method | AddSolutionComponent | Adds a solution component to an unmanaged solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddSubstituteProduct | Deprecated. Establishes an association between a product and a substitute product. Use Associate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddToQueue | Moves a record from a source queue to a destination queue. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Assign | Assigns the specified record to a new security principal (user). This changes the ownerid attribute of the instance. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AssociateEntities | Deprecated. Adds a link between two records in a many-to-many relationship. Use Associate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AttachClone | Clones an arbitrary source entity and attaches it to the context. (Defined by OrganizationServiceContextExtensions.)
public extension method | AttachLink | Overloaded. Attaches a two entity instances. (Defined by OrganizationServiceContextExtensions.)
public extension method | AutoMapEntity | Creates the attribute mappings between two entities. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | BackgroundSendEmail | Sends an email asynchronously. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Book | Schedules or "books" an appointment. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | BulkDelete | Submits an asynchronous bulk delete job. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | BulkDetectDuplicates | Submits an asynchronous duplicates detection job. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | BulkOperationStatusClose | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CalculateActualValueOpportunity | Calculates the value of an opportunity that is in the "Won" state. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CalculateTotalTimeIncident | Calculates the total number of minutes spent on an incident (case). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CancelContract | Cancels a contract. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CancelSalesOrder | Cancels a sales order. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CheckIncomingEmail | Checks whether the incoming email message is relevant to the Microsoft Dynamics CRM system. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CheckPromoteEmail | Checks whether the incoming email message should be promoted to the Microsoft Dynamics CRM system. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CleanUpBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CloneContract | Copies an existing contract and its line items. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CloseIncident | Overloaded. Closes an incident (case). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CloseQuote | Closes a quote. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CompoundCreate | Deprecated. Creates a compound entity (salesorder, invoice, quote, or duplicaterule) and its related entity (salesorderdetail, invoicedetail, quotedetail, or duplicaterulecondition). Use Create. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CompoundUpdate | Deprecated. Updates a compound record (salesorder, invoice, quote or duplicaterule) and its related detail record (salesorderdetail, invoicedetail, quotedetail or duplicaterulecondition). Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CompoundUpdateDuplicateDetectionRule | Updates a duplicate rule (duplicate detection rule) and its related duplicate rule conditions. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ConvertKitToProduct | Converts a kit to a product. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ConvertProductToKit | Converts a product to a kit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ConvertQuoteToSalesOrder | Converts a quote to a sales order. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ConvertSalesOrderToInvoice | Converts a sales order to an invoice. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopyCampaign | Copies a campaign. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopyCampaignResponse | Copies the information from one campaign response to another, and optionally creates a campaign response template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopyDynamicListToStatic | Creates a static list from the specified dynamic list and adds the members that satisfy the dynamic list query criteria to the static list. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopyMembersList | Copies the members from the source list to the target list without creating duplicates. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopySystemForm | Creates a new entity form that is based on an existing entity form. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CreateActivitiesList | Creates the activities for a list. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CreateException | Creates an exception for the recurring appointment instance. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CreateInstance | Creates future unexpanded instances of a recurring appointment master. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CreateWorkflowFromTemplate | Creates a workflow from a workflow template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeleteAuditData | Deletes all partitions containing audit data created before a given end date. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeleteLink | Overloaded. (Defined by OrganizationServiceContextExtensions.)
public extension method | DeleteOpenInstances | Deletes instances of a recurring appointment master that have an Open state. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeliverIncomingEmail | Creates an email activity record from an incoming email message. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeliverPromoteEmail | Creates an email activity instance from the specified email message (Track in CRM). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeprovisionLanguage | Deprovisions a language. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Detach | (Defined by OrganizationServiceContextExtensions.)
public extension method | DetachLink | Overloaded. Detaches a two entity instances. (Defined by OrganizationServiceContextExtensions.)
public extension method | DisassociateEntities | Deprecated. Removes a link between two records in a many to many relationship. Use Disassociate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DistributeCampaignActivity | Creates a bulk operation to distribute the activity, creating the appropriate activity for each member in the list for the specified campaign activity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DownloadReportDefinition | Downloads a report definition. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Execute | (Defined by OrganizationServiceContextExtensions.)
public extension method | Execute | Extensions to the core Execute method. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | ExecuteByIdSavedQuery | Executes a saved query (view) that has the specified ID. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExecuteByIdUserQuery | Executes the user query (saved view) that has the specified ID. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExecuteFetch | Deprecated. Executes the specified Fetch XML query. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExecuteWorkflow | Executes a workflow. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExpandCalendar | Converts the calendar rules to an array of available time blocks for the specified period. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExportSolution | Exports a managed or unmanaged solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExportTranslation | Exports all translations for a specific solution to a compressed file. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | FetchXmlToQueryExpression | Converts a query in Fetch XML to a QueryExpression. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | FetchXmlToQueryExpression | Extensions to the core FetchXmlToQueryExpressionRequest message. (Developer Extensions) (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | FindParentResourceGroup | Finds a parent resource group (scheduling group) for the specified resource groups (scheduling groups). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | FulfillSalesOrder | Fulfills a sales order (order). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GenerateInvoiceFromOpportunity | Generates an invoice from an opportunity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GenerateQuoteFromOpportunity | Generates a quote from an opportunity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GenerateSalesOrderFromOpportunity | Generates a sales order from an opportunity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetAllTimeZonesWithDisplayName | Retrieves all the time-zone definitions for the specified locale returning only the display name attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetDecryptionKey | Gets a decryption key. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetDistinctValuesImportFile | Returns distinct values for a column in the source file that contains list values. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetHeaderColumnsImportFile | Retrieves the source-file column headings, or system-generated column headings, if the source file does not contain column headings. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetInvoiceProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the specified invoice. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetQuantityDecimal | Gets the quantity decimal value for a product. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetQuoteProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the quote. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetReportHistoryLimit | Gets the history limit for a report. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetSalesOrderProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the sales order. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetTimeZoneCodeByLocalizedName | Retrieves the time-zone code for the specified localized time-zone name. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetTrackingTokenEmail | Returns a tracking token that can be then passed in as a parameter to the SendEmail method. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GrantAccess | Grants a security principal (user or team) access to the specified record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ImportRecordsImport | Imports XML mappings and creates an import data map. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ImportSolution | Imports a managed or unmanaged solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ImportTranslation | Imports all translations from a compressed file. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | InitializeFrom | Initializes a new record from an existing record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | InstallSampleData | Installs sample data for an organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | InstantiateFilters | Instantiates a filter. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | InstantiateTemplate | Creates an email message from a template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | IsAttached | Overloaded. Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext. (Defined by OrganizationServiceContextExtensions.)
public extension method | IsBackOfficeInstalled | Deprecated. Checks if Microsoft Great Plains is installed. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | IsComponentCustomizable | Determines whether a solution component is customizable. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | IsDeleted | Overloaded. Determines whether a relationship has been deleted. (Defined by OrganizationServiceContextExtensions.)
public extension method | IsValidStateTransition | Checks to see if the state transition is valid. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LoadProperty | Overloaded. Loads the related entity collection for the specified relationship. (Defined by OrganizationServiceContextExtensions.)
public extension method | LocalTimeFromUtcTime | Retrieves the local time for the specified Universal Time Coordinate (UTC) time. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LockInvoicePricing | Locks the total price of products and services specified in the invoice. When the invoice pricing is locked, changes to underlying price lists (price levels) do not affect the prices for an invoice. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LockSalesOrderPricing | Locks the total price of products and services specified in the sales order (order). When the sales order pricing is locked, changes to underlying price lists (price levels) do not affect the prices for a sales order (order). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LogFailureBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LogSuccessBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LoseOpportunity | Overloaded. Sets the state of an opportunity to Lost. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MakeAvailableToOrganizationReport | Deprecated. Makes the report available to all users in the organization. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MakeAvailableToOrganizationTemplate | Deprecated. Makes the specified email template available to the entire organization. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MakeUnavailableToOrganizationReport | Deprecated. Makes the report unavailable to all users in the organization. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MakeUnavailableToOrganizationTemplate | Deprecated. Makes the specified email template no longer available to the entire organization. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Merge | Merges the information from two records of the same type. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MergeClone | Clones an arbitrary source entity and attaches it to the context. (Defined by OrganizationServiceContextExtensions.)
public extension method | ModifyAccess | Replaces the access rights on the target record for the specified security principal (user or team). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ParseImport | Submits an asynchronous job that parses all import files associated with the specified data import (import). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ProcessInboundEmail | Processes marketing campaign email responses. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ProcessOneMemberBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | PropagateByExpression | Distributes an activity to a quick campaign. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ProvisionLanguage | Provisions a language. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | PublishAllXml | Publishes all customizations. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | PublishDuplicateRule | Submits an asynchronous job to publish a duplicate rule. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | PublishXml | Publishes the customizations for the specified entities. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QualifyLead | Qualifies a lead and creates an account, contact, or opportunity records that are linked to the originating lead. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QualifyMemberList | Qualifies the specified member list and either overrides the list members or removes them according to the specified option. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QueryExpressionToFetchXml | Converts a query represented as a QueryExpression class to the equivalent query represented as FetchXML. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QueryMultipleSchedules | Searches multiple resources for an available time slot matching the specified parameters. This is similar to the QuerySchedule method but it works for multiple resources at one time. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QuerySchedule | Searches the specified resource for an available time slot matching the specified parameters. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReassignObjectsOwner | Reassigns all records that are owned by the security principal (user or team) to another security principal (user or team). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReassignObjectsSystemUser | Reassigns all records that are owned by the user to another security principal (user or team). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReAttach | Resets the EntityState of an entity before attaching it to the context. (Defined by OrganizationServiceContextExtensions.)
public extension method | Recalculate | Recalculates the rollup attribute values for all goals in the goal hierarchy that contain a specified goal. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveItemCampaign | Removes an item from a campaign. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveItemCampaignActivity | Removes an item from a campaign activity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveMemberList | Removes a member from a list. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveMembersTeam | Removes members from a team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveParent | Removes the parent for a record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemovePrivilegeRole | Removes a privilege from an existing role. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveProductFromKit | Removes a product from a kit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveRelated | Deprecated. Removes the relationship between two records as defined by the target classes listed below. For example, remove the relationship between an invoice and a contact. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveSolutionComponent | Removes a solution component to an unmanaged solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveSubstituteProduct | Deprecated. Removes the association between a product and a substitute product. Use Disassociate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RenewContract | Renews a contract. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReplacePrivilegesRole | Replaces the privilege set of an existing role. This effectively deletes all existing privileges from the role and adds the new specified privileges. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Reschedule | Reschedules an appointment, service appointment or recurring appointment. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ResetUserFilters | Resets the offline data filters for the calling user to the default filters for the organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAbsoluteAndSiteCollectionUrl | Retrieves the absolute (complete) URL and the site collection URL of a SharePoint document location or SharePoint site. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAllChildUsersSystemUser | Retrieves a collection of system users who report to the specified system user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAllEntities | Retrieves the metadata for all entities. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveApplicationRibbon | Retrieves the core application ribbons including the entity template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAttribute | Retrieves the metadata for the specified attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAttributeChangeHistory | Retrieves all changes to a specific attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAuditDetails | Retrieves the full audit details of a particular audit record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAuditPartitionList | Retrieves the list of auditing partitions. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAvailableLanguages | Retrieves the list of available languages. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveBusinessHierarchyBusinessUnit | Retrieves all the business units in the business unit hierarchy. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByGroupResource | Retrieves all the resource groups to which the specified resource belongs. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByResourceResourceGroup | Retrieves the resource groups that contain the specified resource. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByResourcesService | Retrieves a collection of services related to the specified set of services. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByTopIncidentProductKbArticle | Retrieves the top ten knowledge base articles for the product specified. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByTopIncidentSubjectKbArticle | Retrieves the top ten knowledge base articles for the subject specified. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDependenciesForDelete | Retrieves the dependencies for solution components that will prevent a solution component from being deleted. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDependenciesForUninstall | Retrieves the dependencies for solution components that could prevent uninstalling a managed solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDependentComponents | Retrieves all components that depend on the specified component. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDeploymentLicenseType | Retrieves the type of license for a deployment of Microsoft Dynamics CRM. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDeprovisionedLanguages | Retrieves the list of language packs installed on the server that have been disabled. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDuplicates | Detects and retrieves duplicate records for the specified record, provided duplicate detection is enabled and there are published duplicate detection rules for the entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveEntity | Retrieves the metadata for the specified entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveEntity | Overloaded. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | RetrieveEntityRibbon | Retrieves the ribbon definition used for a specific entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveExchangeRate | Retrieves the exchange rate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveFilteredForms | Retrieves the system forms for the specified user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveFormattedImportJobResults | Retrieves the formatted results from an import job. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveFormXml | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveInstalledLanguagePacks | Retrieves the list of language packs installed on the server. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveInstalledLanguagePackVersion | Retrieves the version of an installed language pack. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveLicenseInfo | Retrieves the number of licenses for a deployment of Microsoft Dynamics CRM. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveLocLabels | Retrieves the localized labels for the specified attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMembersBulkOperation | Retrieves the members of a bulk operation. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMembersTeam | Deprecated. Retrieves the members of a team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMissingComponents | Retrieves a list of missing components for the target organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMissingDependencies | Verifies whether any solution components are not included in the solution but possibly should be for a complete solution to be exported. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMultiple | Overloaded. Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMultiple | Overloaded. Extensions to the core RetrieveMultiple method. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | RetrieveOrganizationResources | Retrieves the resources used by an organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveParentGroupsResourceGroup | Retrieves a collection of the parent resource groups of the specified resource group (scheduling group). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveParsedDataImportFile | Retrieves the data from the parse table. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrievePrincipalAccess | Retrieves the access rights the specified security principal (user or team) has to a record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrievePrincipalAttributePrivileges | Retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrievePrivilegeSet | Retrieves the set of privileges defined in the system. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveProvisionedLanguagePackVersion | Retrieves the version of the language packs installed on the server. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveProvisionedLanguages | Retrieves the list of language packs installed on the server that are enabled. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveRecordChangeHistory | Retrieves all changes to a specific entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveRequiredComponents | Retrieves all components that this component requires. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveRolePrivilegesRole | Retrieves the privileges that are assigned to the specified role. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveSharedPrincipalsAndAccess | Retrieves all the security principals (users or teams) that have access to a record, together with their access rights to the record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveSubGroupsResourceGroup | Retrieves a collection of the child resource groups of the specified resource group (scheduling group). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveSubsidiaryTeamsBusinessUnit | Deprecated. Retrieves all the team information for child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveSubsidiaryUsersBusinessUnit | Deprecated. Retrieves all system users for the child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveTeamPrivileges | Retrieves the privileges for a team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveTeamsSystemUser | Deprecated. Retrieves a collection of teams of which the specified system user is a member. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveUnpublished | Retrieves the current saved definition of a Web resource, organization-owned chart, or organization-owned dashboard, whether it has been published or not. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveUnpublishedMultiple | Retrieves the current saved definitions of Web resources, organization-owned charts, or organization-owned dashboards, whether they have been published or not. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveUserPrivileges | Retrieves all the privileges a system user (user) has through his or her roles in the specified business unit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveUserSettingsSystemUser | Deprecated. Retrieves the system user settings for the specified system user. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveVersion | Retrieves the version number of the Microsoft Dynamics CRM server. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReviseQuote | Sets the state of a quote to Draft. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RevokeAccess | Removes all access to a record for the specified security principal (user or team). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Rollup | Retrieves all the records related to the specified record (account or contact). This applies to all activity entities, annotation (note), contract, incident (case), invoice, opportunity, quote and sales order (order) entities. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Search | Searches for available time slots that fulfill the specified appointment request. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SearchByBodyKbArticle | Finds all the document indexes that contain the specified text in the body. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SearchByKeywordsKbArticle | Finds all the document indexes that contain the specified keywords. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SearchByTitleKbArticle | Finds all the document indexes that contain the specified text in the title. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendBulkMail | Sends bulk email messages. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendEmail | Sends an email message. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendEmailFromTemplate | Sends an email message using a template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendFax | Sends a fax. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendTemplate | Sends a bulk email message that is created from a template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
public extension method | SetBusinessEquipment | Sets the business that owns the equipment. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetBusinessSystemUser | Sets the business unit for the specified system user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetLocLabels | Sets the localized labels for the specified attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetParentBusinessUnit | Sets the parent (manager) for the specified business unit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetParentSystemUser | Sets the parent (manager) for the specified system user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetParentTeam | Sets the parent (manager) for the specified team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetRelated | Deprecated. Creates a link between an opportunity and an account, contact, or competitor. Use Associate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetReportRelated | Specifies in which areas of Microsoft Dynamics CRM the report can be run and viewed. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetState | Overloaded. Sets the state of a record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | StatusUpdateBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | TransformImport | Submits an asynchronous job to transform the parsed data. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | TriggerServiceEndpointCheck | Validates the configuration of a Windows Azure platform AppFabric solution’s service endpoint. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | TryAccessCache | Tries to perform an action on the underlying IOrganizationServiceCache if applicable. (Defined by OrganizationServiceContextExtensions.)
public extension method | TryRemoveFromCache | Overloaded. Removes an entity from cache if it is applicable to the context. (Defined by OrganizationServiceContextExtensions.)
public extension method | UninstallSampleData | Uninstalls sample data for an organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UnlockInvoicePricing | Unlocks the price per unit for the products in the specified invoice. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UnlockSalesOrderPricing | Unlocks the price per unit for the products in the specified sales order (order). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UnpublishDuplicateRule | Unpublishes a duplicate rule. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UpdateUserSettingsSystemUser | Deprecated. Updates the user settings for a system user. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UtcTimeFromLocalTime | Retrieves the UTC time for the specified local time. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Validate | Validates that all the constraints of an appointment or service appointment are met. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ValidateRecurrenceRule | Validates a recurrence rule for a recurring appointment. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ValidateSavedQuery | Validates a saved query. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | VerifyProcessStateData | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | WhoAmI | Retrieves the user information for the logged on user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | WinOpportunity | Overloaded. Changes the state of an opportunity to Won. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | WinQuote | Changes the state of a quote to Won. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
Top

Explicit Interface Implementations

Name | Description
Execute | Executes a message in the form of a request, and returns a response. (Developer Extensions)
ApplyExpansions |
AddReferenceToCollection |
ClearChanges | Clears all tracking of entities by the OrganizationServiceContext.
CreateResource |
DeleteResource |
GetResource |
GetValue |
RemoveReferenceFromCollection |
ResetResource |
ResolveResource |
SaveChanges | Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.
SetReference |
SetValue |
Service | Gets the organization service interface. (Developer Extensions)
Top

See Also

Reference

CrmOrganizationServiceContext Class
Microsoft.Xrm.Client Namespace

Other Resources

Simplified Connection to Microsoft Dynamics CRM
Developer Extensions Context Object Model
Access Entity Relationships
Attach Entities to the Context
Developer Extensions for Microsoft Dynamics CRM


CrmOrganizationServiceContext Constructor
[image]

Initializes a new instance of the CrmOrganizationServiceContext class.Developer Extensions Context Object Model

Overload List

Name | Description
CrmOrganizationServiceContext () | Initializes a new instance of the CrmOrganizationServiceContext class.
CrmOrganizationServiceContext (CrmConnection) | Initializes a new instance of the CrmOrganizationServiceContext class.
CrmOrganizationServiceContext (IOrganizationService) | Initializes a new instance of the CrmOrganizationServiceContext class.
CrmOrganizationServiceContext (String) | Initializes a new instance of the CrmOrganizationServiceContext class.

See Also

Reference

CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions Context Object Model


CrmOrganizationServiceContext Constructor ()
[image]

Initializes a new instance of the CrmOrganizationServiceContext class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New CrmOrganizationServiceContext

Syntax

Visual Basic
Public Sub New
C#
public CrmOrganizationServiceContext ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext Constructor (CrmConnection)
[image]

Initializes a new instance of the CrmOrganizationServiceContext class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection

Dim instance As New CrmOrganizationServiceContext(connection)

Syntax

Visual Basic
Public Sub New ( _
    connection As CrmConnection _
)
C#
public CrmOrganizationServiceContext (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection object.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace


CrmOrganizationServiceContext Constructor (IOrganizationService)
[image]

Initializes a new instance of the CrmOrganizationServiceContext class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService

Dim instance As New CrmOrganizationServiceContext(service)

Syntax

Visual Basic
Public Sub New ( _
    service As IOrganizationService _
)
C#
public CrmOrganizationServiceContext (
    IOrganizationService service
)
C++

J#

JScript

Parameters
service
Type: IOrganizationService. The organization service interface instance.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace


CrmOrganizationServiceContext Constructor (String)
[image]

Initializes a new instance of the CrmOrganizationServiceContext class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim contextName As String

Dim instance As New CrmOrganizationServiceContext(contextName)

Syntax

Visual Basic
Public Sub New ( _
    contextName As String _
)
C#
public CrmOrganizationServiceContext (
    string contextName
)
C++

J#

JScript

Parameters
contextName
Type: String. The content name.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace


CrmOrganizationServiceContext Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddLink | (inherited from OrganizationServiceContext)
public method | AddObject | (inherited from OrganizationServiceContext)
public method | AddRelatedObject | (inherited from OrganizationServiceContext)
public method | Associate | Creates a link between records (entity instances). (Developer Extensions)
public method | Attach | (inherited from OrganizationServiceContext)
public method | AttachLink | (inherited from OrganizationServiceContext)
public method | ClearChanges | (inherited from OrganizationServiceContext)
public method | Create | Creates a record. (Developer Extensions)
public method | CreateQuery | (inherited from OrganizationServiceContext)
public method | CreateQuery | (inherited from OrganizationServiceContext)
public method | Delete | Deletes a record. (Developer Extensions)
public method | DeleteLink | (inherited from OrganizationServiceContext)
public method | DeleteObject | (inherited from OrganizationServiceContext)
public method | DeleteObject | (inherited from OrganizationServiceContext)
public method | Detach | (inherited from OrganizationServiceContext)
public method | Detach | (inherited from OrganizationServiceContext)
public method | DetachLink | (inherited from OrganizationServiceContext)
public method | Disassociate | Deletes a link between records. (Developer Extensions)
public method | Dispose | (inherited from OrganizationServiceContext)
public method | Equals | (inherited from Object)
public method | Execute | (inherited from OrganizationServiceContext)
public method | GetAttachedEntities | (inherited from OrganizationServiceContext)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | Initializes custom settings.
public method | IsAttached | (inherited from OrganizationServiceContext)
public method | IsAttached | (inherited from OrganizationServiceContext)
public method | IsDeleted | (inherited from OrganizationServiceContext)
public method | IsDeleted | (inherited from OrganizationServiceContext)
public method | LoadProperty | (inherited from OrganizationServiceContext)
public method | LoadProperty | (inherited from OrganizationServiceContext)
public method | Retrieve | Retrieves a record. (Developer Extensions)
public method | RetrieveMultiple | Retrieves a collection of records. (Developer Extensions)
public method | SaveChanges | (inherited from OrganizationServiceContext)
public method | SaveChanges | (inherited from OrganizationServiceContext)
public method | ToString | (inherited from Object)
public method | Update | Updates an existing record. (Developer Extensions)
public method | UpdateObject | (inherited from OrganizationServiceContext)
public method | UpdateObject | (inherited from OrganizationServiceContext)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateQuery | (inherited from OrganizationServiceContext)
protected method | Dispose | Overridden. Disposes the service context. (Developer Extensions)
protected method | Finalize | Overridden. (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnBeginEntityTracking | Overridden. Method called when entity tracking begins. (Developer Extensions)
protected method | OnBeginLinkTracking | (inherited from OrganizationServiceContext)
protected method | OnEndEntityTracking | Overridden. Method called when entity tracking ends. (Developer Extensions)
protected method | OnEndLinkTracking | (inherited from OrganizationServiceContext)
protected method | OnExecute | (inherited from OrganizationServiceContext)
protected method | OnExecute | (inherited from OrganizationServiceContext)
protected method | OnExecuting | (inherited from OrganizationServiceContext)
protected method | OnSaveChanges | Overridden. Method called after an attempt to save data changes. (Developer Extensions)
protected method | OnSavingChanges | (inherited from OrganizationServiceContext)

Extension Methods

 | Name | Description
public extension method | AddItemCampaign | Adds an item to a campaign. The item added must be one of the following entity types: campaign, list, product, or salesliterature. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddItemCampaignActivity | Adds an item to a campaign activity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddLink | Overloaded. Adds the specified link to the set of objects the OrganizationServiceContext is tracking. (Defined by OrganizationServiceContextExtensions.)
public extension method | AddListMembersList | Adds a list of members to a list. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddMemberList | Adds a member to a list. The member added must be one of the following entity types: account, contact, or lead. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddMembersTeam | Adds members to a team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddPrivilegesRole | Adds a set of existing privileges to an existing role. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddProductToKit | Adds a product to a kit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddRecurrence | Adds recurrence information to an existing appointment to make it a recurring appointment master. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddRelatedObject | Overloaded. (Defined by OrganizationServiceContextExtensions.)
public extension method | AddSolutionComponent | Adds a solution component to an unmanaged solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddSubstituteProduct | Deprecated. Establishes an association between a product and a substitute product. Use Associate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AddToQueue | Moves a record from a source queue to a destination queue. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Assign | Assigns the specified record to a new security principal (user). This changes the ownerid attribute of the instance. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AssociateEntities | Deprecated. Adds a link between two records in a many-to-many relationship. Use Associate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | AttachClone | Clones an arbitrary source entity and attaches it to the context. (Defined by OrganizationServiceContextExtensions.)
public extension method | AttachLink | Overloaded. Attaches a two entity instances. (Defined by OrganizationServiceContextExtensions.)
public extension method | AutoMapEntity | Creates the attribute mappings between two entities. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | BackgroundSendEmail | Sends an email asynchronously. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Book | Schedules or "books" an appointment. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | BulkDelete | Submits an asynchronous bulk delete job. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | BulkDetectDuplicates | Submits an asynchronous duplicates detection job. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | BulkOperationStatusClose | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CalculateActualValueOpportunity | Calculates the value of an opportunity that is in the "Won" state. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CalculateTotalTimeIncident | Calculates the total number of minutes spent on an incident (case). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CancelContract | Cancels a contract. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CancelSalesOrder | Cancels a sales order. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CheckIncomingEmail | Checks whether the incoming email message is relevant to the Microsoft Dynamics CRM system. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CheckPromoteEmail | Checks whether the incoming email message should be promoted to the Microsoft Dynamics CRM system. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CleanUpBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CloneContract | Copies an existing contract and its line items. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CloseIncident | Overloaded. Closes an incident (case). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CloseQuote | Closes a quote. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CompoundCreate | Deprecated. Creates a compound entity (salesorder, invoice, quote, or duplicaterule) and its related entity (salesorderdetail, invoicedetail, quotedetail, or duplicaterulecondition). Use Create. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CompoundUpdate | Deprecated. Updates a compound record (salesorder, invoice, quote or duplicaterule) and its related detail record (salesorderdetail, invoicedetail, quotedetail or duplicaterulecondition). Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CompoundUpdateDuplicateDetectionRule | Updates a duplicate rule (duplicate detection rule) and its related duplicate rule conditions. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ConvertKitToProduct | Converts a kit to a product. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ConvertProductToKit | Converts a product to a kit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ConvertQuoteToSalesOrder | Converts a quote to a sales order. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ConvertSalesOrderToInvoice | Converts a sales order to an invoice. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopyCampaign | Copies a campaign. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopyCampaignResponse | Copies the information from one campaign response to another, and optionally creates a campaign response template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopyDynamicListToStatic | Creates a static list from the specified dynamic list and adds the members that satisfy the dynamic list query criteria to the static list. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopyMembersList | Copies the members from the source list to the target list without creating duplicates. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CopySystemForm | Creates a new entity form that is based on an existing entity form. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CreateActivitiesList | Creates the activities for a list. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CreateException | Creates an exception for the recurring appointment instance. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CreateInstance | Creates future unexpanded instances of a recurring appointment master. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | CreateWorkflowFromTemplate | Creates a workflow from a workflow template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeleteAuditData | Deletes all partitions containing audit data created before a given end date. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeleteLink | Overloaded. (Defined by OrganizationServiceContextExtensions.)
public extension method | DeleteOpenInstances | Deletes instances of a recurring appointment master that have an Open state. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeliverIncomingEmail | Creates an email activity record from an incoming email message. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeliverPromoteEmail | Creates an email activity instance from the specified email message (Track in CRM). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DeprovisionLanguage | Deprovisions a language. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Detach | (Defined by OrganizationServiceContextExtensions.)
public extension method | DetachLink | Overloaded. Detaches a two entity instances. (Defined by OrganizationServiceContextExtensions.)
public extension method | DisassociateEntities | Deprecated. Removes a link between two records in a many to many relationship. Use Disassociate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DistributeCampaignActivity | Creates a bulk operation to distribute the activity, creating the appropriate activity for each member in the list for the specified campaign activity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | DownloadReportDefinition | Downloads a report definition. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Execute | (Defined by OrganizationServiceContextExtensions.)
public extension method | Execute | Extensions to the core Execute method. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | ExecuteByIdSavedQuery | Executes a saved query (view) that has the specified ID. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExecuteByIdUserQuery | Executes the user query (saved view) that has the specified ID. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExecuteFetch | Deprecated. Executes the specified Fetch XML query. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExecuteWorkflow | Executes a workflow. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExpandCalendar | Converts the calendar rules to an array of available time blocks for the specified period. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExportSolution | Exports a managed or unmanaged solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ExportTranslation | Exports all translations for a specific solution to a compressed file. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | FetchXmlToQueryExpression | Converts a query in Fetch XML to a QueryExpression. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | FetchXmlToQueryExpression | Extensions to the core FetchXmlToQueryExpressionRequest message. (Developer Extensions) (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | FindParentResourceGroup | Finds a parent resource group (scheduling group) for the specified resource groups (scheduling groups). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | FulfillSalesOrder | Fulfills a sales order (order). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GenerateInvoiceFromOpportunity | Generates an invoice from an opportunity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GenerateQuoteFromOpportunity | Generates a quote from an opportunity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GenerateSalesOrderFromOpportunity | Generates a sales order from an opportunity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetAllTimeZonesWithDisplayName | Retrieves all the time-zone definitions for the specified locale returning only the display name attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetDecryptionKey | Gets a decryption key. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetDistinctValuesImportFile | Returns distinct values for a column in the source file that contains list values. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetHeaderColumnsImportFile | Retrieves the source-file column headings, or system-generated column headings, if the source file does not contain column headings. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetInvoiceProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the specified invoice. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetQuantityDecimal | Gets the quantity decimal value for a product. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetQuoteProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the quote. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetReportHistoryLimit | Gets the history limit for a report. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetSalesOrderProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the sales order. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetTimeZoneCodeByLocalizedName | Retrieves the time-zone code for the specified localized time-zone name. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GetTrackingTokenEmail | Returns a tracking token that can be then passed in as a parameter to the SendEmail method. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | GrantAccess | Grants a security principal (user or team) access to the specified record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ImportRecordsImport | Imports XML mappings and creates an import data map. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ImportSolution | Imports a managed or unmanaged solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ImportTranslation | Imports all translations from a compressed file. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | InitializeFrom | Initializes a new record from an existing record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | InstallSampleData | Installs sample data for an organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | InstantiateFilters | Instantiates a filter. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | InstantiateTemplate | Creates an email message from a template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | IsAttached | Overloaded. Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext. (Defined by OrganizationServiceContextExtensions.)
public extension method | IsBackOfficeInstalled | Deprecated. Checks if Microsoft Great Plains is installed. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | IsComponentCustomizable | Determines whether a solution component is customizable. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | IsDeleted | Overloaded. Determines whether a relationship has been deleted. (Defined by OrganizationServiceContextExtensions.)
public extension method | IsValidStateTransition | Checks to see if the state transition is valid. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LoadProperty | Overloaded. Loads the related entity collection for the specified relationship. (Defined by OrganizationServiceContextExtensions.)
public extension method | LocalTimeFromUtcTime | Retrieves the local time for the specified Universal Time Coordinate (UTC) time. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LockInvoicePricing | Locks the total price of products and services specified in the invoice. When the invoice pricing is locked, changes to underlying price lists (price levels) do not affect the prices for an invoice. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LockSalesOrderPricing | Locks the total price of products and services specified in the sales order (order). When the sales order pricing is locked, changes to underlying price lists (price levels) do not affect the prices for a sales order (order). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LogFailureBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LogSuccessBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | LoseOpportunity | Overloaded. Sets the state of an opportunity to Lost. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MakeAvailableToOrganizationReport | Deprecated. Makes the report available to all users in the organization. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MakeAvailableToOrganizationTemplate | Deprecated. Makes the specified email template available to the entire organization. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MakeUnavailableToOrganizationReport | Deprecated. Makes the report unavailable to all users in the organization. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MakeUnavailableToOrganizationTemplate | Deprecated. Makes the specified email template no longer available to the entire organization. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Merge | Merges the information from two records of the same type. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | MergeClone | Clones an arbitrary source entity and attaches it to the context. (Defined by OrganizationServiceContextExtensions.)
public extension method | ModifyAccess | Replaces the access rights on the target record for the specified security principal (user or team). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ParseImport | Submits an asynchronous job that parses all import files associated with the specified data import (import). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ProcessInboundEmail | Processes marketing campaign email responses. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ProcessOneMemberBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | PropagateByExpression | Distributes an activity to a quick campaign. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ProvisionLanguage | Provisions a language. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | PublishAllXml | Publishes all customizations. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | PublishDuplicateRule | Submits an asynchronous job to publish a duplicate rule. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | PublishXml | Publishes the customizations for the specified entities. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QualifyLead | Qualifies a lead and creates an account, contact, or opportunity records that are linked to the originating lead. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QualifyMemberList | Qualifies the specified member list and either overrides the list members or removes them according to the specified option. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QueryExpressionToFetchXml | Converts a query represented as a QueryExpression class to the equivalent query represented as FetchXML. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QueryMultipleSchedules | Searches multiple resources for an available time slot matching the specified parameters. This is similar to the QuerySchedule method but it works for multiple resources at one time. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | QuerySchedule | Searches the specified resource for an available time slot matching the specified parameters. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReassignObjectsOwner | Reassigns all records that are owned by the security principal (user or team) to another security principal (user or team). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReassignObjectsSystemUser | Reassigns all records that are owned by the user to another security principal (user or team). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReAttach | Resets the EntityState of an entity before attaching it to the context. (Defined by OrganizationServiceContextExtensions.)
public extension method | Recalculate | Recalculates the rollup attribute values for all goals in the goal hierarchy that contain a specified goal. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveItemCampaign | Removes an item from a campaign. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveItemCampaignActivity | Removes an item from a campaign activity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveMemberList | Removes a member from a list. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveMembersTeam | Removes members from a team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveParent | Removes the parent for a record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemovePrivilegeRole | Removes a privilege from an existing role. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveProductFromKit | Removes a product from a kit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveRelated | Deprecated. Removes the relationship between two records as defined by the target classes listed below. For example, remove the relationship between an invoice and a contact. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveSolutionComponent | Removes a solution component to an unmanaged solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RemoveSubstituteProduct | Deprecated. Removes the association between a product and a substitute product. Use Disassociate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RenewContract | Renews a contract. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReplacePrivilegesRole | Replaces the privilege set of an existing role. This effectively deletes all existing privileges from the role and adds the new specified privileges. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Reschedule | Reschedules an appointment, service appointment or recurring appointment. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ResetUserFilters | Resets the offline data filters for the calling user to the default filters for the organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAbsoluteAndSiteCollectionUrl | Retrieves the absolute (complete) URL and the site collection URL of a SharePoint document location or SharePoint site. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAllChildUsersSystemUser | Retrieves a collection of system users who report to the specified system user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAllEntities | Retrieves the metadata for all entities. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveApplicationRibbon | Retrieves the core application ribbons including the entity template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAttribute | Retrieves the metadata for the specified attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAttributeChangeHistory | Retrieves all changes to a specific attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAuditDetails | Retrieves the full audit details of a particular audit record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAuditPartitionList | Retrieves the list of auditing partitions. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveAvailableLanguages | Retrieves the list of available languages. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveBusinessHierarchyBusinessUnit | Retrieves all the business units in the business unit hierarchy. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByGroupResource | Retrieves all the resource groups to which the specified resource belongs. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByResourceResourceGroup | Retrieves the resource groups that contain the specified resource. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByResourcesService | Retrieves a collection of services related to the specified set of services. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByTopIncidentProductKbArticle | Retrieves the top ten knowledge base articles for the product specified. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveByTopIncidentSubjectKbArticle | Retrieves the top ten knowledge base articles for the subject specified. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDependenciesForDelete | Retrieves the dependencies for solution components that will prevent a solution component from being deleted. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDependenciesForUninstall | Retrieves the dependencies for solution components that could prevent uninstalling a managed solution. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDependentComponents | Retrieves all components that depend on the specified component. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDeploymentLicenseType | Retrieves the type of license for a deployment of Microsoft Dynamics CRM. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDeprovisionedLanguages | Retrieves the list of language packs installed on the server that have been disabled. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveDuplicates | Detects and retrieves duplicate records for the specified record, provided duplicate detection is enabled and there are published duplicate detection rules for the entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveEntity | Retrieves the metadata for the specified entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveEntity | Overloaded. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | RetrieveEntityRibbon | Retrieves the ribbon definition used for a specific entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveExchangeRate | Retrieves the exchange rate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveFilteredForms | Retrieves the system forms for the specified user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveFormattedImportJobResults | Retrieves the formatted results from an import job. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveFormXml | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveInstalledLanguagePacks | Retrieves the list of language packs installed on the server. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveInstalledLanguagePackVersion | Retrieves the version of an installed language pack. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveLicenseInfo | Retrieves the number of licenses for a deployment of Microsoft Dynamics CRM. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveLocLabels | Retrieves the localized labels for the specified attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMembersBulkOperation | Retrieves the members of a bulk operation. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMembersTeam | Deprecated. Retrieves the members of a team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMissingComponents | Retrieves a list of missing components for the target organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMissingDependencies | Verifies whether any solution components are not included in the solution but possibly should be for a complete solution to be exported. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMultiple | Overloaded. Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveMultiple | Overloaded. Extensions to the core RetrieveMultiple method. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | RetrieveOrganizationResources | Retrieves the resources used by an organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveParentGroupsResourceGroup | Retrieves a collection of the parent resource groups of the specified resource group (scheduling group). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveParsedDataImportFile | Retrieves the data from the parse table. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrievePrincipalAccess | Retrieves the access rights the specified security principal (user or team) has to a record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrievePrincipalAttributePrivileges | Retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrievePrivilegeSet | Retrieves the set of privileges defined in the system. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveProvisionedLanguagePackVersion | Retrieves the version of the language packs installed on the server. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveProvisionedLanguages | Retrieves the list of language packs installed on the server that are enabled. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveRecordChangeHistory | Retrieves all changes to a specific entity. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveRequiredComponents | Retrieves all components that this component requires. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveRolePrivilegesRole | Retrieves the privileges that are assigned to the specified role. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveSharedPrincipalsAndAccess | Retrieves all the security principals (users or teams) that have access to a record, together with their access rights to the record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveSubGroupsResourceGroup | Retrieves a collection of the child resource groups of the specified resource group (scheduling group). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveSubsidiaryTeamsBusinessUnit | Deprecated. Retrieves all the team information for child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveSubsidiaryUsersBusinessUnit | Deprecated. Retrieves all system users for the child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveTeamPrivileges | Retrieves the privileges for a team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveTeamsSystemUser | Deprecated. Retrieves a collection of teams of which the specified system user is a member. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveUnpublished | Retrieves the current saved definition of a Web resource, organization-owned chart, or organization-owned dashboard, whether it has been published or not. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveUnpublishedMultiple | Retrieves the current saved definitions of Web resources, organization-owned charts, or organization-owned dashboards, whether they have been published or not. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveUserPrivileges | Retrieves all the privileges a system user (user) has through his or her roles in the specified business unit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveUserSettingsSystemUser | Deprecated. Retrieves the system user settings for the specified system user. Use RetrieveMultiple. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RetrieveVersion | Retrieves the version number of the Microsoft Dynamics CRM server. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ReviseQuote | Sets the state of a quote to Draft. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | RevokeAccess | Removes all access to a record for the specified security principal (user or team). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Rollup | Retrieves all the records related to the specified record (account or contact). This applies to all activity entities, annotation (note), contract, incident (case), invoice, opportunity, quote and sales order (order) entities. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Search | Searches for available time slots that fulfill the specified appointment request. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SearchByBodyKbArticle | Finds all the document indexes that contain the specified text in the body. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SearchByKeywordsKbArticle | Finds all the document indexes that contain the specified keywords. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SearchByTitleKbArticle | Finds all the document indexes that contain the specified text in the title. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendBulkMail | Sends bulk email messages. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendEmail | Sends an email message. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendEmailFromTemplate | Sends an email message using a template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendFax | Sends a fax. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SendTemplate | Sends a bulk email message that is created from a template. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
public extension method | SetBusinessEquipment | Sets the business that owns the equipment. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetBusinessSystemUser | Sets the business unit for the specified system user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetLocLabels | Sets the localized labels for the specified attribute. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetParentBusinessUnit | Sets the parent (manager) for the specified business unit. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetParentSystemUser | Sets the parent (manager) for the specified system user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetParentTeam | Sets the parent (manager) for the specified team. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetRelated | Deprecated. Creates a link between an opportunity and an account, contact, or competitor. Use Associate. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetReportRelated | Specifies in which areas of Microsoft Dynamics CRM the report can be run and viewed. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | SetState | Overloaded. Sets the state of a record. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | StatusUpdateBulkOperation | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | TransformImport | Submits an asynchronous job to transform the parsed data. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | TriggerServiceEndpointCheck | Validates the configuration of a Windows Azure platform AppFabric solution’s service endpoint. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | TryAccessCache | Tries to perform an action on the underlying IOrganizationServiceCache if applicable. (Defined by OrganizationServiceContextExtensions.)
public extension method | TryRemoveFromCache | Overloaded. Removes an entity from cache if it is applicable to the context. (Defined by OrganizationServiceContextExtensions.)
public extension method | UninstallSampleData | Uninstalls sample data for an organization. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UnlockInvoicePricing | Unlocks the price per unit for the products in the specified invoice. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UnlockSalesOrderPricing | Unlocks the price per unit for the products in the specified sales order (order). (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UnpublishDuplicateRule | Unpublishes a duplicate rule. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UpdateUserSettingsSystemUser | Deprecated. Updates the user settings for a system user. Use Update. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | UtcTimeFromLocalTime | Retrieves the UTC time for the specified local time. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | Validate | Validates that all the constraints of an appointment or service appointment are met. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ValidateRecurrenceRule | Validates a recurrence rule for a recurring appointment. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | ValidateSavedQuery | Validates a saved query. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | VerifyProcessStateData | For internal use only. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | WhoAmI | Retrieves the user information for the logged on user. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | WinOpportunity | Overloaded. Changes the state of an opportunity to Won. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)
public extension method | WinQuote | Changes the state of a quote to Won. (Developer Extensions) (Defined by OrganizationServiceContextExtensions.)

Explicit Interface Implementations

Name | Description
Execute | Executes a message in the form of a request, and returns a response. (Developer Extensions)
ApplyExpansions |
AddReferenceToCollection |
ClearChanges | Clears all tracking of entities by the OrganizationServiceContext.
CreateResource |
DeleteResource |
GetResource |
GetValue |
RemoveReferenceFromCollection |
ResetResource |
ResolveResource |
SaveChanges | Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.
SetReference |
SetValue |

See Also

Reference

CrmOrganizationServiceContext Class
Microsoft.Xrm.Client Namespace

Other Resources

Simplified Connection to Microsoft Dynamics CRM
Developer Extensions Context Object Model
Access Entity Relationships
Attach Entities to the Context
Developer Extensions for Microsoft Dynamics CRM


CrmOrganizationServiceContext.Associate Method
[image]

Creates a link between records (entity instances). (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim entityName As String
Dim entityId As Guid
Dim relationship As Relationship
Dim relatedEntities As EntityReferenceCollection

instance.Associate(entityName, entityId, relationship, relatedEntities)

Syntax

Visual Basic
Public Sub Associate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)
C#
public void Associate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
entityId
Type: Guid. The ID of the record to which the related records will be associated.
relationship
Type: Relationship. The relationship to be used to create the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be associated.
  Remarks
Extends the core implementation of the Associate method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.Create Method
[image]

Creates a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim entity As Entity
Dim returnValue As Guid

returnValue = instance.Create(entity)

Syntax

Visual Basic
Public Function Create ( _
    entity As Entity _
) As Guid
C#
public Guid Create (
    Entity entity
)
C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that contains the properties to set in the newly created record.
Return Value
Type: Guid
The ID of the new record.

  Remarks
Extends the core implementation of the IOrganizationService.Create method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.Delete Method
[image]

Deletes a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim entityName As String
Dim id As Guid

instance.Delete(entityName, id)

Syntax

Visual Basic
Public Sub Delete ( _
    entityName As String, _
    id As Guid _
)
C#
public void Delete (
    string entityName,
    Guid id
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
id
Type: Guid. The ID of the record to delete.
  Remarks
Extends the core implementation of the IOrganizationService.Delete method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.Disassociate Method
[image]

Deletes a link between records. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim entityName As String
Dim entityId As Guid
Dim relationship As Relationship
Dim relatedEntities As EntityReferenceCollection

instance.Disassociate(entityName, entityId, relationship, relatedEntities)

Syntax

Visual Basic
Public Sub Disassociate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)
C#
public void Disassociate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
entityId
Type: Guid. The ID of the record from which the related records will be disassociated.
relationship
Type: Relationship. The relationship to be used to remove the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be disassociated.
  Remarks
Extends the core implementation of the IOrganizationService.Disassociate method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.Dispose Method
[image]

Disposes the service context. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim disposing As Boolean

Me.Dispose(disposing)

Syntax

Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose (
    bool disposing
)
C++

J#

JScript

Parameters
disposing
Type: Boolean.
  Remarks
Extends the core implementation of the Dispose method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.Initialize Method
[image]

Initializes custom settings.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim name As String
Dim config As NameValueCollection

instance.Initialize(name, config)

Syntax

Visual Basic
Public Overridable Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
C#
public virtual void Initialize (
    string name,
    NameValueCollection config
)
C++

J#

JScript

Parameters
name
Type: String.
config
Type: NameValueCollection. The collection of configuration information.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.Execute Method
[image]

Executes a message in the form of a request, and returns a response. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim param0 As OrganizationRequest
Dim returnValue As OrganizationResponse

returnValue = CType(instance, IOrganizationService).Execute(param0)

Syntax

Visual Basic
Private Function Microsoft.Xrm.Sdk.IOrganizationService.Execute ( _
    param0 As OrganizationRequest _
) As OrganizationResponse Implements IOrganizationService.Execute
C#
OrganizationResponse IOrganizationService.Execute (
    OrganizationRequest param0
)
C++

J#

JScript

Parameters
param0
Type: OrganizationRequest. An instance of a request class that defines the action to be performed.
Return Value
Type: OrganizationResponse
The response to the request.

  Remarks
Extends the core implementation of the Execute method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.OnBeginEntityTracking Method
[image]

Method called when entity tracking begins. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity

Me.OnBeginEntityTracking(entity)

Syntax

Visual Basic
Protected Overrides Sub OnBeginEntityTracking ( _
    entity As Entity _
)
C#
protected override void OnBeginEntityTracking (
    Entity entity
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity.
  Remarks
Extends the core implementation of the OnBeginEntityTracking method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.OnEndEntityTracking Method
[image]

Method called when entity tracking ends. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity

Me.OnEndEntityTracking(entity)

Syntax

Visual Basic
Protected Overrides Sub OnEndEntityTracking ( _
    entity As Entity _
)
C#
protected override void OnEndEntityTracking (
    Entity entity
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity.
  Remarks
Extends the core implementation of the OnEndEntityTracking method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.OnSaveChanges Method
[image]

Method called after an attempt to save data changes. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim results As SaveChangesResultCollection

Me.OnSaveChanges(results)

Syntax

Visual Basic
Protected Overrides Sub OnSaveChanges ( _
    results As SaveChangesResultCollection _
)
C#
protected override void OnSaveChanges (
    SaveChangesResultCollection results
)
C++

J#

JScript

Parameters
results
Type: SaveChangesResultCollection. The result collection.
  Remarks
Extends the core implementation of the OnSaveChanges method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.Retrieve Method
[image]

Retrieves a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim entityName As String
Dim id As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = instance.Retrieve(entityName, id, columnSet)

Syntax

Visual Basic
Public Function Retrieve ( _
    entityName As String, _
    id As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
public Entity Retrieve (
    string entityName,
    Guid id,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
id
Type: Guid. The ID of the record you want to retrieve.
columnSet
Type: ColumnSet. A query that specifies the set of columns, or attributes, to retrieve.
Return Value
Type: Entity
The retrieved record.

  Remarks
Extends the core implementation of the IOrganizationService.Retrieve method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.RetrieveMultiple Method
[image]

Retrieves a collection of records. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = instance.RetrieveMultiple(query)

Syntax

Visual Basic
Public Function RetrieveMultiple ( _
    query As QueryBase _
) As EntityCollection
C#
public EntityCollection RetrieveMultiple (
    QueryBase query
)
C++

J#

JScript

Parameters
query
Type: QueryBase. A query that determines the set of records to retrieve.
Return Value
Type: EntityCollection
The set of records retrieved.

  Remarks
Extends the core implementation of the IOrganizationService.RetrieveMultiple method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext.ApplyExpansions Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim queryable As IQueryable
Dim expandPaths As ICollection(Of ExpandSegmentCollection)
Dim returnValue As IEnumerable

returnValue = CType(instance, IExpandProvider).ApplyExpansions(queryable, expandPaths)

Syntax

Visual Basic
Private Function System.Data.Services.IExpandProvider.ApplyExpansions ( _
    queryable As IQueryable, _
    expandPaths As ICollection(Of ExpandSegmentCollection) _
) As IEnumerable Implements IExpandProvider.ApplyExpansions
C#
IEnumerable IExpandProvider.ApplyExpansions (
    IQueryable queryable,
    ICollection<ExpandSegmentCollection> expandPaths
)
C++

J#

JScript

Parameters
queryable
Type: IQueryable.
expandPaths
Type: ICollection(Returns_ExpandSegmentCollection).
Return Value
Type: IEnumerable
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.AddReferenceToCollection Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim targetResource As Object
Dim propertyName As String
Dim resourceToBeAdded As Object

CType(instance, IUpdatable).AddReferenceToCollection(targetResource, propertyName, resourceToBeAdded)

Syntax

Visual Basic
Private Sub System.Data.Services.IUpdatable.AddReferenceToCollection ( _
    targetResource As Object, _
    propertyName As String, _
    resourceToBeAdded As Object _
) Implements IUpdatable.AddReferenceToCollection
C#
void IUpdatable.AddReferenceToCollection (
    Object targetResource,
    string propertyName,
    Object resourceToBeAdded
)
C++

J#

JScript

Parameters
targetResource
Type: Object.
propertyName
Type: String.
resourceToBeAdded
Type: Object.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.ClearChanges Method
[image]

Clears all tracking of entities by the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext

CType(instance, IUpdatable).ClearChanges

Syntax

Visual Basic
Private Sub System.Data.Services.IUpdatable.ClearChanges Implements IUpdatable.ClearChanges
C#
void IUpdatable.ClearChanges ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.CreateResource Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim containerName As String
Dim fullTypeName As String
Dim returnValue As Object

returnValue = CType(instance, IUpdatable).CreateResource(containerName, fullTypeName)

Syntax

Visual Basic
Private Function System.Data.Services.IUpdatable.CreateResource ( _
    containerName As String, _
    fullTypeName As String _
) As Object Implements IUpdatable.CreateResource
C#
Object IUpdatable.CreateResource (
    string containerName,
    string fullTypeName
)
C++

J#

JScript

Parameters
containerName
Type: String.
fullTypeName
Type: String.
Return Value
Type: Object
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.DeleteResource Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim targetResource As Object

CType(instance, IUpdatable).DeleteResource(targetResource)

Syntax

Visual Basic
Private Sub System.Data.Services.IUpdatable.DeleteResource ( _
    targetResource As Object _
) Implements IUpdatable.DeleteResource
C#
void IUpdatable.DeleteResource (
    Object targetResource
)
C++

J#

JScript

Parameters
targetResource
Type: Object.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.GetResource Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim query As IQueryable
Dim fullTypeName As String
Dim returnValue As Object

returnValue = CType(instance, IUpdatable).GetResource(query, fullTypeName)

Syntax

Visual Basic
Private Function System.Data.Services.IUpdatable.GetResource ( _
    query As IQueryable, _
    fullTypeName As String _
) As Object Implements IUpdatable.GetResource
C#
Object IUpdatable.GetResource (
    IQueryable query,
    string fullTypeName
)
C++

J#

JScript

Parameters
query
Type: IQueryable.
fullTypeName
Type: String.
Return Value
Type: Object
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.GetValue Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim targetResource As Object
Dim propertyName As String
Dim returnValue As Object

returnValue = CType(instance, IUpdatable).GetValue(targetResource, propertyName)

Syntax

Visual Basic
Private Function System.Data.Services.IUpdatable.GetValue ( _
    targetResource As Object, _
    propertyName As String _
) As Object Implements IUpdatable.GetValue
C#
Object IUpdatable.GetValue (
    Object targetResource,
    string propertyName
)
C++

J#

JScript

Parameters
targetResource
Type: Object.
propertyName
Type: String.
Return Value
Type: Object
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.RemoveReferenceFromCollection Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim targetResource As Object
Dim propertyName As String
Dim resourceToBeRemoved As Object

CType(instance, IUpdatable).RemoveReferenceFromCollection(targetResource, propertyName, resourceToBeRemoved)

Syntax

Visual Basic
Private Sub System.Data.Services.IUpdatable.RemoveReferenceFromCollection ( _
    targetResource As Object, _
    propertyName As String, _
    resourceToBeRemoved As Object _
) Implements IUpdatable.RemoveReferenceFromCollection
C#
void IUpdatable.RemoveReferenceFromCollection (
    Object targetResource,
    string propertyName,
    Object resourceToBeRemoved
)
C++

J#

JScript

Parameters
targetResource
Type: Object.
propertyName
Type: String.
resourceToBeRemoved
Type: Object.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.ResetResource Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim resource As Object
Dim returnValue As Object

returnValue = CType(instance, IUpdatable).ResetResource(resource)

Syntax

Visual Basic
Private Function System.Data.Services.IUpdatable.ResetResource ( _
    resource As Object _
) As Object Implements IUpdatable.ResetResource
C#
Object IUpdatable.ResetResource (
    Object resource
)
C++

J#

JScript

Parameters
resource
Type: Object.
Return Value
Type: Object
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.ResolveResource Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim resource As Object
Dim returnValue As Object

returnValue = CType(instance, IUpdatable).ResolveResource(resource)

Syntax

Visual Basic
Private Function System.Data.Services.IUpdatable.ResolveResource ( _
    resource As Object _
) As Object Implements IUpdatable.ResolveResource
C#
Object IUpdatable.ResolveResource (
    Object resource
)
C++

J#

JScript

Parameters
resource
Type: Object.
Return Value
Type: Object
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.SaveChanges Method
[image]

Saves the changes that the OrganizationServiceContext is tracking to Microsoft Dynamics CRM.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext

CType(instance, IUpdatable).SaveChanges

Syntax

Visual Basic
Private Sub System.Data.Services.IUpdatable.SaveChanges Implements IUpdatable.SaveChanges
C#
void IUpdatable.SaveChanges ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.SetReference Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim targetResource As Object
Dim propertyName As String
Dim propertyValue As Object

CType(instance, IUpdatable).SetReference(targetResource, propertyName, propertyValue)

Syntax

Visual Basic
Private Sub System.Data.Services.IUpdatable.SetReference ( _
    targetResource As Object, _
    propertyName As String, _
    propertyValue As Object _
) Implements IUpdatable.SetReference
C#
void IUpdatable.SetReference (
    Object targetResource,
    string propertyName,
    Object propertyValue
)
C++

J#

JScript

Parameters
targetResource
Type: Object.
propertyName
Type: String.
propertyValue
Type: Object.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.SetValue Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim targetResource As Object
Dim propertyName As String
Dim propertyValue As Object

CType(instance, IUpdatable).SetValue(targetResource, propertyName, propertyValue)

Syntax

Visual Basic
Private Sub System.Data.Services.IUpdatable.SetValue ( _
    targetResource As Object, _
    propertyName As String, _
    propertyValue As Object _
) Implements IUpdatable.SetValue
C#
void IUpdatable.SetValue (
    Object targetResource,
    string propertyName,
    Object propertyValue
)
C++

J#

JScript

Parameters
targetResource
Type: Object.
propertyName
Type: String.
propertyValue
Type: Object.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


CrmOrganizationServiceContext.Update Method
[image]

Updates an existing record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim entity As Entity

instance.Update(entity)

Syntax

Visual Basic
Public Sub Update ( _
    entity As Entity _
)
C#
public void Update (
    Entity entity
)
C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that has one or more properties set to be updated in the record.
  Remarks
Extends the core implementation of the IOrganizationService.Update method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CrmOrganizationServiceContext Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | MergeOption | (inherited from OrganizationServiceContext)
public property | SaveChangesDefaultOptions | (inherited from OrganizationServiceContext)

Protected Properties

 | Name | Description
protected property | QueryProvider | (inherited from OrganizationServiceContext)

Explicit Interface Implementations

Name | Description
Service | Gets the organization service interface. (Developer Extensions)

See Also

Reference

CrmOrganizationServiceContext Class
Microsoft.Xrm.Client Namespace

Other Resources

Simplified Connection to Microsoft Dynamics CRM
Developer Extensions Context Object Model
Access Entity Relationships
Attach Entities to the Context
Developer Extensions for Microsoft Dynamics CRM


CrmOrganizationServiceContext.Service Property
[image]

Gets the organization service interface. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmOrganizationServiceContext
Dim value As IOrganizationService

value = CType(instance, IOrganizationServiceContainer).Service

Syntax

Visual Basic
Private ReadOnly Property Microsoft.Xrm.Client.IOrganizationServiceContainer.Service As IOrganizationService Implements IOrganizationServiceContainer.Service
C#
IOrganizationService IOrganizationServiceContainer.Service { get; }
C++

J#

JScript

Property Value
Type: IOrganizationService
The organization service interface.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmOrganizationServiceContext Class
CrmOrganizationServiceContext Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions Context Object Model


DateTimeExtensions Class
See Also Members
[image]

Extensions to the date/time class. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class DateTimeExtensions
C#
[ExtensionAttribute]
public static class DateTimeExtensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.DateTimeExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DateTimeExtensions Members
See Also Methods
[image]

Extensions to the date/time class. (Developer Extensions)

The following tables list the members exposed by the DateTimeExtensions type.

Public Methods (see also Extension Methods)

Name | Description
Floor | Overloaded. Returns the largest discrete value less than or equal to the specified value.
Round | Overloaded. Rounds a value to the nearest discrete value.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DateTimeExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DateTimeExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
Floor | Overloaded. Returns the largest discrete value less than or equal to the specified value.
Round | Overloaded. Rounds a value to the nearest discrete value.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DateTimeExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DateTimeExtensions.Floor Method
[image]

Returns the largest discrete value less than or equal to the specified value.

Overload List

Name | Description
DateTimeExtensions.Floor (DateTime, RoundTo) | Returns the largest discrete value less than or equal to the specified value.
DateTimeExtensions.Floor (DateTimeOffset, RoundTo) | Returns the largest discrete value less than or equal to the specified value.

See Also

Reference

DateTimeExtensions Class
DateTimeExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DateTimeExtensions.Floor Method (DateTime, RoundTo)
[image]

Returns the largest discrete value less than or equal to the specified value.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim d As DateTime
Dim to As RoundTo
Dim returnValue As DateTime

returnValue = DateTimeExtensions.Floor(d, to)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Floor ( _
    d As DateTime, _
    to As RoundTo _
) As DateTime
C#
[ExtensionAttribute]
public static DateTime Floor (
    DateTime d,
    RoundTo to
)
C++

J#

JScript

Parameters
d
Type: DateTime. The date/time.
to
Type: RoundTo. The value to round to.
Return Value
Type: DateTime
The largest discrete value less than or equal to the specified value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeExtensions Class
DateTimeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DateTimeExtensions.Floor Method (DateTimeOffset, RoundTo)
[image]

Returns the largest discrete value less than or equal to the specified value.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim d As DateTimeOffset
Dim to As RoundTo
Dim returnValue As DateTimeOffset

returnValue = DateTimeExtensions.Floor(d, to)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Floor ( _
    d As DateTimeOffset, _
    to As RoundTo _
) As DateTimeOffset
C#
[ExtensionAttribute]
public static DateTimeOffset Floor (
    DateTimeOffset d,
    RoundTo to
)
C++

J#

JScript

Parameters
d
Type: DateTime. The date/time offset.
to
Type: RoundTo. The value to round to.
Return Value
Type: DateTimeOffset
The largest discrete value less than or equal to the specified value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeExtensions Class
DateTimeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DateTimeExtensions.Round Method
[image]

Rounds a value to the nearest discrete value.

Overload List

Name | Description
DateTimeExtensions.Round (DateTime, RoundTo) | Rounds a value to the nearest discrete value.
DateTimeExtensions.Round (DateTimeOffset, RoundTo) | Rounds a value to the nearest discrete value.

See Also

Reference

DateTimeExtensions Class
DateTimeExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DateTimeExtensions.Round Method (DateTime, RoundTo)
[image]

Rounds a value to the nearest discrete value.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim d As DateTime
Dim to As RoundTo
Dim returnValue As DateTime

returnValue = DateTimeExtensions.Round(d, to)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Round ( _
    d As DateTime, _
    to As RoundTo _
) As DateTime
C#
[ExtensionAttribute]
public static DateTime Round (
    DateTime d,
    RoundTo to
)
C++

J#

JScript

Parameters
d
Type: DateTime. The date/time value.
to
Type: RoundTo. The value to round to.
Return Value
Type: DateTime
The nearest discrete value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeExtensions Class
DateTimeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DateTimeExtensions.Round Method (DateTimeOffset, RoundTo)
[image]

Rounds a value to the nearest discrete value.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim d As DateTimeOffset
Dim to As RoundTo
Dim returnValue As DateTimeOffset

returnValue = DateTimeExtensions.Round(d, to)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Round ( _
    d As DateTimeOffset, _
    to As RoundTo _
) As DateTimeOffset
C#
[ExtensionAttribute]
public static DateTimeOffset Round (
    DateTimeOffset d,
    RoundTo to
)
C++

J#

JScript

Parameters
d
Type: DateTimeOffset. The date/time value.
to
Type: RoundTo. The value to round to.
Return Value
Type: DateTimeOffset
The nearest discrete value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DateTimeExtensions Class
DateTimeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions Class
See Also Members
[image]

Extensions to the core Entity class. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class EntityExtensions
C#
[ExtensionAttribute]
public static class EntityExtensions
C++

J#

JScript

  Remarks
Extensions to the core Entity class.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.EntityExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions Members
See Also Methods
[image]

Extensions to the core Entity class. (Developer Extensions)

The following tables list the members exposed by the EntityExtensions type.

Public Methods (see also Extension Methods)

Name | Description
AssertEntityName | Verifies that the logical name of an entity is the expected name.
Clone | Overloaded. Deep clones an instance of the Entity class.
GetAttributeCollectionValue | Gets the attribute collection for a specific attribute of an entity.
GetAttributeValue | Overloaded. Retrieves the value of an attribute.
GetEntityReferenceValue | Retrieves attribute values for EntityReference attributes.
GetFormattedAttributeValue | Retrieves a formatted attribute value.
GetRelatedEntities | Overloaded. Retrieves the collection of related entities for a specific relationship.
GetRelatedEntity | Overloaded. Retrieves the related entity for a specific relationship.
SetAttributeCollectionValue | Modifies the value of a sequence attribute.
SetAttributeValue | Overloaded. Modifies the value of an attribute.
SetRelatedEntities | Overloaded.
SetRelatedEntity | Overloaded.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

EntityExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
AssertEntityName | Verifies that the logical name of an entity is the expected name.
Clone | Overloaded. Deep clones an instance of the Entity class.
GetAttributeCollectionValue | Gets the attribute collection for a specific attribute of an entity.
GetAttributeValue | Overloaded. Retrieves the value of an attribute.
GetEntityReferenceValue | Retrieves attribute values for EntityReference attributes.
GetFormattedAttributeValue | Retrieves a formatted attribute value.
GetRelatedEntities | Overloaded. Retrieves the collection of related entities for a specific relationship.
GetRelatedEntity | Overloaded. Retrieves the related entity for a specific relationship.
SetAttributeCollectionValue | Modifies the value of a sequence attribute.
SetAttributeValue | Overloaded. Modifies the value of an attribute.
SetRelatedEntities | Overloaded.
SetRelatedEntity | Overloaded.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

EntityExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.AssertEntityName Method
[image]

Verifies that the logical name of an entity is the expected name.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim expectedEntityName As String()

EntityExtensions.AssertEntityName(entity, expectedEntityName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AssertEntityName ( _
    entity As Entity, _
    ParamArray expectedEntityName As String() _
)
C#
[ExtensionAttribute]
public static void AssertEntityName (
    Entity entity,
    params string[] expectedEntityName
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
expectedEntityName
Type: String[]. The expected entity name.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.Clone Method
[image]

Deep clones an instance of the Entity class.Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
EntityExtensions.Clone (Entity, Boolean) | Deep clones an instance of the Entity class.
EntityExtensions.Clone (EntityCollection, Boolean) | Deep clones an instance of the Entity class.

See Also

Reference

EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.Clone Method (Entity, Boolean)
[image]

Deep clones an instance of the Entity class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim includeRelatedEntities As Boolean
Dim returnValue As Entity

returnValue = EntityExtensions.Clone(entity, includeRelatedEntities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Clone ( _
    entity As Entity, _
    <OptionalAttribute> Optional includeRelatedEntities As Boolean = True _
) As Entity
C#
[ExtensionAttribute]
public static Entity Clone (
    Entity entity,
    [OptionalAttribute] bool includeRelatedEntities
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
includeRelatedEntities
Type: Boolean. true if related entities should be included in the cloned entity; otherwise, false.
Return Value
Type: Entity
The cloned entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.Clone Method (EntityCollection, Boolean)
[image]

Deep clones an instance of the Entity class.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entities As EntityCollection
Dim includeRelatedEntities As Boolean
Dim returnValue As EntityCollection

returnValue = EntityExtensions.Clone(entities, includeRelatedEntities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Clone ( _
    entities As EntityCollection, _
    <OptionalAttribute> Optional includeRelatedEntities As Boolean = True _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection Clone (
    EntityCollection entities,
    [OptionalAttribute] bool includeRelatedEntities
)
C++

J#

JScript

Parameters
entities
Type: EntityCollection. The collection of entities.
includeRelatedEntities
Type: Boolean. true if related entities should be included in the cloned entity; otherwise, false.
Return Value
Type: EntityCollection
The cloned entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetAttributeCollectionValue Method
[image]

Gets the attribute collection for a specific attribute of an entity.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim returnValue As IEnumerable(Of T)

returnValue = EntityExtensions.GetAttributeCollectionValue(entity, attributeLogicalName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetAttributeCollectionValue(Of T As Entity) ( _
    entity As Entity, _
    attributeLogicalName As String _
) As IEnumerable(Of T)
C#
[ExtensionAttribute]
public static IEnumerable<T> GetAttributeCollectionValue<T> (
    Entity entity,
    string attributeLogicalName
) where T : Entity
C++

J#

JScript

GenericParameters
T
The type, where T is an Entity.
Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String.
Return Value
Type: IEnumerable<T>
The attribute collection for a specific attribute of an entity, where T is an Entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.GetAttributeValue Method
[image]

Retrieves the value of an attribute.Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
EntityExtensions.GetAttributeValue (Entity, String) | Retrieves the value of the attribute.
EntityExtensions.GetAttributeValue (Entity, String) | Retrieves the value of an attribute.

See Also

Reference

EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.GetAttributeValue Method (Entity, String)
[image]

Retrieves the value of the attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim returnValue As Object

returnValue = EntityExtensions.GetAttributeValue(entity, attributeLogicalName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetAttributeValue ( _
    entity As Entity, _
    attributeLogicalName As String _
) As Object
C#
[ExtensionAttribute]
public static Object GetAttributeValue (
    Entity entity,
    string attributeLogicalName
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String. The logical name of the attribute.
Return Value
Type: Object
 The value of the attribute.

  Remarks
Extends the core GetAttributeValue method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.GetAttributeValue Method (Entity, String)
[image]

Retrieves the value of an attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim returnValue As T

returnValue = EntityExtensions.GetAttributeValue(entity, attributeLogicalName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetAttributeValue(Of T) ( _
    entity As Entity, _
    attributeLogicalName As String _
) As T
C#
[ExtensionAttribute]
public static T GetAttributeValue<T> (
    Entity entity,
    string attributeLogicalName
)
C++

J#

JScript

GenericParameters
T
The type, where T is an Entity.
Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String. The logical name of the attribute.
Return Value
Type: Object
The value of the attribute.

  Remarks
Extends the core GetAttributeValue method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetEntityReferenceValue Method
[image]

Retrieves attribute values for EntityReference attributes.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim returnValue As T

returnValue = EntityExtensions.GetEntityReferenceValue(entity, attributeLogicalName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetEntityReferenceValue(Of T) ( _
    entity As Entity, _
    attributeLogicalName As String _
) As T
C#
[ExtensionAttribute]
public static T GetEntityReferenceValue<T> (
    Entity entity,
    string attributeLogicalName
)
C++

J#

JScript

GenericParameters
T
The type, where T is an Entity.
Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String. The logical name of the attribute.
Return Value
Type: T
The entity that contains the attribute values.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
EntityReference
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.GetFormattedAttributeValue Method
[image]

Retrieves a formatted attribute value.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim returnValue As String

returnValue = EntityExtensions.GetFormattedAttributeValue(entity, attributeLogicalName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetFormattedAttributeValue ( _
    entity As Entity, _
    attributeLogicalName As String _
) As String
C#
[ExtensionAttribute]
public static string GetFormattedAttributeValue (
    Entity entity,
    string attributeLogicalName
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String. The logical name of the attribute.
Return Value
Type: String
The formatted attribute value.

  Remarks
Extends the core GetFormattedAttributeValue method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.GetRelatedEntities Method
[image]

Retrieves the collection of related entities for a specific relationship.Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
EntityExtensions.GetRelatedEntities (Entity, OrganizationServiceContext, Relationship) | Retrieves the collection of related entities for a specific relationship.
EntityExtensions.GetRelatedEntities (Entity, OrganizationServiceContext, String, Nullable) | Retrieves the collection of related entities for a specific relationship.
EntityExtensions.GetRelatedEntities (Entity, Relationship) | Retrieves the collection of related entities for a specific relationship.
EntityExtensions.GetRelatedEntities (Entity, String, Nullable) | Retrieves the collection of related entities for a specific relationship.
EntityExtensions.GetRelatedEntities (TEntity, OrganizationServiceContext, Expression) | Retrieves the collection of related entities for a specific relationship.
EntityExtensions.GetRelatedEntities (Entity, Expression) | Retrieves the collection of related entities for a specific relationship.

See Also

Reference

EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.GetRelatedEntities Method (Entity, OrganizationServiceContext, Relationship)
[image]

Retrieves the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim context As OrganizationServiceContext
Dim relationship As Relationship
Dim returnValue As IEnumerable(Of Entity)

returnValue = EntityExtensions.GetRelatedEntities(entity, context, relationship)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntities ( _
    entity As Entity, _
    context As OrganizationServiceContext, _
    relationship As Relationship _
) As IEnumerable(Of Entity)
C#
[ExtensionAttribute]
public static IEnumerable<Entity> GetRelatedEntities (
    Entity entity,
    OrganizationServiceContext context,
    Relationship relationship
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
context
Type: OrganizationServiceContext. The service context.
relationship
Type: Relationship. The relationship instance.
Return Value
Type: IEnumerable<Entity>
The collection of related entities for the relationship.

  Remarks
Extends the core GetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.GetRelatedEntities Method (Entity, OrganizationServiceContext, String, Nullable)
[image]

Retrieves the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim context As OrganizationServiceContext
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim returnValue As IEnumerable(Of Entity)

returnValue = EntityExtensions.GetRelatedEntities(entity, context, relationshipSchemaName, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntities ( _
    entity As Entity, _
    context As OrganizationServiceContext, _
    relationshipSchemaName As String, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
) As IEnumerable(Of Entity)
C#
[ExtensionAttribute]
public static IEnumerable<Entity> GetRelatedEntities (
    Entity entity,
    OrganizationServiceContext context,
    string relationshipSchemaName,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
context
Type: OrganizationServiceContext. The service context.
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
Return Value
Type: IEnumerable<Entity>
The collection of related entities for the relationship.

  Remarks
Extends the core GetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetRelatedEntities Method (Entity, Relationship)
[image]

Retrieves the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationship As Relationship
Dim returnValue As IEnumerable(Of TEntity)

returnValue = EntityExtensions.GetRelatedEntities(entity, relationship)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntities(Of TEntity As Entity) ( _
    entity As Entity, _
    relationship As Relationship _
) As IEnumerable(Of TEntity)
C#
[ExtensionAttribute]
public static IEnumerable<TEntity> GetRelatedEntities<TEntity> (
    Entity entity,
    Relationship relationship
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationship
Type: Relationship. The relationship instance.
Return Value
Type: IEnumerable<Entity>
The collection of related entities for the relationship.

  Remarks
Extends the core GetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetRelatedEntities Method (Entity, String, Nullable)
[image]

Retrieves the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim returnValue As IEnumerable(Of TEntity)

returnValue = EntityExtensions.GetRelatedEntities(entity, relationshipSchemaName, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntities(Of TEntity As Entity) ( _
    entity As Entity, _
    relationshipSchemaName As String, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
) As IEnumerable(Of TEntity)
C#
[ExtensionAttribute]
public static IEnumerable<TEntity> GetRelatedEntities<TEntity> (
    Entity entity,
    string relationshipSchemaName,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced
Return Value
Type: IEnumerable<Entity>
The collection of related entities for the relationship.

  Remarks
Extends the core GetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetRelatedEntities Method (TEntity, OrganizationServiceContext, Expression)
[image]

Retrieves the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As TEntity
Dim context As OrganizationServiceContext
Dim relationshipSelector As Expression(Of Func(Of TEntity, IEnumerable(Of TResult)))
Dim returnValue As IEnumerable(Of TResult)

returnValue = EntityExtensions.GetRelatedEntities(entity, context, relationshipSelector)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntities(Of TEntity As Entity, TResult As Entity) ( _
    entity As TEntity, _
    context As OrganizationServiceContext, _
    relationshipSelector As Expression(Of Func(Of TEntity, IEnumerable(Of TResult))) _
) As IEnumerable(Of TResult)
C#
[ExtensionAttribute]
public static IEnumerable<TResult> GetRelatedEntities<TEntity,TResult> (
    TEntity entity,
    OrganizationServiceContext context,
    Expression<Func<TEntity,IEnumerable<TResult>>> relationshipSelector
) where TEntity : Entity where TResult : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
TResult
The result type, where TResult is an .
Parameters
entity
Type: Entity. The entity instance.
context
Type: OrganizationServiceContext. The service context.
relationshipSelector
The relationship selector.
Return Value
Type: IEnumerable<Entity>
The collection of related entities for the relationship.

  Remarks
Extends the core GetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetRelatedEntities Method (Entity, Expression)
[image]

Retrieves the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationshipSelector As Expression(Of Func(Of TEntity, IEnumerable(Of TResult)))
Dim returnValue As IEnumerable(Of TResult)

returnValue = EntityExtensions.GetRelatedEntities(entity, relationshipSelector)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntities(Of TEntity As Entity, TResult As Entity) ( _
    entity As Entity, _
    relationshipSelector As Expression(Of Func(Of TEntity, IEnumerable(Of TResult))) _
) As IEnumerable(Of TResult)
C#
[ExtensionAttribute]
public static IEnumerable<TResult> GetRelatedEntities<TEntity,TResult> (
    Entity entity,
    Expression<Func<TEntity,IEnumerable<TResult>>> relationshipSelector
) where TEntity : Entity where TResult : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
TResult
Parameters
entity
Type: Entity. The entity instance.
relationshipSelector
The relationship selector.
Return Value
Type: IEnumerable<Entity>
The collection of related entities for the relationship.

  Remarks
Extends the core GetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetRelatedEntity Method
[image]

Retrieves the related entity for a specific relationship.Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
EntityExtensions.GetRelatedEntity (Entity, OrganizationServiceContext, Relationship) | Retrieves the related entity for a specific relationship.
EntityExtensions.GetRelatedEntity (Entity, OrganizationServiceContext, String, Nullable) | Retrieves the related entity for a specific relationship.
EntityExtensions.GetRelatedEntity (Entity, Relationship) | Retrieves the related entity for a specific relationship.
EntityExtensions.GetRelatedEntity (Entity, String, Nullable) | Retrieves the related entity for a specific relationship.
EntityExtensions.GetRelatedEntity (TEntity, OrganizationServiceContext, Expression) | Retrieves the related entity for a specific relationship.
EntityExtensions.GetRelatedEntity (TEntity, Expression) | Retrieves the related entity for a specific relationship.

See Also

Reference

EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.GetRelatedEntity Method (Entity, OrganizationServiceContext, Relationship)
[image]

Retrieves the related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim context As OrganizationServiceContext
Dim relationship As Relationship
Dim returnValue As Entity

returnValue = EntityExtensions.GetRelatedEntity(entity, context, relationship)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntity ( _
    entity As Entity, _
    context As OrganizationServiceContext, _
    relationship As Relationship _
) As Entity
C#
[ExtensionAttribute]
public static Entity GetRelatedEntity (
    Entity entity,
    OrganizationServiceContext context,
    Relationship relationship
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
context
Type: OrganizationServiceContext. The service context.
relationship
Type: Relationship. The relationship instance.
Return Value
Type: Entity
The related entity for a specific relationship.

  Remarks
Extends the core GetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.GetRelatedEntity Method (Entity, OrganizationServiceContext, String, Nullable)
[image]

Retrieves the related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim context As OrganizationServiceContext
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim returnValue As Entity

returnValue = EntityExtensions.GetRelatedEntity(entity, context, relationshipSchemaName, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntity ( _
    entity As Entity, _
    context As OrganizationServiceContext, _
    relationshipSchemaName As String, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
) As Entity
C#
[ExtensionAttribute]
public static Entity GetRelatedEntity (
    Entity entity,
    OrganizationServiceContext context,
    string relationshipSchemaName,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
context
Type: OrganizationServiceContext. The service context.
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced
Return Value
Type: Entity
The related entity for a specific relationship.

  Remarks
Extends the core GetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetRelatedEntity Method (Entity, Relationship)
[image]

Retrieves the related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationship As Relationship
Dim returnValue As TEntity

returnValue = EntityExtensions.GetRelatedEntity(entity, relationship)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntity(Of TEntity As Entity) ( _
    entity As Entity, _
    relationship As Relationship _
) As TEntity
C#
[ExtensionAttribute]
public static TEntity GetRelatedEntity<TEntity> (
    Entity entity,
    Relationship relationship
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationship
Type: Relationship. The relationship instance.
Return Value
Type: Entity
The related entity for a specific relationship.

  Remarks
Extends the core GetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetRelatedEntity Method (Entity, String, Nullable)
[image]

Retrieves the related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim returnValue As TEntity

returnValue = EntityExtensions.GetRelatedEntity(entity, relationshipSchemaName, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntity(Of TEntity As Entity) ( _
    entity As Entity, _
    relationshipSchemaName As String, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
) As TEntity
C#
[ExtensionAttribute]
public static TEntity GetRelatedEntity<TEntity> (
    Entity entity,
    string relationshipSchemaName,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced
Return Value
Type: Entity
The related entity for a specific relationship.

  Remarks
Extends the core GetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetRelatedEntity Method (TEntity, OrganizationServiceContext, Expression)
[image]

Retrieves the related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As TEntity
Dim context As OrganizationServiceContext
Dim relationshipSelector As Expression(Of Func(Of TEntity, TResult))
Dim returnValue As TResult

returnValue = EntityExtensions.GetRelatedEntity(entity, context, relationshipSelector)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntity(Of TEntity As Entity, TResult As Entity) ( _
    entity As TEntity, _
    context As OrganizationServiceContext, _
    relationshipSelector As Expression(Of Func(Of TEntity, TResult)) _
) As TResult
C#
[ExtensionAttribute]
public static TResult GetRelatedEntity<TEntity,TResult> (
    TEntity entity,
    OrganizationServiceContext context,
    Expression<Func<TEntity,TResult>> relationshipSelector
) where TEntity : Entity where TResult : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
TResult
Parameters
entity
Type: Entity. The entity instance.
context
Type: OrganizationServiceContext. The service context.
relationshipSelector
The relationship selector.
Return Value
Type: Entity
The related entity for a specific relationship.

  Remarks
Extends the core GetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.GetRelatedEntity Method (TEntity, Expression)
[image]

Retrieves the related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As TEntity
Dim relationshipSelector As Expression(Of Func(Of TEntity, TResult))
Dim returnValue As TResult

returnValue = EntityExtensions.GetRelatedEntity(entity, relationshipSelector)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetRelatedEntity(Of TEntity As Entity, TResult As Entity) ( _
    entity As TEntity, _
    relationshipSelector As Expression(Of Func(Of TEntity, TResult)) _
) As TResult
C#
[ExtensionAttribute]
public static TResult GetRelatedEntity<TEntity,TResult> (
    TEntity entity,
    Expression<Func<TEntity,TResult>> relationshipSelector
) where TEntity : Entity where TResult : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
TResult
Parameters
entity
Type: Entity. The entity instance.
relationshipSelector
The relationship selector.
Return Value
Type: Entity
The related entity for a specific relationship.

  Remarks
Extends the core GetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetAttributeCollectionValue Method
[image]

Modifies the value of a sequence attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim value As IEnumerable(Of T)

EntityExtensions.SetAttributeCollectionValue(entity, attributeLogicalName, value)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetAttributeCollectionValue(Of T As Entity) ( _
    entity As Entity, _
    attributeLogicalName As String, _
    value As IEnumerable(Of T) _
)
C#
[ExtensionAttribute]
public static void SetAttributeCollectionValue<T> (
    Entity entity,
    string attributeLogicalName,
    IEnumerable<T> value
) where T : Entity
C++

J#

JScript

GenericParameters
T
The type, where T is an Entity.
Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String. The logical name of the attribute.
value
Type: IEnumerable<T>. The attribute value.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.SetAttributeValue Method
[image]

Modifies the value of an attribute.Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
EntityExtensions.SetAttributeValue (Entity, String, Object) | Modifies the value of an attribute.
EntityExtensions.SetAttributeValue (Entity, String, String, Object) | Modifies the value of an attribute.
EntityExtensions.SetAttributeValue (Entity, String, Object) | Modifies the value of an attribute.
EntityExtensions.SetAttributeValue (Entity, String, String, Object) | Modifies the value of an attribute.

See Also

Reference

EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.SetAttributeValue Method (Entity, String, Object)
[image]

Modifies the value of an attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim value As Object

EntityExtensions.SetAttributeValue(entity, attributeLogicalName, value)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetAttributeValue ( _
    entity As Entity, _
    attributeLogicalName As String, _
    value As Object _
)
C#
[ExtensionAttribute]
public static void SetAttributeValue (
    Entity entity,
    string attributeLogicalName,
    Object value
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String. The logical name of the attribute.
value
Type: Object. The attribute value.
  Remarks
Extends the core SetAttributeValue method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityExtensions.SetAttributeValue Method (Entity, String, String, Object)
[image]

Modifies the value of an attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim entityLogicalName As String
Dim value As Object

EntityExtensions.SetAttributeValue(entity, attributeLogicalName, entityLogicalName, value)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetAttributeValue ( _
    entity As Entity, _
    attributeLogicalName As String, _
    entityLogicalName As String, _
    value As Object _
)
C#
[ExtensionAttribute]
public static void SetAttributeValue (
    Entity entity,
    string attributeLogicalName,
    string entityLogicalName,
    Object value
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String. The logical name of the attribute.
entityLogicalName
Type: String. The logical name of the entity.
value
Type: Object. The attribute value.
  Remarks
Extends the core SetAttributeValue method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetAttributeValue Method (Entity, String, Object)
[image]

Modifies the value of an attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim value As Object

EntityExtensions.SetAttributeValue(entity, attributeLogicalName, value)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetAttributeValue(Of T) ( _
    entity As Entity, _
    attributeLogicalName As String, _
    value As Object _
)
C#
[ExtensionAttribute]
public static void SetAttributeValue<T> (
    Entity entity,
    string attributeLogicalName,
    Object value
)
C++

J#

JScript

GenericParameters
T
The type, where T is an Entity.
Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String. The logical name of the attribute.
value
Type: Object. The attribute value.
  Remarks
Extends the core SetAttributeValue method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetAttributeValue Method (Entity, String, String, Object)
[image]

Modifies the value of an attribute.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim attributeLogicalName As String
Dim entityLogicalName As String
Dim value As Object

EntityExtensions.SetAttributeValue(entity, attributeLogicalName, entityLogicalName, value)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetAttributeValue(Of T) ( _
    entity As Entity, _
    attributeLogicalName As String, _
    entityLogicalName As String, _
    value As Object _
)
C#
[ExtensionAttribute]
public static void SetAttributeValue<T> (
    Entity entity,
    string attributeLogicalName,
    string entityLogicalName,
    Object value
)
C++

J#

JScript

GenericParameters
T
The type, where T is an Entity.
Parameters
entity
Type: Entity. The entity instance.
attributeLogicalName
Type: String. The logical name of the attribute.
entityLogicalName
Type: String. The logical name of the entity.
value
Type: Object. The attribute value.
  Remarks
Extends the core SetAttributeValue method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntities Method
[image]

Overload List

Name | Description
EntityExtensions.SetRelatedEntities (Entity, Relationship, IEnumerable) | Modifies the collection of related entities for a specific relationship.
EntityExtensions.SetRelatedEntities (Entity, String, IEnumerable) | Modifies the collection of related entities for a specific relationship.
EntityExtensions.SetRelatedEntities (Entity, String, Nullable, IEnumerable) | Modifies the collection of related entities for a specific relationship.
EntityExtensions.SetRelatedEntities (TEntity, Expression, IEnumerable) | Modifies the collection of related entities for a specific relationship.

See Also

Reference

EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntities Method (Entity, Relationship, IEnumerable)
[image]

Modifies the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationship As Relationship
Dim entities As IEnumerable(Of TEntity)

EntityExtensions.SetRelatedEntities(entity, relationship, entities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetRelatedEntities(Of TEntity As Entity) ( _
    entity As Entity, _
    relationship As Relationship, _
    entities As IEnumerable(Of TEntity) _
)
C#
[ExtensionAttribute]
public static void SetRelatedEntities<TEntity> (
    Entity entity,
    Relationship relationship,
    IEnumerable<TEntity> entities
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationship
Type: Relationship. The relationship instance.
entities
Type: IEnumerable<TEntity>. The collection of entity instances to be related.
  Remarks
Extends the core SetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntities Method (Entity, String, IEnumerable)
[image]

Modifies the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationshipSchemaName As String
Dim entities As IEnumerable(Of TEntity)

EntityExtensions.SetRelatedEntities(entity, relationshipSchemaName, entities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetRelatedEntities(Of TEntity As Entity) ( _
    entity As Entity, _
    relationshipSchemaName As String, _
    entities As IEnumerable(Of TEntity) _
)
C#
[ExtensionAttribute]
public static void SetRelatedEntities<TEntity> (
    Entity entity,
    string relationshipSchemaName,
    IEnumerable<TEntity> entities
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
entities
Type: IEnumerable<TEntity>. The collection of entity instances to be related.
  Remarks
Extends the core SetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntities Method (Entity, String, Nullable, IEnumerable)
[image]

Modifies the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim entities As IEnumerable(Of TEntity)

EntityExtensions.SetRelatedEntities(entity, relationshipSchemaName, primaryEntityRole, entities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetRelatedEntities(Of TEntity As Entity) ( _
    entity As Entity, _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole), _
    entities As IEnumerable(Of TEntity) _
)
C#
[ExtensionAttribute]
public static void SetRelatedEntities<TEntity> (
    Entity entity,
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole,
    IEnumerable<TEntity> entities
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced
entities
Type: IEnumerable<TEntity>. The collection of entity instances to be related.
  Remarks
Extends the core SetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntities Method (TEntity, Expression, IEnumerable)
[image]

Modifies the collection of related entities for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As TEntity
Dim relationshipSelector As Expression(Of Func(Of TEntity, IEnumerable(Of TResult)))
Dim entities As IEnumerable(Of TResult)

EntityExtensions.SetRelatedEntities(entity, relationshipSelector, entities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetRelatedEntities(Of TEntity As Entity, TResult As Entity) ( _
    entity As TEntity, _
    relationshipSelector As Expression(Of Func(Of TEntity, IEnumerable(Of TResult))), _
    entities As IEnumerable(Of TResult) _
)
C#
[ExtensionAttribute]
public static void SetRelatedEntities<TEntity,TResult> (
    TEntity entity,
    Expression<Func<TEntity,IEnumerable<TResult>>> relationshipSelector,
    IEnumerable<TResult> entities
) where TEntity : Entity where TResult : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
TResult
Parameters
entity
Type: Entity. The entity instance.
relationshipSelector
entities
Type: IEnumerable<TEntity>. The collection of entity instances to be related.
  Remarks
Extends the core SetRelatedEntities method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntity Method
[image]

Overload List

Name | Description
EntityExtensions.SetRelatedEntity (Entity, Relationship, TEntity) | Modifies a related entity for a specific relationship.
EntityExtensions.SetRelatedEntity (Entity, String, TEntity) | Modifies a related entity for a specific relationship.
EntityExtensions.SetRelatedEntity (Entity, String, Nullable, TEntity) | Modifies a related entity for a specific relationship.
EntityExtensions.SetRelatedEntity (TEntity, Expression, TResult) | Modifies a related entity for a specific relationship.

See Also

Reference

EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntity Method (Entity, Relationship, TEntity)
[image]

Modifies a related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationship As Relationship
Dim value As TEntity

EntityExtensions.SetRelatedEntity(entity, relationship, value)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetRelatedEntity(Of TEntity As Entity) ( _
    entity As Entity, _
    relationship As Relationship, _
    value As TEntity _
)
C#
[ExtensionAttribute]
public static void SetRelatedEntity<TEntity> (
    Entity entity,
    Relationship relationship,
    TEntity value
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationship
Type: Relationship. The relationship instance.
value
Type: TEntity, where TEntity is an Entity. The entity instance to be related.
  Remarks
Extends the core SetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntity Method (Entity, String, TEntity)
[image]

Modifies a related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationshipSchemaName As String
Dim value As TEntity

EntityExtensions.SetRelatedEntity(entity, relationshipSchemaName, value)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetRelatedEntity(Of TEntity As Entity) ( _
    entity As Entity, _
    relationshipSchemaName As String, _
    value As TEntity _
)
C#
[ExtensionAttribute]
public static void SetRelatedEntity<TEntity> (
    Entity entity,
    string relationshipSchemaName,
    TEntity value
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
value
Type: TEntity, where TEntity is an Entity. The entity instance to be related.
  Remarks
Extends the core SetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntity Method (Entity, String, Nullable, TEntity)
[image]

Modifies a related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As Entity
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim value As TEntity

EntityExtensions.SetRelatedEntity(entity, relationshipSchemaName, primaryEntityRole, value)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetRelatedEntity(Of TEntity As Entity) ( _
    entity As Entity, _
    relationshipSchemaName As String, _
    primaryEntityRole As Nullable(Of EntityRole), _
    value As TEntity _
)
C#
[ExtensionAttribute]
public static void SetRelatedEntity<TEntity> (
    Entity entity,
    string relationshipSchemaName,
    Nullable<EntityRole> primaryEntityRole,
    TEntity value
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
Parameters
entity
Type: Entity. The entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced
value
Type: TEntity, where TEntity is an Entity. The entity instance to be related.
  Remarks
Extends the core SetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


EntityExtensions.SetRelatedEntity Method (TEntity, Expression, TResult)
[image]

Modifies a related entity for a specific relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entity As TEntity
Dim relationshipSelector As Expression(Of Func(Of TEntity, TResult))
Dim value As TResult

EntityExtensions.SetRelatedEntity(entity, relationshipSelector, value)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetRelatedEntity(Of TEntity As Entity, TResult As Entity) ( _
    entity As TEntity, _
    relationshipSelector As Expression(Of Func(Of TEntity, TResult)), _
    value As TResult _
)
C#
[ExtensionAttribute]
public static void SetRelatedEntity<TEntity,TResult> (
    TEntity entity,
    Expression<Func<TEntity,TResult>> relationshipSelector,
    TResult value
) where TEntity : Entity where TResult : Entity
C++

J#

JScript

GenericParameters
TEntity
The type, where TEntity is an Entity.
TResult
Parameters
entity
Type: Entity. The entity instance.
relationshipSelector
value
Type: TEntity, where TEntity is an Entity. The entity instance to be related.
  Remarks
Extends the core SetRelatedEntity method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityExtensions Class
EntityExtensions Members
Microsoft.Xrm.Client Namespace


IOrganizationServiceContainer Interface
See Also Members
[image]

Interface that returns the service. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceContainer

Syntax

Visual Basic
Public Interface IOrganizationServiceContainer
C#
public interface IOrganizationServiceContainer
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceContainer Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


IOrganizationServiceContainer Members
See Also Properties
[image]

Interface that returns the service. (Developer Extensions)

The following tables list the members exposed by the IOrganizationServiceContainer type.

Public Properties

 | Name | Description
public property | Service | Gets the organization service.
Top

See Also

Reference

IOrganizationServiceContainer Interface
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


IOrganizationServiceContainer Properties
[image]

Public Properties

 | Name | Description
public property | Service | Gets the organization service.

See Also

Reference

IOrganizationServiceContainer Interface
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


IOrganizationServiceContainer.Service Property
[image]

Gets the organization service.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceContainer
Dim value As IOrganizationService

value = instance.Service

Syntax

Visual Basic
ReadOnly Property Service As IOrganizationService
C#
IOrganizationService Service { get; }
C++

J#

JScript

Property Value
Type: IOrganizationService
The organization service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceContainer Interface
IOrganizationServiceContainer Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions Class
See Also Members
[image]

Extensions to the core OrganizationServiceContext class. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class OrganizationServiceContextExtensions
C#
[ExtensionAttribute]
public static class OrganizationServiceContextExtensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.OrganizationServiceContextExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
OrganizationServiceContext
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions Members
See Also Methods
[image]

Extensions to the core OrganizationServiceContext class. (Developer Extensions)

The following tables list the members exposed by the OrganizationServiceContextExtensions type.

Public Methods (see also Extension Methods)

Name | Description
AddLink | Overloaded. Adds the specified link to the set of objects the OrganizationServiceContext is tracking.
AddRelatedObject | Overloaded.
AttachClone | Clones an arbitrary source entity and attaches it to the context.
AttachLink | Overloaded. Attaches a two entity instances.
DeleteLink | Overloaded.
Detach |
DetachLink | Overloaded. Detaches a two entity instances.
Execute |
IsAttached | Overloaded. Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext.
IsDeleted | Overloaded. Determines whether a relationship has been deleted.
LoadProperty | Overloaded. Loads the related entity collection for the specified relationship.
MergeClone | Clones an arbitrary source entity and attaches it to the context.
ReAttach | Resets the EntityState of an entity before attaching it to the context.
TryAccessCache | Tries to perform an action on the underlying IOrganizationServiceCache if applicable.
TryRemoveFromCache | Overloaded. Removes an entity from cache if it is applicable to the context.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceContextExtensions Class
Microsoft.Xrm.Client Namespace
OrganizationServiceContext

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
AddLink | Overloaded. Adds the specified link to the set of objects the OrganizationServiceContext is tracking.
AddRelatedObject | Overloaded.
AttachClone | Clones an arbitrary source entity and attaches it to the context.
AttachLink | Overloaded. Attaches a two entity instances.
DeleteLink | Overloaded.
Detach |
DetachLink | Overloaded. Detaches a two entity instances.
Execute |
IsAttached | Overloaded. Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext.
IsDeleted | Overloaded. Determines whether a relationship has been deleted.
LoadProperty | Overloaded. Loads the related entity collection for the specified relationship.
MergeClone | Clones an arbitrary source entity and attaches it to the context.
ReAttach | Resets the EntityState of an entity before attaching it to the context.
TryAccessCache | Tries to perform an action on the underlying IOrganizationServiceCache if applicable.
TryRemoveFromCache | Overloaded. Removes an entity from cache if it is applicable to the context.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceContextExtensions Class
Microsoft.Xrm.Client Namespace
OrganizationServiceContext

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddLink Method
[image]

Adds the specified link to the set of objects the OrganizationServiceContext is tracking.

This is an extension to the core AddLink method.

Developer Extensions for Microsoft Dynamics CRM Access Entity Relationships

Overload List

Name | Description
OrganizationServiceContextExtensions.AddLink (OrganizationServiceContext, Entity, String, Entity, Nullable) | Adds a link between two entity instances.
OrganizationServiceContextExtensions.AddLink (OrganizationServiceContext, TSource, Expression, TTarget) | Adds a link between two entity instances.

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.AddLink Method (OrganizationServiceContext, Entity, String, Entity, Nullable)
[image]

Adds a link between two entity instances.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As Entity
Dim relationshipSchemaName As String
Dim target As Entity
Dim primaryEntityRole As Nullable(Of EntityRole)

OrganizationServiceContextExtensions.AddLink(context, source, relationshipSchemaName, target, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddLink ( _
    context As OrganizationServiceContext, _
    source As Entity, _
    relationshipSchemaName As String, _
    target As Entity, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
)
C#
[ExtensionAttribute]
public static void AddLink (
    OrganizationServiceContext context,
    Entity source,
    string relationshipSchemaName,
    Entity target,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: Entity. The source entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship for the link.
target
Type: Entity. The target entity instance.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
  Remarks
This is an extension to the core AddLink method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.AddLink Method (OrganizationServiceContext, TSource, Expression, TTarget)
[image]

Adds a link between two entity instances.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As TSource
Dim propertySelector As Expression(Of Func(Of TSource, TTarget))
Dim target As TTarget

OrganizationServiceContextExtensions.AddLink(context, source, propertySelector, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddLink(Of TSource As Entity, TTarget As Entity) ( _
    context As OrganizationServiceContext, _
    source As TSource, _
    propertySelector As Expression(Of Func(Of TSource, TTarget)), _
    target As TTarget _
)
C#
[ExtensionAttribute]
public static void AddLink<TSource,TTarget> (
    OrganizationServiceContext context,
    TSource source,
    Expression<Func<TSource,TTarget>> propertySelector,
    TTarget target
) where TSource : Entity where TTarget : Entity
C++

J#

JScript

GenericParameters
TSource
The source entity.
TTarget
The target entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: TSource. The source entity instance.
propertySelector
target
Type: TTarget. The target entity instance.
  Remarks
This is an extension to the core AddLink method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.AddRelatedObject Method
[image]

Developer Extensions for Microsoft Dynamics CRM Access Entity Relationships

Overload List

Name | Description
OrganizationServiceContextExtensions.AddRelatedObject (OrganizationServiceContext, Entity, String, Entity, Nullable) |
OrganizationServiceContextExtensions.AddRelatedObject (OrganizationServiceContext, TSource, Expression, TTarget) |
OrganizationServiceContextExtensions.AddRelatedObject (OrganizationServiceContext, TSource, Expression, TTarget) |

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.AddRelatedObject Method (OrganizationServiceContext, Entity, String, Entity, Nullable)
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As Entity
Dim relationshipSchemaName As String
Dim target As Entity
Dim primaryEntityRole As Nullable(Of EntityRole)

OrganizationServiceContextExtensions.AddRelatedObject(context, source, relationshipSchemaName, target, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddRelatedObject ( _
    context As OrganizationServiceContext, _
    source As Entity, _
    relationshipSchemaName As String, _
    target As Entity, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
)
C#
[ExtensionAttribute]
public static void AddRelatedObject (
    OrganizationServiceContext context,
    Entity source,
    string relationshipSchemaName,
    Entity target,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: Entity. The source entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
target
Type: Entity. The target entity instance.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
  Remarks
This is an extension to the core AddRelatedObject method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.AddRelatedObject Method (OrganizationServiceContext, TSource, Expression, TTarget)
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As TSource
Dim propertySelector As Expression(Of Func(Of TSource, TTarget))
Dim target As TTarget

OrganizationServiceContextExtensions.AddRelatedObject(context, source, propertySelector, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddRelatedObject(Of TSource As Entity, TTarget As Entity) ( _
    context As OrganizationServiceContext, _
    source As TSource, _
    propertySelector As Expression(Of Func(Of TSource, TTarget)), _
    target As TTarget _
)
C#
[ExtensionAttribute]
public static void AddRelatedObject<TSource,TTarget> (
    OrganizationServiceContext context,
    TSource source,
    Expression<Func<TSource,TTarget>> propertySelector,
    TTarget target
) where TSource : Entity where TTarget : Entity
C++

J#

JScript

GenericParameters
TSource
The source entity.
TTarget
The target entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: TSource. The source entity instance.
propertySelector
target
Type: TTarget. The target entity instance.
  Remarks
This is an extension to the core AddRelatedObject method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.AddRelatedObject Method (OrganizationServiceContext, TSource, Expression, TTarget)
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As TSource
Dim propertySelector As Expression(Of Func(Of TSource, IEnumerable(Of TTarget)))
Dim target As TTarget

OrganizationServiceContextExtensions.AddRelatedObject(context, source, propertySelector, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddRelatedObject(Of TSource As Entity, TTarget As Entity) ( _
    context As OrganizationServiceContext, _
    source As TSource, _
    propertySelector As Expression(Of Func(Of TSource, IEnumerable(Of TTarget))), _
    target As TTarget _
)
C#
[ExtensionAttribute]
public static void AddRelatedObject<TSource,TTarget> (
    OrganizationServiceContext context,
    TSource source,
    Expression<Func<TSource,IEnumerable<TTarget>>> propertySelector,
    TTarget target
) where TSource : Entity where TTarget : Entity
C++

J#

JScript

GenericParameters
TSource
The source entity.
TTarget
The target entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: TSource. The source entity instance.
propertySelector
target
Type: TTarget. The target entity instance.
  Remarks
This is an extension to the core AddRelatedObject method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.AttachClone Method
[image]

Clones an arbitrary source entity and attaches it to the context.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As T
Dim includeRelatedEntities As Boolean
Dim returnValue As T

returnValue = OrganizationServiceContextExtensions.AttachClone(context, entity, includeRelatedEntities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function AttachClone(Of T As Entity) ( _
    context As OrganizationServiceContext, _
    entity As T, _
    <OptionalAttribute> Optional includeRelatedEntities As Boolean = False _
) As T
C#
[ExtensionAttribute]
public static T AttachClone<T> (
    OrganizationServiceContext context,
    T entity,
    [OptionalAttribute] bool includeRelatedEntities
) where T : Entity
C++

J#

JScript

GenericParameters
T
Type: Entity. The entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
entity
Type: Entity. The entity instance.
includeRelatedEntities
Type: Boolean. Specifies whether to include related entity instances.
Return Value
Type: T where T is Entity
.The resulting entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Attach Entities to the Context


OrganizationServiceContextExtensions.AttachLink Method
[image]

Attaches a two entity instances.Developer Extensions for Microsoft Dynamics CRM Access Entity Relationships

Overload List

Name | Description
OrganizationServiceContextExtensions.AttachLink (OrganizationServiceContext, Entity, String, Entity, Nullable) | Attaches a two entity instances.
OrganizationServiceContextExtensions.AttachLink (OrganizationServiceContext, TSource, Expression, TTarget) | Attaches a two entity instances.

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.AttachLink Method (OrganizationServiceContext, Entity, String, Entity, Nullable)
[image]

Attaches a two entity instances.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As Entity
Dim relationshipSchemaName As String
Dim target As Entity
Dim primaryEntityRole As Nullable(Of EntityRole)

OrganizationServiceContextExtensions.AttachLink(context, source, relationshipSchemaName, target, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AttachLink ( _
    context As OrganizationServiceContext, _
    source As Entity, _
    relationshipSchemaName As String, _
    target As Entity, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
)
C#
[ExtensionAttribute]
public static void AttachLink (
    OrganizationServiceContext context,
    Entity source,
    string relationshipSchemaName,
    Entity target,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: Entity. The source entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
target
Type: Entity. The target entity instance.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
  Remarks
This is an extension to the core AttachLink method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.AttachLink Method (OrganizationServiceContext, TSource, Expression, TTarget)
[image]

Attaches a two entity instances.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As TSource
Dim propertySelector As Expression(Of Func(Of TSource, TTarget))
Dim target As TTarget

OrganizationServiceContextExtensions.AttachLink(context, source, propertySelector, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AttachLink(Of TSource As Entity, TTarget As Entity) ( _
    context As OrganizationServiceContext, _
    source As TSource, _
    propertySelector As Expression(Of Func(Of TSource, TTarget)), _
    target As TTarget _
)
C#
[ExtensionAttribute]
public static void AttachLink<TSource,TTarget> (
    OrganizationServiceContext context,
    TSource source,
    Expression<Func<TSource,TTarget>> propertySelector,
    TTarget target
) where TSource : Entity where TTarget : Entity
C++

J#

JScript

GenericParameters
TSource
The source entity.
TTarget
The target entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: TSource. The source entity instance.
propertySelector
target
Type: TTarget. The target entity instance.
  Remarks
This is an extension to the core AttachLink method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.DeleteLink Method
[image]

Developer Extensions for Microsoft Dynamics CRM Access Entity Relationships

Overload List

Name | Description
OrganizationServiceContextExtensions.DeleteLink (OrganizationServiceContext, Entity, String, Entity, Nullable) |
OrganizationServiceContextExtensions.DeleteLink (OrganizationServiceContext, TSource, Expression, TTarget) |

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.DeleteLink Method (OrganizationServiceContext, Entity, String, Entity, Nullable)
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As Entity
Dim relationshipSchemaName As String
Dim target As Entity
Dim primaryEntityRole As Nullable(Of EntityRole)

OrganizationServiceContextExtensions.DeleteLink(context, source, relationshipSchemaName, target, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub DeleteLink ( _
    context As OrganizationServiceContext, _
    source As Entity, _
    relationshipSchemaName As String, _
    target As Entity, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
)
C#
[ExtensionAttribute]
public static void DeleteLink (
    OrganizationServiceContext context,
    Entity source,
    string relationshipSchemaName,
    Entity target,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
source
T Type: Entity. he source entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
target
Type: Entity. The target entity instance.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
  Remarks
This is an extension to the core DeleteLink method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.DeleteLink Method (OrganizationServiceContext, TSource, Expression, TTarget)
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As TSource
Dim propertySelector As Expression(Of Func(Of TSource, TTarget))
Dim target As TTarget

OrganizationServiceContextExtensions.DeleteLink(context, source, propertySelector, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub DeleteLink(Of TSource As Entity, TTarget As Entity) ( _
    context As OrganizationServiceContext, _
    source As TSource, _
    propertySelector As Expression(Of Func(Of TSource, TTarget)), _
    target As TTarget _
)
C#
[ExtensionAttribute]
public static void DeleteLink<TSource,TTarget> (
    OrganizationServiceContext context,
    TSource source,
    Expression<Func<TSource,TTarget>> propertySelector,
    TTarget target
) where TSource : Entity where TTarget : Entity
C++

J#

JScript

GenericParameters
TSource
The source entity.
TTarget
The target entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: TSource. The source entity instance.
propertySelector
target
Type: TTarget. The target entity instance.
  Remarks
This is an extension to the core DeleteLink method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.Detach Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entities As IEnumerable(Of Entity)
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.Detach(context, entities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Detach ( _
    context As OrganizationServiceContext, _
    entities As IEnumerable(Of Entity) _
) As Boolean
C#
[ExtensionAttribute]
public static bool Detach (
    OrganizationServiceContext context,
    IEnumerable<Entity> entities
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
entities
Type: IEnumerable<Entity>. The collection of entity instances to detach.
Return Value
Type: Boolean
 .

  Remarks
This is an extension to the core Detach method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Attach Entities to the Context


OrganizationServiceContextExtensions.DetachLink Method
[image]

Detaches a two entity instances.

This is an extension to the core DetachLink method.

Developer Extensions for Microsoft Dynamics CRM Access Entity Relationships

Overload List

Name | Description
OrganizationServiceContextExtensions.DetachLink (OrganizationServiceContext, Entity, String, Entity, Nullable) | Detaches a two entity instances.
OrganizationServiceContextExtensions.DetachLink (OrganizationServiceContext, TSource, Expression, TTarget) | Detaches a two entity instances.

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.DetachLink Method (OrganizationServiceContext, Entity, String, Entity, Nullable)
[image]

Detaches a two entity instances.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As Entity
Dim relationshipSchemaName As String
Dim target As Entity
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.DetachLink(context, source, relationshipSchemaName, target, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function DetachLink ( _
    context As OrganizationServiceContext, _
    source As Entity, _
    relationshipSchemaName As String, _
    target As Entity, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
) As Boolean
C#
[ExtensionAttribute]
public static bool DetachLink (
    OrganizationServiceContext context,
    Entity source,
    string relationshipSchemaName,
    Entity target,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: Entity. The source entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
target
Type: Entity. The target entity instance.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
Return Value
Type: Boolean

.

  Remarks
This is an extension to the core DetachLink method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Access Entity Relationships


OrganizationServiceContextExtensions.DetachLink Method (OrganizationServiceContext, TSource, Expression, TTarget)
[image]

Detaches a two entity instances.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As TSource
Dim propertySelector As Expression(Of Func(Of TSource, TTarget))
Dim target As TTarget
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.DetachLink(context, source, propertySelector, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function DetachLink(Of TSource As Entity, TTarget As Entity) ( _
    context As OrganizationServiceContext, _
    source As TSource, _
    propertySelector As Expression(Of Func(Of TSource, TTarget)), _
    target As TTarget _
) As Boolean
C#
[ExtensionAttribute]
public static bool DetachLink<TSource,TTarget> (
    OrganizationServiceContext context,
    TSource source,
    Expression<Func<TSource,TTarget>> propertySelector,
    TTarget target
) where TSource : Entity where TTarget : Entity
C++

J#

JScript

GenericParameters
TSource
The source entity.
TTarget
The target entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: TSource. The source entity instance.
propertySelector
target
Type: TTarget. The target entity instance.
Return Value
Type: Boolean

.

  Remarks
This is an extension to the core DetachLink method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.Execute Method
[image]

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim request As OrganizationRequest
Dim returnValue As TResponse

returnValue = OrganizationServiceContextExtensions.Execute(context, request)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Execute(Of TResponse As OrganizationResponse) ( _
    context As OrganizationServiceContext, _
    request As OrganizationRequest _
) As TResponse
C#
[ExtensionAttribute]
public static TResponse Execute<TResponse> (
    OrganizationServiceContext context,
    OrganizationRequest request
) where TResponse : OrganizationResponse
C++

J#

JScript

GenericParameters
TResponse
The organization response.
Parameters
context
Type: OrganizationServiceContext. The service context.
request
Type: OrganizationRequest. The request instance to execute.
Return Value
Type: OrganizationResponse
.

  Remarks
This is an extension to the core Execute method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


OrganizationServiceContextExtensions.IsAttached Method
[image]

Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext.

This is an extension to the core IsAttached method.

Developer Extensions for Microsoft Dynamics CRM Attach Entities to the Context

Overload List

Name | Description
OrganizationServiceContextExtensions.IsAttached (OrganizationServiceContext, Entity, String, Entity, Nullable) | Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext.
OrganizationServiceContextExtensions.IsAttached (OrganizationServiceContext, TSource, Expression, TTarget) | Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext.
OrganizationServiceContextExtensions.IsAttached (OrganizationServiceContext, TSource, Expression, TTarget) | Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext.

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Attach Entities to the Context


OrganizationServiceContextExtensions.IsAttached Method (OrganizationServiceContext, Entity, String, Entity, Nullable)
[image]

Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As Entity
Dim relationshipSchemaName As String
Dim target As Entity
Dim primaryEntityRole As Nullable(Of EntityRole)

OrganizationServiceContextExtensions.IsAttached(context, source, relationshipSchemaName, target, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub IsAttached ( _
    context As OrganizationServiceContext, _
    source As Entity, _
    relationshipSchemaName As String, _
    target As Entity, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
)
C#
[ExtensionAttribute]
public static void IsAttached (
    OrganizationServiceContext context,
    Entity source,
    string relationshipSchemaName,
    Entity target,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: Entity. The source entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
target
Type: Entity. The target entity instance.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
  Remarks
This is an extension to the core IsAttached method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Attach Entities to the Context


OrganizationServiceContextExtensions.IsAttached Method (OrganizationServiceContext, TSource, Expression, TTarget)
[image]

Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As TSource
Dim propertySelector As Expression(Of Func(Of TSource, TTarget))
Dim target As TTarget
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.IsAttached(context, source, propertySelector, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function IsAttached(Of TSource As Entity, TTarget As Entity) ( _
    context As OrganizationServiceContext, _
    source As TSource, _
    propertySelector As Expression(Of Func(Of TSource, TTarget)), _
    target As TTarget _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsAttached<TSource,TTarget> (
    OrganizationServiceContext context,
    TSource source,
    Expression<Func<TSource,TTarget>> propertySelector,
    TTarget target
) where TSource : Entity where TTarget : Entity
C++

J#

JScript

GenericParameters
TSource
The source entity.
TTarget
The target entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: TSource. The source entity instance.
propertySelector
target
Type: TTarget. The target entity instance.
Return Value
Type: Boolean

.

  Remarks
This is an extension to the core IsAttached method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.IsAttached Method (OrganizationServiceContext, TSource, Expression, TTarget)
[image]

Determines whether a relationship is attached and therefore being tracked by the OrganizationServiceContext.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As TSource
Dim propertySelector As Expression(Of Func(Of TSource, IEnumerable(Of TTarget)))
Dim target As TTarget
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.IsAttached(context, source, propertySelector, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function IsAttached(Of TSource As Entity, TTarget As Entity) ( _
    context As OrganizationServiceContext, _
    source As TSource, _
    propertySelector As Expression(Of Func(Of TSource, IEnumerable(Of TTarget))), _
    target As TTarget _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsAttached<TSource,TTarget> (
    OrganizationServiceContext context,
    TSource source,
    Expression<Func<TSource,IEnumerable<TTarget>>> propertySelector,
    TTarget target
) where TSource : Entity where TTarget : Entity
C++

J#

JScript

GenericParameters
TSource
The source entity.
TTarget
The target entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: TSource. The source entity instance.
propertySelector
target
Type: TTarget. The target entity instance.
Return Value
Type: Boolean

.

  Remarks
This is an extension to the core IsAttached method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.IsDeleted Method
[image]

Determines whether a relationship has been deleted.

This is an extension to the core IsDeleted method.

Developer Extensions for Microsoft Dynamics CRM Developer Extensions Context Object Model

Overload List

Name | Description
OrganizationServiceContextExtensions.IsDeleted (OrganizationServiceContext, Entity, String, Entity, Nullable) | Determines whether a relationship has been deleted.
OrganizationServiceContextExtensions.IsDeleted (OrganizationServiceContext, TSource, Expression, TTarget) | Determines whether a relationship has been deleted.

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


OrganizationServiceContextExtensions.IsDeleted Method (OrganizationServiceContext, Entity, String, Entity, Nullable)
[image]

Determines whether a relationship has been deleted.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As Entity
Dim relationshipSchemaName As String
Dim target As Entity
Dim primaryEntityRole As Nullable(Of EntityRole)

OrganizationServiceContextExtensions.IsDeleted(context, source, relationshipSchemaName, target, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub IsDeleted ( _
    context As OrganizationServiceContext, _
    source As Entity, _
    relationshipSchemaName As String, _
    target As Entity, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
)
C#
[ExtensionAttribute]
public static void IsDeleted (
    OrganizationServiceContext context,
    Entity source,
    string relationshipSchemaName,
    Entity target,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: Entity. The source entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
target
Type: Entity. The target entity instance.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
  Remarks
This is an extension to the core IsDeleted method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


OrganizationServiceContextExtensions.IsDeleted Method (OrganizationServiceContext, TSource, Expression, TTarget)
[image]

Determines whether a relationship has been deleted.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim source As TSource
Dim propertySelector As Expression(Of Func(Of TSource, TTarget))
Dim target As TTarget
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.IsDeleted(context, source, propertySelector, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function IsDeleted(Of TSource As Entity, TTarget As Entity) ( _
    context As OrganizationServiceContext, _
    source As TSource, _
    propertySelector As Expression(Of Func(Of TSource, TTarget)), _
    target As TTarget _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsDeleted<TSource,TTarget> (
    OrganizationServiceContext context,
    TSource source,
    Expression<Func<TSource,TTarget>> propertySelector,
    TTarget target
) where TSource : Entity where TTarget : Entity
C++

J#

JScript

GenericParameters
TSource
The source entity.
TTarget
The target entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
source
Type: TSource. The source entity instance.
propertySelector
target
Type: TTarget. The target entity instance.
Return Value
Type: Boolean

.

  Remarks
This is an extension to the core IsDeleted method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.LoadProperty Method
[image]

Loads the related entity collection for the specified relationship.

This is an extension to the core LoadProperty method.

Developer Extensions for Microsoft Dynamics CRM Developer Extensions Context Object Model

Overload List

Name | Description
OrganizationServiceContextExtensions.LoadProperty (OrganizationServiceContext, Entity, String, Nullable) | Loads the related entity collection for the specified relationship.
OrganizationServiceContextExtensions.LoadProperty (OrganizationServiceContext, TEntity, Expression) | Loads the related entity collection for the specified relationship.

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


OrganizationServiceContextExtensions.LoadProperty Method (OrganizationServiceContext, Entity, String, Nullable)
[image]

Loads the related entity collection for the specified relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim relationshipSchemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)

OrganizationServiceContextExtensions.LoadProperty(context, entity, relationshipSchemaName, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub LoadProperty ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    relationshipSchemaName As String, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
)
C#
[ExtensionAttribute]
public static void LoadProperty (
    OrganizationServiceContext context,
    Entity entity,
    string relationshipSchemaName,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
entity
Type: Entity. The entity instance.
relationshipSchemaName
Type: String. The schema name of the relationship.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
  Remarks
This is an extension to the core LoadProperty method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


OrganizationServiceContextExtensions.LoadProperty Method (OrganizationServiceContext, TEntity, Expression)
[image]

Loads the related entity collection for the specified relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As TEntity
Dim propertySelector As Expression(Of Func(Of TEntity, Object))

OrganizationServiceContextExtensions.LoadProperty(context, entity, propertySelector)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub LoadProperty(Of TEntity As Entity) ( _
    context As OrganizationServiceContext, _
    entity As TEntity, _
    propertySelector As Expression(Of Func(Of TEntity, Object)) _
)
C#
[ExtensionAttribute]
public static void LoadProperty<TEntity> (
    OrganizationServiceContext context,
    TEntity entity,
    Expression<Func<TEntity,Object>> propertySelector
) where TEntity : Entity
C++

J#

JScript

GenericParameters
TEntity
The entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
entity
Type: TEntity. The entity instance.
propertySelector
  Remarks
This is an extension to the core LoadProperty method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.MergeClone Method
[image]

Clones an arbitrary source entity and attaches it to the context.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As T
Dim includeRelatedEntities As Boolean
Dim returnValue As T

returnValue = OrganizationServiceContextExtensions.MergeClone(context, entity, includeRelatedEntities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function MergeClone(Of T As Entity) ( _
    context As OrganizationServiceContext, _
    entity As T, _
    <OptionalAttribute> Optional includeRelatedEntities As Boolean = False _
) As T
C#
[ExtensionAttribute]
public static T MergeClone<T> (
    OrganizationServiceContext context,
    T entity,
    [OptionalAttribute] bool includeRelatedEntities
) where T : Entity
C++

J#

JScript

GenericParameters
T
The type, where T is Type: Entity.
Parameters
context
Type: OrganizationServiceContext. The service context.
entity
Type: T. The entity instance.
includeRelatedEntities
Type: Boolean. Specifies whether to include related entity instances.
Return Value
Type: Boolean

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


OrganizationServiceContextExtensions.ReAttach Method
[image]

Resets the EntityState of an entity before attaching it to the context.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As Entity

OrganizationServiceContextExtensions.ReAttach(context, entity)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ReAttach ( _
    context As OrganizationServiceContext, _
    entity As Entity _
)
C#
[ExtensionAttribute]
public static void ReAttach (
    OrganizationServiceContext context,
    Entity entity
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
entity
Type: Entity. The entity instance
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
EntityState
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Attach Entities to the Context


OrganizationServiceContextExtensions.TryAccessCache Method
[image]

Tries to perform an action on the underlying IOrganizationServiceCache if applicable.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim action As Action(Of IOrganizationServiceCache)
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.TryAccessCache(context, action)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function TryAccessCache ( _
    context As OrganizationServiceContext, _
    action As Action(Of IOrganizationServiceCache) _
) As Boolean
C#
[ExtensionAttribute]
public static bool TryAccessCache (
    OrganizationServiceContext context,
    Action<IOrganizationServiceCache> action
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
action
Type: Action<IOrganizationServiceCache>. The action.
Return Value
Type: Boolean

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
IOrganizationServiceCache
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.TryRemoveFromCache Method
[image]

Removes an entity from cache if it is applicable to the context.Developer Extensions for Microsoft Dynamics CRM Developer Extensions Context Object Model

Overload List

Name | Description
OrganizationServiceContextExtensions.TryRemoveFromCache (OrganizationServiceContext, Entity) | Removes an entity from cache if it is applicable to the context.
OrganizationServiceContextExtensions.TryRemoveFromCache (OrganizationServiceContext, EntityReference) | Removes an entity from cache if it is applicable to the context.
OrganizationServiceContextExtensions.TryRemoveFromCache (OrganizationServiceContext, OrganizationRequest) | Removes a request/response from cache if it is applicable to the context.
OrganizationServiceContextExtensions.TryRemoveFromCache (OrganizationServiceContext, String) | Removes an item from cache if it is applicable to the context.
OrganizationServiceContextExtensions.TryRemoveFromCache (OrganizationServiceContext, String, Nullable) | Removes an entity from cache if it is applicable to the context.

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


OrganizationServiceContextExtensions.TryRemoveFromCache Method (OrganizationServiceContext, Entity)
[image]

Removes an entity from cache if it is applicable to the context.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.TryRemoveFromCache(context, entity)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function TryRemoveFromCache ( _
    context As OrganizationServiceContext, _
    entity As Entity _
) As Boolean
C#
[ExtensionAttribute]
public static bool TryRemoveFromCache (
    OrganizationServiceContext context,
    Entity entity
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
entity
Type: Entity. The entity instance.
Return Value
Type: Boolean

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


OrganizationServiceContextExtensions.TryRemoveFromCache Method (OrganizationServiceContext, EntityReference)
[image]

Removes an entity from cache if it is applicable to the context.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As EntityReference
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.TryRemoveFromCache(context, entity)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function TryRemoveFromCache ( _
    context As OrganizationServiceContext, _
    entity As EntityReference _
) As Boolean
C#
[ExtensionAttribute]
public static bool TryRemoveFromCache (
    OrganizationServiceContext context,
    EntityReference entity
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
entity
Type: EntityReference. The entity instance.
Return Value
Type: Boolean

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.TryRemoveFromCache Method (OrganizationServiceContext, OrganizationRequest)
[image]

Removes a request/response from cache if it is applicable to the context.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim request As OrganizationRequest
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.TryRemoveFromCache(context, request)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function TryRemoveFromCache ( _
    context As OrganizationServiceContext, _
    request As OrganizationRequest _
) As Boolean
C#
[ExtensionAttribute]
public static bool TryRemoveFromCache (
    OrganizationServiceContext context,
    OrganizationRequest request
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
request
The request instance.
Return Value
Type: Boolean

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.TryRemoveFromCache Method (OrganizationServiceContext, String)
[image]

Removes an item from cache if it is applicable to the context.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim cacheKey As String
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.TryRemoveFromCache(context, cacheKey)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function TryRemoveFromCache ( _
    context As OrganizationServiceContext, _
    cacheKey As String _
) As Boolean
C#
[ExtensionAttribute]
public static bool TryRemoveFromCache (
    OrganizationServiceContext context,
    string cacheKey
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
cacheKey
Type: String. The cache key.
Return Value
Type: Boolean

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextExtensions.TryRemoveFromCache Method (OrganizationServiceContext, String, Nullable)
[image]

Removes an entity from cache if it is applicable to the context.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityLogicalName As String
Dim id As Nullable(Of Guid)
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.TryRemoveFromCache(context, entityLogicalName, id)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function TryRemoveFromCache ( _
    context As OrganizationServiceContext, _
    entityLogicalName As String, _
    id As Nullable(Of Guid) _
) As Boolean
C#
[ExtensionAttribute]
public static bool TryRemoveFromCache (
    OrganizationServiceContext context,
    string entityLogicalName,
    Nullable<Guid> id
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The service context.
entityLogicalName
Type: String. The logical name of the entity.
id
Type: Nullable<Guid>. The ID of the entity instance.
Return Value
Type: Boolean

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client Namespace


OrganizationServiceContextUtility Class
See Also Members
[image]

Contains utility methods. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
Public NotInheritable Class OrganizationServiceContextUtility
C#
public static class OrganizationServiceContextUtility
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.OrganizationServiceContextUtility
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextUtility Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextUtility Members
See Also Methods
[image]

Contains utility methods. (Developer Extensions)

The following tables list the members exposed by the OrganizationServiceContextUtility type.

Public Methods (see also Extension Methods)

Name | Description
TryGetWebsiteIDFromParentLinkForEntityInPendingChanges | For internal use only.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceContextUtility Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextUtility Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
TryGetWebsiteIDFromParentLinkForEntityInPendingChanges | For internal use only.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceContextUtility Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextUtility.TryGetWebsiteIDFromParentLinkForEntityInPendingChanges Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim sourceEntityName As String
Dim websiteID As EntityReference
Dim returnValue As Boolean

returnValue = OrganizationServiceContextUtility.TryGetWebsiteIDFromParentLinkForEntityInPendingChanges(context, entity, sourceEntityName, websiteID)

Syntax

Visual Basic
Public Shared Function TryGetWebsiteIDFromParentLinkForEntityInPendingChanges ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    sourceEntityName As String, _
    <OutAttribute> ByRef websiteID As EntityReference _
) As Boolean
C#
public static bool TryGetWebsiteIDFromParentLinkForEntityInPendingChanges (
    OrganizationServiceContext context,
    Entity entity,
    string sourceEntityName,
    out EntityReference websiteID
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The context.
entity
Type: Entity. The entity.
sourceEntityName
Type: String. The logical name of the source entity.
websiteID
Type: EntityReference.
Return Value
Type: Boolean

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextUtility Class
OrganizationServiceContextUtility Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


RelationshipExtensions Class
See Also Members
[image]

Extensions for working with relationships. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class RelationshipExtensions
C#
[ExtensionAttribute]
public static class RelationshipExtensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.RelationshipExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


RelationshipExtensions Members
See Also Methods
[image]

Extensions for working with relationships. (Developer Extensions)

The following tables list the members exposed by the RelationshipExtensions type.

Public Methods (see also Extension Methods)

Name | Description
ToRelationship | Converts a relationship schema name to a relationship.
ToSchemaName | Converts a relationship into a relationship schema name.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

RelationshipExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


RelationshipExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
ToRelationship | Converts a relationship schema name to a relationship.
ToSchemaName | Converts a relationship into a relationship schema name.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

RelationshipExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


RelationshipExtensions.ToRelationship Method
[image]

Converts a relationship schema name to a relationship.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim schemaName As String
Dim primaryEntityRole As Nullable(Of EntityRole)
Dim returnValue As Relationship

returnValue = RelationshipExtensions.ToRelationship(schemaName, primaryEntityRole)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToRelationship ( _
    schemaName As String, _
    <OptionalAttribute> Optional primaryEntityRole As Nullable(Of EntityRole) = Nothing _
) As Relationship
C#
[ExtensionAttribute]
public static Relationship ToRelationship (
    string schemaName,
    [OptionalAttribute] Nullable<EntityRole> primaryEntityRole
)
C++

J#

JScript

Parameters
schemaName
Type: String. The relationship instance.
primaryEntityRole
Type: Nullable<EntityRole>. The role that the entity plays in the relationship, referencing or referenced.
Return Value
Type: Relationship
The relationship instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipExtensions Class
RelationshipExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


RelationshipExtensions.ToSchemaName Method
[image]

Converts a relationship into a relationship schema name.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim relationship As Relationship
Dim separator As String
Dim returnValue As String

returnValue = RelationshipExtensions.ToSchemaName(relationship, separator)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToSchemaName ( _
    relationship As Relationship, _
    <OptionalAttribute> Optional separator As String = "." _
) As String
C#
[ExtensionAttribute]
public static string ToSchemaName (
    Relationship relationship,
    [OptionalAttribute] string separator
)
C++

J#

JScript

Parameters
relationship
Type: Relationship. The relationship instance.
separator
Type: String.
Return Value
Type: String
The schema name of the relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipExtensions Class
RelationshipExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


RoundTo Enumeration
[image]

Enumerations used for rounding date/time values. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As RoundTo

Syntax

Visual Basic
Public Enumeration RoundTo
C#
public enum RoundTo
C++

J#

JScript

  Members
Member name | Description
Day | Round to the day. Value = 3.
Hour | Round to the hour. Value = 2.
Minute | Round to the minute. Value = 1.
Month | Round to the month. Value = 4.
Second | Round to the second. Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ServiceConfigurationInstanceMode Enumeration
[image]

Enumeration values for the server configuration instance mode. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ServiceConfigurationInstanceMode

Syntax

Visual Basic
Public Enumeration ServiceConfigurationInstanceMode
C#
public enum ServiceConfigurationInstanceMode
C++

J#

JScript

  Members
Member name | Description
PerInstance | Value = 3.
PerName | Value = 2.
PerRequest | Value = 1.
Static | Value = 0.
  Remarks
This enumeration is used for the ServiceConfigurationInstanceMode property.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


StringExtensions Class
See Also Members
[image]

Extensions for working with string values. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class StringExtensions
C#
[ExtensionAttribute]
public static class StringExtensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.StringExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


StringExtensions Members
See Also Methods
[image]

Extensions for working with string values. (Developer Extensions)

The following tables list the members exposed by the StringExtensions type.

Public Methods (see also Extension Methods)

Name | Description
FormatWith | Calls the Format(IFormatProvider, String, Object[]) method with the InvariantCulture provider to return the formatted string.
ToEnum | Overloaded.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

StringExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


StringExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
FormatWith | Calls the Format(IFormatProvider, String, Object[]) method with the InvariantCulture provider to return the formatted string.
ToEnum | Overloaded.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

StringExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


StringExtensions.FormatWith Method
[image]

Calls the Format(IFormatProvider, String, Object[]) method with the InvariantCulture provider to return the formatted string.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim format As String
Dim args As Object()
Dim returnValue As String

returnValue = StringExtensions.FormatWith(format, args)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function FormatWith ( _
    format As String, _
    ParamArray args As Object() _
) As String
C#
[ExtensionAttribute]
public static string FormatWith (
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
format
Type: String. The format.
args
Type: Object[]. The arguments to pass to the formatter.
Return Value
Type: String

The formatted string.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringExtensions Class
StringExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


StringExtensions.ToEnum Method
[image]

Overload List

Name | Description
StringExtensions.ToEnum (Int32) | Converts an integer value into an Enum value.
StringExtensions.ToEnum (String) | Parses a name value into an Enum value.

See Also

Reference

StringExtensions Class
StringExtensions Members
Microsoft.Xrm.Client Namespace


StringExtensions.ToEnum Method (Int32)
[image]

Converts an integer value into an Enum value.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim enumValue As Integer
Dim returnValue As T

returnValue = StringExtensions.ToEnum(enumValue)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToEnum(Of T) ( _
    enumValue As Integer _
) As T
C#
[ExtensionAttribute]
public static T ToEnum<T> (
    int enumValue
)
C++

J#

JScript

GenericParameters
T
Type T.
Parameters
enumValue
Type: Int32. The enumeration value.
Return Value
Type: Type

The Enum value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringExtensions Class
StringExtensions Members
Microsoft.Xrm.Client Namespace


StringExtensions.ToEnum Method (String)
[image]

Parses a name value into an Enum value.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim enumName As String
Dim returnValue As T

returnValue = StringExtensions.ToEnum(enumName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToEnum(Of T) ( _
    enumName As String _
) As T
C#
[ExtensionAttribute]
public static T ToEnum<T> (
    string enumName
)
C++

J#

JScript

GenericParameters
T
Type T.
Parameters
enumName
Type: String. The enumeration value.
Return Value
Type: Type

The Enum value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
StringExtensions Class
StringExtensions Members
Microsoft.Xrm.Client Namespace


TypeExtensions Class
See Also Members
[image]

Extensions to help working with types. (Developer Extensions)

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class TypeExtensions
C#
[ExtensionAttribute]
public static class TypeExtensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.TypeExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TypeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


TypeExtensions Members
See Also Methods
[image]

Extensions to help working with types. (Developer Extensions)

The following tables list the members exposed by the TypeExtensions type.

Public Methods (see also Extension Methods)

Name | Description
GetCustomAttributes | Returns the collection of custom attributes for a given type.
GetEntityLogicalName | Returns the logical name value of the EntityLogicalNameAttribute attribute associated to the class type.
GetFirstOrDefaultCustomAttribute | Returns the first custom attribute of a given type.
GetType | Retrieves a type object by name and by searching through all available assemblies.
GetUnderlyingType | Retrieves the underlying type if the type is nullable, otherwise returns the current type.
IsA | Overloaded. Determines if the input reference type is assignable from this type.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

TypeExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


TypeExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
GetCustomAttributes | Returns the collection of custom attributes for a given type.
GetEntityLogicalName | Returns the logical name value of the EntityLogicalNameAttribute attribute associated to the class type.
GetFirstOrDefaultCustomAttribute | Returns the first custom attribute of a given type.
GetType | Retrieves a type object by name and by searching through all available assemblies.
GetUnderlyingType | Retrieves the underlying type if the type is nullable, otherwise returns the current type.
IsA | Overloaded. Determines if the input reference type is assignable from this type.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

TypeExtensions Class
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


TypeExtensions.GetCustomAttributes Method
[image]

Returns the collection of custom attributes for a given type.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim type As Type
Dim returnValue As IEnumerable(Of T)

returnValue = TypeExtensions.GetCustomAttributes(type)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetCustomAttributes(Of T As Attribute) ( _
    type As Type _
) As IEnumerable(Of T)
C#
[ExtensionAttribute]
public static IEnumerable<T> GetCustomAttributes<T> (
    Type type
) where T : Attribute
C++

J#

JScript

GenericParameters
T
Type T.
Parameters
type
The type.
Return Value
Type: IEnumerable<Type>
The collection of custom attributes for the specified type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TypeExtensions Class
TypeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


TypeExtensions.GetEntityLogicalName Method
[image]

Returns the logical name value of the EntityLogicalNameAttribute attribute associated to the class type.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim type As Type
Dim returnValue As String

returnValue = TypeExtensions.GetEntityLogicalName(type)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetEntityLogicalName ( _
    type As Type _
) As String
C#
[ExtensionAttribute]
public static string GetEntityLogicalName (
    Type type
)
C++

J#

JScript

Parameters
type
The type.
Return Value
Type: String
The logical name of the attribute found.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TypeExtensions Class
TypeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


TypeExtensions.GetFirstOrDefaultCustomAttribute Method
[image]

Returns the first custom attribute of a given type.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim type As Type
Dim returnValue As T

returnValue = TypeExtensions.GetFirstOrDefaultCustomAttribute(type)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetFirstOrDefaultCustomAttribute(Of T As Attribute) ( _
    type As Type _
) As T
C#
[ExtensionAttribute]
public static T GetFirstOrDefaultCustomAttribute<T> (
    Type type
) where T : Attribute
C++

J#

JScript

GenericParameters
T
Type T.
Parameters
type
The type.
Return Value
Type: String
The first custom attribute of the specified type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TypeExtensions Class
TypeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


TypeExtensions.GetType Method
[image]

Retrieves a type object by name and by searching through all available assemblies.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim typeName As String
Dim returnValue As Type

returnValue = TypeExtensions.GetType(typeName)

Syntax

Visual Basic
Public Shared Function GetType ( _
    typeName As String _
) As Type
C#
public static Type GetType (
    string typeName
)
C++

J#

JScript

Parameters
typeName
The type name.
Return Value
Type: Type
The type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TypeExtensions Class
TypeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


TypeExtensions.GetUnderlyingType Method
[image]

Retrieves the underlying type if the type is nullable, otherwise returns the current type.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim type As Type
Dim returnValue As Type

returnValue = TypeExtensions.GetUnderlyingType(type)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetUnderlyingType ( _
    type As Type _
) As Type
C#
[ExtensionAttribute]
public static Type GetUnderlyingType (
    Type type
)
C++

J#

JScript

Parameters
type
The type.
Return Value
Type: Type
The underlying type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TypeExtensions Class
TypeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


TypeExtensions.IsA Method
[image]

Determines if the input reference type is assignable from this type.Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
TypeExtensions.IsA (Type, Type) | Determines if the input reference type is assignable from this type.
TypeExtensions.IsA (Type) | Determines if the input reference type is assignable from this type.

See Also

Reference

TypeExtensions Class
TypeExtensions Members
Microsoft.Xrm.Client Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


TypeExtensions.IsA Method (Type, Type)
[image]

Determines if the input reference type is assignable from this type.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim type As Type
Dim referenceType As Type
Dim returnValue As Boolean

returnValue = TypeExtensions.IsA(type, referenceType)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function IsA ( _
    type As Type, _
    referenceType As Type _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsA (
    Type type,
    Type referenceType
)
C++

J#

JScript

Parameters
type
The type.
referenceType
The reference type.
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TypeExtensions Class
TypeExtensions Members
Microsoft.Xrm.Client Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


TypeExtensions.IsA Method (Type)
[image]

Determines if the input reference type is assignable from this type.

Namespace: Microsoft.Xrm.Client
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim type As Type
Dim returnValue As Boolean

returnValue = TypeExtensions.IsA(type)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function IsA(Of T) ( _
    type As Type _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsA<T> (
    Type type
)
C++

J#

JScript

GenericParameters
T
The type.
Parameters
type
The reference type.
Return Value
Type: Boolean
true if the input reference type is assignable from this type; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
TypeExtensions Class
TypeExtensions Members
Microsoft.Xrm.Client Namespace


Microsoft.Xrm.Client.Caching Namespace

Classes

Class | Description
CacheItemDetail | Additional information about the cache item. (Developer Extensions)
CacheItemPolicyDetail | Additional information about the cache item policy. (Developer Extensions)
ChangeMonitorDetail | Additional information about the change monitor. (Developer Extensions)
ObjectCacheManager | Object cache manager. (Developer Extensions)
ObjectCacheProvider | Object cache provider. (Developer Extensions)

Interfaces

Interface | Description
IExtendedObjectCache | Extended object cache. (Developer Extensions)


CacheItemDetail Class
See Also Members
[image]

Additional information about the cache item. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemDetail

Syntax

Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CacheItemDetail
C#
[SerializableAttribute]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CacheItemDetail
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Caching.CacheItemDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemDetail Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CacheItemDetail Members
See Also Constructors Methods Properties
[image]

Additional information about the cache item. (Developer Extensions)

The following tables list the members exposed by the CacheItemDetail type.

Public Constructors

Name | Description
CacheItemDetail | Constructor initializes an instance of the CacheItemDetail class.
Top

Public Properties

 | Name | Description
public property | CacheKey | Gets the key of the related cache item.
public property | CreatedOn | Gets the creation date of the cache item.
public property | Policy | Gets the policy of the cache item.
public property | UpdatedOn | Gets or sets the last updated date of the cache item.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

CacheItemDetail Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CacheItemDetail Constructor
[image]

Constructor initializes an instance of the CacheItemDetail class.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cacheKey As String
Dim policy As CacheItemPolicy

Dim instance As New CacheItemDetail(cacheKey, policy)

Syntax

Visual Basic
Public Sub New ( _
    cacheKey As String, _
    policy As CacheItemPolicy _
)
C#
public CacheItemDetail (
    string cacheKey,
    CacheItemPolicy policy
)
C++

J#

JScript

Parameters
cacheKey
Type: String. The associated cache item.
policy
Type: CacheItemPolicy. The policy of the cache item.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemDetail Class
CacheItemDetail Members
Microsoft.Xrm.Client.Caching Namespace


CacheItemDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CacheItemDetail Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CacheItemDetail Properties
[image]

Public Properties

 | Name | Description
public property | CacheKey | Gets the key of the related cache item.
public property | CreatedOn | Gets the creation date of the cache item.
public property | Policy | Gets the policy of the cache item.
public property | UpdatedOn | Gets or sets the last updated date of the cache item.

See Also

Reference

CacheItemDetail Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CacheItemDetail.CacheKey Property
[image]

Gets the key of the related cache item.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemDetail
Dim value As String

value = instance.CacheKey

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property CacheKey As String
C#
[DataMemberAttribute]
public string CacheKey { get; }
C++

J#

JScript

Property Value
Type: String
The key.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemDetail Class
CacheItemDetail Members
Microsoft.Xrm.Client.Caching Namespace


CacheItemDetail.CreatedOn Property
[image]

Gets the creation date of the cache item.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemDetail
Dim value As DateTimeOffset

value = instance.CreatedOn

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property CreatedOn As DateTimeOffset
C#
[DataMemberAttribute]
public DateTimeOffset CreatedOn { get; }
C++

J#

JScript

Property Value
Type:  DateTimeOffset
The creation date.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemDetail Class
CacheItemDetail Members
Microsoft.Xrm.Client.Caching Namespace


CacheItemDetail.Policy Property
[image]

Gets the policy of the cache item.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemDetail
Dim value As CacheItemPolicyDetail

value = instance.Policy

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property Policy As CacheItemPolicyDetail
C#
[DataMemberAttribute]
public CacheItemPolicyDetail Policy { get; }
C++

J#

JScript

Property Value
Type: CacheItemPolicy
The policy of the cache item.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemDetail Class
CacheItemDetail Members
Microsoft.Xrm.Client.Caching Namespace


CacheItemDetail.UpdatedOn Property
[image]

Gets or sets the last updated date of the cache item.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemDetail
Dim value As DateTimeOffset

value = instance.UpdatedOn

instance.UpdatedOn = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property UpdatedOn As DateTimeOffset
C#
[DataMemberAttribute]
public DateTimeOffset UpdatedOn { get; set; }
C++

J#

JScript

Property Value
Type: DateTimeOffset
The last updated date.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemDetail Class
CacheItemDetail Members
Microsoft.Xrm.Client.Caching Namespace


CacheItemPolicyDetail Class
See Also Members
[image]

Additional information about the cache item policy. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemPolicyDetail

Syntax

Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class CacheItemPolicyDetail
C#
[SerializableAttribute]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class CacheItemPolicyDetail
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Caching.CacheItemPolicyDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemPolicyDetail Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CacheItemPolicyDetail Members
See Also Constructors Methods Properties
[image]

Additional information about the cache item policy. (Developer Extensions)

The following tables list the members exposed by the CacheItemPolicyDetail type.

Public Constructors

Name | Description
CacheItemPolicyDetail | Initializes an instance of the CacheItemPolicyDetail class.
Top

Public Properties

 | Name | Description
public property | AbsoluteExpiration | Gets the absolute expiration date.
public property | ChangeMonitors | Gets the collection of change monitors.
public property | Priority | Gets the priority.
public property | SlidingExpiration | Gets the sliding expiration time span.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

CacheItemPolicyDetail Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CacheItemPolicyDetail Constructor
[image]

Initializes an instance of the CacheItemPolicyDetail class.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim policy As CacheItemPolicy

Dim instance As New CacheItemPolicyDetail(policy)

Syntax

Visual Basic
Public Sub New ( _
    policy As CacheItemPolicy _
)
C#
public CacheItemPolicyDetail (
    CacheItemPolicy policy
)
C++

J#

JScript

Parameters
policy
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemPolicyDetail Class
CacheItemPolicyDetail Members
Microsoft.Xrm.Client.Caching Namespace


CacheItemPolicyDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CacheItemPolicyDetail Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CacheItemPolicyDetail Properties
[image]

Public Properties

 | Name | Description
public property | AbsoluteExpiration | Gets the absolute expiration date.
public property | ChangeMonitors | Gets the collection of change monitors.
public property | Priority | Gets the priority.
public property | SlidingExpiration | Gets the sliding expiration time span.

See Also

Reference

CacheItemPolicyDetail Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CacheItemPolicyDetail.AbsoluteExpiration Property
[image]

Gets the absolute expiration date.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemPolicyDetail
Dim value As DateTimeOffset

value = instance.AbsoluteExpiration

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property AbsoluteExpiration As DateTimeOffset
C#
[DataMemberAttribute]
public DateTimeOffset AbsoluteExpiration { get; }
C++

J#

JScript

Property Value
Type: DateTimeOffset.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemPolicyDetail Class
CacheItemPolicyDetail Members
Microsoft.Xrm.Client.Caching Namespace


CacheItemPolicyDetail.ChangeMonitors Property
[image]

Gets the collection of change monitors.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemPolicyDetail
Dim value As ICollection(Of ChangeMonitorDetail)

value = instance.ChangeMonitors

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property ChangeMonitors As ICollection(Of ChangeMonitorDetail)
C#
[DataMemberAttribute]
public ICollection<ChangeMonitorDetail> ChangeMonitors { get; }
C++

J#

JScript

Property Value
Type: ICollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemPolicyDetail Class
CacheItemPolicyDetail Members
Microsoft.Xrm.Client.Caching Namespace


CacheItemPolicyDetail.Priority Property
[image]

Gets the priority.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemPolicyDetail
Dim value As CacheItemPriority

value = instance.Priority

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property Priority As CacheItemPriority
C#
[DataMemberAttribute]
public CacheItemPriority Priority { get; }
C++

J#

JScript

Property Value
Type: CacheItemPriority.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemPolicyDetail Class
CacheItemPolicyDetail Members
Microsoft.Xrm.Client.Caching Namespace


CacheItemPolicyDetail.SlidingExpiration Property
[image]

Gets the sliding expiration time span.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemPolicyDetail
Dim value As TimeSpan

value = instance.SlidingExpiration

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property SlidingExpiration As TimeSpan
C#
[DataMemberAttribute]
public TimeSpan SlidingExpiration { get; }
C++

J#

JScript

Property Value
Type: TimeSpan.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CacheItemPolicyDetail Class
CacheItemPolicyDetail Members
Microsoft.Xrm.Client.Caching Namespace


ChangeMonitorDetail Class
See Also Members
[image]

Additional information about the change monitor. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ChangeMonitorDetail

Syntax

Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public NotInheritable Class ChangeMonitorDetail
C#
[SerializableAttribute]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public sealed class ChangeMonitorDetail
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Caching.ChangeMonitorDetail
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChangeMonitorDetail Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ChangeMonitorDetail Members
See Also Constructors Methods Properties
[image]

Additional information about the change monitor. (Developer Extensions)

The following tables list the members exposed by the ChangeMonitorDetail type.

Public Constructors

Name | Description
ChangeMonitorDetail | Initializes a new instance of the ChangeMonitorDetail.
Top

Public Properties

 | Name | Description
public property | CacheKeys | Gets the cache keys.
public property | LastModified | Gets the last modified date and time.
public property | RegionName | Gets the region name.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

ChangeMonitorDetail Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ChangeMonitorDetail Constructor
[image]

Initializes a new instance of the ChangeMonitorDetail.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim changeMonitor As CacheEntryChangeMonitor

Dim instance As New ChangeMonitorDetail(changeMonitor)

Syntax

Visual Basic
Public Sub New ( _
    changeMonitor As CacheEntryChangeMonitor _
)
C#
public ChangeMonitorDetail (
    CacheEntryChangeMonitor changeMonitor
)
C++

J#

JScript

Parameters
changeMonitor
Type: .
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChangeMonitorDetail Class
ChangeMonitorDetail Members
Microsoft.Xrm.Client.Caching Namespace


ChangeMonitorDetail Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

ChangeMonitorDetail Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ChangeMonitorDetail Properties
[image]

Public Properties

 | Name | Description
public property | CacheKeys | Gets the cache keys.
public property | LastModified | Gets the last modified date and time.
public property | RegionName | Gets the region name.

See Also

Reference

ChangeMonitorDetail Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ChangeMonitorDetail.CacheKeys Property
[image]

Gets the cache keys.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ChangeMonitorDetail
Dim value As ICollection(Of String)

value = instance.CacheKeys

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property CacheKeys As ICollection(Of String)
C#
[DataMemberAttribute]
public ICollection<string> CacheKeys { get; }
C++

J#

JScript

Property Value
Type: ICollection<String>
The collection of keys for the cache.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChangeMonitorDetail Class
ChangeMonitorDetail Members
Microsoft.Xrm.Client.Caching Namespace


ChangeMonitorDetail.LastModified Property
[image]

Gets the last modified date and time.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ChangeMonitorDetail
Dim value As DateTimeOffset

value = instance.LastModified

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property LastModified As DateTimeOffset
C#
[DataMemberAttribute]
public DateTimeOffset LastModified { get; }
C++

J#

JScript

Property Value
Type: DateTimeOffset
The last modified date time offset.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChangeMonitorDetail Class
ChangeMonitorDetail Members
Microsoft.Xrm.Client.Caching Namespace


ChangeMonitorDetail.RegionName Property
[image]

Gets the region name.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ChangeMonitorDetail
Dim value As String

value = instance.RegionName

Syntax

Visual Basic
<DataMemberAttribute> _
Public Property RegionName As String
C#
[DataMemberAttribute]
public string RegionName { get; }
C++

J#

JScript

Property Value
Type: String
The name of the region.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ChangeMonitorDetail Class
ChangeMonitorDetail Members
Microsoft.Xrm.Client.Caching Namespace


IExtendedObjectCache Interface
See Also Members
[image]

Extended object cache. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IExtendedObjectCache

Syntax

Visual Basic
Public Interface IExtendedObjectCache
C#
public interface IExtendedObjectCache
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExtendedObjectCache Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


IExtendedObjectCache Members
See Also Methods
[image]

Extended object cache. (Developer Extensions)

The following tables list the members exposed by the IExtendedObjectCache type.

Public Methods

 | Name | Description
public method | RemoveAll | Removes all cache items.
public method | RemoveAllLocal | Removes all cache items that are local to the application.
public method | RemoveLocal | Removes a cache item that is local to the application.<
Top

See Also

Reference

IExtendedObjectCache Interface
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


IExtendedObjectCache Methods
[image]

Public Methods

 | Name | Description
public method | RemoveAll | Removes all cache items.
public method | RemoveAllLocal | Removes all cache items that are local to the application.
public method | RemoveLocal | Removes a cache item that is local to the application.<

See Also

Reference

IExtendedObjectCache Interface
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


IExtendedObjectCache.RemoveAll Method
[image]

Removes all cache items.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IExtendedObjectCache
Dim regionName As String

instance.RemoveAll(regionName)

Syntax

Visual Basic
Sub RemoveAll ( _
    regionName As String _
)
C#
void RemoveAll (
    string regionName
)
C++

J#

JScript

Parameters
regionName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExtendedObjectCache Interface
IExtendedObjectCache Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


IExtendedObjectCache.RemoveAllLocal Method
[image]

Removes all cache items that are local to the application.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IExtendedObjectCache
Dim regionName As String

instance.RemoveAllLocal(regionName)

Syntax

Visual Basic
Sub RemoveAllLocal ( _
    regionName As String _
)
C#
void RemoveAllLocal (
    string regionName
)
C++

J#

JScript

Parameters
regionName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExtendedObjectCache Interface
IExtendedObjectCache Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


IExtendedObjectCache.RemoveLocal Method
[image]

Removes a cache item that is local to the application.<

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IExtendedObjectCache
Dim key As String
Dim regionName As String
Dim returnValue As Object

returnValue = instance.RemoveLocal(key, regionName)

Syntax

Visual Basic
Function RemoveLocal ( _
    key As String, _
    regionName As String _
) As Object
C#
Object RemoveLocal (
    string key,
    string regionName
)
C++

J#

JScript

Parameters
key
regionName
Return Value
Type: Object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IExtendedObjectCache Interface
IExtendedObjectCache Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager Class
See Also Members
[image]

Object cache manager. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class ObjectCacheManager
C#
[ExtensionAttribute]
public static class ObjectCacheManager
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Caching.ObjectCacheManager
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager Members
See Also Methods
[image]

Object cache manager. (Developer Extensions)

The following tables list the members exposed by the ObjectCacheManager type.

Public Methods (see also Extension Methods)

Name | Description
Clear | Removes all items from the cache.
Get | Overloaded.
GetCacheItemDetail | Retrieves the associated CacheItemDetail for a cache item.
GetCacheItemPolicy | Overloaded.
GetChangeMonitor | Builds a CacheEntryChangeMonitor from a set of cache keys.
GetInstance | Retrieves a configured ObjectCache.
Insert | Overloaded.
RemoveAll | Removes all items from the cache by invoking the IExtendedObjectCache if it is available.
Reset |
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

ObjectCacheManager Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
Clear | Removes all items from the cache.
Get | Overloaded.
GetCacheItemDetail | Retrieves the associated CacheItemDetail for a cache item.
GetCacheItemPolicy | Overloaded.
GetChangeMonitor | Builds a CacheEntryChangeMonitor from a set of cache keys.
GetInstance | Retrieves a configured ObjectCache.
Insert | Overloaded.
RemoveAll | Removes all items from the cache by invoking the IExtendedObjectCache if it is available.
Reset |

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

ObjectCacheManager Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.Clear Method
[image]

Removes all items from the cache.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache

ObjectCacheManager.Clear(cache)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub Clear ( _
    cache As ObjectCache _
)
C#
[ExtensionAttribute]
public static void Clear (
    ObjectCache cache
)
C++

J#

JScript

Parameters
cache
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.Get Method
[image]

Overload List

Name | Description
ObjectCacheManager.Get (ObjectCache, String, Func, Action, String) |
ObjectCacheManager.Get (ObjectCache, String, Func, Func, String) |
ObjectCacheManager.Get (String, Func, Action, String) |
ObjectCacheManager.Get (String, Func, Func, String) |
ObjectCacheManager.Get (String, String, Func, Action, String) |
ObjectCacheManager.Get (String, String, Func, Func, String) |

See Also

Reference

ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.Get Method (ObjectCache, String, Func, Action, String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim cacheKey As String
Dim load As Func(Of ObjectCache, T)
Dim insert As Action(Of ObjectCache, T)
Dim regionName As String
Dim returnValue As T

returnValue = ObjectCacheManager.Get(cache, cacheKey, load, insert, regionName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Get(Of T) ( _
    cache As ObjectCache, _
    cacheKey As String, _
    load As Func(Of ObjectCache, T), _
    insert As Action(Of ObjectCache, T), _
    <OptionalAttribute> Optional regionName As String = Nothing _
) As T
C#
[ExtensionAttribute]
public static T Get<T> (
    ObjectCache cache,
    string cacheKey,
    Func<ObjectCache,T> load,
    Action<ObjectCache,T> insert,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

GenericParameters
T
Parameters
cache
cacheKey
load
insert
regionName
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.Get Method (ObjectCache, String, Func, Func, String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim cacheKey As String
Dim load As Func(Of ObjectCache, T)
Dim getPolicy As Func(Of CacheItemPolicy)
Dim regionName As String
Dim returnValue As T

returnValue = ObjectCacheManager.Get(cache, cacheKey, load, getPolicy, regionName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Get(Of T) ( _
    cache As ObjectCache, _
    cacheKey As String, _
    load As Func(Of ObjectCache, T), _
    <OptionalAttribute> Optional getPolicy As Func(Of CacheItemPolicy) = Nothing, _
    <OptionalAttribute> Optional regionName As String = Nothing _
) As T
C#
[ExtensionAttribute]
public static T Get<T> (
    ObjectCache cache,
    string cacheKey,
    Func<ObjectCache,T> load,
    [OptionalAttribute] Func<CacheItemPolicy> getPolicy,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

GenericParameters
T
Parameters
cache
cacheKey
load
getPolicy
regionName
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.Get Method (String, Func, Action, String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cacheKey As String
Dim load As Func(Of ObjectCache, T)
Dim insert As Action(Of ObjectCache, T)
Dim regionName As String
Dim returnValue As T

returnValue = ObjectCacheManager.Get(cacheKey, load, insert, regionName)

Syntax

Visual Basic
Public Shared Function Get(Of T) ( _
    cacheKey As String, _
    load As Func(Of ObjectCache, T), _
    insert As Action(Of ObjectCache, T), _
    <OptionalAttribute> Optional regionName As String = Nothing _
) As T
C#
public static T Get<T> (
    string cacheKey,
    Func<ObjectCache,T> load,
    Action<ObjectCache,T> insert,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

GenericParameters
T
Parameters
cacheKey
load
insert
regionName
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.Get Method (String, Func, Func, String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cacheKey As String
Dim load As Func(Of ObjectCache, T)
Dim getPolicy As Func(Of CacheItemPolicy)
Dim regionName As String
Dim returnValue As T

returnValue = ObjectCacheManager.Get(cacheKey, load, getPolicy, regionName)

Syntax

Visual Basic
Public Shared Function Get(Of T) ( _
    cacheKey As String, _
    load As Func(Of ObjectCache, T), _
    <OptionalAttribute> Optional getPolicy As Func(Of CacheItemPolicy) = Nothing, _
    <OptionalAttribute> Optional regionName As String = Nothing _
) As T
C#
public static T Get<T> (
    string cacheKey,
    Func<ObjectCache,T> load,
    [OptionalAttribute] Func<CacheItemPolicy> getPolicy,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

GenericParameters
T
Parameters
cacheKey
load
getPolicy
regionName
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.Get Method (String, String, Func, Action, String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim objectCacheName As String
Dim cacheKey As String
Dim load As Func(Of ObjectCache, T)
Dim insert As Action(Of ObjectCache, T)
Dim regionName As String
Dim returnValue As T

returnValue = ObjectCacheManager.Get(objectCacheName, cacheKey, load, insert, regionName)

Syntax

Visual Basic
Public Shared Function Get(Of T) ( _
    objectCacheName As String, _
    cacheKey As String, _
    load As Func(Of ObjectCache, T), _
    insert As Action(Of ObjectCache, T), _
    <OptionalAttribute> Optional regionName As String = Nothing _
) As T
C#
public static T Get<T> (
    string objectCacheName,
    string cacheKey,
    Func<ObjectCache,T> load,
    Action<ObjectCache,T> insert,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

GenericParameters
T
Parameters
objectCacheName
cacheKey
load
insert
regionName
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.Get Method (String, String, Func, Func, String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim objectCacheName As String
Dim cacheKey As String
Dim load As Func(Of ObjectCache, T)
Dim getPolicy As Func(Of CacheItemPolicy)
Dim regionName As String
Dim returnValue As T

returnValue = ObjectCacheManager.Get(objectCacheName, cacheKey, load, getPolicy, regionName)

Syntax

Visual Basic
Public Shared Function Get(Of T) ( _
    objectCacheName As String, _
    cacheKey As String, _
    load As Func(Of ObjectCache, T), _
    <OptionalAttribute> Optional getPolicy As Func(Of CacheItemPolicy) = Nothing, _
    <OptionalAttribute> Optional regionName As String = Nothing _
) As T
C#
public static T Get<T> (
    string objectCacheName,
    string cacheKey,
    Func<ObjectCache,T> load,
    [OptionalAttribute] Func<CacheItemPolicy> getPolicy,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

GenericParameters
T
Parameters
objectCacheName
cacheKey
load
getPolicy
regionName
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.GetCacheItemDetail Method
[image]

Retrieves the associated CacheItemDetail for a cache item.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim cacheKey As String
Dim regionName As String
Dim returnValue As CacheItemDetail

returnValue = ObjectCacheManager.GetCacheItemDetail(cache, cacheKey, regionName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetCacheItemDetail ( _
    cache As ObjectCache, _
    cacheKey As String, _
    <OptionalAttribute> Optional regionName As String = Nothing _
) As CacheItemDetail
C#
[ExtensionAttribute]
public static CacheItemDetail GetCacheItemDetail (
    ObjectCache cache,
    string cacheKey,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

Parameters
cache
cacheKey
regionName
Return Value
Type: CacheItemDetail.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.GetCacheItemPolicy Method
[image]

Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
ObjectCacheManager.GetCacheItemPolicy (IEnumerable, String, String) | Builds a CacheItemPolicy from a configuration element.
ObjectCacheManager.GetCacheItemPolicy (ChangeMonitor, String) | Builds a CacheItemPolicy from a configuration element and adds a single ChangeMonitor to the policy..
ObjectCacheManager.GetCacheItemPolicy (ObjectCache, IEnumerable, String, String) | Builds a CacheItemPolicy from a configuration element and adds a set of CacheEntryChangeMonitor objects to the policy.
ObjectCacheManager.GetCacheItemPolicy (String) | Builds a CacheItemPolicy from a configuration element.

See Also

Reference

ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.GetCacheItemPolicy Method (IEnumerable, String, String)
[image]

Builds a CacheItemPolicy from a configuration element.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim dependencies As IEnumerable(Of String)
Dim regionName As String
Dim objectCacheName As String
Dim returnValue As CacheItemPolicy

returnValue = ObjectCacheManager.GetCacheItemPolicy(dependencies, regionName, objectCacheName)

Syntax

Visual Basic
Public Shared Function GetCacheItemPolicy ( _
    dependencies As IEnumerable(Of String), _
    <OptionalAttribute> Optional regionName As String = Nothing, _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As CacheItemPolicy
C#
public static CacheItemPolicy GetCacheItemPolicy (
    IEnumerable<string> dependencies,
    [OptionalAttribute] string regionName,
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
dependencies
regionName
objectCacheName
Return Value
Type: CacheItemPolicy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.GetCacheItemPolicy Method (ChangeMonitor, String)
[image]

Builds a CacheItemPolicy from a configuration element and adds a single ChangeMonitor to the policy..

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim monitor As ChangeMonitor
Dim objectCacheName As String
Dim returnValue As CacheItemPolicy

returnValue = ObjectCacheManager.GetCacheItemPolicy(monitor, objectCacheName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetCacheItemPolicy ( _
    monitor As ChangeMonitor, _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As CacheItemPolicy
C#
[ExtensionAttribute]
public static CacheItemPolicy GetCacheItemPolicy (
    ChangeMonitor monitor,
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
monitor
objectCacheName
Return Value
Type: CacheItemPolicy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.GetCacheItemPolicy Method (ObjectCache, IEnumerable, String, String)
[image]

Builds a CacheItemPolicy from a configuration element and adds a set of CacheEntryChangeMonitor objects to the policy.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim dependencies As IEnumerable(Of String)
Dim regionName As String
Dim objectCacheName As String
Dim returnValue As CacheItemPolicy

returnValue = ObjectCacheManager.GetCacheItemPolicy(cache, dependencies, regionName, objectCacheName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetCacheItemPolicy ( _
    cache As ObjectCache, _
    dependencies As IEnumerable(Of String), _
    <OptionalAttribute> Optional regionName As String = Nothing, _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As CacheItemPolicy
C#
[ExtensionAttribute]
public static CacheItemPolicy GetCacheItemPolicy (
    ObjectCache cache,
    IEnumerable<string> dependencies,
    [OptionalAttribute] string regionName,
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
cache
dependencies
regionName
objectCacheName
Return Value
Type: CacheItemPolicy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.GetCacheItemPolicy Method (String)
[image]

Builds a CacheItemPolicy from a configuration element.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim objectCacheName As String
Dim returnValue As CacheItemPolicy

returnValue = ObjectCacheManager.GetCacheItemPolicy(objectCacheName)

Syntax

Visual Basic
Public Shared Function GetCacheItemPolicy ( _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As CacheItemPolicy
C#
public static CacheItemPolicy GetCacheItemPolicy (
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
objectCacheName
Return Value
Type: CacheItemPolicy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.GetChangeMonitor Method
[image]

Builds a CacheEntryChangeMonitor from a set of cache keys.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim monitorKeys As IEnumerable(Of String)
Dim regionName As String
Dim returnValue As CacheEntryChangeMonitor

returnValue = ObjectCacheManager.GetChangeMonitor(cache, monitorKeys, regionName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetChangeMonitor ( _
    cache As ObjectCache, _
    monitorKeys As IEnumerable(Of String), _
    regionName As String _
) As CacheEntryChangeMonitor
C#
[ExtensionAttribute]
public static CacheEntryChangeMonitor GetChangeMonitor (
    ObjectCache cache,
    IEnumerable<string> monitorKeys,
    string regionName
)
C++

J#

JScript

Parameters
cache
monitorKeys
regionName
Return Value
Type: CacheEntryChangeMonitor.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.GetInstance Method
[image]

Retrieves a configured ObjectCache.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim objectCacheName As String
Dim returnValue As ObjectCache

returnValue = ObjectCacheManager.GetInstance(objectCacheName)

Syntax

Visual Basic
Public Shared Function GetInstance ( _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As ObjectCache
C#
public static ObjectCache GetInstance (
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
objectCacheName
Return Value
Type: ObjectCache.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.Insert Method
[image]

Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
ObjectCacheManager.Insert (ObjectCache, String, Object, IEnumerable, String) | Inserts an object into cache along with an associated CacheItemDetail.
ObjectCacheManager.Insert (ObjectCache, String, Object, CacheItemPolicy, String) | Inserts an object into cache along with an associated CacheItemDetail.

See Also

Reference

ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.Insert Method (ObjectCache, String, Object, IEnumerable, String)
[image]

Inserts an object into cache along with an associated CacheItemDetail.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim cacheKey As String
Dim value As Object
Dim dependencies As IEnumerable(Of String)
Dim regionName As String

ObjectCacheManager.Insert(cache, cacheKey, value, dependencies, regionName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub Insert ( _
    cache As ObjectCache, _
    cacheKey As String, _
    value As Object, _
    dependencies As IEnumerable(Of String), _
    <OptionalAttribute> Optional regionName As String = Nothing _
)
C#
[ExtensionAttribute]
public static void Insert (
    ObjectCache cache,
    string cacheKey,
    Object value,
    IEnumerable<string> dependencies,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

Parameters
cache
cacheKey
value
dependencies
regionName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.Insert Method (ObjectCache, String, Object, CacheItemPolicy, String)
[image]

Inserts an object into cache along with an associated CacheItemDetail.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim cacheKey As String
Dim value As Object
Dim policy As CacheItemPolicy
Dim regionName As String

ObjectCacheManager.Insert(cache, cacheKey, value, policy, regionName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub Insert ( _
    cache As ObjectCache, _
    cacheKey As String, _
    value As Object, _
    <OptionalAttribute> Optional policy As CacheItemPolicy = Nothing, _
    <OptionalAttribute> Optional regionName As String = Nothing _
)
C#
[ExtensionAttribute]
public static void Insert (
    ObjectCache cache,
    string cacheKey,
    Object value,
    [OptionalAttribute] CacheItemPolicy policy,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

Parameters
cache
cacheKey
value
policy
regionName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheManager.RemoveAll Method
[image]

Removes all items from the cache by invoking the IExtendedObjectCache if it is available.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim regionName As String

ObjectCacheManager.RemoveAll(cache, regionName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveAll ( _
    cache As ObjectCache, _
    <OptionalAttribute> Optional regionName As String = Nothing _
)
C#
[ExtensionAttribute]
public static void RemoveAll (
    ObjectCache cache,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

Parameters
cache
regionName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheManager.Reset Method
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
ObjectCacheManager.Reset

Syntax

Visual Basic
Public Shared Sub Reset
C#
public static void Reset ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheManager Class
ObjectCacheManager Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider Class
See Also Members
[image]

Object cache provider. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider

Syntax

Visual Basic
Public Class ObjectCacheProvider
C#
public class ObjectCacheProvider
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Caching.ObjectCacheProvider
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheProvider Members
See Also Constructors Methods
[image]

Object cache provider. (Developer Extensions)

The following tables list the members exposed by the ObjectCacheProvider type.

Public Constructors

Name | Description
ObjectCacheProvider |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Clear |
public method | Equals | (inherited from Object)
public method | Get |
public method | GetCacheItemDetail |
public method | GetCacheItemPolicy | Overloaded.
public method | GetChangeMonitor |
public method | GetHashCode | (inherited from Object)
public method | GetInstance |
public method | GetType | (inherited from Object)
public method | Insert |
public method | RemoveAll |
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetCacheItemDetailCacheKey |
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

ObjectCacheProvider Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheProvider Constructor
[image]

Initializes a new instance of the ObjectCacheProvider Class.

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ObjectCacheProvider

Syntax

Visual Basic
Public Sub New
C#
public ObjectCacheProvider ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Clear |
public method | Equals | (inherited from Object)
public method | Get |
public method | GetCacheItemDetail |
public method | GetCacheItemPolicy | Overloaded.
public method | GetChangeMonitor |
public method | GetHashCode | (inherited from Object)
public method | GetInstance |
public method | GetType | (inherited from Object)
public method | Insert |
public method | RemoveAll |
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetCacheItemDetailCacheKey |
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

ObjectCacheProvider Class
Microsoft.Xrm.Client.Caching Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheProvider.Clear Method
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim cache As ObjectCache

instance.Clear(cache)

Syntax

Visual Basic
Public Overridable Sub Clear ( _
    cache As ObjectCache _
)
C#
public virtual void Clear (
    ObjectCache cache
)
C++

J#

JScript

Parameters
cache
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.Get Method
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim cache As ObjectCache
Dim cacheKey As String
Dim load As Func(Of ObjectCache, T)
Dim insert As Action(Of ObjectCache, T)
Dim regionName As String
Dim returnValue As T

returnValue = instance.Get(cache, cacheKey, load, insert, regionName)

Syntax

Visual Basic
Public Overridable Function Get(Of T) ( _
    cache As ObjectCache, _
    cacheKey As String, _
    load As Func(Of ObjectCache, T), _
    insert As Action(Of ObjectCache, T), _
    <OptionalAttribute> Optional regionName As String = Nothing _
) As T
C#
public virtual T Get<T> (
    ObjectCache cache,
    string cacheKey,
    Func<ObjectCache,T> load,
    Action<ObjectCache,T> insert,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

GenericParameters
T
Parameters
cache
cacheKey
load
insert
regionName
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.GetCacheItemDetail Method
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim cache As ObjectCache
Dim cacheKey As String
Dim regionName As String
Dim returnValue As CacheItemDetail

returnValue = instance.GetCacheItemDetail(cache, cacheKey, regionName)

Syntax

Visual Basic
Public Overridable Function GetCacheItemDetail ( _
    cache As ObjectCache, _
    cacheKey As String, _
    <OptionalAttribute> Optional regionName As String = Nothing _
) As CacheItemDetail
C#
public virtual CacheItemDetail GetCacheItemDetail (
    ObjectCache cache,
    string cacheKey,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

Parameters
cache
cacheKey
regionName
Return Value
Type: CacheItemDetail.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.GetCacheItemDetailCacheKey Method
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim cacheKey As String
Dim returnValue As String

returnValue = Me.GetCacheItemDetailCacheKey(cache, cacheKey)

Syntax

Visual Basic
Protected Overridable Function GetCacheItemDetailCacheKey ( _
    cache As ObjectCache, _
    cacheKey As String _
) As String
C#
protected virtual string GetCacheItemDetailCacheKey (
    ObjectCache cache,
    string cacheKey
)
C++

J#

JScript

Parameters
cache
cacheKey
Return Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.GetCacheItemPolicy Method
[image]

Overload List

Name | Description
ObjectCacheProvider.GetCacheItemPolicy (IEnumerable, String, String) |
ObjectCacheProvider.GetCacheItemPolicy (ChangeMonitor, String) |
ObjectCacheProvider.GetCacheItemPolicy (ObjectCache, IEnumerable, String, String) |
ObjectCacheProvider.GetCacheItemPolicy (String) |

See Also

Reference

ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.GetCacheItemPolicy Method (IEnumerable, String, String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim dependencies As IEnumerable(Of String)
Dim regionName As String
Dim objectCacheName As String
Dim returnValue As CacheItemPolicy

returnValue = instance.GetCacheItemPolicy(dependencies, regionName, objectCacheName)

Syntax

Visual Basic
Public Overridable Function GetCacheItemPolicy ( _
    dependencies As IEnumerable(Of String), _
    <OptionalAttribute> Optional regionName As String = Nothing, _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As CacheItemPolicy
C#
public virtual CacheItemPolicy GetCacheItemPolicy (
    IEnumerable<string> dependencies,
    [OptionalAttribute] string regionName,
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
dependencies
regionName
objectCacheName
Return Value
Type: CacheItemPolicy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.GetCacheItemPolicy Method (ChangeMonitor, String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim monitor As ChangeMonitor
Dim objectCacheName As String
Dim returnValue As CacheItemPolicy

returnValue = instance.GetCacheItemPolicy(monitor, objectCacheName)

Syntax

Visual Basic
Public Overridable Function GetCacheItemPolicy ( _
    monitor As ChangeMonitor, _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As CacheItemPolicy
C#
public virtual CacheItemPolicy GetCacheItemPolicy (
    ChangeMonitor monitor,
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
monitor
objectCacheName
Return Value
Type: CacheItemPolicy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.GetCacheItemPolicy Method (ObjectCache, IEnumerable, String, String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim cache As ObjectCache
Dim dependencies As IEnumerable(Of String)
Dim regionName As String
Dim objectCacheName As String
Dim returnValue As CacheItemPolicy

returnValue = instance.GetCacheItemPolicy(cache, dependencies, regionName, objectCacheName)

Syntax

Visual Basic
Public Overridable Function GetCacheItemPolicy ( _
    cache As ObjectCache, _
    dependencies As IEnumerable(Of String), _
    <OptionalAttribute> Optional regionName As String = Nothing, _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As CacheItemPolicy
C#
public virtual CacheItemPolicy GetCacheItemPolicy (
    ObjectCache cache,
    IEnumerable<string> dependencies,
    [OptionalAttribute] string regionName,
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
cache
dependencies
regionName
objectCacheName
Return Value
Type: CacheItemPolicy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.GetCacheItemPolicy Method (String)
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim objectCacheName As String
Dim returnValue As CacheItemPolicy

returnValue = instance.GetCacheItemPolicy(objectCacheName)

Syntax

Visual Basic
Public Overridable Function GetCacheItemPolicy ( _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As CacheItemPolicy
C#
public virtual CacheItemPolicy GetCacheItemPolicy (
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
objectCacheName
Return Value
Type: CacheItemPolicy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.GetChangeMonitor Method
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim cache As ObjectCache
Dim monitorKeys As IEnumerable(Of String)
Dim regionName As String
Dim returnValue As CacheEntryChangeMonitor

returnValue = instance.GetChangeMonitor(cache, monitorKeys, regionName)

Syntax

Visual Basic
Public Overridable Function GetChangeMonitor ( _
    cache As ObjectCache, _
    monitorKeys As IEnumerable(Of String), _
    regionName As String _
) As CacheEntryChangeMonitor
C#
public virtual CacheEntryChangeMonitor GetChangeMonitor (
    ObjectCache cache,
    IEnumerable<string> monitorKeys,
    string regionName
)
C++

J#

JScript

Parameters
cache
monitorKeys
regionName
Return Value
Type: CacheEntryChangeMonitor.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.GetInstance Method
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim objectCacheName As String
Dim returnValue As ObjectCache

returnValue = instance.GetInstance(objectCacheName)

Syntax

Visual Basic
Public Overridable Function GetInstance ( _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As ObjectCache
C#
public virtual ObjectCache GetInstance (
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
objectCacheName
Return Value
Type: ObjectCache.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.Insert Method
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim cache As ObjectCache
Dim cacheKey As String
Dim value As Object
Dim policy As CacheItemPolicy
Dim regionName As String

instance.Insert(cache, cacheKey, value, policy, regionName)

Syntax

Visual Basic
Public Overridable Sub Insert ( _
    cache As ObjectCache, _
    cacheKey As String, _
    value As Object, _
    <OptionalAttribute> Optional policy As CacheItemPolicy = Nothing, _
    <OptionalAttribute> Optional regionName As String = Nothing _
)
C#
public virtual void Insert (
    ObjectCache cache,
    string cacheKey,
    Object value,
    [OptionalAttribute] CacheItemPolicy policy,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

Parameters
cache
cacheKey
value
policy
regionName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


ObjectCacheProvider.RemoveAll Method
[image]

Namespace: Microsoft.Xrm.Client.Caching
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheProvider
Dim cache As ObjectCache
Dim regionName As String

instance.RemoveAll(cache, regionName)

Syntax

Visual Basic
Public Overridable Sub RemoveAll ( _
    cache As ObjectCache, _
    <OptionalAttribute> Optional regionName As String = Nothing _
)
C#
public virtual void RemoveAll (
    ObjectCache cache,
    [OptionalAttribute] string regionName
)
C++

J#

JScript

Parameters
cache
regionName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheProvider Class
ObjectCacheProvider Members
Microsoft.Xrm.Client.Caching Namespace


Microsoft.Xrm.Client.Collections.Generic Namespace

Classes

Class | Description
ArgumentDictionary | Implementation of an argument dictionary. (Developer Extensions)
ConnectionStringExtensions | Extensions to the connection string functionality. (Developer Extensions)
DictionaryExtensions | Extensions to the dictionary implementation. (Developer Extensions)


ArgumentDictionary Class
See Also Members
[image]

Implementation of an argument dictionary. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ArgumentDictionary

Syntax

Visual Basic
Public NotInheritable Class ArgumentDictionary
    Inherits Dictionary(Of String, String)
C#
public sealed class ArgumentDictionary : Dictionary<string,string>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Collections.Generic.Dictionary
    Microsoft.Xrm.Client.Collections.Generic.ArgumentDictionary
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDictionary Members
Microsoft.Xrm.Client.Collections.Generic Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ArgumentDictionary Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

Implementation of an argument dictionary. (Developer Extensions)

The following tables list the members exposed by the ArgumentDictionary type.

Public Constructors

Name | Description
ArgumentDictionary | Overloaded. Initializes a new instance of the ArgumentDictionary class.
Top

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | AddRange | Overloaded. Adds a range of arguments to the dictionary.
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | IsEnabled | Returns whether the argument is enabled.
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Top

See Also

Reference

ArgumentDictionary Class
Microsoft.Xrm.Client.Collections.Generic Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ArgumentDictionary Constructor
[image]

Initializes a new instance of the ArgumentDictionary class.

Overload List

Name | Description
ArgumentDictionary () | Initializes a new instance of the ArgumentDictionary class.
ArgumentDictionary (String[]) | Initializes a new instance of the ArgumentDictionary class.

See Also

Reference

ArgumentDictionary Class
ArgumentDictionary Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ArgumentDictionary Constructor ()
[image]

Initializes a new instance of the ArgumentDictionary class.

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ArgumentDictionary

Syntax

Visual Basic
Public Sub New
C#
public ArgumentDictionary ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDictionary Class
ArgumentDictionary Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ArgumentDictionary Constructor (String[])
[image]

Initializes a new instance of the ArgumentDictionary class.

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim args As String()

Dim instance As New ArgumentDictionary(args)

Syntax

Visual Basic
Public Sub New ( _
    ParamArray args As String() _
)
C#
public ArgumentDictionary (
    params string[] args
)
C++

J#

JScript

Parameters
args
Type: String[]. An array of string arguments.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDictionary Class
ArgumentDictionary Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ArgumentDictionary Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from Dictionary)
public method | AddRange | Overloaded. Adds a range of arguments to the dictionary.
public method | Clear | (inherited from Dictionary)
public method | ContainsKey | (inherited from Dictionary)
public method | ContainsValue | (inherited from Dictionary)
public method | Equals | (inherited from Object)
public method | GetEnumerator | (inherited from Dictionary)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | (inherited from Dictionary)
public method | GetType | (inherited from Object)
public method | IsEnabled | Returns whether the argument is enabled.
public method | OnDeserialization | (inherited from Dictionary)
public method | Remove | (inherited from Dictionary)
public method | ToString | (inherited from Object)
public method | TryGetValue | (inherited from Dictionary)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
CopyTo | (inherited from Dictionary)
Add | (inherited from Dictionary)
Contains | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)
Remove | (inherited from Dictionary)
GetEnumerator | (inherited from Dictionary)

See Also

Reference

ArgumentDictionary Class
Microsoft.Xrm.Client.Collections.Generic Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ArgumentDictionary.AddRange Method
[image]

Adds a range of arguments to the dictionary.

Overload List

Name | Description
ArgumentDictionary.AddRange (NameValueCollection) | Adds a range of arguments to the dictionary.
ArgumentDictionary.AddRange (String[]) | Adds a range of arguments to the dictionary.

See Also

Reference

ArgumentDictionary Class
ArgumentDictionary Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ArgumentDictionary.AddRange Method (NameValueCollection)
[image]

Adds a range of arguments to the dictionary.

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ArgumentDictionary
Dim items As NameValueCollection

instance.AddRange(items)

Syntax

Visual Basic
Public Sub AddRange ( _
    items As NameValueCollection _
)
C#
public void AddRange (
    NameValueCollection items
)
C++

J#

JScript

Parameters
items
Type: NameValueCollection. A collection of arguments to be added to the dictionary.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDictionary Class
ArgumentDictionary Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ArgumentDictionary.AddRange Method (String[])
[image]

Adds a range of arguments to the dictionary.

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ArgumentDictionary
Dim args As String()

instance.AddRange(args)

Syntax

Visual Basic
Public Sub AddRange ( _
    ParamArray args As String() _
)
C#
public void AddRange (
    params string[] args
)
C++

J#

JScript

Parameters
args
Type: String[]. An array of string arguments.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDictionary Class
ArgumentDictionary Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ArgumentDictionary.IsEnabled Method
[image]

Returns whether the argument is enabled.

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ArgumentDictionary
Dim key As String
Dim returnValue As Boolean

returnValue = instance.IsEnabled(key)

Syntax

Visual Basic
Public Function IsEnabled ( _
    key As String _
) As Boolean
C#
public bool IsEnabled (
    string key
)
C++

J#

JScript

Parameters
key
Type: String. The name of the argument to find in the dictionary.
Return Value
Type Boolean
true if the argument is enabled; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ArgumentDictionary Class
ArgumentDictionary Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ArgumentDictionary Properties
[image]

Public Properties

 | Name | Description
public property | Comparer | (inherited from Dictionary)
public property | Count | (inherited from Dictionary)
public property | Item | (inherited from Dictionary)
public property | Keys | (inherited from Dictionary)
public property | Values | (inherited from Dictionary)

Explicit Interface Implementations

Name | Description
IsReadOnly | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)
IsSynchronized | (inherited from Dictionary)
SyncRoot | (inherited from Dictionary)
IsFixedSize | (inherited from Dictionary)
IsReadOnly | (inherited from Dictionary)
Item | (inherited from Dictionary)
Keys | (inherited from Dictionary)
Values | (inherited from Dictionary)

See Also

Reference

ArgumentDictionary Class
Microsoft.Xrm.Client.Collections.Generic Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionStringExtensions Class
See Also Members
[image]

Extensions to the connection string functionality. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class ConnectionStringExtensions
C#
[ExtensionAttribute]
public static class ConnectionStringExtensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Collections.Generic.ConnectionStringExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionStringExtensions Members
Microsoft.Xrm.Client.Collections.Generic Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionStringExtensions Members
See Also Methods
[image]

Extensions to the connection string functionality. (Developer Extensions)

The following tables list the members exposed by the ConnectionStringExtensions type.

Public Methods (see also Extension Methods)

Name | Description
ToDictionary | Overloaded. Converts a set of connection strings to a dictionary.
ToDictionaryFromConnectionStringName | Converts a set of connection strings to a dictionary by connection string name.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

ConnectionStringExtensions Class
Microsoft.Xrm.Client.Collections.Generic Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionStringExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
ToDictionary | Overloaded. Converts a set of connection strings to a dictionary.
ToDictionaryFromConnectionStringName | Converts a set of connection strings to a dictionary by connection string name.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

ConnectionStringExtensions Class
Microsoft.Xrm.Client.Collections.Generic Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionStringExtensions.ToDictionary Method
[image]

Converts a set of connection strings to a dictionary.

Overload List

Name | Description
ConnectionStringExtensions.ToDictionary (ConnectionStringSettings) | Converts a set of connection strings to a dictionary.
ConnectionStringExtensions.ToDictionary (String) | Converts a set of connection strings to a dictionary.

See Also

Reference

ConnectionStringExtensions Class
ConnectionStringExtensions Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ConnectionStringExtensions.ToDictionary Method (ConnectionStringSettings)
[image]

Converts a set of connection strings to a dictionary.

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionString As ConnectionStringSettings
Dim returnValue As IDictionary(Of String, String)

returnValue = ConnectionStringExtensions.ToDictionary(connectionString)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToDictionary ( _
    connectionString As ConnectionStringSettings _
) As IDictionary(Of String, String)
C#
[ExtensionAttribute]
public static IDictionary<string,string> ToDictionary (
    ConnectionStringSettings connectionString
)
C++

J#

JScript

Parameters
connectionString
Type: ConnectionStringSettings. The connection string settings.
Return Value
Type: IDictionary<String, String>

The resulting dictionary.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionStringExtensions Class
ConnectionStringExtensions Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ConnectionStringExtensions.ToDictionary Method (String)
[image]

Converts a set of connection strings to a dictionary.

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionString As String
Dim returnValue As IDictionary(Of String, String)

returnValue = ConnectionStringExtensions.ToDictionary(connectionString)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToDictionary ( _
    connectionString As String _
) As IDictionary(Of String, String)
C#
[ExtensionAttribute]
public static IDictionary<string,string> ToDictionary (
    string connectionString
)
C++

J#

JScript

Parameters
connectionString
Type: String. The connection string.
Return Value
Type: IDictionary<String, String>

The resulting dictionary.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionStringExtensions Class
ConnectionStringExtensions Members
Microsoft.Xrm.Client.Collections.Generic Namespace


ConnectionStringExtensions.ToDictionaryFromConnectionStringName Method
[image]

Converts a set of connection strings to a dictionary by connection string name.

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionStringName As String
Dim returnValue As IDictionary(Of String, String)

returnValue = ConnectionStringExtensions.ToDictionaryFromConnectionStringName(connectionStringName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToDictionaryFromConnectionStringName ( _
    connectionStringName As String _
) As IDictionary(Of String, String)
C#
[ExtensionAttribute]
public static IDictionary<string,string> ToDictionaryFromConnectionStringName (
    string connectionStringName
)
C++

J#

JScript

Parameters
connectionStringName
Return Value
Type: IDictionary<String, String>

The resulting dictionary.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionStringExtensions Class
ConnectionStringExtensions Members
Microsoft.Xrm.Client.Collections.Generic Namespace


DictionaryExtensions Class
See Also Members
[image]

Extensions to the dictionary implementation. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class DictionaryExtensions
C#
[ExtensionAttribute]
public static class DictionaryExtensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Collections.Generic.DictionaryExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DictionaryExtensions Members
Microsoft.Xrm.Client.Collections.Generic Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DictionaryExtensions Members
See Also Methods
[image]

Extensions to the dictionary implementation. (Developer Extensions)

The following tables list the members exposed by the DictionaryExtensions type.

Public Methods (see also Extension Methods)

Name | Description
FirstNotNullOrDefault |
FirstNotNullOrEmpty |
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DictionaryExtensions Class
Microsoft.Xrm.Client.Collections.Generic Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DictionaryExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
FirstNotNullOrDefault |
FirstNotNullOrEmpty |

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DictionaryExtensions Class
Microsoft.Xrm.Client.Collections.Generic Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DictionaryExtensions.FirstNotNullOrDefault Method
[image]

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim dictionary As IDictionary(Of TKey, TValue)
Dim keys As TKey()
Dim returnValue As TValue

returnValue = DictionaryExtensions.FirstNotNullOrDefault(dictionary, keys)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function FirstNotNullOrDefault(Of TKey, TValue) ( _
    dictionary As IDictionary(Of TKey, TValue), _
    ParamArray keys As TKey() _
) As TValue
C#
[ExtensionAttribute]
public static TValue FirstNotNullOrDefault<TKey,TValue> (
    IDictionary<TKey,TValue> dictionary,
    params TKey[] keys
)
C++

J#

JScript

GenericParameters
TKey
The key.
TValue
The value.
Parameters
dictionary
Type: IDictionary<TKey, TValue>. The dictionary.
keys
Type: TKeys[]. An array of keys.
Return Value
Type: TValue

The entry that is not null or a default value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DictionaryExtensions Class
DictionaryExtensions Members
Microsoft.Xrm.Client.Collections.Generic Namespace


DictionaryExtensions.FirstNotNullOrEmpty Method
[image]

Namespace: Microsoft.Xrm.Client.Collections.Generic
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim dictionary As IDictionary(Of TKey, String)
Dim keys As TKey()
Dim returnValue As String

returnValue = DictionaryExtensions.FirstNotNullOrEmpty(dictionary, keys)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function FirstNotNullOrEmpty(Of TKey) ( _
    dictionary As IDictionary(Of TKey, String), _
    ParamArray keys As TKey() _
) As String
C#
[ExtensionAttribute]
public static string FirstNotNullOrEmpty<TKey> (
    IDictionary<TKey,string> dictionary,
    params TKey[] keys
)
C++

J#

JScript

GenericParameters
TKey
The key.
Parameters
dictionary
Type: IDictionary<TKey, TValue>. The dictionary.
keys
Type: TKeys[]. An array of keys.
Return Value
Type: String

The entry that is not null or empty.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DictionaryExtensions Class
DictionaryExtensions Members
Microsoft.Xrm.Client.Collections.Generic Namespace


Microsoft.Xrm.Client.Configuration Namespace

Classes

Class | Description
ConfigurationElementCollection | Contains a collection of configuration elements. (Developer Extensions)
CrmConfigurationManager | Configuration mangager for Microsoft Dynamics CRM Developer Extensions. (Developer Extensions)
CrmConfigurationProvider | Configuration provider. (Developer Extensions)
CrmConnectionStringSettingsCollection | Collection for connection string settings. (Developer Extensions)
CrmSection | Represents a collection of site configuration nodes and settings for all sites in general. (Developer Extensions)
CrmSectionCreatedEventArgs | Section created event arguments. (Developer Extensions)
InitializableConfigurationElement | Represents a configuration file element that can be initialized. (Developer Extensions)
ObjectCacheElement | Represents an object cache element. (Developer Extensions)
ObjectCacheElementCollection | Represents an object cache element collection. (Developer Extensions)
OrganizationServiceCacheElement | (Developer Extensions)
OrganizationServiceCacheElementCollection | (Developer Extensions)
OrganizationServiceContextElement | (Developer Extensions)
OrganizationServiceContextElementCollection | (Developer Extensions)
OrganizationServiceElement | (Developer Extensions)
OrganizationServiceElementCollection | (Developer Extensions)

Interfaces

Interface | Description
IInitializable | Interface to indicate that an object can be initialized. (Developer Extensions)

Enumerations

Enumeration | Description
ObjectCacheInstanceMode | (Developer Extensions)
OrganizationServiceInstanceMode | Contains values to specify how CrmConfigurationManager will adjust its instantiation behavior. (Developer Extensions)


ConfigurationElementCollection Generic Class
See Also Members
[image]

Contains a collection of configuration elements. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)

Syntax

Visual Basic
<DefaultMemberAttribute("Item")> _
Public MustInherit Class ConfigurationElementCollection(Of T As ConfigurationElement)
    Inherits ConfigurationElementCollection
C#
[DefaultMemberAttribute("Item")]
public abstract class ConfigurationElementCollection<T> : ConfigurationElementCollection where T : ConfigurationElement
C++

J#

JScript

GenericParameters
T
The type of elements in the collection.
  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                System.Configuration.ConfigurationElementCollection
      Microsoft.Xrm.Client.Configuration.ConfigurationElementCollection

                Microsoft.Xrm.Client.Configuration.CrmConnectionStringSettingsCollection

                Microsoft.Xrm.Client.Configuration.ObjectCacheElementCollection

                Microsoft.Xrm.Client.Configuration.OrganizationServiceCacheElementCollection

                Microsoft.Xrm.Client.Configuration.OrganizationServiceContextElementCollection

                Microsoft.Xrm.Client.Configuration.OrganizationServiceElementCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConfigurationElementCollection Members
See Also Methods Properties Constructors Explicit Interface Implementations
[image]

Contains a collection of configuration elements. (Developer Extensions)

The following tables list the members exposed by the ConfigurationElementCollection type.

Protected Constructors

Name | Description
ConfigurationElementCollection | Initializes a new instance of the ConfigurationElementCollection class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection
public property | CollectionName | Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element.
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Gets or sets the element with the specified key.
public property | Item | Gets or sets the element with the specified key.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name.
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection.
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add |
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default.
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position.
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only.
public method | Remove | Overloaded. Removes an element from the collection.
public method | RemoveAt | Removes the element at the specified position from the collection.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement.
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden.
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)
Top

See Also

Reference

ConfigurationElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConfigurationElementCollection Constructor
[image]

Initializes a new instance of the ConfigurationElementCollection class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ConfigurationElementCollection(Of T)

Syntax

Visual Basic
Protected Sub New
C#
protected ConfigurationElementCollection ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add |
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default.
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position.
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only.
public method | Remove | Overloaded. Removes an element from the collection.
public method | RemoveAt | Removes the element at the specified position from the collection.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement.
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden.
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)

See Also

Reference

ConfigurationElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConfigurationElementCollection.Add Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim element As T

instance.Add(element)

Syntax

Visual Basic
Public Sub Add ( _
    element As T _
)
C#
public void Add (
    T element
)
C++

J#

JScript

Parameters
element
Type: Type. The element to add to the collection.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.CreateNewElement Method
[image]

Creates a new ConfigurationElement.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim returnValue As ConfigurationElement

returnValue = Me.CreateNewElement

Syntax

Visual Basic
Protected Overrides Function CreateNewElement As ConfigurationElement
C#
protected override ConfigurationElement CreateNewElement ()
C++

J#

JScript

Return Value
Type: ConfigurationElement

The new configuration element.

  Remarks
Overrides CreateNewElement.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.GetElementKey Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim element As ConfigurationElement
Dim returnValue As Object

returnValue = Me.GetElementKey(element)

Syntax

Visual Basic
Protected Overrides Function GetElementKey ( _
    element As ConfigurationElement _
) As Object
C#
protected override Object GetElementKey (
    ConfigurationElement element
)
C++

J#

JScript

Parameters
element
Type: ConfigurationElement. The configuration element.
Return Value
Type: ConfigurationElement

The configuration element.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.GetElementOrDefault Method
[image]

Retrieves the selected element or falls back to the default.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim name As String
Dim allowDefaultFallback As Boolean
Dim returnValue As T

returnValue = instance.GetElementOrDefault(name, allowDefaultFallback)

Syntax

Visual Basic
Public Function GetElementOrDefault ( _
    name As String, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As T
C#
public T GetElementOrDefault (
    string name,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
name
Type: String. The name of element.
allowDefaultFallback
Type: Boolean. Whether to fall back to the default.
Return Value
Type: Type
The selected element.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.GetKey Method
[image]

Gets the key at the specified index position.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim index As Integer
Dim returnValue As String

returnValue = instance.GetKey(index)

Syntax

Visual Basic
Public Function GetKey ( _
    index As Integer _
) As String
C#
public string GetKey (
    int index
)
C++

J#

JScript

Parameters
index
Type: Int32. The index value.
Return Value
Type: String

The key.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.IsReadOnly Method
[image]

True if the collection is read only.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim returnValue As Boolean

returnValue = instance.IsReadOnly

Syntax

Visual Basic
Public Overrides Function IsReadOnly As Boolean
C#
public override bool IsReadOnly ()
C++

J#

JScript

Return Value
Type: Boolean
true if the collection is read only; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.Remove Method
[image]

Removes an element from the collection.

Overload List

Name | Description
ConfigurationElementCollection.Remove (T) | Removes an element from the collection.
ConfigurationElementCollection.Remove (String) | Removes an element from the collection.

See Also

Reference

ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.Remove Method (T)
[image]

Removes an element from the collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim element As T

instance.Remove(element)

Syntax

Visual Basic
Public Sub Remove ( _
    element As T _
)
C#
public void Remove (
    T element
)
C++

J#

JScript

Parameters
element
Type: Type. The element to remove.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.Remove Method (String)
[image]

Removes an element from the collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim name As String

instance.Remove(name)

Syntax

Visual Basic
Public Sub Remove ( _
    name As String _
)
C#
public void Remove (
    string name
)
C++

J#

JScript

Parameters
name
Type: String. The element to remove.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.RemoveAt Method
[image]

Removes the element at the specified position from the collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim index As Integer

instance.RemoveAt(index)

Syntax

Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
C#
public void RemoveAt (
    int index
)
C++

J#

JScript

Parameters
index
Type: Int32. The index value.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection
public property | CollectionName | Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element.
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Gets or sets the element with the specified key.
public property | Item | Gets or sets the element with the specified key.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name.
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection.
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)

See Also

Reference

ConfigurationElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConfigurationElementCollection.AllKeys Property
[image]

Gets all the keys in the ConfigurationElementCollection

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim value As Object()

value = instance.AllKeys

Syntax

Visual Basic
Public ReadOnly Property AllKeys As Object()
C#
public Object[] AllKeys { get; }
C++

J#

JScript

Property Value
Type: Object[]

The array of keys.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.CollectionName Property
[image]

Gets or sets the name of the element collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim value As String

value = instance.CollectionName

Syntax

Visual Basic
Public MustOverride ReadOnly Property CollectionName As String
C#
public abstract string CollectionName { get; }
C++

J#

JScript

Property Value
Type: String

The name of the collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.Current Property
[image]

Gets the selected or default element.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim value As T

value = instance.Current

Syntax

Visual Basic
Public ReadOnly Property Current As T
C#
public T Current { get; }
C++

J#

JScript

Property Value
Type: String

The selected or default element.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.Default Property
[image]

Gets or sets the default element name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim value As String

value = instance.Default

instance.Default = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("default", DefaultValue:=Nothing)> _
Public Property Default As String
C#
[ConfigurationPropertyAttribute("default", DefaultValue=null)]
public string Default { get; set; }
C++

J#

JScript

Property Value
Type: String

The name of the default element.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.ElementName Property
[image]

Gets the element name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As String

value = Me.ElementName

Syntax

Visual Basic
Protected Overrides ReadOnly Property ElementName As String
C#
protected override string ElementName { get; }
C++

J#

JScript

Property Value
Type: String

The name of the element.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.Item Property
[image]

Gets or sets the element with the specified key.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim index As Integer
Dim value As T

value = instance(index)

instance(index) = value

Syntax

Visual Basic
Public Default Property Item ( _
    index As Integer _
) As T
C#
public T this [
    int index
] { get; set; }
C++

J#

JScript

Parameters
index
Type: Int32. The value of the key.
Property Value
Type: Object

The specified element.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.Item Property
[image]

Gets or sets the element with the specified key.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConfigurationElementCollection(Of T)
Dim name As String
Dim value As T

value = instance(name)

Syntax

Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As T
C#
public T this [
    string name
] { get; }
C++

J#

JScript

Parameters
name
Type: String. The value of the key.
Property Value
Type: Object

The specified element.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ConfigurationElementCollection.Properties Property
[image]

Gets the property collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As ConfigurationPropertyCollection

value = Me.Properties

Syntax

Visual Basic
Protected Overrides ReadOnly Property Properties As ConfigurationPropertyCollection
C#
protected override ConfigurationPropertyCollection Properties { get; }
C++

J#

JScript

Property Value
Type: ConfigurationPropertyCollection

The property collection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConfigurationElementCollection Class
ConfigurationElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager Class
See Also Members
[image]

Configuration mangager for Microsoft Dynamics CRM Developer Extensions. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
Public NotInheritable Class CrmConfigurationManager
C#
public static class CrmConfigurationManager
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Configuration.CrmConfigurationManager
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConfigurationManager Members
See Also Methods
[image]

Configuration mangager for Microsoft Dynamics CRM Developer Extensions. (Developer Extensions)

The following tables list the members exposed by the CrmConfigurationManager type.

Public Methods (see also Extension Methods)

Name | Description
CreateCacheItemPolicy | Gets the configured CacheItemPolicy. (Developer Extensions)
CreateConnectionDictionary | Creates and caches connection strings by name.
CreateConnectionStringSettings | Creates and caches connection strings by name.
CreateContext | Retrieves the configured OrganizationServiceContext instance.
CreateObjectCache | Retrieves the configured ObjectCache instance.
CreateService | Overloaded. Retrieves the configured IOrganizationService instance.
CreateServiceCache | Overloaded. Retrieves the configured IOrganizationServiceCache instance.
GetConnectionStringNameFromContext | Retrieves the connection string name from the context name.
GetCrmSection | Retrieves the configuration section.
GetObjectCaches | Retrieves the cached ObjectCache objects.
Reset | Resets the cached dependencies.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

CrmConfigurationManager Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConfigurationManager Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
CreateCacheItemPolicy | Gets the configured CacheItemPolicy. (Developer Extensions)
CreateConnectionDictionary | Creates and caches connection strings by name.
CreateConnectionStringSettings | Creates and caches connection strings by name.
CreateContext | Retrieves the configured OrganizationServiceContext instance.
CreateObjectCache | Retrieves the configured ObjectCache instance.
CreateService | Overloaded. Retrieves the configured IOrganizationService instance.
CreateServiceCache | Overloaded. Retrieves the configured IOrganizationServiceCache instance.
GetConnectionStringNameFromContext | Retrieves the connection string name from the context name.
GetCrmSection | Retrieves the configuration section.
GetObjectCaches | Retrieves the cached ObjectCache objects.
Reset | Resets the cached dependencies.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CrmConfigurationManager Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConfigurationManager.CreateCacheItemPolicy Method
[image]

Gets the configured CacheItemPolicy. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim objectCacheName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As CacheItemPolicy

returnValue = CrmConfigurationManager.CreateCacheItemPolicy(objectCacheName, allowDefaultFallback)

Syntax

Visual Basic
Public Shared Function CreateCacheItemPolicy ( _
    <OptionalAttribute> Optional objectCacheName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As CacheItemPolicy
C#
public static CacheItemPolicy CreateCacheItemPolicy (
    [OptionalAttribute] string objectCacheName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
objectCacheName
Type: String. The cache name.
allowDefaultFallback
Type: Boolean. Whether to allow fallback to the default.
Return Value
Type: CacheItemPolicy
The configured policy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateConnectionDictionary Method
[image]

Creates and caches connection strings by name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionString As ConnectionStringSettings
Dim returnValue As IDictionary(Of String, String)

returnValue = CrmConfigurationManager.CreateConnectionDictionary(connectionString)

Syntax

Visual Basic
Public Shared Function CreateConnectionDictionary ( _
    connectionString As ConnectionStringSettings _
) As IDictionary(Of String, String)
C#
public static IDictionary<string,string> CreateConnectionDictionary (
    ConnectionStringSettings connectionString
)
C++

J#

JScript

Parameters
connectionString
Type: String. The connection string.
Return Value
Type: Returns_IDictionary<String, String>
The dictionary of cached connection strings.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateConnectionStringSettings Method
[image]

Creates and caches connection strings by name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionStringName As String
Dim returnValue As ConnectionStringSettings

returnValue = CrmConfigurationManager.CreateConnectionStringSettings(connectionStringName)

Syntax

Visual Basic
Public Shared Function CreateConnectionStringSettings ( _
    connectionStringName As String _
) As ConnectionStringSettings
C#
public static ConnectionStringSettings CreateConnectionStringSettings (
    string connectionStringName
)
C++

J#

JScript

Parameters
connectionStringName
Type: String. The connection string name.
Return Value
Type: ConnectionStringSettings
The connection string settings.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateContext Method
[image]

Retrieves the configured OrganizationServiceContext instance.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim contextName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As OrganizationServiceContext

returnValue = CrmConfigurationManager.CreateContext(contextName, allowDefaultFallback)

Syntax

Visual Basic
Public Shared Function CreateContext ( _
    <OptionalAttribute> Optional contextName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As OrganizationServiceContext
C#
public static OrganizationServiceContext CreateContext (
    [OptionalAttribute] string contextName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
contextName
Type: String. The context name.
allowDefaultFallback
Type: Boolean. Whether to allow fallback to the default.
Return Value
Type: OrganizationServiceContext
The configured context.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateObjectCache Method
[image]

Retrieves the configured ObjectCache instance.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim objectCacheName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As ObjectCache

returnValue = CrmConfigurationManager.CreateObjectCache(objectCacheName, allowDefaultFallback)

Syntax

Visual Basic
Public Shared Function CreateObjectCache ( _
    <OptionalAttribute> Optional objectCacheName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As ObjectCache
C#
public static ObjectCache CreateObjectCache (
    [OptionalAttribute] string objectCacheName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
objectCacheName
Type: String.
allowDefaultFallback
Type: Boolean. Whether to allow fallback to the default.
Return Value
Type ObjectCache
The configured cache instance.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateService Method
[image]

Retrieves the configured IOrganizationService instance.

Overload List

Name | Description
CrmConfigurationManager.CreateService (CrmConnection, String, Boolean) | Retrieves the configured IOrganizationService instance.
CrmConfigurationManager.CreateService (String, Boolean) | Retrieves the configured IOrganizationService instance.

See Also

Reference

CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateService Method (CrmConnection, String, Boolean)
[image]

Retrieves the configured IOrganizationService instance.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim serviceName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As IOrganizationService

returnValue = CrmConfigurationManager.CreateService(connection, serviceName, allowDefaultFallback)

Syntax

Visual Basic
Public Shared Function CreateService ( _
    connection As CrmConnection, _
    <OptionalAttribute> Optional serviceName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As IOrganizationService
C#
public static IOrganizationService CreateService (
    CrmConnection connection,
    [OptionalAttribute] string serviceName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
connection
serviceName
Type: String.
allowDefaultFallback
Type: Boolean. Whether to allow fallback to the default.
Return Value
Type: IOrganizationService.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateService Method (String, Boolean)
[image]

Retrieves the configured IOrganizationService instance.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim contextName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As IOrganizationService

returnValue = CrmConfigurationManager.CreateService(contextName, allowDefaultFallback)

Syntax

Visual Basic
Public Shared Function CreateService ( _
    <OptionalAttribute> Optional contextName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As IOrganizationService
C#
public static IOrganizationService CreateService (
    [OptionalAttribute] string contextName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
contextName
Type: String.
allowDefaultFallback
Type: Boolean. Whether to allow fallback to the default.
Return Value
Type: IOrganizationService.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateServiceCache Method
[image]

Retrieves the configured IOrganizationServiceCache instance.

Overload List

Name | Description
CrmConfigurationManager.CreateServiceCache (String, CrmConnection, Boolean) | Retrieves the configured IOrganizationServiceCache instance.
CrmConfigurationManager.CreateServiceCache (String, String, Boolean) | Retrieves the configured IOrganizationServiceCache instance.

See Also

Reference

CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateServiceCache Method (String, CrmConnection, Boolean)
[image]

Retrieves the configured IOrganizationServiceCache instance.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim serviceCacheName As String
Dim connection As CrmConnection
Dim allowDefaultFallback As Boolean
Dim returnValue As IOrganizationServiceCache

returnValue = CrmConfigurationManager.CreateServiceCache(serviceCacheName, connection, allowDefaultFallback)

Syntax

Visual Basic
Public Shared Function CreateServiceCache ( _
    serviceCacheName As String, _
    connection As CrmConnection, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As IOrganizationServiceCache
C#
public static IOrganizationServiceCache CreateServiceCache (
    string serviceCacheName,
    CrmConnection connection,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
serviceCacheName
Type: String.
connection
allowDefaultFallback
Type: Boolean. Whether to allow fallback to the default.
Return Value
Type: IOrganizationServiceCache.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.CreateServiceCache Method (String, String, Boolean)
[image]

Retrieves the configured IOrganizationServiceCache instance.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim serviceCacheName As String
Dim connectionId As String
Dim allowDefaultFallback As Boolean
Dim returnValue As IOrganizationServiceCache

returnValue = CrmConfigurationManager.CreateServiceCache(serviceCacheName, connectionId, allowDefaultFallback)

Syntax

Visual Basic
Public Shared Function CreateServiceCache ( _
    <OptionalAttribute> Optional serviceCacheName As String = Nothing, _
    <OptionalAttribute> Optional connectionId As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As IOrganizationServiceCache
C#
public static IOrganizationServiceCache CreateServiceCache (
    [OptionalAttribute] string serviceCacheName,
    [OptionalAttribute] string connectionId,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
serviceCacheName
Type: String.
connectionId
allowDefaultFallback
Type: Boolean. Whether to allow fallback to the default.
Return Value
Type: IOrganizationServiceCache.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.GetConnectionStringNameFromContext Method
[image]

Retrieves the connection string name from the context name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim contextName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As String

returnValue = CrmConfigurationManager.GetConnectionStringNameFromContext(contextName, allowDefaultFallback)

Syntax

Visual Basic
Public Shared Function GetConnectionStringNameFromContext ( _
    contextName As String, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As String
C#
public static string GetConnectionStringNameFromContext (
    string contextName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
contextName
Type: String.
allowDefaultFallback
Type: Boolean. Whether to allow fallback to the default.
Return Value
Type: String

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.GetCrmSection Method
[image]

Retrieves the configuration section.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim returnValue As CrmSection

returnValue = CrmConfigurationManager.GetCrmSection

Syntax

Visual Basic
Public Shared Function GetCrmSection As CrmSection
C#
public static CrmSection GetCrmSection ()
C++

J#

JScript

Return Value
Type: CrmSection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.GetObjectCaches Method
[image]

Retrieves the cached ObjectCache objects.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim name As String
Dim returnValue As IEnumerable(Of ObjectCache)

returnValue = CrmConfigurationManager.GetObjectCaches(name)

Syntax

Visual Basic
Public Shared Function GetObjectCaches ( _
    <OptionalAttribute> Optional name As String = Nothing _
) As IEnumerable(Of ObjectCache)
C#
public static IEnumerable<ObjectCache> GetObjectCaches (
    [OptionalAttribute] string name
)
C++

J#

JScript

Parameters
name
Type: String.
Return Value
Type: IEnumerable.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationManager.Reset Method
[image]

Resets the cached dependencies.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
CrmConfigurationManager.Reset

Syntax

Visual Basic
Public Shared Sub Reset
C#
public static void Reset ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationManager Class
CrmConfigurationManager Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider Class
See Also Members
[image]

Configuration provider. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider

Syntax

Visual Basic
Public Class CrmConfigurationProvider
C#
public class CrmConfigurationProvider
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Configuration.CrmConfigurationProvider
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConfigurationProvider Members
See Also Constructors Events Methods
[image]

Configuration provider. (Developer Extensions)

The following tables list the members exposed by the CrmConfigurationProvider type.

Public Constructors

Name | Description
CrmConfigurationProvider | Initializes an instance of the CrmConfigurationProvider class.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | CreateCacheItemPolicy |
public method | CreateConnectionDictionary |
public method | CreateConnectionStringSettings |
public method | CreateContext |
public method | CreateObjectCache |
public method | CreateService | Overloaded.
public method | CreateServiceCache | Overloaded.
public method | Equals | (inherited from Object)
public method | GetConnectionStringNameFromContext |
public method | GetCrmSection |
public method | GetHashCode | (inherited from Object)
public method | GetObjectCaches |
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Public Events

Name | Description
ConfigurationCreated |
Top

See Also

Reference

CrmConfigurationProvider Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConfigurationProvider Constructor
[image]

Initializes an instance of the CrmConfigurationProvider class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New CrmConfigurationProvider

Syntax

Visual Basic
Public Sub New
C#
public CrmConfigurationProvider ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | CreateCacheItemPolicy |
public method | CreateConnectionDictionary |
public method | CreateConnectionStringSettings |
public method | CreateContext |
public method | CreateObjectCache |
public method | CreateService | Overloaded.
public method | CreateServiceCache | Overloaded.
public method | Equals | (inherited from Object)
public method | GetConnectionStringNameFromContext |
public method | GetCrmSection |
public method | GetHashCode | (inherited from Object)
public method | GetObjectCaches |
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CrmConfigurationProvider Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConfigurationProvider.CreateCacheItemPolicy Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim objectCacheName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As CacheItemPolicy

returnValue = instance.CreateCacheItemPolicy(objectCacheName, allowDefaultFallback)

Syntax

Visual Basic
Public Overridable Function CreateCacheItemPolicy ( _
    <OptionalAttribute> Optional objectCacheName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As CacheItemPolicy
C#
public virtual CacheItemPolicy CreateCacheItemPolicy (
    [OptionalAttribute] string objectCacheName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
objectCacheName
allowDefaultFallback
Return Value
Type: CacheItemPolicy
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateConnectionDictionary Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim connectionString As ConnectionStringSettings
Dim returnValue As IDictionary(Of String, String)

returnValue = instance.CreateConnectionDictionary(connectionString)

Syntax

Visual Basic
Public Overridable Function CreateConnectionDictionary ( _
    connectionString As ConnectionStringSettings _
) As IDictionary(Of String, String)
C#
public virtual IDictionary<string,string> CreateConnectionDictionary (
    ConnectionStringSettings connectionString
)
C++

J#

JScript

Parameters
connectionString
Return Value
Type: IDictionary<String, String>
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateConnectionStringSettings Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim connectionStringName As String
Dim returnValue As ConnectionStringSettings

returnValue = instance.CreateConnectionStringSettings(connectionStringName)

Syntax

Visual Basic
Public Overridable Function CreateConnectionStringSettings ( _
    connectionStringName As String _
) As ConnectionStringSettings
C#
public virtual ConnectionStringSettings CreateConnectionStringSettings (
    string connectionStringName
)
C++

J#

JScript

Parameters
connectionStringName
Return Value
Type ConnectionStringSettings
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateContext Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim contextName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As OrganizationServiceContext

returnValue = instance.CreateContext(contextName, allowDefaultFallback)

Syntax

Visual Basic
Public Overridable Function CreateContext ( _
    <OptionalAttribute> Optional contextName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As OrganizationServiceContext
C#
public virtual OrganizationServiceContext CreateContext (
    [OptionalAttribute] string contextName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
contextName
allowDefaultFallback
Return Value
Type: OrganizationServiceContext
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateObjectCache Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim objectCacheName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As ObjectCache

returnValue = instance.CreateObjectCache(objectCacheName, allowDefaultFallback)

Syntax

Visual Basic
Public Overridable Function CreateObjectCache ( _
    <OptionalAttribute> Optional objectCacheName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As ObjectCache
C#
public virtual ObjectCache CreateObjectCache (
    [OptionalAttribute] string objectCacheName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
objectCacheName
allowDefaultFallback
Return Value
Type: ObjectCache
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateService Method
[image]

Overload List

Name | Description
CrmConfigurationProvider.CreateService (CrmConnection, String, Boolean) |
CrmConfigurationProvider.CreateService (String, Boolean) |

See Also

Reference

CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateService Method (CrmConnection, String, Boolean)
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim connection As CrmConnection
Dim serviceName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As IOrganizationService

returnValue = instance.CreateService(connection, serviceName, allowDefaultFallback)

Syntax

Visual Basic
Public Overridable Function CreateService ( _
    connection As CrmConnection, _
    <OptionalAttribute> Optional serviceName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As IOrganizationService
C#
public virtual IOrganizationService CreateService (
    CrmConnection connection,
    [OptionalAttribute] string serviceName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
connection
serviceName
allowDefaultFallback
Return Value
Type: IOrganizationService
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateService Method (String, Boolean)
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim contextName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As IOrganizationService

returnValue = instance.CreateService(contextName, allowDefaultFallback)

Syntax

Visual Basic
Public Overridable Function CreateService ( _
    <OptionalAttribute> Optional contextName As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As IOrganizationService
C#
public virtual IOrganizationService CreateService (
    [OptionalAttribute] string contextName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
contextName
allowDefaultFallback
Return Value
Type: IOrganizationService
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateServiceCache Method
[image]

Overload List

Name | Description
CrmConfigurationProvider.CreateServiceCache (String, CrmConnection, Boolean) |
CrmConfigurationProvider.CreateServiceCache (String, String, Boolean) |

See Also

Reference

CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateServiceCache Method (String, CrmConnection, Boolean)
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim serviceCacheName As String
Dim connection As CrmConnection
Dim allowDefaultFallback As Boolean
Dim returnValue As IOrganizationServiceCache

returnValue = instance.CreateServiceCache(serviceCacheName, connection, allowDefaultFallback)

Syntax

Visual Basic
Public Overridable Function CreateServiceCache ( _
    serviceCacheName As String, _
    connection As CrmConnection, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As IOrganizationServiceCache
C#
public virtual IOrganizationServiceCache CreateServiceCache (
    string serviceCacheName,
    CrmConnection connection,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
serviceCacheName
connection
allowDefaultFallback
Return Value
Type: IOrganizationServiceCache
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.CreateServiceCache Method (String, String, Boolean)
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim serviceCacheName As String
Dim connectionId As String
Dim allowDefaultFallback As Boolean
Dim returnValue As IOrganizationServiceCache

returnValue = instance.CreateServiceCache(serviceCacheName, connectionId, allowDefaultFallback)

Syntax

Visual Basic
Public Overridable Function CreateServiceCache ( _
    <OptionalAttribute> Optional serviceCacheName As String = Nothing, _
    <OptionalAttribute> Optional connectionId As String = Nothing, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As IOrganizationServiceCache
C#
public virtual IOrganizationServiceCache CreateServiceCache (
    [OptionalAttribute] string serviceCacheName,
    [OptionalAttribute] string connectionId,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
serviceCacheName
connectionId
allowDefaultFallback
Return Value
Type: IOrganizationServiceCache
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.GetConnectionStringNameFromContext Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim contextName As String
Dim allowDefaultFallback As Boolean
Dim returnValue As String

returnValue = instance.GetConnectionStringNameFromContext(contextName, allowDefaultFallback)

Syntax

Visual Basic
Public Overridable Function GetConnectionStringNameFromContext ( _
    contextName As String, _
    <OptionalAttribute> Optional allowDefaultFallback As Boolean = False _
) As String
C#
public virtual string GetConnectionStringNameFromContext (
    string contextName,
    [OptionalAttribute] bool allowDefaultFallback
)
C++

J#

JScript

Parameters
contextName
allowDefaultFallback
Return Value
Type:  String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.GetCrmSection Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim returnValue As CrmSection

returnValue = instance.GetCrmSection

Syntax

Visual Basic
Public Overridable Function GetCrmSection As CrmSection
C#
public virtual CrmSection GetCrmSection ()
C++

J#

JScript

Return Value
Type: CrmSection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider.GetObjectCaches Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConfigurationProvider
Dim name As String
Dim returnValue As IEnumerable(Of ObjectCache)

returnValue = instance.GetObjectCaches(name)

Syntax

Visual Basic
Public Overridable Function GetObjectCaches ( _
    <OptionalAttribute> Optional name As String = Nothing _
) As IEnumerable(Of ObjectCache)
C#
public virtual IEnumerable<ObjectCache> GetObjectCaches (
    [OptionalAttribute] string name
)
C++

J#

JScript

Parameters
name
Return Value
Type: IEnumerable<ObjectCache>.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConfigurationProvider Events
[image]

Public Events

Name | Description
ConfigurationCreated |

See Also

Reference

CrmConfigurationProvider Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConfigurationProvider.ConfigurationCreated Event
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim handler As EventHandler(Of CrmSectionCreatedEventArgs)

AddHandler CrmConfigurationProvider.ConfigurationCreated, handler

Syntax

Visual Basic
Public Shared Event ConfigurationCreated As EventHandler(Of CrmSectionCreatedEventArgs)
C#
public static event EventHandler<CrmSectionCreatedEventArgs> ConfigurationCreated
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConfigurationProvider Class
CrmConfigurationProvider Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConnectionStringSettingsCollection Class
See Also Members
[image]

Collection for connection string settings. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnectionStringSettingsCollection

Syntax

Visual Basic
<ConfigurationCollectionAttribute(GetType(ConnectionStringSettings))> _
Public NotInheritable Class CrmConnectionStringSettingsCollection
    Inherits ConfigurationElementCollection(Of ConnectionStringSettings)
C#
[ConfigurationCollectionAttribute(typeof(ConnectionStringSettings))]
public sealed class CrmConnectionStringSettingsCollection : ConfigurationElementCollection<ConnectionStringSettings>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                System.Configuration.ConfigurationElementCollection

                Microsoft.Xrm.Client.Configuration.ConfigurationElementCollection
        Microsoft.Xrm.Client.Configuration.CrmConnectionStringSettingsCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnectionStringSettingsCollection Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmConnectionStringSettingsCollection Members
See Also Constructors Fields Methods Properties Explicit Interface Implementations
[image]

Collection for connection string settings. (Developer Extensions)

The following tables list the members exposed by the CrmConnectionStringSettingsCollection type.

Public Constructors

Name | Description
CrmConnectionStringSettingsCollection | Initializes a new instance of the CrmConnectionStringSettingsCollection class.
Top

Public Fields

Name | Description
Name |
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)
Top

See Also

Reference

CrmConnectionStringSettingsCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConnectionStringSettingsCollection Fields
[image]

Public Fields

Name | Description
Name |

See Also

Reference

CrmConnectionStringSettingsCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConnectionStringSettingsCollection.Name Field
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As String

value = CrmConnectionStringSettingsCollection.Name

Syntax

Visual Basic
Public Const Name As String
C#
public const string Name
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnectionStringSettingsCollection Class
CrmConnectionStringSettingsCollection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConnectionStringSettingsCollection Constructor
[image]

Initializes a new instance of the CrmConnectionStringSettingsCollection class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New CrmConnectionStringSettingsCollection

Syntax

Visual Basic
Public Sub New
C#
public CrmConnectionStringSettingsCollection ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnectionStringSettingsCollection Class
CrmConnectionStringSettingsCollection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmConnectionStringSettingsCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)

See Also

Reference

CrmConnectionStringSettingsCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConnectionStringSettingsCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)

See Also

Reference

CrmConnectionStringSettingsCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmConnectionStringSettingsCollection.CollectionName Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmConnectionStringSettingsCollection
Dim value As String

value = instance.CollectionName

Syntax

Visual Basic
Public Overrides ReadOnly Property CollectionName As String
C#
public override string CollectionName { get; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmConnectionStringSettingsCollection Class
CrmConnectionStringSettingsCollection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection Class
See Also Members
[image]

Represents a collection of site configuration nodes and settings for all sites in general. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection

Syntax

Visual Basic
Public NotInheritable Class CrmSection
    Inherits ConfigurationSection
C#
public sealed class CrmSection : ConfigurationSection
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                System.Configuration.ConfigurationSection
      Microsoft.Xrm.Client.Configuration.CrmSection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Configure the Context with the Configuration File


CrmSection Members
See Also Constructors Fields Methods Properties
[image]

Represents a collection of site configuration nodes and settings for all sites in general. (Developer Extensions)

The following tables list the members exposed by the CrmSection type.

Public Constructors

Name | Description
CrmSection | Initializes a new instance of the CrmSection class.
Top

Public Fields

Name | Description
SectionName | The element name of the section.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ConfigurationProviderType |
public property | ConnectionStrings |
public property | Contexts |
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | LockProviderType |
public property | MutexTimeout |
public property | ObjectCache |
public property | ObjectCacheProviderType |
public property | SectionInformation | (inherited from ConfigurationSection)
public property | ServiceCache |
public property | Services |
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

CrmSection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Configure the Context with the Configuration File


CrmSection Fields
[image]

Public Fields

Name | Description
SectionName | The element name of the section.

See Also

Reference

CrmSection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Configure the Context with the Configuration File


CrmSection.SectionName Field
[image]

The element name of the section.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As String

value = CrmSection.SectionName

Syntax

Visual Basic
Public Const SectionName As String
C#
public const string SectionName
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection Constructor
[image]

Initializes a new instance of the CrmSection class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New CrmSection

Syntax

Visual Basic
Public Sub New
C#
public CrmSection ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CrmSection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Configure the Context with the Configuration File


CrmSection.IsReadOnly Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim returnValue As Boolean

returnValue = instance.IsReadOnly

Syntax

Visual Basic
Public Overrides Function IsReadOnly As Boolean
C#
public override bool IsReadOnly ()
C++

J#

JScript

Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ConfigurationProviderType |
public property | ConnectionStrings |
public property | Contexts |
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | LockProviderType |
public property | MutexTimeout |
public property | ObjectCache |
public property | ObjectCacheProviderType |
public property | SectionInformation | (inherited from ConfigurationSection)
public property | ServiceCache |
public property | Services |

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)

See Also

Reference

CrmSection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Configure the Context with the Configuration File


CrmSection.ConfigurationProviderType Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim value As String

value = instance.ConfigurationProviderType

instance.ConfigurationProviderType = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("sectionProviderType", DefaultValue:="Microsoft.Xrm.Client.Configuration.CrmConfigurationProvider, Microsoft.Xrm.Client")> _
Public Property ConfigurationProviderType As String
C#
[ConfigurationPropertyAttribute("sectionProviderType", DefaultValue="Microsoft.Xrm.Client.Configuration.CrmConfigurationProvider, Microsoft.Xrm.Client")]
public string ConfigurationProviderType { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection.ConnectionStrings Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim value As CrmConnectionStringSettingsCollection

value = instance.ConnectionStrings

instance.ConnectionStrings = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("connectionStrings")> _
Public Property ConnectionStrings As CrmConnectionStringSettingsCollection
C#
[ConfigurationPropertyAttribute("connectionStrings")]
public CrmConnectionStringSettingsCollection ConnectionStrings { get; set; }
C++

J#

JScript

Property Value
Type: CrmConnectionStringSettingsCollection
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmSection.Contexts Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim value As OrganizationServiceContextElementCollection

value = instance.Contexts

instance.Contexts = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("contexts", IsDefaultCollection:=False, IsRequired:=True)> _
Public Property Contexts As OrganizationServiceContextElementCollection
C#
[ConfigurationPropertyAttribute("contexts", IsDefaultCollection=false, IsRequired=true)]
public OrganizationServiceContextElementCollection Contexts { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceContextElementCollection
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection.LockProviderType Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim value As String

value = instance.LockProviderType

instance.LockProviderType = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("mutexProviderType", DefaultValue:="Microsoft.Xrm.Client.Threading.MutexLockProvider, Microsoft.Xrm.Client")> _
Public Property LockProviderType As String
C#
[ConfigurationPropertyAttribute("mutexProviderType", DefaultValue="Microsoft.Xrm.Client.Threading.MutexLockProvider, Microsoft.Xrm.Client")]
public string LockProviderType { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection.MutexTimeout Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim value As Nullable(Of TimeSpan)

value = instance.MutexTimeout

instance.MutexTimeout = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("mutexTimeout")> _
Public Property MutexTimeout As Nullable(Of TimeSpan)
C#
[ConfigurationPropertyAttribute("mutexTimeout")]
public Nullable<TimeSpan> MutexTimeout { get; set; }
C++

J#

JScript

Property Value
Type: TimeSpan
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection.ObjectCache Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim value As ObjectCacheElementCollection

value = instance.ObjectCache

instance.ObjectCache = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("objectCache")> _
Public Property ObjectCache As ObjectCacheElementCollection
C#
[ConfigurationPropertyAttribute("objectCache")]
public ObjectCacheElementCollection ObjectCache { get; set; }
C++

J#

JScript

Property Value
Type: ObjectCacheElementCollection
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection.ObjectCacheProviderType Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim value As String

value = instance.ObjectCacheProviderType

instance.ObjectCacheProviderType = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("objectCacheProviderType", DefaultValue:="Microsoft.Xrm.Client.Caching.ObjectCacheProvider, Microsoft.Xrm.Client")> _
Public Property ObjectCacheProviderType As String
C#
[ConfigurationPropertyAttribute("objectCacheProviderType", DefaultValue="Microsoft.Xrm.Client.Caching.ObjectCacheProvider, Microsoft.Xrm.Client")]
public string ObjectCacheProviderType { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection.ServiceCache Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim value As OrganizationServiceCacheElementCollection

value = instance.ServiceCache

instance.ServiceCache = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("serviceCache")> _
Public Property ServiceCache As OrganizationServiceCacheElementCollection
C#
[ConfigurationPropertyAttribute("serviceCache")]
public OrganizationServiceCacheElementCollection ServiceCache { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceCacheElementCollection
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSection.Services Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSection
Dim value As OrganizationServiceElementCollection

value = instance.Services

instance.Services = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("services")> _
Public Property Services As OrganizationServiceElementCollection
C#
[ConfigurationPropertyAttribute("services")]
public OrganizationServiceElementCollection Services { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceElementCollection
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSection Class
CrmSection Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSectionCreatedEventArgs Class
See Also Members
[image]

Section created event arguments. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSectionCreatedEventArgs

Syntax

Visual Basic
Public Class CrmSectionCreatedEventArgs
    Inherits EventArgs
C#
public class CrmSectionCreatedEventArgs : EventArgs
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.EventArgs
    Microsoft.Xrm.Client.Configuration.CrmSectionCreatedEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSectionCreatedEventArgs Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmSectionCreatedEventArgs Members
See Also Constructors Methods Properties
[image]

Section created event arguments. (Developer Extensions)

The following tables list the members exposed by the CrmSectionCreatedEventArgs type.

Public Constructors

Name | Description
CrmSectionCreatedEventArgs |
Top

Public Properties

 | Name | Description
public property | Configuration |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

CrmSectionCreatedEventArgs Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmSectionCreatedEventArgs Constructor
[image]

Initializes a new instance of the CrmSectionCreatedEventArgs Class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New CrmSectionCreatedEventArgs

Syntax

Visual Basic
Public Sub New
C#
public CrmSectionCreatedEventArgs ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSectionCreatedEventArgs Class
CrmSectionCreatedEventArgs Members
Microsoft.Xrm.Client.Configuration Namespace


CrmSectionCreatedEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CrmSectionCreatedEventArgs Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmSectionCreatedEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | Configuration |

See Also

Reference

CrmSectionCreatedEventArgs Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmSectionCreatedEventArgs.Configuration Property
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmSectionCreatedEventArgs
Dim value As CrmSection

value = instance.Configuration

instance.Configuration = value

Syntax

Visual Basic
Public Property Configuration As CrmSection
C#
public CrmSection Configuration { get; set; }
C++

J#

JScript

Property Value
Type: CrmSection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmSectionCreatedEventArgs Class
CrmSectionCreatedEventArgs Members
Microsoft.Xrm.Client.Configuration Namespace


IInitializable Interface
See Also Members
[image]

Interface to indicate that an object can be initialized. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IInitializable

Syntax

Visual Basic
Public Interface IInitializable
C#
public interface IInitializable
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IInitializable Members
Microsoft.Xrm.Client.Configuration Namespace


IInitializable Members
See Also Methods
[image]

Interface to indicate that an object can be initialized. (Developer Extensions)

The following tables list the members exposed by the IInitializable type.

Public Methods

 | Name | Description
public method | Initialize |
Top

See Also

Reference

IInitializable Interface
Microsoft.Xrm.Client.Configuration Namespace


IInitializable Methods
[image]

Public Methods

 | Name | Description
public method | Initialize |

See Also

Reference

IInitializable Interface
Microsoft.Xrm.Client.Configuration Namespace


IInitializable.Initialize Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IInitializable
Dim name As String
Dim config As NameValueCollection

instance.Initialize(name, config)

Syntax

Visual Basic
Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
C#
void Initialize (
    string name,
    NameValueCollection config
)
C++

J#

JScript

Parameters
name
config
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IInitializable Interface
IInitializable Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement Generic Class
See Also Members
[image]

Represents a configuration file element that can be initialized. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As InitializableConfigurationElement(Of TDependency)

Syntax

Visual Basic
Public MustInherit Class InitializableConfigurationElement(Of TDependency)
    Inherits ConfigurationElement
C#
public abstract class InitializableConfigurationElement<TDependency> : ConfigurationElement
C++

J#

JScript

GenericParameters
TDependency
  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement
    Microsoft.Xrm.Client.Configuration.InitializableConfigurationElement

                Microsoft.Xrm.Client.Configuration.ObjectCacheElement

                Microsoft.Xrm.Client.Configuration.OrganizationServiceCacheElement

                Microsoft.Xrm.Client.Configuration.OrganizationServiceContextElement

                Microsoft.Xrm.Client.Configuration.OrganizationServiceElement
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


InitializableConfigurationElement Members
See Also Methods Properties Constructors
[image]

Represents a configuration file element that can be initialized. (Developer Extensions)

The following tables list the members exposed by the InitializableConfigurationElement type.

Protected Constructors

Name | Description
InitializableConfigurationElement | Initializes a new instance of the InitializableConfigurationElement class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | The name of the configuration element.
public property | Parameters | The attributes of the configuration element.
public property | Type | The dependency type name.
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize |
public method | IsReadOnly | Overridden.
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object.
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded.
protected method | CreateDependencyAndInitialize | Overloaded.
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType |
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden.
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden.
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

InitializableConfigurationElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


InitializableConfigurationElement Constructor
[image]

Initializes a new instance of the InitializableConfigurationElement class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New InitializableConfigurationElement(Of TDependency)

Syntax

Visual Basic
Protected Sub New
C#
protected InitializableConfigurationElement ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize |
public method | IsReadOnly | Overridden.
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object.

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded.
protected method | CreateDependencyAndInitialize | Overloaded.
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType |
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden.
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden.
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

InitializableConfigurationElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


InitializableConfigurationElement.AddConfig Method
[image]

Adds a setting.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As InitializableConfigurationElement(Of TDependency)
Dim name As String
Dim value As String

instance.AddConfig(name, value)

Syntax

Visual Basic
Public Sub AddConfig ( _
    name As String, _
    value As String _
)
C#
public void AddConfig (
    string name,
    string value
)
C++

J#

JScript

Parameters
name
value
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.CreateDependency Method
[image]

Overload List

Name | Description
InitializableConfigurationElement.CreateDependency (Func, Object[]) |
InitializableConfigurationElement.CreateDependency (Func, Object[], Func, Object[]) |

See Also

Reference

InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.CreateDependency Method (Func, Object[])
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim createDefault As Func(Of TDefault)
Dim args As Object()
Dim returnValue As TDependency

returnValue = Me.CreateDependency(createDefault, args)

Syntax

Visual Basic
Protected Function CreateDependency(Of TDefault As TDependency) ( _
    createDefault As Func(Of TDefault), _
    ParamArray args As Object() _
) As TDependency
C#
protected TDependency CreateDependency<TDefault> (
    Func<TDefault> createDefault,
    params Object[] args
) where TDefault : TDependency
C++

J#

JScript

GenericParameters
TDefault
Parameters
createDefault
args
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.CreateDependency Method (Func, Object[], Func, Object[])
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim createDefault1 As Func(Of TDefault1)
Dim args1 As Object()
Dim createDefault2 As Func(Of TDefault2)
Dim args2 As Object()
Dim returnValue As TDependency

returnValue = Me.CreateDependency(createDefault1, args1, createDefault2, args2)

Syntax

Visual Basic
Protected Function CreateDependency(Of TDefault1 As TDefault2, TDefault2 As TDependency) ( _
    createDefault1 As Func(Of TDefault1), _
    args1 As Object(), _
    createDefault2 As Func(Of TDefault2), _
    args2 As Object() _
) As TDependency
C#
protected TDependency CreateDependency<TDefault1,TDefault2> (
    Func<TDefault1> createDefault1,
    Object[] args1,
    Func<TDefault2> createDefault2,
    Object[] args2
) where TDefault1 : TDefault2 where TDefault2 : TDependency
C++

J#

JScript

GenericParameters
TDefault1
TDefault2
Parameters
createDefault1
args1
createDefault2
args2
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.CreateDependencyAndInitialize Method
[image]

Overload List

Name | Description
InitializableConfigurationElement.CreateDependencyAndInitialize (Func, Object[]) |
InitializableConfigurationElement.CreateDependencyAndInitialize (Func, Object[], Func, Object[]) |

See Also

Reference

InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.CreateDependencyAndInitialize Method (Func, Object[])
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim createDefault As Func(Of TDefault)
Dim args As Object()
Dim returnValue As TDependency

returnValue = Me.CreateDependencyAndInitialize(createDefault, args)

Syntax

Visual Basic
Protected Function CreateDependencyAndInitialize(Of TDefault As TDependency) ( _
    createDefault As Func(Of TDefault), _
    ParamArray args As Object() _
) As TDependency
C#
protected TDependency CreateDependencyAndInitialize<TDefault> (
    Func<TDefault> createDefault,
    params Object[] args
) where TDefault : TDependency
C++

J#

JScript

GenericParameters
TDefault
Parameters
createDefault
args
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.CreateDependencyAndInitialize Method (Func, Object[], Func, Object[])
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim createDefault1 As Func(Of TDefault1)
Dim args1 As Object()
Dim createDefault2 As Func(Of TDefault2)
Dim args2 As Object()
Dim returnValue As TDependency

returnValue = Me.CreateDependencyAndInitialize(createDefault1, args1, createDefault2, args2)

Syntax

Visual Basic
Protected Function CreateDependencyAndInitialize(Of TDefault1 As TDefault2, TDefault2 As TDependency) ( _
    createDefault1 As Func(Of TDefault1), _
    args1 As Object(), _
    createDefault2 As Func(Of TDefault2), _
    args2 As Object() _
) As TDependency
C#
protected TDependency CreateDependencyAndInitialize<TDefault1,TDefault2> (
    Func<TDefault1> createDefault1,
    Object[] args1,
    Func<TDefault2> createDefault2,
    Object[] args2
) where TDefault1 : TDefault2 where TDefault2 : TDependency
C++

J#

JScript

GenericParameters
TDefault1
TDefault2
Parameters
createDefault1
args1
createDefault2
args2
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.GetDependencyType Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim returnValue As Type

returnValue = Me.GetDependencyType

Syntax

Visual Basic
Protected Function GetDependencyType As Type
C#
protected Type GetDependencyType ()
C++

J#

JScript

Return Value
Type: Type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.Initialize Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As InitializableConfigurationElement(Of TDependency)
Dim obj As TDependency
Dim returnValue As TDependency

returnValue = instance.Initialize(obj)

Syntax

Visual Basic
Public Function Initialize ( _
    obj As TDependency _
) As TDependency
C#
public TDependency Initialize (
    TDependency obj
)
C++

J#

JScript

Parameters
obj
Return Value
Type: Type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.IsReadOnly Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As InitializableConfigurationElement(Of TDependency)
Dim returnValue As Boolean

returnValue = instance.IsReadOnly

Syntax

Visual Basic
Public Overrides Function IsReadOnly As Boolean
C#
public override bool IsReadOnly ()
C++

J#

JScript

Return Value
Returns Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.OnDeserializeUnrecognizedAttribute Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim name As String
Dim value As String
Dim returnValue As Boolean

returnValue = Me.OnDeserializeUnrecognizedAttribute(name, value)

Syntax

Visual Basic
Protected Overrides Function OnDeserializeUnrecognizedAttribute ( _
    name As String, _
    value As String _
) As Boolean
C#
protected override bool OnDeserializeUnrecognizedAttribute (
    string name,
    string value
)
C++

J#

JScript

Parameters
name
value
Return Value
Type: Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.Reset Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim parentElement As ConfigurationElement

Me.Reset(parentElement)

Syntax

Visual Basic
Protected Overrides Sub Reset ( _
    parentElement As ConfigurationElement _
)
C#
protected override void Reset (
    ConfigurationElement parentElement
)
C++

J#

JScript

Parameters
parentElement
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.TryInitialize Method
[image]

Initializes the dependency object.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As InitializableConfigurationElement(Of TDependency)
Dim obj As Object
Dim returnValue As Boolean

returnValue = instance.TryInitialize(obj)

Syntax

Visual Basic
Public Function TryInitialize ( _
    obj As Object _
) As Boolean
C#
public bool TryInitialize (
    Object obj
)
C++

J#

JScript

Parameters
obj
Return Value
Type: Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | The name of the configuration element.
public property | Parameters | The attributes of the configuration element.
public property | Type | The dependency type name.

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)

See Also

Reference

InitializableConfigurationElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


InitializableConfigurationElement.DependencyType Property
[image]

The dependency type.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As InitializableConfigurationElement(Of TDependency)
Dim value As Type

value = instance.DependencyType

Syntax

Visual Basic
Public ReadOnly Property DependencyType As Type
C#
public Type DependencyType { get; }
C++

J#

JScript

Property Value
Type: Type.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.Name Property
[image]

The name of the configuration element.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As InitializableConfigurationElement(Of TDependency)
Dim value As String

value = instance.Name

instance.Name = value

Syntax

Visual Basic
Public MustOverride Property Name As String
C#
public abstract string Name { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.Parameters Property
[image]

The attributes of the configuration element.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As InitializableConfigurationElement(Of TDependency)
Dim value As NameValueCollection

value = instance.Parameters

Syntax

Visual Basic
Public ReadOnly Property Parameters As NameValueCollection
C#
public NameValueCollection Parameters { get; }
C++

J#

JScript

Property Value
Type: NameValueCollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


InitializableConfigurationElement.Type Property
[image]

The dependency type name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As InitializableConfigurationElement(Of TDependency)
Dim value As String

value = instance.Type

instance.Type = value

Syntax

Visual Basic
Public MustOverride Property Type As String
C#
public abstract string Type { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
InitializableConfigurationElement Class
InitializableConfigurationElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement Class
See Also Members
[image]

Represents an object cache element. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement

Syntax

Visual Basic
Public NotInheritable Class ObjectCacheElement
    Inherits InitializableConfigurationElement(Of ObjectCache)
    Implements ICacheItemPolicyFactory
C#
public sealed class ObjectCacheElement : InitializableConfigurationElement<ObjectCache>, ICacheItemPolicyFactory
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                Microsoft.Xrm.Client.Configuration.InitializableConfigurationElement
      Microsoft.Xrm.Client.Configuration.ObjectCacheElement
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElement Members
See Also Constructors Fields Methods Properties Explicit Interface Implementations
[image]

Represents an object cache element. (Developer Extensions)

The following tables list the members exposed by the ObjectCacheElement type.

Public Constructors

Name | Description
ObjectCacheElement | Initializes a new instance of the ObjectCacheElement class.
Top

Public Fields

Name | Description
DefaultObjectCacheName | Gets or sets the default element name.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AbsoluteExpiration | Gets or sets the cache policy absolute expiration date.
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type. (inherited from InitializableConfigurationElement)
public property | Duration | Gets or sets the cache policy cache duration.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | InstanceMode | Gets or sets the instance mode.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | Overridden. Gets or sets the element name.
public property | OutputCacheProfileName | Gets or sets the name of the OutputCacheProfileName from which the cache profile duration is obtained.
public property | Parameters | The attributes of the configuration element. (inherited from InitializableConfigurationElement)
public property | Priority | Gets or sets the cache policy priority.
public property | SlidingExpiration | Gets or sets the ache policy sliding expiration.
public property | Type | Overridden. Gets or sets the dependency type name.
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting. (inherited from InitializableConfigurationElement)
public method | CreateCacheItemPolicy |
public method | CreateObjectCache | Creates an ObjectCache object.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from InitializableConfigurationElement)
public method | IsReadOnly | Overridden. (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object. (inherited from InitializableConfigurationElement)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded. (inherited from InitializableConfigurationElement)
protected method | CreateDependencyAndInitialize | Overloaded. (inherited from InitializableConfigurationElement)
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType | (inherited from InitializableConfigurationElement)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden. (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
Create |
Top

See Also

Reference

ObjectCacheElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElement Fields
[image]

Public Fields

Name | Description
DefaultObjectCacheName | Gets or sets the default element name.

See Also

Reference

ObjectCacheElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElement.DefaultObjectCacheName Field
[image]

Gets or sets the default element name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As String

value = ObjectCacheElement.DefaultObjectCacheName

Syntax

Visual Basic
Public Const DefaultObjectCacheName As String
C#
public const string DefaultObjectCacheName
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement Constructor
[image]

Initializes a new instance of the ObjectCacheElement class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ObjectCacheElement

Syntax

Visual Basic
Public Sub New
C#
public ObjectCacheElement ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting. (inherited from InitializableConfigurationElement)
public method | CreateCacheItemPolicy |
public method | CreateObjectCache | Creates an ObjectCache object.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from InitializableConfigurationElement)
public method | IsReadOnly | Overridden. (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object. (inherited from InitializableConfigurationElement)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded. (inherited from InitializableConfigurationElement)
protected method | CreateDependencyAndInitialize | Overloaded. (inherited from InitializableConfigurationElement)
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType | (inherited from InitializableConfigurationElement)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden. (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
Create |

See Also

Reference

ObjectCacheElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElement.CreateCacheItemPolicy Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim returnValue As CacheItemPolicy

returnValue = instance.CreateCacheItemPolicy

Syntax

Visual Basic
Public Function CreateCacheItemPolicy As CacheItemPolicy
C#
public CacheItemPolicy CreateCacheItemPolicy ()
C++

J#

JScript

Return Value
Type: CacheItemPolicy
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement.CreateObjectCache Method
[image]

Creates an ObjectCache object.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim objectCacheName As String
Dim returnValue As ObjectCache

returnValue = instance.CreateObjectCache(objectCacheName)

Syntax

Visual Basic
Public Function CreateObjectCache ( _
    <OptionalAttribute> Optional objectCacheName As String = Nothing _
) As ObjectCache
C#
public ObjectCache CreateObjectCache (
    [OptionalAttribute] string objectCacheName
)
C++

J#

JScript

Parameters
objectCacheName
Return Value
Type: ObjectCache
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement.Create Method
[image]

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim returnValue As CacheItemPolicy

returnValue = CType(instance, ICacheItemPolicyFactory).Create

Syntax

Visual Basic
Private Function Microsoft.Xrm.Client.Services.ICacheItemPolicyFactory.Create As CacheItemPolicy Implements ICacheItemPolicyFactory.Create
C#
CacheItemPolicy ICacheItemPolicyFactory.Create ()
C++

J#

JScript

Return Value
Type: CacheItemPolicy
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AbsoluteExpiration | Gets or sets the cache policy absolute expiration date.
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type. (inherited from InitializableConfigurationElement)
public property | Duration | Gets or sets the cache policy cache duration.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | InstanceMode | Gets or sets the instance mode.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | Overridden. Gets or sets the element name.
public property | OutputCacheProfileName | Gets or sets the name of the OutputCacheProfileName from which the cache profile duration is obtained.
public property | Parameters | The attributes of the configuration element. (inherited from InitializableConfigurationElement)
public property | Priority | Gets or sets the cache policy priority.
public property | SlidingExpiration | Gets or sets the ache policy sliding expiration.
public property | Type | Overridden. Gets or sets the dependency type name.

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)

See Also

Reference

ObjectCacheElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElement.AbsoluteExpiration Property
[image]

Gets or sets the cache policy absolute expiration date.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim value As DateTimeOffset

value = instance.AbsoluteExpiration

instance.AbsoluteExpiration = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("absoluteExpiration")> _
Public Property AbsoluteExpiration As DateTimeOffset
C#
[ConfigurationPropertyAttribute("absoluteExpiration")]
public DateTimeOffset AbsoluteExpiration { get; set; }
C++

J#

JScript

Property Value
Type: DateTimeOffset
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement.Duration Property
[image]

Gets or sets the cache policy cache duration.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim value As Nullable(Of TimeSpan)

value = instance.Duration

instance.Duration = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("duration")> _
Public Property Duration As Nullable(Of TimeSpan)
C#
[ConfigurationPropertyAttribute("duration")]
public Nullable<TimeSpan> Duration { get; set; }
C++

J#

JScript

Property Value
Type: TimeSpan
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement.InstanceMode Property
[image]

Gets or sets the instance mode.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim value As ObjectCacheInstanceMode

value = instance.InstanceMode

instance.InstanceMode = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("instanceMode", DefaultValue:=ObjectCacheInstanceMode.PerName)> _
Public Property InstanceMode As ObjectCacheInstanceMode
C#
[ConfigurationPropertyAttribute("instanceMode", DefaultValue=ObjectCacheInstanceMode.PerName)]
public ObjectCacheInstanceMode InstanceMode { get; set; }
C++

J#

JScript

Property Value
Type: ObjectCacheInstanceMode
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement.Name Property
[image]

Gets or sets the element name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim value As String

value = instance.Name

instance.Name = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("name", DefaultValue:=Nothing, IsKey:=True, IsRequired:=True)> _
Public Overrides Property Name As String
C#
[ConfigurationPropertyAttribute("name", DefaultValue=null, IsKey=true, IsRequired=true)]
public override string Name { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement.OutputCacheProfileName Property
[image]

Gets or sets the name of the OutputCacheProfileName from which the cache profile duration is obtained.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim value As String

value = instance.OutputCacheProfileName

instance.OutputCacheProfileName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("outputCacheProfileName")> _
Public Property OutputCacheProfileName As String
C#
[ConfigurationPropertyAttribute("outputCacheProfileName")]
public string OutputCacheProfileName { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement.Priority Property
[image]

Gets or sets the cache policy priority.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim value As CacheItemPriority

value = instance.Priority

instance.Priority = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("priority", DefaultValue:=CacheItemPriority.Default)> _
Public Property Priority As CacheItemPriority
C#
[ConfigurationPropertyAttribute("priority", DefaultValue=CacheItemPriority.Default)]
public CacheItemPriority Priority { get; set; }
C++

J#

JScript

Property Value
Type: CacheItemPriority
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement.SlidingExpiration Property
[image]

Gets or sets the ache policy sliding expiration.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim value As TimeSpan

value = instance.SlidingExpiration

instance.SlidingExpiration = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("slidingExpiration")> _
Public Property SlidingExpiration As TimeSpan
C#
[ConfigurationPropertyAttribute("slidingExpiration")]
public TimeSpan SlidingExpiration { get; set; }
C++

J#

JScript

Property Value
Type: TimeSpan
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElement.Type Property
[image]

Gets or sets the dependency type name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElement
Dim value As String

value = instance.Type

instance.Type = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("type", DefaultValue:="System.Runtime.Caching.MemoryCache, System.Runtime.Caching, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")> _
Public Overrides Property Type As String
C#
[ConfigurationPropertyAttribute("type", DefaultValue="System.Runtime.Caching.MemoryCache, System.Runtime.Caching, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public override string Type { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElement Class
ObjectCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElementCollection Class
See Also Members
[image]

Represents an object cache element collection. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElementCollection

Syntax

Visual Basic
<ConfigurationCollectionAttribute(GetType(ObjectCacheElement))> _
Public NotInheritable Class ObjectCacheElementCollection
    Inherits ConfigurationElementCollection(Of ObjectCacheElement)
C#
[ConfigurationCollectionAttribute(typeof(ObjectCacheElement))]
public sealed class ObjectCacheElementCollection : ConfigurationElementCollection<ObjectCacheElement>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                System.Configuration.ConfigurationElementCollection

                Microsoft.Xrm.Client.Configuration.ConfigurationElementCollection
        Microsoft.Xrm.Client.Configuration.ObjectCacheElementCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElementCollection Members
See Also Constructors Fields Methods Properties Explicit Interface Implementations
[image]

Represents an object cache element collection. (Developer Extensions)

The following tables list the members exposed by the ObjectCacheElementCollection type.

Public Constructors

Name | Description
ObjectCacheElementCollection | Initializes a new instance of the ObjectCacheElementCollection class.
Top

Public Fields

Name | Description
Name | Gets or sets the name of the element collection.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden. Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)
Top

See Also

Reference

ObjectCacheElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElementCollection Fields
[image]

Public Fields

Name | Description
Name | Gets or sets the name of the element collection.

See Also

Reference

ObjectCacheElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElementCollection.Name Field
[image]

Gets or sets the name of the element collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As String

value = ObjectCacheElementCollection.Name

Syntax

Visual Basic
Public Const Name As String
C#
public const string Name
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElementCollection Class
ObjectCacheElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElementCollection Constructor
[image]

Initializes a new instance of the ObjectCacheElementCollection class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ObjectCacheElementCollection

Syntax

Visual Basic
Public Sub New
C#
public ObjectCacheElementCollection ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElementCollection Class
ObjectCacheElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheElementCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)

See Also

Reference

ObjectCacheElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElementCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden. Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)

See Also

Reference

ObjectCacheElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectCacheElementCollection.CollectionName Property
[image]

Gets or sets the name of the element collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheElementCollection
Dim value As String

value = instance.CollectionName

Syntax

Visual Basic
Public Overrides ReadOnly Property CollectionName As String
C#
public override string CollectionName { get; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectCacheElementCollection Class
ObjectCacheElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


ObjectCacheInstanceMode Enumeration
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObjectCacheInstanceMode

Syntax

Visual Basic
Public Enumeration ObjectCacheInstanceMode
C#
public enum ObjectCacheInstanceMode
C++

J#

JScript

  Members
Member name | Description
PerInstance | Value = 2.
PerName | Value = 1.
Static | Value = 0.
  Remarks
Developer Extensions for Microsoft Dynamics CRM

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElement Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElement

Syntax

Visual Basic
Public NotInheritable Class OrganizationServiceCacheElement
    Inherits InitializableConfigurationElement(Of IOrganizationServiceCache)
C#
public sealed class OrganizationServiceCacheElement : InitializableConfigurationElement<IOrganizationServiceCache>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                Microsoft.Xrm.Client.Configuration.InitializableConfigurationElement
      Microsoft.Xrm.Client.Configuration.OrganizationServiceCacheElement
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheElement Members
See Also Constructors Methods Properties
[image]

(Developer Extensions)

The following tables list the members exposed by the OrganizationServiceCacheElement type.

Public Constructors

Name | Description
OrganizationServiceCacheElement | Initializes a new instance of theOrganizationServiceCacheElement class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | CacheMode | Gets or sets the caching behavior mode.
public property | CacheRegionName | Gets or sets the cache region name.
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type. (inherited from InitializableConfigurationElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | Overridden. Gets or sets the element name.
public property | ObjectCacheName | Gets or sets the name of the nested ObjectCacheElement configuration.
public property | Parameters | The attributes of the configuration element. (inherited from InitializableConfigurationElement)
public property | QueryHashingEnabled | Gets or sets whether the query used to construct the cache key is to be hashed or left as a readable string.
public property | ReturnMode | Gets or sets the cache retrieval mode.
public property | Type | Overridden. Gets or sets the dependency type name.
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting. (inherited from InitializableConfigurationElement)
public method | CreateOrganizationServiceCache | Creates a IOrganizationServiceCache object.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from InitializableConfigurationElement)
public method | IsReadOnly | Overridden. (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object. (inherited from InitializableConfigurationElement)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded. (inherited from InitializableConfigurationElement)
protected method | CreateDependencyAndInitialize | Overloaded. (inherited from InitializableConfigurationElement)
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType | (inherited from InitializableConfigurationElement)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden. (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceCacheElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheElement Constructor
[image]

Initializes a new instance of the OrganizationServiceCacheElement class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New OrganizationServiceCacheElement

Syntax

Visual Basic
Public Sub New
C#
public OrganizationServiceCacheElement ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Class
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElement Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting. (inherited from InitializableConfigurationElement)
public method | CreateOrganizationServiceCache | Creates a IOrganizationServiceCache object.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from InitializableConfigurationElement)
public method | IsReadOnly | Overridden. (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object. (inherited from InitializableConfigurationElement)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded. (inherited from InitializableConfigurationElement)
protected method | CreateDependencyAndInitialize | Overloaded. (inherited from InitializableConfigurationElement)
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType | (inherited from InitializableConfigurationElement)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden. (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceCacheElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheElement.CreateOrganizationServiceCache Method
[image]

Creates a IOrganizationServiceCache object.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElement
Dim cache As ObjectCache
Dim settings As OrganizationServiceCacheSettings
Dim returnValue As IOrganizationServiceCache

returnValue = instance.CreateOrganizationServiceCache(cache, settings)

Syntax

Visual Basic
Public Function CreateOrganizationServiceCache ( _
    <OptionalAttribute> Optional cache As ObjectCache = Nothing, _
    <OptionalAttribute> Optional settings As OrganizationServiceCacheSettings = Nothing _
) As IOrganizationServiceCache
C#
public IOrganizationServiceCache CreateOrganizationServiceCache (
    [OptionalAttribute] ObjectCache cache,
    [OptionalAttribute] OrganizationServiceCacheSettings settings
)
C++

J#

JScript

Parameters
cache
settings
Return Value
Type: IOrganizationServiceCache.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Class
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElement Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | CacheMode | Gets or sets the caching behavior mode.
public property | CacheRegionName | Gets or sets the cache region name.
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type. (inherited from InitializableConfigurationElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | Overridden. Gets or sets the element name.
public property | ObjectCacheName | Gets or sets the name of the nested ObjectCacheElement configuration.
public property | Parameters | The attributes of the configuration element. (inherited from InitializableConfigurationElement)
public property | QueryHashingEnabled | Gets or sets whether the query used to construct the cache key is to be hashed or left as a readable string.
public property | ReturnMode | Gets or sets the cache retrieval mode.
public property | Type | Overridden. Gets or sets the dependency type name.

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)

See Also

Reference

OrganizationServiceCacheElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheElement.CacheMode Property
[image]

Gets or sets the caching behavior mode.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElement
Dim value As Nullable(Of OrganizationServiceCacheMode)

value = instance.CacheMode

instance.CacheMode = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("cacheMode", DefaultValue:=Nothing)> _
Public Property CacheMode As Nullable(Of OrganizationServiceCacheMode)
C#
[ConfigurationPropertyAttribute("cacheMode", DefaultValue=null)]
public Nullable<OrganizationServiceCacheMode> CacheMode { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceCacheMode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Class
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElement.CacheRegionName Property
[image]

Gets or sets the cache region name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElement
Dim value As String

value = instance.CacheRegionName

instance.CacheRegionName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("cacheRegionName", DefaultValue:=Nothing)> _
Public Property CacheRegionName As String
C#
[ConfigurationPropertyAttribute("cacheRegionName", DefaultValue=null)]
public string CacheRegionName { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Class
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElement.Name Property
[image]

Gets or sets the element name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElement
Dim value As String

value = instance.Name

instance.Name = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("name", DefaultValue:=Nothing, IsKey:=True, IsRequired:=True)> _
Public Overrides Property Name As String
C#
[ConfigurationPropertyAttribute("name", DefaultValue=null, IsKey=true, IsRequired=true)]
public override string Name { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Class
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElement.ObjectCacheName Property
[image]

Gets or sets the name of the nested ObjectCacheElement configuration.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElement
Dim value As String

value = instance.ObjectCacheName

instance.ObjectCacheName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("objectCacheName", DefaultValue:=Nothing)> _
Public Property ObjectCacheName As String
C#
[ConfigurationPropertyAttribute("objectCacheName", DefaultValue=null)]
public string ObjectCacheName { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Class
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElement.QueryHashingEnabled Property
[image]

Gets or sets whether the query used to construct the cache key is to be hashed or left as a readable string.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElement
Dim value As Boolean

value = instance.QueryHashingEnabled

instance.QueryHashingEnabled = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("queryHashingEnabled", DefaultValue:=True)> _
Public Property QueryHashingEnabled As Boolean
C#
[ConfigurationPropertyAttribute("queryHashingEnabled", DefaultValue=true)]
public bool QueryHashingEnabled { get; set; }
C++

J#

JScript

Property Value
Type: Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Class
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElement.ReturnMode Property
[image]

Gets or sets the cache retrieval mode.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElement
Dim value As Nullable(Of OrganizationServiceCacheReturnMode)

value = instance.ReturnMode

instance.ReturnMode = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("returnMode", DefaultValue:=Nothing)> _
Public Property ReturnMode As Nullable(Of OrganizationServiceCacheReturnMode)
C#
[ConfigurationPropertyAttribute("returnMode", DefaultValue=null)]
public Nullable<OrganizationServiceCacheReturnMode> ReturnMode { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceCacheReturnMode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Class
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElement.Type Property
[image]

Gets or sets the dependency type name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElement
Dim value As String

value = instance.Type

instance.Type = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("type", DefaultValue:="Microsoft.Xrm.Client.Services.OrganizationServiceCache, Microsoft.Xrm.Client")> _
Public Overrides Property Type As String
C#
[ConfigurationPropertyAttribute("type", DefaultValue="Microsoft.Xrm.Client.Services.OrganizationServiceCache, Microsoft.Xrm.Client")]
public override string Type { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElement Class
OrganizationServiceCacheElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElementCollection Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElementCollection

Syntax

Visual Basic
<ConfigurationCollectionAttribute(GetType(OrganizationServiceCacheElement))> _
Public NotInheritable Class OrganizationServiceCacheElementCollection
    Inherits ConfigurationElementCollection(Of OrganizationServiceCacheElement)
C#
[ConfigurationCollectionAttribute(typeof(OrganizationServiceCacheElement))]
public sealed class OrganizationServiceCacheElementCollection : ConfigurationElementCollection<OrganizationServiceCacheElement>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                System.Configuration.ConfigurationElementCollection

                Microsoft.Xrm.Client.Configuration.ConfigurationElementCollection
        Microsoft.Xrm.Client.Configuration.OrganizationServiceCacheElementCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheElementCollection Members
See Also Constructors Fields Methods Properties Explicit Interface Implementations
[image]

(Developer Extensions)

The following tables list the members exposed by the OrganizationServiceCacheElementCollection type.

Public Constructors

Name | Description
OrganizationServiceCacheElementCollection | Initializes a new instance of the OrganizationServiceCacheElementCollection class.
Top

Public Fields

Name | Description
Name | The name of the element collection.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden. Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)
Top

See Also

Reference

OrganizationServiceCacheElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheElementCollection Fields
[image]

Public Fields

Name | Description
Name | The name of the element collection.

See Also

Reference

OrganizationServiceCacheElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheElementCollection.Name Field
[image]

The name of the element collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As String

value = OrganizationServiceCacheElementCollection.Name

Syntax

Visual Basic
Public Const Name As String
C#
public const string Name
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElementCollection Class
OrganizationServiceCacheElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElementCollection Constructor
[image]

Initializes a new instance of the OrganizationServiceCacheElementCollection class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New OrganizationServiceCacheElementCollection

Syntax

Visual Basic
Public Sub New
C#
public OrganizationServiceCacheElementCollection ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElementCollection Class
OrganizationServiceCacheElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceCacheElementCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)

See Also

Reference

OrganizationServiceCacheElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheElementCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden. Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)

See Also

Reference

OrganizationServiceCacheElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheElementCollection.CollectionName Property
[image]

Gets or sets the name of the element collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheElementCollection
Dim value As String

value = instance.CollectionName

Syntax

Visual Basic
Public Overrides ReadOnly Property CollectionName As String
C#
public override string CollectionName { get; }
C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheElementCollection Class
OrganizationServiceCacheElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceContextElement Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextElement

Syntax

Visual Basic
Public NotInheritable Class OrganizationServiceContextElement
    Inherits InitializableConfigurationElement(Of OrganizationServiceContext)
C#
public sealed class OrganizationServiceContextElement : InitializableConfigurationElement<OrganizationServiceContext>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                Microsoft.Xrm.Client.Configuration.InitializableConfigurationElement
      Microsoft.Xrm.Client.Configuration.OrganizationServiceContextElement
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElement Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextElement Members
See Also Constructors Methods Properties
[image]

(Developer Extensions)

The following tables list the members exposed by the OrganizationServiceContextElement type.

Public Constructors

Name | Description
OrganizationServiceContextElement | Initializes a new instance of the OrganizationServiceContextElement
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ConnectionStringName | Gets or sets the name of the service connection string.
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type. (inherited from InitializableConfigurationElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | Overridden. Gets or sets the element name.
public property | Parameters | The attributes of the configuration element. (inherited from InitializableConfigurationElement)
public property | ServiceName | Gets or sets the name of the nested OrganizationServiceElement configuration.
public property | Type | Overridden. Gets or sets the dependency type name.
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting. (inherited from InitializableConfigurationElement)
public method | CreateOrganizationServiceContext | Creates a OrganizationServiceContext object.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from InitializableConfigurationElement)
public method | IsReadOnly | Overridden. (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object. (inherited from InitializableConfigurationElement)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded. (inherited from InitializableConfigurationElement)
protected method | CreateDependencyAndInitialize | Overloaded. (inherited from InitializableConfigurationElement)
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType | (inherited from InitializableConfigurationElement)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden. (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceContextElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextElement Constructor
[image]

Initializes a new instance of the OrganizationServiceContextElement

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New OrganizationServiceContextElement

Syntax

Visual Basic
Public Sub New
C#
public OrganizationServiceContextElement ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElement Class
OrganizationServiceContextElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceContextElement Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting. (inherited from InitializableConfigurationElement)
public method | CreateOrganizationServiceContext | Creates a OrganizationServiceContext object.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from InitializableConfigurationElement)
public method | IsReadOnly | Overridden. (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object. (inherited from InitializableConfigurationElement)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded. (inherited from InitializableConfigurationElement)
protected method | CreateDependencyAndInitialize | Overloaded. (inherited from InitializableConfigurationElement)
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType | (inherited from InitializableConfigurationElement)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden. (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceContextElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextElement.CreateOrganizationServiceContext Method
[image]

Creates a OrganizationServiceContext object.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextElement
Dim service As IOrganizationService
Dim returnValue As OrganizationServiceContext

returnValue = instance.CreateOrganizationServiceContext(service)

Syntax

Visual Basic
Public Function CreateOrganizationServiceContext ( _
    service As IOrganizationService _
) As OrganizationServiceContext
C#
public OrganizationServiceContext CreateOrganizationServiceContext (
    IOrganizationService service
)
C++

J#

JScript

Parameters
service
Return Value
Type: OrganizationServiceContext.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElement Class
OrganizationServiceContextElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceContextElement Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ConnectionStringName | Gets or sets the name of the service connection string.
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type. (inherited from InitializableConfigurationElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | Overridden. Gets or sets the element name.
public property | Parameters | The attributes of the configuration element. (inherited from InitializableConfigurationElement)
public property | ServiceName | Gets or sets the name of the nested OrganizationServiceElement configuration.
public property | Type | Overridden. Gets or sets the dependency type name.

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)

See Also

Reference

OrganizationServiceContextElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextElement.ConnectionStringName Property
[image]

Gets or sets the name of the service connection string.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextElement
Dim value As String

value = instance.ConnectionStringName

instance.ConnectionStringName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("connectionStringName", DefaultValue:=Nothing)> _
Public Property ConnectionStringName As String
C#
[ConfigurationPropertyAttribute("connectionStringName", DefaultValue=null)]
public string ConnectionStringName { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElement Class
OrganizationServiceContextElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceContextElement.Name Property
[image]

Gets or sets the element name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextElement
Dim value As String

value = instance.Name

instance.Name = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("name", DefaultValue:=Nothing, IsKey:=True, IsRequired:=True)> _
Public Overrides Property Name As String
C#
[ConfigurationPropertyAttribute("name", DefaultValue=null, IsKey=true, IsRequired=true)]
public override string Name { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElement Class
OrganizationServiceContextElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceContextElement.ServiceName Property
[image]

Gets or sets the name of the nested OrganizationServiceElement configuration.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextElement
Dim value As String

value = instance.ServiceName

instance.ServiceName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("serviceName", DefaultValue:=Nothing)> _
Public Property ServiceName As String
C#
[ConfigurationPropertyAttribute("serviceName", DefaultValue=null)]
public string ServiceName { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElement Class
OrganizationServiceContextElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceContextElement.Type Property
[image]

Gets or sets the dependency type name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextElement
Dim value As String

value = instance.Type

instance.Type = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("type", DefaultValue:="Microsoft.Xrm.Client.CrmOrganizationServiceContext, Microsoft.Xrm.Client")> _
Public Overrides Property Type As String
C#
[ConfigurationPropertyAttribute("type", DefaultValue="Microsoft.Xrm.Client.CrmOrganizationServiceContext, Microsoft.Xrm.Client")]
public override string Type { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElement Class
OrganizationServiceContextElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceContextElementCollection Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextElementCollection

Syntax

Visual Basic
<ConfigurationCollectionAttribute(GetType(OrganizationServiceContextElement))> _
Public NotInheritable Class OrganizationServiceContextElementCollection
    Inherits ConfigurationElementCollection(Of OrganizationServiceContextElement)
C#
[ConfigurationCollectionAttribute(typeof(OrganizationServiceContextElement))]
public sealed class OrganizationServiceContextElementCollection : ConfigurationElementCollection<OrganizationServiceContextElement>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                System.Configuration.ConfigurationElementCollection

                Microsoft.Xrm.Client.Configuration.ConfigurationElementCollection
        Microsoft.Xrm.Client.Configuration.OrganizationServiceContextElementCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextElementCollection Members
See Also Constructors Fields Methods Properties Explicit Interface Implementations
[image]

(Developer Extensions)

The following tables list the members exposed by the OrganizationServiceContextElementCollection type.

Public Constructors

Name | Description
OrganizationServiceContextElementCollection | Initializes a new instance of the OrganizationServiceContextElementCollection class.
Top

Public Fields

Name | Description
Name | The name of the element collection.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden. Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)
Top

See Also

Reference

OrganizationServiceContextElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextElementCollection Fields
[image]

Public Fields

Name | Description
Name | The name of the element collection.

See Also

Reference

OrganizationServiceContextElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextElementCollection.Name Field
[image]

The name of the element collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As String

value = OrganizationServiceContextElementCollection.Name

Syntax

Visual Basic
Public Const Name As String
C#
public const string Name
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElementCollection Class
OrganizationServiceContextElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceContextElementCollection Constructor
[image]

Initializes a new instance of the OrganizationServiceContextElementCollection class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New OrganizationServiceContextElementCollection

Syntax

Visual Basic
Public Sub New
C#
public OrganizationServiceContextElementCollection ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElementCollection Class
OrganizationServiceContextElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceContextElementCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)

See Also

Reference

OrganizationServiceContextElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextElementCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden. Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)

See Also

Reference

OrganizationServiceContextElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextElementCollection.CollectionName Property
[image]

Gets or sets the name of the element collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextElementCollection
Dim value As String

value = instance.CollectionName

Syntax

Visual Basic
Public Overrides ReadOnly Property CollectionName As String
C#
public override string CollectionName { get; }
C++

J#

JScript

Property Value
Returns String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextElementCollection Class
OrganizationServiceContextElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElement Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceElement

Syntax

Visual Basic
Public NotInheritable Class OrganizationServiceElement
    Inherits InitializableConfigurationElement(Of IOrganizationService)
C#
public sealed class OrganizationServiceElement : InitializableConfigurationElement<IOrganizationService>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                Microsoft.Xrm.Client.Configuration.InitializableConfigurationElement
      Microsoft.Xrm.Client.Configuration.OrganizationServiceElement
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElement Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceElement Members
See Also Constructors Methods Properties
[image]

(Developer Extensions)

The following tables list the members exposed by the OrganizationServiceElement type.

Public Constructors

Name | Description
OrganizationServiceElement | Initializes a new instance of theOrganizationServiceElement class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type. (inherited from InitializableConfigurationElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | InstanceMode | Gets or sets the instance mode.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | Overridden. Gets or sets the element name.
public property | ObjectCacheName | Gets or sets the name of the nested ObjectCacheElement configuration.
public property | Parameters | The attributes of the configuration element. (inherited from InitializableConfigurationElement)
public property | ServiceCacheName | Gets or sets the name of the nested OrganizationServiceCacheElement configuration.
public property | Type | Overridden. Gets or sets the dependency type name.
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting. (inherited from InitializableConfigurationElement)
public method | CreateOrganizationService | Creates an IOrganizationService object.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from InitializableConfigurationElement)
public method | IsReadOnly | Overridden. (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object. (inherited from InitializableConfigurationElement)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded. (inherited from InitializableConfigurationElement)
protected method | CreateDependencyAndInitialize | Overloaded. (inherited from InitializableConfigurationElement)
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType | (inherited from InitializableConfigurationElement)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden. (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceElement Constructor
[image]

Initializes a new instance of the OrganizationServiceElement class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New OrganizationServiceElement

Syntax

Visual Basic
Public Sub New
C#
public OrganizationServiceElement ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElement Class
OrganizationServiceElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElement Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddConfig | Adds a setting. (inherited from InitializableConfigurationElement)
public method | CreateOrganizationService | Creates an IOrganizationService object.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from InitializableConfigurationElement)
public method | IsReadOnly | Overridden. (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
public method | TryInitialize | Initializes the dependency object. (inherited from InitializableConfigurationElement)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CreateDependency | Overloaded. (inherited from InitializableConfigurationElement)
protected method | CreateDependencyAndInitialize | Overloaded. (inherited from InitializableConfigurationElement)
protected method | Finalize | (inherited from Object)
protected method | GetDependencyType | (inherited from InitializableConfigurationElement)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | Overridden. (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceElement.CreateOrganizationService Method
[image]

Creates an IOrganizationService object.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceElement
Dim connection As CrmConnection
Dim serviceCache As IOrganizationServiceCache
Dim returnValue As IOrganizationService

returnValue = instance.CreateOrganizationService(connection, serviceCache)

Syntax

Visual Basic
Public Function CreateOrganizationService ( _
    connection As CrmConnection, _
    serviceCache As IOrganizationServiceCache _
) As IOrganizationService
C#
public IOrganizationService CreateOrganizationService (
    CrmConnection connection,
    IOrganizationServiceCache serviceCache
)
C++

J#

JScript

Parameters
connection
serviceCache
Return Value
Type: IOrganizationService.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElement Class
OrganizationServiceElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElement Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | DependencyType | The dependency type. (inherited from InitializableConfigurationElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | InstanceMode | Gets or sets the instance mode.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | Name | Overridden. Gets or sets the element name.
public property | ObjectCacheName | Gets or sets the name of the nested ObjectCacheElement configuration.
public property | Parameters | The attributes of the configuration element. (inherited from InitializableConfigurationElement)
public property | ServiceCacheName | Gets or sets the name of the nested OrganizationServiceCacheElement configuration.
public property | Type | Overridden. Gets or sets the dependency type name.

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)

See Also

Reference

OrganizationServiceElement Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceElement.InstanceMode Property
[image]

Gets or sets the instance mode.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceElement
Dim value As OrganizationServiceInstanceMode

value = instance.InstanceMode

instance.InstanceMode = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("instanceMode", DefaultValue:=OrganizationServiceInstanceMode.PerRequest)> _
Public Property InstanceMode As OrganizationServiceInstanceMode
C#
[ConfigurationPropertyAttribute("instanceMode", DefaultValue=OrganizationServiceInstanceMode.PerRequest)]
public OrganizationServiceInstanceMode InstanceMode { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceInstanceMode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElement Class
OrganizationServiceElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElement.Name Property
[image]

Gets or sets the element name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceElement
Dim value As String

value = instance.Name

instance.Name = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("name", DefaultValue:=Nothing, IsKey:=True, IsRequired:=True)> _
Public Overrides Property Name As String
C#
[ConfigurationPropertyAttribute("name", DefaultValue=null, IsKey=true, IsRequired=true)]
public override string Name { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElement Class
OrganizationServiceElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElement.ObjectCacheName Property
[image]

Gets or sets the name of the nested ObjectCacheElement configuration.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceElement
Dim value As String

value = instance.ObjectCacheName

instance.ObjectCacheName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("objectCacheName", DefaultValue:=Nothing)> _
Public Property ObjectCacheName As String
C#
[ConfigurationPropertyAttribute("objectCacheName", DefaultValue=null)]
public string ObjectCacheName { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElement Class
OrganizationServiceElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElement.ServiceCacheName Property
[image]

Gets or sets the name of the nested OrganizationServiceCacheElement configuration.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceElement
Dim value As String

value = instance.ServiceCacheName

instance.ServiceCacheName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("serviceCacheName", DefaultValue:=Nothing)> _
Public Property ServiceCacheName As String
C#
[ConfigurationPropertyAttribute("serviceCacheName", DefaultValue=null)]
public string ServiceCacheName { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElement Class
OrganizationServiceElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElement.Type Property
[image]

Gets or sets the dependency type name.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceElement
Dim value As String

value = instance.Type

instance.Type = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("type", DefaultValue:="Microsoft.Xrm.Client.Services.CachedOrganizationService, Microsoft.Xrm.Client")> _
Public Overrides Property Type As String
C#
[ConfigurationPropertyAttribute("type", DefaultValue="Microsoft.Xrm.Client.Services.CachedOrganizationService, Microsoft.Xrm.Client")]
public override string Type { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElement Class
OrganizationServiceElement Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElementCollection Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceElementCollection

Syntax

Visual Basic
<ConfigurationCollectionAttribute(GetType(OrganizationServiceElement))> _
Public NotInheritable Class OrganizationServiceElementCollection
    Inherits ConfigurationElementCollection(Of OrganizationServiceElement)
C#
[ConfigurationCollectionAttribute(typeof(OrganizationServiceElement))]
public sealed class OrganizationServiceElementCollection : ConfigurationElementCollection<OrganizationServiceElement>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Configuration.ConfigurationElement

                System.Configuration.ConfigurationElementCollection

                Microsoft.Xrm.Client.Configuration.ConfigurationElementCollection
        Microsoft.Xrm.Client.Configuration.OrganizationServiceElementCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceElementCollection Members
See Also Constructors Fields Methods Properties Explicit Interface Implementations
[image]

(Developer Extensions)

The following tables list the members exposed by the OrganizationServiceElementCollection type.

Public Constructors

Name | Description
OrganizationServiceElementCollection | Initializes a new instance of the OrganizationServiceElementCollection class.
Top

Public Fields

Name | Description
Name | The name of the element collection.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden. Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)
Top

See Also

Reference

OrganizationServiceElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceElementCollection Fields
[image]

Public Fields

Name | Description
Name | The name of the element collection.

See Also

Reference

OrganizationServiceElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceElementCollection.Name Field
[image]

The name of the element collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As String

value = OrganizationServiceElementCollection.Name

Syntax

Visual Basic
Public Const Name As String
C#
public const string Name
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElementCollection Class
OrganizationServiceElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElementCollection Constructor
[image]

Initializes a new instance of the OrganizationServiceElementCollection class.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New OrganizationServiceElementCollection

Syntax

Visual Basic
Public Sub New
C#
public OrganizationServiceElementCollection ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElementCollection Class
OrganizationServiceElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceElementCollection Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Add | (inherited from ConfigurationElementCollection)
public method | CopyTo | (inherited from ConfigurationElementCollection)
public method | Equals | Overridden. (inherited from ConfigurationElement)
public method | GetElementOrDefault | Retrieves the selected element or falls back to the default. (inherited from ConfigurationElementCollection)
public method | GetEnumerator | (inherited from ConfigurationElementCollection)
public method | GetHashCode | Overridden. (inherited from ConfigurationElement)
public method | GetKey | Gets the key at the specified index position. (inherited from ConfigurationElementCollection)
public method | GetType | (inherited from Object)
public method | IsReadOnly | Overridden. True if the collection is read only. (inherited from ConfigurationElementCollection)
public method | Remove | Overloaded. Removes an element from the collection. (inherited from ConfigurationElementCollection)
public method | RemoveAt | Removes the element at the specified position from the collection. (inherited from ConfigurationElementCollection)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseAdd | (inherited from ConfigurationElementCollection)
protected method | BaseIndexOf | (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | Overridden. Creates a new ConfigurationElement. (inherited from ConfigurationElementCollection)
protected method | CreateNewElement | (inherited from ConfigurationElementCollection)
protected method | Finalize | (inherited from Object)
protected method | GetElementKey | Overridden. (inherited from ConfigurationElementCollection)
protected method | GetTransformedAssemblyString | (inherited from ConfigurationElement)
protected method | GetTransformedTypeString | (inherited from ConfigurationElement)
protected method | IsElementName | (inherited from ConfigurationElementCollection)
protected method | IsElementRemovable | (inherited from ConfigurationElementCollection)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | Overridden. (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
CopyTo | (inherited from ConfigurationElementCollection)

See Also

Reference

OrganizationServiceElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceElementCollection Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AllKeys | Gets all the keys in the ConfigurationElementCollection (inherited from ConfigurationElementCollection)
public property | CollectionName | Overridden. Gets or sets the name of the element collection.
public property | CollectionType | (inherited from ConfigurationElementCollection)
public property | Count | (inherited from ConfigurationElementCollection)
public property | Current | Gets the selected or default element. (inherited from ConfigurationElementCollection)
public property | CurrentConfiguration | (inherited from ConfigurationElement)
public property | Default | Gets or sets the default element name. (inherited from ConfigurationElementCollection)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EmitClear | (inherited from ConfigurationElementCollection)
public property | IsSynchronized | (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. Gets or sets the element with the specified key. (inherited from ConfigurationElementCollection)
public property | Item | Overloaded. (inherited from ConfigurationElementCollection)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | SyncRoot | (inherited from ConfigurationElementCollection)

Protected Properties

 | Name | Description
protected property | ElementName | Overridden. Gets the element name. (inherited from ConfigurationElementCollection)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the property collection. (inherited from ConfigurationElement)
protected property | ThrowOnDuplicate | (inherited from ConfigurationElementCollection)

See Also

Reference

OrganizationServiceElementCollection Class
Microsoft.Xrm.Client.Configuration Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceElementCollection.CollectionName Property
[image]

Gets or sets the name of the element collection.

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceElementCollection
Dim value As String

value = instance.CollectionName

Syntax

Visual Basic
Public Overrides ReadOnly Property CollectionName As String
C#
public override string CollectionName { get; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceElementCollection Class
OrganizationServiceElementCollection Members
Microsoft.Xrm.Client.Configuration Namespace


OrganizationServiceInstanceMode Enumeration
[image]

Contains values to specify how CrmConfigurationManager will adjust its instantiation behavior. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Configuration
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceInstanceMode

Syntax

Visual Basic
Public Enumeration OrganizationServiceInstanceMode
C#
public enum OrganizationServiceInstanceMode
C++

J#

JScript

  Members
Member name | Description
PerInstance | Return a new instance on each call. Value = 3.
PerName | Return a single instance for each configuration element specified. Value = 1.
PerRequest | Return the same first instance in the context of a Web request, For example, one instance for each HttpContext instance. Value = 2.
Static | Always return the same static instance. Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client.Configuration Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


Microsoft.Xrm.Client.Diagnostics Namespace

Classes

Class | Description
Tracing | (Developer Extensions)


Tracing Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
Public NotInheritable Class Tracing
C#
public static class Tracing
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Diagnostics.Tracing
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


Tracing Members
See Also Methods Properties
[image]

(Developer Extensions)

The following tables list the members exposed by the Tracing type.

Public Properties

Name | Description
AppDomain |
Framework |
Workflow |
Top

Public Methods (see also Extension Methods)

Name | Description
AppDomainError |
AppDomainEvent |
AppDomainInformation |
FrameworkError |
FrameworkEvent |
FrameworkInformation |
WorkflowError |
WorkflowEvent |
WorkflowInformation |
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

Tracing Class
Microsoft.Xrm.Client.Diagnostics Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


Tracing Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
AppDomainError |
AppDomainEvent |
AppDomainInformation |
FrameworkError |
FrameworkEvent |
FrameworkInformation |
WorkflowError |
WorkflowEvent |
WorkflowInformation |

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

Tracing Class
Microsoft.Xrm.Client.Diagnostics Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


Tracing.AppDomainError Method
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim className As String
Dim memberName As String
Dim format As String
Dim args As Object()

Tracing.AppDomainError(className, memberName, format, args)

Syntax

Visual Basic
Public Shared Sub AppDomainError ( _
    className As String, _
    memberName As String, _
    format As String, _
    ParamArray args As Object() _
)
C#
public static void AppDomainError (
    string className,
    string memberName,
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
className
Type: String.
memberName
Type: String.
format
Type: String.
args
Type: Object[].
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.AppDomainEvent Method
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim eventType As TraceEventType
Dim className As String
Dim memberName As String
Dim format As String
Dim args As Object()

Tracing.AppDomainEvent(eventType, className, memberName, format, args)

Syntax

Visual Basic
Public Shared Sub AppDomainEvent ( _
    eventType As TraceEventType, _
    className As String, _
    memberName As String, _
    format As String, _
    ParamArray args As Object() _
)
C#
public static void AppDomainEvent (
    TraceEventType eventType,
    string className,
    string memberName,
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
eventType
Type: .
className
Type: String.
memberName
Type: String.
format
Type: String.
args
Type: Object[].
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.AppDomainInformation Method
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim className As String
Dim memberName As String
Dim format As String
Dim args As Object()

Tracing.AppDomainInformation(className, memberName, format, args)

Syntax

Visual Basic
Public Shared Sub AppDomainInformation ( _
    className As String, _
    memberName As String, _
    format As String, _
    ParamArray args As Object() _
)
C#
public static void AppDomainInformation (
    string className,
    string memberName,
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
className
Type: String.
memberName
Type: String.
format
Type: String.
args
Type: Object[].
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.FrameworkError Method
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim className As String
Dim memberName As String
Dim format As String
Dim args As Object()

Tracing.FrameworkError(className, memberName, format, args)

Syntax

Visual Basic
Public Shared Sub FrameworkError ( _
    className As String, _
    memberName As String, _
    format As String, _
    ParamArray args As Object() _
)
C#
public static void FrameworkError (
    string className,
    string memberName,
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
className
Type: String.
memberName
Type: String.
format
Type: String.
args
Type: Object[].
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.FrameworkEvent Method
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim eventType As TraceEventType
Dim className As String
Dim memberName As String
Dim format As String
Dim args As Object()

Tracing.FrameworkEvent(eventType, className, memberName, format, args)

Syntax

Visual Basic
Public Shared Sub FrameworkEvent ( _
    eventType As TraceEventType, _
    className As String, _
    memberName As String, _
    format As String, _
    ParamArray args As Object() _
)
C#
public static void FrameworkEvent (
    TraceEventType eventType,
    string className,
    string memberName,
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
eventType
Type: .
className
Type: String.
memberName
Type: String.
format
Type: String.
args
Type: Object[].
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.FrameworkInformation Method
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim className As String
Dim memberName As String
Dim format As String
Dim args As Object()

Tracing.FrameworkInformation(className, memberName, format, args)

Syntax

Visual Basic
Public Shared Sub FrameworkInformation ( _
    className As String, _
    memberName As String, _
    format As String, _
    ParamArray args As Object() _
)
C#
public static void FrameworkInformation (
    string className,
    string memberName,
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
className
Type: String.
memberName
Type: String.
format
Type: String.
args
Type: Object[].
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.WorkflowError Method
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim className As String
Dim memberName As String
Dim format As String
Dim args As Object()

Tracing.WorkflowError(className, memberName, format, args)

Syntax

Visual Basic
Public Shared Sub WorkflowError ( _
    className As String, _
    memberName As String, _
    format As String, _
    ParamArray args As Object() _
)
C#
public static void WorkflowError (
    string className,
    string memberName,
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
className
Type: String.
memberName
Type: String.
format
Type: String.
args
Type: Object[].
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.WorkflowEvent Method
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim eventType As TraceEventType
Dim className As String
Dim memberName As String
Dim format As String
Dim args As Object()

Tracing.WorkflowEvent(eventType, className, memberName, format, args)

Syntax

Visual Basic
Public Shared Sub WorkflowEvent ( _
    eventType As TraceEventType, _
    className As String, _
    memberName As String, _
    format As String, _
    ParamArray args As Object() _
)
C#
public static void WorkflowEvent (
    TraceEventType eventType,
    string className,
    string memberName,
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
eventType
Type: .
className
Type: String.
memberName
Type: String.
format
Type: String.
args
Type: Object[].
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.WorkflowInformation Method
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim className As String
Dim memberName As String
Dim format As String
Dim args As Object()

Tracing.WorkflowInformation(className, memberName, format, args)

Syntax

Visual Basic
Public Shared Sub WorkflowInformation ( _
    className As String, _
    memberName As String, _
    format As String, _
    ParamArray args As Object() _
)
C#
public static void WorkflowInformation (
    string className,
    string memberName,
    string format,
    params Object[] args
)
C++

J#

JScript

Parameters
className
Type: String.
memberName
Type: String.
format
Type: String.
args
Type: Object[].
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing Properties
[image]

Public Properties

Name | Description
AppDomain |
Framework |
Workflow |

See Also

Reference

Tracing Class
Microsoft.Xrm.Client.Diagnostics Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


Tracing.AppDomain Property
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As TraceSource

value = Tracing.AppDomain

Syntax

Visual Basic
Public Shared Property AppDomain As TraceSource
C#
public static TraceSource AppDomain { get; }
C++

J#

JScript

Property Value
Type: TraceSource
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.Framework Property
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As TraceSource

value = Tracing.Framework

Syntax

Visual Basic
Public Shared Property Framework As TraceSource
C#
public static TraceSource Framework { get; }
C++

J#

JScript

Property Value
Type: TraceSource
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Tracing.Workflow Property
[image]

Namespace: Microsoft.Xrm.Client.Diagnostics
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As TraceSource

value = Tracing.Workflow

Syntax

Visual Basic
Public Shared Property Workflow As TraceSource
C#
public static TraceSource Workflow { get; }
C++

J#

JScript

Property Value
Type: TraceSource
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Tracing Class
Tracing Members
Microsoft.Xrm.Client.Diagnostics Namespace


Microsoft.Xrm.Client.Messages Namespace

Classes

Class | Description
OrganizationServiceContextExtensions | Extensions for the core OrganizationServiceContext class. (Developer Extensions)


OrganizationServiceContextExtensions Class
See Also Members
[image]

Extensions for the core OrganizationServiceContext class. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class OrganizationServiceContextExtensions
C#
[ExtensionAttribute]
public static class OrganizationServiceContextExtensions
C++

J#

JScript

  Remarks
Extensions for the core OrganizationServiceContext class.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Messages.OrganizationServiceContextExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions Members
See Also Methods
[image]

Extensions for the core OrganizationServiceContext class. (Developer Extensions)

The following tables list the members exposed by the OrganizationServiceContextExtensions type.

Public Methods (see also Extension Methods)

Name | Description
AddItemCampaign | Adds an item to a campaign. The item added must be one of the following entity types: campaign, list, product, or salesliterature. (Developer Extensions)
AddItemCampaignActivity | Adds an item to a campaign activity. (Developer Extensions)
AddListMembersList | Adds a list of members to a list. (Developer Extensions)
AddMemberList | Adds a member to a list. The member added must be one of the following entity types: account, contact, or lead. (Developer Extensions)
AddMembersTeam | Adds members to a team. (Developer Extensions)
AddPrivilegesRole | Adds a set of existing privileges to an existing role. (Developer Extensions)
AddProductToKit | Adds a product to a kit. (Developer Extensions)
AddRecurrence | Adds recurrence information to an existing appointment to make it a recurring appointment master. (Developer Extensions)
AddSolutionComponent | Adds a solution component to an unmanaged solution. (Developer Extensions)
AddSubstituteProduct | Deprecated. Establishes an association between a product and a substitute product. Use Associate. (Developer Extensions)
AddToQueue | Moves a record from a source queue to a destination queue. (Developer Extensions)
Assign | Assigns the specified record to a new security principal (user). This changes the ownerid attribute of the instance. (Developer Extensions)
AssociateEntities | Deprecated. Adds a link between two records in a many-to-many relationship. Use Associate. (Developer Extensions)
AutoMapEntity | Creates the attribute mappings between two entities. (Developer Extensions)
BackgroundSendEmail | Sends an email asynchronously. (Developer Extensions)
Book | Schedules or "books" an appointment. (Developer Extensions)
BulkDelete | Submits an asynchronous bulk delete job. (Developer Extensions)
BulkDetectDuplicates | Submits an asynchronous duplicates detection job. (Developer Extensions)
BulkOperationStatusClose | For internal use only. (Developer Extensions)
CalculateActualValueOpportunity | Calculates the value of an opportunity that is in the "Won" state. (Developer Extensions)
CalculateTotalTimeIncident | Calculates the total number of minutes spent on an incident (case). (Developer Extensions)
CancelContract | Cancels a contract. (Developer Extensions)
CancelSalesOrder | Cancels a sales order. (Developer Extensions)
CheckIncomingEmail | Checks whether the incoming email message is relevant to the Microsoft Dynamics CRM system. (Developer Extensions)
CheckPromoteEmail | Checks whether the incoming email message should be promoted to the Microsoft Dynamics CRM system. (Developer Extensions)
CleanUpBulkOperation | For internal use only. (Developer Extensions)
CloneContract | Copies an existing contract and its line items. (Developer Extensions)
CloseIncident | Overloaded. Closes an incident (case). (Developer Extensions)
CloseQuote | Closes a quote. (Developer Extensions)
CompoundCreate | Deprecated. Creates a compound entity (salesorder, invoice, quote, or duplicaterule) and its related entity (salesorderdetail, invoicedetail, quotedetail, or duplicaterulecondition). Use Create. (Developer Extensions)
CompoundUpdate | Deprecated. Updates a compound record (salesorder, invoice, quote or duplicaterule) and its related detail record (salesorderdetail, invoicedetail, quotedetail or duplicaterulecondition). Use Update. (Developer Extensions)
CompoundUpdateDuplicateDetectionRule | Updates a duplicate rule (duplicate detection rule) and its related duplicate rule conditions. (Developer Extensions)
ConvertKitToProduct | Converts a kit to a product. (Developer Extensions)
ConvertProductToKit | Converts a product to a kit. (Developer Extensions)
ConvertQuoteToSalesOrder | Converts a quote to a sales order. (Developer Extensions)
ConvertSalesOrderToInvoice | Converts a sales order to an invoice. (Developer Extensions)
CopyCampaign | Copies a campaign. (Developer Extensions)
CopyCampaignResponse | Copies the information from one campaign response to another, and optionally creates a campaign response template. (Developer Extensions)
CopyDynamicListToStatic | Creates a static list from the specified dynamic list and adds the members that satisfy the dynamic list query criteria to the static list. (Developer Extensions)
CopyMembersList | Copies the members from the source list to the target list without creating duplicates. (Developer Extensions)
CopySystemForm | Creates a new entity form that is based on an existing entity form. (Developer Extensions)
CreateActivitiesList | Creates the activities for a list. (Developer Extensions)
CreateException | Creates an exception for the recurring appointment instance. (Developer Extensions)
CreateInstance | Creates future unexpanded instances of a recurring appointment master. (Developer Extensions)
CreateWorkflowFromTemplate | Creates a workflow from a workflow template. (Developer Extensions)
DeleteAuditData | Deletes all partitions containing audit data created before a given end date. (Developer Extensions)
DeleteOpenInstances | Deletes instances of a recurring appointment master that have an Open state. (Developer Extensions)
DeliverIncomingEmail | Creates an email activity record from an incoming email message. (Developer Extensions)
DeliverPromoteEmail | Creates an email activity instance from the specified email message (Track in CRM). (Developer Extensions)
DeprovisionLanguage | Deprovisions a language. (Developer Extensions)
DisassociateEntities | Deprecated. Removes a link between two records in a many to many relationship. Use Disassociate. (Developer Extensions)
DistributeCampaignActivity | Creates a bulk operation to distribute the activity, creating the appropriate activity for each member in the list for the specified campaign activity. (Developer Extensions)
DownloadReportDefinition | Downloads a report definition. (Developer Extensions)
ExecuteByIdSavedQuery | Executes a saved query (view) that has the specified ID. (Developer Extensions)
ExecuteByIdUserQuery | Executes the user query (saved view) that has the specified ID. (Developer Extensions)
ExecuteFetch | Deprecated. Executes the specified Fetch XML query. Use RetrieveMultiple. (Developer Extensions)
ExecuteWorkflow | Executes a workflow. (Developer Extensions)
ExpandCalendar | Converts the calendar rules to an array of available time blocks for the specified period. (Developer Extensions)
ExportSolution | Exports a managed or unmanaged solution. (Developer Extensions)
ExportTranslation | Exports all translations for a specific solution to a compressed file. (Developer Extensions)
FetchXmlToQueryExpression | Converts a query in Fetch XML to a QueryExpression. (Developer Extensions)
FindParentResourceGroup | Finds a parent resource group (scheduling group) for the specified resource groups (scheduling groups). (Developer Extensions)
FulfillSalesOrder | Fulfills a sales order (order). (Developer Extensions)
GenerateInvoiceFromOpportunity | Generates an invoice from an opportunity. (Developer Extensions)
GenerateQuoteFromOpportunity | Generates a quote from an opportunity. (Developer Extensions)
GenerateSalesOrderFromOpportunity | Generates a sales order from an opportunity. (Developer Extensions)
GetAllTimeZonesWithDisplayName | Retrieves all the time-zone definitions for the specified locale returning only the display name attribute. (Developer Extensions)
GetDecryptionKey | Gets a decryption key. (Developer Extensions)
GetDistinctValuesImportFile | Returns distinct values for a column in the source file that contains list values. (Developer Extensions)
GetHeaderColumnsImportFile | Retrieves the source-file column headings, or system-generated column headings, if the source file does not contain column headings. (Developer Extensions)
GetInvoiceProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the specified invoice. (Developer Extensions)
GetQuantityDecimal | Gets the quantity decimal value for a product. (Developer Extensions)
GetQuoteProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the quote. (Developer Extensions)
GetReportHistoryLimit | Gets the history limit for a report. (Developer Extensions)
GetSalesOrderProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the sales order. (Developer Extensions)
GetTimeZoneCodeByLocalizedName | Retrieves the time-zone code for the specified localized time-zone name. (Developer Extensions)
GetTrackingTokenEmail | Returns a tracking token that can be then passed in as a parameter to the SendEmail method. (Developer Extensions)
GrantAccess | Grants a security principal (user or team) access to the specified record. (Developer Extensions)
ImportRecordsImport | Imports XML mappings and creates an import data map. (Developer Extensions)
ImportSolution | Imports a managed or unmanaged solution. (Developer Extensions)
ImportTranslation | Imports all translations from a compressed file. (Developer Extensions)
InitializeFrom | Initializes a new record from an existing record. (Developer Extensions)
InstallSampleData | Installs sample data for an organization. (Developer Extensions)
InstantiateFilters | Instantiates a filter. (Developer Extensions)
InstantiateTemplate | Creates an email message from a template. (Developer Extensions)
IsBackOfficeInstalled | Deprecated. Checks if Microsoft Great Plains is installed. (Developer Extensions)
IsComponentCustomizable | Determines whether a solution component is customizable. (Developer Extensions)
IsValidStateTransition | Checks to see if the state transition is valid. (Developer Extensions)
LocalTimeFromUtcTime | Retrieves the local time for the specified Universal Time Coordinate (UTC) time. (Developer Extensions)
LockInvoicePricing | Locks the total price of products and services specified in the invoice. When the invoice pricing is locked, changes to underlying price lists (price levels) do not affect the prices for an invoice. (Developer Extensions)
LockSalesOrderPricing | Locks the total price of products and services specified in the sales order (order). When the sales order pricing is locked, changes to underlying price lists (price levels) do not affect the prices for a sales order (order). (Developer Extensions)
LogFailureBulkOperation | For internal use only. (Developer Extensions)
LogSuccessBulkOperation | For internal use only. (Developer Extensions)
LoseOpportunity | Overloaded. Sets the state of an opportunity to Lost. (Developer Extensions)
MakeAvailableToOrganizationReport | Deprecated. Makes the report available to all users in the organization. Use Update. (Developer Extensions)
MakeAvailableToOrganizationTemplate | Deprecated. Makes the specified email template available to the entire organization. Use Update. (Developer Extensions)
MakeUnavailableToOrganizationReport | Deprecated. Makes the report unavailable to all users in the organization. Use Update. (Developer Extensions)
MakeUnavailableToOrganizationTemplate | Deprecated. Makes the specified email template no longer available to the entire organization. Use Update. (Developer Extensions)
Merge | Merges the information from two records of the same type. (Developer Extensions)
ModifyAccess | Replaces the access rights on the target record for the specified security principal (user or team). (Developer Extensions)
ParseImport | Submits an asynchronous job that parses all import files associated with the specified data import (import). (Developer Extensions)
ProcessInboundEmail | Processes marketing campaign email responses. (Developer Extensions)
ProcessOneMemberBulkOperation | For internal use only. (Developer Extensions)
PropagateByExpression | Distributes an activity to a quick campaign. (Developer Extensions)
ProvisionLanguage | Provisions a language. (Developer Extensions)
PublishAllXml | Publishes all customizations. (Developer Extensions)
PublishDuplicateRule | Submits an asynchronous job to publish a duplicate rule. (Developer Extensions)
PublishXml | Publishes the customizations for the specified entities. (Developer Extensions)
QualifyLead | Qualifies a lead and creates an account, contact, or opportunity records that are linked to the originating lead. (Developer Extensions)
QualifyMemberList | Qualifies the specified member list and either overrides the list members or removes them according to the specified option. (Developer Extensions)
QueryExpressionToFetchXml | Converts a query represented as a QueryExpression class to the equivalent query represented as FetchXML. (Developer Extensions)
QueryMultipleSchedules | Searches multiple resources for an available time slot matching the specified parameters. This is similar to the QuerySchedule method but it works for multiple resources at one time. (Developer Extensions)
QuerySchedule | Searches the specified resource for an available time slot matching the specified parameters. (Developer Extensions)
ReassignObjectsOwner | Reassigns all records that are owned by the security principal (user or team) to another security principal (user or team). (Developer Extensions)
ReassignObjectsSystemUser | Reassigns all records that are owned by the user to another security principal (user or team). (Developer Extensions)
Recalculate | Recalculates the rollup attribute values for all goals in the goal hierarchy that contain a specified goal. (Developer Extensions)
RemoveItemCampaign | Removes an item from a campaign. (Developer Extensions)
RemoveItemCampaignActivity | Removes an item from a campaign activity. (Developer Extensions)
RemoveMemberList | Removes a member from a list. (Developer Extensions)
RemoveMembersTeam | Removes members from a team. (Developer Extensions)
RemoveParent | Removes the parent for a record. (Developer Extensions)
RemovePrivilegeRole | Removes a privilege from an existing role. (Developer Extensions)
RemoveProductFromKit | Removes a product from a kit. (Developer Extensions)
RemoveRelated | Deprecated. Removes the relationship between two records as defined by the target classes listed below. For example, remove the relationship between an invoice and a contact. (Developer Extensions)
RemoveSolutionComponent | Removes a solution component to an unmanaged solution. (Developer Extensions)
RemoveSubstituteProduct | Deprecated. Removes the association between a product and a substitute product. Use Disassociate. (Developer Extensions)
RenewContract | Renews a contract. (Developer Extensions)
ReplacePrivilegesRole | Replaces the privilege set of an existing role. This effectively deletes all existing privileges from the role and adds the new specified privileges. (Developer Extensions)
Reschedule | Reschedules an appointment, service appointment or recurring appointment. (Developer Extensions)
ResetUserFilters | Resets the offline data filters for the calling user to the default filters for the organization. (Developer Extensions)
RetrieveAbsoluteAndSiteCollectionUrl | Retrieves the absolute (complete) URL and the site collection URL of a SharePoint document location or SharePoint site. (Developer Extensions)
RetrieveAllChildUsersSystemUser | Retrieves a collection of system users who report to the specified system user. (Developer Extensions)
RetrieveAllEntities | Retrieves the metadata for all entities. (Developer Extensions)
RetrieveApplicationRibbon | Retrieves the core application ribbons including the entity template. (Developer Extensions)
RetrieveAttribute | Retrieves the metadata for the specified attribute. (Developer Extensions)
RetrieveAttributeChangeHistory | Retrieves all changes to a specific attribute. (Developer Extensions)
RetrieveAuditDetails | Retrieves the full audit details of a particular audit record. (Developer Extensions)
RetrieveAuditPartitionList | Retrieves the list of auditing partitions. (Developer Extensions)
RetrieveAvailableLanguages | Retrieves the list of available languages. (Developer Extensions)
RetrieveBusinessHierarchyBusinessUnit | Retrieves all the business units in the business unit hierarchy. (Developer Extensions)
RetrieveByGroupResource | Retrieves all the resource groups to which the specified resource belongs. (Developer Extensions)
RetrieveByResourceResourceGroup | Retrieves the resource groups that contain the specified resource. (Developer Extensions)
RetrieveByResourcesService | Retrieves a collection of services related to the specified set of services. (Developer Extensions)
RetrieveByTopIncidentProductKbArticle | Retrieves the top ten knowledge base articles for the product specified. (Developer Extensions)
RetrieveByTopIncidentSubjectKbArticle | Retrieves the top ten knowledge base articles for the subject specified. (Developer Extensions)
RetrieveDependenciesForDelete | Retrieves the dependencies for solution components that will prevent a solution component from being deleted. (Developer Extensions)
RetrieveDependenciesForUninstall | Retrieves the dependencies for solution components that could prevent uninstalling a managed solution. (Developer Extensions)
RetrieveDependentComponents | Retrieves all components that depend on the specified component. (Developer Extensions)
RetrieveDeploymentLicenseType | Retrieves the type of license for a deployment of Microsoft Dynamics CRM. (Developer Extensions)
RetrieveDeprovisionedLanguages | Retrieves the list of language packs installed on the server that have been disabled. (Developer Extensions)
RetrieveDuplicates | Detects and retrieves duplicate records for the specified record, provided duplicate detection is enabled and there are published duplicate detection rules for the entity. (Developer Extensions)
RetrieveEntity | Retrieves the metadata for the specified entity. (Developer Extensions)
RetrieveEntityRibbon | Retrieves the ribbon definition used for a specific entity. (Developer Extensions)
RetrieveExchangeRate | Retrieves the exchange rate. (Developer Extensions)
RetrieveFilteredForms | Retrieves the system forms for the specified user. (Developer Extensions)
RetrieveFormattedImportJobResults | Retrieves the formatted results from an import job. (Developer Extensions)
RetrieveFormXml | For internal use only. (Developer Extensions)
RetrieveInstalledLanguagePacks | Retrieves the list of language packs installed on the server. (Developer Extensions)
RetrieveInstalledLanguagePackVersion | Retrieves the version of an installed language pack. (Developer Extensions)
RetrieveLicenseInfo | Retrieves the number of licenses for a deployment of Microsoft Dynamics CRM. (Developer Extensions)
RetrieveLocLabels | Retrieves the localized labels for the specified attribute. (Developer Extensions)
RetrieveMembersBulkOperation | Retrieves the members of a bulk operation. (Developer Extensions)
RetrieveMembersTeam | Deprecated. Retrieves the members of a team. (Developer Extensions)
RetrieveMissingComponents | Retrieves a list of missing components for the target organization. (Developer Extensions)
RetrieveMissingDependencies | Verifies whether any solution components are not included in the solution but possibly should be for a complete solution to be exported. (Developer Extensions)
RetrieveMultiple | Overloaded. Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query. (Developer Extensions)
RetrieveOrganizationResources | Retrieves the resources used by an organization. (Developer Extensions)
RetrieveParentGroupsResourceGroup | Retrieves a collection of the parent resource groups of the specified resource group (scheduling group). (Developer Extensions)
RetrieveParsedDataImportFile | Retrieves the data from the parse table. (Developer Extensions)
RetrievePrincipalAccess | Retrieves the access rights the specified security principal (user or team) has to a record. (Developer Extensions)
RetrievePrincipalAttributePrivileges | Retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity. (Developer Extensions)
RetrievePrivilegeSet | Retrieves the set of privileges defined in the system. (Developer Extensions)
RetrieveProvisionedLanguagePackVersion | Retrieves the version of the language packs installed on the server. (Developer Extensions)
RetrieveProvisionedLanguages | Retrieves the list of language packs installed on the server that are enabled. (Developer Extensions)
RetrieveRecordChangeHistory | Retrieves all changes to a specific entity. (Developer Extensions)
RetrieveRequiredComponents | Retrieves all components that this component requires. (Developer Extensions)
RetrieveRolePrivilegesRole | Retrieves the privileges that are assigned to the specified role. (Developer Extensions)
RetrieveSharedPrincipalsAndAccess | Retrieves all the security principals (users or teams) that have access to a record, together with their access rights to the record. (Developer Extensions)
RetrieveSubGroupsResourceGroup | Retrieves a collection of the child resource groups of the specified resource group (scheduling group). (Developer Extensions)
RetrieveSubsidiaryTeamsBusinessUnit | Deprecated. Retrieves all the team information for child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions)
RetrieveSubsidiaryUsersBusinessUnit | Deprecated. Retrieves all system users for the child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions)
RetrieveTeamPrivileges | Retrieves the privileges for a team. (Developer Extensions)
RetrieveTeamsSystemUser | Deprecated. Retrieves a collection of teams of which the specified system user is a member. Use RetrieveMultiple. (Developer Extensions)
RetrieveUnpublished | Retrieves the current saved definition of a Web resource, organization-owned chart, or organization-owned dashboard, whether it has been published or not. (Developer Extensions)
RetrieveUnpublishedMultiple | Retrieves the current saved definitions of Web resources, organization-owned charts, or organization-owned dashboards, whether they have been published or not. (Developer Extensions)
RetrieveUserPrivileges | Retrieves all the privileges a system user (user) has through his or her roles in the specified business unit. (Developer Extensions)
RetrieveUserSettingsSystemUser | Deprecated. Retrieves the system user settings for the specified system user. Use RetrieveMultiple. (Developer Extensions)
RetrieveVersion | Retrieves the version number of the Microsoft Dynamics CRM server. (Developer Extensions)
ReviseQuote | Sets the state of a quote to Draft. (Developer Extensions)
RevokeAccess | Removes all access to a record for the specified security principal (user or team). (Developer Extensions)
Rollup | Retrieves all the records related to the specified record (account or contact). This applies to all activity entities, annotation (note), contract, incident (case), invoice, opportunity, quote and sales order (order) entities. (Developer Extensions)
Search | Searches for available time slots that fulfill the specified appointment request. (Developer Extensions)
SearchByBodyKbArticle | Finds all the document indexes that contain the specified text in the body. (Developer Extensions)
SearchByKeywordsKbArticle | Finds all the document indexes that contain the specified keywords. (Developer Extensions)
SearchByTitleKbArticle | Finds all the document indexes that contain the specified text in the title. (Developer Extensions)
SendBulkMail | Sends bulk email messages. (Developer Extensions)
SendEmail | Sends an email message. (Developer Extensions)
SendEmailFromTemplate | Sends an email message using a template. (Developer Extensions)
SendFax | Sends a fax. (Developer Extensions)
SendTemplate | Sends a bulk email message that is created from a template. (Developer Extensions)
SetBusinessEquipment | Sets the business that owns the equipment. (Developer Extensions)
SetBusinessSystemUser | Sets the business unit for the specified system user. (Developer Extensions)
SetLocLabels | Sets the localized labels for the specified attribute. (Developer Extensions)
SetParentBusinessUnit | Sets the parent (manager) for the specified business unit. (Developer Extensions)
SetParentSystemUser | Sets the parent (manager) for the specified system user. (Developer Extensions)
SetParentTeam | Sets the parent (manager) for the specified team. (Developer Extensions)
SetRelated | Deprecated. Creates a link between an opportunity and an account, contact, or competitor. Use Associate. (Developer Extensions)
SetReportRelated | Specifies in which areas of Microsoft Dynamics CRM the report can be run and viewed. (Developer Extensions)
SetState | Overloaded. Sets the state of a record. (Developer Extensions)
StatusUpdateBulkOperation | For internal use only. (Developer Extensions)
TransformImport | Submits an asynchronous job to transform the parsed data. (Developer Extensions)
TriggerServiceEndpointCheck | Validates the configuration of a Windows Azure platform AppFabric solution’s service endpoint. (Developer Extensions)
UninstallSampleData | Uninstalls sample data for an organization. (Developer Extensions)
UnlockInvoicePricing | Unlocks the price per unit for the products in the specified invoice. (Developer Extensions)
UnlockSalesOrderPricing | Unlocks the price per unit for the products in the specified sales order (order). (Developer Extensions)
UnpublishDuplicateRule | Unpublishes a duplicate rule. (Developer Extensions)
UpdateUserSettingsSystemUser | Deprecated. Updates the user settings for a system user. Use Update. (Developer Extensions)
UtcTimeFromLocalTime | Retrieves the UTC time for the specified local time. (Developer Extensions)
Validate | Validates that all the constraints of an appointment or service appointment are met. (Developer Extensions)
ValidateRecurrenceRule | Validates a recurrence rule for a recurring appointment. (Developer Extensions)
ValidateSavedQuery | Validates a saved query. (Developer Extensions)
VerifyProcessStateData | For internal use only. (Developer Extensions)
WhoAmI | Retrieves the user information for the logged on user. (Developer Extensions)
WinOpportunity | Overloaded. Changes the state of an opportunity to Won. (Developer Extensions)
WinQuote | Changes the state of a quote to Won. (Developer Extensions)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceContextExtensions Class
Microsoft.Xrm.Client.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
AddItemCampaign | Adds an item to a campaign. The item added must be one of the following entity types: campaign, list, product, or salesliterature. (Developer Extensions)
AddItemCampaignActivity | Adds an item to a campaign activity. (Developer Extensions)
AddListMembersList | Adds a list of members to a list. (Developer Extensions)
AddMemberList | Adds a member to a list. The member added must be one of the following entity types: account, contact, or lead. (Developer Extensions)
AddMembersTeam | Adds members to a team. (Developer Extensions)
AddPrivilegesRole | Adds a set of existing privileges to an existing role. (Developer Extensions)
AddProductToKit | Adds a product to a kit. (Developer Extensions)
AddRecurrence | Adds recurrence information to an existing appointment to make it a recurring appointment master. (Developer Extensions)
AddSolutionComponent | Adds a solution component to an unmanaged solution. (Developer Extensions)
AddSubstituteProduct | Deprecated. Establishes an association between a product and a substitute product. Use Associate. (Developer Extensions)
AddToQueue | Moves a record from a source queue to a destination queue. (Developer Extensions)
Assign | Assigns the specified record to a new security principal (user). This changes the ownerid attribute of the instance. (Developer Extensions)
AssociateEntities | Deprecated. Adds a link between two records in a many-to-many relationship. Use Associate. (Developer Extensions)
AutoMapEntity | Creates the attribute mappings between two entities. (Developer Extensions)
BackgroundSendEmail | Sends an email asynchronously. (Developer Extensions)
Book | Schedules or "books" an appointment. (Developer Extensions)
BulkDelete | Submits an asynchronous bulk delete job. (Developer Extensions)
BulkDetectDuplicates | Submits an asynchronous duplicates detection job. (Developer Extensions)
BulkOperationStatusClose | For internal use only. (Developer Extensions)
CalculateActualValueOpportunity | Calculates the value of an opportunity that is in the "Won" state. (Developer Extensions)
CalculateTotalTimeIncident | Calculates the total number of minutes spent on an incident (case). (Developer Extensions)
CancelContract | Cancels a contract. (Developer Extensions)
CancelSalesOrder | Cancels a sales order. (Developer Extensions)
CheckIncomingEmail | Checks whether the incoming email message is relevant to the Microsoft Dynamics CRM system. (Developer Extensions)
CheckPromoteEmail | Checks whether the incoming email message should be promoted to the Microsoft Dynamics CRM system. (Developer Extensions)
CleanUpBulkOperation | For internal use only. (Developer Extensions)
CloneContract | Copies an existing contract and its line items. (Developer Extensions)
CloseIncident | Overloaded. Closes an incident (case). (Developer Extensions)
CloseQuote | Closes a quote. (Developer Extensions)
CompoundCreate | Deprecated. Creates a compound entity (salesorder, invoice, quote, or duplicaterule) and its related entity (salesorderdetail, invoicedetail, quotedetail, or duplicaterulecondition). Use Create. (Developer Extensions)
CompoundUpdate | Deprecated. Updates a compound record (salesorder, invoice, quote or duplicaterule) and its related detail record (salesorderdetail, invoicedetail, quotedetail or duplicaterulecondition). Use Update. (Developer Extensions)
CompoundUpdateDuplicateDetectionRule | Updates a duplicate rule (duplicate detection rule) and its related duplicate rule conditions. (Developer Extensions)
ConvertKitToProduct | Converts a kit to a product. (Developer Extensions)
ConvertProductToKit | Converts a product to a kit. (Developer Extensions)
ConvertQuoteToSalesOrder | Converts a quote to a sales order. (Developer Extensions)
ConvertSalesOrderToInvoice | Converts a sales order to an invoice. (Developer Extensions)
CopyCampaign | Copies a campaign. (Developer Extensions)
CopyCampaignResponse | Copies the information from one campaign response to another, and optionally creates a campaign response template. (Developer Extensions)
CopyDynamicListToStatic | Creates a static list from the specified dynamic list and adds the members that satisfy the dynamic list query criteria to the static list. (Developer Extensions)
CopyMembersList | Copies the members from the source list to the target list without creating duplicates. (Developer Extensions)
CopySystemForm | Creates a new entity form that is based on an existing entity form. (Developer Extensions)
CreateActivitiesList | Creates the activities for a list. (Developer Extensions)
CreateException | Creates an exception for the recurring appointment instance. (Developer Extensions)
CreateInstance | Creates future unexpanded instances of a recurring appointment master. (Developer Extensions)
CreateWorkflowFromTemplate | Creates a workflow from a workflow template. (Developer Extensions)
DeleteAuditData | Deletes all partitions containing audit data created before a given end date. (Developer Extensions)
DeleteOpenInstances | Deletes instances of a recurring appointment master that have an Open state. (Developer Extensions)
DeliverIncomingEmail | Creates an email activity record from an incoming email message. (Developer Extensions)
DeliverPromoteEmail | Creates an email activity instance from the specified email message (Track in CRM). (Developer Extensions)
DeprovisionLanguage | Deprovisions a language. (Developer Extensions)
DisassociateEntities | Deprecated. Removes a link between two records in a many to many relationship. Use Disassociate. (Developer Extensions)
DistributeCampaignActivity | Creates a bulk operation to distribute the activity, creating the appropriate activity for each member in the list for the specified campaign activity. (Developer Extensions)
DownloadReportDefinition | Downloads a report definition. (Developer Extensions)
ExecuteByIdSavedQuery | Executes a saved query (view) that has the specified ID. (Developer Extensions)
ExecuteByIdUserQuery | Executes the user query (saved view) that has the specified ID. (Developer Extensions)
ExecuteFetch | Deprecated. Executes the specified Fetch XML query. Use RetrieveMultiple. (Developer Extensions)
ExecuteWorkflow | Executes a workflow. (Developer Extensions)
ExpandCalendar | Converts the calendar rules to an array of available time blocks for the specified period. (Developer Extensions)
ExportSolution | Exports a managed or unmanaged solution. (Developer Extensions)
ExportTranslation | Exports all translations for a specific solution to a compressed file. (Developer Extensions)
FetchXmlToQueryExpression | Converts a query in Fetch XML to a QueryExpression. (Developer Extensions)
FindParentResourceGroup | Finds a parent resource group (scheduling group) for the specified resource groups (scheduling groups). (Developer Extensions)
FulfillSalesOrder | Fulfills a sales order (order). (Developer Extensions)
GenerateInvoiceFromOpportunity | Generates an invoice from an opportunity. (Developer Extensions)
GenerateQuoteFromOpportunity | Generates a quote from an opportunity. (Developer Extensions)
GenerateSalesOrderFromOpportunity | Generates a sales order from an opportunity. (Developer Extensions)
GetAllTimeZonesWithDisplayName | Retrieves all the time-zone definitions for the specified locale returning only the display name attribute. (Developer Extensions)
GetDecryptionKey | Gets a decryption key. (Developer Extensions)
GetDistinctValuesImportFile | Returns distinct values for a column in the source file that contains list values. (Developer Extensions)
GetHeaderColumnsImportFile | Retrieves the source-file column headings, or system-generated column headings, if the source file does not contain column headings. (Developer Extensions)
GetInvoiceProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the specified invoice. (Developer Extensions)
GetQuantityDecimal | Gets the quantity decimal value for a product. (Developer Extensions)
GetQuoteProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the quote. (Developer Extensions)
GetReportHistoryLimit | Gets the history limit for a report. (Developer Extensions)
GetSalesOrderProductsFromOpportunity | Retrieves the products from an opportunity and copies them to the sales order. (Developer Extensions)
GetTimeZoneCodeByLocalizedName | Retrieves the time-zone code for the specified localized time-zone name. (Developer Extensions)
GetTrackingTokenEmail | Returns a tracking token that can be then passed in as a parameter to the SendEmail method. (Developer Extensions)
GrantAccess | Grants a security principal (user or team) access to the specified record. (Developer Extensions)
ImportRecordsImport | Imports XML mappings and creates an import data map. (Developer Extensions)
ImportSolution | Imports a managed or unmanaged solution. (Developer Extensions)
ImportTranslation | Imports all translations from a compressed file. (Developer Extensions)
InitializeFrom | Initializes a new record from an existing record. (Developer Extensions)
InstallSampleData | Installs sample data for an organization. (Developer Extensions)
InstantiateFilters | Instantiates a filter. (Developer Extensions)
InstantiateTemplate | Creates an email message from a template. (Developer Extensions)
IsBackOfficeInstalled | Deprecated. Checks if Microsoft Great Plains is installed. (Developer Extensions)
IsComponentCustomizable | Determines whether a solution component is customizable. (Developer Extensions)
IsValidStateTransition | Checks to see if the state transition is valid. (Developer Extensions)
LocalTimeFromUtcTime | Retrieves the local time for the specified Universal Time Coordinate (UTC) time. (Developer Extensions)
LockInvoicePricing | Locks the total price of products and services specified in the invoice. When the invoice pricing is locked, changes to underlying price lists (price levels) do not affect the prices for an invoice. (Developer Extensions)
LockSalesOrderPricing | Locks the total price of products and services specified in the sales order (order). When the sales order pricing is locked, changes to underlying price lists (price levels) do not affect the prices for a sales order (order). (Developer Extensions)
LogFailureBulkOperation | For internal use only. (Developer Extensions)
LogSuccessBulkOperation | For internal use only. (Developer Extensions)
LoseOpportunity | Overloaded. Sets the state of an opportunity to Lost. (Developer Extensions)
MakeAvailableToOrganizationReport | Deprecated. Makes the report available to all users in the organization. Use Update. (Developer Extensions)
MakeAvailableToOrganizationTemplate | Deprecated. Makes the specified email template available to the entire organization. Use Update. (Developer Extensions)
MakeUnavailableToOrganizationReport | Deprecated. Makes the report unavailable to all users in the organization. Use Update. (Developer Extensions)
MakeUnavailableToOrganizationTemplate | Deprecated. Makes the specified email template no longer available to the entire organization. Use Update. (Developer Extensions)
Merge | Merges the information from two records of the same type. (Developer Extensions)
ModifyAccess | Replaces the access rights on the target record for the specified security principal (user or team). (Developer Extensions)
ParseImport | Submits an asynchronous job that parses all import files associated with the specified data import (import). (Developer Extensions)
ProcessInboundEmail | Processes marketing campaign email responses. (Developer Extensions)
ProcessOneMemberBulkOperation | For internal use only. (Developer Extensions)
PropagateByExpression | Distributes an activity to a quick campaign. (Developer Extensions)
ProvisionLanguage | Provisions a language. (Developer Extensions)
PublishAllXml | Publishes all customizations. (Developer Extensions)
PublishDuplicateRule | Submits an asynchronous job to publish a duplicate rule. (Developer Extensions)
PublishXml | Publishes the customizations for the specified entities. (Developer Extensions)
QualifyLead | Qualifies a lead and creates an account, contact, or opportunity records that are linked to the originating lead. (Developer Extensions)
QualifyMemberList | Qualifies the specified member list and either overrides the list members or removes them according to the specified option. (Developer Extensions)
QueryExpressionToFetchXml | Converts a query represented as a QueryExpression class to the equivalent query represented as FetchXML. (Developer Extensions)
QueryMultipleSchedules | Searches multiple resources for an available time slot matching the specified parameters. This is similar to the QuerySchedule method but it works for multiple resources at one time. (Developer Extensions)
QuerySchedule | Searches the specified resource for an available time slot matching the specified parameters. (Developer Extensions)
ReassignObjectsOwner | Reassigns all records that are owned by the security principal (user or team) to another security principal (user or team). (Developer Extensions)
ReassignObjectsSystemUser | Reassigns all records that are owned by the user to another security principal (user or team). (Developer Extensions)
Recalculate | Recalculates the rollup attribute values for all goals in the goal hierarchy that contain a specified goal. (Developer Extensions)
RemoveItemCampaign | Removes an item from a campaign. (Developer Extensions)
RemoveItemCampaignActivity | Removes an item from a campaign activity. (Developer Extensions)
RemoveMemberList | Removes a member from a list. (Developer Extensions)
RemoveMembersTeam | Removes members from a team. (Developer Extensions)
RemoveParent | Removes the parent for a record. (Developer Extensions)
RemovePrivilegeRole | Removes a privilege from an existing role. (Developer Extensions)
RemoveProductFromKit | Removes a product from a kit. (Developer Extensions)
RemoveRelated | Deprecated. Removes the relationship between two records as defined by the target classes listed below. For example, remove the relationship between an invoice and a contact. (Developer Extensions)
RemoveSolutionComponent | Removes a solution component to an unmanaged solution. (Developer Extensions)
RemoveSubstituteProduct | Deprecated. Removes the association between a product and a substitute product. Use Disassociate. (Developer Extensions)
RenewContract | Renews a contract. (Developer Extensions)
ReplacePrivilegesRole | Replaces the privilege set of an existing role. This effectively deletes all existing privileges from the role and adds the new specified privileges. (Developer Extensions)
Reschedule | Reschedules an appointment, service appointment or recurring appointment. (Developer Extensions)
ResetUserFilters | Resets the offline data filters for the calling user to the default filters for the organization. (Developer Extensions)
RetrieveAbsoluteAndSiteCollectionUrl | Retrieves the absolute (complete) URL and the site collection URL of a SharePoint document location or SharePoint site. (Developer Extensions)
RetrieveAllChildUsersSystemUser | Retrieves a collection of system users who report to the specified system user. (Developer Extensions)
RetrieveAllEntities | Retrieves the metadata for all entities. (Developer Extensions)
RetrieveApplicationRibbon | Retrieves the core application ribbons including the entity template. (Developer Extensions)
RetrieveAttribute | Retrieves the metadata for the specified attribute. (Developer Extensions)
RetrieveAttributeChangeHistory | Retrieves all changes to a specific attribute. (Developer Extensions)
RetrieveAuditDetails | Retrieves the full audit details of a particular audit record. (Developer Extensions)
RetrieveAuditPartitionList | Retrieves the list of auditing partitions. (Developer Extensions)
RetrieveAvailableLanguages | Retrieves the list of available languages. (Developer Extensions)
RetrieveBusinessHierarchyBusinessUnit | Retrieves all the business units in the business unit hierarchy. (Developer Extensions)
RetrieveByGroupResource | Retrieves all the resource groups to which the specified resource belongs. (Developer Extensions)
RetrieveByResourceResourceGroup | Retrieves the resource groups that contain the specified resource. (Developer Extensions)
RetrieveByResourcesService | Retrieves a collection of services related to the specified set of services. (Developer Extensions)
RetrieveByTopIncidentProductKbArticle | Retrieves the top ten knowledge base articles for the product specified. (Developer Extensions)
RetrieveByTopIncidentSubjectKbArticle | Retrieves the top ten knowledge base articles for the subject specified. (Developer Extensions)
RetrieveDependenciesForDelete | Retrieves the dependencies for solution components that will prevent a solution component from being deleted. (Developer Extensions)
RetrieveDependenciesForUninstall | Retrieves the dependencies for solution components that could prevent uninstalling a managed solution. (Developer Extensions)
RetrieveDependentComponents | Retrieves all components that depend on the specified component. (Developer Extensions)
RetrieveDeploymentLicenseType | Retrieves the type of license for a deployment of Microsoft Dynamics CRM. (Developer Extensions)
RetrieveDeprovisionedLanguages | Retrieves the list of language packs installed on the server that have been disabled. (Developer Extensions)
RetrieveDuplicates | Detects and retrieves duplicate records for the specified record, provided duplicate detection is enabled and there are published duplicate detection rules for the entity. (Developer Extensions)
RetrieveEntity | Retrieves the metadata for the specified entity. (Developer Extensions)
RetrieveEntityRibbon | Retrieves the ribbon definition used for a specific entity. (Developer Extensions)
RetrieveExchangeRate | Retrieves the exchange rate. (Developer Extensions)
RetrieveFilteredForms | Retrieves the system forms for the specified user. (Developer Extensions)
RetrieveFormattedImportJobResults | Retrieves the formatted results from an import job. (Developer Extensions)
RetrieveFormXml | For internal use only. (Developer Extensions)
RetrieveInstalledLanguagePacks | Retrieves the list of language packs installed on the server. (Developer Extensions)
RetrieveInstalledLanguagePackVersion | Retrieves the version of an installed language pack. (Developer Extensions)
RetrieveLicenseInfo | Retrieves the number of licenses for a deployment of Microsoft Dynamics CRM. (Developer Extensions)
RetrieveLocLabels | Retrieves the localized labels for the specified attribute. (Developer Extensions)
RetrieveMembersBulkOperation | Retrieves the members of a bulk operation. (Developer Extensions)
RetrieveMembersTeam | Deprecated. Retrieves the members of a team. (Developer Extensions)
RetrieveMissingComponents | Retrieves a list of missing components for the target organization. (Developer Extensions)
RetrieveMissingDependencies | Verifies whether any solution components are not included in the solution but possibly should be for a complete solution to be exported. (Developer Extensions)
RetrieveMultiple | Overloaded. Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query. (Developer Extensions)
RetrieveOrganizationResources | Retrieves the resources used by an organization. (Developer Extensions)
RetrieveParentGroupsResourceGroup | Retrieves a collection of the parent resource groups of the specified resource group (scheduling group). (Developer Extensions)
RetrieveParsedDataImportFile | Retrieves the data from the parse table. (Developer Extensions)
RetrievePrincipalAccess | Retrieves the access rights the specified security principal (user or team) has to a record. (Developer Extensions)
RetrievePrincipalAttributePrivileges | Retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity. (Developer Extensions)
RetrievePrivilegeSet | Retrieves the set of privileges defined in the system. (Developer Extensions)
RetrieveProvisionedLanguagePackVersion | Retrieves the version of the language packs installed on the server. (Developer Extensions)
RetrieveProvisionedLanguages | Retrieves the list of language packs installed on the server that are enabled. (Developer Extensions)
RetrieveRecordChangeHistory | Retrieves all changes to a specific entity. (Developer Extensions)
RetrieveRequiredComponents | Retrieves all components that this component requires. (Developer Extensions)
RetrieveRolePrivilegesRole | Retrieves the privileges that are assigned to the specified role. (Developer Extensions)
RetrieveSharedPrincipalsAndAccess | Retrieves all the security principals (users or teams) that have access to a record, together with their access rights to the record. (Developer Extensions)
RetrieveSubGroupsResourceGroup | Retrieves a collection of the child resource groups of the specified resource group (scheduling group). (Developer Extensions)
RetrieveSubsidiaryTeamsBusinessUnit | Deprecated. Retrieves all the team information for child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions)
RetrieveSubsidiaryUsersBusinessUnit | Deprecated. Retrieves all system users for the child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions)
RetrieveTeamPrivileges | Retrieves the privileges for a team. (Developer Extensions)
RetrieveTeamsSystemUser | Deprecated. Retrieves a collection of teams of which the specified system user is a member. Use RetrieveMultiple. (Developer Extensions)
RetrieveUnpublished | Retrieves the current saved definition of a Web resource, organization-owned chart, or organization-owned dashboard, whether it has been published or not. (Developer Extensions)
RetrieveUnpublishedMultiple | Retrieves the current saved definitions of Web resources, organization-owned charts, or organization-owned dashboards, whether they have been published or not. (Developer Extensions)
RetrieveUserPrivileges | Retrieves all the privileges a system user (user) has through his or her roles in the specified business unit. (Developer Extensions)
RetrieveUserSettingsSystemUser | Deprecated. Retrieves the system user settings for the specified system user. Use RetrieveMultiple. (Developer Extensions)
RetrieveVersion | Retrieves the version number of the Microsoft Dynamics CRM server. (Developer Extensions)
ReviseQuote | Sets the state of a quote to Draft. (Developer Extensions)
RevokeAccess | Removes all access to a record for the specified security principal (user or team). (Developer Extensions)
Rollup | Retrieves all the records related to the specified record (account or contact). This applies to all activity entities, annotation (note), contract, incident (case), invoice, opportunity, quote and sales order (order) entities. (Developer Extensions)
Search | Searches for available time slots that fulfill the specified appointment request. (Developer Extensions)
SearchByBodyKbArticle | Finds all the document indexes that contain the specified text in the body. (Developer Extensions)
SearchByKeywordsKbArticle | Finds all the document indexes that contain the specified keywords. (Developer Extensions)
SearchByTitleKbArticle | Finds all the document indexes that contain the specified text in the title. (Developer Extensions)
SendBulkMail | Sends bulk email messages. (Developer Extensions)
SendEmail | Sends an email message. (Developer Extensions)
SendEmailFromTemplate | Sends an email message using a template. (Developer Extensions)
SendFax | Sends a fax. (Developer Extensions)
SendTemplate | Sends a bulk email message that is created from a template. (Developer Extensions)
SetBusinessEquipment | Sets the business that owns the equipment. (Developer Extensions)
SetBusinessSystemUser | Sets the business unit for the specified system user. (Developer Extensions)
SetLocLabels | Sets the localized labels for the specified attribute. (Developer Extensions)
SetParentBusinessUnit | Sets the parent (manager) for the specified business unit. (Developer Extensions)
SetParentSystemUser | Sets the parent (manager) for the specified system user. (Developer Extensions)
SetParentTeam | Sets the parent (manager) for the specified team. (Developer Extensions)
SetRelated | Deprecated. Creates a link between an opportunity and an account, contact, or competitor. Use Associate. (Developer Extensions)
SetReportRelated | Specifies in which areas of Microsoft Dynamics CRM the report can be run and viewed. (Developer Extensions)
SetState | Overloaded. Sets the state of a record. (Developer Extensions)
StatusUpdateBulkOperation | For internal use only. (Developer Extensions)
TransformImport | Submits an asynchronous job to transform the parsed data. (Developer Extensions)
TriggerServiceEndpointCheck | Validates the configuration of a Windows Azure platform AppFabric solution’s service endpoint. (Developer Extensions)
UninstallSampleData | Uninstalls sample data for an organization. (Developer Extensions)
UnlockInvoicePricing | Unlocks the price per unit for the products in the specified invoice. (Developer Extensions)
UnlockSalesOrderPricing | Unlocks the price per unit for the products in the specified sales order (order). (Developer Extensions)
UnpublishDuplicateRule | Unpublishes a duplicate rule. (Developer Extensions)
UpdateUserSettingsSystemUser | Deprecated. Updates the user settings for a system user. Use Update. (Developer Extensions)
UtcTimeFromLocalTime | Retrieves the UTC time for the specified local time. (Developer Extensions)
Validate | Validates that all the constraints of an appointment or service appointment are met. (Developer Extensions)
ValidateRecurrenceRule | Validates a recurrence rule for a recurring appointment. (Developer Extensions)
ValidateSavedQuery | Validates a saved query. (Developer Extensions)
VerifyProcessStateData | For internal use only. (Developer Extensions)
WhoAmI | Retrieves the user information for the logged on user. (Developer Extensions)
WinOpportunity | Overloaded. Changes the state of an opportunity to Won. (Developer Extensions)
WinQuote | Changes the state of a quote to Won. (Developer Extensions)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceContextExtensions Class
Microsoft.Xrm.Client.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddItemCampaign Method
[image]

Adds an item to a campaign. The item added must be one of the following entity types: campaign, list, product, or salesliterature. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim campaignId As Guid
Dim entityId As Guid
Dim entityName As String
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.AddItemCampaign(context, campaignId, entityId, entityName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function AddItemCampaign ( _
    context As OrganizationServiceContext, _
    campaignId As Guid, _
    entityId As Guid, _
    entityName As String _
) As Guid
C#
[ExtensionAttribute]
public static Guid AddItemCampaign (
    OrganizationServiceContext context,
    Guid campaignId,
    Guid entityId,
    string entityName
)
C++

J#

JScript

Parameters
context
The organization service context.
campaignId
The ID of the campaign.
entityId
The ID of the entity to add to the campaign.
entityName
The entity name for entityId.
Return Value
Returns a Guid that contains the ID of the resulting campaign activity item.

  Remarks
This is a method wrapper for the AddItemCampaignRequest and AddItemCampaignResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddItemCampaignActivity Method
[image]

Adds an item to a campaign activity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim campaignActivityId As Guid
Dim itemId As Guid
Dim entityName As String
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.AddItemCampaignActivity(context, campaignActivityId, itemId, entityName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function AddItemCampaignActivity ( _
    context As OrganizationServiceContext, _
    campaignActivityId As Guid, _
    itemId As Guid, _
    entityName As String _
) As Guid
C#
[ExtensionAttribute]
public static Guid AddItemCampaignActivity (
    OrganizationServiceContext context,
    Guid campaignActivityId,
    Guid itemId,
    string entityName
)
C++

J#

JScript

Parameters
context
The organization service context.
campaignActivityId
The ID of the campaign activity.
itemId
The ID of the record to add to the campaign activity.
entityName
The entity name itemId.
Return Value
Returns a  Guid that contains the ID of the resulting campaign item.

  Remarks
This is a method wrapper for the AddItemCampaignActivityRequest and AddItemCampaignActivityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddListMembersList Method
[image]

Adds a list of members to a list. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim listId As Guid
Dim memberIds As Guid()

OrganizationServiceContextExtensions.AddListMembersList(context, listId, memberIds)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddListMembersList ( _
    context As OrganizationServiceContext, _
    listId As Guid, _
    memberIds As Guid() _
)
C#
[ExtensionAttribute]
public static void AddListMembersList (
    OrganizationServiceContext context,
    Guid listId,
    Guid[] memberIds
)
C++

J#

JScript

Parameters
context
The organization service context.
listId
The ID of the list.
memberIds
An array of the IDs of the members to add to the list.
  Remarks
This is a method wrapper for the AddListMembersListRequest and AddListMembersListResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddMemberList Method
[image]

Adds a member to a list. The member added must be one of the following entity types: account, contact, or lead. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim listId As Guid
Dim entityId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.AddMemberList(context, listId, entityId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function AddMemberList ( _
    context As OrganizationServiceContext, _
    listId As Guid, _
    entityId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid AddMemberList (
    OrganizationServiceContext context,
    Guid listId,
    Guid entityId
)
C++

J#

JScript

Parameters
context
The organization service context.
listId
The ID of the list.
entityId
The ID of the record to add to the list.
Return Value
Returns a Guid that contains the ID of the resulting list member.

  Remarks
This is a method wrapper for the AddMemberListRequest and AddMemberListResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddMembersTeam Method
[image]

Adds members to a team. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim teamId As Guid
Dim memberIds As Guid()

OrganizationServiceContextExtensions.AddMembersTeam(context, teamId, memberIds)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddMembersTeam ( _
    context As OrganizationServiceContext, _
    teamId As Guid, _
    memberIds As Guid() _
)
C#
[ExtensionAttribute]
public static void AddMembersTeam (
    OrganizationServiceContext context,
    Guid teamId,
    Guid[] memberIds
)
C++

J#

JScript

Parameters
context
The organization service context.
teamId
The ID of the team.
memberIds
An array of the IDs of the members to add to the team.
  Remarks
This is a method wrapper for the AddMembersTeamRequest and AddMembersTeamResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddPrivilegesRole Method
[image]

Adds a set of existing privileges to an existing role. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim roleId As Guid
Dim privileges As Object

OrganizationServiceContextExtensions.AddPrivilegesRole(context, roleId, privileges)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddPrivilegesRole ( _
    context As OrganizationServiceContext, _
    roleId As Guid, _
    privileges As Object _
)
C#
[ExtensionAttribute]
public static void AddPrivilegesRole (
    OrganizationServiceContext context,
    Guid roleId,
    Object privileges
)
C++

J#

JScript

Parameters
context
The organization service context.
roleId
The ID of the role.
privileges
The privileges to add to the role.
  Remarks
This is a method wrapper for the AddPrivilegesRoleRequest and AddPrivilegesRoleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddProductToKit Method
[image]

Adds a product to a kit. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim kitId As Guid
Dim productId As Guid

OrganizationServiceContextExtensions.AddProductToKit(context, kitId, productId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddProductToKit ( _
    context As OrganizationServiceContext, _
    kitId As Guid, _
    productId As Guid _
)
C#
[ExtensionAttribute]
public static void AddProductToKit (
    OrganizationServiceContext context,
    Guid kitId,
    Guid productId
)
C++

J#

JScript

Parameters
context
The organization service context.
kitId
The ID of the kit.
productId
The ID of the product to add to the kit.
  Remarks
This is a method wrapper for the AddProductToKitRequest and AddProductToKitResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddRecurrence Method
[image]

Adds recurrence information to an existing appointment to make it a recurring appointment master. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As Entity
Dim appointmentId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.AddRecurrence(context, target, appointmentId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function AddRecurrence ( _
    context As OrganizationServiceContext, _
    target As Entity, _
    appointmentId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid AddRecurrence (
    OrganizationServiceContext context,
    Entity target,
    Guid appointmentId
)
C++

J#

JScript

Parameters
context
The organization service context.
target
The recurring appointment master record to which the appointment is converted.
appointmentId
The ID of the appointment that needs to be converted into a recurring appointment.
Return Value
Returns a Guid, the ID of the newly created recurring appointment.

  Remarks
This is a method wrapper for the AddRecurrenceRequest and AddRecurrenceResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddSolutionComponent Method
[image]

Adds a solution component to an unmanaged solution. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim componentId As Guid
Dim componentType As Integer
Dim solutionUniqueName As String
Dim addRequiredComponents As Boolean
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.AddSolutionComponent(context, componentId, componentType, solutionUniqueName, addRequiredComponents)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function AddSolutionComponent ( _
    context As OrganizationServiceContext, _
    componentId As Guid, _
    componentType As Integer, _
    solutionUniqueName As String, _
    addRequiredComponents As Boolean _
) As Guid
C#
[ExtensionAttribute]
public static Guid AddSolutionComponent (
    OrganizationServiceContext context,
    Guid componentId,
    int componentType,
    string solutionUniqueName,
    bool addRequiredComponents
)
C++

J#

JScript

Parameters
context
The organization service context.
componentId
The ID of the solution component.
componentType
The value that represents the solution component that you are adding.
solutionUniqueName
The unique name of the solution for which you want to add the solution component.
addRequiredComponents
Indicates whether the solution components that are required by the solution component that you are adding are also added to the unmanaged solution.
Return Value
Returns a Guid, the ID of the new solution component record.

  Remarks
This is a method wrapper for the AddSolutionComponentRequest and AddSolutionComponentResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddSubstituteProduct Method
[image]

Deprecated. Establishes an association between a product and a substitute product. Use Associate. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim productId As Guid
Dim substituteId As Guid

OrganizationServiceContextExtensions.AddSubstituteProduct(context, productId, substituteId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AddSubstituteProduct ( _
    context As OrganizationServiceContext, _
    productId As Guid, _
    substituteId As Guid _
)
C#
[ExtensionAttribute]
public static void AddSubstituteProduct (
    OrganizationServiceContext context,
    Guid productId,
    Guid substituteId
)
C++

J#

JScript

Parameters
context
The organization service context.
productId
The ID of the product.
substituteId
The ID of the substitute product.
  Remarks
This is a method wrapper for the AddSubstituteProductRequest and AddSubstituteProductResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AddToQueue Method
[image]

Moves a record from a source queue to a destination queue. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim sourceQueueId As Guid
Dim destinationQueueId As Guid
Dim queueItemProperties As Entity
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.AddToQueue(context, target, sourceQueueId, destinationQueueId, queueItemProperties)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function AddToQueue ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    sourceQueueId As Guid, _
    destinationQueueId As Guid, _
    queueItemProperties As Entity _
) As Guid
C#
[ExtensionAttribute]
public static Guid AddToQueue (
    OrganizationServiceContext context,
    EntityReference target,
    Guid sourceQueueId,
    Guid destinationQueueId,
    Entity queueItemProperties
)
C++

J#

JScript

Parameters
context
The organization service context.
target
The target record to add to the destination queue.
sourceQueueId
The ID of the source queue.
destinationQueueId
The ID of the destination queue.
queueItemProperties
The properties that are needed to create a queue item in the destination queue.
Return Value
Returns a Guid, the ID of the queue item that is created in the destination queue.

  Remarks
This is a method wrapper for the AddToQueueRequest and AddToQueueResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.Assign Method
[image]

Assigns the specified record to a new security principal (user). This changes the ownerid attribute of the instance. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim assignee As EntityReference

OrganizationServiceContextExtensions.Assign(context, target, assignee)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub Assign ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    assignee As EntityReference _
)
C#
[ExtensionAttribute]
public static void Assign (
    OrganizationServiceContext context,
    EntityReference target,
    EntityReference assignee
)
C++

J#

JScript

Parameters
context
The organization service context.
target
The target record to assign.
assignee
The user or team for which you want to assign a record.
  Remarks
This is a method wrapper for the AssignRequest and AssignResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AssociateEntities Method
[image]

Deprecated. Adds a link between two records in a many-to-many relationship. Use Associate. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim moniker1 As EntityReference
Dim moniker2 As EntityReference
Dim relationshipName As String

OrganizationServiceContextExtensions.AssociateEntities(context, moniker1, moniker2, relationshipName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AssociateEntities ( _
    context As OrganizationServiceContext, _
    moniker1 As EntityReference, _
    moniker2 As EntityReference, _
    relationshipName As String _
)
C#
[ExtensionAttribute]
public static void AssociateEntities (
    OrganizationServiceContext context,
    EntityReference moniker1,
    EntityReference moniker2,
    string relationshipName
)
C++

J#

JScript

Parameters
context
The organization service context.
moniker1
moniker2
relationshipName
  Remarks
This is a method wrapper for the AssociateEntitiesRequest and AssociateEntitiesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.AutoMapEntity Method
[image]

Creates the attribute mappings between two entities. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityMapId As Guid

OrganizationServiceContextExtensions.AutoMapEntity(context, entityMapId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub AutoMapEntity ( _
    context As OrganizationServiceContext, _
    entityMapId As Guid _
)
C#
[ExtensionAttribute]
public static void AutoMapEntity (
    OrganizationServiceContext context,
    Guid entityMapId
)
C++

J#

JScript

Parameters
context
The organization service context.
entityMapId
The ID of the entity map to overwrite when the automated mapping is performed.
  Remarks
This is a method wrapper for the AutoMapEntityRequest and AutoMapEntityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.BackgroundSendEmail Method
[image]

Sends an email asynchronously. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim query As QueryBase
Dim returnValue As TResponse

returnValue = OrganizationServiceContextExtensions.BackgroundSendEmail(context, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function BackgroundSendEmail(Of TResponse As OrganizationResponse) ( _
    context As OrganizationServiceContext, _
    query As QueryBase _
) As TResponse
C#
[ExtensionAttribute]
public static TResponse BackgroundSendEmail<TResponse> (
    OrganizationServiceContext context,
    QueryBase query
) where TResponse : OrganizationResponse
C++

J#

JScript

GenericParameters
TResponse
Parameters
context
The organization service context.
query
The query to find the email activities to send.
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the BackgroundSendEmailRequest and BackgroundSendEmailResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.Book Method
[image]

Schedules or "books" an appointment. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As Entity
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.Book(context, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Book(Of TResult) ( _
    context As OrganizationServiceContext, _
    target As Entity _
) As TResult
C#
[ExtensionAttribute]
public static TResult Book<TResult> (
    OrganizationServiceContext context,
    Entity target
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
target
The appointment to book.
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the BookRequest and BookResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.BulkDelete Method
[image]

Submits an asynchronous bulk delete job. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim querySet As QueryExpression()
Dim jobName As String
Dim sendEmailNotification As Boolean
Dim toRecipients As Guid()
Dim cCRecipients As Guid()
Dim recurrencePattern As String
Dim startDateTime As DateTime
Dim sourceImportId As Nullable(Of Guid)
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.BulkDelete(context, querySet, jobName, sendEmailNotification, toRecipients, cCRecipients, recurrencePattern, startDateTime, sourceImportId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function BulkDelete ( _
    context As OrganizationServiceContext, _
    querySet As QueryExpression(), _
    jobName As String, _
    sendEmailNotification As Boolean, _
    toRecipients As Guid(), _
    cCRecipients As Guid(), _
    recurrencePattern As String, _
    startDateTime As DateTime, _
    sourceImportId As Nullable(Of Guid) _
) As Guid
C#
[ExtensionAttribute]
public static Guid BulkDelete (
    OrganizationServiceContext context,
    QueryExpression[] querySet,
    string jobName,
    bool sendEmailNotification,
    Guid[] toRecipients,
    Guid[] cCRecipients,
    string recurrencePattern,
    DateTime startDateTime,
    Nullable<Guid> sourceImportId
)
C++

J#

JScript

Parameters
context
The organization service context.
querySet
An array of queries for a bulk delete job.
jobName
The name of an asynchronous bulk delete job.
sendEmailNotification
Indicates whether an email notification is sent after the bulk delete job has finished running.
toRecipients
cCRecipients
An array of IDs for the system users (users) who are listed in the Cc box of the email notification.
recurrencePattern
The recurrence pattern for the bulk delete job.
startDateTime
sourceImportId
Return Value
Returns a Guid, the ID of an asynchronous bulk delete job that performs a bulk deletion.

  Remarks
This is a method wrapper for the BulkDeleteRequest and BulkDeleteResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.BulkDetectDuplicates Method
[image]

Submits an asynchronous duplicates detection job. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim query As QueryBase
Dim jobName As String
Dim sendEmailNotification As Boolean
Dim templateId As Guid
Dim toRecipients As Guid()
Dim cCRecipients As Guid()
Dim recurrencePattern As String
Dim recurrenceStartTime As DateTime
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.BulkDetectDuplicates(context, query, jobName, sendEmailNotification, templateId, toRecipients, cCRecipients, recurrencePattern, recurrenceStartTime)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function BulkDetectDuplicates ( _
    context As OrganizationServiceContext, _
    query As QueryBase, _
    jobName As String, _
    sendEmailNotification As Boolean, _
    templateId As Guid, _
    toRecipients As Guid(), _
    cCRecipients As Guid(), _
    recurrencePattern As String, _
    recurrenceStartTime As DateTime _
) As Guid
C#
[ExtensionAttribute]
public static Guid BulkDetectDuplicates (
    OrganizationServiceContext context,
    QueryBase query,
    string jobName,
    bool sendEmailNotification,
    Guid templateId,
    Guid[] toRecipients,
    Guid[] cCRecipients,
    string recurrencePattern,
    DateTime recurrenceStartTime
)
C++

J#

JScript

Parameters
context
The organization service context.
query
An array of queries to detect multiple duplicate records. Required.
jobName
The name of the asynchronous system job that detects and logs multiple duplicate records. Required.
sendEmailNotification
A value that indicates whether an email notification is sent after the asynchronous system job that detects multiple duplicate records finishes running. Required.
templateId
The the template (email template) that is used for the email notification.
toRecipients
An array of IDs for the system users (users) who are listed in the To box of the email notification.
cCRecipients
An array of IDs for the system users (users) who are listed in the Cc box of the email notification.
recurrencePattern
The recurrence pattern for the asynchronous system job that detects multiple duplicate records. Optional.
recurrenceStartTime
The start date and time of an asynchronous system job that detects and logs multiple duplicate records. Optional.
Return Value
Returns a Guid, the ID of an asynchronous bulk detect duplicates job that detects and logs duplicate records.

  Remarks
This is a method wrapper for the BulkDetectDuplicatesRequest and BulkDetectDuplicatesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.BulkOperationStatusClose Method
[image]

For internal use only. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim bulkOperationId As Guid
Dim failureCount As Integer
Dim successCount As Integer
Dim statusReason As Integer
Dim errorCode As Integer

OrganizationServiceContextExtensions.BulkOperationStatusClose(context, bulkOperationId, failureCount, successCount, statusReason, errorCode)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub BulkOperationStatusClose ( _
    context As OrganizationServiceContext, _
    bulkOperationId As Guid, _
    failureCount As Integer, _
    successCount As Integer, _
    statusReason As Integer, _
    errorCode As Integer _
)
C#
[ExtensionAttribute]
public static void BulkOperationStatusClose (
    OrganizationServiceContext context,
    Guid bulkOperationId,
    int failureCount,
    int successCount,
    int statusReason,
    int errorCode
)
C++

J#

JScript

Parameters
context
The organization service context.
bulkOperationId
failureCount
successCount
statusReason
errorCode
  Remarks
This is a method wrapper for the BulkOperationStatusCloseRequest and BulkOperationStatusCloseResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CalculateActualValueOpportunity Method
[image]

Calculates the value of an opportunity that is in the "Won" state. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityId As Guid
Dim returnValue As Decimal

returnValue = OrganizationServiceContextExtensions.CalculateActualValueOpportunity(context, opportunityId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CalculateActualValueOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityId As Guid _
) As Decimal
C#
[ExtensionAttribute]
public static decimal CalculateActualValueOpportunity (
    OrganizationServiceContext context,
    Guid opportunityId
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityId
The ID of the opportunity. Required.
Return Value
Returns aDecimal, the actual value of an opportunity.

  Remarks
This is a method wrapper for the CalculateActualValueOpportunityRequest and CalculateActualValueOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CalculateTotalTimeIncident Method
[image]

Calculates the total number of minutes spent on an incident (case). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim incidentId As Guid
Dim returnValue As Long

returnValue = OrganizationServiceContextExtensions.CalculateTotalTimeIncident(context, incidentId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CalculateTotalTimeIncident ( _
    context As OrganizationServiceContext, _
    incidentId As Guid _
) As Long
C#
[ExtensionAttribute]
public static long CalculateTotalTimeIncident (
    OrganizationServiceContext context,
    Guid incidentId
)
C++

J#

JScript

Parameters
context
The organization service context.
incidentId
The ID of the incident (case). Required.
Return Value
Returns an Int64, the total time, in minutes that you use when you work on an incident (case).

  Remarks
This is a method wrapper for the CalculateTotalTimeIncidentRequest and CalculateTotalTimeIncidentResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CancelContract Method
[image]

Cancels a contract. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim contractId As Guid
Dim cancelDate As DateTime
Dim status As OptionSetValue

OrganizationServiceContextExtensions.CancelContract(context, contractId, cancelDate, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub CancelContract ( _
    context As OrganizationServiceContext, _
    contractId As Guid, _
    cancelDate As DateTime, _
    status As OptionSetValue _
)
C#
[ExtensionAttribute]
public static void CancelContract (
    OrganizationServiceContext context,
    Guid contractId,
    DateTime cancelDate,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
contractId
The ID of the contract. Required.
cancelDate
The contract cancelation date. Required.
status
The status of the contract. Required.
  Remarks
This is a method wrapper for the CancelContractRequest and CancelContractResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CancelSalesOrder Method
[image]

Cancels a sales order. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim orderClose As Entity
Dim status As OptionSetValue

OrganizationServiceContextExtensions.CancelSalesOrder(context, orderClose, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub CancelSalesOrder ( _
    context As OrganizationServiceContext, _
    orderClose As Entity, _
    status As OptionSetValue _
)
C#
[ExtensionAttribute]
public static void CancelSalesOrder (
    OrganizationServiceContext context,
    Entity orderClose,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
orderClose
The close activity that is associated with the sales order (order) that you want to cancel. Required.
status
The status of the sales order (order). Required.
  Remarks
This is a method wrapper for the CancelSalesOrderRequest and CancelSalesOrderResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CheckIncomingEmail Method
[image]

Checks whether the incoming email message is relevant to the Microsoft Dynamics CRM system. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim messageId As String
Dim subject As String
Dim from As String
Dim to As String
Dim cc As String
Dim bcc As String
Dim returnValue As TResponse

returnValue = OrganizationServiceContextExtensions.CheckIncomingEmail(context, messageId, subject, from, to, cc, bcc)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CheckIncomingEmail(Of TResponse As OrganizationResponse) ( _
    context As OrganizationServiceContext, _
    messageId As String, _
    subject As String, _
    from As String, _
    to As String, _
    cc As String, _
    bcc As String _
) As TResponse
C#
[ExtensionAttribute]
public static TResponse CheckIncomingEmail<TResponse> (
    OrganizationServiceContext context,
    string messageId,
    string subject,
    string from,
    string to,
    string cc,
    string bcc
) where TResponse : OrganizationResponse
C++

J#

JScript

GenericParameters
TResponse
Parameters
context
The organization service context.
messageId
The ID of the email message stored in the email header. Required.
subject
The subject line for the email message. Optional.
from
The from address for the email message.
to
The addresses of the recipients of the email message.
cc
The addresses of the carbon copy (Cc) recipients for the email message.
bcc
The addresses of the blind carbon copy (Bcc) recipients for the email message.
Return Value
Returns an Int64
  Remarks
This is a method wrapper for the CheckIncomingEmailRequest and CheckIncomingEmailResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CheckPromoteEmail Method
[image]

Checks whether the incoming email message should be promoted to the Microsoft Dynamics CRM system. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim messageId As String
Dim subject As String
Dim returnValue As TResponse

returnValue = OrganizationServiceContextExtensions.CheckPromoteEmail(context, messageId, subject)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CheckPromoteEmail(Of TResponse As OrganizationResponse) ( _
    context As OrganizationServiceContext, _
    messageId As String, _
    subject As String _
) As TResponse
C#
[ExtensionAttribute]
public static TResponse CheckPromoteEmail<TResponse> (
    OrganizationServiceContext context,
    string messageId,
    string subject
) where TResponse : OrganizationResponse
C++

J#

JScript

GenericParameters
TResponse
Parameters
context
The organization service context.
messageId
The message ID that is contained in the email header. Required.
subject
The subject of the message. Optional.
Return Value
Returns Int64.

  Remarks
This is a method wrapper for the CheckPromoteEmailRequest and CheckPromoteEmailResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CleanUpBulkOperation Method
[image]

For internal use only. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim bulkOperationId As Guid
Dim bulkOperationSource As Integer

OrganizationServiceContextExtensions.CleanUpBulkOperation(context, bulkOperationId, bulkOperationSource)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub CleanUpBulkOperation ( _
    context As OrganizationServiceContext, _
    bulkOperationId As Guid, _
    bulkOperationSource As Integer _
)
C#
[ExtensionAttribute]
public static void CleanUpBulkOperation (
    OrganizationServiceContext context,
    Guid bulkOperationId,
    int bulkOperationSource
)
C++

J#

JScript

Parameters
context
The organization service context.
bulkOperationId
bulkOperationSource
  Remarks
This is a method wrapper for the CleanUpBulkOperationRequest and CleanUpBulkOperationResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CloneContract Method
[image]

Copies an existing contract and its line items. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim contractId As Guid
Dim includeCanceledLines As Boolean
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.CloneContract(context, contractId, includeCanceledLines)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CloneContract ( _
    context As OrganizationServiceContext, _
    contractId As Guid, _
    includeCanceledLines As Boolean _
) As Entity
C#
[ExtensionAttribute]
public static Entity CloneContract (
    OrganizationServiceContext context,
    Guid contractId,
    bool includeCanceledLines
)
C++

J#

JScript

Parameters
context
The organization service context.
contractId
The ID of the contract to be copied. Required.
includeCanceledLines
A value that indicates whether the canceled line items of the originating contract are to be included in the copy (clone). Required.
Return Value
Returns an Entity, the resulting contract.

  Remarks
This is a method wrapper for the CloneContractRequest and CloneContractResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CloseIncident Method
[image]

Closes an incident (case). (Developer Extensions)Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
OrganizationServiceContextExtensions.CloseIncident (OrganizationServiceContext, Entity, OptionSetValue) | Closes an incident (case). (Developer Extensions)
OrganizationServiceContextExtensions.CloseIncident (OrganizationServiceContext, Entity, Int32) | Closes an incident (case). (Developer Extensions)

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CloseIncident Method (OrganizationServiceContext, Entity, OptionSetValue)
[image]

Closes an incident (case). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim incidentResolution As Entity
Dim status As OptionSetValue

OrganizationServiceContextExtensions.CloseIncident(context, incidentResolution, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub CloseIncident ( _
    context As OrganizationServiceContext, _
    incidentResolution As Entity, _
    status As OptionSetValue _
)
C#
[ExtensionAttribute]
public static void CloseIncident (
    OrganizationServiceContext context,
    Entity incidentResolution,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
incidentResolution
The incident resolution (case resolution) that is associated with the incident (case) to be closed. Required.
status
A status of the incident. Required.
  Remarks
This is a method wrapper for the CloseIncidentRequest and CloseIncidentResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CloseIncident Method (OrganizationServiceContext, Entity, Int32)
[image]

Closes an incident (case). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim incidentResolution As Entity
Dim status As Integer

OrganizationServiceContextExtensions.CloseIncident(context, incidentResolution, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub CloseIncident ( _
    context As OrganizationServiceContext, _
    incidentResolution As Entity, _
    status As Integer _
)
C#
[ExtensionAttribute]
public static void CloseIncident (
    OrganizationServiceContext context,
    Entity incidentResolution,
    int status
)
C++

J#

JScript

Parameters
context
The organization service context.
incidentResolution
The incident resolution (case resolution) that is associated with the incident (case) to be closed. Required.
status
A status of the incident. Required.
  Remarks
This is a method wrapper for the CloseIncidentRequest and CloseIncidentResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace


OrganizationServiceContextExtensions.CloseQuote Method
[image]

Closes a quote. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim quoteClose As Entity
Dim status As OptionSetValue

OrganizationServiceContextExtensions.CloseQuote(context, quoteClose, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub CloseQuote ( _
    context As OrganizationServiceContext, _
    quoteClose As Entity, _
    status As OptionSetValue _
)
C#
[ExtensionAttribute]
public static void CloseQuote (
    OrganizationServiceContext context,
    Entity quoteClose,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
quoteClose
A quote to be closed. Required.
status
A status of the quote. Required.
  Remarks
This is a method wrapper for the CloseQuoteRequest and CloseQuoteResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CompoundCreate Method
[image]

Deprecated. Creates a compound entity (salesorder, invoice, quote, or duplicaterule) and its related entity (salesorderdetail, invoicedetail, quotedetail, or duplicaterulecondition). Use Create. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim childEntities As EntityCollection
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.CompoundCreate(context, entity, childEntities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CompoundCreate ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    childEntities As EntityCollection _
) As Guid
C#
[ExtensionAttribute]
public static Guid CompoundCreate (
    OrganizationServiceContext context,
    Entity entity,
    EntityCollection childEntities
)
C++

J#

JScript

Parameters
context
The organization service context.
entity
childEntities
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the CompoundCreateRequest and CompoundCreateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CompoundUpdate Method
[image]

Deprecated. Updates a compound record (salesorder, invoice, quote or duplicaterule) and its related detail record (salesorderdetail, invoicedetail, quotedetail or duplicaterulecondition). Use Update. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim childEntities As EntityCollection

OrganizationServiceContextExtensions.CompoundUpdate(context, entity, childEntities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub CompoundUpdate ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    childEntities As EntityCollection _
)
C#
[ExtensionAttribute]
public static void CompoundUpdate (
    OrganizationServiceContext context,
    Entity entity,
    EntityCollection childEntities
)
C++

J#

JScript

Parameters
context
The organization service context.
entity
childEntities
  Remarks
This is a method wrapper for the CompoundUpdateRequest and CompoundUpdateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CompoundUpdateDuplicateDetectionRule Method
[image]

Updates a duplicate rule (duplicate detection rule) and its related duplicate rule conditions. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim childEntities As EntityCollection

OrganizationServiceContextExtensions.CompoundUpdateDuplicateDetectionRule(context, entity, childEntities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub CompoundUpdateDuplicateDetectionRule ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    childEntities As EntityCollection _
)
C#
[ExtensionAttribute]
public static void CompoundUpdateDuplicateDetectionRule (
    OrganizationServiceContext context,
    Entity entity,
    EntityCollection childEntities
)
C++

J#

JScript

Parameters
context
The organization service context.
entity
The duplicate rule that you want updated. Required.
childEntities
A collection of the duplicate rule conditions that you want updated. Required.
  Remarks
This is a method wrapper for the CompoundUpdateDuplicateDetectionRuleRequest and CompoundUpdateDuplicateDetectionRuleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ConvertKitToProduct Method
[image]

Converts a kit to a product. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim kitId As Guid

OrganizationServiceContextExtensions.ConvertKitToProduct(context, kitId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ConvertKitToProduct ( _
    context As OrganizationServiceContext, _
    kitId As Guid _
)
C#
[ExtensionAttribute]
public static void ConvertKitToProduct (
    OrganizationServiceContext context,
    Guid kitId
)
C++

J#

JScript

Parameters
context
The organization service context.
kitId
The the ID of the kit. Required.
  Remarks
This is a method wrapper for the ConvertKitToProductRequest and ConvertKitToProductResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ConvertProductToKit Method
[image]

Converts a product to a kit. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim productId As Guid

OrganizationServiceContextExtensions.ConvertProductToKit(context, productId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ConvertProductToKit ( _
    context As OrganizationServiceContext, _
    productId As Guid _
)
C#
[ExtensionAttribute]
public static void ConvertProductToKit (
    OrganizationServiceContext context,
    Guid productId
)
C++

J#

JScript

Parameters
context
The organization service context.
productId
The the ID of the product. Required.
  Remarks
This is a method wrapper for the ConvertProductToKitRequest and ConvertProductToKitResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ConvertQuoteToSalesOrder Method
[image]

Converts a quote to a sales order. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim quoteId As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.ConvertQuoteToSalesOrder(context, quoteId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ConvertQuoteToSalesOrder ( _
    context As OrganizationServiceContext, _
    quoteId As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
[ExtensionAttribute]
public static Entity ConvertQuoteToSalesOrder (
    OrganizationServiceContext context,
    Guid quoteId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
quoteId
The ID of the quote to convert. Required.
columnSet
The the collection of attributes to retrieve in the resulting sales order (order). Required.
Return Value
Returns a Entity, the resulting sales order (order). Required.

  Remarks
This is a method wrapper for the ConvertQuoteToSalesOrderRequest and ConvertQuoteToSalesOrderResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ConvertSalesOrderToInvoice Method
[image]

Converts a sales order to an invoice. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim salesOrderId As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.ConvertSalesOrderToInvoice(context, salesOrderId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ConvertSalesOrderToInvoice ( _
    context As OrganizationServiceContext, _
    salesOrderId As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
[ExtensionAttribute]
public static Entity ConvertSalesOrderToInvoice (
    OrganizationServiceContext context,
    Guid salesOrderId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
salesOrderId
The ID of the sales order (order) to convert. Required.
columnSet
The collection of attributes to retrieve from the resulting invoice. Required.
Return Value
Returns an Entity, the resulting invoice.

  Remarks
This is a method wrapper for the ConvertSalesOrderToInvoiceRequest and ConvertSalesOrderToInvoiceResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CopyCampaign Method
[image]

Copies a campaign. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim baseCampaign As Guid
Dim saveAsTemplate As Boolean
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.CopyCampaign(context, baseCampaign, saveAsTemplate)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CopyCampaign ( _
    context As OrganizationServiceContext, _
    baseCampaign As Guid, _
    saveAsTemplate As Boolean _
) As Guid
C#
[ExtensionAttribute]
public static Guid CopyCampaign (
    OrganizationServiceContext context,
    Guid baseCampaign,
    bool saveAsTemplate
)
C++

J#

JScript

Parameters
context
The organization service context.
baseCampaign
The ID of the base campaign to copy from. Required.
saveAsTemplate
A value that indicates whether to save the campaign as a template. Required.
Return Value
Returns a Guid, the ID of the newly created campaign.

  Remarks
This is a method wrapper for the CopyCampaignRequest and CopyCampaignResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CopyCampaignResponse Method
[image]

Copies the information from one campaign response to another, and optionally creates a campaign response template. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim campaignResponseId As EntityReference
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.CopyCampaignResponse(context, campaignResponseId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CopyCampaignResponse ( _
    context As OrganizationServiceContext, _
    campaignResponseId As EntityReference _
) As Guid
C#
[ExtensionAttribute]
public static Guid CopyCampaignResponse (
    OrganizationServiceContext context,
    EntityReference campaignResponseId
)
C++

J#

JScript

Parameters
context
The organization service context.
campaignResponseId
The campaign response to copy from. Required.
Return Value
Returns a Guid, ID of the newly created campaign response.

  Remarks
This is a method wrapper for the CopyCampaignResponseRequest and CopyCampaignResponseResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CopyDynamicListToStatic Method
[image]

Creates a static list from the specified dynamic list and adds the members that satisfy the dynamic list query criteria to the static list. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim listId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.CopyDynamicListToStatic(context, listId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CopyDynamicListToStatic ( _
    context As OrganizationServiceContext, _
    listId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid CopyDynamicListToStatic (
    OrganizationServiceContext context,
    Guid listId
)
C++

J#

JScript

Parameters
context
The organization service context.
listId
The ID of the dynamic list. Required.
Return Value
Returns a Guid, the created static list.

  Remarks
This is a method wrapper for the CopyDynamicListToStaticRequest and CopyDynamicListToStaticResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CopyMembersList Method
[image]

Copies the members from the source list to the target list without creating duplicates. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim sourceListId As Guid
Dim targetListId As Guid

OrganizationServiceContextExtensions.CopyMembersList(context, sourceListId, targetListId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub CopyMembersList ( _
    context As OrganizationServiceContext, _
    sourceListId As Guid, _
    targetListId As Guid _
)
C#
[ExtensionAttribute]
public static void CopyMembersList (
    OrganizationServiceContext context,
    Guid sourceListId,
    Guid targetListId
)
C++

J#

JScript

Parameters
context
The organization service context.
sourceListId
The ID of the source list. Required.
targetListId
The ID of the target list. Required.
  Remarks
This is a method wrapper for the CopyMembersListRequest and CopyMembersListResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CopySystemForm Method
[image]

Creates a new entity form that is based on an existing entity form. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As Entity
Dim sourceId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.CopySystemForm(context, target, sourceId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CopySystemForm ( _
    context As OrganizationServiceContext, _
    target As Entity, _
    sourceId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid CopySystemForm (
    OrganizationServiceContext context,
    Entity target,
    Guid sourceId
)
C++

J#

JScript

Parameters
context
The organization service context.
target
The ID of the target list. Required.
sourceId
The ID value of the form to copy.
Return Value
Returns a Guid, the ID value of the system form that the original was copied to..

  Remarks
This is a method wrapper for the CopySystemFormRequest and CopySystemFormResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CreateActivitiesList Method
[image]

Creates the activities for a list. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim listId As Guid
Dim friendlyName As String
Dim activity As Entity
Dim templateId As Guid
Dim propagate As Boolean
Dim ownershipOptions As Object
Dim owner As EntityReference
Dim sendEmail As Boolean
Dim postWorkflowEvent As Boolean
Dim queueId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.CreateActivitiesList(context, listId, friendlyName, activity, templateId, propagate, ownershipOptions, owner, sendEmail, postWorkflowEvent, queueId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CreateActivitiesList ( _
    context As OrganizationServiceContext, _
    listId As Guid, _
    friendlyName As String, _
    activity As Entity, _
    templateId As Guid, _
    propagate As Boolean, _
    ownershipOptions As Object, _
    owner As EntityReference, _
    sendEmail As Boolean, _
    postWorkflowEvent As Boolean, _
    queueId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid CreateActivitiesList (
    OrganizationServiceContext context,
    Guid listId,
    string friendlyName,
    Entity activity,
    Guid templateId,
    bool propagate,
    Object ownershipOptions,
    EntityReference owner,
    bool sendEmail,
    bool postWorkflowEvent,
    Guid queueId
)
C++

J#

JScript

Parameters
context
The organization service context.
listId
The ID of the list. Required.
friendlyName
A user-identifiable name for the campaign. Required.
activity
The activity to be distributed. Required.
templateId
The ID of the email template. Required.
propagate
A value that indicates whether the activity is created and executed. Required.
ownershipOptions
The propagation ownership options. Required.
owner
The owner for the activity. Required.
sendEmail
A value that indicates whether to send an email about the new activity. Required.
postWorkflowEvent
A value that indicates whether an asynchronous job is used to create the activities. Required.
queueId
The ID of the queue to which the created activities are added. Required.
Return Value
Returns a Guid, the ID of the bulk operation created to distribute the campaign activity.

  Remarks
This is a method wrapper for the CreateActivitiesListRequest and CreateActivitiesListResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CreateException Method
[image]

Creates an exception for the recurring appointment instance. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As Entity
Dim originalStartDate As DateTime
Dim isDeleted As Boolean
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.CreateException(context, target, originalStartDate, isDeleted)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CreateException ( _
    context As OrganizationServiceContext, _
    target As Entity, _
    originalStartDate As DateTime, _
    isDeleted As Boolean _
) As Guid
C#
[ExtensionAttribute]
public static Guid CreateException (
    OrganizationServiceContext context,
    Entity target,
    DateTime originalStartDate,
    bool isDeleted
)
C++

J#

JScript

Parameters
context
The organization service context.
target
originalStartDate
The original start date of the recurring appointment.
isDeleted
A value that indicates whether the appointment instance is deleted.
Return Value
Returns a Guid, the ID of the exception appointment.

  Remarks
This is a method wrapper for the CreateExceptionRequest and CreateExceptionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CreateInstance Method
[image]

Creates future unexpanded instances of a recurring appointment master. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As Entity
Dim count As Integer
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.CreateInstance(context, target, count)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CreateInstance ( _
    context As OrganizationServiceContext, _
    target As Entity, _
    count As Integer _
) As Boolean
C#
[ExtensionAttribute]
public static bool CreateInstance (
    OrganizationServiceContext context,
    Entity target,
    int count
)
C++

J#

JScript

Parameters
context
The organization service context.
target
The target appointment instance to create. Required.
count
The number of instances to be created. Required.
Return Value
Returns a Boolean, that indicates whether the series can be expanded.

  Remarks
This is a method wrapper for the CreateInstanceRequest and CreateInstanceResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.CreateWorkflowFromTemplate Method
[image]

Creates a workflow from a workflow template. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim workflowName As String
Dim workflowTemplateId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.CreateWorkflowFromTemplate(context, workflowName, workflowTemplateId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function CreateWorkflowFromTemplate ( _
    context As OrganizationServiceContext, _
    workflowName As String, _
    workflowTemplateId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid CreateWorkflowFromTemplate (
    OrganizationServiceContext context,
    string workflowName,
    Guid workflowTemplateId
)
C++

J#

JScript

Parameters
context
The organization service context.
workflowName
The name for the new workflow. Required.
workflowTemplateId
The ID of the workflow template. Required.
Return Value
Returns a Guid, the ID of the new workflow.

  Remarks
This is a method wrapper for the CreateWorkflowFromTemplateRequest and CreateWorkflowFromTemplateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.DeleteAuditData Method
[image]

Deletes all partitions containing audit data created before a given end date. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim endDate As DateTime
Dim returnValue As Integer

returnValue = OrganizationServiceContextExtensions.DeleteAuditData(context, endDate)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function DeleteAuditData ( _
    context As OrganizationServiceContext, _
    endDate As DateTime _
) As Integer
C#
[ExtensionAttribute]
public static int DeleteAuditData (
    OrganizationServiceContext context,
    DateTime endDate
)
C++

J#

JScript

Parameters
context
The organization service context.
endDate
The end date and time.
Return Value
Returns an  Int32, the number of deleted audit partitions or the number of deleted Audit records.

  Remarks
This is a method wrapper for the DeleteAuditDataRequest and DeleteAuditDataResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.DeleteOpenInstances Method
[image]

Deletes instances of a recurring appointment master that have an Open state. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As Entity
Dim seriesEndDate As DateTime
Dim stateOfPastInstances As Integer

OrganizationServiceContextExtensions.DeleteOpenInstances(context, target, seriesEndDate, stateOfPastInstances)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub DeleteOpenInstances ( _
    context As OrganizationServiceContext, _
    target As Entity, _
    seriesEndDate As DateTime, _
    stateOfPastInstances As Integer _
)
C#
[ExtensionAttribute]
public static void DeleteOpenInstances (
    OrganizationServiceContext context,
    Entity target,
    DateTime seriesEndDate,
    int stateOfPastInstances
)
C++

J#

JScript

Parameters
context
The organization service context.
target
The target record for the operation. Required.
seriesEndDate
The end date for the recurring appointment series. Required.
stateOfPastInstances
The value to be used to set the status of appointment instances that have already passed. Required.
  Remarks
This is a method wrapper for the DeleteOpenInstancesRequest and DeleteOpenInstancesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.DeliverIncomingEmail Method
[image]

Creates an email activity record from an incoming email message. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim messageId As String
Dim subject As String
Dim from As String
Dim to As String
Dim cc As String
Dim bcc As String
Dim receivedOn As DateTime
Dim submittedBy As String
Dim importance As String
Dim body As String
Dim attachments As EntityCollection
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.DeliverIncomingEmail(context, messageId, subject, from, to, cc, bcc, receivedOn, submittedBy, importance, body, attachments)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function DeliverIncomingEmail ( _
    context As OrganizationServiceContext, _
    messageId As String, _
    subject As String, _
    from As String, _
    to As String, _
    cc As String, _
    bcc As String, _
    receivedOn As DateTime, _
    submittedBy As String, _
    importance As String, _
    body As String, _
    attachments As EntityCollection _
) As Guid
C#
[ExtensionAttribute]
public static Guid DeliverIncomingEmail (
    OrganizationServiceContext context,
    string messageId,
    string subject,
    string from,
    string to,
    string cc,
    string bcc,
    DateTime receivedOn,
    string submittedBy,
    string importance,
    string body,
    EntityCollection attachments
)
C++

J#

JScript

Parameters
context
The organization service context.
messageId
The ID of the email message stored in the email header. Required.
subject
The subject line for the email message. Optional.
from
The from address for the email message. Required.
to
The addresses of the recipients of the email message. Required.
cc
The addresses of the carbon copy (Cc) recipients for the email message. Required.
bcc
The addresses of the blind carbon copy (Bcc) recipients for the email message. Required.
receivedOn
The time the message was received on. Required.
submittedBy
The email address of the account that is creating the email activity instance. Required.
importance
The level of importance for the email message. Required.
body
The message body for the email. Required.
attachments
A collection of activity mime attachment (email attachment) instances to attach to the email message. Required.
Return Value
Returns a Guid, the ID of the email.

  Remarks
This is a method wrapper for the DeliverIncomingEmailRequest and DeliverIncomingEmailResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.DeliverPromoteEmail Method
[image]

Creates an email activity instance from the specified email message (Track in CRM). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim emailId As Guid
Dim messageId As String
Dim subject As String
Dim from As String
Dim to As String
Dim cc As String
Dim bcc As String
Dim receivedOn As DateTime
Dim submittedBy As String
Dim importance As String
Dim body As String
Dim attachments As EntityCollection
Dim extraProperties As Entity
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.DeliverPromoteEmail(context, emailId, messageId, subject, from, to, cc, bcc, receivedOn, submittedBy, importance, body, attachments, extraProperties)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function DeliverPromoteEmail ( _
    context As OrganizationServiceContext, _
    emailId As Guid, _
    messageId As String, _
    subject As String, _
    from As String, _
    to As String, _
    cc As String, _
    bcc As String, _
    receivedOn As DateTime, _
    submittedBy As String, _
    importance As String, _
    body As String, _
    attachments As EntityCollection, _
    extraProperties As Entity _
) As Guid
C#
[ExtensionAttribute]
public static Guid DeliverPromoteEmail (
    OrganizationServiceContext context,
    Guid emailId,
    string messageId,
    string subject,
    string from,
    string to,
    string cc,
    string bcc,
    DateTime receivedOn,
    string submittedBy,
    string importance,
    string body,
    EntityCollection attachments,
    Entity extraProperties
)
C++

J#

JScript

Parameters
context
The organization service context.
emailId
messageId
The ID of the email message stored in the email header. Required.
subject
The subject line for the email message. Optional.
from
The from address for the email message. Required.
to
The addresses of the recipients of the email message. Required.
cc
The addresses of the carbon copy (Cc) recipients for the email message. Required.
bcc
The addresses of the blind carbon copy (Bcc) recipients for the email message. Required.
receivedOn
The time the message was received on. Required.
submittedBy
The email address of the account that is creating the email activity instance. Required.
importance
The level of importance for the email message. Required.
body
The message body for the email. Required.
attachments
A collection of activity mime attachment (email attachment) instances to attach to the email message. Required.
extraProperties
Extra properties. Optional.
Return Value
Returns a Guid, the ID of the newly created email activity.

  Remarks
This is a method wrapper for the DeliverPromoteEmailRequest and DeliverPromoteEmailResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.DeprovisionLanguage Method
[image]

Deprovisions a language. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim language As Integer

OrganizationServiceContextExtensions.DeprovisionLanguage(context, language)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub DeprovisionLanguage ( _
    context As OrganizationServiceContext, _
    language As Integer _
)
C#
[ExtensionAttribute]
public static void DeprovisionLanguage (
    OrganizationServiceContext context,
    int language
)
C++

J#

JScript

Parameters
context
The organization service context.
language
The language to deprovision. Required.
  Remarks
This is a method wrapper for the DeprovisionLanguageRequest and DeprovisionLanguageResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.DisassociateEntities Method
[image]

Deprecated. Removes a link between two records in a many to many relationship. Use Disassociate. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim moniker1 As EntityReference
Dim moniker2 As EntityReference
Dim relationshipName As String

OrganizationServiceContextExtensions.DisassociateEntities(context, moniker1, moniker2, relationshipName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub DisassociateEntities ( _
    context As OrganizationServiceContext, _
    moniker1 As EntityReference, _
    moniker2 As EntityReference, _
    relationshipName As String _
)
C#
[ExtensionAttribute]
public static void DisassociateEntities (
    OrganizationServiceContext context,
    EntityReference moniker1,
    EntityReference moniker2,
    string relationshipName
)
C++

J#

JScript

Parameters
context
The organization service context.
moniker1
moniker2
relationshipName
  Remarks
This is a method wrapper for the DisassociateEntitiesRequest and DisassociateEntitiesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.DistributeCampaignActivity Method
[image]

Creates a bulk operation to distribute the activity, creating the appropriate activity for each member in the list for the specified campaign activity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim campaignActivityId As Guid
Dim propagate As Boolean
Dim activity As Entity
Dim templateId As Guid
Dim ownershipOptions As Object
Dim owner As EntityReference
Dim sendEmail As Boolean
Dim queueId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.DistributeCampaignActivity(context, campaignActivityId, propagate, activity, templateId, ownershipOptions, owner, sendEmail, queueId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function DistributeCampaignActivity ( _
    context As OrganizationServiceContext, _
    campaignActivityId As Guid, _
    propagate As Boolean, _
    activity As Entity, _
    templateId As Guid, _
    ownershipOptions As Object, _
    owner As EntityReference, _
    sendEmail As Boolean, _
    queueId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid DistributeCampaignActivity (
    OrganizationServiceContext context,
    Guid campaignActivityId,
    bool propagate,
    Entity activity,
    Guid templateId,
    Object ownershipOptions,
    EntityReference owner,
    bool sendEmail,
    Guid queueId
)
C++

J#

JScript

Parameters
context
The organization service context.
campaignActivityId
The ID of the campaign activity for which the activity is distributed. Required.
propagate
A value that indicates whether the activity is both created and executed. Required.
activity
The activity to be distributed. Required.
templateId
the ID of the email template. Required.
ownershipOptions
The ownership options for the activity. Required.
owner
The owner for the newly created activity. Required.
sendEmail
A value that indicates whether to send an email about the new activity. Required.
queueId
The ID of the queue to which the created activity is added. Optional.
Return Value
Returns a Guid, the ID of the bulk operation that is used to distribute the campaign activity.

  Remarks
This is a method wrapper for the DistributeCampaignActivityRequest and DistributeCampaignActivityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.DownloadReportDefinition Method
[image]

Downloads a report definition. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim reportId As Guid
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.DownloadReportDefinition(context, reportId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function DownloadReportDefinition ( _
    context As OrganizationServiceContext, _
    reportId As Guid _
) As String
C#
[ExtensionAttribute]
public static string DownloadReportDefinition (
    OrganizationServiceContext context,
    Guid reportId
)
C++

J#

JScript

Parameters
context
The organization service context.
reportId
Return Value
Returns String.

  Remarks
This is a method wrapper for the DownloadReportDefinitionRequest and DownloadReportDefinitionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ExecuteByIdSavedQuery Method
[image]

Executes a saved query (view) that has the specified ID. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As Guid
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.ExecuteByIdSavedQuery(context, entityId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ExecuteByIdSavedQuery ( _
    context As OrganizationServiceContext, _
    entityId As Guid _
) As String
C#
[ExtensionAttribute]
public static string ExecuteByIdSavedQuery (
    OrganizationServiceContext context,
    Guid entityId
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
Return Value
Returns String.

  Remarks
This is a method wrapper for the ExecuteByIdSavedQueryRequest and ExecuteByIdSavedQueryResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ExecuteByIdUserQuery Method
[image]

Executes the user query (saved view) that has the specified ID. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As EntityReference
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.ExecuteByIdUserQuery(context, entityId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ExecuteByIdUserQuery ( _
    context As OrganizationServiceContext, _
    entityId As EntityReference _
) As String
C#
[ExtensionAttribute]
public static string ExecuteByIdUserQuery (
    OrganizationServiceContext context,
    EntityReference entityId
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
Return Value
Returns String.

  Remarks
This is a method wrapper for the ExecuteByIdUserQueryRequest and ExecuteByIdUserQueryResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ExecuteFetch Method
[image]

Deprecated. Executes the specified Fetch XML query. Use RetrieveMultiple. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim fetchXml As String
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.ExecuteFetch(context, fetchXml)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ExecuteFetch ( _
    context As OrganizationServiceContext, _
    fetchXml As String _
) As String
C#
[ExtensionAttribute]
public static string ExecuteFetch (
    OrganizationServiceContext context,
    string fetchXml
)
C++

J#

JScript

Parameters
context
The organization service context.
fetchXml
Return Value
Returns String.

  Remarks
This is a method wrapper for the ExecuteFetchRequest and ExecuteFetchResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ExecuteWorkflow Method
[image]

Executes a workflow. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As Guid
Dim workflowId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.ExecuteWorkflow(context, entityId, workflowId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ExecuteWorkflow ( _
    context As OrganizationServiceContext, _
    entityId As Guid, _
    workflowId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid ExecuteWorkflow (
    OrganizationServiceContext context,
    Guid entityId,
    Guid workflowId
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
workflowId
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the ExecuteWorkflowRequest and ExecuteWorkflowResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ExpandCalendar Method
[image]

Converts the calendar rules to an array of available time blocks for the specified period. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim calendarId As Guid
Dim start As DateTime
Dim end As DateTime
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.ExpandCalendar(context, calendarId, start, end)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ExpandCalendar(Of TResult) ( _
    context As OrganizationServiceContext, _
    calendarId As Guid, _
    start As DateTime, _
    end As DateTime _
) As TResult
C#
[ExtensionAttribute]
public static TResult ExpandCalendar<TResult> (
    OrganizationServiceContext context,
    Guid calendarId,
    DateTime start,
    DateTime end
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
calendarId
start
end
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the ExpandCalendarRequest and ExpandCalendarResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ExportSolution Method
[image]

Exports a managed or unmanaged solution. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim solutionName As String
Dim managed As Boolean
Dim exportAutoNumberingSettings As Boolean
Dim exportCalendarSettings As Boolean
Dim exportCustomizationSettings As Boolean
Dim exportEmailTrackingSettings As Boolean
Dim exportGeneralSettings As Boolean
Dim exportMarketingSettings As Boolean
Dim exportOutlookSynchronizationSettings As Boolean
Dim exportRelationshipRoles As Boolean
Dim exportIsvConfig As Boolean
Dim returnValue As Byte()

returnValue = OrganizationServiceContextExtensions.ExportSolution(context, solutionName, managed, exportAutoNumberingSettings, exportCalendarSettings, exportCustomizationSettings, exportEmailTrackingSettings, exportGeneralSettings, exportMarketingSettings, exportOutlookSynchronizationSettings, exportRelationshipRoles, exportIsvConfig)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ExportSolution ( _
    context As OrganizationServiceContext, _
    solutionName As String, _
    managed As Boolean, _
    exportAutoNumberingSettings As Boolean, _
    exportCalendarSettings As Boolean, _
    exportCustomizationSettings As Boolean, _
    exportEmailTrackingSettings As Boolean, _
    exportGeneralSettings As Boolean, _
    exportMarketingSettings As Boolean, _
    exportOutlookSynchronizationSettings As Boolean, _
    exportRelationshipRoles As Boolean, _
    exportIsvConfig As Boolean _
) As Byte()
C#
[ExtensionAttribute]
public static byte[] ExportSolution (
    OrganizationServiceContext context,
    string solutionName,
    bool managed,
    bool exportAutoNumberingSettings,
    bool exportCalendarSettings,
    bool exportCustomizationSettings,
    bool exportEmailTrackingSettings,
    bool exportGeneralSettings,
    bool exportMarketingSettings,
    bool exportOutlookSynchronizationSettings,
    bool exportRelationshipRoles,
    bool exportIsvConfig
)
C++

J#

JScript

Parameters
context
The organization service context.
solutionName
managed
exportAutoNumberingSettings
exportCalendarSettings
exportCustomizationSettings
exportEmailTrackingSettings
exportGeneralSettings
exportMarketingSettings
exportOutlookSynchronizationSettings
exportRelationshipRoles
exportIsvConfig
Return Value
Returns Byte.

  Remarks
This is a method wrapper for the ExportSolutionRequest and ExportSolutionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ExportTranslation Method
[image]

Exports all translations for a specific solution to a compressed file. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim solutionName As String
Dim returnValue As Byte()

returnValue = OrganizationServiceContextExtensions.ExportTranslation(context, solutionName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ExportTranslation ( _
    context As OrganizationServiceContext, _
    solutionName As String _
) As Byte()
C#
[ExtensionAttribute]
public static byte[] ExportTranslation (
    OrganizationServiceContext context,
    string solutionName
)
C++

J#

JScript

Parameters
context
The organization service context.
solutionName
Return Value
Returns Byte.

  Remarks
This is a method wrapper for the ExportTranslationRequest and ExportTranslationResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.FetchXmlToQueryExpression Method
[image]

Converts a query in Fetch XML to a QueryExpression. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim fetchXml As String
Dim returnValue As QueryExpression

returnValue = OrganizationServiceContextExtensions.FetchXmlToQueryExpression(context, fetchXml)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function FetchXmlToQueryExpression ( _
    context As OrganizationServiceContext, _
    fetchXml As String _
) As QueryExpression
C#
[ExtensionAttribute]
public static QueryExpression FetchXmlToQueryExpression (
    OrganizationServiceContext context,
    string fetchXml
)
C++

J#

JScript

Parameters
context
The organization service context.
fetchXml
Return Value
Returns QueryExpression.

  Remarks
This is a method wrapper for the FetchXmlToQueryExpressionRequest and FetchXmlToQueryExpressionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.FindParentResourceGroup Method
[image]

Finds a parent resource group (scheduling group) for the specified resource groups (scheduling groups). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim parentId As Guid
Dim childrenIds As Guid()
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.FindParentResourceGroup(context, parentId, childrenIds)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function FindParentResourceGroup ( _
    context As OrganizationServiceContext, _
    parentId As Guid, _
    childrenIds As Guid() _
) As Boolean
C#
[ExtensionAttribute]
public static bool FindParentResourceGroup (
    OrganizationServiceContext context,
    Guid parentId,
    Guid[] childrenIds
)
C++

J#

JScript

Parameters
context
The organization service context.
parentId
childrenIds
Return Value
Returns Boolean.

  Remarks
This is a method wrapper for the FindParentResourceGroupRequest and FindParentResourceGroupResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.FulfillSalesOrder Method
[image]

Fulfills a sales order (order). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim orderClose As Entity
Dim status As OptionSetValue

OrganizationServiceContextExtensions.FulfillSalesOrder(context, orderClose, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub FulfillSalesOrder ( _
    context As OrganizationServiceContext, _
    orderClose As Entity, _
    status As OptionSetValue _
)
C#
[ExtensionAttribute]
public static void FulfillSalesOrder (
    OrganizationServiceContext context,
    Entity orderClose,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
orderClose
status
  Remarks
This is a method wrapper for the FulfillSalesOrderRequest and FulfillSalesOrderResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GenerateInvoiceFromOpportunity Method
[image]

Generates an invoice from an opportunity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityId As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.GenerateInvoiceFromOpportunity(context, opportunityId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GenerateInvoiceFromOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityId As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
[ExtensionAttribute]
public static Entity GenerateInvoiceFromOpportunity (
    OrganizationServiceContext context,
    Guid opportunityId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityId
columnSet
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the GenerateInvoiceFromOpportunityRequest and GenerateInvoiceFromOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GenerateQuoteFromOpportunity Method
[image]

Generates a quote from an opportunity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityId As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.GenerateQuoteFromOpportunity(context, opportunityId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GenerateQuoteFromOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityId As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
[ExtensionAttribute]
public static Entity GenerateQuoteFromOpportunity (
    OrganizationServiceContext context,
    Guid opportunityId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityId
columnSet
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the GenerateQuoteFromOpportunityRequest and GenerateQuoteFromOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GenerateSalesOrderFromOpportunity Method
[image]

Generates a sales order from an opportunity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityId As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.GenerateSalesOrderFromOpportunity(context, opportunityId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GenerateSalesOrderFromOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityId As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
[ExtensionAttribute]
public static Entity GenerateSalesOrderFromOpportunity (
    OrganizationServiceContext context,
    Guid opportunityId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityId
columnSet
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the GenerateSalesOrderFromOpportunityRequest and GenerateSalesOrderFromOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetAllTimeZonesWithDisplayName Method
[image]

Retrieves all the time-zone definitions for the specified locale returning only the display name attribute. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim localeId As Integer
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.GetAllTimeZonesWithDisplayName(context, localeId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetAllTimeZonesWithDisplayName ( _
    context As OrganizationServiceContext, _
    localeId As Integer _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection GetAllTimeZonesWithDisplayName (
    OrganizationServiceContext context,
    int localeId
)
C++

J#

JScript

Parameters
context
The organization service context.
localeId
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the GetAllTimeZonesWithDisplayNameRequest and GetAllTimeZonesWithDisplayNameResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetDecryptionKey Method
[image]

Gets a decryption key. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.GetDecryptionKey(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetDecryptionKey ( _
    context As OrganizationServiceContext _
) As String
C#
[ExtensionAttribute]
public static string GetDecryptionKey (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns String.

  Remarks
This is a method wrapper for the GetDecryptionKeyRequest and GetDecryptionKeyResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetDistinctValuesImportFile Method
[image]

Returns distinct values for a column in the source file that contains list values. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim importFileId As Guid
Dim columnNumber As Integer
Dim pageNumber As Integer
Dim recordsPerPage As Integer
Dim returnValue As String()

returnValue = OrganizationServiceContextExtensions.GetDistinctValuesImportFile(context, importFileId, columnNumber, pageNumber, recordsPerPage)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetDistinctValuesImportFile ( _
    context As OrganizationServiceContext, _
    importFileId As Guid, _
    columnNumber As Integer, _
    pageNumber As Integer, _
    recordsPerPage As Integer _
) As String()
C#
[ExtensionAttribute]
public static string[] GetDistinctValuesImportFile (
    OrganizationServiceContext context,
    Guid importFileId,
    int columnNumber,
    int pageNumber,
    int recordsPerPage
)
C++

J#

JScript

Parameters
context
The organization service context.
importFileId
columnNumber
pageNumber
recordsPerPage
Return Value
Returns String.

  Remarks
This is a method wrapper for the GetDistinctValuesImportFileRequest and GetDistinctValuesImportFileResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetHeaderColumnsImportFile Method
[image]

Retrieves the source-file column headings, or system-generated column headings, if the source file does not contain column headings. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim importFileId As Guid
Dim returnValue As String()

returnValue = OrganizationServiceContextExtensions.GetHeaderColumnsImportFile(context, importFileId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetHeaderColumnsImportFile ( _
    context As OrganizationServiceContext, _
    importFileId As Guid _
) As String()
C#
[ExtensionAttribute]
public static string[] GetHeaderColumnsImportFile (
    OrganizationServiceContext context,
    Guid importFileId
)
C++

J#

JScript

Parameters
context
The organization service context.
importFileId
Return Value
Returns String.

  Remarks
This is a method wrapper for the GetHeaderColumnsImportFileRequest and GetHeaderColumnsImportFileResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetInvoiceProductsFromOpportunity Method
[image]

Retrieves the products from an opportunity and copies them to the specified invoice. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityId As Guid
Dim invoiceId As Guid

OrganizationServiceContextExtensions.GetInvoiceProductsFromOpportunity(context, opportunityId, invoiceId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub GetInvoiceProductsFromOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityId As Guid, _
    invoiceId As Guid _
)
C#
[ExtensionAttribute]
public static void GetInvoiceProductsFromOpportunity (
    OrganizationServiceContext context,
    Guid opportunityId,
    Guid invoiceId
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityId
invoiceId
  Remarks
This is a method wrapper for the GetInvoiceProductsFromOpportunityRequest and GetInvoiceProductsFromOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetQuantityDecimal Method
[image]

Gets the quantity decimal value for a product. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim productId As Guid
Dim uoMId As Guid
Dim returnValue As Integer

returnValue = OrganizationServiceContextExtensions.GetQuantityDecimal(context, target, productId, uoMId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetQuantityDecimal ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    productId As Guid, _
    uoMId As Guid _
) As Integer
C#
[ExtensionAttribute]
public static int GetQuantityDecimal (
    OrganizationServiceContext context,
    EntityReference target,
    Guid productId,
    Guid uoMId
)
C++

J#

JScript

Parameters
context
The organization service context.
target
productId
uoMId
Return Value
Returns Int32.

  Remarks
This is a method wrapper for the GetQuantityDecimalRequest and GetQuantityDecimalResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetQuoteProductsFromOpportunity Method
[image]

Retrieves the products from an opportunity and copies them to the quote. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityId As Guid
Dim quoteId As Guid

OrganizationServiceContextExtensions.GetQuoteProductsFromOpportunity(context, opportunityId, quoteId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub GetQuoteProductsFromOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityId As Guid, _
    quoteId As Guid _
)
C#
[ExtensionAttribute]
public static void GetQuoteProductsFromOpportunity (
    OrganizationServiceContext context,
    Guid opportunityId,
    Guid quoteId
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityId
quoteId
  Remarks
This is a method wrapper for the GetQuoteProductsFromOpportunityRequest and GetQuoteProductsFromOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetReportHistoryLimit Method
[image]

Gets the history limit for a report. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim reportId As Guid
Dim returnValue As Integer

returnValue = OrganizationServiceContextExtensions.GetReportHistoryLimit(context, reportId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetReportHistoryLimit ( _
    context As OrganizationServiceContext, _
    reportId As Guid _
) As Integer
C#
[ExtensionAttribute]
public static int GetReportHistoryLimit (
    OrganizationServiceContext context,
    Guid reportId
)
C++

J#

JScript

Parameters
context
The organization service context.
reportId
Return Value
Returns Int32.

  Remarks
This is a method wrapper for the
GetReportHistoryLimitRequest and GetReportHistoryLimitResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetSalesOrderProductsFromOpportunity Method
[image]

Retrieves the products from an opportunity and copies them to the sales order. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityId As Guid
Dim salesOrderId As Guid

OrganizationServiceContextExtensions.GetSalesOrderProductsFromOpportunity(context, opportunityId, salesOrderId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub GetSalesOrderProductsFromOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityId As Guid, _
    salesOrderId As Guid _
)
C#
[ExtensionAttribute]
public static void GetSalesOrderProductsFromOpportunity (
    OrganizationServiceContext context,
    Guid opportunityId,
    Guid salesOrderId
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityId
salesOrderId
  Remarks
This is a method wrapper for the GetSalesOrderProductsFromOpportunityRequest and GetSalesOrderProductsFromOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetTimeZoneCodeByLocalizedName Method
[image]

Retrieves the time-zone code for the specified localized time-zone name. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim localizedStandardName As String
Dim localeId As Integer
Dim returnValue As Integer

returnValue = OrganizationServiceContextExtensions.GetTimeZoneCodeByLocalizedName(context, localizedStandardName, localeId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetTimeZoneCodeByLocalizedName ( _
    context As OrganizationServiceContext, _
    localizedStandardName As String, _
    localeId As Integer _
) As Integer
C#
[ExtensionAttribute]
public static int GetTimeZoneCodeByLocalizedName (
    OrganizationServiceContext context,
    string localizedStandardName,
    int localeId
)
C++

J#

JScript

Parameters
context
The organization service context.
localizedStandardName
localeId
Return Value
Returns Int32.

  Remarks
This is a method wrapper for the GetTimeZoneCodeByLocalizedNameRequest and GetTimeZoneCodeByLocalizedNameResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GetTrackingTokenEmail Method
[image]

Returns a tracking token that can be then passed in as a parameter to the SendEmail method. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim subject As String
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.GetTrackingTokenEmail(context, subject)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function GetTrackingTokenEmail ( _
    context As OrganizationServiceContext, _
    subject As String _
) As String
C#
[ExtensionAttribute]
public static string GetTrackingTokenEmail (
    OrganizationServiceContext context,
    string subject
)
C++

J#

JScript

Parameters
context
The organization service context.
subject
Return Value
Returns String.

  Remarks
This is a method wrapper for the GetTrackingTokenEmailRequest and GetTrackingTokenEmailResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.GrantAccess Method
[image]

Grants a security principal (user or team) access to the specified record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim principalAccess As Object

OrganizationServiceContextExtensions.GrantAccess(context, target, principalAccess)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub GrantAccess ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    principalAccess As Object _
)
C#
[ExtensionAttribute]
public static void GrantAccess (
    OrganizationServiceContext context,
    EntityReference target,
    Object principalAccess
)
C++

J#

JScript

Parameters
context
The organization service context.
target
principalAccess
  Remarks
This is a method wrapper for the GrantAccessRequest and GrantAccessResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ImportRecordsImport Method
[image]

Imports XML mappings and creates an import data map. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim importId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.ImportRecordsImport(context, importId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ImportRecordsImport ( _
    context As OrganizationServiceContext, _
    importId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid ImportRecordsImport (
    OrganizationServiceContext context,
    Guid importId
)
C++

J#

JScript

Parameters
context
The organization service context.
importId
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the ImportRecordsImportRequest and ImportRecordsImportResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ImportSolution Method
[image]

Imports a managed or unmanaged solution. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim overwriteUnmanagedCustomizations As Boolean
Dim publishWorkflows As Boolean
Dim customizationFile As Byte()
Dim importJobId As Guid

OrganizationServiceContextExtensions.ImportSolution(context, overwriteUnmanagedCustomizations, publishWorkflows, customizationFile, importJobId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ImportSolution ( _
    context As OrganizationServiceContext, _
    overwriteUnmanagedCustomizations As Boolean, _
    publishWorkflows As Boolean, _
    customizationFile As Byte(), _
    importJobId As Guid _
)
C#
[ExtensionAttribute]
public static void ImportSolution (
    OrganizationServiceContext context,
    bool overwriteUnmanagedCustomizations,
    bool publishWorkflows,
    byte[] customizationFile,
    Guid importJobId
)
C++

J#

JScript

Parameters
context
The organization service context.
overwriteUnmanagedCustomizations
publishWorkflows
customizationFile
importJobId
  Remarks
This is a method wrapper for the ImportSolutionRequest and ImportSolutionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ImportTranslation Method
[image]

Imports all translations from a compressed file. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim translationFile As Byte()
Dim importJobId As Guid

OrganizationServiceContextExtensions.ImportTranslation(context, translationFile, importJobId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ImportTranslation ( _
    context As OrganizationServiceContext, _
    translationFile As Byte(), _
    importJobId As Guid _
)
C#
[ExtensionAttribute]
public static void ImportTranslation (
    OrganizationServiceContext context,
    byte[] translationFile,
    Guid importJobId
)
C++

J#

JScript

Parameters
context
The organization service context.
translationFile
importJobId
  Remarks
This is a method wrapper for the ImportTranslationRequest and ImportTranslationResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.InitializeFrom Method
[image]

Initializes a new record from an existing record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityMoniker As EntityReference
Dim targetEntityName As String
Dim targetFieldType As Object
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.InitializeFrom(context, entityMoniker, targetEntityName, targetFieldType)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function InitializeFrom ( _
    context As OrganizationServiceContext, _
    entityMoniker As EntityReference, _
    targetEntityName As String, _
    targetFieldType As Object _
) As Entity
C#
[ExtensionAttribute]
public static Entity InitializeFrom (
    OrganizationServiceContext context,
    EntityReference entityMoniker,
    string targetEntityName,
    Object targetFieldType
)
C++

J#

JScript

Parameters
context
The organization service context.
entityMoniker
targetEntityName
targetFieldType
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the InitializeFromRequest and InitializeFromResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.InstallSampleData Method
[image]

Installs sample data for an organization. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext

OrganizationServiceContextExtensions.InstallSampleData(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub InstallSampleData ( _
    context As OrganizationServiceContext _
)
C#
[ExtensionAttribute]
public static void InstallSampleData (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
  Remarks
This is a method wrapper for the InstallSampleDataRequest and InstallSampleDataResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.InstantiateFilters Method
[image]

Instantiates a filter. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim templateCollection As EntityReferenceCollection
Dim userId As Guid

OrganizationServiceContextExtensions.InstantiateFilters(context, templateCollection, userId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub InstantiateFilters ( _
    context As OrganizationServiceContext, _
    templateCollection As EntityReferenceCollection, _
    userId As Guid _
)
C#
[ExtensionAttribute]
public static void InstantiateFilters (
    OrganizationServiceContext context,
    EntityReferenceCollection templateCollection,
    Guid userId
)
C++

J#

JScript

Parameters
context
The organization service context.
templateCollection
userId
  Remarks
This is a method wrapper for the InstantiateFiltersRequest and InstantiateFiltersResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.InstantiateTemplate Method
[image]

Creates an email message from a template. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim templateId As Guid
Dim objectType As String
Dim objectId As Guid
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.InstantiateTemplate(context, templateId, objectType, objectId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function InstantiateTemplate ( _
    context As OrganizationServiceContext, _
    templateId As Guid, _
    objectType As String, _
    objectId As Guid _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection InstantiateTemplate (
    OrganizationServiceContext context,
    Guid templateId,
    string objectType,
    Guid objectId
)
C++

J#

JScript

Parameters
context
The organization service context.
templateId
objectType
objectId
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the InstantiateTemplateRequest and InstantiateTemplateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.IsBackOfficeInstalled Method
[image]

Deprecated. Checks if Microsoft Great Plains is installed. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.IsBackOfficeInstalled(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function IsBackOfficeInstalled ( _
    context As OrganizationServiceContext _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsBackOfficeInstalled (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns Boolean.

  Remarks
This is a method wrapper for the IsBackOfficeInstalledRequest and IsBackOfficeInstalledResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.IsComponentCustomizable Method
[image]

Determines whether a solution component is customizable. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim componentId As Guid
Dim componentType As Integer
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.IsComponentCustomizable(context, componentId, componentType)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function IsComponentCustomizable ( _
    context As OrganizationServiceContext, _
    componentId As Guid, _
    componentType As Integer _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsComponentCustomizable (
    OrganizationServiceContext context,
    Guid componentId,
    int componentType
)
C++

J#

JScript

Parameters
context
The organization service context.
componentId
componentType
Return Value
Returns Boolean.

  Remarks
This is a method wrapper for the IsComponentCustomizableRequest and IsComponentCustomizableResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.IsValidStateTransition Method
[image]

Checks to see if the state transition is valid. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As EntityReference
Dim newState As String
Dim newStatus As Integer
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.IsValidStateTransition(context, entity, newState, newStatus)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function IsValidStateTransition ( _
    context As OrganizationServiceContext, _
    entity As EntityReference, _
    newState As String, _
    newStatus As Integer _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsValidStateTransition (
    OrganizationServiceContext context,
    EntityReference entity,
    string newState,
    int newStatus
)
C++

J#

JScript

Parameters
context
The organization service context.
entity
newState
newStatus
Return Value
Returns Boolean.

  Remarks
This is a method wrapper for the IsValidStateTransitionRequest and IsValidStateTransitionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.LocalTimeFromUtcTime Method
[image]

Retrieves the local time for the specified Universal Time Coordinate (UTC) time. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim timeZoneCode As Integer
Dim utcTime As DateTime
Dim returnValue As DateTime

returnValue = OrganizationServiceContextExtensions.LocalTimeFromUtcTime(context, timeZoneCode, utcTime)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function LocalTimeFromUtcTime ( _
    context As OrganizationServiceContext, _
    timeZoneCode As Integer, _
    utcTime As DateTime _
) As DateTime
C#
[ExtensionAttribute]
public static DateTime LocalTimeFromUtcTime (
    OrganizationServiceContext context,
    int timeZoneCode,
    DateTime utcTime
)
C++

J#

JScript

Parameters
context
The organization service context.
timeZoneCode
utcTime
Return Value
Returns DateTime.

  Remarks
This is a method wrapper for the LocalTimeFromUtcTimeRequest and LocalTimeFromUtcTimeResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.LockInvoicePricing Method
[image]

Locks the total price of products and services specified in the invoice. When the invoice pricing is locked, changes to underlying price lists (price levels) do not affect the prices for an invoice. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim invoiceId As Guid

OrganizationServiceContextExtensions.LockInvoicePricing(context, invoiceId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub LockInvoicePricing ( _
    context As OrganizationServiceContext, _
    invoiceId As Guid _
)
C#
[ExtensionAttribute]
public static void LockInvoicePricing (
    OrganizationServiceContext context,
    Guid invoiceId
)
C++

J#

JScript

Parameters
context
The organization service context.
invoiceId
  Remarks
This is a method wrapper for the LockInvoicePricingRequest and LockInvoicePricingResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.LockSalesOrderPricing Method
[image]

Locks the total price of products and services specified in the sales order (order). When the sales order pricing is locked, changes to underlying price lists (price levels) do not affect the prices for a sales order (order). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim salesOrderId As Guid

OrganizationServiceContextExtensions.LockSalesOrderPricing(context, salesOrderId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub LockSalesOrderPricing ( _
    context As OrganizationServiceContext, _
    salesOrderId As Guid _
)
C#
[ExtensionAttribute]
public static void LockSalesOrderPricing (
    OrganizationServiceContext context,
    Guid salesOrderId
)
C++

J#

JScript

Parameters
context
The organization service context.
salesOrderId
  Remarks
This is a method wrapper for the LockSalesOrderPricingRequest and LockSalesOrderPricingResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.LogFailureBulkOperation Method
[image]

For internal use only. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim bulkOperationId As Guid
Dim regardingObjectId As Guid
Dim regardingObjectTypeCode As Integer
Dim errorCode As Integer
Dim message As String
Dim additionalInfo As String

OrganizationServiceContextExtensions.LogFailureBulkOperation(context, bulkOperationId, regardingObjectId, regardingObjectTypeCode, errorCode, message, additionalInfo)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub LogFailureBulkOperation ( _
    context As OrganizationServiceContext, _
    bulkOperationId As Guid, _
    regardingObjectId As Guid, _
    regardingObjectTypeCode As Integer, _
    errorCode As Integer, _
    message As String, _
    additionalInfo As String _
)
C#
[ExtensionAttribute]
public static void LogFailureBulkOperation (
    OrganizationServiceContext context,
    Guid bulkOperationId,
    Guid regardingObjectId,
    int regardingObjectTypeCode,
    int errorCode,
    string message,
    string additionalInfo
)
C++

J#

JScript

Parameters
context
The organization service context.
bulkOperationId
regardingObjectId
regardingObjectTypeCode
errorCode
message
additionalInfo
  Remarks
This is a method wrapper for the LogFailureBulkOperationRequest and LogFailureBulkOperationResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.LogSuccessBulkOperation Method
[image]

For internal use only. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim bulkOperationId As Guid
Dim regardingObjectId As Guid
Dim regardingObjectTypeCode As Integer
Dim createdObjectId As Guid
Dim createdObjectTypeCode As Integer
Dim additionalInfo As String

OrganizationServiceContextExtensions.LogSuccessBulkOperation(context, bulkOperationId, regardingObjectId, regardingObjectTypeCode, createdObjectId, createdObjectTypeCode, additionalInfo)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub LogSuccessBulkOperation ( _
    context As OrganizationServiceContext, _
    bulkOperationId As Guid, _
    regardingObjectId As Guid, _
    regardingObjectTypeCode As Integer, _
    createdObjectId As Guid, _
    createdObjectTypeCode As Integer, _
    additionalInfo As String _
)
C#
[ExtensionAttribute]
public static void LogSuccessBulkOperation (
    OrganizationServiceContext context,
    Guid bulkOperationId,
    Guid regardingObjectId,
    int regardingObjectTypeCode,
    Guid createdObjectId,
    int createdObjectTypeCode,
    string additionalInfo
)
C++

J#

JScript

Parameters
context
The organization service context.
bulkOperationId
regardingObjectId
regardingObjectTypeCode
createdObjectId
createdObjectTypeCode
additionalInfo
  Remarks
This is a method wrapper for the LogSuccessBulkOperationRequest and LogSuccessBulkOperationResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.LoseOpportunity Method
[image]

Sets the state of an opportunity to Lost. (Developer Extensions)

Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
OrganizationServiceContextExtensions.LoseOpportunity (OrganizationServiceContext, Entity, OptionSetValue) | Sets the state of an opportunity to Lost. (Developer Extensions)
OrganizationServiceContextExtensions.LoseOpportunity (OrganizationServiceContext, Entity, Int32) | Sets the state of an opportunity to Lost. (Developer Extensions)

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.LoseOpportunity Method (OrganizationServiceContext, Entity, OptionSetValue)
[image]

Sets the state of an opportunity to Lost. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityClose As Entity
Dim status As OptionSetValue

OrganizationServiceContextExtensions.LoseOpportunity(context, opportunityClose, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub LoseOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityClose As Entity, _
    status As OptionSetValue _
)
C#
[ExtensionAttribute]
public static void LoseOpportunity (
    OrganizationServiceContext context,
    Entity opportunityClose,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityClose
status
  Remarks
This is a method wrapper for the LoseOpportunityRequest and LoseOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.LoseOpportunity Method (OrganizationServiceContext, Entity, Int32)
[image]

Sets the state of an opportunity to Lost. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityClose As Entity
Dim status As Integer

OrganizationServiceContextExtensions.LoseOpportunity(context, opportunityClose, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub LoseOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityClose As Entity, _
    status As Integer _
)
C#
[ExtensionAttribute]
public static void LoseOpportunity (
    OrganizationServiceContext context,
    Entity opportunityClose,
    int status
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityClose
status
  Remarks
This is a method wrapper for the LoseOpportunityRequest and LoseOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace


OrganizationServiceContextExtensions.MakeAvailableToOrganizationReport Method
[image]

Deprecated. Makes the report available to all users in the organization. Use Update. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim reportId As Guid

OrganizationServiceContextExtensions.MakeAvailableToOrganizationReport(context, reportId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub MakeAvailableToOrganizationReport ( _
    context As OrganizationServiceContext, _
    reportId As Guid _
)
C#
[ExtensionAttribute]
public static void MakeAvailableToOrganizationReport (
    OrganizationServiceContext context,
    Guid reportId
)
C++

J#

JScript

Parameters
context
The organization service context.
reportId
  Remarks
This is a method wrapper for the MakeAvailableToOrganizationReportRequest and MakeAvailableToOrganizationReportResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.MakeAvailableToOrganizationTemplate Method
[image]

Deprecated. Makes the specified email template available to the entire organization. Use Update. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim templateId As Guid

OrganizationServiceContextExtensions.MakeAvailableToOrganizationTemplate(context, templateId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub MakeAvailableToOrganizationTemplate ( _
    context As OrganizationServiceContext, _
    templateId As Guid _
)
C#
[ExtensionAttribute]
public static void MakeAvailableToOrganizationTemplate (
    OrganizationServiceContext context,
    Guid templateId
)
C++

J#

JScript

Parameters
context
The organization service context.
templateId
  Remarks
This is a method wrapper for the MakeAvailableToOrganizationTemplateRequest and MakeAvailableToOrganizationTemplateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.MakeUnavailableToOrganizationReport Method
[image]

Deprecated. Makes the report unavailable to all users in the organization. Use Update. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim reportId As Guid

OrganizationServiceContextExtensions.MakeUnavailableToOrganizationReport(context, reportId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub MakeUnavailableToOrganizationReport ( _
    context As OrganizationServiceContext, _
    reportId As Guid _
)
C#
[ExtensionAttribute]
public static void MakeUnavailableToOrganizationReport (
    OrganizationServiceContext context,
    Guid reportId
)
C++

J#

JScript

Parameters
context
The organization service context.
reportId
  Remarks
This is a method wrapper for the MakeUnavailableToOrganizationReportRequest and MakeUnavailableToOrganizationReportResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.MakeUnavailableToOrganizationTemplate Method
[image]

Deprecated. Makes the specified email template no longer available to the entire organization. Use Update. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim templateId As Guid

OrganizationServiceContextExtensions.MakeUnavailableToOrganizationTemplate(context, templateId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub MakeUnavailableToOrganizationTemplate ( _
    context As OrganizationServiceContext, _
    templateId As Guid _
)
C#
[ExtensionAttribute]
public static void MakeUnavailableToOrganizationTemplate (
    OrganizationServiceContext context,
    Guid templateId
)
C++

J#

JScript

Parameters
context
The organization service context.
templateId
  Remarks
This is a method wrapper for the MakeUnavailableToOrganizationTemplateRequest and MakeUnavailableToOrganizationTemplateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.Merge Method
[image]

Merges the information from two records of the same type. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim subordinateId As Guid
Dim updateContent As Entity
Dim performParentingChecks As Boolean

OrganizationServiceContextExtensions.Merge(context, target, subordinateId, updateContent, performParentingChecks)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub Merge ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    subordinateId As Guid, _
    updateContent As Entity, _
    performParentingChecks As Boolean _
)
C#
[ExtensionAttribute]
public static void Merge (
    OrganizationServiceContext context,
    EntityReference target,
    Guid subordinateId,
    Entity updateContent,
    bool performParentingChecks
)
C++

J#

JScript

Parameters
context
The organization service context.
target
subordinateId
updateContent
performParentingChecks
  Remarks
This is a method wrapper for the MergeRequest and MergeResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ModifyAccess Method
[image]

Replaces the access rights on the target record for the specified security principal (user or team). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim principalAccess As Object

OrganizationServiceContextExtensions.ModifyAccess(context, target, principalAccess)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ModifyAccess ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    principalAccess As Object _
)
C#
[ExtensionAttribute]
public static void ModifyAccess (
    OrganizationServiceContext context,
    EntityReference target,
    Object principalAccess
)
C++

J#

JScript

Parameters
context
The organization service context.
target
principalAccess
  Remarks
This is a method wrapper for the ModifyAccessRequest and ModifyAccessResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ParseImport Method
[image]

Submits an asynchronous job that parses all import files associated with the specified data import (import). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim importId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.ParseImport(context, importId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ParseImport ( _
    context As OrganizationServiceContext, _
    importId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid ParseImport (
    OrganizationServiceContext context,
    Guid importId
)
C++

J#

JScript

Parameters
context
The organization service context.
importId
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the ParseImportRequest and ParseImportResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ProcessInboundEmail Method
[image]

Processes marketing campaign email responses. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim inboundEmailActivity As Guid

OrganizationServiceContextExtensions.ProcessInboundEmail(context, inboundEmailActivity)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ProcessInboundEmail ( _
    context As OrganizationServiceContext, _
    inboundEmailActivity As Guid _
)
C#
[ExtensionAttribute]
public static void ProcessInboundEmail (
    OrganizationServiceContext context,
    Guid inboundEmailActivity
)
C++

J#

JScript

Parameters
context
The organization service context.
inboundEmailActivity
  Remarks
This is a method wrapper for the ProcessInboundEmailRequest and ProcessInboundEmailResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ProcessOneMemberBulkOperation Method
[image]

For internal use only. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim bulkOperationId As Guid
Dim entity As Entity
Dim bulkOperationSource As Integer
Dim returnValue As Integer

returnValue = OrganizationServiceContextExtensions.ProcessOneMemberBulkOperation(context, bulkOperationId, entity, bulkOperationSource)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ProcessOneMemberBulkOperation ( _
    context As OrganizationServiceContext, _
    bulkOperationId As Guid, _
    entity As Entity, _
    bulkOperationSource As Integer _
) As Integer
C#
[ExtensionAttribute]
public static int ProcessOneMemberBulkOperation (
    OrganizationServiceContext context,
    Guid bulkOperationId,
    Entity entity,
    int bulkOperationSource
)
C++

J#

JScript

Parameters
context
The organization service context.
bulkOperationId
entity
bulkOperationSource
Return Value
Returns Int32.

  Remarks
This is a method wrapper for the ProcessOneMemberBulkOperationRequest and ProcessOneMemberBulkOperationResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.PropagateByExpression Method
[image]

Distributes an activity to a quick campaign. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim queryExpression As QueryBase
Dim friendlyName As String
Dim executeImmediately As Boolean
Dim activity As Entity
Dim templateId As Guid
Dim ownershipOptions As Object
Dim postWorkflowEvent As Boolean
Dim owner As EntityReference
Dim sendEmail As Boolean
Dim queueId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.PropagateByExpression(context, queryExpression, friendlyName, executeImmediately, activity, templateId, ownershipOptions, postWorkflowEvent, owner, sendEmail, queueId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function PropagateByExpression ( _
    context As OrganizationServiceContext, _
    queryExpression As QueryBase, _
    friendlyName As String, _
    executeImmediately As Boolean, _
    activity As Entity, _
    templateId As Guid, _
    ownershipOptions As Object, _
    postWorkflowEvent As Boolean, _
    owner As EntityReference, _
    sendEmail As Boolean, _
    queueId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid PropagateByExpression (
    OrganizationServiceContext context,
    QueryBase queryExpression,
    string friendlyName,
    bool executeImmediately,
    Entity activity,
    Guid templateId,
    Object ownershipOptions,
    bool postWorkflowEvent,
    EntityReference owner,
    bool sendEmail,
    Guid queueId
)
C++

J#

JScript

Parameters
context
The organization service context.
queryExpression
friendlyName
executeImmediately
activity
templateId
ownershipOptions
postWorkflowEvent
owner
sendEmail
queueId
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the PropagateByExpressionRequest and PropagateByExpressionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ProvisionLanguage Method
[image]

Provisions a language. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim language As Integer

OrganizationServiceContextExtensions.ProvisionLanguage(context, language)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ProvisionLanguage ( _
    context As OrganizationServiceContext, _
    language As Integer _
)
C#
[ExtensionAttribute]
public static void ProvisionLanguage (
    OrganizationServiceContext context,
    int language
)
C++

J#

JScript

Parameters
context
The organization service context.
language
  Remarks
This is a method wrapper for the ProvisionLanguageRequest and ProvisionLanguageResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.PublishAllXml Method
[image]

Publishes all customizations. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext

OrganizationServiceContextExtensions.PublishAllXml(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub PublishAllXml ( _
    context As OrganizationServiceContext _
)
C#
[ExtensionAttribute]
public static void PublishAllXml (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
  Remarks
This is a method wrapper for the PublishAllXmlRequest and PublishAllXmlResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.PublishDuplicateRule Method
[image]

Submits an asynchronous job to publish a duplicate rule. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim duplicateRuleId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.PublishDuplicateRule(context, duplicateRuleId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function PublishDuplicateRule ( _
    context As OrganizationServiceContext, _
    duplicateRuleId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid PublishDuplicateRule (
    OrganizationServiceContext context,
    Guid duplicateRuleId
)
C++

J#

JScript

Parameters
context
The organization service context.
duplicateRuleId
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the PublishDuplicateRuleRequest and PublishDuplicateRuleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.PublishXml Method
[image]

Publishes the customizations for the specified entities. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim parameterXml As String

OrganizationServiceContextExtensions.PublishXml(context, parameterXml)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub PublishXml ( _
    context As OrganizationServiceContext, _
    parameterXml As String _
)
C#
[ExtensionAttribute]
public static void PublishXml (
    OrganizationServiceContext context,
    string parameterXml
)
C++

J#

JScript

Parameters
context
The organization service context.
parameterXml
  Remarks
This is a method wrapper for the PublishXmlRequest and PublishXmlResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.QualifyLead Method
[image]

Qualifies a lead and creates an account, contact, or opportunity records that are linked to the originating lead. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim leadId As EntityReference
Dim createAccount As Boolean
Dim createContact As Boolean
Dim createOpportunity As Boolean
Dim opportunityCurrencyId As EntityReference
Dim opportunityCustomerId As EntityReference
Dim sourceCampaignId As EntityReference
Dim status As OptionSetValue
Dim returnValue As EntityReferenceCollection

returnValue = OrganizationServiceContextExtensions.QualifyLead(context, leadId, createAccount, createContact, createOpportunity, opportunityCurrencyId, opportunityCustomerId, sourceCampaignId, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function QualifyLead ( _
    context As OrganizationServiceContext, _
    leadId As EntityReference, _
    createAccount As Boolean, _
    createContact As Boolean, _
    createOpportunity As Boolean, _
    opportunityCurrencyId As EntityReference, _
    opportunityCustomerId As EntityReference, _
    sourceCampaignId As EntityReference, _
    status As OptionSetValue _
) As EntityReferenceCollection
C#
[ExtensionAttribute]
public static EntityReferenceCollection QualifyLead (
    OrganizationServiceContext context,
    EntityReference leadId,
    bool createAccount,
    bool createContact,
    bool createOpportunity,
    EntityReference opportunityCurrencyId,
    EntityReference opportunityCustomerId,
    EntityReference sourceCampaignId,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
leadId
createAccount
createContact
createOpportunity
opportunityCurrencyId
opportunityCustomerId
sourceCampaignId
status
Return Value
Returns EntityReferenceCollection.

  Remarks
This is a method wrapper for the QualifyLeadRequest and QualifyLeadResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.QualifyMemberList Method
[image]

Qualifies the specified member list and either overrides the list members or removes them according to the specified option. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim listId As Guid
Dim membersId As Guid()
Dim overrideorRemove As Boolean

OrganizationServiceContextExtensions.QualifyMemberList(context, listId, membersId, overrideorRemove)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub QualifyMemberList ( _
    context As OrganizationServiceContext, _
    listId As Guid, _
    membersId As Guid(), _
    overrideorRemove As Boolean _
)
C#
[ExtensionAttribute]
public static void QualifyMemberList (
    OrganizationServiceContext context,
    Guid listId,
    Guid[] membersId,
    bool overrideorRemove
)
C++

J#

JScript

Parameters
context
The organization service context.
listId
membersId
overrideorRemove
  Remarks
This is a method wrapper for the QualifyMemberListRequest and QualifyMemberListResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.QueryExpressionToFetchXml Method
[image]

Converts a query represented as a QueryExpression class to the equivalent query represented as FetchXML. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim query As QueryBase
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.QueryExpressionToFetchXml(context, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function QueryExpressionToFetchXml ( _
    context As OrganizationServiceContext, _
    query As QueryBase _
) As String
C#
[ExtensionAttribute]
public static string QueryExpressionToFetchXml (
    OrganizationServiceContext context,
    QueryBase query
)
C++

J#

JScript

Parameters
context
The organization service context.
query
Return Value
Returns String.

  Remarks
This is a method wrapper for the QueryExpressionToFetchXmlRequest and QueryExpressionToFetchXmlResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.QueryMultipleSchedules Method
[image]

Searches multiple resources for an available time slot matching the specified parameters. This is similar to the QuerySchedule method but it works for multiple resources at one time. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim resourceIds As Guid()
Dim start As DateTime
Dim end As DateTime
Dim timeCodes As Object
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.QueryMultipleSchedules(context, resourceIds, start, end, timeCodes)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function QueryMultipleSchedules(Of TResult) ( _
    context As OrganizationServiceContext, _
    resourceIds As Guid(), _
    start As DateTime, _
    end As DateTime, _
    timeCodes As Object _
) As TResult
C#
[ExtensionAttribute]
public static TResult QueryMultipleSchedules<TResult> (
    OrganizationServiceContext context,
    Guid[] resourceIds,
    DateTime start,
    DateTime end,
    Object timeCodes
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
resourceIds
start
end
timeCodes
Return Value
Returns String.

  Remarks
This is a method wrapper for the QueryMultipleSchedulesRequest and QueryMultipleSchedulesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.QuerySchedule Method
[image]

Searches the specified resource for an available time slot matching the specified parameters. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim resourceId As Guid
Dim start As DateTime
Dim end As DateTime
Dim timeCodes As Object
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.QuerySchedule(context, resourceId, start, end, timeCodes)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function QuerySchedule(Of TResult) ( _
    context As OrganizationServiceContext, _
    resourceId As Guid, _
    start As DateTime, _
    end As DateTime, _
    timeCodes As Object _
) As TResult
C#
[ExtensionAttribute]
public static TResult QuerySchedule<TResult> (
    OrganizationServiceContext context,
    Guid resourceId,
    DateTime start,
    DateTime end,
    Object timeCodes
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
resourceId
start
end
timeCodes
Return Value
Returns String.

  Remarks
This is a method wrapper for the QueryScheduleRequest and QueryScheduleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ReassignObjectsOwner Method
[image]

Reassigns all records that are owned by the security principal (user or team) to another security principal (user or team). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim fromPrincipal As EntityReference
Dim toPrincipal As EntityReference

OrganizationServiceContextExtensions.ReassignObjectsOwner(context, fromPrincipal, toPrincipal)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ReassignObjectsOwner ( _
    context As OrganizationServiceContext, _
    fromPrincipal As EntityReference, _
    toPrincipal As EntityReference _
)
C#
[ExtensionAttribute]
public static void ReassignObjectsOwner (
    OrganizationServiceContext context,
    EntityReference fromPrincipal,
    EntityReference toPrincipal
)
C++

J#

JScript

Parameters
context
The organization service context.
fromPrincipal
toPrincipal
  Remarks
This is a method wrapper for the ReassignObjectsOwnerRequest and ReassignObjectsOwnerResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ReassignObjectsSystemUser Method
[image]

Reassigns all records that are owned by the user to another security principal (user or team). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim userId As Guid
Dim reassignPrincipal As EntityReference

OrganizationServiceContextExtensions.ReassignObjectsSystemUser(context, userId, reassignPrincipal)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ReassignObjectsSystemUser ( _
    context As OrganizationServiceContext, _
    userId As Guid, _
    reassignPrincipal As EntityReference _
)
C#
[ExtensionAttribute]
public static void ReassignObjectsSystemUser (
    OrganizationServiceContext context,
    Guid userId,
    EntityReference reassignPrincipal
)
C++

J#

JScript

Parameters
context
The organization service context.
userId
reassignPrincipal
  Remarks
This is a method wrapper for the ReassignObjectsSystemUserRequest and ReassignObjectsSystemUserResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.Recalculate Method
[image]

Recalculates the rollup attribute values for all goals in the goal hierarchy that contain a specified goal. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference

OrganizationServiceContextExtensions.Recalculate(context, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub Recalculate ( _
    context As OrganizationServiceContext, _
    target As EntityReference _
)
C#
[ExtensionAttribute]
public static void Recalculate (
    OrganizationServiceContext context,
    EntityReference target
)
C++

J#

JScript

Parameters
context
The organization service context.
target
  Remarks
This is a method wrapper for the RecalculateRequest and RecalculateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemoveItemCampaign Method
[image]

Removes an item from a campaign. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim campaignId As Guid
Dim entityId As Guid

OrganizationServiceContextExtensions.RemoveItemCampaign(context, campaignId, entityId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveItemCampaign ( _
    context As OrganizationServiceContext, _
    campaignId As Guid, _
    entityId As Guid _
)
C#
[ExtensionAttribute]
public static void RemoveItemCampaign (
    OrganizationServiceContext context,
    Guid campaignId,
    Guid entityId
)
C++

J#

JScript

Parameters
context
The organization service context.
campaignId
entityId
  Remarks
This is a method wrapper for the RemoveItemCampaignRequest and RemoveItemCampaignResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemoveItemCampaignActivity Method
[image]

Removes an item from a campaign activity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim campaignActivityId As Guid
Dim itemId As Guid

OrganizationServiceContextExtensions.RemoveItemCampaignActivity(context, campaignActivityId, itemId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveItemCampaignActivity ( _
    context As OrganizationServiceContext, _
    campaignActivityId As Guid, _
    itemId As Guid _
)
C#
[ExtensionAttribute]
public static void RemoveItemCampaignActivity (
    OrganizationServiceContext context,
    Guid campaignActivityId,
    Guid itemId
)
C++

J#

JScript

Parameters
context
The organization service context.
campaignActivityId
itemId
  Remarks
This is a method wrapper for the RemoveItemCampaignActivityRequest and RemoveItemCampaignActivityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemoveMemberList Method
[image]

Removes a member from a list. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim listId As Guid
Dim entityId As Guid

OrganizationServiceContextExtensions.RemoveMemberList(context, listId, entityId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveMemberList ( _
    context As OrganizationServiceContext, _
    listId As Guid, _
    entityId As Guid _
)
C#
[ExtensionAttribute]
public static void RemoveMemberList (
    OrganizationServiceContext context,
    Guid listId,
    Guid entityId
)
C++

J#

JScript

Parameters
context
The organization service context.
listId
entityId
  Remarks
This is a method wrapper for the RemoveMemberListRequest and RemoveMemberListResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemoveMembersTeam Method
[image]

Removes members from a team. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim teamId As Guid
Dim memberIds As Guid()

OrganizationServiceContextExtensions.RemoveMembersTeam(context, teamId, memberIds)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveMembersTeam ( _
    context As OrganizationServiceContext, _
    teamId As Guid, _
    memberIds As Guid() _
)
C#
[ExtensionAttribute]
public static void RemoveMembersTeam (
    OrganizationServiceContext context,
    Guid teamId,
    Guid[] memberIds
)
C++

J#

JScript

Parameters
context
The organization service context.
teamId
memberIds
  Remarks
This is a method wrapper for the RemoveMembersTeamRequest and RemoveMembersTeamResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemoveParent Method
[image]

Removes the parent for a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference

OrganizationServiceContextExtensions.RemoveParent(context, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveParent ( _
    context As OrganizationServiceContext, _
    target As EntityReference _
)
C#
[ExtensionAttribute]
public static void RemoveParent (
    OrganizationServiceContext context,
    EntityReference target
)
C++

J#

JScript

Parameters
context
The organization service context.
target
  Remarks
This is a method wrapper for the RemoveParentRequest and RemoveParentResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemovePrivilegeRole Method
[image]

Removes a privilege from an existing role. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim roleId As Guid
Dim privilegeId As Guid

OrganizationServiceContextExtensions.RemovePrivilegeRole(context, roleId, privilegeId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemovePrivilegeRole ( _
    context As OrganizationServiceContext, _
    roleId As Guid, _
    privilegeId As Guid _
)
C#
[ExtensionAttribute]
public static void RemovePrivilegeRole (
    OrganizationServiceContext context,
    Guid roleId,
    Guid privilegeId
)
C++

J#

JScript

Parameters
context
The organization service context.
roleId
privilegeId
  Remarks
This is a method wrapper for the RemovePrivilegeRoleRequest and RemovePrivilegeRoleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemoveProductFromKit Method
[image]

Removes a product from a kit. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim kitId As Guid
Dim productId As Guid

OrganizationServiceContextExtensions.RemoveProductFromKit(context, kitId, productId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveProductFromKit ( _
    context As OrganizationServiceContext, _
    kitId As Guid, _
    productId As Guid _
)
C#
[ExtensionAttribute]
public static void RemoveProductFromKit (
    OrganizationServiceContext context,
    Guid kitId,
    Guid productId
)
C++

J#

JScript

Parameters
context
The organization service context.
kitId
productId
  Remarks
This is a method wrapper for the RemoveProductFromKitRequest and RemoveProductFromKitResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemoveRelated Method
[image]

Deprecated. Removes the relationship between two records as defined by the target classes listed below. For example, remove the relationship between an invoice and a contact. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference()

OrganizationServiceContextExtensions.RemoveRelated(context, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveRelated ( _
    context As OrganizationServiceContext, _
    target As EntityReference() _
)
C#
[ExtensionAttribute]
public static void RemoveRelated (
    OrganizationServiceContext context,
    EntityReference[] target
)
C++

J#

JScript

Parameters
context
The organization service context.
target
  Remarks
This is a method wrapper for the RemoveRelatedRequest and RemoveRelatedResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemoveSolutionComponent Method
[image]

Removes a solution component to an unmanaged solution. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim componentId As Guid
Dim componentType As Integer
Dim solutionUniqueName As String
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.RemoveSolutionComponent(context, componentId, componentType, solutionUniqueName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RemoveSolutionComponent ( _
    context As OrganizationServiceContext, _
    componentId As Guid, _
    componentType As Integer, _
    solutionUniqueName As String _
) As Guid
C#
[ExtensionAttribute]
public static Guid RemoveSolutionComponent (
    OrganizationServiceContext context,
    Guid componentId,
    int componentType,
    string solutionUniqueName
)
C++

J#

JScript

Parameters
context
The organization service context.
componentId
componentType
solutionUniqueName
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the RemoveSolutionComponentRequest and RemoveSolutionComponentResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RemoveSubstituteProduct Method
[image]

Deprecated. Removes the association between a product and a substitute product. Use Disassociate. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim productId As Guid
Dim substituteId As Guid

OrganizationServiceContextExtensions.RemoveSubstituteProduct(context, productId, substituteId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveSubstituteProduct ( _
    context As OrganizationServiceContext, _
    productId As Guid, _
    substituteId As Guid _
)
C#
[ExtensionAttribute]
public static void RemoveSubstituteProduct (
    OrganizationServiceContext context,
    Guid productId,
    Guid substituteId
)
C++

J#

JScript

Parameters
context
The organization service context.
productId
substituteId
  Remarks
This is a method wrapper for the RemoveSubstituteProductRequest and RemoveSubstituteProductResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RenewContract Method
[image]

Renews a contract. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim contractId As Guid
Dim status As Integer
Dim includeCanceledLines As Boolean
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.RenewContract(context, contractId, status, includeCanceledLines)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RenewContract ( _
    context As OrganizationServiceContext, _
    contractId As Guid, _
    status As Integer, _
    includeCanceledLines As Boolean _
) As Entity
C#
[ExtensionAttribute]
public static Entity RenewContract (
    OrganizationServiceContext context,
    Guid contractId,
    int status,
    bool includeCanceledLines
)
C++

J#

JScript

Parameters
context
The organization service context.
contractId
status
includeCanceledLines
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the RenewContractRequest and RenewContractResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ReplacePrivilegesRole Method
[image]

Replaces the privilege set of an existing role. This effectively deletes all existing privileges from the role and adds the new specified privileges. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim roleId As Guid
Dim privileges As Object

OrganizationServiceContextExtensions.ReplacePrivilegesRole(context, roleId, privileges)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ReplacePrivilegesRole ( _
    context As OrganizationServiceContext, _
    roleId As Guid, _
    privileges As Object _
)
C#
[ExtensionAttribute]
public static void ReplacePrivilegesRole (
    OrganizationServiceContext context,
    Guid roleId,
    Object privileges
)
C++

J#

JScript

Parameters
context
The organization service context.
roleId
privileges
  Remarks
This is a method wrapper for the ReplacePrivilegesRoleRequest and ReplacePrivilegesRoleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.Reschedule Method
[image]

Reschedules an appointment, service appointment or recurring appointment. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As Entity
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.Reschedule(context, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Reschedule(Of TResult) ( _
    context As OrganizationServiceContext, _
    target As Entity _
) As TResult
C#
[ExtensionAttribute]
public static TResult Reschedule<TResult> (
    OrganizationServiceContext context,
    Entity target
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
target
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the RescheduleRequest and RescheduleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ResetUserFilters Method
[image]

Resets the offline data filters for the calling user to the default filters for the organization. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim queryType As Integer

OrganizationServiceContextExtensions.ResetUserFilters(context, queryType)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ResetUserFilters ( _
    context As OrganizationServiceContext, _
    queryType As Integer _
)
C#
[ExtensionAttribute]
public static void ResetUserFilters (
    OrganizationServiceContext context,
    int queryType
)
C++

J#

JScript

Parameters
context
The organization service context.
queryType
  Remarks
This is a method wrapper for the ResetUserFiltersRequest and ResetUserFiltersResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveAbsoluteAndSiteCollectionUrl Method
[image]

Retrieves the absolute (complete) URL and the site collection URL of a SharePoint document location or SharePoint site. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim returnValue As TResponse

returnValue = OrganizationServiceContextExtensions.RetrieveAbsoluteAndSiteCollectionUrl(context, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveAbsoluteAndSiteCollectionUrl(Of TResponse As OrganizationResponse) ( _
    context As OrganizationServiceContext, _
    target As EntityReference _
) As TResponse
C#
[ExtensionAttribute]
public static TResponse RetrieveAbsoluteAndSiteCollectionUrl<TResponse> (
    OrganizationServiceContext context,
    EntityReference target
) where TResponse : OrganizationResponse
C++

J#

JScript

GenericParameters
TResponse
Parameters
context
The organization service context.
target
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the RetrieveAbsoluteAndSiteCollectionUrlRequest and RetrieveAbsoluteAndSiteCollectionUrlResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveAllChildUsersSystemUser Method
[image]

Retrieves a collection of system users who report to the specified system user. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As Guid
Dim columnSet As ColumnSet
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveAllChildUsersSystemUser(context, entityId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveAllChildUsersSystemUser ( _
    context As OrganizationServiceContext, _
    entityId As Guid, _
    columnSet As ColumnSet _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveAllChildUsersSystemUser (
    OrganizationServiceContext context,
    Guid entityId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
columnSet
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveAllChildUsersSystemUserRequest and RetrieveAllChildUsersSystemUserResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveAllEntities Method
[image]

Retrieves the metadata for all entities. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As OrganizationServiceContext
Dim entityFilters As EntityFilters
Dim retrieveAsIfPublished As Boolean
Dim returnValue As EntityMetadata()

returnValue = OrganizationServiceContextExtensions.RetrieveAllEntities(service, entityFilters, retrieveAsIfPublished)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveAllEntities ( _
    service As OrganizationServiceContext, _
    <OptionalAttribute> Optional entityFilters As EntityFilters = EntityFilters.Entity, _
    <OptionalAttribute> Optional retrieveAsIfPublished As Boolean = False _
) As EntityMetadata()
C#
[ExtensionAttribute]
public static EntityMetadata[] RetrieveAllEntities (
    OrganizationServiceContext service,
    [OptionalAttribute] EntityFilters entityFilters,
    [OptionalAttribute] bool retrieveAsIfPublished
)
C++

J#

JScript

Parameters
service
The organization service context.
entityFilters
retrieveAsIfPublished
Return Value
Returns EntityMetadata.

  Remarks
This is a method wrapper for the RetrieveAllEntitiesRequest and RetrieveAllEntitiesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveApplicationRibbon Method
[image]

Retrieves the core application ribbons including the entity template. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As Byte()

returnValue = OrganizationServiceContextExtensions.RetrieveApplicationRibbon(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveApplicationRibbon ( _
    context As OrganizationServiceContext _
) As Byte()
C#
[ExtensionAttribute]
public static byte[] RetrieveApplicationRibbon (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns Byte.

  Remarks
This is a method wrapper for the RetrieveApplicationRibbonRequest and RetrieveApplicationRibbonResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveAttribute Method
[image]

Retrieves the metadata for the specified attribute. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As OrganizationServiceContext
Dim entityLogicalName As String
Dim logicalName As String
Dim retrieveAsIfPublished As Boolean
Dim returnValue As AttributeMetadata

returnValue = OrganizationServiceContextExtensions.RetrieveAttribute(service, entityLogicalName, logicalName, retrieveAsIfPublished)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveAttribute ( _
    service As OrganizationServiceContext, _
    entityLogicalName As String, _
    logicalName As String, _
    <OptionalAttribute> Optional retrieveAsIfPublished As Boolean = False _
) As AttributeMetadata
C#
[ExtensionAttribute]
public static AttributeMetadata RetrieveAttribute (
    OrganizationServiceContext service,
    string entityLogicalName,
    string logicalName,
    [OptionalAttribute] bool retrieveAsIfPublished
)
C++

J#

JScript

Parameters
service
The organization service context.
entityLogicalName
logicalName
retrieveAsIfPublished
Return Value
Returns AttributeMetadata.

  Remarks
This is a method wrapper for the RetrieveAttributeRequest and RetrieveAttributeResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveAttributeChangeHistory Method
[image]

Retrieves all changes to a specific attribute. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim attributeLogicalName As String
Dim pagingInfo As PagingInfo
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveAttributeChangeHistory(context, target, attributeLogicalName, pagingInfo)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveAttributeChangeHistory(Of TResult) ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    attributeLogicalName As String, _
    pagingInfo As PagingInfo _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveAttributeChangeHistory<TResult> (
    OrganizationServiceContext context,
    EntityReference target,
    string attributeLogicalName,
    PagingInfo pagingInfo
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
target
attributeLogicalName
pagingInfo
Return Value
Returns AttributeMetadata.

  Remarks
This is a method wrapper for the RetrieveAttributeChangeHistoryRequest and RetrieveAttributeChangeHistoryResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveAuditDetails Method
[image]

Retrieves the full audit details of a particular audit record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim auditId As Guid
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveAuditDetails(context, auditId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveAuditDetails(Of TResult) ( _
    context As OrganizationServiceContext, _
    auditId As Guid _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveAuditDetails<TResult> (
    OrganizationServiceContext context,
    Guid auditId
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
auditId
Return Value
Returns AttributeMetadata.

  Remarks
This is a method wrapper for the RetrieveAuditDetailsRequest and RetrieveAuditDetailsResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveAuditPartitionList Method
[image]

Retrieves the list of auditing partitions. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveAuditPartitionList(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveAuditPartitionList(Of TResult) ( _
    context As OrganizationServiceContext _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveAuditPartitionList<TResult> (
    OrganizationServiceContext context
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
Return Value
Returns AttributeMetadata.

  Remarks
This is a method wrapper for the RetrieveAuditPartitionListRequest and RetrieveAuditPartitionListResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveAvailableLanguages Method
[image]

Retrieves the list of available languages. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As Integer()

returnValue = OrganizationServiceContextExtensions.RetrieveAvailableLanguages(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveAvailableLanguages ( _
    context As OrganizationServiceContext _
) As Integer()
C#
[ExtensionAttribute]
public static int[] RetrieveAvailableLanguages (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns Int32.

  Remarks
This is a method wrapper for the RetrieveAvailableLanguagesRequest and RetrieveAvailableLanguagesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveBusinessHierarchyBusinessUnit Method
[image]

Retrieves all the business units in the business unit hierarchy. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As Guid
Dim columnSet As ColumnSet
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveBusinessHierarchyBusinessUnit(context, entityId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveBusinessHierarchyBusinessUnit ( _
    context As OrganizationServiceContext, _
    entityId As Guid, _
    columnSet As ColumnSet _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveBusinessHierarchyBusinessUnit (
    OrganizationServiceContext context,
    Guid entityId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
columnSet
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveBusinessHierarchyBusinessUnitRequest and RetrieveBusinessHierarchyBusinessUnitResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveByGroupResource Method
[image]

Retrieves all the resource groups to which the specified resource belongs. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim resourceGroupId As Guid
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveByGroupResource(context, resourceGroupId, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveByGroupResource ( _
    context As OrganizationServiceContext, _
    resourceGroupId As Guid, _
    query As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveByGroupResource (
    OrganizationServiceContext context,
    Guid resourceGroupId,
    QueryBase query
)
C++

J#

JScript

Parameters
context
The organization service context.
resourceGroupId
query
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveByGroupResourceRequest and RetrieveByGroupResourceResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveByResourceResourceGroup Method
[image]

Retrieves the resource groups that contain the specified resource. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim resourceId As Guid
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveByResourceResourceGroup(context, resourceId, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveByResourceResourceGroup ( _
    context As OrganizationServiceContext, _
    resourceId As Guid, _
    query As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveByResourceResourceGroup (
    OrganizationServiceContext context,
    Guid resourceId,
    QueryBase query
)
C++

J#

JScript

Parameters
context
The organization service context.
resourceId
query
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveByResourceResourceGroup and RetrieveByResourceResourceGroupResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveByResourcesService Method
[image]

Retrieves a collection of services related to the specified set of services. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim resourceIds As Guid()
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveByResourcesService(context, resourceIds, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveByResourcesService ( _
    context As OrganizationServiceContext, _
    resourceIds As Guid(), _
    query As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveByResourcesService (
    OrganizationServiceContext context,
    Guid[] resourceIds,
    QueryBase query
)
C++

J#

JScript

Parameters
context
The organization service context.
resourceIds
query
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveByResourcesServiceRequest and RetrieveByResourcesServiceResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveByTopIncidentProductKbArticle Method
[image]

Retrieves the top ten knowledge base articles for the product specified. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim productId As Guid
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveByTopIncidentProductKbArticle(context, productId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveByTopIncidentProductKbArticle ( _
    context As OrganizationServiceContext, _
    productId As Guid _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveByTopIncidentProductKbArticle (
    OrganizationServiceContext context,
    Guid productId
)
C++

J#

JScript

Parameters
context
The organization service context.
productId
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveByTopIncidentProductKbArticleRequest and RetrieveByTopIncidentProductKbArticleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveByTopIncidentSubjectKbArticle Method
[image]

Retrieves the top ten knowledge base articles for the subject specified. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim subjectId As Guid
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveByTopIncidentSubjectKbArticle(context, subjectId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveByTopIncidentSubjectKbArticle ( _
    context As OrganizationServiceContext, _
    subjectId As Guid _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveByTopIncidentSubjectKbArticle (
    OrganizationServiceContext context,
    Guid subjectId
)
C++

J#

JScript

Parameters
context
The organization service context.
subjectId
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveByTopIncidentSubjectKbArticleRequest and RetrieveByTopIncidentSubjectKbArticleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveDependenciesForDelete Method
[image]

Retrieves the dependencies for solution components that will prevent a solution component from being deleted. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim objectId As Guid
Dim componentType As Integer
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveDependenciesForDelete(context, objectId, componentType)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveDependenciesForDelete ( _
    context As OrganizationServiceContext, _
    objectId As Guid, _
    componentType As Integer _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveDependenciesForDelete (
    OrganizationServiceContext context,
    Guid objectId,
    int componentType
)
C++

J#

JScript

Parameters
context
The organization service context.
objectId
componentType
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveDependenciesForDeleteRequest and RetrieveDependenciesForDeleteResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveDependenciesForUninstall Method
[image]

Retrieves the dependencies for solution components that could prevent uninstalling a managed solution. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim solutionUniqueName As String
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveDependenciesForUninstall(context, solutionUniqueName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveDependenciesForUninstall ( _
    context As OrganizationServiceContext, _
    solutionUniqueName As String _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveDependenciesForUninstall (
    OrganizationServiceContext context,
    string solutionUniqueName
)
C++

J#

JScript

Parameters
context
The organization service context.
solutionUniqueName
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveDependenciesForUninstallRequest and RetrieveDependenciesForUninstallResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveDependentComponents Method
[image]

Retrieves all components that depend on the specified component. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim objectId As Guid
Dim componentType As Integer
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveDependentComponents(context, objectId, componentType)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveDependentComponents ( _
    context As OrganizationServiceContext, _
    objectId As Guid, _
    componentType As Integer _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveDependentComponents (
    OrganizationServiceContext context,
    Guid objectId,
    int componentType
)
C++

J#

JScript

Parameters
context
The organization service context.
objectId
componentType
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveDependentComponentsRequest and RetrieveDependentComponentsRequest classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveDeploymentLicenseType Method
[image]

Retrieves the type of license for a deployment of Microsoft Dynamics CRM. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.RetrieveDeploymentLicenseType(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveDeploymentLicenseType ( _
    context As OrganizationServiceContext _
) As String
C#
[ExtensionAttribute]
public static string RetrieveDeploymentLicenseType (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns String.

  Remarks
This is a method wrapper for the RetrieveDeploymentLicenseTypeRequest and RetrieveDeploymentLicenseTypeResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveDeprovisionedLanguages Method
[image]

Retrieves the list of language packs installed on the server that have been disabled. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As Integer()

returnValue = OrganizationServiceContextExtensions.RetrieveDeprovisionedLanguages(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveDeprovisionedLanguages ( _
    context As OrganizationServiceContext _
) As Integer()
C#
[ExtensionAttribute]
public static int[] RetrieveDeprovisionedLanguages (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns Int32.

  Remarks
This is a method wrapper for the RetrieveDeprovisionedLanguagesRequest and RetrieveDeprovisionedLanguagesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveDuplicates Method
[image]

Detects and retrieves duplicate records for the specified record, provided duplicate detection is enabled and there are published duplicate detection rules for the entity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim businessEntity As Entity
Dim matchingEntityName As String
Dim pagingInfo As PagingInfo
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveDuplicates(context, businessEntity, matchingEntityName, pagingInfo)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveDuplicates ( _
    context As OrganizationServiceContext, _
    businessEntity As Entity, _
    matchingEntityName As String, _
    pagingInfo As PagingInfo _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveDuplicates (
    OrganizationServiceContext context,
    Entity businessEntity,
    string matchingEntityName,
    PagingInfo pagingInfo
)
C++

J#

JScript

Parameters
context
The organization service context.
businessEntity
matchingEntityName
pagingInfo
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveDuplicatesRequest and RetrieveDuplicatesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveEntity Method
[image]

Retrieves the metadata for the specified entity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As OrganizationServiceContext
Dim logicalName As String
Dim entityFilters As EntityFilters
Dim retrieveAsIfPublished As Boolean
Dim returnValue As EntityMetadata

returnValue = OrganizationServiceContextExtensions.RetrieveEntity(service, logicalName, entityFilters, retrieveAsIfPublished)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveEntity ( _
    service As OrganizationServiceContext, _
    logicalName As String, _
    <OptionalAttribute> Optional entityFilters As EntityFilters = EntityFilters.Entity, _
    <OptionalAttribute> Optional retrieveAsIfPublished As Boolean = False _
) As EntityMetadata
C#
[ExtensionAttribute]
public static EntityMetadata RetrieveEntity (
    OrganizationServiceContext service,
    string logicalName,
    [OptionalAttribute] EntityFilters entityFilters,
    [OptionalAttribute] bool retrieveAsIfPublished
)
C++

J#

JScript

Parameters
service
The organization service context.
logicalName
entityFilters
retrieveAsIfPublished
Return Value
Returns EntityMetadata.

  Remarks
This is a method wrapper for the RetrieveEntityRequest and RetrieveEntityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveEntityRibbon Method
[image]

Retrieves the ribbon definition used for a specific entity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityName As String
Dim ribbonLocationFilter As Object
Dim returnValue As Byte()

returnValue = OrganizationServiceContextExtensions.RetrieveEntityRibbon(context, entityName, ribbonLocationFilter)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveEntityRibbon ( _
    context As OrganizationServiceContext, _
    entityName As String, _
    ribbonLocationFilter As Object _
) As Byte()
C#
[ExtensionAttribute]
public static byte[] RetrieveEntityRibbon (
    OrganizationServiceContext context,
    string entityName,
    Object ribbonLocationFilter
)
C++

J#

JScript

Parameters
context
The organization service context.
entityName
ribbonLocationFilter
Return Value
Returns Byte.

  Remarks
This is a method wrapper for the RetrieveEntityRibbonRequest and p0RetrieveEntityRibbonResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveExchangeRate Method
[image]

Retrieves the exchange rate. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim transactionCurrencyId As Guid
Dim returnValue As Decimal

returnValue = OrganizationServiceContextExtensions.RetrieveExchangeRate(context, transactionCurrencyId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveExchangeRate ( _
    context As OrganizationServiceContext, _
    transactionCurrencyId As Guid _
) As Decimal
C#
[ExtensionAttribute]
public static decimal RetrieveExchangeRate (
    OrganizationServiceContext context,
    Guid transactionCurrencyId
)
C++

J#

JScript

Parameters
context
The organization service context.
transactionCurrencyId
Return Value
Returns Decimal.

  Remarks
This is a method wrapper for the RetrieveExchangeRateRequest and RetrieveExchangeRateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveFilteredForms Method
[image]

Retrieves the system forms for the specified user. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityLogicalName As String
Dim formType As OptionSetValue
Dim systemUserId As Guid
Dim returnValue As EntityReferenceCollection

returnValue = OrganizationServiceContextExtensions.RetrieveFilteredForms(context, entityLogicalName, formType, systemUserId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveFilteredForms ( _
    context As OrganizationServiceContext, _
    entityLogicalName As String, _
    formType As OptionSetValue, _
    systemUserId As Guid _
) As EntityReferenceCollection
C#
[ExtensionAttribute]
public static EntityReferenceCollection RetrieveFilteredForms (
    OrganizationServiceContext context,
    string entityLogicalName,
    OptionSetValue formType,
    Guid systemUserId
)
C++

J#

JScript

Parameters
context
The organization service context.
entityLogicalName
formType
systemUserId
Return Value
Returns EntityReferenceCollection.

  Remarks
This is a method wrapper for the RetrieveFilteredFormsRequest and RetrieveFilteredFormsResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveFormattedImportJobResults Method
[image]

Retrieves the formatted results from an import job. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim importJobId As Guid
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.RetrieveFormattedImportJobResults(context, importJobId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveFormattedImportJobResults ( _
    context As OrganizationServiceContext, _
    importJobId As Guid _
) As String
C#
[ExtensionAttribute]
public static string RetrieveFormattedImportJobResults (
    OrganizationServiceContext context,
    Guid importJobId
)
C++

J#

JScript

Parameters
context
The organization service context.
importJobId
Return Value
Returns String.

  Remarks
This is a method wrapper for the RetrieveFormattedImportJobResultsRequest and RetrieveFormattedImportJobResultsResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveFormXml Method
[image]

For internal use only. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityName As String
Dim returnValue As TResponse

returnValue = OrganizationServiceContextExtensions.RetrieveFormXml(context, entityName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveFormXml(Of TResponse As OrganizationResponse) ( _
    context As OrganizationServiceContext, _
    entityName As String _
) As TResponse
C#
[ExtensionAttribute]
public static TResponse RetrieveFormXml<TResponse> (
    OrganizationServiceContext context,
    string entityName
) where TResponse : OrganizationResponse
C++

J#

JScript

GenericParameters
TResponse
Parameters
context
The organization service context.
entityName
Return Value
Returns String.

  Remarks
This is a method wrapper for the RetrieveFormXmlRequest and RetrieveFormXmlResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveInstalledLanguagePacks Method
[image]

Retrieves the list of language packs installed on the server. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As Integer()

returnValue = OrganizationServiceContextExtensions.RetrieveInstalledLanguagePacks(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveInstalledLanguagePacks ( _
    context As OrganizationServiceContext _
) As Integer()
C#
[ExtensionAttribute]
public static int[] RetrieveInstalledLanguagePacks (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns Int32.

  Remarks
This is a method wrapper for the RetrieveInstalledLanguagePacksRequest and RetrieveInstalledLanguagePacksResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveInstalledLanguagePackVersion Method
[image]

Retrieves the version of an installed language pack. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim language As Integer
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.RetrieveInstalledLanguagePackVersion(context, language)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveInstalledLanguagePackVersion ( _
    context As OrganizationServiceContext, _
    language As Integer _
) As String
C#
[ExtensionAttribute]
public static string RetrieveInstalledLanguagePackVersion (
    OrganizationServiceContext context,
    int language
)
C++

J#

JScript

Parameters
context
The organization service context.
language
Return Value
Returns String.

  Remarks
This is a method wrapper for the RetrieveInstalledLanguagePackVersionRequest and RetrieveInstalledLanguagePackVersionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveLicenseInfo Method
[image]

Retrieves the number of licenses for a deployment of Microsoft Dynamics CRM. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim accessMode As Integer
Dim returnValue As TResponse

returnValue = OrganizationServiceContextExtensions.RetrieveLicenseInfo(context, accessMode)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveLicenseInfo(Of TResponse As OrganizationResponse) ( _
    context As OrganizationServiceContext, _
    accessMode As Integer _
) As TResponse
C#
[ExtensionAttribute]
public static TResponse RetrieveLicenseInfo<TResponse> (
    OrganizationServiceContext context,
    int accessMode
) where TResponse : OrganizationResponse
C++

J#

JScript

GenericParameters
TResponse
Parameters
context
The organization service context.
accessMode
Return Value
Returns String.

  Remarks
This is a method wrapper for the RetrieveLicenseInfoRequest and RetrieveLicenseInfoResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveLocLabels Method
[image]

Retrieves the localized labels for the specified attribute. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityMoniker As EntityReference
Dim attributeName As String
Dim includeUnpublished As Boolean
Dim returnValue As Label

returnValue = OrganizationServiceContextExtensions.RetrieveLocLabels(context, entityMoniker, attributeName, includeUnpublished)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveLocLabels ( _
    context As OrganizationServiceContext, _
    entityMoniker As EntityReference, _
    attributeName As String, _
    includeUnpublished As Boolean _
) As Label
C#
[ExtensionAttribute]
public static Label RetrieveLocLabels (
    OrganizationServiceContext context,
    EntityReference entityMoniker,
    string attributeName,
    bool includeUnpublished
)
C++

J#

JScript

Parameters
context
The organization service context.
entityMoniker
attributeName
includeUnpublished
Return Value
Returns Label.

  Remarks
This is a method wrapper for the RetrieveLocLabelsRequest and RetrieveLocLabelsResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveMembersBulkOperation Method
[image]

Retrieves the members of a bulk operation. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim bulkOperationId As Guid
Dim bulkOperationSource As Integer
Dim entitySource As Integer
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveMembersBulkOperation(context, bulkOperationId, bulkOperationSource, entitySource, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveMembersBulkOperation ( _
    context As OrganizationServiceContext, _
    bulkOperationId As Guid, _
    bulkOperationSource As Integer, _
    entitySource As Integer, _
    query As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveMembersBulkOperation (
    OrganizationServiceContext context,
    Guid bulkOperationId,
    int bulkOperationSource,
    int entitySource,
    QueryBase query
)
C++

J#

JScript

Parameters
context
The organization service context.
bulkOperationId
bulkOperationSource
entitySource
query
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveMembersBulkOperationRequest and RetrieveMembersBulkOperationResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveMembersTeam Method
[image]

Deprecated. Retrieves the members of a team. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As Guid
Dim memberColumnSet As ColumnSet
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveMembersTeam(context, entityId, memberColumnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveMembersTeam ( _
    context As OrganizationServiceContext, _
    entityId As Guid, _
    memberColumnSet As ColumnSet _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveMembersTeam (
    OrganizationServiceContext context,
    Guid entityId,
    ColumnSet memberColumnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
memberColumnSet
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveMembersTeamRequest and RetrieveMembersTeamResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveMissingComponents Method
[image]

Retrieves a list of missing components for the target organization. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim customizationFile As Byte()
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveMissingComponents(context, customizationFile)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveMissingComponents(Of TResult) ( _
    context As OrganizationServiceContext, _
    customizationFile As Byte() _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveMissingComponents<TResult> (
    OrganizationServiceContext context,
    byte[] customizationFile
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
customizationFile
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveMissingComponentsRequest and RetrieveMissingComponentsResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveMissingDependencies Method
[image]

Verifies whether any solution components are not included in the solution but possibly should be for a complete solution to be exported. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim solutionUniqueName As String
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveMissingDependencies(context, solutionUniqueName)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveMissingDependencies ( _
    context As OrganizationServiceContext, _
    solutionUniqueName As String _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveMissingDependencies (
    OrganizationServiceContext context,
    string solutionUniqueName
)
C++

J#

JScript

Parameters
context
The organization service context.
solutionUniqueName
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveMissingDependenciesRequest and RetrieveMissingDependenciesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveMultiple Method
[image]

Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query. (Developer Extensions)

Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
OrganizationServiceContextExtensions.RetrieveMultiple (OrganizationServiceContext, RetrieveMultipleRequest) | Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query. (Developer Extensions)
OrganizationServiceContextExtensions.RetrieveMultiple (OrganizationServiceContext, QueryBase) | Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query. (Developer Extensions)

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveMultiple Method (OrganizationServiceContext, RetrieveMultipleRequest)
[image]

Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As OrganizationServiceContext
Dim request As RetrieveMultipleRequest
Dim returnValue As RetrieveMultipleResponse

returnValue = OrganizationServiceContextExtensions.RetrieveMultiple(service, request)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveMultiple ( _
    service As OrganizationServiceContext, _
    request As RetrieveMultipleRequest _
) As RetrieveMultipleResponse
C#
[ExtensionAttribute]
public static RetrieveMultipleResponse RetrieveMultiple (
    OrganizationServiceContext service,
    RetrieveMultipleRequest request
)
C++

J#

JScript

Parameters
service
The organization service context.
request
Return Value
Returns RetrieveMultipleResponse.

  Remarks
This is a method wrapper for the RetrieveMultipleRequest and RetrieveMultipleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveMultiple Method (OrganizationServiceContext, QueryBase)
[image]

Retrieves a collection of records. The query can be specified using a query expression or a FetchXML query. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As OrganizationServiceContext
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveMultiple(service, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveMultiple ( _
    service As OrganizationServiceContext, _
    query As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveMultiple (
    OrganizationServiceContext service,
    QueryBase query
)
C++

J#

JScript

Parameters
service
The organization service context.
query
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveMultipleRequest and RetrieveMultipleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace


OrganizationServiceContextExtensions.RetrieveOrganizationResources Method
[image]

Retrieves the resources used by an organization. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveOrganizationResources(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveOrganizationResources(Of TResult) ( _
    context As OrganizationServiceContext _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveOrganizationResources<TResult> (
    OrganizationServiceContext context
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveOrganizationResourcesRequest and RetrieveOrganizationResourcesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveParentGroupsResourceGroup Method
[image]

Retrieves a collection of the parent resource groups of the specified resource group (scheduling group). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim resourceGroupId As Guid
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveParentGroupsResourceGroup(context, resourceGroupId, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveParentGroupsResourceGroup ( _
    context As OrganizationServiceContext, _
    resourceGroupId As Guid, _
    query As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveParentGroupsResourceGroup (
    OrganizationServiceContext context,
    Guid resourceGroupId,
    QueryBase query
)
C++

J#

JScript

Parameters
context
The organization service context.
resourceGroupId
query
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveParentGroupsResourceGroupRequest and RetrieveParentGroupsResourceGroupResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveParsedDataImportFile Method
[image]

Retrieves the data from the parse table. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim importFileId As Guid
Dim pagingInfo As PagingInfo
Dim returnValue As String()()

returnValue = OrganizationServiceContextExtensions.RetrieveParsedDataImportFile(context, importFileId, pagingInfo)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveParsedDataImportFile ( _
    context As OrganizationServiceContext, _
    importFileId As Guid, _
    pagingInfo As PagingInfo _
) As String()()
C#
[ExtensionAttribute]
public static string[][] RetrieveParsedDataImportFile (
    OrganizationServiceContext context,
    Guid importFileId,
    PagingInfo pagingInfo
)
C++

J#

JScript

Parameters
context
The organization service context.
importFileId
pagingInfo
Return Value
Returns String.

  Remarks
This is a method wrapper for the RetrieveParsedDataImportFileRequest and RetrieveParsedDataImportFileResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrievePrincipalAccess Method
[image]

Retrieves the access rights the specified security principal (user or team) has to a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim principal As EntityReference
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrievePrincipalAccess(context, target, principal)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrievePrincipalAccess(Of TResult) ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    principal As EntityReference _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrievePrincipalAccess<TResult> (
    OrganizationServiceContext context,
    EntityReference target,
    EntityReference principal
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
target
principal
Return Value
Returns String.

  Remarks
This is a method wrapper for the RetrievePrincipalAccessRequest and RetrievePrincipalAccessResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrievePrincipalAttributePrivileges Method
[image]

Retrieves all the secured attribute privileges a user or team has through direct or indirect (through team membership) associations with the FieldSecurityProfile entity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim principal As EntityReference
Dim returnValue As AttributePrivilegeCollection

returnValue = OrganizationServiceContextExtensions.RetrievePrincipalAttributePrivileges(context, principal)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrievePrincipalAttributePrivileges ( _
    context As OrganizationServiceContext, _
    principal As EntityReference _
) As AttributePrivilegeCollection
C#
[ExtensionAttribute]
public static AttributePrivilegeCollection RetrievePrincipalAttributePrivileges (
    OrganizationServiceContext context,
    EntityReference principal
)
C++

J#

JScript

Parameters
context
The organization service context.
principal
Return Value
Returns AttributePrivilegeCollection.

  Remarks
This is a method wrapper for the RetrievePrincipalAttributePrivilegesRequest and RetrievePrincipalAttributePrivilegesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrievePrivilegeSet Method
[image]

Retrieves the set of privileges defined in the system. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrievePrivilegeSet(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrievePrivilegeSet ( _
    context As OrganizationServiceContext _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrievePrivilegeSet (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrievePrivilegeSetRequest and RetrievePrivilegeSetResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveProvisionedLanguagePackVersion Method
[image]

Retrieves the version of the language packs installed on the server. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim language As Integer
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.RetrieveProvisionedLanguagePackVersion(context, language)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveProvisionedLanguagePackVersion ( _
    context As OrganizationServiceContext, _
    language As Integer _
) As String
C#
[ExtensionAttribute]
public static string RetrieveProvisionedLanguagePackVersion (
    OrganizationServiceContext context,
    int language
)
C++

J#

JScript

Parameters
context
The organization service context.
language
Return Value
Returns String.

  Remarks
This is a method wrapper for the RetrieveProvisionedLanguagePackVersionRequest and RetrieveProvisionedLanguagePackVersionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveProvisionedLanguages Method
[image]

Retrieves the list of language packs installed on the server that are enabled. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As Integer()

returnValue = OrganizationServiceContextExtensions.RetrieveProvisionedLanguages(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveProvisionedLanguages ( _
    context As OrganizationServiceContext _
) As Integer()
C#
[ExtensionAttribute]
public static int[] RetrieveProvisionedLanguages (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns Int32.

  Remarks
This is a method wrapper for the RetrieveProvisionedLanguagesRequest and RetrieveProvisionedLanguagesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveRecordChangeHistory Method
[image]

Retrieves all changes to a specific entity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim pagingInfo As PagingInfo
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveRecordChangeHistory(context, target, pagingInfo)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveRecordChangeHistory(Of TResult) ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    pagingInfo As PagingInfo _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveRecordChangeHistory<TResult> (
    OrganizationServiceContext context,
    EntityReference target,
    PagingInfo pagingInfo
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
target
pagingInfo
Return Value
Returns Int32.

  Remarks
This is a method wrapper for the RetrieveRecordChangeHistoryRequest and RetrieveRecordChangeHistoryResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveRequiredComponents Method
[image]

Retrieves all components that this component requires. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim objectId As Guid
Dim componentType As Integer
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveRequiredComponents(context, objectId, componentType)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveRequiredComponents ( _
    context As OrganizationServiceContext, _
    objectId As Guid, _
    componentType As Integer _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveRequiredComponents (
    OrganizationServiceContext context,
    Guid objectId,
    int componentType
)
C++

J#

JScript

Parameters
context
The organization service context.
objectId
componentType
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveRequiredComponentsRequest and RetrieveRequiredComponentsResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveRolePrivilegesRole Method
[image]

Retrieves the privileges that are assigned to the specified role. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim roleId As Guid
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveRolePrivilegesRole(context, roleId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveRolePrivilegesRole(Of TResult) ( _
    context As OrganizationServiceContext, _
    roleId As Guid _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveRolePrivilegesRole<TResult> (
    OrganizationServiceContext context,
    Guid roleId
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
roleId
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveRolePrivilegesRoleRequest and RetrieveRolePrivilegesRoleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveSharedPrincipalsAndAccess Method
[image]

Retrieves all the security principals (users or teams) that have access to a record, together with their access rights to the record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveSharedPrincipalsAndAccess(context, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveSharedPrincipalsAndAccess(Of TResult) ( _
    context As OrganizationServiceContext, _
    target As EntityReference _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveSharedPrincipalsAndAccess<TResult> (
    OrganizationServiceContext context,
    EntityReference target
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
target
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveSharedPrincipalsAndAccessRequest and RetrieveSharedPrincipalsAndAccessResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveSubGroupsResourceGroup Method
[image]

Retrieves a collection of the child resource groups of the specified resource group (scheduling group). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim resourceGroupId As Guid
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveSubGroupsResourceGroup(context, resourceGroupId, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveSubGroupsResourceGroup ( _
    context As OrganizationServiceContext, _
    resourceGroupId As Guid, _
    query As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveSubGroupsResourceGroup (
    OrganizationServiceContext context,
    Guid resourceGroupId,
    QueryBase query
)
C++

J#

JScript

Parameters
context
The organization service context.
resourceGroupId
query
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveSubGroupsResourceGroupRequest and RetrieveSubGroupsResourceGroupResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveSubsidiaryTeamsBusinessUnit Method
[image]

Deprecated. Retrieves all the team information for child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As Guid
Dim columnSet As ColumnSet
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveSubsidiaryTeamsBusinessUnit(context, entityId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveSubsidiaryTeamsBusinessUnit ( _
    context As OrganizationServiceContext, _
    entityId As Guid, _
    columnSet As ColumnSet _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveSubsidiaryTeamsBusinessUnit (
    OrganizationServiceContext context,
    Guid entityId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
columnSet
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveSubsidiaryTeamsBusinessUnitRequest and RetrieveSubsidiaryTeamsBusinessUnitResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveSubsidiaryUsersBusinessUnit Method
[image]

Deprecated. Retrieves all system users for the child business units of the specified business unit. Use RetrieveMultiple. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As Guid
Dim columnSet As ColumnSet
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveSubsidiaryUsersBusinessUnit(context, entityId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveSubsidiaryUsersBusinessUnit ( _
    context As OrganizationServiceContext, _
    entityId As Guid, _
    columnSet As ColumnSet _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveSubsidiaryUsersBusinessUnit (
    OrganizationServiceContext context,
    Guid entityId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
columnSet
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveSubsidiaryUsersBusinessUnitRequest and RetrieveSubsidiaryUsersBusinessUnitResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveTeamPrivileges Method
[image]

Retrieves the privileges for a team. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim teamId As Guid
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveTeamPrivileges(context, teamId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveTeamPrivileges(Of TResult) ( _
    context As OrganizationServiceContext, _
    teamId As Guid _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveTeamPrivileges<TResult> (
    OrganizationServiceContext context,
    Guid teamId
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
teamId
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveTeamPrivilegesRequest and RetrieveTeamPrivilegesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveTeamsSystemUser Method
[image]

Deprecated. Retrieves a collection of teams of which the specified system user is a member. Use RetrieveMultiple. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As Guid
Dim columnSet As ColumnSet
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveTeamsSystemUser(context, entityId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveTeamsSystemUser ( _
    context As OrganizationServiceContext, _
    entityId As Guid, _
    columnSet As ColumnSet _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveTeamsSystemUser (
    OrganizationServiceContext context,
    Guid entityId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
columnSet
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveTeamsSystemUserRequest and RetrieveTeamsSystemUserResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveUnpublished Method
[image]

Retrieves the current saved definition of a Web resource, organization-owned chart, or organization-owned dashboard, whether it has been published or not. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.RetrieveUnpublished(context, target, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveUnpublished ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    columnSet As ColumnSet _
) As Entity
C#
[ExtensionAttribute]
public static Entity RetrieveUnpublished (
    OrganizationServiceContext context,
    EntityReference target,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
target
columnSet
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the RetrieveUnpublishedRequest and RetrieveUnpublishedResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveUnpublishedMultiple Method
[image]

Retrieves the current saved definitions of Web resources, organization-owned charts, or organization-owned dashboards, whether they have been published or not. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.RetrieveUnpublishedMultiple(context, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveUnpublishedMultiple ( _
    context As OrganizationServiceContext, _
    query As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveUnpublishedMultiple (
    OrganizationServiceContext context,
    QueryBase query
)
C++

J#

JScript

Parameters
context
The organization service context.
query
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveUnpublishedMultipleRequest and RetrieveUnpublishedMultipleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveUserPrivileges Method
[image]

Retrieves all the privileges a system user (user) has through his or her roles in the specified business unit. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim userId As Guid
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.RetrieveUserPrivileges(context, userId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveUserPrivileges(Of TResult) ( _
    context As OrganizationServiceContext, _
    userId As Guid _
) As TResult
C#
[ExtensionAttribute]
public static TResult RetrieveUserPrivileges<TResult> (
    OrganizationServiceContext context,
    Guid userId
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
userId
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RetrieveUserPrivilegesRequest and RetrieveUserPrivilegesResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveUserSettingsSystemUser Method
[image]

Deprecated. Retrieves the system user settings for the specified system user. Use RetrieveMultiple. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityId As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.RetrieveUserSettingsSystemUser(context, entityId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveUserSettingsSystemUser ( _
    context As OrganizationServiceContext, _
    entityId As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
[ExtensionAttribute]
public static Entity RetrieveUserSettingsSystemUser (
    OrganizationServiceContext context,
    Guid entityId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
entityId
columnSet
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the RetrieveUserSettingsSystemUserRequest and RetrieveUserSettingsSystemUserResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RetrieveVersion Method
[image]

Retrieves the version number of the Microsoft Dynamics CRM server. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.RetrieveVersion(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveVersion ( _
    context As OrganizationServiceContext _
) As String
C#
[ExtensionAttribute]
public static string RetrieveVersion (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
Return Value
Returns String.

  Remarks
This is a method wrapper for the RetrieveVersionRequest and RetrieveVersionResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ReviseQuote Method
[image]

Sets the state of a quote to Draft. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim quoteId As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = OrganizationServiceContextExtensions.ReviseQuote(context, quoteId, columnSet)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ReviseQuote ( _
    context As OrganizationServiceContext, _
    quoteId As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
[ExtensionAttribute]
public static Entity ReviseQuote (
    OrganizationServiceContext context,
    Guid quoteId,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
context
The organization service context.
quoteId
columnSet
Return Value
Returns Entity.

  Remarks
This is a method wrapper for the ReviseQuoteRequest and ReviseQuoteResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.RevokeAccess Method
[image]

Removes all access to a record for the specified security principal (user or team). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim revokee As EntityReference

OrganizationServiceContextExtensions.RevokeAccess(context, target, revokee)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub RevokeAccess ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    revokee As EntityReference _
)
C#
[ExtensionAttribute]
public static void RevokeAccess (
    OrganizationServiceContext context,
    EntityReference target,
    EntityReference revokee
)
C++

J#

JScript

Parameters
context
The organization service context.
target
revokee
  Remarks
This is a method wrapper for the RevokeAccessRequest and RevokeAccessResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.Rollup Method
[image]

Retrieves all the records related to the specified record (account or contact). This applies to all activity entities, annotation (note), contract, incident (case), invoice, opportunity, quote and sales order (order) entities. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim query As QueryBase
Dim rollupType As Object
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.Rollup(context, target, query, rollupType)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Rollup ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    query As QueryBase, _
    rollupType As Object _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection Rollup (
    OrganizationServiceContext context,
    EntityReference target,
    QueryBase query,
    Object rollupType
)
C++

J#

JScript

Parameters
context
The organization service context.
target
query
rollupType
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the RollupRequest and RollupResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.Search Method
[image]

Searches for available time slots that fulfill the specified appointment request. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim appointmentRequest As Object
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.Search(context, appointmentRequest)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Search(Of TResult) ( _
    context As OrganizationServiceContext, _
    appointmentRequest As Object _
) As TResult
C#
[ExtensionAttribute]
public static TResult Search<TResult> (
    OrganizationServiceContext context,
    Object appointmentRequest
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
appointmentRequest
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the SearchRequest and SearchResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SearchByBodyKbArticle Method
[image]

Finds all the document indexes that contain the specified text in the body. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim searchText As String
Dim subjectId As Guid
Dim useInflection As Boolean
Dim queryExpression As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.SearchByBodyKbArticle(context, searchText, subjectId, useInflection, queryExpression)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function SearchByBodyKbArticle ( _
    context As OrganizationServiceContext, _
    searchText As String, _
    subjectId As Guid, _
    useInflection As Boolean, _
    queryExpression As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection SearchByBodyKbArticle (
    OrganizationServiceContext context,
    string searchText,
    Guid subjectId,
    bool useInflection,
    QueryBase queryExpression
)
C++

J#

JScript

Parameters
context
The organization service context.
searchText
subjectId
useInflection
queryExpression
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the SearchByBodyKbArticleRequest and SearchByBodyKbArticleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SearchByKeywordsKbArticle Method
[image]

Finds all the document indexes that contain the specified keywords. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim searchText As String
Dim subjectId As Guid
Dim useInflection As Boolean
Dim queryExpression As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.SearchByKeywordsKbArticle(context, searchText, subjectId, useInflection, queryExpression)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function SearchByKeywordsKbArticle ( _
    context As OrganizationServiceContext, _
    searchText As String, _
    subjectId As Guid, _
    useInflection As Boolean, _
    queryExpression As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection SearchByKeywordsKbArticle (
    OrganizationServiceContext context,
    string searchText,
    Guid subjectId,
    bool useInflection,
    QueryBase queryExpression
)
C++

J#

JScript

Parameters
context
The organization service context.
searchText
subjectId
useInflection
queryExpression
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the SearchByKeywordsKbArticleRequest and SearchByKeywordsKbArticleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SearchByTitleKbArticle Method
[image]

Finds all the document indexes that contain the specified text in the title. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim searchText As String
Dim subjectId As Guid
Dim useInflection As Boolean
Dim queryExpression As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceContextExtensions.SearchByTitleKbArticle(context, searchText, subjectId, useInflection, queryExpression)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function SearchByTitleKbArticle ( _
    context As OrganizationServiceContext, _
    searchText As String, _
    subjectId As Guid, _
    useInflection As Boolean, _
    queryExpression As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection SearchByTitleKbArticle (
    OrganizationServiceContext context,
    string searchText,
    Guid subjectId,
    bool useInflection,
    QueryBase queryExpression
)
C++

J#

JScript

Parameters
context
The organization service context.
searchText
subjectId
useInflection
queryExpression
Return Value
Returns EntityCollection.

  Remarks
This is a method wrapper for the SearchByTitleKbArticleRequest and SearchByTitleKbArticleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SendBulkMail Method
[image]

Sends bulk email messages. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim sender As EntityReference
Dim templateId As Guid
Dim regardingType As String
Dim regardingId As Guid
Dim query As QueryBase

OrganizationServiceContextExtensions.SendBulkMail(context, sender, templateId, regardingType, regardingId, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SendBulkMail ( _
    context As OrganizationServiceContext, _
    sender As EntityReference, _
    templateId As Guid, _
    regardingType As String, _
    regardingId As Guid, _
    query As QueryBase _
)
C#
[ExtensionAttribute]
public static void SendBulkMail (
    OrganizationServiceContext context,
    EntityReference sender,
    Guid templateId,
    string regardingType,
    Guid regardingId,
    QueryBase query
)
C++

J#

JScript

Parameters
context
The organization service context.
sender
templateId
regardingType
regardingId
query
  Remarks
This is a method wrapper for the SendBulkMailRequest and SendBulkMailResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SendEmail Method
[image]

Sends an email message. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim emailId As Guid
Dim issueSend As Boolean
Dim trackingToken As String
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.SendEmail(context, emailId, issueSend, trackingToken)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function SendEmail ( _
    context As OrganizationServiceContext, _
    emailId As Guid, _
    issueSend As Boolean, _
    trackingToken As String _
) As String
C#
[ExtensionAttribute]
public static string SendEmail (
    OrganizationServiceContext context,
    Guid emailId,
    bool issueSend,
    string trackingToken
)
C++

J#

JScript

Parameters
context
The organization service context.
emailId
issueSend
trackingToken
Return Value
Returns String.

  Remarks
This is a method wrapper for the SendEmailRequest and SendEmailResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SendEmailFromTemplate Method
[image]

Sends an email message using a template. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim templateId As Guid
Dim regardingType As String
Dim regardingId As Guid
Dim target As Entity
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.SendEmailFromTemplate(context, templateId, regardingType, regardingId, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function SendEmailFromTemplate ( _
    context As OrganizationServiceContext, _
    templateId As Guid, _
    regardingType As String, _
    regardingId As Guid, _
    target As Entity _
) As Guid
C#
[ExtensionAttribute]
public static Guid SendEmailFromTemplate (
    OrganizationServiceContext context,
    Guid templateId,
    string regardingType,
    Guid regardingId,
    Entity target
)
C++

J#

JScript

Parameters
context
The organization service context.
templateId
regardingType
regardingId
target
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the SendEmailFromTemplateRequest and SendEmailFromTemplateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SendFax Method
[image]

Sends a fax. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim faxId As Guid
Dim issueSend As Boolean

OrganizationServiceContextExtensions.SendFax(context, faxId, issueSend)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SendFax ( _
    context As OrganizationServiceContext, _
    faxId As Guid, _
    issueSend As Boolean _
)
C#
[ExtensionAttribute]
public static void SendFax (
    OrganizationServiceContext context,
    Guid faxId,
    bool issueSend
)
C++

J#

JScript

Parameters
context
The organization service context.
faxId
issueSend
  Remarks
This is a method wrapper for the SendFaxRequest and SendFaxResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SendTemplate Method
[image]

Sends a bulk email message that is created from a template. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim templateId As Guid
Dim sender As EntityReference
Dim recipientType As String
Dim recipientIds As Guid()
Dim regardingType As String
Dim regardingId As Guid

OrganizationServiceContextExtensions.SendTemplate(context, templateId, sender, recipientType, recipientIds, regardingType, regardingId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SendTemplate ( _
    context As OrganizationServiceContext, _
    templateId As Guid, _
    sender As EntityReference, _
    recipientType As String, _
    recipientIds As Guid(), _
    regardingType As String, _
    regardingId As Guid _
)
C#
[ExtensionAttribute]
public static void SendTemplate (
    OrganizationServiceContext context,
    Guid templateId,
    EntityReference sender,
    string recipientType,
    Guid[] recipientIds,
    string regardingType,
    Guid regardingId
)
C++

J#

JScript

Parameters
context
The organization service context.
templateId
sender
recipientType
recipientIds
regardingType
regardingId
  Remarks
This is a method wrapper for the SendTemplateRequest and SendTemplateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetBusinessEquipment Method
[image]

Sets the business that owns the equipment. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim equipmentId As Guid
Dim businessUnitId As Guid

OrganizationServiceContextExtensions.SetBusinessEquipment(context, equipmentId, businessUnitId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetBusinessEquipment ( _
    context As OrganizationServiceContext, _
    equipmentId As Guid, _
    businessUnitId As Guid _
)
C#
[ExtensionAttribute]
public static void SetBusinessEquipment (
    OrganizationServiceContext context,
    Guid equipmentId,
    Guid businessUnitId
)
C++

J#

JScript

Parameters
context
The organization service context.
equipmentId
businessUnitId
  Remarks
This is a method wrapper for the SetBusinessEquipmentRequest and SetBusinessEquipmentResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetBusinessSystemUser Method
[image]

Sets the business unit for the specified system user. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim userId As Guid
Dim businessId As Guid
Dim reassignPrincipal As EntityReference

OrganizationServiceContextExtensions.SetBusinessSystemUser(context, userId, businessId, reassignPrincipal)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetBusinessSystemUser ( _
    context As OrganizationServiceContext, _
    userId As Guid, _
    businessId As Guid, _
    reassignPrincipal As EntityReference _
)
C#
[ExtensionAttribute]
public static void SetBusinessSystemUser (
    OrganizationServiceContext context,
    Guid userId,
    Guid businessId,
    EntityReference reassignPrincipal
)
C++

J#

JScript

Parameters
context
The organization service context.
userId
businessId
reassignPrincipal
  Remarks
This is a method wrapper for the SetBusinessSystemUserRequest and SetBusinessSystemUserResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetLocLabels Method
[image]

Sets the localized labels for the specified attribute. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityMoniker As EntityReference
Dim attributeName As String
Dim labels As LocalizedLabel()

OrganizationServiceContextExtensions.SetLocLabels(context, entityMoniker, attributeName, labels)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetLocLabels ( _
    context As OrganizationServiceContext, _
    entityMoniker As EntityReference, _
    attributeName As String, _
    labels As LocalizedLabel() _
)
C#
[ExtensionAttribute]
public static void SetLocLabels (
    OrganizationServiceContext context,
    EntityReference entityMoniker,
    string attributeName,
    LocalizedLabel[] labels
)
C++

J#

JScript

Parameters
context
The organization service context.
entityMoniker
attributeName
labels
  Remarks
This is a method wrapper for the SetLocLabelsRequest and SetLocLabelsResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetParentBusinessUnit Method
[image]

Sets the parent (manager) for the specified business unit. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim businessUnitId As Guid
Dim parentId As Guid

OrganizationServiceContextExtensions.SetParentBusinessUnit(context, businessUnitId, parentId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetParentBusinessUnit ( _
    context As OrganizationServiceContext, _
    businessUnitId As Guid, _
    parentId As Guid _
)
C#
[ExtensionAttribute]
public static void SetParentBusinessUnit (
    OrganizationServiceContext context,
    Guid businessUnitId,
    Guid parentId
)
C++

J#

JScript

Parameters
context
The organization service context.
businessUnitId
parentId
  Remarks
This is a method wrapper for the SetParentBusinessUnitRequest and SetParentBusinessUnitResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetParentSystemUser Method
[image]

Sets the parent (manager) for the specified system user. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim userId As Guid
Dim parentId As Guid
Dim keepChildUsers As Boolean

OrganizationServiceContextExtensions.SetParentSystemUser(context, userId, parentId, keepChildUsers)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetParentSystemUser ( _
    context As OrganizationServiceContext, _
    userId As Guid, _
    parentId As Guid, _
    keepChildUsers As Boolean _
)
C#
[ExtensionAttribute]
public static void SetParentSystemUser (
    OrganizationServiceContext context,
    Guid userId,
    Guid parentId,
    bool keepChildUsers
)
C++

J#

JScript

Parameters
context
The organization service context.
userId
parentId
keepChildUsers
  Remarks
This is a method wrapper for the SetParentSystemUserRequest and SetParentSystemUserResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetParentTeam Method
[image]

Sets the parent (manager) for the specified team. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim teamId As Guid
Dim businessId As Guid

OrganizationServiceContextExtensions.SetParentTeam(context, teamId, businessId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetParentTeam ( _
    context As OrganizationServiceContext, _
    teamId As Guid, _
    businessId As Guid _
)
C#
[ExtensionAttribute]
public static void SetParentTeam (
    OrganizationServiceContext context,
    Guid teamId,
    Guid businessId
)
C++

J#

JScript

Parameters
context
The organization service context.
teamId
businessId
  Remarks
This is a method wrapper for the SetParentTeamRequest and SetParentTeamResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetRelated Method
[image]

Deprecated. Creates a link between an opportunity and an account, contact, or competitor. Use Associate. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference()

OrganizationServiceContextExtensions.SetRelated(context, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetRelated ( _
    context As OrganizationServiceContext, _
    target As EntityReference() _
)
C#
[ExtensionAttribute]
public static void SetRelated (
    OrganizationServiceContext context,
    EntityReference[] target
)
C++

J#

JScript

Parameters
context
The organization service context.
target
  Remarks
This is a method wrapper for the SetRelatedRequest and SetRelatedResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetReportRelated Method
[image]

Specifies in which areas of Microsoft Dynamics CRM the report can be run and viewed. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim reportId As Guid
Dim entities As Integer()
Dim categories As Integer()
Dim visibility As Integer()

OrganizationServiceContextExtensions.SetReportRelated(context, reportId, entities, categories, visibility)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetReportRelated ( _
    context As OrganizationServiceContext, _
    reportId As Guid, _
    entities As Integer(), _
    categories As Integer(), _
    visibility As Integer() _
)
C#
[ExtensionAttribute]
public static void SetReportRelated (
    OrganizationServiceContext context,
    Guid reportId,
    int[] entities,
    int[] categories,
    int[] visibility
)
C++

J#

JScript

Parameters
context
The organization service context.
reportId
entities
categories
visibility
  Remarks
This is a method wrapper for the SetReportRelatedRequest and SetReportRelatedResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetState Method
[image]

Sets the state of a record. (Developer Extensions)Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
OrganizationServiceContextExtensions.SetState (OrganizationServiceContext, EntityReference, OptionSetValue, OptionSetValue) | Sets the state of a record. (Developer Extensions)
OrganizationServiceContextExtensions.SetState (OrganizationServiceContext, Int32, Int32, Entity) | Sets the state of a record. (Developer Extensions)
OrganizationServiceContextExtensions.SetState (OrganizationServiceContext, Int32, Int32, EntityReference) | Sets the state of a record. (Developer Extensions)

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetState Method (OrganizationServiceContext, EntityReference, OptionSetValue, OptionSetValue)
[image]

Sets the state of a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entityMoniker As EntityReference
Dim state As OptionSetValue
Dim status As OptionSetValue

OrganizationServiceContextExtensions.SetState(context, entityMoniker, state, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetState ( _
    context As OrganizationServiceContext, _
    entityMoniker As EntityReference, _
    state As OptionSetValue, _
    status As OptionSetValue _
)
C#
[ExtensionAttribute]
public static void SetState (
    OrganizationServiceContext context,
    EntityReference entityMoniker,
    OptionSetValue state,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
entityMoniker
state
status
  Remarks
This is a method wrapper for the SetStateRequest and SetStateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.SetState Method (OrganizationServiceContext, Int32, Int32, Entity)
[image]

Sets the state of a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As OrganizationServiceContext
Dim state As Integer
Dim status As Integer
Dim entity As Entity

OrganizationServiceContextExtensions.SetState(service, state, status, entity)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetState ( _
    service As OrganizationServiceContext, _
    state As Integer, _
    status As Integer, _
    entity As Entity _
)
C#
[ExtensionAttribute]
public static void SetState (
    OrganizationServiceContext service,
    int state,
    int status,
    Entity entity
)
C++

J#

JScript

Parameters
service
The organization service context.
state
status
entity
  Remarks
This is a method wrapper for the SetStateRequest and SetStateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace


OrganizationServiceContextExtensions.SetState Method (OrganizationServiceContext, Int32, Int32, EntityReference)
[image]

Sets the state of a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim state As Integer
Dim status As Integer
Dim entityMoniker As EntityReference

OrganizationServiceContextExtensions.SetState(context, state, status, entityMoniker)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetState ( _
    context As OrganizationServiceContext, _
    state As Integer, _
    status As Integer, _
    entityMoniker As EntityReference _
)
C#
[ExtensionAttribute]
public static void SetState (
    OrganizationServiceContext context,
    int state,
    int status,
    EntityReference entityMoniker
)
C++

J#

JScript

Parameters
context
The organization service context.
state
status
entityMoniker
  Remarks
This is a method wrapper for the SetStateRequest and SetStateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace


OrganizationServiceContextExtensions.StatusUpdateBulkOperation Method
[image]

For internal use only. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim bulkOperationId As Guid
Dim failureCount As Integer
Dim successCount As Integer

OrganizationServiceContextExtensions.StatusUpdateBulkOperation(context, bulkOperationId, failureCount, successCount)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub StatusUpdateBulkOperation ( _
    context As OrganizationServiceContext, _
    bulkOperationId As Guid, _
    failureCount As Integer, _
    successCount As Integer _
)
C#
[ExtensionAttribute]
public static void StatusUpdateBulkOperation (
    OrganizationServiceContext context,
    Guid bulkOperationId,
    int failureCount,
    int successCount
)
C++

J#

JScript

Parameters
context
The organization service context.
bulkOperationId
failureCount
successCount
  Remarks
This is a method wrapper for the StatusUpdateBulkOperationRequest and StatusUpdateBulkOperationResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.TransformImport Method
[image]

Submits an asynchronous job to transform the parsed data. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim importId As Guid
Dim returnValue As Guid

returnValue = OrganizationServiceContextExtensions.TransformImport(context, importId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function TransformImport ( _
    context As OrganizationServiceContext, _
    importId As Guid _
) As Guid
C#
[ExtensionAttribute]
public static Guid TransformImport (
    OrganizationServiceContext context,
    Guid importId
)
C++

J#

JScript

Parameters
context
The organization service context.
importId
Return Value
Returns Guid.

  Remarks
This is a method wrapper for the TransformImportRequest and TransformImportResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.TriggerServiceEndpointCheck Method
[image]

Validates the configuration of a Windows Azure platform AppFabric solution’s service endpoint. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As EntityReference

OrganizationServiceContextExtensions.TriggerServiceEndpointCheck(context, entity)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub TriggerServiceEndpointCheck ( _
    context As OrganizationServiceContext, _
    entity As EntityReference _
)
C#
[ExtensionAttribute]
public static void TriggerServiceEndpointCheck (
    OrganizationServiceContext context,
    EntityReference entity
)
C++

J#

JScript

Parameters
context
The organization service context.
entity
  Remarks
This is a method wrapper for the TriggerServiceEndpointCheckRequest and TriggerServiceEndpointCheckResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.UninstallSampleData Method
[image]

Uninstalls sample data for an organization. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext

OrganizationServiceContextExtensions.UninstallSampleData(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub UninstallSampleData ( _
    context As OrganizationServiceContext _
)
C#
[ExtensionAttribute]
public static void UninstallSampleData (
    OrganizationServiceContext context
)
C++

J#

JScript

Parameters
context
The organization service context.
  Remarks
This is a method wrapper for the UnInstallSampleDataRequest and UnInstallSampleDataResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.UnlockInvoicePricing Method
[image]

Unlocks the price per unit for the products in the specified invoice. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim invoiceId As Guid

OrganizationServiceContextExtensions.UnlockInvoicePricing(context, invoiceId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub UnlockInvoicePricing ( _
    context As OrganizationServiceContext, _
    invoiceId As Guid _
)
C#
[ExtensionAttribute]
public static void UnlockInvoicePricing (
    OrganizationServiceContext context,
    Guid invoiceId
)
C++

J#

JScript

Parameters
context
The organization service context.
invoiceId
  Remarks
This is a method wrapper for the UnlockInvoicePricingRequest and UnlockInvoicePricingResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.UnlockSalesOrderPricing Method
[image]

Unlocks the price per unit for the products in the specified sales order (order). (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim salesOrderId As Guid

OrganizationServiceContextExtensions.UnlockSalesOrderPricing(context, salesOrderId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub UnlockSalesOrderPricing ( _
    context As OrganizationServiceContext, _
    salesOrderId As Guid _
)
C#
[ExtensionAttribute]
public static void UnlockSalesOrderPricing (
    OrganizationServiceContext context,
    Guid salesOrderId
)
C++

J#

JScript

Parameters
context
The organization service context.
salesOrderId
  Remarks
This is a method wrapper for the UnlockSalesOrderPricingRequest and UnlockSalesOrderPricingResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.UnpublishDuplicateRule Method
[image]

Unpublishes a duplicate rule. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim duplicateRuleId As Guid

OrganizationServiceContextExtensions.UnpublishDuplicateRule(context, duplicateRuleId)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub UnpublishDuplicateRule ( _
    context As OrganizationServiceContext, _
    duplicateRuleId As Guid _
)
C#
[ExtensionAttribute]
public static void UnpublishDuplicateRule (
    OrganizationServiceContext context,
    Guid duplicateRuleId
)
C++

J#

JScript

Parameters
context
The organization service context.
duplicateRuleId
  Remarks
This is a method wrapper for the UnpublishDuplicateRuleRequest and UnpublishDuplicateRuleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.UpdateUserSettingsSystemUser Method
[image]

Deprecated. Updates the user settings for a system user. Use Update. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim userId As Guid
Dim settings As Entity

OrganizationServiceContextExtensions.UpdateUserSettingsSystemUser(context, userId, settings)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub UpdateUserSettingsSystemUser ( _
    context As OrganizationServiceContext, _
    userId As Guid, _
    settings As Entity _
)
C#
[ExtensionAttribute]
public static void UpdateUserSettingsSystemUser (
    OrganizationServiceContext context,
    Guid userId,
    Entity settings
)
C++

J#

JScript

Parameters
context
The organization service context.
userId
settings
  Remarks
This is a method wrapper for the UpdateUserSettingsSystemUserRequest and UpdateUserSettingsSystemUserResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.UtcTimeFromLocalTime Method
[image]

Retrieves the UTC time for the specified local time. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim timeZoneCode As Integer
Dim localTime As DateTime
Dim returnValue As DateTime

returnValue = OrganizationServiceContextExtensions.UtcTimeFromLocalTime(context, timeZoneCode, localTime)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function UtcTimeFromLocalTime ( _
    context As OrganizationServiceContext, _
    timeZoneCode As Integer, _
    localTime As DateTime _
) As DateTime
C#
[ExtensionAttribute]
public static DateTime UtcTimeFromLocalTime (
    OrganizationServiceContext context,
    int timeZoneCode,
    DateTime localTime
)
C++

J#

JScript

Parameters
context
The organization service context.
timeZoneCode
localTime
Return Value
Returns DateTime.

  Remarks
This is a method wrapper for the UtcTimeFromLocalTimeRequest and UtcTimeFromLocalTimeResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.Validate Method
[image]

Validates that all the constraints of an appointment or service appointment are met. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim activities As EntityCollection
Dim returnValue As TResult

returnValue = OrganizationServiceContextExtensions.Validate(context, activities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Validate(Of TResult) ( _
    context As OrganizationServiceContext, _
    activities As EntityCollection _
) As TResult
C#
[ExtensionAttribute]
public static TResult Validate<TResult> (
    OrganizationServiceContext context,
    EntityCollection activities
)
C++

J#

JScript

GenericParameters
TResult
Parameters
context
The organization service context.
activities
Return Value
Returns DateTime.

  Remarks
This is a method wrapper for the ValidateRequest and ValidateResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ValidateRecurrenceRule Method
[image]

Validates a recurrence rule for a recurring appointment. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As Entity
Dim returnValue As String

returnValue = OrganizationServiceContextExtensions.ValidateRecurrenceRule(context, target)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ValidateRecurrenceRule ( _
    context As OrganizationServiceContext, _
    target As Entity _
) As String
C#
[ExtensionAttribute]
public static string ValidateRecurrenceRule (
    OrganizationServiceContext context,
    Entity target
)
C++

J#

JScript

Parameters
context
The organization service context.
target
Return Value
Returns String.

  Remarks
This is a method wrapper for the ValidateRecurrenceRuleRequest and ValidateRecurrenceRuleResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.ValidateSavedQuery Method
[image]

Validates a saved query. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim fetchXml As String
Dim queryType As Integer

OrganizationServiceContextExtensions.ValidateSavedQuery(context, fetchXml, queryType)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub ValidateSavedQuery ( _
    context As OrganizationServiceContext, _
    fetchXml As String, _
    queryType As Integer _
)
C#
[ExtensionAttribute]
public static void ValidateSavedQuery (
    OrganizationServiceContext context,
    string fetchXml,
    int queryType
)
C++

J#

JScript

Parameters
context
The organization service context.
fetchXml
queryType
  Remarks
This is a method wrapper for the ValidateSavedQueryRequest and ValidateSavedQueryResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.VerifyProcessStateData Method
[image]

For internal use only. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim target As EntityReference
Dim processState As String
Dim returnValue As Boolean

returnValue = OrganizationServiceContextExtensions.VerifyProcessStateData(context, target, processState)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function VerifyProcessStateData ( _
    context As OrganizationServiceContext, _
    target As EntityReference, _
    processState As String _
) As Boolean
C#
[ExtensionAttribute]
public static bool VerifyProcessStateData (
    OrganizationServiceContext context,
    EntityReference target,
    string processState
)
C++

J#

JScript

Parameters
context
The organization service context.
target
processState
Return Value
Returns Boolean.

  Remarks
This is a method wrapper for the VerifyProcessStateDataRequest and VerifyProcessStateDataResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.WhoAmI Method
[image]

Retrieves the user information for the logged on user. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim returnValue As TResponse

returnValue = OrganizationServiceContextExtensions.WhoAmI(context)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function WhoAmI(Of TResponse As OrganizationResponse) ( _
    context As OrganizationServiceContext _
) As TResponse
C#
[ExtensionAttribute]
public static TResponse WhoAmI<TResponse> (
    OrganizationServiceContext context
) where TResponse : OrganizationResponse
C++

J#

JScript

GenericParameters
TResponse
Parameters
context
The organization service context.
Return Value
Returns Boolean.

  Remarks
This is a method wrapper for the WhoAmIRequest and WhoAmIResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.WinOpportunity Method
[image]

Changes the state of an opportunity to Won. (Developer Extensions)Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
OrganizationServiceContextExtensions.WinOpportunity (OrganizationServiceContext, Entity, OptionSetValue) | Changes the state of an opportunity to Won. (Developer Extensions)
OrganizationServiceContextExtensions.WinOpportunity (OrganizationServiceContext, Entity, Int32) | Changes the state of an opportunity to Won. (Developer Extensions)

See Also

Reference

OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.WinOpportunity Method (OrganizationServiceContext, Entity, OptionSetValue)
[image]

Changes the state of an opportunity to Won. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityClose As Entity
Dim status As OptionSetValue

OrganizationServiceContextExtensions.WinOpportunity(context, opportunityClose, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub WinOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityClose As Entity, _
    status As OptionSetValue _
)
C#
[ExtensionAttribute]
public static void WinOpportunity (
    OrganizationServiceContext context,
    Entity opportunityClose,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityClose
status
  Remarks
This is a method wrapper for the WinOpportunityRequest and WinOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextExtensions.WinOpportunity Method (OrganizationServiceContext, Entity, Int32)
[image]

Changes the state of an opportunity to Won. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim opportunityClose As Entity
Dim status As Integer

OrganizationServiceContextExtensions.WinOpportunity(context, opportunityClose, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub WinOpportunity ( _
    context As OrganizationServiceContext, _
    opportunityClose As Entity, _
    status As Integer _
)
C#
[ExtensionAttribute]
public static void WinOpportunity (
    OrganizationServiceContext context,
    Entity opportunityClose,
    int status
)
C++

J#

JScript

Parameters
context
The organization service context.
opportunityClose
status
  Remarks
This is a method wrapper for the WinOpportunityRequest and WinOpportunityResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace


OrganizationServiceContextExtensions.WinQuote Method
[image]

Changes the state of a quote to Won. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim quoteClose As Entity
Dim status As OptionSetValue

OrganizationServiceContextExtensions.WinQuote(context, quoteClose, status)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Sub WinQuote ( _
    context As OrganizationServiceContext, _
    quoteClose As Entity, _
    status As OptionSetValue _
)
C#
[ExtensionAttribute]
public static void WinQuote (
    OrganizationServiceContext context,
    Entity quoteClose,
    OptionSetValue status
)
C++

J#

JScript

Parameters
context
The organization service context.
quoteClose
status
  Remarks
This is a method wrapper for the WinQuoteRequest and WinQuoteResponse classes. See the documentation in the Request class for more information about this message.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextExtensions Class
OrganizationServiceContextExtensions Members
Microsoft.Xrm.Client.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


Microsoft.Xrm.Client.Metadata Namespace

Classes

Class | Description
AttributeInfo | Provides additional information about an attribute. (Developer Extensions)
EntityAttribute | (Developer Extensions)
EntityInfo | Provides information about an entity. (Developer Extensions)
EntitySetInfo | Provides information about an entity set. (Developer Extensions)
OrganizationServiceContextInfo | Provides information about the organization service context. (Developer Extensions)
RelationshipInfo | Provides information about a relationship. (Developer Extensions)


AttributeInfo Class
See Also Members
[image]

Provides additional information about an attribute. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As AttributeInfo

Syntax

Visual Basic
Public NotInheritable Class AttributeInfo
C#
public sealed class AttributeInfo
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Metadata.AttributeInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


AttributeInfo Members
See Also Constructors Methods Properties
[image]

Provides additional information about an attribute. (Developer Extensions)

The following tables list the members exposed by the AttributeInfo type.

Public Constructors

Name | Description
AttributeInfo | Creates an instance of the AttributeInfo class.
Top

Public Properties

 | Name | Description
public property | CrmPropertyAttribute | Gets the logical name annotation of the attribute property.
public property | Property | Gets the PropertyInfo reflection object for the attribute property.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | GetValue | Retrieves the value of the property for an entity instance.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

AttributeInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


AttributeInfo Constructor
[image]

Creates an instance of the AttributeInfo class.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim property As PropertyInfo
Dim crmPropertyAttribute As AttributeLogicalNameAttribute

Dim instance As New AttributeInfo(property, crmPropertyAttribute)

Syntax

Visual Basic
Public Sub New ( _
    property As PropertyInfo, _
    crmPropertyAttribute As AttributeLogicalNameAttribute _
)
C#
public AttributeInfo (
    PropertyInfo property,
    AttributeLogicalNameAttribute crmPropertyAttribute
)
C++

J#

JScript

Parameters
property
Type: PropertyInfo. The property.
crmPropertyAttribute
Type: AttributeLogicalNameAttribute. The property attribute.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeInfo Class
AttributeInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


AttributeInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | GetValue | Retrieves the value of the property for an entity instance.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

AttributeInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


AttributeInfo.GetValue Method
[image]

Retrieves the value of the property for an entity instance.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As AttributeInfo
Dim entity As Object
Dim returnValue As Object

returnValue = instance.GetValue(entity)

Syntax

Visual Basic
Public Function GetValue ( _
    entity As Object _
) As Object
C#
public Object GetValue (
    Object entity
)
C++

J#

JScript

Parameters
entity
Type: Object. The entity instance (Entity).
Return Value
Type: Object

The value of the property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeInfo Class
AttributeInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


AttributeInfo Properties
[image]

Public Properties

 | Name | Description
public property | CrmPropertyAttribute | Gets the logical name annotation of the attribute property.
public property | Property | Gets the PropertyInfo reflection object for the attribute property.

See Also

Reference

AttributeInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


AttributeInfo.CrmPropertyAttribute Property
[image]

Gets the logical name annotation of the attribute property.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As AttributeInfo
Dim value As AttributeLogicalNameAttribute

value = instance.CrmPropertyAttribute

Syntax

Visual Basic
Public Property CrmPropertyAttribute As AttributeLogicalNameAttribute
C#
public AttributeLogicalNameAttribute CrmPropertyAttribute { get; }
C++

J#

JScript

Property Value
Type: AttributeLogicalNameAttribute

The logical name annotation of the attribute property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeInfo Class
AttributeInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


AttributeInfo.Property Property
[image]

Gets the PropertyInfo reflection object for the attribute property.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As AttributeInfo
Dim value As PropertyInfo

value = instance.Property

Syntax

Visual Basic
Public Property Property As PropertyInfo
C#
public PropertyInfo Property { get; }
C++

J#

JScript

Property Value
Type:

The reflection object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AttributeInfo Class
AttributeInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityAttribute Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityAttribute

Syntax

Visual Basic
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct)> _
Public NotInheritable Class EntityAttribute
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct)]
public sealed class EntityAttribute : Attribute
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Attribute
    Microsoft.Xrm.Client.Metadata.EntityAttribute
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityAttribute Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

(Developer Extensions)

The following tables list the members exposed by the EntityAttribute type.

Public Constructors

Name | Description
EntityAttribute | Creates an instance of the EntityAttribute class.
Top

Public Properties

 | Name | Description
public property | EntitySetName | Gets or sets the plural name of the static entity.
public property | TypeId | (inherited from Attribute)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)
Top

See Also

Reference

EntityAttribute Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityAttribute Constructor
[image]

Creates an instance of the EntityAttribute class.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entitySetName As String

Dim instance As New EntityAttribute(entitySetName)

Syntax

Visual Basic
Public Sub New ( _
    entitySetName As String _
)
C#
public EntityAttribute (
    string entitySetName
)
C++

J#

JScript

Parameters
entitySetName
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityAttribute Class
EntityAttribute Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityAttribute Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsDefaultAttribute | (inherited from Attribute)
public method | Match | (inherited from Attribute)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
GetIDsOfNames | (inherited from Attribute)
GetTypeInfo | (inherited from Attribute)
GetTypeInfoCount | (inherited from Attribute)
Invoke | (inherited from Attribute)

See Also

Reference

EntityAttribute Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityAttribute Properties
[image]

Public Properties

 | Name | Description
public property | EntitySetName | Gets or sets the plural name of the static entity.
public property | TypeId | (inherited from Attribute)

See Also

Reference

EntityAttribute Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityAttribute.EntitySetName Property
[image]

Gets or sets the plural name of the static entity.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityAttribute
Dim value As String

value = instance.EntitySetName

instance.EntitySetName = value

Syntax

Visual Basic
Public Property EntitySetName As String
C#
public string EntitySetName { get; set; }
C++

J#

JScript

Property Value
Type: String
The plural name of the static entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityAttribute Class
EntityAttribute Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo Class
See Also Members
[image]

Provides information about an entity. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityInfo

Syntax

Visual Basic
Public NotInheritable Class EntityInfo
C#
public sealed class EntityInfo
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Metadata.EntityInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo Members
See Also Constructors Methods Properties
[image]

Provides information about an entity. (Developer Extensions)

The following tables list the members exposed by the EntityInfo type.

Public Constructors

Name | Description
EntityInfo | Creates an instance of the EntityInfo class.
Top

Public Properties

 | Name | Description
public property | AttributesByLogicalName | Gets the AttributeInfo keyed by the attribute logical name.
public property | AttributesByPropertyName | Gets the AttributeInfo keyed by the attribute property name.
public property | Entity | Gets the entity set annotation of the Entity.
public property | EntityLogicalName | Gets the logical name annotation of the Entity.
public property | EntityType | Gets the type of the Entity.
public property | PrimaryKeyProperty | Gets the AttributeInfo of the primary key property.
public property | RelationshipsByPropertyName | Gets the RelationshipInfo keyed by the relationship property name.
public property | RelationshipsBySchemaName | Gets the RelationshipInfo keyed by the relationship schema name.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

EntityInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityInfo Constructor
[image]

Creates an instance of the EntityInfo class.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entityType As Type

Dim instance As New EntityInfo(entityType)

Syntax

Visual Basic
Public Sub New ( _
    entityType As Type _
)
C#
public EntityInfo (
    Type entityType
)
C++

J#

JScript

Parameters
entityType
Type: Type. The entity type.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Class
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

EntityInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityInfo Properties
[image]

Public Properties

 | Name | Description
public property | AttributesByLogicalName | Gets the AttributeInfo keyed by the attribute logical name.
public property | AttributesByPropertyName | Gets the AttributeInfo keyed by the attribute property name.
public property | Entity | Gets the entity set annotation of the Entity.
public property | EntityLogicalName | Gets the logical name annotation of the Entity.
public property | EntityType | Gets the type of the Entity.
public property | PrimaryKeyProperty | Gets the AttributeInfo of the primary key property.
public property | RelationshipsByPropertyName | Gets the RelationshipInfo keyed by the relationship property name.
public property | RelationshipsBySchemaName | Gets the RelationshipInfo keyed by the relationship schema name.

See Also

Reference

EntityInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntityInfo.AttributesByLogicalName Property
[image]

Gets the AttributeInfo keyed by the attribute logical name.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityInfo
Dim value As IDictionary(Of String, AttributeInfo)

value = instance.AttributesByLogicalName

Syntax

Visual Basic
Public ReadOnly Property AttributesByLogicalName As IDictionary(Of String, AttributeInfo)
C#
public IDictionary<string,AttributeInfo> AttributesByLogicalName { get; }
C++

J#

JScript

Property Value
Type: IDictionary<String>
The dictionary of attributes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Class
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
AttributeInfo
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo.AttributesByPropertyName Property
[image]

Gets the AttributeInfo keyed by the attribute property name.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityInfo
Dim value As IDictionary(Of String, AttributeInfo)

value = instance.AttributesByPropertyName

Syntax

Visual Basic
Public ReadOnly Property AttributesByPropertyName As IDictionary(Of String, AttributeInfo)
C#
public IDictionary<string,AttributeInfo> AttributesByPropertyName { get; }
C++

J#

JScript

Property Value
Type: IDictionary<String, AttributeInfo>
The dictionary of attributes.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Class
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
AttributeInfo
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo.Entity Property
[image]

Gets the entity set annotation of the Entity.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityInfo
Dim value As EntityAttribute

value = instance.Entity

Syntax

Visual Basic
Public Property Entity As EntityAttribute
C#
public EntityAttribute Entity { get; }
C++

J#

JScript

Property Value
Type: EntityAttribute
The entity in attribute form.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Class
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Entity
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo.EntityLogicalName Property
[image]

Gets the logical name annotation of the Entity.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityInfo
Dim value As EntityLogicalNameAttribute

value = instance.EntityLogicalName

Syntax

Visual Basic
Public Property EntityLogicalName As EntityLogicalNameAttribute
C#
public EntityLogicalNameAttribute EntityLogicalName { get; }
C++

J#

JScript

Property Value
Type: EntityLogicalNameAttribute
The entity in logical name form.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Class
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Entity
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo.EntityType Property
[image]

Gets the type of the Entity.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityInfo
Dim value As Type

value = instance.EntityType

Syntax

Visual Basic
Public Property EntityType As Type
C#
public Type EntityType { get; }
C++

J#

JScript

Property Value
Type: Type
The type of the entity.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Class
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Entity
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo.PrimaryKeyProperty Property
[image]

Gets the AttributeInfo of the primary key property.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityInfo
Dim value As AttributeInfo

value = instance.PrimaryKeyProperty

Syntax

Visual Basic
Public ReadOnly Property PrimaryKeyProperty As AttributeInfo
C#
public AttributeInfo PrimaryKeyProperty { get; }
C++

J#

JScript

Property Value
Type: AttributeInfo
The attribute info for the primary key.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Class
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
AttributeInfo
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo.RelationshipsByPropertyName Property
[image]

Gets the RelationshipInfo keyed by the relationship property name.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityInfo
Dim value As IDictionary(Of String, RelationshipInfo)

value = instance.RelationshipsByPropertyName

Syntax

Visual Basic
Public ReadOnly Property RelationshipsByPropertyName As IDictionary(Of String, RelationshipInfo)
C#
public IDictionary<string,RelationshipInfo> RelationshipsByPropertyName { get; }
C++

J#

JScript

Property Value
Type: IDictionary<String, RelationshipInfo>
The dictionary of relationship info.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Class
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
RelationshipInfo
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntityInfo.RelationshipsBySchemaName Property
[image]

Gets the RelationshipInfo keyed by the relationship schema name.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntityInfo
Dim value As IDictionary(Of Relationship, RelationshipInfo)

value = instance.RelationshipsBySchemaName

Syntax

Visual Basic
Public ReadOnly Property RelationshipsBySchemaName As IDictionary(Of Relationship, RelationshipInfo)
C#
public IDictionary<Relationship,RelationshipInfo> RelationshipsBySchemaName { get; }
C++

J#

JScript

Property Value
Type: IDictionary<Relationship, RelationshipInfo>
The dictionary of relationship info.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntityInfo Class
EntityInfo Members
Microsoft.Xrm.Client.Metadata Namespace
RelationshipInfo
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntitySetInfo Class
See Also Members
[image]

Provides information about an entity set. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntitySetInfo

Syntax

Visual Basic
Public NotInheritable Class EntitySetInfo
C#
public sealed class EntitySetInfo
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Metadata.EntitySetInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntitySetInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntitySetInfo Members
See Also Constructors Methods Properties
[image]

Provides information about an entity set. (Developer Extensions)

The following tables list the members exposed by the EntitySetInfo type.

Public Constructors

Name | Description
EntitySetInfo | Creates an EntitySetInfo class.
Top

Public Properties

 | Name | Description
public property | Entity | Gets the EntityInfo reflection object for the corresponding entity type.
public property | Property | Gets the PropertyInfo reflection object for the entity set property.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

EntitySetInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntitySetInfo Constructor
[image]

Creates an EntitySetInfo class.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim property As PropertyInfo
Dim entity As EntityInfo

Dim instance As New EntitySetInfo(property, entity)

Syntax

Visual Basic
Public Sub New ( _
    property As PropertyInfo, _
    entity As EntityInfo _
)
C#
public EntitySetInfo (
    PropertyInfo property,
    EntityInfo entity
)
C++

J#

JScript

Parameters
property
Type: . The property info.
entity
Type: EntityInfo. The entity info.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntitySetInfo Class
EntitySetInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntitySetInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

EntitySetInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntitySetInfo Properties
[image]

Public Properties

 | Name | Description
public property | Entity | Gets the EntityInfo reflection object for the corresponding entity type.
public property | Property | Gets the PropertyInfo reflection object for the entity set property.

See Also

Reference

EntitySetInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EntitySetInfo.Entity Property
[image]

Gets the EntityInfo reflection object for the corresponding entity type.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntitySetInfo
Dim value As EntityInfo

value = instance.Entity

Syntax

Visual Basic
Public Property Entity As EntityInfo
C#
public EntityInfo Entity { get; }
C++

J#

JScript

Property Value
Type: EntityInfo
The entity info object.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntitySetInfo Class
EntitySetInfo Members
Microsoft.Xrm.Client.Metadata Namespace
EntityInfo
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EntitySetInfo.Property Property
[image]

Gets the PropertyInfo reflection object for the entity set property.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EntitySetInfo
Dim value As PropertyInfo

value = instance.Property

Syntax

Visual Basic
Public Property Property As PropertyInfo
C#
public PropertyInfo Property { get; }
C++

J#

JScript

Property Value
Type:

The property info.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EntitySetInfo Class
EntitySetInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo Class
See Also Members
[image]

Provides information about the organization service context. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextInfo

Syntax

Visual Basic
Public NotInheritable Class OrganizationServiceContextInfo
C#
public sealed class OrganizationServiceContextInfo
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Metadata.OrganizationServiceContextInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo Members
See Also Constructors Methods Properties
[image]

Provides information about the organization service context. (Developer Extensions)

The following tables list the members exposed by the OrganizationServiceContextInfo type.

Public Constructors

Name | Description
OrganizationServiceContextInfo | Creates an instance of the OrganizationServiceContextInfo class.
Top

Public Properties

 | Name | Description
public property | ContextType | Gets the custom OrganizationServiceContext class.
public property | EntitySetsByEntityLogicalName | Gets the lookup of EntitySetInfo keyed by the entity logical name.
public property | EntitySetsByPropertyName | Gets the lookup of EntitySetInfo keyed by the entity set property name.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
 | TryGet | Overloaded. Returns an OrganizationServiceContextInfo from a custom OrganizationServiceContext class.
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceContextInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo Constructor
[image]

Creates an instance of the OrganizationServiceContextInfo class.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim contextType As Type

Dim instance As New OrganizationServiceContextInfo(contextType)

Syntax

Visual Basic
Public Sub New ( _
    contextType As Type _
)
C#
public OrganizationServiceContextInfo (
    Type contextType
)
C++

J#

JScript

Parameters
contextType
Type: Type. The type.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextInfo Class
OrganizationServiceContextInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
 | TryGet | Overloaded. Returns an OrganizationServiceContextInfo from a custom OrganizationServiceContext class.

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceContextInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo.TryGet Method
[image]

Returns an OrganizationServiceContextInfo from a custom OrganizationServiceContext class.OrganizationServiceContext Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
OrganizationServiceContextInfo.TryGet (OrganizationServiceContext, Entity, EntitySetInfo) | Returns an OrganizationServiceContextInfo from a custom OrganizationServiceContext class and an entity.
OrganizationServiceContextInfo.TryGet (Type, OrganizationServiceContextInfo) | Returns an OrganizationServiceContextInfo from a custom OrganizationServiceContext class.
OrganizationServiceContextInfo.TryGet (Type, String, EntitySetInfo) | Returns an OrganizationServiceContextInfo from a custom OrganizationServiceContext class and an entity logical name.

See Also

Reference

OrganizationServiceContextInfo Class
OrganizationServiceContextInfo Members
Microsoft.Xrm.Client.Metadata Namespace
OrganizationServiceContext

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo.TryGet Method (OrganizationServiceContext, Entity, EntitySetInfo)
[image]

Returns an OrganizationServiceContextInfo from a custom OrganizationServiceContext class and an entity.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim entitySetInfo As EntitySetInfo
Dim returnValue As Boolean

returnValue = OrganizationServiceContextInfo.TryGet(context, entity, entitySetInfo)

Syntax

Visual Basic
Public Shared Function TryGet ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    <OutAttribute> ByRef entitySetInfo As EntitySetInfo _
) As Boolean
C#
public static bool TryGet (
    OrganizationServiceContext context,
    Entity entity,
    out EntitySetInfo entitySetInfo
)
C++

J#

JScript

Parameters
context
entity
entitySetInfo
Return Value
Type: Boolean
true if there is a return value for the specified parameters; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextInfo Class
OrganizationServiceContextInfo Members
Microsoft.Xrm.Client.Metadata Namespace
OrganizationServiceContext
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo.TryGet Method (Type, OrganizationServiceContextInfo)
[image]

Returns an OrganizationServiceContextInfo from a custom OrganizationServiceContext class.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim contextType As Type
Dim contextInfo As OrganizationServiceContextInfo
Dim returnValue As Boolean

returnValue = OrganizationServiceContextInfo.TryGet(contextType, contextInfo)

Syntax

Visual Basic
Public Shared Function TryGet ( _
    contextType As Type, _
    <OutAttribute> ByRef contextInfo As OrganizationServiceContextInfo _
) As Boolean
C#
public static bool TryGet (
    Type contextType,
    out OrganizationServiceContextInfo contextInfo
)
C++

J#

JScript

Parameters
contextType
contextInfo
Return Value
Type: Boolean
true if there is a return value for the specified parameters; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextInfo Class
OrganizationServiceContextInfo Members
Microsoft.Xrm.Client.Metadata Namespace


OrganizationServiceContextInfo.TryGet Method (Type, String, EntitySetInfo)
[image]

Returns an OrganizationServiceContextInfo from a custom OrganizationServiceContext class and an entity logical name.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim contextType As Type
Dim entityLogicalName As String
Dim entitySetInfo As EntitySetInfo
Dim returnValue As Boolean

returnValue = OrganizationServiceContextInfo.TryGet(contextType, entityLogicalName, entitySetInfo)

Syntax

Visual Basic
Public Shared Function TryGet ( _
    contextType As Type, _
    entityLogicalName As String, _
    <OutAttribute> ByRef entitySetInfo As EntitySetInfo _
) As Boolean
C#
public static bool TryGet (
    Type contextType,
    string entityLogicalName,
    out EntitySetInfo entitySetInfo
)
C++

J#

JScript

Parameters
contextType
entityLogicalName
entitySetInfo
Return Value
Type: Boolean
true if there is a return value for the specified parameters; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextInfo Class
OrganizationServiceContextInfo Members
Microsoft.Xrm.Client.Metadata Namespace


OrganizationServiceContextInfo Properties
[image]

Public Properties

 | Name | Description
public property | ContextType | Gets the custom OrganizationServiceContext class.
public property | EntitySetsByEntityLogicalName | Gets the lookup of EntitySetInfo keyed by the entity logical name.
public property | EntitySetsByPropertyName | Gets the lookup of EntitySetInfo keyed by the entity set property name.

See Also

Reference

OrganizationServiceContextInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo.ContextType Property
[image]

Gets the custom OrganizationServiceContext class.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextInfo
Dim value As Type

value = instance.ContextType

Syntax

Visual Basic
Public Property ContextType As Type
C#
public Type ContextType { get; }
C++

J#

JScript

Property Value
Type: Type
The custom OrganizationServiceContext class.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextInfo Class
OrganizationServiceContextInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo.EntitySetsByEntityLogicalName Property
[image]

Gets the lookup of EntitySetInfo keyed by the entity logical name.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextInfo
Dim value As IDictionary(Of String, EntitySetInfo)

value = instance.EntitySetsByEntityLogicalName

Syntax

Visual Basic
Public ReadOnly Property EntitySetsByEntityLogicalName As IDictionary(Of String, EntitySetInfo)
C#
public IDictionary<string,EntitySetInfo> EntitySetsByEntityLogicalName { get; }
C++

J#

JScript

Property Value
Type: IDictionary<String, EntitySetInfo>
The dictionary of entity set info.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextInfo Class
OrganizationServiceContextInfo Members
Microsoft.Xrm.Client.Metadata Namespace
EntitySetInfo
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceContextInfo.EntitySetsByPropertyName Property
[image]

Gets the lookup of EntitySetInfo keyed by the entity set property name.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceContextInfo
Dim value As IDictionary(Of String, EntitySetInfo)

value = instance.EntitySetsByPropertyName

Syntax

Visual Basic
Public ReadOnly Property EntitySetsByPropertyName As IDictionary(Of String, EntitySetInfo)
C#
public IDictionary<string,EntitySetInfo> EntitySetsByPropertyName { get; }
C++

J#

JScript

Property Value
Type: IDictionary<String, EntitySetInfo>
The dictionary of entity set info.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceContextInfo Class
OrganizationServiceContextInfo Members
Microsoft.Xrm.Client.Metadata Namespace
EntitySetInfo
Other Resources
Developer Extensions for Microsoft Dynamics CRM


RelationshipInfo Class
See Also Members
[image]

Provides information about a relationship. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As RelationshipInfo

Syntax

Visual Basic
Public NotInheritable Class RelationshipInfo
C#
public sealed class RelationshipInfo
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Metadata.RelationshipInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


RelationshipInfo Members
See Also Constructors Methods Properties
[image]

Provides information about a relationship. (Developer Extensions)

The following tables list the members exposed by the RelationshipInfo type.

Public Constructors

Name | Description
RelationshipInfo | Creates a RelationshipInfo class.
Top

Public Properties

 | Name | Description
public property | CrmAssociationAttribute | Gets the annotation for the relationship property.
public property | IsCollection | Indicates that the relationship property returns a collection of entities.
public property | Property | Gets the reflection object for the relationship property.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

RelationshipInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


RelationshipInfo Constructor
[image]

Creates a RelationshipInfo class.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim property As PropertyInfo
Dim crmAssociationAttribute As RelationshipSchemaNameAttribute

Dim instance As New RelationshipInfo(property, crmAssociationAttribute)

Syntax

Visual Basic
Public Sub New ( _
    property As PropertyInfo, _
    crmAssociationAttribute As RelationshipSchemaNameAttribute _
)
C#
public RelationshipInfo (
    PropertyInfo property,
    RelationshipSchemaNameAttribute crmAssociationAttribute
)
C++

J#

JScript

Parameters
property
Type: PropertyInfo. The property info.
crmAssociationAttribute
Type: RelationshipSchemaNameAttribute. The schema name.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipInfo Class
RelationshipInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


RelationshipInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

RelationshipInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


RelationshipInfo Properties
[image]

Public Properties

 | Name | Description
public property | CrmAssociationAttribute | Gets the annotation for the relationship property.
public property | IsCollection | Indicates that the relationship property returns a collection of entities.
public property | Property | Gets the reflection object for the relationship property.

See Also

Reference

RelationshipInfo Class
Microsoft.Xrm.Client.Metadata Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


RelationshipInfo.CrmAssociationAttribute Property
[image]

Gets the annotation for the relationship property.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As RelationshipInfo
Dim value As RelationshipSchemaNameAttribute

value = instance.CrmAssociationAttribute

Syntax

Visual Basic
Public Property CrmAssociationAttribute As RelationshipSchemaNameAttribute
C#
public RelationshipSchemaNameAttribute CrmAssociationAttribute { get; }
C++

J#

JScript

Property Value
Type: RelationshipSchemaNameAttribute
The annotation for the relationship property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipInfo Class
RelationshipInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


RelationshipInfo.IsCollection Property
[image]

Indicates that the relationship property returns a collection of entities.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As RelationshipInfo
Dim value As Boolean

value = instance.IsCollection

Syntax

Visual Basic
Public Property IsCollection As Boolean
C#
public bool IsCollection { get; }
C++

J#

JScript

Property Value
Type: Boolean
true if the relationship property returns a collection of entities; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipInfo Class
RelationshipInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


RelationshipInfo.Property Property
[image]

Gets the reflection object for the relationship property.

Namespace: Microsoft.Xrm.Client.Metadata
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As RelationshipInfo
Dim value As PropertyInfo

value = instance.Property

Syntax

Visual Basic
Public Property Property As PropertyInfo
C#
public PropertyInfo Property { get; }
C++

J#

JScript

Property Value
Type: PropertyInfo
The reflection object for the relationship property.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
RelationshipInfo Class
RelationshipInfo Members
Microsoft.Xrm.Client.Metadata Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


Microsoft.Xrm.Client.Runtime.Serialization Namespace

Classes

Class | Description
ObjectExtensions | (Developer Extensions)


ObjectExtensions Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Runtime.Serialization
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class ObjectExtensions
C#
[ExtensionAttribute]
public static class ObjectExtensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Runtime.Serialization.ObjectExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectExtensions Members
Microsoft.Xrm.Client.Runtime.Serialization Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObjectExtensions Members
See Also Methods
[image]

(Developer Extensions)

The following tables list the members exposed by the ObjectExtensions type.

Public Methods (see also Extension Methods)

Name | Description
DeserializeByJson | Deserialize an object using the DataContractJsonSerializer.
SerializeByJson | Serialize an object using the DataContractJsonSerializer.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

ObjectExtensions Class
Microsoft.Xrm.Client.Runtime.Serialization Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
DeserializeByJson | Deserialize an object using the DataContractJsonSerializer.
SerializeByJson | Serialize an object using the DataContractJsonSerializer.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

ObjectExtensions Class
Microsoft.Xrm.Client.Runtime.Serialization Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObjectExtensions.DeserializeByJson Method
[image]

Deserialize an object using the DataContractJsonSerializer.

Namespace: Microsoft.Xrm.Client.Runtime.Serialization
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim text As String
Dim type As Type
Dim knownTypes As IEnumerable(Of Type)
Dim returnValue As Object

returnValue = ObjectExtensions.DeserializeByJson(text, type, knownTypes)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function DeserializeByJson ( _
    text As String, _
    type As Type, _
    knownTypes As IEnumerable(Of Type) _
) As Object
C#
[ExtensionAttribute]
public static Object DeserializeByJson (
    string text,
    Type type,
    IEnumerable<Type> knownTypes
)
C++

J#

JScript

Parameters
text
Type: String.
type
Type: Type.
knownTypes
Type: IEnumerable<Type>.
Return Value
Type: Object

.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectExtensions Class
ObjectExtensions Members
Microsoft.Xrm.Client.Runtime.Serialization Namespace


ObjectExtensions.SerializeByJson Method
[image]

Serialize an object using the DataContractJsonSerializer.

Namespace: Microsoft.Xrm.Client.Runtime.Serialization
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim obj As Object
Dim knownTypes As IEnumerable(Of Type)
Dim returnValue As String

returnValue = ObjectExtensions.SerializeByJson(obj, knownTypes)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function SerializeByJson ( _
    obj As Object, _
    knownTypes As IEnumerable(Of Type) _
) As String
C#
[ExtensionAttribute]
public static string SerializeByJson (
    Object obj,
    IEnumerable<Type> knownTypes
)
C++

J#

JScript

Parameters
obj
Type: Object.
knownTypes
Type: IEnumerable<Type>.
obj
Type: Object.
knownTypes
Type: IEnumerable<Type>.
Return Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObjectExtensions Class
ObjectExtensions Members
Microsoft.Xrm.Client.Runtime.Serialization Namespace


Microsoft.Xrm.Client.Security Namespace

Classes

Class | Description
CrmEntitySecurityProvider | Provides methods to verify entity security for a user. (Developer Extensions)

Interfaces

Interface | Description
ICrmEntitySecurityProvider | An interface used to verify entity security for a user. (Developer Extensions)

Enumerations

Enumeration | Description
CrmEntityRight | (Developer Extensions)


CrmEntityRight Enumeration
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntityRight

Syntax

Visual Basic
Public Enumeration CrmEntityRight
C#
public enum CrmEntityRight
C++

J#

JScript

  Members
Member name | Description
Change | Value = 1.
Read | Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client.Security Namespace
CrmEntitySecurityProvider
Other Resources
Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


CrmEntitySecurityProvider Class
See Also Members
[image]

Provides methods to verify entity security for a user. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntitySecurityProvider

Syntax

Visual Basic
Public MustInherit Class CrmEntitySecurityProvider
    Implements ICrmEntitySecurityProvider, IInitializable
C#
public abstract class CrmEntitySecurityProvider : ICrmEntitySecurityProvider, IInitializable
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Security.CrmEntitySecurityProvider
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


CrmEntitySecurityProvider Members
See Also Methods Constructors
[image]

Provides methods to verify entity security for a user. (Developer Extensions)

The following tables list the members exposed by the CrmEntitySecurityProvider type.

Protected Constructors

Name | Description
CrmEntitySecurityProvider | Initializes a new instance of the CrmEntitySecurityProvider class.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Assert | Overloaded. Asserts that the current user has the requested right to one or more entities.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | Initializes custom settings.
public method | ToString | (inherited from Object)
public method | TryAssert | Overloaded. Asserts that the current user has the requested right to one or more entities.
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

CrmEntitySecurityProvider Class
Microsoft.Xrm.Client.Security Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntitySecurityProvider Constructor
[image]

Initializes a new instance of the CrmEntitySecurityProvider class.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New CrmEntitySecurityProvider

Syntax

Visual Basic
Protected Sub New
C#
protected CrmEntitySecurityProvider ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntitySecurityProvider Class
CrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


CrmEntitySecurityProvider Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Assert | Overloaded. Asserts that the current user has the requested right to one or more entities.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | Initializes custom settings.
public method | ToString | (inherited from Object)
public method | TryAssert | Overloaded. Asserts that the current user has the requested right to one or more entities.

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CrmEntitySecurityProvider Class
Microsoft.Xrm.Client.Security Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


CrmEntitySecurityProvider.Assert Method
[image]

Asserts that the current user has the requested right to one or more entities.

Overload List

Name | Description
CrmEntitySecurityProvider.Assert (OrganizationServiceContext, Entity, CrmEntityRight) | Asserts that the current user has the requested right to an entity.
CrmEntitySecurityProvider.Assert (OrganizationServiceContext, IEnumerable, CrmEntityRight) | Asserts that the current user has the requested right to a set of entities.

See Also

Reference

CrmEntitySecurityProvider Class
CrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


CrmEntitySecurityProvider.Assert Method (OrganizationServiceContext, Entity, CrmEntityRight)
[image]

Asserts that the current user has the requested right to an entity.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntitySecurityProvider
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim right As CrmEntityRight

instance.Assert(context, entity, right)

Syntax

Visual Basic
Public Overridable Sub Assert ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    right As CrmEntityRight _
)
C#
public virtual void Assert (
    OrganizationServiceContext context,
    Entity entity,
    CrmEntityRight right
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The context.
entity
Type: Entity. The entity instance.
right
Type: CrmEntityRight. The rights to look for.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntitySecurityProvider Class
CrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


CrmEntitySecurityProvider.Assert Method (OrganizationServiceContext, IEnumerable, CrmEntityRight)
[image]

Asserts that the current user has the requested right to a set of entities.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntitySecurityProvider
Dim context As OrganizationServiceContext
Dim entities As IEnumerable(Of Entity)
Dim right As CrmEntityRight

instance.Assert(context, entities, right)

Syntax

Visual Basic
Public Overridable Sub Assert ( _
    context As OrganizationServiceContext, _
    entities As IEnumerable(Of Entity), _
    right As CrmEntityRight _
)
C#
public virtual void Assert (
    OrganizationServiceContext context,
    IEnumerable<Entity> entities,
    CrmEntityRight right
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The context.
entities
Type: IEnumerable<Entity>.  The collection of entities.
right
Type: CrmEntityRight. The rights to look for.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntitySecurityProvider Class
CrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


CrmEntitySecurityProvider.Initialize Method
[image]

Initializes custom settings.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntitySecurityProvider
Dim name As String
Dim config As NameValueCollection

instance.Initialize(name, config)

Syntax

Visual Basic
Public Overridable Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
C#
public virtual void Initialize (
    string name,
    NameValueCollection config
)
C++

J#

JScript

Parameters
name
Type: String. The name.
config
Type: NameValueCollection. The collection of values.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntitySecurityProvider Class
CrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


CrmEntitySecurityProvider.TryAssert Method
[image]

Asserts that the current user has the requested right to one or more entities.

Overload List

Name | Description
CrmEntitySecurityProvider.TryAssert (OrganizationServiceContext, Entity, CrmEntityRight) | Asserts that the current user has the requested right to an entity.
CrmEntitySecurityProvider.TryAssert (OrganizationServiceContext, IEnumerable, CrmEntityRight) | Asserts that the current user has the requested right to a set of entities.

See Also

Reference

CrmEntitySecurityProvider Class
CrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


CrmEntitySecurityProvider.TryAssert Method (OrganizationServiceContext, Entity, CrmEntityRight)
[image]

Asserts that the current user has the requested right to an entity.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntitySecurityProvider
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim right As CrmEntityRight
Dim returnValue As Boolean

returnValue = instance.TryAssert(context, entity, right)

Syntax

Visual Basic
Public MustOverride Function TryAssert ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    right As CrmEntityRight _
) As Boolean
C#
public abstract bool TryAssert (
    OrganizationServiceContext context,
    Entity entity,
    CrmEntityRight right
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The context.
entity
Type: Entity. The entity instance.
right
Type: CrmEntityRight. The rights to look for.
Return Value
Type: Boolean
true if the current user has the requested right to the entity; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntitySecurityProvider Class
CrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


CrmEntitySecurityProvider.TryAssert Method (OrganizationServiceContext, IEnumerable, CrmEntityRight)
[image]

Asserts that the current user has the requested right to a set of entities.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CrmEntitySecurityProvider
Dim context As OrganizationServiceContext
Dim entities As IEnumerable(Of Entity)
Dim right As CrmEntityRight
Dim returnValue As Boolean

returnValue = instance.TryAssert(context, entities, right)

Syntax

Visual Basic
Public Overridable Function TryAssert ( _
    context As OrganizationServiceContext, _
    entities As IEnumerable(Of Entity), _
    right As CrmEntityRight _
) As Boolean
C#
public virtual bool TryAssert (
    OrganizationServiceContext context,
    IEnumerable<Entity> entities,
    CrmEntityRight right
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The context.
entities
Type: IEnumerable<Entity>.  The collection of entities.
right
Type: CrmEntityRight. The rights to look for.
Return Value
Type: Boolean
true if the current user has the requested right to the entities in the collection; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CrmEntitySecurityProvider Class
CrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


ICrmEntitySecurityProvider Interface
See Also Members
[image]

An interface used to verify entity security for a user. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ICrmEntitySecurityProvider

Syntax

Visual Basic
Public Interface ICrmEntitySecurityProvider
C#
public interface ICrmEntitySecurityProvider
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ICrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


ICrmEntitySecurityProvider Members
See Also Methods
[image]

An interface used to verify entity security for a user. (Developer Extensions)

The following tables list the members exposed by the ICrmEntitySecurityProvider type.

Public Methods

 | Name | Description
public method | Assert | Overloaded. Asserts that the current user has the requested right to one or more entities.
public method | TryAssert | Overloaded. Asserts that the current user has the requested right to one or more entities.
Top

See Also

Reference

ICrmEntitySecurityProvider Interface
Microsoft.Xrm.Client.Security Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


ICrmEntitySecurityProvider Methods
[image]

Public Methods

 | Name | Description
public method | Assert | Overloaded. Asserts that the current user has the requested right to one or more entities.
public method | TryAssert | Overloaded. Asserts that the current user has the requested right to one or more entities.

See Also

Reference

ICrmEntitySecurityProvider Interface
Microsoft.Xrm.Client.Security Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


ICrmEntitySecurityProvider.Assert Method
[image]

Asserts that the current user has the requested right to one or more entities.Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online

Overload List

Name | Description
ICrmEntitySecurityProvider.Assert (OrganizationServiceContext, Entity, CrmEntityRight) | Asserts that the current user has the requested right to an entity.
ICrmEntitySecurityProvider.Assert (OrganizationServiceContext, IEnumerable, CrmEntityRight) | Asserts that the current user has the requested right to a set of entities.

See Also

Reference

ICrmEntitySecurityProvider Interface
ICrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


ICrmEntitySecurityProvider.Assert Method (OrganizationServiceContext, Entity, CrmEntityRight)
[image]

Asserts that the current user has the requested right to an entity.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ICrmEntitySecurityProvider
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim right As CrmEntityRight

instance.Assert(context, entity, right)

Syntax

Visual Basic
Sub Assert ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    right As CrmEntityRight _
)
C#
void Assert (
    OrganizationServiceContext context,
    Entity entity,
    CrmEntityRight right
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The context.
entity
Type: Entity. The entity instance.
right
Type: CrmEntityRight. The rights to look for.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ICrmEntitySecurityProvider Interface
ICrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


ICrmEntitySecurityProvider.Assert Method (OrganizationServiceContext, IEnumerable, CrmEntityRight)
[image]

Asserts that the current user has the requested right to a set of entities.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ICrmEntitySecurityProvider
Dim context As OrganizationServiceContext
Dim entities As IEnumerable(Of Entity)
Dim right As CrmEntityRight

instance.Assert(context, entities, right)

Syntax

Visual Basic
Sub Assert ( _
    context As OrganizationServiceContext, _
    entities As IEnumerable(Of Entity), _
    right As CrmEntityRight _
)
C#
void Assert (
    OrganizationServiceContext context,
    IEnumerable<Entity> entities,
    CrmEntityRight right
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The context.
entities
Type: IEnumerable<Entity>.  The collection of entities.
right
Type: CrmEntityRight. The rights to look for.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ICrmEntitySecurityProvider Interface
ICrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


ICrmEntitySecurityProvider.TryAssert Method
[image]

Asserts that the current user has the requested right to one or more entities.Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online

Overload List

Name | Description
ICrmEntitySecurityProvider.TryAssert (OrganizationServiceContext, Entity, CrmEntityRight) | Asserts that the current user has the requested right to an entity.
ICrmEntitySecurityProvider.TryAssert (OrganizationServiceContext, IEnumerable, CrmEntityRight) | Asserts that the current user has the requested right to a set of entities.

See Also

Reference

ICrmEntitySecurityProvider Interface
ICrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


ICrmEntitySecurityProvider.TryAssert Method (OrganizationServiceContext, Entity, CrmEntityRight)
[image]

Asserts that the current user has the requested right to an entity.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ICrmEntitySecurityProvider
Dim context As OrganizationServiceContext
Dim entity As Entity
Dim right As CrmEntityRight
Dim returnValue As Boolean

returnValue = instance.TryAssert(context, entity, right)

Syntax

Visual Basic
Function TryAssert ( _
    context As OrganizationServiceContext, _
    entity As Entity, _
    right As CrmEntityRight _
) As Boolean
C#
bool TryAssert (
    OrganizationServiceContext context,
    Entity entity,
    CrmEntityRight right
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The context.
entity
Type: Entity. The entity instance.
right
Type: CrmEntityRight. The rights to look for.
Return Value
Type: Boolean
true if the current user has the requested right to the entity; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ICrmEntitySecurityProvider Interface
ICrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM 2011 and Microsoft Dynamics CRM Online


ICrmEntitySecurityProvider.TryAssert Method (OrganizationServiceContext, IEnumerable, CrmEntityRight)
[image]

Asserts that the current user has the requested right to a set of entities.

Namespace: Microsoft.Xrm.Client.Security
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ICrmEntitySecurityProvider
Dim context As OrganizationServiceContext
Dim entities As IEnumerable(Of Entity)
Dim right As CrmEntityRight
Dim returnValue As Boolean

returnValue = instance.TryAssert(context, entities, right)

Syntax

Visual Basic
Function TryAssert ( _
    context As OrganizationServiceContext, _
    entities As IEnumerable(Of Entity), _
    right As CrmEntityRight _
) As Boolean
C#
bool TryAssert (
    OrganizationServiceContext context,
    IEnumerable<Entity> entities,
    CrmEntityRight right
)
C++

J#

JScript

Parameters
context
Type: OrganizationServiceContext. The context.
entities
Type: IEnumerable<Entity>.  The collection of entities.
right
Type: CrmEntityRight. The rights to look for.
Return Value
Type: Boolean
true if the current user has the requested right to the entities in the collection; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ICrmEntitySecurityProvider Interface
ICrmEntitySecurityProvider Members
Microsoft.Xrm.Client.Security Namespace


Microsoft.Xrm.Client.Services Namespace

Classes

Class | Description
CachedOrganizationService | A wrapper class around the IOrganizationService that manages the details of setting up an OrganizationServiceProxy or other arbitrary IOrganizationService objects. When paired with an OrganizationServiceCache object, becomes a cached service. (Developer Extensions)
DeploymentService | Implements the deployment service interface. (Developer Extensions)
DiscoveryService | A wrapper class around the IDiscoveryService that manages the details of setting up an DiscoveryServiceProxy. (Developer Extensions)
KeyedRequest | (Developer Extensions)
KnownTypesProvider | This API supports the .NET Framework infrastructure and is not intended to be used directly from your code. Creates an array of Type objects that contain the types of individual profile properties. (Developer Extensions)
OrganizationService | A wrapper class around the IOrganizationService that manages the details of setting up an OrganizationServiceProxy or other arbitrary IOrganizationService objects. When paired with an OrganizationServiceCache object, becomes a cached service. (Developer Extensions)
OrganizationServiceCache | An abstracted data caching service that caches the results of IOrganizationService operations. Automatically sets up cache item dependencies and performing update operations invalidates dependent cache items. (Developer Extensions)
OrganizationServiceCacheSettings | (Developer Extensions)
OrganizationServiceExtensions | (Developer Extensions)

Interfaces

Interface | Description
ICacheItemPolicyFactory | (Developer Extensions)
IOrganizationServiceCache | The interface for a data caching service for the organization service. (Developer Extensions)

Enumerations

Enumeration | Description
OrganizationServiceCacheMode | (Developer Extensions)
OrganizationServiceCacheReturnMode | (Developer Extensions)


CachedOrganizationService Class
See Also Members
[image]

A wrapper class around the IOrganizationService that manages the details of setting up an OrganizationServiceProxy or other arbitrary IOrganizationService objects. When paired with an OrganizationServiceCache object, becomes a cached service. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CachedOrganizationService

Syntax

Visual Basic
Public Class CachedOrganizationService
    Inherits OrganizationService
C#
public class CachedOrganizationService : OrganizationService
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Client.Services.OrganizationService
    Microsoft.Xrm.Client.Services.CachedOrganizationService
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService Members
See Also Constructors Methods Properties
[image]

A wrapper class around the IOrganizationService that manages the details of setting up an OrganizationServiceProxy or other arbitrary IOrganizationService objects. When paired with an OrganizationServiceCache object, becomes a cached service. (Developer Extensions)

The following tables list the members exposed by the CachedOrganizationService type.

Public Constructors

Name | Description
CachedOrganizationService | Overloaded. Initializes a new instance of the CachedOrganizationService class.
Top

Public Properties

 | Name | Description
public property | Cache | Gets the cache.
public property | InnerService | (inherited from OrganizationService)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Associate | Creates a link between records. (Developer Extensions) (inherited from OrganizationService)
public method | Create | Overridden. Creates a record. (Developer Extensions)
public method | Delete | Overridden. Deletes a record. (Developer Extensions)
public method | Disassociate | Deletes a link between records. (Developer Extensions) (inherited from OrganizationService)
public method | Dispose | (inherited from OrganizationService)
public method | Equals | (inherited from Object)
public method | Execute | Overloaded. Overridden. Executes a message in the form of a request, and returns a response. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from OrganizationService)
public method | Retrieve | Overridden. Retrieves a record. (Developer Extensions)
public method | RetrieveMultiple | Overridden. Retrieves a collection of records. (Developer Extensions)
public method | ToString | (inherited from Object)
public method | Update | Overridden. Updates an existing record. (Developer Extensions)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CheckIfTokenIsExpired | (inherited from OrganizationService)
protected method | CreateServiceConfiguration | (inherited from OrganizationService)
protected method | CreateUserTokenResponse | (inherited from OrganizationService)
protected method | Finalize | (inherited from Object)
protected method | GetServiceConfiguration | (inherited from OrganizationService)
protected method | GetUserTokenResponse | (inherited from OrganizationService)
protected method | MemberwiseClone | (inherited from Object)
protected method | RegisterDeviceCredentials | (inherited from OrganizationService)
protected method | ToOrganizationService | (inherited from OrganizationService)
protected method | ToOrganizationServiceProxy | (inherited from OrganizationService)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

CachedOrganizationService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService Constructor
[image]

Initializes a new instance of the CachedOrganizationService class.

Overload List

Name | Description
CachedOrganizationService (CrmConnection) | Initializes a new instance of the CachedOrganizationService class.
CachedOrganizationService (CrmConnection, IOrganizationServiceCache) | Initializes a new instance of the CachedOrganizationService class.
CachedOrganizationService (IOrganizationService) | Initializes a new instance of the CachedOrganizationService class.
CachedOrganizationService (IOrganizationService, IOrganizationServiceCache) | Initializes a new instance of the CachedOrganizationService class.
CachedOrganizationService (IOrganizationService, String) | Initializes a new instance of the CachedOrganizationService class.
CachedOrganizationService (String) | Initializes a new instance of the CachedOrganizationService class.
CachedOrganizationService (String, IOrganizationServiceCache) | Initializes a new instance of the CachedOrganizationService class.

See Also

Reference

CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


CachedOrganizationService Constructor (CrmConnection)
[image]

Initializes a new instance of the CachedOrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection

Dim instance As New CachedOrganizationService(connection)

Syntax

Visual Basic
Public Sub New ( _
    connection As CrmConnection _
)
C#
public CachedOrganizationService (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection object.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


CachedOrganizationService Constructor (CrmConnection, IOrganizationServiceCache)
[image]

Initializes a new instance of the CachedOrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim cache As IOrganizationServiceCache

Dim instance As New CachedOrganizationService(connection, cache)

Syntax

Visual Basic
Public Sub New ( _
    connection As CrmConnection, _
    cache As IOrganizationServiceCache _
)
C#
public CachedOrganizationService (
    CrmConnection connection,
    IOrganizationServiceCache cache
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection object.
cache
Type: IOrganizationServiceCache. The cache object.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


CachedOrganizationService Constructor (IOrganizationService)
[image]

Initializes a new instance of the CachedOrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService

Dim instance As New CachedOrganizationService(service)

Syntax

Visual Basic
Public Sub New ( _
    service As IOrganizationService _
)
C#
public CachedOrganizationService (
    IOrganizationService service
)
C++

J#

JScript

Parameters
service
Type: IOrganizationService. The organization service.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


CachedOrganizationService Constructor (IOrganizationService, IOrganizationServiceCache)
[image]

Initializes a new instance of the CachedOrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService
Dim cache As IOrganizationServiceCache

Dim instance As New CachedOrganizationService(service, cache)

Syntax

Visual Basic
Public Sub New ( _
    service As IOrganizationService, _
    cache As IOrganizationServiceCache _
)
C#
public CachedOrganizationService (
    IOrganizationService service,
    IOrganizationServiceCache cache
)
C++

J#

JScript

Parameters
service
Type: IOrganizationService. The organization service.
cache
Type: IOrganizationServiceCache. The cache object.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


CachedOrganizationService Constructor (IOrganizationService, String)
[image]

Initializes a new instance of the CachedOrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService
Dim connectionId As String

Dim instance As New CachedOrganizationService(service, connectionId)

Syntax

Visual Basic
Public Sub New ( _
    service As IOrganizationService, _
    connectionId As String _
)
C#
public CachedOrganizationService (
    IOrganizationService service,
    string connectionId
)
C++

J#

JScript

Parameters
service
Type: IOrganizationService. The organization service.
connectionId
Type: String. The connection ID.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


CachedOrganizationService Constructor (String)
[image]

Initializes a new instance of the CachedOrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionStringName As String

Dim instance As New CachedOrganizationService(connectionStringName)

Syntax

Visual Basic
Public Sub New ( _
    connectionStringName As String _
)
C#
public CachedOrganizationService (
    string connectionStringName
)
C++

J#

JScript

Parameters
connectionStringName
Type: String. The connection string name.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


CachedOrganizationService Constructor (String, IOrganizationServiceCache)
[image]

Initializes a new instance of the CachedOrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionStringName As String
Dim cache As IOrganizationServiceCache

Dim instance As New CachedOrganizationService(connectionStringName, cache)

Syntax

Visual Basic
Public Sub New ( _
    connectionStringName As String, _
    cache As IOrganizationServiceCache _
)
C#
public CachedOrganizationService (
    string connectionStringName,
    IOrganizationServiceCache cache
)
C++

J#

JScript

Parameters
connectionStringName
Type: String. The connection string name.
cache
Type: IOrganizationServiceCache. The cache object.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


CachedOrganizationService Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Associate | Creates a link between records. (Developer Extensions) (inherited from OrganizationService)
public method | Create | Overridden. Creates a record. (Developer Extensions)
public method | Delete | Overridden. Deletes a record. (Developer Extensions)
public method | Disassociate | Deletes a link between records. (Developer Extensions) (inherited from OrganizationService)
public method | Dispose | (inherited from OrganizationService)
public method | Equals | (inherited from Object)
public method | Execute | Overloaded. Overridden. Executes a message in the form of a request, and returns a response. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | (inherited from OrganizationService)
public method | Retrieve | Overridden. Retrieves a record. (Developer Extensions)
public method | RetrieveMultiple | Overridden. Retrieves a collection of records. (Developer Extensions)
public method | ToString | (inherited from Object)
public method | Update | Overridden. Updates an existing record. (Developer Extensions)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CheckIfTokenIsExpired | (inherited from OrganizationService)
protected method | CreateServiceConfiguration | (inherited from OrganizationService)
protected method | CreateUserTokenResponse | (inherited from OrganizationService)
protected method | Finalize | (inherited from Object)
protected method | GetServiceConfiguration | (inherited from OrganizationService)
protected method | GetUserTokenResponse | (inherited from OrganizationService)
protected method | MemberwiseClone | (inherited from Object)
protected method | RegisterDeviceCredentials | (inherited from OrganizationService)
protected method | ToOrganizationService | (inherited from OrganizationService)
protected method | ToOrganizationServiceProxy | (inherited from OrganizationService)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

CachedOrganizationService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService.Create Method
[image]

Creates a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CachedOrganizationService
Dim entity As Entity
Dim returnValue As Guid

returnValue = instance.Create(entity)

Syntax

Visual Basic
Public Overrides Function Create ( _
    entity As Entity _
) As Guid
C#
public override Guid Create (
    Entity entity
)
C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that contains the properties to set in the newly created record.
Return Value
Type: Guid
The ID of the newly created record.

  Remarks
Extends the core implementation of the IOrganizationService.Create method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService.Delete Method
[image]

Deletes a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CachedOrganizationService
Dim entityName As String
Dim id As Guid

instance.Delete(entityName, id)

Syntax

Visual Basic
Public Overrides Sub Delete ( _
    entityName As String, _
    id As Guid _
)
C#
public override void Delete (
    string entityName,
    Guid id
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
id
Type: Guid. The ID of the record to delete.
  Remarks
Extends the core implementation of the IOrganizationService.Delete method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService.Execute Method
[image]

Executes a message in the form of a request, and returns a response. (Developer Extensions)Developer Extensions for Microsoft Dynamics CRM Developer Extensions Context Object Model

Overload List

Name | Description
CachedOrganizationService.Execute (OrganizationRequest) | Executes a message in the form of a request, and returns a response. (Developer Extensions)
CachedOrganizationService.Execute (OrganizationRequest, Func, String) | Executes a message in the form of a request, and returns a response. (Developer Extensions)

See Also

Reference

CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService.Execute Method (OrganizationRequest)
[image]

Executes a message in the form of a request, and returns a response. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CachedOrganizationService
Dim request As OrganizationRequest
Dim returnValue As OrganizationResponse

returnValue = instance.Execute(request)

Syntax

Visual Basic
Public Overrides Function Execute ( _
    request As OrganizationRequest _
) As OrganizationResponse
C#
public override OrganizationResponse Execute (
    OrganizationRequest request
)
C++

J#

JScript

Parameters
request
Type: OrganizationRequest. A request instance that defines the action to be performed.
Return Value
Type: OrganizationResponse
The response to the request. You must cast the return value of this method to the specific instance of the response that corresponds to the Request parameter.

  Remarks
This is a wrapper for the IOrganizationService.Execute method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService.Execute Method (OrganizationRequest, Func, String)
[image]

Executes a message in the form of a request, and returns a response. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CachedOrganizationService
Dim request As OrganizationRequest
Dim selector As Func(Of OrganizationResponse, T)
Dim selectorCacheKey As String
Dim returnValue As T

returnValue = instance.Execute(request, selector, selectorCacheKey)

Syntax

Visual Basic
Public Function Execute(Of T) ( _
    request As OrganizationRequest, _
    selector As Func(Of OrganizationResponse, T), _
    selectorCacheKey As String _
) As T
C#
public T Execute<T> (
    OrganizationRequest request,
    Func<OrganizationResponse,T> selector,
    string selectorCacheKey
)
C++

J#

JScript

GenericParameters
T
Parameters
request
A request instance that defines the action to be performed.
selector
selectorCacheKey
Return Value
Type: OrganizationResponse. You must cast the return value of this method to the specific instance of the response that corresponds to the Request parameter.

  Remarks
This is a wrapper for the IOrganizationService. Execute Method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


CachedOrganizationService.Retrieve Method
[image]

Retrieves a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CachedOrganizationService
Dim entityName As String
Dim id As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = instance.Retrieve(entityName, id, columnSet)

Syntax

Visual Basic
Public Overrides Function Retrieve ( _
    entityName As String, _
    id As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
public override Entity Retrieve (
    string entityName,
    Guid id,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity specified in the entityId parameter.
id
Type: Guid. The ID of the record you want to retrieve.
columnSet
Type: ColumnSet. A query that specifies the set of columns, or attributes, to retrieve.
Return Value
Type: Entity
The requested record.

  Remarks
Extends the core implementation of the IOrganizationService.Retrieve method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService.RetrieveMultiple Method
[image]

Retrieves a collection of records. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CachedOrganizationService
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = instance.RetrieveMultiple(query)

Syntax

Visual Basic
Public Overrides Function RetrieveMultiple ( _
    query As QueryBase _
) As EntityCollection
C#
public override EntityCollection RetrieveMultiple (
    QueryBase query
)
C++

J#

JScript

Parameters
query
Type: QueryBase. A query that determines the set of records to retrieve.
Return Value
Type: EntityCollection
The retrieved set of records.

  Remarks
Extends the core implementation of the IOrganizationService.RetrieveMultiple method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService.Update Method
[image]

Updates an existing record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CachedOrganizationService
Dim entity As Entity

instance.Update(entity)

Syntax

Visual Basic
Public Overrides Sub Update ( _
    entity As Entity _
)
C#
public override void Update (
    Entity entity
)
C++

J#

JScript

Parameters
entity
Type: Entity. An entity instance that has one or more properties set to be updated in the record.
  Remarks
Extends the core implementation of the IOrganizationService.Update method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService Properties
[image]

Public Properties

 | Name | Description
public property | Cache | Gets the cache.
public property | InnerService | (inherited from OrganizationService)

See Also

Reference

CachedOrganizationService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Developer Extensions Context Object Model


CachedOrganizationService.Cache Property
[image]

Gets the cache.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CachedOrganizationService
Dim value As IOrganizationServiceCache

value = instance.Cache

Syntax

Visual Basic
Public Property Cache As IOrganizationServiceCache
C#
public IOrganizationServiceCache Cache { get; }
C++

J#

JScript

Property Value
Type: IOrganizationServiceCache
The cached organization service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
CachedOrganizationService Class
CachedOrganizationService Members
Microsoft.Xrm.Client.Services Namespace


DeploymentService Class
See Also Members
[image]

Implements the deployment service interface. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeploymentService

Syntax

Visual Basic
Public Class DeploymentService
    Implements IDisposable, IDeploymentService, IInitializable
C#
public class DeploymentService : IDisposable, IDeploymentService, IInitializable
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.DeploymentService
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeploymentService Members
See Also Constructors Methods Properties
[image]

Implements the deployment service interface. (Developer Extensions)

The following tables list the members exposed by the DeploymentService type.

Public Constructors

Name | Description
DeploymentService | Overloaded. Initializes a new instance of the DeploymentService class.
Top

Public Properties

 | Name | Description
public property | InnerService | Gets the inner service.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Delete | Deletes a deployment record. (Developer Extensions)
public method | Dispose | Disposes the instance.
public method | Equals | (inherited from Object)
public method | Execute | Executes a deployment message in the form of a request, and returns a response. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize |
public method | Retrieve | Retrieves a deployment record. (Developer Extensions)
public method | RetrieveAll | Retrieves all deployment records for the specified deployment entity type. (Developer Extensions)
public method | ToString | (inherited from Object)
public method | Update | Updates a deployment record. (Developer Extensions)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | ToDeploymentService |
protected method | ToDeploymentServiceClient |
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DeploymentService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeploymentService Constructor
[image]

Initializes a new instance of the DeploymentService class.

Overload List

Name | Description
DeploymentService (CrmConnection) | Initializes a new instance of the DeploymentService class.
DeploymentService (IDeploymentService) | Initializes a new instance of the DeploymentService class.
DeploymentService (String) | Initializes a new instance of the DeploymentService class.

See Also

Reference

DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace


DeploymentService Constructor (CrmConnection)
[image]

Initializes a new instance of the DeploymentService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection

Dim instance As New DeploymentService(connection)

Syntax

Visual Basic
Public Sub New ( _
    connection As CrmConnection _
)
C#
public DeploymentService (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace


DeploymentService Constructor (IDeploymentService)
[image]

Initializes a new instance of the DeploymentService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IDeploymentService

Dim instance As New DeploymentService(service)

Syntax

Visual Basic
Public Sub New ( _
    service As IDeploymentService _
)
C#
public DeploymentService (
    IDeploymentService service
)
C++

J#

JScript

Parameters
service
Type: IDeploymentService. The deployment service interface.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace


DeploymentService Constructor (String)
[image]

Initializes a new instance of the DeploymentService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionStringName As String

Dim instance As New DeploymentService(connectionStringName)

Syntax

Visual Basic
Public Sub New ( _
    connectionStringName As String _
)
C#
public DeploymentService (
    string connectionStringName
)
C++

J#

JScript

Parameters
connectionStringName
Type: String. The connection string name.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace


DeploymentService Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Delete | Deletes a deployment record. (Developer Extensions)
public method | Dispose | Disposes the instance.
public method | Equals | (inherited from Object)
public method | Execute | Executes a deployment message in the form of a request, and returns a response. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize |
public method | Retrieve | Retrieves a deployment record. (Developer Extensions)
public method | RetrieveAll | Retrieves all deployment records for the specified deployment entity type. (Developer Extensions)
public method | ToString | (inherited from Object)
public method | Update | Updates a deployment record. (Developer Extensions)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | ToDeploymentService |
protected method | ToDeploymentServiceClient |

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DeploymentService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeploymentService.Delete Method
[image]

Deletes a deployment record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeploymentService
Dim entityType As DeploymentEntityType
Dim id As EntityInstanceId

instance.Delete(entityType, id)

Syntax

Visual Basic
Public Sub Delete ( _
    entityType As DeploymentEntityType, _
    id As EntityInstanceId _
)
C#
public void Delete (
    DeploymentEntityType entityType,
    EntityInstanceId id
)
C++

J#

JScript

Parameters
entityType
Type: DeploymentEntityType. The deployment entity type.
id
Type: EntityInstanceId. The ID of the deployment entity to delete.
  Remarks
This is a wrapper for the IDeploymentService.Delete Method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeploymentService.Dispose Method
[image]

Disposes the instance.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeploymentService

instance.Dispose

Syntax

Visual Basic
Public Overridable Sub Dispose
C#
public virtual void Dispose ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace


DeploymentService.Execute Method
[image]

Executes a deployment message in the form of a request, and returns a response. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeploymentService
Dim request As DeploymentServiceRequest
Dim returnValue As DeploymentServiceResponse

returnValue = instance.Execute(request)

Syntax

Visual Basic
Public Function Execute ( _
    request As DeploymentServiceRequest _
) As DeploymentServiceResponse
C#
public DeploymentServiceResponse Execute (
    DeploymentServiceRequest request
)
C++

J#

JScript

Parameters
request
Type: DeploymentServiceRequest. The deployment service request.
Return Value
Type: DeploymentServiceResponse
The response from the request.

  Remarks
This is a wrapper for the IDeploymentService.Execute Method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeploymentService.Initialize Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeploymentService
Dim name As String
Dim config As NameValueCollection

instance.Initialize(name, config)

Syntax

Visual Basic
Public Overridable Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
C#
public virtual void Initialize (
    string name,
    NameValueCollection config
)
C++

J#

JScript

Parameters
name
Type: String. The name.
config
Type: NameValueCollection.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace


DeploymentService.Retrieve Method
[image]

Retrieves a deployment record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeploymentService
Dim entityType As DeploymentEntityType
Dim id As EntityInstanceId
Dim returnValue As DeploymentObject

returnValue = instance.Retrieve(entityType, id)

Syntax

Visual Basic
Public Function Retrieve ( _
    entityType As DeploymentEntityType, _
    id As EntityInstanceId _
) As DeploymentObject
C#
public DeploymentObject Retrieve (
    DeploymentEntityType entityType,
    EntityInstanceId id
)
C++

J#

JScript

Parameters
entityType
Type: DeploymentEntityType. The deployment entity type.
id
Type: EntityInstanceId. The ID of the deployment entity to retrieve.
Return Value
Type: DeploymentObject
The retrieved deployment object.

  Remarks
This is a wrapper for the IDeploymentService.Retrieve Method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeploymentService.RetrieveAll Method
[image]

Retrieves all deployment records for the specified deployment entity type. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeploymentService
Dim entityType As DeploymentEntityType
Dim returnValue As DataCollection(Of EntityInstanceId)

returnValue = instance.RetrieveAll(entityType)

Syntax

Visual Basic
Public Function RetrieveAll ( _
    entityType As DeploymentEntityType _
) As DataCollection(Of EntityInstanceId)
C#
public DataCollection<EntityInstanceId> RetrieveAll (
    DeploymentEntityType entityType
)
C++

J#

JScript

Parameters
entityType
Type: DeploymentEntityType. The deployment entity type.
Return Value
Type: DataCollection<EntityInstanceId>

The collection of retrieve deployment objects.

  Remarks
This is a wrapper for the IDeploymentService.RetrieveAll Method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeploymentService.ToDeploymentService Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As IDeploymentService

returnValue = Me.ToDeploymentService(connection)

Syntax

Visual Basic
Protected Overridable Function ToDeploymentService ( _
    connection As CrmConnection _
) As IDeploymentService
C#
protected virtual IDeploymentService ToDeploymentService (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
Return Value
Type: IDeploymentService.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeploymentService.ToDeploymentServiceClient Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As DeploymentServiceClient

returnValue = Me.ToDeploymentServiceClient(connection)

Syntax

Visual Basic
Protected Overridable Function ToDeploymentServiceClient ( _
    connection As CrmConnection _
) As DeploymentServiceClient
C#
protected virtual DeploymentServiceClient ToDeploymentServiceClient (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
Return Value
Type: DeploymentServiceClient.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeploymentService.Update Method
[image]

Updates a deployment record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeploymentService
Dim deploymentObject As DeploymentObject

instance.Update(deploymentObject)

Syntax

Visual Basic
Public Sub Update ( _
    deploymentObject As DeploymentObject _
)
C#
public void Update (
    DeploymentObject deploymentObject
)
C++

J#

JScript

Parameters
deploymentObject
Type: DeploymentObject. The deployment object to update.
  Remarks
This is a wrapper for the IDeploymentService. Update Method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeploymentService Properties
[image]

Public Properties

 | Name | Description
public property | InnerService | Gets the inner service.

See Also

Reference

DeploymentService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeploymentService.InnerService Property
[image]

Gets the inner service.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeploymentService
Dim value As IDeploymentService

value = instance.InnerService

Syntax

Visual Basic
Public ReadOnly Property InnerService As IDeploymentService
C#
public IDeploymentService InnerService { get; }
C++

J#

JScript

Property Value
Type: IDeploymentService.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DeploymentService Class
DeploymentService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService Class
See Also Members
[image]

A wrapper class around the IDiscoveryService that manages the details of setting up an DiscoveryServiceProxy. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DiscoveryService

Syntax

Visual Basic
Public Class DiscoveryService
    Implements IDisposable, IDiscoveryService, IInitializable
C#
public class DiscoveryService : IDisposable, IDiscoveryService, IInitializable
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.DiscoveryService
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DiscoveryService Members
See Also Constructors Methods Properties
[image]

A wrapper class around the IDiscoveryService that manages the details of setting up an DiscoveryServiceProxy. (Developer Extensions)

The following tables list the members exposed by the DiscoveryService type.

Public Constructors

Name | Description
DiscoveryService | Overloaded. Initializes a new instance of the DiscoveryService class.
Top

Public Properties

 | Name | Description
public property | InnerService | Gets the inner service.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Dispose | Dispose of the discovery service.
public method | Equals | (inherited from Object)
public method | Execute | Executes a discover service message in the form of a request, and returns a response. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | Initialize the discovery service.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CheckIfTokenIsExpired | Checks to see if the token has expired.
protected method | CreateServiceConfiguration | Creates the discovery service configuration.
protected method | CreateUserTokenResponse | Creates a user token response.
protected method | Finalize | (inherited from Object)
protected method | GetServiceConfiguration | Get the discovery service configuration.
protected method | GetUserTokenResponse | Get the user token response.
protected method | MemberwiseClone | (inherited from Object)
protected method | RegisterDeviceCredentials | Register the device credentials.
protected method | ToDiscoveryService | Gets the discovery service.
protected method | ToDiscoveryServiceProxy | Gets the discovery service proxy.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DiscoveryService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DiscoveryService Constructor
[image]

Initializes a new instance of the DiscoveryService class.

Overload List

Name | Description
DiscoveryService (CrmConnection) | Initializes a new instance of the DiscoveryService class.
DiscoveryService (IDiscoveryService) | Initializes a new instance of the DiscoveryService class.
DiscoveryService (String) | Initializes a new instance of the DiscoveryService class.

See Also

Reference

DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService Constructor (CrmConnection)
[image]

Initializes a new instance of the DiscoveryService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection

Dim instance As New DiscoveryService(connection)

Syntax

Visual Basic
Public Sub New ( _
    connection As CrmConnection _
)
C#
public DiscoveryService (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService Constructor (IDiscoveryService)
[image]

Initializes a new instance of the DiscoveryService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IDiscoveryService

Dim instance As New DiscoveryService(service)

Syntax

Visual Basic
Public Sub New ( _
    service As IDiscoveryService _
)
C#
public DiscoveryService (
    IDiscoveryService service
)
C++

J#

JScript

Parameters
service
Type: IDiscoveryService. The discovery service.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService Constructor (String)
[image]

Initializes a new instance of the DiscoveryService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionStringName As String

Dim instance As New DiscoveryService(connectionStringName)

Syntax

Visual Basic
Public Sub New ( _
    connectionStringName As String _
)
C#
public DiscoveryService (
    string connectionStringName
)
C++

J#

JScript

Parameters
connectionStringName
Type: String. The connection string name.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Dispose | Dispose of the discovery service.
public method | Equals | (inherited from Object)
public method | Execute | Executes a discover service message in the form of a request, and returns a response. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize | Initialize the discovery service.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CheckIfTokenIsExpired | Checks to see if the token has expired.
protected method | CreateServiceConfiguration | Creates the discovery service configuration.
protected method | CreateUserTokenResponse | Creates a user token response.
protected method | Finalize | (inherited from Object)
protected method | GetServiceConfiguration | Get the discovery service configuration.
protected method | GetUserTokenResponse | Get the user token response.
protected method | MemberwiseClone | (inherited from Object)
protected method | RegisterDeviceCredentials | Register the device credentials.
protected method | ToDiscoveryService | Gets the discovery service.
protected method | ToDiscoveryServiceProxy | Gets the discovery service proxy.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DiscoveryService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DiscoveryService.CheckIfTokenIsExpired Method
[image]

Checks to see if the token has expired.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim token As SecurityTokenResponse
Dim expiryWindow As Nullable(Of TimeSpan)
Dim returnValue As Boolean

returnValue = Me.CheckIfTokenIsExpired(token, expiryWindow)

Syntax

Visual Basic
Protected Function CheckIfTokenIsExpired ( _
    token As SecurityTokenResponse, _
    expiryWindow As Nullable(Of TimeSpan) _
) As Boolean
C#
protected bool CheckIfTokenIsExpired (
    SecurityTokenResponse token,
    Nullable<TimeSpan> expiryWindow
)
C++

J#

JScript

Parameters
token
Type: SecurityTokenResponse. The token.
expiryWindow
Type: Nullable<TimeSpan>. The expiration window.
Return Value
Type: Boolean
true if the token has expired; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService.CreateServiceConfiguration Method
[image]

Creates the discovery service configuration.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As IServiceConfiguration(Of IDiscoveryService)

returnValue = Me.CreateServiceConfiguration(connection)

Syntax

Visual Basic
Protected Overridable Function CreateServiceConfiguration ( _
    connection As CrmConnection _
) As IServiceConfiguration(Of IDiscoveryService)
C#
protected virtual IServiceConfiguration<IDiscoveryService> CreateServiceConfiguration (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
Return Value
Type: IServiceConfiguration<IDiscoveryService>
The configuration for the discovery service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService.CreateUserTokenResponse Method
[image]

Creates a user token response.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim config As IServiceConfiguration(Of IDiscoveryService)
Dim returnValue As SecurityTokenResponse

returnValue = Me.CreateUserTokenResponse(connection, config)

Syntax

Visual Basic
Protected Overridable Function CreateUserTokenResponse ( _
    connection As CrmConnection, _
    config As IServiceConfiguration(Of IDiscoveryService) _
) As SecurityTokenResponse
C#
protected virtual SecurityTokenResponse CreateUserTokenResponse (
    CrmConnection connection,
    IServiceConfiguration<IDiscoveryService> config
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
config
Type: IServiceConfiguration<IDiscoveryService>. The service configuration.
Return Value
Type: SecurityTokenResponse
The user token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService.Dispose Method
[image]

Dispose of the discovery service.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DiscoveryService

instance.Dispose

Syntax

Visual Basic
Public Overridable Sub Dispose
C#
public virtual void Dispose ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService.Execute Method
[image]

Executes a discover service message in the form of a request, and returns a response. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DiscoveryService
Dim request As DiscoveryRequest
Dim returnValue As DiscoveryResponse

returnValue = instance.Execute(request)

Syntax

Visual Basic
Public Overridable Function Execute ( _
    request As DiscoveryRequest _
) As DiscoveryResponse
C#
public virtual DiscoveryResponse Execute (
    DiscoveryRequest request
)
C++

J#

JScript

Parameters
request
Type: DiscoveryRequest . A request instance that defines the action to be performed.
Return Value
Type: DiscoveryResponse
The response from the request. You must cast the return value of this method to the specific instance of the response that corresponds to the Request parameter.

  Remarks
This is a wrapper around the IDiscoveryService.Execute method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DiscoveryService.GetServiceConfiguration Method
[image]

Get the discovery service configuration.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As IServiceConfiguration(Of IDiscoveryService)

returnValue = Me.GetServiceConfiguration(connection)

Syntax

Visual Basic
Protected Overridable Function GetServiceConfiguration ( _
    connection As CrmConnection _
) As IServiceConfiguration(Of IDiscoveryService)
C#
protected virtual IServiceConfiguration<IDiscoveryService> GetServiceConfiguration (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
Return Value
Type: IServiceConfiguration<IDiscoveryService>

The service configuration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService.GetUserTokenResponse Method
[image]

Get the user token response.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim config As IServiceConfiguration(Of IDiscoveryService)
Dim returnValue As SecurityTokenResponse

returnValue = Me.GetUserTokenResponse(connection, config)

Syntax

Visual Basic
Protected Overridable Function GetUserTokenResponse ( _
    connection As CrmConnection, _
    config As IServiceConfiguration(Of IDiscoveryService) _
) As SecurityTokenResponse
C#
protected virtual SecurityTokenResponse GetUserTokenResponse (
    CrmConnection connection,
    IServiceConfiguration<IDiscoveryService> config
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
config
Type: IServiceConfiguration<IDiscoveryService>. The service configuration.
Return Value
Type: SecurityTokenResponse
The user token response.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService.Initialize Method
[image]

Initialize the discovery service.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DiscoveryService
Dim name As String
Dim config As NameValueCollection

instance.Initialize(name, config)

Syntax

Visual Basic
Public Overridable Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
C#
public virtual void Initialize (
    string name,
    NameValueCollection config
)
C++

J#

JScript

Parameters
name
Type: String. The connection string name.
config
Type: NameValueCollection. The configuration.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


DiscoveryService.RegisterDeviceCredentials Method
[image]

Register the device credentials.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim deviceCredentials As ClientCredentials
Dim returnValue As Boolean

returnValue = Me.RegisterDeviceCredentials(deviceCredentials)

Syntax

Visual Basic
Protected Function RegisterDeviceCredentials ( _
    deviceCredentials As ClientCredentials _
) As Boolean
C#
protected bool RegisterDeviceCredentials (
    ClientCredentials deviceCredentials
)
C++

J#

JScript

Parameters
deviceCredentials
Type: ClientCredentials. The device credentials.
Return Value
Type: Boolean
true if the token has expired; otherwise false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DiscoveryService.ToDiscoveryService Method
[image]

Gets the discovery service.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As IDiscoveryService

returnValue = Me.ToDiscoveryService(connection)

Syntax

Visual Basic
Protected Overridable Function ToDiscoveryService ( _
    connection As CrmConnection _
) As IDiscoveryService
C#
protected virtual IDiscoveryService ToDiscoveryService (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
Return Value
Type: IDiscoveryService
The discover service.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DiscoveryService.ToDiscoveryServiceProxy Method
[image]

Gets the discovery service proxy.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As DiscoveryServiceProxy

returnValue = Me.ToDiscoveryServiceProxy(connection)

Syntax

Visual Basic
Protected Overridable Function ToDiscoveryServiceProxy ( _
    connection As CrmConnection _
) As DiscoveryServiceProxy
C#
protected virtual DiscoveryServiceProxy ToDiscoveryServiceProxy (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Type: CrmConnection. The connection.
Return Value
Type: DiscoveryServiceProxy
The discovery service proxy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DiscoveryService Properties
[image]

Public Properties

 | Name | Description
public property | InnerService | Gets the inner service.

See Also

Reference

DiscoveryService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DiscoveryService.InnerService Property
[image]

Gets the inner service.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DiscoveryService
Dim value As IDiscoveryService

value = instance.InnerService

Syntax

Visual Basic
Public ReadOnly Property InnerService As IDiscoveryService
C#
public IDiscoveryService InnerService { get; }
C++

J#

JScript

Property Value
Type: IDiscoveryService
The discovery service interface.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
DiscoveryService Class
DiscoveryService Members
Microsoft.Xrm.Client.Services Namespace


ICacheItemPolicyFactory Interface
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ICacheItemPolicyFactory

Syntax

Visual Basic
Public Interface ICacheItemPolicyFactory
C#
public interface ICacheItemPolicyFactory
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ICacheItemPolicyFactory Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ICacheItemPolicyFactory Members
See Also Methods
[image]

(Developer Extensions)

The following tables list the members exposed by the ICacheItemPolicyFactory type.

Public Methods

 | Name | Description
public method | Create | Creates a cache item policy.
Top

See Also

Reference

ICacheItemPolicyFactory Interface
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ICacheItemPolicyFactory Methods
[image]

Public Methods

 | Name | Description
public method | Create | Creates a cache item policy.

See Also

Reference

ICacheItemPolicyFactory Interface
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ICacheItemPolicyFactory.Create Method
[image]

Creates a cache item policy.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ICacheItemPolicyFactory
Dim returnValue As CacheItemPolicy

returnValue = instance.Create

Syntax

Visual Basic
Function Create As CacheItemPolicy
C#
CacheItemPolicy Create ()
C++

J#

JScript

Return Value
Type: CacheItemPolicy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ICacheItemPolicyFactory Interface
ICacheItemPolicyFactory Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


IOrganizationServiceCache Interface
See Also Members
[image]

The interface for a data caching service for the organization service. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache

Syntax

Visual Basic
Public Interface IOrganizationServiceCache
C#
public interface IOrganizationServiceCache
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


IOrganizationServiceCache Members
See Also Methods Properties
[image]

The interface for a data caching service for the organization service. (Developer Extensions)

The following tables list the members exposed by the IOrganizationServiceCache type.

Public Properties

 | Name | Description
public property | Mode | Gets or sets the caching behavior mode.
public property | ReturnMode | Gets or sets the cache retrieval mode.
Top

Public Methods

 | Name | Description
public method | Execute | Executes a request.
public method | Insert |
public method | Remove | Overloaded.
Top

See Also

Reference

IOrganizationServiceCache Interface
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


IOrganizationServiceCache Methods
[image]

Public Methods

 | Name | Description
public method | Execute | Executes a request.
public method | Insert |
public method | Remove | Overloaded.

See Also

Reference

IOrganizationServiceCache Interface
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


IOrganizationServiceCache.Execute Method
[image]

Executes a request.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim request As OrganizationRequest
Dim execute As Func(Of OrganizationRequest, OrganizationResponse)
Dim selector As Func(Of OrganizationResponse, T)
Dim selectorCacheKey As String
Dim returnValue As T

returnValue = instance.Execute(request, execute, selector, selectorCacheKey)

Syntax

Visual Basic
Function Execute(Of T) ( _
    request As OrganizationRequest, _
    execute As Func(Of OrganizationRequest, OrganizationResponse), _
    selector As Func(Of OrganizationResponse, T), _
    selectorCacheKey As String _
) As T
C#
T Execute<T> (
    OrganizationRequest request,
    Func<OrganizationRequest,OrganizationResponse> execute,
    Func<OrganizationResponse,T> selector,
    string selectorCacheKey
)
C++

J#

JScript

GenericParameters
T
The type.
Parameters
request
Type: OrganizationRequest. The request object.
execute
selector
selectorCacheKey
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


IOrganizationServiceCache.Insert Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim key As String
Dim query As Object
Dim result As Object

instance.Insert(key, query, result)

Syntax

Visual Basic
Sub Insert ( _
    key As String, _
    query As Object, _
    result As Object _
)
C#
void Insert (
    string key,
    Object query,
    Object result
)
C++

J#

JScript

Parameters
key
Type: Object. The key.
query
Type: Object. The query.
result
Type: Object. The result.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


IOrganizationServiceCache.Remove Method
[image]

Removes an object from the cache.

Overload List

Name | Description
IOrganizationServiceCache.Remove (OrganizationServiceCachePluginMessage) | Removes a plug-in message object from the cache.
IOrganizationServiceCache.Remove (Entity) | Removes an entity from the cache.
IOrganizationServiceCache.Remove (EntityReference) | Removes an entity from the cache.
IOrganizationServiceCache.Remove (OrganizationRequest) | Removes a request from the cache.
IOrganizationServiceCache.Remove (String) | Removes a specific cache item.
IOrganizationServiceCache.Remove (String, Nullable) | Removes an entity from the cache.

See Also

Reference

IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


IOrganizationServiceCache.Remove Method (OrganizationServiceCachePluginMessage)
[image]

Removes a plug-in message object from the cache.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim message As OrganizationServiceCachePluginMessage

instance.Remove(message)

Syntax

Visual Basic
Sub Remove ( _
    message As OrganizationServiceCachePluginMessage _
)
C#
void Remove (
    OrganizationServiceCachePluginMessage message
)
C++

J#

JScript

Parameters
message
Type: OrganizationServiceCachePluginMessage. The plug-in message object to remove.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


IOrganizationServiceCache.Remove Method (Entity)
[image]

Removes an entity from the cache.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim entity As Entity

instance.Remove(entity)

Syntax

Visual Basic
Sub Remove ( _
    entity As Entity _
)
C#
void Remove (
    Entity entity
)
C++

J#

JScript

Parameters
entity
Type: Entity. The entity to remove.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


IOrganizationServiceCache.Remove Method (EntityReference)
[image]

Removes an entity from the cache.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim entity As EntityReference

instance.Remove(entity)

Syntax

Visual Basic
Sub Remove ( _
    entity As EntityReference _
)
C#
void Remove (
    EntityReference entity
)
C++

J#

JScript

Parameters
entity
Type: EntityReference. The entity to remove.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


IOrganizationServiceCache.Remove Method (OrganizationRequest)
[image]

Removes a request from the cache.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim request As OrganizationRequest

instance.Remove(request)

Syntax

Visual Basic
Sub Remove ( _
    request As OrganizationRequest _
)
C#
void Remove (
    OrganizationRequest request
)
C++

J#

JScript

Parameters
request
Type: OrganizationRequest. The request object to remove.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


IOrganizationServiceCache.Remove Method (String)
[image]

Removes a specific cache item.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim cacheKey As String

instance.Remove(cacheKey)

Syntax

Visual Basic
Sub Remove ( _
    cacheKey As String _
)
C#
void Remove (
    string cacheKey
)
C++

J#

JScript

Parameters
cacheKey
Type: String. The name of the item to remove.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


IOrganizationServiceCache.Remove Method (String, Nullable)
[image]

Removes an entity from the cache.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim entityLogicalName As String
Dim id As Nullable(Of Guid)

instance.Remove(entityLogicalName, id)

Syntax

Visual Basic
Sub Remove ( _
    entityLogicalName As String, _
    id As Nullable(Of Guid) _
)
C#
void Remove (
    string entityLogicalName,
    Nullable<Guid> id
)
C++

J#

JScript

Parameters
entityLogicalName
Type: String. The name of the entity.
id
Type: Nullable<Guid>. The ID of the entity to remove.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


IOrganizationServiceCache Properties
[image]

Public Properties

 | Name | Description
public property | Mode | Gets or sets the caching behavior mode.
public property | ReturnMode | Gets or sets the cache retrieval mode.

See Also

Reference

IOrganizationServiceCache Interface
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


IOrganizationServiceCache.Mode Property
[image]

Gets or sets the caching behavior mode.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim value As OrganizationServiceCacheMode

value = instance.Mode

instance.Mode = value

Syntax

Visual Basic
Property Mode As OrganizationServiceCacheMode
C#
OrganizationServiceCacheMode Mode { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceCacheMode
The caching behavior mode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


IOrganizationServiceCache.ReturnMode Property
[image]

Gets or sets the cache retrieval mode.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As IOrganizationServiceCache
Dim value As OrganizationServiceCacheReturnMode

value = instance.ReturnMode

instance.ReturnMode = value

Syntax

Visual Basic
Property ReturnMode As OrganizationServiceCacheReturnMode
C#
OrganizationServiceCacheReturnMode ReturnMode { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceCacheReturnMode
The cache retrieval mode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
IOrganizationServiceCache Interface
IOrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


KeyedRequest Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As KeyedRequest

Syntax

Visual Basic
<SerializableAttribute> _
Public NotInheritable Class KeyedRequest
    Inherits OrganizationRequest
C#
[SerializableAttribute]
public sealed class KeyedRequest : OrganizationRequest
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Sdk.OrganizationRequest
    Microsoft.Xrm.Client.Services.KeyedRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KeyedRequest Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


KeyedRequest Members
See Also Constructors Methods Properties
[image]

(Developer Extensions)

The following tables list the members exposed by the KeyedRequest type.

Public Constructors

Name | Description
KeyedRequest | Overloaded. Initializes a new instance of the KeyedRequest class.
Top

Public Properties

 | Name | Description
public property | ExtensionData | (inherited from OrganizationRequest)
public property | Item | (inherited from OrganizationRequest)
public property | Key | Gets or sets a custom key value that is unique to the current request.
public property | Parameters | (inherited from OrganizationRequest)
public property | Request | Gets or sets the underlying request.
public property | RequestId | (inherited from OrganizationRequest)
public property | RequestName | (inherited from OrganizationRequest)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

KeyedRequest Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


KeyedRequest Constructor
[image]

Initializes a new instance of the KeyedRequest class.

Overload List

Name | Description
KeyedRequest () | Initializes a new instance of the KeyedRequest class.
KeyedRequest (OrganizationRequest, String) | Initializes a new instance of the KeyedRequest class.

See Also

Reference

KeyedRequest Class
KeyedRequest Members
Microsoft.Xrm.Client.Services Namespace


KeyedRequest Constructor ()
[image]

Initializes a new instance of the KeyedRequest class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New KeyedRequest

Syntax

Visual Basic
Public Sub New
C#
public KeyedRequest ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KeyedRequest Class
KeyedRequest Members
Microsoft.Xrm.Client.Services Namespace


KeyedRequest Constructor (OrganizationRequest, String)
[image]

Initializes a new instance of the KeyedRequest class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim request As OrganizationRequest
Dim key As String

Dim instance As New KeyedRequest(request, key)

Syntax

Visual Basic
Public Sub New ( _
    request As OrganizationRequest, _
    key As String _
)
C#
public KeyedRequest (
    OrganizationRequest request,
    string key
)
C++

J#

JScript

Parameters
request
Type: OrganizationRequest
key
Type: String
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KeyedRequest Class
KeyedRequest Members
Microsoft.Xrm.Client.Services Namespace


KeyedRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

KeyedRequest Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


KeyedRequest Properties
[image]

Public Properties

 | Name | Description
public property | ExtensionData | (inherited from OrganizationRequest)
public property | Item | (inherited from OrganizationRequest)
public property | Key | Gets or sets a custom key value that is unique to the current request.
public property | Parameters | (inherited from OrganizationRequest)
public property | Request | Gets or sets the underlying request.
public property | RequestId | (inherited from OrganizationRequest)
public property | RequestName | (inherited from OrganizationRequest)

See Also

Reference

KeyedRequest Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


KeyedRequest.Key Property
[image]

Gets or sets a custom key value that is unique to the current request.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As KeyedRequest
Dim value As String

value = instance.Key

instance.Key = value

Syntax

Visual Basic
Public Property Key As String
C#
public string Key { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KeyedRequest Class
KeyedRequest Members
Microsoft.Xrm.Client.Services Namespace


KeyedRequest.Request Property
[image]

Gets or sets the underlying request.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As KeyedRequest
Dim value As OrganizationRequest

value = instance.Request

instance.Request = value

Syntax

Visual Basic
Public Property Request As OrganizationRequest
C#
public OrganizationRequest Request { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationRequest
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KeyedRequest Class
KeyedRequest Members
Microsoft.Xrm.Client.Services Namespace


KnownTypesProvider Class
See Also Members
[image]

This API supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Creates an array of Type objects that contain the types of individual profile properties. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
Public NotInheritable Class KnownTypesProvider
C#
public static class KnownTypesProvider
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.KnownTypesProvider
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KnownTypesProvider Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


KnownTypesProvider Members
See Also Fields Methods
[image]

This API supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Creates an array of Type objects that contain the types of individual profile properties. (Developer Extensions)

The following tables list the members exposed by the KnownTypesProvider type.

Public Fields

Name | Description
EntityKnownTypes | The types for serializing an Entity instance.
QueryExpressionKnownTypes | The types for serializing a QueryExpression instance.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

KnownTypesProvider Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


KnownTypesProvider Fields
[image]

Public Fields

Name | Description
EntityKnownTypes | The types for serializing an Entity instance.
QueryExpressionKnownTypes | The types for serializing a QueryExpression instance.

See Also

Reference

KnownTypesProvider Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


KnownTypesProvider.EntityKnownTypes Field
[image]

The types for serializing an Entity instance.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As IEnumerable(Of Type)

value = KnownTypesProvider.EntityKnownTypes

KnownTypesProvider.EntityKnownTypes = value

Syntax

Visual Basic
Public Shared EntityKnownTypes As IEnumerable(Of Type)
C#
public static IEnumerable<Type> EntityKnownTypes
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KnownTypesProvider Class
KnownTypesProvider Members
Microsoft.Xrm.Client.Services Namespace


KnownTypesProvider.QueryExpressionKnownTypes Field
[image]

The types for serializing a QueryExpression instance.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim value As IEnumerable(Of Type)

value = KnownTypesProvider.QueryExpressionKnownTypes

KnownTypesProvider.QueryExpressionKnownTypes = value

Syntax

Visual Basic
Public Shared QueryExpressionKnownTypes As IEnumerable(Of Type)
C#
public static IEnumerable<Type> QueryExpressionKnownTypes
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
KnownTypesProvider Class
KnownTypesProvider Members
Microsoft.Xrm.Client.Services Namespace


KnownTypesProvider Methods
[image]

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

KnownTypesProvider Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationService Class
See Also Members
[image]

A wrapper class around the IOrganizationService that manages the details of setting up an OrganizationServiceProxy or other arbitrary IOrganizationService objects. When paired with an OrganizationServiceCache object, becomes a cached service. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService

Syntax

Visual Basic
Public Class OrganizationService
    Implements IDisposable, IOrganizationService, IInitializable
C#
public class OrganizationService : IDisposable, IOrganizationService, IInitializable
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.OrganizationService

                Microsoft.Xrm.Client.Services.CachedOrganizationService
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Simplified Connection to Microsoft Dynamics CRM


OrganizationService Members
See Also Constructors Methods Properties
[image]

A wrapper class around the IOrganizationService that manages the details of setting up an OrganizationServiceProxy or other arbitrary IOrganizationService objects. When paired with an OrganizationServiceCache object, becomes a cached service. (Developer Extensions)

The following tables list the members exposed by the OrganizationService type.

Public Constructors

Name | Description
OrganizationService | Overloaded. Initializes a new instance of the OrganizationService class.
Top

Public Properties

 | Name | Description
public property | InnerService |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Associate | Creates a link between records. (Developer Extensions)
public method | Create | Creates a record. (Developer Extensions)
public method | Delete | Deletes a record. (Developer Extensions)
public method | Disassociate | Deletes a link between records. (Developer Extensions)
public method | Dispose |
public method | Equals | (inherited from Object)
public method | Execute | Executes a message in the form of a request, and returns a response. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize |
public method | Retrieve | Retrieves a record. (Developer Extensions)
public method | RetrieveMultiple | Retrieves a collection of records. (Developer Extensions)
public method | ToString | (inherited from Object)
public method | Update | Updates an existing record. (Developer Extensions)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CheckIfTokenIsExpired |
protected method | CreateServiceConfiguration |
protected method | CreateUserTokenResponse |
protected method | Finalize | (inherited from Object)
protected method | GetServiceConfiguration |
protected method | GetUserTokenResponse |
protected method | MemberwiseClone | (inherited from Object)
protected method | RegisterDeviceCredentials |
protected method | ToOrganizationService |
protected method | ToOrganizationServiceProxy |
Top

Extension Methods

 | Name | Description
public extension method | Execute | Extensions to the core Execute method. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | FetchXmlToQueryExpression | Extensions to the core FetchXmlToQueryExpressionRequest message. (Developer Extensions) (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | RetrieveEntity | Overloaded. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | RetrieveMultiple | Overloaded. Extensions to the core RetrieveMultiple method. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Simplified Connection to Microsoft Dynamics CRM


OrganizationService Constructor
[image]

Initializes a new instance of the OrganizationService class.

Overload List

Name | Description
OrganizationService (CrmConnection) | Initializes a new instance of the OrganizationService class.
OrganizationService (IOrganizationService) | Initializes a new instance of the OrganizationService class.
OrganizationService (String) | Initializes a new instance of the OrganizationService class.

See Also

Reference

OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace


OrganizationService Constructor (CrmConnection)
[image]

Initializes a new instance of the OrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection

Dim instance As New OrganizationService(connection)

Syntax

Visual Basic
Public Sub New ( _
    connection As CrmConnection _
)
C#
public OrganizationService (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace


OrganizationService Constructor (IOrganizationService)
[image]

Initializes a new instance of the OrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService

Dim instance As New OrganizationService(service)

Syntax

Visual Basic
Public Sub New ( _
    service As IOrganizationService _
)
C#
public OrganizationService (
    IOrganizationService service
)
C++

J#

JScript

Parameters
service
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace


OrganizationService Constructor (String)
[image]

Initializes a new instance of the OrganizationService class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionStringName As String

Dim instance As New OrganizationService(connectionStringName)

Syntax

Visual Basic
Public Sub New ( _
    connectionStringName As String _
)
C#
public OrganizationService (
    string connectionStringName
)
C++

J#

JScript

Parameters
connectionStringName
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace


OrganizationService Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Associate | Creates a link between records. (Developer Extensions)
public method | Create | Creates a record. (Developer Extensions)
public method | Delete | Deletes a record. (Developer Extensions)
public method | Disassociate | Deletes a link between records. (Developer Extensions)
public method | Dispose |
public method | Equals | (inherited from Object)
public method | Execute | Executes a message in the form of a request, and returns a response. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize |
public method | Retrieve | Retrieves a record. (Developer Extensions)
public method | RetrieveMultiple | Retrieves a collection of records. (Developer Extensions)
public method | ToString | (inherited from Object)
public method | Update | Updates an existing record. (Developer Extensions)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CheckIfTokenIsExpired |
protected method | CreateServiceConfiguration |
protected method | CreateUserTokenResponse |
protected method | Finalize | (inherited from Object)
protected method | GetServiceConfiguration |
protected method | GetUserTokenResponse |
protected method | MemberwiseClone | (inherited from Object)
protected method | RegisterDeviceCredentials |
protected method | ToOrganizationService |
protected method | ToOrganizationServiceProxy |

Extension Methods

 | Name | Description
public extension method | Execute | Extensions to the core Execute method. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | FetchXmlToQueryExpression | Extensions to the core FetchXmlToQueryExpressionRequest message. (Developer Extensions) (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | RetrieveEntity | Overloaded. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | RetrieveMultiple | Overloaded. Extensions to the core RetrieveMultiple method. (Developer Extensions) (Defined by OrganizationServiceExtensions.)
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Simplified Connection to Microsoft Dynamics CRM


OrganizationService.Associate Method
[image]

Creates a link between records. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim entityName As String
Dim entityId As Guid
Dim relationship As Relationship
Dim relatedEntities As EntityReferenceCollection

instance.Associate(entityName, entityId, relationship, relatedEntities)

Syntax

Visual Basic
Public Overridable Sub Associate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)
C#
public virtual void Associate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity that is specified in the entityId parameter.
entityId
Type: Guid.The ID of the record to which the related records are associated.
relationship
Type: Relationship. The name of the relationship to be used to create the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be associated.
  Remarks
This is a wrapper for the IOrganizationService. Associate Method.
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter and access rights on the record that is specified in the entityId parameter. For a list of the required privileges, see Associate Privileges.
Notes for Callers
This method creates multiple associations in one transaction between the record that is specified by the entityId parameter and each record in the relatedEntities parameter for the specified relationship in the relationship parameter.
For a one-to-many relationship, this method sets the ReferencingAttribute in the related record to the value of the entityId.
For a many-to-many relationship, this method creates a record in the intersect table for the relationship, which contains the ID of both the referenced and referencing records. The intersect table name is defined in the IntersectEntityName property for the relationship.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities
You can use this method to associate any records that participate in a relationship, including records for custom entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Access Entity Relationships
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.CheckIfTokenIsExpired Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim token As SecurityTokenResponse
Dim expiryWindow As Nullable(Of TimeSpan)
Dim returnValue As Boolean

returnValue = Me.CheckIfTokenIsExpired(token, expiryWindow)

Syntax

Visual Basic
Protected Function CheckIfTokenIsExpired ( _
    token As SecurityTokenResponse, _
    expiryWindow As Nullable(Of TimeSpan) _
) As Boolean
C#
protected bool CheckIfTokenIsExpired (
    SecurityTokenResponse token,
    Nullable<TimeSpan> expiryWindow
)
C++

J#

JScript

Parameters
token
expiryWindow
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace


OrganizationService.Create Method
[image]

Creates a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim entity As Entity
Dim returnValue As Guid

returnValue = instance.Create(entity)

Syntax

Visual Basic
Public Overridable Function Create ( _
    entity As Entity _
) As Guid
C#
public virtual Guid Create (
    Entity entity
)
C++

J#

JScript

Parameters
entity
An entity instance that contains the properties to set in the newly created record.
Return Value
Type: Guid

The ID of the newly created record.

  Remarks
This is a wrapper for the IOrganizationService. Create Method.
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entity parameter. For a list of the required privileges, see Create Privileges.
Notes for Callers
This method creates one record in a transaction. To create a record that has related records in a transaction, use CreateRequest.
By default the caller becomes the owner for the new record. However, for the caller to own the new record, it must have both Create and Read privileges for the entity. For more information, see Privileges by Entity. Alternatively, you can set the ownerid property to the ID of another user.
The entity instance that is specified as a parameter must contain values for all the attributes where the RequiredLevel is set to SystemRequired. You can see this in the metadata topic for the entity. If the entity instance includes properties where IsValidForCreate is false, the values are ignored. You can find this information in the metadata for your organization. See the preceding metadata browser information.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities
You can use this method to create any record of an entity that supports the Create message, including custom entities.

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
account | Both
activitymimeattachment | Both
annotation | Both
annualfiscalcalendar | Both
appointment | Both
asyncoperation | Server
attributemap | Server
businessunit | Server
businessunitnewsarticle | Both
calendar | Both
campaign | Both
campaignactivity | Both
campaignresponse | Both
columnmapping | Both
competitor | Both
connection | Both
connectionrole | Both
connectionroleobjecttypecode | Both
constraintbasedgroup | Both
contact | Both
contract | Both
contractdetail | Both
contracttemplate | Server
customeraddress | Both
customeropportunityrole | Both
customerrelationship | Both
discount | Server
discounttype | Server
duplicaterule | Server
duplicaterulecondition | Server
email | Both
equipment | Server
fax | Both
fieldpermission | Server
fieldsecurityprofile | Server
fixedmonthlyfiscalcalendar | Both
goal | Server
goalrollupquery | Server
import | Both
importentitymapping | Both
importfile | Both
importjob | Both
importmap | Both
incident | Both
incidentresolution | Both
invoice | Both
invoicedetail | Both
isvconfig | Server
kbarticle | Both
kbarticlecomment | Both
kbarticletemplate | Both
lead | Both
letter | Both
list | Both
lookupmapping | Both
mailmergetemplate | Both
metric | Server
monthlyfiscalcalendar | Both
msdyn_postalbum | Server
msdyn_postconfig | Server
msdyn_postruleconfig | Server
opportunity | Both
opportunityclose | Both
opportunityproduct | Both
orderclose | Both
organizationui | Server
ownermapping | Both
phonecall | Both
picklistmapping | Both
pluginassembly | Server
plugintype | Server
post | Server
postcomment | Server
postfollow | Server
postlike | Server
pricelevel | Server
principalobjectattributeaccess | Server
processsession | Both
product | Server
productpricelevel | Server
publisher | Server
publisheraddress | Server
quarterlyfiscalcalendar | Both
queue | Server
queueitem | Both
quote | Both
quoteclose | Both
quotedetail | Both
recurrencerule | Server
recurringappointmentmaster | Both
relationshiprole | Both
relationshiprolemap | Both
report | Server
reportcategory | Server
reportentity | Server
reportvisibility | Server
resourcespec | Both
role | Server
rollupfield | Server
salesliterature | Server
salesliteratureitem | Server
salesorder | Both
salesorderdetail | Both
savedquery | Server
savedqueryvisualization | Server
sdkmessageprocessingstep | Server
sdkmessageprocessingstepimage | Server
sdkmessageprocessingstepsecureconfig | Server
semiannualfiscalcalendar | Both
service | Server
serviceappointment | Both
serviceendpoint | Server
sharepointdocumentlocation | Server
sharepointsite | Server
site | Server
solution | Server
subject | Both
systemform | Server
systemuser | Server
task | Both
team | Server
template | Both
territory | Server
transactioncurrency | Server
transformationmapping | Both
transformationparametermapping | Both
uom | Server
uomschedule | Both
userentityinstancedata | Both
userentityuisettings | Both
userform | Server
userquery | Both
userqueryvisualization | Both
webresource | Server
workflow | Server
workflowdependency | Server
workflowlog | Server

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Model Your Business Data
Access Entity Relationships
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.CreateServiceConfiguration Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As IServiceConfiguration(Of IOrganizationService)

returnValue = Me.CreateServiceConfiguration(connection)

Syntax

Visual Basic
Protected Overridable Function CreateServiceConfiguration ( _
    connection As CrmConnection _
) As IServiceConfiguration(Of IOrganizationService)
C#
protected virtual IServiceConfiguration<IOrganizationService> CreateServiceConfiguration (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Return Value
Returns IServiceConfiguration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.CreateUserTokenResponse Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim config As IServiceConfiguration(Of IOrganizationService)
Dim returnValue As SecurityTokenResponse

returnValue = Me.CreateUserTokenResponse(connection, config)

Syntax

Visual Basic
Protected Overridable Function CreateUserTokenResponse ( _
    connection As CrmConnection, _
    config As IServiceConfiguration(Of IOrganizationService) _
) As SecurityTokenResponse
C#
protected virtual SecurityTokenResponse CreateUserTokenResponse (
    CrmConnection connection,
    IServiceConfiguration<IOrganizationService> config
)
C++

J#

JScript

Parameters
connection
config
Return Value
Returns SecurityTokenResponse.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.Delete Method
[image]

Deletes a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim entityName As String
Dim id As Guid

instance.Delete(entityName, id)

Syntax

Visual Basic
Public Overridable Sub Delete ( _
    entityName As String, _
    id As Guid _
)
C#
public virtual void Delete (
    string entityName,
    Guid id
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity that is specified in the entityId parameter.
id
Type: Guid. The ID of the record that you want to delete.
  Remarks
This is a wrapper for the IOrganizationService. Delete Method.
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter and access rights on the record that is specified in the id parameter. For a list of the required privileges, see Delete Privileges. When a record is deleted, all child records are also deleted. The entire deletion fails if the caller does not have the delete privilege or access rights for any of these records.
Notes for Callers
This method may cascade to related records according to the cascade configuration for each entity relationship. For a description of how actions on a parent record affect related records, see Cascading behavior.
Typically, you should only delete records that you entered by mistake. For some record types, you can deactivate or close the record instead.
You can use this method to delete any record of an entity that supports the Delete message, including records from custom entities.
For more information about the exceptions that can be thrown when you call this method, see Handle Exceptions in Your Code.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
account | Both
activitymimeattachment | Both
annotation | Both
annualfiscalcalendar | Both
appointment | Both
asyncoperation | Server
attributemap | Server
bulkdeleteoperation | Server
bulkoperation | Server
businessunit | Server
businessunitnewsarticle | Both
calendar | Both
campaign | Both
campaignactivity | Both
campaignresponse | Both
columnmapping | Both
competitor | Both
connection | Both
connectionrole | Both
connectionroleobjecttypecode | Both
constraintbasedgroup | Both
contact | Both
contract | Server
contractdetail | Server
contracttemplate | Server
customeraddress | Both
customeropportunityrole | Both
customerrelationship | Both
discount | Server
discounttype | Server
duplicaterule | Server
duplicaterulecondition | Server
email | Both
equipment | Server
fax | Both
fieldpermission | Server
fieldsecurityprofile | Server
fixedmonthlyfiscalcalendar | Both
goal | Server
goalrollupquery | Server
import | Both
importentitymapping | Both
importfile | Both
importjob | Both
importmap | Both
incident | Both
incidentresolution | Both
invoice | Both
invoicedetail | Both
isvconfig | Server
kbarticle | Both
kbarticlecomment | Both
kbarticletemplate | Both
lead | Both
letter | Both
list | Server
lookupmapping | Both
mailmergetemplate | Both
metric | Server
monthlyfiscalcalendar | Both
msdyn_postalbum | Server
msdyn_postconfig | Server
msdyn_postruleconfig | Server
opportunity | Both
opportunityclose | Both
opportunityproduct | Both
orderclose | Both
ownermapping | Both
phonecall | Both
picklistmapping | Both
pluginassembly | Server
plugintype | Server
post | Server
postcomment | Server
postfollow | Server
postlike | Server
pricelevel | Both
principalobjectattributeaccess | Server
processsession | Both
product | Both
productpricelevel | Both
publisher | Server
publisheraddress | Server
quarterlyfiscalcalendar | Both
queue | Server
queueitem | Both
quote | Both
quoteclose | Both
quotedetail | Both
recurrencerule | Both
recurringappointmentmaster | Both
relationshiprole | Both
relationshiprolemap | Both
report | Server
reportcategory | Server
reportentity | Server
reportvisibility | Server
resourcespec | Both
role | Server
rollupfield | Server
salesliterature | Server
salesliteratureitem | Server
salesorder | Both
salesorderdetail | Both
savedquery | Server
savedqueryvisualization | Server
sdkmessageprocessingstep | Server
sdkmessageprocessingstepimage | Server
sdkmessageprocessingstepsecureconfig | Server
semiannualfiscalcalendar | Both
service | Server
serviceappointment | Both
serviceendpoint | Server
sharepointdocumentlocation | Server
sharepointsite | Server
site | Server
solution | Server
subject | Both
systemform | Server
task | Both
team | Server
template | Both
territory | Server
transactioncurrency | Server
transformationmapping | Both
transformationparametermapping | Both
uom | Server
uomschedule | Both
userentityinstancedata | Both
userentityuisettings | Both
userform | Server
userquery | Both
userqueryvisualization | Both
webresource | Server
workflow | Server
workflowdependency | Server
workflowlog | Server

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.Disassociate Method
[image]

Deletes a link between records. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim entityName As String
Dim entityId As Guid
Dim relationship As Relationship
Dim relatedEntities As EntityReferenceCollection

instance.Disassociate(entityName, entityId, relationship, relatedEntities)

Syntax

Visual Basic
Public Overridable Sub Disassociate ( _
    entityName As String, _
    entityId As Guid, _
    relationship As Relationship, _
    relatedEntities As EntityReferenceCollection _
)
C#
public virtual void Disassociate (
    string entityName,
    Guid entityId,
    Relationship relationship,
    EntityReferenceCollection relatedEntities
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity that is specified in the entityId parameter.
entityId
Type: Guid. The ID of the record from which the related records are disassociated.
relationship
Type: Relationship. The name of the relationship to be used to remove the link.
relatedEntities
Type: EntityReferenceCollection. A collection of entity references (references to records) to be disassociated.
  Remarks
This is a wrapper for the IOrganizationService. Disassociate Method.
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter and access rights on the records that are specified in the entityId and relatedEntities parameters. For a list of the required privileges, see Disassociate Privileges.
Notes for Callers
This method removes multiple associations in one transaction between the record that is specified by the entityId parameter and each record in the relatedEntities parameter for the relationship that is specified in the relationship parameter.
For a one-to-many relationship, this method clears the ReferencingAttribute in the related record to the value of entityId.
For a many-to-many relationship, this method deletes a record in the intersect table for the relationship. The intersect table name is defined in the IntersectEntityName property for the relationship.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities
You can use this method to disassociate any records that participate in a relationship, including records for custom entities.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Access Entity Relationships
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.Dispose Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService

instance.Dispose

Syntax

Visual Basic
Public Overridable Sub Dispose
C#
public virtual void Dispose ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace


OrganizationService.Execute Method
[image]

Executes a message in the form of a request, and returns a response. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim request As OrganizationRequest
Dim returnValue As OrganizationResponse

returnValue = instance.Execute(request)

Syntax

Visual Basic
Public Overridable Function Execute ( _
    request As OrganizationRequest _
) As OrganizationResponse
C#
public virtual OrganizationResponse Execute (
    OrganizationRequest request
)
C++

J#

JScript

Parameters
request
A request instance that defines the action to be performed.
Return Value
Returns OrganizationResponse. You must cast the return value of this method to the specific instance of the response that corresponds to the Request parameter.

  Remarks
This is a wrapper for the IOrganizationService. Execute Method.
Privileges and Access Rights
To execute the message, the caller must have the necessary privileges to the entity type that is specified in the request class. The caller must also have access rights on the specified records in the request class. For more information, see the Request class for the action you want to execute. For example, see AssignRequest.
Notes for Callers
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Method Availability
This method works regardless whether the caller is connected to the server or offline.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Use Messages (Request and Response Classes) with the Execute Method
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.GetServiceConfiguration Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As IServiceConfiguration(Of IOrganizationService)

returnValue = Me.GetServiceConfiguration(connection)

Syntax

Visual Basic
Protected Overridable Function GetServiceConfiguration ( _
    connection As CrmConnection _
) As IServiceConfiguration(Of IOrganizationService)
C#
protected virtual IServiceConfiguration<IOrganizationService> GetServiceConfiguration (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Return Value
Returns IServiceConfiguration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.GetUserTokenResponse Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim config As IServiceConfiguration(Of IOrganizationService)
Dim returnValue As SecurityTokenResponse

returnValue = Me.GetUserTokenResponse(connection, config)

Syntax

Visual Basic
Protected Overridable Function GetUserTokenResponse ( _
    connection As CrmConnection, _
    config As IServiceConfiguration(Of IOrganizationService) _
) As SecurityTokenResponse
C#
protected virtual SecurityTokenResponse GetUserTokenResponse (
    CrmConnection connection,
    IServiceConfiguration<IOrganizationService> config
)
C++

J#

JScript

Parameters
connection
config
Return Value
Returns SecurityTokenResponse.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace


OrganizationService.Initialize Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim name As String
Dim config As NameValueCollection

instance.Initialize(name, config)

Syntax

Visual Basic
Public Overridable Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
C#
public virtual void Initialize (
    string name,
    NameValueCollection config
)
C++

J#

JScript

Parameters
name
config
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.RegisterDeviceCredentials Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim deviceCredentials As ClientCredentials
Dim returnValue As Boolean

returnValue = Me.RegisterDeviceCredentials(deviceCredentials)

Syntax

Visual Basic
Protected Function RegisterDeviceCredentials ( _
    deviceCredentials As ClientCredentials _
) As Boolean
C#
protected bool RegisterDeviceCredentials (
    ClientCredentials deviceCredentials
)
C++

J#

JScript

Parameters
deviceCredentials
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.Retrieve Method
[image]

Retrieves a record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim entityName As String
Dim id As Guid
Dim columnSet As ColumnSet
Dim returnValue As Entity

returnValue = instance.Retrieve(entityName, id, columnSet)

Syntax

Visual Basic
Public Overridable Function Retrieve ( _
    entityName As String, _
    id As Guid, _
    columnSet As ColumnSet _
) As Entity
C#
public virtual Entity Retrieve (
    string entityName,
    Guid id,
    ColumnSet columnSet
)
C++

J#

JScript

Parameters
entityName
Type: String. The logical name of the entity that is specified in the entityId parameter.
id
Type: Guid. The ID of the record that you want to retrieve.
columnSet
Type: ColumnSet. A query that specifies the set of columns, or attributes, to retrieve.
Return Value
Returns the requested Entity.

  Remarks
This is a wrapper for the IOrganizationService. Retrieve Method.
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter and access rights on the record that is specified in the id parameter. For a list of the required privileges, see Retrieve Privileges.
Notes for Callers
The returned record contains values for the specified properties in the columnSet parameter for which the calling user has access rights. Any other property values are not returned. For more information, see The Security Model of Microsoft Dynamics CRM.
Pass null for the columnSet parameter to retrieve only the primary key. If the columnSet includes attributes where IsValidForRead is false, they are ignored. You can find this information in the metadata for your organization. See the preceding metadata browser information.
To retrieve a record and its related records in a single transaction, use the RetrieveRequest class.
You can use this method to retrieve any record of an entity that supports the Retrieve message, including custom entities.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Availability
account | Both
activitymimeattachment | Both
activitypointer | Both
annotation | Both
annualfiscalcalendar | Both
appointment | Both
asyncoperation | Both
attributemap | Server
audit | Server
bulkdeletefailure | Both
bulkdeleteoperation | Both
bulkoperation | Both
bulkoperationlog | Both
businessunit | Both
businessunitnewsarticle | Both
calendar | Both
campaign | Both
campaignactivity | Both
campaignresponse | Both
columnmapping | Both
competitor | Both
connection | Both
connectionrole | Both
connectionroleobjecttypecode | Both
constraintbasedgroup | Both
contact | Both
contract | Both
contractdetail | Both
contracttemplate | Both
customeraddress | Both
customeropportunityrole | Both
customerrelationship | Both
dependency | Server
discount | Both
discounttype | Both
displaystring | Both
duplicaterecord | Server
duplicaterule | Server
duplicaterulecondition | Server
email | Both
entitymap | Server
equipment | Both
fax | Both
fieldpermission | Server
fieldsecurityprofile | Server
fixedmonthlyfiscalcalendar | Both
goal | Both
goalrollupquery | Both
import | Both
importentitymapping | Both
importfile | Both
importjob | Both
importlog | Both
importmap | Both
incident | Both
incidentresolution | Both
invaliddependency | Server
invoice | Both
invoicedetail | Both
isvconfig | Server
kbarticle | Both
kbarticlecomment | Both
kbarticletemplate | Both
lead | Both
leadaddress | Both
letter | Both
list | Both
lookupmapping | Both
mailmergetemplate | Both
metric | Both
monthlyfiscalcalendar | Both
msdyn_postalbum | Server
msdyn_postconfig | Server
msdyn_postruleconfig | Server
opportunity | Both
opportunityclose | Both
opportunityproduct | Both
orderclose | Both
organization | Both
organizationui | Both
ownermapping | Both
phonecall | Both
picklistmapping | Both
pluginassembly | Both
plugintype | Both
plugintypestatistic | Server
post | Server
postcomment | Server
postfollow | Server
postlike | Server
pricelevel | Both
principalobjectattributeaccess | Both
privilege | Both
processsession | Both
product | Both
productpricelevel | Both
publisher | Both
publisheraddress | Server
quarterlyfiscalcalendar | Both
queue | Both
queueitem | Both
quote | Both
quoteclose | Both
quotedetail | Both
recurrencerule | Both
recurringappointmentmaster | Both
relationshiprole | Both
relationshiprolemap | Both
report | Both
reportcategory | Both
reportentity | Both
reportlink | Both
reportvisibility | Both
resource | Both
resourcegroup | Both
resourcespec | Both
role | Both
rollupfield | Both
salesliterature | Both
salesliteratureitem | Both
salesorder | Both
salesorderdetail | Both
savedquery | Both
savedqueryvisualization | Both
sdkmessage | Both
sdkmessagefilter | Both
sdkmessagepair | Both
sdkmessageprocessingstep | Both
sdkmessageprocessingstepimage | Both
sdkmessageprocessingstepsecureconfig | Server
sdkmessagerequest | Both
sdkmessagerequestfield | Both
sdkmessageresponse | Both
sdkmessageresponsefield | Both
semiannualfiscalcalendar | Both
service | Both
serviceappointment | Both
serviceendpoint | Server
sharepointdocumentlocation | Server
sharepointsite | Server
site | Both
sitemap | Both
solution | Both
solutioncomponent | Both
subject | Both
systemform | Both
systemuser | Both
task | Both
team | Both
template | Both
territory | Both
timezonedefinition | Both
timezonelocalizedname | Both
timezonerule | Both
transactioncurrency | Both
transformationmapping | Both
transformationparametermapping | Both
uom | Both
uomschedule | Both
userentityinstancedata | Both
userentityuisettings | Both
userform | Both
userquery | Both
userqueryvisualization | Both
usersettings | Both
webresource | Both
workflow | Server
workflowdependency | Server
workflowlog | Server

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.RetrieveMultiple Method
[image]

Retrieves a collection of records. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = instance.RetrieveMultiple(query)

Syntax

Visual Basic
Public Overridable Function RetrieveMultiple ( _
    query As QueryBase _
) As EntityCollection
C#
public virtual EntityCollection RetrieveMultiple (
    QueryBase query
)
C++

J#

JScript

Parameters
query
Type: QueryBase. A query that determines the set of records to retrieve.
Return Value
Returns EntityCollection.

  Remarks
This is a wrapper for the IOrganizationService. RetrieveMultiple Method.
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity that is specified in the entityName parameter. For a list of the required privileges, see RetrieveMultiple Privileges. This method only returns the records for which the calling user has access rights.
Notes for Callers
The collection of returned records contains the values for the properties that are specified in the ColumnSet parameter for which the calling user has access rights. Any other property values are not returned.
Pass null for the columnSet parameter to retrieve only the primary key. If the columnSet includes attributes that are not valid for retrieval, they are ignored. This is where IsValidForRead is false. You can find this information in the metadata for your organization. See the preceding metadata browser information.
You can use this method to retrieve records of an entity that supports the RetrieveMultiple message, including records from custom entities.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

Entity | Aavailability
account | Both
accountleads | Both
activitymimeattachment | Both
activityparty | Both
activitypointer | Both
annotation | Both
annualfiscalcalendar | Both
appointment | Both
asyncoperation | Both
attributemap | Server
audit | Server
bulkdeletefailure | Both
bulkdeleteoperation | Both
bulkoperation | Both
bulkoperationlog | Both
businessunit | Both
businessunitnewsarticle | Both
calendar | Both
campaign | Both
campaignactivity | Both
campaignactivityitem | Both
campaignitem | Both
campaignresponse | Both
columnmapping | Both
competitor | Both
competitorproduct | Both
competitorsalesliterature | Both
connection | Both
connectionrole | Both
connectionroleassociation | Both
connectionroleobjecttypecode | Both
constraintbasedgroup | Both
contact | Both
contactinvoices | Both
contactleads | Both
contactorders | Both
contactquotes | Both
contract | Both
contractdetail | Both
contracttemplate | Both
customeraddress | Both
customeropportunityrole | Both
customerrelationship | Both
dependency | Server
discount | Both
discounttype | Both
displaystring | Both
duplicaterecord | Server
duplicaterule | Server
duplicaterulecondition | Both
email | Both
entitymap | Server
equipment | Both
fax | Both
fieldpermission | Server
fieldsecurityprofile | Server
fixedmonthlyfiscalcalendar | Both
goal | Both
goalrollupquery | Both
import | Both
importentitymapping | Both
importfile | Both
importjob | Both
importlog | Both
importmap | Both
incident | Both
incidentresolution | Both
invaliddependency | Server
invoice | Both
invoicedetail | Both
isvconfig | Both
kbarticle | Both
kbarticlecomment | Both
kbarticletemplate | Both
lead | Both
leadaddress | Both
leadcompetitors | Both
leadproduct | Both
letter | Both
license | Both
list | Both
listmember | Both
lookupmapping | Both
mailmergetemplate | Both
metric | Both
monthlyfiscalcalendar | Both
msdyn_postalbum | Server
msdyn_postconfig | Server
msdyn_postruleconfig | Server
opportunity | Both
opportunityclose | Both
opportunitycompetitors | Both
opportunityproduct | Both
orderclose | Both
organization | Both
organizationui | Both
ownermapping | Both
phonecall | Both
picklistmapping | Both
pluginassembly | Both
plugintype | Both
plugintypestatistic | Server
post | Server
postcomment | Server
postfollow | Server
postlike | Server
pricelevel | Both
principalobjectattributeaccess | Both
privilege | Both
processsession | Both
product | Both
productassociation | Both
productpricelevel | Both
productsalesliterature | Both
productsubstitute | Both
publisher | Both
publisheraddress | Server
quarterlyfiscalcalendar | Both
queue | Both
queueitem | Both
quote | Both
quoteclose | Both
quotedetail | Both
recurrencerule | Both
recurringappointmentmaster | Both
relationshiprole | Both
relationshiprolemap | Both
report | Both
reportcategory | Both
reportentity | Both
reportlink | Both
reportvisibility | Both
resource | Both
resourcegroup | Both
resourcespec | Both
role | Both
roleprivileges | Both
rollupfield | Both
salesliterature | Both
salesliteratureitem | Both
salesorder | Both
salesorderdetail | Both
savedquery | Both
savedqueryvisualization | Both
sdkmessage | Both
sdkmessagefilter | Both
sdkmessagepair | Both
sdkmessageprocessingstep | Both
sdkmessageprocessingstepimage | Both
sdkmessageprocessingstepsecureconfig | Server
sdkmessagerequest | Both
sdkmessagerequestfield | Both
sdkmessageresponse | Both
sdkmessageresponsefield | Both
semiannualfiscalcalendar | Both
service | Both
serviceappointment | Both
servicecontractcontacts | Both
serviceendpoint | Server
sharepointdocumentlocation | Server
sharepointsite | Server
site | Both
sitemap | Both
solution | Both
solutioncomponent | Both
subject | Both
systemform | Both
systemuser | Both
systemuserlicenses | Both
systemuserprofiles | Server
systemuserroles | Both
task | Both
team | Both
teammembership | Both
teamprofiles | Server
teamroles | Both
template | Both
territory | Both
timezonedefinition | Both
timezonelocalizedname | Both
timezonerule | Both
transactioncurrency | Both
transformationmapping | Both
transformationparametermapping | Both
uom | Both
uomschedule | Both
userentityinstancedata | Both
userentityuisettings | Both
userform | Both
userquery | Both
userqueryvisualization | Both
usersettings | Both
webresource | Both
workflow | Server
workflowdependency | Server
workflowlog | Server

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM
Creating Queries to Retrieve Data


OrganizationService.ToOrganizationService Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As IOrganizationService

returnValue = Me.ToOrganizationService(connection)

Syntax

Visual Basic
Protected Overridable Function ToOrganizationService ( _
    connection As CrmConnection _
) As IOrganizationService
C#
protected virtual IOrganizationService ToOrganizationService (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Return Value
Returns IOrganizationService.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.ToOrganizationServiceProxy Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection
Dim returnValue As OrganizationServiceProxy

returnValue = Me.ToOrganizationServiceProxy(connection)

Syntax

Visual Basic
Protected Overridable Function ToOrganizationServiceProxy ( _
    connection As CrmConnection _
) As OrganizationServiceProxy
C#
protected virtual OrganizationServiceProxy ToOrganizationServiceProxy (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
Return Value
Returns OrganizationServiceProxy.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService.Update Method
[image]

Updates an existing record. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim entity As Entity

instance.Update(entity)

Syntax

Visual Basic
Public Overridable Sub Update ( _
    entity As Entity _
)
C#
public virtual void Update (
    Entity entity
)
C++

J#

JScript

Parameters
entity
An entity instance that has one or more properties set to be updated in the record.
  Remarks
This is a wrapper for the IOrganizationService. Update Method.
Message Availability

                        This message works regardless whether the caller is connected to the server or offline.

Not all entity types support this message offline. See Supported Entities later in this topic.
Privileges and Access Rights
To perform this action, the caller must have privileges on the entity and access rights on the record specified in the Update parameter.. For a list of the required privileges, see Update Privileges.
Notes for Callers
If the entity instance includes properties that are not valid for update, they are ignored. You can find this information in the metadata for your organization. See the preceding metadata browser information.
You can use this method to update any record of an entity that supports the Update message, including custom entities.
For more information about the exceptions that can be thrown when this method is called, see Handle Exceptions in Your Code.
Supported Entities

                        The following table shows the default entities that support this message. For the listed entities of this message, the Availability column shows Server if the caller must be connected to the server and shows Both if the caller can be either connected to, or disconnected from, the server.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions Context Object Model
Developer Extensions for Microsoft Dynamics CRM


OrganizationService Properties
[image]

Public Properties

 | Name | Description
public property | InnerService |

See Also

Reference

OrganizationService Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM
Simplified Connection to Microsoft Dynamics CRM


OrganizationService.InnerService Property
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationService
Dim value As IOrganizationService

value = instance.InnerService

Syntax

Visual Basic
Public ReadOnly Property InnerService As IOrganizationService
C#
public IOrganizationService InnerService { get; }
C++

J#

JScript

Property Value
Returns IOrganizationService.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationService Class
OrganizationService Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache Class
See Also Members
[image]

An abstracted data caching service that caches the results of IOrganizationService operations. Automatically sets up cache item dependencies and performing update operations invalidates dependent cache items. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache

Syntax

Visual Basic
Public Class OrganizationServiceCache
    Implements IOrganizationServiceCache, IInitializable
C#
public class OrganizationServiceCache : IOrganizationServiceCache, IInitializable
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.OrganizationServiceCache
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCache Members
See Also Constructors Methods Properties
[image]

An abstracted data caching service that caches the results of IOrganizationService operations. Automatically sets up cache item dependencies and performing update operations invalidates dependent cache items. (Developer Extensions)

The following tables list the members exposed by the OrganizationServiceCache type.

Public Constructors

Name | Description
OrganizationServiceCache | Overloaded. Initializes a new instance of the OrganizationServiceCache class.
Top

Public Properties

 | Name | Description
public property | Cache |
public property | CacheEntryChangeMonitorPrefix |
public property | CacheRegionName |
public property | ConnectionId |
public property | Mode |
public property | QueryHashingEnabled |
public property | ReturnMode |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | Execute | Executes an organization service message. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize |
public method | Insert |
public method | Remove | Overloaded.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CloneResponse |
protected method | Finalize | (inherited from Object)
protected method | GetBaseCachePolicy |
protected method | GetCacheKey |
protected method | GetCachePolicy |
protected method | MemberwiseClone | (inherited from Object)
protected method | TryGetCacheKey |
protected method | TryGetCachePolicy |
protected method | TryGetDependencies |
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceCache Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCache Constructor
[image]

Initializes a new instance of the OrganizationServiceCache class.

Overload List

Name | Description
OrganizationServiceCache () | Initializes a new instance of the OrganizationServiceCache class.
OrganizationServiceCache (ObjectCache) | Initializes a new instance of the OrganizationServiceCache class.
OrganizationServiceCache (ObjectCache, CrmConnection) | Initializes a new instance of the OrganizationServiceCache class.
OrganizationServiceCache (ObjectCache, OrganizationServiceCacheSettings) | Initializes a new instance of the OrganizationServiceCache class.
OrganizationServiceCache (ObjectCache, String) | Initializes a new instance of the OrganizationServiceCache class.

See Also

Reference

OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache Constructor ()
[image]

Initializes a new instance of the OrganizationServiceCache class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New OrganizationServiceCache

Syntax

Visual Basic
Public Sub New
C#
public OrganizationServiceCache ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache Constructor (ObjectCache)
[image]

Initializes a new instance of the OrganizationServiceCache class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache

Dim instance As New OrganizationServiceCache(cache)

Syntax

Visual Basic
Public Sub New ( _
    cache As ObjectCache _
)
C#
public OrganizationServiceCache (
    ObjectCache cache
)
C++

J#

JScript

Parameters
cache
Type: ObjectCache
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache Constructor (ObjectCache, CrmConnection)
[image]

Initializes a new instance of the OrganizationServiceCache class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim connection As CrmConnection

Dim instance As New OrganizationServiceCache(cache, connection)

Syntax

Visual Basic
Public Sub New ( _
    cache As ObjectCache, _
    connection As CrmConnection _
)
C#
public OrganizationServiceCache (
    ObjectCache cache,
    CrmConnection connection
)
C++

J#

JScript

Parameters
cache
Type: ObjectCache
connection
Type: CrmConnection
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache Constructor (ObjectCache, OrganizationServiceCacheSettings)
[image]

Initializes a new instance of the OrganizationServiceCache class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim settings As OrganizationServiceCacheSettings

Dim instance As New OrganizationServiceCache(cache, settings)

Syntax

Visual Basic
Public Sub New ( _
    cache As ObjectCache, _
    settings As OrganizationServiceCacheSettings _
)
C#
public OrganizationServiceCache (
    ObjectCache cache,
    OrganizationServiceCacheSettings settings
)
C++

J#

JScript

Parameters
cache
Type: ObjectCache
settings
OrganizationServiceCacheSettings
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache Constructor (ObjectCache, String)
[image]

Initializes a new instance of the OrganizationServiceCache class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim cache As ObjectCache
Dim connectionId As String

Dim instance As New OrganizationServiceCache(cache, connectionId)

Syntax

Visual Basic
Public Sub New ( _
    cache As ObjectCache, _
    connectionId As String _
)
C#
public OrganizationServiceCache (
    ObjectCache cache,
    string connectionId
)
C++

J#

JScript

Parameters
cache
Type: ObjectCache
connectionId
Type: String
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | Execute | Executes an organization service message. (Developer Extensions)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Initialize |
public method | Insert |
public method | Remove | Overloaded.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | CloneResponse |
protected method | Finalize | (inherited from Object)
protected method | GetBaseCachePolicy |
protected method | GetCacheKey |
protected method | GetCachePolicy |
protected method | MemberwiseClone | (inherited from Object)
protected method | TryGetCacheKey |
protected method | TryGetCachePolicy |
protected method | TryGetDependencies |

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceCache Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCache.CloneResponse Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim item As TResult
Dim returnValue As TResult

returnValue = Me.CloneResponse(item)

Syntax

Visual Basic
Protected Overridable Function CloneResponse(Of TResult) ( _
    item As TResult _
) As TResult
C#
protected virtual TResult CloneResponse<TResult> (
    TResult item
)
C++

J#

JScript

GenericParameters
TResult
Parameters
item
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Execute Method
[image]

Executes an organization service message. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim request As OrganizationRequest
Dim execute As Func(Of OrganizationRequest, OrganizationResponse)
Dim selector As Func(Of OrganizationResponse, T)
Dim selectorCacheKey As String
Dim returnValue As T

returnValue = instance.Execute(request, execute, selector, selectorCacheKey)

Syntax

Visual Basic
Public Function Execute(Of T) ( _
    request As OrganizationRequest, _
    execute As Func(Of OrganizationRequest, OrganizationResponse), _
    selector As Func(Of OrganizationResponse, T), _
    selectorCacheKey As String _
) As T
C#
public T Execute<T> (
    OrganizationRequest request,
    Func<OrganizationRequest,OrganizationResponse> execute,
    Func<OrganizationResponse,T> selector,
    string selectorCacheKey
)
C++

J#

JScript

GenericParameters
T
Parameters
request
execute
selector
selectorCacheKey
Type: String
Return Value
Type: {0}.

  Remarks
This is a wrapper around the core OrganizationServiceProxy. Execute method.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCache.GetBaseCachePolicy Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim returnValue As CacheItemPolicy

returnValue = Me.GetBaseCachePolicy

Syntax

Visual Basic
Protected Function GetBaseCachePolicy As CacheItemPolicy
C#
protected CacheItemPolicy GetBaseCachePolicy ()
C++

J#

JScript

Return Value
Type: CacheItemPolicy
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.GetCacheKey Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim request As Object
Dim returnValue As String

returnValue = Me.GetCacheKey(request)

Syntax

Visual Basic
Protected Function GetCacheKey ( _
    request As Object _
) As String
C#
protected string GetCacheKey (
    Object request
)
C++

J#

JScript

Parameters
request
Type: Object
Return Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.GetCachePolicy Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim query As Object
Dim result As Object
Dim returnValue As CacheItemPolicy

returnValue = Me.GetCachePolicy(query, result)

Syntax

Visual Basic
Protected Function GetCachePolicy ( _
    query As Object, _
    result As Object _
) As CacheItemPolicy
C#
protected CacheItemPolicy GetCachePolicy (
    Object query,
    Object result
)
C++

J#

JScript

Parameters
query
Type: Object
result
Type: Object
Return Value
Type: CacheItemPolicy
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Initialize Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim name As String
Dim config As NameValueCollection

instance.Initialize(name, config)

Syntax

Visual Basic
Public Overridable Sub Initialize ( _
    name As String, _
    config As NameValueCollection _
)
C#
public virtual void Initialize (
    string name,
    NameValueCollection config
)
C++

J#

JScript

Parameters
name
Type: String
config
Type: NameValueCollection
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Insert Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim key As String
Dim query As Object
Dim result As Object

instance.Insert(key, query, result)

Syntax

Visual Basic
Public Sub Insert ( _
    key As String, _
    query As Object, _
    result As Object _
)
C#
public void Insert (
    string key,
    Object query,
    Object result
)
C++

J#

JScript

Parameters
key
Type: String
query
Type: Object
result
Type: Object
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Remove Method
[image]

Overload List

Name | Description
OrganizationServiceCache.Remove (OrganizationServiceCachePluginMessage) |
OrganizationServiceCache.Remove (Entity) |
OrganizationServiceCache.Remove (EntityReference) |
OrganizationServiceCache.Remove (OrganizationRequest) |
OrganizationServiceCache.Remove (String) |
OrganizationServiceCache.Remove (String, Nullable) |

See Also

Reference

OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Remove Method (OrganizationServiceCachePluginMessage)
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim message As OrganizationServiceCachePluginMessage

instance.Remove(message)

Syntax

Visual Basic
Public Sub Remove ( _
    message As OrganizationServiceCachePluginMessage _
)
C#
public void Remove (
    OrganizationServiceCachePluginMessage message
)
C++

J#

JScript

Parameters
message
Type: OrganizationServiceCachePluginMessage
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Remove Method (Entity)
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim entity As Entity

instance.Remove(entity)

Syntax

Visual Basic
Public Sub Remove ( _
    entity As Entity _
)
C#
public void Remove (
    Entity entity
)
C++

J#

JScript

Parameters
entity
Type: Entity
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Remove Method (EntityReference)
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim entity As EntityReference

instance.Remove(entity)

Syntax

Visual Basic
Public Sub Remove ( _
    entity As EntityReference _
)
C#
public void Remove (
    EntityReference entity
)
C++

J#

JScript

Parameters
entity
Type: EntityReference
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Remove Method (OrganizationRequest)
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim request As OrganizationRequest

instance.Remove(request)

Syntax

Visual Basic
Public Sub Remove ( _
    request As OrganizationRequest _
)
C#
public void Remove (
    OrganizationRequest request
)
C++

J#

JScript

Parameters
request
Type: OrganizationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Remove Method (String)
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim cacheKey As String

instance.Remove(cacheKey)

Syntax

Visual Basic
Public Sub Remove ( _
    cacheKey As String _
)
C#
public void Remove (
    string cacheKey
)
C++

J#

JScript

Parameters
cacheKey
Type: String
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Remove Method (String, Nullable)
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim entityLogicalName As String
Dim id As Nullable(Of Guid)

instance.Remove(entityLogicalName, id)

Syntax

Visual Basic
Public Sub Remove ( _
    entityLogicalName As String, _
    id As Nullable(Of Guid) _
)
C#
public void Remove (
    string entityLogicalName,
    Nullable<Guid> id
)
C++

J#

JScript

Parameters
entityLogicalName
Type: String
id
Type: Guid
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.TryGetCacheKey Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim request As Object
Dim cacheKey As String
Dim returnValue As Boolean

returnValue = Me.TryGetCacheKey(request, cacheKey)

Syntax

Visual Basic
Protected Overridable Function TryGetCacheKey ( _
    request As Object, _
    <OutAttribute> ByRef cacheKey As String _
) As Boolean
C#
protected virtual bool TryGetCacheKey (
    Object request,
    out string cacheKey
)
C++

J#

JScript

Parameters
request
cacheKey
Type: String
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.TryGetCachePolicy Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim query As Object
Dim result As Object
Dim cacheItemPolicy As CacheItemPolicy
Dim returnValue As Boolean

returnValue = Me.TryGetCachePolicy(query, result, cacheItemPolicy)

Syntax

Visual Basic
Protected Overridable Function TryGetCachePolicy ( _
    query As Object, _
    result As Object, _
    <OutAttribute> ByRef cacheItemPolicy As CacheItemPolicy _
) As Boolean
C#
protected virtual bool TryGetCachePolicy (
    Object query,
    Object result,
    out CacheItemPolicy cacheItemPolicy
)
C++

J#

JScript

Parameters
query
Type: Object
result
Type: Object
cacheItemPolicy
Type: CacheItemPolicy
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.TryGetDependencies Method
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim query As Object
Dim dependencies As IEnumerable(Of String)
Dim returnValue As Boolean

returnValue = Me.TryGetDependencies(query, dependencies)

Syntax

Visual Basic
Protected Overridable Function TryGetDependencies ( _
    query As Object, _
    <OutAttribute> ByRef dependencies As IEnumerable(Of String) _
) As Boolean
C#
protected virtual bool TryGetDependencies (
    Object query,
    out IEnumerable<string> dependencies
)
C++

J#

JScript

Parameters
query
dependencies
Type: String
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache Properties
[image]

Public Properties

 | Name | Description
public property | Cache |
public property | CacheEntryChangeMonitorPrefix |
public property | CacheRegionName |
public property | ConnectionId |
public property | Mode |
public property | QueryHashingEnabled |
public property | ReturnMode |

See Also

Reference

OrganizationServiceCache Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCache.Cache Property
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim value As ObjectCache

value = instance.Cache

Syntax

Visual Basic
Public Overridable Property Cache As ObjectCache
C#
public virtual ObjectCache Cache { get; }
C++

J#

JScript

Property Value
Type: ObjectCache
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.CacheEntryChangeMonitorPrefix Property
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim value As String

value = instance.CacheEntryChangeMonitorPrefix

Syntax

Visual Basic
Public Overridable Property CacheEntryChangeMonitorPrefix As String
C#
public virtual string CacheEntryChangeMonitorPrefix { get; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.CacheRegionName Property
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim value As String

value = instance.CacheRegionName

Syntax

Visual Basic
Public Property CacheRegionName As String
C#
public string CacheRegionName { get; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.ConnectionId Property
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim value As String

value = instance.ConnectionId

Syntax

Visual Basic
Public Property ConnectionId As String
C#
public string ConnectionId { get; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.Mode Property
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim value As OrganizationServiceCacheMode

value = instance.Mode

instance.Mode = value

Syntax

Visual Basic
Public Property Mode As OrganizationServiceCacheMode
C#
public OrganizationServiceCacheMode Mode { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceCacheMode
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.QueryHashingEnabled Property
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim value As Boolean

value = instance.QueryHashingEnabled

Syntax

Visual Basic
Public Property QueryHashingEnabled As Boolean
C#
public bool QueryHashingEnabled { get; }
C++

J#

JScript

Property Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCache.ReturnMode Property
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCache
Dim value As OrganizationServiceCacheReturnMode

value = instance.ReturnMode

instance.ReturnMode = value

Syntax

Visual Basic
Public Property ReturnMode As OrganizationServiceCacheReturnMode
C#
public OrganizationServiceCacheReturnMode ReturnMode { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationServiceCacheReturnMode
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCache Class
OrganizationServiceCache Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCacheMode Enumeration
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheMode

Syntax

Visual Basic
Public Enumeration OrganizationServiceCacheMode
C#
public enum OrganizationServiceCacheMode
C++

J#

JScript

  Members
Member name | Description
Disabled | Value = 2.
InsertOnly | Value = 1.
LookupAndInsert | Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheReturnMode Enumeration
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheReturnMode

Syntax

Visual Basic
Public Enumeration OrganizationServiceCacheReturnMode
C#
public enum OrganizationServiceCacheReturnMode
C++

J#

JScript

  Members
Member name | Description
Cloned | Value = 1.
Shared | Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheSettings Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheSettings

Syntax

Visual Basic
Public NotInheritable Class OrganizationServiceCacheSettings
C#
public sealed class OrganizationServiceCacheSettings
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.OrganizationServiceCacheSettings
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheSettings Members
See Also Constructors Methods Properties
[image]

(Developer Extensions)

The following tables list the members exposed by the OrganizationServiceCacheSettings type.

Public Constructors

Name | Description
OrganizationServiceCacheSettings | Overloaded. Initializes a new instance of theOrganizationServiceCacheSettings class.
Top

Public Properties

 | Name | Description
public property | CacheEntryChangeMonitorPrefix | Gets or sets the prefix string used for constructing the CacheEntryChangeMonitor objects assigned to the cache items.
public property | CacheRegionName | Gets or sets the cache region name.
public property | ConnectionId | Gets or sets a key value for uniquely distinguishing the connection.
public property | PolicyFactory | Gets or sets a factory for creating CacheItemPolicy objects.
public property | QueryHashingEnabled | Gets or sets whether the query used to construct the cache key is to be hashed or left as a readable string.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceCacheSettings Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheSettings Constructor
[image]

Initializes a new instance of theOrganizationServiceCacheSettings class.

Overload List

Name | Description
OrganizationServiceCacheSettings () | Initializes a new instance of the OrganizationServiceCacheSettings class.
OrganizationServiceCacheSettings (CrmConnection) | Initializes a new instance of the OrganizationServiceCacheSettings class.
OrganizationServiceCacheSettings (String) | Initializes a new instance of the OrganizationServiceCacheSettings class.

See Also

Reference

OrganizationServiceCacheSettings Class
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCacheSettings Constructor ()
[image]

Initializes a new instance of the OrganizationServiceCacheSettings class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New OrganizationServiceCacheSettings

Syntax

Visual Basic
Public Sub New
C#
public OrganizationServiceCacheSettings ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheSettings Class
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCacheSettings Constructor (CrmConnection)
[image]

Initializes a new instance of the OrganizationServiceCacheSettings class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As CrmConnection

Dim instance As New OrganizationServiceCacheSettings(connection)

Syntax

Visual Basic
Public Sub New ( _
    connection As CrmConnection _
)
C#
public OrganizationServiceCacheSettings (
    CrmConnection connection
)
C++

J#

JScript

Parameters
connection
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheSettings Class
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCacheSettings Constructor (String)
[image]

Initializes a new instance of the OrganizationServiceCacheSettings class.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionId As String

Dim instance As New OrganizationServiceCacheSettings(connectionId)

Syntax

Visual Basic
Public Sub New ( _
    connectionId As String _
)
C#
public OrganizationServiceCacheSettings (
    string connectionId
)
C++

J#

JScript

Parameters
connectionId
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheSettings Class
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCacheSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceCacheSettings Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheSettings Properties
[image]

Public Properties

 | Name | Description
public property | CacheEntryChangeMonitorPrefix | Gets or sets the prefix string used for constructing the CacheEntryChangeMonitor objects assigned to the cache items.
public property | CacheRegionName | Gets or sets the cache region name.
public property | ConnectionId | Gets or sets a key value for uniquely distinguishing the connection.
public property | PolicyFactory | Gets or sets a factory for creating CacheItemPolicy objects.
public property | QueryHashingEnabled | Gets or sets whether the query used to construct the cache key is to be hashed or left as a readable string.

See Also

Reference

OrganizationServiceCacheSettings Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCacheSettings.CacheEntryChangeMonitorPrefix Property
[image]

Gets or sets the prefix string used for constructing the CacheEntryChangeMonitor objects assigned to the cache items.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheSettings
Dim value As String

value = instance.CacheEntryChangeMonitorPrefix

instance.CacheEntryChangeMonitorPrefix = value

Syntax

Visual Basic
Public Property CacheEntryChangeMonitorPrefix As String
C#
public string CacheEntryChangeMonitorPrefix { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheSettings Class
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCacheSettings.CacheRegionName Property
[image]

Gets or sets the cache region name.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheSettings
Dim value As String

value = instance.CacheRegionName

instance.CacheRegionName = value

Syntax

Visual Basic
Public Property CacheRegionName As String
C#
public string CacheRegionName { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheSettings Class
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCacheSettings.ConnectionId Property
[image]

Gets or sets a key value for uniquely distinguishing the connection.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheSettings
Dim value As String

value = instance.ConnectionId

instance.ConnectionId = value

Syntax

Visual Basic
Public Property ConnectionId As String
C#
public string ConnectionId { get; set; }
C++

J#

JScript

Property Value
Type: String.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheSettings Class
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCacheSettings.PolicyFactory Property
[image]

Gets or sets a factory for creating CacheItemPolicy objects.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheSettings
Dim value As ICacheItemPolicyFactory

value = instance.PolicyFactory

instance.PolicyFactory = value

Syntax

Visual Basic
Public Property PolicyFactory As ICacheItemPolicyFactory
C#
public ICacheItemPolicyFactory PolicyFactory { get; set; }
C++

J#

JScript

Property Value
Type: ICacheItemPolicyFactory.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheSettings Class
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceCacheSettings.QueryHashingEnabled Property
[image]

Gets or sets whether the query used to construct the cache key is to be hashed or left as a readable string.

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCacheSettings
Dim value As Boolean

value = instance.QueryHashingEnabled

instance.QueryHashingEnabled = value

Syntax

Visual Basic
Public Property QueryHashingEnabled As Boolean
C#
public bool QueryHashingEnabled { get; set; }
C++

J#

JScript

Property Value
Type: Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceCacheSettings Class
OrganizationServiceCacheSettings Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceExtensions Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class OrganizationServiceExtensions
C#
[ExtensionAttribute]
public static class OrganizationServiceExtensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.OrganizationServiceExtensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceExtensions Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceExtensions Members
See Also Methods
[image]

(Developer Extensions)

The following tables list the members exposed by the OrganizationServiceExtensions type.

Public Methods (see also Extension Methods)

Name | Description
Execute | Extensions to the core Execute method. (Developer Extensions)
FetchXmlToQueryExpression | Extensions to the core FetchXmlToQueryExpressionRequest message. (Developer Extensions) (Developer Extensions)
RetrieveEntity | Overloaded. (Developer Extensions)
RetrieveMultiple | Overloaded. Extensions to the core RetrieveMultiple method. (Developer Extensions)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceExtensions Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceExtensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
Execute | Extensions to the core Execute method. (Developer Extensions)
FetchXmlToQueryExpression | Extensions to the core FetchXmlToQueryExpressionRequest message. (Developer Extensions) (Developer Extensions)
RetrieveEntity | Overloaded. (Developer Extensions)
RetrieveMultiple | Overloaded. Extensions to the core RetrieveMultiple method. (Developer Extensions)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceExtensions Class
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceExtensions.Execute Method
[image]

Extensions to the core Execute method. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService
Dim request As OrganizationRequest
Dim returnValue As TResponse

returnValue = OrganizationServiceExtensions.Execute(service, request)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function Execute(Of TResponse As OrganizationResponse) ( _
    service As IOrganizationService, _
    request As OrganizationRequest _
) As TResponse
C#
[ExtensionAttribute]
public static TResponse Execute<TResponse> (
    IOrganizationService service,
    OrganizationRequest request
) where TResponse : OrganizationResponse
C++

J#

JScript

GenericParameters
TResponse
Parameters
service
request
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceExtensions Class
OrganizationServiceExtensions Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceExtensions.FetchXmlToQueryExpression Method
[image]

Extensions to the core FetchXmlToQueryExpressionRequest message. (Developer Extensions) (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService
Dim fetchXml As String
Dim returnValue As QueryExpression

returnValue = OrganizationServiceExtensions.FetchXmlToQueryExpression(service, fetchXml)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function FetchXmlToQueryExpression ( _
    service As IOrganizationService, _
    fetchXml As String _
) As QueryExpression
C#
[ExtensionAttribute]
public static QueryExpression FetchXmlToQueryExpression (
    IOrganizationService service,
    string fetchXml
)
C++

J#

JScript

Parameters
service
fetchXml
Return Value
Type: QueryExpression.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceExtensions Class
OrganizationServiceExtensions Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceExtensions.RetrieveEntity Method
[image]

(Developer Extensions)Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
OrganizationServiceExtensions.RetrieveEntity (IOrganizationService, RetrieveEntityRequest) |
OrganizationServiceExtensions.RetrieveEntity (IOrganizationService, String, EntityFilters, Boolean) |

See Also

Reference

OrganizationServiceExtensions Class
OrganizationServiceExtensions Members
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceExtensions.RetrieveEntity Method (IOrganizationService, RetrieveEntityRequest)
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService
Dim request As RetrieveEntityRequest
Dim returnValue As RetrieveEntityResponse

returnValue = OrganizationServiceExtensions.RetrieveEntity(service, request)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveEntity ( _
    service As IOrganizationService, _
    request As RetrieveEntityRequest _
) As RetrieveEntityResponse
C#
[ExtensionAttribute]
public static RetrieveEntityResponse RetrieveEntity (
    IOrganizationService service,
    RetrieveEntityRequest request
)
C++

J#

JScript

Parameters
service
request
Return Value
Type: RetrieveEntityResponse
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceExtensions Class
OrganizationServiceExtensions Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceExtensions.RetrieveEntity Method (IOrganizationService, String, EntityFilters, Boolean)
[image]

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService
Dim logicalName As String
Dim entityFilters As EntityFilters
Dim retrieveAsIfPublished As Boolean
Dim returnValue As EntityMetadata

returnValue = OrganizationServiceExtensions.RetrieveEntity(service, logicalName, entityFilters, retrieveAsIfPublished)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveEntity ( _
    service As IOrganizationService, _
    logicalName As String, _
    <OptionalAttribute> Optional entityFilters As EntityFilters = , _
    <OptionalAttribute> Optional retrieveAsIfPublished As Boolean = False _
) As EntityMetadata
C#
[ExtensionAttribute]
public static EntityMetadata RetrieveEntity (
    IOrganizationService service,
    string logicalName,
    [OptionalAttribute] EntityFilters entityFilters,
    [OptionalAttribute] bool retrieveAsIfPublished
)
C++

J#

JScript

Parameters
service
logicalName
entityFilters
retrieveAsIfPublished
Return Value
Type: EntityMetadata
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceExtensions Class
OrganizationServiceExtensions Members
Microsoft.Xrm.Client.Services Namespace


OrganizationServiceExtensions.RetrieveMultiple Method
[image]

Extensions to the core RetrieveMultiple method. (Developer Extensions)Developer Extensions for Microsoft Dynamics CRM

Overload List

Name | Description
OrganizationServiceExtensions.RetrieveMultiple (IOrganizationService, RetrieveMultipleRequest) | Extensions to the core RetrieveMultiple method. (Developer Extensions)
OrganizationServiceExtensions.RetrieveMultiple (IOrganizationService, QueryBase) | Extensions to the core RetrieveMultiple method. (Developer Extensions)

See Also

Reference

OrganizationServiceExtensions Class
OrganizationServiceExtensions Members
Microsoft.Xrm.Client.Services Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceExtensions.RetrieveMultiple Method (IOrganizationService, RetrieveMultipleRequest)
[image]

Extensions to the core RetrieveMultiple method. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService
Dim request As RetrieveMultipleRequest
Dim returnValue As RetrieveMultipleResponse

returnValue = OrganizationServiceExtensions.RetrieveMultiple(service, request)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveMultiple ( _
    service As IOrganizationService, _
    request As RetrieveMultipleRequest _
) As RetrieveMultipleResponse
C#
[ExtensionAttribute]
public static RetrieveMultipleResponse RetrieveMultiple (
    IOrganizationService service,
    RetrieveMultipleRequest request
)
C++

J#

JScript

Parameters
service
request
Return Value
Type: RetrieveMultipleResponse
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceExtensions Class
OrganizationServiceExtensions Members
Microsoft.Xrm.Client.Services Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceExtensions.RetrieveMultiple Method (IOrganizationService, QueryBase)
[image]

Extensions to the core RetrieveMultiple method. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim service As IOrganizationService
Dim query As QueryBase
Dim returnValue As EntityCollection

returnValue = OrganizationServiceExtensions.RetrieveMultiple(service, query)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function RetrieveMultiple ( _
    service As IOrganizationService, _
    query As QueryBase _
) As EntityCollection
C#
[ExtensionAttribute]
public static EntityCollection RetrieveMultiple (
    IOrganizationService service,
    QueryBase query
)
C++

J#

JScript

Parameters
service
query
Return Value
Type: EntityCollection
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationServiceExtensions Class
OrganizationServiceExtensions Members
Microsoft.Xrm.Client.Services Namespace


Microsoft.Xrm.Client.Services.Messages Namespace

Classes

Class | Description
Extensions | (Developer Extensions)
OrganizationServiceCachePluginMessage | (Developer Extensions)
PluginMessage | A message sent to a plug-in.
PluginMessageEntityReference | A reference to a related entity.
PluginMessageRelationship | Represents the primary entity role of the target entity for the plug-in message.

Enumerations

Enumeration | Description
CacheItemCategory | The category of the cache item. (Developer Extensions)


CacheItemCategory Enumeration
[image]

The category of the cache item. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As CacheItemCategory

Syntax

Visual Basic
<FlagsAttribute> _
Public Enumeration CacheItemCategory
C#
[FlagsAttribute]
public enum CacheItemCategory
C++

J#

JScript

  Members
Member name | Description
All | Value = 3.
Content | Value = 2.
Metadata | Value = 1.
None | Value = 0.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


Extensions Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Extensions
C#
[ExtensionAttribute]
public static class Extensions
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Messages.Extensions
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Extensions Members
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


Extensions Members
See Also Methods
[image]

(Developer Extensions)

The following tables list the members exposed by the Extensions type.

Public Methods (see also Extension Methods)

Name | Description
ToEntityReferenceCollection | (Developer Extensions)
ToPluginMessageEntityReference | (Developer Extensions)
ToPluginMessageEntityReferenceCollection | (Developer Extensions)
ToPluginMessageRelationship | (Developer Extensions)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

Extensions Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


Extensions Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
ToEntityReferenceCollection | (Developer Extensions)
ToPluginMessageEntityReference | (Developer Extensions)
ToPluginMessageEntityReferenceCollection | (Developer Extensions)
ToPluginMessageRelationship | (Developer Extensions)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

Extensions Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


Extensions.ToEntityReferenceCollection Method
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entities As List(Of PluginMessageEntityReference)
Dim returnValue As EntityReferenceCollection

returnValue = Extensions.ToEntityReferenceCollection(entities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToEntityReferenceCollection ( _
    entities As List(Of PluginMessageEntityReference) _
) As EntityReferenceCollection
C#
[ExtensionAttribute]
public static EntityReferenceCollection ToEntityReferenceCollection (
    List<PluginMessageEntityReference> entities
)
C++

J#

JScript

Parameters
entities
Return Value
Returns EntityReferenceCollection.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Extensions Class
Extensions Members
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


Extensions.ToPluginMessageEntityReference Method
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim reference As EntityReference
Dim returnValue As PluginMessageEntityReference

returnValue = Extensions.ToPluginMessageEntityReference(reference)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToPluginMessageEntityReference ( _
    reference As EntityReference _
) As PluginMessageEntityReference
C#
[ExtensionAttribute]
public static PluginMessageEntityReference ToPluginMessageEntityReference (
    EntityReference reference
)
C++

J#

JScript

Parameters
reference
Return Value
Returns PluginMessageEntityReference.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Extensions Class
Extensions Members
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


Extensions.ToPluginMessageEntityReferenceCollection Method
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim entities As EntityReferenceCollection
Dim returnValue As List(Of PluginMessageEntityReference)

returnValue = Extensions.ToPluginMessageEntityReferenceCollection(entities)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToPluginMessageEntityReferenceCollection ( _
    entities As EntityReferenceCollection _
) As List(Of PluginMessageEntityReference)
C#
[ExtensionAttribute]
public static List<PluginMessageEntityReference> ToPluginMessageEntityReferenceCollection (
    EntityReferenceCollection entities
)
C++

J#

JScript

Parameters
entities
Return Value
Returns List.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Extensions Class
Extensions Members
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


Extensions.ToPluginMessageRelationship Method
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim relationship As Relationship
Dim returnValue As PluginMessageRelationship

returnValue = Extensions.ToPluginMessageRelationship(relationship)

Syntax

Visual Basic
<ExtensionAttribute> _
Public Shared Function ToPluginMessageRelationship ( _
    relationship As Relationship _
) As PluginMessageRelationship
C#
[ExtensionAttribute]
public static PluginMessageRelationship ToPluginMessageRelationship (
    Relationship relationship
)
C++

J#

JScript

Parameters
relationship
Return Value
Returns PluginMessageRelationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Extensions Class
Extensions Members
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCachePluginMessage Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCachePluginMessage

Syntax

Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Class OrganizationServiceCachePluginMessage
    Inherits PluginMessage
C#
[SerializableAttribute]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public class OrganizationServiceCachePluginMessage : PluginMessage
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Client.Services.Messages.PluginMessage
    Microsoft.Xrm.Client.Services.Messages.OrganizationServiceCachePluginMessage
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationServiceCachePluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCachePluginMessage Members
See Also Constructors Fields Methods
[image]

(Developer Extensions)

The following tables list the members exposed by the OrganizationServiceCachePluginMessage type.

Public Constructors

Name | Description
OrganizationServiceCachePluginMessage | (Developer Extensions)
Top

Public Fields

 | Name | Description
public field | Category | (Developer Extensions)
public field | ConnectionStringName | (Developer Extensions)
public field | MessageName | The name of the message. (inherited from PluginMessage)
public field | RelatedEntities | The list of related entities. (inherited from PluginMessage)
public field | Relationship | The relationship to the target entity. (inherited from PluginMessage)
public field | Secret | (Developer Extensions)
public field | ServiceCacheName | (Developer Extensions)
public field | Target | The target entity. (inherited from PluginMessage)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

OrganizationServiceCachePluginMessage Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCachePluginMessage Fields
[image]

Public Fields

 | Name | Description
public field | Category | (Developer Extensions)
public field | ConnectionStringName | (Developer Extensions)
public field | MessageName | The name of the message.(inherited from PluginMessage)
public field | RelatedEntities | The list of related entities.(inherited from PluginMessage)
public field | Relationship | The relationship to the target entity.(inherited from PluginMessage)
public field | Secret | (Developer Extensions)
public field | ServiceCacheName | (Developer Extensions)
public field | Target | The target entity.(inherited from PluginMessage)

See Also

Reference

OrganizationServiceCachePluginMessage Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationServiceCachePluginMessage.Category Field
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCachePluginMessage
Dim value As Nullable(Of CacheItemCategory)

value = instance.Category

instance.Category = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public Category As Nullable(Of CacheItemCategory)
C#
[DataMemberAttribute]
public Nullable<CacheItemCategory> Category
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationServiceCachePluginMessage Class
OrganizationServiceCachePluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


OrganizationServiceCachePluginMessage.ConnectionStringName Field
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCachePluginMessage
Dim value As String

value = instance.ConnectionStringName

instance.ConnectionStringName = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public ConnectionStringName As String
C#
[DataMemberAttribute]
public string ConnectionStringName
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationServiceCachePluginMessage Class
OrganizationServiceCachePluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


OrganizationServiceCachePluginMessage.Secret Field
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCachePluginMessage
Dim value As String

value = instance.Secret

instance.Secret = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public Secret As String
C#
[DataMemberAttribute]
public string Secret
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationServiceCachePluginMessage Class
OrganizationServiceCachePluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


OrganizationServiceCachePluginMessage.ServiceCacheName Field
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationServiceCachePluginMessage
Dim value As String

value = instance.ServiceCacheName

instance.ServiceCacheName = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public ServiceCacheName As String
C#
[DataMemberAttribute]
public string ServiceCacheName
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationServiceCachePluginMessage Class
OrganizationServiceCachePluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


OrganizationServiceCachePluginMessage Constructor
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New OrganizationServiceCachePluginMessage

Syntax

Visual Basic
Public Sub New
C#
public OrganizationServiceCachePluginMessage ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
OrganizationServiceCachePluginMessage Class
OrganizationServiceCachePluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


OrganizationServiceCachePluginMessage Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

OrganizationServiceCachePluginMessage Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessage Class
See Also Members
[image]

A message sent to a plug-in.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessage

Syntax

Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
<KnownTypeAttribute(GetType(OrganizationServiceCachePluginMessage))> _
Public Class PluginMessage
C#
[SerializableAttribute]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
[KnownTypeAttribute(typeof(OrganizationServiceCachePluginMessage))]
public class PluginMessage
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Messages.PluginMessage

                Microsoft.Xrm.Client.Services.Messages.OrganizationServiceCachePluginMessage
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


PluginMessage Members
See Also Constructors Fields Methods
[image]

A message sent to a plug-in.

The following tables list the members exposed by the PluginMessage type.

Public Constructors

Name | Description
PluginMessage | Initializes a new instance of the PluginMessage class.
Top

Public Fields

 | Name | Description
public field | MessageName | The name of the message.
public field | RelatedEntities | The list of related entities.
public field | Relationship | The relationship to the target entity.
public field | Target | The target entity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

PluginMessage Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessage Fields
[image]

Public Fields

 | Name | Description
public field | MessageName | The name of the message.
public field | RelatedEntities | The list of related entities.
public field | Relationship | The relationship to the target entity.
public field | Target | The target entity.

See Also

Reference

PluginMessage Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessage.MessageName Field
[image]

The name of the message.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessage
Dim value As String

value = instance.MessageName

instance.MessageName = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public MessageName As String
C#
[DataMemberAttribute]
public string MessageName
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessage Class
PluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessage.RelatedEntities Field
[image]

The list of related entities.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessage
Dim value As List(Of PluginMessageEntityReference)

value = instance.RelatedEntities

instance.RelatedEntities = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public RelatedEntities As List(Of PluginMessageEntityReference)
C#
[DataMemberAttribute]
public List<PluginMessageEntityReference> RelatedEntities
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessage Class
PluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessage.Relationship Field
[image]

The relationship to the target entity.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessage
Dim value As PluginMessageRelationship

value = instance.Relationship

instance.Relationship = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public Relationship As PluginMessageRelationship
C#
[DataMemberAttribute]
public PluginMessageRelationship Relationship
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessage Class
PluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessage.Target Field
[image]

The target entity.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessage
Dim value As PluginMessageEntityReference

value = instance.Target

instance.Target = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public Target As PluginMessageEntityReference
C#
[DataMemberAttribute]
public PluginMessageEntityReference Target
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessage Class
PluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessage Constructor
[image]

Initializes a new instance of the PluginMessage class.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New PluginMessage

Syntax

Visual Basic
Public Sub New
C#
public PluginMessage ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessage Class
PluginMessage Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessage Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

PluginMessage Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessageEntityReference Class
See Also Members
[image]

A reference to a related entity.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessageEntityReference

Syntax

Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Class PluginMessageEntityReference
C#
[SerializableAttribute]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public class PluginMessageEntityReference
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Messages.PluginMessageEntityReference
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageEntityReference Members
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


PluginMessageEntityReference Members
See Also Constructors Fields Methods
[image]

A reference to a related entity.

The following tables list the members exposed by the PluginMessageEntityReference type.

Public Constructors

Name | Description
PluginMessageEntityReference | Initializes a new instance of the PluginMessageEntityReference class.
Top

Public Fields

 | Name | Description
public field | Id | The unique identifier of the related entity.
public field | LogicalName | The logical name of the related entity.
public field | Name | A name to identify the PluginMessageEntityReference.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToEntityReference | Converts the PluginMessageEntityReference to an EntityReference.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

PluginMessageEntityReference Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessageEntityReference Fields
[image]

Public Fields

 | Name | Description
public field | Id | The unique identifier of the related entity.
public field | LogicalName | The logical name of the related entity.
public field | Name | A name to identify the PluginMessageEntityReference.

See Also

Reference

PluginMessageEntityReference Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessageEntityReference.Id Field
[image]

The unique identifier of the related entity.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessageEntityReference
Dim value As Guid

value = instance.Id

instance.Id = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public Id As Guid
C#
[DataMemberAttribute]
public Guid Id
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageEntityReference Class
PluginMessageEntityReference Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessageEntityReference.LogicalName Field
[image]

The logical name of the related entity.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessageEntityReference
Dim value As String

value = instance.LogicalName

instance.LogicalName = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public LogicalName As String
C#
[DataMemberAttribute]
public string LogicalName
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageEntityReference Class
PluginMessageEntityReference Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessageEntityReference.Name Field
[image]

A name to identify the PluginMessageEntityReference.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessageEntityReference
Dim value As String

value = instance.Name

instance.Name = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public Name As String
C#
[DataMemberAttribute]
public string Name
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageEntityReference Class
PluginMessageEntityReference Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessageEntityReference Constructor
[image]

Initializes a new instance of the PluginMessageEntityReference class.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New PluginMessageEntityReference

Syntax

Visual Basic
Public Sub New
C#
public PluginMessageEntityReference ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageEntityReference Class
PluginMessageEntityReference Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessageEntityReference Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToEntityReference | Converts the PluginMessageEntityReference to an EntityReference.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

PluginMessageEntityReference Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessageEntityReference.ToEntityReference Method
[image]

Converts the PluginMessageEntityReference to an EntityReference.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessageEntityReference
Dim returnValue As EntityReference

returnValue = instance.ToEntityReference

Syntax

Visual Basic
Public Function ToEntityReference As EntityReference
C#
public EntityReference ToEntityReference ()
C++

J#

JScript

Return Value
Type: EntityReference
An entity reference.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageEntityReference Class
PluginMessageEntityReference Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessageRelationship Class
See Also Members
[image]

Represents the primary entity role of the target entity for the plug-in message.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessageRelationship

Syntax

Visual Basic
<SerializableAttribute> _
<DataContractAttribute(Namespace:="http://schemas.microsoft.com/xrm/2011/Contracts")> _
Public Class PluginMessageRelationship
C#
[SerializableAttribute]
[DataContractAttribute(Namespace="http://schemas.microsoft.com/xrm/2011/Contracts")]
public class PluginMessageRelationship
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Messages.PluginMessageRelationship
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageRelationship Members
Microsoft.Xrm.Client.Services.Messages Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


PluginMessageRelationship Members
See Also Constructors Fields Methods
[image]

Represents the primary entity role of the target entity for the plug-in message.

The following tables list the members exposed by the PluginMessageRelationship type.

Public Constructors

Name | Description
PluginMessageRelationship | Initializes a new instance of the PluginMessageRelationship class.
Top

Public Fields

 | Name | Description
public field | PrimaryEntityRole | The primary entity role.
public field | SchemaName | The schema name of the target entity.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToRelationship | Converts the PluginMessageRelationship to a Relationship type.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

PluginMessageRelationship Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessageRelationship Fields
[image]

Public Fields

 | Name | Description
public field | PrimaryEntityRole | The primary entity role.
public field | SchemaName | The schema name of the target entity.

See Also

Reference

PluginMessageRelationship Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessageRelationship.PrimaryEntityRole Field
[image]

The primary entity role.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessageRelationship
Dim value As Nullable(Of EntityRole)

value = instance.PrimaryEntityRole

instance.PrimaryEntityRole = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public PrimaryEntityRole As Nullable(Of EntityRole)
C#
[DataMemberAttribute]
public Nullable<EntityRole> PrimaryEntityRole
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageRelationship Class
PluginMessageRelationship Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessageRelationship.SchemaName Field
[image]

The schema name of the target entity.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessageRelationship
Dim value As String

value = instance.SchemaName

instance.SchemaName = value

Syntax

Visual Basic
<DataMemberAttribute> _
Public SchemaName As String
C#
[DataMemberAttribute]
public string SchemaName
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageRelationship Class
PluginMessageRelationship Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessageRelationship Constructor
[image]

Initializes a new instance of the PluginMessageRelationship class.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New PluginMessageRelationship

Syntax

Visual Basic
Public Sub New
C#
public PluginMessageRelationship ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageRelationship Class
PluginMessageRelationship Members
Microsoft.Xrm.Client.Services.Messages Namespace


PluginMessageRelationship Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToRelationship | Converts the PluginMessageRelationship to a Relationship type.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

PluginMessageRelationship Class
Microsoft.Xrm.Client.Services.Messages Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


PluginMessageRelationship.ToRelationship Method
[image]

Converts the PluginMessageRelationship to a Relationship type.

Namespace: Microsoft.Xrm.Client.Services.Messages
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As PluginMessageRelationship
Dim returnValue As Relationship

returnValue = instance.ToRelationship

Syntax

Visual Basic
Public Function ToRelationship As Relationship
C#
public Relationship ToRelationship ()
C++

J#

JScript

Return Value
Type: Relationship
The converted relationship.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
PluginMessageRelationship Class
PluginMessageRelationship Members
Microsoft.Xrm.Client.Services.Messages Namespace


Microsoft.Xrm.Client.Services.Samples Namespace

Classes

Class | Description
DeviceRegistrationAuthentication | Provides the device registration information required for Windows Live authentication with Microsoft Dynamics CRM Online.
DeviceRegistrationClientInfo | Contains portal website application information.
DeviceRegistrationFailedException | Indicates that device registration failed.
DeviceRegistrationRequest | Contains the data that is needed to register a device with the Microsoft account identity provider of Microsoft Dynamics CRM Online.
DeviceRegistrationResponse | Contains the response from executing a DeviceRegistrationRequest.
DeviceRegistrationResponseError | Contains registration failure details.
DeviceUserName | Provides a user name for a device.
LiveDevice | Contains token information for an authenticated device.

Enumerations

Enumeration | Description
DeviceRegistrationErrorCode | Contains error codes that can occur when registering a device. (Developer Extensions)


DeviceRegistrationAuthentication Class
See Also Members
[image]

Provides the device registration information required for Windows Live authentication with Microsoft Dynamics CRM Online.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationAuthentication

Syntax

Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<XmlRootAttribute("Authentication")> _
Public NotInheritable Class DeviceRegistrationAuthentication
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[XmlRootAttribute("Authentication")]
public sealed class DeviceRegistrationAuthentication
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Samples.DeviceRegistrationAuthentication
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationAuthentication Members
Microsoft.Xrm.Client.Services.Samples Namespace
DeviceRegistrationRequest
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationAuthentication Members
See Also Constructors Methods Properties
[image]

Provides the device registration information required for Windows Live authentication with Microsoft Dynamics CRM Online.

The following tables list the members exposed by the DeviceRegistrationAuthentication type.

Public Constructors

Name | Description
DeviceRegistrationAuthentication | Initializes a new instance of theDeviceRegistrationAuthentication class.
Top

Public Properties

 | Name | Description
public property | MemberName | Gets or sets the name (identifier) of the device.
public property | Password | Gets or sets the decrypted password for the device.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DeviceRegistrationAuthentication Class
Microsoft.Xrm.Client.Services.Samples Namespace
DeviceRegistrationRequest

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationAuthentication Constructor
[image]

Initializes a new instance of the DeviceRegistrationAuthentication class.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New DeviceRegistrationAuthentication

Syntax

Visual Basic
Public Sub New
C#
public DeviceRegistrationAuthentication ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationAuthentication Class
DeviceRegistrationAuthentication Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationAuthentication Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DeviceRegistrationAuthentication Class
Microsoft.Xrm.Client.Services.Samples Namespace
DeviceRegistrationRequest

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationAuthentication Properties
[image]

Public Properties

 | Name | Description
public property | MemberName | Gets or sets the name (identifier) of the device.
public property | Password | Gets or sets the decrypted password for the device.

See Also

Reference

DeviceRegistrationAuthentication Class
Microsoft.Xrm.Client.Services.Samples Namespace
DeviceRegistrationRequest

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationAuthentication.MemberName Property
[image]

Gets or sets the name (identifier) of the device.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationAuthentication
Dim value As String

value = instance.MemberName

instance.MemberName = value

Syntax

Visual Basic
<XmlElementAttribute("Membername")> _
Public Property MemberName As String
C#
[XmlElementAttribute("Membername")]
public string MemberName { get; set; }
C++

J#

JScript

Property Value
Type: String
The name of the device.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationAuthentication Class
DeviceRegistrationAuthentication Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationAuthentication.Password Property
[image]

Gets or sets the decrypted password for the device.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationAuthentication
Dim value As String

value = instance.Password

instance.Password = value

Syntax

Visual Basic
<XmlElementAttribute("Password")> _
Public Property Password As String
C#
[XmlElementAttribute("Password")]
public string Password { get; set; }
C++

J#

JScript

Property Value
Type: String
The device password.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationAuthentication Class
DeviceRegistrationAuthentication Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationClientInfo Class
See Also Members
[image]

Contains portal website application information.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationClientInfo

Syntax

Visual Basic
<XmlRootAttribute("ClientInfo")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public NotInheritable Class DeviceRegistrationClientInfo
C#
[XmlRootAttribute("ClientInfo")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public sealed class DeviceRegistrationClientInfo
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Samples.DeviceRegistrationClientInfo
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationClientInfo Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationClientInfo Members
See Also Constructors Methods Properties
[image]

Contains portal website application information.

The following tables list the members exposed by the DeviceRegistrationClientInfo type.

Public Constructors

Name | Description
DeviceRegistrationClientInfo | Initializes a new instance of the DeviceRegistrationClientInfo class.
Top

Public Properties

 | Name | Description
public property | ApplicationId | Gets or sets the application ID for the portal website.
public property | Version | Gets or sets the version of the portal application.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DeviceRegistrationClientInfo Class
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationClientInfo Constructor
[image]

Initializes a new instance of the DeviceRegistrationClientInfo class.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New DeviceRegistrationClientInfo

Syntax

Visual Basic
Public Sub New
C#
public DeviceRegistrationClientInfo ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationClientInfo Class
DeviceRegistrationClientInfo Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationClientInfo Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DeviceRegistrationClientInfo Class
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationClientInfo Properties
[image]

Public Properties

 | Name | Description
public property | ApplicationId | Gets or sets the application ID for the portal website.
public property | Version | Gets or sets the version of the portal application.

See Also

Reference

DeviceRegistrationClientInfo Class
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationClientInfo.ApplicationId Property
[image]

Gets or sets the application ID for the portal website.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationClientInfo
Dim value As Guid

value = instance.ApplicationId

instance.ApplicationId = value

Syntax

Visual Basic
<XmlAttributeAttribute("name")> _
Public Property ApplicationId As Guid
C#
[XmlAttributeAttribute("name")]
public Guid ApplicationId { get; set; }
C++

J#

JScript

Property Value
Type: Guid
The application ID.

  Remarks
The application ID defined in the MSDN application manager.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationClientInfo Class
DeviceRegistrationClientInfo Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationClientInfo.Version Property
[image]

Gets or sets the version of the portal application.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationClientInfo
Dim value As String

value = instance.Version

instance.Version = value

Syntax

Visual Basic
<XmlAttributeAttribute("version")> _
Public Property Version As String
C#
[XmlAttributeAttribute("version")]
public string Version { get; set; }
C++

J#

JScript

Property Value
Type: String
The application version.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationClientInfo Class
DeviceRegistrationClientInfo Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationErrorCode Enumeration
[image]

Contains error codes that can occur when registering a device. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationErrorCode

Syntax

Visual Basic
Public Enumeration DeviceRegistrationErrorCode
C#
public enum DeviceRegistrationErrorCode
C++

J#

JScript

  Members
Member name | Description
BlankPassword | The password was blank. Value = 6.
DeviceAlreadyExists | The device already exists. Value = 13.
InterfaceDisabled | The interface is disabled. Value = 1.
InternalError | An internal error occurred. Value = 11.
InvalidCharactersInCredentials | The specified credentials contain invalid characters. Value = 9.
InvalidParameterSyntax | The parameter values contain incorrect syntax. Value = 8.
InvalidRequestFormat | The registration request is invalid. Value = 3.
MissingDeviceUserNameOrPassword | The device, user name or password is missing. Value = 7.
Unknown | An unknown error occurred. Value = 0.
UnknownClientVersion | The client version is unknown. Value = 4.
  Remarks
This enumeration is used in the constructor of the DeviceRegistrationFailedException class.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
Microsoft.Xrm.Client.Services.Samples Namespace
DeviceRegistrationFailedException
RegistrationErrorCode
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationFailedException Class
See Also Members
[image]

Indicates that device registration failed.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationFailedException

Syntax

Visual Basic
<SerializableAttribute> _
Public NotInheritable Class DeviceRegistrationFailedException
    Inherits Exception
C#
[SerializableAttribute]
public sealed class DeviceRegistrationFailedException : Exception
C++

J#

JScript

  Remarks
This exception is thrown when registration of a device with Microsoft account fails.

  Inheritance Hierarchy
System.Object

                System.Exception
    Microsoft.Xrm.Client.Services.Samples.DeviceRegistrationFailedException
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Members
Microsoft.Xrm.Client.Services.Samples Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationFailedException Members
See Also Constructors Methods Properties Events
[image]

Indicates that device registration failed.

The following tables list the members exposed by the DeviceRegistrationFailedException type.

Public Constructors

Name | Description
DeviceRegistrationFailedException | Overloaded.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Data | (inherited from Exception)
public property | HelpLink | (inherited from Exception)
public property | InnerException | (inherited from Exception)
public property | Message | (inherited from Exception)
public property | RegistrationErrorCode | Gets the exception error code.
public property | Source | (inherited from Exception)
public property | StackTrace | (inherited from Exception)
public property | TargetSite | (inherited from Exception)
Top

Protected Properties

 | Name | Description
protected property | HResult | (inherited from Exception)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetBaseException | (inherited from Exception)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | Overridden. Sets the SerializationInfo with information about the exception.
public method | GetType | (inherited from Exception)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Protected Events

 | Name | Description
protected event | SerializeObjectState | (inherited from Exception)
Top

See Also

Reference

DeviceRegistrationFailedException Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationFailedException Constructor
[image]

Overload List

Name | Description
DeviceRegistrationFailedException () | Initializes a new instance of theDeviceRegistrationFailedException class.
DeviceRegistrationFailedException (DeviceRegistrationErrorCode, String) | Initializes a new instance of theDeviceRegistrationFailedException class using an error code and sub-code.
DeviceRegistrationFailedException (DeviceRegistrationErrorCode, String, Exception) | Initializes a new instance of theDeviceRegistrationFailedException class using an error code, sub-code, and an inner exception.
DeviceRegistrationFailedException (String) | Initializes a new instance of theDeviceRegistrationFailedException class using a message.
DeviceRegistrationFailedException (String, Exception) | Initializes a new instance of theDeviceRegistrationFailedException class using a message and an inner exception.

See Also

Reference

DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationFailedException Constructor ()
[image]

Initializes a new instance of the DeviceRegistrationFailedException class.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New DeviceRegistrationFailedException

Syntax

Visual Basic
Public Sub New
C#
public DeviceRegistrationFailedException ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationFailedException Constructor (DeviceRegistrationErrorCode, String)
[image]

Initializes a new instance of the DeviceRegistrationFailedException class using an error code and sub-code.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim code As DeviceRegistrationErrorCode
Dim subCode As String

Dim instance As New DeviceRegistrationFailedException(code, subCode)

Syntax

Visual Basic
Public Sub New ( _
    code As DeviceRegistrationErrorCode, _
    subCode As String _
)
C#
public DeviceRegistrationFailedException (
    DeviceRegistrationErrorCode code,
    string subCode
)
C++

J#

JScript

Parameters
code
Type: DeviceRegistrationErrorCode. An error code.
subCode
Type: String. An error sub-code.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationFailedException Constructor (DeviceRegistrationErrorCode, String, Exception)
[image]

Initializes a new instance of the DeviceRegistrationFailedException class using an error code, sub-code, and an inner exception.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim code As DeviceRegistrationErrorCode
Dim subCode As String
Dim innerException As Exception

Dim instance As New DeviceRegistrationFailedException(code, subCode, innerException)

Syntax

Visual Basic
Public Sub New ( _
    code As DeviceRegistrationErrorCode, _
    subCode As String, _
    innerException As Exception _
)
C#
public DeviceRegistrationFailedException (
    DeviceRegistrationErrorCode code,
    string subCode,
    Exception innerException
)
C++

J#

JScript

Parameters
code
Type: DeviceRegistrationErrorCode. An error code.
subCode
Type: String. An error sub-code.
innerException
Type: Exception. An inner exception.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationFailedException Constructor (String)
[image]

Initializes a new instance of the DeviceRegistrationFailedException class using a message.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim message As String

Dim instance As New DeviceRegistrationFailedException(message)

Syntax

Visual Basic
Public Sub New ( _
    message As String _
)
C#
public DeviceRegistrationFailedException (
    string message
)
C++

J#

JScript

Parameters
message
Type: String. A message for the exception.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationFailedException Constructor (String, Exception)
[image]

Initializes a new instance of the DeviceRegistrationFailedException class using a message and an inner exception.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim message As String
Dim innerException As Exception

Dim instance As New DeviceRegistrationFailedException(message, innerException)

Syntax

Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public DeviceRegistrationFailedException (
    string message,
    Exception innerException
)
C++

J#

JScript

Parameters
message
Type: String. A message for the exception.
innerException
Type: Exception. An inner exception.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationFailedException Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetBaseException | (inherited from Exception)
public method | GetHashCode | (inherited from Object)
public method | GetObjectData | Overridden. Sets the SerializationInfo with information about the exception.
public method | GetType | (inherited from Exception)
public method | ToString | Overridden. (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DeviceRegistrationFailedException Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationFailedException.GetObjectData Method
[image]

Sets the SerializationInfo with information about the exception.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationFailedException
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)

Syntax

Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public override void GetObjectData (
    SerializationInfo info,
    StreamingContext context
)
C++

J#

JScript

Parameters
info
Type: System.Runtime.Serialization.SerializationInfo. Contains the serialized object data about the exception being thrown.
context
Type: StreamingContext. Contains contextual information about the source or destination.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationFailedException Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Data | (inherited from Exception)
public property | HelpLink | (inherited from Exception)
public property | InnerException | (inherited from Exception)
public property | Message | (inherited from Exception)
public property | RegistrationErrorCode | Gets the exception error code.
public property | Source | (inherited from Exception)
public property | StackTrace | (inherited from Exception)
public property | TargetSite | (inherited from Exception)

Protected Properties

 | Name | Description
protected property | HResult | (inherited from Exception)

See Also

Reference

DeviceRegistrationFailedException Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationFailedException.RegistrationErrorCode Property
[image]

Gets the exception error code.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationFailedException
Dim value As DeviceRegistrationErrorCode

value = instance.RegistrationErrorCode

Syntax

Visual Basic
Public Property RegistrationErrorCode As DeviceRegistrationErrorCode
C#
public DeviceRegistrationErrorCode RegistrationErrorCode { get; }
C++

J#

JScript

Property Value
Type: DeviceRegistrationErrorCode
The exception error code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationFailedException Class
DeviceRegistrationFailedException Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationFailedException Events
[image]

Protected Events

 | Name | Description
protected event | SerializeObjectState | (inherited from Exception)

See Also

Reference

DeviceRegistrationFailedException Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationRequest Class
See Also Members
[image]

Contains the data that is needed to register a device with the Microsoft account identity provider of Microsoft Dynamics CRM Online.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationRequest

Syntax

Visual Basic
<XmlRootAttribute("DeviceAddRequest")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public NotInheritable Class DeviceRegistrationRequest
C#
[XmlRootAttribute("DeviceAddRequest")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public sealed class DeviceRegistrationRequest
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Samples.DeviceRegistrationRequest
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Members
Microsoft.Xrm.Client.Services.Samples Namespace
DeviceRegistrationResponse
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationRequest Members
See Also Constructors Methods Properties
[image]

Contains the data that is needed to register a device with the Microsoft account identity provider of Microsoft Dynamics CRM Online.

The following tables list the members exposed by the DeviceRegistrationRequest type.

Public Constructors

Name | Description
DeviceRegistrationRequest | Overloaded.
Top

Public Properties

 | Name | Description
public property | Authentication | Gets or sets the name and password information required to register a device.
public property | ClientInfo | Gets or sets information about the client application.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DeviceRegistrationRequest Class
Microsoft.Xrm.Client.Services.Samples Namespace
DeviceRegistrationResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationRequest Constructor
[image]

Overload List

Name | Description
DeviceRegistrationRequest () | Initializes a new instance of theDeviceRegistrationRequest class.
DeviceRegistrationRequest (Guid, LiveDevice) | Initializes a new instance of theDeviceRegistrationRequest class using an application identifier and device information/.

See Also

Reference

DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationRequest Constructor ()
[image]

Initializes a new instance of the DeviceRegistrationRequest class.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New DeviceRegistrationRequest

Syntax

Visual Basic
Public Sub New
C#
public DeviceRegistrationRequest ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationRequest Constructor (Guid, LiveDevice)
[image]

Initializes a new instance of the DeviceRegistrationRequest class using an application identifier and device information/.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim applicationId As Guid
Dim device As LiveDevice

Dim instance As New DeviceRegistrationRequest(applicationId, device)

Syntax

Visual Basic
Public Sub New ( _
    applicationId As Guid, _
    device As LiveDevice _
)
C#
public DeviceRegistrationRequest (
    Guid applicationId,
    LiveDevice device
)
C++

J#

JScript

Parameters
applicationId
Type: Guid. The An identifier for the client application.
device
Type: LiveDevice. Microsoft account device information.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationRequest Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DeviceRegistrationRequest Class
Microsoft.Xrm.Client.Services.Samples Namespace
DeviceRegistrationResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationRequest Properties
[image]

Public Properties

 | Name | Description
public property | Authentication | Gets or sets the name and password information required to register a device.
public property | ClientInfo | Gets or sets information about the client application.

See Also

Reference

DeviceRegistrationRequest Class
Microsoft.Xrm.Client.Services.Samples Namespace
DeviceRegistrationResponse

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationRequest.Authentication Property
[image]

Gets or sets the name and password information required to register a device.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationRequest
Dim value As DeviceRegistrationAuthentication

value = instance.Authentication

instance.Authentication = value

Syntax

Visual Basic
<XmlElementAttribute("Authentication")> _
Public Property Authentication As DeviceRegistrationAuthentication
C#
[XmlElementAttribute("Authentication")]
public DeviceRegistrationAuthentication Authentication { get; set; }
C++

J#

JScript

Property Value
Type: DeviceRegistrationAuthentication
Device registration information.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Client.Services.Samples Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationRequest.ClientInfo Property
[image]

Gets or sets information about the client application.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationRequest
Dim value As DeviceRegistrationClientInfo

value = instance.ClientInfo

instance.ClientInfo = value

Syntax

Visual Basic
<XmlElementAttribute("ClientInfo")> _
Public Property ClientInfo As DeviceRegistrationClientInfo
C#
[XmlElementAttribute("ClientInfo")]
public DeviceRegistrationClientInfo ClientInfo { get; set; }
C++

J#

JScript

Property Value
Type: DeviceRegistrationClientInfo
Information about the client application.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationRequest Class
DeviceRegistrationRequest Members
Microsoft.Xrm.Client.Services.Samples Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationResponse Class
See Also Members
[image]

Contains the response from executing a DeviceRegistrationRequest.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationResponse

Syntax

Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<XmlRootAttribute("DeviceAddResponse")> _
Public NotInheritable Class DeviceRegistrationResponse
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[XmlRootAttribute("DeviceAddResponse")]
public sealed class DeviceRegistrationResponse
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Samples.DeviceRegistrationResponse
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Members
Microsoft.Xrm.Client.Services.Samples Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationResponse Members
See Also Constructors Methods Properties
[image]

Contains the response from executing a DeviceRegistrationRequest.

The following tables list the members exposed by the DeviceRegistrationResponse type.

Public Constructors

Name | Description
DeviceRegistrationResponse | Initializes a new instance of the DeviceRegistrationResponse class.
Top

Public Properties

 | Name | Description
public property | Error | Gets or sets the error returned from the Microsoft account identity provider.
public property | ErrorSubCode | Gets or sets the error subcode.
public property | IsSuccess | Gets or sets an indication if the device registration was successful.
public property | Puid |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DeviceRegistrationResponse Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationResponse Constructor
[image]

Initializes a new instance of the DeviceRegistrationResponse class.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New DeviceRegistrationResponse

Syntax

Visual Basic
Public Sub New
C#
public DeviceRegistrationResponse ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationResponse Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DeviceRegistrationResponse Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationResponse Properties
[image]

Public Properties

 | Name | Description
public property | Error | Gets or sets the error returned from the Microsoft account identity provider.
public property | ErrorSubCode | Gets or sets the error subcode.
public property | IsSuccess | Gets or sets an indication if the device registration was successful.
public property | Puid |

See Also

Reference

DeviceRegistrationResponse Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationResponse.Error Property
[image]

Gets or sets the error returned from the Microsoft account identity provider.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationResponse
Dim value As DeviceRegistrationResponseError

value = instance.Error

instance.Error = value

Syntax

Visual Basic
<XmlElementAttribute("Error")> _
Public Property Error As DeviceRegistrationResponseError
C#
[XmlElementAttribute("Error")]
public DeviceRegistrationResponseError Error { get; set; }
C++

J#

JScript

Property Value
Type: DeviceRegistrationResponseError
The error returned from the identity provider.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationResponse.ErrorSubCode Property
[image]

Gets or sets the error subcode.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationResponse
Dim value As String

value = instance.ErrorSubCode

instance.ErrorSubCode = value

Syntax

Visual Basic
<XmlElementAttribute("ErrorSubcode")> _
Public Property ErrorSubCode As String
C#
[XmlElementAttribute("ErrorSubcode")]
public string ErrorSubCode { get; set; }
C++

J#

JScript

Property Value
Type: String
The error subcode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationResponse.IsSuccess Property
[image]

Gets or sets an indication if the device registration was successful.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationResponse
Dim value As Boolean

value = instance.IsSuccess

instance.IsSuccess = value

Syntax

Visual Basic
<XmlElementAttribute("success")> _
Public Property IsSuccess As Boolean
C#
[XmlElementAttribute("success")]
public bool IsSuccess { get; set; }
C++

J#

JScript

Property Value
Type: Boolean
Returns true if the registration was successful; otherwise, false.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationResponse.Puid Property
[image]

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationResponse
Dim value As String

value = instance.Puid

instance.Puid = value

Syntax

Visual Basic
<XmlElementAttribute("puid")> _
Public Property Puid As String
C#
[XmlElementAttribute("puid")]
public string Puid { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponse Class
DeviceRegistrationResponse Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationResponseError Class
See Also Members
[image]

Contains registration failure details.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationResponseError

Syntax

Visual Basic
<XmlRootAttribute("Error")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public NotInheritable Class DeviceRegistrationResponseError
C#
[XmlRootAttribute("Error")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public sealed class DeviceRegistrationResponseError
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Samples.DeviceRegistrationResponseError
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponseError Members
Microsoft.Xrm.Client.Services.Samples Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationResponseError Members
See Also Constructors Methods Properties
[image]

Contains registration failure details.

The following tables list the members exposed by the DeviceRegistrationResponseError type.

Public Constructors

Name | Description
DeviceRegistrationResponseError | Initializes a new instance of the DeviceRegistrationResponseError class.
Top

Public Properties

 | Name | Description
public property | Code | Gets or sets the string version of the error code, which is de-serialized from the registration response
public property | RegistrationErrorCode | Gets the enumeration-typed equivalent value that’s used in the rest of the code.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DeviceRegistrationResponseError Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationResponseError Constructor
[image]

Initializes a new instance of the DeviceRegistrationResponseError class.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New DeviceRegistrationResponseError

Syntax

Visual Basic
Public Sub New
C#
public DeviceRegistrationResponseError ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponseError Class
DeviceRegistrationResponseError Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationResponseError Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DeviceRegistrationResponseError Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationResponseError Properties
[image]

Public Properties

 | Name | Description
public property | Code | Gets or sets the string version of the error code, which is de-serialized from the registration response
public property | RegistrationErrorCode | Gets the enumeration-typed equivalent value that’s used in the rest of the code.

See Also

Reference

DeviceRegistrationResponseError Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceRegistrationResponseError.Code Property
[image]

Gets or sets the string version of the error code, which is de-serialized from the registration response

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationResponseError
Dim value As String

value = instance.Code

instance.Code = value

Syntax

Visual Basic
<XmlAttributeAttribute("Code")> _
Public Property Code As String
C#
[XmlAttributeAttribute("Code")]
public string Code { get; set; }
C++

J#

JScript

Property Value
Type: String
The string version of the error code.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponseError Class
DeviceRegistrationResponseError Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceRegistrationResponseError.RegistrationErrorCode Property
[image]

Gets the enumeration-typed equivalent value that’s used in the rest of the code.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceRegistrationResponseError
Dim value As DeviceRegistrationErrorCode

value = instance.RegistrationErrorCode

Syntax

Visual Basic
<XmlIgnoreAttribute> _
Public Property RegistrationErrorCode As DeviceRegistrationErrorCode
C#
[XmlIgnoreAttribute]
public DeviceRegistrationErrorCode RegistrationErrorCode { get; }
C++

J#

JScript

Property Value
Type: DeviceRegistrationErrorCode
The enumeration-typed equivalent value.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceRegistrationResponseError Class
DeviceRegistrationResponseError Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceUserName Class
See Also Members
[image]

Provides a user name for a device.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceUserName

Syntax

Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public NotInheritable Class DeviceUserName
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public sealed class DeviceUserName
C++

J#

JScript

  Remarks
The device name and device password (encrypted and decrypted) for which the token being held by this class is valid.

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Samples.DeviceUserName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Members
Microsoft.Xrm.Client.Services.Samples Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


DeviceUserName Members
See Also Constructors Methods Properties
[image]

Provides a user name for a device.

The following tables list the members exposed by the DeviceUserName type.

Public Constructors

Name | Description
DeviceUserName | Initializes a new instance of theDeviceUserName class.
Top

Public Properties

 | Name | Description
public property | DecryptedPassword | Gets or sets the decrypted device password.
public property | DeviceId | Gets the device identifier.
public property | DeviceName | Gets or sets the name of the device.
public property | EncryptedPassword | Gets or sets the encrypted device password.
public property | UserNameType | Gets or sets the user name type of the device.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToClientCredentials | Converts this type to ClientCredentials.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

DeviceUserName Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceUserName Constructor
[image]

Initializes a new instance of the DeviceUserName class.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New DeviceUserName

Syntax

Visual Basic
Public Sub New
C#
public DeviceUserName ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceUserName Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToClientCredentials | Converts this type to ClientCredentials.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

DeviceUserName Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceUserName.ToClientCredentials Method
[image]

Converts this type to ClientCredentials.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceUserName
Dim returnValue As ClientCredentials

returnValue = instance.ToClientCredentials

Syntax

Visual Basic
Public Function ToClientCredentials As ClientCredentials
C#
public ClientCredentials ToClientCredentials ()
C++

J#

JScript

Return Value
Type: ClientCredentials
The populated client credentials.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceUserName Properties
[image]

Public Properties

 | Name | Description
public property | DecryptedPassword | Gets or sets the decrypted device password.
public property | DeviceId | Gets the device identifier.
public property | DeviceName | Gets or sets the name of the device.
public property | EncryptedPassword | Gets or sets the encrypted device password.
public property | UserNameType | Gets or sets the user name type of the device.

See Also

Reference

DeviceUserName Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


DeviceUserName.DecryptedPassword Property
[image]

Gets or sets the decrypted device password.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceUserName
Dim value As String

value = instance.DecryptedPassword

instance.DecryptedPassword = value

Syntax

Visual Basic
<XmlIgnoreAttribute> _
Public Property DecryptedPassword As String
C#
[XmlIgnoreAttribute]
public string DecryptedPassword { get; set; }
C++

J#

JScript

Property Value
Type: String
The decrypted password.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceUserName.DeviceId Property
[image]

Gets the device identifier.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceUserName
Dim value As String

value = instance.DeviceId

Syntax

Visual Basic
Public ReadOnly Property DeviceId As String
C#
public string DeviceId { get; }
C++

J#

JScript

Property Value
Type: String
The device ID.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceUserName.DeviceName Property
[image]

Gets or sets the name of the device.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceUserName
Dim value As String

value = instance.DeviceName

instance.DeviceName = value

Syntax

Visual Basic
<XmlAttributeAttribute("username")> _
Public Property DeviceName As String
C#
[XmlAttributeAttribute("username")]
public string DeviceName { get; set; }
C++

J#

JScript

Property Value
Type: String
The name of the device.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceUserName.EncryptedPassword Property
[image]

Gets or sets the encrypted device password.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceUserName
Dim value As String

value = instance.EncryptedPassword

instance.EncryptedPassword = value

Syntax

Visual Basic
<XmlElementAttribute("Pwd")> _
Public Property EncryptedPassword As String
C#
[XmlElementAttribute("Pwd")]
public string EncryptedPassword { get; set; }
C++

J#

JScript

Property Value
Type: String
The encrypted device password.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Client.Services.Samples Namespace


DeviceUserName.UserNameType Property
[image]

Gets or sets the user name type of the device.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As DeviceUserName
Dim value As String

value = instance.UserNameType

instance.UserNameType = value

Syntax

Visual Basic
<XmlAttributeAttribute("type")> _
Public Property UserNameType As String
C#
[XmlAttributeAttribute("type")]
public string UserNameType { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Remarks
This defaults to “Logical”.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
DeviceUserName Class
DeviceUserName Members
Microsoft.Xrm.Client.Services.Samples Namespace


LiveDevice Class
See Also Members
[image]

Contains token information for an authenticated device.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LiveDevice

Syntax

Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<XmlRootAttribute("Data")> _
Public NotInheritable Class LiveDevice
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[XmlRootAttribute("Data")]
public sealed class LiveDevice
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Services.Samples.LiveDevice
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Members
Microsoft.Xrm.Client.Services.Samples Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


LiveDevice Members
See Also Constructors Methods Properties
[image]

Contains token information for an authenticated device.

The following tables list the members exposed by the LiveDevice type.

Public Constructors

Name | Description
LiveDevice | Initializes a new instance of the LiveDevice class.
Top

Public Properties

 | Name | Description
public property | ClockSkew | Gets or sets the maximum allowable time difference between client and server clock settings.
public property | Expiry | Gets or sets the date and time at which the token becomes invalid.
public property | Token | Gets or sets the authentication token.
public property | User | Gets or sets the device user name.
public property | Version | Gets or sets the version of the device.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

LiveDevice Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


LiveDevice Constructor
[image]

Initializes a new instance of the LiveDevice class.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New LiveDevice

Syntax

Visual Basic
Public Sub New
C#
public LiveDevice ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Client.Services.Samples Namespace


LiveDevice Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

LiveDevice Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


LiveDevice Properties
[image]

Public Properties

 | Name | Description
public property | ClockSkew | Gets or sets the maximum allowable time difference between client and server clock settings.
public property | Expiry | Gets or sets the date and time at which the token becomes invalid.
public property | Token | Gets or sets the authentication token.
public property | User | Gets or sets the device user name.
public property | Version | Gets or sets the version of the device.

See Also

Reference

LiveDevice Class
Microsoft.Xrm.Client.Services.Samples Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


LiveDevice.ClockSkew Property
[image]

Gets or sets the maximum allowable time difference between client and server clock settings.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LiveDevice
Dim value As String

value = instance.ClockSkew

instance.ClockSkew = value

Syntax

Visual Basic
<XmlElementAttribute("ClockSkew")> _
Public Property ClockSkew As String
C#
[XmlElementAttribute("ClockSkew")]
public string ClockSkew { get; set; }
C++

J#

JScript

Property Value
Type: String
The maximum allowable time difference.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Client.Services.Samples Namespace


LiveDevice.Expiry Property
[image]

Gets or sets the date and time at which the token becomes invalid.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LiveDevice
Dim value As String

value = instance.Expiry

instance.Expiry = value

Syntax

Visual Basic
<XmlElementAttribute("Expiry")> _
Public Property Expiry As String
C#
[XmlElementAttribute("Expiry")]
public string Expiry { get; set; }
C++

J#

JScript

Property Value
Type: String
The date and time when the token becomes invalid.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Client.Services.Samples Namespace


LiveDevice.Token Property
[image]

Gets or sets the authentication token.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LiveDevice
Dim value As XmlNode

value = instance.Token

instance.Token = value

Syntax

Visual Basic
<XmlElementAttribute("Token")> _
Public Property Token As XmlNode
C#
[XmlElementAttribute("Token")]
public XmlNode Token { get; set; }
C++

J#

JScript

Property Value
Type: XmlNode
The authentication token.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Client.Services.Samples Namespace


LiveDevice.User Property
[image]

Gets or sets the device user name.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LiveDevice
Dim value As DeviceUserName

value = instance.User

instance.User = value

Syntax

Visual Basic
<XmlElementAttribute("User")> _
Public Property User As DeviceUserName
C#
[XmlElementAttribute("User")]
public DeviceUserName User { get; set; }
C++

J#

JScript

Property Value
Type: DeviceUserName
The device user name.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Client.Services.Samples Namespace


LiveDevice.Version Property
[image]

Gets or sets the version of the device.

Namespace: Microsoft.Xrm.Client.Services.Samples
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LiveDevice
Dim value As Integer

value = instance.Version

instance.Version = value

Syntax

Visual Basic
<XmlAttributeAttribute("version")> _
Public Property Version As Integer
C#
[XmlAttributeAttribute("version")]
public int Version { get; set; }
C++

J#

JScript

Property Value
Type: Int32
The version of the device.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows 98,Windows 2000,Windows 2000 Server,Windows CE,Windows Server 2008,Windows 98 Second Edition,Pocket PC,Smart Phone,Windows Server 2003,Windows XP Professional,Windows Server 2008,Windows Server 2012,Windows 7,Windows 8,Windows 8.1
  See Also
Reference
LiveDevice Class
LiveDevice Members
Microsoft.Xrm.Client.Services.Samples Namespace


Microsoft.Xrm.Client.Threading Namespace

Classes

Class | Description
LockManager | (Developer Extensions)
LockProvider | (Developer Extensions)
MutexLockProvider | (Developer Extensions)

Interfaces

Interface | Description
ILockProvider | (Developer Extensions)


ILockProvider Interface
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ILockProvider

Syntax

Visual Basic
Public Interface ILockProvider
C#
public interface ILockProvider
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ILockProvider Members
See Also Methods
[image]

(Developer Extensions)

The following tables list the members exposed by the ILockProvider type.

Public Methods

 | Name | Description
public method | Get | Overloaded.
public method | Lock | Overloaded.
Top

See Also

Reference

ILockProvider Interface
Microsoft.Xrm.Client.Threading Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ILockProvider Methods
[image]

Public Methods

 | Name | Description
public method | Get | Overloaded.
public method | Lock | Overloaded.

See Also

Reference

ILockProvider Interface
Microsoft.Xrm.Client.Threading Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ILockProvider.Get Method
[image]

Overload List

Name | Description
ILockProvider.Get (String, Func, Func) |
ILockProvider.Get (String, Func, Func, Action) |
ILockProvider.Get (String, Int32, Func, Func) |
ILockProvider.Get (String, Int32, Func, Func, Action) |

See Also

Reference

ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


ILockProvider.Get Method (String, Func, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ILockProvider
Dim key As String
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim returnValue As T

returnValue = instance.Get(key, loadFromCache, loadFromService)

Syntax

Visual Basic
Function Get(Of T) ( _
    key As String, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T) _
) As T
C#
T Get<T> (
    string key,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService
)
C++

J#

JScript

GenericParameters
T
Parameters
key
loadFromCache
loadFromService
Return Value
Returns {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


ILockProvider.Get Method (String, Func, Func, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ILockProvider
Dim key As String
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim addToCache As Action(Of String, T)
Dim returnValue As T

returnValue = instance.Get(key, loadFromCache, loadFromService, addToCache)

Syntax

Visual Basic
Function Get(Of T) ( _
    key As String, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T), _
    addToCache As Action(Of String, T) _
) As T
C#
T Get<T> (
    string key,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService,
    Action<string,T> addToCache
)
C++

J#

JScript

GenericParameters
T
Parameters
key
loadFromCache
loadFromService
addToCache
Return Value
Returns {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


ILockProvider.Get Method (String, Int32, Func, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ILockProvider
Dim key As String
Dim millisecondsTimeout As Integer
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim returnValue As T

returnValue = instance.Get(key, millisecondsTimeout, loadFromCache, loadFromService)

Syntax

Visual Basic
Function Get(Of T) ( _
    key As String, _
    millisecondsTimeout As Integer, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T) _
) As T
C#
T Get<T> (
    string key,
    int millisecondsTimeout,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService
)
C++

J#

JScript

GenericParameters
T
Parameters
key
millisecondsTimeout
loadFromCache
loadFromService
Return Value
Returns {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


ILockProvider.Get Method (String, Int32, Func, Func, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ILockProvider
Dim key As String
Dim millisecondsTimeout As Integer
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim addToCache As Action(Of String, T)
Dim returnValue As T

returnValue = instance.Get(key, millisecondsTimeout, loadFromCache, loadFromService, addToCache)

Syntax

Visual Basic
Function Get(Of T) ( _
    key As String, _
    millisecondsTimeout As Integer, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T), _
    addToCache As Action(Of String, T) _
) As T
C#
T Get<T> (
    string key,
    int millisecondsTimeout,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService,
    Action<string,T> addToCache
)
C++

J#

JScript

GenericParameters
T
Parameters
key
millisecondsTimeout
loadFromCache
loadFromService
addToCache
Return Value
Returns {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


ILockProvider.Lock Method
[image]

Overload List

Name | Description
ILockProvider.Lock (String, Action) |
ILockProvider.Lock (String, Int32, Action) |
ILockProvider.Lock (String, Func) |
ILockProvider.Lock (String, Int32, Func) |

See Also

Reference

ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


ILockProvider.Lock Method (String, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ILockProvider
Dim key As String
Dim action As Action

instance.Lock(key, action)

Syntax

Visual Basic
Sub Lock ( _
    key As String, _
    action As Action _
)
C#
void Lock (
    string key,
    Action action
)
C++

J#

JScript

Parameters
key
action
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


ILockProvider.Lock Method (String, Int32, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ILockProvider
Dim key As String
Dim millisecondsTimeout As Integer
Dim action As Action

instance.Lock(key, millisecondsTimeout, action)

Syntax

Visual Basic
Sub Lock ( _
    key As String, _
    millisecondsTimeout As Integer, _
    action As Action _
)
C#
void Lock (
    string key,
    int millisecondsTimeout,
    Action action
)
C++

J#

JScript

Parameters
key
millisecondsTimeout
action
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


ILockProvider.Lock Method (String, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ILockProvider
Dim key As String
Dim action As Func(Of T)
Dim returnValue As T

returnValue = instance.Lock(key, action)

Syntax

Visual Basic
Function Lock(Of T) ( _
    key As String, _
    action As Func(Of T) _
) As T
C#
T Lock<T> (
    string key,
    Func<T> action
)
C++

J#

JScript

GenericParameters
T
Parameters
key
action
Return Value
Returns {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


ILockProvider.Lock Method (String, Int32, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ILockProvider
Dim key As String
Dim millisecondsTimeout As Integer
Dim action As Func(Of T)
Dim returnValue As T

returnValue = instance.Lock(key, millisecondsTimeout, action)

Syntax

Visual Basic
Function Lock(Of T) ( _
    key As String, _
    millisecondsTimeout As Integer, _
    action As Func(Of T) _
) As T
C#
T Lock<T> (
    string key,
    int millisecondsTimeout,
    Func<T> action
)
C++

J#

JScript

GenericParameters
T
Parameters
key
millisecondsTimeout
action
Return Value
Returns {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ILockProvider Interface
ILockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockManager Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic

Syntax

Visual Basic
Public NotInheritable Class LockManager
C#
public static class LockManager
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Threading.LockManager
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Members
Microsoft.Xrm.Client.Threading Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


LockManager Members
See Also Methods
[image]

(Developer Extensions)

The following tables list the members exposed by the LockManager type.

Public Methods (see also Extension Methods)

Name | Description
Get | Overloaded.
Lock | Overloaded.
Reset |
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

LockManager Class
Microsoft.Xrm.Client.Threading Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


LockManager Methods
[image]

Public Methods (see also Extension Methods)

Name | Description
Get | Overloaded.
Lock | Overloaded.
Reset |

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

LockManager Class
Microsoft.Xrm.Client.Threading Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


LockManager.Get Method
[image]

Overload List

Name | Description
LockManager.Get (String, Func, Func) |
LockManager.Get (String, Func, Func, Action) |
LockManager.Get (String, Int32, Func, Func) |
LockManager.Get (String, Int32, Func, Func, Action) |

See Also

Reference

LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Get Method (String, Func, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim key As String
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim returnValue As T

returnValue = LockManager.Get(key, loadFromCache, loadFromService)

Syntax

Visual Basic
Public Shared Function Get(Of T) ( _
    key As String, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T) _
) As T
C#
public static T Get<T> (
    string key,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService
)
C++

J#

JScript

GenericParameters
T
Parameters
key
loadFromCache
loadFromService
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Get Method (String, Func, Func, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim key As String
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim addToCache As Action(Of String, T)
Dim returnValue As T

returnValue = LockManager.Get(key, loadFromCache, loadFromService, addToCache)

Syntax

Visual Basic
Public Shared Function Get(Of T) ( _
    key As String, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T), _
    addToCache As Action(Of String, T) _
) As T
C#
public static T Get<T> (
    string key,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService,
    Action<string,T> addToCache
)
C++

J#

JScript

GenericParameters
T
Parameters
key
loadFromCache
loadFromService
addToCache
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Get Method (String, Int32, Func, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim key As String
Dim millisecondsTimeout As Integer
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim returnValue As T

returnValue = LockManager.Get(key, millisecondsTimeout, loadFromCache, loadFromService)

Syntax

Visual Basic
Public Shared Function Get(Of T) ( _
    key As String, _
    millisecondsTimeout As Integer, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T) _
) As T
C#
public static T Get<T> (
    string key,
    int millisecondsTimeout,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService
)
C++

J#

JScript

GenericParameters
T
Parameters
key
millisecondsTimeout
loadFromCache
loadFromService
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Get Method (String, Int32, Func, Func, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim key As String
Dim millisecondsTimeout As Integer
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim addToCache As Action(Of String, T)
Dim returnValue As T

returnValue = LockManager.Get(key, millisecondsTimeout, loadFromCache, loadFromService, addToCache)

Syntax

Visual Basic
Public Shared Function Get(Of T) ( _
    key As String, _
    millisecondsTimeout As Integer, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T), _
    addToCache As Action(Of String, T) _
) As T
C#
public static T Get<T> (
    string key,
    int millisecondsTimeout,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService,
    Action<string,T> addToCache
)
C++

J#

JScript

GenericParameters
T
Parameters
key
millisecondsTimeout
loadFromCache
loadFromService
addToCache
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Lock Method
[image]

Overload List

Name | Description
LockManager.Lock (String, Action) |
LockManager.Lock (String, Int32, Action) |
LockManager.Lock (String, Func) |
LockManager.Lock (String, Int32, Func) |

See Also

Reference

LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Lock Method (String, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim key As String
Dim action As Action

LockManager.Lock(key, action)

Syntax

Visual Basic
Public Shared Sub Lock ( _
    key As String, _
    action As Action _
)
C#
public static void Lock (
    string key,
    Action action
)
C++

J#

JScript

Parameters
key
action
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Lock Method (String, Int32, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim key As String
Dim millisecondsTimeout As Integer
Dim action As Action

LockManager.Lock(key, millisecondsTimeout, action)

Syntax

Visual Basic
Public Shared Sub Lock ( _
    key As String, _
    millisecondsTimeout As Integer, _
    action As Action _
)
C#
public static void Lock (
    string key,
    int millisecondsTimeout,
    Action action
)
C++

J#

JScript

Parameters
key
millisecondsTimeout
action
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Lock Method (String, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim key As String
Dim action As Func(Of T)
Dim returnValue As T

returnValue = LockManager.Lock(key, action)

Syntax

Visual Basic
Public Shared Function Lock(Of T) ( _
    key As String, _
    action As Func(Of T) _
) As T
C#
public static T Lock<T> (
    string key,
    Func<T> action
)
C++

J#

JScript

GenericParameters
T
Parameters
key
action
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Lock Method (String, Int32, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim key As String
Dim millisecondsTimeout As Integer
Dim action As Func(Of T)
Dim returnValue As T

returnValue = LockManager.Lock(key, millisecondsTimeout, action)

Syntax

Visual Basic
Public Shared Function Lock(Of T) ( _
    key As String, _
    millisecondsTimeout As Integer, _
    action As Func(Of T) _
) As T
C#
public static T Lock<T> (
    string key,
    int millisecondsTimeout,
    Func<T> action
)
C++

J#

JScript

GenericParameters
T
Parameters
key
millisecondsTimeout
action
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockManager.Reset Method
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
LockManager.Reset

Syntax

Visual Basic
Public Shared Sub Reset
C#
public static void Reset ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockManager Class
LockManager Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LockProvider

Syntax

Visual Basic
Public MustInherit Class LockProvider
    Implements ILockProvider
C#
public abstract class LockProvider : ILockProvider
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Threading.LockProvider

                Microsoft.Xrm.Client.Threading.MutexLockProvider
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


LockProvider Members
See Also Methods Constructors
[image]

(Developer Extensions)

The following tables list the members exposed by the LockProvider type.

Protected Constructors

Name | Description
LockProvider |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | Get | Overloaded.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Lock | Overloaded.
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetDefaultTimeout |
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

LockProvider Class
Microsoft.Xrm.Client.Threading Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


LockProvider Constructor
[image]

Initializes a new instance of the LockProvider Class.

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New LockProvider

Syntax

Visual Basic
Protected Sub New
C#
protected LockProvider ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | Get | Overloaded.
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Lock | Overloaded.
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetDefaultTimeout |
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

LockProvider Class
Microsoft.Xrm.Client.Threading Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


LockProvider.Get Method
[image]

Overload List

Name | Description
LockProvider.Get (String, Func, Func) |
LockProvider.Get (String, Func, Func, Action) |
LockProvider.Get (String, Int32, Func, Func) |
LockProvider.Get (String, Int32, Func, Func, Action) |

See Also

Reference

LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.Get Method (String, Func, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LockProvider
Dim key As String
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim returnValue As T

returnValue = instance.Get(key, loadFromCache, loadFromService)

Syntax

Visual Basic
Public Overridable Function Get(Of T) ( _
    key As String, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T) _
) As T
C#
public virtual T Get<T> (
    string key,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService
)
C++

J#

JScript

GenericParameters
T
Parameters
key
loadFromCache
loadFromService
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.Get Method (String, Func, Func, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LockProvider
Dim key As String
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim addToCache As Action(Of String, T)
Dim returnValue As T

returnValue = instance.Get(key, loadFromCache, loadFromService, addToCache)

Syntax

Visual Basic
Public Overridable Function Get(Of T) ( _
    key As String, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T), _
    addToCache As Action(Of String, T) _
) As T
C#
public virtual T Get<T> (
    string key,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService,
    Action<string,T> addToCache
)
C++

J#

JScript

GenericParameters
T
Parameters
key
loadFromCache
loadFromService
addToCache
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.Get Method (String, Int32, Func, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LockProvider
Dim key As String
Dim millisecondsTimeout As Integer
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim returnValue As T

returnValue = instance.Get(key, millisecondsTimeout, loadFromCache, loadFromService)

Syntax

Visual Basic
Public Overridable Function Get(Of T) ( _
    key As String, _
    millisecondsTimeout As Integer, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T) _
) As T
C#
public virtual T Get<T> (
    string key,
    int millisecondsTimeout,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService
)
C++

J#

JScript

GenericParameters
T
Parameters
key
millisecondsTimeout
loadFromCache
loadFromService
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.Get Method (String, Int32, Func, Func, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LockProvider
Dim key As String
Dim millisecondsTimeout As Integer
Dim loadFromCache As Func(Of String, Object)
Dim loadFromService As Func(Of String, T)
Dim addToCache As Action(Of String, T)
Dim returnValue As T

returnValue = instance.Get(key, millisecondsTimeout, loadFromCache, loadFromService, addToCache)

Syntax

Visual Basic
Public Overridable Function Get(Of T) ( _
    key As String, _
    millisecondsTimeout As Integer, _
    loadFromCache As Func(Of String, Object), _
    loadFromService As Func(Of String, T), _
    addToCache As Action(Of String, T) _
) As T
C#
public virtual T Get<T> (
    string key,
    int millisecondsTimeout,
    Func<string,Object> loadFromCache,
    Func<string,T> loadFromService,
    Action<string,T> addToCache
)
C++

J#

JScript

GenericParameters
T
Parameters
key
millisecondsTimeout
loadFromCache
loadFromService
addToCache
Return Value
Type: {0}.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.GetDefaultTimeout Method
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim returnValue As Integer

returnValue = Me.GetDefaultTimeout

Syntax

Visual Basic
Protected Overridable Function GetDefaultTimeout As Integer
C#
protected virtual int GetDefaultTimeout ()
C++

J#

JScript

Return Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.Lock Method
[image]

Overload List

Name | Description
LockProvider.Lock (String, Action) |
LockProvider.Lock (String, Int32, Action) |
LockProvider.Lock (String, Func) |
LockProvider.Lock (String, Int32, Func) |

See Also

Reference

LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.Lock Method (String, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LockProvider
Dim key As String
Dim action As Action

instance.Lock(key, action)

Syntax

Visual Basic
Public Overridable Sub Lock ( _
    key As String, _
    action As Action _
)
C#
public virtual void Lock (
    string key,
    Action action
)
C++

J#

JScript

Parameters
key
action
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.Lock Method (String, Int32, Action)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LockProvider
Dim key As String
Dim millisecondsTimeout As Integer
Dim action As Action

instance.Lock(key, millisecondsTimeout, action)

Syntax

Visual Basic
Public MustOverride Sub Lock ( _
    key As String, _
    millisecondsTimeout As Integer, _
    action As Action _
)
C#
public abstract void Lock (
    string key,
    int millisecondsTimeout,
    Action action
)
C++

J#

JScript

Parameters
key
millisecondsTimeout
action
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.Lock Method (String, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LockProvider
Dim key As String
Dim action As Func(Of T)
Dim returnValue As T

returnValue = instance.Lock(key, action)

Syntax

Visual Basic
Public Overridable Function Lock(Of T) ( _
    key As String, _
    action As Func(Of T) _
) As T
C#
public virtual T Lock<T> (
    string key,
    Func<T> action
)
C++

J#

JScript

GenericParameters
T
Parameters
key
action
Return Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


LockProvider.Lock Method (String, Int32, Func)
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As LockProvider
Dim key As String
Dim millisecondsTimeout As Integer
Dim action As Func(Of T)
Dim returnValue As T

returnValue = instance.Lock(key, millisecondsTimeout, action)

Syntax

Visual Basic
Public Overridable Function Lock(Of T) ( _
    key As String, _
    millisecondsTimeout As Integer, _
    action As Func(Of T) _
) As T
C#
public virtual T Lock<T> (
    string key,
    int millisecondsTimeout,
    Func<T> action
)
C++

J#

JScript

GenericParameters
T
Parameters
key
millisecondsTimeout
action
Return Value
Type: Int32.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
LockProvider Class
LockProvider Members
Microsoft.Xrm.Client.Threading Namespace


MutexLockProvider Class
See Also Members
[image]

(Developer Extensions)

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As MutexLockProvider

Syntax

Visual Basic
Public Class MutexLockProvider
    Inherits LockProvider
C#
public class MutexLockProvider : LockProvider
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Client.Threading.LockProvider
    Microsoft.Xrm.Client.Threading.MutexLockProvider
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MutexLockProvider Members
Microsoft.Xrm.Client.Threading Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


MutexLockProvider Members
See Also Constructors Methods
[image]

(Developer Extensions)

The following tables list the members exposed by the MutexLockProvider type.

Public Constructors

Name | Description
MutexLockProvider |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | Get | Overloaded. (inherited from LockProvider)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Lock | Overloaded. (inherited from LockProvider)
public method | Lock | Overridden.
public method | Lock | Overloaded. (inherited from LockProvider)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetDefaultTimeout | (inherited from LockProvider)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

MutexLockProvider Class
Microsoft.Xrm.Client.Threading Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


MutexLockProvider Constructor
[image]

Initializes a new instance of the MutexLockProvider Class.

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New MutexLockProvider

Syntax

Visual Basic
Public Sub New
C#
public MutexLockProvider ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MutexLockProvider Class
MutexLockProvider Members
Microsoft.Xrm.Client.Threading Namespace


MutexLockProvider Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | Get | Overloaded. (inherited from LockProvider)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | Lock | Overloaded. (inherited from LockProvider)
public method | Lock | Overridden.
public method | Lock | Overloaded. (inherited from LockProvider)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetDefaultTimeout | (inherited from LockProvider)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

MutexLockProvider Class
Microsoft.Xrm.Client.Threading Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


MutexLockProvider.Lock Method
[image]

Namespace: Microsoft.Xrm.Client.Threading
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As MutexLockProvider
Dim key As String
Dim millisecondsTimeout As Integer
Dim action As Action

instance.Lock(key, millisecondsTimeout, action)

Syntax

Visual Basic
Public Overrides Sub Lock ( _
    key As String, _
    millisecondsTimeout As Integer, _
    action As Action _
)
C#
public override void Lock (
    string key,
    int millisecondsTimeout,
    Action action
)
C++

J#

JScript

Parameters
key
millisecondsTimeout
action
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
MutexLockProvider Class
MutexLockProvider Members
Microsoft.Xrm.Client.Threading Namespace


Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Classes

Class | Description
AuthenticationPage | Wizard page for determining how to authenticate to CRM.
ConnectionData | Backing model for authenticating to CRM.
ConnectionDialog | ViewModel for authenticating to CRM.
ConnectionLauncher | Starts the wizard page for Microsoft Dynamics CRM authentication.
ConnectionReturnEventArgs | Represents the wrapper around the event arguments from the Return event on the wizard page.
EnumToStringUsingDescription | Utility to convert an enum value into a description of what it is. Used with AuthenticationTypeCode.
ErrorPage | Wizard page for generic error display.
ObservableObject | Interface wrapper superclass for objects that have properties that can be observed, i.e. that raise events when their properties are changed. Superclass of ConnectionData.
OrganizationPage | Wizard page for selecting the organization to which the portal website should connect. For when more than one organization is found via discovery service.
ProgressDialog | Generic wizard page for showing the progress of an operation, with percentage.

Delegates

Delegate | Description
ConnectionReturnEventHandler | Event callback type for the Return event on the wizard page.

Enumerations

Enumeration | Description
AuthenticationTypeCode | Contains values for the the type of authentication used. (Developer Extensions)
ConnectionResult | Contains values that describe a connection to an instance of Microsoft Dynamics CRM. (Developer Extensions)


AuthenticationPage Class
See Also Members
[image]

Wizard page for determining how to authenticate to CRM.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As AuthenticationPage

Syntax

Visual Basic
Public Class AuthenticationPage
    Inherits PageFunction(Of ConnectionResult)
    Implements IComponentConnector
C#
public class AuthenticationPage : PageFunction<ConnectionResult>, IComponentConnector
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Page

                System.Windows.Navigation.PageFunctionBase

                System.Windows.Navigation.PageFunction
                  Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.AuthenticationPage
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


AuthenticationPage Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

Wizard page for determining how to authenticate to CRM.

The following tables list the members exposed by the AuthenticationPage type.

Public Constructors

Name | Description
AuthenticationPage | Initializes a new instance of theAuthenticationPage class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Page)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from Page)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Page)
public property | FontSize | (inherited from Page)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Page)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | KeepAlive | (inherited from Page)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from Page)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RemoveFromJournal | (inherited from PageFunctionBase)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowsNavigationUI | (inherited from Page)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Page)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Page)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowHeight | (inherited from Page)
public property | WindowTitle | (inherited from Page)
public property | WindowWidth | (inherited from Page)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | connectionPage_Return |
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeShowsNavigationUI | (inherited from Page)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTitle | (inherited from Page)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShouldSerializeWindowHeight | (inherited from Page)
public method | ShouldSerializeWindowTitle | (inherited from Page)
public method | ShouldSerializeWindowWidth | (inherited from Page)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | CreateServiceConfiguration | Creates a service configuration object for the discovery service.
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReturn | (inherited from PageFunction)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Page)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
protected method | Start | (inherited from PageFunctionBase)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | Return | (inherited from PageFunction)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from Page)
AddText | (inherited from Page)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

AuthenticationPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


AuthenticationPage Constructor
[image]

Initializes a new instance of the AuthenticationPage class.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionData As ConnectionData

Dim instance As New AuthenticationPage(connectionData)

Syntax

Visual Basic
Public Sub New ( _
    connectionData As ConnectionData _
)
C#
public AuthenticationPage (
    ConnectionData connectionData
)
C++

J#

JScript

Parameters
connectionData
Type: ConnectionData. Configuration data for an existing connection.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationPage Class
AuthenticationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
CrmConnection


AuthenticationPage Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | connectionPage_Return |
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeShowsNavigationUI | (inherited from Page)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTitle | (inherited from Page)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShouldSerializeWindowHeight | (inherited from Page)
public method | ShouldSerializeWindowTitle | (inherited from Page)
public method | ShouldSerializeWindowWidth | (inherited from Page)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | CreateServiceConfiguration | Creates a service configuration object for the discovery service.
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReturn | (inherited from PageFunction)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Page)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
protected method | Start | (inherited from PageFunctionBase)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from Page)
AddText | (inherited from Page)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

AuthenticationPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


AuthenticationPage.connectionPage_Return Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As AuthenticationPage
Dim sender As Object
Dim e As ReturnEventArgs(Of ConnectionResult)

instance.connectionPage_Return(sender, e)

Syntax

Visual Basic
Public Sub connectionPage_Return ( _
    sender As Object, _
    e As ReturnEventArgs(Of ConnectionResult) _
)
C#
public void connectionPage_Return (
    Object sender,
    ReturnEventArgs<ConnectionResult> e
)
C++

J#

JScript

Parameters
sender
Type: Object.
e
Type: ReturnEventArgs<ConnectionResult>.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationPage Class
AuthenticationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


AuthenticationPage.CreateServiceConfiguration Method
[image]

Creates a service configuration object for the discovery service.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim uri As Uri
Dim returnValue As IServiceConfiguration(Of IDiscoveryService)

returnValue = Me.CreateServiceConfiguration(uri)

Syntax

Visual Basic
Protected Overridable Function CreateServiceConfiguration ( _
    uri As Uri _
) As IServiceConfiguration(Of IDiscoveryService)
C#
protected virtual IServiceConfiguration<IDiscoveryService> CreateServiceConfiguration (
    Uri uri
)
C++

J#

JScript

Parameters
uri
Type: URI. The URI of the discovery service.
Return Value
Type: IServiceConfiguration<IDiscoveryService>
A service configuration.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationPage Class
AuthenticationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


AuthenticationPage.InitializeComponent Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As AuthenticationPage

instance.InitializeComponent

Syntax

Visual Basic
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Public Sub InitializeComponent
C#
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
public void InitializeComponent ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationPage Class
AuthenticationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


AuthenticationPage.Connect Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As AuthenticationPage
Dim connectionId As Integer
Dim target As Object

CType(instance, IComponentConnector).Connect(connectionId, target)

Syntax

Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect
C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)
C++

J#

JScript

Parameters
connectionId
Type: Int32.
target
Type: Object.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
AuthenticationPage Class
AuthenticationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


AuthenticationPage Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Page)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from Page)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Page)
public property | FontSize | (inherited from Page)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Page)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | KeepAlive | (inherited from Page)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from Page)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RemoveFromJournal | (inherited from PageFunctionBase)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowsNavigationUI | (inherited from Page)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Page)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Page)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowHeight | (inherited from Page)
public property | WindowTitle | (inherited from Page)
public property | WindowWidth | (inherited from Page)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

AuthenticationPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


AuthenticationPage Events
[image]

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | Return | (inherited from PageFunction)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

AuthenticationPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


AuthenticationTypeCode Enumeration
[image]

Contains values for the the type of authentication used. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As AuthenticationTypeCode

Syntax

Visual Basic
<TypeConverterAttribute(GetType(EnumToStringUsingDescription))> _
Public Enumeration AuthenticationTypeCode
C#
[TypeConverterAttribute(typeof(EnumToStringUsingDescription))]
public enum AuthenticationTypeCode
C++

J#

JScript

  Members
Member name | Description
ActiveDirectory | Active directory authentication. Value = 1.
Federation | Federated authentication. Value = 2.
LiveId | Microsoft account authentication. Value = 3.
None | No authentication. Value = 0.
OnlineFederation | Microsoft account federated authentication. Value = 4.
  Remarks
This enumeration is used to set the following:
  • AuthenticationType
  • AuthenticationType
  • AuthenticationType
  • AuthenticationType

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData Class
See Also Members
[image]

Backing model for authenticating to CRM.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData

Syntax

Visual Basic
<DefaultMemberAttribute("Item")> _
Public Class ConnectionData
    Inherits ObservableObject
    Implements IDataErrorInfo
C#
[DefaultMemberAttribute("Item")]
public class ConnectionData : ObservableObject, IDataErrorInfo
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.ObservableObject
    Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.ConnectionData
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData Members
See Also Constructors Events Methods Properties
[image]

Backing model for authenticating to CRM.

The following tables list the members exposed by the ConnectionData type.

Public Constructors

Name | Description
ConnectionData | Initializes an instance of the ConnectionData class.
Top

Public Properties

 | Name | Description
public property | AuthenticationType | Gets or sets the authentication type.
public property | ConnectionString | Gets or sets the connection string.
public property | DeviceId | Gets or sets the device ID.
public property | DevicePassword | Gets or sets the device password.
public property | Domain | Gets or sets the domain.
public property | Error | Gets the error.
public property | FormPassword | Gets or sets the form password.
public property | IntegratedEnabled | Gets or sets whether integrated is enabled.
public property | IsValidForConnectionString | Gets whether the connection is valid for the connection string.
public property | Item | Gets the connection item.
public property | Organization | Gets or sets the organization information.
public property | Organizations | Gets or sets the collection of organizations.
public property | OrganizationUrl | Gets the organization URL.
public property | Password | Gets or sets the password
public property | ServerUrl | Gets or sets the server URL.
public property | Username | Gets or sets the user name.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnPropertyChanged | (inherited from ObservableObject)
protected method | OnPropertyChanging | (inherited from ObservableObject)
protected method | RaisePropertyChanged | (inherited from ObservableObject)
protected method | RaisePropertyChanging | (inherited from ObservableObject)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Public Events

 | Name | Description
public event | PropertyChanged | (inherited from ObservableObject)
public event | PropertyChanging | (inherited from ObservableObject)
Top

See Also

Reference

ConnectionData Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionData Constructor
[image]

Initializes an instance of the ConnectionData class.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ConnectionData

Syntax

Visual Basic
Public Sub New
C#
public ConnectionData ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnPropertyChanged | (inherited from ObservableObject)
protected method | OnPropertyChanging | (inherited from ObservableObject)
protected method | RaisePropertyChanged | (inherited from ObservableObject)
protected method | RaisePropertyChanging | (inherited from ObservableObject)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

ConnectionData Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionData Properties
[image]

Public Properties

 | Name | Description
public property | AuthenticationType | Gets or sets the authentication type.
public property | ConnectionString | Gets or sets the connection string.
public property | DeviceId | Gets or sets the device ID.
public property | DevicePassword | Gets or sets the device password.
public property | Domain | Gets or sets the domain.
public property | Error | Gets the error.
public property | FormPassword | Gets or sets the form password.
public property | IntegratedEnabled | Gets or sets whether integrated is enabled.
public property | IsValidForConnectionString | Gets whether the connection is valid for the connection string.
public property | Item | Gets the connection item.
public property | Organization | Gets or sets the organization information.
public property | Organizations | Gets or sets the collection of organizations.
public property | OrganizationUrl | Gets the organization URL.
public property | Password | Gets or sets the password
public property | ServerUrl | Gets or sets the server URL.
public property | Username | Gets or sets the user name.

See Also

Reference

ConnectionData Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionData.AuthenticationType Property
[image]

Gets or sets the authentication type.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As AuthenticationTypeCode

value = instance.AuthenticationType

instance.AuthenticationType = value

Syntax

Visual Basic
Public Property AuthenticationType As AuthenticationTypeCode
C#
public AuthenticationTypeCode AuthenticationType { get; set; }
C++

J#

JScript

Property Value
Type: AuthenticationTypeCode
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.ConnectionString Property
[image]

Gets or sets the connection string.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.ConnectionString

instance.ConnectionString = value

Syntax

Visual Basic
Public Property ConnectionString As String
C#
public string ConnectionString { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.DeviceId Property
[image]

Gets or sets the device ID.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.DeviceId

instance.DeviceId = value

Syntax

Visual Basic
Public Property DeviceId As String
C#
public string DeviceId { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.DevicePassword Property
[image]

Gets or sets the device password.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.DevicePassword

instance.DevicePassword = value

Syntax

Visual Basic
Public Property DevicePassword As String
C#
public string DevicePassword { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.Domain Property
[image]

Gets or sets the domain.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.Domain

instance.Domain = value

Syntax

Visual Basic
Public Property Domain As String
C#
public string Domain { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.Error Property
[image]

Gets the error.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.Error

Syntax

Visual Basic
Public ReadOnly Property Error As String
C#
public string Error { get; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.FormPassword Property
[image]

Gets or sets the form password.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.FormPassword

instance.FormPassword = value

Syntax

Visual Basic
Public Property FormPassword As String
C#
public string FormPassword { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.IntegratedEnabled Property
[image]

Gets or sets whether integrated is enabled.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As Boolean

value = instance.IntegratedEnabled

instance.IntegratedEnabled = value

Syntax

Visual Basic
Public Property IntegratedEnabled As Boolean
C#
public bool IntegratedEnabled { get; set; }
C++

J#

JScript

Property Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.IsValidForConnectionString Property
[image]

Gets whether the connection is valid for the connection string.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As Boolean

value = instance.IsValidForConnectionString

Syntax

Visual Basic
Public ReadOnly Property IsValidForConnectionString As Boolean
C#
public bool IsValidForConnectionString { get; }
C++

J#

JScript

Property Value
Type: Boolean.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.Item Property
[image]

Gets the connection item.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim columnName As String
Dim value As String

value = instance(columnName)

Syntax

Visual Basic
Public ReadOnly Default Property Item ( _
    columnName As String _
) As String
C#
public string this [
    string columnName
] { get; }
C++

J#

JScript

Parameters
columnName
Type: String. The column name.
Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.Organization Property
[image]

Gets or sets the organization information.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As OrganizationDetail

value = instance.Organization

instance.Organization = value

Syntax

Visual Basic
Public Property Organization As OrganizationDetail
C#
public OrganizationDetail Organization { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationDetail
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.Organizations Property
[image]

Gets or sets the collection of organizations.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As OrganizationDetailCollection

value = instance.Organizations

instance.Organizations = value

Syntax

Visual Basic
Public Property Organizations As OrganizationDetailCollection
C#
public OrganizationDetailCollection Organizations { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationDetailCollection
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.OrganizationUrl Property
[image]

Gets the organization URL.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.OrganizationUrl

Syntax

Visual Basic
Public ReadOnly Property OrganizationUrl As String
C#
public string OrganizationUrl { get; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.Password Property
[image]

Gets or sets the password

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.Password

instance.Password = value

Syntax

Visual Basic
Public Property Password As String
C#
public string Password { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.ServerUrl Property
[image]

Gets or sets the server URL.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.ServerUrl

instance.ServerUrl = value

Syntax

Visual Basic
Public Property ServerUrl As String
C#
public string ServerUrl { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData.Username Property
[image]

Gets or sets the user name.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionData
Dim value As String

value = instance.Username

instance.Username = value

Syntax

Visual Basic
Public Property Username As String
C#
public string Username { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionData Class
ConnectionData Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionData Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged | (inherited from ObservableObject)
public event | PropertyChanging | (inherited from ObservableObject)

See Also

Reference

ConnectionData Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog Class
See Also Members
[image]

ViewModel for authenticating to CRM.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionDialog

Syntax

Visual Basic
Public Class ConnectionDialog
    Inherits NavigationWindow
    Implements IComponentConnector
C#
public class ConnectionDialog : NavigationWindow, IComponentConnector
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Control

                System.Windows.Controls.ContentControl

                System.Windows.Window

                System.Windows.Navigation.NavigationWindow
                    Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.ConnectionDialog
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

ViewModel for authenticating to CRM.

The following tables list the members exposed by the ConnectionDialog type.

Public Constructors

Name | Description
ConnectionDialog | Initializes an instance of the ConnectionDialog class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AllowsTransparency | (inherited from Window)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | AuthenticationType | Gets or sets the authentication type.
public property | Background | (inherited from Control)
public property | BackStack | (inherited from NavigationWindow)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | CanGoBack | (inherited from NavigationWindow)
public property | CanGoForward | (inherited from NavigationWindow)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | ConnectionString | Gets or sets the connection string.
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | CurrentSource | (inherited from NavigationWindow)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | DialogResult | (inherited from Window)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | ForwardStack | (inherited from NavigationWindow)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from Window)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsActive | (inherited from Window)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Left | (inherited from Window)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from NavigationWindow)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | Organization | Gets or sets the organization detail information.
public property | Organizations | Gets or sets the collection of organizations.
public property | OrganizationUrl | Gets or sets the organization URL.
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | OwnedWindows | (inherited from Window)
public property | Owner | (inherited from Window)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | ResizeMode | (inherited from Window)
public property | Resources | (inherited from FrameworkElement)
public property | RestoreBounds | (inherited from Window)
public property | SandboxExternalContent | (inherited from NavigationWindow)
public property | ServerUrl | Gets or sets the server URL.
public property | ShowActivated | (inherited from Window)
public property | ShowInTaskbar | (inherited from Window)
public property | ShowsNavigationUI | (inherited from NavigationWindow)
public property | SizeToContent | (inherited from Window)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Source | (inherited from NavigationWindow)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | TaskbarItemInfo | (inherited from Window)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Window)
public property | ToolTip | (inherited from FrameworkElement)
public property | Top | (inherited from Window)
public property | Topmost | (inherited from Window)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowStartupLocation | (inherited from Window)
public property | WindowState | (inherited from Window)
public property | WindowStyle | (inherited from Window)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Activate | (inherited from Window)
public method | AddBackEntry | (inherited from NavigationWindow)
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | Close | (inherited from Window)
public method | CoerceValue | (inherited from DependencyObject)
public method | DragMove | (inherited from Window)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
 | GenerateCrmConnectionString |
 | GenerateWebConfigConnectionString |
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
 | GetOrganizations |
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | GoBack | (inherited from NavigationWindow)
public method | GoForward | (inherited from NavigationWindow)
public method | Hide | (inherited from Window)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | Navigate | (inherited from NavigationWindow)
public method | Navigate | (inherited from NavigationWindow)
public method | Navigate | (inherited from NavigationWindow)
public method | Navigate | (inherited from NavigationWindow)
public method | OnApplyTemplate | Overridden. (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | Refresh | (inherited from NavigationWindow)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveBackEntry | (inherited from NavigationWindow)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | Overridden. (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | Show | (inherited from Window)
public method | ShowDialog | (inherited from Window)
public method | StopLoading | (inherited from NavigationWindow)
 | TestOrganizationConnection |
 | TestServerConnection |
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddChild | Overridden. (inherited from ContentControl)
protected method | AddText | Overridden. (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from Control)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from Control)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnActivated | (inherited from Window)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnClosed | Overridden. (inherited from Window)
protected method | OnClosing | (inherited from Window)
protected method | OnContentChanged | Overridden. (inherited from ContentControl)
protected method | OnContentRendered | (inherited from Window)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from Window)
protected method | OnDeactivated | (inherited from Window)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLocationChanged | (inherited from Window)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | Overridden. (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnSourceInitialized | (inherited from Window)
protected method | OnStateChanged | (inherited from Window)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Public Events

 | Name | Description
public event | Activated | (inherited from Window)
public event | Closed | (inherited from Window)
public event | Closing | (inherited from Window)
public event | ContentRendered | (inherited from Window)
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | Deactivated | (inherited from Window)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | FragmentNavigation | (inherited from NavigationWindow)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | LoadCompleted | (inherited from NavigationWindow)
public event | Loaded | (inherited from FrameworkElement)
public event | LocationChanged | (inherited from Window)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | Navigated | (inherited from NavigationWindow)
public event | Navigating | (inherited from NavigationWindow)
public event | NavigationFailed | (inherited from NavigationWindow)
public event | NavigationProgress | (inherited from NavigationWindow)
public event | NavigationStopped | (inherited from NavigationWindow)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceInitialized | (inherited from Window)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StateChanged | (inherited from Window)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
BaseUri | (inherited from NavigationWindow)
Top

See Also

Reference

ConnectionDialog Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog Constructor
[image]

Initializes an instance of the ConnectionDialog class.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ConnectionDialog

Syntax

Visual Basic
Public Sub New
C#
public ConnectionDialog ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Activate | (inherited from Window)
public method | AddBackEntry | (inherited from NavigationWindow)
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | Close | (inherited from Window)
public method | CoerceValue | (inherited from DependencyObject)
public method | DragMove | (inherited from Window)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
 | GenerateCrmConnectionString |
 | GenerateWebConfigConnectionString |
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
 | GetOrganizations |
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | GoBack | (inherited from NavigationWindow)
public method | GoForward | (inherited from NavigationWindow)
public method | Hide | (inherited from Window)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | Navigate | (inherited from NavigationWindow)
public method | Navigate | (inherited from NavigationWindow)
public method | Navigate | (inherited from NavigationWindow)
public method | Navigate | (inherited from NavigationWindow)
public method | OnApplyTemplate | Overridden. (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | Refresh | (inherited from NavigationWindow)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveBackEntry | (inherited from NavigationWindow)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | Overridden. (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | Show | (inherited from Window)
public method | ShowDialog | (inherited from Window)
public method | StopLoading | (inherited from NavigationWindow)
 | TestOrganizationConnection |
 | TestServerConnection |
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddChild | Overridden. (inherited from ContentControl)
protected method | AddText | Overridden. (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from Control)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from Control)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnActivated | (inherited from Window)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnClosed | Overridden. (inherited from Window)
protected method | OnClosing | (inherited from Window)
protected method | OnContentChanged | Overridden. (inherited from ContentControl)
protected method | OnContentRendered | (inherited from Window)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from Window)
protected method | OnDeactivated | (inherited from Window)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLocationChanged | (inherited from Window)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | Overridden. (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnSourceInitialized | (inherited from Window)
protected method | OnStateChanged | (inherited from Window)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

ConnectionDialog Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.GenerateCrmConnectionString Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As ConnectionData
Dim returnValue As String

returnValue = ConnectionDialog.GenerateCrmConnectionString(connection)

Syntax

Visual Basic
Public Shared Function GenerateCrmConnectionString ( _
    connection As ConnectionData _
) As String
C#
public static string GenerateCrmConnectionString (
    ConnectionData connection
)
C++

J#

JScript

Parameters
connection
Return Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.GenerateWebConfigConnectionString Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connection As ConnectionData
Dim returnValue As String

returnValue = ConnectionDialog.GenerateWebConfigConnectionString(connection)

Syntax

Visual Basic
Public Shared Function GenerateWebConfigConnectionString ( _
    connection As ConnectionData _
) As String
C#
public static string GenerateWebConfigConnectionString (
    ConnectionData connection
)
C++

J#

JScript

Parameters
connection
Return Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.GetOrganizations Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionData As ConnectionData
Dim returnValue As OrganizationDetailCollection

returnValue = ConnectionDialog.GetOrganizations(connectionData)

Syntax

Visual Basic
Public Shared Function GetOrganizations ( _
    connectionData As ConnectionData _
) As OrganizationDetailCollection
C#
public static OrganizationDetailCollection GetOrganizations (
    ConnectionData connectionData
)
C++

J#

JScript

Parameters
connectionData
Return Value
Type: OrganizationDetailCollection
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.InitializeComponent Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionDialog

instance.InitializeComponent

Syntax

Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent
C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
public void InitializeComponent ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.Connect Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionDialog
Dim connectionId As Integer
Dim target As Object

CType(instance, IComponentConnector).Connect(connectionId, target)

Syntax

Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect
C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)
C++

J#

JScript

Parameters
connectionId
target
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.TestOrganizationConnection Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionString As String
Dim returnValue As Boolean

returnValue = ConnectionDialog.TestOrganizationConnection(connectionString)

Syntax

Visual Basic
Public Shared Function TestOrganizationConnection ( _
    connectionString As String _
) As Boolean
C#
public static bool TestOrganizationConnection (
    string connectionString
)
C++

J#

JScript

Parameters
connectionString
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.TestServerConnection Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionData As ConnectionData
Dim returnValue As Boolean

returnValue = ConnectionDialog.TestServerConnection(connectionData)

Syntax

Visual Basic
Public Shared Function TestServerConnection ( _
    connectionData As ConnectionData _
) As Boolean
C#
public static bool TestServerConnection (
    ConnectionData connectionData
)
C++

J#

JScript

Parameters
connectionData
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AllowsTransparency | (inherited from Window)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | AuthenticationType | Gets or sets the authentication type.
public property | Background | (inherited from Control)
public property | BackStack | (inherited from NavigationWindow)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | CanGoBack | (inherited from NavigationWindow)
public property | CanGoForward | (inherited from NavigationWindow)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | ConnectionString | Gets or sets the connection string.
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | CurrentSource | (inherited from NavigationWindow)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | DialogResult | (inherited from Window)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | ForwardStack | (inherited from NavigationWindow)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from Window)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsActive | (inherited from Window)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Left | (inherited from Window)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from NavigationWindow)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | Organization | Gets or sets the organization detail information.
public property | Organizations | Gets or sets the collection of organizations.
public property | OrganizationUrl | Gets or sets the organization URL.
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | OwnedWindows | (inherited from Window)
public property | Owner | (inherited from Window)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | ResizeMode | (inherited from Window)
public property | Resources | (inherited from FrameworkElement)
public property | RestoreBounds | (inherited from Window)
public property | SandboxExternalContent | (inherited from NavigationWindow)
public property | ServerUrl | Gets or sets the server URL.
public property | ShowActivated | (inherited from Window)
public property | ShowInTaskbar | (inherited from Window)
public property | ShowsNavigationUI | (inherited from NavigationWindow)
public property | SizeToContent | (inherited from Window)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Source | (inherited from NavigationWindow)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | TaskbarItemInfo | (inherited from Window)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Window)
public property | ToolTip | (inherited from FrameworkElement)
public property | Top | (inherited from Window)
public property | Topmost | (inherited from Window)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowStartupLocation | (inherited from Window)
public property | WindowState | (inherited from Window)
public property | WindowStyle | (inherited from Window)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

Explicit Interface Implementations

Name | Description
BaseUri | (inherited from NavigationWindow)

See Also

Reference

ConnectionDialog Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.AuthenticationType Property
[image]

Gets or sets the authentication type.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionDialog
Dim value As AuthenticationTypeCode

value = instance.AuthenticationType

instance.AuthenticationType = value

Syntax

Visual Basic
Public Property AuthenticationType As AuthenticationTypeCode
C#
public AuthenticationTypeCode AuthenticationType { get; set; }
C++

J#

JScript

Property Value
Type: AuthenticationTypeCode.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.ConnectionString Property
[image]

Gets or sets the connection string.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionDialog
Dim value As String

value = instance.ConnectionString

instance.ConnectionString = value

Syntax

Visual Basic
Public Property ConnectionString As String
C#
public string ConnectionString { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.Organization Property
[image]

Gets or sets the organization detail information.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionDialog
Dim value As OrganizationDetail

value = instance.Organization

instance.Organization = value

Syntax

Visual Basic
Public Property Organization As OrganizationDetail
C#
public OrganizationDetail Organization { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationDetail
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.Organizations Property
[image]

Gets or sets the collection of organizations.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionDialog
Dim value As OrganizationDetailCollection

value = instance.Organizations

instance.Organizations = value

Syntax

Visual Basic
Public Property Organizations As OrganizationDetailCollection
C#
public OrganizationDetailCollection Organizations { get; set; }
C++

J#

JScript

Property Value
Type: OrganizationDetailCollection
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.OrganizationUrl Property
[image]

Gets or sets the organization URL.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionDialog
Dim value As String

value = instance.OrganizationUrl

instance.OrganizationUrl = value

Syntax

Visual Basic
Public Property OrganizationUrl As String
C#
public string OrganizationUrl { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog.ServerUrl Property
[image]

Gets or sets the server URL.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionDialog
Dim value As String

value = instance.ServerUrl

instance.ServerUrl = value

Syntax

Visual Basic
Public Property ServerUrl As String
C#
public string ServerUrl { get; set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionDialog Class
ConnectionDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionDialog Events
[image]

Public Events

 | Name | Description
public event | Activated | (inherited from Window)
public event | Closed | (inherited from Window)
public event | Closing | (inherited from Window)
public event | ContentRendered | (inherited from Window)
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | Deactivated | (inherited from Window)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | FragmentNavigation | (inherited from NavigationWindow)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | LoadCompleted | (inherited from NavigationWindow)
public event | Loaded | (inherited from FrameworkElement)
public event | LocationChanged | (inherited from Window)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | Navigated | (inherited from NavigationWindow)
public event | Navigating | (inherited from NavigationWindow)
public event | NavigationFailed | (inherited from NavigationWindow)
public event | NavigationProgress | (inherited from NavigationWindow)
public event | NavigationStopped | (inherited from NavigationWindow)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceInitialized | (inherited from Window)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StateChanged | (inherited from Window)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

ConnectionDialog Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionLauncher Class
See Also Members
[image]

Starts the wizard page for Microsoft Dynamics CRM authentication.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionLauncher

Syntax

Visual Basic
Public Class ConnectionLauncher
    Inherits PageFunction(Of ConnectionResult)
C#
public class ConnectionLauncher : PageFunction<ConnectionResult>
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Page

                System.Windows.Navigation.PageFunctionBase

                System.Windows.Navigation.PageFunction
                  Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.ConnectionLauncher
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionLauncher Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionLauncher Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

Starts the wizard page for Microsoft Dynamics CRM authentication.

The following tables list the members exposed by the ConnectionLauncher type.

Public Constructors

Name | Description
ConnectionLauncher | Initializes a new instance of the ConnectionLauncher class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Page)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from Page)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Page)
public property | FontSize | (inherited from Page)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Page)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | KeepAlive | (inherited from Page)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from Page)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RemoveFromJournal | (inherited from PageFunctionBase)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowsNavigationUI | (inherited from Page)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Page)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Page)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowHeight | (inherited from Page)
public property | WindowTitle | (inherited from Page)
public property | WindowWidth | (inherited from Page)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | connectionPage_Return |
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeShowsNavigationUI | (inherited from Page)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTitle | (inherited from Page)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShouldSerializeWindowHeight | (inherited from Page)
public method | ShouldSerializeWindowTitle | (inherited from Page)
public method | ShouldSerializeWindowWidth | (inherited from Page)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReturn | (inherited from PageFunction)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Page)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
protected method | Start | Overridden.
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Public Events

 | Name | Description
public event | ConnectionReturn |
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | Return | (inherited from PageFunction)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from Page)
AddText | (inherited from Page)
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

ConnectionLauncher Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionLauncher Constructor
[image]

Initializes a new instance of the ConnectionLauncher class.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ConnectionLauncher

Syntax

Visual Basic
Public Sub New
C#
public ConnectionLauncher ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionLauncher Class
ConnectionLauncher Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ConnectionLauncher Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | connectionPage_Return |
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeShowsNavigationUI | (inherited from Page)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTitle | (inherited from Page)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShouldSerializeWindowHeight | (inherited from Page)
public method | ShouldSerializeWindowTitle | (inherited from Page)
public method | ShouldSerializeWindowWidth | (inherited from Page)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReturn | (inherited from PageFunction)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Page)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
protected method | Start | Overridden.

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from Page)
AddText | (inherited from Page)
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

ConnectionLauncher Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionLauncher.connectionPage_Return Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionLauncher
Dim sender As Object
Dim e As ReturnEventArgs(Of ConnectionResult)

instance.connectionPage_Return(sender, e)

Syntax

Visual Basic
Public Sub connectionPage_Return ( _
    sender As Object, _
    e As ReturnEventArgs(Of ConnectionResult) _
)
C#
public void connectionPage_Return (
    Object sender,
    ReturnEventArgs<ConnectionResult> e
)
C++

J#

JScript

Parameters
sender
e
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionLauncher Class
ConnectionLauncher Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ConnectionLauncher.Start Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Me.Start

Syntax

Visual Basic
Protected Overrides Sub Start
C#
protected override void Start ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionLauncher Class
ConnectionLauncher Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ConnectionLauncher Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Page)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from Page)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Page)
public property | FontSize | (inherited from Page)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Page)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | KeepAlive | (inherited from Page)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from Page)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RemoveFromJournal | (inherited from PageFunctionBase)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowsNavigationUI | (inherited from Page)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Page)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Page)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowHeight | (inherited from Page)
public property | WindowTitle | (inherited from Page)
public property | WindowWidth | (inherited from Page)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

ConnectionLauncher Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionLauncher Events
[image]

Public Events

 | Name | Description
public event | ConnectionReturn |
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | Return | (inherited from PageFunction)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

ConnectionLauncher Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionLauncher.ConnectionReturn Event
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionLauncher
Dim handler As ConnectionReturnEventHandler

AddHandler instance.ConnectionReturn, handler

Syntax

Visual Basic
Public Event ConnectionReturn As ConnectionReturnEventHandler
C#
public event ConnectionReturnEventHandler ConnectionReturn
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionLauncher Class
ConnectionLauncher Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ConnectionResult Enumeration
[image]

Contains values that describe a connection to an instance of Microsoft Dynamics CRM. (Developer Extensions)

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionResult

Syntax

Visual Basic
Public Enumeration ConnectionResult
C#
public enum ConnectionResult
C++

J#

JScript

  Members
Member name | Description
Canceled | The connection was canceled. Value = 1.
Connected | The connection was made successfully. Value = 0.
  Remarks
This enumeration is used in the ConnectionReturnEventArgs class.

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM
Simplified Connection to Microsoft Dynamics CRM


ConnectionReturnEventArgs Class
See Also Members
[image]

Represents the wrapper around the event arguments from the Return event on the wizard page.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionReturnEventArgs

Syntax

Visual Basic
Public Class ConnectionReturnEventArgs
C#
public class ConnectionReturnEventArgs
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.ConnectionReturnEventArgs
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionReturnEventArgs Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ConnectionReturnEventArgs Members
See Also Constructors Methods Properties
[image]

Represents the wrapper around the event arguments from the Return event on the wizard page.

The following tables list the members exposed by the ConnectionReturnEventArgs type.

Public Constructors

Name | Description
ConnectionReturnEventArgs |
Top

Public Properties

 | Name | Description
public property | Data |
public property | Result |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

ConnectionReturnEventArgs Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionReturnEventArgs Constructor
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim result As ConnectionResult
Dim data As Object

Dim instance As New ConnectionReturnEventArgs(result, data)

Syntax

Visual Basic
Public Sub New ( _
    result As ConnectionResult, _
    data As Object _
)
C#
public ConnectionReturnEventArgs (
    ConnectionResult result,
    Object data
)
C++

J#

JScript

Parameters
result
data
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionReturnEventArgs Class
ConnectionReturnEventArgs Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ConnectionReturnEventArgs Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

ConnectionReturnEventArgs Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionReturnEventArgs Properties
[image]

Public Properties

 | Name | Description
public property | Data |
public property | Result |

See Also

Reference

ConnectionReturnEventArgs Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ConnectionReturnEventArgs.Data Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionReturnEventArgs
Dim value As Object

value = instance.Data

Syntax

Visual Basic
Public Property Data As Object
C#
public Object Data { get; }
C++

J#

JScript

Property Value
Type: Object
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionReturnEventArgs Class
ConnectionReturnEventArgs Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ConnectionReturnEventArgs.Result Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ConnectionReturnEventArgs
Dim value As ConnectionResult

value = instance.Result

Syntax

Visual Basic
Public Property Result As ConnectionResult
C#
public ConnectionResult Result { get; }
C++

J#

JScript

Property Value
Type: ConnectionResult
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ConnectionReturnEventArgs Class
ConnectionReturnEventArgs Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ConnectionReturnEventHandler Delegate
[image]

Event callback type for the Return event on the wizard page.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ConnectionReturnEventHandler(AddressOf HandlerMethod)

Syntax

Visual Basic
Public Delegate Sub ConnectionReturnEventHandler ( _
    sender As Object, _
    e As ConnectionReturnEventArgs _
)
C#
public delegate void ConnectionReturnEventHandler (
    Object sender,
    ConnectionReturnEventArgs e
)
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EnumToStringUsingDescription Class
See Also Members
[image]

Utility to convert an enum value into a description of what it is. Used with AuthenticationTypeCode.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EnumToStringUsingDescription

Syntax

Visual Basic
Public Class EnumToStringUsingDescription
    Inherits TypeConverter
C#
public class EnumToStringUsingDescription : TypeConverter
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.ComponentModel.TypeConverter
    Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.EnumToStringUsingDescription
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumToStringUsingDescription Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


EnumToStringUsingDescription Members
See Also Constructors Methods
[image]

Utility to convert an enum value into a description of what it is. Used with AuthenticationTypeCode.

The following tables list the members exposed by the EnumToStringUsingDescription type.

Public Constructors

Name | Description
EnumToStringUsingDescription |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | CanConvertFrom | Overridden.
public method | CanConvertFrom | (inherited from TypeConverter)
public method | CanConvertTo | Overridden.
public method | CanConvertTo | (inherited from TypeConverter)
public method | ConvertFrom | (inherited from TypeConverter)
public method | ConvertFrom | (inherited from TypeConverter)
public method | ConvertFromInvariantString | (inherited from TypeConverter)
public method | ConvertFromInvariantString | (inherited from TypeConverter)
public method | ConvertFromString | (inherited from TypeConverter)
public method | ConvertFromString | (inherited from TypeConverter)
public method | ConvertFromString | (inherited from TypeConverter)
public method | ConvertTo | Overridden.
public method | ConvertTo | (inherited from TypeConverter)
public method | ConvertToInvariantString | (inherited from TypeConverter)
public method | ConvertToInvariantString | (inherited from TypeConverter)
public method | ConvertToString | (inherited from TypeConverter)
public method | ConvertToString | (inherited from TypeConverter)
public method | ConvertToString | (inherited from TypeConverter)
public method | CreateInstance | (inherited from TypeConverter)
public method | CreateInstance | (inherited from TypeConverter)
public method | Equals | (inherited from Object)
public method | GetCreateInstanceSupported | (inherited from TypeConverter)
public method | GetCreateInstanceSupported | (inherited from TypeConverter)
public method | GetHashCode | (inherited from Object)
public method | GetProperties | (inherited from TypeConverter)
public method | GetProperties | (inherited from TypeConverter)
public method | GetProperties | (inherited from TypeConverter)
public method | GetPropertiesSupported | (inherited from TypeConverter)
public method | GetPropertiesSupported | (inherited from TypeConverter)
public method | GetStandardValues | (inherited from TypeConverter)
public method | GetStandardValues | (inherited from TypeConverter)
public method | GetStandardValuesExclusive | (inherited from TypeConverter)
public method | GetStandardValuesExclusive | (inherited from TypeConverter)
public method | GetStandardValuesSupported | (inherited from TypeConverter)
public method | GetStandardValuesSupported | (inherited from TypeConverter)
public method | GetType | (inherited from Object)
public method | IsValid | (inherited from TypeConverter)
public method | IsValid | (inherited from TypeConverter)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetConvertFromException | (inherited from TypeConverter)
protected method | GetConvertToException | (inherited from TypeConverter)
protected method | MemberwiseClone | (inherited from Object)
protected method | SortProperties | (inherited from TypeConverter)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

See Also

Reference

EnumToStringUsingDescription Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EnumToStringUsingDescription Constructor
[image]

Initializes a new instance of the EnumToStringUsingDescription Class.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New EnumToStringUsingDescription

Syntax

Visual Basic
Public Sub New
C#
public EnumToStringUsingDescription ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumToStringUsingDescription Class
EnumToStringUsingDescription Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


EnumToStringUsingDescription Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | CanConvertFrom | Overridden.
public method | CanConvertFrom | (inherited from TypeConverter)
public method | CanConvertTo | Overridden.
public method | CanConvertTo | (inherited from TypeConverter)
public method | ConvertFrom | (inherited from TypeConverter)
public method | ConvertFrom | (inherited from TypeConverter)
public method | ConvertFromInvariantString | (inherited from TypeConverter)
public method | ConvertFromInvariantString | (inherited from TypeConverter)
public method | ConvertFromString | (inherited from TypeConverter)
public method | ConvertFromString | (inherited from TypeConverter)
public method | ConvertFromString | (inherited from TypeConverter)
public method | ConvertTo | Overridden.
public method | ConvertTo | (inherited from TypeConverter)
public method | ConvertToInvariantString | (inherited from TypeConverter)
public method | ConvertToInvariantString | (inherited from TypeConverter)
public method | ConvertToString | (inherited from TypeConverter)
public method | ConvertToString | (inherited from TypeConverter)
public method | ConvertToString | (inherited from TypeConverter)
public method | CreateInstance | (inherited from TypeConverter)
public method | CreateInstance | (inherited from TypeConverter)
public method | Equals | (inherited from Object)
public method | GetCreateInstanceSupported | (inherited from TypeConverter)
public method | GetCreateInstanceSupported | (inherited from TypeConverter)
public method | GetHashCode | (inherited from Object)
public method | GetProperties | (inherited from TypeConverter)
public method | GetProperties | (inherited from TypeConverter)
public method | GetProperties | (inherited from TypeConverter)
public method | GetPropertiesSupported | (inherited from TypeConverter)
public method | GetPropertiesSupported | (inherited from TypeConverter)
public method | GetStandardValues | (inherited from TypeConverter)
public method | GetStandardValues | (inherited from TypeConverter)
public method | GetStandardValuesExclusive | (inherited from TypeConverter)
public method | GetStandardValuesExclusive | (inherited from TypeConverter)
public method | GetStandardValuesSupported | (inherited from TypeConverter)
public method | GetStandardValuesSupported | (inherited from TypeConverter)
public method | GetType | (inherited from Object)
public method | IsValid | (inherited from TypeConverter)
public method | IsValid | (inherited from TypeConverter)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | GetConvertFromException | (inherited from TypeConverter)
protected method | GetConvertToException | (inherited from TypeConverter)
protected method | MemberwiseClone | (inherited from Object)
protected method | SortProperties | (inherited from TypeConverter)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

EnumToStringUsingDescription Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


EnumToStringUsingDescription.CanConvertFrom Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EnumToStringUsingDescription
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim returnValue As Boolean

returnValue = instance.CanConvertFrom(context, sourceType)

Syntax

Visual Basic
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
C#
public override bool CanConvertFrom (
    ITypeDescriptorContext context,
    Type sourceType
)
C++

J#

JScript

Parameters
context
sourceType
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumToStringUsingDescription Class
EnumToStringUsingDescription Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


EnumToStringUsingDescription.CanConvertTo Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EnumToStringUsingDescription
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim returnValue As Boolean

returnValue = instance.CanConvertTo(context, destinationType)

Syntax

Visual Basic
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
C#
public override bool CanConvertTo (
    ITypeDescriptorContext context,
    Type destinationType
)
C++

J#

JScript

Parameters
context
destinationType
Return Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumToStringUsingDescription Class
EnumToStringUsingDescription Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


EnumToStringUsingDescription.ConvertTo Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As EnumToStringUsingDescription
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim returnValue As Object

returnValue = instance.ConvertTo(context, culture, value, destinationType)

Syntax

Visual Basic
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
C#
public override Object ConvertTo (
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
C++

J#

JScript

Parameters
context
culture
value
destinationType
Return Value
Type: Object
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
EnumToStringUsingDescription Class
EnumToStringUsingDescription Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ErrorPage Class
See Also Members
[image]

Wizard page for generic error display.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ErrorPage

Syntax

Visual Basic
Public Class ErrorPage
    Inherits PageFunction(Of ConnectionResult)
    Implements IComponentConnector
C#
public class ErrorPage : PageFunction<ConnectionResult>, IComponentConnector
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Page

                System.Windows.Navigation.PageFunctionBase

                System.Windows.Navigation.PageFunction
                  Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.ErrorPage
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ErrorPage Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

Wizard page for generic error display.

The following tables list the members exposed by the ErrorPage type.

Public Constructors

Name | Description
ErrorPage |
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Page)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | CaptionText |
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from Page)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DescriptionText |
public property | DesiredSize | (inherited from UIElement)
public property | DetailsIsVisible |
public property | DetailsText |
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Page)
public property | FontSize | (inherited from Page)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Page)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | KeepAlive | (inherited from Page)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from Page)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RemoveFromJournal | (inherited from PageFunctionBase)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowsNavigationUI | (inherited from Page)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Page)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Page)
public property | TitleText |
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowHeight | (inherited from Page)
public property | WindowTitle | (inherited from Page)
public property | WindowWidth | (inherited from Page)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeShowsNavigationUI | (inherited from Page)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTitle | (inherited from Page)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShouldSerializeWindowHeight | (inherited from Page)
public method | ShouldSerializeWindowTitle | (inherited from Page)
public method | ShouldSerializeWindowWidth | (inherited from Page)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReturn | (inherited from PageFunction)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Page)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
protected method | Start | (inherited from PageFunctionBase)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | Return | (inherited from PageFunction)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from Page)
AddText | (inherited from Page)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

ErrorPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ErrorPage Constructor
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionData As ConnectionData

Dim instance As New ErrorPage(connectionData)

Syntax

Visual Basic
Public Sub New ( _
    connectionData As ConnectionData _
)
C#
public ErrorPage (
    ConnectionData connectionData
)
C++

J#

JScript

Parameters
connectionData
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorPage Class
ErrorPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ErrorPage Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeShowsNavigationUI | (inherited from Page)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTitle | (inherited from Page)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShouldSerializeWindowHeight | (inherited from Page)
public method | ShouldSerializeWindowTitle | (inherited from Page)
public method | ShouldSerializeWindowWidth | (inherited from Page)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReturn | (inherited from PageFunction)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Page)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
protected method | Start | (inherited from PageFunctionBase)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from Page)
AddText | (inherited from Page)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

ErrorPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ErrorPage.InitializeComponent Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ErrorPage

instance.InitializeComponent

Syntax

Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent
C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
public void InitializeComponent ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorPage Class
ErrorPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ErrorPage.Connect Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ErrorPage
Dim connectionId As Integer
Dim target As Object

CType(instance, IComponentConnector).Connect(connectionId, target)

Syntax

Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect
C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)
C++

J#

JScript

Parameters
connectionId
target
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorPage Class
ErrorPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ErrorPage Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Page)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | CaptionText |
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from Page)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DescriptionText |
public property | DesiredSize | (inherited from UIElement)
public property | DetailsIsVisible |
public property | DetailsText |
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Page)
public property | FontSize | (inherited from Page)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Page)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | KeepAlive | (inherited from Page)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from Page)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RemoveFromJournal | (inherited from PageFunctionBase)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowsNavigationUI | (inherited from Page)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Page)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Page)
public property | TitleText |
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowHeight | (inherited from Page)
public property | WindowTitle | (inherited from Page)
public property | WindowWidth | (inherited from Page)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

ErrorPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ErrorPage.CaptionText Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ErrorPage
Dim value As String

instance.CaptionText = value

Syntax

Visual Basic
Public WriteOnly Property CaptionText As String
C#
public string CaptionText { set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorPage Class
ErrorPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ErrorPage.DescriptionText Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ErrorPage
Dim value As String

instance.DescriptionText = value

Syntax

Visual Basic
Public WriteOnly Property DescriptionText As String
C#
public string DescriptionText { set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorPage Class
ErrorPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ErrorPage.DetailsIsVisible Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ErrorPage
Dim value As Boolean

instance.DetailsIsVisible = value

Syntax

Visual Basic
Public WriteOnly Property DetailsIsVisible As Boolean
C#
public bool DetailsIsVisible { set; }
C++

J#

JScript

Property Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorPage Class
ErrorPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ErrorPage.DetailsText Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ErrorPage
Dim value As String

instance.DetailsText = value

Syntax

Visual Basic
Public WriteOnly Property DetailsText As String
C#
public string DetailsText { set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorPage Class
ErrorPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ErrorPage.TitleText Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ErrorPage
Dim value As String

instance.TitleText = value

Syntax

Visual Basic
Public WriteOnly Property TitleText As String
C#
public string TitleText { set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ErrorPage Class
ErrorPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ErrorPage Events
[image]

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | Return | (inherited from PageFunction)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

ErrorPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObservableObject Class
See Also Members
[image]

Interface wrapper superclass for objects that have properties that can be observed, i.e. that raise events when their properties are changed. Superclass of ConnectionData.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObservableObject

Syntax

Visual Basic
<SerializableAttribute> _
Public Class ObservableObject
    Implements INotifyPropertyChanging, INotifyPropertyChanged
C#
[SerializableAttribute]
public class ObservableObject : INotifyPropertyChanging, INotifyPropertyChanged
C++

J#

JScript

  Inheritance Hierarchy
System.Object
  Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.ObservableObject

                Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.ConnectionData
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObservableObject Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ObservableObject Members
See Also Constructors Events Methods
[image]

Interface wrapper superclass for objects that have properties that can be observed, i.e. that raise events when their properties are changed. Superclass of ConnectionData.

The following tables list the members exposed by the ObservableObject type.

Public Constructors

Name | Description
ObservableObject |
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnPropertyChanged |
protected method | OnPropertyChanging |
protected method | RaisePropertyChanged |
protected method | RaisePropertyChanging |
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Public Events

 | Name | Description
public event | PropertyChanged |
public event | PropertyChanging |
Top

See Also

Reference

ObservableObject Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObservableObject Constructor
[image]

Initializes a new instance of the ObservableObject Class.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ObservableObject

Syntax

Visual Basic
Public Sub New
C#
public ObservableObject ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObservableObject Class
ObservableObject Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ObservableObject Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnPropertyChanged |
protected method | OnPropertyChanging |
protected method | RaisePropertyChanged |
protected method | RaisePropertyChanging |

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

See Also

Reference

ObservableObject Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObservableObject.OnPropertyChanged Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim args As PropertyChangedEventArgs

Me.OnPropertyChanged(args)

Syntax

Visual Basic
Protected Sub OnPropertyChanged ( _
    args As PropertyChangedEventArgs _
)
C#
protected void OnPropertyChanged (
    PropertyChangedEventArgs args
)
C++

J#

JScript

Parameters
args
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObservableObject Class
ObservableObject Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ObservableObject.OnPropertyChanging Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim args As PropertyChangingEventArgs

Me.OnPropertyChanging(args)

Syntax

Visual Basic
Protected Sub OnPropertyChanging ( _
    args As PropertyChangingEventArgs _
)
C#
protected void OnPropertyChanging (
    PropertyChangingEventArgs args
)
C++

J#

JScript

Parameters
args
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObservableObject Class
ObservableObject Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ObservableObject.RaisePropertyChanged Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String

Me.RaisePropertyChanged(propertyName)

Syntax

Visual Basic
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged (
    string propertyName
)
C++

J#

JScript

Parameters
propertyName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObservableObject Class
ObservableObject Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ObservableObject.RaisePropertyChanging Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim propertyName As String

Me.RaisePropertyChanging(propertyName)

Syntax

Visual Basic
Protected Sub RaisePropertyChanging ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanging (
    string propertyName
)
C++

J#

JScript

Parameters
propertyName
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObservableObject Class
ObservableObject Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ObservableObject Events
[image]

Public Events

 | Name | Description
public event | PropertyChanged |
public event | PropertyChanging |

See Also

Reference

ObservableObject Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ObservableObject.PropertyChanged Event
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObservableObject
Dim handler As PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler

Syntax

Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObservableObject Class
ObservableObject Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ObservableObject.PropertyChanging Event
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ObservableObject
Dim handler As PropertyChangingEventHandler

AddHandler instance.PropertyChanging, handler

Syntax

Visual Basic
Public Event PropertyChanging As PropertyChangingEventHandler
C#
public event PropertyChangingEventHandler PropertyChanging
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ObservableObject Class
ObservableObject Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


OrganizationPage Class
See Also Members
[image]

Wizard page for selecting the organization to which the portal website should connect. For when more than one organization is found via discovery service.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationPage

Syntax

Visual Basic
Public Class OrganizationPage
    Inherits PageFunction(Of ConnectionResult)
    Implements IComponentConnector
C#
public class OrganizationPage : PageFunction<ConnectionResult>, IComponentConnector
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Page

                System.Windows.Navigation.PageFunctionBase

                System.Windows.Navigation.PageFunction
                  Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.OrganizationPage
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


OrganizationPage Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

Wizard page for selecting the organization to which the portal website should connect. For when more than one organization is found via discovery service.

The following tables list the members exposed by the OrganizationPage type.

Public Constructors

Name | Description
OrganizationPage |
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Page)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from Page)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Page)
public property | FontSize | (inherited from Page)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Page)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | KeepAlive | (inherited from Page)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from Page)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RemoveFromJournal | (inherited from PageFunctionBase)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowsNavigationUI | (inherited from Page)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Page)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Page)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowHeight | (inherited from Page)
public property | WindowTitle | (inherited from Page)
public property | WindowWidth | (inherited from Page)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | connectionPage_Return |
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeShowsNavigationUI | (inherited from Page)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTitle | (inherited from Page)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShouldSerializeWindowHeight | (inherited from Page)
public method | ShouldSerializeWindowTitle | (inherited from Page)
public method | ShouldSerializeWindowWidth | (inherited from Page)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReturn | (inherited from PageFunction)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Page)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
protected method | Start | (inherited from PageFunctionBase)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | Return | (inherited from PageFunction)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from Page)
AddText | (inherited from Page)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

OrganizationPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationPage Constructor
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim connectionData As ConnectionData

Dim instance As New OrganizationPage(connectionData)

Syntax

Visual Basic
Public Sub New ( _
    connectionData As ConnectionData _
)
C#
public OrganizationPage (
    ConnectionData connectionData
)
C++

J#

JScript

Parameters
connectionData
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationPage Class
OrganizationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


OrganizationPage Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | CoerceValue | (inherited from DependencyObject)
public method | connectionPage_Return |
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeShowsNavigationUI | (inherited from Page)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTitle | (inherited from Page)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | ShouldSerializeWindowHeight | (inherited from Page)
public method | ShouldSerializeWindowTitle | (inherited from Page)
public method | ShouldSerializeWindowWidth | (inherited from Page)
public method | ToString | (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from FrameworkElement)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from FrameworkElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | (inherited from UIElement)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnReturn | (inherited from PageFunction)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Page)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
protected method | Start | (inherited from PageFunctionBase)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from Page)
AddText | (inherited from Page)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

OrganizationPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationPage.connectionPage_Return Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationPage
Dim sender As Object
Dim e As ReturnEventArgs(Of ConnectionResult)

instance.connectionPage_Return(sender, e)

Syntax

Visual Basic
Public Sub connectionPage_Return ( _
    sender As Object, _
    e As ReturnEventArgs(Of ConnectionResult) _
)
C#
public void connectionPage_Return (
    Object sender,
    ReturnEventArgs<ConnectionResult> e
)
C++

J#

JScript

Parameters
sender
e
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationPage Class
OrganizationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


OrganizationPage.InitializeComponent Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationPage

instance.InitializeComponent

Syntax

Visual Basic
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Public Sub InitializeComponent
C#
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
public void InitializeComponent ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationPage Class
OrganizationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


OrganizationPage.Connect Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As OrganizationPage
Dim connectionId As Integer
Dim target As Object

CType(instance, IComponentConnector).Connect(connectionId, target)

Syntax

Visual Basic
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect
C#
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)
C++

J#

JScript

Parameters
connectionId
target
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
OrganizationPage Class
OrganizationPage Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


OrganizationPage Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Page)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | CacheMode | (inherited from UIElement)
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from Page)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Page)
public property | FontSize | (inherited from Page)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Page)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsVisible | (inherited from UIElement)
public property | KeepAlive | (inherited from Page)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | NavigationService | (inherited from Page)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | RemoveFromJournal | (inherited from PageFunctionBase)
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | Resources | (inherited from FrameworkElement)
public property | ShowsNavigationUI | (inherited from Page)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | Tag | (inherited from FrameworkElement)
public property | Template | (inherited from Page)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Page)
public property | ToolTip | (inherited from FrameworkElement)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowHeight | (inherited from Page)
public property | WindowTitle | (inherited from Page)
public property | WindowWidth | (inherited from Page)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

OrganizationPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


OrganizationPage Events
[image]

Public Events

 | Name | Description
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | Return | (inherited from PageFunction)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

OrganizationPage Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ProgressDialog Class
See Also Members
[image]

Generic wizard page for showing the progress of an operation, with percentage.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ProgressDialog

Syntax

Visual Basic
Public Class ProgressDialog
    Inherits Window
    Implements IComponentConnector
C#
public class ProgressDialog : Window, IComponentConnector
C++

J#

JScript

  Inheritance Hierarchy
System.Object

                System.Windows.Threading.DispatcherObject

                System.Windows.DependencyObject

                System.Windows.Media.Visual

                System.Windows.UIElement

                System.Windows.FrameworkElement

                System.Windows.Controls.Control

                System.Windows.Controls.ContentControl

                System.Windows.Window
                  Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog.ProgressDialog
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProgressDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace
Other Resources
Developer Extensions for Microsoft Dynamics CRM


ProgressDialog Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

Generic wizard page for showing the progress of an operation, with percentage.

The following tables list the members exposed by the ProgressDialog type.

Public Constructors

Name | Description
ProgressDialog |
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AllowsTransparency | (inherited from Window)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | CaptionText |
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | DialogResult | (inherited from Window)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from Window)
public property | Indeterminate |
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsActive | (inherited from Window)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Left | (inherited from Window)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | OwnedWindows | (inherited from Window)
public property | Owner | (inherited from Window)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | ProgressText |
public property | ProgressValue |
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | ResizeMode | (inherited from Window)
public property | Resources | (inherited from FrameworkElement)
public property | RestoreBounds | (inherited from Window)
public property | ShowActivated | (inherited from Window)
public property | ShowInTaskbar | (inherited from Window)
public property | SizeToContent | (inherited from Window)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | TaskbarItemInfo | (inherited from Window)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Window)
public property | ToolTip | (inherited from FrameworkElement)
public property | Top | (inherited from Window)
public property | Topmost | (inherited from Window)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowStartupLocation | (inherited from Window)
public property | WindowState | (inherited from Window)
public property | WindowStyle | (inherited from Window)
Top

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Activate | (inherited from Window)
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | Close | (inherited from Window)
public method | CoerceValue | (inherited from DependencyObject)
public method | DragMove | (inherited from Window)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | Hide | (inherited from Window)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | Show | (inherited from Window)
public method | ShowDialog | (inherited from Window)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)
Top

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from Control)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from Control)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnActivated | (inherited from Window)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnClosed | (inherited from Window)
protected method | OnClosing | (inherited from Window)
protected method | OnContentChanged | Overridden. (inherited from ContentControl)
protected method | OnContentRendered | (inherited from Window)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDeactivated | (inherited from Window)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLocationChanged | (inherited from Window)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | Overridden. (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnSourceInitialized | (inherited from Window)
protected method | OnStateChanged | (inherited from Window)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)
Top

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)
Top

Public Events

 | Name | Description
public event | Activated | (inherited from Window)
public event | Cancel |
public event | Closed | (inherited from Window)
public event | Closing | (inherited from Window)
public event | ContentRendered | (inherited from Window)
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | Deactivated | (inherited from Window)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LocationChanged | (inherited from Window)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceInitialized | (inherited from Window)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StateChanged | (inherited from Window)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)
Top

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)
Top

See Also

Reference

ProgressDialog Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ProgressDialog Constructor
[image]

Initializes a new instance of the ProgressDialog Class.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As New ProgressDialog

Syntax

Visual Basic
Public Sub New
C#
public ProgressDialog ()
C++

J#

JScript

  Remarks
The default constructor initializes any fields to their default values.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProgressDialog Class
ProgressDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ProgressDialog Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Activate | (inherited from Window)
public method | AddHandler | (inherited from UIElement)
public method | AddHandler | (inherited from UIElement)
public method | AddToEventRoute | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyAnimationClock | (inherited from UIElement)
public method | ApplyTemplate | (inherited from FrameworkElement)
public method | Arrange | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginAnimation | (inherited from UIElement)
public method | BeginInit | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BeginStoryboard | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | BringIntoView | (inherited from FrameworkElement)
public method | CaptureMouse | (inherited from UIElement)
public method | CaptureStylus | (inherited from UIElement)
public method | CaptureTouch | (inherited from UIElement)
public method | CheckAccess | (inherited from DispatcherObject)
public method | ClearValue | (inherited from DependencyObject)
public method | ClearValue | (inherited from DependencyObject)
public method | Close | (inherited from Window)
public method | CoerceValue | (inherited from DependencyObject)
public method | DragMove | (inherited from Window)
public method | EndInit | (inherited from FrameworkElement)
public method | Equals | Overridden. (inherited from Object)
public method | FindCommonVisualAncestor | (inherited from Visual)
public method | FindName | (inherited from FrameworkElement)
public method | FindResource | (inherited from FrameworkElement)
public method | Focus | (inherited from UIElement)
public method | GetAnimationBaseValue | (inherited from UIElement)
public method | GetBindingExpression | (inherited from FrameworkElement)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetLocalValueEnumerator | (inherited from DependencyObject)
public method | GetType | (inherited from Object)
public method | GetValue | (inherited from DependencyObject)
public method | Hide | (inherited from Window)
public method | InitializeComponent |
public method | InputHitTest | (inherited from UIElement)
public method | InvalidateArrange | (inherited from UIElement)
public method | InvalidateMeasure | (inherited from UIElement)
public method | InvalidateProperty | (inherited from DependencyObject)
public method | InvalidateVisual | (inherited from UIElement)
public method | IsAncestorOf | (inherited from Visual)
public method | IsDescendantOf | (inherited from Visual)
public method | Measure | (inherited from UIElement)
public method | MoveFocus | Overridden. (inherited from UIElement)
public method | OnApplyTemplate | (inherited from FrameworkElement)
public method | PointFromScreen | (inherited from Visual)
public method | PointToScreen | (inherited from Visual)
public method | PredictFocus | Overridden. (inherited from UIElement)
public method | RaiseEvent | (inherited from UIElement)
public method | ReadLocalValue | (inherited from DependencyObject)
public method | RegisterName | (inherited from FrameworkElement)
public method | ReleaseAllTouchCaptures | (inherited from UIElement)
public method | ReleaseMouseCapture | (inherited from UIElement)
public method | ReleaseStylusCapture | (inherited from UIElement)
public method | ReleaseTouchCapture | (inherited from UIElement)
public method | RemoveHandler | (inherited from UIElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetBinding | (inherited from FrameworkElement)
public method | SetCurrentValue | (inherited from DependencyObject)
public method | SetResourceReference | (inherited from FrameworkElement)
public method | SetValue | (inherited from DependencyObject)
public method | SetValue | (inherited from DependencyObject)
public method | ShouldSerializeCommandBindings | (inherited from UIElement)
public method | ShouldSerializeContent | (inherited from ContentControl)
public method | ShouldSerializeInputBindings | (inherited from UIElement)
public method | ShouldSerializeResources | (inherited from FrameworkElement)
public method | ShouldSerializeStyle | (inherited from FrameworkElement)
public method | ShouldSerializeTriggers | (inherited from FrameworkElement)
public method | Show | (inherited from Window)
public method | ShowDialog | (inherited from Window)
public method | ToString | Overridden. (inherited from Object)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToAncestor | (inherited from Visual)
public method | TransformToDescendant | (inherited from Visual)
public method | TransformToVisual | (inherited from Visual)
public method | TranslatePoint | (inherited from UIElement)
public method | TryFindResource | (inherited from FrameworkElement)
public method | UnregisterName | (inherited from FrameworkElement)
public method | UpdateLayout | (inherited from UIElement)
public method | VerifyAccess | (inherited from DispatcherObject)

Protected Methods (see also Extension Methods)

 | Name | Description
protected method | AddChild | (inherited from ContentControl)
protected method | AddText | (inherited from ContentControl)
protected method | AddVisualChild | (inherited from Visual)
protected method | ArrangeCore | Overridden. (inherited from UIElement)
protected method | ArrangeOverride | Overridden. (inherited from Control)
protected method | Finalize | (inherited from Object)
protected method | GetLayoutClip | Overridden. (inherited from UIElement)
protected method | GetVisualChild | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | HitTestCore | Overridden. (inherited from Visual)
protected method | MeasureCore | Overridden. (inherited from UIElement)
protected method | MeasureOverride | Overridden. (inherited from Control)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnAccessKey | (inherited from UIElement)
protected method | OnActivated | (inherited from Window)
protected method | OnChildDesiredSizeChanged | (inherited from UIElement)
protected method | OnClosed | (inherited from Window)
protected method | OnClosing | (inherited from Window)
protected method | OnContentChanged | Overridden. (inherited from ContentControl)
protected method | OnContentRendered | (inherited from Window)
protected method | OnContentStringFormatChanged | (inherited from ContentControl)
protected method | OnContentTemplateChanged | (inherited from ContentControl)
protected method | OnContentTemplateSelectorChanged | (inherited from ContentControl)
protected method | OnContextMenuClosing | (inherited from FrameworkElement)
protected method | OnContextMenuOpening | (inherited from FrameworkElement)
protected method | OnCreateAutomationPeer | Overridden. (inherited from UIElement)
protected method | OnDeactivated | (inherited from Window)
protected method | OnDragEnter | (inherited from UIElement)
protected method | OnDragLeave | (inherited from UIElement)
protected method | OnDragOver | (inherited from UIElement)
protected method | OnDrop | (inherited from UIElement)
protected method | OnGiveFeedback | (inherited from UIElement)
protected method | OnGotFocus | Overridden. (inherited from UIElement)
protected method | OnGotKeyboardFocus | (inherited from UIElement)
protected method | OnGotMouseCapture | (inherited from UIElement)
protected method | OnGotStylusCapture | (inherited from UIElement)
protected method | OnGotTouchCapture | (inherited from UIElement)
protected method | OnInitialized | (inherited from FrameworkElement)
protected method | OnIsKeyboardFocusedChanged | (inherited from UIElement)
protected method | OnIsKeyboardFocusWithinChanged | (inherited from UIElement)
protected method | OnIsMouseCapturedChanged | (inherited from UIElement)
protected method | OnIsMouseCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsMouseDirectlyOverChanged | (inherited from UIElement)
protected method | OnIsStylusCapturedChanged | (inherited from UIElement)
protected method | OnIsStylusCaptureWithinChanged | (inherited from UIElement)
protected method | OnIsStylusDirectlyOverChanged | (inherited from UIElement)
protected method | OnKeyDown | (inherited from UIElement)
protected method | OnKeyUp | (inherited from UIElement)
protected method | OnLocationChanged | (inherited from Window)
protected method | OnLostFocus | (inherited from UIElement)
protected method | OnLostKeyboardFocus | (inherited from UIElement)
protected method | OnLostMouseCapture | (inherited from UIElement)
protected method | OnLostStylusCapture | (inherited from UIElement)
protected method | OnLostTouchCapture | (inherited from UIElement)
protected method | OnManipulationBoundaryFeedback | Overridden. (inherited from UIElement)
protected method | OnManipulationCompleted | (inherited from UIElement)
protected method | OnManipulationDelta | (inherited from UIElement)
protected method | OnManipulationInertiaStarting | (inherited from UIElement)
protected method | OnManipulationStarted | (inherited from UIElement)
protected method | OnManipulationStarting | (inherited from UIElement)
protected method | OnMouseDoubleClick | (inherited from Control)
protected method | OnMouseDown | (inherited from UIElement)
protected method | OnMouseEnter | (inherited from UIElement)
protected method | OnMouseLeave | (inherited from UIElement)
protected method | OnMouseLeftButtonDown | (inherited from UIElement)
protected method | OnMouseLeftButtonUp | (inherited from UIElement)
protected method | OnMouseMove | (inherited from UIElement)
protected method | OnMouseRightButtonDown | (inherited from UIElement)
protected method | OnMouseRightButtonUp | (inherited from UIElement)
protected method | OnMouseUp | (inherited from UIElement)
protected method | OnMouseWheel | (inherited from UIElement)
protected method | OnPreviewDragEnter | (inherited from UIElement)
protected method | OnPreviewDragLeave | (inherited from UIElement)
protected method | OnPreviewDragOver | (inherited from UIElement)
protected method | OnPreviewDrop | (inherited from UIElement)
protected method | OnPreviewGiveFeedback | (inherited from UIElement)
protected method | OnPreviewGotKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewKeyDown | (inherited from UIElement)
protected method | OnPreviewKeyUp | (inherited from UIElement)
protected method | OnPreviewLostKeyboardFocus | (inherited from UIElement)
protected method | OnPreviewMouseDoubleClick | (inherited from Control)
protected method | OnPreviewMouseDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseLeftButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseMove | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonDown | (inherited from UIElement)
protected method | OnPreviewMouseRightButtonUp | (inherited from UIElement)
protected method | OnPreviewMouseUp | (inherited from UIElement)
protected method | OnPreviewMouseWheel | (inherited from UIElement)
protected method | OnPreviewQueryContinueDrag | (inherited from UIElement)
protected method | OnPreviewStylusButtonDown | (inherited from UIElement)
protected method | OnPreviewStylusButtonUp | (inherited from UIElement)
protected method | OnPreviewStylusDown | (inherited from UIElement)
protected method | OnPreviewStylusInAirMove | (inherited from UIElement)
protected method | OnPreviewStylusInRange | (inherited from UIElement)
protected method | OnPreviewStylusMove | (inherited from UIElement)
protected method | OnPreviewStylusOutOfRange | (inherited from UIElement)
protected method | OnPreviewStylusSystemGesture | (inherited from UIElement)
protected method | OnPreviewStylusUp | (inherited from UIElement)
protected method | OnPreviewTextInput | (inherited from UIElement)
protected method | OnPreviewTouchDown | (inherited from UIElement)
protected method | OnPreviewTouchMove | (inherited from UIElement)
protected method | OnPreviewTouchUp | (inherited from UIElement)
protected method | OnPropertyChanged | Overridden. (inherited from DependencyObject)
protected method | OnQueryContinueDrag | (inherited from UIElement)
protected method | OnQueryCursor | (inherited from UIElement)
protected method | OnRender | (inherited from UIElement)
protected method | OnSourceInitialized | (inherited from Window)
protected method | OnStateChanged | (inherited from Window)
protected method | OnStylusButtonDown | (inherited from UIElement)
protected method | OnStylusButtonUp | (inherited from UIElement)
protected method | OnStylusDown | (inherited from UIElement)
protected method | OnStylusEnter | (inherited from UIElement)
protected method | OnStylusInAirMove | (inherited from UIElement)
protected method | OnStylusInRange | (inherited from UIElement)
protected method | OnStylusLeave | (inherited from UIElement)
protected method | OnStylusMove | (inherited from UIElement)
protected method | OnStylusOutOfRange | (inherited from UIElement)
protected method | OnStylusSystemGesture | (inherited from UIElement)
protected method | OnStylusUp | (inherited from UIElement)
protected method | OnTemplateChanged | (inherited from Control)
protected method | OnTextInput | (inherited from UIElement)
protected method | OnToolTipClosing | (inherited from FrameworkElement)
protected method | OnToolTipOpening | (inherited from FrameworkElement)
protected method | OnTouchDown | (inherited from UIElement)
protected method | OnTouchEnter | (inherited from UIElement)
protected method | OnTouchLeave | (inherited from UIElement)
protected method | OnTouchMove | (inherited from UIElement)
protected method | OnTouchUp | (inherited from UIElement)
protected method | RemoveVisualChild | (inherited from Visual)

Extension Methods

 | Name | Description
public extension method | SerializeByJson | Serialize an object using the DataContractJsonSerializer. (Defined by ObjectExtensions.)

Explicit Interface Implementations

Name | Description
AddChild | (inherited from ContentControl)
AddText | (inherited from ContentControl)
Connect | For internal use only.
IsAmbientPropertyAvailable | (inherited from FrameworkElement)

See Also

Reference

ProgressDialog Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ProgressDialog.InitializeComponent Method
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ProgressDialog

instance.InitializeComponent

Syntax

Visual Basic
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent
C#
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
public void InitializeComponent ()
C++

J#

JScript

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProgressDialog Class
ProgressDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ProgressDialog.Connect Method
[image]

For internal use only.

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ProgressDialog
Dim connectionId As Integer
Dim target As Object

CType(instance, IComponentConnector).Connect(connectionId, target)

Syntax

Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")> _
Private Sub System.Windows.Markup.IComponentConnector.Connect ( _
    connectionId As Integer, _
    target As Object _
) Implements IComponentConnector.Connect
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("PresentationBuildTasks", "4.0.0.0")]
void IComponentConnector.Connect (
    int connectionId,
    Object target
)
C++

J#

JScript

Parameters
connectionId
Type: Int32.
target
Type: Object.
  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProgressDialog Class
ProgressDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ProgressDialog Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ActualHeight | (inherited from FrameworkElement)
public property | ActualWidth | (inherited from FrameworkElement)
public property | AllowDrop | (inherited from UIElement)
public property | AllowsTransparency | (inherited from Window)
public property | AreAnyTouchesCaptured | (inherited from UIElement)
public property | AreAnyTouchesCapturedWithin | (inherited from UIElement)
public property | AreAnyTouchesDirectlyOver | (inherited from UIElement)
public property | AreAnyTouchesOver | (inherited from UIElement)
public property | Background | (inherited from Control)
public property | BindingGroup | (inherited from FrameworkElement)
public property | BitmapEffect | Obsolete. (inherited from UIElement)
public property | BitmapEffectInput | Obsolete. (inherited from UIElement)
public property | BorderBrush | (inherited from Control)
public property | BorderThickness | (inherited from Control)
public property | CacheMode | (inherited from UIElement)
public property | CaptionText |
public property | Clip | (inherited from UIElement)
public property | ClipToBounds | (inherited from UIElement)
public property | CommandBindings | (inherited from UIElement)
public property | Content | (inherited from ContentControl)
public property | ContentStringFormat | (inherited from ContentControl)
public property | ContentTemplate | (inherited from ContentControl)
public property | ContentTemplateSelector | (inherited from ContentControl)
public property | ContextMenu | (inherited from FrameworkElement)
public property | Cursor | (inherited from FrameworkElement)
public property | DataContext | (inherited from FrameworkElement)
public property | DependencyObjectType | (inherited from DependencyObject)
public property | DesiredSize | (inherited from UIElement)
public property | DialogResult | (inherited from Window)
public property | Dispatcher | (inherited from DispatcherObject)
public property | Effect | (inherited from UIElement)
public property | FlowDirection | (inherited from FrameworkElement)
public property | Focusable | (inherited from UIElement)
public property | FocusVisualStyle | (inherited from FrameworkElement)
public property | FontFamily | (inherited from Control)
public property | FontSize | (inherited from Control)
public property | FontStretch | (inherited from Control)
public property | FontStyle | (inherited from Control)
public property | FontWeight | (inherited from Control)
public property | ForceCursor | (inherited from FrameworkElement)
public property | Foreground | (inherited from Control)
public property | HasAnimatedProperties | (inherited from UIElement)
public property | HasContent | (inherited from ContentControl)
public property | Height | (inherited from FrameworkElement)
public property | HorizontalAlignment | (inherited from FrameworkElement)
public property | HorizontalContentAlignment | (inherited from Control)
public property | Icon | (inherited from Window)
public property | Indeterminate |
public property | InputBindings | (inherited from UIElement)
public property | InputScope | (inherited from FrameworkElement)
public property | IsActive | (inherited from Window)
public property | IsArrangeValid | (inherited from UIElement)
public property | IsEnabled | (inherited from UIElement)
public property | IsFocused | (inherited from UIElement)
public property | IsHitTestVisible | (inherited from UIElement)
public property | IsInitialized | (inherited from FrameworkElement)
public property | IsInputMethodEnabled | (inherited from UIElement)
public property | IsKeyboardFocused | (inherited from UIElement)
public property | IsKeyboardFocusWithin | (inherited from UIElement)
public property | IsLoaded | (inherited from FrameworkElement)
public property | IsManipulationEnabled | (inherited from UIElement)
public property | IsMeasureValid | (inherited from UIElement)
public property | IsMouseCaptured | (inherited from UIElement)
public property | IsMouseCaptureWithin | (inherited from UIElement)
public property | IsMouseDirectlyOver | (inherited from UIElement)
public property | IsMouseOver | (inherited from UIElement)
public property | IsSealed | (inherited from DependencyObject)
public property | IsStylusCaptured | (inherited from UIElement)
public property | IsStylusCaptureWithin | (inherited from UIElement)
public property | IsStylusDirectlyOver | (inherited from UIElement)
public property | IsStylusOver | (inherited from UIElement)
public property | IsTabStop | (inherited from Control)
public property | IsVisible | (inherited from UIElement)
public property | Language | (inherited from FrameworkElement)
public property | LayoutTransform | (inherited from FrameworkElement)
public property | Left | (inherited from Window)
public property | Margin | (inherited from FrameworkElement)
public property | MaxHeight | (inherited from FrameworkElement)
public property | MaxWidth | (inherited from FrameworkElement)
public property | MinHeight | (inherited from FrameworkElement)
public property | MinWidth | (inherited from FrameworkElement)
public property | Name | (inherited from FrameworkElement)
public property | Opacity | (inherited from UIElement)
public property | OpacityMask | (inherited from UIElement)
public property | OverridesDefaultStyle | (inherited from FrameworkElement)
public property | OwnedWindows | (inherited from Window)
public property | Owner | (inherited from Window)
public property | Padding | (inherited from Control)
public property | Parent | (inherited from FrameworkElement)
public property | PersistId | Obsolete. (inherited from UIElement)
public property | ProgressText |
public property | ProgressValue |
public property | RenderSize | (inherited from UIElement)
public property | RenderTransform | (inherited from UIElement)
public property | RenderTransformOrigin | (inherited from UIElement)
public property | ResizeMode | (inherited from Window)
public property | Resources | (inherited from FrameworkElement)
public property | RestoreBounds | (inherited from Window)
public property | ShowActivated | (inherited from Window)
public property | ShowInTaskbar | (inherited from Window)
public property | SizeToContent | (inherited from Window)
public property | SnapsToDevicePixels | (inherited from UIElement)
public property | Style | (inherited from FrameworkElement)
public property | TabIndex | (inherited from Control)
public property | Tag | (inherited from FrameworkElement)
public property | TaskbarItemInfo | (inherited from Window)
public property | Template | (inherited from Control)
public property | TemplatedParent | (inherited from FrameworkElement)
public property | Title | (inherited from Window)
public property | ToolTip | (inherited from FrameworkElement)
public property | Top | (inherited from Window)
public property | Topmost | (inherited from Window)
public property | TouchesCaptured | (inherited from UIElement)
public property | TouchesCapturedWithin | (inherited from UIElement)
public property | TouchesDirectlyOver | (inherited from UIElement)
public property | TouchesOver | (inherited from UIElement)
public property | Triggers | (inherited from FrameworkElement)
public property | Uid | (inherited from UIElement)
public property | UseLayoutRounding | (inherited from FrameworkElement)
public property | VerticalAlignment | (inherited from FrameworkElement)
public property | VerticalContentAlignment | (inherited from Control)
public property | Visibility | (inherited from UIElement)
public property | Width | (inherited from FrameworkElement)
public property | WindowStartupLocation | (inherited from Window)
public property | WindowState | (inherited from Window)
public property | WindowStyle | (inherited from Window)

Protected Properties

 | Name | Description
protected property | IsEnabledCore | (inherited from UIElement)
protected property | StylusPlugIns | (inherited from UIElement)
protected property | VisualChildrenCount | Overridden. (inherited from Visual)
protected property | VisualParent | (inherited from Visual)

See Also

Reference

ProgressDialog Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ProgressDialog.CaptionText Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ProgressDialog
Dim value As String

instance.CaptionText = value

Syntax

Visual Basic
Public WriteOnly Property CaptionText As String
C#
public string CaptionText { set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProgressDialog Class
ProgressDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ProgressDialog.Indeterminate Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ProgressDialog
Dim value As Boolean

instance.Indeterminate = value

Syntax

Visual Basic
Public WriteOnly Property Indeterminate As Boolean
C#
public bool Indeterminate { set; }
C++

J#

JScript

Property Value
Type: Boolean
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProgressDialog Class
ProgressDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ProgressDialog.ProgressText Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ProgressDialog
Dim value As String

instance.ProgressText = value

Syntax

Visual Basic
Public WriteOnly Property ProgressText As String
C#
public string ProgressText { set; }
C++

J#

JScript

Property Value
Type: String
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProgressDialog Class
ProgressDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ProgressDialog.ProgressValue Property
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ProgressDialog
Dim value As Integer

instance.ProgressValue = value

Syntax

Visual Basic
Public WriteOnly Property ProgressValue As Integer
C#
public int ProgressValue { set; }
C++

J#

JScript

Property Value
Type: Int32
.

  Thread Safety
Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.
  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProgressDialog Class
ProgressDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


ProgressDialog Events
[image]

Public Events

 | Name | Description
public event | Activated | (inherited from Window)
public event | Cancel |
public event | Closed | (inherited from Window)
public event | Closing | (inherited from Window)
public event | ContentRendered | (inherited from Window)
public event | ContextMenuClosing | (inherited from FrameworkElement)
public event | ContextMenuOpening | (inherited from FrameworkElement)
public event | DataContextChanged | (inherited from FrameworkElement)
public event | Deactivated | (inherited from Window)
public event | DragEnter | (inherited from UIElement)
public event | DragLeave | (inherited from UIElement)
public event | DragOver | (inherited from UIElement)
public event | Drop | (inherited from UIElement)
public event | FocusableChanged | (inherited from UIElement)
public event | GiveFeedback | (inherited from UIElement)
public event | GotFocus | (inherited from UIElement)
public event | GotKeyboardFocus | (inherited from UIElement)
public event | GotMouseCapture | (inherited from UIElement)
public event | GotStylusCapture | (inherited from UIElement)
public event | GotTouchCapture | (inherited from UIElement)
public event | Initialized | (inherited from FrameworkElement)
public event | IsEnabledChanged | (inherited from UIElement)
public event | IsHitTestVisibleChanged | (inherited from UIElement)
public event | IsKeyboardFocusedChanged | (inherited from UIElement)
public event | IsKeyboardFocusWithinChanged | (inherited from UIElement)
public event | IsMouseCapturedChanged | (inherited from UIElement)
public event | IsMouseCaptureWithinChanged | (inherited from UIElement)
public event | IsMouseDirectlyOverChanged | (inherited from UIElement)
public event | IsStylusCapturedChanged | (inherited from UIElement)
public event | IsStylusCaptureWithinChanged | (inherited from UIElement)
public event | IsStylusDirectlyOverChanged | (inherited from UIElement)
public event | IsVisibleChanged | (inherited from UIElement)
public event | KeyDown | (inherited from UIElement)
public event | KeyUp | (inherited from UIElement)
public event | LayoutUpdated | (inherited from UIElement)
public event | Loaded | (inherited from FrameworkElement)
public event | LocationChanged | (inherited from Window)
public event | LostFocus | (inherited from UIElement)
public event | LostKeyboardFocus | (inherited from UIElement)
public event | LostMouseCapture | (inherited from UIElement)
public event | LostStylusCapture | (inherited from UIElement)
public event | LostTouchCapture | (inherited from UIElement)
public event | ManipulationBoundaryFeedback | (inherited from UIElement)
public event | ManipulationCompleted | (inherited from UIElement)
public event | ManipulationDelta | (inherited from UIElement)
public event | ManipulationInertiaStarting | (inherited from UIElement)
public event | ManipulationStarted | (inherited from UIElement)
public event | ManipulationStarting | (inherited from UIElement)
public event | MouseDoubleClick | (inherited from Control)
public event | MouseDown | (inherited from UIElement)
public event | MouseEnter | (inherited from UIElement)
public event | MouseLeave | (inherited from UIElement)
public event | MouseLeftButtonDown | (inherited from UIElement)
public event | MouseLeftButtonUp | (inherited from UIElement)
public event | MouseMove | (inherited from UIElement)
public event | MouseRightButtonDown | (inherited from UIElement)
public event | MouseRightButtonUp | (inherited from UIElement)
public event | MouseUp | (inherited from UIElement)
public event | MouseWheel | (inherited from UIElement)
public event | PreviewDragEnter | (inherited from UIElement)
public event | PreviewDragLeave | (inherited from UIElement)
public event | PreviewDragOver | (inherited from UIElement)
public event | PreviewDrop | (inherited from UIElement)
public event | PreviewGiveFeedback | (inherited from UIElement)
public event | PreviewGotKeyboardFocus | (inherited from UIElement)
public event | PreviewKeyDown | (inherited from UIElement)
public event | PreviewKeyUp | (inherited from UIElement)
public event | PreviewLostKeyboardFocus | (inherited from UIElement)
public event | PreviewMouseDoubleClick | (inherited from Control)
public event | PreviewMouseDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonDown | (inherited from UIElement)
public event | PreviewMouseLeftButtonUp | (inherited from UIElement)
public event | PreviewMouseMove | (inherited from UIElement)
public event | PreviewMouseRightButtonDown | (inherited from UIElement)
public event | PreviewMouseRightButtonUp | (inherited from UIElement)
public event | PreviewMouseUp | (inherited from UIElement)
public event | PreviewMouseWheel | (inherited from UIElement)
public event | PreviewQueryContinueDrag | (inherited from UIElement)
public event | PreviewStylusButtonDown | (inherited from UIElement)
public event | PreviewStylusButtonUp | (inherited from UIElement)
public event | PreviewStylusDown | (inherited from UIElement)
public event | PreviewStylusInAirMove | (inherited from UIElement)
public event | PreviewStylusInRange | (inherited from UIElement)
public event | PreviewStylusMove | (inherited from UIElement)
public event | PreviewStylusOutOfRange | (inherited from UIElement)
public event | PreviewStylusSystemGesture | (inherited from UIElement)
public event | PreviewStylusUp | (inherited from UIElement)
public event | PreviewTextInput | (inherited from UIElement)
public event | PreviewTouchDown | (inherited from UIElement)
public event | PreviewTouchMove | (inherited from UIElement)
public event | PreviewTouchUp | (inherited from UIElement)
public event | QueryContinueDrag | (inherited from UIElement)
public event | QueryCursor | (inherited from UIElement)
public event | RequestBringIntoView | (inherited from FrameworkElement)
public event | SizeChanged | (inherited from FrameworkElement)
public event | SourceInitialized | (inherited from Window)
public event | SourceUpdated | (inherited from FrameworkElement)
public event | StateChanged | (inherited from Window)
public event | StylusButtonDown | (inherited from UIElement)
public event | StylusButtonUp | (inherited from UIElement)
public event | StylusDown | (inherited from UIElement)
public event | StylusEnter | (inherited from UIElement)
public event | StylusInAirMove | (inherited from UIElement)
public event | StylusInRange | (inherited from UIElement)
public event | StylusLeave | (inherited from UIElement)
public event | StylusMove | (inherited from UIElement)
public event | StylusOutOfRange | (inherited from UIElement)
public event | StylusSystemGesture | (inherited from UIElement)
public event | StylusUp | (inherited from UIElement)
public event | TargetUpdated | (inherited from FrameworkElement)
public event | TextInput | (inherited from UIElement)
public event | ToolTipClosing | (inherited from FrameworkElement)
public event | ToolTipOpening | (inherited from FrameworkElement)
public event | TouchDown | (inherited from UIElement)
public event | TouchEnter | (inherited from UIElement)
public event | TouchLeave | (inherited from UIElement)
public event | TouchMove | (inherited from UIElement)
public event | TouchUp | (inherited from UIElement)
public event | Unloaded | (inherited from FrameworkElement)

See Also

Reference

ProgressDialog Class
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace

Other Resources

Developer Extensions for Microsoft Dynamics CRM


ProgressDialog.Cancel Event
[image]

Namespace: Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog
Assembly: Microsoft.Xrm.Client (in Microsoft.Xrm.Client.dll)

Usage

Visual Basic
Dim instance As ProgressDialog
Dim handler As EventHandler

AddHandler instance.Cancel, handler

Syntax

Visual Basic
Public Event Cancel As EventHandler
C#
public event EventHandler Cancel
C++

J#

JScript

  Platforms
Development Platforms
The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.
Target Platforms
Windows Server 2008,Windows Server 2012,Windows 7
  See Also
Reference
ProgressDialog Class
ProgressDialog Members
Microsoft.Xrm.Client.Windows.Controls.ConnectionDialog Namespace


Assembly Reference for Extensions to Microsoft Dynamics CRM

This topic is intentionally left blank.

Please go to the Programming reference for extensions to Microsoft Dynamics CRM topic above in the table of contents or view this topic online at Programming reference for extensions to Microsoft Dynamics CRM.

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


Copyright

This document is provided "as-is". Information and views expressed in this document, including URL and other Internet Web site references, may change without notice.

Some examples depicted herein are provided for illustration only and are fictitious. No real association or connection is intended or should be inferred.

This document does not provide you with any legal rights to any intellectual property in any Microsoft product. You may copy and use this document for your internal, reference purposes.

The videos and eBooks might be in English only. Also, if you click the links, you may be redirected to a U.S. website whose content is in English.

© 2015 Microsoft. All rights reserved.

Microsoft, Active Directory, Azure, JScript, Microsoft Dynamics, Outlook, SharePoint, Visual Studio, and Windows are trademarks of the Microsoft group of companies. All other trademarks are property of their respective owners.

Microsoft Dynamics CRM 2015 and Microsoft Dynamics CRM Online


DataCollection<T> Hierarchy

The following table lists the classes derived from Microsoft.Xrm.Sdk.DataCollection.

Derived Classes

Class | Description
Microsoft.Crm.Sdk.Messages.AuditPartitionDetailCollection |
Microsoft.Xrm.Sdk.AttributeMappingCollection |
Microsoft.Xrm.Sdk.AttributePrivilegeCollection |
Microsoft.Xrm.Sdk.Deployment.AttributeCollection |
Microsoft.Xrm.Sdk.Deployment.ErrorDetailCollection |
Microsoft.Xrm.Sdk.Discovery.OrganizationDetailCollection |
Microsoft.Xrm.Sdk.EntityReferenceCollection |
Microsoft.Xrm.Sdk.ExecuteMultipleResponseItemCollection |
Microsoft.Xrm.Sdk.LocalizedLabelCollection |
Microsoft.Xrm.Sdk.Metadata.EntityMetadataCollection |
Microsoft.Xrm.Sdk.Metadata.OptionMetadataCollection |
Microsoft.Xrm.Sdk.OrganizationRequestCollection |
Microsoft.Xrm.Sdk.QuickFindConfigurationCollection |
Microsoft.Xrm.Sdk.QuickFindResultCollection |

See Also

Reference

DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DataCollection<TKey,TValue> Hierarchy

The following table lists the classes derived from Microsoft.Xrm.Sdk.DataCollection.

Derived Classes

Class | Description
Microsoft.Crm.Sdk.Messages.InputArgument |
Microsoft.Xrm.Sdk.AttributeCollection |
Microsoft.Xrm.Sdk.Client.CrossRealmIssuerEndpointCollection |
Microsoft.Xrm.Sdk.Discovery.EndpointCollection |
Microsoft.Xrm.Sdk.EntityImageCollection |
Microsoft.Xrm.Sdk.ErrorDetailCollection |
Microsoft.Xrm.Sdk.FormattedValueCollection |
Microsoft.Xrm.Sdk.Metadata.Query.DeletedMetadataCollection |
Microsoft.Xrm.Sdk.Organization.EndpointCollection |
Microsoft.Xrm.Sdk.ParameterCollection |
Microsoft.Xrm.Sdk.RelatedEntityCollection |
Microsoft.Xrm.Sdk.RelationshipQueryCollection |

See Also

Reference

DataCollection Class
DataCollection Members
Microsoft.Xrm.Sdk Namespace


DeploymentConfigSettings Hierarchy

The following table lists the classes derived from Microsoft.Xrm.Sdk.Deployment.DeploymentConfigSettings.

Derived Classes

Class | Description
Microsoft.Xrm.Sdk.Deployment.AsyncSettings |
Microsoft.Xrm.Sdk.Deployment.ClaimsSettingsBase |
Microsoft.Xrm.Sdk.Deployment.CustomCodeSettings |
Microsoft.Xrm.Sdk.Deployment.DashboardSettings |
Microsoft.Xrm.Sdk.Deployment.DupSettings |
Microsoft.Xrm.Sdk.Deployment.EtmSettings |
Microsoft.Xrm.Sdk.Deployment.IfdSettings |
Microsoft.Xrm.Sdk.Deployment.ImportSettings |
Microsoft.Xrm.Sdk.Deployment.MarketplaceSettings |
Microsoft.Xrm.Sdk.Deployment.MonitoringSettings |
Microsoft.Xrm.Sdk.Deployment.MultiEntityQuickFindSettings |
Microsoft.Xrm.Sdk.Deployment.QuickFindSettings |
Microsoft.Xrm.Sdk.Deployment.ServerSideSyncACTSettings |
Microsoft.Xrm.Sdk.Deployment.ServerSideSyncEmailSettings |
Microsoft.Xrm.Sdk.Deployment.ServerSideSyncQueueSettings |
Microsoft.Xrm.Sdk.Deployment.SqmSettings |
Microsoft.Xrm.Sdk.Deployment.TeamSettings |
Microsoft.Xrm.Sdk.Deployment.ThrottleSettings |
Microsoft.Xrm.Sdk.Deployment.TraceSettings |
Microsoft.Xrm.Sdk.Deployment.WebAddressSettings |
Microsoft.Xrm.Sdk.Deployment.WorkflowSettings |
Microsoft.Xrm.Sdk.Deployment.YammerSettings |

See Also

Reference

DeploymentConfigSettings Class
DeploymentConfigSettings Members
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Use Deployment Entities and Deployment Configuration Settings


DeploymentServiceRequest Hierarchy

The following table lists the classes derived from Microsoft.Xrm.Sdk.Deployment.DeploymentServiceRequest.

Derived Classes

Class | Description
Microsoft.Xrm.Sdk.Deployment.AddCrmDatabaseRequest |
Microsoft.Xrm.Sdk.Deployment.AddDeploymentAdministratorRequest |
Microsoft.Xrm.Sdk.Deployment.DeferredOperationRequest |
Microsoft.Xrm.Sdk.Deployment.DeleteRequest |
Microsoft.Xrm.Sdk.Deployment.RetrieveAdvancedSettingsRequest |
Microsoft.Xrm.Sdk.Deployment.RetrieveAllRequest |
Microsoft.Xrm.Sdk.Deployment.RetrieveMonitoringResultsRequest |
Microsoft.Xrm.Sdk.Deployment.RetrieveRequest |
Microsoft.Xrm.Sdk.Deployment.RetrieveUserMappingRequest |
Microsoft.Xrm.Sdk.Deployment.TrackLicenseRequest |
Microsoft.Xrm.Sdk.Deployment.UpdateAdvancedSettingsRequest |
Microsoft.Xrm.Sdk.Deployment.UpdateProductKeyRequest |
Microsoft.Xrm.Sdk.Deployment.UpdateRequest |

See Also

Reference

DeploymentServiceRequest Class
DeploymentServiceRequest Members
Microsoft.Xrm.Sdk.Deployment Namespace
DeploymentServiceResponse

Other Resources

Introduction to the Deployment Web Service
Deployment Web Service Messages


DeploymentServiceResponse Hierarchy

The following table lists the classes derived from Microsoft.Xrm.Sdk.Deployment.DeploymentServiceResponse.

Derived Classes

Class | Description
Microsoft.Xrm.Sdk.Deployment.AddCrmDatabaseResponse |
Microsoft.Xrm.Sdk.Deployment.AddDeploymentAdministratorResponse |
Microsoft.Xrm.Sdk.Deployment.DeferredOperationResponse |
Microsoft.Xrm.Sdk.Deployment.DeleteResponse |
Microsoft.Xrm.Sdk.Deployment.RetrieveAdvancedSettingsResponse |
Microsoft.Xrm.Sdk.Deployment.RetrieveAllResponse |
Microsoft.Xrm.Sdk.Deployment.RetrieveMonitoringResultsResponse |
Microsoft.Xrm.Sdk.Deployment.RetrieveResponse |
Microsoft.Xrm.Sdk.Deployment.RetrieveUserMappingResponse |
Microsoft.Xrm.Sdk.Deployment.TrackLicenseResponse |
Microsoft.Xrm.Sdk.Deployment.UpdateAdvancedSettingsResponse |
Microsoft.Xrm.Sdk.Deployment.UpdateProductKeyResponse |
Microsoft.Xrm.Sdk.Deployment.UpdateResponse |

See Also

Reference

DeploymentServiceResponse Class
DeploymentServiceResponse Members
Microsoft.Xrm.Sdk.Deployment Namespace

Other Resources

Deployment Web Service Messages


AttributeMetadata Hierarchy

The following table lists the classes derived from Microsoft.Xrm.Sdk.Metadata.AttributeMetadata.

Derived Classes

Class | Description
Microsoft.Xrm.Sdk.Metadata.BigIntAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.BooleanAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.DateTimeAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.DecimalAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.DoubleAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.EnumAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.ImageAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.IntegerAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.LookupAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.ManagedPropertyAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.MemoAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.MoneyAttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.StringAttributeMetadata |

See Also

Reference

AttributeMetadata Class
AttributeMetadata Members
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Customize Entity Attribute Metadata
Sample: Dump Attribute Metadata to a File
Sample: Work with Attributes
Sample: Retrieve Entity Metadata Using JavaScript


MetadataBase Hierarchy

The following table lists the classes derived from Microsoft.Xrm.Sdk.Metadata.MetadataBase.

Derived Classes

Class | Description
Microsoft.Xrm.Sdk.LocalizedLabel |
Microsoft.Xrm.Sdk.Metadata.AttributeMetadata |
Microsoft.Xrm.Sdk.Metadata.EntityMetadata |
Microsoft.Xrm.Sdk.Metadata.ManagedPropertyMetadata |
Microsoft.Xrm.Sdk.Metadata.OptionMetadata |
Microsoft.Xrm.Sdk.Metadata.OptionSetMetadataBase |
Microsoft.Xrm.Sdk.Metadata.RelationshipMetadataBase |

See Also

Reference

MetadataBase Class
MetadataBase Members
Microsoft.Xrm.Sdk.Metadata Namespace

Other Resources

Extend the Metadata Model for Microsoft Dynamics CRM


OrganizationRequest Hierarchy

The following table lists the classes derived from Microsoft.Xrm.Sdk.OrganizationRequest.

Derived Classes

Class | Description
Microsoft.Crm.Sdk.Messages.AddItemCampaignActivityRequest |
Microsoft.Crm.Sdk.Messages.AddItemCampaignRequest |
Microsoft.Crm.Sdk.Messages.AddListMembersListRequest |
Microsoft.Crm.Sdk.Messages.AddMemberListRequest |
Microsoft.Crm.Sdk.Messages.AddMembersTeamRequest |
Microsoft.Crm.Sdk.Messages.AddPrincipalToQueueRequest |
Microsoft.Crm.Sdk.Messages.AddPrivilegesRoleRequest |
Microsoft.Crm.Sdk.Messages.AddProductToKitRequest |
Microsoft.Crm.Sdk.Messages.AddRecurrenceRequest |
Microsoft.Crm.Sdk.Messages.AddSolutionComponentRequest |
Microsoft.Crm.Sdk.Messages.AddSubstituteProductRequest |
Microsoft.Crm.Sdk.Messages.AddToQueueRequest |
Microsoft.Crm.Sdk.Messages.AddUserToRecordTeamRequest |
Microsoft.Crm.Sdk.Messages.ApplyRoutingRuleRequest |
Microsoft.Crm.Sdk.Messages.AssignRequest |
Microsoft.Crm.Sdk.Messages.AssociateEntitiesRequest |
Microsoft.Crm.Sdk.Messages.AutoMapEntityRequest |
Microsoft.Crm.Sdk.Messages.BackgroundSendEmailRequest |
Microsoft.Crm.Sdk.Messages.BookRequest |
Microsoft.Crm.Sdk.Messages.BulkDeleteRequest |
Microsoft.Crm.Sdk.Messages.BulkDetectDuplicatesRequest |
Microsoft.Crm.Sdk.Messages.BulkOperationStatusCloseRequest |
Microsoft.Crm.Sdk.Messages.CalculateActualValueOpportunityRequest |
Microsoft.Crm.Sdk.Messages.CalculatePriceRequest |
Microsoft.Crm.Sdk.Messages.CalculateRollupFieldRequest |
Microsoft.Crm.Sdk.Messages.CalculateTotalTimeIncidentRequest |
Microsoft.Crm.Sdk.Messages.CancelContractRequest |
Microsoft.Crm.Sdk.Messages.CancelSalesOrderRequest |
Microsoft.Crm.Sdk.Messages.CheckIncomingEmailRequest |
Microsoft.Crm.Sdk.Messages.CheckPromoteEmailRequest |
Microsoft.Crm.Sdk.Messages.CleanUpBulkOperationRequest |
Microsoft.Crm.Sdk.Messages.CloneContractRequest |
Microsoft.Crm.Sdk.Messages.CloneProductRequest |
Microsoft.Crm.Sdk.Messages.CloseIncidentRequest |
Microsoft.Crm.Sdk.Messages.CloseQuoteRequest |
Microsoft.Crm.Sdk.Messages.CompoundCreateRequest |
Microsoft.Crm.Sdk.Messages.CompoundUpdateDuplicateDetectionRuleRequest |
Microsoft.Crm.Sdk.Messages.CompoundUpdateRequest |
Microsoft.Crm.Sdk.Messages.ConvertKitToProductRequest |
Microsoft.Crm.Sdk.Messages.ConvertOwnerTeamToAccessTeamRequest |
Microsoft.Crm.Sdk.Messages.ConvertProductToKitRequest |
Microsoft.Crm.Sdk.Messages.ConvertQuoteToSalesOrderRequest |
Microsoft.Crm.Sdk.Messages.ConvertSalesOrderToInvoiceRequest |
Microsoft.Crm.Sdk.Messages.CopyCampaignRequest |
Microsoft.Crm.Sdk.Messages.CopyCampaignResponseRequest |
Microsoft.Crm.Sdk.Messages.CopyDynamicListToStaticRequest |
Microsoft.Crm.Sdk.Messages.CopyMembersListRequest |
Microsoft.Crm.Sdk.Messages.CopySystemFormRequest |
Microsoft.Crm.Sdk.Messages.CreateActivitiesListRequest |
Microsoft.Crm.Sdk.Messages.CreateExceptionRequest |
Microsoft.Crm.Sdk.Messages.CreateInstanceRequest |
Microsoft.Crm.Sdk.Messages.CreateWorkflowFromTemplateRequest |
Microsoft.Crm.Sdk.Messages.DeleteAuditDataRequest |
Microsoft.Crm.Sdk.Messages.DeleteOpenInstancesRequest |
Microsoft.Crm.Sdk.Messages.DeliverIncomingEmailRequest |
Microsoft.Crm.Sdk.Messages.DeliverPromoteEmailRequest |
Microsoft.Crm.Sdk.Messages.DeprovisionLanguageRequest |
Microsoft.Crm.Sdk.Messages.DisassociateEntitiesRequest |
Microsoft.Crm.Sdk.Messages.DistributeCampaignActivityRequest |
Microsoft.Crm.Sdk.Messages.DownloadReportDefinitionRequest |
Microsoft.Crm.Sdk.Messages.ExecuteByIdSavedQueryRequest |
Microsoft.Crm.Sdk.Messages.ExecuteByIdUserQueryRequest |
Microsoft.Crm.Sdk.Messages.ExecuteFetchRequest |
Microsoft.Crm.Sdk.Messages.ExecuteWorkflowRequest |
Microsoft.Crm.Sdk.Messages.ExpandCalendarRequest |
Microsoft.Crm.Sdk.Messages.ExportFieldTranslationRequest |
Microsoft.Crm.Sdk.Messages.ExportMappingsImportMapRequest |
Microsoft.Crm.Sdk.Messages.ExportSolutionRequest |
Microsoft.Crm.Sdk.Messages.ExportTranslationRequest |
Microsoft.Crm.Sdk.Messages.FetchXmlToQueryExpressionRequest |
Microsoft.Crm.Sdk.Messages.FindParentResourceGroupRequest |
Microsoft.Crm.Sdk.Messages.FulfillSalesOrderRequest |
Microsoft.Crm.Sdk.Messages.GenerateInvoiceFromOpportunityRequest |
Microsoft.Crm.Sdk.Messages.GenerateQuoteFromOpportunityRequest |
Microsoft.Crm.Sdk.Messages.GenerateSalesOrderFromOpportunityRequest |
Microsoft.Crm.Sdk.Messages.GenerateSocialProfileRequest |
Microsoft.Crm.Sdk.Messages.GetAllTimeZonesWithDisplayNameRequest |
Microsoft.Crm.Sdk.Messages.GetDecryptionKeyRequest |
Microsoft.Crm.Sdk.Messages.GetDefaultPriceLevelRequest |
Microsoft.Crm.Sdk.Messages.GetDistinctValuesImportFileRequest |
Microsoft.Crm.Sdk.Messages.GetHeaderColumnsImportFileRequest |
Microsoft.Crm.Sdk.Messages.GetInvoiceProductsFromOpportunityRequest |
Microsoft.Crm.Sdk.Messages.GetQuantityDecimalRequest |
Microsoft.Crm.Sdk.Messages.GetQuoteProductsFromOpportunityRequest |
Microsoft.Crm.Sdk.Messages.GetReportHistoryLimitRequest |
Microsoft.Crm.Sdk.Messages.GetSalesOrderProductsFromOpportunityRequest |
Microsoft.Crm.Sdk.Messages.GetTimeZoneCodeByLocalizedNameRequest |
Microsoft.Crm.Sdk.Messages.GetTrackingTokenEmailRequest |
Microsoft.Crm.Sdk.Messages.GrantAccessRequest |
Microsoft.Crm.Sdk.Messages.ImportFieldTranslationRequest |
Microsoft.Crm.Sdk.Messages.ImportMappingsImportMapRequest |
Microsoft.Crm.Sdk.Messages.ImportRecordsImportRequest |
Microsoft.Crm.Sdk.Messages.ImportSolutionRequest |
Microsoft.Crm.Sdk.Messages.ImportTranslationRequest |
Microsoft.Crm.Sdk.Messages.InitializeFromRequest |
Microsoft.Crm.Sdk.Messages.InstallSampleDataRequest |
Microsoft.Crm.Sdk.Messages.InstantiateFiltersRequest |
Microsoft.Crm.Sdk.Messages.InstantiateTemplateRequest |
Microsoft.Crm.Sdk.Messages.IsBackOfficeInstalledRequest |
Microsoft.Crm.Sdk.Messages.IsComponentCustomizableRequest |
Microsoft.Crm.Sdk.Messages.IsValidStateTransitionRequest |
Microsoft.Crm.Sdk.Messages.LocalTimeFromUtcTimeRequest |
Microsoft.Crm.Sdk.Messages.LockInvoicePricingRequest |
Microsoft.Crm.Sdk.Messages.LockSalesOrderPricingRequest |
Microsoft.Crm.Sdk.Messages.LogFailureBulkOperationRequest |
Microsoft.Crm.Sdk.Messages.LogSuccessBulkOperationRequest |
Microsoft.Crm.Sdk.Messages.LoseOpportunityRequest |
Microsoft.Crm.Sdk.Messages.MakeAvailableToOrganizationReportRequest |
Microsoft.Crm.Sdk.Messages.MakeAvailableToOrganizationTemplateRequest |
Microsoft.Crm.Sdk.Messages.MakeUnavailableToOrganizationReportRequest |
Microsoft.Crm.Sdk.Messages.MakeUnavailableToOrganizationTemplateRequest |
Microsoft.Crm.Sdk.Messages.MergeRequest |
Microsoft.Crm.Sdk.Messages.ModifyAccessRequest |
Microsoft.Crm.Sdk.Messages.ParseImportRequest |
Microsoft.Crm.Sdk.Messages.PickFromQueueRequest |
Microsoft.Crm.Sdk.Messages.ProcessInboundEmailRequest |
Microsoft.Crm.Sdk.Messages.ProcessOneMemberBulkOperationRequest |
Microsoft.Crm.Sdk.Messages.PropagateByExpressionRequest |
Microsoft.Crm.Sdk.Messages.ProvisionLanguageRequest |
Microsoft.Crm.Sdk.Messages.PublishAllXmlRequest |
Microsoft.Crm.Sdk.Messages.PublishDuplicateRuleRequest |
Microsoft.Crm.Sdk.Messages.PublishProductHierarchyRequest |
Microsoft.Crm.Sdk.Messages.PublishXmlRequest |
Microsoft.Crm.Sdk.Messages.QualifyLeadRequest |
Microsoft.Crm.Sdk.Messages.QualifyMemberListRequest |
Microsoft.Crm.Sdk.Messages.QueryExpressionToFetchXmlRequest |
Microsoft.Crm.Sdk.Messages.QueryMultipleSchedulesRequest |
Microsoft.Crm.Sdk.Messages.QueryScheduleRequest |
Microsoft.Crm.Sdk.Messages.ReassignObjectsOwnerRequest |
Microsoft.Crm.Sdk.Messages.ReassignObjectsSystemUserRequest |
Microsoft.Crm.Sdk.Messages.RecalculateRequest |
Microsoft.Crm.Sdk.Messages.ReleaseToQueueRequest |
Microsoft.Crm.Sdk.Messages.RemoveFromQueueRequest |
Microsoft.Crm.Sdk.Messages.RemoveItemCampaignActivityRequest |
Microsoft.Crm.Sdk.Messages.RemoveItemCampaignRequest |
Microsoft.Crm.Sdk.Messages.RemoveMemberListRequest |
Microsoft.Crm.Sdk.Messages.RemoveMembersTeamRequest |
Microsoft.Crm.Sdk.Messages.RemoveParentRequest |
Microsoft.Crm.Sdk.Messages.RemovePrivilegeRoleRequest |
Microsoft.Crm.Sdk.Messages.RemoveProductFromKitRequest |
Microsoft.Crm.Sdk.Messages.RemoveRelatedRequest |
Microsoft.Crm.Sdk.Messages.RemoveSolutionComponentRequest |
Microsoft.Crm.Sdk.Messages.RemoveSubstituteProductRequest |
Microsoft.Crm.Sdk.Messages.RemoveUserFromRecordTeamRequest |
Microsoft.Crm.Sdk.Messages.RenewContractRequest |
Microsoft.Crm.Sdk.Messages.RenewEntitlementRequest |
Microsoft.Crm.Sdk.Messages.ReplacePrivilegesRoleRequest |
Microsoft.Crm.Sdk.Messages.RescheduleRequest |
Microsoft.Crm.Sdk.Messages.ResetUserFiltersRequest |
Microsoft.Crm.Sdk.Messages.RetrieveAbsoluteAndSiteCollectionUrlRequest |
Microsoft.Crm.Sdk.Messages.RetrieveAllChildUsersSystemUserRequest |
Microsoft.Crm.Sdk.Messages.RetrieveApplicationRibbonRequest |
Microsoft.Crm.Sdk.Messages.RetrieveAttributeChangeHistoryRequest |
Microsoft.Crm.Sdk.Messages.RetrieveAuditDetailsRequest |
Microsoft.Crm.Sdk.Messages.RetrieveAuditPartitionListRequest |
Microsoft.Crm.Sdk.Messages.RetrieveAvailableLanguagesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveBusinessHierarchyBusinessUnitRequest |
Microsoft.Crm.Sdk.Messages.RetrieveByGroupResourceRequest |
Microsoft.Crm.Sdk.Messages.RetrieveByResourceResourceGroupRequest |
Microsoft.Crm.Sdk.Messages.RetrieveByResourcesServiceRequest |
Microsoft.Crm.Sdk.Messages.RetrieveByTopIncidentProductKbArticleRequest |
Microsoft.Crm.Sdk.Messages.RetrieveByTopIncidentSubjectKbArticleRequest |
Microsoft.Crm.Sdk.Messages.RetrieveCurrentOrganizationRequest |
Microsoft.Crm.Sdk.Messages.RetrieveDependenciesForDeleteRequest |
Microsoft.Crm.Sdk.Messages.RetrieveDependenciesForUninstallRequest |
Microsoft.Crm.Sdk.Messages.RetrieveDependentComponentsRequest |
Microsoft.Crm.Sdk.Messages.RetrieveDeploymentLicenseTypeRequest |
Microsoft.Crm.Sdk.Messages.RetrieveDeprovisionedLanguagesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveDuplicatesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveEntityRibbonRequest |
Microsoft.Crm.Sdk.Messages.RetrieveExchangeRateRequest |
Microsoft.Crm.Sdk.Messages.RetrieveFilteredFormsRequest |
Microsoft.Crm.Sdk.Messages.RetrieveFormattedImportJobResultsRequest |
Microsoft.Crm.Sdk.Messages.RetrieveFormXmlRequest |
Microsoft.Crm.Sdk.Messages.RetrieveInstalledLanguagePacksRequest |
Microsoft.Crm.Sdk.Messages.RetrieveInstalledLanguagePackVersionRequest |
Microsoft.Crm.Sdk.Messages.RetrieveLicenseInfoRequest |
Microsoft.Crm.Sdk.Messages.RetrieveLocLabelsRequest |
Microsoft.Crm.Sdk.Messages.RetrieveMembersBulkOperationRequest |
Microsoft.Crm.Sdk.Messages.RetrieveMembersTeamRequest |
Microsoft.Crm.Sdk.Messages.RetrieveMissingComponentsRequest |
Microsoft.Crm.Sdk.Messages.RetrieveMissingDependenciesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveOrganizationResourcesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveParentGroupsResourceGroupRequest |
Microsoft.Crm.Sdk.Messages.RetrieveParsedDataImportFileRequest |
Microsoft.Crm.Sdk.Messages.RetrievePersonalWallRequest |
Microsoft.Crm.Sdk.Messages.RetrievePrincipalAccessRequest |
Microsoft.Crm.Sdk.Messages.RetrievePrincipalAttributePrivilegesRequest |
Microsoft.Crm.Sdk.Messages.RetrievePrincipalSyncAttributeMappingsRequest |
Microsoft.Crm.Sdk.Messages.RetrievePrivilegeSetRequest |
Microsoft.Crm.Sdk.Messages.RetrieveProductPropertiesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveProvisionedLanguagePackVersionRequest |
Microsoft.Crm.Sdk.Messages.RetrieveProvisionedLanguagesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveRecordChangeHistoryRequest |
Microsoft.Crm.Sdk.Messages.RetrieveRecordWallRequest |
Microsoft.Crm.Sdk.Messages.RetrieveRequiredComponentsRequest |
Microsoft.Crm.Sdk.Messages.RetrieveRolePrivilegesRoleRequest |
Microsoft.Crm.Sdk.Messages.RetrieveSharedPrincipalsAndAccessRequest |
Microsoft.Crm.Sdk.Messages.RetrieveSubGroupsResourceGroupRequest |
Microsoft.Crm.Sdk.Messages.RetrieveSubsidiaryTeamsBusinessUnitRequest |
Microsoft.Crm.Sdk.Messages.RetrieveSubsidiaryUsersBusinessUnitRequest |
Microsoft.Crm.Sdk.Messages.RetrieveTeamPrivilegesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveTeamsSystemUserRequest |
Microsoft.Crm.Sdk.Messages.RetrieveUnpublishedMultipleRequest |
Microsoft.Crm.Sdk.Messages.RetrieveUnpublishedRequest |
Microsoft.Crm.Sdk.Messages.RetrieveUserPrivilegesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveUserQueuesRequest |
Microsoft.Crm.Sdk.Messages.RetrieveUserSettingsSystemUserRequest |
Microsoft.Crm.Sdk.Messages.RetrieveVersionRequest |
Microsoft.Crm.Sdk.Messages.RevertProductRequest |
Microsoft.Crm.Sdk.Messages.ReviseQuoteRequest |
Microsoft.Crm.Sdk.Messages.RevokeAccessRequest |
Microsoft.Crm.Sdk.Messages.RollupRequest |
Microsoft.Crm.Sdk.Messages.RouteToRequest |
Microsoft.Crm.Sdk.Messages.SearchByBodyKbArticleRequest |
Microsoft.Crm.Sdk.Messages.SearchByKeywordsKbArticleRequest |
Microsoft.Crm.Sdk.Messages.SearchByTitleKbArticleRequest |
Microsoft.Crm.Sdk.Messages.SearchRequest |
Microsoft.Crm.Sdk.Messages.SendBulkMailRequest |
Microsoft.Crm.Sdk.Messages.SendEmailFromTemplateRequest |
Microsoft.Crm.Sdk.Messages.SendEmailRequest |
Microsoft.Crm.Sdk.Messages.SendFaxRequest |
Microsoft.Crm.Sdk.Messages.SendTemplateRequest |
Microsoft.Crm.Sdk.Messages.SetBusinessEquipmentRequest |
Microsoft.Crm.Sdk.Messages.SetBusinessSystemUserRequest |
Microsoft.Crm.Sdk.Messages.SetLocLabelsRequest |
Microsoft.Crm.Sdk.Messages.SetParentBusinessUnitRequest |
Microsoft.Crm.Sdk.Messages.SetParentSystemUserRequest |
Microsoft.Crm.Sdk.Messages.SetParentTeamRequest |
Microsoft.Crm.Sdk.Messages.SetRelatedRequest |
Microsoft.Crm.Sdk.Messages.SetReportRelatedRequest |
Microsoft.Crm.Sdk.Messages.SetStateRequest |
Microsoft.Crm.Sdk.Messages.StatusUpdateBulkOperationRequest |
Microsoft.Crm.Sdk.Messages.TransformImportRequest |
Microsoft.Crm.Sdk.Messages.TriggerServiceEndpointCheckRequest |
Microsoft.Crm.Sdk.Messages.UninstallSampleDataRequest |
Microsoft.Crm.Sdk.Messages.UnlockInvoicePricingRequest |
Microsoft.Crm.Sdk.Messages.UnlockSalesOrderPricingRequest |
Microsoft.Crm.Sdk.Messages.UnpublishDuplicateRuleRequest |
Microsoft.Crm.Sdk.Messages.UpdateProductPropertiesRequest |
Microsoft.Crm.Sdk.Messages.UpdateUserSettingsSystemUserRequest |
Microsoft.Crm.Sdk.Messages.UtcTimeFromLocalTimeRequest |
Microsoft.Crm.Sdk.Messages.ValidateRecurrenceRuleRequest |
Microsoft.Crm.Sdk.Messages.ValidateRequest |
Microsoft.Crm.Sdk.Messages.ValidateSavedQueryRequest |
Microsoft.Crm.Sdk.Messages.VerifyProcessStateDataRequest |
Microsoft.Crm.Sdk.Messages.WhoAmIRequest |
Microsoft.Crm.Sdk.Messages.WinOpportunityRequest |
Microsoft.Crm.Sdk.Messages.WinQuoteRequest |
Microsoft.Xrm.Sdk.Messages.AssociateRequest |
Microsoft.Xrm.Sdk.Messages.CanBeReferencedRequest |
Microsoft.Xrm.Sdk.Messages.CanBeReferencingRequest |
Microsoft.Xrm.Sdk.Messages.CanManyToManyRequest |
Microsoft.Xrm.Sdk.Messages.CreateAttributeRequest |
Microsoft.Xrm.Sdk.Messages.CreateEntityRequest |
Microsoft.Xrm.Sdk.Messages.CreateManyToManyRequest |
Microsoft.Xrm.Sdk.Messages.CreateOneToManyRequest |
Microsoft.Xrm.Sdk.Messages.CreateOptionSetRequest |
Microsoft.Xrm.Sdk.Messages.CreateRequest |
Microsoft.Xrm.Sdk.Messages.DeleteAttributeRequest |
Microsoft.Xrm.Sdk.Messages.DeleteEntityRequest |
Microsoft.Xrm.Sdk.Messages.DeleteOptionSetRequest |
Microsoft.Xrm.Sdk.Messages.DeleteOptionValueRequest |
Microsoft.Xrm.Sdk.Messages.DeleteRelationshipRequest |
Microsoft.Xrm.Sdk.Messages.DeleteRequest |
Microsoft.Xrm.Sdk.Messages.DisassociateRequest |
Microsoft.Xrm.Sdk.Messages.ExecuteAsyncRequest |
Microsoft.Xrm.Sdk.Messages.ExecuteMultipleRequest |
Microsoft.Xrm.Sdk.Messages.GetValidManyToManyRequest |
Microsoft.Xrm.Sdk.Messages.GetValidReferencedEntitiesRequest |
Microsoft.Xrm.Sdk.Messages.GetValidReferencingEntitiesRequest |
Microsoft.Xrm.Sdk.Messages.InsertOptionValueRequest |
Microsoft.Xrm.Sdk.Messages.InsertStatusValueRequest |
Microsoft.Xrm.Sdk.Messages.IsDataEncryptionActiveRequest |
Microsoft.Xrm.Sdk.Messages.OrderOptionRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveAllEntitiesRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveAllManagedPropertiesRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveAllOptionSetsRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveAttributeRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveDataEncryptionKeyRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveEntityRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveManagedPropertyRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveMetadataChangesRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveMultipleRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveOptionSetRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveRelationshipRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveRequest |
Microsoft.Xrm.Sdk.Messages.RetrieveTimestampRequest |
Microsoft.Xrm.Sdk.Messages.SetDataEncryptionKeyRequest |
Microsoft.Xrm.Sdk.Messages.UpdateAttributeRequest |
Microsoft.Xrm.Sdk.Messages.UpdateEntityRequest |
Microsoft.Xrm.Sdk.Messages.UpdateOptionSetRequest |
Microsoft.Xrm.Sdk.Messages.UpdateOptionValueRequest |
Microsoft.Xrm.Sdk.Messages.UpdateRelationshipRequest |
Microsoft.Xrm.Sdk.Messages.UpdateRequest |
Microsoft.Xrm.Sdk.Messages.UpdateStateValueRequest |

See Also

Reference

OrganizationRequest Class
OrganizationRequest Members
Microsoft.Xrm.Sdk Namespace
OrganizationResponse

Other Resources

Use Messages (Request and Response Classes) with the Execute Method


OrganizationResponse Hierarchy

The following table lists the classes derived from Microsoft.Xrm.Sdk.OrganizationResponse.

Derived Classes

Class | Description
Microsoft.Crm.Sdk.Messages.AddItemCampaignActivityResponse |
Microsoft.Crm.Sdk.Messages.AddItemCampaignResponse |
Microsoft.Crm.Sdk.Messages.AddListMembersListResponse |
Microsoft.Crm.Sdk.Messages.AddMemberListResponse |
Microsoft.Crm.Sdk.Messages.AddMembersTeamResponse |
Microsoft.Crm.Sdk.Messages.AddPrincipalToQueueResponse |
Microsoft.Crm.Sdk.Messages.AddPrivilegesRoleResponse |
Microsoft.Crm.Sdk.Messages.AddProductToKitResponse |
Microsoft.Crm.Sdk.Messages.AddRecurrenceResponse |
Microsoft.Crm.Sdk.Messages.AddSolutionComponentResponse |
Microsoft.Crm.Sdk.Messages.AddSubstituteProductResponse |
Microsoft.Crm.Sdk.Messages.AddToQueueResponse |
Microsoft.Crm.Sdk.Messages.AddUserToRecordTeamResponse |
Microsoft.Crm.Sdk.Messages.ApplyRoutingRuleResponse |
Microsoft.Crm.Sdk.Messages.AssignResponse |
Microsoft.Crm.Sdk.Messages.AssociateEntitiesResponse |
Microsoft.Crm.Sdk.Messages.AutoMapEntityResponse |
Microsoft.Crm.Sdk.Messages.BackgroundSendEmailResponse |
Microsoft.Crm.Sdk.Messages.BookResponse |
Microsoft.Crm.Sdk.Messages.BulkDeleteResponse |
Microsoft.Crm.Sdk.Messages.BulkDetectDuplicatesResponse |
Microsoft.Crm.Sdk.Messages.BulkOperationStatusCloseResponse |
Microsoft.Crm.Sdk.Messages.CalculateActualValueOpportunityResponse |
Microsoft.Crm.Sdk.Messages.CalculatePriceResponse |
Microsoft.Crm.Sdk.Messages.CalculateRollupFieldResponse |
Microsoft.Crm.Sdk.Messages.CalculateTotalTimeIncidentResponse |
Microsoft.Crm.Sdk.Messages.CancelContractResponse |
Microsoft.Crm.Sdk.Messages.CancelSalesOrderResponse |
Microsoft.Crm.Sdk.Messages.CheckIncomingEmailResponse |
Microsoft.Crm.Sdk.Messages.CheckPromoteEmailResponse |
Microsoft.Crm.Sdk.Messages.CleanUpBulkOperationResponse |
Microsoft.Crm.Sdk.Messages.CloneContractResponse |
Microsoft.Crm.Sdk.Messages.CloneProductResponse |
Microsoft.Crm.Sdk.Messages.CloseIncidentResponse |
Microsoft.Crm.Sdk.Messages.CloseQuoteResponse |
Microsoft.Crm.Sdk.Messages.CompoundCreateResponse |
Microsoft.Crm.Sdk.Messages.CompoundUpdateDuplicateDetectionRuleResponse |
Microsoft.Crm.Sdk.Messages.CompoundUpdateResponse |
Microsoft.Crm.Sdk.Messages.ConvertKitToProductResponse |
Microsoft.Crm.Sdk.Messages.ConvertOwnerTeamToAccessTeamResponse |
Microsoft.Crm.Sdk.Messages.ConvertProductToKitResponse |
Microsoft.Crm.Sdk.Messages.ConvertQuoteToSalesOrderResponse |
Microsoft.Crm.Sdk.Messages.ConvertSalesOrderToInvoiceResponse |
Microsoft.Crm.Sdk.Messages.CopyCampaignResponse |
Microsoft.Crm.Sdk.Messages.CopyCampaignResponseResponse |
Microsoft.Crm.Sdk.Messages.CopyDynamicListToStaticResponse |
Microsoft.Crm.Sdk.Messages.CopyMembersListResponse |
Microsoft.Crm.Sdk.Messages.CopySystemFormResponse |
Microsoft.Crm.Sdk.Messages.CreateActivitiesListResponse |
Microsoft.Crm.Sdk.Messages.CreateExceptionResponse |
Microsoft.Crm.Sdk.Messages.CreateInstanceResponse |
Microsoft.Crm.Sdk.Messages.CreateWorkflowFromTemplateResponse |
Microsoft.Crm.Sdk.Messages.DeleteAuditDataResponse |
Microsoft.Crm.Sdk.Messages.DeleteOpenInstancesResponse |
Microsoft.Crm.Sdk.Messages.DeliverIncomingEmailResponse |
Microsoft.Crm.Sdk.Messages.DeliverPromoteEmailResponse |
Microsoft.Crm.Sdk.Messages.DeprovisionLanguageResponse |
Microsoft.Crm.Sdk.Messages.DisassociateEntitiesResponse |
Microsoft.Crm.Sdk.Messages.DistributeCampaignActivityResponse |
Microsoft.Crm.Sdk.Messages.DownloadReportDefinitionResponse |
Microsoft.Crm.Sdk.Messages.ExecuteByIdSavedQueryResponse |
Microsoft.Crm.Sdk.Messages.ExecuteByIdUserQueryResponse |
Microsoft.Crm.Sdk.Messages.ExecuteFetchResponse |
Microsoft.Crm.Sdk.Messages.ExecuteWorkflowResponse |
Microsoft.Crm.Sdk.Messages.ExpandCalendarResponse |
Microsoft.Crm.Sdk.Messages.ExportFieldTranslationResponse |
Microsoft.Crm.Sdk.Messages.ExportMappingsImportMapResponse |
Microsoft.Crm.Sdk.Messages.ExportSolutionResponse |
Microsoft.Crm.Sdk.Messages.ExportTranslationResponse |
Microsoft.Crm.Sdk.Messages.FetchXmlToQueryExpressionResponse |
Microsoft.Crm.Sdk.Messages.FindParentResourceGroupResponse |
Microsoft.Crm.Sdk.Messages.FulfillSalesOrderResponse |
Microsoft.Crm.Sdk.Messages.GenerateInvoiceFromOpportunityResponse |
Microsoft.Crm.Sdk.Messages.GenerateQuoteFromOpportunityResponse |
Microsoft.Crm.Sdk.Messages.GenerateSalesOrderFromOpportunityResponse |
Microsoft.Crm.Sdk.Messages.GenerateSocialProfileResponse |
Microsoft.Crm.Sdk.Messages.GetAllTimeZonesWithDisplayNameResponse |
Microsoft.Crm.Sdk.Messages.GetDecryptionKeyResponse |
Microsoft.Crm.Sdk.Messages.GetDefaultPriceLevelResponse |
Microsoft.Crm.Sdk.Messages.GetDistinctValuesImportFileResponse |
Microsoft.Crm.Sdk.Messages.GetHeaderColumnsImportFileResponse |
Microsoft.Crm.Sdk.Messages.GetInvoiceProductsFromOpportunityResponse |
Microsoft.Crm.Sdk.Messages.GetQuantityDecimalResponse |
Microsoft.Crm.Sdk.Messages.GetQuoteProductsFromOpportunityResponse |
Microsoft.Crm.Sdk.Messages.GetReportHistoryLimitResponse |
Microsoft.Crm.Sdk.Messages.GetSalesOrderProductsFromOpportunityResponse |
Microsoft.Crm.Sdk.Messages.GetTimeZoneCodeByLocalizedNameResponse |
Microsoft.Crm.Sdk.Messages.GetTrackingTokenEmailResponse |
Microsoft.Crm.Sdk.Messages.GrantAccessResponse |
Microsoft.Crm.Sdk.Messages.ImportFieldTranslationResponse |
Microsoft.Crm.Sdk.Messages.ImportMappingsImportMapResponse |
Microsoft.Crm.Sdk.Messages.ImportRecordsImportResponse |
Microsoft.Crm.Sdk.Messages.ImportSolutionResponse |
Microsoft.Crm.Sdk.Messages.ImportTranslationResponse |
Microsoft.Crm.Sdk.Messages.InitializeFromResponse |
Microsoft.Crm.Sdk.Messages.InstallSampleDataResponse |
Microsoft.Crm.Sdk.Messages.InstantiateFiltersResponse |
Microsoft.Crm.Sdk.Messages.InstantiateTemplateResponse |
Microsoft.Crm.Sdk.Messages.IsBackOfficeInstalledResponse |
Microsoft.Crm.Sdk.Messages.IsComponentCustomizableResponse |
Microsoft.Crm.Sdk.Messages.IsValidStateTransitionResponse |
Microsoft.Crm.Sdk.Messages.LocalTimeFromUtcTimeResponse |
Microsoft.Crm.Sdk.Messages.LockInvoicePricingResponse |
Microsoft.Crm.Sdk.Messages.LockSalesOrderPricingResponse |
Microsoft.Crm.Sdk.Messages.LogFailureBulkOperationResponse |
Microsoft.Crm.Sdk.Messages.LogSuccessBulkOperationResponse |
Microsoft.Crm.Sdk.Messages.LoseOpportunityResponse |
Microsoft.Crm.Sdk.Messages.MakeAvailableToOrganizationReportResponse |
Microsoft.Crm.Sdk.Messages.MakeAvailableToOrganizationTemplateResponse |
Microsoft.Crm.Sdk.Messages.MakeUnavailableToOrganizationReportResponse |
Microsoft.Crm.Sdk.Messages.MakeUnavailableToOrganizationTemplateResponse |
Microsoft.Crm.Sdk.Messages.MergeResponse |
Microsoft.Crm.Sdk.Messages.ModifyAccessResponse |
Microsoft.Crm.Sdk.Messages.ParseImportResponse |
Microsoft.Crm.Sdk.Messages.PickFromQueueResponse |
Microsoft.Crm.Sdk.Messages.ProcessInboundEmailResponse |
Microsoft.Crm.Sdk.Messages.ProcessOneMemberBulkOperationResponse |
Microsoft.Crm.Sdk.Messages.PropagateByExpressionResponse |
Microsoft.Crm.Sdk.Messages.ProvisionLanguageResponse |
Microsoft.Crm.Sdk.Messages.PublishAllXmlResponse |
Microsoft.Crm.Sdk.Messages.PublishDuplicateRuleResponse |
Microsoft.Crm.Sdk.Messages.PublishProductHierarchyResponse |
Microsoft.Crm.Sdk.Messages.PublishXmlResponse |
Microsoft.Crm.Sdk.Messages.QualifyLeadResponse |
Microsoft.Crm.Sdk.Messages.QualifyMemberListResponse |
Microsoft.Crm.Sdk.Messages.QueryExpressionToFetchXmlResponse |
Microsoft.Crm.Sdk.Messages.QueryMultipleSchedulesResponse |
Microsoft.Crm.Sdk.Messages.QueryScheduleResponse |
Microsoft.Crm.Sdk.Messages.ReassignObjectsOwnerResponse |
Microsoft.Crm.Sdk.Messages.ReassignObjectsSystemUserResponse |
Microsoft.Crm.Sdk.Messages.RecalculateResponse |
Microsoft.Crm.Sdk.Messages.ReleaseToQueueResponse |
Microsoft.Crm.Sdk.Messages.RemoveFromQueueResponse |
Microsoft.Crm.Sdk.Messages.RemoveItemCampaignActivityResponse |
Microsoft.Crm.Sdk.Messages.RemoveItemCampaignResponse |
Microsoft.Crm.Sdk.Messages.RemoveMemberListResponse |
Microsoft.Crm.Sdk.Messages.RemoveMembersTeamResponse |
Microsoft.Crm.Sdk.Messages.RemoveParentResponse |
Microsoft.Crm.Sdk.Messages.RemovePrivilegeRoleResponse |
Microsoft.Crm.Sdk.Messages.RemoveProductFromKitResponse |
Microsoft.Crm.Sdk.Messages.RemoveRelatedResponse |
Microsoft.Crm.Sdk.Messages.RemoveSolutionComponentResponse |
Microsoft.Crm.Sdk.Messages.RemoveSubstituteProductResponse |
Microsoft.Crm.Sdk.Messages.RemoveUserFromRecordTeamResponse |
Microsoft.Crm.Sdk.Messages.RenewContractResponse |
Microsoft.Crm.Sdk.Messages.RenewEntitlementResponse |
Microsoft.Crm.Sdk.Messages.ReplacePrivilegesRoleResponse |
Microsoft.Crm.Sdk.Messages.RescheduleResponse |
Microsoft.Crm.Sdk.Messages.ResetUserFiltersResponse |
Microsoft.Crm.Sdk.Messages.RetrieveAbsoluteAndSiteCollectionUrlResponse |
Microsoft.Crm.Sdk.Messages.RetrieveAllChildUsersSystemUserResponse |
Microsoft.Crm.Sdk.Messages.RetrieveApplicationRibbonResponse |
Microsoft.Crm.Sdk.Messages.RetrieveAttributeChangeHistoryResponse |
Microsoft.Crm.Sdk.Messages.RetrieveAuditDetailsResponse |
Microsoft.Crm.Sdk.Messages.RetrieveAuditPartitionListResponse |
Microsoft.Crm.Sdk.Messages.RetrieveAvailableLanguagesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveBusinessHierarchyBusinessUnitResponse |
Microsoft.Crm.Sdk.Messages.RetrieveByGroupResourceResponse |
Microsoft.Crm.Sdk.Messages.RetrieveByResourceResourceGroupResponse |
Microsoft.Crm.Sdk.Messages.RetrieveByResourcesServiceResponse |
Microsoft.Crm.Sdk.Messages.RetrieveByTopIncidentProductKbArticleResponse |
Microsoft.Crm.Sdk.Messages.RetrieveByTopIncidentSubjectKbArticleResponse |
Microsoft.Crm.Sdk.Messages.RetrieveCurrentOrganizationResponse |
Microsoft.Crm.Sdk.Messages.RetrieveDependenciesForDeleteResponse |
Microsoft.Crm.Sdk.Messages.RetrieveDependenciesForUninstallResponse |
Microsoft.Crm.Sdk.Messages.RetrieveDependentComponentsResponse |
Microsoft.Crm.Sdk.Messages.RetrieveDeploymentLicenseTypeResponse |
Microsoft.Crm.Sdk.Messages.RetrieveDeprovisionedLanguagesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveDuplicatesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveEntityRibbonResponse |
Microsoft.Crm.Sdk.Messages.RetrieveExchangeRateResponse |
Microsoft.Crm.Sdk.Messages.RetrieveFilteredFormsResponse |
Microsoft.Crm.Sdk.Messages.RetrieveFormattedImportJobResultsResponse |
Microsoft.Crm.Sdk.Messages.RetrieveFormXmlResponse |
Microsoft.Crm.Sdk.Messages.RetrieveInstalledLanguagePacksResponse |
Microsoft.Crm.Sdk.Messages.RetrieveInstalledLanguagePackVersionResponse |
Microsoft.Crm.Sdk.Messages.RetrieveLicenseInfoResponse |
Microsoft.Crm.Sdk.Messages.RetrieveLocLabelsResponse |
Microsoft.Crm.Sdk.Messages.RetrieveMembersBulkOperationResponse |
Microsoft.Crm.Sdk.Messages.RetrieveMembersTeamResponse |
Microsoft.Crm.Sdk.Messages.RetrieveMissingComponentsResponse |
Microsoft.Crm.Sdk.Messages.RetrieveMissingDependenciesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveOrganizationResourcesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveParentGroupsResourceGroupResponse |
Microsoft.Crm.Sdk.Messages.RetrieveParsedDataImportFileResponse |
Microsoft.Crm.Sdk.Messages.RetrievePersonalWallResponse |
Microsoft.Crm.Sdk.Messages.RetrievePrincipalAccessResponse |
Microsoft.Crm.Sdk.Messages.RetrievePrincipalAttributePrivilegesResponse |
Microsoft.Crm.Sdk.Messages.RetrievePrincipalSyncAttributeMappingsResponse |
Microsoft.Crm.Sdk.Messages.RetrievePrivilegeSetResponse |
Microsoft.Crm.Sdk.Messages.RetrieveProductPropertiesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveProvisionedLanguagePackVersionResponse |
Microsoft.Crm.Sdk.Messages.RetrieveProvisionedLanguagesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveRecordChangeHistoryResponse |
Microsoft.Crm.Sdk.Messages.RetrieveRecordWallResponse |
Microsoft.Crm.Sdk.Messages.RetrieveRequiredComponentsResponse |
Microsoft.Crm.Sdk.Messages.RetrieveRolePrivilegesRoleResponse |
Microsoft.Crm.Sdk.Messages.RetrieveSharedPrincipalsAndAccessResponse |
Microsoft.Crm.Sdk.Messages.RetrieveSubGroupsResourceGroupResponse |
Microsoft.Crm.Sdk.Messages.RetrieveSubsidiaryTeamsBusinessUnitResponse |
Microsoft.Crm.Sdk.Messages.RetrieveSubsidiaryUsersBusinessUnitResponse |
Microsoft.Crm.Sdk.Messages.RetrieveTeamPrivilegesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveTeamsSystemUserResponse |
Microsoft.Crm.Sdk.Messages.RetrieveUnpublishedMultipleResponse |
Microsoft.Crm.Sdk.Messages.RetrieveUnpublishedResponse |
Microsoft.Crm.Sdk.Messages.RetrieveUserPrivilegesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveUserQueuesResponse |
Microsoft.Crm.Sdk.Messages.RetrieveUserSettingsSystemUserResponse |
Microsoft.Crm.Sdk.Messages.RetrieveVersionResponse |
Microsoft.Crm.Sdk.Messages.RevertProductResponse |
Microsoft.Crm.Sdk.Messages.ReviseQuoteResponse |
Microsoft.Crm.Sdk.Messages.RevokeAccessResponse |
Microsoft.Crm.Sdk.Messages.RollupResponse |
Microsoft.Crm.Sdk.Messages.RouteToResponse |
Microsoft.Crm.Sdk.Messages.SearchByBodyKbArticleResponse |
Microsoft.Crm.Sdk.Messages.SearchByKeywordsKbArticleResponse |
Microsoft.Crm.Sdk.Messages.SearchByTitleKbArticleResponse |
Microsoft.Crm.Sdk.Messages.SearchResponse |
Microsoft.Crm.Sdk.Messages.SendBulkMailResponse |
Microsoft.Crm.Sdk.Messages.SendEmailFromTemplateResponse |
Microsoft.Crm.Sdk.Messages.SendEmailResponse |
Microsoft.Crm.Sdk.Messages.SendFaxResponse |
Microsoft.Crm.Sdk.Messages.SendTemplateResponse |
Microsoft.Crm.Sdk.Messages.SetBusinessEquipmentResponse |
Microsoft.Crm.Sdk.Messages.SetBusinessSystemUserResponse |
Microsoft.Crm.Sdk.Messages.SetLocLabelsResponse |
Microsoft.Crm.Sdk.Messages.SetParentBusinessUnitResponse |
Microsoft.Crm.Sdk.Messages.SetParentSystemUserResponse |
Microsoft.Crm.Sdk.Messages.SetParentTeamResponse |
Microsoft.Crm.Sdk.Messages.SetRelatedResponse |
Microsoft.Crm.Sdk.Messages.SetReportRelatedResponse |
Microsoft.Crm.Sdk.Messages.SetStateResponse |
Microsoft.Crm.Sdk.Messages.StatusUpdateBulkOperationResponse |
Microsoft.Crm.Sdk.Messages.TransformImportResponse |
Microsoft.Crm.Sdk.Messages.TriggerServiceEndpointCheckResponse |
Microsoft.Crm.Sdk.Messages.UninstallSampleDataResponse |
Microsoft.Crm.Sdk.Messages.UnlockInvoicePricingResponse |
Microsoft.Crm.Sdk.Messages.UnlockSalesOrderPricingResponse |
Microsoft.Crm.Sdk.Messages.UnpublishDuplicateRuleResponse |
Microsoft.Crm.Sdk.Messages.UpdateProductPropertiesResponse |
Microsoft.Crm.Sdk.Messages.UpdateUserSettingsSystemUserResponse |
Microsoft.Crm.Sdk.Messages.UtcTimeFromLocalTimeResponse |
Microsoft.Crm.Sdk.Messages.ValidateRecurrenceRuleResponse |
Microsoft.Crm.Sdk.Messages.ValidateResponse |
Microsoft.Crm.Sdk.Messages.ValidateSavedQueryResponse |
Microsoft.Crm.Sdk.Messages.VerifyProcessStateDataResponse |
Microsoft.Crm.Sdk.Messages.WhoAmIResponse |
Microsoft.Crm.Sdk.Messages.WinOpportunityResponse |
Microsoft.Crm.Sdk.Messages.WinQuoteResponse |
Microsoft.Xrm.Sdk.Messages.AssociateResponse |
Microsoft.Xrm.Sdk.Messages.CanBeReferencedResponse |
Microsoft.Xrm.Sdk.Messages.CanBeReferencingResponse |
Microsoft.Xrm.Sdk.Messages.CanManyToManyResponse |
Microsoft.Xrm.Sdk.Messages.CreateAttributeResponse |
Microsoft.Xrm.Sdk.Messages.CreateEntityResponse |
Microsoft.Xrm.Sdk.Messages.CreateManyToManyResponse |
Microsoft.Xrm.Sdk.Messages.CreateOneToManyResponse |
Microsoft.Xrm.Sdk.Messages.CreateOptionSetResponse |
Microsoft.Xrm.Sdk.Messages.CreateResponse |
Microsoft.Xrm.Sdk.Messages.DeleteAttributeResponse |
Microsoft.Xrm.Sdk.Messages.DeleteEntityResponse |
Microsoft.Xrm.Sdk.Messages.DeleteOptionSetResponse |
Microsoft.Xrm.Sdk.Messages.DeleteOptionValueResponse |
Microsoft.Xrm.Sdk.Messages.DeleteRelationshipResponse |
Microsoft.Xrm.Sdk.Messages.DeleteResponse |
Microsoft.Xrm.Sdk.Messages.DisassociateResponse |
Microsoft.Xrm.Sdk.Messages.ExecuteAsyncResponse |
Microsoft.Xrm.Sdk.Messages.ExecuteMultipleResponse |
Microsoft.Xrm.Sdk.Messages.GetValidManyToManyResponse |
Microsoft.Xrm.Sdk.Messages.GetValidReferencedEntitiesResponse |
Microsoft.Xrm.Sdk.Messages.GetValidReferencingEntitiesResponse |
Microsoft.Xrm.Sdk.Messages.InsertOptionValueResponse |
Microsoft.Xrm.Sdk.Messages.InsertStatusValueResponse |
Microsoft.Xrm.Sdk.Messages.IsDataEncryptionActiveResponse |
Microsoft.Xrm.Sdk.Messages.OrderOptionResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveAllEntitiesResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveAllManagedPropertiesResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveAllOptionSetsResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveAttributeResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveDataEncryptionKeyResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveEntityResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveManagedPropertyResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveMetadataChangesResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveMultipleResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveOptionSetResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveRelationshipResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveResponse |
Microsoft.Xrm.Sdk.Messages.RetrieveTimestampResponse |
Microsoft.Xrm.Sdk.Messages.SetDataEncryptionKeyResponse |
Microsoft.Xrm.Sdk.Messages.UpdateAttributeResponse |
Microsoft.Xrm.Sdk.Messages.UpdateEntityResponse |
Microsoft.Xrm.Sdk.Messages.UpdateOptionSetResponse |
Microsoft.Xrm.Sdk.Messages.UpdateOptionValueResponse |
Microsoft.Xrm.Sdk.Messages.UpdateRelationshipResponse |
Microsoft.Xrm.Sdk.Messages.UpdateResponse |
Microsoft.Xrm.Sdk.Messages.UpdateStateValueResponse |

See Also

Reference

OrganizationResponse Class
OrganizationResponse Members
Microsoft.Xrm.Sdk Namespace
OrganizationRequest

Other Resources

Use Messages (Request and Response Classes) with the Execute Method